Customizing (BC-CUS)

Release 4.6C
Customizing Information

Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Caution Icon" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image" alt="Example Icon" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image" alt="Note Icon" /></td>
<td>Note</td>
</tr>
<tr>
<td><img src="image" alt="Recommendation Icon" /></td>
<td>Recommendation</td>
</tr>
<tr>
<td><img src="image" alt="Syntax Icon" /></td>
<td>Syntax</td>
</tr>
<tr>
<td><img src="image" alt="Tip Icon" /></td>
<td>Tip</td>
</tr>
</tbody>
</table>
Contents

Customizing (BC-CUS) ................................................................................................................................. 6
Customizing Information ................................................................................................................................. 7
Settings in Customizing ................................................................................................................................. 8
Authorizations for Customizing .................................................................................................................... 10
Customizing Clients ....................................................................................................................................... 12
Implementation Guide (IMG) ....................................................................................................................... 14
SAP Reference IMG ...................................................................................................................................... 16
Project IMGs .................................................................................................................................................. 17
Release-specific Implementation Guide ......................................................................................................... 18
   Displaying Release Notes .......................................................................................................................... 19
Displaying the Implementation Guide .......................................................................................................... 21
   IMG Symbols ............................................................................................................................................. 23
   Displaying IMG Activities ....................................................................................................................... 25
   Display BC Sets ...................................................................................................................................... 26
   Other IMG Display Options .................................................................................................................... 27
Using the IMG ............................................................................................................................................... 30
   Printing the Implementation Guide ......................................................................................................... 32
   Changing IMG Activities ........................................................................................................................ 34
   Searching in the IMG .............................................................................................................................. 35
   Logging Customizing Settings ............................................................................................................... 36
   Customizing Object Where-Used List .................................................................................................... 37
   Translate Structure Title ......................................................................................................................... 38
   Enhancing IMGs ..................................................................................................................................... 39
Project Management .................................................................................................................................... 41
Customizing Projects .................................................................................................................................. 42
   Create Project .......................................................................................................................................... 44
      Specify Project Scope ........................................................................................................................... 45
   Display Project IMG ............................................................................................................................. 47
   Change Project IMG ............................................................................................................................... 48
   Delete Project .......................................................................................................................................... 50
Customizing Project Views ............................................................................................................................. 51
   Create Activity Necessity View ............................................................................................................... 52
   Create Manual Selection in Project IMG View ....................................................................................... 53
   Create Release Customizing View ......................................................................................................... 54
   Create Legal Changes View .................................................................................................................. 56
   Create ASAP Work Package View ....................................................................................................... 57
   Edit Project View ................................................................................................................................... 58
Project Team Members .................................................................................................................................... 60
Status Values, Keywords and Documentation Types ................................................................................... 61
Transporting Customizing Settings ............................................................................................................... 63
Transport Customizing Projects .................................................................................................................. 64
Check Project Overlaps ............................................................................................................................... 66
Migration of Customizing Projects ............................................................................................................... 67
Perform projects ............................................................................................................................................ 68
Manage Customizing Work List .................................................................................................................... 69
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defining a Default Project</td>
<td>70</td>
</tr>
<tr>
<td>Performing Customizing Projects</td>
<td>71</td>
</tr>
<tr>
<td>Customizing Settings</td>
<td>72</td>
</tr>
<tr>
<td>Status Information</td>
<td>73</td>
</tr>
<tr>
<td>Status Information with Split Screen</td>
<td>74</td>
</tr>
<tr>
<td>Edit Status Information without Split Screen</td>
<td>75</td>
</tr>
<tr>
<td>Passing on Status Information</td>
<td>76</td>
</tr>
<tr>
<td>Status Information History Function</td>
<td>77</td>
</tr>
<tr>
<td>Pass Status Information to External Project System</td>
<td>78</td>
</tr>
<tr>
<td>Project Documentation</td>
<td>80</td>
</tr>
<tr>
<td>Create Project Documentation with Split Screen</td>
<td>81</td>
</tr>
<tr>
<td>Display/Change Project Documentation with Split Screen</td>
<td>82</td>
</tr>
<tr>
<td>Delete Project Documentation with Split Screen</td>
<td>83</td>
</tr>
<tr>
<td>Create Project Documentation without Split Screen</td>
<td>84</td>
</tr>
<tr>
<td>Display Project Documentation without Split Screen</td>
<td>85</td>
</tr>
<tr>
<td>Change Project Documentation without Split Screen</td>
<td>86</td>
</tr>
<tr>
<td>Delete Project Documentation without Split Screen</td>
<td>87</td>
</tr>
<tr>
<td>Additional SAPscript Editor Functions</td>
<td>88</td>
</tr>
<tr>
<td>Project Analysis</td>
<td>90</td>
</tr>
<tr>
<td>Project Analysis Functions</td>
<td>91</td>
</tr>
<tr>
<td>Analyzing Projects</td>
<td>93</td>
</tr>
<tr>
<td>Editing the Results</td>
<td>94</td>
</tr>
<tr>
<td>Customizing Object Comparison Tools</td>
<td>96</td>
</tr>
<tr>
<td>Table History</td>
<td>97</td>
</tr>
<tr>
<td>IMG Info System</td>
<td>98</td>
</tr>
</tbody>
</table>
Customizing (BC-CUS)

If a company has decided to implement the SAP System, they must adapt the software to meet their individual business requirements. This process of customizing the system can be controlled and accelerated using the AcceleratedSAP [Ext.] method.

To implement the SAP System, the company sets up project teams that are responsible for project planning and project implementation.

The term Customizing refers to the process of system configuration during which the members of the project teams make the required system settings. In the SAP System, Customizing activities are performed through the Implementation Guide (IMG) [Page 14].

Customizing supports the project teams in the following situations:

- Implementing the SAP System
- Enhancing the SAP System
- in release and system upgrades

Customizing provides the following functions:

- ASAP Roadmap as a structure plan for implementing and enhancing the SAP System
- Tools for making and documenting system settings
- Recommendations for system settings
- Customizing projects as a means for controlling the management, editing and analysis processes of the implementation and upgrade projects
- Support for transferring the system settings from the test system into the production system
- Support for transferring the system settings by means of Business Configuration Sets in a group rollout
- Tools for system upgrades and release upgrades
- Preconfigured industry systems

Customizing does not help you to modify standard SAP functions.

The Customizing functions are grouped in the following user roles by user roles:

- **Project Team Members**
  Project team members make system settings and document project progress. To do this, he or she performs project [Page 68] functions.

- **Project administrator**
  Project managers create projects in the R/3 System, determine the project scope and duration, and coordinate the project team members. To do this, he or she performs project management [Page 41] functions.
Customizing Information

The IMG Information pushbutton gives you Customizing news, e.g. information about the current Release, from project performance and project management. To read the information:

1. Double-click on a row or put the cursor on it and choose Select.
2. Choose Back to quit text display.
3. Choose Continue to return to the original screen.
Settings in Customizing

To display and edit functions in Customizing, you can make both user-specific and cross-project settings. These settings are not lost even if you leave the application.

User-specific settings

To make or change user-specific settings, choose Settings → User-specific… in the Customizing menu in perform project or project management mode.

Display with Controls

On the General tab, you can determine if structures and lists are to be displayed with controls. If controls are used, you have a wider variety of display options available than if you use the standard display format without controls.

If you display an IMG structure in a tree control, you can move the additional information column displayed to the right of the structure and change the display width. To do this, drag the marker at the top of the structure to the right.

A major advantage is provided by the tree control display in combination with a split screen. If this function is active, the screen is divided into several areas when you display a Project IMG:

- The left screen area displays the IMG structure.
- The upper right screen area displays status maintenance with several tabs.
- The lower right screen area displays project documentation with a list of document types. If you create project documentation and click on a document type, MS Word or Lotus WordPro is loaded below it.

You can enter the status and the project documentation for the relevant IMG activity while simultaneously being able to resize the individual screen areas with the mouse.

In the standard system, structures and lists are displayed using controls. If you want to disable controls-based display, deselect the following flags on the General tab:

- Structure displ. with Tree Control (with or without split screen)
- Display lists with Grid Control

Additional display options

You can change the following display options on the IMG Structure tab:

- Load project documentation editor at IMG call
  
  When a project IMG is displayed, the text editor is shown at the bottom right-hand corner of the screen. If this function is not selected, the text editor is only shown when you want to create or read project documentation.

- Text Display
  
  You can display IMG documentation in SAPscript or HTML format.

- Display additional information
If you always want to display the project documentation or release note symbol in the IMG structure, set the corresponding checkbox.

- **Additional information**

  You can determine which additional information should be displayed beside the structure in the standard system, for example, the activity requirement level or the country assignment.

You can override these default settings for displaying a specific implementation guide by calling up the IMG (your Project IMG, for example) and choosing *Additional information* (in the Project IMG with split-screen View).

### Cross-Project Settings

To make or change cross-project settings, choose *Utilities → Cross-project settings* in the Customizing menu of the perform project or project management mode.

The following settings apply to all projects and are not user-specific.

- **Mail (Workflow information)**
  
  The person who edits an IMG activity is automatically notified by mail if this activity is in another project.

  See [Check project overlaps](Page 66).

- **Project documentation editor**

  You can use the following project documentation editors:
  
  - SAP SAPscript editor
  - Microsoft Word for Windows or Lotus WordPro PC editors

  The SAPscript editor is the standard default. If you want to use another editor, select it on the *Cross-Customizing* tab.
Authorizations for Customizing

To be able to perform Customizing activities, you need authorizations for:

- **Authorization to perform Customizing projects**
  
  The authorization object S_PROJECT allows you to process Customizing projects, e.g. create, change or display projects, and maintain status information and project documentation.

- **Authorization in project management with cross-project effect**
  
  The authorization object S_PROJECTS allows you to perform activities in the Customizing project management with cross-project effect, e.g. create and change project templates.

- **Authorization for the IMG activities of a Customizing project**
  
  You can assign authorizations for the IMG activities of each Customizing project, or each project view. Create a role for each Customizing project (view) and assign the Customizing project or view to this role. The authorizations to perform all activities in the Customizing project or view are generated in the profile generation.

You can restrict the access of a user to the rows of a table by business organizational units. One possible use would be that a user is only allowed to display and change the contents of a particular work area, e.g. a country or plant, in a table. See [Line-oriented authorization](#).

**Activities**

You must create (at least) two roles to provide all Customizing authorizations, as follows:

- A copy of the roles **Customizing project member** (technical name: SAP_BC_CUS_CUSTOMIZER) or **Customizing project administrator** (technical name: SAP_BC_CUS_ADMIN) delivered by SAP

- A new role to which you can assign a Customizing project or project view

- Possibly a composite role combining these two roles

Copy the Customizing role delivered by SAP in the role maintenance (transaction PFCG). This role should contain the authorization objects S_PROJECT and S_PROJECTS.

Create a new role and assign a Customizing project or project view to it. Choose *Utilities* → *Customizing auth.* from the *Menu* tab.

Choose whether you want to insert IMG activities from a Customizing project or a project view into the role with the *Insert* key.

The transaction codes and other authorization objects required to maintain tables for this Customizing project (view) are determined automatically and imported into the role.

If you have assigned users (resources) to Customizing projects in the project administration, you can copy them into the roles. Choose *User*. The assigned users are copied into the role.

If you have assigned a Customizing project or a project view to a role, this prevents the manual assignment of transactions. Conversely, you cannot use a role to which you have assigned transactions manually to create Customizing authorizations.
See create roles [Ext.] in the role maintenance documentation.
Customizing Clients

Use

Clients are part of the defining technical structure of the SAP System. Each client contains its own master records and set of tables.

Customizing is either client-specific or cross-client, depending on which business data is configured. Cross-client Customizing is valid for all clients in an SAP System.

Functions

When you install the SAP System, the following clients are available:

- Client 000 as SAP reference client
- Client 001 as production preparation client

SAP Reference client (000)

All SAP tables are in the SAP Reference client. Sample entries, which you can change, exist for the tables in which you store your organizational structure.

The SAP Reference client contains the following settings:

- Tables with default values
  These tables are independent of the organization units.
- Examples of the organization units
- No application data, that is, no master data and no movement data
  Do not use this client in production processing.
- A default Customizing setting

Company code 0001 in client 000 contains complete Customizing. Country-specific Customizing (legal and business requirements) of all standard countries is delivered in company code templates XX01 (XX = country indicator).

SAP updates the settings in each new release. As a result, client 000 always has the current status.

For a release upgrade, SAP automatically updates:

- Table contents and table structures
- Programs
- Screens
- Forms
- Online help
- SAP Reference IMG

You can use the SAP reference client to copy default settings into other clients.
You must not make the SAP Reference client productive.

**Production preparation client (001)**

The production preparation client is identical to the SAP Reference client, i.e. you cannot use this client in production processing either. The Customizing settings are made in this client. You customize it into your test environment.

Copy the new or changed table entries which are put in client 000 by SAP during a system or a release upgrade, using Release Customizing.

See also: [Release-specific implementation guide][Page 18]

**Activities**

To set up a client:

Choose *Administration → System Administration → Administration → Client Administration*.

Then:

1. Defining Clients
2. Copying a Source Client
3. Change country-specific default settings

See [Client Copy][Ext.]
Implementation Guide (IMG)

The Implementation Guide (IMG) is the tool which adjusts the SAP System to the requirements of a company. You use the implementation guide to structure and organize the implementation of the SAP System in your company.

Implementation Guide structure

The implementation guide is a hierarchical structure of the application areas in the component hierarchy. It contains all the work steps required for the implementation with documentation.

There are three implementation guide variants:
- SAP Reference IMG
- Project IMGs
- Project view IMGs

The SAP Reference IMG

SAP delivers an Implementation Guide, the SAP Reference IMG, that contains the work steps for all applications as IMG activities in the SAP System.

See SAP Reference IMG [Page 16].

Project IMGs

To reduce the complexity of the configuration process in the SAP Reference IMG, you generally create separate implementation projects. In the implementation projects, you choose only those functions that you need for the processes in your project. You generate separate project IMGs for each implementation project and for release updates.

See Project IMG [Page 17].

Project view IMGs

You can generate views to structure your project activities by selecting attributes by specified criteria. For example, the mandatory activities view contains only those activities that are required.

See Customizing project views [Page 51].

Using the implementation guide

You can use the IMG to:
- Configure R/3 functions in your company in a quick, safe and cost-effective manner
- Adapt standard functions to meet your company requirements
- Manage, edit and analyze implementation or upgrade projects
- Document and monitor implementation phases with a project management tool
- Transfer configuration data automatically from the quality assurance system to the production system to ensure consistency

The implementation project team is led through all required Customizing settings and is given the necessary system configuration documentation for all required steps.
See Using the implementation guide [Page 30].
SAP Reference IMG

In the standard system, SAP delivers the SAP Reference IMG with each R/3 System. The SAP Reference IMG contains the full functionality of all possible Customizing settings across all countries and application components. It is structured hierarchically according to the R/3 component hierarchy. All Customizing activities are assigned to one or more components. You choose the functions that you want to implement in your company from the R/3 application components. This results in individual Customizing projects for implementing the R/3 System in your company.

To display the SAP Reference IMG see Displaying the implementation guide [Page 21].
Project IMGs

Definition

A project IMG is the implementation guide for a Customizing project. It contains all the Customizing activities which are to be performed in the project. You can determine the project scope by countries, components or Customizing activities. A project IMG is based on the SAP Reference IMG, which can, for example be reduced to the project scope by selecting countries and components.

To display the project IMG see Display implementation guide [Page 21].
Release-specific Implementation Guide

A release-specific Implementation Guide is a project view that is generated based on release-specific attributes from a Customizing project [Page 42]. The release-specific Implementation Guide contains all structure nodes from the Project IMG for which release notes exist.

Each release note in which Customizing settings must be made, has a reference to the Implementation Guide. This reference is then used to generate the release-specific Implementation Guide as a project view.

You can generate a release-specific Implementation Guide for different releases (for example, from 4.0X to 4.5x).

In the release-specific Implementation Guide, you work in the same way as in your Project IMG. You can directly display Release notes [Page 19] from the release-specific implementation guide.
Displaying Release Notes

There are several ways to display release notes:

- As a complete list or using the find function
- Using the symbol in an Implementation Guide
- Using a release-specific project view

As a complete list or using the find function

To display a complete list of all release notes for a specific release:

2. To get a complete list of all release notes from Release 4.0, choose Complete list from Rel. 4.0.
   To get a complete list of all release notes prior to Release 4.0, choose Complete list Release 3.0/3.1.

To display release notes using the full text search function:

2. Choose Full text search...
3. Enter one or more search terms and relate them by AND or OR.
4. Choose Find to start the search.

To display release notes using the attribute search function:

2. Choose Attribute search...
3. Select one or several attributes.
4. Choose Continue to start the search.

Using the symbol in an Implementation Guide

You can display release notes either from the SAP Reference IMG or from any Project IMG. To do this:

1. Choose Tools → AcceleratedSAP → Customizing → Edit project or Project management.
2. Choose SAP Reference IMG, or select a project and display the Project IMG.
3. Choose Additional information → Release notes → Show icons.
4. Expand the structure of the Implementation Guide until you see a structure node with release notes assigned.

Using a release-specific project view

To display all structure nodes of an Implementation Guide for which release notes exist for a specific release, create a release-specific project view.

See: Create Release Customizing view [Page 54].
Displaying the Implementation Guide

You can display the Implementation Guide in various forms:

- **As the SAP Reference IMG**
  
  To display the SAP Reference IMG, choose *Tools → AcceleratedSAP → Customizing → Perform project or Project management* in the SAP menu
  
  then
  
  *Goto → Display SAP Reference IMG* or choose the *Display SAP Reference IMG* pushbutton.

- **As a Project IMG**
  
  There are two ways to display a Project IMG:
  
  - From *Perform project [Page 68]*
    
    Select the project you want to display in your Customizing worklist, and choose *Display project* below the list.
  
  - From *project management [Page 41]*
    
    Select the project which you want to display, in the project overview, and choose *Project → Display* or choose *Display Project* below the project overview.
    
    The project management data is displayed on tabs.
    
    Choose *Goto → Project IMG* or the *Display Project IMG* pushbutton.

  
  The screen and the display functions described below differ depending on whether you display the IMG with or without Tree Control. You can change the display type in the *Perform project or Project management* initial screen under *Settings → User-specific*.

  See *Customizing settings [Page 8]*.

Expanding and Collapsing the Hierarchy Structure

**Display IMG without Tree Control:**

A plus sign before a structure node in the hierarchy structure indicates that there are additional structure nodes on lower levels. By clicking the plus sign, you expand all nodes of the next level.

A minus sign before a structure node in the hierarchy structure indicates that all structure nodes on lower levels have been expanded. By clicking the minus sign, you hide all nodes of the lower levels.

**Display IMG with Tree Control:**

The plus and minus signs are replaced by a triangle which points to the right if there are further structure nodes, or down if the structure is already expanded.
Displaying the Implementation Guide

**Text Display**

You can specify whether you want the IMG documentation displayed in SAPscript or HTML format with *Utilities → Text display*. This setting overrides the text display *standard setting* [Page 8].

For more information about displaying the Implementation Guide, see *Additional IMG displays* [Page 27].
 IMG Symbols

The set of symbols depends on whether you display the implementation guide as project IMG or SAP Reference IMG. Project IMGs have more display functions than the SAP Reference IMG.

Symbols in the SAP Reference IMG and Project IMG

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Display IMG activity documentation" /></td>
<td>The IMG documentation contains all the information necessary to carry out the activities, and explains the higher-level functions.</td>
</tr>
<tr>
<td><img src="image" alt="Perform IMG activity" /></td>
<td>Click this symbol to make system settings. This function is only available for work steps that are linked to a transaction, that is, IMG activities.</td>
</tr>
<tr>
<td><img src="image" alt="Display Release Notes" /></td>
<td>Click this symbol to display existing release notes for the structure nodes.</td>
</tr>
</tbody>
</table>

Other project IMG symbols

The project IMG status information and project documentation display and create procedures depend on whether you are using the split screen [Page 8].

Display without split screen:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Display and maintain status information" /></td>
<td>Click this symbol to enter or display activity data, such as project duration and project team members.</td>
</tr>
<tr>
<td><img src="image" alt="Create project documentation" /></td>
<td>Click this symbol to enter project documentation.</td>
</tr>
<tr>
<td><img src="image" alt="Display project documentation" /></td>
<td>Click this symbol to display and change existing project documentation.</td>
</tr>
</tbody>
</table>

Display with split screen:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Display status information" /></td>
<td>Click this symbol to display status information such as project duration and project team members at the top right.</td>
</tr>
<tr>
<td><img src="image" alt="Create project documentation" /></td>
<td>Click this symbol in the Documentation types window (bottom right) to enter project documentation.</td>
</tr>
<tr>
<td><img src="image" alt="Display project documentation" /></td>
<td>Click on this symbol at the bottom right to display and change the text.</td>
</tr>
<tr>
<td><img src="image" alt="Project documentation exists" /></td>
<td>Project documentation exists.</td>
</tr>
<tr>
<td><img src="image" alt="Delete project documentation" /></td>
<td>Click on this symbol at the bottom right to delete the text.</td>
</tr>
</tbody>
</table>
IMG Symbols
Displaying IMG Activities

You can generally only make Customizing settings from within an IMG activity (work step). The structure node is linked to a Customizing transaction through a maintenance object (usually a view).

An IMG activity contains:
- Documentation
- Attributes
- Maintenance object(s)

Procedure

To display an IMG activity with all associated objects:

1. Place your cursor on the text of a work step in the hierarchy structure. IMG activities can be identified by the Perform customizing activity symbol.

2. Choose Edit → IMG Activity → Display.

Result

You can process the IMG activity and its objects.
Display BC Sets

BC Sets contain a range of Customizing settings grouped together that help you to accelerate and simplify the implementation process. If you use BC Sets, you can flag all IMG activities in a BC Set either from a project IMG or from the SAP Reference IMG. You can also display the IMG activities in the BC Set from the implementation guide.

Prerequisites

You have created one or more BC Sets.

Procedure

1. Choose Additional information → Existing BC Sets or the Existing BC Sets pushbutton.
   
   The text BC Set exists appears in the structure next to all IMG activities whose values are in a BC Set.

2. To go to the BC Set, position the cursor on an IMG activity and choose Goto → Display BC Sets for activity or Display BC Sets for activity pushbutton.
   
   The BC Set containing the selected IMG activity is displayed in the BC Set list. To see the values, proceed as described under Using BC Sets [Ext].
Other IMG Display Options

You can display the following information from the hierarchy structure:

**Keys**

Each object in the structure has an identifier, the *key*, which must be unique. You can show keys for the following objects:

- Documents (the document name)
- IMG activities (ID)
- Attribute (ID)
- Maintenance objects (ID)

Choose Additional information → Additional information → Display key or View → Additional information → Display key in the Project IMG with split-screen.

As only the IMG activities contain attributes and maintenance objects as well as documents, only the document names are shown in the structure for higher-level structure nodes.

**Enhancement ID**

The enhancement ID indicates the position in the structure which has been inserted into the total structure as an enhancement.

See IMG enhancement [Ext.].

**Release Notes**

For each function in the IMG that has been changed, added or deleted, SAP creates a release note that is assigned to the structure node concerned.

1. Choose Additional information → Release notes → Show icons.
   
   For each structure node that has a release note assigned, the system displays the *Release note* symbol in the IMG.

2. To display the release notes, click the *Release notes in IMG symbol next to the structure node.*

**Status Information**

You use the status information in the Project IMG to determine:

- The status of the project system settings
- The keywords assigned to this project
- The project team members

**Attributes**

- Activity necessity
Other IMG Display Options

Identifies an IMG activity as a mandatory activity, an optional activity or a non-required activity. If an activity is mandatory, you must make this setting to enable the system to run correctly.

- **Critical Activity**
  Identifies an IMG activity as critical or non-critical. Critical activities require special care because errors in them can have far-reaching consequences.

- **Assignment to the ASAP Roadmap**
  The IMG activity belongs to an ASAP Roadmap work package.

- **Country assignment**
  The IMG activity belongs to a particular country. If no country is displayed, this activity applies to all standard countries.

- **Application Components**
  The IMG activity belongs to an SAP System application component.

**Business Add-In**

You can determine for which IMG activities customer-specific functional enhancements are planned. Business add-ins are in the IMG activity maintenance object.

**Existing BC Sets**

Which IMG activity is in a BC Set.

**See also:** Display BC Sets [Page 26]

**Client-dependence**

The Customizing tables in the IMG activity are client-specific or cross-client. This information comes from the table OBJH, where all Customizing objects are managed.

**Language-dependence**

Which Customizing tables have to be translated.

- **Table is not language-dependent**
  The Customizing tables behind the IMG activity do not need to be translated.

- **Translation using standard translation procedure**
  The Customizing tables behind the IMG activity can be translated using the SAP translation tools.

  Choose Tools → ABAP Workbench → Utilities → Translation → Short/long texts on the initial R/3 System screen (transaction SE63).

This information comes from the table OBJH, where all Customizing objects are managed.

**Transport Type**

Which Customizing tables have a link to the transport system.

- **Manual transport**
Manually transported Customizing tables are tables that do not have a transport link. Changes are not automatically recorded in a change request. You must enter changes in a change request manually.

- **Automatic transport**
  Customizing tables that have a transport link. Changes are automatically recorded in a change request.

- **No transport**
  Changes to the IMG activity Customizing tables are not to be transported.

This information comes from the table OBJH, where all Customizing objects are managed.
Using the IMG

You can perform the following activities in all implementation guides:

**Read IMG documentation**

To read the description of the nodes in the IMG structure, double-click the structure title or click the *Documentation* symbol (for the *IMG activity*) beside the structure title.

**Editing Documents**

- You can change documents in the implementation guide without changing the original. You must have chosen *Display text with SAPscript*.
  1. Click the *Documentation* symbol (for the *IMG activity*) beside the structure title for which you want to change the documentation.
     - The document is displayed in read mode.
  2. Choose *Document* → *Edit* from the menu, or the *Edit* pushbutton.
     - The document is displayed in edit mode.
  3. Make your text changes.
  4. Save the document with *Document* → *Save* → *Active*.
      - Saving creates a new document with the documentation type *Modification*. The original document remains unchanged with documentation type *Original*.
  5. Set the editing status to final version.
     - The *Modification* document is displayed instead of the *Original*.

**Running Customizing Transactions**

To make Customizing settings, click the *Perform IMG activity* symbol beside the structure title. You go to the associated Customizing transaction.

**Enter status information**

You enter activity data when performing projects. See *Status information* [Page 73].

**Create Project Documentation**

You enter project documentation when performing projects.

See:

- *Create project documentation with split screen* [Page 81] or
- *Create project documentation without split screen* [Page 84].

**Printing the Implementation Guide**

You can either print the structure of the entire IMG, or you can print the IMG documentation or the project documentation for individual structure nodes. See *Printing in the IMG* [Page 32].
Positioning the Cursor

Use this function to display the hierarchy structure from the cursor position.

1. Position the cursor on the structure title for which you want to display the hierarchy structure.
2. Choose Edit → Position from the menu, or the Position icon.
Printing the Implementation Guide

You can print the following documentation:

- **The entire hierarchical structure of an IMG**
- **IMG documentation**
  - Entire IMG
  - Parts of the IMG
  - Specific documents
- **Project Documentation**
  - Entire IMG
  - Parts of the IMG
  - Specific documents

The following description requires that you display the IMG with SAPscript.

**Printing Hierarchical Structures**

1. Choose *Implementation guide* → *Print* → *Displayed structure*.
   A screen for print parameters appears.
2. Enter the name of the printer and choose further print parameters if appropriate.
3. Choose *Print*.

**Printing IMG Documentation**

<table>
<thead>
<tr>
<th>Entire IMG</th>
<th>Parts of the IMG</th>
<th>Specific documents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Position your cursor on the top structure node.</td>
<td>1. Position your cursor on the required node within the structure.</td>
<td></td>
</tr>
<tr>
<td>2. Choose <em>Implementation guide</em> → <em>Print</em> → <em>Nodes</em> → <em>With subnodes</em>.</td>
<td>2. Choose <em>Implementation guide</em> → <em>Print</em> → <em>Nodes</em> → <em>With subnodes</em>.</td>
<td>2. Choose <em>Implementation guide</em> → <em>Print</em> → <em>Nodes</em> → <em>Without subnodes</em>.</td>
</tr>
</tbody>
</table>

The system displays the *Print scope* dialog box.

3. Determine the print scope by selecting *Documents*.
4. Choose *Continue*. 
Printing the Implementation Guide

5. Enter the name of the printer and choose further print parameters if appropriate.

6. Choose Print.

Printing the documentation for the entire IMG makes particular sense for Project IMGs. As it so big, you should not print the entire SAP Reference IMG documentation.

**Print Project Documentation**

<table>
<thead>
<tr>
<th>Entire IMG</th>
<th>Parts of the IMG</th>
<th>Specific documents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Position your cursor on the top structure node.</td>
<td>1. Position your cursor on the required node within the structure.</td>
<td></td>
</tr>
</tbody>
</table>

The system displays the Print scope dialog box.

3. Determine the print scope by selecting Project documentation.

4. If you want to print project documentation for a specific documentation type only, enter the desired documentation type.

5. Choose Continue.

The system displays a print parameters dialog box.

6. Enter the name of the printer and choose further print parameters if appropriate.

7. Choose Print.
Changing IMG Activities

You can change the following objects for a specific IMG activity from any IMG:

- Document
- Attributes
- Maintenance object

Procedure

1. Position your cursor on the title of the IMG activity you want to change.
2. Choose Edit → IMG Activity → Change.
3. In the Assigned objects section, choose the Document, Attributes or Maint. objects tab.
4. Choose Change on the tab of the object selected.
5. Make your changes and save them.
Searching in the IMG

Searching for a string
Use Find to search for a character string within the structure titles of an IMG.

1. Choose Find in node texts in an IMG.
2. Enter the character string to be found.
   You can enter only the first letters of the string. You do not need to enter wildcards (*). In addition, if you do this, you may get wrong results.
3. Choose Continue.
   If only one occurrence of the string is found, the structure title found is highlighted in the IMG. If there are several occurrences of the string, they are displayed in a hit list.

Displaying the Hit List
During the search process, the system generates a hit list that is not discarded before you log off the system. The hit list is user-specific.

1. To display this hit list, choose Find in node texts.
2. The system displays the Search node titles dialog box.
3. Choose Display last hit list.
   This pushbutton is displayed only if you have run a search before and the system has generated a hit list.

The system displays another window that lists all terms found in the last search run.

Find Next
To continue searching, choose Find next. The system uses the last hit list generated to find the next occurrence of the string.

Creating a Text Index
To accelerate the search, you can generate a text index. The creation date of the index tells you if a text index has been created before. If the date field is empty, no index has been created before.

To create a text index:
1. Choose Find in node texts.
2. The system displays the Search node titles dialog box.
3. Choose Refresh search text index.
   When a message tells you that the text index was successfully refreshed, the index has been generated. Creation date and time are entered in the section Text index info.
Logging Customizing Settings

Use
The SAP System can automatically log all changes that are made to Customizing tables. To track who made which changes at which time, you can view the change log.

See Logging Customizing objects [Ext.].

Integration
In contrast to the table history [Ext.] that logs changes to all projects, the change log lists all objects of a single IMG activity.

Prerequisites
So that the system automatically logs table changes, you have to set automatic recording for the relevant tables [Ext.].

Activities
1. In the IMG, position your cursor on the IMG activity for which you want to track changes.
2. Choose Goto → Change log from the menu or choose the Change log pushbutton.
3. In the Restrictions section, enter the period you want to evaluate.
4. Choose Program → Execute.
Customizing Object Where-Used List

Use

Customizing projects may overlap. This means that IMG activities may belong to several projects. To check if a specific Customizing object is used in other projects, you can use the Where else used function.

Activities

1. Position your cursor on the IMG activity for which you want to perform the Where else used function.
2. Choose Where else used.
   The system displays a selection list of all projects.
3. Select the project that you want to compare with your project.
4. Choose Choose.
   The system displays an overview of all IMG activities that have the same Customizing object as the IMG activity you selected.
   You can display the IMG structure for each IMG activity listed.
5. Select an IMG activity and choose Choose.
   The IMG activity is highlighted in the IMG structure.
Translate Structure Title

You can translate structure node titles into an SAP System-supported language.

Procedure

1. Position the cursor on a structure node.
2. Choose Utilities → Translate.
3. Enter the source and target language in the following window.

You have logged on to the SAP System in German and want to translate the structure into Spanish. Choose German as source language and Spanish as target language.

You go to translation mode, where all terms to be translated in the IMG structure at the same level are listed.

If the terms to be translated are in the proposal pool, the proposed translation is proposed. You can overwrite the proposal.

4. Translate missing terms.
5. When you have translated all terms, choose Translation → Save.

Result

You can see the translated structure title by logging on to the SAP System in the target language (e.g. Spanish) and calling the translated structure.
Enhancing IMGs

Use
You want to enhance an IMG structure without changing the original structure. As the enhancement is not made in the original system, the IMG structure remains unchanged in the original system even after an Upgrade.

A company has its own implementation guide which it wants to put in the SAP Reference IMG.

An Industry Business Unit (IBU) wants to enhance the implementation guide with its own application areas.

You can only enhance the structure which you are processing with the enhancement transaction. If you go into lower-level structures and change them, they are modified.

Implementation guide enhancement conditions:
- If there are other nodes below the structure node which is to be enhanced, the enhancement node is the last in the sequence.
- If the enhanced structure node is used several times in a hierarchy, the enhancement node is also displayed several times.
- An IMG enhancement can contain any number of nodes.

Prerequisites
At least one IMG structure exists. IMG structures are created with the transaction SIMGH. See Creating an IMG structure [Ext.].

Activities
1. Enter the transaction s_img_extension in the command field.
2. Select the IMG structure which you want to enhance, in the favorites.
3. Choose an existing ID from the enhancement ID possible entries help, by positioning the cursor on an ID and choosing Select, or create a new ID with Create enhancement ID.
4. Choose Enhance structure.
   The IMG structure is displayed.
5. Position the cursor on the node below which you want to insert the structure enhancement.
6. Enter a new node as described in Create an IMG structure [Ext.].
7. Save the IMG structure with Implementation guide → Save.
Enhancing IMGs

**Result**

The IMG structure is enhanced, without changing the structure in the original system. You cannot distinguish between a new node in the enhanced IMG structure and an original structure node.

If the company already has SAP System or Release update implementation project IMGs or project views, they must be regenerated after enhancing the IMG structure.

Regenerate any project IMGs or project views in the project management (SPRO_ADMIN). See *Change project IMG [Page 48]*.
Project Management

SAP System customizing is based on two user roles: project team member and project administrator. Each role has specific areas of responsibility. This structures and organizes R/3 implementation activities. Areas of responsibility:

- **Perform projects**
  
The project team member makes system settings in Customizing projects, and documents the R/3 implementation procedures using status maintenance and project documentation.
  
  To do this, he or she performs project functions.

- **Project Management**
  
The project administrator organizes customizing. The project management responsibilities are:
  - Create customizing projects and project views
  - Define project scope
  - Specify project start and end
  - Assign team members to the project
  - Define project language
  - Define status
  - Define documentation types
  
  In project management.

Go to project management with *Tools* → *AcceleratedSAP* → *Customizing* → *Project management*.

All existing projects are displayed in the project overview.
Customizing Projects

R/3 Systems are implemented by several company project teams which each perform one or more customizing projects.

There are two kinds of customizing projects:

- **R/3 System implementation**
  
  The project leader determines the project scope by selecting the countries and functions which he or she wants to include in the customizing project, from the SAP reference IMG. The result of this selection is the project IMG, a subset of the SAP Reference IMG [Page 16].

- **System and Release Upgrades**
  
  The project leader creates release-specific project views [Page 18] of one or more customizing projects, in the project management. He or she reduces the scope of a customizing project by selecting attributes, and specifies whether the customizing project contains IMG activities for new, changed or corrected functions.

  You can create any number of Project IMGs and any number of views for each Project IMG. Customizing projects should not overlap. If there are minor overlaps, follow the project transport rules.

  See transport control by project [Ext.].

The graphic below shows how projects are generated from the SAP Reference IMG.

The customizing project provides project-specific project documentation, status information and views of the SAP Reference IMG.
Project team members [Page 60] can be assigned to customizing projects or views. The project leader assigns responsibilities in this way, when the projects are created. Projects assigned appear in the customizing work list of the project team members assigned.
Create Project

Prerequisites

To create a Customizing project, you need authorization object S_PROJECT.

Procedure

2. Choose Project → Create.
3. Enter a project name in the Create new project window, and choose Continue.
   The project name is an alphanumeric string of up to 10 characters.
4. Enter a meaningful project description.
5. Enter the following customizing project data in the General data tab:
   - Person responsible
     The person responsible must be in the R/3 System user management. You can change
     the default user name using the possible entries help.
   - Project language
     The project language makes all language-dependent information (project documentation
     and status information) available to all project members, irrespective of their own logon
     language.
   - Plan data
     Planned project start and end dates, and days required.
     When you enter actual data during the project, the remaining resources required are
     calculated and put in the Percentage complete field.
6. Save the project with Customizing project → Save.
Specify Project Scope

You can specify the project scope in one of two ways in the Scope tab:

- by manual selection of nodes in the reference IMG
- by selecting application components and countries

You specify the structure of your project IMG when you specify the project scope by selecting structure nodes. The customizing project only contains the functions that you want to implement in it. It is a subset of the SAP Reference IMG [Page 16].

Procedure

Manual selection of nodes in the reference IMG

You can assign any number of activities at any structure level of the Reference IMG to your Project IMG by manual selection.

Proceed as follows:
1. Choose Specify project scope by manual selection in Reference IMG.
2. Click on Specify scope….
   
   The SAP Reference IMG is displayed in the Select IMG nodes window.
3. Expand the Reference IMG structure and select structure nodes with Select +/-.
   
   You can select a first-level IMG activity or a higher-level node.
4. When you have selected all desired structure nodes, choose Copy selected nodes.
   
   Your selection is saved.
5. Generate your project IMG with Generate project IMG.
   
   You can generate in the background in the Generate project IMG window. If you have already created project views, you can generate them as well. This is the case when you change and regenerate your project IMG.

Select application components and countries

You can assign whole activity areas for specified countries to your project IMG by selecting application components and countries.

Proceed as follows:
1. Choose Specify project scope by selecting application components and countries.
2. Choose Change selection to select components from the component hierarchy.
   
   The component hierarchy is displayed.
3. Position the cursor on a component and choose Select/DeSelect. Expand the hierarchy structure if necessary.
   
   The component and its subcomponents are selected.
4. When you have completed your component selection, choose Continue.
5. Confirm the save changes prompt.
Specify Project Scope

All countries are in the standard project scope. You should select countries if you only want to install the SAP System in certain countries.

1. Choose Select countries for project scope.

   The list of countries is displayed next to the list of selected countries.

2. Select the countries for which you want to create the customizing project.

3. To put countries in the list of selected countries, choose Left-hand page.

4. Save your customizing project.

5. Choose Generate Project IMG.

Result

The Customizing project is generated with the defined project scope. You can then create project views, assign project team members and set default status values, keywords and documentation types.
Display Project IMG

You can display the project IMG to check whether all selected SAP Reference IMG structure nodes are in your customizing project.

Prerequisites

To display the general data of a Customizing project, you need the authorization object S_PROJECT.

Procedure

To display a Project IMG:

1. Choose Tools → AcceleratedSAP → Customizing ### Project management.

   All existing customizing projects are listed.

2. Position the cursor on the Customizing project of which you want to see the scope.

3. Choose Project → Display.

   The project data are displayed in tab cards.

4. Choose Goto → Display project IMG or the Display project IMG pushbutton.

   The Project IMG structure is displayed. You can now work as usual in the Implementation guide [Page 30].

Display Management Data

If you have selected display with control function and split screen (under Settings → User-specific), you can display the following customizing project status information management data:

- Created by/on
- Changed by/on

To do this:

1. Display the Project IMG as described above.

2. Choose Goto → Management data.

Where Else Used

To check whether the IMG activities in your project are also in other projects, choose Other use of object. You can avoid or correct unwanted project overlaps with this function.
Change Project IMG

Prerequisites

<table>
<thead>
<tr>
<th>Scenario A</th>
<th>Scenario B</th>
</tr>
</thead>
<tbody>
<tr>
<td>You have specified the project scope by <strong>manual selection</strong> in the Reference IMG. You want to add or remove structure nodes to your Project IMG.</td>
<td>You have specified the project scope by <strong>selection of application components and countries</strong>. You want to add or remove application components to your project IMG or change the country selection.</td>
</tr>
</tbody>
</table>

Procedure

To change a Project IMG:

<table>
<thead>
<tr>
<th>Scenario A</th>
<th>Scenario B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Choose <strong>Tools</strong> → <strong>AcceleratedSAP</strong> → <strong>Customizing Project management</strong>. All existing customizing projects are listed.</td>
<td>5. Choose <strong>Specify project scope by selecting application components and countries</strong>.</td>
</tr>
<tr>
<td>2. Position the cursor on the Customizing project whose scope you want to change.</td>
<td></td>
</tr>
<tr>
<td>3. Choose <strong>Project</strong> → <strong>Change</strong> or the <strong>Change project symbol</strong> below the project list. The project data are displayed in tab cards. You can change project data.</td>
<td></td>
</tr>
<tr>
<td>4. To change the project scope and project IMG, choose the <strong>Scope</strong> tab.</td>
<td></td>
</tr>
<tr>
<td>5. Choose <strong>Specify project scope by manual selection in Reference IMG</strong>.</td>
<td></td>
</tr>
<tr>
<td>6. Click on <strong>Specify scope</strong>... The structure of your project IMG is displayed. Selected structure nodes are highlighted.</td>
<td>6. To add or remove application components to your project IMG, choose <strong>Change selection</strong> in the <strong>Application component</strong> group box. The structure of your project IMG is displayed. Selected application components are highlighted.</td>
</tr>
</tbody>
</table>
7. To add or remove a structure node to the project IMG, position the cursor on it and choose `Select +/-`.

7. To remove an application component from the project IMG, deselect it with ![select](select.png).

To add an application component to the project IMG, select it with ![select](select.png).

8. When you have made your changes, choose `Copy selected nodes`.

8. Choose `Continue`.

9. Save the changed project data with `Customizing project -> Save`.

9. To change your country selection, choose `Select countries for the project scope` in the `Countries` group box.

10. Generate the changed project IMG with `Generate project IMG`.

10. To put more countries in your project IMG, select them in the list of `Possible Countries`, and put them in the `Selected countries` list with `Copy countries into selection`.

To remove countries from your project IMG, select them in the `Selected countries` list and put them back in the `Possible countries` list with `Delete countries from selection`.

11. Save the changed project data with `Customizing project -> Save`.

12. Generate the changed project IMG with `Generate project IMG`.

Specify whether to generate in the background in the `Generate project IMG` dialog box.

If you had already created project views before your changes, you can generate them at the same time.
Delete Project

   All existing customizing projects are listed.
2. Select the customizing project which you want to delete.
3. Choose *Project → Delete.*
4. Confirm the confirmation prompt.
   The Customizing project is deleted.

   The following information is deleted with the Customizing project:
   - Project Documentation
   - Status Information
   - Project views

   A customizing project cannot be deleted if it is assigned to a transport request. You can close it with *Close CTS project* in the *Transport requests* tab. You must have released all requests in all clients.
Customizing Project Views

Project views structure customizing projects. Project views are based on the Project IMG, which is reduced to a particular "view" by selecting attributes. Project team members [Page 60] can be assigned to a view. The project team members get all project views in their list to which they have been assigned.

Project views are useful:
- in implementation projects
- in release and system upgrades
- for legal changes

You can create project views for your customizing project by the following criteria:
- Activity necessity [Page 52]
- Manual selection in project IMG [Page 53]
- Release Customizing [Page 54]
- Legal changes [Page 56]
- ASAP work package [Page 57]

You can also generate views by project analysis results. See Edit selection result [Page 94].
Create Activity Necessity View

SAP distinguishes between:

- Mandatory activities
- Optional activities
- Not required activities.

Each activity can be **critical** or **uncritical**. Errors in critical customizing activities have far-reaching consequences.

**Mandatory activities**

SAP cannot supply a full set of standard settings for mandatory activities. You must perform these Customizing activities before you can use the SAP System.

**Optional activities**

Optional activity Customizing settings have SAP defaults, but you should check them, and change them if necessary.

**Not required activities**

Not required activities have SAP defaults which are valid for the SAP standard system.

**Prerequisites**

You have generated a [Project IMG [Page 44]].

**Procedure**

1. Choose the **Project views** tab in the project for which you want to create a view.
2. Click on the **Create project view** icon below the list of existing views.
3. Enter a meaningful project view name in the **Create new view** dialog box.
4. Select the **Activity necessity** selection criterion.
5. Choose **Continue** and confirm the following information with **Continue** again.
6. Select the project view attributes.
7. Save the view data with the Save symbol below the attribute selection.
8. Confirm the view IMG generation prompt.

**Result**

The project view IMG is generated. To display the project view IMG, click on the **Display view IMG** pushbutton under the list of existing views.

To assign a generated project view to a project member, choose the **Assign view to users** pushbutton below the list of existing views.
Create **Manual Selection in Project IMG View**

**Use**

With manual selection, you create a project view by selecting individual structure nodes in your project IMG, not by selecting attributes. You determine the view structure node selection criteria yourself.

You may only choose Purchasing if the Customizing project is for the implementation of Materials Management.

**Prerequisites**

You have generated a [Project IMG][Page 44].

**Procedure**

1. Choose the *Project views* tab in the project for which you want to create a view.
2. Click on the *Create project view* icon below the list of existing views.
3. Enter a meaningful project view name in the *Create new view* dialog box.
5. Choose *Continue* and confirm the following statement with *Continue* again.
6. Click on the *Selection* pushbutton in the *Manual selection in Project IMG* box.
   
   The Project IMG is displayed.

7. Expand the Project IMG structure down to the level at which you want to select structure nodes.
8. Position the cursor on a structure node and click on the *Select +/-* pushbutton.
   
   The selected structure node is highlighted.

9. You can select several structure nodes.
10. End your selection by clicking on the *Copy selected nodes* symbol.
11. Save your manual selection with the *Save* symbol below the selection key.
12. Confirm the view IMG generation prompt.

**Result**

The project view IMG is generated. To display the project view IMG, click on the *Display view IMG* pushbutton under the list of existing views.

To assign a generated project view to a project member, choose the *Assign view to users* pushbutton below the list of existing views.
Create Release Customizing View

Create Release Customizing View

You can generate a project view of your project IMG for a specified release range, by release-specific attributes. You should create one or more release projects for the creation of a release-specific implementation guide, for clarity.

There are release-specific project views for:

- **Upgrade customizing activities**
  
  Upgrade Customizing comprises those IMG activities which are necessary to allow functions previously in use to continue to be used after a system or release upgrade. The IMG for upgrade Customizing contains all IMG activities which you must perform to implement changed functionality after a system upgrade.

- **Delta customizing activities**
  
  Delta Customizing includes all Customizing activities which are necessary to enable new functions to be used in the previously used application areas after a system or release upgrade. The IMG for delta Customizing contains all IMG activities which you must perform to implement new functionality after a system upgrade.

See Release-specific implementation guide [Page 18].

Prerequisites

You have generated a Project IMG [Page 44].

Procedure

1. Choose the Project views tab in the project for which you want to create a view.
2. Click on the Create project view icon below the list of existing views.
3. Enter a meaningful project view name in the Create new view dialog box.
4. Select the Release customizing selection criterion.
5. Choose Continue and confirm the following statement with Continue again.
6. Select the Upgrade customizing or Delta customizing radio button.
7. Specify whether you want to perform Release Customizing of the R/3 Standard or an Add-on or New Dimension system.
8. Specify the Upgrade from and to Releases.
9. Save your entries with the Save symbol in the Release Customizing box.
10. Confirm the view IMG generation prompt.

Result

The project view IMG is generated. To display the project view IMG, click on the Display view IMG pushbutton under the list of existing views.

To assign a generated project view to a project member, choose the Assign view to users pushbutton below the list of existing views.
Create Legal Changes View

To enter legal changes in your system, create a project view of all customizing activities which are affected by the changes. Select by release-specific attributes.

Prerequisites
You have generated a Project IMG [Page 44].

Procedure
1. Choose the Project views tab in the project for which you want to create a view.
2. Click on the Create project view icon below the list of existing views.
3. Enter a meaningful project view name in the Create new view dialog box.
4. Select the Legal changes selection criterion.
5. Choose Continue and confirm the following statement with Continue again.
6. Enter a LawKey in the Legal changes list, or choose one from the possible entries help.
7. Save your entries with the Save symbol below the list of Legal changes.
8. Confirm the view IMG generation prompt.

Result
The project view IMG is generated. To display the project view IMG, click on the Display view IMG pushbutton under the list of existing views.

To assign a generated project view to a project member, choose the Assign view to users pushbutton below the list of existing views.
Create ASAP Work Package View

The project configuration phases are roughly structured in ASAP work packages using release-specific attributes.

Prerequisites
You have generated a [Project IMG](Page 44).

Procedure
1. Choose the Project views tab in the project for which you want to create a view.
2. Click on the Create project view icon below the list of existing views.
3. Enter a meaningful project view name in the Create new view dialog box.
4. Select the ASAP Work package selection criterion.
5. Choose Continue and confirm the following statement with Continue again.
6. Choose the ASAP work package by which the project view is to be created, from the possible entries help for the Work package field.
7. Save the view data with the Save symbol below the attribute selection.
8. Confirm the view IMG generation prompt.

Result
The project view IMG is generated. To display the project view IMG, click on the Display view IMG pushbutton under the list of existing views.

To assign a generated project view to a user as project member, choose the Assign view to users pushbutton below the list of existing views.
Edit Project View

Display Project View

   All existing customizing projects are listed.
2. Select a customizing project for which you want to display project views, and choose Project → Display or the Display project pushbutton below the project list.
3. Choose the Project views tab.
   All views created for this Customizing project are displayed in the Existing views list.
4. Select a view from the list.
5. Click on the Display View data pushbutton to show the project view attribute selection.
   Click on the Display View IMG pushbutton to show the project view IMG.

If you have created several project views for one customizing project, you can sort the display sequence alphabetically ascending or descending with the Sort in ascending order and Sort in descending order pushbuttons.

Change Project View

1. Select a customizing project in project management, for which you want to change project views, and choose Project → Change or the Change project pushbutton below the project list.
2. Choose the Project views tab.
   All views created for this Customizing project are displayed in the Existing views list.
3. Select a view from the list.
4. Choose the Change view data pushbutton below the list.
   The view selection criteria are displayed.
5. Make your changes.
6. Save your changes and regenerate the view IMG.

Delete Project View

1. Select a customizing project in project management, for which you want to change project views, and choose Project → Change or the Change project pushbutton below the project list.
2. Choose the Project views tab.
   All views created for this Customizing project are displayed in the Existing views list.
3. Select a view from the list.
4. Choose the Delete project view pushbutton below the list.
5. Confirm the confirmation prompt.'
The project view is deleted.
Project Team Members

The project team member is a member of the Customizing project team. They make Customizing project system settings and document project progress.

Any number of project team members can be assigned to each project. The project administrator makes this assignment in the project management. You can display the team member assignment in the project IMG with Additional information → Status information → Select team members.

You can enter internal or external project team members in the Project team members tab. You can check whether the project team members are in the user management of your SAP System, with the Check against user master record. Team members who are not R/3 users are highlighted in the list.

You can search for a particular team member by user master record data, in the possible entries help.

Assign User

The project administrator can assign either one user, or all employees in the Project team members tab, to a project. The project then appears in the Customizing work list of the team members assigned.

Proceed as follows:

1. To assign your project to one project team member, choose Edit → Assign user or click on the Assign user pushbutton and enter the name of the team member. The system checks whether the specified name is an R/3 user.

2. To assign all team members to your project, choose Edit → Assign all project team members, or click on the Assign all project team members pushbutton. All project team members on the tab are assigned to the current customizing project.
Status Values, Keywords and Documentation Types

Standard status, keyword and documentation type values for a project are all specified in the same way in the project management. They can then be assigned to IMG activities in the project. If no values have yet been assigned to a project, the project administrator can use the project template, which contains project-independent status values, keywords and documentation types.

Status values
Status values give information about the progress of a customizing project or project IMG activities. They are meaningful ten-character codes and short texts.

The following standard status values are delivered:

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>open</td>
</tr>
<tr>
<td>02</td>
<td>in progress</td>
</tr>
<tr>
<td>03</td>
<td>finished</td>
</tr>
<tr>
<td>04</td>
<td>not relevant</td>
</tr>
</tbody>
</table>

Keywords
You can assign meaningful keywords, for which you can search in the project analysis [Page 90], to each project.

Documentation types
The project documentation allows you to document your SAP System implementation or upgrade Customizing projects. You can use the various documentation types as templates to structure your project documentation. You can also create your own documentation types for particular purposes, e.g.

- logs or decisions
- project standards
- conceptual design
- Problem or error messages

Every documentation type has a unique key. There are two types of project documentation:

- **project-specific documentation**
  This documentation type is only valid within the current customizing project and for all other projects which refer to it.

- **cross-project documentation**
  This documentation type is global. It is available for all customizing projects.

Prerequisites
To create or change status values, keywords and documentation types, you need the authorization object `S_PROJECT`; to create or change project templates, you need the authorization object `S_PROJECTS`.
Status Values, Keywords and Documentation Types

To be able to display status values and project documentation which you created up to Release 4.5, run the program `MIGRATE_PROJECT_NEW [Page 67]`, which:

- converts the status information for project use. Specify a customizing project.
- converts the project documentation to a documentation type which you specified.

All status values, keywords and notes (project documentation) from Releases 3.0, 3.1, 4.0 and 4.5 are retained.

Procedure

1. Choose the `Status values, keywords or documentation type` tab.

   There are two scenarios:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Unused status values/Doc. types list or Keyword directory <strong>already contains</strong> default values.</td>
<td>The Unused status values/Doc. types list or Keyword directory <strong>does not contain</strong> default values.</td>
</tr>
<tr>
<td>Select the entries in the list which you want to assign to your customizing project.</td>
<td>Choose Project template. You get the proposal status value, keyword and documentation type lists for the entire customizing project management.</td>
</tr>
<tr>
<td>Assign the selected entries in the list to Project Status values/Keywords/Doc. types with the Assign pushbutton. To remove listed entries from the project, put them back in the list of unused values with Remove.</td>
<td>If the right-hand list Project management status values/Keywords/Doc. types already contains entries, select from among them and copy into the left-hand list Customizing project Status values/Keywords/Doc. types with the Left-hand page pushbutton. If there are no entries in the project template, make entries in the right-hand list and copy them to the left-hand list.</td>
</tr>
<tr>
<td>Save your assignment with Customizing project → Save.</td>
<td>You can create format templates for documentation types from the project template with Goto → Notes template, depending on the text editor used.</td>
</tr>
<tr>
<td></td>
<td>Save your selection with Project template → Save.</td>
</tr>
<tr>
<td></td>
<td>Save your assignment with Customizing project → Save.</td>
</tr>
</tbody>
</table>
Transporting Customizing Settings

All system setting changes are put in project-specific change requests. You can transport the system settings into other SAP Systems with the change requests. The change requests are managed in the Transport Organizer.

There are two types of Customizing change requests:

- **Customizing request**
  
  Customizing requests contain changes to client-dependent tables.

- **Workbench request**
  
  Workbench requests contain changes to client-independent tables.

You can monitor the change requests by project in the project management. The *Transport requests* tab contains the following functions for the current client:

- **Activate CTS functionality**
  
  As prerequisite for creating change requests. When the CTS functionality is active, the pushbutton label changes to *Display CTS project data*. When the CTS project is finished, the pushbutton label changes to *Reactivate CTS functionality.*

- **Assigned CTS requests**
  
  Go to Transport Organizer request overview, where you can create requests for a project.

- **CTS project object list**
  
  The project object list is unchanged. When the customizing project is finished, the complete object list can be exported.

- **CTS project status switch**
  
  Sets the project status switch.

- **End CTS project…**
  
  End your customizing project. You can reactivate it later.

See [transport control by project [Ext.]] for further information about the Change and Transport System (CTS) for customizing projects.
Transport Customizing Projects

You can transport the following Customizing project information between two clients:

- Customizing project header data
- Status Information
- Project documentation assigned to the Customizing project

The project documentation can be transported only if the following conditions apply:

- The project documentation was created in a transportable development class
- The project documentation is not yet in a task.

The information is cross-client, so there is no need to transport it within a system.

Procedure

2. Select the Customizing-project whose header data and status information you want to transport.
3. Choose Project → Transport or the Transport project pushbutton below the project overview.
   - All entries which can be transported are listed in the Transport documents dialog box.
   - You can exclude entries from the transport by selecting the exclude radio button in their rows.
4. Choose Continue.
   - You go to the Get transport request dialog box.
5. Choose Own requests or Create request.
   - **Own requests**
     - All change requests are displayed.
     a. Display the tasks.
     b. Position the cursor on a task.
     c. Choose Continue.
     - The dialog box reappears.
     d. Choose Continue.
     e. Save.
   - **Create request**
     a. Enter a short text and a user name.
     - The change request is created.
     b. Create a task by choosing Continue.
The task is created.

c. Save.

**Result**

Header data, status information and any project documentation is transported from the source system into a target system.
Check Project Overlaps

You can create where-used lists for all IMG activities in a customizing project, in the project management. This tells you whether an IMG activity used in the project is also used in other projects.

You specify whether the where-used list is for all existing customizing projects or only for a specified selection of customizing projects.

The where-used list checks whether customizing objects in the current project are used more than once. If customizing objects appear in several projects, the person responsible for the project is informed by Mail.

This check function helps you to avoid customizing project overlaps.

Activities

You can enter the name of a user who is to be informed about project overlaps in the Workflow notification box in the Cross reference tab.

You must select the Mail function (Workflow notification) radio button under Settings → Project-independent… in the project management to activate the mail function. You can deactivate the where-used list for a specified project by selecting the Deactivate where-used list radio button in the Cross-reference tab.
Migration of Customizing Projects

To migrate customizing projects from older systems into the current system:

1. Choose System → Services → Reporting.
2. Enter the program name MIGRATE_PROJECT_NEW.
3. Choose Program → Execute.
4. Enter the project number of the old Customizing project which you want to copy into the current system.
5. Choose Program → Execute.
   - The application component hierarchy is displayed in a window.
6. Select the application component which is to contain the new customizing project.
7. Choose Continue.
   - The project IMG for the new customizing project is generated.

Result

The complete contents of a Customizing project from a Release 3.0, 3.1, 4.0 or 4.5 R/3 System are copied into a Release 4.6 customizing project.
Perform projects

SAP System Customizing is based on two user roles: project team member and project administrator. Each role has specific areas of responsibility. This structures and organizes SAP System implementation activities. Areas of responsibility:

- **Project Management**
  
  The project administrator organizes customizing.
  
  To do this, he or she performs project management [Page 41] functions.

- **Perform projects**
  
  The project team member makes system settings in Customizing projects, and maintains the SAP System implementation status and project documentation.

  This is done with the Perform project function.

Go to the Perform project functions with Tools → AcceleratedSAP → Customizing → Perform projects.
Manage Customizing Work List

When you call the Customizing project, you get a list of the projects and project views which the project administrator has assigned to you in the project management. This is your personal Customizing work list. If no projects are assigned to you, your Customizing work list is empty. In this case, you must first put projects or project views in your work list before you can manage them.

Insert Projects
To put projects or project views in your customizing work list:
1. Click on the *Put in work list* pushbutton below the customizing project list.
   
   A list of all existing customizing projects and project views is displayed.
2. Select the projects or project views which you want to put in your personal work list.
3. Click on the *Copy* pushbutton.

   The selected projects and project views are displayed in your Customizing work list.

Remove Several Projects
To remove several projects or project views from your Customizing work list:
1. Click on the *Manage work list* pushbutton below the customizing project list.
2. A list of all existing Customizing projects and project views in your work list is displayed.
3. Select the projects which you want to remove from your work list.
4. Remove the selected projects or project views by clicking on the *Cut out selected favorites* or *Delete selected favorites* pushbutton.

   The selected projects or project views are only removed from your personal work list, they are not deleted from the project management.

Remove Individual Projects
To remove individual projects or project views from your Customizing work list:
1. Select the project which you want to remove from your work list, in your Customizing work list.
2. Click on the *Remove from work list* pushbutton below the Customizing project list.

   The selected project or project view is removed from your personal work list. You can reinsert it at any time.
Defining a Default Project

Declare a customizing project to be your default project if:

- you usually work in this project
- you want to skip the initial screen with the Customizing work list when you work in the project
- you want to go straight to the project IMG of this project.

You can make a project view your default view in the same way.

Procedure

2. Select the project or project view which you want to define as your default project, in your customizing work list.
3. Choose Edit → Default project/view → Define.
   The selected customizing project or view is defined as default project.

The next time that you call a project, the standard project IMG is displayed.

Resetting your Default Project

1. To define another customizing project as default project, or to navigate in the project overview, choose Goto → Back or the Back pushbutton.
2. Choose Edit → Default project/view → Reset.
   The next time you call a project your customizing work list appears.
Performing Customizing Projects

Configuring an SAP System involves various activities and work steps:

- Project team members make Customizing settings according to Customizing projects or project views. They work through the project IMG.
- They document the project status at each work step in the status information. You can name the team members and control the percentage completion.
- In the project documentation you describe the project performance, make notes about your configuration procedure and you can explain the table value settings made.

Activities

2. Select the project you want to perform in your Customizing work list, and choose the Display project pushbutton below the project list.

You can display and perform a Customizing project in one of two ways:

- With split screen
  If you selected user-specific settings [Page 8] with tree control and split screen, you can process the project IMG and the status information and project documentation on one screen. This setting lets you record the project progress and write configuration notes at the same time.

- Without split screen
  If you selected user-specific settings without split screen, the project IMG is displayed. You can go to the status information or project documentation.

The customizing project procedure depends on the setting.
Customizing Settings

The project member makes and documents Customizing settings according to a project IMG which contains all IMG activities which are relevant to the project.

Customizing settings are table entries which can be made with IMG activities. A transaction which is linked to the Customizing object goes from the IMG activities to the tables.

The Customizing object is a view, a view cluster or an individual transaction, depending on the IMG activity. The transaction calls the correct table, view or view cluster. The Customizing object contains information about client-dependence, transport, translation-relevance, etc.

See also View-led Customizing transaction [Ext.] and View Cluster transaction [Ext.].

Customizing deals with all the tables which are needed to adjust the SAP System to company-specific procedures.

Activities

1. To see the transaction and Customizing object in an IMG activity, position the cursor on the IMG activity in the project IMG and choose Edit → IMG activity → Display.
   - The Maintenance objects tab contains the information.

2. To make Customizing settings, click on the IMG activity symbol to the left of the IMG activity structure title in the project IMG.
   - The IMG documentation contains the technical and business details which you need to make the settings.
Status Information

The status information in the Implementation Guide helps you control project flow. It refers to both IMG documents and customizing projects.

It is always project-specific.

SAP provides the following status information:

- **Status**
  
  SAP delivers status values in the standard. You can add your own status values.

- **Percentage complete, planned and actual data**
  
  The percentage complete is calculated from actual and remaining effort. You can enter planned and actual data for the start and end of a project.

- **Project team members**
  
  You can assign internal and external employees or employee groups to a work step.

- **Keywords**
  
  You can define keywords as project analysis search criteria.

- **Memo**
  
  You can make comments about the project.
  
  For example to explain the project status.

All status information changes are logged. For every change, the SAP System generates a change document containing the following information:

- Change date
- Name of the person who made the change
- Old and new field contents

You can display these changes with History [Page 77].

The way in which the status information is handled depends on the display function which you chose.

If you display the Control function with split-screen, see Editing status information with split-screen [Page 74].

If split screen is not set, see Editing status information without split-screen [Page 75].
Status Information with Split Screen

To document the project status of individual work steps in the customizing project, choose Tools → AcceleratedSAP → Customizing → Projects.

Prerequisites

The control function with split screen is active.

Choose Settings → User-specific.... The Structure display with Tree control and Split screen radio buttons in the General tab are set.

You can only assign the status values, project members and keywords which are in a proposal pool in project management.

Procedure

1. Select the project whose status information you want to save, in your Customizing work list, and choose the Display project pushbutton below the project list.
   The Project IMG is displayed at the left-hand side of the screen, the status information at the top right, and below that the project documentation types.

2. To create status information for structure nodes, click on the Status information symbol in the structure next to the structure title.

3. Enter the status in the top right-hand part of the screen.
   The status values [Page 61] must have been maintained in the project management.
   a. You can choose one of the existing status values in the possible entries help.
   b. Put the cursor on a structure node and choose Copy.

4. Enter the planned and actual data in the General tab.
   Enter the date of the planned and actual project begin under Begin and the date of the planned and actual project end under End. The date format is: DD.MM.YYYY.
   The remaining time is calculated when you enter the planned and actual resource use in days.

5. Assign team members
   You can assign team members or groups of team members to work steps which were previously created in project management. Select the name of a team member under Possible team members and choose Assign.

6. Assign keywords to structure nodes as selection criteria.
   The keywords [Page 61] must have been created previously in the project management.

7. You can enter a comment
   You can create a supplementary project note in the Memo tab.

8. Save your entries with Activity data → Save.
Edit Status Information without Split Screen

To document the project status of individual structure nodes in the customizing project, choose Tools → AcceleratedSAP → Customizing → Projects.

Prerequisites

The split screen control function under Settings → User-specific… is not active.

You can only assign the status values, project members and keywords which are in a proposal pool in project management.

Procedure

4. Select the project for which you want to record status information in your Customizing work list, and choose the Display project pushbutton below the project list.
   
The Project IMG is displayed.

5. To create status information for structure nodes, click on the Status information symbol in the structure next to the structure title.

6. Enter the status
   
The status values [Page 61] must have been maintained in the project management.
   
c. You can choose from the existing status values in the possible entries help.
   
d. Put the cursor on a structure node and choose Copy.

4. Enter the planned and actual data in the General tab.
   
Enter the date of the planned and actual project begin under Begin and the date of the planned and actual project end under End. The date format is: DD.MM.YYYY.
   
The remaining time is calculated when you enter the planned and actual resource use in days.

5. Assign team members
   
   You can assign team members [Page 60] or groups of team members which were previously created in project management. Select the name of a team member under Possible team members and choose Assign.

6. Assign keywords
   
   The keywords [Page 61] must have been created previously in the project management.

7. You can enter a comment
   
   You can create a supplementary project note in the Memo tab.

8. Save your entries with Activity data → Save.

9. Choose Goto → Back to return to the Project IMG.
Passing on Status Information

You can pass on the following project IMG status information, i.e. pass the status values of a node to all its lower level structure nodes:

- Status
- Plan data
- Project team members
- Keywords

Prerequisites
Status information is maintained for a structure node in the project IMG.

Procedure
1. Display your Project IMG.
2. Enter the required status information.
3. Choose Activity data → Pass on.
4. Choose the values to be passed on. Select the radio buttons for the status values, if required.
5. Choose Continue.

The status values are passed on to all lower-level structure nodes.
Status Information History Function

Every change in activity data is recorded in a change document. To display these changes:

1. Display the status information in the project IMG, with the Status information symbol next to the structure node.

2. Choose Goto → History.
   - You can see the history of the current client or another.
   - The change document is displayed. The change data comprises:
     - Client
     - Name of the person who made the change
     - Change date and time
     - Changed contents: new value and old value

3. You can print the history with the Print pushbutton below the list.
Pass Status Information to External Project System

You can pass the status information to, or get it from, an external project system, e.g. Microsoft Project.

Prerequisites

Prerequisites:
- You have opened the File Manager.
- You have an external project system, e.g. Microsoft Project from Version 3.0
- You have created a table in the external project system with fields for the relevant activity data.

Procedure

Pass Status Information to an External Project System

1. Choose System → Services → Reporting.
2. Enter program name SAPMSIGP.
3. Choose Program → Execute.
4. Enter the project number of the customizing project which you want to pass.
5. Choose Program → Execute.
6. Choose Download.
7. Enter the name of the file and the path.
8. Choose Continue.
9. Use the ALT + TAB key combination to select the File Manager.
10. Position the cursor on the MPX file which you have just created by means of Download.
   The external project system is called.
12. Open the MPX file.
   Your file is displayed. You can edit the values.

Get Status Information Data from an External Project System

1. Edit the table with the activity data which is assigned to the required customizing project, in the external project system.
2. Save this table as an MPX file.
3. Log on to the SAP System.
5. Enter program name SAPMSIGP.
6. Choose Program → Execute.
7. Enter the project number of the customizing project which you want to get.
8. Choose *Program → Execute*.
9. Choose *Upload*.
10. Enter the name of the file and the path.
11. Choose *Continue*.

   The values from your table are transferred into the activity data of the Customizing project selected.

   ![Warning Symbol]

   If you want to transfer data from MS Project, you must **not** change the structure of the IMG.
Project Documentation

Use

You can document the configuration steps directly in the Customizing project during system configuration. You can, for example, record who made which Customizing settings and why. The project documentation gives you an overview for subsequent changes to business process configurations or project team members.

SAP provides various documentation types as text templates to structure your documentation, in the standard. You can also create other documentation types, which you can use in Perform projects, in Project management. Documentation types can be global or project-specific, i.e. they may be valid for all project IMGs or only one.

Prerequisites

At least one documentation type [Page 61] must have been defined as a template in Project management before you can create project documentation.

Activities

Project documentation is created in various ways, depending on your settings.

If you display with Tree Control and split screen, see Create project documentation with split screen [Page 81].

If you display without split screen, see Create project documentation without split screen [Page 84].
Create Project Documentation with Split Screen

Prerequisites
The control function with split screen is active. Choose Settings → User-specific.... The Structure display with Tree control and Split screen radio buttons in the General tab are set.

Procedure
1. Select the project you want to document in your customizing work list, and choose the Display project pushbutton below the project list.
   The Project IMG is displayed at the left-hand side of the screen, the status information at the top right, and below that the project documentation types.

2. To create project documentation, expand the Project IMG structure to the desired structure node.

3. Click on Status information next to the structure title.
   The structure node status information is shown at the top right.

4. Click on the Create documentation icon in the desired documentation type at the bottom right.
   The text editor is displayed.

5. Create your project documentation and save your document.
   The project documentation is saved as a raw version.

6. To save the project documentation in active form, choose Document → Save → In active version.

   If you want to transport your project documentation into another system, it must be Active. This rule only applies to the SAPscript text editor.

7. Enter the development class in the Create object catalog entry dialog box.
   The document is put in a transport request.

8. Choose Goto → Back to return to the Project IMG.
   A symbol next to the structure title in the project IMG indicates the presence of documentation where you created a text. The Create documentation symbol at the bottom right of the Documentation types window changes to Change documentation. Another symbol to delete the project documentation is also displayed.
Display/Change Project Documentation with Split Screen

**Prerequisites**

Existing project documentation is indicated by the icon in the project IMG.

You have selected split screen display in the user-specific settings. Choose Settings → User-specific…. Select Split screen in the General tab.

**Procedure**

1. Go to the project IMG structure node. Click on the status information symbol next to a structure node.
   
   The status information and documentation type display in the right-hand pane is refreshed.

2. Choose the documentation type of the existing project documentation which you want to read or change.

3. Click on the Change project documentation symbol to the left of the documentation type to display or change the documentation.

   The project documentation is displayed in the default editor in change mode.

4. Change and save the text.

5. Back goes back to the project IMG display.
Delete Project Documentation with Split Screen

Prerequisites

Existing project documentation is indicated by the symbol in the project IMG.

You have selected split screen display in the user-specific settings. Choose Settings → User-specific…. Select Split screen in the General tab.

Procedure

1. Go to the project IMG structure node. Click on the status information symbol next to a structure node.
   
   The status information and documentation type display in the right-hand pane is refreshed.

2. Choose the documentation type of the existing project documentation which you want to delete.

3. Click on the Delete project documentation symbol to the left of the documentation type.

4. Confirm the documentation deletion confirmation prompt.
   
   The project documentation for the structure node is deleted.

   If you logged on in the project language, all existing translations of the project documentation are also deleted.

   If you specified a translation language, only this translation is deleted.
Create Project Documentation without Split Screen

Prerequisites
The control function with split screen is inactive. Choose Settings → User-specific…. Split screen is not selected in the General tab.

Procedure
1. Select the project you want to document in your customizing work list, and choose the Display project pushbutton below the project list.
   The Project IMG is displayed.
2. To create project documentation, expand the Project IMG structure to the desired structure node.
3. Click on the (project documentation) symbol next to the structure title.
   A selection of the existing documentation types is displayed.
4. Click on the symbol next to the desired documentation type.
   The text editor setup appears.
5. Create your project documentation and save your document.
   The project documentation is saved as a raw version.
7. To save the project documentation in active form, choose Document → Save → In active version.
   If you want to transport your project documentation into another system, it must be Active. This rule only applies to the SAPscript text editor.
9. Enter the development class in the Create object catalog entry dialog box.
   The document is put in a transport request.
8. Goto → Back goes back to the documentation type overview.
   A symbol where you created a text indicates the presence of documentation. Another symbol to delete the project documentation is also displayed.
9. Continue goes back to the project IMG structure.
Display Project Documentation without Split Screen

Prerequisites

Existing project documentation is indicated by the icon in the project IMG.

You have deselected the split screen display in the user-specific settings. Choose Settings → User-specific…. Split screen is not selected in the General tab.

Procedure

1. Expand the structure of the project IMG to the structure title for which you want to read the project documentation.

2. Click on the project documentation symbol next to the structure title.

   The documentation types are listed in a new window.

3. Choose the documentation type of the existing project documentation which you want to read.

4. Click on the symbol to the left of the documentation type to display the documentation.

   The project documentation is displayed in the default editor in display mode.

5. Back goes back to the documentation type overview.
Change Project Documentation without Split Screen

Prerequisites

Existing project documentation is indicated by the icon in the project IMG.

You have deselected the split screen display in the user-specific settings. Choose Settings → User-specific…. Split screen is not selected in the General tab.

Procedure

1. Expand the structure of the project IMG to the structure title for which you want to change the project documentation.
2. Click on the (Project documentation exists) symbol.
   The documentation types are listed in a new window.
3. Choose the documentation type of the project documentation which you want to change.
4. Click on the icon to change the documentation.
   The project documentation is displayed in the chosen editor in change mode.
5. Make your text changes.
6. Save your changes.
7. Specify whether your changes are translation-relevant.
   Changes which must also be made in translated versions are translation-relevant.
   Minor text corrections, e.g. syntax errors are not translation-relevant.
8. Goto → Back goes back to the documentation type selection.
9. Continue goes back to the Project IMG structure.
Delete Project Documentation without Split Screen

Prerequisites

Existing project documentation is indicated by the icon in the project IMG.

You have deselected the split screen display in the user-specific settings. Choose Settings → User-specific…. Split screen is not selected in the General tab.

Procedure

1. Expand the structure of the project IMG to the structure node for which you want to delete the project documentation.

2. Click on the (Project documentation exists) symbol.

   A list of documentation types is displayed.

3. Click on the Delete symbol next to the documentation type.

4. Confirm the documentation deletion confirmation prompt.

   The project documentation for the structure node is deleted.

   If you logged on in the project language, all existing translations of the project documentation are also deleted.

   If you specified a translation language, only this translation is deleted.
Additional SAPscript Editor Functions

Display Document information

1. Choose Extras → Information → Document from the text editor.
   The following information is displayed:
   - Language
   - Documentation type
   - Saved version
   - Current version
   - Original language
   - Development class
   - Creator and last changer with dates
   - Transport object
   - Original system

2. Choose Extras → Information → Setting from the text editor.
   The following information is displayed:
   - Processing type
   - Documentation type
   - Language
   - Document class
   - Document name (GUID)

Upload and Download Documentation

You can edit text written in SAPscript in a word processing system on a PC.
You can similarly copy, for example WORD texts, into your project documentation in SAPscript.
To down load data from SAPscript:

1. Open the document whose data you want to pass to a text processing system, in SAPscript in editing mode.

2. Choose Document → Download.

3. Choose the data format.
   One of: RTF, ASCII, ITF and HTML.

4. Choose Continue.

5. Enter the path and complete file name (with extension) under which the file is to be saved.

6. Choose Continue.
   The file is copied to the specified directory in the specified format.
See also Converting SAPscript texts [Ext.].
Project Analysis

You can enter status information for each Customizing project. Project analysis is based on status information. The more detailed status information you enter, the more project analysis options you have. You can analyze a single project, a project view or several projects simultaneously.

The project analysis and analysis results display options are very flexible. You can use selection criteria to restrict the scope of the analysis. You can also choose how the results of the analysis are presented.

SAP provides the following analyses:

- **Project information**
  - Analyzing activity data and all documentation types

- **Progress control**
  - For example, by linking status information (for example, project team members and a given status) or by aggregating the project information

- **Analysis scope for one or several Customizing projects**
  - Analysis is always based on the Customizing project.

- **General analyses**
  - Analyses for a specific day, for example

When you access project analysis, your standard project is the default. You can also define your own standard analyses and save them as variants.

You can also maintain status information and the project documentation directly from project analysis.

**Accessing Project Analysis**

To access project analysis:

1. Choose **Tools → Accelerated SAP → Customizing → Perform project or Project management.**

2. Choose **Goto → Project analysis** in the Customizing screen, or the **Project analysis** pushbutton.
Project Analysis Functions

Project analysis is based on the status information that you can enter for each activity in the Customizing project. We use the term "activities" here, although you can also store and analyze status information for project IMG structure nodes.

You can analyze data for a single project or for several projects, depending on the scope of your project or the purpose of your analysis.

You can use the following criteria for analyzing single or multiple projects:

<table>
<thead>
<tr>
<th>General project data</th>
<th>IMG structure node text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resources</td>
<td>Project manager</td>
</tr>
<tr>
<td></td>
<td>Project team members</td>
</tr>
<tr>
<td>Keywords</td>
<td>Keywords</td>
</tr>
<tr>
<td>Status</td>
<td>Status</td>
</tr>
<tr>
<td></td>
<td>Percentage complete</td>
</tr>
<tr>
<td>Deadlines</td>
<td>Planned start</td>
</tr>
<tr>
<td></td>
<td>Planned end</td>
</tr>
<tr>
<td></td>
<td>Project start</td>
</tr>
<tr>
<td></td>
<td>Project end</td>
</tr>
<tr>
<td>Resources</td>
<td>Planned resources</td>
</tr>
<tr>
<td></td>
<td>Current resources</td>
</tr>
<tr>
<td></td>
<td>Remaining resources</td>
</tr>
<tr>
<td>Documentation</td>
<td>Documentation types</td>
</tr>
<tr>
<td>Memo text</td>
<td>Memo</td>
</tr>
<tr>
<td>Management data</td>
<td>Created on</td>
</tr>
<tr>
<td></td>
<td>Created by</td>
</tr>
<tr>
<td></td>
<td>Last change date</td>
</tr>
<tr>
<td></td>
<td>Last changed by</td>
</tr>
</tbody>
</table>

The following project analysis scenarios are possible:

- **Planned activities without actual data**
  
  The system analyzes all activities for which the planned project start falls within the period you specified for *Planned start* and for which no actual activity data yet exists.

  Analysis criteria: *Project number(s), Planned start period, Current resources = initial* [Page 93], *Remaining resources = initial (no values)*

- **Activities not yet completed**
Project Analysis Functions

The system analyzes all activities for which the planned project end falls within the period you specified for Planned end and for which 100% completion has not yet been achieved.

Analysis criteria: Project number(s), Planned end period, Percent complete < 100.

- All activities started

The system analyzes all activities for which the actual project start (from the actual data of the activity data) falls within the period you specified for Project start and for which the actual project end is still open.

Analysis criteria: Project number(s), Project start period, Project end = initial (no value)

- All activities completed

The system analyzes all activities for which the actual project end (from the actual data of the activity data) falls within the analysis period you have specified.

Analysis criteria: Project number(s), Project end period

- Individual analyses

In addition to the above scenarios, you can perform individual analyses and define these as your default analyses. To be able to compare individual values in the analysis result to each other, you can calculate the total for any column you want.

For example, you are implementing several projects and find that the planned resources calculated are incorrect and that you will probably need more time.

To check the relation of the planned resources to the current resources, you analyze all activities that are not yet 100% complete. Afterwards, you calculate the total for the Planned resources, Actual resources and Remaining work columns on the basis of the analysis result.

Analysis criteria: Project number(s), Planned resources, Actual resources, Remaining work, Percent complete < 100.
Analyzing Projects

Prerequisites

To be able to analyze projects, you must have created their master data in the *Perform project* mode.

Procedure

1. Choose *Goto → Project analysis* or the *Project analysis* pushbutton in Perform projects or Project management.
2. Enter the number of the Customizing project that you want to analyze.
   
   You can enter other Customizing projects via the *Multiple selection* symbol to the right of the project number to analyze several projects at the same time.
3. Restrict project analysis by entering your criteria.
   
   You can select by initial value with *Edit → Selection options* from the menu or the *Selection options* pushbutton.

   ![Note icon]

   You want to select all activities that have been started but not yet completed. Enter a project start date and set the project end to its initial value by double-clicking the selection field. The system displays the *Select by Initial Value* dialog box. Choose = *(Single value)* and then *Continue*. Leave the selection field empty.

4. Choose *Execute* to start project analysis.
5. You can save your selection data as a variant to reuse it as your standard analysis later on.
   
   To do this, choose *Goto → Variants → Save as variant*. To display your standard analyses, choose *Goto → Variants → Display*.

   ![Arrow icon]

   For more information on how to use the selection screen, choose *Goto → Selection screen help*.

Result

The analysis results are displayed as a list.

Double-click on a line in the list to work with the project IMG. The selected structure title in the Project IMG is highlighted.

![Arrow icon]

If you change status information after you have performed a project analysis, you must start this analysis again to update the results.


**Editing the Results**

You can change the way the analysis list is presented as follows:

### Defining the Sort Sequence

You can sort the results in any order.

To do this:

1. From the list, choose *Edit → Ascending order or Descending order*, or choose the appropriate symbols. The system displays a list of all fields available.
2. Put fields from the field list in the sort fields list. The field sequence is significant.
   - The top sort field in the *Sort fields* list is the first sort criterion.
3. Choose *Copy*.
   - The analysis list is sorted as defined.

### Setting a Filter

You can restrict the results display. To do this:

1. Select the headers of all columns that you want to filter, in the analysis list.
2. Choose *Edit → Set filter* from the menu, or choose the *Set filter* symbol. On the *Define filter criteria* dialog box, you see all columns that you have selected.
3. Enter a value or a term as your filter criterion.
   - You can specify a restriction interval with the *Multiple selection* symbol. Relational operators are available to assist you.
4. Choose *Continue*.
   - The list is restricted according to your filter criteria.
   - To remove your restriction, choose *Edit → Delete filter*.

### Summing values

You can sum numerical columns.

To do this:

1. Select the headers of all columns that you want to sum, in the analysis list.
2. Choose *Edit → Sum values* from the menu, or the *Sum values* symbol.
   - A new line is appended to the list with the totals of the selected columns.

You can calculate **subtotals** for sorted columns.

To do this:

1. Select the header of a column in the analysis list that contains values that **cannot** be summed, such as the *Project team members* column.
2. Choose *Edit → Subtotal* from the menu, or the *Subtotal* symbol.
The system displays a new line after each change in the column selected that shows the subtotals of the values added up previously.

**Display Variants**

You can save the changed results list display format as a display variant to reuse at a later date.

To do this:

1. Choose Settings → Display Variant → Save from the menu, or the Save display variant pushbutton.
2. Enter a name and a description for your display variant.
3. Set the User-specific checkbox if the display variant is not to be available to other users.
4. Specify whether you also want to save the sort and subtotals criteria in your display variant.
5. Choose Save.

Your settings are saved as a display variant. To reuse this display variant, choose Settings → Display variant → Choose.

**Creating a Project View**

You can create a project view for each project in the results list. To do this:

1. Place your cursor in the results list on a line of the project for which you want to create a project view.
2. Enter the name of the project view.
3. Display project view immediately goes to the project view.

You can use the project view as usual and change it as required.

4. Choose Back to return to the analysis list.
5. If you change the project view, you must rerun your analysis.
Customizing Object Comparison Tools

Use

The following comparison tools help you to trace Customizing changes:

- **Cross-System Viewer**
  The Customizing Cross-System Viewer compares Customizing objects between clients or systems. Each comparison is based on the following selection criteria:
  - Comparison of Customizing objects in IMG activities in a project IMG or the SAP Reference IMG
  - Comparison of Customizing objects in specified components
  - Comparison of Customizing objects in object lists or transport requests
  - Comparison of Customizing objects in a Business Configuration Set

- **Object Comparison**
  The object comparison compares Customizing objects in individual tables or views between clients or systems.

- **Transfer Assistant**
  The Transfer Assistant checks the consistency of client-specific Customizing changes in a system, before the data is transported from the quality assurance system into the production system.

- **Business Configuration Sets**
  Customizing settings can be collected in BC Sets. The Customizing objects in BC Sets can be compared with the original data in a system.

Activities

Choose *Tools → Customizing objects* in perform project or project management.

See [Customizing Cross-System Tools](#).
Table History

Changes to tables or Customizing objects in the SAP System are logged and can be analyzed cross-project.

You can either:

- **List the change logs**
  
  You can choose to analyze Customizing object or table change logs.

- **Compare history and current status**
  
  You can compare the current status of a table with its status at a specified date.

See [Analyze logged Customizing objects [Ext.]](##).

Activities

Choose *Tools* → *Table history* in perform project or project management.
IMG Info System

Use

Use the IMG Info system to check the scope of the IMG activities assigned to a Customizing project or project view.

The Info system has the following options:

- **Comparing the IMG Activities in the SAP Reference IMG with Your Project IMG**
  
  You use this function to check if the SAP Reference IMG is completely covered by the Project IMGs you have generated. In the hierarchy structure, the system marks those IMG activities that have not yet been assigned to a Customizing project.

- **Comparing the IMG Activities in a Project IMG with Activities in Project Views**
  
  You use this function to check if the Project IMG selected is covered by the project views you have created. In the project structure, the system marks those IMG activities that have not yet been assigned to a project view.

- **Repeated Use of Objects**
  
  You use this function to see where the same Customizing object occurs in several activities.

### Activities

<table>
<thead>
<tr>
<th>Comparing the IMG Activities in the SAP Reference IMG with Your Project IMG</th>
<th>Comparing the IMG Activities in a Project IMG with Activities in Project Views</th>
<th>Repeated Use of Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the edit project or project management view, choose Tools → IMG Info system → Compare Reference IMG ↔ Project.</td>
<td>1. From the edit project or project management view, choose Tools → IMG Info system → Project ↔ Views.</td>
<td>1. From the edit project or project management view, choose Tools → IMG Info system → Repeated use of object in project.</td>
</tr>
<tr>
<td>2. Enter the number of the Customizing project that you want to compare to the views.</td>
<td>2. Enter the number of the Customizing project.</td>
<td></td>
</tr>
<tr>
<td>3. Choose Execute.</td>
<td>3. Choose Execute.</td>
<td></td>
</tr>
</tbody>
</table>