Expert Mode

Release 4.6C

SAP
Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Caution Icon]</td>
<td>Caution</td>
</tr>
<tr>
<td>![Example Icon]</td>
<td>Example</td>
</tr>
<tr>
<td>![Note Icon]</td>
<td>Note</td>
</tr>
<tr>
<td>![Recommendation Icon]</td>
<td>Recommendation</td>
</tr>
<tr>
<td>![Syntax Icon]</td>
<td>Syntax</td>
</tr>
<tr>
<td>![Tip Icon]</td>
<td>Tip</td>
</tr>
</tbody>
</table>
Contents

Expert Mode ................................................................................................................................. 12
Organizational Management ........................................................................................................ 13
Org. Plan........................................................................................................................................ 17
  Organizational Object ................................................................................................................ 19
  Positions ..................................................................................................................................... 23
  Work centers ............................................................................................................................. 28
  Tasks .......................................................................................................................................... 30
  Holder ......................................................................................................................................... 33
  Cost Center ................................................................................................................................. 34
Relationships .................................................................................................................................. 35
Infotypes ........................................................................................................................................ 37
  About the Object Infotype (1000) ......................................................................................... 38
  About the Relationship Infotype (1001) ................................................................................ 39
  About the Description Infotype (1002) .................................................................................. 41
  Department/Staff (Infotype 1003) .......................................................................................... 42
  About the Character Infotype (1004) ..................................................................................... 44
  About the Restrictions Infotype (1006) .................................................................................. 46
  Vacancy (Infotype 1007) ......................................................................................................... 47
  Account Assignment Features (Infotype 1008) ................................................................. 49
  About the Health Examinations Infotype (1009) ............................................................. 51
  About the Authorities and Resources Infotype (1010) .................................................. 52
  Work Schedule (Infotype 1011) ............................................................................................ 53
  About the Employee Group/Subgroup Infotype (1013) ................................................. 56
  About the Obsolete Infotype (1014) .................................................................................... 57
  Cost Planning (Infotype 1015) ............................................................................................... 58
  Standard Profiles (Infotype 1016) ....................................................................................... 60
  About the PD Profiles Infotype (1017) ................................................................................ 62
  Cost Distribution (Infotype 1018) .......................................................................................... 64
  Quota Planning (Infotype 1019) ............................................................................................ 66
  About the Site Dependent Info Infotype (1027) ........................................................... 68
  About the Address Infotype (1028) ..................................................................................... 69
  About the Mail Address Infotype (1032) ............................................................................ 71
  About the Shift Group Infotype (1039) .............................................................................. 73
  SAP Organizational Object (Infotype 1208) ................................................................. 75
  General Attribute Maintenance (Infotype 1222) .............................................................. 76
Planning Tools ................................................................................................................................ 77
  Plan Version ............................................................................................................................. 78
  Validity Period ......................................................................................................................... 79
  Time Constraints ..................................................................................................................... 80
  Status ....................................................................................................................................... 82
### Integration with SAP Business Workflow

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role Resolution</td>
<td>86</td>
</tr>
<tr>
<td>Role</td>
<td>88</td>
</tr>
<tr>
<td>Role Container</td>
<td>91</td>
</tr>
<tr>
<td>Role Definition</td>
<td>93</td>
</tr>
<tr>
<td>Define Roles Using Responsibilities</td>
<td>96</td>
</tr>
<tr>
<td>Creating a Container Definition</td>
<td>98</td>
</tr>
<tr>
<td>Creating a Responsibility</td>
<td>100</td>
</tr>
<tr>
<td>Assigning Agents</td>
<td>102</td>
</tr>
<tr>
<td>Defining Roles Using Organizational Data</td>
<td>103</td>
</tr>
<tr>
<td>SAP Organizational Object</td>
<td>105</td>
</tr>
<tr>
<td>Assigning SAP Organizational Objects</td>
<td>107</td>
</tr>
<tr>
<td>Creating Object Assignments</td>
<td>109</td>
</tr>
<tr>
<td>Defining Roles Using Function to Be Executed</td>
<td>122</td>
</tr>
<tr>
<td>Function Module for Role Resolution</td>
<td>124</td>
</tr>
<tr>
<td>Interface of Function Module for Role Resolution</td>
<td>126</td>
</tr>
<tr>
<td>Role to Determine Manager</td>
<td>128</td>
</tr>
<tr>
<td>Role Resolution Using Evaluation Paths</td>
<td>129</td>
</tr>
<tr>
<td>Define Role to Evaluate Evaluation Paths</td>
<td>130</td>
</tr>
<tr>
<td>Define Binding</td>
<td>132</td>
</tr>
<tr>
<td>Role for Determining Organizational Unit of a User</td>
<td>134</td>
</tr>
<tr>
<td>The Cancellation for Role Resolution Without Result Indicator</td>
<td>136</td>
</tr>
<tr>
<td>Selecting Objects from the Organizational Plan</td>
<td>138</td>
</tr>
<tr>
<td>Specify Agent, Recipient, or Administrator by His or Her Role</td>
<td>140</td>
</tr>
</tbody>
</table>

### Integration with Personnel Administration

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activating Integration</td>
<td>142</td>
</tr>
<tr>
<td>Making Initial Settings</td>
<td>143</td>
</tr>
<tr>
<td>Maintaining Tables</td>
<td>144</td>
</tr>
<tr>
<td>Assigning a Person to a Position</td>
<td>145</td>
</tr>
<tr>
<td>Assigning Persons Temporarily</td>
<td>146</td>
</tr>
<tr>
<td>Transferring a Person</td>
<td>147</td>
</tr>
<tr>
<td>Ending a Contract</td>
<td>148</td>
</tr>
<tr>
<td>Changes in Organizational Management</td>
<td>149</td>
</tr>
<tr>
<td>Retrospective Changes</td>
<td>151</td>
</tr>
<tr>
<td>Linking a Person to Several Positions</td>
<td>152</td>
</tr>
<tr>
<td>Temporary Assignment of a Person to a Job</td>
<td>153</td>
</tr>
<tr>
<td>Vacancies</td>
<td>154</td>
</tr>
<tr>
<td>Obsolete Positions</td>
<td>155</td>
</tr>
<tr>
<td>Infotype Record Splits</td>
<td>156</td>
</tr>
<tr>
<td>Processing Blocks</td>
<td>157</td>
</tr>
</tbody>
</table>
Batch Inputs from Personnel Admin. to Org. Management .......................................................... 158
Batch Inputs from Org. Management to Personnel Admin. .......................................................... 159
Editing the Organizational Plan ........................................................................................................ 160
Infotype Maintenance .......................................................................................................................... 162
  Object Manager .............................................................................................................................. 163
    Finding/Selecting Objects .............................................................................................................. 165
    Using Search Variants .................................................................................................................. 166
    Using Search Tools ...................................................................................................................... 167
  Maintaining Organizational Units ................................................................................................... 169
    Creating Organizational Units ..................................................................................................... 170
    Changing Objects ....................................................................................................................... 171
    Displaying Objects ...................................................................................................................... 172
    Copying Objects .......................................................................................................................... 173
    Delimiting Objects ...................................................................................................................... 174
    Deleting Objects ......................................................................................................................... 175
    Changing the Status of Objects .................................................................................................... 176
  Maintaining Jobs ............................................................................................................................. 177
    Creating Jobs ............................................................................................................................... 178
    Changing Objects ....................................................................................................................... 179
    Displaying Objects ...................................................................................................................... 180
    Copying Objects .......................................................................................................................... 181
    Delimiting Objects ...................................................................................................................... 182
    Deleting Objects ......................................................................................................................... 183
    Changing the Status of Objects .................................................................................................... 184
  Maintaining Positions ...................................................................................................................... 185
    Creating Positions ....................................................................................................................... 186
    Changing Objects ....................................................................................................................... 187
    Displaying Objects ...................................................................................................................... 188
    Copying Objects .......................................................................................................................... 189
    Delimiting Objects ...................................................................................................................... 190
    Deleting Objects ......................................................................................................................... 191
    Changing the Status of Objects .................................................................................................... 192
  Maintaining Work Centers ............................................................................................................... 193
    Creating Work Centers ............................................................................................................... 194
    Changing Objects ....................................................................................................................... 195
    Displaying Objects ...................................................................................................................... 196
    Copying Objects .......................................................................................................................... 197
    Delimiting Objects ...................................................................................................................... 198
    Deleting Objects ......................................................................................................................... 199
    Changing the Status of Objects .................................................................................................... 200
  Maintaining Tasks ........................................................................................................................... 201
    Create tasks ................................................................................................................................. 202
    Changing Tasks ............................................................................................................................ 204
    Displaying Tasks .......................................................................................................................... 205
    Copying Tasks .............................................................................................................................. 206
    Deleting Tasks ............................................................................................................................. 207
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delimiting Tasks</td>
<td>208</td>
</tr>
<tr>
<td>Changing the Status of Tasks</td>
<td>209</td>
</tr>
<tr>
<td>General Maintenance</td>
<td>210</td>
</tr>
<tr>
<td>Maintaining Infotype Records for Objects</td>
<td>211</td>
</tr>
<tr>
<td>Creating Infotype Records</td>
<td>212</td>
</tr>
<tr>
<td>Changing Infotype Records</td>
<td>213</td>
</tr>
<tr>
<td>Displaying Infotype Records</td>
<td>214</td>
</tr>
<tr>
<td>Copying Infotype Records</td>
<td>215</td>
</tr>
<tr>
<td>Delimiting Infotype Records</td>
<td>216</td>
</tr>
<tr>
<td>Deleting Infotype Records</td>
<td>217</td>
</tr>
<tr>
<td>Changing the Status of Infotype Records</td>
<td>218</td>
</tr>
<tr>
<td>Maintaining Infotype Records for Tasks</td>
<td>219</td>
</tr>
<tr>
<td>Creating Infotype Records for Tasks</td>
<td>220</td>
</tr>
<tr>
<td>Changing Infotype Records for Tasks</td>
<td>221</td>
</tr>
<tr>
<td>Displaying Infotype Records for Tasks</td>
<td>222</td>
</tr>
<tr>
<td>Copying Infotype Records for Tasks</td>
<td>223</td>
</tr>
<tr>
<td>Delimiting Infotype Records for Tasks</td>
<td>224</td>
</tr>
<tr>
<td>Deleting Infotype Records for Tasks</td>
<td>225</td>
</tr>
<tr>
<td>Changing the Status of Infotype Records for Tasks</td>
<td>226</td>
</tr>
<tr>
<td>Simple Maintenance</td>
<td>228</td>
</tr>
<tr>
<td>Object Manager</td>
<td>229</td>
</tr>
<tr>
<td>Finding/Selecting Objects</td>
<td>230</td>
</tr>
<tr>
<td>Using Search Variants</td>
<td>231</td>
</tr>
<tr>
<td>Using Search Tools</td>
<td>232</td>
</tr>
<tr>
<td>Standard Features</td>
<td>233</td>
</tr>
<tr>
<td>Accessing Simple Maintenance</td>
<td>234</td>
</tr>
<tr>
<td>Working with Screen Areas</td>
<td>235</td>
</tr>
<tr>
<td>Access from Organizational Management</td>
<td>236</td>
</tr>
<tr>
<td>Starting Basic Plan in Create Mode</td>
<td>237</td>
</tr>
<tr>
<td>Starting Basic Organizational Plan in Change Mode</td>
<td>238</td>
</tr>
<tr>
<td>Starting Basic Plan in Display Mode</td>
<td>239</td>
</tr>
<tr>
<td>Selecting a Plan Version</td>
<td>240</td>
</tr>
<tr>
<td>Tree Structure</td>
<td>241</td>
</tr>
<tr>
<td>Expanding the Tree Structure</td>
<td>242</td>
</tr>
<tr>
<td>Compressing the Tree Structure</td>
<td>243</td>
</tr>
<tr>
<td>Printing Tree Structures</td>
<td>244</td>
</tr>
<tr>
<td>Selecting Additional Information</td>
<td>245</td>
</tr>
<tr>
<td>Switching to Infotype Maintenance</td>
<td>246</td>
</tr>
<tr>
<td>Switching to Structural Graphics</td>
<td>247</td>
</tr>
<tr>
<td>Selecting Editing Periods</td>
<td>248</td>
</tr>
<tr>
<td>Switching between Display and Change Mode</td>
<td>249</td>
</tr>
<tr>
<td>Switching Between Simple Maintenance Screens</td>
<td>250</td>
</tr>
<tr>
<td>Searching for Objects</td>
<td>251</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Creating an Organizational Plan</td>
<td>263</td>
</tr>
<tr>
<td>Creating and Editing Organizational Plans</td>
<td>265</td>
</tr>
<tr>
<td>Creating and Editing Organizational Plans</td>
<td></td>
</tr>
<tr>
<td>Creating Root Organizational Units</td>
<td>266</td>
</tr>
<tr>
<td>Creating Organizational Units</td>
<td>267</td>
</tr>
<tr>
<td>Changing Organizational Units</td>
<td>268</td>
</tr>
<tr>
<td>Delimiting Organizational Units</td>
<td>269</td>
</tr>
<tr>
<td>Deleting Organizational Units</td>
<td>270</td>
</tr>
<tr>
<td>Rearranging Organizational Units</td>
<td>271</td>
</tr>
<tr>
<td>Prioritizing Organizational Units</td>
<td>272</td>
</tr>
<tr>
<td>Moving Organizational Units</td>
<td>273</td>
</tr>
<tr>
<td>Delimiting/Moving Subordinate Positions</td>
<td>275</td>
</tr>
<tr>
<td>Deleting/Moving Subordinate Positions</td>
<td>277</td>
</tr>
<tr>
<td>Delimiting Relationships</td>
<td>278</td>
</tr>
<tr>
<td>Deleting Relationships</td>
<td>279</td>
</tr>
<tr>
<td>Assigning Unrelated Organizational Units</td>
<td>280</td>
</tr>
<tr>
<td>Creating and Editing Staff Assignments</td>
<td>281</td>
</tr>
<tr>
<td>Creating and Editing positions</td>
<td>282</td>
</tr>
<tr>
<td>Create jobs</td>
<td>283</td>
</tr>
<tr>
<td>Changing Jobs</td>
<td>284</td>
</tr>
<tr>
<td>Assigning Positions to Jobs</td>
<td>285</td>
</tr>
<tr>
<td>Delimiting Job/Position Assignments</td>
<td>286</td>
</tr>
<tr>
<td>Deleting Job/Position Assignments</td>
<td>287</td>
</tr>
<tr>
<td>Displaying/Editing Task Profiles for Jobs</td>
<td>288</td>
</tr>
<tr>
<td>Creating and Editing positions</td>
<td>289</td>
</tr>
<tr>
<td>Creating Positions</td>
<td>290</td>
</tr>
<tr>
<td>Renaming Positions</td>
<td>292</td>
</tr>
<tr>
<td>Delimiting Positions</td>
<td>293</td>
</tr>
<tr>
<td>Deleting Positions</td>
<td>294</td>
</tr>
<tr>
<td>Moving Positions</td>
<td>295</td>
</tr>
<tr>
<td>Rearranging Positions</td>
<td>296</td>
</tr>
<tr>
<td>Prioritizing Positions</td>
<td>297</td>
</tr>
<tr>
<td>Creating Chief Position Assignments</td>
<td>298</td>
</tr>
<tr>
<td>Delimiting/Deleting Chief Position Assignments</td>
<td>299</td>
</tr>
<tr>
<td>Assigning Holder Positions</td>
<td>300</td>
</tr>
<tr>
<td>Determining Staffing Percentages</td>
<td>301</td>
</tr>
<tr>
<td>Replacing Users with Employees</td>
<td>302</td>
</tr>
<tr>
<td>Delimiting Relationships</td>
<td>303</td>
</tr>
<tr>
<td>Deleting Relationships</td>
<td>304</td>
</tr>
<tr>
<td>Assigning Unrelated Positions</td>
<td>305</td>
</tr>
<tr>
<td>Creating and Editing Task Profiles</td>
<td>306</td>
</tr>
<tr>
<td>Displaying Task Profiles</td>
<td>308</td>
</tr>
<tr>
<td>Assigning Tasks to Objects</td>
<td>309</td>
</tr>
<tr>
<td>Editing the Weighting of Tasks</td>
<td>311</td>
</tr>
</tbody>
</table>
Expert Mode

Changing Color Assignments ................................................................. 365
Changing Color Assignments for Objects ........................................ 366
Changing Shapes for Objects ................................................................. 367
Changing Line Styles for Objects .......................................................... 368

Working with Hierarchical Structures ............................................. 369
Switching Between Overview and Detail Mode .................................. 370
Displaying Close-ups of a Structure ..................................................... 371
Displaying Substructures ............................................................................... 371
Displaying Parent Structures ................................................................. 373
Displaying Whole Structures ................................................................. 374
Selecting All Objects in a Structure ...................................................... 375
Deselecting All Objects in a Structure .................................................. 376
Centering Selected Objects .......................................................................... 377
Centering Root Objects ........................................................................... 378
Displaying Paths ..................................................................................... 379
Displaying Subordinate Objects .............................................................. 380
Suppressing Subordinate Objects ........................................................... 381
Increasing Space Between Objects ......................................................... 382
Decreasing Space Between Objects ......................................................... 383
Using One Level Lower ........................................................................... 384
Using One Level Higher .......................................................................... 385

About the Toolbox .................................................................................. 386
Retrieving the Toolbox ............................................................................. 387
Starting Graphics Tools in Organizational Management .................... 388

Option Settings ....................................................................................... 389
View Options ......................................................................................... 390
The View Options Dialog Box ................................................................. 391
Changing View Options ........................................................................... 394
Object Options .......................................................................................... 395
The Object Options Dialog Box .............................................................. 396
Changing Object Options ......................................................................... 398
Line Options .............................................................................................. 399
The Line Options Dialog Box ................................................................. 400
Changing Line Options ............................................................................ 401
Changing Design Groups ........................................................................ 402
Mailing Hierarchical Structures ............................................................... 403
About Sorting Objects ............................................................................... 404
The Sort Objects Dialog Box ................................................................. 405
Sorting Objects ......................................................................................... 406
About Searching for Objects ................................................................. 407
The Search for Objects Dialog Box ......................................................... 408
Searching for Objects ............................................................................... 409
View Windows ......................................................................................... 410
Adding View Windows ............................................................................. 411
Deleting View Windows ........................................................................... 412
The Arrange Views Dialog Box ............................................................... 413
Arranging Views ....................................................................................... 414
Miscellaneous Features ........................................................................... 415
The Print Feature ..................................................................................... 416
The Print Dialog Box..............................................................417
The Format Dialog Box................................................................419
Printing Hierarchical Structures.............................................420
Printing Tips and Troubleshooting........................................421
General Hints.........................................................................422
Problems Importing CGM files into Graphics Programs........423
Problems Printing PostScript Data........................................425

Customizing and Structural Graphics.................................427
Reports in Organizational Management.................................428
Existing Organizational Units (Report RHXEXI00)..................430
Staff Functions for Organizational Units (Report RHXSTAB0)....431
Organizational Structure with Persons (Report RHXSTR02)......432
Organizational Structure with Work Centers (Report RHXSTR02)...433
Existing Jobs (Report RHXEXI02)...........................................434
Job Index (Report RHSTEL00)................................................435
Job Description (Report RHXDESC0).....................................436
Complete Job Description (Report RHXSCRIP0).....................437
Periods for Unoccupied Positions (Report RHFILLPOS)..........438
Existing Positions (Report RHXEXI03).................................439
Staff Assignments (Report RHSBES00)..................................440
Position Description (Report RHXDESC1)..............................442
Staff Functions for Positions (Report RHXSTAB1)..................443
Authorities and Resources (Report RHXHFM0)......................444
Planned Labor Costs (Report RHSOLO00/RHXSOLO00)........445
Vacant Positions (Report RHVOP0).......................................446
Obsolete Positions (Report RHVOP01)..................................447
Complete Position Description (Report RHXSCRIP1)...............448
Reporting Structure without Persons (Report RHSTR05)........450
Reporting Structure with Persons (Report RHSTR04)..............451
Existing Work Centers (Report RHXEXI05)............................452
Work Centers per Organizational Unit (Report RHXSTRU06)...453
Existing Tasks (Report RHXEXI04).......................................454
Activity Profile of Positions (Report RHXSTR07)....................455
Activity Profile of Positions with Persons (Report RHXSTR08)...456
Existing Objects (Report RHEXIST0)....................................457
Structure Display/Maintenance (RHSTRU00).........................458
Reporting on an Infotype (Report RHINFAW0)......................459
Starting an HR Report (Report RHPNPSUB)..........................460
Expert Mode

This section of the documentation on the Organizational Management component contains information on Expert mode. This mode also includes the Simple Maintenance view.

To access this mode, choose Human resources → Organizational Management → Expert mode.

To access Simple Maintenance, choose Human resources → Organizational Management → Expert mode → Simple Maintenance.
Organizational Management

Purpose

The Organizational Management component enables you to:

1. depict the organizational and reporting structures in your company as well as your current Organizational Plan [Page 17]

2. analyze your current organizational plan according to the evaluation paths of your choice, and, based on this, to plan workforce requirements and personnel costs

3. create additional organizational plans as planning scenarios in order to simulate new structures in the context of business process reengineering

4. create effective workflow management through access to the reporting structure.

Organizational Management’s object-oriented design [Page 19] provides you with a number of organizational objects with which you create organizational plans.

At the center of an organizational plan are organizational units [Page 21](departments, for example) arranged in a hierarchy that mirrors the structure of your enterprise. Other organizational units such as positions [Page 23](sales administrator, for example) depict your enterprise’s reporting structure. Objects such as jobs, tasks, and work centers are the building blocks of your organizational plan.

By relating objects via relationships, you create a network that mirrors your organizational and reporting structures. In addition to this, you can create relationships to objects from other components (cost center, employee or R/3 User, for example).
This functional organizational plan differs from the administrative enterprise structure and the personnel structure whose elements are relevant to Payroll Accounting (company code, personnel subarea or employee group, for example). These structures are found in their corresponding components.

These functional and administrative structures come into contact if a person is assigned to an organizational plan (as the holder of a position) as well as an enterprise or personnel structure (that is, to a personnel subarea etc.).

**Implementation Considerations**

Organizational Management is the basis for additional Personnel Planning and Personnel Development components and functions as well as for SAP Business Workflow. The fact that these components can be integrated should be taken into account when you are installing them.

**Integration**

- Organizational Management comprises of two subcomponents with which you can create and maintain organizational plans:
  - Organizational Plan (BC-BMT-OM-OM)
  - Structural graphics (BC-BMT-OM-GRF)
- Installing Organizational Management enables you to use the following components from Personnel Planning and Personnel Development effectively:
Organizational Management

- Personnel Development (PA-PD)
- Recruitment (PA-RC)
- Compensation Management (PA-CM)
- Personnel Cost Planning (PA-CM-CP)
- Training and Event Management (PE)

Organizational Management also has interfaces to the following components:
- Shift Planning (PT-SP)
- Capacity Planning (PP-CRP)
- Personnel Administration (PA-PA)
- Human Resources Information Systems (PA-IS)

Organizational Management also forms the basis for SAP Business Workflow (BC-BMT-WFM). The organizational plan you create forms the framework for a routing structure that SAP Business Workflow uses to assign tasks to an employee.

Both Organizational Management and SAP Business Workflow are components of Business Management (BC-BMT).

Features

The subcomponents of Organizational Management offer the following tools with which you can create and maintain an organizational plan for your enterprise:

- **Simple Maintenance [Page 228]**
  
  This tool allows you create organizational objects quickly and easily as well as relate them to an organizational plan. Your organizational plan is presented in a tree structure, which enables you to maintain it according to your requirements.

- **Maintaining Object Infotypes [Page 162]**
  
  Using this tool, you can create and process individual organizational objects and the relationships between them. You can also create, maintain or display additional attributes and characteristics for the objects.

- **Structural Graphics [Page 338]**
  
  Using this tool, you can display and maintain your organizational object graphically. It enables you, for example, to move objects around inside structures. Procedures for working with objects are simplified in Structural Graphics. However, not all of the functions are available. You can access other functions from structural graphics.

- **Planning and Evaluation Tools**
  
  Using plan versions, status indicators, validity periods, time constraints and evaluation paths, you can create simulations and reports according to your requirements.
Org. Plan

Definition

Depicts the functional organizational (department hierarchy, for example) and reporting structures between the positions in an enterprise. In addition to this, it can include relationships between positions and tasks, jobs and work centers.

An organizational plan is modeled using the tools from the Organizational Plan and is the foundation for Organizational Management.

Use

Using your organizational plan you can depict the functional structure of your enterprise (as opposed to the administrative structure). You decide how much of your enterprise to represent in the organizational plan.

As well as your current plan, you can depict additional organizational plans for planning purposes. These various organizational plans are called plan versions [Page 78] and can be evaluated.

Structure

An organizational plan is made up of several separate hierarchies and catalogs that are related to one another. These hierarchies and catalogs are also consist of relationships between and lists of organizational objects [Page 19]. Thus, you can depict your enterprise in all its complexity.

An organizational plan can include the following hierarchies and catalogs (elements).

- an organizational structure
An organizational structure depicts the hierarchy in which the various organizational units at your enterprise are arranged. You create an organizational structure by creating and maintaining organizational units, and then creating relationships between the units.

The organizational structure is the only element of an organizational plan that must be created. The other elements are optional.

- **staff assignments**
  
  Staff assignments depict the assignment of positions to organizational units and the relationship between positions and holders (employees or R/3 users). You create staff assignments in the organizational units positions and assign them in the organizational unit holders.

- **a reporting structure**
  
  A reporting structure depicts the position hierarchy in your enterprise. You create a reporting structure by relating positions to one another.

- **a job index**
  
  A job index identifies the different jobs in your enterprise. You develop a job index by creating and maintaining jobs.

- **a work center plan**
  
  A work center catalog identifies the different work centers in your enterprise. You develop a work center index by creating and maintaining work centers.

- **a task catalog**
  
  A task catalog identifies the tasks that are performed by employees in your enterprise. The catalog can also identify a set of tasks that are routinely performed together. You develop a task index by creating and maintaining tasks.

As well as a one dimensional organizational plan, you can also depict a multi-dimensional matrix organization.

**Integration**

Organizational plans can also include organizational objects that do not come from Organizational Management, cost center or person (employee or R/3 user), for example.

For more information, see Organizational Management.
Organizational Object

Definition

Objects that are used to create an organizational plan [Page 17] in Organizational Management. The following object types are available:

- Organizational Unit [Page 21]
- Position [Page 23]
- Job [Page 26]
- Work Center [Page 28]
- Task [Page 30]

Organizational plans can also include organizational objects that come from components other than Organizational Management (cost center or person (employee or R/3 user), for example) or objects defined in customizing.

Use

You can relate organizational objects in two ways to create an organizational plan:

- you can either relate objects of the same object type in separate hierarchies or list them in separate catalogs.
- or you can relate objects of different object types and in so doing relate the hierarchies and catalogs.

These relationships [Page 35] enable you to depict multi-dimensional dependency in your enterprise’s organizational plan.

It is not mandatory to use all of these objects in your plan. You do not have to define work centers, for example, if you do not find them applicable. You do not have to assign tasks to your jobs and positions. You must, however, create organizational units.

By determining a validity period for every organizational object, you can display and evaluate situations in the past, present and future.

Structure

An organizational object comprises:

- a short and long description
- an 8 digit ID number and a description
- a relationship, which defines the link between the object and other objects
- various object characteristics
- a validity period and a time constraint
- a status indicator

For further information on creating and maintaining organizational objects, see: Simple Maintenance [Page 228]
Organizational units

Definition
Organizational object (object key O) used to form the basis of an organizational plan. Organizational units are functional units in an enterprise. According to how tasks are divided up within an enterprise, these can be departments, groups or project teams, for example.

Organizational units differ from other units in an enterprise such as personnel areas, company codes, business areas etc. These are used to depict structures (administration or accounting) in the corresponding components.

Use
By depicting your organizational units and the hierarchical or matrix relationships between them, you model the organizational structure of your enterprise.

This organizational structure is the basis for the creation of an organizational plan, as every position [Page 23] in your enterprise is assigned to an organizational unit. This defines the reporting structure.

Integration
An organizational unit can be related, amongst other things, to:

- other organizational units via relationship A/B 002 (reports to / is line manager of).
- positions [Page 23] via relationship A/B 003 (belongs to / includes) and A/B 012 (manages / is managed by).
- tasks [Page 30] via relationship A/B 007 (describes / is described by)
- a master cost center via relationship A 011 (cost center assignment) or with several cost centers [Page 34] via relationship A 014 (cost center distribution)

The organizational units do not have to have their own cost centers.

You determine the characteristics of an organizational unit using the following infotypes:

Object (infotype 1000) [Page 38]
Relationships (infotype 1001) [Page 39]
Description (infotype 1002) [Page 41]
Department/Staff (infotype 1003) [Page 42]
About the Account Assignment Features Infotype (1008) [Page 49]
Work Schedule (infotype 1011) [Page 53]
Cost Planning (infotype 1015) [Page 58]
Standard Profiles (infotype 1016) [Page 60]
PD Profiles (infotype 1017) [Page 62]
Cost Distribution (infotype 1018) [Page 64]
Required Positions (infotype 1019) [Page 66]
Organizational units

Site Dependent Info (infotype 1027) [Page 68]
Address (infotype 1028) [Page 69]
Mail Address (infotype 1032) [Page 71]
Sales Area (infotype 1037) [Ext.]
Shift Group (infotype 1039) [Page 73]
SAP Organizational Object (infotype 1208) [Page 75]
Positions

Definition

Organizational object (object key S) used to distribute tasks to different positions and to depict the reporting structure in your organizational plan. Positions are concrete and are held by employees or R/3 users in an enterprise, sales administrator, head of European sales or secretary in the marketing department, for example.

Positions differ from jobs. A job [Page 26] is not concrete but rather the basis for the creation of various positions with similar tasks and characteristics.

A position does not only inherit its tasks and characteristics from a job. It can also be assigned tasks and characteristics directly or inherit them from the organizational unit that it belongs to.

Use

You assign positions to organizational units, in doing this, you also determine the tasks assigned to them. You can define a chief position within an organizational unit, to which all other positions in the organizational unit report.

In some enterprises, by assigning positions to organizational units, you define the reporting structure, that is the assignment of positions to one another.

If the actual reporting structure of your enterprise differs from the reporting structure according to the organizational structure, you can model it in two ways:

- as a reporting structure, if your positions are assigned in a one dimensional hierarchy
- as a matrix organization, if your positions report to more than one organizational unit
  
  Matrix relationships can be disciplinary or professional.

In doing this, you relate the positions concerned to each other, regardless of which organizational unit they are assigned to.

You need positions to:

- create staff assignments, that is the assignment of holders (employees or R/3 users) to positions and to a corresponding organizational unit
- distribute tasks between positions in your enterprise
- use Workflow Management
- evaluate your reporting structure

You can depict and document the reporting structure of your enterprise using reports. The reporting structure you create determines the evaluation paths available to you.

Integration

A position must always be related to:

- an organizational unit [Page 21] via relationship A/B 003 (belongs to / includes)
- a job [Page 26] via relationship A/B 007 (describes / is described by)

A position can also be related to:
Positions

- an organizational unit via relationship A 012 (reports to)
- another position via relationship A/B 002 (reports to / is line manager of) or A/B 004 (is subordinate to (disc.) / supervises) or A/B 005 (is subordinate to / is line manager of)
- a holder [Page 33] (one or more persons or R/3 users) via relationship A/B 008 (holder)
- tasks [Page 30] via relationship A/B 007 (describes / is described by)
- a work center [Page 28] via relationship A/B 003 (belongs to / includes)
- a master cost center via relationship A 011 (cost center assignment) or with several cost centers [Page 34] via relationship A 014 (cost center distribution)

You determine the characteristics of a position using the following infotypes:

- Object (infotype 1000) [Page 38]
- Relationships (infotype 1001) [Page 39]
- Description (infotype 1002) [Page 41]
- Department/Staff (infotype 1003) [Page 42]
- Planned Remuneration (infotype 1005) [Ext.]
- Vacancy (infotype 1007) [Page 47]
- About the Account Assignment Features Infotype (1008) [Page 49]
- Authorities and Resources (infotype 1010) [Page 52]
- Work Schedule (infotype 1011) [Page 53]
- Employee Group/Subgroup (infotype 1013) [Page 56]
- Obsolete (infotype 1014) [Page 57]
- Cost Planning (infotype 1015) [Page 58]
- Standard Profiles (infotype 1016) [Page 60]
- PD Profiles (infotype 1017) [Page 62]
- Cost Distribution (infotype 1018) [Page 64]
- Address (infotype 1028) [Page 69]
- Mail Address (infotype 1032) [Page 71]
- Job Evaluation Results (infotype 1050) [Ext.]
- Survey Results (infotype 1051) [Ext.]
- SAP Organizational Object (infotype 1208) [Page 75]

To use Personnel Cost Planning effectively, you must update the Vacancy infotype (1007) for positions. You must also maintain the Cost Planning infotype (1015) for either the position, or the describing job.
Job

Definition
Organizational object (object key C) used to create positions in an organizational plan.

Positions [Page 23] are concrete and can be held by persons in an enterprise (secretary in the marketing department, for example). Jobs, in contrast, are classifications of functions in an enterprise (secretary, for example), which are defined by the assignment of tasks [Page 30] and characteristics. Jobs serve as job descriptions, that apply to several positions with similar tasks or characteristics.

Use
When you create jobs, they are listed in a job index.

When you create a new position (secretary in the marketing department, for example), you can relate it to a job that already exists in your job index (secretary, for example). The position then automatically inherits the tasks and characteristics of the job.

If there is no corresponding job, add one to your job index and assign it tasks and characteristics. This will then be available when you add new positions.

This relationship will make it easier for you to create positions that are similar or the same, as you will not have to assign tasks and characteristics to each individual position. You can also assign additional tasks and characteristics directly to positions.

You have 20 secretaries in your enterprise. Each one holds a position (secretary in the marketing department, for example). This position is described by the job secretary and the tasks and characteristics that belong to it. In addition to this, each position (secretary in the marketing department, for example) can be assigned specific tasks and characteristics, which differentiate it from other positions (secretary in the personnel department, for example).

Jobs can also provide a valuable point of reference for developing qualifications, if you plan to install the Personnel Development component of HR.

Integration
A job can be related, amongst other things, to:

- a position [Page 23] via relationship A/B 007 (describes / is described by)
- tasks [Page 30] via relationship A/B 007 (describes / is described by)
- a holder [Page 33] of a position via relationship A/B 017 (is performed by / performs)
  You can then assign a position holder directly to a job, if a different job applies to him or her than the one which his or her position is assigned to.
- another job via relationship A/B 041 (is the same as)

You determine the characteristics of an job using the following infotypes:
Object (infotype 1000) [Page 38]
Relationship (infotype 1001) [Page 39]
Description (infotype 1002) [Page 41]
Planned Remuneration (infotype 1005) [Ext.]
Cost Planning (infotype 1015) [Page 58]
Standard Profiles (infotype 1016) [Page 60]
PD Profiles (infotype 1017) [Page 62]
Job Evaluation Results (infotype 1050) [Ext.]
Survey Results (infotype 1051) [Ext.]
Work centers

Definition
Organizational object (object key A) used to depict work centers that exist in your enterprise in your organizational plan. A work center identifies the physical location where work is carried out. A work center can be defined by a general place description (Philadelphia, for example) or a very specific place description (office 105, desk III, for example).

Use
When you create a work center, you create a work center index for your enterprise. The work centers listed here can then be assigned to other organizational units, positions, for example. You can assign characteristics to work centers.

You can identify any restrictions associated with the work center—perhaps an area of a plant may be unsuitable for employees with disabilities. Using the health examinations infotype (1009), you can determine whether a work center will be subject to regular health examinations.

Integration
A work center can be related, amongst other things, to:

- a position [Page 23] (or more than one position) via relationship A/B 003 (belongs to / includes)
- another work center via relationship A/B 003 (belongs to / includes)

You determine the characteristics of a work center using the following infotypes:

- Object (infotype 1000) [Page 38]
- Relationships (infotype 1001) [Page 39]
- Description (infotype 1002) [Page 41]
- Planned Remuneration (infotype 1005) [Ext.]
- Restrictions (infotype 1006) [Page 46]
- Health Examinations (infotype 1009) [Page 51]
- Authorities and Resources (infotype 1010) [Page 52]
- Work Schedule (infotype 1011) [Page 53]
- Employee Group/Subgroup (infotype 1013) [Page 56]
- Obsolete (infotype 1014) [Page 57]
- Cost Planning (infotype 1015) [Page 58]
- Cost Distribution (infotype 1018) [Page 64]
- Address (infotype 1028) [Page 69]
- Mail Address (infotype 1032) [Page 71]
Tasks

Definition
Tasks are one of the key objects in the system. They are useful cross-application means of carrying information and as such, provide a powerful tool for managing the flow of data and information through the system.

Use

Types of Tasks

<table>
<thead>
<tr>
<th>Name</th>
<th>Object type abbreviation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tasks (customer-defined tasks)</td>
<td>T</td>
</tr>
<tr>
<td>Standard tasks</td>
<td>TS</td>
</tr>
<tr>
<td>Workflow tasks (customer-defined)</td>
<td>WF</td>
</tr>
<tr>
<td>Workflow templates</td>
<td>WS</td>
</tr>
</tbody>
</table>

The use of these tasks differs, depending on the area of the system you are working in:

- If you are working with the Human Resources component, you use tasks and standard tasks.
- If you are working with SAP Business Workflow, you use the following tasks:
  - Normal tasks
  - Standard tasks
  - Workflow tasks
  - Workflow templates

For human resources purposes, tasks are individual duties and responsibilities that are carried out by employees. The following activities are examples of tasks:

- Answering the telephone
- Producing marketing material
- Assessing applicants
- Developing software

You can use tasks for the following purposes:

- To describe jobs and positions
  
  For job and position descriptions, create tasks and create relationships between the tasks, and jobs and positions, using the Relationship infotype (1001).
As a point of reference for developing qualifications, if you plan to use the Personnel Development component

It is not mandatory to create tasks.

Once you have created tasks, you can use various infotypes to define their different attributes. You may create an unlimited number of tasks.

You can create single tasks, or task groups. Single tasks are individual activities, creating the department budget, assessing new equipment; task groups define activities that are usually performed together.

You can create a task group with the name Secretarial tasks. This group contains the following single tasks:

- Word processing
- Answering the telephone
- Filing

Task groups are advantageous since they save you time when you create relationships between jobs and positions. It is faster to create a relationship with one task group, than with several single tasks. You can build a task group by creating relationships between the single tasks involved.

All tasks that exist at a certain time are listed in a task catalog. The task catalog also shows the relationships among different tasks, if task groups have been defined.

**Task Profiles**

A task profile is a list of separate tasks assigned to a specific object. The list of tasks defines the purpose, the role, and the actions of an object in the system.

The system uses task profiles differently, depending on the application area:

- In Organizational Management, task profiles serve as highly detailed job and position descriptions
- In SAP Business Workflow, task profiles determine the tasks that a user can perform in the system
- In SAP Session Manager, task profiles determine the areas of the system a user sees when logging on.

There are different types of task. The content of the task profile varies according to the type of task:

- If you are working with the Human Resources component, task profiles include normal tasks (referred to as customer-defined tasks) and standard tasks.
- If you are working with SAP Business Workflow or SAP Session Manager, your task profile may contain the following tasks:
  - Normal tasks
  - Standard tasks
  - Workflow tasks
Tasks

- Workflow templates

In addition, task profiles developed for SAP Business Workflow or SAP Session Manager can include roles. If you include a task in a task profile, and that task is part of a role, the entire role is included in the task profile.

You can create and maintain task profiles for the following objects:

- Organizational units
- Positions
- Jobs
- Work centers
- Users

How you set up task profiles varies according to the method you use to maintain your organizational plan.

Integration

You can edit the following infotypes for tasks:

Object (1000) [Page 38]
Relationship (1001) [Page 39]
Character (1004) [Page 44]
Standard Profiles (1016) [Page 60]
PD Profiles (1017) [Page 62]

If you are working with SAP Business Workflow, you can edit additional infotypes: See SAP Business Workflow [Ext.]
Holder

Definition
A person (object type key P) or R/3 user (object type key US) who is listed as an employee in Personnel Administration, who is assigned to a position or a work center in an organizational plan.

For more information, see Personnel Administration [Ext.]

Use
By assigning a holder to a position [Page 23], you determine,
- where a person (employee) is functionally assigned in your enterprise
- which tasks are assigned to an employee
- who (employees or R/3 users) tasks are to be forwarded tasks in a workflow

By assigning a holder to a work center [Page 28], you specify where in your enterprise an employee or R/3 user works.

By assigning a person (employee) to a position, you implement integration between Organizational Management and Personnel Administration, as long as it is set up in Customizing.

Integration
The following relationships are relevant to a holder:

- A person or R/3 user becomes a holder, if he or she is related to a position via relationship A/B 008 (holder).
- You can assign a position holder to a job [Page 26] directly via relationship A/B 017 (is carried out by/ carries out), if another job is to apply to them other than the one which his or her position is assigned to.
Cost Center

Definition
External object (object type K) from Controlling which represents a clear origin of costs.
For more information, see Cost Center Accounting [Ext.]
Cost Center [Ext.]

Use
By assigning cost centers to organizational objects, you determine where costs incurred by the object are to be charged. The inheritance principle applies: If an organizational object is not assigned a cost center, the cost center assigned to the superior object applies.
An organizational object may also be assigned more than one cost center. For more information, see Cost Distribution (infotype 1018) [Page 64].

Integration
A cost center can be related to the following organizational objects:

- an organizational unit [Page 21] via relationship A 011 (Cost center assignment)
- a position [Page 23] via relationship A 011 (Cost center assignment)
- a work center [Page 28] via relationship A 011 (Cost center assignment)
Relationships

Definition
By defining relationships between objects, you create a hierarchy of objects that mirrors your organizational structure.

Use
In Detail Maintenance, you create relationships between objects by entering information in the Relationship infotype (1001). In Simple Maintenance, it is more straightforward. When you create a new object, the system creates that object’s relationships.

You use the network of relationships between objects to model the reporting structures of your organization.

Structure
There are many different types of relationships between objects in the component Organizational Management. It is the relationships between objects that give information its value. It is important to understand the syntax used to identify relationships and the structure of relationships.

Syntax Used to Identify Relationships
The standard syntax used to identify a relationship is A/B 000. A/B refers to the two different sides of a relationship, which you create when you link two objects. The system calls these sides passive (A) and active (B). They form the reciprocal relationship, and are vital in holding the relationship together. The three-digit numerical code identifies the relationship.

You assign a position to an organizational unit, to identify where the position is allocated. The system creates a relationship infotype record between the organizational unit and the position. You can check the relationship in the Relationship infotype screen in Detail Maintenance. This relationship is called 003. This means the position belongs to the organizational unit, which in turn incorporates the position. The organizational unit’s relationship record is B 003 and the position’s is A 003.

Structure of Relationships
A relationship between two objects can be structured:

- Hierarchically
- Laterally
- Unilaterally

For example, the relationship between a senior position in an organizational unit and another position in that same unit is hierarchical. The senior position (B 002) is line supervisor to the lower placed position (A 002) which reports to the position above.

A lateral or flat relationship, for example, is relationship 041, which names a situation where two jobs are equivalent, and can replace each other. One side of the relationship is A 041, the other
Relationships

is B 041, but the two sides have equal standing. A relationship between a job and a position is also a lateral relationship.

A relationship can be one-sided. For example, a relationship between an object (such as a position) and an external object type (a cost center in Controlling, perhaps), has only one direction and so is one-sided.

Integration

Inheritance is one of the most powerful aspects of the component Organizational Management. Inheritance is when an object automatically receives attributes assigned to another object. It occurs when:

- The object concerned shares a special type of relationship with another object
  For example, positions always inherit the attributes of the job to which they are related. This concept is fundamental.

- Objects are placed below other objects in a hierarchical structure
  The lower-level objects inherit the attributes of the higher-level objects unless you specifically provide other attributes. (The Simple Maintenance tree structure, which illustrates this hierarchy, can help you visualize how inheritance takes place.)

Inheritance is particularly useful as a time-saver. In setting up your organizational plan, you create numerous objects with individual attributes. However, many objects share the same attributes. Entering the same attributes for each object takes a lot of time. Instead, inheritance does this for you.

- If you need to enter the working hours of 40 positions, you define the working hours for the organizational unit, and the positions inherit these automatically.

- Perhaps your company has employed 20 new consultants. Each of these positions inherits the attributes of the job consultant.
Infotypes

Definition
Allow you to enter and store object characteristics which are thematically linked.

Use
You use infotypes to define additional object attributes or characteristics. You edit infotypes in Detail Maintenance. You can create, change, display, delete and delimit infotypes.

Each infotype enables you to define particular characteristics for an object. In the Relationships infotype, you can, for example, define how two objects are related to one another. In the Work Schedule infotype, you can define working time for a position, organizational unit or a work center.

Some infotypes are only relevant for certain object types. The Vacancy infotype is, for example, only relevant for positions and the Character infotype only for tasks. Some infotypes can be edited for all object types, the Object and Relationships infotypes, for example.

Structure
Each time you create an infotype for an object, you create an infotype record. Once you have created infotype records, you can change, display, list, copy, delimit or delete them.

You can create any number of infotypes for an object. You can also create several infotype records for the same infotype for an object. An object can, for example, have several relationship infotype records which define the objects links with other objects in the organizational structure.

The data in an information type can be divided into various other information categories. These categories are called subtypes. In the Health Examinations infotype, for example, you can define two categories or subtypes of health information for a work center.

- Health exclusions
- Health examinations
About the Object Infotype (1000)

Definition
Infotype that determines the existence of an organizational object.

Use
As soon as you have created an object using this infotype, you can determine additional object characteristics and relationships to other objects using other infotypes.

To create new objects you must:
- Define a validity period for the object
- Provide an abbreviation to represent the object
- Provide a brief description of the object

The validity period you apply to the object automatically limits the validity of any infotype records you append to the object. The validity periods for appended infotype records cannot exceed that of the Object infotype.

The abbreviation assigned to an object in the system renders it easily identifiable. It is helpful to use easily recognizable abbreviations.

You can change abbreviations and descriptions at a later time by editing object infotype records. However, you cannot change an object’s validity period in this manner. This must be done using the Delimit function.

You can also delete the objects you create. However, if you delete an object the system erases all record of the object from the database. You should only delete objects if they are not valid at all (for example, if you create an object accidentally).
About the Relationship Infotype (1001)

Definition
Infotype, which defines the Relationships between different objects.

Use
You indicate that an employee or user holds a position by creating a relationship infotype record between the position and the employee or user. Relationships between various organizational units form the organizational structure in your enterprise. You identify the tasks that the holder of a position must perform by creating relationship infotype records between individual tasks and a position.

Creating and editing relationship infotype records is an essential part of setting up information in the Organizational Management component. Without relationships, all you have are isolated pieces of information.

You must decide the types of relationship records you require.

You must manually create relationship records when you work in Infotype Maintenance. However, when you work in Simple Maintenance and Structural Graphics, the system creates certain relationship infotype records automatically.

Structure
There are many types of possible relationships between different objects. Each individual relationship is actually a subtype or category of the Relationships infotype.

Certain relationships apply only to certain objects. When you create relationship infotype records, you must select a relationship that is suitable for the two objects involved. For example, a relationship that can be applied to two organizational units might not make any sense for a work center and a job.

The report RHRLAT0 (Allowed relationships of object types) reports on the relationships permitted for particular objects. The Relationship infotype screen also includes an Allow Relationships option. When this is chosen, a dialog box displays a list of suitable relationships.

Organizational Management includes a predefined set of relationships. You can select from these, or you can create other relationships. For further information, see the Implementation Guide (IMG) under Organizational Management > Integration > Basic Settings > Infotype Maintenance.

You can create and edit numerous relationship records for a single object. An organizational unit can be related to several different organizational units, with a position, for example, as well as a work center.
About the Relationship Infotype (1001)

Integration

The benefit of defining relationship records lies in the reporting results which you obtain when you report on particular relationships between objects in an organizational plan.

This happens as follows:

1. When you start a report, you enter a chain of relationships or a certain number of relationships in which you are interested, for example *Organizational unit* > *Position* > *Employee*. This chain of relationships is known as an Evaluation path.

2. The system then traces the different structures in your plan, and reports on all objects that are involved in the named evaluation path.
About the Description Infotype (1002)

Definition
Infotype containing descriptions of organizational objects.

Use
The information you store in this infotype is for reference only and can not be reported on. For this reason, the creation of the infotype is optional, it can, however, be very helpful.

In this infotype, you can describe the main area of responsibility of an organizational unit in your enterprise as follows: Production department is responsible for materials, stockkeeping, packing and distribution. You can also provide a work center with certain rules and instructions.

You must categorize the infotype records that you create in this infotype. You can do this by assigning subtypes. Description subtypes are user-defined and so can vary from company to company. You can, for example, categorize descriptions as general, environmental, or technical. For more information, see the Implementation Guide (IMG) for Organizational Management.

You can maintain numerous Description infotype records for one object, perhaps a general description record, a technical record, and so on. You can also create records in different languages.

⚠️

The Description infotype should not be used as a means of entering job or position descriptions. Job and position descriptions consist of a list of tasks the holder of a job or position must perform. Create these types of description by creating jobs, positions and tasks and relationships between them.
Department/Staff (Infotype 1003)

Definition
Infotype, with which you can allocate a staff indicator to organizational units and positions as well as flag organizational units as departments.

Use
You use the Department/Staff infotype solely for organizational units and positions. It has the following functions:

- It allows you to apply a Staff flag to organizational units and positions

  A staff flag indicates that an organizational unit or position is not part of the normal reporting structure at your company, but rather reports directly to a high level position, or organizational unit.

- It allows you to apply a Department flag to organizational units

  It is necessary to apply department flags only when integration is active between Personnel Planning and Personnel Administration. If integration is active, certain data records from Personnel Planning are written to Personnel Administration. For this, you must enter which departments are represented by organizational units so that the corresponding data is transferred. (Organizational units do not necessarily represent departments in Personnel Planning. Units may represent teams, or groups, within a single department.)

If your company uses department flags, you must also make entries in table T77S0, by entering PPABT PPABT for the flags to operate properly. For further information, see the Implementation Guide (IMG) under Organizational Management > Integration > Set Up Integration with Personnel Administration.

You do not have to create this infotype. You can maintain this infotype using Infotype Maintenance, by creating infotype records one object at a time. Or, you can work in Simple Maintenance, where procedures are streamlined. See Further Attributes [Page 332]

If you want to create this infotype, you can run reports, which list all objects with the staff indicator. The RHXSTAB0 report (Staff Functions for Organizational Units) lists flagged organizational units, and the RHXSTAB1 report (Staff Functions for Positions) lists flagged positions.
About the Character Infotype (1004)

Definition
Infotype with which you can categorize the different tasks you maintain in your task catalog. For example, you can differentiate between tasks that contribute directly to the products and services your company produces, and tasks that are administrative in nature.

Use
The Character infotype is only used when you work with tasks, within the context of Human Resources (HR). (Tasks are also used in SAP Business Workflow.) It is not mandatory that you create and edit this infotype. The information contained in the infotype can, however, be useful if you want to determine salaries for jobs and positions, for example. An awareness of the nature of tasks which have to be carried out helps you determine suitable compensation. Do decisions have to be made, for example? Will a task directly help the company to reach its targets?

Tasks can be divided into the following categories:

- Rank
- Phase
- Purpose

You decide how many of these categories are appropriate for your company. You interpret the meaning of the different categories as you see fit. The system interpretation of the different categories (outlined below) is a suggestion only.

If you create this infotype, you can start reports, which will list the characteristics of tasks. The report RHXIAW04 (Character of a task in an organization) lists all the characteristics of tasks in one or more organizational unit. The report RHXIAW05 (Character of individual tasks) lists the characteristics of single tasks.

Structure

Rank
Use this category to classify tasks as a planning, or completion, or control task.

Phase
Use this category to classify how tasks fit into a business process.

Purpose
This category allows you to identify tasks that directly contribute to the products or services that a company provides.
About the Character Infotype (1004)
About the Restrictions Infotype (1006)

Definition
Infotype with which you can identify any restrictions applicable to employees who are assigned to a work center.

Use
You only create a Restrictions infotype for work centers.

- Has no wheelchair access, it may be unsuitable for disabled employees
- Requires heavy lifting, it may be unsuitable for women
- Exposes workers to alcohol, it may be unsuitable for employees under 18 years of age

Restrictions are categorized. The different categories of restrictions, and the reasons why the restrictions exist, are user-defined and so may vary from company to company. You can set up restriction categories and reasons in tables T778C and T778X, respectively.

You do not have to create this infotype. However, it can be helpful if such restrictions exist in a work environment, and you want to record them.

There are reports which you can use to report on restrictions for selected work centers, for example, RHXIAW01, (Single work centers with restrictions) and RHXIAW00 (Work centers with restrictions in an organization).

For the RHXIAW00 report to work, you must create and update relationships between work centers and organizational units, using the Relationship infotype (1001).
Vacancy (Infotype 1007)

Definition
Infotype with which you can identify positions which are currently vacant or will be vacant in the future, that is, they may be occupied again in the future.

Use
You only create a Vacancy infotype for positions. You might create a vacancy record for an occupied position if, for example, you know an employee is taking maternity leave.

You can create a Vacancy infotype record for a position that is occupied, or unoccupied.

If your company does not distinguish between occupied and unoccupied positions - that is, you consider all unoccupied positions to be vacant - you can set an indicator rather than maintain the Vacancy infotype.

The indicator tells the system to treat all unoccupied positions as vacant. For further information see the Implementation Guide (IMG) under Organizational Management > Functions > Activate/deactivate “Vacancy” infotype).

If your company does distinguish between occupied and unoccupied positions, you must maintain the Vacancy infotype.

You can mark vacancy records as historical records, once you no longer need them – that is, once a position is filled. Historical records are maintained in the database, but cannot be changed or used in processing. If you use the Applicant Management component, it is helpful to keep a record of vacancies after they are filled.

You can maintain this infotype using Infotype Maintenance, by creating infotype records one object at a time. Or, you can work in Simple Maintenance, where procedures are streamlined. See Further Attributes [Page 332]

Integration
The Vacancy infotype is used by more than one Human Resources component. For example, if you use Personnel Cost Planning, the system can take vacancies into account when it calculates cost projections. Vacancies are also registered in Career and Succession Planning, where, for example, they can be used when you conduct a search for suitable positions for an employee. If integration with the Personnel Administration component is active, the Applicant Management component also checks vacancy records. It is not mandatory to create the Vacancy infotype for Organizational Management purposes. You should, however, create this infotype for positions if you want to install the following HR components: Personnel Cost Planning, Career and Succession Planning or Applicant Administration.

See also:
Personnel Cost Planning [Ext.]
Vacancy (Infotype 1007)
Account Assignment Features (Infotype 1008)

Definition

Infotype with which you can define account assignment features for organizational units and positions.

- It plays a role in the assignment of cost centers to objects.
  
  You need cost center assignments if you plan to use the Personnel Cost Planning component.

- It allows you to enter default settings helpful for the Personnel Administration component.
  
  This ensures a more efficient integration of the Organizational Management and Personnel Administration components.

Use

You can maintain this infotype using Infotype Maintenance, by creating infotype records one object at a time. Or, you can work in Simple Maintenance, where procedures are streamlined.

Cost Center Assignments

Using this infotype, you can specify cost center-related default settings for organizational units and positions. These default values ensure that the system suggests the correct cost center assignment for objects. We recommend that you set default values in order to prevent incorrect data being entered on persons.

Cost centers are determined according to a combination of different pieces of information, including business areas, company codes, and so on. By setting defaults for these items, you narrow down the number of cost centers that can be assigned to an object.

The principle of inheritance applies to account assignment defaults. For example, the defaults set for an organizational unit are inherited by subordinate organizational units, as well as by positions assigned to the organizational units.

If you do not want to set up defaults using the Account Assignment infotype, you can enter a single default for all organizational units, in Customizing. Refer to the Personnel Management section of the Implementation Guide (IMG).

Personnel Administration Defaults

Using this infotype, you can assign personnel areas to organizational units or positions. Default values for payroll, authorizations and so on are controlled via personnel areas.

The inheritance principle applies to personnel areas. This means that employees automatically inherit personnel areas assigned to organizational units and positions, unless you specify otherwise.

This presents two advantages for Personnel Administration users:

- Faster assignment of personnel areas, since you do not have to do this separately for every employee.
- Fewer entry errors, as the system suggests the values to be inherited.
Account Assignment Features (Infotype 1008)

Entering personnel areas presents an additional advantage to customers who are installing the Organizational Management and Personnel Administration components together. Each personnel area is assigned a company code. Company codes are one of the factors used to determine cost centers. (Personnel Administration may require cost center assignments so that payroll charges can be charged back.)

This means if you specify a personnel area, it is not necessary to make any more entries in this infotype.

Integration

If enterprise organization is active in a controlling area, you can only maintain an organizational unit’s cost center and company code assignments in Controlling.

The system saves these assignments in Account Assignment Features (infotype 1008) in the Controlling Area and Company Code attributes. However, you can maintain or overwrite the Business Area and Personnel Area attributes of this infotype in Organizational Management, even if enterprise organization is active. See also Enterprise Organization [Ext.]

See also:
Personnel Cost Planning [Ext.]
About the Health Examinations Infotype (1009)

Definition
Infotype, with which you can create prerequisites and restrictions for employees at particular work centers.

Use
You only create a Health Examinations infotype for work centers.
You do not have to create this infotype.
If you create this infotype, the following reports are available, which document work centers with health exclusions or health examinations:
- Report RHXIAW02 (Work centers requiring health examinations in an organization)
- Report RHXIAW03 (Single Work Centers Requiring Health Examinations)

Structure
Health information is categorized into two subtypes:
- Health exclusions
- Health examinations

You can add other subtypes, or categories, if required. Refer to the Personnel Management section of the Implementation Guide (IMG).

You must assign the information you enter in the Health Examinations infotype to a subtype.

Use the Health exclusion subtype when employees are restricted from a work center if they have, or have had, a certain ailment. For example, employees who have had TB might be restricted from work centers where food is handled.

Use the Health examination subtype when a particular health examination must be performed on a regular basis, for example, if regular eye tests or hearing tests are required.
About the Authorities and Resources Infotype (1010)

Definition
Infotype with which you can define authorities and resources for positions or work centers.

Use
The *Authorities and Resources* infotype is created mostly for positions. You can, however, use it for work centers. This infotype serves two separate purposes. It allows you to identify:

- The authority assigned to a position or work center
  
  A position can have authority to sign contracts of up to 50,000 dollars. You can also use authorities to set authorizations for access to different areas of your company.

- The resources, or the equipment, made available to positions or work centers
  
  including the following:
  
  - laptops
  - special equipment
  - cars

Save the corresponding data in the subtypes *Authorities* and *Resources*.

If you create *Authorities* and *Resources* infotype records, you must assign information to one of the above subtypes.

You do not have to create this infotype.

You can use report RHXHFMT0 (*Authorities and resources*) to report on the data contained in the infotype.
Work Schedule (Infotype 1011)

Definition
Infotype with which you can define work schedules for organizational units, positions or work centers.

Use
You define planned working times for your organizational units, positions or work centers in order to store the projected volume of work per object. If a position is to be occupied, you can, for example, compare the planned working time stored for the position with the planned working time stored for the employee [Infotype 0007 [Ext.]]. In this way, you can avoid unwanted inconsistencies.

- If you want to create a company-wide planned working time, you can do so in Customizing. For more information, see the Personnel Management Implementation Guide (IMG) under Organizational Management → Infotype Settings → Working Time → Maintain Rule Values. We recommend, however, that rather than creating a working time for the whole company, you create a record for infotype 1011 for the root organizational unit and allow the value to be passed down the hierarchy.

- If you have various working times in your enterprise, create records for infotype 1011 for your organizational objects as you require.
  - You can also use the planned working time stored in Customizing as a default value. You can also specify in Customizing, which of the entry fields you can maintain with daily, weekly, monthly or annual values. For more information, see the Personnel Management Implementation Guide (IMG) under Organizational Management → Infotype Settings → Working Time → Maintain Rule Values.
  - To save time, you can also define work schedule groups as subtypes of infotype 1011. These can be created for organizational units. As long as positions are assigned to employee groups/subgroups ([Infotype 1013 [Page 56]]), you can group them into work schedule groups and allocate them a working time together. For more information, see the Personnel Management Implementation Guide (IMG) under Organizational Management → Infotype Settings → Working Time → Maintain Working Time Groups.

In these cases, positions inherit planned working times as follows:

- A record for infotype 1011 exists for a position: this work schedule applies.

- There is neither a record for infotype 1011 nor a record for infotype 1013 for a position: the position inherits the next working time flagged as “general” from a superior organizational unit. If there is no corresponding infotype record, the working time stored in Customizing is used.

- No record for infotype 1011 exists for a position; it is assigned to a combination of employee group and subgroup via infotype 1013. This group is not assigned to a work schedule group: The position inherits, as far as possible, the working time of the ALL subtype or the working time flagged as “general” for the directly superior organizational unit. If neither of these exists, the position inherits the working time from the next highest organizational unit. If none of these working times is found in the whole organizational structure, the working time stored in Customizing is used.
Work Schedule (Infotype 1011)

- No record for infotype 1011 exists for a position; it is assigned to a combination of employee group and subgroup via infotype 1013. This group is assigned to a work schedule group: The position inherits, as far as possible, the working time of the subtype (work schedule group) or the working time flagged as “general” for the directly superior organizational unit. If neither of these exists, the position inherits the working time from the next highest organizational unit. If none of these working times is found in the whole organizational structure, the working time stored in Customizing is used.

If the inherited working time does not cover the entire object period of the position, the position continues to inherit working times until the whole object period is covered.

In these cases, work centers inherit planned working times as follows:

- A record for infotype 1011 exists for a work center: this work schedule applies.
- No record for infotype 1011 exists for a work center. The work center is related to a position for which a record for infotype 1011 does exist: the work center inherits the position’s working time.
- No record for infotype 1011 exists for a work center. The work center is related to a position for which a record for infotype 1011 does not exist: the work center inherits a working time in the same way as a position.

You can maintain this infotype in Simple Maintenance or in Detail Maintenance.

You can report on working times using the reports RHXBES0 or RHSBES00 (Staff assignments). The report shows work schedules of organizational units, and possibly positions, and employees, depending on the options you select. (If integration is active with Personnel Administration, the report also shows absentee statistics, as well as other personnel data, as long as you have the authorization required.)

Structure

A complete record for infotype 1011 includes the following entries:

- the value you entered in the maintainable field
- based on this, the values calculated by the system for the non-maintainable fields
- a percentage that specifies the relationship between the value you entered and the default value stored.

A complete record for infotype 1011 for an organizational unit also includes the following:

- a subtype key, that is the work schedule group
- whether the working time entered for this infotype is to act as a general working time for subordinate objects

If there is more than one work schedule group (subtype) in the organizational unit, then there might be multiple infotype records for a single unit.

Integration

If you have activated integration between Organizational Management and Personnel Administration in Customizing, when a position is to be newly occupied, the planned working time
entered for the position in infotype 1011 is compared to the planned working time for the employee stored in infotype 0007. The work schedule check must also be activated for the relationship A/B 008 (Holder). For more information, see the Personnel Management Implementation Guide (IMG) under Organizational Management → Basic Settings → Relationship Maintenance.

If your company uses Personnel Cost Planning, the system can use the work schedule information, together with the information stored in the Cost Planning infotype 1015, to perform calculations. See Personnel Cost Planning [Ext.]

In the Organizational Management component, work schedules are for reference purposes. They are not used to calculate payroll, for example.

You can create more complex work schedules using the Workforce Planning component.
About the Employee Group/Subgroup Infotype (1013)

**Definition**
Infotype with which an employee group and subgroup can be assigned to a position.

**Use**
The Employee Group/Subgroup infotype is an optional infotype and is only created for positions. If you create this infotype and install both the Personnel Administration and Organizational Management components, you can check both employee and position data in both components. To carry out this check, the employee groups and subgroups must be available in both components.

The system checks that:
- Both the employee assigned to a position, and the position itself, are assigned to the same employee group and employee subgroup
- Work schedules assigned to positions and employee groups/subgroups in Organizational Management are consistent with the working times assigned to the holder of the position (the employee) in Personnel Administration.

If the system detects an inconsistency, a warning message appears. You can, however, still proceed with activities.

When integration is inactive, this infotype is still relevant, since the system checks employee groups and subgroups when you work with work schedules.

Employee groups and subgroups are user-defined, when Personnel Administration is installed. Refer to the Personnel Administration section of the Implementation Guide (IMG).

You can maintain this infotype using Infotype Maintenance, by creating infotype records one object at a time. Or, you can work in Simple Maintenance, where procedures are streamlined.
About the Obsolete Infotype (1014)

Definition

Infotype with which positions that are no longer required as a result of reorganization, but are still occupied can be flagged as obsolete. This enables you to recognize instantly if any action is required (searching for new activities for the holders of such positions, for example).

Use

This infotype is typically used for positions, although you can use the infotype with work centers as well.

Integration

You must create this infotype if you wish to install the HR Recruitment component. This component checks the system for positions that have been flagged as obsolete so that new positions can be found for the holders of the obsolete positions.

If the holder of an obsolete position is assigned to a new position or leaves the company, the system will ask you to delimit the validity period of the obsolete position.

You can maintain this infotype using Infotype Maintenance, by creating infotype records one object at a time. Or, you can work in Simple Maintenance, where procedures are streamlined.
Cost Planning (Infotype 1015)

Definition
Infotype with which information on all cost elements that form part of personnel costs in general can be stored.

Use
The Personnel Cost Planning component allows you to develop various scenarios for personnel cost targets and projections. The scenarios you develop can later be transferred to Controlling (CO) for budget planning purposes.

The Cost Planning infotype is only relevant if you use the Personnel Cost Planning component of Human Resources.

There are three methods you can use to develop different costing scenarios:

- Projected pay
- Payroll results
- Basic pay

The Cost Planning infotype is used to create cost planning using projected pay.

You can create this infotype for single jobs or positions. It is, however, also possible to enter the information for work centers or organizational units.

You might append cost data to organizational units and work centers when there is a fixed or lump sum of money that cannot be applied to individual jobs or positions.

The different types of costs are called wage elements. You can enter a maximum of seven wage elements for each cost planning infotype record you create. The wage elements themselves are defined in Customizing. Refer to the Personnel Management section of the Implementation Guide (IMG).

Structure
For each wage element entry you must identify the:

- Name of the particular wage element
- Amount of the element (either carried over from the Wage Table, or you can enter a different amount)
- Currency
- Time frame (a monthly contribution, a yearly adjustment, and so on)

Integration
Wage elements are referred to as cost elements, once they are brought into Personnel Cost Planning.
See also:
Personnel Cost Planning [Ext.]
Standard Profiles (Infotype 1016)

Definition

Infotype with which the following objects may be assigned authorization profiles defined by the system.

- Organizational units
- Jobs
- Positions
- Tasks (or standard tasks, if you have installed SAP Business Workflow)

Use

Authorization profiles control the functions/activities that the user can carry out in the system. An authorization profile is a list of authorizations that control access to different areas of the system. Authorities can also dictate the types of infotypes that users work with in the system. The authorities are valid across all system products. (Authority profiles are user-defined, at installation.)

For more information on authorization profiles, see BC - Users and Authorizations [Ext.]

Authority profiles are applied to R/3 users on an individual basis, one at a time. If you use the Standard Profile, you do not have to assign authorization profiles to employees individually. Instead, the profile to which you have assigned organizational units, jobs, positions, or tasks is transferred automatically to employees that are related to the object concerned. Make these assignments using report RHPROFIL0 (Generate user profiles).

The Standard Profiles infotype allows you to specify several authorization profiles in one record.

To restrict the data that is displayed to a user who is working with organizational plans, use the infotype PD Profile.

Before you assign standard profiles, you should consider which object type is best suited to the assignment of authorization profiles.

For example, if authority profiles tend to be fairly standard for all workers in an organizational unit, then it may be most effective to apply profiles to organizational units. (Where exceptions occur for jobs or tasks, you can create additional profiles for them.) If, however, authorities vary by job or task, it may be best to apply profiles to the jobs or tasks concerned.

It is important to note that the profile assigned to a task does not cancel out the profile assigned to a position, or job, or organizational unit. One infotype record does not override another. Rather, all profiles that are applied to an object directly or indirectly are considered valid.

Assigning Profiles to Different Organizational Objects
### Standard Profiles (Infotype 1016)

<table>
<thead>
<tr>
<th>If you assign profiles to</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Individual tasks</td>
<td>The assignment is automatically passed on to the related positions and jobs. You can add supplementary authorizations to the jobs and positions, if required.</td>
</tr>
<tr>
<td>Jobs and positions</td>
<td>You can identify any special (specific) authorities to tasks, if required.</td>
</tr>
<tr>
<td>Organizational units</td>
<td>All jobs and positions assigned to the organizational units receive the same authorizations (and employees, if integration with PA master data is active).</td>
</tr>
</tbody>
</table>
About the PD Profiles Infotype (1017)

Definition
Infotype with which structural authorizations can be created and edited.

Use
Structural authorizations control:
- which objects in the organizational plan a user is permitted to display, for example,
  - Organizational units
  - Qualifications and Requirements
  - Business events
- which activities in the organizational plan a user is permitted to execute, for example,
  - create
  - change
  - display

Authorization profiles are set up in Customizing. Refer to the Personnel Management section of the Implementation Guide (IMG).

If you are working in the Organizational Management component, you must implement safety measures, by creating the PD Profile infotype as well as report RHPROFL0 (Generate user authorizations) or edit table T77UA.

Since PD profiles only affect access to Organizational Management, you must still use the Standard Profiles infotype to enter basic authority privileges. Users require a standard profile, for example, to log on to the system.

Structure
A PD profile contains a list of authorizations, and anything listed in the profile is allowed. You may include an unlimited number of authorities in one profile, and you can append PD profiles to the following objects:
- Organizational units
- Positions
- Jobs
- Tasks (or standard tasks, if you have installed SAP Business Workflow)

Integration
As a stronger safety measure, install the PD profile as well as the standard profile.
Let's assume you only want to display the projected pay for the ‘Special administrator’ position in the system. (The Projected Pay infotype is assigned to positions).

To set this up, you must create the following:

- a Standard Profile infotype record for the position ‘Special administrator’ which allows the position holder to display records from the Projected Pay infotype.
- a PD Profile infotype record for the position ‘Special administrator’ which allows the position holder to display positions.
Cost Distribution (Infotype 1018)

Definition
Infotype which determines how costs are to be distributed between several cost centers.

Use
Costs incurred by an organizational object are usually written to the master cost center directly assigned to the object (master cost center) or the cost center inherited by the object from a superior object. Determine the master cost center in infotype 1001.

Create a record for infotype 1018 if you wish to distribute costs to more than one cost center. Enter which portion of the costs you would like to distribute to which cost center. If the object is already assigned a master cost center, the left-over share will be written to this cost center.

If the object was assigned a master cost center before it was created, you must reconcile cost distribution with this.

Subordinate organizational objects within an organizational unit (positions, work centers) inherit cost distribution, if they have not been assigned their own master cost center or cost distribution.

Structure
A complete record for infotype 1018 includes the following entries:

- an exact classification of every cost center, which is not a master cost center and to which costs are to be distributed (controlling area, object ID and name of the cost center).
- an exact specification of what percentage of costs are to be written to each cost center

If the organizational object has a master cost center, this will be displayed (the entry will be transferred from infotype 1001).

Integration
You can create this infotype for the following organizational object types:

- Organizational Unit [Page 21]
- Position [Page 23]
- Work Center [Page 28]

Cost distribution to additional cost centers is simulated as external relationship A014 in reports.

Cost distribution is used in the following components:

- Personnel Cost Planning
- Payroll and Accounting

Employee costs are written from Payroll to Accounting.

You can also define cost distribution for employees in infotype 0027 [Ext.] in Personnel Administration. If integration between Organizational Management and Personnel Administration (PLOGI ORGA) and the integration of Cost Distribution (PLOGI COSTD)
have been set up in Customizing. If there is a valid record for infotype 0027, employee costs will always be handled according to this cost distribution. Otherwise, employee costs will be distributed according to the record for infotype 1018 which has been defined for the employee's position or work center.

⚠️

Retroactive changes to cost distribution can be relevant to retroactive accounting.
Quota Planning (Infotype 1019)

Definition
Infotype with which you can plan how many positions, defined based on a particular job, or how many full-time equivalents (FTE) you will need in the future for a particular organizational unit.

You can only carry out this planning for organizational units.

Use
You can see all jobs that are being used in a particular organizational unit. You can plan how many positions, defined based on these jobs, or FTEs the organizational unit will need in the future.

In planning you can display how many positions already exist in the organizational unit. You can then add new jobs – with the planned numbers of positions or FTEs.

This infotype is relevant for simple maintenance and the new maintenance interface in Organizational Management, as well as for Manager's Desktop.

Planning in Full-Time Equivalents (FTE)
A full-time equivalent (FTE) is the required capacity expressed in terms of full-time positions. This is calculated by considering the working time of the position as a fraction of the working time of the organizational unit the position is assigned to.

For example, a position has a weekly working time of 20 hours and is assigned to an organizational unit with a working time of 40 hours. You can calculate the value of an FTE by dividing the working time of the position (20) by the working time of the organizational unit (40). This gives an FTE value of 0.5.

Using the WORKT FTEQ switch in table T77S0, you can specify that you want to carry out quota planning in FTE instead of in positions. You can make entries with up to two decimal places.

In addition, you can use the WORKT FTEP switch to determine the value of an FTE with relation to the staffing percentage of the position, taking into account the capacity utilization level of the employee (person). This possibility is particularly useful for the calculation of existing required positions in FTE, where the actual hours worked by an employee (person) in the position are important.

Structure
When setting up quota planning, you should differentiate between the following steps:

1. In table T778U, define the planning types (e.g. first planning, second planning and so on), in other words the subtypes (0001, 0002 and so on) of this infotype.

2. In table T77POSBUD, define the planning type, the time interval (week, month, and so on) and the total planning period.

3. Based on the settings you made in step 2, the system can carry out the actual planning of required positions within the application.
See also the relevant customizing activities in the Implementation Guide (IMG) under Personnel Management -> Organizational Management -> Infotype Settings -> Quota Planning or under Personnel Management -> Manager’s Desktop -> Quota Planning.
About the Site Dependent Info Infotype (1027)

**Definition**
Infotype with which a calendar can be related to an organizational unit.

**Use**
Days on which there is no work are defined in the calendar. Examples of such days are

- Civic or religious holidays
- Any nonworking day unique to a company

For Organizational Management purposes, it is not mandatory to maintain the infotype there, since calendar data provides information only.

However, the Training and Event Management and Shift Planning components of HR do require this information. These modules check calendars, to ensure business events and shifts are planned for days when businesses operate. If you plan to use Training and Event Management or Shift Planning, you must provide calendar information.

A default factory calendar must be set for these two modules. For Training and Event Management, maintain the entry SEMIN ORTCA in table T77S0. For Shift Planning, maintain the entry PEINS CALID in the same table. (Refer to the Personnel Management section of the Implementation Guide (IMG).)

The Site Dependent Info applies only to organizational units and locations whose calendars differ from the default. Use the infotype to identify the correct calendar for the organizational unit, or location, in use.
About the Address Infotype (1028)

Definition
Infotype, with which addresses of companies or external trainees as well as information on the location of organizational objects and resources can be stored.

Use
In Organizational Management, maintain this infotype for
- Organizational units
- Work Centers
- Positions
The information is for reference purposes only. The infotype is optional.
In Training and Event Management, maintain the infotype for
- Business event locations
- Room resources
- External trainees and trainers
- Companies
The Address infotype maintained for the business event location is used in correspondence for notifications such as confirmations of registration, confirmations of attendance. By using a variable in the correspondence, you can control whether the first or second address is to be given.
This infotype must be created for companies or for external attendees and trainers (object type External Person).

Structure
To complete the Address infotype for locations of rooms, enter the following data:
- Name of building
- Room number

Addresses of buildings are created separately. To maintain addresses of buildings for the purposes of room location information, you must have completed the step Set Up Building Address [Ext.] in Customizing for Training and Event Management or in Current Settings.

The following information is also maintained for addresses:
- Telephone number
- Fax number
- 2nd Address line
About the Address Infotype (1028)

- Street, House number
- Postal Code, City
- Country key
- Region
- Distance in kilometers

You can store various addresses by creating subtypes. The following subtypes are set up in the SAP Standard system:

Subtype blank: 1st Address
Subtype 0001: 2nd Address
About the Mail Address Infotype (1032)

Definition
Infotype with which data for message transfer can be created.

Use
The infotype contains details required for the electronic transmission of information, for example, user IDs. You maintain this data for various objects, for example
- Organizational units
- External employees
- Companies

When something happens relating to a reservation – for example, if there is a cancellation – the system checks for all objects involved in the event (the participants, organizers, and so on) and sends notifications.

For Room Reservation Planning purposes, you might define this infotype for the organizational units designated as event organizers, companies, and external persons. However, Customizing allows you to determine the objects to which this infotype applies. Refer to the Personnel Management section of the Implementation Guide (IMG).

Structure
When creating this infotype, you must identify the:
- Name of the electronic mail system used
  (At present, the system supports only the SAP mail system.)
- User ID of the employee responsible for coordinating mail communications in the organizational unit, or company, or work center
- User ID of the external employee, or position holder
- Owner or creator of the distribution list for the organizational unit, or company, or work center

If you are working with an external employee, or position, this information is not required.

Integration
This infotype is not usually set up in the Organizational Management component. There are, however, exceptions. If your company does not use a SAP mail system, you can use this infotype to store information about mail addresses, for positions, or work centers. However, in this case, the information is for reference purposes only. The system cannot do anything with the data.
About the Shift Group Infotype (1039)

Definition
Infotype with which a shift group can be assigned to an organizational unit.

Use
The Shift Group infotype is only used for organizational units and is only used if you are using the Shift Planning Human Resources Component.

A shift group is a collection of individual shifts. For example, a shift group might include the following three shifts:

<table>
<thead>
<tr>
<th>Shift name</th>
<th>Hours worked</th>
</tr>
</thead>
<tbody>
<tr>
<td>Early shift</td>
<td>6 a.m. to 2 p.m.</td>
</tr>
<tr>
<td>Afternoon shift</td>
<td>2 p.m. to 10 p.m.</td>
</tr>
<tr>
<td>Midnight shift</td>
<td>10 p.m. to 6 a.m.</td>
</tr>
</tbody>
</table>

Shift groups are user-defined, so the actual content of a shift group – the number of shifts and the hours worked – can vary. The shift groups themselves are defined in the Shift Planning component of HR.

By assigning shift groups to an organizational unit, you determine the shifts that will be worked in the organizational unit. The characteristics of the shift group, the requirements type, for example, are passed on to the organizational units.

The system uses this information for cross-checking purposes, to ensure the shift plans you set up include the correct shifts and requirement types for each organizational unit you use.

You can only assign one shift group to an organizational unit, at any given time. However, one shift group can be assigned to many different organizational units.

Integration
Shift group assignments can be carried out in the Shift Planning and Organizational Management components of HR.

Refer to the Personnel Management section of the Implementation Guide (IMG).
About the Shift Group Infotype (1039)
SAP Organizational Object (Infotype 1208)

Definition
Infotype with which relationships between SAP organizational objects [Page 105] and objects from Organizational Management (organizational units, positions, jobs and work centers) can be created and edited.

Use
These relationships (or assignments) are relevant only for SAP Business Workflow customers who are using roles [Page 88] to identify agents for the individual tasks in a workflow. See SAP Business Workflow [Ext.]

Integration
There are two areas where you can work with these types of assignments:

- By using this infotype in Infotype Maintenance in Organizational Management
  This is not recommended.
- By using the Assignment of SAP Organizational Objects transaction
  This is recommended. See Assigning SAP Organizational Objects [Page 107]
General Attribute Maintenance (Infotype 1222)

Definition
Infotype, in which you can store as much data on Organizational Management objects as you require.

Use
The infotype allows you to store data generically in the form of key values (or value ranges). Data can be divided logically using scenarios.

Every attribute (key/value pair) has particular characteristics, for example
- a reference to the Data Dictionary
- specific F4 help
- special types of inheritance

These characteristics must be determined in the same way as the permitted attributes per scenario in Customizing.

The data from the organizational plan can be read in order to, for example, find the organizational unit responsible for an order.

This infotype is only used in Customer Relationship Management.

Structure
Each scenario corresponds to a subtype of infotype 1222. All necessary modules for reading attributes are grouped in the function group RHOMATTRBIUTES.

Integration
You can access Customizing for the scenarios and attributes via the viewcluster T77OMATTR.
Planning Tools

Definition

To maximise the planning benefits of the Organizational Management component, use the following planning tools:

- **Status**
  
  To streamline your planning processes, use the statuses active, planned, submitted, approved or rejected.

- **Plan versions**
  
  To maintain multiple copies of the same or similar plans on the system, use plan versions. You can then plan and evaluate possible organizational changes without affecting the active plan version.

- **Validity dates**
  
  Use validity dates to define the lifespan of an object or object attribute.

- **Time constraints**
  
  Time constraints are used internally by the system to protect the integrity of information such as infotypes, subtypes and relationships.

- **Aspects**
  
  Use aspects to filter out the type of objects that can be maintained, and the type of infotypes that can be maintained for each object.
Plan Version

Definition
A plan version is a designated area where you deposit different sets of information. A single plan version may contain information maintained in any or several of the Human Resources components.

Use
You may maintain an unlimited number of plan versions in your system. This enables you to use different plans to experiment with various scenarios for your company. One plan might reflect current day-to-day operations at your firm. Another might reflect your company after a planned merger takes place. It is important to note that there is no link between information maintained in separate plan versions.

The organizational plan can be one of many subsets of information in the plan version. Alternatively, you can create a plan version containing only an organizational plan – or single set of information – within Organizational Management. In that case, the organizational plan is the single component of a plan version.

You can maintain a number of nonplan versions in the system.

Structure
You differentiate between plan versions by assigning each a unique code. Codes are user-defined and alphanumeric. These are maintained in the plan version table (for details, refer to the Personnel Management section of the Implementation Guide [IMG].)
Validity Period

Definition
Validity periods identify the lifespan of an object or infotype record – or the period of time when an object or infotype record ‘exists’.

Use
You must apply validity periods to every object and infotype you create. You do so so that your organizational plan can reflect the many changes that occur within your company. You then have a fluid or dynamic view of your company, rather than a static record.

A validity period consists of a start date and an end date. An object or infotype record ‘exists’ for the range of time specified by the two dates.

Validity periods for objects
When you create objects, the system automatically proposes either the current date as the start date, or the last start date you used in your work session. For the end date, the system proposes your system default date – usually 31.12.9999. You may enter a different start date, but you cannot enter your own end date.

Once an object’s validity period is established, you can only change it using the delimit function.

Validity periods for infotype records
The validity period you assign to an object limits the validity period you may assign to any infotype records appended to the object. Infotype record validity periods cannot exceed the validity period applied to the object itself.

When you work with infotypes, the system automatically proposes the current date as the start date. For the end date, the system uses the end date defined for the object you are working with.

You may enter a different start date or end date, provided the:

- Start date assigned to the infotype record is not earlier than the start date applied to the object
- End date assigned to the infotype is not later than the end date applied to the object

Once you have saved the start date of an infotype record, you cannot change it. You can change the end date by using the delimit function.


**Time Constraints**

**Definition**

Time constraints are a tool used internally by the system to protect the integrity of information maintained in *Organizational Management*.

**Use**

You use time constraints to prevent you from creating records that contradict each other. For example, a position can belong to only one organizational unit at one time. If the system allowed you to assign the position to another organizational unit during the same timeframe, there will be two contradictory records. Then, if you try to report on the data, the information will be useless.

**Structure**

There are four classes of time constraints:

**Time constraint 0**

This allows for:

- A maximum of one infotype record of the same type and for the same object, to exist at the same period of time
- No changes to be made to the record at all

**Time constraint 1**

This allows for:

- A maximum of one infotype record of the same type and for the same object, to exist at the same period of time
- No gaps to exist between the records
- Some changes to be made to the attributes of the record

**Time constraint 2**

This allows for:

- A maximum of one infotype record of the same type and for the same object, to exist at the same period of time
- Gaps to exist between valid records

**Time constraint 3**

This allows for:

- Multiple infotype records of the same type and for the same object, to exist at the same period of time
- Gaps to exist between valid records. For example, there could be a three-year gap between the validity periods of two infotype records that exist for the same object.
Integration

Time constraints work interdependently with validity periods. They determine which combination of validity periods are allowed among the different types of records you create and maintain in Organizational Management.
Status

Definition
Status identifies the current standing that an object or infotype record has within an organizational plan. Status also affects the type of editing you can do. There are five statuses available:

- Active
- Planned
- Submitted
- Approved
- Rejected

Objects with different status can appear in the same plan version. The active objects could represent current operations at your firm, and the planned objects could represent changes you plan to make, for example, adding a new department or new position.

Use
You must assign a status to every object and infotype record you create. However, you do not need to use all the statuses. Many users choose only to use active status.

How you apply status to objects and infotype records in Organizational Management, depends on the method you use to maintain an organizational plan – Detail Maintenance, Simple Maintenance, or Structural Graphics.

Applying status according to method

<table>
<thead>
<tr>
<th>If you are in ...</th>
<th>You ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detail Maintenance</td>
<td>Apply status to objects and infotype records one at a time. Applying a status is part of the creation process. You can select a default status here. This can save you data entry time if you work with the same status much of the time.</td>
</tr>
<tr>
<td>Structural Graphics</td>
<td>Cannot apply status one at a time. A default status is selected, and then that status is applied to all objects and infotype records created. You can, however, change the default status.</td>
</tr>
<tr>
<td>Simple Maintenance</td>
<td>Cannot select status. A default status of active is applied to all objects and infotype records created.</td>
</tr>
</tbody>
</table>

Structure
Status attributes:

- Active
  Indicates that an object is currently operable. You have unrestricted activities – you can create, change, display, delimit, delete and list when using active objects.

- Planned
Status

Indicates that an object is proposed or anticipated, but not currently operable. You can create, change, display, delimit, delete and list when using planned objects.

- **Submitted**
  Indicates that an object has been submitted for review and subsequent approval/rejection. You cannot create objects with submitted status. Nor can you make changes.

- **Approved**
  Indicates that an object, previously submitted for review, is accepted or authorized. By changing the status to active, you can edit the object (create, change, display, delimit, delete and list).

- **Rejected**
  Indicates that an object is rejected or turned down. You can only display objects with rejected status. However, you can change the status to planned so that you can work with the object again.

**Integration**

There are two ways you can change the status applied to objects and infotype records, in Organizational Plan:

- Run the report RHAKT100 (*Change Object Status*) for selected objects or infotype records
- Change the status of objects and infotype records one at a time in *Detail Maintenance*

It is not possible to change the status of objects or infotype records in *Structural Graphics* or *Simple Maintenance*.
Integration with SAP Business Workflow

Purpose

The main purpose of SAP Business Workflow [Ext.] is to get the right task to the right agent (organizational unit, position, job or user) at the right time. This speeds up the completion of business processes. Organizational Management provides the framework for a routing structure that SAP Business Workflow uses for task assignment at runtime. By scrolling through the complex network of relationships in an organizational plan [Page 17], SAP Business Workflow is able to pinpoint exactly where tasks should be routed. This organizational plan provides you with:

- a flexible model of your company on the system, which you can manipulate to reflect actual and proposed human resources scenarios
- a structure along which you can route your business processes

There are two possible cases:

- The Organizational Management component is used for human resources purposes in your enterprise. In this case, you use the organizational plan for human resources purposes as well as for workflow. As long as integration between Personnel Administration and Organizational Management is active, you can assign tasks to both users and employees. You can assign users to employees in the Communication (0105) [Ext.] infotype.

- The Organizational Management component is not used in your enterprise. In this case, you create only a small part of your organizational plan in order that all workflows may run. As there is no integration with Human Resources, you can only assign tasks to users.

To reduce the number of agents found, or to restrict the number of agents responsible, you can use Role Resolution [Page 86].

Prerequisites

In order for Workflow to distribute tasks across your organization, you must first create the necessary organizational plan structures in the system.

Process flow

1. Familiarise yourself with the task distribution relevant to workflow in your enterprise.

2. Create an organizational plan, or part of an organizational plan in Simple Maintenance in Expert mode or in the Organization and Staffing (Workflow) view.

   For more information on creating an organizational plan, see About Simple Maintenance [Page 228] (expert mode) or Organization and Staffing (Workflow) [Ext.].

3. So that you can use SAP Business Workflow, assign tasks to the organizational objects (organizational units, positions, persons and/or users). There are various Task types which allow you to do this.

   For more information on creating and editing tasks, see Tasks and Task Groups [Ext.].

4. Define roles as required.

   For more information, see Role Resolution [Page 86].

5. You can use the organizational plan you create in SAP Business Workflow.
Integration with SAP Business Workflow

For more information on working with SAP Business Workflow, see SAP Business Workflow [Ext.].
Role Resolution

Use
Role resolution enables you to restrict the number of possible agents for a work item. Role resolution determines which responsible agents have a property described by a role [Page 88]. This improves the ability of SAP Business Workflow [Ext.] to get the right task to the right person at the right time.

Integration
The tools used to define roles [Page 93] are part of the Organizational Management component. At runtime, the SAP Business Workflow component uses the roles defined here in conjunction with the organizational plan for role resolution to determine agents for work items. (Decision as to which tasks must be assigned to which agents)

Prerequisites
To facilitate role resolution, roles must be defined [Page 93].

Features
The system performs role resolution. It is first performed at runtime depending on and using information from the process currently running.

The example refers to the role "orders administrator for customer <customer> as of order amount <order amount>".

If customer "Miller Ltd." and order amount "$34,569.34" are determined for a specific order, the agents are determined at workflow runtime who are the "orders administrator for customer Miller Ltd. as of order amount $34,569.34".

The principle of role resolution is always the same:

- The contents of the role container are read.
- The “regulations” or “rules” resulting from the role type are applied to this data.
- The agents so determined are returned as the role resolution result to an internal table with the structure SWHACTOR. This table contains the agents as Organizational Management objects (user, person, position, job, organizational unit) in the required "mix".

The type of role determines how role resolution is performed exactly. You can determine the type of role when defining a role.
Role

Definition

Object used by the SAP Business Workflow component to determine possible agents for a work item.

Use

You use roles to specify an agent (or agents) for a task if the set of possible agents is too large, or not specific enough. By assigning work items to organizationally suitable employees, responsibilities and authorizations are managed efficiently, and bottlenecks are avoided.

You want to forward Mr. Smith’s notification of absence to his head of department. All heads of department at your enterprise are possible agents for a notification of absence. However, you do not want every head of department to receive Mr. Smith’s notification of absence. At runtime, the role used to determine a manager [Page 128] enables you to evaluate assignments (relationships) within an organizational plan. The system uses relationships to determine that Ms. Miller is Mr. Smith’s head of department. The task is forwarded to Ms. Miller.

Further examples:

Role to Determine Design Office [Page 121]
Role to Determine Organizational Unit of a User [Page 134]

The agent for a role does not have to be a user. All of the objects in the Organizational Management component can be agents for a role.

The workflow uses the values in the role container to select a subset of possible agents. Role resolution, which is performed at runtime to determine the agent for a workflow step, is therefore an intelligent, efficient, and flexible tool.

Roles as Default Roles for Defining Single-Step Tasks

When defining single-step tasks [Ext.], you can specify particular agents or recipients by their role in the following instances:

- Agent for task
- Recipient for completion
- Recipient for missed latest end
- Recipient for missed start
- Recipient for missed end

In this context, reference is made to default roles for a task. Specifying default roles for a single-step task is always optional. If default roles are specified, you may need to define binding from the task container to the role container.

Resolution is performed for default roles before the single-step task is executed. (If the single-step task is used as a step in a workflow definition, resolution is only performed for default roles if the workflow definition contains no other information with regard to responsibilities or recipients.)
As a general rule, a single-step task can only be executed by its possible agents (or a subset thereof) when it is processed.

Specifying a role restricts these agents to those you have selected. This method cannot be used to authorize new agents to execute a customer task/standard task.

**Roles in Workflow Definition**

When the following steps of a [Workflow Definition](#) are defined, the agents responsible and the recipients can be specified by their role:

- Activities
- Wait steps
- User decisions

These specifications only have local validity for the respective workflow definition, and they are optional.

(Specifying a role is just one of several methods that can be used to specify the agents responsible and the recipients. It is also possible to specify responsibility by using a suitable organizational object (job, position, organizational unit) or by using an expression [Ext.] with reference to the workflow container.)

**Structure**

There are various ways of defining roles. You can use the following:

- **Function modules**
  
  You use a function module to define standard roles if the agent for a task must be found according to extremely complex selection criteria. If you define roles using function modules, the system finds agents by executing the function. How data is obtained varies from function to function. You can use predefined functions, or create your own functions.

- **Organizational data**
  
  You use organizational data to define standard roles if your business processes are managed on the basis of your organization model. If you define roles using organizational data, role resolution traces the possible agents for a task by using the relationships between the task, the objects in Organizational Management, and the SAP organizational objects.

- **Responsibilities**
  
  You use responsibilities to define standard roles if you need more precise selection criteria to find agents, but do not want to use function modules. You can also use the organization model to find possible agents using jobs, positions, etc.

All three methods offer certain advantages. However, it is preferable to use responsibilities because you do not require ABAP coding, and can easily display and change agent assignments. You can define as many criteria for a role as required, even if you only want to use some of these criteria for the responsibilities.

Each role has a [role container](#) that includes the values on which role resolution is based.
Role

Roles are always defined across clients, and they are always connected to the transport system as cross-client transport objects. At this time, the definition of client-specific roles is not supported.

When saved, each role is assigned an 8-digit number by the system that is preceded by AC, which is used for identification purposes.
Role Container

Use

The role container contains a role’s parameters. Each role has just one role container. At runtime, the role parameters contain the current, context-specific information that forms the basis of role resolution. Therefore, the role parameters constitute “input” for role resolution.

The role parameters are provided with values from the workflow container via binding.

Features

Depending on the role resolution procedure, the role container includes the following information:

<table>
<thead>
<tr>
<th>Role resolution procedure</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Based on responsibilities</td>
<td>The role container includes object references or field values (with names as required) that must be provided with values from the calling component via binding.</td>
</tr>
<tr>
<td>Including organizational data</td>
<td>The role container only includes the Org_Object_ID element. This element is defined with a reference to the SAP organizational object whose assigned agents must be determined. The role container is created automatically, and is not visible during role definition.</td>
</tr>
<tr>
<td>By executing a function module</td>
<td>The role container includes object references or field values as required (with names as required) that are read by the function module for role resolution and processed accordingly. Prior to role resolution, the container elements are provided with values from the task container via binding.</td>
</tr>
</tbody>
</table>
| Based on evaluation paths                  | The role container includes the following elements:  
  - OType, data type reference OBJEC-OTYPE
    Type of object in Organizational Management according to the first step in the evaluation path
  - ObjID, data type reference OBJEC-REALO
    Identification of organizational object.
  - Org_Agent, data type reference WFSYST-AGENT
    C14 field as combination of organizational object type and organizational object.

When defining the role, create either the first two elements, or the last element, as role parameters in the container.
Role Container

**Activities**

You maintain the role container on the *Container* tab page when maintaining the roles.
Role Definition

Use
You use this function if you want to define more roles in addition to the roles delivered by SAP.

Prerequisites
Before you start defining roles, you must start the workflow process.

1. Decide what you want the workflow to achieve, and break it down to the smallest meaningful units of work. These units of work become single-step tasks in your workflow.

2. Select the objects you require. To do so, create a business object or use one of the existing objects. You should be able to find an object that you can use in the Business Object Repository.

3. Each task accesses an object method. Make sure that the methods you require already exist.

4. Create the tasks, or use the existing tasks. Define the possible agents for the task in the task definition.

5. Group the tasks together in the workflow.

6. Assign agents to the work items in the workflow definition. They must be a subset of the possible agents for the task. If this is not the case, the work item is not executed.

You can do this manually, as a 1:1 assignment, or by using role resolution.

For more information, see SAP Business Workflow [Ext.].

Features
When defining a role, you determine

- Which information must be available so that role resolution can be performed when the workflow is executed.
  
  This information constitutes the role parameters. They are defined as elements of the role container.

- The rules or regulations in role resolution that are used to determine the appropriate employees.

  The role resolution procedure is determined by the role type.

The Responsibilities Role Type
When role resolution is performed, an assignment table is evaluated in which Organizational Management objects (jobs, positions, users, organizational units) are assigned to the various characteristics of the role parameters. This assignment table was explicitly created during role definition.

For more information, see Define Roles Using Responsibilities [Page 96].
Role Definition

The Organizational Data Role Type

When role resolution is performed, the system evaluates SAP organizational objects, such as materials controller, planner group, shipping point, or sales office, which are maintained in the master data of an application object.

This type of role resolution requires the use of a separate maintenance transaction independent of role definition to create assignments between the SAP organizational objects and the organizational objects in Organizational Management (jobs, positions, users, organizational units) with which they are related.

For more information, see Define Roles Using Organizational Data [Page 103].

The Function to be Executed Role Type

When role resolution is performed, a function module is accessed that then facilitates evaluations as required. A table that is maintained in Customizing is evaluated by the function module. The function module must adhere to a given interface, and is specified during role definition.

For more information, see Define Roles Using Function to be Executed [Page 122].

Role Resolution Based on Evaluation Paths

When role resolution is performed, the system uses information that is available in Organizational Management on the basis of relationships between individual objects that are maintained in an organizational plan.

This information can be used, for example, if you need to determine the head of an organizational unit, or the remaining members of the organizational unit, starting from the initiator of the workflow.

From a technical perspective, this role resolution is very similar to role resolution by executing a function module. The RH_GET_STRUCTURE function module must be used; an evaluation path is also specified.

For more information, see Role Resolution Using Evaluation Paths [Page 129].

Activities

If you want to use role resolution to restrict the number of possible agents for a work item in a workflow, you must:

1. Choose SAP menu → Tools → Business Workflow → Development → Definition tools → Standard roles to select the tools used to define roles
2. Decide how you want to find agents in the system, that is, using function modules, organizational data, or responsibilities
3. Create a container definition (not for the organizational data role type)
4. Binding is automatically suggested for the workflow. Confirm that the fields in the role container are compatible with the fields in the workflow container.
5. Start the workflow.

At runtime, role resolution provides you with a table containing a set of possible agents. These agents are determined at runtime using the values assigned to the role container elements.
Define Roles Using Responsibilities

Use
A responsibility is an organizational object in which you group criteria together that are required by the workflow at runtime to assign work items to possible agents. This type of criteria definition does not require Customizing settings or ABAP coding.

If you use responsibilities for role definition, you enjoy numerous advantages. You can

- Use criteria that you select as required
- Work with value ranges or individual values
- Display (and change) user assignments
- Group several criteria together in a responsibility

Prerequisites
Before defining roles, you must define workflow steps using the procedure described in SAP Business Workflow [Ext]. You then define the tasks that must be executed. Finally, you use roles to assign and find a list of possible agents for the task at runtime.

Procedure
Responsibilities can only be created for existing standard roles.

To define roles using responsibilities, proceed as follows:

1. Create a container definition [Page 98]
   A container is a generic structure that transfers data at runtime. You must create the container definition first because the responsibility depends on the data that you select in the container. You must define a container element for each criterion that you select for the evaluation at runtime.

2. Create a responsibility [Page 100], and define criteria (individual values or value ranges) in the responsibility editor for the container elements.
   At this point, you can also process the values and display the container elements.

3. Assign users or organizational objects to the responsibility [Page 102]
   If the values in the role container are compatible at runtime with the criteria defined for a responsibility, the organizational objects assigned to this responsibility are identified as possible agents for the work item.

Result
If the values in the role container are compatible with the criteria defined for the responsibilities, SAP Business Workflow identifies the possible agents for a work item. As a result, the right person receives the right work item at the right time. This ensures that business processes at your enterprise run efficiently and on schedule.
Creating a Container Definition

Prerequisites

A container definition informs the system about the data type processed by the workflow.

You must decide whether you want to create a container definition that references table fields or object types. When the container definition references object types, you use values in the key fields of objects to restrict the list of possible agents. When the container definition references Data Dictionary fields, you can use specific data such as the amount of an order or the customer name on an invoice to restrict the list of possible agents.

To call the transaction for processing roles, access the SAP menu and choose Tools → Business Workflow → Development → Definition tools → Standard roles → Create.

The Maintain Standard Role screen appears.

Creating a Container Definition with Table Fields

1. Choose Create.
   The Standard Role: Create screen appears.
2. Enter a name for your standard role in the Basic Data box.
3. Select the role type Responsibilities.
4. Choose Container Definition in the Role Definition box.
   The Standard Role: Process Container screen appears.
5. Choose Create.
   The Create Element dialog box appears.
6. If you want to use Data Dictionary fields, choose Yes.
   The Create with Data Dictionary Field Defaults dialog box appears.
7. Specify the table from which you want to select fields and Choose Continue.
   The table appears.
8. Select the fields that you want to appear in the container definition and confirm your entries by choosing Continue.
   The system prompts you to create the texts for the container elements in the Create dialog box.
   The Element <....> dialog box appears. If you select the required indicator, an error will occur in the workflow if no binding has been defined for the element. If you select the multiple lines indicator, you can specify multiple values for one container element. You can select both indicators. Choose Continue.
10. Choose Back.
    The Standard Role: Create screen appears.
**Creating a Container Definition with Object Types**

Carry out steps 1 to 5, and then proceed as follows:

6. If you want to use object types, choose *No*.
   
   The *Standard Role: Process Container* screen appears.

7. Enter a name for the element. If you select the *required* indicator, an error will occur in the workflow if no binding has been defined for the element. If you select the *multiple lines* indicator, you can specify multiple values for one container element. You can select both indicators.

8. Select the object type you want to reference, and choose *Continue*.
   
   The *Standard Role: Process Container* screen appears.

9. Choose *Back*.
   
   The *Standard Role: Create* screen appears.

**Result**

You have created a container definition with either Data Dictionary fields or object types as elements. You use these elements to define the criteria for role resolution.
Creating a Responsibility

Creating a Responsibility

Prerequisites

Before you create responsibilities, you must Create a Container Definition [Page 98]. The values in the role container must either agree with the criteria defined for the responsibility or be in their area. The reason for this is that role resolution compares the two values in order to return a list of possible agents.

If you have created a container definition, the Responsibilities button appears on the Add Standard Role screen in the Role definition group box. If you are no longer on the Standard Role Definition screen, then in the SAP Standard Menu, choose Tools → Business Workflow → Development → Definition Tools → Standard Roles → Change and enter the required role. Choose Change.

Creating a Responsibility

On the Standard Role: Create screen:

1. Choose Responsibilities from the Role definition group box.

   The Responsibilities: Change screen appears.

2. Select the superior object (the role you are creating) and choose Create.

   The Create Responsibility screen appears.

3. Enter the name and the validity period of the responsibility and confirm your entries.

   The Change responsibilities for standard role screen appears. This is the responsibility editor.

4. Define values (either single values or value areas) and choose Save.

5. If you do not want to check all criteria for a particular responsibility, leave this line blank.

   The LED display turns yellow, to make you aware that some of the criteria of the standard role will not be checked for this responsibility.

Responsibility Editor

On the Change responsibilities screen, select the responsibility that you wish to edit and choose Change. The Change responsibilities for standard role screen appears. You can:

- Edit the values for each element
- Create a description for a responsibility
- Display a container definition
- Display details on each element

Result

You have created a responsibility with container elements.
Assigning Agents

Prerequisites
You must first create a container definition [Page 98] and then create a responsibility [Page 100], in which you define criteria for the container values. You then assign an agent to each responsibility.

If you are no longer on the Standard Role Definition screen, then in the SAP Standard Menu, choose Tools → Business Workflow → Development → Definition Tools → Standard Roles → Change and enter the required role. Choose Change and on the Standard Role: Change screen, choose Goto → Responsibilities.

Procedure
On the Responsibilities: Change screen:

1. Select the responsibility you want to assign to an agent and choose Edit → Agent assignment → Create.
   The Selection dialog box appears.

2. Select the organizational object type you want to assign as an agent and choose Continue.
   The system asks you to enter a search term and to create the relationship between the responsibility and the selected object. Confirm your entries.

   In the Overall View, you can also specify a validity period for the relationship.

Result
At runtime, the workflow evaluates the possible agents and ensures that the right tasks are routed to the right agents at the right time.
Defining Roles Using Organizational Data

Use
A Business Object is often related with an organizational entity (such as MRP controller, laboratory, sales group, purchasing organization, or planner group) by virtue of its master data. From a technical perspective, organizational entities are represented by object types in the Business Object Repository. The indicator organizational type in their basic data defines such object types as SAP Organizational Objects [Page 105]. The attributes of an application object type can be defined with a data type reference to a SAP organizational object type.

These can be evaluated for role resolution purposes to locate the agent of a step. For this to function correctly, you must assign specific agents in the form of positions or organizational units from Organizational Management to the abstract SAP organizational objects. At runtime, these assignments are evaluated in a role resolution if the required input data is available.

The role resolution finds a valid organizational object from Organizational Management as output data.

There are some changes required to be made to material master data.
This task should be routed to employees in the Laboratory/Design Office stored in their material master data. SAP delivers the sample role LABOR from the SAP Organizational Objects for agent determination purposes. For more information, see Role to Determine a Design Office [Page 121].

Someone should contact the supplier of a certain material.
This task should be routed to employees in the purchasing group stored in the material master data.

Procedure

Relationship Between Organizational Plan and SAP Organizational Objects
You have to set up a relationship between SAP Organizational Objects and the corresponding organizational units or positions in the organizational plan. This step must always be performed because the organizational plan is set up by each customer specific to the enterprise.

For more information, see Assign SAP Organizational Objects [Page 107].

Definition of a Role for Evaluating this Relationship
You define a role according to a predefined schema that can evaluate the above relationship between the organizational plan and SAP Organizational Objects. This step is only required if you cannot use any of the roles delivered in the standard system.

For more information, see Defining Roles [Page 116].
Defining Roles Using Organizational Data

Entering the Role for Specifying Responsibility

You enter the role as agent of an activity or a single-step task and maintain the role container binding.

For more information, see Defining Binding [Page 117].

The single step task Material Master: Maintain Design Data should always be processed by the MRP controller responsible for the material.

**Definition time:** The role Determine laboratory/design office is specified as the role of the agent of the step Material Master: Maintain Design Data. The binding definition is &Material.Labor& (Workflow Container) -> ORG_OBJECT_ID (Role container).

**Run time:** The material H4 Lamp, for example, is processed by the task. When the material is known, the agent determined for the work item could be the user that has the role of MRP controller for this material.

Result

At runtime, the workflow determines what organizational objects have the actual values of the key fields of the SAP organizational objects assigned to them. These organizational objects become the agents for the work items.

For more information, see Agent as Attribute of SAP Organizational Object [Page 118].
SAP Organizational Object

Definition

Instance of an SAP Organizational object type defined in the Business Object Repository.

Use

You can route tasks to the appropriate users by creating relationships between SAP Organizational Objects – which reside in the Business Object Repository (BOR) – and the Organizational Management objects. The system finds an agent by tracing the relationships between the task, the SAP Organizational Object and the Organizational Management object.

Before you can edit object assignments, you must choose the objects with which you want to work. You can then create relationships between the two kinds of objects. This allows you to use roles to identify potential agents for tasks in SAP Business Workflow. Once you have created these object assignments, you can edit, delete, delimit, and view them.

SAP Organizational object types represent organizational units on the object type level in the Business Object Repository. These units are used to form and describe employee groups.

Examples of organizational units and corresponding SAP organizational object types are:

<table>
<thead>
<tr>
<th>Object Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BUS0005</td>
<td>Shipping point</td>
</tr>
<tr>
<td>BUS0007</td>
<td>Purchasing organization</td>
</tr>
<tr>
<td>SAP_40132</td>
<td>Work scheduler group</td>
</tr>
<tr>
<td>T024</td>
<td>Purchasing groups</td>
</tr>
<tr>
<td>T024D</td>
<td>MRP controller</td>
</tr>
<tr>
<td>T024L</td>
<td>Laboratory/office for material</td>
</tr>
<tr>
<td>TVKGR</td>
<td>Sales group</td>
</tr>
</tbody>
</table>

What does SAP deliver?

The attribute relationships between Business object types and SAP organizational object types mentioned above are, as a rule, already defined in the Business Object Repository.

Structure

A relationship between an SAP organizational object and a business object type is defined in such a way that the SAP organizational object is available as an attribute of an application object.
SAP Organizational Object

For the object type **BUS1001 (material)**, the attribute **Laboratory** is defined by a data type preference from object type **T024L (laboratory/design office for material)**.

**Integration**

SAP Organizational Objects must be entered in table T7791, in order for these assignments to **Organizational Management** objects to be possible. This table is preset in the appropriate format, and you can add new entries.
Assigning SAP Organizational Objects

Use
So that you can define roles using organizational data, you must create and edit assignments between SAP organizational objects and Organizational Management organizational objects.

For example, you want to restrict the task of buying certain materials to certain individuals within a specific organizational unit. This is achieved by creating an assignment between a purchasing group (purchasing groups are SAP Organizational Objects) and an organizational unit.

You can create assignments between any object classified as an SAP Organizational Object, and the Organizational Management objects – organizational units, positions, jobs, and work centers. You apply a validity period to these assignments, so that changes in responsibility can be shown.

Procedure
1. From the SAP menu, choose Tools → Business Workflow → Development → Definition tools → Organizational Management → SAP Org. Objects → Create Assignments.
   The Assignment to SAP Organizational Objects: Initial screen appears.
2. In the Organizational unit and Selection period fields, identify the Organizational Management objects you want to edit.
   Entries in these fields allow you to confine the objects you edit to:
   - A specific area of the organizational plan
   - Objects in the organizational plan that are valid during a specified time frame
   Enter a superior organizational unit if you want to create a relationship between an SAP organizational object and a position. You will subsequently be able to navigate from the selected organizational unit to the object.
3. In the View dialog box, select the SAP Organizational Objects you want to edit. You can choose either:
   - Organizational object type
     You confine your work to specific SAP Organizational Object Types. This reduces the number of steps you perform later, if creating assignments.
   - All organizational object types
     You can work with all types of SAP Organizational Objects. Select an object.

Assignments between SAP organizational objects and organizational objects from Organizational Management can also be created in Infotype 1208 [Page 75].
Creating Object Assignments

Prerequisites

You want to create a relationship between an organizational unit or a position and an SAP organizational object, in order to create the link between positions and MRP controllers or organizational units and design offices.

Prerequisites

You are in the Assigning SAP Organizational Objects: Initial screen and have selected the organizational unit and SAP organizational object, which you want to edit. (See Assigning SAP Organizational Objects [Page 107])

Procedure

1. Choose Assignment → Change.
   
   Another screen appears, displaying the Organizational Management objects you selected.

   The tree structure can display additional information, including existing assignments with SAP Organizational Objects, and other Organizational Management objects in the organizational plan. To adjust the data displayed so that it meets your requirements, choose View.

2. Select the Organizational Management object you want to assign.

3. Choose Assignment → Create.

4. The procedure now varies, depending on the selections made in step 2:

5. If you are working with a specific SAP Organizational Object type, the appropriate dialog box appears, in which you can identify a specific object (for example, a specific purchasing group).
   
   Make the appropriate selections from the dialog boxes.

   If you are working with all SAP Organizational Object types, a series of dialog boxes appears, allowing you to identify the type of SAP Organizational Object type you want to work with, and then a specific object.
   
   Make the appropriate selections from the dialog boxes.

   You want to create a relationship between the organizational unit 50001285 and the SAP organizational object Laboratory, which is described by the key field 002.

   To do so, create a new relationship between the organizational unit and the SAP organizational object T024L (Laboratory). A dialog box appears in which you can specify the key field for this SAP organizational object.
Creating Object Assignments

**Result**

The system saves the assignment and displays it in the tree structure.
**Function Module**

The following function module enables you to set up a relationship between an SAP organizational object and a position or organizational unit:

**RH_SAP_ORG_OBJEC_RELATE**

Assigns an SAP organizational object to an object in Organizational Management

**Interface**

**Export Parameters**

- **ACT_OBJTYPE**, reference field P1208-OBJTYP
- **ACT_OBJKEY**, reference field P1208-OBJKEY

**Exceptions**

- **SAP_OBJECT_KEY_NOT_VALID**

When the function module is accessed, you specify the SAP organizational object type (name is taken from the Business Object Repository) and the object type-specific key that is used to uniquely identify an object of this type.

You assign an organizational unit to this SAP organizational object in the input field. This relationship is transferred to Organizational Management.
Delimiting Object Assignments

Use
You can delimit object assignments to change the validity period applied to the relationship between an Organizational Management object and an SAP Organizational Object, so that the end date occurs sooner than stated.

It can be necessary to delimit the object assignment, for example, if you plan to redirect responsibility for a task at a specific time in the future.

Prerequisites
You are in the Assigning SAP Organizational Objects: Initial screen and have selected the organizational unit and SAP organizational object, which you want to edit. (See Assigning SAP Organizational Objects [Page 107])

Procedure
1. Choose Assignment → Change.

   Another screen appears, displaying the Organizational Management objects you selected.

   ![Tree structure]

   The tree structure can display additional information, including existing assignments with SAP Organizational Objects, and other Organizational Management objects in the organizational plan. To adjust the data displayed so that it meets your requirements, choose View.

2. Select the assignment that should be delimited:
   a) Locate the two objects in the assignment in the tree structure
   b) Choose the object that is at the lower level of the tree structure

3. Choose Assignment → Delimit.

   A screen appears, displaying the assignment information.

4. In the second Validity field, enter the appropriate end date for the validity period.

5. Choose SAP OrgObjects → Delimit.

   A message appears confirming the system has delimited the assignment.
Deleting Object Assignments

Use

You should only delete assignments between Organizational Management objects and SAP Organizational Objects only if you want to erase all record of an assignment from the database.

⚠️ Deletions should only be necessary if positions have been created incorrectly or by accident. If you want to indicate that responsibilities have changed, use the delimit feature instead.

Prerequisites

You are in the Assigning SAP Organizational Objects: Initial screen and have selected the organizational unit and SAP organizational object, which you want to edit. (See Assigning SAP Organizational Objects [Page 107])

Procedure

1. Choose Assignment → Change.

   Another screen appears, displaying the Organizational Management objects you selected.

   The tree structure can display additional information, including existing assignments with SAP Organizational Objects, and other Organizational Management objects in the organizational plan. To adjust the data displayed so that it meets your requirements, choose View.

2. Select the assignment, which you want to delete:
   a) Locate the two objects in the assignment in the tree structure
   b) Choose the object that is at the lower level of the tree structure

3. Choose Assignment → Delete.

   A message appears asking you to confirm that you want to delete.

4. Choose Yes.

   The system deletes the assignment.
Define Role

Prerequisites
You want to define a role whose resolution refers to an SAP organizational object type.

Procedure
1. Create a new role. To call the transaction for processing roles, access the SAP menu and choose Tools → Business Workflow → Development → Definition tools → Standard roles → Create.
2. Select the Organizational data checkbox.
3. Specify an SAP organizational object type.

Result
The role container is created automatically. It includes just one element, Org_Object_ID, in which the object reference to the SAP organizational object is stored.

In this instance, you do not need to specify a function module or define a role container when defining the role.
**Define Binding**

**Prerequisites**

You have used your role container to create a role whose resolution is based on the evaluation of organizational data. For more information, see Define Role [Page 116].

To "provide" the role container with the object reference to the SAP organizational object, you now define binding for the role container:

- If you use the role for a single-step task, you define binding from the task container.
- If you use the role for a step, you define binding from the workflow container.

**Procedure**

Assign the following to the role container element: an expression that references the SAP organizational object as an attribute of the application object to be processed.

Org_Object_ID <= &<object reference>.<object reference>&

At runtime, the object reference to the processed object of the type *material* is included in the workflow container under the name Material. You assign the laboratory attribute of this object to the role container in the binding definition. By doing so, you take advantage of the fact that an attribute has been created for the *material* object type under the name Laboratory that includes an object reference to the design office. You define binding as follows:

<table>
<thead>
<tr>
<th>Org_Object_ID</th>
<th>&lt;=</th>
<th>&amp;Material.Labor&amp;</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Role container)</td>
<td></td>
<td>(Workflow container)</td>
</tr>
</tbody>
</table>
Agent as Attribute of SAP Organizational Object

Use

Organizational entities, which are specified in the master data of a business object, are usually supported by positions or organizational units, which may need to be addressed as the recipient of a work item. The following description illustrates the procedure used to determine these agents on the basis of organizational entities, and how they are indirectly available as attributes of the business object.

SAP Organizational Object Types

Prerequisites

Business Object Type and SAP Organizational Object Type

From a technical perspective, organizational entities are represented by SAP organizational objects [Page 105] in the Business Object Repository.

The attributes of an application object type can be defined with references to these SAP organizational object types.

SAP Organizational Object Type and the IFSTROBJCT Interface

Each SAP organizational object type (example: design office) should support the IFSTROBJCT interface. As a result, this object type inherits the agent attribute. This attribute returns the position or organizational unit that is related to the SAP organizational object.

Many SAP organizational object types supplied by SAP already support the IFSTROBJCT interface.
You only need to enhance a subtype of the corresponding object type with the IFSTROBJCT interface if this is not the case. Programming is not required.

**Activities**

**Relationship Between Organizational Plan and *SAP Organizational Objects***

Each *SAP organizational object* must be related to the corresponding position or organizational unit. This step must *always* be performed because the organizational plan is initially determined for specific customers.

For more information, see *Assign SAP Organizational Objects [Page 107]*.

**Responsibility for a Step**

When responsibility is determined for a step as part of a workflow definition, the agent can be derived from the workflow container and specified using a multi-level expression of the following type:

`&<business object type>.<SAP organizational object type>.agents&.`

On the entry screen for *Responsibility*, select *Container* and enter `&Material.Labor.Agents&.`

This procedure means there is no need to define and use a corresponding *role*.

**Error Handling**

When this step is performed, the following error situations can arise after the expression has been evaluated:

- The agent that is determined does **not belong to the possible agents** for the underlying single-step task.
- The relationship between the organizational plan and organizational object (see above) is not maintained, or not maintained in full.

If one of the above error situations arises, the step is instantiated as a work item and addressed to **all of the possible agents** for the single-step task.

**Reference to Related Topics**

An alternative concept exists that also makes use of the link between organizational entities and business objects and requires the definition of a role. This concept, which appears initially to be less easy to use, is required, for example, if you need to enter a role as a default role for a single-step task, or if a different method must be used to solve errors.
Agent as Attribute of SAP Organizational Object
Role to Determine Design Office

Definition
A role delivered by SAP for determining the employees in a particular design office.

Use
This role enables you to use material to be processed to address the controller responsible for the material. As a result, the object reference to the material to be processed (object type BUS1001) is usually included in the _WI_Object_ID element of the task container, and/or in a Material element (or similar) of the workflow container.

This BUS1001 object type has the Laboratory attribute, so that an expression of type &_WI_Object_ID.Laboratory& and/or &Material.Laboratory& must be specified as the source of binding for the Org_Object_ID element of the role container.

Structure

| Role:       | 30100012 |
| Abbreviation: | Laboratory |
| Name:       | Determine laboratory/design office |

Integration
Individual positions from the organizational plan must be related with the corresponding SAP organizational objects of the T024L Laboratory/design office for material type. These relationships are evaluated for role resolution.
Defining Roles Using Function to Be Executed

**Use**

You use function modules for role definition when very complex selection criteria are required for agent determination, in other words, when it is not possible to use responsibilities to model agent selection. Function modules provide you with a very powerful tool for determining the agent of a task in Workflow.

**Prerequisites**

1. You must specify what job you expect the workflow to perform. Depending on this, you decide whether you want to use a *standard function module* delivered by SAP or your *own function module* that suits your requirements exactly. To avoid having to display the coding of the function module during the procedure, you should be absolutely sure about what container elements are required by the function module beforehand. If you do need to check the coding of a function module, on the *Standard Role: Display* screen, choose *Goto Function module*.

2. You created your own function module, where relevant. The function module must enable the following process:
   a. The role container transferred as the table parameter `AC_CONTAINER` is read using the macro commands `SWC_GET_ELEMENT` and `SWC_GET_TABLE`. If you want to have the macro commands available, you must integrate the Include `<CNTN01>` as a sub-report for shared use. `<CNTN01>` mainly contains the macro command definitions for creating and processing a container instance.

      For a complete list of all macro commands, refer to:
      - Macro Instructions for Processing a Container Instance in a Program [Ext.]
      - Macro Instructions for Accessing Objects, Attributes and Methods [Ext.]

   b. The role parameters are used to determine the relevant agent. At its simplest, this sub-program consists of a loop on a (Customizing) table, from which the agent is selected.

   c. The table `ACTOR_TAB` is filled.

      (See also Example [Page 124])

2. You have created a role. To call the transaction for processing roles, access the SAP menu and choose *Tools → Business Workflow → Development → Definition tools → Standard roles → Create*.

**Procedure**

On the *Standard Role: Create* screen:

1. Select *Function to be executed*.

2. Enter the name of the function module. For example, if you want to use a function module for reporting on the organizational structure, you can enter `RH_GET_STRUCTURE`.

3. Save the role.
Defining Roles Using Function to Be Executed

Depending on what function module you used, the field *Evaluation path* appears.

4. Enter the relevant evaluation path and choose *Save*.

5. Choose *Container Definition*.
   - The *Standard Role: Process Container* screen appears.

6. Choose *Create*. The *Create Element* dialog box appears.

7. If you want to use Data Dictionary fields, choose *Yes*.
   - The *Create with Data Dictionary Field Defaults* dialog box appears.

8. Specify the table from which you want to select fields and choose *Continue*.
   - The table appears.

9. Select the fields that you want to appear in the container definition. Bear in mind that these are the elements required by the function module.
   - The system prompts you to confirm the texts for the container elements.

10. Choose *Back*.
    - The *Standard Role:Create* screen appears.

**Result**

Workflow executes the function module and, depending on the container data, returns a list of possible agents.
The following excerpts from a fictitious function module for role resolution, which determines the agent responsible on the basis of a release code and object to be released, can be used as an example.

The ReleaseCode and ReleaseObject elements are defined in the role container as role parameters.

```
FUNCTION GET_REL_RESPONSIBLE.

*----------------------------------------------------------
|   Loka: Schnittstelle:                               |
|   TABLES                                               |
|   ACTOR_TAB STRUCTURE SWHACTOR                         |
|   AC_CONTAINER STRUCTURE SWCONT                        |
|   EXCEPTIONS                                           |
|   NOBODY_FOUND                                         |
*----------------------------------------------------------

INCLUDE <CNTN01>.

* define variables stored in container
  DATA: RELEASE_OBJECT TYPE SWC_OBJECT.
  DATA: RELEASE_CODE LIKE RM06B-FRGAB.

* local data
  DATA: BEGIN OF REOBJECTKEY,
       NUMBER LIKE EBAN-BANFN,
       POSITION LIKE EBAN-BNFPO,
       END OF REOBJECTKEY.

REFRESH ACTOR_TAB.
CLEAR ACTOR_TAB.

* convert persistent container to runtime container
  SWC_CONTAINER_TO_RUNTIME AC_CONTAINER.

* read elements out of container
  SWC_GET_ELEMENT AC_CONTAINER 'ReleaseCode' RELEASE_CODE.
  SWC_GET_ELEMENT AC_CONTAINER 'ReleaseObject' RELEASE_OBJECT.

* separate object key
  SWC_GET_OBJECT_KEY RELEASE_OBJECT REOBJECTKEY.

* loop and select table <TABLE> with
  * RELEASE_CODE
  * REOBJECTKEY-NUMBER and REOBJECTKEY-POSITION
    ....
```
* end of selection

* exception and parameter handling
  IF SY-SUBRC NE 0.
    RAISE NOBODY_FOUND.
  ELSE.
    ACTOR_TAB-O榷PE = <TABLE>-ACTOR_TYPE.
    ACTOR_TAB-O榷PE = <TABLE>-ACTOR_TYPE.
    APPEND ACTOR_TAB.
  ENDIF.

ENDFUNCTION.
Interface of Function Module for Role Resolution

The interface of a function module for role resolution is described by the following parameters:

**Table Parameters**

**AC_CONTAINER, Reference Structure SWCONT**
Role container with role-specific parameters that must be available as input values for role resolution.

**ACTOR_TAB, Reference Structure SWHACTOR**
Table with results of role resolution as return values.

The `SWHACTOR` structure has the following logical appearance:

<table>
<thead>
<tr>
<th>Field name</th>
<th>Type</th>
<th>Length</th>
<th>Short text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Otype</td>
<td>CHAR</td>
<td>2</td>
<td>Object type in Organizational Management</td>
</tr>
<tr>
<td>ObjID</td>
<td>CHAR</td>
<td>12</td>
<td>ID of object in Organizational Management</td>
</tr>
</tbody>
</table>

The structure consists of two fields:

- **OType** includes a 2-character character field that contains the identification of the object type in Organizational Management. At this time, the following object types are permitted as the result of role resolution:
  - O Organizational unit
  - S Position
  - C Job
  - A Work center
  - US User name
  - P Person (PD master data)
  - The entries for **OType** are checked against table T779O [Ext.].

- **ObjID** includes a 12-character character field that contains the identifying name of a user and/or the unique ID (8-digit number) of an object in Organizational Management.

**Exceptions**

**NOBODY_FOUND**
If the function module for role resolution is exited via the **NOBODY_FOUND** exception, the status of the **Cancellation for role resolution without result for further procedure** indicator is decisive.

- The indicator is set:
  - The work item and/or workflow from which role resolution was requested is assigned the incorrect status.

- The indicator is not set:
The work item and/or workflow from which role resolution was requested continues. To determine the agent, the possible agents are evaluated.

The cause of the error, which may have been output as a message when the exception was triggered, is logged in the history of the work item and/or in the workflow step log. The message type is not relevant to error handling.

**Error Handling for an Empty Table**

If the function module for role resolution is not exited via its `NOBODY_FOUND` exception, and if the `ACTOR_TAB` table with the agents is still returned empty, the above information applies accordingly.
Role to Determine Manager

Definition
A role delivered by SAP for determining the manager of an agent, position, or organizational unit.

Use
Oftentimes, you will use this role to find the manager of the initiator of a workflow, or the manager of the current agent of a step. The _WF_Initiator element of the workflow container and _WI_Actual_Agent element of the task container are used to store the user names in a 14-character character field in accordance with the RHOBJECTS-OBJECT reference. Binding, therefore, must be defined for the Org_Object element of the role container.

As an example, role 00000168 is also used in the example demo for processing a notification of absence. For more information, see Example Demo: Process Notification of Absence [Ext.].

Structure

<table>
<thead>
<tr>
<th>Role:</th>
<th>00000168</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abbreviation:</td>
<td>Manager</td>
</tr>
<tr>
<td>Name:</td>
<td>Manager of...</td>
</tr>
</tbody>
</table>

The SWX_GET_MANAGER function module is used to define this role.

Integration
The organizational plan of the enterprise is used for role resolution.

The link between an employee and his or her manager can be depicted in the organizational plan by two different relationships:

- Indication of the chief position for an organizational unit (position "manages" organizational unit, relationship A/B012).

- Direct reporting structure between positions (position "reports to" position, relationship A/B002).
Role Resolution Using Evaluation Paths

Use

The organizational situation of employees within an enterprise is depicted in the organizational plan. Using this existing information, you can perform role resolution starting from one particular employee to determine one other employee, or several other employees, along specific relationships in the organizational plan.

The following role evaluates a function module to perform resolution. Please note that this function module is provided by SAP as a default.

Starting from a particular employee, you want to determine his or her organizational unit so that you can address a work item to all of the employees in this organizational unit.

The role that includes this functionality is available in your system and can be used as an explanation of this documentation. For more information, see the role used to determine the organizational unit of a user [Page 134].

Integration

From a technical perspective, this role resolution is very similar to Role Resolution Using a Function to be Executed [Page 122]. The RH_GET_STRUCTURE function module must be used; an evaluation path is also specified.

Activities

1. Maintain an organizational plan with the appropriate relationships.

2. An evaluation path describes how the relationships between organizational objects are processed in a particular logical order, as required for the role resolution described above.

3. Define a role that evaluates these relationships. This role uses the RH_GET_STRUCTURE function module to perform resolution.

   This step is only required if you cannot use any of the roles delivered in the standard system. For more information, see Define Role [Page 116].

4. If you enter the role as an agent for an activity or as a default role for a single-step task, maintain binding for the role container. For more information, see Define Binding [Page 132].
Define Role to Evaluate Evaluation Paths

Use
You want to define a role whose resolution is based on the evaluation of evaluation paths.

Procedure
4. Create a new role. To call the transaction for processing roles, access the SAP menu and choose Tools → Business Workflow → Development → Definition tools → Standard roles → Create.
2. Select the Function to be executed checkbox.
3. Enter RH_GET_STRUCTURE as the function module for role resolution.
   The named function module is provided by SAP for this purpose. Further programming is not required.
   If this function module is entered as a function module for role resolution, you can specify the evaluation path in an additional dialog box.
4. Define the role container.
   The role container for a role based on the RH_GET_STRUCTURE function module must only contain the following elements:
   Element OType, data type reference OBJEC-OTYPE: type of object in Organizational Management according to the first step in the evaluation path.
   Element Org_Agent, data type reference WFSYST-AGENT: C14 field as combination of object type in Organizational Management and object in Organizational Management.

Create the first two elements, or the last element, as role parameters.

   The object type in Organizational Management (example: US) and the object in Organizational Management (example: SCHMIDT) can be transferred either to two separate fields or to one field (example: USSCHMIDT). Data specified in one field is evaluated first.

You define the manager_of role (manager of a user). To do so, you refer to the RH_GET_STRUCTURE function module and specify US_CHEF as the evaluation path.

You create a new element with the name Org_Agent in the role parameter container. You define this container element as an obligatory element with a data type reference to dictionary table field WFSYST-AGENTS.
Define Binding

Prerequisites

You have created a role based on the RH_GET_STRUCTURE function module using your role container.

To "provide" the role container with the agent that represents the starting point of role resolution, you now define binding for the role container:

- If you use the role as a default role for a single-step task, you define binding from the task container.
- If you use the role as a role for a step, you define binding from the workflow container.

The workflow container and task container include system fields that are always available. In the standard system, they are filled by the workflow system. These container elements often include the information required as role parameters and can, therefore, be used as a source for binding. The following container elements include information on users in a C14 field in the <USName> structure.

- The _WF_Initiator element of the workflow container
- The _WI_Actual_Agent element of the task container

Procedure

The procedure is explained using the example of an "approve leave" single-step task. This task must always be completed by the manager of the person who submits the request. Therefore, you want to enter the manager_of role as the default role, and then integrate this customer task as an activity in a workflow definition.

1. Create an element in the task container called applicant with reference to the WFSYST-AGENTS ABAP Dictionary field.
2. Declare the manager_of role as the default role of this customer task.
3. Define the following binding from the task container to the role container:

<table>
<thead>
<tr>
<th>Org_Agent</th>
<th>&amp;Applicant&amp;</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Role container)</td>
<td>(Task container)</td>
</tr>
</tbody>
</table>

4. In the description of the appropriate activity within the workflow definition, define the following binding from the workflow container to the task container:

<table>
<thead>
<tr>
<th>APPLICANT</th>
<th>&amp;_WF_Initiator&amp;</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Task container)</td>
<td>(System variable in workflow container)</td>
</tr>
</tbody>
</table>
Binding Definition for Role Resolution

Diagram showing the workflow, task, and role containers with the following elements:
- Workflow container: _WF_INITIATOR
- Task container: APPLICANT
- Role container: ORG_AGENT
Role for Determining Organizational Unit of a User

Definition
A role delivered by SAP for determining the organizational unit to which a particular employee belongs.

Use
This role enables you to determine an employee’s organizational unit on the basis of the employee. A distinction is made between the following scenarios:

- The role is used in conjunction with a single-step task, which is classified as a general task [Ext.].
  The generated work item can be viewed by all of the employees from the organizational unit that has been determined (and can be processed by a user from this organizational unit).
- The role is used in conjunction with a single-step task whose possible agents [Ext.] are specified by one or more positions.
  The work item can only be viewed by employees with a position that belongs to the organizational unit that has been determined and is part of the possible agents.
- The role is used in conjunction with a single-step task whose possible agents [Ext.] are specified by a job.
  The work item can only be viewed by employees with a position that belongs to the organizational unit that has been determined and is described by the job.

Structure

<table>
<thead>
<tr>
<th>Role</th>
<th>30000011</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abbreviation</td>
<td>FindOwnOrgUn</td>
</tr>
<tr>
<td>Name</td>
<td>Organizational unit of a user</td>
</tr>
</tbody>
</table>

This role uses the RH_GET_STRUCTURE function module in conjunction with the WF_ORGUN evaluation path (organizational unit of a user/person).

Integration
Each user whose organizational unit must be found must, of course, belong to an organizational unit via his or her position.
The Cancellation for Role Resolution Without Result Indicator

**Definition**
Indicator that determines how the system reacts if role resolution fails to find a valid agent.

**Use**
It is possible for role resolution to fail to find a valid agent. This is the case
- If role resolution runs with errors and does not provide any results at all
  (From a technical perspective: the function module for role resolution is exited via its NOBODY_FOUND exception, and/or returns an empty agent table.)
- If role resolution provides agents that do not belong to the possible agents [Ext.] of the single-step task.
  (Of course, if recipients or persons responsible for workflow are expressed by specifying a role, the latter cannot occur.)

<table>
<thead>
<tr>
<th>If this indicator is...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>SET</td>
<td>Flow is cancelled if role resolution fails to find an agent. This protects the data.</td>
</tr>
<tr>
<td>NOT SET</td>
<td>All of the possible agents in the system become actual agents for the work item if role resolution fails to find an agent. The task is completed.</td>
</tr>
</tbody>
</table>

The error situation is recorded in the step log.

Role resolution is used to distribute invoices to various buyers at your enterprise. Only Mr Miller can execute this work item if the invoice amount exceeds $5,000. If you set the Cancellation for role resolution without result indicator, and if role resolution fails to find an agent for an invoice that exceeds $5,000, the workflow is cancelled. Only the workflow administrator can restart it. If you do not set the Cancellation for role resolution without result indicator, and if role resolution fails to find an agent for an invoice that exceeds $5,000, all buyers can process the invoice.
The Cancellation for Role Resolution Without Result Indicator
Selecting Objects from the Organizational Plan

Use

As well as defining roles, it can be necessary to describe certain relationships between employees and areas of responsibility or the borders between areas of responsibility in system tables. This information is then available for role resolution.

Create a table by assigning certain companies and invoice amounts to administrators via their positions.

<table>
<thead>
<tr>
<th>Position</th>
<th>Company</th>
<th>Amount ($)</th>
</tr>
</thead>
<tbody>
<tr>
<td>50001234</td>
<td>A - H</td>
<td>0 - 50.000,-</td>
</tr>
<tr>
<td>50001235</td>
<td>A - H</td>
<td>&gt; 50.000,-</td>
</tr>
<tr>
<td>50001236</td>
<td>I - Z</td>
<td>0 - 60.000,-</td>
</tr>
<tr>
<td>50001237</td>
<td>I - Z</td>
<td>&gt; 60.000,-</td>
</tr>
</tbody>
</table>

If the name of the company and the invoice amount are known, the details in this table are used for role resolution, in order to find an administrator.

The following function modules are available, to ensure that you have access to objects from Organizational Management which you need to fill the table and that you can program possible entries.

Features

RH_DETERMINE_ORG_OBJECT

Determines the ID of any Organizational Management object.

Interface

Import Parameter

- **ORG_OBJECT**, Reference structure SWHACTOR

Exceptions

- **NO_ACTIVE_PLVAR**
- **NO_OBJECT_ID_SELECTED**
- **NO_OBJECT_TYPE_SELECTED**

This function module can be called without transfer parameters.

When you access this function module, as dialog box is displayed from which you can select an object type from Organizational Management.

Once you have selected an object type from Organizational Management, one of the Organizational Management objects stored for this type can be selected and displayed using the search function.

The object type and ID of this Organizational Management object is returned as an export.
parameter in the SWHACTOR structure and can be used in your application.

**RH_DETERMINE_ORG_OBJID**

Determines the ID of an Organizational Management object from a predefined Organizational Management object type.

**Interface**

**Export parameter**

- **ORG_OBJECT_TYPE**, Reference field OBJEC-OTYPE

**Import Parameter**

- **ORG_OBJECT_OBJID**, Reference field SWHACTOR-OBJID

**Exceptions**

- **NO_ACTIVE_PLVAR**
- **NO_OBJECT_ID_SELECTED**

This function module forms only the “second half” of the function module described above. When you access it, you transfer the Organizational Management object type whose possible values you want to display using the possible entries function. You transfer this Organizational Management object type as a 1 or 2 character ID.

You can select and display one of the entries, which is stored for the Organizational Management object type using the search function.

The object type and ID of this Organizational Management object is returned as an export parameter in the variable ORG_OBJECT_OBJID and can be used in your application.
Specify Agent, Recipient, or Administrator by His or Her Role

Use
You want to specify an agent, the workflow administrator, or a recipient by his or her role. To do so, you can use the roles you defined yourself or the standard roles provided by SAP.

Procedure
The procedure for entering a role is always the same:

1. To enable you to specify the agent/administrator/recipient as a role, select Role.
2. Enter the unique, 8-digit number of the role in the appropriate input field.

   If you do not know what this number is, use the input help function. In the standard system, the input help function displays the abbreviation and description of the role. By choosing F17, you can display the plan version and number of the role instead of the description.

3. Define binding for assigning values to the role container:

   When a role is specified in the task definition or workflow definition, the role container must be filled with values from the appropriate container (task container or workflow container) via a binding definition. The binding definition editor is available for this purpose. It enables you to define the appropriate assignments to the elements of the role container.
Integration with Personnel Administration

Purpose
Integration between the Organizational Management and Personnel Administration components enables you to,

- use data from one component in the other
- keep data in the two components consistent

Relationship between a person (Personnel Administration) and a position (Organizational Management).

Prerequisites
So that you can benefit from integration, you must set it up.

For more information, see Activating Integration [Page 142].
Activating Integration

You activate integration by defining an active plan version in the Personnel Planning and Development Implementation Guide (IMG) (under Global Settings). If you do not define a plan version, integration remains inactive. Once integration is active, you must specify the persons for whom data is exchanged. The selection criteria are:

- Company code
- Personnel sub-area
- Employee group
- Employee subgroup

The PLOGI feature enables you to determine the combination of selection criteria to be used for integration. You find detailed instructions on maintaining this feature in Personnel Administration.

You can set up integration for all employees in any combination of selection criteria. The PLOGI PLOGI entry in table T77S0 acts as a central switch for integration. If the entry contains a plan version, integration is activated for all employees who meet the criteria set in feature PLOGI. If you make no entry in the table, integration is switched off.

To integrate Seminar and Convention Management and Time Management without organizational assignment, the PLOGI PLOGI switch must still contain a plan version. You switch off integration with organizational assignment using the PLOGI ORGA feature in the Organizational Management IMG.
Making Initial Settings

When you activate integration for the first time, you must ensure that the Personnel Administration and the Organizational Management databases are consistent. To do this, you use the reports:

- RHINTE00 (Adopt organizational assignment (PA to PD))
- RHINTE10 (Prepare integration (PD to PA))
- RHINTE20 (Check program integration PA - PD)
- RHINTE30 (Create batch input folder for infotype 0001)

The following table entries are also required:

- PLOGI PRELI in Customizing for Organizational Management (under Set up integration with Personnel Administration). This entry defines the standard position number.
- INTE in table T77FC
- INTE_PS, INTE_OSP, INTEBACK, INTECHEK and INTEGRAT in Customizing under Global Settings → Maintain evaluation paths.

These table entries are included in the SAP R/3 system. You must not change them.

Since integration enables you to create relationships between persons and positions (A/B 008), you may be required to include appropriate entries to control the validation of these relationships. You make the necessary settings for this check in Customizing under Global Settings → Maintain relationships.
Maintaining Tables

Objects in *Organizational Management* in the integration plan version must also be contained in the following *Personnel Administration* tables:

<table>
<thead>
<tr>
<th>Tables</th>
<th>Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>T528B and T528T</td>
<td>positions</td>
</tr>
<tr>
<td>T513S and T513</td>
<td>jobs</td>
</tr>
<tr>
<td>T527X</td>
<td>organizational units</td>
</tr>
</tbody>
</table>

When integration is active, and these objects are created (or deleted) using *Organizational Management* transactions, the corresponding entries in the above tables are automatically created (or deleted). The entries created automatically are marked with a “P” and cannot be changed or deleted manually. You cannot flag manual entries in this way (the field cannot be maintained manually).

You can transfer either the long or the short texts of *Organizational Management* objects to the *Personnel Administration* tables. You do this in the *Organizational Management* Implementation Guide in the step *Set Up Integration with Personnel Administration*. If you change these control entries at a later date, you must also change the relevant table texts. Use the report RHINTE10 to do this.
Assigning a Person to a Position

When you create the Personnel Administration infotype 0001 (Organizational Assignment) for a person in Personnel Administration, a dialog box appears in which you assign the person to a position. The system always defaults to a staffing percentage of 100%. You can, however, change this percentage and assign a person to several positions up to a total of 100%.

You can enter the position in infotype 0000 (Actions). In this case, when the event reaches infotype 0001, the Personnel Area and Personnel Subarea fields are completed with the values that you have appended to the position. In addition, the organizational assignment of the position (job, organizational unit, cost center) is displayed in infotype 0001 (Organizational assignment).

If you do not enter the position in infotype 0000, you can subsequently enter it in infotype 0001. If you do not enter a position or staff assignments with a staffing percentage of under 100%, a dialog box appears in which you can complete your entries.

The system reads the organizational integration of this position and saves it along with the position number in the corresponding fields in infotype 0001. If the data on the position changes in the period in which the position is occupied by a person, the system creates more than one version of infotype 0001, to guarantee that the assignments of the person are always saved correctly.

If the position has been assigned directly, or by using an organizational unit to a cost center that belongs to a controlling area to which the person has not been assigned, you cannot assign the person to this position. The system rejects any attempt to assign the person to this position, because the assignment must be unique.

If an infotype 1013 record (Employee group/subgroup) has already been created for the position, and the record contains data that is different from the data entered for the person, the system displays a message to inform you.

If you assign a person to a work center instead of to a position, the job field, organizational unit field, and so on, are not filled.

If the person is not assigned to a position or work center, infotype 0001 is given the standard position to draw attention to the absence of an assignment. The number of this default position can be found in the PLOGI PRELI entry in the (see the IMG under Global Settings → Set up Integration with Personnel Administration).

If, in the case of a transfer, you delete your new entries, the previous position remains unchanged.
Assigning Persons Temporarily

Assigning Persons Temporarily

You can temporarily assign persons to an organizational unit, if, for example, the position or person are not yet fixed. You create a temporary assignment, by entering the object type and the number of the organizational unit in the dialog box, where you would usually enter the position.

This organizational unit will only be saved in infotype 0001 - a relationship will not be created in Organizational Management.

Because a default position is stored in infotype 0001, this assignment is incomplete. For this reason, you should replace the assignment as soon as possible, by assigning the person to a position. To assign a person to a position correctly, you can either transfer the person or create a relationship between the person and a position in Organizational Management. The ‘temporary’ organizational unit is then replaced by the correct organizational unit that has been assigned to a position.

You can display and evaluate temporary assignments using report RHSBES00.

Using the function module RH_PERSON_WITH_ORGUNIT_ONLY, you can program further evaluations, that will search specific organizational units for persons with incomplete position assignments. Such persons are identified by the default positions available in infotype 0001.

See .

Relationships (infotype 1001) [Page 39]
Transferring a Person

You can only change organizational assignments using transactions from the Organizational Management component.

However, the Personnel Administration events Transfer and Leaving are exceptions to this rule, as the required actions take place in both Personnel Administration and Organizational Management. When a transfer takes place, you are required to specify a new position.

If an employee is transferred to a non-integrated area (see the PLOGI feature), the system delimits the employee's position relationship in Organizational Management, and records the new organizational assignment in infotype 0001.

If a transfer takes place on the start date of an infotype 0001 record, and if the transfer does not involve a change of company code, personnel sub-area, employee group or subgroup, you must make an entry on the screen for infotype 0001 to display the dialog box in which the new position is specified.
Ending a Contract

Features

If a person's contract is terminated, the system delimits all the relationships between positions and work centers in Organizational Management. The standard position (no assignment) appears in infotype 0001 (Organizational assignment), as of the date on which the person left the company.

However, the system retains the other specifications regarding the organizational assignment (that is, job, organizational unit, and cost center). The system considers employees that have left the company as not integrated. Once the employee has left, you can change infotype 0001.

If you delete an infotype 0001 record, all of that person's assignments to positions and work centers are deleted in the Organizational Management system.
Changes in Organizational Management

Features

Each time you make a change in Organizational Management, the system checks whether or not this has had an effect on the organizational assignment of one or more persons. This takes place when you create or delete:

- Relationships (infotype 1001) between
  - and K or S
  - S and C or P or K
  - A and P
  - C and P

- The department entry in infotype 1003, which defines an organizational unit as a department.
  
  If the department switch is active (entry PPABT_PPABT in Customizing under Organizational Management → Integration with Personnel Administration), an organizational unit is transferred to the infotype 0001 record. This occurs only if it has been defined as a department.

The system checks these persons to determine if the structure contains a cost center and a person belonging to different controlling areas, or company codes. If so, an error message appears.

When creating or changing infotype 1013 – which you can use to specify an employee group and subgroup for a position – you should only make entries that are compatible with the employee group and subgroup of the persons assigned to the position. If you enter incompatible data, the system issues a warning message.

Changes you make to infotype 1008, which can be maintained for positions and organizational units, and which contains data on company code, business area, personnel area, and personnel sub-area, have no effect on Personnel Administration records.

Once the system has successfully checked the data, it saves the data in Organizational Management. The infotype 0001 records of the persons concerned are then read by the Personnel Administration database, changed in accordance with the Organizational Management transaction, and are written back to the Personnel Administration database.

See also:

- Department/Staff (infotype 1003) [Page 42]
- Employee Group/Subgroup (infotype 1013) [Page 56]
Changes in Organizational Management
Retrospective Changes

Features

The system checks all Organizational Management actions to determine if they require changes to be made to personnel data with a greater retroactive effect than the “Earliest retroactive accounting period”. This period, which is defined in Personnel Administration, prevents subsequent changes from being made to specific payroll sub-units.

If integration is active, the earliest retroactive accounting period is also valid for Organizational Management transactions, if infotype 0001 is affected for persons. If you try to change data before the earliest retroactive accounting period, the system rejects the changes.
Linking a Person to Several Positions

Features

You can link one person to several positions. You can, however, only create one position per person in infotype 0001, for this reason, the position with the highest staffing percentage is determined and saved in infotype 0001.

Each time you display infotype 0001, a system message indicates that there are further positions, in addition to the one on the screen. These can be displayed by selecting Additional Positions. The same procedure applies to a person who is assigned to work centers.

A work center is only stored in infotype 0001 if a position does not exist in the same period.
Temporary Assignment of a Person to a Job

Features

You can assign a person temporarily to a different job than the one that usually defines his or her position. You do this using the standard relationship B 017 (carries out). If this relationship exists between a person and a job, the job is transferred to infotype 0001, instead of the job that normally describes the position. If there is more than one such relationship for one person, the system scans for the job with the highest weighting percentage.

When you enter in the system that the person is leaving the position, a dialog box appears asking if relationship B 017 should be deleted, or delimited.

You use report RHSBES00 to determine whether or not such relationships exist.

See also:

Relationship (infotype 1001) [Page 39]
Vacancies

Features

If integration with the Recruitment component is active data on vacancies (that is, positions marked as vacant in infotype 1007) is transferred to Personnel Administration table T750X. When infotype 1007 records are created, you can enter the additional information required by table T750X.

Furthermore, the functions that are commonly used for maintaining vacancies occur in the corresponding Personnel Administration transactions (such as when a vacancy is delimitated due to a vacant position being filled by a new employee). For further information see the Implementation Guide (IMG) under Organizational Management → Functions → Activate/deactivate “Vacancy” infotype in the documentation on the switch PPVAC_PPVAC.

See also:

Vacancy (infotype 1007) [Page 47]
Obsoleted Positions

Features

You can flag positions as obsolete in infotype 1014. The system checks whether another person occupies the position, if

- a person is transferred or their contract runs out (Personnel Administration component)
- the corresponding relationship has been deleted or delimited (Organizational Management component)

If not, the system displays a dialog box where you can specify that the position should be delimited from the date it becomes vacant.

If an obsolete position is subsequently filled by either the Personnel Administration or Organizational Management system, a message is displayed to indicate that it has been marked as obsolete. If an infotype 1014 record is created for a position, the system checks whether or not the position is occupied and then displays an appropriate message.

See also:

Obsolete (infotype 1014) [Page 57]
Infotype Record Splits

Features
The entry PLOGI SPLIT can be used in integration control to split up infotype 0001 records if the name of an organizational unit, job, or position changes. In this way, you can ensure that the system always displays the most up to date names in the transactions. For further information, see the Implementation Guide (IMG) the documentation on the integration switch PLOGI SPLIT under Organizational Management.
Processing Blocks

Features

To prevent other users from making changes simultaneously, persons affected by Organizational Management transactions are locked as soon as the system finds them. As a result, you cannot perform transactions for persons who have already been locked.

The system unlocks the persons and Organizational Management objects processed by the transaction after the Organizational Management update takes place. Infotype 0001 records are then processed by the integration program and updated in Personnel Administration. The system locks the personnel numbers again to do this.

If, in the time between the Organizational Management and Personnel Administration updates, another user locks a personnel number that has just been unlocked by the Organizational Management update program, processing of Infotype 0001 in Personnel Administration cannot be performed for this person.

In this case, no changes are made to Personnel Administration to prevent inconsistencies between Organizational Management and Personnel Administration. The changes that have already been made in Organizational Management are reversed.
Batch Inputs from Personnel Admin. to Org. Management

Features

If batch input sessions are processed for master data and they perform actions that are relevant to integration, no changes are made to data from Organizational Management data. To achieve consistency between the Personnel Administration component and Organizational Management data, you must give the Organizational Management database the same status as Personnel Administration. You do this by starting report RHINTE00 for the persons concerned, and processing the resulting batch input session. You find this report in the Organizational Management Implementation Guide (IMG) under Organizational Management → Functions → Transfer data from master data record to Personnel Planning, or in the menu of the application.

If you create the personnel action Leaving by batch input, infotype 0001 is split and the default position is written to infotype 0001. Use report RHINTE00 to delimit the relationship between position and person.

When programming your own Batch Input for Personnel Administration, you can, however, use PP02 to update Organizational Management in the same session after the Organizational Management changes have been made. This ensures that you have consistent data between Personnel Administration and Organizational Management after the Batch Input has been processed.
Batch Inputs from Org. Management to Personnel Admin.

Features

Batch input sessions that are processed in the Organizational Management system do not change Personnel Administration master data. To change the data, you must start report RHINTE30 for the persons concerned, and process the resulting batch input session. You find this report in the Organizational Management Implementation Guide (IMG) under Organizational Management → Functions → Transfer data from PD to master data record, or in the menu of the application.

When you make changes online within Organizational Management, you can also choose to have the system compile a list of the personnel numbers affected by the changes, rather than allowing corresponding changes to be made immediately within Personnel Administration. The system checks whether the Organizational Management actions lead to inconsistencies. You can then use report RHINTE30 to create a batch input session to make the required Personnel Administration changes for these persons. (The personnel numbers are collected internally in table HRINTE30, which is then accessed by report RHINTE30).

You can also perform several Organizational Management actions and then run report RHINTE30 to create a common BTCI session for all of the persons concerned. This Organizational Management online Personnel Administration batch variant is controlled by the PLOGI PRELU entry in the IMG under Organizational Management → Set up integration with Personnel Administration.

There are three ways you can update Personnel Administration master data when Organizational Management actions are carried out. Master Data may change as follows:

- Directly
- By batch input
- Either directly, or by batch input, depending on the number of persons affected

For more information, see the documentation for the entry PLOGI PRELU (see above).
Editing the Organizational Plan

Purpose

In Expert mode, you can use Simple Maintenance and Infotype maintenance to display and edit your enterprise's current organizational and reporting structures as well as plan and model personnel changes. You can display and process organizational structures hierarchically or as a matrix.

The object-oriented design of Organizational Management allows you to display organizational units, positions and their holders and tasks in an organizational plan and to process them according to your requirements.

This gives you an overview of the current status of your organizational and reporting structures and enables you to report on historical data at any time. In addition, you can plan and model future scenarios.

For further information on Organizational Management see Organizational Management [Page 13]

Prerequisites

If you want to display and model your organizational plan using Simple Maintenance and Infotype maintenance, you must be:

- well-acquainted with the organizational structure at your company, and how the different areas work together
- aware of all of the different types, or categories, of jobs performed at your company familiar with jobs are fields of work or functions, head of department or secretary, for example. A job forms the basis for the description of a position (head of sales department, for example).
  
  The areas of work and functions, in contrast to their positions, only appear once in a company.
- aware of how many individual positions fall within the different job categories you have identified.

Planning Ahead

If you are using tasks to describe jobs or positions, you must:

- develop easily recognizable descriptions
- identify any groups of tasks that are routinely performed together, so that you can catalog them as a group

If your organizational plan includes the work centers, you must determine the restrictions or prerequisites for them, for example, a medical examination required for a particular work center. To do this, use the infotype ‘Restrictions’ (1006) in Infotype Maintenance.

Process flow

Simple Maintenance and Infotype Maintenance are tools which help you to edit, plan and model your enterprise’s organizational plan. You use them as follows:

1. Simple Maintenance
In *Simple Maintenance*, you can put together a basic framework for your organizational plan. Simple Maintenance contains all the functions you require in order to add objects from Organizational Management to your organizational plan, from creating an organizational structure and determining staff assignments to creating task profiles.

You use three screens in *Simple Maintenance* to create organizational structures, staff assignments and task profiles. The information in these screens is presented in a tree structure. This allows you to display the step by step creation of your organizational plan as well as the relationships between the different organizational objects.

See About Simple Maintenance [Page 228] Creating an Organizational Plan [Page 263]

2. Infotype Maintenance

You can describe individual organizational objects in your organizational plan (organizational units and positions, for example) using attributes (infotypes) in *Infotype Maintenance*. You can create, edit, display, delete, and list all infotypes allowable for the object.

You can jump from the different screens in *Simple Maintenance* directly in to *Infotype Maintenance* by choosing Goto → Object description.

See About Infotype Maintenance [Page 162]

**Result**

You have created structures for your organizational plan.

You can reproduce structural or personnel changes within your company by editing the whole organizational plan, substructures or individual organizational objects using the two tools described above. You can also use Simple Maintenance to plan future developments by simulating various planning scenarios and comparing them to the current organizational plan.

The information stored in the organizational plan on organizational and reporting structures provide a basis for the use of other Personnel Planning and Development components such as Personnel Cost Planning, Compensation Management, Training and Event Management and SAP Business Workflow.
Infotype Maintenance

Use
Once you have created the basic framework of your organizational plan in Simple Maintenance, you can create and maintain all infotypes allowed for individual objects in your organizational plan. These can be the basic object types of Organizational Management – organizational unit, position, work center and task. You can also maintain object types, which do not belong to Organizational Management.

Prerequisites
See General Maintenance [Page 210].

Features
You have two options when editing:

- You can select a particular basic Organizational Management object type and only edit objects of this object type. For this, choose Human Resources → Organizational Management → Expert Mode → <Object> or Task Catalog

- In General Maintenance, you can select different object types while you are editing. To do this, choose Human Resources → Organizational Management → Expert Mode → General

In this way, you can work with objects with object types that do not belong to Organizational Management. In General Maintenance, you can, for example, maintain events or appraisals.

Once you have entered an object, you can create, maintain, display and delete all infotypes allowed for this object. You can also change the status of objects and infotype records retrospectively.
Object Manager

Use
With the object manager you can search for and select objects that you want to display or edit.

Prerequisites
You are familiar with the validity concept of the application. The validity concept determines which objects you can find during a search.

Features
The object manager consists of the search area and the selection area.

- In the search area are one or more search functions for each object type, for example the Search Term and Structure Search functions. These search functions are marked with a highlight. In addition, the object type itself can contain a search function. The object types are marked with the respective object type-specific symbol.

If necessary, you can add more object types and search functions in customizing. You can also change the sequence of the search functions. For further information see the Implementation Guide (IMG) under Personnel Management → Global Settings in Personnel Management → Settings for Object Manager or the IMG for Organizational Management.
Object Manager

- In the search area you can create **search variants**, so that you can reuse search criteria you have grouped together, or hits. These search variants are marked with 🔍.

- In the **selection area** the system displays the objects that you searched for and actually found. According to the search function, this can be either a hit list or a structure.

- You can scroll through search results in the selection area using ⬅️ and ➡️.

- You can completely hide or display the **object manager**, so that the other screen areas get correspondingly bigger or smaller. To do that, choose **Settings → Show Object Manager** or **Hide Object Manager**.

- With 🎟️ you can increase or reduce the size of the selection area, in order to show more hits. As you do that, the search area is hidden or displayed accordingly.

  🎟️

  The system saves the last settings relating to screen size and the last object selection user-specifically, and they are available next time you call up the transaction.

  You can reset these settings and the last object selection using the report RH_DELETE_OM_USER_SETTINGS. Note that the reset takes place across all applications. For more information, see the report documentation.

- You can call up **generic object services** for a selected object using the right mouse button menu. To do that, select an object in the selection area with the right mouse button and choose **Generic Object Services**. For further information about generic object services, see [List of Object Services [Ext.]](#).


Finding/Selecting Objects

Use
In the **Search area** you can search for one or more objects that you want to display or edit.
For each object type there are various **search functions**, for example:
- Search Term
- Structural Search
- Free Search

Prerequisites
Objects you are searching for must already exist. Create new objects as required.
The required object types and search functions are set up.

Procedure
1. In the **search area** select one of the available search functions and if necessary enter the
   required selection criteria.
   In the **selection area** the system displays all found objects with the corresponding object
type, either as a list or as a structure.
2. Double-click on the required object.
Using Search Variants

Use
In some search functions, for example Search Term, you can restrict the number of hits by using a combination of selection criteria. You can then save such a combination as a search variant so that you can use it again. You can also delete a search variant again, if necessary.

Procedure

Creating Search Variants
1. Use one of the search functions to search for objects.
   The system displays the hits in the selection area.
2. Choose and enter a name. Choose .
   The system saves the search criteria as a search variant and assigns them to the corresponding object type in the search area. The search variant is marked with .
3. Select the search variant you created and choose . You can check your search criteria.

Searching for Objects Using a Search Variant
1. Select a search variant.
   The hits are displayed in the selection area.
2. Double-click on the required object.

Deleting Search Variants
1. Select the search variant that you want to delete.
2. Choose .
   The search variant is deleted.
Using Search Tools

Use
With the search tools for each object type you can search for objects in various object type-specific ways.

These search tools are marked with 📘. In addition, the object type itself can contain a search tool. The object types are marked with the respective object type-specific symbol.

Prerequisites
You are familiar with how the search tools are assigned.

- In the search area, the object type itself can contain a search tool. The object types are marked with 📘.
- Search tools can be positioned under the corresponding object type. In that case it is marked with 📘.

Procedure

Searching for Objects Using a Search Term
1. Choose Search Term (or the required object type, if it has this search function).
   The Search for <object type> dialog box appears.
2. Enter a name. This can be a name, abbreviation or numeric ID. You can also search using the entry ∗.
3. Restrict the number of hits, if required. Enter whether the object you are looking for is directly or indirectly assigned to another object.
   The results of the search are displayed in the selection area. The display in the overview and detail areas does not change.
5. If necessary, you can start another search for the same object type and then choose 🖇️ Insert to add the new hits to the first results in the selection area.
6. Double-click on the required object in the selection area.

Searching for Objects Using Free Search
The Free Search search tool uses the InfoSet Query.
1. Choose Free Search (or the required object type, if it has this search function).
   The Find Objects of Type <Object type> dialog box appears. For further information, see HR in the InfoSet Query [Ext]. After the search, the system displays the search results in the selection area.
2. Double-click on the required object in the selection area.
Using Search Tools

Searching for Objects Using Structure Search

1. Choose Structure Search (or the required object type, if it has this search function).

   In the selection area the system displays all found objects of the relevant object type in a tree structure, ordered according to their assignment in the organizational plan.

   If necessary, you can refresh the hits displayed in the selection area using . This is recommended, for example, if you have created new objects shortly before.

2. Expand the structure until the required object is revealed.

   To display unrelated objects, choose .

3. Double-click on the required object in the selection area.
Maintaining Organizational Units

Use

You maintain organizational units on the Maintain Organizational Units screen. To access this screen, choose Human Resources → Organizational Management → Expert Mode → Organizational Unit.

In this screen, you can create and maintain all possible infotypes for the organizational unit object type. Enter the name of an organizational unit and specify the status of the infotypes you want to create, using the tab pages.

The infotypes you have already maintained for an organizational unit are indicated by a green check mark.
Creating Organizational Units

Procedure

You create organizational units when you want to add new organizational units to an organizational plan.

You can create organizational units using either Simple Maintenance or by creating infotype 1000 (object) as described here. This ‘existence infotype’ is a prerequisite for creating further infotypes for an object.

You can also create new organizational units by copying existing organizational units. See Copying Objects [Page 197]

1. On the Organizational Management screen, choose Expert Mode → Organizational unit.
   The Maintain Organizational Unit screen appears.
2. In the Plan version and Organizational unit fields, enter data as required.
3. Under Infotype name, choose Object.
4. Using one of the tab pages, select the status, which you want to assign to the new object.
5. Choose Create infotype.
   The Add Object screen appears.
6. In the Validity, Object abbreviation, and Object name fields, enter data as required.
7. Save your entries.
   The Essential relationship Relationships screen appears. To create a relationship record, go to step 8. If you do not want to create a relationship record, skip step 9. Otherwise, skip this step.
8. To create a relationship infotype record:
   a. Enter data in the appropriate fields as required.
   b. Save your entries.
   The Maintain Organizational Unit screen appears.
9. To exit the Essential relationship Relationships screen, choose Back or Cancel.
   – The Maintain Organizational Unit screen appears.

If you are creating a large volume of organizational units, try using Fast Entry.
Changing Objects

Procedure

You can change organizational units, jobs, positions and work centers when you want to edit their object abbreviations or object names. Abbreviations and names are maintained in the Object infotype (1000). To change tasks, see Changing Tasks [Page 204].

You cannot change the validity period assigned to an object using the Change function. For this, you must use the Delimit function. To change the validity period of several objects at the same time, use the report RHGRENZ0 (Delimit objects).

1. On the Organizational Management screen, choose Expert mode → <Object>.
   
   The Maintain <Object> screen appears.

2. In the Plan version and <Object> fields, enter data as required.

3. Under Infotype name, choose Object.

4. Using the tab pages, select the status of the objects you wish to change.

5. Choose Change infotype.
   
   The Change Object screen appears.

6. In the Object abbreviation and Object name fields, enter data as required.

7. Save your entries.
   
   The Maintain <Object> screen appears.
Displaying Objects

Procedure

You can display basic data for organizational units, jobs, positions and work centers if you want to review rather than edit them. This includes the abbreviation and name, the validity period, language key, and status of an object. This information is stored in the Object infotype (1000). To display tasks, see Displaying Tasks [Page 205].

1. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. Under Infotype name, choose Object.
4. Using the tab pages, select the status of the objects you wish to display.
5. Choose Edit → Display infotype.
   The Display Object screen appears.
6. Exit the function.
   The Maintain <Object> screen appears.
Copying Objects

Procedure

Copy organizational units, jobs, positions and work centers if you want to create new objects by duplicating objects that already exist. Creating objects by copying can save you data entry time. To copy tasks, seeCopying Tasks [Page 206].

When you copy objects, you can also copy all appended infotypes. This can be helpful if objects have the same attributes. The report RHCOPY10 (Copy Object Using Selection List) also allows you to copy objects.

You can also include additional infotypes in a copy request. This is not possible in Infotype Maintenance. You must use the report RHCOPY00 (Copy Objects).

1. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. Choose <Object> → Copy.
   The Maintain Plan Data: Copy Object dialog box appears.
4. Enter data as required in the Target object, Abbreviation and Name fields. Flag Copy relationships also.
5. Choose Copy object.
   The Copy Object dialog box appears.
6. Choose Yes.
   The Maintain <Object> screen appears.
Delimiting Objects

Procedure

You can delimit organizational units, jobs, positions and work centers when you want to change their validity periods, so that the end date occurs sooner than stated. This can be necessary, for example, when you plan to eliminate an object due to restructuring. To delimit tasks, see Delimiting Tasks [Page 208].

When you delimit objects, the system delimits any infotype records appended to the object, to the same date.

1. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. Choose <Object> → Delimit.
   The Maintain Plan Data: Delimit Object screen appears.
4. In the Delimit date and Historical rec. fields, enter data as required.
5. Choose Delimit.
   The Validity Period dialog box appears.
6. Choose Yes.
   The Maintain <Object> screen appears.
Deleting Objects

Prerequisites
You should delete organizational units, jobs, positions and work centers only when you want to erase all record of an object from the database. When you delete objects, the system deletes all appended infotypes as well. The system keeps no historical information. To delete tasks, see Deleting Tasks [Page 207].

⚠️
Deletions should only be necessary when, for example, you incorrectly or accidentally create an object. To change the validity period of an object, use the Delimit function.

Procedure
1. On the Organizational Management screen, choose Expert mode → <Object>.

   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. Under Infotype name, choose Object.
4. Using the tab pages, select the status of the objects you wish to delete.
5. Choose <Object> → Delete.

   The Maintain Plan Data: Delete Object dialog box appears.
6. Check the information to ensure you have selected the correct object.
7. Choose Delete.

   The Delete Object dialog box appears.
8. Choose Yes.

   The Maintain <Object> screen appears.
Changing the Status of Objects

Procedure

You can change the status of organizational units, jobs, positions and work centers if the planning status of the object has changed in the organizational plan. Status changes occur for several reasons. For example, a planned object may be approved, and require activation. To change the status of a task, see Changing the Status of Tasks [Page 209].

When you change the status of an object, the system applies the new status retroactively, to the beginning of the object’s validity period.

To change the status for a number of objects, you can save time by using the report RHAKIT00 (Change Status of Object).

1. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. Under Infotype name, choose Object.
4. Using the tab pages, select the current status of the object.
5. Choose Edit → Status.
   Another menu appears.
6. Select a new status.
   The Display Object screen appears.....
7. Check the information to ensure you have selected the correct object.
8. Save your entries.
   The Maintain <Object> screen appears.
Maintaining Jobs

Use

You maintain jobs on the Maintain Jobs screen. To access this screen, choose Human Resources → Organizational Management → Expert Mode → Job.

In this screen, you can create and maintain all possible infotypes for the job object type. Enter the name of an job and specify the status of the infotypes you want to create, using the tab pages.

The infotypes you have already maintained for the job are indicated by a green check mark.
Creating Jobs

Procedure

You create jobs when you want to add new jobs to the index of jobs you maintain for an organizational plan.

You can create jobs using either Simple Maintenance or by creating infotype 1000 (object) as described here. This ‘existence infotype’ is a prerequisite for creating further infotypes for an object.

You can also create new jobs by copying existing jobs. See Copying Objects [Page 197]

   The Maintain Job screen appears.
2. In the Plan version and Job fields, enter data as required.
3. Under Infotype name, choose Object.
4. Using the tab pages, select the status, which you want to assign to the new object.
5. Choose Create infotype.
   The Add Object screen appears.
6. In the Validity, Object abbreviation, and Object name fields, enter data as required.
7. Save your entries.
   The Maintain Job screen appears.

If you are creating a large volume of jobs, try using Fast Entry.
Changing Objects

Procedure

You can change organizational units, jobs, positions and work centers when you want to edit their object abbreviations or object names. Abbreviations and names are maintained in the Object infotype (1000). To change tasks, see Changing Tasks [Page 204].

You cannot change the validity period assigned to an object using the Change function. For this, you must use the Delimit function. To change the validity period of several objects at the same time, use the report RHGRENZ0 (Delimit objects).


   The Maintain <Object> screen appears.

9. In the Plan version and <Object> fields, enter data as required.

10. Under Infotype name, choose Object.

11. Using the tab pages, select the status of the objects you wish to change.

12. Choose Change infotype.

   The Change Object screen appears.

13. In the Object abbreviation and Object name fields, enter data as required.

14. Save your entries.

   The Maintain <Object> screen appears.
Displaying Objects

Procedure

You can display basic data for organizational units, jobs, positions and work centers if you want to review rather than edit them. This includes the abbreviation and name, the validity period, language key, and status of an object. This information is stored in the Object infotype (1000). To display tasks, see Displaying Tasks [Page 205].

7. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.

8. In the Plan version and <Object> fields, enter data as required.


10. Using the tab pages, select the status of the objects you wish to display.

11. Choose Edit → Display infotype.
    The Display Object screen appears.

12. Exit the function.
    The Maintain <Object> screen appears.
Copy objects

Procedure

Copy organizational units, jobs, positions and work centers if you want to create new objects by duplicating objects that already exist. Creating objects by copying can save you data entry time. To copy tasks, see Copying Tasks [Page 206].

When you copy objects, you can also copy all appended infotypes. This can be helpful if objects have the same attributes. The report RHCOPY10 (Copy Object Using Selection List) also allows you to copy objects.

You can also include additional infotypes in a copy request. This is not possible in Infotype Maintenance. You must use the report RHCOPY00 (Copy Objects).

7. On the Organizational Management screen, choose Expert mode → <Object>.

The Maintain <Object> screen appears.

8. In the Plan version and <Object> fields, enter data as required.

9. Choose <Object> → Copy.

The Maintain Plan Data: Copy Object dialog box appears.

10. Enter data as required in the Target object, Abbreviation and Name fields. Flag Copy relationships also.

11. Choose Copy object.

The Copy Object dialog box appears.

12. Choose Yes.

The Maintain <Object> screen appears.
Delimiting Objects

Procedure

You can delimit organizational units, jobs, positions and work centers when you want to change their validity periods, so that the end date occurs sooner than stated.

This can be necessary, for example, when you plan to eliminate an object due to restructuring. To delimit tasks, see Delimiting Tasks [Page 208].

When you delimit objects, the system delimits any infotype records appended to the object, to the same date.

7. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
8. In the Plan version and <Object> fields, enter data as required.
9. Choose <Object> → Delimit.
   The Maintain Plan Data: Delimit Object screen appears.
10. In the Delimit date and Historical rec. fields, enter data as required.
11. Choose Delimit.
    The Validity Period dialog box appears.
12. Choose Yes.
    The Maintain <Object> screen appears.
Deleting Objects

Prerequisites
You should delete organizational units, jobs, positions and work centers only when you want to erase all record of an object from the database. When you delete objects, the system deletes all appended infotypes as well. The system keeps no historical information. To delete tasks, see Deleting Tasks [Page 207].

⚠️
Deletions should only be necessary when, for example, you incorrectly or accidentally create an object. To change the validity period of an object, use the Delimit function.

Procedure

   The Maintain <Object> screen appears.

10. In the Plan version and <Object> fields, enter data as required.

11. Under Infotype name, choose Object.

12. Using the tab pages, select the status of the objects you wish to delete.

13. Choose <Object> → Delete.

   The Maintain Plan Data: Delete Object dialog box appears.

14. Check the information to ensure you have selected the correct object.

15. Choose Delete.

   The Delete Object dialog box appears.

16. Choose Yes.

   The Maintain <Object> screen appears.
Changing the Status of Objects

Procedure

You can change the status of organizational units, jobs, positions and work centers if the planning status of the object has changed in the organizational plan. Status changes occur for several reasons. For example, a planned object may be approved, and require activation. To change the status of a task, see Changing the Status of Tasks [Page 209].

When you change the status of an object, the system applies the new status retroactively, to the beginning of the object’s validity period.

To change the status for a number of objects, you can save time by using the report RHAKT100 (Change Status of Object).


   The Maintain <Object> screen appears.

10. In the Plan version and <Object> fields, enter data as required.

11. Under Infotype name, choose Object.

12. Using the tab pages, select the current status of the object.


   Another menu appears.


   The Display Object screen appears.....

15. Check the information to ensure you have selected the correct object.

16. Save your entries.

   The Maintain <Object> screen appears.
Maintaining Positions

Use

You maintain positions on the Maintain Positions screen. To access this screen, choose Human Resources → Organizational Management → Expert Mode → Position.

In this screen, you can create and maintain all possible infotypes for the position object type. Enter the name of a position and specify the status of the infotypes you want to create, using the tab pages.

The infotypes you have already maintained for a position are indicated by a green check mark.
Creating Positions

Procedure

You create positions whenever you want to add new positions to an organizational structure.

You can create positions using either Simple Maintenance or by creating *infotype 1000* (object) as described here. This ‘existence infotype’ is a prerequisite for creating further infotypes for an object.

You can also create new positions by copying existing positions. See Copying Objects [Page 197]

⚠️

You can also create positions by copying jobs. This ensures consistency and saves you time. Use the report RHMULT00 (Duplicate Objects), or work in *Simple Maintenance*.


   The Maintain Position screen appears.

2. In the Plan version and Job fields, enter data as required.

3. Under Infotype name, choose Object.

4. Using the tab pages, select the status, which you want to assign to the new object.

5. Choose Create infotype.

   The Add Object screen appears.

6. In the Validity period, Object abbreviation, and Object name fields, enter data as required.

7. Save your entries.

   The Essential relationship Relationships screen appears. To create a relationship record, go to step 8. Otherwise, skip this step.

8. To create a relationship:
   a. Enter data in the appropriate fields as required.
   b. Save your entries.

   The Maintain Position screen appears.

9. To exit the Essential relationship Relationships screen, choose Back or Cancel.

   The Maintain Position screen appears.

   If you are creating a large volume of positions, try using the Fast Entry feature.
Changing Objects

Procedure

You can change organizational units, jobs, positions and work centers when you want to edit their object abbreviations or object names. Abbreviations and names are maintained in the Object infotype (1000). To change tasks, see Changing Tasks [Page 204].

You cannot change the validity period assigned to an object using the Change function. For this, you must use the Delimit function. To change the validity period of several objects at the same time, use the report RHGRENZ0 (Delimit objects).

15. On the Organizational Management screen, choose Expert mode → <Object>.

   The Maintain <Object> screen appears.

16. In the Plan version and <Object> fields, enter data as required.

17. Under Infotype name, choose Object.

18. Using the tab pages, select the status of the objects you wish to change.

19. Choose Change infotype.

   The Change Object screen appears.

20. In the Object abbreviation and Object name fields, enter data as required.

21. Save your entries.

   The Maintain <Object> screen appears.
Expert Mode

Displaying Objects

Displaying Objects

Procedure

You can display basic data for organizational units, jobs, positions and work centers if you want to review rather than edit them. This includes the abbreviation and name, the validity period, language key, and status of an object. This information is stored in the Object infotype (1000). To display tasks, see Displaying Tasks [Page 205].

   The Maintain <Object> screen appears.
14. In the Plan version and <Object> fields, enter data as required.
15. Under Infotype name, choose Object.
16. Using the tab pages, select the status of the objects you wish to display.
17. Choose Edit → Display infotype.
   The Display Object screen appears.
18. Exit the function.
   The Maintain <Object> screen appears.
Copying Objects

Procedure

Copy organizational units, jobs, positions and work centers if you want to create new objects by duplicating objects that already exist. Creating objects by copying can save you data entry time. To copy tasks, see Copying Tasks [Page 206].

When you copy objects, you can also copy all appended infotypes. This can be helpful if objects have the same attributes. The report RHCOPY10 (Copy Object Using Selection List) also allows you to copy objects.

You can also include additional infotypes in a copy request. This is not possible in Infotype Maintenance. You must use the report RHCOPY00 (Copy Objects).


   The Maintain <Object> screen appears.

14. In the Plan version and <Object> fields, enter data as required.

15. Choose <Object> → Copy.

   The Maintain Plan Data: Copy Object dialog box appears.

16. Enter data as required in the Target object, Abbreviation and Name fields. Flag Copy relationships also.

17. Choose Copy object.

   The Copy Object dialog box appears.

18. Choose Yes.

   The Maintain <Object> screen appears.
Delimiting Objects

Procedure

You can delimit organizational units, jobs, positions and work centers when you want to change their validity periods, so that the end date occurs sooner than stated.

This can be necessary, for example, when you plan to eliminate an object due to restructuring. To delimit tasks, see Delimiting Tasks [Page 208].

When you delimit objects, the system delimits any infotype records appended to the object, to the same date.


   The Maintain <Object> screen appears.

14. In the Plan version and <Object> fields, enter data as required.

15. Choose <Object> → Delimit.

   The Maintain Plan Data: Delimit Object screen appears.

16. In the Delimit date and Historical rec. fields, enter data as required.

17. Choose Delimit.

   The Validity Period dialog box appears.

18. Choose Yes.

   The Maintain <Object> screen appears.
Deleting Objects

Prerequisites
You should delete organizational units, jobs, positions and work centers only when you want to erase all record of an object from the database. When you delete objects, the system deletes all appended infotypes as well. The system keeps no historical information. To delete tasks, see Deleting Tasks [Page 207].

Deletions should only be necessary when, for example, you incorrectly or accidentally create an object. To change the validity period of an object, use the Delimit function.

Procedure
17. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
18. In the Plan version and <Object> fields, enter data as required.
19. Under Infotype name, choose Object.
20. Using the tab pages, select the status of the objects you wish to delete.
   The Maintain Plan Data: Delete Object dialog box appears.
22. Check the information to ensure you have selected the correct object.
23. Choose Delete.
   The Delete Object dialog box appears.
24. Choose Yes.
   The Maintain <Object> screen appears.
Changing the Status of Objects

Procedure

You can change the status of organizational units, jobs, positions and work centers if the planning status of the object has changed in the organizational plan. Status changes occur for several reasons. For example, a planned object may be approved, and require activation. To change the status of a task, see Changing the Status of Tasks [Page 209].

When you change the status of an object, the system applies the new status retroactively, to the beginning of the object’s validity period.

To change the status for a number of objects, you can save time by using the report RHAKTI00 (Change Status of Object).

17. On the Organizational Management screen, choose Expert mode → <Object>.

The Maintain <Object> screen appears.

18. In the Plan version and <Object> fields, enter data as required.

19. Under Infotype name, choose Object.

20. Using the tab pages, select the current status of the object.


Another menu appears.

22. Select a new status.

The Display Object screen appears.....

23. Check the information to ensure you have selected the correct object.

24. Save your entries.

The Maintain <Object> screen appears.
Maintaining Work Centers

Use

You maintain work centers on the *Maintain Work Centers* screen. To access this screen, choose *Human Resources* → *Organizational Management* → *Expert Mode* → *Work Center*.

In this screen, you can create and maintain all possible infotypes for the work center object type. Enter the name of a work center and specify the status of the infotypes you want to create, using the tab pages.

The infotypes you have already maintained for the work center are indicated by a green check mark.
Creating Work Centers

Procedure
You can create work centers when you want to add new work centers to your organizational plan. You can also create new work centers by copying existing ones.


   The Maintain Work Center screen appears.

2. In the Plan version and Work center fields, enter data as required.

3. Under Infotype name, choose Object.

4. Using the tab pages, select the status you want to assign to the new work center.

5. Choose Create infotype.

   The Add Object screen appears.

6. In the Validity period, Object abbreviation, and Object name fields, enter data as required.

7. Save your entries.

   The Maintain Work Center screen appears.

   If you are creating a large volume of work centers, try using Fast Entry.
Changing Objects

Procedure

You can change organizational units, jobs, positions and work centers when you want to edit their object abbreviations or object names. Abbreviations and names are maintained in the Object infotype (1000). To change tasks, see Changing Tasks [Page 204].

You cannot change the validity period assigned to an object using the Change function. For this, you must use the Delimit function. To change the validity period of several objects at the same time, use the report RHGRENZ0 (Delimit objects).

   The Maintain <Object> screen appears.

23. In the Plan version and <Object> fields, enter data as required.

24. Under Infotype name, choose Object.

25. Using the tab pages, select the status of the objects you wish to change.

   The Change Object screen appears.

27. In the Object abbreviation and Object name fields, enter data as required.

28. Save your entries.
   The Maintain <Object> screen appears.
Displaying Objects

Procedure

You can display basic data for organizational units, jobs, positions and work centers if you want to review rather than edit them. This includes the abbreviation and name, the validity period, language key, and status of an object. This information is stored in the Object infotype (1000). To display tasks, see Displaying Tasks [Page 205].

   The Maintain <Object> screen appears.
20. In the Plan version and <Object> fields, enter data as required.
22. Using the tab pages, select the status of the objects you wish to display.
23. Choose Edit → Display infotype.
   The Display Object screen appears.
24. Exit the function.
   The Maintain <Object> screen appears.
**Copying Objects**

**Procedure**

Copy organizational units, jobs, positions and work centers if you want to create new objects by duplicating objects that already exist. Creating objects by copying can save you data entry time. To copy tasks, see [Copying Tasks](Page 206).

When you copy objects, you can also copy all appended infotypes. This can be helpful if objects have the same attributes. The report RHCOPY10 (Copy Object Using Selection List) also allows you to copy objects.

You can also include additional infotypes in a copy request. This is not possible in Infotype Maintenance. You must use the report RHCOPY00 (Copy Objects).

   The Maintain <Object> screen appears.

20. In the Plan version and <Object> fields, enter data as required.

21. Choose <Object> → Copy.
   The Maintain Plan Data: Copy Object dialog box appears.

22. Enter data as required in the Target object, Abbreviation and Name fields. Flag Copy relationships also.

23. Choose Copy object.
   The Copy Object dialog box appears.

24. Choose Yes.
   The Maintain <Object> screen appears.
Delimiting Objects

Procedure

You can delimit organizational units, jobs, positions and work centers when you want to change their validity periods, so that the end date occurs sooner than stated.

This can be necessary, for example, when you plan to eliminate an object due to restructuring. To delimit tasks, see Delimiting Tasks [Page 208].

When you delimit objects, the system delimits any infotype records appended to the object, to the same date.


The Maintain <Object> screen appears.

20. In the Plan version and <Object> fields, enter data as required.


The Maintain Plan Data: Delimit Object screen appears.

22. In the Delimit date and Historical rec. fields, enter data as required.

23. Choose Delimit.

The Validity Period dialog box appears.

24. Choose Yes.

The Maintain <Object> screen appears.
Deleting Objects

Prerequisites

You should delete organizational units, jobs, positions and work centers only when you want to erase all record of an object from the database. When you delete objects, the system deletes all appended infotypes as well. The system keeps no historical information. To delete tasks, see Deleting Tasks [Page 207].

Deletions should only be necessary when, for example, you incorrectly or accidentally create an object. To change the validity period of an object, use the Delimit function.

Procedure


   The Maintain <Object> screen appears.

26. In the Plan version and <Object> fields, enter data as required.

27. Under Infotype name, choose Object.

28. Using the tab pages, select the status of the objects you wish to delete.

29. Choose <Object> → Delete.

   The Maintain Plan Data: Delete Object dialog box appears.

30. Check the information to ensure you have selected the correct object.

31. Choose Delete.

   The Delete Object dialog box appears.

32. Choose Yes.

   The Maintain <Object> screen appears.
Changing the Status of Objects

Procedure

You can change the status of organizational units, jobs, positions and work centers if the planning status of the object has changed in the organizational plan. Status changes occur for several reasons. For example, a planned object may be approved, and require activation. To change the status of a task, see Changing the Status of Tasks [Page 209].

When you change the status of an object, the system applies the new status retroactively, to the beginning of the object's validity period.

To change the status for a number of objects, you can save time by using the report RHAKTI00 (Change Status of Object).


   The Maintain <Object> screen appears.

26. In the Plan version and <Object> fields, enter data as required.

27. Under Infotype name, choose Object.

28. Using the tab pages, select the current status of the object.

29. Choose Edit → Status.

   Another menu appears.

30. Select a new status.

   The Display Object screen appears.....

31. Check the information to ensure you have selected the correct object.

32. Save your entries.

   The Maintain <Object> screen appears.
Maintaining Tasks

Use
Due to a change in task areas in your company, you want to add new tasks to your task catalog. Or you may wish to change tasks already contained in your task catalog. This may be necessary, for example, if tasks have changed due to changes in job or position descriptions.

Activities
To maintain tasks using infotypes, go to the Task Catalog screen by choosing Human resources → Organizational management → Expert mode → Task catalog.

On the Maintain Task screen, you can create or edit infotypes for the task object type by choosing Create or Change. If you are changing a task that already exists, the ID, name and abbreviation of the task you previously selected are automatically transferred. The infotypes you have already maintained for a task are indicated by a green check mark.

If you want to create new infotypes for a task, specify their status using the tab pages.

You can only maintain tasks from the Human resources view. For information on Workflow or standard tasks and workflow templates, see SAP Business Workflow [Ext.], for more information on task maintenance, see Tasks and Task Groups [Ext.].
Create tasks

Procedure

You create tasks when you want to add new tasks to the task catalog you maintain for an organizational plan. You can also create new tasks by copying existing ones. See Copying Tasks [Page 206]

1. On the Organizational Management screen, choose Expert mode → Task Catalog.
   The Task Catalog screen appears.
2. Determine how the system is to build up a task catalog by entering data as required in the appropriate fields.
3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.
4. If the new task should stand on its own as a single task, choose Task Catalog.
5. If the new task is to be part of a task group, select the task that is to be or is the superior task.
6. Choose Create.
   The Maintain Task screen appears.
7. Check the Plan version and Task fields.
   The system inserts this information according to your selection in the task catalog.
8. Under Infotype name, choose Object.
9. Using the tab pages, select the status, which you want to assign to the new task.
10. Choose Create infotype.
    The Add Object screen appears.
11. In the Validity, Object abbreviation, and Object name fields, enter data as required.
12. Save your entries.
    The Maintain Task screen appears. To create a relationship record, refer to the procedure described below.

Creating Relationships

To create a relationship:
1. Under Infotype name, choose Relationships.
2. Choose Create infotype.
   The Add Relationship screen appears.
3. Enter data in the appropriate fields as required.
4. Save your entries.
   The Maintain Task screen appears.
5. To exit the Maintain Task screen, choose Back or Cancel.

   The Task Catalog screen appears.
Changing Tasks

Procedure

You can change tasks when you want to edit a task’s object abbreviation, or object name. Abbreviations and names are maintained in the Object infotype (1000).

1. On the Organizational Management screen, choose Task catalog.
   The Task Catalog screen appears.

2. Determine how the system is to build up a task catalog by entering data as required in the appropriate fields.

3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.

4. Select the task you want to change.

5. Choose Change.
   The Maintain Task screen appears.

6. Check the Plan version and Task fields.
   The system inserts this information according to your selection in the task catalog.

7. Under Infotype name, choose Object.

8. Using the tab pages, select the status of the task you wish to change.

9. Choose Change infotype.
   The Object Infotype screen appears.

10. In the Object abbreviation and Object name fields, enter data as required.

11. Save your entries.
   The Maintain Task screen appears.

12. To return to the Task Catalog screen, choose Back or Cancel.
Displaying Tasks

Procedure

You can display the basic information on a task if you want to review, rather than edit it. This includes an object's abbreviation and name, its validity period, language key, and status. This information is stored in the Object infotype (1000).

1. On the Organizational Management screen, choose Task catalog.
   The Task Catalog screen appears.
2. Determine how the system should build up a task catalog by entering data as required in the appropriate fields.
3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.
4. Select the task you want to display.
5. Choose Task → Display.
   The Maintain Task screen appears.
6. Check the Plan version and Task fields.
   The system inserts this information according to your selection in the task catalog.
7. Under Infotype name, choose Object.
8. Using the tab pages, select the status of the task you wish to display.
   The Display Object screen appears.
10. Exit the function.
11. To return to the Task Catalog screen, choose Back or Cancel.
Copy Task

Procedure

You can copy tasks when you want to create a new task by duplicating an existing one. Creating objects by copying can save you data entry time.

When you copy tasks, you can also copy all records for the Relationship infotype. This can be helpful when tasks have the same attributes. The report RHCOPY10 (Copy Object Using Selection List) also allows you to copy objects. Using this report, you can include additional infotypes in the copy request.

1. On the Organizational Management screen, choose Expert mode → Task Catalog.
   The Task Catalog screen appears.

2. Determine how the system is to build up a task catalog by entering data as required in the appropriate fields.

3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.

4. Select the task you want to copy.

5. Choose Task → Display.
   The Maintain Task screen appears.

6. Check the Plan version and Task fields.
   The system inserts this information according to your selection in the task catalog.

7. Choose Task → Copy.
   The Maintain Plan Data: Copy Object screen appears.

8. In the Target object, Abbreviation and Name fields, enter data as required. Flag Copy relationships also.

9. Choose Copy object.
   The Copy Object dialog box appears.

10. Choose Yes.

11. To return to the Task Catalog screen, choose Back or Cancel.
Deleting Tasks

Prerequisites
You should delete tasks only when you want to erase all record of a task from the database. When you delete tasks, the system deletes all appended infotypes as well. The system keeps no historical information.

⚠️
Deletions should only be necessary when, for example, you incorrectly or accidentally create a task. To change the validity period of a task, use the Delimit function.

Procedure
1. On the Organizational Management screen, choose Task catalog.
   The Task Catalog screen appears.
2. Determine how the system is to build up a task catalog by entering data as required in the appropriate fields.
3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.
4. Select the task you want to delete.
5. Choose Tasks → Delete.
   The Delete Task dialog box appears.
6. Choose Yes.

Result
The system confirms that the object has been deleted. The Task Catalog screen appears.
Delimiting Tasks

Procedure

Delimit tasks if you want to bring the validity end date forward, and in so doing, change the validity period.

This can be necessary if, for example, you want to eliminate a task due to restructuring.

⚠️ When you delimit objects, the system delimits any infotype records appended to the object, to the same date.

1. On the Organizational Management screen, choose Task catalog.

   The Task Catalog screen appears.

2. Determine how the system is to build up a task catalog by entering data as required in the appropriate fields.

3. Choose Execute.

   The Task Catalog screen appears, displaying the selected tasks.

4. Choose Task → Display.

5. Check the Plan version and Task fields.

   The system inserts this information according to your selection in the task catalog.

6. Under Infotype name, choose Object.

7. In the Status field, select the status of the task you want to delimit.

8. Choose Task → Delimit.

   The Maintain Plan Data: Delimit Object screen appears.

9. In the Delimit date and Historical rec. fields, enter data as required.

10. Choose Delimit.

    The Delimit Object dialog box appears.

11. Choose Yes.

12. To return to the Task Catalog screen, choose Back or Cancel.
Changing the Status of Tasks

Procedure

You can change the status of a task if the plan status of a task in your organizational plan changes. Status changes occur for several reasons. For example, a planned task may be approved, and require activation.

When you change the status of an object, the system applies the new status retroactively, to the beginning of the object's validity period.

To change the status for a number of objects, you can save time by using the report RHAKIT00 (Change Status of Object).

1. On the Organizational Management screen, choose Expert mode → Task Catalog.
   The Task Catalog screen appears.
2. Determine how the system is to build up a task catalog by entering data as required in the appropriate fields.
3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.
4. Select the task, whose status you want to change.
5. Choose Task → Display.
   The Maintain Task screen appears.
6. Check the Plan version and Task fields.
   The system inserts this information according to your selection in the task catalog.
7. Under Infotype name, choose Object.
8. Using the tab pages, select the current status of the task.
   Another menu appears.
10. Select a new status.
    The Object Infotype screen appears.
11. Check the information to ensure you have selected the correct task.
12. Save your entries.
    The Maintain Task screen appears.
General Maintenance

Use

You can use *General Maintenance* to maintain infotypes if you want to select object types directly during editing. The advantage of *General Maintenance* is that you can maintain infotypes for object types that do not belong to Organizational Management.

You can work with qualifications and appraisals (*Personnel Development*), or events, resources and event types (*Training and Event Management*), for example.

You can flag the object types and infotypes per object type, that are not to be edited using General Maintenance, in Customizing. Make the necessary settings in the step *Maintain Infotypes (Infotype per Object Type)*, choose *Basic Settings → Data Model Enhancement → Infotype Maintenance*.

Note that you can not maintain infotypes for a particular object if the ‘existence infotype’ 1000 (*Object*) has not been flagged as maintainable.

To access General Maintenance, choose *Human Resources → Organizational Management → Expert Mode → General*

Creating, editing, displaying and deleting infotypes as well as changing the status of objects using *General Maintenance* is the same as for the basic object types in *Organizational Management*. Refer to the following chapters:

- Maintaining Organizational Units [Page 169]
- Maintaining Jobs [Page 177]
- Maintaining Positions [Page 185]
- Maintaining Work Centers [Page 193]
- Maintaining Tasks [Page 201]
Maintaining Infotype Records for Objects

Use
In Expert Mode, you can create and edit infotype records on the standard infotype maintenance screen, that is, you can change, display, copy, delimit and delete infotype records.

You can also display records for an infotype in a list and make changes, in this list, to individual records.

Prerequisites
The procedure for maintaining infotype records for objects refers to the basic object types of Organizational Management – organizational units, jobs, positions, work centers and tasks. The procedure for the task object type is different, due to the character of the object type.

Maintaining all other object types is the same as for all the object types named above.

The infotypes you wish to maintain can be flagged as not maintainable in Customizing. See General Maintenance [Page 210]
Creating Infotype Records

Prerequisites

So that you can create infotype records for objects, the object, that is the ‘existence infotype’ 1000 (Object), must already have been created. You can create this in Simple Maintenance or by maintaining infotypes for objects.

Note that all the object types and infotypes that have been flagged as not maintainable in customizing in Customizing, can not be maintained in the standard infotype maintenance screen. See General Maintenance [Page 210]

Procedure

You create infotype records if you want to create the object itself (infotype 1000 Object) or if you want to create additional characteristics for an object.

The procedure for creating additional infotype records varies for each infotype. For example, the final steps involved in creating the Description infotype (1002) are different to those followed to create the Work Schedule infotype (1011) record.

1. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. In the Infotypes field, select the infotype you want to create.
   It could be that not all the infotypes that are available can be displayed on one screen. By using Page up and Page down, you can display all infotypes.
4. Using the tab pages, select the status the new infotype record.
5. Choose Edit → Create infotype.
   The infotype screen you selected appears.
6. Enter data in the appropriate fields as required.
7. Save your entries.
   The Maintain <Object> screen appears.
Changing Infotype Records

Prerequisites

Not all data in an infotype records can always be changed. For example, you cannot change the validity period of an infotype record. To do this, you must use the Delimit function.

The individual infotypes – Relationship infotype (1001), Description infotype (1002), and so on – may have further restrictions on what can be altered in change mode.

Procedure

You can change infotype records when you want to edit the information they contain.

1. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. Under Infotype name, select the infotype you want to change.
4. Using the tab pages, select the current status of the infotype.
5. Choose Edit → Change infotype.
   The infotype screen you selected appears.

   If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to change.

6. Edit the fields you want to change.
7. Save your entries.
   The Maintain <Object> screen appears.
Displaying Infotype Records

Procedure
You can display infotype records when you want to review, but not edit, the information contained in a record.

1. On the Organizational Management screen, choose Expert mode → <Object>.

   The Maintain <Object> screen appears.

2. In the Plan version and <Object> fields, enter data as required.

3. Under Infotype name, select the infotype you want to display.

4. Using the tab pages, select the current status of the infotype.

5. Choose Edit → Display infotype.

   The infotype screen you selected appears.

   If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to change.

6. Exit the function.

   The Maintain <Object> screen appears.

To display the list of all infotype records that exist for an object,

1. Under Infotype name, choose Object.

2. Select a status.

3. Choose Goto → Display overview.
Copy Infotype Records

Procedure
You copy infotype records for a particular object if you want to re-use the information they contain. This will considerably reduce data-entry time.

1. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. Under Infotype name, select the infotype you want to change.
4. Using the tab pages, select the status of the objects you wish to copy.
5. Choose Edit → Copy infotype.
   The infotype screen you selected appears.
   
   If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to delete.
6. Overwrite the default values according to your requirements.
7. Save your entries.
   The Maintain <Object> screen appears.
Delimiting Infotype Records

Procedure

Delimit infotype records if you want to bring the validity end date forward, and in so doing, change the validity period.

If, for example, the working time stored for a position has changed, you can delimit the corresponding record for the Work Schedule infotype and create a new one.

2. In the Plan version and <Object> fields, enter data as required.
3. Under infotype name, select the infotype you want to delimit.
4. Using the tab pages, select the current status of the infotype.
5. Choose Edit → Delimit infotype. The infotype screen you selected appears.

   If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to delimit.

6. In the Validity and Historical rec fields, enter data as required.
Deleting Infotype Records

Prerequisites
You should delete infotype records only when you want to erase all account of a record from the database. The system keeps no historical information.

Deleting Infotype Records

Procedure
2. In the Plan version and <Object> fields, enter data as required.
3. Under Infotype name, select the infotype you want to delete.
4. Using the tab pages, select the current status of the infotype.
5. Choose Edit → Delete infotype.

The infotype screen you selected appears.

If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to delete.
6. Choose Delete.

The Delete Selected Infotype dialog box appears.
7. To delete, choose Yes.

The Maintain <Object> screen appears.
Changing the Status of Infotype Records

Procedure

You can change the status of an infotype record when the record’s standing in a plan changes. Status changes occur for several reasons. For example, a planned infotype may be approved or confirmed, and require activation.

When you change the status of an infotype, the system applies the new status retroactively, to the beginning of the infotype record’s validity period, unless you select Propose change.

To change the status of a number of infotype records, you can save time using the report RHAKTI00 (Change Status of Object). This report allows you to select the infotypes whose status is to be changed.

1. On the Organizational Management screen, choose Expert mode → <Object>.
   The Maintain <Object> screen appears.
2. In the Plan version and <Object> fields, enter data as required.
3. Under Infotype name, choose Object.
4. Using the tab pages, select the current status of the object.
5. Choose Edit → Status change.
   Another menu appears.
6. Select a new status.
   An infotype screen appears, displaying the selected record.
7. Save your entries.
   The Maintain <Object> screen appears.
Maintaining Infotype Records for Tasks

Use

In Expert Mode, you can create and edit infotype records for tasks on the standard infotype maintenance screen, that is, you can change, display, copy, delimit and delete infotype records for tasks.

You can also display infotype records for a task in a list and make changes, in this list, to individual records.

Prerequisites

See Maintaining Infotype Records for Objects [Page 211]
Creating Infotype Records for Tasks

Prerequisites

So that you can create infotype records for tasks, the object, that is the ‘existence infotype’ 1000 (Object), must already have been created. You can create this in Simple Maintenance or by maintaining infotypes for objects.

The procedure for creating additional infotype records varies for each infotype. For example, the final steps involved in creating the Description infotype (1002) are different to those followed to create the Work Schedule infotype (1011) record.

Procedure

You create infotype records if you want to create the task itself (infotype 1000 Object) or if you want to create additional characteristics for a task.

1. On the Organizational Management screen, choose Expert mode → Task Catalog. The Task Catalog screen appears.
2. Determine how the system should build up a task catalog by entering data as required in the appropriate fields.
3. Choose Execute. The Task Catalog screen appears.
4. Select a task.
5. Choose Display. The Maintain Task screen appears.
6. Check the Plan version and Task fields to ensure they state the correct version and task. The system inserts this information according to your selection in the task catalog.
7. Under Infotype name, select the infotype you want to create.

   It could be that not all the infotypes that are available can be displayed on one screen. By using Page up and Page down, you can display all infotypes.
8. Using the tab pages, select the status of the new infotype record.
9. Choose Edit → Create infotype. The infotype screen you selected appears.
10. Enter data in the appropriate fields as required.
11. Save your entries.
12. To return to the Task Catalog screen, choose Back or Cancel.
Changing Infotype Records for Tasks

Prerequisites

Not all data in an infotype records can always be changed. For example, you cannot change the validity period of an infotype record. To do this, you must use the Delimit function.

The individual infotypes – Relationship infotype (1001), Description infotype (1002), and so on – may have further restrictions on what can be altered in change mode.

Procedure

You can change infotype records when you want to edit the information they contain.

1. On the Organizational Management screen, choose Expert mode → Task catalog.
   The Task Catalog screen appears.
2. Determine how the system should build up a task catalog by entering data as required in the appropriate fields.
3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.
4. Select the task you want to delimit.
5. Choose Task → Display.
   The Maintain Task screen appears.
6. Check the Plan version and Task fields to ensure they state the correct version and task.
   The system inserts this information according to your selection in the task catalog.
7. Under Infotype name, select the infotype you want to create.

   It could be that not all the infotypes that are available can be displayed on one screen. By using Page up and Page down, you can display all infotypes.
8. Using the tab pages, select the current status of the infotype record.
9. Choose Edit → Change infotype.
   The infotype screen you selected appears.

   If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to change.
10. Edit the fields you want to change.
11. Save your entries.
   The Maintain Task screen appears.
12. To return to the Task Catalog screen, choose Back or Cancel.
Changing Infotype Records for Tasks
Displaying Infotype Records for Tasks

Procedure

You can display infotype records when you want to review, but not edit, the information contained in a record.

Using the Maintain or Display overview function in the standard infotype maintenance screen, you can display a list of all infotype records that exist for an object.

1. On the Organizational Management screen, choose Expert mode → Task Catalog.
   The Task Catalog screen appears.
2. To inform the system, which tasks should be selected, enter the required data in the appropriate fields.
3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.
4. Select the task you want to delimit.
5. Choose Task → Display.
   The Maintain Task screen appears.
6. Check the Plan version and Task fields to ensure they state the correct version and task.
   The system inserts this information according to your selection in the task catalog.
   If you have selected more than one task, you can display the object IDs of the other tasks for which you want to display the infotypes in the Task field, using Back.
7. Under Infotype name, select the infotype you want to display.
8. Using the tab pages, select the current status of the infotype.
   The infotype screen you selected appears.
   If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to change.
10. To exit the screen, choose Back or Cancel.
    The Maintain Task screen appears.
11. To return to the Task Catalog screen, choose Back or Cancel.
Copy Infotype Records for Tasks

Procedure

You copy infotype records for tasks if, for example, you want to transfer the object itself or the object’s relationship to a new infotype record.

1. On the Organizational Management screen, choose Expert mode → Task Catalog.
   The Task Catalog screen appears.
2. Select the task whose infotypes you wish to copy.
3. Choose Task → Display or Change
   The Maintain Task screen appears.
4. Select the infotype that you wish to copy.
5. Using the tab pages, select the current status of the infotype.
6. Choose Edit → Copy infotype.
   The infotype screen you selected appears.

   If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to delete.
7. Overwrite the default values according to your requirements.
8. Save your entries.
   The Maintain Task screen appears.
9. To return to the Task Catalog screen, choose Back or Cancel.
Delimiting Infotype Records for Tasks

Procedure

Delimit infotype records if you want to bring the validity end date forward, and in so doing, change the validity period.

It can be necessary to delimit a record for the Relationships infotype if a task is no longer to be used to describe a position and the validity of the relationship is to end before the validity end date.

1. On the Organizational Management screen, choose Expert mode → Task Catalog.
   The Task Catalog screen appears.
2. Determine how the system should build up a task catalog by entering data as required in the appropriate fields.
3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.
4. Select the task you want to edit.
5. Choose Task → Display.
   The Maintain Task screen appears.
6. Check the Plan version and Task fields to ensure they state the correct version and task.
   The system inserts this information according to your selection in the task catalog.
7. Select the infotype that you wish to delimit.
8. Using the tab pages, select the current status of the infotype record.
   The infotype screen you selected appears.

   If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to delimit.
10. In the Validity and Historical rec fields, enter data as required.
11. Choose Delimit.
   The Maintain Task screen appears.
12. To return to the Task Catalog screen, choose Back or Cancel.
Deleting Infotype Records for Tasks

Prerequisites
You should delete infotype records only when you want to erase all account of a record from the database. The system keeps no historical information.

Deletions should only be necessary, for example, when you incorrectly or accidentally create a an infotype. To change the validity period of a record, use the Delimit Function.

Procedure

The Task Catalog screen appears.
11. Determine how the system should build up a task catalog by entering data as required in the appropriate fields.
12. Choose Execute.

The Task Catalog screen appears, displaying the selected tasks.
13. Select the task you want to edit.

The Maintain Task screen appears.
15. Check the Plan version and Task fields to ensure they state the correct version and task.

The system inserts this information according to your selection in the task catalog.
16. Select the infotype you want to delete.
17. Using the tab pages, select the current status of the infotype record.
18. Choose Edit → Delete infotype.

The infotype screen you selected appears.

If more than one infotype record is available, choose Goto → Previous record or Next record to select the record that you want to delete.
19. Choose Delete.

The Delete<selected infotype> dialog box appears.
20. To delete, choose Yes.

The Maintain Task screen appears.
21. To return to the Task Catalog screen, choose Back or Cancel.
Changing the Status of Infotype Records

Procedure

You can change the status of an infotype record when the record’s standing in a plan changes. Status changes occur for several reasons. For example, a planned infotype may be approved or confirmed, and require activation.

When you change the status of an infotype, the system applies the new status retroactively, to the beginning of the infotype record’s validity period, unless you select Propose change.

To change the status of a number of infotype records, you can save time using the report RHAKTI00 (Change Status of Object), rather than working in Detail Maintenance. This report allows you to select the infotypes whose status is to be changed.

1. On the Organizational Management screen, choose Expert mode → Task Catalog.
   The Task Catalog screen appears.
2. In the appropriate fields, enter data as required.
3. Choose Execute.
   The Task Catalog screen appears, displaying the selected tasks.
4. Select the task you want to edit.
5. Choose Task → Display.
   The Maintain Task screen appears.
6. Check the Plan version and Task fields to ensure they state the correct version and task.
   The system inserts this information according to your selection in the task catalog.
7. Under Infotype name, select the infotype you want to edit.
8. Using the tab pages, select the current status of the infotype record.
   Another menu appears.
10. Select a new status.
    An infotype screen appears, displaying the selected record.
11. Save your entries.
    The Maintain Task screen appears.
12. To return to the Task Catalog screen, choose Back or Cancel.
Simple Maintenance

Use

*Simple Maintenance* in Expert Mode is one of the methods you can use to develop and model organizational plans in the component *Organizational Management* with speed and efficiency.

In addition to mapping your current organizational and reporting structure, *Simple Maintenance* gives you flexible tools to plan and model future structural changes well in advance.

Although *Simple Maintenance* is available to all users of *Organizational Management*, it was originally designed to meet the needs of *SAP Business Workflow* users.

*SAP Business Workflow* users do not need all the functions available in *Organizational Management*. For this reason, the original concept behind *Simple Maintenance* was to provide a tool that allows users to build and maintain organizational plans, with speed and simplicity.

Features

- For *Organizational Management* users, *Simple Maintenance* is best used to establish the basic framework in organizational plan development.

- *Simple Maintenance* uses a tree structure, which allows you to create a basic framework for organizational plans, using streamlined procedures. In this way, you can create your organizational and reporting structures step by step.

- There are three main areas in Simple Maintenance. Each area contains particular maintenance functions, depending on whether you want to edit organizational structures, staff assignments or task profiles.

- For complete, detailed editing of individual organizational objects in your organizational plan (editing particular positions or organizational units, for example), we recommend that you switch to *Infotype Maintenance [Page 162]*.

- Workflow users, who do not require all HR functions, should use *Simple Maintenance*. See also, *SAP Business Workflow (BC-BMT-WFM) [Ext.]*

See also:

*Organizational Management [Page 13]*
Object Manager

Use

With the object manager you can search for and select objects that you want to display or edit.

Prerequisites

You are familiar with the validity concept of the application. The validity concept determines which objects you can find during a search.

Features

The object manager consists of the search area and the selection area.

- In the search area are one or more search functions for each object type, for example the Search Term and Structure Search functions. These search functions are marked with . In addition, the object type itself can contain a search function. The object types are marked with the respective object type-specific symbol.

If necessary, you can add more object types and search functions in customizing. You can also change the sequence of the search functions. For further information see the Implementation Guide (IMG) under Personnel Management → Global Settings in Personnel Management → Settings for Object Manager or the IMG for Organizational Management.
Object Manager

- In the search area you can create **search variants**, so that you can reuse search criteria you have grouped together, or hits. These search variants are marked with 📚.
- In the **selection area** the system displays the objects that you searched for and actually found. According to the search function, this can be either a hit list or a structure.
- You can scroll through search results in the selection area using ← and →.
- You can completely hide or display the **object manager**, so that the other screen areas get correspondingly bigger or smaller. To do that, choose **Settings → Show Object Manager** or **Hide Object Manager**.
- With 📐 you can increase or reduce the size of the selection area, in order to show more hits. As you do that, the search area is hidden or displayed accordingly.

The system saves the last settings relating to screen size and the last object selection user-specifically, and they are available next time you call up the transaction.

You can reset these settings and the last object selection using the report RH_DELETE_OM_USER_SETTINGS. Note that the reset takes place across all applications. For more information, see the report documentation.

- You can call up **generic object services** for a selected object using the right mouse button menu. To do that, select an object in the selection area with the right mouse button and choose **Generic Object Services**. For further information about generic object services, see **List of Object Services [Ext.]**.
Finding/Selecting Objects

Use
In the Search area you can search for one or more objects that you want to display or edit. For each object type there are various search functions, for example:
- Search Term
- Structural Search
- Free Search

Prerequisites
Objects you are searching for must already exist. Create new objects as required. The required object types and search functions are set up.

Procedure
2. In the search area select one of the available search functions and if necessary enter the required selection criteria.
   In the selection area the system displays all found objects with the corresponding object type, either as a list or as a structure.
3. Double-click on the required object.
Using Search Variants

Use

In some search functions, for example *Search Term*, you can restrict the number of hits by using a combination of selection criteria. You can then save such a combination as a *search variant* so that you can use it again. You can also delete a search variant again, if necessary.

Procedure

Creating Search Variants

2. Use one of the search functions to search for objects.
   
   The system displays the hits in the *selection area*.

3. Choose and enter a name. Choose .
   
   The system saves the search criteria as a search variant and assigns them to the corresponding object type in the *search area*. The search variant is marked with .

4. Select the search variant you created and choose . You can check your search criteria.

Searching for Objects Using a Search Variant

3. Select a search variant.
   
   The hits are displayed in the *selection area*.

4. Double-click on the required object.

Deleting Search Variants

3. Select the search variant that you want to delete.

4. Choose .
   
   The search variant is deleted.
Using Search Tools

Use

With the search tools for each object type you can search for objects in various object type-specific ways.

These search tools are marked with 📋. In addition, the object type itself can contain a search tool. The object types are marked with the respective object type-specific symbol.

Prerequisites

You are familiar with how the search tools are assigned.

- In the search area, the object type itself can contain a search tool. The object types are marked with 📋.
- Search tools can be positioned under the corresponding object type. In that case it is marked with 📋.

Procedure

Searching for Objects Using a Search Term

2. Choose Search Term (or the required object type, if it has this search function).
   The Search for <object type> dialog box appears.
5. Enter a name. This can be a name, abbreviation or numeric ID. You can also search using the entry *.
6. Restrict the number of hits, if required. Enter whether the object you are looking for is directly or indirectly assigned to another object.
7. Choose 🕵️ Search.
   The results of the search are displayed in the selection area. The display in the overview and detail areas does not change.
7. If necessary, you can start another search for the same object type and then choose 📦 Insert to add the new hits to the first results in the selection area.
8. Double-click on the required object in the selection area.

Searching for Objects Using Free Search

The Free Search search tool uses the InfoSet Query.

3. Choose Free Search (or the required object type, if it has this search function).
   The Find Objects of Type <Object type> dialog box appears. For further information, see HR in the InfoSet Query [Ext]. After the search, the system displays the search results in the selection area.
4. Double-click on the required object in the selection area.
Using Search Tools

**Searching for Objects Using Structure Search**

2. Choose *Structure Search* (or the required object type, if it has this search function).

   In the **selection area** the system displays all found objects of the relevant object type in a tree structure, ordered according to their assignment in the organizational plan.

   ![Refresh Hits](image)

   If necessary, you can refresh the hits displayed in the selection area using ![Refresh](image). This is recommended, for example, if you have created new objects shortly before.

3. Expand the structure until the required object is revealed.

4. Double-click on the required object in the selection area.
Foundations

Use

Simple Maintenance is one of the methods you can use to develop and model organizational plans in the component Organizational Management with speed and efficiency.

Features

In Simple Maintenance, you can:

- **create basic objects**
  
  In Simple Maintenance you can create the basic objects of your organizational plan, that is, organizational units, jobs, positions and tasks, with speed and simplicity. These are arranged in a tree structure. Depending on the objects you have selected, the system automatically creates the corresponding relationships.

- **use plan versions**
  
  You need a plan version to work with an organizational plan in Simple Maintenance. A plan version is a designated area where you deposit different sets of information. The system always defaults to the plan version which has been designated as the active plan version.

- **select views**
  
  As Simple Maintenance was conceived both for users of SAP Business Workflow and Human Resources users, you can switch between two views. The overall view provides the user with access to all functions necessary for using Workflow. The human resources view restricts access to human resources areas.

- **use three main screens**
  
  In Simple Maintenance, you work with three main screens. Each of these screens offers different editing functions.
  
  - The Change Organizational Structure screen allows you to build up and maintain the organizational structure for your organizational plan.
  
  - The Change Staff Assignments screen allows you to create staff assignments. This is achieved by creating jobs and positions, and by assigning holders to positions.
  
  - The Change Task Profile screen allows you to create, maintain, and view task profiles for jobs, positions and organizational units.

Simple Maintenance also allows you to establish and maintain:

- A reporting structure (chain of command) among the positions in an organizational plan
- Cost center assignments, as well as default settings for cost centers
- Certain infotypes

To minimize the number of procedures you have to follow, some HR functions are not available in Simple Maintenance. You cannot create and maintain work centers, for example.

All objects you create in Simple Maintenance automatically receive active status
Switching Maintenance Interfaces

Use
You can replace the Organization and Staffing and the Organization and Staffing (Workflow) views with Simple Maintenance. You may want to switch if, for example, you have already used Simple Maintenance and you want to work with the maintenance interface you are used to. For more information on Simple Maintenance, see Simple Maintenance [Page 228].

In addition, you can jump to Infotype maintenance from a selected object. For more information, see Infotype Maintenance [Page 162].

Procedure

Situation A: You are in Organization and Staffing or Organization and Staffing (Workflow) view and want to switch to Simple Maintenance.

Choose Settings → Maintenance Interface. You access Simple Maintenance.

If you do not change this setting, you will automatically access Simple Maintenance when you call up a maintenance interface in the future.

Situation B: You want to reverse this setting. You are in Simple Maintenance.

Choose Settings → Maintenance Interface. The Organization and Staffing interface appears.

When you call up a maintenance interface in future, the Organization and Staffing view will appear.

Situation C: You are in neither of the two maintenance interfaces; you want to select an interface.

In the SAP menu choose Human resources → Organizational management → Settings → Set maintenance interface. The Set maintenance interface dialog box appears. Select a maintenance interface and confirm by choosing . If you do not change this setting, you will automatically access the interface you select when you call up a maintenance interface in the future.

Situation D: You have selected an object in the Organization and Staffing maintenance interface and displayed its characteristics in the detail area. You want to go to the infotype maintenance for this object.

Choose Goto → Detail object → Enhanced object description. To get back to the Organization and Staffing view, choose .
Standard Features

Use

Standard Features in Simple Maintenance describe amongst other things, how to edit or display objects and structures from your organizational plan, where information should be entered when working with objects or how to steer yourself round Simple Maintenance, for example, expanding and compressing tree structures, displaying particular parts of a structure and so on.

Features

Standard functions in Simple Maintenance can be structured so that they concern the following:

- accessing Simple Maintenance
- tree structures
- changing between modi or screens
- transferring to Infotype Maintenance
Accessing Simple Maintenance

You can start Simple Maintenance from:

- Organizational Management
- Business Workflow, in the Basis component

How you access Simple Maintenance depends on where in the system you are working. You can either access it via Human resources → Organizational Management → Expert mode or Tools → Business Workflow → Organizational plan → Expert mode.
Working with Screen Areas

Use
You use the screen areas to select and edit objects. To do so, you select the view you want to edit.

Integration
For more information on the views available, see
- Views [Page 260]
- Access from Organizational Management [Page 242]

Features
- Create mode in Simple Maintenance contains one screen area.
- Change mode and display mode in Simple Maintenance have three screen areas.

In the work area, you can
- select objects that you want to edit
- select the view you want
- edit the objects and structures in your organizational plan

There are various screen which allow you to do this. For more information, see Screens [Page 261].
All procedures described in the following documentation relate to this work area.

- The search area represents an alternative method of searching for organizational objects.
  - All *Simple Maintenance* screens allow you to search for organizational units using the search area.
  - In the *Change task profile* and *Display task profile* screens, you can also search for positions, jobs, persons and users.

The following search functions are available to you depending on object type:

- The **search term** allows you to search for the name or ID of an object.
- The **structure search** displays all objects of the object type concerned according to their assignment in the organizational plan in a structure tree.
- The **Ad Hoc Query** allows you to carry out very specific selections. For more information, see Human Resources Ad Hoc Query

- The objects found will be listed in the **Selection area**. You can select the object you need by double-clicking on it. It is then displayed in the **work area** and can be processed there.

**Activities**

To call up screen areas, choose

- [Create mode][Page 244], to create an organizational plan
- [Change mode][Page 245] to edit an existing organizational plan
- [Display mode][Page 246] to display an existing organizational plan
Access from Organizational Management

Use

The following is an overview of the views available to you in Simple Maintenance, including their functions and editing modes:

Access the Change organizational plan and Display organizational plan screens via Organizational Management → Expert mode → Simple Maintenance → Change or Display. From here, you can choose one of the views below:

<table>
<thead>
<tr>
<th>You are working in this view:</th>
<th>and you want to do</th>
<th>use this mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic data (Organizational plan)</td>
<td>create a plan</td>
<td>create</td>
</tr>
<tr>
<td></td>
<td>add or edit information</td>
<td>change</td>
</tr>
<tr>
<td></td>
<td>review information</td>
<td>display</td>
</tr>
<tr>
<td>Reporting structures</td>
<td>add or edit information</td>
<td>change</td>
</tr>
<tr>
<td></td>
<td>review information</td>
<td>display</td>
</tr>
<tr>
<td>Account Assignment</td>
<td>• Creating Cost Center Assignments</td>
<td>change</td>
</tr>
<tr>
<td></td>
<td>• Create cost distribution</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Change account assignment features</td>
<td></td>
</tr>
<tr>
<td></td>
<td>review information</td>
<td>display</td>
</tr>
<tr>
<td>Further Attributes</td>
<td>Add or edit characteristics for organizational units or positions, for example:</td>
<td>change</td>
</tr>
<tr>
<td></td>
<td>• Staff and department indicators (O only)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Working time (O and S)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Employee group/subgroup (S only)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Vacancy, Obsolete indicator (S only)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>review information</td>
<td>display</td>
</tr>
</tbody>
</table>

Prerequisites

How you access Simple Maintenance depends on the type of information you want, and the type of activities you want to perform. Remember, you need sufficient system authority to work in the change or create mode.

Based on business processes, you decide whether to work in the overview or human resources view. Decide which view you want to work in before creating the organizational plan (Create organizational unit screen). You can also switch between the two views in the Change organizational plan and Display organizational plan screen, if you have chosen the Basic data view. See also Views [Page 260]
Starting Basic Plan in Create Mode

Prerequisites

Use create mode in Simple Maintenance if you want to create a brand new organizational plan that contains no objects within Expert mode. Otherwise, you should use the change or display mode.

Procedure

1. Choose Organizational Management ➔ Expert mode ➔ Simple Maintenance ➔ Create.
   
   The Create Organizational Unit screen appears.

2. Enter a short and long name as well as a validity period for the highest organizational unit in your organizational plan.

3. Specify whether you want to work in the overall view or the human resources view. Views [Page 260]

4. Choose Create.
   
   The Organizational Structure/Change screen appears.

Result

You have created a root organizational unit, which is the highest unit of an organizational structure (Executive board, for example). The root organizational unit is the starting point of the organizational structure. Creating and Editing Organizational Structures [Page 265]
Starting Basic Organizational Plan in Change Mode

Prerequisites

You can start Simple Maintenance using this method if you only want to enhance or edit the basic details of an organizational plan.

Procedure


   The Change Organizational Plan screen appears.

2. In the Organizational Unit and Editing period fields, enter data as required.

3. Under View, choose the view in which you want to enhance or edit your organizational plan. Access from Organizational Management [Page 242]

   Note that you can only switch between the overall view and human resources view in this screen once you have chosen Basic Data. Views [Page 260]

4. Choose Change.

   The Organizational Structure/Change screen appears.

   Via Organizational plan → Display → Change, you can switch between change and display mode.
Starting Basic Plan in Display Mode

Prerequisites
You can start Simple Maintenance using this method if you only want to review the basic details of your organizational plan in Expert mode.

Procedure
1. Choose Organizational Management → Expert mode → Simple Maintenance → Display.
   The Display Organizational Plan screen appears.
2. In the Organizational Unit and Editing period fields, enter data as required.
3. Under View, choose the view in which you want to display your organizational plan. Access from Organizational Management [Page 242]
   Note that you can only switch between the overall view and human resources view in this screen once you have chosen Basic Data. Views [Page 260]
4. Choose Display.
   The Organizational Structure/Display screen appears.
   Via Organizational plan → Display → Change, you can switch between change and display mode.
Selecting a Plan Version

Prerequisites

In Simple Maintenance, choose a plan version to identify the plan. A plan version is a scenario in which you deposit different sets of information.

The system always defaults to the plan version which has been designated as the active plan version. You can also choose a different plan version.

If you are a user of SAP Business Workflow, and you want to work with workflow-related information in Simple Maintenance, you can only work with the active plan version.

Selecting a Plan Version

1. Choose Organizational Management → Expert mode → Simple Maintenance → Create or Change or Display.
   The corresponding initial screens for Simple Maintenance appear.

2. Select Settings → Plan version.
   A dialog box appears.

3. In the Plan version field, enter data as required.

4. Choose Continue.

Reverting to the Active Plan Version

1. See step 1

2. Select Settings → Active plan version.
   A message appears in the message line, confirming that you are in the active plan version.
Tree Structure

Definition

In Simple Maintenance, the different elements in an organizational plan are visually represented by a tree. The different branches illustrate the relationships among different objects. The tree structure is not just a presentation tool. You can also use it to build and maintain plans with speed and simplicity.

Structure

The tree structure presents clear advantages for maintaining plans. You can:

- Visually perceive relationships between the different objects
- Use the system to create certain relationship records based on where you place objects within the tree structure
- Select the objects you want to work with by selecting them on the screen. (To select objects in Infotype Maintenance, you must provide object IDs)
- Move objects within the structure by choosing them on screen

You can adjust the tree structure display so that it shows different types of information. For example, you can adjust it so that it displays validity periods for objects, or for relationship records.
Expanding the Tree Structure

Prerequisites
Organizational plans are displayed in a tree structure in *Simple Maintenance*.

Expand the tree structure if you want to display the branches underneath the selected object. Depending on the screen you have chosen (Organizational structure or Staff Assignments, for example) and the position of the cursor the relevant organizational or reporting structures will be displayed. To display the whole structure you must select the root object.

Procedure
1. From any *Simple Maintenance* screen, choose the object whose substructure you want to display.
2. Choose one of the following menu paths:
   - *Edit* → *Expand*.
   - *Expand*
     The system displays the complete structure underneath the selected object.
Compressing the Tree Structure

Prerequisites

Organizational plans in Simple Maintenance are displayed in tree structures.

You can compress the tree structure if, for example, you want a better overview, all branches underneath the selected object disappear.

Procedure

1. From any Simple Maintenance screen, choose the object whose substructure you want to hide.
2. Choose one of the following menu paths:
   - Edit $\rightarrow$ Compress.
   - Compress
     
     The system hides the substructure underneath the selected object.
Printing Tree Structures

Prerequisites
Using different views, you can determine the how structures and objects from your organizational plan are displayed in the tree structure and in so doing, how it is printed.

Procedure
1. On any Simple Maintenance screen, choose the menu option on the far left.
   A dialog box appears.
2. Choose Print.
   The print request screen appears.
3. Enter the appropriate print parameters.
4. Choose Print.
Selecting Additional Information

Use

From the Organizational Structure..., Staff Assignment... or Task Profile... screen you can select various types of additional information by choosing View. This information is displayed for objects in your organizational plan that you wish to edit in the tree structure.

Prerequisites

You are in Simple Maintenance, in Expert mode. The system is set up in such a way, that the short text description, that is, the names of the objects are displayed in the tree structure. You can, however, display the following information:

Features

<table>
<thead>
<tr>
<th>You want to display:</th>
<th>Choose:</th>
<th>The system checks that:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object Key</td>
<td>View → Key on</td>
<td>the object type abbreviation and the object ID are displayed.</td>
</tr>
<tr>
<td>Relationship text</td>
<td>View → Relationship text on</td>
<td>The relationship long text is inserted.</td>
</tr>
<tr>
<td>Object abbreviations</td>
<td>View → Abbreviation on</td>
<td>The object abbreviations are displayed.</td>
</tr>
<tr>
<td>Object Period</td>
<td>View → Object Period on</td>
<td>The validity period of the object is displayed.</td>
</tr>
<tr>
<td>Relationship Period</td>
<td>View → Relationship Period on</td>
<td>The validity period of the relationships is displayed.</td>
</tr>
<tr>
<td>Weighting Percentage (Relationship between tasks and jobs, positions or organizational units)</td>
<td>View → Percentage on</td>
<td>The system displays the weighting percentage. [See note]</td>
</tr>
<tr>
<td>Staffing Percentage (Relationship between holders and Positions)</td>
<td>View → Percentage on</td>
<td>The system displays the staffing percentage. [See note]</td>
</tr>
<tr>
<td>User Assignments</td>
<td>View → Assignments → User on</td>
<td>the user assignment of employees appears. You created the assignments in infotype Communication (0105)</td>
</tr>
<tr>
<td>Substitute</td>
<td>View → Assignments → Substitute on</td>
<td>the substitute holder of the position is displayed.</td>
</tr>
</tbody>
</table>
Selecting Additional Information

<table>
<thead>
<tr>
<th>Chief</th>
<th>View → Assignments → Chief on</th>
<th>The chief position of the organizational unit is indicated by a symbol (hat).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing Period</td>
<td>View → Editing Period</td>
<td>A dialog box appears in which you can specify the start date of the editing period.</td>
</tr>
<tr>
<td>Color Legend</td>
<td>View → Color Legend</td>
<td>the colors which are assigned to infotypes are displayed on the color legend.</td>
</tr>
<tr>
<td>Other Layout</td>
<td>View → Change layout</td>
<td>the tree structure is compressed.</td>
</tr>
</tbody>
</table>

If the tree structure containing the additional information is not displayed completely, use the scroll function, or increase the size of the screen.

This type of additional information enables you to assign relationships between object weighting or staffing percentages on the Change Staff Assignment or Change Task Profile screen.
Switching to Infotype Maintenance

Prerequisites
You can perform infotype maintenance, such as creating, changing, or deleting infotype records, while working in Simple Maintenance. To do so, you must request an object description for a selected object, and then maintain the infotype on the Maintain Plan Data: Select Infotype screen. (Workflow users do not need to perform much infotype maintenance.)

However, be aware that changes made there are not automatically updated. You can manually update infotype information using the Refresh options.

When you refresh information, the system re-extracts information from the database.

If you need to perform a lot of infotype maintenance, consider switching to Infotype Maintenance.

Procedure
1. On any Simple Maintenance screen, choose the object you want to edit.
2. Choose Goto → Object description.
   The Maintain Plan Data: Select infotypes screen appears containing data on the selected option.
3. Choose an infotype and select Create, Change or Display.
   A dialog box appears, where you can make your entry.
4. Save your entries.
   The object description reappears.
5. To return to Simple Maintenance, choose Back or Cancel.
Switching to Structural Graphics

Prerequisites
Organizational plans are displayed in a tree structure in *Simple Maintenance*. You can switch to *Structural Graphics* to view or maintain a structure in a graphical format.

Procedure
1. On any *Simple Maintenance* screen, choose the object that should be used as the root object, for the *Structural Graphics* display.
2. Choose one of the following menu paths:
   - Goto → *Structural graphics*
   - *Structural Graphics*
     The *Structural Graphics* screen appears, displaying the selected objects.
3. To return to *Simple Maintenance*, choose Back or Cancel.
Selecting Editing Periods

Prerequisites
By entering an editing period you limit the objects in your organizational structure that you can edit or display to those who are valid in the period.

The system sets an editing period which always begins with the current date. You can, however, overwrite the preset data. The system always suggests the editing period you have previously chosen if a validity period is required, when creating a new object, for example. You can overwrite this suggestion.

Procedure
1. From the Organizational Management screen, choose the change mode from any of the cascading menus in Simple Maintenance (with the exception of matrix)
2. Enter data as required.
3. To save your entries, choose Change.
   The tree structure is displayed, where you can continue to edit.

   Alternatively, you can insert the editing period in any screen in Simple Maintenance which displays the tree structure. Select View → Editing Period.

   The Editing Period dialog box appears, where you can make your entry.
Switching between Display and Change Mode

Prerequisites

When you access *Simple Maintenance* you choose an editing mode (*Simple Maintenance* → *Basic Organizational Plan* → *Create, Change or Display*) You can switch between display and change mode in the screens in which your Organizational Plan is presented as a tree structure. In change mode, you can edit the objects shown in a plan, but in display mode, no changes are allowed.

Procedure

To switch between change and display mode, choose *Organizational plan* → *Display <-> Change*.

The screen title changes to *Display or Change*, as appropriate. The system adjusts the options offered in the toolbar, according to your selection.

If you do not have sufficient authorization to work in maintain mode, the system defaults to display mode. See: *PD Profiles Infotype (1017) [Page 62]*
Switching Between Simple Maintenance Screens

Prerequisites
Using this function you can switch from one screen to another in Simple Maintenance, if you want to plan staff assignments for positions according to your organizational structure, for example.

You can easily move among the different areas and screens within Simple Maintenance using the Goto features. Depending on your location in the system, there may be a toolbar option that allows you to change screens.

Procedure
1. On the current screen, choose Goto.
   A sub-menu appears, listing the screen options.
2. Choose the one you want.
   The selected screen appears.

   Depending on your location, and what you are doing, you may also need to select the object you want to work with in the next screen. For example, to move from the Organizational Structure screen to the Staff Assignments screen, you must first select an organizational unit, and then follow the above steps.
Searching for Objects

Prerequisites

Use the search function when working with a complex organizational structure in order to locate objects quickly. Searches are carried out by text, the system looks for a text for each object (the object name and the object abbreviation).

The system only checks for objects that are displayed in the tree structure at the time of the search. The system does not search in any compressed branches of the tree structure. To change the tree structure see Expanding the Tree Structure [Page 249].

Procedure

1. On any Simple Maintenance screen, choose Edit → Find.
   
   The Find dialog box appears.

2. Enter the name or the abbreviation (in part or in full) of the object you are searching for in the Find field.

3. In the other parameters in the dialog box, enter data as required.

4. Choose Find.
   
   – If the system does not find a matching object, a dialog box appears with a message. Choose Continue.
   
   – If the system finds objects that match the parameters set, they are displayed in a dialog box.
Views

Use
You can work with Simple Maintenance using one of two different views – the overall view or the human resources view. Different views were introduced because Simple Maintenance serves two communities of users – SAP Business Workflow and Human Resources (HR) users.

Features
The difference between the two views hinges on tasks and task profiles. The types of tasks in Human Resources (HR) are different to those used in the SAP Business Workflow. Consequently, the contents of task profiles and some functions vary between the two views.

Differences Between Simple Maintenance Views

<table>
<thead>
<tr>
<th>In this view</th>
<th>you can work with</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overall view</td>
<td>• Tasks</td>
</tr>
<tr>
<td></td>
<td>• Standard tasks</td>
</tr>
<tr>
<td></td>
<td>• Workflow tasks</td>
</tr>
<tr>
<td></td>
<td>• Workflow templates</td>
</tr>
<tr>
<td></td>
<td>• Roles</td>
</tr>
<tr>
<td>Human resources view</td>
<td>• Tasks</td>
</tr>
<tr>
<td></td>
<td>• Standard tasks</td>
</tr>
</tbody>
</table>
Screens

Use
For ease of use, Simple Maintenance handles work using the minimum of different screens. Each screen handles a specific set of activities. For example, in the basic organizational plan area, the Change Organizational Structure screen handles only those activities related to organizational structures.

Features

In Simple Maintenance, you work with three main screens:

- **Change Organizational Structure screen**
  
  The Change Organizational Structure screen acts as the foundation screen in Simple Maintenance. Your activities always begin there. You can then switch to the other screens in Simple Maintenance, as appropriate.

  The Change Organizational Structure screen allows you to build up and maintain the organizational structure for your organizational plan. This is achieved by creating and maintaining organizational units. When you create organizational units in Simple Maintenance, you also automatically create the relationship records that link the units.

- **Change Staff Assignments screen**
  
  The Change Staff Assignments screen allows you to identify the staff assignments required for an organizational plan. This is achieved by creating jobs and positions, and by assigning holders to positions.

  When you create positions on the Change Staff Assignments screen, you also automatically create the relationships records that link positions with organizational units.

  If you create positions by copying jobs, the system creates the relationship records that link positions and jobs.

  However, one position will not automatically be designated as the leader of an organizational unit. For these types of relationships to be created, you must make the appropriate selections from the tree structure, and from the menu.

  To focus on a single unit, choose the desired organizational unit on the Change Organizational Structure screen. The Change Staff Assignments screen appears, displaying details for the selected unit only.

- **Change Task Profile screen**
  
  The Change Task Profile screen allows you to create, maintain, and view task profiles for:
  - Organizational unit
  - Job
  - Position
  - Users

  The types of tasks you can work with in the Change Task Profile screen depend on the view you have chosen.
Creating an Organizational Plan

Purpose
Using Simple Maintenance you can view your company’s organizational and reporting structures and create task profiles quickly and easily. This helps to establish a clear picture of the entire structure of your company and provides a basis for forward planning.

To view your organizational plan use organizational objects, organizational units, positions or tasks for example. When you create an organizational plan, you support other screens, the creation of organizational structures, staff assignments and task profiles, for example. The tree structure in which objects and structures are displayed allows you to edit them at will.

The value of your organizational model is underlined by its use with SAP Business Workflow, as, for example, Workflow tasks are defined in your organizational model as positions or organizational units, the system is quickly able to find the person responsible for a task. The system is also responsible for ensuring that workflow tasks are passed to the correct agent. The advantage of an integrated workflow system is that it saves you from having to allocate tasks to people.

Process flow
Three steps can vary in the creation of your organizational plan in Simple Maintenance:

1. Creating the Organizational Structure
   An organizational plan will be described by organizational units which exist in a company. These organizational units are linked in a hierarchical structure which mirrors the reporting paths of the company. You can, however, create organizational units which exist apart from a structure.
   To start a new plan, you must begin by creating a root organizational unit. A root organizational unit is the highest level unit in an organizational structure, for example, Board of Directors. The root organizational unit is the starting point of the organizational structure.

2. Creating a staff assignment
   A staff assignment is created for each organizational unit. Positions are created which are allocated to organizational units. A position is based on a job which describes it, this is an advantage of the organizational model which contains your organizational plan. This means that a position inherits the description of the task. This lowers your administrative costs. You only have to describe the position using tasks which are not inherited.
   A job is a business segment which is defined by task and requirement. Jobs (secretary or programmer, for example) will only appear once in a company. You can create jobs when they are necessary for your organizational structure but do not yet exist in your job index. If you create a position first, the jobs which you have assigned to the position will be displayed. Simple Maintenance lets you create several jobs at once.
   Holders are then assigned to positions. You use this feature to determine which person (employee) or R/3 user occupies a position. By assigning a position, R/3 users in Workflow can, directly or indirectly - by their relationship with employees - be determined as agents of work items. In Simple Maintenance you can identify positions as chief positions of an organizational unit.
Creating an Organizational Plan

3. Creating a task profile

Once you have created your organizational structure and staff assignments, you can create and edit task profiles using Simple Maintenance. Using the task profile you can determine which tasks are specific to organizational units, jobs and positions. The specific assignment of tasks is important when determining agents using SAP Business Workflow as Possible agents are determined when you assign tasks.

You can describe tasks in as much or as little detail as you want and include them in your task catalog. In this way the traditional job descriptions can be replaced at little cost. It is recommended that tasks are assigned to jobs. Tasks should only be assigned to positions if they are specific to those positions. Tasks assigned to jobs are automatically passed on to the assigned positions.

By assigning tasks to organizational units, jobs and positions you determine an abstract responsibility for that task. Thus, positions are given to potential planned employees and not to actual people.

This ensures that important information is not lost when, for example, an employee leaves the company. You can call up this information from the system at any time.

Result

With the help of organizational units, jobs, positions and tasks, you can fit your current organizational structures and reporting hierarchy as well as the task profile of your company into a plan (plan version) quickly and easily.

At a later date you may want to decentralize one or more organizational unit, that is to say you may want each of the relevant modeling tasks to be carried out by different departments.

To carry out organizational modeling on a decentralized level, copy the section of your organizational plan to be reorganized and save it as an individual plan. You can work on this plan without affecting the active (real) plan.

Using this model plan, you can consider new tasks for the company. The organizational structure may have to be expanded by adding new organizational units or modified by movement. It can be necessary to create new positions which include planned new employees. Positions which are not occupied will be marked as vacant.

If the model plan does match your company’s requirements, you can transfer it into your current plan using plan version reconciliation.
Creating and Editing Organizational Plans

Use

The first step in creating an organizational plan using Simple Maintenance is to create an organizational structure which is made up of different, mostly hierarchical organizational units. Organizational units are all organizational objects, for example, groups, departments or teams.

The organizational structure usually mirrors the reporting structure of a company. Reporting paths which differ can be copied in Simple Maintenance by determining the hierarchy of positions.

Your organizational structure begins with a root organizational unit. A root organizational unit is the highest level unit in an organizational structure, for example, Board of Directors. Using the root organizational unit as a starting point, you can create additional subordinate organizational units. In Simple Maintenance, you can create numerous organizational units or levels at one time.

You can edit the organizational structure of your organizational plan in the Change Organizational Structure screen in Simple Maintenance. The system uses a tree structure to edit your organizational structure. The system determines the appropriate relationship according to where you place the unit in the tree structure, and creates the necessary relationship record.
Creating Root Organizational Units

Prerequisites

To start a new plan, you must begin by creating a root organizational unit. A root organizational unit is the highest level unit in an organizational structure, for example, Board of Directors. The root organizational unit is the starting point of the organizational structure.

Procedure

1. To access Simple Maintenance, select Organizational Management → Expert mode → Simple Maintenance → Create.

   The Create Organizational Unit screen appears.

2. In the Organizational unit: Abbr. and Name fields, enter data as required for each job you want to create.

3. In the Validity period field, enter a validity period for the organizational unit.

4. In the View field, select the view in which you want to work. Views [Page 260]

5. Choose Organizational plan → Create.

Result

The system saves the organizational unit. The Change Organizational Structure screen appears, on which you can continue to build up an organizational structure for your plan.

Once you save the root organizational unit, the system switches from create mode to change mode.
Creating Organizational Units

Prerequisites

If you want to add new organizational units to your organizational structure based on a root organizational unit or an organizational structure which already exists, you can create an organizational unit. In Simple Maintenance, you can create numerous organizational units at one time.

Procedure

1. On the Change Organizational Structure screen, choose the organizational unit that is to become the parent object for the new organizational unit, or units, you are creating.

2. Choose Edit → Create → Organizational unit.

   The Create Organizational Units dialog box appears. The name of the organizational unit you selected as the parent is displayed at the top of the screen.

3. In the Abbr. and Name fields, enter data as required for each organizational unit you want to create.

   If you need extra lines for further entries, select the Further entries button.

4. If necessary, choose Period, to adjust the validity period.

   The Validity Period dialog box appears.

   a. In the Organizational Unit and Relationship fields, enter validity dates as required.

   b. Choose Continue.

      Otherwise, skip to step 5.

   The system applies the validity period to all of the organizational units you entered in the Create Organization Units dialog box.

5. Save your entries.
Changing Organizational Units

Prerequisites
You change organizational units by changing their object abbreviations or object names, or changing the validity period.

Procedure
1. On the Change organizational structure screen, select the organizational unit you want to change and choose Edit → Change → Rename
   The Rename O... dialog box appears.
2. In the Object abbr, Name and Validity period fields, enter data as required.
3. Save your entries.
Delimiting Organizational Units

Prerequisites

Delimit organizational units if you want to change their validity periods, so that the end date occurs sooner than stated. This can be necessary, for example, to eliminate an organizational unit due to a corporate re-organization.

Warning: When you delimit objects, the system delimits any infotype records appended to the object, to the same date.

Procedure

1. On the Change Organizational Structure screen, choose the organizational unit you want to delimit.
2. Select Edit → Delimit → Object.
   The Validity Period dialog box appears.
   If there are positions assigned to the organizational unit, the Delimit Subordinate Positions dialog box appears instead.
3. Choose Delimit Date.
   The Validity Period dialog box appears.
4. Enter data as required.
5. Choose Continue.
6. Choose Delimit.

Result

The system delimits the object and the validity period. You can see the changed dates using View → Object Period or Relationship Period on the right of the tree structure.
Deleting Organizational Units

Prerequisites

You delete organizational units only when you want to erase the data from the database permanently. The system deletes all characteristics appended to the unit as well (infotypes, such as the Relationships infotype, for example). The system keeps no historical information.

Deletions should only be necessary when, for example, you incorrectly or accidentally create an object. To change the validity period of an organizational unit, select Edit → Delimit → Object.

Procedure

1. On the Change Organizational Structure screen, choose the organizational unit you want to delete.
2. Select Edit → Delete → Object.
   The Delete Object dialog box appears.
   If additional organizational units and positions are subordinate to the organizational unit, the message Move/delimit/delete all subordinate objects appears.
   If there are positions assigned to the organizational unit but no additional organizational units, the Delete Subordinate Positions dialog box appears instead. Deleting/Moving Subordinate Positions [Page 277]
3. Choose Delete.
Rearranging Organizational Units

Prerequisites
You can shuffle the sequence in which organizational units are arranged within a level of the hierarchy. By doing so, you change the priority of relationship records used in the structural evaluation.

Procedure
1. On the Change Organizational Structure screen, choose the organizational unit you want to change.
2. Choose Change sequence.
   The Choose List item screen appears, on which those organizational objects whose position the relevant organizational unit can take are indicated by a hand symbol.
3. Click on the hand symbol of the organizational unit whose position you want the organizational unit to take.

Result
The sequence of the organizational units in the display changes, in that the organizational unit concerned is superior to the organizational unit you clicked on. You can also display changes in Infotype Maintenance via infotype 1001 (Relationships).

Display Changes on the Maintain Plan Data and Select Infotype Screens
1. On the Change Organizational Structure screen, choose an object, then choose Goto → Object Description.
   The Maintain Plan Data: Select infotype screen appears.
2. Under Infotype name, choose Relationship and Display.
   The Add Relationship screen appears.

Result
In the Priority field, the alphabetic characters showing relationship priorities have changed.
Prioritizing Organizational Units

Prerequisites

In Simple Maintenance and in Structural Graphics, priorities dictate how objects are presented in hierarchical structures.

There is generally more than one object on the same level of a structure. Objects which are on the same level of a structure will be arranged from top to bottom (tree structure) or from left to right (structural graphics) according to their object IDs. They will also be prioritized in this way.

You can set the order by assigning a priority number to each of the objects. You can either prioritize objects by giving them a number between 1 (highest priority) and 99 or by assigning them a combination of letters (AA, AB, AC and so on).

Procedure

1. On the Change Organizational Structure screen, select an object which is on the same level as another, whose priority you want to change. Having done this, choose Edit → Prioritize → Organizational Unit.

   The Priority of Organizational Units dialog box appears.

2. In the Priority field, enter priority numbers for each organizational unit.

3. Save your entries.

Result

The Change Organizational Structure screen appears, displaying a tree structure that reflects the priorities set.
Moving Organizational Units

Prerequisites
Move organizational units if you want to change where a unit is placed within an organizational structure. This changes the relationship records linked to the organizational unit.

In Infotype Maintenance, this can be achieved by delimiting the relationship record, and then creating a new one. However, in Simple Maintenance it is a more straightforward procedure.

Moving Organizational Units by Running a Search
1. On the Change Organizational Structure screen, choose the organizational unit you want to move.
2. Select Edit → Move → General.
   The Choose Organizational Unit screen appears.
3. In the Search string field, (or Structure search), look up the organizational unit to which you want to move the position. Choose Continue.
   If the system finds more than one organizational unit, the Search Function for Organizational Unit appears, listing the units.
   If the system finds only one organizational unit, the Move dialog box appears, showing the object’s proposed new placement in the organizational structure. In this case, skip to step 4.
4. In the Search Function for Organizational Unit dialog box, select a unit and choose Continue.
   The Move dialog box appears, showing the object’s proposed new placement in the organizational structure.
5. If necessary, choose Period to adjust the validity period for the relationship infotype record you are creating.
   The Validity Period dialog box appears.
   a. In the appropriate fields, enter data as required.
   b. Choose Continue.
      Otherwise, skip to step 6.
6. Choose Move.

Result
The system moves the object. The Change Organizational Structure screen appears, displaying the new placement.

Moving Organizational Units Without Running a Search
1. On the Change Organizational Structure screen, choose the organizational unit you want to move.
2. Select Edit → Move → Object.
   The Select Superior Object screen appears.
Moving Organizational Units

3. Select the superior object, and then choose Edit → Select.

4. If necessary, choose Period to adjust the validity period for the relationship infotype record you are creating.
   
   The Validity Period dialog box appears.
   
   a. In the appropriate fields, enter data as required.
   b. Choose Continue.
   
   Otherwise, skip to step 5.

5. Choose Move.

   You can use the Move icon, instead of selecting Edit → Move → Object, to move the organizational units in the same way.
Delimiting/Moving Subordinate Positions

Prerequisites
If you attempt to delimit an organizational unit, and there are positions assigned to the unit, you should either:

- Delimit the positions
  or
- Move the positions, that is, assign them to another organizational unit

The system retrieves the Delimit Subordinate Positions dialog box, so you can take action.

You can also delimit the organizational unit without moving or delimiting subordinate positions. This ends the task.

Moving Positions
1. From the Delete Subordinate Positions dialog box, choose Move.

   The Choose Organizational Unit screen appears.

2. In the Search string field, look up the organizational unit that becomes the new parent object. Choose Continue.

   If the system finds more than one organizational unit, all units will be listed.

   If the system finds only one organizational unit, the Move dialog box appears, showing the proposed position placement, in the organizational structure. In this case, skip to step 3.

3. Select a unit and then choose Choose.

4. If necessary, choose Period to adjust the validity period of the relationship between positions and the organizational unit.

   The Validity Period dialog box appears.

   a. In the Validity Period fields, enter data as required.

   b. Choose Continue.

   Otherwise, skip to step 5.

5. Choose Move.

Result
The Change Staff Assignment screen appears. The new position allocations appear in the tree structure. The process of delimiting is restarted. Click here to restart delimitation process [Page 269].

Delimiting Positions
1. On the Delimit Subordinate Positions dialog box, choose Delimit.
Delimiting/Moving Subordinate Positions

The Delimit dialog box appears listing the positions to be delimited.

2. If necessary, choose Period to adjust the validity period of the relationship between positions and the organizational unit.

   The Validity Period dialog box appears.

   a. In the Validity Period fields, enter data as required.
   b. Choose Continue.

   Otherwise, skip to step 3.

3. Choose Delimit.

Result

The system delimits the positions. The Validity Period dialog box appears. The process of delimiting is restarted. Click here to restart delimitation process [Page 269].
Deleting/Moving Subordinate Positions

Prerequisites
If you attempt to delete an organizational unit, and there are positions assigned to the unit, you must either:
- Delete the positions
  or
- Move the positions, that is, assign them to another organizational unit

The system retrieves the Delete Subordinate Positions dialog box, so you can take action.

Moving Positions
1. From the Delete Subordinate Positions dialog box, choose Move.
   The Choose Organizational Unit screen appears.
2. In the Search string field, look up the organizational unit that becomes the new parent object. Choose Continue.
   If the system finds more than one organizational unit, all units will be listed.
   If the system finds only one organizational unit, the Move dialog box appears, showing the proposed position placement, in the organizational structure.
3. Select a unit and then choose Choose.
   The Move dialog box appears, showing the proposed position placement, in the organizational structure.
4. If necessary, choose Period to adjust the validity period of the relationship between positions and the organizational unit.
   The Validity Period dialog box appears.
   a. In the Validity Period fields, enter data as required.
   b. Choose Continue.
      Otherwise, skip to step 5.
5. Choose Move.

Deleting Positions
1. From the Delete Subordinate Positions dialog box, choose Delete.
   The Delete dialog box appears, listing the positions to be deleted.
2. Choose Delete.
Delimiting Relationships

Prerequisites

Delimit relationships between organizational units if you want a relationship to end sooner than stated. This can be necessary, for example, when a corporate re-organization is planned.

When you delimit the relationships, you are actually delimiting relationship infotype records. The relationship between organizational units is relationship A 002 (reports to) or B 002 (is line manager of).

Procedure

1. On any Simple Maintenance screen, choose the relationship record you want to delimit.
2. Choose Edit → Delimit → Relationship.
   The Delimit Relationship dialog box appears, displaying the organizational units.
3. Choose Delimit Date.
   The Validity Period dialog box appears.
4. Enter a new end date.
5. Choose Continue.
6. Choose Delimit.

Result

The system delimits the relationship period which you can display by selecting View → Relationship Period.
Deleting Relationships

Prerequisites
Delete relationships between organizational units when you want to erase all traces of a relationship from the database. The system keeps no historical information.

Deletions should only be necessary when you incorrectly or accidentally create a relationship. Otherwise, it is more appropriate to move, or delimit.

⚠️ If you delete relationship records between organizational units, the lower level organizational unit is also removed from the tree structure. The system has not deleted the unit! However, it cannot display the unit in the tree structure because the unit has no relationship. To fix this, you must go into Infotype Maintenance, and create a new relationship record.

When you delete relationships, you are deleting relationship infotype records. The relationship between organizational units is relationship A 002 (reports to) or B 002 (is line manager of).

Procedure
1. On any Simple Maintenance screen, choose the relationship record you want to delete.
2. Choose Edit → Delete → Relationship.
   The Delete Relationship dialog box appears, displaying the objects linked by the relationship infotype record.
3. Choose Delete.
Assigning Unrelated Organizational Units

Prerequisites

If you work in *Simple Maintenance*, it is not necessary for you to formally assign organizational units to a place within an organizational structure. The system carries out the assignment.

However, if you create organizational units in *Infotype Maintenance*, organizational units are not automatically placed within the organizational structure. This means that your organizational plan might include unassigned or unrelated organizational units.

This feature allows you to place existing, unassigned organizational units within an organizational structure.

Procedure

1. On the *Change Organizational Structure* screen, choose the organizational unit that is to become the parent of the unassigned organizational unit.

2. Choose *Edit* → *Assign* → *Organizational unit*.

   The *Choose Organizational Unit* screen appears.

3. In the *Search String* field, look up the organizational unit you want to add to the organizational structure. Choose *Continue*.

   If the system finds more than one organizational unit, the *Search Function for Organizational Unit* dialog box appears, listing the units.

4. Select one or more of the units. Choose *Continue*.

   The *Organizational Unit Assignment* dialog box appears, showing the proposed placement. If you decide not to assign the unit(s) to the proposed placement, deselect their indicator next to the object ID.

   If the system finds only one organizational unit, the *Organizational Unit Assignment* dialog box appears, showing the proposed placement of the object within the organizational structure.

5. If necessary, choose *Period*, to adjust the validity period.

   The *Validity Period* dialog box appears.

   a. In the *Account Assignment Feature - Current Settings* fields, enter data as required.

   b. Choose *Continue*.

      Otherwise, skip to step 6.

6. Save your entries.
Creating and Editing Staff Assignments

Use

For every organizational unit in your organizational structure you can create relevant staff assignments. First you must create **positions** which are to be allocated to established organizational units. A position is based on a job which describes it, this is an advantage of the organizational model which contains your organizational plan. This means that a position inherits the description of the task. This lowers your administrative costs. You only have to describe the position using tasks which are not inherited.

A **position** represents the concrete form of a job, it is for the most part occupied by a person and is assigned to an organizational unit (or more than one organizational unit), secretary in the marketing department for example. A position has a definite profile and can become vacant.

A **job** is a business segment which is defined by task and requirement. Jobs (secretary or programmer, for example) will only appear once in a company. You can create jobs when they are necessary for your organizational structure but do not yet exist in your job index. If you create a position first, the jobs which you have assigned to the position will be displayed. **Simple Maintenance** lets you create several jobs at once.

**Holders** are then assigned to positions. You use this feature to determine which person (employee) or R/3 user occupies a position. By assigning a position, R/3 users in Workflow can, directly or indirectly - by their relationship with employees - be determined as agents of work items. In **Simple Maintenance** you can identify positions as **chief positions** of an organizational unit.

You can create and edit staff assignments for organizational plans using **Simple Maintenance** in the **Change Staff Assignments** screen.
Creating and Editing positions

Use

A **job** is a business segment which is defined by task and requirement. Jobs will only appear once in an organization (secretary or programmer for example). You can create jobs when they are necessary for your organizational structure but do not yet exist in your job index.

In accordance with the concept of organizational management, a position is based on the job which describes it. This means that a position inherits the tasks and characteristics of the job. This lowers your administrative costs. You only have to describe the position using tasks which are not inherited.

There is a list of jobs in your company on the *Job Profile* screen. You can create and edit jobs using this screen as you can using the *Change Staff Assignments* screen. *Simple Maintenance* lets you create several jobs at once.
Create jobs

Prerequisites

A job is a business segment which is defined by task and requirement. Jobs will only appear once in an organization (secretary or programmer for example). You can create jobs when they are necessary for your organizational structure but do not yet exist in your job index. If you create a position first, the jobs which you have assigned to the position will be displayed. Simple Maintenance lets you create several jobs at once.

Procedure

1. On the Change Staff Assignments or Change Task Profile screen, choose Edit → Create → Jobs.

   The Create Jobs screen appears. Existing jobs are listed along the bottom of the screen, in alphabetical order.

2. In the Abbr. and Name fields, enter data as required for each job you want to create.

3. If you want to change the validity period, select Period. The system default period will begin with the current date. Make sure that the validity periods of the job to which a position is assigned is covered by the validity period of the position.

   The Validity Period dialog box appears.

   a. Enter data as required.

   b. Choose Continue.

      Otherwise, skip to step 4.

      The system applies the validity period to all of the jobs you entered in the Create Jobs dialog box.

4. Save the job.

   Newly created jobs do not appear in the tree structure unless they are assigned to a position.
Changing Jobs

Prerequisites
You can change the object abbreviations, objects names or validity periods of jobs.
You can change jobs using *Infotype Maintenance*.

Procedure
1. On any *Simple Maintenance* screen, choose Goto → *Job Profile*.
   The *Job Profile* screen will appear on which jobs available in your company will be listed alphabetically.
2. Select the job you want to change and choose Edit → Change → Rename
   The *Rename* dialog box appears.
3. In the appropriate fields, enter data as required.
4. Save your entries.
Assigning Positions to Jobs

Prerequisites

You assign a position to a job when a position has been created without using a job as a basis, and it is now necessary to link the two. (You can create positions without copying jobs in Detail Maintenance.)

It is recommended that you link all positions with a job. (This enables the position to inherit attributes from the job, which in turn saves data entry time.) When you assign jobs to positions, you are creating a relationship infotype record. This is relationship A/B 007.

⚠️

You can assign more than one position to a job. You can not, however, assign more than one job to a position. A position may be linked with only one job at a time.

Procedure

1. On the Change Staff Assignments screen, choose the position you want to edit and select Goto → Task Profile.

   The Change Task Profile dialog box appears.

2. Select the position once again, and choose either

   - Edit → Assign → Job
     or
   - Assign job

   The Assign Job dialog box appears.

3. To identify the job you want to assign,

   - choose an existing job using the Abbr. field
     or
   - Choose Create Jobs.

4. In the Validity Period field, enter the appropriate data.

5. Save your entries.
Delimiting Job/Position Assignments

Prerequisites

Delimit the assignment of a position to a job if the relationship between the two objects should end sooner than stated. This can be necessary if, for example, your company plans to re-work job and position descriptions.

If you delimit this assignment, you are actually delimiting a relationship record. This is relationship A/B 007.

Procedure

1. On the Change Task Profile screen, choose the job whose relationship with a position you wish to delimit.

2. Choose Edit Delimit Relationship.

   The Delimit Relationship dialog box appears. It displays the position and the relevant job.

3. Choose Delimit Date.

   The Delimit Relationship dialog box appears.

4. Enter a new end date.

5. Choose Continue.

6. Choose Delimit.
Deleting Job/Position Assignments

Prerequisites

You delete job or position assignments to erase all traces of the assignment from the database. The system keeps no historical information.

Deletions should only be necessary, for example, if you incorrectly or accidentally create a relationship record. If the objects involved are being reorganized, then it is more appropriate to move or delimit.

If you delete this assignment, you are actually deleting a relationship record. This is relationship A/B 007.

Procedure

1. On the Change Task Profile screen, choose the job whose relationship with a position you wish to delete.

2. Choose Edit → Delete → Relationship.

   The Delete Relationship dialog box appears, displaying both of the objects linked by the relationship infotype record.

3. Choose Delete.
Displaying/Editing Task Profiles for Jobs

Prerequisites
Display a task profile for a job if you want to view tasks that are currently assigned to a job. Edit the task profile for a job if you want to add or delete task assignments.

Procedure
1. On any Simple Maintenance screen, choose Goto → Job Profile.
   The Task Profile screen appears, listing all jobs in your organizational plan.
2. Choose Edit → Expand to view the task profiles.
   The tree structure displays the task profiles for the jobs listed.
3. Select the corresponding jobs and edit the task profile, that is, add new tasks (Edit → Assign → Task) or delete tasks (Edit → Delete → Relationship).
Creating and Editing positions

Use

A **position** represents the concrete form of a job, it is for the most part occupied by a person and is assigned to an organizational unit (or more than one organizational unit). An example of a position would be, therefore, *secretary in the marketing department*, whereas *secretary* would be a job. A position has a definite profile and can become vacant.

In accordance with the concept of organizational management, a position is based on the job which describes it. This means that a position inherits the tasks and characteristics of a job. This lowers your administrative costs. You only have to describe the position using tasks which are not inherited.

The main advantage of this concept is to be able to determine agents independently of individuals using *SAP Business Workflow*.

You can create and edit positions in both the *Basic Organizational Plan* and *Reporting Structure* areas of *Simple Maintenance*. 

Creating Positions

Prerequisites

You create positions whenever you want to add new positions to an organizational structure. You use this function to select the organizational unit to which you want to assign one or more positions. In Simple Maintenance, you can create numerous positions at once.

It is best to create positions by copying jobs. Choose the job which forms the basis of the position and create a position name using the name of the job. The position secretary in the marketing department will be derived from the job secretary. This procedure offers two clear advantages, the system:

– Automatically creates a relationship between the job and the positions
  This is relationship A/B 007.

– Assigns newly created positions to the organizational unit in use.
  This is relationship A/B 003.

Procedure

1. If you are working with staff assignments for a particular organizational unit, select Edit → Create → Positions from the Change Staff Assignments screen (If you double click on the correct organizational unit, the Change Organizational Structure screen will appear)

   The Create Positions dialog box appears.

2. If you are working with staff assignments for the entire organizational structure, select the organizational unit where the new position should be assigned.

3. Choose Edit → Create → Positions.

   The Create Positions dialog box appears.

4. In the Describing job field, select the job to be copied.

   If a suitable job does not exist, you can create a new job by choosing Create job.

5. In the Position field, enter data as required.

6. Save your entries.

   If the position assignment is inappropriate – that is, some or all of the positions should be assigned to other organizational units – you can easily re-assign the positions using the move feature. (This is only possible from the Change Staff Assignment screen)

You can also create positions using the Change Position Hierarchy screen following the above procedure.
Renaming Positions

**Prerequisites**

Rename positions if you want to edit a position’s object abbreviation or object name.

**Procedure**

1. On the *Change Staff Assignments* or *Change Position Hierarchy* screen, choose the position that you want to rename.
2. Choose *Edit > Change > Rename*.
   
   The *Rename* dialog box appears.
3. In the *Object abbr.*, *Name* and *Validity period* fields, enter data as required.
4. Save your entries.
Delimiting Positions

Prerequisites
Delimit positions if you want to change their validity periods, so that the end date occurs sooner than stated.
This can be necessary to eliminate a position due to a corporate downsizing.

⚠️
When you delimit objects, the system delimits any infotypes appended to the object, to the same date.

Procedure
1. On the Change Staff Assignments or Change Position Hierarchy screen, choose the position that you want to delimit.
2. Select Edit ➤ Delimit ➤ Object.
   The Delimit Object dialog box appears.
3. Choose Delimit Date.
   The Delimit Object dialog box appears.
4. Enter a new end date.
5. Choose Continue.
6. Choose Delimit.

Result
The system delimits the object and the validity period. You can see the changed dates using View ➔ Object Period or Relationship Period on the right of the tree structure.
Deleting Positions

Prerequisites

Only delete positions if you want to erase all record of a position from the database. When you delete positions, the system deletes all infotypes appended to the position as well. The system keeps no historical information.

⚠️

Deletions should only be necessary if positions have been created incorrectly or by accident. To change the validity period, use the delimit function.

Procedure

1. On the Change Staff Assignments or Change Position Hierarchy screen, choose the position that you want to delete.

2. Select Edit → Delete → Object.

   The Delete Object dialog box appears.

3. Choose Delete.
Moving Positions

Prerequisites

Move positions if you want to change the assignment of positions to organizational units.

If you are changing the assignment of a position to an organizational unit at a certain time, delimit the existing relationship (A/B 003) from this time and create a new relationship between the position and the organizational unit.

You move positions on the Change Staff Assignments screen.

To see the procedure for moving positions see, Moving Organizational Units [Page 273].
Rearranging Positions

You can shuffle the sequence in which positions are arranged within a level of the hierarchy. By doing so, you change the priority of relationship records used in the structural evaluation.

Procedure

1. On the Change Staff Assignments or Change Position Hierarchy screen, choose the position whose position you want to change.
2. Select Edit → Move → Sequence.
   A screen appears displaying the position you wish to move using a symbol.
3. Select the organizational unit above or below the one you want to move and choose Edit → Insert above or Insert below.

Result

The displayed sequence of positions changes. You can also display the changes on the Maintain Plan Data: Select Infotypes screen in Detail Maintenance.

Displaying Changes in Detail Maintenance

1. On the Change Staff Assignment screen, choose a position, then choose Goto → Object Description.
   The Maintain Plan Data: Select infotype screen appears in Detail Maintenance.
2. Choose Relationships → Display.
   The Add Relationship screen appears.

Result

In the Priority field, the alphabetic characters showing relationship priorities have changed.

Chief positions will be always be displayed first and can only be arranged again separately.
Prioritizing Positions

Prerequisites

Prioritizing Organizational Units  [Page 272]

A position designated as the chief position for an organizational unit always appears first (closest to the top) in its respective level of the tree structure.

Procedure

1. On the Change Staff Assignments screen, choose the organizational unit you want to edit.
2. Choose Edit → Priority → Positions.
   The Priority of Positions dialog box appears.
3. In the Priority field, enter priority numbers for each position.
4. Save your entries.
Creating Chief Position Assignments

Prerequisites

A chief position is a position you designate to become the leader of a particular organizational unit. It is not mandatory to designate leaders of organizational units. Chief positions are identified in the tree structure by an indicator.

If you decide to designate leaders, you are creating relationship infotype records between organizational units and positions. (This is relationship A/B 012.)

The system allows you to name numerous positions as chief positions, even though they are assigned to the same organizational unit. (In some companies, certain areas may be led by more than one person.) You must make sure that there are only as many chief positions as would realistically be required.

⚠️

Having a chief position is important for Workflow applications, amongst other things. With the help of this indicator, SAP Business Workflow can address a task to the superior of a position holder, the authorization of a wage rise for example.

To set up a reporting structure, you must do so in Detail Maintenance, or in the reporting structure area of Simple Maintenance.

Procedure

1. On the Staff Assignments screen, choose the position that becomes the leader of an organizational unit.

2. Choose Edit → Chief Position → Create

   The Create Chief screen appears, displaying the organizational unit and the position.

3. If necessary, choose Period to adjust the validity period of the chief relationship between positions and the organizational unit.

   The Validity Period dialog box appears.

   a. In the fields, enter data as required.

   b. Choose Continue.

   Otherwise, skip to step 4.

4. Save your entries.

Result

The system saves the change. The Change Staff Assignments screen appears. An indicator appears beside the position designated as the leader.
Delimiting/Deleting Chief Position Assignments

Prerequisites

When you delimit a chief position assignment, you are delimiting the infotype record A/B 012 between the position and the organizational unit involved. You delimit when you want to change the validity period of a position, so that the end date occurs sooner than stated. You might want to do this, for example, if there is a re-organization at your company.

When you delete a chief position assignment, you are deleting the infotype record A/B 012 between the position and the organizational unit involved.

Delimiting Chief Relationships

1. On the Change Staff Assignments screen, choose the position whose chief position you want to change.
2. Choose Edit → Chief Position → Delimit
   The Delimit Chief dialog box appears, displaying the organizational unit and the position concerned.
3. Choose Delimit Date...
   The Delimit Chief dialog box appears.
4. In the Validity period field, enter a new end date.
5. Choose Continue.
6. Choose Delimit.

You can display the delimited relationship by double-clicking on the symbol for the chief indicator and entering the relationship period in the Organizational Assignment screen.

Deleting Chief Relationships

1. On the Change Staff Assignments screen, choose the position whose chief relationship you want to change.
2. Choose Edit → Chief Position → Delete.
   The Delete Chief dialog box appears, displaying the organizational unit and the position concerned related by relationship A/B 012.
3. Choose Delete.
Assigning Holder Positions

Prerequisites
You use this feature to determine which person (employee) or R/3 user occupies a position. By assigning a position, R/3 users in Workflow can, directly or indirectly - by their relationship with employees - be determined as agents of work items.

If you have got Personnel Administration set up, the system knows which employees are assigned to positions. Employees must be linked with R/3 users so that R/3 users can be recognized as agents. This relationship must be maintained in infotype Communication (105) of the Master Data area.

If you are not using Personnel Administration, users are directly assigned to positions and are immediately established as agents of particular single-step tasks.

If you assign positions to holders, you create relationship records, this is relationship A/B 008.

Procedure
1. On the Change Staff Assignments or Change Position Hierarchy screen, choose the position that you want to assign.
2. Choose Edit ® Assign ® Holder.
   The Assign Holder dialog box appears.
3. In the Type, Name, Staffing percentage, and Period fields, enter data as required.
4. Save your entries.
   The tree structure displays the holder of the position.

   To un-assign a position holder, you must either delimit, or delete, the relationship record between the position and the holder (employee or system user).
Determining Staffing Percentages

Prerequisites

The staffing percentage that you enter in Simple Maintenance determines what percentage of an employee’s time he occupies a position. If a holder has worked, for example, up to now for 40 hours per week and then works part time for 20 hours a week, the staffing percentage which relates to him will drop from 100 to 50%.

⚠️

If you want to know what percentage of time a position is occupied, start the report RHSBES00. The percentage given in this report relates to the position.

Procedure

1. On the Change Staff Assignments screen, choose the holder whose staffing percentage you want to change.
2. Choose Edit → Change → Staff. Percentage.
   The Assign Holder dialog box appears.
3. Change the staffing percentage and save your entries.
   If the staffing percentage is over 100%, an error message or warning appears. Otherwise, the system warns you that overlapping records will be deleted.
   To save the new entry, choose Continue.
   To change the new entry, choose New entry.
Replacing Users with Employees

Prerequisites

The following describes how to replace the assignment User → Position with the assignment Employee → Position. This function is only necessary under certain circumstances.

Some customers using Organizational Management may not necessarily use all of the functions of Human Resources. In this situation, the customer identifies the holders of positions by assigning users to positions. However, the customer might later decide to use the complete Human Resources package of Organizational Management.

To take full advantage of all Human Resource functions, employees should be directly related with positions. Employees act as a link between Organizational Management and Personnel Administration.

When you execute a replacement, the system assigns the employee to the position, and deletes the original relationship record between the user and the position.

In order for the system to do this, the Employee → User relationship must be maintained in the Communication infotype (0105), in Personnel Administration.

Procedure

1. On the Change Staff Assignments screen, select the user and choose Edit → Change → Replace user.

   The Replace User with Person dialog box appears.

   Sometimes the dialog box contains more than one entry for a user, this happens if the user has more than one user master record. In this case, you must select one record for replacement. If it is appropriate to replace the remaining records, you must go back and replace them one at a time.

2. Choose Continue.

   This feature handles replacements one assignment at a time. To replace a large number of replacements, start report RHREPL20.
Delimiting Relationships

Prerequisites
Delimit relationships between organizational units if you want a relationship to end sooner than stated. This can be necessary, for example, if there is a reorganization at your company.

Depending on where you are working in Simple Maintenance, you might be delimiting the relationship between positions and:
- Organizational units (this is relationship A/B 003)
- Holders (this is relationship A/B 008)
- Positions (this is relationship A/B 002)
- Jobs (this is relationship A/B 007)
- Tasks (this is relationship A/B 007)

Procedure
1. On the Change Staff Assignments or Change Reporting Structure screen, choose the infotype record you want to delimit.
2. Choose Edit ⊕ Delimit ⊕ Relationship.
   The Delimit Relationship dialog box appears.
3. Choose Delimit Date.
   The Delimit Relationship dialog box appears.
4. Enter a new end date.
5. Choose Continue.
6. Choose Delimit.

Result
The system delimits the relationship period which you can display by selecting View → Relationship Period.
Deleting Relationships

Prerequisites
You delete relationships (assignments) when you want to erase all traces of a relationship from the database. The system keeps no historical information.

Deletions should only be necessary, for example, when you incorrectly or accidentally create a relationship record. If the objects involved are being reorganized, then it is more appropriate to move, or delimit, the objects.

When you work with positions, you might be deleting relationship infotype records between positions and:

- Organizational units (this is relationship A/B 003)
- Holders (this is relationship A/B 008)
- Positions (this is relationship A/B 002)
- Jobs (this is relationship A/B 007)
- Tasks (this is relationship A/B 007)

⚠️ If you delete relationship records, the subordinate object is also removed from the tree structure. The system does not delete the object! However, it cannot display the object in the tree structure unless there is a relationship. To fix this, you must go into Detail Maintenance, and create a new relationship record.

Procedure
1. On the Change Staff Assignments or Change Position hierarchy screen, choose the relationship infotype record you want to delete.
2. Choose Edit ® Delete ® Relationship.
   The Delete Relationship dialog box appears, displaying the affected objects.
3. Choose Delete.
Assigning Unrelated Positions

Prerequisites

If you create positions in Simple Maintenance, it is not necessary to assign positions to an organizational unit. The system automatically carries out the assignment when you have created an organizational unit or if you are working with an organizational unit.

However, if you create positions in Detail Maintenance, they will not automatically be assigned to an organizational unit. It is therefore possible that your organizational plan might include unassigned or unrelated positions.

Using the following procedure, you can assign positions to organizational units and create a relationship - this is relationship A/B 003

Procedure

1. On the Change Staff Assignments or Change Reporting Structure screen, choose the organizational unit that is to become the parent of the unassigned position(s).
2. Choose Edit ® Assign ® Position.
   The Choose Position dialog box appears.
3. In the Search string field, look up the position(s) you want to assign. Choose Continue.
   If the system finds more than one position, a list of all positions found appears.
   The search lists all positions in the organizational plan — not just those that are unrelated.
4. Choose each position you want to assign, and select Transfer.
   The Position Assignment dialog box appears, showing the new assignment.
5. If you decide not to assign the position(s) to the proposed placement, you can deselect the appropriate Position Assignment indicator(s).
   If the system finds only one position, the Position Assignment dialog box appears, showing the proposed placement.
6. If necessary, you can search for positions in the Structure Search field.
7. If necessary, choose Period to adjust the validity period of the relationship between positions and the organizational unit.
   The Validity Period dialog box appears.
   a. Enter data as required.
   b. Choose Continue.
   Otherwise, skip to step 8.
8. Choose Assign.
Creating and Editing Task Profiles

Use

Once you have created your organizational structure and staff assignments, you can create and edit task profiles using Simple Maintenance. You may have to create new tasks if the task catalog in your company has changed. You can include the new tasks in existing task profiles or create new task profiles.

You create task profiles to which you assign task objects - these objects can be jobs, positions or organizational units. This creates relationship records between the task and the other object. This is relationship A/B 007.

Using the task profile you can determine which tasks are specific to organizational units, jobs and positions. The specific assignment of tasks is important when determining agents using SAP Business Workflow. Possible agents are determined when you assign tasks.

Integration

You can describe tasks in as much or as little detail as you want and include them in your task catalog. In this way the traditional job descriptions can be replaced at little cost. It is recommended that tasks are assigned to jobs. Tasks should only be assigned to positions if they are specific to those positions. Tasks assigned to jobs are automatically passed on to the assigned positions.

By assigning tasks to organizational units, jobs and positions you determine an abstract responsibility for that task. Thus, positions are given to potential planned employees and not to actual people.

This ensures that important information is not lost when, for example, an employee leaves the company. You can call up this information from the system at any time.

Activities

You can create and edit task profiles for organizational units, positions and jobs using Simple Maintenance in the Change Task Profile screen.

You can edit established task profiles by:

- Assigning additional tasks
- Removing a task assignment by either delimiting, or deleting, the relationship between the object and the task.

You can edit tasks in Simple Maintenance. On the Change Task Profile screen, select a task and choose Goto → Task Maintenance. The Display Task dialog box appears. By choosing Display <-> Change you access change mode in which you can carry out maintenance.

The view you have chosen determines the task types you can work with.

1. If you work in the overall view, you can assign any type of task.
2. If you work in the Human Resources view, you can only assign Workflow tasks and templates.
Displaying Task Profiles

Prerequisites

You view task profiles to review, and edit, them for objects in your organizational plan. You can display task profiles for the following object types which can be linked to:

- Organizational units
- Positions
- Jobs
- Users or employees

Procedure

1. On the Change Staff Assignments screen, choose the object whose task profile you want to see.
2. Choose Goto → Task Profile.

   The Change Task Profile screen appears, displaying the profile for the selected object.

   Depending on the object selected, the tree structure may also contain other objects. You can display the task profile of the other objects via Edit → Expand.

Viewing the Task Profile

<table>
<thead>
<tr>
<th>If you select this object</th>
<th>you can view task profiles for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organizational unit</td>
<td>• The organizational unit</td>
</tr>
<tr>
<td>Position</td>
<td>• The position</td>
</tr>
<tr>
<td></td>
<td>• The job related to the position</td>
</tr>
<tr>
<td></td>
<td>• The organizational unit, where the position is assigned</td>
</tr>
<tr>
<td>Employee or user</td>
<td>• The position related to the employee or user</td>
</tr>
<tr>
<td></td>
<td>• The job related to the position</td>
</tr>
<tr>
<td></td>
<td>• The organizational unit, where the position is assigned</td>
</tr>
</tbody>
</table>

You cannot directly request task profiles for jobs from the Change Staff Assignments screen. To see the profile, select a position, employee, or user assigned to the job. Or, you can use a separate feature specifically designed for displaying job task profiles. Displaying/Editing Task Profiles for Jobs [Page 288]

   The types of tasks contained in a task profile vary according to the view you use.
Assigning Tasks to Objects

Prerequisites

You assign tasks to objects to build up task profiles. This is done quickly in Simple Maintenance, since you can assign more than one task at a time using Other Task.

When you assign tasks, you are creating relationships between the task and the other object. This is relationship A/B 007.

Procedure

1. On the Change Task Profile screen, choose the position, job, or organizational unit you want to assign a task.
2. Choose Edit → Assign → Tasks.
   The Select Task dialog box appears.
3. In the Search string field, select from the list of tasks.
   The Search Function dialog box appears listing tasks.
4. If necessary, in the Structure Search field, search for a list of tasks from which to choose.
   The Select Task dialog box appears. You can choose either the Task Catalog or the Business Application Components screen. You can switch between the screens.

   The view you have chosen (overall view or Human Resources view) determines the types of task available to you.
5. Select the appropriate tasks, and choose Transfer.
   The Assign Tasks dialog box appears. It displays the task, and the job, position, or organizational unit to be related.
6. If necessary, choose Period to adjust the validity period of the relationship between the task and the object.
   The Validity Period dialog box appears.
   a. Enter data as required.
   b. Choose Continue.
   Otherwise, skip to step 7.

   If you select more than one task assignment, the validity period applies to each assignment.
7. To assign a weighting to the task, choose Percentage.
   The Weighting Percentage dialog box appears.
   a. In the Percentage field, enter data as required.
   b. Choose Continue.
Assigning Tasks to Objects

If you enter more than one task assignment, the weighting percentage applies to each assignment.

8. Save your entries.

Result

The Change Task Profile window appears. The tree structure displays the new task assignment.
Editing the Weighting of Tasks

Prerequisites
You can apply a weighting to task assignments. Weightings give you a way to quantify how time should be spent. For example, in your company the tasks performed by the job secretary might include word processing:

- Word processing 75%
- Answering phones 10%
- Filing 10%
- Making travel arrangements 5%

If you add a task assignment (taking minutes, perhaps) to the task profile, you have to change the weighting percentages of all the tasks.

Procedure
1. On the Change Task Profile screen, choose the task assignment whose weighting you want to change.
2. Choose Edit → Change → Weighting Percentage.
   The Weighting Percentage dialog box appears.
3. Change the percentage and choose Continue.
Removing Tasks from Task Profiles

To remove a task from a task profile you can:

– Delimit the relationship (assignment) between the task and the object
  
  *Delimit* if the task assignment is valid, but becomes invalid, for example, due to a reorganization of job duties.

– Delete the relationship (assignment) between the task and the object
  
  *Delete* to erase all record of the task assignment from the database. This can be necessary if the task assignment was a mistake in the first place.
Delimiting Task Assignments

Prerequisites
Delimit a task assignment if you want to change the validity period of the relationship record between a task and an object, so that the end date occurs sooner than stated. (This is relationship A/B 007.)

This can be necessary if your company plans to re-work job or position descriptions, and the task assignments may become invalid after a certain date.

You can delimit relationship records between tasks and:

- Positions
- Jobs
- Organizational units
- Users

Procedure
1. On the Change Task Profile screen, choose the relationship record you want to delimit.
2. Choose Edit → Delimit → Relationship.
   The Delimit Relationship dialog box appears. It displays the two objects linked by the relationship record selected.
3. Choose Delimit Date.
   The Delimit Relationship dialog box appears.
4. Enter a new end date.
5. Choose Continue.
6. Choose Delimit.
Deleting Task Assignments

Prerequisites
Delete task assignments to erase all traces of a relationship record between a task and an object from the data base. The system keeps no historical information.
Deletions should only be necessary when you incorrectly or accidentally create a relationship.
You can delete relationship records between tasks and:
- Organizational units
- Jobs
- Positions
- Users

Procedure
1. On the Change Task Profile screen, choose the relationship record you want to delete.
2. Choose Edit → Delete → Relationship.
   The Delete Relationship dialog box appears. It displays the objects linked by the relationship record.
3. Choose Delete.

Result
The system deletes the relationship record. The Change Task Profile window appears once again.
Reporting Structures

Use

Simple Maintenance offers the fastest and easiest way to build up and maintain a reporting structure for an organizational plan. The reporting structure refers to relationships between positions. Positions may be subordinate to other positions.

The reporting structure is mostly determined by the organizational structure. You can however, create a reporting structure which deviates from the organizational structure.

Features

- You work with reporting structures in Simple Maintenance by selecting an organizational unit. You can then work with the positions assigned to that organizational unit.
- To create a reporting structure which goes beyond the current organizational structure, you can use the search function to relate selected positions to a corresponding structure.
- Information is presented in a tree structure, making it easier to perceive the hierarchy among different positions.

In Infotype Maintenance, you build up reporting structures by creating objects and relationships individually. You can display a complete reporting structure using report RHSTRU00.
Creating Chief Positions

Prerequisites

A chief position is a position you designate as the leader of a particular organizational unit. It is not mandatory to create chief positions.

If you create chief positions, you are creating relationship records between organizational units and positions. (This is relationship A/B 012.)

The system allows you to create numerous positions as chief positions, even though they are assigned to the same organizational unit. (In some companies, certain areas may be led by more than one person.) You must make sure the chief position designation is appropriate.

You can work with chief positions in the Basic organizational plan, and Reporting structure areas of Simple Maintenance. If you work in the Reporting structure area, there is an extra feature. The system automatically creates relationship records to indicate that other positions report to the chief position. (This is relationship A/B 002.) This is a fast way to build up your reporting structure.

Procedure

1. On the Change Reporting Structure screen, choose the position you want as chief position of the organizational unit.

2. Choose Edit → Chief Position → Create

   The Create Chief dialog box appears, displaying the organizational unit, and the position.

3. If necessary, choose Period to adjust the validity period suggested for the relationship between positions and the organizational unit.

   The Validity Period dialog box appears.

   a. In the Validity Period fields, enter data as required.

   b. Choose Continue.

   Otherwise, skip to step 4.

4. Choose Create.

   The system saves the relationship record. A second dialog box appears, asking if the other positions in the organizational unit should report to the chief position.

5. To subordinate the other positions, choose Yes.

   The Select Positions dialog box appears, displaying the proposed hierarchy.

   a. Select the positions that should be subordinated.

   b. Save your entries.

   To decline the assignment, choose No.

Result

The Change Reporting Structure screen appears. The position created as chief position is indicated by a hat icon.
Delimiting Chief Position Assignments

Prerequisites

You can delimit the designation of chief position. A chief position is a position you designate to become the leader of a particular organizational unit. Chief positions are identified in the tree structure by a hat icon.

When you delimit a chief position assignment, you are delimiting the infotype record A/B 012 between the position and the organizational unit involved. You delimit when you want to change the validity period of a position, so that the end date occurs sooner than stated. You might want to do this, for example, if there is a re-organization at your company.

Procedure

1. On the Change Reporting Structure screen, choose the position you want to edit.
2. Choose Edit → Chief Position → Delimit
   The Delimit Chief dialog box appears, displaying the organizational unit and the position concerned.
3. Choose Period.
   The Validity Period dialog box appears.
4. In the second Validity period field, enter a new end date.
5. Choose Continue.
6. Choose Delimit.
Deleting Chief Position Assignments

Prerequisites
You can delete the designation of chief position. A chief position is a position you designate to become the leader of a particular organizational unit. Chief positions are identified in the tree structure by a hat icon.

When you delete a chief position designation, you are deleting the infotype record A/B 012, between the position and the organizational unit involved.

Procedure
1. On the Change Reporting Structure screen, choose the position you want to edit.
2. Choose Edit → Chief Position → Delete Assignment
   The Delete Chief dialog box appears, displaying the organizational unit and the position concerned.
3. Choose Delete.

Result
The Change Reporting Structure screen appears. The chief position indicator has been removed.
Subordinating Positions

Prerequisites
You subordinate a position to show that it reports to, or has less authority, than another position, within the reporting structure of your company.

When you subordinate a position, the system creates a relationship record between the subordinate and superior positions. (This is relationship A/B 002.)

Procedure
1. On the Change Reporting Structure screen, choose the position you want to subordinate.
2. Choose Edit → Subordinate. The Select superior position dialog box appears. The positions which you can select as the new superior positions are indicated by a hand icon.
3. Select the position that which is to become the higher-level position and choose Select. The Create Subordination dialog box appears, showing the proposed line of authority.
4. Choose Create.
Selecting Superior Positions / Same Org. Unit

Prerequisites

You use this function to show that a position in a reporting structure has more responsibility and is superior to other positions in your company.

If you elevate a position, the system creates a relationship record between the superior and subordinate positions. (You can select more than one subordinate position.) This is relationship A/B 002.

You can use this feature if the subordinate positions are assigned to the same organizational unit as the superior position. Otherwise, see Selecting Superior Positions / Different Org. Unit [Page 322].

Procedure

1. On the Change Reporting Structure screen, choose the position you want to make superior.
2. Choose Edit → Elevate → Within OrgUnit.
   
   The Select Positions for Subordination dialog box appears, displaying the proposed hierarchy.
3. Select the positions that are to subordinate to the elevated position.
4. Save your entries.
Selecting Superior Positions / Different Org. Unit

Prerequisites

You use this function to show that a position in a reporting structure has more responsibility and is superior to other positions in your company.

You can use this feature if the subordinate position is assigned to an organizational unit that is different from the one in which you are working. Otherwise, see Selecting Superior Positions / Same Org. Unit [Page 321].

If you elevate a position, the system creates a relationship record between the superior subordinate positions. This is relationship A/B 002.

Elevating a Position

1. On the Change Reporting Structure screen, choose the position you want to elevate.
2. Choose Edit → Elevate → General.
   The Choose Position dialog box appears.
3. In the Search string field, look up the position that is to be assigned to the superior position. Choose Continue.
   If the system finds only one position, the Assign Position dialog box appears, showing the proposed new placement – skip to step 5.
   If the system finds more than one position, the Search Function for Position dialog box appears, listing the positions.
4. Select the appropriate subordinate position.
   The Position Assignment dialog box appears, showing the new assignment.
5. Save your entries.
   An indicator appears beside the superior position. It indicates there is a position that reports to this superior position, which is assigned to a different organizational unit.

Switching to the Other Organizational Unit

1. Choose the symbol mentioned in step 5
   The Organizational Assignment dialog box appears, identifying the organizational unit where the subordinate position is assigned.
2. Select the organizational unit.
   The Change Reporting Structure screen appears. The system displays the reporting structure for this organizational unit. You can edit the reporting structure, as required.
3. To return to the previous organizational unit, choose Back or Cancel.
The Account Assignment Area

In the account assignments area of Simple Maintenance, you can:

1. Directly assign cost centers to organizational units and positions
2. Assign default settings related to cost centers to organizational units and positions. (These, in turn, help to determine appropriate cost center assignments for various objects.)

The Simple Maintenance tree structure makes the assignment of cost centers and default settings faster and easier, since less data entry is involved. The tree structure also helps you to visualize how objects inherit cost center assignments and other default values.

You can assign cost centers and defaults in other areas of the system. For example, you can carry out both of these tasks in Detail Maintenance, by manually creating and maintaining Relationship (1001) Cost Distribution (1018) and Account Assignment (1008) infotype records.

Note that the staffing percentage can have a great effect on cost distribution.

It also possible to enter cost center assignment in Personnel Administration. However, these methods are both more time consuming.

Cost center assignments are necessary in various situations.

Different Uses for Cost Center Assignments

<table>
<thead>
<tr>
<th>If you plan to use</th>
<th>You can</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Personnel Cost Planning</strong></td>
<td>Transfer cost projections to Controlling (CO), where they can be incorporated into overall financial plans.</td>
</tr>
<tr>
<td></td>
<td>(Costing information is transferred through cost centers, and so your organizational plan must include cost centers that correspond with those in CO.)</td>
</tr>
<tr>
<td><strong>Personnel Administration</strong></td>
<td>Require cost center assignments so that payroll costs can be charged back to the appropriate area of your company. Payroll costs are charged back according to cost center.</td>
</tr>
</tbody>
</table>

If your company works with cost centers, you should consider setting some defaults to control, or guide, the cost center assignments.

Cost centers are determined according to a combination of different pieces of information, including business areas, company codes, and so on. So by setting defaults for these items, you narrow down the cost centers that can be assigned to an object. This helps prevent people from entering inappropriate information. This can be especially helpful if you have a complicated organizational plan.

See also:

Account Assignment Features (Infotype 1008) [Page 49]
Personnel Cost Planning [Ext.]
The Account Assignment Area
Starting Account Assignments in Change Mode

Prerequisites
You work in change mode to add to, or edit cost center assignments or default settings, in an organizational plan.

Procedure
1. On the Organizational Management screen, choose Simple maintenance → Account assignment → Change.
   The Account Assignment/Change screen appears.
2. In the Organizational Unit and Editing period fields, enter data as required.
3. Choose Account assignment → Change.
   The Account Assignment/Change screen appears.

You can start account assignment in display mode in the same way.

You can switch between change and display mode. See Switching between Display and Change Mode [Page 257]
Creating Cost Center Assignments

Prerequisites
Creating Cost Center Assignments

You create cost center assignments to assign a cost center to an organizational unit, or position.

When you create a cost center assignment, the system creates a relationship record between the organizational unit or position and the cost center. (This is relationship A/B 011.) No assignment percentage record can be entered.

When you assign further cost centers (cost distribution), a record of infotype 1018 (cost distribution) is created for the organizational units and positions concerned. A cost center and a percentage record for the cost center assignment will be entered into this record.

The percentage assignment of the Cost center will be the difference after cost distribution.

The inheritance principle applies to cost center assignments. Subordinate objects inherit the cost center of superior objects.

Note that the staffing percentage can have a great effect on cost distribution.

Procedure

1. On the Account assignment/change screen, choose the organizational unit, or position, you want to edit.
2. Choose Edit → Cost center → Create or Cost distribution → Create
   The Assign Cost Center or Change Cost Distribution dialog box appears.
3. Enter data as required.
4. Save your entries.

You might not see the cost center assignment, if the tree structure is not fully expanded. See Expanding the Tree Structure [Page 249]
Creating/Changing Cost Center Weightings

Prerequisites
You change cost center assignments to adjust the weighting applied.

Weightings are used if positions and organizational units have more than one cost center assignment, during one period of time. This can happen, for example, if two departments share the cost of one position. In these types of situations, weightings identify the percentage of costs to be charged to each cost center.

Procedure
1. On the Account assignment/change screen, choose the cost center assignment you want to change.
2. Choose Edit → Cost Distribution → Change.
   The Create Cost Distribution dialog box appears.
3. In the Percentage field, enter data as required.
4. Save your entries.

Note that the staffing percentage can have a great effect on cost distribution.

Result
The system saves the change. The new percentage is displayed in the tree structure, provided the proper view option is set.
Delimiting Cost Center Assignments

Prerequisites
You can delimit a cost center assignment to indicate the assignment is invalid after a specified date.

Procedure
1. On the Account Assignment / Change screen, choose the cost center whose assignment you wish to delimit.
2. Choose Edit → Cost center → Delimit (to delimit cost center assignment) or Cost distribution → Delimit (to delimit the assignment of additional cost centers).
   The Delimit Relationship dialog box appears, displaying the selected assignment.
3. To set the delimitation date, choose Delimitation Date.
   The Delimit Relationship dialog box appears.
   a. Enter the delimitation date.
   b. Choose Continue.

Result
The system delimits the assignment. The delimit date is displayed in the tree structure, provided the proper view option is set.
Deleting Cost Center Assignments

Deleting Cost Center Assignments

Prerequisites
You delete cost center assignments to erase all record of an assignment from the database. The system keeps no historical information.

⚠️
Deletions should only be necessary, for example, if you incorrectly or accidentally create an assignment. To change cost centers, you should delimit the assignment, and create a new assignment.

Procedure
1. On the Change Staff Assignments screen, choose the cost center whose assignment you want to delete.

   ➡️
If you want to delete the cost center assignment of a particular object, select this object.

2. Select Edit → Cost Center or Cost Distribution → Delete

   The Delete Relationship or Delete Cost Distribution dialog box appears, displaying the selected assignment.

3. Choose Delete.
Setting Account Assignment Defaults

Prerequisites
You can use this feature to enter default settings that the system uses to help determine appropriate cost center assignments for objects.

Cost centers are determined according to a combination of different pieces of information, including business areas, company codes, and so on. So by setting defaults for these items, you narrow down the cost centers that can be assigned to an object.

You can set defaults for:
- Business areas
- Personnel areas
- Personnel subareas
- Company codes

When you do so, you are creating an Account Assignment (1008) infotype record.

The inheritance principle applies to default settings. Subordinate objects inherit the settings of superior objects.

Procedure
1. On the Account Assignment / Change screen, choose the object for which you want to enter a default.
2. Choose Edit → Account assignment feature → Change.
   The Create account assignment feature dialog box appears.
3. Enter data as required.
4. Save your entries.

Result
The system saves the default settings. Based on your entries, the system determines the appropriate controlling area, and inserts it.
Further Attributes

Definition
Quick and simple way in to create and maintain the main infotypes used in Organizational Management in Simple Maintenance.

Use
You identify the different attributes of an object by individually creating and maintaining infotype records, in Detail Maintenance.

However, in Simple Maintenance, settings for a number of infotypes are combined into one area, so they can be maintained together. (You can still retrieve and work with the infotype records in Detail Maintenance.)

You can define further attributes for positions or organizational units. You select the object you want to work with directly from the tree structure.

Structure
You can maintain the following attributes for organizational units:

- Department/Staff flags
- Work schedules

You can maintain the following attributes for positions:

- Department/Staff flags
- Work schedules
- Employee groups/employee subgroups
- Obsolescence
- Vacancies

Some interdependencies exist among different infotypes. If you change, information for one infotype, it can automatically change another. For example, if you change an Employee Group/Subgroup infotype record, it can change the Work Schedule infotype record as well.

You should check infotype settings after you save entries, to ensure any automatic changes are appropriate.

See also:
Department/Staff (infotype 1003) [Page 42]
Work Schedule (infotype 1011) [Page 53]
Employee Group/Subgroup (infotype 1013) [Page 56]
Obsolete (infotype 1014) [Page 57]
Vacancy (infotype 1007) [Page 47]
Quota Planning

Use

Using this function, you can plan required positions per job centrally for the organizational units you are directly responsible for. You can plan either in full positions, or in full-time equivalents (FTE).

A planning type is chosen centrally for each planning round. In other words, it is determined whether the first plan, second plan or another plan created in Customizing will be followed. The line manager can, therefore, only plan those planning types that are marked as ‘current’ in the Plan Required Positions screen.

In the same way, the unit of time (months, weeks, quarters, years, for example) according to which positions are planned over the entire planning period (01.01.1999 - 31.12.1999, for example) is predefined centrally in Customizing.

For further information on planning required positions, see Quota Planning (1019) [Page 66].

– You can make quota planning settings in the corresponding customizing activities in the IMG (implementation guide), in the Manager’s Desktop component (Personal Management → Manager’s Desktop → Quota Planning), and in the Organizational Management component (Personnel Management → Organizational Management → Infotype Settings → Quota Planning).

– You can find quota planning reports in the SAP Easy Access Menu under Personnel → Organizational Management → Tools → Quota Planning.

Activities

In the Planned line, enter for each time period the total number of positions required in your area of responsibility. You must also take into account the existing positions that are displayed directly above in the Current line.

In a planning period of one year, a manager must plan the positions he or she requires for his or her area for each quarter. Ten positions are predefined in the Current line. The manager plans no new positions for the first two quarters, two for the third quarter, and three more for the last quarter. The manager therefore enters the numbers 10,10,12 and 15 in the Planned line for the four quarters.
Starting Further Attributes in Change Mode

Prerequisites
You work in change mode to add or edit infotype settings.

Procedure
1. On the Organizational Management screen, choose Simple maintenance → Further attributes → Change
   The Attributes of Organizational Units and Positions/Change screen appears.
2. In the Organizational Unit and Editing period fields, enter data as required.
3. Choose Attributes → Change.
   The Attributes of Organizational Units and Positions/Change screen appears.

You start display mode in the same way.
You can switch between change and display mode. See Switching between Display and Change Mode [Page 257]
Viewing Current Infotype Settings

Prerequisites
You use this function, if you want to display, rather than edit, the current infotype settings.

Procedure
1. On the Attributes of Organizational Units and Positions/Display screen, choose the object you want to display.
2. Choose Edit → Display Attributes.
   A dialog box appears displaying the current infotype settings. (Which dialog box appears depends on the object type you selected – position or organizational unit.)
3. To exit the dialog box, choose Cancel.
Changing Attributes

Prerequisites
You change attributes to add or edit the infotype settings.
You are not required to enter all infotype settings.
The attributes you can enter vary according to the type of object you select – position or organizational unit.

Procedure
1. On the Attributes of Organizational Units and Positions/Change screen, choose the object you want to edit.
2. Choose Edit → Change Attributes.
   A dialog box appears displaying the current infotype settings. (Which dialog box appears depends on the object type you selected – position or organizational unit.)
3. To add or change settings, enter data in the corresponding fields. (Overwrite current settings.)
4. Save your entries.
5. To exit the dialog box, choose Cancel.

Result
The system saves your entries, and creates the appropriate infotype records.

Because interdependencies exist among different infotypes, your entries for one infotype can automatically change another. You should check infotype settings after you save entries, to ensure any automatic changes are appropriate.
Structural Graphics (BC-BMT-GRF)

Purpose

*Structural Graphics* is a tool in the *Organizational Management* application component that lets you display and edit the structures and objects in your organizational plan. *Structural Graphics* is particularly advantageous since it lets you view objects and structures, and perform a variety of maintenance activities for the objects in graphical format.

Implementation Considerations

There are a number of ways you can access *Structural Graphics*. You can access it from *Simple Maintenance* or from the *Organizational Management* main menu by choosing **Reporting → General → Structural Graphics**.

When you maintain your organizational plan from the *Structure Display/Maintenance* screen, you can also access *Structural Graphics*.

For more detailed information on the basics of *Organizational Management*, refer to *Organizational Management* [Page 13].

Integration

The graphical display and edit functions offered by *Structural Graphics* complement the tools provided in *Simple Maintenance of Organizational Management*.

The functions in *Simple Maintenance* are particularly suited to creating organizational and reporting structures in your organizational plan. *Structural Graphics* is advantageous in that it lets you graphically display the whole organizational plan, complete with the relationships between the various objects. In addition, it makes organizational planning and modeling in a graphical environment much easier.

Features

- *Structural Graphics* lets you make structural changes to your organizational plan by simply moving objects around in the hierarchical structure. You can move single objects or substructures within your organizational plan. Changes to the arrangement of your organizational plan are represented immediately in the graphic.

- You can perform maintenance activities using the *Toolbox* in conjunction with the main Graphics window. Alternatively, you can use the functions behind the menu options **Utilities** and **Extras**. The *Toolbox* is a collection of options that allow you to perform basic editing, for example, creating, inserting, moving, and delimiting. It is possible to customize the options offered in the *Toolbox*, so options may vary from company to company.

- Selecting objects in *Structural Graphics* is easy. You simply use the cursor to select the object you want to edit, and it appears highlighted in the Graphics window. You can select a number of objects by clicking the right mouse button and dragging the cursor.

- The function **Maintain Infotypes** lets you edit the attributes of objects. In the Object Description window, the list of infotype records maintained for the selected object is displayed for editing.

- *Structural Graphics* also offers you functions for changing the shapes and colors of objects, and adjusting the display format of your structure as required.
Graphic Tools in Human Resources

The SAP R/3 system offers graphics tools that allow users who use different R/3 application components to display and work with information.

Organizational Management includes the following graphics tools:

- Structural Graphics
- Statistical Graphics
- Business Graphics

Use these tools to display different types of information in different components of Human Resources (HR).

**Structural Graphics**

When you use Structural Graphics the system displays information in hierarchical structures. In Organizational Management for example, you can display organizational structures, reporting structures and business event structures. Structural Graphics also allows you to maintain structures (create, change, delimit, and so on).

**Statistical Graphics**

When you use Statistical Graphics the system displays information in a two-dimensional line graph. Use Statistical Graphics to compare figures and statistics. For example, in the Qualifications and Requirements component of HR, you can request a report that compares the qualifications of an employee with the requirements of a position. This information is shown in a statistical display.

**Business Graphics**

When you use Business Graphics the system displays information using three- or four-dimensional graphs. For example, in the Personnel Cost Planning component of HR you can request a report that breaks down personnel costs based on organizational units. Business Graphics displays costs for selected organizational units in a three-dimensional bar graph.

**See also:**

[Starting Graphics Tools in Organizational Management](Page 388)
Starting Graphics Tools in Organizational Management

The different components of Human Resources (HR) use different graphics tools. For example, the Organizational Management component uses Structural Graphics, the Qualifications and Requirements component uses Statistical Graphics, and so on.

How you access graphics tools depends on which component you are using.

How you access a graphics tool determines the types of objects you can work with. For example, if you access Structural Graphics from Organizational Management, you cannot work with qualification object types.
Starting Structural Graphics in Organizational Management

You can access *Structural Graphics* from the *Organizational Management* component in different ways.

How you access Structural Graphics determines the type of objects you can work with. For example, if you access *Structural Graphics* through the position report options, you can only work with positions and employees.

You can also specify which objects you want to work with: Related topics:

- [Starting Structural Graphics for Any Object](#) [Page 347]
- [Starting Structural Graphics for Organizational Units](#) [Page 343]
- [Starting Structural Graphics for Positions](#) [Page 344]
- [Starting Structural Graphics for Work Centers](#) [Page 345]
- [Starting Structural Graphics for Tasks](#) [Page 346]
Starting Structural Graphics for Organizational Units

Prerequisites
Start Structural Graphics for organizational units when you want to work with organizational units in a plan. This lets you work with the positions, persons, or work centers related to organizational units.

To access Structural Graphics for organizational units, an organizational plan must contain at least one organizational unit.

Procedure
On the Organizational Management screen:
1. Choose Reporting → Organizational unit → Organizational Plan.
2. Select whether you want to view the organizational plan with organizational units, positions, persons or work centers.
   A report request screen appears.

   The title of the report request screen depends on the report you select, even though you are working with the Simplified Request screen.

3. Enter data as required.
4. Choose Execute.
   The Structure Display/Maintenance screen appears, showing the selected organizational units. Depending on your earlier selections, it may also list positions, persons, or work centers.

5. To limit the information shown in Structural Graphics, select the highest level unit that interests you. Structural Graphics displays the selected unit, and all its underlying units.
   Otherwise, select the first organizational unit in the list.


Result
The Structural Graphics screen appears displaying the selected units.
Starting Structural Graphics for Positions

Prerequisites
Start Structural Graphics for positions when you want to work with positions in an organizational plan. You can work with or without the persons related to the positions.

To access Structural Graphics for positions an organizational plan must contain at least one position.

Procedure
On the Organizational Management screen:
1. Choose Reporting → Position → Reporting structure.
2. You select whether you want to view positions with or without persons.
   
   A report request screen appears.

   The title of the report request screen depends on the report you select, even though you are working with the Simplified Request screen.

3. Enter data as required.
4. Choose Execute.
   
   A screen appears listing the selected positions. (Depending on your earlier selections, it may also list persons).

5. To limit the information shown in Structural Graphics, select the highest level position of the area that interests you. Structural Graphics displays the selected position, and its underlying positions.

   Otherwise, select the first position in the list.


Result
The Structural Graphics screen appears displaying the selected positions.
Starting Structural Graphics for Work Centers

Prerequisites
Start Structural Graphics for work centers when you want to work with work centers and related organizational units.

Work center information is displayed according to organizational structure. To define which work centers Structural Graphics displays, specify the organizational units.

To access Structural Graphics for work centers, an organizational plan must contain at least one organizational unit.

Procedure
On the Organizational Management screen:
1. Choose Reporting → Work center → Per Org.Unit.
   A report request screen appears.
   The title of the report request screen depends on the report you select, even though you are working with the Simplified Request screen.
2. If you want to limit the organizational units shown (and therefore the work centers), enter data as required on the report request screen.
   If not, leave the fields blank. All work centers and organizational units of every status are shown.
3. Choose Execute.
   A screen appears listing the selected work centers and organizational units.
4. If you want to limit the information shown in Structural Graphics, select the highest level organizational unit of the area that interests you. Structural Graphics displays the selected unit, and its underlying units and work centers.
   If not, select the first unit in the list.

Result
The Structural Graphics screen appears displaying the selected organizational units and work centers.
Starting Structural Graphics for Tasks

Prerequisites
Start *Structural Graphics* for tasks when you want to work with tasks in an organizational plan. This allows you to work with the positions related with tasks, or with the positions and persons related with tasks.

Task information is displayed according to organizational structure. To define which tasks *Structural Graphics* shows, specify the organizational units.

Procedure
On the *Organizational Management* screen:

1. Choose *Reporting* → *Task* → *Activity Profile*.
2. Select tasks with or without persons. A report request screen appears.

   ![Report Request Screen]

   The title of the report request screen depends on the report you select, even though you are working with the *Simplified Request* screen.

3. If you want to limit the organizational units (and therefore the tasks) shown in *Structural Graphics*, enter data in the appropriate fields.
   If not, leave the fields blank.
4. Choose *Execute*.

   A screen appears listing the selected organizational units, positions, tasks, and persons. (This depends on your earlier selections.)
5. If you want to limit the information *Structural Graphics* shows, select the highest level organizational unit of the area that interests you. *Structural Graphics* displays the selected unit, and its underlying objects (other organizational units, tasks, positions and persons).
   If not, select the first organizational unit in the list.
6. Choose *Structural Graphics*.

Result
The *Structural Graphics* screen appears displaying the selected organizational units, positions, tasks and persons (if you selected them earlier).
Starting Structural Graphics for Any Object

Prerequisites
Start Structural Graphics for any object when you want to specify the type of objects you work with in Structural Graphics.

Procedure
On the Organizational Management screen:
   A report request screen appears.
2. To select the objects you want to work with, enter data in the appropriate fields.
3. Choose Execute.

Result
The Structural Graphics screen appears displaying the selected objects.
Maintaining Objects in Structural Graphics

The following topics describe how to maintain objects in Structural Graphics (create, change, delete and so on).

You cannot select the type of object you want to change if you have started Structural Graphics. How you start Structural Graphics determines the type of object you can work with. See Starting Structural Graphics in Organizational Management [Page 342]

Creating Objects in Structural Graphics [Page 352]
Inserting Objects in Structural Graphics [Page 354]
Moving Objects in Structural Graphics [Page 353]
Delimiting Objects in Structural Graphics [Page 356]
Deleting Objects in Structural Graphics [Page 357]

See also:
Using Additional Functions [Page 415]
Selecting Objects

To perform certain activities, you must first select an object. An example of an action is changing the shape or color of an object.

You can select single objects, groups of objects, or all objects.

Selecting Single Objects [Page 350]
Selecting Groups of Objects [Page 351]
Selecting All Objects in a Structure [Page 375]
Deselecting All Objects in a Structure [Page 376]
Selecting Single Objects

To work with an object, select the object. The system highlights the selected object.
Selecting Groups of Objects

Prerequisites
Select groups of objects when you want to perform the same action on all those objects.

Procedure

To select single objects:
1. Press and hold down the **SHIFT** key.
2. Select the first object.
   The system highlights the selected object.
3. Press and hold down the **SHIFT** key and select another object. Repeat this as often as required.

To select a group of objects:
1. Press the left mouse button and hold it down.
   A small rectangle appears in the view window.
2. Drag the mouse across the objects, until the objects are inside the rectangle.
3. Release the mouse button.
   The system highlights the selected objects.

To select one branch of a structure:
1. Press and hold down the **CTRL** key.
2. Select the object which is at the highest level in the branch.
   The system highlights the selected branch.

To select more than one branch of a structure:
1. Press and hold down the **CTRL** and **SHIFT** keys.
2. Select the highest level object in the first branch.
   The system highlights the selected branch.
3. Select the highest level object in the next branch.
   The system highlights the selected branch.
4. Select as many branches as required.
Creating Objects in Structural Graphics

Prerequisites
Create objects when you want to add new objects to an organizational plan.

To create an object in Structural Graphics, you must define where the object fits in a hierarchical structure. When you do this, you define a relationship between a new object and an existing object. (Therefore, you create a relationship infotype record.)

You can create more than one object at a time in Structural Graphics.

Procedure
On the Structural Graphics screen:
1. Select the parent object for the new object.
2. Do one of the following:
   - Retrieve the Toolbox, and choose Utilities → Create object. See Retrieving the Toolbox [Page 387]
   - Choose Utilities → Create objects.
     A dialog box appears.
3. Enter data in the Abbr. and Name fields for each new object. You can enter up to five new objects.
4. To enter a validity period for the new objects, choose Period.
   - The Validity Period dialog box appears.
   - To change the default validity period, enter new dates. You can overwrite the existing dates.
     To accept the default validity period, go to step #5.
5. To enter a status for the new objects, choose Status.
   - A dialog box appears.
   - Select a status option.
     To accept the default status, go to step 6.
6. Choose Continue.

Result
Structural Graphics displays the new objects in the hierarchical structure.
Moving Objects in Structural Graphics

Prerequisites
You can change the positions of objects in a hierarchical structure. When you change the positions of objects you change the relationships between objects and, therefore, the relationship infotype records.

When you move an object, the system also moves its underlying objects.

⚠️ When you position an object in a structure, the relationship it forms with other objects must be permitted. For example, you cannot move an employee from one organizational unit to another because you cannot create a direct relationship between an employee and an organizational unit.

Procedure
On the Structural Graphics screen:
1. Select the object you want to move.
2. Do one of the following:
   - Retrieve the Toolbox, and choose Utilities → Move object. (See Retrieving the Toolbox [Page 387].)
   - Choose Utilities → Move objects.
     The mouse pointer changes.
3. Select the new parent object.

Result
The system moves the selected object, and its underlying objects.
Inserting Objects in Structural Graphics

Prerequisites
Use the Insert Objects feature to add an object to a hierarchical structure when the object is not related to other objects in the hierarchical structure.

Using the Insert Objects feature in Structural Graphics is like creating a relationship infotype record in Detail Maintenance but is faster and simpler.

You can insert more than one object at a time.

Procedure
On the Structural Graphics screen:

1. Select the parent object for the new object.
2. Do one of the following:
   - Retrieve the Toolbox, and choose Utilities → Insert object. See Retrieving the Toolbox [Page 387]
   - Choose Utilities → Insert objects.
     The Relationship/Object type dialog box appears.
3. Use the dialog box to select a relationship, then choose Continue.
   The Possible Entries dialog box appears.
4. Use the dialog box to select the object you want to insert.
   A dialog box appears showing the parent object.
5. To enter a validity period, choose Period.
   - The Validity Period dialog box appears.
   - To change the default validity period, enter new dates. You can overwrite the existing dates.
     To accept the default validity period, go to step #6.
6. To enter a status, choose Status.
   - A dialog box appears.
   - Select a status option.
     To accept the default status, go to step #7.
7. Choose Continue.

Result
The system inserts the object(s) in the hierarchical structure.
Delimiting Objects in Structural Graphics

Prerequisites
Delimit an object when you want to change the validity period of the object.
You may want to change validity periods when, for example, your company closes a department. In this case, change the validity period for the organizational unit concerned.

Procedure
On the Structural Graphics screen:
1. Select the object you want to delimit.
2. Do one of the following:
   - Retrieve the Toolbox, and choose Utilities → Delimit object. (See Retrieving the Toolbox [Page 387].)
   - Choose Utilities → Delimit object.
   The Delimit dialog box appears.
3. Choose Period
   The Set Date dialog box appears.
4. Enter the Delimitation Date.
5. Choose Continue.
   You return to the Delimit dialog box.
6. Choose Continue.
   You return to the main Structural Graphics screen.

Result
The selected object is delimited to the date you entered.
Deleting Objects in Structural Graphics

Prerequisites

There is an important difference between deleting objects and delimiting objects. It is important that you use these features in the appropriate circumstances.

When you delete objects, all records of the objects are removed from your plan. Delete objects only when, for example, you have mistakenly created an object.

Do not delete an object when, for example, your company suppresses an organizational unit or position and you want to show that change in the hierarchical structure. Do not delete an object because information about the object changes. Use the Delimit feature to do this.

Procedure

On the Structural Graphics screen:
1. Select the object you want to delete.
2. Do one of the following:
   - Retrieve the Toolbox, and choose Utilities → Delete object. (See Retrieving the Toolbox [Page 387].)
   - Choose Utilities → Delete objects.
     The Delete dialog box appears.
3. Choose Continue.

Result

The system deletes the selected object.
Displaying an Object Description

Prerequisites
Use this option to display the infotype records of a selected object.

Procedure
On the Structural Graphics screen:
1. Select an object.
2. Do one of the following:
   - Retrieve the Toolbox, and choose Extras → Object description. (See Retrieving the Toolbox [Page 387].)
   - Choose Extras → Object description.
3. The Display Infotypes screen shows the required information.
4. Choose Back or Cancel.
Displaying Object Data in Structural Graphics

Prerequisites
Display object data to view information about an object (organizational units, positions, and so on) displayed in Structural Graphics. For example, you can view the validity period, object status, object ID, and so on.

You can only display information. You cannot edit it.

Procedure
On the Structural Graphics screen:
1. Select an object.
2. Do one of the following:
   – Retrieve the Toolbox, and choose Extras \(\rightarrow\) Display object data. (See Retrieving the Toolbox [Page 387].)
   – Choose Extras \(\rightarrow\) Display object data.
     A screen appears displaying the object data.
3. To exit the screen, select the control box.
   A menu appears.
4. Choose Close.
   The Object Data screen closes.
Maintaining Infotypes in Structural Graphics

Prerequisites

You can maintain infotypes for selected objects in Structural Graphics but you cannot maintain them directly. Request an object description for a selected object. Then, on the Object Description screen, maintain the infotypes.

Infotype information is not immediately updated in Structural Graphics. You must exit Structural Graphics to update infotype information.

If you maintain a lot of infotype information, use Detail Maintenance.

Procedure

On the Structural Graphics screen:

1. Select an object.
2. Do one of the following:
   - Retrieve the Toolbox, and choose Extras → Maintain infotypes. See Retrieving the Toolbox [Page 387]
   - Choose Extras → Maintain infotypes.
3. The Object Description screen appears listing the types of infotype records that are maintained (or not) for the selected object.
4. To exit the screen, choose Back or Cancel.
Changing Staff Modes in Structural Graphics

Prerequisites

Use this feature when your organizational plan includes positions and organizational units that have staff flags. Staff flags are applied in the Department/Staff Function infotype (1003).

The Change staff mode option allows you to switch the staff flag on and off. This lets you display a reporting or organizational structure with or without staff positions and organizational units. When staff flags are switched on, staff objects are shown to one side of the superior object. When staff flags are switched off, staff objects are shown below the superior object.

Unlike display features in Structural Graphics, when you change staff flags, they remain changed.

Procedure

On the Structural Graphics screen:
1. Select an object (an organizational unit or position).
2. Do one of the following:
   - Retrieve the Toolbox, and choose Utilities → Change staff modes. (See Retrieving the Toolbox [Page 387].)
   - Choose Utilities → Change staff modes.

Result

The flag on the selected object is switched on or off.

If there is no Department/Staff Function infotype record for the object you select, the system allows you to create one.
Changing Object Attributes

Changing Color Assignments for Objects [Page 366]
Changing Shapes for Objects [Page 367]
Changing Line Types for Objects [Page 368]
Color Assignments

You can change the colors of the elements of the Structural Graphics display.

The Color Assignment Dialog Box [Page 364]

Changing Color Assignments for Objects [Page 366]
The Color Assignment Dialog Box

The **Color Assignment** dialog box allows you to change the color of different elements of the Structural Graphics display, for example, objects, title bars, view window frames, and so on.

**Left side of dialog box**

Use the left side of the dialog box to select a color.

**Right side of dialog box**

Use the right side of the dialog box to select the element you want to change color. The elements listed depend on whether you choose *Object* or *Options* to access the *Color Assignment* dialog box.

**See also:**

- [Changing Color Assignments](Page 365)
- [Changing Color Assignments for Objects](Page 366)
Changing Color Assignments

Prerequisites
You can change the colors of the elements of Structural Graphics, for example, the colors of title bars, background shading, text in title bars, and so on. Changes are valid only for the current work session. However, you can save settings for future work sessions, using the Save Options feature.

You can create and maintain a number of color schemes using design profiles. You can then select a design profile using the Design option in the View Options dialog box. Design profiles are set up in Customizing.

Procedure
1. Choose Options → Color Assignment.
   The Color Assignment dialog box appears.

2. Use the dialog box options to enter your selections.
   See The Color Assignment Dialog Box [Page 364]

3. Choose Apply.
   The system changes the color.

4. To change other color assignments:
   – Use the Color Assignment dialog box options to enter your selections.
   – Choose Apply.

5. To exit the Line Options dialog box, choose Continue or Cancel.
Changing Color Assignments for Objects

Prerequisites
You can change the colors of the following:
- Background color of an object shape
- Text that identifies an object
- Lines that connect an object to its parent object

You can only change object color assignments when the Design setting in the View Options dialog box is set to manual. For details, see The View Options Dialog Box [Page 391]

Color selections only apply to the current work session.

Procedure
1. Select the object.
2. Choose Object → Change colors.
   The Color Assignment dialog box appears.
3. Choose your colors.
   See The Color Assignment Dialog Box [Page 364]
4. Choose Apply.
   The system applies the colors you choose.
5. To change color assignments for other objects:
   - Select the object.
   - Choose your colors in the Color Assignment dialog box.
   - Choose Apply.
6. To exit the Color Assignment dialog box, choose Continue.
Changing Shapes for Objects

Prerequisites
You can change the shape of an object. This can be useful, for example, if you need to set one object apart from other objects.

The settings you make apply only to the current work session.

You can only change object shapes when the Design setting in the View Options dialog box is set to manual. See The View Options Dialog Box [Page 391]

Procedure
1. Select the object whose shape you want to change.
2. Choose Object → Change shape.
   A drop-down menu shows a list of shapes available.
3. Choose the shape you want.

Result
The system changes the shape of the object.
Changing Line Styles for Objects

Prerequisites
You can change the style of lines that connect objects in a hierarchical structure. You can, for example, use solid lines, dotted lines, and so on.

You must first select the object. Structural Graphics changes the style of the line from the selected object to its parent object.

You can only change line styles when the Design setting in the View Options dialog box is set to manual. See The View Options Dialog Box [Page 391]

Procedure
1. Select an object.
2. Choose Object → Change line style.
   A drop-down menu shows a list of line styles available.
3. Choose a line style.

Result
The system changes the line style.
Working with Hierarchical Structures

There are a number of features that allow you to customize the way the system presents hierarchical structures. This allows you to view information in different ways.

- Displaying Close-ups of a Structure [Page 371]
- Displaying Substructures [Page 372]
- Displaying Parent Structures [Page 373]
- Displaying Whole Structures [Page 374]

- Centering Selected Objects [Page 377]
- Centering Root Objects [Page 378]
- Displaying Paths [Page 379]

- Suppressing Subordinate Objects [Page 381]
- Displaying Subordinate Objects [Page 380]

- Increasing Space Between Objects [Page 382]
- Increasing Space Between Objects [Page 383]

- Displaying Objects One Level Lower [Page 384]
- Displaying Objects One Level Higher [Page 385]

To change how the system displays hierarchical structures, use the View Options, Object Options and Line Options dialog boxes.
Switching Between Overview and Detail Mode

Prerequisites
You can work with Structural Graphics in overview or detail mode.

- In Overview mode the system compresses the hierarchical structure so that you can see all of the structure in one view window. Because the objects are compressed, the complete object name may not be visible.

- In Detail mode the system presents a hierarchical structure so that you can read the descriptions of the objects in the structure. You may not be able to see all of the structure.

If you are working with multiple view windows, you can use different view modes in different view windows. For example, view window 1 can contain an overview of a hierarchical structure, and view window 2 can contain a detail of the structure.

Procedure
Choose one of the following:

- Goto → Detail<->View
- Detail<->View.

Result
The system changes the view mode.
Displaying Close-ups of a Structure

Prerequisites

Use this feature to display a close-up of a section of a hierarchical structure. The section you select expands to fill the view window. This feature affects the active view window only.

This feature is only available in overview mode.

You can also use the Display Substructures feature to view selected sections of a structure. See Displaying Substructures [Page 372]

Procedure

1. Choose Goto → Choose section.
   
   A rectangle appears in the window.

2. Select the rectangle and hold down the left mouse button. Drag the rectangle over the section you want to view in close-up.

3. Release the mouse button.

Result

The system displays a close-up of the selected section of the structure.
Displaying Substructures

Prerequisites

Use this feature to display a substructure of a hierarchical structure. Substructures are parent/child structures that form a hierarchical structure.

When you use this feature, Structural Graphics hides objects above and below the substructure you select.

This feature is active in overview and detail mode, and only affects the active view window.

You can also use the Choose Section feature to view selected areas of a structure. For details, see Displaying Close-ups of a Structure [Page 371]

Procedure

1. Select the parent object in the substructure you want to view.
2. Choose Goto → Display substructure.

Result

The system displays the substructure.
Displaying Parent Structures

Prerequisites

Use this feature to display objects which are one level higher in a hierarchical structure. This feature is useful if you have hidden parent objects using other Structural Graphics features such as Display Substructure. This feature only affects the active view window.

Procedure

Choose Goto → Parent structure.

Result

The system displays the parent objects.
Displaying Whole Structures

Prerequisites
Use this feature to view an entire hierarchical structure.
This feature is useful if you have used other features to view a section of a structure.
This feature only affects the active view window.

Procedure
Choose Goto → Display whole structure.

Result
The system displays the whole structure.
Selecting All Objects in a Structure

Prerequisites

The *Select all* feature allows you to select all objects in a hierarchical structure. Use this feature to perform the same action on all objects. When you use *Select all*, the system selects all objects in all view windows.

Procedure

Choose *Edit* → *Select all*.

Result

The system highlights selected objects.
Deselecting All Objects in a Structure

Prerequisites
Use the Deselect all feature to deselect all selected objects in a hierarchical structure. When you use Deselect all, the system deselects all objects in all view windows.

Procedure
Choose Edit → Deselect all.

Result
The system deselects all objects.
## Centering Selected Objects

### Prerequisites
How this feature works depends on whether you are in detail mode or overview mode.

### Procedure

#### Detail mode
Use this feature to center selected object(s) in the window. The position of the objects in the hierarchical structure is unchanged.

If you select more than one object, the system centers each object in turn.

This feature only affects the active view window.

1. Select the object(s) you want to center.
2. Choose *Goto → Center selected object.*
   - The system centers the object.
3. If you select more than one object:
   - Press the **TAB** key.
   - The system centers the next object.

#### Overview mode
Use this feature to position the mouse pointer on a selected object. If you select more than one object, the system points to each object in turn.

This feature only affects the active view window.

1. Select the object you want to center.
2. Choose *Goto → Center selected object.*
   - The mouse pointer points to the selected object.
3. If you selected more than one object:
   - Press the **TAB** key.
   - The mouse pointer points to the next object.
Centering Root Objects

Prerequisites
Use this feature to center the root object of a hierarchical structure in the view window. The position of the object in the hierarchical structure is unchanged.
This feature only affects the active view window, and is only available in detail mode.

Procedure
Choose Goto → Center selected object.

Result
The system centers the root object.
Displaying Paths

Prerequisites
Use this feature to view a list of all objects in a path of a hierarchical structure.
Select a path by selecting any object in the path.

Procedure
1. Select an object in the path you want to view.
2. Choose Object → Display path.
   The Object Path dialog box displays a list of objects in the path.
3. To view objects in other paths:
   – Select another object.
   The system displays a new list.
4. To exit the Object Path dialog box:
   – Select the Control Box.
   A drop down menu appears.
5. Choose Close.
Displaying Subordinate Objects

Prerequisites

Display subordinate (or child) objects when a branch of a structure is hidden. You can hide selected branches of a structure using the Suppress Subordinate Objects feature. See Suppressing Subordinate Objects [Page 381]

If you are working with multiple view windows, this feature affects all open windows.

Procedure

1. Select the parent object of the child objects you want to display.
2. Choose Object → Display Subordinate Objects.

Result

The system displays the branch of the structure.
Suppressing Subordinate Objects

Prerequisites

Use the Suppress Subordinate Objects feature to hide objects that are below a certain level in a branch of a hierarchical structure.

If you are working with multiple view windows, this feature affects all view windows, in overview and detail mode.

Procedure

1. Select the parent object of the child objects you want to hide.
2. Choose Object → Suppress Subordinate Objects.

Result

The system hides the selected branch of the structure.
Increasing Space Between Objects

You can increase the display area between objects in a hierarchical structure by changing the *Outer Frame* and *Inner Frame* settings in the *Object Options* dialog box.

[Changing Object Options [Page 398]]
Decreasing Space Between Objects

You can decrease the display area between objects in a hierarchical structure by changing the Outer Frame and Inner Frame settings in the Object Options dialog box.

Changing Object Options [Page 398]
Using One Level Lower

Prerequisites
Use the _One level lower_ feature to display an object or branch of objects at one level lower in a structure.

This feature does not affect the relationship or position of objects in a structure. It is for display only.

The system applies this feature to all view windows open, in overview or detail mode.

Procedure
1. Select the object you want to display at a lower level.
2. Choose _Object_ → _One level lower_.

Result
The system displays the selected object at a lower level in the structure.
Using One Level Higher

Prerequisites

Use the One level higher feature to display an object or branch of objects at one level higher in a structure.

This feature does not affect the relationship or position of objects in a structure. It is for display only.

The system applies this feature to all view windows open, in detail or overview mode.

Procedure

1. Select the object you want to display at a higher level.
2. Choose Object → One level higher.

Result

The system displays the selected object at a higher level in the structure.
About the Toolbox

About the Toolbox

Use the Toolbox to change objects, for example, creating, inserting, moving, delimiting, and so on.

You can set the functions available in the toolbox in Customizing. For this reason, functions can vary from company to company. (For details on Customizing the Toolbox, see the Implementation Guide, Personnel Planning and Development.)

Use the Toolbox with the main Structural Graphics screen. Use the Structural Graphics screen to select an object; then use the Toolbox to change the object.

To change objects, you can also use the Utilities and Extras menu paths.

See also:

Retrieving the Toolbox [Page 387]
Retrieving the Toolbox


See also:
About the Toolbox [Page 386]
Starting Graphics Tools in Organizational Management

The different components of Human Resources (HR) use different graphics tools. For example, the Organizational Management component uses Structural Graphics, the Qualifications and Requirements component uses Statistical Graphics, and so on.

How you access graphics tools depends on which component you are using.

How you access a graphics tool determines the types of objects you can work with. For example, if you access Structural Graphics from Organizational Management, you cannot work with qualification object types.
**Option Settings**

**Use**

Use the *Option Settings* feature to make changes to settings that define how the system displays hierarchical structures.

The following option settings are available:

- View Options
- Object Options
- Line Options
- Sort option settings
- Search option settings
- The number of view windows open
- Color assignments, except when you use the *Object* options

To save your settings, choose *Options → Save options*. If you do not save the option settings, the next time you use *Structural Graphics* the system uses the last option settings saved, or the default settings.

To delete settings, choose *Options → Delete options*. 
View Options

The View Options feature allows you to control how the system displays hierarchical structures. For example, the system can display structures top-down or left-to-right.
The View Options Dialog Box

The View Options dialog box lets you change how hierarchical structures are displayed in view windows. View options apply in detail and overview mode.

The changes you make apply only to the current work session. However, you can save the settings for future work sessions, using the Save Options feature.

⚠️ If you access the View Options dialog box through the Print dialog box (not through the standard menu), the settings you enter apply to the print request only.

View

Use this option to select a view window. View windows are numbered sequentially in the order in which the windows are opened. To select a view window, select the arrows until the view window is shown.

Display Level

Use this option to determine how many levels of a hierarchical structure to display. 0 means the entire structure, 1 means top level only, 2 means top two levels only, and so on. Select the corresponding display depth using the arrow key.

Grid

You can display hierarchical structures on a grid. To display the grid, set the Grid indicator.

Display Mode

Use this option to select the view mode, overview or detail. In Overview mode the system compresses the hierarchical structure so you can see all of it in one view window. In Detail mode the system expands the hierarchical structure so you can see each object in the hierarchical structure. However, in Detail mode you cannot see all the structure.

(To switch between overview and detail mode, choose one of the following:

- `Detail<->View`
- `Goto Goto Detail<->View`)

Knock-On Mode

This option lets you determine how Structural Graphics displays an object when you select the object. (You must select an object before changing the object’s shape, color, line style, and so on.)

This option is useful when you work with multiple view windows. This option allows you to view a selected object from different points of view at the same time.

You can select a different knock-on mode for each view window. When you select an object, each window shows the selected object in a different way. Example: One window shows the selected object centered, another window shows the substructure of the selected object, and another window shows the parent structure.

To select a knock-on mode, set one of the following indicators:
The View Options Dialog Box

*Off* - The system highlights the selected object. The display does not change.

*Center* - The system highlights the selected object, and positions it in the center of the view window.

*Substructure* - The system highlights the selected object, and displays only the selected object and its child objects.

*Parent structure* - The system highlights the selected object, and displays only the selected object and its parent object.

**Graphic Type**

Use this option to select how Structural Graphics presents a hierarchical structure. To make a selection, set one of the following indicators:

- *Normal* - The system presents the hierarchical structure in a top-down format.
- *Feathered* - The system presents the hierarchical structure in a right-to-left format.
- *Compact* - The system presents the hierarchical structure using a combination of formats. Top-down format is used for the upper levels of the structure. (Objects on the lowest level are presented vertically. When you select this option, the system sets the number of levels displayed to 3. You can change this setting in the *Display Depth* field.)
- *User-defined* - The system presents the hierarchical structure according to a format which you define. See *Define Graphic Type* below.

**Design**

Use this option to select which design profile you want to apply to a view window. Design profiles contain presentation characteristics. For example, a profile can use squares to represent objects, blue lines to connect objects, and so on. Define Design profiles in Customizing.

The design profiles available depend on the design group you select. You can change design groups. See the *Change design* option below.

**Define Graphic Type**

Use this option to define a method for presenting hierarchical structures. You can define object alignment and rotation.

*Alignment* - The system aligns the objects in the hierarchical structure so that they are left justified, right justified, or centered. To define alignment, set the appropriate indicator.

*Rotation* - The system rotates the structure to present it at the rotation degree you specify. For example, if you enter 180°, the structure appears upside down.

To specify a rotation, select the arrows until the system shows the rotation value you want.

1. To define a graphic type: Choose Graphic Type → *User defined*.
2. Choose *Define graphic type*.
   - The *Define Graphic Type* dialog box appears.
3. Make your selections.
4. To exit the dialog box: Choose *Close*. 
You return to the View Options dialog box.

5. Choose Apply.
   
   The system applies the settings to the active view window.

**Change Design**

Use this option to select a different design group. A design group is a set of design profiles. The design group you select determines which design profiles you can choose from when you use the Design option.

To change design groups:

1. Choose Change Design.
   
   The Design dialog box appears.

2. Select a design group.

3. Choose Continue.

For more information, see Changing Designs [Page 402]

**See also:**

Changing View Options [Page 394]
Changing View Options

Prerequisites

Change view options when you want to change how Structural Graphics presents hierarchical structures in view windows. You can enter different settings for different view windows.

View options determine how the system displays a structure, for example, top-down or right-to-left.

Procedure

1. Select a window.
2. Choose Options \(\rightarrow\) View options.
   
   The View Options dialog box appears.
3. Select the appropriate settings.
   
   For more information on the settings, see The View Options Dialog Box [Page 391]
4. Choose Apply.
5. To enter settings for other view windows:
   
   – Select a window.
   
   – Select the appropriate settings in the View Options dialog box.
   
   – Choose Apply.
6. To exit the View Options dialog box, choose Continue.
Object Options

Use *Object Options* to change how the system presents objects.

The [Change Object Options Dialog Box](Page 396)
[Changing Object Options](Page 398)
The Object Options Dialog Box

The **Object Options** dialog box lets you change how the system displays information about objects. Object options apply in detail and overview mode for the active view window.

Changes you make apply only to the current work session. However, you can save changes for future work sessions, using the **Save Options** feature.

⚠️ If you access the **Object Options** dialog box through the **Print** dialog box (not through the menu), the settings you enter apply to the print request only.

**Text Alignment**

Use this option to change the alignment of the text that identifies objects. To do so, set the appropriate indicator.

**Draw**

Use this option to determine which shapes the system uses to represent objects. To do so, set the appropriate indicator.

- **Shadow** - The system shades the edge of a shape to create a three-dimensional effect.
- **Solid** - The system fills the shape with color.
- **Line Wrap** - The system wraps the text. This option is active only in overview mode.

**Font**

Use this option to change the size of the object name text on screen. The system uses the selected font in any printouts you request.

**Outer Frame and Inner Frame**

The shape used to represent an object consists of two frames, an outer frame and an inner frame. The outer frame is the outline of the shape itself. The inner frame is the edge of the text box, which contains the text that describes the object.

The shapes that make up a hierarchical structure are displayed on a grid. (The grid can be visible or hidden.) Each cell in the grid contains one object.

**Outer Frame**

Use this option to change the size of a shape in relation to the size of the grid cell which contains the object. Use the top arrow to set the width. The lower arrow controls the height.

To increase the space between objects, decrease the vertical size of the outer frame. The system can display more of the text which describes the relationship between the objects.

**Inner Frame**

Use this setting to control the size of the text box relative to the size of the object (The size of the object is determined by the **Outer frame** setting). The top arrows control horizontal size, and the bottom arrows control vertical size. To enter a size, select the arrows.
Font Size
The use of this field depends on how you access the Object Options dialog box. This field is for display only. However, if you access this dialog box through the Print dialog box, you can change the font size for a printout. To choose a size, select the arrows.

See also:
Changing View Options [Page 394]
Changing Object Options

Prerequisites
You can change how the system displays object shapes and text in a selected view window. For example, you can change the alignment of text and the font size.

Procedure
1. Select a view window.
2. Choose Options → Object options.
   The Object Options dialog box appears.
3. Enter the appropriate settings.
   For more information on the settings, see The Object Options Dialog Box [Page 396]
4. Choose Apply.
5. To change object options for other view windows:
   – Select another window.
   – Enter the appropriate settings in the Object Options dialog box.
   – Choose Apply.
6. To exit the Object Options dialog box, choose Continue.
Line Options

You can change how Structural Graphics displays lines that connect objects in a hierarchical structure.

The Line Options Dialog Box [Page 400]
Changing Line Options [Page 401]
The Line Options Dialog Box

Use the Line Options dialog box to change the lines that connect objects. For example, you can select diagonal or straight lines, and you can change the width of the lines. Line options apply in detail and overview mode for the active view window.

Changes you make apply only to the current work session. However, you can save changes for future work sessions, using the Save Options feature.

⚠️ If you access the Line Options dialog box through the Print dialog box (not through the menu), the settings you enter apply to the print request only.

Relationship line
Use this option to select the type of lines you want. Lines can be diagonal or straight.

Relationship indicator
Use these options to change other aspects of a line.

Text - The system displays text that describes the relationship between two objects connected by a line. (Whether or not there is text depends on which R/3 application component you are using.)

Marker - The system places a small rectangle on the line.

Arrow - The system uses an arrow to show the direction of the relationship.

Font
Use this option to change the size of the text that describes the relationship between two objects. (Whether or not there is text depends on the R/3 application component you are using.) The system uses the selected font in printouts you request.

Group same texts
In a group of objects that are subordinate to the same parent object, the relationship between the subordinate objects is the same. Therefore, the text describing the relationship is the same.

Use this option to tell the system to display this text only once. This saves space in the view window. The system shows one complete description of the relationship.

Font Size
Use of this field depends on how you access the Line Options dialog box. This field is for display only. However, if you access this dialog box through the Print dialog box, you can change the font size for a printout. To change the size, select the arrows.

See also:
Changing Line Options [Page 401]
Changing Line Options

Prerequisites
You can change how the system presents lines that connect objects. For example, you can change the line style from straight to diagonal, the width of the line, and so on.

Procedure
1. Select a window.
2. Choose Options → Line options.
   The Line Options dialog box appears.
3. Select the appropriate settings.
   For more information on the settings, see The Line Options Dialog Box [Page 400]
4. Choose Apply.
5. To change line options for other view windows:
   – Select another window.
   – Select the appropriate settings in the Line Options dialog box.
   – Choose Apply.
6. To exit the Line Options dialog box, choose Continue or Cancel.
Changing Design Groups

Prerequisites

A design group is a set of design profiles. The design group you select determines which design profiles are available when you use the Design option in the View Options dialog box.

Design profiles contain presentation characteristics. For example, a profile can use squares to represent objects, blue lines to connect objects, and so on.

Define design groups and profiles in Customizing.

Choose a different design group when you want to work with a different set of design profiles.

How this feature works, depends on the R/3 application component you are using.

Procedure

1. Choose Options → Change Design.
   
   The Design dialog box appears.

2. Select the design group you want.

3. Choose Continue.
Mailing Hierarchical Structures

Prerequisites
You can mail a hierarchical structure to a person’s inbox. To use this feature, your company must use the R/3 mail system, SAPoffice.

When you mail a structure, the system sends the hierarchical structure as it appears in the active view window, except for temporary adjustments made to the structure. Temporary adjustments include viewing substructures or centering root objects.

Procedure
1. Choose Structure → Send.
   The Send Document screen appears.
2. In the Recipient field enter the names of persons you want to receive the hierarchical structure.
3. Choose Send.

Result
The system sends the hierarchical structure to the recipients.
About Sorting Objects

The *Sort* feature changes the order in which objects are presented in a hierarchical structure *from left to right* in each branch of a structure. You can sort objects according to various criteria, for example, ascending or descending order.

A sort does **not** affect the relationships between objects in a structure.

[The Sort Objects Dialog Box](Page 405)
[Sorting Objects](Page 406)
The Sort Objects Dialog Box

The Sort Objects dialog box lets you change the order in which objects are presented in a hierarchical structure from left to right in each branch of a structure. You must also make various settings.

Settings you make here apply only to the current work session. However, you can save changes for future work sessions, using the Save Options feature.

**Sort mode**

Use this field to enter the criteria for the sort. Set the following indicators:

- **No sort** - The system returns to the original sort order. When you choose No sort, the system presents objects in the order that they were provided to Structural Graphics by the R/3 application component you are using. For example, in Personnel Planning and Development (PD), this is the order in which the system extracted objects from the database.

- **By priority** - When you create objects you can give them priority numbers. The system can use priority numbers to sort objects. Priority numbers can be 1 to 99. 1 has the highest priority and is shown on the extreme left. 99 has the lowest priority and is shown on the extreme right.

- **By key** - The system sorts objects according to the key that identifies an object. The key varies for each R/3 application component. The key contains codes that identify objects.

- **By text** - The system sorts objects alphabetically, based on the text that describes the objects.

**Text type**

If you want to sort based on text, use this field to tell the system to use detail or overview texts. Overview texts describe objects when you are in overview mode. Overview texts are abbreviations the system uses based on available space. Detail texts describe objects when you are in detail mode. Detail texts are complete.

**Sequence**

Set this indicator to sort objects in ascending or descending order.
Sorting Objects

Prerequisites

Sort objects when you want to change the order in which objects appear in a structure. A sort affects the order of presentation from left to right in each branch of a structure.

The settings you enter are valid only during the current work session. However, you can save the settings for future work sessions, using the Save Options feature.

Procedure

1. Choose Object → Sort objects.
   
   The Sort Objects dialog box appears.

2. Enter the appropriate settings.
   
   See The Sort Objects Dialog Box [Page 405]

3. Choose Sort.
   
   The system sorts all objects.

4. To exit the Sort Objects dialog box, choose Close.
About Searching for Objects

The *Search* feature in Structural Graphics allows you to search for objects in the hierarchical structure you are viewing.

[The Search for Objects Dialog Box](Page 408)

[Searching for Objects](Page 409)
The Search for Objects Dialog Box

The Search for Objects dialog box lets you decide how the system makes a search. The following fields are available:

**Search string**

Use this field to enter all or part of the name of the object(s) you want to find. A search is made on the object name.

**Case sensitive**

Use this field to indicate if the system should match the case in your entry in the Search string field. To match case, set the Case sensitive indicator.

**Remove previous selection**

You can keep the Search for Objects dialog box open and make several searches in sequence. Use this field if you have made a search and want to remove the settings for that search. To remove settings, set the Remove previous selection indicator.

See also:

Searching for Objects [Page 409]
Searching for Objects

Prerequisites

Use the Search for objects feature when you want to find an object or objects in a hierarchical structure.

The search is made on the names of objects. You can enter all or part of the text. The system highlights any object that contains the string you enter.

The settings you enter are valid only during the current work session. However, you can save the settings for future work sessions, using the Save Options feature.

The Search for objects feature is useful when you are working with large structures. The search includes all open view windows.

Procedure

1. Choose Object → Search for objects.

   The Search for Objects dialog box appears.

2. Enter text in the Search string field, and set the Case sensitive and Remove previous selection indicators, if required.

   For more information on the settings, see The Search for Objects Dialog Box [Page 408]

3. Choose Search.

   The system highlights objects that match your entry.

4. To search for other objects:

   – Enter text in the Search string field, and set the Case sensitive and Remove previous selection indicators, if required.

   – Choose Search.

   The system highlights objects that match your entry.

5. To exit the dialog box:

   – Select the Control Box.

   – A drop down menu appears.

   – Choose Close.
View Windows

You can work with multiple view windows in Structural Graphics. The following topics describe working with view windows.
Adding View Windows

Prerequisites
You can add view windows to view different sections of a structure. You can apply different attributes, such as color or shape assignments, to different view windows.
This feature is useful when you are working with a large structure.

You can change how multiple view windows are displayed, for example, side-by-side or stacked, using the Arrange views option. See Arrange Views [Page 414]

Procedure
Choose one of the following:
• Options → Further view
or
• Plus sign (+) in the top right corner of the display area.

Result
The systems adds a view window. Arranging Views
Deleting View Windows

**Prerequisites**
You can delete a view window in the Structural Graphics display. (You can add windows using the *Add View Windows* feature.)

**Procedure**
Choose *Options* → *Delete current view*.

**Result**
The system deletes the view window.
The Arrange Views Dialog Box

The Arrange Views dialog box lets you change how view windows are displayed. Changes that you make only apply for the current work session. Use Customizing to change default settings for views.

Left side of dialog box

Use the left side of the dialog box to change how windows are displayed, for example, side-by-side or stacked.

Right side of dialog box

Use the right side of the dialog box to change the order in which windows are displayed. View windows are displayed in the order in which you open them. However, you may want the information in the third window to appear first. To change the order of the view windows, select the arrows.

See also:

Arrange Views [Page 414]
Arranging Views

Prerequisites

Arrange views when you work with multiple windows in Structural Graphics, and you want to change how the system displays windows.

Procedure

1. Choose Options → Arrange views.
   The Arrange Views dialog box appears.
2. Arrange the view windows as required.
   For more information on the options, see The Arrange Views Dialog Box [Page 413]
3. Choose Arrange.
4. Exit the Arrange Views dialog box.
Miscellaneous Features

The following topics describe miscellaneous features in Structural Graphics:

- Changing Staff Modes in Structural Graphics [Page 361]
- Displaying Substructures [Page 358]
- Displaying Object Data in Structural Graphics [Page 359]
- Maintaining Infotypes in Structural Graphics [Page 360]
- Displaying Substructures [Page 358]
The Print Feature

The Print feature in Structural Graphics allows you to print the hierarchical structure you are viewing.

The Print Dialog Box [Page 417]
The Format Dialog Box [Page 419]
Printing Hierarchical Structures [Page 420]
Printing Tips and Troubleshooting [Page 421]
The Print Dialog Box

Use the Print dialog box to define where and how the system prints a hierarchical structure.

Settings you make here apply only to the current work session. However, you can save the settings for future work sessions, using the Save Options feature.

Print Quantity

Use this option to select a print mode. There are three print modes available.

- **Completely** - The system prints the entire structure. In overview mode, the structure fits on one page. In Detail Mode, the structure may be too large for one page. The structure is printed on more than one page. By combining the printouts, you obtain a complete picture of your structure.

- **View** - The system prints the hierarchical structure as displayed in the active view window. In detail mode, the substructure may not fit on one page.

- **Book** - The system prints each substructure of a hierarchical structure on a separate page. Substructures are the individual parent/child structures that collectively make up a larger hierarchical structure.

The system starts at the root object, and prints a substructure for each object. You can specify how many levels are to be included in your structure. Do this using the Display level setting in the View Options dialog box.

If you are in detail mode, substructures may be too large to fit on one page. In this case, the printer prints the structure on separate pages. By combining the printouts, you obtain a complete picture of your substructure.

If you select Book style, you can add page numbers and page references. See below.

Frame

- **Solid Frame** - The system prints a solid frame on each page.

- **No Frame** - The system prints without frames.

The corner frames are useful if you want to join pages together.

Output

Use this option to select an output device.

- **Local printer** - The system prints to a local PostScript printer (a printer connected directly to your PC). If you select this option, you must enter the printer port in the File field, for example, PRN or LPT1.

- **System (R/3 Spool)** - The system prints to a PostScript printer connected to the SAP R/3 system. If you select this option, you must enter the name of the printer in the File field.

The printer you select must be a PostScript printer and must be defined in the R/3 system to receive structural graphics.

Otherwise, the print request fails.

- **File** - You can copy the hierarchical structure to a file on your PC. If you select this option, you must enter a filename in the File field.
The Print Dialog Box

Export Filter
Use this option to define where the system sends the hierarchical structure. Select one of the two options.

PostScript - The system sends the structure to a Postscript printer.

CGM - The system sends the hierarchical structure to a Computer Graphics Metafile (CGM) file. CGM is a file format used for graphics. Files with this format can be read by PowerPoint® 4.0, CorelDRAW!® and other graphics programs.

Page numbers
Use this option to add page numbers to your printout. This option is only available when you select the Completely or Book print styles in Print Quantity.

Page References
This option adds page references to your printout. This option is only available when you select the Book print style in Print Quantity. The page references appear under the object that is the root object for the subordinate object in the substructure.

File
Use this field to specify a destination for your printout.

Format
Use this option to enter print format settings, for example, page orientation and size. See The Format Dialog Box [Page 419]

To change text font size or line styles for a printout, use View Options, Object Options and Line Options in the Print dialog box. When you access these dialog boxes through the Print dialog box, the settings you enter only apply to the print request. They do not affect the view windows.

See also:
Printing Hierarchical Structures [Page 420]
The Format Dialog Box

Use the Format dialog box to change the print format of hierarchical structures.

Format

Use this option to select the paper size. The value you select here determines the dimensions shown in the Print list box.

Orientation

Use this option to determine print orientation. You can choose landscape (horizontal) or portrait (vertical).

Unit

Use this option to select a unit of measurement for paper dimensions and margin sizes.

Printer

Use this option to determine the dimensions of the paper for your printout. Dimensions available depend on your selection in the Format list box. Dimensions are given in the unit of measurement you select in the Unit field.

Border

Use this option to specify the size of margins for the printout. Enter margin sizes in the unit of measurement you select in the Unit field.

See also:

Printing Hierarchical Structures [Page 420]
Printing Hierarchical Structures

Prerequisites
If you are working with multiple view windows, the system prints from the active view window.

Procedure
   The Print dialog box appears.
2. Enter data as required.
   The correct print parameters depend on the environment at your company. For more information on the settings, see The Print Dialog Box [Page 417]
3. Choose Print.
   The system sends the structure to the printer.
4. When printing is complete, the Print State dialog box appears.
5. Choose Continue.
Printing Tips and Troubleshooting

General Hints [Page 422]
Problems Importing CGM files into Graphics Programs [Page 423]
Problems Printing PostScript Data [Page 425]
General Hints

- You must have a properly installed PostScript printer.

Because the R/3 system runs on different platforms, the system does not route print requests through platform-dependent print utilities, such as, the Print Manager in Windows©. This means settings in platform-dependent utilities are not applied when you print from Structural Graphics.

- Ensure that all settings are the same for the transfer of data from computer to computer or from computer to printer. For example, when using File Transfer Protocol (FTP), ensure that the transfer mode is set to binary using the command `<bin>`. Computers can convert data to ASCII values differently. If the settings do not match, problems may occur, and you will not be able to read or print the data.

- Ensure that the page size corresponds to the page size for the printer you are using.
Problems Importing CGM files into Graphics Programs

You can import hierarchical structures from Structural Graphics into graphics programs, such as, CorelDRAW!, and Microsoft Draw. You must use the file format Computer Graphics Metafile (CGM).

Here are some of the problems which can occur:

**Problem:**
The CGM file is imported by the graphics program but text, objects, lines, and so on, are missing.

**Solution:**
It is possible that the colors are not set correctly or have been imported incorrectly. Try changing the background color. It is also possible that the object was not imported at all, or incorrectly imported by the import filter. Try using another graphics program. It is also possible, as a result of changes to settings (for example, font size), that the missing object is now outside the visible area and can no longer be displayed.

**Problem:**
You cannot select the objects in the imported graphic with the graphics program you are using.

**Solution:**
Some graphics programs, such as CorelDRAW!3.0, group imported graphics. To select one object, you must first ungroup the objects. So that you can select the subobjects individually, you must first cancel the grouping.

**Problem:**
The text is not aligned correctly.

**Solution:**
The graphics program does not align the text correctly. There have been no problems with left-justified texts. However, right-justified and centered texts are not always correctly aligned. This depends on the graphics program you are using.

**Problem:**
The font is not the same.

**Solution:**
In CGM format you cannot specify a font name. You can in PostScript. You select the font from an index. The best results come using Helvetica. As a result, this is the font used in CGM format. However, since you select from an index, some programs assign different fonts to file texts. To change the font, select the text and assign a new font.
Problems Importing CGM files into Graphics Programs

Problem:
The text size is not correct.

Solution:
It is possible that the importing graphics program is not scaling objects correctly. Select all objects concerned and change their size. You can also select the text objects concerned and change the font size. Not all graphics programs offer this feature.

Problem:
The system displays an error message.

Solution:
Either:
- The system cannot locate the print device.
  You entered a device name that does not exist.
- The system cannot find the path or file you entered.
  You entered an incorrect path or filename.

The system displays the name or path you entered in angled brackets <...>. Check that the entry is correct.
Problems Printing PostScript Data

Problem:
The printer prints text without graphics. The text appears as follows:

%!PS-ADOBE-1.0
%%Creator: SAP-Strukturgrafik
%%Title:
%%Pages:
%%DocumentFonts: Courier, Helvetica, Times-Roman
%%PrintMode:
%%EndComments

Solution:
In this case, your printer prints the PostScript data directly and as a result can not interpret it. Your printer must be a PostScript printer. Check that this is the case and that it is properly installed. See General Hints for details.

Problem:
No reaction from the printer.

Solution:
Check that the printer is properly installed and connected. See General Hints for details.

Problem:
There is a reaction from the printer at the start of output but no printout.

Solution:
The data may have been distorted during transfer and cannot be correctly interpreted. See General Hints for details.

Problem:
The system displays an error message. >".

Solution:
Either:
- The system cannot locate the print device.
  You entered a device name that does not exist.
- The system cannot find the path or file you entered.
You entered an incorrect path or filename.
The system displays the name or path you entered in angled brackets <...>. Check that the entry is correct.
Customizing and Structural Graphics

When you use an R/3 application component with Structural Graphics, there are additional features available to you, which you can set in Customizing.

See the Implementation Guide for the R/3 application component you are using.
Reports in Organizational Management

Use
The Organizational Management component offers numerous reports, with which you can access data on your most important questions concerning the organizational plan.

Features
When you access a report, a screen containing selection parameters appears. As well as report-specific parameters, additional selection fields are provided:

- **Object type** (depending on report: organizational unit, job, position, work center or task)
  
  You can specify the object with which you want to start the report.

- **Search Term**
  
  You can search for an object.

- **Status**
  
  You can specify that only objects with a certain status can be reported on.

- **Reporting Period / Reporting Key Date**
  
  Depending on the report, there are various criteria for determining a key date or a reporting period.

You can switch to the standard selection screen in many reports that you access via the SAP menu. This offers additional selection parameters.

Standard Selection Screen

- **Plan Version**
  
  You can specify the plan version for which you want to start a report.

- **Object Type**
  
  You can specify the object type for which you want to start a report.

- **Object ID**
  
  You can specify the object with which you want to start a report.

- **Object Status**
  
  You can specify that only objects with a certain status can be reported on.

- **Data Status**
  
  You can specify that only data with a certain status can be reported on.

- **Set Structure Conditions**
  
  You can set various structure conditions.

- **Evaluation Path**
  
  Via the evaluation path, you can specify the objects in a structure that are to be reported on.
• **Status Vector**
  
  You can specify that only objects whose relationship infotypes (assignments) have a certain status can be reported on.

• **Status Overlap**
  
  You can execute a simulation that displays the results as though all relationship infotypes were active.

• **Display Depth**
  
  You can specify the level of a structure to which the report is to be executed.
Existing Organizational Units (Report RHXEXI00)

Use
This report provides an overview of all existing organizational units.

Integration
This report is also accessed by other reports and transactions.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all organizational units, with information on
- validity period
- status
- name
- object ID
Staff Functions for Organizational Units (Report RHXSTAB0)

Use
This report displays all organizational units and their staff functions.

Prerequisites
So that you can report on organizational units with staff functions, you must have flagged them with the staff indicator.

- Select the Staff field for the organizational unit in the Organization and Staffing view. For more information, see Basic Data (Organizational Unit) [Ext.].
- Create a record for infotype 1003 for the organizational unit in Expert Mode. For more information, see Department/Staff (Infotype 1003) [Page 42].

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all organizational units and their staff functions, with information on

- status
- validity

Activities
Once the report is started, the number of objects found is displayed. To display individual objects, choose Organizational Unit by double-clicking on it.
Organizational Structure with Persons (Report RHXSTR02)

Use
This report displays the persons who belong to each organizational unit.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
A structure tree appears, which displays the organizational structure and the persons who belong to it. The hierarchy levels are shown by corresponding indentations in the tree structure.
Organizational Structure with Work Centers (Report RHXSTR02)

Use
This report displays the work centers which belong to each organizational unit.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
A structure tree appears, which displays the organizational structure and the work centers which belong to it. The hierarchy levels are shown by corresponding indentations in the tree structure.
Existing Jobs (Report RHXEXI02)

Use
This report provides an overview of all existing jobs.

Integration
This report is also accessed by other reports and transactions.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all jobs, with information on

- validity period
- status
- name
- object ID
Job Index (Report RHSTEL00)

Use
This report enables you to display all existing jobs.

Features
Selection
In addition to the general selection parameters [Page 428], the following selection parameters are available:
- Directly assigned persons
  You can specify whether you want to display the persons directly assigned to the jobs.

Output
The list contains all jobs, with information on
- the positions assigned to them
- the holders of the positions assigned
- staffing percentage of the assigned positions
Job Description (Report RHXDESC0)

Use
This report lists all jobs and their job descriptions.

Integration
This is a preliminary report for general report Object description (RHDESC20).
The complete job description [Page 437] report provides a complete job description.

Prerequisites
So that you can report on job descriptions, you must have created descriptions for jobs.
- You can create a description in the Organization and Staffing view. For more information, see Basic Data (Job) [Ext.].
- Create a record for infotype 1002 for the job in Expert Mode. For more information, see Description (Infotype 1002) [Page 41].

Features
Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all jobs, with information on
- name
- validity
- description

Activities
Use the buttons ◀ and ▶ to navigate through the list.
Complete Job Description (Report RHXSCR0)

Use
This report lists all jobs along with specifications on their description, requirements profile, task profile and resources and authorities.

Prerequisites
So that you can report on descriptions, you must have created descriptions for jobs.
- You can create a description in the Organization and Staffing view. For more information, see Basic Data (Job) [Ext].
- Create a record for infotype 1002 for the job in Expert Mode. For more information, see Authorities/Resources (Infotype 1010) [Page 52].

To report on authorities and resources, you must have maintained a record for infotype infotype 1010. For more information, see Description (Infotype 1002) [Page 41].

You can only report on the requirements profile for jobs if the Personnel Development component is installed.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all jobs, with information on
- name
- description
- authorities and resources
- requirements profile
- task profile

Activities
Use the buttons ⬇️ and ⬆️ to navigate through the list.
Periods for Unoccupied Positions (Report RHFILLPOS)

Use
This report displays the periods in which assigned positions are unoccupied per organizational unit.

Features
Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Use the evaluation path SBESX if you want to report on all the positions in an organizational structure. The system starts the report for the organizational unit you enter and reports accordingly on all the organizational units below it.

If you are, however, using the evaluation path SBES, only the positions belonging to the organizational unit you have entered are reported on.

Output
The list contains all relevant positions by organizational unit, with information on

- the period for which the position is unoccupied
- new holder
- number of unoccupied days
- average of unoccupied days per organizational unit
Existing Positions (Report RHXEXI03)

Use
This report provides an overview of all existing positions.

Integration
This report is also accessed by other reports and transactions.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all positions, with information on
- validity period
- status
- name
- object ID
Staff Assignments (Report RHSBES00)

Use
This report enables you to display the staff assignments (positions and persons) for one or more organizational units.

Features

Selection
In addition to the general selection parameters [Page 428], the following selection criteria are available:

- **Organizational unit**
  You enter the organizational unit for which you want to start the report.

- **Status**
  You can specify whether active, planned, submitted, approved or rejected objects are to be displayed.

- **Report on Organizational Structure**
  You can specify whether only the selected organizational unit is to be reported on, or whether all the organizational units assigned to it are to be taken into account as well.

- **Basis for Working Time**
  You can display working times in hours per day, per week, per month or per year.

- **Display Holders Only**
  You can either display the position holders or the holders and their substitutes.

- **Persons without Positions**
  You can also display persons who are not assigned a position.

Output
The list contains all positions by organizational unit, with information on

- the persons assigned to the positions

- chief positions

- staffing status

- actual working times

- planned working times

- staffing percentages

- assignment to employee groups

- assignment to employee subgroups
Position Description (Report RHXDESC1)

Use
This report lists all positions and their position descriptions.

Integration
This is a preliminary report for general report Object description (RHDESC20).
The complete position description [Page 448] report provides a complete position description.

Prerequisites
So that you can report on position descriptions, you must have created descriptions for positions.
- You can create a description in the Organization and Staffing view. For more information, see Basic Data (Position) [Ext.].
- Create a record for infotype 1002 for the position in Expert Mode. For more information, see Description (Infotype 1002) [Page 41].

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all positions, with information on
- name
- validity
- description

Activities
Use the buttons ⬅ and ➤ to navigate through the list.
Staff Functions for Positions (Report RHXSTAB1)

Use
This report displays all positions and their staff functions.

Prerequisites
So that you can report on positions with staff functions, you must have flagged them with the staff indicator.

- Select the Staff field for the position in the Organization and Staffing view. For more information, see Basic Data (Position) [Ext.].
- Create a record for infotype 1003 for the position in Expert Mode. For more information, see Department/Staff (Infotype 1003) [Page 42].

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all positions and their staff functions, with information on

- status
- validity

Activities
Once the report is started, the number of objects found is displayed. To display individual objects, choose Position by double-clicking on it.
Authorities and Resources (Report RHXHFMT0)

Use
This report lists all positions or work centers with the resources and authorities entered for them.

Prerequisites
To report on authorities and resources, you must have maintained the subtypes of infotype 1010 for positions/work centers in Expert Mode. For more information, see Authorities/Resources (Infotype 1010) [Page 52].

Features
Selection
In addition to the general selection parameters [Page 428], the following selection parameters are available:

- Authorities/Resources
  You can choose between the two subtypes of infotype 1010, Authorities/Powers of Attorney and Technical Resources.

Output
The list contains all positions or work centers, with information on

- name
- status
- authorities and resources
**Planned Labor Costs (Report RHSOLO00/RHXSOLO00)**

**Use**
This report enables you to determine the planned labor costs per position or work center for one or more organizational units.

**Prerequisites**
The Planned Remuneration (1005) [Ext.] infotype is valid for the positions/work centers belonging to the organizational unit concerned or for the relevant jobs.

**Features**

**Selection**
In addition to the general selection parameters [Page 428], the following selection parameters are available:

- **Currency**
  You can select the currency in which you want the data to be displayed.

- **Conversion type It. TCURR**
  You can enter an exchange rate type.

- **Values**
  You can decide how the planned remuneration band widths are to be set up.

- **Periods**
  You can specify the unit of time that is to be used to calculate or display the amount in compensation administration.

**Output**
The list contains all positions or work centers per organizational unit, with information on

- amount
- currency
Vacant Positions (Report RHVOPOS0)

Use
This report enables you to display all positions that are flagged as vacant. A vacant position is a position that has no holder during a particular period and is flagged as vacant.

Prerequisites
So that you can report on vacant positions, you must have flagged them as vacant:

- Flag a position as Vacancy open in the Organization and Staffing view. For more information, see Position [Ext.].
- Create a record for infotype 1007 for the position in Expert Mode. For more information, see Vacancy (Infotype 1007) [Page 47].

Features
Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all vacant positions by organizational unit, with information on

- period of vacancy
- staffing status
Obsolete Positions (Report RHVOPOS1)

Use
This report enables you to display all positions that are flagged as obsolete. An obsolete position is a position that is removed at a particular time.

Prerequisites
So that you can report on obsolete positions, you must have flagged them as obsolete:

- Flag a position as obsolete in the Organization and Staffing view. For more information, see Position [Ext.].
- Create a record for infotype 1014 for the position in Expert Mode. For more information, see Obsolete (Infotype 1014) [Page 57].

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all obsolete positions by organizational unit, with information on

- the period in which the position is obsolete
- staffing status
Complete Position Description (Report RHXSCRPI)

Use
This report lists all positions and the numerous characteristics which describe them.

Prerequisites
So that you can report on these characteristics, the relevant infotypes must be maintained and the corresponding relationships available.

Features
Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all positions, with information on
- description
- staffing (holder of a position)
- superior and subordinate positions
- activity profile of the position
- requirements profile (only if the Personnel Development component is installed)
- describing job
- activity profile of the job
- requirements profile of the job (only if the Qualifications/Requirements component is installed)
- work center assigned to the position
- integration of the position in the organization

Using the object description function, you can display further information, such as Resources/Authorities etc.

Activities
Use the buttons ↓ and ↑ to navigate through the list.
You can edit infotypes by choosing Goto → Object description.
**Reporting Structure without Persons (Report RHSTR05)**

**Use**
This report lists the subordinate positions for each position selected.

**Integration**
Report RHDTRU04 enables you to display a [Reporting Structure with Persons](Page 451).

**Prerequisites**
To report on a reporting structure, you must have created a reporting structure. To do this, you must subordinate positions to one another:

- You can create a hierarchy in the Organization and Staffing view. For more information, see [Hierarchy (Position) [Ext.]
- You can create a reporting structure in Expert Mode. For more information, see [Reporting Structures](Page 315).

**Features**

**Selection**
For more information on the selection parameters, see [Reports in Organizational Management](Page 428).

**Output**
A structure tree appears, which displays the subordination and superordination of positions. The hierarchy levels are shown by corresponding indentations in the tree structure.
Reporting Structure with Persons (Report RHSTR04)

Use
This report lists the subordinate positions for each position selected. All position holders are also displayed.

Integration
Report RHDTRU05 enables you to display a Reporting Structure without Persons (Report) [Page 450].

Prerequisites
To report on a reporting structure, you must have created a reporting structure. To do this, you must subordinate positions to one another:

- You can create a hierarchy in the Organization and Staffing view. For more information, see Hierarchy (Position) [Ext.].
- You can create a reporting structure in Expert Mode. For more information, see Reporting Structures [Page 315].

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
A structure tree appears, which displays the subordination and superordination of positions as well as the assignment of persons to positions. The hierarchy levels are shown by corresponding indentations in the tree structure.
Existing Work Centers (Report RHXEXI05)

Use
This report provides an overview of all existing work centers.

Integration
This report is also accessed by other reports and transactions.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all work centers, with information on
- validity period
- status
- name
- object ID
Work Centers per Organizational Unit (Report RHXSTRU06)

Use
This report lists the work centers assigned to each organizational unit.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
A structure tree appears, which displays the assignment of work centers to organizational units. The hierarchy levels are shown by corresponding indentations in the tree structure.
Existing Tasks (Report RHXEXI04)

Use
This report provides an overview of all existing tasks.

Integration
This report is also accessed by other reports and transactions.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all tasks, with information on
- validity period
- status
- name
- object ID
Activity Profile of Positions (Report RHXSTR07)

Use

This report displays the positions belonging to an organizational unit, as well as the directly or indirectly (via job) assigned tasks and the assigned persons.

Features

Selection

For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output

A structure tree appears, which displays the assignment of tasks and persons to positions. The hierarchy levels are shown by corresponding indentations in the tree structure.
Activity Profile of Positions with Persons (Report RHXSTR08)

Use

This report displays the positions belonging to an organizational unit, as well as the directly or indirectly (via job) assigned tasks.

Features

Selection

For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output

A structure tree appears, which displays the assignment of tasks to positions. The hierarchy levels are shown by corresponding indentations in the tree structure.
Existing Objects (Report RHEXIST0)

Use
This report provides an overview of all existing objects.

Integration
This report is also accessed by other reports and transactions.

Features

Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
The list contains all objects, with information on
- validity period
- status
- name
- object ID
Structure Display/Maintenance (RHSTRU00)

Use
This report displays a section of the organizational plan according to the initial object and evaluation path entered.

Prerequisites
The evaluation path you enter must appear in table T778A.

Features
Selection
For more information on the selection parameters, see Reports in Organizational Management [Page 428].

Output
A structure tree appears, which displays the assignment of organizational objects to one another. The hierarchy levels are shown by corresponding indentations in the tree structure.
Reporting on an Infotype (Report RHINFAW0)

Use

This report enables you to report on any infotype. This can be executed structurally or sequentially (in other words, along a structure using an evaluation path according to table T77AW/T778A). The report can also be used for infotypes that you have created yourself.

Features

Selection

In addition to the general selection parameters [Page 428], the following selection parameters are available:

- **Infotype**
  
  You can specify the infotype that you wish to report on.

- **Subtype**

  You can specify the subtype that you wish to report on.

- **Reporting on an Infotype Field**

  You can specify the field entries of the infotype records that are to be displayed.

- **Selecting an Infotype Field**

  You can select the fields, whose entries you wish to display.

- **All Objects**

  You can specify that the objects for which there is no record for the infotype be displayed as well.

- **Objects without this Infotype**

  You can specify that only those objects for which there is no record for the infotype be displayed.
Starting an HR Report (Report RHPNPSUB)

Use
Using this program, you can start various reports for a number of personnel numbers. The reports will draw on information from the structures in the organizational plan.

Features
Selection
The following selection parameters are available in addition to the general selection parameters [Page 428]:

- **HR Reporting**
  Enter the name of the report you want to start.

- **Report Variants**
  You can select a report variant.

- **Enhanced HR Selection**
  You can use additional selection parameters.

- **Sort by Personnel Number**
  Sorting is possible.

Output
The output depends on the report you select.