The Test Workbench in the SAP System (BC-CAT-PLN)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390® and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>⚠</td>
<td>Caution</td>
</tr>
<tr>
<td>📜</td>
<td>Example</td>
</tr>
<tr>
<td>🔗</td>
<td>Note</td>
</tr>
<tr>
<td>🧑‍🔧</td>
<td>Recommendation</td>
</tr>
<tr>
<td>☑</td>
<td>Syntax</td>
</tr>
<tr>
<td>💡</td>
<td>Tip</td>
</tr>
</tbody>
</table>
Contents

The Test Workbench in the SAP System (BC-CAT-PLN) ......................................................... 6

CATT: Create Test Case ................................................................................................................ 7

Test Case Types ............................................................................................................................... 8
  Use of Automatic Test Cases ........................................................................................................ 9
  Use of Manual Test Cases ............................................................................................................. 10
  Maintain Hypertext Links in Long Text ...................................................................................... 11
  Use of Referring Test Cases ......................................................................................................... 12
  Using CATT for R/2 test cases ..................................................................................................... 13
  R/2: Create Simple Test Case ...................................................................................................... 15
  R/2: Create Transaction-Independent Test Case ........................................................................ 16
  Using External Applications .......................................................................................................... 17
  Use External Applications ............................................................................................................ 18
  Run External Application ............................................................................................................ 20
  Using an External Test Tool ......................................................................................................... 21
  Setup external test tool interface .............................................................................................. 22
  Call External Test Tool From CATT ......................................................................................... 23
  Edit External Test Tool Test Script .......................................................................................... 24
  Parameter interface between CATT and external test tool ..................................................... 25
  Using function module tests .......................................................................................................... 26
  Create Function Module Test ..................................................................................................... 27
  Parameterize Function Module Test .......................................................................................... 28
  Edit Compare Parameters ........................................................................................................... 29

The Test Organizer .......................................................................................................................... 30

The Test Catalog ............................................................................................................................... 32
  Create Test Catalog .................................................................................................................... 33
  Create Test Catalog Automatically ............................................................................................ 34
  Edit Test Catalog Structure ........................................................................................................ 35
  Edit Test Catalog Attributes ....................................................................................................... 37
  Put Test Catalog in the Application Hierarchy ........................................................................... 38
  Transport Test Catalog or Test Plan ............................................................................................ 39
  Migrate .......................................................................................................................................... 40
  Check Test Catalog or Plan Structure ....................................................................................... 41

Test Plan .......................................................................................................................................... 42
  Create Test Plan .......................................................................................................................... 43
  Edit Test Plan Structure ............................................................................................................. 44
  Regenerate Test Plan .................................................................................................................. 46
  Edit Test Plan Attributes ............................................................................................................ 47
  Transport Test Catalog or Test Plan ........................................................................................... 48
  Display Test Plan Hierarchy ......................................................................................................... 49
  Check Test Catalog or Plan Structure ....................................................................................... 50

Test Package .................................................................................................................................... 51
  Create Test Package .................................................................................................................... 52
  Edit Test Package Structure ......................................................................................................... 53
  Edit Test Package Attributes ....................................................................................................... 54
  Define Tester Worklist ................................................................................................................. 55
The Test Workbench in the SAP System (BC-CAT-PLN)

Use

Intensive test phases, with function and acceptance tests in all phases, are essential to the success of an R/3 project. This starts with the first implementation of an SAP System and continues through all modifications of the system to customer requirements by customizing, modification and customer developments. SAP provides the Test Workbench to support customers in this area.

From the test planning stage onwards, the Test Organizer in the Test Workbench provides a tool to create a structure of the applications to be tested.

Individual test cases can be created when planning is complete. Use the Computer Aided Test Tool [Ext. (CATT) in the Test Workbench. Test cases can be descriptions for manual tests, or test case scripts which are to be performed automatically.

The test cases created can be put in the outline structure created during planning, in the Test Organizer. This provides a constant overview of the progress of test case creation.

The test organizer can plan the function test in a two-step procedure (test plan, test package), after the test creation phase.

The tester performs the tests in the test package assigned to him or her, in the Test Workbench tester transaction, and assigns a test case status to each test case in it.

The test organizer can check test progress at any time during the tests with status reports.

Implementation notes

The storage of test catalogs, test plans and test packages has changed for Release 4.5A. Test catalogs from previous Releases can be migrated [Page 40] by a program into the new store.

You should make important test case status and mail system settings with a customizing transaction [Page 66] before you use the Test Workbench.
CATT: Create Test Case

Definition

You can create test cases with the Computer Aided Test Tool (CATT) in the Test Workbench. You can use various test case types [Page 8], depending on the purpose of the test.

Use

You define test cases with CATT. A distinction is made between test cases for acceptance tests and for functional tests.

Acceptance test cases are always performed manually by testers. They are subjective tests of the usability of business processes, so they are test descriptions that the tester must perform.

Functional test cases ensure that transaction functions contain no errors. They can run automatically without user dialog and need not be performed by testers. Test cases are usually created by recording the transactions to be tested.

Integration

Go from the Test Organizer to the test case attribute definition, by choosing in the test catalog, plan or package display. You can then go to the test case description (choose Long text) or functions ( ).
Test Case Types

Use

The Test Workbench has the following test case types:

<table>
<thead>
<tr>
<th>Type</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>CATT [Page 9]</td>
<td>Automatic R/3 transaction test</td>
</tr>
<tr>
<td>Function module test [Page 26]</td>
<td>Automatic function module test case</td>
</tr>
<tr>
<td>Remote R/2 test [Page 13]</td>
<td>Remote R/2 transaction test</td>
</tr>
<tr>
<td>External application [Page 17]</td>
<td>To load files locally on to the presentation system, where they can be edited by external programs. Test cases of this type can save test data in the format of external manufacturers' test tools [Page 21].</td>
</tr>
<tr>
<td>Referring [Page 12]</td>
<td>Test case to refer to test cases in other R/3 Systems. The test case can only be called from the Test Organizer.</td>
</tr>
</tbody>
</table>

The test case type is specified in the test case attribute screen [Ext.].

Integration

All types can be created, maintained and managed in the Test Organizer [Page 30].
Use of Automatic Test Cases

Use

Type CATT test cases are used to test R/3 transactions automatically. The transactions usually run without user interaction. Tests are logged.

Type CATT test cases have two maintenance modes:

- **CATT [Ext.]** Create test cases.
- **Extended CATT [Ext.]:** Create test cases with complex check logic: all CATT functions [Ext.] are available.

Procedure

1. Create test cases. Use the recording functionality. You can create transaction chains that correspond with your business processes.
2. Define test rules in the test cases.
3. Create test case variants.
4. Manage the test cases in the Test Organizer.
5. Run the test cases and analyze the logs. You may have to retest test cases in which errors occurred.
Use of Manual Test Cases

Use

Type *Manual test case* test cases contain the instructions for manual tests. Test instructions are written as SAPscript long texts for the test case.

*Manual* test cases cannot use the automatic CATT functions.

Procedure

1. Create a *Manual test case*.
2. Write a long text for this test case and save it.
3. Manage the test case in the Test Organizer.
Maintain Hypertext Links in Long Text

You can set hypertext links to Repository objects in the test case long text maintenance editor, as follows:

**Procedure**

1. Go to the test case long text maintenance.
2. Choose *Include → Link*.
3. Choose the object type to which a link is to be set in the *Selected Link* field in the *Set Link* dialog box.
4. Enter the data required for the object type.
5. Enter the link text.
6. Choose ENTER.

   The link is inserted in the text.

   The following text is inserted after the link has been created:

   - Data element document
     
     `<DS:DE.name>Name_in_text</>`
   - Release note
     
     `<DS:RELNname>Name_in_text</>`
     
     e.g. `<DS:RELNBC_DOC TOOLS>Doc. info</`
   - Book structure chapter
     
     `<DS:CHAP.name>Name_in_text</>`
   - Online-executable report
     
     `<DS:REPO.name>Name_in_text</>`
   - Transaction executed online in foreground
     
     `<DS:TRAN.name>Name_in_text</>`
   - Online CATT procedure
     
     `<DS:CATT.name>Name_in_text</>`
   - Glossary entry
     
     `<GL:name>Name_in_text</>`
Use of Referring Test Cases

Use

A Referring type test case refers to an existing automatic test case in another R/3 System. This type is useful when you use a central test management system which manages test catalogs of test cases and tests various R/3 Systems (with different Releases).

Create a test case containing a test routine in each system. It must have the same name in all systems.

Create a test case of type referring, which calls the test case in the target system, in the central test system.

The target system is specified in the Test Organizer when the test plan is created. You can create a test plan for each R/3 System to be tested and specify the correct R/3 System in each test plan.

Test cases of this type can only be called by the Test Organizer.

Procedure

1. Create an automatic test case in the target system.
2. Create a new test case in the central test system.
3. Assign type Referring to the test case in the attribute maintenance Management data tab.
4. Assign the referred test case in the target system to the test case in the attribute maintenance General data tab.
5. Save the test case.
6. Put the test case in a test catalog in the Test Organizer.
7. Specify the target system when you create the test plan.
Using CATT for R/2 test cases

Use

Remote R/2 test type test cases are used to test R/2 transactions automatically. The transactions run without user interaction. You can check system messages can and test database changes. All tests are logged.

Remote R/2 test cases have all CATT functions [Ext.]. They are maintained in CATT extended mode [Ext.].

The following restrictions apply:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FUN</td>
<td>The function module runs in R/3 but it can call function modules remotely in R/2</td>
</tr>
<tr>
<td>CHETAB SETVAR &lt;tab&gt;</td>
<td>All tables that are not in ATAB must have a data read function module in the R/2 table TC40B.</td>
</tr>
<tr>
<td>SET cursor</td>
<td>Has no effect</td>
</tr>
<tr>
<td>SET/GET parameters</td>
<td>Not available</td>
</tr>
</tbody>
</table>

Prerequisites

The R/2 test system must be Release 5.0G or later and the following SAP Basis components must be installed:

- BS2000:
  - Remote Function Call
  - Host communication with TCP/IP
  - 153 SAP host link
- MVS and VSE systems:
  - Remote Function Call
  - Host communication with other LU 6.2 systems
  - 153 SAP host link

There must be an RFC connection between the R/3 system and the R/2 test system. The R/2 user must be type ‘CPIC’ and must have the necessary authorizations.

Procedure

1. Create simple Remote R/2 test cases (test modules) to test individual transactions.
2. Assemble these simple test cases into procedures. Create Remote R/2 test cases that use the test modules in a meaningful sequence. You can create transaction sequences that correspond with your business processes.
3. Save the test case.
4. Create test case variants.
Using CATT for R/2 test cases

5. Manage the test case in the Test Organizer.
6. Run the test case and analyze the log.
R/2: Create Simple Test Case

Prerequisites

You must have an RFC link to the target system before creating a Remote R/2 test case.

Procedure

1. Record a BDC session of the transactions to be tested in the R/2 test system with the transaction SIRC.
2. Check that the BDC session is batch-input-compatible with the transaction SBDC. You can use the following utility programs:

<table>
<thead>
<tr>
<th>Utility Program</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSCATB00</td>
<td>Display screen definition</td>
</tr>
<tr>
<td>RSCATB10</td>
<td>CALL TRANSACTION with spooler data</td>
</tr>
<tr>
<td>RSCATB30</td>
<td>Display BDC session in R/3 format.</td>
</tr>
</tbody>
</table>
3. Call the CATT maintenance transaction in the R/3 System and create a new test case.
4. Enter the type Remote R/2 test in the test case attribute screen. You are prompted for the R/2 remote system if you have not yet specified it. Specify the System.
5. Go to the function editor. Choose Edit → Enter TCD.
6. Enter the file and session names in the Read R/2 BDC session dialog box. Choose Continue. A new TCD entry is made in the function editor.
7. Parameterize [Ext.] the R/2 transaction input fields.
8. Save the test case.

Message check via SAPMSCEM 0001 also in R/2

The message check via screen SAPMSCEM 0001 is now also recommended for the R/2 System, particularly if the expected message numbers are between 001 and 010 because these numbers are also used for system errors with the message ID (work area) TT. In such cases a transaction with errors could pass as ‘OK’ if only the numbers and not the message ID are checked, so you should append the message screen SAPMSCEM 0001 to the screen list. Define the check for message number and work area in this message screen. This replaces Check Error which only checks the message number with a combined message number and work area check.

See Extended system message checks [Ext.].
R/2: Create Transaction-Independent Test Case

Prerequisites
You must have an RFC link to the target system before creating a Remote R/2 test case.

Procedure
1. Call the CATT maintenance transaction in the R/3 System and create a new test case.
2. Enter the type Remote R/2 test in the test case attribute screen. You are prompted for the R/2 remote system if you have not yet specified it. Specify the System.
3. Go to the function editor.
4. Refer to the simple test cases from which you want to assemble the transaction-independent test case, with the REF function.
5. Insert other CATT functions in the test case (e.g. table check).
6. Save the test case.
7. Manage the test case in the Test Organizer.
8. Run the test case and analyze the log.
Using External Applications

Use
You can put external applications in test cases that are used in other test cases. You can, for example run external test tools or display manual test documentation, which was not created in the SAP system, in external programs.

Prerequisites
Frontend:
- Windows NT, Windows95; Windows 3.x or OS/2
- Installation of the application program
- Association of filename extension with the application program

Procedure
1. Create a new External application type test case.
2. Put the files in the file list.
3. Pass import parameters to the external applications and read the export parameters back from it.
4. Use the test case in other test cases.
Use External Applications

1. Go to the CATT maintenance transaction initial screen and create a new test case.
2. Maintain the attributes. Specify type External application. This flags the test case as an external application.
3. Go to the file list via Goto → Functions. All files for the module are listed in the CATT - External application file list window.

You cannot define functions for external applications.
4. Process the file list using the functions below.
5. Mark the object which is to be executed when the test case runs locally on your computer. Unmarked files are downloaded before running the external application and are thus also available.
6. Save the test case.

If you want to use a data file as initial file, you must ensure that the initial filename extension is associated with the application program on your computer.

File list functions:

Delete line:
Delete marked test module objects.

Insert URL:
To call URL addresses, choose Insert URL. Enter the URL address in the input line. When this line is chosen, a web browser is called and goes to this address.

Import file:
Import local files into the test module.

Export file:
Store files from the test module locally on the presentation system.

Refresh file:
You can refresh an existing file by uploading an up-to-date version from your presentation system and overwriting the old version.
**Parameter interface between test module and external application:**

Parameters can be defined to allow test cases to communicate with an external application. Import parameters are downloaded in a text file and can be read by the external application. The text file is downloaded first, before the external application files.

The external application can put export parameters in this text file, which is uploaded by the test case after the external application has run. The parameters can be processed further in the test case. The CATT export parameter names are downloaded with the import parameters.

**Name of the parameter passing text file**

The default name for the parameter passing text file is `CATSTART.TXT`. If you want a different file name, define an import parameter with the name &PARAMFILE in the type `External application` test module. Assign the desired file name to this parameter.

**Text file structure**

Each parameter has a text record with three fields:

1: Parameter type 1-character, "I" = Import-, “E” = Export

2: Parameter name max. 12-character, without leading “&”

3: Parameter value max. 132-char.

The first two fields are separated by a space. The 2nd field is output as 12 characters. If the parameter name is shorter, the field is filled with spaces. The last two fields are separated by " = " (space, equals sign, space).

```
I IMPORT1    = Test
E EXPORT     = Test end
E EXPORT1    = Test successful
```

Export parameters can be returned without spaces.

A parameter text line cannot exceed 148 characters.
Run External Application

If a type C test case calls an *External application* type test case, it always runs in the foreground. When running the test case, a dialog box appears that tells you how to proceed.

If there is a long text containing test instructions for the external application test case, choose *Long text* in the dialog box to display it.

After performing all external test case steps, choose *Continue* in the R/3 system dialog box. The test case runs as described in *Run test case [Ext.]*.
Using an External Test Tool

Use
Test cases in the format of the test tools of external manufacturers (e.g. Mercury Interactive), can be used in CATT via a standardized CATT interface. The test cases must be of type External application, and the external test tool must be installed on the frontend where the SAPGUI runs. The interface between CATT and the external test tool is based on Control Enabling Technology. You can call the external test tool and create, edit and execute a test case from CATT. You can use all CATT functions to manage and analyze the test case.

The CATT interface is a functionality enhancement to use external test tools in CATT test cases. Common Internet Browsers are also supported, so SAP Internet application components can also be tested.

Prerequisites
To test SAP Internet application components, the external test tool must have a special SAP enhancement. See the manufacturer documentation for whether this enhancement is possible.
Setup external test tool interface

Prerequisites

The external test tool installation on your frontend must support the CATT interface. See the manufacturer specification.

Procedure

Customizing:

1. Go to customizing (Tools → Business Engineer → Customizing).
2. Go to the application component hierarchy (Implementation projects → SAP reference IMG).
3. Select the chapter
   Application-independent components
   CATT tool
   Use external test tool
4. Run this customizing transaction.
5. Enter your interface parameters as described in the IMG chapter documentation. You can, for example specify the external test tool name with which you subsequently call the test tool in the CATT maintenance screen.

When you have configured the interface in CATT, you can use all the external test tool functions from CATT.
Call External Test Tool From CATT

Procedure

1. Go to the CATT maintenance transaction initial screen and create a new test case.
2. Maintain the attributes and specify type External application. This flags the test case as an external application.
3. Go to the file list. Next to the file inclusion function pushbuttons (see Using external applications [Page 17]), there is a pushbutton labeled external test tool, or with the name of which you specified in Customizing [Page 22].
4. Call the external test tool by pressing this pushbutton. If the interface was defined correctly, the external test tool runs on your presentation computer.
5. Record a test case with the external test tool and save it with a test tool function (see manufacturer documentation).
6. After saving, the external test object appears in the CATT test case file list. In the same line next to the test object name is a two-character manufacturer code which was defined in customizing to identify the external test tool format.

Communication with CATT is only possible if the external test tool was called from the CATT file list (from the CATT maintenance transaction with Go to → Functions). The communication is canceled when you leave the CATT maintenance screen or call a CATT function. To reestablish communication, you must call the test tool from CATT again.
Edit External Test Tool Test Script

The CATT interface can save a test case as a test object in an *External application* type CATT test module. Only one external test tool test case can be saved per CATT test case.

After the test object has been created and saved in the external test tool, the test script appears in the CATT maintenance screen file list.

See the documentation of the external test tool for the use of the save function in the CATT interface.

When the test object appears in the file list, save the CATT test case. This interrupts the communication to the external test tool.

The test script of an external test case cannot be deleted with the file list functions. To delete a test script, you must delete the CATT test case.

To edit the test script, call the external test tool with the right-hand pushbutton above the file list, and edit it locally in the external test tool. The updated test script is imported into the CATT test case again after editing.
Parameter interface between CATT and external test tool

CATT has import and export parameters for passing data between test modules and external applications (see also Use external applications [Page 18]) which the external test tool can use. They are passed to the CATT interface with the test case when the external test tool is called. The test tool provides import and export parameter read and set functions.

The parameters have the following format:

- The parameter type is either import or export.
- The parameter name is maximum 12-character and case-insensitive.
- The parameter value is maximum 132-character and case-sensitive.

You can also redefine import and export parameters which were added to the existing CATT test case parameters after saving the CATT test case, from the external test tool.

Communication with CATT is only possible if the external test tool was called from the CATT file list (from the CATT maintenance transaction with Go to Functions). The communication is canceled when you leave the CATT maintenance screen or call a CATT function. To reestablish communication, you must call the test tool from CATT again.
Using function module tests

Use

You can create and run function module tests with type *Function module test*. Function module dialogs can also be tested.

When you create a function module test, a parameter set is created for the function module parameters, structures and tables to be passed. The function module then runs. If it contains dialogs, they are recorded. At the end of the function module, its result is added to the parameter set as a compare parameter. You can then choose parameters, structures and tables from among the compare parameters, whose contents should match the recorded values in future tests.

Procedure

1. Create a function module test [Page 27].
2. Parameterize the function module test case [Page 28], if it contains dialogs.
3. Edit the list of compare parameters [Page 29].
4. Save the test case.
5. Use the test case to test function modules automatically.
Create Function Module Test

Procedure

1. Create a Function module test type test case:
   Create a new Function module test type test case in the Test Organizer and choose Record.
   Choose Record function module in the CATT maintenance transaction initial screen.
2. Enter the function module name in the dialog box and choose Copy.
3. Pass test values to the function module import, changing and table interfaces.
4. Run the function module.
5. Perform any function module dialogs.
6. You get the result at the end of the function module. You can now choose which comparisons are to be carried out for subsequent function module tests by selecting entries. The current result is your reference.
Parameterize Function Module Test

Prerequisites
You can only parameterize dialog function modules. You can only parameterize the dialog entries.

Procedure
1. Go to the Function module test type test case functions.
2. Position the cursor on the function module to be tested and choose Choose. You go to the dialog screen overview.
3. Position the cursor on a screen and choose Choose. The simulated screen appears.
4. Maintain the parameters, as described in Maintain screen [Ext.].
5. Save the changes.
**Edit Compare Parameters**

At the end of a function module test, the tested function module returns a result to its interface (Export, Changing, Tables). You can compare this result with a set of compare parameters. If the result of the function module test is different from the compare parameters, the test is flagged as failed.

You can exclude specified compare parameters from the result comparison.

**Procedure**

1. Go to the *Function module test* type test case functions.
2. Choose *Compare parameters*.
   A list of the compare parameters, which was created when the function module test was recorded, appears.
3. Mark the result parameters (Export, Changing, Tables) which are to be compared with the current result, after the function module test. Position on the parameter names and choose *Select/Deselect*.
4. Save the changes.

   ![NextArrow]

You can only compare complete structures or internal tables. You cannot choose individual structure or internal table fields.
The Test Organizer

Definition

The Test Organizer:

- creates test catalogs, test plans and test packages
- analyses the status of tests

Structure

The Test Organizer components are:

A test catalog [Page 32] is a set of test cases in a Hypertext structure. This structure can contain links to additional documents. To be able to use the test catalog to generate test plans, you must put it in the SAP Application hierarchy. The test catalog is assigned in the SAP environment. You can create test plans across several test catalogs via the SAP application hierarchy. This procedure allows you to create a lot of small test catalogs, which are easier to maintain than one large test catalog.

A test plan [Page 42] is a set of tests which must be performed within a specified period for a specified purpose. The test cases can be in several test catalogs.

A test package [Page 51] is a person and period-oriented view of a test plan. It contains all tests which a tester is to perform during a specified period.

A test case [Ext.] describes the object to be tested. Test case attributes determine the test case types. Test cases are created and performed in the CATT: Computer Aided Test Tool [Ext.].
A test case is given a test case status with reference to the structure nodes of a test package, as the result of a test. The test is analyzed by a status report which can create various views (e.g. of particular test packages).
The Test Catalog

Definition

A **test catalog** is a set of test cases in a hypertext structure, which can also contain references to related documents.

Use

You manage all **test cases** created with CATT, in test catalogs. Test cases are classified as manual or automatic. Manual test cases are used mainly for acceptance tests, and automatic test cases mainly for function tests.

To be able to use the test catalog to generate test plans, you must put it in the SAP Application hierarchy. This puts the test catalog in the SAP environment in which you can create test plans, which may be in several test catalogs. This procedure allows you to create a lot of small test catalogs, which are easier to maintain than one large test catalog.

Structure

A test catalog comprises the test catalog structure and the test catalog attributes.

Test cases are arranged hierarchically in the test catalog structure. This specifies, e.g. the sequence in which the tests are to be performed.

The test catalog attributes are for test catalog management.
Create Test Catalog

Procedure

1. Go to the test catalog maintenance initial screen via Test Workbench → Test Organizer → Manage test catalog.

2. Choose ▶.

3. Enter a test catalog title in the attribute screen. Enter the name of the person responsible.

4. You can assign the test catalog to an application component by entering the application ID in the Component field.
   This puts the test catalog in the Application hierarchy [Page 38].

5. Save the test catalog attributes.

6. Enter the development class in the following dialog box.

7. If you have chosen a transportable development class, you are prompted to specify a transport request.
   
   ![Transport Request]
   
   This development class and transport request are also used for all other objects which are created in this transaction.

8. Go to test catalog structure maintenance with ▶.


10. You return to the test catalog maintenance initial screen. The new test catalog is in your favorites list.
Create Test Catalog Automatically

Use
This function creates test catalogs efficiently.

Prerequisites
You are in the Manage test catalogs (transaction STWB_1) initial screen.

Procedure
1. Choose Utilities → Create test catalog automatically. You go to the Create test catalogs screen.
2. Assign a title.
3. Assign the test catalog to a component.
   The F4 help for the input field gives you a hierarchical display of the components. Go to a component and choose it by double-click.
4. Enter the test cases to be put in the test catalog.
   The F4 help is the possible test case search criteria. You can search with wildcard characters [Ext.]. Confirm your selection with ✔.
5. If you want to insert test cases by selection, the test cases found are listed. Select test cases. Confirm your selection with ✔.
6. To create the test catalog, choose ✔.
7. Choose a development class and save your test catalog.

Result
A test catalog containing all the selected test cases is created.
Edit Test Catalog Structure

Procedure

1. Go to the test catalog maintenance initial screen with Test Workbench → Test Organizer → Manage test catalog.

2. Choose a test catalog using the F4 help or from your favorites list.

3. Choose or .

   You go to the test catalog structure maintenance or display respectively.

4. Expand the test catalog.

5. If you are editing a large test catalog structure, you can focus on the branch of the structure to be edited. Position the cursor on a branch and choose .

6. Create new nodes with Create as subnode and Create at same level.

7. Delete nodes with .

8. Change nodes with .

9. To move nodes:
   - Position the cursor on the node
   - Choose .
   - Select any more nodes.
   - Position the cursor on the node after which the new node is to be inserted.
   - Choose .
   - Specify whether the node is to be a subnode or at the same hierarchy level, in the following dialog box. Choose .

10. To copy nodes into the buffer:
    - Position the cursor on the node
    - Choose .
    - Select any more nodes.
    - Choose .

11. When you have copied nodes into the buffer, as described in item 10, you can reinsert them at the current cursor position with .

   You can move or copy several nodes at the same time by selecting several nodes with .

   You can also copy nodes between test catalogs by inserting the contents of the buffer in other test catalogs.
12. Save the changes.

**Insert nodes at the same or a lower level**

1. Put the cursor on the object at which you want to create another node at the same or a lower level.
2. Choose *As subnode* or *At the same level*.
3. Choose the node type.
   - *Structure text*: Enter a text. To create several structure nodes, use the *Other nodes* function.
   - *Test case*: Enter the name of the test case which you want to put in the structure. You can also create a new test case here by entering a test case name and choosing the test case type on the test case *Attribute screen [Ext.]*.
   - *Test catalog*: Choose the test catalog to be included, from the *F4* help.
   - *Documentation*: Enter a short text which is to appear in the test catalog structure, in the *Short text* field. Choose a document class with *F4*. Select the document from the *Document* field *F4* help.

4. Leave the dialog box with *Continue*.

The new node is created.

Various icons, whose meanings are explained under *Goto → Legend*, appear in front of the new node, depending on the object used.
Edit Test Catalog Attributes

Procedure

1. Go to the test catalog maintenance initial screen with Test Workbench → Test Organizer → Manage test catalog.

2. Choose a test catalog from the F4-help or your favorites list.

3. Choose .
   You go to the test catalog attribute display.

4. To change attributes, go to maintenance mode with .

5. Change the title and person responsible for the test catalog.

6. Assign the test catalog to a component in the application hierarchy in the Component field, or as described in Include test catalog in the Application Hierarchy [Page 38].

7. Save the changes.
Put Test Catalog in the Application Hierarchy

**Procedure**

1. Go to the test catalog maintenance initial screen via Test Workbench → Test Organization → Manage test catalog.

2. Choose ▶️. You see the application hierarchy, extended by the test catalogs which have so far been included.

3. Go to the Application hierarchy node at which you want to insert your test catalog.

4. Use 🔧 to display only the relevant part of the application hierarchy.

5. Position the cursor on the relevant application hierarchy node and choose Assign test catalog.

6. Specify whether the test catalog is to be created (Create) or already exists (Search).

7. A new test catalog is created, or an existing one found respectively.

8. When you return to the application hierarchy display, the new test catalog is included.

9. Save the changes.

You can also assign to an application component in the Test catalog attribute maintenance [Page 37].

**Other Application Hierarchy Display Functions:**

You can delete test catalogs from the application hierarchy with Delete test catalog assignment.

You can move a test catalog to the current cursor position when you have selected it, with Move test catalog.
Transport Test Catalog or Test Plan

Prerequisites
The test catalog or test plan and its contents must be in a transportable development class.

Procedure
1. Go to the test catalog or test plan maintenance initial screen and choose the test catalog to be transported.
2. Choose ✓
   You get a list of the objects in the test catalog in the chosen test cases.
3. Select objects. You can select all objects at once with ✓.
   Objects in not-transportable development classes can be put in transportable development classes and transported.
4. Choose ✓
5. Choose the request in which the selected objects are to be put, from the list of your transport requests, which is displayed, and Continue.
   All objects are put in the specified transport request.
Migrate "Old" Test Catalogs

Prerequisites
You can convert test catalogs, which you created and used with the Test Organizer before Release 4.5A, with the report RSTWB_MIGRATE. You can then use these test catalogs in the new Test Organizer.

⚠️
No test plans, packages, status or notes are migrated. You cannot migrate a current test into the new Test Organizer. Finish the test with the previous transactions (STW1: Manage test catalog, STW2: Manage test plan, STW3: Manage test package, STW4: Test and STW5: Assign tester) and only then migrate your test catalog into the new Test Organizer for future tests.

Procedure
1. To migrate the test catalog, choose Utilities → Migrate test catalog.
2. Read the information under Migration in the selection screen.
3. Enter the name of the test catalog, which is to be migrated into the new Test Organizer.
4. The Only original test catalogs flag controls whether a test catalog which is not original in the current system can be migrated. If the system contains only a copy of the test catalog (or an included test catalog), it is only migrated if the flag is initial.
5. You get an overview of the migrated objects after migration.

 риск
A new test catalog is created each time you migrate a test catalog even if the same test catalog is migrated several times, in which case they have different attributes.

Result
The specified test catalog is in, and can be used in, the new Test Organizer.

The original test catalog is not deleted.
Check Test Catalog or Plan Structure

Use

After migrating old test catalogs or transporting a test catalog or test plan, you can check whether all test cases, test case descriptions, texts and subordinate test catalogs are in the test catalog or plan in the current system.

Procedure

1. Go to the test catalog or plan maintenance initial screen.
2. Choose the test catalog or plan to be checked.
3. Choose Check.

Result

You get a list of all referred objects in the test catalog and their statuses.
Test Plan

Definition

A test plan is a set of test cases which are to be tested in a particular period for a particular purpose. A test plan is based on one or more test catalogs.

Use

Before testing, put all the test cases which are relevant for the test in a test plan, basing its structure and contents on one or more test catalogs.

After testing, keep the test plan to document the test.

Structure

A test plan comprises the test plan structure and the test plan attributes.

The test plan structure is based on the extended application hierarchy structure, in which the test catalogs with their test cases are entered. The test plan structure is defined by selecting the relevant test catalogs for the test plan. The structure is refined by then selecting individual test cases.

Test plan attributes are for test plan management.
Create Test Plan

A test plan is created with reference to one or more test catalogs. The test catalogs must be in the application hierarchy.

Procedure

1. Go from the ABAP Workbench to the maintenance transaction via Test Workbench → Test Organizer → Manage test plan.
2. Choose .
3. Enter a technical name and a title for the test plan and choose Continue.
4. The extended application hierarchy is displayed. Expand it until you reach the relevant area.
5. Set the focus on this area with .
6. Select the subareas which are relevant for the test plan with .
7. To select by test case attributes, choose .
   Complete the following selection screen and Execute. Only those test cases are now selected which were selected in step 6 and also satisfy the specified selection conditions.
8. You can select or discard test cases manually with .
9. Generate the selected test plan with .
10. Assign the test plan to a development class and specify a transport request, if required.
11. After generation, you go to the test plan maintenance initial screen. The new test plan is in your favorites list.
12. Maintain the test plan attributes [Page 47].
Edit Test Plan Structure

You can change test plans quickly by putting new test cases, which have not yet been put in test catalogs, in existing test cases. Test plan structure changes are not automatically made in the test catalogs. You must make the changes in the test catalog.

Procedure

1. Go to the test plan maintenance initial screen with Test Workbench → Test Organizer → Manage test plan.
2. Choose a test plan from the F4-help or your favorites list.
3. Choose or . You go to the test plan structure maintenance or display respectively.
4. Expand the test plan.
5. If you are editing a large test plan structure, you can focus on a branch of the structure. Position the cursor on a branch and choose .
6. Create new nodes with Create as subnode and Create at same level.
7. Change or delete a node with or .
8. To move nodes:
   - Position the cursor on the node
   - Choose .
   - Select any more nodes.
   - Position the cursor on the node after which the new node is to be inserted.
   - Choose .
   - Specify whether the node is to be a subnode or at the same hierarchy level, in the following dialog box. Choose .
9. To copy nodes into the buffer:
   - Position the cursor on the node
   - Choose .
   - Select any more nodes.
   - Choose .
10. When you have copied nodes into the buffer, as described in item 9, you can reinsert them at the current cursor position with .

You can move or copy several nodes at the same time by selecting several nodes with .
You can also copy nodes between test plans by inserting the contents of the buffer in other test plans.

11. Save the changes.

**Insert nodes at the same or a lower level**

1. Put the cursor on the object at which you want to create another node at the same or a lower level.

2. Choose *As subnode* or *At the same level*.

3. Choose the node type.
   - *Structure text*: Enter a text. To create several structure nodes, use the *Other nodes* function.
   - *Test case*: Enter the name of the test case which you want to put in the structure. You can also create a new test case here. Choose a test case name and choose 
     
     Choose the test case type on the test case *Attribute screen [Ext.]*.
   - *Documentation*: Enter a short text which is to appear in the test catalog structure, in the *Short text* field. Select the document from the *Document field* help.

4. Leave the dialog box with *Continue*.

   The new node is created.

   Various icons, whose meanings are explained under *Goto → Legend*, appear in front of the new node, depending on the object used.
Regenerate Test Plan

Use

You can use this function to make changes to an existing test plan, e.g. to include additional test cases from the underlying test catalog in the existing test plan.

You can reselect from the component hierarchy as when creating test plans, and then regenerate the test plan.

Procedure

1. Go from the ABAP Workbench to the maintenance transaction via Test Workbench → Test Organizer → Manage test plan.
2. Choose a test plan to be regenerated.
3. Choose .
4. The extended application hierarchy is displayed. Expand it until you reach the relevant area. The test cases in the test plan are selected.
5. Set the focus on this area with .
6. Select the subareas that are relevant for the test plan with .
7. To select by test case attributes, choose .
   Complete the following selection screen and Execute. Only those test cases are now selected which were selected in step 6 and also satisfy the specified selection conditions.
8. You can select or discard test cases manually with .
9. Generate the selected test plan with .
10. After generation you go to the test plan maintenance initial screen.
**Edit Test Plan Attributes**

**Procedure**

1. Go to the test plan maintenance initial screen with `Test Workbench → Test Organizer → Manage test plan`.
2. Choose a test plan from the `F4`-help or your favorites list.
3. Choose `Edit`. You go to the test catalog attribute display.
4. To change attributes, go to maintenance mode with `Edit`.
5. Change the title and person responsible for the test plan.
6. Change the test plan release validity.
7. Enter a keyword which could be, e.g. a test plan-independent status analysis [Page 57] selection criterion.
8. An application component is assigned to the test plan when it is generated. To assign another component, enter it in the *Component* field.
9. If you use referencing test cases [Page 12] in the test plan, you must specify a remote connection to the target system in which the referred test cases are defined, in the *Logical destination* field.
10. Save the changes.
Transport Test Catalog or Test Plan

Prerequisites
The test catalog or test plan and its contents must be in a transportable development class.

Procedure
6. Go to the test catalog or test plan maintenance initial screen and choose the test catalog to be transported.

7. Choose .
   You get a list of the objects in the test catalog in the chosen test cases.

8. Select objects. You can select all objects at once with .
   Objects in not-transportable development classes can be put in transportable development classes and transported.

9. Choose .

10. Choose the request in which the selected objects are to be put, from the list of your transport requests, which is displayed, and Continue.
    All objects are put in the specified transport request.
Display Test Plan Hierarchy

The test plan hierarchy gives you a quick overview of a test plan. It shows all test packages and the assignment of test packages to testers.

Procedure

1. You go to the test plan maintenance initial screen.
2. Choose a test plan for which you want to display the hierarchy from your favorites list or the F4 help.
3. Go to the hierarchy with Manage test packages.
   The test catalog hierarchy is displayed in a tree structure.

The hierarchy has the following functions:

- Generate, Change, Display and Delete test packages in this test plan.
- Display and Change the assignment of test packages to be tested.
Check Test Catalog or Plan Structure

Use
After migrating old test catalogs or transporting a test catalog or test plan, you can check whether all test cases, test case descriptions, texts and subordinate test catalogs are in the test catalog or plan in the current system.

Procedure
4. Go to the test catalog or plan maintenance initial screen.
5. Choose the test catalog or plan to be checked.
6. Choose Check.

Result
You get a list of all referred objects in the test catalog and their statuses.
Test Package

Definition

A test package is a person and period-oriented view of a test plan. It contains all tests which a tester is to perform in a specified period.

Use

Extensive tests are usually performed by several testers, so you divide the test cases in your test plan into test packages which are work lists for a tester. You can assign a test case to several test packages.

You assign the test package to a tester.

Structure

A test package comprises the test package structure and the test package attributes.

The test package structure is based on the structure of a test plan. The test package structure is defined by selecting the relevant test cases for the test package from among all test cases of the test plan.

Test plan attributes are for test package management.
Create Test Package

The test cases for individual testers are gathered in test packages. Test packages are based on test plans. Test cases for the test package are selected from the test plan.

Procedure

1. Go to the test plan hierarchy display [Page 49] to generate a test package.
2. Position on the test plan title and choose .
3. Enter a short description of the test package in the following dialog box.
4. The relevant part of the extended application hierarchy is displayed.
5. Select areas for the test package with .
6. To select by test case attributes, choose .
   Complete the following selection screen and make the selection. Only those test cases are selected which were previously selected and satisfy the specified conditions.
7. You can manually select or discard test cases with .
8. Generate the selected test package with .
9. After generation, the new test package is in the test plan hierarchy display. You can assign the test package to a tester [Page 55].
Edit Test Package Structure

Procedure

10. Go to the hierarchy display [Page 49] of the test plan from which you have generated a test package.

11. Expand the view and position on the relevant test package.

12. Choose or .
    You go to the test package structure display or maintenance respectively. The entire test plan structure is displayed.

13. Select other test cases to put in the test package with .

14. Remove test cases from the test package by deselecting them with .

15. You can select by test case attributes with .

16. The test package is changed according to your selection with .
    If the test package test cases already had a status, it remains valid after generation, if the test case is still in the test package.

17. After generation you go back to the test plan hierarchy display. Assign a tester to the test package [Page 55].
Edit Test Package Attributes

Procedure

1. Go to the hierarchy display [Page 49] of the test plan from which you have generated a test package.

2. Expand the view and position on the relevant test package.

3. Choose .
   You go to the test package attribute display.

4. To change attributes, go to maintenance mode with .

5. Change the title and person responsible for the test package.

6. Change the test package validity release.

7. If the test package uses Referring test cases [Page 12], you must specify a remote link to the target system in which the referred test cases are defined, in the Logical destination field.

8. Save the attributes.
Define Tester Worklist

Assign Test Package to Tester

A test package is usually assigned to a tester. The tester finds this test package in the test package test transaction.

⚠️
The test package assignment is client-dependent.

To assign a test package to a tester:

1. Go to the hierarchy display [Page 49] of the test plan from which you have generated a test package.
2. Expand the view and position on the relevant test package.
3. Choose 🗈.
4. Enter the tester’s user name in the Assign test package dialog box and choose Continue.
5. The tester assignment is put in the hierarchy.

To reset a tester assignment, position the cursor on the name of the tester and choose 🕭.

⚠️
If several testers test the same test case in the same test package, the status entry of the last tester applies. This type of assignment does not satisfy the four eyes principle: to perform the test case independently, copy the test package and assign each package to a tester.

💡
For automatic test cases which run in the background the four-eyes principle is superfluous because the test case run is so defined that any tester would get the same result.

Delete Test Package from Worklist

If you want to remove test packages from the tester worklist without losing the tester assignment, you can lock the assignments. This is useful above all when a test is finished and the tester should not change the status any more.

1. Go to the hierarchy display [Page 49] of the test plan from which you have generated a test package.
2. Expand the hierarchy completely so that you can see all test packages and their assignments.
3. Choose the relevant test packages.
Define Tester Worklist

4. Lock the test packages with the Lock assignment function. The assignment status icon changes from (assignment released) to (assignment locked).

To unlock an assignment, mark the test package and choose Release assignment.

Delete Test Package Assignment

To delete a test package assignment, choose Goto → Delete assignment.

You should not delete the assignment of a test package to a tester if it has already been processed because you would lose information.
Analyze Status

You can analyze the status for one test plan or test plan-independently.

A test plan status analysis is usually the result of a particular test.

Test plan-independent status analyses combine the results of several test plans, so they are the overall result of a comprehensive test (involving several test plans).

Analysis of the status of one test plan:

Procedure

1. Go to the test plan maintenance initial screen with Test Workbench → Test Organizer → Manage test plan.
2. Choose a test plan from the F4-help or your favorites list.
3. Choose Status analysis.
4. You can specify a time period for the analysis of a status with .
5. Select an object depending on whether you want to analyze the status of one test package or the entire test plan.
6. Choose Create detail view.
   A test progress overview is displayed. Test case information is displayed on the left-hand side and the test status on the right-hand side. You can choose the display format to analyze the status in the View menu.

   If a test case has been assigned to several test packages, an independent test case status is created for each test package. You can see all statuses of a test case by clicking on the Overview icon after the test case.

   To display all test statuses assigned to all test cases, choose View → Additional information → Status short text y/n.

   The View menu contains more status analysis display types.

Test plan-independent status analysis

Procedure

1. Go to the status analysis selection screen via Test Workbench → Test Organization → Status Info system.
2. Restrict the status analysis with selections.
3. Start the status analysis.
4. A list of the selected test plans and status information summaries is displayed.
Analyze Status

⚠️

This analysis uses status information from previous status analyses of individual test plans. These statuses could be obsolete (e.g. a tester has maintained a test case status in the meantime). This is indicated by a flag in the Obsolete result column and an entry in the report header line. You can refresh this information by selecting test plans and choosing Refresh status analysis.

5. To see the status information for a test plan in detail, select it and choose Status information detail view.
   This performs a current status analysis of all test packages in the selected test plan.

6. To send the status analysis, choose 💌. You can send it with a comment via the Office System Mail.

7. You can perform other analyses of the list using general list functions. You can e.g. pass the data to a spreadsheet program.
Authorization Profile S_TWB

Use
The authorization profile S_TWB assigns Test Organizer authorizations.

Functions
The authorization profile contains the fields TREE_TYPE, ACTVT and APPL_COMP. The fields are described in the authorization object online documentation.
Testing

Definition
Testers work through their test packages in the Test transaction.

Use
The tester transaction provides all functions required for a test. Frequently-used functions are:

- Read test case instructions
- Perform tests (manually and automatically)
- Set test status
Testing

Procedure

1. Go to the test transaction with Test Workbench → Test. An overview of all test packages for which you are the tester is displayed.

2. Choose a test package, which you want to test and choose 📊.

3. If your test package is very large and heavily subdivided, you can focus on the part, which you want to process now. Put the cursor on the top-level node of the area and choose 📊.

4. Choose 📊 to read the test case documentation.

5. Perform the test as described in the documentation. The test is performed automatically or manually:
   - automatically:
     Run the test by choosing 📊 in front of the test case. Describe how the test is to be performed in the next dialog box. See also Perform tests automatically [Page 63].
   - manually:
     Perform the test according to the instructions in the long text.

6. Set the test status [Ext.] with 📊. If the status has already been set, 📊 can be replaced by 📊 (pass) or 📊 (fail).

7. Proceed as follows:
   - Choose a status [Page 65], which describes the test result from the Status field possible entries.
   - Document your test effort in the Test effort fields.
   - Write a tester note in the Short information field. Choose 📊 to record further information
   - If a retest is necessary, select the retest type in the Retest required of group.
   - Create an internal or customer problem if required, and enter the problem number on the screen.
   - Send a message to the person responsible for the test case with 📬.
   - Save your entries.

7. Repeat steps 5 - 8 for the remaining tests.
You can start a spreadsheet program with the pushbutton. You go to dialog boxes in which you can specify how and where to your data are exported. Your data are copied into a spreadsheet program according to your settings.
Perform Automatic Tests

Procedure

Automatic test cases have the icon before the test case short text.

1. When you have read the test case documentation, click on the icon in front of the test case short text.

2. You can set the following test attributes in the Run CATT test locally or Run CATT test remotely dialog box:
   - CATT test status: You should only set this flag in consultation with the test coordinator.
   - Copy CATT result in status: If this flag is set, the result is copied into the test case status which you are maintaining.
   - Flag log for archiving: You should only set this flag in consultation with the test coordinator. It controls log archiving. If the flag is not set, the log is not archived. It is then available for at least 14 days.
   - Test termination flag: this flag terminates the automatic test case as soon as an error occurs. If it is not set, all tests in the test case are performed, even if an error occurs.
   - Log type: choose the level of log detail.
   - Processing mode: specifies the transaction processing mode:
     - Foreground: run in dialog.
     - Background: run in background.
   
   Error: If no error occurs in a test case transaction, it runs in the background. If an error occurs in a transaction, the dialog screen in which the error occurred is displayed in the foreground. You can then change the input values and continue the test with ENTER. The transaction then runs in the background again if no further errors occur.

! Entries that you made during the test case in Foreground or Error mode are not logged.

3. You can also specify a remote link via which the test case is to be run, in the Run CATT test cases remotely dialog box.
   Use the remote link specified by the test organizer.

4. Continue when you have filled the dialog box.

5. You get a log after the test. Check the log for errors. Leave it with .

6. You go to the test case status. If the Copy CATT result in status flag is set at runtime, the status field is already filled. Enter further information for this test case and save the status.

7. Go back to the test package display.
Perform Automatic Tests
### Assign Status

The following table contains an overview of the standard SAP status values. The test organizer can change and delete these values and create new test statuses. Ask your test organizer if you have any questions about status values.

<table>
<thead>
<tr>
<th>Situation</th>
<th>Status</th>
<th>Activities</th>
</tr>
</thead>
<tbody>
<tr>
<td>You have not yet performed a test.</td>
<td>Untested</td>
<td>-</td>
</tr>
<tr>
<td>You want to indicate that you have temporarily interrupted a test.</td>
<td>Testing</td>
<td>-</td>
</tr>
<tr>
<td>You have performed a test and found no errors.</td>
<td>PASS</td>
<td>-</td>
</tr>
<tr>
<td>You have found errors which slightly impair the software (e.g. ergonomic weaknesses, poor user guidance).</td>
<td>PASS with restrictions</td>
<td>Make Processing notes or create a problem message</td>
</tr>
<tr>
<td>You have found program errors or serious faults.</td>
<td>FAIL/ Retest required</td>
<td>Create problem message</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note problem number under Problem no. created</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Maintain the Retest required of Block.</td>
</tr>
<tr>
<td>Error in automatic CATT procedure (type C).</td>
<td>CATT error</td>
<td>Create problem message</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note problem number under Problem no. created</td>
</tr>
<tr>
<td>The automatic CATT procedure ran without errors</td>
<td>CATT PASS</td>
<td>-</td>
</tr>
<tr>
<td>The automatic CATT procedure was cancelled</td>
<td>CATT not performed</td>
<td></td>
</tr>
<tr>
<td>When checking corrections, the original error is solved and no other errors have arisen.</td>
<td>Retest PASS</td>
<td>-</td>
</tr>
</tbody>
</table>
Change Test Workbench Customizing

You can adjust the following Test Workbench settings to your requirements:

- Status definition: You can change, delete and supplement the SAP standard status.
- Message system: you can specify a mail system to which Test Workbench test objects send messages to the people responsible for them.

Procedure

1. Go to the test catalog maintenance.
2. Choose Environment → Settings.
   - You go to the customizing transaction initial screen.

Status definition:

The status definition table is not yet filled at delivery time. If the status assignment accesses this table and it is still empty, the SAP standard status is automatically assigned.

The statuses CATT_FAIL, CATT_PASS and NOT_TESTED are created automatically by the system. You can only change the name of these statuses.

3. Select the Status definition radio button and choose Change.
4. If you need information about handling the customizing transaction, choose Utilities → Users guide.
5. Maintain the existing status definitions or add new ones. The fields have the following meaning:
   - Status: technical name of the status
   - Status name: descriptive text for the status, this is then visible, e.g. in the status maintenance for a test performed in the Test Workbench.
   - Value: the status is categorized as pass, fail or untested. This value is used in status analyses.
   - Sort field: specifies the sequence in which the status appears in F4 help.
6. To maintain the status name in other languages, choose Edit → Translation. For further information, see Maintain language-dependent texts [Ext.].
7. Save your changed status definitions and go back to the initial screen.

Message system:

1. Select the Central management radio button and choose Change.
2. Define the message system:
   - Central: specify a mail system to which test objects send messages via a remote link.
   - Local: The local SAP mail system of your R/3 system is used as the mail system.
3. Save the changes.
User-Specific Settings

**Use**
Some Test Workbench settings can be user-specific.

**Functions**
Status info system display variants:
- List control: Functionally enhanced list
- Normal list: advisable in WAN networks.
The tester worklist is available as an ABAP List Viewer list.

**Actions**

**Status Infosystem**
1. Go to the test catalog or plan maintenance initial screen.
2. Choose Utilities → Settings…
   The User-specific settings dialog box has two tabs.
3. Choose the General tab to change the status info system list display.

**Tester Worklist**
1. Call the transaction Testing (STWB_WORK). You go to your worklist.
2. You can change the field display with Settings → Display variants → Current… or .
   The following screen lists the columns at the left-hand side: All these columns are displayed in
   the worklist.
   Available columns are listed on the right-hand side: you can put them in the display.
3. To put a column in the list, select it and choose .
4. To remove a column from the list, select it and choose .
5. Confirm the changes with .
6. Save your changes with . You go to a screen in which you specify layout and description
   names and make other settings. See the ALV Grid Control [Ext.] documentation.
7. User-specific variants are under Settings → Display variants → Select…