Business Configuration Sets (BC-CUS)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Icon" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image2" alt="Icon" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image3" alt="Icon" /></td>
<td>Note</td>
</tr>
<tr>
<td><img src="image4" alt="Icon" /></td>
<td>Recommendation</td>
</tr>
<tr>
<td><img src="image5" alt="Icon" /></td>
<td>Syntax</td>
</tr>
</tbody>
</table>
Contents

Business Configuration Sets (BC-CUS) ...........................................................5
Business Configuration Set Structure ........................................................................................ 6
Using BC Sets .......................................................................................................................... 8
BC Set List ............................................................................................................................. 10
Create Business Configuration Sets ......................................................................................... 12
Create BC Set via IMG hierarchy ............................................................................................. 13
Create BC Set From Other BC Sets .......................................................................................... 16
Create BC Set From Transport Request ..................................................................................... 17
Change a Simple BC Set ............................................................................................................. 18
Change Hierarchical BC Set ....................................................................................................... 21
BC Set Editing Functions ........................................................................................................... 23
Checking BC Sets ....................................................................................................................... 26
Activate Business Configuration Sets ......................................................................................... 29
Activate BC Sets Automatically ................................................................................................ 30
Activate BC Sets Interactively ................................................................................................ 31
Business Configuration Sets (BC-CUS)

Customizing settings can be collected by processes into Business Configuration Sets (BC Sets). BC Sets make Customizing more transparent by documenting and analyzing the Customizing settings. They can also be used for a group rollout, where the customizing settings are bundled by the group headquarters and passed on in a structured way to its subsidiaries.

BC Sets are provided by SAP for selected industry sectors, and customers can also create their own.

When a BC Set is created, values and combinations of values are copied from the original Customizing tables into the BC Set and can be copied into in the tables, views and view clusters in the customer system. The BC Sets are always transported into the customer system in which Customizing is performed.

The loading of BC Sets is logged by the system, i.e. which BC Set was copied when into the system, and any errors which occurred. This information is significant for Continuous Change and Upgrade.

The settings in the BC Set can be compared with the system data using the Customizing Cross-System Viewer [Ext.], to check the consistency of the data.

Advantages of using BC Sets:

- Efficient group rollout.
- Industry sector systems are easier to create and maintain.
- Customizing can be performed at a business level.
- Change Management is quicker and safer.
- Upgrade is simpler.

The BC Set creation and editing procedure is described in the following topics:

Create Business Configuration Sets [Page 12]
Activate Business Configuration Sets [Page 29]
Business Configuration Set Structure

BC Sets group table values for a Customizing area. For example, a BC Set could contain the Customizing settings for particular business processes. The table values can be in any order. You can put the values for a complete table or individual fields of one or more tables in a BC Set. You can also combine several BC Sets into one higher-level BC Set.

Features

There are two kinds of BC Sets:

- Simple BC Sets (referred to as "BC Sets")
- Hierarchical BC Sets

A BC Set is identified by the following attributes:

- Name
- Type (simple or hierarchical)
- Release
- Last changed by (person), on (date) and at (time)

Simple BC Set

A BC Set contains data from Customizing tables. The data is selected by table columns and rows, each column is a field, each row a record.

There is no BC Set size restriction. A BC Set can contain data from one or more IMG activities. Each IMG activity is listed separately with its Customizing objects (tables or views).
Graphic: BC Set structure

**Hierarchical BC Sets**

A hierarchical BC Set comprises several other BC Sets, which can also be hierarchical. The hierarchy can have any number of levels. It structures complex system setting data. You can delete or add lower-level BC Sets at any time.

![Hierarchical BC Set structure](image)

**Activities**

- You can edit BC Sets in the system with the transaction `SCPR3`.
- You can activate BC Sets in the system with the transaction `SCPR20`.

See also:

- [Using BC Sets](Page 8)
- [Activate Business Configuration Sets](Page 29)
Using BC Sets

The screen is divided into the following areas when you use BC Sets:

**Header**
When you select a BC Set from the list by double-click, its name and short text are displayed as a header.

**List**
You can select BC Sets by double-click in the list. The list also provides additional information about BC Sets. You can show or hide the list.

A simple BC Set is indicated in the list by ⬅️, a hierarchical BC Set by ⬛️. See [BC Set list](#) [Page 10].
IMG Structure and BC Set Structure

When you select a BC Set from the list by double-click, its structure is displayed. The BC Set name and icon are displayed as the top node. Other BC Sets are shown below this node, down to IMG activities at the lowest level.

You can go to the IMG structure in change mode. The IMG activities in the BC Set are indicated by a flag in the structure.

Values

If you double-click on an IMG activity in the structure of a BC Set, the tables and views which are used in the Customizing activity are displayed. The tables or views in a BC Set are indicated by a flag.

The BC Set values are displayed in data records and fields.
BC Set List

Use

In the BC Set list, you can tell from the icons if a BC Set is hierarchical (type $\text{§}$) or simple (type $\text{∥}$). The BC Set name, short text, change date, company name and validity range are also displayed.

The company name identifies the creator of a BC Set. BC Sets which were created by others (e.g.: SAP, partner, group headquarters) can be changed.

The validity range of a Business Configuration Set is the range of R/3 Releases for which it is valid. BC Sets cannot be activated in systems which are outside this range. Otherwise the data in the tables used could become inconsistent.

You can put BC Sets in a personal worklist as Favorites. If you have no Favorites, all BC Sets are listed.

Prerequisites

You have entered the BC Set maintenance tool transaction SCPR3 in the command field or chosen Tools → AcceleratedSAP → Customizing → Business Configuration Sets.

Features

The BC Set list display allows you to:

Sort

You can sort the data in the list in ascending or descending order. Click on a column header and choose Sort ascending or Sort descending.

Search

You can search for a term in the list. Click on the column to be searched and choose Search… Enter the search term and specify row-wise or column-wise search.

Set filter

The filter function restricts the column selection in the list.

Print

View → Print preview shows the list on the screen as it would be printed. Choose Print to print the displayed list.

Views

You can display the list in various formats, e.g. in Excel format.

Expand or reduce list

To view the list in full screen, choose the magnifying glass Large BC Set list. The magnifying glass Small BC Set list shrinks the list again.
**Selection**

You can collect BC Sets in a list by selection criteria. The following criteria are possible:

- Attributes
- Activities
- Tables
- Texts

Choose *New selection* and then the selection criterion. Enter your data, e.g. the BC Set name or the last changer, in the following window.

You can display only the BC Sets which you have edited, in the list (user = last changer). Choose *New selection* and then *My BC Sets*. *All BC Sets* displays the complete list again.

**Favorites**

All users can define their own Favorites. Favorites are edited independently of the displayed list. To display the Favorites, load them with the Selection function.

You can create Favorites in two ways:

- with *Maintain Favorites*
  
  Choose *Maintain Favorites*. Copy the desired BC Sets from the value list into the Favorites, in the next window, by marking them and clicking on the left arrow (*Add to Favorites*). Choose *Copy Favorites* (*Continue*).
  
  - with *Save list as Favorites*

  You can declare a selected list as your Favorites. Create the list by selection criteria, e.g. your own BC Sets. Choose *Save list as Favorites*.

  *New selection → Load Favorites* displays your Favorites. Newly created BC Sets are automatically put in the Favorites.

**Context menu**

Click on the right-hand mouse key for the context menu with more BC Set processing functions. The context menu refers to the BC Set indicated by the cursor (not one selected by double-click).

See [ABAP List Viewer (ALV) Grid Control [Ext.]]( Ext.).
Create Business Configuration Sets

Use

You can create BC Sets:

- **via the IMG hierarchy**
  
  This is the most common procedure. You go to the IMG structure, where you can select the Customizing activities. Call the activities in a business process and copy all the values which are relevant for the control of the process.

- **by collecting BC Sets**
  
  A BC Set can comprise several other BC Sets. You can construct complex BC Sets for industry sectors or a group rollout from smaller BC Sets. These are called hierarchical BC Sets.

- **via a transport request**
  
  You can base a BC Set on existing transports. In certain systems, every changed record is recorded in a transport request. A BC Set can be based on this transport request. BC Sets created in this way must usually be edited.

Activities

1. Choose *Tools* → *Customizing objects* → *Business Configuration Sets* in the Customizing menu, or enter the transaction code `SCPR3` in the command field.

2. Choose *Bus.Conf.Set* → *Create*.

3. Enter a name and a short text for the BC Set.

   ![Tip] Customer BC Sets must begin with `Y` or `Z`. This ensures that they are not overwritten by BC Sets delivered by SAP.

   SAP BC Sets have a valid prefix. To get a valid prefix, choose *Valid prefix*. You can create BC Sets with the prefix `TST_` for test purposes.

4. Choose one of the three options *IMG Hierarchy*, *Collection of Bus.Conf.Sets* and *Transport request*, and Continue.

   See one of the following procedures, depending on how you want to create a BC Set:
   
   [Create BC Set via IMG hierarchy][Page 13]
   
   [Create BC Set from other BC Sets][Page 16]
   
   [Create BC Set from transport request][Page 17]
Create BC Set via IMG hierarchy

Prerequisites

You want to create a BC Set via the IMG hierarchy. Decide whether you want to base the BC Set on the SAP Reference IMG or a Project IMG. In the SAP Reference IMG, you can access all IMG activities. The Project IMG is a selection of IMG activities.

To use the SAP Reference IMG, choose Utilities → Reference IMG.

To use a Project IMG, choose Utilities → Project IMG. Choose a project in the following window.

If you have switched between SAP Reference IMG and Project IMG, you must restart the transaction SCPR3.

The setting is retained until you choose another IMG hierarchy.

Procedure

1. Expand the IMG structure to the IMG activity for which you want to save data in a BC Set. Click on the IMG activity icon next to the title of the desired IMG activity.

   The tables or views in the selected IMG activity are listed at the top right of the screen.

   You can choose other tables with Other tables. You can remove tables which you do not need in the BC Set from the list with Delete table. The data of the table is deleted from the BC Set.

2. Select the table or view whose data you want to put in the BC Set.

3. Choose Select table/view.

   The values of this table or view are shown on the tab below.

5. All data records of the selected table or view are displayed in the Data records tab.
Create BC Set via IMG hierarchy

The column headers are the table or view field names.

5. To select data:
   a. Select all the records which you want to put in the BC Set.
   b. Select fields by clicking on the column header. The column is highlighted.
      Assign an attribute to the field.
      The following attributes exist:
      - Standard
      - Not changeable after activation
      - Get values at activation
      To not copy a selected column into the BC Set, choose Do not copy. The attribute symbol is deleted for the selected column.

Attribute **Standard**

When you create a BC Set, all fields except the key fields are selected in the Copy column and have the attribute Standard. In this case the table field value is copied without confirmation when the BC Set is activated and can be changed manually.

Attribute **Not changeable after activation**

Assign this attribute to table fields whose values are not to be changed after activation of the BC Set. The values of these fields are copied unchanged when the BC Set is activated [Page 29]. This is for example the case when Customizing settings are passed unchanged to subsidiaries in a group rollout. Business settings could otherwise be accidentally overwritten when the BC Set is activated.

Attribute **Get values at activation**

Assign this attribute to table fields whose values are to be specified by the user during activation of the BC Set.
Customers can change the values of these fields when the BC Set is activated. All fields whose value can not yet be determined when the BC Set is created should have this attribute. These are typically organizational units such as company code, plant, etc.

You can also select data records by selection criteria. Choose Choose selectively. Enter a selection criterion in the next window, e.g. Check rule= ‘AE’ and confirm with Continue. The data record which satisfies the criterion is marked.

The following three steps are not necessary if you have already selected fields and assigned attributes in the Data records tab. Only select fields if you have not yet assigned attributes in the Data records tab.

6. Choose the Field selection, attributes tab. The Copy column is set for all table fields. This means that the data in the selected fields are to be copied into the BC Set.

7. Click on the fields which you do not want to copy into the BC Set.

8. Assign one of the above attributes to each field by clicking on the radio button in the appropriate column.

If a field in the Key column and in the Copy column is marked, the value of the field is copied into the BC Set.

If a field is marked in the Key column but not in the Copy column, you are prompted for the value when the BC Set is activated, and you can change it.


10. Enter a development class [Ext.] in the Create object catalog entry window and choose Save. Enter the transport request [Ext.] number in the following window.
Create BC Set From Other BC Sets

Prerequisites
You want to create a hierarchical BC Set from several existing BC Sets.

Procedure
1. You can restrict the set of BC Sets which you want to use, in the Bus.Conf.Set: Select by attributes dialog box. Enter your selection criteria and choose Execute.
   The Business Configuration Set: Select dialog box appears.
2. Select all BC Sets which are to go in the new BC Set and Continue.
3. The structure of the hierarchical BC Set is displayed.
4. Save the BC Set if the structure is correct.
   To put other BC Sets in the hierarchy, position the cursor on the BC Set beneath which the other BC Sets are to be inserted. Click on Insert entry.
   To remove BC Sets from the hierarchy, position the cursor on the BC Set to be deleted. Click on Delete entry.
   Save your changes.
5. Enter a development class in the Create object catalog entry window and Save. Enter the transport request number in the following window.

Result
The BC Set hierarchy is created by links. You can delete links or add BC Sets in a change mode.
Create BC Set From Transport Request

Prerequisites
You want to create a BC Set from a transport request. A transport request containing Customizing data must already exist.

This Customizing request is a change request with which you can copy and transport the changed system settings.

The BC Set is based on the data in the Customizing request. You can copy all the data records in the Customizing request into the BC Set, or select a subset.

You can subsequently edit BC Sets created from transport requests.

Procedure
1. Enter the Customizing request number and Continue.
   
   You can search for requests with the F4 help. The request type is Workbench/Customizing requests. The request status is changeable or released.

2. Decide which data in the column Copy is to be copied into the BC Set. Click on the fields which you do not want to copy into the BC Set.

3. Mark the column for table fields whose values should not be changed after activation of the BC Set. This prevents business settings being overwritten by mistake.

4. Mark the column for table fields whose values are to be determined by the user when the BC Set is activated.

5. Choose Continue. The selected data is displayed again in a list for checking.
   
   Confirm the selected data with Continue.

   You can also print the settings displayed with the Print pushbutton.

6. Enter a development class in the Create object catalog entry window and choose Save.
Change a Simple BC Set

You can change BC Sets as follows:

- Change the field or data record selection
- Delete tables or views from a BC Set
- Delete IMG activity from BC Set
- Add IMG activity
- Add tables or views
- Change BC Set short text and validity range

Procedure

1. Double-click on the BC Set to be changed in the list.
   The structure of the BC Set to be changed is displayed.
2. Choose BC Set → Display/Change or click on Display/Change.
   
   If you call a BC Set which is also used in other (hierarchical) BC Sets, in change mode, you are warned that the other BC Sets will also be changed.

Change the field or data record selection

You can change the field or data record selection in an existing IMG activity as follows:

Add data records to an IMG activity

1. Double-click on the IMG activity which you want to enhance, in the structure.
   The BC Set values are displayed at the right-hand side of the screen.
2. Click on Display all fields to display all fields in the table or view.
   Only used fields gives an overview of the fields in the BC Set.
3. Mark the data records which you want to add to the BC Set.
   Refresh lists the selected data.
   Refresh refreshes the screen. This is advisable after you have made a lot of changes which are not yet displayed.
4. Assign attributes as described in Create BC Set via IMG hierarchy [Page 13].
5. Save your changes.

Delete data records

1. Double-click on the IMG activity for which you want to delete data records, in the structure.
   Its tables or views are displayed with their values in the BC Set at the right-hand side of the screen.
2. Click on the data record to be deleted to unmark it.
3. Save your changes.
   The data record is deleted from the BC Set.

   To delete a selected field from the BC Set, click on Do not copy.

**Delete tables or views from a BC Set**

To delete one or more tables or views from a BC Set, you must deselect all data records of this table or view. You can alternatively delete the selected tables or views with a pushbutton.

1. Double-click on the IMG activity which you want to change, in the structure.
   Its tables or views are displayed at the right-hand side of the screen.
2. Select the table(s) or view(s) which you want to delete, in the *Tables and views of selected IMG activity* list.
3. Choose *Delete table*.
4. Confirm that you want to delete the BC Set table data.
   The selected table or view is deleted from the list.

**Delete IMG activity from BC Set**

To delete an IMG activity from a BC Set, you must delete all of its tables or views. You can alternatively delete the IMG activity with a pushbutton.

1. Double-click on the IMG activity which you want to delete from the BC Set, in the structure.
   The IMG activity values are displayed in the right-hand side of the screen.
2. Choose *Delete activity from BC Set* to the right of the IMG activity name.
   The IMG activity is deleted from the structure without a confirmation prompt.
3. Save your changes.

**Add IMG activity**

1. Choose *IMG structure*.
   The implementation guide hierarchy is displayed.
2. Expand the structure to the desired IMG activity.
   The IMG activities in the BC Set are indicated by a flag in the structure.
3. Click on the *IMG activity* icon next to the title of the IMG activity in the structure.
   Its tables or views are displayed.
4. Select the table or view whose values you want to put in the BC Set.
5. Select table fields and data records as described in Create BC Set via IMG hierarchy [Page 13].
6. Save your changes.
   *BC Set structure* displays the BC Set structure.
Change a Simple BC Set

Add tables or views

To add other tables or views to the tables or views of the selected IMG activity:

1. Double-click on the IMG activity which you want to change, in the structure.
   Its tables or views are displayed at the right-hand side of the screen.

2. Choose Other tables.

3. Enter the table or view name in the next window and choose Continue.
   The table or view is added to the Tables and views of selected IMG activity list.

Change BC Set short text and validity range


2. You can change the description of the BC Set in the Short text field or the validity period in the Release field.

3. Choose Continue.

4. Save your changes in a transport request.
Change Hierarchical BC Set

You can change hierarchical BC Sets as follows:

- add lower-level BC Sets
- Remove lower-level BC Sets from the hierarchy structure
- Change BC Set short text and validity range

Prerequisites

You have already called the BC Set in change mode.

If you call a BC Set which is also used in other BC Sets, in change mode, you are warned that the other BC Sets will also be changed.

Procedure

Add lower-level BC Sets

You can only add BC Sets at the lowest level.

1. Click on Insert entry.
2. Enter the name of the BC Set which you want to add, in the Bus.Conf.Sets: Select by attributes window and choose Execute.
3. Select the displayed BC Set and choose Continue.

   The specified BC Set is linked to the end of the BC Set structure.

Remove lower-level BC Sets from the hierarchy structure

BC Sets are linked to the hierarchy structure. You can delete these links in change mode. This only applies to BC Sets which are directly below the BC Set to be changed in the hierarchy.

Example: Remove lower-level BC Sets from the structure
You have opened BC Set A on level 1 in change mode. You can remove both BC Sets at level 2 from the structure. You delete the link between two BC Sets, not the BC Set itself. If you remove BC Set C from the structure, the links to the lower-level BC Sets D and E are also deleted. To remove BC Set F on level 4 from the structure, you must edit BC Set E on level 3 in change mode.

1. Position the cursor on the lower-level BC Set which you want to remove from the structure.
2. Choose `Delete entry`.

   The lower-level BC Set is removed from the structure.

   In contrast to the `Delete` function, only the links in the structure are deleted, not the BC Set itself.

**Change BC Set short text and validity range**

1. Choose `Bus.Conf.Set → Change validity` or the `Text/Validity` pushbutton.
2. You can change the description of the BC Set in the `Short text` field or the validity period in the `Release` field.
3. Choose `Continue`.
4. Save your changes in a transport request.
BC Set Editing Functions

Use
The following BC Set maintenance tool functions are described below:

- Copy BC Set
- Delete BC Set
- Create documentation
- Maintain attributes
- Legend
- Where-used list
- BC Sets in transport request
- Download BC Set
- Upload BC Set

Activities

Copy BC Set
You can copy a BC Set using the context menu (right mouse key) or as follows:
1. Double-click on the BC Set to be copied in the list.
2. Choose Bus.Conf.Set → Copy or click on the Copy BC Set icon.
3. Specify a different name for the new BC Set and choose Continue.
4. Enter a development class and save. Enter a transport request.

Delete BC Set
You can delete a BC Set using the context menu (right mouse key) or as follows:
1. Double-click on the BC Set to be deleted in the list.
3. Confirm the following confirmation prompt.

The BC Set is deleted from the system if it is not also in another BC Set. If so, a system message informs you. If you still want to delete the BC Set which is used elsewhere, the links to it are also deleted.

Create documentation
You can create documentation, which may describe the use and contents of a BC Set.
1. Double-click on the BC Set which you want to document, in the list.
2. Go to change mode with Bus.Conf.Set → Display/Change, or click on the Display/Change icon.
BC Set Editing Functions

3. Choose **Edit → Create documentation** or click on the **Create documentation** icon.

4. Enter your text in the SAPscript editor and save it in **active** state with **Document → Save → Active**.

5. Enter a development class and save. Enter a transport request.

6. Go **Back** to the initial screen.

You can display the documentation of the selected BC Set in display mode with **Edit → Display documentation** or by clicking the **Display documentation** icon.

**Maintain attributes**

You can assign countries and industries to BC Sets in the attribute maintenance.

1. Choose a BC Set by double-click in change mode.

2. Choose **Edit → Maintain attributes** or click on the **Maintain country and industry attributes** icon.

3. Make your entries in the **Countries** and **Industries** tabs and save.

4. Go **Back** to the initial screen.

You can display the attributes assigned to a BC Set in display mode with **Edit → Display attributes** or by clicking on the **icon**.

**Legend**

The legend explains the meaning of the BC Set type icons and the field attributes.

Choose **Utilities → Legend** or click on the **Legend** icon to display the legend.

**Where-used list**

A where-used list tells you whether a BC Set is in another BC Set.

1. Double-click on the BC Set of which you want to check the use, in the list.

2. Choose **Utilities → Where-used list** or the **Where-used list** icon.

   All BC Sets containing this BC-Set are listed. If the selected BC Set is not in any other BC Set a message in the status line says so.

**BC Sets in transport request**

In a hierarchical BC Set you can enter all lower-level BC Sets in a transport request. The BC Set must not be a local object. You do not need to select the lower-level BC Sets individually.

1. Choose a hierarchical BC Set by double-click.

2. Choose **Utilities → BC Sets in transp.**

3. Enter a development class and save. Enter a transport request.

You can put the lower-level BC Sets in the same transport request as the higher-level hierarchical BC Set or in another transport request.
**Download BC Set**

You can download BC Sets from the SAP System to a directory in your PC or another data medium.

1. Double-click on the BC Set to be downloaded, in the list.
2. Click on **Download BC Set**.
3. Enter the download path and filename in the following window and choose *Continue*. You can overwrite the proposed path and filename. You can browse the directories on your PC with the possible entries help.

   The BC Set is downloaded to the specified directory.

**Upload BC Set**

You can upload BC Sets from your PC or another data medium into the SAP System.

1. Click on **Upload BC Set**.
2. Enter the path from which you want to upload the file, and the filename, in the following window and choose *Continue*. You can overwrite the proposed path and filename.

   You can find the filename of the BC Set in the directories on your PC with the possible entries help.

   The System checks whether the specified BC Set name already exists in the SAP-System.

   If it does, it is displayed. You can continue the upload or cancel. To overwrite the existing BC Set, choose *Continue*, otherwise *Cancel*.

   If the BC Set does not yet exist in the SAP System, choose *Continue* to upload it into the SAP System.

   BC Set long texts are not uploaded and downloaded.
Checking BC Sets

The following BC Set checks exist:

- Compare with Customizing tables (with or without key check)
- Key conflict check
- Combinability

Prerequisites

You have already created BC Sets or transported BC Sets provided by SAP into your production preparation system.

Activities

Compare with Customizing tables

The BC Set creator can compare Customizing tables with the BC Set data to ensure that the BC Sets contain the actual system settings. If there are differences, he or she can copy the Customizing table data into the BC Sets.

1. Double-click on the BC Set to be compared with the Customizing tables.

2. Choose Utilities → Comp. with Cust.tab. or the Compare with Customizing table icon.

   Differences found by the check are listed.

3. You can display all entries with the Display all pushbutton or the differences only with the Only display differences pushbutton.

4. If you are comparing a simple BC Set, you can copy the data from the displayed Customizing tables directly into the BC Set with the Copy data pushbutton.

Example: Result of comparison of BC Set and Customizing tables

<table>
<thead>
<tr>
<th>BC Set</th>
<th>2nd table</th>
</tr>
</thead>
<tbody>
<tr>
<td>1: IB_CO_1050</td>
<td>2nd table: TKA07</td>
</tr>
<tr>
<td>Client</td>
<td>Control</td>
</tr>
<tr>
<td>1. 000</td>
<td>0001</td>
</tr>
<tr>
<td>2. 000</td>
<td>0001</td>
</tr>
</tbody>
</table>

In this example, the BC Set values (in the 1st row) and the values in the table named at the right (in the 2nd row) are identical.

Compare with Customizing tables with key check

The project member who makes the system settings can check which BC Set data will be overwritten if he or she enters concrete values for fields with value prompt, before activating. These changes only apply during the data comparison. They are not saved in the BC Set.
Make this check before activating a BC Set.

1. Choose Utilities → Comp. with Cust.tab. + Key check.

   All key fields with the Get values at activation attribute are displayed.

Example: Result of comparison of BC Set and Customizing tables with key check

<table>
<thead>
<tr>
<th>Key field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distrib.channel</td>
<td>...</td>
</tr>
<tr>
<td>Int.co billing div.</td>
<td>...</td>
</tr>
<tr>
<td>Planning plant</td>
<td></td>
</tr>
<tr>
<td>Plant</td>
<td>032</td>
</tr>
<tr>
<td>Plant</td>
<td>031</td>
</tr>
<tr>
<td>Purch. organization</td>
<td>031</td>
</tr>
<tr>
<td>Sales organization</td>
<td>031</td>
</tr>
<tr>
<td>Shipping point/receiving pt</td>
<td></td>
</tr>
</tbody>
</table>

2. You can overwrite proposed values and choose Continue.

   The comparison is made with the changed values.

3. You can display all entries with the Display all pushbutton or the differences only with the Only display differences pushbutton.

Key conflicts

Key conflicts occur if there are two data records in a hierarchical BC Set with the same key but different values.

Example key conflict scenario

A project member changes the data in the Customizing table in a BC Set, after creating the BC Set. The project member later creates another BC Set which uses the same data records. Both BC Sets - before and after the data change - are put in a hierarchical BC Set. Their table entries create key conflicts.

Key conflicts are not automatically visible, so you must check the data. You should perform a key conflict check each time you create a hierarchical BC Set.

1. Double-click on the hierarchical BC Set which you want to check for key conflicts.

2. Click on Key conflict check.

   Any key conflicts are listed.

   You are warned about key conflicts in data records with values which could be overwritten at activation. You can resolve the key conflict by changing the entries in the lower-level BC Sets when you activate the BC Set.
Checking BC Sets

Data records with values which cannot be changed after activation cause an error. You can print the error list with Print.

Combinability

Whereas key conflict checks are made within one hierarchical BC Set, the data records of several BC Sets (hierarchical and simple) can also be checked together for key conflicts. The BC Set selection is not subject to any restrictions.

1. Choose Utilities → Combinability in the initial screen.
2. Enter the names of the BC Sets on which you want to perform a key conflict check in the following window.
3. Choose Combinability check.

Data records with the same key are listed and can be printed.

Resolve key conflicts by changing the table entries in the selected BC Sets.

---

Example: Result of a combinability check

 минимальность! следующие записи могут привести к проблемам.

Tabelle: TBRGT
1. BC-Set: O_LANGU_TEST 2. BC-Set: KEYLANGU1

<table>
<thead>
<tr>
<th>Mandan</th>
<th>Sprach</th>
<th>Berechtigung</th>
<th>Bereich</th>
<th>Bezeichnung</th>
</tr>
</thead>
<tbody>
<tr>
<td>0000</td>
<td>E</td>
<td>_TABU_DIS</td>
<td>FE32</td>
<td>FI: Exchange rates</td>
</tr>
<tr>
<td>0000</td>
<td>E</td>
<td>_TABU_DIS</td>
<td>FE32</td>
<td>Value was changed</td>
</tr>
</tbody>
</table>
Activate Business Configuration Sets

Use

BC Set activation makes the values in the BC Set available for the implementation. The new or changed data records are written into a change request, which can transport the data into the production system.

Before activating BC Sets, run the following control functions in the production preparation system to avoid errors in your Customizing tables.

The following functions exist:

- Compare with Customizing tables with key check
- Key conflict check
- Combinability

See Checking BC Sets [Page 26].

Prerequisites

BC Sets can only be activated if there is no production client in the system.

⚠️ Activating a BC Sets copies all data from the BC Set into the original tables. The existing entries in the original tables are overwritten.

BC Sets should only be activated in the system in which you make the Customizing settings. Test the settings before transporting them into the production system. See Compare BC Set with Customizing tables [Page 26].

Activities

You can activate BC Sets:

- automatically. This is the usual and quicker method.
- interactively. The data is displayed before it is loaded into the tables. The user can control the activation.

The procedure differs in the two cases. See:

Activate BC Sets automatically [Page 30]
Activate BC Sets interactively [Page 31]
Activate BC Sets Automatically

BC Sets are activated automatically in the background. The BC Set values are copied into the tables without confirmation. Automatic activation is quicker than interactive activation.

Prerequisites

BC Sets can only be activated if there is no production client in the system.

Procedure

1. Enter the transaction code SCPR20 in the command field.
2. Enter the name of the BC Set which you want to activate.
3. Choose Bus.Conf.Set → Activate or the Activate pushbutton.
   A warning that original tables are overwritten by activation of BC Sets appears. You can still cancel the activation at this point.
4. To proceed with the activation, choose Continue.
   All fields with the Get values at activation attribute are listed in the Business Configuration Set: Variable values window. These are above all organizational unit fields, such as company code, plant, etc.
   If a BC Set contains several data records with the same field defined as a variable, it is only displayed once for value input when activating. If you overwrite the proposed value, it appears in all occurrences of the field.
   If a repeatedly occurring field has different values, all proposed input values are displayed.
   Example: Activate BC Set with variable fields [Ext.]
5. You can overwrite proposed values and choose Continue.
6. The system checks for key conflicts in the BC Set.
   Key conflicts occur if there are two data records in a hierarchical BC Set with the same key but different values. In this case it is not clear which of the values is to be put in the original tables. The activation is cancelled if key conflicts occur.
7. Enter the transport request number when asked for a Customizing transport request and choose Continue.
   If the BC Set contains non-customizing-relevant data, e.g. master data, you are prompted for another transport request. Enter the system transport request number and choose Continue.

Result

All the data in the BC Set is put in the original tables. The System confirms that the data has been saved.

The activation log of changed data records is displayed. You can print the log.
Activate BC Sets Interactively

In interactive BC Set activation, you can enter the BC Set values in the Customizing tables under the guidance of the system. You can decide which data is changed or copied. The system decides which Customizing objects can be copied automatically and which are to be processed manually.

Prerequisites

BC Sets can only be activated if there is no production client in the system.

Procedure

1. Enter the transaction code SCPR20 in the command field.
2. Enter the name of the BC Set which you want to activate.
   
   A warning that original tables are overwritten by activation of BC Sets appears. You can still cancel the activation at this point.
4. To proceed with the activation, choose Continue.
   
   All fields with the Get values at activation attribute are listed in the Business Configuration Set: Variable values window. These are above all organizational unit fields, such as company code, plant, etc.
   
   If a BC Set contains several data records with the same field defined as a variable, it is only displayed once for value input when activating. If you overwrite the proposed value, it appears in all occurrences of the field.
   
   If a repeatedly occurring field has different values, all proposed input values are displayed.
   
   Example: Activate BC Set with variable fields [Ext.]
5. You can overwrite proposed values and choose Continue.
6. The system checks for key conflicts in the BC Set.
   
   Key conflicts occur if there are two data records in a hierarchical BC Set with the same key but different values. In this case it is not clear which of the values is to be put in the original tables. The activation is cancelled if key conflicts occur.
7. Enter the transport request number when asked for a Customizing transport request and choose Continue.
   
   If the BC Set contains non-customizing-relevant data, e.g. master data, you are prompted for another transport request. Enter the system transport request number and choose Continue.
8. The following overview is displayed:
   
   a. Data displayed green can be activated automatically. Start the activation procedure by clicking on the Execute icon to the left of the Activate next data records function.
   
   b. Data displayed red cannot be activated automatically. It must be put in the tables manually.
Activate BC Sets Interactively

You should print out the overview of data which cannot be activated automatically to support the data entry into the tables.

The icon provides additional information about the procedure.

Start the interactive activation by clicking on the Execute icon to the left of the Enter data in the tables manually function.

9. You can enter a Customizing project in the Customizing: Select project window.

   All existing Customizing projects are listed in the possible entries help. Select a project and confirm with Continue.

   If you are not using a Customizing project, choose Without project.

10. The implementation guide (IMG) is displayed. The IMG activity whose values are in the BC Set is highlighted.

11. If the Customizing object is a view, you can copy the data from the BC Set into the Customizing tables with the Copy BC Set pushbutton.

    If the Customizing object is for example an individual transaction, not a view, you must enter the data in the Customizing table manually. Click on the Execute icon to the left of the highlighted IMG activity.

12. Enter the data from the BC Set (supported by the printout) in the table and save your entries.


Result

The traffic-light icon changes from red to green to indicate that the data from the BC Set has been copied into the original tables.