Hypertext Structure Maintenance (BC-DOC-DTL)

Release 4.6C

SAP
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, RIVA, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Caution" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image2" alt="Example" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image3" alt="Note" /></td>
<td>Note</td>
</tr>
<tr>
<td><img src="image4" alt="Recommendation" /></td>
<td>Recommendation</td>
</tr>
<tr>
<td><img src="image5" alt="Syntax" /></td>
<td>Syntax</td>
</tr>
<tr>
<td><img src="image6" alt="Tip" /></td>
<td>Tip</td>
</tr>
</tbody>
</table>
Contents

Hypertext Structure Maintenance (BC-DOC-DTL) ....................................................... 5
Hypertext Structure ........................................................................................................ 6
Create Hypertext Structure ........................................................................................... 7
Change Hypertext Structure ........................................................................................... 9
Display Hypertext Structure .......................................................................................... 12
Rename Hypertext Structure .......................................................................................... 14
Translate Node Texts ....................................................................................................... 15
Manage Favorites ........................................................................................................... 16
Print Hypertext Structure .............................................................................................. 17
Delete Hypertext Structure ............................................................................................ 18
Transport Hypertext Structure ....................................................................................... 19
Search Function ............................................................................................................. 20
Hypertext Structure Maintenance (BC-DOC-DTL)

Documents can be structured hierarchically in hypertext structures. This is suitable for the description of concepts as well as for processes or procedures.

A hypertext structure comprises nodes which are linked to documentation objects.

You can display existing hypertext structures and create and edit your own structures with the structure maintenance transaction SDOCU (Tools → Hypertext → Structures → Doc. structures).
Hypertext Structure

A hypertext structure is a tree structure comprising nodes.
Each node has a title and refers technically to an object which is stored and accessed as an independent unit. The existence of the object does not depend on the structure.

A hypertext structure can contain objects of various document classes, e.g.
- Structure chapter
- Release notes
- CATT procedure descriptions.

A node can link to another structure. When you are editing a structure, structures which it contains are only visible as nodes without subnodes. The structure is only displayed with all its nodes in display mode.

As the documents are usually not displayed with the structure maintenance transaction \textit{SDOCU}, this transaction has no authorization check. The usual transaction is required to create, display and edit hypertext structures.
Create Hypertext Structure

1. Choose Tools → Hypertext → Structures → Doc. structures in the SAP menu, or enter the transaction SDOCU in the command field.
   You go to the Edit structures screen.
2. Enter the original language in which the structure is to be created, in the Language field.
3. Choose Structure → Create.
4. Enter the structure title in the Explanatory text field in the following dialog box and choose ENTER.
   The structure title is also displayed as the title of the root node.
5. Assign the structure to a development class and save it in a transport request.
   You go to in the hypertext structure editing mode with the root node.
6. To create the structure with its nodes, position the cursor on the displayed root node.
7. Choose Edit → Nodes → Enter → As subnode.
   You can only insert other nodes below the root node as subnodes. You can insert new nodes below other nodes at the same level.
8. Enter the node name in the following dialog box.
   The node is displayed in the structure with this name.
9. Two cases are distinguished when putting documents in the structure:

<table>
<thead>
<tr>
<th>Documents already exist</th>
<th>Documents are new</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on the Assign other document pushbutton to the right of the document name.</td>
<td>Enter the document class (e.g. CHAP for a structure chapter) or choose one from the F4 possible entries help.</td>
</tr>
<tr>
<td>Choose one of the listed documents.</td>
<td>Enter an alphanumeric document name of up to 20 characters.</td>
</tr>
<tr>
<td>Choose Copy.</td>
<td>Choose Create.</td>
</tr>
<tr>
<td>The name and document class of the selected document is displayed in the dialog box.</td>
<td>You go to the text editor. Enter your documentation and save it. See The documentation maintenance transaction [Ext.].</td>
</tr>
</tbody>
</table>

10. The same document can be entered at various places in the structure.

11. Specify a development class and save the document in a transport request.
   Go back to the initial screen with Back.

12. Go to the hypertext structure editing mode with Continue.
Create Hypertext Structure

11. Add nodes until the structure has the required form.

   You can add other structures as well as nodes. See Change hypertext structure [Page 9].

12. Save the structure with Structure → Save.
Change Hypertext Structure

You can change hypertext structures at any time. You can:

- Add nodes or another structure
- Delete nodes
- Edit nodes
- Move nodes in the structure
- copy nodes from the clipboard.

Prerequisites

You are in the hypertext structure maintenance and have already created one or more hypertext structures.

Procedure

1. Select a structure in your Favorites.
2. Choose the original language of the structure.
3. Choose Structure → Change or the Change structure pushbutton.

Add nodes or another structure

You can enter additional nodes or another structure anywhere in the structure.

1. Put the cursor on a node below which you want to insert the new node (structure).
2. To insert the node (structure) at the same hierarchy level, choose Edit → Nodes → (Structure) Insert → At same level.
3. To insert the node (structure) as a subnode, choose Edit → Nodes → (Structure) Insert → As subnode.
4. To insert a new node, see Create hypertext structure [Page 7].
5. To insert another structure, enter a structure name in the Link to a structure dialog box.
   The structure is inserted as a new node with this name. The name need not be the actual name of the structure.
6. You can search for the structure to be inserted with Find structure.
7. Enter the title of the structure in the following window. You can enter part of the title and choose Execute.
   The title of the structure found is displayed in a second window.
8. Choose Copy. The title is shown in the Link to a structure window.
9. Choose Copy and save the structure change with Structure → Save.
   The linked hypertext structure is only displayed as a structure node. The structure is only displayed with all its nodes in display mode.
Change Hypertext Structure

Delete nodes
1. Position the cursor on the node which you want to delete from the structure.
   
   To delete several nodes at the same time, position the cursor on each node and choose Edit → Nodes → Select.

2. Choose Edit → Nodes → Delete or Delete (selected) nodes.

   Subnodes of the deleted nodes are also deleted.

   The selected nodes are deleted from the structure without confirmation. The documentation referred to is retained.

Edit nodes
You can:

- change node text (node title in structure)
- assign another document
- change document text

1. Position the cursor on a node and choose Edit → Nodes → Change or Change nodes.

2. Make your changes.

   If you want to assign another document, you must delete the existing document name first. You can then assign a document from the list with the Assign other document icon to the right of the Document name field.

   To change the text, choose Change. You go to the text editor where you can make your changes. Save your document active. Go back to the initial screen with Back.

3. Choose Continue.

4. Save the structure changes with Structure → Save.

Move nodes in the structure
1. Position the cursor on a node and choose Edit → Nodes → Select.

   To move several nodes at the same time, position the cursor on each node and choose Edit → Nodes → Select.

   Subnodes are also selected and moved.

2. Position the cursor on the node under which you want to insert the selected node.

3. Choose Edit → Nodes → Move.

4. Specify whether the selected node is to be inserted at the same level or as a subnode.

Copy nodes from the clipboard
This function copies structure nodes onto the clipboard and from there to another location in the structure. The difference to moving is that the nodes are copied not moved.
To copy nodes onto the clipboard:

1. Position the cursor on a node and choose *Edit → Nodes → Select.*

   Subnodes are also selected.

2. Choose *Edit → Clipboard → Save selected node.*

   The selected nodes are exported to the clipboard but also remain in their original position in the hypertext structure.

3. Position the cursor on the node under which you want to insert the node from the clipboard.

4. Choose *Edit → Clipboard → Insert → At same level or As subnode.*

   The selected nodes are copied from the clipboard to the selected position in the hypertext structure.
Display Hypertext Structure

You have the following display options as well as hypertext structure display:

- Show and hide documentation key
- Display documents
- Position cursor
- Display management information
- Display object directory entry

Prerequisites

You are in the hypertext structure maintenance and have created at least one hypertext structure which is in your Favorites.

Procedure

Display Hypertext Structure

1. Select the hypertext structure which you want to display, in your Favorites.
2. Choose Structure → Display or the Structure display pushbutton.
   Only the main node of the structure and the nodes in the first hierarchy level are displayed.
3. Nodes which have subnodes are indicated by a folder symbol with a "+" sign to the left of the structure title. Expand the subnodes by clicking on the symbol. An expanded structure is identified by the folder symbol with a "−" sign. Clicking on the symbol again collapses the structure again.

Show key

You can display the technical names of the documentation objects to the right of the nodes with View → Show key in display or edit modes.

The document names are hidden again with View → Hide key.

Display document

To display a document for a structure node, click on the symbol to the left of the node title. The document is displayed in the current editor. Back goes back to the structure display.

Position cursor

This function displays the hierarchy structure from the cursor position:

1. Position the cursor on the node title whose hierarchy you want to display.
2. Choose Edit → Position or the Position pushbutton.
   The selected node is displayed as the top node on the screen.
Display management information

You can get management information about a selected structure under Goto → Display structure header data in the structure maintenance initial screen. The management information is:

- Structure creator and creation date
- Changer and change date
- Structure title
- Original language
- Structure and node type
- Structure buffering

Display object directory entry

You can display or change the object directory entry (TADIR entry) for a selected structure with Utilities → Object directory entry. The object directory entry contains:

- Object name
- Development class
- Person responsible
- Original system
- Original language

You can display other structure attributes with the Object attribute icon.
Rename Hypertext Structure

Prerequisites
You have already created one or more hypertext structures.

Activities
2. Select a structure in your Favorites.
4. Enter the new structure name in the following window and choose Continue.
   The changed structure name is displayed in your Favorites.
Translate Node Texts
You can translate all node and structure title texts into any language.

Prerequisites
You are in the Hypertext structure maintenance initial screen and have created at least one structure.

Procedure
1. Select the structure to be translated in your Favorites and choose Utilities → Translation.
2. Specify the source and target language and choose Continue.
   You go to the SAP translation interface where all node texts and the structure title are listed in the source language.
3. Enter the translation of the node text in the line below the source language.
   If there is a proposed translation for the node text it is displayed. You can copy the proposed translation into the target language with Proposal pool → Copy proposal.
4. When you have translated all node texts, save them with Translation → Save and save the translation in a transport request.

Result
When you logon to the system in the target language, the structure is displayed in this language.
Manage Favorites

The list of hypertext structures which you have edited or chosen is displayed under *My favorites* in the structure maintenance initial screen. Each newly-created Hypertext structure is automatically put in the Favorites. You can also put hypertext structures which you did not create in your Favorites.

**Procedure**

1. Choose *Favorites management* below your Favorites list.
   
   A new window with the hypertext structures which you have already selected is displayed.

2. You can:
   
   a. Put more hypertext structures in the Favorites.
   
   b. Cut out or delete hypertext structures from the Favorites.

   You can search for a hypertext structure to put in the Favorites by the following criteria:

   - Title
   - Development class
   - Owner and date of creation
   - Creation Release
   - Last person to change and date of change
   - Release of last change

3. Choose a function and confirm with *Save favorites (Enter).*

   You can also put the hypertext structures found with the possible entries help to the right of the structure names into your Favorites with the *Add to Favorites* pushbutton.
Print Hypertext Structure

You can print all or part of a hypertext structure.

Prerequisite

You are in hypertext structure maintenance (transaction SDOCU) display or change mode.

Procedure

Print displayed structure

This function prints the structure tree as it is currently displayed on the screen. Collapsed subnodes (with "+" in the folder symbol in front of the node) are not printed. The node contents (documents) are not printed.

If the technical names of the documents are displayed with View → Show key, the document names are printed.

To print the structure tree, choose Structure → Print → Displayed structure.

Print nodes with all subnodes

This function prints a set of related documents. The contents of the currently selected node and all its subnodes are printed. A contents page with page numbering is created. The documents are also numbered by their hierarchical position in the hypertext structure.

1. To print a node with subnodes, position the cursor on the node.
2. Choose Structure → Print → Node → With subnodes.

Print one node

This function prints the contents of one node, a document.

1. Position the cursor on the node.
2. Choose Structure → Print → Node → Without subnodes.
Delete Hypertext Structure

This function deletes a structure with all its nodes. To delete individual nodes from the structure, see [Change hypertext structure](Page 9).

The documents in the structure are not deleted. Before you delete a document, ensure that it is not used elsewhere. Delete documents in the document maintenance under Tools → ABAP Workbench → Utilities → Documentation (transaction SE61).

**Procedure**

1. Select the hypertext structure which you want to delete, in your Favorites.
2. Choose Structure → Create.
   
   You can cancel the deletion up to this point.
3. To delete, confirm the prompt.
   
   The entire hypertext structure with all nodes is deleted.

   The hypertext structure and its links to the objects is deleted, but not the objects themselves.
Transport Hypertext Structure

1. To transport a Hypertext structure into another system, select it in the initial screen of the Hypertext structure maintenance.

2. Choose Structure → Transport.

3. Specify an existing transport request with the User request pushbutton.
   
   If you have no transport requests, create one with Create request and save it.

4. Choose Continue.
Search Function

You can search by:
- structure
- Find Node
- document

Find Structure
If you do not know the precise name of the structure, you can display all the existing hypertext structures or a selection of structures. You can either search for a name or define further selection conditions.

1. Choose Search in the hypertext structure maintenance initial screen.
2. Specify one of the following selection criteria:
   - Structure title
   - Development class
   - Creator
   - Creation date
   - Creation Release
   - Last changed by
   - Date of last change
   - Release of last change
3. Choose Execute.
   - If you have no selection criterion, leave all fields empty and choose Execute. In this case all existing hypertext structures are listed. Select a structure from the list.
4. Choose Copy (Enter).
5. The structure title is displayed in the Structure field.
   - To copy the structure into your Favorites, click on Add to Favorites to the right of the structure title.

You can also search for structures in the Favorites management [Page 16].

Find Node
You can search for the title of a node or for several titles containing a certain term in structure display or maintenance modes. It makes no difference whether the nodes are displayed or collapsed.

1. Choose Search.
2. Enter a complete title or partial term in the dialog box.
Search Function

Do not use place holders ("**") which can interfere with the search function.

3. Specify whether you want to search for the term in the entire structure or only in the currently-displayed structure, and choose Search.
   The first node title found is highlighted.

4. Choose Find next to determine whether the term occurs in other places in the structure.
   If you position the cursor on a node title in the structure, the search is from the cursor position, otherwise it is from the last node found.

Find Document

You can search for a document in display or change mode if:
- the document key is shown (View → Show key)
- the structure is completely expanded.

To search for a document in the structure:
1. Choose System → List → Find....
2. Enter the technical name of the document in the dialog box (not the node title).
3. Specify whether to search from the cursor position or in a page.
4. Specify the number of hits after which the search is to be ended.
5. Choose Search.
   The hit list is displayed in another dialog box.
6. Click on a document in the hit list.
   The document found is marked in the structure by the cursor.