Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Caution Icon" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image" alt="Example Icon" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image" alt="Note Icon" /></td>
<td>Note</td>
</tr>
<tr>
<td><img src="image" alt="Recommendation Icon" /></td>
<td>Recommendation</td>
</tr>
<tr>
<td><img src="image" alt="Syntax Icon" /></td>
<td>Syntax</td>
</tr>
<tr>
<td><img src="image" alt="Tip Icon" /></td>
<td>Tip</td>
</tr>
</tbody>
</table>
# Contents

**BC Documentation of System Objects** ............................................................... 5
Concept ....................................................................................................................... 6
Overview ..................................................................................................................... 7
Objects that can be Documented ............................................................................... 8
Documentation Types ................................................................................................. 9
Document Classes ..................................................................................................... 11
Document .................................................................................................................. 13
Editing Status ............................................................................................................ 14
Version Management .................................................................................................. 15
Authorizations ............................................................................................................. 16
Enhancing SAP Documentation .................................................................................. 17
Documentation Maintenance ....................................................................................... 18
Overview .................................................................................................................... 19
Documentation Maintenance in the ABAP/4 Development Workbench ...................... 20
Maintain Documentation in the F1 Help ...................................................................... 21
Documentation Maintenance Transaction .................................................................... 22
  Editing a Single Object ............................................................................................. 23
  Creating and Editing a Selection List ......................................................................... 24
  Creating and Editing a Work List ............................................................................. 25
  The "Not Required Documentation" Flag ................................................................... 27
  Editing a Document – the Documentation Editor .................................................... 28
  Administrative information on documents and objects ............................................. 31
  Data Element Supplements ...................................................................................... 33
  Use of Parameters in Message Documentation ....................................................... 35
  General Texts as Text Modules .............................................................................. 36
  Links to other Objects ............................................................................................. 37
*Maintaining short texts* ............................................................................................ 38
Output Documentation ................................................................................................. 39
Copying Documents .................................................................................................... 41
Deleting Documents ..................................................................................................... 42
Enhancing SAP Documentation .................................................................................. 43
Transporting Documentation ....................................................................................... 44
Statistics ...................................................................................................................... 45
BC Documentation of System Objects
Concept

This section contains basic information about the concept of object-oriented documentation.

Overview [Page 7]
Objects that can be Documented [Page 8]
Documentation Types [Page 9]
Document Classes [Page 11]
Document [Page 13]
Editing Status [Page 14]
Version Management [Page 15]
Authorizations [Page 16]
Enhancing SAP Documentation [Page 17]
Overview

Various elements of the interface as well as components of the ABAP/4 Development Workbench can be documented directly in the system. This documentation can be accessed with the F1 key or by using the special menu options or function keys within a specific application. This facilitates working with the application and reduces the need to consult information on external media (such as manuals). The use of objects such as data elements or error messages is clearly described, thus enabling a better overview of the ABAP/4 Development Workbench.

The documentation is managed in a separate database and can be edited with a special maintenance transaction. Activated documents are released for translation.

The document texts are displayed in your logon language.

In addition to the online documentation on objects, online documentation on applications is also available in the form of online books that are created as hypertext (Tools → Hypertext → Structures or Maintain module).

The following documentation explains how you can document objects in the R/3 System. First the fundamental concepts are introduced and then handling the documentation maintenance transaction is described.
Objects that can be Documented

In the R/3 System, objects which can be documented are either interface components, such as data elements and messages, or components of the ABAP/4 Development Workbench, such as function modules and corrections. Documents with explanatory text can be created for these objects.

Using the maintenance transaction, however, it is also possible to create documents that do not refer to any object in the system. Examples of this type of documentation are Release Notes, general texts (which can be included as text modules in other documents) or chapters of online books. Documents of this type represent independent objects in the system.
Documentation Types

To allow customers to create both their own documentation and to modify SAP originals, the following documentation types are distinguished:

- **Original**
  
  documentation created by SAP has the type "original". If you write documentation development objects of your own, these are also considered as originals.

- **Modification**
  
  If you want to write documentation on objects for which SAP originals already exist or which have been marked as "not for documentation" you can create the document type "modification". In the help display this document is superimposed on the original document without technically deleting it.

  In cases where SAP objects were delivered without documentation or were not marked as "not requiring documentation", the customer documentation is stored as an "original" document type. Keep in mind, that your documentation can be overwritten by a Release upgrade, if SAP delivers subsequent documentation.

  When you create a modification you have three options:
  - You can write a completely new, independent text.
  - You can copy in the original text and add to it.
  - You can integrate the original as an INCLUDE and add to it.

A further distinction is made between the following types of documentation:

- **End user documentation**
  
  These are help texts that are required for working with applications:
  - Input/output fields
  - Messages
  - ABAP/4 syntax documentation
  - Release Notes
  - and so on.

- **Technical documentation**
  
  These are help texts that describe ABAP/4 Development Workbench objects required for developing programs:
  - Domains
  - Function modules
  - Corrections
  - and so on.

The following four types of documentation exist:
Documentation Types

- Original - end user
- Original - technical documentation
- Modification - end user
- Modification - technical documentation
Document Classes

The document classes normally indicate the type of object that is to be documented. However, some document classes do not refer to any type of object. These classes have an independent existence as system objects in their own right. Examples are Release Notes, chapters of online manuals and “general texts” that can be included as modules in other documents.

The various document classes are either assigned to documentation type technical documentation or end user documentation. You can maintain modules of type end user documentation with the documentation maintenance transaction. The modules of type technical documentation are edited in the relevant maintenance transaction for the object type in question, for example for function modules and their parameters in the function library.

The most important document classes are listed here:

**End user documentation**
- General text
- Authorization object
- Authorization profile
- Data element
- Data element supplement
- Chapter in a structure
- Message
- Release Note
- Report
- ABAP/4 syntax documentation
- System log
- Text in dialog
- ABAP/4 environment
- etc.

You can obtain a complete list in the maintenance transaction by pressing the F4 help key on the field for the document class.

**Technical documentation**
- Domains
- Function modules and parameters
- Function module exceptions
- Correction transport requests
- Tables
- etc.
Document Classes
Document

The document contains the documentation text and is assigned to a particular document class. When you write a document the standard heading for the specific document class is shown.

In general, the documentation on an object consists of a single document. In the following situations it could, however, be comprised of more than one object:

- **Data element supplement** for a particular screen
  The document for a data element, containing the data element definition, can be supplemented by a document belonging to the class of data element supplements.

- **INCLUDE**
  Documents belonging to the class of general texts can be included at any location, i.e. in documents of all classes.

- **Link**
  A document can contain a link to another document offering users the option to request further information if required. This referenced document can in turn contain a further link or include a general text.
Editing Status

The editing status indicates the stage that editing has reached and is determined when the document is saved. To save the active version of a document, a special authorization is required.

A documentation object or element can have the following editing statuses:

- **Object without documentation**
  As yet no documentation has been written for this object.

- **Object does not require documentation**
  The object does not require any documentation for one of the following three reasons:
  - the object does not appear on a screen
  - the short text describes the object adequately
    This refers only to the definition itself. Information applying to specific screens, such as the procedure, can be stored in data element supplements.
  - object does not currently require documentation
    The object is, for example, in a test phase or is being used temporarily.

- Document in **raw version**
  The document is being revised. The raw version of a document may not be transported.

- **Document is active**
  Editing has been completed and the document has been saved as active version. Thereby, the version is finalized and released for transport and translation.

  Documents that have the editing status “final version”, which was used in previous releases, can be included in a work list and edited. But you can save them only as raw version or as active version.
Version Management

The purpose of retaining versions is to inform the translator of any changes that have been made to existing documents and to create an editing history.

A version is considered to have been finalized when the document in question is saved as active. The active version is released for translation.

When you edit and save an active document again, the version number is incremented. This happens irrespective of whether or not a text change has been made.

When you save an already active document again as active, the version number is incremented only if you declare the change made to be translation-relevant.
Authorizations

The authorization check distinguishes between the following:

- Maintenance in *raw version* status
  
  This authorization allows users to create and maintain documents with the raw version status throughout the system, i.e. in all development classes.

- Maintenance in *active version*
  
  This authorization allows users to create and maintain documents in active version for a specified development class or for a selection of development classes. It includes the authorization for maintaining documentation in the raw version.

These authorizations are assigned to the user via profiles which are entered by the system administrator into the user master record.
Enhancing SAP Documentation

Customers can document their own objects and they can modify or enhance documentation of SAP objects. When maintaining SAP documentation, you have the following options:

- **Maintaining originals**
  Your modifications are lost after release upgrades.

- **Creating enhancements**
  - You can create your own documentation independently from SAP documentation (Changes to SAP documentation are not effective after a release upgrade).
  - You can copy SAP original documentation and change it as required. (Changes to SAP documentation are not effective after a release upgrade.)
  - You can include SAP original documentation and add your own documentation. (Changes to SAP documentation remain effective after a release upgrade and customer enhancements are preserved.)

If a customer enhancement exists for documentation with the editing status active, this will be displayed by the help system. If the customer enhancement is deleted, the SAP documentation will be displayed again in its place.

Enhancements can be written in any language. They are independent of the original language of the SAP documentation. They cannot, however, be translated in the system.

You can either supplement existing SAP documentation or write your own fully independent customer documentation.
Documentation Maintenance

This section explains how you can maintain documentation in the system.

Overview [Page 19]
Documentation Maintenance in the ABAP/4 Development Workbench [Page 20]
Maintain Documentation in the F1 Help [Page 21]
Documentation Maintenance Transaction [Page 22]
Editing a Single Object [Page 23]
Creating and Editing a Selection List [Page 24]
Creating and Editing a Work List [Page 25]
The “Not Requiring Documentation” Flag [Page 27]
Editing a Document – the Documentation Editor [Page 28]
Administrative information on documents and objects [Page 31]
Data Element Supplements [Page 33]
Use of Parameters in Message Documentation [Page 35]
General Texts as Text Modules [Page 36]
Links to other Objects [Page 37]
Maintaining short texts [Page 38]
Output Documentation [Page 39]
Copying Documents [Page 41]
Deleting Documents [Page 42]
Enhancing SAP Documentation [Page 43]
Transporting Documentation [Page 44]
Statistics [Page 45]
Overview

Technical documentation for an object can only be maintained directly in the ABAP/4 Development Workbench. To do this, call the appropriate maintenance transaction for the system object in question. For example, in the case of domains, this is the Dictionary and in the case of function modules, this is the function library.

In addition, there is also a separate maintenance transaction that can be found under Tools → ABAP/4 Workbench → Utilities → Documentation. This maintenance transaction allows you to maintain all document classes of the type "end user documentation".

The documentation maintenance transaction allows you to both edit and manage documents. The editor used is SAPscript. You can edit objects individually or in a work list which groups objects together according to certain criteria.

Accessing Documentation Maintenance

There are various different ways of entering and maintaining documentation:

- during object maintenance in the ABAP/4 Development Workbench
- with display help texts via the F1 key
- with the documentation maintenance transaction

These different approaches are dealt with in greater detail in subsequent sections.

Authorizations

Whichever approach you choose, an authorization check will take place.

If you are authorized for raw versions, you will be able to create and edit raw versions of documentation throughout the system.

The authorization for active versions applies to a particular development class or set of development classes. You are authorized to edit raw and active versions of all modules in the assigned development classes.

You can display the authorization values you have been assigned in the initial screen of the maintenance transaction by selecting Utilities → Authorizations.
Documentation Maintenance in the ABAP/4 Development Workbench

In the ABAP/4 Development Workbench you can maintain all document classes that refer to objects in the ABAP/4 Development Workbench. This can be done when you create objects. For “technical” documentation this is the only possible approach.

You can access this function from object maintenance via a menu function with name Long text or Documentation. You will generally find this function as a pushbutton or under the menu option Goto. In the ABAP/4 Dictionary, for example, you can enter documentation for the data element or domain you are currently working on by selecting Goto → Documentation.

When you select this function, the SAPscript editor is called with the setting allowing you to maintain the object in question. After saving your text, you can return to the original object maintenance transaction.
Maintain Documentation in the F1 Help

You can maintain document classes that are displayed in the F1 help (e.g. data element and message) directly from the help window. Irrespective of how the F1 help is displayed (in a modal or modeless window), you can call the function Maintain directly with the F7 key. Alternatively, in the modal help window you can press the right mouse button to obtain a list of the available functions and then select Maintain, or, in the modeless help viewer, you can press the corresponding pushbutton in the standard toolbar.

You get directly to the SAPscript editor for maintaining the displayed document. Once editing is complete, you return to the help display. To display the new version you need to call F1 help again.

This approach is recommended for testing and revising documentation. It also permits to create and maintain Data Element Supplements [Page 33] which are linked to the relevant input/output field on the specific screen where help was requested. This link is based on a table entry which is made by the system if you use this approach to enter your documentation.
Documentation Maintenance Transaction

The documentation maintenance transaction provides the functionality required for maintaining and managing documents.

The initial screen allows you to change the following settings:

- **Document class**
  Choose the document class for editing a single element or a selection list.

- **Documentation type**
  Set the documentation type to specify whether originals or modifications will be maintained.

- **Language**
  Choose the language in which you wish to write the documentation. Note that an already created document can only be maintained in its original language.

To change one of these settings, position on the relevant output field, press the F4 key and select the desired entry.

You can edit documents using the following options:

- **Editing a single object**
  To do this you need to enter the exact name of the document in the initial screen.

- **Selecting from a list**
  If you are unsure of the precise name of the document you require, or if you want to edit several documents with similar names, you can create a selection list for the document class specified by entering the first characters of a document name followed by the wildcard `*`.

- **Selecting from a work list**
  A work list represents the complete set of all objects and documents that correspond to certain selection criteria at the time at which it is generated. It can be saved for repeated use.

  If system objects are added or deleted after the work list is generated, these are not taken into account anymore. For this reason, it is necessary to refresh a work list from time to time.

  You can create or delete any number of work lists.

  Since work lists are specific to a user, overlapping with work lists belonging to other system users cannot occur.
Editing a Single Object

In the initial screen of the maintenance transaction, enter the name of the object for which you want to maintain documentation. Then select the appropriate button for the type of editing you wish to perform.

Pushbuttons for the following types of editing are available:

- Change
- Create
- Display
- Copy
Creating and Editing a Selection List

Using a selection list for maintaining documentation enables you to:

- work on a set of **documents of a document class** in context
- select objects or documents according to their **editing status**:
  - Objects not requiring documentation
  - Undocumented objects
  - Raw version documents
  - Final version documents
  - All documents (documents in raw, final, or active version)
- label undocumented objects as "**not requiring documentation**"
- print a list of the documents or objects selected with administrative information

To edit a selection of documents, proceed as follows:

1. Choose the desired document class in the document class field using the Possible entries pushbutton or \F4\.
2. Enter the object name generically by using the wildcard "*" on the right to represent any number of characters. (e.g. for messages you could enter the application area "XY" and the number "***").

⚠️

If you want to list all the supplements for a data element, you must enter the character "**" in the name of the data element. You cannot enter "***" in the field for the supplement number.

3. Select the **Change** function. A dialog box for selecting the editing status of the objects appears.
4. In the dialog box, first select the editing status, or statuses, and then **Continue**. The object list is displayed on the screen.
5. Select the document you wish to edit from the displayed list by positioning the cursor on the element you require and activating the **Select** function or by double-clicking with the mouse on the appropriate line. You will then branch to the editor.

After you have finished editing the document, you can return to the list where you can select further objects for editing.
Creating and Editing a Work List

Using a work list for maintaining documentation enables you to:

- work on a larger set of **documents of various document classes** in context. You can define that set by specifying various selection criteria.
- maintain short texts for the objects in your work list by double-clicking on the short text displayed in the work list overview. This will get you to the maintenance transaction for the respective object.
- use the following **print output options**:
  - print a list of the documents or objects selected with administrative information
  - Documentation in edited form with INCLUDES
  - Documentation with editor formatting and expanded links.

You can use the following selection criteria when creating a work list:

- **Editing Status**
  - Objects not requiring documentation
  - Undocumented objects
  - Raw version documents
  - Final version documents
  - Active documents
- **Environment for Work List**
  - Development class
  - Transaction
  - Program
  - Table
- **Document Class**
  You can choose document classes from the list available for end user documentation.

Creating a Work List

1. In the initial screen of the documentation maintenance transaction, select the menu function **Utilities → Work list**.
2. Select one or more editing statuses (editing status "objects not requiring documentation" can only be selected on its own).
3. Under "Environment for work list", select an environment.
4. Press **ENTER** or click on the OK pushbutton in the standard toolbar. A dialog box appears in which you can enter the name of the selected environment.
Creating and Editing a Work List

5. Specify the name of the environment (development class, program, etc.) and select "Continue." A further dialog box for selecting document classes appears.

6. Select the document classes you require and then "Continue." The desired work list is generated.

7. Save the work list you have generated with menu function "Work list → Save."

With large development classes containing many objects the generation of a work list may take a while. Therefore, if you want to work on a work list repeatedly you should save it.

Using an Existing Work List

1. In the initial screen of the documentation maintenance transaction, select "Utilities → Work list" to branch to the initial screen for a work list.

2. Select one or more editing statuses (editing status "Objects not requiring documentation" can only be selected on its own).

3. Select the "Work list" option under the heading "Environment for work list".

4. Press "ENTER" or click on the OK pushbutton in the standard toolbar.

5. A dialog box appears. Enter here the name of the work list you wish to use and select "Continue."

You can also make a generic entry using the wildcard * to create a list of saved work lists. You can then select a work list of your choice for editing or deletion.
The “Not Requiring Documentation” Flag

Some objects do not require any documentation. There can be several different reasons for this:

- An object is temporarily not to be documented.
- An object is described adequately by its short text.
- A data element does not appear on any screen.

You can label such objects as "not requiring documentation". This indicator has the effect of locking objects so no documentation can be written for them. It also means that they are no longer considered as "undocumented" objects by the documentation management system (in work lists, for example).

This indicator can be removed again, if required.

Setting the Indicator

To indicate that an object does not require documentation, proceed as follows:

1. Generate a list of undocumented objects (in the form of either a generic list or a work list) containing the object you wish to mark as not requiring documentation.
2. Position the cursor on the object you wish to assign the indicator to.
3. Select one of the following three functions:
   - currently without documentation
   - self-explanatory
   - without screen reference

Removing the Indicator

1. Generate a list of objects not requiring documentation (either in the form of a generic list or as a work list) that contains the object with the indicator.
2. Position the cursor on the object whose indicator you wish to remove.
3. Select the function Reactivate object.
Editing a Document – the Documentation Editor

You can use the SAPscript editor to edit a document. The functionality of the editor has been enhanced in the documentation maintenance transaction. You can find functions specifically meant for maintaining documentation under the menu options Document, Goto and Details.

In the following sections the most important steps for editing documents are explained. For further information on word processing in SAPscript, please refer to the documentation on SAPscript.

Enter Text

When you create a new document, the appropriate standard heading for the document class automatically appears. If you like, you can enter text for individual headings. Headings that are not used are suppressed from the help screen display.

To insert text between chapter headings or existing text, select the Insert function or press the F5 function key. This takes you into a separate editing area where you can then enter a text. When you have finished entering your text, select the function End insertion or press the F5 key again. This returns you to the original screen. The text you entered is now integrated into the existing text.

If you simply want to insert short passages into gaps or add text to the end of your document, you can do this directly. Use the ENTER key to start a new paragraph.

You can select passages of text by double-clicking with the mouse on the first and last characters. The first and last characters of the selected text string are displayed in round brackets in the status line of the editor. On selected text you can perform the following functions:

- Delete
- Cut and Paste
- Copy and Paste.

You can place selected text in three user clipboards (Display with Goto → User clipboard) and include the stored text elsewhere in your document, or in another document (Include → Clipboard).

The user clipboard

If you want to copy longer pieces of text into other documents, you can use the user clipboard 1, 2 or 3. Proceed as follows:

1. Select the text section which you want to copy, by double-clicking on the first, and then on the last line. The selected lines are highlighted and the first and the last character is displayed at the bottom of the screen in brackets.

2. Choose Edit → Selected area → User clipboard → Clipboard_1 (or Clipboard_2 or Clipboard_3). The selected text is copied onto the specified clipboard and is kept there until another text is copied to the same clipboard.

3. Position the cursor in the destination document at the position at which the text is to be inserted, and choose Include → Clipboard → User clipboard → Clipboard_1 (or Clipboard_2 or Clipboard_3). The text is inserted.
Formatting

When you create a document, it is linked automatically to a standard style sheet. Formats for paragraphs and characters are defined here. The style sheets are managed by a separate maintenance transaction (Tools → Word processing → Styles).

To see which formats are available in the standard style, select Format → Character... or → Paragraphs.... To find out how a particular format is defined, position your cursor on the format you are interested in and select the function Attribute.

Use character formats to highlight areas of text through use of a particular font. To format an area of text, proceed as follows:

1. Select the block of text by double-clicking with the mouse on the first and last characters.
2. Select Format → Character to obtain a selection list of available fonts.
3. Position the cursor on the format you require and activate Select.

If you know which format you require, you can of course make the necessary entries by hand. Note that the representation on the screen is different to the printout.

The standard use of fonts at SAP is shown below:

- **<ZH> Emphasis**
- **<LS> Menu options/functions** (emboldened for F1-help))
- **<LB> User entries**

Paragraph formats format a complete section of text right up until the beginning of the next paragraph format. The procedure is as follows:

1. Select the paragraph you require by double-clicking with the mouse (anywhere within the paragraph).
2. Select Format → Paragraphs to obtain a list of available paragraph formats that can be selected.
3. Position the cursor on the paragraph you require and activate Select.

If you know the paragraph tag you require, you can simply overwrite the existing tag in the field to the left of the text input area. To start a new paragraph, press ENTER. A new paragraph with the same format as the previous paragraph is created.

The standard use of paragraph formats at SAP is shown below:

**AS** Standard paragraph

- **B1** First level list of equal elements with indentation of following lines
  - **AL** Paragraph following B1 and N1
    - **B2** Second level list of equal elements with indentation of following lines
      - **BL** Paragraph following B2 and N2
  1. **N1** Ordered list at the first level and indentation of following lines
    a) **N2** Ordered list at the second level with indentation of following lines
Editing a Document – the Documentation Editor

When you use the paragraph format N1 or N2, you have to initialize the counter after completing the list (e.g. when printing several documents or if there are several lists within a single document), otherwise the counter is continually incremented.

1. Enter /: in the paragraph column.
2. Enter RESET N1 or RESET N2 in the adjoining text area.

Checking format and layout

To check the format and layout of the document, choose function Document → Screen output. You can do this without saving the document first.

Save

When you save, you can select the editing status in which the document will be stored.

- **Raw Version**
  
  To save, either select the Save pushbutton in the standard toolbar or Document → Save → Raw version in the menu bar.

- **Active Version**
  
  To save, either select the pushbutton Save active in the application toolbar or Document → Save → Active version in the menu bar.

  Raw version documents are not transported.
  Active version documents are transported and released for translation.

  (see also Editing Status [Page 14] and Version Management [Page 15])

If the edited object is not yet contained in a change request, you are prompted in a dialog box to enter a change request, or to select one from a list (F4 possible entries, or pushbutton User requests).
Administrative information on documents and objects

You can access the following administrative information during word processing in SAPscript:

- **Document**
  - short text
  - document class
  - language
  - documentation type
  - editing status
  - version number
  - master language indicator ("X" = language is master language)
  - development class
  - created by/created on
  - last changed by/changed on

Call function *Extras → Information → Documentation object.*

A dialog box with the above information appears.

- **Where-used list for data elements**
  - program
  - screen number
  - table
  - field
  - screen display

Call function *Extras → Where-used list → Data element.*

A list of screens in which the data element is used is displayed. If you double-click with the mouse on the appropriate line, a schema of the screen is displayed. The line containing the data element in question is highlighted in a different color.

You can also generate this where-used list during work with a generic list or work list. To do so, position the cursor on the appropriate data element and select the function *Goto → Screen list* or press the pushbutton *Screen list* in the application tool bar.

Only those screens generated with the screen maintenance transaction (Screen Painter) are included in such a list. This means that you cannot check the use of data elements in selection screens or list screens.

- **Version history**
  - Document class
Administrative information on documents and objects

- Object name
- Language
- Version number, documentation type, editing status, changed by, date

Call function *Goto*  →  *Version history*

A window displaying the above information appears.
Data Element Supplements

Documents for data element documentation normally only contain the chapter heading "definition". The user often requires more information on how to make an entry in a field. The data element supplement can be used for this. It contains the following headings:

- Use
- What_to_do
- Examples
- Dependencies

Standard Supplement

The standard supplement is included directly in the document for the data element. It is displayed each time you call F1 help for this field.

Procedure

1. From the SAPscript editor, in the data element documentation, select Extras → Chapter headings → DE standard supplement. The headings listed above are added at the end of the document.
2. Enter the text you require and save it.

Supplements for particular screens

A data element is often used in different ways in different screens. This makes it necessary to provide the user with specific information on the different uses of the data element.

For this purpose you can create a supplement for each screen or for each field in a screen where the data element is used. This is displayed only when you call F1 help on the respective field and screen in the respective program.

If a standard supplement already exists for the data element, it will be overwritten by the screen-specific supplement.

Procedure

1. Go to the relevant screen and activate F1 help on the relevant input/output field.
   The help text is displayed in a help window.
2. In the help window, select Maintain or press F7.
   In a dialog box you can now choose whether you want to maintain the documentation of the data element or a data element supplement. If no data element supplement does yet exist for this field, the option Data element is selected.
3. Select the option DE supplement and enter a number (with leading zeros). Make sure the flag assign automatically is set.
4. Press ENTER or the OK button to get to the documentation editor.
5. Enter your text and save the document.
   When the document is saved, a table entry is created which links this data element supplement with the associated screen field in this program.
Data Element Supplements

You are prompted for a change request number in a dialog box. In the change request, an entry is made for the document and another one for the table entry linking the document to the screen field.

Any further links you may want to specify between data element supplements and screen fields of this program are also transported with this entry.

Alternatively you can proceed as follows:

1. In the initial screen select the document class data element supplement.
2. Enter the name of the relevant data element and a number (with leading zeros) and press **ENTER**. You branch to the Editor.
3. Enter the text and save it.

In this case, you must create the link between the data element supplement and the screen field manually:

1. Call table maintenance with (System → Services → Extended table maintenance).
2. Enter “THLPF” for the table name and select **Maintain**. The table is displayed and can be edited.
3. Select the option **New Entries** to obtain a new line that is ready for entry.
4. Enter the link data. Values that need to be entered are:
   - **Program name**
   - **Screen**
     - Screen number
   - **Field name**
     - Table name and fieldname, connected by a hyphen
   - **DeSs**
     - Data element supplement number

You can obtain the program, screen, and table field data via the Technical Info function on the help screen for the field in question.

5. Save your entries. You are prompted for a change request number in a dialog box. Display all your requests with **Own requests**. Choose one of these requests, or create a new request with **Create request**.
Use of Parameters in Message Documentation

If, when a message is called in a program, it is accompanied by parameters, that are intended to supplement the display of the message, you can use these parameters in the documentation too. Address the required parameters in the text with "Vn", where "n" stands for the ranking of the parameter in the message call. Enclose the parameter call with "&" characters.

If, for example, you wish to use the second parameter of a message in the documentation, write in the editor:

... the object &V2& could not be found...
General Texts as Text Modules

General Texts as Text Modules

If you want to be able to use a section of text more than once, you can store it in a text module. You can then insert it wherever you require by means of an INCLUDE statement. Text modules are documents which do not refer to any object. They are stored in the system as independent system objects and are also transported as such. Consequently, when you create such an object, you must assign it to a development class. Proceed as follows:

1. In the initial screen of the documentation maintenance transaction, select document class "General texts".
2. Enter a name for the text module. You should attempt to adhere to the following naming convention:
   a) 1st position: "Y" or "Z" (indicates that the text is a "general text" belonging to the customer)
   b) 2nd and 3rd position: code for the document class
   c) 4th position: underscore "_"
   d) from the 5th position: name reflecting the contents of the document
   Example: NA_CHECK_ENTRY

   The umlaut or special characters other than the underscore "_" may not be used.

   General texts can be included by all users of the system. The assignment of descriptive names is recommended, to enable existing modules to be used effectively.

3. Enter the text you require and save the module.
4. Include the module you have created at the relevant place in your text:
   a) Position the cursor on the desired location.
   b) Select Include → Text → Documentation.
   c) Enter the name of the module in the dialog box.
   d) Check that the text was correctly included by executing the screen display with Documentation → Screen output.

Avoid using headings as this restricts the general usability of the text.

If you want to work in a multilingual system, that is, you want to be able to translate documentation, you will need to pay attention to the following:

Text modules are translated as independent units. Therefore, no reference should be made to the text that precedes or follows on from a module. Generally, texts stored in text modules must therefore be logical units of information which can stand on their own.
Links to other Objects

You can include links in your text that allow users to see other documents or to execute actions. Two types of links are provided:

- Displaying another document
- Executing an action

Text for which a link exists is highlighted. The user can follow the link by clicking on the highlighted text (hotspot) in the help display.

To insert a link in your document, proceed as follows:

1. Position the cursor to where you want to insert the link.
2. Choose Include → Link. A dialog box for selecting the type of link appears.
3. Select a document class or action in the Link target type field.
4. Enter the name of the object you want to link to and the text you want to insert in your document as a hotspot (Link text).
5. Choose Continue. The link is inserted into the text.
6. Test the link: Choose Document → Screen output and double-click on the highlighted text.
Maintaining short texts

The documentation maintenance transaction is primarily used for creating and editing long texts that describe system objects. All system objects have short texts created by the system developer in the ABAP/4 development workbench. You can edit short texts of objects that you are working on in the documentation maintenance transaction:

- from the documentation editor
  by selecting the function Goto → Maintain short text
- from a work list
  by double-clicking on the short text of the respective object
Output Documentation

You can output documentation texts both to the screen and to the printer. The screen output can be used to check the layout. To do this, call Document → Screen output in the SAPscript editor.

Printing a Single Document

To print the document you are working on in the documentation editor, call function Document → Print.

You can also enter the name of a document in the initial screen of the documentation maintenance transaction and print it with the function Document → Print or the corresponding pushbutton. In this case, the printout also includes an object’s short text.

Printing a Selection of Documents

You can print any selection of documents with the aid of a work list.

The work list may be generated for a selected editing status, document class or environment. You can display the work list in full or only for a particular editing status.

To execute the output function, select Work list → Print in the work list. In the dialog box, select one of the following:

- **Documentation: formatted**
  Output corresponds to the screen display

- **Documentation: SAPscript format**
  Output corresponds to display in SAPscript editor

More output functions

In the initial screen of the maintenance transaction, select Document → Output to call the following print output functions:

- **Document class**
  This function allows you to output all elements in a document class or a generic selection of elements from the class irrespective of editing status.

- **Environment**
  This function allows you to make the same selection as when you print a work list.

- **Table manual**
  This function allows you to print the documentation for the fields of a table.

Printing a List of Documents or Objects that can be Documented

There are two methods available for printing a list of names of documents or of objects that can be documented:

- **Work list**
  In the work list choose Work list → Print and select the option "Work list" in the dialog box.
Output Documentation

- Selection list
  
  In the selection list, choose the *Print* function.
Copying Documents

In the initial screen of the maintenance transaction you can use the Copy pushbutton to copy any document to another document. This other document may belong to all classes. A dialog box appears for specifying the source, target and editing status in which the target module will be stored.

The copy function is also available when you are working in the editor.

Documents can be copied in two directions:

- **From within the source element** (only within a single document class)
  
  From within the element you want to copy, select *Document → Save as*....

- **Into the target element** (irrespective of document class)
  
  Choose the element to which you want to copy and select *Document → Copy from*.... In the following dialog box, you can enter the document class and the name of the document.
Deleting Documents

You can delete documents in various ways:

- **In the initial screen of the documentation maintenance transaction**
  Select the document class and enter the name of the document. Then choose `Document → Delete`.

- **In the work list**
  Select the document you want to delete and choose `Delete`.

- **In the SAPscript editor**
  To delete the current document, choose `Document → Delete`.

When deleting documents, the following rules apply:

- **Delete all languages**
  If you delete the document in the original language (that is, if the field `Master language` is marked in the SAPscript editor under `Details → Information → Documentation object`), the document will be deleted in all languages.

- **Delete foreign language**
  If you delete the document in a foreign language (that is, if the field `Master language` is not marked in the SAPscript editor under `Details → Information → Documentation object`), the document will only be deleted in the current language.
Enhancing SAP Documentation

If you want to write your own documentation for an SAP object you have the following options:

- **You can maintain the original documentation:**
  
  If you select the *Maintain* function on the help screen, the original text is displayed for you to maintain. However, your changes will be lost at the next Release upgrade.

- **You can create a document of type "Modification user" for this object:**
  
  This document overwrites the SAP documentation in the help screen. To achieve this the document must be active. Raw versions are not displayed.

Procedure for creating an enhancement

1. Call the initial screen of the documentation maintenance transaction.
2. Select the documentation type *Modification user* via the F4 help function.
3. Select the appropriate document class in the same way.
4. Enter the name of the document you wish to enhance.
5. You must now decide whether you want to create a complete new document of your own or whether you want to use and enhance the existing SAP documentation. You have the following options:
   - If you simply want to enhance the SAP documentation, select the option *Make SAP documentation available as an INCLUDE*. With this option, any changes made to the SAP documentation will remain effective after a release upgrade.
   - If you want to use the SAP documentation, but wish to edit and store it separately, select the option *Make SAP documentation available as expanded text*. In this case, any changes made to SAP documentation will no longer be effective after a release upgrade.
   - If you want to write your own documentation which is completely separate to the SAP documentation, do not select either of the two options

6. Press **ENTER** or click on the OK button in the standard toolbar to go to the editor.
8. Save the document as active version.
Transporting Documentation

Documents are either objects in their own right (general texts, online manuals, release notes) or object components (all other types of element).

Elements that exist as independent objects are always transported directly. Elements existing as object components can be transported either on their own as object components or together with the main object.

A document cannot be transported until it has active version status. Raw versions are rejected by the transport system.

This only applies to documents of the type “user”. Technical documentation is transported as a raw version.
Statistics

You can perform a statistical analysis of the documentation in one or more development classes. This analysis refers to document classes of the end user documentation type. Technical documentation is not included in the statistics.

To call the statistics, select Utilities → Statistics. You can choose as follows:

- **Development class**
  - You can specify exactly one development class
  - You can specify a development class generically (e.g. ZZ*)
  - You can specify a development class range e.g.
    - Development class ZZAA
    - to Development class ZZBB
      All development classes in this range are evaluated.

- **Language**
  You specify here, in which language the documentation is to be evaluated.

- **Documentation type**
  You can choose here whether you want to evaluate the original or extensions.

- **Buffer size**
  This input adjusts the internal data read space to the current hardware platform. The default value need not usually be changed.

- **Only original system**
  With this option, you can ensure that – particularly when using generic evaluations, or evaluations for a development class range – only development classes are evaluated, whose original system is the current system.

As generic evaluation generally makes great demands on the System, background processing is allowed. You must first create variants:

2. Enter the program name RSTWGZS2.
3. Choose Goto → Variants.

For further details, refer to the program documentation, which you can display with Help → Extended help in the program selection screen.