Terminology and Glossary in SAPterm (BC-DOC-TER)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of InFox Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Caution</td>
</tr>
<tr>
<td>📝</td>
<td>Example</td>
</tr>
<tr>
<td>📄</td>
<td>Note</td>
</tr>
<tr>
<td>📚</td>
<td>Recommendation</td>
</tr>
<tr>
<td>⌨️</td>
<td>Syntax</td>
</tr>
<tr>
<td>💡</td>
<td>Tip</td>
</tr>
</tbody>
</table>
# Contents

Terminology and Glossary in SAPterm (BC-DOC-TER) .................................................. 5
General Information ........................................................................................................... 6
User Settings ....................................................................................................................... 8
Adding Additional Languages to User Settings ................................................................. 10
Finding Terms .................................................................................................................... 11
Results List ......................................................................................................................... 13
Terminology Concept ......................................................................................................... 15
Index Entries ....................................................................................................................... 18
Creating Terms .................................................................................................................. 20
Creating and Maintaining Terms for Non-Core Developments ....................................... 22
Maintaining Terms ............................................................................................................ 23
Maintenance Dialog: Maintain Entry ................................................................................ 25
Adding an Additional Application Component to an Existing Term ............................... 29
Entry Classes ..................................................................................................................... 31
Grammar Information ....................................................................................................... 34
Additional Information ....................................................................................................... 39
Source Information ............................................................................................................ 44
Creating Links to Source of Term .................................................................................... 46
Maintaining Other KW Contexts ...................................................................................... 49
Superuser Functions in SAPterm ..................................................................................... 52
Status Maintenance .......................................................................................................... 53
Displaying and Maintaining Term Status ......................................................................... 56
Maintaining Term Status for Target Language Terms ..................................................... 58
Deleting Terms ................................................................................................................. 61
Deleting Target Language Terms .................................................................................... 62
Translation in SAPterm ..................................................................................................... 64
Translating Individual Terms ......................................................................................... 65
Translating Terms Using a Worklist ................................................................................ 67
Translating Index Entries ................................................................................................. 71
Translating Glossary Definitions ...................................................................................... 75
Glossary in SAPterm ......................................................................................................... 78
Creating and Changing Glossary Definitions ................................................................. 79
Translating Glossary Definitions ..................................................................................... 81
Utilities in SAPterm .......................................................................................................... 84
Downloading Terminology from SAPterm .................................................................... 85
Creating Glossary Lists .................................................................................................... 88
Calling Up Statistics in SAPterm .................................................................................... 90
General Information

The SAPterm data structure is "concept-oriented". SAPterm is compatible with commercially available terminology databases, which are also concept-oriented.

Concept-orientation means that a concept is an abstract linguistic entity. A concept is defined by entries in various languages.

A SAPterm concept has the following global attributes:

- Application component to which this concept applies
- Translation-relevance (which is indicated by its entry class [Page 31])
- Links [Page 46] to SAP objects and documentation, for example data elements, or Knowledge Warehouse documentation.

Each entry also has attributes:

- Language
- Valid Release range
- Country-specific entry
- Industry sector-specific entry
- Grammatical attributes

A concept is a closed object. Concepts only have internal relationships, there are no relationships between concepts.
In contrast to a dictionary, you can search for the translation of a term in any language in a concept-oriented terminology database.

Concept-oriented terminology databases are particularly appropriate for managing technical terminology. It is less useful for managing a colloquial dictionary.
User Settings

Use
If you work frequently in SAPterm, you can set defaults that best fit the way you work with the User settings function.

Maintenance of the user settings is a prerequisite for using SAPterm.

Functions
You can make the following settings:

- **Display**
  You can choose between **Monolingual** (terms appear in the source language only) and **Multilingual** (terms appear in both the source language and in the target language).

- **Source language (default) and Target language (default)**
  You can define which languages are preset as the source and target when you call up SAPterm. You can however, change this default setting in the initial screen of SAPterm.

- **Additional languages**
  You can select further languages in which you wish to view the terminology concept. You can display as many or as few languages as required. For more information, see User Settings: Insert languages [Page 10].

- **Categories**
  You can choose whether you wish to see only terminology entries, index entries, or both. The default setting is **Terminology entries only**. To see index entries as well, you need to change your setting here.

- **Further entries**
  You can decide to display all, some, or none of the additional entries related to a main entry.

- **Environment**
  You can define which environment information is to be displayed for the term.

- **Status display**
  You can choose whether to display the status and entry class of a term as an icon or in text form. You can also decide whether you always want to see the status of terms in the hit list.

- **Detail display**
  You can define whether the additional information and the environment information are immediately visible in the terminology concept display or whether you have to expand the hierarchy to reveal the information.

- **General settings**
  You can subscribe to an Early Warning List containing terms created within a particular period, which the system sends via Mail.
Activities

1. Choose Administration → User settings → Maintain in the SAPterm initial screen to maintain the user settings.
   
   You go to the Maintain User Settings for <user name> dialog box.

2. Flag the settings you require.

3. Save and close the dialog box.
Adding Additional Languages to User Settings

Procedure

To insert languages in the *Maintain user settings for <user name>* dialog box, proceed as follows:

- Under *Additional languages*, choose the language you wish to insert from the field available. The chosen language is inserted in the list.
- To remove a language from this list, choose the *Delete* icon next to the language you wish to delete.

Result

All languages in the list are displayed in the terminology concept [Page 15].
Finding Terms

Use
There are two different ways of searching for terms in SAPterm

- **Searching from the initial screen of SAPterm**
  
  This is a simple search method where the system looks though the table keys of the terminology database. These table keys are stored in uppercase, which means that the search is not case-sensitive, and does not consider special characters.

- **Searching using Selection options**

  This search method enables you to define further criteria, for example, if you only want to search for terms within a specific application component, or terms created by a specific user. This search is case-sensitive, and can distinguish special characters.

Prerequisites

You must enter a term.

The terminology database supports generic searches with "*".

For performance reasons, a general search with only "*" is not possible when searching from the initial screen of SAPterm.

Procedure

**Finding Terms from the Initial Screen**

1. Call up transaction STERM.
2. Enter the term that you want to find and choose *Find*. 
Finding Terms

**Finding Terms Using Selection Options**

To find terms in the terminology database using selection criteria, proceed as follows:

1. Call up transaction STERM.
2. Choose *Selection options*.
   
   The *SAPterm: General Selection Criteria for Searches* screen appears.

3. Enter the selection criteria that you require and choose *Execute*.

**Result**

A list [Page 13] of all terms found is displayed.
Results List

Use

The results list contains all entries in the terminology database which fit the search criteria. The title bar displays the number of matches.

You can perform the following actions from the list:

- Display the complete terminology concept information by selecting the entry and choosing Display term concept.
  
  For more information, see Display Terminology Concept [Page 15].
- Display existing glossary entries and comment/source texts by choosing the relevant symbols in the results list. You can display the glossary entries in either SAPscript or HTML formats; the comment/source texts appear in SAPscript format.
- Edit a term by selecting the entry and choosing Maintain entry.
  
  For more information, see Maintenance Dialog: Maintain Entry [Page 25].
- Edit a glossary entry by selecting the entry and choosing Maintain glossary entry.
  
  For more information, see Create and Change Glossary Definitions [Page 79]
- Determine which objects have a link to a glossary entry by selecting the entry and choosing Where-used list.

It is important to call up the where-used list if you are carrying out standardization or cleanup actions to rid the database of duplicate entries. You must inform colleagues who have created links to entries pending deletion so that they may reset the links to the correct entry.

- Display entry class and term status by choosing Display status.
- Change the status of a term by choosing Edit → Maintain status.
This function is available to SAPterm superusers only.

- Display definitions of all the icons in the results list by choosing Legend.

**Functions**

You can further define the display of terms in the results list by using the functions in the status line, the menu or the right-hand mouse key. The following functions are available:

- Display monolingual/bilingual results list
- Display status of terms as icon/text
- Sort entries (cursor must be positioned on the appropriate column)
- Display translated/non-translated entries only (if you are displaying a bilingual list)
- Display status 3 terms only
- Display status 1 and 2 terms only

The following, additional functions are available to SAPterm superusers, after choosing Maintain status:

- Set all terms to status 3 by choosing Edit → Release all entries.
- Set all status 3 terms to status 2 by choosing Edit → Revoke release for all entries.
Terminology Concept

Use
You can display all information about a term with this function.

Features

General information
- Administration information
  - Original language
  - Classification (for example, system text, internal entry)
- Source
  - Link to source of the term

Individual entry information
- Administration information
  - Creation date
  - Creator
  - Date of last change
  - Last changer
  - Status
- Glossary
  - Creation date
  - Creator
  - Date of last change
  - Last changer
  - Glossary definition
- Grammar
  - Grammatical type
  - Part of speech
  - Gender (for those languages where this attribute is necessary)
- KW Context
  - First Release
  - Invalid after Release
The *Invalid after Release* information refers to the last release in which this term is valid. For example, if the *KW Context* displays a term as being invalid after Release 4.0A, this means that the term is still valid in Release 4.0A, and will cease to be valid in Release 4.0B.

- Country
- Industry sector

**Activities**

**Displaying all languages**

To display the term in all languages, into which it has been translated, choose *Display all languages* from the application toolbar.

**Navigating between terminology concepts**

If your results list [Page 13] contains more than one term, you can branch to the terminology concept of the previous and next term by choosing the *Previous entry* and *Next entry* icons from the application toolbar.

**Displaying the where-used list**

You can use this function to check where the given term is used in glossary links, in documentation created in both SAPscript and in the Knowledge Warehouse. The system also checks where a term is used as an index entry in KW documents.

To display the where-used list for a term entry, choose *Where-used list* from the application toolbar. A dialog box appears containing a list of the documents. You can select a document from the list in order to see the text.

**Deleting the entire terminology concept**

This function enables superusers to delete a term, along with all its translations, as long as no glossary entry exists for this term. For more information, see Deleting Terms [Page 61].
Maintaining a target text term
You can move directly to maintenance for given language entries (designations) from the terminology concept display. This function is visible as a maintenance icon (📝) next to each designation.

Deleting a target text term
Superusers can use this function to delete language-specific entries (designations) in the terminology concept. This function is visible as a deletion icon (🗑️) next to each designation. For more information, see Deleting Target Language Terms [Page 62].
Index Entries

Definition

Index entries are maintained by documentation developers in the Knowledge Warehouse (KW) in order to help users find information more easily by means of an index.

Use

Index entries created from the Knowledge Warehouse are now stored in SAPterm and can be changed there as well.

Index entries can only be created in info object maintenance in the Knowledge Warehouse. For more information, see Creating Index Entries in the Terminology Database.

You can, however, change index entries in SAPterm by selecting an index entry from the results list and choosing Maintain entry.

The maintenance screen for index entries is different than the maintenance screen for term entries and supports selected activities only, such as definition of valid and invalid synonyms. Other maintenance functions, such as creating glossary entries, are not possible for an index entry.

Structure

The index entry format in the results list differs from that of terminology entries.

"company code, create" highlighted in gray is an index entry consisting of a main entry (company code) and a subentry (create) and will appear in the KW index search tool as follows:

company code
create

Index subentries is a new category of additional information which can be selected or deselected under Further entries in the user settings for display.

Integration

All searches started from the SAPterm initial screen will display term entries only in the results list by default. You can define whether you want to display index entries in the results list in your user settings. The detailed search screen offers radio buttons that allow you to filter the search for term entries, index entries, or both.

Index entries that appear in the SAPterm results list are highlighted in gray and marked with an icon to distinguish them from terminology entries. The initial link to the source information is automatically created with the index entry in the Knowledge Warehouse and cannot be maintained manually. To find out the info objects, in which a specific index entry is used, select the index entry in the results list and choose Where-used list. The system displays a list of KW info objects where it is registered as an index entry. This is especially useful for translators who require specific context information in order to translate an index entry.

Term entries may serve simultaneously as index entries but are not highlighted differently. To determine whether a term entry also serves as an index entry, select the term entry in the results list and select Where-used list to see a list of KW info objects where it is registered as an index entry. If you decide you wish to make an index entry a term entry, you have to enter it separately.
as a term and maintain the relevant information, then arrange for so that the single term entry serves both roles. This means you need to reset the links to the KW info objects from the old index entry to the new term/index entry, then delete the old index entry.

See also:

Translating Index Entries [Page 71]
Creating Terms

Procedure

To create a term, proceed as follows:

1. Call the transaction STERM.
2. Enter the term and choose Create.

   The system checks whether the term you wish to create already exists in the terminology database.
   - If this term already exists in SAPterm, the system displays a warning.
     - Choose Display entries to view the existing terms
       The Terminology Concept Confirmation Prompt dialog box appears. You can use the Previous entry and Next entry functions to branch from one terminology concept to the next.
       If you choose Continue, you return to the initial screen.

   Please read the existing terms carefully and decide whether you need to enter this term again. You may only need to add the application component of the term you wish to enter to the term that is already maintained in SAPterm. For more information, see Adding an Additional Application Component to an Existing Term [Page 29].

   - Choose Create entry to enter the term again.

     The maintenance screen appears.
     - If this term does not yet exist, the maintenance screen appears.

3. Enter the required data.

   For more information, see Maintenance Dialog: Maintain Entry [Page 25].
4. Save your entries.

**Result**

The system saves the term in the terminology database.
Creating and Maintaining Terms for Non-Core Developments

Use
To maintain terminology for the core (R/3) application components, you need to use transaction STERM in the primary SAPterm system (that is, the translation system where the central SAPterm database is located).

To maintain terminology for application components belonging to non-core developments (such as Industry Solutions), you need to use transaction STERM_EXTERNAL.

Prerequisites
The component assignment is mandatory for all terms, and you cannot use a component if it does not exist in the system that you refer to. This means that you cannot use transaction STERM to maintain non-core terms, and you cannot use transaction STERM_EXTERNAL to maintain terms for core components.

Procedure
1. To maintain terminology for application components from an SAP Industry Solution or other product not part of the Core, call up transaction STERM_EXTERNAL.
   A screen appears in which you need to enter the reference system.
2. Enter the name of the reference system in the System ID field and choose Enter.

Result
You will see an identical initial screen for SAPterm, but STERM_EXTERNAL uses the component hierarchy from the reference system.
Maintaining Terms

Procedure

To maintain a term, proceed as follows:

1. Call the transaction STERM.
2. Enter the term and choose Maintain.
   
   The system checks whether the term to be maintained already exists in the terminology database.
   
   - If this term already exists several times in SAPterm, the system displays a list of the existing terms.
   
   - If this term only exists once, you go to the maintenance dialog.
3. Enter the required data.
   
   For more information, see Maintenance Dialog: Maintain Entry [Page 25].

4. Save your entries.

Result

The system saves the changed term in the terminology database.
Changes to existing term and glossary entries reset the status of the entry to indicate a possible translation-relevant change.

Changes or additions to additional information do not reset the status.
Maintenance Dialog: Maintain Entry

Use
You can create and change terms in the Maintain Entry screen.

Functions
You can maintain the following attributes for each term in the terminology database.

Mandatory Attributes
You must maintain the following attributes for each term. You cannot save the entry without this mandatory information.

- Application Component
  Here you need to assign the term to the component hierarchy. You can use F4 help to choose the application component.

If the term is valid SAP-wide, choose the component SAP R/3.

- Entry Class
  The entry class affects the translation of and the external access to the terminology entries in SAPterm.
  For more information, see Entry classes [Page 31].

- Grammar
  Here you need to enter information about the grammatical attributes of the term.
  The grammatical attributes are necessary for comparing the terminology with machine translation dictionaries.
  For more information, see Grammar Information [Page 34].
Maintenance Dialog: Maintain Entry

- **Source / Link to source**

  The Source field and the Link to source function are used for documenting the contextual information used in defining the term concept.

  Source information is the only additional information that is mandatory. When you create a term, you cannot save it if you have not provided a copy of, or a bibliographic reference to, a source text, or a link to the source text itself.

  For guidelines on what information to provide in the Source field, see Source Information [Page 44].

  For more information on creating a link to existing documentation on a term entry, see Creating Links to Source of Term [Page 46].

**Optional Attributes**

You can maintain the following attributes as well as the obligatory attributes:

- **Comment**

  The Comment field contains any other usage, background, or contextual information not covered by the other attributes or the definition. For instance, you can enter the long version of an abbreviation used as a main entry, or a note on the trademarked status of a term.
You are recommended, where possible, to enter any comments in both English and German, where possible. This ensures that as many users as possible can benefit from this additional information.

- **Glossary entry**
  A glossary entry holds the definition of the concept to which the term refers.
  For more information, see *Creating and Changing Glossary Definitions [Page 79]*.

- **Other KW context**
  Create/maintain another entry in the same language for a concept
  You can maintain this context analogously to the SAP Knowledge Warehouse.
  For more information, see *Maintaining Other KW Contexts [Page 49]*.

- **Additional information (tab pages)**
  Additional information enhances the value of the term for all users.
  You can maintain valid abbreviations and invalid synonyms for the term, for example.
  For more information, see *Additional Information [Page 39]*.

### Additional Functions in the *Maintain Entry* Screen

- **Change entry**
  If you want to edit the main entry, choose *Edit ➔ Change entry*. This ensures that the field for the source term is ready for input.

- **Display/Maintain status**
  The status of the term you are currently maintaining is displayed as a traffic light next to the *Language* field.
  Users with superuser authorization can maintain the status of a term in the *Maintain Entry* screen by double-clicking the traffic light icon.
Maintenance Dialog: Maintain Entry

- **Terminology concept**
  
  This function enables you to display all information about a term.

  For more information, see [Terminology Concept](#) [Page 15].
Adding an Additional Application Component to an Existing Term

Use
You can use the Other components function to assign further application components to the original component of a terminology concept. The purpose of this function is to reduce the number of duplicate entries in the database, where identical terms have been entered multiple times for different components.

Prerequisites
- Please note that a terminology concept in any component is automatically "valid" for other components unless it is otherwise indicated.
- You should only use this function to underline a given additional validity in cases where it might be unclear, in order to avoid duplication of terminology concepts.
- Do not enter other components needlessly, and never enter all the available components.

Procedure
1. From the Maintain Entry [Page 23] screen, choose Other components (the arrow to the right of the Application component field).
   The dialog box Further Components appears.
2. Enter the application component key in the Further Components field.
   You can use F4 Help on this field to help you choose the application component you require.
3. Choose Create.
Adding an Additional Application Component to an Existing Term

The application component is now added to the Further components list in this dialog box. To remove the application component from this list, choose the Delete icon to the left of the component key.

4. Choose Continue.
5. Save your entries.

Result

The system displays the Additional components icon for this term in the results list. When you choose this icon, the system displays a dialog box containing all components that have been assigned to this terminology concept.

If you specify a particular application component in Selection criteria in order to restrict your search, the system will display the following:

- Terms that are assigned to this application component as the primary component
- Terms that have a different component as their primary component, but where this application component has been assigned as an additional component

A terminology entry will always have a primary component assignment. This determines the unique terminology concept that is used to create hypertext links to any glossary entry created for the term.
Entry Classes

You must assign an entry class to a terminology concept. The entry class affects the translation of and the external access to the terminology entries in SAPterm. Entry classes can also serve as search attributes.

Terminology entry classes are divided into the following categories:

- System texts
- Documentation (Knowledge Warehouse)
- Internal entries
- Proper names

Assign terms that appear in SAP software and documentation to an entry class which guarantees the terms will be made available to customers. SAP benefits from the widest possible distribution of its terminology.

System Texts

System text is the default entry class for a term when you create it. All terms that appear in the software menus, screens, messages, and other user interface elements should be classified as System texts. Due to the fact that the interface is translated into all languages, all terms in this entry class must be translated into all SAPterm languages. In addition, because customers see all interface elements in the software, all terms in this entry class appear in terminology and glossary products for externals if the term entry has the status Released.

Documentation (Knowledge Warehouse)

Documentation terms appear in online help, training material, collateral information such as brochures, and other electronic and printed documents. All terms in this entry class also appear in terminology and glossary products for externals if the term entry has the status Released. However, because the source materials are not translated into all SAPterm languages,
Entry Classes

translation coordinators for the individual languages must decide whether these term entries need to be translated or not.

**Internal Entries**

Internal entries are terms entered for SAP reference only. These include names of departments, legal and business terms used in company correspondence and administration, set phrases used by translation teams in their areas of specialty, and so on. These entries are never made available to customers even if the term entry has the status Released. It is highly recommended that these entries are translated if they are useful for a given language but there is no requirement to do so.

**Proper Names**

These terms may or may not require translation. This entry class is subdivided further into the following categories:

- SAP product names
- Other product names
- Technical names

**SAP / Other Product Names**

A product name is a registered or non-registered trademark (such as a symbol or word) indicating the origin or ownership of the product and legally reserved for the use of the product's maker or seller. Most of the proper names used by SAP for its products and software features are de facto unregistered trademarks and enjoy legal protection.

The company name SAP is not translated and is written in Roman script in all languages. It is a registered trademark in many countries and an unregistered trademark in others.

Many trademarks are not translated into other languages; rather, they are treated as loan words. This can only be decided on a case-by-case basis after thorough research by the relevant product management team.

When using trademarks or product names of other companies in SAP software and documentation, always research to make sure you are using the official name as determined by the company in question.

Procter & Gamble’s skin cream product is called Oil of Olay in the United States. As part of product localization, the company gives the skin cream other names in other regions: Oil of Ulay in the United Kingdom and Russia, Oil of Olaz in French and German-speaking markets, and Oil of Ulan in China and Malaysia.

**Technical Names**

A technical name is a text that is language-independent (in other words, a text that should not be translated, but should remain the same in all languages throughout the SAP System). Technical
names include transaction names, ABAP commands and names of function modules. If you class a term as a technical name, you are, in effect, classing this term as not relevant for translation.

If you enter the ABAP command INCLUDE as a technical name, this ensures that translators will not translate this text into their target language when they encounter it.
Grammar Information

You must maintain the following attributes for each new term:

- Grammatical type
- Part of speech
- Gender (depending on the language of the term)

Grammatical type

The grammatical attribute is required for the analysis of terms for machine translation. The grammatical type classifies the structure of the character string entered into one of the following categories:

- Word
- Multiword
- Clause

Word

The category Word includes:

- Character strings which do not contain spaces

  Example
  movement, deactivate, gradually, quickly

- Character strings connected by one or more hyphens

  Example
  once-only, use-before, client-specific

- Character strings (composite) which comprise two or more elements and are not separated by spaces

  Example
  mySAP.com, InfoCube, ValueSAP

Multiword

The category Multiword includes phrases of two or more words. These phrases are an entity and comprise the most important parts of speech in a sentence (noun, verb, adjective or adverb).
As terms must be entered in STERM with a part of speech, it is very important to distinguish between the various types of multiword terms: noun, verb, adjective or adverb. The root word of a multiword term is the main indicator of the part of speech. The root word of the phrase is the element that can be declined or conjugated.

The root word is **bold** in the following examples.

<table>
<thead>
<tr>
<th>Type of Multiword Term</th>
<th>Examples</th>
</tr>
</thead>
</table>
| Multiword term as noun  | associated company  
|                        | hundred-percent subsidiary  
|                        | internal job advertisement  
|                        | overview of something  |
| Multiword term as verb  | take responsibility for something  
|                        | post an account  
|                        | change fundamentally  |
| Multiword term as adjective | greatly reduced  
|                        | effectively ready  |
| Multiword term as adverb | very slowly  
|                        | as usual  |

Nominal multiword terms | internal job *advertisement*  
|                        | internal job *advertisements*  

Verbal multiword terms | *is* dependent on something  
|                        | *was* dependent on something  |
See Part of Speech for guidelines for distinguishing between nouns, verbs, adjectives and adverbs.

Clause

The category Clause includes word sequences which contain at least two root elements of a sentence: a subject (= noun or nominal phrase) and a predicate (= verb or verbal phrase):

Example

trailer swings out, receipt is being printed

If the conjugated verb in the phrase is the auxiliary verb to be, it can be omitted:

Example

machine not ready for use, elevator under repair

If you classify a term as a Clause, you should assign it to the part of speech Noun.

Part of Speech

Terms can have the following parts of speech:

- Noun
- Verb
- Adjective
- Adverb

If you cannot identify the word type of a term, use the following guidelines:
## Grammar Information

| Noun                                      | Nouns are words or expressions that refer to persons, places, things, circumstances or attributes.  
|                                          | Nouns also have the following characteristics:  
|                                          | • They can be associated with an article.  
|                                          | • They can be declined.  

| Verb                                      | Verbs identify actions.  
|                                          | Verbs can be conjugated.  

| Adjective                                 | Adjectives define properties of nouns.  
|                                          | Adjectives can be declined like nouns.  

| Adverb                                    | Adverbs describe situations.  
|                                          | They are neither declined nor conjugated.  
|                                          | Adverbs answer the questions *How, When, or Where?*  

Enter prepositional phrases in the terminology database as adverbs. For example:  
• in time  
• at the end of the transaction

### Gender

You may also need to maintain the gender of a noun, depending on the language for which you are maintaining the term.
English nouns require no attribute for gender, so the function for setting this attribute does not appear. German nouns require attributes for gender, so attributes for gender appear when you select *Noun* as the part of speech for a term.
**Additional Information**

You can maintain the following additional information for a term:

- Abbreviations
- Synonyms
- Invalid synonyms
- Superordinate terms
- Invalid spelling

---

**Abbreviation**

*VaR*

**Synonyms**

- retail inventory method
- retail method

**Invalid synonyms**

- sales price valuation
- valuation at sales prices

**Superordinate term**

- valuation

**Invalid spelling**

- valuation at Retail
A counter appears next to the respective additional information tab title in the Maintain Entry screen if abbreviations, synonyms, and so on already exist for a main entry.

**Abbreviations**

**Use**

You can enter abbreviations (meaning abbreviations, initialisms, and acronyms) that occur in the SAP System and in the documentation.

Abbreviations create special difficulties for translation. You should document abbreviations in this field whenever you encounter them.

**Prerequisites**

- In general, enter an abbreviation in the Abbreviation field and use the full string as the main term.

  If the abbreviation is more commonly used than the full string, enter the abbreviation as the term and enter the full string in full form in one of the following locations (in order of priority):

  - If the term has a glossary entry, enter the full form in the first line of the glossary entry, followed by the definition.
  - If the term does not have a glossary entry, enter the full form in the Comment field.
  - In both cases, enter the full form in the Valid synonym field where applicable.

- Do not enter an abbreviation in parentheses after a main entry.
- Do not enter an abbreviation that is longer than the main entry.
- Enter each abbreviation in a separate line.
**Procedure**

1. From the [Maintain entry](Page 23) screen, choose the *Abbreviations* tab.
2. In this tab page, enter the abbreviation in the field provided.
3. Choose the *Save* icon to the left of this field.
4. Repeat this procedure for each abbreviation that you wish to maintain.

**Synonyms**

**Use**

Synonyms are terms that can be used in place of the main entry. For example, you can enter a shorter version of the main entry, which can then be used to avoid clumsy repetitions.

Do not create synonyms that do not exist in the system or in the documentation. The focus of terminology work is the standardization of terms where possible and the avoidance of synonyms. If synonyms exist, however, you need to document them, perhaps in order to standardize them later.

Avoid entering unnecessary synonyms (such as "order" for "purchase order", which it is normally obvious from the context).

**Prerequisites**

- The meaning is clear from the context.
- You have already explained the meaning of the synonym in the text.
- Enter each valid synonym in a separate line.

**Procedure**

1. From the [Maintain entry](Page 23) screen, choose the *Synonyms* tab.
2. In this tab page, enter the synonym in the field provided.
3. Choose the Save icon to the left of this field.
4. Repeat this procedure for each synonym that you wish to maintain.

**Invalid Synonyms**

**Use**
Invalid synonyms are terms that are not to be used in place of the main entry.

**Prerequisites**
- Enter synonyms that are used internally but are not to be used in customer documentation
- Enter terms that have changed between the R/2 System and the R/3 System
- Do not enter variant spellings as invalid synonyms. See Invalid Spellings below.
- Enter each invalid synonym in a separate line.

Note that, if a term changes from one release to another, you should store this information in a separate KW context [Page 49]. This ensures that the old term is still valid for a given release but invalid for another. An invalid synonym, on the other hand, is invalid in all instances applying to a term context.

**Procedure**
1. From the Maintain entry [Page 23] screen, choose the Invalid Synonyms tab.
2. In this tab page, enter the invalid synonym in the field provided.
3. Choose the Save icon to the left of this field.
4. Repeat this procedure for each invalid synonym that you wish to maintain.
Superordinate Terms

Use
Superordinate terms are umbrella terms related to the main entry as part of a physical or conceptual relationship. You can create hierarchies of relationships by assigning subordinate terms to their superordinate concepts.

Prerequisites
- In order to create a hierarchical assignment of terms, you need to enter a term that already exists in SAPterm as a Superordinate Term.
- Enter each conceptual relationship in a separate line.

Procedure
1. From the Maintain entry [Page 23] screen, choose the Superordinate Terms tab.
2. In this tab page, enter the superordinate term in the field provided.
3. Choose the Save icon to the left of this field.
4. Repeat this procedure for each superordinate term that you wish to maintain.

Invalid Spelling

Use
Terms entered under Invalid Spelling are variant spellings of the main entry that are not allowed. The Invalid Spelling information is also intended to simplify language tool support for search-and-replace during cleanup actions.

Procedure
1. From the Maintain entry [Page 23] screen, choose the Invalid spelling tab.
2. In this tab page, enter the invalid spelling in the field provided.
3. Choose the Save icon to the left of this field.
4. Repeat this procedure for each invalid spelling that you wish to maintain.
Source Information

The *Source* field is used for documenting the contextual information used in defining the term concept and should contain information on the origin of the term.

When you enter a new term, you must either enter the source or create a link to the source before you can save the term. For more information on creating a link to the source, see Creating Links to Source of Term [Page 46].

SAPterm source information does not appear in terminology and glossary products for externals. It is intended for internal use only.

Guidelines for Entering Source Information

- Leave an empty line between each example.
- Translators do not need to translate source information into their respective languages. If you choose not to do so, leave the *Source* field empty. Do not insert a copy of the untranslated source information, and do not refer back to it (such as "see the German source information").
- Enter a sample text from SAP publications or other sources showing how the term is used. Do not enter more than one or two sentences.
- Enter the citation information in full after the sample text:
  - For books, trade journals, and other external publications, use standard bibliographic citation formats.
  - For SAP documentation and system objects to which you cannot create links, you need to enter the following information:

<table>
<thead>
<tr>
<th>Type of object</th>
<th>Information to be provided</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help documentation</td>
<td>Component key, component name, and topic name</td>
</tr>
<tr>
<td>Source Information</td>
<td></td>
</tr>
<tr>
<td>------------------------------------</td>
<td></td>
</tr>
<tr>
<td>System documentation</td>
<td></td>
</tr>
<tr>
<td>Documentation class, documentation name</td>
<td></td>
</tr>
<tr>
<td>SAP System</td>
<td></td>
</tr>
<tr>
<td>Type of object (such as domain, message, transaction) and technical name of object</td>
<td></td>
</tr>
<tr>
<td>Training material</td>
<td></td>
</tr>
<tr>
<td>Course number, course title, and page</td>
<td></td>
</tr>
<tr>
<td>Brochures, marketing material, press releases</td>
<td></td>
</tr>
<tr>
<td>Title, material number (if available), date, page</td>
<td></td>
</tr>
</tbody>
</table>
Creating Links to Source of Term

Use

When creating a term in SAPterm, you can add a link to existing documentation in order to provide extra information on the term. At present it is possible to create a link from a term to the following object types:

<table>
<thead>
<tr>
<th>Documentation object type</th>
<th>Class name in SAPterm</th>
</tr>
</thead>
<tbody>
<tr>
<td>Implementation Guide documentation</td>
<td>• BOOK for objects with technical names beginning with BOOK</td>
</tr>
<tr>
<td></td>
<td>• CHAP for objects with technical names beginning with CHAP</td>
</tr>
<tr>
<td></td>
<td>• SIMG for objects with technical names beginning with SIMG</td>
</tr>
<tr>
<td>Data element documentation</td>
<td>DE</td>
</tr>
<tr>
<td>Dialog texts</td>
<td>DT</td>
</tr>
<tr>
<td>Data element supplement documentation</td>
<td>DZ</td>
</tr>
<tr>
<td>Function module documentation</td>
<td>FU</td>
</tr>
<tr>
<td>Knowledge Warehouse documentation</td>
<td>KENO</td>
</tr>
<tr>
<td>Message documentation</td>
<td>NA</td>
</tr>
<tr>
<td>Release notes</td>
<td>RELN</td>
</tr>
<tr>
<td>General texts</td>
<td>GT</td>
</tr>
</tbody>
</table>

Contact the SAPterm administrator if you need to create a link to documentation belonging to a non-allowed object type. The administrator can allow additional object types in SAPterm when necessary.
**Creating Links to Source of Term**

**Prerequisites**
- The term exists in the SAP System or in the Knowledge Warehouse documentation.
- You need to know the technical name and the object type of the documentation to which you wish to create a link.

If you are creating a link to Knowledge Warehouse documentation, you can also search for the information object to which you wish to create a link.

- Such links can only be created in entry maintenance.

**Procedure**
1. Proceed as described in Create Term [Page 20], and enter data as described in Maintenance Dialog: Maintain Entry [Page 25].
2. On the Maintain Entry screen, choose Link to source.
   The screen Maintain Links to Term Source Information appears.
3. Enter the Class of the documentation object. See the table above for the available documentation object types and their classes. You can use F4 help in the Class field to help you.
4. Enter the document name in the Document field.
To maintain a link to an individual information object in the Knowledge Warehouse, use the F4 help on the Document field to search for the information object to which you wish to create a link.

The dialog box Info category appears. To create a link to an individual information object, select Topic and choose Copy.

The Find info object dialog box appears. Enter as much information as possible as selection criteria in order to restrict the search and choose Execute. Entering the technical name of an information object is the most efficient way of locating it.

The results of your search are displayed in the dialog box Choose info object. Select the information object you require and choose Copy info object.

The document name of the information object is now inserted in the Document field.

You wish to create a link to a piece of documentation from the Implementation Guide. The technical name of this documentation is CHAPSIMG_EXAMPLE. To create a link to this documentation object, you need to enter CHAP in the Class field, and enter SIMG_EXAMPLE in the Document field.

5. To test that the correct documentation is displayed for this term, choose Display.

6. Save your entries.

**Result**

The link to the source of the term is created in the terminology database.
Maintaining Other KW Contexts

Use
You can use the Other KW context function to add other main entries to a main entry of a terminology concept, in the same language, with this function.

You can use the function in the following situations:

- The terminology has changed.

**Example**

The term *Function Library* was valid until Release 4.0A. From Release 4.0A, this term has been replaced by *Function Builder*. The terminology change should be documented in the terminology database.

- There are country or industry sector-specific different names for the same thing: for example, all countries have their own version of social insurance.

**Example of country-specific names**

![Diagram showing different names for social insurance in various countries and languages.](image)

The terminology database should document that these are all names for different country versions of the same concept.

**Example of industry sector-specific names**

- SAP Standard: Material
- Industry sector (Retail): Article
Maintaining Other KW Contexts

In a concept-oriented database, all entries belong to the same concept. The entries must have different context attributes.

*Function Library and Function Builder* have different context attributes “changed in Release” (4.0A and unspecified). The terms “national insurance”, “social security” and “social security program” have different context attributes “Country” (GB, US, CA).

Terms with the same context attributes cannot be maintained in parallel as two independent main entries. These are treated as valid *synonyms*.

**Prerequisites**

Before you can create an additional main entry under a new KW context, you first need to have saved the initial main entry.

**Activities**

1. Maintain a main entry.
2. Under *KW Context*, maintain the following, depending on the situation:
   - To indicate that this term is only valid after a specific release, enter the name of this release in the *First Basis release* field (for terms from the standard R/3 System). For terms from industry solutions and any other non-R/3 developments, enter the name of the release in the *First IS release* field.
   - To indicate that this term will no longer be valid after a specific release, enter the name of this release in the *Invalid after Basis rel.* field (for terms from the standard R/3 System). For terms from industry solutions and any other non-R/3 developments, enter the name of the release in the *Invalid after IS release* field.
   - To indicate that this term is only valid in a specific country, enter the two-character ID of this country in the *Country* field (you can use F4 Help to choose the country ID).
   - To indicate that this term is only valid in a specific industry, enter the ID of this industry in the *Industry* field (you can use F4 Help to choose the industry ID).
3. To create another entry, choose Goto → Create entries with other KW context.
4. Maintain the new term.
5. Under KW Context for this term, maintain the context attributes that differ from those of the main entry.
6. Save your entries.

**Example**

To document the fact that the term *Function Library* was valid until Release 4.0A and has been replaced by *Function Builder* from Release 4.0A onwards, proceed as follows:

1. Maintain the main entry, in this case *Function Library*.
2. Under KW Context for this entry, enter 4.0A in the Invalid after Basis rel. field.
3. Save the entry.
4. Now choose Goto → Create entries with other KW context.
5. In this screen, maintain the new term, in this case *Function Builder*.
6. Under KW Context for this entry, enter 4.0A in the First Basis release field.
7. Save your entries.

The terminology concept detail display now contains two English entries. You can see from the context attributes that the entry *Function Library* has been replaced from Release 4.0A by the term *Function Builder*. 
Superuser Functions in SAPterm

Superuser Functions in SAPterm

SAPterm superusers are responsible for maintenance tasks for a specific application component, or group of components, and for a specific language in SAPterm. They have authorizations for additional functions to perform these tasks.

SAPterm superuser tasks include:

- Conducting regular reviews of terminology for a component or components
- Maintaining the status of terms for a component or components
- Coordinating terminology work in their target language and with other SAPterm superusers

SAPterm superuser reviews include the following activities:

- Superusers for the SAPterm source languages (either English or German) check that the term has been entered under the correct component. If necessary, they arrange to move the term into the correct component.
- All superusers check terms in their target language for compliance with the SAPterm entry conventions (main entry and additional information). They correct the terms if necessary, and delete stray test entries, duplicates, or incorrect entries.
- Superusers also work with other SAPterm superusers, and information developers and software developers when wide-scale corrections or deletions are necessary for terminology standardization.

See also:

- Status Maintenance [Page 53]
- Displaying and Maintaining Term Status [Page 56]
- Maintaining Term Status for Target Language Terms [Page 58]
- Deleting Terms [Page 61]
Status Maintenance

Use
Status indicators are used to track changes in the terminology database. Superusers set status indicators separately for each term and for each language, in order to indicate the review status of a specific term.

Integration
All new terms in SAPterm are automatically assigned status 1.
If no glossary entry exists, the SAPterm superuser has the following options
- Release the term
- Delete the term immediately.
If a glossary entry exists, the SAPterm superuser has the following options:
- Release the term
- Delete the term entry
- Set the status for deletion.
Changes to a released term by an authorized information developer (usually, the creator of the term) automatically reset the term to status 2 because a new review is necessary. A SAPterm superuser can also set a term to status 2 for later review.

Prerequisites
The status indicators apply to a term entry according to the following criteria.

<table>
<thead>
<tr>
<th>Status</th>
<th>Icon</th>
<th>Definition</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>New</td>
<td>The term was entered in the terminology database. It has not been reviewed and given official sanction as an SAP term in the relevant language. The term is to be used guardedly.</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>Pending review</td>
<td>There are two scenarios:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- The term entry and/or the glossary entry have been changed in a source language. Translators in other languages must review the changes in order to determine whether they must make relevant changes in their languages.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- The terminology superuser sets the status manually to indicate the term entry and/or the glossary entry are being peer-reviewed</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>The term is to be used guardedly.</td>
</tr>
<tr>
<td>Status</td>
<td>Released</td>
<td>Pending deletion</td>
<td></td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
<td>------------------</td>
<td></td>
</tr>
</tbody>
</table>
| **3**      | Released | The term meets the quality standards for SAP terminology:  
|            |          | - The term has been peer-reviewed by a terminology superuser, the information development team, the development team, subject matter experts, and/or a focus group consisting of any or all of the above for the relevant component or component group.  
|            |          | - The term entry conforms to the entry conventions for the language in question.  
|            |          | - The term entry includes sufficient source information for translators to determine the correct term for their respective languages.  
|            |          | - The peer review concluded that the term entry is either:  
|            |          |   - A term unique to SAP requiring a glossary entry in order to define the concept.  
|            |          |   - A standard term used in the relevant industries to which the components apply, but with an SAP-variant usage requiring a glossary entry in order to define the concept.  
|            |          |   - A standard term used in the relevant industries to which the components apply, without an SAP-variant usage and which may or may not require a glossary entry.  
|            |          |   - A term with multiple possible translations into another language within the same context, requiring a term entry in order to standardize the translation for SAP use.  
|            |          | The term is to be used without reservation. |
| **4**      | Pending deletion | The term is not part of the SAPterm database for one or more of the following reasons:  
|            |          | - The term concept is false or doesn't exist within a SAP context.  
|            |          | - The term entry is a duplicate of an established term entry without an language-specific alternate concept or designation to justify the duplication.  
|            |          | - The term entry is an abbreviation, valid or invalid synonym, or other piece of additional information belonging to an existing term entry, but created mistakenly as a main entry.  
|            |          | - The term is a stray test entry.  
|            |          | The term is not to be used under any circumstances. |
Features
Terms may have differing statuses in different languages. A source language term can have status 1 (new) and the target language term can have status 3 (released). This reflects the different work cycles of the various workgroups. However, it is better if the term is released in the source language first because the entry is officially only provisional until released.

Activities
For more information on how to maintain the status of terms, and on how to set a term for deletion, see the following:

Displaying and Maintaining Term Status [Page 56]
Maintaining Term Status for Target Language Terms [Page 58]
Deleting Terms [Page 61]
Displaying and Maintaining Term Status

Prerequisites
To maintain the status of a term, you need superuser authorization.

Procedure
To maintain the status of a term, proceed as follows:

1. Call up transaction STERM.
2. Enter the term and choose Find. Alternatively, use Selection criteria to call up a number of terms based on your requirements (for example, all terms from a specific component with status 1 and 2).
   
   The results list [Page 13] appears containing all terms found.
3. Choose Edit → Display status.
   
   The status of the terms is displayed as follows in the results list.
   
   – Status 1 (new)
   – Status 2 (to be checked)
   – Status 3 (released)
4. Choose Edit → Maintain status to activate the maintenance mode.
5. To change the status of a term, click on the traffic light icon.

To release all the terms in this list in one step, choose Edit → Release all entries.

To reset the status of all terms in one step choose Edit → Revoke release for all entries.
Result

The status changes as follows:

- If a glossary entry exists for a term, it is not possible to reset this term to status 2 after this term has been set to status 3.
- Once you have changed the status of a status 1 term, you cannot change the status of this term back to New.

For more information on deleting terms without glossary entries, and setting the status of terms with glossary entries for deletion, see Deleting Terms [Page 61].

See also:

Maintaining Term Status for Target Language Terms [Page 58]
Maintaining Term Status for Target Language Terms

Use
Superusers wishing to maintain the status of their translations of a source term need to follow a different procedure for maintaining term status in SAPterm.

Prerequisites
To maintain the status of a term, you need superuser authorization for your target language.

Procedure
1. Call up transaction STERM
2. Now set your target language as the Source language and your source language as the Target language
6. Enter the term and choose Find. Alternatively, use Selection criteria to call up a number of terms based on your requirements (for example, all terms from a specific component with status 1 and 2).
   The results list [Page 13] appears containing all terms found.
7. Choose Edit → Display status.
   The status of the terms is displayed as follows in the results list.
   - Status 1 (new)
   - Status 2 (to be checked)
   - Status 3 (released)
8. Choose Edit → Maintain status to activate the maintenance mode.
9. To change the status of a term, click on the traffic light icon.
To release all the terms in this list in one step, choose Edit → Release all entries.
To reset the status of all terms in one step choose Edit → Revoke release for all entries.

**Result**

The status changes as follows:

- [ ] → [ ]
- [ ] → [ ]
- [ ] → [ ]
If a glossary entry exists for a term, it is not possible to reset this term to status 2 after this term has been set to status 3.

Once you have changed the status of a status 1 term, you cannot change the status of this term back to New.

For more information on deleting terms in your target language, see Deleting Target Language Terms [Page 62].
Deleting Terms

Prerequisites

- To delete a term, you need superuser authorization.
- Before you delete a term, you first need to call up a Where-used list for this term, to check that this term is not used in any glossary links or as an index entry. For more information, see Displaying the where-used list in Terminology Concept [Page 15].

Procedure

1. Call up transaction STERM.
2. Enter the term you want to delete and choose Find.
   - If only one term matches your search criteria, the terminology concept [Page 15] for this term appears.
   - If more than one term matches your search criteria, the system displays the results list [Page 13]. To display the Terminology concept of the term you wish to delete, select the term and choose Goto → Select term concept.
3. In the Terminology concept screen for this term, choose Edit → Delete entire entry.
   - A dialog box Knowledge Warehouse Context Attribute Query appears.
4. Choose Enter to check that no documentation objects contain links to this term.
   - A dialog box appears, asking you to confirm that you wish to delete the entire terminology concept.
   - If a glossary entry exists for this term, an additional dialog box will appear informing you of this fact.
5. Choose Yes.

Result

If no glossary entry exists for this term, the system deletes the term and its concept.

If a glossary entry exists for this term, the system sets the term to status 4 [Page 53] (pending deletion). Terms with status 4 are then deleted at regular intervals by the SAPterm administrator.
Deleting Target Language Terms

Use

Superusers can delete language-specific entries (designations) for a specific term. This function is visible as a deletion icon ( ) next to each designation in the Terminology Concept [Page 15].

Two English-language designations exist for a terminology concept, but one is incorrect. You can delete the incorrect entry separately, leaving the concept intact with the correct English designation.

Prerequisites

To delete a target text term, you need to have superuser authorization for the language in question.

Procedure

1. Call up transaction STERM.
2. Enter the term for which you want to delete a language-specific designation, and choose Find.
   
   The results list [Page 13] appears containing all terms found.
3. Select the term and choose Goto → Display term concept.
4. In the terminology concept [Page 15] for this term, select the language entry you wish to delete from this term concept, and choose the deletion icon next to it.

Result

The system deletes the target text entry from the terminology database.
You cannot use this function to delete all the original language entries. At least one entry must remain in order to define the terminology concept. To delete the entry, you need to delete the entire terminology concept. For more information, see Deleting Terms [Page 61].
Translation in SAPterm

If you want to translate terms in SAPterm, you need to ensure that your target language default setting is maintained in your user settings [Page 8].

See also:

Translating Individual Terms [Page 65]
Translating Terms Using a Worklist [Page 67]
Translating Index Entries [Page 71]
Translating Glossary Definitions [Page 81]
Translating Individual Terms

Use
You can translate terms individually in SAPterm.
To translate a number of terms in a worklist, see Translating Terms Using a Worklist [Page 67].

Prerequisites
If you want to translate terms in SAPterm, you need to ensure that your target language default setting is maintained in your user settings [Page 8].

Procedure
1. Call up transaction STERM.
2. Make sure that the Source language and Target language into which you wish to translate are correct.
3. Enter the term and choose Maintain.
   The Maintain Entry screen appears.
4. Choose Go to → Translate entry.
   You go to the Translate Entry screen.
5. Enter the translation in the Target term field.

To compare the term with the proposal pool [Ext.], choose Compare with Proposal Pool from the application toolbar.
To make further entries for the term, choose Other KW context [Page 49] from the application toolbar.
6. Maintain the necessary grammar information [Page 34] for your target language term.
Translating Individual Terms

7. Maintain any necessary additional information [Page 39], such as synonyms or abbreviations, for your target language term.
8. Save your entries.

Result
The system saves the translation of the term in the terminology database.
Translating Terms Using a Worklist

Use

Translators can now create worklists in order to translate a number of SAPterm entries in one step. The worklists can be filtered based on individual requirements (for example, all untranslated entries in a specific application component with status 2 or 3 in the source language).

Worklists can be created for term entries, index entries, or both categories. The worklist offers fields for the translation and the part of speech.

Superusers can also maintain the status of each term when they use the worklist, flagging terms for release (status 3) or for review (status 2).

Procedure

1. Call up transaction STERM.
2. Make sure that the Source language and Target language into which you wish to translate are correct.
3. Choose Utilities → Translation worklist.
   The Create Translation Worklist screen appears.
4. Enter the Application component of the terms you want to translate.
5. Under Entry category, select Terminology only to translate terms only, or All categories to translate both terms and index entries in this worklist. For more information on translating index entries, see Translating Index Entries [Page 71].
6. Select the translation status All entries to see both translated and untranslated index entries, or New entries only to display only untranslated entries.
7. Set the number of entries you would like to display at a time in the Maximum number of entries field.
8. Choose Execute.

   The system displays the Translation Worklist screen. You can see the number of entries that match your selection criteria in the title bar. The status of each term is displayed as a traffic light icon on the left-hand side of each term entry.
Translating Terms Using a Worklist

9. Translate the index entries and maintain the *Part of speech*.

10. You also can use the following functions, which are available as icons next to each index entry in your worklist. To display a list of all the icons displayed in this screen and their meanings, choose the *Legend* icon from the application toolbar.

   - *Display links to long texts* 🏽
   
     If the term you are translating is used as an index entry, you can use this function to display the info objects to which this term is assigned as an index entry. The system then displays the info objects in the logon language.

   - *Proposal for all untranslated entries* 📝
   
     The system inserts the [best proposal [Ext.]] from the proposal pool (if the source text in your worklist exists in the proposal pool).
The entry conventions for SAPterm differ from those for texts translated in transaction SE63 [Ext.]. Consequently, you may need to change the capitalization of most of the proposals inserted into your SAPterm translation worklist.

Your translations of terms in SAPterm do not need to match entries in the proposal pool. You should therefore not need to change the proposal pool here. Any changes you do make to the proposal pool will lead to modified texts appearing in translation worklists in transaction SE63 [Ext.].

- **Compare with proposal pool**
  
  This function allows you to display the proposal pool entry for that term. You can then copy the translation you require from the proposal pool to your SAPterm translation worklist.

- **Copy source text**
  
  This function allows you to copy the source text to your translation line.

- **SAPterm: Display Identical Entries**
  
  This function allows you to look up terms in SAPterm which have the same source text as the source text in your translation worklist. You can copy a translation from SAPterm by selecting the translation you require and using the Copy translation icon in the dialog box. You can also display the terminology concept by choosing the Display term concept icon.
Translating Terms Using a Worklist

If you would like to enter additional information for your target language terms, you can call them up directly in a separate session of transaction STERM. You can then enter synonyms and abbreviations for a specific term.

11. Save your entries.

12. If you would like to call up further term entries matching the selection criteria you entered on the selection screen, choose the Next entries icon in the application toolbar.

Result

Once you have saved your worklist, the system uploads the information back into SAPterm.
Translating Index Entries

Use

Index entries are maintained by documentation developers in the Knowledge Warehouse [Ext.] in order to help users find information more easily.

Index entries are translated in SAPterm by means of a translation worklist.

Procedure

2. Call up transaction STERM.

4. Choose Utilities → Translation worklist.

   The Create Translation Worklist screen appears.

5. Enter the Application component and the user name of the author of the index entries for your folder in the Created by field.

   It is not possible to enter an author only without an application component.

7. Select the category Index entries only and the translation status All entries to see both translated and untranslated index entries, or New entries to display only untranslated entries.

8. Set the number of entries you would like to display at a time in the Maximum number of entries field.

9. Choose Execute.

   The system displays the Translation Worklist screen. You can see the number of index entries that match your selection criteria in the title bar.
If you have selected by application component only, the list may contain entries from other authors working in this application component.

If you have selected by application component and author, the system will display all (or all untranslated) entries created by the author in this application component.

10. Translate the index entries and maintain the Part of speech.

11. You also can use the following functions, which are available as icons next to each index entry in your worklist. To display a list of all the icons displayed in this screen and their meanings, choose the Legend icon from the application toolbar.

   – Display links to long texts

     You can use this function to display the info objects to which the index entry is assigned. The system then displays the info objects in the logon language.
This may include objects from other folders if other authors reference the same index entries.

Proposal for all untranslated entries

The system inserts the best proposal [Ext.] from the proposal pool (if the source text in your worklist exists in the proposal pool).

The entry conventions for index entries differ from those for texts translated in transaction SE63 [Ext.]. Consequently, you may need to change the capitalization of most of the proposals inserted into your SAPterm translation worklist.

Index entries do not need to match entries in the proposal pool. You should therefore not need to change the proposal pool here. Any changes you do make to the proposal pool will lead to modified texts appearing in translation worklists in transaction SE63 [Ext].
Translating Index Entries

- **Compare with proposal pool**
  
  This function allows you to display the proposal pool entry for that term. You can then copy the translation you require from the proposal pool to your SAPterm translation worklist.

- **Copy source text**
  
  This function allows you to copy the source text to your translation line.

- **SAPterm: Display Identical Entries**
  
  This function allows you to look up terms in SAPterm which have the same source text as the source text in your translation worklist. You can copy a translation from SAPterm by selecting the translation you require and using the *Copy translation* icon in the dialog box. You can also display the terminology concept by choosing the *Display term concept* icon.

If you would like to enter additional information [Page 39] for your index entries, you can call them up directly in a separate session of transaction STERM. You can then enter synonyms and abbreviations for a specific index entry.

You can leave index entries untranslated if you feel they are not relevant in the target language. The source language entries will then remain in your worklist as untranslated but will not appear in the index itself.

12. Save your entries.

13. If you would like to call up further index entries matching the selection criteria you entered on the selection screen, choose the *Next entries* icon (➡️) in the application toolbar.

**Result**

Once you have saved your worklist, the system uploads the information back into SAPterm.
Translating Glossary Definitions

You must translate SAPterm terminology entries in SAPterm itself. However, when you translate glossary entries, you have two options:

- You can translate the definition text as part of the translation workflow in transaction SE63 [Ext.].
- You can translate the text manually.

Translating Glossary Entries in SE63 Translation Worklists

Prerequisites

In order for the definition text to appear for translation in SE63, you must first translate the term's designation in SAPterm. The definition will not appear in your worklist for translation if the designation is not available for the header information.

Translate the term's designation as early as possible. If you translate it too late in the release cycle, the definition may not be included in the final worklist run.

Procedure

1. On the initial SAPterm screen, check the source and target language settings.
2. Find the source language term and choose Maintain entry.
4. On the Maintain Translation of "<Term>" screen, enter the translation of the term and all required information, and save your entries.
5. Exit the translation and maintenance screens.
Translating Glossary Definitions

Result
The definition text will appear in your worklist after the next worklist run. You can use the split screen editor to translate the definition more easily, without running the risk of changing or deleting the source text. For more information, see Functions in the Split Screen Editor [Ext.].

Translating Glossary Entries in SAPterm Manually

Use
If a glossary entry was not included in a worklist run or needs to be translated quickly, translate the definition text manually. You can copy and paste the source text into the definition field for the translation, then overwrite the source text with the translation.

Procedure
1. On the initial SAPterm screen, check the source and target language settings.
2. Find the source language term and choose Maintain entry.
4. On the Change: GLOSSAR <term> Language <source language key> screen, select the definition text and copy it to your clipboard.

Do not make any changes or deletions to the definition text itself without the consent of the author.
5. Return to the Maintain Entry screen, and then choose Translate entry.
6. On the Maintain Translation of "<Term>" screen, enter the translation of the term, if you have not already done so, along with all the required information, and save your entries.
You cannot create a glossary entry without saving the term first. The term and its application component ID serve as the header for the definition text.

7. Once the term exists in the target language, choose Maintain glossary.
8. Paste the definition text that you copied to your clipboard into the SAPscript editor field.
9. Translate the text by overwriting the source text. Ensure the paragraph format commands correspond to those used in the source definition text.
10. Save the glossary entry to return to the Maintain Translation of "<Term>" screen. Save the entry again and exit.

Result

The definition text is translated and will not appear in your translation worklist unless it is changed between worklist runs. It then appears as a modified long text.
Glossary in SAPterm

A glossary entry contains the definition of the concept to which the term refers.

To see glossary entries as they are displayed on the documentation CD, choose Help → Glossary in any system.

Which terms require glossary entries?

- Terms that appear only in SAP products and that are not defined anywhere else.
- Terms with variant meanings in different contexts need to be defined in an SAP context in order to avoid misunderstandings.
- Many (but not all) specialist terms in business, specific industries, or information technology must be defined in an SAP context in order to relate them to the use of SAP products.

What is not a glossary entry?

- Terms defined by other companies for their products.
- Terms with generally understood meanings and usage (computer, accounting). Term entries may be necessary to standardize a translation; glossary entries, however, are superfluous.

Glossary Links

SAPterm assigns each terminology concept a globally unique identifier (GUID) in the background to distinguish the entry from all other entries. The GUID is 32 characters long and thus unique.

When you create a link to a glossary entry, the link uses the GUID to display the appropriate glossary entry based on the contextual information in the object. For example, a glossary link in English-language documentation displays the English glossary entry. Other contextual limitations would include release, country, and industry.

All glossary entries exist simultaneously as identical SAPscript and HTML files. This allows you to set links from SAP System documentation and from Knowledge Warehouse (KW) documentation.

SAPscript glossary entries are created immediately in a database table to be distributed to other systems as part of the language transports from the translation system. You can thus create links from system objects to new entries if the table is available in the system you are working in. For more information, see Links to other Objects [Ext.].

HTML glossary entries are replicated in the Info Repository within a few minutes or in an automatic, overnight background job if you choose to wait. You can create links from KW documentation to new entries as soon as the HTML exists in the Info Repository. For more information, see Inserting Global Hyperlinks [Ext.].

See also:

Create and Change Glossary Definitions [Page 79]
Translating Glossary Definitions [Page 81]
Creating and Changing Glossary Definitions

Use

Glossary definitions are maintained in SAPterm using the SAPscript editor [Ext.]. When you create a glossary entry, SAPterm uses a predefined style template that ensures a consistent layout for the definition in both the SAPscript display (SAP System text editor) and in the HTML display (Web browser format).

Prerequisites

- Glossary definitions must be maintained in SAPterm.
- The term for which a glossary definition is to be created must already exist in SAPterm. This ensures that terminology and glossary are consistent.
- You cannot set links to other documentation objects in glossary definitions.

Procedure

1. Call up transaction SAPterm.
2. Enter the term for which you want to create a glossary entry and choose Maintain.
3. Choose Glossary entry from the application toolbar.
   The SAPscript editor appears.
   The application component name and ID of the term are automatically inserted in the title line.
4. Enter the glossary definition.

Choose Format → Paragraph to see a list of available paragraph formats.
5. Save the glossary definition.

6. Return to the Maintain Entry screen.
   A dialog box appears, asking if you want to create the HTML version of the glossary entry now.

7. Choose Yes for the glossary entry to be created immediately, or No for the entry to be created later.

**Result**

SAPscript glossary entries are created immediately in a database table to be distributed to other systems as part of the language transports from the translation system. This means that you can create links from system objects to new entries once the table contents are available in the system you are working in.

HTML glossary entries are replicated in the Info Repository within a few minutes or in an automatic, overnight background job if you choose to wait. You can create links from Knowledge Warehouse documentation to new entries as soon as the HTML exists in the Info Repository.
Translating Glossary Definitions

You must translate SAPterm terminology entries in SAPterm itself. However, when you translate glossary entries, you have two options:

- You can translate the definition text as part of the translation workflow in transaction SE63 [Ext.].
- You can translate the text manually.

Translating Glossary Entries in SE63 Translation Worklists

Prerequisites

In order for the definition text to appear for translation in SE63, you must first translate the term's designation in SAPterm. The definition will not appear in your worklist for translation if the designation is not available for the header information.

Procedure

6. On the initial SAPterm screen, check the source and target language settings.

7. Find the source language term and choose Maintain entry.


9. On the Maintain Translation of "<Term>" screen, enter the translation of the term and all required information, and save your entries.

10. Exit the translation and maintenance screens.

Translate the term's designation as early as possible. If you translate it too late in the release cycle, the definition may not be included in the final worklist run.
Translating Glossary Definitions

Result
The definition text will appear in your worklist after the next worklist run. You can use the split screen editor to translate the definition more easily, without running the risk of changing or deleting the source text. For more information, see Functions in the Split Screen Editor [Ext.].

Translating Glossary Entries in SAPterm Manually

Use
If a glossary entry was not included in a worklist run or needs to be translated quickly, translate the definition text manually. You can copy and paste the source text into the definition field for the translation, then overwrite the source text with the translation.

Procedure
2. On the initial SAPterm screen, check the source and target language settings.
3. Find the source language term and choose Maintain entry.
5. On the Change: GLOSSAR <term> Language <source language key> screen, select the definition text and copy it to your clipboard.

Do not make any changes or deletions to the definition text itself without the consent of the author.
6. Return to the Maintain Entry screen, and then choose Translate entry.
7. On the Maintain Translation of "<Term>" screen, enter the translation of the term, if you have not already done so, along with all the required information, and save your entries.
You cannot create a glossary entry without saving the term first. The term and its application component ID serve as the header for the definition text.

8. Once the term exists in the target language, choose Maintain glossary.

9. Paste the definition text that you copied to your clipboard into the SAPscript editor field.

10. Translate the text by overwriting the source text. Ensure the paragraph format commands correspond to those used in the source definition text.

11. Save the glossary entry to return to the Maintain Translation of "<Term>" screen. Save the entry again and exit.

Result

The definition text is translated and will not appear in your translation worklist unless it is changed between worklist runs. It then appears as a modified long text.
Utilities in SAPterm

- Downloading Terminology from SAPterm [Page 85]
- Creating Glossary Lists [Page 88]
- Calling Up Statistics in SAPterm [Page 90]
Downloading Terminology from SAPterm

You can download lists of terms or index entries to a local file based on various criteria. Some reasons for doing so include:

- You want to give a list of new terms to your product manager or your team for review.
- A colleague needs a list of terms from a given component for reference while on travel.
- You want to run a spellchecker in another program through the index entries in your area.

Downloading Entries from the Results List

Any user with display authorization can download term and index entries from the results list [Page 13].

This example shows how to download a list of all main term entries from a given component that have not yet been translated into a target language. You can, of course, select or deselect other delimiters as you require.

1. Call up transaction STERM.
2. Choose Selection options.
3. Check the source and target languages. Leave the Term field empty or enter an asterisk (*).
4. Enter the correct component in the Application component field.
   - You can use Multiple selection to enter more than one component or groups of components.
5. Under Select Terminology entries only and deselect Index entries.
6. Under Entry category, select Main entries only and deselect the other categories.
7. Choose Execute.
8. When the results list appears, choose the right mouse button and choose Display non-translated entries only.
   - The results list will now display only those entries that have not been translated into the target language. To return to the original hit list, choose the right mouse button and choose Display all entries.
9. Download the resulting list by choosing System → List → Save → Local file.
   - The Save list in file dialog box appears.
10. Select Spreadsheet and choose Enter.
    - The Save DAT to a Local File dialog box appears.
11. You can accept the default directory in the File name field, or you can change it according to your wishes. Do not specify a file format in the Files of type: field.
12. Choose Transfer
13. Start Microsoft ® Excel ® and choose File → Open... In the dialog window, in the Files of type: field, select All Files (*.*) Then find the relevant folder in order to see the downloaded file.
Excel will start the Text Import Wizard which you use to format the data by rows and columns.

You can change the worksheet formatting (such as adjusting the column widths), sort the entries in the resulting worksheet (alphabetically, by component, and so on) and include any additional columns (for instance, a column for feedback or for notes).

14. To keep the formatting and information in the resulting file, save in Excel spreadsheet format (.xls)

**Download Entries with the Download Functions**

SAPterm superusers can download term and index entries using the Utilities option from the initial screen of SAPterm.

This example shows how to download a list of index entries from a given component that have not yet been translated into a target language. You can, of course, select or deselect other delimiters as you require.

1. Call up transaction STERM.
2. Choose Utilities → Download → Terminology.
3. Under Download format, enter EXCEL_LST1 in the Format version field.
4. Under Language selection, enter the key for the source language in the Language field. Choose Multiple selection to enter the target language. Deselect Translated entries only.
5. Under Global attributes, deselect Terminology entries and select Index entries. Enter the correct component in the Application component field.

You can use Multiple selection to enter more than one component or groups of components.

6. Under Entry category, select Main entries only and deselect the other categories.
7. Choose Execute.

The Transfer to a Local File dialog box appears.

8. You can accept the default directory and file name in the File name field, or you can change them according to your wishes.

9. Accept the default format ASCII (ASCII format) appearing in the Data format field. You can choose Download to clipboard to check the file in an ASCII viewer first, but this is not mandatory.

The system downloads the data to the file you specified.

10. Start Microsoft ® Excel ® and choose File → Open... In the dialog window, in the Files of type: field, select All Files (*.*). Then locate the downloaded file and choose Open

    Excel will start the Text Import Wizard which you use to format the data by rows and columns.

    You can change the worksheet formatting (such as adjusting the column widths), sort the entries in the resulting worksheet (alphabetically, by component, and so on) and include any additional columns (for instance, a column for feedback or for notes).

11. To keep the formatting and information in the resulting file, save in Excel spreadsheet format (.xls)
12. To find the non-translated entries, select the entire worksheet and choose \textit{Data} \rightarrow \textit{Sort}.
   Sort by the column with the target entries.

   Excel will sort the non-translated entries to the bottom of the list.
Creating Glossary Lists

Use

You can download glossary entries from SAPterm into a local file for use in special projects (for example, as an appendix to a brochure or training manual).

Procedure

1. Call up transaction STERM.
2. Choose Utilities → Download → Glossary (HTML).
   The Glossary Download in HTML Format screen appears.
3. Under Selection criteria, enter the Language you require.
   At the present, the glossary is available only in English and German.
4. Enter the key for the application component you require in the Component field. You can enter an asterisk (*) after the component key to include the glossary entries for all associated subcomponents, or you can choose Multiple selection to include the glossary entries for several separate components.
   To create a glossary with all glossary entries in CO, enter CO. To include the glossary entries of all the related subcomponents, enter CO*. To include the glossary entries only for CO, FI, and TR, choose Multiple selection and enter CO, FI, and TR.
5. Choose Execute.
   The system calculates the number of glossary entries in the component and creates the file.
   The Transfer to a Local File dialog box appears.
10. You can accept the default directory and file name in the *File name* field, or you can change them according to your wishes.

11. Accept the default format *ASC* (ASCII format) appearing in the *Data format* field. You can choose *Download to clipboard* to check the file in an ASCII viewer first, but this is not mandatory.

12. Choose *Transfer*.

**Result**

The system downloads the HTML format file to the specified directory. You can then display or edit the text with HTML editors and browsers or with word processing programs.

The system downloads the glossary in HTML format. You can change the format or save the file in another format with most HTML editors or word processing programs. You may have to search for and delete hidden HTML text commands if you change the file format; otherwise, they may affect the text display in other formats.
Calling Up Statistics in SAPterm

Status and Components

Use

These statistics show you the number of new terms, terms to be checked, released terms and terms pending deletion for one or more languages and application components.

Prerequisites

You need superuser authorization to call up statistics based on status and component.

Procedure

2. Under Entry category, select whether you want to view statistics for Terminology entries, Index entries, or both.
3. Under Type of report, select By component and enter the Language and Application component for which you want to display the statistics.
   - To display statistics for several languages and application components, use the Multiple selection icons.
   - To display statistics for all application components choose Overview under Type of report.
4. Choose Execute.

Result

The following information is displayed according to each language and component:

- Number of new terms (status 1)
- Number of terms to be checked (status 2)
- Number of released terms (status 3)
- Number of terms pending deletion (status 4)
- Total number of terms

Period-Based Statistics

Use

You can use these statistics to display information on terminology activities for one or more languages or components over a specific period of time.

Prerequisites

You need superuser authorization to call up the period-based statistics.
**Procedure**

1. Call up transaction STERM and choose **Utilities ➔ Statistics ➔ Based on period.**
2. Under **Type of report,** select whether **By language and component** and enter the **Language** and **Application component** for which you want to display the statistics.
   - To display statistics for several application components, use the **Multiple selection** icons.
   - To display statistics for all application components choose **By language** under **Type of report.**
3. Under **Languages,** enter the **Language** for which you want to display the statistics. To display the statistics for more than one language at a time, use **Multiple selection.**
4. Under **Entry category,** choose whether you want to display the statistics for **Terminology entries,** **Index entries** or **Glossary entries.**
5. Under **Period,** select whether you want to display **Weekly,** **Monthly,** or **Annual** values, and enter the **Start/end date** for the statistics.
6. Choose **Execute.**

**Result**

The system displays the number of terms entered in SAPterm for the language you selected, according to the component for each period (week, month, or year) in the date range you selected:

**Terminology Statistics for Translation**

**Use**

This statistics function displays the translation quotas for terms with **entry class [Page 31]** System texts and Documentation, and for **index entries [Page 18]** for a specific source and target language.

**Prerequisites**

To display the translation statistics, you need superuser authorization.

**Procedure**

1. Call up transaction STERM and choose **Utilities ➔ Statistics ➔ Translation.**
2. Enter the **Source language** and **Target language** for which you want to view the translation statistics.
3. Enter the application component you require. To display the translation statistics for more than one component, use **Multiple selection.**
4. Choose **Execute.**

**Result**

The following information is displayed for the component(s) you selected.
- Percentage of translated terms with entry class **System texts**
- Percentage of translated terms with entry class **Documentation**
Calling Up Statistics in SAPterm

- Percentage of translated index entries
- Number of translated terms
- Total number of terms
- Overall percentage of translated terms

Glossary Statistics

Use
This function displays statistics on the volume of lines in the glossary.

At present, the glossary is only available in German and English.

Prerequisites
To display the glossary statistics, you need superuser authorization.

Procedure
Call up transaction STERM and choose Utilities → Statistics → Glossary.

Result
The system displays the following information for the languages in which the glossary is available:

- Total number of glossary entries
- Number of glossary entries that were originally written in this language
- Total number of lines of glossary
- Number of glossary lines that were originally written in this language