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SAP@Web Studio 
Purpose 
The SAP@Web Studio is a PC tool for developing Internet applications.  
The SAP@Web Studio allows you to create, modify, and manage all the files required by the 
Internet Transaction Server (ITS) to drive Internet applications that access data in the R/3 
System. Users can start these applications from any suitable Web browser.  
Developing Internet applications driven by the ITS is a two-stage process that defines a clear 
separation between business logic and presentation logic. This process takes place both inside 
and outside the R/3 System.  
• Inside the R/3 System. you define the business logic.  

To implement the business logic, you create transactions, function modules, or simple 
reports, in the ABAP Workbench.  
If you are using the Web transactions implementation model to enable R/3 transactions 
to run from a Web browser, the dialog flow is defined in the screen flow logic of the 
relevant transaction on the R/3 side.  

• Outside the R/3 System, you define the presentation logic.  
To implement the presentation logic, you create all the required ITS files in the 
SAP@Web Studio.  
If you are using the flow file implementation model to develop an application where user 
navigation is not predefined in advance, you also define the dialog flow in the SAP@Web 
Studio.  

Implementation Considerations 
If you want to develop Internet applications that users can run from a Web browser via the ITS to 
access data in the R/3 System, you should install the SAP@Web Studio.  

Integration 
To allow Internet applications developed in the SAP@Web Studio to access data in the R/3 
System, you must install an R/3 System, which is Release 3.0D or higher.  
To connect the R/3 System to the Internet, test Internet applications developed in the SAP@Web 
Studio, and allow users to run them from a Web browser, you must also install the ITS.  

Features 
The SAP@Web Studio contains several features that support the development, design, and 
testing of Internet applications. This involves creating, maintaining, publishing, and managing all 
the ITS files required to run them.  
The SAP@Web Studio wizards allow you to:  
• Create ITS services.  
• Generate HTMLBusiness templates.  
• Create language resources.  
Using the application design features in the SAP@Web Studio, you can:  
• Define the presentation aspects (“look and feel“) of applications by editing HTMLBusiness 

templates in the HTMLBusiness editor.  
The HTMLBusiness editor provides support for entering both HTMLBusiness and standard 
HTML code.  
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• Define the dialog flow of applications based on the flow file implementation model by 
generating a flow file for each HTMLBusiness template in the HTMLBusiness editor.  

The HTMLBusiness editor provides support for entering the eXtensible Markup Language 
(XML) code that defines the dialog flow of such applications.  

• Edit services and languages in the grid control editor.  
The grid control editor allows you to enter parameters in name/value pairs.  

− In service files, the parameters define how a service should run.  
− In language resource files, the parameters define the language-independent texts used 

in your application.  
When you have completed the design process, you can use the SAP@Web Studio’s testing, file 
publishing, and source control facilities to:  
• Test new applications by running them directly in a Web browser.  

The HTMLBusiness editor allows you to preview the layout of HTMLBusiness templates and 
view data values in context by recording them when you run an application.  

• Publish the files that make up an application to an ITS site.  
It is also possible to publish individual files as you develop applications.  

• Manage the files that make up an application in ITS source control within the R/3 System.  
For an overview of the steps required to develop Internet applications driven by the ITS in the 
SAP@Web Studio, see Internet Application Development [Seite 12].  

 
The SAP@Web Studio is a flexible, integrated development environment that allows 
you to develop Internet applications driven by the ITS outside the constraints of the 
R/3 System.  
You can also develop Internet applications by implementing services inside the R/3 
System. To do this, you use the Web Application Builder in the ABAP Workbench. 
For further information, see the section on integrating Internet services in BC ABAP 
Workbench Tools [Extern]. If this link does not work from your current location, and 
you are outside the R/3 System, log on to the latest release and see under Help → 
SAP Library → Basis Components → ABAP Workbench (BC-DWB) → BC ABAP 
Workbench Tools.  
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ITS File Types 
All Internet applications developed in the SAP@Web Studio are known to the Internet 
Transaction Server (ITS) as services.  
An ITS service is the set of files required by the ITS to run an Internet application from a Web 
browser. Each service can consist of up to five ITS file types:  
• A service file  
• HTMLBusiness templates  
• Flow files  
• Language resources  
• Multipurpose Internet Mail Extension (MIME) files  

Service File 
The service file contains the service description, which is the set of parameters that determines 
how a service runs. If this information is incomplete at runtime, the ITS may derive some details 
from the global service file (see below), or require the user to enter logon information. In any 
case, there must be one service file for each application.  
Each service can be divided into one or more themes. Themes are instances of services that 
differ only in look and feel (appearance, graphics, layout or language). Each theme has its own 
set of HTMLBusiness templates, flow files (if applicable), language resources, and Multipurpose 
Internet Mail Extension (MIME) files, but the functionality of the service is identical. In the 
SAP@Web Studio, themes are stored in subdirectories of the service directory.  

HTMLBusiness Templates 
HTMLBusiness templates are the means used by the ITS to display application screens in a Web 
browser when running a service.  
For each screen, there must be one HTMLBusiness template. Each template contains standard 
HTML code, and HTMLBusiness statements.  
HTMLBusiness is an SAP-specific macro language, which allows you to merge R/3 data dynamically 
into HTMLBusiness templates. 

Flow Files 
Flow files contain the dialog flow logic that defines logical transitions between application states, 
depending on what the user chooses to do in the course of running an application.  
When you are developing applications with the flow file implementation model, you need to 
generate one flow file for each HTMLBusiness template. Each flow file contains Extensible Markup 
Language (XML) statements, using a predefined subset of XML elements.  

Language Resources 
Language resources are language-independent texts used by the ITS to run a service in a 
particular language.  
Instead of hard-coding language-specific texts in HTMLBusiness templates, you specify 
placeholders and store the texts in the relevant language resource file. At runtime, the ITS looks 
for placeholders in the templates and replaces them with texts from the language resource file.  
For ease of maintenance alone, it makes sense to keep HTMLBusiness templates for a service 
language-independent by creating language resources. However, not all templates use language 
resource files, and they are not mandatory.  
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MIME Files 
MIME files contain the image, sound, and video elements you may want to include in services to 
enhance the visual appearance and effectiveness of your Internet applications. Like language 
resources, MIME files are optional.  

Summary of ITS File Types 
The following table summarizes the ITS file types used to develop Internet applications in the 
SAP@Web Studio, together with their name format and file extenson. The table also specifies 
whether each file type is required or optional.  

ITS File Types 

File Type File Name Format and Extension Required or 
Optional? 

Service file <service>.srvc Required. 
One service file 
per application. 

HTMLBusiness  
templates 

Web transaction implementation model: 
• Language-independent templates: 

<program>_<screen>.html 
• Language-specific templates: 

<program>_<screen>_<language>.html 
The <program>, <screen>, and <language> 
elements refer to the R/3 program, screen, and 
development language of the associated ABAP 
transaction.  
Flow file implementation model:  
• <template name>.html 

In this case, the template name is arbitrary. 

Required. 

Flow files Flow file implementation model:  
• <template name>.flow 

One for each HTMLBusiness template. 

Required in flow 
file applications. 

Language  
resources 

<service>_<language>.htrc Optional but 
recommended. 
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MIME files MIME file names are arbitrary. The file extensions 
depend on the type of file you are using. Here are some 
examples:  
• Image files: 

− <name>.gif  
− <name>.jpeg 

• Video files 
− <name>.avi 

• Sound files 
− <name>.wav 

Optional. 

Global Service File 
Services also derive information from the global service file (global.srvc), which is created 
during ITS setup and defines default parameter values for all services. The values defined in 
individual service files always override values in the global service file.  
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ITS File Storage Locations 
The storage location of Internet Transaction Server (ITS) files that make up Internet applications 
developed in the SAP@Web Studio depends on the file type and whether the files have already 
been published, as shown in the following table: 

ITS File Storage Locations 

File Type Storage Location 

Unpublished files Project directory on local hard drive. 
The default is: 
C:\Program 
Files\SAP\Studio\2.0\bin\<project> 

Published HTMLBusiness templates 
and all other non-MIME files 

ITS site [Seite 38] 

Published MIME files Web server 

Master copies of files ITS source control in R/3 
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Internet Application Development  
Purpose 
This process describes the main steps you have to take in the SAP@Web Studio to develop 
Internet applications driven by the Internet Transaction Server (ITS).  

Prerequisites 
You have defined the business logic in the R/3 System:  
• If you are developing an application based on the Web transactions implementation model, 

you have developed a dialog transaction.  
You must do this first, because you need to be able to specify the underlying ABAP 
program and screen numbers when creating HTMLBusiness templates.  

• If you are developing an application based on the flow file implementation model, you have 
developed a set of Business APIs (BAPIs) or standard function modules.  

In this case, it is not essential to define the business logic first, but it makes sense to 
follow the procedure described in this documentation.  

Process Flow 
To develop an Internet application that accesses data in the R/3 System and can be run from a 
Web browser, you must create an Internet Transaction Server (ITS) service.  
The steps specified below describe how to:  
• Create a new service.  
• Modify an existing service.  

Creating a New Service 
1. Start the SAP@Web Studio [Seite 17] and set up the environment [Seite 21]. 
2. Create a new project [Seite 32] to store the service directories and files. 

You can assign several services to one project. 
3. Define an ITS site [Seite 39]. 
4. Create the ITS files: 

a. Create the service [Seite 43]. 
b. Create the HTMLBusiness templates [Seite 48]. 
c. If required, create flow files [Seite 52] for the HTMLBusiness templates.  
d. If required, create language resource files [Seite 53]. 
e. If required, create more themes [Seite 55] for the service. 

5. Specify the active service [Seite 87]. 
6. Edit the files [Seite 58] as necessary, and perform a syntax check [Seite 71] on the 

HTMLBusiness templates. 
7. Publish and test [Seite 86] the service. 
8. Store the new files in ITS source control: 

a. Add the files to ITS source control [Seite 95]. 
b. Create a change request in the R/3 System. 
c. Assign the files to the change request [Seite 96]. 
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Modifying an Existing Service 
1. Start the SAP@Web Studio [Seite 17] and, if necessary, adjust the environment [Seite 21]. 
2. Open an existing project [Seite 33]. 
3. Select an existing ITS site [Seite 41]. 
4. Import the existing files [Seite 36]. 

You can import files from the ITS server, or from the Web server, or check them out of 
ITS source control. 
If you import the files from ITS source control, you must assign them to a change request 
[Seite 96]. 

5. Specify the active service [Seite 87]. 
6. Edit the files [Seite 58] as necessary, and perform a syntax check [Seite 71] on the 

HTMLBusiness templates. 
7. Publish and test [Seite 86] the service. 
8. If you previously checked the files out of ITS source control, check them back in [Seite 98]. 

Result 
You can now run the new or modified application from a Web browser.  
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SAP@Web Studio User Interface  
Purpose 
This process describes the basic functions of the SAP@Web Studio user interface.  
The SAP@Web Studio user interface is a flexible environment, which you can adjust to suit your 
development requirements. It includes all the features you need to create, maintain, and manage 
files required by the Internet Transaction Server (ITS) to run Internet applications from a Web 
browser.  

SAP@Web Studio User Interface 

 
Apart from the title bar and standard toolbar, the user interface consists of:  
• Four windows:  

− Main work area  
− Project workspace  
− HTML Tags  
− Message area  

• Publish toolbar  

SAP@Web Studio Windows 
The four main windows that make up the SAP@Web Studio user interface are listed in the 
following table: 
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Window Location Purpose 

Main Work Area Upper right window. Used to display and edit ITS files. 

Project Workspace Upper left window. Lists all ITS files belonging to the current 
project.  
There are two available views [Seite 19], so 
what you see depends on the view you 
choose. The above graphic shows the File 
View. 

HTML Tags Below project workspace Displays a list of standard HTML tags.  
You can modify the initial list to include the 
tags you use most frequently for developing 
HTMLBusiness templates. 

Message Area Lower window. Displays status and error messages. 

You can adjust the relative size of all these windows (see below for details).  

SAP@Web Studio Publish Toolbar 
Located below the standard toolbar, the SAP@Web Studio publish toolbar contains a list box for 
currently defined ITS sites, as well as functions for building, publishing, and testing ITS services.  

SAP@Web Studio Publish Toolbar 

 
The elements in the publish toolbar are listed in the following table, moving from left to right: 

Element Description Purpose 

 
ITS site field. Contains currently defined ITS sites [Seite 38]. 

 
Publish button. Publishes specified ITS files to a specified ITS 

site. 

 
Build button. Publishes all ITS files in the currently active 

service to the current ITS site. 

 
Go button. Publishes all ITS files in the currently active 

service to the current ITS site, opens a Web 
browser, and starts the service. 

 
When you start the SAP@Web Studio, the main work area on the right is blank, so 
the Editor menu is inactive and thus not displayed in the menu bar. As soon as you 
open an HTMLBusiness template or other file for maintenance, the SAP@Web Studio 
inserts the Editor menu between the Tools and Options menus, as shown in the 
above graphic.  

Process Flow 
Before starting to develop Internet applications, you need know how to:  
• Start and stop [Seite 17] the SAP@Web Studio.  
• Adjust the user interface [Seite 18] to suit your needs.  
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• Use the project workspace views [Seite 19].  
• Use the editors [Seite 20].  
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Starting and Stopping the SAP@Web Studio 
Prerequisites 
You must have installed the SAP@Web Studio.  

Procedure 
The table below describes the procedures for starting and stopping the SAP@Web Studio: 

Function Procedure Remarks 

Start the 
SAP@Web Studio 

On the Windows NT 4.0 desktop, choose 
Start → Programs → SAP@Web Studio 
→ Studio <release>. 

The SAP@Web Studio 
installation procedure 
automatically inserts an entry 
in the Programs menu on 
your Windows NT 4.0 
desktop. 

Stop the 
SAP@Web Studio 

In the SAP@Web Studio, choose File → 
Exit. 

If the SAP@Web Studio 
detects unsaved changes, it 
prompts you to save them. 
When you confirm, the 
SAP@Web Studio closes all 
R/3 connections and 
terminates. 
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Adjusting the User Interface  
Use 
You can adjust the SAP@Web Studio user interface to suit your needs.  

Procedure 
The following table describes the functions available for adjusting the SAP@Web Studio user 
interface:  

To Procedure 

Adjust relative size of a window. 1. Place cursor between two windows until you 
see a crosshair cursor. 

2. Drag in either direction until you achieve the 
desired size. 

View/hide the publish toolbar. Choose View → Publish Toolbar. 

View/hide ITS files in project workspace. Choose View → Project Workspace. 

View/hide tags in HTML Tags window. Choose View → HTML Tags. 

View/hide output in message area. Choose View → Message Area. 
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Using the Project Workspace Views 
The SAP@Web Studio’s project workspace allows you to display the Internet Transaction Server 
(ITS) files in two different views, as listed in the following table: 

View Description Remarks 

File View Displays a file system view of all 
services assigned to a project. 

In this view, you can expand the 
hierarchy for each service to display the 
associated HTMLBusiness templates and 
other files. 
You can only display the files associated 
with one project at once. 

Source Control Displays all files in ITS source 
control at the currently defined 
ITS site. 

To see this view, you must connect to 
the R/3 System. 

Procedure 
The following table describes the functions available for manipulating views and files in the 
project workspace: 

Function Procedure 

Select view Select the tab for the view you want. 
To display files in the Source Control view, you must connect to the R/3 
System [Seite 94]. 

Edit files To edit files in any of the views, double-click on the file names. 
This opens the file in the appropriate editor in the main work area. 

Other file-related 
functions 

1. Select any file in the File View. 
2. Click the right mouse button. 

You see a list of possible functions in a pop-up window. 
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Using the SAP@Web Studio Editors 
To edit the various Internet Transaction Server (ITS) file types, the SAP@Web Studio provides 
different editors:  
• HTMLBusiness editor  

You use the HTMLBusiness editor to edit HTMLBusiness templates and flow files.  
• Grid control editor  

You use the grid control editor to edit service files and language resource files.  

Procedure 
Using the HTMLBusiness Editor 
To open the HTMLBusiness editor: 
1. Go to the File View in the project workspace.  
2. Expand the hierarchy for a service.  
3. Double-click on the name of an HTMLBusiness template (extension .html).  
For further information about editing HTMLBusiness templates and flow files in the HTMLBusiness 
editor, see HTMLBusiness Editor [Seite 59].  

Using the Grid Control Editor 
To open the grid control editor:  
1. Go to the File View in the project workspace.  
2. Expand the hierarchy for a service.  
3. Double-click on the name of a service file (extension .srvc) or a language resource file 

(extension .htrc).  
For further information about editing service files and language resource files in the grid control 
editor, see Grid Control Editor [Seite 74].  
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SAP@Web Studio Options 
Purpose 
This process describes the options available in the SAP@Web Studio for customizing your 
environment.  

Process Flow 
You can:  
• Specify R/3 connection information [Seite 22]  
• Specify a file viewer application [Seite 24]  
• Specify default languages, character sets, and fonts [Seite 25]  
• Specify a default project directory [Seite 28]  
• Set the Web browser to open inside the SAP@Web Studio [Seite 29]  
• Set HTMLBusiness editor options [Seite 30]  
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Specifying R/3 Connections 
The SAP@Web Studio allows you to predefine logon information for each R/3 System to which 
you want to connect. This information includes:  
• R/3 System details (system ID, host, and message server)  
• User details (client, user name, password, and language)  
You can specify R/3 connections that log on by group or by server:  
• Connection by group  

Logging on by group means that the system chooses the application server host for you 
at runtime. This lets the system balance the user load by choosing the host machine that 
is least busy. If you are unsure which group to use, ask your system administrator. 
In general, you should specify R/3 connections by group whenever possible. 

• Connection by server 
Sometimes, you want to log on to a specific R/3 host. If you create a connection by 
server, you specify this host explicitly. This means that when you log on, you are 
connected to this system only. 

Procedure 
Function Procedure 

Specify Connection By Group 1. Choose Options → R/3 Systems. 
2. Choose Group. 
3. Select an R/3 System and choose Lookup. 

The SAP@Web Studio displays a list all available 
groups. 

4. Select the desired group and choose Add. 
The SAP@Web Studio displays R/3 System 
information for this connection. 

5. Enter (or update) the values in these fields, as desired. 
− Description  
− System Number  

6. Choose OK. 

Specify Connection By Server 1. Choose Options → R/3 Systems. 
2. Choose Server. 
3. Select an R/3 System and choose Lookup. 

The SAP@Web Studio displays a list of all available 
servers. 

4. Select the desired group and choose Add. 
The SAP@Web Studio displays R/3 System 
information for this connection. 

5. Enter (or update) the values in these fields, as desired. 
− Description  
− System Number  

6. Choose OK. 
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Specifying File Viewers 
The SAP@Web Studio allows you to select a file viewer for displaying files. This is useful if, for 
example, you want to display graphics in a particular graphics viewer.  
If you predefine the applications you want to use as file viewers, you do not have to navigate to 
an application each time you want to use it to view a file.  

Procedure 
You can add a file viewer, change its properties, or delete it, as described in the following table: 

Function Procedure Result 

Add file viewer 1. Select Options → Studio Properties. 
2. Select the Send To: tab page. 
3. Find the file viewer you want to add 

to the list of known file viewers: 
a. Choose Add. 
b. Navigate to directory that 

contains required file viewer. 
c. Select program name, and 

choose Open. 
d. In the Shortcut tab page, enter 

an application name, and any 
command line arguments. 

For information about 
command line arguments, 
see the documentation fo 
the file viewer. 

4. Choose OK. 

The SAP@Web Studio adds 
the selected file viewer to its 
list of known viewers. 
You can also choose Apply 
instead of OK. Apply saves 
your settings, but leaves the 
Studio Properties dialog open. 

Change file viewer 
properties 

1. Select Options → Studio Properties. 
2. Select the Send To: tab page. 
3. Select the file viewer you want to 

change. 
4. Choose Properties. 
5. Change the entry as desired, and 

choose OK. 

The SAP@Web Studio 
updates the properties of the 
selected file viewer. 
You can also choose Apply 
instead of OK. Apply saves 
your settings, but leaves the 
Studio Properties dialog open. 

Delete file viewer 1. Select Options → Studio Properties. 
2. Select the Send To: tab page. 
3. Select the file viewer you want to 

delete. 
4. Choose Delete. 

The SAP@Web Studio 
deletes the selected file 
viewer. 
You can also choose Apply 
instead of OK. Apply saves 
your settings, but leaves the 
Studio Properties dialog open. 
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Native Language Support (NLS) 
Purpose 
This process describes how you can set options in the SAP@Web Studio to support HTMLBusiness 
templates that contain texts in virtually any language.  
Since most western languages are represented by a single-byte character set, this is the default 
in the SAP@Web Studio. However, many Asian languages require a double-byte character set to 
be displayed properly. If, for example, you have templates that contain Japanese texts, they 
cannot be read by the default character set.  

Process Flow 
To internationalize the SAP@Web Studio, you need to:  
1. Install the National Language Pack for Windows NT on your system.  

See the Microsoft Web site for details.  
2. Specify the default language [Seite 26].  
3. Specify the character set or font [Seite 27] that corresponds to your locale.  
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Specifying a Default Language 
In the SAP@Web Studio, you can specify a default language to be used for displaying all your 
files. This determines the character set used to display your code.  

Prerequisites 
You must install the National Language Pack for Windows NT.  

Procedure 
To specify the default language centrally: 
1. Choose Options → Studio Properties. 
2. Select the Fonts tab page. 
3. Select the language you want to use as the default language. 

Result 
The SAP@Web Studio uses the selected language for displaying all files. 

 
The character set used is important only for language-specific texts that you code 
explicitly in your HTMLBusiness templates. If the templates contain language resource 
keys, you always see these in the HTMLBusiness editor. Text substitution does not 
occur until the Internet Transaction Server (ITS) interprets the keys at runtime. 
Remember also that the length of the language key depends on the release of your 
R/3 System: 
• One character for R/3 releases prior to 4.0 (for example, e for English) 
• Two characters for R/3 releases from 4.0 (for example, en for English) 
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Specifying a Default Character Set and Font 
In the SAP@Web Studio, you can specify a default character set and font to be used for 
displaying all your files. 
The HTMLBusiness editor supports all proportional and fixed fonts that are available for a particular 
character set. 

Prerequisites 
You must install the National Language Pack for Windows NT. 

Procedure 
1. Choose Options → Studio Properties. 
2. Select the Fonts tab page. 
3. In the Language group box, select a language. 
4. In the Character Sets group box, select a character set for your language. 
5. Select a font for your character set from the dropdown list box. 
6. Choose OK. 

You leave Studio Properties. 
7. Click the globe button in the status bar. 

You get a list of character sets. 
8. Select the character set you want. 

Your selection is activated in the HTMLBusiness editor. 

Result 
The SAP@Web Studio uses the selected character set and font for displaying all files. 
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Specifying a Default Project Directory 
The default project directory is the default location for all projects created in the SAP@Web 
Studio, but you can specify any directory you like. The default path is: 

C:\Program Files\SAP\Studio\2.0\bin\<project> 

You can also specify that files you remove from the project hierarchy in the project workspace 
should also be deleted from the hard disk. 

Procedure 
Function Procedure Result 

Specify default project directory 1. Choose Options → 
Studio Properties. 

2. Select the Directories 
tab page. 

3. Enter a directory name 
in the Default Project 
Dir: field. 

The SAP@Web Studio uses 
the selected directory to store 
all projects. 

Delete files from hard disk as 
well as from project hierarchy 

Check the box Delete files 
from disk, if removed from 
project. 

 

 

 
The project directory is always located on your host machine, so you can set the 
default project directory to any local directory you like. 
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Opening a Web Browser in the SAP@Web Studio 
When you test a service, the SAP@Web Studio automatically opens a Web browser on your 
machine.  
By default, the Web browser runs outside the SAP@Web Studio. Sometimes, however, it is 
useful to open the Web browser inside the SAP@Web Studio. 

Procedure 
To specify that you want the Web browser to open inside the SAP@Web Studio: 
1. Choose Options → Studio Properties. 
2. Select the Web Browser tab page. 
3. Ensure that Open Browser window in Studio is selected. 

 
Opening a Web browser inside the SAP@Web Studio works only for Microsoft 
Internet Explorer 4.0 (or higher).  
All other browsers must be opened outside the SAP@Web Studio. 
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Setting HTMLBusiness Editor Options 
To support the development of HTMLBusiness templates, the HTMLBusiness editor displays the 
various elements of HTMLBusiness code in different colors. This makes the code more easily 
readable, and distinguishes it from standard HTML code.  
You can change the default colors for each element of HTMLBusiness to suit your needs.  

Procedure 
To set colors for displaying HTMLBusiness code in the HTMLBusiness editor:  
4. Select Options → Studio Properties.  
5. Select the Editor tab page.  

You see a list of HTMLBusiness elements with their HTMLBusiness editor default colors:  

 
6. Choose the element you want to customize, select a color from the palette, and choose OK.  

Result 
The SAP@Web Studio resets the default color for the element.  
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ITS Project Management 
Purpose 
This process describes how to manage Internet Transaction Server (ITS) projects in the 
SAP@Web Studio. 

Process Flow 
Before you start to develop an Internet application in the SAP@Web Studio, you should create a 
project. This is a convenient way of grouping the constituent ITS files, because it allows you to 
define which service you want to work on, and keeps the number of files small and focused. 
The default project directory for all projects created in the SAP@Web Studio is:  

C:\Program Files\SAP\Studio\2.0\bin\<project> 

When you first create a project, it opens automatically. To maintain this project subsequently, or 
maintain any existing project, you must first open it. 
When a project is open, the File View tab page displays the files in the current project:  
• Each project can contain one or more services.  
• Each service can contain one or more themes.  
• Each theme can contain one or more HTMLBusiness templates, flow files, language resources, 

and Multipurpose Internet Mail Extension (MIME) files.  
In the SAP@Web Studio, you can: 
• Create [Seite 32] projects  
• Open [Seite 33] projects  
• Close [Seite 34] projects  
• Add [Seite 35] files to projects  
• Import [Seite 36] files into projects  
• Delete [Seite 85] files from projects  
• Change the default project directory [Seite 28]  

 
Always use the appropriate file management function in the SAP@Web Studio. Do 
not manipulate the underlying project directory directly. 
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Creating ITS Projects 
To develop Internet applications in the SAP@Web Studio, you must create a project. 

Procedure 
1. Choose File → New and select the Projects tab. 
2. Enter a project name. 
3. If necessary, go to the Project Location field and browse to the place where you want the 

SAP@Web Studio to create the new project.  
4. Choose OK. 

Result 
Unless you have specified a different default project directory [Seite 28], the SAP@Web Studio 
creates a project directory called <project> and a project file called <project>.itsp under:  

C:\Program Files\SAP\Studio\2.0\bin\<project>\<project>.itsp 
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Opening ITS Projects 
To work on a project in the SAP@Web Studio, you must open it first. 
When you open a project, it becomes the currently active project. Any previously opened project 
is closed, and all subsequent actions apply to the most recently opened project. 
The SAP@Web Studio maintains a list of the most recently opened projects, so you can open 
them directly without having to browse through the file system. 

Prerequisites 
You must have created at least one project. 

Procedure 
You can either select a recent project from the list of recently maintained projects or search for 
one in the file system, as described in the following table: 

Function Procedure 

Open a recent project 1. Choose Choose File → Recent Projects. 
2. Select a project. 

Open a project from the file system. 1. Choose File → Open Project. 
2. Navigate to your project directory, if necessary. 
3. Double-click on the project file name. 

Result 
The SAP@Web Studio opens the selected project and displays the project name in the project 
workspace. 
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Closing ITS Projects 
When you close a project, all the subdirectories and files are no longer directly available.  

Procedure 
To close the currently active project, do one of the following: 
• Choose File → Close Project.  
• Open another project. 

Result 
The SAP@Web Studio closes the project by removing all the subdirectories and files from the 
project workspace. 
To work on this project again, you must open [Seite 33] it again.  
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Adding Files to ITS Projects 
There are two ways you can add files to a project: 
• To add files to a project from the file system, use this procedure. 
• To add files to a project from an ITS site or ITS source control, import [Seite 36] them. 

Procedure 
To add files to a project from the file system: 
1. In the project workspace File View, select the project to which you want to add files. 
2. Choose Project → Add to Project → Files. 

You see the Add Files to Project dialog box where you can access files in any directory. 
3. Navigate to the directory containing the files you want to add. 
4. Select the file(s). 
5. Choose Open. 

Result 
The SAP@Web Studio adds the files to the project directory. 

 
To add files to a project, you can also use the Copy, Cut, and Paste functions in the 
standard toolbar. 
If you delete files, they are removed from the project, but not from the underlying 
directory.  

 
Always use the SAP@Web Studio interface to add files to a project. Adding files 
directly to the underlying project directory may result in inconsistent services. 
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Importing Files Into ITS Projects 
There are two ways you can add files to projects: 
• To add files to a project from an ITS site or ITS source control, use this procedure. 
• To add files to a project from the file system, add [Seite 35] them. 

Procedure 
To import files into a project from an ITS site or ITS source control: 
1. Select the service name to which you want to add the files.  
2. Choose Project → Add to Project → Import. 

You see the Add ITS Service Wizard dialog box where you can access files in any 
directory.  

3. Follow the appropriate procedure, depending on what you want to do: 

Function Procedure 

Import files from ITS site 1. Choose Next. 
2. Select Import Service from Site and choose Next. 
3. Select a site, and choose Next. 
4. Select the ITS service name, and choose Next. 
5. Select the desired service files, and choose Next. 
6. Choose Finish. 

Import files from ITS source 
control 

1. Choose Next. 
2. Select Add Service from R/3 Source Control and 

choose Next. 
3. Select an R/3 System, and choose Next. 
4. Enter the logon information, and choose Next. 
5. Select the desired service, and choose Next. 
6. Select the desired service files, and choose Next. 
7. Choose Finish. 

Result 
The SAP@Web Studio imports the files into the current project directory. 

 
Importing files from ITS source control is a GET operation. This means that if you 
modify the files, you cannot return them to ITS source control afterwards. If you want 
to change the files, check them out [Seite 97]. 
To add files to a project, you can also use the Copy, Cut, and Paste functions in the 
standard toolbar. 
If you delete files, they are removed from the project, but not from the underlying 
directory.  

 
Always use the SAP@Web Studio interface to import files to a project. Adding files 
directly to the underlying project directory may result in inconsistent services. 
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ITS Site Management 
Purpose 
This process describes how to define an Internet Transaction Server (ITS) site, which is the 
server location of the files required by the ITS to start a service.  
Since some files are stored on the ITS server, and others on the Web server, an ITS site is really 
a combination of these two components. The ITS server and the Web server can reside on 
different systems, so an ITS site must contain information about the system and the data 
location.  
• During development, all the files that make up an ITS service are assigned to a project in the 

SAP@Web Studio.  
• At runtime, all the files that make up an ITS service files must be located at the ITS site, 

either on the ITS server or the Web server.  
The mechanism used to transfer files from the SAP@Web Studio to the ITS site (runtime 
environment) is known as publishing.  
The following table lists the different ITS service files and specifies whether they reside on the 
ITS server or on the Web server:  

ITS File Location 

Services ITS server 

HTMLBusiness templates ITS server 

Flow files ITS server 

Language resources ITS server 

MIME files Web server 

 
In the SAP@Web Studio, the procedure for defining ITS sites – including the ITS server and the 
Web server – supports different protocols such as NT NetBIOS and FTP.  

Process Flow 
To publish all the files required by the ITS to drive an Internet application, define an ITS site 
[Seite 39].  
If you have defined more than one ITS site, specify the currently active site [Seite 41].  
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Defining an ITS Site 
To define an Internet Transaction Server (ITS) site, you need to specify the ITS server and Web 
server locations of all the ITS files – services, HTMLBusiness templates, flow files, language 
resources, and Multipurpose Internet Mail Extension (MIME) files – that make up a service.  

Procedure 
To define an ITS site, you use the SAP@Web Studio site wizard:  
1. Choose Project → Site Definition. 

You see the Site Definition dialog box.  
2. Choose New. 

You see the Site Wizard. 
3. Enter a site name, and choose Next. 
4. Enter the Web server host name, and choose Next. 
5. Enter the ITS server host name, and choose Next. 
6. Define the shared directories on the Web server and the ITS server. 

What you have to do here depends on whether you allow the SAP@Web Studio to 
determine the location of the ITS files (ITS Virtual Shares) or whether you want to define 
your own (Custom Shares): 

− ITS Virtual Shares 

ITS Version Procedure 

2.0 and later Enter an ITS virtual instance name.  
The SAP@Web Studio automatically defines the following shared 
directories: 
• <ITS instance>_ITS for non-MIME files stored on the ITS 

server. 
• <ITS instance>_WWW for MIME files stored on the Web server. 

1.0/1.1 In these earlier ITS versions, you need to define the shared directories 
for the Web server and ITS server explicitly. 

− Custom Share  
This option allows you to determines the shared directories and their location yourself by 
entering the Web server URL and ITS server URL. You can use both NetBIOS or FTP 
connections. 

Connection Procedure 

NetBIOS 1. Create shared directories on the Web server and ITS server. 
2. Enter the Web server URL. 

This determines the location of the MIME files. 
Example: //<host name>/<Web share>/<dir>  

3. Enter ITS server URL 
This determines the location of all other ITS files 
Example: //<host name>/<ITS share>  
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FTP 1. Set up an FTP server and an FTP root directory with write access, 
so you can publish the files. 

2. Enter Web server URL 
This determines the location of the MIME files. 
Example: ftp://<host name>:<port number>/<dir>  

3. Enter ITS server URL 
This determines the location of all other ITS files 
Example: ftp://<host name>:<port number>  

 
7. Choose Next. 
8. Choose Finish to confirm 
9. Choose OK to exit. 
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Specifying the Active ITS Site 
If you have defined more than one ITS site, you must specify one as the currently active site.  

Procedure 
Go to the publish toolbar, and select the desired site name in the ITS site list box.  

Result 
When you publish files, the SAP@Web Studio uses this site to determine the locations of the ITS 
server and Web server directories.  
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ITS Service Creation 
Purpose 
This process describes how to create all the files required by the Internet Transaction Server 
(ITS) to run an Internet application from a Web browser. This set of files is known as a service.  

Process Flow 
To create an ITS service to run your application, you must:  
1. Create a service file [Seite 43].  

Each service must contain one service file.  
2. Create HTMLBusiness templates [Seite 48].  

Each service must contain at least one HTMLBusiness template.  
3. If you are developing a flow file application, you also need to create flow files [Seite 52].  

In applications based on the flow file implementation model, you must attach one flow file 
to each HTMLBusiness template.  

4. Create language resources [Seite 53].  
Unless you intend to use language-specific HTMLBusiness templates, you must create at 
least one language resource file for the language in which the transaction is being 
developed and tested. 

5. If you want to create instances of the same service that differ only in look and feel, you need 
to create multiple themes [Seite 55].  

You can create several themes for one service. Themes are instances of services that 
differ only in look and feel. Each theme has its own set of templates and other service 
files, but the functionality of the service is the same for all themes.  

 
If you are developing applications using the Web transactions implementation model, 
it is best to create services, HTMLBusiness templates, and language resources with the 
SAP@Web Studio wizards, but you can also create files manually [Seite 57].  
If you are developing applications using the flow file implementation model, you 
must create files manually [Seite 57].  
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Creating ITS Service Files 
To create an Internet Transaction Server (ITS) service, you must create a service file.  
The service file contains the service description, which is the set of parameters that determines 
how a service runs. If this information is incomplete at runtime, the ITS may derive some details 
from the global service file, or require the user to enter logon information. In any case, there must 
be one service file for each application.  
 

 
If you are developing applications using the Web transactions implementation model, 
it is best to create services with the SAP@Web Studio service wizard, but you can 
also create the files manually [Seite 57].  
If you are developing applications using the flow file implementation model, you must 
create the files manually [Seite 57].  

Prerequisites 
There must be a user in the R/3 System which your service is using. 

Procedure 
To create a service file using the service wizard: 
1. Choose File → New and select the File Wizards tab. 
2. Select Service Wizard. 

 
3. Ensure that Add to Project is selected, and that the project directory name is correct. 
4. Choose OK. 
5. Enter a service name, and choose Next. 
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The service name can have up to 14 characters. This must be unique and should 
normally be the same as the corresponding R/3 transaction. 

6. Select an R/3 System to which you are connecting, and choose Next. 

 
7. Specify how R/3 logon information is to be determined. 
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Logon information includes the client, user name, password, and logon language. 
Specify whether you want to use global logon information or define service-specific logon 
information by selecting the appropriate option: 

Option Procedure 

Use global service specification No action required.  
The logon information is taken from the global 
service file global.srvc at runtime. 

Specify a service specific login Enter service-specific logon information. 
You may wish to define a special user with limited 
authorizations for Web transactions. This user must 
exist in the R/3 System. 
Alternatively, you can leave these variables blank, 
and let users enter their own logon information. 

 

 
If you define service-specific logon information, remember that the language key 
must be: 
• One character for R/3 releases prior to 4.0 (for example, e for English) 
• Two characters for R/3 releases from 4.0 (for example, en for English) 

8. Enter a timeout value and choose Next. 
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The timeout value defines the time (in minutes) after which the service terminates if no 
ITS session activity occurs. This is important in case the user branches to another URL 
without leaving the ITS session. 

9. Enter the ITS service type and choose Next: 

 
Specify whether you are calling an R/3 transaction or making WebRFC calls by selecting 
the appropriate option and entering the required information: 

Option Procedure 

Use Web Transaction Enter the R/3 transaction name. 
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Use WebRFC Enter the following information: 
• Destination 

R/3 System to which you are connecting. 
• System Type 

Target system type. The default is R/3. 
• RFC Trace 

Select this if you want to trace your communication 
protocol. 

 
10. Choose Finish to confirm. 
 

Result 
The SAP@Web Studio creates a service file called <service>.srvc and displays it in the 
project workspace.  
You edit this service file with the grid control editor [Seite 74]. Remember that parameter values 
specified here always override the default parameter values in the global service file 
global.srvc. 

 
The SAP@Web Studio does not automatically create a theme for your new service, 
and the service file does not contain a theme parameter.  
However, the global service file global.srvc initially contains contains the default 
theme parameter 99. At runtime, this setting causes the system to search for HTML 
templates in a subdirectory called 99. If the subdirectory does not exist, an error 
occurs.  
Therefore, when you create HTMLBusiness templates for your service, the SAP@Web 
Studio automatically proposes the default theme 99.  
If you do not intend to use more than one theme for this service, you should accept 
the default setting. If you change this value, you must also change the value 
specified in the global service file global.srvc. 

If you want to use more than one theme for a service, you must create the themes explicitly 
[Seite 55] 
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Creating HTMLBusiness Templates 
You must create an HTMLBusiness template for every screen in an Internet application.  

 
If you are developing applications using the Web transactions implementation model, 
it is best to create HTMLBusiness templates with the SAP@Web Studio template 
wizard, but you can also create the files manually [Seite 57].  
If you are developing applications using the flow file implementation model, you must 
create the files manually [Seite 57].  

Prerequisites 
There must be a user in the R/3 System which your service is using. 
You must create a service file [Seite 43] first. 

Procedure 
To create an HTMLBusiness template using the template wizard: 
1. Choose File → New and select the File Wizards tab. 
2. Select Template Wizard. 

 
3. Ensure that Add to Project is selected, and that the project directory name is correct. 
4. Choose OK. 
5. Select an R/3 System that contains the required screen information and choose Next. 
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6. Enter the required R/3 logon information and choose Next. 

 
Logon information includes the client, user name, password, and logon language. 

 
If you define service-specific logon information, remember that the language key 
must be: 
• One character for R/3 releases prior to 4.0 (for example, e for English) 
• Two characters for R/3 releases from 4.0 (for example, en for English) 

7. Enter the required R/3 screen information and choose Next. 
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Enter values in the fields as described in the following table: 

Field Value 

Program  Program name of R/3 transaction. 

Screen Number  Screen number of program. 

Service  The SAP@Web Studio proposes the current service. 

Style Template style. 
There are four possible template styles: 
• Classic  

• Business  

• WebGUI  

• Mobile Devices  

The style you choose depends on the type of application you 
are developing. When you select a style, a description of the 
main features is displayed on the left. 

Theme  The SAP@Web Studio proposes the default theme 99. 
Unless you intend to create more than one theme for your 
service, or you want to change the name for some other 
reason, leave the theme unchanged. 

Language dependent  • If you want to keep your templates language-independent, 
ignore the Language dependent box. Whenever possible, 
you should use this option. 

• If you need to create language-specific templates, check 
the Language dependent box and select a language. 

 
8. Choose Finish to confirm. 
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Result 
The SAP@Web Studio:  
• Creates the HTMLBusiness template and displays it in the project workspace under the current 

service and theme.  
• Activates the Editor menu in the menu bar  

The Editor menu contains functions for editing HTMLBusiness templates.  
The format of the file name depends whether you have created a language-independent template 
or a language-specific HTMLBusiness template: 

File Type File Format 

Language-independent <program name>_<screen number>.html 

Language-specific <program name>_<screen number>_<language>.html 

You edit HTMLBusiness templates in the HTMLBusiness editor [Seite 59].  
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Creating Flow Files 
Use 
If you are developing an application based on the flow file implementation model, you must 
create a flow file for each HTMLBusiness template that requires a dialog flow definirion, and define 
the flow logic. To do this, you use the HTMLBusiness editor.  

Prerequisites 
You have created the associated HTMLBusiness template.  

Procedure 
To create a flow file for an HTMLBusiness template:  
1. If the HTMLBusiness template for which you want to generate a flow file is not already open in 

the main work area, open it by double-clicking the file name in the project workspace.  
The SAP@Web Studio opens the template in the main work area.  

2. Choose Add Flow File or Edit → Add Flow File.  
The SAP@Web Studio creates and opens a flow file with initial <flow> and closing 
</flow> tags.  
You can toggle between the HTMLBusiness code defined in the HTMLBusiness template and 
the flow logic defined in the flow file by using the HTML Source and Flow Source buttons 
located in the status bar of the HTMLBusiness editor.  

3. Enter the flow logic between the <flow> and </flow> tags.  
4. Save your work.  

Result 
The SAP@Web Studio creates a flow file called <template>.flow and attaches it to the 
HTMLBusiness template.  
Flow files are not displayed separately in the project workspace, but you can always distinguish 
whether a flow file exists for a template by looking at the template icon:  

Template Icon Status 

 Template has flow file. 

 Template has no flow file. 
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Creating Language Resources 
Unless you are working with language-specific HTMLBusiness templates, you should create at least 
one language resource file for the language in which the application is being developed. 

 
If you are developing applications using the Web transactions implementation model, 
it is best to create language resources with the SAP@Web Studio resource wizard, 
but you can also create the files manually [Seite 57].  
If you are developing applications using the flow file implementation model, you must 
create the files manually [Seite 57].  

Prerequisites 
There must be a user in the R/3 System which your service is using. 
You must first create a service file [Seite 43] and at least one HTMLBusiness template [Seite 48]. 

Procedure 
To create a language resource file using the resource wizard: 
1. Choose File → New and select the File Wizards tab. 
2. Select Resource Wizard. 

 
3. Ensure that Add to Project is selected, and that the project directory name is correct. 
4. Choose OK. 
5. Enter values for service, theme, and language, and choose Next. 
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If you define service-specific logon information, remember that the language key 
must be: 
• One character for R/3 releases prior to 4.0 (for example, e for English) 
• Two characters for R/3 releases from 4.0 (for example, en for English) 

You get a dialog window that lists all the language resource files that exist for this 
service.  

6. If language resource files exist for the service and you want to import the language resource 
keys from these, check the relevant boxes. 

7. Choose Next. 
8. Choose Finish. 

Result 
The SAP@Web Studio creates a language resource file called  
<service>_<language>.htrc and displays it in the project workspace under the current 
service and theme.  
You can edit this language resource file in the grid control editor [Seite 74].  
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Creating ITS Themes 
Themes are instances of Internet Transaction Server (ITS) services that differ only in their look 
and feel (appearance, graphics, layout or language).  
• Each service can be divided into one or more themes.  
• Each theme has its own set of HTMLBusiness templates, flow files (if applicable), language 

resources, and Multipurpose Internet Mail Extension (MIME) files, but the functionality of the 
service is identical. In the SAP@Web Studio, themes are stored in subdirectories of the 
service directory.  

When creating HTMLBusiness templates, you can accept the default theme 99 proposed by the 
SAP@Web Studio or rename the theme.  
If necessary, you can create further themes for your service and even define a default theme:  
• To create a theme for a service, you must create a subdirectory for all the HTMLBusiness 

templates and other files associated with the theme. This subdirectory should have the same 
name as the theme. 

• To define a default theme for a service, you add a ~theme parameter to the service file and 
specify a value. This default can be overridden at runtime. 

Procedure 
The procedures in the table below table describe how to: 
• Create a theme for a service. 
• Specify a default theme for a service. 

Function Procedure 

Create a theme 1. Choose the File View tab, and select the service. 
2. Choose Project → Add to project → Theme, or press the right 

mouse button and choose Insert → Theme. 
The SAP@Web Studio creates a new directory in the File 
View, and places the cursor in the directory name box. 

3. Enter a name for the directory and press Enter. 
If you intend to use ITS source control to manage your files, 
choose a theme name that is no more than two characters 
long. 

Specify a default theme 1. Choose the File View and double-click on the service. 
The SAP@Web Studio displays the service file in the main 
work area. 

2. Find the ~theme parameter in the file. 
• If the parameter already exists, select it. 
• If the parameter does not exist: 

a. Place the cursor in the bottom (blank) field in the Name 
column. 

b. Enter ~theme in this field. 
3. Click on the Value part of the same row, and enter a two-

character theme name. 
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Result 
When you have created a new theme, you can add HTMLBusiness templates and other ITS files, or 
copy existing files from another theme to the new theme.  
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Creating ITS Files Manually 
When developing Internet applications driven by the Internet Transaction Server (ITS), you can 
create some of the files either with the SAP@Web Studio wizards or manually.  
• If you are developing an application based on the Web transactions implementation model, it 

is best to create the service file, HTMLBusiness templates, and language resources with the 
wizards designed for the purpose, but you can also create the files manually.  

• If you are developing an application based on the flow file implementation model, you must 
create the files manually. Do not use the wizards.  

When you create ITS files manually, the SAP@Web Studio creates an empty file according to the 
information you provide. If, for example, you are creating HTMLBusiness templates, it does not log 
on to the R/3 System, and does not generate HTMLBusiness code.  

Procedure 
To create a service, HTMLBusiness template, or language resource manually: 
1. Choose File → New and select the Files tab. 
2. Select the type of file you want to create. 
3. Enter the service name, and all other required fields. 

− To add the file to a project: 
a. Ensure that Add to Project is selected. 
b. If you want to specify a project other than that displayed in the Location field, enter 

the desired project or browse to find a project. 
− To add the file to a non-project location: 

a. Deselect Add to project. 
b. If you want to specify a project other than that displayed in the Location field, enter 

the desired project or browse to find a project.  
4. Choose OK.  

Result 
The SAP@Web Studio creates the file and opens it in the relevant editor in the main work area:  
• Service files and language resource files are opened in the grid control editor [Seite 74].  
• HTMLBusiness templates are opened in the HTMLBusiness editor [Seite 59].  
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ITS Service Maintenance 
The SAP@Web Studio provides two editors to maintain the Internet Transaction Server (ITS) 
files that make up services:  
• HTMLBusiness editor  
• Grid control editor  

HTMLBusiness editor 
You use this editor to: 
• Enter and test HTMLBusiness and standard HTML code in HTMLBusiness templates.  
• Create flow files.  
• Edit flow logic.  
• Preview the HTMLBusiness template layout.  
• View context data values.  

Grid control editor 
You use this editor to: 
• Define service parameters in service files.  
• Define language-independent text in language resource files.  
• Maintain context data values.  

 
The commands used in the HTMLBusiness editor and the grid control editor require a 
file window to be open and selected. If no file window is open, the command is either 
unavailable, or applies to items selected in the File View.  

For detailed information about using the HTMLBusiness editor, see HTMLBusiness Editor [Seite 59].  
For detailed information about using the grid control editor, see Grid Control Editor [Seite 74].  
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HTMLBusiness Editor 
You use the HTMLBusiness editor to enter and test HTMLBusiness and standard HTML code in 
HTMLBusiness templates.  
The HTMLBusiness editor can run in four modes:  
• HTML Source  

This mode displays the HTMLBusiness code that defines the presentation.  
You use this mode to enter and maintain standard HTML and HTMLBusiness code. 
For clarity, you can set specific parts of the code - standard HTML, comments, or 
HTMLBusiness – to be displayed in a different color.  
The editor mode is the default mode.  

• Flow Source  
This mode displays the XML code that defines the  flow logic in the flow file attached to 
the HTMLBusiness template.  

• Context Data  
The context grid allows you to view data values generated for each HTMLBusiness template 
at runtime. To generate data values, you can choose to record the session when you test 
a service.  

• Preview  
The preview displays your template as it will look when displayed as an HTML page in 
the user’s Web browser, but without the data values supplied at runtime.  
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Starting and Stopping the HTMLBusiness Editor 
Use 
You use these procedures when you want to start or stop the HTMLBusiness editor.  

Prerequisites 
You must have created at least one service with one or more HTMLBusiness templates in the 
project workspace. 

Procedure 
Use the following procedures to start or stop the HTMLBusiness editor for each HTMLBusiness 
template: 

Function Procedure Result 

Start HTMLBusiness 
editor 

1. Select a service in the project 
workspace and expand file 
hierarchy. 

2. Select the template you want to 
edit.  

3. Double-click or press right 
mouse button and choose 
Open. 

The HTMLBusiness editor opens the 
template in HTML Source mode in 
the main work area.  
In the main work area, you can 
have any number of windows 
open at once. 

Stop HTMLBusiness 
editor 

1. Select template you wish to 
close in the work area. 

2. Choose File → Close. 

The HTMLBusiness editor closes. 
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Using the HTMLBusiness Editor 
The HTMLBusiness editor offers most standard text editing functions.  

Prerequisites 
You must have started the HTMLBusiness editor for the HTMLBusiness template you want to edit.  

Procedure 
The standard functions provided by the HTMLBusiness editor are summarized in the following table: 

Operation Procedure Result/Remarks 

Select text Drag mouse over text.  

Select a word Double-click on word  

Select all text 1. Position cursor in editor window. 
2. Choose Edit → Select All. 

 

Cut text 1. Select text. 
2. Choose Cut or Edit → Cut. 

Places selected text in buffer. 
Text remains in buffer until next 
cut or copy operation. 

Copy text 1. Select text. 
2. Choose Copy or Edit → Copy. 

Places selected text in buffer. 
Text remains in buffer until next 
cut or copy operation. 

Paste previously 
cut or copied text 

1. Position cursor where you want to 
paste text. 

2. Choose Paste or Edit → Paste. 

Pastes text from buffer. 
A paste operation does not 
empty the buffer. 

Delete text 1. Select text. 
2. Choose Delete or Edit → Delete. 

Deletes selected text. 
When you delete text with the 
Delete function, it is gone. To 
rescue deleted text, choose 
Undo immediately. 

Undo cut, delete, or 
other operation 

Choose Undo or Edit → Undo. Reverses previous operation. 

Find text 1. Choose Find or Edit → Find. 
2. In Find what field, enter search 

string. 
3. Choose Find Next. 

Finds next occurrence of string. 
To find subsequent occurrences, 
keep choosing Find Next. 
You can search for whole words 
only, perform a case-sensitive 
search, and search up or down. 
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Replace text. 1. Choose Edit → Replace. 
2. In Replace with field, enter 

replace string  
3. To replace first occurrence of find 

string, choose Replace. 
To replace all occurrences of find 
string, choose Replace All. 

Replaces one occurrence of find 
string or all occurrences. 
To search for each occurrence of 
the find string before replacing it, 
choose Find Next. 
You can search for whole words 
only, perform a case-sensitive 
search, and search up or down. 

Set marker(s) 1. Place the cursor on the desired 
line in the code. 

2. Select Ctrl + F2 

Sets a marker.  
If you set more than one marker, 
you can jump between them by 
pressing F2. 

Delete marker(s) 1. Place the cursor on the desired 
line in the code, where there is 
already a marker. 

2. Select Ctrl + F2 

Deletes marker. 

 

 
If an HTMLBusiness template or other ITS file is open for editing in the main work area, 
the editor commands apply to the file text.  
If no HTMLBusiness template or other ITS file is open in the main work area, the editor 
commands apply to the file selected in the File View.  
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Inserting Standard HTML Tags 
When using the HTMLBusiness editor to enter standard HTML code, you can:  
• Insert HTML tags as you type.  
• Insert HTML tag attributes as you type.  
• Insert text formatting tags.  

Procedure 
Inserting Standard HTML Tags as you Type 
If you enter < to open a standard HTML tag, the HTMLBusiness editor recognizes this and 
automatically displays a list of valid tags in a scrollable pop-up window at the cursor position. 
As you type, the HTMLBusiness editor finds, and highlights, the nearest alphabetical match in the 
list of valid tags. You can select the highlighted tag or any other tag in the list. 
If you select a tag from the list of valid tags, the HTMLBusiness editor inserts it at the cursor 
position. 
When you enter the closing angle bracket for the tag, the HTMLBusiness editor inserts the closing 
tag automatically. 

 
Suppose you intend to use the <body> tag in your template. 
As soon as you enter < to open the tag, the HTMLBusiness editor displays a list of valid 
tags. To insert the body tag, double-click on it and you see <body . 
When you enter the closing angle bracket, the HTMLBusiness editor automatically 
inserts the closing tag </body>. 

If the HTMLBusiness editor finds no more matches as you type, the window closes automatically.  
To close the pop-up window at any time, click elsewhere on the screen. 

Inserting Standard HTML Tag Attributes as you Type 
If you enter a valid standard HTML tag followed by a blank, and this tag has attributes, the 
HTMLBusiness editor recognizes this and automatically displays a list of valid tag attributes in a 
scrollable pop-up window at the cursor position.  
As you type, the HTMLBusiness editor finds, and highlights, the nearest alphabetical match in the 
list of valid tag attributes. You can select the highlighted tag attribute or any other tag attribute in 
the list. 
If you select a tag attribute from the list of valid tag attributes, the HTMLBusiness editor inserts it at 
the cursor position. 
When you type the closing angle bracket, the HTMLBusiness editor inserts the closing tag 
automatically. 

 
Suppose you intend to use the tag <select> followed by the tag attribute name. 
As soon as you enter a blank after <select, the HTMLBusiness editor displays a list of 
possible attributes. To insert the attribute, double-click on it and you see <select 
name=““  
When you enter the closing angle bracket, the HTMLBusiness editor automatically 
inserts the closing tag </select>. 
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If the HTMLBusiness editor finds no match as you type, the window closes automatically. 
To close the pop-up window at any time, click elsewhere on the screen.  

Inserting Standard HTML Formatting Tags 
To insert standard HTML formatting tags as you type: 
1. Either position the cursor or select some existing text  

− If you position the cursor, the HTMLBusiness editor inserts the opening and closing tags 
there, so you can enter text between them. 

− If you select some existing text, the HTMLBusiness editor inserts the opening and closing 
tags to enclose the selected text. 

2. Either click on the right mouse button and choose HTML Tags or go to the SAP@Web Studio 
menu bar and choose Editor → HTML Tags. 

3. Select the desired tag. 
The HTMLBusiness editor inserts the tags as summarized in the table below: 

HTML Tag HTMLBusiness Editor Action 

Bold Inserts the tag <b></b> or  
encloses selected text. 

Italic Inserts the tag <i></I> or  
encloses selected text. 

Paragraph Inserts the tag <p> or  
encloses selected text. 

Break Inserts the tag <b> or  
encloses selected text. 

Font dialog Opens a font dialog, where 
you can define a font, color, 
and size tags. 
Converts your selections to 
HTML and either inserts it at 
the cursor position or encloses 
the selected text. 
Example of inserted HTML: 
<font face="Arial" color="Green" size="3"></font> 

Header 1 Inserts the tag <h1></h1> or  
encloses selected text. 

Header 2 Inserts the tag <h2></h2> or  
encloses selected text. 

Header 3 Inserts the tag <h3></h3> or  
encloses selected text. 

Header 4 Inserts the tag <h4></h4> or  
encloses selected text. 

Header 5 Inserts the tag <h5></h5> or  
encloses selected text. 
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Header 6 Inserts the tag <h6></h6> or  
encloses selected text. 

Result 
In all cases, the SAP@Web Studio inserts the desired HTML tag. 
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Entering HTMLBusiness Code 
Use 
When entering HTMLBusiness code in the HTMLBusiness editor, you can:  
• Highlight HTMLBusiness elements.  
• Get parameter information on HTMLBusiness keywords and functions.  
• Display the definition of HTMLBusiness functions.  
• Insert HTMLBusiness tags.  
• Insert language resource keys as you type.  

Prerequisites 
You must have started the HTMLBusiness editor for the template you want to edit. 

Procedure 
Highlighting HTMLBusiness Elements 
When you are editing an HTMLBusiness template, the HTMLBusiness editor recognizes and highlights 
HTMLBusiness elements.  
The following table lists HTMLBusiness elements and their default colors:  

HTMLBusiness Element Default Color 

General HTMLBusiness Blue 

HTMLBusiness keywords Brown 

Constants Black 

Language resource keys Pink 

HTMLBusiness comments Gray 

Developer comments Green 

You can either use the default colors or define your own colors [Seite 30].  

Getting Parameter Information on HTMLBusiness Keywords and Functions 
You can get full parameter information for any HTMLBusiness keyword or function as you type. To 
do this, select the text, click the right mouse button, and choose Parameter information. 

 
Suppose you want to select parameter information for the wgateURL function. 
If you select the text, you see the following information: 
wgateURL(parameter = expression {,parameter = expression}) 

Displaying HTMLBusiness Function Definitions 
If you write your own HTMLBusiness function, you can go to the definition of that function wherever 
it is located (it may reside in a different file).  
To do this, select the text, click the right mouse button, and choose Goto definition.  
If you change the definition of a self-written HTMLBusiness function: 
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• The parameter information is automatically updated and can be viewed from wherever you 
select Goto definition. 

• The function is no longer recognized and is not highlighted. However, the HTMLBusiness editor 
and all editor instances, which include the current file, recognize the new function created by 
the modification. This also applies to include statements. 

Inserting HTMLBusiness Tags as you Type 
When you are editing HTMLBusiness templates, you can insert HTMLBusiness tags as you type: 
1. Either position the cursor or select some existing text. 

If you position the cursor, the opening and closing tags are inserted there, so you can 
enter text between them. 
If you select some existing text, the opening and closing tags are inserted to enclose the 
selected text. 

2. Either click on the right mouse button and choose HTMLBusiness Tags or go to the 
SAP@Web Studio menu bar and choose Editor → HTMLBusiness Tags. 

3. Select the desired tag. 
The HTML editor inserts the tags as summarized in the table below: 

HTML Tag HTMLBusiness Editor Action 

Backticks Inserts two backticks `` or  
encloses selected text. 

Server Tags Inserts the tag <server></server> or  
encloses selected text. 

MimeUrl Inserts the tag mimeURL() or encloses selected text in the 
parentheses. 

 

Inserting Language Resource Keys as you Type 
If you are editing an HTMLBusiness template and you enter # to denote a language resource key, 
the HTMLBusiness editor recognizes this and automatically displays a list of language resource keys 
already defined for the currently active service (and theme, if relevant) in a scrollable pop-up 
window at the cursor position.  
As you type, the HTMLBusiness editor finds, and highlights, the nearest alphabetical match in the 
list of language resource keys. You can select the highlighted key or any other key in the list. 
If you select a key from the list of keys, the HTMLBusiness editor inserts it at the cursor position. 
When you enter the closing angle bracket for the tag, the HTMLBusiness editor inserts the closing 
tag automatically. 
If the HTMLBusiness editor finds no more matches as you type, the window closes automatically.  
To close the pop-up window at any time, click elsewhere on the screen. 
If you update a language resource file by adding or deleting language resource keys, this is 
immediately reflected in the pop-up list that appears in the editor. 
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Maintaining Custom Tag Lists 
To support the editing of HTMLBusiness templates in the HTMLBusiness editor, the SAP@Web Studio 
allows you to maintain your own list of frequently used tags, so that you can access them faster. 
When you first start the SAP@Web Studio after installation, the HTML Tags window contains a 
list of standard HTML tags in a layout that resembles a file manager. You can modify the list – 
and the window itself - to meet your own requirements. 
You can: 
• Insert tags from the HTML Tags window directly into HTMLBusiness templates.  
• Add new tags.  
• Change, rename, and delete existing tags.  
• Create new folders to store groups of tags.  
• Move tags between folders.  
• Display or hide the HTML Tags window.  

Procedure 
Depending on what you want to do, follow the procedure in the table below: 

To Procedure Result 

Insert a tag into an 
HTMLBusiness template. 

1. In HTMLBusiness template, either 
position cursor or select text. 

2. In HTML Tags window, double-
click tag you want to insert. 

The SAP@Web Studio inserts 
the tag at the cursor position 
or encloses the selected text. 

Create a tag. 1. Position cursor somewhere in 
HTML Tags window. 

2. Select right mouse button. 
3. Choose Add Tag. 
4. In Custom Tag Name field, 

enter a name for your tag. 
5. In Start Text box, specify a start 

text for your tag. 
6. In End Text box, specify an end 

text for your tag. 
7. Choose OK. 

The SAP@Web Studio adds 
the tag to the list in the HTML 
Tags window. 

Change a tag. 1. Select tag. 
2. Select right mouse button 
3. Choose Edit Tag. 
4. Change tag as required. 
5. Choose OK.  

The SAP@Web Studio applies 
your changes. 
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Rename a tag. 1. Select tag. 
2. Select right mouse button. 
3. Choose Rename. 
4. Specify new name by 

overwriting old name. 
5. Press Enter. 

The SAP@Web Studio 
renames the tag. 

Delete a tag. 1. Select tag. 
2. Select right mouse button. 
3. Choose Delete.  

The SAP@Web Studio 
deletes the tag immediately. 

Create a folder. 1. Select an existing folder. 
2. Select right mouse button. 
3. Choose Create Folder. 
4. Enter a name for the folder. 
5. Press Enter.  

The SAP@Web Studio 
creates a new folder. 

Display or hide HTML 
Tags window. 

Choose Editor → View HTML Tags. The SAP@Web Studio 
displays or hides the HTML 
Tags window below the 
project workspace. 

 

April 2001  69 



SAP@Web Studio  SAP AG 
Inserting Graphics into HTMLBusiness Templates 

Inserting Graphics into HTMLBusiness Templates 
When you are editing HTMLBusiness templates in the HTMLBusiness editor, you can insert graphic 
and other Multipurpose Internet Mail Extension (MIME) files directly by drag and drop.  

Procedure 
1. In the SAP@Web Studio’s project workspace, select the File View.  
2. Select the file that contains the graphic you want to insert.  
3. Drag the file to the HTMLBusiness editor window and drop it at the desired location in the 

HTMLBusiness code.  

Result 
The HTMLBusiness editor automatically generates the necessary HTMLBusiness code (and the 
required parameters).  

 
If you select the image file help.gif and drag it to an English template under 
theme 99 in a service called myservice, the HTMLBusiness editor generates the 
following code in the template: 
`mimeURL(~service=“myservice“,~theme=“99“,~language=“en“,~name
=“help.gif“)` 
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Checking HTMLBusiness Syntax 
When you have designed your HTMLBusiness template, you can use the HTMLBusiness editor to 
check the syntax of HTMLBusiness code.  

Procedure 
To perform a syntax check on the HTMLBusiness code in an HTMLBusiness template: 
1. Choose Syntax Check or Tools → Syntax Checker. 

The SAP@Web Studio lists all syntax errors in the lower window. 
2. Double-click on an error message. 

Result 
The SAP@Web Studio places the cursor where the error occurred in the HTMLBusiness code. 

 
This function checks only syntax errors in HTMLBusiness code, that is, only errors found 
in those statements enclosed in backticks.  
Errors in standard HTML code are not detected. 
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Previewing HTMLBusiness Template Layout 
When you have designed your HTMLBusiness template and performed a syntax check, you can use 
the HTMLBusiness editor’s preview mode to check how the template will look when displayed as an 
HTML page in the user’s Web browser.  

Procedure 
To preview the layout of an HTMLBusiness template 
1. If the HTMLBusiness template is not already open in the main work area, open it by double-

clicking the file name in the project workspace. 
The SAP@Web Studio opens the template in the main work area.  

2. At the bottom of the template window, choose Preview. 

Result 
The SAP@Web Studio displays the HTMLBusiness template as it will look in the user’s Web 
browser.  

 
Since the preview mode previews the layout of HTMLBusiness templates without 
connecting to an R/3 System, templates that rely on R/3 texts for their appearance 
may look incomplete.  
The preview mode is only a dummy display, so pushbuttons and other actions have 
no effect.  
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Viewing Context Data Values 
When you test a service by running it in the SAP@Web Studio, you can record the operation, so 
that the data values generated for each HTMLBusiness template at runtime are stored in a context 
file. You can then view these values in the HTMLBusiness editor’s, and edit them in the grid control 
editor. 
The data values generated may be runtime variables, R/3 texts used to label buttons, or other 
screen objects. 

Prerequisites 
You must run the service and record [Seite 90] the operation for at least one HTMLBusiness 
template. 

Procedure 
To view data values for an HTMLBusiness template: 
1. Start the HTMLBusiness editor by selecting the HTMLBusiness template. 
2. At the bottom of the template window, choose Context Data.  

Result 
The HTMLBusiness editor switches to the context grid where you see a list of generated data 
values. 

 
For information about how to edit these values in the grid control editor, see Using 
the Grid Control Editor [Seite 75]. 
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Grid Control Editor 
You use the grid control editor to: 
• Display and edit service files 
• Display and edit language resource files 
• Edit context data values 

These values are generated at runtime, stored in the context data file, and displayed in 
the HTMLBusiness editor’s context grid.  

The grid control editor displays the information in each of these files as a list of name/value pairs 
in individual cells. The value of the name component for each pair must be unique. To edit the 
file, you can tab from one cell to the next.  
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Using the Grid Control Editor 
Use 
This procedure describes how to use the functions in the grid control editor to maintain: 
• Context data values  

These values are generated at runtime, stored in the context data file, and displayed in 
the HTMLBusiness editor’s Context Data mode. 

• Service files 
• Language resource files 

Prerequisites 
You need to display the file you want to maintain. 

Procedure 
The functions available in the grid control editor are similar, regardless of the type of file you are 
editing. They are summarized in the following table: 

Function To Procedure 

Sort column entries. Click column header. 
To reverse the order, click column header again. 

Layout 
definition 

Resize columns. Place cursor between columns until you see a 
different symbol, and drag in either direction until you 
achieve the required column sizes. 

Move from cell to cell. To go to next cell, use TAB key. 
To go to previous cell, use SHIFT+TAB. 

Move from line to line. Use arrow keys. 

Scroll file up/down. Use vertical scroll bar or page up/down key. 

Navigation 

Scroll file across. Use horizontal scroll bar. 

Edit a cell. Select cell by double-clicking. 
This opens an edit box where you can enter data. If 
the new text is longer than the old text, the cell 
expands automatically. 

Create an entry. If the file contains blank lines, double-click on a line 
and enter data in box. 
If the file contains no blank lines, choose Insert → 
New String and enter data in box. 
The cell expands automatically. 

Maintenance 
functions 

Copy 1. Select cell by double-clicking. 
2. Select right mouse button. 
3. Choose Copy in pop-up window. 
You can also use keyboard operations. 
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Cut 1. Select cell by double-clicking. 
2. Select right mouse button. 
3. Choose Cut in pop-up window. 
You can also use keyboard operations. 

Paste 1. Select cell by double-clicking. 
2. Select right mouse button. 
3. Choose Paste in pop-up window. 
You can also use keyboard operations. 

Delete 1. Select cell by double-clicking. 
2. Select right mouse button. 
3. Choose Delete in pop-up window. 
You can also use keyboard operations. 

Undo 1. Select cell by double-clicking. 
2. Select right mouse button. 
3. Choose Undo in pop-up window. 
You can also use keyboard operations. 
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Editing Service and Language Resource Files 
You edit service files and language resource files in the grid control editor.  
When you open a service file or a language resource file in the grid control editor, you see the 
defined service parameters as name-value pairs. The procedure for editing these files is similar.  

Procedure 
Opening a file for maintenance in the grid control editor depends on the file type. Use the 
appropriate procedure in the following table: 

To Procedure 

Display/edit service files 1. Select the service file in the SAP@Web 
Studio’s project workspace. 

2. Double-click. 

Display/edit language resource files 1. Select the language resource file in the 
SAP@Web Studio’s project workspace. 

2. Double-click. 

Edit context data values for HTMLBusiness 
templates 

1. Select the template file in the SAP@Web 
Studio’s project workspace. 

You see the HTMLBusiness editor. 
2. Double-click 
3. At the bottom of the template window, choose 

Context Grid. 

 

Result 
In each case, the SAP@Web Studio displays the grid control editor. 
For information about basic grid control editor functions, see Using the Grid Control Editor [Seite 
75]. 
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ITS File Management 
Purpose 
This process describes how to manage Internet Transaction Server (ITS) files in the SAP@Web 
Studio project workspace.  
These ITS files include services, HTMLBusiness templates, flow files, language resources, and 
Multipurpose Internet Mail Extension (MIME) files. Flow files are attached to HTMLBusiness 
templates and are not displayed separately in the project workspace.  

Process Flow 
In the project workspace, the SAP@Web Studio provides basic file management functions that 
allow you to: 
• Open [Seite 79] files 
• Save [Seite 80] files 
• Print [Seite 81] files 
• Close [Seite 82] files 
• Copy and move [Seite 83] files 
• Drag and drop [Seite 84] files 
• Delete [Seite 85] files 
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Opening ITS Files 
You can open Internet Transaction Server (ITS) files from one of the views in the project 
workspace, or from a dialog box (if the file is not displayed in project workspace). 

Prerequisites 
You have already opened a project.  

Procedure 
To open a file displayed in the File View of the project workspace:  
1. In the project hierarchy, navigate to the file you want to open. 
2. Double-click on the file name.  

Result 
The SAP@Web Studio calls the appropriate editor for the type of file you are opening, and 
displays the file in the main work area. 
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Saving ITS Files 
You can save an Internet Transaction Server (ITS) file to its current location, to a different 
location, or to a new name. 

Procedure 
If you have multiple files open in the main work area, select the file you want to save. Then, 
follow the appropriate procedure in the following table: 

Function Procedure 

Save file to current location Choose Save or File → Save. 

Save file to different name or 
location 

1. Choose File → Save As. 
The SAP@Web Studio displays the Save As 
dialog box where you can specify the drive, 
directory, and file name for saving your file. 

2. Navigate to the desired directory. 
3. If necessary, enter the new name for the file. 
4. If necessary, select the file type for the file (in the 

Save as type field). 
The SAP@Web Studio saves your file with the file 
extension for the file type you select. 

Result 
When you save a file to a different name or location, the SAP@Web Studio closes the original 
file, and opens the new file.  
To continue editing the original file, you have to re-open it. 
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Printing ITS Files 
You can print the text of HTMLBusiness templates and flow files.  

Procedure 
1. In the File View of the project workspace, select and open the HTMLBusiness template.  
2. If you want print the flow file, switch to Flow Source in the HTMLBusiness editor.  
3. Choose Print or File → Print. 

Result 
The SAP@Web Studio sends your HTMLBusiness code to the defined printer. 
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Closing ITS Files 
The procedure for closing Internet Transaction Server (ITS) files is the same for all file types.  

Procedure 
1. Select the window of the file you want to close.  
2. Choose File → Close.  

If you have changed the file contents, but not yet saved the changes, the SAP@Web 
Studio prompts you to save.  

− To save before closing, choose Yes.  
− To close without saving, choose No.  

If the file is new, the SAP@Web Studio displays the Save as dialog box.  
− Specify a name for the file and choose OK.  

Result 
The SAP@Web Studio closes the file. 
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Copying and Moving ITS Files 
You can copy or move Internet Transaction Server (ITS) files either from the file system or from 
ITS source control. 
To copy or move Internet Transaction Server (ITS) files from the file system: 
• Add the files [Seite 35] to the project. 
• Drag and drop the files [Seite 84]. 
To copy or move files from ITS source control: 
• Import the files [Seite 36] to the project. 
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Dragging and Dropping ITS Files 
You can copy or move files between directories in a project by dragging and dropping them in the 
project workspace File View. 

Procedure 
To copy or move files by drag and drop, follow the relevant procedure in the following table: 

Function Procedure Result 

Copy file(s). 1. Select file(s) you want to copy. 
2. Drag file(s) to target directory. 

The SAP@Web Studio copies 
file(s) from source directory to 
target directory. 
The file(s) now exist(s) in both 
directories. 

Move file(s). 1. Select file(s) you want to move. 
2. Hold down right mouse button and 

press Shift key 
3. Drag file(s) to target directory 
4. Release right mouse button. 

The SAP@Web Studio moves 
file(s) from source directory to 
target directory. 
The file(s) now exist(s) only in the 
target directory. 
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Deleting ITS Files 
You can either delete Internet Transaction Server (ITS) files, or move them to another directory. 

Procedure 
Function Procedure Result 

Delete files 1. In the File View, select the file(s) you want to 
delete. 

2. Choose Delete or Edit → Delete. 

The SAP@Web Studio 
deletes the file(s) from your 
project directory.  
Any files you delete remain in 
the underlying directory in the 
file system. 

Move files 1. Select file(s) you want to move. 
2. Hold down right mouse button and press 

Shift key. 
3. Drag file(s) to target directory. 
4. Release right mouse button. 

The SAP@Web Studio 
moves the selected files from 
the source directory to the 
target directory. 

 
When you delete files with the Delete function, the SAP@Web Studio deletes the 
selected file(s) from the project hierarchy in the project workspace, but not from the 
hard disk. This prevents data loss resulting from accidental deletion. 
If you want files that you delete to be removed from the hard disk at the same time, 
you must select this option explicitly. In this case, see Specifying a default project 
directory [Seite 28]. 
You can also delete files by moving them with the Copy, Cut, and Paste functions in 
the standard toolbar. 

 
To delete files from a project, always use the functions in the SAP@Web Studio user 
interface. Deleting files from the underlying project directory may result in 
inconsistent services.  
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ITS Service Publishing 
Purpose 
This process describes how to publish the Internet Transaction Server (ITS) files that make up a 
service.  
Publishing a service means copying the current versions of all the relevant files from the 
SAP@Web Studio on your PC to the ITS site (that is, to the relevant directories on the ITS server 
or the Web server). At runtime, the ITS uses these files to generate the HTML pages displayed in 
the user’s Web browser.  

Prerequisites 
Before you can publish any files in a service, you must first define an ITS site.  

Process Flow 
When you publish a service, you need to:  
1. Specify the active ITS service [Seite 87]  
2. Publish the service to an ITS site.  

There are three ways to publish an ITS service. Use the appropriate function in the 
SAP@Web Studio’s publish toolbar, as listed in the following table: 

Function Effect 

 
Publish function. 
Publishes individual files in a service. 
This function allows you to select the files you want to publish, and specify 
the ITS site to which they should be published. 

 
Build function. 
Builds the service and publishes all the files. 
This function publishes all the files that make up a service to the currently 
active ITS site in a single operation. You cannot select individual files or 
specify an ITS site. 

 
Go function. 
Builds the service, publishes all the files, and starts the service. 
This function publishes all the files that make up a service to the currently 
active ITS site in a single operation, and starts the service at the same 
time. You cannot select individual files or specify an ITS site. 

− If you want to publish individual files in a service, see Publishing ITS Files [Seite 88].  
Remember that if you want to test the service, you must first publish all the files.  

− If you want publish all the files in a service, see Building ITS Services [Seite 89].  
− If you want to publish all the files in a service, and test the service at the same time, see 

Testing ITS Services [Seite 90]. 
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Specifying the Active ITS Service 
Before publishing an Internet Transaction Server (ITS) service, you must specify the currently 
active service, because the Build and Go functions in the SAP@Web Studio publish toolbar 
always operate on the currently active service:  
• The Build function publishes the service to the active ITS site.  
• The Go function publishes the service to the active ITS site, and starts it.  

Procedure 
To specify the currently active service:  
1. Choose Project → Set Active Service.  

The SAP@Web Studio displays a sub-menu of services in the current project.  
2. Select the desired service name.  

The SAP@Web Studio highlights the selected service in the project workspace File 
View.  

Result 
The SAP@Web Studio applies all subsequent Build and Go operations to the currently active 
service.  
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Publishing ITS Files 
Publishing an Internet Transaction Server (ITS) service means copying the current versions of all 
the relevant files from the SAP@Web Studio on your PC to the ITS site (that is, to the relevant 
directories on the ITS server or the Web server). At runtime, the ITS uses these files to generate 
the HTML pages displayed in the user’s Web browser.  
You can either:  
• Publish the entire service to the currently active ITS site.  

If you want to do this, it is easier to use the Build function, which builds the service and 
publishes all the files in a single operation. In this case, see Building ITS Services [Seite 
89].  

• Publish individual files in a service to a specified ITS site.  
If you want to do this, follow the procedure below.  

Prerequisites 
To publish individual ITS files, you must first:  
• Define an ITS site [Seite 39].  
• Specify the desired active service [Seite 87].  

This is important, because the Publish function always publishes selected files to the 
currently active service.  

Procedure 
1. In the File View, select the files (or service) you want to publish.  

You see the Publish Files dialog box.  
2. Choose Publish Files or Project → Publish Files.  
3. Enter the desired site name in the Publish to Site field.  
4. Ensure that all the files you want to publish are selected.  
5. Choose OK.  

The SAP@Web Studio performs a syntax check on the HTMLBusiness statements in every 
HTMLBusiness template to be published. If templates contain errors, these are listed in the 
message area.  
To jump to the location of the error, double-click on an error message  

Result 
The SAP@Web Studio copies the files to the ITS server directory and Web server directory, as 
specified by your site definition.  
At the site destination, the SAP@Web Studio compares all file versions, and overwrites any old 
files with new ones, if they have changed.  
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Building ITS Services 
Building an Internet Transaction Server (ITS) service means publishing all the files by copying 
the current versions of all the relevant files from the SAP@Web Studio on your PC to the ITS site 
(that is, to the relevant directories on the ITS server or the Web server). At runtime, the ITS uses 
these files to generate the HTML pages displayed in the user’s Web browser.  
When building a service, the SAP@Web Studio automatically publishes everything. It does not 
prompt you for file or site information.  
If you want to publish individual files in a service, see Publishing ITS Files [Seite 88].  

Prerequisites 
To build a service, you must first:  
• Define an ITS site [Seite 39].  
• Specify the desired active service [Seite 87].  

This is important, because the Build function always publishes the currently active 
service.  

Procedure 
In the publish toolbar, choose Build or Project → Build Service.  

Result 
The SAP@Web Studio immediately copies all files that make up the service to the ITS server 
directory and Web server directory, as specified by your ITS site definition.  
At the site destination, the SAP@Web Studio compares all file versions, and overwrites any old 
files with new ones, if they have changed.  
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Testing ITS Services 
To test an Internet Transaction Server (ITS) service, you can simply start it.  
When you do this, the SAP@Web Studio:  
• Publishes the service to the currently active ITS site  
• Opens a Web browser (either inside or outside the SAP@Web Studio)  
• Starts the service in the Web browser  
You can also publish a service without calling it.  

Prerequisites 
To publish a service, you must first:  
• Define an ITS site [Seite 39].  
• Specify the desired active service [Seite 87].  

This is important, because the Go function always starts the currently active service.  
You do not need to connect to R/3 first.  

Procedure 
1. Select the service you want to start. 
2. Choose choose Go or Project → Start Service. 

The SAP@Web Studio opens a Web browser, starts the service, and displays the first 
screen of the application as an HTML page. 

3. If you want to check the data values generated for each template at runtime, choose Record 
in the Web browser window. 

You can switch this option on/off for each template. 
To view the recorded data values, see Viewing Context Data Values [Seite 73]. 

 
By default, the Web browser runs outside the SAP@Web Studio. To change this 
option, see Opening a Web Browser in the SAP@Web Studio [Seite 29]. 
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Using Web Browser Functions 
When you start a service in the SAP@Web Studio, a Web browser opens either inside or outside 
the SAP@Web Studio environment. Web browsers that run inside the SAP@Web Studio have a 
simplified user interface that hides the browser toolbars and menu bars.  
Use this procedure to access Web browser functions not visible in the SAP@Web Studio main 
work area. 

Prerequisites 
You must set the SAP@Web Studio options to open the Web browser inside the Studio [Seite 
29]. 

Procedure 
To use Web browser toolbar functions: 
1. Position the mouse in the Web browser window. 
2. Click the right mouse button. 

Result 
You get a menu containing the important functions. 
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ITS Source Control 
Purpose 
This process describes how you can use source control in the R/3 System to manage versions of 
all the Internet Transaction Server (ITS) files that make up a service.  
When you have created a service and tested it in the SAP@Web Studio, you can store all the 
files in the R/3 System together with the related ABAP code by adding them to ITS source 
control. This protects against simultaneous modification of files, because all users have read 
access to files, but only a single user is allowed to check files out and modify them.  

Process Flow 
What you can or cannot do with ITS files depends on whether they have been checked into ITS 
source control and where they currently reside, as summarized in the following table: 
 

Current ITS File Location Possible Action 

Not yet in ITS source control Add the files [Seite 95]. 

Checked into ITS source control Either: 
• Check the files out [Seite 97] for modification. 

Only allowed for single users for update 
purposes. 

• Get files for read-only access [Seite 100]. 
These files cannot be copied back to ITS source 
control. 

Checked out of ITS source control Check the files in [Seite 98]. 
Only the user who has checked the files out can do this. 

 
You can manage source-controlled ITS files in the R/3 System. To do this, log on to 
the relevant system and choose Tools → Web development → Web object 
administration. 
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Working With Source-Controlled ITS Files 
Internet Transaction Server (ITS) source control protects files against simultaneous updates by 
different users.  

Prerequisites 
To access files in ITS source control, you must connect to the R/3 System [Seite 94].  

Procedure 
The procedures below summarize what you can do with files in ITS source control:  

If you want to Procedure 

Add files to ITS source control for the 
first time 

1. Add the files [Seite 95]. 
2. Assign the files to a change request [Seite 96] in 

the R/3 System. 

Update files in ITS source control 1. Check the files out [Seite 97]. 
2. Edit [Seite 58] and test [Seite 90] the files. 
3. Check the files back in [Seite 98]. 

You do not need to reassign the files to the 
change request. The R/3 System does this 
automatically. 

Reassign files in ITS source control to 
a new change request after transport 

Assign the files to a new change request [Seite 96] in 
the R/3 System. 
After releasing a change request for transport, you 
must ensure that the files are assigned to a new 
change request. If you fail to do this, users cannot 
check the files in or out. 

Get read-only access to files in ITS 
source control 

Get the required file(s) [Seite 100]. 
This procedure allows you read-only access to ITS 
files. You cannot copy these files back into source 
control. 

 
You can manage source-controlled ITS files in the R/3 System. To do this, log on to 
the relevant system and choose Tools → Web development → Web object 
administration. 
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Connecting to the R/3 System 
To manage Internet Transaction Server (ITS) files in ITS source control, you must connect to the 
R/3 System.  

Prerequisites 
You must have a user in the R/3 System to which you are connecting. 

Procedure 
To connect to an R/3 System: 
1. Choose Tools → Source Control → Connect to R/3. 

The SAP@Web Studio displays the Select R/3 System dialog box, which displays all the 
R/3 connections you have defined. You can define more connections using the New 
button. 

2. Select an R/3 System, and choose OK. 
3. If not already displayed, enter logon information such as client, user, password, and 

language. 
4. If you want the SAP@Web Studio to remember and reuse your password, select Save 

Password. 
If you do this, the SAP@Web Studio stores your password internally in encrypted format. 
On subsequent logons, you do not have to enter your password again.  
If you set up the SAP@Web Studio to maintain all other logon information for you, you do 
not see a logon screen at all.  

5. Choose OK. 

Result 
The SAP@Web Studio logs you on to the R/3 System, and displays all source-controlled 
services in the Source Control view. 
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Adding Files to ITS Source Control 
When you have created and tested an Internet Transaction Server (ITS) service, you can add the 
files to ITS source control. 

Prerequisites 
You must connect to the R/3 System [Seite 94] where you want to add the files. 

Procedure 
1. Select the file(s) you want to add. 
2. Click the right mouse button and choose Add to Source Control. 

You see the Source Control Check In dialog box.  
3. Check the files you want, and choose OK. 

Result 
The SAP@Web Studio adds the files to ITS source control in the R/3 System. Users wishing to 
modify these files must check them out first. 
Now, assign the files to a change request in R/3 [Seite 96]. If you fail to do this, ITS source 
control will not permit any subsequent check-outs. 
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Assigning ITS Files to Change Requests in R/3 
When you add Internet Transaction Server (ITS) files to ITS source control in the R/3 System for 
the first time, you must assign them to a change request.  
At subsequent check-ins, the system remembers the relevant change request and automatically 
replaces the files. You don’t need to specify a change request each time. 
If you release a change request for transport, you must create a new change request and 
reassign the files to it. If you fail to do this, the files cannot be checked out (or in) by other users. 

Prerequisites 
You must add the files to ITS source control [Seite 95].  

Procedure 
To assign new files to a change request in the R/3 System:  
1. Choose Tools → Web development � Web object administration. 
2. In the Service name field, enter the service name. 

You can make generic entries here. 
3. Choose Execute. 

You see a list of objects for the service. 
4. Select the service and choose Transport. 

You see the Change Request Query dialog. 
5. Enter a valid change request number or create a new one.  

− To display a list of your own existing change requests, choose Own requests.  
− To create a change request, choose Create request.  

Result 
The R/3 System creates a change request and assigns the files. You can now check the files out 
[Seite 97] and modify them.  

 
When the R/3 System releases a change request that includes ITS files, it does not 
check the status of the files. Therefore, it is possible to release a transport for which 
files are still checked out. If this happens, you cannot check the objects back in until 
you create a second change request and assign the objects to it. 
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Checking ITS Files out of Source Control 
If you want to modify Internet Transaction Server (ITS) files already added to ITS source control, 
you must check them out first.  
Checking out files means downloading copies of the source-controlled versions from the R/3 
System to the SAP@Web Studio. 
If you check out files accidentally, or find that you do not want to make any changes, you can 
also reverse this operation. 

Prerequisites 
• You must connect to the R/3 System [Seite 94] from which you want to check out the files. 
• The files you check out must be assigned to a change request [Seite 96] in the R/3 System.  
• The files must not be already checked out to another user. 

Procedure 
To Procedure Result 

Check files out 1. In the File View, select the files 
you want to check out. 

2. Click the right mouse button and 
choose Check Out. 

The SAP@Web Studio 
downloads the files to your 
working directory, and marks 
them as checked out to you. 

Undo file checkout 1. In the File View, select the files for 
which you want to undo the check 
out. 

2. Click the right mouse button and 
choose Undo Check Out. 

The SAP@Web Studio reverses 
the checkout operation. 
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Checking ITS Files Into Source Control 
When you have finished modifying source-controlled Internet Transaction Server (ITS) files, you 
must check the new versions back into ITS source control. 
Checking files back into ITS source control means uploading them from the SAP@Web Studio to 
the R/3 System in order to update the source-controlled versions with your latest changes. 

Prerequisites 
• You must connect to the R/3 System [Seite 94] where you want to check in the files. 
• The files must have been previously checked out [Seite 97] to you. 

Procedure 
To check files back into ITS source control: 
1. In the File View, select the files you want to check in. 
2. Click the right mouse button and choose Check In. 

Result 
The SAP@Web Studio copies the files from your working directory to ITS source control.  
If you are checking the files back in and they were already assigned to a change request, they 
are automatically reassigned to the same change request. 
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Setting Checkin/Checkout Options 
Sometimes, you forget and work on Internet Transaction Server (ITS) files that you have not 
checked out. This can happen if you have checked the files into ITS source control, but the old 
versions still reside on the your PC. 
You can prevent this by setting the appropriate options in the SAP@Web Studio. ITS source 
control then does one of the following when you check files in: 
• Deletes the files from the source directory 
• Sets the read-only attribute on files in the source directory 

Procedure 
To set checkin/checkout options when you add files ITS source control or check them back in. 
1. Choose Options → Check In/Out.  
2. Select an option: 

To Procedure 

Delete files on your PC. Select Remove local copy after Add or Check In. 

Set files to read-only. Select Use read only flag for files that are not checked out. 
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Getting Read-Only Access to ITS Files 
You can always get read-only access to Internet Transaction Server (ITS) files in ITS source 
control by copying them from the R/3 System. As long as you don’t want to modify them, you 
don’t need to worry about whether another user has exclusive access. 

Prerequisites 
• You must connect to the R/3 System [Seite 94] from which you want to get the files. 
• You must specify a working directory for the files [Seite 28]. 

Procedure 
To copy files from ITS source control to your PC: 
1. In the Source Control tab, select the files you want to copy. 
2. Choose Tools → Source Control →Get File(s). 

Result 
The SAP@Web Studio copies the files from R/3 System to your working directory.  
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