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The Appointment Calendar (BC-SRV-GBT)
Purpose
The appointment calendar allows you to organize your appointments [Page 7] and to find out
when other employees have appointments. The appointments are managed centrally and can be
taken into consideration when appointments are planned in your enterprise.

Integration
The appointment calendar is included in various SAP applications, for example, the processing of
sales orders or working with activities in Customer Relationship Management. The appointment
calendar is also available as an independent application. The maintenance of your appointments
is independent of the application you are in. This means that appointments that you created for
sales orders are also displayed in your activities view and vice versa.

Features
The appointment calendar supports you in your appointment planning with the following
functions:

•  You can switch between a daily, weekly or monthly view when displaying your appointments.

•  You can work with individual appointments, group appointments and periodic appointments.
You can create a detailed description for each appointment.

•  A search function supports you when searching for times without appointments for one or
more users.

•  Appointments can block a time period or just reserve it (all-day event).

•  All employees involved in a group appointment are notified automatically when the
appointment is created and changed.

•  A substitute concept enables each user to assign authorizations for the display and
maintenance of their appointments to other employees.

•  Various time zone functions support you when you are planning appointments in different
time zones.

All important functions can be called by clicking once or twice on the object concerned (for
example, day, week, month or appointment). For further information, see Working with the
Appointment Calendar [Page 15].

It is possible to maintain the SAP appointment calendar from other user interfaces, for example,
a Web browser or Microsoft Outlook. See Appointment Calendar in the Internet [Page 36] and
Calendar Integration [Page 45].

An interface is available for integrated appointment management. Developers who integrate the
appointment calendar into their application can find further information under Business
Appointment Services [Ext.].
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Appointments
Definition
Time period or point in time to which a user has assigned a specific activity or a specific event.

Use
Appointments are assigned to a specific time period in the appointment calendar. This time
period is then blocked for the activity specified. You can assign more than one appointment to a
time period.

The appointment calendar provides additional utilities to facilitate the creation of special
appointments:

•  Periodic appointments [Page 10]

•  Group appointments [Page 11]

•  Dominants [Page 12].

Structure
An appointment consists of data, such as start and end time of the appointment, title, description,
priority, visibility [Page 8] and appointment type [Page 9].
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Visibility
Use
You can use visibility to control the access authorizations [Page 14] to an appointment.

Features
The appointment calendar offers three levels of visibility:

•  public
By default, public appointments can be displayed by all employees. Examples of such
appointments include company meetings and customer visits.

•  private
Private appointments can only be displayed by selected employees. Examples of such
appointments include lunch dates and doctor appointments.

•  secret
Secret appointments can only be accessed by you. However, they still block a time
period, which is to be taken into consideration when appointments are planned within the
enterprise.
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Appointment Type
Use
The appointment type is an optional specification that users select from a list of possible entries.
Examples of appointment types include vacation, customer visits or working at home. The
appointment type normally only has a descriptive character, however it can be used for user-
defined user exits. This means that when an appointment of a certain type is created, an action is
triggered directly or is demanded by the user.

For further information, see Appointment Types and Event Handling [Ext.] in the documentation
for BC - Generic Business Tools for the application developer.
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Periodic Appointments
Definition
Time periods or points in time to which a user has assigned a specific recurring activity or a
recurring event.

Use
You can create periodic appointments for activities that are repeated at regular intervals or on
fixed dates. When you specify the time intervals, you can also specify various rules, which you
can link together as required. This enables related appointments to be displayed.

Examples of periodic appointments:

•  Weekly group meetings

•  A workshop taking place on the 11th, 15th, 17th and 27th of June

•  Visiting hours - Mondays and Thursdays from 08.00 to 12.00 hrs and every
first Monday in the month from 14.00 to 16.00 hrs.

A search function supports you when you create or change periodic appointments. It can be used
to search for conflicts with non-working days.

You can also create periodic group appointments [Page 11].
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Group Appointments
Definition
Time period or point in time to which a user has assigned a specific activity or a specific event for
more than one participant.

Use
In order to arrange an appointment with several people, you can create a group appointment.
You can specify individual users or distribution lists as participants. A search function helps you
to find an appointment when all the specified participants are available.

When you have created a group appointment, all the participants are notified automatically and
the appointment is created for the participants whose calendars you are authorized to maintain.
The participants for whom the appointment was not created can execute the notification so that
the appointment is entered automatically.

You can also create periodic [Page 10] group appointments.
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All-Day Event
Definition
Time period that a user has reserved for a main activity.

Use
You can use an all-day event to reserve the days that you want to spend preparing a
presentation or sorting out your folders, for example.

Since all-day events do not block a day, they are not taken into consideration in the search for
times without appointments. Therefore, use all-day appointments that block a time period rather
than all-day events for activities that leave no time for other appointments, for example, customer
visits or holidays. (You create all-day appointments by creating an appointment with the
corresponding time specification. Appointments that are not all-day events block a time period.)
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The Public Holiday Calendar and the Factory Calendar
Use
If a public holiday calendar or a factory calendar is set, the non-working days in the relevant
region or in the company are highlighted in color in the calendar display and are not included in
the search for appointments. By default, a calendar that does not contain public holidays is
assigned to the appointment calendar.

Prerequisites
Your administrator [Page 34] sets which calendars you can select.

Activities
You set the factory calendar for your appointment calendar in your calendar settings [Page 20].

When you create periodic appointments, you can select a public holiday calendar or a factory
calendar, which is then used as a basis for the search for conflicts with non-working days.
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Substitutes and Display Authorizations
Use
You can use access authorizations to define which users can access your appointment calendar
with which functions. For example, you can allow all users to display your appointment calendar
with the times of the entered appointments as well as the details about public appointments.
Furthermore, you can specify substitutes who are also allowed to maintain your appointments.

Features
You can set the following access authorizations:

•  General display authorization
This enables all users to display your appointment calendar with all the entered
appointments. The title and description of private and secret appointments are not
displayed. This authorization is assigned by default for every appointment calendar but
can be withdrawn at any time.

It is recommended that you do not change this setting as it enables other employees in
your company to take your appointments into consideration when they are planning
appointments.

•  Substitute authorization
You can create substitutes and assign them specific display authorizations or
maintenance authorizations relating to the visibilities [Page 8] public and private. Secret
appointments can only be maintained by you.

It is advisable to assign the person responsible for the coordination of appointments
for a department or work group a substitute authorization that allows them to
maintain public and, if necessary, private appointments.

Activities
To change the display authorization for your calendar or to maintain a substitute, proceed as
described in Maintaining Access Authorizations [Page 22].

Access authorizations can also be maintained centrally by administrators [Page 34].
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Working with the Appointment Calendar
Use
In the appointment calendar, you can display and maintain your appointments and the
appointments of other employees.

Prerequisites
The authorizations required to work with the appointment calendar are contained in the role
SAP_BC_SRV_GBT_USER. Administrators should assign this role to all users.

In order to display and maintain the appointments of other employees, you require display
authorization or substitute authorization for their appointment calendar. Users can maintain these
authorizations themselves. For further information, see Substitutes and Display Authorizations
[Page 14].

Activities
Calling the Appointment Calendar
To call your calendar, choose Workplace → Appointment Calendar (transaction SSC1).

You receive a calendar info when you log on to the SAP System on the days for
which appointments have been arranged in your calendar. You can go directly to
your appointment calendar by choosing  .

To call the calendar of an employee, proceed as described in Displaying the Appointments of
Other Users [Page 19].

Displaying and Maintaining Appointments
Whilst an appointment calendar is being processed, it remains open for display and maintenance
by other users. This ensures that, at all times, the appointments of all users can be taken into
consideration when appointments are being planned within your company. Whilst an appointment
is being changed by a user, it can only be displayed by other users. Choose  to see the
appointment changes that were made by other users whilst you were displaying an appointment
calendar.

After you have called a calendar, you go to change mode for your own calendar and for
calendars that you are authorized to maintain. For other calendars, you go to display mode. For
further information, see Displaying and Maintaining Appointments [Page 23].

For information on planning appointments in different time zones, see Time Zone-Related
Appointment Planning [Page 32].

You can also maintain your appointment calendar from other user interfaces, for example, a Web
browser or Microsoft Outlook. For further information, see Appointment Calendar in the Internet
[Page 36] and Calendar Integration [Page 45].
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The Calendar Display
Use
The appointment calendar has two screen areas:

•  The navigation area

•  The appointment overview (daily, weekly or monthly view).

Navigation area
The navigation area displays an overview of several months and enables the user to navigate
quickly over a longer time period and to change the time period displayed in the daily or weekly
view. Days for which appointments have been arranged are highlighted in color. Non-working
days are marked by italics.

Nov 1999 Dec 1999 Jan 2000 Feb 2000 Mar 2000

MO
TU
WE
TH
FR
SA

SU

Call a day by clicking
once on the date

Call a week by clicking
once on the week
number

Weeks or days with
appointments are
highlighted in yellow

You can scroll through
the monthly view here.

Appointment overview (daily, weekly and monthly view)
The appointment overview gives an overview of the appointments in the selected time period and
enables the user to call the calendar editing functions quickly: You can switch between the daily,
weekly and monthly view.

The graphic shows how appointments are displayed in the appointment overview, using the daily
view:



 SAP AG The Appointment Calendar (BC-SRV-GBT)

The Calendar Display

April 2001 17

Monday 13th March 2000

Appointment
(blocks a time
period)

All-day event
(reserves a time
period)

To display or change an
appointment: Call the
appointment by double-
clicking on it

To create an appointment:
Double-click on a free time
period

Activities
The standard toolbar for the appointment overview [Page 18] provides functions for changing the
calendar display. You define the default settings for the calendar display in the calendar settings
[Page 20].
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The Standard Toolbar for the Daily and Weekly Views
Use
Functions for navigating and for changing the display are available on the toolbar.

Today  Current week

Navigation

Choose this icon to
switch between the
local times view and
the user time view.

Choose this icon to switch
between the daily, weekly
and monthly views.

Choose this icon to call the
calendar settings.

The following standard functions are also available:

 Create appointment (You can also do this double-clicking on a time interval)

 Display or change the selected appointment (You can also do this by double-clicking on the
appointment)

 Delete the selected appointment

 Cut the selected appointment

 Copy the appointment

 Insert the selected appointment

 Update display.



 SAP AG The Appointment Calendar (BC-SRV-GBT)

The Appointments of Other Users

April 2001 19

The Appointments of Other Users
Use
You can find out about the appointments of employees. To do this, you can either call their
calendars or display their appointments in your calendar. A search function is also available to
support you when searching for times when several employees are free.

Prerequisites
To be able to call the appointment calendar of an employee, you must have at least display
authorization for this calendar. This authorization is assigned by default to all users, but can be
changed by employees for their own calendars. See Substitutes and Display Authorizations
[Page 14].

Activities
Calling the appointment calendar of an employee

1. Choose Goto → Open other calendar.

2. Specify the name of the employee.

3. Choose .

The calendar is displayed in a new session.

Displaying the appointments of other employees

1. Choose Edit → Add other appointments to display.

2. Specify the name of the employee.

3. Choose .

The appointments of the employee specified are displayed in your calendar. You can
repeat the procedure for other employees.

4. To remove the appointments of other employees from your calendar display, choose Edit →
Display own appointments only.

Searching for times when several employees are available
Proceed as described in Searching for Free Times [Page 27].
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Calendar Settings
Use
In the calendar settings, you can adapt the display of the appointment overview to suit your
needs, set a factory calendar [Page 13] and limit the receipt of info mails about group
appointments. You can make the following settings:

Number of days
First day of the week
Factory calendar

Time from  / to
Time interval

Receive no mailInitial
screen

Display daily work schedule
Display times on-call

7 day week
Sunday
Germany (Baden-Württemberg)

Weekly overview

Specify values that
correspond to your region or
your working week.

The factory calendar
contains the non-working
days in your enterprise.

Specify the length of day that is
to be displayed and the time
intervals in which a day is to be
divided.

These flags are only
activated if these plans
have been maintained
for you.

First view when you call the
appointment calendar (daily
or weekly view)

Stops notification being sent for
group appointments that have
already been automatically created
in your calendar.
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Activities
You can call the user settings from the standard toolbar for the appointment overview [Page 18].
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Maintaining Substitutes and Display Authorizations
Use
For information on the use of substitutes and display authorizations, see Access Authorizations
[Page 14].

Procedure
1. In the appointment calendar, choose Substitute → Maintain.

2. The following functions are available in substitute maintenance:

Function Description

General display
authorization

Select this field to grant display authorization for your calendar to all
users.

Substitute
authorization

In order to create a new substitute, enter the name of the substitute
and assign an authorization to this person using the entry help.

In order to change the access authorization of a substitute, assign a
different substitute authorization to them using the entry help.

In order to delete a substitute, select the entry and choose .

3. Choose .

Only you yourself can maintain secret appointments and display the title and
description of secret appointments.
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Creating and Maintaining Appointments
Function Procedure

Creating
appointments

1. Choose .

You can also call this function by double-clicking on a free
time interval. In this case, the date and time of the time
interval are preset.

2. You can search for free times [Page 27].

3. Enter the duration, title and room of the appointment and, if necessary,
select an appointment type using the entry help. You can also create a
description, insert a copy or import an existing text file from your PC
using .

You obtain an overview of these functions in the detail screen of
an appointment [Page 25].

4. Specify a different time zone, if necessary, and select whether the
appointment is always to be displayed in the user time zone. For
further information, see Time Zone-Related Appointment Planning
[Page 32]. If you are planning appointments in one time zone only, do
not change anything here.

5. If necessary, specify rules for a periodic appointment [Page 28].

6. If necessary, specify the participants of a group appointment [Page
31].

7. Choose .

It is possible to create several appointments for the same
time. Scheduling conflicts are then highlighted in color in the
appointment overview.

Changing
appointments

1. Select the appointment in the appointment overview by double-clicking
on it.

2. Make the changes.

3. Choose .

Moving
appointments

1. Position the cursor on the appointment in the appointment overview.

2. Choose .

3. Confirm the subsequent dialog box with Yes.

4. Position the cursor on the new time interval.

5. Choose .
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Copying
appointments

1. Position the cursor on the appointment in the appointment overview.

2. Choose .

3. Position the cursor on the time interval in which the copy of the
appointment is to be inserted.

4. Choose .

Deleting
appointments

1. Select the appointment in the appointment overview by double-clicking
on it.

2. Choose .

3. Confirm the subsequent dialog box with Yes.

Special Features of Group Appointments
You can specify whether the description of a group appointment can only be changed by you, as
the organizer of the appointment, or whether it can be changed by all users.

A description that can be changed by all users could serve as participant
confirmation or it could be used to gather discussion points, for example. If, on the
other hand, the description contains a fixed agenda, it can be protected from
changes by the other participants.

If you have created, changed or deleted a group appointment, the participants receive notification
in their Business Workplace [Ext.] inbox. The appointment, or change of appointment, is copied
automatically in appointment calendars that you are authorized to maintain. These participants
do not receive notification if they have activated this option in their calendar settings. The
participants for whom the appointment has not been maintained can execute the notification in
their inboxes (in the context menu of the message) so that the appointment is automatically
entered in their calendars.

Special Features of Periodic Appointments
After you have confirmed the change or deletion of a periodic appointment, you have to select, in
the subsequent dialog box, whether the function is to apply to the called appointment only or to
all subsequent appointments. Changes to descriptions always apply to all appointments.

If you move (cut and insert at a different time) appointments in a periodic appointment, the
affected rules are automatically adapted. However, the whole periodic appointment cannot be
moved at the same time but only the appointments that belong to a rule.

However, you can copy the whole periodic appointment and insert it again. Note, however, that
when you insert periodic appointments with several rules, all the time specifications are retained.
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Detail Screen for an Appointment
In addition to the title, appointment type [Page 9] and room, you can also specify the following
appointment attributes on the detail screen for an appointment:

Appointments with
high priority are
highlighted in red.

Choose this icon
to start the
search for free
times.

Specify the intervals
for periodic
appointments.

Specify the
participants for group
appointments.

The date and time of
the time period that
you have clicked on
is preset.

Select if the
appointment does not
block a time period
(but rather reserves a
time period).

Deselect if the
appointment is always to
be displayed in the user
time zone.

Time zone in
which the
appointment
takes place.

Finish

Appt. type
Room

Start

Title

Time zone

All-day appt.

Display appt. in local time

Priority
Visibility

 Period  Participants

You can enter an appt.
description of any length
here.

Under Visibility,
define who can
access the
appointment.

For more information, see

Visibility [Page 8]

Searching for Free Times [Page 27]
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Specifying Rules for a Periodic Appointment [Page 28]

Specifying the Participants of a Group Appointment [Page 31].
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Searching for Free Times
1. In the detail screen for an appointment, choose .

2. Specify the time period within which free times are to be searched for.

3. Select an appointment duration.

4. If you are creating a group appointment, choose Participants.

5. Enter the participants. You can specify address names and distribution lists. Enter the
corresponding address type for each one. Otherwise, the address type can be entered
automatically [Ext.].

6. Choose .

7. If you want a list of free times, choose . If you want an overview of the appointments that
the participants have during the specified time period, choose  Appointment overview.

8.  Either in the list or in the overview, select the time interval in which the appointment is to
take place.

9. Choose .

10. Proceed as described in Creating and Maintaining Appointments [Page 23].
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Specifying Rules for a Periodic Appointment
Use
The time periods in which the activities or events of a periodic appointment are scheduled are
spread over several time intervals that recur regularly or irregularly. You can use the following
interface to specify the rules for these time intervals:

Rules for Periodic Appointments

Time period     For one year 01.01.2001 31.12.2001

Every week: Tuesdays 8:00-12:00, Thursdays 8:00-12:30;

And every first Monday in the month from 16:00 to 18:00 hrs

More Delete

Rule Daily periodic appointments

Every       1   Days

From  8:00   hrs  to  12:30  hrs   Central Europe

Exceptions     Not on non-working days

Factory calendar
Public holiday cal.
Every day is a working day

Germany (Hessen)

Copy

Time period to which all the rules for
the periodic appointment apply

Display of all the rules created for
the periodic appointment

Details about a new rule or about
the rule selected in the display

Exceptions for non-working days
that apply to all the rules for the
periodic appointment

Procedure
In the detail screen of an appointment, choose Period. Then create rules or edit existing rules. To
complete editing, choose  Copy.

Creating Rules
1. Specify the time period for which the periodic appointment is to be created.
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If you select a time period from the input help (for example, For one year), the end
date of the time period is entered automatically.

2. Select a rule.

3. Depending on the rule selected, make the following specifications for the appointments:

− Daily periodic appointments
Specify the time period between the individual appointments in days and the time at
which the appointments take place.

− Weekly periodic appointments
i. Specify the time period between the individual appointments (for example, every

week).

ii. Select the week days on which the appointments are to take place and specify the
time at which the appointments are to take place on the selected week days.

− Monthly periodic appointments
Select whether the appointments are to take place on a specific date or on a specific
week day in the month. The rest of the specifications depend on this choice:

•  On a specific date

Specify the time period between the individual appointments in months, and also
specify the day and time of the appointment.

•  On a specific week day

Specify in which week and on which week day the appointment is to take place.

Specify the time period between the individual appointments, and also specify
the time of the appointment.

− Additional appointments
Specify the date and time of the additional appointments.

− No appointments on
Specify the date of the appointments or of the time periods on which appointments are
not to take place. Appointments that, according to a rule, take place on this date are then
canceled. They are not displayed in the calendar.

4. Specify whether exceptions apply to non-working days and how appointments are then to be
handled (for example, whether they are to be canceled or moved to the next working day).

5. Specify the factory calendar or the public holiday calendar according to which the exceptions
are to be calculated.

6. Choose  Copy.

Creating Further Rules
1. Choose  More in the display of the rules.

2. Proceed as described in Creating Rules.
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Changing Rules
1. In the display of the rules, select the rule that you want to change.

2. Change the details of the rule, for example, the rule type, the time period between the
appointments, or the times.

Deleting Rules
1. In the display of the rules, select the rule that you want to delete.

2. Choose  Delete.
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Specifying the Participants of a Group Appointment
Procedure
Adding Participants
4. Choose Participants.

5. Enter the participants. You can specify address names and distribution lists. Specify the
corresponding address type for each one. Otherwise, the address type can be entered
automatically [Ext.].

6. Choose .

Deleting Participants
1. Select the group appointment by double-clicking on it.

2. Choose Participants.

3. To add participants, specify address names or distribution list names.

4. Select the participants that you want to delete.

5. Choose .

Result
The participants are informed by mail and/or by the change to their calendars.
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Time Zone-Related Appointment Planning
Use
Each appointment has to be assigned the time zone in which it takes place. The appointment is
then displayed in the calendar at a time that is dependent on the time zone-dependency of the
appointment and on the view used.

If you maintain your calendar for one time zone only, there is no difference in the
views. In this case, you do not need to deal with time zones. Your own time zone is
assigned automatically to your appointments.

Views: Local times view and user time view
An appointment is displayed in the local times view in the time zone assigned to it, that is, in its
local time. It is displayed in the user time view in your time zone, that is, the time zone that is
assigned to you in your user data. Local time-independent appointments are exceptions. These
are displayed in the local times view in your time zone. Therefore, they are displayed in the local
times view and in the user time view in your time zone.

Time zone-dependency: Local time-dependent appointments and local time-independent
appointments
Local time-independent appointments are appointments that take place in a different time zone to
the one that you are in at the time of the appointment. For example, a video conference taking
place in the time zone Sydney but which you are participating in from Central Europe.

Activities
Switching time zone views
When you call the appointment calendar, the local times view is displayed. To switch views,
choose .

You can recognize which view is currently active by the icon:

•  If the icon is depressed = User time view

•  If the icon is not depressed = Local times view.

Changing the time zone of an appointment
Your time zone is preset when you create an appointment. You can change the time zone when
you create or change the appointment.

Changing your own time zone

1. Choose System → User profile → Own data.

A new session is opened.

2. On the tab page Defaults, specify the time zone.

3. Choose .

The initial screen is displayed.
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4. Close the session.

Creating local time-independent appointments
When you create or change an appointment, deselect the field Display appointment in local time.
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Administration of the Appointment Calendar
Use
Neither Customizing nor administration settings are required for users to be able to work with the
appointment calendar. However, it is advisable to check whether an appropriate factory calendar
or public holiday calendar exists. Only then can users be supported in their appointment planning
by the exclusion of non-working days.

In administration, you can maintain substitutes centrally for users and user groups. You can also
preset or change the calendar settings for all users.

In Customizing, you can define your own appointment types and assign to the appointment types
using a Customer Exit Action (function module). You can also change the settings for the
appointment priorities.

Prerequisites
You require administrator authorization for the appointment calendar. This is contained in the role
SAP_BC_SRV_GBT_ADMIN.

Activities
A personal appointment calendar with the standard values is automatically assigned to each user
in the SAP System the first time he or she calls the calendar. This calendar is based on the
public holiday calendar or factory calendar that is preset for the whole client.

You maintain factory calendars and public holiday calendars in the Basis R/3 Implementation
Guide (Tools --> Business Engineer --> Customizing) under Basis → General Settings. For
further information, see Maintain Calendars [Ext.] (for Japan: Maintain Calendars for Japan
[Ext.]).

You maintain appointment types in the Basis R/3 Implementation Guide or in the role menu
under Business Communication Administration → Appointment calendar → Appointment
calendar: Appointment type maintenance. For further information, see Maintain Appointment
Types for the Appointment Calendar [Ext.].

You maintain appointment priorities in the Basis R/3 Implementation Guide or in the role menu
under Business Communication Administration → Appointment calendar → Appointment
calendar: Priority maintenance. For more information, see the Implementation Guide under Basis
→ Basis Services → Generic Business Tools → Appointment calendar in the documentation for
the node Maintain Priorities for the Appointment Calendar [Ext.].

In order to maintain substitutes centrally for one or more users, choose Business
Communication Administration → Appointment Calendar −−> Substitute maintenance in the role
menu. Specify a substitute and choose Authorization maintenance. In the subsequent dialog box,
you can specify the users to be substituted and the corresponding access authorizations [Page
14]. Instead of specifying all the users individually, you can also use distribution lists [Ext.].

To change the calendar settings, choose Business Communication Administration →
Appointment calendar → Maintenance of constant values. Specify the new values for the
calendar settings [Page 20]. On the right hand side, select the values that are to be changed and
choose . The values are changed for all the calendar users.
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To be able to use the appointment calendar, users must be assigned the authorizations for
transactions SSC1 and SSC0. This authorization is contained in the role
SAP_BC_SRV_GBT_USER. For more information on roles, see the documentation Users and
Roles [Ext.].
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Appointment Calendar in the Internet
Use
This Easy Web Transaction (EWT) offers your employees an easy to use, intuitive interface for
the maintenance of their appointments in the SAP System. As a result, appointment data can
also be managed in the SAP System by employees who do not work with the SAP GUI. This
means that it is possible to benefit from the advantages of a central appointment availability
without incurring training expenses for the use of the SAP GUI. When planning their own
appointments or creating group appointments, employees can access the appointments of their
colleagues, irrespective of whether these were created using the SAP GUI or the Web interface.
Furthermore, employees working out of the office, for example, can maintain their appointments
using an Internet link in the SAP System.

Integration
The appointment calendar [Ext.] is part of the Basis component of the SAP System and can,
therefore, be used in all applications by all users.

Authorizations/Security
The authorizations required to maintain your own appointment calendar are contained in the role
SAP_BC_SRV_GBT. Access authorizations for the calendars of other users are defined by users
for their own calendars or by an administrator. By default, every user can display the appointment
calendars of other users. Users can limit the display options for individual appointments by
classifying them as secret. Secret appointments block a time period, but no detailed information
is displayed.

Standard Settings and Preallocated Data
You can make settings for the EWT appointment calendar in Customizing. For further
information, see Customizing of the appointment calendar under Basis → Basis/Services →
Generic Business Tools → Appointment calendar. There, you can define the appointment types,
which can be assigned to appointments using the SAP GUI or the Web interface, and the
priorities that can be selected. For further information, see Administration of the Appointment
Calendar [Page 34].

Features
The usability of the EWT calendar is of utmost importance. Therefore, some of the functions of
the SAP GUI calendar were not incorporated in the Web calendar.

All-day events can only be maintained in the SAP GUI calendar. They are, however, displayed in
the Web calendar. Various options for defining the period of periodic appointments are available
in the SAP GUI calendar. Whereas in the Web calendar, you only have the choice of daily,
weekly, monthly or yearly periods. Appointments with other periods are, however, displayed in
the Web calendar as periodic appointments and can be changed or deleted there.

Adjustment Options
Service Name
The service name of this Easy Web Transaction is BWCA You will find all the associated files in
the SAP System and in the SAP@Web Studio under this name.
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SAP Development Objects
The following development objects are of significance for this EWT:

Development class SSC

Transaction SSC1

Function group for screens SAPLBW05
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The Appointment Calendar
Help on Procedures
Your appointment calendar is displayed with the following screen areas:

•  Navigation area (overview of several months)

•  Appointment overview (daily, weekly or monthly view)

In the time period displayed in the daily or weekly view, appointments and scheduling conflicts
are flagged with text, color or icons. The following functions are available:

Navigating in the appointment calendar [Page 39]

Displaying and maintaining appointments [Page 41]

Calling the appointment calendars of other employees [Page 42]

Creating or deleting substitutes [Page 43]

Changing the calendar settings [Page 44].

Information on the Appointment Calendar
The Easy Web calendar enables you to maintain your appointment calendar in the SAP System.
You can create, display, change and delete your own appointments or the appointments of your
employees. The appointments that were maintained in the SAP GUI are also displayed in the
Web.

If you maintain appointments for several employees, you can create group appointments. The
participants are then notified when the appointment is created and if it is changed. The
appointment is entered directly in the calendars of the users for whom you have substitute
authorization.

If you maintain appointments that take place on a regular basis, you can create periodic
appointments. For example, you can create an appointment for a weekly group meeting for the
first six months of next year for all the participants.

You cannot create periodic appointments that take place irregularly (for example, on
the 14th, 15th and 20th of October or on the first Monday of every month) in the Web
calendar. However, you can display and change such appointments just like other
periodic appointments. Other is entered as the period for such appointments.
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Navigating in the Appointment Calendar
Displaying a day in the detail view:
On the calendar page, click on the date.

Displaying a week in the detail view:
On the calendar page, click on the week number.

Displaying a month in the detail view:
On the calendar page, click on the name of the month.

Displaying the previous or next month:
On the calendar page, click on the arrow above or below the column containing the name of the
month.

Displaying the previous or next year:
On the calendar page, click on the arrow pointing right or left next to the year number.

Enlarging or reducing screen areas:
Move the separator lines using the mouse.

Increasing or decreasing the number of months displayed:
On the calendar page, click on the + or - above the column containing the name of the month.

Back [Page 38]
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Creating Appointments
Creating Normal Appointments
1. In the daily or weekly view, choose Create appointment.

Alternatively, you can call this function by clicking once on a free time interval in the
detail view. In this case, the date and time of the time interval are preset.

2. Specify at least the date and title of the appointment in the dialog box.

If you do not enter a title, the system automatically enters the date as the title.

3. Choose Save.

Creating Group Appointments
Perform the following steps for each participant:

1. When you create or change an appointment, specify the name of a participant in the field
above the participant list.

2. Choose Insert.

3. If more than one employee is found, select the participant by clicking once on his or her
name.

4. Choose Save.

Creating Periodic Appointments
1. When you create or change an appointment, specify in the Period field whether the

appointment is to take place daily, weekly, monthly or yearly.

2. Specify the end date of the period in the field To. Enter the date for which the appointment
was created as the start date of the period.

3. Choose Save.

The appointment is created from the start date to the end date of the period, at the
specified time and in the specified intervals (for example, from 03.01.2000 to 30.06.2000,
every Monday from 14:00 to 16:00 hrs).

Back [Page 38]
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Displaying, Changing or Deleting an Appointment
Displaying / Changing an Appointment
1. In the appointment overview, click on the text of the appointment.

2. Make changes, if necessary.

3. In the case of periodic appointments, specify whether it is the current appointment only that is
to be changed or all appointments in the period.

4. Choose Save.

A group appointment can only be changed by the organizer. The organizer is the
user who created the appointment.

Deleting Participants of a Group Appointment
1. In the appointment overview, click on the text of the appointment.

2. In the participant list, click on Trash next to the participant for whom you want to delete the
appointment.

3. Confirm the subsequent dialog box.

Deleting an Appointment
1. In the daily or weekly view, click on the text of the appointment.

2. In the case of periodic appointments, specify whether it is the current appointment only that is
to be changed (therefore deleted) or all the appointments in the period.

3. Choose Delete.

4. Confirm the subsequent dialog box.

Displaying Scheduling Conflicts
In the appointment overview, click on the time period highlighted in red.

Back [Page 38]



The Appointment Calendar (BC-SRV-GBT)  SAP AG

Calling the Appointment Calendar of Another Employee

42 April 2001

Calling the Appointment Calendar of Another Employee
1. In the field Maintain appointment calendar or Display appointment calendar, enter the name

of the employee whose calendar you want to call. You can also specify part of the name and
replace the rest with the joker *, for example, B*cker.

2. Click on the icon Start user search.

3. If more than one employee is found, select the employee you require by clicking once on his
or her name.

The calendar of the employee is displayed. You can navigate in the same way as you
can in your own calendar and you can display the detail view of an appointment as well
as scheduling conflicts. If you have substitute authorization for the employee's calendar,
you can also maintain appointments.

In the case of secret appointments, only the time data is displayed to you and not the
title or the description of the appointment. This is also the case for private
appointments, unless you have substitute authorization for the private appointments
of the employee.

To return to your own calendar, click on the icon Own calendar next to the confirmation tick.

Back [Page 38]
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Creating or Deleting Substitutes
Creating Substitutes
1. Choose Substitutes.

2. Specify the name of the employee who you want to create as a substitute.

3. Choose Insert.

4. If more than one employee is found, select the employee you require by clicking once on his
or her name.

5. Choose Save.

Deleting Substitutes
1. Choose Substitutes.

2. Click on Trash next to the employee who you want to delete as your substitute.

3. Choose Save.

Back [Page 38]
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Changing the Calendar Settings
1. Choose Personal settings.

2. You can change the following settings:

− The length of day that is to be displayed to you (for example, 8:00 to 18:00 hrs).

− The time intervals in which a day is to be divided (for example, 30 minutes).

− The detail view that is to be preset when you call your calendar (for example, the weekly
view).

− The days that are to be displayed in the weekly view (for example, a 5 day week,
therefore Monday to Friday).

− If public holidays or other non-working days are to be flagged in your calendar, set a
calendar that corresponds to your region or your enterprise.

3. Choose Save.

Back [Page 38]
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Calendar Integration
Purpose
Calendar integration enables you to connect calendars from third party manufacturers to the R/3
System. As a result, appointments that users in another electronic calendar (calendar client)
have maintained can be synchronized with R/3 appointments. The advantages of a central
address management and of integrating the R/3 calendar into R/3 applications are connected
with the functions of the chosen calendar client. For example, users can work offline with a
calendar client such as Microsoft Outlook.

Outlook calendar integration [Page 47] provides a calendar integration that enables the Microsoft
Outlook calendar to be connected to the R/3 System. As a result, users who use the workflow
and mail functions of the R/3 System via the Microsoft Outlook interface can also maintain their
R/3 calendar in Outlook. For information on the connection of mail clients to the R/3 System, see
BC - SAP MAPI Service Provider [Ext.].

Integration
The connection between the R/3 calendar and the calendar client runs via a synchronization
module that is independent of the calendar client used. The synchronization module expects the
appointments in an independent format. On the R/3 side the R/3 connector is converted and on
the client side a client connector.

The following graphic illustrates the composition of calendar integration.
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Outlook Calendar Integration
Use
Outlook calendar integration allows enterprises to plan their appointments in the R/3 System,
regardless of whether users maintain their appointments in the R/3 calendar or the Microsoft
Outlook calendar.

Integration
Outlook calendar integration consists of the SAP calendar interface and the Outlook-R/3 calendar
interface. The Outlook R/3 calendar interface is composed of the programs that connect
Microsoft Outlook to the synchronization module (WdkSyCl.exe) of the SAP calendar interface:

•  The Microsoft Outlook Client Connector (Wdkcol.dll)

•  The Outlook Client Extension (Wdkcalex.dll)

•  The configuration file of the Outlook Client Extension (Sapcalex.ecf)
The following graphic illustrates the composition of Outlook calendar integration:
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Installing Outlook Calendar Integration
Use
The Outlook calendar integration installation program contains all the programs you need for the
connection between the R/3 calendar and the Outlook calendar. You will find this program on the
SAP presentation CD.

Prerequisites
Operating system Windows 95, Windows 98 or Windows NT 4.0.

R/3 System version 4.5B or higher.

Microsoft Outlook 98

If you use the minimum installation of Microsoft Outlook, it is possible that the
program component Expression Service, which is required for calendar integration,
will be missing. If this is the case, you will receive an error message. In order to
install the missing program component, call the Microsoft Outlook installation
program again and select only the Expression Service to be installed.

If a version of Outlook calendar integration is already installed on your PC, deinstall
this before installing the new version. You must also deinstall the client extension
from the Microsoft Outlook Add In Manager. To do this, choose Extras → Options in
the Outlook menu, then Further options on the tab page Others, then Add In
Manager. Deselect SAP calendar and confirm all three dialog boxes with OK.

You can also use calendar integration with R/3 Release 4.0B, but to do so you need
to make some adjustments. Before installing, read note 0103529 and related notes in
SAPNet.

Procedure
Call the installation program Setup.exe.

A wizard guides you through the installation process.

When you reach the installation options, choose Desktop interfaces and choose Change option
to confirm. Select the component Calendar synchronization for MS Outlook and confirm.

Result
The installation program installs the required files. The client extension is also copied to the Add-
In directory in Microsoft Outlook (for example, C:\Programs\Microsoft Office\Office\Addins). If
errors occur during installation, read note 178760 in SAPNet.

Before you can use calendar integration, you have to set calendar integration [Page 57].
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Setting Calendar Integration
Purpose
You can create several calendars in Microsoft Outlook. Therefore, you have to inform the system
which calendar is to be synchronized with the R/3 System. Note that you can only use calendars
in the personal folders area. You cannot use calendars under the folder in which the inbox for
mails and work items from the R/3 System is located.

If you also maintain calendars for other R/3 users, you can arrange these calendars in the same
personal folders area or use a separate personal folders area for each one. The graphic shows a
mail area and a calendar area in which the calendars of several users have been created.

Outlook Today (C11-001 SAPoffice - Brown)

Inbox

Outbox

Outgoing Queue

Private

Public

Trash

Calendar area

My calendar

Anna Smith’s calendar

Resubmit

Deleted items

Tasks

Do not create
calendars in an R/3
mail area!

Create calendars
in a personal
folders area!

Process Flow
If you do not use a calendar in Microsoft Outlook yet:

1. Create or select personal folders area

See Creating Calendar Areas [Page 52].

2. Create or select the calendar folder

Use an existing calendar folder in the calendar area that you selected earlier or create a
new folder for appointments in the calendar area. It is recommended that you copy the
calendar used to the Outlook short cut bar.

3. Create and configure the calendar profile.

See Calendar Profiles [Page 56].
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Result
If you work in Microsoft Outlook, the calendars of the current profile are synchronized at the
specified time. For further information, see Working with Calendar Integration [Page 66].
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Creating the Calendar Area
Use
You have to use a calendar that is in the personal folders area of MS Outlook for calendar
integration. Furthermore, the personal folders area must be assigned to the mail profile as a
service. You can use an existing personal folders area or create a new one.

Procedure
Procedure 1
1. Open Outlook.

If you have created several mail profiles, log on using the profile in which you want to
use the calendar.

2. Choose File → New → Personal folders (pst file).

3. In the subsequent dialog box, specify the path and file name with the ending PST. You can,
for example, copy the proposed file Personal Folders(1).pst.

4. Choose Create.

5. Specify the name under which the area is to be displayed in the file list, for example
Calendar area.

6. Choose OK.

Procedure 2
As an alternative to procedure 1, you can proceed as follows. In this case, however, you cannot
choose the name of the area yourself. Furthermore, the standard files (inbox, outbox, and so on),
which you cannot delete, are automatically displayed to you in this area.

1. On the tab page Services, choose Add.

2. Select the personal folders area.

3. Choose OK.

4. In the subsequent dialog box, specify the path and file name with the ending PST. You can,
for example, accept the proposed file Outlook.pst.

5. Choose Create.

6. Choose OK.

If you want to maintain the same calendar in several profiles, add the service to each
of these profiles.
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Calendar Profiles
Use
Calendar integration synchronizes an R/3 calendar with an Outlook calendar. In the calendar
profile, you define which calendars are to be synchronized and how synchronization is to take
place.

If you want to synchronize several calendars, you have to create a calendar profile for each
combination of

•  R/3 calendar (R/3 System, client and user) and

•  Outlook calendar folder.

In the example, Mr Brown has assigned a personal folders area with the name
'calendar area' to the mail profile for his mails and work items in the R/3 System C11.
The calendars that Mr Brown maintains in Outlook are to be synchronized with the
calendars in client 001 of the R/3 System C11. As well as maintaining his own
calendar, Mr Brown also maintains the calendar of his boss, Anna Smith. Therefore,
he created two profiles.

Outlook Today (C11-001 SAPof

Inbox

Outbox

Outgoing Queue

Private

Public

Trash

Calendar Area

My calendar

Anna Smith’s calendar

Resubmit

Deleted items

Tasks

Client              000

Client              001
  User          Brown

  User          Smith

Client             003

System T11

System C11

Profile    BrownProfile    Smith

If Mr Brown wants to synchronize 'My calendar' with another client or another R/3
System, he has to create a profile for this combination too.
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However, only one profile is used in a synchronization process. Only the calendars
specified in the current profile are synchronized. To synchronize a different calendar
combination, you have to change the profile.
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Maintaining the Calendar Profile
Use
You have to create a calendar profile for every calendar combination that is to be synchronized.
Only the current profile is synchronized. Therefore, you have to change the current profile if
another calendar combination is to be synchronized.

The profile does not automatically change if you edit a calendar file that belongs to a
different profile to the current one.

Procedure
1. Choose Extras → Options.

2. On the tab page SAP Calendar, choose Settings.

3. Choose Profile.

4. A list of the existing profiles is displayed.

You can perform the following functions in this list:

Change the current profile
a. Select the profile that is to be set as the current profile.

b. Choose OK.

Create a profile
a. Enter the name of the new profile in the field Profile name.

b. Choose OK.

c. The new profile is automatically set as the current profile.

Delete a profile
a. Select the profile.

b. Choose Delete.

c. The profile is deleted immediately.

The standard profile and the profile currently set cannot be deleted.

Change profile
Set the profile as the current profile and change the settings.
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Configuring the Calendar Profile
Use
A calendar profile summarizes which calendars are to be synchronized, when synchronization is
to take place and which time period in the calendar is to be synchronized.

Activities
Create a profile for each calendar combination. See Maintaining Calendar Profiles [Page 56]. If
you only maintain one calendar, you can change the preset standard profile.

You make all the settings for calendar integration in Microsoft Outlook. The settings include

•  setting the time of synchronization [Page 59] and

•  setting synchronization [Page 60].

The following graphic shows an overview of the settings that are summarized in a profile for each
calendar combination:
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If the dialog box for the synchronization settings does not appear, although you have
called the settings using the pushbutton, it could be covered by other windows (for
example, the Outlook main window). Check first before calling the function again.
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Setting the Time of Synchronization
Use
You can set a default for when an automatic synchronization between the Outlook calendar and
the R/3 calendar should take place:

•  When Outlook is started

•  When Outlook is shut down

•  When appointments are created or changed in Outlook

You can select one or more of these options. Bear in mind however, that the synchronization
process affects performance. You can also specify whether you want to start synchronization
manually directly from the Outlook menu.

Activities
To change the settings for the synchronization period, choose Extras → Options. On the tab
page SAP Calendar, specify when an automatic synchronization is to take place and choose
Apply. You can call up more functions using pushbuttons:

Function Description

Synchronizing This function is used to start a synchronization.

Settings This function is used to change the settings for synchronization [Page 60].

If the dialog box for the synchronization settings does not appear,
although you have called the settings using the pushbutton, it
could be covered by other windows (for example, the Outlook
main window). Check first before calling the function again.

Info You call a dialog box containing the version number of the current Outlook-
R/3 calendar integration.
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Setting Synchronization
Use
You use these settings to record in the calendar profile which calendars are to be compared and
how appointments are to be synchronized in cases of conflict.

Activities
Choose Extras → Options and on the tab page SAP calendar, choose Settings.

If the dialog box for the synchronization settings does not appear, although you have
called the settings using the pushbutton, it could be covered by other windows (for
example, the Outlook main window). Check first before calling the function again.

You can call up the following functions using pushbuttons:

Function Description

Profiles If you want to change the settings for another profile, change the profile. See
Maintaining Calendar Profiles [Page 56].

Initial values This function is used to reset all settings to the initial values.

Help This function is used to call documentation on calendar integration.

Make you settings on the tab pages:

•  General Settings [Page 61]

•  Settings for Conflict Resolution [Page 62]

•  Logon Information [Page 63].
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General Settings
Use
In general settings, specify which time period is to be used for synchronization.

Activities
Choose Extras → Options and on the tab page SAP calendar, choose Settings.

Microsoft Outlook is set as the comparison calendar on the tab page General. To set the period
during which the appointments are compared during synchronization, choose one of the following
functions:

Function Description Condition

All in the next
<number> <unit>
or

All in the last
<number> <unit>

All appointments that exist in the
specified time period are
synchronized.

Both entries are 2 days. During a
synchronization on 17.10.1998 all
appointments from 15.10.98 to
19.10.1998 are synchronized.

Select the option all in the next, if
the users work regularly with the
calendar online.

You only need the additional option
in the last if the users require all
past appointments to be
documented in both calendars.

It is best not to specify too long a
time period, because all the existing
appointments in the time period are
compared each time. If the users
use their calendars every day, the
entry All in the next 2 days is
sufficient

All in the future All appointments that exist as of
the current point in time are
synchronized.

Only select this option if this is the
first time a synchronization has
been performed or if users work
with the calendar very little.

All All existing appointments are
synchronized.

Only select this option if this is the
first time a synchronization has
been performed and the users
require past appointments to be
documented in both calendars, or if
appointments stored in the R/3
System are to be deleted in
Microsoft Outlook.

You can also set whether it is possible to interrupt the synchronization process manually.
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Resolving Conflicts
Use
You can maintain the calendar in the R/3 System or in Microsoft Outlook. The calendars are
compared with one another during synchronization and are both updated. Conflicts arise if an
appointment has been changed in the R/3 calendar and in Microsoft Outlook since the last
synchronization took place. You can specify how these conflicts are to be resolved. You can also
specify whether, and in which cases, you want to receive a query before an appointment is
synchronized.

Activities
Choose Extras → Options and on the tab page SAP calendar, choose Settings.

On the tab page Conflict resolution, set:

When you want to receive a query:

Function Description

Query

•  when deleting

•  when changing

•  when creating
a new
appointment

If you activate a query, the user receives a list during synchronization, of
all appointments that have been processed using one of the selected
functions since the last synchronization. The user then confirms the
appointments that are to be synchronized.

How appointments are to be synchronized in cases of conflict:

Function Description

Copy most recent
appointment

The most recently changed appointment overwrites the appointment in
the other calendar.

SAP R/3 calendar
has priority

Appointments from the R/3 calendar overwrite the appointments in
Microsoft Outlook.

Synchronization
calendar has
priority

Appointments from Microsoft Outlook overwrite appointments in the R/3
calendar.
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Logon Information
Use
You have to specify which R/3 System you use the calendar in and which calendar you use in
Microsoft Outlook. You also have to enter logon data so that the R/3 calendar can be accessed
during synchronization. Furthermore, you can make a setting so that non-working days in your
enterprise are highlighted in the Outlook calendar.

Activities
Choose Extras → Options and on the tab page SAP calendar, choose Settings.

The logon data within the context of SAP R/3 is automatically entered if you choose the
pushbutton R/3 Logon on the tab page Logon information and log on to the required R/3 System.

In the input field Calendar, you can use value help to display the calendar files that you created in
Microsoft Outlook.

You can only use calendars from a personal folder area. Furthermore, only the
calendars that are located on the first level under these areas can be used.

You can also copy non-working days from the R/3 System [Page 64].
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Copying Non-Working Days
Prerequisites
Non-working days are copied from the public holiday or factory calendar that is set in the R/3
System.

Procedure
1. Choose Extras → Options and on the tab page SAP calendar, choose Settings.

2. Choose Copy public holidays.

− In the subsequent dialog box, specify:

− whether you want to copy public holidays and/or other non-working days (for example,
company vacation)

− whether you want to receive a query before the non-working days are created in the
Outlook calendar.

− which year you want to copy the non-working days for.

3. Choose Start.

4. Choose OK.

5. If you have selected the query, you receive a dialog box asking you to confirm that the
appointments on non-working days are to be copied:
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 Compare R/3 Calendar with MS Outlook

R/3 Calendar MS Outlook

01.01.1999 New years day...

OK

Click here to
change the
selection for this
date.

By clicking OK, you create
all the selected dates as
non-working days in the
Outlook calendar.

Click here to change
the selection for all the
dates in this list.

Result
The appointments on non-working days are created in the Outlook calendar and marked as R/3
non-working days.
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Working with Outlook Calendar Integration
Use
You and your substitutes can maintain your calendar either in the R/3 System or in Microsoft
Outlook using Outlook calendar integration. So that both calendars stay up to date, they are
regularly compared. Your individual settings [Page 60] determine when the synchronization
process starts and whether the user receives queries concerning the process.

In the Outlook calendar, you can execute the available functions independently of R/3 and work
online or offline. If you require help when working with the Outlook calendar, use Microsoft help.
If you require help with regard to synchronization, see

Make sure that you work in Outlook in the calendar file that you set in the calendar
profile. If you also want to maintain another calendar as a substitute, you have to
create a calendar profile for this calendar too. Only the calendar specified in the
current profile is synchronized.
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Synchronizing R/3 and Outlook Calendars
Use
In order for calendars in the R/3 System and in Microsoft Outlook to contain the same
appointments, changes made in one calendar must be copied to the other. Synchronization can
occur automatically when you call and/or exit Microsoft Outlook or you can start synchronization
manually. When and how synchronization takes place depends on your settings.

Activities
Only the calendar specified in the current profile is synchronized, irrespective of whether
synchronization takes place automatically or is started manually. If you want to synchronize other
calendar combinations, you have to change the profile. See Maintaining Calendar Profiles [Page
56].

Synchronization is started in Microsoft Outlook and the settings [Page 59] for the synchronization
process are also made there. It is not possible to start synchronization from the R/3 System. To
start synchronization manually, choose Extras → SAP calendar synchronization in the Microsoft
Outlook menu.

If queries [Page 69] are activated in your settings, a dialog box is displayed during
synchronization in which you select appointments that you want to be synchronized.

It can take some time for the dialog box to be displayed, depending on the system
load.

If several synchronization processes are started at the same time, they run one after
the other. You should therefore not call synchronization repeatedly if the system
does not react immediately. It is possible that you have not yet answered the queries
from the current synchronization.

Constraints
Some functions are treated differently in the two different calendars causing the following
differences in synchronization:

Outlook Function Synchronization with R/3 Calendar

Appointment series Appointment series are called periodic appointments in the R/3
System.

During synchronization, appointment series / periodic appointments
are created in the R/3 calendar / Outlook calendar as normal
appointments. If the appointments are created outside the
synchronization period, they are taken into account in the next
synchronizations.

Appointment
attachments

The R/3 calendar does not display attachments, they remain
‘invisible’. If you change appointments in the R/3 calendar that had
an attachment in the Outlook calendar, the attachments remain in
Outlook when the R/3 synchronization is performed.
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Tasks The R/3 calendar does not support tasks.

Contacts Contacts are not synchronized.
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Queries During Synchronization
Use
If you have activated Queries in your settings, you receive an overview of the appointments that
have been edited in a calendar with the specified function and that are now to be transferred to
the other calendar. In this case, the appointments are only synchronized if you confirm
synchronization.

If online synchronization is selected, you receive the queries individually and
sometimes after a time delay.

Features
The query window contains a list of the appointments that have been edited in the
synchronization period either in the R/3 calendar or in the Outlook calendar. The following
information is displayed for each appointment in the list:

•  Date and time of the appointment

•  Appointment title

•  Function to be used to edit the appointment during synchronization (only those specified in
the query settings).

The specified icons have the following meanings:

� Create new appointment

� Delete appointment

� Change appointment in the R/3 calendar

� Change appointment in the Outlook calendar.

You can also display the following detailed information for each appointment:

•  Description

•  Start of appointment

•  End of appointment

•  Room

•  Transparency (0 = not blocked, 1 = blocked)

•  Classification (public, private, secret)

•  All-day appointment (dominant)

•  Appointment type

•  Appointment-specific data

•  Last change.

In the detailed display, the fields that differ in the two calendars are indicated by an exclamation
mark (!).
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Activities
Before synchronization takes place, a dialog box is displayed listing all appointments that have
been created, changed or deleted since the last synchronization. You can execute the following
actions:

Function Description

Synchronize all
appointments

Confirm.

Synchronize some
appointments

Remove the ticks (�) from the appointments that you do not want to
synchronize and confirm.

If you reject the change of appointments, the appointments are not
listed again for future synchronizations until they have been
changed again or deleted.

If you reject the deletion of appointments, the appointments are
listed as new appointments for future synchronizations.

If you reject the creation of appointments, the appointments are
listed again as appointments to be created for future
synchronizations.

Display detailed
information about an
appointment

Select the appointment by double-clicking on it.

Synchronize
appointments
individually

Select an appointment in the detailed display and

- choose >> to copy the appointment into the Outlook
calendar, or

- choose << to copy the appointment into the R/3 calendar.

Synchronize individual
fields of an appointment

Select the required fields in the detailed display and

- choose > to change the field in the Outlook calendar, or

- choose < to change the field in the R/3 calendar.


