SAP MAPI Service Provider (BC-SRV-GBT)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Caution" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image" alt="Example" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image" alt="Note" /></td>
<td>Note</td>
</tr>
<tr>
<td><img src="image" alt="Recommendation" /></td>
<td>Recommendation</td>
</tr>
<tr>
<td><img src="image" alt="Syntax" /></td>
<td>Syntax</td>
</tr>
<tr>
<td><img src="image" alt="Tip" /></td>
<td>Tip</td>
</tr>
</tbody>
</table>
Contents

SAP MAPI Service Provider (BC-SRV-GBT) ......................................................... 5
Configuring SAP MAPI .......................................................................................... 7
Installing the SAP MAPI ....................................................................................... 9
Creating Profiles .................................................................................................. 10
Creating a Profile Automatically .......................................................................... 12
Setting Individual Parameters in the Profile ...................................................... 13
MAPI Clients: Compatibility ................................................................................. 16
Using SAP MAPI with External Mail Systems .................................................. 17
Working with SAP MAPI ...................................................................................... 18
Switching Between Online and Offline Modes .................................................. 19
Sending Mails ....................................................................................................... 20
Recipient List ......................................................................................................... 21
Address Book ........................................................................................................ 22
Inserting Addresses from the Business Workplace .......................................... 23
Finding an Address ............................................................................................... 24
Deleting Addresses from the Address Book ...................................................... 25
Selecting Recipients from the Address Book ..................................................... 26
Displaying User Data ............................................................................................ 27
Processing Work Items in the MAPI Client ....................................................... 28
Forwarding Work Items ....................................................................................... 30
Executing Work Items ......................................................................................... 31
Special Work Item Form: Initiating Callback ................................................. 33
Processing Work Item Attachments ................................................................. 34
Download Options for Work Items ................................................................... 35
Configuring Inbox List Column Display ........................................................... 36
Refreshing Folders Manually ............................................................................. 37
Improving Performance ....................................................................................... 38
Hazards in Offline Processing ........................................................................... 39
Trouble-Shooting ................................................................................................. 40
SAP MAPI Service Provider (BC-SRV-GBT)

Purpose

The SAP MAPI Service Provider (SAP MAPI, also: SAP MAPI SPI for Service Provider Interface) allows access to the R/3 mail server Business Workplace [Ext.] (previous name: SAPoffice) and to the SAP Business Workflow [Ext.] from the MAPI-compatible mail clients. Users can therefore use the SAP MAPI working environment in order to edit and send Workplace documents and to execute work items. Examples of MAPI-compatible mail clients: Microsoft Windows Messaging™, Exchange Client for Windows™ and Microsoft Outlook for Windows™.

Integration

The SAP MAPI service also consists of three services which link the Workplace and the SAP Business Workflow via RFC. The link is triggered when the user calls the mail client in online mode. Synchronization takes place in both directions, that is, changes made in the mail client can be seen in Workplace and vice versa.

Features

SAP MAPI offers:

- Standard Workplace functionality
  for example, manage, send or receive documents
- Integrated workflow support
  You can access SAP Business Workflow immediately, processing work items directly in the MAPI clients. In addition, work items can also be processed via SAPforms [Ext].
- Offline processing
  You can also edit messages or work items without a link to R/3. For example, messages can be registered, changed and "sent", that is, put in the out box. When you log on to the
R/3 System again, these messages are automatically sent in R/3. You can, for example, "forward" work items offline, that is they are only actually flagged for transfer. They are then automatically forwarded in R/3 upon the next logon.

In general, all offline changes are automatically updated when they "are online" again. For work items you can use a special Outlook form.

See also:

Configuring SAP MAPI [Page 7]
Working in the mail client [Page 18].
Configuring SAP MAPI

Purpose

SAP MAPI contains:

- SAPoffice Message Store (folders for documents and work items), transport and address book (mpsap32.dll)
- Executable programs (mpdb.exe and mprfcsv.exe)
- Workflow/Business Object Attachment Interpreter (mpinterp.exe, mpbusobj.exe and mpstub.exe)
- Files for column display for workflows (mpform.ico and mpform.cfg)
- PST file (personal folders) for special SAPforms Outlook form for offline workflow support and setup (wkfpubli.exe, sapwkf.prf and sapwkf.pst)
- NEWPROF configuration template [Page 12] (saptempl.prf)
- Application help documentation (readme.txt and mapifaq.htm). The most up-to-date frequently asked questions list is available in the Internet at http://www.saplabs.com/software/mapi/Mapifaq.htm

Prerequisites

- Windows NT 3.51, Windows NT 4.0, or Windows 95.
- R/3 SAPoffice Release 3.1G or above (from Enjoy Release: Business Workplace)
- For offline processing of work items: R/3 Release from 4.5A onwards and a mail client that supports MS Outlook forms.
- Minimum 8 MB of RAM on your PC.
- At least 10 MB of free disk space
- SAPGUI and SAPLogon are installed (required for SAP Workflow support and for creating SAPLogon session entries).
- The MAPI subsystem and a MAPI-compatible client are installed.

Under Windows 95 and NT 4.0, the MAPI subsystem and Microsoft Windows Messaging (a MAPI-compatible client) come with the operating system. Under Windows NT 3.51, you must have installed the MAPI subsystem and a MAPI-compatible client (for example, Exchange Client for NT) from a separate source before installing the SAP MAPI.

Microsoft Windows Messaging is a version of the Exchange Client with fewer functions. Two noticeable features are missing: A spell-checker and automatic recognition of World Wide Web http addresses. To get these features, you need to install the Exchange Client on top of Microsoft Windows Messaging.
Process Flow

1. Install the SAP MAPI [Page 9]
2. Create profile [Page 10]
3. Setting individual parameters in the profile [Page 13]

When you have installed the SAP MAPI, the error message *Local cache not found* is displayed when you start the MAPI client for the first time. This error is caused by the fact that the local cache can only be created in online mode. You should therefore ignore the error message and logon when the next dialog box appears. The local cache is now created.
Installing the SAP MAPI

The SAP setup program can be found on the SAP Presentation CD-ROM under GUI\WINDOWS\WIN32.

Procedure

1. Execute the SAPsetup program.
2. In setup, only choose Desktop Interfaces. From this choose the SAP MAPI Service Provider again (select Change Options to display the selection).

Result

SAP MAPI is installed. Create your logon profile.
Creating Profiles

To use the SAP MAPI after installation, you must create a MAPI logon profile for the mail client. The profile determines which service providers are used in a logon session. Instead of creating this profile manually as described here, you can use one of the template profiles [Page 12] which are supplied with SAP MAPI.

Procedure

1. Go into the system control (under the Windows NT Start menu).
2. Select the Mail (or Mail and Fax) option from the Control Panel to call the MAPI profile manager.
   When the dialog box <profile name> Properties is displayed, select Profiles on the Services tab page to display the Mail and Fax dialog box. Otherwise, you are there already.
3. Choose Add to call up the new logon profile setup wizard.
   The wizard will present you with two choices:
   - Manual configuration
     a) Select manual configuration and confirm your entries.
     b) Enter a name for your profile and confirm your entry.
     A dialog box for the properties of your new profile is displayed.
     c) Select Add from the "Services" tab page and select the SAP MAPI from the subsequent dialog box. Confirm your selection.
     An R/3 logon dialog box is displayed.
     d) Select the required R/3 System and enter the client, your user name and your password in the subsequent dialog box.
     Confirm your entries.
     e) If you want to edit work items offline with Microsoft Outlook, then see the following steps. If you want to manage other data in the client than that delivered by the R/3 server (for example calendar or contacts), you must create another personal folder in the same way as steps f) and g) as the default message store.

The SAPoffice message store is always supplied with documents or work items from the Workplace, irrespective of what you enter as the default message store. However, by configuring a personal folder, data that is only available in client can be protected from access by SAP MAPI (for example, when deleting the local cache, see Trouble shooting [Page 40]).

f) You must configure a service that supports Outlook forms in the same way as step c). A personal folder is suitable for this. You must enter this personal folder in the tab page transmission. Thus it is the default message store.

g) Choose properties in the tab page Services. Assign a PST file to your personal folder. The most simple method is to use the PST file sapwkf.pst supplied with the SAP MAPI. This file already contains the form for work item display workitem.oft and even the file mpform.cfg for the column display of the work item. You no longer need to carry out the further steps.
Creating Profiles

h) If you want to use a different PST file, you must install files workitem.oft and mpform.cfg afterwards. You must install and publish the form workitem.oft with program wkfpubli.exe. You inform the program of the directory of workitem.oft as well as the name of the profile.

i) Install file mpform.cfg in the Personal Forms Library. In Outlook 97 choose Tools → Options → Custom Forms → Forms → Install, in Outlook 98 Tools → Options → Other → Advanced Options → Custom Forms → Forms → Install.

- Wizard configuration. Your profile automatically contains a personal folder and the personal address book as services. In this case, the objects are stored locally on your hard drive and are not affected by SAP MAPI.

a) Choose Use the following information services and select the SAP MAPI. Confirm your selection.

b) Enter a name for your profile and confirm your entry.

c) Select R/3 Logon

d) Select the required R/3 system and enter the client, your user name and your password in the subsequent dialog box. Confirm your entries.

e) The SAP MAPI setup wizard will lead you through the profile creation process. If you are unsure of some configuration parameters, accept the default values.

f) If you want to edit work items offline with Microsoft Outlook, then see the steps from point f) in the manual configuration.

**Result**

Your profile has been created. You should check the parameters: Also see the section Setting individual parameters in the profile [Page 13]
Creating a Profile Automatically

Use
The program NEWPROF, which is supplied with both Microsoft Outlook and Microsoft Exchange, automates the creation and configuration of a logon profile. This program reads the profile attributes from a PRF file.

Features
Two PRF files are supplied with the SAP MAPI and contain the profile template for the following functions:

- Send and receive mails and manage folders (saptempl.prf)
- Process workflows offline (sapwkf.prf).

Activities
Also see both PRF files.
Setting Individual Parameters in the Profile

1. Go to the Control Panel (under the Windows NT Start menu) and choose Mail (or Mail and Fax) to call the MAPI profile manager.

When the dialog box <profile name> Properties is displayed, select Show Profiles on the Services tab page to display the Mail and Fax dialog box.

2. Select the profile to be maintained and choose Properties.

3. Select SAP MAPI Service Provider and choose Properties.

4. If necessary change the properties:

General properties

- **Password**
  Maintain your R/3 password for the selected system.

- **Language**
  Maintain your logon language.

- **Save Password Enable**
  Select this field if your password should be used by the system at logon. If this field is not selected, you will be required to enter your password every time you log on. The field is not selected as standard.

- **Offline Support Enable** (activate offline support)
  Select this field if you are going to work offline. If this field is selected, the system asks if you want to work online or offline each time you log on. The field is selected as standard.

Message Store Properties

- **Workflow Enable**
  Select this field if you are going to process SAP Business Workflow work items. Otherwise, do not select the field, since workflow support reduces system performance. The field is not selected as standard.

- **Inbox Refresh Interval (Minutes)**
  This field defines the automatic refresh interval for your inbox (to check for new messages). In Slow Link mode the field enters after how many minutes MAPI logs on to the R/3 System again. For further information on the Slow Link mode see Improving performance [Page 38].

  The minimum interval is 10 minutes. The default is 15 minutes.

- **Append Internet Header to Message Body**
  This defines whether the message header of Internet documents received is displayed under the text. If you use Microsoft Outlook, this field can be ignored because the information can be called in a separate display field at any time.

- **R/3 Connection Idle Timeout (hours)**
  The client logs off from the R/3 server after the specified time (in hours). The default value is 4 hours, the maximum value 12 hours. If no entry is made, the system switches to offline mode immediately.
Setting Individual Parameters in the Profile

- **HTML Body Support**
  If the indicator is set, the contents of the HTML documents are stored as a special HTML body. Only select the field for MS Outlook 98! Other clients do not support HTML mail.

- **Install/Update Outlook Forms**
  If you press this key, Outlook forms specially tailored for SAP are used for the message in- and outbox. The forms are installed in the library *personal forms*.

**Address Book Properties**

- **Group Entries by Address Types**
  The addresses are sorted according to their names. If you select this field, the addresses are sorted firstly according to address type and secondly according to names.

- **Maximum No. of Entries Allowed**
  This parameter specifies the maximum number of entries that can be maintained in the Workplace Address Book. Users who routinely communicate with many Workplace users may increase this number. If the Address Book is full, a dialog box is displayed to alert the user on the next insertion attempt. Allow 20 to 40 KB of RAM to increase the capacity of the address book by 100 entries. The default value is 200 entries.

- **Max. Distribution List Downloaded Automatically (No. of Entries)**
  Distribution lists in R/3 can contain a large number entries. To avoid long response times, the system checks the size of a distribution list (number of recipients) before downloading the list from the R/3 System. If the maximum value is exceeded, a dialog box is displayed, asking you to confirm that the distribution list should be downloaded. The field *Distribution List Download Size Limit* specifies this threshold: The default value is 25 entries.

- **Max. Recipient List Downloaded Automatically (No. of Entries)**
  Together with an R/3 message, the recipient list can also be loaded on to the PC. After the threshold entered here (standard: 25) no more recipients are loaded on to the PC in order to save memory space and time.

- **Insertion of Addresses Resolved against R/3**
  New message recipients which have been resolved against Workplace may be inserted in the MAPI Address Book. You have a choice of three modes:
  - **Automatic**: All resolved address strings are inserted without user interaction.
  - **Never**: Resolved address strings are never inserted.
  - **Prompt for User Confirmation**: The system asks the user (via a dialog box) whether or not to insert each resolved address. This is the standard setting.

**Local cache properties**

- **AutoSave Timeout Interval (Minutes)**
  SAP MAPI automatically attempts to save your actions in the *local cache* on the hard disk. This field specifies the point after which a *timeout* is triggered for this attempt. The default is 30 minutes.

- **Increase Cache Size Mode**
  If the maximum cache size is reached, you can set SAP MAPI to respond with the following alternatives:
  - **Automatic**: The maximum cache size is increased by 50%.
  - **Never**: The cache is reduced to 75% of the maximum cache size.
Setting Individual Parameters in the Profile

- **Prompt for User Confirmation**: The system asks you if it should increase the cache. This is the default setting.

- **Cache Size (Bytes)**
  This field defines the local cache size in bytes. The local cache keeps copies of folders and messages to improve performance. The larger the cache size, the better the performance. The minimum cache size is 500K, the default is 50 MB.

- **Cache Location**
  This field specifies the directory in which the local cache is stored. To maintain the directory entry, choose *Browse* and select a new directory. You can only maintain the directory entry if you are NOT logged on to the system which uses this cache.

  To delete the cache, select *Clear Cache*. Only documents and work items which have been downloaded from the R/3 System (and which are therefore still available in the same system) are deleted.

To check the consistency of your cache and to recreate the cache if required, select *Validate Cache*. 
MAPI Clients: Compatibility

SAP MAPI has been tested with Microsoft Windows Messaging, the Exchange client, and Microsoft Outlook. This section summarizes incompatibility issues found with some MAPI clients.

Microsoft Windows Messaging and the Exchange client

- Inserting objects or links as attachments is not yet supported.
  Instead, you should use the file manager to drag and drop files or select Insert → File in Windows Messaging or the Exchange client.

Microsoft Outlook

- Large-scale changes to the SAPoffice Message Store settings can affect logon profiles.
  This causes the program to crash when Outlook is called. In this case, the logon profile must be deleted and a new profile created. Repeat the steps in Creating Logon Profiles [Page 10].
Using SAP MAPI with External Mail Systems

SAP MAPI can also be configured so that an external mail system is used for sending and receiving messages.

When using external mail systems, you should ensure that the external system is configured as the default message store in your logon profile. If this is not the case, you should repeat the steps described in Configuring Logon Profiles [Page 13].

With this setup, you can still:

- Display mails and R/3 reports from SAPoffice
- Change messages and folders in SAPoffice
- Processing Work Items
- Send messages to R/3 and/or external mail server.
Working with SAP MAPI

SAP MAPI does not affect the user interface of the relevant MAPI client. You can continue to work with your mail program in the normal way. You can find the help documentation for the user interface in the documentation for the relevant MAPI client.
Switching Between Online and Offline Modes

Prerequisite
Offline support can be activated in your Logon profile [Page 13].

Procedure
1. Go into a SAP Message Store folder. The SAP Message Store is the folder with the name <SID><CLNT> SAPoffice - <UNAME>, therefore for example C11003 SAPoffice - SMITH for the system C11, client 003, user Smith.
2. Choose Extras → Connect/Disconnect SAP Server.
   If you are in offline mode, a logon box is displayed. If you are in online mode, a window is displayed in which you can choose which R/3 objects are processed offline and therefore should be copied to your PC (download).
3. In offline mode choose Online to change to this mode. In Online mode select the objects that you want to process offline and confirm your entries.
4. After the mail client has carried out the necessary operations, it notifies you of the new mode.
   You can enter and send messages as normal in offline mode. The Send function in client simply places messages in the Outbox.
   To synchronize changes press the F5 key in MS Outlook or choose Tools → Sending and Receiving. Thus, the offline changes are "made" (for example, of work items) in the R/3 System and new mails sent from the Outbox in R/3. Furthermore, newly received mails are displayed in client in R/3.
Sending Mails

1. In the mail client select the SAP MAPI folder or one of your subfolders.
   You identify the folder by the name $<\text{SID}>\times<\text{CLNT}> \text{ SAPoffice} - <\text{UNAME}>$, therefore for example $C11003 \text{ SAPoffice} - \text{SMITH}$ for the user Smith in system C11, client 003.

2. Create a new message. In client MS Outlook, for example, choose File $\rightarrow$ New $\rightarrow$ Mail Message.
   The corresponding form for creating a message is displayed in MS Outlook.

3. You can select the message recipient(s) from the SAP address book as it involves a recipient that already exists in the R/3 System.
   Choose to... in the MS Outlook form and in the next screen of your SAP address book. If you are in online mode, you can also search for recipients via Find in the R/3 System.

   For changeable mails see Hazards in offline processing [Page 39]
Recipient List

Use
The recipient list includes all users and objects who have received the document. If the document was forwarded to a recipient, the forwarder is also listed. In addition, attributes linked to the send operation are displayed.

Send operations to which the attribute BC (Blind Copy) has been assigned are displayed only to the sender and the recipient of the blind copy, not to the other recipients.

The transmission information relating to each recipient can be viewed from the recipient list, including whether or not the document has been viewed.

Procedure
1. Choose a document you have sent and select Display.
2. The recipient list can be displayed by double clicking on a recipient name or on the number of recipients (...recipients).
Address Book

The address book in the SAP MAPI stores addresses which are frequently used. Typical Workplace users communicate with a small subset of other users, usually about 100-200 people. As a result, downloading the entire R/3 user database to the local machine would be a waste of both time and hard drive space. This, however, leaves the problem of how to keep the data on the local PC up-to-date.

For this reason, SAP MAPI constructs a new user-specific address book. This does not mean that users must insert each address individually. Instead, the address book adds recipient addresses while you work with your messages. When creating a new message, users enter the recipient address in the recipient fields To: and Cc: When the message is sent, a search is made for the recipient character string in the local address book. If the recipient is not found, the search is expanded to include the entire R/3 user database.

Users can also configure the address book themselves. For example, users can specify whether each new recipient address should be entered in the address book immediately or whether the entry should first be confirmed via a dialog box.
Inserting Addresses from the Business Workplace

Prerequisites
You are in online mode [Page 19].

Procedure
1. Open the SAP address book (displayed through system ID and client). In MS Outlook, for example, choose Tools → Address book and in the following window Display names: The SAP address book.
2. Select File → New entry.
3. Choose the address type SAPoffice user from the following dialog window.
   Alternatively the following address types are available:
   - Internet address
   - FAX number
   - Organizational unit
   - Remote R/3 address
   - Shared distribution list (must already exist in R/3)
   - Private distribution list (already exists or to be created)
   - External address from R/3 address management
4. Make the required entries and confirm the values.
Finding an Address

1. Open the address book [Page 23].
2. Select Tools → Find
3. Enter a character string when the subsequent dialog box appears (generic searches with * are also possible). Define whether the search is to include only the local MAPI address book or the entire R/3 user database.

   In the case of a generic entry which begins with * and which includes the R/3 user database, the search will take a long time.

4. Confirm your entries.
Deleting Addresses from the Address Book

1. Open the address book [Page 23].

2. Select the entries to be deleted.
   You can use the Control and Shift keys to select multiple addresses or a series of addresses.

3. Select File → Delete
   If you have selected a private distribution list for deletion, a dialog box appears asking whether the private distribution list to be deleted locally should also be deleted from the R/3 System.

4. Confirm your selection.
Selecting Recipients from the Address Book

You can specify multiple recipients for a new message directly from the address book.

Procedure

1. Open the address book [Page 23].
2. Select the required addresses and select File → New message

Result

The relevant form is displayed so that users can enter the message text and the selected addresses have already been entered in the recipient field.
Displaying User Data

Prerequisite
You are in online mode [Page 19].

Procedure
1. Open the address book [Page 23].
2. Select the required entry and choose File → Properties.
   - For Workplace users and external R/3 addresses, two pages are displayed showing user information, for example office phone and fax numbers, office location, and so on.
   - For distribution lists, the information refers to the individual users. From here, users can also add or remove members from a private distribution list.

   Information for address entries can also be called by double-clicking on the address character string in the message header for the displayed message.
Processing Work Items in the MAPI Client

Use

You can process SAP Business Workflow work items from your MAPI client. For general information on work items in the R/3 System, see the Workflow documentation [Ext.]. Work items can be processed online and offline with restrictions.

For offline processing see the section Hazards in offline processing [Page 39]!

Prerequisites

General

You have activated Workflow processing in the MAPI client profile [Page 13]. You must make the appropriate selection in your logon profile [Page 10].

Especially for offline processing

- You can only process work items offline in Microsoft Outlook client.
- You require SAPforms Runtime (available under Development Tools on the presentation CD)
- For Outlook 97 you must ensure that the following exists for the installation:
  - VB Script Runtime 2.0 or above
  - OLE Messages Library 1.0 or Active Messages Library 1.1 or CDO 1.2
- You must have the SAPforms Outlook form workitem.oft installed and published. For more information see create profile [Page 10]

The form workitem.oft is only available in English. The menu entries are therefore only English and are also written that way in what follows. But you can translate the form with the standard methods from MS Outlook.

Features

Functions which are possible offline and online

- Display work items
- Reserve and replace work items
- Forwarding [Page 30] work items
- Change priorities
- Set work items to done
- Append attachments [Page 34] to, or process the work items (SAPoffice documents and business objects).
- Start Workflow
- **Refresh [Page 37]** inbox (folder inbox).
- Work items to the generic decision task and work items which use electronic forms from SAPforms, can also be executed offline. Electronic forms are, for example, Outlook or Visual Basic forms, but not Web (HTML) forms. For more information see the SAPforms documentation [Ext.].
- If you have installed SAPphone, you can also answer calls offline by executing the corresponding work item.

**Functions which are only available in online mode**

- Generally: execute [Page 31] work items.
  - But see the work items above which can also be executed offline.

**Activities**

If you are a selected agent of a work item, it appears on your PC in the inbox list of the MAPI client. It is indicated with a SAP icon. The work item text is displayed as the subject. The "message" text is the task description. You can configure [Page 36] this column display.

Position the cursor on a work item and choose by right-mouse-clicking the menu open (alternatively a double click works if the option open means execute has not been set in the form). The display of an individual work item is then displayed. For further activities see

Forwarding work items [Page 30]
Executing work items [Page 31]
Processing work item attachments [Page 34]
Forwarding Work Items

Prerequisites
For offline work, the prerequisites from the section Work item processing in the MAPI-Client [Page 28] apply.

Procedure
1. By double clicking you go from the post inbox to the work item display.
2. Choose Forward Work Item in the display.
3. Select the address book in which the agents are located. As there are Workplace agents, choose the SAP address book <SID><CLNT>SAP address book - <UNAME> for the required Message Store, for example C11003 SAP address book SMITH of user Smith in system C11, client 003.
   If you do not yet have the corresponding agent in the SAP address book and are working in online mode, you can select the agent via find in the R/3 System.
4. Select the work item agents and choose Agent in order to include them in the list of users.
5. Choose Save and Close.
Executing Work Items

Prerequisites

For offline work, the prerequisites from the section Work item processing in the MAPI Client [Page 28] apply. Also, only specific work items can be executed offline. Also see the part "scope of functions" in the same section.

Procedure

1. By double clicking you go from the post inbox to the work item display.
   
The system can react in two ways:
   
a) If you are working without a form for work item display, the mail form is displayed.
   Choose Display to display your SAPoffice Message Store via the SAP GUI in the R/3 System. The normal R/3 display of a work item is displayed and you can execute it in the normal way. When you leave the display (press F3), the GUI window is closed and the client post inbox is displayed again.

b) If you are working with a form for work item display, this is opened: That is the form based work item display from which you can execute the work item.
   
The further procedure for case b) is analyzed in the following.

2. Choose Execute.
   
The corresponding action of the form is executed. The following cases are possible for the further dialog:
   
a) The work item cannot be executed offline (see "prerequisites"). Then go to where the work item is executed by SAP GUI in the R/3 System. The form is closed. The work item changes its status in the client post inbox. If, however, there is not a connection to the R/3 Server, SAP MAPI displays an error message.

b) The work item can be executed offline (no decision task). A new form is displayed which matches the work item execution (task methods).

c) The tab page Decision is displayed in a work item for the generic decision task and there you choose your decision (alternative).

In the following, case 2a) is disregarded.

3. If the work item must be explicitly ended, another dialog box appears after execution, in which you can explicitly set the work item to done. The form is also then automatically closed and the changes are saved. If you do not want to set the work item to done, you can do this later in the form.

4. If the work item must not be explicitly ended, you are asked after the execution whether you want to save the changes and close the form. If you do not do this, then you can do it later in the form.

   You can deactivate the Save and Close query in Outlook Forms Designer (tab page Options)

5. After Save and Close (selected by you in dialog mode or in the form or implicitly in the decision task) the form is closed and the changes are saved. The work item status in the client post inbox is updated.
6. You can choose the function Edit → Delete in client, in order to temporarily delete a done work item (that is, until the next time the inbox is called up) for a better overview of the post inbox. The work item remains on the R/3 server database.
Special Work Item Form: Initiating Callback

Definition

This form replaces the standard form for work item display for "callback" task work items.

Use

You can directly initiate the callback from Microsoft Outlook via SAPphone: For example, you can select Call back directly from the context menu (right mouse button). In the form itself you can still change the telephone number before (double click on the work item). The telephone system itself is however controlled by SAPphone so you must be in Online Mode [Page 19].

Structure

The form is called Mpphone.fdm (fdm = form descriptor message) and is located in the MAPI subdirectory of the presentation CD (path Gui\Windows\Win32\Sapgui\Mapi). You install it in the personal forms library in the same way as file Mpform.cfg (see Create profile [Page 10], step i. in the manual configuration).

Integration

As the callback involves a specific work item, you must have made SAP MAPI "workflow-compatible". For further information see Work Item Processing in the MAPI Client [Page 28].

You require a corresponding telephone system and must have configured SAPphone. For further information see SAPphone [Ext].
Processing Work Item Attachments

Prerequisites

The only case considered is processing the work item with a form, because if you are working without a form, you go via SAP GUI to the R/3 System and work there as normal.

For offline processing the prerequisites from the section Work item processing in the MAPI client [Page 28] apply.

Procedure

1. By double clicking you go from the post inbox to the work item display.
2. In the display (in the SAPforms display form) choose Edit → Edit Message in order to append or change attachments. Text changes however are not “taken into” the R/3 System.
3. You select an existing attachment by double clicking on it. You make the changes to the attachment in the SAPforms form.
4. You use drag and drop to add a new attachment. Select in client for example a message, hold the mouse button down, and drag it into the message (not in the attachment part!)
Download Options for Work Items

Use
For offline processing you can load work items from the R/3 System to your PC according to specific criteria you have specified. These criteria are the download options.

Prerequisites
The prerequisites from the section Work item processing in the MAPI-Client [Page 28] apply.

Activities
The download options are displayed in a dialog box when switching to the offline mode [Page 19] or also when closing the client. You must set the indicator Download the following...Inbox Workflow Items in order to activate the download options for the work items. Conversely, deactivate the options so as not to load any work items onto your PC.

The following options (among others) are relevant for work items:

- **Download Only Read Workflow Items**
  Only the work items that you have already displayed in client are loaded.

- **Download Only Reserved Workflow Items**
  Only work items that you have reserved are loaded (therefore those that you have already executed). This avoids synchronization errors [Page 39] as you are now the only one who can process the work item.

- **Don’t Download Attachments**
  Attachments are not loaded in order to save memory space or for performance reasons. A second option allows the attachment size in KBytes to be restricted.

You cannot store any of your own default values for the download options. The last setting is proposed to you each time.
Configuring Inbox List Column Display

Use
Different work item attributes can be displayed as columns in the MAPI client inbox. You can sort according to these attributes.

Prerequisites
The file mpforms.cfg must be installed in profile. For more information see create profile [Page 10]

Procedure
1. Call up the field selection in client.
2. Choose the form SAP Work Item List for the field selection. If it is not yet offered, add it to the selection from the folder personal forms and then choose it.
3. From the fields offered, drag those required with the mouse into the header of the inbox list (drag and drop).
   
   The fields are included as new columns. You can for example include the following fields and sort the work items according to them:
   
   - Priority of work item
   - Status (reserved, in process, ...)
   - Overdue
4. Correspondingly, you can drag away unwanted columns from the header with the mouse.
Refreshing Folders Manually

One additional function offered by SAP MAPI is the ability to refresh a folder manually.

Normally, SAP MAPI finds and retrieves new messages via regular queries sent to the R/3 System. The intervals between these automatic updates can be defined from the tab page Message Store in the Profile parameters [Page 13].

Procedure

1. Click on a folder with the root folder of the SAPoffice Message Store (the string <mail system> SAPoffice - <user name> in the folder hierarchy).

2. Choose Extras → Refresh SAP Folder.
Improving Performance

Here are some tips for improving system performance:

- If the R/3 system is slow, you can choose the option *Slow Link* when starting MAPI in Online mode. The following then happens: If you have not entered a command in the MAPI client for five minutes, MAPI logs off from the R/3 system. After the time period that you have entered in the field *inbox refresh interval* [Page 13], it logs on to the R/3 system again, synchronizes changes and reads the inbox again. This cycle is repeated the next time you don't enter a command for five minutes.

- Reduce the number of messages in your inbox by moving messages to your private folders.

- Reduce the number of messages in each private folder by using subfolders to further categorize messages.

- Remove obsolete entries from the SAP address book.

- Avoid substring searches of the form *xxx* or *xxx*, where the search string begins with *. The searches may be successful, but be ready to wait!
Hazards in Offline Processing

As the R/3 server and the MAPI client cannot "speak with one another", they can exclude settings from one another which leads to errors when switching to online mode. Such errors are for example:

- A work item has been reserved or executed both in the R/3 server as well as in the client.
  
  You can avoid this error by only loading work items onto your PC in download options [Page 35] that you have already reserved.

- The work item may not be forwarded to the agent specified by you because the agent does not belong to the possible agents of the corresponding task and the task does not permit any general forwarding.

- An agent to whom you wish to forward the work item no longer exists in the R/3 System.

- A document has been changed or executed both in the R/3 server as well as by you locally in the client. The changes in client are lost when switching to online mode.

  Your local changes are saved in the client trash. From there you can incorporate the modifiable document after the switch to the online mode. Something similar can occur in online mode if a document is changed at the same time in the server and in the client. Also see problem 4 in the section Trouble-Shooting [Page 40].
Trouble-Shooting

**Problem 1:**
Unable to open a subfolder or to copy/move messages into a subfolder?

**Causes:**
1. In most cases, the subfolders or messages do not exist.
2. Occasionally, the local cache files may become corrupted. Although the SAP MAPI contains error-recovery routines, sometimes you may have to manually delete the local cache files.

**Procedure**

**Cause 1:**

**Cause 2:**
1. Select the *Mail* (or *Mail and Fax*) option from the *Control Panel*.

   From the *General* tab page, select your logon profile for the SAP MAPI and choose *Properties*.

2. Select SAP MAPI from the Services tab page and choose *Properties*.
3. Open the *Local Cache* tab page from the *Configuration* dialog box.
4. Select *Clear Cache* and *Apply*.

   Confirm your entries.
5. Confirm the subsequent dialog box.

**Problem 2:**

You cannot log on, although the server is running.

**Cause:** It is possible that the architecture of the SAP MAPI has changed so much between two releases that the existing logon profiles can no longer be used.

**Procedure**

Select the *Mail* (or *Mail and Fax*) option from the *Control Panel*.

When the dialog box `<profile name> Properties` is displayed, select *Show Profiles* on the Services tab page to display the *Mail* (or *mail and fax*) tab page.

1. Delete all profiles using the *Delete* function.
2. Create new logon profiles [Page 10].
Problem 3:
Unable to send successfully.

Procedure
Check the SAPoffice message store and address book settings [Page 13].

Problem 4:
After the last synchronization, a modifiable document has been changed in both the server and by the client. You therefore cannot save the document in the client. Further changes in the server will not be made in the client.

Procedure
Send the document from the server to the corresponding client. The document appears in the post inbox. From there, you incorporate the changes in the document in the client. Then save the original modifiable document.