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  Getting Started with the SAPscript Editor 

Getting Started with the SAPscript Editor 
SAPscript is the integrated text management system of the SAP R/3 System. You will find that it 
looks and feels a lot like other leading word-processing systems that you may use on your 
personal computer. 
SAPscript is tightly integrated into the SAP System. You will therefore be using it for many 
different word-processing tasks all over the SAP System. 
This section explains how to start SAPscript and how to enter and format text. Only the basics of 
word-processing and formatting are covered here. For help with more advanced tasks, see 
Editing Documents [Extern] and Previewing and Printing SAPscript Documents [Seite 16]. 

 
If your frontend operates under the 32bit platform Windows 95 or Windows NT 4.0, 
you can use the SAPscript PC editor. This WYSIWYG editor offers the common 
mouse functions (drag & drop, cut & paste). In addition, you can execute the most 
important functions via pushbuttons (paragraph and character formats).  

SAPscript Line Editor 
Starting SAPscript [Extern]  
The SAPscript Text-Entry Screen [Extern] 
Creating and Changing Documents [Seite 8] 
Entering and Formatting Text [Seite 42] 
Saving a Document [Seite 10] 
Deleting a Document [Seite 11]  
 
 
SAPscript PC Editor (32bit Version) 
The PC Editor [Seite 17]  
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Creating and Changing Documents 
Use 
If the R/3 system does not automatically call the editor, you can also create and edit a document 
manually. 

Procedure 
1. Choose Tools → SAPscript → Standard text. 

The dialog window Standard text: Request appears. 
2. Enter the following: 

 

Field Enter 

Name The name of the document. 
You can use letters, numbers, spaces, and any special characters other than * 
(asterisk) and, (comma) in names.  
Example:  Report on Dayton Project 

Text ID Identifies the application to which the document belongs.   
Leave the ID set to the default value ST for standard text. Standard texts are 
documents that are not specific to any SAP application, or system texts. The SAP 
applications have their own text ID’s for application-specific documents. 

Language The language under which your document should be stored in the SAP System. 
For example, the system can contain English (E) and German (D) versions of a 
document. The language key is important only if your document is to be translated. 
Otherwise, you can leave it set to the default value, the language in which you are 
logged on. 

 
1. To create a new document, choose Standard text → Create 
2. To edit an existing document, choose Standard text → Change 

Result 
You are now in the editor and can type in text, edit it, save it, and so on. 
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Finding Documents 
1. Choose Tools → SAPscript → Standard text. 

The dialog window Standard text: Request appears. 
2. Choose Standard text → Find.   

The dialog window for finding standard texts appears.  
3. Use the floowing search criteria and wildcards: 

Search criteria 

Field Note 

Text Text name 

Text ID  

Language This is a required input field. 

Short title See also: Entering a Short Title [Seite 15] 

Author  

Creation date  

Creation release  

Last person who changed the document  

Change date  

Change release  

Wildcards 

Character Note 

+ Placeholder for any single character in the search string.  

Example: If you enter the search string m++er in the Author field, the result 
includes any five-letter names that start with M and end with ER.  Search result:  
Mayer, Meier, Moier, and so on. 

* Generic placeholder for one or more characters in a search string. 
Examples: If you enter the search string m*r in the Author field, the search result 
contains any names beginning with M and ending with R.  Result:  Mor, Moor, 
Meier, and so on.   

If you enter the search string me*, the search result contains any names beginning 
with ME. 

4. Choose Execute. 
A list of the selected documents appears. 

 
If you do not make any other specifications except for the language (for example, 
"D"), the system searches for all text names. 
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Saving a Document 
Use 
Saving a document stores the document in the SAP database, overwriting any previously existing 
version.   

Procedure 
In the editor, choose Text → Save. 

 
Documents are not automatically saved. Therefore, it is a good idea to save a long 
document periodically. If you log off the SAP System before saving a SAPscript 
document, the document is also lost.   

 
You can also save several different versions of a document. Choose Text → Save as 
and enter the text name, the text ID, and the language. 
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  Deleting Documents 

Deleting Documents 
Procedure 

1. Choose Tools → SAPscript → Standard text. 
The dialog window Standard text: Request appears. 

2. Enter the name of the document you want to delete and choose Standard text → 
Change. 

3. Choose Text → Delete. 
4. Choose Back. 

Result 
The document has been deleted. 

 
A deleted document cannot be restored! 
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Paragraph Formats 
Definition 
You use a paragraph format to lay out the paragraphs of the text entered in the editor. 

Use 
In the SAPscript editors, you can assign a paragraph format to each paragraph. 
However, you define the attributes of the paragraph formats in the form and style. After the 
definition, you can assign the corresponding style or form to a standard text. If you do not choose 
a form or style explicitly, the R/3 system assigned the default form SYSTEM. For more 
information, see the documentation Style and Form Maintenance.. 

Structure 
You use a paragraph format to determine 

• the font, the font size, and the font style 
• the outline attributes of the paragraphs 
• the tabs within the paragraph 

Integration 
If you want to format only a character string, but no entire paragraph, use the appropriate 
character format. 
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  Character Formats 

Character Formats 
Definition 
You use character formats to lay out character strings within a text. 

Use 
In the SAPscript editors, you can assign character formats to character strings. 
However, you define the attributes of the character formats in the form and style.. For more 
information, see the documentation Style and Form Maintenance.. 

Structure 
You use a character format to determine 

• the font and the font size 
• special attributes of characters, such as superscript or subscript 

Integration 
If you want to format an entire paragraph, use the appropriate paragraph format. 
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Inserting Special Characters  
Use 
You can insert non-typable characters into your document. All characters defined in the character 
set the R/3 system is using are available to you.   

Procedure 
1. Choose Insert  → Character. 
2. Position the cursor on the desired character and choose Choose. 
3. Choose Continue. 

 
If your R/3 system is using the standard Western European character set (SAP ID 
number 1100), then you can insert the currency symbol for the Japanese Yen into 
your document even if it is not available from your keyboard.   
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  Entering a Short Title 

Entering a Short Title 
Use 
You can enter a short title for a document, which you can later use to find the document 

Procedure 
1. Choose Tools → SAPscript → Standard text. 

The dialog window Standard text: Request appears. 
2. Choose Standard text → Find. 
3. Enter the corresponding short titlr and choose Continue. 

For more information on the search procedure, see Finding Documents [Seite 9]. 
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Previewing and Printing Documents 

Previewing 
Use 
You can display a SAPscript document in formatted form on the screen while you are editing it.  
In the print preview, you can check line feeds and page breaks and. If necessary, correct them 
before printing the document 

Prerequisites 
The text is formatted according to the form and style selected. Includes and symbols are 
replaced in the preview, and hypertext links are also activated.   

Procedure 
Choose Text → Print preview. 

Printing Documents 
Procedure 

1. Choose Text → Print. 
The dialog window Print: General Standard Text <text name> appears. 

2. Enter the name of the printer to which you want to send the text and the number of 
copies.  

3. In the field Page selection determine the pages you want to print. The parameters n and 
m symbolize the page numbers you select.  

Page selection Output 

No value Entire text 

N Page n 

n,m Pages n and m 

n-m Pages n to m 

n- From page n to end of text

-m From 1st page to page m 

4. Choose Print.  
The print command is confirmed by a message.  

 
You can also choose a fax machine as output device. 
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The PC Editor 
Use 
You use the PC editor to create and edit texts. These texts you can then print using forms (for 
example, form letters) or use for creating documents in the R/3 system (for example, orders and 
material texts). 

Integration 
The PC editor is entirely downward compatible. You can easily use any texts created with the line 
editor. The system converts the assigned styles and formats appropriately and provides them as 
before. 

Prerequisites 
Platform 
On your frontend, either WindowsNT 4.0 or Windows95 must be installed as 32-bit operating 
system. At present, other platforms are not supported. 

Control Files 
You need several *.DLL and *.OCX files. When you upload these *.DLL and *.OCX files, the SAP 
GUI automatically installs this required component. 
In a dialog window, you can determine whether to automatically update this component. 

Functionality 
You can edit texts in the PC editor as you would edit documents in any current word processing 
system. 
Among others, the PC editor provides the following functions: 

• Cutting and pasting texts 
• Directly assigning paragraph and character formats via pushbuttons in the application 

toolbar 
• Displaying all applied paragraph and character formats WYSIWYG, for example, bold 

face, justified text, different font sizes 
• Inserting special text structures (text elements, symbols, and commands) 
• Integrated syntax check for the inserted commands to avoid input errors 

Activities 
The R/3 system automatically calls the PC editor in the corresponding application. 
To switch to the line editor, in the PC editor choose Settings → Editor mode. 
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Editing Text 
To edit texts, proceed as follows 

Function Procedure 

Mark text  Keep the left mouse button pressen and drag the mouse over the 
text you want to mark. 

Cut text Mark the text. Choose Edit → Selected area → Cut. 

Copy text Mark the text. Choose Edit → Selected area → Copy. 

Insert (paste) text Choose Edit → Paste. 

Display paragraph tags Choose Format → Paragraph on/off. 

Create new paragraph Choose Continue. 

Assign paragraph format Position the cursor on the desired paragraph. Choose Format → 
Paragraph. Position the cursor on the number of the paragraph 
format and choose Continue. The paragraph format you select 
overwrites the previously assigned format. 

Set tab Set the tab positions with the tab key of your keyboard. The 
positions depend on the definitions in the assigned style or form. 
They are at once visible. 

Soft carriage return Choose Shift+Continue. 

Assign character format Mark the desired character string. Choose Format → 
Character..Position the cursor on the number of the character format 
and choose Continue. The character format you select enhances the 
previously assigned format. 

Reset character formats The system resets all character formats. Mark the formatted 
character string. Choose Edit → Reset character formats.  
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Including Texts 
Use 
You can include standard texts, texts of the online documentation, and hypertext modules into 
your document. You can include texts directly and by reference. 
When including text directly, the text is inserted in the editor in formatted form. You can then edit 
it further. 
To include a text by reference, use the INCLUDE statement. The system does not display the 
text in the editor. Only if you print or preview the text, does the system include the most up-to-
date version of the text. 

Procedure 
Including Standard Text  

1. Choose Include → Text → Standard. 
The dialog window for including text appears. 

2. Enter the text name, the text ID, and the language. To include the text directly, select 
Expand immediately. 

3. Choose Continue. 

Including Online Documentation 
1. Choose Include → Text → Documentation. 

The dialog window for including text appears. 
2. Enter the text name, the text ID, and the language. To include the text directly, select 

Expand immediately. 
3. Choose Continue. 

Including Hypertext Modules 
1. Choose Include → Text → Hypertext. 

The dialog window for including text appears. 
2. Enter the text name, the text ID, and the language. To include the text directly, select 

Expand immediately. 
3. Choose Continue. 

Expanding Text Included by Reference 
1. Select the INCLUDE command line. 
2. Choose Edit → Selected area → Expand INCLUDE. 

The system includes the text directly. 

 
After expanding the text, the reference no longer exists. 
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Including Symbols 
Use 
You can use symbols to insert program and system data as well as existing texts into your 
document. 
SAPscript supports four types of symbols: 

• Text symbols 
• Program symbols 
• Standard symbols 
• System symbols 

Integration 
To include and change symbols, you can also use the function Insert command. If you know the 
symbol names, you can enter them directly in the dialog window Create additional information. 

Functionality 
Text Symbols 
You define text symbols locally in your document. 
You use text symbols to define recurring terms or text fragments in your document. In the 
document, you then use the defined symbol to insert the terms or text fragments at the desired 
places. 

Program Symbols 
The values of program symbols come from the tables of programs. 
You use either the print program needed to provide the data for the SAPscript document to be 
printed or data defined globally in programs. The tables must exist in the ABAP Dictionary. 

Standard Symbols 
The standard symbols are maintained in the SAPscript table TTDTG; they are globally available 
to all SAPscript documents. 
Standard symbols are language-dependent. The form processor replaces the symbol in the 
language you chose for the document. If the symbol does not exist in this language, the system 
does not print the symbols. 

 
The symbol &SGDH& contains the text "Dear Madam and Sir". 

System Symbols 
System symbols come from global system variables. 

List of system symbols 

System symbol Description 

DATE Current date 

DAY Day of current date 

DEVICE Ourput device: PRINTER, SCREEN, TELEX, FAX 

20  April 2001 



 SAP AG BC - Word-Processing in the SAPscript Editor 
  Including Symbols 

HOURS Hours of current time 

MINUTES Minutes of current time 

MONTH Month of current date 

NAME_OF_MONTH Name of the month of current date 

NEXTPAGE Number of the next page 

PAGE Page number of a SAPscript text 

SECONDS Seconds of current time 

SPACE Blank character 

TIME Current time 

ULINE Underscore 

VLINE Vertical line 

YEAR Year of current date 

 

Activities 
You can insert the symbols anywhere in the text. When printing or displaying the print preview of 
the document, the form processor replaces the symbol name with the current symbol value. 
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Inserting Text Symbols 
Procedure 
Inserting a Text Symbol 

1. Choose Insert → Symbols → Text. 
2. Place the cursor on the desired text symbol. 
3. Choose Choose. 
4. The system inserts the text symbol. 

Editing the Value of a Text Symbol 
1. Choose Insert → Symbols → Text. 
2. Choose Edit value bearbeiten. 

The dialog window Value definition for symbol <text symbol> appears. 
3. Enter the appropriate value definition. 
4. Choose Continue. 

In the dialog window Text symbols the specified value appears after the name of the text 
symbol. 

5. Choose Continue. 

Deleting all Text Symbol Values 
1. Choose Insert → Symbols → Text. 
2. Choose Delete all values. 

The system deletes all defined values. 
3. Choose Continue. 

Using Formatting Options for Text Symbols 
1. Choose Insert → Symbols → Text. 
2. Choose Options. 

The dialog window Formatting options for <text symbol> appears. 
3. Fill in the fields. 
4. Choose Continue. 
5. Choose Continue. 

The system executes the selected formatting option. 
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Inserting Program Symbols 
Choose Insert → Symbols → Program symbols. 

1. If no program is selected, choose Append print program. 
The dialog window Append print program to form appears. 
Enter the desired print program. 
Choose Copy. 

2. Select a print program. 
3. Choose DDIC fields or Global data. 

A list of the fields appears. 
4. Select the desired field. 
5. Choose Continue. 

The system inserts the program symbol. 
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Inserting Standard Symbols 
1. Choose Insert → Symbols → Standard. 

The dialog window Standard Symbols in Language <language> appears. 
2. Select the desired standard symbol. 
3. If you want to use the formatting options for standard symbols, choose Options. Fill in the 

respective fields and choose Continue. 
4. Choose Choose. 

The system inserts the standard symbol. 
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Inserting System Symbols 
1. Choose Insert → Symbols → System. 

The dialog window System Symbols: Tables appears. 
2. Select the desired table. 
3. Choose Choose. 

The dialog window System Symbols: Fields from <table> appears. 
4. Select the desired field. 
5. If you want to use the formatting options for system symbols, choose Options. Fill in the 

fields and choose Continue. 
6. Choose Choose. 

The system inserts the field. 
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Starting the PC Editor Manually 
Procedure 

1. Choose Tools → SAPscript → Standard text. 
The dialog window Standard text: Requests appears. 

2. Choose Settings → PC editor.  
The dialog window SAPscript-Editor: Settings appear. If the line editor is marked, unmark 
it. 

3. Choose Continue. 
4. Enter a text name. Choose Standard text → Create. 

Result 
The PC editor starts. 
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Creating Additional Information 
Use 
Additional information consists of symbols, control commands, text elements, comments, SAP 
characters and links. The PC editor displays them in a different color and read-only. 

Procedure 
Creating Additional Information 

1. Choose Edit → Insert command. 
The dialog window Create additional information appears. 

2. Select the desired additional information. 
• Symbols 

Enter the symbol name of a text symbol, a program symbol, a standard symbol, or a 
system symbol in the form &symbolname&. 
For more information, see Including Symbols [Seite 20] and SAPscript Symbols 
[Extern]. 

• Command 
Enter the command name in the form &commandname&. 
For more information, see SAPscript Control Statements [Extern]. 

• Text element 
Enter the name of the text element. 
For more information, see Text Elements [Extern]. 

• Comment 
Enter the desired comment. 

• SAP character 
Enter the number of the SAP character. 

• Link 
Enter the character format, the key, and the text of the link. 

3. Choose Continue. 
The system includes the additional information in the PC editor. 

Changing Additional Information 
1. Double-click on the additional information in the PC editor to select it. 
2. Choose Edit → Change command. 

The dialog window Change additional information appears. 
3. Change the additional information. 
4. Choose Continue. 

Deleting Additional Information 
1. Double-click on the additional information in the PC editor to select it. 
2. Choose Edit → Delete command. 

The additional information is deleted. 
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Using Clipboards 
You can use four types of clipboards for cutting and copying text. 

The SAPscript Clipboard 
Use 
Use the SAPscript clipboard for copying text within or between SAPscript documents. 

Prerequisites 
You can use the SAPscript clipboard only within one R/3 system and one client. 

Procedure 
1. To mark the text, choose Edit →  Select.   
2. To copy to and from the clipboard, choose Edit → Selected area → Copy or Edit → 

Selected area → Cut, and Edit → Paste. 

SAPscript User Clipboards 
Use 
Use the SAPscript user clipboards to copy “permanent” text areas. The "permanent text" is kept 
in the clipboard until you overwrite it, even if you log off or restart the R/3 system.   

Prerequisites 
You can use the SAPscript user clipboards only within one R/3 system and one client. 

Procedure 
1. Choose Edit → Select to mark the text.  
2. Choose Edit → Selected area → Copy to user clipboard 
3. Select one of the five available clipboards.  
4. To insert the text, choose Insert → Clipboard → User clipboard and select the 

appropriate clipboard. 

 
You can edit the contents of the SAPscript user clipboards. Choose Goto → User 
clipboard to open a normal SAPscript text entry session for the contents of one of the 
clipboards. 

ABAP Editor Clipboards 
Use 
You use the ABAP editor clipboards for copying blocks of text from the ABAP editor to the line 
editor. 

Prerequisites 
You can use the clipboards of the ABAP editor only in one R/3 system and one client. 

Procedure 
1. To mark text in the ABAP editor, use the line commands XX, YY, or ZZ. 
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Each command writes to a different clipboard. It must be used in pairs, for example, XX 
<text to mark> XX.   

2. To insert the text in the line editor, choose Insert → Clipboard → Line editor. 
3. Select the appropriate clipboard.   

PC or Workstation Clipboard 
Use 
Use the PC or workstation clipboard for copying text  

• Between SAPscript documents when you cannot use a SAPscript clipboard. 
• Between SAPscript and other programs running at your PC or workstation. 
• From SAPscript to the ABAP editor (small blocks of text only).   

Prerequisites 
If you want to copy texts from external programs into SAPscript, you may have to do it line by 
line. Text areas that exceed one line are not inserted correctly in SAPscript. However, from ASCII 
editors such as Microsoft Notepad, these text areas are inserted correctly. 
If you copy a text area from an external program into SAPscript, paragraph and character formats 
are not included. 

Procedure 
1. Mark the text by dragging the cursor. 

In a Microsoft Windows PC, switch to select mode first by pressing CTRL and Y.   
2. Choose CTRL C (Copy) or CTRL X (Cut) to copy from SAPscript to the clipboard.   
3. Paste the clipboard contents into SAPscript with Insert  → Clipboard  → Clipboard (or 

use the hot key CTRL-V for Paste). 
The paragraph formatting in a SAPscript text is correctly copied into the new SAPscript 
window. Blocks of SAPscript text or editor text that extend beyond the end of the 
SAPscript screen are correctly inserted too. 
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Finding and Replacing 

Finding and Replacing 
Use 
You can find and replace words and character strings in the PC editor. 

Prerequisites 
This function affects the text located between the cursor position and the beginning or end of the 
text, depending on the search direction you choose. 

Procedure 
Finding Text 

1. Choose Edit → Find. 
2. Enter the desired search term and select the appropriate options. 
3. Choose Find. 

If the search term exists in the text, the system positions the curson on it. 

Finding and Replacing Text 
1. Choose Edit → Replace. 
2. Enter the search term and the replacement term and select the desired options. 
3. Choose Replace all. 

If the search term exists in the text, the system replaces it throughout the text by the 
replacement term. 

4. Choose Replace. Select the desired option. 

Deleting Words and Character Strings Using a Search Term 
1. Choose Edit → Replace. 
2. Enter the search term and select the appropriate options. 
3. Choose Replace all. 

The system deletes the search term throughout the text. 
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Setting a Page Break Manually 
Use 
If you insert a page break, the page layout of the new page is determined by the form, which may 
contain several different page layouts. Enter the name of the desired page layout after the NEW-
PAGE statement. Choose Format → Page to display a page layouts available. 

Procedure 
1. Choose Edit → Insert command. 

The dialog box for entering additional information appears. 
2. Enter NEW-PAGE or NEW-PAGE <page layout>. 
3. Choose Continue. 

 
The form you use for your document defines a page layout called NEW-SECTION. 
The following command then starts a new page in your document. The page is laid 
out according to the design specified in the form under NEW-SECTION.   
NEW-PAGE NEW-SECTION 

For more information, see Explicit Page Break: NEW-PAGE [Extern]. 
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Numbering and Marking Headings and Paragraphs 
Use 
You can number the headings and other paragraph types in your text or mark them in another 
way. You can create a numerical hierarchy of your paragraphs and, for example, categorize your 
headings as level 1, 2, and 3 and number them as follows: 1; 1.1; 1.1.1; 1.2 and so on. 

Functionality 
You have these outline options: 

• Letters 
• Digits 
• Fixed characters, such as *, o, =, -, and so on. 

Digits can be Roman or Arabic; letters can be uppercase or lowercase. 
You determine the outline options for a certain paragraph format. SAPscript then automatically 
numbers the paragraphs consecutively or inserts the set fixed characters in front of the 
paragraphs. 
Fixed characters can consist of several characters and contain right or left delimiters. When 
chaining several numbered paragraphs (for example of different levels), SAPscript uses a period 
to separate the paragraph level numbers. 

 
Delimiter: a) - (a) - a. … 
Chaining: 1.1 - 1.1.1 - 1.2 - 1.2.1... 

The outline functions in the PC editor are displayed only in print preview or when actually 
printing. 

Activities 
Resetting the Numbering 

1. Choose Edit → Insert command. 
The dialog window for inserting additional information appears. 

2. Enter the statement RESET <paragraph format>. 
3. Choose Continue. 

For more information, see Resetting Paragraph Numbering [Extern]. 
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Tabs and Tables 
Setting Tabs 
Define the tab positions within a paragraph in the paragraph format definition in the style or form 
you are using. If the paragraph format does not define any tabs, then the tab positions defined in 
the dialog box Change form header under Basic settings are used. 

Creating Tables 
1. Select one of the predefined paragraph formats for tables, if available, in your style or 

form.   
Since tables in SAPscript are laid out using tabs, a paragraph format for a table usually 
defines the correct tab settings for the table.  

2. Enter and format the table header. (Your style or form may provide a special paragraph 
format for the header, which already includes any special formatting.) 

3. Enter and format the text for the table columns. You must ensure that the text for each 
column fits into the column. Enter one or more tabs to separate the text of one column 
from that of the next. Use the tab key on your keyboard. 

4. Choose Text → Print Preview to check whether you have correctly laid out the text for 
the table.   
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The Line Editor 
Use 
You use the line editor to create and edit texts. You need these texts when printing forms (for 
example, form letters) or when creating documents in the R/3 system (for example, orders and 
meterial texts). 

Integration 
You can easily use texts created with the PC editor. The system converts the assigned formats 
and styles appropriately and provides them as before. 

Activities 
To switch to the PC editor, choose Goto  → Editor mode. 
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Line Editor Screen  
Below you see the text-entry screen of the SAPscript line editor. The most important areas are: 

• The format column, at the left of the editing area. 
In this column, you can specify paragraph formats and activate special types of 
formatting, such as interpretating SAPscript commands.   

• Input lines for entering your text.  
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Title Bar  
The title bar contains the following information on the current document: 

• Mode: 
– Display 
– Change 
– Select. 

Select appears when you select a block of text. For more information, see Marking 
Text [Seite 47].   

• Name of the document, in this example JH_TEST_01. 
• Language in which the document is stored, in this example DE.  
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Ruler 
The ruler shows the number of characters you have typed in. The standard line length in the line 
editor is 72 characters. 
If you encounter “long lines” in the line editor, you can shift the display to the left and right to edit 
the lines. The ruler then helps to remind you whether you are in the left half of a line (1-72) or in 
the right half (number higher than 72).   
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Format Tag Column  
In the format tag column, enter paragraph formatting tags and formatting commands. The 
paragraph formatting tag determines how a paragraph is displayed or printed. You use formatting 
commands to enter command and comment lines. For a list of all formatting tags and commands 
available, choose the Possible entries pushbutton. 

 
The text shown in the line editor is formatted as “A” paragraph, which is the standard 
paragraph format of the S_OFFICE style. An * asterisk marks the standard 
paragraph in a style or form. 
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Text Entry Area  
Type your text into the text entry lines. You can type continuously: SAPscript fills your text using 
a line length of 72 characters as soon as you choose ENTER or a function. 
To enter text in the line editor continuously, the checkbox Automatic tab at field end must be 
marked. For more information on setting automatic tabbing, see Setting Automatic Tabbing 
[Extern] and Entering Text [Seite 43]. 
Note that the line editor’s text filling has no influence on the final appearance of the text. Your text 
is formatted no earlier than at the time it is displayed or printed. For more information, see 
Previewing and Printing SAPscript Documents [Seite 16].  
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SAPscript Status Line 
The status line shows information about the document: 

• The style selected for the document, if any. In the example screen, the style is 
S_OFFICE. 

• The form selected for the document. In the example screen, the form is SYSTEM, the 
default form.   

• The numbers of the lines of text that you currently see on the screen followed by the total 
number of lines of text in the document. In the example screen, the first line is displayed 
(Lines 1 - 1) and the document length is 1 line (/1).   

If you select a block of text, then the status line shows the start and end of the selected block 
instead of the style and form. The status line also shows the most recently used paragraph and 
character formats.   
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Entering and Formatting Text 
Use 
Entering and formatting text in the line editor is different from WYSIWYG word-processing 
programs on a PC. The main difference is that the text you enter in the line editor is not in its final 
format. Instead, formatting is applied to a text only when a document is printed, print-previewed, 
or displayed.  
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Entering Text 
Prerequisites 
If the cursor sticks at the end of a line instead of jumping to the next line  

1. Click the SAPGUI options symbol at the upper right corner of your SAP screen and 
choose Options.   

2. In the Cursor table, mark Automatic tab at field end.   

Procedure 
Enter your text continuously into the text lines of the line editor. At the end of a line, the cursor 
automatically jumps to the beginning of the next line. 
If you press ENTER, or control returns to SAPscript for another reason, SAPscript fills the text in 
lines that fit the width of the editing screen. It automatically rejoins words that were broken by the 
line feed.   
Do not worry if the line feeds that SAPscript inserts are not where you want them to.  The final 
text-filling and line-feeding takes place only when you print or display the text. 
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Inserting Text 
Prerequisites 
To toggle in the line editor between overwrite and insert mode, use the Insert key on your 
keyboard. In insert mode, you can type text anywhere into your document.  
In the line editor, however, you can insert text by directly typing it in only up to the end of the 
current line in the text entry area.   
To insert more text than will fit in the current line, you can switch the line editor into a special 
insertion mode. In this insertion mode, you can type text into your document just as in normal text 
entry mode (for more information, see Entering Text [Seite 43]). 

Procedure 
1. Position the cursor at the place where you want to insert text. 
2. Start the special insertion mode by choosing Insert. 

SAPscript opens several new lines at the cursor position for inserting your text.  The end 
of the insertion window is shown by two periods in the format tag column.  

3. Enter the new text. 
If you run out of space while entering your new text, choose Format. SAPscript fills the 
text that you have entered and opens up additional lines for inserting more text.  
SAPscript also adds more insert lines if you create a new paragraph in the inserted text 
with the ENTER key.   

4. End the insertion procedure with End insertion, Back, or Cancel. 
SAPscript deletes any unused insert lines, removes the two periods from the format tag 
column, and leaves the cursor at the end of the newly inserted text. 
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Formatting Text 
Prerequisites 
Styles and Forms: SAPscript contains a basic set of “built-in” paragraph and character formats 
in the default form SYSTEM. If you use SYSTEM, you can always use the Block, Centered, and 
Left-justified paragraph formats.   
A style contains a larger set of paragraph and character formats, from which you can choose. A 
form contains the “page design” for your document (letter, check, invoice, and so on). A form may 
contain character and paragraph formats, as well.  
If SAPscript was started for you automatically, the correct style and form for the document you 
are working on has probably already been selected.  
If you started SAPscript yourself, then you should pick out the style that you want to use. Leave 
the default form SYSTEM unchanged. 
For more information, see Styles and Forms [Seite 84]. 

Procedure 
Formatting Paragraphs 

1. Enter the paragraph formatting tag into the format tag column. 
For a list of available formats choose Format → Paragraph. The format you choose 
applies to the entire paragraph, no matter where the cursor is positioned in the 
paragraph.  
An asterisk * in the format column shows that a paragraph is to be formatted with 
whatever the default paragraph format is. The default format is specified in the style or 
form assigned to your document.  

Formatting Characters 
To format one or more characters, enclose the characters in character formatting tags: 

1. Mark the character(s) that you want to format. If you want to format an entire word, just 
put the cursor in the word. You do not need to mark the word. 
You can apply a continuous character format only within a single paragraph. To format a 
character string that crosses to another paragraph, apply the character format separately 
to each part of the string. 
For more information, see Marking Text [Seite 47]. 

2. To get a list of the available formats, choose Format → Character.   
3. In the dialog window, double-click on the desired character format.   

SAPscript enters the “<>“ tags for the format around the text you marked. If you have not 
marked any text, the tags are inserted into the text at the cursor position. You can then 
type the text that is to be formatted within the format start <nn> and format end </> tags.  
You can enclose as many characters as you want in character tags, even several lines of 
one paragraph. 
Your character formatting overrides any character formatting applied by the paragraph 
formats. 

 
<K>Cursive text</> tells SAPscript to format the phrase like this:  Cursive text. 
(In online display, the text may instead be highlighted with a different color or 
intensity.) 
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Marking Text 
Prerequisites 
You must mark text before you can carry out operations like Cut or Copy. 

Procedure 
Marking text 

1. Position the cursor before the first character of the block of text.  
2. Choose Select or double click with the cursor.  
3. Position the cursor before the last character of the block of text.  
4. Choose Select or do a double click again.  

The lines that contain the marked text are highlighted and can now be processed further.  
You can see the beginning and ending of the marked text in the status line at the bottom of the 
screen. 

Marking a Word 
To mark a word, put the cursor anywhere in the word and either click twice or choose Select.  

Marking a Line 
To mark exactly one line, position the cursor in the format tag column before the line in question. 
Choose Select once. 

Marking a Paragraph 
To mark a complete paragraph, position the cursor in the format tag column of the paragraph in 
question.  Double click on the format twice or double click on Select.  

Marking an Entire Document 
To mark all of a document, position the cursor in the format tag column and click three times on 
Select. 

Extending a Selection 
To add more text to a marked block, put the cursor outside the block at the required position and 
choose Select.  

Reducing a Selection 
To shorten a marked block, put the cursor within the block at the required position and choose 
Select. You can shorten a marked block only from the end of the block. 

Undoing a Selection 
Choose Cancel or Back. 

Marking Text for the PC or Workstation Clipboard 
For operations using the PC or workstation clipboard, mark text with the mouse.   
Under UNIX, 

1. Hold down the left mouse button. 
2. Pull the mouse to mark an area. 
3. Cut and paste the marked text using the workstation hot keys. 

Under Microsoft Windows, 
1. Press CTRL-Y to switch the SAP frontend software into select mode.  
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2. Hold down the left mouse button. 
3. Pull the mouse to mark an area. 
4. Cut and paste the marked text using the Windows hot keys: CTRL C for Copy; CTRL X 

for Cut; CTRL V for Paste. 
 
 
 

48  April 2001 



 SAP AG BC - Word-Processing in the SAPscript Editor 
  Cutting, Copying, and Pasting Text 

Cutting, Copying, and Pasting Text 
You can rearrange text in your documents by cutting, copying and pasting it: After marking the 
text, buttons for all three functions appear on the SAPscript text-entry screen. You can also reach 
these functions by choosing Edit.  

• Cut. Cutting removes a marked block of text from your document and copies it to a 
clipboard.   

• Copy. Copying copies a marked block of text to a clipboard.  
• Paste. Pasting inserts text from a clipboard in your document at the cursor position. 

For information on the clipboards available to SAPscript, see Using Clipboards [Seite 54]. For 
information on marking text, see Marking Text [Seite 47]. 
You can always retrieve the block of text last stored in the clipboard and  

• Insert it into the document at another position.  
• Insert it into the document at several positions.  
• Insert it into one or more documents.  

 
• Only one clipboard is available for each user per client.  
• You can reinsert a block of text accidentally cut from your document as long 

as it has not been overwritten in the clipboard.  
• You cannot retrieve text you deleted using the backspace key, the delete key 

(DEL), or the SAPscript Delete function key.  
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Deleting Text 
Prerequisites 
As in most other word-processing programs, you can delete text in the line editor with the 
backspace and delete keys. This topic describes additional delete functions offered by SAPscript.  

Procedure  
Deleting Extra Blanks 
If your document contains sequences of more than one blank space, you can delete the 
superfluous blank spaces with the Compress command. 

1. Mark the text from which you want to remove superfluous blanks.  
2. Choose  Edit → Selected area → Compress.  

All strings of consecutive blank spaces are compressed into a single space.  

 
Compress does not observe the American formatting rule that two spaces should 
follow a period ending a sentence. If you compress text that includes sentence ends, 
then you will need to re-insert the second space at the end of each sentence.   

Deleting Text Without Overwriting the Clipboard 
To delete text without overwriting the contents of the SAPscript clipboard,   

1. Mark the text you want to delete.  
2. Choose Delete.   

The selected text is deleted and cannot be reinserted in your document.  
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Deleting Formats 
Deleting paragraph formats 

1. Put the cursor on the paragraph format in the format tag column.   
2. Delete the format or type it over with blank spaces.   
3. Choose Format to delete the paragraph format and add the text, if any, to the previous 

paragraph.  

Deleting Character Formats 
To delete a character format, delete the angle bracket tags that apply the format.   

 
<ZK>sample text</> applies italic formatting to “sample text”: 
Remove the italics formatting by deleting <ZK> and </>. Be sure to remove both the 
start and end markers of the format. Leaving the end tag </> can cause unexpected 
formatting errors.    
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Merging and Splitting Paragraphs 
In the line editor, you can merge two or more paragraphs into one paragraph. You can also split 
a paragraph into two or more paragraphs.  

Merging Consecutive Paragraphs  
1. Delete the paragraph tag in the format column of the second paragraph.  
2. Choose Format.  

The text of the second paragraph is added to the preceding paragraph. The paragraph 
format of the first paragraph applies to this newly created paragraph. If you delete the 
paragraph tag of several consecutive paragraphs, they are all added to the first 
paragraph.  

Merging Non-Consecutive Paragraphs  
1. Mark the text – but not the paragraph tag – of the paragraph you want to add to or insert 

into another paragraph.  
2. Copy it to the clipboard with Cut.  
3. Use the Backspace key to delete the paragraph tag of the now empty paragraph.  

The blank line disappears automatically the next time you choose Format or any other 
SAPscript function. 

4. Place the cursor on the target position and insert the text into the target paragraph with 
Edit  → Paste.  

 
Be sure to insert your text from the clipboard before you cut or copy another text. 
Any new cut or copy operation overwrites the contents of the clipboard. 

Splitting a Paragraph  
1. Put the cursor before the first character of the new paragraph.  
2. Choose Continue to insert a second paragraph tag.  

The new paragraph tag is taken from the original paragraph. You can enter a new 
paragraph format if required. 
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Moving Around in the Line Editor 
In the line editor, you can scroll or position the cursor on a specific line number.  

Scrolling 
Use the scroll buttons or the slider bar in the SAP window to scroll forwards and backwards in the 
line editor. If you scroll ahead by one screen page, then the next screen page starts with the line 
on which the cursor is positioned.  
You can also scroll horizontally in a text with F20 Page left/right. 

Going to a Particular Line 
To go to a particular line in your document, choose Edit → Position and specify the desired line 
number. In the line editor, this line then appears at the top of the screen. SAPscript puts the 
cursor on the line.   
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Using Clipboards 
You can use four types of clipboards for cutting and copying text in SAPscript. 

The SAPscript Clipboard 
Use 
Use the SAPscript clipboard for copying text within one or between different SAPscript 
documents. 

Prerequisites 
You can use the SAPscript clipboard only within a single R/3 system and client. 

Procedure 
1. Choose Edit → Select to select the text. 
2. Choose Edit → Selected area → Copy or Edit → Selected area → Cut and Edit → Paste 

to copy text to the clipboard and to reinsert it. 

SAPscript User Clipboards 
Use 
You use the SApscript user clipboard to copy “permanent” text areas. The "permanent" text 
persists in the clipboard until you overwrite it, even if you log off or the SAP System is restarted.  

Prerequisites 
You can use the SAPscript user clipboard only within a single R/3 system and client. 

Procedure 
1. Choose Edit → Select to select the text.  
2. Choose Edit  → Selected area → Copy to user clipboard and choose one of the five 

available clipboards.  
3. To insert the text, choose Include → Clipboard → User clipboard and the desired 

clipboard. 

 
You can edit the contents of user clipboards. Choose Goto → User clipboard to open 
a normal SAPscript text entry session for the contents of one of the clipboards. 

ABAP Editor Clipboard 
Use 
Use the ABAP editor clipboard for copying blocks of text from the ABAP editor to the line editor. 

Prerequisites 
You can use the ABAP editor clipboard only within a single R/3 system and client. 
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Procedure 
4. To mark text in the ABAP editor, use the line commands XX, YY, or ZZ. Each command 

copies text to a different clipboard. It must be used in pairs, for example, XX <text to 
mark> XX.   

5. To insert the text into the line editor, choose Include → Clipboard → Line editor and 
choose the appropriate clipboard.   

PC or Workstation Clipboard 
Use 
Use the PC or workstation clipboard for copying text  

• Between SAPscript documents when you cannot use a SAPscript clipboard. 
• Between SAPscript and other programs running at your PC or workstation. 
• From SAPscript to the ABAP editor (small blocks of text only).   

Prerequisites 
You may have to copy text from external programs line by line, since text areas exceeding one 
line are not correctly pasted into SAPscript. However, from ASCII editors, such as Microsoft 
Notepad, these text areas are copied correctly. 
If you paste a text area from an external program into SAPscript, the paragraph and character 
formats are not copied. 

Procedure 
4. Mark the text by pulling the cursor. 

In a Microsoft Windows PC, press CTRL and Y first to switch to select mode.   
5. Choose CTRL C (Copy) or CTRL X (Cut) to copy from SAPscript to the clipboard.   
6. Choose Include  → Clipboard  → Clipboard to paste the clipboard contents into 

SAPscript. 
The paragraph formatting in a SAPscript text is correctly copied into the new SAPscript 
window. Blocks of SAPscript text or editor text that extend beyond the end of the 
SAPscript screen are correctly inserted, too You can also use the hot key STRG-V 
(Paste). 
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Finding and Replacing 
Use 
You can search for and replace both text in the text entry area and paragraph formats in the 
format tag column.  

Procedure 
• To search or replace, choose Edit → Find or Edit → Replace. A search or replace action 

affects the text between the cursor position and the start or end of the document, 
depending upon the direction you choose.   

• To accept all replacements without check, choose Replace all. 
• To check each replacement, choose Confirm replace. 

In this case, you must choose Replace to carry out a replacement and Search forward or 
Search backward to continue the operation.   

• To repeat a search, choose Search forward or Search backward.  

Including Blanks at the End of a Search or Replacement Term  
A search or replacement term usually ends with the last non-blank character. However, if you 
need to include blanks at the end of the search or replacement term, enclose the entire term in 
inverted commas.  

 
Search term = 'house '  
The system searches for the term house with one blank at the end.  

If a term that is enclosed in inverted commas already contains an inverted comma, enter this 
inverted comma twice.  

 
Search term = 'SAP''s R/3 System '  

Using Replace to Delete a Search Term 
As in other word-processors, you can use Replace to delete a search term. Simply replace the 
term with an empty string. To specify an empty string as the replacement term, enter two 
successive inverted commas ('').   

 
If you enter the search term 'house ' and the replacement term '', then the string 
house<space character> will be deleted from your text.    
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Setting Breaks Manually 
Use 
You can insert line feeds, page breaks, and blank lines manually into your document. 
When you insert a line feed or blank line, the attributes of the paragraph format and any active 
character format remain in effect. 
When you insert a page break, the form determines the page design for the new page. A form 
may define several different page designs. You can pick one of these page designs for your new 
page by name: 

1. To see a list of the available page designs, choose Format → Pages. 
2. After NEW-PAGE, specify the page name. 

 
The form you use for your document defines a page layout called NEW-SECTION. 
The following command then starts a new page in your document. The page is laid 
out according to the design specified in the form under NEW-SECTION.   
/: NEW-PAGE NEW-SECTION 

For more information, see Explicit Page Break: NEW-PAGE [Extern]. 

Procedure 
Function Procedure 

Manual line feed Enter the paragraph tag / into the format tag column (followed by the 
text in the text input line). 

When output, the text in the input line appears in a new line. 

Manual page break Choose Page. 
The command /: NEW-PAGE is inserted into your text. 

Blank line Enter the paragraph tag / into the format tag column (without text in 
the text input line) 
When output, a blank line is inserted. 

Delete format settings Delete the appropriate paragraph tag in the format tag column and 
choose Edit → Format. 
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Suppressing Text Formatting 
You can suppress formatting of particular lines of text or text strings in the line editor or in the 
output. The following sections show what formatting you can suppress. 

Suppressing Automatic Blanks When Lines are Filled 
Use 
This function allows you to put together text from multiple lines in a single word or character 
string. It is intended for special formatting situations, for example, if you want to print the first part 
of a string only if a certain condition is met, but the second part of the string in any case. 

 
You can enter 

Go up to the sixth floor with the ele 
= vator.  Then ring the bell.   

The output then looks like this: 
Go up to the sixth floor with the elevator.  Then ring the bell. 

Suppressing Text Filling in the Text-Entry Screen 
Use 
This function makes long lines in the text-entry screen easier to read. When you load or include 
text that covers the entire 72 columns of the standard text entry area, the text is easier to read if 
you preserve the original line structure. Lines with the formatting specifications = and /= can use 
the entire 132 columns of the text entry lines without being filled. 

Procedure 
Enter = or /= in the format tag column and choose Format. SAPscript then leaves these lines 
unfilled. That is, no line breaks are inserted in such a line in the editor.   
At output, the lines are filled as follows: 

• Format = 
The text is added to the previous line without an intervening blank. (See also the 
previous section.) 

• Format /= 
The text starts on a new line in the printout or screen display.  

Suppressing Formatting 
Use 
You use this function to print or display formatting specifications for certain purposes. These 
formatting specifications can also be used for long lines, just as = and /=, described above.  

 
You can enter 

<(><ZK>Text to be output as cursive text</><)>  
The text is displayed or printed like this:  

<ZK>Text to be output as cursive text</> 
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You can also help SAPscript to interpret tabs and commas correctly. If you want your text to have 
a comma followed by a tab, this requires a sequence of three commas in your text:,,,   
The first two commas are interpreted as a tab, followed by a comma. To ensure the correct 
interpretation, enter <(>,<)>,,  

Procedure 
To prevent formatting of a particular line or character string within a line, enter parentheses (). 
Tabs and character formats are then not resolved. Instead, they are printed out as normal text.   
You can use these formatting tags in the following ways: 

• Enter ( in the format tag column to prevent the entire adjoining line of text from being 
formatted. At output, the line is concatenated without an intervening blank space with the 
end of the previous line. 

• Enter /( in the format tag column to prevent the entire adjoining line of text from being 
formatted. At output, the text starts on a new line in the printout or screen display.  

• Enter <(> and <)> around a character string to prevent a character format from being 
processed.   
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Tabs and Tables 
Setting Tabs 
To enter a tab in your text, you must enter two consecutive commas: (,,). You cannot use the 
tab key on your keyboard.  
Define the tab positions in the paragraph format definition in the style or form you are using. If the 
paragraph format does not define any tabs, then the tab positions defined in the dialog box 
Change form header under Basic settings are used. 

Creating Tables 
To create a table in SAPscript,  

1. Select one of the predefined paragraph formats for tables, if available, in your style or 
form.   
A paragraph format for a table usually defines the correct tab settings for the table, since 
table formatting in SAPscript is done with tabs.  

2. Enter and format the header that you wish to use for the table. (Your style or form may 
provide a special paragraph format for the header, which already includes any special 
formatting.) 

3. Enter and format the text for the columns in the table. You must ensure that the text for 
each column fits in the column. Enter one or more tabs to separate the text of one 
column from that of the next.  

4. Choose Print → Preview or print your table to check that you have correctly laid out the 
text for the table.   

 
To set up a three-column table, in the text entry area enter 
<ZK>Style,,Use,,,,Special features</>    
s_docus1,,Online docu format,,,,Num. paragraphs  
 

Print preview: 

Style Use Special features 

s_docus1 Online docu format Num. paragraphs
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Numbering and Marking Headings and Paragraphs 
Use 
You can number or otherwise mark headings and other types of paragraphs in your text. You can 
also number headings hierarchically according to the heading level. For example, you can have 
heading levels 1, 2, and 3 numbered accordingly:  1; 1.1; 1.1.1; 1.2, and so on. 

Functionality 
There are several numbering and marking options: 

• Letters  
• Numbers  
• Fixed characters, such as *, o, =, - 

Numbers can be represented as Roman or Arabic numerals. Letters can be written as uppercase 
or lowercase letters.  
You specify the numbering or marking you want to apply to a particular paragraph format. 
SAPscript automatically carries out the numbering or places the fixed character string that you 
have chosen before each such paragraph. 
Fixed character markings can consist of several characters. You can identify them by left or right 
delimiters. When number-chaining interdependent paragraphs (such as headings on different 
levels), a period is used to separate the paragraph numbering. 

 
Delimiters: a) - (a) - a. (and so on) 

Chaining: 1.1 - 1.1.1 - 1.2 - 1.2.1 (and so on)

Activities 
Resetting Numbering 
To reset the numbering scheme of a paragraph, enter the command /: RESET <paragraph-
tag>. 
For more information, see Resetting Paragraph Numbering [Extern]. 
 

April 2001  61 



BC - Word-Processing in the SAPscript Editor  SAP AG 
Copying and Comparing Across Clients 

Copying and Comparing Across Clients 
Use 
You can compare or copy the following kinds of objects across clients: 

• Styles 
• Forms 
• Standard texts. 

Functionality  
With the client compare, you can 

• Check whether an object exists in both clients. 
• Display the differences between the versions of an object. 

With the copy tool, you can copy an object from a source client to the client in which you are 
currently working. You can copy a style or form in all the languages in which it is available.  
Both the compare and copy tools support generic specifications, so that you can compare or 
copy sets of objects or all objects.   

Activities 
1. Depending on the object type you want to compare or copy, choose Tools →  SAPscript 

→ Form, Standard text, or Style. 
2. Choose Utilities → Compare clients or Utilities → Copy from client 
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Copying Client Contents 
Use 
To copy one or more standard texts, forms, or styles from one client to another client, choose 
Copy from client. 

 
It is not possible to copy styles or forms to client 000.  

Procedure 
Copying Standard Texts  

1. Choose Tools → SAPscript → Standard text 
2. Choose Utilities → Copy from client.  

This takes you to the dialog window for copying texts between clients.    
3. Make the following entries:  
Text name  

Enter the name of the standard text you want to copy. You can enter a generic name 
such as ST* or *.  

Text ID  
Enter the text ID (type) of the text(s) you have selected.  

Language  
Enter the appropriate language key.  

Source client  
Specify the client in which the standard text was created. By default, this is client 
000.    

Target name  
Specify the name of the new standard text.   

Action log  

Select to create an action log. 

No entry not to create an action log.

4. Choose Execute.   
If you selected the field Action log, the system displays a log after the copy process. 

Copying Forms  
1. Choose Tools → SAPscript → Form 
2. Choose Utilities → Copy from client.  

This takes you to the dialog window for copying forms between clients.    
3. Make the following entries:  
Form name  

Enter the name of the form you want to copy. You can enter a generic name such as 
ST* or *.  

Source client  
Specify the client in which the form was created. By default, this is client 000.    
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Target form  
Specify the name of the new form.   

Action log  

Select to create an action log. 

No entry not to create an action log.

4. Choose Execute.   
If you selected the field Action log, the system displays a log after the copy process. 

Copying Styles  
1. Choose Tools → SAPscript → Style 
2. Choose Utilities → Copy from client.  

This takes you to the dialog window for copying styles between clients.    
3. Make the following entries:  
Style name  

Enter the name of the style you want to copy. You can enter a generic name such as 
ST* or *.  

Source client  
Specify the client in which the style was created. By default, this is client 000.    

Target style  
Specify the name of the new style.   

Action log  

Select to create an action log. 

No entry not to create an action log.

4. Choose Execute.   
If you selected the field Action log, the system displays a log after the copy process. 
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Comparing Client Contents 
Use 
Choose Compare clients 

• To check whether a particular standard text, style, or form already exists in another 
client. 

• To identify differences in the object attributes and definitions.  
You can mark single objects for a comparison, or generate comparisons of a whole set of 
objects.   

 
A comparison covers only the attributes and, if applicable, the formal definition of an 
object. A comparison does not extend to the text level of an object. A comparison 
can highlight differences in the author of an object or the formats used in a style or 
form. But a comparison cannot detect differences in standard texts nor in the texts 
used in forms.  

Procedure 
Comparing Standard Texts 

1. Choose Tools → SAPscript → Standard text 
2. Choose Utilities → Compare clients.  

This takes you to the dialog window for displaying standard texts in two different clients.    
3. Make the following entries:  
Text name  

Enter the name of the standard text you want to check. You can enter a generic 
name such as ST* or *.  

Language  
Enter the appropriate language key.  

Text ID  
Enter the text ID (type) of the text(s) you have selected. 

Source client  
Specify the client, on the basis of which you want the check to be carried out. By 
default, this is client 000.    

Target client  
Specify the client you want to check against the source client. By default, this is the 
client in which you are currently active.   

4. Choose Execute.   
The system displays a list with the source client in the left-hand column and the target 
client in the right-hand column. An empty line in either column indicates that the standard 
text does not exist in the corresponding client.  

5. To display the differences between the standard texts, select one of the texts and choose 
Choose. 

6. You can display detailed information on a standard text. Select the standard text and 
choose Text info.  
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Comparing Forms 
1. Choose Tools → SAPscript → Form 
2. Choose Utilities → Compare clients.  

This takes you to the dialog window for displaying forms in two different clients.    
3. Make the following entries:  
Form name  

Enter the name of the form you want to check. You can enter a generic name such 
as ST* or *.  

Source client  
Specify the client, on the basis of which you want the check to be carried out. By 
default, this is client 000.    

Target client  
Specify the client you want to check against the source client. By default, this is the 
client in which you are currently active.   

4. Choose Execute.   
The system displays a list with the source client in the left-hand column and the target 
client in the right-hand column. An empty line in either column indicates that the form 
does not exist in the corresponding client.  

5. To display the differences between the forms, select one of the forms and choose 
Choose. 

6. You can display detailed information on a form. Select the form and choose Form info.  

Comparing Styles 
1. Choose Tools → SAPscript → Style 
2. Choose Utilities → Compare clients.  

This takes you to the dialog window for displaying styles in two different clients.    
3. Make the following entries:  
Style name  

Enter the name of the style you want to check. You can enter a generic name such 
as ST* or *.  

Source client  
Specify the client, on the basis of which you want the check to be carried out. By 
default, this is client 000.    

Target client  
Specify the client you want to check against the source client. By default, this is the 
client in which you are currently active.   

4. Choose Execute.   
The system displays a list with the source client in the left-hand column and the target 
client in the right-hand column. An empty line in either column indicates that the style 
does not exist in the corresponding client.  

5. To display the differences between the styles, select one of the styles and choose 
Choose. 

6. You can display detailed information on a style. Select the style and choose Style info.  
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Converting SAPscript Texts 
Use 
SAPscript texts are stored in Interchange Text Format (ITF). SAPscript offers conversion 
programs for the text file formats Rich Text Format (RTF) and ASCII as an interface to other word 
processors. And you can convert the edited text to HTML. 
RTF files contain all the formatting information for the text and can be both interpreted and 
generated by all common word processors. 
In ASCII files the text is not formatted. The only layout element is the line feed. Various character 
sets are possible. 
HTML files contain the entire formatting information of a text and can therefore be displayed 
using any HTML3.X browser (Netscape, MS Internet Explorer, and so on). Control commands, 
symbols, and include texts are resolved, provided that this can be done without processing the 
form (that is, without using the composer). 

Prerequisites 
When converting RTF files, you should execute a format conversion from the document template 
to the SAPscript paragraph and character formats or vice versa. This allows you to replace non-
existant paragraph and character formats and to avoid the fomat names to be copied directly. 
For more information, see SAPscript Format Conversion [Seite 69]. 

Functionality 
In the SAPscript editors, you can 

• Export texts in the formats ITF, RTF, or ASCII into a local file 
• Import local files in the formats ITF, RTF, ASCII, or HTML and insert the texts at the 

cursor position. 

Activities 
In the editors, choose Text → Upload and Text → Download or Documentation → Upload and 
Documentation → Download or Clipboard → Upload and Clipboard → Download. 
 

SAPscript Format Conversion [Seite 69] 
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SAPscript Format Conversion 
Use 
The SAPscript format conversion allows you to assign and rename paragraph formats and 
character formats in the source and target texts when converting formatted texts. 

Prerequisites 

 
In releases 2.1 and 2.2, the format conversion was still controlled via the tables 
TTDCF and TTDCW. If you have already worked with format conversions at that 
time, you will now have to convert to the new procedure starting from release 3.0. To 
begin with, start report RSTXDUMS. This report puts all old conversions into the new 
form, so that you can now process them using the function Format conversion. 

Functionality 
Importing RTF Files 
Format conversion is devided into two parts. You can map one paragraph style onto exactly one 
SAPscript paragraph format, but you can map one character style onto up to four SAPscript 
character formats. 

Exporting RTF Files 
Maintaining these conversions is dedvided into paragraph formats and character formats. You 
can map one paragraph or character format onto exactly one paragraph or character style. 

Word Style Sheets (Prototypes) 
Word style sheets (prototypes) are designed for the conversion of SAPscript formats to the 
formats of an existing style sheet. 

Format Conversion in SAPscript Texts 
You can convert the paragraph and character formats relevant for text formatting in the form or 
style to those of another form or style. 
You can map a paragraph format onto exactly one paragraph format, but you can map a 
character format onto up to four character formats. 

Activities 
Choose Tools → SAPscript → Administration → Format conversion. 
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Mapping Formats for Conversions 
Importing RTF Files 
Use 
When importing RTF files, you should map the format templates of this file to character and 
paragraph formats of a SAPscript style or form. The maintenance of these conversions is divided 
into paragraph formats and character formats. You can map exactly one paragraph style to 
exactly one SAPscript paragraph format, but you can map one character style onto up to four 
SAPscript character formats. 

Procedure 
1. Choose Tools → SAPscript → Administration → Format conversion. 

The dialog window SAPscript Format conversion appears. 
2. Select Import RTF files and choose Continue. 
3. Enter the name of the document template. 
4. Enter the name of the form or style onto which you want to map the format templates. 
5. Choose Format conversion → Create/Change. 
6. Choose Paragraph formats and/or Character formats. Enter the target format for each 

source format. 
7. Choose Save. 

The system saves the format conversion. 
8. When loading the RTF file, specify the format conversion of the document template. 

 
Format "Combi" contains the character formats bold and italic. In the style there is 
only a format ZF (bold) and a format ZK (italic). In the fromat conversion, a 
conversion from Combi to ZF and ZK is defined. 
Note the special RTF descriptions that correspond to the Word standard descriptions 
(for example heading 1, annotation text), as well as the RTF notation of some 
characters, especially umlauts. Apart from this, the characters '\', '{', '}' and ';' should 
never appear in the format name. A previous style sheet import is always useful. To 
display the RTF standard descriptions, choose Environment → RTF descriptions. 
If you have already executed a style sheet import, the formats are already listed as 
source formats. In any case, the SAPscript character or paragraph formats are 
suggested as possible entries help for the target formats. 
If no SAPscript paragraph is assigned to a paragraph format, the SAPscript default 
paragraph (“*“) is used. If no target format is defined for a character format, this 
format is not evaluated. 

Exporting RTF Files 
Use 
When exporting documents as RTF files, you should map the character and paragraph formats of 
a SAPscript style or form onto the format templates of the RTF file. The maintenance of these 
conversions is divided into paragraph formats and character formats. You can map a paragraph 
or character format to exactly one paragraph or character template. 
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Procedure 
1. Choose Tools → SAPscript → Administration → Format conversion. 

The dialog window SAPscript Format conversion appears. 
2. Select Export RTF files and choose Continue. 
3. Enter the name of the form or style. 
4. Enter the name of the document template onto which you want to map the paragraph or 

character format. 
5. Choose Format conversion → Create/Change. 
6. Choose Paragraph formats and/or Character formats. Enter the target format for each 

source format. 
7. Choose Save. 

The system saves the format conversion. 
8. When downloading the RTF file, specify the format conversion of the document template. 

 
If you do not select a style shoot prototype, you are merely renaming and evaluating 
the formats. A style sheet with format definitions from style or form is generated, in 
which only the names of the formats can deviate from the original SAPscript 
character and paragraph formats. 

Via the dominant column, you can evaluate the formats. If, for example, these two 
character formats exist: Z1 meaning bold, Z2 meaning underscored. In Word you do not 
allow any underscores: but want to use a uniform format “emphasized” instead. Enter the 
following: 

Determine format dominance 

Source format Target format Dominant

Z1 (bold) Emphasized X 

Z2 (underscored)  Emphasized  

Word Document Templates (Prototypes) 
Use 
Word document templates (prototypes) are designed for the conversion of SAPscript formats to 
the formats of a document template that already exists. 

Prerequisites 
For example, you are working in Word with the document template ABC.DOT. You want to use 
this template on texts converted from SAPscript. To do this, you must first save a word text 
assigned to the document template as RTF file, for example, with the name of XYZ.DOT. 

Procedure 
1. Choose Tools → SAPscript → Administration → Format conversion. 

The dialog window SAPscript Format conversion appears. 
2. Select Word document templates (prototypes) and choose Continue. 
3. Enter the name of the document template. 
4. Choose Prototype → Import. 
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5. Enter the name of the appropriate RTF file and choose Continue. The system creates the 
prototype. 

Format Conversion Between SAPscript Texts 
Use 
You can convert the paragraph and character formats of the form or style relevant for the text 
formatting to those of another form or style. 

 
SAPscript text ABC was until now formatted with the style STYL1 and form 
LAYOUT1. Now you want to assign a form LAYOUT2 to it. 

 
You can map one paragraph format onto exactly one paragraph format, but you can map one 
character format onto up to four character formats. 

 
You can execute this format conversion also via the function module 
EXCHANGE_ITF. For more information, see EXCHANGE_ITF [Extern]. 

Procedure 
1. Choose Tools → SAPscript → Administration → Format conversion. 

The dialog window SAPscript Format conversion appears. 
2. Select Format conversion in SAPscript texts and choose Continue. 
3. Enter the names of the forms and/or styles. 
4. Choose Format conversion → Create/Change. 
5. Choose Paragraph formats and/or Character formats. Enter the target format for each 

source format. 
6. Choose Save. 

The system saves the format conversion. 
7. In the corresponding SAPscript text, assign the other form. 
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Document Templates and Style Sheets 
Word 5.5 for DOS or OS/2 
You can define character and paragraph formats in a style sheet (*.dfv). They are identified via 
the “hot key”, a two character key, some of them via predefined descriptions such as "Outline 1". 

Word 2.0 
In the document template (*.dot), you can define format templates for paragraph formats. Unlike 
in Word 5.5, their names can be longer than two characters. 

Word 6.0 and Higher 
In addition to the features in 2.0, you can now define format templates for character formats. 
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ITF Export and ITF Import 
ITF Export  
Use 
A leader is placed in front of the output file. From this leader a text header is constructed if it is 
reimported. The text from the editor follows, with all character and paragraph markers, symbols, 
and commands. 

Procedure 
1. Choose Text → Download. 

The dialog window Download appears. 
2. Select ITF and choose Download. 
3. Enter the complete file path and choose Download. 

ITF Import 
Use 
If a header with form and style specifications exists, then form and style are set to these values in 
the editor and in the clipboards. 

 
This does not apply for the documentation editor in the ABAP Workbench. 

Procedure 
1. Choose Text → Upload. 

The dialog window Upload appears. 
2. Select ITF and choose Upload. 
3. Enter the complete file path and choose Upload. 
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RTF Export and RTF Import 
RTF Export  
Use 
During the RTF export, an RTF file is created in which the character and paragraph formatting 
from the original text are mostly contained. 
Variable symbols of the ITF text are replaced. Includes and control structures are canceled and 
comments ignored. 
If a document template is specified, a format conversion of the relevant SAPscript formats (style 
or form) to the Word document template takes place 
For more information, see SAPscript Format Conversion [Seite 69]. 

Prerequisites 
Importing RTF files to modern text processors is straightforward, but some preparation is 
necessary with the older DOS programs. 
For example, in Microsoft Word (from Version 5.0) under the operating systems MS DOS or OS/2 
the RTF file has to be converted to a Word text file together with a document template with the 
following command: 

Importing RTF files to Microsoft Word 

Operating system Conversion command 

MS-DOS Rtf_dos file1.rtf file2.txt file3.dfv /o/c 
rtf_dos file1.rtf file2.txt file3.dfv /o/m 

OS/2 Rtf_os2 file1.rtf file2.txt file3.dfv /o/c 
rtf_os2 file1.rtf file2.txt file3.dfv /o/m 

  
/o If file2.txt already exists, overwriting takes place without 

confirmation 
/c Document template file3.dfv is newly created 

/m Document template file3.dfv already exists and may be modified 

Procedure 
1. Choose Text → Upload. 

The dialog window Upload appears. 
2. Select Rich Text Format (RTF) and choose Upload. 
3. Enter the complete file path, the document template, and the form or style. 
4. Choose Upload. 

RTF Import 
Prerequisites 
The source text must have been created using a document template and saved as RTF file. In 
the R/3 system, a form or style should exist whose paragraph and character formats correspond 

April 2001  75 



BC - Word-Processing in the SAPscript Editor  SAP AG 
RTF Export and RTF Import 

to those of the document template. If there is none available, for example because the names of 
the tags in the document template are different, you can stell specify a format conversion. 

 
This conversion was designed for Word starting with 5.0. For RTF files created with 
WinWord 2.0, character formats cannot be converted. This is possible only with 
WinWord 6.0 again. However, if you want to save a text created with WinWord 2.0 as 
RTF file and import it into SAPscript, character formats cannot be converted. You 
can specify character formats in WinWord 6.0 only via format templates, never via 
Word. Otherwise, up to and including release 2.1K/2.2E, text imported to SAPscript 
can be lost. In later releases, these character formats again cannot be converted. 

For more information, see SAPscript Format Conversion [Seite 69]. 

Procedure 
1. Choose Text → Download. 

The dialog window Download appears. 
2. Select Rich Text Format (RTF) and choose Download. 
3. Enter the complete file path and the document template. 
4. Choose Download. 
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ASCII Export and ASCII Import 
ASCII Export 
Use 
All formats that appear in an ITF text, with the exception of line feeds and tabs, are taken out. 
The pure ASCll text, as it would appear when printed, is transferred. Some formatting is possible 
only via the line width parameter. Variable symbols are replaced, includes and control structures 
are canceled. 
The ITF text can be converted to any character set that is maintained in the Spool Administration 
(SPAD). 

Procedure 
1. Choose Text → Download. 

The dialog window Download appears. 
2. Select ASCII and choose Download. 
3. Enter the complete file path as well as line width and character set. 
4. Choose Download. 

ASCII Import 
Use 
All ASCII files can be loaded into the SAPscript editors. You must specify the character set of the 
file, that is, its number in the spool administration SPAD. The system then converts it to the 
system character set. 

Procedure 
1. Choose Text → Upload. 

The dialog window Upload appears. 
2. Select ASCII and choose Upload. 
3. Enter the complete file path and the character set. 
4. Choose Upload. 
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HTML Export  
Use 
The SAPscript editor internally calls the function module CONVERT_ITF_TO_HTML. This 
function module is used by other applications as well, for example, when converting OSS Notes, 
for ABAP documentation, and for glossary and IMG texts. 
The function module CONVERT_ITF_TO_HTML converts a SAPscript text to HTML to allow you 
to display the text using any HTML3.X browser (Netscape, MS Internet Explorer, and so on). The 
function module requires the text header (DDIC structure THEAD) and the text lines (DDIC 
structure TDLINES) as input. 
After successful conversion, the function module returns a table that contains the corresponding 
HTML text (DDIC structure HTMLLINE). During the conversion, SAPscript control commands, 
standard symbols, and include texts are resolved as far as it is possible without processing the 
form (that is, without using the composer). 
To assign SAPscript paragraph and character formats to HTML formats, use the appropriate 
tables with the function call. 
Conversion is controlled via several parameters: 

• Checking the syntax of the ITF text 
• Resolving symbols, include texts, and control commands 
• Printing control commands or text element names that cannot be interpreted 
• Representing character and paragraph formats in HTML 
• Specifying a CALLBACK routine to interpret links 
• Suppressing the HTML header 
• Determining the HTML background 

 
For an example of how to use CONVERT_ITF_TO_HTML, refer to the report 
RSTXHTML. You can use this report to convert any standard texts as well as 
documentation texts to HTML. 

For more information, refer to thedocumentation of the function module 
CONVERT_ITF_TO_HTML. 
 

Procedure 
1. Choose Text → Download. 

The dialog window Download appears. 
2. Select HTML and choose Download. 
3. Enter the complete file path and the data format. 
4. Choose Download. 
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Exporting to and Importing from Word  
Exporting Documents to Word 
Use 
The Word document keeps the format names specified in the SAPscript style or foem. To convert 
the SAPscript document to a Word style, specify a format conversion. 
After the format conversion, you can export SAPscript documents in RTF format and convert the 
formatting to the specified Word document template. 

Procedure 
1. Choose Tools → SAPscript → Administration → Format conversion. 

The dialog window SAPscript Format conversion appears. 
2. Select Word document templates (prototypes) and choose Continue. 
3. Enter the name of the document template (*.DOT). 
4. Choose Prototype → Import. 
5. Enter the path and the name of the RTF file for the document template. 
6. Choose Import. 

The system creates the document template (prototype). 
7. Choose Back, select Export of RTF files and choose Continue. 
8. Enter the name of the form or style. The name must correspond to the form or style 

assigned to your SAPscript document. 
9. Enter the name of the above document template (*.DOT). 
10. Choose Format conversion → Create/Change. 
11. Choose Paragraph formats and/or Character formats and enter the target format for each 

source format. 
12. Choose Continue. 

The system stores the format conversion. 
13. Go to your SAPscript document and choose Text → Download. 
14. Select Rich Text Format (RTF) and choose Download. 
15. Enter the path and the name of the Word file (*.RTF), into which you want to export the 

SAPscript document, and the name of the document template. 
16. Choose Export. 

The system exports the SAPscript document according to the format conversion into 
Word. 

For more information, see SAPscript Format Conversion [Seite 69]. 

Importing Documents from Word 
1. Save the Word document as RTF file. 
2. Choose Tools → SAPscript → Administration → Format conversion. 

The dialog window SAPscript Format conversion appears. 
3. Select Word document templates (prototypes) and choose Continue. 
4. Enter the name of the document template (*.DOT). 
5. Choose Prototype → Import. 
6. Enter the path and the name of the above RTF file. 
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7. Choose Import. 
The system creates the document template (prototype). 

8. Choose Back, select Import of RTF files and choose Continue. 
9. Enter the name of the document template. 
10. Enter the name of the form or style. The name must correspond to the form or style 

assigned to your SAPscript document. 
11. Choose Format conversion → Create/Change. 
12. Choose Paragraph formats and/or Character formats and enter the target format for each 

source format. 
13. Choose Continue. 

The system stores the format conversion. 
14. Go to your SAPscript document and choose Text → Upload. 
15. Select Rich Text Format (RTF) and choose Upload. 
16. Enter the path and the name of the file you want to import, the name of the document 

template, and the name of the form or style. 
17. Choose Import. 

The system imports the Word file according to the format conversion. 

 
If necessary, you can upload Word files in RTF format without first setting up format 
conversions. In this case, the paragraphs in the document are set to the default 
format (* format). Character formats are named with the first two characters of the 
name of the Word format.    

For more information, see SAPscript Format Conversion [Seite 69]. 
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Transporting Format Conversions and Style Sheet 
Prototypes 
Conversions and style sheet prototypes are stored as SAPscript  texts, language ‘E’ in client '00' 
and can be transported with the mechanisms intended for SAPscript objects: 

1. Create a transport request in client '00' (by hand as shown below, or via report 
RSTXTRAN). 

2. Release the transport. 

 
Format conversions and style sheet prototypes are client-independent. 

Transporting Format Conversions 
Format conversions are SAPscript texts with text object ‘STYLESHEET’ and text ID ‘ABB’. 
The text name is 34 characters long and has the following format: 

Text name format 

Character Meaning 

1 Type of source format: S (style), F (form), D (document template) 

2 to 17 Source format name (as given in initial screen of format conversion) 

18 Type of target format: S (style), F (form), D (document template) 

19 to 34 Target format name (as given in initial screen of format conversion) 

These texts are stored in language ‘E’ in client '00'. 
The entry in the transport request should appear as follows: 
R3TR | TEXT | <text object>,<text name>,<text ID>,<language> 

 
You want to transport the format conversion of form ABC to the document template 
XYZ.DOT to another system. You create a transport request with the following entry: 
R3TR | TEXT | STYLESHEET,FABC-------------Dxyz.dot,ABB,E 
(in this example the minus signs signify blanks in the text name) 
Alternatively, you can execute report RSTXTRAN and there select the texts you want 
to transport. 

Transporting Style Sheet Prototypes 
Style sheet prototypes are SAPscript texts with text object ‘STYLESHEET’ and text ID ‘RTF’. 
These are also stored in client '00' in the language ‘E’. The text name corresponds to the 
prototype name. 

 
You want to transport the style sheet prototype XYZ.DOT to another system. The 
entry in the transport request must have the form: 
R3TR | TEXT | STYLESHEET,xyz.dot,RTF,E 
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Style and Form Defined 
For more information, see BC - Style and Form Maintenance [Extern]. 

Styles 
A style defines the set of paragraph and character formats that are available for formatting a 
document.   

 
A typical style contains, for example, a definition for a standard paragraph, list 
paragraph formats, and possibly special-purpose paragraph formats for headings, 
data in forms, and so on. A style also defines such character formats as boldface 
and italics.  

 
If you select a style, this style provides the character and paragraph formats for your 
document. Any formats defined in the form selected for a document are ignored. Be 
careful, therefore, about selecting a style if none is currently selected. Selecting a 
style in this case can override formats in the form and produce unpredictable results.  

 
An include text preserves the style assigned to an included text.  

 
If your document is formatted with the S_OFFICE style and you include a document 
that uses the S_DOKUS1 style, SAPscript formats the included text according to 
S_DOKUS1; the other text is formatted with S_OFFICE. 

Forms 
A form specifies the page design. It defines one or more windows and arranges them on a page. 
Windows are output areas for texts and informatiom, such as the bank routing information on a 
check or the items in an invoice.   
In a form, you can specify different page designs for different pages, for example, for the first 
page and for subsequent pages.   
A form is language-specific. The language of a form is determined by the print program or by the 
language you specify. The language is important because a form can contain pre-defined texts 
which must of course be printed in the correct language.  
A print program collects information from the R/3 system and from the form, uses the text you 
entered in the editors, and then generates the document. The print program uses a form and 
sometimes also a style to format and generate the document. 
The program you use determines the windows into which you can enter text. If, for example, you 
choose Tools → SAPscript → Standard text, the system automatically opens window MAIN of 
form SYSTEM for text input. 
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Changing Styles and Forms  
Use 
If one of the editors was automatically started by your SAP application, the form and style are 
already allocated. You should not change theses settings. 

Prerequisites 
If you started one of the editors yourself without giving any specifications, SAPscript by default 
assigns the SYSTEM form and no style to the document.   
SYSTEM specifies a simple page design: a single full-page column. This page design is suitable 
for most general-purpose documents, such as notes that you may write in SAPscript. 

Procedure 
Changing Forms and Styles 

1. Choose Format → Change form or Format → Change style.  
2. Select the desired form or style. 
3. Choose Choose. 

De-Selecting Forms or Styles 

 
De-selecting forms and styles can be done in the line editor only. 

1. Choose Format → Change form or Format → Change style. 
2. Choose Reset Assignment. 
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Calling the Editor From Within Applications 
Use 
To edit texts in your application, you can call up the SAPscript Editor either fullscreen or inline. 

Features 
Fullscreen Editor 
To call the fullscreen editor, use function module EDIT_TEXT [Extern]. Make sure to pass the 
appropriate text format in the text header (TDTEXTTYPE). 

Inline Editor 
If you want to edit or display only the first few lines of a text, you can use the inline editor. With 
the inline editor, you can edit several text parts on one screen. For more information, see 
Displaying Text Lines in Application Screens [Extern]. 
As inline editor, you can use an editor based on screen-processing techniques or on the controls 
technology. 

Screen-Processing Techniques 
The screen-processing techniques offer a SAPscript Editor with formattings. To call this editor, 
use function module EDIT_TEXT_INLINE [Extern]. 
Compared with the fullscreen editor, the screen-processing techniques have the following 
restrictions: 
• The editor does not automatically unite words that are split up at the end of the line. 
• The editing functions available in the fullscreen editor are not supported. You can only use 

the generally available elementary editing functions for screen fields. 
• Scrolling in the text is not possible. 
• Only the beginning of the text line is visible. If the text lines are wider than the screen fields, 

you can process that part of the line that is not displayed only in the fullscreen editor. 
• The changes to the text lines are written immediately to the original line table of the text 

(Save function of the editor applies automatically). Thus, you can no longer reconstruct the 
original state of the text unless you stop all changes made in the transaction from being 
updated. 

Controls Technology 
The controls technology offers a note editor without formattings and without SAPscript support 
(such as symbols and commands); that is, only pure ASCII text is displayed. 
To call this editor, use SAP TextEdit [Extern]. 

In the development class STXD you can find the sample program 
SAPSCRIPT_DEMO_NOTE_EDITOR, which demonstrates how to use TextEdit as 
inline editor. To present the SAPscript texts two conversion modules are used. 
During the conversion of the SAPscript texts, the formatting information, such as 
paragraph or character format, is lost. 

For general information on controls see BC - Controls Tutorial [Extern] and SAP Control 
Framework [Extern]. 
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