SAP Patch Manager (SPAM) (BC-UPG-OCS)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔴⚠️</td>
<td>Caution</td>
</tr>
<tr>
<td>📝</td>
<td>Example</td>
</tr>
<tr>
<td>📈</td>
<td>Note</td>
</tr>
<tr>
<td>🡀🡢</td>
<td>Recommendation</td>
</tr>
<tr>
<td>🕵️‍♂️</td>
<td>Syntax</td>
</tr>
<tr>
<td>💡</td>
<td>Tip</td>
</tr>
</tbody>
</table>
Contents

SAP Patch Manager (SPAM) (BC-UPG-OCS) ............................................................... 5
SAP Patch Manager (SPAM) (BC-UPG-OCS) ............................................................... 5
Authorizations for SPAM ............................................................................................ 7
Support Packages: Types ............................................................................................. 8
Settings for SPAM ......................................................................................................... 10
Importing Support Packages Using SPAM ................................................................. 12
Importing SPAM/SAINT Updates .................................................................................. 14
Loading A Support Package ....................................................................................... 15
Defining a Queue .......................................................................................................... 17
Rules for the Queue ...................................................................................................... 19
Importing a Queue ........................................................................................................ 20
SPAM: Modification Adjustment .................................................................................. 22
SPAM: Checking Logs ................................................................................................... 23
Confirming a Queue ...................................................................................................... 24
Importing Support Packages into Other Systems ....................................................... 25
SPAM Steps .................................................................................................................. 26
SPAM: Troubleshooting ............................................................................................... 28
Displaying the Status ................................................................................................... 29
SPAM: ABAP/Screen Generation ................................................................................ 30
Errors in SPAM Steps .................................................................................................. 31
Resetting the Status of a Support Package ............................................................... 36
Deleting the Queue ....................................................................................................... 37
SAP Patch Manager (SPAM) (BC-UPG-OCS)

Use

The SAP Patch Manager (SPAM) is the customer side of the Online Correction Support (OCS). Transaction SPAM lets you efficiently and easily import SAP-provided Support Packages into your system.

Depending on the system used or the configuration of your system, you must apply different Types of Support Packages [Page 8]. You can get the Support Packages in the SAPNet R/3 Frontend, the SAPNet Web frontend, or on Collection CDs.

SPAM runs at the SAP transaction level, so that a knowledge of the operating system is not required for handling the tool.

SAP now uses the term Support Package instead of patch.

Note that you can only use this transaction with SAP GUI for Java and SAP GUI for Windows.

Calling SPAM

You can call Transaction SPAM in one of the following 2 ways:

- Go to the SAP menu and choose Tools → ABAP Workbench → Utilities → Maintenance → Patches.
- Enter the Transaction SPAM.

Functions

The SAP Patch Manager offers you the following functions:

- Loading Support Packages:
  You can load the Support Packages you need from the SAPNet Web Frontend, the SAPNet R/3 Frontend, or from Collection CDs into your system.

- Importing Support Packages
  - Restart capability
    When you import a Support Package into your system, SPAM follows a predefined sequence of steps.
    If the Support Package process terminates, it can be resumed at a later point in time. Processing restarts at the step that failed.
  - Displaying the import status in your system
    You can find the import status in your system at any time using Transaction SPAM.

Transaction SPAM is integrated into the SAP upgrade procedure.
Authorizations for SPAM

You need the following authorizations to use all SAP Patch Manager Functions:

- S_TRANSPRT
- S_CTS_ADMIN

You can find both of them in the authorization profile S_A.SYSTEM.

If you log on in client 000 and your user master data contains the corresponding authorization profile, you can use all the functions of the SAP Patch Manager. If you log on in another client or without the correct user profile, you can only use the display functions.

Only assign this authorization profile to the system administrator. Only the system administrator should have authorization for:

- Downloading Support Packages
- Importing Support Packages
- Confirming successfully imported Support Packages
- Resetting the status of a Support Package
Support Packages: Types

Definition

A Support Package corrects errors in the SAP System or makes necessary adjustments, for example, due to legal changes. The objects affected are replaced in your system.

Each Support Package is valid for only one release (but for all databases and operating systems) and requires an exactly defined number of predecessors. The upgrade of the following release or correction release contains all the Support Packages of the previous versions that were available up to the delivery of the upgrade.

SPAM makes sure that Support Packages are imported only in the specified order.

To prevent errors from occurring, you should import every Support Package as soon as it becomes available. This keeps your system up-to-date.

Use

The following types of Support Packages are available:

- **SPAM/SAINT Update**
  
  A SPAM/SAINT Update (PAT) contains updates and improvements to the SAP Patch Manager and the SAP Add-On Installation Tool.

- **FCS Support Package**
  
  An FCS Support Package (FFD) updates an FCS system to its General Availability release so that other Support Packages can be imported.

- **Component Support Package**
  
  This type of Support Package (COP) is valid for one software component (SAP_BASIS, SAP_HR, SAP_APPL, ...) and contains corrections to errors in the Repository and Dictionary in this software component only. In addition to these corrections, Support Packages for the SAP_HR component also contain adjustments due to legal changes.

**Naming Convention:**

<table>
<thead>
<tr>
<th>Software Component</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP_APPL</td>
<td>R/3 Support Package</td>
</tr>
<tr>
<td>SAP_BASIS</td>
<td>Basis Support Package</td>
</tr>
<tr>
<td>SAP_ABA</td>
<td>Application Interface Support Package</td>
</tr>
<tr>
<td>SAP_HR</td>
<td>R/3 HR Support Package</td>
</tr>
<tr>
<td>SAP_APO</td>
<td>APO Support Package</td>
</tr>
</tbody>
</table>

- **BW Support Package**

A BW Support Package (BWP) is a Support Package for the software component SAP Business Information Warehouse (SAP_BW) and only contains corrections for this component.

- **Add-On Support Package**
An Add-On Support Package (AOP) is valid for an add-on with a particular release and contains corrections for this add-on.

- **Conflict Resolution Transport**
  
  A Conflict Resolution Transport CRT is exclusively used for add-ons, for example, IS-IS or IS-OIL. It resolves conflicts that can occur between Support Packages and an add-on.

  Note that a CRT that is valid for an add-on release also resolves all conflicts with earlier releases from this add-on. A CRT can also contain other corrections for the relevant add-on. A CRT can also be a special Add-On Support Package.
Settings for SPAM

To go to the dialog box where you can make general settings for the SAP Patch Manager (SPAM), choose Extras → Settings. These settings influence the behavior of the system when you load and import Support Packages of different types. The SPAM updates are an exception, where certain settings are already fixed.

You can activate and deactivate the following attributes:

- **Transmission Monitor**
  When you activate the Transmission Monitor, you can follow the progress of the download of the Support Packages from SAPNet - R/3 Frontend on a graphical monitor. Otherwise, the progress of the download is displayed in the status line.

- **Scenario**
  When you choose the scenario, you determine which activities you want to be performed when the Support Package is imported.
  
  The standard scenario is used to import Support Packages completely; all steps are performed.
  
  The test scenario lets you determine if a modification adjustment is required before the Support Package is actually imported, or if conflicts occur that must be resolved before the import. In the test scenario, data and objects are not imported into your R/3 System.
  
  There is no test scenario for SPAM updates. The selection you make here is ignored when importing a SPAM update.

- **Create new data file**
  You can determine whether you want the data files to be unpacked from the EPS packets each time you import. This is the default setting.
  
  If you use a multiple system landscape with a common transport directory, it is best to only activate this option in the first system into which you import Support Packages, and to deactivate it in the following systems. This saves time because the data files do not need to be created again in these systems.

- **Delete data file after import**
  You can determine whether you want the data files to be deleted after the Support Packages have been imported. This saves hard disk space and is the default setting.
  
  If you use a multiple system landscape with a common transport directory, it is best to deactivate this option, since then you do not need to create new data files in the other systems (see Create new data file above).

- **Run ABAP generator/screen generator**
  This option lets you determine if the programs and screens delivered with the Support Package should be generated while the Support Package is imported.

  Note that the generation can take a long time.
If you do not choose Generation, the programs and screens are only generated when they are called for the first time. Note that you can only influence this parameter if generation is permitted by SAP for these Support Packages during the import.

You cannot influence generation for the SPAM update.

### SPAM Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>SAP Default Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transmission Monitor</td>
<td>Off</td>
</tr>
<tr>
<td>Scenario</td>
<td>Default</td>
</tr>
<tr>
<td>Create new data file</td>
<td>On</td>
</tr>
<tr>
<td>Delete data file after import</td>
<td>On</td>
</tr>
<tr>
<td>Run ABAP generator/screen generator</td>
<td>Off</td>
</tr>
</tbody>
</table>
Importing Support Packages Using SPAM

Use

Use Transaction SPAM to import Support Packages [Page 8] into your system, whether they come from SAPNet - R/3 Frontend, SAPNet - Web Frontend or from Collection CDs.

Prerequisites

User:

- You must have the relevant authorization [Page 7] for the SAP Patch Manager.
- You must be logged on to Client 000.
- You must have called Transaction SPAM.

Choose Tools → ABAP Workbench → Utilities → Maintenance → Patches, or enter the transaction code SPAM.

The initial screen gives an overview of the status of the last queue that was imported. If the Support Package import is incomplete, the last (terminated) step processed by SPAM is displayed.

System:

- Check the correct function of the transport tools by choosing Utilities → Check transport tool.
- Make sure that there is enough space in the transport directory (size of the OCS files multiplied by 2) (use Transaction AL11 to see the profile parameter DIR_TRANS or use Transaction SE38 and the report program RSPARAM). It is particularly important that there is enough space in the subdirectories trans/EPS/in and trans/data.
- Use the newest SPAM update.

Check if the SPAM update offered in SAPNet - R/3 Frontend or SAPNet - Web Frontend is newer than the one in your system. (The version of the SPAM update in your system appears in the title bar of the SPAM screen.) To avoid problems when importing Support Packages, we recommend always first importing the newest SPAM update [Page 14]. You import a SPAM update in the same way that you import Support Packages.
- You cannot have any incompletely imported Support Packages in your system.

To check this, under Directory choose Aborted Support Packages and then choose Display. No Support Packages should appear. Under the section Package, the status should display a green traffic light. If this is not the case, look at the detailed status and log information of all Support Packages found in the system. To do this, choose Goto → Status and/or Goto → Log.

Activities

1. Load the Support Package [Page 15].
2. Define a queue [Page 17].
3. Import the queue [Page 20].
4. If necessary: Adjust modifications [Page 22].
5. Check logs [Page 23].
6. Confirm the queue [Page 24].
Importing SPAM/SAINT Updates

Use
SPAM/SAINT Updates (in short, SPAM Update) contain updates and improvements to the SAP Patch Manager and the SAP Add-On Installation Tool. There is always one SPAM update for each maintenance level release. This update is updated accordingly. You can find the version in the short description, for example:

SPAM/SAINT update - version 4.6A/0001

A SPAM update is always the first Support Package in the list of Support Packages in SAPNet - R/3 Frontend.

Make sure you always have the newest version of SPAM before you import Support Packages.

Prerequisites
You can only import a SPAM update successfully if there are no aborted Support Packages in the system.

A dialog box informs you if there are aborted Support Packages. You then have two options:

- First import the complete queue and then the SPAM update.
- Reset the queue status, import the SPAM update first and then the queue. To reset the queue status, choose Extras → Reset status → Queue.

If you reset the queue after objects have already been transported (for example, after an error in step DDIC_IMPORT), your system will be inconsistent. Only reset the queue if the import was aborted before the step DDIC_IMPORT. For more information, see SPAM Steps [Page 26].

Note that, as of SPAM/SAINT Version 11, you cannot reset the queue once you have reached the step DDIC_IMPORT.

Procedure
1. Check if the SPAM update offered is newer than the one in your system. (The current SPAM version is displayed in the title bar of the SPAM initial screen.)

2. To import the newest SPAM update, choose Support → Import SPAM update.

   SPAM updates are automatically confirmed after being successfully imported.
Loading A Support Package

Use
You must load Support Packages before you can import them. SAP provides Support Packages in the following locations:

- in SAPNet - R/3 Frontend
- in SAPNet - Web Frontend
- on Collection CDs

Prerequisites

- The Change and Transport System is configured correctly.
- There is enough space available in the transport directory (UNIX: /usr/sap/trans).
- You must have the relevant authorizations [Page 7] for the SAP Patch Manager.
- You must be logged onto Client 000.
- You must have already called Transaction SPAM.
- You are using the newest SPAM version.

Procedure

Loading Support Packages from SAPNet - R/3 Frontend

Before you load a Support Package from SAPNet - R/3 Frontend, maintain the network parameters for logging on to SAPNet - R/3 Frontend. To do this, use Transaction OSS1.

1. Request the Support Packages you need in SAPNet - R/3 Frontend.
2. Load the Support Packages from SAPNet - R/3 Frontend into your SAP System by choosing Support Package → Download.
   
   A list of Support Packages appears. You can then select the Support Packages that you want to load.
   
   The size of the uncompressed Support Packages is displayed in bytes. You can use the size of the Support Packages to estimate the load time.
3. Using the status display, check if the load was successful.
4. To return to the SPAM initial screen, choose Goto → Back.
5. Define the queue [Page 17].

Loading Support Packages from SAPNet - Web Frontend or from Collection CDs

Support Packages from SAPNet or from Collection CDs are in a compressed format. You have to unpack these Support Packages before you can process them further.
Loading A Support Package

1. Load the Support Packages from SAPNet - Web Frontend or mount the right CD.
2. Log on using the following user:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>User</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>&lt;sid&gt;adm</td>
</tr>
<tr>
<td>AS/400</td>
<td>&lt;SID&gt;OFR</td>
</tr>
<tr>
<td>Windows NT</td>
<td>&lt;SID&gt;adm</td>
</tr>
</tbody>
</table>

3. Switch to the following subdirectory in your system:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Subdirectory</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX and AS/400</td>
<td>usr/sap/trans/tmp</td>
</tr>
<tr>
<td>Windows NT</td>
<td>&lt;DRIVE&gt;:\usr\sap\TRANS\TMP</td>
</tr>
</tbody>
</table>

4. Unpack the archive containing the Support Packages using the following command:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>CAR -xvf /&lt;CD_DIR&gt;/<em>&lt;PATH&gt;/</em>&lt;ARCHIVE&gt;*.CAR</td>
</tr>
<tr>
<td>AS/400</td>
<td>CAR '-xvf /QOPT/<em>&lt;VOLID&gt;//</em>&lt;PATH&gt;/<em>&lt;ARCHIVE&gt;</em>.CAR'</td>
</tr>
<tr>
<td>Windows NT</td>
<td>CAR -xvf &lt;CD_DRIVE&gt;:/<em>&lt;PATH&gt;/</em>&lt;ARCHIVE&gt;*.CAR</td>
</tr>
</tbody>
</table>

5. Place the unpacked Support Packages in the EPS Inbox of your transport directory.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>EPS Inbox of the Transport Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>/usr/sap/trans/EPS/in</td>
</tr>
<tr>
<td>AS/400</td>
<td>/usr/sap/trans/EPS/in</td>
</tr>
<tr>
<td>Windows NT</td>
<td>&lt;DRIVE&gt;:\usr\sap\trans\EPS\in</td>
</tr>
</tbody>
</table>


   You see a list of the uploaded Support Packages that are now known in the SAP System with all of their attributes. These can now be handled in the correctly by the SAP Patch Manager.

7. To return to the SPAM initial screen, choose Back.

8. Define the queue [Page 17].
Defining a Queue

Use

The queue specifies which Support Packages are imported into your system by the SAP Patch Manager and in which order.

If the queue is not completely defined, you must define the queue from the Support Packages available.

If the queue is already completely defined, this is then displayed; you cannot change the selection anymore. However, you can delete the queue completely by choosing Delete queue [Page 37].

If you delete the queue after objects have already been transported (for example, after an error in step DDIC_IMPORT), your system will be inconsistent. Only delete in these SPAM steps to correct errors and import the Support Packages again as soon as you can.

Transaction SPAM ensures that only the Support Packages appropriate for your system appear in the queue. Support Packages that are meant for another release or add-on do not appear in the queue, even if they were loaded into your SAP System. For more information, see Rules for the Queue [Page 19].

You must define the queue before importing Support Packages.

Prerequisites

You have used SPAM to load [Page 15] the relevant Support Packages into your SAP System.

Procedure

1. To define a queue, call Transaction SPAM and choose Display/define. The Component selection dialog box appears.

2. The list of installed software components (for example, SAP_BASIS, SAP_HR, SAP_BW, Add-On) appears. Select the relevant components.

3. The available queue appears. This queue contains the Support Packages available for the selected components in your system, and, if necessary, the Conflict Resolution Transports (CRTs) and other Add-On Support Packages.

   You can do the following:
   - If the queue displayed is how you want it, you can copy and confirm the queue by choosing Confirm queue and leaving this window.
   - You can reduce the queue selection. To do this, select the Support Package that you want to be the last in the queue. This recalculates the queue, but you can also do it explicitly by choosing Recalculate queue.
Defining a Queue

You can only select Support Packages that belong to the software components selected by you (the cursor changes its appearance accordingly). The Support Packages that belong to the queue are highlighted in green. The highest Support Package selected by you for the selected software component is also flagged with a green check mark. The Support Packages that no longer belong to the queue are still visible in the list, and you can choose them again.

- If you want to specify the queue for another software component, choose New component.

Result

You have defined the queue. Now import the Support Packages in the queue [Page 20].
Rules for the Queue

The following rules apply when creating a queue:

- If you have an FCS system, an FCS Support Package is the first Support Package in the queue. If it is missing from the queue, it cannot be defined. Instead, an error message tells you the name of the missing FCS Support Package. You cannot import an FCS Support Package into a non-FCS system (official delivery version).

- Support Packages for a selected component are placed in the queue according to their sequence.

- If Support Packages in the queue are related to Support Packages of another component (additional predecessor relationship, required CRTs), the queue is extended by additional Support Packages until all the predecessor relationships are fulfilled.

⚠️

Make sure that the SAP Patch Manager takes into account the configuration of your SAP System and includes only those Support Packages in the queue that may be imported into your system.
Importing a Queue

Use
The SAP Patch Manager offers you 2 scenarios for importing Support Packages or a queue:

- **Test scenario**
  
  Use the Test scenario before actually importing the Support Package or queue to determine if conflicts or problems arise (for example, repairs that have not been released), or if a modification adjustment is necessary.

  The scenario enables you to estimate and perhaps minimize the time and energy needed to import Support Packages. In this scenario, no data is imported into the system and if an error occurs, you can also continue the process without correcting the error.

  You must choose the Test scenario explicitly.

  Note that after the test scenario has run, the queue is empty and must defined once again. Furthermore, you must explicitly choose the Standard scenario afterward.

- **Standard scenario**
  
  In this scenario, the Support Packages in the queue are completely imported. If an error occurs, you can only continue and end the application successfully if the error is corrected.

Prerequisites

The queue is already defined.

Procedure

1. To choose the scenario you want, choose *Extras → Settings*.
2. Choose the scenario.
3. Choose *Support Package → Import queue*.

   This function is also used to resume an aborted Support Package import.

   The status line informs you of the progress of the application and the current steps of the SAP Patch Manager. You may be taken to modification adjustment (Transactions SPDD, SPAU) during the import.

   If you import with the standard scenario, you must adjust Dictionary objects immediately (Transaction SPDD). You can choose to skip the adjustment of Repository objects (Transaction SPAU) and do it later ([modification adjustment](Page 22)).

   The session is blocked while a Support Package is being imported. To avoid logging on again, open a second session before you import the Support Package.
Importing a Queue
SPAM: Modification Adjustment

Use
If you have modified SAP objects, you must adjust these objects when importing them. (Transaction SPDD adjusts Dictionary objects, Transaction SPAU adjusts Repository objects.)

Prerequisites
SPAM prompts you to adjust your modifications.

Procedure
1. Stop the import of the Support Package (F12). (SPAM resumes at the step RUN_SPDD or RUN_SPAU.)
2. So that your developers can perform the modification adjustment, go to the Transport Organizer [Ext.] and create a request that includes tasks for the developers.
3. Ask the developers to adjust the modifications for their objects.
   - Adjusting: Dictionary objects (SPDD): Developers can display a list of affected objects by choosing Extras \rightarrow Adjust modifications from the initial screen of Transaction SPAM.
   - Adjusting Repository objects (SPAU): Developers must call Transaction SPAU and then adjust the objects.
     After the adjustment is completed, the developers must release their tasks and inform you. You can perform the adjustment in any client.
4. Call Transaction SPAM.
5. Choose Support Package \rightarrow Import queue. SPAM prompts you again to adjust the modifications. As this has already been done, ignore this prompt and choose Continue. SPAM completes processing and displays the status.
SPAM: Checking Logs

Use
The function Queue logs displays logs for SPAM steps that the transport control program tp uses. After successfully importing the queue, check these logs each time.

Assigning the SPAM Steps to Log Files

<table>
<thead>
<tr>
<th>Step</th>
<th>Log file</th>
</tr>
</thead>
<tbody>
<tr>
<td>DISASSEMBLE_PATCH</td>
<td>Create cofile</td>
</tr>
<tr>
<td>TEST_IMPORT</td>
<td>Test import</td>
</tr>
<tr>
<td>IMPORT_OBJECT_LIST</td>
<td>Command file import</td>
</tr>
<tr>
<td>DDIC-IMPORT</td>
<td>DD import</td>
</tr>
<tr>
<td>IMPORT_PROPER</td>
<td>Data Dictionary activation</td>
</tr>
<tr>
<td></td>
<td>Import</td>
</tr>
<tr>
<td></td>
<td>ADO import</td>
</tr>
<tr>
<td></td>
<td>Check versions</td>
</tr>
<tr>
<td></td>
<td>Method execution</td>
</tr>
<tr>
<td></td>
<td>Generate ABAP/screen</td>
</tr>
</tbody>
</table>

Procedure
To display the logs, choose Goto → Log → Queue in the initial screen of SPAM.

Return Codes:

<table>
<thead>
<tr>
<th>Return Code</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or 4</td>
<td>System information and warnings</td>
</tr>
<tr>
<td></td>
<td>Warnings are generally not critical for the system. Check them</td>
</tr>
<tr>
<td></td>
<td>however, since sequence errors may occur in exceptional cases.</td>
</tr>
<tr>
<td>Greater than 4</td>
<td>Serious errors that must be corrected before you can successfully</td>
</tr>
<tr>
<td></td>
<td>import the Support Package.</td>
</tr>
</tbody>
</table>
Confirming a Queue

Use
Confirm the successful application of the queue in your system. This ensures that other Support Packages can be imported in the future. Another Support Package cannot be imported without a confirmation.

If you have not yet confirmed Support Packages that were imported successfully, you will be asked to confirm these Support Packages when the system is upgraded.

Prerequisites
You have successfully imported one or more Support Packages.

Procedure
Confirm the successful import of the Support Package in your system by choosing Support Package → Confirm.
Importing Support Packages into Other Systems

Prerequisites
1. The Support Packages were imported successfully into a system (test or development system).
2. You have adjusted modifications.

Procedure
1. Load the Support Packages into the next system (quality or production system). You must differentiate between the following scenarios:
   - Your systems have a common transport directory:
     - **Releases 3.x:**
       If the *.ATT files do not exist, execute the program RSEPSDOL in the source system and the program RSEPSUPL in the target system.
       - If the *.ATT files do exist, just execute RSEPSUPL in the target system.
     - **Releases 4.x:**
       - In the target system, choose *SPAM → Support Package → Upload.*
   - Your systems do not have a common transport directory:
     - **Releases 3.x:**
       Execute RSEPSDOL in the source system to create the *.ATT files if they do not already exist.
       Use `ftp` to transfer all the files with the extension *.PAT in binary mode and all the files with the extension *.ATT in ASCII mode from the source system directory `/usr/sap/trans/EPS/in` (UNIX and AS/400) or `<DRIVE>:\usr\sap\trans\EPS\in` (Windows NT) to the target system transport directory.
       Execute the program RSEPSUPL in the target system.
     - **Releases 4.x:**
       With the command `ftp`, transfer all the files with the extension *.PAT in binary mode from the source system directory `/usr/sap/trans/EPS/in` (UNIX and AS/400) or `<DRIVE>:\usr\sap\trans\EPS\in` (Windows NT) to the target system transport directory.
       In the target system, choose *SPAM → Support Package → Upload.*
2. Import the Support Packages as usual as usual.
3. Import the modification adjustment transport.
SPAM Steps

The SAP Patch Manager informs you of the status of the step currently being executed in the status bar. If you want to know which steps are executed for which scenario, run the program RSSPAM10.

The following list explains the steps executed by SPAM in the order in which they are performed.

1. PROLOGUE
   In this step, the system checks if you are authorized to import Support Packages.

2. CHECK_REQUIREMENTS
   In this step, various requirements are checked for importing a Support Package, for example, the transport control program tp logging on to your system.

3. DISASSEMBLE
   In this step, files from the corresponding EPS parcels are disassembled, or unpacked, and stored in the directory.

4. ADD_TO_BUFFER
   In this step, the queue is put into the transport buffer of your system.

5. TEST_IMPORT
   In this step, the system checks if there are still objects in tasks that have not yet been released and are overwritten when the Support Package is imported.

6. IMPORT_OBJECT_LIST
   In this step, the object lists for the Support Packages in the queue are imported into the system.

7. OBJECTS_LOCKED_?
   In this step, the system checks if there are still objects in tasks that have not yet been released and are overwritten when the Support Package is imported.

8. SCHEDULE_RDDIMPDP
   In this step, the transport daemon (program RDDIMPDP) is scheduled.

9. ADDON_CONFLICTS_?
   In this step, the system checks if there are conflicts between objects in the queue and installed add-ons.

10. SPDD_SPAU_CHECK
    In this step, the system checks if a modification adjustment is necessary (Transactions SPDD/SPAU).

11. DDIC_IMPORT
    In this step, all the ABAP Dictionary objects of the queue are imported.

12. AUTO_MOD_SPDD
    In this step, the system checks if modifications to the ABAP Dictionary objects can be adjusted automatically.
13. RUN_SPDD_?
   In this step, you are asked to adjust your modifications to the ABAP Dictionary objects by calling Transaction SPDD.

14. IMPORT_PROPER
   In this step, all the Repository objects and table entries are imported. Then actions such as distribution, conversion, activation and generation occur.

15. AUTO_MOD_SPAU
   In this step, the system checks if modifications can be adjusted automatically.

16. RUN_SPAU_?
   In this step, you are asked to adjust your modifications to the Repository objects by calling Transaction SPAU.

17. EPILOGUE
   In this step, the import of the Support Package is ended. The system checks if the queue has been completely processed.
SPAM: Troubleshooting

While the Support Package is being imported, the SAP Patch Manager goes through various steps. If errors occur, SPAM terminates the process to ensure the consistency of the application. After you have corrected the error, you can continue importing the Support Package. If the process terminates, a dialog box appears informing you at which step and why the process was terminated.

You can also get to this dialog box by choosing Goto → Status and then Queue, Support Package or SPAM update (Displaying the Status of a Support Package [Page 29]). Depending on the step where the error occurred, you receive more specific help on how to correct the problem.

You may also have to reset the status of the Support Package [Page 36].

Note

If you have any problems downloading Support Packages from SAPNet - R/3 Frontend, read Note 173814.

If problems occur while working with SPAM, read Note 97628, which gives you an overview of known problems and their solutions.

You can find a list of the most important Notes from the Online Correction Support (OCS) in Note 97620, which is regularly updated.

If you cannot solve your problem using these Notes or with the following information, send a an error message through SAPNet using the information from the error dialog box and send it to the component BC-UPG-OCS. Also read Note 97660 before creating your error message.

See also:

Errors at Generation [Page 30]
Errors in SPAM Steps [Page 31]
Displaying the Status

Use
You can display the import status and the Support Package status of your system.

Procedure

Displaying the Import Status
To display the import status, choose Goto → Status → Queue. A dialog box appears telling you if the Support Package was imported.

Displaying the Support Packages that Are in the System
To display the Support Package status of your system, select one of the following options under Directory and choose Display:
- New Support Packages (have not been imported yet)
- Aborted Support Packages (have not been successfully imported)
- Imported Support Packages (have been successfully imported)
- All Support Packages
A list appears with information about the selected Support Packages.
For more information on the Support Packages displayed, choose View → Change view.

Displaying the Support Package Level of the Installed Software Components
To display the software components installed in your SAP System with their Support Package level, choose Status → Package level. A dialog box appears that lists the installed software components and additional information.
For more information on this dialog box, choose Online manual.
SPAM: ABAP/Screen Generation

Use
For performance reasons, SPAM is set up by default so that no ABAP programs or screens can be generated while a Support Package is being imported. The relevant programs are generated only when they are called. However, you can set up SPAM so that generation does occur when a Support Package is imported.

SPAM may return error messages during generation, for example, because a report written by the customer or a modification of an existing report has incorrect syntax and refers to an object that is imported as part of the queue.

It is usually best to ignore the generation error at first and then correct it after the Support Package has been imported.

Requirements
You are importing a Support Package.

Procedure
To make settings for the generation of ABAP programs and screens, choose *Extras* on the initial screen of SPAM.

<table>
<thead>
<tr>
<th>SPAM Functions</th>
<th>Menu Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch generation on and off</td>
<td>→ Settings</td>
</tr>
<tr>
<td>Ignore generation errors during import</td>
<td>→ Ignore generation errors</td>
</tr>
</tbody>
</table>
Errors in SPAM Steps

If an error is recognized in a step, the SPAM transaction stops the processing until the error is corrected. You can find out the reason the SPAM transaction was stopped and in which step by choosing Status.

Error Types

SPAM displays the following types of error messages:

1. Security checks for Transaction SPAM
   A typical example is the step OBJECTS_LOCKED?. If objects are still locked in requests that are to be overwritten by the queue, the SPAM transaction stops processing.

2. Error messages from the programs tp and R3trans
   You can always find the cause of the error in the relevant transport log. A typical example is the step TEST_IMPORT. A check is made to see whether there are unconfirmed repairs to objects that are to be overwritten by the queue. The relevant objects are listed in the test import log.

3. Incorrect configuration of the Change and Transport System
   Often the errors here are not having the relevant authorizations to files of the Change and Transport System, or using old program versions of tp or R3trans. Check the correct function of the transport tools by choosing Utilities → Check transport tool.

   A typical example is the step DISASSEMBLE. If <sid>adm does not have write authorization for the directory /usr/sap/trans/data (UNIX), SPAM stops at the step DISASSEMBLE with CANNOT_DISASSEMBLE_R_DATA_FILE.

   Transaction SPAM requires that the Change and Transport System [Ext.] is configured correctly.

You can find more information on known problems in the Notes 97630 and 97620.

Known Problems

PROLOGUE

In this step, a dialog box prompts you to confirm the import of the Support Package. If you are not authorized to execute the SPAM transaction or the current queue has not yet been confirmed, the SPAM transaction is stopped with a corresponding message.

CHECK_REQUIREMENTS

In this step, various requirements for the import of the Support Package are checked. The following messages explain why this step may be terminated:

- TP_CANNOT_CONNECT_TO_SYSTEM: tp cannot log onto the system’s database.
- QUEUE_NOT_EMPTY: There are incompletely processed OCS requests in the tp buffer.

   Use the following tp command to display these requests:
   tp SHOWBUFFER <SID> -D SOURCESYSTEMS= TAG=SPAM

   You can continue processing the queue as soon as these requests have been processed completely, or deleted from the tp buffer.

DISASSEMBLE
Errors in SPAM Steps

In this step, files from the corresponding OCS files are unpacked and stored in the directory `/usr/sap/trans/data` (UNIX). The command files (cofiles) from the accompanying files are generated and are stored in the directory `/usr/sap/trans/cofiles` (UNIX). The following messages explain why this step may be terminated:

- **CANNOT_SKIP_ATTRIBUTE_RECORD**: The attributes could not be read in the OCS file. The file cannot be opened for reading, because it may have been deleted in the meantime, or you do not have the correct authorizations at the operating system level.

- **CANNOT_DETERMINE_EPS_PARCEL**: The OCS file is not in the EPS Inbox, because it may have been deleted. You must load the appropriate Support Package again.

- **CANNOT_DETERMINE_DATA_FILES**: The name of a data file could not be determined, because a profile parameter was not correctly configured. Check the settings using the report RSPARAM.

- **CANNOT_DISASSEMBLE_R_DATA_FILE**: An R3trans data file could not be unpacked. Possible errors are that the relevant OCS file was not found, or the data file could not be opened to be written to. An error occurred when transmitting a 20K block from the EPS Inbox to the directory `/usr/sap/trans/data` (UNIX).

- **CANNOT_DISASSEMBLE_D_DATA_FILE**: An ADO data file could not be unpacked. The reasons are the same as for the message **CANNOT_DISASSEMBLE_R_DATA_FILE**.

- **CANNOT_CREATE_COFILE**: The cofile could not be created from the corresponding data file. One possible error is that `<sys>adm` does not have write authorization for the directory `/usr/sap/trans/cofiles` (UNIX). Check whether the data file was created. If it was not created, check that the option *Create new data file* is activated in the SPAM settings [Page 10].

For more information, see the Note 70752.

**ADD_TO_BUFFER**

In this step, the queue is placed in the transport buffer of your system. The following messages explain why this step may be terminated:

- **TP_INTERFACE_FAILURE**: The tp interface could not be called. There is an RFC error.

- **CANNOT_ADD_PATCH_TO_BUFFER**: A Support Package could not be included in the transport buffer. You can find more information in the SLOG log file in the directory `/usr/sap/trans/log` (UNIX).

- **CANNOT_MODIFY_BUFFER**: An unsuccessful attempt was made to modify the transport buffer.

**TEST_IMPORT**

In this step, the system checks if there are still objects in tasks which have not yet been released and are overwritten when the Support Package is imported. You can find the source of error in the log of the test import. For further information, see the Note 42379.

**IMPORT_OBJECT_LIST**

In this step, the object lists for the Support Packages in the queue are imported in the system. The following messages explain why this step may be terminated:

- **TP_INTERFACE_FAILURE**: The tp interface could not be called.
Errors in SPAM Steps

- **TP_FAILURE**: The program tp could not be executed. You can find more information in the SLOG and/or the ALOG log file.

- **COMMAND_FILE_IMPORT_FAILURE**: The object list for one or more Support Packages could not be imported. You can find the source of error in the log of the command file import.

**OBJECTS_LOCKED_?**

In this step, the system checks if there are still objects in requests which have not yet been released and are overwritten when the Support Package is imported. The following messages explain why this step may be terminated:

- **CANNOT_GET_OBJECT_LIST**: The object list for a Support Package could not be found, because the Support Package does not exist.

- **CANNOT_CHECK_LOCKS**: An error occurred when checking the locks of an object in the queue.

- **OBJECTS_LOCKED_IN_REQUESTS**: Objects were found that are still in requests that have not yet been released. Before continuing with the import of the Support Package, release these requests.

**SCHEDULE_RDDIMPDP**

In this step, the transport daemon (program RDDIMPDP) is scheduled. The following messages explain why this step may be terminated:

- **CANNOT_SCHEDULE_RDDIMPDP**: The job RDDIMPDP could not be scheduled. Call Transaction SM37 (job selection), enter the following parameters and then choose Continue:

<table>
<thead>
<tr>
<th>Job name</th>
<th>RDDIMPDP</th>
</tr>
</thead>
<tbody>
<tr>
<td>User name</td>
<td>&lt;User name&gt;</td>
</tr>
<tr>
<td>Trigger event</td>
<td>SAP_TRIGGER_RDDIMPDP</td>
</tr>
</tbody>
</table>

Select the job that was terminated and display the job log.

- Problems with the SAP lock mechanism: Call Transaction SM12 and make sure that there are no programs listed with the name RDDIMPDP. For more information, see the Note 11677.

**ADDON_CONFLICTS_?**

In this step, the system checks if there are conflicts between objects in the queue and installed add-ons. If there are any conflicts, SPAM terminates and asks you to import the relevant Conflict Resolution Transports (CRTs). The following messages explain why this step may be terminated:

- **CANNOT_GET_OBJECT_LIST**: The object list for a Support Package could not be determined, because the Support Package does not exist.

- **CANNOT_GET_LAST_UPGRADE_INFO**: The information about the last Repository switch upgrade could not be determined.

- **UNRESOLVED_ADDON_CONFLICTS**: Conflicts with add-ons could not be resolved, because the relevant CRTs are missing from the queue.

**SPDD_SPAU_CHECK**
Errors in SPAM Steps

In this step, the system checks if a modification adjustment is necessary (Transactions SPDD/SPAU).

**DDIC_IMPORT**

In this step, the ABAP Dictionary is imported. The following messages explain why this step may be terminated:

- **TP_INTERFACE_FAILURE**: The tp interface could not be called.
- **TP_FAILURE**: The program tp could not be executed. You can find more information in the SLOG and/or the ALOG log file.
- **CANNOT_IMPORT_DDIC**: The ABAP Dictionary could not be imported. You can find the source of error in the Dictionary import log.

**AUTO_MOD_SPDD**

In this step, the system checks if modifications to the ABAP Dictionary objects can be adjusted automatically.

**RUN_SPDD_?**

In this step, you are asked to adjust your modifications to the ABAP Dictionary objects by calling Transaction SPDD.

**IMPORT_PROPER**

In this step, the Repository including all table entries is imported. The following messages explain why this step may be terminated:

- **TP_INTERFACE_FAILURE**: The tp interface could not be called.
- **TP_FAILURE**: The program tp could not be executed. You can find more information in the SLOG and/or the ALOG log file.
- **TP_STEP_FAILURE**: A tp step could not be performed successfully. You can find the source of error in the relevant log, for example, in the import or generation log. If the generation is terminated (tp step G), you can correct the error either immediately or after the import of the Support Package. In the second case, you must perform the following steps:
  1. To ignore the generation errors, choose Extras → Ignore gen. errors.
  2. Continue importing the Support Package.

Generation errors can also be caused by buffer synchronization problems. For more information, see the Note 40584.

If a tp step is listed in a termination message, it concerns a step that is independent of the transport request. The step’s log cannot be displayed using the pushbutton Log. In this case, analyze the following files:

- **tp step 6**: P<YY><MM><DD>.<SID>
- **tp step N**: N<YY><MM><DD>.<SID>
- **tp step S**: DS<YY><MM><DD>.<SID>

All the logs are located in /usr/sap/trans/log. You can display them using the report RSPUTPRT or Transaction AL11.
AUTO_MOD_SPAU

In this step, the system checks if modifications can be adjusted automatically.

RUN_SPAU_?

In this step, you are asked to adjust your modifications to the Repository objects by calling Transaction SPAU.

EPILOGUE

In this step, the import of the Support Package is ended. The system checks if the queue has been completely processed. In this case, there should be no more transport buffer entries for the queue. The following messages explain why this step may be terminated:

- **TP_INTERFACE_FAILURE**: The tp interface could not be called.
- **TP_FAILURE**: The program tp could not be executed. You can find more information in the SLOG and/or the ALOG log file.
- **QUEUE_STILL_IN_BUFFER**: The queue has not been processed completely, since there are still incomplete Support Packages of the queue in the transport buffer.
- **CANNOT_RESET_FCS_FLAG**: If there is an FCS Support Package (FFD) in the queue, the system is flagged as having the General Availability release after it is imported. In this case, this operation could not be successfully performed.
Resetting the Status of a Support Package

Use
If you have to reimport a Support Package because errors occurred or a SPAM update is necessary, then reset its status.

⚠️
Resetting the status does not mean that the system has the old status. If you reset the status after objects have already been imported (for example, after an error in step DDIC_IMPORT), your system will be inconsistent. Only reset the status if you need to correct errors. Continue the import as soon as possible.

Procedure
To reset a Support Package or a queue, choose Extras → Reset status.

Result
The corresponding entries are deleted in the cofile and in the log file after the status has been updated. You have to completely import the Support Package again. Transaction SPAM starts the import with the step CHECK_REQUIREMENTS [Page 26].
Deleting the Queue

Use
If you have already defined a queue, but the queue is not what you require or errors have occurred, you can delete this queue.

If you delete the queue after objects have already been transported (for example, after an error in step DDIC_IMPORT), your system is inconsistent. Only delete the queue in these SPAM steps to correct errors, and then import the Support Packages again as soon as you can.

Note that, as of SPAM/SAINT Version 11, you **cannot** delete the queue once you have reached the step DDIC_IMPORT.

Procedure
1. In the initial screen of Transaction SPAM, choose Display/define. A dialog box appears displaying the current queue.
2. Choose the Delete queue icon.

Result
The queue has been deleted. You can now define a new queue.