Internal Orders (CO-OM-OPA)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>☢️</td>
<td>Caution</td>
</tr>
<tr>
<td>📚</td>
<td>Example</td>
</tr>
<tr>
<td>💡</td>
<td>Note</td>
</tr>
<tr>
<td>⚙️</td>
<td>Recommendation</td>
</tr>
<tr>
<td>🔥</td>
<td>Syntax</td>
</tr>
</tbody>
</table>
Inhalt

Internal Orders (CO-OM-OPA) ............................................................................................................................. 9
Internal Orders.......................................................................................................................................................... 9
Master Data ............................................................................................................................................................ 13
Master Data Maintenance In The Intranet .................................................................................................................. 14
   Creating An Internal Order In The Intranet ........................................................................................................ 15
   Creating An Internal Order................................................................................................................................. 16
   Displaying Master Data For An Internal Order In The Intranet ..................................................................... 17
   Displaying Internal Orders .................................................................................................................................. 19
   Adapting The Internal Order Form .................................................................................................................... 20
   Web Application Builder................................................................................................................................... 21
      Creating HTML Templates ............................................................................................................................ 23
      Extending HTML Templates ........................................................................................................................ 26
   Adding MIME Objects......................................................................................................................................... 28
   Requesting a Master Data Change in the Intranet/Internet (AC) ....................................................................... 30
   Processing Request Forms .................................................................................................................................. 33
   Processing a Request in the SAP System............................................................................................................ 36
      Processing Notifications .................................................................................................................................. 37
      Process Notification ......................................................................................................................................... 38
      Processing Notifications Using Worklist ...................................................................................................... 40
   Task Processing ................................................................................................................................................ 41
      Processing Tasks Using Worklist ...................................................................................................................... 42
      Processing Tasks Using Workflow ................................................................................................................ 43
   Status Query For Request .................................................................................................................................. 44
Order Manager And Collective Processing Of Master Data Changes .............................................................................. 45
   Working In The Order Manager.......................................................................................................................... 48
   Changing Master Data In Collective Processing................................................................................................ 50
   Creating an Internal Order ................................................................................................................................... 53
Structuring Layouts .................................................................................................................................................. 54
   Order Layout in the Standard................................................................................................................................ 55
Status Management in Internal Orders .......................................................................................................................... 58
   General SAP Status Management..................................................................................................................... 60
   Order Status Management.................................................................................................................................. 63
Order Group .................................................................................................................................................................. 68
   Master Data Groups........................................................................................................................................... 70
   Creating or Changing Master Data Groups ......................................................................................................... 71
   Processing Master Data Groups .......................................................................................................................... 73
   Copying Master Data Groups ............................................................................................................................ 75
      Example: Copying the Cost Center Standard Hierarchy .................................................................................. 78
Work Breakdown Structure or Internal Order Distribution .......................................................................................... 79
Transferring Old and External Data.................................................................................................................................. 83
   Old or External Data Transfer ............................................................................................................................. 86
   Example: Filled Sender Structure ....................................................................................................................... 87
Planning ..................................................................................................................................................................... 92
   Short-Term Business Planning........................................................................................................................... 95
Currencies in Planning ............................................................................................................... 97
Integrated Planning for Internal Orders ..................................................................................... 100
   Integrated Planning Indicator in Versions ........................................................................... 103
   Copying Planning ............................................................................................................... 106
   Notes on ............................................................................................................................ 108
   Notes on Copying Planning ............................................................................................. 109
Manual Internal Order Planning ............................................................................................... 110
   Overall Planning for Internal Orders .................................................................................. 112
   Manual Cost Planning in the Work Breakdown Structure .................................................. 115
   Cost Planning ..................................................................................................................... 118
   Presenting Planning Values ............................................................................................... 119
   Entering Planning Texts ..................................................................................................... 121
   Cost Element and Activity Input Planning (Detail Planning) ............................................... 122
   Copying Views .................................................................................................................. 123
   Checking Cost Planning ..................................................................................................... 124
   Planning Annual Values .................................................................................................... 125
   Plan Line Items .................................................................................................................. 126
   Unit Costing ....................................................................................................................... 128
   Planning Primary Costs and Revenues .............................................................................. 129
      Performing Primary Cost Planning and Revenue Planning ........................................... 131
   Resource Planning .............................................................................................................. 132
      Pricing .............................................................................................................................. 134
      Resource Planning ........................................................................................................... 136
      Revaluating Resource Planning ...................................................................................... 137
   Planning Activity Input ....................................................................................................... 138
   Planning Statistical Key Figures ....................................................................................... 139
   Planning Statistical Key Figures ....................................................................................... 140
   Executing Manual Planning ............................................................................................... 141
   Techniques for Supporting Manual Planning ...................................................................... 144
      Flexible Selection of Planning Screens ........................................................................ 145
   Planning Screen Layout ..................................................................................................... 148
      Planner Profiles ............................................................................................................... 150
      Planning Layouts .............................................................................................................. 152
      Standard Planning Layouts ............................................................................................ 153
      Structuring Planning Layouts .......................................................................................... 164
      Defining Planning Layouts ............................................................................................. 166
      Distribution Keys ........................................................................................................... 167
      Standard Distribution Keys ............................................................................................ 168
Easy Cost Planning for Internal Orders .................................................................................. 170
   Editing Costing Models and Assigning Attributes .............................................................. 173
   Creating and Assigning Characteristics ............................................................................ 178
   Structuring the Entry Screen .............................................................................................. 180
   Defining Derivation Rules ................................................................................................. 182
      Template for Easy Cost Planning .................................................................................. 183
Periodic Allocations in Planning ............................................................................................ 185
   Periodic Reposting in Planning .......................................................................................... 186
   Planning Overheads ........................................................................................................... 187
   Planned Settlement for Internal Orders .............................................................................. 188
   Cost Center Allocations (Plan) ......................................................................................... 190
## Availability Control .................................................................................................................... 252

- Assigned Value In Internal Orders ................................................................. 254
- Assigned Value In Projects ............................................................... 255
- Entering Settings For Availability Control ........................................ 256
- Basic Settings for Availability Control in Budget Profile ................ 257
- Specifying Tolerance Limits ............................................................... 258
- Availability Control Actions ................................................................. 260
- Transaction Group ............................................................................ 261
- Activating Availability Control ........................................................... 263

## Budget Management ................................................................................................................. 192

- Budget Management for Internal Orders ........................................ 194
- Budgeting in More Than One Currency ......................................... 195
- Budget Allocation Prerequisites ....................................................... 198
- Allocating Original Budget ............................................................... 199
- Transferring Cost Planning Values As Budget .............................. 200
- Manual Distribution of Budgets ....................................................... 202
- System Status: Budgeted ................................................................. 203
- Totaling up Budget Values ............................................................... 204
- Revaluating Budget Values ............................................................... 205
- Entering Budget Texts .......................................................... 206
- Budget Value Display .............................................................. 208
- Copying Views ................................................................. 210
- Checking Budgeting .............................................................. 211
- Saving Without Checks .............................................................. 213
- Distributing Annual Budgets ......................................................... 214
- Displaying Budget Line Items ......................................................... 215
- Budget Updates ............................................................. 216
- Budget Supplement .......................................................... 218
- Making Budget Supplements in Projects .................................... 219
- Making Budget Supplements to Projects .................................. 220
- Budget Returns .......................................................... 222
  - Making Budget Returns in Projects ......................................... 224
  - Making Budget Returns From Projects .................................. 225
- Budget Transfer Posting ............................................................... 226
- Run Budget Update Reports ........................................................ 230
- Releasing The Budget .............................................................. 231
- Budget Carryforward .............................................................. 234
- Request For Budget Increase In The Intranet ................................ 236
- Special Fields In The Form .......................................................... 239
- Customizing Settings For Form Fields ........................................ 242
- Form For The Approving Manager Or Processor ....................... 244
- Task Processing ........................................................................... 245
- Processing Tasks Using Worklist ............................................... 246
- Processing Tasks Using Workflow ................................................ 247
- Document Flow ........................................................................... 248
  - Displaying the Document Flow for a Notification .................... 250
- Status Query ................................................................................. 251

## Task Processing ............................................................................................................... 245

- Processing Tasks Using Worklist .................................................. 246
- Processing Tasks Using Workflow ................................................ 247
- Document Flow ........................................................................... 248
  - Displaying the Document Flow for a Notification .................... 250
- Status Query ................................................................................. 251

## Budget Value Display ........................................................................................................ 208

- Entering Budget Texts .............................................................. 206
- Revaluating Budget Values ........................................................... 205
- Totaling up Budget Values ........................................................... 204
- System Status: Budgeted ............................................................... 203

## System Status: Budgeted ......................................................................................... 203

- Allocating Original Budget ............................................................... 200
- Transferring Cost Planning Values As Budget .............................. 200

## Transferring Cost Planning Values As Budget ..................................................... 200

- Manual Distribution of Budgets ....................................................... 202
- System Status: Budgeted ................................................................. 203
- Totaling up Budget Values ............................................................... 204
- Revaluating Budget Values ............................................................... 205
- Entering Budget Texts .............................................................. 206
- Budget Value Display .............................................................. 208
- Copying Views ................................................................. 210
- Checking Budgeting .............................................................. 211
- Saving Without Checks .............................................................. 213
- Distributing Annual Budgets ......................................................... 214
- Displaying Budget Line Items ......................................................... 215
- Budget Updates ............................................................. 216
- Budget Supplement .......................................................... 218
- Making Budget Supplements in Projects .................................... 219
- Making Budget Supplements to Projects .................................. 220
- Budget Returns .......................................................... 222
  - Making Budget Returns in Projects ......................................... 224
  - Making Budget Returns From Projects .................................. 225
- Budget Transfer Posting ............................................................... 226
- Run Budget Update Reports ........................................................ 230
- Releasing The Budget .............................................................. 231
- Budget Carryforward .............................................................. 234
- Request For Budget Increase In The Intranet ................................ 236
- Special Fields In The Form .......................................................... 239
- Customizing Settings For Form Fields ........................................ 242
- Form For The Approving Manager Or Processor ....................... 244
- Task Processing ........................................................................... 245
- Processing Tasks Using Worklist ............................................... 246
- Processing Tasks Using Workflow ................................................ 247
- Document Flow ........................................................................... 248
  - Displaying the Document Flow for a Notification .................... 250
- Status Query ................................................................................. 251
Internal Orders (CO-OM-OPA)

Purpose

Internal orders are normally used to plan, collect, and settle the costs of internal jobs and tasks. The SAP system enables you to monitor your internal orders throughout their entire life-cycle; from initial creation, through the planning and posting of all the actual costs, to the final settlement and archiving:

Implementation Considerations

Order management within a company usually differentiates between sales-oriented orders, and internal orders. Sales-oriented orders (production or sales orders) are intended mainly for the logistical control of input factors and sales activities. Internal orders are categorized as either:

- Orders used only for monitoring objects in Cost Accounting (such as, advertising or trade fair orders)
- Productive orders that are value-added, that is, orders that can be capitalized (such as in-house construction of an assembly line).

Internal order management is the most detailed operational level of cost and activity accounting. It can be used for:

- **Cost monitoring**, for example, where costs need to be looked at from object-related aspects, unlike in Cost Element Accounting or Cost Center Accounting
- **Assisting decision-making**, when you need to decide between in-house production and external procurement

An enterprise’s internal orders can be used for different controlling purposes. For more information, see [Classified by Controlling Objectives](#).

Features

- You can use [master data](#) to assign certain characteristics to your internal orders, which enables you to control which business transactions can be used with the internal order.
- **Internal order planning** enables you to roughly estimate the costs of a job before the order starts and to make an exact calculation at a later date. You can choose between various planning approaches to compare the effectiveness of different methods.
- You can assign and manage [budgets](#) for internal orders.
- You apply the actual costs incurred by a job to your internal orders using [actual postings](#). In Financial Accounting, you can assign primary cost postings (such as the procurement of external activities and external deliveries) directly to internal orders.
- In [period-end closing](#) you can use various different allocation methods (for example, overhead costing) to allocate costs between different areas of Cost Accounting.
  - **Order settlement** enables you to transfer the costs incurred by an order to the appropriate receivers.
- The [information system for internal orders](#) enables you to track planned and assigned costs on your orders in each stage of the order life-cycle.
You can archive internal orders that you no longer require. See Archiving [Seite 420].
Internal Orders

Definition
An internal order is used to monitor parts of the costs, and under certain circumstances, the revenues of the organization.

Use
You can create an internal order to monitor the costs of a time-restricted job or the costs (and revenues, if required) for the production of activities. Internal orders can also be used for the long-term monitoring of costs.

- **Overhead cost orders [Extern]** are used for the time-restricted monitoring of overhead costs (that are incurred when you execute a job) or for the long-term monitoring of parts of the overhead costs.
- **Investment orders [Extern]** let you monitor investment costs that can be capitalized and settled to fixed assets.
- **Accrual orders [Extern]** enable you to monitor period-related accrual calculation between expenses posted in Financial Accounting and the costing-based costs debited in Cost Accounting.
- **Orders with revenues [Extern]** let you monitor costs and revenues that are incurred for activities for external partners, or for internal activities that do not form part of the core business for your organization.
- **You can use model orders [Extern]** as a reference, when creating new internal orders.

You can find further information on the internal order types mentioned above, in **Orders Classified by Content [Extern]**.

Integration
You can use the following transaction-related postings on internal orders for the allocation of costs between different areas of cost accounting:

- **Repostings of Primary Costs and Revenues**
  - **Repostings [Extern]** enable you to repost primary costs, which you had previously assigned to a given internal order in Financial Accounting. They also enable you to refine the original assignment (true to the cost element) to other internal orders, or to repost cost centers.

- **Direct Internal Activity Allocations**
  - The system posts internal activities (such as those supplied by the cost center) to the internal order that received the activity, using the corresponding **activity type [Extern]**.

- **Creating Statistical Key Figures**
  - **Statistical key figures [Extern]** on internal orders are for information purposes only.
    - For example, if you want to post all the costs incurred for a trade fair to a trade fair order, you create statistical key figures for the following:
Internal Orders

- The number of visitors to your trade stand,
- Requests for further meetings
- The total number of orders arising from your trade fair participation.

**Funds Commitments**

This function allows you to enter costs, which you know will definitely occur, but you do not yet know through which transaction they will be caused (for example, purchase order, material reservations, and so on).

You can thus reserve parts of the order budget at an early stage.

For more information on funds commitment, see Commitments Management [Extern].

**Allocation of Overhead Costs**

You can allocate overhead costs to internal orders using overhead calculation [Seite 393] or cost center assessment.

For more information on allocations, see Manual Actual Postings [Extern].
Master Data

Use

Master data [Extern] is partly used for system-technical purposes, and partly for business purposes. It either does not change at all, or only insignificantly during the life of an internal order.

You use the master data to define the attributes of an internal order, such as:

- Its purpose (using the Order Type [Extern])
- The processing possibilities (using Status Management [Seite 58] and the allowed or prohibited Business Transactions [Extern] per status)

Features

For more information on the classification of order master data, see Structuring the Order Layout [Seite 54].

You can print master data for internal orders, using forms adaptable to your needs. For more information, see the implementation guide (IMG), under Controlling → Internal Orders → Order Master Data → Prepare for Order Printing [Extern].

See also:

Creating an Internal Order [Seite 53]

You can maintain master data in the intranet as well as in the SAP R/3 System.

More information is available in Maintaining Master Data in the Intranet [Seite 14].
Master Data Maintenance In The Intranet

You can maintain master data in the intranet as well as in the SAP R/3 System.

You can:

- Create internal orders in the intranet [Seite 15]
- Enter master data [Seite 17]
- Change master data for internal orders in collective processing [Seite 45]
- Apply for master data changes in the intranet [Seite 30]
- Structure the internal order form in the intranet with the SAP@WEB-Studio or with the web application [Seite 20]
Creating An Internal Order In The Intranet

Use

In the intranet you enter the main master data fields for an internal order. The remaining data is provided by a model or template order stored in the order type.

Prerequisites

When you create an internal order, all the fields that you removed from an HTML template must be filled by a model order stored in the order type. Ensure that a valid internal order can be created using the combination of the model order and the remaining master data fields that can be maintained.

Features

You have all the same options when creating an internal order in the intranet as you do when creating it in the SAP R/3 System.

You go to the master data maintenance from the initial screen.

In the master data maintenance, you can go to the following places:

- Request for master data change
  - For more information on requests for master data changes, see the SAP Library under Financials → Controlling → Internal Orders → Master Data For Internal Orders → Master Data Maintenance In The Intranet → Request For Master Data Change In The Intranet [Seite 30].
- Cost analysis
- A customer function
- A Real Estate object
- An asset under construction
- Create a completed asset

You are working in the intranet environment with a form that you can adapt to your requirements in the SAP@WEB-Studio or in the web application builder.

For more information, see: Adapting An Internal Order Form [Seite 20].

See also:

Entering Master Data For An Internal Order In The Intranet [Seite 17]
Creating An Internal Order

1. Enter an order type or choose an order as a reference.
2. Choose Master data
   The form is filled with data according to the order type or reference order selected.
3. Enter an explanatory long text.
4. The white fields are ready for input.
   In the Status group box, you can:
   • Change the system status from Release to Technically completed.
   • Set or reset a lock on the user status with Set/Reset.
5. Save your entries.

In the master data for each internal order, you can store a costing model instead of a unit costing by choosing Extras → Costing.
For more information, see the SAP Library under Financials → Controlling → Product Cost Controlling → Processing Costing Variants And Assigning Attributes [Seite 173].
Displaying Master Data For An Internal Order In The Intranet

**Use**

Unlike the tab page display in the SAP System, the transaction in the intranet is form-based.

**Features**

From the initial screen, you can go to the following:

- Master data maintenance
- Request for master data change
- Cost analysis

In the master data maintenance, you can go to the following places:

- Request for master data change
  
  For more information on requests for master data changes, see the SAP Library under Financials → Controlling → Internal Orders → Master Data For Internal Orders → Master Data Maintenance In The Intranet → Request For Master Data Change In The Intranet [Seite 30].

- Cost analysis
- A customer function
- A Real Estate object
- An asset under construction
- Create a completed asset

As well as displaying, you can do the following:

- Enter long texts
- Change the user or system status
  
  For more information on status management, see: Status Management [Seite 30] For Internal Orders.

- Lock or unlock internal orders

💡

You can go to Execution Services [Extem] as well as to objects linked to internal orders.

For more information, see the SAP Library under Financials → Controlling → Product Cost Controlling → Product Cost Planning → Easy Cost Planning and Execution Services [Extem].

You can create the entry form layout by processing the HTML output page in the SAP@WEB-Studio, where you can define the appearance of the form according to your requirements. This processing replaces the traditional Customizing.
Displaying Master Data For An Internal Order In The Intranet

You can now make any more master data changes in the intranet or the KO04 transaction. For more information, see: Collective Processing Of Master Data Changes [Seite 45].

If you do not have authorization to change master data, you can create a request for master data changes.
For more information, see: Adapting An Internal Order Form [Seite 20].

See also:

Creating An Internal Order In The Intranet [Seite 15]
Displaying Internal Orders

Enter an order number.

To display the master data for this order, choose Master data.
The form contains entries depending on the selected order type or reference order.

a. Enter an explanatory long text
b. You can make entries in the fields that have a white background
c. In the status group box, you can change the system status from released to technically completed.
d. You can set or undo a lock using Set/reset.
e. Save your entries.

To change the master data for this order, choose Change order.
This takes you to the request for master data change.
For more information, see the SAP-Library under Financials → Controlling → Internal Orders → Master Data For Internal Orders → Master Data Maintenance In The Intranet → Requesting Master Data Change.

To display a list of the costs incurred on this order, choose Cost Analysis.
This takes you to a overall cost report that lists the costs incurred on the internal order during the entire runtime.

For more information on overall cost reports, see the SAP Library under Financials → Controlling → Internal Orders → Information System For Internal Orders → Report Types For Internal Orders → Overall Cost Reports.
Adapting The Internal Order Form

Use
To adapt the internal order form to your requirements, choose this function.

Activities
You use the SAP@WEB-Studio and the web application builder in the ABAP workbench to create your internal order form. This processing replaces the traditional Customizing.

For more information on adaptation tools, see the SAP Library under:
- Basis → BC-ABAP Workbench → Integration of Internet Services → Web Application Builder [Seite 22]
- Basis → SAP-Internet Applications → SAP@Web Studio [Extern]

You can use the CO_ORDER_EDIT and CO_ORDER_CRT services provided by SAP as templates for your layouts. They can be used to edit and enter the order master data in the KAUF development class respectively.

Copy the required service in the ABAP workbench, to a development class in the customer namespace, then create a theme.

To create an HTML template for the theme, enter the following in the initial screen:
- Screen no. 0115 to display the master data.
- Screen no. 0116 to create the master data.

Enter screen no. 0695 from the SAPMKAUF program for the detail screen.

The CO_ORDER_EDT_E and CO_ORDER_CRT_E services provided by SAP contain a predefined possible layout for the templates.

The Internet Transaction Server [Extern] [ITS] portrays changed and published HTML templates without the F4 help. However, templates that were generated dynamically from a transaction screen do have F4 help.

If you require F4 help on the initial screen, then do not change or publish screens 115 and 116. Instead, change and publish only detail screen no. 695.

Alternatively, you can create initial screen templates in which you then call up an existing worklist from the IST using the HTML business function. In the web application builder in the ABAP workbench, you can make simple changes to the template source text, then save and publish it.

If you want to make bigger changes, import the service to a project in the SAP@Web-Studio. The template created in the ABAP workbench consists of the descriptions for the screen elements in business HTML. Alternatively, you can generate a template consisting of standard HTML only in the SAP@Web-Studio using a file wizard for a service generated without template. This would be very simple, and may not meet all requirements, but contains a screen that is easier to change and portray.
Links
On a changed and published service, you can create a link to provide access to it (for example, to the work place). The query string for the link must contain the CO_ORDER_EDIT and CO_ORDER_CRT forms.
You can now use a link to refer to interfaces with different layouts in the same transaction, which have different themes.
To skip the initial screen, you need to provide the link with the necessary parameters for the initial screen.

You can use the query link http://<Enter your ITS server here>/scripts/wgate/co_order_crt/!?~okcode=mast&order_master-order_type=0100

to go directly to another link on the detail screen to create an order for order type 0100.

Result
You created an internal order according to your requirements without using Customizing.
Web Application Builder

Purpose
The Web Application Builder allows you to create Web development objects within the ABAP Workbench. Existing R/3 transactions require these objects to allow them to run as Web transactions in a Web Browser. You can also use the Web Application Builder as an integrated environment for creating MiniApps.

Integration
The Web Application Builder is a fully integrated tool within the ABAP Workbench. Objects that you create with it, such as service files, HTML templates, and MIME objects, are stored in the R/3 Repository and are connected to the R/3 Change and Transport System.

Features
- Creating Internet services for existing R/3 transactions or MiniApps.
- Implementing the dialog logic.
- Generating the HTML templates for the screens of a transaction. These contain standard HTML and HTML Business statements that map the screen layout.
- Editing the generated HTML templates using HTML and HTML Business to develop them further.
- Including MIME objects (icons, graphics, Java applets, animation...) to improve the layout further.
- Creating language-specific texts (language resources).
- Publishing the services or individual service components on the Internet Transaction Server (ITS)
- Executing the complete Web transaction from the ABAP Workbench.
- Connection to the Change and Transport System (CTS).
- Connection to Version Management.

Constraints
Certain functions are not yet available:
- There is no syntax check
- HTML Business and the flow logic are not yet integrated with the Debugger.
Creating HTML Templates

Use

When you implement a MiniApp, you must create HTML templates. The dialog logic of a MiniApp runs on the ITS, not in R/3.

For each transaction, you can choose whether you want to generate HTML templates for all screens, for some screens (mixed mode [Extern]), or at all. Templates that you create explicitly are identical to the HTML documents that are generated automatically by the WebGUI.

Generating templates explicitly is useful if the WebGUI features are insufficient for your needs and you would need to adapt the standard generated template anyway. This will particularly be the case if you are trying to improve the layout of a screen or if you want to include hyperlinks.

Standard template generation from the WebGUI should be sufficient for most transactions. The WebGUI can display the screen elements of a simple transaction (text fields, input/output fields, checkboxes, radio buttons, tabstrip controls, table controls, subscreens...) without you having to go to the effort of creating a template.

Prerequisites

- You must already have created the service.
- You have sufficient knowledge of HTML and HTML Business to take advantage of the template-based approach.

Procedure

To create an HTML template from the tree display in the object list:

1. Right-click the name of the service.
2. From the context menu, choose Create → Template.
   
   The Create Template dialog box appears.
3. Enter the theme for the service and fill out the remaining fields.

   If the Web application is a Web transaction and you want to generate a template for a particular screen, select Generate HTML from screen and enter the program name and screen number.

   If the application has no corresponding R/3 screen (MiniApps), select Name of template and enter the name.
4. Confirm by choosing Save.

   The Create Object Catalog Entry dialog box appears.

5. Assign the template to a development class and choose.

**Result**

The generated template appears in the object list under Templates. The generated contents of the template are displayed in the Editor. Only the static screen information is evaluated - an HTML function is inserted in the template for each screen element. These are highlighted in blue. You can now change the contents of the template using standard HTML and HTML Business.
Creating HTML Templates

See also:

Extending HTML Templates [Seite 26]
Adding MIME Objects [Seite 28]
Publishing Services [Extern]
Extending HTML Templates

Once you have created an HTML template, you can change the generated source code. To do this, you must be familiar with the basics of HTML and HTML\textsuperscript{Business}.

HTML\textsuperscript{Business} is an extension of standard HTML developed by SAP to allow R/3 screen data to be merged dynamically with information on HTML templates and to make it easier for the ITS to exchange data between the R/3 System and the Web Server.

For further information, refer to HTML\textsuperscript{Business} Reference [Extern].

Example

This example sets a hyperlink to a particular position on an HTML page:

```
'SAP_DynproLayerBegin(003,012,029,003)'
'SAP_DynproGroupBegin("%#AUTOTEXT002")'
'SAP_DynproGroupEnd("%#AUTOTEXT002")'
'SAP_DynproLayerEnd()'

'SAP_DynproLayerBegin(006,013,009,001)'
'SAP_Button("PUSH1")'
'SAP_DynproLayerEnd()'

'SAP_DynproLayerBegin(020,013,008,001)'
'SAP_Button("PUSH2")'
'SAP_DynproLayerEnd()'

'SAP_FormEnd()'
'SAP_BodyContentEnd()'

'SAP_DynproLayerBegin(006,002,011,001)'
'<a href="http://workbench:1980" style="color: rgb(187,0,0)">Workbench No</a>'
'SAP_DynproLayerEnd()'
```

See also:
Extending HTML Templates

Publishing a Service [Extern]
Adding MIME Objects [Seite 28]
Adding MIME Objects

Use
You can use MIME objects (icons, graphics, audio files, animations...) to improve the layout of your Web applications.

Prerequisites
You must already have created an Internet service.

Procedure
To add a MIME object to an Internet service from the object list:
6. Right-click the relevant service.
7. In the context menu, choose Create → Mime.

The Read from Local File dialog box appears:
8. Enter the path name of the file you want to import, and ensure that the file format is correct.
9. Choose Import.

The Create Mime dialog box appears.
10. Enter the theme and the name for the MIME object.
11. In the Name field, you can create a subdirectory, separated from the name of the MIME object by a forward slash ("/").

12. Choose to continue.

The Create Object Catalog Entry dialog box appears.
13. Assign the MIME object to a development class and choose .
**Result**

The MIME object has been inserted in the R/3 Repository as a standalone object. It appears under Mimes in the object list display, and, if it is a graphic, its contents are displayed.

You can now use this object in your interface design.

💡

When you publish the service, the MIME objects are not stored in an ITS directory. Instead, they are stored on the HTTP server under the name and subdirectory you specified in step 5 above.

**See also:**

[Publishing Web Applications](#)
Requesting a Master Data Change in the Intranet/Internet (AC)

Purpose

You can request the change to the following master data from the Intranet/Internet:

<table>
<thead>
<tr>
<th>Object</th>
<th>Type of change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost centers [Extern]</td>
<td>create, change, lock</td>
</tr>
<tr>
<td>Internal orders [Extern]</td>
<td>date</td>
</tr>
<tr>
<td>G/L accounts [Extern]</td>
<td>create, change</td>
</tr>
<tr>
<td>Vendors [Extern]</td>
<td>Address change</td>
</tr>
<tr>
<td></td>
<td>Enter, delete, change bank details</td>
</tr>
<tr>
<td>Customers [Extern]</td>
<td>Address change</td>
</tr>
<tr>
<td></td>
<td>Enter, delete, change bank details</td>
</tr>
</tbody>
</table>

You can only request changes to master data for customers and vendors via the Internet.

You do not have to know the name of the processor, since the system automatically determines it. The request is transferred to the SAP System and can be processed there with the functions of the message processing.

You can call up the individual request forms from the various SAP application (depending on the object) and from the workplace.

<table>
<thead>
<tr>
<th>Start change request</th>
<th>for &lt;Object&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>From the Employee Workplace [Extern] launchpad</td>
<td>Cost centers, internal orders, G/L accounts, customers, vendors</td>
</tr>
<tr>
<td>From the Enterprise Organization [Extern]</td>
<td>Cost centers</td>
</tr>
<tr>
<td>From Editing the standard hierarchy [Extern]</td>
<td>Cost centers</td>
</tr>
<tr>
<td>From the cost center master data report [Extern]</td>
<td>Cost centers</td>
</tr>
<tr>
<td>From the web transaction Create internal order [Seite 15]</td>
<td>Internal orders</td>
</tr>
<tr>
<td>From the web transaction Display internal order [Seite 17]</td>
<td>Internal orders</td>
</tr>
<tr>
<td>From Editing G/L account master data individually [Extern]</td>
<td>G/L accounts</td>
</tr>
</tbody>
</table>

Prerequisites

- In a scenario, you have defined the process for request a master data change.
  
  To do so, in Customizing choose Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific
Requesting a Master Data Change in the Intranet/Internet (AC)

Customizing → Request For Change to Master Data → Define Own Scenarios For Request For Change To Master Data [Extern].

- For cost centers and G/L accounts, you have determined which requests can be started from the aforementioned SAP applications.

  To do so, in Customizing choose (for example) Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing → Request For Change to Master Data → Assign Own Scenarios For the Request For Change To Master Data [Extern].

Process Flow

1. You call up the request form for a master data change.
   a. To call up the form from the Employee Workplace launchpad, choose Create internal service request.
   b. To call up the form from the SAP System, for the application choose Extras Change request for <object>.

   In the master data directory, specify that a cost center has to be changed.
   From the directory, you can go to the request form for master data changes by choosing Extras → Change request for cost centers.

2. You request a change to or a new master record using the form in the Intranet/Internet (see Processing Request Forms [Seite 33]).

   When you send the request, the information is transferred to the SAP R/3 System. The system determines the responsible processor based on entries made in Customizing (see Define Own Scenarios For The Request For Change to Master Data [Extern]).

3. The processor receives the request for a master data change in his/her worklist or workflow inbox (see Task Processing [Seite 245]).

4. The following options are available to the processor:
   a. They may require additional information, should the request be incomplete. They attach a note to the requests and enter the person making the request as the processor.
   b. The processor rejects the request for a master data change.
   c. They approve the request and makes the necessary adjustments in the SAP R/3 System.
   d. They forward the request.

   In the second decision level, the options a to d are available again.

   In the last three cases, the processor can enter a text to explain the reason for his/her decision.

   You can check the current state of the request at any time (see Status Query of a Request [Seite 44]).
Requesting a Master Data Change in the Intranet/Internet (AC)

Request for Master Data Change

Result
The master data change is either completed or the request is rejected.

For more information, see the SAP Library under Cross-Application Components → Internal Service Request [Extern].
Processing Request Forms

Use
With a request form, you can request a master data change from the Intranet/Internet.
The standard system comes with predefined formulas with which you can request changes to
various objects. This form is divided into various areas, but you can adjust the layout and the
individual fields individually.

Prerequisites
- You defined in Customizing which fields are to be available on the form.
  For more information, see Cross-Application Components → Internet/Intranet Services →
  Definition of Scenarios With Specific Customizing → Request For Master Data Change
  → Define Own Scenarios For The Request For Master Data Change [Extern]
- You have defined the layout of the form
  a. Using the SAP@Web Studios [Extern]
  b. Using the Web Application Builder [Seite 22] in the ABAP Development Workbench
- If you access the form via Create an Internal Service Request from the launchpad of the
  Employee Workplace, you first have to select the right request from, such as a request for a
  new cost center or a change to customer bank details (see Creating an Internal Service
  Request [Extern]).
Processing Request Forms

Procedure

1. Enter the data for the object.

   For the request Create a new cost center, your are required to make the following entries:
   - Controlling area
   - Cost center key
   - Valid from ... to
   - Name
   - Responsible person

   For the request Change an existing cost center, your are required to make the following entries:
   - Controlling area
   - Cost center key
   - Valid from ... to

2. Enter a text to describe the problem.

   This is an optional entry.

3. If you know the name of the processor for this problem, enter it in the processor field.

   If a processor or a standard role was entered in Customizing, these fields contain the corresponding entries. The partner role setting in Customizing controls whether an individual employee or a department is entered as the problem processor. You can find additional information about roles in Defining Roles based on Responsibilities [Extern].

   If an entire department was entered in Customizing as the processor, you cannot overwrite the Processor field. The system displays a list of the processors.

4. The fields for Created by contain your data.

5. If you make the request on behalf of someone else (for example, for a colleague or boss), you can also list the initiator.

   The processor of the request can then contact the initiator directly should any questions arise.

6. Check your entries.

7. Send the request.

   Confirm the message, that your request has been saved.

Result

The request is transferred to the SAP R/3 System and assigned to a processor.
Processing a Request in the SAP System

Use

You have made one of the following requests using an Intranet/Internal request form:

- Request Change to Master Data [Seite 30]
- Request an Adjustment Posting [Extern]

The request is automatically transferred to the SAP System and assigned to a processor.

Integration

The system creates a message [Extern] when the request form is sent. The following functions are available for processing messages [Seite 37] in the SAP System.

- Task processing [Seite 245]
  
  The following jumps to the following activities are available in task processing:
  
  - Access to the request form
  - Access to the processing transactions in the SAP R/3 System

    that were set up in Customizing for the related requests.

    See Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing → Request for a Master Data Change (Request for an Adjustment Posting) → Define Own Scenarios For The Request For Master Data Change [Extern] (Define Own Scenarios For The Request For Adjustment Postings [Extern]).

- Status query [Seite 44]
- Document Flow Display [Seite 248]
  
  The document flow display is only relevant for the request for an adjustment posting.

Activities

To call up the functions for message processing, in the SAP Easy Access Menu choose Office → Message.

You can find additional information about messages in the SAP Library under Cross-Application Components (CA-NO) → Messages [Extern].
Processing Notifications

To process the internal service request [Extern], you can do the following:

- Processing notifications [Seite 38]
- Processing notifications using the worklist [Seite 40]

You call up processing via:

- Office → Notification → Worklist → Notifications or
- Office → Notification → Change
Process Notification

Use

Put notification in process
Once you have created a notification and entered all relevant information, you can put the notification in process. When you put a notification in process, you release the notification for processing.

A notification can be put in process in the following ways:

- You can put a notification in process manually.
- The system puts a notification in process automatically if an order was created for the notification.

When a notification is put in process, the system changes the status of the notification from "outstanding" (OSNO) to "notification in process" (NOPR).

Postpone notification
In some cases, it may be necessary to delay the processing of a notification (for example, if the assigned tasks cannot be carried out yet).

Using this function, you can postpone the processing of a notification. When you postpone a notification, it receives the status NOPO (notification postponed).

💡
You cannot postpone a notification that has already been put in process.

Complete notification
You complete a notification when the problem has been solved and no further processing is necessary. Once you complete a notification, you can no longer change any data in the notification. You can then only display the notification.

When a notification is completed, it receives the status NOCO (notification completed).

💡
You cannot complete a notification if outstanding tasks still exist in the notification.

Categorizing a notification problem
When you complete a notification, the system displays a dialog box with the current date and time. You can accept the displayed date and time as the completion time or you can change it. In this dialog box, you must specify whether the problem arose because of an internal or external cause. For example, if a vendor delivers a defective product, you are dealing with an externally caused problem.

Put notification in process again
You can put a completed notification in process again, if you determine that additional processing is necessary.

Archive completed notification
Completed notifications are automatically archived and are deleted from the database after a specific, predefined time interval. This time interval is defined in Customizing. Therefore, make sure you have finished processing the notification before you complete it.

**Delete notification**

In some cases, you may want to delete a notification. You cannot, however, delete a notification directly. You must set a deletion flag in the notification which identifies it as one that can be deleted.

A company typically runs an archiving program at regular intervals. This program searches for the notifications with deletion flags, converts the deletion flags to deletion indicators, and copies the notifications to an archive. The system then deletes the notifications from the database.

Before you delete a notification, make sure that it is no longer needed.

Once you set a deletion flag for a notification, you can no longer change the data in the notification. It then receives the status Deletion flag and Completed. You can now only display the notification. For more information about notification statuses, see Status Management [Extern].

If you set a deletion flag in the notification header, the system also sets deletion flags for the individual notification tasks.

You can cancel the deletion flag as long as it has not been converted to a deletion indicator. You can then put the notification back in process and change or display it in the usual manner.

**Procedure**

<table>
<thead>
<tr>
<th>Desired processing type</th>
<th>What you should know</th>
</tr>
</thead>
<tbody>
<tr>
<td>Put notification in process</td>
<td>Call up the notification in the create or change mode and then choose Notification → Functions → Put in process.</td>
</tr>
<tr>
<td>Postpone notification</td>
<td>Call up the notification in the change mode, choose Notification → Functions → Postpone, and then save the notification.</td>
</tr>
<tr>
<td>Complete notification</td>
<td>Call up a notification in the change mode and choose Notification → Functions → Complete. Specify the completion date/time and the cause of the problem; then close the dialog box and save the notification.</td>
</tr>
<tr>
<td>Delete notification</td>
<td>To set a deletion flag, call up the notification in change mode and then choose Notification → Functions → Deletion flag → Set. To reset the deletion flag, choose Notification → Functions → Deletion flag → Deselect.</td>
</tr>
</tbody>
</table>
Processing Notifications Using Worklist

Use

Using the worklist for notifications, you can select notifications on the basis of different criteria and process them. You can select the notifications as follows:

- You select the notifications using the My worklist function. The system then displays the following notifications for further selection and processing:
  - All notifications to be processed by you as the "person responsible" or that fall within your department's area of responsibility
  - All notifications to be processed by you as a <Partner function>
  - All notifications you created
  - All notifications that were last processed by you

- You select the notifications using the General selection function. The system then displays all notifications for further selection and processing. Make sure the preset selection criteria contain the values you want (for example, notification status, selection period).

Prerequisites

If you use the General selection function and you want to process notifications for which you are not responsible or which you did not create, you must have the corresponding authorization.

Activities

You choose Logistics → Central Functions → Notification → Worklist → Notifications to call up the worklist for notifications.

You enter the required data and choose Execute.

See also:

Select and Process Notifications Using Worklist [Extern]
Task Processing

Purpose

Using the functions for task processing, you can change or display the tasks in a notification independently of the notification itself. In this way, you can:

- Process tasks quickly and easily
- Execute tasks using the functions of the action box
- Access the information in the associated notification at any time

Process Flow

1. You process the tasks using one of the following options, depending on your job duties or method of working:
   - **Worklist [Seite 246]**
     You call up the worklist for tasks to determine whether tasks exist that you must process.
   - **Workflow [Seite 247]**
     You check your workflow inbox determine whether tasks exist that you must process.
   - **Functions for Task Processing [Extern]**
     If you want to process a specific task in a specific notification, use the transactions for processing or displaying a task.

2. After you have selected and executed one of the above options, you process a task by either:
   - Forwarding the task to another person, if you cannot process the task yourself
   - Carrying out the instructions specified in the task
   - Documenting the information for a task that has just been executed; for example, as a task long text or via a follow-up function in the action box (internal remark)
   - Setting the status of the task to "completed," once you have carried out the instructions specified in the task
   - Executing additional follow-up functions in the action box, if additional tasks need to be implemented

Result

Once you have processed and completed a task, you can complete the notification (provided there are no other tasks in the notification that need to be processed).
Processing Tasks Using Worklist

Use

Using the worklist for tasks, you can select notification tasks on the basis of different criteria and process them. You can select the tasks as follows:

- You select the tasks using the My worklist function. The system then displays the following tasks for further selection and processing:
  - All outstanding tasks to be processed by you as the "person responsible"
  - All tasks to be processed by you as a <Partner function>
  - All tasks you created
  - All tasks you completed
- You select the tasks using the General selection function. The system then displays all tasks for further selection and processing. Make sure the preset selection criteria contain the values you want (for example, selection period, outstanding tasks only).

Prerequisites

If you use the General selection function and you want to process tasks for which you are not responsible or which you did not create, you must have the corresponding authorization.

Activities

You choose Logistics → Central functions → Notification → Worklist → Tasks to call up the worklist for tasks.

You enter the required data and choose Execute.

See also:

Select and Process Tasks Using the Worklist [Extern]
Processing Tasks Using Workflow

Use

If a task is created in a notification or if the person responsible for a task is changed, the system can automatically notify the person or department responsible via the SAP Business Workflow that a task needs to be processed.

You receive the information about the task that needs to be processed as a work item in your inbox (Business Workplace). Your inbox provides an overview of all tasks that you are responsible for processing. You can begin processing the work item directly from your business workplace.

Integration

You can access your business workplace by choosing Office → Workplace from the SAP menu. Then choose Inbox → Workflow to display any work items that may be present.

Prerequisites

The required system settings to activate the SAP Business Workflow have been made.

Activities

If there is a work item in your inbox, proceed as follows to begin processing the work item:

- You double click the work item to display a description of the task to be executed.
- You choose Execute to process the work item. The system calls up the transaction to process the task.
Status Query For Request

Use
You can call up the status of the request at any time during its runtime.

See also:
- Status Management For Notifications [Extern]
- Display Status Information [Extern]
- System Status Assignment [Extern]
- Assigning And Changing User Statuses [Extern]
- Status Management For Tasks [Extern]
Order Manager And Collective Processing Of Master Data Changes

Use

The Order Manager provides you with a graphic user interface to manage master data. This interface is easy to use, and fast to learn. Collective processing enables the expert to process the data efficiently for the management of master data for internal orders.

Features

The linking element between work steps is a worklist, which can be filled either by using a selection variant or selecting single orders (personal worklist). The worklist last used is saved specifically for its user and is available again next time the user logs on to the system.

The worklist displays the master data fields for the selected orders in columns. This is an ALV grid list with the following functions: Sort, find, details, set filter, print, and your own display variants. You can save the layout either user-specific, or for all users.

You can display or change single orders from the worklist. You can also create new orders, possibly as a copy of an order in the worklist.

You can also select single orders, and process them in the new collective processing for orders. Collective processing enables you to (for example) replace entries in individual fields in the selected orders with a common value. If you select individual columns as well as the orders in the worklist, and if these fields are allowed for collective processing changes, then these columns are available in collective processing as being changeable. If you do not select any columns, then the defaulted columns are changeable in collective processing.

You can store calculations for internal orders.

For more information, see the SAP Library under Financials → Controlling → Product Cost Controlling → Processing Costing Variants And Assigning Attributes [Seite 173].

Note the following table, showing what you can do with the costing in each mode:

<table>
<thead>
<tr>
<th>Mode</th>
<th>The costing can be</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display order</td>
<td>Displayed</td>
</tr>
<tr>
<td>Change order</td>
<td>Changed/deleted</td>
</tr>
<tr>
<td>Create order</td>
<td>Created</td>
</tr>
</tbody>
</table>
**Order Manager Structure**

- **Search by**
  - Order
  - Selection variant

- **Personal worklist**

**Collective Processing Structure**

- **New entries**
  - Internal orders in which data is changed

- **Assignments**
  - The data in this column is changed
Activities

See [Working In The Order Manager][48] and [Change Master Data In Collective Processing][50]

See also:
[Request For Budget Increase In The Intranet][30]
**Working In The Order Manager**

**Use**

The *Order Manager* provides you a graphic user interface to manage master data. This interface is easy to use, and fast to learn. Collective processing enables the expert to process the data efficiently for the management of master data for internal orders.

**Order Manager Structure**

![Diagram of Order Manager structure]

**Procedure**

1. Choose **Accounting → Controlling → Internal orders → Master data → Order Manager**. The *Order Manager* screen appears.
2. If you have not yet worked in the *Order Manager*, you need to create a worklist using **Search for**.
   - **Order**
   - **Selection variant**
3. If you have already worked in the *Order Manager*, you can either see the last ten internal orders that you processed in your *personal worklist*, or the orders from the last *selection variant* chosen.
   
   You can delete or add orders in the worklist, or call up the orders using a different selection variant.
4. The system lists all the internal orders that correspond to your search.
5. To display the master data for a single internal order, choose the corresponding internal order by double-clicking on the order number.
   To enlarge the master data screen, you can hide the worklist by choosing Worklist.
   ![Note]
   You select more than one internal order at the same time by pressing Ctrl and selecting the internal orders in the list with the mouse, row by row.

6. To delete internal orders in your worklist, select them and choose Delete from worklist.

7. To change the master data for more than one internal order in collective processing, select it and chose Collective processing.
   If you selected any special columns as well as the internal orders, then these are available in collective processing. If they are changeable, the selected columns are transferred as ready for input to collective processing. If the columns are not changeable, then they are transferred to collective processing and can be displayed.
   If you did not select any special columns, then the predefined columns for short text and order type are available in collective processing.
   You receive a note on the selection function and its effects.
   You can insert additional columns in collective processing at any time.

8. When you leave the transaction, the system saves the last ten orders that you selected or the last selection variant that you used, specifically for your user.
   When you next call up the Order Manager, these orders are available.

See also:
Changing Master Data In Collective Processing [Seite 50]
Changing Master Data In Collective Processing

Use
Collective processing enables the expert to process the data efficiently for the management of master data for internal orders.

Prerequisites
You are authorized to change master data. If you do not have this authorization, you can select the Request For Master Data Change In The Intranet [Seite 30] directly from the application.

Collective Processing Structure

Procedure
Access from the Order Manager
You have been working in the Order Manager and have selected orders there. You have chosen Collective processing.
If you selected single columns as well as the internal orders that were selected by row, then these columns are available in collective processing and are changeable (providing they are allowed to be changed).
If you did not select any special columns, then the predefined columns are available in collective processing.
For more information on the Order Manager, see Working In The Order Manager [Seite 48].
Changing Master Data In Collective Processing

Direct Access Via The SAP Easy Access Menu

1. Choose Accounting → Controlling → Internal Orders → Master Data → Special Functions → Collective Processing → Manually.

2. Enter a selection variant.
   This takes you to collective processing.

   By row, select the internal orders to be changed.
   You select more than one internal order at the same time by selecting the internal orders in the list with the mouse, by row.

3. Enter new data that is to be changed in the selected internal orders, under New values in the columns.

4. In New values, select the columns that contain the data to be replaced.

5. Choose Change field values.
   The system replaces the data in the selected columns of the selected internal orders.

   You can process a block of up to one hundred internal orders at a time.

You also have the following options:

- **Only change the field when it has a certain current value**
  Choose Restrictions on/off, and enter the new value in the first row. Enter the value to be replaced in the second row Replace only.

- **Select fields**
  You can insert more fields for processing.

- **Store formulas for the automatic replacement of numerical values**
  1. Choose Enter formulas/FORM routines.
  2. Store a descriptive short text for the formula.
  3. Choose ABAP.
  4. Define a formula.
  5. Save your entries.

  **Example**
  You want to increase the estimated costs in all the selected orders by 10%.

  **Display previous value**
  Providing you do not leave the transaction after changing the values, you can display the previous values by choosing Old values on/off. To display database changes (such as changes made by other users in the meantime), choose Refresh.

  **Undo changes**
  Providing you do not leave the transaction after changing the values, you can recreate the previous values by choosing Undo changes.

  **Test changes**
  Before saving, you can test whether the required changes are possible. Some master data may be exempt from the change in some of the internal orders, and therefore cannot be
Changing Master Data In Collective Processing

changed. To do so, choose *Test changes.* This function may last as long as the saving function, as the system makes the same checks during testing. The system highlights in color master data that cannot be changed.

6. Save your entries.
   You can decide whether to save
   
   - The changes you made to the internal orders currently selected,
   
   - Or the changes that you made during all of processing (without leaving collective processing).

   The system checks the changed data for consistency. The system does not allow changes that would create data inconsistency, instead it records these in the log. The system highlights in color master data that cannot be changed.

**Result**

You have changed the master data for more than one internal order.
Creating an Internal Order

1. Choose *Master Data → Order → Create* from the *Internal Orders* menu.
2. Enter the *order type* and choose *Master data*.
   Set the *Controlling Area* for your order in the dialog box, and choose *Enter*.
3. Enter a *short text* to describe your internal order.
4. For external number assignment, enter a key for the internal order.
5. Enter the required data for the internal order in the tab pages.
   The internal order layout may differ from the *Order Layout in the Standard* [Seite 55].
   - The system sets the *controlling area, company code, and business area* according to various settings, or if required, automatically.
   - *General data* is for information only and is not validated by the system.
   - The system sets the *status, currency* and *object class* automatically.
   - You can also maintain the fields in the period-end closing group box at a later date.
   - If you want to settle an internal order 100% to *one* cost center or *one* G/L account under *one* settlement cost element, then enter this data into the group box *Settlement to a Receiver*. In all other cases you define settlement using the *Settlement Rule [Extern]*, which you can also define later.
6. Save your internal order.

*Rather* than carrying out a unit costing, you can define a costing model in the master data for the relevant internal order via *Extras → Costing*.

You can find more information on this type of costing in the SAP Library under *Financials → Controlling → Product Cost Controlling → Editing Costing Models and Assigning Attributes* [Seite 173].

More information is available in the SAP Library under *Easy Cost Planning for Internal Orders* [Seite 170].

**Results**

Your internal order is created. The system issues an order number when you make an internal number assignment. This number clearly identifies the internal order.

**See also:**
*Master Data Maintenance in the Intranet* [Seite 14]
Structuring Layouts

Use

The interface structure for internal orders is not strictly defined. You can determine how your orders are represented in the system according to the intended usage.

Integration

In customizing, you can use the field selection to specify (per order type) when and which field in the order master data is displayed or ready for input.

Features

Order master data consists of tab pages with predefined group boxes. You can change the titles of the tab pages in Customizing and assign the group boxes individually to the tab pages. For more information, see Layouts in the Standard System [Seite 55].

Activities

Define the order layout in customizing for each order type, under Controlling → Internal orders → Order master data → Screen layout → Define Order Layouts [Extern].
Order Layout in the Standard

In the standard system, the order master data is structured as follows:

<table>
<thead>
<tr>
<th>Tab page</th>
<th>Group box</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assignments</td>
<td>Assignments</td>
<td>You can maintain the organizational assignments for your order (for example, Company code, Business area) To specify user authorizations using the Responsible Cost Center For example, you can give a user authorization for all internal orders that have a given responsible cost center.</td>
</tr>
</tbody>
</table>
| Control | Status | A status documents the current processing status of an internal order. It informs you that a particular status has been reached (for example, "Order released"), and determines which business transactions you can use. The SAP system differentiates between system and user statuses:  
- **System statuses** are set by the system and inform you that a given function has been performed on the internal order. For example, if you release an internal order for actual postings, the system automatically sets the appropriate system status.  
- A **User status** is a status that you define to supplement existing system statuses. You define user statuses in Customizing, in a status profile, and then enter this in the corresponding order type.  
The system and user statuses currently active for an order are displayed on the Control Data screen. Before executing a business transaction for an internal order, ensure that at least one active status allows it, and that none of the active statuses prohibits it. |
### Order Layout in the Standard

<table>
<thead>
<tr>
<th>Control</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Control</strong></td>
</tr>
<tr>
<td>This is where you maintain the general control parameters</td>
</tr>
<tr>
<td>- Currency</td>
</tr>
<tr>
<td>- Statistical key figure</td>
</tr>
<tr>
<td>- Whether integrated planning is active</td>
</tr>
<tr>
<td>![Warning] When you set the indicator for internal orders or projects, note that a project cannot be plan integrated and statistical at the same time.</td>
</tr>
<tr>
<td>The system also displays, for example, whether:</td>
</tr>
<tr>
<td>- Revenue postings are allowed</td>
</tr>
<tr>
<td>- Commitments management is active</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Period-end closing</th>
<th>Period-end closing</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Period-end closing</strong></td>
<td></td>
</tr>
<tr>
<td>This is where you maintain, for example:</td>
<td></td>
</tr>
<tr>
<td>- Parameters for costing (<em>Results analysis key</em>)</td>
<td></td>
</tr>
<tr>
<td>- Parameters for overhead costing (<em>Costing sheet and overhead key</em>)</td>
<td></td>
</tr>
<tr>
<td>- Parameters for interest calculation (<em>Interest calculation sheet</em>)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Settlement to one Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Settlement to one Receiver</strong></td>
</tr>
<tr>
<td>This is where you maintain the parameters for order settlement to one receiver (<em>Settlement cost element</em> and receiving <em>Cost center</em> or receiving <em>G/L account</em>).</td>
</tr>
<tr>
<td>To settle more than one receiver, choose <em>Settlement rule</em>. The settlement rule consists of one or more distribution rules, which define the distribution for the costs incurred on the order to the various receivers. You can find more information on this subject under: <em>Settlement Rule [Extern]</em>.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>General data</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General data</strong></td>
</tr>
<tr>
<td>In this subscreen you maintain general data, such as <em>Applicant</em> and <em>Responsible person</em> for the order. This data is for information purposes only and is not checked by the system.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Investments</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Investments</strong></td>
</tr>
<tr>
<td>This is where you maintain all the parameters required for capital investment orders (for example, <em>Investment profile</em>, <em>Scale</em>, <em>Investment reason</em>)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Assignment to investment program / Appropriation request</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Assignment to investment program / Appropriation request</strong></td>
</tr>
<tr>
<td>This is where you assign the order to one or more investment program items.</td>
</tr>
</tbody>
</table>
Simulation data for depreciation

This is where you maintain the data for asset depreciation of the investment order (for example Asset class).

Joint venture

This is where you maintain all the additional parameters you need to use the Joint Venture component. The system only displays this group box when you activate the component.

**User-Defined Fields**

As well as the group boxes already mentioned, you can also define user-defined fields, which you can summarize in user-defined group boxes. You can also include these group boxes in the tab pages in customizing.
Status Management in Internal Orders

Use

The current status of an internal order (or the combination of all statuses) determines which business transactions you can perform on the internal order. You use status management to specify the current processing status of an internal order. The status can be set by the system or by the user.

Integration

An internal order is not a static object, but has its own life cycle that begins when you create it and ends after you close it. During this time, the internal order is changed by various business transactions. For example, costs are planned, posted and settled for it.

Each internal order passes through four system statuses, one of which is always active.

- **Created**
  In this status, for example, actual postings are not possible.

- **Released**
  Nearly all business transactions are allowed in this status.

- **Technically completed**
  In this status, for example, you cannot make any planning changes.

- **Closed**
  In this status, for example, no cost-relevant business transactions are allowed.

Features

You can plan the processing of an internal order, by saving a plan date in the order master data for this system status (except for **Created**). These values are for information purposes. The system logs in the internal order when a system status has actually been reached, and which system status it is.

Changing the system status of an order is itself a business transaction. You do this using a function (for example, **Released**) in the master data maintenance.

In addition to the four system statuses already mentioned, further system statuses are set through given business transactions. Examples are:

- **Locked**
  In this status you cannot carry out any business transactions except for resetting the lock.

- **Settlement rule created**
  This status is set automatically by the system if you created a settlement rule.

Activities

If you want to determine when particular business transactions are to be allowed, you can define a user status. The user status enhances the existing system statuses.

For more information on defining the user status, see General SAP Status Management [Seite 60]. General SAP status management is also used in other areas (projects, production orders, and so on) and will replace Order Status Management [Seite 63] at a future date.
To plan the flow of an internal order, choose Accounting → Controlling → Internal orders → Master data → Order → Change → Master data → Goto → Flow.
General SAP Status Management

Use

Use the general SAP status management if you require user status.

Status

The current processing status of an object is documented by one or more statuses. A status is an indicator that fulfills two functions:

- It informs you that a particular status has been reached (for example, The order has been released)
- It influences the number of business transactions you can perform.

If you execute a business transaction, this can then set or delete one or more statuses for the specified object.

You can set any number of statuses for an object.

Statuses can be displayed in two different ways in the system:

- As a 30-character text
- As a 4-character identification code

Both display variations are language dependent.

The system displays the active status of an object in list form or in a status row. The status row may contain up to a maximum of eight statuses. You use the status profile to define the position in which the application status is displayed in this row. The system can output several statuses in the same position. The system uses the Priority column in the status profile to determine which status is actually displayed. The list display shows all active statuses (arranged according to position and priority).

A status can be either active or inactive: A status can

- Allow a business transaction
- Allow a business transaction with a warning
- Prohibit a business transaction

If a business transaction is allowed with a warning for a particular object, the system issues a warning message when you execute the business transaction. You can then decide whether to ignore the warning and continue with the business transaction.
You want to flag a released internal order for deletion. However, the internal order has not yet reached the *Closed* status. In this case, the system first issues a warning indicating that the order has not yet been closed.

To use a business transaction, the following is required:
- At least one active status must allow the business transaction.
- No active status may prohibit the business transaction.

General SAP status management distinguishes between system status and user status.

**System Status**

The system sets a *system status* informing the user that the system has executed a certain business transaction for an object. You can only influence this status by executing a business transaction that changes the system status.

If you release an internal order, the system automatically sets the *Released* system status.

**User Status**

You can set a user status in addition to the existing system status. You specify the user status in a status profile, which you create for each order type in Customizing. You can specify and activate any number of user statuses.

In a production order you can simultaneously set the *Released*, *Pre-costed*, *Printed*, and *Finally confirmed* statuses.

The system status and the user status influence the business transactions in the same way.

**Status Profile**

A *status profile* contains a user-defined quantity of user statuses and rules. You can define status profiles in customizing for each order type. See the [Define Status Profiles](#) activity in the IMG:

The status profile allows you to:
- Define the user status and document its functions with a corresponding long text.
- Assign a status number that specifies the order in which the system reaches the user statuses.
- Define an initial status, which is then automatically set when an object is created.
- Determine that a user status is automatically set when you execute a business transaction.
- Permit or forbid specified transactions, if a status is active.

**Status Number**

User statuses can be used to determine a sequence for the different steps involved in processing an object. For each step, you specify a user status and give it a *status number*. You should assign these status numbers so that they are reached in ascending order.
General SAP Status Management

If you assign a status number to a user status, specify a lowest and highest status number for the user status. These numbers limit the status number interval from which the subsequent user statuses can be chosen.

You require the user status to monitor individual steps during construction of a building. You create the following user status in a status profile:

<table>
<thead>
<tr>
<th>Status number</th>
<th>Status</th>
<th>Short text</th>
<th>Lowest status number</th>
<th>Highest status number</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>PLAN</td>
<td>Planning</td>
<td>10</td>
<td>20</td>
</tr>
<tr>
<td>20</td>
<td>APRV</td>
<td>Plan approval</td>
<td>10</td>
<td>30</td>
</tr>
<tr>
<td>30</td>
<td>CNST</td>
<td>Construction</td>
<td>30</td>
<td>40</td>
</tr>
<tr>
<td>40</td>
<td>HDVR</td>
<td>Handover</td>
<td>30</td>
<td>50</td>
</tr>
<tr>
<td>50</td>
<td>CMPL</td>
<td>Completed</td>
<td>50</td>
<td>50</td>
</tr>
</tbody>
</table>

The system usually works through the statuses in numerical order (status numbers). In this example however, it would be impossible to change directly from status PLAN to status CNST, because from status number 10 you can only switch to maximum status number 20 APRV. Similarly, once you reach the CNST, you can no longer return to the PLAN or APRV statuses.

Activities

To activate general SAP status management for internal orders, assign the status profile that you require to the appropriate order type in customizing for internal orders (see the Define Order Types [Extern] IMG activity).
Order Status Management

Use
You should not use this form of status management, as it is obsolete and no longer included in general SAP status management.

You define the old order status management for each order type. Each order type has its own status management, which you can more or less structure according to the function of the orders.

General business practice often requires a detailed subdivision of the order cycle, based on the business transactions that take place on the order.

The business transactions for a trade fair order are displayed below.

There are different business transactions in the Released system status: Posting preproduction costs (external invoices), and posting production costs. Posting follow-up costs in the Technically completed system status involves posting external invoices.

<table>
<thead>
<tr>
<th>Status</th>
<th>Business transaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Created</td>
<td>Planning</td>
</tr>
<tr>
<td>Released</td>
<td>Posting preproduction costs</td>
</tr>
<tr>
<td></td>
<td>- Stand rental</td>
</tr>
<tr>
<td></td>
<td>- Trade fair fees</td>
</tr>
<tr>
<td>Released</td>
<td>Posting running costs</td>
</tr>
<tr>
<td></td>
<td>- Material issues</td>
</tr>
<tr>
<td></td>
<td>- Internal activities</td>
</tr>
<tr>
<td></td>
<td>- External services</td>
</tr>
<tr>
<td>Technically complete</td>
<td>Posting follow-up costs</td>
</tr>
<tr>
<td></td>
<td>- Hotel bills</td>
</tr>
<tr>
<td></td>
<td>- Travel expenses</td>
</tr>
<tr>
<td>Settlement</td>
<td></td>
</tr>
<tr>
<td>Closed</td>
<td>None</td>
</tr>
</tbody>
</table>

It is likely that you will want to limit business transactions to given periods. For example, posting external invoices would only be possible before the order has been settled. Or, you do not allow any more internal activities after the order is technically complete.

You can do this by subdividing your Released status and assigning the transactions to where they are to be allowed.
You can subdivide a system status into more than one status. You can subdivide a system status into more than one status.

Unlike the general SAP status management, the system status is not changed using a function in order status management. The system status is directly linked to the order status and is thus automatically changed when the status changes.

**Business Transaction Group**

You can define business transaction groups by grouping more than one business transaction together, in Customizing, under *Controlling -> Internal Orders -> Master Data in Internal Orders -> Status Management in Internal Orders -> Order Status Management.*

![Image](image.png)

The transactions for a trade fair could consist of the following actions:

- Planning primary costs
- Planning overheads
- Posting external invoices
- Material withdrawals
- Allocating internal activities
- Posting overheads
- Settlement of costs
- You can use these transactions to form transaction groups, for example:
  - Cost planning
  - Posting preproduction costs (external invoices)
  - Posting running costs (internal activities, material issues, overheads):
  - Posting follow-up costs (only external invoices)
  - Settlement
- You can then use these groups to define which transactions are allowed and prohibited at given times:

Business transactions are allowed on an order, depending on whether you assign a status to the transaction group that they belong to. If a transaction is **not** assigned to a status, then it is prohibited in this status.

**Disallowed Transaction Group**

To prohibit business transactions for individual orders, define these as a transaction group, and store it in the order as a disallowed transaction group.

A disallowed transaction group can be identical to the currently allowed transaction group. It can also consist of only part of the transactions from the allowed transaction group. The disallowed transaction group limits the allowed transactions.

Order status management determines, for example:

- Which status is defaulted by the system when you open the order.
• Which transactions are allowed or forbidden in a particular status (a transaction is only allowed if it belongs to the transaction group of the order status, and is not prohibited by the system status).

• Whether, and when, planning documents [Extern] are written.

• Which attributes the screen fields have during master data maintenance in the given status.

• When you can select the order for deletion.

The following graphic shows a status overview for trade fair orders. In this example, we have defined six statuses (from 10 to 60) for the order type.

<table>
<thead>
<tr>
<th>Order type 0400</th>
<th>Trade fair order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order status</td>
<td>LSt</td>
</tr>
<tr>
<td>10 Planning</td>
<td>10</td>
</tr>
<tr>
<td>20 Preprod. costs</td>
<td>10</td>
</tr>
<tr>
<td>30 Running costs</td>
<td>20</td>
</tr>
<tr>
<td>40 Follow-up costs</td>
<td>30</td>
</tr>
<tr>
<td>50 Settlement</td>
<td>40</td>
</tr>
<tr>
<td>60 Closed</td>
<td>60</td>
</tr>
</tbody>
</table>

The columns contain the following:

**Order Status**

The first two columns from left to right contain the order status [Extern] number and a description.

**LSt, HSt** (lowest status, highest status)

These two columns determine how you can change the status in the order. The next example provides you with a detailed description.

**Crt, Rel, Cmp, Cls** (created, released, technically completed, closed)

These four columns contain check boxes for the different system statuses. To assign the order status to a system status, mark the appropriate column. When you do this, you need to follow the sequence from left to right. You also need to use the numerically ascending sequence for the status.

**TranGrp** (transaction group)

This column contains the transaction group allowed for each respective status.

**PID** (planning documents)

In this column, indicate whether you want to log planning changes in this status. This enables the system to write line items (that you can display) for each change in order planning. Of course, the allowed transaction group must also...
Order Status Management

include planning actions, otherwise you cannot plan, and the indicator has no effect.

**Dst** (default status)

Select the default status in this column. This is the status that the orders of this order type should have when they are created, and is usually the status with the lowest number.

The default status is only a default value, and can be overtyped if required.

The following example illustrates how status management can affect an order.

<table>
<thead>
<tr>
<th>Order type 0400</th>
<th>Trade fair order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order status</td>
<td>LSt</td>
</tr>
<tr>
<td>10 Planning</td>
<td>10</td>
</tr>
<tr>
<td>20 Preprod. costs</td>
<td>10</td>
</tr>
<tr>
<td>30 Running costs</td>
<td>20</td>
</tr>
<tr>
<td>40 Follow-up costs</td>
<td>30</td>
</tr>
<tr>
<td>50 Settlement</td>
<td>40</td>
</tr>
<tr>
<td>60 Closed</td>
<td>60</td>
</tr>
</tbody>
</table>

You have planned your order in status 10 and now want to release it.

The **HSt** column shows that you can set the order in status 20 only (setup costs).

You therefore change the status in your order to 20.

This causes the following:

- You changed the phase to **Released** at the same time
- The **Released** date was set automatically in the order
- You can now post the external invoices for your setup costs

If, for example, you now want to return to the planning status, which is allowed according to **LSt** (lowest status = 10), the system sets the **Released** date.

From status 20, you can set status 30, where all actual postings are allowed (transaction group **ALL**). If you make any planning changes now, they are recorded in planning documents according to column **PID**.

If you do not expect follow-up costs, you can set status 50 while in status 30, thus skipping status 40. At the same time, you have again changed the system status, which also sets the **Technically completed** date. You can now settle the order.

Then you realize that one of your employees has not yet submitted his travel expenses. As you cannot post this in status 50, because it only allows settlement, you need to reset the status in the order again.
The lowest status (LSt) determines that you can only go back as far as status 40 from the settlement status. The system notes the highest status that the order has reached to this point. The lowest status to which you can return, therefore always remains the same. Thus, you **cannot** return from status 40 to status 30, although according to LSt, status 40 would normally allow this.

After you posted the follow-up costs, you can change the status to 50 again, and settle the order.

As soon as the order is settled completely, you can set the deletion flag, as this column is selected for status 50.

You can also set the order to status 60 after it is settled. As indicated in the LSt and HSt columns, you now cannot make any further status changes.

You can no longer post to the order at this point. You can, however, still use it for evaluations in reporting.
Order Group

Definition
Several internal orders are grouped into one order group to display a certain structure.

Use
You can use order groups for the following:
- Planning
- Overhead calculation
- Settlement
- Evaluation in reporting

Structure
You can set up order groups using as many levels as you wish. The orders themselves are always at the lowest level of the group. An order may be assigned to different groups at the same time. Groups are client-dependent so you may only use a group name once.

You have three buildings (A, B, C) on which maintenance work is being done by three maintenance workshops (painter, locksmith, electrician). You create an order for each building and each workshop, then group these nine orders together to form the order group shown below:

You create the top node and name it MAINT01 "Maintenance". You then add three further nodes, one each for building A, building B and building C respectively.
You assign to each building node the orders of the workshop that carries out the work on this building.
You use this group to analyze both the entire maintenance costs for the three buildings, as well as the costs for each individual building.
The above graphic displays order group MAINT01, which groups the orders according to buildings.

You can also set up a second group using the same orders. This time, instead of creating building nodes, you create three workshop nodes to which you then assign the respective orders. This alternative group allows you to evaluate the maintenance costs for each workshop.

The MAINT02 group contains the same orders as MAINT01, this time grouped according to workshop.
Master Data Groups

Definition
Master data can be grouped together, for example:

- Cost center groups
- Cost element groups
- Activity type groups
- Statistical key figure groups
- Business process groups
- Order groups

In addition to those groups that are subnodes of the standard hierarchy, for analysis or planning purposes, you can also create alternative groups that do not belong to the standard hierarchy.

All cost centers and business processes must be incorporated in the relevant standard hierarchy [Extern]. Note that you can assign a cost center or business process to only one hierarchy group, but to any number of alternative groups.

Use
You can use master data groups in different areas (analysis, planning, allocation).

You can divide complex groups into manageable sections by separating them into sub-groups. You can create and maintain sub-groups separately and then combine them in larger groups.

Remember that groups have no time dependencies. In contrast, most master data is time-dependent.

If, for example, the cost center structure changes for the new fiscal year, the standard hierarchy changes with it. As the standard hierarchy is not time-dependent, the system ensures that reports covering multiple fiscal years always use the same standard hierarchy [Extern], thus providing comparable results.

To save older standard hierarchies for documentation purposes, copy the hierarchy before making changes and use this copy for evaluating reports for previous fiscal years (see: Copying Master Data Groups [Seite 75]).
Creating or Changing Master Data Groups

Prerequisites

You want to create new master data groups or change existing ones.

Procedure

1. In the master data menu of the given application component, choose Master data → <object> group → Create or Change.
2. Enter the group you wish to change or create.
   
   If you are creating a new group, you can use an existing group as a template. The template group can belong to the same controlling area [Extern], or chart of accounts [Extern], or different ones.
   
   a. If you are using reference groups from the same controlling area, assign a new name to the new group. The highest node contains the group names entered. The existing structure is appended to the highest node. This means that every change to the original automatically affects the copy.
   
   b. If you are using a reference group from a different controlling area, you may use the same name for the new group. The entire structure is copied into the current controlling area. It retains the same name. The copy and the original are two separate structures.
   
   c. If a subgroup (node) already exists with the same name you have selected for the new group, the system asks whether you want the existing group to be overwritten by the new group or whether the copying should be aborted (see: Copying Master Data Groups [Seite 75]).

3. Choose Hierarchy.
4. You can create your groups successively in the group structure display.
   
   To do so, select the node from which you want to extend the group, and choose Insert at same level or Insert at lower level.

5. At the required location in the tree structure, the system displays fields in which you can enter a name and description for the new subgroup (node).
   
   You can use the F4 help to make your entries.

6. Then choose Enter or Accept change.
7. To assign individual values to an end node, select the node and choose Insert <object> (for example, Insert cost center).

   So long as the structure is not the standard hierarchy for Cost Center Accounting or Activity-Based Costing, the system displays fields in which you can enter the From-value and the To-value.

   You can use the F4 help to make your entries.

8. Choose Accept change.

   The system either displays the individual values assigned and their descriptions, or issues a message that the individual values do not exist.
Creating or Changing Master Data Groups

9. To create or change groups belonging to an object (such as a cost element or cost center), you can assign a selection variant to an end node (see: Selection Variants [Extern]). Proceed as follows:

   a. Position your cursor on an end node.

   b. Choose Insert <object> group at lower level and enter the name of the selection variant, or choose this variant using input help.

   c. Choose Enter.

   d. To change the selection variant, simply double-click on it. You can reassign selection variants just as you reassigned groups.

   e. To display a list of the master data for a selection variant, position your cursor on the selection variant and choose Extras → Break down selection variant. In a dialog box the system displays a list of the corresponding master data.

When you are creating or changing groups you can not create any new selection variants.

10. Save your structure.

   If you are processing the standard hierarchy [Extern] or a hierarchy group of cost centers or business processes, you can also create or change the master data of cost centers or business processes.

   See

   Processing the Standard Hierarchy Using Group Maintenance [Extern]
   (Cost Center Accounting)

   Processing the Standard Hierarchy Using Group Maintenance [Extern]
   (Activity-Based Costing)
Processing Master Data Groups

Use
You can use the following functions to create and change groups for the following objects:

- Cost elements [Extern]
- Cost centers [Extern]
- Business processes [Extern]
- Activity types [Extern]
- Statistical key figures [Extern]
- Orders [Extern]
- WBS elements [Extern]

Features
The following graphic shows the functions for processing master data groups:
**Activities**

To process master data groups, choose *Master Data -> <Object> group* from the SAP Easy Access menu in the relevant component.

**See also**

- Creating or Changing Master Data Groups [Seite 71].
- Functions for Structural Processing of Master Data Groups [Extern]
- Additional Functions for Processing Master Data Groups [Extern]
- Transport Functions for Master Data Groups [Extern]
- Copying Master Data Groups [Seite 75].
Copying Master Data Groups

Use

You can copy the following groups within a controlling area [Extern] or within a chart of accounts [Extern]:

- Cost center groups [Extern]
- Cost element groups [Extern]
- Activity type groups [Extern]
- Statistical key figure groups [Extern]
- Order groups [Extern]
- Business process groups
- WBS element groups

Copying groups is especially useful for fixing characteristic values at a given time for a group with time-dependent objects: This lets you make changes that will affect the next fiscal year.

Features

Copying the entire group structure in the same controlling area or chart of accounts

1. In the relevant application component, choose Master data → <object>group → Create or Change or Display.
2. On the initial screen for group maintenance, choose Group → Copy.
3. Enter the group to be copied and enter a suffix.
   The suffix can be any given string of alphanumeric or special characters. For example, you can use a numerical fiscal year that characterizes the group.
4. Choose Copy <object>group.
   The system copies the group. If a subgroup (node) in the target controlling area has the same name, the system asks whether you want the existing group to be overwritten by the new group.
5. Save the copy.
   The system creates a copy of the existing group in the same controlling area or chart of accounts. The system creates a new name for the copy by adding the suffix to the original name of the node. If a suffix already existed in the previous name, this is replaced by the new suffix.
   The copy and the original are two separate, independent structures.
The number of groups doubles with each copy transaction. For very large hierarchies, you should therefore regularly delete any copies you no longer require. Alternatively, you can keep the number of groups low if you copy only the parts in which changes have taken place and manually create the security copy.

Within controlling area 0001, you want to copy the current HIER group. Enter the suffix 1998.

The system generates the HIER 1998 group in controlling area 0001.

You copy order groups and WBS element groups independent of controlling area and chart of accounts.

**Copying the entire group structure in a different controlling area or chart of accounts**

1. In the relevant application component, choose *Master data → <object>group → Create*.
2. Choose a group from a different controlling area or chart of accounts (see: *Creating or Changing Master Data Groups [Seite 71]* )
3. Enter a name for the new group and choose *Hierarchy*.
   
   You can adopt the name of the group used as the reference. The entire structure is then copied into the current controlling area or chart of accounts. It retains the same name.
4. Save the copy.

The copy and the original are two separate, independent structures.

This option does not exist for order groups, because they are not assigned to either a controlling area or a chart of accounts.

In controlling area 9999, you want to create a copy of the HIER group of controlling area 0001. To do this, create the HIER group in controlling area 9999 with reference to the HIER group of controlling area 0001.

**Copying the top group node in the same controlling area or chart of accounts and appending the existing structure.**

1. In the relevant application component, choose *Master data → <object>group → Create*.
2. Choose a group from the same controlling area or chart of accounts as a reference (see: *Creating or Changing Master Data Groups [Seite 71]* )
3. Enter a new name for the new group and choose *Hierarchy*.
   
   The highest node contains the group names entered. The existing structure is appended to the highest node. This means that every change to the original automatically affects the copy.
4. Save the copy.
In controlling area 0001, you want to create the HIER_NEW group as a copy of the HIER group. To do this, create the HIER_NEW with reference to the HIER group. The system creates the HIER_NEW node. The remaining nodes are appended to this node.

When you copy groups, the system checks whether nodes of the same name as the copy already exist in the system. If the system finds at least one node with an existing name, a message asks you whether the system should overwrite the existing nodes or if the copying should not be executed. It is not possible to overwrite existing nodes in the standard hierarchy.
Example: Copying the Cost Center Standard Hierarchy

Problem:
You are processing the standard hierarchy using group maintenance.

In the current fiscal year, you want to carry out cost center planning for the following fiscal year, based on the standard hierarchy [Extern]. However, in the new fiscal year, changes are made to the standard hierarchy structure. This could be, for example, because cost centers are removed or added, or because the hierarchy assignment of the cost centers has changed. To carry out planning using the standard hierarchy structure that is valid for the next fiscal year, you must make the appropriate changes to the standard hierarchy.

However, the existing standard hierarchy is required for reporting in the current fiscal year, because only this hierarchy portrays the structure in the current fiscal year.

Solution:
Copy the current standard hierarchy, and then make the changes to the structure.

You now have two hierarchies available in the system:

- The standard hierarchy for the current fiscal year, which you use for reporting
- The modified standard hierarchy, with which you carry out planning for the next fiscal year
Work Breakdown Structure or Internal Order Distribution

Use
To carry out actual postings in distributed systems for internal orders and work breakdown structures, you can distribute the master data and status information of internal orders and work breakdown structures to more than one system.

Integration

Functions in the Master System
All functions for internal orders and work breakdown structures are available. However, in the master system you cannot call up the corresponding line items from line item reports if the line items all come from one receiving system.

You create the internal orders or the work breakdown structures in the master system. When you save them, the R/3 System distributes them automatically to one or more receiving systems. Through the filter objects Controlling area and order type or project profile, you control whether, and in which system, the internal orders or work breakdown structures are to be distributed.

You can also send released internal orders and work breakdown structures at a later date.

Functions in the Receiving System
- Master data and status information display
  You can only make changes in the original master system. These changes are transferred to the receiving systems.
- Postings from other R/3 components (such as, FI, MM)
- Assessment
- Distribution
- Periodic reposting
- Manual reposting (costs, revenues, line items)
- Direct and indirect activity allocation
- Reposting internal activity allocation
- Accrual calculation
- Settlement debits
- Line item reports

Restrictions with Distributing Internal Orders and Work Breakdown Structures
- WBS elements cannot be distributed individually. Only complete work breakdown structures are distributed.
- If a WBS element is assigned to an internal order, the system does not automatically distribute this WBS element to the receiving system. This means that the assignment of the WBS element to the internal order is not known in the receiving system.
Work Breakdown Structure or Internal Order Distribution

If required, you can distribute the work breakdown structure first to the receiving system and then later on distribute the internal order.

- If you settle activities of cost centers that do not exist in the master system, you can only settle the internal order or work breakdown structure using settlement type FUL.

The following business transactions are not possible in the receiving system:

- Planning of internal orders, costs, and appointments on work breakdown structures
- Budgeting and availability control
- Commitment postings
- Overhead costing
- Settlement of internal orders and WBS elements
- Assignments of orders and networks to the work breakdown structure

If you set the deletion indicator in the master system for an internal order or a work breakdown structure and this change was adopted in the receiving system, the R/3 System also deletes the given internal order or work breakdown structure in the receiving system. To ensure that in the receiving system you cannot make postings to deleted objects, you should choose a time period corresponding to the setting of the deletion flag and the setting of the deletion indicator (for example, for internal orders by setting residence time 1). You must make sure that the Deletion flag status has been adopted in all receiving systems before you set the deletion indicator in the master system.
The data flow between distributed systems is identical for internal orders and work breakdown structures. This is described using the example of an internal order:

If you create or change internal order 10001 in system 1, it is automatically distributed to the receiving systems (in this case: system 2, system 3) and created or changed there using the same order number. System 1 is the master system of internal order 10001.

- Postings made in the master system are only available in the master system (CO document 10101 in this case).
- Postings made in other receiving system (in this case, system 3) are sent via ALE to the master system. They are available in the both the receiving system and in the master system (in this case, CO doc. 30001 from system 3 is given its own number CO doc. 10102 in the master system).

**Prerequisites**

Whenever possible, you should carry out all cross-system Customizing settings in one system.

- The organizational units (e.g. controlling area, company code) are defined identically in the master system and the receiving systems.
- The order type or the project profile are defined identically in the master system and in the receiving systems.
- The status selection profiles are defined identically in the master system and in the receiving system.
Work Breakdown Structure or Internal Order Distribution

- For internal orders: The number ranges are defined separately in the master system and in the receiving system. This is because a distributed internal order in the receiving system is given the same number as in the master system.

  or work breakdown structures: The project edit screens are defined identically in the master system and in the receiving systems. In the receiving systems you should include a lock indicator for the project edit screens, so that these project numbers cannot be used for new projects.

Activities

In the Implementation Guide (IMG), choose Basis Components → Distribution (ALE) → Predefined ALE Business Processes → Accounting → Master Data Distribution → Distribution of Internal Orders [Extern] or Distribution of Work Breakdown Structure [Extern].

Use the following objects:

<table>
<thead>
<tr>
<th>Business object</th>
<th>Work Breakdown Structure</th>
<th>Internal Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution method</td>
<td>SaveReplica</td>
<td>SaveReplica</td>
</tr>
<tr>
<td>Message type</td>
<td>INTERNAL_ORDER</td>
<td></td>
</tr>
</tbody>
</table>

To send internal orders and work breakdown structures at a later time, choose Tools → ALE → Master data distribution → Accounting → Internal Order or Projects → Send.

For more information about ALE see the SAP Library under Basis → Middleware → ALE-Introduction and Administration.
Transferring Old and External Data

Use
You can transfer orders automatically from external systems to the SAP system. Old and external data is normally transferred to the SAP system, as part of the implementation project in the IT department.

Integration
You can do this using the Executive Information System (EIS) application component.

Features
The system enters data from the external files into the data fields of the SAP internal orders that you wish to create. The procedure for is the same as for creating orders from the application. The option described in this section is an alternative to batch input.

For the purpose of this data transfer, the SAP system includes the receiver structure OREXT. A corresponding sender structure must exist in the external system. The external system must contain a matching sender structure and this structure must contain, as an external file, all the orders you want to create in the SAP system. The external file must contain exactly one complete sender structure for each order (including up to three distribution rules).

See also:
Example of a Filled Sender Structure [Seite 87]

Order Settlement
The field KONTY_n determines the settlement receiver (n=1,2,3). You can settle to the following receivers if you maintain KONTY_n as follows:

Settlement Receivers

<table>
<thead>
<tr>
<th>Receiver</th>
<th>KONTY_n</th>
<th>Conversion Exit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed assets</td>
<td>AN</td>
<td>ALPHA</td>
</tr>
<tr>
<td>Cost center</td>
<td>KS</td>
<td></td>
</tr>
<tr>
<td>Cost object</td>
<td>HP</td>
<td>ALPHA</td>
</tr>
<tr>
<td>Network</td>
<td>NP</td>
<td>ALPHA</td>
</tr>
<tr>
<td>Order</td>
<td>OR</td>
<td>ALPHA</td>
</tr>
<tr>
<td>Sales order</td>
<td>VB</td>
<td>ALPHA</td>
</tr>
<tr>
<td>Project/WBS element</td>
<td>PR</td>
<td>KONPR</td>
</tr>
<tr>
<td>G/L account</td>
<td>SK</td>
<td>ALPHA</td>
</tr>
</tbody>
</table>
Transferring Old and External Data

If you want to use fewer than three distribution rules, only maintain the KONTY_n fields you need.

The company code (BUKRS) field in the distribution rule is not currently supported, but is present because it will be used in future releases. Therefore you need to leave it blank.

The SCOPE field (object class) is two characters long in the OREXT. Entries there are not language dependent, for example, OC for overhead costs. For the purposes of the screen display, the system determines the language-dependent field contents from the domain table for the SCOPE data element. The system uses five-characters, for example, GKOST for overhead costs.

In the case of order types for which the old order status management is active, you can use the ASTNR field to set the initial status. Otherwise, the system uses the default status.

The same consistency checks occur for the automatic creation of internal orders as when you create or maintain internal orders in SAP transactions. This means you must fill the same fields. The field names in the sender structure must be the same as the screen field names.

You can display a field name by positioning the cursor on that field, then choosing F1 and F9.

Maintaining Order Types and Dependent Objects

Many of the attributes of the order to be created are derived from the order type (for example, whether revenue postings are allowed or not). You need to specify the order type in the appropriate field in the sender structure. The data you transfer using the sender structure must fit the definitions of the corresponding order type in the SAP system.

If you require a settlement rule [Extern], you need to enter a settlement profile in the order type. If you want to transfer a source assignment, you need to maintain the source structure [Extern].

The SAP system must be able to recognize all the organizational units, settlement receivers, and so on. To settle one of the orders you want to create to a different order, you cannot create this in the same run as the order you want to settle, as it must already exist in the system.

In contrast to the creation of orders in the application, you cannot use reference orders [Extern] or model orders [Extern] in the process of transferring old, or external data from external systems.

Activities

Triggering Old and External Data Transfer [Seite 86]
Old or External Data Transfer

1. Choose Internal orders → Environment → Data transfer → Master data
2. Enter the name of the sender structure you have defined.
3. Enter the file name of the external file containing the sender structure. Then choose Execute.

If you wish to collectively process the internal orders that are to be created in the SAP system, (for example, releasing them collectively), then you can summarize them into one order group after transferring them from the external system. If you wish to create an order group, you can, for example, use the name of the person entering data (ERNAM field) and the date it was entered (ERDAT field).

Results

The SAP system creates new internal orders using the transferred data from the external system.
Example: Filled Sender Structure

The sender structure below has the same structure as the SAP receiver structure OREXT. The minimum data field entries are made for creating an internal order that is to be fully settled to a WBS element.

If required, you can obtain the current OREXT receiver structure from the Data Dictionary. Choose Tools → ABAP Workbench → Development → Dictionary.

Example of an ORSEND Structure with entries

<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Length</th>
<th>Short Description</th>
<th>Field Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUFNR</td>
<td>CHAR</td>
<td>12</td>
<td>Order number</td>
<td>' '</td>
</tr>
<tr>
<td>AUART</td>
<td>CHAR</td>
<td>4</td>
<td>Order type</td>
<td>'0100'</td>
</tr>
<tr>
<td>KTEXT</td>
<td>CHAR</td>
<td>40</td>
<td>Short text</td>
<td>Order to WBS</td>
</tr>
<tr>
<td>KOKRS</td>
<td>CHAR</td>
<td>4</td>
<td>Controlling area</td>
<td>'0001'</td>
</tr>
<tr>
<td>BUKRS</td>
<td>CHAR</td>
<td>4</td>
<td>Company code</td>
<td>'0001'</td>
</tr>
<tr>
<td>GSBER</td>
<td>CHAR</td>
<td>4</td>
<td>Business area</td>
<td>'0001'</td>
</tr>
<tr>
<td>WERKS</td>
<td>CHAR</td>
<td>4</td>
<td>Plant</td>
<td>' '</td>
</tr>
<tr>
<td>PRCTR</td>
<td>CHAR</td>
<td>10</td>
<td>Profit center</td>
<td>' '</td>
</tr>
<tr>
<td>KOSTV</td>
<td>CHAR</td>
<td>10</td>
<td>Responsible cost center</td>
<td>TEST_001</td>
</tr>
<tr>
<td>POSID</td>
<td>CHAR</td>
<td>24</td>
<td>WBS element</td>
<td>' '</td>
</tr>
<tr>
<td>STORT</td>
<td>CHAR</td>
<td>10</td>
<td>Location</td>
<td>' '</td>
</tr>
<tr>
<td>SOWRK</td>
<td>CHAR</td>
<td>4</td>
<td>Plant for location</td>
<td>' '</td>
</tr>
<tr>
<td>ASTNR</td>
<td>NUMC</td>
<td>2</td>
<td>Order Status</td>
<td>' '</td>
</tr>
</tbody>
</table>
### Example: Filled Sender Structure

<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VOGRP</td>
<td>CHAR</td>
<td>4</td>
<td>Group locked. Business Transaction</td>
</tr>
<tr>
<td>PDAT1</td>
<td>DATS</td>
<td>8</td>
<td>Planned release date</td>
</tr>
<tr>
<td>PDAT2</td>
<td>DATS</td>
<td>8</td>
<td>Planned technical completion date</td>
</tr>
<tr>
<td>PDAT3</td>
<td>DATS</td>
<td>8</td>
<td>Planned closing date</td>
</tr>
<tr>
<td>ASTKZ</td>
<td>CHAR</td>
<td>1</td>
<td>Statistical order indicator</td>
</tr>
<tr>
<td>WAERS</td>
<td>CUKY</td>
<td>5</td>
<td>Order currency</td>
</tr>
<tr>
<td>KALSM</td>
<td>CHAR</td>
<td>6</td>
<td>Costing Sheet</td>
</tr>
<tr>
<td>ZSCHL</td>
<td>CHAR</td>
<td>6</td>
<td>Overhead key</td>
</tr>
<tr>
<td>ABGSL</td>
<td>CHAR</td>
<td>6</td>
<td>Results analysis key</td>
</tr>
<tr>
<td>AWSLS</td>
<td>CHAR</td>
<td>6</td>
<td>Variance key</td>
</tr>
<tr>
<td>ABKRS</td>
<td>NUMC</td>
<td>2</td>
<td>Processing group</td>
</tr>
<tr>
<td>KSTAR</td>
<td>CHAR</td>
<td>10</td>
<td>Settlement Cost Element</td>
</tr>
<tr>
<td>KOSTL</td>
<td>CHAR</td>
<td>10</td>
<td>Settle order to cost center</td>
</tr>
<tr>
<td>SAKNR</td>
<td>CHAR</td>
<td>10</td>
<td>Settle order to G/L account</td>
</tr>
<tr>
<td>USER0</td>
<td>CHAR</td>
<td>20</td>
<td>Applicant</td>
</tr>
<tr>
<td>USER1</td>
<td>CHAR</td>
<td>20</td>
<td>Applicant tel. no.</td>
</tr>
<tr>
<td>USER2</td>
<td>CHAR</td>
<td>20</td>
<td>Responsible person</td>
</tr>
</tbody>
</table>
### Example: Filled Sender Structure

<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USER3</td>
<td>CHAR</td>
<td>20</td>
<td>Responsible person tel. no.</td>
</tr>
<tr>
<td>USER4</td>
<td>CHAR</td>
<td>14</td>
<td>14-char. text field</td>
</tr>
<tr>
<td>USER5</td>
<td>DATS</td>
<td>8</td>
<td>Application date</td>
</tr>
<tr>
<td>USER6</td>
<td>CHAR</td>
<td>15</td>
<td>Department</td>
</tr>
<tr>
<td>USER7</td>
<td>DATS</td>
<td>8</td>
<td>Work start date</td>
</tr>
<tr>
<td>USER8</td>
<td>DATS</td>
<td>8</td>
<td>Work finish date</td>
</tr>
<tr>
<td>USER9</td>
<td>CHAR</td>
<td>1</td>
<td>Work approved indicator</td>
</tr>
<tr>
<td>VNAME</td>
<td>CHAR</td>
<td>6</td>
<td>Joint venture</td>
</tr>
<tr>
<td>RECID</td>
<td>CHAR</td>
<td>2</td>
<td>Cost type</td>
</tr>
<tr>
<td>ETYPE</td>
<td>CHAR</td>
<td>3</td>
<td>Investment class</td>
</tr>
<tr>
<td>TXJCD</td>
<td>CHAR</td>
<td>15</td>
<td>Tax jurisdiction code</td>
</tr>
<tr>
<td>JV_JIBCL</td>
<td>CHAR</td>
<td>3</td>
<td>JIB/JIBE class</td>
</tr>
<tr>
<td>JV_JIBSA</td>
<td>CHAR</td>
<td>5</td>
<td>JIB/JIBE subclass</td>
</tr>
<tr>
<td>SCOPE</td>
<td>CHAR</td>
<td>2</td>
<td>Object class</td>
</tr>
<tr>
<td>KDAUF</td>
<td>CHAR</td>
<td>10</td>
<td>Sales order number</td>
</tr>
<tr>
<td>KDPOS</td>
<td>NUMC</td>
<td>6</td>
<td>Item number Sales order</td>
</tr>
<tr>
<td>AUFEX</td>
<td>CHAR</td>
<td>20</td>
<td>External order number</td>
</tr>
</tbody>
</table>
1. Distribution rules
The distribution rules are substructures of ORSEND. To reach them in the Data Dictionary, choose Extras \rightarrow Substructures \rightarrow Explode all subst.

<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>IVPRO</td>
<td>CHAR</td>
<td>6</td>
<td>Capital investment measure profile</td>
<td></td>
</tr>
<tr>
<td>AKSTL</td>
<td>CHAR</td>
<td>10</td>
<td>Requesting cost center</td>
<td></td>
</tr>
<tr>
<td>PERBZ_1</td>
<td>CHAR</td>
<td>3</td>
<td>Settlement Type</td>
<td>FUL</td>
</tr>
<tr>
<td>URZUO_1</td>
<td>CHAR</td>
<td>3</td>
<td>Source assignment</td>
<td></td>
</tr>
<tr>
<td>PROZS_1</td>
<td>DEC</td>
<td>5</td>
<td>Settlement percentage rate</td>
<td>'100'</td>
</tr>
<tr>
<td>AQZIF_1</td>
<td>DEC</td>
<td>10</td>
<td>Settlement equivalence number</td>
<td>'0'</td>
</tr>
<tr>
<td>BETRR_1</td>
<td>CURR</td>
<td>15</td>
<td>Amount/amount rule</td>
<td>'0'</td>
</tr>
<tr>
<td>KONTY_1</td>
<td>CHAR</td>
<td>2</td>
<td>Account assignment category</td>
<td>PR</td>
</tr>
<tr>
<td>GSBER_1</td>
<td>CHAR</td>
<td>4</td>
<td>Business area</td>
<td></td>
</tr>
<tr>
<td>BUKRS_1</td>
<td>CHAR</td>
<td>4</td>
<td>Company code</td>
<td></td>
</tr>
<tr>
<td>HKONT_1</td>
<td>CHAR</td>
<td>10</td>
<td>G/L account number</td>
<td></td>
</tr>
<tr>
<td>PRCTR_1</td>
<td>CHAR</td>
<td>10</td>
<td>Profit center</td>
<td></td>
</tr>
<tr>
<td>KOSTL_1</td>
<td>CHAR</td>
<td>10</td>
<td>Receiving cost center</td>
<td></td>
</tr>
<tr>
<td>AUFNR_1</td>
<td>CHAR</td>
<td>12</td>
<td>Order number</td>
<td></td>
</tr>
<tr>
<td>POSID_1</td>
<td>CHAR</td>
<td>24</td>
<td>WBS element</td>
<td>04717.1A.010</td>
</tr>
<tr>
<td>ANLN1_1</td>
<td>CHAR</td>
<td>12</td>
<td>Main asset number</td>
<td></td>
</tr>
</tbody>
</table>
### Example: Filled Sender Structure

<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANLN2_1</td>
<td>CHAR</td>
<td>4</td>
<td>Asset subnumber</td>
<td></td>
</tr>
<tr>
<td>NPLNR_1</td>
<td>CHAR</td>
<td>12</td>
<td>Network number account assignment</td>
<td></td>
</tr>
<tr>
<td>VORNR_1</td>
<td>CHAR</td>
<td>4</td>
<td>Business activity number</td>
<td></td>
</tr>
<tr>
<td>KDAUF_1</td>
<td>CHAR</td>
<td>10</td>
<td>Sales order number</td>
<td></td>
</tr>
<tr>
<td>KDPOS_1</td>
<td>NUMC</td>
<td>6</td>
<td>Item number Sales order</td>
<td></td>
</tr>
<tr>
<td>KSTRG_1</td>
<td>CHAR</td>
<td>12</td>
<td>Cost object</td>
<td></td>
</tr>
</tbody>
</table>

2. Distribution rule

| PERBZ_2  | ...   | ...    |                                      |         |
| PERBZ_3  | ...   | ...    |                                      |         |

3. Distribution rule

| PERBZ_2  | ...   | ...    |                                      |         |
Planning

Purpose

During internal order planning, you enter costs, activities and business processes that you expect to incur during the life cycle of an order. Using internal order planning, you can compare plan and actual costs, and carry out a differentiated variance analysis.

You can plan individual internal orders and groups of orders with the same order type (see also: Order Groups [Seite 68]).

Unlike cost center planning, you can plan overhead rates on internal orders (except for statistical orders) as well as overheads.

Implementation Considerations

Cost planning is performed mostly on internal orders with long durations. You do not usually plan internal orders that only exist for a very short period (such as, internal orders for unexpected small repairs). You can plan order costs in more than one version and using various planning forms, depending on when you are planning and the information available.

Integration

You can manage the approved cost framework for an internal order or an order group using Budget Management [Seite 194].

Features

The SAP system provides you with a range of planning functions for the processing of internal orders covering the different levels of planning detail required at different stages of order execution:

Integrated Planning

Integrated Planning for Internal Orders [Seite 100] allows you to settle internal order plan data to cost centers or business processes. You can then transfer them to Profit Center Accounting and the General Ledger. To do this, you should note the difference between:

- **Plan-Integrated Internal Orders**

  Plan-integrated internal orders enable you to plan cost elements and activity inputs integrated with cost centers and business processes in a plan version. The system updates plan allocations directly to the cost center or the business process. You can settle plan integrated internal orders to cost centers and business processes in the plan. You then transfer the plan data to Profit Center Accounting and the Extended General Ledger.

- **Non-Plan-Integrated Internal Orders**

  You can only plan costs and activities locally on non-plan-integrated internal orders. There is no scheduling on the performing cost centers or business processes. You cannot execute a plan settlement of these orders to cost centers and business
processes. Neither can you transfer the data to Profit Center Accounting or the General Ledger.

Planning in More Than One Plan Version

Information on an internal order changes constantly during the planning phase. This means it may be necessary to plan an internal order in more than one version. This corresponds to the planning process in normal business practice. You can plan internal orders in as many versions as you wish.

These individual plan versions can be:
- Stored separately in the system
- Changed
- Copying (see also: Copy Versions [Seite 106])
- Compared using the reports available in the information system (for example, plan/plan comparisons, comparisons between actual costs and the various plan versions). So for example, you can use this to compare best and worst-case planning scenarios.

Types of Planning

- **Manual Internal Order Planning [Seite 110]**
  Activity-dependent or activity independent planning of both primary and secondary costs, which occur as a result of activity input.
- **Overall Planning for Internal Orders [Seite 112]**
- **Unit Costing [Seite 128]**
- **Primary Cost and Revenue Planning [Seite 129]**
- **Planning Activity Input [Seite 138]**
- **Planning Statistical Key Figures [Seite 139]**
- **Planning Allocations [Seite 185]**
  Automatic internal order planning of the allocations made at period-end closing.
- **Periodic Reposting in Planning [Seite 186]**
- **Planning Overhead Rates [Seite 187]**
- **Planned Settlement for Internal Orders [Seite 188]**
- **Allocations from Cost Centers [Seite 190]**
  Planning of allocations that occur during period-end closing from cost centers to orders.

Period-End Closing

In period-end closing, you can debit an order in version 0 using overhead, assessments or distribution. You can also execute a periodic reposting of plan-integrated internal orders. You do this by debiting or settling indirect activity allocation.

Planning Documentation

You can record changes to internal order planning in planning documents. You normally do so for changes in a plan that has already been approved. You use the Write plan line items activity,
Planning

which you allow by setting an appropriate user status (see also: Status Management for Internal Orders [Seite 58]) to define whether and from which status planning documents are written.
Short-Term Business Planning

Use

Cost center planning is a component of short-term business planning. Short-term refers to a planning horizon for the duration of a fiscal year. In short-term business planning, you create the following sub-plans:

- One or more sales plans
- One or more master production schedules
- One or more cost plans
- One or more operating profit plans

The planning process combines the individual planning areas into an integrated planning network.

The following figure shows how the individual planning areas are linked to one another.
Sales Plan
The starting point for short-term planning is the sales plan. It establishes the quantities to be sold in the planning period. Generally, the sales plan is created by Sales and Distribution (SD) and Controlling (CO). The plan sales volumes are forwarded to Production Planning (PP) because this module reconciles plan capacities and activities.

Master Production Schedule
The master production schedule is worked out in close coordination with the sales plan. The master production schedule determines both the capacities and the quantity requirements for raw materials and operating supplies. The plan activities established here are forwarded to the cost centers which must supply these capacities in the form of units of activity. Moreover, the cost center managers must plan the costs to be incurred and the activity quantities to be taken from other cost centers based on the plan capacities and activities.

Cost Center Plan
Cost center planning consists of the following areas:
- Planning of activity quantities and/or prices
- Planning of costs expected to be incurred
- Planning statistical key figures, which are used as the basis for the allocation of costs
Together with sales planning, cost planning is the starting point for sales and profit planning.

Sales and Profit Plan
You can calculate revenues based on the planned sales volume and prices, from which the plan contribution margins can be derived. To do this, the revenues are compared with the plan costs.

Financial Budget
Interdependencies exist between cost, sales, and financial planning. The financial planning can trigger a restrictive effect on production planning and cost center planning.
Currencies in Planning

Use

Currencies can be updated for both plan and actual values. The use of more than one currency must be allowed in the controlling area.

You can plan in the following currencies:

- Controlling area currency [Extern]
- Object currency [Extern]
- Transaction currency [Extern]
- Currency of the user’s choice

The controlling area is always used, regardless of whether you have selected All currencies in the control indicators for your controlling area.

You specify the object currency in the master data of the given planning object, for example, a cost center. The object and transaction currencies are only active if you have selected All currencies in the controlling area for the relevant fiscal year.

You can select any permitted currency as the transaction currency. The system always derives the value date and the exchange rate type from the fiscal-year dependent data of the version.

User-Definable Currency

In addition to planning in controlling area, object or transaction currencies, you can also plan in a currency of your choice. You can also translate your plan values, for example, into euro. You can include the user-definable currency in additional columns or rows of the planning layout for cost element planning. You can then display or maintain this currency.

💡

If you have made a change to the exchange rates between two planning meetings for activity input (for example, due to the EURO changeover), this may cause large differences between the values in the object currency for the receiver, and for the sender, even though both have the same currency.

This is due to the fact that the system does not revaluate when the exchange rates change.

To avoid data inconsistencies, you can create a new version as a buffer, and copy your prices into it.

Then copy the prices back to your original version.

You need to copy the objects as well as the prices for orders and projects that are not plan integrated.

The following key figures are available for plan values in user-definable currency:

- Planned fixed costs
- Planned variable costs
Currencies in Planning

- Planned total costs
- Actual total costs

If the appropriate rows or columns exist in the planning layout, you can set your user-definable currency in the initial screen for manual planning. Choose `Settings -> User-definable currency`.

If you use the user-definable currency, you can enter the following attributes:

- Currency
- Exchange rate type
- Value date for the translation

If you do not specify a currency, the system uses the controlling area currency. If you do not enter an exchange rate type, the SAP R/3 System derives the exchange rate type and the value date from the fiscal-year dependent version parameters.

You can make default settings for your user-definable currency in `Customizing for Cost Center Accounting` or `Activity-Based Costing`. Choose `Planning -> Manual Planning -> Create User-Defined Planner Profiles`.

You can also define the relevant Set/Get parameters as user parameters in your user master data.

The SAP R/3 System translates into the user-definable currency, or from the user-definable currency into controlling area currency, regardless of whether you have selected `All currencies` in the control indicators for the controlling area.

The SAP R/3 System does not write the user-definable currency to the database when postings occur.

Currencies in Planning Layouts

If you do not use the transaction currency as a characteristic in your planning layout:

- The SAP R/3 System automatically uses the object currency for newly created planning records
- As of Release 4.0, the system updates the accumulated plan and actual costs in controlling area and object currencies across all data records, even if the costs were updated under different transaction currencies.

If you change these accumulated costs, the system updates under the transaction currency corresponding to the object currency, if such a record already existed. Otherwise, the update is executed using the first transaction currency that the system finds in the database.

You can only include the key figure “Actual costs in transaction currency” in those planning layouts that use the characteristic “Transaction currency”.

If you plan in the transaction currency, the system automatically translates the plan data to cost center and controlling area currency during the planning process.

When planning in different currencies, the planning results are always stored in transaction currency, object currency, and controlling area currency.
You plan raw materials on cost center 4210 in Japanese Yen JPY (the raw materials come from Japan, and are invoiced in Yen). However, you plan personnel costs in US dollars USD.

The following situations might exist:

1. You want to plan in USD only
   Enter USD as the transaction currency.

2. You want to plan in JPY only.
   Enter JPY as transaction currency.

3. You want to plan in both currencies.
   Enter an asterisk (*).
Integrated Planning for Internal Orders

Features

Integrated planning for Internal Orders with Cost Centers or Business Processes

In integrated planning for internal orders, cost centers or business processes, you can integrate cost element and activity input planning for an internal order with cost center or business process planning. You can do this in a plan version. All the planned business allocations on the internal order (also repostings, assessments and so on) are then automatically updated on the sender/receiver cost center, or on the sender/receiver business process.

You can only use integrated planning for Internal Orders with Cost Center Accounting or Activity Based Costing, if the internal order already exists at the time of cost center or business process planning. You cannot lock the plan version. You can only plan locally for internal orders that are not plan-integrated. The same applies to internal orders that did not exist when you planned the cost centers or business process. You can also manually plan costs and activities on receiver cost centers or business processes, when required.

For more information, see:

- Planning Order Costs on Cost Centers [Extern]
- Cost Center Planning [Extern] for planning on cost centers.
Cost center two plans to take 2000 production hours from cost center one, using an internal order. The planning of activities on the cost center and internal order can be integrated, because the internal order already exists in the system, and the same time horizon is planned. If integrated planning is active, the scheduled activity for the order is updated on cost center one. The settlement of the internal order in the plan is updated on cost center two (the receiving cost center).

Cost center three plans to take 700 production hours from cost center one. No internal order exists at the time of cost center planning. The internal order is created later and so cannot be integrated into planning. You need to execute cost center planning manually, and independently from order planning.

**Integrated Planning of Internal Orders with Profit centers, and the Extended General Ledger**

If you activate integrated planning with Profit Center Accounting and the Extended General Ledger, the system transfers planning data for internal orders and Cost Center Accounting to Profit Center Accounting and the Extended General Ledger.
You need to activate the *Integrated Planning* indicator in the version. This ensures that the system makes the planning data for internal orders available to other applications in the SAP system.

**Activities**

For more information on activating integrated planning for internal orders, see Integrated Planning Indicator in Versions [Seite 103].
Integrated Planning Indicator in Versions

When you create a controlling area, the system automatically creates the Plan/actual (0) version. Actual values are posted in this version. If you only want to plan in one version, you can plan in this version (version 0).

If you want to plan in more than one version, you must define plan versions before you start. To do this, choose Maintain Versions [Extern] in the implementation guide (IMG) for Overhead Cost Orders.

Integrated Planning for Internal Orders and Projects

⚠️

When you set the indicator for internal orders or projects, note that a project cannot be plan integrated and statistical at the same time.

The following indicators are used for integrated planning for internal orders and projects:

- Integrated planning in the order master data or the order type.
- Integrated planning with Cost Center Accounting and Activity-Based Costing in versions.
- Integrated planning with Profit Center Accounting and the Extended General Ledger in the version.

Activating Integrated Planning for Internal Orders with Cost Center or Business Process Planning

To activate integrated planning for internal orders with Cost Center Accounting or Activity-Based Costing you must set the following indicators:

- **Integrated planning indicator In the order master data**
  You can set the indicator in the order type as a default value. Choose Integrated Planning in Order Types as Default [Extern] in the Implementation guide for Overhead Cost Orders.

- **The Integrated Planning indicator in the version. Cst-Ac./BProcess-Ac.**
  To do this, choose Settings for Fiscal Year in the version. Highlight the required fiscal year and choose Detail.

This gives you the following options:

<table>
<thead>
<tr>
<th></th>
<th>Plan-Integrated Internal Order</th>
<th>Non-Plan-Integrated Internal Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integrated planning with Cost Center Accounting and Activity-Based Costing active</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>Integrated planning with Cost Center Accounting and Activity-Based Costing not active</td>
<td>3</td>
<td>4</td>
</tr>
</tbody>
</table>

- **Integrated planning with Cost Center Accounting and Activity-Based Costing active, plan-integrated order (1).**

  In this case, integrated planning is active for the internal order with Cost Center Accounting and Activity-Based Costing.
Integrated Planning Indicator in Versions

You can plan activity inputs on plan-integrated internal orders. Scheduled activity is updated by the system on the sender cost center or the sender business process.

If you are planning overhead rates, overhead is applied to the internal order and the credit objects are credited. The corresponding credit objects must also be plan-integrated in this case.

If you have activated Profit Center Accounting and the General Ledger, you can transfer the internal order plan data to them.

In the plan, you can settle to the following receivers:

- Cost centers
- Business processes
- Internal Orders
- WBS elements
- Profitability segments

You can make periodic postings of plan integrated internal orders.

💡

As a rule, it is a good idea to activate the Integ. planning indicator CstAc./BProcess-Ac in version 0.

- Integrated planning with Cost Center Accounting and Activity-Based Costing is active, but the internal order is not plan-integrated (2)
  
  If you only want to plan internal orders locally despite active integrated planning with Cost Center Accounting and Activity-Based Costing, then you do this non-plan-integrated.

- Integrated planning with Cost Center Accounting and Activity-Based Costing is not active, but the internal order is plan-integrated (3)
  
  This setting is only useful if you wish to create a complete copy of a plan-integrated version (of a plan-integrated internal order) to document planning history. Then use the target version, non-plan integrated.

- Neither indicator is active (4)
  
  You plan your internal order locally only. No integrated planning occurs.

Activation of Integrated Planning with Profit Center Accounting and the Extended General Ledger

If integrated planning of internal orders with Cost Center Accounting and Activity-Based Costing is active, you can transfer the planning data for internal orders and cost centers to other profit centers and the Extended General Ledger. To do this, highlight Integ. Planning in the version.

As a rule, it is sufficient to postpone the transfer to other applications, until cost center planning and order planning is complete. This is because only the final planning results are of importance to Profit Center Accounting and the Extended General Ledger. Moreover, if you activate the Integ. planning indicator, every planning change leads to the update of plan line items, which diminishes system performance.
Integrated Planning for Different Planning Types

The following is a summary of the planning types, showing where integrated planning is and is not allowed:

<table>
<thead>
<tr>
<th>Planning type</th>
<th>Integrated Planning with Cost Center Accounting and Activity-Based Costing</th>
<th>Integrated Planning with Profit Center/Extended General Ledger</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overall planning</td>
<td>Allowed</td>
<td>Not possible</td>
</tr>
<tr>
<td>Primary cost planning</td>
<td>Allowed</td>
<td>Possible</td>
</tr>
<tr>
<td>Revenue planning</td>
<td>Allowed</td>
<td>Possible</td>
</tr>
<tr>
<td>Activity input planning</td>
<td>Allowed</td>
<td>Possible</td>
</tr>
<tr>
<td>Unit costing</td>
<td>Not allowed</td>
<td>Not possible</td>
</tr>
</tbody>
</table>

Locking a version

If integrated planning with Cost Center Accounting and Activity-Based Costing is active, and you set the Version locked indicator, you are no longer able to plan on plan-integrated internal orders. You can, however, continue to plan on internal orders, which are non-plan-integrated.
Copying Planning

Use
Transferring planning data from a source version (reference) to a target version.

Integration
If the target version is plan-integrated, no allocation data is copied. An exception to this is scheduled actual data on the internal order.

You can use a plan integrated internal order in a version as a copy reference. To do this, you need to set the Copy indicator in the version and integrated planning needs to be active for Cost Center Accounting.

Features
For internal orders you can copy from actual to plan as well as plan to plan. When you copy from actual data to planning data, the system assigns the actual business transactions to the corresponding business transactions that can be manually planned.

For projects, you can copy from actual data to planning data.

Activities
1. In the corresponding application menu, choose Planning → Planning aids → Copy planning → Copy actual to plan/plan to plan.
2. Select the template (actual/plan) and the target (plan) for copying.
   - If you want to copy the planning data for primary costs, revenues, activity inputs, statistical key figures and fiscal-year-dependent overall planning, enter the corresponding fiscal year.
   - If you want to copy the overall values from overall planning, and you do not want to copy any fiscal-year dependent planning data, activate the Overall values indicator and do not enter a fiscal year in the input screen.

You can copy individual WBS elements and subhierarchies in projects.

3. When you activate selection variants, you can create a variant. Choose the required selection criteria in the next screen and save the variant.

   The selection variants are determined according to the settings in the database profile (with hierarchies and so on) for projects.

4. In the Existing target data group, specify whether any data that already exists in the target version should be overwritten.
   - Do not change
     The system checks whether there is already any planning data in the target version for the corresponding planning. This data is not overwritten.
## Copying Planning

- **Reset and overwrite**
  The system resets all the data in the target version for this planning transaction, and overwrites it with planning data from the template version.

⚠️ If you chose *Total up planning values automatically* in the planning profile, this setting is **not** taken into account. If you wish to use this function for your copied planning, you need to activate the function again in the copy.

**See also:**
- [Notes on Copying Planning](#)
- [Notes on "Copying from Actual to Plan"](#)
Notes on "Copying From Actual to Plan"

Use

Copying actual to plan is devised as an aid for manual planning.

You can only copy the postings from actual data that can also be manually planned. Once you have finished copying, you need to execute all the actual periodic allocations (such as, periodic repostings, distribution, accruals and so on) in planning, to ensure that you have the same values there.

The system copies the following actual data for internal orders/projects:

- **Primary costs**
  - You can only copy postings that can be manually planned:
    - a. Primary postings from Financial Accounting (COIN business transaction)
    - b. Repostings in Controlling (the RKU1 and RKU3 business transactions)
  - The system does **not** copy "automatic" business transactions (periodic reposting, distribution).

- **Revenues**
  - You can copy statistically posted revenues on internal orders/projects. Planning is then also statistical.

- **Activity allocation**
  - You can copy activity allocations that were manually posted. The system does not copy automatic postings. It updates planning in the same way as in manual planning, only the quantity is planned. The costs that incur as a result are calculated by multiplying the plan quantity and the plan price. '
  
The system updates statistical key figures in planning data in exactly the same way in which it posted them in actual data (activity dependent or independent).

**Currency Translation**

Note that after copying, the actual and plan values can be differentiated using another currency translation. In the actual data, the system translates the values for each posting, and takes the average rate on the posting date. In the planning data, the system translates the totals each period, using the assumed exchange rate and the value date of the plan version.
Notes on Copying Planning

Use

*Copy planning* is devised to facilitate manual planning. You can only copy business transactions that can be planned manually. You need to execute periodic allocations again after copying.

Currency Translation

You can specify the leading currency for costs and prices during copying. The system automatically selects the controlling area currency for the prices and the transaction currency for the costs. However, if you have deactivated *all currencies* in the settings for the controlling area in the target fiscal year, then the system automatically sets the controlling area currency as the leading currency. The system uses the leading currency from the source version for the target version. The system then calculates all the other currencies in the target version, using the value date and the exchange rate type.

Entering Overall Planning, Dependent on Year

- Values from the version = Exchange rate type (entry is mandatory)
- The entry of a value date is optional, if no date is entered, the system uses the first fiscal year.

Entering Overall Planning, Independent of Year

- The system takes the exchange rate type and the value date from the planning profile. The entry of the exchange rate type is optional, if no exchange rate type is entered, the system uses the exchange rate type in the version of the current fiscal year.

Performance

You can significantly improve the program runtime by doing the following:

1. Restricting the data using the display frame
   - Select only the actual data for the data available in your system and which you also wish to copy.
2. For larger amounts of data you need to use background processing.
3. When you have a large amount of data, start the copy program individually for each business process (such as, activity allocation).

See also:

*Copying Planning [Seite 106]*
*N"Copying from Actual to Plan" [Seite 108]*
Manual Internal Order Planning

Purpose
Activity-dependent or activity independent planning of both primary and secondary costs, which occur as a result of activity input.

Integration
The various types of planning are only possible if the relevant business transactions are permitted.

Features
These planning types are not mutually exclusive, but you can also use them in a combination. Depending on the information status, you use one or more of the planning types listed below. This means that for certain parts of an internal order, you can use unit costing or cost element planning, while roughly estimating the costs of the other parts of the order using overall planning.

<table>
<thead>
<tr>
<th>Function</th>
<th>Use</th>
<th>See also</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overall planning</td>
<td>Overall planning is the simplest way of planning costs on internal orders. This type of planning does not depend on cost elements. You can use it to plan overall and annual values for an internal order.</td>
<td>Overall Planning [Seite 112]</td>
</tr>
<tr>
<td>Unit costing planning</td>
<td>If you have access to more information on sources of supply, quantities and prices, you can perform unit costing taken from the overall planning.</td>
<td>Unit Costing [Seite 128]</td>
</tr>
<tr>
<td>Execution Services</td>
<td>You can store a costing model in the master data of the internal order created. Choose Extras -&gt; Costing.</td>
<td>Easy Cost Planning and Execution Services [Extern]</td>
</tr>
<tr>
<td>Cost/revenue element and activity input planning</td>
<td>You use these types of planning when you have detailed information on costs. Each planning type is carried out for one year and covers cost-element-related planning of primary costs, revenues and activity inputs. If more than one currency is permitted within your controlling area, the system will propose a value date each time you use cost element planning. You can overwrite this date if required.</td>
<td>Primary Cost and Revenue Planning [Seite 129] Planning Activity Input [Seite 138]</td>
</tr>
<tr>
<td>Planning statistical key figures</td>
<td>You can plan statistical key figures in order to calculate the business-related key figures in orders.</td>
<td>Planning Statistical Key Figures [Seite 139]</td>
</tr>
</tbody>
</table>
Overall Planning for Internal Orders

Use

Overall planning is the most important and fundamental form of order planning. This type of planning is independent of cost elements, and you use it to estimate the costs likely to be incurred for an internal order.

The following describes how you can:

- Plan overall cost for a project
- Plan the annual values for a project

Features

Overall planning is always performed in the controlling area currency.

The system updates plan costs and plan quantities (such as actual costs). These costs and quantities remain variable. This applies to primary and secondary cost planning.

Screen Sequence in Overall Planning

Planning Timeframe

You can plan either overall values or annual values.

When you access overall planning, the system provides the fiscal year you specified as the start year in the planner profile. You can define the planning profile in customizing, by choosing
Overall Planning for Internal Orders

Controlling → Internal orders → Planning → Manual planning → Define Planning Profile for Overall Planning [Extern], then store the planning profile in the order type.

You can enter the following in overall planning:

- An overall plan value for an order
- An annual plan value for each year in the order life

You can plan the timeframe for past and future dates that you specified in the planner profile. You can use planning for previous annual values to transfer old data from other systems when implementing internal orders.

Views

From Views, you can choose the values you want displayed in overall planning, (alongside the planned values you enter manually).

- Plan total
- Unit costing
- Cost element planning

See also:

Presenting Plan Values [Seite 119]

Checking Your Plan

If you require the system to check whether the cumulated planning value (the plan total of all the years) is greater than the total planning value, choose Planning values → Check.

If an error occurs, the system issues a message referring you to an error log. You can display and print this log by choosing Extras → Error log.

Further Planning Types

You can also call up the following planning types in overall planning:

- Unit Costing [Seite 128]
- Primary Cost and Revenue Planning [Seite 129]
- Planning Activity Input [Seite 138]
- Planning Statistical Key Figures [Seite 139]

Activities

For overall planning, choose Internal orders → Planning → Overall values → Change.

To obtain an overview of the overall planning for an internal order or order group, choose Internal orders → Information system → Internal order reports → More reports → List, then choose the List: Overall plan/Actual/Commitment report.
Manual Cost Planning in the Work Breakdown Structure

Purpose
If cost planning and controlling are the most important factors in a project, then enter the expected costs, activities, and business processes in manual cost planning. You can use manual cost planning to compare planning and actual costs, and thus make a differentiated variance analysis.

Implementation Considerations
If you enter planning values on the lower planning elements, then the system totals values in an upward direction (bottom-up planning). Alternatively, you can manually distribute the planning values from the planning elements at the top to those below (top-down planning).

See also:
Totaling Planning Values [Extern]

Integration
You can manage the approved cost limit for a budget by using Budget Management [Extern].

The graphic below shows how cost planning and budgeting interact.

Features
There are different types of planning and functions, which cover the different levels of detail in the various phases of a project:

Integrated Planning
Integrated planning for projects enables you to settle planning data or business processes and to pass them on the profit center and the general ledger.
Integrated planning for projects corresponds to integrated planning for internal orders.
Manual Cost Planning in the Work Breakdown Structure

For more information, see Integrated Planning for Internal Orders [Seite 100].

**Plan-Integrated Projects:**
Plan-integrated projects enable you to plan cost elements and activity inputs integrated with cost centers and business processes in a plan version. The system updates allocations directly to the cost center or the business process.

**Non-Plan-Integrated Projects:**
You can only plan costs and activities locally on non-plan-integrated projects. There is no planning on the cost centers or business processes used.

**Planning in More Than One Plan Version**
Information on a project can change during the planning phase. Cost planning in more than one version is therefore useful. This corresponds to the planning process in normal business practice. You can plan projects in as many CO-versions as you wish.

See also Plan Versions [Extern].

**Types of Planning**
The work breakdown structure provides you with different planning types on the WBS element. This is independent of the project status and the level of detail required.

You can use these types of planning **individually or together**, so you can use unit costing or cost element planning for certain subtasks in a planning element for example, depending on the information that you have available. This enables you to estimate the costs of the remaining tasks using hierarchy planning.

**Hierarchy Planning of Overall and Annual Values**
Hierarchy planning is the simplest way of planning costs. This type of planning does not depend on cost elements. The planning values are entered and displayed in a hierarchy.
Manual Cost Planning in the Work Breakdown Structure

You can estimate the expected costs for a project or planning element by, for example:
- Removing cost information from comparison objects.
- Deriving costs from contract totals.

Hierarchy planning on the work breakdown structure corresponds to overall planning for internal orders.

See also:
Overall Planning for Internal Orders [Seite 112]

If you have more information during planning, then hierarchy planning is a useful start for two alternative types of more detailed project cost planning.

Cost Element and Activity Input Planning (Detail Planning) [Seite 122]
This type of planning covers planning (by cost element) of primary costs, revenues, activity input and statistical key figures.

Unit Costing [Seite 128]
If you have accurate information on resources, quantities, and prices, you can use unit costing as a highly detailed planning method for planning project costs. You can execute unit costing on an overall and an annual basis.
Cost Planning

**Prerequisites**

You need to create a work breakdown structure [Extern] to be able to plan overall cost for a project.

**Procedure**

1. In either Logistics or Accounting, choose Project System ->Financials -> Planning -> Costs in WBS -> Overall Values -> Change
2. The Cost Planning: Initial Screen appears.
3. Enter data as required.

   ![Note](Note.png)

   The first time that you plan costs for a project, the system automatically creates planning version 0.
4. Choose Continue.
   It displays the project with its WBS elements and the fields (ready for input) for the overall planning values.
   Cost planning initially uses the overall cost likely to be incurred for a project.
   In the planning profile, you can specify whether cost planning is possible on all WBS elements, or only on those that were defined as planning elements. Define planning elements in the master data for the project (operative indicator).
6. Enter Planning values for the WBS elements on which you wish to plan.
7. Use Annual overview or Annual values to enter the time frame for distribution of the planning values.
8. Choose Check.
9. The system checks your cost planning.
   For more information, see Check Cost Planning [Seite 124].
10. Save your cost planning.
Presenting Planning Values

Features
In addition to overall and annual planning values, you can see the following values by choosing Views:

Distributed Value
This is calculated as follows:

| Structure planning values of lower-level WBS elements |
| Planning values for cost elements, from lower-level WBS elements |
| Unit costings from lower-level WBS elements |

💡
If you planned by cost element in an earlier release, then you can convert these planning values with the BPDIST00 report.

Distributable Value
This is the difference between the planning value and the distributed value.

Plan Total of a WBS Element
This is calculated as follows:

| Structure planning value (independent of cost element) |
| Cost element planning value |
| Unit costing value |
| Value of the additive orders for the project, meaning the orders assigned to this and all lower-level WBS elements. |
| Value of the additive networks and network activities that are assigned to this and all lower-level WBS elements (= planning costs for networks or network activities) |
| Plan total |

💡
Additive values consist of:

| Overall planning value (independent of cost element) |
| Cost element planning value |
| Unit costing values |

Order / Network
This consists of the planning values of additive orders or networks.
Presenting Planning Values

Planning values for **additive orders** consist of:

- **Approximate planning values**
- **Planning values for cost elements**
- **Unit costing**

Planning values for **additive networks** consist of:

- **Costings from internally and externally processed business transactions**
- **Values from cost transactions**

**Previous Year**

These are the planning values of the previous year

**Cumulated Value**

This is the plan total of all years.

**Remainder**

This is the difference between the total planning value and the cumulated value.

**Unit costing values**

**Values from Cost element Planning**

You use the parameters in the planning profile to specify which default values the system displays with the planning value, when you access cost planning.

**Settings**

You determine whether you want to enter planning values in 1; 10; 100; 1,000; 10,000; 100,000; or millions (**0 to **6) of currency units via **Settings → Scaling**. Depending on the currency, you can also choose more than one decimal place for the display of your planning values.
**Entering Planning Texts**

**Use**

You can enter explanatory short texts or descriptive long texts for the cost planning of a project, or for chosen and selected WBS elements.

**Entering planning text as short or long text**

1. In the *WBS Element Overview* or *Annual Overview* screen, choose *Goto -> Text*. The *Text* dialog box appears. The *Document date* field is defaulted with today's date.
2. You can store a short text in the *Text* field.
3. To supplement or replace a long text, enter a name in the *Long text* field for the text that you wish to store.
4. Choose *Continue*. The system informs you that this text was not found.
5. Choose *Continue*. A dialog box appears, in which you are asked if you wish to create the text for the first time.
6. Choose *Continue*. The SAPscript Editor appears.
7. Enter the text.
8. Save your text.
9. Go back to Budgeting.

**Changing long texts**

1. In the *WBS Element Overview* or *Annual Overview* screen, choose *Goto -> Text*.
2. The *Text* dialog box appears.
3. Enter the text name in the *Long text* field
4. Choose *Change long text*. The SAPscript Editor appears, in which you can change the text.
5. Save your changes.

**Searching for long texts**

1. Place the cursor on the *Long text* field and choose the input help.
2. The system then displays the *Standard text catalog* dialog box.
3. Enter one or more search criteria.
4. Start the text search by choosing *Program -> Execute*.
5. The system displays a list of texts found, from which you can make an appropriate selection.
**Cost Element and Activity Input Planning (Detail Planning)**

**Use**
You can use cost planning with cost elements (detail planning) if you have exact information. This is mostly only possible in the later stages of a project.

**Features**
Detail planning takes place on an annual basis and includes the planning by cost element of:

- Primary costs
- Activity input
  Planning activity input is the quantity-based planning of secondary cost elements on a project that uses activity from a sender cost center.
- Statistical key figures
  You can plan statistical variables, such as, the number of employees.

You need to save the values from the detail planning separately.

For more information on planning statistical key figures, see the documentation for Cost Center Accounting, under [Planning Statistical Key Figures](Seite%20139) [Seite 139].

For more information on cost planning by cost elements, see [Cost Center Accounting](Extern) [Extern].
Copying Views

Use
You can display various values next to planning values in the WBS element overview and the annual overview. You can use part of the view that you set up as a planning value, or you can add it to existing planning values.

Procedure
1. Choose Views to select the view that you wish to take as a planning value or add to existing values.
2. Select the WBS elements that you wish to copy the selected view to.
3. Choose Edit -> Copy view
   Enter the percentage of the view that is set up, then choose whether this value should overwrite the existing value or be added to it.
4. Choose Continue.
   According to the percentage that you chose, the system takes the values from the installed view as planning values or adds them to existing planning values. It does this for the selected WBS elements.
   You can adapt the values by overwriting.
5. Save the planning values by choosing Planning values -> Save without checks.
Checking Cost Planning

Use

Once you have planned the costs, you can check the planning.

- The system checks within the project structure, whether the planning totals of a lower level in the work breakdown structure are greater than the planning value at a higher level.
- If planning for overall values is set up in the planning profile, the system checks within the time level, whether the total of the annual planning values is greater than the structure planning value.

Procedure

1. You are in the Change Cost Planning: WBS Element Overview screen.
2. Choose Check.
   The Structure Planning: Display Messages screen appears.
3. The system lists the incorrectly planned WBS elements. You can call up error logs for the WBS elements, which detail the cause of the errors.
4. Choose Continue to close the window.
   The Change Cost Planning: WBS Element Overview screen appears again.
   The incorrectly planned WBS elements are highlighted in red.
5. If necessary, correct your planning.
6. Overwrite the corresponding planning values.
7. Choose Check.
8. Save your cost planning.

Results

The following is a result of any errors that occur:

The system highlights the incorrectly planned WBS elements in the Overview and Annual Overview screens.

The system also displays a message referring you to an error log. To display and print the error log, choose Extras -> Display error log. The log displays the incorrectly planned WBS and planning elements and displays the planning values and distributed values for comparison purposes. To call up an explanatory text, choose Long text, or double-click on a row in the error log.
Planning Annual Values

Use

You can plan the years that are likely to be needed to realize a project either before or after you plan overall cost.

Planning Annual Values for a WBS Element

1. Call up the project that you wish to plan for. The Change Cost Planning: WBS Element Overview screen displays the project with its WBS elements in the start year.
2. Select the planning element for which you want to plan the annual values.
3. Choose Annual values. The system displays the overview screen for the annual planning, and the overall planning value (if one exists) for the selected planning element and the fields (ready for entry) for the annual values.
4. Enter your annual planning value for the selected planning element.
5. Execute your annual planning for all of the planning elements in the same way.
6. Check the planning by choosing .
7. Save the planning values by choosing .

The Adjust and Total up functions are also available for planning annual values.

Planning Annual Values for all WBS Elements

Instead of specifying the annual values for a particular planning element using the annual overview, you can also plan on all the planning elements for a particular year.

1. Choose Year. The system displays the element overview for the start year, with the fields ready for planning value entry. If you do not want to start planning with the project start year, then choose Goto -> Timeframe -> Timeframe... The system displays the Timeframe dialog box. Enter the required planning year, and choose .
2. If you want to plan for the following year, choose . You can choose and to choose the following or previous year for planning. The system displays the element overview with the fields ready for input in the planning element.
Plan Line Items

Definition
The following changes in costing planning can be documented in the system as line items:
Changes in:
- Structure oriented cost planning (independent of cost elements)
- Planning primary costs and activity input
- Unit costing (independent of cost elements)
Plan line items are not written for changes in:
- Network costing
- Unit costing (by cost element)
The project or the WBS element must have a user status, to which the Plan line items business transaction is assigned. This enables the system to write line items.
Writing line items means that:
- Planning changes are possible at any time
- Each change is recorded with the date and who made the change (plan line items are written) so that you can track these changes at any time later on.

Use
For more information on how to create a user status, see Status Management [Extern].
To display the plan line items (independent of cost elements) for a WBS element, go to Cost Planning and choose Extras -> Display line items
The plan line items (dependent on cost elements) are displayed in the information system.

💡
If line items can be written in the project, then changes are documented in line items, in the different versions.
The system only creates line items from the time when you set this up. This means that the planning value of a cost element may, in certain circumstances, vary from the total of the planning line items.
In WBS elements that are plan integrated, the system writes line items (regardless of the user status) for cost planning (dependent on cost elements), if you activated the integrated planning indicator in the fiscal year-dependent parameters for each planning version.

💡
On WBS element 2000.1, you have already planned EUR 10,000.00 under the External activity cost element (415000). Now activate the line item writing function within the project. The system now documents all planning changes in line items. Another EUR 2,000.00 and EUR 3,000.00 are planned. The total of the planning line items is EUR 5,000 as a result. However, the total of the
Plan Line Items

cost element planning is EUR 15,000, therefore the result of the totals record planning is not the same as for line items.

💡

Line items are identified by a unique number. In customizing for the project system, you need to specify number range intervals under Check Number Ranges for Rough Planning [Extern].
Unit Costing

Use

Unit costing allows you to plan in detail for an internal order at a lower level than with overall planning. To do this, call up unit costing from overall planning.

You can also use detailed planning to execute detailed planning below the cost element level. This is useful when you have totaled a number of individual jobs and activities under one cost element.

You use unit costing once information on supply sources, quantities and prices is available, and do so on an overall or an annual basis.

Wage costs are recorded under cost element 420000. The plan envisages USD 368,700 for this. You can, however, differentiate the wage costs by employee category and period.

This means that the planned figure for three category A employees is USD 1,000 per period, making a total of USD 36,000 for category A personnel. For category B personnel, however, the figure is only USD 1,000 per period for periods one to three and periods 10-12 (making USD 6,000 in total). This is because these are external personnel, employed on a seasonal basis. For category C personnel, the figure is USD 900 per period for periods 6-8 (making USD 2,700 in total). These are personnel working in their vacations from, say, higher education. You cannot achieve this degree of detail in "normal" primary cost planning at totals level (for each cost element), but only in unit costing.

Features

For more information on unit costing, see Resource Planning [Seite 132].

For more information on the purpose of Base Object Costing, see Reference and Simulation Costing [Extern].

Unit Costing Alternatives

Rather than carrying out a unit costing, you can define a costing model in the master data for the relevant internal order.

You can find more information in the SAP Library under Easy Cost Planning for Internal Orders [Seite 170].
Planning Primary Costs and Revenues

Use

In primary cost planning, you record the costs incurred by the consumption of goods and services originating outside of your business.

These include the following:

- Material costs
- Costs of raw materials and operating supplies
- Wage costs
- External services
- Statistical costs for balance sheet account
- Accrued costs
  Accrued costs may have a different meaning in internal accounting than in Financial Accounting (accrued interest or depreciation). They may also be incurred at different times in Financial Accounting and Cost Accounting (special payments, such as vacation allowance, Christmas bonus, or irregular costs, such as repairs).

To plan revenues in internal orders, you use special cost elements for the revenue elements class for each chart of accounts. You can only plan revenues if the order type allows revenue postings. Entries for revenues in internal orders must be preceded by a minus sign ("-").

Features

You plan the primary costs and revenues by cost element, divided among the internal orders on which you later assign the actual costs. You can also plan on order groups and cost element groups.

For more information on defining cost element groups, see Cost Element Groups [Extern].

If you want to further subdivide the plan value for a cost element, you can use unit costing. This is a good idea if, for example, you have combined several items/external services under one cost element.

For more information, see Unit Costing [Seite 128].

For planning by cost element, you can combine the planning object and planning content as follows:

<table>
<thead>
<tr>
<th>Planning object</th>
<th>Planning content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single order</td>
<td>Single cost element</td>
</tr>
<tr>
<td>Single order</td>
<td>Cost element group</td>
</tr>
<tr>
<td>Order Group</td>
<td>Single cost element</td>
</tr>
<tr>
<td>Order Group</td>
<td>Cost element group</td>
</tr>
</tbody>
</table>
Planning Primary Costs and Revenues

You wish to plan wage costs for some trade fair orders. You combine the orders for the various trade fairs into one order group, and Enter the order group and the cost element 420000 (Wages) on the initial screen.

Then you can either go to the overview screen or the period screen, where the system offers you the first trade fair order for processing. Choose Previous combination or Next combination to scroll from one trade fair order to another.

You want to plan the advertising costs for several trade fair orders. You combine the orders for the various trade fairs into one order group, and summarize the individual advertising costs into one cost element group.

The overview screen displays all the advertising costs for the first trade fair order, where you can scroll from one order to another.

In the period screen, you can scroll down to plan all the advertising cost elements for the first trade fair order, then for the second, and so on.

You can enter the planned total for each cost element, and distribute this to the plan periods by specifying a standard, or user-defined distribution key. For more information, see the implementation guide (IMG), under Controlling → Internal Orders → Planning → Manual Planning → Maintain User-Defined Distribution Keys [Extern].

Alternatively, you can distribute the plan values manually in the period screen. For more information see: Manual Planning [Seite 141].

For more information on making online, dynamic changes to the planning screen, see Techniques for Support in Manual Planning [Seite 144].
Performing Primary Cost Planning and Revenue Planning

You access Primary Cost and Revenue Type Planning:

- By choosing Accounting → Controlling → Internal orders → Planning → Costs/Activity input → Change.
- Directly from overall planning.

Procedure

1. Choose Planning → Set planner profile and enter the following for planning:
   - Enter the standard profile SAP101 to plan primary costs
   - Enter the standard profile SAP103 to plan revenues
2. Choose
   - Accounting → Controlling → Internal orders → Planning → Costs/Activity input → Change.
   On the Change Planning for Cost Elements/ActyInput: Initial screen, enter the data required.
   - Accounting → Controlling → Internal orders → Planning → Overall → Change → Overall planning → Extras → Detail planning → Primary costs or revenues.
     The entries you have just made on the initial screen are set automatically by the system from overall planning.
3. In the period screen, you can plan each internal order across cost elements for the periods of a fiscal year.
4. In the overview screen, you can plan each internal order per period by cost elements.
5. The structure of this screen depends on the combination of planning objects you entered on the initial screen. If, for example, you enter an individual internal order and an individual cost element, then the system only displays these two objects.
6. Save your planning values.

Results

You can obtain the cost element planning value by doing the following:

Call up overall planning for your order group and choose Views → Cost element planning In Plan total; the cost element planning value appears in the right-hand column, and is marked with a K.
Resource Planning

Use

Resource planning is a planning aid. If you only know the quantities of consumed resources (see also: Resources [Extern]) you can use resource planning to plan activity-dependent or activity-independent primary costs [Extern] or revenues [Extern] by quantity. You can carry out detailed planning of a cost element by subdividing the cost element on the basis of the resources. The SAP R/3 System valuates the given resource consumption with a price, which you can store separately in the system.

You can also link resources to a material [Extern] or to a base planning object [Extern]. This means that a resource or a base planning object has been entered in the resource master record. For the valuation of resource consumption during planning, the SAP R/3 System uses the price of the material, regardless of whether you have defined a price for the resource during pricing (see also: Pricing [Seite 134]).

- During primary cost planning, you can plan resources on cost centers, cost center/activity type, orders and WBS elements.
- You cannot plan resources during overall planning of orders and WBS elements.

Resource planning differs in the following ways from activity input planning, which also provides a quantity-based planning approach:

- From where is the activity/resource input/taken from?
- Cost element, under which the consumption is posted

<table>
<thead>
<tr>
<th>Distinguishing characteristic</th>
<th>Activity input planning</th>
<th>Resource planning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Origin of the activity/resource</td>
<td>Internal</td>
<td>External</td>
</tr>
<tr>
<td>Cost element, under which the consumption is posted</td>
<td>Secondary</td>
<td>Primary</td>
</tr>
</tbody>
</table>

You can also copy resources together with the planning (see also: Copying Planning Values [Extern]). The system copies only the consumption quantities. The system valuates the resource prices during the copying transaction. If the price of a resource in the target fiscal year is 2% higher than the price of the same resource in the source fiscal year, the costs in the target fiscal year will also be 2% higher than the costs in the source fiscal year.

You can also transfer resource consumption from an SAP external system into resource planning via the external data interface. For more information about the external data interface, see External Data Transfer [Extern].
Features

Resource planning contains the following functions:

- Price determination (see: Price Determination [Seite 134])
- Manual planning of resources (see: Executing Resource Planning [Seite 136])
- Revaluation (see: Revaluating Resource Planning [Seite 137])

Price determination

You can specify the prices for the resource consumption valuation individually. You can also use pricing to specify criteria, combinations of criteria or define rules for determining prices.

Manual planning

SAP provides you with the standard planner profile SAPR&R. This planner profile contains standard planning layouts for resource planning on cost centers [Extern], orders [Extern] and WBS elements [Extern].

For more information on planner profiles and planning layouts, see Planner Profiles [Seite 150] and Standard Planning Layouts [Seite 153].

Resource Planning: An Example [Extern]

Revaluation

When you change a resource price in price maintenance, the SAP R/3 System automatically recalculates your planning.

If, however, a resource refers, for example, to a base planning object, and the price of this base planning object changes, the system does not automatically execute a recalculation. In this case, you must recalculate the costs already planned using this resource. Only then can you ensure that your planning is up-to-date. (See also: Revaluating Resource Planning [Seite 137])
Pricing

Use

You can specify the prices for the resource consumption valuation individually. You can also use price determination to specify criteria, combinations of criteria or define rules for determining prices.

The SAP R/3 System executes price determination using the condition technique. It enables you to adjust the access to the resource prices to meet your individual requirements. The system controls price determination using the following settings:

- Condition types
- Price tables
- Access sequences
- Costing sheets

In the standard system, SAP supplies price tables, access sequences, condition types and costing sheets. You can also define new, individual settings for price determination. For more information about Pricing, see the Implementation Guide (IMG) under Controlling → Overhead Cost Controlling → Cost Center Accounting → Planning → Resource Planning → Pricing Strategy.

The following access sequences are stored in the standard access sequence K001:

- Price per cost center
- Price per controlling area
- Price per country/region

You must enter fiscal year and version as selection criteria. Other criteria, such as company code, controlling area, plant, cost center, region, and so on, you can define yourself.

Price table for the combination resource/region

<table>
<thead>
<tr>
<th>Resource</th>
<th>Region</th>
<th>Price in USD</th>
<th>Price unit</th>
<th>From per.</th>
<th>FYYear</th>
<th>Vers.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power kWh</td>
<td>Chicago</td>
<td>0,22</td>
<td>100</td>
<td>01</td>
<td>1998</td>
<td>000</td>
</tr>
<tr>
<td>Power kWh</td>
<td>New York</td>
<td>0,20</td>
<td>100</td>
<td>01</td>
<td>1998</td>
<td>000</td>
</tr>
</tbody>
</table>

You specify the criteria resource and region in an access sequence. The R/3 System uses this to ensure that you can maintain one price per region for a resource. During price maintenance, the above-mentioned prerequisites apply for one price, regarding version, currency key and validity period.
For example, for the resource “Power” in the Chicago region, price determination calculates a price of 0.22 USD in the entire fiscal year 1998 in version 000 for 100 kWh.

You can store prices in any currency and for any integral price units.

- Within one fiscal year and one version, the currency key for a resource must be the same.
- You can store prices for a version from a specified period of a fiscal year. The prices are then valid till the end of the fiscal year.
- You can maintain resource prices in resource planning. To do so, choose Planning → Cost and activity input → Change → Extras → Resource planning → Maintain prices.
Resource Planning

Prerequisites
If you want to carry out resource planning without adopting the standard planner profile SAPR&R, you must define your own planner profile and planning layout [Extern].

Procedure
To plan primary costs at resource level, proceed as follows:

1. Select a planner profile for resource planning such as the standard planner profile [Extern] SAPR&R.

   To do so, in your application choose Planning → Set planner profile.

2. Choose Planning → Cost element/activity input → Change.

3. Select a planning layout for resource planning.

To change existing plans or create new ones, choose Change. In the overview screen you can enter the fixed and variable plan consumption for a resource. You use a distribution key [Extern] to distribute the plan values to the fiscal year periods. You can either select a standard distribution key or define your own. On the period screen, you can also distribute your period values manually to the individual periods.

If you have stored a price for the resource (see: Pricing [Seite 134]) the system revaluates the consumption using this resource price (see also Revaluating Resource Planning [Seite 137])

For more information about planning and changing planning screens, see Executing Manual Planning [Seite 141] and Techniques for Supporting Manual Planning [Seite 144]
Revaluating Resource Planning

Use
If a resource refers to a specimen [Extern] or material [Extern], and its price is changed, you must revaluate resource planning manually.

Procedure
To revaluate resources:
1. In the planning menu for your application, choose Cost/activity input → Change → Extras → Resource planning → Revaluate.
2. Specify which data is to be reevaluated.
3. To do this, maintain the following fields:
   a) Controlling area
   b) Version
   c) From period
   d) To period
   e) Fiscal year
   f) From resource
   g) To resource
4. Choose Execute.

Result
The SAP R/3 System posts the resource consumption using the updated price. You can check the results on the overview screen and on the period screen for planning.
Planning Activity Input

Use
Similar to primary costs, you can plan activity input on an internal order or order group, for each
cost center/activity type, or for each business process. You can do this individually or in groups.

Features
You require the prices for the activity types when planning activity inputs.

For plan-integrated internal orders in plan-integrated versions, the system takes the price from
the current version (see also: Indicator in the Version for Integrated Planning [Seite 103])
When you change the price for an activity type, the system automatically recalculates the
relevant orders. It calculates the quantity of the planned activity input using the price (for the
activity type) to determine the planned costs on the internal orders. If you planned activity input
for an internal order from a cost center or a business process, the SAP system updates the
scheduled activity and the resulting credit posting on the sender cost center or the sender
business process.

If you plan activity inputs on internal orders but integrated planning for internal orders and Cost
Center Accounting is not active, you can use the Calculation version for ICA field in the version.
This specifies the version from which the prices for the activity type are to be taken for valuing
the activity input. If you do not specify a calculation version, the system uses the corresponding
price from version 0.

The SAP system does not update the scheduled activity and the credit on the sender
cost center for non-plan-integrated internal orders.

Activities
1. To replace the SAP 102 planner profile, choose Planning → Set planner profile.
2. Choose Planning → Costs/activity input → Change.

See also:
Manual Order Planning [Seite 141]
For more information on making online, dynamic changes to the planning screen, see
Techniques for Supporting Manual Planning [Seite 144].
Planning Statistical Key Figures

Use
Statistical key figures can be used:

- to determine business key figures on cost centers
  
  Costs per employee

- as a receiver base (key) for assessments and distributions

  You assess the cafeteria costs to individual cost centers within your organization, according to the number of employees.
  
  The telephone costs are distributed to the individual cost centers according to the number of telephones in each cost center.
  
  In this case, you plan the number of employees and the number of telephones on each cost center as a statistical key figures and enter them as actual values.

There are two different types of statistical key figures.

- Fixed values
- Total values

  In the overview screens for the planning of statistical key figures, the R/3 System displays the average values (not totals) for statistical key figures of category Fixed values.

You can plan statistical key figures as activity-independent or activity-dependent. Use planning layout 1 - 301 for activity-independent planning, and planning layout 1 - 302 for activity-dependent planning (see: Structuring the Planning Screen [Seite 148]).

For more information on the automatic transfer of statistical key figures from the LIS, see: Processing Statistical Key Figures [Extern] and Transferring Statistical Key Figures from the Logistics Information System [Extern].

Actions

Executing Statistical Key Figure Planning [Seite 140]

Executing Manual Planning [Seite 141]
Planning Statistical Key Figures

1. Select a standard planner profile [Extern]

   To set a standard planner profile, choose:
   - for applications belonging to Controlling (cost centers, internal orders, processes)
     Planning → Set planner profile
   - For Real Estate Management: Controlling → Planning → Set planner profile
   - For the Project System: Financials → Planning → Costs in WBS → Set planner profile

<table>
<thead>
<tr>
<th>Planning type</th>
<th>Standard profiles</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity-independent planning of statistical key figures</td>
<td>SAP101, etc.</td>
</tr>
<tr>
<td>Activity-dependent planning of statistical key figures</td>
<td>SAP104</td>
</tr>
</tbody>
</table>

- To create a new plan, or to change an existing one, choose Planning → Statistical Key Figures → Change.

For more information about planning and changing planning screens, see Executing Manual Planning [Seite 141] and Techniques for Supporting Manual Planning [Seite 144]
Executing Manual Planning

Purpose

This process describes how to execute cost center planning and lists the aids provided by the SAP R/3 System. This process applies to all applications in the SAP R/3 System, which use the planning layouts and planner profile methods. These are as follows:

- Cost Center Accounting
- Internal orders
- Activity-Based Costing
- Real Estate Controlling
- Project System

Process Flow

The graphic shows the screen sequence used in planning.

Planning

- Set planner profile
- Costs/activity inputs
- Activity output/prices
- Statistical key figures:
  - Change/create
## Executing Manual Planning

### Planning: Initial Screen

<table>
<thead>
<tr>
<th>Overview Screen</th>
<th>Period Screen</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout</td>
<td></td>
</tr>
<tr>
<td>Variables</td>
<td></td>
</tr>
<tr>
<td>Version</td>
<td>From period</td>
</tr>
<tr>
<td></td>
<td>To period</td>
</tr>
<tr>
<td>Fiscal year</td>
<td></td>
</tr>
<tr>
<td>Planning Objects</td>
<td></td>
</tr>
<tr>
<td>Entry</td>
<td></td>
</tr>
<tr>
<td>Free</td>
<td>Formula-based</td>
</tr>
</tbody>
</table>

### Overview Screen

<table>
<thead>
<tr>
<th>Previous Combination</th>
<th>Next Combination</th>
<th>Period Screen</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version</td>
<td>Period</td>
<td>Fiscal year</td>
</tr>
<tr>
<td>Planning Objects</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

List for plan data entry

### Period Screen

<table>
<thead>
<tr>
<th>Previous Combination</th>
<th>Next Combination</th>
<th>Overview Screen</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version</td>
<td>Fiscal year</td>
<td>Planning objects</td>
</tr>
<tr>
<td></td>
<td>Period distribution of the plan values</td>
<td></td>
</tr>
</tbody>
</table>

### Initial Screen

Depending on the planner profile selected (see also: Planner Profiles [Seite 150]) the initial screen contains the first planning layout that this planner profile contains (see also: Planning Layouts [Seite 152]). You can scroll between the planning layouts of a planner profile.

As well as displaying the groups you have used, you can also display the planner profile and the planning layout(s) contained in it (see also: Manual Planning Aids [Extern]).

You can use various indicators to control how much data is to be prepared for the following overview screen.
If you have locked a planning transaction for some of the periods in the fiscal year in the period lock [Extern], and you are using a period interval for manual planning that contains at least one of the locked periods, then the system does not allow you to plan. This also applies to the periods that are not locked. Therefore, you should use only period intervals that do not contain locked periods.

**Overview Screen**

The overview screen layout depends on the planner profile and related planning layouts. You can manually change individual settings, such as scaling or the layout of rows and columns, during planning.

The first plan or actual record that you post to an object in a fiscal year using a certain cost element is the record that determines the unit of measure for the consumption. If there is no unit of measure, then you cannot plan consumption. You need to differentiate between the following:

- There is still at least one plan record (in another version)
  
  You can only change the unit of measure and the consumption in the version that was planned first. Once you have defined a unit of measure in that version, which is valid for the whole fiscal year, the consumption (in this unit of measure) is ready for input for all versions. The unit of measure in the first version can only be changed until planning data is posted in another version. After this, you can only make the unit of measure ready for input by deleting the plan records in all versions, and re-creating the required unit of measure.

- At least one actual record already exists
  
  You need to reverse the actual records that exist, and re-create the required unit of measure. After this, the consumption in planning (under this unit of measure) is ready for input.

- Orders have at least one database record for actual or plan values. This database comes from an order settlement (by cost element).
  
  Even after an order settlement is reversed, a database record still exists, and prevents the unit of measure from being changed.

**Period Screen**

In the period screen you can display or change the period-based distribution of your plan value. You can select the period screen either for each row from the planning overview screen or from the initial screen.
Techniques for Supporting Manual Planning

You can use various planning techniques to perform manual cost center planning. The techniques you use depend on your organization’s requirements. They may vary between organizations. This section deals with the following questions:

- **Should the cost center planning be executed in multiple versions?** (for example, to depict alternative or continuous planning)
  
  In the SAP R/3 System you can create as many versions as you require.
  
  See also: Planning and Parallel Valuation in Multiple Versions [Extern].

- **Which cost structures can be expected in the planning period?**
  
  If seasonal fluctuations are expected, you must be able to plan these using flexible distribution keys.

- **Is planning to be executed centrally or locally?** (possibly using predefined planning models)
  
  The answer to this question determines which planning view you select. The planning view determines the selection of objects and combinations of objects to be planned during cost center planning. For example, you can specify whether you want to plan a cost element on a cost center, or a cost element group on a cost center, or a cost element group on a cost center group.
  
  See also: Flexible Selection of Planning Views [Seite 145]

- **Do you need to plan in different currencies?**
  
  You can select the currencies to be use in the planning process.
  
  See also: Currencies in Planning [Seite 97]

- **How are the planning screens to be structured?**
  
  The planning screens (planning layouts) must meet your planning requirements. If the standard planning layouts in the system do not meet your specific requirements, you can create your own planning layouts. This allows you to define your own entry screens.
  
  See also:
  
  
  – Structuring the Planning Screen [Seite 148]
Flexible Selection of Planning Screens

Purpose

You can select the planning view according to your requirements. This supports the varied business planning needs. You have the following options for the selection of the planning level:

Selecting Planning Views

<table>
<thead>
<tr>
<th>Planning view</th>
<th>Where used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center/cost element, activity type, or statistical key figure</td>
<td>Local planning by cost center manager</td>
</tr>
<tr>
<td>Cost center group/cost elem. group, activity type group, or statistical key figure group</td>
<td>Local planning by cost center manager; group can be specified as &quot;planning model&quot;</td>
</tr>
<tr>
<td>Cost center group/cost elem. group, activity type group, or statistical key figure group</td>
<td>Central planning by cost center planner in consultation with the cost center manager</td>
</tr>
</tbody>
</table>

Process Flow

You can create groups of cost centers, cost elements, activity types, and statistical key figures during master data maintenance especially for planning purposes. For more information, see:

Cost elements [Extern]
Cost centers [Extern]
Activity types [Extern]
Statistical Key Figures [Extern]

You can, of course, access existing groups, such as from the standard hierarchy or the cost element structure of the overhead allocation sheet, if these fit your planning requirements.

Central and Local Planning

You can switch at any time between central and local, cost-center or cost-element-based planning.

You can

- Plan multiple cost elements on one cost center (local)
- Plan multiple cost centers under one cost element/cost element group (central)

The type of planning you select depends on the organizational structures of your business enterprise.

The two methods can also be combined. For example, certain cost elements (such as insurance and taxes) can be planned centrally, and other cost elements (such as operating supply items) can be planned locally by the respective cost center managers.

You need first to define the planning structures for both procedures. You can either access the original structures which you defined during master data maintenance (the cost center hierarchy of the company or the overhead allocation sheet structure), or you can define alternative
Flexible Selection of Planning Screens

structures (hierarchies) for planning purposes. The following graphic shows an example of a cost center structure:

Example

In the planning process, you first plan the production cost center SFI 4210 with the cost elements "Wages" (420000), "Shift premium" (421000), "Salaries" (430000) and "Salary bonus" (431000). Then you plan the production cost center SF2 4220 with the cost elements "Wages" (420000), "Shift premium" (421000) and "Salaries" (430000). The cost element (431000) "Salary bonus" is not planned. Therefore, no record is stored in the data base for this cost element on cost center 4220.

You then plan cost center 4230 using all four cost elements.

This procedure is the same as the one used for planning multiple activity types or statistical key figures.
Planning Screen Layout

Use

You enter plan data in Controlling via entry screens. You structure these entry screens during Customizing for planning using the Report Painter [Extern] functions (see also: User-Defined Planning Layouts [Extern]). In the following, entry screens for plan data are referred to as planning layouts [Seite 152].

Planning layouts are used in different application components within the SAP System. Information on defining planning layouts other information over and above cost center planning can be found as follows:

<table>
<thead>
<tr>
<th>Internal orders</th>
<th>User-Defined Planning Layouts [Extern]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity-Based Costing</td>
<td>Defining Planning Layouts [Extern]</td>
</tr>
<tr>
<td>Real Estate Controlling</td>
<td>User-Defined Planning Layouts [Extern]</td>
</tr>
</tbody>
</table>

The standard system includes several common planning layouts [Seite 153] designed for cost center planning and other related activities. These planning layouts are structured according to planning areas and assigned to a particular planner profile (for cost center planning for example). See also: Planner Profile [Seite 150]

One planner profile can contain multiple planning areas. One planner area can contain multiple planning layouts. You can group planning layouts efficiently by assigning them to planner profiles. During planning you can switch between planning layouts belonging to a given planning area of a given planner profile.

⚠️

Before switching planning layouts within a planning area, you must first save the data of the planning layout you are leaving.

The graphic below shows the possible uses of planner profiles and planning layouts:
It is advisable to create a separate planner profile, with appropriate planning layouts, for each enterprise area for which planning is to be performed.

Planning with user-definable entry screens has the following advantages:

You can:

- Define multiple lead columns
- Flexibly structure value columns, for example:
  - Version planning
  - Quarterly, half-year, and annual planning
  - Centralized or decentralized planning
  - Activity outputs (sender perspective)
  - Cost planning in different currencies
  - Planning with varying actual price indicators, and a switching structure for cost component splitting
Planner Profiles

Use

You use planner profiles to control the process flow for planning. They are hierarchically structured. In a planner profile, you specify the planning layout to be used for each planning area, such as cost elements/activity inputs, activity types/prices, or statistical key figure planning. You can store any number of planning layouts for each planning area in a planner profile.

The planning layouts are assigned to a planner profile as profile items. Each planning area may contain any number of profile items. The profile item determines the sequence of the planning layouts in a planner profile. Using different profile items you can assign the same planning layout (with different default parameters) to one planner profile.

You have assigned the planning area Cost elements/activity inputs to the planner profile PROFIL 1. In profile items 1 and 2 you have assigned planning layout 1-101 to this planning area.

For the planning layout in profile item 1 you set the parameters Version 0 and cost center group PRODUCTION. For the planning layout in profile item 2 you set the parameters Version 1 and cost center group ADMINISTRATION.

During planning you can choose Next/previous planning layout to switch between the planning layouts of the selected planner profile. This allows you to plan in different versions.

In a planner profile, you can set the following planning conditions.

- You can control planning authorizations by assigning an authorization group to a planner profile. This is particularly important for decentralized planning. By using specialized planner profiles for planners, and by assigning authorization groups, you ensure that planning is restricted to the relevant area of responsibility.

- By setting default parameters for the planning layout in the planner profiles, you can enter default settings for the variables of a planning layout. You enter values for these variables in the planner profile. You can overwrite these values, and you can also prevent overwriting by selecting the appropriate indicator in the planner profile definition. In a planning session, the system checks all variables defined in a planning layout and handles them as parameters.

The system includes the following standard planner profiles [Extern]:

For more information on creating planner profiles, see Customizing for

- the Controlling applications under:
  Controlling → Cost Center Accounting/Activity-Based Costing/Internal Orders → Planning → Manual Planning → Maintain User-Defined Planner Profiles [Extern]
- R/3 Real Estate management under:
  Real Estate → Real Estate Controlling → Planning → Create User-Defined Planner Profiles [Extern]
- the Project System under:
Planner Profiles

Planning Layouts

Use

You use planning layouts to specify your cost planning structure. You define the headings, lead columns, and value columns, based on your specific business requirements. You do this for each planning area. The planning areas are:

- Cost elements/activity input
- Activity types/prices
- Statistical key figures

You can create different planning layouts for each planning area which may have different key columns, characteristics, and so on. This allows you to set up flexible planning schemes which meet specific business requirements such as versions, semi-annual or quarterly planning. The SAP standard system contains default versions of the most commonly used planning layouts for each planning area. You can easily create additional planning layouts, if required. The planning layouts supplied by SAP are described below:

See also: Standard Planning Layouts [Seite 153] for cost center planning.
Standard Planning Layouts

Use

The standard system includes planning layouts for all planning areas. You can use these standard planning layouts, copy and adapt them to your requirements, or create completely new planning layouts. The standard planning layouts are divided into two categories: Planning layouts permanently assigned to a planner profile and planning layouts not yet assigned to a planner profile. The unassigned planning layouts are required only for special situations. Before using these unassigned planning layouts, you must first assign them to the corresponding planner profile.

Standard planning layouts are supplied only in client 000. To use the planning layouts in other clients, you must import them into the given client. You should execute this import after each release upgrade. For more information, see Customizing for Controlling under Controlling → General Controlling → Preparation for Production Start → Transporting System Settings → Transport Settings for Planning → Import Standard Planning Layouts [Extern].

The standard planning layouts are protected. They cannot be changed. To create your own planning layouts with a similar structure to a standard planning layout, first copy the standard planning layout under a different name and then change the copy.

Integration

A list of standard planning layouts with brief descriptions is provided below.

SAP supplies the following planning layouts:

Cost Element/Activity Input Planning

<table>
<thead>
<tr>
<th>Planning layouts</th>
<th>Description</th>
<th>Assigned to Planner Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 101</td>
<td>Activity-independent and activity-dependent primary cost element planning</td>
<td>SAP101, SAPALL</td>
</tr>
<tr>
<td>1 - 102</td>
<td>Activity-independent and activity-dependent activity input planning</td>
<td>SAP102, SAPALL</td>
</tr>
<tr>
<td>1 - 102P</td>
<td>Activity-independent and activity-dependent process input planning</td>
<td>SAPALL</td>
</tr>
<tr>
<td>1 - 103</td>
<td>Activity-independent cost and revenue element planning</td>
<td>SAP103</td>
</tr>
<tr>
<td>1 - 104</td>
<td>Activity-independent and activity-dependent secondary order cost planning</td>
<td>SAP104, SAPALL</td>
</tr>
<tr>
<td>1 - 104P</td>
<td>Primary and secondary order cost planning for business processes</td>
<td>SAPALL</td>
</tr>
</tbody>
</table>
### Standard Planning Layouts

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
<th>Assigned to Planner Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 161</td>
<td>Decentralized simplified planning of costs and revenues</td>
<td>SAPEASY</td>
</tr>
<tr>
<td>1 - 162</td>
<td>Centralized simplified planning of costs and revenues</td>
<td>SAPEASY</td>
</tr>
<tr>
<td>1 - 1R1</td>
<td>Resource planning</td>
<td>SAPR&amp;R</td>
</tr>
<tr>
<td>1 - 1R1</td>
<td>Value-based dependency planning</td>
<td>SAPR&amp;R</td>
</tr>
<tr>
<td>1 - 1R3</td>
<td>Quantity-based dependency planning</td>
<td>SAPR&amp;R</td>
</tr>
<tr>
<td>Not assigned</td>
<td>Activity-independent cost planning in transaction currency</td>
<td></td>
</tr>
<tr>
<td>1 - 151</td>
<td>Activity-independent cost planning for four quarters</td>
<td></td>
</tr>
<tr>
<td>1 - 153</td>
<td>Cost element planning for two versions</td>
<td></td>
</tr>
<tr>
<td>1 - 154</td>
<td>Cost element planning with previous year figures displayed</td>
<td></td>
</tr>
<tr>
<td>1 - 155</td>
<td>Activity output (sender perspective) with receiver valuation</td>
<td></td>
</tr>
<tr>
<td>1 - 156</td>
<td>Central planning of a cost element</td>
<td></td>
</tr>
<tr>
<td>1 - 157</td>
<td>Cost element plan/actual comparison</td>
<td></td>
</tr>
</tbody>
</table>

Planning layouts 1 - 151 to 1 - 157 are provided in addition to the planning layouts already included in the planner profiles.

### Activity Type Planning

<table>
<thead>
<tr>
<th>Planning layouts</th>
<th>Description</th>
<th>Assigned to Planner Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 201</td>
<td>Standard activity type planning</td>
<td>SAP101, SAP102, SAPALL</td>
</tr>
<tr>
<td>1 - 201C</td>
<td>Centralized planning of activity types/prices</td>
<td>SAPALL</td>
</tr>
<tr>
<td>1 - 202</td>
<td>Simplified PP planning</td>
<td>SAP103</td>
</tr>
<tr>
<td>1 - 203</td>
<td>Activity type planning with actual price indicator, switching structure for cost component splitting</td>
<td>SAP104</td>
</tr>
<tr>
<td>1 - 204</td>
<td>Activity type planning with prices and additional attributes, such as predistribution of fixed costs</td>
<td>SAP101, SAPALL</td>
</tr>
<tr>
<td>1 - 261</td>
<td>Simplified price planning</td>
<td>SAPEASY</td>
</tr>
<tr>
<td>1 - 262</td>
<td>Centralized simplified price planning</td>
<td>SAPEASY</td>
</tr>
</tbody>
</table>
### Statistical Key Figure Planning

<table>
<thead>
<tr>
<th>Planning layouts</th>
<th>Description</th>
<th>Assigned to planner profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 301</td>
<td>Activity-independent statistical key figure planning</td>
<td>SAP101, SAP102, SAP103</td>
</tr>
<tr>
<td>1 - 302</td>
<td>Activity-dependent statistical key figure planning</td>
<td>SAP104</td>
</tr>
<tr>
<td>1 - 303C</td>
<td>Centralized statistical key figure planning</td>
<td>SAPALL</td>
</tr>
<tr>
<td>1 - 361</td>
<td>Simplified statistical key figure planning</td>
<td>SAPEASY</td>
</tr>
<tr>
<td>1 - 362</td>
<td>Centralized simplified statistical key figure planning</td>
<td>SAPEASY</td>
</tr>
</tbody>
</table>

### Planning Layouts for Cost Element/Activity Input Planning

- Activity-independent and activity-dependent cost element planning (1 - 101)

  With this planning layout you can plan:
  - Activity-independent and activity-dependent primary costs (cost element category 01, 04)
  - Revenues (cost element category 11, 12)
  - Activity-independent and activity-dependent settlement costs (cost element category 21)
  - Credits from overhead (cost element category 41)

The following table provides examples of planning records in this planning layout that can be used individually or collectively.

**Header**

- Period
- Fiscal year
- Version
- Cost centers

<table>
<thead>
<tr>
<th>Activity type</th>
<th>Cost element</th>
<th>Cost element categories</th>
<th>Business transaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>400.000</td>
<td>1</td>
<td>Activity-independent primary cost planning</td>
</tr>
<tr>
<td>-</td>
<td>800.000</td>
<td>11/12</td>
<td>Revenue planning</td>
</tr>
<tr>
<td>Production hour</td>
<td>400.000</td>
<td>1</td>
<td>Activity-dependent primary cost planning</td>
</tr>
<tr>
<td>-</td>
<td>655.000</td>
<td>21</td>
<td>Activity-independent planning of settlement costs</td>
</tr>
</tbody>
</table>
To use activity-dependent and activity-independent planning in one planning layout, proceed as follows:

1. Select *Entry optional* in the planning layout for the variable of the activity type group. This is the case for standard planning layouts.

2. In the initial planning screen, you must have:
   - Specified an activity type group including the initial value, or
   - Entered "*" for the activity type. This entry allows you to plan all activity types, including the initial value.

### Activity-independent and activity-dependent activity input planning (1 - 102)

The following table provides examples of planning records in this planning layout that can be used individually or collectively.

<table>
<thead>
<tr>
<th>Header</th>
<th>Period</th>
<th>Fiscal year</th>
<th>Version</th>
<th>Cost centers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Receiver act. type</td>
<td>Sender cost center</td>
<td>Sender activity type</td>
<td>Business transaction</td>
<td></td>
</tr>
<tr>
<td>-</td>
<td>4210</td>
<td>REP</td>
<td>Activity-independent activity input planning</td>
<td></td>
</tr>
<tr>
<td>Production hour</td>
<td>4210</td>
<td>REP</td>
<td>Activity-dependent activity input planning</td>
<td></td>
</tr>
</tbody>
</table>

### Activity-independent cost and revenue element planning (1 - 103)

The following table provides examples of planning records in this planning layout that can be used individually or collectively.

<table>
<thead>
<tr>
<th>Header</th>
<th>Version</th>
<th>Fiscal year</th>
<th>Period</th>
<th>Cost centers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Receiver act. type</td>
<td>Sender cost center</td>
<td>Sender activity type</td>
<td>Business transaction</td>
<td></td>
</tr>
<tr>
<td>-</td>
<td>4210</td>
<td>REP</td>
<td>Activity-independent activity input planning</td>
<td></td>
</tr>
<tr>
<td>Production hour</td>
<td>4210</td>
<td>REP</td>
<td>Activity-dependent activity input planning</td>
<td></td>
</tr>
</tbody>
</table>
Activity-independent and activity-dependent secondary order cost planning (1 - 104)

Planning layout 1 - 104 was originally intended for secondary order cost planning. With this planning layout you can plan:

- Activity-independent and activity-dependent primary costs
- Revenues
- Activity-independent and activity-dependent settlement costs
- Credits from overhead rates
- Activity-independent and activity-dependent secondary order costs
- Activity-independent and activity-dependent secondary costs

The following table provides examples of planning records in this planning layout that can be used individually or collectively.

**Header**
Version
Fiscal year
Period
Cost centers

<table>
<thead>
<tr>
<th>Cost element</th>
<th>Receiver acty type</th>
<th>Sender cost center</th>
<th>Cost element type</th>
</tr>
</thead>
<tbody>
<tr>
<td>400.000</td>
<td>-</td>
<td>-</td>
<td>1 Activity-independent primary cost planning</td>
</tr>
<tr>
<td>800.000</td>
<td>-</td>
<td>-</td>
<td>11/12 Revenue planning</td>
</tr>
<tr>
<td>400.000</td>
<td>Production hour</td>
<td>-</td>
<td>1 Activity-dependent primary cost planning</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cost/revenue element</th>
<th>Cost element categories</th>
<th>Business transaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>400.000</td>
<td>1</td>
<td>Activity-independent primary cost planning</td>
</tr>
<tr>
<td>800.000</td>
<td>11/12</td>
<td>Revenue planning</td>
</tr>
</tbody>
</table>
Standard Planning Layouts

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>655.000</td>
<td>-</td>
<td>-</td>
<td>21 Activity-independent secondary order costs</td>
</tr>
<tr>
<td>655.000</td>
<td>Production hour</td>
<td>-</td>
<td>21 Activity-dependent secondary order costs</td>
</tr>
<tr>
<td>634.000</td>
<td>-</td>
<td>-</td>
<td>41 Planning for credits from overhead</td>
</tr>
<tr>
<td>655000</td>
<td>4210 FST</td>
<td>21 Activity-independent secondary order costs</td>
<td></td>
</tr>
</tbody>
</table>

- Local planning of total costs (1 - 161)
  This planning layout allows you to plan locally (for each cost element) the total plan costs, without having to enter additional attribute values.

- Centralized planning of total costs (1 - 162)
  This planning layout allows you to plan centrally (for each cost center) the total plan costs, without having to enter additional attribute values.

- Resource planning (1 - 1R1)
  This planning layout lets you plan quantity-based primary costs.
  The characteristics activity type, cost element, resource, consumption and costs are displayed together. The resource is a new characteristic that can be positioned anywhere in the layout: For example, in the header, in a lead column or in a value column. You can also include three new key figures in the planning layout for resource planning:
  - Price in the planned currency
  - Price in controlling area currency
  - Price unit
  The system calculates as follows:
  - Fixed consumption quantity * Price = Fixed costs
  - Variable consumption quantity * Price = Variable costs
  - Total consumption quantity * Price = Total costs
  Only the consumption quantities are displayed as ready for input in the planning layout.
  It is possible to plan resources and cost elements in one planning layout. If the cost element and the resource are in the same lead column, and you enter only a resource, the system derives the cost element from the resource master data.
If you have executed detailed planning (by resource) for one or more cost elements, the system accumulates the costs below the cost element at resource level. These costs can then be used, for example, for distribution, assessment or plan cost splitting.

- **Value-based dependency planning**
  You use this planning layout for value-based planning of primary costs. You can add the following new key figures to the planning layout for value-based dependency planning:
  - Dependency type
  - Dependency source type
  - Fixed dependency price
  - Variable dependency price
  - Dependency source quantity

  The system calculates as follows:
  - Fixed dependency price * Dependency source quantity = Fixed costs
  - Variable dependency price * Dependency source quantity = Variable costs

  Depending on the dependency type, the fields *Fixed dependency price*, *Variable dependency price*, *Plan fixed costs*, and *Plan variable costs* in the planning layout are ready for input.

- **Quantity-based dependency planning**
  This planning layout lets you plan quantity-based primary costs. The characteristics activity type, cost element, resource, consumption and costs are displayed together. You can also include three new key figures in the planning layout for value-based dependency planning:
  - Dependency type
  - Dependency source type
  - Fixed dependency quantity
  - Variable dependency quantity
  - Fixed dependency price
  - Variable dependency price
  - Dependency source quantity
  - Fixed plan consumption
  - Variable planned consumption

  The system calculates as follows:
Standard Planning Layouts

- Fixed dependency price * Dependency source quantity = Fixed costs
- Variable dependency price * Dependency source quantity = Variable costs

Depending on the dependency type, the fields *Fixed dependency qty, Variable dependency qty, Plan fixed consumption, Plan variable consumption, Plan fixed costs, and Plan variable costs* in the planning layout are ready for input.

- Activity-independent cost planning in transaction currency (1 - 151)
  You can use this planning layout to plan costs in transaction currency.

- Activity-independent cost planning for four quarters (1 - 152)
  This planning layout allows you to plan by fiscal quarter.

- Cost element planning in two versions (1 - 153)
  You use this planning layout to enter plan values for two different versions. The SAP R/3 System calculates the difference between the two values.

- Cost element planning with display of previous year figures (1 - 154)
  This planning layout lets you display the previous year plan values for costs and consumption, in addition to the current plan values. The SAP R/3 System calculates the difference between the two values.

- Planning activity output from a sender perspective (1 - 155)
  This planning layout allows you to plan sender outputs. From a sender perspective, you plan: How high is the activity output of the sender?

- Central planning of a cost element (1 - 156)
  You can use this planning layout to plan centrally the costs and consumption of a cost element for all cost center/activity type combinations. The “Cost element” characteristic is in the planning layout header, the “Cost center/activity type” characteristic is in the rows.

- Plan/actual comparison for cost elements (1 - 157)
  With this planning layout, you can plan activity-independent costs while displaying the actual values of a comparison year.

Planning Layouts for Activity Types/Price Planning

- Activity type planning (1 - 201)
  Planning layout 1 - 201 lets you plan activity types on cost centers or cost center groups. The planning layout value columns contain the following key figures:
  - Plan activity
  - Capacity
  - Cost element for the activity allocation
  - Fixed price
  - Variable price
  - Price unit
- Equivalence number
- Scheduled activity

_Distribution key, Activity unit, Plan price indicator, Long text exists, and Average price are added to the value columns as attributes._

- Activity type planning for the PP planner (1 - 202)
  This planning layout contains only key figures and attributes relevant to production planning. This includes the following characteristics and attributes:
  - Plan activity
  - Fixed price
  - Variable price
  - Price unit
  - Plan price indicator

  - Distribution keys
  - Activity unit
  - Cost element for the activity allocation
  - Average prices
  - Long text exists

- Activity type planning with actual price indicator and switching structure for cost component splitting (1 - 203)
  In addition to key figures for activity type planning (see also 1 - 201) this planning layout has key figures and attributes which give you the following activity type planning options.
  - Plan output
  - Set an actual price indicator varying from the plan.
  - Specify a switching structure for cost component splitting

- Activity type planning with different attributes (1 - 204)
  In this planning layout you can plan activity types with the following attributes:
  - Predistribution of fixed costs
  - Plan price indicator
  - Actual price indicator
  - Price calculation with the periodic averages
  - Plan activity type category
  - Actual activity type category
  - Exchange rate type
  - Value date
Standard Planning Layouts

- Switching structure
- Output factor
- Long text exists
- Allocation cost element

- Simplified price planning (1 - 261)
  This planning layout lets you plan total prices for each activity type. Available attributes are *Price unit*, *Distribution key*, and *Long text exists*.

- Simplified centralized price planning (1 - 262)
  This planning layout lets you plan total prices centrally. Available attributes are *Price unit*, *Distribution key*, and *Long text exists*.

Planning Layouts for Statistical Key Figure Planning

- Activity-independent statistical key figure planning (1 - 301)
  You can use planning layout 1 - 301 to plan a current and a maximum value. Available attributes are *Distribution key*, *Unit*, *Key figure type* and *Long text exists*.

- Activity-dependent statistical key figure planning (1 - 302)
  Planning layout 1 - 302 contains the same value columns as the planning layout for activity-independent key figure planning. It differs only in the lead columns. While planning layout 1 - 301 has only one lead column (statistical key figure), planning layout 1 - 302 has two: *Activity type* and *Statistical key figure*. With this planning layout you can plan activity-independent and activity-dependent statistical key figures.

⚠️

To use activity-dependent and activity-independent planning in one planning layout, proceed as follows:

1. Enter *Entry optional* in the planning layout as the variable for the statistical key figure group. This is defaulted for standard planning layouts.

2. In the initial planning screen, you must have:
   - Specified a statistical key figure group that includes the initial value, or
   - Entered "**" for the statistical key figure. This entry allows you to plan all statistical key figure, including the initial value.

- Simplified statistical key figure planning (1 - 361)
  You can use this planning layout to plan a current value. Available attributes are *Distribution key*, *Unit*, *Key figure type* and *Long text exists*.

- Simplified centralized statistical key figure planning (1 - 362)
  This planning layout allows you to plan centrally (for each cost center) a current value. Available attributes are *Distribution key*, *Unit*, and *Long text exists*. 
Structuring Planning Layouts

Use

If the standard planning layouts supplied by SAP do not meet your requirements, you can define your own layouts. The following section describes the structure of a planning layout and the procedure for defining your own layouts (see also Defining Planning Layouts [Seite 166]).

All planning layouts are based on the following structure:

```
+-----------------+-----------------+
| Title           | Headers         |
|                 |                 |
+-----------------+-----------------+
| Key Columns     | Value Columns   |
```

The header of the planning layout contains the characteristics that apply to the whole planning table. You make these entries in the planning layout, under Edit → Gen. data selections.

To plan activity-independent costs, you define header characteristics, such as version, period, fiscal year, cost center and cost element. These characteristics are always displayed in the planning initial screen and the planning overview screen.

The lead columns contain the objects to be planned. You can define multiple lead columns. You create lead columns using predefined characteristics provided by SAP.

If you want to plan activity-independent costs, you define the cost element as a lead column. When you plan activity-dependent costs, you add the activity type as the second column. You enter the cost element and the activity type in the initial screen. However, in contrast to the other characteristics on this screen, you must also define them in the lead columns. This is so that you can plan them.

The value columns are used for the planning itself. This is where you enter the plan values.

You create value columns from the following:

- Characteristics
- Attributes
Formulas

For activity-independent or activity-dependent cost planning, you set the characteristics Fixed plan costs or Variable plan costs in the value columns. You can add further characteristics, such as a distribution key.

You define these three areas during Customizing for Controlling, under Overhead Cost Controlling → Cost Center Accounting or Activity-Based Costing under Planning → Manual Planning → User-Defined Planning Layouts. Once you define a planning layout, you can only change it in Customizing, not during planning.
Defining Planning Layouts

Use
If the standard planning layouts supplied by SAP do not meet your requirements, you can define your own layouts. The IMG contains more detailed information on defining planning layouts:

- For Overhead Cost Controlling applications, see:
  
  Controlling → Cost Center Accounting / Activity-Based Costing / Internal Orders → Planning → Manual Planning → User-Defined Planning Layouts [Extern]

- For SAP Real Estate Management, see:
  
  Real Estate → Real Estate Controlling → Planning → User-Defined Planning Layouts [Extern]

- For the Project System, see:
  
Distribution Keys

Use

During planning, the SAP R/3 System interprets the values you enter as overall values. Planning transactions use distribution keys, based on different criteria, to distribute the values to the individual plan periods. You can enter the distribution key in manual planning.

The SAP R/3 System uses your planning data during runtime, regardless of whether you have already saved a distribution key or not. The entered plan value is distributed according to each distribution key to the periods. The system saves the period values that are determined in this way.

The standard system includes predefined fixed distribution keys which cannot be changed (see: Standard Distribution Keys [Seite 168]).

In addition, you can create any distribution keys you require, for example, to allow for seasonal fluctuations, or to create shift schedules (see: User-Defined Distribution Keys [Extern])

Any changes made to the definition of a distribution key do not have an effect on the data that you planned previously using this distribution key.

For more information on creating your own distribution keys, see the Implementation Guide for Cost Center Accounting, under Planning → Manual Planning → Define Own Distribution Keys [Extern]
Standard Distribution Keys

Use

SAP provides the following standard distribution keys:

- **Distribution key 0**
  Used to enter values manually for each period.

- **Distribution key 1**
  Used to distribute the input value (annual plan value) equally across all plan periods.

- **Distribution key 2**
  Used to distribute the input value (annual plan value) according to the last distribution key used.

- **Distribution key 3**
  Interprets the input value as a percentage rate and multiplies it each period by the previous value.

- **Distribution key 4**
  Used to distribute period values not equal to zero to the subsequent empty periods.

- **Distribution key 5**
  Copies period values not equal to zero to the subsequent empty periods.

  The SAP R/3 System differentiates between true distribution keys and input help.

- **Distribution key 6**
  Copies a given period value to subsequent periods.

  This distribution key has no effect on the manually planned values, as it is used on the period level. The distribution keys are, however, available on the annual level.

- **Distribution key 7**
  Used to distribute the input value (annual plan value) among the individual periods in line with the number of calendar days per period.

- **Distribution key 11**
Can only be used in Cost Center Accounting for planning activity-dependent costs or activity-dependent statistical key figures.

The input value (annual plan value) is distributed in line with the activity quantity planned on the cost center.

⚠️

The R/3 System uses only those activity quantities planned at the time of the distribution key’s use. If you change activity quantities later or copy plan values to another version, the R/3 System does **not** automatically carry out new distributions.
Easy Cost Planning for Internal Orders

Use

To calculate costs on an internal order, you can alternatively use Easy Cost Planning [Extern] for the unit costing.

In the following modes, you can process the costing in the ways shown:

<table>
<thead>
<tr>
<th>Mode</th>
<th>The costing can be:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display order</td>
<td>Displayed</td>
</tr>
<tr>
<td>Change order</td>
<td>Changed/deleted</td>
</tr>
<tr>
<td>Create order</td>
<td>Created</td>
</tr>
</tbody>
</table>

Note the following features when creating a costing for internal orders using Easy Cost Planning:

- You can only plan in plan version 0.
- Unit cost planning is no longer possible in overall planning.
- Plan-integrated objects are not supported.

If you use a reference order when creating an internal order, and you have used Easy Cost Planning to make a calculation for this order, the same planning reference is assigned to the new internal order.

For more information on the Order Manager, see Order Manager and Collective Processing of Master Data Changes [Seite 45].

Prerequisites

You have not yet carried out a unit costing on the internal order.

Features

You can calculate costs and call up Execution Service [Extern].

Activities

Choose:

- Accounting → Controlling → Internal orders → Master data → Order Manager in the Create order mode, or
- Choose Accounting → Controlling → Internal orders → Master data → Special functions → Order → Create.

Choose Extras → Costing → Create.
A dialog box with two tab strips appears.
You can now create a costing in several ways:
Choosing a Planning Form From Easy Cost Planning
Choose Create cost estimate to go to Easy Cost Planning. From there you can use Choose planning form to decide on the input help for the planning form.

Choosing a Planning Form in the Dialog Box
If you choose in the dialog box to create with a planning form, you can choose the planning form in the following ways:

- On the tab strip Create with planning form, under Subject area, choose Planning forms last used. If no planning forms are displayed (for example, if you have not yet created a cost estimate), choose All planning forms or another role-specific worklist.
  The system shows all planning forms from the subject area.
  Double click on a planning form to go to Easy Cost Planning.

- To search for a specific planning form, enter a search term and choose Find.

- Under With planning form enter the technical name of the planning form and choose Create.
  You go to Easy Cost Planning with this planning form.

For all three options the costing variant is taken automatically from the order type chosen when you created the internal order. The system enters the costing date and valuation date in the Additional data tab strip, but you can change these.

After you change one of the above procedures, the Internal Order:Change:Easy Cost Planning screen appears.

You can:
- Create worklists
Standard Distribution Keys

- Display document flows for the costings
- Delete costings
- Subdivide costings
- And so on

For more notes about what you need to take into account in Easy Cost Planning, see Planning Costs Using Easy Cost Planning [Extern].
Editing Costing Models and Assigning Attributes

Use

In [Easy Cost Planning [Extern]] the planner can use the costing model that you create with this function as a planning form. This enables the costs to be calculated from the planner's point of view. You can use the costing model for all similar planning processes.

By assigning attributes to the role of the planner, you decide which screen areas are displayed for the planner in the cost estimate and also to what extent they can be changed. This assignment applies across all models and hence is only required once for each role.

Prerequisites

To be able to define costing models, experience in using the SAP System is required, particularly in the following areas:

<table>
<thead>
<tr>
<th>Application</th>
<th>Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Classification System (CA-CL)</td>
<td>Characteristics</td>
</tr>
<tr>
<td>Activity-Based Costing (CO-OM-ABC)</td>
<td>Templates</td>
</tr>
<tr>
<td>Product Cost Controlling (CO-PC)</td>
<td>Costing tools, special unit costing and costing items</td>
</tr>
<tr>
<td>Overhead Cost Controlling (CO-OM)</td>
<td>Chart of accounts, cost centers, cost elements and activity types, internal orders, overhead</td>
</tr>
<tr>
<td>Materials Management (MM)</td>
<td>Purchasing, services, material valuation, inventory management</td>
</tr>
</tbody>
</table>

In order to carry out cost planning, a costing variant must have been defined in Customizing for every object to be planned. If you want to view the costs in groups, you must have already defined cost component groups in Customizing for the application component concerned under Define Cost Component Structure.

During the implementation phase, organizational limits must have been made for the namespaces of the characteristics, to control the use of characteristics that use the Classification System (CA-CL).

For the Execution Services, you must have made the required settings in Customizing for the respective application component under Execution Services.

Features

The following graphic gives you an overview of the costing run:
### Worklists

<table>
<thead>
<tr>
<th>Worklists</th>
<th>Header Data</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planning Forms</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Characteristics</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Roles</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Work and Display Area

- Table of costing model characteristics
- Preview of entry screen and HTML editor

You can show or hide ( veterinarian ) the screen area Worklists and also change the size of the screen areas.

**Worklists area**

This area contains the planning forms, characteristics and roles. These are the predefined directories. The worklists provide an overview of the data present in the system and a user-friendly view of its structure. Once you have loaded the most frequently used planning forms, characteristics and roles into the worklists, they are always available for you to use. The directories can be made available to everyone, or limited to a specific role to which you must have been assigned, or defined in such a way that they are only available for your yourself to use.

To load available data in the worklists either choose ( vitamin ) immediately next to the node, or ( vitamin ). You can create, insert ( vitamin ), rename worklists and extend the display of worklists (from user-specific to role-specific or globally to all users), or restrict ( vitamin ) them. You can copy planning forms, characteristics or roles to other worklists of the same category per drag & drop. Make sure that you select nodes supplied with a hyperlink together with the symbol in front of them. It is not possible to copy subdirectories. Using ( vitamin ) you can call up any worklists that are in the system but have not yet been displayed. To delete worklists, choose ( vitamin ). To remove subdirectories or loaded data from a worklist choose ( vitamin ). To save worklists, choose ( vitamin ) in the screen area Worklists.

You can call a costing model and role directly by clicking on the relevant node in the worklist.

You can assign a characteristic directly to a model. To do so, you must have chosen the model and called up the assignment of the characteristics in the work area. You can copy the characteristic into the table in the work area using drag and drop.

**Definition area**
Here you can edit a costing model or role. If you want to switch from editing the costing model to editing the roles either choose , or choose the role directly in the worklist. Choose to return to editing the costing model, or choose it directly in the worklist.

Having selected a costing model or created a new one, you can carry out all changes or definitions (by clicking on the nodes) in this area. You can create a description for the model ( ). You can then use it to document the model. When the planner wants to create a cost estimate, this description is available for finding a planning form. For information on the editor, see the PC editor [Extern] and editing text [Extern].

If you have selected a role, you can select here the attributes which should be assigned to the role.

If you assign the attribute Hide cost estimate item view to the single role Maintain internal orders (SAP_CO_OM_JOB_INTORDER_MAINT) then the relevant button is hidden, meaning it is no longer possible to show the item view. This applies to all planners to whom this role has been assigned. If you want to make it impossible to show the item view for a planner to whom several roles have been assigned, then you have to assign this attribute to all of this planner's roles. The simplification of the screen achieved by this is particularly useful for occasional users, especially if they do not have extensive knowledge of Controlling in the SAP System. However, for the planner it also means that it is no longer possible to change the costing items manually.

Work and Display area

In this area, you can assign the characteristics. When you create new characteristics, you can define the characteristics directly from here. If the characteristics exist already, you can change them using in the Characteristics maintenance column.

In addition to this, you can display a preview on the entry screen by clicking on the node Structure model entry screen. You can then edit it here.

If you delete, change, edit or create new characteristics then these changes will only be displayed in the preview once you have saved the model.

Activities

- Select:
  - Choose Logistics → Project System → Basic Data → Templates → Models for Easy Cost Planning.
  - Accounting → Investment Management → Appropriation Requests → Environment → Maintain Costing Model
  - Accounting → Controlling → Product Cost-Controlling → Product Cost Planning → Easy Cost Planning & Execution Services → Maintain Costing Model

- Create costing model:
  Choose . Enter a name for the costing model. The name must not begin with a number or contain any blanks. If you do not enter a description, the system copies the
Editing Costing Models and Assigning Attributes

- Name automatically into the *Description* field. You can change the description at any time by choosing [button].
  
  If you are copying a model ([button]), enter yes to the dialog box *Save template?* Otherwise the template will not be copied.

- **Creating and Assigning Characteristics [Seite 178]**
- If you want to [structure the automatically-created entry screen [Seite 180]] to suit your requirements, select this node in the definition area.

- **Defining Derivation Rules [Seite 182]**
- If you want to display the screen areas in the cost estimate on a role-specific basis, select a role and assign the relevant attributes to it by setting the indicator. Save your settings in the screen area *Definition* using [button] (Save attribute assignment).

- Save your entries.

**Multilingual capability**

If the planner needs the costing model to be available in more than one language, you need to carry out the following activities, noting the special features:

**Characteristics**

When creating the characteristic, enter the description of the characteristic on the tab *Descriptions* in all the languages that you require.

If you want to set default values, go to the [Values tab], select a value and choose [button] Enter the description in all of the languages that you require.

If you choose *Extras → Change Language*, you can enter the characteristic description and the descriptions for all values for the language selected.

**Entry screen**

Do not change the characteristic descriptions on the entry screen. Additional text (for example notes or texts for hyperlinks) and changes can only be entered in one language, and consequently are only available in that language. The *Confirm* button and the heading *Comment* are automatically displayed in the correct language.

**Derivation rules**

You must ensure that descriptions are available in all of the languages that you require. Make sure when you use a costing model (item category J) that this also applies for the description of the model used. Do not enter any descriptions in the item lines. The descriptions are then automatically displayed in the correct language. Exception: you can only enter the description for item categories *comment line, calculation line (process and cost center/activity type), text item* and *variable item* in one language, which in turn are only available in that particular language.

**Costing Model Description**

Once you have created the model, log on to the system in each language in turn which you need to be available. Call up the model for editing and choose [button] Enter the description for each model in the correct language and save your entries. To ensure the description of the model is available in the languages you require, enter it in each of the relevant languages.
Result

The costing model is available as a template on a permanent basis. For more information, see Using Easy Cost Planning [Extern].

Example

Example of the Easy Cost Planning of a Project [Extern]
Creating and Assigning Characteristics

Use
Characteristics represent the cost incurring functions of a planning process in the costing model. A characteristic can be assigned to more than one costing model.

Prerequisites
You have created a costing model.

Procedure
1. Define the characteristics by clicking on the node Assign characteristics to the model.
   The system displays a table in the work/display area.
2. Under Characteristic name, enter the name of an existing characteristic, or create a new one. Then choose Continue.
   a. If you are using an existing characteristic, the data is copied into the table.
   b. If you are not using an existing characteristic, the system asks you if you are creating a new one. Choose Yes.
      The Create Characteristic screen appears.
      Enter the required data. SAP recommends that you select a characteristic group containing characteristics that you have created specifically for costing models. You should note the following:
      i. The system cannot interpret user-defined data formats or multiple value characteristics.
      ii. If you enter values to be available in a dropdown box, you should not set the indicator Additional values. If you want to enable planners to define their own characteristics in addition to the values that you have entered, you must define a specific characteristic for this purpose. You do this when you define the derivation rules, for instance by creating a variable item.
      iii. If you want a value to appear in the entry screen as a default setting, set the indicator D for this value.
3. Save your entries.
   You should note that on the Restrictions tab page, the characteristics are always assigned to class type 051 (which is not displayed in the input help). This ensures that the characteristics are only available for Easy Cost Planning. If you want to use characteristics with a different class type, you have to enter class type 051 for these in addition.
   You should also bear in mind that characteristics may be used in a variety of costing models, which means that if you change a characteristic this could affect more than one costing model. If you create new characteristics, you can identify them as yours by the name that you give them. Heed any naming conventions that may apply in this
regard. Characteristics to which further class types are assigned in addition to class type 051 may be used by other application components which similarly use the *Classification System* (CA-CL).

**Result**

The characteristic is assigned to the costing model and can be specified in the entry screen.
Structuring the Entry Screen

Prerequisites
You have created a costing model and assigned characteristics to it.

If you do not want to make the changes directly in HTML, you must have installed an HTML editor.

Procedure
1. Call a preview of the automatically-created entry screen by clicking on the node Structure model entry screen.
2. In the work/display area, choose 📜.
3. If you want to make the changes using your own HTML editor, you can download the HTML code as a local file to your PC by choosing 📜. To import the changed file back, choose 📜.

   If you want to change the HTML code directly, you should note the following points:
   - You must not delete the variables for the field values, because if you do the values of the characteristics cannot be interpreted correctly. The variables are generated in the form of ‘<CHARACTERISTIC NAME>.value’ or ‘< CHARACTERISTIC NAME >.name’. The system replaces the variables with the value entered. The entire expression for the variable must not exceed one line (there must not be a line break).
   - If you insert a hyperlink, you should display the Internet page in a new window. To do this, you must enter the command target="_blank" in HTML code in the following position: <a href="http://www. ... " target="_blank">Text of link in entry screen></a>. If you display the Internet page directly in the same screen area as the entry screen, the planner can only go back to the entry screen by right-clicking on the mouse. However, this would mean that the data entered before the link sequence is lost.

4. To display the changed HTML code from the editor in the preview, choose 📜.

   You can generate the entry screen in SAP style (standard setting) or in Web style. When you save the costing model, the style generated last is saved.

Result
When the costing model is saved, the changed entry screen is stored as a file by means of the Business Document Service [Extern]. However, this only happens if you have made changes in the automatically-generated entry screen (with 📜 or 📜). You can save multiple versions. The most recent version is always the active one. You can manage the files with the Business Document Navigator (📜): If, for example, you want to use an older version, you have to delete the newer ones.

⚠️
If you subsequently change a characteristic and have altered the automatically-generated entry screen with 📜 or 📜, you must regenerate the entry screen in order to include the changes. If you have changed the HTML code, it will be overwritten by the regeneration. To prevent this from happening with multiple changes, proceed as follows: Download the previous HTML code to your PC. Regenerate and compare
the HTML codes. Using cut and paste, insert the position at which the change to the characteristic has affected the HTML code into the HTML code in the local file, and import this back into the SAP System. Confirm the changes with ☑.
Defining Derivation Rules

Use

Using the derivation rules the view and thinking of the planner is transferred to the costing items of the unit costing. This is where you enter the resources needed for the planning.

If the costing model is to offer a choice between several resources of the same sort, enter all of the resources and use Activation to regulate which resource in the planning case is entered in the cost estimate. You define the activation via the prompt for a particular specification of the related characteristic, for example if characteristic LENGTH = 10, the line with resource (material) A10 is used, and if LENGTH = 20 the line with resource A20 is used.

To determine the quantity of the respective resource you use a characteristic, for example, the characteristic NUMBER OF WORKING HOURS for an internal activity item.

Prerequisites

You have created a costing model.

Procedure

You can only define the derivation rules (of the template) for the costing model when you define the model.

1. Click on the node in the definition area of the costing model.

   The screen Create template <NAME OF COSTING MODEL> appears. The template automatically receives the name of the costing model and is created in a specific environment, depending on the planning object.

2. Enter the costing items required for the planning object. For more information, see Templates for Easy Cost Planning [Seite 183].

3. Go back and save the template.
Template for Easy Cost Planning

Definition

The template is a dynamic calculation tool that uses functions and formulas to calculate numerical values and determine the results of Boolean expressions (true or false). Templates for Easy Cost Planning are created in environments 200, 205-208, and 214-215. The environment is defined automatically by the system depending on the object to be planned (internal order, WBS element, and so on). With the exception of environment 214, you cannot create environments through Customizing. Instead, you can only do so by defining a costing model.

Structure

The template contains a table in which you can make the following line entries:

<table>
<thead>
<tr>
<th>Column</th>
<th>Possible Entry/Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item category in template</td>
<td>Comment line, process, calculation row (process), cost center/activity type, calculation row (cost center/activity type), costing model, external activities, subcontracting, material, service, base planning object, text item, variable item</td>
</tr>
<tr>
<td></td>
<td>For the item category calculation row, you cannot call the editor or define methods in the object column. You can only select costing models that are valid either for all planning objects or for the same planning object as the costing model in which you want to insert this model as a submodel.</td>
</tr>
<tr>
<td>Description</td>
<td>The description is displayed in the cost estimate as the description for the costing items. The system determines the description for most of the item categories automatically once you have confirmed your entries. (The description is used in the case of the base planning object.) Consequently you only need to make an entry here if the description cannot be determined by the system or if you need to overwrite it.</td>
</tr>
</tbody>
</table>
Template for Easy Cost Planning

| **Object** | Enter the object (such as a material), depending on the item category specified. You can either enter the object directly, or define methods [Extern].

For *item categories of the template* J to R, you can use the input help to make the required entries. Always enter a cost element if the system is unable to determine one. This applies to those item categories for which the cost element was requested in the possible entries help; with base planning objects the cost element can be determined via the master data providing you have entered one there. If the item does not have a cost element, it is not possible to assign the costs to a cost component. This means that the costs cannot be rolled up if they are incurred in a cost estimate which is part of a costing structure with superior cost estimates.

For the categories *Process* and *Cost center/Activity type*, you can either predefine an object or determine dynamically one or more processes or cost centers/activity types. For more information, see Object Determination [Extern]. |
|---|

| **Quantity** | Enter a quantity or characteristic directly. You can enter the appropriate characteristic by defining a formula [Extern].

For more information, see Activity Quantity Determination [Extern]. |

| **Activation** | Specify the condition under which an item is active. For the *activation* of an item, you can predefine values as active or inactive or define a method that returns active or inactive at the point of evaluation. If you do not enter anything in the column, the item is active.

The item (MATERIAL: Gravel; 0001 / GRAVEL01; M3; QUANTITY_ FILLER; METHOD) with method: FILLER = “Gravel” is only active if gravel was selected as the FILLER. For all other characteristic values, the item is not included in the costing.

For more information, see Activation [Extern]. |

| **Price** | Price for a variable item This column is not utilized for any other item category. |

Depending on the item category in the template, there are various functions available to define methods and formulas.

For more information on the costing item categories, refer to Master Data for Unit Costing [Extern].
Periodic Allocations in Planning

Purpose
The planning of allocations that occur periodically.

Features

<table>
<thead>
<tr>
<th>Function</th>
<th>Use</th>
<th>See also:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic reposting in planning</td>
<td>You plan periodic repostings to make corrections on internal orders.</td>
<td>Periodic Reposting [Seite 186]</td>
</tr>
<tr>
<td>Planning overheads</td>
<td>You plan overhead rates as part of overhead allocation.</td>
<td>Planning Overhead Rates [Seite 187]</td>
</tr>
<tr>
<td>Template allocation</td>
<td>You plan to use overhead cost by means of internal orders.</td>
<td>Plan Template Allocation [Extern]</td>
</tr>
<tr>
<td></td>
<td>You plan to do this related to source using business processes.</td>
<td>See also: Template [Extern]</td>
</tr>
<tr>
<td>Planned settlement for internal orders</td>
<td>In internal order settlement, the costs collected on an internal order are then posted to cost centers or business processes.</td>
<td>Planned Settlement for Internal Orders [Seite 188]</td>
</tr>
</tbody>
</table>
Periodic Reposting in Planning

Use
Periodic reposting enables you to correct internal orders. Periodic reposting affects the plan costs at the period end.

Features
At the period end, the costs (first collected on a costs collector, such as an order, or cost center) are reposted to the corresponding receivers, using keys (internal order, cost center). The following data remains unchanged:

- The original cost element (primary cost element or revenue cost element)
- The accounting proof of origin

For more information on this subject, see the SAP Library, under Financials -> CO Controlling -> Cost Center Accounting -> Period-End Closing -> Periodic Reposting [Extern].

You can execute periodic repostings of costs on internal orders, regardless of the version in the plan, if you activated integrated planning of internal orders with Cost Center Accounting (see also Indicator for Integrated Planning in the Version [Seite 103]).
Planning Overheads

Use

Once you have executed cost element planning [Extern], the system can determine the overhead rates for the plan values.

For further information, see the SAP Library under Financials → Controlling → Cost Element Accounting.

Integration

- The system debits internal orders and cost centers with overheads, regardless of whether integrated planning with Cost Center Accounting is active.

- Cost centers, business processes and internal orders are only credited if integrated planning is active for the order to which overhead is applied and all credit objects. You also need to activate integrated planning for internal orders with Cost Center Accounting/Activity-Based Accounting in the version. For more information, see Integrated Planning Indicator in Versions [Seite 103].

- You can use overhead rate planning on cost centers to execute plan accrual. This is useful if you are dealing with true overhead costs. If the object is plan integrated, and integrated planning with Cost Center Accounting is activated in the version, you can write credit records for any credit object, as well as debit records (in contrast to accrual for accrued overhead). For more information on plan accrual calculation, see the SAP Library under Financials → Controlling (CO) → Cost Center Accounting → Cost center planning → Utilities → Plan accrual calculation [Extern].

Features

Whether plan costs incur overhead or not, depends on which costing sheet and, where appropriate, which overhead key you defined in your object.

The overhead rates are allocated using a secondary cost element for overhead rates.

Activities

To plan overhead rates, choose Planning → Allocations → Overhead in the corresponding application.

For more information on overhead rate calculation, see Calculating Overheads [Seite 393].
Planned Settlement for Internal Orders

Use
In planned settlement, you can post plan costs that you planned on an internal order. You can post them to cost centers, business processes or to the Profitability Analysis.

Integration
On the cost center, after the planned settlement of internal orders, you can distribute the planned costs to activity types, using splitting.
For more information on splitting, see Cost Center Planning [Extern].

For more information on planned settlement for internal orders to the Profitability Analysis, see Planned Settlement of Orders [Extern].

Prerequisites
You can execute the planned settlement for internal orders if the internal order planning integration with Cost Center Accounting or Activity-Based Costing is activated. Additionally, the settlement rule for the internal order you want to settle, must contain at least one of the following rules:

- PER rule (for period-related settlement of costs to a cost center).
- PRE rule (for the previous period-related settlement to capital investment measures).

See also:
Integrated Planning Indicator in Versions [Seite 103]).

Features
You can execute a planned settlement for internal orders to cost centers, business processes and the Profitability Analysis.

You can only split the planned costs (settled from an internal order to a cost center or a business process) completely between activity types on a fixed basis. This is because settlement of costs to cost centers or business processes is always independent of activity.

💡
When you execute marginal costing and plan costs on an internal order proportionate to an activity type, you also need to plan these costs on the receiving cost center manually. Settlement is not possible within integrated planning.

💡
You are planning the maintenance of a production plant on an internal order. The maintenance costs are proportional to the output of the plant. In this case, you do not activate integrated planning. You need to plan the maintenance costs manually on the receiver cost center.


Activities

To settle individual internal orders to cost centers, business processes, or to profitability analysis, choose Planning → Allocations → Settlement → Individual processing.

To settle more than one internal order to cost centers, business processes, or to profitability analysis, choose Planning → Allocations → Settlement → Collective processing in the corresponding application.

For more information, see the implementation guide (IMG), under Controlling → Internal Orders → Planning → Maintain Settlement [Extern].
Cost Center Allocations (Plan)

Use

In cost center accounting allocations, the system allocates plan costs from sender cost centers or business processes to internal orders.

Features

Allocations of costs to an internal order are possible, regardless of the version in the plan. To do these, you need to activate integrated planning of Orders with Cost Center Accounting, and the order must be plan integrated (see also: Indicator for Integrated Planning in the Version [Seite 103]).

Distribution

Distribution means allocating the plan costs from a sender cost center to internal orders, according to distribution keys that you defined.

The following data is transferred to the internal orders in the process:

- The original cost element (primary cost element) remains unchanged.
- The sender and receiver data is documented.

For more information on the procedure for distribution, see Distribution [Extern].

Assessment

As part of plan assessment, you can use an assessment cost element to allocate costs from a sender cost center to internal orders, according to assessment keys defined by the user.

For more information on the procedure for distribution, see Periodic Reposting [Extern].

Indirect Activity Allocation

In indirect activity allocation, you define keys that you use to allocate activities and business processes to internal orders. Moreover, you can determine the activity quantities for cost centers and business processes (whose activities it is impossible, or very time consuming to determine) indirectly.

There are two methods of processing activity allocation, depending on the category of activity type to be allocated:

- **Activities can be entered in the cost center or business process.**

  For some business processes or activity types, you can determine for each cost center the amount of activities carried out. You can then use indirect activity allocation to distribute these posted activity quantities from the cost centers or business processes to the receivers. You define these in the segment according to their allocation base.

- **Activities cannot be recorded in the cost center or business process, or if at all, then only with difficulty.**

  You can use activity calculation for activity types, whose activity quantities cannot be determined, or only with a great deal of effort.
Cost Center Allocations (Plan)

- Using the internal order tracing factors with weighting factors. You can define these for each cost center or business process.
- Using fixed, preset tracing factors in the segment definition.

For more information on indirect activity allocation [Extern] and procedure, see Cost Center Planning.
Budget Management

Purpose

The budget is the approved cost limit for a project.

It differs from project cost planning due to its binding nature. Whereas the project costs need to be estimated as accurately as possible during the planning phase, the funds are predetermined as a budget in the approval phase. The budget is the limit set by management for project costs over a certain period of time.

Features

- Original budget
  - The original budget is the budget that was allocated originally. From a time that you specify, this budget can only be corrected using budget updates.

- Budget updates
  - Unforeseen events, extra jobs required, such as an increase in cost of external activity can meant that the original budget needs to be corrected, so budget updates are required. These are made in the following ways:
    - Supplements
    - Returns
    - Budget transfers

- Current budget
  - The current budget is derived from:

|                |  
|----------------|---
| Original budget|   
| Supplements    | +  

The project system has the following types of budget:
In many enterprises, distribution of budget does not mean that the funds have been released. Therefore, in the project system there is a release function with which you can successively release budget. A release is based on the current budget, meaning the original budget that has been changed by supplements, returns, or transfer postings.

This section describes:

- Which prerequisites for budget allocation [Seite 198] are required
- How you allocate original budget [Seite 199] on a budget
- How you make budget updates [Seite 216] in the form of supplements, returns, and transfer postings.
- How you release [Seite 231] budget
Budget Management for Internal Orders

Use
The budget is the approved cost structure for an internal order or an order group.
In contrast to planning, budget management is binding. In the planning phase you need to estimate costs, whereas during the approval phase, funds are prescribed by the budget.

Features
The following different budget types exist:

- **Original Budget**
  This is the budget originally assigned, before any updates were made.

- **Budget Updates**
  Unforeseen events, additional requirements, for example, price rises for external activities, and so on. This may mean you need to update the original budget, in the form of:

- **Supplements**
- **Returns**

- **Current Budget**
  This is derived from the budget types already mentioned:

<table>
<thead>
<tr>
<th></th>
<th>Original budget</th>
<th>Supplements</th>
<th>Returns</th>
<th>Current budget</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The method for assigning and updating budget, and for configuring availability control for internal orders or order groups is similar to that for projects, except that projects are organized in a hierarchy.

For more information on budgeting, see: Budget Management [Seite 192], and Availability Control [Seite 252].

Investment programs enable you to manage and monitor budgets that cover more than one order.
You can find more information in the SAP Library, under Financials → Investment Management (IM) → Investment Management Overview [Extern].
Budgeting in More Than One Currency

Use

Having multinational locations with different national currencies may mean that you need to use different currencies for budgeting. This can also be useful if your costs are incurred abroad by goods procurement in different currencies.

Features

Each budget line item is saved in the currency in which you entered it. The system also saves the amount in the controlling area object currencies if they differ from the first currency.

⚠️ The system calculates each exchange rate using the exchange rate type and the value date. These are contained in the budget profile for the total values, and from plan version 0 for the annual values.

In the budget profile or the plan version, if the exchange rate type or the value date are different, the total and annual values may also have different exchange rates, and thus differ from each other.

The budgeting function helps you enter your budgeting data, but has limitations in the following areas:

- **Availability control and distributed value check within a project hierarchy**  
  The system only does this in the controlling area currency.

- **Budget carryforward to the following fiscal year**  
  The system only does this in the controlling area currency.

For each project profile or order type, you specify in the budget profile in which currency the budget is to be entered in.

- **Budgeting in the controlling area currency**  
  The controlling area currency is the currency used for the controlling area. If you are using the controlling area currency for budgeting, you can only use this currency for entering the budget items.

- **Budgeting in the object currency**  
  This is the currency used for the object (such as the WBS element), and is specified in the master data for the object (such as, WBS element). If you specify the object currency for budgeting, you can only enter the budget items using their respective object currencies.

- **Budgeting in any currency required**  
  Being able to select any currency enables you to budget independently of the controlling area currency and object currencies. If you selected your own currency for budgeting, you can also choose the currency to be used for posting each budget line item. You can use as many currencies as required for budgeting.

⚠️ The system valuates budget line items using the current exchange rate. If the exchange rate changes after the budget has been entered, this can cause significant...
Budgeting in More Than One Currency

differences between budget values that were entered in different currencies. In particular, when you reduce the budget, this may result in values that are difficult to analyze and that are in currencies other than the controlling area currency.

For further information, see:

- **Budget Supplements [Seite 218]**
- **Budget Returns [Seite 222]**
- **Budget Transfers [Seite 226]**

If you use more than one currency for budgeting, it may be more difficult to analyze the values displayed in the budget.
For more information on the values displayed in budgeting, see: **Budget Value Display [Seite 208]**

If you use more than one currency for budgeting, then system checks are very important.
For more information on budget checks, see: **Budget Checks [Seite 211]**

**Activities**

**Scenario 1**
You set a global controlling area, and want to monitor the budgets for all international subsidiaries. Your project managers run their **national projects** in the currency of that country. You should proceed as follows:

1. Use the object currency for budgeting
2. Define the object currencies of all WBS elements for a project depending on each national currency.
3. Assign the budget to the projects in their corresponding country currency. Your project managers then distribute the budget in the country currency within the project hierarchies.

Availability control takes place in the controlling area currency for all budget values, so you can check all budgets at any time.

Even if exchange rates change, the overall budget for the corporate group cannot be exceeded. However, the project managers can only use the budgets entered in the country currency as a guide. They should include exchange rate variances in their budget planning, as the system checks available budget in the controlling area currency.

**Scenario 2**
You have one controlling area for all countries with **global projects** and want to monitor the budgets in all of the international subsidiaries. You should proceed as follows:

1. Use the object currency for budgeting
2. Define the object currencies for the WBS elements in different currencies as required.
3. Assign the budget to the projects in the object currency of the top hierarchy node. Your project managers then distribute the budget in the project hierarchies.
There may be budget line items that have a different currency than the object currency when you make budget transfers, supplements and returns. For more information, see Budget Transfers [Seite 226].

Availability control takes place in the controlling area currency so you can check all budgets at any time.

**Scenario 3**

You have a global controlling area with global projects. Costs are also incurred in more than one currency on each WBS element. You want to monitor the budgets for all of the international subsidiaries. You should proceed as follows:

1. Select your own currency for budgeting
2. The person responsible for the budget of a project, a subhierarchy, or a WBS element enters the budgets in the currency in which future expenditure is planned.

Availability control takes place in the controlling area currency so you can check all budgets at any time. The system ensures that the total of annual budgets for each currency does not exceed the total budget.

Even if exchange rates change, the overall budget for the corporate group cannot be exceeded. However, the project managers can only use the budgets entered in the country currency as a guide. They should include exchange rate variances in their budget planning, as the system checks available budget in the controlling area currency.

In the project hierarchy, the system checks the distributed values in the controlling area currency, not the individual currencies.

**Recommendations**

- Keep the exchange rates as stable as possible. In particular, you should not change the exchange rates while entering the original budget.

- Define special reports that account for the problems caused by different currencies. For more information, see: Report: Updating Budgets: [Seite 230]

- Use as few currencies as possible, as the system often displays totals values in controlling area or object currencies only. You cannot make a direct comparison of budgets that have been entered in different currencies.
Budget Allocation Prerequisites

The following settings determine whether a budget can be allocated to a WBS element:

- **Budget profile in the project definition**
  You store a budget profile in the project definition. This profile contains the control parameters for budgeting. In Customizing specify the following under Project System -> Costs -> Budget -> Specify Default Budget Profile For Project Definitions [Extern]:
  - The period of time during which budgeting is allowed
  - Whether budgeting is allowed for total annual values, and/or annual values

The following are ways in which you can assign a budget profile to a project:

- In Customizing under Project System -> Costs -> Budget -> Maintain Budget Profile [Extern] as a default value
- In the profile data of a standard project definition in the application under Project System -> Basic Data -> Project -> Special Maintenance Functions -> Work Breakdown Structure -Y Project Definition -> Create -> Control Tab Page -> Group Box for Accounting -> Budget Profile.

In the profile data of a project definition in Customizing, under Project System -> Structures -> Operative Structures -> Work Breakdown Structure -> Create Project Profile [Extern]

- Status
  You can allocate budget after the status Created has been reached. If you want to prohibit budget allocation in the Created status, you need to define a user status.

  For more information on status management in the project system, and how to create a user status, see Status Management [Extern]
Allocating Original Budget

Once the planning phase is over, a project is approved and budgeted by a decision-making committee, whereby an original budget is assigned to the project. The budget is distributed by the project manager using the top-down method to the individual WBS elements.

You can budget a project by:

- Transferring the values in the cost planning as budget, or
- Entering the budgets directly into the WBS elements.
Transferring Cost Planning Values As Budget

**Prerequisites**

The budget allocation for a project is generally preceded by cost planning, which is the basis for specifying and approving the budget. As the project system supported detailed planning of project costs, the planning values are transferred as budget for obvious reasons.

To do this, you need to create a project with a work breakdown structure, and execute cost planning.

For more information on creating a work breakdown structure, see the SAP Library under AC-Financials → PS Project System → Structures → Work Breakdown Structure (WBS) → Processing The Work Breakdown Structure [Extern].

For more information on cost planning on a work breakdown structure, see the SAP Library, under AC-Financials → CO-Controlling → Internal Orders → Internal Order Planning → Manual Internal Order Planning → Manual Cost Planning On Work Breakdown Structures [Extern].

**Procedure**

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change.
   The system may request you to set a controlling area. The following screen appears: Change Original Budget: Initial Screen.
2. Enter the required data and choose Original budget.
   The following screen appears: Change Original Budget: WBS Annual Overview.
3. Choose WBS Element overview.
   You can make entries and budget on the WBS elements that allow the budgeting business transaction.
4. Choose the timeframe during which you want to budget via Goto → Timeframe.
5. Choose the Plan Total in CO Area Currency view, via Views.
   The Version dialog box appears.

<table>
<thead>
<tr>
<th>The plan total consists of the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value of the structure planning (independent of cost element)</td>
</tr>
<tr>
<td>+ Value of cost element planning</td>
</tr>
<tr>
<td>+ Value of unit costing</td>
</tr>
<tr>
<td>+ Value of the additive orders for the project, so the orders that are assigned to this and all lower-level WBS elements.</td>
</tr>
<tr>
<td>( = total planning value (independent of cost element) + value of cost element planning + value of unit costing)</td>
</tr>
</tbody>
</table>
Transferring Cost Planning Values As Budget

<table>
<thead>
<tr>
<th>+</th>
<th>Value of the additive networks and network activities that are assigned to this and all lower-level WBS elements. (= Plan costs of the networks or activities)</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Plan total</td>
</tr>
</tbody>
</table>

5. Enter the version whose plan values you want to transfer
6. Choose Continue.
   The values in the selected plan version are displayed as a view
7. Select the WBS elements whose plan values you want to transfer as budget
8. Choose Edit → Copy view.
   If the corresponding budget currencies differ from the controlling area currency, the system translates the plan data in the controlling area currency into the budget currency.
   - If you are budgeting in the object currency, the budget values for each object are displayed in its object currency. The object currency is always displayed on the screen behind the budget value.
   - If you are budgeting in a freely selected budget, all budget values are displayed in the current currency.
     The Copy view dialog box is displayed.
9. Enter the percentage of the plan total and decide whether the value is to:
   - Overwrite the existing value
   - Be added to the existing value
11. Choose Continue.
    You transfer the plan totals of the selected WBS elements as budget values (taking the selected percentage). You can adapt the values by overwriting them.
12. Save your budgeting.
Manual Distribution of Budgets

Use
If you do not want to use planning values as budget values, you can enter the budget directly in the WBS elements.
Distribute the total budget (using the top-down method) to the individual elements in the work breakdown structure.

Procedure
Choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Original budget -> Change.
The Change Original Budget: Initial Screen appears.
Enter the necessary data and choose Original budget.
The Change Original Budget: WBS Annual Overview screen appears.
Choose WBS Element overview.

The Budgeting business transaction is allowed only on the WBS elements that are ready for input, and thus can be budgeted.

Distribute the available budget to the individual WBS elements.
If you want to display the time-based distribution to a WBS element, choose Annual values.
If you want to see the budget distribution to the various WBS elements in one year, choose Previous year and Next year.
If you want to call up the distribution for different years, choose Goto -> Timeframe.

Check your budgeting
For more information, see Check Budgeting [Seite 211].

Check your budgeting.

Reassigning a WBS element (that has a budget) within the work breakdown structure is not supported.
System Status: **Budgeted**

After you have allocated a budget to an WBS element for the first time, the *budgeted* system status is set. The system status is retained if you take the budget back from the WBS element.

In the *Budgeted* system status, the following business transactions are forbidden:

- Deleting the WBS element
- Reassigning the WBS element and its lower-level objects.

You can set the deletion flag for WBS element that have the *budgeted* status.

The budgeted system status can be reset for WBS elements with the 0 budget by choosing Logistics or Accounting → Project System → Controlling budgeting → Tools → Reset 'budgeted' status.

The system resets the *budgeted* status if:

- The budget was taken back with the same business transaction with which it was originally allocated, and
- The selected WBS elements have the 0 budget.
Totaling up Budget Values

Use
Different people who are responsible, for example, for certain project areas or WBS elements, can budget for projects decentrally.

If budgeting is decentral (budgeting upwards or bottom-up), the person responsible for the overall budget requires an overview of the sectional budgets. They need to be totaled up, meaning that the budget values are in a hierarchy, and so that it is not possible for more budget to be distributed "below" than is available "above".

However, there may be more budget on a higher level than is distributed on the lower level.

Features
The Totaling up function provides you with an overview of the budget values that were actually distributed.

You can use this function at any time during budgeting.

Activities
Call up the function by choosing Accounting → Project system → Controlling → Budgeting → Original budget → Change → Original budget → WBS-Element overview → Edit → Total up.

You can select a particular timeframe, or you can total up total values.

The budget values of a project or a project area are totaled up. This means that they are totaled up for the higher level in the work breakdown structure and displayed there. At the same time, the system overwrites a budget value on a WBS element with the distributed value (roll-up), in other words, the total of the distributed budget values from the lower level.

A WBS element has a budget of USD 100,000. USD 50,000 and USD 25,000 of which are distributed to two WBS elements on the level below. If you trigger the totaling up function, the budget of USD 100,000 is overwritten by the distributed value of USD 75,000.
Reevaluating Budget Values

Use
You can revaluate the budget values of a project or chosen, selected WBS elements. In other words, you can increase or decrease the values by a certain percentage or amount.

Procedure
1. Choose Accounting → Project system → Controlling → Budgeting → Original budget → Change → Original budget → WBS element overview. In the WBS element overview, select the WBS elements that have the budgets to be reevaluated.

3. Choose Edit → Revaluate.
   The Revaluate dialog box appears.

4. Enter the percentage or amount by which you want to change the current budget. If you want to reduce the budget, enter " – " after the figure.

5. When you choose Continue, the system changes the values accordingly.

6. Save the budget values.
Entering Budget Texts

Use

You can enter short, explanatory texts and/or long, descriptive texts for a project budget, or for chosen and selected WBS elements.

Procedure

1. Choose Accounting → Project system → Controlling → Budgeting → Original budget → Change → Original budget.
2. In the WBS Element Overview or in the Annual Overview, choose Goto → Document text. The Text dialog box appears. The Document date field is defaulted with today's date.
3. You can store a short text in the Text field.
4. As an alternative or as a supplement, you can enter a long text. Enter a name for the text that you wish to store in the Long text field, and choose Continue. The system informs you that this text was not found.
5. Choose Continue. A dialog box appears, in which you are asked if you wish to create the text for the first time.
6. Choose Yes. The SAPscript Editor appears.
7. Enter the text.
8. Save your text.
   Choose Back to return to budgeting.

To change a long text, proceed as follows:

1. In the WBS Element Overview or in the Annual Overview, choose Document text. The Text dialog box appears.
2. Enter the text name in the Long text field, and choose Change long text. The SAPscript Editor appears, in which you can change the text.
3. Save your changes.

To find a long text, proceed as follows:

1. Place the cursor on the Long text field in the dialog box, and choose the F4 help. The Find standard texts dialog box appears.
2. Enter one or more search criteria.
3. Choose Proceed to start your text search. The system displays a list of texts found, from which you can make an appropriate selection.
Budget Value Display

Use
In addition to overall and annual budget values, you can see other budget values by choosing Views: If you are using different currencies for budgeting, the system displays the budget values in the currency of each view.

Features
Some values can be displayed only in the controlling area or object currencies.

- **Distributed Value**
  The total of the current budget (see below) for each lower-level WBS element. The distributed values can be displayed only in the controlling area or object currencies.

- **Distributable value**
  This is the difference between the current budget and distributed value. The distributable values can be displayed only in the controlling area or object currencies.

- **Assigned value**
  Total of commitment and actual postings. This can be displayed when availability control is active. The availability control checks new postings against the available budget regardless of the currency used to enter the budget items. The availability control checks in the controlling area currency, which is why the system displays the assigned value in the controlling area currency only.

- **Current Budget**
  Original budget that was changed by budget updates (supplements, returns, transfers). The current budget can be displayed only in the controlling area or object currencies.

- **Entered in transaction currency** (only for budgeting with freely chosen currencies)
  Total of the budget values entered in each currency. The system does not include amounts that were entered in a different currency. This view may only display some of the values from the Current Budget view.

- **Release**
  Based on the released budget from the current budget. The system checks releases using the controlling area currency. Therefore, you can display releases in the controlling area only.

- **Cumulated value**
  Total of the annual budgets. The system determines the cumulated value always using only the values in the currency that you are currently using for processing the budget.

- **Remaining value**
  Difference between overall budget and cumulated. The system determines the remaining value always using only the values in the currency that you are currently using for processing the budget.

- **Previous year**
  The system determines the values from the previous year always using only the values in the currency that you are currently using for processing the budget.

- **Plan total**
  The system always displays the Plan total in the controlling area currency.
The **Plan total** consists of the following:

<table>
<thead>
<tr>
<th>+</th>
<th>Structure planning value (independent of cost element)</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Cost element planning value</td>
</tr>
<tr>
<td>+</td>
<td>Unit costing value</td>
</tr>
<tr>
<td>+</td>
<td>Value of the additive orders for the project, meaning the orders assigned to this and all lower-level WBS elements. ( = Overall planning value that is cost element independent + Value of cost element planning + Unit costing values)</td>
</tr>
<tr>
<td>+</td>
<td>Value of the additive networks and network activities that are assigned to this and all lower-level WBS elements. ( = Plan costs of the networks or activities)</td>
</tr>
<tr>
<td>=</td>
<td>Plan total</td>
</tr>
</tbody>
</table>

Note that after budget updates are made by supplements, returns, and transfers, the displayed values (such as the distributed value) are always based on the current budget, not the original budget.

You specify the values displayed next to the budget value in the initial screen for budgeting by determining them in the budget profile, using the **View** parameter.

**Activities**

Choose **Settings -> Scaling factor** to select the currency units for displaying the budget values in 1, 10, 100, 1,000, 10,000, 100,000 or millions (**0 to **6) and to set the number of decimal places.
Copying Views

Use
In the WBS element overview and annual overview, you can choose Views to display different values as well as the budget values. You can transfer a percentage portion of the set view, or add it to existing budget values.

Procedure
1. Choose Accounting → Project System → Controlling → Budgeting → Original budget → Change → Original budget → WBS element overview.
2. Use Views to choose the view that you want to transfer as budget, or add to existing budget values.
3. Select the WBS elements that you want to copy to the selected view.
4. Choose Edit → Copy view. The Copy view dialog box appears.
5. Enter the percentage of the set view and decide whether this value is to:
   - Overwrite the existing value, or
   - Be added to the existing value.
6. Choose Continue.
   For the selected WBS elements, the values from the set view (taking the selected percentage into account) are transferred as budget values, or added to existing budgets.
   You can adapt the values by overwriting them.

💡
The view currency may differ from the one you used for entering the budget. If this is the case, the system translates the values to be copied into the appropriate budget currency.
7. Save your budgeting.
Checking Budgeting

Use

After budget has been distributed, you can check your budgeting for the total or annual values. This check is made when you save the budget.

Features

The system checks the following budget values:

- In the project structure, the system checks whether the budget values from a lower-level of the WBS element (assigned-values) exceed the budget value of the next level up. As this check is made in the controlling area currency, the system also includes budget that was entered in different currencies.

  ![](warningicon.png)

  The system also checks the assigned values in the controlling area currency even if you chose your own currencies for budgeting.

- For each WBS element, the system ensures that the total of the annual budgets does not exceed the overall budget, if budgeting total values is planned (The Total values indicator is set in the budget profile). This check is made in the controlling area currency so that the system can also include the budget values that were entered in another currency.

  ![](warningicon.png)

  Even if the total values and annual values match up in a freely selected currency, the values in the controlling area currency can vary from each other if the exchange rate type or the value date for the total values and the annual values differ.

- In active availability control, the system also checks whether the assigned values exceed the overall or annual budget. This check is made in the controlling area currency, so that the system can include budget values that were entered in a different currency. The budget used for comparison depends on the settings made in the availability control in the budget profile.

  For more information, see Availability Control [Seite 252].

If errors occur, the following happens:

- In the overview screen and the annual view, the system selects the budgeted elements in the WBS that contain errors.

- The system issues an error log that you can print out. This log displays the budgeted WBS elements that contain errors, compared with the Budget and assigned values. In active availability control, the log contains the warnings or error messages that were issued due to any excesses of the tolerance limit. You can call up an explanatory text by choosing Long text or by double-clicking on a row in the log.

Activities

Check your budgeting by choosing 📊.
Checking Budgeting

Correct you budget allocation if necessary, by processing the corresponding budget values as follows:

1. Overwrite or select, delete and re-enter
2. Re-check and
3. Save.
Saving Without Checks

You can save budgeting without checks, providing you have not yet activated availability control for your project.

This is particularly useful if you want to save a budget allocation in the system that has not yet been approved by a decision-making committee. As soon as you activate availability control, it is no longer possible to save without checks.

For more information on availability control, see Availability Control [Seite 252].
Distributing Annual Budgets

You can plan the years that are likely to be needed to realize a project either before or after the distribution of the overall budget.

1. Choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Original budget -> Change.
   The Change Original Budget: Initial Screen appears.
2. Enter the necessary data and choose Continue or Original budget.
3. Choose the WBS Element overview.
5. Place the cursor on the WBS element where you want to distribute annual budgets.
6. To call up the annual overview, choose Years.
7. The Change Original Budget: Annual Overview screen appears. The system displays the overall budget (if any) on the WBS element, and the fields ready for input for the annual values.

Alternative procedure:
Instead of specifying the annual values for a certain WBS element using the annual overview, you can also budget all WBS elements for a certain year.

1. Choose Goto -> Annual values to call up the element overview for the start year with the fields ready for input for the budget values.
2. Choose Goto -> Timeframe -> Timeframe to call up the Timeframe dialog box, with the entry field Year, which contains the start year.
   You can now choose a this timeframe or overwrite the year entry to choose another timeframe.
3. If you choose Continue then the system displays the element overview for the selected timeframe, with the fields ready for input in the WBS elements.
4. Enter your annual budget for the selected WBS element.
5. Use this method to budget for all WBS elements in the project.
6. Check your budgeting and save the budget values.

The Copy view, reevaluate, and Total up functions are also available for budgeting annual values.
Displaying Budget Line Items

Each change that you save in budgeting is documented as a line item by the system.

Procedure

To display the budget line items for a WBS element, choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Original budget -> Change.

The Change Original Budget: Initial Screen appears.

Enter the necessary data and choose Continue or Original budget.

Choose the WBS Element overview.

The Change Budget: WBS Element Overview screen appears.

Choose Extras -> Line item.

If you are using more than one currency for budgeting, the system displays all of the line items for the required WBS element. This is independent of the currency that you are currently using for the budget.

You can prohibit line item writing for changes to the original budget by means of a user status, although the system continues to write line items for budget updates.

You can create short texts and/or long texts for budget line items.

Line items are identified by a unique number. You need to specify intervals (number ranges) for this in Customizing for the Project System.

For more information, see the implementation guide (IMG) under Project System -> Costs -> Budget -> Create Number Ranges for Budgeting [Extern].
Budget Updates

Unforeseen events, additional requirements, price rises for external activities, and so on may mean you need to update the original budget.

There are three types of budget update:

Supplements
Returns
Transfers

You can also update the budget using the change function in the budget. The system logs the changes as line items.

The time to “freeze” a budget as an original budget, and to update it with supplements, returns and transfers depends on when you want to log data origins, in other words the sender-receiver relationships for the updates. You therefore use budget updates to prove where supplements, returns and transfers originated, and where they are to be used. You do this using status management.

For example, the Budgeting business transaction is allowed in the Created status. You create a user status in the status profile. This prohibits the Budgeting business transaction, but allows the Budget supplement, Budget return, and Budget transfer business transactions. When you have specified the original budget, you set the user status so that the budget can only be updated using supplements, returns, or transfers. For more information on status management, see the SAP Library under Accounting → PS-Project System → Structures → Status Management [Extern].

If availability control is activated for a project, then each update is checked. For more information, see: Availability Control [Seite 252].

The current budget is calculated as follows:

<table>
<thead>
<tr>
<th>The current budget is calculated as follows:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
<tr>
<td>Original budget</td>
</tr>
<tr>
<td>+</td>
</tr>
<tr>
<td>Supplements</td>
</tr>
<tr>
<td>-</td>
</tr>
<tr>
<td>Returns</td>
</tr>
<tr>
<td>+/-</td>
</tr>
<tr>
<td>Transfers</td>
</tr>
<tr>
<td>=</td>
</tr>
<tr>
<td>Current budget</td>
</tr>
</tbody>
</table>
Budget Supplement

Use
If the funds provided are not sufficient, the Project System enables you to use budget supplements, which can be used on the project.

Features
There are two types of supplement:

In The Project
You make a supplement in the project from the top-down, from a higher level WBS element to the one below. You can supplement only as much budget on a WBS element, as is contained in the higher level.

The amount of budget left depends on the distributable or available values. The available value is the difference between distributable and assigned values. The system determines these values in the controlling area currency, and includes budget line items that were entered in different currencies.

To The Project
By making a supplement to a project, you make particular supplements, meaning that you provide a selected WBS element with additional external budget. This is independent of the remaining budget on the higher level. The system updates the supplemented budget on the WBS “upwardly”.

If you use more than one currency for budgeting, the system always translates a supplement with the current exchange rate into the controlling area currency or object currency. If the exchange rate for the supplement is different from what it was when you entered the original budget, the new total budget was translated using an average rate.

💡
Budgeting in the object currency with projects whose WBS elements have different object currencies may mean that there are budget line items on WBS elements in currencies that differ from the object currency.
For more information, see Budget Transfers [Seite 226].

You cannot supplement budget in all project statuses. The project or the WBS elements for which budget is to be supplemented need to have a status that allows the Budget supplement business transaction.

See also:
Making Budget Supplements in Projects [Seite 219]
Making Budget Supplements to Projects [Seite 220]
Making Budget Supplements in Projects

Use

You make a supplement in a project in the same way as manual budget allocation: The values are entered and displayed hierarchically on the WBS. You can allocate supplements to the total budget and / or to individual annual budgets. The order in which you do this is not important, similar to budget allocation.

Procedure

To supplement budget in the project, proceed as follows:

Choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Supplement -> Change.

The Change Supplement: Initial Screen appears.

Enter the necessary data and choose Supplement.

Choose WBS Element overview.

The Change Supplement: WBS Element Overview screen appears.

Enter the corresponding data.

💡 Only the WBS elements where the Budget supplement business transaction is allowed are ready for input.

To select the timeframe for which you want to allocate a supplement, choose Annual values -> Previous or Next.

Allocate the supplements then choose Continue.

The system displays the updated view as well as the supplements, for example, the Distributed value.

Totaling up, adjustment, and other functions in budget allocation, are available for supplements in the project.

Save your supplements.
Making Budget Supplements to Projects

Procedure

To make a budget supplement to a project, proceed as follows:

Choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Supplement -> To project.

The Post Supplement: Initial Screen appears.

In the initial screen, enter the required issue date for the original document in the document date field. The system defaults today's date, but you can overwrite this if required.

If you want to enter a lot of similar items, you can enter default values (listed below) in the Template field group for the supplement items that you want to enter afterwards:

- **Receiver year**
  The Receiver year is the year in which the receiver object receives additional budget. To enter budget supplements in different years, leave this field empty.

- **Total values too**
  If you select this indicator, the system changes the total budget for the receiver to the same extent as the annual values. To supplement total values only, select this indicator and leave the Receiver year field empty.

- **Text**
  You can enter a short text in this field to describe the supplement.

- **Long text**
  You can enter the name of a standard text describing the supplement in this field.
  You can search for an existing text using the F4 help. The Find standard texts dialog box appears. You can enter the search criteria for a text search here.

  If you want to create a long text, enter a description and choose Execute. The system displays a message that the text cannot be located. Choose Continue. A dialog box appears, in which you are asked if you wish to create the text. Once you have confirmed this, go to the editor for standard texts.

If required, enter short text.

Choose Continue.

The Post Supplements: List Screen appears.

Allocate the supplements by entering the receiver WBS element and the amount. If the template does not specify it, select the year and if required, the option to include total values.

The following functions are provided under Supplement:

- **Hold**
  You can use this function to save entered items before an interruption in your work for example. The entry rows that are put on hold appear automatically when you restart the function, providing they are not posted.

- **Check**
  You can use the checking function before posting to determine whether the entered items contain any errors. The system selects any rows containing errors, and you can display a list of these
errors by choosing Extras -> Display error log. To print out the error log, choose Extras -> Print error log.

Post
The supplement items that you entered are posted. Any rows containing errors found by the system are not posted. These are selected and displayed in the error log. If posting is completed successfully, the system deletes any backups that you made using the Hold function.
Budget Returns

Use

You can return any surplus funds that you have.

Features

There are two types of budget return:

In The Project

*Returns in the project* are made from the bottom-up from a lower-level WBS element to the next one up. You can only return budget that is distributable or available. The system determines the amount of distributable or available budget in the controlling area currency, including budget line items that were entered in different currencies.

From The Project

You submit distributable or available budget on a WBS element from the project. The system updates the returns within the project, meaning that the total budget is reduced accordingly.

⚠️

Budgeting in the object currency with projects whose WBS elements have different object currencies may mean that there are budget line items in currencies that differ from each object currency. For more information, see *Budget Transfers [Seite 226]*.

Each return is translated into the controlling area or object currency using its current exchange rate.

A budget of 1000.00 USD translated into the controlling area currency is returned.

<table>
<thead>
<tr>
<th>Object Currency</th>
<th>Exchange Rate</th>
<th>Controlling Area Currency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Budget</td>
<td>2000 EUR</td>
<td>1,- $ ≡ 2 EUR</td>
</tr>
<tr>
<td>Budget is Reduced</td>
<td>-2200 EUR</td>
<td>1,- $ ≡ 2.20 EUR</td>
</tr>
<tr>
<td>Resulting Current Budget</td>
<td>-200 EUR</td>
<td>1,- $ ≡ 2.20 EUR</td>
</tr>
</tbody>
</table>

If the exchange rate for the return is higher than it was when the original budget was entered, then the budget has a negative value in the object currency.
### Budget Returns

<table>
<thead>
<tr>
<th>Current Budget</th>
<th>2000 EUR</th>
<th>1,- $ \equiv 2 EUR</th>
<th>1000,- $</th>
</tr>
</thead>
<tbody>
<tr>
<td>Budget is Reduced</td>
<td>-1500 EUR</td>
<td>▼ Change 1,- $ \equiv 1,50 EUR</td>
<td>-1000,- $</td>
</tr>
<tr>
<td>Resulting Current Budget</td>
<td>500 EUR</td>
<td></td>
<td>0 $</td>
</tr>
</tbody>
</table>

If the exchange rate for the return is higher than it was when the original budget was entered, then the budget has a negative value in the object currency.

You cannot return budget in all project statuses. The project or the WBS elements for which budget is to be returned need to have a status that allows the *Budget return* business transaction.

**See also:**

- [Budget Returns in Projects](Seite 224)
- [Budget Returns from Projects](Seite 225)
Making Budget Returns in Projects

Use

You make a return in a project in the same way as manual budget allocation: The values are entered and displayed hierarchically on the WBS.

You can return total budget and/or individual annual budgets. The order in which you do this is not important, similar to budget allocation.

Procedure

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Return → In project.

2. Enter the necessary data and choose Return. The Change Return: Annual Overview appears.

3. If you want information on the distributable budget of the sender before entering the amount, then leave the Amount column empty, and choose . In the amount column, the system displays all the distributable budget of the sender for all items previously entered.

See also:

Making Budget Supplements in Projects [Seite 219]
Making Budget Returns From Projects

Use

The method of returning budget from the project corresponds to the method for making a supplement to a project.

Procedure

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Return → From project.
   The Post Returns: Initial Screen appears, in which you can enter default values for more than one similar return.
2. Enter data as required.
3. If required, choose Settings → Double-line entry to create an entry with two rows.
   The system displays single-line entry, which you use to initially only enter the Sender WBS element and the returned amount for each return item. The other fields contain default values (Sender year, Total values too, Short text and Long text). Therefore you need to specify default values for single-line entry.
   To enter individual sender WBS elements, and/or years, then choose double-line entry.
4. The Post Return: List Screen appears.
5. For information on the distributable budget of the sender, leave the Amount column empty, and choose.
   In the amount column, the system displays all the distributable budget of the sender for all items previously entered.

See also:
Making Budget Returns to Projects [Seite 220]
Budget Transfer Posting

Use
In an area of responsibility, budget run low on a project, while on another project there is still sufficient budget. You can use transfer postings to provide a project with available budget from another project.

Prerequisites
The currency for a transfer posting must be allowed on both of the WBS elements involved. The WBS elements can belong to different projects or to the same one.

Features
You can differentiate between the following:

- Transfer postings between different WBS elements in the same timeframe. Sender and receiver WBS element must not belong to the same hierarchy branch.
- Transfer postings between different timeframes for the same WBS element (also advances or carryforwards)
- Transfer postings between different WBS elements from different years.

You cannot make transfer postings in every project status. The WBS elements involved must have a status that allows the business transaction Budget transfer posting.

There are three business transactions in transfer postings:

- **Budget transfer posting - Receiver**
  The WBS element that has a status which allows this business transaction can receive in a transfer posting.

- **Budget transfer posting - Sender**
  The WBS element that has a status which allows this business transaction can send in a transfer posting.

- **Budget transfer posting - Transfer**
  The WBS element that has a status which allows this business transaction can send and receive budget in a transfer posting.

A transfer posting has the same procedure as a supplement to a project [Seite 220] or a return from a project [Seite 225] except that you specify a sender and receiver WBS element, or year.

Transfer postings between objects on lower hierarchy levels are also made by the system on the objects in the higher hierarchy levels.

⚠️

During budgeting in the **object currency**, the following problems may occur during a transfer posting:

The system only regards budget line items in each object currency as the **entered budget**. Transfer postings that were made in other currencies are therefore not displayed on objects in higher hierarchy levels as **entered** values.
The system regards all budget line items as *current budget*.

To display the budget line items for a WBS element, choose *Logistics* → or *Accounting* → *Project system* → *Controlling* → *Budgeting* → *Original budget* → *Change*.

The following screen appears: *Change Original Budget: Initial Screen*.

Enter the required data, and choose *Continue* or *Original budget*.

Choose the WBS element overview.

The following screen appears: *Change Budget: WBS Element Overview*.

Choose *Extras* → *Line items*.

You have entered the following budget values on a work breakdown structure with two hierarchy branches, and five objects with different object currencies.

Now you make a transfer posting between two WBS elements on the lowest hierarchy level: 100 $ from *WBS element 1.1.1* to *WBS element 1.2.1*. The current budget is now as follows on the work breakdown structure:

*WBS elements* 1.1 and 1.2 have EUR as their object currency. The transferred 100 $ is displayed in the line item report. The entered value of the *WBS element 1.1* however, is still 2000 EUR and *WBS element 1.2* is 100 EUR, as the system only includes the budget line items that were entered in EUR.
Activities

To transfer budget, choose Logistics or Accounting → Project system → Controlling → Budgeting → Transfer posting.

In the following initial screen: Transfer Budget: Initial Screen, you can enter a sender and receiver year as a default value for numerous, similar transfer postings. You can also specify whether the total values should be included in the sender WBS element.

Under Settings you can choose Double-row entry to switch from single to double row entry. The default is single row entry, which you can initially use to make entries in the WBS element sender and receiver fields, and to enter the amount and currency of the transfer posting for each transfer item. The other fields Sender year, Include total value, Text and Long text contain default entries. Therefore, you need to specify default values for single row entry.
If you want to enter individual sender WBS elements and / or years for each transfer item, then choose double-row entry.

Note that the sender and receiver year are two subsequent years.
Run Budget Update Reports

Procedure

To display totals records for supplements, returns and transfers for projects, proceed as follows:

Choose Logistics or Accounting -> Project System -> Information System -> Controlling -> Costs -> Budget related -> Budget updates

To display the budget line items for a WBS element, choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Original budget -> Change.

The Selection: Budget Updates screen appears.

Enter a project and choose Execute.

You can go from the totals records to the line item display, and call up a document chain that displays the sender-receiver relationship for each budget update.

⚠️

The system displays the totals records for the budget values in the controlling area currency only.

Recommendation

If you use more than one currency for budgeting, and require the budget values in the report to be in each currency, then define corresponding reports.

Alternatively, the line item report is available.
Releasing The Budget

Use
In many companies, distributing the budget is not the same as releasing funds. Therefore the Project System enables you to release the budget successively.

You can release budget on a total or an annual level (providing budgeting using total or annual values is included in the budget profile).

Prerequisites
The release is based on the current budget, meaning the original budget changed by supplements, returns, or transfers.

Activities

Releasing The Budget
1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Release → Change.
The Change Release: Initial Screen appears.
2. Enter the necessary data and choose Release.
   The Change Release: Annual Overview screen appears.
   ![Tip]
   You can release the budget for a project or for an individual WBS element. Enter the corresponding WBS element.
4. Choose WBS Element overview.
   The Change Release: WBS Element Overview screen appears.
   ![Tip]
   The Budget business transaction is allowed only on the WBS elements that are ready for input, and thus can be released.
5. Choose the timeframe that you want to release by choosing Goto → Timeframe.
6. Choose Views to select the Plan total in COAr Currency view.
   The Version dialog box appears.
7. Enter the version that contains the plan values you want to use as the budget.
8. Choose Continue.
   The system displays the values in the selected plan version as a view.
9. Select the WBS elements that contain the plan values you want to use as the budget.
10. Choose Edit -> Copy view
   If the current budget currency differs from the controlling area currency, the system translates the planning data from the controlling area currency to the budget currency.
Releasing The Budget

- If you use the object currency for budgeting, the system displays the budget values for each object in its own object currency. The system displays the object currency on the screen after the budget value.

- If you chose your own currency for budgeting, the system displays all the budget values in the current currency. The Copy view dialog box appears.

10. Enter the percentage of the plan total and decide whether the value is to
- Overwrite the existing value
- Be added to the existing value

13. Choose Continue.
You transfer the plan totals for the selected WBS elements as budget values, taking into account the selected percentage. You can adapt the values by overwriting.

14. Save your release.

Check Release
You can check the release at any time by choosing Release -> Check. The system automatically checks the budget release when you save it.

Providing the availability control is not active you can save a budget release without checking it.
If availability control is active this is no longer possible. The system then only allows you to save a budget release that does not contain any errors.

Checked Values

- **Project structure**
  In the project structure the system checks whether the releases in a lower-level of the WBS element (Distributed values) exceed those in the level above. The system uses controlling area currency for the check, and includes budget line items that were entered in different currencies.

- **Time level**
  For each WBS element, the system checks whether the total of the annual releases (cumulated releases) exceeds the total release. This check is made using the current currency. The system does not include budget line items that were entered in a different currency.

- **Releasing the current budget**
  The system checks whether
  - The total release exceeds the current total budget
  - The annual releases exceed the current annual budget
  The system uses controlling area currency for the check, and includes budget line items that were entered in different currencies.
Availability control is active

In Customizing under Project System → Costs → Budget → Maintain Budget Profile [Extern], you can make settings to determine whether the system checks availability for overall budgets, annual budgets, overall releases, or annual releases. If availability control is active, the system also checks the following:

Availability control for overall releases
If this is active, the system checks whether the Assigned values (= actual + commitment) exceed the overall release.

Availability control for annual releases
If this is active, the system checks whether the Assigned values on an annual level exceed the annual release.

The system uses controlling area currency for the check, and includes budget line items that were entered in different currencies.

For more information on availability control, see: Activating Availability Control [Seite 263].
Budget Carryforward

Use

The budget carryforward enables you to carry forward budget remainders from projects, internal orders, and plant maintenance orders to the following fiscal year.
A budget that has not been used up is mainly defined here as the difference between planned budget and incurred actual costs.
Budget carried forward to the following year can also be posted to the previous year in certain circumstances.

Prerequisites

Commitments are not taken into account when the unused budget is calculated. Therefore you need to carry forward commitment before you do so for the budget. To call up commitment carryforward, choose Accounting → Controlling → Internal orders → Year-end closing → Commitment carryforward, or Logistics or Accounting → Project system → Controlling → Year-end closing → Commitment carryforward.

Features

If required, you can carry budget forward at year-end closing.
It is generally useful to carry forward budget by project, project interval, or internal order interval.
If you do so by internal orders, you require a selection variant. You use this to specify which internal orders are to be selected, and to be included in the carryforward run. You may need to maintain the selection variant before carrying forward budget. You do this in Customizing, under Controlling → Internal Orders → Order Master Data → Selection and Collective Processing → Define Selection Variant [Extern].

You can carry forward budget more than once in a row. Each time, budgets are carried forward that were not included in the previous runs, because the corresponding internal orders or WBS elements were locked, for example. If you make follow-up postings of actual costs, the system posts back budget that was carried forward to the following year (a maximum of the total budget carried forward to the following year).

Budget carryforward is only allowed if the object (WBS element/internal order) has been Created, Released, or Technically completed. Budget carryforward is not possible for Closed objects, or those that have a deletion indicator or deletion flag. Nor can you carry forward negative budget into the following year.

You can start the budget carryforward as a test run or update run.

If you want to check the budgets carried forward, you can choose the detail list and display it.

There is no availability control during the budget carryforward.

Budget is always carried forward in the controlling area currency, meaning that budget line items entered in a different currency are also carried forward.

Activities

To call up budget carryforward, choose Accounting → Controlling → Internal orders → Year-end closing → Budget carryforward in Controlling.
In the Project System, you call up budget carryforward by choosing Logistics or Accounting
Project system → Controlling → Year-end closing → Budget carryforward.
Request For Budget Increase In The Intranet

Use
You want to apply for a budget increase for an order, network, network activity, or a WBS element.

You do not know who approves this operation.

Features
There are two different scenarios:

- Request for budget increase (scenario SR61)
  The form is sent to a processor, who changes the budget and executes the budget transactions in the R/3 System.

- Request for budget with approval (scenario SR62)
  The form is sent to an approving manager, who is determined as follows:
  
  - If you enter an approving manager, then they receive a message.
  - Otherwise, the budget manager or WBS manager stored in Customizing receives the message.
  - If you did not enter an approving manager and do not have any budget or WBS manager in Customizing, then the role determines the approving manager.

  The manager approves the request. The request processor receives a message via the role determined in Customizing, and via workflow.

  For more information on Customizing scenarios, see the implementation guide (IMG) under Cross-Application Components → Internet / Intranet Services → Internal Service Request → Definition of Scenarios → Define Scenarios [Extern] or in the SAP-Library under Cross-Application Components → Internal Service Request [Extern].
Request For Budget Increase In The Intranet

Form for the budget increase request without approval

The form for the request that requires approval is different in that the Processed by field is replaced by the Approved by field.

Activities

You (the person entering the request) call up the internal service request [Extern] from the LaunchPad in the mySAP.com Workplace via Create internal service request.
Initial screen for an internal service request

You select the form Request for budget increase.

You (the person entering or initiating the request) enter an object, the required budget increase, and the required currency in the form.

The system determines the approving manager or the processor of the notification as required.

The request is forwarded to the approving manager or the processor.

The applicant often specifies the object to which they want to post costs to be included in the active availability control. Examples of this are plan data, actual costs or commitments.

The object that actually carries budget (and may be different than the specified object) may be unknown or not of interest to the applicant.

See also:
Special Fields In The Form [Seite 239]
**Special Fields In The Form**

The form for the request with approval differs in that the *Processed by* field is replaced with the *Approved by* field.

**Budget User**
- Can always be changed by person entering request
- The object is always entered manually
- Possible entries:
  - Order
  - WBS element
  - Network
  - Network activity

💡

You can apply for **one** object budget increase in **one** request.

**Budget Object**
- Not changeable
- The system provides the budget carrying object for the budget user
- Options:
Request For Budget Increase In The Intranet

- WBS element and WBS element number
- Order and order number

• Always changeable by the person making the entry
• Is specified by the system using standard role
• If no standard role was stored, then the budget manager is the processor.

Amount

• Always changeable by the person making the entry

Currency

• Changeable if contains no entry
• Currency determination
  - No entry
    The system chooses the budget currency from the budget object.
    
    If the budget currency is the group currency or the object currency, then this currency
    is the only currency that can be freely selected for the amount.
  
  - Entry made by the person entering the request

• Budgeting currency = Group or object currency
  If the budget currency is the group currency or the object currency, then the system issues
  an error message if you enter a different currency, and the system provides the correct
  currency.

• Budgeting currency = Freely selectable transaction currency
  The currency entered is accepted.

The system determines the budgeting currency using the Customizing settings

• For internal orders under Accounting → Controlling → Internal Orders → Budgeting and
  Availability Control → Maintain Budget Profiles [Exter]

• For projects under Project System → Costs → Budget → Maintain Budget Profiles [Exter].

Approved by

• Always changeable

• The approving manager is determined as follows:
  - The person entering the data enters the name of an approving manager. This entry is
    prioritized over the settings in Customizing.
  - If an approving manager's name is not entered, the system uses the Customizing
    settings to determine someone for approval.

• For internal orders under Accounting → Controlling → Internal Orders → Budgeting and
  Availability Control → Maintain Budget Manager. [Exter]
• **For projects** under *Project System → Structures → Operative Structures → Work Breakdown Structure → Create WBS Element Manager [Extern].

  - If you did not store a budget or project manager in Customizing, and the person entering the data does not specify anyone, then the system creates an approving manager using the roles stored in scenario Customizing. For more information on customizing scenarios, see the implementation guide (IMG), under *Cross-Application Components → Internet / Intranet Services → Internal Service Request → Definition of Scenarios → Define Scenarios [Extern].

**Remarks**

Enables you to enter a short reason or description for a budget increase.

**See also:**

*Customizing Settings For Form Fields [Seite 242]*
Customizing Settings For Form Fields

Customizing Settings For Form Fields

Determining The Budgeting Currency

The budgeting currency is determined by the budget profile.

For more information on budget profile settings, see the implementation guide (IMG):

- **For internal orders** under Accounting → Controlling → Internal Orders → Budgeting and Availability Control → Maintain Budget Profile [Extern].
- **For projects** under Project System → Costs → Budget → Maintain Budget Profile [Extern].

Determining The Budget Manager

For internal orders:

You can define a manager in Customizing for each controlling area, object class, and order type.

⚠️ You can have more than one budget manager or WBS element manager in Customizing. If there is more than one manager, the system chooses the first from the list.

For WBS elements:

The budget managers are always the WBS element manager and the project manager.

If you did not enter a budget manager, or store a manager in Customizing, then the system determines a manager using the role stored in the Customizing for scenarios.

For more information on customizing scenarios, see the implementation guide (IMG) under Cross-Application Components → Internet / Intranet Services → Internal Service Request → Definition of Scenarios → Define Scenarios [Extern].

Determining The Budget Object

The system checks to which budget object a budget consumer was assigned.

If budget is already allocated on the potential budget object, then this budget object is used for the request.

If no budget was allocated on the potential budget object, the system checks the path in the hierarchy from the bottom upwards to the TOP WBS element. The first object with budget that the system finds in the hierarchy is the budget object for the request.

If no budget object is found in the entire hierarchy, where budget was already allocated, then the system uses the object initially specified as the potential budget object for the request.

Examples For Finding Budget Objects

**Example One**

<table>
<thead>
<tr>
<th>Object</th>
<th>Budget</th>
<th>Actual</th>
<th>Assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top WBS element</td>
<td>1000</td>
<td>1000</td>
<td></td>
</tr>
<tr>
<td>WBS element one</td>
<td></td>
<td></td>
<td>1000</td>
</tr>
<tr>
<td>Order</td>
<td></td>
<td>1000</td>
<td>1000</td>
</tr>
</tbody>
</table>
Budget object = Top WBS element

### Example Two

<table>
<thead>
<tr>
<th>Object</th>
<th>Budget</th>
<th>Actual</th>
<th>Assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top WBS element</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>WBS element one</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Order</td>
<td>1000</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Budget object = WBS element one

### Example Three

<table>
<thead>
<tr>
<th>Object</th>
<th>Budget</th>
<th>Actual</th>
<th>Assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top WBS element</td>
<td>1000</td>
<td>1000</td>
<td></td>
</tr>
<tr>
<td>WBS element</td>
<td>1000</td>
<td>1000</td>
<td></td>
</tr>
<tr>
<td>Order</td>
<td></td>
<td>1000</td>
<td>1000</td>
</tr>
</tbody>
</table>

Budget object = WBS element one

### Determining The Processor

The processor is located using the standard role stored in Customizing for the scenario. If you did not store a standard role, the budget manager is informed as the processor. You can also enter a person as a processor.
Form For The Approving Manager Or Processor

The object that the applicant specified is displayed in the initial screen. The approving manager can go from each budget report for the budget object to the budget previously allocated. In addition, the manager can, if required, decide which object is to receive budget there. In WBS elements, the report automatically contains the corresponding project.

For WBS elements, the processor decides whether to make a budget supplement or to release the budget.

Budget Allocation With Hierarchy
The initial screen for budget allocation with hierarchy automatically contains the budget object. For WBS elements, the initial screen for budget allocation with hierarchy automatically contains the entire project.

Budget Allocation Without Hierarchy
The initial screen for budget allocation without hierarchy automatically contains the budget object. For WBS elements, the initial screen for budget allocation without hierarchy automatically contains the WBS element.

Budget Release (Projects Only)
For the budget release (access with hierarchy), the initial screen for the budget allocation with hierarchy automatically contains the entire project.
Task Processing

Purpose

Using the functions for task processing, you can change or display the tasks (Extern) in a notification independently of the notification itself. In this way, you can:

- Process tasks quickly and easily
- Execute tasks using the functions of the action box
- Access the information in the associated notification at any time

Process Flow

2. You process the tasks using one of the following options, depending on your job duties or method of working:
   - Worklist [Seite 246]
     You call up the worklist for tasks to determine whether tasks exist that you must process.
   - Workflow [Seite 247]
     You check your workflow inbox determine whether tasks exist that you must process.
   - Functions for Task Processing [Extern]
     If you want to process a specific task in a specific notification, use the transactions for processing or displaying a task.

3. After you have selected and executed one of the above options, you process a task by either:
   - Forwarding the task to another person, if you cannot process the task yourself
   - Carrying out the instructions specified in the task
   - Documenting the information for a task that has just been executed; for example, as a task long text or via a follow-up function in the action box (internal remark)
   - Setting the status of the task to "completed," once you have carried out the instructions specified in the task
   - Executing additional follow-up functions in the action box, if additional tasks need to be implemented

Result

Once you have processed and completed a task, you can complete the notification (provided there are no other tasks in the notification that need to be processed).
Processing Tasks Using Worklist

**Use**

Using the worklist for tasks, you can select notification tasks on the basis of different criteria and process them. You can select the tasks as follows:

- You select the tasks using the *My worklist* function. The system then displays the following tasks for further selection and processing:
  - All outstanding tasks to be processed by you as the "person responsible"
  - All tasks to be processed by you as a <Partner function>
  - All tasks you created
  - All tasks you completed
- You select the tasks using the *General selection* function. The system then displays all tasks for further selection and processing. Make sure the preset selection criteria contain the values you want (for example, selection period, outstanding tasks only).

**Prerequisites**

If you use the *General selection* function and you want to process tasks for which you are not responsible or which you did not create, you must have the corresponding authorization.

**Activities**

You choose *Logistics* → *Central functions* → *Notification* → *Worklist* → *Tasks* to call up the worklist for tasks.

You enter the required data and choose *Execute*.

**See also:**

*Select and Process Tasks Using the Worklist* [Extern]
Processing Tasks Using Workflow

Use

If a task is created in a notification or if the person responsible for a task is changed, the system can automatically notify the person or department responsible via the SAP Business Workflow that a task needs to be processed.

You receive the information about the task that needs to be processed as a work item in your inbox (Business Workplace). Your inbox provides an overview of all tasks that you are responsible for processing. You can begin processing the work item directly from your business workplace.

Integration

You can access your business workplace by choosing Office → Workplace from the SAP menu. Then choose Inbox → Workflow to display any work items that may be present.

Prerequisites

The required system settings to activate the SAP Business Workflow have been made.

Activities

If there is a work item in your inbox, proceed as follows to begin processing the work item:

- You double click the work item to display a description of the task to be executed.
- You choose Execute to process the work item. The system calls up the transaction to process the task.
Document Flow

Use
You can use this function to display the document flow for a notification as a list or network graphic. The document flow allows you to identify:

- Preceding documents (documents from which the current notification originated)
- Subsequent documents (documents that originated from the current notification)
- "To-and-from" references between documents

Each document contains the following information:
- Document number
- Document number
- Additional data (if available)
- Logical system (if any of the other documents was created in a logical system other than the one in which the original notification was created)

You can also display the detailed information for each document.

Integration
The document flow is integrated in the following processes:

- Materials Management (MM)
- Production Planning and Control (PP)
- Sales and Distribution (SD)
- Customer Service (CS)
- Plant Maintenance (PM)
- Financials (FI)
- Controlling (CO)
- Project System (PS)

Features
The document flow, for example, can display the following objects (among others):

- Quality notification
- Service notification
- Maintenance notification
- General notification
- Claim
- Service order
• Sales order
• Production order
• Run schedule header
• Goods movement
• Purchase order
• Inspection lot
Displaying the Document Flow for a Notification

**Procedure**

1. Call up a notification in the create or change mode.

2. Choose one of the following menu paths, depending on whether you want to display the document flow as a list or graphic:
   - *Extras* → *Notification documents* → *Document flow* → *List*
   - *Extras* → *Notification documents* → *Document flow* → *Graphic*

   ![](image)

   The notifications that reference other subsequent documents in the list display are labeled with a *(Ref.)* designation.

3. If you displayed the document flow as a graphic, select a document and choose *Goto* → *Display document*.

   The detailed information for the selected document is displayed.
Status Query

During the whole runtime of an internal service request [Extern], you can obtain the current status.

See also:
- Status Management For Notifications [Extern]
- Display Status Information [Extern]
- Assigning System Statuses [Extern]
- Assigning And Changing User Statuses [Extern]
- Status Management For Tasks [Extern]
Availability Control

Use
These components enable you to monitor and control project costs. The project manager can use availability control to call up an overview of the assigned funds and see which type they are. Availability control enables you to control costs actively by issuing warnings and error messages when costs are incurred.

Implementation Considerations
The component is fully integrated with upstream and downstream components, for example:

- Controlling (CO)
- Financial Accounting (FI)
- Production Planning and Control (PP)
- Materials Management (MM)

Features
Availability control monitors funds using budget allocation.

- **Passive Availability Control**
  Overview of funds, their assignment and type

- **Active Availability Control**
  Prevents the assignment of too many funds.

  If you enter business transactions that create costs on a Controlling element [Extern] (for example, posting of an invoice), the system checks whether there is still sufficient budget available for the controlling element. For projects, you can also use releases as an alternative to the current budget. It uses the tolerance limits specified in Customizing for the check.

- For internal orders, see Controlling -> Internal Orders -> Budgeting and Availability Control -> Define Tolerance Limits for Availability Control [Extern].
- For projects, see Project System -> Costs -> Budget -> Define Tolerance Limits [Extern].
  For more information, see Defining Tolerance Limits [Seite 258].

Availability control checks the current distributable budget (or release) against the assigned value.

- **Distributable Budget**
  The budget from the controlling element that is not yet distributed to other, lower-level WBS elements.

- **Assigned Value**
  Costs incurred by a Controlling element.
  For more information on the calculation of assigned values, see

  Assigned Values in Internal Orders [Seite 254].
- Assigned Values in Projects [Seite 255].

Warning! Budget Excess!!!
Assigned Value In Internal Orders

The assigned value for internal orders consists of:

- Actual costs
- Statistical actual costs
- Commitment
- Debit by settlement to an internal order
- Credit by settlement to a budget controlled object (such as an internal order, or a WBS element)

⚠️ The following is **not** used for calculation of the assigned value:

- Actual costs with a cost element that was defined as exempt in Customizing for availability control. For more information, see the implementation guide (IMG) under Controlling → Internal Orders → Budgeting and Availability Control → Specify Exempt Cost Elements For Availability Control [Extern].

- Actual costs that were incurred by a business transaction that does not belong to the allowed transactions groups [Seite 261] in the availability control. This can happen if you have not ++ maintained the tolerance limits [Seite 258] in customizing. For more information, see the implementation guide (IMG) under Controlling → Internal Orders → Budgeting and Availability Control → Specify Tolerance Limits For Availability Control [Extern].

- Credits by settlement to an object that is **not** budget controlled (such as a cost center)

- Revenues
Assigned Value In Projects

The *assigned value* for projects is calculated from:

- Actual costs on the budget carrying WBS element
- Statistical actual costs on the budget carrying WBS element
- Actual costs from lower-level WBS elements, if these do not have any budget
- Statistical actual costs from lower-level WBS elements, if these do not have any budget
- Commitments on the budget carrying WBS element
- Commitments from lower-level WBS elements, if these do **not** have any budget.
- Maximum from plan and actual costs + commitments from assigned networks or orders.

For more information, see the implementation guide (IMG) under *Project System → Costs → Plan Costs → Specify Order Value Update Of Orders For Projects [Extern]*.

- Debit by settlement to WBS element
- Credit by settlement to a budget controlled object (such as an internal order, or WBS element)

The following is **not** relevant for calculation of the assigned value:

- Actual costs with a cost element that was defined in Customizing for availability control as an exempt cost element.
  For more information, see the implementation guide (IMG) under *Project System → Cost → Budget → Specify Cost Elements [Extern]*.

- Actual costs that were incurred by a business transaction that does not belong to the valid transaction groups [Seite 261] in availability control.
  This situation cannot occur if you did **not** maintain the tolerance limits [Seite 258] as a transaction group in Customizing.
  For more information, see the implementation guide (IMG) under *Project System → Costs → Budget → Specify Tolerance Limits [Extern]*.

- Credits by settlement to an object that is **not** budget controlled (such as a cost center)
- Revenues
Entering Settings For Availability Control

Mandatory Customizing Settings

1. In the budget profile, you store all the values needed for the budgeting process, by choosing the following in Customizing:

   - For projects Project System → Costs → Budget → Maintain Budget Profile [Extern].
   - For internal orders Controlling → Internal Orders → Budgeting and Availability Control → Maintain Budget Profile [Extern].
     For more information, see Basic Settings For Availability Control In The Budget Profile [Seite 257].

2. The tolerance limits that availability control uses for checks are stored for each transaction group for a budget profile, by choosing the following in Customizing:

   - For internal orders Controlling → Internal Orders → Budgeting and Availability Control → Specify Tolerance Levels For Availability Control [Extern].
   - For projects Project System → Costs → Budget → Specify Tolerance Limits [Extern].
     For more information, see Specifying Tolerance Limits [Seite 258].

Optional Customizing Settings

Exempt cost elements are cost elements that are not included in availability control (such as interest or credit notes for activities that were provided in a joint venture of a project for a partner project).

Choose the following in Customizing

   - For projects Project System → Costs → Budget → Specify Exempt Cost Elements [Extern]
   - For internal orders Controlling → Internal Orders → Budgeting and Availability Control → Specify Exempt Cost Elements For Availability Control [Extern].
Basic Settings for Availability Control in Budget Profile

Use
In the budget profile you determine whether/how availability control is to be activated and which budget values should be checked by availability control.

Features
You control whether/how availability control should be activated using activation types (0=not activated, 1=Automatic Activation with Budget Allocation [Seite 264], 2=Backround Activation [Seite 265]).

More information is available in Activating Availability Control [Seite 263].

For projects, availability control can check against the current budget or the released budget. Furthermore, you can decide whether availability control is carried out on the basis of year-independent (= total values) or year-dependent values. Depending on the settings of the budget profile, the availability control checks against the

- actual overall budget
- actual annual budget
- released overall budget (only for projects)
- released annual budget (only for projects)

The current budget is made up of

- Original Budget [Seite 199]
- Supplement [Seite 218]
- Return [Seite 222]
- Repostings from the Budget [Seite 226]
Specifying Tolerance Limits

**Use**

When certain business transactions are entered that create costs on the corresponding Controlling-Element [Extern], the system checks whether the available budget or available released budget is sufficient. It uses the tolerance limits specified in Customizing for this check.

For more information on specifying tolerance limits, see the implementation guide (IMG).

- For internal orders, see Controlling → Internal Orders → Budgeting and Availability Control → Define Tolerance Limits for Availability Control [Extern].
- For projects, see Project System → Costs → Budget → Define Tolerance Limits [Extern].

**Features**

You can specify tolerance limits for each controlling area, budget profile, and different Business Transaction Group [Seite 261].

You can specify different tolerance levels with three possible options (issue with a warning [1], a warning and a mail to the project manager [2], or an error message [3]).

You can define the tolerance limits as the usage level, and / or as an absolute variance from the current budget or the release.

**Usage Level**

This is the relationship between assigned funds and the budget, displayed as a *percentage*.

**Absolute Variance**

This is the difference between assigned funds and budget, displayed in an *absolute amount*.

SAP recommends that you *either* specify a percentage usage rate, *or* an absolute variance for tolerance limits in availability control.

If you defined a percentage usage rate and an absolute variance as a tolerance limit for a budget profile and a transaction group, the action you specified is triggered if the assignments exceed one of the two tolerance limits.

**Example**

Availability control of a current overall budget (EUR 100,000)

<table>
<thead>
<tr>
<th>Business Transaction Group</th>
<th>Action</th>
<th>Percentage Usage Level</th>
<th>Absolute Variance</th>
<th>System Reaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>++</td>
<td>1</td>
<td>80 %</td>
<td></td>
<td>For all business transactions, a warning is issued once EUR 80,000 assigned value reached.</td>
</tr>
</tbody>
</table>
### Specifying Tolerance Limits

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>++</td>
<td>2</td>
<td>1000</td>
<td>For all business transactions, a warning is issued and a mail is sent to project manager once assigned value of EUR 101,000 is reached.</td>
</tr>
<tr>
<td>01</td>
<td>3</td>
<td>110%</td>
<td>Purchase orders are prevented by error message once the assigned value of EUR 110,000 has been reached.</td>
</tr>
</tbody>
</table>

**See also:**

*Set up Availability Control [Seite 256]*
Availability Control Actions

When the tolerance limit is exceeded, the system does one of the following:

**Warning (Action One)**

The system informs you when the tolerance limit is exceeded. You can still execute the business transaction that triggered this (such as posting an FI document).

**Warning and Mail to The Project Manager (Action Two)**

The system sends the project manager a message containing the WBS element on which the budget was exceeded, and the business transaction triggered the excess. The amount by which the budget was exceeded and the document number are also specified.

If no manager name is stored in the master record for the project or the WBS element, the system issues an error message instead of a warning and a mail.

For orders, you maintain the budget manager in Customizing, under **Controlling → Internal Orders → Budgeting and Availability Control → Maintain Budget Manager [Extern]**.

**Warning (Action Three)**

The system issues an error message if an action leads to the specified tolerance limit being exceeded. The system rejects the business transaction (such as a purchase order) that causes the budget to be exceeded.
### Transaction Group

All business transactions are assigned to a transaction group in availability control. You can store an action for the system to execute for a business transaction that triggers too many allotted funds. For more information, see Availability Control Actions [Seite 263].

For the following transaction groups, you can specify tolerance limits for each budget profile, for the different actions. To do so, go to Customizing and choose:

- For internal orders, Controlling → Internal Orders → Budgeting and Availability Control → Specify Tolerance Limits For Availability Control [Extern].
- For projects, Project System → Costs → Budget → Specify Tolerance Limits [Extern].
- **All transaction groups**
  This general transaction group is designed to facilitate your entries, and is useful if you do not want to define separate tolerance limits for each transaction group. In addition to a tolerance limit defined for **All transaction groups**, you can specify a limit for **one** transaction group. This limit takes precedence over the "generally" valid tolerance limit. The tolerance limit and action specified for **all transaction groups** is thus ignored if there are additional entries for a special transaction group.

- **Purchase requisition**
- **Purchase order**
- **Orders for the project**
  When planning on an order for a project, the system checks the change to the rest of the plan for the order. It also checks the assignment and detachment of an order/network that already has assigned values, using this transaction group.

  ![Lightbulb](image)

  Postings to orders for the project are checked in each transaction group, for example, the purchase order from an order for the project is checked in the **Purchase order** transaction group.

- **Goods withdrawal**
- **FI Document**
  Suitable for postings in FI
- **Controlling document**
  Suitable for postings in cost accounting.
- **Budgeting**
  During the life cycle of a project, the budget may be reduced, although allotted funds have already arisen on the project. You need this transaction group to enable the availability control to include subsequent budget changes.
  If this means that the allotted funds exceed a tolerance limit in availability control, the system
tells you to see the error log when you make checks or save. The log contains the warnings or error messages that were issued as a result of the tolerance limit being exceeded.

- *Funds reservation* (manual commitment)
- *Fixed prices in the project*
Activating Availability Control

Use
In the budget profile, you use the *Activation type* to specify whether and/or how the availability control is to be activated.

Features
There are three different types of activation:

- $0 = $Cannot be activated $
- $1 = $Automatic activation when budget is allocated [Seite 264]
- $2 = $Background activation [Seite 265]

If you selected background activation, you can activate the availability control online [Seite 266] for a particular project.

Activities
When availability control is activated, the system does the following:

- It determines the WBS elements that carry budget - these are controlling elements.

- It determines the corresponding assigned funds. It checks the assigned funds against the controlling element budgets. The assigned funds can be on the budget-carrying WBS element, the lower-level WBS elements and their assigned project orders.

After activation, each posting to the project is checked by the availability control.

As availability control affects system performance, you should activate it in the background for projects with less detail, only when you think that the budget may be exceeded.
Activating Availability Control with Budget Allocation

Use

In the budget profile, you selected *Activation type 1* for availability control. This means that the availability control is automatically activated when you make entries (or release budget, if this is to be checked).

Availability control is always defined for a particular budget profile, and you need to define a tolerance limit for at least one business transaction group for the budget profile. Once you enter a budget for a project with the corresponding budget profile, the availability control is activated.

💡

For technical reasons, availability control cannot be activated automatically for projects (assigned to an investment program) when budget is allocated from the investment program item to the top WBS element. Activation follows automatically during the next background activation run.
Activating Availability Control In The Background

Prerequisites
In the budget profile, you selected Activation type two for availability control (background activation).

During background activation of availability control, the system checks whether the limit of the usage level stored in the budget profile has been reached or not. If it has been exceeded, then availability control is activated.

You can start the background run for availability control automatically and on a regular basis.

In The Project System (Same Procedure For Internal Orders)
In the Project System, select the projects for which you want to start the background run.

1. Choose Logistics or Accounting → Project system → Controlling → Budgeting → Tools → Activate availability control
2. For internal orders, choose Accounting → Controlling → Internal orders → Budgeting → Availability control → Activate.
3. If required, enter the controlling area and the database profile. The Background Activation of Availability Control For Projects appears.
4. Enter the required data.

💡 During background activation of availability control, the system creates a log for the objects for which you activated availability control. If you set the indicator for a complete log, all the other projects in the variant (object selection) are displayed, for which you did not activate availability control.

4. To save the project selection as a variant, choose Goto → Variants → Save as variant.... The ABAP: Save as variant screen appears.
2. Enter a variant name and text (meaning) and set the indicator For Background processing only.
3. Save the variant using ➔. The initial screen appears again, and the system informs you that the variant was saved.

Job Definition
You can start the background run for availability control on a regular basis by using a job definition.
Activating Availability Control Online

In the budget profile you selected activation type two for availability control (background activation). You can now activate availability control in advance for one particular project online.

You can therefore activate availability control for a project before the usage level has been reached for background processing, or before the next background run.

In The Project System (Same Procedure For Internal Orders)

You activate availability control online as follows:

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change.
   For internal orders, choose Accounting → Controlling → Internal orders → Budgeting → Original budget → Change.
   The Change Original Budget: Initial Screen appears.

2. Enter the required data and choose Original budget.

   The system confirms activation with a message.

   Availability control is activated only when you next Save or make a Check. After activation, each posting that follows is checked for availability.

4. The system determines the assigned values that you can compare with the budget values by choosing Views → Assigned in CO area currency.

If you now want to reduce the budget (for example), and the allotted funds thus exceed the tolerance limit in the availability control, you are notified when you check or save the budget.
Checking Whether Availability Control is Active

You can see whether availability control is active by looking at the system status of the potential budget object, or the display and change mode in the budgeting function (original budget, release, and so on).

Availability control is active in the following cases:

- The Availability control activated system status is set for the WBS element budget object.

   1. Choose Logistics or Accounting → Project System → Basic data → Project → Special maintenance functions → Structure planning → Change project.

      The Change Project: WBS Element Overview screen appears.

   2. The system displays the system status of the WBS elements via basic data.

In The Project System (Same as for Internal Orders)

- The display and change sessions in the budgeting function contain a corresponding message.

   1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change or Display.

      For internal orders, choose Accounting → Controlling → Internal orders → Budgeting → Original budget → Change or Display.

   2. Enter the necessary data and choose Continue.

   3. Choose Extras → Availability control → Information.

      You can now see whether the system issued a corresponding message.

- The Assigned column is visible in the budgeting transactions.

   1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change or display.

   2. Enter the necessary data and choose Continue.

   - For an overview of the assigned amounts on the WBS-Element overview, choose Extras → Availability control → Reference.

      1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change or display.

      2. Enter the necessary data and choose Continue.

      3. Choose WBS Element overview → Extras → Availability control → Reference.

      As well as the assigned and the distributable budget, the system displays the element with budget (which is on a higher level in the project structure) in the Controlling element column for each WBS element without budget. The system posts assigned funds from the WBS element and all lower-level WBS elements (that do not have any budget) to the controlling element.

      The current assigned and distributable values are displayed after the budget is checked.
Deactivating Availability Control

You can deactivate activated availability control for one or more projects. This is useful, if for example:

- Availability control was activated by mistake
- Availability control was already active for the previous year for annual budgets, but activation for the fiscal year just started is not yet required.

Procedure

In The Project System (Same For Internal Orders)

1. Choose Logistics or Accounting → Project system → Controlling → Budgeting → Tools → Deactivate availability control.
   For internal orders, choose Accounting → Controlling → Internal orders → Budgeting → Availability control → Deactivate.

   If you choose activation type one, the system reactivates availability control for the next budget.

   You can ensure long-term activation with activation type zero only.
Excluding WBS Elements From Availability Control

A project and its WBS elements go through different stages, or statuses. The status determines whether you can use certain business transactions or not. You can exclude a WBS element with budget and the lower-level account assignment elements from availability control. You do this by activating a user status for the controlling element, for which the availability control business transaction is not allowed.

If a WBS element has this status, then the assigned funds are not included in the availability control, in other words, no action is triggered. However, the assigned values are still updated on the controlling element.

For more information on how to create a user status, see the SAP Library under Financials → PS-Project System → Structures → Status Management [Extern].
Referencing Availability Control In Projects

Use
You can obtain an overview of the allotted funds in the display and change modes of the budgeting function.

Prerequisites
You have activated availability control.

Procedure
Choose Accounting → Project System → Controlling → Budgeting → Original budget → Change or Display → Original budget → Extras → Availability control → Reference.

Result
As well as the assigned and distributable (=budget - assigned) budget, the system displays (under controlling element) the budget carrying element that is on the next level up from a WBS element that does not have any budget in the project structure. On this controlling element, all postings (that were made on WBS elements with no budget) are cumulated as allotted funds.

The current assigned and distributable values are displayed after checks are made.
Reconstructing Availability Control

Reconstructing Availability Control
In Customizing, you can start reconstruction of the assigned values. You need to do so if:

- You are introducing a new release
- You have changed the settings for availability control in the budget profile
- You have changed the tolerance limits for availability control
- You have redefined exempt cost elements
- You have changed the settings for updating order values on orders for the project
- You suspect that there may be data inconsistencies, for example in objects from older releases, or after corrections were installed for budgeting / availability control.

When you execute this function, the system redetermines the assigned values for the selected projects. It also creates references to the budget carrying objects, and transfers the new settings for the budget profile to the budget table.
# Notes for Problems with Availability Control

<table>
<thead>
<tr>
<th>Problem</th>
<th>Symptom</th>
<th>Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Availability control is not reacting, despite correct settings and activation.</td>
<td></td>
<td></td>
<td>Check to see if the corresponding entries are in the control tables TRWCI and TRWCA (see below: Entries in TRWCI and TRWCA).</td>
</tr>
<tr>
<td><strong>Activation type 1</strong> (activation with budget allocation) was selected for activation of availability control. Availability control is to be executed on a project, although the project has not yet been budgeted.</td>
<td></td>
<td></td>
<td>Post an original budget to the top WBS element. Then execute a return for the same amount. The current budget is zero.</td>
</tr>
<tr>
<td>Availability control is now active.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Availability control with <strong>action two</strong> (mail to project manager) does not send a mail when the assigned values are exceeded.</td>
<td>An error message appears.</td>
<td>No manager name has been entered in the WBS element, or in the project definition.</td>
<td>Enter the project manager name in Customizing, under Project System → Structures → Operative Structures → Work Breakdown Structure → Create Manager for WBS Element. [Extern]</td>
</tr>
<tr>
<td></td>
<td>A warning appears.</td>
<td>In Customizing for the project manager, the <strong>user</strong> has not been entered correctly.</td>
<td>Enter the <strong>user</strong> name of the project manager in Customizing, under Project System → Structures → Operative Structures → Work Breakdown Structure → Create Manager for WBS Element. [Extern]</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Note that you need to enter the name in upper case letters.</td>
</tr>
</tbody>
</table>
Notes for Problems with Availability Control

<table>
<thead>
<tr>
<th>Neither a warning nor an error message appears.</th>
<th>Availability control is not active, or the tolerance limits have not yet been exceeded.</th>
<th>Activate availability control or maintain the tolerance limit accordingly. For more information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>When you post a goods receipt or enter an activity, this does not trigger an availability control action, although the tolerance limit was exceeded.</td>
<td>The system does not check the assigned values during goods receipt.</td>
<td>Check whether you can solve the problem by using one of the solutions suggested below (see below: Posting a goods receipt or entering an activity).</td>
</tr>
<tr>
<td>For technical program reasons, only the assigned value is updated when you post a goods receipt, or enter an activity.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Entries in TRWCI and TRWCA

The program control table TRWCI (in which the installed components are stored) must contain the COFC entry (Controlling Funds Control).

the TRWCA table contains the same components (fiscal year-related) as the TRWCI table. You can use this table to deactivate specific components for certain fiscal years. In the TRWCA table, the COFC component should be active until the year 2050.

Posting a Goods Receipt or Entering an Activity

- Use the commitment values from the purchase order for the budget check.
- Check whether tolerance limits were maintained for the *purchase order* transaction group. Before the purchase order, activate availability control.
- Check whether you can work with unvaluated goods receipts. In this case, the system updates the *assigned values* only once the goods receipt has taken place. When goods are received, the system checks the *assigned values* and if necessary, triggers the corresponding actions.
- Do not allow any more account assignment changes for the goods receipt posting.
Funds Commitment (Cost Centers, Internal Orders, Projects)

Use
You use this function to enter anticipated costs or revenues where you do not yet know which business transaction will later cause them (purchase order, material reservation and so on). In this way, you can reserve parts of the budget in advance.

You can assign funds commitment to internal orders, cost centers, or projects.

Integration
A funds commitment that is assigned to a WBS element, a network, or an internal order is part of the active budget availability control. The funds commitment checks whether the available budget is still sufficient. The system includes defined tolerance limits below and above the budget.

For more information, see Availability Control [Seite 252].

The system displays the funds commitment as a commitment in the information system for the account assignment objects. For more information, see Commitments Management [Exterm].

You can archive the documents for funds commitment. For more information on archiving, see: CA - Archiving Application Data [Exterm].

Prerequisites
To process the funds commitment, you need the corresponding authorizations for each document type from the K_KMOB_DCT authorization object.

Features
Funds commitment includes the following single activities:

- Creating Funds Commitments [Seite 277]
  
  You create a funds commitment as a marked document, which contains:
  
  - Data in the document header, that is valid for the entire document
  - At least one funds commitment item that contains the actual data on the funds commitment.

- Changing Funds Commitments [Seite 279]
  
  You can change the funds commitment as well as enter more items for funds commitment.

- Reducing Funds Commitments [Seite 280]
  
  When you manually reduce a funds commitment, you enter the reduction amount for the funds commitment item. You use the open amount to determine the reduction amount. The reduction amount is always the difference between the funds commitment amount, and the total of the partial amounts already reduced. The reduction amount must not be greater than the open amount.

  You can:
Funds Commitment (Cost Centers, Internal Orders, Projects)

- Reduce **one** funds commitment
  You can reduce the items for **one** marked document by specifying the document number for a funds commitment.

- Reduce **more than one** funds commitment
  You can reduce the items in marked documents for **more than one** funds commitment when you are in a list.

- **Calling Up Reduction History [Extern]**
  
  **Reduction reference**
  For information purposes, you can make reference to a follow-up document (such as, order, purchase order, FI document) through which the actual costs will be or have been incurred.

  - To enter a reduction reference for **reduction documents already entered**, choose **Edit → Reduction references** in the reduction history.
  
  - To enter reduction references for the **current reduction document**, choose **Extras → Reduction references** from the list screen or detail screen.

  **Reversing reduction references**
  You can reverse individual reduction postings. Place the cursor on a reduction document in the reduction history, and choose **Reverse**. The system indicates the reduction document in the STO column as reversed.

- **Evaluations Of Funds Commitment Documents In The Information System [Extern]**
Creating Funds Commitments

Procedure

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Actual postings → Funds commitment → Create.
   - Accounting → Controlling → Internal orders → Actual postings → Funds commitment → Create.
   - Accounting → Controlling → Project System → Actual postings → Funds commitment → Create.

The Create Funds Commitments screen appears.

2. Enter data as required.
   - Document type
     The document type categorizes your documents, and controls whether you can enter negative values for funds commitment (to display credits for example). See also: Document Type / Number Assignment [Extern])
   - Document date (issue date of the original document)
     The system defaults today's date, but you can overwrite this if required.
   - Document number
     If you specified an external number assignment for the funds commitment, enter the required document number here. You can define the number interval for the internal or external number assignment in the implementation guide for each application.

3. You have the following options:
   a. If you want to enter more than one funds commitment item, then choose Fast entry. You can specify a reference to another funds commitment, as well as account assignments and an amount for each funds commitment item.
   b. If you want to enter a funds commitment item, then choose Detail screen. You can use all functions that are available for processing a funds commitment item.

4. Enter data as required.
   - Order, WBS element or cost center.
     The account assignment objects (order and WBS element) must have a status that allows the funds commitment business transaction. For more information on status management, see General SAP Status Management [Seite 60].

You need to specify another true account assignment object (such as a cost center) for statistical internal orders or WBS elements. The system does not debit these with costs, but records the values for information purposes only.
Creating Funds Commitments

- On the Detail screen enter the following information if required:
  - Cost center
    The cost center account assignment object does not have status management.
  - Material or vendor.
    If you know which material or which vendor is going to require the funds commitment, you can specify this. The system checks whether material or the vendor exist in the system.
  - Quantity and price
    As an alternative to a funds commitment amount, you can enter a quantity and a unit price.

5. Save your entries with [ ].

Results

For internal number assignment, the system determines the document number when you save. The document number is used for posting the funds commitment.

During funds commitment, the system updates a cost commitment on the account assignment object. This update is independent of commitments management activation in Customizing for

- Your controlling area
- Your order type
- Your cost center

A funds commitment that is assigned to a WBS element, a network, or an internal order is part of the active budget availability control. The funds commitment checks whether the available budget is still sufficient. The system includes defined tolerance limits below and above the budget.

If a specified tolerance limit is exceeded by a funds commitment, the system can trigger different actions when you save:

- Warning
- Mail to the order or project manager
- Error message

For more information on availability control, see: Availability Control [Seite 252].
Changing Funds Commitments

1. Choose one of the following:
   - **Accounting** → **Controlling** → **Cost Center Accounting** → **Actual postings** → **Funds commitment** → **Change**.
   - **Accounting** → **Controlling** → **Internal orders** → **Actual postings** → **Funds commitment** → **Change**.
   - **Logistics or Accounting** → **Project System** → **Controlling** → **Actual postings** → **Funds commitment** → **Change**.

   The *Change Funds Commitment* screen appears.

2. Enter the necessary data and choose **Fast entry** or **Detail screen**

   ![lightbulb]

   You can switch between the fast entry and the detail screen at any time.

   In the detail screen, you can switch between the document items using ☐️ and ☐️.

3. Change the document item, or create a new one.

   Once a funds commitment item is completed with the reduction of this document, select **Completed** in the detail screen. The system displays the completed funds commitment item and then reduces the funds commitment completely. If the system is to reconstruct the funds commitment, undo the selection.
Reducing Funds Commitments

Reducing Funds Commitments Manually

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Actual postings → Funds commitment → Reduce.
   - Accounting → Controlling → Internal orders → Actual postings → Funds commitment → Reduce.
   - Logistics or Accounting → Project System → Controlling → Actual postings → Funds commitment → Reduce.
   The Reduce Funds Commitments Manually screen appears.

2. Enter the necessary data and choose 📊.

3. If the system is to reduce the funds commitment completely, select the completion indicator for this funds commitment item in the detail screen. You can also enter a reduction reference.

4. To reduce the funds commitment by amount, enter the reduction amount and if required, a descriptive short text in the detail screen, under Reduction information.

5. If you want to complete a funds commitment item with a reduction posting, select the Item completed indicator.

6. If you want to reduce commitments for more funds commitment items, choose 📊.

7. Save the funds commitment reduction with 📊.

Reduce Funds Commitments with Invoices

Prerequisites

In Customizing under Financial Accounting → Basic Settings for Financial Accounting → Document → Line Item → Control → Maintain Field Status Variants [Extern] the Earmarked funds field is selected as a mandatory or an optional entry.

Procedure

1. When you post a vendor invoice in the account assignment block, enter the document number of a funds commitment in the Earmarked funds field.

Results

To obtain an overview of reduced funds commitments, choose Environment → Usage history. The system displays a list of the reduction amounts with the following information:

- Document amount
- Number, amounts and data from the reduction postings
- Open amount
Evaluating Funds Commitment Documents in The Information System

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Information system → Reports for Cost Center Accounting → Line items → Cost centers: Commitment line items
   - Accounting → Controlling → Internal orders → Information system → Reports for internal orders → Line items → Orders: Commitment line items
   - Logistics or Accounting → Controlling → Project System → Information System → Controlling → Actual postings → Commitments.

   The Display Line Item Commitments for Projects screen appears.

2. Enter the necessary data and choose More selection criteria.
   The Define More Selection Criteria screen appears.


4. From the overview tree, choose Documents/Objects → Reference document category.
   In the right-hand screen area, the system displays the Dynamic selections group box.

5. Enter the reference document category MIVO and save your entry with .

6. The Display Commitment Line Items for Projects screen appears.

7. Use to run the report.

For more information, see Commitments Management [Extern].

Results

You receive a list of all fund commitment documents that fulfill the specified selection conditions.
Manual Actual Postings in Internal Orders

Purpose

You use actual postings to enter actual costs that enable up-to-date monitoring of the costs incurred by the organization. In this way, you can identify any variances at an early stage and correct them.

Manual actual postings are the daily transaction-based postings of primary and secondary costs. Actual postings create totals records and line items. A **totals record** summarizes all the costs posted to the internal order under a particular cost element. **Line items** consist of document rows created during posting, and document the individual posting transaction.

Features

Manual actual postings consist of:

- **Postings in Financial Accounting:**
  
  You can assign postings of primary costs directly to an internal order within Financial Accounting (for example, for external services and deliveries). The same applies to goods movements, if you are not using the Materials Management component (MM).

- **Goods Movements in Materials Management:**
  
  In the MM component, you can make the following statistical postings to internal orders:
  
  - Purchase requisitions
  - Purchase orders

  When you create a purchase order that is statistically posted to an internal order, a commitment is created on the order. The commitment is converted to actual costs when the goods are received. For more information see the **SAP Library**, under **Financials -> Controlling -> Internal Orders -> CO - Commitments Management [Extern]**.

  - Goods receipts
  - Reservations
  - Goods issues

  A goods issue that refers to a material reservation in which an internal order number is stored, automatically leads to the posting of actual costs on the internal order.

  For more information on purchase requisitions and purchase orders, see the **SAP Library**, under **Logistics -> MM Materials Management -> MM - Purchasing [Extern]**.

  For more information on goods receipt, reservations and goods issue, see the **SAP Library**, under **Logistics -> MM Materials Management -> MM - Inventory Management [Extern]**.

- **Internal Activity Allocations in Cost Accounting**

  For more information on internal activity allocations, see **Event-Based and Periodic Actual Postings [Seite 286]**.
Constraints
To be able to post actual costs on an internal order, this must be allowed by the relevant business transaction.

For more information, see Status Management for Internal Orders [Seite 58].
Postings From Cost Accounting

Use

Repostings of Primary Costs and Revenues

Repostings enable you to correct posting errors from primary systems. This means that you can repost primary costs (that were assigned to a certain internal order in Financial Accounting) by cost element to other internal orders or cost centers, thus improving the original assignment.

An incorrect internal order was entered for a material purchase order. As the posting for the goods receipt refers to the purchase order, the system automatically debits the costs to the wrong internal order.

You can use reposting to transfer these costs to the correct internal order, or to a cost center. The original cost element remains unchanged.

See the SAP Library for more information on reposting costs and revenues.

Direct Internal Activity Allocation

This enables you to directly post internal activities supplied by cost centers to the internal order that received the activity. The consumption quantity is valued using the plan price for the cost center. The internal order is debited with an allocation cost element.

Creating Statistical Key Figures

Statistical key figures on an internal order are for information purposes only.

On a trade fair order, you post all costs incurred for a trade fair. For information purposes, you then post statistical figures for the number of visitors at your booth, the number of requests for further appointments, or the number of orders resulting from the trade fair, and any further appointments.

Funds Commitments

This function enables you to enter costs, which you know will definitely occur, but you do not yet know which transaction will cause them (for example, purchase order, material reservations, and so on).

You can thus reserve parts of the order budget at an early stage.

For more information, see Funds Commitment [Seite 275].
Time Sheets

Use

The time sheet lets you create uniform, cross-component personal time records. It unifies the existing personal time keeping functionalities from the individual components. The time sheet can provide you with information about the working time used for internal activity allocation in Controlling (CO).

For more information, see the SAP Library under CA Cross-Application Components → Time Sheets [Extern] and the Implementation Guide (IMG) under Cross-Application Components → Time Sheets [Extern].
Period-End Closing in Internal Orders

Purpose
In period-end closing, period-related business transactions are executed after the period end.

Features
The following belong to periodic actual postings:

- Revaluation at Actual Prices [Seite 383]
- Calculating Overhead [Seite 393]
- Periodic Reposting [Extern]
- Actual Template Allocation [Extern]
  
  For more information, see Template [Extern].

- Internal Order Settlement [Seite 400]
- Assessment and Distribution Methods
Schedule Manager (CA)

The extensive automation features of the Schedule Manager facilitate the definition, scheduling, execution, and review of tasks that are executed on a regular basis, such as period-end closing.

The Schedule Manager consists of four independent components:

- Flow Definition [Seite 323]
- Scheduler [Seite 298]
- Monitor [Seite 316]
- Worklist [Seite 343]
Variables in Schedule Manager

By defining variables in Schedule Manager, you can minimize the amount of work that is required to make the necessary value changes (for example, Period) for tasks in the task list.

For more information, see:

- Defining Global Variables for the Task List and Flow Definition
- Specifying Selection Variables in the Program Variants
- Specifying Selection Variables for Flow Definitions With Parallel Branches
Defining Global Variables for the Task List and Flow Definition

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables in the program variants.

Features

You can define selection variables for single programs that are included as tasks in the task plan, as well as for flow definitions.

You can specify global parameters for the task list, such as the company code or profit center.

In Schedule Manager, the same flow definitions (= workflows) can be run in parallel, such as for different plants. The definition of the global variables defined for the main workflow can also be used for the parallel branches.

Activities

You can display the currently defined selection variables. To do so, choose Extras → Settings → Selection variables. You can also define new selection variables. You can then choose these as selection variables in the variable attributes when creating variants for single programs.

For more information, see:

Defining Selection Variables [Seite 292]

Specifying Selection Variables in the Program Variants [Seite 293]

Specifying Selection Variables for Flow Definitions With Parallel Branches [Seite 329]
Defining Selection Variables

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables.

Prerequisites

You must assign a TVARV variable for the plant to each program that is to be run once for all plants.

Procedure

1. Call up the transaction STVARV (Display table TVARV: Selection variables).
2. Choose Change. You can create, change and delete new variables.
3. Define a parameter name for your variant.
4. Call up the transaction SM34.
5. Go to view cluster VSMANTVARV.
6. Specify the same parameter name for the variable as you did in transaction STVARV.

Changes to the global selection variables specified for the task list are transferred to all variables specified in tasks in the task list.

Result

You defined a global selection variable for Schedule Manager.

For more information, see:

Defining Selection Variables in the Program Variants [Seite 293]

Specifying Selection Variables for Flow Definitions With Parallel Branches [Seite 329]
Specifying Selection Variables in the Program Variants

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables in the program variants.

Prerequisites

You have defined the variables already. For more information, see Defining Selection Variables [Seite 292].

You are in flow definition [Extern] in Schedule Manager (Extras → Flow definition → Edit flow definition).

1. Choose a processing step in the navigation area.
   On the right of the screen, you see Flow definition: Task details.

2. Enter a new variant for this processing step and define a name for this new variant in the Variant field.

3. Choose Change variant.
   The Variant Maintenance screen appears. Program <program name>, variant <variant name>.

Procedure

4. Choose Attributes.

5. Make an entry in the Description field.

6. Now you want to specify variables for the period and fiscal year that you can then change once centrally for all programs and flow definitions that use those variables. To do this, under the heading Selection screen objects, select the column S in the lines Period and Fiscal year.

7. Choose Selection variables.

8. To choose selection criteria for the variables P_FROM (period) and P_GJAHYR (fiscal year), use the input help.
   ![Input help]
   You previously entered these variables in table TVARV.

9. Save your entries.
   The Variant Maintenance screen appears. Program <program name>, variant <variant name>.

Result

You can no longer make entries in the Period and Fiscal year fields. These fields are now always filled through the current entries in table TVARV.
Specifying Selection Variables in the Program Variants
Specifying Selection Variables for Flow Definitions With Parallel Branches

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables in the program variants.

You have five programs that must run with the same valuation for nine plants. That means that every program must run with a plant-specific variant for each plant. These variants differ only in their Plant specification.

As described below, you define global variables for fiscal year, period and plant. Create variants for the five programs and define the global variants that you created previously. Finally define a flow definition (A) for the five programs. Define a flow definition (B) with nine parallel branches (for the plants). Include the flow definition A in each of these branches. A dialog box appears that displays the three global variables (fiscal year, period, plant). Enter a value for the variable Plant and flag the entry as to be saved. The dialog box reappears when you plan flow definition B in the day view. Enter values for each fiscal year and period. Do not make an entry for the variable Plant. If you make an entry here, the system does not accept it. You defined the plant when creating the flow definition.

Prerequisites

You have defined the variables already. For more information, see Defining Selection Variables [Seite 292].

You are in flow definition [Extern] in Schedule Manager (Extras → Flow definition → Edit flow definition).

4. Choose a processing step in the navigation area. On the right of the screen, you see Flow definition: Task details.

5. Enter a new variant for this processing step and define a name for this new variant in the Variant field.

6. Choose Change variant. The Maintain Variant: Program <program name>, Variant <variant name> screen appears.

Procedure

9. Choose Attributes.

10. Make an entry in the Description field.

11. Now you want to specify variables for the period and fiscal year that you can then change once centrally for all programs and flow definitions that use those variables. To do this, under the heading Selection screen objects, select the column S in the lines Period and Fiscal year.
Specifying Selection Variables for Flow Definitions With Parallel Branches

12. Choose Selection variables.

13. To choose selection criteria for the variables P_FROM (period) and P_GJAHR (fiscal year), use the input help.

You previously entered these variables in table TVARV.

10. Save your entries.

The Maintain Variant: Program <program name>, Variant <variant name> screen appears.

Result

The system uses these entries for the following purposes:

- To feed these variables to a program created directly as a task in the workflow.
- To feed these variables to the parallel branches.

The system mixes the variables of the parallel branches with those of the main workflow.

If the parameter values of the main workflow are different from those of the subworkflows, the system uses the parameter values that were specified when the subworkflows were created.
Individual Functions of the Schedule Manager

Use

A number of periodic tasks are executed on a regular basis (daily, weekly, or monthly) in the SAP System. An example of such a task is period-end closing. This requires the processing of a large number of individual objects at certain times. This process is supported by the individual components of the Schedule Manager.

Features

Flow definition

In a flow definition, you can link tasks [Extern] to each other if they are related or if you wish to use a worklist in them. You can therefore schedule a flow definition as a task in the scheduler.

See also Using the Flow Definition [Seite 323] in the SAP Library.

Scheduler

In the scheduler, you can schedule tasks in a structure tree. You can use drag-and-drop in a daily overview to enable the system to execute the tasks at a certain time.

See also Using the Scheduler [Seite 298] in the SAP Library.

Monitor

The monitor gives you an overview of the scheduled tasks during and after processing. You can correct faulty objects in a worklist.

See also Using the Monitor [Seite 316] in the SAP Library.

Worklist

Objects that are to be processed in a processing step sequence are managed in the worklist.

The worklist monitor presents information such as which objects were processed without errors and which objects could not be processed. You can display information on the cause of errors, and thus control the way in which the object is processed further.

The worklist ensures that when a processing step sequence is processed again, the system only processes the objects which had errors or which you manually instructed the system to reprocess. Define the processing step sequence in the flow definition.

See also Multilevel Worklist [Seite 343] in the SAP Library.
Using the Scheduler

Use
In the scheduler, you can execute and monitor complex business flows, for example, period-end closing. You can define task lists if you have the corresponding authorization.

Integration
- You can group tasks that are to be executed in the background in a particular order, (and which are controlled by the workflow) into a flow definition [Seite 323].
- You monitor flows and jobs during and after processing in the monitor [Seite 316]
- Use the multilevel worklist [Seite 343] to improve performance and reduce error processing.

Prerequisites
Before using the scheduler, you need to create a task list in which you can later insert the tasks to be scheduled.

Features

The scheduler is divided up into three areas:
- **Task list**
  Tasks structured into task groups in chronological order, which are executed periodically, possibly by more than one user to complete a certain process.
Monthly overview
An overview of the current and previous month.
You can select a day from the monthly overview, which the system then displays in the daily overview in detail.

Daily overview
Overview of the tasks to be done during the day.
Tasks created in the task list are scheduled in the daily overview. The system displays executed tasks in the daily overview with the time that they started.

Activities
Create a task list.
Schedule tasks in the daily overview and if required, have the system execute them.
Task List

Definition
A structured group of tasks, which are executed periodically, and possibly by more than one user to complete a certain process, such as, period-end closing.

Use
The task list enables you to schedule your process (split into tasks) in the daily overview (Scheduling in the Daily Overview [Seite 311]).

Structure
The task list is displayed as a structure tree, into which you can insert different task types [Seite 301].

Integration
The Schedule Manager [Seite 289] consists of the daily overview and the monthly overview.
Task Types

You can use the following types of task in the task plan:

- Job chains executed in the background (= flow definition)
- Individual jobs executed in the background (= program with variant)
- Programs or transactions executed online.
- Notes as placeholder to describe a task that you do not process in the SAP System (such as “inform Mr. X”)

It is only programs with variants that can be scheduled in the daily view and the system executes them automatically. The system cannot start programs and transactions. You can start these manually from the task list. To do so, use the right mouse button to choose Execute.

See also:
Inserting Your Own Programs into the Task List [Seite 308]
Creating a Task List

Use
The task list [Seite 300] forms the basis of the scheduler [Seite 298]. This is where you arrange tasks or task groups into a chronological structure that represents an entire process (such as period-end closing).

Prerequisites
You have divided the process to be displayed into its components (programs, transactions, and jobs).

Procedure
1. Choose Task list → Create.
2. Enter a name for the new task list.
3. Choose Insert.
   A detail screen appears.
4. Enter a description for the new task list.
5. Specify the display format for the daily and monthly overviews.
6. Save your entries.

Result
You have created a task list in which you can now insert tasks.

See also:
Creating New Tasks/Task Groups in the Task List [Seite 303]

💡
To create and process a copy of the SAP task list in your own namespace, choose Task list → Save.
Inserting Tasks/Task Groups into the Task List

Use
To complete a process in Schedule Manager, you need to split the process into its parts (programs, transactions, jobs). You can then insert, delete and reorganize the tasks or task groups (tasks grouped according to content or time-based criteria) chronologically in the task list.

Prerequisites
You create a task list [Seite 302].

Procedure
Inserting Tasks/Task Groups in the Task List
1. Choose Change task list.
2. Select the highest node under which the new task/task group should appear.
3. Use a right mouse click to choose Insert task.
   You can enter a different description for the task/task group and also choose the task type.
   You can specify the person responsible for the task.
4. Choose Insert.
5. Save the changes.
The task types are displayed by various symbols in the structure tree of the task list.

Using Existing Tasks as Templates for New Tasks
1. Use a right mouse click to select the task that you want to use as the template for the new task.
2. Choose Copy.
3. Position your cursor on the node under which the new task is to be assigned.
4. Use a right mouse click to choose Insert.
5. Save your changes to the task list.

Changing or Deleting Tasks
1. Choose Change task list.
2. Use a right mouse click to select the task to be checked/deleted.
3. Choose Change or Delete.
4. Save the changes.

Reorganizing Tasks in the Task List
1. You can use drag-and-drop to move a task to another position in the task list.
2. Save the changes.
Result

You can now process the task plan by scheduling the tasks in the daily overview.

Note that you can enter a relative start time [Seite 313] when creating a task. You require this start time, if you want to schedule a complete task list [Seite 312]. To prevent tasks from being started at weekends or public holidays, you can restrict start dates to calendar days and weekdays.
Inserting Your Own Programs as Tasks

Use
You can include your own transaction directly in the task plan without having to make changes to the transaction.

If you run your own program periodically, you can extend the program so that it can be used in flow definitions (Workflows) and you can see the processing status in the monitor.

For the program to use the worklist, the programming guidelines for the job monitor and the flow definition must be met. You must carry out further program extensions.

Procedure

Connecting Your Own Program to the Monitor
The program CUSTOMER_REPORT is available in the system as standard. This shows you how to call two function modules that enable the easiest connection to the monitor (without a workflow connection).

Incorporate the two Includes SCHEDMAN_INIT and SCHEDMAN_CLOSE in your program. The program is connected to the Job Monitor.

Utilizing Your Program for Flow Definition
If you also want to utilize your program in flow definitions, you must incorporate the Include RKASMAWF in the selection screen.

At the beginning of processing, install the following coding instead of the Include SCHEDMAN_INIT mentioned above:

```plaintext
data: gs_key    like schedman_key.
data: ls_detail like schedman_detail_user.
data: ls_appl   like schedman_customer.
data: ld_dummy(20) value 'ABCDEFGHIJKL'.
constants: customer_appl like smmain-application value 'CUSTOMER'
            ls_detail-application = customer_appl.
            ls_detail-repid        = sy-repid.
*  ls_detail-testflag     = true.    "Decide if testrun or not
            ls_appl-customer_field = ld_dummy.

CALL FUNCTION 'KPEP_MONI_INIT_RECORD'
  EXPORTING
    LS_DETAIL        = ls_detail
    *            LS_WITEM         = 
```
Inserting Your Own Programs as Tasks

    LS_APPL = ls_appl
    *  LD_WORKLIST_FLAG = ' '

IMPORTING
    LS_KEY = gs_key.
    *  TABLES
    *  LT_SELKRT =
    *  LT_PARAM =

In the structure SCHEDMAN_CUSTOMER, you can define your own fields, which you fill with values at runtime.

At the end of program processing, install the following coding instead of the Include SCHEDMAN_CLOSE:

    data: ld_aplstat like smmain-aplstat.
    data: LS_SCMA_EVENT LIKE SCMA_EVENT.
    constants: c_status_ok value '0'.
    constants: c_status_undefined value '2'.
    constants: c_status_error value '4'.
    constants: c_status_aborted value 'A'.
    include schedman_events.

    * decide the status you want to send
      ld_aplstat = c_status_ok.
      * ld_aplstat = c_status_undefined.
      * ld_aplstat = c_status_error.
      * ld_aplstat = c_status_aborted.

    * If the report ended with error -> stop whole workflow. Otherwise
      * start the next job
        if ld_aplstat = '4' or ld_aplstat = 'A'.
          ls_scma_event-wf_event = cs_wf_events-error.
        else.
          ls_scma_event-wf_event = cs_wf_events-finished.
        endif.
the variables wf_witem and wf_okey
* are from include RKASMAWF and are filled AUTOMATICALLY
* fill them into structure ls_scma_event
  ls_scma_event-WF_WITEM = wf_witem.
  ls_scma_event-WF_OKEY  = wf_okey.

CALL FUNCTION 'KPEP_MONI_CLOSE_RECORD'
  EXPORTING
    LS_KEY           = gs_key.
*    LS_MESSAGE    =
*    LD_OBJECTS    =
*    LS_EXT        =
*    LS_RL         =
    LS_SCMA_EVENT = ls_scma_event

* TABLES
*    LT_SPOOL    =
CHANGING
    LD_APLSTAT  = ld_aplstat
EXCEPTIONS
    NO_ID_GIVEN = 1
    OTHERS      = 2.

For programs that you want to include in flow definitions, note the following:

- If it is a cross-application program, you need to copy the program that was already stored with an application, and then store the new program in the SCMAPROG table with the new application.

Enter the name of your program as a customer program in Schedule Manager. For more information, see Inserting Your Own Programs as Tasks [Seite 308].

You can include your own program in a flow definition using these settings, and see the results in the monitor.
Inserting Your Own Programs as Tasks

Prerequisites

To add your own programs to the task list and schedule them, you must store them in the system and make sure the Schedule Manager knows how to access them.

Procedure

1. To do so, choose Extras → Settings → Customer Programs. This brings you to the table Registration of Customer Schedule Manager Programs.
2. Choose New entries.
3. Enter the ABAP program name or search for it using the input help.
4. Use the input help to select an application. You can enter either a CUSTOMER application or a standard application. If you use a standard application, you must replace the constant value CUSTOMER_APPL in the coding for SCHEDMAN_INIT with your chosen value.
   \[
   \text{constants: customer_appl like smmain-application value '********'.}
   \]
5. You can set the following indicators:
   - **AVo** (worklist)
     Determines that the program
     - Receives the objects to be processed in the worklist of the Schedule Manager. This means that no scope of selection must be defined for the report itself. The scope of selection only has to be defined once in the flow definition.
     - Processes these objects within the worklist, and that a processing status is set for each processing step and object during processing.
     - Issues messages on the object within the worklist.
     To ensure that these requirements are met, certain programming guidelines must be followed when the customer program is written.
   - **Sel** (Selection)
     A program for which this indicator is set is a selection program for the worklist (or for a flow definition with worklist) for a customer application. Programming guidelines must be followed for such programs as well.
   - **Rep** (Reports)
     This indicator is set for programs that generate reports that are based on worklists. Programming guidelines must be followed for such programs as well.
6. Save your entries.
Inserting Your Own Programs as Tasks

Essentially any program can be scheduled in Schedule Manager. However, to enable information on the program to be output in the job monitor, the program must meet certain programming guidelines. Additional programming guidelines must be met to enable the program to be scheduled with the workflow (flow definition).

For the program to use the worklist, the programming guidelines for the job monitor and the flow definition must be met. Further programming guidelines must also be noted.

For more information, see Inserting Your Own Programs as Tasks. [Seite 305].
Storing Task Documentation

Use

You can attach Microsoft Office documents to the tasks where they are required for processing. You can also store straightforward long texts to document a task.

Procedure

Creating Microsoft Office Documentation

1. Choose Change task list.
2. Use the right mouse button to select the task to be documented.
3. Choose Office document.
   The required Microsoft Office document type appears. You can now enter your text.
4. Save the document and return to the scheduler by choosing File → Close → Back to the Schedule Manager.

Creating a Long Text

1. Choose Change task list.
2. Use the right mouse button to select the task to be documented.
3. Choose Long text.
   A window appears in which you can enter a note.
4. Choose Continue.
   The system returns to the scheduler.

You can only store one long text and one Microsoft Office document at the same time for a given task.

All users assigned to this task list have access to these documents.

Sending Long Texts

1. Use the right mouse button to select the task for which you have entered a note.
2. Choose Send note.
3. Enter the recipient and a recipient type.
   You can select the priority of the transmission and other attributes.
   You can view the note again and create attachments.

Result

You have stored a document for a task, which is now permanently available to you for reference.
Scheduling Tasks in the Daily Overview

Use
To enable the system to start tasks at certain times, you need to schedule the tasks from the task list in the daily overview.

Prerequisites
You have inserted tasks into a task list.

Procedure
1. Choose Insert task.
2. Use drag-and-drop to schedule a task from the task list in the daily overview, by dropping the task onto an appropriate time.

⚠️ Transactions and programs can only be started directly by you. You cannot schedule these task types [Seite 301] in the daily overview.

3. To start a transaction or program from the task list, select this task.
4. Use the right mouse button to choose Execute.

Result
The system executes the tasks at the times you specified.
Scheduling a Complete Task List in the Daily Overview

Use
You can schedule a complete task list. The advantage of doing so is that you can use the same task list each month for scheduling purposes simply by changing the start date and time.

Prerequisites
Before you can schedule the complete task list, you must specify a relative start time [Seite 313] for each task in the task list. This schedules the sequence of tasks independently of the concrete start date of the task list.

Scheduling a Complete Task List in the Daily Overview
1. Select the highest node of the task list with the right mouse button.
2. Choose Schedule.
3. Specify when the task list should be run.
   You can choose between:
   • Starting on the current day
   • Starting on any other day

Scheduling the Complete Task List
Before actually scheduling the task list, you can run a simulation.
1. Select the highest node of the task list with the right mouse button.
2. Choose Simulation of scheduling.
3. Specify when the task list should be run.
   The system outputs a list showing the starting dates of the tasks in the task list.

Deleting the Scheduling of a Complete Task List
1. Select the scheduled task list in the daily overview.
2. Choose Delete.
   The system outputs a table showing the statuses of the tasks in the task list.

You can decide when the jobs in the task list should be started. For more information, refer to Controlling Whether Jobs Are Started [Seite 315].
Relative Start Time

Use

You can schedule complete task lists.

To do this, it is necessary to specify a *relative start time* for each task.

Features

The relative start time contains two time parameters:

- The number of calendar days or workdays (called the *offset*), such as 2 calendar days or 1 workday.
- The actual starting time, such as 12:15 pm.

Using these parameters, you can schedule and reschedule the individual tasks independently of the actual run date of the task list itself.

Example 1

You have created the task *foreign currency valuation* with the parameters *offset in working days: 1* and *start time: 12:15 pm*. If the task list is scheduled to start on a Friday and a factory calendar is being used, the task will be started the following Monday at 12:15 pm (weekends are not working days). If a Gregorian calendar is being used (in this case all days are working days), the task would be started on Saturday at 12:15 pm. If the same task list were scheduled to start on a Monday, in both cases the task would be started on the following Tuesday at 12:15 pm.

If the task list contains several tasks with relative start times, the actual start times are always calculated on the basis of the scheduled date and the specified calendar.

Example 2

The task *assessment* has an offset of 1 calendar day, and the task *settlement* has an offset of 2 calendar days. The schedule date of the task list is March 11. The task *assessment* is started on March 12 (March 11 + 1 day), and the task *settlement* is started on March 13 (March 11 + 2 days).

![Tip Icon]

The offset for the start time is always based on the *concrete* schedule date. The system then calculates the concrete start date from this offset using the schedule date and the specified calendar.
Runtime Analysis for Jobs

Use
Runtime analysis shows you the average runtime of jobs or flow definitions. It also estimates the runtime of the next job to be executed.

Activities
1. Select a job with the right mouse button.
2. Choose runtime analysis.
   The system shows you the following information:
   - The average runtime
   - The number of runs executed
   - The runtime of the last and next-to-last runs
   - The estimated runtime of the next run
3. You can also enter your own estimation of the runtime.

   If any runtime information is available for tasks in the task list, it is displayed in the last three columns of the task list.
Controlling Whether Jobs Are Started

Use
If you schedule a job in the daily overview but do not release it, it is not automatically started by the system when the start time is reached.
This function is particularly useful for scheduling a complete task list [Seite 312].

Features
You can release a job:
- When inserting it into the task list
- After scheduling the job in the daily overview

Activities
You are in the mode task list - scheduling.
1. You select a job with the right mouse button.
2. You choose Schedule.
   On the subsequent screen, you specify under Release task whether the job is executed automatically when the start time is reached.
Using the Monitor

Use

The monitor shows the information on an active or completed job that was scheduled in the scheduler.

To improve performance and facilitate error rectification, use the multilevel worklist [Seite 343].

Integration

The monitor is part of the Schedule Manager [Seite 289].

Other components are:

- **Flow definition**
  
  You can group tasks that are to be executed in the background in a particular order (and which are controlled by the workflow) into a flow definition [Seite 323].

- **Scheduler**
  
  You can create individual tasks for business transactions (which for example, make up period-end closing) in the scheduler [Seite 298] task list. By scheduling them in the daily overview, you enable the system to execute them.

Structure

For detailed information on the functions of the monitor, refer to:

- Monitor - Monitoring Active and Completed Jobs [Seite 318]
• Monitor - Working with the Object List [Seite 358]
Monitor - Monitoring Active and Completed Jobs

Definition
The monitor shows the information on an active or completed job that was scheduled in the scheduler.

Prerequisites
To enable the system to start jobs or job chains, you need to schedule them in the daily overview of the scheduler.

Features
To determine the current status of jobs that are still running, you can repeat the database selection.

If you only wish to see jobs with a certain status, you can hide the other statuses.

The monitor is divided into three areas:

Structure

- Structure tree
  The structure tree displays the workflows (expanded into substeps) and jobs which ran at particular times, in chronological order.
  You receive information on:
Monitor - Monitoring Active and Completed Jobs

- The job status
- The job runtime
- The update status

Use the right mouse button to see the different functions available for this job, such as:
- Start transaction
- Restart report
- Goto object monitor in the generalized worklist, and so on.

For more detailed information on a job, double-click on the required entry in the structure tree. The detail view appears.

**Detail view of a job**

By switching the tab titles you can select different detailed information (details, parameters, additional information) on a job.

There are four pushbuttons underneath the tab page. These are only active if corresponding data for the selected job is available:

- Spool list
  Display of batch spool list(s)

- Job log
  Display of the job log belonging to the batch job

- Extract
  Online display of results lists that were saved

- Basic list
  Online display of a short list that was saved. This list contains the most important information on a job.

**Message list**

If messages occurred for a job and these were saved, then the system displays them in the message area.

To go to a message long text, double-click on the corresponding message.

**Activities**

From a scheduled job, you call up the monitor from the daily overview of the scheduler.

You call up the required details for a selected job.

See also:

Monitor - Working with the Object List [Seite 358]
Monitor - Working with the Object List

Definition
The monitor of the Schedule Manager is a tool for processing multilevel worklists. It contains information on active or completed jobs that were planned in the scheduler.

Use
This section provides information on using the object list in the monitor of the Schedule Manager.

For more information on jobs in the monitor, see Using the Monitor [Seite 316].

The monitor performs the following functions:

- Displays the available worklists and their processing steps
- Keeps track of the processing status of each object (such as product cost collectors, WBS elements, internal orders, and production orders) and each processing step
- Assists you in analyzing the causes of errors for the objects and processing steps
- Displays the processing status of objects (particularly for the objects with errors)
- Shows the hierarchical relationships between the objects
- Compares object hierarchies with each other
- Controls whether objects enter the next processing step
- Sends objects to the responsible person for further processing

You can set the processing status so that objects of negligible value, for example, are not reprocessed in a processing step even if errors are issued for the objects in that step. In this case, it is not necessary to remove the cause of the error.
The monitor is divided into the following screen areas:

**Structure Tree with Worklists/Processing Steps/Jobs**

The structure tree containing the worklists, processing steps and jobs is displayed on the left side of the monitor.

In the system, the worklists are updated separately for each scope of selection and processing step sequence. The processing step sequence is specified in the flow definition. You can view the worklists of the application component in which you are working, including their functions and objects.

The system displays the following information on each worklist:

- Number of objects in the worklist
- Processing steps
- Number of objects processed in each processing step
- Number of objects with errors in each processing step

**Object List**

The object list is located in the top right area of the screen. The object list can display one or more processing steps of a worklist. You select the processing steps in a worklist in the structure tree `worklists/processing steps/jobs`.

The object list includes the following information:
Monitor - Working with the Object List

- The objects for the selected processing steps. You can control which objects are displayed for each processing step by means of a filter that takes the individual processing statuses into account. In application toolbar icons for object list, choose the icon Objects: Set status filter. The system uses the last user-specific default setting of the dialog box. Note the default settings of this dialog window in the SAP standard system. The last user-specific setting of the dialog box is the default.
- The processing step performed for the object
- The processing status of the object for each processing step
- A check box you can select to indicate that you have processed the object in the worklist monitor
- The person responsible for the object (if any)

Message List

The message list is located in the lower right-hand portion of the screen. The message list displays messages for certain objects. You can use these messages to analyze the causes of error for each object and processing step.

See also:

Schedule Manager: Multilevel Worklist [Seite 343]
Multilevel Worklist: Process Flow [Seite 356]

For detailed information on using the monitor of the Schedule Manager, see the following section:

Processing Status of Objects and Processing Steps [Seite 372]
Processing Worklists [Seite 361]
Using the Flow Definition

Use

A flow definition consists of individual flow steps. These steps include scheduling programs with variants in the job control of the SAP System, and interaction with users by email.

The flow definition is a graphical summary of several steps. A step in the flow definition corresponds to a task in the task plan, except that the individual step does not appear directly in the task plan, rather it is displayed in the flow definition, which is included in the task plan.

Integration

The Schedule Manager provides a multilevel worklist [Seite 343]. The multilevel worklist improves performance and facilitates error finding. To use the Schedule Manager worklist, create a flow definition and schedule it in the scheduler. For further information about this worklist, see Choosing Objects for Processing [Seite 371].

Prerequisites

Workflow profiles enable you to adapt the user interface of the flow definition according to your requirements. If required, the project team can create and provide this type of profile. To make individual processing available as flow steps, you need a program which provides all the processing parameters and displays an ergonomic user interface.

⚠️

If you are using the workflow builder function for the first time in the SAP System, go into Customizing and choose Basis → Business Management → SAP Business Workflow → Maintain Standard Settings for the SAP Business Workflow and then Automatic Customizing.

For more information, see Creating a Flow Definition [Seite 325].

For more information on error handling in flow definitions, see: Error Handling [Seite 333].

Features

You can define individual flow definitions with as many flow steps as you like, or you can link flow definitions together within an “upper” flow definition. You must assign the “upper” flow definition to an application (or application component) that is on a higher level than the applications assigned to the lower-level flow definitions.
Flow Step Types

In the workflow builder, you can schedule four types of flow step:

Program with Variants
Enter a program and a variant.

User Decision
For a user decision, the system sends a message to a user. The system generates a text that creates a message header in the user’s inbox. The system stops processing the individual tasks in the flow definition [Seite 323] until the user confirms the message. The text should therefore contain the information required to make the decision, such as which task the system just executed and which data needs checking.

Fork
You can define as many tasks as you wish in each of the parallel branches. All of the parallel branches join at the end, although the task that follows the join is only processed when all of the tasks in each branch are completed.

You cannot subsequently change the number of parallel branches. However, you can delete a branch by deleting all of the tasks in the branch. You cannot add another branch.

Flow Definition
The flow definition consists of several tasks that the system executes in the specified order, once you schedule the flow definition in the daily overview of the scheduler. You can create further "sub-" flow definitions within a flow definition.
Creating a Flow Definition

Use
You use a flow definition [Seite 323] in the Schedule Manager [Seite 289]. You can insert a flow definition in the task list of the scheduler, then schedule it into the daily overview and run it.

Procedure
1. Choose Extras → Process flow definition in the Scheduler
   Enter a description for the flow definition
2. Choose Create.

⚠️
When creating without a template, the system generates a flow definition example (with flow steps) for the specified application. Do not delete the steps Check objects in worklist and Renew worklist processing, because these steps enable the recursive call of worklist processing. If the step Renew worklist processing is deleted, you cannot include it in the flow definition.

3. In the screen that follows, enter a description for your flow definition and then assign it to an application component.

💡
Note that all flow steps in a flow definition (which is also assigned to an application) must also be assigned to this application or to the application on the next level up or down.
Creating a Flow Definition

If you have chosen the application Controlling for the flow definition, you can only create flow steps in this flow definition if the application that you define for the steps is above or below Controlling (SAP) in the hierarchy (for example, Internal Orders, Cost Center Accounting...). In this flow definition for example, you cannot insert a report in which the application Financial Accounting is defined.

4. If required, indicate that you are working with a worklist [Seite 343]. To work with a multi-level worklist, you must have chosen an application with a worklist and the function With worklist during creation.

5. Enter a development class in the dialog box Create object catalog entry, then save your entry.
   The workflow builder appears. Each node (step, event or operator) in the workflow builder has a menu that you can call up using the right mouse button. This immediately shows you the operations that are possible for a node, and cancels out the need for long menu structure or pushbutton paths.
6. In the navigation area, select the node *Steps*.
7. Choose *Create step*.
8. Choose the *flow step type [Seite 324]*.
9. Specify the required information for the flow step.

💡 You can choose programs only using the input help. Programs are displayed in the input help only if you have registered them in the tables `SCMAPROGRAMS` (for SAP programs) or `SCMAPROG_CUST` (for your own programs). For more information about working with your own programs, see *Inserting Own Programs as Tasks [Seite 305]*.

10. Choose *Cancel* to return to the Workflow Builder.

11. You see the task in the structure tree of the task area. The task is integrated in the graphic of the flow definition. Move the task to the desired position in the flow definition.

12. Save your entries.

For more information on the Workflow Builder, see the SAP Library under BC-*Basis Components* → Business Management (BC-BMT) → SAP Business Workflow Navigation (BC-BMT-WFM) → *Workflow Builder [Extern]*.
Creating a Flow Definition

If you are using the workflow builder function for the first time in the SAP System, go to the Implementation Guide (IMG) and choose Basis → Business Management → SAP Business Workflow → Maintain Standard Settings for the SAP Business Workflow and then Automatic Customizing.

You can also use the SAP standard flow definitions. Variant names for these flow definitions begin with SAP&. These variants only contain selection variables named SAP-SCMA. Use the STVARV transaction or Schedule Manager, Extras → Settings → Selection variables to adapt the variable values according to your requirements. For further information on selection variables, see Defining Global Variables for Task Lists/Flow Definitions [Seite 291] and Defining Selection Variables for Flow Definitions With Parallel Branches.
Specifying Selection Variables for Flow Definitions With Parallel Branches

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables in the program variants.

You have five programs that must run with the same valuation for nine plants. That means that every program must run with a plant-specific variant for each plant. These variants differ only in their Plant specification.

As described below, you define global variables for fiscal year, period and plant. Create variants for the five programs and define the global variants that you created previously. Finally define a flow definition (A) for the five programs. Define a flow definition (B) with nine parallel branches (for the plants). Include the flow definition A in each of these branches. A dialog box appears that displays the three global variables (fiscal year, period, plant). Enter a value for the variable Plant and flag the entry as to be saved. The dialog box reappears when you plan flow definition B in the day view. Enter values for each fiscal year and period. Do not make an entry for the variable Plant. If you make an entry here, the system does not accept it. You defined the plant when creating the flow definition.

Prerequisites

You have defined the variables already. For more information, see Defining Selection Variables [Seite 292].

You are in flow definition [Extern] in Schedule Manager (Extras → Flow definition → Edit flow definition).

7. Choose a processing step in the navigation area.
   On the right of the screen, you see Flow definition: Task details.

8. Enter a new variant for this processing step and define a name for this new variant in the Variant field.

9. Choose Change variant.
   The Maintain Variant: Program <program name>, Variant <variant name> screen appears.

Procedure

14. Choose Attributes.

15. Make an entry in the Description field.

16. Now you want to specify variables for the period and fiscal year that you can then change once centrally for all programs and flow definitions that use those variables. To do this, under the heading Selection screen objects, select the column S in the lines Period and Fiscal year.
Specifying Selection Variables for Flow Definitions With Parallel Branches

17. Choose Selection variables.

18. To choose selection criteria for the variables P_FROM (period) and P_GJAHR (fiscal year), use the input help.

You previously entered these variables in table TVARV.

11. Save your entries.
   The Maintain Variant: Program <program name>, Variant <variant name> screen appears.

**Result**

The system uses these entries for the following purposes:

- To feed these variables to a program created directly as a task in the workflow.
- To feed these variables to the parallel branches.

The system mixes the variables of the parallel branches with those of the main workflow.

If the parameter values of the main workflow are different from those of the subworkflows, the system uses the parameter values that were specified when the subworkflows were created.
Choosing Objects for Processing

Use
An advantage of this worklist [Extern] is that the objects for processing only have to be selected once per flow definition.

Prerequisites
You are in flow definition [Extern] in Schedule Manager (Extras → Flow definition → Edit flow definition).

Procedure
10. Choose a processing step in the navigation area.
   On the right of the screen, you see Flow definition: Task details.
11. Enter a new variant for this processing step and define a name for this new variant in the Variant field.
12. Choose Create variant.
   The Variant Maintenance screen appears. Program <program name>, variant <variant name>.
   Here you can determine the scope of selection of the program variants for the flow definition.
13. To be able to choose more extensive selection criteria, first complete the required entry fields, for example Period <006>, Fiscal year <2000>.
14. You can now define further selection parameters using the various pushbuttons that are offered in dialog boxes.
15. Choose Attributes.
   The ABAP: Save Attributes of Variant <Variant name> screen appears.
Defining Processing Options, Output Options and Execution Types

You are in flow definition [Extern] in Schedule Manager (Extras → Flow definition → Edit flow definition).

16. Choose a processing step in the navigation area. On the right of the screen, you see Flow definition: Task details.

17. Choose Change variant. The screen Variant Maintenance appears. Program <program name>, variant <variant name>.

18. In the corresponding group frames, select the desired processing option, output option and execution type. For example, you can define whether parallel processing is allowed.

19. Perform variant maintenance for all programs that are linked to the flow definition.

For further information see Defining Selection Variables in the Program Variants [Seite 293] and Selection Variables for Flow Definitions with Parallel Branches [Seite 329].
Error Handling

Job error handling involves the following:

1. For checking purposes:
   - Periodically reading the job status
   - Checking the maximum runtime

2. When errors occur:
   - User decision "Continue the flow with the next task"
   - User decision "Reschedule the job"

⚠️

The user decision "Reschedule job" is not available for worklists.
Error: A Job Stops

Cause
The job stops, if for example, the system is turned off.

Error Handling
The dialog for an error in the job administration is handled in its own sub-workflow, which consists of a user decision. This message is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, mail to section (see also: Creating a Flow Definition [Seite 325]). That person receives the mail that an error has occurred in job XY in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:

- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

💡 You can use this option without any problems, for jobs that have worklists. However, you need the worklist ID to be able to execute the job outside of the workflow.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Extern] to control the rescheduling of the job.
Graphical Representation of the Flow

1. Workflow started
2. An error occurred in job &1
   - Reschedule job
   - Schedule Manager: Schedule job
   - Set the FINISHED event
   - Event sent
3. Workflow finished
Error: A Job Becomes "Stuck"

Symptom
The program has a runtime that is far longer than expected.

Error Handling
The dialog for a processing error in the program is handled in its own sub-workflow, which consists of a user decision. This message is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, mail to section (see also: Creating a Flow Definition [Seite 325]). That person receives the mail that an error has occurred in program X, variant Y in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:

- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

You can use this option for jobs that have worklists. However, you need the worklist ID to be able to execute the job outside of the workflow.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Extern] to control the rescheduling of the job.

Graphical Representation of the Flow
Workflow started

Program &1, variant &2 contains errors

Reschedule job

Schedule Manager: Schedule job

Workflow finished
Error: An Executed Report Found an Error

Symptom
Due to an error in the content, the REPORTERROR workflow event was triggered.

Error Handling
The workflow executes an error dialog. This contains a user decision. The user decision is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, send to section (See also: Creating a Flow Definition [Seite 325]). That person receives the mail that an error has occurred in program X, variant Y in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:
- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Extern] to control the rescheduling of the job.

⚠️ No user decision is called up for jobs that have worklists. This is because the error handling for worklists is triggered by rerunning the task steps in the workflow. Therefore, programs written for worklists always trigger the FINISHED event.

Graphical Representation of the Flow
Error: An Executed Report Found an Error

Workflow started

Job started

Schedule Manager: Start job

Fork

Schedule Manager: Job error handling

Wait for REPORTERROR event

Schedule Manager: Dialog for program errors

1 from 3

Workflow finished

Wait for FINISHED event
Error: Job Scheduling Was Unsuccessful

Cause
Scheduling a job can be unsuccessful if the technical name of the report or variant was changed after the flow definition was created. This means that the technical names in the flow definition no longer exist.

Error Handling
The workflow recognizes the error and issues an error message displaying the faulty technical name of the report or variant.

The message is linked to a user decision. This message is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, mail to section (see also: Creating a Flow Definition [Seite 325]). That person receives the message in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:

- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Extern] to control the rescheduling of the job.
Error: The Workflow Stops

Cause

The workflow stops due to an error in the workflow runtime system.

Symptom

The job just scheduled is completed since the job control functions separately from the workflow. However, the following steps in the flow definition are no longer executed.

Error Handling

It is not possible to restart at the point where the workflow stopped. Therefore, you need to reschedule the whole flow definition.
Error: The Workflow Becomes "Stuck"

Cause
During job scheduling using the workflow, if an error occurs in the program section of the report and the report is being run at the AT SELECTION-SCREEN OUTPUT event, then the job is not scheduled.

Error Handling
The system issues an error message to notify you that scheduling is not complete.

The message is linked to a user decision. This message is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, mail to section (see also: Creating a Flow Definition [Seite 325]). That person receives the message in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:

- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Extern] to control the rescheduling of the job.
Multilevel Worklist

Use

The worklist of the Schedule Manager is a multilevel worklist. This worklist is particularly useful for the period-end closing activities.

Why Is the Worklist Multilevel?

In previous releases, the period-end closing process in the R/3 system consisted of a series of batch jobs. The sequence of the processing steps was established by the order in which the jobs were called. The objects were selected separately for each job. Through the selection criteria entered, it was possible to specify a unified scope of selection. This scope of selection had to be respecified for each processing step (that is, for each individual function of period-end closing).

When an object was processed, errors that occurred in previous processing steps were not taken into account. For this reason, it was necessary to check the objects that had errors once a job was completed. Any errors had to be corrected and then the job restarted for the entire scope of selection. In some areas (such as the period-end close in Product Cost by Period), it was already possible to create a single-level worklist for individual processing steps. With this single-level worklist, the objects with errors could be called up for each processing step, and the causes of the errors determined. The processing step could then be performed again for the object after the error was corrected. This worklist did not prevent objects with errors from being processed in the subsequent processing step (that is, in the subsequent job).

Advantages of the Multilevel Worklist

The worklist of the Schedule Manager is a multilevel worklist. This means that the worklist is generated for a sequence of processing steps rather than for just one processing step. The worklist therefore enables efficient execution of processing step sequences. Processes such as period-end closing can be performed much more efficiently with a multilevel worklist.

The multilevel worklist has the following advantages:

- The processing step sequences (such as in period-end closing) can be performed faster than before.

  Manual processing after completion of each job is no longer necessary. Manual processing is only necessary after executing a sequence of processing steps that consists of multiple jobs (for example, complete closing of an application component).

  Furthermore, if errors were issued for objects in the single-level worklist, it was often necessary to repeat the processing steps for the entire scope of selection (and not just for the objects with errors). With the multilevel worklist, the processing steps are repeated only for the objects that have errors.

- CPU time is reduced because objects are selected only once for each processing step sequence, instead of for each individual processing step. Objects are selected before the first processing step is executed. The multilevel worklist provides performance benefits particularly with complex structures in which dependencies between objects must be taken into account (such as complex project structures).

As a rule, jobs are planned and monitored by members of the EDP team. In many cases, these employees are not responsible for the correcting the errors shown in the error logs. With the multilevel worklist, you can directly inform the employees responsible for correcting the errors.
Multilevel Worklist

This notification takes place by means of a mail message that is sent automatically through the workflow [Extern].

Integration

The multilevel worklist is part of the Schedule Manager and is always used with the other functions of the Schedule Manager (see Prerequisites).

The following applications, functions, and objects are currently supported by the multilevel worklist:

<table>
<thead>
<tr>
<th>Cost Object Controlling: Manufacturing Orders and Product Cost Collectors</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Process Flow</strong></td>
</tr>
<tr>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Period-end closing for manufacturing orders and product cost collectors [Extern]</td>
</tr>
<tr>
<td>• The objects are not assigned to a cost object hierarchy, or it is specified in the cost object category that the individual orders of a material are processed outside the cost object hierarchy (see Product Cost by Period).</td>
</tr>
<tr>
<td>• The objects do not have status DLFL (deletion flag).</td>
</tr>
<tr>
<td>Product cost collectors are objects of the Product Cost by Period subcomponent.</td>
</tr>
</tbody>
</table>
### Preliminary Settlement for Co-Products, Rework

- Preliminary settlement for co-products: Order header of manufacturing orders as processing objects; order items as receivers.
- Preliminary settlement of rework: Order header of manufacturing orders as processing objects, order header of manufacturing orders or product cost collectors as receivers; but not: Settlement of rework on product cost collectors or manufacturing orders assigned to a cost object hierarchy (see below).
- Preliminary settlement of collective orders (old processing method without automatic goods movement) Header of manufacturing orders as processing objects, header of manufacturing orders as receivers.

<table>
<thead>
<tr>
<th>WIP calculation [Extern]</th>
<th>Production and process orders or, in joint production, their items, as well as CO production orders and product cost collectors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variance calculation</td>
<td>Production and process orders or, in joint production, their items, as well as CO production orders and product cost collectors</td>
</tr>
<tr>
<td>Settlement [Extern]</td>
<td>Production and process orders or, in joint production, their items, as well as CO production orders and product cost collectors</td>
</tr>
</tbody>
</table>
Cost Object Controlling: Cost Object ID (Cost Object Nodes in a Cost Object Hierarchy and General Cost Objects)

<table>
<thead>
<tr>
<th>Process Flow</th>
<th>Period-end closing for cost object ID</th>
</tr>
</thead>
</table>

Multilevel Worklist
Scope of Selection for Processing Objects

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template allocation</td>
<td>Cost object nodes of <strong>cost object hierarchies</strong> or the single objects assigned to the cost object hierarchy (product cost collectors, manufacturing orders or production orders without quantity structure); <strong>general cost objects</strong></td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>Cost object nodes of <strong>cost object hierarchies</strong> or the single objects assigned to the cost object hierarchy; <strong>general cost objects</strong></td>
</tr>
<tr>
<td>Actual cost distribution</td>
<td>Cost object nodes of <strong>cost object hierarchies</strong>; the single objects assigned to the lowest cost object nodes are the final receivers</td>
</tr>
<tr>
<td>Actual overhead</td>
<td>Depending on the Customizing settings, cost object nodes of <strong>cost object hierarchies</strong> or the single objects assigned to a cost object hierarchy; <strong>general cost objects</strong></td>
</tr>
</tbody>
</table>

Preliminary Settlement for Co-Products, Rework

<table>
<thead>
<tr>
<th>Preliminary Settlement for Co-Products, Rework</th>
<th>Only for orders assigned to the <strong>cost object hierarchy</strong>;</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Preliminary settlement for co-products: Order header of manufacturing orders as processing objects, order items as receivers</td>
</tr>
<tr>
<td></td>
<td>• Preliminary settlement of rework: Order header of manufacturing orders as processing objects, order header of manufacturing orders or product cost collectors that are assigned to the cost object hierarchy as receivers</td>
</tr>
</tbody>
</table>

WIP calculation

<p>| WIP calculation | The single objects assigned to a <strong>cost object hierarchy</strong>; but not: Order items in joint production (manufacture of co-products), CO production orders |</p>
<table>
<thead>
<tr>
<th><strong>Variance calculation</strong></th>
<th>Depending on Customizing settings, cost object nodes of <strong>cost object hierarchies</strong> or the single objects assigned to the cost object hierarchy</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Settlement</strong></td>
<td>Depending on Customizing settings, the top nodes of a <strong>cost object hierarchy</strong> or all nodes of the cost object hierarchy; if applicable, all orders assigned to the cost object hierarchy, and in joint production the items of the manufacturing orders; All <strong>general cost objects</strong></td>
</tr>
</tbody>
</table>
## Project System

<table>
<thead>
<tr>
<th>Process Flow</th>
<th>Scope of Selection for Processing Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period-end closing for Project System</td>
<td>WBS elements, networks, and orders</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generation of settlement rule</td>
<td>WBS elements</td>
</tr>
<tr>
<td>Template allocation</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Actual overhead</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Cost forecast</td>
<td>Networks</td>
</tr>
<tr>
<td>Interest calculation</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Project earned value</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Results analysis</td>
<td>WBS elements and orders</td>
</tr>
<tr>
<td>Incoming orders</td>
<td>WBS elements</td>
</tr>
<tr>
<td>Settlement</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Reporting</td>
<td>WBS elements, networks, and orders</td>
</tr>
</tbody>
</table>
Multilevel Worklist

Internal Orders

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Period-end closing for internal orders</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope of Selection for Processing Objects</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Processing Step</td>
<td>Objects</td>
</tr>
<tr>
<td>Template allocation</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Actual overhead</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Interest calculation</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Results analysis</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Settlement</td>
<td>Internal orders, maintenance orders</td>
</tr>
</tbody>
</table>

Sales Orders

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Period-end closing for sales orders</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope of Selection for Processing Objects</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Processing Step</td>
<td>Objects</td>
</tr>
<tr>
<td>Template allocation</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Actual overhead</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Results analysis</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Settlement</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
</tbody>
</table>

Prerequisites

You are working with the Schedule Manager and are using all of its functions.

A prerequisite for the use of the multilevel worklist is that a constant quantity of objects (or, in subsequent executions, their subset) is processed in a predefined sequence of processing steps.

The selection set of the objects is determined through the application you select (for example, Cost Object Controlling: Manufacturing orders and product cost collectors) (see above), as well as through any additional entries that you may make when creating report variants (see below).

The sequence of processing steps is specified in the flow definition.

This means that you proceed as follows:

2. From the scheduler, create a flow definition [Seite 323]. In the flow definition, specify the processing step sequence (for example, a sequence of all single functions of period-end closing for product cost collectors). The creation of the flow definition is realized through the Workflow Builder.

You access the flow definition with the menu options Extras → Process the flow definition. When you create the flow definition, you should:
Specify which application the flow definition is intended for (such as Cost Object Controlling: Manufacturing Orders and Product Cost Collectors)

Make sure you create a flow definition with a worklist

The Workflow Builder appears. Depending on the application you selected, you receive a SAP template that you can modify to meet your requirements.

3. Create a task for each processing step in the flow definition. Such tasks can be, for example, reports for the single functions of period-end closing or user decisions.

To facilitate maintenance of the flow definition, the system offers you a default template. This consists of a task placeholder at the beginning of the flow as well as a task placeholder in the feedback loop. You define the placeholder at the beginning of the flow before the feedback loop as a report task for selecting the worklist. You define the single functions of period-end closing as tasks in the feedback loop.

To define the selection or a single function (such as overhead calculation) as a task, select the Program indicator when you create the task. Then, select the report from a proposal list that you want to include in the processing sequence (such as Overhead: Worklist of Manufacturing Orders)

Then create a report variant for the execution of the report. Maintain the parameters for the variant. Here you can specify various parameters such as whether a detail list is output and whether processing takes place simultaneously on multiple servers.

You can further filter the scope of selection of the object to be processed by using a selection profile.

In addition, enter the period and fiscal year.

You can use the same flow definition each time if you enter selection variables instead of fixed values for the period and fiscal year when you maintain the report variants. In this case, the system calculates the period and fiscal year of the single functions dynamically from the current values for these variables when it executes the flow definition. This is only possible if you use selection variables (called TVARV variables) for the period and fiscal year parameters. When you create the report variant, you specify that you are working with selection variables. You maintain the selection variables by entering the transaction STVARV, or by starting the transaction through Extras → Settings → Selection Variables in the menu of the Schedule Manager and changing the variables there to the period and fiscal year to be processed. This enables you to use the same job variant every month. You only need to update the TVARV variable before executing the job variant.

You specify a user decision if you want the previous processing results to be checked after one or more processing steps. After executing the previous processing steps, the system automatically sends a mail message to the person responsible for checking the results (usually the cost accountant). When you create the flow definition, you specify which user receives this mail.

When you use the multilevel worklist, the system always specifies a user decision and a feedback loop for the reentry into postprocessing as the last step of the flow definition.

You can also insert user interactions at other points in the process definition if you want to check the objects processed up to a particular step before continuing with processing.
Multilevel Worklist

If you approve (release) the check of the objects with errors, you make it possible for the objects with errors to automatically be reprocessed later.

4. Enter the flow definition as a task in the task list of the Scheduler.
5. Start the task (the flow definition) in the Scheduler.
6. You monitor the flows and jobs during and after processing in the monitor [Seite 316] of the Schedule Manager.

Features

Basic Functions of the Multilevel Worklist

The multilevel worklist is generated for an entire sequence of processing steps.

The scope of selection is determined once and is valid for all processing steps. The worklist encompasses the objects of the scope of selection for which processing in the present processing step sequence is both possible and necessary. The scope of selection, therefore, equals the maximum scope of the worklist. Certain restrictions can be specified for individual processing steps in the scope of selection. These restrictions are usually determined through selection profiles that are specified when report variants are created.

The processing steps are performed in an order strictly defined in the flow control of the scheduler. A processing status is maintained for each object and processing step. The processing status indicates whether further processing of the object is allowed.

Each processing step only contains the objects for which (based on the processing status of the previous processing step) processing in this step is allowed.

In each processing step, dependencies between objects are interpreted according to the application. For this reason, it can be necessary to include other objects when processing an object in a step. The system accounts for such object dependencies automatically. You do not have to make any additional settings.

You want to perform results analysis for a WBS element (nonvaluated project stock). Production orders whose actual costs should be included in results analysis are assigned to the WBS element.

There are individual worklists for each processing step sequence (that is, each flow definition). Typical processing step sequences are the period-end closing sequences for the individual application components. Individual worklists are created for each application (for example, for internal orders and projects).

The multilevel worklist fulfills the following basic requirements:

- The selected objects are processed as far as possible.
- The selected objects are only processed when processing is both necessary and possible.
- Object dependencies are taken into account.

Object dependencies can be encountered, for example:

- In engineer-to-order environments
- When you are using cost object hierarchies
Suppose you are performing results analysis for WBS elements in an engineer-to-order environment. The system first determines which WBS elements are relevant on the basis of the selection criteria. These WBS elements are called primary objects because they are the original objects to be processed.

Results analysis also includes values that are posted to the production orders assigned to the WBS elements. These production orders are selected on the basis of their dependency on the WBS element. They are called secondary objects.

The determination of secondary objects depends not only on the type of worklist (for example, cost object hierarchies, projects), but also on the present business function and on the processed objects.

Suppose you are performing period-end closing for a cost object hierarchy. You calculate the actual overhead at the level of the cost object nodes. In this case, there are no dependent objects because every cost object node is included in overhead calculation. Relationships to other cost object nodes do not play a role.

You also want to distribute the actual costs assigned to the cost object nodes to the lowest cost object nodes of the assigned product cost collector. The following situation arises during distribution:

As soon as a cost object node in a cost object hierarchy is a primary object, all other nodes are secondary objects (as long as they are not also primary objects).

During the execution of the flow definition, the individual processing steps receive a list of the objects to be processed. Each processing step sends the processing status of each object and a list of the displayed messages back to the worklist.

The scope of selection can contain all objects to be processed in a particular flow. However, in some situations you may want to perform the same flow more than once in parallel with different scopes of selection. This manual parallel processing can serve to reduce the overall run time.

Suppose you want to perform period-end closing for the application component Product Cost by Order in Cost Object Controlling. You can process all production orders and process orders in a plant, or all plants in a controlling area.

You create multiple scopes of selection in which you select by plant and order type. This means that, for example, one scope of selection includes all production orders in a plant, while another scope of selection includes all process orders in that same plant.

The previous processing step in the sequence must be fully completed before the next step can be started.

After the entire processing step sequence has been executed, the user forces a manual check.
Multilevel Worklist

The user-defined flow of individual processing steps (specified in the flow definition), the check of the objects with errors, as well as the release of this check (for renewed processing of objects) should be repeated until all objects in all processing steps have the status OK. Once this is achieved, processing is completed.

Processing of Objects in the Worklist

You process the worklist in the monitor. The monitor shows a list of the faulty objects and the messages issued for the objects. This information is needed for analyzing and correcting the errors.

In the monitor, you can specify how objects are to be processed the next time the processing step sequence is executed. For example, you can specify the following:

- That objects marked as faulty in a given processing step are excluded the next time that processing step is executed, and instead enter the subsequent processing step.
- That objects processed without errors are nevertheless reprocessed if they are faulty in a business sense (for example, as a result of incorrect Customizing settings)

If an object was processed without error in an update run for project interest calculation, new interest calculation can only be triggered if the previous interest calculation is first reversed. If no reversal is carried out, the object is not included in the recalculation of interest even though its processing status would normally allow this.

You control this through the processing status for the object and processing step.

Note the following:

If an object has been changed since it was processed in the processing step sequence defined by the flow definition (for example, additional costs have been assigned to the object), this change is not taken into account if the object has already been processed without error. In this case, you should change the processing status for the first processing step of the processing step sequence to force reprocessing.

See also:

See the following sections for additional information on the monitor and how to use it:

Schedule Manager: Monitor - Working with the Object List [Seite 358]
Processing Worklists [Seite 361]
Processing Status [Seite 372]

Triggering Reprocessing of Objects

Automatic Reprocessing

Once all objects have been processed and you have corrected the errors or specified that the processing step for which errors were issued should be skipped, the processing step sequence can be repeated in order to reprocess the objects that had been faulty in the previous run. You initiate reprocessing from the mail.
The system then processes the objects in the selection scope that had been processed with errors in the first run of the processing sequence and those that you instructed the system to reprocess (processing forced manually). For each object, processing starts with the processing step that had errors or for which processing was forced manually. The only processing steps repeated for an object are those for which errors occurred in the previous run, those that have not yet been performed, and those for which reprocessing was forced.

Both in the first run and in the repeated run, the only objects that are processed in each processing step are those that were successfully processed in the previous step and that have not yet been successfully processed in the current step. This limits the number of objects to be reprocessed in each step to those for which errors appeared in that step or in the preceding steps of the first run. Dependencies between objects are also taken into account. That is, depending on the object to be processed and the processing step, it may be necessary to reprocess additional objects even though they were already processed successfully.

**Administrative Data Reorganization of the Multilevel Worklist**

The administrative data of multilevel worklists encompasses the scope of selection, the step information (flow step), the processing status for the object, and the error messages for the object. This administrative data is deleted together with the workflow data of the Schedule Manager. It is not possible to archive the worklists.

**Activities**

Once all processing steps have been executed, the system informs you by mail that the results of the processing steps are ready for review. After you have checked the results and corrected any errors, the system asks you whether you would like to repeat reprocessing.

To make the relevant checks, access the monitor of the Schedule Manager.

You can access the monitor in the following ways:

- From the mail
- Directly from the menu of the application component

**See also:**

Multilevel Worklist: Process Flow [Seite 356]
Multilevel Worklist: Process Flow

Prerequisites
You have created a flow definition [Seite 323]. In the flow definition, you define the sequence of processing steps that you want to perform. A processing step corresponds to a single function. Examples of individual processing steps are WIP calculation, variance calculation, and settlement. A processing step sequence is defined by linking these single functions to each other in a flow definition.
You have established the flow definition in the scheduler [Seite 298].

Process Flow
1. The system starts the sequence of processing steps in accordance with the planning specified in the scheduler. The objects to be processed are selected on the basis of the following logic:
   - Objects that were processed successfully in the previous flow step but have not yet been processed successfully in the current flow step are transferred from the selection to be processed. These objects are called primary objects.
   - The system also reads the dependent objects for the current flow step for all selected objects. These dependent objects are called secondary objects. If a primary object has one or more secondary objects that were not successfully processed in the previous flow step, neither the primary object nor its associated secondary objects can be processed in the current flow step.
2. The system executes the processing steps.
3. When the system has executed all processing steps, you receive a mail to inform you that the planned sequence of processing steps has been completed. This mail is generated using the workflow link.
4. You can reprocess the faulty objects directly from the mail.
5. The user can view the processed objects with their processing status in the monitor of the Schedule Manager.
6. The user processes the objects with errors.
7. The user retriggers the processing step sequence from the mail in his office inbox.
8. The system now processes the objects in the selection that were processed with errors in the first run of the processing sequence, or whose processing was forced manually.
   - For each object, processing starts with the step that was not processed correctly.
   - The subsequent processing steps are then started automatically in the defined sequence.

💡
If an object that was processed without errors in the first run of the processing step sequence is changed before the second run of the processing step sequence, these changes do not result in an automatic reprocessing of the object. If you want the object to be reprocessed, manually set the corresponding processing status.
The production order 1000000 is included with all other production orders of plant 1000 in period-end closing of Product Cost by Order. Work in process for the order is calculated as EUR 1,000 and settled to Financial Accounting (FI). All processing steps (for example, WIP calculation and settlement) of the processing step sequence were also performed without out errors.

However, not all production orders were processed without errors. In this way, for example, the production order 1000005 receives the processing status error for the processing step WIP calculation and the production order 1000010 receives the processing status error for the processing step Settlement.

After work in process has been settled for all production orders, including production order 1000000, additional costs amounting to EUR 200 are posted to production order 1000000.

Remove the errors for the production orders 1000005 and 1000010 and reinitiate the processing step sequence. The production orders 1000005 and 1000010 are reprocessed. Production order 1000000 is not processed as it was processed without errors in the first run.

If you want to force a reprocessing of production order 1000000, you can manually set the corresponding processing status.

See also:

Schedule Manager: Worklist [Seite 343]
Schedule Manager: Monitor - Working with the Object List [Seite 358]
Processing Status of Objects and Processing Steps [Seite 372]
Processing Worklists [Seite 361]
Monitor - Working with the Object List

Definition

The monitor of the Schedule Manager is a tool for processing multilevel worklists. It contains information on active or completed jobs that were planned in the scheduler.

Use

This section provides information on using the object list in the monitor of the Schedule Manager. For more information on jobs in the monitor, see Using the Monitor [Seite 316].

The monitor performs the following functions:

- Displays the available worklists and their processing steps
- Keeps track of the processing status of each object (such as product cost collectors, WBS elements, internal orders, and production orders) and each processing step
- Assists you in analyzing the causes of errors for the objects and processing steps
- Displays the processing status of objects (particularly for the objects with errors)
- Shows the hierarchical relationships between the objects
- Compares object hierarchies with each other
- Controls whether objects enter the next processing step
- Sends objects to the responsible person for further processing

You can set the processing status so that objects of negligible value, for example, are not reprocessed in a processing step even if errors are issued for the objects in that step. In this case, it is not necessary to remove the cause of the error.
The monitor is divided into the following screen areas:

**Structure Tree with Worklists/Processing Steps/Jobs**

The structure tree containing the worklists, processing steps and jobs is displayed on the left side of the monitor.

In the system, the worklists are updated separately for each scope of selection and processing step sequence. The processing step sequence is specified in the flow definition. You can view the worklists of the application component in which you are working, including their functions and objects.

The system displays the following information on each worklist:

- Number of objects in the worklist
- Processing steps
- Number of objects processed in each processing step
- Number of objects with errors in each processing step

**Object List**

The object list is located in the top right area of the screen. The object list can display one or more processing steps of a worklist. You select the processing steps in a worklist in the structure tree `worklists/processing steps/jobs`.

The object list includes the following information:
Monitor - Working with the Object List

- The objects for the selected processing steps. You can control which objects are displayed for each processing step by means of a filter that takes the individual processing statuses into account. In application toolbar icons for object list, choose the icon Objects: Set status filter.
  The system uses the last user-specific default setting of the dialog box. Note the default settings of this dialog window in the SAP standard system. The last user-specific setting of the dialog box is the default.
- The processing step performed for the object
- The processing status of the object for each processing step
- A check box you can select to indicate that you have processed the object in the worklist monitor
- The person responsible for the object (if any)

**Message List**

The message list is located in the lower right-hand portion of the screen. The message list displays messages for certain objects. You can use these messages to analyze the causes of error for each object and processing step.

**See also:**

- Schedule Manager: Multilevel Worklist [Seite 343]
- Multilevel Worklist: Process Flow [Seite 356]

For detailed information on using the monitor of the Schedule Manager, see the following section:

- Processing Status of Objects and Processing Steps [Seite 372]
- Processing Worklists [Seite 361]
Processing Worklists

Use
You process worklists in the monitor of the Schedule Manager.

Navigating to the Monitor

Procedure
1. You can access the monitor in the following ways:
   a. In the Schedule Manager, there are three ways of accessing the monitor from the screen Schedule Tasks for Task List: By selecting a calendar day, selecting the desired tasks in the daily overview, and then choosing Monitor daily overview in the application toolbar; by choosing the Monitor icon above the daily overview; or by double-clicking on a task in the daily overview.
   b. From the menu of the application component. For example, to access the worklists of the Product Cost by Period component, go to the menu of Product Cost by Period and choose Period-End Closing → Schedule Manager → Worklist Monitor. Choose the following: Product Cost Collector or Cost Object Hierarchy. The screen Select Worklist appears. In the selection screen, use the possible entries function for the Application field to select the application component for which you want to call up the worklist (such as Cost Object Controlling: Manufacturing Orders and Product Cost Collectors). Usually the appropriate application will already be shown as a default. Enter the additional selection criteria such as the period and fiscal year, and choose Enter. You can further restrict the selection with the icon Further selection criteria.

Result
The screen Schedule Manager: Monitor appears.

Working with the Monitor of the Schedule Manager

Using the Monitor
The monitor enables you to analyze the objects processed in a worklist and control how the objects are processed further. The focus is on the objects for which errors were issued.

Objects for which errors were issued in a processing step do not enter the next processing step.

You can analyze and correct the error, or you can instruct the system to skip processing (that is, not to process the objects in the corresponding step). Skipping processing can be appropriate for objects that have errors but whose value is negligible.

You instruct the system to skip processing by setting the processing status to skip processing. The system then processes the object in the next processing step as if it had been processed without errors in the previous step.

If the object is part of a hierarchy, this can also prevent the object from stopping the entire hierarchy from being processed.

The functions hierarchy display and hierarchy comparison provide support when you search for errors.
Processing Worklists

When actual overhead rates were calculated in the period-end closing process, one production order was not processed due to faulty Customizing settings. The production order is assigned to a WBS element. When the cost accountant reviewed the objects in the monitor, he decided that the missing overhead is insignificant and can be disregarded, since the effort involved in finding and correcting the error would be out of proportion to the amount in question. The faulty production order should therefore be included in results analysis for the WBS element. To prevent the entire project to which the production order is assigned from being excluded from processing, the accountant sets the processing status of the production order for the step **overhead** to *Skip processing*.

On the other hand, it may sometimes be necessary to process an object again even though it has been processed without error. You do this by setting the status *Repeat processing*. This can be appropriate in cases where incorrect Customizing settings have resulted in improper values. The processing steps only recognize errors that are indicated as errors in the monitor. However, an object can be faulty in a business sense without necessarily generating an error message. Such errors can only be found by checking the results by hand.

In the flow definition, you can specify that a manual check (usually by the cost accountant) should take place after certain processing steps.

To force renewed processing of the object after correcting the error (in our example, this would involve selecting another results analysis method in Customizing), you change the processing status to *Repeat processing*.

Suppose you want to calculate results analysis data for a WBS element. In Customizing, you selected a results analysis method that causes unrealized profits to flow into inventory valuation. However, you don’t want unrealized profits to be inventoried.

It may also be necessary to force an object to be processed due to the fact that postings which debited an object after period-end closing made the period-end closing data obsolete.

Suppose you have performed period-end closing for a production order. All processing steps of the production order were performed without error. The production order is then debited with additional costs that must be accounted for in period-end closing. You must therefore force the system to repeat the processing steps for the production order. In this case, you only need to force a repeat of the first processing step of the sequence. The production order is automatically included in all subsequent processing steps.

The monitor of the Schedule Manager is divided into three screen areas:

- Structure tree with worklists/processing steps/jobs
- Object list
- Message list (you have the choice between object messages, step messages, and messages of the originating objects)
Structure of the Monitor

(see also: Schedule Manager: Monitor - Working with the Object List [Seite 358])

Different functions are available in each screen area. These functions are described in the Procedure section below.

Procedure

Displaying Objects for One or More Processing Steps

You want to view the processed objects for one or more processing steps.

In the object list, you can choose to view all processed objects or only the objects with errors, for example, for one or more processing steps. Since the worklist’s primary function is to assist you in analyzing the objects with errors, you should limit yourself to viewing only the objects that have errors. If you choose to view all processed objects, this will reduce system performance.

With the default settings of the standard system, objects with the following processing statuses are displayed:

- Flagged for postprocessing
- Processing forced manually
- Error
- Followup error
Processing Worklists

- Hierarchy error
- Minor error

For detailed information on the processing statuses updated for the objects, see the following section: Processing Status for Objects [Seite 372].

To view the objects, proceed as follows in the structure tree worklists/processing steps/jobs:

Double-click on a processing step in the structure tree with worklists/processing steps/jobs to generate the object list for that processing step. If there are any messages that refer to the processing step as a whole (rather than to specific objects), they are displayed in the message list.

Double-click on a worklist in the structure tree with worklists/processing steps/jobs to generate the object list for all processing steps. If there are any messages for the worklist, they are shown in the message list.

You can also select the processing steps with the context menu. Proceed as follows:

a) To display all processing steps for the objects in a worklist:

Select a worklist with the right mouse button and choose Object list - All steps in the context menu. The object list for the worklist is generated.

The object list can display up to ten processing steps. If there are more than ten steps, the dialog box Select Processing Steps appears, in which you can select a maximum of ten steps.

a) To display individual processing steps for the objects in a worklist:

If you don’t want to see all processing steps for a worklist, select a worklist with the right mouse button and choose Object list - Select steps in the context menu. The dialog box Select Processing Steps appears, in which you can select a maximum of ten steps.

When you process worklists for manufacturing orders, the object list has a column for the material number. The material shown in this column is usually the material that is manufactured with the order shown in that row.

In joint production, the column shows the following:

- For the order header (i.e., for the object "ORD order"):
  - If a process material is being used, the process material is shown.
  - Otherwise the leading co-product is shown. The leading co-product is the co-product shown in the first order item.
- For the order item (i.e., for the object "OIT order item"), the material produced with that order item is shown.

Displaying the Processing Status for Each Object and Processing Step

The object list shows the processing status for each object and processing step. A column is displayed in the object list for each processing step selected in the structure tree.
**Processing Worklists**

worklists/processing steps/jobs. This column shows the processing status of each object. The processing statuses are represented as icons. If you want to know which processing status is assigned to which icon, then click on the corresponding Legend icon above the object list. The screen Processing Status: Icon Legend appears. The icon in the dialog box provides explanations of the processing statuses.

For detailed information on processing statuses, including examples, see the following section: [Processing Status for Objects][Seite 372]

**Filtering Objects**

You can also display objects of other processing statuses through a status filter. To do so, click on the filter icon (Objects: Set status filter) above the object list. Select the relevant processing status and press Enter. All objects that have the corresponding processing status are displayed in the object list.

You can also filter objects according to criteria other than the processing status (function of the ABAP List Viewer).

**Deciding Whether to Process Objects Further**

You now have a list of objects. These are normally the objects with errors. You must decide whether to continue processing these objects. You have the following options:

- You correct the errors.
- You instruct the system to continue processing the objects even though you have not corrected the errors. This is appropriate for objects whose value is insignificant.

Reports on the objects are available to help you reach a decision.

**Executing Reports**

Reports can help you determine the following:

- Whether the value of the object is negligible
  
  In this case, you instruct the system not to process the object. Otherwise, you correct the error.

- Whether the values calculated for an object are acceptable in a business sense. You may also want to do this for objects that were processed without error (processing status OK).
  
  If this is not the case, then once you have corrected the problem (the error may have been caused by faulty Customizing settings), you can force further processing. You can also assign further reports with the function report assignment (if supported).

To view a report on an object, position the cursor on the object in the object list and click on the execute report icon above the object list. Then enter the required parameters and select the report you want to see (only for projects; production orders do not allow reports to be selected). On the basis of the data in the report, you can now decide how the object is to be handled.

To analyze the error for the objects with the processing status Error, look at the messages for the object and processing step.

**Messages for One or More Objects**

To see the messages that were issued for one or more objects:

1. Select the objects.
Processing Worklists

In the object list, select an object by positioning the cursor on the object, holding down the left mouse button, and pressing the Ctrl key on the keyboard. Continue to select further objects in the same way.

2. View the messages.

To see the messages for the selected objects, click the Display object messages icon above the object list. You can also display the messages for one line of the object list by double-clicking on the line.

In the pull-down menu of the Display object messages icon above the object list, you can choose between the following types of messages:

- Object messages
- Step messages
- Messages of originating objects

The object messages appear in the message list.

3. View the long text of the messages.

To analyze the error, you will normally need to look at the long text of the message. To see the long text, double-click on the message in the message list.

Step-Specific Messages (Messages Without Reference to a Specific Object)

To see the messages for a particular processing step, go to the object list and choose the drop-down menu of the Display object messages icon, and then choose Display step messages. The step-specific messages are displayed in the message list.

Messages of Originating Objects

You should look at the messages of the originating objects particularly when you want to analyze objects with the processing status Followup error.

Skipping Processing Manually

You have decided to have the system skip a processing step for one or more objects.

- In the object list, select the step statuses that you want to change. Click the icon Set processing status.

If you select the status Skip processing, the system changes the processing status to Skipped manually. The object is not included in this processing step during the next execution of the processing step sequence. The object enters the subsequent processing step as if it had been processed without errors.

Forcing Processing Manually

There are two ways to force the system to reprocess objects:

Position your cursor in the object list and press the right mouse button. In the context menu, choose Repeat processing. The system changes the processing status to Postprocessing forced manually. The next time the processing step sequence is performed, the object is included in that processing step and in all subsequent processing steps.

You can also force the system to process objects by selecting the objects and clicking the icon Set processing status (icon in the object list) and choosing Repeat processing. You can select multiple objects at the same time with the following methods:
To select an entire column, click on the column header.
To select individual columns, lines, or cells, hold down the Ctrl key and click.

The system changes the processing status to Postprocessing forced manually. The next time the processing step sequence is performed, the object is included in that processing step and in all subsequent processing steps.

**Editing Master Data**

From the object list, you can access master data maintenance for the object. To do so, position your cursor on the relevant object and click on the Edit master data icon above the object list. The system starts a new session. You are now in the change mode of the relevant object. You can close the session by going back (green arrow).

The error message Maintain the settlement rule of the sender is issued for a production order for the processing step Settlement. To maintain the settlement rule, call up the production order.

**Display as Hierarchy**

In the hierarchy view, the objects are displayed according to their hierarchical relationship to each other.

Select one or more objects in the object list and choose Display as hierarchy. The screen Object list - hierarchy view appears. In the hierarchy view, the object or objects you branched from are selected.

Expand the object hierarchy. This provides a quick overview of the relationships between the faulty objects. You can process objects to which a particularly large number of faulty objects are assigned.

To go back to the object list from the hierarchy, choose Back to object list.

In the object list hierarchy view screen, you can only change the processing status of individual objects. Mass changes to the processing status of the objects is only possible in the object list.

In addition, a requirement for the display hierarchy function is that the objects have hierarchy information in the worklist. This is the case in the Project System and for cost object hierarchies.

**Hierarchy Comparison**

Objects that have hierarchy information (such as projects and cost object hierarchies) can be compared with each other using the hierarchy comparison function. This allows you to more efficiently find errors that are due to differences in the values of two periods. Comparing the data of two periods is particularly useful because the items and values of the objects in the hierarchy can change between periods.
Processing Worklists

In the project system, it is also possible to compare two versions of an original structure. The changes that were made to the version are shown in a separate window.

Before you start the comparison, you specify which two data structures you want to compare. You define one of the two structures as the original structure and the other as the version. During the comparison, the two structures are represented in the form of a hierarchical structure tree in a separate screen area. You can compare individual objects, subhierarchies, or the two complete structures. The results of the comparison are grouped into different categories:

- New objects (which objects were added to the version?)
- Changed objects (which object attributes were changed, and how?)
- Nonexistent objects (which objects do not exist or were deleted?)
- Hierarchy position of changed objects (which objects changed their position in the hierarchy?)

For detailed information on the hierarchy comparison, see the documentation under:

Logistics → Project System → Collaborative Engineering and Project Management → Monitoring → Comparing Two Folders

The Schedule Manager only supports the comparison function; synchronization is not possible.

Sending Objects

Select one or more objects in the object list and choose the Send icon above the object list. To receive a log of the transmission, choose Send log. If you choose Send to agent, the person responsible for the object receives a mail in his or her inbox (Office → Workplace → Inbox) with information on the required change. From this mail, you can access the screen Schedule Manager: Monitor which displays only the sent objects. Note that the filter function in the icons of the object list (Objects: Set Status Filter) is not available when you access the monitor through your office inbox.

To be able to use the function for sending objects, the following settings must be made in each client:

2. Select task type Workflow template and enter task 20001060 (SCMA_WL_DISP). The screen Workflow Template: Change appears.
3. Select the tab Triggering events. Activate the event linkage by clicking the icon Event linkage active in the first column. The light symbol changes to green.
4. Save the data.

If no agent can be determined for the object, the dialog box Entry of Responsible Agent appears, in which you can specify the user responsible for further processing.

The object list contains the field Agent ID next to the existing column headers. This field shows the agent responsible for the object. The agent can be an R/3 user or a node in the organization plan.
Processing Worklists

On the basis of the organizational data of the objects (such as the plant, company code, and so on), you can specify criteria for each object type that are used to determine the agent.

You specify the agents responsible for the objects under:

Schedule Manager → Extras → Settings for worklist → Maintain responsibilities for objects.

For detailed information on maintaining responsibilities, refer to the SAP Library under:

Human Resources → Personnel Management → Organizational Management → Integration with SAP Business Workflow → Role Resolution → Role Definition → Define Roles Using Responsibilities

Define Roles Using Responsibilities [Extern]

Flagging Checked Objects

You can flag objects to indicate that you have checked them.

To do this, either select the check box **Object checked** directly, or select one or more objects and click the icon **Change "checked" indicators** and then in the pull-down menu:

- **Select indicators**: selects the check boxes for the selected objects
- **Deselect indicators**: deselects the check boxes for the selected objects
- **Toggle checked <-> not checked**: Toggles the status for the selected objects

The indicators are only visual and have no effect on processing.

Displaying Other Worklists

To display other worklists, click the **Other worklist** icon at the top of the screen. The enter the required data and choose **Enter**. This function is only available when you access the Schedule Manager through the application components. When you access the Schedule Manager through a mail in your Office inbox, this function is **not** available.

Triggering Reprocessing of the Worklist

Prerequisites

Before you trigger reprocessing of the worklist, you must have done the following:

- Corrected the errors of the faulty objects, or instructed the system to skip processing for those objects
- Forced reprocessing of objects that are faulty in a business sense

Procedure

To trigger reprocessing, access the mail that was sent to you through the workflow. Start reprocessing from this mail.

Result

The following objects are processed:

- Objects that had errors in the previous execution of the processing step sequence and whose errors have been corrected
  
  These objects are processed starting with the processing step in which the error occurred.
Processing Worklists

- Objects that had errors in the previous execution of the processing step sequence and for which the processing status *Skip processing* was set
  These objects are processed starting with the processing step following the processing step for which the status *Skip processing* was set.

- Objects that received the status *Postprocessing forced manually*
  These objects are processed starting with the processing step for which the status *Postprocessing forced manually* was set.

See also:
Many of the icons displayed above the individual screen areas support the standard functions of the ABAP List Viewer (ALV). These icons are not explicitly explained here. The same applies to the standard ALV functions in the context menu (right mouse button). For information on the ALV, refer to the SAP Library under *Cross-Application Components (CA) -> General Application Functions -> ABAP List Viewer*, or under: [Functions of the ABAP List Viewer](http://example.com)
Choosing Objects for Processing

Use
An advantage of this worklist [Extern] is that the objects for processing only have to be selected once per flow definition.

Prerequisites
You are in flow definition [Extern] in Schedule Manager (Extras → Flow definition → Edit flow definition).

Procedure
20. Choose a processing step in the navigation area. On the right of the screen, you see Flow definition: Task details.
21. Enter a new variant for this processing step and define a name for this new variant in the Variant field.
22. Choose Create variant. The Variant Maintenance screen appears. Program <program name>, variant <variant name>. Here you can determine the scope of selection of the program variants for the flow definition.
23. To be able to choose more extensive selection criteria, first complete the required entry fields, for example Period <006>, Fiscal year <2000>.
24. You can now define further selection parameters using the various pushbuttons that are offered in dialog boxes.
25. Choose Attributes. The ABAP: Save Attributes of Variant <Variant name> screen appears.
Processing Status of Objects

Use

The processing status of an object tells you whether processing was successful in a specific processing step.

For every object listed in the worklist of the Schedule Manager [Seite 343], a processing status is indicated for each processing step. The system sets the processing status during processing. This status can be changed manually in the monitor.

In addition to information on the success of processing, the processing status shows whether further processing of an object is allowed. This ensures that an object which was not processed in a processing step due to errors is not passed on to the next step.

Integration

The processing status is displayed in the monitor. The status is not updated to the processed object. For more information on the monitor, see the following section: Schedule Manager: Monitor - Working with the Object List [Seite 358]

The examples described below are based on the use of the multilevel worklist in Cost Object Controlling and the Project System.

Features

Through the processing status, the worklist of the Schedule Manager controls whether an object is processed in the following processing step. The system automatically sets the following processing statuses:

Automatic Processing Statuses

- Not processed
  The object has not been processed yet.

- OK
  The object was processed without errors.

- Minor error
  A warning or error occurred while the object was being processed. However, this error does not prevent further processing in a following step.

- Flagged for postprocessing
  This status is set in the following case:
  The object must be processed in a processing step because, for example, processing was forced. In the subsequent processing step, the object has one of the following processing statuses:
  - OK
  - Not relevant
Minor error

Since the object normally would not be processed when it has this processing status, the system sets the processing status of the subsequent processing step to *Flagged for postprocessing*. This ensures that an object processed in one step is always included in the subsequent processing steps. The processing status is reset to *Flagged for postprocessing* regardless of whether the object was changed in the previous processing step.

Error

An error occurred while the object was being processed that prevents further processing. You can either correct the error or instruct the system to include the object in the subsequent processing step despite the error (processing status *Processing skipped manually*).

Followup error

An object receives the processing status *Followup error* for a processing step if it belongs to a group of objects that are processed together and this group contains one or more objects that were processed with errors (processing status *Error*), or were not processed, in the previous processing step.

The object with the processing status *Followup error* is not processed in the processing step for which it received that error. This ensures that the entire group of objects can only be processed when none of the objects contains an error that hinders the processing of an object in the group.

See the end of this text for an example of the processing statuses *Followup error* and *Hierarchy error*.

Hierarchy error

An object receives the processing status *Hierarchy error* for a processing step if it belongs to a group of objects that are to be processed together and this group contains one or more objects that were processed with errors in the current processing step (processing status *Error*).

The object with the processing status *Hierarchy error* is not processed in the processing step for which it received that error. This ensures that the entire group of objects can only be processed when none of the objects contains an error that affects processing.

See the end of this text for an example of the processing statuses *Followup error* and *Hierarchy error*.

Filtered

The user has excluded the object from processing by defining an application-specific filter.

Not relevant

- The object is not relevant for processing in this processing step due to its attributes derived from Customizing or master data.
- The object is not relevant due to a status that has been set for it.
Internal Orders (CO-OM-OPA)

Processing Status of Objects

Example 1:
According to the selection parameters, all production orders of a plant are selected for variance calculation in period-end closing of Product Cost by Order. No variance key has been specified for some of the production orders. These production orders are not included in variance calculation. The production orders receive the processing status Not relevant.

Example 2:
According to the selection parameters, all production orders of a plant are selected for overhead calculation in period-end closing of Product Cost by Order. A system status or user status is set for some production orders, which does not allow processing. Examples of this are the system statuses open, closed, deletion flag and locked.

In some cases, a given status may make an object relevant or irrelevant only in certain processing steps.

Example:
A production order has a settlement rule with the settlement type FUL (full settlement). If neither the status DLV (delivered) nor the status TECO (technically completed) is set for the object, it is not relevant for variance calculation and receives the corresponding processing status. The order is relevant for the other processing steps of period-end closing such as template allocation, overhead calculation, calculation of work in process and settlement, regardless of whether one or none of the two statuses is set.

As a rule, with the processing status not relevant, no messages are issued for the object and processing step. To see the messages that caused the processing status to be set to not relevant, you can have the system process the object individually. Possibly, you can also force the issuance of messages through user-defined error management by putting the message type at the top.

For WIP calculation and results analysis, you can force the system to issue messages despite the status not relevant. You can guarantee the issuance of messages by setting the indicator Log information messages. If the indicator is set, all information messages are issued including those from processing within and outside of the multilevel worklist, even if the status not relevant is set for an object and processing step.

Manual Processing Statuses

You can set the following processing steps manually:

- Processing skipped manually
In the object list, the user manually sets the processing status of an object and processing step to *Skip processing*. The system changes the processing status to *Processing skipped manually*.

The object with this processing status is not included in the relevant processing step, and enters the next processing step.

- **Processing forced manually**

In the object monitor, the user manually sets the processing status of an object and processing step to *Repeat processing*. The system changes the processing status to *Processing forced manually*. The object is processed in the relevant processing step again even if the processing step had been executed without error.

If an object was processed without error in an update run for project interest calculation, new interest calculation can only be triggered if the previous interest calculation is first reversed. If no reversal is carried out, the object is not included in the recalculation of interest, despite its processing status.

**Example**

Example of the processing statuses *Follow-up error* and *Hierarchy error*:

During the calculation of actual overhead rates in period-end closing, a production order assigned to a WBS element was not processed due to deficient Customizing settings. The production order receives the processing status *Error* for the processing step *Actual overhead*.

In addition to this production order, other production orders are also assigned to the WBS element. All other production orders assigned to the WBS element receive the processing status *Hierarchy error* for the processing step *Actual overhead*. This status indicates that an object of an object group (all production orders assigned to a WBS element) contained errors in the processing step.

The processing step following the processing step *Actual overhead* is *Results analysis*. During results analysis for the WBS element, the data is included that was updated to the production orders assigned to the WBS element. Because one of the production orders assigned to the WBS element was marked as faulty and all other production orders received the corresponding processing status *Hierarchy error* in the processing step *Actual overhead*, the processing step *Results analysis* can not be carried out successfully for the WBS element.

The WBS element receives the processing status *Followup error* for the processing step *Results analysis*.

If you decide that the deficit resulting from the missing overhead is so low that it can be ignored, you can avoid time-consuming error analysis by specifying a processing status that prevents the production order from being included in the calculation of overhead. All production orders, including the one for which no overhead was calculated, are included in results analysis.

If the value of the production order is significant, you must remove the cause of error.

**Additional Information**

Note the following:

- There is no one-to-one assignment of message types to processing statuses in the worklist of the Schedule Manager. For example, not every message of message type "E" (error)
Processing Status of Objects

results in the processing status Error for an object in the Schedule Manager in that processing step.

The system issues the message CK 214 as an error message.

If this message is based on target cost version 0 in variance calculation, the processing status Error is set in the worklist of the Schedule Manager.

If this message is based on a target cost version in variance calculation that is not 0, the processing status Minor error is set in the worklist of the Schedule Manager.

- Some messages are issued with different message types based on the object to be processed. Different processing statuses are set in the Schedule Manager.

In variance calculation, if message KV 158 is based on a single production order, the system issues this message as an error message. The processing status Error is set in the worklist of the Schedule Manager.

In variance calculation, if this message is based on a product cost collector to which multiple production orders are assigned, the system issues a warning message. The processing status OK is set in the worklist of the Schedule Manager.

Note the following:

If you are using the multilevel worklist of the Schedule Manager, the objects with the processing status Error for a processing step are not processed in the subsequent step. In many cases, the processing status Error is set because a message was issued with the message type “E” (error). When calculating variances and scrap variances, you can use user-defined error management to influence the message type for a large number of messages in the worklist of the Schedule Manager, this can result in a different processing status being updated to the processing step. This enables you to ensure that objects are processed in the subsequent processing step, for example.

A message was issued as an error message in variance calculation. The processing status Error is issued in the monitor.

The error is not serious, so you decide that the object should be processed in the next processing step. You therefore use user-defined error management to specify a message type of lower severity (such as "W" for a warning message). This ensures that the object does not receive the processing status Error for the processing step in the worklist due to this message. The object then enters the subsequent processing step.

No Processing Status Output

It may occasionally happen that no processing statuses are issued. See the following for an example of this: Separation of Value Calculation from Goods Movements: Effects on Cost Object Controlling [Extern].

See also:

For information on the following topics and many others, see the section Processing Worklists [Seite 361]:

376 April 2001
• When processing should be skipped or forced manually
• How to decide whether to do so
• How you can change the processing status

For detailed information on user-defined error management, see the following section:

User-Defined Error Management in Cost Object Controlling [Extern]
Scenarios for the Schedule Manager

Purpose
You can use the elements of the Schedule Manager in different scenarios in various combinations.

Prerequisites
You are working on a complex process, which consists of many different business transactions (tasks).

Process Flow
You decide which functions (scheduler [Seite 298], monitor [Seite 316], flow definition [Seite 323], multilevel worklist [Seite 343]) you require to execute and monitor your process.

You can choose between three scenarios:

- Starting Transactions/Reports Online, Scheduling Jobs [Seite 379]
- Starting Transactions/Report Online, Scheduling Jobs and Job Chains [Seite 380]
- Starting Transactions/Reports Online, Scheduling Jobs and Job Chains, Worklist [Seite 381]
Starting Transactions/Reports Online, Scheduling/ Monitoring Jobs

Use
Not only can you start transactions and reports online, and schedule jobs in the task list with this scenario, but you can also monitor the scheduled jobs in the monitor [Seite 316] while they are being executed.

Integration
You need the scheduler [Seite 298] and monitor from the Schedule Manager for this scenario.

Prerequisites
The application contains reports for your processing, which you can schedule as jobs.

Features
This scenario contains the following work steps:
- Creating a Task List [Seite 302]
- Inserting a Task/Task Group in the Task List [Seite 303]
- Scheduling Tasks in the Daily Overview [Seite 311]
- Monitoring Jobs in The Monitor [Seite 316]

Activities
In this scenario, you choose a task list in the scheduler or create a new task list.
You insert tasks in the daily overview. You can monitor the jobs in the monitor by selecting a task with the right mouse button and choosing Monitor.
Starting Transactions/Reports Online, Scheduling Jobs/Job Chains, Monitoring Jobs

Use
Not only can you start transactions and reports online, and schedule jobs/job chains from the flow definition in the task list with this scenario, but you can also monitor the scheduled jobs in the monitor [Seite 316] while they are being executed.

Integration
For this scenario, you need the following elements: the scheduler [Seite 298], the monitor of the Schedule Manager [Seite 316], and the flow definition [Seite 323].

Prerequisites
The application contains reports for your processing, which you can schedule as jobs.

Features
This scenario contains the following work steps:
- Creating a Task List [Seite 302]
- Inserting a Task/Task Group in the Task List [Seite 303]
- Scheduling Tasks in the Daily Overview [Seite 311]
- Monitoring Jobs in The Monitor [Seite 316]
- Creating a Flow Definition [Seite 323]

Activities
In this scenario, you choose a task list in the scheduler or create a new task list.
You insert tasks in the daily overview. You can monitor the jobs in the monitor by selecting a task with the right mouse button and choosing Monitor.
You can also insert job chains (that you specified in a flow definition) into the task list and schedule them in the daily overview. You can also use the monitor to check processing of the job chains.
Starting Transactions/Reports Online, Scheduling Jobs and Job Chains, Worklist

Use
Not only can you start transactions and reports online, and schedule jobs in the task list with this scenario, but you can also monitor the scheduled jobs in the monitor [Page 316] while they are being executed. You can also use worklists and check them in the object monitor [Page 358] in the generalized worklist.

Integration
For this scenario, you need the scheduler [Page 298], the monitor of the Schedule Manager, the flow definition [Page 323] and the multilevel worklist [Page 343].

Prerequisites
The application contains reports for your processing, which you can schedule as jobs.
You are using worklists.

Features
This scenario contains the following work steps:
- Creating a Task List [Page 302]
- Inserting a Task/Task Group in the Task List [Page 303]
- Scheduling Tasks in the Daily Overview [Page 311]
- Monitoring Jobs in The Monitor [Page 316]
- Creating a Flow Definition [Page 323]
- Working with the Worklist Monitor [Page 358]

Activities
In this scenario, choose a task list from the scheduler, or create a new one. Only use task lists that have the task type flow definition.

You insert tasks in the daily overview. You can monitor the jobs in the monitor by selecting a task with the right mouse button and choosing Monitor.

In addition to the scheduler, monitor and flow definition, you can also work with a generalized worklist. Objects that are to be processed in a processing step sequence are managed in the worklist. Define the processing step sequence in the flow definition.

The worklist monitor shows you, for example, which objects were processed without errors, and which objects could not be processed. You can display information on the cause of errors, and thus control the way in which the object is processed further.

The generalized worklist ensures that when processing step sequences are repeated, the system only reprocesses the objects that previously contained errors and those for which you manually forced reprocessing.
Revaluation at Actual Prices

Use

Revaluation at actual prices supplements revaluation of activity allocations between cost centers and business processes. It is used to correct activity allocations that occurred previously from cost centers or business processes to other cost accounting objects.

You can use revaluation at actual prices for the following objects:

- Internal orders

In Cost Object Controlling:

- Production orders
- Process orders
- Product cost collectors
- Cost object nodes in a cost object hierarchy
- Sales document items [Extern] (for example, sales orders)
- General cost objects

In the Project System:

- Projects
- WBS elements
- Networks
- Network activities

Revaluation on cost centers and business process levels takes place within actual price calculation in Cost Center Accounting.

For more information, see the SAP Library under Financials → Controlling → Cost Center Accounting → Period-End Closing → Actual Price Calculation [Extern]

If a cost accounting object uses an activity from a cost center or business process, you usually start with a plan price to allocate the activity. This is because the actual price is calculated during period-end closing. In the actual price calculation, the SAP system performs an iterative calculation of the prices for the activity types. To do this, it uses the actual costs that were debited to the cost center or business process, and the activities actually incurred. During this process, the system accounts for all activity relationships between cost centers and business processes.

After actual price calculation, you can revaluate the objects at actual prices if they have used the activities from cost centers or business processes. You do this using Revaluation at actual prices (revaluation). The system always determines the variances between the costs posted up to this point and the costs that occur under the new prices. The corresponding sender cost center is credited by the actual price revaluation and the receiver is debited accordingly.

For more information, see Example of Revaluation at Actual Prices [Extern]
Revaluation at Actual Prices

Integration

The method you use for the revaluation depends on the price indicator that you specified in the fiscal year dependent parameters in version 0 in customizing. You can set the following price indicators.

For more information, see the SAP Library under Financials → Controlling → Cost Center Accounting → Period-End Closing → Actual Price Calculation → Actual Price Calculation Procedure [Extern]

- Period price
  Periodically differentiated prices, based on the costs and activity quantities for the period.

- Average price
  Price based on the costs and activity quantities of all periods. You post the revaluation in the period in which the activity was incurred.

- Cumulative price
  Price based on the costs and activity quantities of all periods. You post revaluation of the current period and all previous periods to the current period.

When you use revaluation, you cannot apply any percentage overhead to costs that have cost element category 43 (internal activity allocation). If you were able to perform revaluation on cost elements with applied overhead, you would have to recalculate the overhead, leading to a recursion.

Revaluation of Material leads to follow-up costs. During settlement to materials you deal with this in the same way as price control.

- If the material’s price control indicator is set to S, you can post the follow-up costs as price differences.

- Or if the material’s price control indicator is set to V, readjust the follow-up costs to the inventory, so long as there is stock coverage in the warehouse.

If you make an actual costing in the Actual Costing / Material Ledger application component, you can debit the difference between the plan price and actual price to Material directly. In this case, you do not require revaluation at actual prices.

For more information, see the implementation guide (IMG) under Controlling → Product Cost Controlling → Actual Costing/Material Ledger → Actual Costing → Activate Actual Costing [Extern].

Prerequisites

You activated the Revaluation indicator in customizing (in the appropriate version).

If you are using Activity-Based Costing, you executed the process cost allocation before revaluation in Cost Object Controlling.

Once you debit the cost object with all the activities incurred in the period, you can execute the revaluation of actual price activities in Cost Object Controlling. During the period, the cost object is debited with activities using internal activity allocations. If required, the system debits the cost object using process costs during period-end closing.
Features

Revaluation occurs periodically for individual cost accounting objects or in collective processing for more than one cost accounting object. You start revaluation with your own user-defined transactions after the actual price calculation. Revaluation occurs for all the secondary cost elements affected.

⚠️ After revaluation, it is important that you execute settlement for all of the receivers again. **This is an important requirement**, as it is the only way that you can pass on revaluation data from a revaluated CO object to further CO objects.

See also:

Example: Revaluation at Actual Prices With Repeated Settlement [Seite 389]

You can also start revaluation for test and forecast purposes. In this case, you do not update the revaluations that you calculated. You can run both test and update runs either online or in the background.

You can repeat revaluation as often as required. The system only updates the differences that occurred due to price changes.

You can create a worklist for objects that could not be revaluated during collective processing. The system uses this worklist to provide you with information about the cause of any incorrect processing. Once you have corrected these error sources, you can restart revaluation for the objects in the worklist. You can find further information on worklist processing in Using the Worklist for Revaluation at Actual Prices [Seite 388].

You can completely reverse the revaluations made in the update runs, so long as the status of the relevant CO objects allows this. The original activity allocations remain the same. If you have reversed any activity allocations, you should also reverse the revaluation for the period affected.

💡 For cumulative prices, you should reverse the revaluations for the higher periods first.

⚠️ After reversing the revaluations, ensure that you perform the settlement again. This is required because such revaluation data, that was transferred from one cost accounting object to other cost accounting objects, is not reversed.

See also:

Internal Order Settlement [Seite 400]

Activities

Revaluation at Actual Prices [Seite 386]
Revaluating at Actual Prices

Prerequisites

Before revaluating at actual prices, you should do the following:

1. SAP recommends you to set the period lock for actual activity allocation (RKL).
2. Set the period lock for actual indirect activity allocation (RKIL), so that you can carry out the following steps on solidly based costs. Should it still be necessary to carry out further activity allocations in Financial Accounting before settlement, you must carry out the following steps once again.
3. Calculate the overheads if there are internal CO receivers with periodic settlement rules (PER rules). You cannot use percentage-based overhead calculation in this case for secondary cost elements.
4. If there are CO internal receivers with PER rules, carry out CO internal settlement. The system settles all CO objects that have internal receivers.
5. Carry out the splitting function.
6. Calculate the price. The actual price is used for revaluation.

Procedure

1. For revaluation at actual prices, choose the following:

<table>
<thead>
<tr>
<th>From:</th>
<th>The following menu paths:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internal orders</td>
<td>In Internal Orders, Actual postings → Period-end closing → Revaluation at actual prices → Individual processing or Collective processing</td>
</tr>
<tr>
<td>In Cost Object Controlling:</td>
<td>In period-end closing for the relevant object, Revaluation at actual prices → Individual processing or Collective processing</td>
</tr>
<tr>
<td>Objects in the project system</td>
<td>In the implementation area menu, Period-end closing → Overheads → Revaluation at actual prices → Individual processing or Collective processing</td>
</tr>
</tbody>
</table>

When using the cost object hierarchy, ensure that you revaluate activities that were posted to cost object nodes in a cost object hierarchy before you distribute the actual costs posted to it.

2. After revaluating at actual prices, do the following:
   a) If there are no CO internal receivers with PER rules, calculate the overhead. You can also calculate overhead for secondary cost elements.
   b) Set the period lock for revaluation (RKLN).
c) Carry out settlement for all receivers. **This is an important requirement**, as it is the only way that you can pass on revaluation data from a revaluated CO object to further CO objects.

d) Run any reports required. Your data is consistent again after the settlement.

**Revaluation Results**

The system displays the revaluation results in a list. In addition to the selection criteria and the processing parameters, the list header contains the following data:

- Processing status (test run, update run)
- Number of messages
- Number of selected objects, whose status does not permit revaluation (with an error message)
- Number of processed objects

There is no change to the debit, if:

- No activity was included,
- No actual price exists,
- The object was already valued with the actual price, or
- You cannot post to the cost center to be credited, due to its current status.

The list itself displays the debits for the selected and revaluated objects. You can branch to the master record for each activity type. The list contains the following details:

- Sender
- Allocation cost element
- Values in the controlling area currency.

You can display additional columns using other display variants.

Any errors that occur are recorded by the system in an error log.

You can print both the list and the error log if you select background processing.
Worklist for Revaluation at Actual Prices

Prerequisites
To use the worklist, you need to set the Worklist indicator, using collective processing for revaluation at actual prices.

Worklist for Revaluation at Actual Prices
1. Choose Revaluation at actual prices: Extras -> Worklist -> Process
   The Application log screen appears.
2. Choose Execute.
   The screen Application log for object collective processing in Controlling, Revaluation at actual prices appears.

Obtaining Detailed Information on Objects
1. Highlight the worklist to be processed, and choose Display messages.
   The system displays a list of log messages with the highest log class. Choose Detail for a list detailing all objects with errors and their corresponding messages.
2. Choose Long text on the individual message rows, then use the system to display the procedure for correcting object errors.
3. Once you correct these errors, you can restart revaluation for the objects in the worklist.

Revaluation of Worklist Objects
1. 1. In the Application log for object collective processing: Revaluation at actual prices screen, highlight the worklist for revaluation, then choose Detail.
    The Worklist screen appears.
2. Choose Execute.

The procedure is described below, using Order-related Product Controlling as an example.
Example: Revaluation at Actual Prices With Repeated Settlement

Settlement of an Internal Order to a Cost Center

Activity Allocation

1. Two repair hours are allocated from a cost center / activity type to an order for USD 5.00.
2. The cost center / activity type is credited with USD 5.00.
3. The order is debited with USD 5.00. The system makes a value type 04 posting (actual).

<table>
<thead>
<tr>
<th>Object</th>
<th>Amount</th>
<th>Business Transaction</th>
<th>Partner</th>
<th>Document Indicator</th>
<th>Value Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order</td>
<td>+5 USD</td>
<td>RKL</td>
<td>CCtr 1/REP</td>
<td>S</td>
<td>04</td>
</tr>
<tr>
<td>CCtr 1/REP</td>
<td>- 5.00 USD</td>
<td>RKL</td>
<td>Order</td>
<td>H</td>
<td>04</td>
</tr>
</tbody>
</table>

Order Settlement Using The PER Distribution Rule

4. The system settles the order to a cost center during periodic settlement. The order is credited with USD 5.00.
5. The cost center / activity type is initially debited with USD 5.00 (value type 09 posting).
6. In a further posting, the cost center / activity type is credited with USD 5.00 (value type 09 posting).
7. The cost center is debited with USD 5.00. After the order is settled, the cost center no longer shows that the order existed.

<table>
<thead>
<tr>
<th>Object</th>
<th>Amount</th>
<th>Business Transaction</th>
<th>Partner</th>
<th>Document Indicator</th>
<th>Value Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Example: Revaluation at Actual Prices With Repeated Settlement

<table>
<thead>
<tr>
<th>CCtr 2</th>
<th>+5 USD</th>
<th>KOAL</th>
<th>Order</th>
<th>S</th>
<th>04</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order</td>
<td>- 5.00 USD</td>
<td>KOAL</td>
<td>CCtr 2</td>
<td>A</td>
<td>04</td>
</tr>
<tr>
<td>CCtr 1/REP</td>
<td>+5 USD</td>
<td>KOAL</td>
<td>Order</td>
<td>H</td>
<td>09</td>
</tr>
<tr>
<td>CCtr 1/REP</td>
<td>- 5.00 USD</td>
<td>KOAL</td>
<td>CCtr 2</td>
<td>H</td>
<td>09</td>
</tr>
</tbody>
</table>

The information on the transferred quantity and the sender is only transferred to the receiver in a periodic settlement (PER distribution rule). This enables the system to include activities in price determination, that were provided to orders, and then settled to cost centers. The flow of activity between the cost centers is shown in the document rows with value type 09.

Settlement of an order to a cost center or business process must be made once before price determination, as the price determination would otherwise not recognize the activity flow from CCtr 1/REP to CCtr 2.

Flow of Activity

<table>
<thead>
<tr>
<th></th>
<th>CCtr 1/REP</th>
<th>Order</th>
<th>CCtr 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Allocation</td>
<td>- 5.00 USD</td>
<td>+5 USD</td>
<td></td>
</tr>
<tr>
<td>Settlement</td>
<td>+5 USD</td>
<td>- 5.00 USD</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- 5.00 USD</td>
<td></td>
<td>+5 USD</td>
</tr>
</tbody>
</table>

Splitting

8. Actual costs are split within Cost Center Accounting

Price Determination

In Cost Center Accounting, when the system determines actual prices, it determines the actual prices for cost centers / activity types. At the same time, it revaluates all of the allocations made from a cost center / activity type to a cost center in Cost Center Accounting with the difference to the plan price. The system revaluates all of the allocations that were posted using value type 09.

The price for two repair hours is, for example, not 5.00 USD, but 6.00 USD.

9. The cost center / activity type is credited with another 1.00 USD during price determination.

10. The cost center is debited with 1.00 USD.

To post between cost centers, you need the KSII business transaction. Initially, the order is not included during price determination.

<table>
<thead>
<tr>
<th>Object</th>
<th>Amount</th>
<th>Business Transaction</th>
<th>Partner</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCtr 2</td>
<td>+1 USD</td>
<td>KSII</td>
<td>CCtr 1/REP</td>
</tr>
<tr>
<td>CCtr 1/REP</td>
<td>-1 USD</td>
<td>KSII</td>
<td>CCtr 2</td>
</tr>
</tbody>
</table>
Order Revaluation

11. During order revaluation, the cost center / activity type is credited with the difference to the plan price (1.00 USD).

12. The order is debited with the difference to the plan price (USD 1.00). The system does this by making a value type 04 posting (actual). It does this, by searching for all postings to the order that have value type 04 in the COSS table, and whose partner object PAROB is a cost center / activity type, or a business process. The system only revaluates these partner objects.

If there is a chain of orders that were settled one after the other, only the first order is reevaluated.

<table>
<thead>
<tr>
<th>Object</th>
<th>Amount</th>
<th>Business Transaction</th>
<th>Partner</th>
<th>Document Indicator</th>
<th>Value Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order</td>
<td>+1 USD</td>
<td>RKLN</td>
<td>CCtr 1/REP</td>
<td>S</td>
<td>04</td>
</tr>
<tr>
<td>CCtr 1/REP</td>
<td>-1 USD</td>
<td>RKLN</td>
<td>Order</td>
<td>H</td>
<td>04</td>
</tr>
</tbody>
</table>

This means that
- The order is no longer completely credited
- The cost center / activity type was credited by USD 1.00 too many.

Therefore, you need to resettle the order, also after the revaluation.

Second Settlement

After revaluation, the order balance is not zero, but 1.00 USD. Therefore, you need to settle the order again.

13. The order is settled to the cost center. The order is credited with USD 1.

14. The cost center is debited with +1 USD.

15. However, as the cost centers were already reevaluated during price determination, the system makes an offsetting entry which credits the cost center by 1.00 USD, and debits the cost center / activity type by 1.00 USD. The postings on the cost center / activity type and the cost center each balance out to zero.

The order revaluation has had no effect on the cost centers / activity types, but the effect can be seen on the order itself.

Postings (value type 09) that transfer the information on the sender to the receiver take place at the same time as the first settlement, but using transaction RKLN.

<table>
<thead>
<tr>
<th>Object</th>
<th>Amount</th>
<th>Business Transaction</th>
<th>Partner</th>
<th>Document Indicator</th>
<th>Value Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCtr 2</td>
<td>+1 USD</td>
<td>RKLN</td>
<td>Order</td>
<td>S</td>
<td>04</td>
</tr>
</tbody>
</table>
Example: Revaluation at Actual Prices With Repeated Settlement

<table>
<thead>
<tr>
<th>Order</th>
<th>Target</th>
<th>CCtr</th>
<th>Amount</th>
<th>Activity</th>
</tr>
</thead>
<tbody>
<tr>
<td>-1 USD</td>
<td>RKLN</td>
<td>CCtr 2</td>
<td>A</td>
<td>04</td>
</tr>
<tr>
<td>+1 USD</td>
<td>RKLN</td>
<td>Order</td>
<td>H</td>
<td>09</td>
</tr>
<tr>
<td>-1 USD</td>
<td>RKLN</td>
<td>CCtr 2</td>
<td>H</td>
<td>09</td>
</tr>
<tr>
<td>+1 USD</td>
<td>RKLN</td>
<td>Order</td>
<td>H</td>
<td>04</td>
</tr>
<tr>
<td>-1 USD</td>
<td>RKLN</td>
<td>CCtr 1/REP</td>
<td>S</td>
<td>04</td>
</tr>
</tbody>
</table>

Flow of Activity

<table>
<thead>
<tr>
<th></th>
<th>CCtr 1/REP</th>
<th>Order</th>
<th>CCtr 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Revaluation</strong></td>
<td>-1 USD</td>
<td>+1 USD</td>
<td></td>
</tr>
<tr>
<td><strong>Settlement</strong></td>
<td>+1 USD</td>
<td>-1 USD</td>
<td></td>
</tr>
<tr>
<td></td>
<td>-1 USD</td>
<td></td>
<td>+1 USD</td>
</tr>
<tr>
<td></td>
<td>+1 USD</td>
<td></td>
<td>-1 USD</td>
</tr>
</tbody>
</table>
Overheads

Purpose
You use overhead costing to allocate overhead through percentage-based or quantity-based overhead rates. The basis for the allocation are the primary cost elements that you post as overhead costs. In the manufacturing industry, for example, these are usually the labor and material costs.

Integration
To make an overhead costing, you need to define control data in customizing for the corresponding application, and include this in a Costing sheet [Seite 397].

Features
You can apply overhead to both plan and actual costs, or on the basis of commitment data.

Business processes do not use commitments.
If you debit a cost center with overhead rates, then they also apply to all the activity types in this cost center.

You can make an overhead costing:
• For one or several objects
• Without updating the calculated overheads, for test and forecasting purposes

Constraints
You start Overhead Calculation [Seite 394] using its own transaction. This means that you cannot carry out transaction-based overhead calculation.
Calculating Overheads

Use

You can allocate overheads using percentage-based or quantity-based overhead rates for plan or actual data, alternatively you can use commitments data.

Prerequisites

To make an overhead costing [Extern], you need to define control data during customizing and include this in a costing sheet [Seite 397].

Features

You can calculate overhead for single or multiple objects. Collective processing is based on selection variants that are individually definable.

You can start overhead costing for test and forecast purposes without updating the overhead calculation. The system then calculates the overhead, without you having to update the object (such as, internal order, cost center, business process). This enables you to identify and correct any errors before the actual calculation (such as, an invalid overhead costing sheet in the master data, or missing percentage rates).

You can run overhead costing online or in the background without a display.

The following reports are also available for overhead calculation:

- RKAZCO43: Overhead: Manufacturing orders and Product cost collectors
- RKAZKJPJ: Cost object hierarchy, general cost objects
- RKAZVA44: Actual overhead: Sales orders
- RKAZKSI4: Actual overhead: Cost centers incl. activity types
- RKAZCPZ4: Actual overhead: Business processes
- RKAZKGI4: Actual overhead: Internal and maintenance orders
- RKAZCJ45: Actual overhead: Projects/WBS elements/Networks
- RKAZKSP4: Planned overhead: Cost centers including activity types
- RKAZCPZP: Planned overhead: Business processes
- RKAZKGP4: Planned overhead: Internal and maintenance orders
- RKAZCJ47: Planned overhead: Projects/WBS elements/Networks
- RKAZKSO9: Commitment overhead: Cost centers including activity types
- RKAZKGO4: Commitment overhead: Internal and maintenance orders
- RKAZCJO9: Commitment overhead: Projects/WBS elements/Networks

You can use the dialog display to check the overheads that the system calculates based on the costing sheet.
Calculating Overheads

You can create an overhead costing as often as required for each period. If any of the object values (for example, internal order, cost center, business process), or overhead costing values change themselves, the system updates the difference (can be a positive or a negative value).

**Date Determination**

The system determines the date during overhead costing as follows:

- **Posting date:**
  - _Plan processing of line items_: First day of the period
  - _Actual processing_: Last day of the period
    
    You can enter a posting date for overhead calculation. However, the posting date must be within the period for which you are calculating the overhead.
    
    To enter the posting date, choose Accounting → Controlling → Internal orders → Period-End Closing → Single functions → Overhead rates → Actuals - individual processing → Extras → Posting date.
    
    - _Commitments_: The system does not write any line items

- **Document date:**
  - Today’s date

- **Overhead calculation:**
  - With posting date

- **Currency translation:**
  - _Actual_: With the entered value date, otherwise posting date
  
  _Planning data_: With the entered value date, otherwise with the value entered in the version for planning data in Customizing under Controlling → Internal Orders → Planning → Basic Settings → Maintain Versions → Maintain Settings of Version in Controlling Area → Settings by Fiscal Year → Details → Tab Page: Planning → Currency translation.

**Results List and Error Log**

The system displays the results of the overhead calculation in a list for all objects, for which it has determined values. This list contains the following information:

- **Basic list** with information on current processing and number of objects processed.

- **Detailed list** with the amounts for each sender and receiver when you enter the credit cost element. If you already performed the overhead costing for the given period, the system only displays variances from the overhead already costed.

- **Period drilldown** in the planning data, should the overhead costing or simulation occur over several periods.

If errors occur during processing, the system refers you to an error log that contains an error listing.

You can print both the results list and the error log.
Calculating Overheads

Activities

Enter the costing sheet required for overhead costing in your object (such as a cost center, business process, internal order, project or costing reference object).

To calculate the overhead rates, choose Accounting → Controlling → Internal orders → Period-End Closing → Single Functions → Overhead Rates → Actuals - Individual Processing.

- To run the overhead calculation in the background without a display, select Background processing.
- To simulate the overhead calculation, choose Test run.
- To check overhead calculations using the costing sheet, select Dialog display.

⚠️

The dialog display always shows the current data from the database, even if the system updated them already. The Detail list shows whether the data were updated already.

The Detail list only displays differences to the overheads already updated. If the overhead is already updated, the Dialog display shows the results of the overhead calculation, and the Detail list is empty.

No dialog display is issued for a reversal.

- To create a worklist for objects that do not have overhead applied to them, select Worklist (in Collective processing).

💡

If the credit object is an internal order, you need to deactivate the partner update and avoid settling the credit orders, as this enables you to avoid performance problems.

The system will only contain plan overheads for projects and WBS elements in individual or collective processing for one more fiscal year only. If the overhead is to be applied for more than one fiscal year, you need to calculate overhead separately for each fiscal year. This is the only way that you can guarantee an update to the profit center and the special purpose ledger. You do not need to enter a To-fiscal year.
Costing Sheet

Definition
The costing sheet combines all parts of the overhead costing, and determines the rules for calculating the values to be posted.

Structure
The costing sheet links the control data for the overhead costing.
Costing Sheet

<table>
<thead>
<tr>
<th>Overhead rate: C010</th>
<th>Dependency: D010</th>
</tr>
</thead>
<tbody>
<tr>
<td>Valid from</td>
<td>Valid until</td>
</tr>
<tr>
<td>01.01.1992</td>
<td>31.12.1999</td>
</tr>
<tr>
<td>01.01.1992</td>
<td>31.12.1999</td>
</tr>
<tr>
<td>01.01.1992</td>
<td>31.12.1999</td>
</tr>
</tbody>
</table>

- **Calculation Base**
  
  This defines the primary cost elements to which a particular overhead is to be applied.
  
  This represents a group of cost elements to which you want to apply overhead. For each controlling area, you can assign individual cost elements or cost element intervals and individual origins as well as origin intervals to the calculation bases.

- **Overhead**
  
  The overhead rate determines to what extent the percentage-based or quantity-based overhead rate should be applied to the direct costs. It also specifies under which conditions (dependencies) the overhead rate is to be applied. For example, you can calculate a defined overhead rate for each plant by specifying a plant dependency.

- **Credit**
  
  A credit specifies the credit object and the credit cost element.
  
  If an object in actual data is debited with overhead, then another object (such as, a cost center, or order) is credited at the same time. You allocate the overhead using a special overhead cost element (category 41).

  Only debits are posted in commitments (no credits).

  A costing sheet comprises multiple rows that are processed from top to bottom during the overhead calculation.

- **Base Rows**
  
  You define these by assigning a calculation base, so that they contain the direct costs that are to have overhead applied to them during the overhead costing.

- **Overhead Rows**
  
  These are defined by the assignment of an overhead rate.
  
  An overhead row consists of a base row or a totals row. The overhead amount is calculated by multiplying the amount contained in these rows by the overhead percentage rate or quantity-based overhead rate determined through the overhead rates.
As well as overheads, the overhead rows contain credit keys. These credit keys determine which object (such as a cost center or order) is to be credited under which cost element during overhead rate determination.

- **Totals Rows**
  
  Totals rows are used to generate subtotals or final totals.

**See also:**

[Calculating Overhead [Seite 394]]
**Internal Order Settlement**

**Purpose**
An internal order is usually used as an interim collector of costs and an aid to the planning, monitoring, and controlling processes needed. When the job has been completed, you settle the costs to one or more receivers (cost center, fixed asset, profitability segment, and so on).

**Features**
To be able to settle an order, you must have saved a settlement rule in each of the senders. This settlement rule determines where the costs are to be settled to. You can achieve this in two ways:

- **Settlement to One Receiver**
  You use this basic form of order settlement to completely settle the costs collected on the internal order. This is either to a cost center, or a G/L account under a settlement cost element. The system generates the appropriate settlement rule from the information contained in the internal order master data.

  For more information on order settlement to one receiver, see [Order Settlement To One Receiver][1].

- **Comprehensive Settlement**
  Definition of a comprehensive settlement rule gives you more settlement possibilities, for example, you can:

  - Settle costs to a wide range of receivers (project, sales order, profitability segment, and so on).
  - Specify how the costs are to be distributed between receivers.
  - Define the cost elements under which the sender is to be credited and the receivers debited.

  For more information on comprehensive settlement, see the [SAP Library][2], under Financials -> CO Controlling -> Internal Orders -> Settlement [extern].

**Constraints**
You can only use one of these settlement methods at a time: For example, if you defined settlement to one cost center in the master data for an internal order, then you can only define a more comprehensive settlement rule once you have deleted the first rule.
Internal Order Settlement to One Receiver

Use
You settle the costs collected on an internal order to one cost center, one G/L account, or one business process using one settlement cost element.

⚠️
If you have entered a general settlement rule for an internal order, you cannot use the kind of order settlement described here.

Prerequisites
In the settlement parameters, you need to assign a settlement profile to the internal order. As you cannot maintain settlement parameters when you settle to one receiver, you can store the settlement profile in the order type. Otherwise, you need to create the internal order with the help of a reference order, which has a settlement profile assigned to it.

Before you can settle an order, it must have a status that allows the Settlement business transaction. If you posted revenues to internal orders, you cannot settle them to cost centers.

Features
The system always uses the document type “SA” during settlement to one receiver. If you wish to use another type of document for your order settlement, use the more comprehensive settlement.

You can find more information on more comprehensive settlement in the SAP Library under Financials → CO Controlling → Internal Orders → Settlement [Extern]

<table>
<thead>
<tr>
<th>Receiver</th>
<th>Settlement Cost Element</th>
<th>Credit for the Order</th>
<th>Debit</th>
<th>Settlement Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center</td>
<td>Category 21 (internal settlement)</td>
<td>Under the settlement cost element</td>
<td>Takes place on the cost center under the settlement cost element</td>
<td>Settlement is made by period: The system always only calculates the costs from the period specified during settlement.</td>
</tr>
</tbody>
</table>
Internal Order Settlement to One Receiver

<table>
<thead>
<tr>
<th>G/L account</th>
<th>Category 22 (external settlement)</th>
<th>Under the settlement cost element</th>
<th>Takes place on the G/L account</th>
<th>The system executes a cumulative settlement of all the costs incurred on the internal order (up to, and including the settlement period). To execute settlement by period, you must settle the order in each period.</th>
</tr>
</thead>
</table>

Activities

- To enter the settlement receiver and the settlement cost element, choose the *Period-end closing* tab page in the internal order master data. Then, in the *Settlement to one receiver* group box, enter the settlement cost element and the receiver for the costs collected on the order. When you settle the internal order, the system automatically creates the corresponding settlement rule and hides the *Settlement Rule* pushbutton.

- To settle internal orders, choose

- **Individual processing**
  You use individual processing to control the settlement of individual internal orders.

- **Collective Processing**
  Collective processing is normally used as part of period-end closing to trigger background processing. This is when you want to process a large number of internal orders.

- **Line item apportionment**
You only require line item apportionment for capital-investment measures. You can find more information on line item apportionment for capital-investment measures in the SAP Library.

**Collective Processing**

In the initial screen for collective processing, make the following entries:

- Selection variant
- Parameters
- Processing

To select internal orders, enter a selection variant.

You can define selection variants in customizing by choosing **Controlling → Internal Orders → Order Master Data → Selection and Collective Processing → Define Selection Variants [Extern]**, or by choosing **SelVariant**.

These selection variants are also used elsewhere, such as collective processing of internal orders.

You can refer to order master data fields and order groups when making a selection. You can also determine classification characteristics during selection. However, this is not a good idea when you are processing large numbers of internal orders (more than 10,000).

You can find more information on the **Parameter and Processing Control** group boxes, in **Carrying Out Settlement [Extern]**, located in the SAP Library under **Financials → CO Controlling → Internal Orders → Settlement**.
Information system For Internal Orders

Purpose
Reporting is the tool used to analyze internal orders. It provides information on the status of your internal orders and enables you to control them effectively.

There are several predefined standard reports available for the Internal Orders component (CO-OM-OPA). You can also use the Report Painter to define your own reports.

Features

Report/Report Interface
Most reports allow you to mark given rows and then, using the Report call function, to branch to another report containing detailed information.

You can branch from a total cost report to a cost element report, from where you can start a line item report.

Defining Your Own Reports
When defining your own reports for internal orders, you should note the following technical details:

<table>
<thead>
<tr>
<th>Report Type</th>
<th>Table</th>
<th>Library</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overall cost and cost element reports</td>
<td>CCSS</td>
<td>601</td>
</tr>
<tr>
<td>Overall plan and budget reports using Report Painter</td>
<td>RWCOOM</td>
<td>602</td>
</tr>
<tr>
<td>Summarization reports for Internal Orders</td>
<td>KKBC</td>
<td>701</td>
</tr>
</tbody>
</table>

You can find more information on defining your own reports in the SAP Library under Financials → CO Controlling → Cost Center Accounting → Information System → Report Definition → Report Painter [Extern]

For more information on the Internal Orders information system, see Internal Orders Report Types [Seite 405].

You can find more information on Reporting in the Controlling component in the SAP Library under Financials → CO Controlling → Cost Center Accounting → Information System [Extern]
Report Types for Internal Orders

Use
Defaulted standard reports for internal order analysis contain the status of an internal order.

Features
The following report types are available for internal orders:

- **Total Cost Reports**
  In total cost reports, the system totals actual or plan costs for each internal order within a given period across cost elements. If you specify an order group, the system generates a row for each internal order contained in the group. It then determines the total costs for the internal orders belonging to each node in the order group [Extern], and displays this in a totals row.
  
  For more information, see Total Cost Reports [Seite 418].

- **Cost Element Reports**
  For these reports, you must specify a cost element group during data selection. The system creates a separate row in the report for each cost element and each node of the cost element group, then it totals the corresponding cost elements for each node.
  
  SAP provides a standard cost element group, which you need to adapt to suit your own cost element layout. This standard cost element group is independent of the chart of accounts or controlling area.
  
  For more information, see Cost Element Reports [Seite 416].

- **Line Item Reports**
  There are line item reports for actual costs, plan costs, and commitments.
  
  - **Actual Line Items**
    Actual line items are created each time you post actual costs. They contain information about the posted amount, the posting date, and the user who posted the item.
  
  - **Commitment Line Items**
    Commitment line items are generated when commitments are created (for example for purchase orders).
  
  - **Plan Line Items**
    During internal order planning, the system creates line items if the order status specifies that planning documents should be written. Therefore, plan line items only document plan value changes made after planning documents are written for an internal order.

- **Overall Plan and Budget Reports**
  You can plan overall cost (independently of cost element) in internal orders, and determine the annual plan costs or the order budget. Special reports are available covering these topics.
Report Types for Internal Orders

For more information, see Overall Plan and Budget Reports [Seite 412]

- **Summarization Reports**

  The purpose of order summarization is to group internal orders with common attributes for the reporting system. Orders are summarized in the Controlling component (CO), using master data fields. Order summarization by classification characteristics is no longer used.

  In this way, you might summarize and analyze the costs of all the orders for a given order type, responsible cost center, or plant. This provides a much greater degree of cost transparency within your organization.

  For more information, see Summarization [Seite 409].

- **Master Data Indexes**

  Each report includes the internal orders within one controlling area only. Therefore, you must always specify the controlling area within data selection. If an order group contains internal orders from multiple controlling areas, then the system only includes those from the controlling area you specified.

  For more information, see Order List: Master Data Index / Cost Analysis [Seite 407].

  You can overwrite selection parameters (fiscal year, period, plan version), and enter individual single values or intervals instead of cost element groups or order groups.

**Activities**

To call up the report tree with the structure you have defined, choose Accounting → Controlling → Internal orders → Information system → Report selection from the Internal Orders menu.

For more information on calling up your own reports, see Selecting Order Reports [Seite 419]
Internal Order List: Master Data Index/Cost Analysis

Use

Internal order lists provide you with an overview of a number of selected internal orders. They list data (relevant for your purposes) from the order master data for the selected internal orders.

Features

Master Data Index

Different selection variants are defined in the standard to help you with selection from the master data index. You can use the order master data fields as selection criteria. You can define your own selection criteria, or limit the selection using Selection Criteria.

You can go from here to the master data for the internal orders listed.

You want to assign all orders that have a given combination of Responsible cost center/order type to a new manager.

Enter the responsible cost center and the order type as selection criteria. The system displays a list of all the orders that meet the specified criteria. You can branch to each of these orders and change the name of the responsible person.

You can generate an order group using the master data index for internal orders. You can use these order groups for overhead calculation and in reporting.

You cannot use order groups (that you create with the Order list function) in order planning, nor can you edit them using the hierarchy function.

Cost Analysis

The system selects classification characteristics in order to analyze plan and actual costs. These characteristics are taken from the internal order master data. You need to generate them using the Implementation Guide.

You can restrict the selection by entering intervals or individual values in the appropriate fields. The system creates an order list, showing the orders which meet the specified criteria.

The system only selects orders with order types for which classification is active.

You can find more information on classification in the SAP Library under Order Selection [Extern]

Activities

To create master data indexes, choose Controlling → Internal Orders → Information System → Reports for Internal Orders → Master Data Indexes.

If you want to carry out cost analysis of classified orders, choose Controlling → Internal Orders → Information System → Reports on Internal Orders → More Reports → Cost Analysis.
Summarization

Use

You need more than a cost structure analysis of individual internal orders (Internal Orders [Extern], Production Orders [Extern], Projects) to ensure efficient controlling. You need to be able to group together account assignment objects with common attributes and analyze them collectively. This provides a much greater degree of cost transparency within your organization.

You can, for example, summarize and analyze the costs of all your orders according to the following criteria:

- Order type [Extern]
- Responsible cost center
- Plant [Extern]

Integration

You can summarize internal orders, production orders and projects collectively.

For more information on project summarization, see the SAP Library under Accounting → PS-Project System → Project Information System → Project Summarization [Extern].

Features

For reporting purposes, summarization collects account assignment objects with common attributes.

You can use summarization initially to obtain an overview of a large number of orders. It is also useful for processing order groups containing large variances. You can then analyze relevant account assignment objects individually, using the cost element reports. This means that you do not have to analyze each account assignment object individually.

Summarization hierarchy

You use characteristics to define the individual levels of the summarization hierarchy. These characteristics refer to the fields in the master data for the account assignment object.

The controlling area is always the top node in the summarization hierarchy. To summarize account assignment objects, you need to differentiate between those and the others in the same controlling area. You do this by using a characteristic in the corresponding hierarchy identification.

For more information on summarization hierarchies, see the SAP Library under Accounting → CO-Controlling → Product Cost Controlling (CO-PC) → Product Cost Controlling Information System → Cost Object Controlling: Information System → Key Figures in cost Object Controlling → Summarization Hierarchies [Extern], or the implementation guide for the summarization object.

You can find more information on classification in the SAP Library under Financials → CO Controlling → Product Cost Controlling → Cost Object Controlling [Extern]
Summarization

**Summarization Reports**
The following standard summarization reports are available:

- **Summarization objects: Actual/plan/variance**
  - Compares the plan and actual costs for the selected subhierarchy.

- **Summarization objects: Actual/plan/commitment**
  - Compares the costs already assigned and those still available. The value in the Allotted column is calculated by adding actual cost and commitment values. The difference between the plan costs and the assigned costs is displayed in the last column as available costs.

- **Summarization objects: Curr. Period/Cum./Total**
  - Compares the plan and actual costs for a selected period, the entire fiscal year, and cumulated.
Controlling Documents

Use
The system creates a controlling document for all postings to CO objects, for example during settlement, reposting, or activity allocation. You can display these documents in the system.

Integration
The line item reporting system is available for further analysis of controlling documents. For example, you can call up the posting document or the master record.

Activities
1. Enter the document number.
   If you do not know the document number, you can choose Further sel. criteria to enter search criteria, such as the cost element.
   Once you select your criteria, the system displays a dialog box where you can enter intervals for the criteria you selected. When you choose Proceed, the system confirms that the selection criteria are saved.
2. Choose Proceed to start your selection.
   The system creates a list of controlling documents meeting the various criteria you entered. You can now select a document from this list.
   The system enters the document number in the Document number field.
3. Choose Execute.
   The system displays the controlling document.

For more information on how to display Controlling documents, see the SAP Library, under Financials -> Controlling -> Cost Center Accounting -> Information System in Cost Center Accounting -> Important Standard Reports -> Document Display [Extern].
Overall Plan and Budget Reports

Use
These reports display the values for overall planning or budgeting.

Features
The system creates the overall plan report or the budget report for the order or order group you entered in the selection screen. These reports are located under Internal orders → Information system → Reports for internal orders → More reports.

- **List: Overall Plan/Actual/Commitment**
  Displays the overall plan, actual and commitment values for all years or for individual years. The system also displays the allotted amounts and the available plan values.

- **List: Budget/Actual/Commitment**
  Displays the budget, actual, and commitment values for all years or for individual years. The system also displays the available amounts.
Line Item Report

Use
Line item reports list the line items for the internal orders you have selected.
You can use the line item report to select individual posting documents.

Features
There are line item reports for actual costs and plan costs, as well as for commitments and settlement data.
Unlike ordinary order reports, the line item reports (except the report for plan line items) are programmed. This means that you do not create them using Report Painter.

Actual Line Items
Actual line items are created each time you post actual costs. They contain information about the posted amount, the posting date, and the user who posted the item.

When you start an actual-line item report, you need to limit the line items to be read by entering an order (or order group), a cost element (or cost element group) and a posting period. Additionally, you can configure different layouts to control the appearance of the report.

You can go directly from a line item on the list to the corresponding document. This may be a Financial Accounting document (created by posting to a general ledger account), or a Controlling document (created by a posting within Controlling). A document usually has more than one line item.

You can also display line item reports for actual costs that have been archived. You can find more information in the SAP Library under Financials → CO Controlling → Cost Center Accounting → Information System → Interactive Information System → Report Painter Report → Reading Standard Reports from Archives [Extern]

💡
For incorrect line items, you can trigger an adjustment posting straight from the report via Extras → Correction request.
You can find further information on in the SAP Library under Financials → CO Controlling → Controlling → Controlling Methods → Correction Requests via Intranet [Extern]

Settlement of Actual Line Items
The report lists all actual line items from the order settlement.

Commitment Line Items
You can find more information on commitments line item reports in the SAP Library under Financials → CO Controlling → Internal Orders → Planning in Internal Orders → Commitments Management [Extern]
Line Item Report

Plan Line Items

During order planning, line items are only created if the order status specifies that planning documents should be written. Therefore, plan line items only document changes to the plan values, which occurred when planning documents were written for the order.

A plan line item contains all periods of a fiscal year, thus documenting simultaneously all period values changed during one planning transaction. The system creates a row for each cost element and document number. This row contains the total of the changed plan values and plan quantities.

Plan line item reports are only available if plan line items are updated. To do this, go to customizing and choose Controlling → General Controlling in the Organization → Maintain Versions [Extern]. Select the Integrated Planning indicator in the settings for each fiscal year.

You can only call up plan line items as a target report from other reports using the report/report interface.

You can find more information on cost center line item reports in the SAP Library under Financials → CO Controlling → Cost Center Accounting → Information System → Important Standard Reports in Cost Center Accounting → Line Item Report →

- Cost Centers: Actual Line Item Reports [Extern]
- Cost Centers: Commitment Line Item Reports [Extern]
- Cost Centers: Budget Line Items
- Cost Centers: Plan Line Item Reports [Extern]

You can find more information on business process line item reports in the SAP Library under Financials → CO Controlling → Activity-Based Costing → Activity-Based Costing Information System → Important Standard Reports → Line Item Report →

- Business Processes: Plan Line Items [Extern]
- Business Processes: Actual Line Items [Extern]

Selection

You can select the line item reports using the following parameters:

- Object ( Cost Center [Extern], Business Process [Extern], Order [Extern])
- Object interval
- Object group
- Cost element
- Cost element interval
- Cost element group
- Posting period
- Debit date for commitments [Extern].
The selection screen enables you to use the line item reports for all components. You can restrict the selection to object type, partner object types and other selection criteria in the selection screen. You can go to the line item report from the selection screen.

To increase extra fields for line item reports, you can use the COOMEPO1 enhancement. To do this, go to customizing and process the following IMG activity in the corresponding application: Information System → Standard Reports → Develop Enhancements for Line Item Reports [Extern].

**Standard Variants**

To create the list, you can use the SAP standard display variants. You can also define more display variants.

You can find information about the functions in display of the line item report in the SAP Library under Financials → CO Controlling → Cost Center Accounting → Information System → Important Standard Reports → Line Item Reports → Executing Line Item Reports Online → Line Item Report Display [Extern]

If you are working with transfer prices (parallel value flows), then you can select the required valuation from the initial screen in the line item report. To do this, choose Extras → Valuation view.

For more information on transfer prices, see Multiple Valuations [Extern]
Cost Element Reports

Use
Cost element reports represent the costs of the selected internal orders according to cost element.

Features
For these reports, you must specify a cost element group during data selection. The system creates a separate row in the report for each cost element and each node of the cost element group. The system totals the corresponding cost elements for each node.

Any cost element that is not included in the cost element group does not appear in the report, even if actual costs have been incurred for it.

If you select more than one order for your report, the costs incurred are totaled by cost element across all the orders. Therefore, if you enter an order group, the system displays the costs (by cost element) of all the orders belonging to this group.

The following cost element reports are available in the standard:

Plan/Actual Comparisons
- **Orders: Actual/plan/variance**
  Comparison of actual and plan costs. The value in the *Absolute variances* column is calculated by subtracting the plan costs from the actual costs. The last column shows the percentage variance, based on the plan costs.

- **Orders: Curr.period/cumulated**
  Comparison of the total plan and actual costs as well as:
  - Actual costs for the period
  - Cumulated costs per fiscal year
  - Cumulated costs from all fiscal years in the past

- **List: Cost elements**
  Represents the costs and quantities in the plan and actual data for each order and cost element. Variances are also listed.

- **Orders: Drilldown by partner**
  Compares plan and actual costs, as well as variances. The rows list the costs by cost element. Secondary cost elements are displayed additionally by partners and partner types.

- **Orders: Actual/plan/commitment**
  Compares the costs already assigned and those still available. The value in the *Assigned* column is calculated by adding actual cost and commitment values. The difference between the plan costs and the assigned costs is displayed in the last column as available costs.
**Actual/Actual Comparisons and Planning Reports**

- **Orders: Planning overview**
  Provides an overview of the planned costs, quantities and statistical key figures for an order.
  For more information on the planning overview, see Planning Overview [Extern].

- **Orders: Annual comparison (actual or plan)**
  Comparison of the costs in two fiscal years.

- **Orders: Quarterly comparison (actual or plan)**
  Quarterly totals within a fiscal year.

- **Orders: Period comparison (actual or plan)**
  Period totals within a fiscal year.

**Further Reports**

- **Orders: Actual/plan/variance**
  Comparison of actual and plan costs. The actual costs are always those actually incurred (including price variances). The price variances included in the actual costs are displayed separately. The values in the *Variances* column are calculated by subtracting the plan costs and price variances from the actual costs.

- **Orders: Actual/plan/consumption**
  Comparison of actual and plan costs. The value in the *Absolute variances* column is calculated by subtracting the plan costs from the actual costs. The *Consumption* is the percentage portion of the actual costs based on the plan costs.

- **Orders: Actual/plan fixed/variable**
  Comparison of actual and plan costs. Fixed and variable costs are shown separately.

- **Orders: Currency comparison (actual) (Orders: TCurr/OCurr/CO Area curr.)**
  Displays costs in the transaction, order, and controlling area currencies. This report is only useful if you have activated all the currencies in a controlling area.

**Activities**

SAP provides a standard cost element group, which you need to adapt to suit your own cost element layout. This standard cost element group is independent of the chart of accounts or controlling area.

You can define separate cost element groups for each chart of accounts and use them in the report. You can set up the store of cost element groups in customizing, under Controlling → Internal orders → Planning → Group maintenance → Maintain Cost Element Groups [Extern].
Total Cost Reports

Use
In total cost reports, the system totals actual or plan costs for each internal order within a given period across cost elements.

Features
When you enter an order group, the system creates a separate row for each order contained in the group. Additionally, the system determines the total costs for the orders belonging to each node in the order group. This is then displayed in a totals row.
The following total cost reports are available in the standard:

Plan/Actual Comparisons
- **List: Orders**
  Displays all the actual and plan costs incurred to date, with variances
- **Order: Debits/Credits**
  Displays all the debits/credits carried out to date, with balances
- **List: Actual/Plan/Commitment**
  Displays all the costs already assigned and those still available.

Further Reports
- **Orders: Drilldown by Period**
  This displays actual and plan costs for each period, with variances.
- **List: Actual Annual Value**
  Displays the total actual costs for a fiscal year.
- **List: Actual Cumulative**
  Displays all the actual costs incurred to date.
Selecting Internal Order Reports

1. Choose Controlling → Internal orders → Information system → Reports for Cost Center Accounting.

   The system displays a report tree with the existing internal order reports.

2. Place your cursor on the required report, and choose Select (for example, Plan/Actual comparisons → Order: Actual/Plan/Variance.)

3. In the screen which follows, (for example, Order: Actual/Plan/Variance) enter at least the required order/order group. You can also change the defaults in the other input fields.

4. Choose Execute.

   The system displays the appropriate internal order report.
Archiving Internal Orders

Use

During archiving (reorganization), internal orders are written on an external storage medium and deleted from the database at the same time.

Features

Enter a date as a selection criterion for the archiving. This date is used for comparison with the date of the last change to the internal orders. It only selects the internal orders not changed since this date. The system checks to see if it may archive the internal orders selected.

The time at which internal orders are archived depends on the two residence times that you defined when customizing each of the respective order types. These residence times are given in months.

Activities

Choose Accounting → Controlling → Internal orders → Environment → Archiving → Orders → Archive

In the variant, you can further restrict the selection by entering:

- One or more controlling areas
- One or more order numbers
- One or more order types

Archiving is a multi-step process:

- To flag an internal order for deletion, go to order master data maintenance and choose Edit → Deletion flag → Set.

  You can set the deletion flag in the internal order providing this does not contain actual costs or commitments [Extern]. In other words, the internal order must be completely settled. This constraint does not apply to statistical orders, which you can flag for deletion at any time.

  This constraint does not apply if you have stored a settlement profile for the internal order that contains the "Actual costs can be settled" or "Actual costs cannot be settled" indicators.

  You can find more information in the SAP Library under Financials → CO Controlling → Internal Orders → Period-End Closing in Internal Orders → Internal Order Settlement → Settlement → Settlement Rule → Settlement Parameters [Extern].

  You can undo the deletion flag, providing the system has not yet set the deletion indicator. Choose Edit → Deletion flag → Delete.

- Residence time 1 indicates the interval that must elapse between flagging the order for deletion and setting the deletion indicator.

  You cannot reverse the deletion indicator.

- Residence time 2 indicates the interval between setting the deletion indicator, and archiving the internal order. If the deletion indicator has already been set, the system checks (during
the reorganization run) whether this residence time has elapsed. Only then does it write the internal order to an archive file and delete it in the database.

You can find further information on archiving in the SAP Library under Cross-Application Components → General Application Functions (CA-GTF) → CA-Archiving and Deleting Application Data [Extern].

You can find more information on archiving internal orders in the SAP Library in Archiving Internal Orders (CO-OM-OPA) [Extern] in Cross-Application Components.