
Executive Information System
and Business Planning

H
E

L
P

.E
C

E
IS

Re lease  4 .6C



Executive Information System and Business Planning  SAP AG

2 April 2001

Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose
without the express permission of SAP AG. The information contained herein may be changed
without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software
components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered
trademarks of
Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®,
AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server
TM

 are registered trademarks of
Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide
Web Consortium,
Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for
technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow,
SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com
are trademarks or registered trademarks of SAP AG in Germany and in several other countries
all over the world. All other products mentioned are trademarks or registered trademarks of their
respective companies.



 SAP AG Executive Information System and Business Planning

April 2001 3

Icons

Icon Meaning

Caution

Example

Note

Recommendation

Syntax

Tip



Executive Information System and Business Planning  SAP AG

4 April 2001

Contents

Executive Information System and Business Planning ............................................. 7
Executive Information System (EC-EIS).................................................................................................... 8
Setting Up the Data Basis ......................................................................................................................... 10
Presentation of the Data ........................................................................................................................... 11

Overview of Drilldown Reporting ............................................................................................................ 12
Example: Working with a Basic Report ............................................................................................. 13
Overview of Form Reports ................................................................................................................ 18

Example: Working with a Form Report ........................................................................................ 19
Overview of the Report Portfolio ............................................................................................................ 21

Concept Hierarchy..................................................................................................................................... 22
Data Basis (EC-EIS/EC-BP)....................................................................................................................... 23
Aspect ......................................................................................................................................................... 24

Characteristics........................................................................................................................................ 27
Basic Key Figures................................................................................................................................... 29
Field Group............................................................................................................................................. 30
Considerations for Data Modeling .......................................................................................................... 31
Creating an Aspect ................................................................................................................................. 32
Performing Operations on an Aspect ..................................................................................................... 34

Maintaining the Field Catalog................................................................................................................... 35
Calculated Key Figures............................................................................................................................. 36

Maintaining Calculated Key Figures....................................................................................................... 38
Displaying and Deleting Calculated Key Figures ................................................................................... 44

Master Data ................................................................................................................................................ 45
Maintaining Master Data......................................................................................................................... 47
Deleting Master Data.............................................................................................................................. 48

Master Data Hierarchy............................................................................................................................... 49
Maintaining the Master Data Hierarchy.................................................................................................. 51
Example: Master Data Hierarchy............................................................................................................ 53
Derivation of Characteristic Values ........................................................................................................ 54

Currencies in EC-EIS and EC-BP ............................................................................................................. 56
Currency Translations ............................................................................................................................ 57

Quantity Units in EC-EIS and EC-BP ....................................................................................................... 59
Transaction Data........................................................................................................................................ 60

Individual Record Entry for Transaction/Plan Data ................................................................................ 61
Maintaining a Data Entry Layout (EC-EIS)............................................................................................. 63
Entering Actual Data With Layouts (EC-EIS) ......................................................................................... 66
Transaction/Plan Data, Displaying or Deleting....................................................................................... 69

Validations.................................................................................................................................................. 70
Example of Single Record Validation ..................................................................................................... 73
Example of a Matrix Validation............................................................................................................... 74
Activating Validations for Data Entry and Planning................................................................................ 76
Activating Validations for Data Transfer ................................................................................................. 77

Data Slices.................................................................................................................................................. 78
Comments .................................................................................................................................................. 80

Maintaining Comments........................................................................................................................... 81



 SAP AG Executive Information System and Business Planning

April 2001 5

List of Comments on Transaction Data .................................................................................................. 82
Documents ................................................................................................................................................. 83
Importing a File .......................................................................................................................................... 84

Importing a File: Transaction data.......................................................................................................... 87
Importing a File: Master Data ................................................................................................................. 90
Importing a File: Master Data Hierarchy................................................................................................. 92
Importing a File: Transformation of a Record......................................................................................... 96
Importing a File: File in MC Format ........................................................................................................ 98

Data Collection (EC-EIS/EC-BP)............................................................................................................... 99
Data Transfer Methods............................................................................................................................ 100

Example of the Methods of Data Transfer ........................................................................................... 101
Setting up Data Transfer ...................................................................................................................... 102

Executing Data Transfer ................................................................................................................. 103
Displaying the Transfer Log and Processing Errors ....................................................................... 104

Data Transfer from Other SAP Modules .............................................................................................. 105
Data Transfer from R/2.................................................................................................................... 106
Data Collection from R/3 ................................................................................................................. 107

Flexible Upload of Data from Microsoft Excel ...................................................................................... 110
Aspect Summarization.......................................................................................................................... 111
Other Types of Data Transfer............................................................................................................... 112
Data Transfer to the Report Portfolio (EC-EIS) .................................................................................... 113

Business Planning (EC-BP).................................................................................................................... 115
Interactive Planning................................................................................................................................. 117

Planning Layout.................................................................................................................................... 119
Planner Profile ...................................................................................................................................... 124
Edit Plan Data Interactively .................................................................................................................. 126

Planning Scenario ........................................................................................................................... 129
Integrated Excel in Planning................................................................................................................. 130

Setting Up Integrated Excel ............................................................................................................ 132
How To Plan Using Integrated Excel .............................................................................................. 135
Flexible Upload of Data from Microsoft Excel ................................................................................. 137

Automatic Planning ................................................................................................................................. 138
Edit Plan Data Automatically ................................................................................................................ 141

Seasonal Distribution.............................................................................................................................. 144
Maintaining the Distribution Key........................................................................................................... 145

Revaluation .............................................................................................................................................. 146
Determining the Revaluation Factor..................................................................................................... 147

Forecast .................................................................................................................................................... 148
Forecast Profile .................................................................................................................................... 150
Weighting Group................................................................................................................................... 151

Top-Down Planning ................................................................................................................................. 152
Top-Down Scenario.............................................................................................................................. 154

Information System (EC-EIS).................................................................................................................. 156
Interactive Drilldown Reporting ............................................................................................................. 157

Drilldown Reports ................................................................................................................................. 159
Creating a Report ............................................................................................................................ 160

Creating and Changing a Form.................................................................................................. 161
Copying a Form.......................................................................................................................... 162



Executive Information System and Business Planning  SAP AG

6 April 2001

Characteristic Groups ................................................................................................................ 163
Key Figure Groups ..................................................................................................................... 164
Creating Constants .................................................................................................................... 165
User Exit: Elimination of Internal Business Volume................................................................... 166

Example of Elimination with Rules 2 and 3........................................................................... 170
Example of Elimination with Rule 4 ...................................................................................... 173

Creating a Report....................................................................................................................... 176
Changing Reports and Displaying Reports................................................................................ 178

Working with Reports ...................................................................................................................... 179
Selecting a Report...................................................................................................................... 180
Executing a Report..................................................................................................................... 182
Freezing Report Data and Printing Reports in the Background ................................................ 186

Example of the Use of a Variant Group................................................................................ 188
Connection to inSight for SAP R/3............................................................................................. 189

inSight for SAP R/3: Installation and Logging on.................................................................. 191
Drilldown Report in inSight ................................................................................................... 192

Optimizing Response Times ........................................................................................................... 193
Summarization Levels................................................................................................................ 195

Example: How to Improve Response Time of Report? ........................................................ 198
Authorization Objects in the Information System ............................................................................ 199

Report Portfolio ....................................................................................................................................... 200
Report Portfolio..................................................................................................................................... 201

Maintaining User Groups................................................................................................................. 202
Maintaining Report Classes ............................................................................................................ 203
Transferring a Report to the Report Portfolio .................................................................................. 204

Copying Reports from Drilldown Reporting................................................................................ 206
Maintaining a Report Portfolio Report........................................................................................ 208
Exception Reporting in the Report Portfolio............................................................................... 211
Changes That Have an Effect on the Report Portfolio Report................................................... 213

Using the Executive Menu............................................................................................................... 215
Executing the Report Portfolio using the Hierarchy Graphic ..................................................... 216
Executing A Report Portfolio Report Directly............................................................................. 218
Functions in a Report Portfolio................................................................................................... 219
Printing with Microsoft Word for Windows in the Report Portfolio ............................................. 221

Example of Printing a Report from Microsoft Word .............................................................. 223
Tools (EC-EIS/EC-BP).............................................................................................................................. 224
Translating Texts ..................................................................................................................................... 225
Reorganization in the Information System ( EC-EIS)........................................................................... 227
Archiving .................................................................................................................................................. 229



 SAP AG Executive Information System and Business Planning

Executive Information System and Business Planning

April 2001 7

Executive Information System and Business Planning
In this section of the SAP online documentation, you will find information on two subcomponents
of Enterprise Controlling:

Executive Information System (EC-EIS) [Page 8]

Business Planning (EC-BP) [Page 115]

Both applications use a special data retention, separate from the R/3 System's operational
dataset. They use the data collection metods required for this data retention, the information
system (drilldown reports and report portfolio), and other tools. You can find information on these
areas in the following sections:

Data Basis [Page 23]

Data Collection [Page 99]

Information System [Page 156]

Tools [Page 224]
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Executive Information System (EC-EIS)
Purpose
An executive information system (EIS) provides information about all the factors that influence
the business activities of a company. It combines relevant data from external and internal
sources and provides the user with important current data which can be analyzed quickly.

The EC-Executive Information System (EC-EIS) is a system which is used to collect and evaluate
information from different areas of a business and its environment. Among others, sources of this
information can be the Financial Information System (meaning external accounting and cost
accounting), the Human Resources Information System and the Logistics Information System.
The information provided serves both management and the employees in Accounting.

Implementation Considerations
EC-EIS is the information system for upper management. It is generally suitable for the collection
and evaluation of data from different functional information systems in one uniform view.

Integration
The Executive Information System is based on the same data basis, and has the same data
collection facilities as Business Planning (EC-BP) [Page 115]. In EC-EIS you can report on the
data planned in EC-BP.

Within this documentation, unless indicated otherwise, the sections Data Basis (EC-EIS/EC-BP)
[Page 23], Data Collection (EC-EIS/EC-BP) [Page 99], and Tools (EC-EIS/EC-BP) [Page 224]
are relevant for both applications. The section Business Planning (EC-BP) is only relevant if you
have the EC-BP component installed.

Features
When customizing your Executive Information System you set up an individual EIS database for
your business and have this supplied with data from various sub-information systems (Financial
Information System, Human Resources Information System, Logistics Information System, cost
accounting, etc.) or with external data. Since this data is structured heterogeneously, you can
structure the data basis into separate EIS data areas for different business purposes. These data
areas are called aspects. You can define various aspects for your enterprise containing, for
example, information on the financial situation, logistics, human resources, the market situation,
and stock prices. For each aspect you can create reports to evaluate the data. You can either
carry out your own basic evaluations in the EIS presentation (reporting) system or analyze the
data using certain report groups created specifically for your requirements. To access the EIS
presentation functions, choose Information systems → EIS.

In this documentation the application functions are described in detail and the customizing
functions in brief. It is intended for the EC-EIS user but also those responsible for managing the
system. To access the EC-EIS application menu, choose Accounting → Enterprise control.
→ Executive InfoSystem.

To call up the presentation functions from the application menu, choose Environment →
Executive menu.

Necessary preliminary tasks and settings are carried out in Customizing. You can find a detailed
description of the customizing functions in the implementation guidelines.
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Setting Up the Data Basis
An aspect consists of characteristics and key figures. Characteristics are classification terms
such as division, region, department, or company. A combination of characteristic values for
certain characteristics (such as Division: Pharmaceuticals, Region: Northwest) is called an
evaluation object. Key figures are numerical values such as revenue, fixed costs, variable costs,
number of employees and quantity produced. They also form part of the structure of the aspect.
The key figure data is stored according to the characteristics in an aspect.

Besides these key figures stored in the database, you can also define calculated key figures in
EC-EIS and EC-BP. Calculated key figures are calculated with a formula and the basic key
figures of the aspect (for example: CM1 per employee = (sales - sales deductions - variable
costs)  / Number of employees).

Determining characteristics and key figures when setting up the system provides the framework
for the possible evaluations. You make these settings in customizing. When the structure of the
aspect and the data basis have been defined in Customizing, you can evaluate data.

See also:

Aspect [Page 24]

Characteristic [Page 27]

Basic Key Figure [Page 29]
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Presentation of the Data
Drilldown reporting and the report portfolio help you to evaluate and present your data.

You can evaluate EC-EIS data interactively using drilldown reporting. You a make a selection of
the characteristics and key figures from the data basis. You can analyze many types of variance
(plan/actual comparisons, time comparisons, object comparisons). Drilldown reporting contains
easy-to-use functions for navigating through the dataset. In addition, there are a variety of
functions for interactively processing a report (selection conditions, exceptions, sort, top n and so
on). You can also access SAPgraphics and SAPmail and print using Microsoft Word for Windows
and Microsoft Excel.

Drilldown reporting, with its numerous functions, is aimed at trained users, especially financial
controllers and managers. By using the various function levels appropriately, other users can
execute reports without needing extensive training. The reports created in drilldown reporting can
be combined for specific user groups and stored in the graphical report portfolio.

The report portfolio is aimed at users with basic knowledge of the system who wish to access
information put together for their specific needs. You can call up report portfolio reports via a
graphical menu. This menu can be set up individually for different user groups. The navigation
function in the report portfolio is limited to scrolling through reports created by the relevant
department.

Overview of Drilldown Reporting [Page 12]

Overview of the Report Portfolio [Page 21]
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Overview of Drilldown Reporting
When you create a drilldown report, you first need to choose the aspect whose data you wish to
analyze. Each report has a unique name and a short description. A report can be created as
either a basic report or a form report. The report with a form gives you the chance to freely
configure the layout using a form, which the basic report does not. When you create a form
report, you enter the name of the pre-defined form which contains the report layout.

In a report, we differentiate between two types of list. In a drilldown list, several objects
(characteristic values), for example, divisions, are contained in the rows and a selection of key
figures (for example, revenue and contribution margin 1) are contained in the columns. In a
detail list, a single object (for example, the combination of customer X in sales area 1) is broken
down into all its component key figures. The rows of the list are filled with the key figures and the
columns may contain, for example, the planned and actual values for the object.

The following examples illustrate how you work with a basic report and a form report:

Example: Working with a Basic Report [Page 13]

Example: Working with a Form Report [Page 19]

Further information on drilldown reporting can be found under Interactive Drilldown Reporting
[Page 157].
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Example: Working with a Basic Report
When you create a basic report, the system first displays the screen Variables where you
specify characteristic values for the characteristics contained in every aspect (fixed
characteristics):

•  Fiscal year

•  Period (from/to)

•  Plan/Actual indicators

•  Version

On the screen Characteristics, the system displays a list of the characteristics in the aspect
chosen and you select those which you wish to analyze. If you specify a characteristic group on
this screen, the system displays the characteristics which belong to that group. You specify those
which are of interest to you for evaluation. In this way, you define the dimensions of the data
model which will be used later during drilldown. When you choose the characteristics, you
automatically define the sequence of characteristics; however, you can alter the sequence by
choosing Extras → Sort orders → Sort characteristics. The sequence represents the hierarchy
in which you can drill down in the report. In the following example, a basic report is created which
contains the characteristics Company, Division, Country and Customer group, in that
order.

On the screen Specify Characteristic Values, you can then specify the characteristic values
which interest you. If, for example, you specify the characteristic value Chemtech for
characteristic Company, you can limit the report to this particular characteristic value. If you do
not yet know which characteristic values you wish to evaluate in the report, you can create a
variable. (This example does not contain any variables.)

The next stage is to specify the key figures you wish to analyze and which will later appear in the
columns of the basic report. On the screen Key Figures, the system displays a list of the key
figures that relate to the chosen aspect, or to the selected key figure group. In the example, the
key figures Revenue, Contribution margin 1 (CM1), Sales deductions, Fixed
manufacturing costs and Variable manufacturing costs have been chosen. You
can find further information on creating a report in the section Creating a report [Page 176]

After you have made the entries indicated above, you must save the report (Report → Save)
before you can execute it (Report → Execute).

After you have executed a drilldown report, a drilldown list appears by default. The characteristic
values of that characteristic that has not had values chosen for it during the creation of the report,
and that appears first in the sort order (Division in the example), appear in the rows. The
values of the selected key figures appear in the columns. If the detail list is to be displayed first,
you can set this when creating a report by choosing Extras → Initial list.

In order to fulfill the information needs of different users, there are three levels of functionality
when executing reports in drilldown reporting. If you have the appropriate authorization, you can
select another functional level under Extras → Additional functions. You can find further
information on this topic in the section Executing a report [Page 182] In level 1 you carry out the
navigation functions by placing the cursor on a row and then choosing the desired function in the
Navigate menu. If you have the correct authorization you can select another level by choosing
Extras → Additional functions. Both possibilities for selection of navigation functions are
described in this example.
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If you roll over cursor-sensitive fields and icons with the cursor when in the report list,
the form of the cursor changes into a hand. Please note that if you click just once on
such a field with the mouse button then a function will be carried out. With other
types of fields a single click just positions the cursor.

 
Some of the navigation functions in this example are not accessible with level 1.
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By selecting Division or choosing Navigate → >Country, you can display the values of the
division by country in our example. The selected division is then displayed in the report
header:
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By double-clicking further on Country or by choosing Navigate → >Customer group in the
example, you can display a breakdown by customer group.
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Company: Chemtech
Country: D

Division:Paints

Customer group Revenue CM1

Wholesale

Retail

Major customers
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50,000
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By clicking on the icon  or choosing Navigate → Country, you return to the next highest
level.
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Division: Paints

With a single click on the icon  next to a division already chosen (in the report header) or if
you choose Navigate → Deactivate characteristic, the system displays the values for the
countries totaled over all the divisions. With this you have switched the evaluation
hierarchy and set the characteristic country over the characteristic division.
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If you wish to perform drilldown independently of the predefined sort order, select a row and
choose Navigate → Choose next level, or select the row and the characteristic Customer
group in order to break down the values for a country by customer group. This means that
you can navigate freely through a particular data area.

D
et

ai
l l

is
t

Wholesale

Customer group Revenue CM1

Retail

Major customers

30,000

40,000

30,000

1,000

2,000

2,000

Company: Chemtech Division: Paints

. . . . . .

Sometimes the width of the screen is not sufficient to display a large number of selected key
figures. Besides scrolling through the columns, you can also click on the icon at the start of a

row and the icon , or position the cursor on a row and choose   , to display all the key figures
for the object selected.

In a basic report, the detail list contains only one column.
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Company: Chemtech
Customer group: Wholesale

Country: CH

. . . . . .

Key figure

Revenue
CM1
Sales deductions
Variable costs
Fixed costs

40,000
2,000
5,000

20,000
13,000

Further navigation functions are explained in the section Executing a Report [Page 182] and in
the online handbook Drilldown Reporting [Ext.].
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Overview of Form Reports
A form report offers greater options for formatting detail and drilldown lists. It uses a predefined
form as a layout. For information on form maintenance, see the cross-application handbook
Drilldown Reporting [Ext.].

A form can have one or two axes, meaning either columns, rows, or columns and rows. For a
form with one axis, you merely define the content and sequence of the columns or rows. Please
see Example: Working with a Basic Report [Page 13] for a Plan-Actual comparison.

An example of a form report can be found under Example: Working with a Form Report [Page
19].
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Example: Working with a Form Report

...

...

...

...

Division: Pharma.     Plan    Act.    Var.

Division:       Revenue                CM1
                Plan Act.  Var.  Plan Act.  Var.

Revenue

Paints

CM1
Sales deductions

Plastics

Vbl. manuf. costs

Pharma.

Detail list

Drill-down list

Definition of form:

Report structure: as above

Plan Act. Var. - - -

Company: Chemtech

Company: Chemtech

As you can see in the diagram above, the detail list of the report has the same layout as the form.
(See also Overview of Drilldown Reporting [Page 12] ).

The example is of a form with one axis but without key figures. You select the characteristics
for the columns in the form. You first establish the key figures in the report definition. If, however,
you wish to establish the key figures in the form, you can create a form with one axis with key
figures instead.

If you wish to specify the contents of the rows and the columns in the detail list, you need to use
a form with two axes when you create a report. See Creating a Report [Page 176] for more
information.

A typical example of a form with two axes is that required for displaying balance sheets. In this
example, you can see that it is possible to insert text rows, blank rows, underscores, and so on.
You can also apply colors to rows and columns to improve clarity.
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Drill-down list:

Detail list:

Company:

Company: Chemtech USA

Assets:

Liabilities:

Total assets

Total liabilities:

Fixed assets

Equity

Current assets

Outside capital

Chemtech D

Chemtech USA

Medipharm

Fixed assets
PL.Act.Act.Pr.Yr PL.Act.Act.Pr.Yr

Plan Act. Pr. YrAct

Current assets

...

...

...

...

For more information on the exact differences between the form types, and for notes on sensible
use of the different forms, see the online documentation Drilldown Reporting [Ext.].

The reports created in drilldown reporting can be stored in the report portfolio as single screens
or as screen sequences. In the process, you name the report portfolio report and assign it to a
report class. You can also specify whether you wish to copy the report with or without data. If you
copy a report without data to the report portfolio, the data will be selected periodically or when
you execute the report portfolio report. For more information, see Copying Reports from
Drilldown Reporting [Page 206].
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Overview of the Report Portfolio
The report portfolio users can display an overview of the report classes and reports in their report
portfolios. The menu can be structured differently for each user group. The nodes of the
hierarchy correspond to the report classes. The different reports are assigned to these classes. A
color is assigned to each node. This color can depend on exception conditions you define. If
certain thresholds in the report have been exceeded, the appropriate reports and report classes
will be colored red or green accordingly.

The following graphic represents a graphical menu. By selecting a report class, you can display
all the reports belonging to this class. By selecting the name of a report, you can display the
pages of this report. You can then scroll through the report portfolio report. For more information
see Report Portfolio [Page 200].

Balances

Subsidiary report

Profit

Market research

Hum.res.

Partnerships

Markets

Foreign

Domestic

Double click

News

Foreign

Overview of all
report classes in
a user group

List of all reports
in report class
"Foreign"
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Concept Hierarchy
The graphic below illustrates the relationships between the main concepts in SAP-EIS. The
Executive Information System EC-EIS can be divided into two main areas, holding and
presenting data. Holding data consists of the data basis and data transfer. Presentation consists
of drilldown reporting and the report portfolio. The most important concepts are assigned to these
areas.

Hierarchy of SAP-EIS Concepts

Report Hierarchy/User group

Presenting data

Report portfolio

SAP - EIS

Drill-down rep.Data basis Data transfer

Aspect

Holding data

Sender structure

Sender structure
Receiver structure
Transfer rules

Characteristics
Key figures
Drill-down/Detail lists

Drill-down

Characteristic
Key figure

Basic key figure

Calculated
key figure

Report class
Report

Graphics
Comments
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Data Basis (EC-EIS/EC-BP)
Purpose
The data basis forms the foundation of the Executive Information System (EC-EIS) and Business
Planning (EC-BP). It saves related business data in several database tables that are each built
according to an individual structure. A data table of this kind is called an Aspect [Page 24] The
aspects separate the data basis into individual, evaluation areas that are largely independent of
each other.

Integration
The data basis is a prerequisite for the saving and evaluation of data. It is, therefore, a
prerequisite for the components Executive Information System and Business Planning.

Features
The data basis is freely configurable. You can set up and enhance aspects according to your
information requirements. The creation of structure and environment objects for each aspect is
managed with the help of generation techniques (see Creating an Aspect [Page 32]).

The fields of the data structure for the aspect are stored in a field catalog that can be seen as an
EC-EIS-specific or EC-BP-specific addition to the ABAP Dictionary. These fields can be used in
several aspects (see Maintaining the Field Catalog [Page 35]).

In addition to the aspects themselves, the transaction data stored for each aspect in the
database belongs to the data basis.
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Aspect
Definition
An aspect is an individual sub-section of the summarized business information of an enterprise.
A database table containing characteristics and key figures from the field catalog is created for
each aspect. Together, the aspects form the data pool on which the presentation (Report
Portfolio [Page 200] and Interactive Drilldown Reporting [Page 157]) in the Executive information
System (EC-EIS), and the planning in Business Planning (EC-BP) are based.

Use
The information contained in an aspect serves as a basis for evaluating a busines area. An
aspect can, for example, contain information on the cash position, logistics, human resources,
market situation or share prices. You can determine the number and structure of the aspects
according to your company’s requirements.

Structure
An aspect consists of Characteristics [Page 27] and Basic Key Figures [Page 29].
Characteristics are classification terms such as division, region, department, or company. Basic
key figures are numerical values such as revenue, fixed costs, variable costs, number of
employees or quantity produced. The key figure data is stored in an aspect by characteristic.
Determining characteristics and key figures when setting up the system provides the framework
for future evaluations.

Besides the key figures stored in the database, you can also define calculated (or derived) key
figures. Calculated Key Figures [Page 36] can be calculated with a formula from the basic key
figures of the aspect (for example: Contribution Margin 1 (CM1) per employee = (sales - sales
deductions - variable costs) / Number of employees).

In addition to the database table with the characteristics and key figures, each aspect consists of
a description of its structure in the ABAP dictionary, and environment objects. The transaction
and plan data for an aspect is stored in the database table. The aspect environment consists of
screens, user interfaces and programs for entering and displaying data. (See also Creating an
Aspect [Page 32]).

Example aspects



 SAP AG Executive Information System and Business Planning

Aspect

April 2001 25

Field catalog Master dataAspects

Orders / Logistics

CMPNY

BUSDV

PRSCS

SALES

CompanyProfit center results

Market data

Field attributes

Chemicals
Steel

XYZ Oil Inc.
UVW Plastics
C

Aromatics install.
Tool construction

Business
center

Profit
center

As shown in the graphic, one aspect can contain key figures on orders, another one may contain
information on profit centers, another on market data etc. The characteristics (for example,
Company) and basic key figures (for example, Sales revenue) are selected from the field catalog.
The transaction data or plan data for the key figures is sorted by characteristic values (for
example, the company XYZ Oil Inc.). The characteristic values are also indicated as master data.

Granularity of the data
The number of characteristics n in the aspect data structure combine to form an n-dimensional
data cube. This is the basis for drilldown and aggregation in the presentation and business
planning. The number of characteristics determines the complexity of the data cube, and the
number of characteristic values determines the length of the side of a dimension. The
characteristics of the aspect determine the maximum degree of fineness with which the data is
available. The cube on the left shows the possible combinations of characteristic values of the
characteristics. The cube on the right is an example of an evaluation object or a planning object,
meaning a combination of characteristic values.
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Characteristics
Definition
A characteristic is an qualitative classification term such as division, region, department or
company. Characteristics are criteria according to which, data for key figures is saved and
evaluated, for example, revenue per division.

Structure
The characteristics can be both existing fields in the SAP System (for example, material) and
enterprise-specific fields that you create when maintaining an aspect. The characteristics are
stored in the EC-EIS/EC-BP field catalog and can be used in several aspects. You maintain the
characteristics when defining an aspect.

You determine various characteristic values for a characteristic (for example, characteristic
division has the values Pharmaceuticals, Colors, Chem.; characteristic region has the values
North, South). A combination of characteristic values (for example division: Pharma, Region:
South) is called an evaluation object. You can find out how to maintain characteristic values in
the section Maintaining Master Data [Page 47].

Compound characteristics
Certain characteristics can only be interpreted in conjunction with another characteristic of the
aspect. SAP uses the term compound characteristics for this. For example, the characteristic
region is normally only maintained or interpreted in conjunction with a country. In this case a
compound characteristic region is defined for the country. In the definition of such a
characteristic, you determine the compound with the second characteristic.

Characteristic attributes
Characteristics can also have attributes, that describe the properties or assignments of the
values. From this you can, for example, group products into a product group. The advantage of
such characteristic attributes is that the information is stored in the master data rather than in the
transaction data. Therefore, if you carry out a reorganization of your company at a later date and
wish to change the assignments, these changes have an instant effect on the report without a
database conversion.

Navigation attributes
You can store generated characteristics as attributes for user-defined characteristics with a
generated check table (‘generated characteristics’).

In the report the navigation attributes are handled just as the characteristics of the aspect. You
can carry out navigation functions with an attribute just as with other characteristics. In many
cases the system can use one attribute to derive others. You can adopt these proposed
multidimensional attributes and use them in your reports.

Display attributes
Display attributes are those that can be shown in the reports for information, but cannot be used
for navigation. Depending on the origin of the characteristic, the display attributes are created
differently:

•  With generated characteristics, you can create new attributes that are not in the field catalog.
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•  SAP-delivered characteristics from the system field catalog are delivered with specific
attributes.

•  For other fields from SAP tables, you can adopt attributes from the corresponding check
tables.

You maintain the attributes in Customizing when maintaining the characteristics.

Fixed characteristics
As well as the aspect-specific characteristics, every EC-EIS and EC-BP data structure contains
the fixed characteristics version, plan/actual indicator, fiscal year and period. You do not
have to enter these fixed characteristics as they are automatically included when saving the data
structure. Predefined check tables, whose contents you can maintain, exist for the fixed
characteristics. The meaning of the fixed characteristics is explained in more detail in Master
Data [Page 45]. The facility to hold data in various currencies is explained in Currencies [Page
56].
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Basic Key Figures
Definition
A basic key figure is a figure such as sales, fixed costs, variable costs, number of employees, or
quantity produced, that cannot be derived or calculated from other figures. The data for key
figures is stored by characteristic on the database of an aspect.

Structure
Basic key figures can be both existing fields in the SAP System (for example, sales) and
enterprise-specific fields that you create when maintaining an aspect. The basic key figures are
stored in the EC-EIS/EC-BP field catalog and can be used in several aspects.

The Executive Information System and Business Planning both have a key figure transaction,
with which you can define key figures that can be calculated using formulas, in addition to the
basic key figures of an aspect. For more information, see Calculated Key Figures [Page 36].
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Field Group
Definition
A field group is a user-defined grouping of characteristics and basic key figures from the EC-EIS
or EC-BP field catalog.

Use
The field catalog contains the fields that are used in the aspects. As the number of fields grows,
the field catalog becomes very large and unclear. To simplify maintenance of the aspects, you
can group fields in a field group. You can group the fields as you wish, for example, by subject
area or responsibility area. A field may be included in several field groups.

When maintaining the data structure of an aspect, you can select the field group that contains the
relevant characteristics and basic key figures. This way you limit the number of fields offered.

See also:
Characteristics [Page 27]

Basic Key Figures [Page 29]

Maintaining the Field Catalog [Page 35]
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Considerations for Data Modeling
You can create the aspects in EC-EIS and EC-BP according to your information requirements
and volume of data. Data which belongs together from a business perspective and which has
common objects of reference should be combined in a single aspect.

In order to carry out cross-aspect analyses, you can define view aspects in EC-EIS. These
consist of the characteristics and basic key figures of interest chosen from as many aspects as
you wish. EC-EIS reports are always based on one aspect or one view aspect.

During the data modeling phase you need to consider carefully the level of detail required for the
data within EC-EIS and EC-BP. A greater level of detail in the data simplifies specific searches
during navigation and drilldown in presentation and also allows more detailed planning. However,
the greater volume of data required will increase response times. You need to decide here, to
which degree the data transferred from transaction systems can be usefully aggregated.

In general in the R/3 System, and also therefore in EC-EIS and EC-BP, there is a strict
separation of master data and transaction/plan data. Master data includes, for example, an
enterprise’s customer list or product catalog. The master data in EC-EIS and EC-BP is managed
in its own tables, independent of the aspects. The aspect tables contain transaction data and/or
plan data only.

See also:

Master Data [Page 45]

Transaction Data [Page 60]

For information on maintaining an aspect, see Creating an Aspect [Page 32].
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Creating an Aspect
Use
With the creation of an aspect for a subarea of your enterprise, you determine what information
you wish to retain and evaluate for this area (see also Aspect [Page 24]).

Features
You maintain aspects in Customizing. To create or change an aspect, you define its data
structure online. A fiscal year variant and an aspect currency are assigned to each aspect. The
fiscal year variant determines for which period of time the transaction data is stored in EC-EIS or
EC-BP. The aspect currency is used as standard for basic key figures, for which nothing else has
been determined with respect to the currency (see Currencies [Page 56]).

You maintain the data structure by transferring evaluation groups (Characteristics [Page 27]) and
value fields (Basic Key Figures [Page 29]) from the field catalog. You can enter any amount of
both types of field. You only have to keep to the database limitations for the total length of a data
record. For more information, see Customizing.

Characteristics, that are only to be interpreted in conjunction with other characteristics, have to
be defined in the compound characteristics definition (see Characteristics [Page 27]).

As well as the aspect-specific characteristics, every EC-EIS and EC-BP data structure contains
the fixed characteristics version, plan/actual indicator, fiscal year and period.(see Master
Data [Page 45]). The facility to hold data in various currencies is explained in Currencies [Page
56].

When you have selected the characteristics and key figures for an aspect, you must save the
aspect and then activate it. The data structure is created in the ABAP Dictionary when you save
it. When you activate an aspect, the environment is derived from the description of the data
structure and is generated automatically. The environment must be generated before you can
maintain or display transaction data. You will find further information on this topic in Customizing.

View Aspects (EC-EIS only)
You can create a view aspect to evaluate the data from several aspects at once. To do this, you
make a selection of characteristics and basic key figures from the aspects concerned. This way
you define a view of two or more existing aspects without having to create a new database table.
A view aspect reads its data from the database tables of the relevant aspects and aggregates
them in a common context. When you execute a report using a view aspect, you enter the name
of the view aspect. The system handles the data records as if they have been read from a single
aspect. You can find information on creating a view aspect in Customizing.

Virtual Aspects (EC-EIS only)
Virtual aspects enable you to evaluate data from any transaction data tables. No transaction data
table of the EC-EIS database is generated when you define a virtual aspect.  In this case, the
transaction data is in any database table.

In contrast to the other aspect types, the selection routines for data collection are not created
automatically when the aspect environment is generated. Only calls of function modules are
created, which execute the actual data collection. These function modules are in the reserved
customer name space, and in particular cases must be created by you in accordance with the
respective requirements.
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The generated call has the form:
call function 'Z_EIS_READ_DATA_CFNNN'

tables
sel_tab = reptab
rec_tab = tru_tab.

‘NNN’ is to be replaced by the specific aspect number (therefore for aspect 600, a function
module Z_EIS_READ_DATA_CF600 is called).

The parameters have the following meaning:

•  sel_tab: An internal table, which contains the selection conditions for the requested data as
rows. This table can be used for example as content of the WHERE condition of a dynamic
SELECT statement.

•  rec_tab: An internal table, which contains the selected data records when you exit the
module. This table has the IFNNN structure generated by the aspect definition as row type
(therefore, for aspect 600 it has the row type of the DDIC structure IF600).

The way how the respective module generates the data records of table rec_tab from the
selection conditions of table sel_tab, is completely user-defined, and can be adjusted in
particular cases to very special needs.

Virtual aspects offer a high degree of flexibility in data storage, but require deeper knowledge
about the internal structures of EC-EIS, and a considerable degree of programming knowledge.
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Performing Operations on an Aspect
Changing an aspect
If a database table exists for an aspect data structure or if data is already contained in an aspect,
you can only create additional fields in the existing structure.

Deleting an aspect
You can delete an aspect as an entire unit. Using this function the data, data structure, database
table, and environment are deleted.

When you delete an aspect, do not forget dependent objects such as calculated key figures or
reports which are no longer useful without the aspect database table. You can, however, keep
such objects for the purposes of setting up the aspect again.

Transporting an aspect
You can transport an aspect and all ABAP Dictionary objects, which logically belong to it, into
another system.

You can find more details on these operations in Customizing.
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Maintaining the Field Catalog
Storing aspect fields in the field catalog
The characteristics and basic key figures are stored in a field catalog when they are saved. This
catalog can be seen as a EC-EIS/EC-BP-specific supplement to the ABAP Dictionary. Report-
relevant attributes for the fields are also stored in the field catalog. The field catalog is aspect-
independent. Once a field is contained in the field catalog, it may be copied to other aspects but
may no longer be changed. This guarantees a uniform, cross-area use of evaluation groups and
key figures.

You can create field groups to structure the fields in the field catalog. A Field Group [Page 30]  is
a user-defined grouping of characteristics and basic key figures.

Reorganization of the field catalog
The field catalog and ABAP Dictionary information on the aspect data structures must be
consistent with one another - each data structure field must also exist in the field catalog. If this is
no longer the case, you should reorganize the field catalog in order to restore the consistency.
When you do this, the system reads the aspect structure from the ABAP Dictionary and
reconciles it with the field catalog.

Deleting fields from the field catalog
Characteristics and basic key figures, that are no longer used in any aspect, can be deleted from
the field catalog. Any relevant master data, comments, generated ABAP Dictionary objects will
be deleted at the same time.

You can find more information on the field catalog in Customizing.
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Calculated Key Figures
Using the basic key figures in the database (see Creating an Aspect [Page 32]), you can create
further key figures (derived or calculated key figures). Unlike basic key figures, the value of a
calculated key figure is not saved in the database. Instead it is calculated by the system
whenever you execute a report containing this key figure.

 
If you have defined the basic key figures Sales revenue and Employees in an
aspect, you can define the sales revenue per employee with the formula Sales
revenue/Employees.

Key figure formulas can comprise the basic key figures of that aspect, constants and existing
defined key figures in the aspect, i.e. you can build up tree-like key figure hierarchies (see
diagram below). In the presentation there is no distinction between basic key figures and derived
key figures.
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Each derived key figure has a unique name, valid in all aspects. Furthermore, each key figure is
assigned to a specific aspect because it can be split into the basic key figures of that aspect.
However, if all these basic key figures exist in a second aspect, the derived key figure can also
be used in the second aspect. You can create derived key figures for a view aspect, and use
basic key figures (from the aspects which form the view aspect) in the formulas. The procedure
for defining key figures in an aspect and in a view aspect is identical.

For information on creating and editing calculated key figures see Maintaining Calculated Key
Figures [Page 38] See also Displaying and Deleting Calculated Key Figures [Page 44].
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Maintaining Calculated Key Figures
You maintain the calculated key figures in an aspect in the EC-EIS application menu under
Information system → Key figures → Maintain. To create or change a key figure, proceed as
follows.

1. Enter the aspect whose key figure you wish to maintain. Choose Edit key figures.

2. Enter the name of a new key figure or that of an existing key figure. Choose Key figure →
Create or Change.

3. Maintain the short text and description, and enter a formula. The components of the
formula should be separated with blank spaces.

 
Formula Description

REVEN - COST Normal subtraction

REVEN MAX COST Maximum of REVEN and COST

REVEN %A COST COST as percentage of REVEN

REVEN + ABS (COST) Sum of REVEN and the absolute COST amount

Using the function Extras → Basic fields → Display, you can display the possible components for
the formula. Using the function Switch basic fields, you can switch between basic key figures,
existing key figures and constants. For more information on constants, see Creating Constants
[Page 165].

The following operators are supported in the formula:

Operator Description

+, -, *, / Basic arithmetic operations

% Percentage variance (i.e. a % b = 100 * (a-b) / abs(b))

%A Percentage (a %A b = 100* a/b)

%T Percentage of the total sum  1

%S Percentage of the sum

** Raise to a power

= Assignment

ABS Absolute amount

CNT 1 if operand <> 0, otherwise 0

COS Cosine

DIV Division (of integers)

DTA Jump function. 1 if operand is 0, otherwise 0
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EXP Exponential function

LOG Logarithm

MAX Maximum

MX0 Maximum of operand and zero

MIN Minimum

MN0 Minimum of operand and zero

MOD Remainder (of division of integers)

NDI Key figure value without dimension

REF Value 1 without dimension  2

SIN Sine

SQT Square root

Key:
1. This operator can only be used when maintaining forms for drilldown reports. Total sum

means the value in the results row when aggregated over all the characteristics.

2. This operator can only be used when maintaining forms for drilldown reports. Sum means
the value in the results row for the current drilldown.

Choose Edit → Edit formula to delete and insert lines in the formula area.

 
Key figure formulas may be up to 4,096 bytes long. Note that key figures in the info
system are broken down internally.

Before saving the formula, you must choose Edit → Check formula. The formula is then checked
for correct syntax, the formula stages are generated, and the technical attributes are set to
default values. The formula stages represent the breakdown of the key figure formula into
elementary calculation steps (stages). After the syntax check, the key figures are checked for
their logical sense. A check is made, for example, that quantities are not added to values.

You can use the function Edit → Reset formula to reset the key figure to the version stored in the
database or the last saved version.

Choose Edit → Substitute formula to replace the key figures with the elements defining them until
the formula contains only basic key figures and constants.

Choose Extras → Get formula(s) to display or hide the formulas for the key figures in the lower
section of the formula area. You can specify the key figures by entering the name or subgroup.

Use the function Extras → Switchover paging to switch between the upper and lower formula
areas.

Choose Extras → Check recursive act. to check whether recursive relationships exist between
key figures.

Extras → EIS stage forms is for internal test purposes only.
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The function Extras → Evaluate formula(s) acts as a calculator. You can enter values in the basic
fields (Enter basic values) and then have the system calculate the key figure values from the
formulas (Calculate key fig.). The system displays the calculated values on the formula stage
screen (Goto → Formula stages). You may have to switch between the value and attribute
display (Extras → Values/Attributes).

Choose the function Formula stages to branch to another screen. Here, the calculation stages for
the key figure are displayed. In addition, you can set the time-based and non-time-based
aggregation rules, the time reference field, the No aggregation required indicator and the number
format (number of decimal places and display factor).

Aggregation of key figures
An attribute of key figures, important for their use in presentation, is the aggregation rule
assigned to the key figures. This determines if and how the individual key figures are to be
aggregated over characteristics in a report. There are two types of aggregation for basic key
figures:

1. Time-based aggregation rules define how a key figure is to be aggregated over time. In
the following example, it would not make sense to add the number of employees for each
period over several periods, but it may be useful to calculate the average. With stock
prices, the maximum, minimum, and average within a period are of interest, but not the
sum. To calculate non-cumulative values such as these, you need to specify a reference
field, that is, the smallest time unit in the aspect. The key figure must be posted for each
characteristic value defined for this reference field, in this case, number of employees
each month.

2. Non-time-based aggregation defines how the key figure is to be summarized over a
characteristic that is not a time dimension. In the following example, the number of
employees is totaled over the cost centers because the characteristic cost center has no
time dimension.

You can maintain a non-time-based and a time-based aggregation rule for each key figure.

 
Basic key figure Number of employees is defined as:

Field name Description Aggregation Time-based aggr. Ref. field

EMPLY No. of employees SUM AVG &PERI

The number of employees must be posted each month (&PERI).

This basic key figure is then used in a basic report.

Period No. of employees

001.1995 10

002.1995 15

003.1995 35
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Result 20 (Average value)

If you drill down period 2 by cost center, the list appears as follows:

Cost center No. of employees

010 5

020 7

030 3

Result 15 (Total)

The following functions are available for time-based aggregation:

Function Description

AVG Average

CNT Counter

FIR First value

LAS Last value

MAX Maximum

MIN Minimum

NOP No aggregation

SC+ Summation where > 0

SC- Summation where < 0

STD Standard deviation

SUM Summation

VAR Variance

The following functions are available for non-time-based aggregation:

Function Description

MAX Maximum

MIN Minimum

NOP No aggregation

SC+ Summation where > 0
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SC- Summation where < 0

SUM Summation

Reference field for time-based aggregation
If you define a time-based aggregation rule other than SUM for a key figure, you must maintain a
time reference field. This must be a valid characteristic of type D as well as being the smallest
unit of time in the aspect (You can use the variable &PERI delivered by SAP which represents
the fiscal year and the period.) The time reference field must be the most precise time field in the
aspect. According to this rule, the field Posting date would supersede Fiscal year.

All key figures in a report must have the same time reference field.

 
Where a basic key figure has a time-based aggregation rule other than SUM, it cannot
be used to create calculated key figures with another aggregation rule. This means,
for example, that to create a key figure Maximum warehouse stock with time-based
aggregation MAX and time reference field &PERI which stores the maximum
warehouse stock per period, it is necessary to define the key figure Warehouse stock
with time-based aggregation SUM and the key figure Average warehouse stock with
time-based aggregation AVG and time reference field &PERI.

No aggregation required
Set the No aggregation required indicator if the key figure cannot be aggregated in a report from
the rows or columns before it. For example, sales revenue per employee for all plants cannot be
calculated from the relevant key figures for the individual plants, but rather must be calculated
using the cumulated revenue and the total of all employees. The collective key figure must be
calculated in the results row on the basis of a new formula.

 

Month Sales Employees Sales/Employee

Plant 1 100 1000 0,1

Plant 2 1000 100 10

Result 1100 1100 10.1 or 1?

In the above example, it is important that the results row is not calculated like the other rows
(sales divided by employees) but that it is calculated using a formula defined for the cell.

The No aggregation required indicator must be set when

•  Operators other than =, + and - are used in the key figure

•  The No aggregation required indicator is set in a key figure used in the formula

•  A time-based or non-time-based rule other than SUM is used in any basic or calculated
key figure used in the formula.
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Key Figure Groups
You can create key figure groups and assign key figures to these groups You can use these key
figure groups in the report definition in order to simplify the selection of key figures. Before you
assign a key figure to a key figure group during key figure maintenance, you must first have
created key figure groups in Customizing.
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Displaying and Deleting Calculated Key Figures
To display or delete the calculated key figures for an aspect, choose Information system → Key
figures → Display from the EC-EIS application menu.

Displaying calculated key figures
Enter the aspect and choose Display. If you also wish to display the formulas defined for the
calculated key figures, choose With formula. Choose Execute to display all the calculated key
figures in the selected aspect.

Deleting calculated key figures

 
This function immediately deletes all calculated key figures in the selected aspect
without displaying them first.

Enter the aspect and choose Delete. Use Execute to delete all calculated key figures in the
selected aspect.
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Master Data
The master data consists of the permitted characteristic values of a characteristic and the
relevant descriptive texts. When the transaction data is recorded, the system checks the
characteristic value entries against this master data. There are two types of master data:
characteristic values for fixed characteristics and characteristic values for user-defined
characteristics.

Characteristic Values for Fixed Characteristics
Each EC-EIS and EC-BP data structure contains the fixed characteristics version, plan/actual
indicator, fiscal year and period.

The plan/actual indicator separates plan data from actual data in the database. The planning
functions edit plan data exclusively, data entry edits actual data exclusively. The data transfer
applies equally to plan and actual data.

The version allows you to hold differing datasets in parallel. For the planning it serves as a plan
version, but the actual data can also be held in different versions.

Reporting can compare plan and actual data of different versions in one report.

 
The version and plan/actual indicator in Release 4.0 replace the version and the
value type of earlier releases. The ‘Version’ of previous releases has been renamed
as ‘Data area’. Neither the data area nor the value type are fixed characteristics in
Release 4.0. However, they can still be managed as user-defined characteristics in
the aspect. You can get details on the conversion from Release 3.x to 4.0 in the
Release Information in the System.

The master data for the fiscal year are the fiscal years you wish to report on.

You define the number of periods per fiscal year in the fiscal year variant.

You maintain the values of the fixed characteristics version, fiscal year and period in
Customizing. The characteristic values for the plan/actual indicator are delivered and do not have
to be maintained.

Characteristic Values for User-Defined Characteristics
After you have created the user-defined characteristics you require in the aspect, you must
define the corresponding characteristic values. For more information, see Maintaining Master
Data [Page 47].

When defining a user-defined characteristic, you can store one or more characteristics as
attributes, for example, product group for a product. In this case, during master data
maintenance, you do not just enter the characteristic values for a characteristic, but you also
assign them to the attributes.

You can link characteristic values with one another using derivation rules. This way, in either
manual data entry or automatic data transfer, you can derive unentered characteristic values
from other values. For more information, see Derivation of Characteristic Values [Page 54].
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Maintaining Master Data
To maintain characteristic values for the user-defined characteristics, choose Master data →→→→
Characteristic values → Maintain in the application menu. Maintenance involves three steps.
You can display characteristic values in a similar way.

1. Enter an aspect to narrow down the selection of characteristics.

2. Select a characteristic to be maintained.

3. Change or add to the list of characteristic values.

Sometimes, other characteristics are assigned to this characteristic as attributes. If this is
the case, further columns appear, in which you can enter the attributes for the
characteristic values, for example, product group for the product. Note that the multilevel
attributes are derived automatically, and may not be changed here.

Choose Master data →→→→ Characteristic values → Import file to import master data from a file
into the system. The procedure is described in Importing a File [Page 84]
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Deleting Master Data
To delete the characteristic values for user-defined characteristics, choose Master data →→→→
Characteristic values → Delete in the application menu. Proceed as follows:

1. Enter an aspect to narrow down the selection of characteristics.

2. Select a characteristic to be edited.

3. Select one or more characteristic values.

4. Choose Delete.

Using Master data →→→→ Characteristic values → Delete, it is also possible to delete characteristic
values without displaying them first.
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Master Data Hierarchy
What is a master data hierarchy?
You can define hierarchical relationships between the characteristic values for many
characteristics used in EC-EIS and EC-BP. You can evaluate these in drilldown reporting or edit
them in business planning. You can, for example, portray a hierarchy of your company’s products
or customers. You can define various variants of a hierarchy, which you can then display in
reports. These variants enable you to analyze simulations and ‘What if...?’ situations.

You create a master data hierarchy based on the master data of a characteristic (the
characteristic values). Note that where different characteristics refer to the same master data
table, the hierarchy is the same too. You cannot maintain external hierarchies for characteristics
without master data tables. This is the case for characteristics which were created for Release
3.0 without check and text tables.

It is important to remember here that hierarchies are based on one characteristic. This means
that only the characteristic values of one characteristic are contained in a hierarchy. Furthermore,
each characteristic value may only occur once in the hierarchy. Therefore, each value remains
unique in the overall hierarchy.

It is possible to create alternative hierarchies based on the same characteristic in order to
simulate different combinations. These alternative hierarchies are stored as hierarchy variants.
Up to 999 different variants of a hierarchy can be created for one characteristic.

Hierarchies from other applications (in EC-EIS only)
Standard hierarchies for certain objects are also maintained in other application components. As
with other characteristics, you can create a separate master data hierarchy in EC-EIS and
maintain different variants. However, in EC-EIS it may sometimes be helpful to report using the
standard hierarchies. You can use these standard hierarchies, created in other application
components, as reference hierarchies in EC-EIS. This means that you do not have to reconstruct
such hierarchies. Note that you cannot change the reference hierarchy in EC-EIS. Changes to
the hierarchy must be undertaken in the original application component, for example, the
standard hierarchy for cost centers must be maintained in Cost Center Accounting.

The reference hierarchies that you can use in EC-EIS are the cost center, cost element, and
profit center hierarchies as well as the HR organizational structure, company group and the
balance sheet/income statement structure. In order to make a reference hierarchy visible in EIS,
the corresponding characteristic in EC-EIS (for example, cost center) must refer to the original
object (meaning data element and domain) in the application component. If a hierarchy already
exists in a component and the corresponding characteristic is maintained in the aspect, the
hierarchy appears automatically for selection in drilldown reporting. If you have also created one
or more hierarchy variants for the characteristic in EC-EIS, these will also appear for selection. In
Customizing, for each hierarchy, you can set how they should be displayed in the report,.

In order to be able to select a hierarchy for cost centers, cost elements or profit
centers in reporting, you must have selected the characteristic Controlling area in
the report and have entered a value for it.

To be able to select a balance sheet/income statement structure you must have
selected the characteristics Company code and Chart of accounts in the report.
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You can also transfer master data hierarchies from other systems into EC-EIS or EC-BP. You
can find detailed information on this in Customizing.

Term explanations
A master data hierarchy defines hierarchical relationships between characteristic values. Some
term definitions are necessary to describe the basic concept.

Each characteristic value contained in the hierarchy represents a hierarchy node. If such a node
contains further dependent nodes, it is called a structure node. If a node has no dependent
nodes, it is called an end node.

This classification only refers to the hierarchical position of the node, therefore only to the
existence of dependent nodes. A further classification is required regarding the relationship to the
master data.

A node whose characteristic value is contained in the master data is called a chargeable node.
Since the consistency between master data and transaction data is checked when data is
posted, you can only charge to those characteristic values represented by the master data.

A node, whose characteristic value is not contained in the master data, is called a non-
chargeable node. Nodes like this are stored in their own EC-EIS tables with appropriate texts.
To maintain these nodes use the hierarchy maintenance functions or choose Master data →
Master data hierarchy → Non-chargeable nodes in the application menu.

The distinction between chargeable and non-chargeable nodes gives no indication as to their
hierarchical position as structure nodes or end nodes. The following combinations are possible:
chargeable structure nodes, chargeable end nodes, non-chargeable structure nodes, and non-
chargeable end nodes. These four terms are used in connection with master data hierarchies.
Note that only nodes containing values are displayed in the presentation.

For more information, see Example: Master Data Hierarchy [Page 53].

Consistency of the master data hierarchy
A master data hierarchy does not have to contain all existing characteristic values. If new master
data is created, this has no effect on the hierarchy.

Every characteristic value in the master data hierarchy must exist as a chargeable or
non-chargeable node. This means that if you delete a master data record, the
corresponding chargeable node will be deleted automatically. If this is a structure
node, all dependent nodes will also be deleted.

Since non-chargeable nodes are stored in tables, but master data can be managed from other
applications, it is possible to create a new master data record with a characteristic value which
already exists as a non-chargeable node. In such cases, the non-chargeable node is replaced by
the chargeable node. The rule is that chargeable nodes supersede non-chargeable nodes

For more information, see Maintaining the Master Data Hierarchy [Page 51].
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Maintaining the Master Data Hierarchy
For more information on the master data hierarchy concept, see Master Data Hierarchy [Page
49]. See also Example: Master Data Hierarchy [Page 53].

To maintain the hierarchies, choose Master data → Master data hierarchy → Edit.

Creating a master data hierarchy
1. Enter the name of the characteristic for which you wish to create a hierarchy. Enter a

number between 1 and 999 for the hierarchy variant.

  
 If you enter a characteristic which has been created with the same data element and
same domain as another characteristic, the hierarchy is valid for both characteristics
because it has the same characteristic values. A list of the affected characteristics
appears automatically in the lower part of the screen.

2. Choose Hierarchy → Create

 The next screen contains information about the hierarchy

3. Enter a description of the hierarchy and, where necessary, select Visible system-wide.

 If you select Visible system-wide, the current variant will be active in all the applications
using the master data hierarchy maintenance,. Otherwise, the variant is only available in
EC-EIS and EC-BP.

4. Choose Goto → Back.

5. Now add the hierarchy nodes you require.

 Position the cursor on a node and press F4 to display the chargeable characteristic
values. Select the desired characteristic value or an existing non-chargeable node.

 To enter a non-chargeable characteristic value which does not yet exist, choose Goto →
Maint.non-chrge.node.

6. After adding the characteristic values you require, save the hierarchy.

Each characteristic value may only occur once in a hierarchy variant. If a characteristic value is
already contained in the hierarchy, it no longer appears as a possible entry. There are various
functions in the Edit menu for adding new nodes:

•  Create entry → Same level

A blank node is added on the same level as the selected entry.

•  Create entry → One level lower

A blank node is added on the level below the selected entry.

•  Create sev. entries → Same level

Several blank nodes are added on the same level as the selected entry.

•  Create sev. entries → One level lower

Several blank nodes are added on the level below the selected entry.
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•  Create range → Same level

A range is added on the same level as the selected entry.

•  Create range → One level lower

A range is added on the level below the selected entry

With these last functions you can enter a value range, that is from characteristic value X
to characteristic value Z.

Changing, displaying, copying and deleting a master data
hierarchy
You perform the functions Change, Display, Copy and Delete in a similar way to Create.

You can copy an existing hierarchy from one hierarchy variant into another, and use it as the
basis for a new hierarchy. You can then change it as necessary.

When you change a hierarchy, you can add new nodes, remove existing ones and also cut out
and insert parts of the hierarchy.

You can search for certain values in the hierarchy by choosing Edit → Find → Characteristic
value. You can also see the relationships between the nodes by positioning the cursor on a node
and searching according to parent, 1st child and so on.

In order to facilitate working with the hierarchy, you can expand and collapse the groups and
subgroups by clicking on the plus and minus signs.

On the initial screen, you can delete a hierarchy variant that is no longer required.
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Example: Master Data Hierarchy
The following is an example of a master data hierarchy for the characteristic Country. This
characteristic has the characteristic values (or master data) Germany, USA, France and so on. A
hierarchy is built up from these characteristic values with the help of a structure. The structure
consists of the structure nodes World, America, Europe and Asia. Apart from Asia the structure
nodes are not characteristic values and therefore cannot be posted to. All characteristic values
can be posted to. You can also create different variations of this hierarchy.

W World

X America

Y Europe

Nodes

.....    ..... .....    .....

non-chargeable
chargeable

Master data

Country

D Germany
Germany

Spain

Japan

France

Sweden

USA

Canada

Mexico

U
F
S
E
C
M
A
J

USA
France

Sweden

Spain

Canada

Mexico

Asia
Japan

World

Europe

America

Asia

External hierarchy
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Derivation of Characteristic Values
When manually entering transaction data or plan data, or during data transfer, it can be helpful to
determine unfilled characteristic values automatically from other existing characteristic values.

To implement these links you must define derivation rules. These rules are defined in a similar
way to the transfer rules for data transfer, and are maintained in Customizing.

 
The derivation rules are valid in all aspects. As soon as you define a derivation rule
for a characteristic, this rule is valid for all aspects in which the characteristic is
defined.

The receiver field is the characteristic that is to be filled with a value. The sender field is the
characteristic whose value determines the contents of the receiver field.

 
The characteristic product group is linked to the characteristic division. Each
characteristic value of the product group can be uniquely assigned to a division. The
product group washing machines belongs, for example, to division electrics.

In the above example the characteristic division is the receiver field. A characteristic
value for the division is derived dependent on the value in the sender field (product
group). In the example, the division electrics is derived from the product group
washing machines.

If a field to be derived is already filled with a characteristic value, it will not be overwritten. You
can, therefore, enter a value which deviates from the derivation rule during manual data entry,
planning or during data transfer. This value always takes precedence over the derived value. If a
characteristic value cannot be assigned because of the rules, the characteristic value remains
vacant. For example, you might have created a new product group tumble dryer, but not have
maintained it yet in the corresponding derivation rule. This means that a value for the
characteristic division cannot be derived from the product group.

Derivation with manual data entry and planning
With manual entry of transaction or plan data, the derivation is carried out in two places:

1. After the entry of a new data record, the unspecified characteristic values of the record
are derived.

2. Before existing data records are read, the unspecified characteristic values are derived
using the rules created in Customizing. The records matching the selection criteria are
then displayed.

 
Only those records that correspond exactly to the selection criteria and the derivation
rules are displayed. If you manually entered a deviating value for a characteristic
value to be derived, and posted the record, this record is only displayed if the
characteristic was limited to the deviating value. However, all posted records are
displayed if selected in the presentation.
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You have manually entered a data record in which you have specified the product
group washing machines and the division household. Although there is a
derivation rule that defines the link between product group washing machines and
division electrics, the manual entry is not overwritten. However, if you want to
display the saved data records for the product group washing machines with the
data entry transaction, and do not enter the division in the selection conditions at the
same time, the record with product group washing machines and division
household will not be displayed.

Choose Extras → Further characteristics in the data entry transaction or in planning with a layout
to display a list of all characteristics and their values. Derived characteristic values are also
displayed.

For more information on manual data entry, see Individual Record Entry for Transaction/Plan
Data [Page 61]  and Entering Data with Layouts [Page 66].

Derivation with automatic data transfer
In the data transfer, the derivation rules are executed only after the transfer rules for the sender
structure have been executed. For more information on data transfer, see Data Transfer [Page
99].
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Currencies in EC-EIS and EC-BP
There are three ways to determine the currency in which data in EC-EIS and EC-BP is to be
stored.

Defining the currency via the aspect
The aspect determines in which default currency the basic key figures (whose unit is a currency)
are to be stored. If you do not determine anything else with respect to the currency of a basic key
figure then the data for this basic key figure is saved in the aspect currency.

Defining the currency for a basic key figure
For each basic key figure, you can define the currency in which the data is to be stored,
independent of the aspect. You define the currency when you create a basic key figure. A
currency defined in this way supersedes the currency of the aspect.

Defining the currency depending on the characteristic value
You may wish to store the values in a certain currency depending on the characteristic value
concerned, such as balance sheet data in company code currency or cost accounting data in
controlling area currency. To do so, define a currency reference to a characteristic for each basic
key figure so that the currency is determined from the characteristic value currency. The basic
key figure amount will then be interpreted in the currency determined by the characteristic value
currency. A currency defined in this way also supersedes the default currency of the aspect.

The various procedures for defining currencies for basic key figures are described in
Customizing.
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Currency Translations
Use
When you transfer external data into an aspect, currency translations allow you to determine how
currency-related key figures are translated for display in EC.

Integration
The specific currency translation options you have depend on the global Customizing settings
that have been made.

Prerequisites
The data to be transferred has a currency reference, for example prices or salaries.

Features
Exchange Rate Type
You choose the appropriate exchange rate type to be used from numerous possible exchange
rate types. These include for example buying rate, asking rate, official average rate etc. You
define the available exchange rate types in Customizing.

Target Currency
You make settings concerning the target currency. There are two strategies available for this.

•  Fixed: You specify a currency into which the currency data is translated during transfer. This
is an optional setting and in some cases it may be better not to specify a currency. For
example, in drilldown reporting you can only use certain translation types if no target
currency has been specified for data transfer.

•  Variable: Besides setting a fixed target currency, you can also designate a variable target
currency. You must also create the reference to a characteristic here, on which the choice of
currency depends. You do this by specifying a table and a field in the table. The value of the
field will determine the target currency, foe example the field COUNTRY1 in the country table
T005.

Inverse Exchange Rate
You can determine that an exchange rate inversion is to be carried out. This can be necessary if
the transferred data was already translated into another currency, and if the data is to be
displayed in drilldown reporting in the original currency.

Currency Translation Date
You can define the time frame for currency translation. The two available currency translation
strategies differ as follows:

•  Fixed: The currency translation is carried out using the exchange rate from a specific date.
This can be either the rate from the current date or a spot exchange rate.

•  Variable: The currency translation is carried out using an exchange rate that is derived from
the posting date of the transferred data records, for example period start, year end.
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Quantity Units in EC-EIS and EC-BP
There are three ways of defining the quantity units in which data in EC-EIS and EC-BP is to be
stored.

Defining a quantity unit per data record
If you do not want to use the methods listed below, you can post quantities per data record in any
units as you like.

Defining the quantity unit for a basic key figure
For each basic key figure, you can define the quantity unit in which the data is to be stored. You
define the quantity unit when you create a basic key figure. This means that the values for this
key figure can be stored in all aspects using only that quantity unit.

Defining the quantity unit depending on the characteristic value
If you wish to maintain the values dependent on a single characteristic value using a specific
quantity unit, you can define a reference to that characteristic for a basic key figure so that the
quantity unit is determined from the characteristic value. A quantity of the basic key figure will
then be interpreted with the quantity unit determined by the quantity unit of the characteristic
value. An example of this is the activity quantity of a cost center, that is stored in the same units
as defined in the master record of the activity type. If quantity unit Hours is defined for quantity
type Production hours, the activity quantity of a cost center which references this will also be
Hours.
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Transaction Data
The transaction data is usually transferred automatically from other applications (see Types of
Data Transfer [Page 100]). However, you can enter transaction data manually. Individual record
entry is possible, or several at once using a layout.

•  You can find a description of individual record entry in Entering Transaction Data in
Individual Records [Page 61].

•  You can configure the screen structure for multiple-object data entry as you wish. You
must define a data entry layout in Customizing before you enter any values. For more
information, see Maintaining a Data Entry Layout [Page 63].

The procedure of a data entry session is described in Entering Data with Layouts [Page
66].

Using Transaction data → Transfers → Import file in the EC-EIS application menu, and Plan
data → Transfers → Import file in the EC-BP application menu, you can import transaction data
or plan data from a file into the SAP R/3 System. The procedure is described in Importing a File
[Page 84].

The use of Summarization Levels [Page 195] can improve the response times in reporting by
creating duplicate, summarized data sets.
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Individual Record Entry for Transaction/Plan Data
When entering data records individually, you can enter values for all the key figures for one
object (combination of characteristic values) in the entry screen. You maintain the individual
records in  the EC-EIS application menu under Transaction data → Data entry → Maintain
record, and in the EC-BP application menu under Plan data → Transfers → Maintain record. You
maintain the transaction or plan data in four steps:

1. Enter the aspect. Choose Continue.

 A simple layout is automatically created for the aspect, and given a name. The
characteristics for this aspect are displayed.

2. Enter characteristic values for the fixed characteristics of the data record: Plan/Actual
indicator, Version, Fiscal year and Period. Specify the characteristic values for the
desired user-defined characteristics. By doing this you determine the objects to be
entered in this session.

 If you specify the dependent characteristic (for example, the region) of a compound
characteristic, you must also enter the characteristic it depends on (for example country).
For information on compound characteristics, see Creating an Aspect [Page 32].

 Your entries are checked against the master data and the derivation rules. When you
have entered a characteristic value, from which the characteristic value of another
characteristic can be derived, the value is derived according to the corresponding rule.
For more information, see Derivation of Characteristic Values [Page 54].

 If you wish to enter the record in a foreign currency, enter the currency in the currency
field.

 Select the Overview Screen.

3. The basic key figures of the aspect are displayed.

 Enter the values with units where necessary in the columns.

 The units will be checked against the currency or quantity unit table. Values that have
been entered in a foreign currency are automatically translated, with translation key 005
and the stored parameters, into the currency of the characteristic value, the aspect or
key figure.

 To display a list of all characteristics and their values, choose Extras → Other
characteristics. Derived characteristic values are also displayed.

 To create, display, change or delete comments on transaction data or plan data, position
the cursor in the cell for which you wish to see the comment and then choose
Environment → Comments. Existing comments on the selected transaction or plan data
are listed in a dialog box. The comments are selected according to the cursor position. If
you position the cursor in a cell, you get comments for the combination of key figure and
characteristic values, that determines the contents of this cell. You can also call up
comments for columns or rows, but the selection may only contain one key figure in each
case.

 Using the corresponding icons you can display, change or delete these comments. If you
wish to create a comment for the selected transaction or plan data, another dialog box
appears.
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– If you wish to enter the comment in SAPscript, enter a short text and choose
Continue. You can enter and format your text.

– If you want to upload the comment from a PC application, enter a short text and
choose Import.... You can select a file from your PC.

 The necessary preparations for maintaining comments on transaction or plan data are
described in Customizing.

4. Choose Transaction data → Post.

If validations have been created for this layout, they are now checked. For more information, see
Activating the Validations for the Data Entry [Page 76].

You can change and display an individual record in a valid currency by entering the appropriate
currency. Changes are automatically translated into the characteristic, version, or key figure
currency just as they are when you create a record.
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Maintaining a Data Entry Layout (EC-EIS)
When maintaining transaction data with a layout you can maintain actual data for a selection of
key figures and characteristic values on one screen. You must first have created a data entry
layout in Customizing. With the layout you define the specific screen structure for data entry. A
layout is similar to a form in drilldown reporting and can be used as many times as you like for
entering data. You can find a detailed description of the creation of a layout in Customizing.

Structure of a layout
All layouts are based on the following structure:

T i t l eT i t l e

Header

Lead columns Value columns

The fixed characteristics, Plan/Actual indicator, Version, Fiscal year and Period have to be
specified in the data entry layout. You can set these either in the header (meaning in the general
selections), in the lead column, or in the columns.

Definition of the header
Several characteristics make up the header of a layout. You can choose these from the general
selections using Edit → Gen. data selection → Display/change. You can specify characteristic
values, define an interval or create variables for the characteristic values.

 
With compound characteristics, the superior characteristic must be defined either in
the general selections or in a lead column. If you define the superior characteristic in
the header you must select a single value. If you want to enter data for several
characteristic values you should define the characteristic in a lead column (see
Definition of a Lead Column below). For more information about compound
characteristics, see Creating an Aspect [Page 32].

Using Edit → Gen. Dat.selections → Header layout you can change the sort order of the
characteristics that you chose for the header and, if necessary, hide characteristics. A maximum
of nine characteristics can be shown in the header. If you select more than nine you must hide
the others.
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Definition of a lead column
The lead column defines the contents of the rows. You have two options for defining a lead
column:

•  By selecting a row you can select desired characteristics and, where necessary, key figures
for this row. You must then select exactly the same characteristics in the other rows. The
values of the characteristics in the individual rows are not fixed. You can specify the
characteristic values or define variables for them. Similarly you can enter a heading for the
lead column. If you define a lead column with this method you cannot create any further lead
columns.

•  To enter data for a number of characteristics, define a lead column as a single element by
selecting Lead column. You will be requested to select a single characteristic. You can
specify the characteristic value, define a variable for the characteristic value, or select all
characteristic values by entering a *. With user-defined characteristics you also have the
option of defining an interval. If you define a lead column with this method, the key figures
are then in the other columns. You can define up to nine lead columns under Edit →
Columns → New lead column. To rearrange the sequence of the key columns, choose Edit
→ Columns → Sort lead columns

 
If a compound characteristic is to appear in a lead column with text, the superior
characteristic must be limited to one value in the general selections.

Definition of a column
If you have created the lead column as a single element or if you have not defined any key
figures in the rows, the columns (or value columns) will automatically contain the key figures.
Where necessary the columns can also contain characteristics. The key figure for a column is
entered directly. If you have selected a characteristic, you can either enter the characteristic
value directly or create a variable. A column for the attributes is automatically created next to
each column. It contains the unit for the key figure and possesses the same selection criteria as
the column it belongs to, meaning identical key figure, characteristics and characteristic values.

Choose Formatting → Number format to set both the desired number of decimal places and a
scaling factor (for example, entry in 1000s) per column. These settings can be changed during
the data entry.

Variables
Variables enable a more flexible setting up of data layouts. Variables are parameters which you
do not have to specify until the entry session and which can be replaced in different ways. As
described above, within a layout, you can create local variables in the header, in the columns, in
the rows or in the lead column. Local variables begin with $. Within a layout we differentiate
between variables for characteristic values and variables for texts.

Maintaining variables for characteristic values
You can maintain local variables after you have defined them. You can specify for each variable
whether or not a value must be entered in the data entry session. To do so, choose Extras →
Variables → Characteristic value → Maintain variable. If you do not maintain the variable the
system will interpret it as a mandatory entry in the report.



 SAP AG Executive Information System and Business Planning

Maintaining a Data Entry Layout (EC-EIS)

April 2001 65

To maintain the texts for variables for characteristic values, choose Extras → Variables →
Characteristic value → Identifier.

Maintaining variables for texts
Just as with variables for characteristic values, you can maintain local text variables by choosing
Extras → Variables → Text → Maintain variable. In most cases you will probably decide to store
a replacement path, so that the text is pulled automatically from the master data. For local text
variables, you can decide whether the text should be entered during the data entry session or if
the system should determine it. If you decide to have the text entered manually, the text length
will be identical to the variable name length. If you choose to have it replaced automatically, you
can specify how this should be done in a series of dialog boxes. Using various dialog boxes, you
determine which characteristic the text is referring to; whether the from or to value should be
taken, whether the variable should be replaced by the characteristic value itself or by the text,
and also the position and length of the text. Note that variables are only then automatically
replaced when it concerns an element with characteristics, and the relevant characteristic was
selected when the element was defined.

After you have created and saved your layout, you can enter data. For more information, see
Entering Data with Layouts [Page 66].

Changing and Displaying a Data Entry Layout
You can change or display an existing layout using the same initial screen. Choose Entry layout
→ Display/Change.
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Entering Actual Data With Layouts (EC-EIS)
When maintaining transaction data with a layout, you can maintain actual values from one
version for a selection of key figures and characteristic values on one screen. You must first have
created a data entry layout in Customizing. For more information, see Maintaining a Data Entry
Layout (EC-EIS) [Page 63].

After you have created the entry layout, you can enter data under Transaction data → Data entry
→ Maintain with layout  as follows:

1. Enter the aspect and the layout.

 To display information about the contents of the layout choose Extras → Layout.

2. On the following screen, specify the variables that may be defined for certain
characteristics in the layout. This way you determine the objects to be entered in this
session.

 Your entries are checked against the master data and the derivation rules. When you
have entered a characteristic value, from which the characteristic value of another
characteristic can be derived, the value is derived according to the corresponding rule.
For more information, see Derivation of Characteristic Values [Page 54].

 If you do not enter any characteristic values, and no derivation rule is defined, the data is
entered on the Not assigned level of the corresponding characteristic.

 In Currency, enter the currency of the values you wish to enter as an entry tool. The
currency-relevant values to be entered in the session are automatically translated to the
currency of the characteristic, the aspect or key figure with translation key 005 and its
parameters. If a different currency translation key should be used, you can set this in
Customizing.

3. Select Goto → Overview screen or Goto → Period screen.

Overview screen
After you have specified the variables, you can enter the values on this screen. The overview
screen corresponds to the layout you created in Customizing.

Enter the values (with units where necessary) in the columns.

 
Note: if you enter values with different quantity units for a key figure and then save
them, the various values will be saved despite their different units. The unit is
validated only when a fixed unit or a reference unit has been assigned to the key
figure. If, in such a case, you enter different units belonging to the same basic unit,
such as gram (g) and kilogram (kg), the values are automatically converted into the
fixed or reference unit.

If you have established an interval for a characteristic in the header of a layout, you can scroll by
choosing Goto → Next combination/Previous combination.

 
If, within an interval, data for a combination of characteristic values does not yet
exist, this combination will be automatically skipped. If you wish to enter data for this
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combination, you can maintain variables for the from and to values of the
characteristic, and then enter individual values instead of intervals. Alternatively, you
can enter this data using another layout. To enter data for a series of values for a
characteristic for which data possibly does not exist yet, you should define these
values in a lead column instead of in the header.

To create, display, change or delete comments for transaction data, position the cursor in the cell
for which you wish to see the comment and then choose Environment → Comments. Existing
comments on the selected transaction data are listed in a dialog box. The comments are selected
according to the cursor position. If you position the cursor in a cell, you get comments for the
combination of key figure and characteristic values, that determines the contents of this cell. You
can also call up comments for columns or rows, but the selection may contain only one key figure
in each case.

Using the corresponding icons you can display, change or delete these comments. If you wish to
create a comment for the selected transaction data, a different dialog box appears.

– If you wish to enter the comment in SAPscript, enter a short text and choose Continue.
You can enter and format your text.

– If you want to upload the comment from a PC application, enter a short text and choose
Import.... You can select a file from your PC.

The necessary preparations for maintaining comments on transaction data are described in
Customizing.

To change the number of places after the decimal point and the scaling factor on both screens
choose Settings → Number format. To display a list of all characteristics and their values, choose
Extras → Other characteristics. Derived characteristic values are also displayed.

Period Screen
The period screen is automatically created from the overview screen and displays the periods in
the rows. The values on this screen are always distributed the same way. If you already entered
values on the overview screen, they are distributed evenly over the periods. You can change the
period values and thereby the weighting. If you change the values later on the overview screen,
they will be distributed on the period screen in the same way as the manually entered period
values.

 
Note: on the period screen you can neither change the units nor scroll through the
various characteristics in the header.

When you have entered your data, choose Transaction data → Post.

If validations have been created for this layout, they are now checked. For more information, see
Activating Validations for Data Entry and Planning [Page 76].

Displaying transaction data
Starting from the same initial screen you can display the transaction data entered for a layout.
Choose Transaction data → Display. For more information on displaying the posted data, see
Derivation of Characteristic Values [Page 54].



Executive Information System and Business Planning  SAP AG

Entering Actual Data With Layouts (EC-EIS)

68 April 2001



 SAP AG Executive Information System and Business Planning

Transaction/Plan Data, Displaying or Deleting

April 2001 69

Transaction/Plan Data, Displaying or Deleting
Displaying transaction data
To display transaction or plan data: in the EC-EIS application menu choose Transaction data →
Data entry → Display data, and in the EC-BP application menu choose Plan data → Transfers →
Display data.

1. Enter the aspect and choose option Display transaction data. Choose Execute.

The system displays a selection screen.

2. Specify the amount of transaction data you wish to display and choose Execute.

The system displays a list of the data you have selected.

3. Select a record and choose Choose.

The system displays the transaction data.

Deleting transaction data
To delete transaction data or plan data from an aspect, choose Tools → Data → Delete
transaction data or Delete plan data.

Enter the aspect in each case and choose the relevant functions. Then choose Execute.

Displaying data records for selective deletion
Specify the data records you wish to display and choose Execute. The selected records are
displayed.

You can delete records by selecting them and choosing the function Delete.

Deleting data records immediately

 
This function deletes the data you select without displaying it first.

Select the transaction data to be deleted and choose Execute.

If you confirm the warning issued by the system, the data is deleted. The system displays a
log of the deleted records.

Deleting individual key figure columns
This function allows you to delete transaction or plan data for certain key figures without deleting
the entire record.

For the characteristic values, enter either individual values, intervals or the generic entry *.
Choose Select key figures. Select the key figures whose transaction or plan data you wish to
delete. Choose Delete key figure values. If you confirm the warning issued by the system, the
data from the selected key figures is deleted.
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Validations
The validation function lets you check the values and value intervals entered in the R/3
environment with the help of user-defined rules. If data is entered in the system, it is checked
against the validation rules. If the data does not correspond to these rules, it may not be posted
in certain circumstances,. Since the validation is carried out before posting, only checked data is
accepted into in EC-EIS and EC-BP.

Validations are always valid for one aspect and are created in Customizing. How you maintain
and copy validations is described in detail in Customizing.

If are you maintaining validations for the first time for an aspect, the system first generates the
necessary environment.

The validations can be used in three places in EC-EIS and EC-BP.

1. You can lay down rules for the manual entry of transaction data, which are checked
before saving. This way you can avoid entering meaningless or incorrect data. (For
general information on data entry, see Transaction Data [Page 60]).

2. As with the entry of transaction data, you can store rules for interactive planning that
are checked before saving. (For general information on planning, see Business Planning
[Page 115]).

3. Validation rules can also be stored for automatic data transfer. The received records
are checked against these rules after the summarization but before posting. This way
incorrect or meaningless data will not be transferred to EIS. (For general information on
data transfer, see Data Transfer [Page 99]).

Each validation consists of up to 999 steps. A check processes the steps one after the other. A
validation step consists of the following components:

•  Prerequisite

The entry values to be verified are selected using the prerequisite. If entry values are not
selected for verification (if the prerequisite is not fulfilled), then the values are valid and
the transaction will be carried out. In some cases, the use of a prerequisite is not
necessary.

•  Check

During the check, the values selected using the prerequisite are verified. If the check
result is true (TRUE), the transaction is continued. If the check result is false (FALSE), a
message is issued by the system.

•  Message

If the prerequisite is fulfilled, but the check is not, the system issues a message.

Prerequisites and checks are defined with the help of Boolean logic. You can define simple
logical statements, or you can use rules, user exits and sets in your logical formulas to define
very complex statements. You can find further information about Boolean logic under Validations,
Substitutions, and Rules [Ext.].

There are four different types or importance levels of messages:

Type A Termination
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Type E Error

Type W Warning

Type I Information

Messages of type A and E are genuine errors, which lead to the data not being updated.
Messages of type W and I are only additional information which is logged, but the data is updated
anyway.

Types of Validation
There are two different types of validation in EC-EIS and EC-BP.

1. Single record validation
Each new or changed data record is checked individually in single record validation. For
example, a check can be made as to whether the sum of two key figures is lesser than or
equal to a third key figure.

 
If revenue is greater than zero, then it must be greater than the sum of the bonuses
and sales commissions.

You can find out how to define this validation under Example of Single Record
Validation [Page 73].

2. Matrix validation
The data records are checked in their entirety with the matrix validation. For example, a
check can be made, as to whether the sum of the assets equals the sum of the liabilities.

 
The plan data for 1998 may not deviate from the actual data for 1997 by more than
20%.

You can find out how to define this validation under Example of a Matrix Validation
[Page 74].

Maintaining and copying rules and validations
You can store parts of validations which you use often or which you wish to use in several
validations. You store them in rules and can use them repeatedly. You can also copy validations
and rules. You can find further information on maintaining validations and rules in Customizing.

Activating validations
After you have created a validation, you must activate it for data entry, planning, or data transfer.
For more information see Activating Validations for Data Entry and Planning [Page 76] and
Activating Validations for Data Transfer [Page 77].
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Example of Single Record Validation
Each new or changed data record is checked individually in single record validation. The
formulas are written here with the technical name of the expert mode. For more information on
creating formulas in the expert mode or formula builder, see Customizing.

Prerequisite Check

Revenue is greater than zero Revenue must be greater than the sum of the bonuses and
sales provision

CF001-REVEN > ‘0’ CF001-REVEN > (CF001-BONUS + CF001-VPROV)
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Example of a Matrix Validation
The data records are checked in their entirety with the matrix validation. Two rules are used in
this example. A check is made as to whether the plan data for 1998 does not deviate by more
than 20% from the actual data for 1997. There is no prerequisite in this example.

The formulas are written here with the technical names of the expert mode. For more information
on creating formulas in the expert mode or on the formula builder, see Customizing.

Rule ACT97:

CF001-PLACTI = ‘0’ ”Actual” AND CF001-YEARB = ‘1997’ ”Year”

“Plan/Actual indicator actual and year 1997”

Rule PLAN98:

CF001-PLACTI = ‘1’ ”Plan” AND CF001-YEARB = ‘1998’ AND CF001-VERSIO =
‘001’ ”Version 001”

“Plan / Actual indicator plan and year 1998 and version 001”

Check:
SUM ( CF001-REVEN) WHERE ACT97

“Application of the rule ACT97”
GROUP_BY CF001-PERIO CF001-DIVSN

<= 1.20 * SUM ( CF001-REVEN) WHERE PLAN98

“Application of the rule PLAN98”
GROUP_BY CF001-PERIO CF001-DIVSN

AND

SUM ( CF001-REVEN) WHERE ACT97

GROUP_BY CF001-PERIO CF001-DIVSN

>= 0.8 * SUM ( CF001-REVEN) WHERE PLAN98

GROUP_BY CF001-PERIO CF001-DIVSN

The entire quantity of the records is limited by the where condition to the actual values 1997 or to
the plan values 1998. The group statement ensures that the revenues are summed and the
variance checked for each combination of division and period. The group statement must be
identical on both sides of the comparison operator. As soon as the check for one combination of
division and period is not fulfilled, the entire check becomes invalid.

 
No data is read for the validation. The data that the validation is supposed to check
must be selected using the sender program or the data entry layout. In this case, you
must ensure that both the actual values for 1997 and the plan data for 1998 are
available for the validation.
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Activating Validations for Data Entry and Planning
Activating
After you have created Validations [Page 70], you establish when and which of the validations
are checked during the data entry or planning. Activation of validations also occurs in
Customizing.

On the initial screen of the validation maintenance choose Validation → Activate for → Data entry
or Planning. A table appears in which you make entries for the various data entry layouts or
planning layouts, and where you can assign a single record validation and/or a matrix validation
to each layout. If a validation field does not exist in the layout, the system issues a warning. You
can also assign a validation rule directly when maintaining the sender structure. (For general
information on data entry, see Transaction Data [Page 60]).

Checking data during data entry or planning
After you have entered data in a data entry layout or planning layout, choose Transaction data →
Post. or Planning → Post. At this time the validations you have activated for the layout are run.
With a single record validation, only the new and changed data records are checked. With a
matrix validation, however, all records are checked.

 
Only period values are checked. This means that, if you enter values on the overview
screen, and these are distributed across periods, then the figures of the period
screen are checked rather than the figures you can see..

If the data does not correspond to one of the validation rules, the message created for it appears:

•  If there are only messages of type W (Warning) or I (Information), a log is written but the
data is saved anyway.

•  If a message of type A (Termination) or E (Error) is present, the data is not saved.

During the data entry or planning you can check the validation by choosing Transaction data →
Validate or Planning → Validate. This way you can see the messages before saving, and
possibly correct them.

Evaluating validation logs
To see the validation logs: in the EC-EIS application menu choose Transaction data → Data
entry → Display logs, and in the EC-BP application menu choose Plan data → Transfers →
Validation log. On the following screen, you can limit the selection of logs. The field ext. number
contains the aspect and the entry layout, for example, 001/ABCD. You can also search
generically for all the logs of an aspect, by entering 001/*.

A list of the selected logs appears. To list the messages for each log, choose Goto → Display
messages.
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Activating Validations for Data Transfer
Activating
After you have created Validations [Page 70], you establish when and which of the validations
are checked during the data transfer. Activation of validations also occurs in Customizing.

On the initial screen of the validation maintenance, choose the menu path Validation → Activate
for → Data transfer. A table appears with the sender structures of the aspect. Here you can
assign a validation and/or a matrix validation to the various sender structures. (For general
information on data transfer, see Data Transfer [Page 99]).

Checking data during data transfer
After you have started the data transfer, the validation is automatically executed after the
summarization of the data (with receiver records).

If the data does not correspond to one of the validation rules, the message created for it appears:

•  If there are only messages of type W (Warning) or I (Information), a log is written but the
data is saved anyway.

•  If a message of type A (Termination) or E (Error) is present, the data is not saved. It is
noted in both the validation log and the transfer log that the validation has registered
errors.

Evaluating validation logs
To see the validation logs: in the EC-EIS application menu choose Transaction data → Data
entry → Display logs, and in the EC-BP application menu choose Plan data → Transfers →
Validation log. On the following screen you can then limit the selection of the logs.
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Data Slices
Use
You use a data slice to partition your dataset into subsets. You need data slices if:

•  You want to protect your data from changes

•  You want an overview of the completeness of the data transferred, from other companies
for example.

•  You want to delete certain data before you import new data

The official figures for last month are submitted by the companies of a group. The
companies should not make any more changes to last month’s data. Corrections
may only be made by the responsible person. The companies may, however, report
on the data.

The relevant data slice is ‘open for update’ until the key date when the companies
have submitted their data. After the key date, the status is changed by the system
administration to ‘only responsible person may change’.  Other users’ authorization
to report on this data remains unaffected.

Using the statistics, the responsible person can check if companies have not yet
submitted their data.

Plant 009 was sold. No more data may be posted for this plant. You create a data
slice in which you specify the characteristic value plant 009. Then you lock the data
slice for any changes. This way no new data may be posted for the plant. You may,
however, report on the old data.

Features
You can assign a data slice to one or more aspects. You can also assign comment tables to a
data slice. The characteristics of the aspect, or of the comment table, describe the conditions for
the transfer or maintenance of the data. You can restrict the characteristics by entering
characteristic values, intervals or variables.

The authorization protection is determined by the assignment of users and a responsible person
to the data slice. You manage the data slice using various statuses. If the data slice is open for
update, all assigned users may change the corresponding data. If it is locked, no users may
change the data in the data slice. As a third possibility, only the responsible person may make
changes.

If you attempt to manually change data in a locked data slice, the system produces an error
message. You may not change the data. If you attempt to automatically transfer locked data, the
data will be stored temporarily but not posted. A corresponding message is written in the log.
From within the log you can analyse the errors and update the data, but only when the data slice
is open again.

Note that the data slices may not be used in archiving.
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Comments
You can create comments for the following objects in EC-EIS and EC-BP:

•  Reports (EC-EIS only)

•  Fixed characteristics

•  Characteristics

•  Basic key figures

•  Calculated key figures

•  Master data (characteristic values)

•  Report portfolio reports (EC-EIS only)

You can create comments in various languages for each of these objects. If you do not specify
otherwise, the comments are always created, deleted and changed in the logon language. You
can translate the comments into any of the system-supported languages.

With the exception of the comments on report portfolio reports, they can subsequently be
displayed in drilldown reports (see Executing a Report [Page 182]). If a comment exists for an
object in the logon language, it will be displayed in this language. If it exists in several foreign
languages, it will be displayed in the language which was defined next in the system.

For more information, see Maintaining Comments [Page 81].

Comments on Transaction Data and Plan Data
You can also store and display comments for transaction data and plan data while you are
entering actual data, while you are executing reports, and also by choosing Transaction
data/Plan data → Comments → Comment list [Page 82]. As with other types of comments, these
ones can be created in SAPscript or called up from any PC application that you have on your
computer such as Microsoft PowerPoint, Microsoft Word etc. The necessary preparations are
described in Customizing.
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Maintaining Comments
Choose Master data → Comments → Maintain to maintain comments manually for reports,
fields in the field catalog (meaning characteristics and basic key figures), calculated key figures,
master data (characteristic values), and report portfolio reports. Proceed as follows:

1. Select the object type you wish to maintain and choose Comments → Maintain.

2. On the next screen, select an object and choose Comments → Maintain.

3. Write your text and save it when you have finished.

To copy an existing comment to another object, select the object for which the text exists. Then
choose Comments → Select. Then select the object to which you wish the text to be copied and
choose Comments → Copy. The comment will then appear in both objects.

For an overview of all the existing comments for an object, choose Comments → List. The
comments for the object (insofar as they are available) are set and displayed beneath one
another in all the languages supported by the system.

Choose Master data →→→→ Comments →→→→ Import file to import comments from a file into the
system. For more information, see Importing a File [Page 84].

Comments on Transaction Data and Plan Data
Comments on transaction and plan data are maintained and stored differently. You can display
and add comments when executing a report, when entering actual or plan data, or by choosing
Transaction data → Comments → Comment list [Page 82]. Before you can maintain comments
on transaction or plan data, you must create a comment table and select the characteristics upon
whose transaction or plan data you wish to comment. Then, you must assign the table to the
relevant aspect. You can find information about this in Customizing.
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List of Comments on Transaction Data
Use
Using the comments list you can list the existing comments to certain transaction data of an
aspect. From within the list you can display, change, create, delete, copy and reassign
comments.

Features
You can restrict the selection of comments for transaction data by entering characteristic values.
It is also possible to exclude comments from the selection that have been created for a certain
characteristic. For example, if you only wish to see those comments where no regions were
specified, you select the field Initial for the characteristic region. The system displays a list of
comments found for your selection conditions.

You can sort this list according to certain characteristic values. To do this, choose Edit → Sort. If
you choose the characteristic company code, for example, the comments are sorted in
ascending order according to company code.

With the help of the corresponding icons you can display, change or delete the comments. If you
wish to create a comment for the selected transaction data, another dialog box appears.

– If you wish to enter the comment in SAPscript, enter a short text and select Continue.
You can enter and format your text.

– If you want to upload the comment from a PC application, enter a short text and select
Import.... You can select a file from your PC.

Using the function Comment list → Copy comment, you can copy a comment and assign it to a
second data record where you enter different characteristic values. Using Comment list → Move
comments, you can reassign a comment from one data record to another.

The necessary preparations for maintaining comments on transaction data are described in
Customizing.



 SAP AG Executive Information System and Business Planning

Documents

April 2001 83

Documents
During master data maintenance, you can store documents for EC-EIS and EC-BP master data,
that is, for specific characteristic values.

 
The functions described below are only relevant if you have the Document
Management [Ext.] system installed.

Maintaining and displaying documents
Choose Master data → Documents to connect to the document administration system. Here you
can display and maintain documents for master data.

•  Display

Select an object for which a document has been stored. A dialog box appears with a list
of all the documents stored for this object. From here, you can access a transaction in
the document management system and display a document in bitmap format, for
example.

•  Maintain

Select an object and choose Maintain document. The system displays a dialog box in
which you can enter documents for this object. From here, you can access a transaction
in the document management system and select a document.
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Importing a File
Using this function, you import data from a file. You can transfer transaction data, plan data,
comments and master data hierarchies. In order to import larger datasets periodically, you can
schedule program RKCFILE0 in the background.

Prerequisites
You must have maintained the sender structure, the transfer rules, and where necessary, the
sender structure package (see Types of Data Transfer [Page 100]).

Examples
You can use the following examples to help set the sender structure, the transfer rules, and the
parameters for various tasks:

Importing a File: Transaction Data [Page 87]

Importing a File: Master Data [Page 90]

Importing a File: Master Data Hierarchy [Page 92]

Procedure
To import data from a file, proceed as follows:

1. Depending on whether you wish to import transaction data, plan data, master data,
comments or a master data hierarchy, choose Import file under either Transaction data,
Plan data, or Master data.

2. Enter a sender structure and a file name, or the name of a logical file.

3. Choose File system to define whether the file is on the presentation server or the
application server. Make sure that the process which is to read the data has the correct
access authorization for the file. You must enter the path correctly. If you are reading
data from the application server, ensure that you enter the path from the point of view of
the user who started the application server. Enter the path as an absolute path.

  
 Note that only files from the application server can be imported in background
processing.

4. Under Editing you can choose to:

– Execute a data transfer,

– Display the file,

– Display the assignment of sender record fields to field contents,

– Save the records temporarily.

 If you select Sender set-display field assignments, the system displays a list that makes
clear which value is contained in which sender record field. Using this list, you can see if
you have described the sender structure incorrectly.

5. At File type you determine if you are dealing with a text file. With this type of file, newline
appears at the end of each line.



 SAP AG Executive Information System and Business Planning

Importing a File

April 2001 85

 For a binary file, the SAP binary format is expected. Note that binary files cannot be
imported from the presentation server.

 With TXT format, the fields in the lines should be separated with tabs.

 With CSV format, the fields should be separated with semicolons.

 With MC format, the file to be imported is split into two parts: firstly, lines at the beginning
with characteristic values which are valid for the rest of the records, and secondly,
individual records. The fields in these individual records are split by a field separator
(either a comma or a semicolon). For more information, see Importing a File: File in MC
Format [Page 98].

 Note that with TXT, CSV, and MC formats, fields of type C which are not text fields are
automatically converted into capital letters.

6. If you wish to import numbers in packed numbers, use Number format to define whether
these packed numbers are in the file in double length as characters 0123456789+-, or if
they already exist in SAP format P. Internally, the SAP R/3 System usually works with
packed numbers during a data transfer. If the numbers are stored in single length in the
file, the system assumes that the numbers do not need to be packed into SAP-internal
format. If the numbers are stored in double length in the file, the system converts the
numbers into packed format. The minus sign can be before or after the figures. Apart
from binary and text files, it is assumed that the packed numbers are always stored in
double length in the file and therefore need to be converted.

 Specify if the numbers do not have any editing characters or if they have a decimal point
or comma.

 This option is irrelevant when importing master data or comments on master data, and is
not available in these cases.

 Integers and floating point numbers must be between 12 and 16 bytes in length in the
file.

7. Choose Date format to determine whether the date reads YYYYMMDD or DD.MM.YYYY.
This option only applies to TXT, CSV, and MC formats. For all other formats, the date
reads YYYYMMDD.

8. Other settings:

With Data format you can specify whether the data is in ASCII or EBCDIC format. In
EBCDIC format, all fields apart from packed fields (type P) and hexadecimal fields (type
X) are converted from EBCDIC to ASCII. Fields of type P and X do not need to be
converted.

If your file contains comments rows that are not to be imported, you can indicate them as
such here. Enter the character with which the comment rows begin. The system will then
ignore these rows when importing.

9. Settings for repeat fields:

In many information systems, the period is locked for transaction data. The period is not
then, in the key of the transaction data record. In such cases, the key figures are stored n
times in the data portion of the record, where n is the number of possible periods.
Records of this structure cannot be transformed using data transfer rules into n
transaction data records, in which the period is stored in the key, and the key figure
exists only once in the data portion. A transformation during the data transfer is
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necessary for this. For the data transfer, the period must be contained in the sender
structure.

To transform such a record, proceed as follows:

(a) In Index field, enter the characteristic that only exists in the receiver
structure, for example PERDE (period).

(b) In Repetition factor, enter the number of records to be generated in the
receiver structure, for example 12 (periods).

(c) In Start value for index field, enter the start index, for example (period) 1.
The Increment for index field defines how the index is to develop, for
example start value + 1 (increment).

(d) The Repeat fields are the fields of the sender structure in which the fields of
the original structure are to be summarized.

For more information, see Importing a File: Transformation of a Record [Page 96].

Result
If you have selected Display file, the system displays a list of the transferred records. If you have
selected Sender-set-display field assignments, the system displays additional information about
how the individual fields of the sender record were filled. If you have transferred the data, a
confirmation message will appear. You will find more detailed information on the update and
summarization in the log (see Displaying the Transfer Log and Processing Errors [Page 104]).
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Importing a File: Transaction data
TXT file
You have a TXT file on your PC with the stock prices and the difference from the previous day
for company XXX on the following days:

XXX_13.01.1997_110.50_-2.00

XXX_14.01.1997_112. 00_1.50

XXX_15.01.1997_115. 00_3.00

XXX_16.01.1997_113. 00_-2.00

XXX_17.01.1997_112. 50_-0.50

The underscore ( _) between the fields in the lines symbolizes the TAB character that separates
the fields.

You want to import this data into aspect 004 (stock prices). The aspect contains the
characteristics FIRMA (corporation) and BOTAG (trading day) and the key figures AKURS (stock
price) and DIFFZ (difference).

You create a sender structure KURSE and enter the following data:

Aspect 004

Conversion 0

Field name Ref. table Field name Type Length Dec. places

FIRMA CF004 Corporation C 8 0

BOTAG CF004 Trading day D 8 0

AKURS CF004 Com. stock P 8 2

DIFFZ CF004 Difference P 8 2

With the entry of a field name and a reference table, the other fields are automatically derived
from the reference table. You generate the sender structure and then maintain the transfer rules.
In addition to the characteristic values, that are maintained in the sender structure, transfer rules
have to be maintained for the fixed characteristics VERSIO (version), YEARB (fiscal year),
PERIO (period), and PLACTI (Plan/Actual indicator).

Recv. field Assign. rule Sender field Offset Length Constant

VERSIO SET VERSIO 0

YEARB MOVE BOTAG 0 4

PERIO MOVE BOTAG 4 2

FIRMA MOVE FIRMA 0 0

BOTAG MOVE BOTAG 0 0



Executive Information System and Business Planning  SAP AG

Importing a File: Transaction data

88 April 2001

PLACTI SET 0

You save the transfer rules and then maintain the selection data for importing the file.

To carry out a test run of the transfer, enter the following data:

Field Entry/Selection

Sender structure SHARE PRICE

File Path in which the file can be found. For example d:\file\ablexcel\share.txt

File system Presentation server

Editing Display file

Display sender record -field assignment

File type TXT format

Number format Type P

Decimal point

Data format ASCII

Date format DD.MM:YYYY

Then you can execute the program.

If the test data is satisfactory, you can select Data transfer and execute the program again.

CSV files
In CSV files the fields of a record are separated with a semicolon.

 
If you are working with an English version of MS Excel, note that the fields are
separated with a comma. In this case, save the file as a text file. When importing the
file, select file type Text file with field separator instead of CSV format and enter a
comma (,) as the separator.

XXX,13.01.1997,110.50,-2.00

XXX,14.01.1997,112.00,1.50

XXX,15.01.1997,115.00,3.00

XXX,16.01.1997,113.00,-2.00

XXX,17.01.1997,112.50,-0,50

To execute this example with a CSV file, you would basically set the parameters as for a TXT file,
with the exception of the path and file type.
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Text file
To transfer a text file without an editing character (neither a +/- sign nor a decimal point) with this
sender structure and these transfer rules, the file to be imported must read as follows:

XXX199701130001105000000200-

XXX199701140001120000000150

XXX199701150001150000000300

XXX199701160001130000000200-

XXX199701170001125000000050-

(FIRMA BOTAG AKURS DIFFZ)

This format is given by the specified length and decimal places in the sender structure.

In order to execute this example using a text file without editing characters, the parameters must
basically be set in the same way as a TXT file, with the following exceptions:

Field Entry/Selection

File type Text file

Number format No editing characters

Date format YYYYMMDD

See also:

Importing a File [Page 84]
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Importing a File: Master Data
You have a TXT file on your PC with the following product group characteristics:

LADIES_Ladies shoes

MENS_Mens shoes

CHILDREN_Childrens shoes

The underscore ( _) between the fields in the lines symbolizes the TAB character that separates
the fields.

You want to import this data into aspect 001 (Profitability Analysis). The aspect contains the
characteristic ARTGR (Product group).

You create sender structure ARTGR and enter the following data:

Characteristic: ARTGR

Conversion: 0

Field name Type Length Dec. places

Product group C 8

Description C 20

You generate the sender structure and then maintain the transfer rules. In this case the language
D (German) has been entered as a constant. You maintain the following rules for the fields:

Recv. field Assign. rule Sender field Offset Length Constant

ARTGR MOVE ARTGR 0 0

TXT20 MOVE TXT20 0 0

LANGU SET D

You save the transfer rules and then edit the selection data for importing the file.

To carry out a test run of the transfer, enter the following data:

Field Entry/Selection

Sender structure ARTGR

File Path, in which the file can be found, for example, d:\file\ablexcel\artgr.csv

File system Presentation server

Editing Display file

Display sender record - field assignment
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File type CSV format

Number format Type P

No editing characters

Data format ASCII

Date format YYYYMMDD

You can now start the program.

If the test data is satisfactory, you can select Data transfer and execute the program again.

See also:

Importing a File [Page 84]
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Importing a File: Master Data Hierarchy
The product groups in your company are structured hierarchically:

Hierarchy representation with left sibling
You have a TXT file on your PC with the following representation of the master data hierarchy:

SHOES

LADIES_SHOES

BOOTS_LADIES

SPORT_LADIES_BOOTS

LEIS_LADIES_SPORT

MENS_SHOES_LADIES

LEATHER_MENS

HIKING_MENS_LEATHER

CHILDRENS_SHOES_MENS

SUMMER_CHILDRENS

WINTER_CHILDRENS_SUMMER

The underscore ( _) between the fields in the lines symbolizes the TAB character that separates
the fields.

You want to import this data in accordance with hierarchy display 3 into aspect 001 (Profitability
Analysis). With hierarchy display 3 you do not just transfer the characteristic value and
information about the superior nodes (parent nodes), you also transfer information about the
equivalent previous node (left sibling). You can find more information about the various hierarchy
displays in Customizing.

The aspect contains the characteristic ARTGR (Product group) and all the characteristic values
contained in the hierarchy.

You create a sender structure HIER. The receiver structure TKCHIEDM is fixed for the transfer of
a master data hierarchy. The fields of your sender structure are transferred into the fields of the
receiver structure. Because of this, the fields for the characteristic value, the parent node and the
sibling node, must always be of type C. Enter the following data:

Aspect 001
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Conversion 0

Field name Ref. table Field name Type Length Dec. places

KEYID TKCHIEDM Char. value C 32 0

PARNT TKCHIEDM Char. value C 32 0

LEFTK TKCHIEDM Char. value C 32 0

With the entry of a field name and a reference table, the other fields are automatically derived
from the reference table. You generate the sender structure and then maintain the transfer rules.
In addition to the characteristic values, that are maintained in the sender structure, transfer rules
have to be maintained for the fields FIELD (field name), HVERS (hierarchy variant) and HSTEP
(hierarchy level). You fill FIELD with the name of the characteristic and HVERS with the number
of the desired hierarchy variant. The field HSTEP is not required with this hierarchy
representation and can be filled with a constant (000). If you are also transferring text, maintain
the text fields too. Enter a constant for the language.

Recv. field Assign. rule Sender field Offset Length Constant

FIELD SET ARTGR

HVERS SET 001

HSTEP SET 000

KEYID MOVE KEYID 0 0

PARNT MOVE PARNT 0 0

LEFTK MOVE LEFTK 0 0

TXT_M

TXT_L

LANGU SET D

You save the transfer rules and then maintain the selection data for importing the file.

To carry out a test run of the transfer, enter the following data:

Field Entry/Selection

Sender structure HIER

File Path, in which the file can be found, for example, d:\file\ablexcel\hier.txt

File system Presentation server

Editing Display file

Display sender record-field assignment

File type TXT format
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Number format Type P

No editing characters

Data format ASCII

Date format YYYYMMDD

Then you can execute the program.

If the test data is satisfactory, you can select Data transfer and execute the program again.

Hierarchy representation with level number
You have a TXT file on your PC with the following representation of the master data hierarchy:

1_SHOES

2_LADIES

3_BOOTS

3_SPORT

3_LEIS

2_MENS

3_LEATHER

3_HIKING

2_CHILDRENS

3_SUMMER

3_WINTER

The underscore ( _) between the fields in the rows symbolizes the Tab character which
separates the fields.

You want to import the data in accordance with hierarchy display 1 into aspect 001 (Profitability
Analysis). With hierarchy representation 1 you do not just transfer the characteristic value but
also information about the hierarchy level. The sequence of the characteristic values determines
the position of the nodes compared to other nodes on the same level. You can find more
information about the various hierarchy representations in Customizing.

In this case, the field HSTEP (hierarchy level) must be included in your sender structure and
maintained in the transfer rules correspondingly. The field LEFTK (left sibling)is not required in
the sender structure and can be left vacant in the transfer rules.

See also:

Importing a File [Page 84]
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Importing a File: Transformation of a Record

The records in the file have the following structure:

Field Description

YEARB Fiscal year

COCDE Company code

PLANT Plant

CSTCT Cost center

VLA01 Value A Period 1

VLA02 Value A Period 2

.

.

.

VLA12 Value A Period 12

VLB01 Value B Period 1

VLB02 Value B Period 2

.

.

.

VLB12 Value B Period 12

This record must be transformed into 12 records (Repetition factor 12; Start value 1; Increment 1)
with the following structure:

Field Description

YEARB Fiscal year

PERDE Period

COCDE Company code

PLANT Plant

CSTCT Cost center
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VLA Value A

VLB Value B

The second record differs from the first in two ways:

1. It contains the field PERDE. This field should be entered under the parameter Index field
on the selection screen.

2. Instead of the 24 fields VLA01,...., VLA12, VLB01,...., VLB12, it contains the two fields
VLA and VLB.

The sender structure of the second record must be described for the data transfer. Make the
following entries on the selection screen to transform the first record into 12 records of the record
of the second structure.

Field Entries

Index field PERDE

Repeat factor 12

Start value of the index field 1

Increment of the index 1

Repeat fields VLA

VLB

After the transformation 12 records exist, each with the additional field PERDE. Instead of the 24
fields VLAO1....VLA12, VLB01.....VLB12, each record contains the two fields VLA and VLB. In
the first record, the field VLA is filled with the value VLA01, and VLB is filled with the value
VLB01. In the second record the field VLA is filled with the value VLA02, and field VLB is filled
with VLB02 etc.
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Importing a File: File in MC Format
In this file in MC format all the records refer to fiscal year 1996, period 002:

1996

002

00000001;PROFITC;00004543000;000000004534500;000000004000430

00000001;PROFITC;00004555000;000000004523000;000000004800000

The field separator in this file is the semicolon.
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Data Collection (EC-EIS/EC-BP)
Purpose
Data collection encompasses functions, with which you can fill aspects with data. This data can
come from the SAP environment or from other applications.

Implementation Considerations
You need this component in order to provide your aspects with data from a multitude of sources.

Features
Using the SAP-delivered programs, data can be transferred online into EC-EIS or EC-BP from an
R/2 System or an R/3 System in which the Executive Information System or Business Planning is
operational. If data is to be transferred from R/2 or R/3 other than via these special data transfer
programs, this can be done with an ABAP/4 query that has been enhanced accordingly. In
addition, files can be imported and self-created transfer programs used for the data transfer.
During the transfer, the data can be edited with the help of many functions in order to remove its
heterogeneity (for example, currency, key terms).
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Data Transfer Methods
EC-EIS and EC-BP provide several tools for filling your aspects with data. These include the
individual and list data-entry as described in Transaction Data [Page 60], and the tools described
in Customizing:

•  Data transfer from the same R/3 system  (see Data Transfer from R/3 [Page 107])

•  Data transferred from another R/2 or R/3 System  (see Data Transfer from Other SAP
Modules [Page 105])

•  Importing a file  (see Other Types of Data Transfer [Page 112])

•  Aspect summarization  (see Other Types of Data Transfer [Page 112])

•  ABAP/4 Query  (see Data Transfer from R/3 [Page 107])

•  Data transfer to the report portfolio  (see Transferring Data to the Report Portfolio [Page
113]).

The transfer of data into EC-EIS and EC-BP using the methods above consists of several steps:

1. The transfer method controls the communication between the sender and receiver
systems when transferring data from another SAP System (R/2 or R/3)  (see Setting up
Data Transfer [Page 102]).

2. The sender structure describes the data to be transferred so that the system can
interpret it correctly  (see Setting up Data Transfer [Page 102]).

3. The transfer rules define how the receiver structure is to be filled with the transferred
data  (see Setting up Data Transfer [Page 102]).

4. During the actual data transfer it is possible to combine sender structures in a package,
schedule transfer runs in the background, to monitor these and to correct any errors
(see Executing Data Transfer [Page 103]).

For more information see Example of the Types of Data Transfer [Page 101].
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Example of the Methods of Data Transfer
The following example shows the various methods of transferring data from both SAP and non-
SAP sources into EC-EIS and EC-BP. The large rectangle represents the R/3 System in which
EC-EIS or EC-BP runs. Within this system, data can be transferred to the aspects via standard
interfaces or individual programs. Data from other R/3 or R/2 Systems can be transferred using
ABAP Queries or CPI-C. The ABAP Query can be carried out in either the source or target
system. Data from non-SAP source systems can be imported into EC-EIS or EC-BP using CPI-C,
or from a file.

Aspect

CPIC File

Aspect structure

Transfer rules

Source system
R/2 or R/3

Source system
Non-SAP

Sender structure

Individual
programs

Standard
interfaces

Data in same
R/3 system
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Setting up Data Transfer
Transfer method
To set up communication between a sender system and EC-EIS/EC-BP, you must maintain the
transfer parameters. The procedure for R/2 and R/3 sender systems is described in detail in
Customizing.

For communication at network level, refer to the R/3 documentation SAP Communication:
Configuration [Ext.]. The R/2 document S41.2 is identical to this documentation.

Sender structure
You maintain the sender structures for transaction data, master data, master data comments and
master data hierarchies in R/2 and R/3 Systems in Customizing. When you maintain the sender
structures, you define how the transferred data is to be interpreted by the system.

You can create validations for each sender structure. Validations prevent the transfer of falsely
converted or meaningless data to an aspect. For more information, see Activating Validations for
Data Transfer [Page 77].

In Customizing you can combine several sender structures in one package. This way you can
use different sender structures to send a file to several aspects in a certain sequence.

Receiver structure
The receiver structure does not need to be maintained since it corresponds to the data structure
of the receiving aspect.

Transfer rules
The transfer rules, that enable the conversion of sender structures to receiver structures, are
maintained separately for characteristics and key figures. The maintenance of transfer rules is
described in detail in Customizing.

For more information, see Example of the Methods of Data Transfer [Page 101].
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Executing Data Transfer
The steps described in Setting up Data Transfer [Page 102] are to be carried out when setting up
the system or when you set up new data collection programs. After you have set up a data
transfer you can transfer the data. You can schedule the transfer procedure using standard R/3
background processing to occur periodically so that data is transferred at regular intervals. For
more information, see Customizing.

After a data transfer has occurred, you can check under Transaction data → Transfers →
Transfer log if the data has reached the aspect. If errors have occurred, you can correct them
there.

For more detailed information, see Displaying the Transfer Log and Processing Errors [Page
104].
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Displaying the Transfer Log and Processing Errors
Since the data transfer does not regularly run online but in the background, a log is written for
each data transfer.

The log for a sender structure contains information on errors and the chronological process of the
data transfer. You can display the logs in the EC-EIS application menu under Transaction data →
Transfers → Transfer log, and in the EC-BP application menu under Plan data → Transfers →
Transfer log.

After you have entered your selections and selected Execute, a list of the available logs appears.

For the selection of the logs to be displayed, SAP recommends that you do not enter
anything in the Time field with a time frame of more than one day. Otherwise this can
produce unexpected results: Then data records are only selected within the specified
time frame for every day (and not from the specified start date/start time to end
date/end time).

You can display further information about the errors for each log by double-clicking on the list
entry. Using  Detail information, you can process receiver records that have not been updated,
as well as incorrect sender records. You can display or delete sender and receiver records, and
display the expected structures. Sender and receiver records can be imported again. If, following
the error analysis, you must import or update a large number of data records, you should
schedule the function in the background processing.

The number of transfer logs that can be saved depends on the quantity of data. Therefore, SAP
recommends that you schedule a weekly job that deletes the logs .

Further information, and also possible data transfer problems and their solutions are described in
Customizing.
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Data Transfer from Other SAP Modules
Types of Data Transfer [Page 100] deals with the tools you can use to organize the transfer of
data to EC-EIS and EC-BP. For the SAP modules covered in the following sections, SAP delivers
selection programs. Depending on the sending application, the sender structure is either already
defined (as with FI-LC Consolidation) or it is generated in Customizing (as with CO-PA
Profitability Analysis).

Data Transfer from R/2 [Page 106]

Data Transfer from R/3 [Page 107]
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Data Transfer from R/2
The table lists the sender programs and structures for transferring transaction data from SAP R/2
Systems.

Application Program Sender structure

RF   Financial Accounting RFBILA00, RFSERG00 Balance sheet item,
account, company code,
business area, reporting
year, “From” rep. month,
 “To” rep. month, currency,
amount.

RK-E  Profitability Analysis TK75 Generated

RK-S  Cost Center Accounting SAPK021V,

RKCKSTKS

KIDS

RKCKSTSP to generate sender
structure

RK-P  Projects RXSEIPSA EIPS (DDIC)

Others ABAP Query Generated

Use of the individual interfaces is described in Customizing.
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Data Collection from R/3
Setting up and executing data transfer from R/3 Systems is described in Customizing.

The table lists the sender programs and structures for the transfer of transaction data from the
SAP R/3 Systems:

Application Program Sender Structure

FI-LC Consolidation RGCEISS1 FILCEIS (DDIC)

FI-GL Bal.Sheet/P&L RFBILA00 EISFI (DDIC)

PS Project System (Accounting) RKPSEIS1 PSGENACC (DDIC)

PS Project System (Logistics) RKPSEIS1 PSGENLOG (DDIC)

EC-CS Consolidation FICEIS00 FC07EIS (DDIC)

CO-PA Profitability Analysis Generated by basic drilldown Generated

CO-OM Overhead
             Cost Controlling

              Controlling

Generated by Report Writer report Generated

EC-PCA Profit Center
              Accounting

Generated by Report Writer report Generated

FI-SL Special Ledger Generated by Report Writer report Generated

Others ABAP Query Generated

If you have the corresponding application components in operation in your installation, you can
transfer data online from the current SAP R/3 System into EC-EIS/EC-BP with the help of the
following programs delivered by SAP. In the EC-EIS application menu under Transaction data
→ Transfers → Data transfer R3, or in the EC-BP application menu under Plan data → Transfers
→ Data transfer R3, select a program, enter your selection data and then execute the program.

Data collection from Consolidation  (FI-LC)
Program RGCEISS1 collects consolidated closing figures using sender structure FILCEIS.

Data collection from General Ledger  (FI-GL)
Using program RFBILA00 and sender structure EISFI, you can transfer balance sheet and
income statement data into EC-EIS and EC-BP.

Data collection from the Project System  (PS)
Using program RKPSEIS1 and sender structure PSGENACC, you can transfer accounting key
figures from the Project System into EC-EIS and EC-BP.

The program RKPSEIS1 and the sender structure PSGENLOG collect the logistics key figure
values from the Project System.
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Data collection from Consolidation  (EC-CS)
Program FICEIS00 and sender structure FC07EIS transfer data from Consolidation.

Data collection from Profitability Analysis  (CO-PA)
Data from CO-PA can be transferred to EC-EIS or EC-BP using basic reports. A corresponding
sender structure is generated automatically.

Provided that the CO-PA data is in the same system as EC-EIS or EC-BP, the
system offers the available reports in the list for execution.

If the data is in another system, you proceed as follows:

1. In the source system select the desired CO-PA report.

2. Choose  Extras → Report parameters.

3. Make a note of the value of the parameter Generation name, or transfer the value into the
Windows clipboard.

4. Switch to the target system in the ABAP Workbench and execute the report there, note that
you must enter the generation name as the report name (and not the technical name of the
report).

Data collection from Overhead Cost Controlling  (CO-OM)
You can use the Report Writer to transfer CO-OM data to EC-EIS or EC-BP. In such reports the
key figures must be in the columns. The rows or general selections must contain the
characteristic values. Sample reports are delivered for Cost Center Accounting in the report
library 1EI. A corresponding sender structure is generated automatically.

Data collection from Profit Center Accounting  (EC-PCA)
Just as in Overhead Cost Controlling, you can use the Report Writer to transfer EC-PCA data to
EC-EIS and EC-BP. Sample reports are delivered for Profit Center Accounting in the report
library 8A2 (report groups 8AE1 for actual data and 8AE2 for plan data). A corresponding sender
structure is generated automatically.

Data collection from Special Ledger  (FI-SL)
Just as in Overhead Cost Controlling, you can use the Report Writer to transfer data to EC-EIS
and EC-BP.

Data collection using ABAP Query
EC-EIS and EC-BP are connected to the ABAP Query. This means that all data that can be
displayed using a one line ABAP Query, can also be transferred to the aspects you have defined.
The ABAP Query is suitable for data collection whenever the sender database is transparent and
no additional external information is required. The information structures in the R/3 Logistics
Information System for example, fulfill these conditions. You can also transfer master data to EC-
EIS or EC-BP in the background using ABAP Query. You can find detailed information on this
topic in the online documentation BC ABAP Query.
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Flexible Upload of Data from Microsoft Excel
Use
You can load as much plan, transaction or master data as you wish from a Microsoft Excel sheet
into one or more aspects of the EC-EIS or EC-BP.

Integration
To execute a flexible upload you require the data transfer tools.

Prerequisites
You must have created one or more sender structures, whose fields correspond to the cells of
the file to be loaded. The Microsoft Excel files must be saved in TXT or CSV format.

Features
In Customizing you define which areas of the sheet are to be loaded into EC-EIS/EC-BP and
which cells are to be assigned to the fields of the sender structure(s). This data description only
has to be stored once for similarly structured files, for example, monthly reports.

With the upload you can load data from a single file or from the files of an entire path. If you load
data from several files simultaneously, the system creates certain files on your PC. These are
overwritten with each upload.

 
Before you execute the first flexible upload for all the files of a path, check that you
do not have any files on your PC in this path called dir_file.TXT or dir_file.BAT. If
this is the case, you should rename the existing files, otherwise they will be
overwritten.

As with importing a file, you enter the decimal display, the date format and the separator for CSV
files. The tabulator is expected as the separator with TXT files.

If you choose the field Test run, no data will be written to the database.
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Aspect Summarization
Use
By summarizing an aspect, you can reorganize transaction data or combine data from various
aspects in a summarization aspect. This allows you to:

•  convert transaction data for characteristic values which have been changed (for example,
if you have changed characteristic values but the transaction data records have been
saved for the old characteristic values)

•  transmit transaction data from one aspect to another

Prerequisites
Before you can summarize an aspect you must have generated a corresponding program.

Features
If you transfer the data to the same aspect again, you can generate a selection program as well
as sender structures and standard transfer rules, for an aspect. If you wish to transfer the data to
another aspect, you must update the target aspect and rules in the sender structures.
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Other Types of Data Transfer
Importing a File
To import a file, you must maintain the sender structure and transfer rules under one of your
program names. To import a file, choose Transaction data → Import file. You can find further
information in Customizing or under Importing a File [Page 84].

User-Defined Collection Programs
You can use the standard functions for communication and data transfer to run your own
programs for data selection. The procedure is described in detail in Customizing.
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Data Transfer to the Report Portfolio (EC-EIS)
Using the function Information System → Report portfolio → Rep.portfolio report → Transf.other-
>Portf., you can transfer reports existing in the following formats to the report portfolio:

•  Files on operating system level (UNIX files,...)

•  Contents of a print order

•  Print output of a program

•  Reports that can be called up using the report/report interface

(for example, drilldown reports, Report Writer reports, ABAP programs)

There are two ways of specifying to which user group and report class a report should be
assigned:

1. When you choose Manual entry, you must enter these parameters.

2. When you choose Automatic entry, the parameters are taken from the settings
maintained in Customizing.

If you regularly fill the report portfolio from the same sources, you should maintain the
appropriate settings in Customizing.

Transferring the Printout of a Program
To set up the transfer of a printout from other R/3 and R/2 programs to the report portfolio, you
must enter the name of the variant with which the program is to be started.

If you wish to transfer the printout of an R/3 program to the report portfolio, you must have
maintained the default printer in the user master record of the user who is to carry out the
function. You do this under System → User profile → Own data → Defaults, field
OutputDevice.

Transferring the Contents of an R/2 Print Order
To display the contents of an R/2 print order in the report portfolio, you must make the relevant
settings in Customizing and start program RKCDMSP2 in R/2 by entering the print order number.

Calling Up Reports and Programs using the Report/Report
Interface
To call up either a drilldown report, a Report Writer report, an ABAP program or a PC program
using the report/report interface and to copy it to the report portfolio, proceed as follows:

1. Choose Execute R/3 program and then Manual entry.

2. Enter the report portfolio parameters and choose Confirm.

A series of dialog boxes for the report/report interface is displayed.

3. To assign a receiver report to the report portfolio report (or to the sender report), choose
Insert line in the first dialog box.

4. In the second dialog box, choose Other report type to display all possible entries. Select
a report type.
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Depending on the report type you select here, different dialog boxes for selecting the
report or program appear. You can assign as many different reports or programs as
you wish to a report portfolio report.

 
If you wish to call up a PC program, you must create a variant for the ABAP program
RKCWINEX using Transaction SE38. After you have created the variant, you
transfer the ABAP program RKCWINEX with the corresponding variant to the report
portfolio.

5. Save your entries.

6. Using Environment → Report portfolio report, you can execute the report portfolio report
that you have just created.
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Business Planning (EC-BP)
Purpose
Business Planning (EC-BP) enables you to produce a group-wide business plan at a high level.
The business plan supplements the detailed plans of the operative components with a planning
facility that encompasses all the components and participating companies. The aim of EC-BP is
to produce a consistent and realistic plan that improves the efficiency of the enterprise and the
management process.

Implementation Considerations
(EC-BP) is a component for recording and evaluating aggregated plan data. You can use it to
collect and maintain data from various functional plan sections in one uniform view.

Integration
EC-BP has the same data basis and data collection facilities as EC-EIS. You can also use the
EC-BP functions to create a report on your plan data.

In this documentation, unless noted otherwise, the sections Data Basis (EC-EIS/EC-BP) [Page
23], Data Collection (EC-EIS/EC-BP) [Page 99] and Tools (EC-EIS/EC-BP) [Page 224] are
relevant for both applications. The section Information System (EC-EIS) [Page 156] is only
relevant if you wish to edit reports on plan data in EC-EIS.

Features
The EC-BP data structures are integrated with those of EC-EIS. If you implement EC-EIS, you
have the advantage of being able to use and supplement the data pool in EC-BP. The data pool
is organized into individual sub-sections of summarized business information called aspects. You
can define these specifically for your enterprise for example, cash position, human resources,
logistics. In addition to the available data contained in the aspects, you can transfer plan data
from the various operative systems for example, financial information system, human resources
information system, logistics information system, cost accounting etc.

For each aspect you can produce plans that portray different planning views for example, by
group or business area, or you can produce sub-plans portraying investments or sales, for
example. You can either enter your data manually or edit it automatically. In addition to planning
values, you can also plan prices and quantities using appropriate formulas.

Using versions you can store various scenarios for the same time period. You can produce plans
for a fiscal year, and also cross-yearly plans, for example, June 1998 - March 1999.

To construct the screen for interactive planning you configure planning layouts using
characteristics and key figures from the data basis. You can also define formulas for locally-
calculated key figures. The system saves the plan data bottom-up, which means that data from a
lower level is aggregated to the next highest level.

Planners can use the R/3 interface of the planning processor (familiar from other applications) or
Excel-In-Place. Excel-In-Place combines a Microsoft Excel interface with the planning functions
of EC-BP. If you produce plan documents with Excel, you can save and edit them on your PC.
After completion of the plan section, you can import the data back into EC-BP.
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In automatic planning, the system generates plan data based on user-defined premises. After
you have set the parameters for automatic planning, and have initiated the automatic planning
run, the system generates and posts the plan data automatically.

Apart from recording plan data, there are various functions available for editing your plan data.
Using revaluations, you can either increase or decrease the plan data by a certain percentage.
Seasonal distribution keys help to distribute the data from year level to period level. Top-down
planning distributes aggregated data to lower levels on the basis of reference data from a
different version or a different time period. Using statistical methods, you can have the system
forecast plan data on the basis of previous data. In the automatic planning, the statistical
methods (forecast profiles), distribution keys and revaluation factors can refer to specific
combinations of characteristic values.

Because EC-BP and EC-EIS share a common data basis, you can use EC-EIS functions to
report on the plan data. For example, you can produce plan/actual comparisons, navigate
through the data, create exceptions, and send the report to your manager using SAPoffice
functions.

In this documentation, the application functions are described in detail and the customizing
functions in brief. The information is intended for the EC-BP user, but also for the EC-BP system
manager. To access the EC-BP application menu, choose Accounting → Enterprise controlling
→ Business planning.

Carry out all necessary preliminary tasks and settings in Customizing. For more information
about Customizing functions, see the implementation guidelines.
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Interactive Planning
Use
In interactive planning, you plan values for key figures for selected characteristics. You use a
Planning Layout [Page 119] to create the planning screen. The data that you can plan may be
dependent on a planner profile.

Prerequisites
You have created a suitable planning layout in Customizing, and where necessary, a planner
profile.

Features
Function What you should know

Set Planner Profile You use this function when you wish to use a planner profile to select the
planning layout and the objects to be planned, and when no planner
profile has been assigned to you in Customizing.

The planner profiles support the organization of the planning process,
especially if planning in your enterprise is decentralized. The system
administrator assigns planner profiles to certain users. The profiles
contain predefined planning objects. For more information, see Planner
Profile [Page 124].

Change Plan Data You use this function when you wish to enter or change plan data. You
select the objects to be planned, a version, and a time period. The objects
to be planned in a planning session are determined by the planning layout
and also the planner profile. You can plan the values either cumulatively
or per period.

In addition to the entry of values, various planning functions are available.

Seasonal Distribution [Page 144]:

The system distributes available data on the period screen in a similar
pattern to the existing plan data (distribution key 2). Using a different
distribution key, you can change the distribution of the values over the
periods (see Maintaining the Distribution Key [Page 145]). You can use
SAP-delivered distribution keys for this, or create your own distribution
keys. In this way, you can, for example, set up a seasonal distribution of
the plan values to the periods.

Revaluation [Page 146]

To revaluate the data of a column or a row using a percentage rate, you
can use the function Change Values [Ext.]. You can also add an absolute
amount to the data with the same function.

For more information about functions, see Edit Plan Data Interactively
[Page 126].

Display Plan Data You use this function to select the planning objects and display the plan
data for a certain version and time period.



Executive Information System and Business Planning  SAP AG

Interactive Planning

118 April 2001

Forecast Plan Data You use this function to automatically forecast plan data during the
planning session (see Forecast [Page 148]). With the forecast function,
the number of periods in the reference and plan areas may be different.

You can execute the forecast by manually setting the parameters, or by
basing the forecast on existing reference data (see Forecast Profile [Page
150]).
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Planning Layout
Definition
A planning layout is a form, that gives the screen structure for the entry of plan values.

Use
In planning layouts you determine the screen structure for your planning session. You define the
header area, value and lead columns depending on your special business requirements.

You can create different planning layouts, that differ with respect to the lead columns,
characteristics etc. In this way you get the chance to create varied planning screens that meet
specific business requirements such as version, half-yearly or quarterly planning.

Structure
All planning layouts are based on the following schematic structure:

T i t l eT i t l e

Header

Lead columns Value columns

Header Area
The header area of a planning layout is formed by several text rows that describe the objects to
be planned in greater detail. These details are taken from the General data selections that are
made in the planning layout. The characteristics of the general data selections (for example,
version, fiscal year) are valid for the entire planning layout. Generally, you can define the
characteristics of both the general data selections and of the columns as variables. The definition
as a variable means that these fields are ready for input on the initial screen at the time of
execution of the planning.

If you have maintained navigation attributes for your characteristics, you can select these
attributes in the general selections and use them in the planning session to select the data. Note
that, since the attributes are non-chargeable, the underlying characteristic must be specified in
the planning layout

 
You wish to display plan data using the navigation attribute responsible person.
The underlying characteristic is the region. In order to use the attribute responsible
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person as a selection criteria for the planning, you can create a variable for the
responsible person in the general selections in the planning layout. You must also
enter an interval of characteristic values or exactly one characteristic value for the
characteristic region in the layout.

Lead Column
The lead columns determine the contents of the rows. Where necessary, you can define several
lead columns.

You have two alternatives for the definition of lead columns:

1. Definition of one or more lead columns using the column title
 In this way, you can select exactly one characteristic per lead column and then specify
either all characteristic values (*), an interval of characteristic values, one characteristic
value, or a hierarchy node. (This layout corresponds to a single-coordinate form in
drilldown reporting.)

 
Revenue planning

1. Lead column 2. Lead column 1. Value column 2. Value column

 Countries  Business areas  Revenue Sales deductions

 *  400 - 403

 420 - 429

  

 

1. Definition of exactly one lead column using the rows
In this way, you can select one characteristic per row, combine several characteristics,
combine characteristics with key figures, or calculate formulas. (This layout corresponds
to a two-coordinate form in drilldown reporting.)

 

Version planning

1. Lead column 1st Value Col. 2nd Val. Col. 3rd Val. Col.

Act. 1997 Plan 1998 Plan 1999
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Gross domestic revenue

Gross foreign revenue

Sales deductions

Stock changes

Other capitalized internal activities

Material expense

Expense for services obtained

Wages and salaries

Social security contributions and expenses

Depreciation

Other operating expenses

Operating profit (Formula)

Value column
The value columns are used to enter plan values.

There are two types of value columns:

•  Columns with characteristics/key figures

With a value column of element type Key figure with characteristics, you select exactly
one key figure from the list of all possible key figures. Then you determine the
characteristics and characteristic values.

You can use both basic key figures and calculated key figures in your planning layout.
With the exception of ratios, calculated key figures are not ready for input. Calculated key
figures, that consist of a ratio, can be input in the planning session. The values of the
affected basic key figures are automatically calculated and changed in the relevant
columns.

With a value column of element type Characteristic you select characteristics and then
the relevant characteristic values. If you have created a master data hierarchy, you can
also select a hierarchy node or a variable for a hierarchy node. Note that you must
specify the hierarchy variant in both cases.

•  Formula columns

Formula columns are based on the values of columns already defined. The SAP R/3
System offers the available value columns in a dialog box where you can define
formulas. The values of these columns are calculated by the system if the value columns
used in the formula have been provided with values. Formula columns also serve as a
basis for the target value search.

Attribute column
You can assign units or a distribution key to a value column. This is done by defining attribute
columns.
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You define a planning layout in Customizing, using Planning → Interactive planning → Create
planning layout.

When you have created your planning layout in Customizing, you can plan your data (see Edit
Plan Data Interactively [Page 126]).

Selection of the plan data
In the planning it can be necessary to make supplementary changes. In such cases you can not
always plan in detail and you must enter all data at a high level. (If you wish, you can execute a
top-down distribution later using automatic planning. When you select the plan data, these values
are also taken into consideration. They are selected after being summarized over all non-
specified characteristics.

 
In your enterprise you are planning the investment budget for each plant and
company code for the fiscal year 1999. In the database four records were posted at
this level. In addition, one record was planned at company code level. The plant is
not specified in this record.

Company code Plant Investment budget in TDM

0001 0001 200

0001 0002 300

0002 0001 100

0002 0002 200

0002 - 100

In the planning layout you then select the plan data for each company code for the fiscal year
1999.

Company code Investment budget in TDM

0001 500

0002 400

The values for the plant are selected summarized for each company code. This means that the
record with no plant is also selected. Note that Actual data in an EC-EIS data entry layout is
selected differently. With the same selection criteria for actual data, the following data would
have been selected in the data entry layout.

Company code Investment budget in TDM

0002 100
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Only the data that corresponds exactly to the selection criteria is displayed. This means that only
the record with the characteristic values company code 002 and plant [blank] will be displayed.
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Planner Profile
Definition
A planner profile is a selection of planning layouts for the planning session, sometimes with
specific default settings.

Use
A planner profile is an optimal planning aid for controlling the planning flow. There is a many-to-
many relationship between the planner profile and the aspect, that is you can use a planner
profile in many aspects and in the context of an aspect you have access to many planner
profiles.

You have assigned Aspect 001 Profitability Analysis to planner profile
PROFILE01. In profile positions 1 and 2 you have assigned the planning layout PL01
to this planning area (aspect).

You enter version 1 as a parameter for the planning layout in profile position 1. Enter
version 2 as a parameter for the planning layout in profile position 2.

When planning, you can use the function Next/previous layout to jump between the
planning layouts of the selected planner profile. This allows you to plan in various
versions.

Structure
In a planner profile, you determine which planning layouts are to be used for each planning area
(aspect). In a planner profile, you can store as many planning layouts for each planning area as
you wish.

The planning layouts are assigned in the planner profile using profile positions. In each planning
area you can have as many profile positions as you wish. The profile position determines the
sequence of the planning layouts in a planner profile. It is also possible, using different profile
positions, to assign the same planning layout (with different predefined parameters however)
several times in a planner profile.

Features
In a planner profile you can set the following parameters for planning.

•  By assigning an authorization group to a planner profile, you can control specific
authorizations for planning. This is especially important for decentralized planning. Using
planner profiles that are customized for each planner, and assignment of authorization
groups, you can ensure that only planning is only carried out within the relevant responsibility
area.

•  If you wish to edit the planning layout in Microsoft Excel rather than with the R/3 interface,
you can activate the Excel integration indicator. You must also enter a file description or have
one generated. You can find more information on the required settings for working with Excel
under Setting Up Integrated Excel [Page 132].
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•  You can make settings for the variables in a planning layout by predefining the planning
layout parameters in the planner profiles. This simply means entering values for these
variables in the planner profile. You can overwrite these values. However, you can also
prevent overwriting by activating the relevant indicator in the planner profile definition. In a
planning session the SAP R/3 System retrieves as parameters all the variables defined in a
planning layout.

•  If some users always work with the same planner profiles, you can enter these profiles with
parameter-ID PPP in the user parameters under System → User profile → Own data.

•  You set the planner profile for a planning session by choosing Planning → Interactive → Set
planner profile, and entering a profile.

•  If you want to plan without a planner profile, you can switch off the profile. You do this by
choosing Planning → Interactive → Set planner profile and then choosing Clear profile.

You can find more information about creating planner profiles in Customizing.
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Edit Plan Data Interactively
Prerequisites
You have created a planning layout in Customizing .

Procedure
You get to the planning functions using Planning → Interactive → Change plan data.

Using a planner profile set up for the purpose, you can edit your plan data in Microsoft Excel
instead of with the R/3 interface. You can find more information under Integration of Microsoft
Excel [Page 130].

1. Enter the aspect and the planning layout.

2. In the selection screen, enter the characteristic values for which you want to record or
change plan data.

As a rule, the planning layout you have selected will contain variables for certain
characteristics, for example product group, customer group or cost center. It also
contains variables for the characteristics version and ‘from’ and ‘to’ period/year. By
entering characteristic values for these variables on this screen, you specify definitively
the objects to be planned in this session, the desired plan versions, the time frame etc.

If the planning layout has been correspondingly defined, you can also select hierarchy
nodes from a master data hierarchy, or (multilevel) navigation attributes, for example, the
person responsible for a customer group. Note, however, that you cannot post any data
for these objects.

If you wish to enter your plan data in a different currency to that of the aspect or basic
key figure, you can specify a data entry currency. The plan data is however, translated
upon saving and saved to the database in the aspect or basic key figure currency that
you selected in Customizing. In Customizing you can determine which currency
conversion key should be used. If you have not maintained a translation key, then key 5
(average rate with key date at period start) is automatically used.

3. Choose free or form-based.

If you activate free, the SAP R/3 System displays in the overview screen those records
already planned. They can now be changed. You can also record new characteristic
values and add these to the rows.

If you activate form-based, the SAP R/3 System displays in the overview screen all the
planning objects that have been selected in the initial screen, with valid master records.
This is independent of whether plan values already exist. The same structure of
characteristic values is displayed in each planning session. You may not record new
characteristic values.

Overview screen
After you have entered the values for the variables, you can enter your plan figures on the
overview screen. The layout of the overview screen depends on the selected planning layout.
Before branching to the overview screen, the plan figures already available on the database are
read for the objects to be planned and summarized according to the specified characteristics. In
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order to prevent the simultaneous planning of objects by different users, the objects to be
planned are locked by the system.

Functions in the Overview Screen
Seasonal Distribution [Page 144]

Revaluation [Page 146]

Forecast [Page 148]

Planning Quantities and Prices
Within a planning layout; if a calculated key figure, consisting of a ratio, is used in a column or
row, you can change the values of the column or row. The other key figures of the formula are
automatically calculated.

You have used a calculated key figure price (revenue/sales volume) as a column in
your planning layout. There is also a revenue column and a sales volume column in
the planning layout. If you enter a sales volume and a price in the planning session,
the revenue is calculated automatically. If you enter a sales volume and a price in the
planning session, the revenue is calculated automatically.

Target Value Search
The target value search enables you to carry out a break-even analysis. This means that you can
use simulations to change plan data for a key figure until the contribution margin equals zero.
The target value is calculated from a source value using a formula. For this to happen, the
relevant columns in the planning layout must be created as formula columns.

Calculation Formulas
Calculation formulas serve as planning aids when calculating plan values. If you have created
calculation formulas for certain basic key figures in planning, and wish to use these in interactive
planning and write them to the database, you place the cursor on a cell and choose Change →
Planning functions → Calculate basic key figures  You can find further information about this in
Customizing.

The planned sales commission amounts to 6% of revenue. Using a calculation
formula, you can determine that the planned sales commission is calculated and
posted as follows:

Sales commission = revenue * 0.06

Other Functions
You can access the following system help when entering plan values:

Print Preparation [Ext.]

Cutting [Ext.]

Copying [Ext.]

Setting [Ext.]

Sorting [Ext.]
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Undoing rows, entries, recreating [Ext.]

Overview screen [Ext.]

Period Screen [Ext.]

Next, previous, other combination [Ext.]

Next, previous layout [Ext.]

Number Format [Ext.]

Period Screen
On the period screen you can display or manually change the period distribution of your plan
value. If you wish to use a different distribution key you should set this on the overview screen.

Once you have entered or changed your plan data, save it.

Result
You can now look at your plan values in the Executive Information System and compare them
with plan values from other areas or periods.
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Planning Scenario
You are planning a budget increase for the cost centers as a percentage increase. You wish to
enter the percentage increase. The SAP R/3 System should calculate the plan value of the
current year from the plan value of the previous year and the percentage increase.

Inverse formulas allow you to enter values in a formula column while planning; the SAP R/3
System then uses these to calculate the values for another column of the planning layout. How to
define an inverse formula is described in detail in Customizing.

Definition of the planning layout
Planning Layout

Lead Column Value. Col. 1 Value. Col. 2 Formula Column

Cost center Plan current year Plan prev. year %-Increase

 ((Plan curr. yr.- Plan prev. yr.) /Plan prev.
year) * 100

You indicate the column Plan current year as not ready for input, the column %-increase as
ready for input. Then you generate the inverse formula.

Interactive planning of the data
In the interactive planning you copy the plan values of the previous year to the plan values of the
current year.

After copying the planning:

Cost center Plan current year Plan prev. year % Increase

530 500.000 500.000

You enter the percentage increase. The plan costs of the current year are calculated.

After calculating the new plan costs:

Cost center Plan current year Plan prev. year % Increase

530 550.000 500.000 10
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Integrated Excel in Planning
Use
For planning with integrated Excel, Microsoft Excel is used as a planning screen for your
planning data in the SAP System. This allows you to combine the comfort of Excel's formatting
and data processing functions with the powerful planning functions of your SAP application. You
are therefore able to use the Office input interface with online planning in the SAP System.

There are two ways of using Excel to plan your data:

•  Planning with Excel integrated into the user interface of the SAP System

Excel replaces the standard SAP planning screen. This enables you to plan using the
functions of both the SAP System and Excel.

•  Offline planning in Excel and uploading data into the SAP System

From one or more PCs that are not connected to the SAP System, you can enter your
planning data into several Excel spreadsheets. This data can then be uploaded into the
SAP System, where you can process it further using the SAP planning functions.

Prerequisites
Software
To be able to plan using integrated Excel, the following should be installed on your PC:

•  The Windows NT 4.0 or Windows 95 operating system

•  Microsoft Excel 97

•  A current SAP GUI (32 Bit) matching your System Release

Hardware
To ensure good response times, your PC should have a Pentium II processor and 64 MB RAM.

Features
In Customizing, you can define Excel spreadsheets for use as templates in planning. In those
templates, you can move data around, insert graphics, define macros, and format text and cells.
You can use this template to plan with integrated Excel or to plan with the upload function.

Link between Excel and the SAP System
From the technical point of view, Excel is called up by the SAP System using OLE (Object
Linking and Embedding), an interface in the Office programs. Integrated Excel into the SAP
System allows you to use the same Excel functions that are available with the integration of
Excel in Word, for example.

On a more detailed level, the link between the Excel spreadsheet and the SAP planning layout is
created above the position of the data in the Excel spreadsheet:
The SAP System uses Customizing to determine which SAP data is in Excel and where it can be
found. The position of the data cannot be changed in the planning screen to ensure that the data
is imported correctly. The fields of the planning layout are mapped to the Excel spreadsheet
using File Description [Ext.].



 SAP AG Executive Information System and Business Planning

Integrated Excel in Planning

April 2001 131

Constraint
You cannot use integrated Excel to enter any planning data in the period screen.

Activities
Initial Steps
To be able to use Microsoft Excel as your planning screen, you need to activate the indicator
integrated Excel in Customizing for your application when Setting Up The Planning Framework
[Ext.] (only CO-PA), or when you assign your planning layouts to a planner profile.

In Customizing, you can also design an Excel spreadsheet to be used as a template for planning
in Excel.

For more information about setting up integrated Excel, see Setting Up Integrated Excel [Page
132].

Planning in Excel
•  Excel integrated in the SAP interface

To plan directly in the SAP System using integrated Excel, you can choose between
executing a corresponding parameter set (only CO-PA) or using a planner profile in
which Excel was activated as the planning screen for one or more layouts. You enter
your planning data in Excel and can use Excel functions such as macros or diagrams as
well as all the usual SAP planning functions. For more information on planning with
integrated Excel, see How To Plan Using Integrated Excel [Page 135].

•  Planning in Excel and uploading data into the SAP System

The Excel template created in Customizing can be copied as often as required and used
to create planning data in Excel. By using the uploading function for Excel, you can
transfer the individual files into the SAP system. This means that planning data can be
entered into different PCs, local planning thereby being possible. For more information
on the required procedure, see Planning Offline and Uploading into the SAP System
[Ext.].
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Setting Up Integrated Excel
Prerequisites
Your Planning Layouts [Ext.] must be defined.

If you want to change a planning layout for which you have already created an Excel
template, you must create a new Excel template.

For technical reasons, it is necessary that the system already contain planning data that
corresponds to the planning layout (at least one row) before an Excel spreadsheet can be
formatted as a template. If no such data is present in the system, you need to create some. One
way of doing this is by entering data into the appropriate layout without integrated Excel.

Procedure
Activating Excel
Depending on the application you are working in, you should proceed as follows:

•  In Profitability Analysis (CO-PA), you set the integrated Excel indicator to "active" when
you define a parameter set for the planning method Enter planning data or Display planning
data (for more information, see the section Set Up Manual Entry of Planning Data [Ext.]).
When you first select this parameter set in the planning framework, the structure that you
specified in the planning layout is represented in the upper left-hand corner of an Excel
sheet.

•  In the other applications, select Integrated Excel in Customizing on the Define Planner
Profiles screen when you assign planning layouts to the planner profile. This activates Excel
as the planning tool for that layout in that planner profile. When you enter planning, the
system displays the planning layout you defined in the upper left-hand corner of an Excel
spreadsheet.

When moving the planning layout, you can enter a specific name for the file description.
This makes sense, for example, in cases where you intend to use the file description
several times. If you do not enter anything here, the system automatically creates a file
description when you save your planner profiles. This file description will reflect the
position in the profile.

If you want to customize a particular spreadsheet to be used uniquely with that layout
in planning, you need to define an appropriate template (see "Defining an Excel
Template").

If you want to upload an Excel spreadsheet, you need to edit an Excel sheet
template in order that the system can generate a file description. This file description
is required for the upload. Furthermore, you need to make several additional settings
(see Planning Offline and Uploading into the SAP System [Ext.]).
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Defining an Excel Template
1. CO-PA: Execute the planning method Enter planning data, using the related parameter set.

Doing so takes you to an unformatted Excel sheet. There you choose Settings → Formatting.

Other applications: In the IMG for defining the planner profile, choose Default
Parameters and enter values for the variables defined in the planning layout. You must
do this so that you can open the spreadsheet in the next step. If desired, you can delete
these entries again after you have customized your Excel template.

To open Excel in the SAP window, choose .

2. In the Maintain File Description screen, you can now customize an Excel spreadsheet as a
template for your planning screen.

Note the following:

− To move planning data within the spreadsheet, only use the appropriate SAP
function. To do this, select the data you want to move using , and then position the
cursor on the target location and choose . You save the link between the old position
and the new position of the data by choosing  Save file description [Ext.].

− The first Excel spreadsheet is protected. Cells that were not locked against entries in the
SAP entry screen, such as those that can be defined in the planning layout, are excluded
from this protection in Excel. If you want to use functions in Excel that extend beyond
editing those cells where entries can be made, you first need to remove the general
spreadsheet protection in Excel.

After editing, you should then reactivate the spreadsheet protection in Excel to
ensure that, for subsequent planning, the only data that can be entered corresponds
to that specified in the SAP System.

− You can use the Excel formatting functions (such as different fonts or colors) to format
the Excel template.

− You can use Excel to create diagrams, macros and formulas and then use these for
additional calculations, for example. It is recommended that you insert these into a
second spreadsheet to avoid the data conflicting with the actual R/3 planning data later.
The SAP planning data is imported from the first spreadsheet only.

− When you enter formulas in the SAP data area in Excel, they are overwritten by the
formula result during posting, and the formulas themselves are then discarded.

− You can save the Excel formatting in the SAP System by choosing  Save Excel layout.

3. If you later want to upload files from your PC to the SAP System, you must enter a generic
file name [Ext.] (see the section Planning Offline and Uploading into the SAP System [Ext.]).

4. Choose  in the toolbar. This function will also save the file description and the Excel
template.

Data saved with this function is permanent from then on.

5. Choose .
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CO-PA: You then return to the planning framework.

Other applications: You return to the Default Parameters screen. Delete any values you
entered for the variables if you do not want to have them displayed as the template in
planning. Choose .

The default parameters are only saved temporarily at this point.

For this reason, you should then finish by saving the planner profile. Only then does
the system assign a definitive file description to the planning layout and save the
values for the variables are saved permanently.
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How To Plan Using Integrated Excel
Prerequisites
To be able to use Microsoft Excel as your planning screen in the SAP System, you need to make
the appropriate settings either in Customizing under Define Planner Profile or when defining the
parameter set for the Enter planning data planning method (CO-PA only). For more information,
see Setting Up Integrated Excel [Page 132].

Procedure
1. CO-PA: Execute the planning method Enter planning data using a parameter set for which

Excel has been activated as the planning tool. This automatically calls up Excel within the
SAP window.

Other applications: Enter planning using a planner profile and choose a planning layout
for which integrated Excel has been activated. To open Microsoft Excel in the SAP
System window, choose . (It is not possible to use Excel to create planning data in the
period screen.)

− If you have used Customizing just to set the indicator for integrated Excel and no special
formatting has been made in the Excel template for this planning layout, the system
displays the planning data unformatted in the upper left-hand corner of the spreadsheet.

− If you have formatted an Excel template in Customizing, the system opens this template
in Excel.

2. Enter your planning data.

Note the following:

− You must avoid any use of the following Excel functions:
- Delete
- Paste
- Sort
Use of the above functions prevents data from being imported correctly into the SAP
System.

− If you want to delete data, choose  in the SAP System.

− Enter new objects for planning directly beneath the existing SAP data (where
appropriate, beneath the totals row). To paste, use the SAP possible entries function
(available via ). Note that the system does not recognize data that is separated from
the existing SAP planning data by an empty row.

− You can sort additional data into existing data by choosing Edit → Sort in the SAP
menu.

− If the Excel spreadsheet is protected, then the entries that can be made in the individual
cells correspond to those specified in the SAP System.

− You can access SAP possible entries by choosing ..

− The SAP System only imports data from the first spreadsheet in an Excel folder. You can
perform additional calculations or add diagrams on a second spreadsheet. These
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calculations and diagrams are only kept during your planning session if they have not
already been created in Customizing.

− When you enter formulas in the SAP data area in Excel, they are overwritten by the
formula result during posting, and the formulas themselves are then discarded.

− If you want to save, use an SAP planning function or run a validity check, you need to
make sure that no cell is currently being edited in Excel. You can control this by
displaying the "Formula Bar" in Excel (choose View → Formula bar).

− To run a validity check for the data you have entered, choose  in the SAP System.

3. Post the data by choosing .

You then return to the initial screen.



 SAP AG Executive Information System and Business Planning

Flexible Upload of Data from Microsoft Excel

April 2001 137

Flexible Upload of Data from Microsoft Excel
Use
You can load as much plan, transaction or master data as you wish from a Microsoft Excel sheet
into one or more aspects of the EC-EIS or EC-BP.

Integration
To execute a flexible upload you require the data transfer tools.

Prerequisites
You must have created one or more sender structures, whose fields correspond to the cells of
the file to be loaded. The Microsoft Excel files must be saved in TXT or CSV format.

Features
In Customizing you define which areas of the sheet are to be loaded into EC-EIS/EC-BP and
which cells are to be assigned to the fields of the sender structure(s). This data description only
has to be stored once for similarly structured files, for example, monthly reports.

With the upload you can load data from a single file or from the files of an entire path. If you load
data from several files simultaneously, the system creates certain files on your PC. These are
overwritten with each upload.

 
Before you execute the first flexible upload for all the files of a path, check that you
do not have any files on your PC in this path called dir_file.TXT or dir_file.BAT. If
this is the case, you should rename the existing files, otherwise they will be
overwritten.

As with importing a file, you enter the decimal display, the date format and the separator for CSV
files. The tabulator is expected as the separator with TXT files.

If you choose the field Test run, no data will be written to the database.
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Automatic Planning
Use
Automatic planning allows you to use existing plan or actual data from one version or time period
as a template for plan data for another version or time period. The advantage is that you can
easily edit larger amounts of data in this way, for example, if your plan data is based on the
actual data of the previous year. You can also make certain changes to the data.

Integration
With the exception of top-down planning, the plan data can be updated with the tools of the
component data transfer.

Features
Function What you should know

Copy plan data You use this function if you wish to copy plan or actual data from one
version or time period to another version or time period. You can take
reference data from more than one year  (for example, 010.1997 to
004.1998), and also copy to more than one year. The number of reference
periods however, must equal the number of plan periods.

Change plan data You use this function if you wish to copy plan data and simultaneously
change it using a seasonal distribution and/or a revaluation. You can take
reference data from more than one year  (for example, 010.1997 to
004.1998), and also copy to more than one year. The number of reference
periods however, must equal the number of plan periods.

The seasonal distribution of the reference data remains intact when
copying, meaning that period values are copied. If the seasonality of the
reference data is not to be adopted due to special circumstances, then
you can enter a new seasonal distribution for the planning run. The
reference data for all periods of the selected reference time frame is
accumulated and distributed to the periods of the planning time frame
according to the seasonal distribution key (see Seasonal Distribution
[Page 144]). You can use certain SAP-delivered distribution keys for this
or create your own (see Maintaining Distribution Keys [Page 145]). In the
planning session you can either set a seasonal distribution for all data
records, or (using a planning aid access) you can select a distribution for a
specific characteristic combination.

If you want to use existing plan or actual data (with a percentage increase
or decrease) as a basis for new plan data, you can select a revaluation
factor. The reference data will then be amended to take account of this
increase/decrease (see Revaluation [Page 146]). You can either set the
revaluation for all data records, or (using a planning aid access) you can
select a revaluation for a specific characteristic combination (see
Determining the Revaluation Factor [Page 147]).
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Forecast plan data You use this function when you wish to automatically forecast plan data
(see Forecast [Page 148]). You can take reference data from more than
one year (for example, 010.1997 to 004.1998), and also copy to more
than one year. With the forecast function, the number of periods in the
reference and plan areas may be different.

Using a forecast profile, you can generate plan data based on already
existing reference data (see Forecast Profile [Page 150]).

You can either set the forecast for all data records, or (using a planning
aid access) you can select a forecast for a specific characteristic
combination. In addition, you can select a different forecast profile for
each key figure.

Top-down planning You use this function when you wish to automatically distribute plan data
top-down within an aspect. Plan data is distributed from a higher level to
lower levels, for example, from customer group level to customer level
(see Top-Down Planning [Page 152]). You can take reference data from
more than one year  (for example, 010.1997 to 004.1998), and also plan
for more than one year. The number of reference periods however, must
equal the number of plan periods.

Updating the plan data
You can either update the plan data directly, or you can update with the functions of data
transfer, using a sender structure and transfer rules.

The direct update (that is without transfer rules) is suitable for planning sessions in which you
copy values into the same fields of a second version and, possibly a second time frame (or copy
and revaluate, or distribute anew). You determine whether existing plan data is to be overwritten,
or if the values are to added to existing records on the database. You do not have to carry out
any activities in Customizing for the direct update of the data.

Note that:

•  The direct update is only possible when planning in the same aspect

•  Top-down planning can only be updated directly

If you wish to carry out one or more of the following functions while copying, you must update the
data using a sender structure and with transfer rules:

•  Update the data in a different aspect

•  Translate currency

•  Import data to another client or to another system

•  Convert characteristics

The prerequisite for this is the maintenance of the sender structures and transfer rules in
Customizing. When maintaining the transfer rules you determine whether existing plan data is to
be overwritten or if the values are to added.
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Authorizations
To protect the plan/actual indicator and the version in automatic planning, you use the
authorization object K_KC_DB_VS. You can use data slices to protect the fiscal year and the
period. If you wish to protect other characteristics use the general characteristic authorization for
EC-EIS and EC-BP.
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Edit Plan Data Automatically
Prerequisites
The functions of automatic planning run similarly to those of interactive planning. The procedures
and various details of automatic planning are described below:

Procedure
Initial Screen
Enter the following details for plan data:

1. Enter the aspect to be planned.

2. Enter the plan version, into which the changed data will be transferred.

3. Enter the periods to be planned.

Enter the following details for reference data:

1. Enter the aspect from which data is to be transferred, or referenced.

2. Specify if you wish your plan to refer to actual data or to an existing plan version.

3. Enter a version from which the data is to be copied or referenced.

4. Determine from which periods the source data is to be copied or referenced.

Enter the necessary details for function:

The function determines how the plan data is to be processed. You can find more information
about the various functions under:

Seasonal Distribution [Page 144]

Revaluation [Page 146]

Forecast [Page 148]

Top-Down Planning [Page 152]

Enter the following details for extras:

1. Select Test run if you wish to execute the function without any changes to the database.

2. Select Log to keep a log of the procedure.

3. Select Background processing for dealing with a large number of changed objects to
avoid dialog processing (see section Background Processing).

Enter the necessary details for updating:

With the exception of top-down planning, which is always updated directly, you can either update
the plan data directly or by using the data transfer functions. The latter entails updating using a
sender structure and transfer rules. For more information see Automatic Planning [Page 138].
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Selection of the Characteristics
After you have made your entries on the tab page General settings, choose the tab page
Characteristics. Here, you can restrict the selection of plan data to be copied by selecting certain
characteristics. If you only wish to edit data for regions and areas, for example, you can select
the characteristics region and area.

If you are working with the characteristic data area in your aspect, you have to enter a
characteristic value. The data area holds the default currency for the basic key figures and must,
therefore, be specified.

Selection of Key Figures
Choose the tab page Key figures to determine which key figures you will plan with. If you want to
plan only sales volume and revenue, for example, select these fields.

For automatic planning, select only those key figures for which "Summation" (sum) is
defined as the aggregation behavior.

If you have created calculation formulas for certain basic key figures in planning, and wish to use
these in automatic planning and write them to the database, select the relevant key figures. If you
do not choose a basic key figure for calculation, it will not be calculated with the stored formula,
but will be processed like the other key figures. For example, it might be increased by 5% or it
might be forecast. You can find further information about this in Customizing.

In top-down planning you enter a reference base for the value distribution For more information
see Top-Down Planning [Page 152].

Characteristic Value Restriction
Choose the tab page Selections to restrict the characteristic values. If you want to plan the
regions South and East only, for example, enter single values or an interval.

Choose Automatic planning → Execute to carry out the automatic planning.

Save Parameterization
When you have made all settings for the planning run, you can save them as parameterization
with a specific name. Enter a technical name and a description of the settings in the field current
parameterization and choose , to save. This saving of the planning parameters is at the same
time a prerequisite for being able to schedule planning runs in the background.

Background Processing
If you wish to change a lot of data, it is recommended to let the automatic planning run in
background processing. While the automatic planning is running the program RKCPLEXE is
called up. Using a variant for this program, you determine which parameterization is used for the
planning. Then you plan the program in background processing.

Result
The plan data is generated automatically according to the function you have selected, and is
saved to the database if required. If a log has been kept, it is displayed automatically during
online execution, or written to the spool during background processing.
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Seasonal Distribution
Use
Using the seasonal distribution, you can distribute values that you enter for the entire planning
time frame to the individual periods according to a predefined distribution key. The default setting
distributes values in line with those already existing. If no values already exist the distribution is
carried out evenly.

You can use the seasonal distribution when changing plan data automatically, and in interactive
planning (see Edit plan data automatically [Page 141]and  Edit plan data interactively [Page
126]).

Prerequisites
You are using SAP-delivered distribution keys or you have created your own.

Features
Automatic Planning
The seasonal distribution of the reference data remains intact when copying, meaning that period
values are copied. If the seasonality in the reference data is not to be adopted due to special
circumstances, you can copy the plan data and change it at the same time. You do this by
entering a new seasonal distribution for the planning run. The reference data for all periods of the
selected reference time frame is accumulated and distributed to the periods of the planning time
frame according to the seasonal distribution key. You can use certain SAP-delivered distribution
keys for this or create your own (see Maintaining Distribution Keys [Page 145]).

In the planning session you can either enter a seasonal distribution for all data records, or you
can select an object-dependent distribution for a specific characteristic combination. The object-
dependent distribution is controlled by a planning aid access created in Customizing. For more
information see Maintaining Distribution Keys [Page 145].

Note that, if the distribution key is not maintained for the time period to be planned or
the characteristic combination, then the data will be copied but not distributed.

Interactive Planning
When planning interactively, you define a column for the distribution key in the planning layout.
As a default, distribution key 2 (analogous distribution) is set. When entering the plan values, you
can change the key in the overview screen. You can display the distributed values on the period
screen, and change them if necessary.
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Maintaining the Distribution Key
Use
The function Create distribution key is an optional planning aid, that makes the entry of plan
data easier.

Using the distribution key, you can distribute values that you enter on the overview screen for the
entire planning time frame, to the periods according to a predefined seasonal distribution. The
default setting distributes values in line with those already existing. If no values already exist the
distribution is carried out evenly.

You can assign a distribution key to certain combinations of characteristic values in Customizing
in order to represent different planning scenarios in automatic planning. This assignment is done
using an object-dependent parameter and a planning aid access. For each combination of
characteristic values (for example, company code 0001, fiscal year 1999) you can portray several
scenarios. You do this by storing several object-dependent parameters with different planning aid
accesses. This enables you to store, for example, best-case and worst-case plans. For more
information, see Customizing.

Features
If you would like to use a particular seasonal distribution, you can define new distribution keys. A
relative factor is assigned to each period and the entered plan values are distributed according to
this factor. All periods, to which no value has been assigned, implicitly receive the factor zero.
The number of periods in the year is determined from the fiscal year variant of the aspect.

If you wish to set up a seasonal distribution that repeats each year, enter the data for any year
you wish and check the field Cyclical.
If necessary, you can also delete distribution keys that are no longer required.

The creation of a distribution key is described in more detail in Customizing.
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Revaluation
Use
When changing your plan data, you can revaluate the values using either a percentage increase
or decrease. This enables you, for example, to base your plan values for 1999 on your actual
values from 1998 plus 10%.

You can execute the revaluation when changing plan data automatically, and in interactive
planning (see Edit Plan Data Automatically [Page 141] and  Edit Plan Data Interactively [Page
126]).

Prerequisites
You have created revaluation factors for the revaluation in automatic planning.

Features
Automatic Planning
For automatic planning, you determine the percentage increase or decrease by means of a
revaluation factor for each key figure (see Determining the Revaluation Factor [Page 147]). If you
want to use existing plan or actual data (with a percentage increase or decrease) as a basis for
new plan data, select a revaluation factor. The reference data will then be amended to take
account of this increase/decrease.

In the planning session you can either enter a revaluation for all data records, or you can select
an object-dependent revaluation for a specific characteristic combination. The object-dependent
revaluation is controlled by a planning aid access created in Customizing. Note that, for object-
dependent revaluation, the revaluation factor must be maintained for the target time period. The
system executes the revaluation of the data in the target time period with the appropriate
revaluation factor. For more information see Determining Revaluation Factors [Page 147].

Interactive Planning
In interactive planning you can enter the increase or decrease as a percentage, or you can enter
it directly as a value. In this case you do not need a revaluation factor.

Select a cell, a column, or a row and choose Edit → Change values. In the dialog box which
appears you can enter a percentage for the revaluation, or you can enter a value to be added.
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Determining the Revaluation Factor
Use
A revaluation factor is an optional planning aid that makes the entry of plan data in the automatic
planning easier.

A revaluation factor defines increase and decrease percentage rates for the key figures of an
aspect. When maintaining the revaluation factors, enter a revaluation factor for each key figure
that should be increased. For each key figure that should be decreased you enter a negative
revaluation factor.

You can assign a revaluation factor to certain combinations of characteristic values in
Customizing in order to represent different planning scenarios in automatic planning. This
assignment is done using an object-dependent parameter and a planning aid access. For each
combination of characteristic values (for example, company code 0001, fiscal year 1999) you can
portray several scenarios. You do this by storing several object-dependent parameters with
different planning aid accesses. This enables you to store, for example, best-case and worst-
case plans. For more information, see Customizing.

Features

 
The plan for the year 1998 should be created as a proposal from the actual data from
1997, increased by 5%.

1. Using New entries you enter the name of the revaluation factor

2. Select Assign factors.

3. Using New entries you select the corresponding key figures for
which an increase should be determined.

4. In each field enter Percentage rate 5.

5. Save your entries.
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Forecast
Use
A forecast is a projection of available data using statistical methods.

Based on existing plan or actual data, new plan data is generated for a certain time period.
Various forecast strategies or models are supported such as moving average, 2nd order
exponential smoothing, and seasonal models. The models and forecast parameters are
maintained in forecast profiles. Using a forecast profile, you can forecast plan values for several
combinations of characteristics and key figures. You can find more information on forecast
profiles under Forecast Profile [Page 150].

You can use the forecast when changing plan data automatically, and in interactive planning (see
Edit plan data automatically [Page 141] and  Edit plan data interactively [Page 126]).

Integration
You can find more general information on the forecast in the online documentation on Sales and
Operations Planning, section Planning Table: The Forecast [Ext.].

Prerequisites
You have created a suitable forecast profile in Customizing.

Features
Automatic Planning
In automatic planning, the data is projected according to the profile parameters.

In the planning session you can either enter a forecast for all data records, or you can select an
object-dependent forecast for a specific combination of characteristics and key figures. The
object-dependent forecast is controlled by a planning aid access created in Customizing. For
more information see Forecast Profile [Page 150].

Interactive Planning
In interactive planning you also use a profile to execute a forecast. You can change the forecast
parameters online, or you can modify the forecast data directly, or interactively using a graphic.

1. Position the cursor on the cell for which the forecast is to be executed.

2. Choose Edit → Planning functions → Forecast or press F9.
The dialog box for the model selection appears.

3. Enter the start and end dates of the period for which you wish to forecast data. The time
period you have already selected for planning appears as default in this field.

4. Enter the start and end date of the past period, from which the data for the forecast is to
be taken. Also enter the version and the plan/actual indicator of the reference data.

5. Enter a profile. If you wish to execute the forecast interactively, choose also Interactive
forecast.
To display a log of any errors that may have occurred during the forecast, choose
Display forecast messages.
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6. In the next dialog box you set up the model. If necessary you can edit the values from
past time periods. Then choose Forecast.

7. In this dialog box you change the parameters for the model. Then choose Forecast.

8. The results of the forecast are displayed in the next dialog box. You can change these
either manually or by using the interactive graphic.

9. Then the log is displayed.

10. Save the data in the planning layout.
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Forecast Profile
Use
A forecast profile consists of a strategy and a grouping of parameters, according to which, you
can project existing plan or actual data into the future.

The profile allows you to execute the forecast repeatedly without having to make the forecast
settings each time.

You can assign a planning profile to certain combinations of characteristic values in Customizing
in order to represent different planning scenarios in automatic planning. This assignment is done
using an object-dependent parameter and a planning aid access. For each combination of
characteristic values, for example company code 0001, fiscal year 1999, you can portray several
scenarios. You do this by storing several object-dependent parameters with different planning aid
accesses. This enables you to store, for example, best-case and worst-case plans. For more
information, see Customizing.

Features
Each profile has a forecast strategy. This defines the forecast model, for example constant,
trend, seasonal model, together with the desired parameters.

See also the following information in the online documentation on Sales and Operations
Planning:

Forecast Model [Ext.]

Forecast Profile [Ext.]

Forecast Parameters [Ext.]

In your forecast, you may wish to give certain values a higher weighting so that they will have a
greater effect on the projection strategy. To do this, you must create weighting groups (see
Weighting Group [Page 151]
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Weighting Group
Use
A weighting group weights the data from certain previous periods using weighting factors.

It is required for a projection with a weighted moving average forecast model in order to
determine the future values.

You can find further information about this in Customizing.
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Top-Down Planning
Use
Top-down planning is a distribution of plan data from a high level to objects on a lower level.

You can distribute plan data that is planned at a higher level (for example, customer group) to a
lower level (for example, customer). The plan data is distributed analogous to the existing
reference data. Plan and actual data can be used as a reference.

Top-down planning is only possible in automatic planning For an example of top-down planning,
see Top-Down Scenario [Page 154]. For general information on the procedure, see Edit Plan
Data Automatically [Page 141].

Features
Methods for the Distribution
Here you can choose between two methods.

If you distribute the total value, the existing values on the lower level are summed with the values
on the level to be distributed, and then newly distributed. This method is appropriate for a
situation where existing values are also to be newly distributed according to the reference data.

If you choose the option Distribute nonassigned values only, the higher level values to be
distributed are broken down according to the reference data and then added to the existing data
on the lower level. This method is appropriate for a situation where the existing values are not to
be newly distributed, for example, because you changed the values manually after the last
distribution.

Reference Base
You have two possible reference bases for distribution of the values.

•  You can use one specific basic key figure as a reference base for all key figures.

This way all key figures are distributed on the basis of (for example) sales volume.

•  You can use the relevant key figure as a reference base for itself.

This way the revenue is distributed on the basis of revenue, sales commission on the
basis of sales commission.

Processing of the Characteristics
You determine for each selected characteristic, how it should be processed in top-down
distribution.

•  Distribute

 The values are distributed to these characteristics.

•  Transfer

The values are distributed from this level to the other characteristics. Then, the data at
this level is deleted.
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Top-Down Scenario
Revenue is planned in two different categories:

•  Split by region

•  By country for businesss transactions for where a regional assignment is not appropriate.

The following plan data was planned at the level of the characteristic Region (in addition to the
revenue not split by region).

Country Region Revenue in USD (thousands)

USA East 100

USA West 80

The following plan data was planned at the level of the characteristic Country (in addition to the
regionally assigned values).

Country Region Revenue in USD (thousands)

USA -- 90

For the country USA, the planned revenue is to be newly distributed based on the previous year’s
values for the key figure sales volume.The following was selected as reference data:

Country Region Sales volume

USA East 50

USA West 100

The distribution of the previous year’s sales volume data means that the revenue is to be
distributed in a 1:2 relationship to the regions East and West. This distribution can be carried out
using either of two strategies:

1. Result: Distribution by the ‘Distribute total value’ method
The planned values are summed to a total value of USD 270,000 and are newly distributed at
regional level according to the reference base:

Country Region Revenue in USD (thousands)

USA East 90

USA West 180

2. Result: Distribution by the ‘Distribute unassigned values only’ method
Only the value at the higher level (Country), USD 90,000 is distributed based on the actual
previous year’s data for the key figure sales volume, and summed to a total value per region:
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Country Region Revenue in USD (thousands)

USA East 130

USA West 140

The value at country level is deleted in both cases after the top-down planning.

Country Region Revenue in USD (thousands)

USA -- --
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Information System (EC-EIS)
Purpose
The information system is the presentation and analysis tool of the executive information system
(EC-EIS). The EC-EIS data is presented in both the report portfolio and drilldown reporting.

The end user can view predefined reports, graphics and texts in the report portfolio. In drilldown
reporting the Controller not only prepares reports for management, but also analyzes and makes
comments on the data.

Implementation Considerations
You need this component for reporting on the EC-EIS data.

Integration
You can use the information system to report on the plan data from Business Planning (EC-BP).

Features
For more information on the functions in drilldown reporting see Interactive Drilldown Reporting
[Page 157]

For more information on the functions in the report portfolio see Report Portfolio [Page 200].

Constraints
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Interactive Drilldown Reporting
Purpose
Drilldown reporting is a dialog-orientated information system for evaluating the data on your EC-
EIS database. The task of drilldown reporting is to portray business objects (combinations of
characteristics) in such a way that you can quickly pinpoint noteworthy objects, because, for
example, they contain unusually high or low values for a particular key figure. It is important to
note that drilldown reporting always refers to the business objects of one particular aspect.
Drilldown reporting can be used to evaluate the dataset according to all the characteristics
contained in an aspect. You may use any key figures you wish in interactive drilldown reporting.
The system also enables you to perform variance analyses (plan/actual comparisons, fiscal year
comparisons, object comparisons, etc.). For each key figure, you can display several objects and
for each object, several key figures.

Interactive drilldown is mainly used by employees from controlling and staff departments.

Integration
The EC-EIS data is presented in both the report portfolio and drilldown reporting. The end
user can view predefined reports, graphics and texts in the report portfolio. For more information,
see Report Portfolio [Page 200].

Features
Drilldown reporting contains convenient functions for navigating through the dataset, for example,
next level (drilldown), next object within a level, hiding a level, detail list, and drilldown list. It also
contains numerous additional functions for editing a report interactively (conditions, exceptions,
sort orders, top n lists, etc.). In addition, drilldown reporting is connected to SAP graphics,
SAPmail, and various printing functions with Microsoft Word and Excel. With the interface to the
product "inSight" from arcplan Information Services, you can configure your own graphical user
interface for interactive drilldown reporting.

Within drilldown reporting you can create and display reports which are simple in layout (data
controlled) or more complex (formatted).

The data selected for a report can subsequently be saved. This leads to improved response
times the next time you call up the report. This may lead to the report data not being completely
up to date, which is not necessarily a disadvantage, for example, report data that only needs to
be updated periodically.

The functions in drilldown reporting are split into three levels so that a user can access the
function level which most suits his information requirements and tasks.

As well as the interactive functions, reporting contains functions for printing large numbers of
reports.

You can find general information on drilldown reporting, and its procedures in the cross-
application online documentation Drilldown Reporting [Ext.].
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Drilldown Reports
Definition
A drilldown report is a report used for the interactive evaluation of data.

Use
Drilldown reports are created by members of the controlling department and other concerned
departments according to their specific requirements. The subsequent evaluation of the selected
data is normally carried out by the same people. The results of drilldown reporting can be
assembled in a graphical report portfolio, for specific user groups.

Structure
A report can be created as either a basic report or a form report. The form report, in contrast to
the basic one, lets you configure the layout as you wish.

In a report, we differentiate between two types of list. In a drilldown list, several objects
(characteristic values) such as divisions, are shown in the rows and a selection of key figures (for
example, revenue and contribution margin 1) are shown in the columns. In a detail list, a single
object (for example, the combination of customer X in sales area 1) is broken down into all its
component key figures. The rows of the list are composed of the key figures, and the columns
may contain, for example, the planned and actual values for the object.
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Creating a Report

Use
The construction of a drilldown report does not just involve the creation of the report itself but
also the creation of other components of reporting. The functions that are valid generally are
described in the online documentation Drilldown Reporting [Ext.]. Supplementary EC-EIS specific
functions are described in this section. To get an overview of the necessary steps when creating
a report, we recommend that you read this documentation first.
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Creating and Changing a Form
When creating a new form in an aspect which was created before Release 4.0, you must first
specify or change the data area. The data area determines the time frame in which the
transaction data is stored, for example, in weekly or monthly values. Once you have saved the
form, you can no longer change the data area.

When changing a form, you should be aware that it may already have been used in various
reports. The change will automatically be made in all these reports. This is the case both for
drilldown reports and for definition reports in the report portfolio. Changes to a form do not affect
data reports in the report portfolio.

You can find general information on drilldown reporting, and also the appropriate procedures in
the cross-application online documentation Drilldown Reporting [Ext.].
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Copying a Form
In some situations it may be helpful to use the same form in two or more aspects. You can copy
a form from one aspect to another by choosing menu sequence Form → Copy on the initial
screen for maintaining a form (Information system → Form → Create or Change). Then you enter
the form to be copied, the aspect from which it is to be copied, as well as the target aspect and
the name of the new (copied) form. When the form has been copied, no relationship exists
between the two forms.

You can find general information on drilldown reporting and on its procedures in the cross-
application online documentation Drilldown Reporting [Ext.].



 SAP AG Executive Information System and Business Planning

Characteristic Groups

April 2001 163

Characteristic Groups
Use
You can define characteristic groups for use in presentation in the Executive Information System.
These let you call up a specific group of characteristics when you create a report.

When you define a report without entering a characteristic group, the system offers you all the
characteristics of the aspect to choose from. If you enter a characteristic group, however, the
system offers only those characteristics assigned to that group.

A typical way to use this function might be to group together all the region- and customer-related
characteristics which the sales director might use when he or she calls up a report. For
production management, you might define a second characteristic group which contains
characteristics relevant to the product or profit center.

The characteristic groups are set up in Customizing.

Activities
You can define a specific characteristic group in your user parameters using parameter ID MKG;
use System → User defaults → Own data. This lets you limit the choice of characteristics for
individual users.

You can find general information on drilldown reporting, and also the appropriate procedures in
cross-application online documentation CA - Drilldown Reporting [Ext.].

See also:

Key figure groups [Page 164]
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Key Figure Groups
Use
You can define key figure groups for use in presentation in SAP-EIS. These let you call up a
specific group of key figures when you create a report.

When you define a report without specifying a key figure group, the system offers you all the key
figures of the aspect to choose from. If you specify a key figure group, however, the system
offers only the key figures assigned to that group.

A typical way to use this function might be to group together all the personnel-related key figures
or all the finance-related key figures. Note that, unlike characteristics in characteristic groups, a
key figure can only be assigned to one key figure group. Also note that key figure groups are not
dependent on the client, a key figure group is valid for all clients.

Activities
You create a key figure group in Customizing. You can then assign a key figure to the key figure
group under Information system → Key figures → Maintain. For more information on this, see
Maintaining Calculated Key Figures [Page 38]

You can find general information on drilldown reporting, and also the appropriate procedures in
cross-application online documentation Drilldown Reporting [Ext.].

See also:

Characteristic Groups [Page 163]
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Creating Constants
To use constants in the formula for a calculated key figure, you need to first create the constants.
You create constants under Information system → Key figures → Constants.
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User Exit: Elimination of Internal Business Volume
A user exit is available to enable an elimination of internal business volume in drilldown
reporting. With this enhancement you can, for example, eliminate the turnover between
characteristic values (for example, between sender company and receiver company) on the basis
of rules in the user exit.

Setting up the User Exit
The user exit can be called up from the SAP menu under Tools → ABAP-Workbench → Utilities
→ Enhancements → Project management → Utilities → SAP Enhancements.

1. Enter the name KKDR0002 in the field Enhancement and select Program → Execute.

The name of the enhancement is displayed.

2. Position the cursor on the enhancement name and choose Edit →
Components +/-. The available enhancement components are displayed.

Position the cursor on the line "Technical name of the enhancement is displayed.

3. Position the cursor on the line "Drilldown user EIS: Elimination of Internal Business Volume"
and select Edit → Display SAP Docu.

Here you will find the necessary technical information to set up an exit, and a note about example
coding.

Rules for Elimination of Internal Business Volume
There are four different rules for elimination in the user exit. These can be used individually or in
conjunction with one another. The rules are explained in the following section. The technical
formula and an example are given for each rule:

1. The characteristic values in the sender and receiver data records are identical.

Formula notation: Data record (sender) = Data record (receiver)

If, for example, company X sells to itself, no revenue is generated from an external point
of view. This value will be eliminated in the report according to rule 1.

Sender Receiver Amount Result

X X 50,- is eliminated

2. The sender characteristic value in the report cell is the same as the receiver
characteristic value in the data record.

Formula notation: Report cell (sender) → = → Characteristic value → = → Data record
(receiver)

If the sender characteristic value in a certain cell of the report agrees with the receiver
characteristic value in the data record then the value is eliminated in the report.

Rule 2 is normally used in conjunction with rule 3. See Example of Elimination with Rules
2 and 3 [Page 170].

3. The sender characteristic in the cell is not fixed.
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Formula notation: Report cell (sender) = → *
If the sender characteristic is not specified in the cell, the value of the key figure is
eliminated in the cell.

Rule 3 is dependent on the current drilldown level. It is normally only meaningful when
used in conjunction with another rule. Otherwise elimination is usually carried out entirely
or not at all in a whole column depending on the current drilldown characteristic. See
Example of Elimination with Rules 2 and 3 [Page 170].

4. The sender characteristic value in the report cell is the parent node of the receiver
characteristic value in the data record.

Formula notation:  → Report cell (sender)  → = → Node  → = → Parent of data record
(receiver)

In a master data hierarchy, the characteristic values A1 and A2, for example, are
subordinate to characteristic value A. Characteristic value A1 achieves a revenue of 200
DM in a business transaction with characteristic value A2. From the point of view of
characteristic value A1 external revenue was achieved, but from the point of view of
characteristic value A however, the business transaction was internal. The amount is
eliminated in cell A. See Example of Elimination with Rule 4 [Page 173].

When do I use which Rule?
Rule 4 is mostly used in reports which display a master data hierarchy,. This rule eliminates
along a master data hierarchy.

If the hierarchy of the characteristic values is set up in the database, you should use a
combination of rules 2 and 3.

Setting Elimination Conditions
The elimination rules can either be used individually or in conjunction with others. They can be
switched on for either a single characteristic pair (for example, sender company and receiver
company) or for several characteristic pairs. It also possible to form various combinations of rules
and characteristic pairs.

Maintaining Simple Conditions
By simple conditions we mean a single combination of rules(s) and characteristic pair(s), which
determine the elimination.

Elimination of the key figure Ext. revenue according to rule 4 for the characteristic
pair Company.

The first step when maintaining an elimination condition is the selection of the key figure to be
eliminated. This should be a formula key figure defined for the elimination, for example,
EXREVEN = REVEN.

Then you must decide for which characteristic pair or pairs the values are to be eliminated. A
characteristic pair consists of a sender characteristic value and a receiver characteristic value, for
example, sender company and receiver company.

In the third step, you select the rule to execute the elimination with. You summarize this data in
an elimination group
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If you enter more than one rule, the system checks whether at least one rule, for example rule 2
or 3 has been fulfilled at time of execution of the report. This is because rules are combined in a
simple condition using ‘OR’.

Maintaining Complex Conditions

You wish to eliminate according to rule 2 or 3 for the characteristic pair "Company",
but only if rule 2 or 3 is fulfilled for the characteristic pair "Profit Center".

The following graphic should clarify the relationship between the elements of this
elimination group.

Elimination group 1

Key figure
EXREVEN
External
revenue

Subgroup 1 Subgroup 2

Rule 2
or

Rule 3

Rule 2
or

Rule 3
AND

Charateristic pair
SCOM - Sender- company
RCOM - Receiver- company

Characteristic pair
SPCTR - Sender

profit center
RPCTR - Receiver

profit center

In this example, the key figure EXREVEN is assigned to the elimination group 1.
Within this elimination group there are two subgroups, one for the characteristic pair
"Company" and one for the characteristic pair "Profit Center". Two rules are assigned
to each subgroup. In this example these are rules 2 and 3.

According to this condition, an elimination is only made when at least one rule in both
subgroups is fulfilled:

Subgroup 1
Company:

Subgroup 2
Profit center

(Rule 2 OR rule 3) AND (Rule 2 OR rule 3)

When executing a report the system checks in each cell whether rule 2 or rule 3 is
fulfilled for the characteristic pair "Company". Then it checks if rule 2 or 3 is fulfilled
for the characteristic pair "Profit Center". If at least one rule is fulfilled in each
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subgroup then the value of the affected cell is eliminated in the report. See also
Example of Elimination with Rules 2 and 3 [Page 170].

By a complex condition we mean several simple conditions which, in conjunction with each other,
determine the elimination. From a technical point of view, the simple conditions are combined
with a logical ‘AND’. If you want to connect these conditions using ‘AND’, you must assign each
simple condition to a subgroup.

A subgroup consists of one simple condition, which is one or more characteristic pairs and their
corresponding rule(s). All subgroups to be evaluated in conjunction with one another make up an
elimination group.

Within a subgroup the rules are connected by ‘OR’, so when executing a report the system
checks whether at least one condition is fulfilled. The various subgroups are connected by ‘AND’.
This means that the system only eliminates the affected value when at least one condition is
fulfilled in all subgroups of an elimination group.
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Example of Elimination with Rules 2 and 3
Before you look at this example you should read the section called Setting Elimination
Conditions in the chapter User Exit: Elimination of Internal Business Volume [Page 166]. The
example shown there refers to the same data as used below.

You wish to eliminate for the characteristic pair "Company" according to rule 2 or 3, but only if
rule 2 or 3 is also fulfilled for the characteristic pair "Profit Center".

The following information is necessary for maintaining the user exit:

Element Technical Name Meaning

Elimination group 1

Subgroup 1

Sender characteristic SCOM Sender company

Receiver characteristic RCOM Receiver company

Rules 2 and 3

Key figure EXREVEN Ext. revenue

and

Element Technical Name Meaning

Elimination group 1

Subgroup 2

Sender characteristic SPCTR Sender profit center

Receiver characteristic RPCTR Receiver profit center

Rules 2 and 3

Key figure EXREVEN Ext. revenue

According to this condition, an elimination is only made when at least one rule in both subgroups
is fulfilled:

Subgroup 1
Company:

Subgroup 2
Profit center

(Rule 2 OR rule 3) AND (Rule 2 OR rule 3)
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In the following graphic you can see the posted data records and two pages of the report for the
characteristics Sender Company, Receiver Company, Sender Profit Center and Receiver Profit
Center with a comparison of the eliminated and total revenues.

SC RC SP RP

Value type 0
Fiscal year 1997
Period 1

Actual data
Fiscal year 1997

to 3
Revenue Reven. Curr.

EGESL

TEST Ext. revenue

SGESL A1 Company A1

RPCTR
Display

Revenue
TDM

Ext.revenue
TDM

X Profit Center X 30 30
Y Profit Center Y 40  0
Y2 Profit Center Y2             140              140
Result            210              170

SPCTR
Display

Navigation

TEST Ext. revenue
Navigation

SPCTR
RCOM

SCOM A1 Company A1
RPCTR Y Profit Center Y

Revenue
TDM

Ext.revenue
TDM

X Profit Center X 40              40
Result 40  0

DEM
DEM
DEM
DEM
DEM

DEM

DEM
DEM
DEM

DEM
DEM
DEMSum

Using the following table, you can see which rules are fulfilled in the three rows on the first report
page:

Ro
w

Subgroup 1
(Company)
Rule 2

Subgroup 1
(Company)
Rule 3

Subgroup 2
(Prof.Center)
Rule 2

Subgroup 2
(Prof.Center)
Rule 3
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X not fulfilled not fulfilled not fulfilled fulfilled

Y fulfilled not fulfilled not fulfilled fulfilled

Y2 not fulfilled not fulfilled not fulfilled fulfilled

Only in row Y is a rule fulfilled for both subgroups. Let’s look more closely at the row Profit
Center Y. The characteristic Sender Company is specified in the report header (A1). Therefore,
rule 3 is not valid for subgroup 1. Rule 2, however, is fulfilled in this case as the sender company
in the cell is identical to the receiver company in the data record. Therefore, one rule is fulfilled
for subgroup 1.

Then the system checks the rules of subgroup 2. Rule 3 is valid for this cell and subgroup 2 as
the Sender Profit Center is not specified. One rule from both subgroups has been fulfilled and
thereby the value of cell Profit Center Y / Ext. revenue eliminated.

As the elimination using rule 3 is dependent on the drilldown level, row Profit Center Y is now
drilled down in the report. On the second report page you can see that the characteristic Sender
Company (A1) and the characteristic Receiver Profit Center (Y) are defined in the header. There
is now an external revenue in the cell Profit Center X / Ext. revenue. This is due to the fact that,
although rule 2 is fulfilled for subgroup 1 (Sender Company identical to Receiver Company), no
rule is valid for subgroup 2. In this case therefore, the value is not eliminated.

See also User Exit: Elimination of Internal Business Volume [Page 166]
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Example of Elimination with Rule 4
In the following example, for the characteristic Sender Profit Center (SPCTR), you will see the
posted records and the report with the eliminated and total revenues for comparison. The master
data hierarchy for the characteristic Profit Center is displayed below.

Hierarchy RKCG SCOML
Short description Sender company
Status saved

Hierarchy RKCG SPCTR
Short description Sender Profit Center
Status saved

TotalTOT TotalTOT

Profit Center X

Profit Center X1

Profit Center X11

Profit Center X12

Profit Center X2

Profit Center Y

Profit Center Y1

Profit Center Y2
Profit Center Y3

Profit Center Y4

Profit Center Z

Profit Center Z1

Profit Center Z2

X

X1

X11

X12

X2

Y

Y1

Y2
Y3

Y4

Z

Z1

Z2

Company A

Company A1

Company A11

Company A12

Company A2

Company B

Company B1

Company B2

Company C

A

A1

A11
A12

A2

B

B1

B2

C

The following information is necessary for maintaining the user exit:

Elimination group 1

Subgroup none

Sender characteristic SPCTR Sender profit center

Receiver characteristic RPCTR Receiver profit center

Rule 4

Key figure EXREVEN Ext. revenue
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EXREVEN Quarterly report

Value type 0 Actual data
Fiscal year 1997 Fiscal year 1997
Period 1 bis      3

Revenue Reven.curr.

Navigation
Period
RPCTR
RCOM
SCOM

SPCTR
Display

Total
Profit Center X
Profit Center X
Profit Center X1
Profit Center X1
Profit Center Y
Profit Center Y
Profit Center Y1
Profit Center Y2

TOT
X

X
X1

X1
Y

Y
Y1
Y2

Revenue
TDM

Ext.revenue
TDM

Look at the node Profit Center Y in the examp le. Y is the parent node of Y1 and Y2. In the
report the revenues for Y2 are eliminated as it has only attained revenue with itself. Profit Center
Y1, however, achieves revenue of 100 thousand DMs, as it settled two transactions with Profit
Center Y2. Profit Center Y achieved revenue of 44 thousand DMs with Profit Center X. On the
group level of Y, however, only 44 thousand DMs are shown in the report since the internal
business volume of the group is eliminated. The internal business volume for Profit Center X and
its subnodes is also eliminated.

On the top level of the report you can see that an external revenue of 52 thousand DMs is
displayed. As rule 4 eliminates along a hierarchy, the revenue which was generated between
Profit Centers X and Y is also eliminated. Only the revenue which was achieved with an external
receiver counts as external revenue.

See also User Exit: Elimination of Internal Business Volume [Page 166]
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Creating a Report
The functions used to define a report can be accessed from the SAP-EIS menu (Information
system → Report → Create). You can find general help on report definition in the cross-
application online documentation Drilldown Reporting [Ext.]. SAP-EIS specific functions and
features are described here.

From the initial screen, you can access the various components of a report in any order. Below,
you will find an explanation of the features relating to SAP-EIS in the order in which they are
described in the cross-application online handbook.

Note for Users of Aspects that were created before Release 4.0

While you process the components of the report, you can specify or change the data
area under menu sequence Extras → Data area.. The data area determines the
time frame in which the transaction data is stored, for example, in weekly or monthly
values. A report in SAP-EIS is always based on one version.
With form reports the version is set during the form definition. This data area is taken
as the default for the report. You can however, choose another data area for the
report, if the two versions use the same fiscal year variant.
With the parameter-ID VRS you can define a certain data area in the user master
record using System → User profile → User parameters. This data area is then used
as the default in the basic report. It is only a proposal and you can overwrite it.

As the data area is of considerable importance when defining a report, it cannot be
changed afterwards.

For more information see Master Data [Page 45] .

Entering Variables
In a basic report in SAP-EIS, the fields Fiscal year, Period (from/to), Plan/Actual indicator
(actual/plan) and Version  are automatically stored as variables. You must specify them either on
this screen or when you execute the report.

In a form report, the fields vary depending on the form definition.

Selecting Characteristics
On the screen Characteristics the system displays a list of the characteristics in the relevant
aspect. You select those characteristics which interest you. If you have created characteristic
groups, a field Characteristic group appears on the screen. If you make an entry in this field, the
system only displays the characteristics contained in that group (see Characteristic Groups [Page
163]).

On this screen, you can also maintain comments on the report under Extras → Comment.

Using Extras → inSight on/off, you can activate or deactivate the current report for access from
inSight. Only reports which are activated here can be called up in inSight. The switch is set to ‘off’
as a default.
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The latter two functions can also be carried out on the screens Characteristic Values
and Key Figures.

Characteristic Values
If you choose a characteristic for which one or more hierarchy variants have been created, you
can choose one of these variants for the report under Extras → Select hierarchy.... If you do not
yet know which of the hierarchy variants will be of interest when the report is executed, you can
choose Entry at execution.

If certain characteristics were correspondingly created in the current aspect and master data
hierarchies exist for these in the original application, you can also select these hierarchies here.
This applies to cost center, cost element and profit center hierarchies as well as for HR
organizational structures, company groupings, and balance sheet/P&L structures. For more
information see Master Data Hierarchy [Page 49]

To be able to select a hierarchy for cost centers, cost elements or profit centers, you
have to have selected the characteristic Controlling area in the report.

To be able to select a P&L structure you have to have selected the characteristics
Company code and Chart of accounts in the report.

Key Figures
On the screen Key Figures, the system lists all the key figures that relate to the chosen aspect. If
you have assigned key figures to key figure groups, a field Key figure group appears on this
screen. If you make an entry in this field, the system will offer the key figures in the desired
group, rather than all the key figures for the aspect (see Key Figure Groups [Page 164]).

The function Extras → Key figure info. is used to display further information about the key figure
on which you have positioned the cursor. The key figures are subdivided into basic key figures
which are stored on the database, and calculated key figures, which are calculated when you
execute the report. Derived key figures can result from operations using basic key figures, and
also from operations using other calculated key figures. This function displays the formula behind
a calculated key figure.

Elimination of Internal Business Volume

If you wish to eliminate the revenue between two internal organizational units in your
reports there is a corresponding user exit which you can use. For more information
see User Exit: Elimination of Internal Business Volume [Page 166]
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Changing Reports and Displaying Reports
When you use the functions Information system → Report → Change and Display, you
process the same screens as when you create a report.

When you change a drilldown report in SAP-EIS, the same SAP-EIS-specific features need to be
taken into account as when you create a report (see Creating Reports [Page 176]).

In addition to the functions described in the cross-application online handbook, you can also
display comments when you display a drilldown report in SAP-EIS.

If you wish to delete a report, you can do so from the Change transaction. However, if you wish
to delete a group of reports, it is easier to do this under Tools → Info system→ Delete reports.

You can find general information on drilldown reporting, and also the appropriate procedures in
cross-application online documentation Drilldown Reporting [Ext.].
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Working with Reports
Use
There is a series of functions available with which you can edit a report. You can find a detailed
description of the available cross-application functions in the online documentation CA -
Drilldown Reporting [Ext.]. The supplementary functions specific to EC-EIS are explained here.

Selecting a Report [Page 180]

Executing a Report [Page 182]

Freezing Report Data and Printing Reports in the Background [Page 186]

Connection to inSight for SAP-EIS [Page 189]
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Selecting a Report
Report Tree
In Customizing it is possible to build up a hierarchy of drill-down reports. This hierarchy is called
a reporting tree and is used to:

•  collect all reports for a certain area

•  structure reports hierarchically.

In Customizing, you define

•  which reports are to be contained in the reporting tree and

•  how the hierarchy is to be structured.

You access the reporting tree in the Executive Menu under Information system → Report
selection.

You can also create a reporting tree which consists of those reports which you regularly use. The
user tree is stored under your user name. When you call up the reporting tree, the system only
displays the reports contained in your user tree. Using Goto → Standard tree on/off you can
switch back to the reporting tree defined in Customizing.

To call up a report, position the cursor on an end node of the reporting tree and choose Select.

For more information on the functions in the reporting tree see Utilities → Online manual.

Standard Reports
The standard reports for aspect 1 (Profitability Analysis) and aspect 50 (Balance sheet/P&L) are
available under the EC-EIS report selection. These can be used as models for further EIS
reports.

In detail, the following are reports for aspect 1:

Plan/actual comparison 0-SAP01

Division comparison 0-SAP02

Ranking list according to customer groups 0-SAP03

Contribution margin: Region / business area / Prod. group 0-SAP04

Percentage 0-SAP05

Comparison: Current year / previous year 0-SAP06

Quarterly comparison: Customer group / division 0-SAP07

Quarterly comparison: State list 0-SAP08

Quarterly comparison: Product group list 0-SAP09

The following reports are delivered for aspect 50:

Group: Year / previous year in group currency 0-SAP01
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Company: Year / previous year in local currency 0-SAP02

Company code: Closing year / previous yr in grp / local currency 0-SAP05

Company code: Financial statement year / prev. year in local curr 0-SAP06

Overview company codes: Key figures in group currency 0-SAP07

Company code: results structure year / previous year in local curr. 0-SAP08

Working in the Report
After you have executed the report, you have the use of the usual drilldown functions. For more
information on navigation and editing within a drilldown report, see the online documentation
Drilldown Reporting [Ext.].
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Executing a Report
On the initial screen of the function Information system → Report → Execute, you will find the
functions Execute and New selection. The first thing to mention in order to understand these
functions is that you can select new data when calling up a report, or you can work with a dataset
which was saved previously.

•  The function Execute

If saved data is available the system calls up the last report saved. If no report data was
saved, but data is available on a corresponding summarization level, then the
summarized data is displayed. If there is no saved or summarized data available then the
data is selected anew.

•  The function New Selection

The current dataset is always selected.

In the top right corner of the report, the system always displays information about the
dataset used (Current data or Data of MM.DD.YY HH:MM:SS).

You save the data from a report either under Information system → Report → Execute using
function Save data, or, using a variant in background processing (see Freezing Report Data and
Printing Reports in the Background [Page 186]). If saved data exists for a report, the system
does not have to select the data from the SAP-EIS database when the report is next executed.
This has a positive effect on the runtime of the report.

If you want current data but would still like to shorten the runtime of the report, you can set up a
summarization level for the report. For more information see Summarization Levels [Page 195]

For general information on performance in reporting see Optimizing Response Times [Page 193]

Function Levels for Different User Categories
The functions in drilldown reporting are divided into three groups so that different user categories
can use different functions depending on their information requirements and tasks. This means
that users can quickly learn how to use the functions they require. You can access these levels
under Extras → Other functions.

Level 1 contains the basic drilldown reporting functions, a connection to any available documents
or comments to a report, and the interface to SAPoffice. Using the assigned functions, you can
navigate through a defined hierarchy of characteristics in a predefined report. To analyze larger
datasets, you can use the functions in the detail list.

This level is aimed at users who occasionally wish to analyze form reports in drilldown reporting
without requiring the full navigation functionality.

Level 2 contains the functions in Level 1 and the remaining navigation functions in drilldown
reporting, the interface to the report portfolio, and also Excel List Viewer and PC download,
graphic functions, functions for changing the display and all functions for working with
hierarchies. The user can also display exceptions.

This level is aimed at users who require the complete analysis functionality in drilldown reporting,
and also the interfaces mentioned above.

All functions includes the functions in Level 2 plus the print setting functions, the functions for
saving reports, defining exceptions and maintaining reports in drilldown reporting.
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This level is aimed at users who not only require the full functionality of drilldown reporting, but
also need to maintain reports and print settings.

Using parameter IDs RLV1 (Level 1), RLV2 (Level 2) and RLV0 (All functions), you can assign a
level to each user master parameter via menu sequence System → User defaults → Own
data. This enables you to assign a function level to a user depending on his or her requirements.
You can change the level in a report under Extras → Other functions. Before the function level
is changed the system runs an authorization check.

SAP-EIS-specific Functions
•  Report →Export

Using this function you can copy the current sheet or a sequence of sheets, with or
without data into the report portfolio. For more information see Copying Reports from
Drilldown Reporting [Page 206]

•  Goto → Graphics → Graphics...

You can show portfolio graphics on the drilldown list. Portfolio graphics are used to
display various objects in two dimensions in certain positions using an X/Y coordinate
system. You can define the radius of the objects using a third dimension. You can also
create pie charts for objects using further dimensions. The system displays two dialog
boxes where you specify what the portfolio graphic should look like. You can call up the
graphic from the first dialog box. You will find more information in the online help on the
portfolio graphic itself.

•  Goto → R/2 report

This function passes on all the selection conditions of a specific cell in a report to an R/2
system. From there, as of the next R/2 release, it will be possible to call up the
transaction relevant to the contents of the cell automatically. This function will enable a
form of navigation between SAP-EIS and an R/2 system.

•  Extras → Transfer log

Using this function, you can display a list of the last nine data transfers and their status.

•  Extras → Comment → Display

Comments to entire reports, to key figures, to characteristics and to characteristic values
may be available. To determine for which objects comments are available, select Extras
→ Comment → Highlight. The objects are then emphasized in color. Position the
cursor on the desired emphasized text and select Extras → Comment → Display.
The comment is displayed in a dialog box.

If a comment is available for the object in the language in which you have logged on,
it will be displayed in this language. If it exists in several foreign languages, it will be
displayed in the language which was defined next in the sequence in the system.

•  Extras → Comment → Maintain

If you wish to create or change a comment select this. With this function, you access the
editor with which you can create a new comment or change an existing one.

For objects such as characteristics, key figures and characteristic values, you maintain
comments under menu options Master Data → Comments → Maintain in the SAP-EIS
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application menu. For maintaining comments on other objects see Maintaining
Comments [Page 81].

•  Extras → Comment → Highlight

This function highlights all fields for which a comment has been stored. You are therefore
recommended to use this option before displaying or maintaining comments. Please note
that objects for which comments exist for transaction data are not highlighted with this
function.

•  Extras → Comment → Comment on numbers

Using this function, you can create, display, change, or delete comments to transaction
data. Position the cursor in the cell, row, or column for which you wish to see comments
and then select the function. Existing comments on the selected transaction data are
listed in a dialog window. The comments are chosen according to the selection condition
of the report, drilldown level and cursor position. The more specific the data selection,
the more specific the corresponding comments will be. If you position the cursor in the
report header you get comments on characteristics in the header and in the navigational
area, for example. However, if you navigate through the report, drilldown in a row, and
then position the cursor in a cell, you will find comments on the combination of
characteristic values and key figures that determine the contents of this cell.

With the help of the corresponding icons you can display, change or delete these
comments. If you want to create a comment for the selected transaction data another
dialog window appears.

− If you wish to enter the comment in SAPscript, enter a short text and select Continue.
You can enter and format your text.

− If you wish to upload the comment from a PC application, enter a short text and
select Import.... You can select a file from your PC.

The necessary preparations for maintaining comments on transaction data are described
in Customizing.

•  Extras → Document → Display

Document Management [Ext.] is connected to SAP-EIS. The functions under this menu
are only of interest to you if you have the document management system installed.

Using master data maintenance, you can store documents for SAP-EIS master data, for
specific characteristic values. If you position the cursor on an object for which a
document has been stored,  the system displays a dialog box listing all the documents
stored for this object. From here, you can access a function in the document
management system and display a document in bitmap format, for example.

•  Extras → Document → Select

This function highlights all fields for which a document has been stored. You are
therefore recommended to use this function before calling up Display.

•  Extras → Key figure info.

Using this function, you can display further information on a key figure. The formula for
calculating the key figure is displayed.

You can find general information on drilldown reporting, and also the appropriate procedures in
cross-application online documentation Drilldown Reporting [Ext.].
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Freezing Report Data and Printing Reports in the
Background
This section describes how you can select and freeze data in the background for a report . Using
variants and variant groups to save data means that, when you execute the report, data no
longer needs to be selected from the EC-EIS database. The data is already formatted, which
greatly reduces the amount of time it takes to execute the report. For general information on
system performance in reporting, see Optimizing Response Times [Page 193]

This section also describes how you can print reports using variants and variant groups. As with
saving data, you can also have reports printed out in background processing at specific points in
time, including periodically.

The variants and variant groups in Release 4.0 replace the variable groups of earlier
releases. You can get details on the conversion from Release 3.x to 4.0 in the
Release Information in the system.

1. Step: Creating Variants
In order to freeze report data or print a report, you first have to define variants. In a variant you
determine how the variables are filled in the report, in order to be able to process the report in the
background. Select Information system → Report data → Maintain variants.

Establish the selection data for the report and set how the report should be processed in the
background:

•  Printing a report

If you wish to print data, choose Print report(s). You must specify whether you wish to
print the drilldown or detail list. You must also decide whether you want a new selection
of data, or to print existing frozen data.

•  Selecting and freezing data

If you wish to select data in the background, choose Freeze report data. The selected
data will then be saved.

•  Checking exceptions in the report portfolio

If the report is stored in the report portfolio, you can choose Check exceptions. This flag
controls whether the exceptions created in a report portfolio report are to be evaluated in
the report portfolio. If you select this flag, the system first selects the data and then
checks whether any exception thresholds have been exceeded. For more information on
this topic see Exception Reporting in the Report Portfolio [Page 211].

If you have made your entries select Goto → Variants → Save as variant... (see the online
documentation BC Computing Center Management System [Ext.]). You can schedule this variant
in the background processing or execute the report directly online. If it is necessary to schedule
several reports regularly in background processing, you can combine several reports with their
variants in one variant group (see step 2).

2. Step: Defining and Maintaining Variant Groups
Using a variant group you can do the following in one step:
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•  schedule several variants for one report, meaning that you can process different variable
combinations of a report,

•  schedule variants for several reports, meaning that you can process different reports (see
Example of the Use of a Variant Group [Page 188])

Using Information system → Report data → Define variant gr. you can create a variant group.
Then under Information system → Report data → Maintain variant gr. you enter the reports and
variants that you wish to process with this variant group. On the start screen you determine for
which report type you would now like to enter variants. You can however, enter drilldown reports
and report portfolio reports in the same variant group.

3. Step: Scheduling Variant Groups in Background Processing
In the third step, you schedule the variant group in background processing. If you only wish to
schedule certain reports of the variant group, you can enter the reports to be executed. Based on
the variant group and the selected reports, a job will be scheduled in background processing.
You can have this job carried out regularly at fixed points in time. For more information, see the
online handbook BC Computing Center Management System [Ext.].
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Example of the Use of a Variant Group
Report REPORT1 contains one variable for the period and another for the division which you
would like to analyze. A second report, REPORT2, contains variables for the period and the
sales region.

The marketing department of your company is particularly interested in the division
Pharmaceuticals and in the regions Northeast and South for period 1. You create variant
MARKA for this department. For this variant MARKA of report REPORT1, you define the period as
period 1 and the division as Pharmaceuticals.

For MARKB in REPORT2, you define the variable combinations: period 1 and region Northeast,
as well as period 1 and region South.

Then you create a variant group MARKET and enter the variants MARKA and MARKB for the
reports REPORT1 and REPORT2.

In order to print or save the reports you schedule the variant group MARKET in the background
processing.
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Connection to inSight for SAP R/3
inSight for SAP R/3 is a special version of the PC application inSight, which is suitable for the
presentation of data from various R/3 components. It offers an alternative to the SAP-GUI user
interface for displaying drilldown reports.

inSight accesses an R/3 System online via an interface. The elements of the individual drilldown
reports are then available in inSight. In inSight, you can drag-and-drop the elements of the
drilldown report to design a new report. The inSight interface is then actively connected to R/3
using RFC (Remote Function Call). This ensures that both the users who access R/3 via inSight
and those who work directly in drilldown reporting have access to the same figures.

Functions in inSight
In an inSight document you can display several drilldown lists and graphics at once, insert
bitmaps and configure and position control elements such as radio buttons and push buttons as
you like.

You can also use the inSight interface to present reports that use variables or master data
hierarchies. You specify the variable or hierarchy when setting up the document in inSight. You
can set conditions and change sort orders just as in drilldown reporting. If exceptions were
defined in the drilldown report, the corresponding colors are displayed in inSight.

inSight is an ideal tool for the controller or management assistant because of the diversity of its
functions. You can, for example, create quite a complex presentation or choose a specific
selection of reports relevant to a manager’s area of responsibility. Managers can use inSight as a
user interface. Using push buttons and radio buttons, they can call up further data, reports, lists,
graphics and pictures. A document can also be created so that navigation through various levels
is possible.

inSight for SAP is attractive to managers because it combines the business functionality of SAP
R/3 with a convenient, user-friendly interface. There are various display options and you can
configure the documents as you wish (see graphic: Drilldown Report in inSight [Page 192]).

Interface between R/3 and inSight
To display report data from R/3 in inSight, you must first log on to an R/3 system from inSight
(see inSight for SAP R/3: Installation and Logging on [Page 191]). An index of the R/3 reports is
then automatically created in the inSight developer mode and is displayed in the inSight
database window. When you select a report with the mouse, the report definition is read from R/3
and the drilldown report is opened with RFC. All the necessary data for the report is read from
the R/3 database when the report is opened. The data remains in R/3 however, and is
transferred individually for each view in inSight. If you wish to display the data according to
another characteristic value in inSight, the data is prepared in R/3 for this new selection and then
sent to inSight.

Only a selection of drilldown reports are available in inSight. You can determine
whether a report can be called up from inSight or not when you are creating or
changing a report in R/3 (see Creating a Report [Page 176]).

If you want to display data from several SAP R/3 reports in inSight, then inSight logs on to R/3
several times. For each log on, the system uses the same details that you entered when you
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logged on first. You can also display report data from other systems in an inSight file. In this
case, the logon box appears for each system that data is taken from.

The facility to simultaneously display data from more than one report in an inSight file
is available only indirectly (by opening several parallel sessions in the same system).
However, overuse of this facility can lead to an excessive load on the system and
poorer response times. As a reference, the critical limit lies between 20 and 30
reports per inSight file.
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inSight for SAP R/3: Installation and Logging on
Installation
To install inSight for SAP R/3 under the Windows NT operating system you will need Windows
NT 3.51 or higher. For installation under the Windows 3.11 and Windows for Workgroups
operating systems you need the Win32S Version 1.30 system enhancement.

To enable inSight to communicate with the R/3 system you must install the SAP Automation
Server. The Automation Server is delivered with the R/3 system. For more information on the
installation of the SAP Automation Server see the BC - SAP Assistant documentation.

Logging on
After you have fulfilled the prerequisites above and installed inSight, you can set up the
connection to the R/3 system. Proceed as follows:

1. Call up inSight and open the database window.

2. Click on the Create new connection file button in the database window.

3. In the Create new connection dialog box select the option External database and interface
SAP R/3.

4. In the following dialog box, Create new connection, enter a name for the connection file.

5. A dialog box for logging on to the R/3 system is displayed.

Enter the name of the R/3 system and the client. In addition, enter your R/3 user name,
password and the desired language (English or German). You must also fill out the fields
with the necessary server and gateway information. The Host Name is the name or IP
address of the application server. Enter the R/3 instance number in the field System. The
Gateway Host is the name or IP address of the gateway server. The normal entry in the
field Gateway Service is sapgw plus the system number, for example sapgw00. If you
require more detailed information about these entries you should contact your system
administrator or use the menu path Tools → Administration → Monitoring → System
monitoring → Gateway monitor.

For general information on inSight see Connection to inSight for SAP-EIS [Page 189].
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Drilldown Report in inSight
This is an example of the display options in a drilldown report in inSight. You can include
graphics, bitmaps, push buttons and radio buttons with the report lists.
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Optimizing Response Times
This section contains notes about the optimization of response times in a report. It is most
relevant for the project team and the system administrator.

Typically, in an executive information system, reports with aggregated data are required. In these
reports the end user navigates down to the level of detail which is of business interest to him or
her. If the report is executed, the transaction data records are read and summarized so that the
user can navigate as he or she wishes through the free characteristics selected in the report
definition. Further summarizations over the free characteristics take place during the terminal
session, in order to put the lists together. This data is contained in the main memory and can
sometimes lead to a large volume of data and longer response times. In order to read 100,000
records of a length of 500 bytes from the hard-drive, the system typically requires about 3
minutes. The quantities of data are often much larger than that. This means, that in many cases,
executing reports online takes too long. In the following section we detail some of the possibilities
for obtaining optimal response times in reporting.

Executing the Report Online
To call up a report, which reads data from the transaction database, with an appropriate
response time only small quantities of data should be read. As a rule, it makes sense to execute
reports of up to 20,000 records online. With special tuning measures this figure can be higher, for
example, when the database buffer is enlarged and access to the hard drive is no longer
required. Creating special indices can also be of use. The details of the tuning measures are
dependent on both the database system and the operating system.

Executing the Report in the Background and Saving Data
You can execute a report in the background and save the data contained in the main memory.
This data is then known as saved data.

This method has the advantage that the end user does not have to wait for the reading of
transaction data. The report can be scheduled in the background and the end user automatically
receives the most recently saved data. The saved data is also in exactly the level of detail which
the end user requires. A report with saved data can be called up much more quickly than a report
which is executed online, since little demand is placed on the database server.

The disadvantage of this method is that you must create a variant for each variable combination.
This can be troublesome if many, different variable combinations are required. However, these
variants can be summarized in one variant group and executed together in the background

With large, complex reports it makes sense to use saved data..

Summarization Levels
You can reduce the quantity of data to be read (and, therefore, the response time of a report) by
holding the dataset in a summarized form. These summarized datasets are called
summarization levels. You can determine both the number of levels required and the respective
degree of detail.

This process does not just have the advantage that the data which is read from the
summarization levels can be called up quickly, the data is also always up to date compared to
the saved data. The data is always updated at the same time as the aspect transaction database.
A disadvantage of this process is that the data transfer becomes slower with an increasing
number of summarization levels.
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The use of summarization levels makes sense if the data is required by several reports.

As not every summarization level can produce an improvement in response times compared to a
report which is executed online, there are guidelines for defining your summarization levels.

Using the Report-Report Interface
With the report-report interface you can connect several individual reports, each with a limited
number of characteristics, to one another like building blocks in order to be able to navigate from
highly aggregated objects into detail, or to other types of objects. To achieve optimal response
times you start with a highly summarized report. Few free characteristics should be included in
this report. Using the report-report interface you can call up (connected) reports, which contain
additional characteristics with which the objects are described in more detail. These connected
reports normally have good response times as only a small and very specific quantity of data
must be selected.

These processes are in many cases not mutually exclusive. A better result is often
attained with a combination of the methods, for example,

•  saved data for a large, complex report, but a summarization level for a report
using highly aggregated data

•  a report with summarized data, which calls up an online report using the report-
report interface. See Example: How can I Improve the Response Times of my
Report? [Page 198]

See also:

Freezing Report Data and Printing Reports in the Background [Page 186]

Summarization Levels [Page 195]

Overview: Report/Report-Interface [Ext.]
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Summarization Levels
What are Summarization Levels?
Typically in an executive information system, reports with aggregated data are required. In these
reports the end user navigates from a highly aggregated level down to the level of detail which is
of business interest to him. The selected report data is contained in the main memory and can
sometimes lead to a large volume of data and long response times. There are various
alternatives for improving the response times of a report. See Optimizing Response Times [Page
193] In this section the alternative using summarization levels is described, and the guidelines
according to which your summarization levels are to be defined are also explained. You can find
out how to create and build up summarization levels in Customizing.

A summarization level saves transaction data of an aspect in additional compressed forms. In
such transaction data individual objects are described using a range of characteristics.
Summarizing means that selected characteristics are left out. Objects from the original dataset,
which are no longer differentiated once characteristics have been left out, are summarized in one
object in the summarization level. The summarization allows for quick access to the data in
reporting.

These simple example shows how the transaction data records can be summarized on the
database in order to improve the reading times in the report.

Employee xxx in cost center 100 in company code 1000 worked 50 hours overtime.

Employee yyy in cost center 100 in company code 1000 worked 30 hours overtime.

Employee zzz in cost center 200 in company code 1000 worked 20 hours overtime.

If the transaction data were transferred in this way then three records would be
written in the transaction database table:

Employee Cost center Company code Overtime

xxx 100 1000 50

yyy 100 1000 30

zzz 200 1000 20

As a rule relatively few analysis paths are used in reporting, so you can define a summarization
level for the example above.

A summarization level is formed at the cost center level, meaning a summarization is
made over the characteristic employee. The records are compressed together and
the following structure ensues:

Cost center Company code Overtime

100 1000 80

200 1000 20
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In this case, you could set the summarization level even higher, by forming it at the
company code level.

Company code Overtime

1000 100

The more characteristics that are summarized, the higher the level of compression of the data
and the more limited the use of the level. You must decide between the shortened response time
because of the level of summarization and the possible use of the level in reporting. Highly
summarized data will not be of much use to you, if it can only be used in a very few reports.

At the definition stage you have the following options.:

1. Characteristics, above which the summarization will occur

The key figure values are summarized above a characteristic.
Afterwards you can no longer evaluate the characteristic in the report.

2. Free characteristics

The key figure values cannot be summarized over the characteristic.
Afterwards you can evaluate whatever characteristic values you like in the report.

3. Fixed characteristics

The key figure values are only retained for a certain characteristic value.
Afterwards you can only evaluate this characteristic value in the report.

Depending on how you have specified a characteristic in your report, you decide whether a
characteristic is to be summarized, given a fixed value, or left free. You define the summarization
levels in Customizing. To enable  the summarization levels to be used by reports, the levels have
to be supplied with data. To do this, you schedule a job in the background processing to build up
the summarization levels. Only then can the levels be used by reports. After the levels have been
built up, the data is always updated at the same time as the aspect is supplied from the
transaction database. In this way, the summarized data is as up to date as the transaction data.
You can find more information about this in Customizing.

When executing a report, the system checks whether there is saved data available for the report.
If data has already been saved it will be displayed. If no data has been saved for the report but a
suitable summarization level exists, then the data from the summarization level will be called up.
If there is neither saved data nor a suitable summarization level, the data is selected as new.

When do I use Summarization Levels?
If you are not satisfied with the response times of the reports in your Executive Information
System you should consider defining some summarization levels.

However, before you decide on summarization levels you should find out about the other ways of
improving response times. You can read about these under Optimizing Response Times [Page
193]

Guidelines for Creating a Summarization Level
When defining a summarization level there are often several possible combinations of
characteristics. Since not every summarization level can produce an improvement in response
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times compared to a report executed online, there are guidelines for defining summarization
levels. To attain the optimum summarization effect you must analyze the desired report for each
summarization level, determine the affected master and transaction data and consider the
following guidelines:

1. A summarization level should contain as few records as possible compared to the
number of records in the transaction data.

Estimate the number of records to be read on the database, and the number of records
in your planned summarization level. A minimum factor of 10 should be attained.

Where possible, summarization levels should be defined above characteristics with many
values. You can attain a greater summarization effect if you summarize above the
characteristics product and customer as these characteristics typically contain many
values.

If your summarization level contains many records, the corresponding report must be
defined in such a way that it does not have to read more than 10,000 to 20,000 records
from the summarization level.

2. As few summarization levels as possible should exist

Since the summarization levels are updated automatically, each change to the
transaction data leads to an update in all the summarization levels. This means that a
change to one transaction data record leads to several writing processes in the
database. If there are many summarization levels, performance in the data transfer is
impaired.

If you generate a proposal for a summarization level you should edit it manually. You
should also check whether a similar summarization level already exists You will find this
information when maintaining the summarization levels in the overview and detail screen.
You should check this data for all summarization levels occasionally, as the number of
accesses, for example, can help you to decide whether a particular level is still required.
You can find more information about this in Customizing.

3. Dependent characteristics should always be included in a summarization level.

In many cases there is a dependency between several characteristics. If, for example,
the product group is derived from the product number, then the product group is
dependent on the product. The volume of data in the summarization level is not enlarged
by the inclusion of the product group and therefore does not impair performance. The
advantage is that the summarization level can also be used by reports which contain
these dependent characteristics.

The dependency between two characteristics normally exists because of derivation (see
Derivation of characteristic values [Page 54]) or is already given by previous systems, for
example a representative for customers in a customer master.

A detailed description of how you create and build up summarization levels is given in
Customizing.

For an example of defining a summarization level see Example: How can I Improve the
Response Times of my Report? [Page 198].



Executive Information System and Business Planning  SAP AG

Summarization Levels

198 April 2001

Example: How to Improve Response Time of
Report?

An aspect contains the following characteristics:

•  10 main product groups (each with 10 product groups)

•  100 product groups (each with 10 products)

•  1,000 products

•  100 customer groups (each with 10 customers)

•  1,000 customers

In this example the main product group is dependent on the product group, and the product
group is dependent on the product. Furthermore, the customer group is dependent on the
customer. There is no dependency between other characteristics. Each customer buys each
product. One million records (1,000 products * 1,000 customers) result from this in the
transaction database.

In your report you wish to navigate from the list of the main product groups, via the
characteristics product group, product and customer group, to the customer. If you define a
report for this with all characteristics, it would lead to long response times when executing the
report online because the data would be loaded into the memory from the deepest level of detail.

You can solve this problem as follows:

1. You define the first report using the free characteristics main product group, product
group and product.

2. Then you define the second report using all five characteristics where the characteristics
main product group, product group and product are defined as required variables. You
define the characteristics customer group and customer as free characteristics.

3. You link the reports using the report-report interface.

4. You create a summarization level for the first report with the characteristics main product
group, product group and product.

When you execute the first report, 1,000 records are read from the summarization level, since the
product group and main product group depend on the product, and there are 1,000 products.

In order to navigate as far as the customer, you navigate to a product in the first report. Then call
up the second report using the report-report interface. Since the three required variables are
adopted from the first report, a maximum of 1,000 records must be read from the transaction
database. You can now navigate as far as the customer for this product.

Compared to a single report with all characteristics, where a million records must be read, in this
case just 1,000 records must be read twice, and the reports can be executed online.
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Authorization Objects in the Information System
In Customizing you will find information on authorization protection for the characteristics, and on
individual functions when executing reports.
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Report Portfolio
Purpose
This component is used for the collection of predefined reports for different users or groups of
users. Each report portfolio consists of a collection of reports, that are put together for one
particular user.

Implementation Considerations
This component is intended for users who, with minimal knowledge of the system, wish to call up
information put together specifically for them, especially therefore, for top management.

Features
Access to the report portfolio is via a hierarchy, that can also be displayed graphically. This
hierarchy is configured individually by subordinating the nodes, for example to the user’s area of
responsibility. You can assign any number of reports or PC applications to each hierarchy node.
You can individually prepare reports can for the user of the report portfolio, by compiling a
sequence of lists, graphics, and comments. The report data can be either saved in the displayed
state, or regularly updated.
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Report Portfolio
Definition
A 'report portfolio' is a hierarchical structure of all the reports available to a user group. The
nodes of the structure are called report classes. The individual reports, composed of various
elements, are assigned to report classes for a better overview.

List

List Graphic Comment

News

Markets Profit

Finances Sales

Human R.

Individual
structure
of the report
portfolio

Reports

Elements
of a
report

The figure above is an example of how you access the reports via a graphic in the report
portfolio.  Examples of report classes in the above figure are news, profit, finances.

You can arrange the report classes as you wish. You can define a number of different variations
by creating different hierarchies. A user is assigned an appropriate hierarchy of report classes via
his or her user group. The hierarchy can be structured according to area of responsibility such as
division, region or business function. It can contain as many levels as you wish.

A report class contains several reports. An individual report can consist of one sheet, a sequence
of sheets or an external report. A single sheet can be either a table, a graphic, or text.

Use
In the Executive Information System a user is assigned to one or more user groups. Each user
group has exactly one report portfolio. Using this assignment, the user accesses the information
that is of interest to him or her.

Maintaining User Groups [Page 202]

Maintaining Report Classes [Page 203]

Transferring a Report to the Report Portfolio [Page 204]

Using the Executive Menu [Page 215]
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Maintaining User Groups
The first step when setting up the report portfolio is to create user groups. Each user group is
then assigned a specific report class hierarchy. When creating a user group you can use an
existing user group as a reference. If the referenced user group has existing  report classes or
reports, a dialog box appears asking you if you wish to copy these also.

To create a user group, choose Information system → Report portfolio → User group → Create.

1. Enter a two-character name and a text for the user group.

You can use an existing user group as a reference .

2. Then choose Goto → User grp detail scr.

On the next screen, you define what the hierarchy graphic of the report classes within the
user group should look like.

You must choose a background color, representation form, orientation (whether the
upper node should appear at the top, bottom, left or right side of the window) and size
(whether the graphic should be optimized to fit in the window or whether it should remain
a standard size). The system displays proposal values for the hierarchy graphic. You can
overwrite these by having the possible entries displayed and then choosing values.

3. When you have entered the values save your entries.

In addition to the parameters which you previously defined, you can change many
settings within the hierarchy graphic itself and then save them. You can access the
graphic under: Change user group → Report class overview. You can find more
detailed information on the graphic display under Help in the graphic window.

You can change and display a report class in a similar way. User groups can be printed from
Microsoft Word for Windows. For more information see Printing with Microsoft Word for Windows
in the Report Portfolio [Page 221].

Most users of the report portfolio wish to have their user group displayed automatically, without
having to actually enter it. To do this, enter the appropriate user group in parameter HID in each
user's parameters (System → User profile → Own data).

If you work with various user groups, you can enter the user group you are currently working with
in the report portfolio under menu option Report portfolio → Set user group. This user group is
then automatically called up when you choose Information system → Report portfolio in the
Executive Menu. This setting is stored by the system until you change it, or until you log off the
system. The user group you enter here temporarily overrides any setting made for you in
parameter HID.
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Maintaining Report Classes
You create the structure of report classes in the report portfolio under Information system →
Report portfolio → Report class → Create. If you wish to create a hierarchy for a new user group,
you should create the top report class first and then build the hierarchy from top to bottom.

1. Enter the name of the user group and a description for the new report class.

Here also, you can use an existing report class as a reference.

Choose Goto → Report class overview.

2. On the next screen, a number is automatically assigned to the report class. Here, you
define which color the report class should be displayed in. You also maintain the
structure of the report portfolio, the hierarchical arrangement of the report classes. When
you create the top position in the hierarchy you do not have to specify the position of the
node. If you wish to position a new report class under an existing class, enter the existing
report class number in the field Upper-level report class. If several report classes are
already positioned under a report class, a new report class is positioned at the far right,
as long as the field Right report class remains vacant. If you make an entry in this field,
however, you can specify exactly where the new report class is to be positioned.

3. Save your entries.

You can change and display a report class in a similar way.

4. After you have created some report classes, you should call up the hierarchy graphic
using Report class overview. This shows the structure in graphic form. To change the
display of the graphic, you must access the hierarchy graphic via the user group (see
Maintaining User Groups [Page 202]).

You can print a report class using MS Winword. For more information see Printing with Microsoft
Word for Windows in the Report Portfolio [Page 221].
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Transferring a Report to the Report Portfolio
After you have created user groups and report classes, the third step is to transfer reports to the
report portfolio. You can either copy reports from SAP-EIS drilldown reporting, or copy them from
an external source using SAP-EIS data transfer.

Transferring Reports from Drilldown Reporting
When you transfer a report from drilldown reporting, you can choose to save the Data or the
Structure of the report in the report portfolio.

Reports stored with data are saved (or ‘frozen’) with the data or graphics they contain at the time
of transfer. This means that when you execute the report, the data displayed is exactly the same
as when it was transferred. When you store reports with the structure, the report definition or a
sequence of screens are saved. If new data records are posted to the SAP-EIS database, these
are included when you execute the report in the report portfolio.

Since data can be selected at different points in time, you need to differentiate between two
further cases with structure reports. If no data has been selected, the data is read when you call
up the report. The data can, however, also be selected in the background processing(see
Freezing Report Data and Printing Reports in the Background [Page 186] A scheduled job can
run at regular intervals, for example, every night. From the point of view of performance, it is
advisable to use frozen data, and to only select current data when you need it. To select current
data when calling up a report, choose Extras → New selection.

You can copy both individual screens and screen sequences from drilldown reporting. A screen
sequence can consist of tables, graphics and comments.

The four possible types of report portfolio report are shown in the following figure. They are: the
single screen with frozen data, the single screen with current data, the screen sequence with
frozen data and the screen sequence with current data.

Single screen, Data

Data of 01/20/94
No. of salary earners

Sales
Purchasing
Production

Screen sequence, Data

Data of 01/20/94
No. of salary earners

Sales
Purchasing
Production

Single screen, Structure

Current data
No. of salary earners

Sales
Purchasing
Production

Screen sequence, Structure

Current data
No. of salary earners

Sales
Purchasing
Production
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If you have defined exceptions in a report to be copied, these are also transferred to the report
portfolio. For more information see Exception Reporting in the Report Portfolio [Page 211]

Note that changes made to a drilldown report after the report was copied into the report portfolio
do not have any effect on the report portfolio report. Changes made to a form at a later date are,
however, automatically made in structure reports based on that form. Since data reports always
represent a copy of a list or screen sequence at a particular point in time, changes in the form on
which such reports are based do not have any influence on the data report in the report portfolio.

You can access the transfer functions in the drilldown reports under Report → Export. For more
information see Copying Reports from Drilldown Reporting [Page 206]

Transferring Reports from External Sources
There are two types of report which are transferred from external sources.

•  Data reports with individual screens

With this type of report, a list is copied into the report portfolio. No interactive functions
are supported with these lists.

•  Reports which can be started using the report/report interface

From within the report portfolio you can execute drilldown reports, Report Writer reports
and ABAP/4 programs. By calling up certain ABAP/4 programs (for example,
RKCWINEX) you can also start any PC program you choose.

You copy these into the report portfolio under Report portfolio → Rep.portfolio report →
Transf.other->Portf. For more information see Transferring Data to the Report Portfolio [Page
113].
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Copying Reports from Drilldown Reporting
To copy a drilldown report to the report portfolio, proceed as follows:

1. Choose Report → Export in the report you wish to transfer. A dialog box will appear.
Tick the radio button Transfer to report portfolio

A dialog box appears in which you enter how, and to which part of the report portfolio the
report is to be transferred.

First you enter the Report name. Note that this does not have to be identical to the name
of the original drilldown report.

2. Then specify in which User group, in which Report class, and with which Color the report
is to be stored.

Normally you assign the report to just one user group and one report class. If the report
needs to be accessible by several user groups, you can define this in the report portfolio
(see Maintaining a Report Portfolio Report [Page 208]).

3. Then you define what is to be transferred.

You have to make two important decisions here:

– You can choose between a Single screen and a Screen sequence. If you choose a
Single screen, the list currently displayed is copied to the report portfolio. If you choose a
Screen sequence, the list currently displayed and a desired sequence of functions and
lists is copied.

– Now you still need to specify whether the report should be saved with the data as it is
currently displayed, or if only the structure (definition) should be saved. This very
important distinction is explained in detail in Transferring a Report to the Report Portfolio
[Page 204]

Using the Comment button, you can create a comment which is exported, along with the
report, into the report portfolio. Not only can you display this comment in the report
portfolio but you can update it too (see Maintaining a Report Portfolio Report [Page
208]).

The Report texts button enables you to maintain the descriptive texts for the report. A
dialog box is displayed. Here you can copy the short text using the button Short descr.,
the long text using the Long text button, or you can enter text manually.

4. Then choose Continue.

If you had selected the option Single screen, the current screen will be copied to the
report portfolio automatically. If you had selected the option Screen sequence, you can
now perform several of the interactive functions and thereby ‘record’ them. When you
have created the desired sequence choose menu sequence Report → Export →
Close Copy → rep. portfolio again. A dialog box appears in which you can decide
whether you wish to save the sequence recorded.

Note the following two points concerning the recording of a screen sequence.

− When saving graphics, the first screen of the graphic is saved.

− For many functions you have to specify the parameters in dialog boxes. If, for
example, you wish to sort the list according to a certain column, you must position
the cursor on the relevant column and then specify in a dialog box whether you wish



 SAP AG Executive Information System and Business Planning

Copying Reports from Drilldown Reporting

April 2001 207

to sort in ascending or descending order. When the end user displays the sequence
in the report portfolio, the system does not display any dialog boxes as this is not
relevant. However, it does display a message informing him or her how the column
was sorted.

If you have saved a report in the report portfolio with or without data, you can then edit it. For
more information see Maintaining a Report Portfolio Report [Page 208].



Executive Information System and Business Planning  SAP AG

Maintaining a Report Portfolio Report

208 April 2001

Maintaining a Report Portfolio Report
If you have saved a report with or without data in the report portfolio, you can edit it later under
Information system → Report portfolio → Rep.portfolio report → Change.

We can distinguish between two types of changes:

Changes that affect the report itself and mean that the report will be displayed differently during
execution (see Changing a report and Executing and changing a report).
Changes that affect only the assignment of the report to a report class or to a user group (see
Changing the assignment of a report to a report class).

Changing a Report
If a comment was created during the export of a drilldown report, you can call up the text using
the menu path Extras → Display comment If no comment is maintained for the report you can
create a text using Extras → Maintain comment.

When you execute a definition report containing variables in the report portfolio, , no variables will
be offered for entry (default). The values are automatically taken from the user parameters or
from the drilldown report. Under Extras → Variables you can set other proposal values, or make
the variables ready for input by the user of the report portfolio report.

The functions Report → Execute, Edit → Execute and Change, and Extras → New selection are
available on this screen You can select new data when calling up a definition report, or you can
work with a dataset which was saved previously. The functions Execute + Change and Execute
use the report saved in the background processing (where available), whereas the function New
selection selects the current dataset in every case In the top right corner of the report, the system
displays information about the dataset used (Current data or Data from MM.DD.YY HH:MM:SS).

With the function Extras  → Report assignment, you can change an existing assignment between
the report portfolio and a report, which can be called up using the report-report interface You
define this assignment in the SAP-EIS application menu using the menu path Information system
→ Report portfolio → Report portfolio report → Transf. other -> Portf. For more information see
Transferring Data to the Report Portfolio [Page 113].

The menu sequence Extras → Report texts enables you to maintain the descriptive texts for the
report. A dialog box is displayed. Here you can copy the short text using the button Short descr.,
the long text using the Long text button, or you can enter text manually.

Using the menu path Extras → Layout → Header or Footer, you can create or change headers or
footers for definition reports, or you can copy them from other reports. In addition to normal
texts, you can insert general text variables (for example, report author, date of selection, last
person who made a change), selection parameters (for example, current fiscal period) and
characteristics.

Using the menu path Extras → Layout → Header on/off or Footer on/off, you can turn the
headers and footers created for the report on and off.

It is also possible to delete a report from the function Change. When you want to delete a large
number of reports, it is easiest to do it under Tools→ Drilldown→ Delete report
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Executing and Changing a Report

The function Execute and change is possible for all types of reports except those
which are called up via the report-report interface.

1. On the initial screen you can choose whether you wish to display all the sheets in the report
or only the active ones.

A distinction is necessary because you can hide individual screens within a screen
sequence

2. If you choose menu option Edit → Execute + Change, you can:

− scroll through a sequence of screens (Previous page, Next page),

− display and hide report lists and graphics (Activate screen, Deactivate screen,
Activ.prev.graphic, Deactiv.prev.graphic). This is useful if you record a long
sequence of screens in the drilldown and then decide that some of the screens are
not required. It is not necessary then to transfer the report to the report portfolio once
again. Using the function Deactivate screen, you can change the report in such a
way that  certain screens are suppressed from the end user’s view when he or she
chooses Rep.portfolio report in the Executive Menu Note that it is not always
possible to deactivate a screen. You cannot deactivate the last active screen in a
sequence. Also, in a screen sequence containing graphics at least one report list in
the screen sequence must remain active. The activation and deactivation of graphics
does not occur within the graphics themselves but rather in the subsequent report
list,

−  save changes to settings in 2D and 3D graphics,

−  edit reports which were copied as lists from external sources,

−  maintain the comment for the report here. You do that on the initial screen (see
Change report).

−  create or display a comment for each page. When you use the function Execute
report you can display these comments but not maintain them.

−  create, display, change and delete exceptions as in drilldown reporting. You can
also control which exceptions are relevant for the graphical menu (see Exception
Reporting in the Report Portfolio [Page 211])

•  change the three different Report texts (of differing length) for a report.

When you have made your changes, do not forget to save the report.

Changing the Assignment of a Report to a Report Class
Once you have transferred a report to the report portfolio, it is assigned to a report class and a
user group. You can, however, make the same report available to several user groups or assign
the report to several report classes within a user group. Under menu options Edit → Report
class assignment you can find the functions for doing this Create / Change / Display / Delete.
The functions are similar to those described under Maintaining Report Classes [Page 203]

When you Create an assignment, you can make the new assignment to the same user group or
to a different one. The existing report assignment can be used as a reference.
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When you use Change, Display and Delete, the system issues a list of existing report
assignments. After you have chosen a report assignment, you can perform the desired function.
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Exception Reporting in the Report Portfolio
Exceptions are of importance in two instances in the report portfolio. Firstly they are used to
portray the report lists in color. Secondly they are used to color reports and report classes in the
graphic menu. The procedure for creating exceptions is described in the cross-application online
documentation Drilldown Reporting [Page 211].

Displaying Exceptions in Report Portfolio Reports
The following points should be noted when presenting report lists:

If a report is stored as a data report in the report portfolio, a copy of the drilldown report is saved
simultaneously in the report portfolio. That means that in the report portfolio report the colors are
exactly the same. You see the colors at a certain point in time. These are never updated.

If a report is transferred as a definition report into the report portfolio, the exceptions defined for
the drilldown report are also transferred. These exceptions are then evaluated in the report
portfolio every time new data is selected, just as they would be in drilldown reporting.

Using menu option Report portfolio → Rep. portfolio report → Change, you can create,
change and delete exceptions in the report portfolio report, just as in drilldown reporting (see
below).

Displaying Exceptions in the Hierarchy Graphic
Colors are assigned to reports and report classes in the graphical menu as follows:

Reports and report classes are all assigned default colors which apply if no exception is defined,
or if the exception is in the ”normal” state (has not been exceeded or fallen short of). Red and
green are not valid default colors as these are reserved for values which have either exceeded or
fallen short of an exception. If you use exceptions, we recommend that you use yellow as the
default color. This means that reports and report classes which are in a “normal” state will appear
yellow in the hierarchy graphic. This traffic light effect enables an immediate overview of the
status of the different reports and report classes.

An important difference between displaying exceptions in the graphical menu and in a report list
is that the exceptions have to be evaluated before the report is executed. In a report list, the
exceptions can, of course, be evaluated when you execute the report. When you display a
graphical overview of several reports in the hierarchy graphic, you have not yet executed the
reports. It is not possible to evaluate the exceptions in all the reports when you display the
graphical menu. This is because of the effect it would have on performance The exceptions can
be evaluated using a job which saves the data in background processing. The flag Check
exceptions, which can be found under Information system → Report data → Maintain variants
controls whether the exceptions should be evaluated in background processing. See Freezing
Report Data and Printing Reports in the Background [Page 186]

Using Information system → Report portfolio → Rep.portfolio report → Change, you can
change exceptions in a report. Using this function, you also define which exceptions are relevant
for the graphical menu. The dialog box in which you process the exceptions contains the function
Graphical menu. This function offers three options: Display red and green, Not to be used and
Display red. The default setting is Display red and green, which means that the exception is
highlighted in the graphic whether it is red or green. If more than one exception has been
defined, red has priority over green which has priority over normal.
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Let us assume that a report was created with three exceptions and then executed in the
background. The first exception was in the state green, the second normal, and the third red. The
date and time when the exceptions were evaluated is also recorded.

If, in the above example, we set parameter Display red and green for the first exception and
parameter Not to be used for the second and third exceptions, the report would appear green in
the graphical menu.

The color of the definition report in the graphic is passed on to the report class to which the report
belongs. That means that, if just one of the reports in a report class is red, the whole report class
is colored red.

Evaluation of the Exceptions with Different Combinations of Variables
A closer look is required when the exceptions for a report with variables are evaluated in
the background. It is possible, with such reports, that for one variable group several
combinations of variables are checked one after the other.

You have defined fiscal year and region as variables and want to check the
exceptions for

a. )  fiscal year 1995, region North and

b.)  fiscal year 1996, region South.

.

In the first case the report is in the “red” state, but in the second it is in the “green”
state. The color with the highest priority in the hierarchy graphic is displayed for you
in the report portfolio, in this case ”red”. (The rule is that red takes priority over
green and normal).

When you execute the report a dialog window appears for the variable entry. With the function
Variable (Exception), the respective variable combination, which is responsible for the coloring of
the hierarchy graphic, is set in the entry fields. In our example therefore, the Fiscal Year 1995
and Region North are set as variables.

Display Exceptions
If you choose the menu option Display exceptions in the report portfolio report, information about
the last time the exceptions were evaluated in background processing is displayed. The list
contains the date and time  as well as a color for each exception. You can therefore see which
exceptions have led to which color in the hierarchy graphic.

You can find more detailed information about the state of an exception under Extras → Report
parameters. Here you can see on which sheet of the report an exception has a certain state.
When, for example, you have an exception which is of importance on various sheets of a report
you can see that the state varies. It could be green on sheet 1, normal on sheet 2, and red on
sheet 3.
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Changes That Have an Effect on the Report Portfolio
Report
A report portfolio report, that is recorded from a drilldown report at a certain point in time, can be
saved either with or without data.

A report portfolio report, that is saved with data is not affected by changes to either the data basis
or drilldown reporting. As data reports always display a copy of a list or screen sequence at a
certain point in time, changes do not have an affect on the data report in the report portfolio.

A report, whose definition has been set in the report portfolio, contains the corresponding report
components, meaning characteristics, key figures, form, variables, columns etc.; that you defined
at the time. The data itself is selected in the report portfolio. If you change a sub-object in the
databasis or in the form, which is referred to in the definition, the affected report portfolio report is
automatically adjusted in as far as is possible. However, you can undertake changes, that make
it necessary to adjust the report manually. If such a situation should occur, the system will
produce the relevant message when executing the report portfolio report. You always have the
possibility of deleting the report and recording anew in drilldown reporting. Other possibilities are
listed below.

The following section describes the changes that cannot be automatically converted by the
system. Before you undertake such changes in your EIS system, you should bear in mind the
possible effects on already existing report portfolio reports.

Change Description
Effect on report portfolio
report Solution

Delete
characteristic

You delete at least
one characteristic
from the affected
aspect.

The characteristic(s) is/are no
longer available for the report.
The data for these
characteristics can no longer
be evaluated.

You recreate the
characteristic(s) in
the databasis.

Delete key
figure

You delete at least
one basic or
calculated key figure
from the affected
aspect.

The key figure(s) is/are no
longer available for the report.
The data for these key figures
can no longer be evaluated.

You recreate the key
figure(s) in the
databasis.

No free
characteristic
available in
the form

You provide all the
characteristics in your
form with a value.

The characteristics are no
longer available for the
characteristic selection. In
order to be able to execute a
report at least one free
characteristic must be
available.

You change the
form in such a way
that at least one
characteristic is not
specified or only as
an interval.

Specify free
characteristic
in the general
data
selections

You provide one
characteristic in your
form with a value.

If your report contains, for
example, a drilldown according
to this free characteristic, the
drilldown is no longer possible.

Undo the changes in
the form.
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Delete global
variable

You delete a global
variable

The variable is no longer
available for the report.

Recreate the
variable.

Change
global or local
variable

You change the
setting for a variable
from optional to
mandatory entry.

When executing the report, the
system expects a previous
entry that is not available as
the variable was optional up
until now.

Change the report
portfolio report.
Enter a default value
for the variable or
highlight the
indicator Enter when
executing.

Delete
rows/column
in the form

You delete a row or
column in the form.

If your report uses the affected
row or column for a function,
e.g. for a graphic; this function
is no longer possible here.

In this case, delete
the report and
create a new report
portfolio report.

Hide row or
column in the
form

You hide a row or
column in the form.

If your report uses the affected
row or column for a function,
e.g. for a graphic; this function
is no longer possible here.

Switch the row or
column back on in
the form.

Delete
hierarchy

You delete a master
data hierarchy

The master data hierarchy that
was used in the report, is no
longer available.

You recreate the
master data
hierarchy.

Create new
hierarchy

You have created
one or more new
hierarchies for a
characteristic with a
mandatory hierarchy.

Some characteristics from
other applications can have a
so-called mandatory hierarchy.
This setting means that only
this hierarchy is permitted for
the characteristic. A single
hierarchy exists at the time of
the definition of the report. The
report does not now have an
unequivocal assignment to a
mandatory hierarchy.

In this case, delete
the report and
create a new report
portfolio report.
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Using the Executive Menu
The Executive menu is intended for users who require quick access to information especially
prepared for them.

Going from this menu, you have three different access possibilities to a selection of reports.

•  Using Info system → Report portfolio, you call up the hierarchy graphic defined for you
for access to your own report portfolio. You can find details on the report portfolio and
how you can display reports from there in the section Executing the Report Portfolio
using the Hierarchy Graphic [Page 216] .

•  Using Info system → Report portfolio report, you can enter the name of an individual
report portfolio report and display it. You find out how to display a report in the section
Executing A Report Portfolio Report Directly [Page 218] .

•  Using Info system → Report selection, you call up either the general report tree of
drilldown reports or one especially created for you. You can find out how to execute a
report from there in the section Selecting a Report [Page 180] .
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Executing the Report Portfolio using the Hierarchy
Graphic

List

List Graphic Comment

News

Markets Profit

Finances Sales

Human R.

Individual
structure
of the report
portfolio

Reports

Elements
of a
report

In the figure above you can see an example of a user group, which is represented in hierarchy
graphic form. The hierarchy contains the names of report classes in the relevant user group. The
report classes contain the reports assigned to them. Examples of report classes are: Profit,
Finances, News.  The report classes contain their assigned reports and elements such as lists
of graphics. Default colors are assigned to the reports and report classes.

A report can contain one or more so-called exceptions. An exception is a condition that
determines whether a object is striking, meaning whether unexpectedly high or low values
appear with respect to a key figure. If one or more exceptions are determined by the system, a
report or report class can automatically be colored red or green accordingly. In this example, the
report class Market appears in the default color yellow. For more information see Exception
Reporting in the Report Portfolio [Page 211].

In order to display a report in your report portfolio proceed as follows:

1. Select Info system → Report portfolio.

The hierarchy graphic of the report class in your user group is displayed.
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Note that when you choose the function Report portfolio, the graphic is usually
displayed immediately. You will only be asked to enter your user group if this has
not been set.

2. Choose a report class by clicking on it with the left mouse button.

The system displays an overview of all the reports assigned to that class in the form of a
graphic.

3. hoose the report you require by clicking once on it with the left mouse button.

It is possible that a dialog window will appear before you see the first report list. You can
transfer the suggested values for the variables or enter your own values in this dialog
window. These are normally variables for characteristic values (for example, fiscal year
1996), which determine the dimensions of the report. Text variables can also be offered.
You can enter a text here which is displayed in the report list. Furthermore, there are
variables for hierarchies, hierarchy nodes and formulas.

If exceptions are defined for the report, it is possible that the key Variable (Exception) is
offered in the dialog window. Via this function the combination of characteristic values in
the entry fields, which is responsible for the coloring of the hierarchy graphic, is
presented to you.
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Executing A Report Portfolio Report Directly
You can display a report in the report portfolio without using the graphical menu. Proceed as
follows:

1. Choose Information system → Rep.portfolio report.

2. Enter a report name by entering a name directly or by choosing one from the possible
entries (F4).

3. Choose Execute.

If data has been saved in a report structure  in background processing, the saved
data is automatically displayed when you call up the report from the hierarchy
graphic or using direct call up (see Transferring a Report to the Report Portfolio
[Page 204]).

It is possible that a dialog window will appear before you see the first report list. You can transfer
the suggested values for the variables or enter your own values in this dialog window. These are
normally variables for characteristic values (for example, fiscal year 1996), which determine the
dimensions of the report. Text variables can also be offered. You can enter a text here which is
displayed in the report list. Furthermore, there are variables for hierarchies, hierarchy nodes and
formulas.
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Functions in a Report Portfolio
The functions which are available when you execute a report portfolio report depend on the type
of report. If you access a report which is started using the report/report interface, you can use the
functions which are available in the program started. If you start an ABAP/4 program which calls
up a PC program, you can use the functions of the PC program (for example, Microsoft Word or
Microsoft Excel). If you call up a drill-down report which has been copied from EIS drill-down
reporting, the following functions are available:

•  Using the function Previous page and Next page, you can scroll through the sequence of
pages in the report.

•  Using Display comment, you can display the comments stored for individual pages by the
user who created the report.

•  Using Display exceptions, you can display the settings made for individual exceptions.

•  Under Report parameters, the system displays the most important information about the
report (author, date created, etc.). In addition here you can find out the condition of a
certain exception on a particular sheet of a report.

•  Using the function Print, you can print the report page displayed. To print from Microsoft
Word for Windows, read Printing with Microsoft Word for Windows in the Report Portfolio
[Page 221].

•  Using Send, you can send the displayed report page to another user via the SAPmail
system.

•  Choose Back to leave the report. If you accessed the report from the report class
overview, you will return to the hierarchy graphic. You will then be on the screen which
displays all reports for a report class. By choosing the report class, you access the
overview of all report classes. If you choose Back again, you return to the hierarchy
graphic.

If no data is available for a characteristic value contained in the definition report at
the time of execution of the report portfolio report or there is no saved data
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available in the background processing, you may not be able to use functions
based on this characteristic value. You will be able to carry out the functions again
when data is selected for that characteristic value.
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Printing with Microsoft Word for Windows in the Report
Portfolio

To use the functions described here, you must have an English, German or French version of
Microsoft Word for Windows version 6.0 installed. These print functions are only active under
operating systems Windows and Windows NT.

You set up the interface to Microsoft Word for Windows in Customizing. The guidelines tell you
how to carry out the installation.

In the report portfolio, you can use this function when you execute a report with the function
Rep.portfolio report. It is also possible to print report classes and user groups.

You can print all those reports in Microsoft Word which are not called up using the
report/report interface.

If you print a report class or user group which contains a report that is accessed via
the report/report interface, this report will not be printed.

The following section describes how you print a report.

1. Choose Print in MS Winword.

First of all you get a dialog box, in which you can make various settings.

– Contents page

– Cover page

– Chapter number(s)

– Page numbers

– Only printing

.If you select this field, the system will automatically format and print the Microsoft
Word document without displaying it. If you choose the other option, system will
display the Microsoft Word document for you to edit. Once you have made the
desired changes, you can print it manually.

– Interactive printing

If you do not wish to save the document in the default file but rather in another file,
maintain Settings for interactive print functions.

Then all the active pages and any comments are collected. All graphics, with the
exception of portfolio graphics, are also collected. These components, which are referred
to as print modules, are transferred to Microsoft Word.

2. If the report contains variables a dialog box appears. Enter the corresponding characteristic
values.

3. In the next dialog box, you can make various settings. The system automatically divides the
print modules into chapters. Here, you can change the dynamic chapter headers and sort the
chapters. In addition, you can also set whether a new page should be started for a new print
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module. You can then save these settings, which means that the next time you use the
function for the same object, you can use the same settings.

By choosing Additional settings, you can make settings for the print modules. You can
also save these settings.

If you wish to change the standard layout, you can create a Microsoft Word macro for
each print module. If you only wish to change the layout for one printout, you can do this
when you edit the document (see above). If, on the other hand, you want to print the
report many times, each time with the changed layout, you should use a macro.

When you print a report class, the system first looks for all the reports which belong to the report
class. The procedure after that is the same as that for printing a single report.

Likewise, the system collects all the report classes and reports for a user group.

Please see Example of Printing a Report from Microsoft Word [Page 223].
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Example of Printing a Report from Microsoft Word
The following figure represents an example of a report portfolio report, transferred from Microsoft
Word for Windows 6.0. The report portfolio report Divisions is made up of two lists, one for each
division, a comment on the entire report and a comment on one of the lists. If the settings Cover
sheet, Chapter numbers and Page numbers have been chosen for the transfer to MS Word, the
report will be printed in the format you see in the example. The first three sheets contain the
Cover sheet, Table of Contents and comment on the entire report respectively.

Report portfolio

Report:  Divisions

Report:  Divisions

Comment for report:

Comment: The last ...

The last year saw a definite increase
in the sales revenue of all divisions

Comment on Pharm.
Division Pharm. ...

Division:   Pharm.

Division:   Plastics

Region

Region

NE

NE

NW

N W

Sales qty.

Sales qty.
5400

2400

300

700

Gross rev.

Gross rev.

1700

3000

2800

1200

MS Word

Divisions
Coversheet

ContentsChap. 1

Chap. 1

Chap. 1.1
Chap. 1.2

Division:

Division:

Region

Region

NE

NE

NW

NW

Division Pharm. ...

Pharm.

Plastics
Plastics

Pharm.
Chap. 1.1

Chap. 1.2
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Tools (EC-EIS/EC-BP)
Purpose
This component contains functions that the system administration executes in a productive
system, for example, reorganization in the information system or archiving of transaction data
and plan data. You can find more details under:

Translating Texts [Page 225]

Reorganization in the Information System (EC-EIS) [Page 227]

Archiving [Page 229].
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Translating Texts
Under Tools → Translation tool, you can translate user-defined or user-generated EC-EIS and
EC-BP-specific texts, which are language dependent, into another language. This is necessary if
these texts are to be used in the other language, for example in a report,. You can find and
translate these texts directly in your system using the translation tool. To do this, proceed as
follows:

1. Enter the source and target languages.

2. Select the object type you wish to translate and enter the name of the object.

3. Choose option Selected object only or Object + all dependent objects.

 If you choose Selected object only, the system searches for the texts belonging to that
object only. If you enter an aspect, for example, the system searches for the aspect texts
only.

 If you choose Object + all dependent objects, the system searches for all subobjects
which can be assigned to this object. For example, if you enter an aspect, the system
searches not only for the aspect texts but also for the for the key figure texts, the
characteristic texts and the characteristic value texts belonging to the aspect.

  
 The system may take some time to search, especially if you choose Object + all
dependent objects, as it may have to search many EC-EIS objects for texts.

 On the following screen, the system displays a list of the object classes found. These classes are
listed according to their translation status:

 not translated  no objects of this class are translated

 partly translated  some objects of this class are translated

 translated  all objects of this class are translated

  (objects of this class are also highlighted)

1. Select the object classes that you wish to translate. Choose Object list.

 In the object list, all the objects in the object classes you selected are displayed with the
object class, the name and the text of the object in the source language. For translated
objects, the text of the object in the target language also appears.

2. Select the objects you wish to process.

 If you wish to change the target text of an object which has already been translated,
choose this object also.

3. Choose option Translate or Fast translation.

 If you choose option Fast translation, the system attempts to find proposals from the SAP
proposal pool. If it finds a proposal, the proposal is entered automatically. If the system
cannot find a proposal, the text in the source language is copied to the text in the target
language. This option is only available for texts which have not been translated.

 If you choose option Translate, you can enter translations for all the selected objects
yourself.
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4. If you chose Translate, the selected objects are displayed on the next screen. Attempt to
find proposals for the texts by choosing Get proposals. If no proposal exists for a text,
enter the translation in the field beneath the source text.

5. Save your entries.
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Reorganization in the Information System ( EC-EIS)
Deleting report data
The report data is the data that has been saved for a drilldown report or report portfolio report at
a certain time. If you delete this data, the corresponding report remains intact. The next time you
call up the report, the system selects new data for the report.

If you no longer require certain report data, you can delete it under Tools → Information system
→ Delete report data. Proceed as follows:

1. Specify the report data you wish to delete (for example, all report data saved by the user
Smith). Choose Execute.

 The system displays a list of the objects you selected.

2. Select the objects to be deleted and choose Delete.

The system then displays the status of the objects.

Deleting reports
You can delete individual drilldown reports under Information system → Report → Change. You
can also delete individual report portfolio reports under Information system → Report portfolio →
Report portfolio report → Change. However, if you wish to delete several reports, you should do
this under Tools → Information system → Delete reports. Proceed as follows:

1. Specify the reports you wish to delete (for example, all reports which are based on a certain
form). Choose Execute.

The system displays a list of the objects you selected.

2. Select the objects to be deleted and choose Delete.

The system then displays the status of the objects.

Deleting forms
You can only delete a form if it is no longer used in any report. If you select a form to be deleted,
the system checks whether the form is still being used in any report. If it is, the system will not
delete the form.

If you no longer require certain forms, choose Tools → Information system → Delete forms.
Proceed as follows:

1. Specify the forms to be deleted (for example, all single coordinate forms in a certain
aspect). Choose Execute.

 The system displays a list of the objects you selected.

2. Select the objects to be deleted and choose Delete.

The system then displays the status of the objects. If there are reports that still use a
form you have selected to be deleted, the form is flagged with status Not deleted and the
message Object is still being used. You can select the form to display a list of the reports
based on that form. From here you can execute these reports and delete them if
appropriate.
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Archiving
Use
The transaction data, that is transferred or posted into the executive information system or into
business planning, can be reorganized using an archiving program.

The following functions are available for archiving:

•  Storing the transaction data or plan data

•  Deleting the transaction data or plan data

•  Reloading the transaction data or plan data from the archive

With the appropriate authorization, you can call up archiving in the EC-EIS application menu
under Tools → Data → Archive trans. data. You can call it up in the EC-BP application menu
under Tools → Data → Archive plan data

The above functions are described in detail in the documentation on archiving and deleting
application data: Archiving transaction data/plan data (EC-EIS/EC-BP) [Ext.]


