## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🚨</td>
<td>Caution</td>
</tr>
<tr>
<td>📣</td>
<td>Example</td>
</tr>
<tr>
<td>📚</td>
<td>Note</td>
</tr>
<tr>
<td>🌟</td>
<td>Recommendation</td>
</tr>
<tr>
<td>🌟</td>
<td>Syntax</td>
</tr>
</tbody>
</table>
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Product Safety (EHS-SAF)</strong></td>
<td>12</td>
</tr>
<tr>
<td><strong>Product Safety (EHS-SAF)</strong></td>
<td>13</td>
</tr>
<tr>
<td><strong>Substance Management</strong></td>
<td>16</td>
</tr>
<tr>
<td>Substance Management: Process</td>
<td>17</td>
</tr>
<tr>
<td>Maintaining Substance Data: An Example</td>
<td>20</td>
</tr>
<tr>
<td>Function Model of Substance Management</td>
<td>21</td>
</tr>
<tr>
<td>Substance</td>
<td>22</td>
</tr>
<tr>
<td>Substance Search</td>
<td>23</td>
</tr>
<tr>
<td>Engineering Change Management for Substances</td>
<td>25</td>
</tr>
<tr>
<td>Substance Reference</td>
<td>26</td>
</tr>
<tr>
<td>Substance Category</td>
<td>28</td>
</tr>
<tr>
<td>Substance Identification</td>
<td>29</td>
</tr>
<tr>
<td>Substance Lists</td>
<td>31</td>
</tr>
<tr>
<td>Material Assignment</td>
<td>32</td>
</tr>
<tr>
<td>Substance Characteristic Values</td>
<td>34</td>
</tr>
<tr>
<td>Setting up Substance Characteristic Categories and Characteristics</td>
<td>36</td>
</tr>
<tr>
<td>Substance Characteristic Type Substance Property</td>
<td>38</td>
</tr>
<tr>
<td>Substance Characteristic Type Substance Composition</td>
<td>39</td>
</tr>
<tr>
<td>Substance Characteristic Type Substance Listing</td>
<td>40</td>
</tr>
<tr>
<td>Substance Characteristic Categories: Example</td>
<td>41</td>
</tr>
<tr>
<td>Assessments</td>
<td>42</td>
</tr>
<tr>
<td>Sources</td>
<td>43</td>
</tr>
<tr>
<td>User-Defined Texts</td>
<td>44</td>
</tr>
<tr>
<td>Usage</td>
<td>46</td>
</tr>
<tr>
<td>Relevance Indicator</td>
<td>48</td>
</tr>
<tr>
<td>Component Overview</td>
<td>49</td>
</tr>
<tr>
<td>Determination of Secondary Data</td>
<td>50</td>
</tr>
<tr>
<td>Notification Status</td>
<td>51</td>
</tr>
<tr>
<td>Notification Status Values</td>
<td>53</td>
</tr>
<tr>
<td>Determination of Notification Status for Compositions</td>
<td>54</td>
</tr>
<tr>
<td>Example: Determination of Listed Substances</td>
<td>55</td>
</tr>
<tr>
<td>Example: Derivation of List and Component Notification</td>
<td>56</td>
</tr>
<tr>
<td>Determination of Notification Status</td>
<td>57</td>
</tr>
<tr>
<td>Checking the Notification Status</td>
<td>59</td>
</tr>
<tr>
<td>Source Management</td>
<td>60</td>
</tr>
<tr>
<td>Editing Sources</td>
<td>61</td>
</tr>
<tr>
<td>Substance List Management</td>
<td>62</td>
</tr>
<tr>
<td>Processing Substance Lists</td>
<td>63</td>
</tr>
<tr>
<td>Data Origin</td>
<td>64</td>
</tr>
<tr>
<td>Data Owner/Provider</td>
<td>65</td>
</tr>
<tr>
<td>Data Provider and Data Origin: An Example</td>
<td>66</td>
</tr>
<tr>
<td>Substance Management: Procedures</td>
<td>67</td>
</tr>
</tbody>
</table>
# Phrase Management

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Searching for Phrases</td>
<td>91</td>
</tr>
<tr>
<td>Creating Phrases</td>
<td>92</td>
</tr>
<tr>
<td>Editing Phrase Items</td>
<td>93</td>
</tr>
<tr>
<td>Copying Phrases</td>
<td>94</td>
</tr>
<tr>
<td>Editing the Phrase Header</td>
<td>95</td>
</tr>
<tr>
<td>Editing the Phrase Hit List</td>
<td>96</td>
</tr>
<tr>
<td>Copying Substance Data</td>
<td>97</td>
</tr>
<tr>
<td>Editing Substance Characteristic Values</td>
<td>98</td>
</tr>
<tr>
<td>Searching for Phrases in Characteristic Fields</td>
<td>99</td>
</tr>
<tr>
<td>Editing the Input Help</td>
<td>100</td>
</tr>
<tr>
<td>Editing Assessments</td>
<td>101</td>
</tr>
<tr>
<td>Assigning Substance Lists</td>
<td>102</td>
</tr>
<tr>
<td>Assigning Materials</td>
<td>103</td>
</tr>
<tr>
<td>Using the Properties Tree</td>
<td>104</td>
</tr>
<tr>
<td>Editing Substance Characteristic Values</td>
<td>105</td>
</tr>
<tr>
<td>Searching for Phrases in Characteristic Fields</td>
<td>106</td>
</tr>
<tr>
<td>Editing User-Defined Texts</td>
<td>107</td>
</tr>
<tr>
<td>Processing Usages</td>
<td>108</td>
</tr>
<tr>
<td>Processing the Component Overview</td>
<td>109</td>
</tr>
<tr>
<td>Phrase Assignment</td>
<td>110</td>
</tr>
<tr>
<td>Function Model for Phrase Set Management</td>
<td>111</td>
</tr>
<tr>
<td>Phrase set management</td>
<td>112</td>
</tr>
<tr>
<td>Phrase Deletion</td>
<td>113</td>
</tr>
<tr>
<td>Creating Phrases</td>
<td>114</td>
</tr>
<tr>
<td>Editing the Phrase Hit List</td>
<td>115</td>
</tr>
<tr>
<td>Editing the Phrase Header</td>
<td>116</td>
</tr>
<tr>
<td>Editing Phrase Items</td>
<td>117</td>
</tr>
<tr>
<td>Copying Phrases</td>
<td>118</td>
</tr>
<tr>
<td>Editing Phrase Items</td>
<td>119</td>
</tr>
<tr>
<td>Editing Phrase Items</td>
<td>120</td>
</tr>
<tr>
<td>Copying Phrases</td>
<td>121</td>
</tr>
<tr>
<td>Editing Phrase Items</td>
<td>122</td>
</tr>
<tr>
<td>Editing Phrase Items</td>
<td>123</td>
</tr>
</tbody>
</table>
Editing the Language Selection ..........................................................................................124
Assigning Phrase Sets ........................................................................................................125
Merging Phrases .................................................................................................................126
Combining Phrases .............................................................................................................128
Displaying Phrase History ..................................................................................................129
Creating Where-Used Lists for Phrases .............................................................................130
Searching for Phrase Sets .................................................................................................131
Creating Phrase Sets ..........................................................................................................132
Processing the Phrase Set Hit List ....................................................................................133
Processing the Phrase Set Header .....................................................................................134
Copying Phrase Sets ..........................................................................................................135
Maintaining Phrase Set Descriptions ..................................................................................136
Assigning Phrases to a Phrase Set .....................................................................................137
Assigning Phrase Sets to Characteristics ..........................................................................138
Master Data Adjustment....................................................................................................139
Generating Symbols ..........................................................................................................141
Adjusting Characteristic Categories and Characteristics ..................................................142
Adjusting Symbols and Phrase-Related Characteristics ..................................................143
Report Generation .......................................................................................................................144
Report Generation: Process .................................................................................................145
Maintaining Document Templates ......................................................................................146
Document Templates: Procedures .........................................................................................148
Searching for Document Templates .....................................................................................149
Creating Document Templates ............................................................................................150
Processing the Document Template Hit List .........................................................................151
Processing Document Template Headers .............................................................................152
Copying Document Templates .............................................................................................153
Assigning Labels to Document Templates .............................................................................154
Starting and Closing WWI ...................................................................................................155
Basic Functions in the Hit List .............................................................................................157
Maintaining Document Template Layouts ............................................................................159
WWI: Procedures ..................................................................................................................162
Inserting Static Objects Using Word Functions .....................................................................163
WWI: Using the Symbol Bar ................................................................................................164
WWI: Using Special Keyboard Shortcuts .............................................................................165
WWI: Processing Basic Settings ..........................................................................................166
WWI: Selecting Display Mode .............................................................................................168
Selecting Methods for Entering Data ..................................................................................169
WWI: Inserting Phrases ........................................................................................................171
WWI: Inserting Symbols .......................................................................................................173
Bar code ..............................................................................................................................175
Expansion Mode .................................................................................................................176
Template ..............................................................................................................................177
Function Module ..................................................................................................................179
Symbols - Example .............................................................................................................180
WWI: Inserting Repeating Groups ................................................................. 182
Repeating Groups - Examples ............................................................................. 184
Example: Creating a Table of Contents ................................................................. 187
Example: Repeating Group S:CLASS ................................................................. 189
WWI: Blank Compression ..................................................................................... 190
Blank Compression - Example ............................................................................ 191
WWI: Using Wizard ............................................................................................. 192
Generating Headings .......................................................................................... 193
Generating Symbols in 3-Column Tables ............................................................ 194
Generating Symbols from Substance Characteristic Categories ......................... 196
WWI: Using Conditioned Text ............................................................................. 199
Conditioned Text - Example .............................................................................. 200
WWI: Character Sizing ....................................................................................... 201
Character Sizing - Example ................................................................................ 202
WWI: Checking Templates .................................................................................. 203
Maintaining Generation Variants ....................................................................... 204
Generation Variants: Procedures ........................................................................ 206
Searching for Generation Variants ..................................................................... 207
Creating Generation Variants ............................................................................ 208
Processing the Generation Variant Hit List ......................................................... 209
Processing the Generation Variant Header ........................................................... 210
Assigning Labels to Generation Variants ............................................................. 211
Processing Ratings and Validity Areas for Generation Variants ......................... 212
Document Types in Substance Reporting ............................................................ 213
Report Template (SBV) ..................................................................................... 214
Reports (SBR) ..................................................................................................... 215
Final Report (SBE) .............................................................................................. 216
Cover Sheet Template (DBV) ............................................................................. 217
Inbound Documents (IBD) .................................................................................. 218
WWI (Windows Word Processor Integration) ......................................................... 219
Expansion fence .................................................................................................. 220
Report Creation Procedure .................................................................................. 221
Document Template Objects ............................................................................. 222
Symbols ............................................................................................................... 223
Symbol Type Phrase ............................................................................................ 224
Symbol Type Symbol ........................................................................................... 225
Symbol Type Parameter ....................................................................................... 227
Layout of an Abridged Material Safety Data Sheet: An Example ......................... 228
Expanded Report Template: An Example ............................................................ 229
Note on the Example .......................................................................................... 232
Notes on Section A ............................................................................................. 233
Notes on Section B ............................................................................................. 234
Notes on Section C ............................................................................................. 235
Notes on Section D ............................................................................................. 236
Notes on Section E ............................................................................................. 237
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material Name, Material Number</td>
<td>312</td>
</tr>
<tr>
<td>Subsequent Shipping</td>
<td>313</td>
</tr>
<tr>
<td>Manual Report Shipping</td>
<td>315</td>
</tr>
<tr>
<td>Creating Report Shipping Orders Manually</td>
<td>316</td>
</tr>
<tr>
<td>Bundling Report Shipping Orders</td>
<td>318</td>
</tr>
<tr>
<td>Generating Reports</td>
<td>320</td>
</tr>
<tr>
<td>Packing Shipping Order Bundles</td>
<td>321</td>
</tr>
<tr>
<td>Shipping Order Packages</td>
<td>323</td>
</tr>
<tr>
<td>Saving Report Shipping Orders</td>
<td>326</td>
</tr>
<tr>
<td>Processing the Report Shipping Log</td>
<td>328</td>
</tr>
<tr>
<td>Processing Report Shipping Orders</td>
<td>330</td>
</tr>
<tr>
<td>Processing Report Shipping Order Headers</td>
<td>332</td>
</tr>
<tr>
<td>Maintaining the Addresses of Report Recipients</td>
<td>333</td>
</tr>
<tr>
<td>Maintaining the Internet Address of a Customer</td>
<td>334</td>
</tr>
<tr>
<td>Substance / Report Information System</td>
<td>335</td>
</tr>
<tr>
<td>Substance Information System</td>
<td>336</td>
</tr>
<tr>
<td>Accessing the Substance Information System</td>
<td>337</td>
</tr>
<tr>
<td>Displaying Properties</td>
<td>338</td>
</tr>
<tr>
<td>Displaying Compositions/Constituents</td>
<td>341</td>
</tr>
<tr>
<td>Report Information System</td>
<td>343</td>
</tr>
<tr>
<td>Using the Report Information System</td>
<td>345</td>
</tr>
<tr>
<td>Interfaces</td>
<td>346</td>
</tr>
<tr>
<td>Import and Export: Process</td>
<td>348</td>
</tr>
<tr>
<td>Import: Process</td>
<td>350</td>
</tr>
<tr>
<td>Identifying Relevant Fields</td>
<td>352</td>
</tr>
<tr>
<td>Table Assignment: Phrases</td>
<td>354</td>
</tr>
<tr>
<td>Data for the Phrase Library</td>
<td>355</td>
</tr>
<tr>
<td>Phrase Group Data</td>
<td>356</td>
</tr>
<tr>
<td>Further Phrase Data</td>
<td>357</td>
</tr>
<tr>
<td>Table Assignment: Sources</td>
<td>359</td>
</tr>
<tr>
<td>Table Assignment: Substances</td>
<td>360</td>
</tr>
<tr>
<td>Substance Header Data</td>
<td>361</td>
</tr>
<tr>
<td>Substance Identification</td>
<td>362</td>
</tr>
<tr>
<td>Additional Information for Substance Identifier - Substance List Allocation</td>
<td>363</td>
</tr>
<tr>
<td>Substance References</td>
<td>364</td>
</tr>
<tr>
<td>Additional Information for Identifiers</td>
<td>365</td>
</tr>
<tr>
<td>Substance - Material Assignment</td>
<td>366</td>
</tr>
<tr>
<td>Substance Characteristic Values</td>
<td>367</td>
</tr>
<tr>
<td>Additional Information for Substance Characteristic Assessment</td>
<td>368</td>
</tr>
<tr>
<td>Additional Information for Substance Characteristic Usage</td>
<td>369</td>
</tr>
<tr>
<td>Additional Information for Substance Characteristic Sources</td>
<td>370</td>
</tr>
<tr>
<td>Additional Information for Substance Characteristic Texts</td>
<td>371</td>
</tr>
<tr>
<td>Additional Information for Substance Characteristic Items</td>
<td>372</td>
</tr>
<tr>
<td>Transport Approval</td>
<td>373</td>
</tr>
<tr>
<td>Packaging Code Approval</td>
<td>374</td>
</tr>
</tbody>
</table>
Risk Classification ................................................................. 375
Transport Classification ......................................................... 376
Table Assignment: Properties Tree ........................................ 377
Properties Tree ...................................................................... 378
Substance Characteristic Values ............................................ 379
Class .................................................................................. 380
Characteristics ..................................................................... 381
Phrase Sets .......................................................................... 382
Table Assignment: Report Template ...................................... 383
Report Template Header ....................................................... 384
Labels ................................................................................. 385
Report Symbols .................................................................... 386
Specifying the Sequence of the External Data Structure .......... 387
Structure of External File: Phrase Data .................................... 388
Structure of External File: Source .......................................... 389
Structure of External File: Substances ..................................... 390
Structure of External File: Properties Tree .............................. 391
Structure of External File: Report Templates .......................... 392
Abbreviations and Syntax Rules ............................................. 393
Syntax for a Characteristic Line ............................................. 395
Structure of Programming Lines ............................................ 396
Example: Transfer File for Phrases ........................................ 397
Example: Transfer File for Sources ......................................... 400
Example: Transfer File for Substances ................................. 402
Example: Transfer File for a Properties Tree .......................... 406
Example: Transfer File for a Report Template ....................... 414
Source Import ....................................................................... 416
Importing Sources ............................................................... 417
Importing Phrases ............................................................... 419
Checking Files during Phrase Import ....................................... 421
Importing Phrases ............................................................... 422
Importing Substances .......................................................... 424
Checking Files during Substance Import ................................ 426
Controlling Substance Import ............................................... 428
Assigning Substances Manually during Substance Import ........ 430
Importing Substance Identifiers ............................................ 431
Error Handling during Substance Import .............................. 432
Importing Substances .......................................................... 433
Properties Tree Import .......................................................... 435
Importing Properties Trees ................................................... 437
Report Template Import ........................................................ 439
Importing Report Templates .................................................. 440
Importing Reports: Process ................................................... 442
Importing Dok-X-SDB Reports ............................................... 445
Export: Process ................................................................. 446
Exporting Sources, Phrases and Substances ...............................................................448
  Exporting Sources .....................................................................................................450
  Exporting Phrases .................................................................................................451
  Exporting Substances.........................................................................................452
Properties Tree Export...........................................................................................453
  Exporting Properties Trees.................................................................................454
Report Template Export.......................................................................................455
  Exporting Report Templates..............................................................................456
Exporting Reports: Process ..................................................................................457
  Exporting Reports Manually................................................................................461
Product Safety (EHS-SAF)
Product Safety (EHS-SAF)

Purpose

This component contains the functions that you require in the following areas:

- **Substance Management [Page 17]**

  All environmentally-relevant information for pure substances, preparations, mixtures and recycled materials are managed under the general term **substance**. In substance management, you define and manage data and text information for substances. Data for substance identification, material allocations, compositions, substance listings, and substance properties are included in this area.

  The R/3 System enables you to maintain substance lists and sources in productive systems **(See also: Substance List Management [Page 62] and Source Management [Page 60])**.

  You can record data for dangerous goods regulations and classification in substance management. For further information on dangerous goods classification, see the documentation for the R/3 component **Dangerous Goods Management** in the section **Dangerous Goods Basic Data [Ext.]** (process: Dangerous Goods Classification [Ext.]).

- **Phrase Management [Page 92]**

  You can create standard texts in phrase management, reducing the amount of writing and translating necessary. Phrases are managed in libraries.

- **Report Generation [Page 145]**

  You can output substance data on substance reports. You structure report layout using Windows Word Integration (WWI). This means that you can also use Microsoft Word functions. Specially defined symbols are replaced by values when reports are generated. Phrases are output in the languages specified. You use rating and validity area to specify that only permitted substance data appears on the substance report.

- **Report Management [Page 258]**

  In report management, the R/3 System supports the required work steps from report generation to final release. To save data, you can store reports you no longer require with status **Historic** that you can call at any time.

- **Report Shipping [Page 290]**

  Released reports can be used for report shipping. Report shipping controls the processes involved in creating a shipping order through to saving it. As well as allowing you to shipping material safety data sheets automatically, the R/3 System enables you to set up an automatic subsequent shipping for updated reports if changes have been made in reports to substance or phrase data.

- **Substance / Report Information System [Page 335]**

  You can use the substance information system to access specific substance data.

  The report information system enables you to search and display existing reports with status **Released and Historic**.
The comprehensive import and export functions support first database and exchange data between different systems.

You can use the filling function from the R/3 component dangerous goods interfaces to copy dangerous goods classification data to the dangerous goods master. For further information on the dangerous goods interface, see the documentation for the R/3 component Dangerous Goods Management in the section Dangerous Goods Interfaces [Ext.].

Data for hazard storage classes, VbF classes and water pollution classes are copied with a special transaction to the warehouse management system only.

For further information, see the R/3 implementation guide (IMG) under Logistics Execution → Warehouse Management → Hazardous Materials → Copy hazardous materials data from substance database.

**Integration**

You must have installed the following components for the R/3 System to be able to use all functions in the R/3 component Product Safety:

- Engineering change management
- Document management system
- Classification system
- Material master
- Sales and distribution
- Dangerous Goods Management

**Features**

The substance database has the following features:

- **Flexible definition of substance properties:**
  
  You can use the R/3 component Classification System to define substance properties to be as flexible as required. In the Classification System, you can define any number of properties (classes) featuring any number of fields (characteristics).

- **Authorization Concept**
  
  It is essential that the data stored on the substance database is secure. The R/3 authorization concept prevents unauthorized access to substance data. All changes to substance data are logged and thus traceable.

- **Engineering change management**
  
  Laws and regulations are regularly amended. These amendments cause changes to system behavior and substance data. The R/3 substance database also allows for mass
changes for which you can specify key dates. All modifications are activated on the key date you select. Key dates can also be changed.

- **Central substance database**
  
The R/3 System enables the creation of a central substance database. The database can be used for cross-company queries, that is for research purposes or to provide immediate information for incident management. The huge mass of substance data is stored in one central location. The database can also store data on substances that are not physically handled in a company for information purposes. Data can be recorded on local substances databases and then be reconciled with the data stored in a central EHS substance database. Data from the central substance database is then distributed to further systems within companies that process data for planning, checks and evaluations.

- **Standard interface**
  
Standard interfaces simplify the cost-effective transfer of data from existing applications or external systems. EHS runs data consistency checks during imports.
Substance Management

**Purpose**

You use this component to characterize Substances [Page 22] with different identifiers, and record structured data and text information for substances as phrases. You can find information about R and S records, material safety data sheet requirements or physical attributes. The R/3 System offers you a selection of typical substance characteristic categories using a properties tree. If required, you can use Customizing for Product Safety to define your own properties trees and substance characteristic categories.

**See also:** Maintaining Substance Data - An Example [Page 20].

The R/3 component Substance Management uses interfaces to external systems to enable you to determine secondary values from existing values. You can then transfer this secondary data and use it to assign characteristic values to substances (See also: Secondary Data Determination [Page 50]).

**Integration**

You can assign any number of materials to a substance, thus creating a link to other logistic processes. At the moment, automatic report shipping for substances requiring a material safety data sheet is carried out from within Delivery (See also: Material Safety Data Sheet Shipping [Page 304]).

The R/3 System supports the import and export of substance data in productive systems. When exporting substances, you can convert phrases in the active R/3 phrase library to phrases for the export library. Similarly, when importing substances, you can convert phrases in the import library to phrases for the active R/3 phrase library (See also: Interfaces [Page 346]).

You use engineering change management and change documents to allocate validity areas to phrase changes, and to log changes.
Substance Management: Process

Purpose
See: Substance Management [Page 16]

Prerequisites
- To use substances in the R/3 System, you can create them yourself, or import them. In addition, to assign characteristic values to substances, you must have imported or manually created phrases and sources.
  
  See also:
  Import and Export: Process [Page 348]
  Phrase Management [Page 92]
  Source Management [Page 60]

- Materials to which you want to allocate substances must have been created in the R/3 material master.

- You must have the authorization to edit and display substances.

Process flow
See also: Function Model of Substance Management [Page 21]

1. You can carry out the following activities in the initial Substance Management screens:
   
   – You can enter different search criteria, and start drill-down reporting for the required substances. If the required substance does not exist in the R/3 System, you can create it.

   The R/3 System enables you to define further search functions as user exits.

   – You can create a substance immediately.

   If you process or create substances with engineering change management, you must enter a change number on the initial screen.

   More information

   Procedure

2. The results of the search are displayed in the hit list. In the hit list, you then process the substances further, and create new ones.

   Procedure

   Editing the Substance Hit List [Page 71]
Substance Management: Process

3. When creating a substance on the initial screen or from the hit list, you first enter the data for the **substance header**.

   You can copy an existing substance as a **template**. You can copy substance data from another substance to an existing substance.

   In the substance header you can enter **reference substances** depending on the substance category. A reference substance transfers its assigned characteristic values to the referencing substance. If required, you can overwrite these values.

   **More information**
   - Substance Reference [Page 26]
   - Substance Category [Page 28]

   **Procedure**
   - Editing the Substance Header [Page 73]
   - Copying Substance Data [Page 74]

4. You use **substance identifiers** to create a unique description of a substance.

   You allocate a **substance list** to each substance identifier. You maintain this list in substance list management.

   **More information**
   - Substance Identification [Page 29]
   - Substance Lists [Page 31]

   **Procedure**
   - Editing Substance Identifiers [Page 75]
   - Assigning Substance Lists [Page 77]

5. In the R/3 Product Safety component, you can allocate several **materials** to a substance, depending on the substance category.

   **More information**
   - Material Assignment [Page 32]

   **Procedure**
   - Assigning Materials [Page 78]

6. The **properties tree** offers a structured representation of all the substance characteristic categories that you can maintain in substance characteristic value assignment.

   Within the properties tree, you can copy data records for **substance characteristic categories** from one substance to another.

   **More information**
   - Substance Characteristic Values [Page 34]

   **Procedure**
   - Using the Properties Tree [Page 79]
   - Editing Substance Characteristic Values [Page 82]

7. You store substance data and information as characteristic values in substance characteristic value assignment.

   You can change the **assessment**, enter a **source** or any **user-defined text** for all substance characteristic categories. You can also use the **usage** feature to control the rating and the validity area for which the substance characteristic values are permitted.
For substance characteristic categories from substance characteristic types *substance composition* and *substance listing*, you also process **component overview**.

More information

Assessments [Page 42]
Sources [Page 43]
User-Defined Texts [Page 44]
Usage [Page 46]
Component Overview [Page 49]
Source Management [Page 60]

Procedure

Editing Characteristic Values [Page 83]
Editing Assessments [Page 86]
Assigning Sources [Page 87]
Editing User-Defined Texts [Page 88]
Processing Usages [Page 89]
Processing the Component Overview [Page 90]

Result

- From within the hit list, you can
  - start the **export** for substances
    **See also:** Export: Process [Page 446]
  - create **report body requests** for substances
    **See also:** Report Management [Page 258]
- call specific substance management data in the **substance information system**. You can display the data in different ways.
  **See also:** Substance Information System [Page 336]
Maintaining Substance Data: An Example

To create the substance \textit{2 Propanone} manually, you must either define a substance key (LM_01 for example) yourself, or let the R/3 System assign a key. As the substance is handled in companies and data must be accessible to all, assign substance category \textit{real substance}, and substance authorization group \textit{ALL} to the substance. Use the following \textit{identifiers} to characterize the substance:

- Trade name: Acetone
- Structural formula: CH\textsubscript{3}COCH\textsubscript{3}
- CAS number: 67–64–1

In \textit{Product Safety Customizing}, the setting is made to allow materials to be allocated to real substances. The material with the key 500000 (Acetone p.a. in 2 liter bottles) is allocated to the substance \textit{2 Propanone} correspondingly.

In characteristic value assignment, you maintain \textit{substance characteristic categories}, for example:

- in \textit{Physical-chemical properties}:
  - Boiling point: 56°C
  - Melting point: -95°C
- in \textit{Regulations without transport}:
  - \textit{Labelling}: Highly flammable
  - \textit{MSDS requirement}: MSDS shipping required (\textit{See also: Material Safety Data Sheet Shipping [Page 304]})

As the data is to be accessible to all and valid for the whole world, the following \textit{use} is allocated to all four substance characteristic categories:

- Rating: PUBLIC (Released w/o restrictions)
  As the values are to be issued on a substance report, an active indicator is set for each rating.
- Validity area: REG_WORLD (World)

\begin{itemize}
  \item The substance report generation variant links the use with a substance report template that you defined in \textit{Product Safety reporting}.
  \item If a report is generated (such as a material safety data sheet, for example) only the symbols on the substance report template are expanded that are released for the recipient and for which the active indicator has been set.
\end{itemize}
Function Model of Substance Management

The search result of substance drill-down reporting is represented in a hit list from which you can call substance management functions:

- Substance header with substance reference allocation
- Substance identifier and substance list allocation
- Properties tree for navigation into substance characteristic value assignment
- Material allocation

You can also use the Create function in both the initial screen and the hit list.

Function Model of Substance Management
Substance

Definition
This business object describes a chemical element, a compound, or a mixture of chemical elements or compounds.

Structure
- There can be several identifiers for a substance, in the form of numbers, names, or formulas.
  
  See also: Substance Identification [Page 29]
- A substance can make references to one or more other substances. This reference between substances enables characteristics of the reference substance to be passed on to the referencing substance.
  
  See also: Substance Reference [Page 26]

Integration
- Substances are divided up according to substance category (for example, listed substance, real substance).
  
  See also: Substance Category [Page 28]
- Authorization groupings divide substances according to user groups that are authorized to work with these substances.
- Substances are allocated characteristic values using the substance characteristic categories of the type substance property, substance composition, and substance listing.
  
  See also: Substance Characteristic Values [Page 34]
- From the point of view of logistics, one or more materials can be allocated to a substance.
  
  See also: Material Allocation [Page 32]
Substance Search

Use
In the initial substance management screen, you use the drill-down reporting functions to define criteria with which substances are to be selected.

Features
The results of the search are displayed in a hit list where you can restrict or extend the search results further.

All search criteria on the initial screen are linked by AND operations. This includes searches using
- Identifiers (trade name, CAS number, structure formula, for example)
- Substance lists
- Material and material short text

Search functions
Search functions are delivered in the standard system that you can check in Customizing for Product Safety in Manage user exits. Call the documentation of the corresponding standard function module to define your own search functions. Write the new function module to correspond with the reference module and its interface.

You can use the following functions:

<table>
<thead>
<tr>
<th>Search function</th>
<th>Finds substances</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substance with property</td>
<td>that have certain characteristic values for certain substance characteristic categories.</td>
</tr>
</tbody>
</table>

You use this function to select the required substance characteristic category in the Properties tree dialog box.

The R/3 System lists the corresponding characteristics for which you can enter the values you require.

💡 You can set up the search to be exclusive or inclusive for non-phrase-related characteristics. To do this, call the possible entries help for the characteristic. A dialog box appears that you can use to choose the comparison type. If you then mark the exclusive field on the comparison type dialog box, then the R/3 System finds all substances that do not have the characteristic values you specified.

After confirmation you can choose a substance characteristic category once again and enter characteristic values.
Substance Search

Substance with header data: that fulfill the specified search criteria in the substance header. This includes:

- Substance details (substance key, substance category, and so on)
- Administrative data (name of creator, of person who last change the data, data origin, data owner, and so on)

Substance contains component: that fulfill the specified search criteria. This includes details covering reference value, substance key, component type and concentration. You can also enter the substance characteristic category containing the corresponding component.

You can choose whether the specified component:

- Exists directly as a constituent of the substance for which you are searching
- Exists as an indirect, further component of a constituent

Substance with phrase valuation: to which a certain phrase was assigned as a characteristic value.

Substance uses reference substance: that have a particular reference phrase.

Activities

Searching for Substances [Page 68]
Engineering Change Management for Substances

Use
This function enables you to carry out data changes for a particular key date using a change number. Each change number is valid from a particular validity date so that the data have a validity period in accordance with the change number.

When you change existing data, R/3 Product Safety creates a change comment that contains the person responsible for the change, and the change date.

- If you make changes without using a change number, the standard validity period used goes from 01.01.0001 to 31.12.9999. The system enters the current date as the key date.

- When you use change numbers for the first time, the R/3 System divides the overall validity period into two adjoining validity periods. Whenever you use other change numbers that feature different validity dates, the system carries out further subdivisions of validity periods.


Prerequisites:
You have created a change number from the SAP R/3 screen under Logistics → Central functions → Engineering change management.

Features
You can use engineering change management within R/3 substance management to

- Import characteristic values for substances
- Create substances

  - The change number has higher priority than the key date.
  - You can display changes to data records by choosing Extras → Administrative info in substance management.

Activities
To display the change documents, proceed as follows. From the SAP R/3 screen, choose Tools → ABAP Workbench, then → Developm → ABAP Editor. Enter the RSSCD100 program and choose Execute. On the following screen, enter ESSUB as object class, and choose Execute.

In the substance management screens you can obtain more information about, for example, Data Origin [Page 64] and Data Owner/Provider [Page 65] under Extras → Administrative info.
Substance Reference

Use
You can use this function to allocate one or more reference substances to a substance. In doing this the R/3 System generates a link from the characteristic values of the reference substance to those of the referencing substance. This greatly reduces the amount of data that needs to be entered.

Prerequisites
The required reference substance must belong to a substance category for which the Ref. perm (referencing permitted) indicator has been set in the IMG activity Define substance categories.

Features
The following rules apply for substance reference in the R/3 System.

- If you allocate a reference substance to a substance, a link is created to the substance from all the characteristic values assigned to the reference substance. You cannot exclude individual substance characteristic categories.

  No data is transferred outside substance characteristic values. The following, for example, are not transferred:
  - Identifiers
  - Material allocations

- You can manually overwrite characteristic values that are assigned to a referenced substance. You can choose
  - whether the characteristic values assigned to a referenced substance are to be deleted, and whether you re-enter data
  - whether the characteristic values assigned to a referenced substance are to remain as a template, and whether you overwrite data

  In the properties tree, each substance characteristic category that is assigned a value by a reference substance is given a special symbol (“three diverging arrows”). If you overwrite the characteristic values assigned to a referenced substance manually, the symbol changes (“pencil and paper”)

- If you allocate several reference substances to a substance, the characteristic categories for these reference substances may not overlap.
Unique substance characteristic values to be transferred from several reference substances to one referencing substance

- The R/3 System rejects the allocation of a reference substance if at least one of the following conditions is fulfilled: The planned reference substance
  - is identical to the referencing substance (a substance may not reference itself)
  - has a substance category that does not allow the substance to be used as a reference substance (defined in Customizing for Product Safety)
  - is being processed by another user
  - already has a reference substance (multi-level referencing is not allowed)
  - overlaps with at least one other reference substance for this substance in at least one characteristic category

**Activities**

If you call a substance characteristic category that was transferred to the substance via substance referencing, the characteristic value is shown in display mode.

To edit the referenced characteristic value you must call the edit mode on the Display substance screen by choosing Substance → Display ↔ edit.

See also:

Editing the Substance Header [Page 73]
Substance Category

Definition
You use this object to categorize substances according to their use in companies.

Use
A substance may be allocated to one substance category only. In Customizing for Product Safety, in the IMG activity Specify substance categories, you define

- whether materials may be allocated to a substance of a particular substance category
- whether a substance of a particular substance category may serve as a reference substance
- the number range group to which a substance category is allocated

In addition, you can specify a check function that checks whether the syntax of the assigned substance key is correct.

The standard system contains the following substance categories:

- **Real substances**
  A real substance is one which is physically present in a company.
  In the standard system, you can allocate one or more materials to the real substance. You can assign values to the substance characteristic category of a real substance, or define it using references to other listed substances.

- **Real substance groups**
  Real substance groups are used to represent families of real substances with a number of common properties.

- **Listed substances**
  A listed substance is a substance whose properties are described in laws and scientific literature.
  Unlike real substances, listed substances are not produced, traded, or used. You can use a listed substance as a “properties model” for a real substance by allocating the listed substance as a reference substance.

- **Listed substance groups**
  Listed substance groups are used to represent families of listed substances with a number of common properties.

- **Copy templates**
  Copy templates contain pre-defined characteristic values. You can use them to create new substances.
Substance Identification

Use

This function enables you to clearly identify a substance.

A substance identifier is defined in the following way:

- The substance identification **type** generally specifies the data type. The types *name*, *number*, and *formula* are delivered in the standard system.

- The substance identification **category** gives a more exact description of the substance identification type.

  ![Image]

  The substance identification type *NAME* is subdivided into the following identification categories: Trivial name, product name, IUPAC name

Integration

The R/3 System enables you to output identifiers on substance reports.

Prerequisites

In Customizing for *Product Safety*, you have carried out the following IMG activities:

- In the IMG activity *Check identification listing* in Customizing for *Product Safety*, you define the identifiers to be displayed on the individual program screens (on the hit list, in substance characteristic values, for example). For an identification listing, you can define
  - the maximum number of identifiers to be displayed for an item
  - that an identifier is only to be displayed, if a particular substance list is allocated to it

- In the IMG activity *Check identification categories* you can define:
  - further identification types and identification categories
  - the maximum length of an identifier
  - a check function that checks whether the entry for an identifier is correct
  - whether an identifier of type *Name* is language-dependent
  - whether small letters are to be changed to capitals
  - whether special characters are allowed
  - whether an identifier of type *Formula* is allocated to a document

Features

You can

- create any number of substance identifiers for a substance. Within a substance identification category, you can also define the sort sequence as required.
Substance Identification

- enter a text of any length using the R/3 Editor for each identifier
- allocate substance lists to each identifier

See also: Substance Lists [Page 31]

<table>
<thead>
<tr>
<th>Identification type</th>
<th>Identification category</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>IUPAC name, synonym, trivial name, trade name, etc.</td>
</tr>
<tr>
<td>Number</td>
<td>CAS number (Chemical Abstract Service), EINECS (European Inventory of Existing Commercial Chemical Substances), ELINCS (European List of New Chemicals), UN number (UN list for dangerous goods transports) and so on.</td>
</tr>
<tr>
<td>Formula</td>
<td>Empirical formula, rational formula (a formula structured according to chemical function units), etc.</td>
</tr>
</tbody>
</table>

Activities

Editing Substance Identifiers [Page 75]
Substance Lists

Definition
This object is a directory in which substances with certain attributes are listed. As a rule, substances are grouped together in lists with regard to legal regulations.

Typical substance lists:
- EINECS (European Inventory of Existing Chemical Substances)
- TSCA (Toxic Substances Control Act)

Use
The R/3 Product Safety component enables you to allocate substance lists to individual identifiers and to record the substance list in which those identifiers originated.

You can
- allocate an identifier to one or more substance lists
- allocate a substance list to one or more identifiers

You maintain substance lists in Substance List Management [Page 62].
Material Assignment

Use

You can use this function to assign any number of materials from the R/3 Material Master component to a substance in the R/3 Product Safety component, thereby creating a link to further logistic processes.

The material contains logistics data, such as price, weight and dimensions. This data depends on a substance’s packaging size or trading units.

Substances carry substance property data. This data is independent of a substance’s packaging size or trading units.

If the material carries the environment relevant indicator and a delivery is posted to this material, the R/3 System checks whether the material is assigned to a substance that requires a material safety data sheet, and then, if necessary, triggers material safety data sheet shipment.

See also: Material Safety Data Sheet Shipping [Page 304]

<table>
<thead>
<tr>
<th>Material</th>
<th>Relation</th>
<th>Substance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acetone p.a.</td>
<td>1:1</td>
<td>Acetone p.a.</td>
</tr>
<tr>
<td>Super glue</td>
<td>1:n</td>
<td>Resin, Hardener</td>
</tr>
<tr>
<td>1 liter SAE 15-W40 oil</td>
<td>n:1</td>
<td>SAE 15-W40 oil</td>
</tr>
<tr>
<td>1 liter SAE 15-W40 oil</td>
<td>0:1</td>
<td>Chromous salts</td>
</tr>
</tbody>
</table>

Material - substance assignment

Prerequisites

- You must have created the materials in the material master of the R/3 Materials Management component.

- In the Basic data 2 view of the material master, you must set the Environmentally rlvt (environmentally relevant) indicator for materials which require a material safety data sheet.

- The substance must belong to a substance category for which the Mat. assignment indicator has been set in the IMG activity Specify substance categories.
Features
You can
• assign one or several materials to a real substance.
• assign one material to several real substances.
• specify a plant for a material.
After you have assigned a material and plant, the R/3 System checks whether
• the material and plant exist
• the material exists in the plant
  The combination of material and plant must be a valid plant material.
• the material-plant combination is unique
  The combination may only be assigned once to one substance only. You must enter the material either always without plant, or always with plant.

  If you do not enter a plant for a material, the assignment is valid for all plants in which the material occurs.

For further information on the R/3 Material Master (LO-MD-MM), see Help → R/3 library → LO - Logistics → LO - Logistics - General → Logistics Basic Data (LO-MD) → LO Managing Material Master Data.

Activities
Assigning Materials [Page 78]
Substance Characteristic Values

Use

You use this function to structurally maintain substance data and information. You enter substance characteristic value assignment via the properties tree. The tree gives you a clear, multi-level arrangement of the individual subject areas. Within substance characteristic value assignment you can enter a source, any comments, or assign characteristic values for a data record.

Usage is a special feature that specifies a level (or rating) at which a data record may be accessible. It also specifies which validity area the data record has (See also: MSDS Jurisdiction [Page 294]).

Characteristic value assignment depends on the following objects:

- The substance characteristic type generally specifies the data type. You can use the following types:
  - Substance Characteristic Type Substance Property [Page 38]
  - Substance Characteristic Type Substance Composition [Page 39]
  - Substance Characteristic Type Substance Listing [Page 40]

- You can allocate substance characteristic categories to each substance characteristic type in Customizing for Product Safety in the IMG activity Set up substance characteristic categories. You allocate a class of class type 100 (substance characteristic value) to each substance characteristic category. You maintain the class in R/3 Classification System.
  
  See also: Substance Characteristic Categories: Example [Page 41]

- You can create characteristics for each class that are then transferred to the corresponding substance characteristic category. After you have included the substance characteristic category in the properties tree in the IMG activity Set up properties trees, and have carried out the Adjust characteristic category - characteristics function in Master Data Adjustment [Page 255], you can call the substance characteristic category in R/3 Product Safety and enter actual values for the characteristics.
  
  See also: Setting up Substance Characteristic Categories and Characteristics [Page 36]

Integration

You can use all data in substance characteristic value assignment on substance reports. You use the Usage function to ensure that only the characteristic values that are permitted for the substance report recipient are output.

Prerequisites

- You have set up a properties tree in Customizing for Product Safety (See also: Prerequisites under Using the Properties Tree [Page 79]).
So that you can use phrases for characteristic value assignment, you must have maintained phrases in Phrase Management accordingly (See also: Phrase Management [Page 92]).

You can only see and edit substance characteristic categories for which you have authorization.

**Features**

In the R/3 Product Safety properties tree, individual substance characteristic categories are listed for which you can record any number of data records in substance characteristic value assignment.

All substance characteristic categories contain the following standard functions:

- [Assessments](Page 42)
- [Sources](Page 43)
- [User-Defined Texts](Page 44)
- [Usage](Page 46)

For substance characteristic categories composition and substance listing, Product Safety also has the [Component Overview](Page 49) function.

**Activities**

[Editing Substance Characteristic Values](Page 82)

For more information about maintaining dangerous goods data, see [Dangerous Goods Basic Data [Ext.]](Page 82). (Process: [Dangerous Goods Classification [Ext.]](Page 82)).
Setting up Substance Characteristic Categories and Characteristics

Each substance characteristic category is represented by a class of class type 100. In R/3 Classification System you can assign any number of characteristics to a class.

In Customizing for Product Safety (IMG) a substance characteristic category is assigned to each class. In this way the substance characteristic category inherits the characteristics of the class. Substance characteristic categories can be of type substance property, substance composition, or substance listing.

Characteristics can have the following data types:

- Numerical characteristics
- Number range numerical characteristics
- User-defined alphanumerical characteristics
- Predefined format characteristics
- Phrase library-related characteristics (data type CHAR30)

Numerical characteristics feature a default unit of measurement. In fields such as these, you only need to enter the value as a number. The unit of measurement is added after you have chosen Confirm.

You can only use other units of measurement, if these are contained in the R/3 unit of measurement table, feature identical dimensions, and if the conversion parameters have been maintained.

If you have created new characteristics you must carry out the Adjust char. cat. - char. (Adjust characteristic category - characteristics) function in Master Data Adjustment to update the display.

- For further information on the R/3 Classification System (CA-CL), see Help → R/3 library → CA - Cross-Application Components → Classification (CA-CL).
- We recommend that you use the IMG activity Adopt standard substance database structure to adopt the standard substance characteristic categories and characteristics.
Setting up Substance Characteristic Categories and Characteristics

**Classification System**

- Class (Class cat. 100)
  - Char ...
  - Char ...
  - Char ...

- Class (Class cat. 100)
  - Char ...
  - Char ...
  - Char ...

**IMG**

- Set up substance char. category
- Subs. Char. category ...
- Subs. Char. category ...
- Subs. Char. category ...

**Allocation of:**

- Subs. Char. type
- Class

**Subs. Characteristic types**
- Typ A: properties
- Typ B: substance listings
- Typ C: compositions

Relationship between substance characteristic category and class
Substance Characteristic Type Substance Property

Definition
This object assigns characteristic values to a substance using numeric values or phrases.

Use
The substance characteristic type Substance Property is subdivided into individual substance property categories that can be sorted into groups in the properties tree.

Typical descriptions for groups of substance property categories:

– Physical/chemical properties
– Toxicological properties
– First aid data

The Physical/chemical properties group, for example, can contain the following substance property categories:

– Density
– Melting point
– pH value
Substance Characteristic Type  *Substance Composition*

**Definition**
This object lists a substance’s components and their concentrations. Components are substances that are still present in a substance after the manufacturing process has finished.

**Use**
The substance characteristic type *Substance Composition* is subdivided into individual substance composition categories. The following criteria can be taken into account:

- the choice of substance components
- The precision of the quantative values

Typical substance composition categories:
- Exact chemical composition
- Composition according to TSCA (Toxic Substances Control Act)
Substance Characteristic Type Substance Listing

Definition
Listing of substances without quantitative data.

Use
The substance characteristic type *substance listing* is classified according to individual substance listing categories.

Typical substance listing categories:
- Substances that must be monitored at the work center
- Products of decomposition processes
Substance Characteristic Categories: Example

The three substance characteristic types Substance Property, Substance Composition and Substance Listing are classified according to individual substance characteristic categories.

If there are very many substance characteristic categories, they can be sorted into groups, for example, physical-chemical properties.

<table>
<thead>
<tr>
<th>Substance characteristic type</th>
<th>Substance characteristic category</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substance properties</td>
<td>Density, color, acid number, and so on</td>
</tr>
<tr>
<td>Phys.-chem. properties</td>
<td>First aid eye, first aid skin, and so on</td>
</tr>
<tr>
<td>First aid</td>
<td>Acute oral toxicity, acute toxicity on skin contact, and so on</td>
</tr>
<tr>
<td>Toxicology</td>
<td>and so on</td>
</tr>
<tr>
<td>Substance composition</td>
<td>Exact chemical composition. Composition according to TSCA, and so on</td>
</tr>
<tr>
<td>Substance listing</td>
<td>Substances that must be monitored at work center. Products of decomposition processes.</td>
</tr>
</tbody>
</table>
Assessments

Use

Each substance characteristic value in R/3 Product Safety has an assessment. The following ratings are available in the standard R/3 System, for example:

- Not assessed
- Valid without restrictions
- Valid with restrictions
- Invalid
- Cannot be assessed

Prerequisites

In Customizing for Product Safety, you define a standard assessment that is automatically allocated by the system to each characteristic value you created. You can change these characteristic values if required.

Activities

Editing Assessments [Page 86]
Sources

Use

Using the Sources function, you can record a source and an additional note for a data record within substance characteristic value assignment.

Features

You can import sources into the R/3 System (See also: Export and Import [Page 348]).

You can maintain sources manually in the Source Management [Page 60].

Additional information can be displayed for each source, for example:

- Category and description of source
- Author
- Date of publication
- Order number
- General remark on the source itself

Activities

Allocating Sources [Page 87]
User-Defined Texts

Use

You can enter any user-defined texts for substance characteristic values, thus giving a closer description of the values.

When importing substance data, characteristics can be assigned phrases that do not yet exist in the R/3 System. In order not to lose the phrases, you can create them as characteristic-dependent user-defined texts.

Prerequisites

To define a characteristic-independent user-defined text,

- you must have flagged user-defined text categories as characteristic-dependent in Customizing for Product Safety.

In Customizing for Product Safety, you can also specify how many user-defined texts can be allocated to a characteristic per user-defined text category. The R/3 System checks this when you allocate user-defined texts to characteristics.

- You must have allocated the required characteristic-dependent user-defined text category together with a phrase set to a particular characteristic for a substance characteristic category. You do this in phrase set - characteristic allocation

Within a characteristic category, a characteristic-dependent user-defined text category may be allocated to a characteristic once only. You can allocate another characteristic-dependent user-defined text category to another characteristic from the same substance characteristic category.

Features

- Long Text Editor
  You can use the R/3 Editor to enter texts of any length.

- Characteristic-Dependent User-Defined Texts
  The R/3 Product Safety component enables you to allocate user-defined texts to a particular characteristic of a substance characteristic category.

  You assign the characteristic in question with a phrase, for example see user-defined text, and, using the function user-defined text, create a text in the relevant characteristic-dependent user-defined text category.

Activities

See also: Editing User-defined Texts [Page 88]

To assign a particular user-defined text category to a characteristic, proceed as follows:
1. Choose one of the following:
   – In the phrase set header, in phrase set labels, in phrase allocation, or in the phrase set hit list, choose Utilities → Char. assignment.
   – From the Product Safety [Ext.] screen, choose Phrases → Alloc. PhrSet-Char.

   The properties tree appears.

2. Place the cursor on the desired substance characteristic category, and choose Edit → Choose.

   The R/3 System lists all characteristics for that substance characteristic category.

3. In the UD TxtCat field, enter the key for the required user-defined text category for a characteristic.

4. Choose Enter and save your changes.

5. Choose Back.

See also:

Allocating Phrase Sets to Characteristics [Page 138]
Usage

Usage

Use

The Usage function consists of the Rating and Validity area fields.

You must define one or more usages for every assignment of substance characteristic values that is to be output on a substance report. You use the Usage feature to ensure that only certain data that belongs to a particular rating (PUBLIC, INTERN, for example) and a particular validity area is output on a substance report.

When the R/3 System generates reports, it compares the usage of a substance characteristic category that is to be output with that of the substance report generation variant, that is assigned to the substance report via R/3 Customizing.

See also:
Generation Variant [Page 250]
Inter-dependence of Individual Jurisdictions for MSDS Shipment: An Example [Page 301]

Prerequisites

You can use usage profiles that you define in the IMG activity Specify usage profiles to assign a standard usage to each substance characteristic category in Customizing for Product Safety, in the IMG activity Set up substance characteristic categories.

In the IMG activity Specify substance characteristic categories, you can also define whether usage is to be set to active automatically for a substance characteristic category that is copied, created or changed. Otherwise, you must reset the active indicator manually every time you edit substance characteristic values.

Features

Usage consists of the following elements:

- The rating specifies the users that can view the characteristic values assigned to the substance.

- A validity area is a group of countries or regions valid for the corresponding rating. You can exclude countries from the validity area by flagging the exclusion indicator.

  To define the validity area Europe without Italy, enter Europe and Italy as validity areas and flag the exclusion indicator for Italy.

- The active indicator shows whether rating and validity area are active, and that the R/3 System may include the corresponding substance characteristic values on the report.

- The Relevance Indicator [Page 48] specifies whether a change is relevant to existing characteristic values for the affected rating and validity area. For this reason this indicator is particularly important when generating reports.
Activities

Processing Usages [Page 89]
Relevance Indicator

Use

The relevance indicator specifies the substance characteristic values that are different in comparison with a previous substance report.

You can use the Generation Variant [Page 250] to specify that changes on the substance report are visually marked, thus making them instantly recognizable. The relevance indicator also affects the version numbering of a regenerated report. See also: Versioning Reports [Page 267]).

Prerequisites

The relevance indicator is only of significance if a previous report for the substance characteristic values specified already exists.

To mark changes on the substance report, you must first have set the Generate change marks indicator in the substance report generation variant.

Features

The system considers the relevance indicator for both manually and automatically generated reports.

If the relevance indicator is set for a substance characteristic usage, this means that

- The indicator is set in the report header. You can manually deselect the indicator in the report header.

- When a report is regenerated, all the affected substance characteristic values are marked at the side of the text, as long as this is specified in the generation variant

- The R/3 System proposes the creation of a new main version for the report body that was regenerated due to a relevant substance change

If a substance characteristic value is changed again, the R/3 System resets all relevance indicators for this characteristic value. You must reset the indicator manually, if the change is relevant.
Component Overview

Use
You use this function to enter the individual components of a substance.

For substance characteristic categories of type *Substance composition* you can enter additional quantitative values, whereas for substance characteristic categories of type *Substance listing*, you can list the components without details.

Prerequisites
As soon as you assign values to substance characteristic categories of type *substance composition* or *substance listing*, the system activates the function *component overview*.

Features

**Substance characteristic categories of type substance composition**
Firstly, you define the reference point for component entries (percent in weight w/w or percent in volume vol/vol) for substance characteristic categories of type *substance composition*.

You specify the component category for every component. In addition, you can enter the following details on substance concentration:

- Average proportion
- Possible deviation from the lower limit (>, >=)
- Lower limit
- Possible deviation from the upper limit (<, <=)
- Upper limit
- Exponent

**Substance characteristic categories of type substance listing**
You can enter the respective components for the substance characteristic categories of type *substance listing* without entering component category and concentration.

Activities
Processing the Component Overview [Page 90]
Determination of Secondary Data

Use

In secondary data determination, you can carry out the following activities:

- Derivation of data (secondary data) from existing data
  
  The existing R and S records for individual constituents are transferred via a defined interface to an external system in which the R and S records for compositions that contain these constituents are determined. The derived secondary data are then transferred back to the R/3 System.

- Checking the derived data
  
  Data from the R/3 component Product Safety can be updated using an import. If these data were used to determine secondary data, you can check these secondary data and derive them again if necessary.

Features

- Customer-specific enhancements with user exits
  
  The derivation and checking of secondary data is carried out using function modules that are integrated in user exit management in Customizing for Product Safety. You can also develop your own user exits in the same way.

  Normally, secondary data can be derived and checked in the R/3 System or in an external system.

- Example of secondary data determination: Notification Status [Page 51]
  
  In the R/3 standard system, there is an example of secondary data determination and checking for notification status.
Notification Status

Definition
Substance characteristic category of the type Substance property and Substance listing. The notification status specifies

- If a substance may be used in a defined jurisdiction
- On what basis its use is prohibited or permitted, and if any restrictions apply

Use
The notification status is normally specified by individual legislatures for pure substances and must be derived for products made of pure substances. The user exit Notification status was developed for this.

See also: Determination of Notification Status [Page 57]

If existing data is changed, you must check the notification status. The user exit Check notification status was developed for this.

See also: Checking the Notification Status [Page 59]

⚠️
All values for the notification status given here are sample values only. The phrase set and the phrases containing these values are not delivered in the standard system.

Structure
In the standard properties tree, the substance characteristic category Notification status is located under the node Regulations without transport. The substance characteristic category Notification status contains the following characteristics:

- **Basis of notification**
  Contains the substance lists used to determine notification status (ELINCS (list of new substances), TSCA (TSCA list), for example).

- **Revision**
  Additional data used to determine the most recent notification status (version number or year of publication of a particular list, for example).

- **List notification**
  The notification status for the composition if all notification values of each node of the fully expanded component tree are to be taken into account. The R/3 System does not distinguish between substance categories. This means that a leaf can also be a substance of the substance category Real substance. The value cannot be changed manually.

See also: Determination of Notification Status for Compositions [Page 54]
Notification Status

The description *List notification* is derived from the fact that the leaves of a component tree are normally substances of substance category *Listed substance*.

- **Component notification**
  - The notification status derived from the notification statuses of individual constituents that can themselves be compositions.
  - The R/3 System determines the component notification for the complete composition using the individual values for the constituents.
  - If you have set the notification status of a constituent manually, there could be discrepancies between the component and list notification. The component notification is set automatically and cannot be changed manually. It is for information purposes only.

- **Notification**
  - Contains the notification status. You enter this value manually or adopt it after the R/3 System has determined the notification status.
  - In the phrase set allocated, the sort sequence determines the priority of the individual values.
  - **See also:** Notification Status Values [Page 53]

- **Additional info**
  - The additional data for notification status includes the sample value q (quantity limit), t (temporary special case), and e (special case general).

- **Notification date**
  - Date on which a substance was registered with the relevant authority.
Notification Status Values

Notification status can have the following values in the R/3 component *Product Safety*.

⚠️

All values for the notification status given here are sample values only. The phrase set and the phrases containing these values are not delivered in the standard system.

<table>
<thead>
<tr>
<th>Value</th>
<th>Sort</th>
<th>Priority</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>n</td>
<td>1</td>
<td>1</td>
<td>Notification negative</td>
</tr>
<tr>
<td>q</td>
<td>3</td>
<td>3</td>
<td>Quantity limit</td>
</tr>
<tr>
<td>t</td>
<td>4</td>
<td>4</td>
<td>Temporary special case</td>
</tr>
<tr>
<td>e</td>
<td>5</td>
<td>5</td>
<td>Special case general</td>
</tr>
<tr>
<td>y</td>
<td>6</td>
<td>6</td>
<td>Notification positive</td>
</tr>
<tr>
<td>No value entered</td>
<td>9999</td>
<td>2</td>
<td>In work (default value)</td>
</tr>
</tbody>
</table>

If you want to create a phrase set with corresponding phrases, you must adhere to the following guidelines for sorting to acquire a valid status.

- Notification status is determined according to priority. The gap in the sorting between 1 and 3 forms a place-holder for the default value 9999. This value then has priority 2 and is used when a characteristic has had no value assigned to it.

- In cases *q*, *t*, and *e*, the notification status is determined only in connection with the characteristic value for *Additional info*.
Determination of Notification Status for Compositions

To determine the notification status for a substance with a composition of several different substances, the R/3 System first determines the individual constituents. The composition of a substance is thereby expanded completely regardless of whether a constituent has substance category *Listed substance* or *Real substance*.

See also: Example: Determination of Listed Substances [Page 55]

Finally, the R/3 System reads the characteristic value of the phrase-related characteristic *Notification status* for each constituent. The R/3 System uses the priority allocated to the characteristic value to derive the notification status for the composition that corresponds to the lowest priority (calculation of a minimum). If no value is found, the R/3 System uses the default value.

If the user does not have the required authorizations to expand the composition tree completely, the process is terminated at the appropriate point. The default value is used for further derivation.

A composition contains substances A, B, C, and D. The results are as follows.

**Case A:**

<table>
<thead>
<tr>
<th>Substance</th>
<th>Notification status</th>
<th>Legend:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>6</td>
<td><em>B = notification status is positive</em></td>
</tr>
<tr>
<td></td>
<td></td>
<td><em>1 = notification status is negative</em></td>
</tr>
<tr>
<td>B</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>D</td>
<td>6</td>
<td></td>
</tr>
</tbody>
</table>

⇒ Notification status = 6

**Case B:**

<table>
<thead>
<tr>
<th>Substance</th>
<th>Notification status</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>6</td>
</tr>
<tr>
<td>B</td>
<td>1</td>
</tr>
<tr>
<td>C</td>
<td>6</td>
</tr>
<tr>
<td>D</td>
<td>6</td>
</tr>
</tbody>
</table>

⇒ Notification status = 1

See also: Example: Derivation of List and Component Notification [Page 56]
**Example: Determination of Listed Substances**

In the following example, the substances (set in square brackets) are listed substances. The listed substances have the following notification statuses:

\[ Z=y, \ D=e, \ B'=y, \ B''=y, \ C'=y, \ C''=n, \ H_2O=y. \]

In the first step in determining the notification status, the composition tree is expanded completely to listed substance level.

Within the recursive descent, the system checks for the appropriate authorization every time a composition is read. If the user does not have all the authorizations to expand the composition tree completely, the process is terminated at the appropriate point.

In this case, the default value specified in the phrase set with sort sequence 9999 is used for further derivation. This value is marked in the output.

**Composition tree**

**Step 1:**
Expansion to the listed substance level
(leaves of tree)
Example: Derivation of List and Component Notification

In the first step in determining the notification status, the composition tree is expanded completely to listed substance level.

See also: Example: Determination of Listed Substances [Page 55]

The notification status $n$ (notification negative) has a lower priority than notification status $y$. This means that component C has list notification $n$ as a result.

This means that the notification status would be derived from the values in brackets if the values for the list notification were passed up in the hierarchy.

Step 2

Derivation of list notification (Lis) and component notification (Com)

Displaying the results as a list

<table>
<thead>
<tr>
<th>P</th>
<th>Lis</th>
<th>Kom</th>
<th>Prop</th>
<th>A</th>
<th>Lis</th>
<th>Kom</th>
<th>Prop</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>A</td>
<td>(n)</td>
<td>y</td>
<td>40%</td>
<td>B'</td>
<td>y</td>
<td>44%</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>(n)</td>
<td>y</td>
<td>50%</td>
<td>B'</td>
<td>y</td>
<td>18%</td>
</tr>
<tr>
<td></td>
<td>[C']</td>
<td>y</td>
<td>60%</td>
<td></td>
<td>C'</td>
<td>y</td>
<td>15%</td>
</tr>
<tr>
<td></td>
<td>[C&quot;]</td>
<td>n</td>
<td>1%</td>
<td></td>
<td>C&quot;</td>
<td>n</td>
<td>0.25%</td>
</tr>
<tr>
<td></td>
<td>y</td>
<td>38%</td>
<td></td>
<td></td>
<td>D</td>
<td>e</td>
<td>6%</td>
</tr>
<tr>
<td></td>
<td>A'</td>
<td>(e)</td>
<td>50%</td>
<td></td>
<td>Z</td>
<td>y</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>[B']</td>
<td>y</td>
<td>85%</td>
<td></td>
<td>H₂O</td>
<td>y</td>
<td>14.5%</td>
</tr>
<tr>
<td></td>
<td>[Z]</td>
<td>y</td>
<td>10%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[D]</td>
<td>e</td>
<td>5%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For substance A, there is an obvious discrepancy between the list and component notification, that is, the notification status for substance A was changed by the appropriate person responsible (from $n$ to $y$). This yields an overall default value for the list notification of $P_{\text{Lis}} = \min(y,n,y,y,y,y,e,y,n,e,y) = n$ and $P_{\text{Reg}} = \min(y,y,n,e,y) = n$ for the component notification.
Determination of Notification Status

Prerequisites

- You have specified the parameters for user exit types SUB_SEDACA and SUB_SEDACH in the IMG activity Manage user exits in Customizing for Product Safety. For further information, see the documentation for the IMG activity Manage user exits.
- The basis for notification (substance list) is present in the R/3 component Product Safety.
- You have read authorization for values assigned to composition and write authorization for the target characteristic category.

Procedure

1. In the substance management hit list, select all substances for which you want to determine a notification status.
   [See also: Searching for Substances [Page 68]]
2. Choose Utilities → Secondary data → Det. secondary data and select the user exit Notification status.

   The Determination of Secondary Data: Notification Status screen appears.
3. Enter the substance list to be used for the determination, and specify the usage.

   The individual components for the selected substance must have a data record in the substance characteristic category Notification status that corresponds to this usage. The R/3 System always uses the first corresponding data record.

   ![Warning]

   The usage is to be selected so that the R/3 System finds exactly one composition and notification status per substance.
4. Specify if the display should be as component tree or substance listing.

   ![Warning]

   To determine the percentage proportion, the reference point must be the same for all components. (Per cent volume or mass)
5. Choose Execute.

   The list and component registries are displayed. You can display them in sequence for all substance originally selected.

   ![Warning]

   All values in round brackets were determined by the R/3 System.
   If you specified a component tree display, expand it completely to see all list and component registries.
6. If you want to adopt the list and component registries determined, choose Adopt.
Determination of Notification Status

It is recommended that you allocate a standard usage profile to the target substance characteristic value. In this way, the notification status entered can be used automatically for other data derivations and in reports.
Checking the Notification Status

Prerequisites

- You have specified the parameters for user exit types SUB_SEDACA and SUB_SEDACH in the IMG activity Manage user exits in Customizing for Product Safety. For further information, see the documentation for the IMG activity Manage user exits.

- The basis for notification (substance list) is present in the R/3 component Product Safety.

- You have read authorization for composition values.

Procedure

1. In the substance management hit list, select all substances for which you want to check the notification status.
   
   See also: Searching for Substances [Page 68]

2. Choose Utilities → Secondary data → Check and select the standard user exit Check notification status.

3. Enter the substance list to be used for the determination, and specify the usage.
   
   The individual components for the selected substance must have a data record in the substance characteristic category Notification status that corresponds to this usage. The R/3 System always uses the first corresponding data record.

   ![Tip]

   The usage is to be selected so that the R/3 System finds exactly one composition and notification status per substance.

4. Choose Execute.
   
   The background job Check notification status is started.

   All substances for which a deviating value in the list or component notification is found are sent to you as an SAP office message. You must make corrections manually, and ensure that this procedure is part of your own data maintenance routine.
Source Management

Purpose
This process enables you to record and maintain sources. You define sources at a central point and can then use them for substance characteristic value assignment.

Prerequisites
- To use sources in the R/3 System, you can create them yourself, or import them.
  See also: Import and Export: Process [Page 348]
- You must have the authorization to edit and display sources.

Process flow
You process sources from the SAP R/3 screen.

Alternatively, you can process sources starting from the processing mode of substance characteristic value assignment by choosing Extras → Source and then Environment → Edit sources.

See also:
Editing Sources [Page 61]
Editing Sources

1. From the Product Safety [Ext.] screen, choose Tools \(\rightarrow\) Current settings.
2. Choose Create sources.
3. If you
   - Want to create a source: Choose Edit \(\rightarrow\) New entries.
   - Want to change a source: Position the cursor and choose Goto \(\rightarrow\) Details.

   ![Lightbulb icon]

   The detail screen appears.

   If there is only one entry, the detail screen appears straight away.

4. Enter your data.
5. Choose ENTER and save your changes.
Substance List Management

Purpose
This process enables you to create and maintain substance lists (See also: Substance Lists [Page 31]).

Prerequisites
You have authorization to process substance lists.

Process flow
You process substance lists from SAP R/3 screen.

💡
Alternatively, you can access the substance list from the substance list assignment when you are in processing mode by choosing Environment → Edit substance lists (See also: Assigning Substance Lists [Page 77]).

⚠️
Once substance list entries have been used in a live system, they cannot be deleted.

See also:
Processing Substance Lists [Page 63]
Processing Substance Lists

1. From the Product Safety [Ext.] screen, choose Tools → Current Settings.
2. Choose Specify Substance Lists.
3. **If you**  **Then**
   - Want to create a substance list
     - Choose Edit → New entries.
   - Want to change a substance list
     - Position the cursor and choose Goto → Details.
     - The detail screen appears.
     - If there is only one entry, the detail screen appears straight away.
4. Enter your data.
5. Choose **ENTER** and save your changes.

You can use the functions **Utilities → Adjust** and **Utilities → Change requests (Organizer)** in substance list management. These are Customizing functions.
Data Origin

The R/3 System uses data origin to make a record of the system from which the data originates for all substance data records.

All sources that are known in the current system are managed in Customizing for Product Safety in the IMG activity Specify Data Origin. There you select the current data origin that is to be automatically used as default when creating and exporting substance data.

If a substance data record is changed, the R/3 System automatically allocates the data origin that is set as a default value in Customizing, to the data record. If you want the original data origin, you must set the Retain data origin/provider indicator in the hit list under Utilities → Retain data provider.

See also:

Data Provider and Data Origin: An Example [Page 66]
Phrase Management [Page 92]
Data Owner/Provider

The data owner is responsible for ensuring the data is correct and is assigned to a substance authorization group in Customizing for Product Safety in the IMG activity Specify substance authorization groups. The data provider is the organizational unit that supplies the data for an import into the R/3 System. If there is no data provider for a substance data record in an import file, the data owner that was specified for the corresponding substance authorization group in Customizing is used as a default value.

If a substance data record is changed, the R/3 System automatically assigns the data owner/provider, that corresponds with the substance authorization group of the changed substance, to the data record. If you want the original data owner, you must set the Retain data origin/provider indicator in the hit list under Utilities → Retain data provider.

You enter the data owner/provider in address management in R/3 Product Safety under Tools → Edit addresses → Data owner/provider.

See also:

Data Provider and Data Origin: An Example [Page 66]
Phrase Management [Page 92]
Data Provider and Data Origin: An Example

Three R/3 Product Safety systems are employed in a chemical company. The systems are used by different departments:

<table>
<thead>
<tr>
<th>Data Origin</th>
<th>Data Provider</th>
</tr>
</thead>
<tbody>
<tr>
<td>System 1</td>
<td>Pharmaceuticals</td>
</tr>
<tr>
<td>System 2</td>
<td>Cosmetics</td>
</tr>
<tr>
<td>System 3</td>
<td>Dyes</td>
</tr>
<tr>
<td></td>
<td>Adhesives</td>
</tr>
<tr>
<td></td>
<td>Fuels</td>
</tr>
</tbody>
</table>

The names of the R/3 Product Safety systems are used for the data origin, and the names of the departments are used for the data providers.

When data is transferred either from or to R/3 Product Safety (import or export), data origin and data provider are taken into account. In this way, you avoid an undesired overlap of data areas.
Substance Management: Procedures

To maintain substances, you can use the following procedures:

- Searching for Substances [Page 68]
- Creating Substances [Page 70]
- Editing the Substance Hit List [Page 71]
- Editing the Substance Header [Page 73]
- Copying Substance Data [Page 74]
- Editing Substance Identifiers [Page 75]
- Example: Editing Identifiers [Page 76]
- Assigning Substance Lists [Page 77]
- Assigning Materials [Page 78]
- Using the Properties Tree [Page 79]
- Editing Substance Characteristic Values [Page 82]
- Editing Characteristic Values [Page 83]
- Searching for Phrases in Characteristic Fields [Page 84]
- Editing the Input Help [Page 85]
- Editing Assessments [Page 86]
- Assigning Sources [Page 87]
- Editing User-defined Texts [Page 88]
- Processing Usages [Page 89]
- Processing the Component Overview [Page 90]
Searching for Substances

1. From the Product Safety [Ext.] screen, choose one of the following paths:
   - Substances → Edit substances
   - Substances → Display substances.
     The initial screen appears. You can start substance drill-down reporting from here.
     During the search, all entries are linked with AND.

2. Enter the required data you know. The R/3 System searches for incomplete data in the Substance, Subs. auth. group, Identifier, and Material fields as follows:
   - Single generic delimitation, <Iso*>, for example.
   - Double generic delimitation, <*15*>, <*chlor*>, for example.
   - Placeholder in the middle of a key. <Butan+l> stands for both butanol and butanal.
   - Combination of search methods, <*>1234+678*>, for example.

   If you enter a value generically (with *) in a Substance field that has value help and confirm it, the R/3 System searches the R/3 substance database as follows:
   - The system first looks for identifiers of type Number.
   - If it does not find any corresponding identifier numbers, it then looks for identifiers of type Name.
   - If it does not find any corresponding identifier names, it then looks for substance keys.

   If you enter a value generically (with *) in a Substance field that has no value help and confirm it, the R/3 System searches the R/3 substance database for suitable substance keys.

   - The system does not differentiate between lower case and upper case letters during search runs.
   - The system ignores special characters such as underscores, hyphens, commas, periods, blanks, parenthesis, and so on.

3. Use the extended search functions.
   See: Substance Search [Page 23]

   All search entries (including the values for user exits) are retained even after you have exited the transaction (SET/GET memory). You can delete all search data by choosing New entry.

4. Choose ENTER, or Substance → Navigation → Hit list.
Result

In the substance hit list, the R/3 System lists the substances that correspond to the search criteria.

If the R/3 System does not find the required substance, you can enter new search criteria, or create the substance yourself.

See also:

- Editing the Substance Hit List [Page 71]
- Accessing the Substance Information System [Page 337]
Creating Substances


2. Enter a change number, if necessary, and check the key date.

   The change number has higher priority than the key date.

3. Choose Substance → Create. The Create Substance: Header screen appears.

4. You must carry out the following activity: Editing the Substance Header [Page 73].

   You can create substances from within the hit list after drill-down reporting by choosing Substance → Create.

See also:

Engineering Change Management for Substances [Page 25]
Editing the Substance Hit List

1. In the Product Safety [Ext.] screen, choose one of the following paths:
   - Substances → Edit substances
   - Substances → Display substances
   The initial screen for these functions appears.

2. In the initial screen, specify your search criteria (see Searching for Substances [Page 68]) and choose Substance → Navigation → Hit list.
   If the R/3 System finds data records that correspond to your search criteria, the hit list appears. It is displayed in two lines:
   - The first line contains the substance key, category, and a maximum of nine identifiers.
   - The second line contains up to 10 more identifiers. The first is the search identifier that led to the inclusion of the data record in the hit list.
     If you search for materials, the material found is displayed in the first column of the second line in place of the identifier.
     You specify the identifier display in Customizing for Product Safety.
   See also: Basic Functions in the Hit List [Page 157]

3. Select the substances you want to edit.
   Selected substances can be edited using the functions in the Edit menu.
   The R/3 System does not allow you to delete a substance if:
   - The substance is used by another substance as a reference substance
   - The substance is part of the composition of another substance
   - The substance is part of a substance listing (for example, hazardous constituents)
   - The substance is used in a report

4. You process substances further by choosing the functions in the Goto menu.
   - Editing the Substance Header [Page 73]
   - Editing Substance Identifiers [Page 75]
   - Assigning Materials [Page 78]
   - Using the Properties Tree [Page 79]
Editing the Substance Hit List

Within substance management, you can call additional information for a substance, for example, its Data Origin [Page 64] and Data Owner/Provider [Page 65] by choosing Extras → Administrative info.

Additional Functions

- **General**
  - **Function**
  - **Choose**
    - Different properties trees: Utilities → Other prop. tree.
    - Background information:Extras → Administrative info.

- **For selected substances**
  - **Function**
  - **Choose**
    - Retain the Data Origin [Page 64] and Data Owner/Provider [Page 65]: Utilities → Retain file provider.
    - Determination of Secondary Data [Page 50]: Utilities → Secondary data → Determination.
    - Exporting Substances [Page 452]: Substance → Export.

- Calling the Report Information System [Page 343], Report Generation [Page 145]:
  - Testing reports: Substance → Reports → Report from template.
  - Creating report requests: Substance → Reports → Create report.
Editing the Substance Header

Prerequisites

If you want to edit a substance under a change number, you must enter the change number in the initial substance management screen.

See also: Engineering Change Management for Substances [Page 25]

Procedure

1. If you want to create the substance header then choose Substance → Create in the Edit Substance: Initial Screen screen or in the substance management hit list.

   The substance header screen appears.

   ![Tip]

   You can copy data for an existing substance (See also: Copying Substance Data [Page 74]).

2. Edit the required data.

   When creating a new substance header, you can enter a key in the Substance field. If you do not enter a key, the system assigns a key to the substance after you have made the required entries and chosen Enter.

3. Choose ENTER and save your changes.

Result

- The R/3 System completes the administrative data.
  The validity period is set according to the change number specified. If no change number was entered, the validity period is unlimited.

- If you have entered a substance key yourself, the R/3 System checks the substance key against the external number range interval that you defined in the IMG activity Specify number ranges for substances in Customizing for Product Safety.

- To give a newly created substance a unique character, allocate substance identifiers to it as the next step.

See also: Editing Substance Identifiers [Page 75]
Copy Substance Data

1. If you want to copy a substance as template, From the Product Safety [Ext.] screen, choose Substances $\rightarrow$ Edit substances, and then Substance $\rightarrow$ Create.

   The Create Substance: Header screen appears.

   Enter the required data for the new substance, and choose Enter.

2. Choose Substance $\rightarrow$ Copy template.

   The Substance Management: Copy Template dialog box appears.

3. In the Copy from field, choose the substance to be copied, and select the data to be transferred.

   In the CharVals field, you can select individual characteristic categories that are to be copied from the R/3 System. If you do not select any data, all characteristic values are copied.

   The data to be copied must be used with regard to the substance category. For example, if you have specified in Customizing for Product Safety that material allocations are not permitted for the LIST_SUB substance category, then the Copy all field is inactive.

4. Choose ENTER and save your changes.

Result

The R/3 System copies all selected data.
Editing Substance Identifiers

1. Choose Goto → Identifiers in the substance header, material assignment, properties tree, or substance characteristic value assignment.
   The Edit Substance: Identifiers screen appears.
2. Enter the required data (See also: Example: Editing Identifiers [Page 76]).
   Please observe the following notes:
   – The identification category depends on the identification type.
   – Choose a language key for language-dependent identifiers.
   – To access the long text editor, choose Extras → Long text.
3. Choose ENTER and save your changes.

You can use the editing functions from the Edit menu for selected identifiers.

Result

You can assign substance identifiers to substance lists. To do this, select the substance identifiers you want, and choose Extras → Subs. list alloc.

See also: Assigning Substance Lists [Page 77]
Example: Editing Identifiers

Four identifiers for the substance chloroform:

<table>
<thead>
<tr>
<th>IDType</th>
<th>IDCat</th>
<th>L</th>
<th>Sort.</th>
<th>Identifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>NUM</td>
<td>CAS</td>
<td></td>
<td>1</td>
<td>67-66-3</td>
</tr>
<tr>
<td>NUM</td>
<td>EINECS</td>
<td></td>
<td>1</td>
<td>200-663-8</td>
</tr>
<tr>
<td>NAM</td>
<td>IUPAC</td>
<td>E</td>
<td>1</td>
<td>chloroform</td>
</tr>
<tr>
<td>FRM</td>
<td>MOLEC</td>
<td></td>
<td>1</td>
<td>CHC13</td>
</tr>
</tbody>
</table>

Legend for identification type (ID type): NUM = number, NAM = name, FRM = formula.

Legend for identification category (ID cat.): CAS = CAS number (Chemical Abstract Service), EINECS = EINECS (European Index of Existing Chemical Substances), IUPAC = International Union of Pure and Applied Chemistry, MOLEC = molecular formula.

Legend for language key (L): E = English.
Assigning Substance Lists

Prerequisites:
You have maintained substance lists in Substance List Management [Page 62].

Procedure
1. Select an identifier on the substance identification screen.
2. Choose Extras → Substance list assignment.
   The Edit Substance: Substance List Assignment screen appears.
3. Select a substance list in the SubsList field.
4. Choose ENTER and save your changes.

See also:
Editing Substance Identifiers [Page 75]
Assigning Materials

Prerequisites

- You must create the materials in the material master of the R/3 materials management component.
- The substance must belong to a substance category for which the Mat. assignment indicator has been set in the IMG activity Specify substance categories.

To ensure that material safety data sheet shipping is triggered by the delivery of a material, you must have

- Flagged the Environmentally rlvt indicator for the material in the material master in the Basic Data 2 view
- Rated the substance to be assigned as having a material safety data sheet requirement in substance characteristic value assignment

For further information about automatic shipping of material safety data sheets, see the R/3 Implementation Guide for Product Safety under Report Shipping.

See also: Material Safety Data Sheet Shipping [Page 304]

Materials can be assigned with or without a plant.

Procedure

1. Choose Goto → Material assignment in the substance header, substance identifiers, hit list, properties tree or in substance characteristic value assignment.
   The Edit Substance: Material Assignment screen appears.
2. Select the material key in the Material field.
   You can use the editing functions from the Edit menu for selected materials.
3. If required, limit the assignment to one or more plants.
4. Choose ENTER and save your changes.
Using the Properties Tree

Prerequisites

- You have set up a properties tree using one of the following methods:
  - In Customizing for Product Safety, you have carried out the IMG activity Adopt standard substance database structure.
    
    You should carry out this IMG activity once only.
  - You have imported a properties tree or defined one manually in Customizing for Product Safety.  
    
    See also: Export and Import [Page 348]
  - You have defined a properties tree manually in Customizing for Product Safety in the IMG activity Set up properties trees.

- You have chosen the required properties tree in the substance management hit list via Utilities → Other prop. tree.

- You have the required authorizations.

  In the R/3 System, you can assign read and write authorization to a user for each node (including roots). A user can display an end node if he has authorization for all nodes, including end nodes and roots.

Procedure

You access substance characteristic value assignment as follows:

1. Choose Goto → Properties tree in the hit list, substance header, substance identifiers, or material assignment.
   
   The Edit Substance: Properties Tree screen appears.

2. Expand the properties tree to the lowest level where the substance characteristic categories are displayed.

3. To access substance characteristic values, choose one of the following methods:
   
   - Position the cursor on the desired substance characteristic category and choose Goto → Characteristics.
   
   - Double-click on the desired substance characteristic category.

   The Edit Substance: Characteristic Values screen appears.

   See also: Editing Substance Characteristic Values [Page 82]
Using the Properties Tree

You copy data records for a substance characteristic category as follows:

1. Call the substance whose data records you want to copy, and navigate to the properties tree (See also: Searching for Substances [Page 68]).

2. In the properties tree, select the substance characteristic categories whose data records you want to copy by positioning the cursor on them and choosing F9.

3. Choose Edit → Copy.

   All data records for the selected substance characteristic categories, including the additional information on source, usage, etc., are copied to the clipboard.

   This data is retained in the clipboard until you have exited the transaction or copied other data.

4. Call the substance to which you want to copy the data records, and navigate to the properties tree.

5. Choose Edit → Paste.

   All data records in the clipboard are copied for the current substance. All characteristic categories thus modified are highlighted in the display.

Further functions in the properties tree

Different versions of the properties tree

If you want to have the line on which the cursor is placed as the first line on the screen then choose Edit → Nodes → Position nodes.

If you want to position the node under the cursor as the root then choose Edit → Nodes → Set section.

The corresponding hierarchy is displayed as the first line in the tree.

Displaying substance report symbols

If you want to display the substance report symbols for a substance characteristic category and its characteristics then choose Extras → Report symbols.

Source of characteristic value

Substance characteristic categories can be assigned values using various methods. The method used is indicated by a particular character beside the characteristic value in the properties tree. Choose Utilities → Update char. icons to update the display.

<table>
<thead>
<tr>
<th>Source of characteristic value</th>
<th>Character</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manually</td>
<td>Checkmark</td>
</tr>
<tr>
<td>By reference</td>
<td>Three diverging arrows</td>
</tr>
<tr>
<td></td>
<td>The first identifier for the reference substance is displayed next to the icon.</td>
</tr>
</tbody>
</table>
By manually overwriting a reference Sheet with pen

The first identifier for the reference substance is displayed next to the icon.

💡 If you have assigned a reference substance to your substance, a warning appears if you call the Characteristics function. Despite the warning, you can still assign characteristic values, and overwrite referenced ones.
Editing Substance Characteristic Values

1. Select a substance characteristic category in the properties tree and choose Goto → Characteristics.

See also: Using the Properties Tree [Page 79]

The Edit Substance: Characteristic Values screen appears.

If values have been referenced for this substance characteristic category, the screen is displayed automatically in display mode. To edit the referenced substance characteristic category, choose Substance → Edit ↔ Display.

A dialog box in which you can choose:

- if you want to copy the characteristic values for the reference substance and then edit them
- if you want to create new characteristic values (this means that the characteristic values for the reference substance are deleted in this substance characteristic category)

2. Maintain the individual areas within substance characteristic value assignment:

Editing Characteristic Values [Page 83],
Editing Assessments [Page 86]
Allocating Sources [Page 87]
Editing User-defined Texts [Page 88]
Processing Usages [Page 89]

For substance characteristic categories of type Substance composition and Substance listing.

Processing the Component Overview [Page 90]

If you call substance characteristic value assignment in display mode, only data records to which active usages are allocated are displayed. You must also have the authorization for usage.

If you call substance characteristic value assignment in editing mode, all data records are displayed. If you have already allocated a usage to the data records, you must have editing authorization. Otherwise, the data records are displayed in display mode only.
Editing Characteristic Values

Prerequisites

- If no data record has been created for the substance characteristic category, you create a data record as follows:
  1. Enter the number of the sort sequence (1, for example) for your first data record in the SS (sort sequence) field.
  2. Choose ENTER.
     The R/3 System makes the characteristic fields ready for input.

- If you create new characteristics, you must carry out the Adjust char. cat. - char. (Adjust characteristic category - characteristic) function in Adjust master data so that the characteristics for the corresponding substance characteristic categories are updated.
  See also: Master Data Adjustment [Page 255]

- If you want to allocate phrases to characteristics, you must allocate the corresponding phrase sets to the characteristics in the allocation of phrase sets to characteristics.
  See also: Allocating Phrase Sets to Characteristics [Page 138]

- In Adjust master data, you must carry out the (De)Activate phrase-rltd char. function so that you can use the phrases from the corresponding phrase sets as F4 value help when assigning values to characteristics.

Procedure

1. Enter numerical values directly in the characteristic fields.
   In phrase-related characteristic fields, you can either search generically in the characteristic field, or call the input help.
   - Searching for Phrases in Characteristic Fields [Page 84]
   - Editing the Input Help [Page 85]

2. Choose ENTER and check the entries the system then adds to the characteristic fields (that is, units of measure).  

3. Save your entries.
Searching for Phrases in Characteristic Fields

You can search for a phrase generically according to phrase text or phrase code. You can search as follows:

- Single generic delimitation, <Iso*>, for example.
- Double generic delimitation, <!5*>, <!chlo*>, for example.
- Placeholder in the middle of a key. <Butan+1> stands for both butanol and butanal, for example.
- Combination of search methods, <!234+678*>, for example.

The system does not differentiate between lower case and upper case letters during search runs.

<table>
<thead>
<tr>
<th>If the R/3 System</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>finds a hit</td>
<td>the phrase is displayed in the characteristic field.</td>
</tr>
<tr>
<td>finds several hits</td>
<td>The dialog box for input help appears. The results of the search are restricted according to the search criteria entered.</td>
</tr>
</tbody>
</table>

See: Editing the Input Help [Page 85]
Editing the Input Help

The input help consists of the following areas:

- the selected phrases (upper area)
- the rest of the phrase set (lower area)

You can use the editing functions displayed as symbols in the dialog box:

You use the Cut and Paste functions to move phrases

- within the areas
- between the areas

You can move a phrase by double-clicking on it.

<table>
<thead>
<tr>
<th>Function</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>All selected phrases are transferred to the clipboard.</td>
</tr>
<tr>
<td></td>
<td>Phrases with single values are transferred to substance characteristic value assignment immediately.</td>
</tr>
<tr>
<td>Paste</td>
<td>Position the cursor. All phrases in the clipboard are inserted above the cursor.</td>
</tr>
<tr>
<td>Find</td>
<td>You can search for</td>
</tr>
<tr>
<td></td>
<td>- complete phrase keys</td>
</tr>
<tr>
<td></td>
<td>- complete words</td>
</tr>
<tr>
<td></td>
<td>You cannot search generically.</td>
</tr>
<tr>
<td>Sort in ascending order</td>
<td>Position the cursor on the column to be sorted and choose Sort in asc. order.</td>
</tr>
<tr>
<td>Text/Long text</td>
<td>You can switch between short and long text display.</td>
</tr>
<tr>
<td>Print</td>
<td>You can print the list.</td>
</tr>
</tbody>
</table>
Editing Assessments

Prerequisites

If no data record has been created for the substance characteristic category, you create a data record as follows:

1. Enter the number of the sort sequence (1, for example) for your first data record in the SS (sort sequence) field.
2. Choose ENTER.
   The R/3 System makes the characteristic fields ready for input.

Procedure

1. On the Edit Substance: Characteristic Values screen, choose Extras → Assessment.
   The Edit Substance: Assessment screen appears.
2. Select the desired assessment.
   
   In Customizing for Product Safety, define which assessment is selected as default.
3. Choose ENTER and save your changes.
Assigning Sources

Prerequisites

- Sources are imported to source management, or created manually.
  See also: Source Management [Page 60]

- If no data record has been created for the substance characteristic category, you create a data record as follows:
  1. Enter the number of the sort sequence (1, for example) for your first data record in the SS (sort sequence) field.
  2. Choose ENTER.
     The R/3 System makes the characteristic fields ready for input.

Procedure

1. On the Edit Substance: Characteristics screen, choose Extras → Source.
   The Edit Substance: Source screen appears.

2. Enter the required data.

3. Choose ENTER and save your changes.
Editing User-Defined Texts

Prerequisites
If no data record has been created for the substance characteristic category, you create a data record as follows:

1. Enter the number of the sort sequence (1, for example) for your first data record in the SS (sort sequence) field.
2. Choose ENTER.
   The R/3 System makes the characteristic fields ready for input.

Procedure
1. On the Edit Substance: Characteristics screen, choose Extras → User-defined texts.
   The Edit Substance: User-Defined Texts screen appears.
2. Enter the required data.
   To record a longer text, proceed as follows:
   Double-click on the User-defined text field to call the long text editor. Enter your text and save.
3. Choose Back.
   The Edit Substance: User-Defined Texts screen appears.
   - When you enter a long text, the system indicates this with a symbol. You can then edit the text using the text editor only.
   - For selected user-defined texts, you can use the editing functions in the Edit menu.
Processing Usages

Prerequisites
If no data record has been created for the substance characteristic category, you create a data record as follows:

1. Enter the number of the sort sequence (1, for example) for your first data record in the SS (sort sequence) field.
2. Choose ENTER.

   The R/3 System makes the characteristic fields ready for input.

Procedure

   The Edit Substance: Usage screen appears.
2. Enter a rating in the Rating field.
3. Choose ENTER.

   The system flags the last entry made with a checkmark.
4. You activate usage by flagging the “active” indicator (Act. ind.), if the corresponding substance characteristic values are permitted to appear on a substance report (See also: Usage [Page 46]).

   If you want to mark a change made to a characteristic value as relevant, set the relevance indicator (See also: Relevance Indicator [Page 48]).
5. Enter a validity area for the selected rating in the Validity area field.

   You can enter several validity areas for one rating.
6. Choose ENTER.

   – If you want to exclude the selected area from the validity area, set the exclusion indicator (Excl. ind.).
   – For selected validity areas, you can use the functions from the Edit menu.
7. Save your entries.

   The validity area displayed on the screen is always related to the rating marked with a checkmark. Click on the rating to display the validity area assigned to it.
Processing the Component Overview

Prerequisites

- You have selected a substance characteristic category of type *Substance composition* or *Substance listing*.
- If no data record has been created for the substance characteristic category, you create a data record as follows:
  1. Enter the number of the sort sequence (1, for example) for your first data record in the SS (sort sequence) field.
  2. Choose ENTER.

The R/3 System makes the characteristic fields ready for input.

Procedure

1. On the *Edit Substance: Characteristics* screen, choose Goto → *Component overview*.

   The *Edit Substance: Component Overview* screen appears.

2. Enter the required data.

3. Choose ENTER and save your changes.

Result

- For substance characteristic categories of type *Substance composition*, the R/3 System checks if
  - the lower limit is below the upper limit
  - the average value falls between the upper and lower limit
  - the total average value <= 100%

  The Value, Lower limit and Upper limit fields are only taken into account if an entry has been made there.

- If you have entered a sort sequence, the R/3 System sorts the components when generating substance reports according to this sequence (see also: Report Generation [Page 145]).
Phrase Management

Purpose

Phrase management supports the central management and translation of text modules called Phrases [Page 96]. You can use phrases to carry out the following language-independent activities:

- To record substance characteristic data: first aid measures, or r and s records, for example (See also: Substance Characteristic Value Assignment [Page 34])
- Output texts on substance reports (See also: Report Generation [Page 145])

Phrases are managed in phrase libraries, and one library is selected for data maintenance. You can update active phrases after importing a new version of the passive library by creating phrase references from the passive phrases to phrases in the active phrase library. In addition, the R/3 System enables you to compose the active library from phrases from several different passive libraries.

Integration

The R/3 component Interfaces supports phrase import and export in productive systems. This means that phrases can be translated outside the R/3 System, for example.

See also: Interfaces [Page 346]

You use engineering change management and change documents to assign validity areas to phrase changes, and to maintain text changes as language-dependent.
Phrase Management: Process

Purpose

See Phrase Management [Page 91].

Prerequisites

- To use phrases in the R/3 System, you can create them yourself, or import them.
  
  See also: Import and Export: Process [Page 348]

- You have entered at least one phrase library, and one phrase group in Customizing for Product Safety. You must specify one of the phrase libraries as the active phrase library.

  You can create phrase groups from the Product Safety screen by choosing Tools → Current settings.

- You have authorization to display or process the phrases.

Process Flow

See also: Function Model for Phrase Management [Page 95]

1. You can carry out the following activities in the initial Phrase management screens:

   - You can enter different search criteria, and start drill-down reporting for the required phrases. If the required phrases do not exist in the R/3 System, you can create it.

     The R/3 System enables you to define further search functions as user exits in Customizing for Product Safety.

   - You can create a phrase immediately.

   If you process or create phrases with engineering change management, you must enter a change number on the initial screen.

   For further information, see

   Phrase Search [Page 97]
   Phrase Engineering Change Management [Page 98]

   Procedure

   Searching for Phrases [Page 117]
   Creating Phrases [Page 119]

2. The results of the search are displayed in the hit list. In the hit list, you then process the phrases further, and create new ones.

   Procedure

   Editing the Phrase Hit List [Page 120]

3. When creating a phrase on the initial screen or from the hit list, you first enter the data for the phrase header.
In the phrase header, you can create **references** from phrases in the active phrase library to phrases in the passive phrase library.

From the hit list, you can copy an existing phrase as a **template**.

For further information, see

**Phrase Reference [Page 100]**

**Editing the Phrase Header [Page 121]**

**Copying Phrases [Page 122]**

4. **Phrase items** enable you to create phrase texts of any length, revise phrase codes and comments, and enter file names for graphics in predefined languages.

You specify the languages and the sequence of languages in the phrase items in **language selection**.

In **phrase set allocation**, you allocate phrases to phrase sets to enable phrases to be used as values for substance characteristics.

For further information, see

**Phrase Items [Page 101]**

**Editing Phrase Items [Page 123]**

**Editing the Language Selection [Page 124]**

**Phrase set allocation [Page 102]**

**Allocating Phrase Sets [Page 125]**

5. The following functions are available for existing phrases:

You can **merge phrases** if you import a more recent version of a passive phrase library.

You can

– update the active library for existing phrase references, as long as the passive phrases are used as phrase references

– create phrases from the passive phrase library in the active library

If you want to select one representative phrase for several similar phrases, choose **combine phrases**.

Changes made to phrase texts, codes and graphics in the R/3 System are logged in the **phrase history**.

Before you delete phrases, you should use a **where-used list** to check if the phrases are used as substance characteristic values or in a substance report. How and if phrases are **deleted** depends on whether phrases are used or not, and whether they belong to the active or passive phrase library.

For further information, see

**Merging phrases [Page 103]**

**Combining Phrases [Page 105]**

**Phrase History [Page 106]**

**Phrases: Where-Used List [Page 107]**

**Phrase deletion [Page 108]**

Procedure

**Merging Phrases [Page 126]**

**Combining Phrases [Page 128]**

**Displaying Phrase History [Page 129]**

**Creating Where-Used Lists for Phrases [Page 130]**
Phrase Management: Process

Result

- You can export phrases from the hit list.

  For further information, see
  Import and Export: Process [Page 348]

- To use phrases as substance characteristic values, you allocate the phrases to phrase sets.

  For further information, see
  Maintaining Phrase Sets [Page 110]
The search result of substance drill-down reporting is displayed in a hit list from which you can call phrase management functions:

- Phrase header
- Phrase items
- Phrase sets: Assignment

You can also use the Create function in both the initial screen and the hit list.

**Function model for phrase management**

![Diagram of function model for phrase management]
Phrases

Definition

Standardized text required to assign values to characteristics, or used as text modules on substance reports. You can translate phrases into all languages defined in Product Safety Customizing. In addition, you can also use a phrase to create a link to a graphic.

Structure

- A **phrase library** defines phrase assignment and origin.
  
  You can only use phrases from the active phrase library for characteristic value assignment. The R/3 System enables you to import purchased or company-specific phrase libraries into the R/3 System, and to merge [Page 103] them with the active phrase library.
  
  In the standard system, the back-up phrase library is delivered in which the R/3 System stores deleted phrases from the active phrase library.

- A **phrase group** is specified for each library so that phrases can be classified more precisely. Each phrase belongs to exactly one phrase group.

- A **phrase code** is a language-dependent abbreviation for a phrase (C for corrosive, for example).

- You can enter one or more **phrase references [Page 100]** for an active phrase.

Integration

Phrase management is integrated in **Phrase Set Management**.

See also: **Phrase set management [Page 110]**
Phrase Search

Use

You use the search functions to define criteria for phrases in the initial phrase management screen. All search criteria on the initial screen are linked by AND operations.

The results of the search are displayed in a hit list where you can restrict or extend the search results further. You can also create a phrase in the hit list.

Features

Search functions are delivered in the standard system that you can check in Customizing for Product Safety in Manage user exits. To define your own search functions, copy the appropriate search function and adapt it to fit your requirements.

You can use the following search fields and functions:

<table>
<thead>
<tr>
<th>Search field</th>
<th>Determines</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ref. phrase</td>
<td>Phrases with a particular reference phrase</td>
</tr>
<tr>
<td>Phrase set</td>
<td>Phrases that belong to a particular phrase set</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Search function</th>
<th>Determines</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phrase w/o selected language</td>
<td>Phrases that have not yet been translated in the language specified.</td>
</tr>
<tr>
<td>Phrase w/o phrase set assignment</td>
<td>Phrases to which no phrase set has yet been assigned.</td>
</tr>
<tr>
<td>Phrase changed or created</td>
<td>Phrases that are valid for a particular time interval, and were changed or created again.</td>
</tr>
</tbody>
</table>

For passive phrases, this enables you to search for phrases that were changed and are also being used as reference phrases in the active library. To do this, you can selection all phrases newly imported into the R/3 System.

You can then process phrases further using the Phrase Merge [Page 103] function

In the standard system, this search function is restricted to phrase items. You can also enter the following search areas manually:

- Phrase header
- Phrase references
- Phrase set assignment

Activities

Searching for Phrases [Page 117]
Phrase Engineering Change Management

Use

This function enables you to carry out data changes for a particular key date using a change number. Each change number is valid from a particular validity date so that the data have a validity period in accordance with the change number.

When you change existing data, the EH&S system creates a change comment that contains the person responsible for the change, and the change date.

- If you make changes **without using a change number**, the standard validity period used goes from 01.01.0001 to 31.12.9999. The system enters the current date as the key date.

- When you **use change numbers** for the first time, the R/3 System divides the overall validity period into two adjoining validity periods. Whenever you use other change numbers that feature different validity dates, the system carries out further subdivisions of validity periods.


Prerequisites:

From the **SAP R/3 System** screen, you have created a change number under **Logistics → Central functions → Engineering change management**.

Features

You can use engineering change management within R/3 phrase management to

- Import a more recent version of a phrase library
  
    You must enter the change number in the phrase import screen.

- Create and process phrases

  You must enter the change number in the initial phrase management screen.

  - The change number has higher priority than the key date.

Activities

You can do the following from within Phrase Management:

- You can obtain information, for example, about the **data origin [Page 64]** and **data owner / data provider [Page 65]**, by choosing *Extras → Administrative info*. 
To display the change documents for all phrases you have selected in the hit list, choose *Extras → ChangeDoc log*. The documents start from the key date minus 7 days. Date and time of, and person responsible for changes made to a phrase are recorded in a log.
Phrase References

Use

Using phrase references, you create a link between phrases whose contents are similar or identical.

In general, you can only assign a phrase from a passive library (passive phrase) to a phrase from an active library (active phrase) as a phrase reference.

Features

The following rules apply when creating phrase references:

- You can define one or several phrase references for one phrase.
- The R/3 System can only evaluate single-level references.
- Phrase references can not be defined manually between phrases in passive libraries. The links are created by the R/3 System when the phrases are imported, and can be exported and copied.

You can define phrase references between a passive and an active phrase as follows:

- You create a phrase reference for an active phrase without setting the $OT$ (Transfer original text) indicator.
  
  The R/3 System continues to use the text of the active phrase for characteristic value assignment.

- You create a phrase reference for an active phrase, and set the $OT$ (Transfer original text) indicator.
  
  The R/3 System overwrites the text of the active phrase with the text of the passive phrase, and copies the other language-dependent attributes to the active phrase. You use phrase history [Page 106] to display earlier valid versions.
  
  Any languages contained in the active phrase but not in the passive are not deleted. These changes can be carried out using change numbers.

- You use the Phrase Merge [Page 103] function to create a phrase from a passive phrase library in the active phrase library. The R/3 System retains the phrase origin via the phrase reference, and sets the $OT$ (Transfer original text) indicator.
  
  You can assign any number of phrase references to a phrase. However, you can only set the $OT$ (Transfer original text) indicator once.

Activities

Editing the Phrase Header [Page 121]
Phrase Items

Use

This function provides support for the translation of phrases.

Each language for a phrase exists as a phrase item containing the phrase text, phrase code, and possibly a link to a graphic.

Prerequisites

- You must have defined the translation languages in Specify language selection in Customizing for Product Safety.
- You must have authorization to process the phrases in a particular language. Phrases in languages for which you have no authorization are shown in display mode only.

Features

- You use a long text editor to enter texts of any length for each phrase item.
- You can also use the Language Selection function to restrict the translation languages, and choose the comparison language for translation. When you maintain phrases, the text appears in the comparison language in display mode in the long text editor.
  In addition, you can specify the sort sequence used for the languages.

Activities

Editing Phrase Items [Page 123]
Phrase Set Assignment

Use
This function provides support for the assignment of phrases from the active phrase library to phrase sets.
You can use phrases from a phrase set as value help when assigning values to a characteristic, if the phrase set has been assigned to a characteristic in Phrase Set - Characteristic Assignment [Page 114].

Prerequisites:
- You can only assign phrases from the active library to phrase sets.
- You must have defined the phrase sets in phrase set management.

Features
In phrase management, the R/3 System enables you to assign phrases to phrase sets as follows:
- In phrase set assignment, you can assign any number of phrase sets to a phrase.
- You can flag any number of phrases in the hit list, and assign these to a phrase set simultaneously.

If you delete a phrase's assignment to a phrase set, but assign the phrase as a value to a substance characteristic, you can only change or save the assignment if you assign another value to the characteristic. Otherwise, you can simply cancel the characteristic assignment altogether.

Activities
Assigning Phrase Sets [Page 125]
**Merging Phrases**

**Use**
This function supports the following activities:

- If phrase references have been defined between active and passive phrases, the active phrases can be updated after a more recent version of the passive phrase library has been imported. You use the *Phrase changed/created* search function to select the changed phrases within a passive phrase library. The phrases selected can then be updated in the active library using the *Merge* function.

- If a new version of a passive phrase library has been installed, you can search for the phrases created using the *Phrase changed/created* function. The phrases can be selected and transferred to the active library using the *Merge* function.

  In this way, you can construct an active library from phrases from different passive libraries, for example

**Prerequisites**
The phrases that you want to merge must belong to a passive phrase library.
You can select the phrases to be merged or updated using the *Phrase changed/created* search function.

**Features**

**Assigning a phrase key**

- To update active phrases, you can select the key for the particular active phrase as follows:
  - If the passive phrases are used as phrase references, the function automatically lists the corresponding active phrase for each passive phrase.

    The R/3 System then searches for phrase references with original text transfer. If it does not find any, it searches for phrase references without original text transfer. The first active referencing phrase is displayed.

  - If the R/3 System could not allocate an active phrase via the phrase reference, you can also use the *Determine target phrase* function to look for active phrases whose contents are identical to the passive phrases.

    Phrases with identical contents are all phrases whose first 132 characters correspond in the language displayed (without taking case or special characters into account).

  - You can enter the phrase key for an existing active phrase manually.

On the merge screens, you can also decide which of the passive phrases with the *OT* (transfer with original text) indicator should be merged. For reference phrases that are already being used with the *OT* indicator, the R/3 System automatically proposes the *OT* indicator.
Merging Phrases

To create passive phrases in the active library, you can create the key for a new active phrase as follows:

- Transfer the passive phrase key
- Reassign the phrase key in the R/3 System
- Assign the phrase key manually

The R/3 System checks the phrase key against the external number range interval that is defined in Customizing for Product Safety.

If the phrase group is not entered for a new phrase, this is obtained from the passive phrases. If the phrase group does not yet exist in the active library, the phrase group is created in the active library.

Processing

When updating existing active phrases, the data is processed as follows:

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>The OT indicator is set,</td>
<td>The Merge function overwrites all phrase items (phrase text, code, remark) that exist in the languages for the passive phrase. You should check the other languages. The OT indicator is transferred.</td>
</tr>
<tr>
<td>The OT indicator is not set,</td>
<td>The phrase items for the active phrase are retained. The OT indicator is not set,</td>
</tr>
</tbody>
</table>

You can display the former phrase text using the phrase history.

When creating active phrases, data is processed as follows:

The Merge function creates a phrase reference for the new active phrase to the passive phrase with the OT (transfer original text) indicator, and adopts its phrase items.

Activities

Merging Phrases [Page 126].
Combining Phrases

Use
This function enables you to select a representative phrase for similar phrases in the active phrase library, and to store the other similar phrases in a back-up phrase library.

Prerequisites
You can only combine phrases in the active library.

Features
This function takes the following cases into account:

<table>
<thead>
<tr>
<th>If the phrases to be replaced</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Have phrase references</td>
<td>These are transferred to the representative phrase.</td>
</tr>
<tr>
<td></td>
<td>Phrase references with original text transfer are transferred as phrase references without original text transfer.</td>
</tr>
<tr>
<td>Are used as characteristic values</td>
<td>They are replaced by the representative phrase.</td>
</tr>
<tr>
<td>Have phrase items that do not occur in the representative phrase</td>
<td>These items are not copied to the representative phrase.</td>
</tr>
</tbody>
</table>

⚠️ If a phrase that is to be replaced is used in a substance report, it must be replaced manually with the representative phrase. You can use the Where-Used List [Page 107] to determine the substance report that is affected before combining the phrases.

Before combining, you must first make sure that the representative phrase is present in the same language as the previous phrases.

Activities
Combining Phrases [Page 128]
Phrase History

Use
The function enables you to compare current phrase versions with previously valid versions. The history is displayed in relation to the day on which changes were made according to the creation of change documents.

Features
The function compares the current phrase text and code for all languages with the previously valid phrase texts and codes. Changes to graphics are also displayed. The phrase history is output in list form. You can sort the list, and configure the columns as required.

- The first line of a phrase history contains entries for
  - Phrase keys and phrase groups
  - Validity periods and change dates for the phrase header
  - The data origin

- The second level contains entries for
  - Language, phrase text and code
  - Validity periods and change dates for the phrase text

Activities
Displaying Phrase History [Page 129]
Phrases: Where-Used List

Use

This function determines if a phrase is used.

- as a characteristic value
- as a phrase on a substance report template

Before deleting a phrase, the R/3 System produces a where-used list for the entire time axis. The phrase is not deleted if it is used as a characteristic value or on a report.

See also: Phrase Deletion [Page 108]

Features

The where-used list supplies the following information

- for selected characteristics
  - Substance key and identifiers
  - Substance characteristic category with label
  - Validity period, person responsible for changes, sort number, characteristic

- for substance report templates:
  - Document number of template with version
  - Generation variant with label
  - Validity period, person responsible for changes, validity area, report type

Activities

Creating Where-Used Lists for Phrases [Page 130]
Phrase Deletion

Use

This function controls the reaction of the R/3 System when you attempt to delete phrases. The function takes into account:

- Whether the phrases are used as characteristic values
- Whether the phrases come from the active or passive phrase library

Before you delete a phrase, you should create a Where-Used List for Phrases [Page 107]. In this way, you can, for example, determine the report templates on which the phrase is used.

Features

If you want to delete a phrase, one of the following system reactions will occur:

<table>
<thead>
<tr>
<th>The phrase belongs to the active library</th>
<th>The phrase is in use</th>
<th>Reaction of the R/3 System</th>
</tr>
</thead>
<tbody>
<tr>
<td>yes</td>
<td>yes</td>
<td>All allocations of the phrase to phrase sets are deleted. The phrase itself is not deleted. This results in the following: If the phrase is used in substance characteristic values, the system continues to display the phrase. The substance characteristic values can only then be edited and saved again if a phrase is allocated that actually exists in the phrase set.</td>
</tr>
<tr>
<td>yes</td>
<td>no</td>
<td>All allocations of the phrase to phrase sets are deleted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- If a phrase has a reference to a passive phrase and the OT (transfer original text) indicator is set (origin of phrase is a phrase in the passive library), the phrase with phrase references from the active library is deleted and is retained in the passive library.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- If the phrase has no reference with the OT indicator (phrase was created or imported in the active library), the phrase is moved together with its references from the active library to the backup library.</td>
</tr>
</tbody>
</table>
### Phrase Deletion

<table>
<thead>
<tr>
<th>no</th>
<th>yes</th>
<th>Phrases from a passive library that are in use may not be deleted.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>A user has up to now been using the system DEMO. In this system, substances are present that have been assigned characteristic values from the DEMO phrase library. First, the user imports the DEMO phrase library as the passive library. Then, the user imports the DEMO substances that could contain characteristic values that refer to the passive DEMO library. These DEMO phrases are thus used.</td>
</tr>
<tr>
<td>no</td>
<td>no</td>
<td>The phrase is deleted from the passive library. If the phrase is used as a reference phrase, the key of the passive reference phrase remains in the header of the relevant active phrase. The fact that the passive phrase no longer exists is irrelevant.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Phrase reference with <em>OT</em> indicator: The phrase items are copied from the reference phrase and are retained.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Phrase reference without <em>OT</em> indicator: The key of the passive phrase is displayed only.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This results in the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- The origin of the active phrase is documented.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Phrase conversion can be used when importing substances.</td>
</tr>
</tbody>
</table>
Phrase set management

Purpose

In this process, you group phrases from the active phrase library that are to be used as substance characteristic values.

After a phrase set has been assigned to a characteristic, you can use the phrases in this phrase set as possible entries for characteristic values.

In the active phrase library, you can import assignments between phrases and phrase sets into the R/3 System additively, or export them to the transfer file.

Prerequisites

- You have created the phrases in the active phrase library in phrase management [Page 92].
- The characteristics to which you want to assign phrase sets must be of data type CHAR30, and belong to a substance characteristic category in the properties tree.

See also:
- Setting up Substance Characteristic Categories and Characteristics
- Phrase Set - Characteristic Assignment [Page 114]
- Overview of Phrase Set - Characteristic Assignment [Page 115]

- You must also have the authorization to maintain phrase sets.

Process flow

See also: Function Model for Phrase Set Management [Page 112]

1. You can carry out the following activities in the initial Phrase management screens:
   - You can enter different search criteria, and start drill-down reporting for the required phrase sets. If the required phrase set does not exist in the R/3 System, you can create it.
   - You can create a phrase set immediately.

   Procedure
   - Searching for Phrase Sets [Page 131]
   - Creating Phrase Sets [Page 132]

2. The results of the search are displayed in the hit list. In the hit list, you then process the phrase sets further, and create new ones.

   Procedure
   - Processing the Phrase Set Hit List [Page 133]

3. When creating a phrase set on the initial screen or from the hit list, you first enter the data for the phrase set header.

   You can copy an existing phrase set as a template.
4. In labels for phrase sets, you can translate a short description of your phrase set into the languages you have defined in Customizing for Product Safety.

Procedure
Maintaining Phrase Set Labels [Page 136]

5. You can assign phrases to the phrase sets you have created in phrase assignment.

Procedure
Phrase Assignment [Page 113]   Assigning Phrases to a Phrase Set [Page 137]


Procedure
Assigning Phrase Sets to Characteristics [Page 138]
Function Model for Phrase Set Management

The search result of phrase set drill-down reporting is displayed in a hit list from which you can call phrase set management functions:

- Phrase set header
- Phrase set label
- Phrase assignment

You can also use the Create function in both the initial screen and the hit list.

Function model for phrase set management

See also:
Phrase set management [Page 110]
Phrase Assignment

Use
This function enables you to define the value set for phrase sets.

Integration
To be able to use a phrase set as value help for a substance characteristic value, you must have assigned the phrase set to the corresponding characteristic (see Phrase Set - Characteristic Assignment [Page 114]).

Features

- The *phrase assignment* function lists the phrases in the phrase set. You can
  - assign more phrases or delete existing assignments
  - specify the sort sequence

- The R/3 System ensures that you only assign a phrase once to a particular phrase set.

- However, you can assign a phrase to several different phrase sets at the same time.

  You can also define assignments between phrases and phrase sets in phrase management (see Phrase Set Assignment [Page 102]).

Activities
Assigning Phrases to a Phrase Set [Page 137]
Phrase Set - Characteristic Assignment

Use
This function enables you to assign the following to the characteristic of a substance characteristic category:

- a phrase set
  This makes the phrases in the phrase sets available as a value set for assigning characteristic values.

- a user-defined text category
  This enables you to assign user-defined texts as values to this characteristic in the relevant user-defined text category.

See also: Overview of Phrase Set - Characteristic Assignment [Page 115]

Prerequisites
- The characteristics must be of data type CHAR30, and belong to a substance characteristic category in the properties tree.
  See also: Setting up Substance Characteristic Categories and Characteristics [Page 36]

- To ensure that the R/3 System updates the display of characteristics to which phrase sets can be assigned, you must carry out one of the following functions:
  - Adjust char. cat. - char. in Adjust master data
    See also: Master Data Adjustment [Page 255]
  - Adjust charac. in Characteristics Alloc. to Phrase Set

- You must have activated phrase-related characteristics in master data adjustment.

- You must have created the phrase sets in phrase set management.
  See also: Phrase set management [Page 110]

- To assign user-defined text categories, you define in Customizing for Product Safety which user-defined text categories may be assigned to a characteristic.

Features
First you select the substance characteristic category using the properties tree.

All characteristics to which you can assign phrase sets or user-defined text categories are listed for the selected substance characteristic category.

Activities
Assigning Phrase Sets to Characteristics [Page 138]
Overview of Phrase Set - Characteristic Assignment

Phrase set - characteristic assignment links phrase-related characteristics with phrase sets. The phrases that are assigned to a phrase set constitute the value set that you can use for characteristic value assignment.

Graphic: phrase set - characteristic assignment
Phrase Management: Procedures

Procedures for phrases

Searching for Phrases [Page 117]
Creating Phrases [Page 119]
Editing the Phrase Hit List [Page 120]
Editing the Phrase Header [Page 121]
Copying Phrases [Page 122]
Editing Phrase Items [Page 123]
Editing the Language Selection [Page 124]
Allocating Phrase Sets [Page 125]
Merging Phrases [Page 126]
Combining Phrases [Page 128]
Displaying Phrase History [Page 129]
Creating Where-Used Lists for Phrases [Page 130]

Procedures for phrase sets

Searching for Phrase Sets [Page 131]
Creating Phrase Sets [Page 132]
Processing the Phrase Set Hit List [Page 133]
Processing the Phrase Set Header [Page 134]
Copying Phrase Sets [Page 135]
Maintaining Phrase Set Labels [Page 136]
Allocating Phrases to a Phrase Set [Page 137]
Allocating Phrase Sets to Characteristics [Page 138]
Searching for Phrases

1. From the Product Safety [Ext.] screen, choose one of the following paths:
   - Phrases → Edit phrases
   - Phrases → Display phrases.

   The initial screen appears. You can start substance drill-down reporting from here.
   During the search, all entries are linked with AND.

   The system supports the language-dependent full-text drill-down reporting in the Phrase code and Phrase text fields.

   If the symbol for a generic search (*) is placed to the right of the search string in the Phrase text field, then only the first 132 characters of a phrase are sought (Physician*, for example). If not, a full-text search is carried out (Phys"ician*, for example, or *Physician*).

2. Enter the required data, insofar as it is known to you. The R/3 System supports the search for any missing data as follows:
   - Right and left delimitation for phrase key with "*", for example, <*A15*>, for example.
   - Generic search by right and left delimitation with *, <*First*>, for example, for language-dependent texts.
   - Placeholder in the middle of a key. <BC+EF> stands for BCDEF or BC1EF, for example.
   - Combination of search methods, <*1234+678*>, for example.

   The search distinguishes between upper and lower case letters. You must therefore observe upper and lower case letters in the key.

   The language field is automatically set to the logon language. You can change it as required. If the phrase does not exist in the required language, it will be displayed in the language in which it was created.

3. Use the search functions under Limiting criteria for phrase selection:

   See also: Phrase Search [Page 97]


Result

In the hit list, the R/3 System lists the phrases that correspond to the search criteria.

If the R/3 System does not find the required phrase, you can enter new search criteria, or create the phrase yourself.
Searching for Phrases

See also:

Editing the Phrase Hit List [Page 120]
Creating Phrases

2. Enter a change number, if necessary, and check the key date.
   The change number has higher priority than the key date.
4. You must edit the phrase header: Editing the Phrase Header [Page 121].
   After carrying out drill-down reporting, you can create phrases from within the phrase management hit list using the Phrase → Create function.
Editing the Phrase Hit List

1. On the Product Safety [Ext.] screen, choose one of the following menu paths:
   - **Phrases → Edit phrases**
   - **Phrases → Display phrases.**

   The initial screen of the chosen transaction appears.

2. In the initial screen, specify your search criteria (see Searching for Phrases [Page 117]) and choose **Phrase → Navigation → Hit list.**

   The hit list appears.

   **See also: Basic Functions in the Hit List [Page 157]**

   - If a long text exists for a phrase, a long text icon is displayed. You can display the long text by double-clicking on the icon.
   - You can display a phrase list with the complete phrase texts in all available languages by choosing **Utilities → Long text print list.** The list can be printed in A4 portrait form.

3. Select the phrases that you want to edit.

   Selected phrases can be edited using the functions from the **Edit** menu.

4. You can edit the phrases further under **Goto** and **Extras.**

   - Within phrase management, you can display additional information (for example about **Data Origin [Page 64]** or **Data Owner/Provider [Page 65])** via **Extras → Administrative info.**
Editing the Phrase Header

Prerequisites
If you want to maintain phrases using a change number, you need to enter it on the initial phrase management screen.

See also: Phrase Engineering Change Management [Page 98]

Procedure
1. If you want to then choose
   create the phrase header  Phrase → Create on the initial screen or the hit list.
   edit the phrase header  Goto → Phrase header in the hit list, phrase set assignment, or on the phrase item screen.

   The relevant phrase header screen appears.

   ![Note]
   You can also select a phrase in the hit list, and use it as a copy template for a new phrase (See also: Copying Phrases [Page 122]).

2. Enter the required data. You can change the note, the phrase group and reference phrases in the phrase header of an existing phrase.

   Please observe the following when creating a phrase:

   Phrase  If you have not entered a key, the R/3 System assigns a key to the phrase after you have made the required entries and confirmed them.
   If you want to use the phrase as a characteristic value, you must enter the active phrase library. This is marked in input help.

   Phrase code  You can enter a phrase code when creating a phrase. Alternatively, you can create, edit, and translate phrase codes on the Phrase items screen.

   Phrase text  Enter a phrase text of up to 132 characters. You can create additional long text in Phrase items.

   Reference phrases  If you want to use a reference phrase text, set the OT (original text) indicator.

3. Choose ENTER and save your changes.

Result
The R/3 System also completes the administrative data.

The validity period is set according to the change number specified. If no change number was entered, the validity period is unlimited.
Copying Phrases

Prerequisites
You can copy phrases within a library.

Procedure
1. In the Product Safety [Ext.] screen, choose Phrases → Edit phrases.
2. Enter your search criteria (see Searching for Phrases [Page 117]) and choose Phrase → Navigation → Hit list.
3. In the hit list, select the phrases you want to copy.
   The Copy from... screen dialog box appears.
5. In the Target phr. field, enter a new phrase key or leave the Target phr. field blank if the R/3 System is to assign a key.
6. Choose Enter.
   The phrase copied is added to the hit list with the new phrase key.
7. Save your entries.

Result
The phrase is copied together with all phrase texts.
Allocations to phrase sets and phrase references are not copied.
Editing Phrase Items

1. In the hit list for the selected phrases, in the phrase header, or in phrase set assignment, choose Goto \(\rightarrow\) Phrase items.
   
   The Edit Phrase: Items screen appears.

   ![Icon](image)

   In the Changed on field, the R/3 System displays the date of the last change made to a phrase item.

2. Enter the first 132 characters of your text in the Phrase text field in the languages specified.

3. To create the long text, choose one of the following:
   
   - Double-click on the Phrase text field to open the text editor for maintaining long texts.
   - Place the cursor on the field, and choose Goto \(\rightarrow\) Long text.

4. Enter your text, save, and choose Back.

   ![Icon](image)

   If you record a long text, the system displays an icon to indicate this at the end of the Phrase text field. In this case, the phrase text can only be processed in the long text editor.

5. If necessary, edit the Phrase code, Note, and Graphic fields.

   ![Icon](image)

   Enter the complete file name of your graphic with the file extension in the Graphic field. The system uses these file names when you generate a substance report.

   Check whether the file exists in sub-directory GRAFICS in the WWI directory on your WWI PC.

6. Choose ENTER and save your changes.

7. If you want to change the language, choose Utilities \(\rightarrow\) Language selection (See also: Editing the Language Selection [Page 124]).
Editing the Language Selection

1. From the Edit Phrase: Items, choose Utilities → Language selection.
   The Phrase Management: Language Selection dialog box appears.

2. In the Sequence field, select the required language display item for each language.

3. Set the Disp. lang (display language) indicator for the languages in which the phrase items are to be displayed.
   You can set the C (comparison language) indicator for the language that is to be used as comparison language for translation in the long text editor. The phrase is then displayed in the comparison language in the long text editor. If you do not set the indicator, the source language of the phrase is used as the comparison language.

4. Choose Enter.

Result
The settings you have made are transferred to the Edit phrase: Items screen. The settings remain until you have exited the phrase editing transaction.
Assigning Phrase Sets

To assign a phrase to several phrase sets, proceed as follows:

1. In the hit list for the selected phrases, in the phrase header, or in phrase set assignment, choose Goto → Phrase set alloc.
   The Edit Phrase: Phrase Set Assignment screen appears.
2. In the Phrase set field, choose the key for the phrase set to which you want to assign the phrase.
3. Choose ENTER and save your changes.

To assign several phrases to one phrase set, proceed as follows:

1. In the phrase hit list, select the phrases to be assigned to a phrase set.
2. Choose Edit → Assign.
   The Assign phrases to phrase set dialog box appears.
3. Choose the phrase set key.
   Choose Continue and save your entries.

To check the assignment, choose Goto → Phrase set alloc.
   The Edit Phrase: Phrase Set Assignment screen appears.
If you call the phrases you selected previously using Previous phrase or Next phrase, the system automatically displays the assigned phrase set in the Phrase set field.
Merging Phrases

Prerequisites
You can only merge phrases in the passive phrase library.

You can carry out specific searches for changed or newly-created phrases on the initial phrase management screen. To do this, search for changed/created phrases by choosing Phrase (See also: Phrase Search [Page 97]).

Procedure
1. In the passive phrase hit list, select the phrases to be merged.
2. Choose Extras → Merge.
   A dialog box appears in which the selected passive phrases are listed.

You update active phrases as follows:
3. If a passive phrase is used as a phrase reference then the R/3 System assigns the corresponding active phrase.
   If a passive phrase is not used as a phrase reference you can assign an existing active phrase, or you can choose Det. target phrase.
   The R/3 System searches the first 132 characters of all phrases in the active phrase library and lists the first phrases that it finds with contents identical to those in the passive library.
   This activity can take some time.

   You update the dialog box by choosing Refresh.
   You can compare the phrase texts for passive and active phrases by choosing the long text icon.
4. Decide if you want to select or deselect the OT (transfer original text) indicator.
5. Select the passive phrases you want to merge.
6. Choose ENTER.

You create active phrases as follows:
3. If the R/3 System lists passive phrases in the dialog box to which no existing active phrases can be assigned, you can assign keys for new active phrases as follows:
   – You transfer the passive phrase key by choosing Adopt phrase ID.
If you do not enter a phrase group for the new active phrase, the phrase group for the passive phrase is adopted. If the phrase group does not already exist in the active library, it is then created.

– You can assign a new key yourself.
– If you leave the Phrase field empty, the R/3 System assigns a key itself.

4. Select the passive phrases you want to merge.
5. Choose ENTER.

Result
The phrases you have selected in the dialog box are either merged, or created in the active library.

The changed and created active phrases are added to the current hit list. This means that you can call substance headers and phrase items to check the data.

For newly created phrases, the R/3 System creates phrase references to the corresponding passive phrases, and sets the OT indicator.
Combining Phrases

**Combining Phrases**

**Prerequisites**
Before combining phrases, you should generate a where-used list.
The phrases must belong to the active phrase library.

**Procedure**
1. In the phrase management hit list, select the phrases that you want to combine.
2. Choose *Extras → Combine*.
   A dialog box appears in which the phrase keys and texts for the selected phrases are displayed. To display the long text, choose the long text symbol.
3. Select the desired representative phrase.
4. Choose *ENTER*.

**Result**
The R/3 System adopts the phrase selected as a representative phrase, and transfers the remaining phrases to the backup library.

*(See also: range of functions in Phrase Combination [Page 105]*)
Displaying Phrase History

1. In the phrase management hit list, choose Utilities → History.
   The history for all phrases on the hit list appears. The currently valid text is shown in red.

2. To display the long text for each currently valid phrase, choose Goto → Long text.
   The current phrase corresponds to the search parameters in the initial phrase management screen. You can display these parameters by choosing Utilities → Search parameters.

3. To change the column selection, choose Utilities → Column selection.
   The R/3 System displays the current column selection. You can tailor this to suit your own requirements.

   To return to the original setting for column display, choose Utilities → Return to original.

💡

You can display a phrase list with the complete phrase texts in all available languages by choosing Utilities → Long text print list. The list can be printed in A4 portrait form.
Creating Where-Used Lists for Phrases

1. In the phrase management hit list, select the phrases for which you want to create a where-used list.
2. Choose Extras → Where-used list.
   
   The R/3 System carries out an authorization check. An expandable tree appears. All phrase-related characteristics and all substance report templates containing your phrases are shown.
Searching for Phrase Sets

1. On the Product Safety [Ext.] screen, choose one of the following menu paths:
   - Phrases → Edit phrase sets
   - Phrases → Display phrase sets.

   The corresponding initial screen appears. You can start drill-down reporting from here. During the search, all entries are linked with AND.

2. Enter the required data you know.
   - The R/3 System supports generic searches, *K15*, for example.
   - If you want to find all phrase sets assigned to a particular phrase, specify search criteria for this phrase: The phrase must belong to the active phrase library.
   - In the Description, Phrase code, and Phrase text fields, ensure you use the correct small and capital letters.

3. Choose Phrase set → Hit List.

   See also: Processing the Phrase Set Hit List [Page 133]
Creating Phrase Sets

   The Edit Phrase Set: Initial Screen appears.

2. Choose Phrase set → Create.
   The Create Phrase Set: Header screen appears.

3. You must now edit the phrase set header (See also: Processing the Phrase Set Header [Page 134]).

   ![Tip]

   You can create phrase sets from within the hit list after drill-down reporting by choosing Phrase set → Create.
1. On the Product Safety [Ext.] screen, choose one of the following menu paths:
   - Phrases → Edit phrase sets
   - Phrases → Display phrase sets.
   
   The initial screen of the chosen transaction appears.

2. In the initial screen, specify your search criteria (see Searching for Phrase Sets [Page 131]) and choose Phrase set → Hit list.

   The hit list appears.

   Choose Utilities → Search parameters to display the search parameters used to generate the current list.

   If the search result does not meet your requirements, choose Phrase set → Other selection to trigger a new search.

3. Select the phrase sets that you want to edit.

   Selected phrase sets can be edited using the functions from the Edit menu.

4. Choose the functions from the Goto menu to carry out further editing:
   
   – Processing the Phrase Set Header [Page 134]
   – Maintaining Phrase Set Descriptions [Page 136]
   – Assigning Phrases to a Phrase Set [Page 137]

   Within phrase set management, you can call additional information for a phrase set by choosing Utilities → Administrative info.
Processing the Phrase Set Header

1. If you want to create the phrase set header
   Then In the Edit Phrase Set: Initial screen, or in the phrase set management hit list, choose Phrase set → Create.

2. Edit the phrase set header
   Choose Goto → Phrase set header in the phrase set hit list, phrase set label, or on the phrase allocation screen.

   The system takes you to screen Create Phrase Set: Header or Edit Phrase Set: Header.

   When you create new data, you can use as an existing phrase set as a template (see Copying Phrase Sets [Page 135]).

3. Enter data as required.

   When creating new data, you can enter a user-defined key in the Phrase set field. If you have not entered a key, the R/3 System allocates a key to the phrase set after you have made the required entries and confirmed them.

3. Choose ENTER and save your changes.

Result

The R/3 System completes the administrative data.
Copy the Phrase Sets

   The Edit Phrase Set: Initial Screen appears.
2. Enter your search criteria (See also: Searching for Phrase Sets [Page 131]) and choose Phrase set → Hit list.
3. In the hit list, select the phrase sets you want to copy.
4. Choose Edit → Copy.
   The Create Phrase Set: Header screen appears.
5. Assign a new key, and complete the required data.
6. Save your entries.

**Result**
The R/3 System copies the phrase set you have selected, together with
- the descriptions for the phrase set
- the phrases assigned to it
Maintaining Phrase Set Descriptions

1. In the hit list for the selected phrase sets, in the phrase header, or in phrase set assignment, choose Goto → Phrase set description.
   
The Edit Phrase Set: Descriptions screen appears.

2. Enter the desired language key in a field in the Lan column.

3. Enter the translated description for the phrase set in the Description field.

   You can use the functions from the Edit menu for selected lines.

4. Choose ENTER and save your changes.
Assigning Phrases to a Phrase Set

1. In the hit list for the selected phrase sets, in the phrase set header, or in phrase set descriptions, choose Goto → Phrase assignment.

   The Edit Phrase Set: Phrase Assignment screen appears.

2. Place the cursor in a Phrase field, and enter the desired phrase.

3. Enter the desired sort sequence in the Sort field.

4. Choose ENTER and save your changes.
Assigning Phrase Sets to Characteristics

Prerequisites

If you have created new characteristics you must carry out Adjust characteristic category - characteristic in master data adjustment. Among other things, this function deletes all characteristics that are still listed in the phrase set - characteristic - assignment but that no longer exist in the R/3 System.

Procedure

1. Choose one of the following:
   – In the phrase set header, phrase set descriptions, in phrase assignment, or in the phrase set hit list, choose Utilities → Char. assignment
   – On the Product Safety [Ext.] screen, choose Phrases → Assign PhrSet-Char.
   The properties tree appears.

2. Place the cursor on the desired substance characteristic category, and choose Edit → Choose.
   The R/3 System lists all characteristics for that substance characteristic category.

   You can use the characteristic category - characteristic adjustment function from master data adjustment on this screen. To do this, choose Utilities → Adjust charac.

3. Enter the key for the required phrase set in the Phrase set field.

   In addition, you can assign a user-defined text type to each characteristic if you have set the characteristic-dependent indicator for the user-defined text type in Customizing for Product Safety.

   See also: User-Defined Texts [Page 44]

4. Choose ENTER and save your changes.
5. Choose Back.
Master Data Adjustment

Use

The R/3 Product Safety component provides the following functions in Master Data Adjustment:

- **Adjusting Characteristic Categories and Characteristics** [Page 142]
  
  This function determines all characteristics with data type CHAR30 and to which phrases can be allocated. These characteristics are transferred to characteristic - phrase set allocation where you can allocate corresponding phrase sets (See also: Phrase set - characteristic allocation [Page 114]). At the same time, the system deletes all characteristics that still exist in the allocation but no longer in the R/3 System.

  Use this function if you have created new characteristics for a class of class type 100 (substance characteristics) in the R/3 component Classification System.

- **(De)activating Phrase-Related Characteristics**
  
  This function allocates a special dialog box as possible entries function to all characteristics to which a phrase set was allocated in phrase set - characteristic allocation. You use this dialog box to allocate phrases of the assigned phrase set to the characteristic.

- **Generating Symbols** [Page 141]
  
  You define report templates using symbols (See also: Symbols [Page 223]).

  Master data adjustment enables you to automatically generate symbols for each characteristic, table field and structure field. For example, if you have created new characteristics for a substance characteristic category, you can use this function to generate symbols for these characteristics.

  ![Tip](Tip.png)

  When generating symbols, the system takes all table fields into account that have been defined in the IMG activity Define R/3 tables for symbol generation in Customizing for Product Safety.

  You will also find information about important tables and structure fields in Output Data in SD [Page 311]

- **Regenerating symbol labels**
  
  When you choose the Generate symbols function, the R/3 System generates symbol labels in the logon language. To generate the label subsequently in a different language, you can use the Regenerate symbol labels function.

- **Adjusting Symbols and Phrase-Related Characteristics** [Page 143]
  
  This function updates the symbol definitions for characteristic symbols that have been changed from non phrase-related to phrase-related (or vice versa).

  For phrase characteristics, the system sets the substance report symbol group to 00 in Product Safety Customizing.

  (You can check the Customizing entries in the detail screen of the IMG activity Check and define report symbols).

- **Deletion indicator**
Master Data Adjustment

The R/3 System sets the missing deletion indicators.

- Physically delete data
  
  This indicator is used to physically delete data that has been marked as deleted.
Generating Symbols

1. From the Product Safety [Ext.] screen, choose Tools → Adjust master data.
   The Adjust Master Data screen appears
2. Flag Generate symbols.
   Choose Execute.

   During symbol generation, all table fields are taken into account that are entered in
   the IMG activity Specify R/3 tables for report symbol generation in Customizing for
   Product Safety.

   The system displays a result message after it has completed the program.

   Choose Program → Exec. in background to make the Background Print Parameters
   dialog box appear. Use this dialog box to specify your print parameters. Now choose
   Save. The system schedules the print job. The system prints the results of the job
   after its completion. In the meantime, you can continue working in the system.
Adjusting Characteristic Categories and Characteristics

1. From the Product Safety [Ext.] screen, choose Tools → Adjust master data. The Adjust Master Data screen appears.

2. Flag Adjust characteristic category - characteristics. Choose Execute.

The system generates a message on the:

- Number of new characteristic category - characteristic combinations
- Number of unchanged characteristic category - characteristic combinations
- Number of deleted characteristic category - characteristic combinations

Choose Program → Exec. in background to make the Background Print Parameters dialog box appear. Use this dialog box to specify your print parameters. Now choose Save. The system schedules the print job. The system prints the results of the job after its completion. In the meantime, you can continue working in the system.
Adjusting Symbols and Phrase-Related Characteristics

1. From the Product Safety [Ext.] screen, choose Tools → Adjust master data.
   The Adjust Master Data screen appears
2. Flag Adjust symbol-phr-rltd. characteristic.
   Choose Execute.
   The system generates a message on the number of changed symbols.
Report Generation

Purpose

This process enables you to output data from the R/3 substance database and other R/3 modules, and graphic symbols on reports. You can use R/3 phrase management to store text modules on the report as language-independent.

You use a modified version of Microsoft Word (Windows Wordprocessor Integration (WWI)) to form the layout of the reports.
Report Generation: Process

Purpose
See: Report Generation [Page 144].

Prerequisites
- To use report templates, you can create them yourself, or import them (see: Import and Export: Process [Page 348])
- You must have the authorization to edit and display report templates and generation variants.

Process flow
Firstly, you create a document template. The process for report templates, cover sheet templates and acknowledgements of receipt is the same.

You use WWI to define the layout of the document template.

You use the Generation Variant [Page 250] to link document template and usage. In this way you can ensure that only permitted values are output on the substance report.

Procedure
Maintaining Document Templates [Page 146]
Maintaining Document Template Layouts [Page 159]
Maintaining Generation Variants [Page 204]

Result
You can use the generation variant to create a report request for a substance, and to start report shipping after a report has been released.

More information
Report Management [Page 258]
Report Shipping [Page 290]

See also: Report Creation Procedure [Page 221]
Maintaining Document Templates

Purpose

You use the document templates to specify the layout of the substance reports. In the R/3 System, in addition to report templates, you can also create cover sheets and acknowledgements of receipt.

Prerequisites

- To use report templates in the R/3 System, you can create them yourself, or import them. You can import sample templates using the IMG activity Import sample templates in Customizing for Product Safety (see: Export and Import [Page 348]).
- You must have the authorization to edit and display document templates.

Process flow

1. You can carry out the following activities in the initial document template management screens:
   - You can enter different search criteria, and start drill-down reporting for the required document templates. If the required document template does not exist in the R/3 System, you can create the report template.
   - You can create a document template immediately.

   More information
   Document Types in Substance Reporting [Page 213]
   Procedure
   Searching for Document Templates [Page 149]
   Creating Document Templates [Page 150]

2. The results of the search are displayed in the hit list. In the hit list, you then process the document templates further, and create new ones.

   Procedure
   Processing the Document Template Hit List [Page 151]

3. When creating a report template on the initial screen or from the hit list, you first enter the data for the document template header.

   You can copy an existing document template as a template.

   Procedure
   Processing Document Template Headers [Page 152]
   Copying Document Templates [Page 153]

4. You maintain a description of the document template in different languages using the Label function.

5. To edit a document template layout, you start a modified version of Winword (Windows Wordprocessor Integration (WWI)) from the R/3 System.
You can define the layout of the document template. In addition, if you have allocated the report template to a generation variant, and it has either status Released or In work, you can simulate and print a preview of the expanded layout of the final report.

You cannot simulate cover sheet templates and acknowledgments of receipts before they have been generated to final versions.

More information
- Maintaining Document Template Layouts [Page 159]
- Maintaining Generation Variants [Page 204]

You can use released report templates for generating reports (See: Report Management [Page 258]).
Document Templates: Procedures

Searching for Document Templates [Page 149]
Creating Document Templates [Page 150]
Processing the Document Template Hit List [Page 151]
Processing Document Template Headers [Page 152]
Copying Document Templates [Page 153]
Assigning Labels to Document Templates [Page 154]
Starting and Closing WWI [Page 155]
Searching for Document Templates

1. From the Product Safety [Ext.] screen, choose Reports → Edit templates → Report template or Cover sheet template or Acknowledgement of receipt template.

   The initial screen appears. You can start drill-down reporting from here. During the search, all entries are linked with AND.

2. Enter the data known to you on the initial screen. The system allows you to carry out double-sided generic searches using the document template key (<<K15>>, for instance).

3. You can use the following selection criteria for selecting document templates:
   – Document version
   – Status
   – Description (system supports double-sided generic searches)
   – The person responsible for creating the document (system supports double-sided generic searches)

4. If you have already allocated a report template to a generation variant, you can use the following generation variant data as further selection criteria:
   – The key for the generation variant (system supports double-sided generic entry)
   – Key date on which the substance generation variant is valid
   – Report type
   – Validity area
   – Rating

5. Choose Enter, or (Document) Template → Navigation area → Hit list.

Result

The R/3 System lists the document templates that match the search criteria.

See: Processing the Document Template Hit List [Page 151]

If the R/3 System does not find the required document template, you can enter new search criteria, or create the document template yourself.
Creating Document Templates

1. From the Product Safety [Ext.] screen, choose Reports → Edit templates → Report template or Cover sheet template or Acknowledgement of receipt template.
   The initial screen appears.
2. Choose (Document)template → Create.
   The document header appears.
   The system enters the document version 00, the logon language, status AA, current date, the current time, and current person responsible.

   You can create document templates from within the hit list after drill-down reporting by choosing (Document)template → Create.
Processing the Document Template Hit List

1. From the Product Safety [Ext.] screen, choose Reports → Edit templates → Report template or Cover sheet template or Acknowledgement of receipt template.

   The initial screen appears.

2. In the initial screen, specify your search criteria (see Searching for Document Templates [Page 149]) and choose (Document)template → Navigation area → Hit list.

   If the R/3 System finds data records for your search criteria, the hit list appears.

   See: Basic Functions in the Hit List [Page 157]

3. Select the document templates you want to process.

   Selected document templates can be processed using the functions from the Edit menu.

4. You can reach more screens by choosing the functions in the Goto menu.

   – Processing Document Template Headers [Page 152]
   – Assigning Labels to Document Templates [Page 154]
   – Starting and Closing WWI [Page 155]
Processing Document Template Headers

1. If you

<table>
<thead>
<tr>
<th>If you</th>
<th>Then choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Want to create the document template header</td>
<td>from the Product Safety [Ext.] screen Reports → Edit templates → Report template or Cover sheet template or Acknowledgement of receipt template, then (Document)/template → Create or (Document)/template → Create in the hit list of document templates</td>
</tr>
<tr>
<td>Want to edit the substance header</td>
<td>Goto → Header in the hit list or label</td>
</tr>
</tbody>
</table>

The document template header appears.

You can copy data from an existing document header. See: Copying Document Templates [Page 153]

2. Enter the required data. Please note the following when creating new document headers:

<table>
<thead>
<tr>
<th>Template</th>
<th>Enter a key for the template.</th>
</tr>
</thead>
<tbody>
<tr>
<td>/-version</td>
<td>The R/3 System has entered the version 00. If you have already used a document key, you cannot save until you have set the version to a higher number.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a text of your choice. You can process this text further even after you have saved it.</td>
</tr>
</tbody>
</table>

3. Choose Enter and save your changes.

Result

You can now maintain the labels for the document template or start WWI.

See also:

Assigning Labels to Document Templates [Page 154]
Starting and Closing WWI [Page 155]
Copying Document Templates

1. From the Product Safety [Ext.] screen, choose Reports → Edit templates → Report template or Cover sheet template or Acknowledgement of receipt template.

   The corresponding initial screen appears.

2. On the initial screen, enter your search criteria to select the document template to be copied (see: Searching for Document Templates [Page 149]).

3. Choose Hit list.

   The hit list matching your selection criteria appears.

   To create the next highest version of your document template, choose Extras → Create new version.

4. Select the document template to be copied and choose Edit → Copy.

   The Create Report Template: Header screen appears in which the R/3 System has entered the data of the document template copied.

5. Enter a new document key or document version, and change the description as required.

6. Choose Enter and save your changes.

Result

You call WWI by choosing Goto → Document. A document whose layout corresponds to the copied document template appears. You can then change the document.
Assigning Labels to Document Templates

1. Choose Goto → Label in the document template header or in the hit list for document templates.
   
   The Edit Report Template: Label screen appears.
   
   ![Icon]
   
   You can change the description that you have entered in the logon language in the document template header.

2. Place the cursor in the column under Language key and select the required language.

3. Now enter the translation of the label next to the language key.

4. Choose Enter and save your changes.
Starting and Closing WWI

Prerequisites

Document templates whose layout you want to process in Windows Wordprocess Integration (WWI) may not have status RE (released). If the templates do have this status, reset the status in the hit list for document templates by choosing Report Template → Reset status.

Procedure

1. From the Product Safety [Ext.] screen, choose Reports → Edit templates → Report template or Cover sheet template or Acknowledgement of receipt template.
   The initial screen appears.

2. Enter your search criteria (see: Searching for Document Templates [Page 149]).

3. Choose (Document)template → Navigation area → Hit list. If the R/3 System finds reports that correspond to your search criteria, the hit list appears.

4. To start WWI, choose Goto → Document in one of the following screens.
   - In the hit list for document templates
     In the hit list, select the document template for which you want to start WWI.

   ! Warning
   Document templates that have been processed in WWI have the status IP (In processing on work station) and cannot be called for processing in WWI again.

   If you are already editing one report template on a frontend, a lock prevents you from editing further report templates on the same frontend. If you were editing a report template using WWI, and the RFC connection was interrupted, you must unlock the frontend so that you can once again call the report template for editing. You can use the R/3 System to remove the lock by choosing Utilities → Frontend in the report template hit list. However, you should first make sure that no templates are being edited on the frontend.
   - In the document template header
   - In the document template label

     Word is called with a document in which you can process your document template.

     See also: Maintaining Document Template Layouts [Page 159]

5. To return to the R/3 System and make the changes, choose WWI → Check template in WWI. Correct any errors that occurred.

6. Choose File → Back to R/3 and Save.

   The system closes Word and takes you back to R/3. The report template and the symbol structure you defined are saved in the R/3 database.

   On return to the R/3 System, you always enter the hit list for document templates.
Starting and Closing WWI

7. The template is assigned a status according to how you return from WWI:

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Resulting status</th>
</tr>
</thead>
<tbody>
<tr>
<td>You have checked the template and have returned with save to the R/3 System.</td>
<td>Status IW (In work)</td>
</tr>
<tr>
<td>You have not checked the template, and have returned with save to the R/3 System.</td>
<td>Status UN (unknown)</td>
</tr>
<tr>
<td>The WWI start fails.</td>
<td>Status SE (system error)</td>
</tr>
<tr>
<td>Up to and including EH&amp;S release 2.2A, you must close the R/3 Windows Server dialog box manually.</td>
<td></td>
</tr>
</tbody>
</table>

Result

After you have created the layout for your report template, and allocated the report template to a generation variant, you can simulate a report from the report template in substance management (see: Testing Layouts [Page 274]).

To release the document template, select it in the hit list and choose (Document) template → Release. You can then use the document template to generate reports (see: Report Management [Page 258]).
# Basic Functions in the Hit List

You can use the following basic functions to process the hit list:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Basic Functions in the Hit List</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Function</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Substance (or phrase, or other object) → Other selection</td>
<td>You can start a new search with different search parameters.</td>
</tr>
<tr>
<td>(only for substances and phrases:) Utilities → Search parameters</td>
<td>The R/3 system displays the search parameters used to construct the current hit list.</td>
</tr>
<tr>
<td>(only for substances:) Utilities → Extend selection</td>
<td>You can enter additional search parameters. After you have confirmed your entries, the existing hit list is extended to include the new hits.</td>
</tr>
<tr>
<td>(only for substances:) Utilities → Refine selection</td>
<td>You can enter search parameters for existing substance data records. After you have confirmed your entries, the existing hit list is refined to include these data records only.</td>
</tr>
<tr>
<td>Utilities → Reset selection</td>
<td>After you have modified the hit list using Extend selection and Refine selection, you can use Reset selection to call the previous hit list.</td>
</tr>
<tr>
<td>Utilities → Column selection</td>
<td>A dialog box appears in which you can flag the columns that you want displayed in the hit list. After you have chosen Confirm, all non-flagged columns are hidden.</td>
</tr>
<tr>
<td>Utilities → Return to original</td>
<td>The R/3 System displays all columns.</td>
</tr>
<tr>
<td>Flag the columns that you would like to sort (click on the header line). Choose the symbol Sort ascending.</td>
<td>If you have flagged several columns, a dialog box appears in which you can specify an ascending or descending sort sequence for each individual column. If you have only flagged one column, it will be sorted in ascending order immediately.</td>
</tr>
<tr>
<td>Flag the columns that you would like to sort (click on the header line). Choose the symbol Sort descending</td>
<td>If you have flagged several columns, a dialog box appears in which you can specify an ascending or descending sort sequence for each individual column. If you have only flagged one column, it will be sorted in descending order immediately.</td>
</tr>
<tr>
<td>System → List → Find</td>
<td>A dialog box appears in which you can search for a particular term in the hit list.</td>
</tr>
<tr>
<td>System → List → Print (or phrase or other objects)</td>
<td>A dialog box appears in which you can enter print parameters for your R/3 printer. You can then choose Print.</td>
</tr>
</tbody>
</table>

**See also:**
Basic Functions in the Hit List

- Editing the Substance Hit List [Page 71]
- Editing the Phrase Hit List [Page 120]
- Processing the Document Template Hit List [Page 151]
- Processing the Generation Variant Hit List [Page 209]
Maintaining Document Template Layouts

Purpose

You define language-independent document templates using certain objects and symbols in a modified version of Word (Windows Wordprocessor Integration (WWI) (see: Document Types in Substance Reporting [Page 213]).

Prerequisites

- You have created a document template (Report Template (SBV) [Page 214], cover sheet template, acknowledgment of receipt).
  See: Maintaining Document Templates [Page 146].
- You have installed the current EH&S version of WWI on the workstation where you want to maintain the document templates, and you have called WWI from the R/3 System.
  See: Starting and Closing WWI [Page 155].

When editing report templates, performance can be improved if you make the settings in Word to display hidden text. To do this, under Tools → Options → View, mark the Hidden Text indicator.

You may not enter Hidden as text attribute for format templates.

You will find more information about the WWI installation in the Implementation Guide for Product Safety in the section WWI Installation.

Inserting Phrases

If you want to insert phrase texts, codes, graphics, the language for a phrase, or comments about phrases, you must have maintained them in phrase management in the R/3 System.

Inserting Symbols

- You have maintained substance data. You use the Insert symbol function to insert all symbol keys for which you generated symbols using master data adjustment on the report. (See: Master Data Adjustment [Page 255]). There are symbols of type symbol, parameter or phrase. Symbols of the type phrase refer to fields in phrase management, such as note for phrase, phrase language, phrase code or graphic for phrase, for example. To insert phrase texts, you can use the insert phrase function.

According to the symbol group defined in the IMG activity Specify report symbol groups in Customizing for Product Safety, you use the Insert symbol function to insert values from table fields, characteristic values or phrases from phrase-related characteristics. The tables can belong to the R/3 component Product Safety or other R/3 components.

For information on important table and structure fields, see Output Data in SD [Page 311].
Maintaining Document Template Layouts

- The symbol labels are generated by the system in the language in which you or your system administrator were logged on at the time of generation. To generate labels subsequently in other languages, you can use the corresponding function in Master Data Adjustment.

Process flow

1. WWI User Interface

   You can access the main functions using the WWI menu, the right-hand mouse button or by using a special WWI toolbar.

   WWI also features a number of special keyboard shortcuts.

   You can only change the basic settings if you have a local installation of WWI on your PC. For central installation, your system administrator will make the settings.

   If required, you can choose preview mode. In preview mode, information formatted as hidden is not displayed.

   More information
   - WWI: Using the Toolbar [Page 164]
   - WWI: Using Special Keyboard Shortcuts [Page 165]
   - WWI: Processing Basic Settings [Page 166]
   - WWI: Selecting Display Mode [Page 168]

2. Inserting Static Objects and Symbols

   You use Word functions to insert static objects, such as lines and tables, into the template.

   You use various symbol types to link the document template with R/3 data.

   To insert symbols on the report template, there are two different procedures: Insert phrase and Insert symbol.

   More information
   - Document Template Objects [Page 222]
   - Inserting Static Objects Using Word Functions [Page 163]

3. Editing Symbols

   Using various control objects, you define how the system outputs data (for instance, hide repeated text, output only certain characteristic values). Wizard enables you to

   - Generate titles
   - Generate symbols with labels in three-column tables
Maintaining Document Template Layouts

- Generate symbols for a substance characteristic category with labels in list or table format

<table>
<thead>
<tr>
<th>More information</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repeating Group Types [Page 245]</td>
<td>WWI: Suppressing Blank Compression [Page 190]</td>
</tr>
<tr>
<td>Character Sizing [Page 249]</td>
<td>WWI: Character Sizing [Page 201]</td>
</tr>
</tbody>
</table>

4. Returning to the R/3-System

Before you return to R/3, check the layout you created.

More information

Procedure

WWI: Checking Templates [Page 203]

Result

You can simulate the expanded layout of the final report for report templates with status Released or In work.

See: Testing the Layout [Page 274]

In order to do this, you must have allocated the report template to a generation variant that produces the link between the report template and the usage.

See: Maintaining Generation Variants [Page 204]

💡

You cannot simulate cover sheet templates and acknowledgments of receipts before they have been generated to the final version.
WWI: Procedures

Inserting Static Objects Using Word Functions [Page 163]
WWI: Using the Symbol Bar [Page 164]
WWI: Using Special Keyboard Shortcuts [Page 165]
WWI: Processing Basic Settings [Page 166]
WWI: Selecting Display Mode [Page 168]
WWI: Inserting Phrases [Page 171]
WWI: Inserting Symbols [Page 173]
Choosing Method for Entering Data [Page 169]
WWI: Inserting Repeating Groups [Page 182]
WWI: Blank Compression [Page 190]
WWI: Using Wizard [Page 192]
WWI: Using Conditioned Text [Page 199]
WWI: Character Sizing [Page 201]
WWI: Checking Templates [Page 203]
Inserting Static Objects Using Word Functions

You use Word functions to insert:

- Static objects such as
  - Separators
  - Frames
  - Tables
  - Graphics
  - Headers and footers
- Characters, paragraph and other formatting
WWI: Using the Symbol Bar

The WWI menu contains the WWI functions.

To display the toolbar with the most important WWI functions, choose View → Toolbars and flag WWI.

The table below lists the WWI menu options, keyboard shortcuts, and WWI icons.

<table>
<thead>
<tr>
<th>Menu option</th>
<th>Keyboard shortcut</th>
<th>Toolbar icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>ALT + T</td>
<td>----</td>
</tr>
<tr>
<td>Display Mode</td>
<td>ALT + M</td>
<td>Camera</td>
</tr>
<tr>
<td>Insert Repeating groups</td>
<td>ALT + R</td>
<td>Three windows</td>
</tr>
<tr>
<td>Insert Blank Compression</td>
<td>ALT + L</td>
<td>Two halves of a page</td>
</tr>
<tr>
<td>Edit Group</td>
<td>ALT + G</td>
<td>Yellow box in front of page</td>
</tr>
<tr>
<td>Insert Symbol</td>
<td>ALT + Y</td>
<td>ABC icon with brackets</td>
</tr>
<tr>
<td>Insert Phrase</td>
<td>ALT + P</td>
<td>ABC icon</td>
</tr>
<tr>
<td>Insert Symbol or Phrase</td>
<td>ALT + E</td>
<td>Table with pen</td>
</tr>
<tr>
<td>Conditioned text</td>
<td>ALT + X</td>
<td>a in brackets</td>
</tr>
<tr>
<td>Character Sizing</td>
<td>ALT + Z</td>
<td>Magnifying glass</td>
</tr>
<tr>
<td>Wizard</td>
<td>ALT + W</td>
<td>Fox</td>
</tr>
<tr>
<td>Check Template</td>
<td>ALT + C</td>
<td>---</td>
</tr>
</tbody>
</table>

The Edit Group function is valid within repeating groups or blank compression.
## WWI: Using Special Keyboard Shortcuts

WWI-enhanced Winword provides the following special keyboard shortcuts:

<table>
<thead>
<tr>
<th>Keyboard shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + R</td>
<td>Resets the formatting information of all highlighted characters:</td>
</tr>
<tr>
<td></td>
<td>– All hidden formatting information is removed.</td>
</tr>
<tr>
<td></td>
<td>– All changed colors are reset.</td>
</tr>
<tr>
<td>CTRL plus -(on the numbers keyboard)</td>
<td>Word hides all toolbars currently displayed (turn off Num on keyboard).</td>
</tr>
<tr>
<td>CTRL plus +(on the numbers keyboard)</td>
<td>Word displays all hidden toolbars (turn off Num on keyboard).</td>
</tr>
<tr>
<td>F1</td>
<td>Calls the R/3 F1-help for the currently selected symbol or repeating group.</td>
</tr>
</tbody>
</table>
WWI: Processing Basic Settings

Prerequisites

- You have started WWI-enhanced Word (see: Starting and Closing WWI [Page 155]).
- Your PC access a locally installed WWI directory. If your PC is connected to a central WWI server, please notify your system administrator.

As the system saves files WWI.INI and WWI.DOT when you make changes, no other users may edit WWI documents whilst you are processing them.

Procedure

1. Choose WWI → Basic Settings.
   The WWI settings dialog box appears.
2. You can change the following settings:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Language</td>
<td>Specify the language for all WWI dialogs and outputs.</td>
</tr>
<tr>
<td>Table</td>
<td>Here you define the table provided as an input template under WWI → Input Template.</td>
</tr>
<tr>
<td>Separator</td>
<td>Specify the separator you require.</td>
</tr>
<tr>
<td>Width 1</td>
<td>Specify the width of the first table column, for example 3 cm.</td>
</tr>
<tr>
<td>Width of separator</td>
<td>Specify the width of the second table column, for example 1 cm.</td>
</tr>
<tr>
<td></td>
<td>Word calculates the width of the third column from the page width.</td>
</tr>
<tr>
<td>Display changes</td>
<td>Set this indicator if you want the system to highlight changes.</td>
</tr>
<tr>
<td>Text color</td>
<td>Specifies the color of revised text, for example red.</td>
</tr>
<tr>
<td>Shade</td>
<td>Specifies the shading used for revised text, for example 25%</td>
</tr>
<tr>
<td>Frame-Left</td>
<td>Specify the type of frame used to mark revisions, for example double.</td>
</tr>
<tr>
<td><strong>Color settings</strong></td>
<td></td>
</tr>
<tr>
<td>Color is meta information</td>
<td>Set this indicator if you want the color of symbols to remain unchanged after the symbols are expanded.</td>
</tr>
</tbody>
</table>
Specify which color settings are to apply to the current document, or all documents.

Specify the color in the following fields.

💡

For further information on the Activate pushbutton, see the IMG activity Carry out macro language setting in Customizing for Product Safety.
WWI: Selecting Display Mode

Prerequisites
You have started WWI-enhanced Word (see: Starting and Closing WWI [Page 155]).

Procedure
Choose WWI → Display Mode.

The hidden characters are displayed/hidden.

💡

All symbols consist of hidden and normal characters. As the hidden characters provide control information only, you can choose Display Mode to hide them.
Selecting Methods for Entering Data

There are several methods for outputting texts, data or graphics on report templates. According to the method you have selected, choose the Insert Phrase or Insert Symbol function.

<table>
<thead>
<tr>
<th>Method</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>WWI: Inserting Phrases [Page 171]</td>
</tr>
<tr>
<td>B</td>
<td>WWI: Inserting Symbols [Page 173]</td>
</tr>
</tbody>
</table>

Prerequisites

You or your system administrator must have generated the symbol keys.

See also: Generating Symbols [Page 141].

Procedure

When do you need which method?

<table>
<thead>
<tr>
<th>If you want to insert</th>
<th>As</th>
<th>You need the</th>
<th>Choose method</th>
</tr>
</thead>
<tbody>
<tr>
<td>A phrase (or text)</td>
<td>Phrase (symbol type label/phrase)</td>
<td>Phrase key (control symbol on report template: EHS_L_TEXT)</td>
<td>A</td>
</tr>
<tr>
<td></td>
<td>Phrase-related characteristic (symbol type symbol)</td>
<td>Symbol key for characteristic (expansion mode GPC, subexpansion category P)</td>
<td>B</td>
</tr>
<tr>
<td></td>
<td>Identifier of expansion type Name (symbol type symbol)</td>
<td>Symbol key of the Identifier field (standard: GESTRIDENT; expansion mode: IT with type NAM)</td>
<td>B</td>
</tr>
<tr>
<td></td>
<td>Text MSDS sender (symbol type parameter)</td>
<td>Symbol key of the MSDS text sender field: EHS_SNSDB</td>
<td>B</td>
</tr>
<tr>
<td></td>
<td>A numerical value</td>
<td>Characteristic (symbol type symbol)</td>
<td>Symbol key of the characteristic</td>
</tr>
<tr>
<td></td>
<td>Field value for the R/3 component Product Safety (symbol type symbol)</td>
<td>Symbol key of the table field</td>
<td>B</td>
</tr>
<tr>
<td></td>
<td>Field value for another component</td>
<td>Symbol key of the table field</td>
<td>B</td>
</tr>
<tr>
<td></td>
<td>A graphic</td>
<td>Phrase-related characteristic (symbol type symbol)</td>
<td>Symbol key for characteristic (expansion mode GPC, subexpansion category P)</td>
</tr>
</tbody>
</table>
## Selecting Methods for Entering Data

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
<th>Control Symbol</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphic for a phrase (symbol type <em>label/phrase</em>)</td>
<td>Phrase key (control symbol on report template: <code>LABEL_GRAP</code>)</td>
<td>A</td>
<td></td>
</tr>
<tr>
<td>A phrase code</td>
<td>Phrase-related characteristic (symbol type <em>symbol</em>)</td>
<td>Symbol key for characteristic (expansion mode GPC, subexpansion category C)</td>
<td>B</td>
</tr>
<tr>
<td>Code for a phrase (symbol type <em>label/phrase</em>)</td>
<td>Phrase key (control symbol on report template: <code>LABEL_CODE</code>)</td>
<td>A</td>
<td></td>
</tr>
</tbody>
</table>

(Symbols: A, B)
WWI: Inserting Phrases

Prerequisites

- You have started the current WWI version of Word (see: Starting and Closing WWI [Page 155]).
- You want to insert phrase texts, phrase codes, phrase graphics, the language of a phrase or comments on phrases. The corresponding phrase data must have been maintained in R/3 phrase management.
- You have decided to use the Insert phrase method (see: Select Method for Entering Data [Page 169]).
- You must specify whether you want to insert a phrase in a report template or a cover sheet template as the Expansion Fence [Page 220] as it is different for each type of report.

The standard symbol names (symbol keys) are as follows in the standard:

<table>
<thead>
<tr>
<th>Insert</th>
<th>In report template</th>
<th>In cover sheet template</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phrase text</td>
<td>EHS_L_TEXT</td>
<td>EHS_H_TEXT</td>
</tr>
<tr>
<td>Phrase code</td>
<td>LABEL_CODE</td>
<td>LABEL_TEXT</td>
</tr>
<tr>
<td>Phrase graphic</td>
<td>LABEL_GRAP</td>
<td>LABEL_GRAP</td>
</tr>
<tr>
<td>Phrase language</td>
<td>LABEL_LANG</td>
<td>LABEL_LANG</td>
</tr>
<tr>
<td>Note on a phrase</td>
<td>LABEL_REM</td>
<td>LABEL_REM</td>
</tr>
</tbody>
</table>

Procedure

1. Place the cursor at the point where you want to insert the phrase.
2. Choose WWI → Insert Phrase.

The Phrase Search dialog box appears.

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Select the appropriate symbol name (EHS_L_TEXT, for example)</td>
</tr>
<tr>
<td></td>
<td>(phrase text)</td>
</tr>
<tr>
<td>Phrase Catalog</td>
<td>Key for the phrase library, CED, for example</td>
</tr>
<tr>
<td>Phrase Group</td>
<td>Key for phrase group</td>
</tr>
<tr>
<td>Filter</td>
<td>You can search for the text for the required phrase:</td>
</tr>
<tr>
<td></td>
<td>- The search is case sensitive</td>
</tr>
<tr>
<td></td>
<td>- You can search generically using the * character. The entry</td>
</tr>
<tr>
<td></td>
<td><em>aid</em>, for example, would yield the following phrases:</td>
</tr>
<tr>
<td></td>
<td>Protection of first-aiders</td>
</tr>
<tr>
<td></td>
<td>For effective first-aid, special training/education is needed, etc.</td>
</tr>
</tbody>
</table>
3. Choose Search.
**WWI: Inserting Phrases**

The system lists all phrases that correspond to the search criteria in the Filter field for the selected phrase library and group.

4. Place the cursor on the required phrase, and choose OK.

   Word inserts the symbol for the phrase in the report template.

   - If the phrase is not found when the report is generated, the entry is output as follows:

     ```
     {**phrase library - phrase key**}
     ```

   - If you want to insert the phrase text, phrase code or phrase graphic of a phrase-related characteristic, follow the procedure used for inserting symbols from the symbol group Symbol. You use the expansion mode to control whether the phrase-related characteristic is output as a phrase, code or graphic (see: WWI: Inserting Symbols [Page 173]).

5. If you want to edit symbols subsequently, position the cursor within the symbol and choose WWI → Edit Symbol or Edit Group.

**Result**

The symbol entry for a phrase looks as follows:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;03EHS_L_TEXT(CED-01.00000030)</code></td>
<td>Notes: Symbol type 03 (symbol type label/phrase).</td>
</tr>
<tr>
<td><code>&lt;03EHS_L_TEXT</code></td>
<td>Key for the symbol name (controls if the output is to be as text, code or phrase, etc.) (These standard keys are defined in the IMG activity Check and define report symbols in Customizing for Product Safety).</td>
</tr>
<tr>
<td><code>&lt;03EHS_L_TEXT(CED</code></td>
<td>Phrase library in which the phrase is contained</td>
</tr>
<tr>
<td><code>&lt;03EHS_L_TEXT(CED-01.00000030)</code></td>
<td>Phrase key</td>
</tr>
</tbody>
</table>

**See also:**

- Maintaining Document Template Layouts [Page 159]
- Symbol Type Phrase [Page 224]
WWI: Inserting Symbols

Prerequisites

- You have started the current version of WWI (see: Starting and Closing WWI [Page 155]).
- You have decided to use the Insert symbol method (see: Select Method for Entering Data [Page 169]).
- You use the Insert symbol function to insert all symbol keys for which you generated symbols using master data adjustment on the report (see: Master Data Adjustment [Page 255]). There are symbols of type symbol, parameter or phrase. Symbols of the type phrase refer to fields in phrase management, such as note for phrase, phrase language, phrase code or graphic for phrase, for example. To insert phrase texts, you can use the insert phrase function (see: WWI: Inserting Phrases [Page 171]).

According to the symbol group defined in the IMG activity Specify report symbol groups in Customizing for Product Safety, you use the Insert symbol function to insert values from table fields, characteristic values or phrases from phrase-related characteristics. The tables can belong to the R/3 component Product Safety or other R/3 components.

For information on important table and structure fields, see Output Information in SD [Page 311].

- The symbol labels are generated by the system in the language in which you or your system administrator were logged on at the time of generation. To generate labels subsequently in other languages, you can use the corresponding function in Master Data Adjustment.

Procedure

1. Place the cursor at the point where you want to insert the symbol.
2. Choose WWI → Insert Symbol.
   The Symbol Properties screen appears.
3. Choose Search.
   The Symbol Tree screen appears. Open the tree structure. It displays both classes and table-dependent symbols. The symbols are ordered according to symbol group (see the IMG activity Specify report symbol groups in Customizing for Product Safety).
4. Place the cursor on the required symbol, and choose OK.
   The symbol key is inserted in the Symbol Properties dialog box in the Symbol field.
   The expansion category displayed in the dialog box depends on the expansion mode defined for symbols in the detail view of the IMG activity Check and specify report symbols in Customizing for Product Safety.

   Regardless of the current expansion mode, you can use certain sub-expansion categories to influence data output.
WWI: Inserting Symbols

<table>
<thead>
<tr>
<th>Expansion Mode [Page 176]</th>
<th>Subexpansion category</th>
</tr>
</thead>
<tbody>
<tr>
<td>GPC</td>
<td>Graphic/phrase/code (G, P or C)</td>
</tr>
<tr>
<td>IT</td>
<td>Identifier (I for type, category, list) or T (for selection strategy)</td>
</tr>
<tr>
<td>NM</td>
<td>Numerical processing (see: Input Templates [Page 177]) or Processing method (see: Function Modules [Page 179])</td>
</tr>
<tr>
<td>Barcode</td>
<td>Processing method (see: Barcodes [Page 175])</td>
</tr>
</tbody>
</table>

5. Enter the required data for each expansion mode.

6. If necessary, set the Multiple Handling indicator in the Symbol Properties dialog box.

<table>
<thead>
<tr>
<th>If you</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose First</td>
<td>The system only outputs the first value for the characteristic or the first identifier (of the subexpansion category you specified).</td>
</tr>
<tr>
<td>Choose All</td>
<td>The system outputs all characteristic values or identifiers for a data record (of the subexpansion category you specified).</td>
</tr>
</tbody>
</table>

7. Choose Enter.

   Word inserts the symbol into the report template.

8. If you want to edit symbols subsequently, position the cursor within the symbol and choose WWI → Edit Symbol or Phrase.

   If you insert a symbol for values from substance characteristic value assignment, you must always create a repeating group around the symbol of type main group.

See also:

Symbols - Examples [Page 180]
Maintaining Document Template Layouts [Page 159]
Symbol Type Symbol [Page 225]
Bar code

To enable the R/3 System to output values as bar codes, proceed as follows:

1. Acquire a registered font for your barcode and install it.
2. Write your own conversion program (ABAP function module) that adjusts the values. The interface must correspond with the function module C128_DUMMY_CONVERSION_METHOD.
3. Use the function module C128_DUMMY_CONVERSION_METHOD as the method for the corresponding symbol in the template (expansion mode M) or in the symbol definition.
4. Format the symbol in the template with the corresponding font.
Expansion Mode

If you carry out the *Insert Symbol* function, the expansion mode defined in the detail screen in the IMG activity *Specify and check report symbols* for the symbol selected. The expansion mode is defined with regard to the data type for the symbol. Depending on the expansion mode, you can use other subexpansion categories.

<table>
<thead>
<tr>
<th>Symbol data type</th>
<th>Expansion Mode</th>
<th>Subexpansion category</th>
</tr>
</thead>
<tbody>
<tr>
<td>Characteristic value</td>
<td>None</td>
<td>N: <em>Input Templates</em></td>
</tr>
<tr>
<td></td>
<td>Barcodes</td>
<td>([Page 175])</td>
</tr>
<tr>
<td></td>
<td>NM</td>
<td>or</td>
</tr>
<tr>
<td></td>
<td>M: <em>Function Modules</em> ([Page 179])</td>
<td></td>
</tr>
<tr>
<td>Graphic of a phrase-related characteristic</td>
<td>GPC</td>
<td>G</td>
</tr>
<tr>
<td>Text of a phrase-related characteristic</td>
<td>GPC</td>
<td>P</td>
</tr>
<tr>
<td>Code of a phrase-related characteristic</td>
<td>GPC</td>
<td>C</td>
</tr>
<tr>
<td>Identifier</td>
<td>IT</td>
<td>I: <em>Type</em> (for instance, NAM),</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Category (for instance, TRIV),</td>
</tr>
<tr>
<td></td>
<td></td>
<td>List (only if the identifier is allocated to a substance list)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>T: Identifier selection strategy</td>
</tr>
<tr>
<td>Field values for a table in the R/3 component <em>Product Safety</em></td>
<td>None</td>
<td>N: <em>Input Templates</em></td>
</tr>
<tr>
<td>or</td>
<td>Barcodes</td>
<td>([Page 175])</td>
</tr>
<tr>
<td>Field values for a table in another component (symbol type <em>Parameter</em>)</td>
<td>NM</td>
<td>or</td>
</tr>
<tr>
<td></td>
<td>M: <em>Function Modules</em> ([Page 179])</td>
<td></td>
</tr>
</tbody>
</table>

The selection strategy for identifiers is specified in the IMG activity *Check identification listing* in Customizing for *Product Safety*. 

[Image 464x733 to 482x741]
[Image 145x222 to 162x240]
Template

If you specify expansion category NM and subexpansion category N, you can define input templates for numerical values.

- Input template for decimal places before the period
  
  You can use the following decimal places in the input template:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Z = optional place (eliminates leading zeros)</td>
<td></td>
</tr>
<tr>
<td>2.</td>
<td>B = optional place (no leading zeros eliminated - if the R/3 System does not find any values, it replaces B with a blank)</td>
<td></td>
</tr>
<tr>
<td>3.</td>
<td>9 = fixed place (no leading zeros eliminated - if the R/3 System does not find any values, it replaces 9 with a zero)</td>
<td></td>
</tr>
</tbody>
</table>

  The order of the decimal places in the template is as above from left to right before the decimal point.
  
  If the number of decimal places is larger than the number defined in the template, the system outputs asterisks (*) instead.

- Template for decimal places after the period
  
  You can use the following decimal places in the input template:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>9 = fixed place (no following zeros eliminated - if the R/3 System does not find any values, it replaces 9 with a zero)</td>
<td></td>
</tr>
<tr>
<td>2.</td>
<td>B = optional place (no following zeros eliminated)</td>
<td></td>
</tr>
<tr>
<td>3.</td>
<td>Z = optional place (eliminates following zeros)</td>
<td></td>
</tr>
</tbody>
</table>

  The order of the decimal places in the template is as above from left to right after the comma.

<table>
<thead>
<tr>
<th>Numerical value</th>
<th>Template</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.3456789</td>
<td>99.99BBZ</td>
<td>12.34567</td>
</tr>
<tr>
<td>12.3</td>
<td>99.99BBZ</td>
<td>12.30</td>
</tr>
<tr>
<td>123.45600</td>
<td>99.99BBZZ</td>
<td>**.4560</td>
</tr>
</tbody>
</table>

- Input template for units of measure
  
  If you do not define a template, the system outputs the unit of measure specified by the transfer parameter.
  
  You define the input template of the unit of measure after the input template for the numerical value. Separate the template definitions by a blank.
Template

You can use the following decimal places in the input template:

D = optional decimal place (if R/3 finds no value → D is replaced by a blank)

If the number of characters required by the unit of measure is larger than the number of characters you defined for the input template, the system outputs an asterisk (*) behind the unit of measure.

<table>
<thead>
<tr>
<th>Numerical value</th>
<th>Template</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.34 kg/l</td>
<td>99.99 DD</td>
<td>12.34 k*</td>
</tr>
<tr>
<td>12.34 kg/l</td>
<td>99.99 DDDDD</td>
<td>12.34 kg/l</td>
</tr>
</tbody>
</table>

You can use 'D-' to completely suppress the output of the dimension.

<table>
<thead>
<tr>
<th>Numerical value</th>
<th>Template</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>123.45 kg/l</td>
<td>999.9 DDD</td>
<td>123.4 kg*</td>
</tr>
<tr>
<td>123.45 kg/l</td>
<td>999.9</td>
<td>123.4 kg/l</td>
</tr>
<tr>
<td>123.45 kg/l</td>
<td>999.9 D-</td>
<td>123.4</td>
</tr>
</tbody>
</table>

Input template for intervals

The system processes both values of the interval separately and prepares the template accordingly.

<table>
<thead>
<tr>
<th>Numerical value</th>
<th>Template</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.34 - 13.5 kg/l</td>
<td>99.99 DDDD</td>
<td>12.34 - 13.50 kg/l</td>
</tr>
</tbody>
</table>

Original accuracy definitions are transferred.

<table>
<thead>
<tr>
<th>Numerical value</th>
<th>Template</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt; 12.34 - &lt; 13.5 kg/l</td>
<td>99.99 DDDD</td>
<td>&gt; 12.34 - &lt; 13,50 kg/l</td>
</tr>
</tbody>
</table>
Function Module

You can define a function module as processing method for a symbol by choosing one of the following options:

- In Customizing for Product Safety in the detail screen of the IMG activity Check and define report symbols
- In WWI on the Insert Symbols dialog box in WWI as processing method NM and subprocessing method M.

The entry in WWI has priority.

The function module must meet the requirements of a specific interface. The system checks both in Customizing as well as when you use a method in layout, whether the function module is active in the system and whether it meets the requirements of the interface.

Before creating new function modules, check the documentation of sample function module C128_DUMMY_CONVERSION_METHOD:

Choose transaction se37 and enter the name of function module C128_DUMMY_CONVERSION_METHOD.

You can now display the documentation and the source text for the interface of the function module.
Symbols - Example

Below you will find some examples for symbols of symbol type Symbol or Parameter. Note that the symbol keys listed are examples only.

- A symbol entry is always denoted by pointed parentheses < >.
- Extended control information is always appended to a symbol, separated by a semicolon. Extended control information specifies which data the system outputs, if several characteristic values are assigned to a data record.

<table>
<thead>
<tr>
<th>Extended selection</th>
<th>Control information appended to symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>Multiple handling: First</td>
<td>01</td>
</tr>
<tr>
<td>Multiple handling: All</td>
<td>*</td>
</tr>
</tbody>
</table>

For instance, if you want to output all values except the first, append the following entry manually to the symbol: ;2-*.

1. Symbol entry for one characteristic

<01G1013005VA> Complete symbol entry

Notes:

<01 Symbol type 01 (symbol type Symbol)

<01G1013005VA> Key for symbol name

Expansion: none

2. Symbol entry for a phrase-related characteristic

<01G1013005VA(P;*)> Complete symbol entry

Notes:

<01 Symbol type 01 (symbol type Symbol)

<01G1013005VA> Key for symbol name

<01G1013005VA(P> Expansion category GPC and subexpansion category P

<01G1013005VA(P;*)> Extended: All values

- Subexpansion category C expands the phrase code of a phrase (for instance, T+ for Highly toxic). You must maintain the code as a phrase item in phrase management.
See also: Editing Phrase Items [Page 123]

– Subexpansion category G expands the graphics for a phrase (for instance the skull symbol for *Highly toxic*). You need to maintain the graphics file and its extension (for instance, `picture.bmp`) as a phrase item in phrase management. The graphics file must be stored in WWI folder *Graphics*.

3. **Symbol for an identifier (field in an table)**

```
<01GESTRIDENT(I:NAM, TRIV,)> Complete symbol entry
```

<table>
<thead>
<tr>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;01</td>
</tr>
<tr>
<td>&lt;01GESTRIDENT</td>
</tr>
<tr>
<td>&lt;01GESTRIDENT(I:NAM; TRIV)&gt;</td>
</tr>
</tbody>
</table>

4. **Symbol for a characteristic with input template**

```
<01G1013005VA(N:"ZZ9,9 DDDDDD")> Complete symbol entry
```

<table>
<thead>
<tr>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;01</td>
</tr>
<tr>
<td>&lt;01G1013005VA</td>
</tr>
<tr>
<td>&lt;01G1013005VA(N:&quot;ZZ9,9 DDDDDD&quot;)&gt;</td>
</tr>
</tbody>
</table>

5. **Symbol for a symbol of symbol type Parameter**

```
<02GKNA1PFACH> Complete symbol entry
```

<table>
<thead>
<tr>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;02</td>
</tr>
<tr>
<td>&lt;02GKNA1PFACH&gt;</td>
</tr>
</tbody>
</table>
**WWI: Inserting Repeating Groups**

**Prerequisites**
- You have started the current version of WWI (see: Starting and Closing WWI [Page 155]).
- You have created symbols for data for which several data records can be output.

**Procedure**

1. Select the symbols to be included in the repeating group.

   Repeating groups may not extend over several cells in a table line. It may extend within a cell or over the whole table line.

2. Choose **WWI → Insert Repeating Group**.

   The *Insert Repeating Group* dialog box appears.

3. Select the type of repeating group that you require. For further information, see
   - Repeating Groups [Page 243]
   - Repeating Group Types [Page 245]

   You can use the *Browse* function to search for substance characteristic categories. The R/3 System opens the *Symbol Tree* dialog box in which you can select the required substance characteristic category under *Char. symbols*.

4. Select:

<table>
<thead>
<tr>
<th>All</th>
<th>If you want to output all data records over which the system iterates</th>
</tr>
</thead>
<tbody>
<tr>
<td>All except the first</td>
<td>If you want to output all data records with the exception of the first</td>
</tr>
</tbody>
</table>

5. Choose *Enter*.

   Word transfers the control objects for the repeating group to the highlighted area.

   - Repeating groups have the substance report symbol type 11.
   - Group identifications must be placed in separate lines to maintain paragraph formatting.

6. You can nest repeating groups. For valid nesting definitions, see the syntax graph (see: Repeating Groups [Page 243]).

   The numbering must be unique. Otherwise, the error log cannot be allocated uniquely in the document template.
When checking the document template, the system always outputs an error for any symbol with the same symbol key as the error log (Check-File). This means that, particularly for repeating groups, the error text is output for the first corresponding symbol found, even if this has been defined correctly.

Make sure that the key for repeating groups is composed of “BRG” and the number, and that the allocation is unique.

7. If you want to edit repeating groups subsequently, position the cursor within the symbol and choose WWI → Edit Group.

See also:

Repeating Groups - Example [Page 184]
Creating Table of Contents - Example [Page 187]
Repeating Group S:CLASS - Example [Page 189]
Repeating Groups - Examples

Please note that the symbol keys listed are examples only.

**Goal:**

You want to output the 3rd and 4th value of characteristic Notes of the 2nd characteristic record of substance characteristic category First aid eye:

```
<11BRG001(M,SAP_EHS_1015_003;2)>
<01G1015003AD(P;3-4)>
<11ERG001>
```

<table>
<thead>
<tr>
<th>1st line</th>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;11</td>
<td>Repeating group type</td>
</tr>
<tr>
<td>&lt;11BRG</td>
<td>Begin repeating group</td>
</tr>
<tr>
<td>&lt;11BRG001</td>
<td>Repeating group no. 1</td>
</tr>
<tr>
<td>&lt;11BRG001(M</td>
<td>Repeating group type: master</td>
</tr>
<tr>
<td>&lt;11BRG001(M,SAP_EHS_1015_003</td>
<td>Symbol key for characteristic category Composition</td>
</tr>
<tr>
<td>&lt;11BRG001(M,SAP_EHS_1015_003;2)</td>
<td>Restrict output to 2nd characteristic record</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>2nd line</th>
<th>Output 3rd to 4th value of phrase-related characteristic Notes (symbol key G1015003AD)</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;01G1015003AD(P;3-4)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>3rd line</th>
<th>End repeating group</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;11ERG001</td>
<td></td>
</tr>
</tbody>
</table>

**Goal:**

You want to output the components of a composition including the substance keys, average content, and base.
## Repeating Groups - Examples

### 1st line

<table>
<thead>
<tr>
<th>Code</th>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>Repeating group type</td>
</tr>
<tr>
<td>11BRG</td>
<td>Begin repeating group</td>
</tr>
<tr>
<td>11BRG001</td>
<td>Repeating group no. 1</td>
</tr>
<tr>
<td>11BRG001(M)</td>
<td>Repeating group type: master</td>
</tr>
<tr>
<td>11BRG001(M,SAP_EHS_1012_003:)</td>
<td>Symbol key for characteristic category Composition</td>
</tr>
<tr>
<td>11BRG001(M,SAP_EHS_1012_003:)</td>
<td>All data records</td>
</tr>
</tbody>
</table>

### 2nd line

<table>
<thead>
<tr>
<th>Code</th>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>Repeating group type</td>
</tr>
<tr>
<td>11BRG</td>
<td>Begin repeating group</td>
</tr>
<tr>
<td>11BRG002</td>
<td>Repeating group no. 2</td>
</tr>
<tr>
<td>11BRG002(POS)</td>
<td>Repeating group type: slave (components of the composition)</td>
</tr>
<tr>
<td>11BRG002(S:POS;*)</td>
<td>All data records</td>
</tr>
</tbody>
</table>

### 3rd line

<table>
<thead>
<tr>
<th>Code</th>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>01GESTRSUBID</td>
<td>Sample symbol (for instance, substance key)</td>
</tr>
<tr>
<td>01GESTVCOMPA</td>
<td>Sample symbol (for instance, average content)</td>
</tr>
<tr>
<td>01GESTVCOMPR</td>
<td>Sample symbol (for instance, base)</td>
</tr>
</tbody>
</table>
Repeating Groups - Examples

<table>
<thead>
<tr>
<th>4th and 5th line</th>
<th>End repeating group no. 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;11ERG002&gt;</code></td>
<td>End repeating group no. 2</td>
</tr>
<tr>
<td><code>&lt;11ERG001&gt;</code></td>
<td>End repeating group no. 1</td>
</tr>
</tbody>
</table>
Example: Creating a Table of Contents

The following example shows you how to define a table of contents.

In the following example, a repeating group of type Q (proof of source) was defined that determines how sources appear in the text. Alternatively, you can specify that the sources are to be listed alphabetically.

In the original, the control characters are formatted as hidden text. The symbols contain sample values only.

Report template layout:

Characteristic 1:

<11BRG002(M,SAP_EHS_1013_005;*)> <01G1013005VA> <01EHS_TXTREF>
<11ERG002>

Characteristic 2:

<11BRG003(M,SAP_EHS_1013_021;*)> <01G1013021VA> <01EHS_TXTREF>
<11ERG003>

Bibliography

<11BRG004(Q:AUFT;*)> <01EHS_TXTREF> <01GTCG4SRCAU>:
<01GTCG4SRCNA>; <01GTCG4SRCYE>

Layout of generated report:

Characteristic 1:

45 °C ¹
44 °C ²

Characteristic 2:

0,7752 g/cm³ ³
0,7699 g/cm³ ⁴
Example: Creating a Table of Contents

Bibliography

1 Author Z: name of book Z; year of publication Z
2 Author A: name of book A; year of publication A
3 Author X: name of book X; year of publication X
4 Author Y: name of book Y; year of publication Y
Example: Repeating Group S:CLASS

If the symbol for the dangerous goods regulation (G1022024LW) is defined within the repeating group S:CLASS, the characteristic values that are not relevant are suppressed by the UN listed substance. This ensures that the system only outputs the UN listed substance legal data valid for the corresponding regulation.

In the report template, you must manually allocate the function module C14N_SYMBOL_DREG_SUPPRESS as expansion mode M to the symbol that stands for the output of transport data (G1022024LW). This function module is delivered in the standard system.

The syntax in the report template must be as follows:

```
<11BRG001 (M, SAP_EHS_1022_023;)>
<11BRG002 (S:CLASS;*)>
<11BRG003 (M, SAP_EHS_1022_024;*)>

<13BNG001
(*;G1022024LW;C14N_SYMBOL_DGREG_SUPPRESS)>
<01SYMBOL01>
<01SYMBOL02>
<01SYMBOL03>
...
<13ENG001>
<11ERG003><11ERG002><11ERG001>
```

Substance characteristic category for transport classification
Loop over all allocated listed substances
Loop over all characteristic values for the dangerous goods regulation
Symbol for which the formatting method C14N_SYMBOL_DGREG_SUPPRESS is defined.

If the symbol G1022024LW is reset to initial by the processing method, the complete block up to <13ENG001> is not output.
**WWI: Blank Compression**

**Prerequisites**
- You have started WWI-enhanced Word (See: Starting and Closing WWI [Page 155]).
- You want to stop data being output if a particular value is missing.

**Procedure**

1. Highlight the area for which you want to define blank compression.
   - Blank compression may not extend over several cells in a table line. It may extend within a cell or over the whole table line.

2. Choose WWI → Insert Blank Compression.
   - The Blank Compression dialog box appears.
   - The symbols in the selected text are displayed in the left section.

3. Position the cursor on each symbol in turn for which the system must find a value so that the entire selected text is also output, and choose the Copy function.

4. If you want to include further symbols as a condition, choose Add in the dialog box.
   - The symbol properties dialog box appears. Here, you can use the Search function to select further symbols.
   - You can change all symbols displayed as a condition in the Blank Compression dialog box in the control symbols area by positioning the cursor on the symbol required and choosing Modify or Delete.

5. In the blank compression dialog box in the operator area, specify whether the conditions entered are to be linked with AND (*) or OR (+).

6. Choose Enter.
   - Word enters blank compression in your template according to the conditions defined.
   - Repeating groups have the substance report symbol type 13.

7. If you want to edit blank compression subsequently, position the cursor within the symbol and choose WWI → Edit Group.

**See also:**
- Blank Compression - Example [Page 191]
- Blank Compression [Page 247]
**Blank Compression - Example**

Please note that the symbol keys listed are examples only.

You want to output an address:

- **Name:** `<02GKNA1NAME1>`
- **Straße:** `<02GKNA1STRAS>`
- **Ort:** `<02GKNA1ORT01>`

It only makes sense to output this section if a name exists for the address.

Define the following blank compression:

```plaintext
<13BNG001(+:02GKNA1NAME1)>
```

- **Name:** `<02GKNA1NAME1>`
- **Street:** `<02GKNA1STRAS>`
- **City:** `<02GKNA1ORT01>`

```plaintext
<13ENG001>
```

Blank compression ensures that the system checks whether a value is assigned to symbol `GKNA1NAME1`. If this is not the case, the complete group from `BNG001` to `ENG001` is removed from the document.
WWI: Using Wizard

Prerequisites

- You have started the current version of WWI (see: Starting and Closing WWI [Page 155]).
- In WWI.INI, you have checked the default settings in the [Template] section containing the following default values for working with Wizard:
  - Column width for inserting three-column tables
  - Column separators (colon, for example) for three-column tables
  - Phrase name (specifies if the phrase is inserted as text or code), phrase group, and phrase library
  - Word styles (for headings, symbols and phrases)
  - Frames and shading (for tables)

Procedure

1. Position the cursor on the point in your document template where you want to insert symbols with Wizard.

   ![Tip]

   Do not position the cursor within a table. If you have selected the text, the system asks you if the selected text is to be overwritten by that generated by Wizard.

2. Choose WWI → Wizard.

   The Symbol Tree dialog box appears.

   There are several ways of influencing the result of the search in the symbol tree (see: According to the selection, you can:

   - Generating Headings [Page 193]
   - Generating Symbols in 3-Column Tables [Page 194]
   - Generating Symbols from Substance Characteristic Categories [Page 196]

   ![Tip]

   The three node types you can select can be distinguished by their icons in the symbol tree.
Generating Headings

Prerequisites
See: WWI: Using Wizard [Page 192]

Procedure
1. Position the cursor on the point in your document template where you want to insert symbols with Wizard. Make sure not to place the cursor within the table.

2. Choose WWI → Wizard.
   The Symbol Tree dialog box appears.
   There are several ways of influencing the result of the search in the symbol tree (see: WWI: Using Wizard [Page 192]).

3. To insert a substance characteristic category as a heading on your report template, position the cursor in the symbol tree under Char. symbols on a node to which no characteristic symbols are allocated, and choose OK.

4. The Wizard Heading Option Dialog box appears. In the Filter field, Word displays the text for the selected substance characteristic value as search criteria, Physical-chemical data.
   You can modify the text in the Filter field. Generic entries are accepted, and the search is case sensitive.

5. If you choose the Search function, all phrases in the R/3 System that correspond to your search criteria are listed in the dialog box.

6. Position the cursor on the phrase you want to use as a heading.

7. Choose the required format for your heading in the Style field, and choose OK.

8. Word inserts the symbol for the phrase, and formats the entry accordingly.
Generating Symbols in 3-Column Tables

Prerequisites
See: WWI: Using Wizard [Page 192]

Procedure
1. Position the cursor on the point in your document template where you want to insert symbols in a three-column table with Wizard. Make sure not to place the cursor within the table.

2. Choose WWI → Wizard.
The Symbol Tree dialog box appears.
There are several ways of influencing the result of the search in the symbol tree (see: WWI: Using Wizard [Page 192]).

3. To insert a table, place the cursor in the symbol tree on a symbol for a table field or character, and choose OK.
The Wizard Symbol Option Dialog box appears. The symbol key is inserted in the Symbol Properties dialog box in the Symbol field. You can define an expansion category regardless of the symbol (see: WWI: Inserting Symbols [Page 173]).

4. In the dialog box under Styles, define the required format in the Symbol field.

5. If you have set the Phrase indicator, Word enters the symbol text in the Filter field.

   ! If you have not set the Phrase indicator, then only the symbol is inserted in the report template (corresponds to the procedure WWI: Inserting Symbols).

6. You can search generically for the required phrase text in the Filter field. The search is case sensitive.
   a) Choose Search.
      The system lists all phrases that correspond to the search criteria in the Filter field for the default phrase library and group.
   b) Place the cursor on the required phrase, and choose OK.
      Word inserts the symbol for the phrase in the report template.

7. In the dialog box under Styles, define the required format in the Phrase field.

8. If necessary, set the Blank Compression indicator.
   In this case, the phrase is only output if the R/3 System can find a value for the symbol when generating the report.

9. Choose Enter. Word inserts a three-column table as follows (the control characters are formatted as hidden):

   <13BNG001(+:01G1013002VA)>
<table>
<thead>
<tr>
<th>&lt;03EHS_L_TEXT(EHSXP-E08.00290020)&gt;</th>
<th>&lt;01G1013002VA&gt;</th>
</tr>
</thead>
</table>

<13ENG001>
Generating Symbols from Substance Characteristic Categories

Prerequisites
See: WWI: Using Wizard [Page 192]

Procedure
1. Position the cursor on the point in your document template where you want to insert symbols with Wizard. Make sure not to place the cursor within the table.

2. Choose WWI → Wizard.
   The Symbol Tree dialog box appears.
   There are several ways of influencing the result of the search in the symbol tree (see: WWI: Using Wizard [Page 192]).

3. In the symbol tree under Char. symbols, place the cursor on a node to which characteristic symbols are allocated, and choose OK.
   The Wizard Group Option Dialog box appears.
   The substance characteristic category selected is entered in the Substance Characteristic field.

4. If you want to output a heading with Wizard, set the Heading indicator.
   The Filter field is ready for input. The text for the substance characteristic category has been entered as search criteria, Relative density, for example.
   You can modify the text in the Filter field. Generic entries are accepted, and the search is case sensitive.
   a) If you choose the Search function, all phrases in the R/3 System that correspond to your search criteria are listed in the dialog box. If no phrases are found, you must change the search criteria.
   b) Position the cursor on the phrase that you want to use as a heading, and choose the required format for your heading in the Heading field under Styles.

5. All characteristics for the substance characteristic category are listed in the Symbols area. According to your requirements, the characteristic symbols can be
   – Removed from the list using the Delete function
   – Sorted using the Up and Down functions
   a) If you want to output the description of the characteristic for a characteristic value as a phrase, set the indicator for the characteristic symbol at the beginning of each line. The sequence of phrases and values influences the result. See the example given below (characteristic values without phrases are displayed in a row).
   b) Under Styles, choose the required format in the Phrase and Symbol fields.

6. Set the Table indicator to output the data in table format.
   If you do not set the indicator, the data are output in list format with three-column tables.
7. Choose OK.

If you want to output phrases for characteristic values, Word checks if the corresponding phrases are available. If not, the system displays the Phrase Search dialog box in which you can modify the search criteria according to the procedure: WWI: Inserting Phrases [Page 171]

**Result**

---

**List Output**

---

**Report template layout:**

- `<11BRG010(M,SAP_EHS_1013_006)>`
- `<13BNG017(+:01G1013006VA)>`
  - `<03EHS_L_TEXT(EHSXP-E08.00290020)> : <01G1013006VA>`
- `<13ENG017>`
- `<13BNG018(+:01G1013006ET)>`
  - `<03EHS_L_TEXT(EHSXP-E11.00900130)> : <01G1013006ET> <01G1013006E1(P)>`
- `<13ENG018>`
- `<11ERG010>`

---

**Layout of generated report:**

Relative density: 0,9 g/cm3
Temperature:     20°C <

To ensure that the temperature “20°C <” is output correctly as “<20°C”, you must reverse the sequence of symbols on the report template (after you have inserted the symbols using Wizard). However, in Wizard, the sequence may not be changed. If you change the sequence, a new line (or table column, see below) is created for each phrase so that the temperature is separated from its accuracy.

Instead, you can set the phrase indicator for the symbol with the incorrect syntax, and change the phrase after you have exited Wizard.

---

**Table Output**

---

**Report template layout:**

- `<03EHS_L_TEXT(EHSXP-E08.00290020)>`
- `<03EHS_L_TEXT(EHSXP-E11.00900130)>`
### Generating Symbols from Substance Characteristic Categories

To ensure that the temperature "20°C <" is output correctly, you must reverse the sequence of symbols on the report template (after you have inserted the symbols using Wizard).
WWI: Using Conditioned Text

Prerequisites

- You have started WWI-enhanced Word (see: Starting and Closing WWI [Page 155]).
- You want to eliminate repetitions.

Procedure

1. Select the symbol you want to define as conditioned text.
2. Choose WWI → Conditioned Text.

   Word inserts square parentheses around the symbol. You define the color of the parentheses in the Basic Settings.

   ![Lightbulb](lightbulb.png)

   Conditioned text cannot be inserted over several table cells.

See also:

Conditioned Text - Example [Page 200]
Conditioned text [Page 248]
Conditioned Text - Example

Please note that the symbol keys listed are examples only.
This example demonstrates how you can use conditioned text to prevent repeated text from being output by the system.

You want to output a list of substance components:

\[\text{Component} \quad \text{Benzene} \]
\[\text{Component} \quad \text{Toluene} \]
\[\text{Component} \quad \text{Ethanol} \]

The system outputs the following list:

Component    Benzene
Component    Toluene
Component    Ethanol

Conditioned text results in the following:

\[\text{Component} \quad \text{Benzene} \]
\[\text{Component} \quad \text{Toluene} \]
\[\text{Component} \quad \text{Ethanol} \]

The system outputs the following list:

Component    Benzene
             Toluene
             Ethanol
WWI: Character Sizing

Prerequisites

- You have started WWI-enhanced Word (see: Starting and Closing WWI [Page 155]).
- You want to adjust the characters to fit a frame.

Procedure

1. To insert a frame, choose Insert → Frame.
2. Place the cursor in the top left-hand corner of the frame for which you want to define character sizing.
3. Choose WWI → Automatic Character Sizing.

   The system generates a dialog box in which you enter the
   - Minimum font size in points
   - Maximum font size in points

   If you define another frame or table in the report template directly after a frame with dynamic text sizing, you separate the objects with a paragraph mark. The paragraph marks may not be formatted as hidden. Otherwise, the text size will not be adjusted.

See also:

Character Sizing - Example [Page 202]
Character Sizing [Page 249]
Character Sizing - Example

Please note that the symbol keys listed are examples only.

A control symbol for character sizing looks as follows:

<100DYNTXT(8,32)> Complete symbol entry in top left-hand corner of the frame

Notes:

- Symbol type 100 (symbol type Font size)
- Symbol key (DYNTXT = dynamic text)
- Minimum font size
- Maximum font size
WWI: Checking Templates

Prerequisites
You have started WWI-enhanced Word (see: Starting and Closing WWI [Page 155]) and created the layout for a document so that you want to return to the R/3 System.

Procedure
Choose WWI → Check Layout.

Result
The document template created is checked. The system creates a structure file in ASCII format that contains all control objects in the template (with the exception of character sizing objects).

The syntax checks on the structure file are as follows:
- Analysis of the structure file (finds symbols and control data)
- Check for all symbols and their parameters
- Check for all repeating groups and their parameters
- Check for all symbol nesting
- Creation of error log
- Saving the structure information

The structure information is not stored until the check routine has been completed.
Maintaining Generation Variants

Purpose

Substance report generation variant links report templates to a leading validity area and to one or more substance characteristic ratings (see: Usage [Page 46]).

A report can also contain sections for which you have defined discrete validity areas and a language (for instance, multi-language hazard labels). You allocate discrete validity areas and the relevant languages in the substance report generation variant.

Process flow

1. You can carry out the following activities in the initial generation variant maintenance screens:
   – You can enter different search criteria, and start drill-down reporting for the required generation variants. If the required generation variant does not exist in the R/3 System, you can create it.
   – You can create a generation variant immediately.

2. The results of the search are displayed in the hit list. In the hit list, you then process the generation variants, and create new ones.

3. When creating a generation variant on the initial screen or from the hit list, you first enter the data for the generation variant header. You thereby allocate a report template and a leading validity area to the generation variant.

4. You maintain the description for the generation variant in different languages using the Label function.

5. You specify the following definitions for the generation variant:
   – In the rating, you define the target group for the report template.
   – The leading (global) validity area is maintained when a generation variant is created.

   If you want to define specific areas on a report in particular languages, you must enter further discrete validity areas together with the respective language. You use
repetition groups of type G to define the access to discrete validity-language combinations on the report template.

**Result**

After you have allocated a report template to a generation variant, you can generate and print test reports for viewing purposes.

If the report template is released, you can create reports and, using the report management functions, release them for shipping.

**Procedure**

Processing Ratings and Validity Areas for Generation Variants [Page 212]

**More information**

Repeating Groups [Page 243]

Report Management [Page 258]

Report Shipping [Page 290]
Generation Variants: Procedures

Searching for Generation Variants [Page 207]
Creating Generation Variants [Page 208]
Processing the Generation Variant Hit List [Page 209]
Processing the Generation Variant Header [Page 210]
Assigning Labels to Generation Variants [Page 211]
Processing Ratings and Validity Areas for Generation Variants [Page 212]
Searching for Generation Variants

1. From the Product Safety [Ext.] screen, choose Reports → Edit or Display GenVariants.
   The initial screen appears. You can start drill-down reporting from here. During the search, all entries are linked with AND.

2. Enter the data known to you. The R/3 System supports double-sided generic search (<*K15*>) in the Generation variant and Template/-version fields.
   - The system does not differentiate between lower case and upper case letters during search runs.
   - The system takes special characters into account: underscores, hyphens, commas, periods, blanks, parenthesis, and so on.

3. Choose Variant → Navigation → Hit list.

Result

The R/3 System lists the generation variants that match the search criteria in the hit list.

See: Processing the Generation Variant Hit List [Page 209]

If the R/3 System does not find the required generation variant, you can enter new search criteria, or create the generation variant yourself.
Creating Generation Variants


3. You must process the generation variant header: Processing the Generation Variant Header [Page 210].

You can create generation variants from within the hit list after drill-down reporting by choosing Variant → Create.
Processing the Generation Variant Hit List

1. From the Product Safety [Ext.] screen, choose Reports → Edit or Display GenVariants. The initial screen appears.

2. Enter your search criteria on the initial screen (See: Searching for Generation Variants [Page 207]): and choose Variant → Navigation → Hit list.
   
   If the R/3 System finds data records that correspond to your search criteria, the hit list appears.
   
   See also: Basic Functions in the Hit List [Page 157]

3. Select the variants you want to process.

   ![Selected phrases can be processed using the functions from the Edit menu.]

4. You process substances further by choosing the functions in the Goto menu.

   Processing the Generation Variant Header [Page 210]
   Assigning Labels to Generation Variants [Page 211]
   Processing Ratings and Validity Areas for Generation Variants [Page 212]
Processing the Generation Variant Header

Prerequisites

You must have already created the report template that you allocated to the generation variant (See: Creating Document Templates [Page 150]).

Procedure

1. If you want to Then choose
   Create the variant header Variant → Create on the initial screen or in the hit list
   Edit the variant header Goto → Header in the hit list, description or rating

The generation variant header appears.

2. Enter the required data in the generation variant header. Please observe the following notes:

<table>
<thead>
<tr>
<th>Generation variant</th>
<th>Enter a key for your generation variant when creating it.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validity area</td>
<td>Enter the leading validity area for the generation variant.</td>
</tr>
</tbody>
</table>

💡 You can define more validity areas by choosing Rating/Validity.

<table>
<thead>
<tr>
<th>Report type</th>
<th>Enter the report type (MSDS, label) to be used for the report template that you allocate to this generation variant.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template/-version</td>
<td>Enter the key and the version of the report template to be allocated to the generation variant.</td>
</tr>
</tbody>
</table>

Controlling report management

You use the indicator and the initial status to control which statuses reports must acquire in turn in report management.

See: Generation Variant Indicator [Page 252]

Display options

<table>
<thead>
<tr>
<th>Date format</th>
<th>Choose a date format as required.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal display</td>
<td>Choose a decimal display as required.</td>
</tr>
</tbody>
</table>

⚠️ Do not change your generation variant after you have used it for generating reports.

3. Choose Enter and save your changes.

Result

The R/3 System completes the administrative data.
Assigning Labels to Generation Variants

1. On the variant header screen, rating/validity screen or in the hit list, choose Goto → Label.

   The Edit Generation Variant: Label screen appears.

2. Place the cursor in the column under Language key and select the required language.

3. Enter the label for the generation variant beside this.

   ![Lightbulb]

   You can edit the selected lines using the functions from the Edit menu.

4. Choose Enter and save your changes.

   The system enters the appropriate languages for the language keys.
Processing Ratings and Validity Areas for Generation Variants

1. On the generation variant header screen, label screen or in the hit list, choose Rating/Validity.
   The Process Generation Variant: Rating/Validity screen appears.

2. Enter the required rating under the Characteristic rating field.

3. Choose Enter.
   The system completes the rating descriptions.

   ![Light Bulb]
   You can specify a priority for a rating. During the generation process, the system first takes all characteristic values with priority 1 into account. If no characteristic values exist for this rating, characteristic values with a rating of lower priority are used.

4. In the column under the Validity area field, enter a validity area if you want to define a special validity area for particular sections of your report. You can enter several validity areas.

5. Choose Enter.
   The system completes the validity area descriptions.

6. In the column under the Language field, enter the required language for the validity area.

7. If required, specify a sort sequence for the validity areas.

8. Choose Enter and save your changes.
   The system completes the country and language descriptions.

   ![Light Bulb]
   You can edit selected lines using functions in the Edit menu.
Document Types in Substance Reporting

**Definition**

The following document types are used in substance reporting:

- **Report Template (SBV) [Page 214]**
  
  Documents of document type SBV use various types of symbol to define the contents of your report. The link between report templates and substance report generation variants enables you to generate reports (SBR) and final reports (SBE).

- **Reports (SBR) [Page 215]**
  
  Reports are generated for specific substances using released report templates. Report bodies contain expanded substance data.

- **Final Report (SBE) [Page 216]**
  
  Final reports are based on released reports. When reports are shipped, data from other R/3 components is added to complete the final report in a second generation run.

- **Cover Sheet Template (DBV) [Page 217]**
  
  Cover sheet templates use various types of symbol to define the layout of cover sheets.

- **Cover Sheet (DBE)**
  
  The final version of a cover sheet is generated directly from a cover sheet template. Cover sheets are generated from a report at the same time as the final report.

- **Inbound Documents (IBD) [Page 218]**
  
  Inbound documents are scanned documents created in external systems.

- **Acknowledgement of Receipt Templates (EBV) and Acknowledgements of Receipt (EBE)**
  
  Just like cover sheet templates, you can define templates for acknowledgments of receipt that are then used to generate acknowledgements of receipt.

  In order to do this, you must have defined the following settings in Customizing for Product Safety:
  
  - In the IMG activity *Check shipping reasons*, set the indicator for acknowledgement of receipt.
  
  - In the IMG activity *Allocate templates: cover sheets/acknowledgements of receipt*, make the allocations as required.
Report Template (SBV)

Definition

Report templates define the layout of documents. Various symbol types link the template with data stored on the R/3 substance database and data from other R/3 components.

The symbols contained in a document template have not yet been expanded, that is, they have not been replaced by substance data, phrases or field values.

Use

R/3 System ↔ Winword

When you create a report template, R/3 calls an enhanced version of Winword, the so-called WWI (Windows Word Processor Integration) [Page 219]. During processing the file is held locally on your PC.

When you exit Winword, the Winword RTF file is downloaded to the R/3 database, saved there, and then deleted from the local data carrier.

As the generated document is saved as an RTF document, the generation is carried out independently of the language of the Word version.

Link to the Substance Report Generation Variant

Report templates are linked with their usages by SBGV (Generation Variant [Page 250]). Usages define the validity areas and ratings for which a symbol of type Symbol contained in the report template may be expanded. The Usage [Page 46] must therefore have been maintained:

- for the SRGV to which you allocate the report template
- and for the individual characteristic values assigned to substance characteristic categories of those substances for which all symbols of symbol type Symbol are to be expanded in your report template. (To ensure that the system expands characteristic values, you must set the active indicator of the substance characteristic.)

You can only start report generation after you have released the report template and linked it with a substance, an SRGV, a language, and a key date.
Reports (SBR)

Definition

The **report** is the result of a first generation run using a report request that was requested for a report template. (See: Report Template (SBV) [Page 214]).

- Using a **substance report generation variant**, the report is generated directly for a **substance** on a **key date** in a specific **language**. Symbol types **Symbol** and **Phrase**, that is, those placeholders that reference data stored on the R/3 substance database, are expanded.

- All other placeholders (symbol type **Parameter**) refer to data stored in other applications. This data is expanded in a second generation run. The result is the Final Report (SBE) [Page 216].

Use

Report management supports you in all steps required for processing reports until they are released. Released reports can be sent and thus generated as final reports. Report management ensures that you can check the contents of a report body at any time without having to access the substance database. This feature enhances system performance.
Final Report (SBE)

Definition
You generate final reports (synonymous to “Reports ready to be shipped”) using Reports (SBR) [Page 215]. The system uses the following criteria to select the appropriate report:

- The substance for which you generated the report
- The generation variant that defines the validity area and rating of the report.
- The language in which all phrases are expanded in the report body
- The key date, if you are using engineering change management

The R/3 System expands all other data when it generates the final report. This data does not stem from R/3 Product Safety but from other R/3 components and completes the report. Data from other components may, for instance, be

- Material data
- Customer data

Use
You can generate final reports with or without triggering shipping:

- Generation without shipping
  
  You generate the report manually to check the layout of the report.
  
  See: Testing Layouts [Page 274]

- Generation with shipping
  
  You can trigger this function manually or automatically from the R/3 component Sales and Distribution (SD).
  
  See: Report Shipping [Page 290]
Cover Sheet Template (DBV)

Definition

Cover sheet templates define the layout of a cover sheets (letters, for example) used for reports.

You create cover sheets in the same way as report templates using an enhanced version of Winword (Winword Wordprocessor Integration (WWI)) and various symbol types (see: Report Template (SBV) [Page 214]).

Cover sheets are always expanded completely in one generation run. There are no intermediate stages.

Use

As cover sheet templates are always expanded completely, the system only expands symbol types with an expansion fence > 10.

See: Expansion fence [Page 220]

To be able to generate a cover sheet template, you must have carried out the following steps in Customizing for Product Safety:

- In the IMG activity Check shipping reasons, set the cover sheet indicator.
- In the IMG activity Allocate templates: cover sheets/acknowledgements of receipt, make the allocations as required.
Inbound Documents (IBD)

Definition

Inbound documents are substance reports that were not generated in your R/3 System. They were generated in an external system (that may also be an R/3 System) and imported into your R/3 System.

When importing, a key file must exist for the report file. The key file defines the allocations to the substance report generation variant, the language and the substance.

See: Importing Reports [Page 442]

Use

You will mostly import inbound reports if you want to transfer reports that already exist in old systems, or if you want to manage reports that have been sent to you.

After being imported, the inbound report keeps the initial status as defined in the generation variant header, and is managed in exactly the same way as a substance report generated in the R/3 System.
**WWI (Windows Word Processor Integration)**

**Use**

The so-called WWI is an enhanced version of Winword that is called from the R/3 System when you want to edit or create a report.

**Features**

WWI differs from the standard Winword:

- The menu bar contains the new **WWI** menu. You use the functions in the WWI menu to create symbols, control indicators and special expansion categories so that data from the R/3 System is formatted in the desired way when generating is carried out.

- There is a new WWI toolbar.

- Some options in Winword menus are disabled. You cannot save your document to the hard disk of your PC, for instance.

To be able to process a document template in WWI, you should be familiar with Microsoft Word.
Expansion fence

Different expansion fences for the different symbol types are specified in Customizing for Product Safety in the detail view of IMG activity Check and define report symbols.

The following expansion fences are defined as standard:

<table>
<thead>
<tr>
<th>Symbol Type</th>
<th>Expansion Fence</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Phrase</em> for report templates (symbol name, for instance <code>EHS_L_TEXT</code>)</td>
<td>0</td>
</tr>
<tr>
<td>Symbol</td>
<td>10</td>
</tr>
<tr>
<td><em>Phrase</em> for cover sheets (symbol name, for instance <code>EHS_H_TEXT</code>)</td>
<td>20</td>
</tr>
<tr>
<td>Parameter</td>
<td>20</td>
</tr>
</tbody>
</table>

When using symbol type *Phrase*, you need to differentiate whether the phrase is used for a report template or a cover sheet.

During the first generation run, the system always generates reports from report templates. The system only expands symbol types with an expansion fence of 0 – 10.

During the second generation run, the system generates final reports from reports and final cover sheets from cover sheet templates. The system only expands symbol types with an expansion fence of 11 – 20.

Phrases can thus only be expanded on cover sheets if their expansion fence is > 10. The symbol name for this type of symbol is `EHS_H_TEXT`.
Report Creation Procedure

The graphic below shows the procedure you need to follow to create a report that is ready to be shipped.

```
Reporting. Creating Templates
1) Create report/cover sheet template (EH&S)
2) Edit report/cover sheet template (WWI)
3) Create SRGV
4) Check report template
5) Release report/cover sheet template
6) Allocate cover sheet template (IMG)

Reporting: Generating Reports
7) Create report = report request
8) Generate report
9) Check report
10) Release report
11) Generate reports ready to be shipped
```
Document Template Objects

Definition

Report templates can contain the following objects:

- **Static objects**
  
  Static objects are not language-dependent and do not reference substance data. You enter these objects on the template using Word functions. Examples:
  
  - Separators
  - Graphics
  - Word tables
  - Colors

- **Symbols**
  
  Symbols [Page 223] are used to access data in R/3 Product Safety or other R/3 components. There are three symbol types:
  
  - Symbols of Symbol Type Phrase [Page 224]
  - Symbols of Symbol Type Symbol [Page 225]
  - Symbols of Symbol Type Parameter [Page 227]

- **Control objects**
  
  These objects control data selection and output. The system supports the following control objects:
  
  - Repeating Groups [Page 243]
  - Blank Compression [Page 247]
  - Conditioned text [Page 248]
  - Character Sizing [Page 249]

See also: Layout of an Abridged Material Safety Data Sheet: An Example [Page 228]
Symbols

Definition
You use symbols to allocate data from R/3 Product Safety and other R/3 components to certain positions in your Winword document. Symbols contain key information that the R/3 System uses to access the R/3 substance database or other R/3 tables automatically and to output the corresponding values on the substance report.

Structure

Customizing
Various symbols are contained in the IMG activity Check and define report symbols in Customizing for Product Safety.

The following symbol types are used as placeholders for data in document templates, for instance:

<table>
<thead>
<tr>
<th>Key of symbol type</th>
<th>Name</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>Symbol</td>
<td>Placeholder for characteristic values, phrase-related characteristics, and table fields of R/3 Product Safety</td>
</tr>
<tr>
<td>02</td>
<td>Parameter</td>
<td>Placeholder for table field values from other R/3 components (for instance, SD data)</td>
</tr>
<tr>
<td>03</td>
<td>Label/Phrase</td>
<td>Placeholder for phrase texts from R/3 Product Safety</td>
</tr>
</tbody>
</table>

You can allocate the symbols to substance characteristic categories and their characteristics on the detail screen of the Customizing table. On this screen, you can also maintain the allocation of symbols to table fields.

Automatic Generation of Symbols
When you adjust the master data, the system automatically generates symbols for the following IMG activities:

- For the entries in IMG activity Specify R/3 tables for report symbol generation. You can specify the table fields for which you want to generate symbols.
- For all defined substance characteristic categories and characteristics in IMG activity Specify substance characteristic categories.

If you have created new substance characteristic categories and characteristics and want to use these in your reports, you need to adjust the master data again to generate the relevant symbols.

See: Master Data Adjustment [Page 255]

Symbol key
The generated symbol keys have a unique nomenclature.

See: Nomenclature of Symbol Names [Page 239]
Symbol Type Phrase

Symbol Type *Phrase*

Use
Symbols of symbol type *Label Phrase* reference phrases in the phrase management of R/3 *Product Safety*. You use this symbol type to insert language-independent, standardized text modules into your document template.

Features
When generating the report, the R/3 System selects the phrases that are specified in a symbol of type *Phrase* using the phrase key and library. The phrases are expanded in the language that you specified using the language key.

Using a symbol of symbol type *Phrase*, you also insert phrase codes and graphics into templates. For this, you need to specify the appropriate expansion category in the Windows Wordprocessor Integration (WWI). The complete name of the graphics file (including its extension) must be entered as a phrase item.

You can also insert graphics dynamically in WWI. The graphics file must be located in the WWI *LAYOUT* directory. To insert the graphic, choose *Insert → Picture* in WWI.

If you define a repeating group of the type *Validity and language area*, within a document template, you can output language-dependent symbols in different languages in accordance with the validity area. In such cases, the system uses the discrete validity area - language combinations defined in the generation variant (see: *Generation Variant* [Page 250]).

See also:
Section A in *Layout of an Abridged Material Safety Data Sheet: An Example* [Page 228].

Activities
*WWI: Inserting Phrases* [Page 171]
*WWI: Inserting Symbols* [Page 173]
Symbol Type Symbol

Use
You use symbols or symbol type Symbol to insert the following data from R/3 Product Safety:

- Characteristic value (symbol type Symbol, symbol group Symbol)
- Graphics, phrases or codes of a phrase-related characteristic (symbol type Symbol, symbol group Phrase)
- Value of a table field in R/3 Product Safety, for instance, Identifiers (symbol type Symbol, symbol group Symbol)

Features
The following expansion categories are available for the symbol type symbol:

- Barcode
  The system can convert symbols according to customer requirements and output them as a barcode.

- Identifier
  A symbol can be expanded as a specific identifier. The identifier is defined using the identification type, the identification category, and, in certain cases, the substance list allocated to the identifier.

- Expansion Masks
  You can define an expansion mask for numerical values and thus define, for example, the number of decimal places before and after the period.

- Function Module
  In addition, you can create user-defined expansion categories. In this case, you need to specify the key of a function module.

You insert symbols of symbol type Parameter in the same way as symbols of symbol type Symbol.

Phrases of phrase-related characteristics as well as some identification categories are language-dependent. These symbols are expanded in the language you specified when you started report generation.

If you define a repeating group of the type Validity and language area, within a document template, you can output language-dependent symbols in different languages in accordance with the validity area. In such cases, the system uses the discrete validity area - language combinations defined in the generation variant (see: Generation Variant [Page 250]).

See also:
Section B in Layout of an Abridged Material Safety Data Sheet: An Example [Page 228].
Symbol Type Symbol

WWI: Inserting Symbols [Page 173]
Symbol Type Parameter

Use
Symbols of symbol type Parameter do not reference data from R/3 Product Safety, but data from other R/3 components.

Features
The following expansion categories are available for the symbol type parameter:

- **Barcode**
  The system can convert symbols according to customer requirements and output them as barcode.

- **Expansion Mask**
  You can define an expansion mask for numerical values and thus define, for example, the number of decimal places before and after the period.

- **Function Module**
  In addition, you can create user-defined expansion categories. In this case, you need to specify the key of a function module.

See also: Sections A and F in Layout of an Abridged Material Safety Data Sheet: An Example [Page 228].

Activities
You insert symbols of symbol type Parameter in the same way as symbols of symbol type Symbol.

WWI: Inserting Symbols [Page 173]
Layout of an Abridged Material Safety Data Sheet: An Example

Below you can see a report template used to generate an abridged material safety data sheet. You can also access the expanded report template.

Expanded Report Template: An Example [Page 230]

The symbol names are only examples.

A see: Notes on Section A [Page 233]

1  <03EHS_L_TEXT(CED-SDB)> ¶
2  <03EHS_L_TEXT(CED-SDB1)> ¶
   ¶
3  <03EHS_L_TEXT(CED-SDB4)> → <02GLIPSARKTX> ¶

B see: Notes on Section B [Page 234]

1  <03EHS_L_TEXT(CED-SDB12)> ¶
   ¶
2  <03EHS_L_TEXT(CED-SDB13)> ¶
   ¶
3  <01GESTRIDENT(I:NAM,TRIV,)> ¶
4  <01GESTRIDENT(I:NAM,CC,)> ¶
   ¶
5  <03EHS_L_TEXT(CED-SDB-02-06)> ¶
6  <11BRG001 (M,SAP_EHS_1023_001;*)><01G1023001SY(C,*))> <11ERG001> ¶
   ¶

C see: Notes on Section C [Page 235]

1  <03EHS_L_TEXT(CED-SDB-02-03)> ¶
   ¶
2  <11BRG003 (M,SAP_EHS_1012_004;*)> ¶
   ¶
3  <03EHS_L_TEXT(CED-SDB-01.002)> ¶ <03EHS_L_TEXT(CED-SDB-02-07)> ¶ <03EHS_L_TEXT(CED-SDB-02-05)> ¶
Layout of an Abridged Material Safety Data Sheet: An Example

D see: Notes on Section D [Page 236]
1 <03EHS_L_TEXT(CED-SDB18)> ¶
2 <03EHS_L_TEXT(CED-SDB-04-05)> ¶
3 <01G1015003AD(P;01)> <11BRG004(D;2-*)> ¶
4 <01G1015003AD(P;2-*)> <11ERG004> ¶

E see: Notes on Section E [Page 237]
1 <03EHS_L_TEXT(CED-SDB-09-01)> ¶
2 <11BRG004 (M,SAP_EHS_1013_019;*)> ¶
3 [<03EHS_L_TEXT (CED-SDB-09-13)> <01G1013019VA> <01G1013019ET> <03EHS_L_TEXT(CED-SDB-09-001)> <01G1013019SQ>)] ¶
4 <11ERG004> ¶
5 <11BRG005 (M,SAP_EHS_1013_005;*)> ¶
6 [<03EHS_L_TEXT (CED-SDB-09-12)> <01G1013005VA >01G1013005ME>(N:"ZZ9,999 DDDDDDDDDDDDDDDDDDD;";*)> ¶
7 <11ERG005> ¶

F see: Notes on Section F [Page 238]
1 <03EHS_L_TEXT(CED-SDB-8-5)> <02GCVDPLOGID> <03EHS_L_TEXT(CED-SDB-01.004)> 1 / 1 ¶

April 2001 229
Expanded Report Template: An Example

Below you can see the report that was generated using the sample report template (see Note on the Example “Report Template with Symbols”: Prerequisites for Generation [Page 232]):

A
1 Material Safety Data Sheet
2 According to 91/155/EEC
3 Product: EXTRATHION

B
1 1. Composition/Constituent Data
2 Chemical Characterization
3 Plant protective, contains malathion
4 Insecticide concentrate, liquid
5 Hazard symbol:
6 T+, Xn

C
1 Hazardous Components:
3 IUPAC Name  R Records:  Contents:
5 Malathion  R20/22  22 %
   Toluol  R20/22, R10  33 %
   Cyclohexanone  R10, R20/22  > 38 %

D
1 2. First Aid Measures:
2. **On eye contact:**

3/4 If eye irritation persists, contact your doctor. *

Wash thoroughly with plenty of water. Do not forget to wash under the eyelids. *

Protect unaffected eye.

---

E

1. **Physical and Chemical Properties**

3. PH value:  
   - (20.00 °C) 5.8 - 7.1  (at 0.00100 g/cm³)  
   - (25.00 °C) 6.1 - 7.5  (at 0.00110 g/cm³)

6. Density:  
   - (25.00 °C) 0.97 g/cm³  (DIN 51793/55)  
   - (30.00 °C) 9 kg/m³  (ISO 1234)

---

F

1. Report No.: 000001  

Page: 1 / 1
Note on the Example "Report Template with Symbols": Prerequisites for Generation

The following prerequisites must be met, if the system is to expand all symbols when you generate a report manually.

- The values of the characteristics, phrases, and table fields to which the symbols refer have been maintained
  - for the substance for which you want to generate the report.
  - for the components of the substance as section C contains symbols that reference the hazardous components of the substance.

- The usages allocated to the characteristic values must be identical to the validity area and the rating for the generation variant.

- You must have set the active indicator for the individual characteristics.

- You need to record the value for symbols of type Parameter manually (in this case: Product: EXTRATHION and report no.: 000001). (Data for the symbol type parameter is only expanded from the relevant R/3 component when you trigger automatic shipping.)
Notes on Section A

Lines 1-3: The symbol \textit{EHS\_L\_TEXT} (symbol type \textit{Label / Phrase}) with symbol name references text modules in a phrase library. The round parenthesis contains the phrase library key and the phrase key. These keys are separated by a hyphen.

Line 3: The symbol of symbol type \textit{Parameter} references data from other R/3 components. In this case, symbol \textit{GLIPSARKTX} references the material description.
Notes on Section B

Lines 3, 4: The symbol of symbol type Symbol with symbol name GESTRIDENT references identifiers.

Line 3: The system selects all identifiers type NAM and category TRIV.

Line 4: The system selects all identifiers type NAM and category CC.

Line 6: The symbol of symbol type Symbol and expansion category GPC + C define that the system outputs the phrase code for a phrase-related characteristic. In the example, the phrase codes refer to characteristic Hazard symbol (symbol name G1023001SY) of characteristic category Labeling (symbol name SAP_EHS_1023_001). The asterisk * in symbol <01G1023001SY (C;*)> denotes that the system is to output all phrase codes in the characteristic record of the characteristic.

A repeating group type master (M, SAP_EHS_1023_001) is defined around symbol G1023001SY in case several characteristic records exist for the substance characteristic category Labeling. The asterisk * (M,SAP_EHS_1023_001;*) denotes that the system is to output all characteristic records.

The repeating group is defined by the control objects start of repeating group BRG001 and end of repeating group ERG001 as well as by the definition of the group as a master (M,SAP_EHS_1023_001;*).

The system searches in substance characteristic category SAP_EHS_1023_001. It outputs all characteristic values allocated to characteristic G1023001S as phrase code. Therefore, for substance characteristic category with the key SAP_EHS_1023_001, the system searches in all characteristic records for all characteristics with the value G1023001SY and outputs them as phrase code.

All repeating groups terminate with “end of repeating group (ERGnnn)”. All control objects are automatically assigned a serial number.
Notes on Section C

You can use Word function *Table* when you want to define a table in your document.

Line 3: The symbol of symbol type *Phrase* creates the column headings.

Line 5, 6 / column 1: The symbol of symbol type *Symbol* with symbol name *GESTRIDENT* references identifiers. The system selects all identifiers type *NAM* and category *IUPAC*.

Line 5 / column 2: The symbol of symbol type *Symbol* with expansion category *GPC + C* outputs the phrase codes for the phrase-related characteristic *R-records* (symbol name *G1023001R2*) of substance characteristic category *Labeling* (symbol name *SAP_EHS_1023_001*).

Line 5-8 / column 3: The symbol of symbol type *Symbol* is used to output three R/3 table fields of R/3 *Product Safety*.

- Symbol name *GESTVPRECL* references field *Operator lower limit*. The system outputs <, > or *nothing* depending on the field value.

- Symbol name *GESTVCOMPL* references field *Lower limit component* and outputs the *value* of the field.

- Symbol name *GESTVCOMPE* references field *Exponent* and outputs the exponent type, for instance, %, %%.

Lines 4 and 6 or 9: The definition of a repeating group type *Slave* (S:POS) ensures that the system outputs all components listed under substance characteristic category *Hazardous components*. The system outputs the following data for these components according to the symbols:

- Identifiers (IUPAC NAME)
- All risk records
- The percentage of the individual components in the hazardous constituents.

In order to define a line break after each component, you need to enter *SHIFT + RETURN* (↓) after control object <BRGnnn(SPOS;*)>.

Lines 2 and 10: To ensure that the system outputs all hazardous components (symbol name *SAP_EHS_1012_004*) in the tables defined above, you need to define a repeating group type *Master* that references characteristic category *SAP_EHS_1012_004* around the whole table.
Notes on Section D

Lines 3, 4: You want to output all phrases allocated to phrase-related characteristic *First aid eye contact* (symbol name *G1015003AD*) as a list with each item *separated* by an asterisk. Please note that you need to enter periods that you want to output at the end of a phrase manually.

Using the symbol of symbol type *Symbol* and expansion category *GPC + P*, you first define that the system only outputs the first phrase of the phrase-related characteristic.

You now need to insert the same symbol once more and define that the system outputs all phrases with the exception of the first. Insert a repeating group type *D* (discrete expansion of multiple values) around the symbol. You need to specify, both in the control object as well as in the symbol that the system is to output all values with the exception of the first (2-∗). Insert a line break after the control object <11BRPnnn(D;2-∗)>. Define a colon as separator.

- If you only want to output the phrases as a list without a separator, you only need to define a repeating group type D around the symbol and a line break behind it:

  <11BRG004(D;∗)> <01G1015003AD(P;∗)> ¶
  <11ERG004>

- The quantity definition in the discrete repeating group does not have any effect on the report you output. Instead, it is the quantity definition around the symbol that determines the number of values the system outputs for a characteristic with multiple values.
Notes on Section E

Line 3: You defined a table and want to output the following data in the table columns:

- Labels (using a symbol of symbol type "Phrase"). You want to output the label and a colon in the first column. To prevent the label from being repeated in each cell of the first column, use the conditioned text function.

- Values for various characteristics (using a symbol of symbol type "Symbol"). These characteristics are part of characteristic category "pH value" (symbol name "SAP_EHS_1013_019").

Lines 2, 4: To output all characteristic records, you need to define a special repeating group type "Master" around the complete table.

Lines 5-7: A table for characteristic category "Density" (symbol name "SAP_EHS_1013_005") is defined in a similar way in these lines.
Notes on Section F

Line 1: Apart from the symbol of symbol type Phrase the footer also contains the symbol of symbol type Parameter that is used to output the report number. When the report is generated from SD, the report number is assigned automatically by the system.
Nomenclature of Symbol Names

Symbol keys of standard characteristics

The symbol name that the system generates for a standard characteristic contains:

- A G
- A part of the class key (see: Nomenclature of Standard Class Keys [Page 241])
- A part of the characteristic key (see: Nomenclature of Standard Characteristic Keys [Page 242])

The following nomenclature only applies to symbols that you created from standard characteristics as of Release 3.0F. Symbol keys you generated earlier remain unchanged.

G10100001AB Complete symbol key

Notes:

G……………… Letter G (stands for generation)
G1010………. Four-digit cluster of class key
G1010001… Class number
G1010001AB Two characters from the specific component of the characteristic key:
- If the specific component contains an underscore, the system uses the first letter and the first letter after the underscore (AB_CD => AC).
- If the specific component does not contain an underscore, the system uses the first two characters.

Symbol keys for tables or structure fields and non-standard characteristics

The symbol key also commences with a G. The rest of the symbol key is made up in the following way:

- The symbol keys for R/3 table fields consist of the first four characters of the table name and the first five characters of the field name.

Tables in the R/3 components always begin with EST (ESTRI, ESTVH). The symbol key for the IDENT field, is thus GESTRIDENT (symbol key for identifier)

- The symbol keys for substance characteristic categories consist of the first four characters of the class name and the first five characters of the characteristic name.
Nomenclature of Symbol Names

If two symbols should feature identical names, the system replaces the final character with a digit.
Nomenclature of Standard Class Keys

The example below explains the structure of class keys.

SAP_EHS_1010_001  Complete class key

Notes:

SAP_EHS: all class keys shipped with the standard R/3 System feature this key

SAP_EHS_1010: Four-digit cluster.

– The first two digits denote the shipment.

Example:

SAP_EHS_10: standard shipment
SAP_EHS_11: standard shipment Pharmaceuticals

– The next two digits group classes according to their position in the properties tree. As a rule, all classes allocated to a node of the tree are grouped.

Example:

SAP_EHS_1010: contains all classes of node Administration

Serial number of all classes of cluster SAP_EHS_1010

SAP_EHS_1010_001, SAP_EHS_1010_002, and so on

In the standard system, substance characteristic categories have the same name as the class they are allocated to.
Nomenclature of Standard Characteristic Keys

The example below explains the structure of characteristics keys.

**SAP_EHS_1010_001_STREET**  Complete characteristic key

<table>
<thead>
<tr>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP_EHS_1010_001..........</td>
</tr>
<tr>
<td>SAP_EHS_1010_001_STREET</td>
</tr>
<tr>
<td>SAP_EHS_1010_001_CONTACT_PART</td>
</tr>
<tr>
<td>SAP_EHS_1010_001_CONTACT_DATE</td>
</tr>
<tr>
<td>and so on</td>
</tr>
</tbody>
</table>
Repeating Groups

Use

Repeating groups iterate over data objects stored on the substance database. If a symbol refers to several data records, you can use the repeating group to control which data records are to be output.

Features

A repeating group carries two main items of information:

- You use the following types of repeating groups to allocate the object whose data records are to be read in a loop.

  See also: Repeating Group Types [Page 245].

  Repeating group **type** | Identification code for the object in the symbol
  -- | --
  Master | \( \text{M} \)
  Slaves | \( \text{S:PO} \), \( \text{S:POSD} \), \( \text{S:FREI} \), \( \text{S:VERW} \), \( \text{S:CLASS} \) (see also Example: Repeating group \( \text{S:CLASS} \) [Page 189])

- Validity and language area | \( \text{G} \)
- Discrete expansion of multiple characteristic values | \( \text{D} \)
- Sources | \( \text{Q} \)

A slave always references the data for a characteristic value. In order for the system to allocate the right characteristic category, a slave must nest in a master.

- You use the following identification code to define a data output restriction if not all of the symbol’s data records are to be read in a loop.

  **Identification code** in the symbol | **Description**
  -- | --
  \( n \) | The system selects value “n”
  \( * \) | The system selects all values it finds
  \( n-m \) | The system selects all values from “n” to “m”
  \( n-* \) | The system selects all values starting as of “n”
Repeating Groups

The range is always separated from the other parameters of the symbol by a semicolon.

\[<11BRG001(M,SAP_EHS_1015_003;1-3)>\]
\[<01G1015003AD(P;01)>\]
\[<11ERG001>\]

The system expands the first three characteristic records of characteristic category SAP_EHS_1015_003 and outputs the first phrase of the characteristic G1015003AD.

Nesting check

You can define nesting structures for repeating groups. The system checks the nesting. The syntax graph below illustrates valid nesting structures for repeating groups.

You can determine all valid structures by following the arrows.

Activities

WWI: Inserting Repeating Groups [Page 182]
Repeating Group Types

Use
Repeating groups are organized according to their different functions using types.

Features

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Master</td>
<td>Masters read the characteristic values of characteristic categories in a loop. You therefore always need to specify the key of the substance characteristic category.</td>
</tr>
<tr>
<td>(M)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Dependent tables:</td>
</tr>
<tr>
<td></td>
<td>– Substance ↔ Characteristic category allocation (ESTVH)</td>
</tr>
<tr>
<td></td>
<td>– Substance characteristic (ESTVA)</td>
</tr>
<tr>
<td></td>
<td>– Source of substance characteristic (ESTDS)</td>
</tr>
<tr>
<td></td>
<td>– Source (TCG46)</td>
</tr>
<tr>
<td></td>
<td>– Characteristic rating (ESTDR)</td>
</tr>
<tr>
<td></td>
<td>– Rating key (TCG71)</td>
</tr>
<tr>
<td></td>
<td>– Rating text (TCG72)</td>
</tr>
</tbody>
</table>

Slaves

<table>
<thead>
<tr>
<th>(S:POS)</th>
<th>The repeating group iterates all components of a characteristic category of type Composition or Substance listing. The slave thus needs to nest in a master repeating group.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Dependent tables: Characteristic items (ESTVP)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>(S:POSD)</th>
<th>A component of characteristic category Composition or Substance listing may in turn consist of further components. You can expand these up to a specified depth. (If you do not specify a depth, the complete hierarchy is expanded.) The slave thus needs to nest in a master repeating group.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Dependent tables: Characteristic items (ESTVP)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>(S:FREI)</th>
<th>You can use this type of repeating group to expand and print user-defined texts you recorded for a characteristic of a characteristic category. Use the user-defined text or user-defined text category symbol and define a repeating group type S:FREI around the symbol. This type of repeating group must nest in a master repeating group.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Dependent tables: user-defined texts (ESTDF)</td>
</tr>
</tbody>
</table>
Repeating Group Types

(S:VERW) You use the symbol for ratings or validity areas to output usages. You then define a repeating group type S:VERW around the symbol. The usage is always allocated to the characteristic of a characteristic category.

The slave thus needs to nest in a master repeating group.

Dependent tables: additional information - substance characteristic usage (ESTDU)

(S:CLASS) The repeating group extends over all UN listed substances for a characteristic category of type Transport classification.

This means the repeating group must be nested in a master repeating group.

Dependent tables: Shipment EST0F

As UN listed substances in transport classification are allocated according to regulations, the system only outputs the listed substance legal data that are valid for this regulation. See also: Example - Repeating Group S:CLASS (Page 189)

Validity area and language

(G) If you defined discrete validity areas and languages in addition to the global validity area in the generation variant, you can use this type of repeating group to access these validity-language combinations.

The system determines in a loop all combinations you defined and uses them to determine the correct expansion value of the symbol in the repeating group.

You can use this function to expand data that is country-specific.

Discrete expansion of multiple values

(D) Normally, the system outputs multiple values in one line, separated by a comma. This repeating group type outputs values in separate lines and is thus defined directly around the corresponding characteristic that contains the multiple values.

See also: Section D in Layout of an Abridged Material Safety Data Sheet: An Example (Page 228)

Sources

(Q) Sources are assigned serial numbers and are appended to the document. You can choose between two options:

– An alphabetical list of all sources
– A list according to where the sources are used in the text

Dependent tables:

– Source of characteristic value
– Source (TCG46)
Blank Compression

Use
You use this function to define symbols for which values must exist. This is so that the values of further symbols that have been defined are output on a report.

You want to output an address consisting of a name, street, city, and country. If the system cannot find the name, you can ensure that it does not output the complete address.

Features
All entries that are between the beginning and end of the defined section are not output. You can link all symbols within the section using AND or OR.

The inclusion or non-inclusion of data in documents to correspond with legislative requirements is the responsibility of the user.

Activities
WWI: Blank Compression [Page 190]


Conditioned text

Use

Using conditioned text, you can specify that the system does not output repeated texts in tables.

Without conditioned text, the system would output the components of a composition as illustrated below:

Composition:
Component : Benzene
Component : Toluene
Component : Methanol

Using conditioned text (special repeating group) you define that the system does not output identical text elements.

Composition:
Component : Benzene
 : Toluene
 : Methanol

Activities

WWI: Using Conditioned Text [Page 199]
Character Sizing

Use
You can use the character sizing function to ensure that the system uses the optimum font size inside a Word frame. The system adapts the font size to the space available.
You can specify a range for the font size (for instance, 8 to 32).

Activities
WWI: Character Sizing [Page 201]
Generation Variant

Use
This function controls the generation and the procedure in report management:

- Controlling generation
  Substance data stored in the R/3 substance database needs to automatically reach the correct addressee in accordance with the validity area and rating.
  
  The substance report generation variant (SRGV) forms the link between the report template and the usage, that is made up of the validity area and the rating. You maintain the usage both for the individual substance characteristics and for the substance report generation variant. Data is generated and output on the report only if the usage of a substance characteristic value corresponds with the validity area and the rating of the generation variant.
  
  See: Usage [Page 46], Report Template (SBV) [Page 214].

- Controlling report management
  You use the generation variant indicator to specify the stages in the status network in report management through which a report must pass when it is created for the first time.
  
  See: Generation Variant Indicator [Page 252]

Features

- Rating
  You protect substance data against unauthorized access using ratings. You can, for example, specify that data can be accessed by all customers.

- Validity area
  A validity area can group several jurisdictions in which the same substance data is valid.
  
  You need to differentiate between:
  
  - Leading validity areas
    You specify these validity areas when you create a generation variant.
  
  - Discrete validity areas
    If you want a document (a multi-language hazard label, for example) to feature several validity area/language combinations, you also define these assignments as part of the substance report generation variant.
    
    You also need to define a repeating group type Validity and language area so that the system selects the correct data for the report.
    
    See Taking Validity Areas into Account when Generating Reports [Page 254]

- Report type
  The report type is also directly linked to the generation variant. A report can be identified using the report type, for example, as a TREMcard or material safety data sheet (MSDS). As standard, only reports of the type Material safety data sheet can be sent in the
material safety data sheet shipping function. This is controlled via the business process

Material safety data sheet shipping that defines report types in the IMG activity.

See also:

Substance Report Selection [Page 294]
Generation Variant Indicator

Use
You use the generation variant indicator to define which stages of the status network you must edit in report management when generating a report for the first time.

See also: Report Status Network [Page 260], Report Management [Page 258]

Features
You can use the following indicators:

- Manual report requests gen. automatically indicator

<table>
<thead>
<tr>
<th>If the Manual report requests gen. automatically indicator</th>
<th>then the report</th>
</tr>
</thead>
<tbody>
<tr>
<td>has been set,</td>
<td>is given the status that you specified as Initial release status.</td>
</tr>
<tr>
<td>has not been set,</td>
<td>is given the status RR (report request), independent of the other indicators, provided that you create the report request manually.</td>
</tr>
<tr>
<td></td>
<td>You carry out the conversion to Initial release status in report management, using the Generate function.</td>
</tr>
<tr>
<td></td>
<td>Report requests that have been created automatically are always generated by the system.</td>
</tr>
</tbody>
</table>

- Initial release status

  In the standard system you can enter the following types of initial status:
  - GS (Gen. successful)
  - R1 (Release 1)
  - CO (Complete)
  - RE (Released)

  The conversion to next status is carried out for status GS, R1 and CO by means of the Accept function. If you want to delete the report, choose Reject.

  You can use Set to historical to manually convert a report which has status RE to the next status HI (historic).

- Version requirement indicator

  When converting the status from CO → RE, the version of the report is set to a higher number if you have set the Version requirement indicator.

  See also: Versioning Reports [Page 267]

- Set historical automatically indicator
The conversion to status HI is carried out automatically if the *Set historical automatically* indicator is set, and a new report for the same substance, same language and same generation variant with status RE is generated subsequently.

**Activities**

Processing the Generation Variant Header [Page 210]
Taking Validity Areas into Account when Generating Reports

When selecting characteristic values, the validity area of both the substance and the generation variant in the corresponding countries and regions is expanded.

So that a characteristic value can be selected, all countries and regions of the generation variant must also be maintained for the substance. The number of the countries and regions specified for the generation variant must be the same or less than the amount specified for the substance.

If no region has been assigned to a country in a validity area, the R/3 System considers the validity area as if all validity areas were assigned.

If the validity area specified is REG_WORLD, the R/3 System automatically uses all countries entered in the IMG activity Define validity areas in Customizing for Product Safety.

<table>
<thead>
<tr>
<th>Validity area</th>
<th>Country</th>
<th>Region</th>
</tr>
</thead>
<tbody>
<tr>
<td>REG_WORLD</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>REG_US</td>
<td>US</td>
<td>–</td>
</tr>
<tr>
<td>REG_US_CA</td>
<td>US</td>
<td>California</td>
</tr>
<tr>
<td>REG_US_LA</td>
<td>US</td>
<td>Los Angeles</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Validity area in substance</th>
<th>Validity area in SRGV</th>
<th>Is characteristic value selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>REG_WORLD</td>
<td>REG_WORLD</td>
<td>YES</td>
</tr>
<tr>
<td>REG_WORLD</td>
<td>REG_US</td>
<td>YES</td>
</tr>
<tr>
<td>REG_US</td>
<td>REG_WORLD</td>
<td>NO</td>
</tr>
<tr>
<td>REG_US</td>
<td>REG_US</td>
<td>YES</td>
</tr>
<tr>
<td>REG_US</td>
<td>REG_US_CA</td>
<td>YES</td>
</tr>
<tr>
<td>REG_US_CA</td>
<td>REG_US</td>
<td>NO</td>
</tr>
<tr>
<td>REG_US_CA</td>
<td>REG_US_CA</td>
<td>YES</td>
</tr>
<tr>
<td>REG_US_CA</td>
<td>REG_US_LA</td>
<td>NO</td>
</tr>
</tbody>
</table>
Master Data Adjustment

Use

The R/3 Product Safety component provides the following functions in Master Data Adjustment:

- **Adjusting Characteristic Categories and Characteristics [Page 142]**
  
  This function determines all characteristics with data type CHAR30 and to which phrases can be allocated. These characteristics are transferred to characteristic - phrase set allocation where you can allocate corresponding phrase sets (See also: Phrase set - characteristic allocation [Page 114]). At the same time, the system deletes all characteristics that still exist in the allocation but no longer in the R/3 System.

  Use this function if you have created new characteristics for a class of class type 100 (substance characteristics) in the R/3 component Classification System.

- **(De)activating Phrase-Related Characteristics**
  
  This function allocates a special dialog box as possible entries function to all characteristics to which a phrase set was allocated in phrase set - characteristic allocation. You use this dialog box to allocate phrases of the assigned phrase set to the characteristic.

- **Generating Symbols [Page 141]**
  
  You define report templates using symbols (See also: Symbols [Page 223]).

  Master data adjustment enables you to automatically generate symbols for each characteristic, table field and structure field. For example, if you have created new characteristics for a substance characteristic category, you can use this function to generate symbols for these characteristics.

  ![Tip]

  When generating symbols, the system takes all table fields into account that have been defined in the IMG activity Define R/3 tables for symbol generation in Customizing for Product Safety.

  You will also find information about important tables and structure fields in Output Data in SD [Page 311]

- **Regenerating symbol labels**
  
  When you choose the Generate symbols function, the R/3 System generates symbol labels in the logon language. To generate the label subsequently in a different language, you can use the Regenerate symbol labels function.

- **Adjusting Symbols and Phrase-Related Characteristics [Page 143]**
  
  This function updates the symbol definitions for characteristic symbols that have been changed from non phrase-related to phrase-related (or vice versa).

  For phrase characteristics, the system sets the substance report symbol group to 00 in Product Safety Customizing.

  (You can check the Customizing entries in the detail screen of the IMG activity Check and define report symbols).

- **Deletion indicator**
Master Data Adjustment

The R/3 System sets the missing deletion indicators.

- Physically delete data

  This indicator is used to physically delete data that has been marked as *deleted*. 
Report Management

Purpose

This component leads you through the individual work steps required to manage reports from report generation to report release.

Features

The generated substance reports contain all substance-related data and phrases for a particular language and usage. All other current parameters are generated later during shipping. You can use user exits to control the parameter values determined by the R/3 System during the process, and you can overwrite them manually in report management if necessary.

In Customizing for Product Safety, you can vary the status sequence the reports must follow. In this way, you can define different control regimes in report management through which a report must pass before it is released for shipping. You use the Generation Variant [Page 250] to determine which statuses a report must acquire in the status sequence (see Report Status Network [Page 260]).

Version numbers are assigned to reports to determine if a report was changed in a way that is relevant or not to its predecessor. In updated reports, the changed substance data is displayed in a different color, thereby providing an instant overview of all relevant changes.

The R/3 System ensures that when changes are made to substance or phrase data, new report requests are created automatically for the reports affected by these changes.

You can compare any two reports and display the differences between them using a link between your system and a suitable display application (Word, Adobe File Utilities, for instance).
Report Management: Process

Purpose
See: Report Management [Page 257]

Prerequisites
- You must have the appropriate authority to process reports in report management:
  
  A user with authorization for the rating PUBLIC can only display entries that originated from generation variants rated as PUBLIC only.
- You have installed the current EH&S version of Windows Wordprocessor Integration (WWI).
- To generate reports from report templates, you first have to:
  a) Assign substance characteristic values including usage and active indicator
     See: Substance Management [Page 17]
  b) Create the report template
     See: Maintaining Document Templates [Page 146]
  c) Define the layout of the report template and release it
     See: Maintaining Document Template Layouts [Page 159]
  d) Create a generation variant, maintain the usage for it and assign the appropriate report template to it
     See: Maintaining Generation Variants [Page 204]

Process flow
1. In the substance management hit list, you can generate a test report from a report template to check the layout and print the report as required.
   Report templates are linked to usage through substance report generation variants (SRGV).
   
   More information
   Report Template (SBV) [Page 214]  Procedure
   Testing Layouts [Page 274]
   Reports (SBR) [Page 215]
   Generation Variant [Page 250]

2. You first create a report for a substance, generation variant and language by generating a report request manually in substance management. You use the generation variant indicators to control the subsequent work steps within report management.
   
   More information
   Generation Variant Indicators [Page 252]  Procedure
   Creating Report Requests Manually [Page 275]
3. You can use the R/3 System to generate a worklist for reports in which changes have been made subsequently to phrase or substance data. The R/3 System subsequently generates all reports affected automatically and sets the reports to the initial status you defined in the generation variant header.

The R/3 System places manually generated report requests in the worklist.

You can monitor the generation using the WWI monitor.

More information

Procedure

Report Management Worklist [Page 262]
Generating Worklists [Page 276]
Displaying the WWI Monitor [Page 284]

4. In report management, the reports are displayed in the report tree. The worklist is processed according to report status.

You use the initial status and the indicator for the corresponding generation variant to determine if a report

– Must be generated manually as it was created manually
– Must pass through different control regimes in release
– Must be taken into account in versioning
– Is to be set to status Historical automatically if a new report is generated subsequently and released

More information

Procedure

Report Trees [Page 264]
Processing Worklists for Reports [Page 279]
Releasing Reports [Page 265]
Versioning Reports [Page 267]

5. You can use the following additional functions in report management:

– You can display reports as Microsoft Word documents from the hit list. The R/3 System determines default values for report symbols of type Parameter. You can overwrite these values.
– Substance assignment enables you to assign several substances to one report (n:m relationship between substance and report).
– You can compare the currently released report with the previous version.

More information

Procedure

Default Parameters for Reports [Page 270]
Overwriting Default Parameter Values [Page 285]
Substance Assignment [Page 272]
Assigning Substances to a Report [Page 286]
Comparing Reports [Page 287]
Report Status Network

The report status network is structured as follows:

See: Status Network for Reports [Page 261]

1. **Status before and during generation:**
   The status *Start of work* (SW) is followed by the status *Report body request* (RR). During generation, the report has status *Generation possible* (GP). If the generation fails (status GE), or a *System error* (SE) occurs, the R/3 System terminates generation.

   For reports in status GE or SE, you can restart generation.

2. **Status after generation:**
   After a report body has been successfully generated, it has the status *Generation Successful* (GS). The R/3 System then resets the report to the initial status you defined in the generation variant header.

   If some phrase symbols are not present in the required language after generation, the report has the status *Generated with warning*. You can still process the report further.

3. **Release statuses:**
   During the release process, the report passes through different control regimes. For example, the report body must be released in turn by a chemist (status R1 or “CH”), a lawyer (status F2 or “LA”), and another person of your choice (status XY).

4. **Versioning statuses:**
   After the report has been released for the last time, it has status *Complete* (CO) and can now be versioned.

5. **Statuses of released reports:**
   Reports with status *Released* (RE) are ready for report shipping. Released reports can be set to status *Historic* (HI).
Status Network for Reports

The following graphic gives an example of a complete status network:

SW: Start of work
RR: Report request
GP: Generation possible
GF: Generation failed
SE: System error
GS: Generation successful
GW: Generated with warning
F1 (or CH): Release, by chemist, for example
F2 (or LA): Release, by lawyer, for example
XY: Any further status to be defined as required
CO: Complete, assigned by the system after the last person responsible has released the report
RE: Released
Report Management Worklist

Use
The R/3 System determines all manually and automatically generated report requests when generating the worklist.

Report requests are generated automatically

- If substance data or phrases are changed and are already used in reports (with status GS, F1, F2,..., CO or RE) so that the existing reports must be updated

If you delete the whole data record (instance) for a substance, this also means that the active and relevant indicators no longer exist. For this reason, the R/3 System does not include reports that contain these substances when generating the worklist.

- If a report for a substance, generation variant and language is to be sent because of an automatically generated report shipping order and the R/3 System cannot select a released report

For manual report shipping, you must generate the report request manually.

Features
The R/3 System determines the substance and phrase changes as follows:

Substance changes
1. The R/3 System determines all substances whose data was altered in the relevant time frame.
2. When determining the other substances in which a changed substance is used in, the R/3 System checks the following areas:
   - Substance references
   - Substance listings
   - Substance compositions
3. The R/3 System determines all report bodies that refer to the changed substances.
4. Reports are checked to determine if the changes made to the substance data is relevant to them. Only these reports enter the worklist as newly generated reports.

Phrase changes
The R/3 System makes changes to phrase data as follows:

1. All phrases that were changed in the relevant time frame are selected.
2. Reports in which the phrase data was originally created as phrase symbols enter the worklist immediately as regenerated reports.
3. The system then determines the substances in which the changed phrases are used.
4. All reports that refer to these substances are then selected.
5. The system checks the reports to determine whether the changed phrase data is relevant to them. Only these reports enter the worklist as newly generated reports.

**Creating worklists**

The time frame for which changes are determined is specified by the date of the last worklist generation and the current date minus one day. Because time frames for which a worklist has already been generated are logged, there can be no time gaps. This ensures that no changes are overlooked.

---

**Creating worklists**

**Activities**

- [Generating Worklists](Page 276)
- [Processing Worklists for Reports](Page 279)
Report Trees

Use

Reports are displayed in report management in a hierarchical tree structure. You can display either substance or material view.

Features

Substance view

The data are arranged as follows:

- Substance key and identifiers
- Substance report generation variant (SRGV) with validity area
- Report with version, language, status and remark

You can display each report or call additional information for it (for the status log, report size, for instance).

Material view

In addition, the top branch of the tree displays the material allocated to the report:

- If a substance is used in several materials, the reports for this substance are displayed in the report tree for each material.
- If a material is allocated to two or more substances, all allocated substances and reports are arranged underneath the material.

Substances without material allocation are allocated to a default material

- That you must have created in the material master
- That you have then selected as default material by choosing Utilities → Change default mat.

See also:

Report Management [Page 258]
Report Information System [Page 343]
Releasing Reports

Use

The number and sequence of the individual release statuses depend on the control regimes through which the reports must pass. You can adjust the status network to fit your requirements.

Features

Release stages

Accepting a report transfers it to the next release status. If a report is refused, it is then deleted (see also: Status Network for Release: Example [Page 266]).

Bypassing Release

In the generation variant header, you use the Initial release status field to specify

- If a report must be released
  
  A report can bypass release status altogether if you have defined CO (complete) or RE (released) as initial status.

- Which release status is to initiate the release

This means that you can start at any point in the release process.

Activities

Processing Worklists for Reports [Page 279]
Status Network for Release: Example

This graphic displays an example of a status network defined for releasing reports.

Legend:
GS: Generation successful
F1 (or CH): Acceptance or rejection of report by chemist
F2 (or LA): Acceptance or rejection of report by lawyer
XY: Any further status that you define as required
CO: last status (complete), assigned by the system after the last person responsible for releasing the report has accepted the report
RE: Released
Versioning Reports

Use
This function supports the assignment of version numbers to a number of reports that are generated for the same substance, generation variant and language.

Prerequisites
To enable versioning, you must have set the Version requirement indicator in the generation variant header.
If the relevancy indicator was set, new main or sub versions of reports are created. You can set the relevancy indicator:
- In substance characteristic usage
  The corresponding substance characteristic values are marked in the manually or automatically generated final report if you have set the Generate change marks indicator in the generation variant header, and a released and versioned report exists as a previous version. The R/3 System determines the relevant changes made since the previous report was generated.
- In the report header
  The report may not have status RR (report request), RE (released), or HI (historical).

Features

Start version
If you generate a report for a substance, generation variant, and language for the first time and choose Accept when the report has the status CO (complete), a dialog box appears in which you specify the start number for the main version regardless of whether you have set the Version requirement indicator or not. This start version can be used as the initial report version following the replacement of legacy systems. In this case, the sub version is always zero.

Numbering
If you choose Accept again for a report with status CO (complete), the following system reactions occur:

<table>
<thead>
<tr>
<th>If the Version requirement indicator</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Has not been set</td>
<td>The report is always assigned the version number V1.0, regardless of whether the relevancy indicator has been set.</td>
</tr>
<tr>
<td>Has been set, and the report is relevant</td>
<td>The R/3 System assigns the next highest number to the main version and sets the sub version to zero (V2.6 → V3.0, for instance). The R/3 System does not permit gaps in the main version.</td>
</tr>
</tbody>
</table>
Versioning Reports

| Has been set, and the report is not relevant | The R/3 System assigns the next highest number to the sub version and leaves the main version unchanged (V2.6 → V2.7, for instance). |

- A version number assigned to a report cannot be changed.
- Report shipping always selects the most current released version of a report.

For reports with key date in the future that must be versioned and released before the key date is reached, you must check

- If a report with a higher version number was generated subsequently and released because of a change
- If the subsequently generated report has the same future key date

If the key date is not in the future, you must create a report request manually for the key date in the future so that this report has the highest version number and no data is lost during shipping.

Version 3.2 contains substance data valid for 1st August.

Version 4.0 contains substance data valid for 1st May and relevant changes were made to it.

<table>
<thead>
<tr>
<th>Version</th>
<th>Generated on</th>
<th>Released on</th>
<th>Key date</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.2</td>
<td>1. April</td>
<td>1st April</td>
<td>1st August</td>
</tr>
<tr>
<td>Relevant change =&gt; 4.0</td>
<td>1st May</td>
<td>1st May</td>
<td>1st May</td>
</tr>
</tbody>
</table>

If a report shipping order is created on the 1st August, the system selects the reports with the highest version numbers (version 4.0). However, the data valid for the 1st August are not contained in this version.

To create a version that contains the relevant changes as well as the data valid for the 1st August, you must create a report request manually with key date 1st August.

<table>
<thead>
<tr>
<th>Version</th>
<th>Generated on</th>
<th>Released on</th>
<th>Key date</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.1</td>
<td>1st May</td>
<td>1st May</td>
<td>1st August</td>
</tr>
</tbody>
</table>

This scenario remains the same for relevant and non-relevant changes.

**Bypassing versioning**

You can bypass the status CO (complete) by defining RE (released) as initial status in the generation variant.

<table>
<thead>
<tr>
<th>In addition, if the Version requirement indicator</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Has not been set</td>
<td>The acceptance of the report in the last release status leads automatically to the final release of the report. The report is always assigned version V1.0. During this process, the currently released report is replaced.</td>
</tr>
</tbody>
</table>
Has been set | The R/3 System automatically specifies V1.0 as the start version for the first generated report. The subsequent versions depend on whether the relevancy indicator has been set or not.

Activities

Processing Worklists for Reports [Page 279]

See also:

Generation Variant Indicator [Page 252]
Report Management [Page 258]
Relevance Indicator [Page 48]
Default Parameters for Reports

Use

In report management and the report information system, you can use default parameters to fill symbols of symbol type Parameter with valid values for displaying and printing reports so that the user must not enter values manually.

The R/3 System determines the currently valid values for symbols of symbol type Parameter at the shipping stage.

Prerequisites

You have made the following settings in Customizing for Product Safety.

- In the IMG activity Define report symbol groups, you have defined the substance report symbol groups for the determination of default parameters and allocated the required function modules.
- In the IMG activity Check and define report symbols, you have allocated the required substance report symbol groups to the substance report symbols.
- In the IMG activity Check identification listing, you have checked the identification listing D_MATNAM according to your requirements.

Features

Default parameters

For the user exit, function modules are delivered with the standard system that determine the appropriate values for an initiator (sales organization) or material number. You must distinguish between the following parameter symbols:

- Parameter symbols that depend on an initiator
- Parameter symbols that are linked to a material
  - The R/3 System determines the default parameter value for the material in the following way.
    - If the material is available in the R/3 System, the first 132 characters of the basic data long text are output in the logon language.
    - If no basic data long text is available, the material short text is output in the logon language.
    - If no material short text is available, the system outputs the identifier that it has determined in accordance with the list of identifiers D_MATNAM.
    - If no corresponding identifier is available, the substance key is output as the default value.
Temporary overwriting

In report management, you can overwrite the default parameters manually. In the report information system, overwriting is forbidden as standard. However, you can set up this option with the appropriate authorization.

The changed values are not stored. They are only used for the current transaction.

Activities

Overwriting Default Parameter Values [Page 285]

See also:

Report Management [Page 258]
Report Information System [Page 343]
Substance Assignment

Use
This function enables you to assign several substances to a report. The report is then generated for a particular substance and can then be used in report shipping for that substance and all assigned substances.

The number of reports required in the R/3 System is thus reduced.

Features
- Substances are assigned in the report header within report management. You can only assign substances for which no released reports for the same generation variant exist.
- Substance assignment can be defined differently for each report version. When creating new versions (or when replacing one version with another), the new report “inherits” the substance assignments of the previously valid report.
  
  However, changes are not entered automatically in all existing report versions.

  If substance data assigned to a report is changed, an entry is not automatically made in the worklist. You must check if the assigned report fits with the changed data.

You must also check if the assignment is valid if you change the substance for which the report was generated.

Activities
Assigning Substances to a Report [Page 286]
Report Management: Procedures

**Testing Layouts [Page 274]**

**Creating Report Requests Manually [Page 275]**

**Generating Worklists [Page 276]**

**Processing Worklists for Reports [Page 279]**

**Processing Additional Functions in Report Management [Page 282]**

**Displaying the WWI Monitor [Page 284]**

**Overwriting Default Parameter Values [Page 285]**

**Assigning Substances to a Report [Page 286]**

**Comparing Reports [Page 287]**
Testing Layouts

Prerequisites

- You have created a report template with status *In work (IW)* or *Released (RE)*.
- You have defined a generation variant and assigned it to the report template.

Procedure

1. In the substance management hit list, mark all substances for which you want to generate a report for a generation variant, language, and key date (see Substance Search [Page 23]).
2. In the hit list, choose Substance → Reports → Report from template.
   The Create Report Using Template dialog box appears.
3. Enter the generation variant, language, and key date.
4. Choose Display or Print.
   If you have defined symbols of type Parameter in your report template, the Maintain Parameter Values dialog box appears. Process the screen as follows:
   - Enter the values for the parameter symbols (see Symbol Type Parameter [Page 227]).
     If a Parameter-type symbol is defined within a repeating group in the report template, you can enter several values for the parameter: Select the corresponding field and choose Insert line or Add line. The system adds another line with the appropriate parameter. Enter another value.
   - Choose Transfer.

Result

<table>
<thead>
<tr>
<th>If you</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose Display</td>
<td>Word displays the simulated report. To return to the R/3 System, choose File → Back to R/3.</td>
</tr>
<tr>
<td>Choose Print</td>
<td>The simulated report is printed and the R/3 System displays a success message.</td>
</tr>
</tbody>
</table>

See also:

- Maintaining Generation Variants [Page 204]
- Starting and Closing WWI [Page 155]
Creating Report Requests Manually

Prerequisites

- You have created and released a report template.
- You have defined a generation variant and allocated it to the report template.

Procedure

1. In the substance management hit list, mark all substances for which you want to create a report request for a generation variant, language and key date (see: Substance search [Page 23]).
2. In the hit list, choose Substance → Reports → Create report.
   The Create Reports dialog box appears.
3. Enter the generation variant, language, and key date.
4. Choose Create report.
   The system generates a report request for all substances you have selected.

Result

- You can display the log.
  - In the Create reports dialog box, choose Log.
    The Processing Log for Selected Substances screen appears.
  - Select the line with your user name and choose Display messages.
- Depending on the generation variant indicators
  - The R/3 System generates the report request for the report
  - You must generate the report request manually in the worklist
    The report then has the Initial release status you defined in the header for the generation variant.
- The report is then processed further in the report management worklist. See: Processing Worklists for Reports [Page 279]
Generating Worklists

Use

Worklists can be generated manually or scheduled automatically.

Worklists are generated automatically using programs RC1AVGE1 and RC1AVGE2.

The program RC1AVGE1 determines the reports that could be affected by a change to a substance or phrase, so-called reports with potential changes. The program RC1AVGE2 then determines whether the reports with potential changes that you selected have actually been affected by a change to a substance or a phrase.

For more information, see the hyperlink to Report RC1AVGE1 and Report RC1AVGE2 that is set in release note EHS_22B_PATCHLEVEL03 (Changes to SAP EH&S Release 2.2B, Patch Level 1 and 3).

The release note is assigned to the standard release 4.6A of component Environment Management -> Product Safety. To obtain the release notes, choose Help -> Release notes and generate the release notes for standard release 4.6A.

Prerequisites

Manually or automatically generated report requests exist (see: Usage under Report Management Worklist [Page 262]).

The R/3 System places manually generated report requests in the worklist. For automatically generated report requests, you can create the worklist manually or have the R/3 System create them for you periodically.

You have set up the environment parameters AVGEN_SPLIT and AVGEN_SHOW_MSG in the IMG activity Specify environment parameters. For more information, see the documentation in the IMG activity Specify environment parameters.

Procedure

Generating the Worklist Manually

1. From the Product Safety [Ext.] screen, choose Reports -> Edit reports -> Gen. work list. The Generate work list dialog box appears.
2. Choose Yes. The R/3 System creates the worklist in the background.

Generating Worklists Automatically

1. Scheduling the program RC1AVGE1

   The program RC1AVGE1 should be scheduled periodically, for example, on a daily basis.
a. Call the R/3 System in the required client.
b. From the SAP R/3 screen, choose System → Services → Jobs → Define job.
c. Enter a job name (WORKLIST_GEN, for example) and choose the appropriate job class.
d. Choose Start condition and in the following dialog box, choose Date/Time.
e. Enter the required data and select Periodic job.
f. Choose the function Period values and specify the periods. Choose ✓ and then □.
g. Choose ✓ and then □.
h. Choose Step and in the following dialog box, choose the function ABAP program.
i. In the Name field, enter the key RC1AVGE1.
j. Choose ✓ and then □.

Before you leave the Define Job screen, you must save your entries again.

The R/3 System creates the worklist periodically according to the start date defined.

2. Scheduling the program RC1AVGE2

You can schedule a job for the program RC1AVGE2 in the following ways:

a. You can schedule the program RC1AVGE2 with the program RC1AVGE1. To do this, schedule a job that has program RC1AVGE1 assigned as step 1, and program RC1AVGE2 assigned as step 2.

Make sure that no variants with selection criteria are scheduled for the program RC1AVGE2 that restrict the selection of reports with potential changes. This would prevent all reports that were determined by program RC1AVGE1 from being checked.

b. If changes to a substance or a phrase could lead to the report program RC1AVGE1 determining very many reports as having potential changes, you should schedule the job for report program RC1AVGE2 in such a way as to prevent all of the reports with potential changes from being checked in one run. Otherwise the runtime could be extremely long.

For this reason, you should schedule the job for program RC1AVGE2 with selection criteria (for example, substance authorizations group, substance, SRGV, language, number of reports to be checked). This means you can run several jobs simultaneously, or spread the checks out over several days.

With this procedure, you must make sure that the selection criteria is chosen for the different jobs in such a way so that each report with potential changes is taken into account for checking by at least one job. If the criteria overlap, the report with potential changes is checked by the job that selects the report first.

c. Apart from scheduling jobs periodically, you also have the option of always starting the job for the program RC1AVGE2 whenever the reworking of a particular substance or phrase is completed in a particular language.
Generating Worklists

For example, if a substance is reworked over a period of two weeks, we do not recommend that you generate new versions of the reports for this substance within these two weeks. In this case, after the substance has been reworked, you should start the job for the program RC1AVGE2 with a variant that has this substance as a selection criterion.

In the same way, for example, you should only check all English reports when the reworking of all the English phrases has been completed.

With this procedure, you must once again make sure that reports specified are not forgotten during the checks. We therefore recommend that you run the job for report program RC1AVGE2 at regular intervals without selection criteria to be sure that all the reports with potential changes are checked.

Result

All reports generated for the worklist have the same initial status defined in the generation variant header. You can then call reports in the worklist and process them (see also: Processing Worklists for Reports [Page 279]).

Depending on the status, older report versions that exist for the same substance, generation variant and language are updated as follows:

<table>
<thead>
<tr>
<th>If an older report version</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Does not yet have the status Released</td>
<td>The R/3 System replaces the older report version with the current report.</td>
</tr>
</tbody>
</table>

| Has the status Released | The R/3 System creates the updated report again. |
Processing Worklists for Reports

Prerequisites

- Manually or automatically generated reports exist. See also:
  - Creating Report Requests Manually [Page 275]
  - Report Management Worklist [Page 262]
  - Generating Worklists [Page 276]

- Each time you change to a different processing stage, an authorization check takes place. If you have the authorization, the system takes you to the next processing step.

Procedure

1. In the R/3 main menu, choose Logistics → Material management → Product safety.

   Depending on the status you want to process, you can choose the following paths in the R/3 Product Safety [Ext.] menu.

   Path: Reports → Edit reports → General
   - For reports with any status

   Path: Reports → Edit reports → Validate
   - Status RR (report request)
   - Status GW (generated with warning)
   - Status SE (system error)
   - Status GF (generation failed)

   Path: Reports → Edit reports → Release
   - Selected status
   - GS (generation successful)
   - R1 (release 1)
   - CO (complete)

   Reports versions are created when the status is reset from CO → RE.

   Path: Reports → Edit reports → Version
   - CO (complete)

   Path: Reports → Edit reports → Set to historical
   - RE (released)

   The Report Management: Initial Screen appears.

2. Enter your search criteria.

   You can
   - Search by the substance for which the substance report was generated
   - Search by report status assigned to the report
Processing Worklists for Reports

The status of the report directly after it has been generated depends on the generation variant indicators:

See: Generation Variant Indicator [Page 252]


If the R/3 System finds one or more reports that correspond to your search criteria, the Report Management: Report Tree screen appears.

If you have entered a material as search criteria, the material view appears. Otherwise, the substance view appears.

You can use additional functions within substance management.

See: Processing Additional Functions in Report Management [Page 282]

4. Use the following functions to set the report to the corresponding subsequent status.

   ![Lightbulb]

   If errors occur after you have carried out the functions, the corresponding reports are marked with an error icon. For further information, choose the error icon.

<table>
<thead>
<tr>
<th>Status</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>RR</td>
<td>Generate</td>
</tr>
</tbody>
</table>

You execute this function for manually generated report requests if the *Manual report requests gen. automatically* indicator is **not** set. Automatically generated report requests are generated by the R/3 System itself.

If the report requests are generated correctly, the report is set to the initial release status via status *GP* (generation possible) and *GS* (generation successful). You define the initial release status in the generation variant header.

If errors occur during generation, the system assigns *SE* (system error) or *GF* (generation failed) as subsequent status. After you have corrected the errors, you can choose *Generate* once again.

To monitor the generation, call the WWI monitor. See: Displaying the WWI Monitor [Page 284]

   ![Lightbulb]

   If phrases for a report to be generated do not exist in the report language, the R/3 System sets the report to status *GW* (generated with warning). The phrases are displayed in the report as keys only. Reports with status *GW* can be processed as normal.
SG  Accept => R1 (or Initial release status)

You can bypass release status R1, R2,..., if you define the status CO (complete) or RE (released) as initial release status in the generation variant header (see Releasing Reports [Page 265]).

R1  Accept => R2, etc.
R2, etc. Accept => CO or RE

You can bypass status CO if you do not set the Version requirement indicator in the generation variant header. The subsequent status is then RE.

CO  Accept => RE

You can send released reports from the Report Information System (see Report Information System [Page 343] and Report Shipping [Page 290]).

The version of the report with status RE depends on whether you have set the Version requirement indicator (see Versioning Reports [Page 267]).

RE  Historical => HI

The report is converted to status HI automatically if the Set historical automatically indicator is set and a report for the same substance, generation variant, and language is generated subsequently with status RE.

If you set the currently released report to historical and there is no newly released report, there can be no report shipping for this substance, language, and generation variant for the time being.

If report shipping is triggered again automatically, the R/3 System creates a new report request. For manual report shipping, you must generate the report request manually.
Processing Additional Functions in Report Management

You can use several additional functions to process selected reports. To select the reports, place the cursor on the required report and choose F9 or choose Edit → Subtree → Select Subtree.

Please observe the following notes:

<table>
<thead>
<tr>
<th>Choose</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Document</td>
<td>The report is displayed in Word. It may not have status RR (report request).</td>
</tr>
<tr>
<td>Goto → Additional info</td>
<td>The status log is displayed together with information on the substance key, generation variant and so on.</td>
</tr>
<tr>
<td>Goto → Parameter values</td>
<td>The R/3 System displays the parameter values that you can overwrite in report management. See: Overwriting Default Parameter Values [Page 285]</td>
</tr>
<tr>
<td>Extras → History</td>
<td>Reports with status HI (historic) are added to the display.</td>
</tr>
<tr>
<td>Extras → Report comparison</td>
<td>You can compare two selected reports.</td>
</tr>
<tr>
<td>Utilities → Administrative info</td>
<td>The document key and other administrative information is displayed.</td>
</tr>
<tr>
<td>Utilities → Change print parameters</td>
<td>If you want to print a report under Report → Print, you can enter the print parameters here. After you exit the transaction, the R/3 System uses the print parameters defined in System → User profile → User defaults.</td>
</tr>
<tr>
<td>Utilities → Change default material</td>
<td>A dialog box appears in which you can choose another default material. The R/3 System saves the default material in your user parameters. You can display these parameters by choosing System → User profile → User parameters.</td>
</tr>
<tr>
<td>Utilities → Change initiator</td>
<td>A dialog box appears in which you can choose another initiator.</td>
</tr>
</tbody>
</table>

💡

If you call a report template in display mode only, Word is called without the WWI menu option.

If you display a document in landscape setup, you must close it before you can display a second document from the R/3 modus. If you do not, an error message is displayed.

See also:

Using the Report Information System [Page 345]
Displaying the WWI Monitor

1. From the Product Safety [Ext.] screen, choose Tools → WWI monitor.
   The WWI Monitor: Overview screen is displayed and lists the generation server for each client and dispatcher.

   ![Note]

   Use the functions in the Edit menu to display, hide, delete and sort the generation orders.

2. Select a generation order for each document, and choose Goto → Log or Goto → Job overview for further information.

3. Check if the WWI indicator is active (green = active; red = inactive).
   If the indicator for the dispatcher or corresponding work process for a generation server is inactive, place the cursor on the dispatcher or generation server, and choose Utilities → Activate server.
   This function starts triggering simultaneously. Orders with status Released can thus be generated from the WWI server.

   ![Note]

   Choose Utilities → Test server to call technical information about the server.
Overwriting Default Parameter Values

Prerequisites
You have authorization to overwrite default parameters.

Procedure
1. Enter the work list.
   See: Processing Worklists for Reports [Page 279]
2. Select the required report and choose Goto → Parameter values.
   The R/3 System displays all symbols of type Parameter that depend on an initiator or have a reference to a material.
3. Check the parameter values and overwrite them if necessary.

See also:
Default Parameters for Reports [Page 270]
Assigning Substances to a Report

Prerequisites
The report may not have status RR (report request), GP (generation possible), SE (system error), or GF (generation failed).
You must have authorization to process the report header.

Procedure
1. From the Product Safety [Ext.] screen, choose Reports → Edit reports → General (or Validate, Release, Version, Set to historical).
   See: Processing Worklists for Reports [Page 279]
2. Enter your search criteria.
   If the R/3 System finds one or more reports that correspond to your search criteria, the Report Management: Report Tree screen appears.
4. Select the required report and choose Goto → Header.
   The report header data are displayed.
5. In the Reference substances columns, assign the report substances for which the report is valid.
   You can only assign substances for which no released reports for the same generation variant exist.
6. Save your entries.

See also:
Substance Assignment [Page 272]
Comparing Reports

Prerequisites

- The reports you want to compare must have one of the following statuses:
  - R1,...\((Release\ 1,...)\)
  - RE (Released)
  - CO (Complete)
  - GS (Gen. successful)
  - Historic => HI

- You must have maintained the environment parameter REPORT_COMP_EXECUTABLE in the IMG activity Specify environment parameters in Customizing for Product Safety.

Procedure

1. From the Product Safety [Ext.] screen, choose Reports → Edit reports → General (or Validate, Release, Version, Set to historical) or choose Reports → Report information system.
2. Enter your search criteria (see: Processing Worklists for Reports [Page 279]).
   If the R/3 System finds one or more reports that correspond to your search criteria, the Report Management: Report tree screen appears.
4. Select two reports by choosing Edit → Subtree → Select subtree.
5. Choose Extras → Report comparison.

Result

Depending on your PC installation, Word is started. The report you selected first is displayed and the differences between it and the second report are marked.

You can compare any two selected reports. If you select one report only, the R/3 System compares it automatically with its released previous version.

See also:

Report Information System [Page 343]
Report Shipping

Purpose

This component supports you with shipping reports containing substance data manually or automatically. The R/3 System allows you to replace all standard routines (see Report Shipping: Process [Page 290]) for running report shipping with your own routines adapted to meet your own requirements. A series of SAP enhancements allow you to integrate individual routines in the standard functions, for example, in order to:

- Determine the report type
- Determine the material name
- Check the MSDS requirement
- Determine the language of the MSDS
- Determine the substance report generation variant
- Ship material safety data sheets from Sales

Features

The following functions are supported as standard:

- Integrated shipping process

  Automatic report shipping is planned as part of a superior business process. For example, the R/3 System supports you with shipping material safety data sheets in advance for deliveries of certain chemical products. For the jurisdictions USA and the European Union, the R/3 System ships only the material safety data sheets required by law. The recipient, the report language, and the relevant report are determined automatically. The R/3 System ensures that only reports that have been released are shipped.

- Check functions

  You can set up shipping in accordance with the legal requirements of the recipient country and region. The whole shipping procedure from triggering the shipping process to the actual shipping is subject to your checks. If you wish, the person responsible in your organization must check the output for the report shipping order and post the receipt of the acknowledgement of receipt.

- Efficient use of data

  All released reports already contain the generated substance data. The R/3 System determines the logistic data, for example, address or product name, relevant for shipping and adds this data to the substance report. This means that the same substance report can be sent to a number of different recipients. You can also set up the R/3 System so that it determines the most up-to-date released substance report again before generating.

- Support for different types of communication

  Reports can be sent as an e-mail, a letter, or as a fax. If required, you can specify that reports whose recipient and communication type are the same can be shipped together.
The R/3 System automatically distributes this bundle of reports among the existing shipping units (for example, letter formats).

- **Automatic subsequent shipping**
  In European Union countries, if relevant changes are made to certain data, an updated material safety data sheet must be re-sent within a legally prescribed period of time. The R/3 System automates this process.

- **Shipping inbound reports**
  In addition to shipping substance reports that were generated in the R/3 System, you can also ship inbound reports. Inbound reports are reports that were imported from external systems.
Report Shipping: Process

Purpose
See: Report Shipping [Page 288]

Prerequisites
- In Customizing for Product Safety, you have made settings in the Report Shipping section:
  - Report shipping is controlled using the Shipping Reason [Page 301].
  - For automatic report shipping the R/3 System must be able to select the following data uniquely:
    - Report Recipient [Page 292]
    - Substance Report Selection [Page 294]
    - Sender (MSDS Initiator; Sales Organization) [Page 296]
- The reports must have been released in Report Management [Page 258]. As standard, report shipping is set up for the report type Material safety data sheet.
- You have installed the current EH&S version of Windows Wordprocessor Integration (WWI) and made settings in the Report Generation section of Customizing for Product Safety.

Process flow

1. Creating a report shipping order
   - The Substance Report Shipping Order [Page 297] (report shipping order) is the central object in report shipping. It contains all parameters that are used to define and control report shipping. The report shipping order can be requested manually or automatically.
   - Manual Report Shipping [Page 315] is started from the report information system.
   - Creating reports automatically includes the following:
     - Automatic Report Shipping [Page 304] that is started from the R/3 component Sales and Distribution (SD) for material safety data sheets
     - Subsequent Shipping [Page 313] of material safety data sheets
   - A report shipping order is also created automatically when exporting reports and printing (see Exporting Reports [Page 457]).

2. Controlling the report shipping order using user exits
   - From its creation to shipping, the report shipping order passes through various stations in the form of user exits:
     - Checking Report Shipping Orders [Page 308]
     - Bundling Report Shipping Orders [Page 318]
In addition to these user exits you can create your own function modules in the IMG activity "Manage user exits."

3. Checking the report shipping order manually

You check the current status of your report shipping order using the shipping log. See: Processing the Report Shipping Log [Page 328]

Usually, you set up the shipping process automatically. However, you can also start report shipping orders in the background with initial status Created (CR). In this case, you must edit the report shipping orders manually by carrying out either the Accept or Reject functions. See: Processing Report Shipping Orders [Page 330]

You can also make settings in Customizing so that:

- You must manually confirm report output
  It is important to check reports during output as errors may occur when printing reports, due to paper being stuck in the printer, lack of toner, and so on.

- You must manually confirm that a report has been received
  Acknowledgements of receipt must be signed by the recipient and returned to you as the sender.

You can send rejected and failed report shipping orders again and reset communication type and printer parameters in the shipping header. See: Processing Report Shipping Order Headers [Page 332]

**Result**

You use a user exit to save the completed report shipping order.

Saving Report Shipping Orders [Page 326]

You can increase the performance of inbound document shipping if, when programming, you ensure that when importing inbound documents, a Postscript file is additionally created for each *.PDF file. This means that in inbound shipping, the required *.PS files are immediately available and do not have to be created.
Report Recipient

Definition

The recipient of a substance report. Shipping of material safety data sheets (MSDS) is currently set up for MSDS recipients. You must differentiate between the report recipient and the ship-to-party.

- **Manual report shipping**
  
  You enter the report recipient directly when you ship a report. The following kinds of address management are supported:
  
  - Address management in the R/3 component *Sales and Distribution (SD)*
  - Address management in the R/3 user administration
  - Address management in the R/3 component *Product Safety*

- **Automatic report shipping**
  
  For automatic report shipping you can use only the address management in the R/3 component *Sales and Distribution (SD)*.

  The R/3 System selects the respective MSDS recipient using the R/3 partner determination. The languages in which the substance report must be shipped are also linked to the recipient country.

See:

- *Shipping Order Packages [Page 323]*
- *Maintaining the Addresses of Report Recipients [Page 333]*
- *Maintaining the Internet Address of a Customer [Page 334]*

Structure

The following structure forms the basis for selecting the MSDS recipient for triggering automatic shipping.

- **Partner function SR**
  
  In general, SAP differentiates between various types of business partners that participate in a business transaction in sales and distribution processing. The R/3 System uses so-called partner functions to differentiate between business partners (for example, customers, vendors, forwarding agents). These partner functions are grouped together using partner determination procedures and are assigned to the corresponding business partners via an account group. The obligatory partner function *Safety Data Sheet Receiver (SR)* exists for the MSDS recipient.

- **Partner determination procedure WESR**
  
  For report shipping, the partner determination procedure *ship-to party material safety data sheet recipient* (WESR) has been set up. In the standard system, the partner determination procedure WESR contains the obligatory partner functions *MSDS recipient* (SR) and *ship-to party* (WE). The ship-to party is generally also the MSDS recipient. This means that both partner functions with identical addresses are assigned as standard to a business partner that belongs to a particular account group.
As it is possible that the recipient of a report is not always the ship-to party, the R/3 System allows you to enter a different address for the MSDS recipient or to specify a number of MSDS recipients.

- **Contact person**

  You can define a number of contact persons for one MSDS recipient. If you have also assigned the function of contact person for material safety data sheets to a contact person, this contact person and not the higher-level business partner receives the relevant material safety data sheets from the R/3 System.

You can use the environment parameter SRE_DS_SDSREC to set up the MSDS contact person function. For further information, see the IMG activity Specify environment parameters in Customizing for Product Safety.
Substance Report Selection

Use
This function selects the report for a report shipping order in accordance with the following:

- Substance
- Generation variant
- Language
- Key date

If the R/3 System cannot select a report for these criteria, it creates a report request (see Automatic Report Shipping [Page 304]).

Prerequisites
You have made the settings in Product Safety Customizing for report shipping.

Features
Each substance report is generated for one particular substance. A substance can also be assigned to a report via the report-substance assignment.

Selection for Manual Shipping
Manual shipping is started from the report information system. From the report tree in the report information system you can immediately recognize for which substance a report was generated, which generation variant was used, on which key date, and in which language the report was generated.

Selection for Automatic Shipping

- Substance selection

In automatic report shipping, the R/3 System must be able to select a substance via the material-substance assignment function. The R/3 System checks whether a report was generated for the substance itself or whether the substance was assigned to a report via the substance-report assignment function.

- Generation variant selection

The generation variant defines, for example, which report template is used for generating, which usage (validity area and rating) the substance data in the generated report has, and which report type the generated report has (see Generation Variant [Page 250]).

The R/3 System selects the generation variant using the condition schema in the IMG section Condition schemata for SRGV selection. The first of the condition tables contains the most accurate assignments. Here, for example, you can assign a generation variant directly to a ship-to party. If the R/3 System cannot find a generation variant from this table it checks the second table and so on. The most general table is the fourth and final table. Here the selection is defined very generally so that the R/3 System can always find a generation variant. In this fourth table you can therefore specify a generation variant directly for a particular report type.
The jurisdictions of the ship-to party and the material safety data sheet recipient do not need to match the validity area of the generation variant. This means it is possible to send an MSDS that contains data valid for the USA to a recipient in Europe.

- **Language selection**

  The language of the MSDS is determined by the language of the Report Recipient [Page 292]. You can assign other languages to the report recipient's country in the IMG activity Assign language and lead time to country if the report is to be generated and shipped in a number of languages.

- **Key date selection**

  For automatic shipping, use the IMG activity Specify key date for shipping to define which key date is to be used as the procurement date depending on the shipping reason. During generation, the substance data that are valid on the key date are used.


MSDS Initiator (Sales Organization)

Definition

The sender’s details must be entered on a material safety data sheet. These details include, for example, the address of the company, emergency telephone number, and names of contact persons who can provide information about a material safety data sheet.

The R/3 System determines the sender data for the material safety data sheet via the sales organization (in general, the initiator) that was specified in the sales document. You can store other data in a text field for the sales organization in Customizing. You can output all this data on a report.

For more information about the text field, see the IMG activity Check external prerequisites in Customizing for Product Safety.
Substance Report Shipping Order

Definition

Groups together all parameters that are used to define and control report shipping. The report shipping order can be requested manually or automatically.

To send substance reports (like material safety data sheets, TREMcards, or labels), you need the following objects to exist in report shipping:

<table>
<thead>
<tr>
<th>Object</th>
<th>Consists of</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial shipping order</td>
<td>&gt; 1 recipient and &gt; 1 report</td>
</tr>
<tr>
<td>Report shipping order (substance report shipping order)</td>
<td>1 recipient and 1 report</td>
</tr>
<tr>
<td>Shipping order bundle</td>
<td>1 recipient and &gt; 1 report</td>
</tr>
<tr>
<td>Shipping order package</td>
<td>1 recipient and ≥ 1 report,</td>
</tr>
<tr>
<td></td>
<td>whereby the number of reports within a</td>
</tr>
<tr>
<td></td>
<td>package is limited by the size of the</td>
</tr>
<tr>
<td></td>
<td>shipping unit used (C4 or C6 envelope,</td>
</tr>
<tr>
<td></td>
<td>for example).</td>
</tr>
<tr>
<td></td>
<td>A shipping order package can also contain a cover sheet and acknowledgement of receipt.</td>
</tr>
</tbody>
</table>

Structure

The report shipping order provides you with information about:

Report shipping order parameters

- Shipping order ID
- Shipping reason (for example, generated manually, generated by Sales)
- Business process (for example, material safety data sheet shipping)
- Target shipping date and shipping date with time of shipping
- Report shipping order type (report, cover sheet, or acknowledgement of receipt) and shipping element (for example, envelope that holds 10 sheets of paper or e-mail that can send up to 1 MB of data)
- Status (for example, waiting for goods issue check, ready)
- Communication type
  
  The communication type depends on the recipient and the shipping reason. Possible communication types are e-mail, letter, fax (see: Shipping Order Packages [Page 323]).
- Output device
  
  If the report is to be mailed as a letter, you will need to specify a printer.
- Subsequent shipping indicator
Substance Report Shipping Order

Recipient parameters
You can use the environment parameter SRE_DS_SDSREC to specify whether the recipient of a report is to be a company or a person (contact person).

You will find more information on the environment parameter SRE_DS_SDSREC in the IMG activity Define environment parameters in Customizing for Product Safety.

The following kinds of address management are supported:

- Address management in the R/3 component Sales and Distribution (SD) (customers with partner function MSDS recipient)
- Address management in the R/3 user administration (for manual report shipping only)
- Address management in the R/3 component Product Safety (for manual report shipping only)

As well as name and address, you must also specify the valid communication types for every recipient.

Substance report parameters
The following parameters are displayed:

- Parameters that describe the substance report (for example, substance, generation variant, language, report type, version, report status, relevancy indicator)
- Parameters that are assigned to the substance report (for example, material name, material number)

Additional report parameters
The following information is provided:

- Document key
- Document format
- Document size

Control indicators
The R/3 System stores the administrative data and control indicators. In addition to the date of creation and name of the person who created the report, the date and person responsible for the output check and the acknowledgement of receipt are logged.

Changes to certain parameters of the report shipping order are possible, depending on the status of the report shipping order, if shipping cannot otherwise be carried out. For example, it may be necessary to change the communication type Letter if a printer is defective. The R/3 System stores the name of the person who made the changes and the date of the changes.
Report Shipping Status Network

Status network for the creation of report shipping orders

Status network for the control and maintenance of report shipping orders
Report Shipping Status Network

Status network for saving report shipping orders

You can cancel processing for orders with any status from IW through to PA by manually choosing the Reject function. The report shipping order has status ER and can be manually restarted or deleted from there.
Shipping Reason

Definition

The trigger for starting report shipping. Report shipping is also controlled by the shipping reason. The shipping reason also takes into account the business process for which shipping is triggered. A typical business process is, for example, shipping material safety data sheets (MSDS).

You define the shipping reason and its parameters in Customizing for Product Safety.

Structure

Shipping Reason – Elements

The shipping reason consists of the following elements:

- **Reason**
  The following reasons for shipping could exist:
  - Shipping triggered from Sales and Distribution (SD_CALL) if automatic shipping of a material safety data sheet is required
  - Subsequent shipping (SUB_CALL) if the R/3 System has generated a new main version for a report as the result of a relevant change
  - Manual shipping or print job (MAN_CALL or PRINT_CALL) if you want to react to a customer request directly by e-mail or mail.

- **Reason type**
  The reason type allows you to subdivide the shipping reason more exactly. For shipping triggered by Sales, you can differentiate between triggering by delivery (reason type DELIVERY) and by order (reason type ORDER).

- **Business process**
  The link to the report type is also made via the business process. The report type is assigned to a report via the corresponding generation variant with which the report was generated. When material safety data sheets are shipped, only those reports whose report type is assigned to the business process Material safety data sheet shipping in the IMG activity Specify report types are selected as standard.

Control Indicator for Shipping Reason

You can define the following indicators depending on the shipping reason:

- **Initial status**
  The initial status Created specifies that a report shipping order must be released manually before processing it further.
  The initial status Released specifies that the report shipping order can be processed immediately.

- **Shipping reason**
Shipping Reason

You can choose whether processing waits until a periodic job is run or whether it starts immediately. Report shipping orders that are generated immediately are always set to the next processing status, independent of their initial status.

You can also control the following:

- Whether the report shipping order should be taken into account in subsequent shipping
- Whether the person responsible has to confirm report output
- Whether the person responsible has to post the acknowledgement of receipt
- Whether the R/3 System has to select the most up-to-date released report again before generating the report ready for shipping
- Whether the report shipping orders have to be bundled
- Whether a cover sheet is to accompany the report
- Whether an acknowledgement of receipt is to accompany the report

Customizing Settings Dependent on the Shipping Reason

A number of other Customizing settings for report shipping depend on the shipping reason:

- IMG activity Assign communication types
  
  Depending on the shipping reason you can assign communication types. For example, the communication types fax, e-mail, and letter are supported. The communication type can be subdivided more exactly using the communication group.

  Depending on the communication types, the routines for bundling, generating, packing, and sending are assigned as standard. Whether a number of report shipping orders are actually bundled together does not just depend on the control indicator in the shipping reason, but also on whether the bundling routine is assigned to the communication type that was selected for this shipping reason.

  The routines for checking and saving report shipping orders are assigned directly to the shipping reason. The check records the report shipping orders first and then, in a second stage, runs the actual check function.

- IMG activity Assign templates: cover sheets/acknowledgements of receipt

  Depending on the shipping reason you can also assign a cover sheet and acknowledgement of receipt. As a selection criterion you can also enter the initiator (sales organization) and the recipient country. In addition, you can specify the cover sheet and acknowledgement of receipt directly for the business process. This assignment is then used for shipping order bundles that contain report shipping orders with different shipping reasons and belong to the business process in question. For the R/3 System to output the documents you must have set the appropriate control indicators for the shipping reason.

- IMG activity Specify parameter values to be saved (see: Saving Report Shipping Orders [Page 326])

- IMG activity Specify key date for shipping

  The key date defines the validity date for the report selection and also corresponds to the shipping date.

- IMG activity Assign recipient for error handling
Depending on the shipping reason, you assign the error code that is sent to a defined R/3 recipient by e-mail. There are a number of different error codes depending on the point in the program where the error occurred.
Automatic Report Shipping

Purpose

Automatic report shipping is currently possible for shipping material safety data sheets.

In many countries, the law specifies that recipients of chemical products must receive a material safety data sheet (MSDS) before taking delivery of the products. The EH&S material safety data sheet management system automates this process and enables customers to fulfill legal requirements.

Shipping can be triggered either from the delivery or from the order. As the delivery follows the order, as standard the R/3 System only carries out the complete shipping process after the shipping document has been posted. When posting a sales document, the R/3 System simply checks whether a corresponding report can be selected after transferring data to the EH&S System. If necessary, the R/3 System creates a report request.

In Customizing for Product Safety, the customer exit Develop enhancement to check MSDS shipping allows you to set up the whole shipping process from the order.

Prerequisites

- In Customizing for Product Safety, you have made settings in the Report Shipping section:

  Report shipping is controlled using the Shipping Reason [Page 301].

  Apart from the delivery note and material master data, the R/3 System must be able to select the following data uniquely:

  - Report Recipient [Page 292]
  - Substance Report Selection [Page 294]
  - Sender (MSDS Initiator, Sales Organization) [Page 296]

- The reports must have been released in Report Management [Page 258]. As standard, report shipping is set up for the report type Material safety data sheet.

- You have installed the current EH&S version of Windows Wordprocessor Integration (WWI) and made settings in the Report Generation section of Customizing for Product Safety.

Process flow

Material safety data sheet shipping is triggered using output control via condition technique. In this case, the output is the posting of a delivery note in the R/3 component Sales and Distribution (SD), whose delivery item:

- Contains a material that is flagged in the material master as environmentally relevant
- Contains an item category to which an output determination procedure is assigned that contains the output type SDB
Automatic triggering of material safety data sheet shipping in the R/3 component Sales and Distribution (SD)

Material safety data sheet shipping functions as follows:

1. **Procedure in the R/3 component Sales and Distribution (SD)**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delivery posting</td>
<td>When saving a delivery in Sales, the system checks whether there is a material in the delivery for which the <strong>environmentally relevant indicator</strong> is flagged in the material master.</td>
</tr>
<tr>
<td>Output selection</td>
<td>If this is the case, <strong>output</strong> type SDB is selected using a condition schema in Sales.</td>
</tr>
<tr>
<td>Data transfer to EHS</td>
<td>When the output is processed, <strong>Sales-specific data</strong> (for example, recipient data, sender data) is evaluated by the R/3 System. When this is completed, it is transferred to the R/3 component Product Safety.</td>
</tr>
</tbody>
</table>

2. **Procedure in the R/3 component Product Safety (EH&S)**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material-substance assignment check</td>
<td>In EH&amp;S, the substances of which the material consists are determined using the <strong>material-substance assignment</strong>.</td>
</tr>
</tbody>
</table>
### Automatic Report Shipping

| **Check whether the exclusion indicator is not set** | The R/3 System then only cancels material safety data sheet shipping for a substance if:
| | – The *MSDS shipping not required* exclusion indicator is set for the substance
| | – The rating for this characteristic value also matches the rating that you have defined in Customizing as an environment parameter

The rating CUSTOMER is defined for the environment parameter SRE_DS_CHECK_VALID. The *MSDS shipping not required* exclusion indicator was set in the substance characteristic values and the rating was also set to CUSTOMER. The European Union was entered as the validity area for the substance characteristic values. This means the report is not shipped if the country of the ship-to party belongs to the European Union. If the country of the ship-to party is, for example, the USA, the substance characteristic value is invalid and the report is shipped.

| **Generation variant selection** | You select the **generation variant** for the report you want to send using the condition schema for EH&S report shipping.
| **Report selection** | The **report** is selected according to the following criteria:
| | See: Substance Report Selection [Page 294]
| | – Generation variant
| | – Language; determined according to the recipient country
| | – Key date on which the report data is valid

The key date can be defined in the IMG activity *Specify key date for shipping* in Customizing for Product Safety.

| | The **version** of the report that is determined in this way is only a draft version. If you have set the *Check indicator* in the IMG activity *Check shipping reasons* under shipping reason, before generating the report ready for shipping the R/3 System checks whether a newer released version of the report has since been created for the above key date.
Report shipping order

A report shipping order is generated with the selected report and the MSDS recipient determined by Sales.

- The shipping reason for this report shipping order is set automatically by the system (SD_CALL).

- You can make settings for the shipping time in the IMG activity Specify key date for shipping in Customizing for Product Safety.

You can enter a shipping lead time depending on the recipient country in the IMG activity Assign language and lead time to country. (To ensure the material safety data sheet is delivered on time, it is a good idea to send the material safety data sheet, for example, two days before goods issue.)

- The sales organization is used as initiator (sender) of the shipping order.

The newly generated report shipping order is created in the send log with the initial status defined for the shipping reason. The initial status Created requires you to release the report manually, whereas with the initial status Released, processing of the report shipping order starts as soon as the shipping time is reached.

3. Activities in EH&S if no report is found for the selection parameters:

<table>
<thead>
<tr>
<th>Activity</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report request creation</td>
<td>The R/3 System creates a report request in the work list.</td>
</tr>
<tr>
<td>Creating a report shipping order</td>
<td>The R/3 System also creates and processes a report shipping order.</td>
</tr>
<tr>
<td>Release check</td>
<td>Before generating the ready-to-ship report, the R/3 System checks if the report request has resulted in a released report. If the report is not yet released, the R/3 System sets the status of the report shipping order to Errors. When the report is finally released, you can set the report shipping order manually to the status In work using the function Restart.</td>
</tr>
</tbody>
</table>

Result

Further processing of the released report shipping order starts as soon as the shipping time is reached (see: Output Data in SD [Page 311]).

All further steps that are required for creating a Substance Report Shipping Order [Page 297] are then carried out in the R/3 component Product Safety.

The standard check filters the shipping of material safety data sheets according to regulatory requirements (see: Checking Report Shipping Orders [Page 308]).
Checking Report Shipping Orders

Use

This function checks in accordance with the shipping reason whether a report shipping order that has been created may be sent. If shipping is not required from a legal point of view, the report shipping order is rejected, thus saving you unnecessary costs.

The function is created as a user exit so that you can define your own function modules for the check. The first stage of the check covers all newly released report shipping orders. In the second stage, the R/3 System checks in accordance with the country and region of the ship-to party whether the report shipping orders that were generated automatically by Sales are required by law.

Using Customizing you can also set up the check for manually triggered report shipping orders. In this case there is no ship-to party so that the R/3 System uses the country and region of the report recipient.

All report shipping orders that are not rejected by the check are passed on for further processing.

Prerequisites

- The report shipping order has the status Released (RE) and has been automatically generated from the R/3 component Sales and Distribution (SD) (see: Report Shipping Status Network [Page 299]).
- You can use the following settings in Customizing for Product Safety:
  - Defining the check method
    In the IMG activity Manage user exits, you can find the user exit EHS_CHECK of user exit type SRE_DIST.

    ![Lightbulb]
    Report shipping orders that were generated manually are recorded as standard using the user exit EHS_CHECK. However, the check function is not used on them.
  - Assigning the check method
    In the IMG activity Assign names for user exits, the user exit EHS_CHECK is assigned to the exit type CHECK in accordance with the shipping reason. The exit type CHECK defines the point in the program at which the user exit is called.

    ![Lightbulb]
    In the standard system, the user exit EHS_CHECK is assigned to the business process Material safety data sheet shipment (MSDS_DIST) and the cause Created by SD (SD_CALL).
    In the IMG activity Assign check and subsequent shipping functions, the function module is assigned to material safety data sheet shipping in accordance with the country and region of the ship-to party or the material safety data sheet recipient. This check function is integrated in the user exit EHS_CHECK.
Features

Standard Check Function for Validity Area USA

The check function CVEM_RDO_CHECK_US for the USA ensures that a material safety data sheet is always sent for the first delivery in a calendar year of a product that requires a material safety data sheet. If further purchase orders are received, then a material safety data sheet is sent whenever a relevant change is made that results in a new main version. For this reason, subsequent shipping is not required in the USA.

If a new report shipping order for a new main version is created, the R/3 System checks whether a material safety data sheet recipient in the USA has already received this version. If an existing report shipping order is identical in all of the following criteria, the new report shipping order is rejected:

- Recipient ID of report (customer, not contact person)
- Sales organization of sender
- Name of material for which the report is being sent
- Substance ID for which the report was generated
- Generation variant ID for which the report was generated
- Language in which the report was generated
- Main version of report

If all these criteria apart from the language are identical, the R/3 System does not reject the report shipping order. The report is sent in the new language.

Standard Check Function for Validity Area European Union

In European Union countries, the twelve-month rule applies to the shipping of material safety data sheets. The check function CVEM_RDO_CHECK_EU accepts a new report shipping order only if no equivalent report shipping order has been received by shipping or subsequent shipping within the last twelve months.

The check runs through a total of three steps. In steps one and two, the R/3 System runs the check for report shipping orders whose target shipping date is less than 12 months ago. By using the target shipping date, the shipping lead time is also taken into account.

In the standard system the target shipping date is calculated by:

- Subtracting the lead time from the goods issue date for shipping from delivery
- Subtracting the lead time from the requested delivery date for shipping from orders

Step 1:

In the first step, the R/3 System compares the same criteria as for the validity area USA (see above) but initially ignores the main version. If within the last twelve months a report shipping order is identical in all criteria to the new report shipping order and the subsequent shipping indicator is set, the new report shipping order is rejected.
Checking Report Shipping Orders

Reshipping a report is then not necessary as the customer automatically receives a new version of the report via subsequent shipping.

- Step 2:
  If the subsequent shipping indicator is not set, the second step also compares the main versions. If the main versions match, the new report shipping order is rejected. If the customer issues a new purchase order every month, for example, and if the main version of the report that was originally sent is unchanged, a new report is not sent to the customer. Only if the customer renews the purchase order after a break of more than twelve months does he/she receive a report again, regardless of whether the main version has changed or not.

- Step 3:
  If no previous report shipping order was found, in the third step the R/3 System checks whether a released subsequent shipping order exists whose date of creation lies within the last twelve months. The target shipping date is irrelevant here. If the main version of the subsequent shipping order is also identical to the version of the new report shipping order, the new report shipping order is rejected.

Report Shipping Orders to be Checked

The existing report shipping orders are checked in all statuses apart from report shipping orders with the status *Start of work* and *Released*. As these report shipping orders were not yet checked, it is possible that they may be rejected and are then no longer relevant. As subsequent shipping orders are never rejected once they are generated, they are also taken into account in the status *Released*. The R/3 System also includes manually generated report shipping orders in the check.

Further Processing of Report Shipping Orders

If an order is rejected after it has been checked, you can set the status of this order manually from *Rejected* back to *In work*.

The R/3 System always saves the report shipping order that was rejected last in order to retain the date of the last purchase order from a customer for a particular material. All other report shipping orders with the status *Rejected* are assigned a deletion indicator by the report RCVDDISP. You can set the number of days until these report shipping orders are deleted by the dispatcher (report RCVDDISP) in Customizing in the IMG activity *Specify environment parameters* using the environment parameter SRE_DS_DELETE.

For further information on the report RCVDDISP, see the IMG activity *Set up jobs for report shipping* in the Implementation Guide (IMG) for Product Safety.
Output Data in SD

If a delivery contains at least one environmentally-relevant material, the R/3 System transfers all relevant delivery data from the R/3 component Sales and Distribution to the R/3 component Product Safety when an MSDS output is sent.

During this process, the fields for the structure RCGCUSDATA and the fields for the structure RCGSDDOC are filled with values and transferred from the R/3 component Sales and Distribution to the R/3 component Product Safety.

If you choose Goto → Parameter values in the hit list for the report shipping orders, the field values for the structures RCGUSDATA and RCGSDDOC are displayed. If the R/3 System cannot determine any values, the fields remain blank.

For further information on determining the material name, see Material Name, Material Number [Page 312].
Material Name, Material Number

Determining the material name is dependent on the shipping reason.

- **Triggering report shipping manually**
  - If you have maintained a long text in the R/3 component *Material master*, the first 132 characters of the basic data long text are displayed in the logon language.
  - If no basic data long text exists, the material short text is displayed in the logon language.
  - If no material short text exists, the identifier that the R/3 System determined in accordance with the identification listing D_MATNAM is displayed.
  - If no appropriate identifier exists, the substance key is displayed as the default value.

  Determining the material name is done in the same way as determining the default parameter value (see *Default Parameters for Reports* [Page 270]).

- **Triggering report shipping automatically**
  When shipping is triggered from the R/3 component *Sales and Distribution*, the material sales text is displayed if you have set the environment parameters SRE_DS_TDID_DELPOS and SRE_DS_TDID_ORDPOS accordingly. For further information about the environment parameters, see the IMG activity *Specify environment parameters* in Customizing for *Product Safety*.

  If you have not maintained a material sales text, the R/3 System displays the article short text.

For further information on maintaining the material texts for triggering report shipping manually and automatically, see the IMG activity *Check external prerequisites*. 
Subsequent Shipping

Use
This function supports the subsequent shipping of reports that have already been sent, if a new version of the report exists and has been released. The subsequent shipping function delivered in the standard system takes into account the legal guidelines for the validity area European Union.

Depending on the recipient country and region, you can modify the delivered function for subsequent shipping or develop your own functions and implement them in the program.

Prerequisites
- A new main version of a report replacing an older one has been created and released (see Versioning Reports [Page 267]).
- The report shipping order for the previous report version is logged in the shipping log, and the subsequent shipping indicator is set in the IMG activity Check shipping reasons.
- In Customizing for Product Safety, you have made settings in the Report Shipping section: You must make the following settings especially for subsequent shipping:
  - Defining the shipping reason
    In the IMG activity Check shipping reasons, the cause SUB_CALL with the business process MSDS_DIST is set up for subsequent shipping in the standard system.
  - Defining the check method
    In the IMG activity Manage user exits you can find the user exit EHS_SUBSEQ of user exit type SRE_SUBSEQ. The function for subsequent shipping is implemented in the program depending on the recipient country and region.
  - Assigning the check method
    In the IMG activity Assign check and subsequent shipping functions, the function module to call the subsequent shipping function is assigned depending on the recipient country and region.

Features
Determining subsequent shipping orders can be set up to run automatically at set intervals. Using the validity date, the R/3 System also takes into account reports that have already been released but only become valid at a date in the future.

Subsequent shipping orders are created by the R/3 System as follows:
- The R/3 System only selects all new released reports that have a new main version. A new main version is created automatically in the R/3 System when a report is created by the R/3 System as the result of a relevant change to a substance. Using the generation variant you can also specify that all relevant changes should be indicated on the generated report.
- The system checks whether previous versions of the reports exist. However, only report shipping orders are included whose target shipping dates from the R/3 component Sales and Distribution (SD) are not older than twelve months. This means a purchase order for a material must have been issued within the last twelve months.
Subsequent Shipping

- The R/3 System checks whether the subsequent shipping indicator is set for the previous versions of the report shipping orders.
- The R/3 System compares the selected reports and the new reports for the following assignments:
  - The report-substance assignment set in the report header
  - The material-substance assignment set in substance management

If the assignments match, the subsequent shipping orders are created and displayed in the shipping log (see Processing the Report Shipping Log [Page 328]). The current recipient data is determined during this process.

If you have used the shipping reason to specify that subsequent shipping orders should be created with the initial status **Created**, the subsequent shipping orders must first be released manually. All released subsequent shipping orders are passed on for further processing without additional checks.

See: Report Shipping Status Network [Page 299]

A customer orders a material on February 1, 1998 for which a material safety data sheet must be sent. The version 1.0 is sent. The subsequent shipping indicator is set. On July 1 version 2.0 is created and is shipped subsequently. The R/3 System uses February 1, 1998 as the target shipping date. Version 3.0 is created on February 15, 1999 and is not shipped subsequently. Subsequent shipping took place eight months ago, but the target shipping date is more than twelve months ago.
Manual Report Shipping

Use

You can use this function to create report shipping orders manually for released reports. The report is created in the report information system in which only released reports are displayed.

Whether a report is available for material safety data sheet shipping then only depends on the report type that the generation variant assigns to the report.

In the standard system, the report type Material safety data sheet is required for shipping. This report type must be assigned to the business process Material safety data sheet shipping in the IMG activity Specify report types and this business process must be assigned to the shipping reason Manual shipping in the IMG activity Check shipping reasons.

Prerequisites

- In Customizing for Product Safety, you have made settings in the Report Shipping section.
- Released reports of the report type Material safety data sheet exist (see: Releasing Reports [Page 265]).
- You have installed the current EH&S version of Windows Wordprocessor Integration (WWI) and made settings in the Report Generation section of Customizing for Product Safety.

Features

You must send every report for a material. If a material is not assigned to the report via the material-substance assignment, you can set any default material.

You can choose any of the following as the recipient:

- Customer (business partner, customer, company)
- Office user of the R/3 System
- Report recipient

The R/3 System allows you either to process the shipping order in the background or to start shipping immediately. For the background processing type, you can use settings in Customizing to control whether these report shipping orders must first be accepted manually by the person responsible. With immediate processing, the report shipping orders are immediately passed on for further processing.

You can decide directly when starting shipping whether you want to set the subsequent shipping indicator.

As the default, manually created report shipping orders are recorded in the first step of the check, but not checked. If you want to, you can specify that manually created report shipping orders should also be checked (see: Checking Report Shipping Orders [Page 308]).

Activities

Creating Report Shipping Orders Manually [Page 316]
Creating Report Shipping Orders Manually

Prerequisites

In report management, the status of the report must be changed to RE (Released) (see Report Management [Page 258]).

The report has the report type Material safety data sheet.

In the R/3 material master, you have created the material or the default material for which you want to send the report.

Procedure

1. In the Product Safety [Ext] screen, choose Reports → Report info system.
   
   The initial Report Information System screen appears:

2. Enter the data required for selecting the relevant reports and choose Report → Navigation → Report tree.

   The report information system appears.

   To send reports, you must be in the material view. If necessary, choose Utilities → Toggle view → Material view. If no material has been assigned to the substance of a substance report, the R/3 System displays the default material that you assigned by choosing Utilities → Change default mat. You can carry out shipping using the default material, or you can choose Utilities → Change default mat. to assign a different material.

3. Mark the reports that are to be sent. To do this, place the cursor in the appropriate position and choose Edit → Nodes → Select nodes.


   The Report shipping: enter parameters dialog box appears.

5. Enter the following data:

<table>
<thead>
<tr>
<th>Recipient parameters</th>
<th>Choose between</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Customer (the data must have been created in the R/3 customer master record). See Maintaining the Internet Address of a Customer [Page 334]</td>
</tr>
<tr>
<td></td>
<td>• Office users (each user of your R/3 System is entered as an office user. To check this, choose Office → Administration → Office user in the R/3 main menu.)</td>
</tr>
<tr>
<td></td>
<td>• Report recipient (the data must have been in the address management system of the R/3 Product Safety component). See Maintaining the Addresses of Report Recipients [Page 333]</td>
</tr>
</tbody>
</table>
Procedure parameters

Choose between

- **Background:** Enter the *Target shipping date*.
- **Immediately:** Enter the *Communication* and, if required, the *Output device*.

When shipping a document manually by fax, you must enter the fax machine as the output device.

Additional parameters

Decide if this shipping order is relevant for subsequent shipping.

The indicator is set as default if you have set it in the IMG activity *Check shipping reasons*.

6. Choose **ENTER**.

The shipping process is started.

**Result**

The report shipping order that has been manually generated is given the starting status, depending on the process parameters chosen and the initial status that you defined in the IMG activity *Check shipping reasons*.

The process parameters that you selected manually override the process type that you defined in the IMG activity *Check shipping reasons*.

<table>
<thead>
<tr>
<th>If the following settings have been made:</th>
<th>The report shipping order is given the status</th>
</tr>
</thead>
</table>
| **Process parameter: In the background:** | **SW (Start of work)**

Initial status {0 (Created)}

You must accept this status **manually** in order to reset the status of the shipping order to **RE (Released)**. |
| **Process parameter: In the background:** | **RE (Released)**

Initial status {1 (Released)}

Report RCVDDISP starts the report shipping order at a defined time. Report RCVDEVEN then calls the user exit EHS_CHECK (see *Checking Report Shipping Orders [Page 308]*). |
| **Process parameter: Immediately:** | **RE (Released)**

Initial status AA or RE.

Report RCVDEVEN immediately calls the user exit EHS_CHECK. |

See also: [Report Shipping Status Network [Page 299]](#)
Bundling Report Shipping Orders

Use

This function allows you to send report shipping orders with the same shipping reason and communication type to the same recipient bundled together instead of separately. This therefore enables you to reduce shipping costs. Manually generated report shipping orders can also be bundled together.

The function module is created as a user exit so that you can define your own function modules for bundling.

Prerequisites

- The shipping order has been successfully checked, and thus has status *In work (IW)* (see: Report Shipping Status Network [Page 299]).
- You can use the following standard settings in Customizing for *Product Safety*:
  - Bundling indicator
    You have set the indicator for bundling in the IMG activity *Check shipping reasons*. If the indicator is not set, the R/3 System creates a separate bundle for each report shipping order.
  - Defining the bundling method
    In the IMG activity *Manage user exits* you can find the user exit EHS_BUNDLE of user exit type SRE_DIST.
  - Assigning the bundling method
    In the IMG activity *Assign names for user exits*, the user exit EHS_BUNDLE is assigned to the exit type BUNDLE in the standard system in accordance with the communication type. The exit type BUNDLE defines the point in the program at which the user exit is called.

Features

Bundling Criteria

Whether a number of report shipping orders are bundled together does not just depend on the control indicator in the shipping reason, but also on whether the bundling routine is assigned to the communication type that was selected for this shipping reason.

As standard, report shipping orders are grouped according to the following criteria within one bundling method:

- Recipient
- Communication type
- Report shipping order initiator
- Business process
Bundling Organization

The R/3 System collects all report shipping orders that were not rejected by the check routine. Using the bundling criteria, the system checks if bundles already exist to which these report shipping orders can be assigned.

If no suitable bundles exist, new bundles are created.

Bundling according to bundling criteria *Recipient* and *Communication type*
Generating Reports

Use

After a report shipping order has been successfully checked and bundled, this function generates the appropriate ready-to-ship reports.

The function module is created as a user exit so that you can define your own function modules for generation.

Prerequisites

- The report shipping order has the status Order bundled (BU) (see: Report Shipping Status Network [Page 299]).
- You have installed the current EH&S version of Windows Wordprocessor Integration (WWI) and made settings in the Report Generation section of Customizing for Product Safety.
- You can use the following settings in Customizing for Product Safety:
  - Defining the generation method
    In the IMG activity Manage user exits, you can find the user exit EHS_GEN of user exit type SRE_DIST. The user exit contains the function module for the generation.
  - Assigning the generation method
    In the IMG activity Assign names for user exits, the user exit EHS_GEN is assigned to the exit type GENERATE depending on the communication type. The exit type GENERATE defines the point in the program at which the user exit is called.

Features

There are several steps involved in generating reports:

- Depending on the shipping reason, you can set the R/3 System so that it checks whether a new released version of the report exists for the required key date before generating. To do this, set the Check indicator in the IMG activity Check shipping reasons. If a new version exists it is sent.
- For report shipping, the report (the *.DOC file, for example) must be uploaded from the R/3 Document Management System.
- If the report still contains symbols of the symbol type Parameter, the R/3 System replaces them all with the actual values. Current sales and distribution data such as the customer address are then determined for shipping.
- The R/3 System determines the size of the individual final reports (in pages and bytes) so that the shipping order bundle can then be packed into shipping order packages.
Packing Shipping Order Bundles

Use

This function divides shipping order bundles into shipping order packages using shipping units. The function module is created as a user exit so that you can define your own function modules for packing.

Prerequisites

- The report shipping order has the status Order generated (GE) (see Report Shipping Status Network [Page 299]).
- You can use the following settings in Customizing for Product Safety:
  - Defining the shipping unit
    In the IMG activity Specify shipping units, you have defined the required shipping units (for example, C4 envelope, C6 envelope).
  - Assigning the shipping unit
    In the IMG activity Assign shipping units, at least one shipping unit must be assigned to each communication type. If required, you can also assign a shipping unit in accordance with the initiator, the business process, and the recipient country. You define the capacity of the shipping unit (number of pages or bytes) in the IMG activity Specify shipping units.
  - Assigning the cover sheet and acknowledgement of receipt
    In the IMG activity Assign templates: cover sheets/acknowledgements of receipt you define the keys for the document templates in accordance with the shipping reason. You can also assign the keys in accordance with the initiator and the country. In addition, you must have set the indicators for the cover sheet and the acknowledgement of receipt in the IMG activity Check shipping reasons.
  - Defining the packing method
    In the IMG activity Manage user exits, one of two user exits of user exit type SRE_DIST is provided: EHS_PACK_B (for bytes) or EHS_PACK_P (for pages). Depending on the communication type, the shipping orders are packed according to bytes or pages.
  - Assigning the packing method
    In the IMG activity Assign names for user exits, the user exits EHS_PACK_B or EHS_PACK_P are assigned to the exit type PACKAGE in accordance with the communication type. The exit type PACKAGE defines the point in the program at which the user exits are called.

Features

The system goes through the following steps when packing order bundles:
Packing Shipping Order Bundles

- If there is a choice of a number of different size shipping units for one communication type, the R/3 System assigns the shipping order bundle to the appropriate shipping unit. If the shipping order bundle is too big, it is split up. The result is the shipping order packages.

- You can assign a cover sheet and an acknowledgement of receipt to a shipping order package. Cover sheets and acknowledgements of receipt never contain substance data. This means the cover sheet and acknowledgement of receipt can be generated fully during packing (reset status GE → PA) once it is clear exactly how many packages have been created.

- For each shipping order package, the system records which reports have been assigned to it. This information is then used when generating the cover sheet and acknowledgement of receipt.
Shipping Order Packages

Use
This function carries out the shipping method depending on the communication type for completed shipping packages.

The function module is created as a user exit so that you can define your own function modules for shipping.

Prerequisites
• The report shipping order has the status Order packaged (PA) (see: Report Shipping Status Network [Page 299]).
• You can use the following standard settings in Customizing for Product Safety:
  – Defining the output format
    In the IMG activity Specify communication you have defined the format in which the report is to be output depending on the communication types.
  – Assigning the communication type for the shipping reason
    In the IMG activity Assign communication types you have defined the priority of the permitted communication types depending on the shipping reason. In the IMG activity Assign shipping units, you have assigned at least one shipping unit to each communication type.
  – Assigning the communication type to the report recipient
    You have defined the permitted communication types and a default communication type for all report recipients.
  – Defining the shipping method
    In the IMG activity Manage user exits, for each communication type, you can find a separate variation of the standard user exit EHS_SEND of user exit type SRE_DIST.
  – Assigning the shipping method
    In the IMG activity Assign names for user exits, the user exit EHS_SEND_* is assigned to the exit type SEND in accordance with the communication type. The exit type SEND defines the point in the program at which the user exit is called.

Features

Selecting the Communication Type
• Manual report shipping
  When triggering shipping manually you can choose between:
  – Customer (business partner, customer, company)
  – Office user of the R/3 System
Prerequisites

- Report recipient
  
  You enter the recipient directly when you set up the report shipping order. The R/3 System determines which communication types are specified for both the customer and in Customizing and allows you to choose from these. For shipping in the background, the communication type you specified as the default for the recipient is taken into account in the same way as for automatic report shipping (see below).

- Automatic report shipping
  
  For automatic report shipping, you can choose from customers only (business partner, customer, or company) as the recipient and not from office users or report recipients. You must have specified the permitted communication types for all customers and their contact persons in the R/3 component Sales and Distribution. You can define a communication type as the default communication type.

In Customizing you define the priorities of the permitted communication types depending on the shipping reason. The default communication type always has the highest priority, but must also be present in Customizing so that it can be used for shipping.

In the figure, shipping as e-mail is not permitted as the communication type E-mail is not entered in Customizing.

In the same way, the communication type can be overridden by contact persons:

The communication type Letter was defined for the three contact persons of a business partner, whereas the business partner has the communication type Fax. In Customizing, only the communication type Fax is defined for shipping material safety.
data sheets. As a fax cannot be sent to the contact persons, they will not receive a report. Instead, the business partner receives a total of three faxes, each of which contains the address data of one contact person.

**Shipping Methods**

The following shipping methods are possible in the standard system:

- **Printing via the R/3 spool**
  
  Reports printed via the R/3 spool must be in Postscript format. Conversion in accordance with the formats defined for the communication type only takes place when the final report is generated.

- **E-mail**
  
  Reports distributed via e-mail can be sent in *.DOC format.
  
  When shipping via e-mail, the reports including the cover sheet and acknowledgement of receipt are sent as attachments to the e-mail. The e-mail itself contains only a standard text.
  
  You can use the following alternatives for shipping:
  - Sending an e-mail within an R/3 client
  - Sending an e-mail between SAP R/3 Systems (RML: remote mail)
  - Sending a mail via the Internet

- **Fax**
  
  In the SAP R/3 Office, you use the communication server *SAPcom* to send faxes. The reports that are to be sent may be in Postscript or PCL format. Conversion takes place when generating the final report.
Saving Report Shipping Orders

Use

This function transfers the data in a report shipping order to the shipping history, depending on the shipping reason.

In the standard system, print requests, acknowledgements of receipt, and cover sheets are not saved, but are deleted by the user exit EHS_SAVE.

The shipping history is used to:

- Prove that a specific substance report has already been sent to a recipient
- Provide the data required for subsequent shipping and the checking method.

The function module is created as a user exit so that you can define your own function modules for saving.

Prerequisites

- The report shipping order has the status Complete (CO) (see Report Shipping Status Network [Page 299]).
- You can use the following standard settings in Customizing for Product Safety:
  - Defining the save format
    In the IMG activity Specify communication you have defined the format in which the ready-to-ship report is to be saved depending on the communication type. A suitable application must be installed in order for you to be able to display the saved report.
  - Assigning the communication type for the shipping reason
    In the IMG activity Assign communication types you have defined the priority of the permitted communication types depending on the shipping reason. In the IMG activity Assign shipping units, you have assigned at least one shipping unit to each communication type.
  - Assigning the communication type to the report recipient
    You have defined the permitted communication types and a default communication type for all report recipients. You will find more information about selecting the communication type under Shipping Order Packages [Page 323].
  - Defining the shipping method
    In the IMG activity Manage user exits, you can find the user exit EHS_SAVE of user exit type SRE_DIST.
  - Assigning the shipping method
    In the IMG activity Assign names for user exits, the user exit EHS_SAVE is assigned to the exit type SAVE for the corresponding shipping reasons. The exit type SAVE defines the point in the program at which the user exit is called.
  - Defining the environment parameter
In the IMG activity *Define environment parameters* you use the environment parameter SRE_DS_SAVE to define the number of days after which a report shipping order is saved.

**Features**

You can reset the status of a report shipping order with or without a final report indicator to *Historical*.

- **With final report indicator**

  If you set the final report indicator depending on the shipping reason in the IMG activity *Check shipping reasons*, the ready-to-ship report is saved in the R/3 Document Management System. The parameter values are therefore no longer required, so they are deleted. If, however, you still want to save parameter values, enter these parameters in the IMG activity *Specify parameter values to be saved* depending on the shipping reason.

  You can call the whole report and the list of special parameters in the hit list of report shipping orders. Reports in commonly used formats such as *.DOC* and *.RTF* are displayed in Microsoft Word. For special formats (such as Postscript) for which your PC does not have an application, your work station must be installed as an information PC. In this case the report and parameters are re-merged.

    ![Tip]

    To display the report, choose *Goto → Final report display*.
    
    To display the special parameter values, choose *Goto → Parameter values*.

- **Without final report indicator**

  If you have not set the final report indicator, the final generated report is deleted. All parameter values used on the report are saved. The additional parameters specified in the IMG activity *Specify parameter values to be saved* depending on the shipping reason are also saved.

  When you call the display of the ready-to-ship report in the hit list of report shipping orders, the R/3 System generates the report using the saved parameter values. For this to be possible, your work station must have the WWI installation for an information PC.

  You can also call the list of parameter values from the hit list.

    ![Tip]

    On the other hand, if you choose *Goto → Document* in the report information system, the report is generated with the parameter values that are currently valid.
Processing the Report Shipping Log

Prerequisites
The system has automatically created a report shipping order, or you have created one manually.

Procedure
   The Processing report shipping orders: Initial Screen appears.
2. Enter your selection criteria on the screen. During the search, all entries are linked with AND.
   – If you want to look for all initial or package IDs for a particular time frame, then leave the entry in the field as 0.
   – Expand the time frame selection if required. Today’s date is included automatically as standard.
   – If necessary, restrict the status for which you want to select report shipping orders.
   – You can limit the search to a particular recipient.
     In this case you can choose one of the following:
     Customer (the data must have been created in the R/3 customer master record. See Maintaining the Internet Address of a Customer [Page 334]).
     Office users (each user of your R/3 System is entered as an office user. To check this, choose Office → Administration → Office user).
     Report recipient (the data must have been in the address management system of the R/3 Product Safety component. See Maintaining the Addresses of Report Recipients [Page 333]).
     – You can use standard user exits of the type SRS_QUERY to make further restrictions. If required you can define your own user exits of this type and store them in the IMG activity Manage user exits.
   The hit list appears. You can process report shipping orders you select using the following functions:

<table>
<thead>
<tr>
<th>Choose</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Flow trace</td>
<td>The flow trace log for your report shipping order appears.</td>
</tr>
<tr>
<td>Goto → Parameter values</td>
<td>The values of the symbol type Parameter appear.</td>
</tr>
<tr>
<td>Goto → Final report display</td>
<td>In status WC, WA, RY, and HI, you can generate the final report for display.</td>
</tr>
<tr>
<td>Utilities → Toggle view → Column selection</td>
<td>You configure the display of columns.</td>
</tr>
</tbody>
</table>
4. Depending on the status of a report shipping order, you can carry out the following activities from within the shipping log.
   – [Processing Report Shipping Orders](Page 330)
   – [Processing Report Shipping Order Headers](Page 332)
Processing Report Shipping Orders

Prerequisites

A report shipping order exists with the status CR (created), WC (waiting for output check), or WA (waiting for acknowledgement of receipt). The following prerequisites must be met for each of these statuses:

**Processing report shipping orders with status CR:**
You have chosen initial status (created) and process type B (in the background) in the IMG activity *Check shipping reasons*. When sending manually, you have chosen the process parameter *In the background*.

**Processing report shipping orders with status WC:**
In the IMG activity *Check shipping reasons*, you have set the indicator for output check.

**Processing report shipping orders with status WA:**
In the IMG activity *Check shipping reasons*, you have set the indicator for acknowledgement of receipt.

Procedure

2. Enter your selection criteria on the screen (see Processing the Report Shipping Log [Page 328]). Choose either CR, WC or WA as the status.
4. Select the report shipping orders that you want to process.
5. Choose Report ship. order → Accept or Reject.

Result

If you accept the report shipping order, depending on the initial status, the statuses are changed as follows:

<table>
<thead>
<tr>
<th>Initial status</th>
<th>Target status</th>
</tr>
</thead>
<tbody>
<tr>
<td>CR (created)</td>
<td>RE (released)</td>
</tr>
<tr>
<td>WC (waiting for output check)</td>
<td>WA (waiting for acknowledgement of receipt) or RY (ready)</td>
</tr>
<tr>
<td>WA (waiting for acknowledgement of receipt)</td>
<td>RY (ready)</td>
</tr>
</tbody>
</table>

See Report Shipping Status Network [Page 299]

If you reject the report shipping order, depending on the initial status, the statuses are changed as follows:
If an error occurs in the R/3 System, an error message is sent by e-mail. You define the recipient of this mail in Customizing for Product Safety in the IMG activity Assign recipient for error handling.

You can do the following to orders with status ER (error):

- **You can restart them:** Choose Report ship. order → Restart.
  
  The restarted report shipping order is processed further in the background in the next processing cycle.
  
  If the report shipping order is to be sent again immediately, also choose Edit → Ship immediately.

- **You can delete them manually:** Choose Edit → Delete.
Processing Report Shipping Order Headers

Prerequisites
You have created a report shipping order.

Procedure

   The Processing report shipping orders: Initial Screen appears.
2. Enter your selection criteria on the screen (see Processing the Report Shipping Log [Page 328]).
4. Select the report shipping orders that you want to process and choose Goto → Header.
   You can process as follows:
   In status CR, you can change the target shipping date and the subsequent shipping indicator.
   In status RE you can only change the target shipping date and subsequent shipping indicator if the target shipping date is at least one day in the future.
   In status IW, BU, GE, and PA, the R/3 System is processing the report shipping order and therefore data can only be displayed.
   In status WA and WC the report shipping order is waiting for you to accept it or reject it manually. In the report shipping order header, data can only be displayed.
   In status RY and HI, you can only change the subsequent shipping indicator.
   In status ER you can edit the communication type, output device, and communication group fields, and, if necessary, change the subsequent shipping indicator.

💡

You can restart the report shipping order from status ER.
Choose Report ship. order → Restart. The report shipping order you restarted is processed further in the background in the next processing cycle. If the report shipping order is to be sent again immediately, also choose Edit → Ship immediately.

💡

In status CR and ER, you can define new print parameters in the report shipping order header by choosing Utilities → Set print param. In status RE you can only change the print parameters if the target shipping date is at least one day in the future.
Maintaining the Addresses of Report Recipients

1. From the Product Safety [Ext.] screen, choose Tools \(\rightarrow\) Edit addresses \(\rightarrow\) Report recipient or Data owner/provider.

   The Address Management:Report Recipient screen appears.

2. Choose Address \(\rightarrow\) Create.

3. Enter the required data.

4. Save your entries.
Maintaining the Internet Address of a Customer

1. From the R/3 main menu choose Logistics → Sales and distribution → Master data and then Business partners → Ship-to party → Create.
   The initial screen appears.

2. On the following screen Create Customer: Address you can maintain an internet address for your customer by choosing Other communication.

   The address of the customer contact person is taken into account and not the business address. You can maintain the address directly in partner details. The system uses the postal address of the company (customer) for the address in partner details. You can maintain other communication addresses such as FAX or INT specially for the contact person.

Result

You can enter an internet mail address directly into the company address. Substance reports from the R/3 component Sales and Distribution can be shipped to this internet mail address.
Substance / Report Information System

Purpose

Substance Information System

The substance information system enables you to carry out targeted searches for substance data.

The search results are displayed in a hit list where you can call different output methods. You can use integrated user exits to program the output methods to suit your requirements.

Report Information System

The report information system provides you with information about reports in status Released and Historic. You can also display and print reports. You can also compare reports within the report information system.

You can manually send reports with status Released to a material. The released report contain all substance-related data and phrases for a particular language and usage. You can use user exits to control the current parameter values determined by the R/3 System during display or when shipping reports, and you can overwrite them manually in report management if necessary.
Substance Information System

Purpose

See: Substance/Report Information System [Page 335]

Prerequisites

- In Customizing for Product Safety, you have carried out the IMG activities in the Substance/Report Information System section.
- You have authorization to display substances.

The usage check is carried out for the active usages of a data record for a characteristic value. If there is no active usage for a data record, the system checks if the user has the general authorization.

Process flow

1. When you enter the substance information system, you can use the same drill-down reporting functions as in substance management.

   In the IMG activity Manage user exits in Customizing for Product Safety, you can define further user exits for substance search that you can use in the initial substance management and substance information system screens.

2. The results of the search are displayed in the hit list and can be restricted or extended from here.

   More information
   Accessing the Substance Information System [Page 337]

3. You choose the output method in the hit list. The output methods are realized as user exits so that you can define your own output methods in the IMG activity Manage user exits in Customizing for Product Safety.

4. Depending on Customizing, you can specify the substance characteristic categories for which you want to display data as follows:
   - You specify the substance characteristic categories in Customizing.
   - You select the substance characteristic categories within substance information system.

5. You call the selected output method for selected substances:

   More information
   Displaying Properties [Page 338]
   Displaying Compositions/Constituents [Page 341]
Accessing the Substance Information System

1. From the Product Safety [Ext.] screen, choose Substances → Substance information system.

   The Substance Information System: Initial Screen appears. You can start substance drill-down reporting from here.

2. Enter the search criteria for your substance. Use extended drill-down reporting.

   See also: Searching for Substances [Page 68].

3. Choose Substance → Hit list.

   The R/3 System lists all substances that match your search criteria.

   Choose Utilities → Extend selection and Utilities → Refine selection as required (See also: Basic Functions in the Hit List [Page 157]).

4. Within the hit list, you can display data for selected substances:

   **If you want to display**
   
   Data for substance characteristic categories of type Property, Composition or Listing as an R/3 list or an Excel list

   Data for a substance characteristic category of type Substance composition or Substance listing including different formatting methods

   **Then choose the following procedure:**

   Displaying Properties [Page 338]

   Displaying Compositions/Constituents [Page 341]
Displaying Properties

Prerequisites
You must have carried out substance drill-down reporting in the substance information system and be in the hit list.

See also: Accessing the Substance Information System [Page 337]

Procedure
1. Select the substances you want to output.
2. Choose Utilities → Change output.
   A dialog box appears.
3. If you want to display data
   Then choose
   - As a list in the R/3 System: VALUATION
   - As an Excel list: EXCEL or EXCEL-LAB

   To output an EXCEL list in the standard, you must select the substance characteristic categories manually, but to output an EXCEL-LAB list, the substance characteristic categories are predefined in Customizing and are related to the identification data.

   In the standard system, you can define additional data in Customizing for EXCEL output.

   For further information, see the documentation for the IMG activity Specify parameters for substance information system.

4. Choose Utilities → Choose output parameter.
   You use the parameter for user exit type SUB_ISOUT to control the output in the IMG activity Manage user exits.
   If you have set the FLG_ENV_VALCAT_ONLY parameter
   Then the system displays
To be equal to TRUE
A note that parameter entry has been disabled in Customizing.

For further information, see the documentation for the IMG activity Specify parameters for substance information system.

To be equal to FALSE, or not defined
The properties tree in a dialog box where you can select substance characteristic categories manually
Select the required substance characteristic categories.

If you have already selected substance characteristic categories on the initial screen using the Substance with property search function, these are selected automatically as default.

If you have not selected any substance characteristic categories, those specified in Customizing are selected as default.

If you use Microsoft Excel, you can select a maximum of 50 substance characteristic categories.

5. Choose Goto → Output.

Output VALUATION
The output VALUATION displays the property data in the R/3 System as a list. All selected substances are displayed one below the other. In the header section, the identifiers are displayed for each substance according to the column selection on the hit list.

Within the output, you can

- Select more substance characteristic categories by choosing Edit → Choose properties
- Specify the additional information (assessment, source, usage, user-defined texts) to be displayed by choosing Edit → Set output filter

Output EXCEL and EXCEL-LAB
The R/3 System determines the following for the substances selected:

- The data for the substance characteristic categories entered
Displaying Properties

- Additional information - assessment, source and usage

The data are then downloaded to your PC and Excel is started:

- A table is displayed in the Excel folder for each property.

- A line is output in the appropriate table for each substance and characteristic data record.

- One column in the table is output for each characteristic. This ensures that all characteristics for a substance characteristic category are taken into account. Multiple characteristic value assignments are separated by a semi-colon.

The R/3 System lists the selected substances with three identifiers each.

Any values the R/3 System finds that correspond to the selection criteria are displayed.

In Excel, you can process the data further and store them in an Excel file. However, you cannot import the changes back into the R/3 System. Excel is a display program only for the R/3 data.
Displaying Compositions/Constituents

Prerequisites
You must have carried out substance drill-down reporting in the substance information system and be in the hit list.

See also: Accessing the Substance Information System [Page 337]

Procedure
1. Select the substances you want to output.
2. Choose Utilities → Change output.
   A dialog box appears.
3. Select the output COMPONENT in the dialog box.
4. Choose Utilities → Choose output parameter.
   You use the parameter for user exit type SUB_ISOUT to control the output in the IMG activity Manage user exits.
   
   **If you have set the FLG_ENV_VALCAT_ONLY parameter**
   To be equal to TRUE
   **Then the system displays**
   A note that parameter entry has been disabled in Customizing.
   
   The substance characteristic category is predefined in the IMG activity Manage user exits.

For further information, see the documentation for the IMG activity Specify parameters for substance information system.
Displaying Compositions/Constituents

To be equal to FALSE, or not defined

The properties in a dialog box in which all substance characteristic categories of type Substance composition and Substance listing are displayed.

Select the required substance characteristic category.

If you have already selected a substance characteristic category on the initial screen using the Substance with components search function, these are selected automatically as default.

If you have not selected any substance characteristic categories on the initial screen, those specified in Customizing are selected as default.

5. Choose Goto → Output.

Within the output COMPONENT, you can switch between three different outputs:

- Output 1:
  When you enter the output function, a fully expanded composition tree (hierarchy tree) for a substance appears. The data record with sort sequence 1 is always displayed for the corresponding substance characteristic category.

  You can switch to other selected substances by choosing Substance → Previous substance or Next substance.

- Output 2:
  To display the substances in the lowest part of the composition tree, choose Goto → Constituents. The R/3 System determines the total proportion of each constituent.

  The basis for this is the current substance characteristic category and the first data record there.

- Output 3:
  To display all data records maintained for the substance characteristic category of the currently displayed substance, choose Goto → Components.

  Double-click on the substance key. It then becomes the root, and the corresponding output is structured around it. To return to the original display, choose Substance → Superior substance.
Report Information System

Purpose

See Substance / Report Information System [Page 335]

Prerequisites

- You have the required authorization that can be controlled using the following objects:
  - Substance authorization group
  - Report type
  - Report status
  - Rating
  - Validity area

  In report shipping, the R/3 System also checks if the user has authorization for the sales organization to which the report is to be sent.

- You have installed the current EH&S version of Windows Wordprocessor Integration (WWI).

Process Flow

1. Access and drilldown reporting

   You can access the report information system in several ways:
   a) From the area menu

      A selection screen is displayed where you can determine reports according to various criteria. All reports found are displayed in a report tree (see Report Trees [Page 264]).

      As inbound documents are also assigned to a substance, report type, and report generation variant (SRGV), these can also be selected.

      To display inbound documents, you required a special application on your frontend PC (Acrobat Reader for inbound documents with file type *.PDF, for example).

   b) Other forms of substance-related access

      The R/3 System enables you to branch to the report information system hit list from various substance displays. All reports and inbound documents assigned to the relevant substances are displayed directly. You can access the report information system as follows:

      - From the substance management hit list, the substance header, and the properties tree
      - From the substance information system hit list
      - From the report shipping order hit list

   c) From other applications in the R/3 component Sales and distribution
The report information system can be called from the following applications by RFC (remote function call):

- Sales order
- Customer quotation
- Customer inquiry
- Delivery
- Shipment

2. Displaying and printing reports

Reports are displayed and printed in Word. The R/3 System assigns default values for the symbol type Parameter (see Default Parameters for Reports [Page 270]).

💡

You can print the report out on a local printer using Word.

In addition, you can select several reports in the report tree and send them to an R/3 printer via the R/3 spool system.

3. Shipping and exporting reports

If you have the authorization, you can send reports and inbound reports from the material view of the report tree.

You can also use the export function.

Activities

Using the Report Information System [Page 345]

See also:

Report Shipping [Page 290]

Import and Export: Process [Page 348]
Using the Report Information System

1. In the R/3 main menu, choose Logistics → Environment management → Product safety and then Reports → Report info system.
   The Report Information System: Initial Screen appears.

2. Enter your search criteria.
   You can use limiting criteria for selecting substances and reports.

   If the R/3 System finds reports that correspond to your search criteria, the report tree appears.
   To enter new search parameters, choose New entry.
   
   If you enter a material as search criteria, the material view of the report tree is displayed. You can also access this by choosing Utilities → Toggle view → Material view.

If you

4. Then choose

   Want to send a report  Report → Send from the material view
   See also: Report Shipping [Page 290]
   After you have sent reports, choose Environment → Report shipping to access report shipping orders directly.

   Want to export a report  Report → Export from the material view
   See also: Exporting Reports [Page 457]

5. As in report management, you can use several additional functions to process selected reports.

   See also: Processing Additional Functions in Report Management [Page 282]
Interfaces

Purpose
You can use this component to exchange data between systems.

Features

Import and Export of Sources, Substances, Phrases, Properties Trees and Report Templates
The R/3 component Product Safety supports first database as well as data import and export in productive systems. This means that you can transfer data between different systems.
You can exchange data between

- two R/3 Systems
- an R/3 System and an external system.

You can export phrases in the original language, translate them in an external system, and then import them to the R/3 System.

You use exchange profiles to define the transfer parameters used to control data exchange.

You can use phrase references in the legally valid phrase library to adapt your current R/3 phrase library that you use for substance characteristic value assignment so that the exported substance characteristic values correspond to the legal requirements of the EU.

In substance import, the R/3 System enables you to import passive phrases used as substance characteristic values to the active phrase library.

You use R/3 Engineering Change Management to import phrases.

Importing and Exporting Reports
Report import in the R/3 component Product Safety enables you to import inbound reports (Inbound Documents (IBD) [Page 218]) to the R/3 System.

You can also export scanned reports and reports from the R/3 component Product Safety as Dok-X format.

See also:
Section Purpose in Importing Reports: Process [Page 442] and Exporting Reports: Process [Page 457]

Dangerous goods interfaces
You can use the filling function from the R/3 component Dangerous Goods Interfaces [Ext.] to copy dangerous goods classification data to the dangerous goods master.
Relevant data can be copied for the warehouse management system in Customizing by choosing *Logistics Execution* → *Warehouse Management* → *Hazardous materials* → *Copy hazardous material data from substance database.*
Import and Export: Process

**Purpose**

See also: Interfaces [Page 346]

Data import enables you to transfer data between different systems in conjunction with data export. You can import or export the following data:

- Sources
- Phrases
- Substances (including dangerous goods data)
- Properties trees
- Report templates
- Reports (inbound documents)

**Import**

More informations


Importing Reports: Process [Page 442]

**Export**

More informations


Exporting Reports: Process [Page 457]

**Process flow**

1. For the import, copy the transfer file that you have generated yourself or by exporting the data, to a directory on your PC.
2. You upload the transfer file from your PC directory to the application server.
3. You import the transfer file from the application server to the R/3 component Product Safety.

4. For the export, you first select the respective data that you want to export from the R/3 component Product Safety and then you start the export to the application server from the component to a file.

5. You download the exchange file from the application server to your PC directory.
Export: Process

Purpose
This process describes the import of sources, phrases, substances, properties trees and report templates.

Prerequisites

In R/3

- In Customizing for Product Safety, you must specify the settings in the Interfaces section.
- You must have the required authorizations and the corresponding write authorization.

In an external environment
The transfer file must be in ASCII format, in ISO Latin 1. The system in which the data originates (external environment), must be able to make the data available correspondingly. The external environment can also be an R/3 System.

- Importing data from a non-R/3 System
  To create the transfer file for importing data from a non-R/3 external system, proceed as follows:
  Determine the relevant table fields for each transfer file.
  Procedure
  Identifying Relevant Fields [Page 352]
  You write the transfer file with regard to the following guidelines:
  Procedure
  Specifying the Sequence of the External Data Structure [Page 387]
  See also:
  - Abbreviations and Syntax Rules [Page 393]
  - Structure of Programming Lines [Page 396]

- Importing data from a R/3 System
  To exchange data between two R/3 Systems, you must first export the data. The R/3 System then creates the transfer file automatically. You can use this file to import the data.

Process flow

1. Copy the transfer file that you have generated yourself or by exporting the data, to a directory on your PC.
2. To copy the transfer file from your PC directory to the application server, choose Data transfer → Upload file from the Product Safety [Ext.] screen.

To avoid problems with carriage return and carriage linefeed, please ensure that your operating system can read the file format correctly.

3. The data is imported for each transfer file in turn. Proceed as follows:
   a) Carry out File check (pre-import). If the R/3 System finds errors, you can use the Download file function to load the transfer file to a directory on your PC, correct them in a ASCII editor and then upload them again.
   b) Carry out data import. This runs as a background job.

More information                   Procedure
Importing Phrases [Page 419]       Importing Phrases [Page 422]
Source Import [Page 416]           Importing Sources [Page 417]
Importing Substances [Page 424]    Importing Substances [Page 433]
Identifying Relevant Fields

Prerequisites

The transfer file must be stored on a computer that can be accessed with Remote Function Call (RFC).

- You must create a path for the transfer file in the external environment. This path may not have more than 40 characters.

- File size is unrestricted. However, for performance reasons, it should not be more than 10 megabytes.

- The transfer file must be a sequential ASCII file. We currently support ISO 8859-1 (ISO Latin 1).

Procedure

1. Choose your required table assignment.
   - Table Assignment: Phrases [Page 354]
   - Table Assignment: Sources [Page 359]
   - Table Assignment: Substances [Page 360]
   - Table Assignment: Properties Tree [Page 377]
   - Table Assignment: Report Template [Page 383]

   You can call the individual tables in the R/3 System and compare the table fields. To do this, choose from the SAP R/3 System screen Tools → ABAP Workbench, then Overview → Data Browser, and enter the name of the table in the Table name field. After you have chosen ENTER, the system displays the requested table.

2. Specify the table fields to which you want to transfer the external data.

   - Observe the status and type entries for the table fields:
     
     Status M = Required field
     Status K = Optional field
     Status C = The data in the table field are checked against a permitted quantity of values during import.

   - The following table fields occur in several tables. These fields are grouped under ADMIN:

     **“.ADMIN” fields**

     | Table field | Status | Type | Comment |
     |-------------|--------|------|---------|

352 April 2001
Identifying Relevant Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CRDAT</td>
<td>K DATS8</td>
<td>Date of creation</td>
</tr>
<tr>
<td>CRNAM</td>
<td>K CHAR12</td>
<td>Created by</td>
</tr>
<tr>
<td>UPDDAT</td>
<td>K DATS8</td>
<td>Date of last change</td>
</tr>
<tr>
<td>UPDNAM</td>
<td>K CHAR12</td>
<td>Name of the last person to change the data</td>
</tr>
<tr>
<td>OWNID</td>
<td>K CHAR10</td>
<td>Key of data owner</td>
</tr>
</tbody>
</table>

- If the CRDAT, CRNAM, UPDDAT, UPDNAM fields are not delivered with the import, the R/3 System enters the current date and importer.
- Enter a unique ID and name in the substance transfer file for each data provider. The data provider ID for the transfer file need not correspond to the data owner/provider ID in the R/3 System. To assign the correct data owner/provider ID in the R/3 System, the R/3 System compares the data provider names in the transfer file with the addresses of the existing data owners/providers in the R/3 System, and replaces the imported data provider IDs with the data owner/provider IDs in the R/3 System.

⚠️

When importing substances, there is a risk that phrases are imported that are used as values for characteristics but do not exist in the R/3 component Product Safety. To ensure that you do not lose this data, you can enter these phrase texts as characteristic-dependent user-defined texts for the relevant characteristics in the transfer file. You assign a value to the characteristic itself, for example, with the phrase See user-defined text.

Characteristics to which you want to assign characteristic-dependent user-defined texts must fulfil certain requirements (see User-Defined Texts [Page 44]).
**Table Assignment: Phrases**

Assign your data in the following order:

<table>
<thead>
<tr>
<th>Phrases</th>
<th>Table names</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>TCG62 (language-dependent label for phrase library)</td>
</tr>
<tr>
<td>2. Phrase Group Data [Page 356]</td>
<td>TCG63 (phrase group)</td>
</tr>
<tr>
<td></td>
<td>TCG64 (language-dependent label for phrase group)</td>
</tr>
<tr>
<td>3. Further Phrase Data [Page 357]</td>
<td>ESTPH (phrase header)</td>
</tr>
<tr>
<td></td>
<td>ESTPP (phrase item)</td>
</tr>
<tr>
<td></td>
<td>ESTPO (original phrase)</td>
</tr>
<tr>
<td></td>
<td>ESTPJ (phrase header - phrase set assignment)</td>
</tr>
</tbody>
</table>
# Data for the Phrase Library

Table name: TCG61 (phrase library)

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>CATPIN</td>
<td>M</td>
<td>CHAR5</td>
<td>World-wide unique phrase library ID</td>
</tr>
<tr>
<td>CATDIST</td>
<td>M</td>
<td>CHAR40</td>
<td>Distributor</td>
</tr>
<tr>
<td>CATDATE</td>
<td>M</td>
<td>DATS8</td>
<td>Publication date</td>
</tr>
<tr>
<td>CATVERS</td>
<td>M</td>
<td>CHAR10</td>
<td>Version number</td>
</tr>
<tr>
<td>CHECKF</td>
<td>K</td>
<td>CHAR30</td>
<td>Name of check function</td>
</tr>
<tr>
<td>NUMRNGE</td>
<td>K</td>
<td>CHAR30</td>
<td>Number range for phrase key</td>
</tr>
<tr>
<td>REM</td>
<td>K</td>
<td>CHAR60</td>
<td>Additional language-independent remarks</td>
</tr>
</tbody>
</table>

Table name: TCG62 (language-dependent label for phrase library)

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGU</td>
<td>M C</td>
<td>LANG1</td>
<td>Language key</td>
</tr>
<tr>
<td>CATNAM</td>
<td>M</td>
<td>CHAR40</td>
<td>Language-dependent label for phrase library</td>
</tr>
</tbody>
</table>
## Phrase Group Data

### Table name: TCG63 (phrase group)

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>PHRGRP</td>
<td>M</td>
<td>CHAR10</td>
<td>Phrase group</td>
</tr>
<tr>
<td>REM</td>
<td>K</td>
<td>CHAR60</td>
<td>Additional language-independent remarks</td>
</tr>
</tbody>
</table>

### Table name: TCG64 (language-dependent label for phrase group)

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGU</td>
<td>M, C</td>
<td>LANG1</td>
<td>Language key</td>
</tr>
<tr>
<td>PHRGNAM</td>
<td>M</td>
<td>CHAR40</td>
<td>Language-dependent label for phrase group</td>
</tr>
</tbody>
</table>
Further Phrase Data

Table name: ESTPH (phrase header)

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>PHRID</td>
<td>M</td>
<td>CHAR15</td>
<td>Unique ID for a phrase header</td>
</tr>
<tr>
<td>REM</td>
<td>K</td>
<td>CHAR60</td>
<td>Additional language-independent administrative comment</td>
</tr>
<tr>
<td>SRLANGU</td>
<td>K C</td>
<td>LANG1</td>
<td>Source language for the phrase (relevant for translation)</td>
</tr>
</tbody>
</table>

Remarks:
- The combination PHRID/CATPIN need not exist in the system.
- CATPIN must exist.

Table name: ESTPP (phrase item)

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>LANGU</td>
<td>M C</td>
<td>LANG1</td>
<td>Language key</td>
</tr>
<tr>
<td>PHRCODE</td>
<td>K</td>
<td>CHAR20</td>
<td>Phrase code</td>
</tr>
<tr>
<td>PHRTEXT</td>
<td>K</td>
<td>CHAR5000</td>
<td>Phrase text</td>
</tr>
<tr>
<td>REM</td>
<td>K</td>
<td>CHAR60</td>
<td>Remark</td>
</tr>
<tr>
<td>PHRGRAPH</td>
<td>K</td>
<td>CHAR30</td>
<td>File name for a graphic</td>
</tr>
</tbody>
</table>

Table name ESTPO (original phrase)

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>PHROFLG</td>
<td>K</td>
<td>CHAR1</td>
<td>Indicator for phrase text transfer</td>
</tr>
<tr>
<td>PHRID</td>
<td>M</td>
<td>CHAR15</td>
<td>Unique ID for a phrase header</td>
</tr>
<tr>
<td>CATPIN</td>
<td>M C</td>
<td>CHAR5</td>
<td>World-wide unique phrase library ID</td>
</tr>
</tbody>
</table>

Remarks:
- The combination PHRID/CATPIN need not exist in the system.
- CATPIN must exist.
Further Phrase Data

<table>
<thead>
<tr>
<th>.ADMIN</th>
<th>PHRSEL</th>
<th>PHRID</th>
<th>ORD</th>
<th>See also: Identifying Relevant Fields [Page 352]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>M</td>
<td>CHAR10</td>
<td>K</td>
<td>Phrase set</td>
</tr>
<tr>
<td></td>
<td>M</td>
<td>CHAR15</td>
<td></td>
<td>Unique ID for a phrase header</td>
</tr>
<tr>
<td></td>
<td></td>
<td>INT4</td>
<td></td>
<td>Sort sequence (printout)</td>
</tr>
</tbody>
</table>
# Table Assignment: Sources

Table name: TCG46 (sources)

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>SRCID</td>
<td>M</td>
<td>CHAR10</td>
<td>Unique ID for a source</td>
</tr>
<tr>
<td>SRCNAM</td>
<td>M</td>
<td>CHAR40</td>
<td>Description of source</td>
</tr>
<tr>
<td>SRCAUTH</td>
<td>K</td>
<td>CHAR40</td>
<td>Source author</td>
</tr>
<tr>
<td>REM</td>
<td>K</td>
<td>CHAR60</td>
<td>Additional remarks</td>
</tr>
<tr>
<td>SRCCAT</td>
<td>K</td>
<td>CHAR10</td>
<td>Source category</td>
</tr>
<tr>
<td>SRCYEAR</td>
<td>K</td>
<td>NUMC</td>
<td>Publication year of source</td>
</tr>
<tr>
<td>SRCORDN</td>
<td>K</td>
<td>CHAR30</td>
<td>Source order number</td>
</tr>
</tbody>
</table>
Table Assignment: Substances

Assign your data in the following order:

<table>
<thead>
<tr>
<th>Substances</th>
<th>Table names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Substance Header Data [Page 361]</td>
<td>ESTRH</td>
</tr>
<tr>
<td>2. Substance Identification [Page 362]</td>
<td>ESTRI</td>
</tr>
<tr>
<td>3. Additional Information for Substance Identifier - Substance List Assignment [Page 363]</td>
<td>ESTRL</td>
</tr>
<tr>
<td>4. Substance References [Page 364]</td>
<td>ESTRRR</td>
</tr>
<tr>
<td>7. Substance Characteristic Values [Page 367]</td>
<td>ESTVA</td>
</tr>
<tr>
<td>8. Additional Information for Substance Characteristic Assessment [Page 368]</td>
<td>ESTDR</td>
</tr>
<tr>
<td>10. Additional Information for Substance Characteristic Sources [Page 370]</td>
<td>ESTDS</td>
</tr>
<tr>
<td>11. Additional Information for Substance Characteristic Texts [Page 371]</td>
<td>ESTDF</td>
</tr>
<tr>
<td>13. Transport Approval [Page 373]</td>
<td>EST07</td>
</tr>
<tr>
<td>14. Risk Classification [Page 375]</td>
<td>EST0B</td>
</tr>
<tr>
<td>15. Risk Classification [Page 375]</td>
<td>EST0D</td>
</tr>
<tr>
<td>16. Transport Classification [Page 376]</td>
<td>EST0F</td>
</tr>
</tbody>
</table>
Substance Header Data

Table name: ESTRH

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
<td></td>
</tr>
<tr>
<td>SUBID</td>
<td>M</td>
<td>CHAR12</td>
<td>Unique ID for a substance</td>
</tr>
<tr>
<td>SUBCAT</td>
<td>K C</td>
<td>CHAR10</td>
<td>Substance category</td>
</tr>
<tr>
<td>AUTHGRP</td>
<td>K C</td>
<td>CHAR10</td>
<td>Substance authorization object</td>
</tr>
<tr>
<td>REM</td>
<td>K</td>
<td>CHAR60</td>
<td>Additional language-independent remarks</td>
</tr>
<tr>
<td>SUBCHAR</td>
<td>M</td>
<td>CHAR10</td>
<td>Substance character</td>
</tr>
</tbody>
</table>

Remarks:

If a substance already exists in the R/3 System, the header substance data are normally not changed.

- **SUBID**: Transfer if the substance is created.
- **SUBCAT**: Transfer if the substance is created. If it is not delivered in the transfer file, and the substance is created, the value entered under Parameters is taken. You can choose the Parameters function from the screen for the first database substance master.
- **AUTHGRP**: Transfer if the substance is created. If it is not delivered in the transfer file, and the substance is created, the value entered under Parameters is taken in the First Database Substance Master Parameters screen.
- **REM**: Transfer if the substance is created. Otherwise, REM is ignored.
## Substance Identification

Table name: ESTRI

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>IDTYPE</td>
<td>M C</td>
<td>CHAR10</td>
<td>Identification type</td>
</tr>
<tr>
<td>IDCAT</td>
<td>M C</td>
<td>CHAR10</td>
<td>Identification category</td>
</tr>
<tr>
<td>LANGU</td>
<td>K C</td>
<td>LANG1</td>
<td>Language key</td>
</tr>
<tr>
<td>IDENT</td>
<td>M</td>
<td>CHAR5000</td>
<td>Identifier</td>
</tr>
<tr>
<td>ORD</td>
<td>K</td>
<td>INT4</td>
<td>Sort sequence (within the category)</td>
</tr>
</tbody>
</table>
**Additional Information for Substance Identifier - Substance List Allocation**

Table name: ESTRL

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>SLSTID</td>
<td>M C</td>
<td>CHAR10</td>
<td>Substance list</td>
</tr>
</tbody>
</table>
# Substance References

Table name: ESTRR

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td><strong>See also:</strong> <a href="#">Identifying Relevant Fields</a> [Page 352]</td>
</tr>
<tr>
<td>SUBIDREF</td>
<td>M</td>
<td>CHAR12</td>
<td>Unique ID for reference substance</td>
</tr>
</tbody>
</table>

Remarks:

- SUBIDREF: Transfer if the substance is created. Otherwise, SUBIDREF is ignored.
## Additional Information for Identifiers

Table name: ESTRI

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ADMIN</td>
<td></td>
<td></td>
<td><strong>See also:</strong> Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>IDTYPE</td>
<td>M C</td>
<td>CHAR10</td>
<td>Identification type</td>
</tr>
<tr>
<td>IDCAT</td>
<td>M C</td>
<td>CHAR10</td>
<td>Identification category</td>
</tr>
<tr>
<td>LANGU</td>
<td>K C</td>
<td>LANG1</td>
<td>Language key</td>
</tr>
<tr>
<td>IDENT</td>
<td>M</td>
<td>CHAR132</td>
<td>Identifier</td>
</tr>
<tr>
<td>ORD</td>
<td>K</td>
<td>INT4</td>
<td>Sort sequence (within the category)</td>
</tr>
</tbody>
</table>
# Substance - Material Assignment

Table name: ESTMJ

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td><strong>See also:</strong> Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>WERKS</td>
<td>K C</td>
<td>CHAR4</td>
<td>Plant</td>
</tr>
<tr>
<td>MATNR</td>
<td>M C</td>
<td>CHAR18</td>
<td>Material number</td>
</tr>
</tbody>
</table>
Substance Characteristic Values

Table name: ESTVA

Characteristic categories should be defined in the R/3 Classification System.

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>$ESTVA-.ADMIN</td>
<td></td>
<td></td>
<td>See also: [Identifying Relevant Fields][Page 352]</td>
</tr>
<tr>
<td>$ESTVA-ORD</td>
<td>K</td>
<td>INT4</td>
<td>Sort sequence (for example, for a printout of a Tox-Label)</td>
</tr>
<tr>
<td>$ESTVA-COMPREL</td>
<td>M</td>
<td>CHAR10</td>
<td>Reference quantity or volume (w/w, vol/vol)</td>
</tr>
<tr>
<td>Characteristic 1</td>
<td>??</td>
<td>??</td>
<td>To be defined in the Classification System</td>
</tr>
<tr>
<td>Characteristic n</td>
<td>??</td>
<td>??</td>
<td>To be defined in the Classification System</td>
</tr>
</tbody>
</table>

Remarks:

$ESTVA-COMPREL permitted only when assigning values of type “composition”
Additional Information for Substance Characteristic Assessment

Table name: ESTDR

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>_ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>RELID</td>
<td>M C</td>
<td>CHAR10</td>
<td>Characteristic assessment</td>
</tr>
</tbody>
</table>

Remarks:
If the additional information for a characteristic value is not delivered with the transfer file, the characteristic assessment is set to 0 (not assessed).
Additional Information for Substance Characteristic Usage

Table name: ESTDU

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td><strong>See also:</strong> Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>VACLID</td>
<td>M C</td>
<td>CHAR10</td>
<td>Characteristic rating</td>
</tr>
<tr>
<td>RVLID</td>
<td>M C</td>
<td>CHAR10</td>
<td>Validity area</td>
</tr>
<tr>
<td>EXCLFLG</td>
<td>K</td>
<td>CHAR 1</td>
<td>Indicator specifying if a validity area is an exclusion area</td>
</tr>
<tr>
<td>ACTVFLG</td>
<td>K</td>
<td>CHAR1</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Indicator specifying if the validity area rating is active</td>
</tr>
<tr>
<td>ESNTFLG</td>
<td>K</td>
<td>CHAR1</td>
<td>Indicator specifying if change was relevant</td>
</tr>
</tbody>
</table>

Remarks:

- **EXCLFLG** If not delivered in the transfer file, the indicator is not set (no exclusion area).
- **ACTVFLG** If not delivered in the transfer file, the indicator is set (validity area rating is active).
- **ESNTFLG** If not delivered in the transfer file, the indicator is not set (change not relevant).

If the additional information for a characteristic value is not delivered in the transfer file, the default values set in Customizing are set for the creation of characteristic categories.
Additional Information for Substance Characteristic Sources

Table name: ESTDS

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>SRCID</td>
<td>M C</td>
<td>CHAR10</td>
<td>Unique ID for a source</td>
</tr>
<tr>
<td>SRCTEXT</td>
<td>K</td>
<td>CHAR40</td>
<td>Additional notes on source (language-independent)</td>
</tr>
</tbody>
</table>
Additional Information for Substance Characteristic Texts

Table name: ESTDF

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>TEXTCAT</td>
<td>M</td>
<td>CHAR10</td>
<td>Characteristic text category</td>
</tr>
<tr>
<td>ORD</td>
<td>K</td>
<td>INT4</td>
<td>Sort sequence (for printouts)</td>
</tr>
<tr>
<td>LANGU</td>
<td>K</td>
<td>LANG1</td>
<td>Language key</td>
</tr>
<tr>
<td>TEXT</td>
<td>M</td>
<td>CHAR5000</td>
<td>User-defined texts</td>
</tr>
</tbody>
</table>

Remarks:
- LANGU: If not delivered in the transfer file, key is set to ‘relevant for all languages’.
Additional Information for Substance Characteristic Items

Table name: ESTVP

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>SUBIDREF</td>
<td>M/K</td>
<td>CHAR12</td>
<td>Unique substance ID</td>
</tr>
<tr>
<td>COMPCAT</td>
<td>M C</td>
<td>CHAR20</td>
<td>Component category</td>
</tr>
<tr>
<td>PRECL</td>
<td>K</td>
<td>CHAR5</td>
<td>Accuracy lower limit (&lt;, &lt;=, &gt;, &gt;=)</td>
</tr>
<tr>
<td>COMPLOW</td>
<td>K</td>
<td>NUMC4</td>
<td>Lower limit</td>
</tr>
<tr>
<td>PRECU</td>
<td>K</td>
<td>CHAR5</td>
<td>Accuracy upper limit (&lt;, &lt;=, &gt;, &gt;=)</td>
</tr>
<tr>
<td>COMPUPP</td>
<td>K</td>
<td>NUMC4</td>
<td>Upper limit</td>
</tr>
<tr>
<td>COMPAVG</td>
<td>K</td>
<td>NUMC4</td>
<td>Average proportion</td>
</tr>
<tr>
<td>COMPEXP</td>
<td>M/K</td>
<td>CHAR10</td>
<td>Exponent for component (% , ppm)</td>
</tr>
</tbody>
</table>

Remarks:

SUBIDREF Transfer if the substance is created. Otherwise, SIBIDREF is ignored. The field may not be displayed if the additional information for “identifiers” is not delivered for a component.

COMEXP May not be displayed if none of the three values for lower limit, upper limit, and average proportion has been entered.

‘SUBIDREF’ is the only field permitted for the substance characteristic item for a substance listing.
## Transport Approval

### Table EST07

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ADMIN</td>
<td></td>
<td></td>
<td><strong>See also:</strong> [Identifying Relevant Fields](Page 352)</td>
</tr>
<tr>
<td>DPOT</td>
<td>MC</td>
<td>CHAR10</td>
<td>Risk potential</td>
</tr>
<tr>
<td>MOS</td>
<td>MC</td>
<td>NUMC3</td>
<td>Dangerous goods transport category</td>
</tr>
<tr>
<td>ADMOS</td>
<td>MC</td>
<td>CHAR1</td>
<td>Transport approved</td>
</tr>
</tbody>
</table>
## Packaging Code Approval

### Table EST0B

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td></td>
<td></td>
<td>See also: [Identifying Relevant Fields](Page 352)</td>
</tr>
<tr>
<td>DPOT</td>
<td>MC</td>
<td>CHAR</td>
<td>10 Risk potential</td>
</tr>
<tr>
<td>PACOD</td>
<td>MC</td>
<td>CHAR</td>
<td>5 Packaging code</td>
</tr>
<tr>
<td>PERIP</td>
<td>KC</td>
<td>CHAR</td>
<td>1 Permissibility of inner packaging</td>
</tr>
<tr>
<td>IPMQU</td>
<td>K</td>
<td>QUAN</td>
<td>8 Inner packaging: max. quantity / volume</td>
</tr>
<tr>
<td>UIPMQ</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measure for inner packaging: max. quantity / volume</td>
</tr>
<tr>
<td>PEROP</td>
<td>KC</td>
<td>CHAR</td>
<td>1 Approval of outer package</td>
</tr>
<tr>
<td>OPMQU</td>
<td>K</td>
<td>QUAN</td>
<td>8 Outer package: max. quantity / volume</td>
</tr>
<tr>
<td>UOPMQ</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit for maximum quantity / volume of outer package</td>
</tr>
<tr>
<td>TOGWE</td>
<td>K</td>
<td>QUAN</td>
<td>8 Packaging gross weight</td>
</tr>
<tr>
<td>UTOGW</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit for packaging gross weight</td>
</tr>
<tr>
<td>PERSP</td>
<td>KC</td>
<td>CHAR</td>
<td>1 Permissibility of single packaging</td>
</tr>
<tr>
<td>SPAQU</td>
<td>K</td>
<td>QUAN</td>
<td>8 Single packaging: max. quantity / volume</td>
</tr>
<tr>
<td>USPAQ</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit for single packaging: max. quantity / volume</td>
</tr>
<tr>
<td>EERIP</td>
<td>KC</td>
<td>CHAR</td>
<td>1 Permissibility of inner packaging (for limited quantities)</td>
</tr>
<tr>
<td>EIPA</td>
<td>K</td>
<td>QUAN</td>
<td>8 Maximum inner packaging - limited quantity (qty/volume)</td>
</tr>
<tr>
<td>UEIPA</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measurement (limited quantity max. inner packaging)</td>
</tr>
<tr>
<td>EEROP</td>
<td>KC</td>
<td>CHAR</td>
<td>1 For limited quantities: max. outer package (limited qty)</td>
</tr>
<tr>
<td>EOPA</td>
<td>K</td>
<td>QUAN</td>
<td>8 Maximum outer package limited quantity (quantity/volume)</td>
</tr>
<tr>
<td>UEOPA</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measurement (ltd. quantity max. outer package)</td>
</tr>
<tr>
<td>EGWE</td>
<td>K</td>
<td>QUAN</td>
<td>8 Packaging gross weight limited quantity (mass)</td>
</tr>
<tr>
<td>UEGWE</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measurement (ltd. quantity packaging gross weight)</td>
</tr>
<tr>
<td>EERSP</td>
<td>KC</td>
<td>CHAR</td>
<td>1 Permissibility of single packaging (limited quantities)</td>
</tr>
<tr>
<td>ESPA</td>
<td>K</td>
<td>QUAN</td>
<td>8 Max. single packaging limited quantity (quantity/volume)</td>
</tr>
<tr>
<td>UESPA</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measurement (ltd. quantity max. single packaging)</td>
</tr>
<tr>
<td>IPALL</td>
<td>KC</td>
<td>CHAR</td>
<td>1 Indicator pallet / skeleton container</td>
</tr>
<tr>
<td>AGAUN</td>
<td>KC</td>
<td>CHAR</td>
<td>1 Agreement of authorities required</td>
</tr>
</tbody>
</table>
# Risk Classification

## Table EST0D

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ADMIN</td>
<td></td>
<td></td>
<td><strong>See also:</strong> Identifying Relevant Fields [Page 352].</td>
</tr>
<tr>
<td>DPOT</td>
<td>MC</td>
<td>CHAR</td>
<td>10 Risk potential</td>
</tr>
<tr>
<td>HNU</td>
<td>KC</td>
<td>CHAR</td>
<td>4 Hazard identification number</td>
</tr>
<tr>
<td>RELQ</td>
<td>K</td>
<td>QUAN</td>
<td>8 Quantity limit (ma. 10011)</td>
</tr>
<tr>
<td>RELU</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measure quantity unit (ma. 10011)</td>
</tr>
<tr>
<td>MULRQ</td>
<td>K</td>
<td>NUMC</td>
<td>4 Multiplication factor quantity limit (ma. 10011)</td>
</tr>
<tr>
<td>PIN</td>
<td>K</td>
<td>CHAR</td>
<td>25 Packing Instruction Number</td>
</tr>
<tr>
<td>PINLQ</td>
<td>K</td>
<td>CHAR</td>
<td>25 Packing Instruction Number for Limited Quantities</td>
</tr>
<tr>
<td>DGTA</td>
<td>KC</td>
<td>CHAR</td>
<td>1 Transport permitted</td>
</tr>
<tr>
<td>SPPRO</td>
<td>K</td>
<td>CHAR</td>
<td>5 Special provision</td>
</tr>
<tr>
<td>PAI</td>
<td>K</td>
<td>QUAN</td>
<td>8 Quantity a-marginals inner packaging</td>
</tr>
<tr>
<td>PAIU</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measurement (a-marginal)</td>
</tr>
<tr>
<td>PAO</td>
<td>K</td>
<td>QUAN</td>
<td>8 Quantity a-marginal outer package</td>
</tr>
<tr>
<td>PAOU</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measurement (a-marginal)</td>
</tr>
<tr>
<td>PASI</td>
<td>K</td>
<td>QUAN</td>
<td>8 A-ma. single packaging (quantity/volume)</td>
</tr>
<tr>
<td>UPASI</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measurement (a-marginal)</td>
</tr>
<tr>
<td>PAGW</td>
<td>K</td>
<td>QUAN</td>
<td>8 A-ma. gross weight (quantity)</td>
</tr>
<tr>
<td>UPAIW</td>
<td>K</td>
<td>UNIT</td>
<td>3 Unit of measurement (a-marginal)</td>
</tr>
</tbody>
</table>
## Transport Classification

### Table EST0F

<table>
<thead>
<tr>
<th>Table field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ADMIN</td>
<td></td>
<td></td>
<td>See also: Identifying Relevant Fields [Page 352]</td>
</tr>
<tr>
<td>SUBIDREF</td>
<td>M/K</td>
<td>CHAR</td>
<td>12 Unique substance ID</td>
</tr>
<tr>
<td>LWDG</td>
<td>MC</td>
<td>CHAR</td>
<td>12 Dangerous goods regulation</td>
</tr>
<tr>
<td>DPOT</td>
<td>KC</td>
<td>CHAR</td>
<td>10 Risk potential</td>
</tr>
<tr>
<td>WOS</td>
<td>KC</td>
<td>CHAR</td>
<td>2 Processing status of DG basic data</td>
</tr>
</tbody>
</table>
Table Assignment: Properties Tree

Assign your data in the following order:

<table>
<thead>
<tr>
<th>Properties tree</th>
<th>Table names</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Properties Tree [Page 378]</td>
<td>TCG51</td>
</tr>
<tr>
<td></td>
<td>TCG52</td>
</tr>
<tr>
<td></td>
<td>TCG53</td>
</tr>
<tr>
<td>2. Substance Characteristic Values [Page 379]</td>
<td>TCG11</td>
</tr>
<tr>
<td></td>
<td>TCG12</td>
</tr>
<tr>
<td>3. Class [Page 380]</td>
<td>CLCLASSES</td>
</tr>
<tr>
<td></td>
<td>CLA_DESCR</td>
</tr>
<tr>
<td></td>
<td>CLA_CH_ATR</td>
</tr>
<tr>
<td></td>
<td>CLA_LNGTXT</td>
</tr>
<tr>
<td></td>
<td>CABNT</td>
</tr>
<tr>
<td></td>
<td>CAWN</td>
</tr>
<tr>
<td></td>
<td>CAWNT</td>
</tr>
<tr>
<td>5. Phrase Sets [Page 382]</td>
<td>ESTPS</td>
</tr>
<tr>
<td></td>
<td>ESTPT</td>
</tr>
<tr>
<td></td>
<td>TCG66</td>
</tr>
</tbody>
</table>
## Properties Tree

### Table name: TCG51

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>MENID</td>
<td>M</td>
<td>CHAR 10</td>
<td>Properties tree key</td>
</tr>
</tbody>
</table>

### Table name: TCG52

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGU</td>
<td>M</td>
<td>LANG 1</td>
<td>Language key</td>
</tr>
<tr>
<td>MENNAM</td>
<td>M</td>
<td>CHAR 40</td>
<td>Description of the properties tree</td>
</tr>
</tbody>
</table>

### Table name: TCG53

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>M</td>
<td>NUMC 6</td>
<td>Node ID in the tree</td>
</tr>
<tr>
<td>ESTCAT</td>
<td>M</td>
<td>CHAR 30</td>
<td>Substance characteristic category - key</td>
</tr>
<tr>
<td>PARENT</td>
<td>M</td>
<td>NUMC 6</td>
<td>ID parent node</td>
</tr>
<tr>
<td>COMPR</td>
<td>K</td>
<td>CHAR 1</td>
<td>Indicator: compress nodes</td>
</tr>
</tbody>
</table>
## Substance Characteristic Values

**Table name: TCG11**

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESTCAT</td>
<td>M</td>
<td>CHAR 30</td>
<td>Substance characteristic category</td>
</tr>
<tr>
<td>ESTTYPE</td>
<td>K</td>
<td>CHAR 10</td>
<td>Substance characteristic type</td>
</tr>
<tr>
<td>REM</td>
<td>K</td>
<td>CHAR 60</td>
<td>Remark/comment</td>
</tr>
<tr>
<td>CLVANAM</td>
<td>M</td>
<td>CHAR 18</td>
<td>Class name for characteristic value</td>
</tr>
<tr>
<td>CLVPNAM</td>
<td>K</td>
<td>CHAR 18</td>
<td>Class name for composition</td>
</tr>
<tr>
<td>ECCOFLG</td>
<td>K</td>
<td>CHAR 1</td>
<td>Indicator: set copied substance characteristic values to active</td>
</tr>
<tr>
<td>ECINFLG</td>
<td>K</td>
<td>CHAR 1</td>
<td>Indicator: set new substance characteristic values to active</td>
</tr>
<tr>
<td>ECUPFLG</td>
<td>K</td>
<td>CHAR 1</td>
<td>Indicator: set changed substance characteristic values to active</td>
</tr>
<tr>
<td>USEPROF</td>
<td>K</td>
<td>CHAR 10</td>
<td>Default usage profile (contains validity area + rating)</td>
</tr>
<tr>
<td>IDLID</td>
<td>K</td>
<td>CHAR 10</td>
<td>Identification display</td>
</tr>
</tbody>
</table>

**Table name: TCG12**

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGU</td>
<td>M</td>
<td>LANG 1</td>
<td>Language key</td>
</tr>
<tr>
<td>ESTNAM</td>
<td>M</td>
<td>CHAR 40</td>
<td>Label for substance characteristic category</td>
</tr>
</tbody>
</table>
Class

Table name: KLAH (structure name CLCLASSSES)

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLASS</td>
<td>M</td>
<td>CHAR 18</td>
<td>Class name</td>
</tr>
<tr>
<td>CLASS_TYPE</td>
<td>M</td>
<td>CHAR 3</td>
<td>Class type</td>
</tr>
</tbody>
</table>

Table name: SWOR (structure name CLA_DESCR)

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGUAGE</td>
<td>M</td>
<td>LANG 1</td>
<td>Language key</td>
</tr>
<tr>
<td>CATCHWORD</td>
<td>M</td>
<td>CHAR 40</td>
<td>Catchword, 1. Catchword=label</td>
</tr>
</tbody>
</table>

Table name: KSML (structure name CLA_CH_ATR)

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHARACT</td>
<td>M</td>
<td>CHAR 30</td>
<td>Allocated characteristic</td>
</tr>
</tbody>
</table>

Table name: KLAT (structure name CLA_LNGTXT)

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGUAGE</td>
<td>M</td>
<td>LANG 1</td>
<td>Language key</td>
</tr>
<tr>
<td>TXT_ART</td>
<td>M</td>
<td>CHAR 1</td>
<td>Text ID / text category</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>0=long text</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1=standard description</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2=standard title</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>The long text is used as F1 help.</td>
</tr>
<tr>
<td>TXT_DESCR</td>
<td>K</td>
<td>CHAR 40</td>
<td>Short description of the long text</td>
</tr>
<tr>
<td>TXT_FORM</td>
<td>K</td>
<td>CHAR 2</td>
<td>Control column / tag column</td>
</tr>
<tr>
<td>TXT_LINE</td>
<td>M</td>
<td>CHAR 72</td>
<td>Text line</td>
</tr>
</tbody>
</table>
Characteristics

Table name: CABN

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATNAM</td>
<td>M</td>
<td>CHAR 30</td>
<td>Characteristic name</td>
</tr>
<tr>
<td>ATFOR</td>
<td>M</td>
<td>CHAR 4</td>
<td>Characteristic data type</td>
</tr>
<tr>
<td>ANZST</td>
<td>M</td>
<td>INT2 5</td>
<td>Number of characters for characteristic values</td>
</tr>
<tr>
<td>ANZDZ</td>
<td>K</td>
<td>INT2 5</td>
<td>Number of decimal places: Def.=0</td>
</tr>
<tr>
<td>MSEHI</td>
<td>K</td>
<td>UNIT 3</td>
<td>Unit of measure</td>
</tr>
<tr>
<td>ATINT</td>
<td>K</td>
<td>CHAR 1</td>
<td>Indicator that specifies if interval values are permitted; def.=N</td>
</tr>
<tr>
<td>ATVOR</td>
<td>K</td>
<td>CHAR 1</td>
<td>Indicator that specifies if negative values are permitted; def.=N</td>
</tr>
<tr>
<td>ATEIN</td>
<td>K</td>
<td>CHAR 1</td>
<td>S=single-value; M=multi-value; def.=S</td>
</tr>
<tr>
<td>ATINP</td>
<td>K</td>
<td>CHAR 1</td>
<td>Indicator: characteristic is ready for input</td>
</tr>
<tr>
<td>ATPRT</td>
<td>K</td>
<td>CHAR 10</td>
<td>Check table</td>
</tr>
<tr>
<td>ATPRF</td>
<td>K</td>
<td>CHAR 30</td>
<td>Function module for value check</td>
</tr>
<tr>
<td>ATDEX</td>
<td>K</td>
<td>NUMC1</td>
<td>Display format for exponents</td>
</tr>
</tbody>
</table>

Table name: CABNT

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPRAS</td>
<td>M</td>
<td>LANG 1</td>
<td>Language key</td>
</tr>
<tr>
<td>ATBEZ</td>
<td>M</td>
<td>CHAR 30</td>
<td>Characteristic description</td>
</tr>
<tr>
<td>ATUE1</td>
<td>K</td>
<td>CHAR 30</td>
<td>First heading on screens</td>
</tr>
</tbody>
</table>

Table name: CAWN

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATWRT</td>
<td>M</td>
<td>CHAR 30</td>
<td>Characteristic values</td>
</tr>
</tbody>
</table>

Table name: CAWNT

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPRAS</td>
<td>M</td>
<td>LANG</td>
<td>Language key</td>
</tr>
<tr>
<td>ATWTB</td>
<td>M</td>
<td>CHAR 30</td>
<td>Description of the characteristic value</td>
</tr>
</tbody>
</table>
## Phrase Sets

### Table name: ESTPS

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>PHRSEL</td>
<td>M</td>
<td>CHAR 30</td>
<td>Phrase set</td>
</tr>
<tr>
<td>REM</td>
<td>K</td>
<td>CHAR 60</td>
<td>Remark</td>
</tr>
</tbody>
</table>

### Table name: ESTPT

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGU</td>
<td>M</td>
<td>LANG 1</td>
<td>Language key</td>
</tr>
<tr>
<td>PHRASNAM</td>
<td>M</td>
<td>CHAR 40</td>
<td>Phrase set description</td>
</tr>
</tbody>
</table>

### Table name: TCG66

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESTCAT</td>
<td>M</td>
<td>CHAR 30</td>
<td>Substance characteristic category</td>
</tr>
<tr>
<td>ATNAM</td>
<td>M</td>
<td>CHAR 30</td>
<td>Characteristic name</td>
</tr>
</tbody>
</table>
Table Assignment: Report Template

Assign your data in the following order:

<table>
<thead>
<tr>
<th>Report template</th>
<th>Table name</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Labels [Page 385]</td>
<td>DRAT</td>
</tr>
<tr>
<td></td>
<td>TCGA7</td>
</tr>
</tbody>
</table>
## Report Template Header

**Table name: DRAW**

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>DOKAR</td>
<td>M</td>
<td>CHAR 3</td>
<td>Document category</td>
</tr>
<tr>
<td>DOKNR</td>
<td>M</td>
<td>CHAR 25</td>
<td>Document number</td>
</tr>
<tr>
<td>DOKVR</td>
<td>M</td>
<td>CHAR 2</td>
<td>Document version</td>
</tr>
</tbody>
</table>
## Labels

Table name: DRAT

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGU</td>
<td>M</td>
<td>LANG 1</td>
<td>Language key</td>
</tr>
<tr>
<td>DKTXT</td>
<td>K</td>
<td>CHAR 40</td>
<td>Description of document (short text)</td>
</tr>
</tbody>
</table>
## Report Symbols

### Table name: TCGA6

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LSYTYPE</td>
<td>M</td>
<td>CHAR 2</td>
<td>Substance report symbol type</td>
</tr>
<tr>
<td>LSYID</td>
<td>M</td>
<td>CHAR 10</td>
<td>Substance report symbol</td>
</tr>
<tr>
<td>CLASS</td>
<td>K</td>
<td>CHAR 18</td>
<td>Class number</td>
</tr>
<tr>
<td>ATNAM</td>
<td>K</td>
<td>CHAR 30</td>
<td>Characteristic name</td>
</tr>
<tr>
<td>TABNAME</td>
<td>K</td>
<td>CHAR 10</td>
<td>Table name</td>
</tr>
<tr>
<td>FIELDNAME</td>
<td>K</td>
<td>CHAR 10</td>
<td>Name of table field</td>
</tr>
</tbody>
</table>

### Table name: TCGA7

<table>
<thead>
<tr>
<th>Field</th>
<th>Status</th>
<th>Type</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>LANGU</td>
<td>M</td>
<td>LANG 1</td>
<td>Language key</td>
</tr>
<tr>
<td>LSYNAM</td>
<td>M</td>
<td>CHAR 40</td>
<td>Description for substance report symbol</td>
</tr>
</tbody>
</table>
Specifying the Sequence of the External Data Structure

1. You enter the administrative section at the start of the external file.

   In a substance file, you enter the phrase library after the administrative section.

2. You obtain the sequence of the following table values from the following graphics:
   - Structure of External File: Phrase Data [Page 388]
   - Structure of External File: Source [Page 389]
   - Structure of External File: Substances [Page 390]
   - Structure of External File: Properties Tree [Page 391]
   - Structure of External File: Report Templates [Page 392]

   - In the graphics, please note the status of the □ fields
     Status M = Table must be entered in file.
     Status K = Table can be entered in file.

   - In addition, please note the number of maximum repetitions (1 or n)

See also:
Example: Transfer File for Phrases [Page 397]
Example: Transfer File for Sources [Page 400]
Example: Transfer File for Substances [Page 402]
Example: Transfer File for a Properties Tree [Page 406]
Example: Transfer File for a Report Template [Page 414]
Structure of External File: Phrase Data

The following graphic displays the structural arrangement of individual tables and their mutual dependencies.
Structure of External File: Source

The following graphic displays the structural arrangement of individual tables and their mutual dependencies.

```
Message source library
M 1

Source TCG 46
M n

Structure label
Status: K = optional
M = mandatory
Max. no. of repeats
```
Structure of External File: Substances

The following graphic displays the structural arrangement of individual tables and their mutual dependencies.
Structure of External File: Properties Tree

The following graphic displays the structural arrangement of individual tables and their mutual dependencies.
Structure of External File: Report Templates

The following graphic displays the structural arrangement of individual tables and their mutual dependencies.

```
<table>
<thead>
<tr>
<th>Messages Report template</th>
</tr>
</thead>
<tbody>
<tr>
<td>M 1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Header</th>
<th>Label</th>
<th>Symbols</th>
</tr>
</thead>
<tbody>
<tr>
<td>M 1</td>
<td>M n</td>
<td>K n</td>
</tr>
</tbody>
</table>
```
Abbreviations and Syntax Rules

You can use the following abbreviations when programming:

- One character corresponds to one column, \(+BC\) corresponds to three columns, for example.
- Blank columns are filled with blanks (\(+BC\) must be followed by three blanks, for example, and then further data is entered from column 7 onwards).

<table>
<thead>
<tr>
<th>Description of line</th>
<th>Column 1-max. 5</th>
<th>From column 7 onwards</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>+C</td>
<td>Up to end of line (column 80)</td>
</tr>
<tr>
<td>Font (ISO-LATIN 1)</td>
<td>+SC</td>
<td>ISO-LATIN 1 (max. 30 characters)</td>
</tr>
<tr>
<td>Identifiers</td>
<td>+ID</td>
<td>Database name, max. 30 characters, IUCLID for example</td>
</tr>
<tr>
<td>Version</td>
<td>+V</td>
<td>Max. 30 characters, 2.22, for example</td>
</tr>
<tr>
<td>Export date</td>
<td>+D</td>
<td>YYYYMMDD, 19970128, for example</td>
</tr>
<tr>
<td>Key date for export</td>
<td>+VD</td>
<td>YYYYMMDD, 19970128, for example</td>
</tr>
<tr>
<td>Set languages for export</td>
<td>+SL</td>
<td>E, for example</td>
</tr>
<tr>
<td>Begin data owner</td>
<td>+BA</td>
<td></td>
</tr>
<tr>
<td>Identifiers</td>
<td>+ID</td>
<td>ID1, for example</td>
</tr>
<tr>
<td>Company name</td>
<td>+NAME</td>
<td>BASF, for example</td>
</tr>
<tr>
<td>City (headquarters)</td>
<td>+CITY</td>
<td>Ludwigshafen, for example</td>
</tr>
<tr>
<td>Country</td>
<td>+CNTY</td>
<td>GB, for example</td>
</tr>
<tr>
<td>End data owner</td>
<td>+EA</td>
<td></td>
</tr>
<tr>
<td>Begin phrase library</td>
<td>+BC</td>
<td>Library type: max. 30 characters</td>
</tr>
<tr>
<td>End phrase library</td>
<td>+EC</td>
<td></td>
</tr>
<tr>
<td>Begin substance</td>
<td>+BS</td>
<td>Official substance name: up to end of line (column 80)</td>
</tr>
<tr>
<td>End substance</td>
<td>+ES</td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table or begin</td>
<td>+BV</td>
<td>$Table name or name of characteristic value (max. 30</td>
</tr>
<tr>
<td>characteristic category</td>
<td></td>
<td>characters)</td>
</tr>
<tr>
<td>End R/3 table or end characteristic category</td>
<td>+EV</td>
<td></td>
</tr>
</tbody>
</table>
Abbreviations and Syntax Rules

<table>
<thead>
<tr>
<th>Begin additional R/3 table</th>
<th>+BAI</th>
<th>$Table name or type of additional information (max. 30 characters)</th>
</tr>
</thead>
<tbody>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>End of File</td>
<td>+EOF</td>
<td></td>
</tr>
</tbody>
</table>

For characteristic categories, the field names are composed of $table name-field name. Example: $ESTVA-UPDDAT

The arrangement of characteristic names and data entries for a substance characteristic line are displayed in diagram: Syntax for a Characteristic Line [Page 395]

See also:

Example: Transfer File for Phrases [Page 397]
Example: Transfer File for Sources [Page 400]
Example: Transfer File for Substances [Page 402]
Example: Transfer File for a Properties Tree [Page 406]
Example: Transfer File for a Report Template [Page 414]
Syntax for a Characteristic Line

The following syntax diagram displays the arrangement of characteristics and data entries in a substance characteristic line.

See also:

Abbreviations and Syntax Rules [Page 393]
Structure of Programming Lines

You must construct the individual programming lines as follows:

One character corresponds to one column, +BC corresponds to three columns, for example

Blank columns are filled with blanks (+BC must be followed by three blanks, for example, and then further data is entered from column 7 onwards).

1. **Structure of lines that begin with an identification code**:

<table>
<thead>
<tr>
<th>Column 1-5</th>
<th>Control identification, “+BV”, for example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 6</td>
<td>Blank</td>
</tr>
<tr>
<td>Column 7-80</td>
<td>Table, “$ESTPH”, for example, or name of a characteristic category</td>
</tr>
</tbody>
</table>

2. **Structure of lines that begin with a field name or characteristic**:

<table>
<thead>
<tr>
<th>Column 1-30</th>
<th>Field name, “TEXT”, for example, characteristic name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 31</td>
<td>Blank</td>
</tr>
<tr>
<td>Column 32-80</td>
<td>Data (value for a characteristic), “First aid notes for”...</td>
</tr>
</tbody>
</table>

3. **Structure of continuation lines**

<table>
<thead>
<tr>
<th>Column 1-2</th>
<th>+*</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 3-6</td>
<td>Blanks</td>
</tr>
<tr>
<td>Column 7-80</td>
<td>continuations of data,...“care of burns and general skin irritations”</td>
</tr>
<tr>
<td>Column 1-2</td>
<td>+*</td>
</tr>
<tr>
<td>Column 3-6</td>
<td>Blanks</td>
</tr>
<tr>
<td>Column 7-80</td>
<td>continuation of data,...“of first degree.”</td>
</tr>
</tbody>
</table>

Continued lines are joined together without separators. If a blank space appears, this will appear as the first character in the continued line (column 7).

Structure of a continued line with a line break at the end of the line

<table>
<thead>
<tr>
<th>Column 1-3</th>
<th>+**</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 4-6</td>
<td>Blanks</td>
</tr>
<tr>
<td>Column 7-80</td>
<td>Continuation of data,...“injuries”, for example, + line break</td>
</tr>
</tbody>
</table>

See also:

- Example: Transfer File for Phrases [Page 397]
- Example: Transfer File for Sources [Page 400]
- Example: Transfer File for Substances [Page 402]
- Example: Transfer File for a Properties Tree [Page 406]
- Example: Transfer File for a Report Template [Page 414]
Example: Transfer File for Phrases

The following example shows a transfer file (.DAT) for phrases.

<table>
<thead>
<tr>
<th>Notes</th>
<th>Column 1-5</th>
<th>Column 1-30</th>
<th>Column 7-80</th>
</tr>
</thead>
<tbody>
<tr>
<td>or for table fields + data</td>
<td>+C</td>
<td></td>
<td>Administrative section</td>
</tr>
<tr>
<td>Comment up to line end</td>
<td>+SC</td>
<td></td>
<td>ISO-LATIN 1</td>
</tr>
<tr>
<td>Character set</td>
<td>+ID</td>
<td></td>
<td>IUCLID</td>
</tr>
<tr>
<td>Identification (database name)</td>
<td>+V</td>
<td></td>
<td>2.20</td>
</tr>
<tr>
<td>Version</td>
<td>+D</td>
<td></td>
<td>19960122</td>
</tr>
<tr>
<td>Date</td>
<td>+C</td>
<td></td>
<td>Phrases</td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td></td>
<td>$TCG61</td>
</tr>
<tr>
<td><strong>Begin phrase library</strong></td>
<td>+BV</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table field CAPTIN</td>
<td></td>
<td></td>
<td>IUCIL</td>
</tr>
<tr>
<td>Table field CATDIST</td>
<td></td>
<td></td>
<td>Company name</td>
</tr>
<tr>
<td>Table field CATDATE</td>
<td></td>
<td></td>
<td>19960101</td>
</tr>
<tr>
<td>Table field CATVERS</td>
<td></td>
<td></td>
<td>2.21</td>
</tr>
<tr>
<td>End R/3 table</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td></td>
<td>Language-dependent label for phrase library</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td></td>
<td>$TCG62</td>
</tr>
<tr>
<td>Table field LANGU</td>
<td></td>
<td></td>
<td>D</td>
</tr>
<tr>
<td>Table field CATNAM</td>
<td></td>
<td></td>
<td>IUCLID Phrasenkatalog</td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
<td>E</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td></td>
<td>IUCLID phrase library</td>
</tr>
<tr>
<td>Table field LANGU</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table field CATNAM</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td></td>
<td>Phrase group</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td></td>
<td>$TCG63</td>
</tr>
<tr>
<td>Table field PHRGRP</td>
<td></td>
<td></td>
<td>A</td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td></td>
<td>Language-dependent label for phrase group</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td></td>
<td>$TCG64</td>
</tr>
<tr>
<td>Table field LANGU</td>
<td></td>
<td></td>
<td>D</td>
</tr>
</tbody>
</table>
### Example: Transfer File for Phrases

<table>
<thead>
<tr>
<th>Table field</th>
<th>PHRGNA</th>
<th>PHRGNA M</th>
</tr>
</thead>
<tbody>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td>+BV</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>$TCG64</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>PHRGNA M</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td>+BV</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>$ESTPH</td>
<td></td>
</tr>
<tr>
<td>End R/3 table (header)</td>
<td>PHRID</td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+EV</td>
<td>+BV</td>
</tr>
<tr>
<td>End R/3 table (identification)</td>
<td>$ESTPP</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>LANGDU</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>PHRTEXT</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>Begin R/3 table (header)</td>
<td>PHRID</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td>+BV</td>
</tr>
<tr>
<td>Begin R/3 table (identification)</td>
<td>$ESTPP</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>LANGDU</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>PHRCODE</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>mg/mg</td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>PHRTEXT</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>mg/mg</td>
<td></td>
</tr>
<tr>
<td>End phrase library</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Comment**

Phrase - phrase set allocation

| Begin R/3 table | +BV | $ESTPJ |
**Example: Transfer File for Phrases**

<table>
<thead>
<tr>
<th>Table field</th>
<th>PHRSEL</th>
<th>A01</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table field</td>
<td>PHRID</td>
<td>A01-01</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+EV</td>
<td>$ESTPJ</td>
</tr>
<tr>
<td>Table field</td>
<td>PHRSEL</td>
<td>A01</td>
</tr>
<tr>
<td>Table field</td>
<td>PHRID</td>
<td>A01-03</td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td>.</td>
</tr>
<tr>
<td>etc.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$ESTPJ</td>
</tr>
<tr>
<td>Table field</td>
<td>PHRSEL</td>
<td>A16</td>
</tr>
<tr>
<td>Table field</td>
<td>PHRID</td>
<td>A16-02</td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td>.</td>
</tr>
<tr>
<td>End of File</td>
<td>+EOF</td>
<td>.</td>
</tr>
</tbody>
</table>

**See also:**

- Specifying the Sequence of the External Data Structure [Page 387]
- Abbreviations and Syntax Rules [Page 393]
- Structure of Programming Lines [Page 396]
### Example: Transfer File for Sources

The following example shows a transfer file (.DAT) for sources.

<table>
<thead>
<tr>
<th>Notes</th>
<th>Column 1-5</th>
<th>Column 1-30</th>
<th>Column 7-80</th>
<th>Column 32-80</th>
</tr>
</thead>
<tbody>
<tr>
<td>or for table fields</td>
<td>+C</td>
<td>Administrative section</td>
<td>ISO-LATIN 1</td>
<td></td>
</tr>
<tr>
<td>Comment up to line end</td>
<td>+SC</td>
<td>IUCLID</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Character set</td>
<td>+ID</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Identification (database name)</td>
<td>+V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Version</td>
<td>+D</td>
<td>2.20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>+C</td>
<td>19960110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+BC</td>
<td>Quellen</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Begin references</strong></td>
<td>+BV</td>
<td>References</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>SRCID</td>
<td>$TCG46</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>SRCNAM</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>SRCAUTH</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>REM</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCID</td>
<td>481113</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCNAM</td>
<td>IUCLID references</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCAUTH</td>
<td>IUCLID</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>REM</td>
<td>Company (1993): calculation of department U.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCID</td>
<td>4831114</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCNAM</td>
<td>IUCLID references</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCAUTH</td>
<td>IUCLID</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>REM</td>
<td>Abc et.al.(1971): J. of Pharm. 11 (1)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCID</td>
<td>4831115</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCNAM</td>
<td>IUCLID references</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SRCAUTH</td>
<td>IUCLID</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>REM</td>
<td>Abc et.al.(1971): J. of Pharm. 11 (2)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>......Table field</td>
<td>SRCCAT</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>......Table field</td>
<td>SRCYEAR</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>......Table field</td>
<td>SRCORDN</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>......Table field</td>
<td>$TCG46</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>......Table field</td>
<td>BOOK</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>......Table field</td>
<td>1995</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>......Table field</td>
<td>IBDN-34324-434</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>End references</td>
<td>+EC</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>End of File</td>
<td>+EOF</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
See also:

Specifying the Sequence of the External Data Structure [Page 387]

Abbreviations and Syntax Rules [Page 393]

Structure of Programming Lines [Page 396]
Example: Transfer File for Substances

The following example shows a transfer file (.DAT) for substances.

<table>
<thead>
<tr>
<th>Notes</th>
<th>Column 1-6</th>
<th>Column 1-30</th>
<th>Column 7-30</th>
<th>Column 32-80</th>
</tr>
</thead>
<tbody>
<tr>
<td>or for table fields and characteristics:</td>
<td></td>
<td></td>
<td>Administrative section</td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Character set</td>
<td>+SC</td>
<td></td>
<td>ISO-LATIN 1</td>
<td></td>
</tr>
<tr>
<td>Identification (database name)</td>
<td>+ID</td>
<td></td>
<td>IUCLID</td>
<td></td>
</tr>
<tr>
<td>Format version</td>
<td>+V</td>
<td></td>
<td>2.21</td>
<td></td>
</tr>
<tr>
<td>Export date</td>
<td>+D</td>
<td></td>
<td>19960304</td>
<td></td>
</tr>
<tr>
<td>Key date for export</td>
<td>+VD</td>
<td></td>
<td>19960304</td>
<td></td>
</tr>
<tr>
<td>Set languages for export</td>
<td>+SL</td>
<td></td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td></td>
<td>Identification for data owner</td>
<td></td>
</tr>
<tr>
<td><strong>Begin data owner</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Identification</td>
<td>+BA</td>
<td></td>
<td>ID1</td>
<td></td>
</tr>
<tr>
<td>Data owner name</td>
<td>+NAME</td>
<td></td>
<td>BASF</td>
<td></td>
</tr>
<tr>
<td>City (headquarters)</td>
<td>+CITY</td>
<td></td>
<td>Ludwigshafen</td>
<td></td>
</tr>
<tr>
<td>Country</td>
<td>+CNTY</td>
<td></td>
<td>DE</td>
<td></td>
</tr>
<tr>
<td><strong>End data owner</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Begin data owner</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Identification</td>
<td>+BA</td>
<td></td>
<td>ID2</td>
<td></td>
</tr>
<tr>
<td>Data owner name</td>
<td>+NAME</td>
<td></td>
<td>HOECHST</td>
<td></td>
</tr>
<tr>
<td>City (headquarters)</td>
<td>+CITY</td>
<td></td>
<td>Frankfurt</td>
<td></td>
</tr>
<tr>
<td>Country</td>
<td>+CNTY</td>
<td></td>
<td>DE</td>
<td></td>
</tr>
<tr>
<td><strong>End data owner</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td></td>
<td>Identification phrase library</td>
<td></td>
</tr>
<tr>
<td><strong>Begin phrase library</strong></td>
<td></td>
<td></td>
<td>Phrases</td>
<td></td>
</tr>
<tr>
<td>Identification</td>
<td>+ID</td>
<td></td>
<td>IUCL</td>
<td></td>
</tr>
<tr>
<td>Version</td>
<td>+V</td>
<td></td>
<td>2.21</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>+D</td>
<td></td>
<td>19960101</td>
<td></td>
</tr>
</tbody>
</table>
Example: Transfer File for Substances

<table>
<thead>
<tr>
<th>End phrase library</th>
<th>Begin substance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>Substance Data</td>
</tr>
<tr>
<td>+EC</td>
<td>2-nitroanisole</td>
</tr>
<tr>
<td>+C</td>
<td>IU-91236</td>
</tr>
<tr>
<td>+BS</td>
<td>REAL_SUB</td>
</tr>
<tr>
<td>+BV</td>
<td>ID1</td>
</tr>
<tr>
<td></td>
<td>$ESTRH</td>
</tr>
<tr>
<td></td>
<td>$ESTRI</td>
</tr>
<tr>
<td></td>
<td>NUM</td>
</tr>
<tr>
<td></td>
<td>CAS</td>
</tr>
<tr>
<td></td>
<td>91-23-6</td>
</tr>
<tr>
<td></td>
<td>ID1</td>
</tr>
<tr>
<td></td>
<td>$ESTRL</td>
</tr>
<tr>
<td></td>
<td>EINECS</td>
</tr>
<tr>
<td></td>
<td>ID1</td>
</tr>
<tr>
<td></td>
<td>$ESTRL</td>
</tr>
<tr>
<td></td>
<td>EINECS</td>
</tr>
<tr>
<td></td>
<td>ID1</td>
</tr>
<tr>
<td></td>
<td>$ESTVA-UPDDAT</td>
</tr>
<tr>
<td></td>
<td>19930225</td>
</tr>
<tr>
<td></td>
<td>$ESTVA-UPDNAM</td>
</tr>
<tr>
<td></td>
<td>MAIER</td>
</tr>
<tr>
<td></td>
<td>$ESTVA-OWNID</td>
</tr>
<tr>
<td></td>
<td>ID1</td>
</tr>
<tr>
<td></td>
<td>$ESTVA-UPDDAT</td>
</tr>
<tr>
<td></td>
<td>19930225</td>
</tr>
<tr>
<td></td>
<td>$ESTVA-UPDNAM</td>
</tr>
<tr>
<td></td>
<td>MAIER</td>
</tr>
<tr>
<td></td>
<td>$ESTVA-OWNID</td>
</tr>
<tr>
<td></td>
<td>ID1</td>
</tr>
<tr>
<td></td>
<td>SAP_EHS_1018_003</td>
</tr>
<tr>
<td></td>
<td>F30-04</td>
</tr>
<tr>
<td></td>
<td>SAP_EHS_1018_003</td>
</tr>
<tr>
<td></td>
<td>F30-04</td>
</tr>
<tr>
<td></td>
<td>SAP_EHS_1018_003</td>
</tr>
<tr>
<td></td>
<td>F30-04</td>
</tr>
</tbody>
</table>
Example: Transfer File for Substances

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>SAP_EHS_1018_003_METHOD</th>
<th>F26-17</th>
</tr>
</thead>
<tbody>
<tr>
<td>Characteristic</td>
<td>SAP_EHS_1018_003_GLP</td>
<td>F25-01</td>
</tr>
<tr>
<td>etc.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Characteristic</td>
<td>SAP_EHS_1018_003_VALUE_S1</td>
<td>10 mg/l</td>
</tr>
</tbody>
</table>

Begin additional R/3 table

<table>
<thead>
<tr>
<th>Table field</th>
<th>OWNID</th>
<th>ID1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>UPDNAM</td>
<td>EUCLID</td>
</tr>
<tr>
<td>Table field</td>
<td>TEXTCAT</td>
<td>RM</td>
</tr>
<tr>
<td>Table field</td>
<td>TEXT</td>
<td></td>
</tr>
</tbody>
</table>

End additional R/3 table

Begin additional R/3 table

<table>
<thead>
<tr>
<th>Table field</th>
<th>OWNID</th>
<th>ID1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>UPDNAM</td>
<td>EUCLID</td>
</tr>
<tr>
<td>Table field</td>
<td>TEXTCAT</td>
<td>RE</td>
</tr>
<tr>
<td>Table field</td>
<td>TEXT</td>
<td></td>
</tr>
</tbody>
</table>

End additional R/3 table

End characteristic category

Begin characteristic category

<table>
<thead>
<tr>
<th>Table field</th>
<th>$ESTVA-UPDDAT</th>
<th>19921130</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table field</td>
<td>$ESTVA-UPDNAM</td>
<td>HOFMAN</td>
</tr>
<tr>
<td></td>
<td>$ESTVA-OWNID</td>
<td>ID1</td>
</tr>
<tr>
<td></td>
<td>$ESTVA-COMPREL</td>
<td>w/w</td>
</tr>
</tbody>
</table>

Begin additional R/3 table

<table>
<thead>
<tr>
<th>Table field</th>
<th>OWNID</th>
<th>ID1</th>
</tr>
</thead>
</table>

End additional R/3 table
### Example: Transfer File for Substances

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGU</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table field</td>
<td>UPDNAM</td>
<td>EUCLID</td>
</tr>
<tr>
<td>Table field</td>
<td>TEXTCAT</td>
<td>RU</td>
</tr>
<tr>
<td>Table field</td>
<td>TEXT</td>
<td>Firma;</td>
</tr>
<tr>
<td>Line continuation</td>
<td></td>
<td>Product</td>
</tr>
<tr>
<td>Line continuation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>SUBIDREF</td>
<td>IU-135134</td>
</tr>
<tr>
<td>Table field</td>
<td>COMPACT</td>
<td>IMPURITY</td>
</tr>
<tr>
<td>Table field</td>
<td>PRECL</td>
<td>=</td>
</tr>
<tr>
<td>Table field</td>
<td>COMPLROW</td>
<td>1</td>
</tr>
<tr>
<td>Table field</td>
<td>PRECU</td>
<td>=</td>
</tr>
<tr>
<td>Table field</td>
<td>COMPEXP</td>
<td>%</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>IDTYPE</td>
<td>NUM</td>
</tr>
<tr>
<td>Table field</td>
<td>IDCAT</td>
<td>CAS</td>
</tr>
<tr>
<td>Table field</td>
<td>IDENT</td>
<td>135-13-4</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>OWNID</td>
<td>ID1</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td></td>
<td></td>
</tr>
<tr>
<td>End characteristic category</td>
<td></td>
<td></td>
</tr>
<tr>
<td>End substance</td>
<td></td>
<td></td>
</tr>
<tr>
<td>End of file</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**See also:**
- Specifying the Sequence of the External Data Structure [Page 387]
- Abbreviations and Syntax Rules [Page 393]
- Structure of Programming Lines [Page 396]
Example: Transfer File for a Properties Tree

The following example shows a transfer file (.DAT) for a properties tree.

<table>
<thead>
<tr>
<th>Notes</th>
<th>for control lines</th>
<th>Column 1-5</th>
<th>Column 7-80</th>
</tr>
</thead>
<tbody>
<tr>
<td>For table fields and characteristics:</td>
<td></td>
<td>Column 1-30</td>
<td>Column 32-80</td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td><strong><strong><strong>Administrative section</strong></strong></strong></td>
<td></td>
</tr>
<tr>
<td>Character set</td>
<td>+SC</td>
<td>ISO-LATIN 1</td>
<td></td>
</tr>
<tr>
<td>Identification (source system)</td>
<td>+ID</td>
<td>EH&amp;S</td>
<td></td>
</tr>
<tr>
<td>Version</td>
<td>+V</td>
<td>1.00</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>+D</td>
<td>19970101</td>
<td></td>
</tr>
<tr>
<td>Begin tree</td>
<td>+BC</td>
<td>Properties tree</td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td><strong><strong><strong>Properties tree</strong></strong></strong></td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$TCG51</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>MENID</td>
<td>STANDARD</td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td>Add. info: language-dependent dependency, nodes</td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCG52</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>MENNAM</td>
<td>Standard properties tree</td>
<td></td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCG53</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>ID</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>ESTCAT</td>
<td>ROOT</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>PARENT</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>COMPR</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCG53</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>ID</td>
<td>1000</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>ESTCAT</td>
<td>MELT_POINT</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>PARENT</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>COMPR</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCG53</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>ID</td>
<td>2000</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>ESTCAT</td>
<td>BOILING</td>
<td></td>
</tr>
<tr>
<td>Table field</td>
<td>PARENT</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>
Example: Transfer File for a Properties Tree

<table>
<thead>
<tr>
<th>Table field</th>
<th>COMPR</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>+C</td>
<td><em><strong><strong>Substance characteristic category</strong></strong></em></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$TCG11</td>
</tr>
<tr>
<td>Table field</td>
<td>ESTCAT</td>
<td>MELT_POINT</td>
</tr>
<tr>
<td>Table field</td>
<td>ESTTYPE</td>
<td>A</td>
</tr>
<tr>
<td>Table field</td>
<td>REM</td>
<td>Comment</td>
</tr>
<tr>
<td>Table field</td>
<td>ECCOFLG</td>
<td>X</td>
</tr>
<tr>
<td>Table field</td>
<td>ECINFLG</td>
<td>X</td>
</tr>
<tr>
<td>Table field</td>
<td>ECUPFLG</td>
<td>X</td>
</tr>
<tr>
<td>Table field</td>
<td>USEPROF</td>
<td>Within Europe</td>
</tr>
<tr>
<td>Table field</td>
<td>IDLID</td>
<td>D_DEFAULT</td>
</tr>
<tr>
<td>Table field</td>
<td>CLVANAM</td>
<td>MELT_POINT</td>
</tr>
<tr>
<td>Table field</td>
<td>CLVPNAM</td>
<td>MELT_POINT</td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>+C</td>
<td>Add. info: language-dependent dependency, substance category</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCG12</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>ESTNAM</td>
<td>Melting point</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>+C</td>
<td><em><strong><strong>Substance characteristic category 2</strong></strong></em></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$TCG11</td>
</tr>
<tr>
<td>Table field</td>
<td>ESTCAT</td>
<td>BOILING</td>
</tr>
<tr>
<td>Table field</td>
<td>ESTTYPE</td>
<td>A</td>
</tr>
<tr>
<td>Table field</td>
<td>REM</td>
<td>Comment</td>
</tr>
<tr>
<td>Table field</td>
<td>ECCOFLG</td>
<td>X</td>
</tr>
<tr>
<td>Table field</td>
<td>ECINFLG</td>
<td>X</td>
</tr>
<tr>
<td>Table field</td>
<td>ECUPFLG</td>
<td>X</td>
</tr>
<tr>
<td>Table field</td>
<td>USEPROF</td>
<td>Within Europe</td>
</tr>
<tr>
<td>Table field</td>
<td>IDLID</td>
<td>D_DEFAULT</td>
</tr>
<tr>
<td>Table field</td>
<td>CLVANAM</td>
<td>BOILING</td>
</tr>
<tr>
<td>Table field</td>
<td>CLVPNAM</td>
<td>BOILING</td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>+C</td>
<td>Add. info: language-dependent dependency, substance category</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCG12</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>ESTNAM</td>
<td>Boiling point</td>
</tr>
</tbody>
</table>
### Example: Transfer File for a Properties Tree

<table>
<thead>
<tr>
<th>End additional R/3 table</th>
<th>+EAI</th>
</tr>
</thead>
<tbody>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
</tr>
<tr>
<td>Table field</td>
<td>CLASS</td>
</tr>
<tr>
<td>Table field</td>
<td>CLASS_TYPE</td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
</tr>
<tr>
<td>Table field</td>
<td>CATCHWORD</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
</tr>
<tr>
<td>Table field</td>
<td>CATCHWORD</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
</tr>
<tr>
<td>Table field</td>
<td>CATCHWORD</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
</tr>
<tr>
<td>Table field</td>
<td>CHARACT</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
</tr>
<tr>
<td>Table field</td>
<td>CHARACT</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
</tr>
<tr>
<td>Table field</td>
<td>CHARACT</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_ART</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_DESCR</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_FORM</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_LINE</td>
</tr>
<tr>
<td></td>
<td>+*</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_ART</td>
</tr>
</tbody>
</table>
Example: Transfer File for a Properties Tree

<table>
<thead>
<tr>
<th>Table field</th>
<th>TXT_FORM</th>
<th>*</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table field</td>
<td>TXT_LINE</td>
<td></td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$KLAT</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_ART</td>
<td>0</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_FORM</td>
<td>*</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_LINE</td>
<td>The melting point can be measured * according to various methods. Please</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$KLAT</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_ART</td>
<td>0</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_FORM</td>
<td>*</td>
</tr>
<tr>
<td>Table field</td>
<td>TXT_LINE</td>
<td>Please note the characteristic GLP.</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td><em><strong><strong>Classes 2</strong></strong></em></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$KLAH</td>
</tr>
<tr>
<td>Table field</td>
<td>CLASS</td>
<td>BOILING</td>
</tr>
<tr>
<td>Table field</td>
<td>CLASS_TYPE</td>
<td>100</td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td>Add. info: description, characteristics, docu.</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$SWOR</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
<td>E</td>
</tr>
<tr>
<td>Table field</td>
<td>CATCHWORD</td>
<td>BOILING</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$SWOR</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>CATCHWORD</td>
<td>Boiling point</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$SWOR</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGUAGE</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>CATCHWORD</td>
<td>Temperature</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$KSML</td>
</tr>
<tr>
<td>Table field</td>
<td>CHARACT</td>
<td>LOWER</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$KSML</td>
</tr>
<tr>
<td>Table field</td>
<td>CHARACT</td>
<td>UPPER</td>
</tr>
</tbody>
</table>
## Example: Transfer File for a Properties Tree

<table>
<thead>
<tr>
<th>Table field</th>
<th>CHARACT</th>
<th>METHOD</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KSML
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_DESCR Description for boiling point
Table field TXT_FORM *
Table field TXT_LINE This is a physical/ chemical property.
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $SKLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $SKLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $SKLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $SKLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $SKLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $SKLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $SKLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $KLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
End additional R/3 table +EAI
Begin additional R/3 table +BAI $SKLAT
Table field LANGUAGE D
Table field TXT_ART 0
Table field TXT_FORM *
Table field TXT_LINE The boiling point can be measured according to various methods. Please
```

<table>
<thead>
<tr>
<th>Table field</th>
<th>LANGUAGE</th>
<th>TXT_ART</th>
<th>TXT_FORM</th>
<th>TXT_LINE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D</td>
<td>0</td>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

```
### Example: Transfer File for a Properties Tree

<table>
<thead>
<tr>
<th>Table field</th>
<th>Description</th>
<th>Code</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATVOR</td>
<td>X</td>
<td></td>
<td>/negative values permitted</td>
</tr>
<tr>
<td>ATEIN</td>
<td>S</td>
<td></td>
<td>/=&gt; single-value</td>
</tr>
<tr>
<td>ATINP</td>
<td>X</td>
<td></td>
<td>/not ready for input</td>
</tr>
</tbody>
</table>

**Comment**

+ C  
Add. info: description, values and docu

**Begin additional R/3 table**

+BAI  
$CABNT

**Table field**

SPRAS  
D

**Table field**

ATBEZ  
Lower limit

**Table field**

ATUE1  
Lower limit

**End additional R/3 table**

+EAI

**Begin additional R/3 table**

+BAI  
$CAWN

**Table field**

ATWRT  
>= 10

**End additional R/3 table**

+EAI

**Begin additional R/3 table**

+BAI  
$CAWNT

**Table field**

SPRAS  
D

**Table field**

ATWTB  
Description of the characteristic value

**End additional R/3 table**

+EAI

**End R/3 table**

+EV

**Comment**

+ C

*******Characteristic 2*******

**Begin R/3 table**

+BV  
$CABN

**Table field**

SPRAS  
D

**Table field**

ATNAM  
UPPER

**Table field**

ATFOR  
NUMC

**Table field**

ANZST  
8

**Table field**

ANZDZ  
3

**Table field**

MSEHI  
°C

**Table field**

ATINT  
X  
/interval entry permitted?

**Table field**

ATVOR  
X  
/negative values permitted

**Table field**

ATEIN  
S  
/=> single-value

**Table field**

ATINP  
X  
/not ready for input

**Comment**

+ C  
Add. info: description, values and docu

**Begin additional R/3 table**

+BAI  
$CABNT

**Table field**

SPRAS  
D

**Table field**

ATBEZ  
Upper limit

**Table field**

ATUE1  
Upper limit

**End additional R/3 table**

+EAI

**Begin additional R/3 table**

+BAI  
$CAWN

**Table field**

ATWRT  
>= 100

**End additional R/3 table**

+EAI

**Begin additional R/3 table**

+BAI  
$CAWNT

**Table field**

ATWRT  
Description of the characteristic value
Example: Transfer File for a Properties Tree

<table>
<thead>
<tr>
<th>Comment</th>
<th>Example: Transfer File for a Properties Tree</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin R/3 table</td>
<td>+BV $CABN</td>
</tr>
<tr>
<td>Table field</td>
<td>ATNAM METHOD</td>
</tr>
<tr>
<td>Table field</td>
<td>ATFOR CHAR</td>
</tr>
<tr>
<td>Table field</td>
<td>ANZST 20</td>
</tr>
<tr>
<td>Table field</td>
<td>ATPRF C14_PHRASECHARACT_CHEK</td>
</tr>
<tr>
<td>Add. info: description, values and docu</td>
<td>Add. info: description, values and docu</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI $CABNT</td>
</tr>
<tr>
<td>Table field</td>
<td>SPRAS D</td>
</tr>
<tr>
<td>Table field</td>
<td>ATBEZ Method</td>
</tr>
<tr>
<td>Table field</td>
<td>ATUE1 Method</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Comment</th>
<th>Add. info: description, values and docu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin R/3 table</td>
<td>+BV $CABN</td>
</tr>
<tr>
<td>Table field</td>
<td>ATNAM SUBSET</td>
</tr>
<tr>
<td>Table field</td>
<td>ATFOR CHAR</td>
</tr>
<tr>
<td>Table field</td>
<td>ANZST 20</td>
</tr>
<tr>
<td>Table field</td>
<td>ATPRT TCG81</td>
</tr>
<tr>
<td>Add. info: description, values and docu</td>
<td>Add. info: description, values and docu</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI $CABNT</td>
</tr>
<tr>
<td>Table field</td>
<td>SPRAS D</td>
</tr>
<tr>
<td>Table field</td>
<td>ATBEZ Composition</td>
</tr>
<tr>
<td>Table field</td>
<td>ATUE1 Composition</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Comment</th>
<th>Phrase set ****</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin R/3 table</td>
<td>+BV $ESTPS</td>
</tr>
<tr>
<td>Table field</td>
<td>PHRSEL A_30</td>
</tr>
<tr>
<td>Table field</td>
<td>REM Remark</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI $ESTPT</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU E</td>
</tr>
<tr>
<td>Table field</td>
<td>PHRASNAM MELTING B201DECOMPOSITION</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI $TCG66</td>
</tr>
<tr>
<td>Table field</td>
<td>ESTCAT MELT_POINT</td>
</tr>
<tr>
<td>Table field</td>
<td>ATNAM LOWER</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
</tr>
</tbody>
</table>
Example: Transfer File for a Properties Tree

<table>
<thead>
<tr>
<th>Begin additional R/3 table</th>
<th>+BAI</th>
<th>$TCG66</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table field</td>
<td>ESTCAT</td>
<td>BOILING</td>
</tr>
<tr>
<td>Table field</td>
<td>ATNAM</td>
<td>LOWER</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td>End tree</td>
<td>+EC</td>
<td></td>
</tr>
<tr>
<td>End of File</td>
<td>+EOF</td>
<td></td>
</tr>
</tbody>
</table>

See also:

- Specifying the Sequence of the External Data Structure [Page 387]
- Abbreviations and Syntax Rules [Page 393]
- Structure of Programming Lines [Page 396]
Example: Transfer File for a Report Template

The following example shows a transfer file (.DAT) for a report template.

<table>
<thead>
<tr>
<th>Notes</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>for control lines</td>
<td>Column 1-5</td>
<td>Column 7-80</td>
</tr>
<tr>
<td>For table fields and</td>
<td>Column 1-30</td>
<td>Column 32-80</td>
</tr>
<tr>
<td>characteristics:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>+C</td>
<td><em><strong><strong>Administrative section</strong></strong></em></td>
</tr>
<tr>
<td>Character set</td>
<td>+SC</td>
<td>ISO-LATIN 1</td>
</tr>
<tr>
<td>Identification (database name)</td>
<td>+ID</td>
<td>EH&amp;S</td>
</tr>
<tr>
<td>Version</td>
<td>+V</td>
<td>1.00</td>
</tr>
<tr>
<td>Date</td>
<td>+D</td>
<td>19970101</td>
</tr>
<tr>
<td><strong>Begin template</strong></td>
<td>+BC</td>
<td>Report template</td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>+C</td>
<td><em><strong><strong>Header data</strong></strong></em></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$DRAW</td>
</tr>
<tr>
<td>Table field</td>
<td>DOKAR</td>
<td>SBV</td>
</tr>
<tr>
<td>Table field</td>
<td>DOKNR</td>
<td>EC_Safety_data_sheet</td>
</tr>
<tr>
<td>Table field</td>
<td>DOKVR</td>
<td>00</td>
</tr>
<tr>
<td><strong>End R/3 table</strong></td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>+C</td>
<td>Label for report template</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$DRAT</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>DKTXT</td>
<td>Layout für EG Sicherheitsdatenblatt</td>
</tr>
<tr>
<td><strong>End R/3 table</strong></td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$DRAT</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>E</td>
</tr>
<tr>
<td>Table field</td>
<td>DKTXT</td>
<td>Safety sheet layout</td>
</tr>
<tr>
<td><strong>End R/3 table</strong></td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>+C</td>
<td>Symbol</td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$TCGA6</td>
</tr>
<tr>
<td>Table field</td>
<td>LSYTYPE</td>
<td>00</td>
</tr>
<tr>
<td>Table field</td>
<td>LSYID</td>
<td>200</td>
</tr>
<tr>
<td>Table field</td>
<td>CLASS</td>
<td>BOILING</td>
</tr>
<tr>
<td>Table field</td>
<td>ATNAM</td>
<td>B202GLP</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCGA7</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>LSYNAM</td>
<td>Wert</td>
</tr>
<tr>
<td><strong>End additional R/3 table</strong></td>
<td>+EAI</td>
<td></td>
</tr>
</tbody>
</table>
### Example: Transfer File for a Report Template

<table>
<thead>
<tr>
<th>Begin additional R/3 table</th>
<th>+BAI</th>
<th>$TCGA7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>E</td>
</tr>
<tr>
<td>Table field</td>
<td>LSYNAM</td>
<td>Value</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td>Begin R/3 table</td>
<td>+BV</td>
<td>$TCGA6</td>
</tr>
<tr>
<td>Table field</td>
<td>LSYTYPE</td>
<td>02</td>
</tr>
<tr>
<td>Table field</td>
<td>LSYID</td>
<td>1157</td>
</tr>
<tr>
<td>Table field</td>
<td>TABNAME</td>
<td>KNVK</td>
</tr>
<tr>
<td>Table field</td>
<td>FIELDNAME</td>
<td>KUNNR</td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCGA7</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>D</td>
</tr>
<tr>
<td>Table field</td>
<td>LSYNAM</td>
<td>Firmenname</td>
</tr>
<tr>
<td>End additional R/3 table</td>
<td>+EAI</td>
<td></td>
</tr>
<tr>
<td>Begin additional R/3 table</td>
<td>+BAI</td>
<td>$TCGA7</td>
</tr>
<tr>
<td>Table field</td>
<td>LANGU</td>
<td>E</td>
</tr>
<tr>
<td>Table field</td>
<td>LSYNAM</td>
<td>Company name</td>
</tr>
<tr>
<td>End R/3 table</td>
<td>+EV</td>
<td></td>
</tr>
<tr>
<td>End template</td>
<td>+EC</td>
<td></td>
</tr>
<tr>
<td>End of File</td>
<td>+EOF</td>
<td></td>
</tr>
</tbody>
</table>

**See also:**

- [Specifying the Sequence of the External Data Structure](Page 387)
- [Abbreviations and Syntax Rules](Page 393)
- [Structure of Programming Lines](Page 396)
Source Import

Use
You use this function to import sources into the R/3 System.

Features
When importing sources, you can use the following functions:

File check
Before you import sources, you must start pre-import. The R/3 System then checks:

- the path for the transfer file
- the syntactic structure of the transfer file

The number of syntax errors is displayed on the screen. You can display a detailed error description using the check log.

- The administrative part of the transfer file (version, date, for example)
- The number of sources in the transfer file
- The number of sources that already exist in the R/3 System, or the number to be created

Data Import
Data import is carried out in the background in direct-input procedures. The R/3 System creates an import log for this.

If a source key in the R/3 System then the source is

- does not exist created.
- does exist updated using the data from the transfer file.

Activities
Importing Sources [Page 417]
Importing Sources

Prerequisites

See the Prerequisites section under: Import: Process [Page 350].

Procedure

1. From the Product Safety [Ext.] screen, choose Data transfer → Sources.
   The initial Import Sources: Parameters screen appears.

2. If you have defined an exchange profile in Customizing for Product Safety, enter the key for the exchange profile, and choose ENTER.
   The settings in the exchange profile are transferred.

3. Please ensure that the path and file name for the transfer file and directory on the application server have been entered in the File with path field.

   /USR/SAP/SH1/SYS/GLOBAL/SOURCE.DAT

   The R/3 System checks the transfer file and determines the sources to be created and changed.

5. Choose Goto → Check log. Select the log for your transfer file, choose Goto → Display messages, and check any error messages there.

   To correct the transfer file, choose Data transfer → Download file from the Product Safety [Ext.] screen. Make the changes in an ASCII editor, and then choose Data transfer → Upload file.

6. On the initial screen for source import, choose Edit → Transfer/start time.
   A dialog box appears in which you can define the start date. After you have saved your data, the R/3 System starts the data transfer for the start date specified.

   To check the procedure, choose Data transfer → Check transfer → Sources from the Product Safety [Ext.] screen.

7. On the initial screen for source import, choose Goto → Direct-Input, to display the log for the database update.
   Then choose Job administration → Execute, select the log for your transfer file, and choose Job administration → Display log. The system generates a list of all messages for the background job.
   Evaluate the messages, and make the necessary corrections.
Importing Sources

**Result**

- The system overwrites old sources.
- New sources are added.
- Sources that already exist and were not imported again are retained (the sources are not deleted, as they may have been used in substance characteristic value assignment).

After the import, you can check sources in [Source Management](#) [Page 60].
Importing Phrases

Use
You use this function to import the following data into the R/3 System:

- Phrase catalog
- Phrase groups
- Phrases
- Phrase references
- Assignments to phrase sets

You can import individual languages. In addition, you can use engineering change management for importing phrases.

Features
When importing phrases, you can use the following functions:

File check
The R/3 System checks whether the data can be transferred correctly from the transfer file and determines the phrases to be changed and created (see Checking Files during Phrase Import [Page 421]).

A log is created for checking the file, and you use the file to ascertain any errors made.

<table>
<thead>
<tr>
<th>When comparing the data in the transfer file and the R/3 System, if</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>A phrase key in the transfer file was not found in the R/3 System,</td>
<td>The phrase is newly created on import with all languages specified.</td>
</tr>
<tr>
<td>Phrase key and phrase text are identical,</td>
<td>The phrase is not imported.</td>
</tr>
<tr>
<td>The phrase keys are identical, but phrase texts are different in the languages to be imported,</td>
<td>You can use the transfer parameters to control if the phrase should be imported with or without engineering change management.</td>
</tr>
</tbody>
</table>

Control
You can use the transfer parameters to determine:

- Whether the phrase references are transferred

Phrase references are created even when the phrases themselves are not contained in the respective phrase library. However, the phrase library must have been entered in Customizing for Product Safety.

- Whether the assignments from phrases to phrase sets should be transferred
Importing Phrases

- Whether you want to import phrases using engineering change management:

<table>
<thead>
<tr>
<th>If you</th>
<th>Then the imported phrase</th>
</tr>
</thead>
<tbody>
<tr>
<td>Want to import with change numbers</td>
<td>Is valid from the date of the change number. It is valid for newly created and changed phrases.</td>
</tr>
<tr>
<td></td>
<td>The change date refers to:</td>
</tr>
<tr>
<td></td>
<td>- Phrase header</td>
</tr>
<tr>
<td></td>
<td>- Phrase text</td>
</tr>
<tr>
<td></td>
<td>- Phrase references</td>
</tr>
<tr>
<td></td>
<td>- Assignments to phrase sets</td>
</tr>
<tr>
<td>Want to import without change numbers</td>
<td>Replaces the existing phrase in all languages for which the import is to be carried out</td>
</tr>
<tr>
<td></td>
<td>The following are also replaced:</td>
</tr>
<tr>
<td></td>
<td>- Phrase references</td>
</tr>
<tr>
<td></td>
<td>- Assignments to phrase sets</td>
</tr>
</tbody>
</table>

- If you want to carry out a full import

  In this case, the old phrase library together with all phrase groups in the R/3 System is deleted before import.

Data import

The data is transferred in the background using the direct-input procedure. The R/3 System creates an import log for this.

<table>
<thead>
<tr>
<th>If an error occurs in</th>
<th>Then the following is not imported</th>
</tr>
</thead>
<tbody>
<tr>
<td>The phrase library or its description</td>
<td>The entire library</td>
</tr>
<tr>
<td>The phrase group or its description</td>
<td>The entire group with all assigned phrases</td>
</tr>
<tr>
<td>The phrase (phrase header, phrase text, phrase reference)</td>
<td>This particular phrase</td>
</tr>
</tbody>
</table>

All phrase changes that occurred during phrase import are logged using engineering change management. You can call the logs in phrase management (see Phrase Engineering Change Management [Page 98]).

You can display changes made with change numbers in the Phrase History [Page 106].

Activities

Importing Phrases [Page 422]
Checking Files during Phrase Import

Use
The R/3 System checks if the data can be transferred correctly from the transfer file, and determines the phrases to be changed and created.

Features
The R/3 System checks

- The path for the transfer file
- The syntactic structure of the transfer file
  The number of syntax errors is displayed on the screen. You can display a detailed error description using the check log.
- If the phrase library exists in the R/3 System, and if it is active or passive
- If the phrase library from the file has the same date as or a more recent date than the existing library in the R/3 System If the date is earlier, the library cannot be imported.
- The administrative part of the transfer file
- The number of phrases in the transfer file
- The number of phrases that already exist in the R/3 System, or the number to be created
Importing Phrases

Prerequisites

- The phrase library must have been entered in Customizing for Product Safety.
- See the Prerequisites section under: Import: Process [Page 350]

Procedure

1. From the Product Safety [Ext.] screen Data transfer → Phrases.
   The initial Import Phrases: Parameters screen appears.

2. If you have defined an exchange profile in Customizing for Product Safety, enter the key for the exchange profile, and choose ENTER.
   The settings in the exchange profile are transferred.
   
   If you want to work with engineering change management, you must enter the change number in the exchange profile.

3. Please ensure that the path and file name for the transfer file and directory on the application server have been entered in the File with path field.

   /USR/SAP/SH1/SYS/GLOBAL/PHRASE.DAT

4. Flag the Phrase set assignment indicator if you have maintained the assignments of phrases to the corresponding phrase sets in the transfer file, and want to import them.

   Any assignments you want to make later must be done manually.

5. Choose Edit → Check file.
   The R/3 System checks the transfer file and determines the phrases to be created and changed.

6. Choose Goto → Check log. Select the log for your transfer file, choose Goto → Display messages and check any error messages there.

   To correct the transfer file, choose Data transfer → Download file from the Product Safety [Ext.] screen. Make the changes in an ASCII editor, and then choose Data transfer → Upload file.

7. On the initial screen for phrase import, choose Edit → Transfer/start time.
   A dialog box appears in which you can define the start date. After you have saved your data, the R/3 System starts the data transfer for the start date specified.
To check the procedure, choose Data transfer → Check transfer → Phrases from the Product Safety [Ext.] screen.

8. On the initial screen for phrase import, choose Goto → Direct-Input, to display the log for the database update.

   Then choose Job administration → Execute, select the log for your transfer file, and choose Job administration → Display log. The system generates a list of all messages for the background job.

   Evaluate the messages, and make the necessary corrections.

**Result**

The results of the import depend on the your transfer parameters.

*See also: Importing Phrases [Page 419]*

After the import, you can check phrases in phrase managment.
Importing Substances

Use
You use this function to import the following data into the R/3 System:

- Substance headers
- Substance identifiers with substance list assignment
- Substance references
- Substance - material assignments
- Substance characteristic values with additional information
  - Data for transport license, packing code - license, danger classification, and transport classification

Integration
Substance import directly includes Importing Phrases [Page 419] and Source Import [Page 416].

Features
The following functions are included in substance import:

File check
The R/3 System checks if the data can be transferred correctly from the transfer file, and compares the substances from the transfer file with the substances in the R/3 substance database.

See also: Checking Files during Substance Import [Page 426]
The R/3 System writes a log for the file check. You use this log to correct any errors that occur.

Control
You use parameters to define

- Which methods are to be used to assign the substances in the transfer file to the substances in the R/3 System
- How the new data are to be imported into the R/3 System and if old data are to be deleted or retained

See also: Controlling Substance Import [Page 428]

Data import
The data is transferred in the background in direct-input procedures. The R/3 System creates an import log for this.
While you are importing a substance, the substance assigned in the R/3 System is locked against changes in the R/3 substance management. If the lock cannot be set, the substance cannot be imported.

When importing substance identifiers [Page 431], the system ensures that there are no inconsistencies for existing identifiers in the R/3 System.

The R/3 System does not import a substance if there are errors in the substance master record (substance header, substance identifiers).

If there are errors in other values, the corresponding data is not imported (a material assignment, usage, or the complete substance characteristic values).

Information on the errors that occurred are displayed in the import log (see Error Handling during Substance Import [Page 432]).

**Activities**

Importing Substances [Page 433]
Checking Files during Substance Import

Use

This function checks if all parameters required for substance import have been maintained in the R/3 System, and then takes you to parameter maintenance, if you have to maintain parameters subsequently.

The function then compares the substances from the transfer file and those from the R/3 substance database, and lists all application pairs found. The R/3 System creates a check log for this.

Prerequisites

See the Prerequisites section under: Importing Sources, Phrases, Substances, Properties Trees, Report Templates [Page 350].

Features

Before import, the R/3 System checks:

- The path for the transfer file
- The syntactic structure of the transfer file
  - The number of syntax errors is displayed on the screen. You can display a detailed error description using the check log.
- If the source system has been created in the R/3 System
- If the data provider from the transfer file has been created as a data owner/provider in the R/3 component Product Safety. It is only then that the data provider can be imported.
- The key data from the phrase library in the substance file, and the key data from the phrase library in the R/3 System
  - If the data do not correspond, the R/3 System generates a warning.
- Which substances in the transfer file can be assigned to those in the R/3 component Product Safety.
  - The R/3 System selects unique assignments for import.
  - You influence the results of the search by the entry made in the Search type field (see Controlling Substance Import [Page 428]). To enable a substance to be imported into the R/3 System, the R/3 System must be able to find a unique assignment for this substance, or no assignment to a substance in the R/3 database.
  - The R/3 System flags all substance that can be imported. This procedure is equally valid for substances, component substances, and reference substances.

<table>
<thead>
<tr>
<th>If the search results indicate that</th>
<th>Then the substance is</th>
</tr>
</thead>
<tbody>
<tr>
<td>The substance in the transfer file cannot be assigned a substance in the R/3 System</td>
<td>Selected</td>
</tr>
</tbody>
</table>
Checking Files during Substance Import

<table>
<thead>
<tr>
<th>Condition</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>The substance in the transfer file can be assigned exactly one substance in the R/3 System</td>
<td>Selected</td>
</tr>
<tr>
<td>The substance in the transfer file is assigned at least two substances in the R/3 System</td>
<td>Not selected. You must select your required assignment pair yourself.</td>
</tr>
<tr>
<td>The substance to be imported exists twice or more in the transfer file</td>
<td>Not selected. Check the file.</td>
</tr>
</tbody>
</table>

You can manually revise the substance assignment made in the R/3 System (see Assigning Substances Manually during Substance Import [Page 430]).
Controlling Substance Import

Use

You use parameters to control the file check and substance import. You can set default parameters by using exchange profiles to define default values in Customizing for Product Safety. You can overwrite the parameters manually in the parameter dialog.

Features

You can use the following parameters to control substance import:

- Parameters for preliminary check
  - You use the Search type field to define the method with which you assign the substances in the transfer file to the substances in the R/3 System. The search method is used for:
    - Substances
    - Component substances
    - Reference substances
  - You can search using substance key or using precisely defined identifiers. You can also enter combinations.
  - When searching using identifiers, the identification listing specified is used for the search. The position and priority of an identifier within an identification listing has no significance here. All identifiers in the identification listing for a substance are read from the file.
  - The search can be run as an AND or an OR search using the field Logic link type.
  - OR search: If a substance in the R/3 System has the same identifier as the substance in the file, this substance is treated as being the same as the substance in the file. This can apply for a number of substances in the R/3 System so that a number of substances in the R/3 System can be assigned to one substance in the file. You have to make the exact assignment manually.

The substance IMPSUB in the file has the CAS number 50-00-0. It is searched for using the CAS number only. Three substances (SUB1, SUB2, SUB3) are found in the system with this CAS number. The following is displayed:

<table>
<thead>
<tr>
<th>Substance</th>
<th>CAS Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUB1</td>
<td>50-00-0</td>
</tr>
<tr>
<td>IMPSUB</td>
<td>50-00-0</td>
</tr>
<tr>
<td>SUB2</td>
<td>50-00-0</td>
</tr>
<tr>
<td>IMPSUB</td>
<td>50-00-0</td>
</tr>
<tr>
<td>SUB3</td>
<td>50-00-0</td>
</tr>
<tr>
<td>IMPSUB</td>
<td>50-00-0</td>
</tr>
</tbody>
</table>

No assignment is to be marked as to be imported. You have to make the correct assignment yourself.
Controlling Substance Import

- AND search: The substance in the R/3 System must have the same identifiers in the identification listing as the substance in the file. If the substance in the file does not have all the identifiers in the identification listing, only the existing ones are used for the search.

- Transfer parameters

  You define how new data are to be imported into the R/3 System and if old data are to be deleted or retained.

  You use the Deletion category field to specify whether:

  - All substance data are to be deleted before import into the R/3 System
  - No substance data are to be deleted and the import is to be carried out additively
  - Only those data are to be deleted and reloaded that correspond to the data origin and the data provider in the transfer file
  - The characteristic values of the substance characteristic categories in the properties tree specified as the parameter are to be deleted. Identifiers, substance references, and material assignments are not deleted

  You use the Phrase conversion field to specify that all phrases to be used as substance characteristic values are to be converted to phrases in the active phrase library, if phrase references were defined.

  You use the Properties tree or Usage profile field to specify that the data to be imported belong to the substance characteristic categories in a particular properties tree or have the usage in a particular usage profile.

- Parameters for standard values

  You specify standard values for substance categories, substance authorization groups, user-defined text categories, and component categories. If the values are missing in the transfer file, the R/3 System uses the standard values.

  You specify if the substance key for new substances should be taken from the internal number range. Otherwise, the substance key in the file is used.

See also:
Checking Files during Substance Import [Page 426]
Assigning Substances Manually during Substance Import

Use

You can manually revise the substance assignment created by the R/3 System during the file check.

See also:

Checking Files during Substance Import [Page 426]

Features

You influence the assignment of substances from the transfer file to an R/3 substance by modifying the substance key.

Influence of substance key

<table>
<thead>
<tr>
<th>If</th>
<th>Then you can</th>
</tr>
</thead>
<tbody>
<tr>
<td>The R/3 System finds a substance key</td>
<td>Leave the substance key unchanged</td>
</tr>
<tr>
<td></td>
<td>The R/3 System imports the data that correspond to the definition in the Deletion category field for the substance.</td>
</tr>
<tr>
<td></td>
<td>Change the substance key</td>
</tr>
<tr>
<td></td>
<td>You can enter a substance key that already exists and thus assign the substance data to this substance.</td>
</tr>
<tr>
<td></td>
<td>Delete the substance key</td>
</tr>
<tr>
<td></td>
<td>If you delete the substance key, the substance is created during import.</td>
</tr>
<tr>
<td>The R/3 System does not find a substance key</td>
<td>Enter the substance key yourself</td>
</tr>
<tr>
<td></td>
<td>You can enter a substance key that already exists and thus assign the substance data to this substance.</td>
</tr>
<tr>
<td></td>
<td>Leave the field empty</td>
</tr>
<tr>
<td></td>
<td>If no substance key is assigned, the substance is created during import.</td>
</tr>
</tbody>
</table>

If you enter a substance key, the key must already exist. You cannot define a new key manually.

The assignments you enter are not checked further by the import.
Importing Substance Identifiers

Use
The R/3 System checks that substance identifiers are unique before they are imported.

Features
The following cases can occur during the check:

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>An identifier exists in the R/3 System and in the transfer file, and both have the same data origin</td>
<td>The identifier remains unchanged</td>
</tr>
<tr>
<td>The identifier exists in the R/3 System and in the transfer file, but they have different data origins</td>
<td>The data origin for the identifier in the R/3 System is deleted</td>
</tr>
</tbody>
</table>

If the data origin for an identifier is missing, this means the identifier has at least two data origins.

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>The identifier exists in the transfer file, but not in the R/3 System</td>
<td>The identifier is created with its data origin in the R/3 System.</td>
</tr>
<tr>
<td>The identifier exists in the R/3 System but not in the transfer file</td>
<td>The identifier is deleted</td>
</tr>
</tbody>
</table>

This procedure ensures that any typing errors in an identifier can be corrected in the R/3 System during renewed import.

To avoid unwanted data losses when deleting an identifier, you must ensure that all necessary identifiers are complete in the transfer file.

The erroneous identifier WATTER with data origin ABC is present in the R/3 System. A renewed import leads to the creation of the correct identifier WATER in the R/3 System with data origin ABC. As WATTER is not present in the transfer file, WATTER is deleted by the R/3 System. The typing error is corrected.
Error Handling during Substance Import

Use
A substance is not transferred if it contains errors or inconsistencies in the substance master data record. If errors or inconsistencies occur in substance characteristic values, for example, if a non-existent phrase or source is used, only the value assignment is not transferred.

Errors are written to an error log during import. This can be displayed using direct-input functions or batch job administration.

Features

<table>
<thead>
<tr>
<th>Error</th>
<th>From table</th>
<th>Reaction to error</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substance header</td>
<td>ESTRH</td>
<td>Substance import terminated</td>
</tr>
<tr>
<td>Identifiers</td>
<td>ESTRI</td>
<td>Substance import terminated</td>
</tr>
<tr>
<td>Substance list doesn’t exist</td>
<td>ESTRL</td>
<td>Assignment not imported</td>
</tr>
<tr>
<td>Material assignment</td>
<td>ESTMJ</td>
<td>Record not imported</td>
</tr>
<tr>
<td>Reference substances</td>
<td>ESTRR</td>
<td>Assignment not transferred</td>
</tr>
<tr>
<td>Substance characteristic value</td>
<td></td>
<td>No substance characteristic values imported</td>
</tr>
<tr>
<td>(without additional information)</td>
<td></td>
<td>User-defined text category used that was defined as standard parameter</td>
</tr>
<tr>
<td>User-defined text category does not exist</td>
<td></td>
<td>User-defined text category used that was defined as standard parameter</td>
</tr>
<tr>
<td>Assessment entered does not exist</td>
<td></td>
<td>The default value defined in Customizing is used</td>
</tr>
<tr>
<td>Component category does not exist</td>
<td></td>
<td>Component category used that was defined as standard parameter</td>
</tr>
<tr>
<td>Error in composition</td>
<td>ESTVP</td>
<td>No substance characteristic values imported</td>
</tr>
<tr>
<td>Source does not exist</td>
<td>TCG46</td>
<td>Assignment not imported</td>
</tr>
<tr>
<td>Substance characteristic usage does not exist</td>
<td>ESTDU</td>
<td>Usage not imported</td>
</tr>
<tr>
<td>General additional information</td>
<td></td>
<td>Additional information not imported</td>
</tr>
<tr>
<td>Syntax or semantic errors</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Importing Substances

Prerequisites

See the Prerequisites section under: Import: Process [Page 350]

In addition, the following prerequisites must be fulfilled:

- The sources and phrases to be used in the substance transfer file must be present in the R/3 System.
- Existing assignments of phrases to their corresponding phrase sets must have been imported already. Otherwise, the assignments must be maintained after import.
- The characteristic categories and characteristics have been set up.

Procedure

1. From the Product Safety [Ext.] screen, choose Data transfer → Substances.

   The initial Import Substances: Substances screen appears.

2. If you have defined an exchange profile in Customizing for Product Safety, enter the key for the exchange profile, and choose ENTER.

   The settings in the exchange profile are transferred to the initial screen.

3. Please ensure that the path and file name for the transfer file and directory on the application server have been entered in the File with path field.

   /USR/SAP/SH1/SYS/GLOBAL/SUBSTANCE.DAT

4. Choose Edit → Check file to check the exchange file for syntax errors and start pre-import.

   If you have not entered an exchange profile, or if there are parameter values missing, a dialog box appears in which you can enter parameter values. Complete the required data.

   The R/3 System then carries out pre-import, and lists the substances from the R/3 substance database that correspond to the substances from the transfer file. The R/3 System flags all substances that could be assigned uniquely. Check or correct the assignments. Deselect the substances you do not want to transfer.

5. To check if the R/3 System found errors during the file check, choose Goto → Check log.

   Select the log for your transfer file and choose Goto → Display messages.

   To correct the transfer file, choose Data transfer → Download file from the Product Safety [Ext.] screen. Make the changes in an ASCII editor, and then choose Data transfer → Upload file.

6. On the initial screen for substance import, choose Edit → Transfer/start time.

   A dialog box appears in which you can define the start date. After you have saved your data, the R/3 System starts the data transfer for the start date specified.
Importing Substances

To check the procedure, choose Data transfer → Check transfer → Substances from the Product Safety [Ext.] screen.

7. On the initial screen for substance import, choose Goto → Direct-Input to display the log for the database update.

   Then choose Job administration → Execute, select the log for your transfer file, and choose Job administration → Display log. The system generates a list of all messages for the background job.

   Evaluate the messages, and make the necessary corrections.

Result

Import is carried out according to the transfer parameters that you defined in step 4.

See also: Controlling Substance Import [Page 428]

After import, you can check the substances in substance managment.
Properties Tree Import

Use

These functions enable you to:

- Import a new properties tree into the R/3 System
- Modify an existing properties tree

In combination with the *Properties Tree Export* function, you can compare properties trees in different R/3 Systems.

Features

When importing properties trees, you can use the following functions:

File check

The R/3 System checks to see if the data from the transfer file can be transferred correctly and determines all substance characteristic categories to be changed and created in the R/3 System.

A log is created for checking the file and you use the file to ascertain any errors made.

For all selected substance characteristic categories in the R/3 System, you can display the differences between the properties trees in the source and target systems. The following differences can occur:

- The descriptions for the substance characteristic categories are different.
- Different classes are assigned to the substance characteristic category.
- A class is defined in different ways.
- The characteristics in a class are different.
- The characteristics are defined in different ways.
- The descriptions for the characteristics are different.
- The phrase sets assigned to the characteristics are different.
- The names for the phrase sets are different.

Control

All selected substance characteristic categories are imported.

⚠️ You should ensure that:

- No SAP classes are marked
- No classes you created that contain SAP characteristics are marked

SAP characteristics and classes must not be transported using import or export. Otherwise, the original SAP characteristics and classes cannot be overwritten by an updated properties tree during a release upgrade.
Properties Tree Import

You are allowed to transport only the substance characteristic categories you defined yourself.

In addition, you can use parameters to determine which elements of the substance characteristic categories are imported (for example, descriptions for substance characteristic categories, classes, class descriptions, characteristics, and characteristic descriptions).

If a characteristic is newly created in the R/3 System, then all elements of the characteristic that are dependent on other selected elements (descriptions, for example) are imported without being specifically selected.

Data import

The data is transferred in the background using the direct-input procedure. The R/3 System creates an import log for this.

<table>
<thead>
<tr>
<th>If in the target system</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>No properties tree exists with the same key,</td>
<td>The properties tree is newly created.</td>
</tr>
<tr>
<td>A properties tree exists with the same key,</td>
<td>The structures are matched up.</td>
</tr>
<tr>
<td></td>
<td>The R/3 System inserts new substance characteristic categories in the appropriate points in the properties tree.</td>
</tr>
<tr>
<td></td>
<td>Objects that already exist are not deleted as a result of the import.</td>
</tr>
</tbody>
</table>

New characteristics for a substance characteristic category are always appended at the end of the list of characteristics.

The characteristics A and C are assigned to class K. On importing, the characteristics A, B, and C are imported for class K. The sequence of the characteristics is then: A, C, B.

No truncated value lengths of characteristics can be transported using the import. If, for example, the characteristic A already exists in the R/3 System with the length CHAR 30, it is not possible to overwrite this characteristic with the length CHAR 1 using an import in the R/3 System. In this case, an error message will be written in the log. Lengthening values is, however, permitted.

If you reconfigure your R/3 System, you can generate phrase sets for all characteristics of data type CHAR30 in the IMG activity Generate standard phrase sets in Customizing for Product Safety if the phrase sets are not part of the export file.

Activities

Importing Properties Trees [Page 437]
Importing Properties Trees

Prerequisites
See Prerequisites under Import: Process [Page 350]

Procedure
1. In the Product Safety [Ext.] screen, choose Data transfer → Properties tree.
   The Import Properties Tree: Parameters screen appears.
2. Ensure that the path and file name for the transfer file and directory on the application server have been entered in the File w/path field.
   /USR/SAP/SH1/SYS/GLOBAL/TREE.DAT
3. Choose Edit → Check file.
   The R/3 System checks the transfer file and lists all substance characteristic categories in the transfer file.
4. Choose Goto → Check log. Select the log for your transfer file, choose Goto → Display messages, and check any error messages there.
   To correct the transfer file, in the Product Safety [Ext.] screen choose Data transfer → Download file. Make the changes in an ASCII editor and then choose Data transfer → Upload file.
5. If required, choose the elements of the properties tree you want to import under Goto → Parameters.
6. To display the differences between the properties tree from the import file and the existing properties tree in the R/3 System, choose Properties tree → Differences.
   A list is displayed showing you the differences in the substance characteristics categories (for example, different labels) and characteristics.
7. On the initial screen for properties tree import, choose Edit → Transfer/start time.
   A dialog box appears in which you can define the start date. After you have saved your data, the R/3 System starts the data transfer for the start date specified.
   To check the procedure, in the Product Safety [Ext.] screen choose Data transfer → Check transfer → Reports.
8. Then choose Job administration → Execute, select the log for your transfer file, and choose Job administration → Display log. The system generates a list of all messages for the background job.
Importing Properties Trees

Evaluate the messages and make the necessary corrections.

**Result**

- If no identical properties tree exists in the target system, the properties tree is created new.
- If an identical properties tree exists in the target system, the structures are matched up.

**See also:**

Properties Tree Import [Page 435]
Report Template Import

Use
You use this function to import report templates (substance report templates, cover sheet templates, acknowledgements of receipt templates) to the R/3 System. In conjunction with report template export, you can exchange report templates between different R/3 Systems.

Features
When importing report templates, you can use the following functions:

File check
The R/3 System checks if the data can be transferred correctly from the transfer file, and aligns the symbols (See also: A log is created for checking the file, and you use the file to ascertain any errors made.

The R/3 System reads the following objects:

- The key for the report template
- The label for the report template
- The symbols used on the report template

<table>
<thead>
<tr>
<th>If the R/3 finds the following for a symbol in the transfer file:</th>
<th>Then the R/3 System uses</th>
</tr>
</thead>
<tbody>
<tr>
<td>One corresponding symbol in the R/3 System</td>
<td>The key for the symbol in the R/3 System</td>
</tr>
</tbody>
</table>
| No corresponding symbol in the R/3 System                     | The key for the symbol in the transfer file  
You must replace this symbol with an existing symbol or delete it after import at the very latest. Otherwise, an error will occur when you carry out the Check template function. |

Data import
Data import is carried out on the screen, and not in the background, as Word must be started to compare the symbols.

The data is transferred in the background in direct-input procedures. The R/3 System creates an import log for this.

The report template is created and the document is loaded to the Document Management System.

Activities
Importing Report Templates [Page 440]
Importing Report Templates

Prerequisites

- You have installed the current EH&S version of Windows Wordprocessor Integration (WWI) on the workstation from which you want to import the report template.
- You have generated symbols by choosing Tools → Adjust master data from the Product Safety [Ext.] screen.
- See the Prerequisites section under: Import: Process [Page 350]

Procedure


2. Please ensure that the path and file name for the transfer file and directory on the application server have been entered in the File with path field.

   `/USR/SAP/SH1/SYS/GLOBAL/REPORT.DAT`

   If the template key already exists in the R/3 System, you should change it in the *.DAT file before import to an ASCII editor.

   To correct the transfer file, choose Data transfer → Download file from the Product Safety [Ext.] screen. After making the corrections in an ASCII editor, choose Upload file.

3. Choose Edit → Check file.

   The R/3 System checks the transfer file for syntax errors, and determines the data for the report template to be imported.

4. Choose Goto → Check log. Select the log for your transfer file, choose Goto → Display messages, and check any error messages there.

5. On the initial screen for source import, choose Edit → Transfer/start time.

   The R/3 System determines the symbols in the report template. Check the list of symbol alignments. All entries in the System column must have symbol names. If they do not, check if symbol generation was carried out on your system.

6. Choose Edit → Transfer/start time.

   The report template was imported.

Result

After the report template is imported, Word is called on your workstation, and the newly imported template is loaded. The symbols are then automatically adjusted to align the symbols in your imported template with the existing symbols in your system.
This process can take some time. After the symbols have been adjusted, you can edit the report template manually.

Finally, check the template in Word by choosing *WWI → Check template*, then *File → Back to R/3*, and *Back and save*.

You can process the report templates further on the screens for report template management.
Importing Reports: Process

Purpose

Report import in the R/3 component Product Safety enables you to import Inbound Documents (IBD) into the R/3 System.

In this way, you can import material safety data sheets from the Dok-X document management system. Dok-X is a product of the company TechniDATA GmbH.

You can create further interfaces by copying the Dok-X function module and tailoring it to suit your requirements in the IMG activity Manage user exits in Customizing for Product Safety.

In theory, all document formats can be imported, provided the format has been set up in Customizing for the Document management system (DMS). An additional key file contains a reference to the file name of the document. This can have the extension *.PDF, for example, or another format.

After importing, the display in the report information system functions only if the corresponding display program is installed for the document type.

For printing and shipping, you must ensure that the WWI server can convert the relevant format into Postscript.

Prerequisites

See the Prerequisites section under Import: Process [Page 350].

A key file for the inbound report file must exist via which the R/3 System can determine the corresponding substance, the language, and the generation variant. The import date is used as the key date.

Example of a key file:

<table>
<thead>
<tr>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPN=DUPONT</td>
</tr>
<tr>
<td>DTY=SDB</td>
</tr>
<tr>
<td>PRN=LITHIUM POLYSILICATE</td>
</tr>
<tr>
<td>EDN=00001513</td>
</tr>
<tr>
<td>CTY=GB</td>
</tr>
<tr>
<td>LAC=E</td>
</tr>
<tr>
<td>STA=V</td>
</tr>
</tbody>
</table>
DAT=19.03.1996  Validity date (corresponds to the import date)

SYN=CHE - LITHIUM POLYSILICATE  Synonym name (evaluated depending on the exchange profile)

SYN_1=LITHIUM POLYSILICATE  Synonym name 2

FNA=30.PDF  File name (the extension ".PDF" is part of the name)

FFT=PDF  File type

The generation variant is determined from the details on the country and the report type (see the IMG activity *Condition schemata for SRGV selection*).

**Process Flow**

1. You use the *Check directory* function to carry out the pre-import.
   - The R/3 System determines the scope of the import.
   - The R/3 System assigns an R/3 substance, a language, and a generation variant to each report.
   
   You use an exchange profile to specify which identifiers from the key file *.KEY are to be used to assign an R/3 substance to a report.

   The *.KEY file is supplied by the Dok-X system and contains all key information for the report. The actual report is a *.PDF file and is also provided by the Dok-X system.

2. Check the check log generated by the R/3 System for pre-import.

3. Carry out the import.

   For further information, see

   Importing Dok-X-SDB Reports [Page 445]

**Result**

- After the reports have been imported to report management, you can display the key information in the *.KEY file for an inbound document.

  To do this, choose *Reports* → *Report information system* in the *Product Safety [Ext.]* screen and enter **IBD_MSDS** as report type as well as your other selection criteria.

  Choose *OK*. Select the required entry and choose *Goto* → *Additional info*.

- If you have imported a Dok-X report into the R/3 System and a report already exists in the R/3 System for this generation variant, language, and substance, the following scenarios can occur:

  If the report in the R/3 System... Then...

April 2001  443
Importing Reports: Process

- **Has the status Released**
  - The Dok-X-SDB report is newly created in the R/3 System.

- **Does not yet have the status Released**
  - The imported Dok-X-SDB report replaces the existing report in the R/3 System.

💡

After the Dok-X report is imported, it has the initial status that you specified in the generation variant.
Importing Dok-X-SDB Reports

Prerequisites
See the Prerequisites section under: Import: Process [Page 350]

Procedure

1. From the Product Safety [Ext.] screen, choose Data transfer → Reports.
   The Import reports dialog box appears.
2. Select the user exit names with which you want to carry out the import. The user exit name EHS_DXSDB (import Dok-X material safety data sheets) is proposed as standard.
3. Choose ENTER.
   The Import Reports: Parameters screen appears.
4. Check that
   – The standard exchange profile DX_SDB_IMP has been entered in the Exchange profile field
   – The correct path for the transfer directory has been entered in the Transfer directory field
5. Choose Edit → Check directory to start pre-import.
6. Choose Goto → Check log. Select the log for your transfer file, choose Goto → Display messages, and check any error messages there.
7. On the initial screen for report import, choose Edit → Transfer/start time.
   A dialog box appears in which you can define the start date. After you have saved your data, the R/3 System starts the data transfer for the start date specified.

💡 To check the procedure, choose Data transfer → Check transfer → Reports from the Product Safety [Ext.] screen.
8. On the initial screen for source import, choose Goto → Direct-Input, to display the log for the database update.
   Then choose Job administration → Execute, select the log for your transfer file, and choose Job administration → Display log. The system generates a list of all messages for the background job.
   Evaluate the messages, and make the necessary corrections.

Result
See the Result section under: Importing Reports [Page 442]
Export: Process

Purpose

This process describes the export of sources, phrases, substances, properties trees and report templates.

See the Purpose section under: Interfaces [Page 346].

Prerequisites

- You must have specified the settings in Interfaces in Customizing for Product Safety.
- You must also have authorization for export.
- You must have write authorization for the transfer files.

Process flow

1. After you have selected the objects to be exported, check the export parameters.

   When importing substances, phrases and sources, you can enter an exchange profile for which the export parameters have already been defined.

   You define exchange profiles in the IMG activity Specify exchange profiles in Customizing for Product Safety.

2. You start export, and the R/3 System runs it in the background.

More information

- Export of Sources, Phrases and Substances [Page 448]
- Properties Tree Export [Page 453]
- Report Template Export [Page 455]

Procedure

- Exporting Sources [Page 450]
- Exporting phrases [Page 451]
- Exporting Substances [Page 452]
- Exporting Properties Trees [Page 454]
- Exporting Report Templates [Page 456]

Result

1. You can check the export job you have started by choosing Data transfer → Check export → <Export object> from the Product Safety [Ext.] screen.

   Place the cursor on your job, and choose Goto → Job log. If necessary, you can display the long text for a message by choosing Goto → Long text.

2. If export is successful, the data is created in transfer format in the transfer directory on the application server.

   The export format of the data correspond to the syntax required by the import program.
3. You can download this file on your PC from the Product Safety [Ext.] screen under Data transfer → Download file.

In the same way, you can copy the file to your application server by choosing Data transfer → Upload file.
Exporting Sources, Phrases and Substances

Use

In source management, the phrase hit list or substance hit list, you can export the following objects:

<table>
<thead>
<tr>
<th>Source management</th>
<th>Phrase management</th>
<th>Substance management</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sources</td>
<td>Phrase library</td>
<td>Substance header</td>
</tr>
<tr>
<td></td>
<td>Phrase groups</td>
<td>Substance identifiers</td>
</tr>
<tr>
<td></td>
<td>Various phrases</td>
<td>Substance references</td>
</tr>
<tr>
<td></td>
<td>Phrase references</td>
<td>Substance - material assignments</td>
</tr>
<tr>
<td></td>
<td>Assignments to phrase sets</td>
<td>Substance characteristic values with additional information</td>
</tr>
</tbody>
</table>

You use drill-down reporting for phrases and substances to group phrases and substances to fit your requirements. For phrases, you can also limit the languages in which the phrases are to be imported.

Features

When exporting sources, phrases or substances, you can use the following functions:

File check

Before export, the R/3 System checks if the transfer file can be opened on the application server. If the file already exists, you can

- Overwrite the transfer file
- Rename the file

Data export

Data export is carried out in the background. The R/3 System

- Generates an export log containing information about errors that occurred
- Protects phrases and substances from changes during export
- Generates the transfer file in transfer format and stores it on the application server

If an error occurs in a substance characteristic value, this particular value cannot be exported.

You can only export R/3 data for which you have read authorization.

Activities

Exporting Sources [Page 450]
Exporting phrases [Page 451]
Exporting Substances [Page 452]
Exporting Sources

Exporting Sources

Prerequisites
See the Prerequisites section under: Export: Process [Page 446].

Procedure

1. From the Product Safety [Ext.] screen, choose Tools → Current settings.
2. Choose Create sources.
   The initial source management screen appears.

   If there is only one source, the source detail screen appears. If this is the case, in order to reach the overview screen for source management, you must go back.

3. In the overview screen, select all sources you want to export.
4. Choose Table view → Export.
   The Sources: Export dialog box appears.
5. Check the data and enter an exchange profile if necessary.
6. To update the display, choose Refresh.
   If necessary, enter the date manually.
7. Choose Export.
   The R/3 System displays the name of the background job it has started.

Result
See the Result section under Export: Process [Page 446].
Exporting Phrases

Prerequisites

See the Prerequisites section under: Export: Process [Page 446].

Procedure

1. From the Product Safety [Ext.] screen, choose Phrases → Edit phrases.

2. Enter your search criteria and choose Phrase → Navigation area → Hit list.
   You use the functions in drill-down reporting and the hit list to extend and limit the hit list display.
   See also: Searching for Phrases [Page 117]

3. Select all phrases in the phrase management hit list that you want to export, and choose Phrase → Export.
   The Phrase Management: Export - Phrases dialog box appears.

4. Check the data and enter an exchange profile if necessary.

5. To update the display, choose Refresh.
   If necessary, you can enter the date manually.

6. If you want to restrict the number of languages to be exported, choose Language selection. The system records the language selection in the transfer file.

7. If you want to plan the job for a certain time, choose Start time.

8. Choose Export.
   The R/3 System displays the name of the background job it has started.

Result

See the Result section under: Export: Process [Page 446].
Exporting Substances

Prerequisites
See the Prerequisites section under: Export: Process [Page 446].

Procedure
1. From the Product Safety [Ext.] screen, choose Substances → Edit substances.
2. Enter your search criteria and choose Substance → Navigation → Hit list.
   You use the functions in drill-down reporting and the hit list to extend and limit the hit list display.
   See also: Searching for Substances [Page 68]
3. Select all substances in the substance management hit list that you want to export, and choose Substance → Export.
   The Substance Management: Export - Substances dialog box appears.
4. Check the data and enter an exchange profile if necessary.
5. To update the display, choose Refresh.
   If necessary, you can enter the data manually.
6. If you want to plan the job for a certain time, choose Start time.
7. Choose Export.
   The R/3 System displays the name of the background job it has started.

Result
See the Result section under: Export: Process [Page 446].
Properties Tree Export

Use
This function enables you to select a properties tree in the R/3 component Product Safety and export the data. In combination with the Properties Tree Import function, you can compare properties trees between different R/3 Systems.

Prerequisites
See the Prerequisites section under: Export: Process [Page 446]

Funktionsumfang
When exporting properties trees, you can use the following functions:

File check
Before export, the R/3 System checks if the transfer file can be opened on the application server. If the file already exists, you can
- Overwrite the transfer file
- Rename the file

Data export
Data export is carried out in the background. The R/3 System
- Generates an export log containing information about errors that occurred
- Generates the transfer file in transfer format, stores it on the application server and enters the following data:
  - Data origin
  - Export date
  - Key and description for properties tree
  - All corresponding substance characteristic categories
  - All dependent elements (characteristics, descriptions, etc.)

Activities
Exporting Properties Trees [Page 454]
Exporting Properties Trees

Prerequisites
See the Prerequisites section under: Export: Process [Page 446].

Procedure
1. In Customizing for Product Safety, select the properties tree you want to export in the IMG activity Set up properties trees.
2. Choose Table view → Export.
   The Properties Tree: Export Parameters dialog box appears.
3. Check the data and overwrite them if necessary. Enter the remaining required data.
4. Choose Export.
   The R/3 System displays the name of the background job it has started.

Result
See the Result section under: Export: Process [Page 446].

See also:
Properties Tree Export [Page 453]
Report Template Export

Use
This function works in conjunction with report template import to enable you exchange report templates between different R/3 Systems. You can also exchange report templates if the R/3 Systems were set up separately and their symbol keys defined differently.

Prerequisites

- You must ensure
  - That the Word formatting is identical in source and target system
  - That the methods that can be defined for symbols are present in the target system

See the Prerequisites section under: Export: Process [Page 446]

Features
When exporting report templates, you can use the following functions:

File check
Before export, the R/3 System checks if the transfer file can be opened on the application server. If the file already exists, you can

- Overwrite the transfer file
- Rename the file

Data transfer
Data export is carried out in the background. The R/3 System

- Generates an export log containing information about errors that occurred
- Generates the following files in the transfer directory on the application server:
  - A *.DAT file containing the labels and symbols
  - A *.DOC file containing the layout of the report template

The R/3 System enters the following data in the *.DAT file:
- Data origin
- Export date
- Key and description for report template
- Key and labels for symbols

Activities
Exporting Report Templates [Page 456]
Exporting Report Templates

Prerequisites
See the Prerequisites section under: Export: Process [Page 446].

Procedure
1. Select the report template that want to export on the report template hit list (see Searching for Document Templates [Page 149]).
   The Report Template: Export Parameters dialog box appears.
3. Check the data and overwrite it if necessary. Enter the remaining required data.
4. Choose Export.
   The R/3 System displays the name of the background job it has started.

Result
See the Result section under: Export: Process [Page 446].
Exporting Reports: Process

Purpose

The R/3 component Product Safety enables you to export reports in Dok-X format. Dok-X is a document management system of the company TechniDATA GmbH.

Apart from reports in the R/3 component Product Safety, you can also use report export for scanned reports (inbound reports).

You can define your own export methods in Customizing for Product Safety. To do this, use the following IMG activities:

- Manage user exits
- Assign names for user exits

Report export is a special form of report shipping and is integrated in Report Shipping in Customizing for Product Safety.

Report shipping can be started immediately or in the background. However, report export is always carried out in the background.

Prerequisites

- To export a report,
  - It must have the status Released.
  - You must have entered a material in the report information system for which the report is to be exported.
- You have specified the settings in Interfaces in Customizing for Product Safety.
- If you are exporting a report for the first time, you must generate the report export order manually.

Procedure

Exporting Reports Manually [Page 461]

Process Flow

1. At the time for which you have planned the report RCVDDISP, the R/3 System starts report export for all automatically and manually generated export orders.

   For further information on the report RCVDDISP, see the IMG activity Set up jobs for report shipping in the Implementation Guide (IMG) for Product Safety.

Automatic Export

For reports, the R/3 System automatically creates export orders that were newly generated for report export since the last export date and have the status Released. As standard, the export orders immediately have the status Released. You can check this
Exporting Reports: Process

Standard setting in the IMG activity Check shipping reasons in Customizing for Product Safety.

Manual Export

Manual Dok-X report export is started from the report information system. When you create a manual Dok-X report export order, the R/3 System checks whether the report has already been exported. The following criteria are checked in this case:

- Substance ID of the substance for which the report was generated
- Substance ID of the substance for which the report was chosen in the report information system (see Substance Assignment [Page 272])
- Generation variant ID
- Report language
- Initiator of the Dok-X report export order
- Material name
- Internal report version

The R/3 System checks all Dok-X report export orders independent of their status. Exceptions here are orders that have the status Order created as you can delete them by using the function Reject.

If a report has already been exported, you can decide whether you want to export the report again or not.

2. The export orders are processed by the report RCVDEVEN. Customizing for Product Safety is set so that all export orders in the R/3 System are processed to the status Historical.

If old export orders in status Historical exist for a report, they are deleted.

3. The exported report is stored on the application server in the directory you specified for Dok-X report export under Interfaces → Basic Settings for Import and Export in Customizing for Product Safety.

The following files are stored on the application server:

- A key file (*.KEY) containing the key information for the report
- A DOKX-SDB file (*.PS) containing the report in Postscript format

The key file for the Dok-X report export contains the following parameters:

- DTY (document category)
  As only the export of material safety data sheets is supported in the standard system, the value SDB is assigned to this document category.
- SID (substance ID)
  Substance for which the Dok-X report export order was created.
- PRN (material name)
  Material for which the Dok-X report export order was created. The material name is determined using the same algorithm as for report shipping (see Material Name, Material Number [Page 312]).
STA (status)
This parameter is always assigned the value V.

LAC (report language)

CPN (company name)
The company name is determined by means of the initiator (sales organization) that triggered the Dok-X report export order.

FFT (file format)
The reports are always exported in Postscript format (PS) in Dok-X report export.

FNA (file name)
The file name is formed from a consecutive eight-digit number and the file extension .PS. For further information, see Specify file paths and names in the IMG for Product Safety.

DAT (generation date of the report)

VER (report version)
The report version is made up of the main and sub versions of the report.

CTY (validity area)
The validity area is assigned the leading validity area of the generation variant of the report to be exported.

Result

1. In the Product Safety [Ext.] screen you can check the report export order under Reports → Edit report shipping. Enter your search criteria and choose Report ship. order → Navigation area → Hit list.

2. The most recent Dok-X report export order for a report is always stored in the R/3 System. Older Dok-X report export orders for the same report are deleted if they have the status Historical. The R/3 System uses the following criteria to compare the Dok-X report export orders:
   - Substance ID of the substance for which the report was generated
   - Substance ID of the substance for which the report was chosen in the report information system (see Substance Assignment [Page 272])
   - Generation variant ID
   - Report language
   - Initiator of the Dok-X report export order
   - Material name
   - Main and sub version of the report and, if necessary, the date the export order was created.

3. For each new report created, the R/3 System checks whether a Dok-X report export order exists for the previous version of this report. If this is the case, a subsequent export order is created, but only if the newly created report was not already exported manually from the report information system.
Exporting Reports: Process

Automatic subsequent export is dependent on the initiator. This means that when a new version of a report is created and a number of Dok-X report export orders exist for the previous version of this report which were triggered by different initiators, a subsequent export order is created for each of these Dok-X report export orders.

Subsequent export orders are created periodically for specific time periods in the same way as subsequent shipping orders for reports.
Exporting Reports Manually

If you are exporting a report for the first time, you must generate the report export order manually.

For reports, the R/3 System creates export orders that were newly generated since the last export date and have the status Released.

Prerequisites

See the Prerequisites section under: Exporting Reports [Page 457].

Procedure

1. From the Product Safety [Ext.] screen, choose Reports → Report information system.
   The Report Information System: Initial Screen appears.
2. Enter your selection criteria and a material.
   The hits corresponding to your selection criteria are displayed in the Report Information System: Report Tree screen.
4. Select the required reports by choosing Edit → Select and choose Report → Export.
   The Export Reports dialog box appears.
5. Choose the required export method (standard method: DOKX_EXOMN) and choose ENTER.
   The R/3 System displays the number of report export orders generated.

Result

See the Result section under: Exporting Reports [Page 457].