Payments

Release 4.6C

SAP
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, RIVA, R/2, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🚨</td>
<td>Caution</td>
</tr>
<tr>
<td>📝</td>
<td>Example</td>
</tr>
<tr>
<td>🔄</td>
<td>Note</td>
</tr>
<tr>
<td>🌡️</td>
<td>Recommendation</td>
</tr>
<tr>
<td>📘</td>
<td>Syntax</td>
</tr>
<tr>
<td>💡</td>
<td>Tip</td>
</tr>
</tbody>
</table>
# Contents

## Payments ................................................................. 8

- Customizing the Payment Program ........................................ 9
- How the Payment Program Works ........................................ 10
- House Banks ........................................................................ 12

## Payment Methods ...................................................... 13
  - Country-Specific Definitions for the Payment Method .............. 14
  - Country-Specific Definitions for the Payment Method: Graphic ... 15
  - Company Code Specifications for the Payment Method ........... 16
  - Company Code-Specific Definitions for the Payment Method: Graphic ... 18

## Payment Method: Additional Specifications ....................... 19

## Bank Chains (Multi-Stage Payment Methods) ..................... 20
  - Defining Bank Chains for Customers and Vendors ......................... 22
  - Defining Bank Chains for House Banks ........................................ 24
  - Defining Bank Chains for Cash Management ................................. 25
  - Including Bank Chains on Payment Lists ...................................... 26

## Forms ........................................................................ 28
  - Specifications for the Paying Company Code ............................... 30
  - Parts of the Form ....................................................................... 31
  - Payment Form Components: Graphic .......................................... 33
  - Letter Header, Sender, and Footer ............................................... 34
  - Text Elements for Special Windows: Graphic ............................... 35
  - Text Elements in the Main Window .............................................. 36
  - Check Forms: An Example .......................................................... 38
  - Payment Run Data for the Form Printout ..................................... 39
  - Modifying the Forms ................................................................. 41
    - Form Printing Specifications .................................................... 42
    - How to Adapt a Form .............................................................. 43
    - Letter Header, Sender, and Footer ............................................. 44
    - Displaying Fields from REGUH, REGUD, and REGUP .................. 45
    - Creating Variants ..................................................................... 46
  - Print Control ........................................................................... 47

## Payment Program Settings .............................................. 49
  - Company Code Specifications .................................................. 50
  - Selecting Open Items ............................................................... 52
    - Selecting Items to be Paid ....................................................... 53
    - Company Code Specifications .................................................. 54
    - Cash Discount Strategy ........................................................... 55
    - Example: Selecting Items to be Paid ............................................ 56
    - Processing Payment Requests .................................................. 58
    - Blocking Open Items .............................................................. 59
    - Notes on Clearing Dates ........................................................... 60
  - Grouping Open Items and Individual Payments ....................... 61
    - Grouping Open Items Under Grouping Keys .............................. 62
    - Cross-Company Code Payments .............................................. 63
    - Clearing Customers and Vendors ............................................... 65
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entering Authorizations</td>
<td>125</td>
</tr>
<tr>
<td><strong>Creating the Payment Proposal</strong></td>
<td>126</td>
</tr>
<tr>
<td>Creating a Payment Proposal</td>
<td>127</td>
</tr>
<tr>
<td>Planning a Payment Proposal</td>
<td>128</td>
</tr>
<tr>
<td>Checking the Log</td>
<td>129</td>
</tr>
<tr>
<td>Displaying the Payment Proposal</td>
<td>130</td>
</tr>
<tr>
<td>Generating a Proposal List</td>
<td>131</td>
</tr>
<tr>
<td>Evaluating the Exception List</td>
<td>132</td>
</tr>
<tr>
<td><strong>Editing the Payment Proposal (Online)</strong></td>
<td>133</td>
</tr>
<tr>
<td>Editing Payments</td>
<td>134</td>
</tr>
<tr>
<td>Changing Payments</td>
<td>136</td>
</tr>
<tr>
<td>Editing Line Items</td>
<td>137</td>
</tr>
<tr>
<td>Changing Line Items</td>
<td>138</td>
</tr>
<tr>
<td><strong>Running the Payment and Payment Medium Programs</strong></td>
<td>140</td>
</tr>
<tr>
<td>Printout Control</td>
<td>141</td>
</tr>
<tr>
<td>Functions of the Variants</td>
<td>142</td>
</tr>
<tr>
<td>Checking the Payment Log and Payment List</td>
<td>143</td>
</tr>
<tr>
<td>Executing the Payment Medium Programs Separately</td>
<td>144</td>
</tr>
<tr>
<td>Scheduling the Payment Program和 Payment Medium Programs Jointly</td>
<td>145</td>
</tr>
<tr>
<td>Starting the Payment Medium Programs Online</td>
<td>146</td>
</tr>
<tr>
<td>Recognizing and Eliminating Form Printing Errors</td>
<td>147</td>
</tr>
<tr>
<td><strong>Payment Medium Workbench</strong></td>
<td>148</td>
</tr>
<tr>
<td>Creating Payment Media</td>
<td>150</td>
</tr>
<tr>
<td>Payment Medium Format</td>
<td>153</td>
</tr>
<tr>
<td>Payment Medium Format Supplement</td>
<td>155</td>
</tr>
<tr>
<td>Note to Payee</td>
<td>156</td>
</tr>
<tr>
<td>Alternative Payer, Alternative Payee</td>
<td>158</td>
</tr>
<tr>
<td>Selection Variants</td>
<td>159</td>
</tr>
<tr>
<td>Data Medium Exchange Engine</td>
<td>161</td>
</tr>
<tr>
<td>Format Tree Definition</td>
<td>162</td>
</tr>
<tr>
<td>Screen Layout</td>
<td>163</td>
</tr>
<tr>
<td>Nodes</td>
<td>164</td>
</tr>
<tr>
<td></td>
<td>Header</td>
</tr>
<tr>
<td></td>
<td>Node Types</td>
</tr>
<tr>
<td></td>
<td>Creating Nodes</td>
</tr>
<tr>
<td></td>
<td>Conditions</td>
</tr>
<tr>
<td>Data Mapping</td>
<td>169</td>
</tr>
<tr>
<td></td>
<td>Source Field Inventory</td>
</tr>
<tr>
<td></td>
<td>Conversion of Source Data</td>
</tr>
<tr>
<td></td>
<td>Aggregation</td>
</tr>
<tr>
<td></td>
<td>Exit Modules</td>
</tr>
<tr>
<td></td>
<td>Activating Format Trees</td>
</tr>
<tr>
<td></td>
<td>Checks</td>
</tr>
<tr>
<td></td>
<td>Testing Active Format Trees</td>
</tr>
<tr>
<td></td>
<td>Transporting Format Trees</td>
</tr>
<tr>
<td></td>
<td>Format Tree Maintenance</td>
</tr>
<tr>
<td></td>
<td>Generation of Data File Using DMEE</td>
</tr>
<tr>
<td><strong>Data Medium Exchange and Data Medium Administration</strong></td>
<td>182</td>
</tr>
</tbody>
</table>
Outputting the DME File into the SAP System.........................183
Outputting the DME File into the File System........................184
Creating a Payment Medium Report Variant............................185
Running the Payment Medium Program.................................186
Data Medium Administration..................................................187
Downloading a DME File onto Disk...........................................189
Deleting DME Administrative Data Across Company Codes......190
Payment Orders........................................................................191
Payment Requests....................................................................194
Payments

Purpose
You can use the payment program to process international payment transactions with customers and vendors.

Information on payment transactions in Euro can be found by choosing "Cross-application components" and then "European Monetary Union", and also in the SAP Library under European Monetary Union: Euro (CA-EUR) [Ext.]

Implementation Considerations
Configuration of the payment program is described in Customizing the Payment Program [Page 9]

Integration
The payment program is used by the following components: Accounts Receivable (FI-AR), Accounts Payable (FI-AP), Treasury (TR), and Bank Accounting (FI-BL).

Features
The payment program lets you handle both outgoing and incoming payments. It is flexible enough to allow you to define those payment features that vary from country to country such as payment method, payment form, or data carrier specifications.

The standard system contains the common payment methods and the corresponding forms that have been defined separately for each country.

The standard payment methods include check, transfer, and bill of exchange. Country-specific payment methods, such as the POR procedure in Switzerland, the bill of exchange payment request, and the PBC procedure have also been defined.

Other special features include:
- Clearing open items between customers and vendors
- Inter-company payments, that is one company code pays centrally for others
- Paying or clearing any type of open item, for example clearing down payments
- Restricting access to the payment program by assigning authorizations
Customizing the Payment Program

This section describes how to make the necessary specifications for the payment program.

Before you can use the payment program, you need to define:

- Your house banks and the accounts at your banks
- The required payment methods
- The necessary payment forms
  
  The standard system has predefined payment methods and payment forms. You can copy them and adapt them to meet your own requirements.

Payment program configuration involves determining:

- **What is to be paid.** To do this, you specify rules according to which the open items are selected and grouped for payment.

- **When payment is carried out.** The due date of the open items determines when payment is carried out. However, you can specify the payment deadline in more detail via configuration.

- **To whom the payment is made.** You specify the payee.

- **How the payment is made.** You determine rules that are used to select a payment method.

- **From where the payment is made.** You determine rules that are used to select a bank and a bank account for the payment.

The above rules and conditions must be defined if the payment program is to determine the above-mentioned information automatically. However, you can also specify this information manually.

Most of the aforementioned specifications are company code-specific, enabling you to configure the payment program to suit the differing requirements of each company code.

- The settings for the payment program are made under *Payment Program* in the Accounts Receivable and Accounts Payable section of the Implementation Guide.

- Payment forms are defined by following the menu path *Tools → Word processing → Layout set* from the R/3 System initial screen.

- To define printers and character sets, select *Tools → Administration → Spool → Spool administration* or *Spool → Font maintenance*.
How the Payment Program Works

Purpose
With the payment program you can process international payment transactions involving your customers and vendors.

Prerequisites
The Payment Methods [Page 13], House Banks [Page 12], and Forms [Page 28] you use must be defined or adapted before the payment run is executed.

If the above-mentioned steps are to be carried out automatically, the payment program requires the following information:

- Rules according to which it can determine the open items to be paid and, if expedient, group them together for payment. For example, you can specify grace periods for incoming items, which are taken into consideration when calculating the due date.
  - Specifications for selecting the payee. You can enter an alternative payee in your customer/vendor's master record or in the document itself.
  - Rules used by the payment program to select the payment methods. You can specify payment methods via your customer or vendor's master record or via the open items, or you can have the payment program select them using specified rules.
  - Rules used by the payment program to select the house bank from which the payment is made. House banks are banks where your company (company code) maintains accounts. You can specify a house bank in your customer/vendor's master record or in the line item, or you can have the payment program select it using specified rules.
  - Specifications for automatic postings. The payment program requires information such as document types, posting keys and accounts, in order to carry out the automatic postings.

You set the rules for controlling the payment program

- In the customer/vendor master record
- In the line items
- via configuration of the payment program
  - With individual specifications for each payment run

You can find further information in Payment Program Settings [Page 49]

Process Flow
The program processes open items in three steps (see the figure Processing Open Items [Page 115]):

1. It determines the open items to be paid and creates a proposal list. You can process the proposal list on-line. Among other things, you can change payment methods or banks, block items, or cancel payment blocks.

2. The payment program carries out payment using the proposal list. The payment run includes only the open items contained in the proposal list. The payment program posts
documents and provides the data for the form printout and for creating the data carriers, the payment advice notes and the payment summaries.

3. It uses the print program to print the forms and create the data carriers.
House Banks

The banks with which your company (company code) maintains a bank account are referred to as house banks.

You define these banks in the system under a house bank key (bank ID). You store the accounts that you maintain at these banks under an account ID. For each bank account, you create a G/L account in the SAP system.

Bank master data is stored centrally in the SAP system. This includes address data and other control data, such as the SWIFT code. You require bank master data for your house banks and for your customer or vendor's banks. By specifying the country and a country-specific key, such as the bank number or the SWIFT code, you establish the connection between your house banks and the bank master data (see the figure below). The bank details are required for printing the payment forms.

You can find out how to create bank master data in Bank Master Data [Ext.] and Configuring the System Using the Implementation Guide [Ext.] under "Bank-Related Accounting."

<table>
<thead>
<tr>
<th>Company Code</th>
<th>House Bank</th>
<th>Bank Country</th>
<th>Bank Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>001</td>
<td>COMBA</td>
<td>D</td>
<td>670 400 31</td>
</tr>
<tr>
<td>001</td>
<td>DEUBA</td>
<td>D</td>
<td>672 700 03</td>
</tr>
<tr>
<td>001</td>
<td>DREBA</td>
<td>D</td>
<td>672 922 00</td>
</tr>
<tr>
<td>001</td>
<td>PGIRO</td>
<td>D</td>
<td>660 100 75</td>
</tr>
</tbody>
</table>
Payment Methods

The payment method is the procedure such as check, transfer, or bill of exchange, by which payments are made.

The following payment methods are usual in Accounts Payable and Accounts Receivable:

Payment Methods in the System

<table>
<thead>
<tr>
<th>Accounts Payable</th>
<th>Accounts Receivable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check</td>
<td>Bank collection</td>
</tr>
<tr>
<td>Transfer</td>
<td>Bank direct debit</td>
</tr>
<tr>
<td>Postal giro transfer</td>
<td>Refund by check</td>
</tr>
<tr>
<td>Bill of exchange</td>
<td>Refund by bank transfer</td>
</tr>
<tr>
<td>Check/bill of exchange</td>
<td>Bank bills</td>
</tr>
<tr>
<td></td>
<td>Bill of exchange payment request</td>
</tr>
</tbody>
</table>

You define the payment methods in two steps:

1. First, you make all the specifications that are required for each payment method in each country. This is necessary for all the payment methods used by your organization in each country. If you have companies (company codes) in Germany, France, and the USA for example, you define the payment method "check" for each country.

2. You then define the payment methods you use for each company code. When in this configuration function, you also specify the conditions of their use.

For more information, see Notes on the Payment Method [Page 70]
Country-Specific Definitions for the Payment Method

The payment methods that are used in at least one of your organization's company codes are defined as follows. Country-Specific Definitions for the Payment Method: Graphic [Page 15] shows those specifications used for the payment method "check" in Germany.

You classify a payment method by selecting the characteristics that are to apply to it (see (1) of the graphic). The program uses this information to determine the data required for the payment forms and data media.

You must also define which information from the customer/vendor master record is to be used to determine the payment method (see (2) of the diagram). If this information is missing from the customer/vendor master record, the payment method cannot be used.

In the standard system, the payment method "check" (for Germany) is configured such that a check is created (classification). The street or P.O. Box must be contained in the customer or vendor master record.

These specifications are supplemented with other specifications for posting the payment documents and printing the forms (3) and (4).

For the payment method "check", document type "KA" is used and the print program RFFOD_S.

All the payment medium programs are documented in detail in the language of the country of use. If you want to have the system list all the standard payment medium programs available, proceed as follows:

1. Choose System → Services → Reporting. Enter RFFO* and select the function Utilities → Find.
2. Enter FORD in the Program category field and execute the search. The system will generate a list of all payment medium programs in the system. The name of each program gives you an indication of its purpose.
Country-Specific Definitions for the Payment Method: Graphic

Country UK United Kingdom
PytMthd C
Description Check

PytMthd for
- Outgoing payments
- Incoming payments

Classification of pymt mthd
- Bank transfer
- Check
- Bill of exchange
- Check/bill of exchange

Necessary details in master record
- Street, P.O. Box, or P.O. Box postal code
- Bank details
- Collection authorization

Posting details
- Document type for payment: ZS
- Document type for clearing: ZV
- Special G/L ind. bill/ex. pymt request
- Only payment order

Pyt medium
- Create conventional payment medium (RFF0*)
- Payment medium program: RFF0D_S
- Name of print dataset: LIST1S
- Use new payment medium tool
- Format: 01
- Key in coding line: 01
- Print dataset for bills/exch.
- Format supplement
Company Code Specifications for the Payment Method

The conditions under which each payment method is used must be defined for each company code that makes payments. (Company Code-Specific Definitions for the Payment Method: Graphic [Page 18] shows those specifications that are used for the payment method "check" in Germany).

- To do this, enter a minimum and a maximum amount for a payment (1). This tells the program the value range within which the payment method can be selected by the payment program. Note that unless you specify a maximum amount, the payment method cannot be used at all. This value range does not apply if the payment method is specified in the open item.

- You also specify whether the payment method can be used for foreign payment transactions. You specify whether payment is made if
  - The customer or vendor is based abroad (2)
  - The bank to which the payment is made is based abroad (3)

- You specify whether it is possible to use the payment method in question to pay in foreign currency (4) in which case any currency can be used.
  
  You can also specify particular currencies per payment method and country. If this payment method is selected, payments are only processed in one of the currencies specified.
  
  If you wish to define particular currencies, choose the function Currencies in the country-specific details for each payment method.

  If the payment method allows only payments in local currency, then any foreign currencies you may have defined are ignored.

- During a transition phase, both the existing local currency and the EURO can be used for domestic bank transfers. To enable this, define payments in foreign currency as permitted for the payment method Bank transfer and the EURO and the existing local currency are possible currencies.

- You can use a payment method such as EURO bank transfer for certain currencies only.

- You use foreign currency checks with pre-printed currency key (for example USD checks) and you wish to set up a payment method with which you make payments in USD only, whereby USD is not your local currency.

- You specify if the payment method should include the attribute Payment per Due Date. This indicator ensures that a payment will be created for each due date. Items to be paid are then grouped according to due date, and instead of one payment being generated, as many payments are generated as there are different due dates.

  For the payment method "check", you do not specify any minimum amount limits since this payment method is used if other payment methods cannot be used. You
must specify a maximum amount because otherwise the payment method cannot be used. The customer or vendor can be located abroad. The customer/vendor’s bank is irrelevant for check payments. Foreign payment transactions are therefore possible. Payments in foreign currencies are permitted.
Company Code-Specific Definitions for the Payment Method: Graphic

**Amount limits**
- Min. amount: 0 USD
- Max. amount: 999,999.99 USD

**Grouping of items**
- Separate payment for each ref.
- Payment due per day

**Control of bank selection**
- Not optimized
- Optimization by bank group
- Optimization by postal codes

---

**Form details**

**Pymt adv. note control**
Payment Method: Additional Specifications

You can define additional specifications (Mailstop codes) per company code. The payment program groups payments according to these specifications. For each additional specification made, a separate payment will be carried out. In the payment medium programs, you can select and sort where needed according to an additional specification. Correspondence can also be sorted using this criterion.

You can define proposed values for the additional payment method specifications in the customer and vendor master records. During data entry, these values will be displayed as defaults which can be selected or overwritten.

As an example, you can use additional specifications for controlling the issuing of checks. The specification could divert checks to be sent to partner firms by interoffice mail, instead of through the postal system. There are various conceivable internal distribution channels here too. Each internal distribution channel can be represented by a payment method supplement. This will greatly simplify operations with multiple mail systems, since checks can be separated by additional payment method specification at the time of printing.
Bank Chains (Multi-Stage Payment Methods)

Use

Bank chains [Ext.] are used to make payment via more than one bank, for example via the correspondence banks of the house bank, the recipient bank, or the intermediary banks. You can define up to three banks.

Before the advent of this function, when making a payment to a business partner abroad, you had to specify your house bank and the business partner’s bank when processing payments. These two banks represented the start and end of the payment cycle and it was down to the house bank to determine via which banks the payment should be made. Using the bank chain function, you can now specify this bank chain yourself, leading to faster payment transaction processing and considerable cost savings through reduced bank charges.

Integration

To use the bank chain function, you must also implement the function Automatic Payments in either the Financial Accounting (FI) or the Treasury (TR) application component.

For more information on automatic payments in Financial Accounting, see Payments [Ext.] For more information on automatic payments in Treasury, see Payment Program for Payment Requests [Ext.]

Features

For each payment, the payment program can determine a combination of intermediary banks that you previously defined. The order of the banks in the bank chain can depend on the following factors:

- House bank
- Vendor’s bank details
- Customer’s bank details
- Treasury business partner’s bank details
- Currency
- Payment method supplement

These factors are represented in the R/3 System by means of scenarios for bank chain determination that you define in Customizing for Bank Accounting, as described under Activities below.

If you carry out a payment run (whether for open items or for payment requests from Treasury or Cash Management) the system determines the bank chain according to your Customizing settings and those you made in the master data. If, during payment proposal editing, you have changed an entry (house bank or partner bank for example) that is relevant to bank chain determination, the system re-determines the bank chain, which is then displayed on screen.

The system is only able to determine the bank chain if a payment method is used for which a bank chain is needed (no bank chain is determined for payments by check for example.)
When processing payments, you can use program RFZALI20 to create a payment list and an exception list. The payment list contains a summary of all payments and line items. The exceptions list contains blocked line items and open items that the payment program did not propose for payment. In the standard system, the bank chain is not included on either list. If you want to have the bank chain output on the payment or exception list, see Including Bank Chains on Payment Lists [Page 26]

Bank chains are transferred each time a payment medium is created. The following formats are supported in this process:

- S.W.I.F.T MT100
- S.W.I.F.T MT200
- S.W.I.F.T MT202
- EDI (Basis-IDOC: PEXR2002)
- Sending of payment data by ALE (Basis-IDOC:FIARQ01)

**Activities**

1. Copy one of the scenarios that are delivered in the standard system or define a new scenario.
   To do so, in Customizing for Bank Accounting choose Bank Chains → Define Scenario [Ext.]

2. Activate the scenario.
   To do so, in Customizing for Bank Accounting choose Bank Chains → Activate Bank Chain [Ext.]

3. If you want payments to be made via a bank chain and independently of a business partner's bank details, define a general bank chain.
   To do so, in Customizing for Bank Accounting choose Bank Chains → Create General Bank Chain [Ext.]
   If you want payments to be made via a bank chain and dependent on a business partner’s bank details, define a partner-specific bank chain.
Defining Bank Chains for Customers and Vendors

Use
The purpose of this activity is to specify which bank chain is to apply for a given customer or vendor.

Prerequisites
You have already defined the master data for the customer or vendor.

Procedure
   The system now displays the Banking screen.
3. Enter the customer or vendor account number and select the indicator for the payment direction (incoming or outgoing payment). If necessary, enter the appropriate data in the parameters Company code, House bank, Account, Currency, and Payment method supplement. Choose Execute.
   The system displays a list of partner banks.
   In the Vendor field, enter KRED1 and select Outgoing payment.
4. Choose the required bank. If a bank chain did not already exist, the system displays a message alerting you to this fact.
   The system displays the Bank Chain per Business Partner Account screen.
5. Choose Edit → New entries and enter the desired specification for the bank chain. Bank chains are specified per Currency and (if necessary) also per Sender bank country, Sender bank key and Payment method supplement.
   Enter DEM in the Currency field.
6. Choose Bank chain per business partner account, followed by Edit → New entries and enter the required bank chain by specifying the:
   - Bank number
   - Bank category (correspondence bank of the sender, intermediary bank, sender’s correspondence bank)
   - Country
   - Bank key
   - Bank account of the correspondence or intermediary bank
### Defining Bank Chains for Customers and Vendors

<table>
<thead>
<tr>
<th>No.</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cat</td>
<td>2 (intermediary bank)</td>
</tr>
<tr>
<td>Corr.Ctry</td>
<td>DE</td>
</tr>
<tr>
<td>Corr.Bank key.</td>
<td>111222</td>
</tr>
<tr>
<td>Bank account</td>
<td>GIRO</td>
</tr>
</tbody>
</table>

7. Save your entries.

**Result**

You have now created a bank chain for a customer or vendor partner bank for outgoing or incoming payments.
Defining Bank Chains for House Banks

Use
Here you define which bank chain applies for incoming or outgoing payments for a given house bank.

Prerequisites
You have created the master data for the house banks.

Procedure
   The system displays the Banking initial screen.
2. Choose Master data → Bank chain → House banks → Edit.
3. Enter a Company code, together with a Payment currency and/or a Payment method supplement. Choose Execute.
   The system displays a list of house bank accounts in the company code.
4. Choose the required bank.
   The system displays the Bank Chain per Business Partner Account screen.
5. Specify the required bank chain. Choose Edit → New entries. Enter the Currency, and if necessary the Sending bank country, the Sending bank key, and the Payment method supplement.
6. Choose Payment methods per business partner account followed by Edit → New entries. Enter the bank number, bank category, bank country, bank key, and the Bank account of the correspondence bank.
7. Save your entries.

Result
You have now defined a bank chain for incoming payments to a house bank account.
Defining Bank Chains for Cash Management

Use
To define bank chains for Cash Management.

Procedure
   The system displays the Banking screen.
2. Choose Master data → Bank chain → Bank account carry over → Edit.
   Enter a company code, the house bank and the bank account of the sending and receiving bank. Select the appropriate payment direction indicator (incoming or outgoing payment). You may also wish to enter a Payment currency and Payment method supplement. Choose Execute.
   If no bank chain exists, the system outputs a message informing you that a new entry will be created.
3. Choose Edit → New entries and specify the bank chain for the appropriate bank. To do this, enter the Currency and (if necessary) a Payment method supplement.
4. Choose Payment methods per business partner account and Edit → New entries and enter the bank chain by entering the bank number, the bank category (correspondence bank of the sender, intermediary bank, recipient's correspondence bank), the Bank country, the Bank key and the Bank account of the correspondence or intermediary bank.
5. Save your entries.

Result
You have now defined a bank chain for Cash Management.
Including Bank Chains on Payment Lists

Use

In the standard system, the bank chain [Ext.] is not printed on the payment list or the exception list. If you want the system to include the bank chain on the printout, carry out the technical modifications detailed below.

Procedure

1. Create CUSTOMER INCLUDE

The ABAP dictionary structures REGUH_LST (header information) and REGUP_LST (line item information) contain the output fields provided by program RFZALI20. Add the fields you require (the field CHAINTEXT for example) to the CI_INCLUDE CI_REGUH_LST with the following attributes:

<table>
<thead>
<tr>
<th>Field name</th>
<th>Data element</th>
<th>Type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHAINTEXT</td>
<td>CHAINTEXT</td>
<td>CHAR</td>
<td>92</td>
</tr>
</tbody>
</table>

Bank chain as text

Proceed as follows:


b. Select Structures, enter CI_REGUH_LST and choose Create.

The system displays a dialog box. Choose Enter.

c. Enter the required field name (CHAINTEXT for example).

You can search for the corresponding data element (CHAINTEXT for example) by choosing the possible entries key in the Type name field. Choose Execute.

d. Save the INCLUDE structure.

2. Define Business Transaction Event “00002110”

You can use the Business Transaction Event “00002110” to enter data in the fields (CHAINTEXT for example) added using CI_INCLUDE.

Proceed as follows:

a) Copy the sample function module SAMPLE_INTERFACE_00002110 and enter the required source text (from function module FI_BL_BANKCHAIN_RFZALI20 for example) in your function module. To do so, choose Tools → ABAP Workbench → Development → Function Builder. Field CHAINTEXT is filled in this function module and then made ready for output. Note that all the command lines are deactivated in this module.

b) You now need to create a product for the Publish & Subscribe interface.

ii. Create a new product by choosing Edit → New entries.

iii. Enter the necessary data and save your entries.

iv. Choose Settings → P/S function modules → …of a customer.

v. To create a new function module for the Publish & Subscribe interface, choose Edit → New entries.

vi. Enter Event 00002110, the product, and the function module SAMPLE_INTERFACE_00002120. Save your entries.

For information on the use of business transaction events, see the Financial Accounting Global Settings section of the Implementation Guide.

**Result**

The bank chain is now ready for output in the payment list.
Forms

Various programs are available for printing payment forms. In some cases, the print programs are country-specific. You specify the program to used for a payment method when you make the country specifications for the payment method. See Country-Specific Definitions for the Payment Method: Graphic [Page 15] (4) This prevents the payment program from selecting the wrong print program when printing is carried out.

You also specify a name for the print job in print administration, under which the data for the payment transfer is stored temporarily. See Country-Specific Definitions for the Payment Method: Graphic [Page 15] (4)

To ensure that the programs print the forms correctly, the system specifies which data is printed in which position. The form layout is defined with SAPScript. You specify the name of the defined payment form when you make the company code specifications for the payment method. See the figure below, (1). You also determine how many invoice items can be printed out in the part of the form which serves as the note to the payee. See the figure below, (2). If more items are to be paid than can be listed on a form, you specify whether

- A payment advice should be printed. See the figure below, (3)
- Several forms should be created. See the figure below, (4)

You also store the address data of the issuer of the form. See the figure below, (5). This data is used by the print program.

You define the form that is used for printing a payment advice separately. You then specify this form when making the specifications for the paying company code. See Specifications for the

The standard system contains pre-defined forms for the standard payment methods. You can copy them and adapt them to your requirements.
# Specifications for the Paying Company Code

### General Specifications

<table>
<thead>
<tr>
<th>Specification</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum amount for incoming payment</td>
<td>1.00 USD</td>
</tr>
<tr>
<td>Minimum amount for outgoing payment</td>
<td>5.00 USD</td>
</tr>
<tr>
<td>No exchange rate differences</td>
<td>✓</td>
</tr>
<tr>
<td>Form for the payment advice</td>
<td>F110_D_AVIS</td>
</tr>
<tr>
<td>EDI accompanying sheet form</td>
<td>Display form</td>
</tr>
</tbody>
</table>

### Bill of Exchange Creation

- One bill of exch. per due date interval
- One bill of exch. per due date
- One bill of exch. per invoice

### Use of Payment Reference

- Separate payment for each ref.

### Due Date of Bill of Exchange/Invoice Requests for Incoming Payments

- Latest due date in days
- Bill on demand with due date up to days

### Due Date for Outgoing Payments

- Earliest due date in days
- Latest due date in days
Parts of the Form

A payment form is usually no longer than one page. In the SAP System, the form page is divided into different windows. The figure Payment Form Components: Graphic [Page 33] shows some of the text windows defined for checks in Germany. These are:

Text Window for Checks

<table>
<thead>
<tr>
<th>Window</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>HEADER</td>
<td>Company specifications, such as the company name or the company logo</td>
</tr>
<tr>
<td>PAGE</td>
<td>Page number</td>
</tr>
<tr>
<td>INFO, INFO 2</td>
<td>Date, document number, your account with the vendor, clerk etc.</td>
</tr>
<tr>
<td>ADDRESS</td>
<td>Sender specifications for window envelopes and receiver address</td>
</tr>
<tr>
<td>MAIN</td>
<td>Text, line item information from the payment run and total amount</td>
</tr>
<tr>
<td>CARRYFWD</td>
<td>Carry forward, starting from the second page (where form is longer than one page) form overflow</td>
</tr>
<tr>
<td>CHECK</td>
<td>Check</td>
</tr>
<tr>
<td>CHECKADD</td>
<td>Check address</td>
</tr>
<tr>
<td>CHECKSPL</td>
<td>Amount in words</td>
</tr>
<tr>
<td>SUMMARY</td>
<td>Check form summary</td>
</tr>
</tbody>
</table>

You determine the windows and their position on the page when defining a form. You enter a specific text for each window. This text is referred to as a text element.

You can enter various different texts for the HEADER, ADDRESS, and FOOTER windows, and the opening/closing form in the MAIN window for each company code. See Letter Header, Sender, and Footer [Page 34].

The MAIN window is processed in a special way. You can define several text elements for this window. The text elements offer you the chance to enter different texts for a window, which are then printed (depending on the print data set offered by the payment program). Read Text Elements in the MAIN Window [Page 36]

For information that the system fills in automatically at the time of the payment run, you define symbols in the text element. These are replaced by the appropriate data when the payment form is printed. In the MAIN window (see the figure Check Forms: An Example [Page 38] for example, you can see the document number of each open item or the cash discount amount calculated for the invoice amount. In both cases, the information is not entered in the form until the payment run takes place. Symbols were entered in the text element to represent this data.

See also:
Payment Run Data for the Form Printout [Page 39]
Parts of the Form
Payment Form Components: Graphic
Letter Header, Sender, and Footer

For each of the forms in the SAP system, windows have been defined for the letter header, the sender specifications in the letter window (see the above figure) and the footer text. You can enter text in these windows in three ways. In the figure Text Elements for Special Windows: Graphic [Page 35] is an example.

Since the texts for the above-mentioned windows are company code-specific, you must specify whether you are working with one or several company codes:

- You can enter a fixed text in the form window text element. You should do this only if you use the form for a single company code.

- You can define a standard text for several forms. Enter the name of the standard text in the text elements of your choice in several forms. However, this is only worth doing if you work with one company code but want to use one text for several forms. In the figure above, the standard text "ADRS HEADER" was used, for example.

- You can define standard texts for several forms, and specify (depending on the dunning area and company code involved) which text should be used in the form. You are advised to do this if you work with several company codes that use the same form. Three steps are necessary to do this:
  - Create the company code-specific standard texts.
  - When configuring the dunning program, specify which standard text is to be used for which company code.
  - In the text element, enter a standard variable for the standard text (see the table below). Depending on the company-code in question, the print program replaces the variable with the name of the standard text.

The variables for the company code-specific standard texts that you specify in the text element are predefined in the system:

**Symbols for Standard Texts**

<table>
<thead>
<tr>
<th>Standard text for</th>
<th>Symbols in the Text Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Letter header</td>
<td>REGUD-TXTKO</td>
</tr>
<tr>
<td>Sender in the letter window</td>
<td>REGUD-TXTAB</td>
</tr>
<tr>
<td>Signature line</td>
<td>REGUD-TXTKO</td>
</tr>
<tr>
<td>Footer</td>
<td>REGUD-TXTFU</td>
</tr>
</tbody>
</table>
Text Elements for Special Windows: Graphic
Text Elements in the Main Window

Text Elements in the Main Window

The MAIN window contains a series of text elements. Each element is indicated by /E in the format column and a number in the text area (see the figure below). The print program will then print these text elements in the form, providing they are defined in the print data set.

You define text for order checks and checks in the check form. If the print dataset contains information for the payment method "check", the program uses the text for checks.

The following table contains some text elements for a check form from the MAIN window.

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>510-O</td>
<td>Text for order checks</td>
</tr>
<tr>
<td>510-C</td>
<td>Pre-numbered checks</td>
</tr>
<tr>
<td>510-S</td>
<td>Text for checks</td>
</tr>
<tr>
<td>515</td>
<td>Heading for line item information</td>
</tr>
<tr>
<td>525</td>
<td>Line item information</td>
</tr>
</tbody>
</table>

By using various text elements, you can use the same basic forms for similar payment methods, differentiating them simply by inserting different text elements (specific to the payment method being used) in the MAIN window. The print program determines the correct text element on the basis of the specifications stored under the payment method being used. As an example, the figure below shows how the text elements are defined for the MAIN window in the check form.
If you want to define your own form and use text elements specific to the payment method, you should keep to the following conventions when creating the text element name:

- The first three characters are determined by the program.
- These characters are followed by a hyphen.
- You then specify the payment method. In the USA, for example, you could enter C for check and O for order check.

For the forms, the print program always uses the text elements that have been specified for the payment method in question. Text elements that are to be printed out for all payment methods which use this form should be entered as a three-digit number only.

The text elements that can be used for forms are already defined in the system. All that you can change for each text element is the text. You can formulate this as you wish. You can find further information in the documentation for the individual print programs.
Check Forms: An Example

Dear Sir/Madam,

Please find enclosed a check for payment of 2000000026, with which we have settled the items, assuming that the goods/services in question delivered/performed as ordered and priced.

regards,
IDES Holding Inc.

<table>
<thead>
<tr>
<th>Document</th>
<th>Your doc.</th>
<th>Date</th>
<th>Deductions</th>
<th>Gross amnt</th>
</tr>
</thead>
<tbody>
<tr>
<td>1900000155</td>
<td>C652555</td>
<td>11.16.1998</td>
<td>83.00</td>
<td>3,100.00</td>
</tr>
<tr>
<td>1900000156</td>
<td>F626266</td>
<td>11.16.1998</td>
<td>156.00</td>
<td>5,200.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>249.00</td>
</tr>
</tbody>
</table>

Total amount

** EIGHT THOUSAND AND FIFTY ONE USD **

NAME

Go West Shipping,
P.O. box 1234,
Newark, DE 19711.
Payment Run Data for the Form Printout

The data from the payment run that you require for the form printout is provided by the payment program. The payment program stores this data after each payment run in the following structures:

- **REGUH**
  
  Contains the information on the payment, such as the payment method, payment document number, and payee. The payment program creates a REGUH record for each payment.

- **REGUP**
  
  Contains the information on the paid items, such as the amount, cash discount, and invoice document number. The payment program creates a REGUP record for each paid item in a payment.

- **REGUD**
  
  Contains derived values that are not contained in the above-mentioned files. These include information from the customer/vendor bank master record, amounts with protective asterisks, or amounts without editing characters for the OCRA line. This structure is filled by the print program and then deleted after the payment transfer medium is printed.

- **SPELL**
  
  Contains the payment amount in words.

All the fields in these structures can be used as symbols in the form. You can also transfer field contents from any configuration tables in the system. The prerequisite is that these are read by the appropriate print program.

For the corresponding form, text elements have been defined for the individual windows as follows:

1. **HEADER, ADDRESS and FOOTER**
   
   For this window, company code-specific standard texts have been defined. See Text Elements for Special Windows: Graphic [Page 35] (3). The names of the texts have been specified for each window (dependent on the company code) in the configuration of the payment program. When the form is printed, the print program determines and inserts the appropriate text.

2. **MAIN**
   
   The **MAIN** window contains several text elements: one text element each for the text, the header line, the line item information, and the total amount. The document numbers, dates, currency keys, and amounts are provided after the payment run. Symbols have been defined in the appropriate text elements for this data. For example, the variable &REGUP-BELNR& has been entered for the document number and the variable &REGUP-BLDAT& for the document date.

3. **CHECK**
   
   The **CHECK** window contains the information that is printed on the actual check. Symbols have been defined in the text for such information from the payment run. Using
Payment Run Data for the Form Printout

these symbols, the print program determines the check number, account number, bank number, and amount, for example.
Modifying the Forms

The standard system contains an appropriate country-specific form for every standard payment method. These forms can be copied and modified as necessary. This new form must then be assigned to the respective payment methods (via the company-code-dependent definitions: See Form Printing Specifications [Page 42]). You can change the standard texts, the position of the windows or the highlighting of individual words and letters. If you need other information from the payment run in your forms, you can insert the appropriate symbols into your text elements. This allows you to use the field contents from the structures REGUH, REGUP, REGUD, SPELL, and FASBE for your form. You can look at which fields are contained in the above-mentioned files via the Data Dictionary.
# Form Printing Specifications

<table>
<thead>
<tr>
<th>Form Printing Specifications</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Paying Co.Cd.</strong></td>
</tr>
<tr>
<td><strong>Pymt Mthd</strong></td>
</tr>
</tbody>
</table>

## Forms
- **Forms for payment**: F110_D_SCHECK
- **Additional forms**: Display form
- **Correspondence sorting**: Display form

## Printing paid items
- **Items per form**: 99
- **Message if page exceeded**: 3
- **Extra forms if page exceeded**: 4

## Specifications on the form
- **Issuer**
  - Name
  - Address1
  - Address2
How to Adapt a Form

If you cannot use the standard forms in the SAP system, you must create your own forms. You can do this by copying the standard forms and modifying them where necessary.

Carry out the following steps from the initial SAP menu:

1. Choose **Tools → Word processing → Layout sets.**
   
   You reach the initial screen for word processing.

2. Specify the name of your form and select **Create/change.**
   
   Your forms should begin with the letter " Z". This is a protected name format that is not used by SAP.

3. A dialog box appears. Here you enter a customer development class or specify that you will be using a local private object.

4. You reach the display of the general definitions for the form.
   
   From here, you can transfer specifications and text elements from another form (e.g. the SAP standard form) into your form.
   
   To do so, choose **Layout set → Copy from.** Via the entry Go to you can select the required specifications for your form.

Further information about how to adapt a form can be found in the documentation for SAPScript word processing.
Letter Header, Sender, and Footer

You determine your standard texts for letter header, sender and footer when you carry out the following steps from the initial SAP menu:

1. Select Tools → Word processing → Standard text.
   You reach the initial screen for word processing.
2. Specify the name of the text and select Standard text → Create/change.
3. You reach a screen for text entry.

Further information for changing or entering standard texts can be found in the documentation for SAPScript word processing.

You can specify the standard texts directly in the text elements if you are not using different texts for different company codes.

To specify the standard texts for each company code, carry out the following steps in Customizing for Accounts Receivable and Accounts Payable:

1. Choose Configure payment program.
   You reach the initial screen for the configuration of the payment program.
2. Choose Company codes → Paying.
   A list of the paying company codes is displayed.
3. Select the company code you require.
4. Choose Goto → Sender details.
5. Enter the names of the standard texts for letter header, sender and footer.
6. Save your entries by choosing Company codes → Save.

If you use company-code-dependent standard texts, you must specify the corresponding symbols in the text element for the print program (see the table below).

Symbols for Standard Texts

<table>
<thead>
<tr>
<th>Standard text for</th>
<th>Symbols in the Text Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Letter header</td>
<td>REGUD-TXTKO</td>
</tr>
<tr>
<td>Sender in the letter window</td>
<td>REGUD-TXTAB</td>
</tr>
<tr>
<td>Footer</td>
<td>REGUD-TXTFU</td>
</tr>
</tbody>
</table>
Displaying Fields from REGUH, REGUD, and REGUP

In order to display the fields from the files REGUH, REGUD and REGUP, proceed from the initial SAP menu as follows:

2. Next, select Dictionary
3. Enter one of the above-mentioned files as an object name, select the field Table and then select Display.

The fields in the structure are displayed. The field names which you can use for the forms are in the first column.
Creating Variants

You must create at least one selection variant for every print report. You specify this variant later (for the payment form print run) when entering the parameters for a payment run.

In order to define a variant proceed from the initial SAP menu as follows:

2. Enter the report name, for example RFFOD__S, and then select Goto → Variants.
   You reach the screen for processing your variant. The report name has been transferred.
3. Enter a name for the new variants and select Variants → Create.
   The screen for entering the selection criteria and the specifications appears.
4. Enter your criteria and make your specifications. Then press the CONTINUE push-button.
   You reach the screen for maintaining variant values. Enter a short description of the variants in the Meaning field.
5. Save your variant by selecting Variant → Save.

   Leave the Run date and Identification fields in your variants free. These fields are filled dynamically when the program is run.
Print Control

You can carry out a payment run for different company codes, payment methods, and business partners even though different forms or data carriers may have to be printed or created for each payment method and company code. You can specify this later by entering selection variants for the data medium print programs.

The variants contain a series of selection criteria that are used to separate the data in the print data set. Separate print jobs are created in print administration for each variant called up from a data medium print program. Each print request is displayed in print management with the form description. See Country-Specific Definitions for the Payment Method: Graphic [Page 15] (4). You can call up the print jobs individually for printing.

You carry out the payment run for the payment methods "check" and "order check". The payment program creates a print file for this payment run. Since each payment method uses specific forms, you define a separate selection variant for each payment method for the print program RFFOD__S. The system places a print request in print administration for each variant (see the figure below).

You define the selection variants when you configure the payment program. You can define as many variants as you require for each print program but you must define at least one.

Besides the company code and the payment method, you can use other selection criteria for each variant:

- *Payment document check*. Only posted documents are selected for printing.
Print Control

- **House bank.** Only payments processed via the specified house bank are selected. This may be necessary, for example, if house banks require special forms or if you want to create diskettes for the data medium exchange for several banks.

- **Accounts.** Only documents containing the specified bank account are selected.

- **Currency key.** You use this criterion if you print forms with pre-printed currency keys. You can separate the print jobs per currency via the criterion.

- **Payment document number.** You use this criterion, for example, if you want to print certain payment documents separately.

You make certain printing specifications for each variant. These include:

- **Forms to be printed.** You specify which additional forms (payment advice notes or payment summaries) are printed when you use this variant. You specify the printer on which each form is printed. Alternatively, you can select *Print immediately.*

- **Number of sample printouts.** With line printers, it is advisable to run at least two sample printouts to enable you to adjust the forms correctly on the printer.

- **Language in which the text is printed.** You can specify that the addressee's language (which is entered in his/her master record) is used. Otherwise, the print program selects the language of the sender.

- **Currency key.** If you do not already use ISO codes for your currency keys, you can specify that the ISO code is used in the printed payment forms.

You can also define variants for those programs created by the payment list, the payment proposal list, and the exception list. Variants are not absolutely necessary for these programs.
Payment Program Settings

Each company code used by the payment program first makes several fundamental decisions. The setting of tolerance days for the payment of payables is one such decision. Since the payment program can be used for more than one company code, you must also specify the company code that is making the payment.

Further control over the payment program can be exercised by specifying the following:

- How open items are selected and (if required) grouped together for one payment
- The payee
- How the payment method is selected
- How the bank is selected
- Which forms and other data carriers are used

You make these specifications when:

- Configuring the payment program
- Entering data in your customer/vendor master records
- Entering data in the open items
- Entering data for the payment run in hand
Company Code Specifications

When configuring the payment program, you specify the company codes that are involved in automatic payments and also which company code makes the payments (paying company code).

General Company Code Specifications

For each company code using the payment program, some general information is required, i.e. information that is not specifically linked to a payment method. For example, you specify which special G/L transactions are included in the payment run (see the figure below, (1)).

In some organizations, one company code carries out the payment transactions centrally on behalf of several company codes. Consequently, you must specify the paying company code for each company code (see the figure above, (2)). This specification is also required even if you do not make payments centrally; In this case the paying company code you enter is identical to the company code. For more information on this, see Cross-Company Code Payments [Page 63].

Specifications for the Paying Company Code

You specify how the paying company code makes the payment (see the figure below, (1)). Here, for example, you specify minimum amounts for incoming and outgoing payments. The payment program only makes a payment for the company code if the payment is within the amount limit set.
### Company Code Specifications

#### Paying company code

**Company Code**: 0001  
**Company**: SAP AG Walldorf

<table>
<thead>
<tr>
<th>General specifications</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum amount for incoming payments</td>
<td>1.00</td>
<td>USD</td>
</tr>
<tr>
<td>Minimum amount for outgoing payments</td>
<td>5.00</td>
<td>USD</td>
</tr>
<tr>
<td>No exchange rate differences</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Form for the payment advice</td>
<td>F1100_D_AVIS</td>
<td>Display form</td>
</tr>
<tr>
<td>Form for the EDI accomp. sheet</td>
<td>F1100_D_AVIS</td>
<td>Display form</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Creation of bills of exch.</th>
<th>Use of the payment reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>One bill of exch. per due date interval</td>
<td>Separate payment per reference</td>
</tr>
<tr>
<td>One bill of exch. per due date</td>
<td></td>
</tr>
<tr>
<td>One bill of exchange per invoice</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Bill of exch. due date/bill of exchange requests for incoming payments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latest due date in</td>
</tr>
<tr>
<td>Bill on demand with due date up to</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Due date for outgoing payments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Earliest due date in</td>
</tr>
<tr>
<td>Latest due date in</td>
</tr>
</tbody>
</table>

Further amount limits can be set for the payment method. (See [Company Code-Specific Definitions for the Payment Method: Graphic [Page 18] (1)].) The narrower range always applies.
Selecting Open Items

Use

The payment program identifies the open items and selects the items to be paid. Items are always paid as late as is possible without losing cash discount. You specify the exact time of payment when configuring the payment program.

Features

Criteria for Selecting Open Items

The selection of open items is affected by several factors:

- The **due date of the items** is basically determined via the baseline date and the terms of payment in the open items. The payment program calculates the cash discount periods and the due date for net payment.

- You can specify **Company code-specific grace periods** for payables. See *Company Code Specifications [Page 54]* (2).

  The grace period is added to the due date calculated. Consequently, the payment can be made at a later date.

- A **minimum cash discount percentage rate** can be specified for outgoing payments **per company code**. See *Company Code Specifications [Page 54]*, *(Outgoing payment with cash discount from)*.

  If you cannot achieve the specified minimum percentage rate, you pay on the due date for net payment. You use the minimum cash discount percentage rate if the net term is more advantageous to you than a possible cash discount. If a minimum rate has not been specified, the program pays with the highest possible cash discount.

- You can define which **special G/L transactions** are to be taken into consideration. You do this by entering the special G/L code of the transaction in question when you make the company code specifications. See *Company Code Specifications [Page 54]* [Page 54] (1).

  The payment program can make a down payment in response to a down payment request. The special G/L code for down payment requests must then be entered as the transaction for which payment is to be made. If you want to use the payment program to clear down payments, you will need to enter the codes used for this transaction.

- For each **payment run**, you specify the date of the next payment run. The program uses this date to determine whether an item is to be included in the current or the next payment run.
Selecting Items to be Paid:

Use

The time at which an item is paid depends on several factors:

- Whether it is a payable or a receivable
  
  With **payables**, the items selected are those which,
  
  - Taking the grace period into account, achieve a higher cash discount if paid in the current payment run than if paid in the following run. You can limit the selection of items further via the minimum cash discount percentage rate.
  
  - Would be overdue in the following payment run (after allowing for the grace period).
    
    A special rule applies for invoice-related credit memos: The item is always due together with the invoice it is linked to.
    
    All other open items are paid in the next payment run.
    
    For **receivables**, the payment program always pays soon enough to secure the highest possible cash discount. The payment is made with the first payment run that is carried out on or after the due date of the first cash discount term.

- Which strategy you use to decide between cash discount payments and net payments.

- Whether you make bill of exchange payments before the due date. Read the topics on bills of exchange.
# Company Code Specifications

## General

### Company code specifications

## Company Code Specifications

### Control data

<table>
<thead>
<tr>
<th>Sending company code</th>
<th>Paying company code</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>US01 SAP AG Walldorf</td>
</tr>
</tbody>
</table>

- Separate payment per business area

### Cash disc. & tolerances

<table>
<thead>
<tr>
<th>Grace period in days for payable</th>
<th>Outgoing payment with discount form</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>%</td>
</tr>
</tbody>
</table>

- Always max. cash discount

### Poss. additional functions

- Payt method supplement

### Vendor

<table>
<thead>
<tr>
<th>Special G/L transactions to be settled</th>
<th>Spec. G/L transactions for exceptions list</th>
</tr>
</thead>
</table>

### Custom.

<table>
<thead>
<tr>
<th>Special G/L transactions to be settled</th>
<th>Special G/L transactions for except. list</th>
</tr>
</thead>
</table>

- 1
Cash Discount Strategy

Use

When configuring the payment program you can set up one of the following strategies for outgoing payments:

- Make payments with the highest possible cash discount.
- Make payments as late as possible even if this means losing cash discount.
- Make payments according to a strategy that is midway between these two extremes.

If the highest possible cash discount is desired, flag the field Max. Cash Discount: See Company Code Specifications: Graphic [Page 54]. The payment program applies cash discount term 1 to these open items.

If you specified a minimum percentage rate (see Company Code Specifications: Graphic [Page 54], outgoing payment with cash discount from), the payment program settles items only if the discount percentage rate entered can be reached in the current payment run. If not, payment is made when the amount is due net. If you wish to make payment as late as possible, enter 99 percent as the minimum percentage rate (during payment program configuration). This determines that payments are always made net.

By means of the minimum percentage rate, you can also define strategies that lie between the two extremes (due net and maximum discount).
Example: Selecting Items to be Paid

You have to pay several items, which are due on different days:
- Item 1 was due 2 days ago
- Item 2 is due today
- Item 3 is due tomorrow
- Item 4 is due in 4 days
- Item 5 is due in 10 days

You have specified three days as a grace period for settling payables. The next payment run is to be made in seven days.

The payment program pays in the current payment run those items with a due date between the current payment run and the day before the following payment run (allowing for grace periods).

**With a three day grace period**

In this case, the payment program pays items one through three. These items were not considered for the previous payment run since the grace period permitted a later payment. Allowing for the grace period, the fourth item is not due for seven days, i.e. the day of the next payment run, and will therefore be paid then. The fifth item can be paid in the next payment run or at a later date.
With no grace period

If you do not define a grace period, the payment program would have paid the first item in the previous payment run. Items two, three and four will be paid in the current payment run and item five in the next run.
Processing Payment Requests

Like invoices, payment requests are paid by the payment program when the due date is reached. The system also checks to ensure that the corresponding invoice is not scheduled to be paid in the next payment run, and has not already been paid. If a payment request cannot be made for one of the aforementioned reasons, it will appear on the payment proposal exception list. In such a case, you should cancel the request, since payment cannot be made.

You can also make partial payments for previously posted invoices. To do this, you first block the invoice from payment, and then enter a payment request for the partial amount.
Blocking Open Items

Use

You block the items that, regardless of their due date, you do not want to pay. To do this, you enter a blocking key in the item, which represents the reason for blocking. If you want to block the account of a customer or vendor from payment, you enter the blocking key in their master record.

The standard system contains several blocking keys for blocking, which you can add to or change.

The payment program creates a payment proposal during the payment run. The payment is made on the basis of this payment proposal list. The blocked items are displayed separately on the list. You can process the payment proposal, and, for example, set or cancel the payment block on an item.

It is also possible to determine that a blocking key can not be changed from the payment proposal transaction.
Notes on Clearing Dates

On the whole, the payment date is used as the clearing date. There exist, however, the following exceptions.

Items whose posting date comes after the posting date of the payment run will be paid, provided they are already due.

The clearing date for such payments is not the payment date, but rather the latest posting date possible. Thus any danger of the clearing date coming before the posting date is prevented in the context of paid items. Errors are avoided in this way.
Grouping Open Items and Individual Payments

Use
Wherever possible, the payment program will always group items together for payment. However, you can also specify that an individual payment (a separate payment) is made for a particular item. Indeed, for certain payment methods such as the POR procedure in Switzerland and the PBC procedure in Denmark, only individual payments are possible.

Features
The payment program can only group together open items for payment if the open items in an account have the same:

- Currency
- Payment method in the item
- Bank in the item
- Contents of the grouping fields (if a grouping key is specified in the customer or vendor master record)

You can also pay open items from different company codes together, as well as customer and vendor line items.

Items in an account are not grouped together if you:

- Make payments separately per business area. This procedure entails separate payments being created per business area.
- Want to make individual payments

Items in which a payment method is specified are not grouped with items in which no payment method is specified.
Grouping Open Items Under Grouping Keys

Use

You can use grouping keys to group together the open items of a customer or vendor that should be paid together.

A grouping key is used for example during loan management, when automatic debit at the vendor is carried out separately according to loan numbers.

Prerequisites


2. Enter the required grouping key in the vendor and customer master records for which you wish to group open items.

   To do this, in the vendor or customer master record, select Company code data → Payment transactions and enter the required grouping key in the Grouping key Field.

Features

When you define a grouping key, you must specify a maximum of three fields from table BSIK (vendors) or table BSID (customers). Those open items for which the contents of these fields match are grouped together.
Cross-Company Code Payments

Use

If one company code pays centrally for others in your organization, all the open items of a customer/vendor that exist in several company codes are paid together, provided:

Prerequisites

- You have specified the same paying company code for all participating company codes (see the topic "General Company Code Specifications" in Company Code Specifications [Page 50]).
- The company codes are located in the same country
- The local currencies and where appropriate, all parallel currencies, are identical

Features

The paying company code is the one that settles the open items; the postings to the bank accounts and sub-accounts are made to this company code.

Either the paying or the "sending" company code (i.e. the company code against which the receivable exists) can function as the sending company code:

- If the paying company code should also be displayed as the sending company code for the customer/vendor, you should specify it as a sending company code.
  If you do not specify a sending company code, the system automatically takes the paying company code as such. If this is the case, the open items are grouped together in a single payment. With such a payment you cannot see from the payment transfer medium which company code owed the payable.
  - If you want to specify which company code owes the payable to the customer or vendor, specify this company code as the sending company code. If you do this, all the items which have the same paying and sending company codes are grouped together for payment. A separate payment form is generated for these items. On payment advice notes, a note is recorded stating for which company code the payment is made, (for the sending company code). This is not possible in the case of other payment forms. If necessary, you can configure the payment program in such a way that a payment advice note is also printed in the case of other payment forms.

  Company code 0001 pays additionally for company codes 0002 and 0003. Company code 0001 should be entered for itself as both paying and sending company code in this situation. For company codes 0001 and 0002, company code 0001 is the paying company code. The company codes themselves are entered as the sending company codes. This ensures that a separate payment is made for each sending company code. The sending company codes are listed in the notes in the payment advice notes.

The standard forms for the payment advice and the check with payment advice contain a separate text element for the note on the sending company code. If you define your own forms, and want such a note, you must add this text element to them.
Cross-Company Code Payments
Clearing Customers and Vendors

Use

If you run a vendor as a customer at the same time, you can offset the open items. Under this procedure, receivables and payables are offset against each other. If a credit balance results a payment is due. If you have a debit balance, you draw up a debit memo, providing all the other conditions for this have been fulfilled.

Prerequisites

- You must enter the account number of the other business partner in the master record.
  
  The Customer/Vendor field is in the general area on the Control screen.

- In both master records, the option for clearing between customer and vendor accounts must be selected.
  
  The Clrg with vend./Clrg with cust. field is in the company code-specific area.
Local Payment

Use

Unless you specify otherwise, where an organization has both a head office and branches, the payment program pays via the head office: This means that the information required by the payment program is taken from the master record of the head office. Postings are always made to the head office account.

It is also possible to pay locally, with the payment program making payments for each branch separately.

Prerequisites

Select the field *Local processing* in the vendor/customer master record under *Company code data → Correspondence*.

Features

During local payment, all specifications (bank details and address) are determined from the master record of the branch.

There are two ways that you can define the payment methods:

- If you want to arrange separate payment methods for each branch, you should enter these in the branch master records only.
- If all the branches of an organization use the same payment methods, enter these in the head office master record only.

If payment methods are defined in both the branch and head office master records, the branches can use any of these methods.
Separate Payment by Business Area

Use
You can determine that open items are paid separately by business area for every paying company code. See topic "General Company Code Specifications" in Company Code Specifications [Page 50]. The payment program then makes separate payments per business area.
Individual Payment

Use

Open items are paid individually according to the following prerequisites:

- With the POR procedure, individual payment is the only possible payment method. The payment method must be classified accordingly. You must specify in the master record of the customer/vendor that the customer/vendor receives payments with the POR procedure.

- If you always want to pay the open items for a customer/vendor individually, you can determine this in the company code-specific area of the master record. To do this, you mark the field Individual payment.

- If you want to pay one of the open items individually with a certain payment method, define this payment method as individual payment. See Company Code Specifications for the Payment Method: Graphic [Page 18] (5). This payment method must be entered in those open items that are to be paid individually.

You want to pay individual items with a separate check. Define a second payment method for check in addition to the standard payment method, for which you set the same specifications and also define as an individual payment. Enter this payment method in the open items for which a separate check is to be created.
Alternative Payee

On occasions, you might not want to send payment to a vendor (invoicing party) for a payable that exists.

In general, the payment recipient and the invoice issuer (vendor) are identical. However, a payment can also be effected for an alternative payee. For this to happen, you must first specify the alternative payee. In the standard system you can specify the alternative payee in the following ways:

- Entering the data (name, address, bank details, and so on) in open items, if this is the only item to be paid to an alternative payee.
- Entering the account number of the alternative payee in the company code-specific area of the master record of the vendor, if an alternative payee is only necessary in certain company codes for the vendor.
- Entering the data (name, address, bank details, and so on) in the general area of the master record of the vendor, if payments are to be made to an alternative payee.

The above information is listed in order of priority. For example, if an alternative payee is specified in open items, this has priority over the specification in the master record. The same applies to customers.

If you want to enter the alternative payee in the line item, the field *Payee in document* must be marked in the general data area of the vendor or customer master record. This makes it possible to enter the necessary master data for the payee by marking the field *Alternative payee* when posting to the customer or vendor account.

If you clear between customers and vendors, the payment program always uses the specifications from the *vendor* master record. No entries are contained for one-time accounts for the payment recipient in master data. These specifications are entered during the creation of a document. The payment program then determines the payee from the information given in the document line item. You must enter the possible payment methods in the master record of the one-time account.
Notes on the Payment Method

You can define payment methods in the master record or in the open items.

In the master record you can either:

- Specify a single payment method, if, for example, you have already defined a specific payment method with a business partner, or

- Specify multiple payment methods, one of which will be selected by the payment program according to your specifications during the payment run. The manner in which the payment program selects a payment method is explained in Selection of the Payment Method by the Payment Program [Page 71]

If you specify a payment method in the open items, it will override the specification in the master record. A payment method defined in the open items must not exist in the master record.

⚠️

The payment method with which you want to pay must always be specified in the customer or vendor master record or in the open item.
Selection of the Payment Method by the Payment Program

Use

Before every payment run you must specify which payment methods may be used in the payment run. If a payment method is specified in open items or in the master record of the customer/vendor and if that payment method is permitted for that payment run, the payment program selects this payment method. The payment method in the open items takes precedence over any payment method defined in the master record.

If several payment methods are specified in the master record and none in the item, then the payment program selects a payment method. The program checks (in the sequence in which you entered them) whether each of the payment methods you specified for the payment run can be used. To be able to be used, a payment method must satisfy the following conditions (among others):

- The payment method must be specified in the customer/vendor master record or open items.
- The master record must contain the specifications needed for the payment method. See topic Country-Specific Definitions for the Payment Method [Page 14].
- For foreign payments, the payment program checks whether the payment method in question allows payments to customer/vendors or banks located abroad. See Company Code Specifications for the Payment Method [Page 16]
- In the case of payments in foreign currency the payment method must be allowed for foreign currency payments. See Company Code Specifications for the Payment Method [Page 16]
- The permissible minimum and maximum amounts must be adhered to for the payment amount. See Company Code Specifications for the Payment Method [Page 16]
- For payment, a bank permissible for the payment method under consideration is determined. Read Bank Selection [Page 73] to see how banks are selected for a payment method.

If one of the specified payment methods meets all the above conditions, this payment method is used. Otherwise, the program carries out all the checks for the next payment method in the list you entered.
Sample Payment Method Selection

You have to settle a payable of 3,000 USD owed to a vendor. The master record of the vendor specifies that the payment methods "check" and "transfer" are allowed. No payment method is specified in the item.

During the payment run, you specify the payment methods "transfer" and "check". The following values are specified for the payment methods:

<table>
<thead>
<tr>
<th></th>
<th>Transfer</th>
<th>Check</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum amount</td>
<td>5.00</td>
<td>0</td>
</tr>
<tr>
<td>Maximum amount</td>
<td>1,999.99</td>
<td>9,999,999.00</td>
</tr>
<tr>
<td>Foreign payment</td>
<td>not possible</td>
<td>possible</td>
</tr>
<tr>
<td>Specs. in master record</td>
<td>Bank details</td>
<td>none</td>
</tr>
<tr>
<td>Number of items per form</td>
<td>2</td>
<td>99</td>
</tr>
</tbody>
</table>

The payment program checks the payment methods in the sequence you entered them during the payment run. The amount cannot be transferred as the payment amount (3,000 USD) is above the maximum amount possible for transfer (1,999.99 USD). The item can be paid by check if a suitable house bank can be determined for it. Read the topic Bank Selection [Page 73]
Bank Selection

For payment transactions you need house banks and possibly the bank details of your customers/vendors. House banks are banks with which your company code maintains accounts. To find out how to define your house banks, see Configuring the System Using the Implementation Guide [Ext.]. Depending on the payment method used, you may/may not require the bank details of your customers/vendors. For example, you require the bank details of your customers/vendors for transfers, but not for clearing checks. Enter customer/vendor bank details in master records.

You can enter as many sets of bank details in master records as you want, both for your company codes and for your customers/vendors. You can determine the bank that is selected by:

- An explicit specification in the master record of the customer/vendor or in the open items. The specification in the item has higher priority.
- The payment program, which determines according to specified rules, the most suitable house bank or the optimal combination of house bank and customer/vendor's bank.

See also:

- Bank Details in Open Items [Page 75]
- Selecting the Bank Details of a Business Partner [Page 76]
- Bank Details in the Customer/Vendor Master Record [Page 74]
- Selecting the House Bank [Page 77]
- Optimizing Bank Selection [Page 79]
- Available Amounts [Page 82]
- Value Dates [Page 83]
- Value Dates in the Customer/Vendor Master Record [Page 84]
- Sample Bank Selection [Page 85]
Bank Details in the Customer/Vendor Master Record

Use

In the master record of the customer/vendor, you can make as many bank detail entries as you want. If the payment transactions should always be carried out by a customer/vendor’s bank, only specify this bank.

If you only want to allow one house bank to carry out payment transactions with a customer/vendor, enter this bank in the master record of the customer/vendor. The correct field for this is in the company code-specific area of the master record.
Bank Details in Open Items

Use

You can specify the **bank details of the business partner** in the open items simply by entering a bank type in the item. The bank type is a feature that you can assign freely for all of your customer or vendor's banks. If a bank type is specified in the item, a bank with the same bank type is selected from the master record for payment (see the figure below).

<table>
<thead>
<tr>
<th>Vendor master record</th>
<th>Line item</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bank details</strong></td>
<td><strong>Bank details</strong></td>
</tr>
<tr>
<td>Cntry</td>
<td>Bus. partner's bank</td>
</tr>
<tr>
<td>Bank no.</td>
<td>GR01</td>
</tr>
<tr>
<td>Acct</td>
<td>House bank</td>
</tr>
<tr>
<td>Bk. type</td>
<td>CM</td>
</tr>
<tr>
<td>D 1234567 123</td>
<td></td>
</tr>
</tbody>
</table>

If there are several banks specified in the customer/vendor master record, some with and some without a bank type, the system first checks those banks in the master record that do not have a bank type for purposes of paying documents that also have no bank type specified. Banks with a bank type are only used if the master record contains none of the former type.

If you want to specify the paying **house bank** in the item, you can enter the appropriate bank ID there (see the figure above).
Selecting the Bank Details of a Business Partner

Use

If the payment method being used requires the customer/vendor’s bank details and these have not been specified, the payment program selects the bank details allowed for that method. The bank details allowed must be specified in the customer/vendor master record. The payment program selects the bank details that meet all the requirements of the payment method:

- If a collection authorization is necessary for the payment method, the customer/vendor master record must contain a collection authorization for bank details.
- If only bank details for banks located in the same country are allowed for the payment method, the payment program selects an appropriate bank.
- If the payment method specifications require the bank to be a postal check office or postal giro office, the payment program selects an appropriate bank. You determine in the bank master data whether a bank is a post office bank.

If, after all the criteria have been checked, the payment program chooses several banks, it uses the first bank that fulfills all the terms. If the payment being used also requires the program to select the optimal bank for payment, further checks, involving the house banks, are necessary. Read the topic Optimizing Bank Selection [Page 79].
Selecting the House Bank

You specify which house banks are allowed for every payment method or, if you prefer, for both payment method and currency. You should sort this list of permissible banks in ranking order according to priority. See the figure below, (1). For every combination of payment method and house bank, specify via which bank account (for example giro or foreign exchange account) the payment should be made. See the figure below, (2).

For every account at a house bank, specify the amounts that are available for the payment run. See the figure below, (3).

The payment program determines the house bank in the same sequence:
Selecting the House Bank

1. First it determines the bank ID (house banks) based on the payment method and currency. If it finds no entry for the combination, it checks the bank for payment method without currency specification, if such an entry exists.

2. It determines the account ID on the basis of the bank ID, the payment method and the currency.

3. Finally, it finds out whether sufficient amounts are available for both bank ID and account ID.

During the payment run the payment program therefore attempts to determine a house bank and a bank account that has a sufficient amount available for payment. This may result in the following possibilities:

- No house bank is found that fulfills all terms. The payment cannot then be made with the payment method with which the check was carried out. The checks are carried out for the next possible bank. If no bank is determined, the payment method can not be used. If another method is available, it will then be checked as well. This is noted in the log for the payment run.

- One house bank only is determined. The payment is made via this house bank.

- The program produces a list with house banks. The payment is made from the house bank with the highest priority according to the defined ranking order of the banks. This is not the case if payment optimization has been specified. Read the topic Optimizing Bank Selection [Page 79]
Optimizing Bank Selection

Use
For every payment method you can specify for each company code whether the program should select the optimal bank for payment. Optimization can be by bank group or by postal code. See Company Code-Specific Definitions for the Payment Method: Graphic [Page 18]

Optimization by bank group helps ensure that money is transferred from your house bank to your customer/vendor’s bank as fast as possible. In order to do this, assign a bank group (that is freely definable) to all banks in your master records.

Optimization by postal code ensures the house bank is selected according to the customer/vendor’s location.

Optimization by Bank Group
If you specify optimization according to bank groups for a payment method, the payment program selects two banks that belong to the same bank group. If several house banks come into consideration, the bank with the highest priority (ranking order) is selected. If an optimization is not possible, the optimization function does not apply.

In the first part of the figure below, two banks belong to the same bank group: The Bank of America belongs to the bank group BA as a house bank and also as the bank of the customer/vendor. The Bank of Chicago belongs to the bank group BC. In this case, the payment program selects the Bank of America, i.e. the bank with the higher priority. The second part of the figure shows a combination for which optimization is not possible. The payment program selects the house bank with the highest priority without taking optimization into account.
You determine which bank group a bank belongs to in the master data of the bank. You should set up the groups in such a way that the financial transactions can be processed between the banks of the same group rapidly. In Germany, for example, the banks that belong to the same giro network are assigned to the same bank group.

**Optimization by Postal Code**

If a certain payment method specifies optimization by postal code, the payment program selects a house bank based on the postal code area of the customer/vendor. If no house bank is defined for the postal code area of the customer/vendor, or if the selected house bank cannot be used, the payment program selects the house bank with the highest priority from the priority list. In this case, optimization does not take place.

For this type of optimization, you must assign your house banks to a range of postal codes (see the figure below).
Available Amounts

Use

The payment program checks whether the selected bank accounts have sufficient funds for payment.

For your accounts at the house banks you can specify available amounts separately for incoming payments and outgoing payments (see the figure below). For outgoing payments, you define the size of the amount that can be paid. For incoming payments, you specify the amount up to which such payments can be made to a bank account. If this limit is exceeded, the payment program selects another bank. The specifications you make concerning available amounts determine which bank account should pay. You should ensure that these amounts are up-to-date before every payment run.

The payment program does not carry out amount splitting. If the amount on a bank account is not sufficient for a payment, the payment program selects another bank account. If it finds no bank account from which it can post the entire amount for a payment, it does not carry out the payment.

<table>
<thead>
<tr>
<th>Company code 0001</th>
<th>SAP AG Walldorf</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bank ID</strong></td>
<td><strong>Account ID</strong></td>
</tr>
<tr>
<td>CM</td>
<td>GIRO</td>
</tr>
<tr>
<td>BA</td>
<td>GIRO</td>
</tr>
<tr>
<td>CB</td>
<td>GIRO</td>
</tr>
<tr>
<td>CB</td>
<td>DEM</td>
</tr>
</tbody>
</table>

You can specify the amounts based on currency and probable value date (days) at the bank. The value dates are the difference between the posting date of the payment run and the probable value date (value date at the bank).

You can use value dates to plan available amounts on a graduated time scale. You generally only need this facility if you post payments by bill of exchange before the due date. In all other cases, you can enter 999.

The specified value dates are the maximums in each case.
Value Dates

Use

Value dates are the number of days that elapse between the posting date of the payment run and the value date at the bank.

Value dates are used by the payment program in two different ways:

- The payment program adds the number of days needed for the payment to be debited from your account to the posting date of the payment run and thereby establishes the value date of the payment. This date is noted in the payment document. Such information is particularly important for the Cash Management and Forecast application. If no value dates are determined, the posting date of the payment run is selected as a value date.

- In addition, the payment program needs the value dates to check the available amounts. See the topic Available Amounts [Page 82].

You define the value dates either based on your experience of previous payments made with that payment method, bank account, payment amount and currency (see the figure below), or you can allow the value date to be determined automatically by the system, which will use a bank calendar and individual agreements with the bank as decision criteria.

<table>
<thead>
<tr>
<th>Co. code</th>
<th>Bank ID</th>
<th>Account ID</th>
<th>Amount limit</th>
<th>Curr</th>
<th>Days to value date</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>CM</td>
<td>GIRO</td>
<td>5,000.00</td>
<td>USD</td>
<td>3</td>
</tr>
<tr>
<td>S</td>
<td>CM</td>
<td>GIRO</td>
<td>99999,999,999.00</td>
<td>USD</td>
<td>2</td>
</tr>
<tr>
<td>U</td>
<td>CM</td>
<td>GIRO</td>
<td>99999,999,999.00</td>
<td>USD</td>
<td>1</td>
</tr>
</tbody>
</table>

Payments that are made by transfer are debited from your bank account on the next day. This occurs regardless of the amount. That means that for payments made with this payment method, the money must be available the next day. For this payment method, you should enter 1 in the field Days to value date (see the figure above). The period within which a check is cashed can be dependent on the amount. For amounts of up to 5,000 USD, the time between the posting date and the value date is three days. For all other amounts, the value date is within two days of the posting date (see the figure above).
Value Dates in the Customer/Vendor Master Record

Use

When processing checks, the system allows you to enter (per customer/vendor) the number of days you expect to pass between the posting date and the value date. You enter the number of days in the field *Check cashing time*. The payment program uses this to calculate the probable value date. If no entry is made in this field, the number of days is determined by reference to the standard entry. See topic *Value Dates [Page 83]*
Sample Bank Selection

You have to settle the following payables:

<table>
<thead>
<tr>
<th>Vendor</th>
<th>Amount</th>
<th>Currency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vendor 1</td>
<td>20,000</td>
<td>USD</td>
</tr>
<tr>
<td>Vendor 2</td>
<td>20,000</td>
<td>USD</td>
</tr>
<tr>
<td>Vendor 3</td>
<td>12,000</td>
<td>USD</td>
</tr>
<tr>
<td>Vendor 4</td>
<td>3,000</td>
<td>USD</td>
</tr>
<tr>
<td>Vendor 5</td>
<td>6,000</td>
<td>DEM</td>
</tr>
</tbody>
</table>

In the vendor master record, the payment method "check" is specified.

The following amounts were planned for your bank accounts:

<table>
<thead>
<tr>
<th>Bank selection</th>
<th>Account selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>-</td>
</tr>
<tr>
<td>S</td>
<td>-</td>
</tr>
<tr>
<td>S</td>
<td>USD</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Planned amounts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bank ID</td>
</tr>
<tr>
<td>CM</td>
</tr>
<tr>
<td>BA</td>
</tr>
<tr>
<td>CB</td>
</tr>
</tbody>
</table>

The payment program then determines, for the combination of payment method and currency, bank details and a bank account that has the required amounts available.

The payables are settled from the following bank accounts:

Selection of the bank account for payment

<table>
<thead>
<tr>
<th>Vendor</th>
<th>Amount</th>
<th>Bank ID</th>
<th>Remaining amount after Payment to account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vendor 1</td>
<td>20,000 USD</td>
<td>CM</td>
<td>30,000 USD</td>
</tr>
<tr>
<td>Vendor 2</td>
<td>20,000 USD</td>
<td>CM</td>
<td>10,000 USD</td>
</tr>
<tr>
<td>Vendor 3</td>
<td>12,000 USD</td>
<td>BA</td>
<td>88,000 USD</td>
</tr>
<tr>
<td>Vendor 4</td>
<td>3,000 USD</td>
<td>CM</td>
<td>7,000 USD</td>
</tr>
<tr>
<td>Vendor 5</td>
<td>6,000 DEM</td>
<td>CB</td>
<td>6,000 DEM</td>
</tr>
</tbody>
</table>
Sample Bank Selection

You want to directly debit amounts from a bank account with various value date periods. Transfers (value date within one day) and bills of exchange (due within 90 days) are to be debited from the account.

Plan an amount of 30,000 USD for transfers. For paying bills of exchange, you should plan on amount of 100,000 USD. The following payments should be made in the payment run: 10,000 USD to vendor 1; 20,000 USD to vendor 2; and 40,000 USD to vendor 3.

The transfers to vendors 1 and 2 will be made from the aforementioned account. The payment program will select a different bank account for the transfer to the third vendor.
Specifications for Posting Payments

Use

The payment program posts payments and related postings such as those for tax, tax adjustments, exchange rate differences, or cash discount) automatically.

Prerequisites

To enable these postings to be made, you must first enter the following information:

- The bank or bank subaccounts to be posted to
- The document type to be used for posting the payments
- Whether exchange rate differences are posted. For further information on configuring the payment program for exchange rate differences, see the topic Posting Exchange Rate Differences: Payment Program [Page 94]
Bank Accounts and Bank Subaccounts

Use

It is advisable to use bank subaccounts for posting incoming and outgoing payments.

If you do not use subaccounts, set up your standard bank accounts in the payment program configuration menu. See Selecting the House Bank [Page 77]

Included in this are accounts for outgoing checks, outgoing transfers, incoming checks, and bank collection (see below).

Using such subaccounts has its advantages: You can, at any given time, reconcile the balance of the account at your bank with the balance of your corresponding G/L account. The subaccounts ensure that all incoming and outgoing payments are posted to the G/L bank account until the money is actually debited from/credited to your bank account. This transfer posting from the clearing account to the bank account is carried out when you receive the appropriate account statement from your bank.

Prerequisites

If you want to use the bank subaccounts function, create subaccounts with whatever degree of differentiation you require. You can, for example, create a bank subaccount for each bank or for each bank and a group of payment methods. The charts of accounts supplied along with this package provide a reference for such differentiation.

You must specify the account number so that the payment program can post to the appropriate bank subaccount (see the figure above). This posting is made on the basis of bank ID, payment method, and possibly currency.
Subaccounts are generally managed on an open item basis and with line item display, since you want to be able to see at any time via these accounts whether a business transaction has been completed.

**Notes on the Sort Sequence of Items in Bank Subaccounts**

If bank subaccounts that are usually posted to by the payment program (for example, the account for foreign bank transfers) have a special sort sequence, it is easier to process them when posting the bank statement.

The documents from the payment run contain, in their document header (field BKTXT), the date and identification number (e.g. 19940301-ID) of the run. You can have the system automatically transfer this information to the Allocation field in the line item if you define a corresponding item sorting rule and enter this in the G/L account master record.

Subsequently you can, when entering a bank statement, select via the Allocation field all the foreign transfers from a certain payment run in order to clear them.

**Posting Separately by Business Area**

If you have determined that the payments for a certain company code should be made separately per business area, then the bank posting is made to the business area of the paid items.

If you do not separate the payments by business area, you can specify that the bank postings should be made to one certain business area. To do so, specify the required business area for the bank account (see the figure above).

> This specification is only effective if you do not already pay separately by business area!

In all other cases the postings to the bank subaccounts are carried out without reference to business areas.
You settled a payable amounting to 5,000 USD by check. The payment was posted to the subaccount for outgoing checks and to the vendor account (see the figure below). The payable on the vendor account was cleared with this procedure.

After the check amount is actually debited from your bank account, you post it to the corresponding G/L bank account and select the corresponding check on the outgoing checks account (see the figure above).

During clearing, the system posts the amount to the bank subaccount "outgoing checks" and clears the posted item on this account.

The check is now marked as cashed. Your G/L bank account only contains those amounts which have actually been debited from your bank account.
Notes on the Sort Sequence of Items in Bank Subaccounts

If bank subaccounts that are usually posted to by the payment program (for example, the account for foreign bank transfers) have a special sort sequence, it is easier to process them when posting the bank statement.

The documents from the payment run contain, in their document header (field BKTXT), the date and identification number (for example, 19940301-ID) of the run. You can have the system automatically transfer this information to the Assignment field in the line item if you define a corresponding item sorting rule and enter this in the G/L account master record.

Subsequently, when entering a bank statement, via the Assignment field, you can select all the foreign transfers from a certain payment run in order to clear them.
Posting Separately by Business Area

Use

If you have determined that the payments for a certain company code should be made separately per business area, then the bank posting is made to the business area of the paid items.

If you do not separate the payments by business area, you can specify that the bank postings should be made to one certain business area. To do so, specify the required business area for the bank account (see the figure above).

This specification is only effective if you do not already pay separately by business area.

In all other cases the postings to the bank subaccounts are carried out without reference to business areas.
**Document Type for Payments**

**Use**

You specify the document type which the payment program should use for posting the payments when making the country-specific specifications for the payment method. The document type must be defined using internal number assignment.

You can specify two document types for cross-company code payments. One document type is used for the document in the paying company code, the other for the clearing postings in the other company codes.
Posting Exchange Rate Differences: Payment Program

Use

Unless you specify otherwise, the payment program posts the exchange rate differences arising from foreign currency items. It does this by determining the difference between the rate at the time of posting and that when the item is paid. In order to determine the local currency amount at the time of payment, the payment program uses the exchange rates defined in the system.

If you do not want the exchange rate differences to be posted, you should specify this for the paying company code. See Specifications for the Paying Company Code [Page 30]. If you do so, the payment program calculates the equivalent payment amount in local currency on the basis of the local currency amounts in the paid items.

If the items to be paid have been reevaluated in the course of balance sheet preparation work, the adjustment postings to the receivables and payables accounts are reversed when the item is paid. At the same time, in order to determine the payment amount in local currency, the system also reads the valuation difference noted in the item.

If the payment program posts exchange rate differences, these actual exchange rate differences are noted in the cleared item. Such exchange rate differences are only temporary because the final difference can only be calculated when the bank statement is posted. If the payment program does not post any exchange rate differences, the cleared item does not then contain any information on realized differences. The exchange rate differences are not posted until the bank statement is posted. This method does not allow you to assign the differences to affiliated and non-affiliated companies for example. Further, it is not possible to retroactively assign the exchange rate variances to the business areas or cost centers which generated them.
Consistency Checks: Payment Program

Use

During configuration of the payment program the checks usually carried out in the SAP System are performed. This includes a check as to whether the keys entered are defined in the system. If necessary the system issues a warning or error message.

You enter a document type for the payment postings that has not yet been defined. The system will issue an error message. If, however, you have specified for the bank posting a bank subaccount that has not yet been created, the system merely warns you.

After configuration of the payment program, you can have the system run a consistency check. During this, the system checks whether keys were entered during the configuration of the payment program that have since been deleted from the system.

You enter a business area for the bank posting. If you then delete this business area, you should also remove the corresponding entry from the payment program configuration. The consistency check shows you the appropriate key.

During the consistency check, the system runs the same checks as it did for the configuration.

You can request an additional log for the payment run. If the program did not settle certain open items, the reasons for this are detailed in this log. You can decide how to rectify the situation on the basis of this information.
Authorizations: Payment Program

You can assign authorizations for configuring and running the payment program. For further information see Configuring the System Using the Implementation Guide [Ext.] under Financial Accounting Global Settings → Authorization Management.
Payment Currency

Use
You use this function if you wish to use the automatic payment facility to make payments in which the currency of the items to be paid is different from the currency of the payment.

This enables you, the payer, to fulfill your obligations to pay in any of the currencies currently at your disposal.

You can either come to a general agreement with your vendor about which alternative currencies can be used, or make separate arrangements for individual cases about the payment currency and, if necessary, the payment amount.

You can specify an alternative payment currency in the open item. You can also specify an amount. This states the equivalent of the gross amount of the open item in the payment currency.

Integration
The payment currency function is supported in both Accounts Payable (FI-AP) and Accounts Receivable (FI-AR).

In the liquidity forecast in the Treasury component (TR-CM-CM-CM-LF), the expected payment flow for customer or vendor open items is normally stored in the relevant document currency.

Prerequisites
You must make the following settings in Customizing for Financial Accounting (FI):

- Field selection
  Change the field selection for the reconciliation accounts and posting keys in which you want it to be possible to enter a payment currency or an amount in payment currency. The fields Payment currency and Amount in payment currency can be found under Payment transactions.

- Document change rules
  If you want it to be possible to change the Payment currency and Amount in payment currency fields at a later date, you must maintain the document change rules for those fields. When making the settings, please note that changes are only worthwhile if the line item has not yet been cleared.

- Selection field, search field, sort field
  You can define the new fields as selection fields, search fields or sort fields for the clearing transactions and line item display.

- Account determination
  When the payment is made, the system automatically generates line items for the differences in amount resulting from the amounts being specified in payment currency. You define the relevant accounts in Customizing for Financial Accounting in the activities Define Accounts for Payment Differences with Alternative Currency and Define Clearing Accounts for Payment Differences with Alternative Currency.
Payment Currency

Features

Payment Currency for Document Processing

You can specify an alternative payment currency and an amount in the payment currency for line items that can be paid automatically. You can enter any currency except the document currency.

If an amount in payment currency is specified, this takes the place of the gross amount in the payment program. This means that cash discount and withholding tax may be deducted from the amount on payment.

The amount in payment currency is subject to a plausibility check. The gross amount in document currency is translated into payment currency. The translation is calculated from Document currency → Local currency → Payment currency. The system uses the exchange rate contained in the document header for the first step of the calculation, and the current average rate from the exchange rate table for the second.

If the amount entered differs from the amount calculated in this way by more than one percent, thus exceeding the tolerance specifications in the company code table (maximum exchange rate difference), the system issues a corresponding warning. The message settings can be changed, so you can suppress the message or change it into an error message if required.

For more information on setting system messages, see the Implementation Guide (IMG) for Financial Accounting under Change Message Control for Document Processing [Ext.]

The system uses the payment currency for invoice-related credit memos. If the invoice contains an amount in payment currency, the system enters the corresponding amount in the credit memo.

<table>
<thead>
<tr>
<th>Invoiced amount</th>
<th>100 DEM</th>
<th>Amount in payment currency</th>
<th>180 USD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Credit memo amount</td>
<td>20 DEM</td>
<td>Amount in payment currency</td>
<td>36 USD</td>
</tr>
</tbody>
</table>

The payment currency and the corresponding amount can be changed in a line item, provided that the document change rules have been configured to allow this.

Payment Currency in the Payment Program

The payment program determines the payment amount of an item in the predefined payment currency as if the item had been posted in the payment currency. Not all of the required amounts are available in the payment currency, so the system carries out the following translations:

<table>
<thead>
<tr>
<th>Gross amount of item</th>
<th>If the item does not contain an amount in the payment currency, the system determines the amount when running the payment program.</th>
<th>Payment currency is the local currency, and company code settings specify that exchange rate differences are not to be posted when clearing in local currency.</th>
<th>In this case, the local currency amount is transferred as an amount in payment currency.</th>
</tr>
</thead>
</table>
Payment currency is the local currency, and exchange rate differences can be posted when clearing in local currency.

In this case the amount in document currency is translated into local currency at the current exchange rate. The result usually differs from the original posting amount in local currency.

Payment currency is different from local currency.

In this case the amount in document currency is translated into payment currency at the current exchange rate. The translation is calculated from Document currency \( \rightarrow \) Local currency \( \rightarrow \) Payment currency.

Cash discount amount, cash discount base, withholding tax base

These amounts, where specified, exist in document currency. Once the amount has been determined in payment currency, these amounts are updated by the rule of three.

If, in addition to the payment currency, the amount in payment currency has also been specified, a new difference is produced when the payment is posted. The specified amount will usually differ from the amount arrived at by translating at the current exchange rate. The difference represents an overpayment or an underpayment, as agreed with your business partner, and is automatically posted by the system. As with exchange rate differences, the difference amount is only given in local currency. You must specify a difference account in Customizing for automatic posting. See also: Payment Currency: Posting Example 1 [Ext.]

The following scenarios exist for automatic posting:

- **Exchange rate differences are posted in the payment program**
  
  In this case, the system determines the local currency amount to be posted to the bank subaccount by translating the payment amount.

  If the specified difference account is not tax-relevant, the whole difference amount is posted as one line item in local currency: Payment Currency: Posting Example 1 [Ext.]

  If the specified account is tax-relevant, the tax is calculated from the difference amount (in the same way as cash discount): Payment Currency: Posting Example 2 [Ext.]

- **Exchange rate differences are not posted in the payment program**
  
  In this case, the local currency amount to be posted to the bank subaccount is the total of the local currency amounts of the items for payment, less cash discount and withholding tax.

  If the specified difference account is not tax-relevant, or if a difference account has not been specified, the system does not generate a difference posting. In Payment Currency: Posting Example 1 [Ext.], the local currency amount in the bank subaccount would be changed to 1800 DEM.
Payment Currency

If the specified difference account is tax-relevant, the posting to the bank subaccount is changed (1800 DEM instead of 1776 DEM), as well as the posting to difference account 2 (24 DEM instead of 0 DEM). See also: Payment Currency: Posting Example 3 [Ext.]

Manual Clearing

If an item is cleared in a different currency from the one in which it was posted, the system translates the amounts into the clearing currency at the current exchange rate. This translation is omitted if the clearing currency is the same as the specified payment currency and an amount has already been entered in the payment currency. In this case the system uses the amount in payment currency.

The same difference postings may result as with the payment program, when the payment program can post exchange rate differences.

In line items for which a payment currency has been specified, the payment currency replaces the document currency. The expected amount is the amount in payment currency minus the expected deduction of cash discount. If an amount in payment currency has not been entered, the system translates the amount in document currency into payment currency and uses this instead of a specified amount. The translation is calculated from Document currency → Local currency → Payment currency.
Special Features When Paying by Bill of Exchange

Use

Payment by bill of exchange varies from country to country. Two different procedures can be distinguished:

- Bill of exchange issue before due date
- Bill of exchange issue on due date

Bill of exchange issue before due date

In countries such as France, Spain, and Italy, bills of exchange are issued directly after the invoice is issued. The drawer (payee) is thus able to pass on the bill of exchange to a bank for refinancing as early as possible. He pays the bill of exchange charges.

When settling payables by bill of exchange, the **bill of exchange payable** is drawn up at an early stage and sent to the vendor.

For bills of exchange receivable (bill of exchange is drawn on the customer), the bill of exchange is printed by the payment program and then either:

- Sent directly to a bank for refinancing. This bill of exchange receivable is referred to as a **bank bill**.
- Sent to the customer for acceptance. This bill of exchange receivable is referred to as a **bill of exchange payment request**.

Bill of exchange issue on due date

In Germany and Austria, bills of exchange are not issued until the invoice is actually due (the due date of the bill of exchange will be later than the due date of the invoice). The payer thus gains from the fact that his receivables are paid later on the bill due date. He is liable for the bill charges, though. In the payment program, this procedure is only used for bills of exchange for outgoing payments.

If you use this procedure, bills of exchange payable and bills of exchange for the incoming check/bill of exchange procedure are printed.

The special features to be noted for the above-mentioned procedures during the payment program are described below.

The preparations necessary for posting bills of exchange and the procedure to be followed is described in [Special G/L Transactions: Bills of Exchange [Ext.]](#).
Bills of Exchange Payable: Payment Program Settings

Bills of Exchange Payable: Payment Program Settings

Bills of exchange payable are issued at different times depending on the country in question. In Germany and Austria, it is common not to issue the bill of exchange until the due date for payment of the invoice (the bill of exchange due date will be later than the invoice due date). In other countries, in France, Italy, and Spain for example, bills of exchange are issued after receipt of invoice. The bill of exchange payment occurs before the bill due date. You determine when the bill of exchange is issued by the payment program when configuring the payment program.

In contrast to the other payment methods, there are some special features that must be noted for bills of exchange payable. The following is true of bills payable:

- There must be a separate payment method classified for "bills of exchange".
- The bill liability that is created for you at the bank and printed on the bill of exchange should be posted to a separate bank subaccount and a clearing account.
- The payment program needs additional specifications for the posting such as the special G/L indicator for the bill payable.

The following is only of importance for bills of exchange issued before the due date:

- You can determine a bill of exchange limit for each customer/vendor; no bills may be issued for amounts above this limit.
- You can determine which open items are grouped together for payment by bill of exchange.
- You can specify a due date period (which must then be entered for any open items to be paid in order that they are paid by bill of exchange.
- You can specify charges, which are printed out on the bill of exchange forms (common in Spain).
Bills of Exchange Payable: Global Settings

Bank Accounts and Bank Clearing Accounts

When you use a bill of exchange to settle a payable, this payable is converted into a bill of exchange payable. The payment program clears the original payable from the vendor account and posts a bill payable to this account at the same time.

Two further postings are also created automatically for the bill of exchange posting depending on the system configuration: The first of these is a posting to a bank subaccount. This account displays the bill liability for each bank. It allows you to monitor when an outflow of funds is to be expected. The offsetting entry is made to a corresponding clearing account, so that the document has a zero balance. The posting to the bank subaccount is especially necessary for the Cash Management and Forecast application component, which is thus informed about the expected outflow of funds due to payment by bill of exchange.

If you want the payment program to create these postings, you must select the option Post bill liability to the bank in the company code specifications for the payment method. (In Company Code-Specific Definitions for the Payment Method: Graphic [Page 18], you can see the settings for the payment method Check. When viewing data for the payment method Bills of exchange, you see that additional fields are displayed for bills of exchange).

You should define the numbers of the accounts according to the company code, bank, payment method and currency in question. See the figure Bank Subaccounts for the Payment Program [Page 104].

Issue Date and Due Date (Date of Maturity)

The payment program enters the issue date and due date (day of expiration) into the bill of exchange. You can specify both dates manually during the payment run.

Additional Posting Specifications

You should define the special G/L indicator required by the payment program for a bill of exchange posting to the vendor account when you make the country-related specifications for the payment method. See Country-Specific Definitions for the Payment Method: Graphic [Page 15] (3)

The posting keys that the payment program needs for bank postings, posting the bill payable to the vendor account and the bill liability to the bank are already specified in the standard system.
## Bank Subaccounts for the Payment Program

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>CM</td>
<td>O</td>
<td>-</td>
<td>GIRO</td>
<td>113101</td>
<td>001</td>
</tr>
<tr>
<td>CM</td>
<td>S</td>
<td>-</td>
<td>GIRO</td>
<td>113101</td>
<td></td>
</tr>
<tr>
<td>CM</td>
<td>U</td>
<td>USD</td>
<td>GIRO</td>
<td>113101</td>
<td></td>
</tr>
<tr>
<td>BA</td>
<td>O</td>
<td>-</td>
<td>GIRO</td>
<td>113201</td>
<td></td>
</tr>
<tr>
<td>BA</td>
<td>S</td>
<td>-</td>
<td>GIRO</td>
<td>113201</td>
<td></td>
</tr>
<tr>
<td>CB</td>
<td>O</td>
<td>-</td>
<td>GIRO</td>
<td>113301</td>
<td></td>
</tr>
<tr>
<td>CB</td>
<td>S</td>
<td>-</td>
<td>GIRO</td>
<td>113301</td>
<td></td>
</tr>
<tr>
<td>CB</td>
<td>U</td>
<td>USD</td>
<td>USD</td>
<td>113302</td>
<td></td>
</tr>
<tr>
<td>CB</td>
<td>U</td>
<td>USD</td>
<td>GIRO</td>
<td>113301</td>
<td></td>
</tr>
</tbody>
</table>
Settings for Bills of Exchange Payable Prior to Due Date

Use

Bill of Exchange Limit
In the customer or vendor master record, you can specify a bill of exchange limit that determines the maximum amount for which a bill of exchange may be issued. If the amount to be cleared is over this maximum, the payment program splits the amount and issues further bills of exchange.

This makes sense if your vendor has an agreement with his house bank that bills of exchange are only cashed up to a certain amount. Limits for bills of exchange are used in Spain, for example.

Grouping Together Several Open Items
You specify whether certain open items should be grouped together for payment by bill of exchange via the specifications for the paying company code. See the topic Specifications for the Paying Company Code [Page 30] (2). You can specify that a single bill of exchange should be created

- For all invoices within a certain due date interval. The intervals are to be specified during the payment run.
- For all invoices which are due the same day.
- For every invoice.

Issue Date and Due Date
The issue date and the due date are entered into the bill of exchange by the payment program. You can specify both dates manually during the payment run. This is necessary for the date of issue once per payment run. You can select from the following alternatives for the due date:

- Specify before the payment run if invoices should be grouped together by due date interval. You should specify a due date for each bill of exchange in each interval.
- Do not specify a date if you want the due date to be taken from the paid invoices. All invoices that have the same due date are paid with a single bill of exchange.

Due Date Interval for Open Item Selection
To ensure that the payment program only issues a bill of exchange if this can be used for refinancing, you can specify for an item the minimum and maximum period (in days) before the due date for payment. See the figure Specifications for the Paying Company Code [Page 30] (3)

Only items that fulfill this condition are paid with a bill of exchange. This should ensure that the bill of exchange has a life which allows the vendor to deposit it at the bank for refinancing.

Charges
Charges can be designed as country-dependent or related to a specific house bank. You can calculate charges at the presentation of a bill of exchange, in order to:

- Check the bank settlement
- Print the charges on the bill of exchange form. This is required in Spain, for example.
### Account Determination

<table>
<thead>
<tr>
<th>Bank ID</th>
<th>Pymt mthd</th>
<th>Curr.</th>
<th>Account ID</th>
<th>Charge type</th>
</tr>
</thead>
<tbody>
<tr>
<td>CM</td>
<td>W</td>
<td>USD</td>
<td>GIRO</td>
<td>G1</td>
</tr>
<tr>
<td>BA</td>
<td>W</td>
<td>USD</td>
<td>GIRO</td>
<td>G2</td>
</tr>
</tbody>
</table>

### Charges

<table>
<thead>
<tr>
<th>Charge type</th>
<th>Amount limit</th>
<th>Curr.</th>
<th>Charges 1</th>
<th>Charges 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>G1</td>
<td>100,000.00</td>
<td>USD</td>
<td>10.00</td>
<td>5.00</td>
</tr>
<tr>
<td>G2</td>
<td>200,000.00</td>
<td>USD</td>
<td>20.00</td>
<td>7.00</td>
</tr>
</tbody>
</table>
Checks/Bills of Exchange Payable: Payment Program Settings

If the payment program is used to pay by check/bill of exchange, the bill of exchange is printed but not posted.

The bill of exchange does not need to be posted since you first send it to the vendor together with the check and wait for it to be returned. The payment program only supplies the data for printing the bill of exchange.

For the payment method "check/bill of exchange", the following special features are to be noted for the payment program:

The payment method must be classified as a payment method for check/bill of exchange.

The issue date and due date for the bill of exchange are entered by the payment program into the bill of exchange. You must specify them as a parameter for the payment run.

The payment program must enter a bank and a bank account number on the bill of exchange. When defining the ranking order of the banks, you can specify the bank and the bank account number for the payment method "check/bill of exchange" (see the figure below). To do this, specify the key for your house bank and the key for the corresponding bank account. The bank may be different from the bank on which the check is issued. If no bank details for the check/bill of exchange are available, the payment program also enters in the bill of exchange the bank for the check.

![Diagram of payment program settings](image)

<table>
<thead>
<tr>
<th>Paying Co.Cd.</th>
<th>Pynt mthd</th>
<th>Forms</th>
<th>Paid items printout</th>
<th>Specifications on the form</th>
</tr>
</thead>
<tbody>
<tr>
<td>0001 SAP AG</td>
<td>S Check</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. Form for payment medium: F110_D_SCHECK
2. Items per form: 99
3. Pyt. advice if form is full: 3
4. Extra forms if form is full: 4
5. Issuer:
   - Test name 1
   - Test name 2
   - 12345 Test city
Checks/Bills of Exchange Payable: Payment Program Settings

You must specify which form is used for check/bill of exchange when making the specifications for the payment methods in each company code. See the figure Form Printing Specifications [Page 42] (1).
Bank Bills and Bill of Exchange Payment Requests: Payment Program

Use

In France, Spain and Italy, the following bill of exchange receivable procedures are used:

- **Bank bills**
  
  You can issue the bill of exchange and submit it to a bank for discounting without it having been accepted by the customer. This procedure is used if such an agreement was made with the customer.

- **Bill of exchange payment request**
  
  You issue the bill of exchange and send it to the customer for acceptance. Only once the customer has accepted the bill of exchange do you post it.

The payment program can create both these types of bills of exchange.

Both bank bills and bill of exchange payment requests enable customers to gain a longer payment period. The due date is generally fixed later than for standard invoices. The customer pays the receivable by bill of exchange far in advance of the due date for payment. With this procedure, the due date of the bill of exchange is equal to the invoice due date. You receive your money earlier since you can discount the bill of exchange immediately. Any bank charges incurred thereby are payable by you.
Bank Bills: Special Features

Use

Bank bills are issued by the payment program. They are drawn up as soon as possible after invoice. If you wish, you can have the payment program clear the invoices paid with the bill of exchange or first create a noted item. See topic Bill of Exchange Payment Requests: Special Features [Page 111] In the customer account, a note is made in the noted items that a bill of exchange was issued. The actual posting is only made if the amount was credited to the bank account.

If the payment program has already cleared the invoices, it notes the bill of exchange document number in the invoice line items. This enables you to establish with which bills of exchange the invoices were cleared. If a bill of exchange is not honored you can cancel the payment by bill of exchange and post a new receivable for every corresponding invoice to your customer.
Bill of Exchange Payment Requests: Special Features

Use

A bill of exchange payment request, (that still awaits acceptance by the customer) is marked as a noted item in the customer account and the special G/L account for bills of exchange receivable. No transaction figures are updated. Nor are any open items yet cleared, since the customer may not accept the bill of exchange or choose to modify it.

The payment program issues the bill of exchange payment request (bill of exchange without acceptance). It also copies the document number of the bill of exchange payment request into the invoice line items that are to be cleared with the bill of exchange. See the figure below.

The bill of exchange is accompanied by a payment advice, which informs the customer about which invoices should be paid with the bill.
Bill of Exch. Pymt Requests, Bank Bills, and the Payment Program

Note the following features when making payment by "bank bill" or "bill of exchange payment request":

- You can combine several open items for payment. You determine the criteria according to which the items should be grouped for each paying company code.
- You can specify which due date the items must have in order that you are paid with a bill of exchange. You should also specify this criterion for the paying company code.
- You can also enter a bill of exchange limit, beyond which no bills of exchange are issued. You enter the specifications for this in the master record of the customer.
- Before the payment run, enter the issue date and due date (day of expiration).
- The payment program needs bank details in order to print a bill of exchange. You enter the specifications for this in the master record of the customer.
- In order to make automatic postings, the payment program needs posting keys and special G/L indicators. These specifications are already defined in the system.

A prerequisite for posting bill of exchange payment requests and bank bills is that the payment methods are classified accordingly.

Special Specifications for the Paying Company Code

You set whether certain open items should be grouped together for payment by bill of exchange via the specifications for the paying company code. See the topic Specifications for the Paying Company Code [Page 30] (2). You can specify that a single bill of exchange should be created

- For all open items that lie in a due date interval. The intervals are to be specified during the payment run.
- For all invoices that are due the same day.
- For each invoice

In order that you can use the bill of exchange for refinancing, the bill of exchange due date must not be too far in the future. On the other hand, bills of exchange with a due date in the near future should be issued as a bill on demand so that they can be submitted for payment immediately.

Via the specifications for the paying company code, you determine the maximum number of days before the due date an item may be paid with a bill of exchange. See Specifications for the Paying Company Code [Page 30] (3). In addition, you should specify how many days from the start of the payment run a bill of exchange should be created as a bill on demand. The payment program adds the specified days to the posting date of the payment run and compares the result to the bill due date.
Issue Date and Due Date for Bill of Exchange Payment Requests, Bank Bills, and the Payment Program

The issue date and the due date are entered into the bill of exchange by the payment program. You can specify both dates manually during the payment run. This is necessary for the date of issue once per payment run. You can select from the following alternatives for the due date:

- Specify before the payment run if items should be grouped together by due date interval. You should specify a due date for each bill of exchange in each interval.
- Enter * if you want the program to average the due date on the basis of the paid invoices.
- Do not specify a date if you want the due date to be taken from the paid invoices. All invoices which have the same due date are paid with a single bill of exchange.

Special Specifications in the Customer Master Record

The payment program puts the bank details of the customer and the account number into the bill of exchange automatically. The program transfers the first bank details and their account number from the master record of the customer, unless bank details are specified in the item.

In addition, you can specify a bill of exchange limit in the master record of the customer. This determines the maximum amount for which a bill of exchange can be issued. In some countries, there are agreements between the bank customer and his/her house bank that a bill of exchange is only cashed up to a specified maximum amount. In these cases, enter a bill of exchange limit into the master record of the customer. If the amount to be cleared is over this maximum, the payment program splits the amount and issues further bills of exchange.

Posting Keys and Special G/L Indicators

The posting keys that the payment program needs are stored in the system. There are keys for the following postings:

- Bill of exchange payment request to the customer account and the special G/L account
- Bill of exchange posting to the customer account and to the special G/L account

The special G/L indicator that the payment program uses for posting the bill of exchange payment request must be specified in the country-specific specifications for the payment method.

In the standard system it is the special G/L indicator R. A special G/L indicator must also be stored for the bank bill. In the standard system this is the special G/L indicator W.
Executing the Payment Program

This section describes how to execute the automatic payment program. The payment program is capable of processing both outgoing and incoming payments. It can process in both Accounts Receivable and Accounts Payable.

The payment program processes domestic and foreign payments for vendors and customers. It creates payment documents and supplies data to the payment medium programs. These payment medium programs print either a payment list, payment forms (for example, checks) or create data carriers such as magnetic tape or floppy disks.

The standard system contains payment medium programs and forms for the most common payment methods. It can also create payments on disk. Note that payment forms and file formats vary from country to country and sometimes also from bank to bank. Details on the payment forms and file formats in your country can be found in the country-specific program documentation. You can design new payment forms and modify the existing ones using the tools offered by SAPScript. These tools are described in the Basis documentation.

The payment medium program stores data in the SAP print administration and (where DME is used) in the DME administration. From there, data is picked up separately per form/data carrier and output to the printer or data carrier.
Processing Open Items

1. Proposal run
2. Payment run
Overview of the Payment Run Procedure

This topic gives a general overview of the precautions and processing steps that need to be taken to execute a payment run.

Planning and Parameter Specifications

If you have several house banks that you can use for your payment transactions and have limited funds in these accounts, you will have to plan the cash balances available for each bank account and specify the ranking order by which the program is to use these accounts. In addition, because there are several house banks available to the payment program you have to enter the order in which the bank accounts are selected.

Before every payment run, you need to specify which company codes, account types, and accounts to include in the payment run. Furthermore, you have to enter the desired posting date, the possible payment methods, and the date of the next payment run. There are also some other optional specifications that you can make.

Creating the Payment Proposal

Once the specifications for the payment run are complete, you can schedule the payment proposal. In a window, you either enter the desired start date and time or arrange for immediate execution. The status display shows you which step the job currently is at.

If the payment proposal is created, the system first checks the results, reading the proposal log and recording any exceptions in it. This includes the reading of the proposal log in which all exceptions are recorded.

By displaying or printing the payment proposal list or by editing the payment proposal, you can get an overview of the payments proposed by the program.

Editing the Payment Proposal

You can divide payment proposal processing between the clerks responsible. To do this, you must specify the accounting clerk ID stored in the master record after accessing payment proposal editing.

It is possible to make changes when editing the payment proposal. You can make changes to the payment (payment method, house bank) and the items paid (block indicator, cash discount). All changes you make affect only the payment proposal. No changes are made to the source documents.

Executing the Payment Run and Payment Medium Programs

Once you have accepted the payment proposal or have finished editing it, you can schedule the payment run. The job created for the payment run will contain either only the payment program as one step or an extra step for each payment medium program and each variant. In the latter case, you need to specify which variants to use for each payment medium program prior to scheduling the payment run. In scheduling the run, you specify the desired start time and select the print programs option.

If you want to run only the payment program first, you can schedule the print programs for a different time in a separate job.
Selecting Banks and Planning Available Amounts

Use
The payment program helps you to optimize your payments. To schedule your cash receipts and payments, you must:

- Define the bank selection
- Define the available amounts These specifications will depend on the size and structure of your organization.

Defining Bank Selection
If you have several bank accounts for the same payment method and the same currency (for example, check accounts in local currency), you can define the sequence by which the payment program is to use these bank accounts. If the funds of the first bank account are exhausted, the payment program automatically selects the second bank account, and so on.

Defining Available Amounts
You can define, per bank account, up to what amount of receipts and payments can be carried out through that account. This can be of benefit, for example, if you want to preserve the ability to pay for an item which is not made by the payment program.

Graphic
The figure Bank Selection [Page 118] shows how the principles of bank selection and control of available amounts work.
# Bank Selection

## Table 1: Bank Selection Details

<table>
<thead>
<tr>
<th>Payment</th>
<th>Order</th>
<th>Bank ID</th>
<th>Bank name</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>1</td>
<td>301</td>
<td>Citibank</td>
</tr>
<tr>
<td>S</td>
<td>2</td>
<td>300</td>
<td>Bank of America</td>
</tr>
</tbody>
</table>

## Table 2: Additional Payment Details

<table>
<thead>
<tr>
<th>Bank ID</th>
<th>Payment Method</th>
<th>Planned amt</th>
<th>Bank name</th>
</tr>
</thead>
<tbody>
<tr>
<td>300</td>
<td>S</td>
<td>70,000</td>
<td>Bank of America</td>
</tr>
<tr>
<td>301</td>
<td>S</td>
<td>50,000</td>
<td>Citibank</td>
</tr>
</tbody>
</table>

The system will attempt to pay checks from the Citibank account until the available amount of 50,000 USD has been used up.
Sample Bank Selection and Control of Available Amounts

You want to use the payment program to pay five open items to five different vendors:

- Payment to first vendor 40,000
- Payment to second vendor 30,000
- Payment to third vendor 20,000
- Payment to fourth vendor 7,000
- Payment to fifth vendor 12,000

## Sample Bank Selection

<table>
<thead>
<tr>
<th>Available Amounts for Automatic Payments</th>
<th>Bank A Prio 2</th>
<th>Bank B Prio 1</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before debit memo from first customer</td>
<td>70,000</td>
<td>50,000</td>
<td></td>
</tr>
<tr>
<td>After debit memo for first customer</td>
<td>70,000</td>
<td>10,000</td>
<td>Bank B Prio 1</td>
</tr>
<tr>
<td>(40,000)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>After debit memo for second customer</td>
<td>40,000</td>
<td>10,000</td>
<td>Insufficient amount at bank B</td>
</tr>
<tr>
<td>(30,000)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>After debit memo for third customer</td>
<td>20,000</td>
<td>10,000</td>
<td>Insufficient amount at bank B</td>
</tr>
<tr>
<td>(20,000)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>After debit memo for fourth customer</td>
<td>20,000</td>
<td>3,000</td>
<td>Bank B Prio 1</td>
</tr>
<tr>
<td>(7,000)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>After debit memo for fifth customer</td>
<td>8,000</td>
<td>3,000</td>
<td>Insufficient amount at bank B</td>
</tr>
<tr>
<td>(12,000)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Procedure for Controlling Bank Selection

You can access the payment program via the Accounts Payable menu as well as the Accounts Receivable menu. Choose Periodic work → Payments.

Determining Ranking Order of Bank Selection

To determine the ranking order of bank selection, proceed as follows:

1. Choose Environment → Maintain configuration. This takes you to the initial screen for configuring the payment program.

2. Choose Bank → Bank selection. You receive a list of company codes for which payment methods have been defined.

3. Select a company code for which you want to make your specifications.

4. Give the ranking order for every payment method (starting with 1) and the Bank ID of the bank which is to be used for payments.

Only make an entry in the currency field if another ranking order is to apply, depending on a certain currency. If this is the case, insert corresponding entries for this currency.

Determining Available Amounts

To determine the available sums of money in your bank accounts, proceed as follows:

1. Choose Environment → Maintain configuration. This takes you to the initial screen for configuring the payment program.

2. Choose Banks → Available amounts. You receive a list of company codes for which payment methods have been defined.

3. Select a company code for which you want to make your specifications.

4. For every bank, every account, and every currency enter the available sum of money into the column Outgoing payment. If there is no entry for the currency, the entry is valid in local currency. With this, determine the maximum amount which the payment program can take from this account.

If you always have sufficient means of payment in all your bank accounts, you can enter the amount 9,999,999,999 for all banks, all accounts, and all currencies during the setting up of the system.

Further information on defining banks and bank accounts can be found in Bank Accounts and Bank Subaccounts [Page 88]
Entering Payment Parameters

Use
Before you can start the payment run, you first have to enter the payment parameters. You use these payment parameters to define when, for which period, which company code, which business partners, and so on should be considered by the payment program.

Procedure
1. From the SAP Easy Access Menu, choose Accounting → Financial Accounting → Accounts receivable/Accounts payable → Periodic Processing → Payments.
   The Automatic Payment Transactions screen appears.
2. Enter the following data:
   - **Date of execution**
     Enter the date for which the payment run should be executed.
   - **Identification**
     Choose an alphanumeric key to uniquely identify the payment run. This is necessary should you schedule several payment runs for the same day.
3. Choose the Parameters tab.
   Here, you can either enter payment parameters or copy parameters from a previous payment run (choose ). Otherwise, enter the following data:
   - **Posting date**
     Enter the date to be printed on the payment media.
   - **Documents entered up to**
     Enter the date up to which documents should be considered in the payment run. The creation date and not the posting date is definitive here. Open items entered after this date are not processed in the payment run.
   - **Due date**
     Date by which an open item must be due in order to be considered in the payment run. If you do not specify a due date, the posting date counts as the due date.
   - **Company code**
     Enter the four-character company codes that you want to pay.
   - **Payment methods**
     Enter the keys of the payment methods that are to be used for every company code or company code interval in this payment run. The sequence of the keys determines which methods are used to pay open items, when no particular payment method has been specified in the open item or master record.
   - **Next posting date**
     Enter the posting date of the next payment run. Using this date, the program determines whether the open items are paid in this payment run or the next.
   - **Account restrictions** (optional)
     If you want to restrict payment to specific customers or vendors, enter the required data. You thereby restrict the number of accounts to be paid.
Entering Payment Parameters

To clear items with each other from a business partner that is both a customer and a vendor, enter both account numbers. The payment program then determines a joint balance (see Clearing Customers and Vendors [Page 65]).

Open items for which no payment method has been specified, can be settled using various payment methods (e.g. check (C), transfer (T) or bill of exchange (B)). If you enter, for example, BTC in the parameters, the system first checks whether a bill of exchange can be generated. If this is not possible, the same check is made for a bank transfer. Should this also not be feasible (for example, because of inconsistencies in the customer/vendor's bank details), then the system checks whether the items can be paid by check.

4. You can make further restrictions to the payment run. Choose the Free selection tab.

You can enter up to three additional selection criteria for accounts and documents. Fields of tables BSEG, BKPF, LFA1, LFB1, KNA1, and KNB1 serve as selection criteria. You can assign values to these fields, and include or exclude those values during the search.

The system expects the entries to be made either as a list of individual values, e.g. value 1, value 2, value 3, and so on, or as a list of intervals, e.g. (from value 1, to value 1), (from value 2, to value 2). However, you can enter individual specifications and intervals at the same time. A comma must separate them, and no blanks should be used. Set intervals between brackets - (" "). Specify individual values using the defined field length; do not omit leading zeros.

5. You can define criteria for an additional log. Choose the Additional log tab.

If you call up the log later on, the system displays the processing logic of the payment program in appropriate detail. Before doing anything, you should read the note under Checking the Log [Page 129] in "Creating the Payment Proposal".

The following processing steps can be logged.

- Due date check
- Payment method selection in all cases
- Payment method selection if not successful
- Payment document items

Click next to the corresponding option and enter the account numbers of the vendors or customers.

6. Save your entries and then choose the Status tab.

Here, the system displays the current status of each of the payment runs.
Specifying the Payment Medium Program and Variants

Use

There is one payment medium program for each payment method. This program prints the payment forms or creates the data media on disk. You can specify different payment medium programs for the payment methods you specify in the payment parameters.

Procedure

On the Automatic Payment Transactions screen, select the Printout/data medium tab.

Enter one or more variants for every payment medium program used to print the payment data for a payment method.

You can also specify variants for creating the payment proposal list (RFZALI00) and exception list (RFZALI10) on this screen.

You can find further information on payment medium programs and variants in Printout Control [Page 141] and in Creating a Payment Medium Report Variant [Page 185].
Entering Additional Specifications for a Bill of Exchange

Use

In countries such as France, Spain, and Italy, bills of exchange are issued directly after the invoice is issued.

When paying by bill of exchange, additional specifications are required, according to which variants were set during customizing. The issue date must, however, always be specified. The payment date appears here as a proposal figure.

For bills of exchange in countries such as France, Spain, and Italy, one of the following procedures is set during Customizing:

- One bill of exchange per invoice
- One bill of exchange for all invoices that are due on the same day
- One bill of exchange for all invoices due within a certain predetermined time period (for example, a week).

If the latter procedure is set, you must specify the periods in the payment run and the bill of exchange due date for each period.

If you do not specify a due date for the bill of exchange, the system calculates one automatically. This calculation results in the average due date of all the invoices in that period.

Procedure

To enter bill of exchange data, on the Automatic Payment Transactions screen, choose Edit → Bill of exchange data, then choose Continue.
Entering Authorizations

When entering the payment parameters, you can restrict the authorization to change the payment parameters to a limited number of users. Proceed as follows:

1. Choose Edit → Authorized users.
2. Enter the SAP user names of the users to whom you are giving authorization to change the payment parameters.
3. To continue, choose Continue.
Creating the Payment Proposal

Purpose

After you have specified all parameters for the payment run, the payment proposal can be created.

The payment proposal displays the open items whose payment is proposed by the payment program (depending on its configuration). The criteria that determine the selection of the open items are described in detail in Selecting Open Items [Page 52].

Process Flow

The figure Creating a Payment Proposal [Page 127] shows the theoretical procedure behind the creation of a payment proposal.
Creating a Payment Proposal

Configuration/Parameters

Create

User schedules payment proposal

Payment proposal runs . . .

Payment proposal created

User checks:
- Pyrm proposal log
- Proposal list
- Exception list

Edit payment proposal
Planning a Payment Proposal

Planning a Payment Proposal

In order to plan a payment proposal, proceed as follows:

2. Enter the start date and time.
   If the payment program is to immediately create the payment proposal, you must click in the field Start immediately.
3. If you want to test the payment medium programs using the dunning proposal data, select the option with print programs. This is generally only useful in the testing and configuration stages.
4. Choose ENTER.

   As well as the payment medium programs you can also schedule the reports for generating the payment proposal list (RFZALI00) and the exception list (RFZALI10). The names of these reports have been entered beforehand using PRINT PROGRAMS.

   The additional option With lists then appears in a pop-up window.

Status Display

The system tells you that the proposal is being processed. Each time you choose ENTER, the current status of the proposal run is displayed. Upon completion of the job, the message that the proposal run has been executed appears.
Checking the Log

After you have created the payment proposal, you should call up and read the log. To do this, choose Edit → Proposal → Display log.

The log informs you of possible configuration errors. In this case, no payment is possible. You must correct the errors, delete the payment proposal, and carry out a new payment proposal.

If you entered criteria for an additional log during parameter maintenance (for example, payment method selection in all cases) the log will be more extensive processing will take longer. An additional log is only to be defined in exceptional situations or for testing purposes.
Displaying the Payment Proposal

When you displaying the payment proposal, you can also gives you the capability to monitor its contents. Every payment is displayed, even if you divided processing between different accounting clerks. Following processing, you can view the payment proposal again to see which changes have been made, and by which clerks.

To display the payment proposal, choose Edit → Proposal → Display. To obtain a general overview of the created payments, use the functions Sort and Search.
Generating a Proposal List

To generate a complete proposal list, choose Edit → Proposal → Proposal List.

A window displaying the program name (RFZALI00) will appear. If a variant was set up, enter the variant name and choose ENTER.

You then receive a complete overview of all payments and line items.

The end of the list contains a breakdown of the payment amounts sorted by

- Business areas
- Countries
- Currencies
- Payment Methods
- Banks

You can view this information online or print it out.
Evaluating the Exception List

In addition to the proposal list, you can display or print out an exception list. The exception list displays blocked items and all open items which the payment program did not propose for payment.

The exception list contains:

- Blocked items
- Special G/L transactions (depending on the configuration of your system)
- Items that could not be settled despite being due

The reason for the exception is represented by an error number. The list includes an error text for every error reason.

To generate an exception list, choose Edit → Proposal → Exception list.

This brings up a window with the name of the program (RFZALI10). If you want to print the list, enter the appropriate variant name and choose ENTER.
Editing the Payment Proposal (Online)

Once the payment proposal is created, you can edit it online. Both payments and line items can be processed and edited.

You can divide payment proposal processing between different clerks. It is therefore possible for several people to process extensive proposal runs in parallel. You can then use the display function to track what changes were made and who made them.

All changes made when editing the payment proposal affect only the payment proposal. All changes you make affect only the payment proposal. No changes are made to the source documents.
**Editing Payments**

You can use the following functions to help you edit payments:

- Sort
- Search
- Change line layout
- Totals display

To process payments, choose Edit \(\rightarrow\) Proposal \(\rightarrow\) Edit proposal. The system displays a dialog box in which you can choose whether to edit every payment (all clerks) or only those for which you are responsible (clerk ID code).

The payments selected are then listed on the next screen (list level 1). One line item is displayed per payment. If there are any exceptions for an account (for example, blocked items), an additional line item appears in the list.

**Sorting Payments**

You can sort payments by certain criteria. To do this, choose Edit \(\rightarrow\) Sort. Choose the desired sort criteria and sequence.

You can select up to four fields as sort criteria. To do this, either enter the numbers 1 through 4 in the respective fields, or double-click in each field in the appropriate order (the number one will appear in the first field selected, the number two in the second, and so on).

**Searching for Payments**

You can shorten the payment list by searching for particular payments. To do this, choose Edit \(\rightarrow\) Find. Select the type of payment field you want to search for, for example, Amount paid in local currency. In the dialog box that follows, enter the appropriate values or value ranges.

The system now searches for the payments you searched for and displays these in a list. To narrow down the number of payments still further, choose Edit \(\rightarrow\) Find again, and enter a further search criterion, for example, Payment method.

**Changing the Line Layout**

To change the line layout, choose Settings \(\rightarrow\) Line layout, and then select the desired line layout in the dialog box.

**Totals Display**

You can display the total of proposed payments using four summarization levels. To do this, choose Goto \(\rightarrow\) Display totals. You can then select the desired summarization level.

Select the required summarization level and choose ENTER. To list the summarization levels in another sort sequence, choose Edit \(\rightarrow\) Sort. A window appears in which you can change the sequence of the totals display.

To enter the sequence in the respective fields, enter the numbers 1-4 manually, or place your cursor in each field and select Choose. Alternatively, enter the numbers by double-clicking in each field.
The standard settings for the *Sort*, *Find*, *Change line layout*, and *Display totals* functions depends on your system configuration, and can be changed in Customizing.
Changing Payments

In editing payments online, you can change the:

- Payment method
- House bank
- Due date

To do this, position the cursor on the payment you want to change, and choose Edit → Change. The system displays a dialog box in which you can change the payment method and house bank.

Changing the Payment Method

To change the payment method, simply enter a new indicator, and then choose Continue. The system checks whether your entry is permissible. If it is not, an error message appears. You can only use payment methods:

- Which were preset with the parameters of the payment run.
- For which the necessary specifications, for example, bank details for a wire transfer, are available in the master record.

Changing the House Bank

To change the paying house bank, enter the required bank name and account ID. Then, choose Continue.

The system checks whether the selected bank was set up in Customizing. If not, an error message appears.

Changes you make are only effective once you save them.

When making changes to a lot of payments, you should save your data frequently. By choosing Environment → Payment changes, you can display the change history and also see which changes have not yet been saved.

Changing a Payment Due Date

You can enter a new payment due date. The new date cannot be before the payment run date or - except for bill of exchange payments - be more than 30 days after the payment run.
Editing Line Items

You can edit line items for a payment or an exception list at a second list level. You can use the following functions to help you edit line items:

- Sort
- Search
- Change line layout

To edit line items of a payment, double-click the desired payment line. The system then displays the open items of this payment on another screen.

Sorting Line Items

To sort open items, choose Edit → Sort. This brings up an additional window where you can sort the line items according to four criteria and define a sequence (see "Sorting Payments" in Editing Payments [Page 134]).

Searching for Line Items

To search for particular open items, choose Edit → Find. Select a search criterion and enter the desired values or value ranges (see "Searching for Payments" in Editing Payments [Page 134]).

Changing the Line Layout

To change the line layout, choose Settings → Line Layout, and select the required line layout variant. There are four variants delivered with the standard system.

The standard setting for the sort, find, change line layout, and display totals functions depends on your system configuration. You can change it in Customizing.
Changing Line Items

In online editing of line items, you can:

- Block or unblock line items
- Change the cash discount amount
- Assign line items to another payment

To make these changes, position the cursor on the line item you want to change, and choose Edit → Change.

Blocking/Unblocking Line Items

To block open items for this payment run, enter a block indicator in the Payment block field and choose Continue.

A blocked line item is indicated in the list display with an arrow (←→). This means that the open item no longer belongs to the payment. If you now display the list of payments by pressing F3 (BACK), you see that the blocked line item has been transferred into the group of exceptions and the outgoing payment has been reduced by the corresponding amount.

To reset a block indicator, position the cursor on the exception list in question and select Choose. Position the cursor on the items that you want to unblock and choose Edit → Change. Overwrite the block indicator in the dialog box.

In a payment proposal, you can set and delete only those block indicators that can be edited. Block indicators that can be edited are determined in Customizing.

Changing the Cash Discount Amount or the Cash Discount Rate

To change the cash discount amount, place the cursor on the Cash discount field or the days for cash discount, and change the amount.

Assigning Line Items to Another Payment

You can remove line items from one payment and assign them to another one. To do this, choose Reassign in the change dialog box. If there are other payments for this account in the proposal, the system will list the payments to which you can assign the item. Select one of the displayed payment methods by selecting Choose.

You can even create a new payment for the item. To do this, choose New payment, and enter the payment method, house bank, and account into the fields provided. If no other payment exists for the account, you will have to create a new payment to assign the item to.

After you choose Continue, the system checks whether your entries correspond to the payment program configuration. If they do not, an error message appears.

Open items you assign to another payment are indicated by an arrow (←→) in the list displayed. The arrow indicates that this item will be removed from the current payment and transferred to another, once you save the data.

If you return to the first list level from the open item display, you can see the newly added payments. These are marked with an arrow (→) prior to saving the changes.
Changes you make become effective only if you save them.

**Blocking All Items of a Payment**

If you want to block all items of a payment, you can do this by choosing *Block all*.

When making changes to a lot of open items, you should save your data frequently. By choosing *Environment → Line item changes*, you can display the change history and also see which changes are not saved yet.
Running the Payment and Payment Medium Programs

Running the Payment and Payment Medium Programs

Once you have edited and accepted the proposal, you can plan the payment run. Several programs are used in creating the payments:

- The payment program creates the payment documents and prepares the data for printing the forms or creating the tape or disk.

- Various payment medium programs use the data prepared by the payment program to create forms or files for the data media.

Basic Procedure

You can choose from the following options when carrying out the payments:

- You can schedule just the payment program first, and then once the run is completed successfully, you can schedule the payment medium program.

- Or you can schedule the payment program and the payment medium program at the same time.

- Or you can execute the payment program first, and then once the run is completed successfully, you can execute the printout online.
Printout Control

Use

You can carry out a payment run for different company codes, payment methods, and business partners even though different forms or data carriers may have to be printed or created for each payment method and company code. To distinguish between the different types of forms and media, you use variants in the payment medium programs.

Variants are defined when configuring the payment program. You can define as many variants as you require for each payment medium program. You have to define at least one.

The names of the payment medium programs for the individual countries have the following naming conventions:

RFFO<Country indicator>_<Payment method>

The program titled RFFOUS_T generates bank transfers in ACH format for the USA.

You can find the names of the payment medium programs in the country-specific payment method data (in the system configuration tables).
Functions of the Variants

Use

Variants contain a series of selection criteria that separate the payment dataset. Each variant called up in a payment medium program triggers a separate print request in the output controller or creates a separate file in DME administration. Each print request is displayed in print administration. You can call up the print jobs individually for printing.

You execute a payment run for payment methods "check" and "order check" using program RFFOD__S. The payment program creates a print file for this payment run. Since each payment method uses specific forms, you define a separate selection variant for each payment method for the print program RFFOD__S. The system creates a print request for each variant:

![Diagram of payment process]

When creating variants for the payment medium programs, you should always leave the fields for the run identification, run date and proposal run blank. These fields are always filled automatically with the appropriate data for the run in question.

You can find more detailed information on print control and using forms in *Forms [Page 28]*.
Checking the Payment Log and Payment List

Prior to printing the forms, you should view the payment log and check over the payment list to make sure that the payment run was completed successfully.

To check the payment run, read the payment log and check the payment list before you print the forms.

To call up the payment log, choose Edit → Payment → Display log.

To display the payment run, choose Edit → Payment → Display.

You can use the search and sort functions in this display to get a quick overview of the payments. Moreover, you can display a history of the changes made to the payment proposal, which will show which clerks made which changes. To do this, choose Edit → Proposal → Display.

To simply display and print the payment run, choose Edit → Payment → Payment list.
Executing the Payment Medium Programs Separately

Always ensure that the payment run and ensuing postings have been successfully completed before starting the payment medium program. In the status display, you can see how many documents were created and how many of them have already been posted.

You must have your required variants already defined in the system for the payment medium program. To learn how to define these variants, read Creating a Payment Medium Report Variant [Page 185].

The following steps describe how to execute the payment medium programs separately from the payment run. If you have already entered variants for the payment medium programs, skip to step 4 below.

1. Choose Edit → Print Programs from the Automatic Payment Transactions screen. You then reach the screen for entering variants.

2. Check whether the required variants have been entered. If not, enter the variants created for the data medium exchange into the corresponding payment medium program.

3. Choose Parameters → Save. You will again reach the Automatic Payment Transactions screen.

4. In the Automatic Payment Transactions screen, choose Edit → Payments → Schedule print.... A dialog box appears.

5. Enter the required start date and specify the job name.

The program will now generate, for each variant, separate files in the output controller where you select and print them separately. The numbers of the generated print requests can be found in the print run log.

1. Choose System → Services → Output controller. You will then reach a screen from which you can access the print requests. If necessary, reset the date to the print run start date.

2. Choose Spool request → List. The next screen lists the print requests.

3. For each job, enter the corresponding form and position the cursor in the system on the appropriate print job. If several printer connections exist, you will be able to carry out several print jobs simultaneously by selecting them as well.

4. Choose Display to view the forms on your monitor.

5. Choose Spool request → Print to print the forms.

Files may also be generated for data medium exchange. You can access DME administration via Environment → DME administration. You can access further information on DME administration under Data Medium Exchange and Data Medium Administration [Page 182].
Scheduling the Payment Program and Payment Medium Programs Jointly

To be able to execute the payment program and payment medium program jointly, you must have entered the payment medium program variants. You can read how to do this in Running the Payment and Payment Medium Programs [Page 140].

To schedule the payment and payment medium programs jointly, proceed as follows:

1. Choose Edit → Payments → Schedule payment.
2. Enter the start date and time for the background job in the additional window.
3. Select the option With print programs.
4. Select ENTER.

The documents generated by the payment program are first saved to the log file and then posted later. This makes it possible for all documents to be available only a short time after the end of the payment run.

Some payment medium programs require information from the posted documents for form printing, with others you can switch on a check of the posted documents with parameter settings. In these cases, you must first ensure that the programs only start if all payment documents are posted. This can only be guaranteed if the payment medium programs are separately scheduled for a later point in time.

In the status display, you can see how many documents were created and how many of those have already been posted.
Starting the Payment Medium Programs Online

In order to avoid unnecessarily burdening the system while it is up and running, you should only start payment medium programs online for:

- Small payment runs
- Additional generation of individual payment media
- Cases in which an interactive processing is required, such as error searches.

To start online printing, proceed as follows:

1. Choose System → Services → Reporting.
2. Enter the name of a payment medium program, for example RFFOD__S, and execute the program, with variants if necessary. You must also enter at least the payment run date and the payment run ID.
3. Execute the program.

   On the next screen, you will find information on the generated payment media. You can go to the print administration or DME administration programs with a double-click on the output file.
Recognizing and Eliminating Form Printing Errors

Various errors can occur while printing forms, for example

- **Termination of Processing**
  
  The cause for program termination (i.e., the production run had not been carried out yet, the form does not exist or is not active) will be reported in the error message and in its accompanying help text.

- **Internal SAPScript error**
  
  Check the structure of the form. It has to be in compliance with the parameters listed in the program documentation. For example, it is not possible to generate a transfer via the check printing program, since transfers and checks have a completely different form structure.

**Error Log**

If errors which do not cause the payment program to terminate abnormally occur as the task is being generated, they will be listed in the error log. If such an error log is indeed generated, it must be reviewed. You then need to decide whether the error rendered the payment medium or payment advice notes invalid, and whether they need to be newly created after you have eliminated the condition that caused the error.

In background processing, the error log will be output twice, once in the job run log and once in the print job file. You can find useful information regarding these errors in the error message help texts which are output with the run log.
Payment Medium Workbench

Purpose

The Payment Medium Workbench (PMW) is a tool used to configure and create payment media sent by organizations to their house banks. This generic tool will gradually phase out the classic payment medium programs (RFFO*) due to the range of advantages that it provides.

- Superior control and verification of payment procedure
- Improved performance with mass payments (> 50,000)
- Better sort functions with payment advice notes
- Clearer to work with than the myriad previous payment medium programs
- Easier to maintain and to extend

Implementation Considerations

Before you can use the Payment Medium Workbench, you have to make various settings in Customizing. You can find the relevant activities in Customizing for Financial Accounting, under Accounts Receivable and Accounts Payable → Business Transactions → Outgoing Payments → Automatic Outgoing Payments → Payment Media → Make Settings for Payment Medium Formats from Payment Medium Workbench [Ext.].

Integration

The Payment Medium Workbench can be used by several components, for example FI-AP/AR, FI-TV, HR-PY, TR-CM, and TR-TM.

Features

The Payment Medium Workbench is embedded in a development environment. You can access all Workbench objects, (program objects, dictionary objects, and mapping tool objects) with a double-click. The Payment Medium Workbench encompasses the following areas:

1. Customizing for payment media
   - Defining Payment Medium Formats [Page 153]
   - Adjusting payment medium formats
   - Adjusting the Note to Payee [Page 156]
   - Assigning payment medium format and note to payee
   - Creating, Assigning, and Transporting Selection Variants [Page 159]
2. Creating Payment Media [Page 150]
   - Creating payment media without documents in file form
   - Output of the created data media into DME administration
     DME administration supports both files stored in the TemSe or the file system, and payment messages like Internet payments (OFX) or IDoc.
   - Creation of payment advice notes
Output of the created payment advice notes as letter, fax, or IDoc

Creation of an output log (an error log too, if necessary) for each program run of the payment medium program

**Constraints**

At the present time, not all formats that can be created using the classic payment medium programs (RFFO*) are supported. You can display a complete list of available payment medium formats in format definition, or by using input help (in configuration of payment methods in the country, for example).
Creating Payment Media

Purpose
The following describes creation of payment media using the Payment Medium Workbench [Page 148].

Prerequisites
When you configure the payment program you decide whether you want to use the classic payment medium programs or the Payment Medium Workbench. You have to make this decision for every combination of country/payment method and sometimes supplement the data.


Use Payment Medium Workbench
1. In the screen Change View "Payment Method/Country": Overview select the required combination of payment method/country with a double-click.
   The Change View "Payment Method/Country": Details screen appears.
2. In the screen area Payment medium select the option Use payment medium workbench.
3. In the same screen area enter or check the Format and the Format supplement and save your entries.

Checking Formula Entries
1. In the upper screen area choose Use in company codes.
   The system displays the Display View "Maintenance of Company Code Data for Payment Method": Overview screen.
2. Choose the change mode and select your company code by double-clicking on it.
   The system displays the Change View "Maintenance of Company Code Data for a Payment Method": Details screen.
3. Choose Form data and check or supplement the existing formulas for your company code.
4. Save your data and choose Exit.
   The Change View "Payment Method/Country": Details screen appears again.

Check Note to Payee by Origin
1. In the selection tree choose Note to Payee by Origin.
   The Change View "Note to Payee by Origin": Overview screen appears.
2. Check or supplement the existing note to payee.
3. Choose Back.
4. The Change View "Payment Method/Country": Detail screen appears again, and you should now save the data.

**Process Flow**

**Creation of payment media**

Creation of payment media using the *Payment Medium Workbench* involves several steps.

**Customizing for payment media**

1. You decide that you want to use the Payment Medium Workbench for the particular payment method.
2. You check the existing payment medium formats and make any necessary changes.
3. You configure the note to payee.
4. You maintain the [Selection Variants](Page 159) as prerequisite for the automatic scheduling of payment media by the payment program.

**Creation of payment media using the generic payment medium program**

1. You start the payment program and select the option *Create payment medium* during scheduling of the update run. In the payment run parameters, a variant has only to be defined for the payment advice note print program of the *Payment Medium Workbench*.
2. Directly following the payment run, the payment balance is sorted automatically and split into groups according to the level of detail, for creation of the payment media in the next step.
3. For each group, the payment medium program is started with the variant defined in Customizing. It selects the payments belonging to each group and creates the payment medium using the format-specific event modules/mapping rules.
Creating Payment Media

4. The payment medium is transferred to DME administration.
5. Parallel to step 3, the payment advice note program creates the necessary payment advice notes as letter, Idoc, or Fax (using Business Transaction Events 00002040).

Result

The Payment Medium Workbench programs create:

- Data media
- Payment advice notes
- Output logs
- Error Logs
Payment Medium Format

Definition

The payment medium format controls how payment orders and debit memo orders to the bank are created. The specifications (published by the banks or the central banking committees) of the formats serve as the basis for definition of payment medium formats.

- Payment medium without documents: DME or Internet payments
- Country-specific formats: ACH, DTAUS0

The Payment Medium Workbench contains a range of predefined formats, like the DTAUS0 format for domestic payment transactions in Germany, ACH for domestic payment transactions in USA, and OFX for Internet payments via OFX.

To create a format, in Customizing for Financial Accounting, choose Accounts Receivable and Accounts Payable → Business Transactions → Outgoing Payments → Automatic Outgoing Payments → Payment Media → Make Settings for Payment Medium Formats from Payment Medium Workbench → Create Payment Medium Formats.

To change a format, in Customizing for Financial Accounting, choose Accounts Receivable and Accounts Payable → Business Transactions → Outgoing Payments → Automatic Outgoing Payments → Payment Media → Make Settings for Payment Medium Formats from Payment Medium Workbench → Adjust Payment Medium Format.

Formats contain various fields that are filled with field contents from your SAP system. This transaction is called mapping. There are two ways in which mapping can occur.

- With/to programmed function modules
- Using the Data Medium Exchange Engine [Page 161]

Use

The payment medium format can be country-dependent or country-independent and is assigned to one or more payment methods.

Structure

The following settings are made during definition of a format:

1. Payment medium type (DME, for example)
2. Level of detail of the payment medium
   - This is the level at which payment orders should be grouped in a file (for example creation of a file per combination of house bank and paying company code).
3. Format-specific parameters
4. Payment Medium Format Supplements [Page 155] (for example format-specific description for bank transfer and debit memo)
5. Events that call function modules, connection to DME Engine
Payment Medium Format

6. Size of text fields for the Note to Payee [Page 156]

Example

The note to payee for the German format DTAUS0 is described as follows:

- 13 x 27 bytes of space for the main note to payee (body text of 13 lines each with 27 characters)
- 1 x 11 bytes of space for the internal short reference
- 1 x 27 bytes of space for the external short reference

With the previous classic method for creation of payment media, the format is implemented as a program whilst the structure of the note to payee is predefined.
Payment Medium Format Supplement

Definition
This is the key that facilitates the commercial description of data for the selected payment medium format. This is printed in the coding line of the payment medium or copied into the appropriate field with data medium exchange, for example.

Thus, with debit memos, we can distinguish between collection procedure and direct debiting procedure.

Use
You only use the payment medium format supplement if there is provision for this in the format specification.

In Germany, the payment medium format supplement is called Text key (Textschlüssel).
**Note to Payee**

**Definition**

A note to payee is a field on a data medium containing information on paid line items relevant for the business partner.

Number and length of the note to payee fields are defined in the payment medium format, whilst the content itself is defined in the note to payee.

**Use**

SAP provides predefined notes to payee that you can adapt for your own formats. Notes to payee are structured according to the following methods:

- With Customizing in SAPScript format
- With a function module
- With a combination of Customizing and function module

To adapt a note to payee, in Customizing for Financial Accounting, choose *Accounts Receivable and Accounts Payable → Business Transactions → Outgoing Payments → Automatic Outgoing Payments → Payment Media → Make Settings for Payment Medium Formats from Payment Medium Workbench → Adjust Note to Payee.*

**Structure**

The note to payee consists of a maximum of 6 different line types:

1. Main note to payee for description of the payment, for example with the payment of invoices in the lines there is the invoice number, the invoice date, and/or the invoice amount.
2. Internal short reference for your company for identification of the transaction in case of failed payment. This could be the number of the payment document, for example.
3. External short reference for your business partner, a contract/customer number, for example.
4. Payment advice note that replaces the lines of type 1 where there is not sufficient space available.
5. and 6. See *Alternative Payer, Alternative Payee [Page 158]*.

**Integration**

The note to payee is independent of format, a separate entity that exists alongside the formats. You can assign the note to payee to a format via the payment method and the origin. You can assign a note to payee to several formats, thus minimizing the effort involved.

**Example**

<table>
<thead>
<tr>
<th>Line type 1</th>
<th>Main note to payee line 1</th>
<th>No. 746 999 from 01.01.2000</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line type 1</td>
<td>Main note to payee line 2</td>
<td>No. 333 934 from 02.15.2000</td>
</tr>
<tr>
<td>Line type 1</td>
<td>Main note to payee line 3</td>
<td>No. 4 734 from 02.20.2000</td>
</tr>
<tr>
<td>Line type 1</td>
<td>Main note to payee line 4</td>
<td>Visit our homepage: <a href="http://www.sap.com">www.sap.com</a></td>
</tr>
<tr>
<td>------------</td>
<td>---------------------------</td>
<td>---------------------------------</td>
</tr>
<tr>
<td>Line type 2</td>
<td>Internal short reference</td>
<td>Payment document 6785987</td>
</tr>
<tr>
<td>Line type 3</td>
<td>External short reference</td>
<td>Our account with you: 345876</td>
</tr>
</tbody>
</table>
Alternative Payer, Alternative Payee

Note to payee structure

This example shows in combination in the Payment Medium Workbench how you can handle two special cases, namely the alternative payer and the alternative payee.

The Note to Payee [Page 156] consists of up to 6 different line types. Line types 5 and 6 are intended for following special cases:

- Line type 5 supplements the text of line type 1 through specification of an invoicing party where the payment is made to an alternative payee.

- Line type 6 supplements the text of line type 1 through specification of an invoice recipient where the payment is made from an alternative payer.
Selection Variants

Use
If you wish to use the Payment Medium Workbench [Page 148] for creation of payment media, you have to enter selection variants for the generic payment medium program. These do not have to be entered as parameters for every payment run, as is the case for the classic payment medium programs (RFFO*), rather they are maintained centrally.

Prerequisites
In Customizing for the Payment Medium Format [Page 153], choose Adjust Payment Medium Format and determine the level of detail. The level of detail governs how payment media are output in payment groups. In selection variant maintenance, the system displays all defined payment groups that each require assignment of one selection variant.

Procedure
You can enter, assign, and transport selection variants for the generic payment medium program.

Assigning selection variants
At least 1 variant is defined in each payment group for each payment medium format. It is important to assign a selection variant to each group to ensure that no payment is forgotten.

1. To assign a selection variant, in Customizing for Financial Accounting, choose Accounts Receivable and Accounts Payable → Business Transactions → Outgoing Payments → Automatic Outgoing Payments → Payment Media → Make Settings for Payment Medium Formats from Payment Medium Workbench → Create/Assign Selection Variants.
2. On the left side of the screen, select the payment medium format to which you want to assign a variant. The system displays the format on the right side of the screen. In order to make the list easier to work with, you can use Drag&Drop to copy formats to the favorites list.
3. When you place the cursor over a selection variant field and press F4 (input help) the system displays possible variants. Choose the variant you require.
4. Carry out assignment for each individual group level. You can speed up this process by using filter, copy, selection, and paste functions.
5. Save assignment of the selection variants.

Creating selection variants
1. To create a selection variant, in Customizing for Financial Accounting, choose Accounts Receivable and Accounts Payable → Business Transactions → Outgoing Payments → Automatic Outgoing Payments → Payment Media → Make Settings for Payment Medium Formats from Payment Medium Workbench → Create/Assign Selection Variants.
2. On the left side of the screen, select the payment medium format for which you want to create a variant. The system displays the format on the right side of the screen.
3. Place the cursor over a selection variant field, enter a name for a new variant, and press continue.

The system displays a dialog box where you confirm variant creation.
Selection Variants

The system displays the selection screen of the generic payment medium program SAPFPAYM.

4. Here, you enter the required selection criteria, then you maintain the attributes before saving the variant.

5. Choose Back to return to selection variant maintenance for the payment medium formats.

6. Save assignment of the selection variants.

If you want to work with Dynamic selections you can enter several variants per group using the procedure described above (Variant → Enter further variants). You should only use Dynamic selections to define selection variants where no alternative exists. After this, you need to ensure that no payment order has been carried out in duplicate and that only 1 payment medium has been created for each order.

You can increase the level of detail in Customizing (Adjust Payment Medium Format) as an alternative to Dynamic selections.

Transporting selection variants

In selection variant maintenance for payment medium creation, it is possible to branch to transport of the settings made and the selection variants for payment medium creation themselves.

1. To carry out the transport, in Customizing for Financial Accounting, choose Accounts Receivable and Accounts Payable → Business Transactions → Outgoing Payments → Automatic Outgoing Payments → Payment Media → Make Settings for Payment Medium Formats from Payment Medium Workbench → Create/Assign Selection Variants.

2. To transport the selection variants, choose Transport variants to all formats.

3. To transport selection variant assignment, choose Transport settings to all formats. You can decide whether you transport the currently selected format or whether you transport all formats.

Result

The payment program starts payment medium creation using each selection variant entered.
Data Medium Exchange Engine

Use
The Data Medium Exchange Engine (DMEE) enables you to define file formats that meet the requirements of your financial institution. This is particularly important as there is no worldwide or regional standard. In some cases, no country standard exists and the file must comply with bank-specific standards. With no ABAP programming knowledge required, this tool enables you to flexibly define new formats and to efficiently modify existing ones. In addition, DMEE can be used by calling applications to generate a DME file.

Integration
Formats can be defined for and DME files can subsequently be generated from the following application areas in Financial Accounting:

- Payment program
- Tax reporting
- Withholding tax reporting

Features
- Creation of formats with a graphical DME tool
- Single program interface for all formats
- No coding for additional layouts or changes
- Transport of layouts
Format Tree Definition

Purpose
This process describes the steps involved in defining a format tree in the DME Engine.

Process Flow
There are three main steps:

1. Data selection
   
   After you specify the application for which you wish to create a file format (such as the payment program) and assign a unique format tree ID, the system executes a selection step. It selects all R/3 fields that are predefined for the particular application. These fields form the source field inventory [Page 171] and are made available to you when you do the data mapping in step 3.

2. Definition of tree structure
   
   In this step, you define the layout of the format tree in a hierarchical structure. This tree stores all data that is relevant to describe this file structure: here you maintain the level structure of the file, the field structure, and the mapping and conversion of SAP source fields to file target fields.

3. Data mapping
   
   When you define your structure, you must link the fields in your file format to the corresponding fields in the R/3 System. This enables the DME Engine to extract the required data from the appropriate fields when you later generate a file. There are several mapping procedures; the most common ones are direct reference to R/3 fields or specification of a constant. You can also define more complicated mapping rules by including conditions, aggregation, or user exits.

After the above steps have been completed, you activate [Page 176] your format tree and it can then be used for generating DME files from the defined applications.

See also:
Creating Nodes [Page 167]
Data Mapping [Page 169]
Screen Layout

After you specify a tree type and a unique format tree ID on the initial screen of the DME Engine, the **DMEE: Create Format Tree <format tree>** screen appears. It is divided into three parts:

1. **Tree structure**
   On the left side of the screen, you define your format tree by inserting nodes in a hierarchical structure.

2. **Detailed view**
   When you insert a node in the format tree, detailed information is displayed to the right of the tree in the top frame. Here you specify additional data depending on the type of node. The information is displayed like a card index; you navigate between different areas by choosing the tabstrips along the top.
   
   You can display the details for any node by double-clicking it in the left-hand tree structure.

3. **Source fields**
   The bottom right frame contains all source fields made available by the data-selection step. These fields make up the source field inventory; you can select from them during the data-mapping process.
Nodes

Definition
Object that represents a hierarchy level in a format tree structure.

Use
Nodes are used to model a file defined by a certain external authority, such as a bank, government, or standardization organization. In most cases, it is possible to transfer to the format tree on a 1:1 basis the structure in the file description that the authority provides. SAP recommends that each file field corresponds to an element in the format tree.

Structure
Each format tree begins with a root node called the header. It appears automatically at the top of the tree structure when you create a format tree, and you can maintain the details on the right.

Below the header, you insert nodes to form the body of your format tree based on your file requirements. Likewise, details for the nodes can also be maintained on the right. For a description of the nodes and when to use each type, see Node Types.
The root node of the DMEE format tree contains technical settings and properties that apply to the entire file. Below is an overview of data that can be maintained on the detailed view to the right of the tree structure. For more information on the individual fields, refer to the F1 help.

Administrative data
You can document your format tree as needed. To do so, specify a name for your documentation text in the Documentation field; the name format `<format tree ID>_DMEE` is recommended. You can then maintain the text directly in the SAPscript editor by choosing the Goto → Documentation.

The version [Page 180] of the format tree is displayed. The system assigns the fixed value 000 to an active version and 001 to a maintenance version.

Format attributes
Here you specify a DDIC structure in the case of format-specific parameters and delimiter information.

For format trees of the tree type PAYM, you can additionally specify that an accompanying sheet is to be printed when the file is generated. The system supports the printing of both simplified sheets and sheets with subtotals. If you specify an accompanying sheet with subtotals, you must maintain the key fields on the Sort/key fields tabstrip.

Levels
Here you specify the number of levels in the format. In addition, you can define a repetition limit for each level. This value specifies how often a certain level may be output. If this number is exceeded, the corresponding level cannot be output anymore. If the limit is reached for the uppermost level in the format tree and additional data is to be processed, a second file is generated. If the limit is reached for lower levels, the preceding level is repeated so that data can continue to be output for this level.

Sort/key fields
Here you can specify how certain fields are to be sorted. For the payment program, for example, you can sort according to currency or account by specifying the appropriate source field. If a sort field is additionally marked as a key field, then a change to the value in this field causes the corresponding format level to end.

If you indicate on the Format attributes tabstrip that an accompanying sheet is to be printed, you maintain the key fields here, which define how the subtotals are calculated.

File data
Here you specify whether segments are to be separated by carriage return or by line feed.
Node Types

Each node type performs a different function and various data can be maintained accordingly in the detailed view. For additional information on nodes and when to use certain node types, choose Extras → Node legend on the DMEE: Create/Change Format Tree <format tree> screen.

Below is an overview of node types in the DME Engine and their use:

<table>
<thead>
<tr>
<th>Node</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Segment group</td>
<td>Used to group segments</td>
</tr>
<tr>
<td>Segment</td>
<td>Represents a record in the target file</td>
</tr>
<tr>
<td>Composite</td>
<td>Used to group elements</td>
</tr>
<tr>
<td>Element</td>
<td>Represents a target field of the DME file</td>
</tr>
<tr>
<td>Atom</td>
<td>Describes the link from the file definition to the internal R/3 structures</td>
</tr>
<tr>
<td>Technical node</td>
<td>Element that is not output to a target file; it stores values that are used in other tree nodes (elements, atoms) by a reference to this node</td>
</tr>
</tbody>
</table>
Creating Nodes

1. For the first node, position the cursor on the root node and choose the pull-down menu next to the \icon, or do a right mouse click on the root node and select the node you wish to create.

2. For successive nodes, always position the cursor on the node above where you want to insert a node. You can then specify whether the node is to be inserted on the same level or as a subnode.

   When you insert a node, position the cursor on the node above where you wish to insert the new node by double-clicking. If you just highlight it with a single click, the details of another node may still be displayed to the right and the system recognizes this as the previous node.

3. Depending on the type of node you create, various data can be maintained in the detailed view to the right of the format tree. For more information on the individual fields, choose the F1 help for the field.
Conditions

Use

This function enables you to define conditions that control whether a certain format tree node is processed during file generation.

Conditions can be defined for any node type [Page 166]. If one condition applies to several consecutive elements, you should define a composite. If you assign a condition to a segment or a composite, it applies to the corresponding subtree. In this way, for example, you can control that a complete record (a segment, including all its elements defined as subnodes) is not output to the file.

Activities

You define a conditional relationship for a node in the detailed view under Conditions. Here you specify one of the following types of condition arguments and the corresponding arguments:

- Constant
- Field in a source structure (from the source field inventory)
- Reference ID (of another node already defined in the format tree)

When a file is generated from one of the predefined applications, the system processes the format tree and checks each node for conditions. If a condition is met, the system processes the node; if it is not, the node is ignored.

If a condition for an upper-level node is not met, all subnodes are also ignored during processing.
Data Mapping

Purpose
This process describes how to map data from R/3 source fields to the target fields in a DME file. In most cases, you specify how data is to be mapped to elements, the nodes in the DMEE format tree that represent these target fields. You can also specify a mapping procedure and source information for atoms, which you define if an element contains several mapping rules.

Process Flow
1. You insert an element in the format tree structure on the left.
2. The system automatically displays the detailed view for an element in the right frame. This includes the following tabstrips: Attributes, Source, Conditions, and Aggregation.
3. After you enter the required attribute information, select a mapping procedure.

Mapping procedures:

<table>
<thead>
<tr>
<th>Select mapping procedure</th>
<th>If</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constant</td>
<td>The value is to be set to a constant</td>
</tr>
<tr>
<td>Structure field</td>
<td>A value is to be retrieved from a specific source field in the R/3 System</td>
</tr>
<tr>
<td>Reference to tree node</td>
<td>An attribute (current value, length, or counter reading) of another DMEE format object that was already defined is to be used</td>
</tr>
<tr>
<td>Aggregation</td>
<td>A value related to a reference node is to be totaled and made available to this node</td>
</tr>
<tr>
<td>Exit module</td>
<td>The standard mapping and conversion rules do not meet your requirements and you wish to specify an exit module</td>
</tr>
<tr>
<td>Own mapping (atoms)</td>
<td>Your mapping rules are dependent on conditions or if different parts of the element are to be filled from different sources</td>
</tr>
</tbody>
</table>

4. Enter detailed source information:
   a. If you choose one of the following mapping procedures, enter source data in the appropriate fields on the Source tabstrip:
      - Constant
      - Structure field
      - Reference to tree node
      - Exit module

In most cases, you specify that the target field is to be filled from one source field from the R/3 System, which corresponds to the mapping procedure Structure field.
Data Mapping

To specify the source field, you can enter the source field and structure directly under Source, or you can select a field from the source field inventory [Page 171].

b. If you choose Aggregation as the mapping procedure, enter data as required on the Aggregation tabstrip.

c. If you choose Own mapping (atoms) as the mapping procedure, you create as many atoms as you require in the form of subnodes to the element. You then specify a mapping procedure and source information for the atoms.

5. You can specify a conversion method used to convert source field data to a particular format for the DME file. This step is optional; if no conversion method is specified, data is transferred to the target field in the format it has in the R/3 System.

See also:

Aggregation [Page 174]

Exit Modules [Page 175]

Conversion of Source Field Data [Page 172]
Source Field Inventory

For each DMEE tree type, a set of possible source fields is predefined by SAP. These fields form the source field inventory, which is generated automatically during the data-selection step. You can select from these fields in the data-mapping process.

The source field inventory can consist of the following fields, depending on the tree type:

- **Source fields for the application**
  
  These fields are dependent on the particular application.

- **ABAP system fields**
  
  These fields are made available for each application. An example is the system date.

- **Technical fields**
  
  These fields are additional ABAP system fields that are usually not selected in the data-mapping process. However, they are still made available in the case that you require such source fields.

- **Source fields for note to payee (internal table)**
  
  These fields are specific to the tree type PAYM (payment program). If the appropriate settings are defined in Customizing for *Payment Medium Formats for the Payment Medium Workbench* and you select one of these fields as your source field, then a value will be filled in this target field.

- **Parameters and source fields from Customizing**
  
  These fields are specific to the tree type WTRE (withholding tax reporting). By choosing one of these fields, you map data that has been defined in Customizing and that remains unchanged.

**Selecting fields from the source field inventory**

To select a field from the source field inventory, double-click the document icon to the left of the field name, and the system transfers the structure and the field name to the mapping source above. For a description of the fields, choose 📄. To branch from the structure directly to the ABAP Dictionary, choose 📄. You can also insert a new element in the format tree directly from the source field inventory by highlighting the field name and dragging it to the format tree. The element is inserted after the last node in the structure and assigned the technical name of the field.
Conversion of Source Data

Use

This function converts source field data to a particular format for the DME file. You can specify a conversion method for any of the mapping procedures available for elements and atoms.

The system supports conversion rules for the following field types:

- Date
- Time
- Currency amount
- Character string

If you require an additional conversion method, you must specify an exit module for the node.

Activities

First enter the source information, then choose on the Attributes tabstrip; the system restricts selection criteria and displays the conversion rules that apply to the particular field type. Or, you can choose from all available formats via the input help.

Available formats

<table>
<thead>
<tr>
<th>For field type</th>
<th>You can specify a combination of the following data:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>• Day, month, and year sequence</td>
</tr>
<tr>
<td></td>
<td>• Number of characters for year: two or four</td>
</tr>
<tr>
<td></td>
<td>• With or without separator</td>
</tr>
<tr>
<td></td>
<td>• Type of separator: slash or period</td>
</tr>
<tr>
<td></td>
<td>• Year, month, or day only</td>
</tr>
<tr>
<td></td>
<td>• Year and number of days since January 1</td>
</tr>
<tr>
<td>Time</td>
<td>• Hour, minutes, and seconds sequence (with or without seconds)</td>
</tr>
<tr>
<td></td>
<td>• With or without separator</td>
</tr>
<tr>
<td></td>
<td>• Hour only</td>
</tr>
<tr>
<td></td>
<td>• Conversion to time stamp</td>
</tr>
<tr>
<td>Currency amount</td>
<td>• Number of decimal places</td>
</tr>
<tr>
<td></td>
<td>• Decimal formatting: period, comma or none</td>
</tr>
<tr>
<td></td>
<td>• With leading zeros</td>
</tr>
<tr>
<td></td>
<td>• Left- or right-justified</td>
</tr>
<tr>
<td></td>
<td>• Output decimal value as 0 (round down)</td>
</tr>
</tbody>
</table>
### Conversion of Source Data

| Character string | • With leading zeros  
|                 | • Left- or right-justified   
|                 | • Replace leading zeros with space   
|                 | • Replace strange characters  
|                 | • All letters as capital letters |
Aggregation

Use
This function enables you to aggregate values for specified format tree nodes (called aggregation nodes) and it makes this number available to a target field (element) in the DME file.

The aggregation function can be used at the end of a level or a file to:

- Add the total value of specified nodes
  In this case, you can only specify aggregation nodes that are filled with values (elements).

  This could be the amount of all payments in a level.

- Add the number of nodes
  In this case, you can specify any aggregation nodes because the system totals the number of occurrences, not specific values.

  This could be the number of payments in a level.

Activities
When you create an element, select the mapping procedure Aggregation. On the Aggregation tabstrip, you enter the reference IDs of the nodes you wish to aggregate and the aggregation type – how the aggregation nodes are to be totaled to the target node (either summation of values or of total number of occurrences).
Exit Modules

Use
You can implement exit modules for elements or atoms if the standard mapping and conversion rules do not support your requirements. Exits can also be used to select data from additional database tables not included in the standard selection step (such as customer database tables) and therefore not made available in the source field inventory. The exit module can, however, use the same source fields as the standard mapping rules.

Activities
When you create an element or an atom, select the mapping procedure Exit module. On the Source tabstrip, you then enter the name of the exit function.

You write ABAP source code in the ABAP Workbench – not in the DME Engine. The function module DMEE_EXIT_TEMPLATE can be used as a template for your exit module.
Activating Format Trees

Use

You always maintain version 001 of the DMEE format tree. After you finish maintenance of your format tree, you activate the tree so that it can be used to generate a DME file from one of the defined applications.

Procedure

1. Complete maintenance of the format tree.
2. Choose Format tree → Activate or 🌡.
3. The system performs a check [Page 177] of the format tree.

Result

If the check determines inconsistencies (errors or warnings), the system saves the format tree in the maintenance version, 001. To activate the tree, you must first correct all errors and then repeat the activation procedure.

If no errors are determined, the system activates the format tree and saves it as the active version, 000.
Checks

Use
Checks are carried out on the format tree to prevent inconsistent data from being used when a file is generated. You can execute a check manually at any time in the format-defining process. In addition, the system performs a check automatically when you activate your format tree.

Activities
To perform a manual check, choose Format tree → Check or . The system carries out the following checks:

- Syntax check
- Consistency check (such as reference to node attributes)
- Correct level distribution
- Check for completeness

If the check generates error or warning messages, the system displays a log. The log indicates the type of message (red for error, yellow for warning, green for information) and a short text. The text of an error message – which must be corrected in order to activate a format tree – is additionally highlighted in yellow. If a long text is available for the message, you can display it by choosing .

After a log has been generated, you can display it by choosing Goto → Log or .
Testing Active Format Trees

Use

The DME Engine includes a testing function, which enables you to test active versions [Page 180] of format trees before they are used to generate a file. This function is intended for small-scale tests only. You can employ it, for example, to test the effects of new conversion rules or to determine if the offset is correct within a line or record. It is not intended to check an entire format tree – but rather a few lines – as it is very difficult to manually generate all application data correctly.

Activities

1. On the initial screen of the DME Engine, choose Format tree → Test active version or .

   The DMEE Test Data screen appears. The system displays the source structures for the particular application, each followed by the most commonly selected source fields for that structure. If you need to test fields not included here, you can add fields via the standard layout function.

2. Next you enter the data you wish to test.

   Only enter data in those fields that are specified in the format tree as actual source fields.

3. To start the test, choose File → Test or .

4. On the Data output dialog box that appears, the system displays in list form the results for the data you entered as they would appear in an actual DME file.

   If you do not enter data in the fields for which mapping rules are defined in the format tree, these fields remain empty when the test version is output. Fields defined as constants are output accordingly.

See also:

Activating Format Trees [Page 176]
Transporting Format Trees

You can transport both active and maintenance versions of format trees to other systems. The logical transport object for a DMEE format tree is R3TR DMEE; this contains all associated database tables. To transport a format tree, choose either Format tree → Transport or on the initial screen of the DME Engine.

The DME Engine also supports an upload/download of format trees as an alternative to the transport:

- **Upload format tree**
  You can upload a format tree that you have as an XML file. To do so, choose Format tree → Upload XML file on the DMEE initial screen. You then specify the file name and the presentation server or URL address.

- **Download format tree**
  You can download a format tree and create an XML file on your PC that contains all format tree information. To do so, choose Format tree → Download XML file on the DMEE initial screen. After you specify which version you wish to download (active or maintenance), you enter the tree type, format tree ID, and a name for the XML file.
Format Tree Maintenance

Use

A DMEE format tree can be maintained with the transaction DMEE. You specify the tree type and the name of your format tree. A DMEE file specification can then be defined or modified in the form of a hierarchical tree structure.

Versions

When you create a format tree, the system automatically assigns it the version 001 (maintenance version). When you have finished maintaining the tree and wish to use it to generate DME files, you activate the tree. In the activation process, the system performs certain checks; if these are successful, an active version of the tree is stored under the version 000.

After you activate a format tree, two versions exist in the system: the active version (000) and the maintenance version (001). You always maintain version 001. When making changes to the maintenance version, you can always return to the last active version. You would want to do this, for example, if you make changes to the maintenance version, save it, and decide later that you do not want to keep these changes. To return to the last active version, on the DMEE initial screen choose Edit → Maintain active version.

When you return to the last active version, it overwrites the maintenance version.

Only two versions exist in the system at any given time. Once you modify a maintenance version and activate it, this is the only active version that exists – at this point it is not possible to return to an earlier active version.

Both the active and maintenance versions can be transported to other systems.
Generation of Data File Using DMEE

Purpose
The DMEE format tree can be used by a calling application to generate a DME file. The system currently supports the use of the DME Engine from three Financial Accounting applications: payment program, tax reporting, and withholding tax reporting.

Prerequisites
For the PAYM tree type, the format tree must be defined as a payment medium format in Customizing for Payment Medium Formats for the Payment Medium Workbench.

Process Flow
The calling application carries out the following steps:
1. Selects data and fills the transfer structure
2. Calls DMEE modules with the data that has been selected
3. Obtains an internal table with data in format structure
4. Writes data to a file or to File/TemSe/... and, in the case of PAYM, possibly updates DME administration
Data Medium Exchange and Data Medium Administration

Use

This topic first describes the available functions in FI for generating data carriers, and second, the data medium administration functions that help in the administration of generated data carriers.

In Data Medium Exchange (DME), a file containing all payment information and corresponding to the banking rules for the country in question, is generated. For example, banks in Germany require MS-DOS files in DTAUS0 format for payments by domestic transfer or direct debits. For these same transactions in the USA, ACH format is needed, and BACS format is used in Great Britain.

Depending on the specifications for Data Medium Exchange in your country, you may be able to use various methods to store data created by the payment program:

- In the SAP System (TemSe). This is the case for Germany, Austria, Switzerland, Belgium, France, the USA, and Denmark.
- In the file system. This is the case for Great Britain and Norway, for example.
- Not at all. In this case, you can only print forms.
Outputting the DME File into the SAP System

Use

If required, you can store the file you have created within the SAP system (the file is stored in the TemSe rather than in the file system). This way the file cannot be accessed by unauthorized external users. You can then download the file into the user's file system using one of the DME administration functions.

You can determine the name of the file to be created during the download when running the payment medium program: the contents of the file name parameter are stored in the administration data and are proposed when running the download.
Outputting the DME File into the File System

Use

If required, you can write the file into the file system. You can also copy the file to the PC from the file system of the application server using the download function of DME administration.

The name of the file can either be created by the system or be defined by the user. If the file name is assigned by the system, it consists of the disk format, date and time of creation and also a consecutive number. This ensures the file names in the file system are always unique. The file name assigned by the system can be taken from the payment medium program log.

If you want to assign the file name yourself, you can create a variant for data medium exchange (per house bank if required), within which you define a file name. Note that the system likewise adds a consecutive number to the file name so that the name is unique for each program run. From an organizational point of view, you should make sure that files that already exist are not overwritten.

If you cannot find the file using DME administration, this could be due to the following reason: The directory that was written to when the payment medium program was started (for example, in background processing), cannot be read online. You should therefore choose a directory that can be written to and read by different machines.

Due to the problems mentioned above and the effect this has on data security, it is advisable not to write data to the file system. It may be advisable, however, to use this method if the DME file is “picked up” from the file system by an external program to be passed on to the bank.
Creating a Payment Medium Report Variant

To create a report variant for DME, proceed as follows:

1. Choose System → Services → Reporting. This takes you to the initial screen for report processing.

2. Enter the name of the payment medium program for which you want to create a variant and choose Goto → Variants. You reach the screen for maintaining variants.

3. Enter a variant name and choose Variants → Create.

4. Select the field Data medium exchange, then enter the name of the printer. This is necessary so that the system can prepare the form for the accompanying sheet that is created during DME. Also select the field Print immediately if required.

5. Select the field Issue payment advices (if this field exists), then enter the name of the printer. Also select the field Print immediately if required.

6. Select the field Print payment summary, then enter the name of the printer. Also select the field Print immediately if required.

7. Make an entry in the field File name (for DME) as follows:
   
   For outputting into the file system, enter the name under which the file generated is to be stored in the file system (as long as you have elected not to have the system generate a name).
   
   For outputting into the SAP system, enter the name which, if required, is to be proposed later when running the download.

8. Choose Variant → Save.
Running the Payment Medium Program

You should run the payment medium program upon successful completion of the payment run - that is, when the status information “Payment run carried out” is displayed on the Automatic Payment Transactions screen and a message appears to say that all documents were posted. Starting from this screen, proceed as follows:

1. Choose Edit → Print programs. This takes you to the screen for entering variants.
2. For the relevant payment medium program, enter the variant entered for the DME.
3. Choose Parameters → Save. This takes you back to the Automatic Payment Transactions screen.
5. In the dialog box that appears, enter the required start time and a name for the print job.
6. Select ENTER.
Data Medium Administration

Use

Data medium administration (DME administration) helps you to manage the data media that you create in Financial Accounting and in Human Resources.

In the Accounts Receivable or Accounts Payable menu, choose Periodic processing → Payments. The system displays the Automatic Payment Transactions: Status screen. From here, choose Environment → Payment medium → DME administration to reach the DME administration screen.

In the Payroll country menus, choose Payroll → Bank transfer → DME management.

In the DME administration overview, the system displays all the data media created with the selection criteria you have specified. You can call up further information for each data medium. Select the required data medium.

Features

DME administration includes the following functions:

- **Displaying data medium attributes**
  
  Choose Extras → DME attributes
  
  The system displays the following information for the selected data medium:
  - Payment run ID
  - House bank or clearing house
  - Date and time of data medium creation
  - Responsible person
  - Amount paid in currency specified
  - Further technical data

- **Deleting an individual or several data media**
  
  The accompanying administrative data is deleted from the system at the same time.
  
  Select the required data medium and then choose Edit → Delete data medium. A confirmation prompt appears. The selected data media are deleted when you confirm this prompt.
  
  If you wish to delete data media from several company codes, then you should use the reorganization function within the payment program.

  **See also:**
  
  Deleting DME Administrative Data Across Company Codes [Page 190]

- **Downloading one or more files from the SAP system or from the file system to hard drive or disk**

  **See also:**
  
  Downloading a DME File onto Disk [Page 189]
Data Medium Administration

- **Displaying the contents of a data medium on the screen or printing the contents**
  
  Choose *Edit → Display DME contents* from the DME administration overview screen.

  The following functions are not available for payments from *Human Resources* (HR).

- **Displaying Documents**

  Choose *Extras → DME attributes* and then *Environment → Display documents*. By selecting *Choose*, you branch into the selected payment document.

- **Displaying the transferred data after receiving and entering the account statement**

  To do this, choose *Extras → Bk transact.attribs* from the DME administration overview screen. If your electronic account statements are processed automatically, then the system fills in the fields within the *Account statement* group.

- **Printing the payment summary for the selected data medium**

  To do this, choose *Extras → Payment summary* from the DME administration overview screen.

- **Creating a payment advice note**

  If you do not use the automatic transfer of electronic account statements but instead enter the account statement data manually, you can simplify this work by means of payment advice notes within DME administration.

  You can create a payment advice note for a specified data medium using *Environment → Generate doc.pmt adv*. You can enter this payment advice number at a later stage when clearing the bank clearing account. During clearing, the system then only proposes those open items which belong to the payments specified in the payment advice.

  You can find more information on the use of this function in Great Britain, (for the creation of a Telepay file, for example) in the documentation of report RFFODTA1.
Downloading a DME File onto Disk

Use

The downloading function within DME administration enables you to create a copy of the data medium on your PC. This procedure is logged in the system. You can create as many duplicates of a data medium as you wish. Only the administrative data from the last download is stored in the system.

When writing a file to drives A or B, you can also assign a volume label. To print the relevant volume number onto your disk accompanying sheet when running the payment medium program, maintain the symbol &REGUD-LABEL& in the form you use for the disk accompanying sheet.

Procedure

1. Choose Accounting → Financial accounting → Accounts payable → Periodic processing → Payments, then Environment → Payment medium → DME administration.
   The system displays the DME administration initial screen.

2. Enter the reference number or the paying company code and the bank country. You can make further selections by payment run date and identification. In the standard system, the default setting is that you want to see the payment run data which has not yet been downloaded to the PC. The fields Payment run and Data medium (not yet transferred externally) are selected.

3. Choose Edit → Overview.

4. Select one or more data media and then choose Edit → Download...
   The system displays a dialog box.

5. Enter a file name including path. If you are downloading to a disk, you can also add a volume number to the disk. Select the Volume field. The standard system proposes the number printed on the accompanying sheet. You can allocate the accompanying sheet to the correct disk at a later stage using this number. You can, however, also give the disk another name.

6. Choose Continue. The system may ask whether you have loaded a disk. When you confirm this, the download is carried out. If you have selected several data media to be downloaded, the system will ask you to load a new disk before each further disk is written to.

   ![Download Arrow]

   If the data media from the payment program are stored in the file system and not in the SAP system (TemSe), then the system already interprets this procedure as a download. You therefore only find data media created in this way in the DME administration if you choose Data medium (transmit.to external).
Deleting DME Administrative Data Across Company Codes

Use

If you do not want to delete the DME administrative data for each company code individually, you can also delete it within the reorganization of the payment run data.

The DME administrative data is deleted from the system without detail checks. Before a reorganization, you should make sure that the data media affected have been created and processed by the bank.

Procedure

1. Choose Accounting → Financial accounting → Accounts Receivable (Payable) → Periodic processing → Payments, and then Payment run → Reorganization.

2. In the Reorganization dialog box, select the Delete admin.data function.
Payment Orders

Payment orders are created when a payment is due to be carried out (payment form created, payment transfer transmitted to the bank by DME) but the payment is not to be posted until it is shown on the account statement sent to you by your house bank.

For the period between the payment run and the point at which the account statement is processed, the line items paid must be flagged in such a way to prevent them being repaid in another payment run. It is not possible to carry out clearing or to reverse the line items either.

The payment program therefore creates payment orders. Each payment order is assigned a number unique within the client. A payment order consists of header data and line item data. The header data includes the paying company code, the payment amount, payment method, and house bank account. A separate record is stored in the line item data for each line item paid. In addition to the line item key, (document number, company code, fiscal year, line item) this record contains the gross amount, the deduction for cash discount and the withholding tax amount.

The payment order number is recorded on the payment form or in the data medium. This number appears where the payment document number would normally appear if the posting of the payment was just created by the payment program.

This number is printed on the account statement from your house bank, enabling you to locate the items paid quickly and easily from the payment order. The items are cleared when the account statement is posted.

Payment orders offer the following:

- When making payments in a foreign currency, the bank exchange rate can be posted.
  
  In contrast, if foreign currency payments are posted using the payment program, only those exchange rates defined in Customizing can be used. This usually necessitates additional exchange rate difference postings when the account statement is later posted and the cash receipt/cash disbursement accounts are cleared.

- Where a payment order is to be carried out at some time in the future, the line items are not cleared very much earlier than the date on which the payment is made.

System Administration Changes

The standard system contains 10 number ranges for payment orders. These number ranges enable you to run up to ten payment runs in parallel.

<table>
<thead>
<tr>
<th>Number Range</th>
<th>Interval</th>
</tr>
</thead>
<tbody>
<tr>
<td>00</td>
<td>0000000001 - 09999999999</td>
</tr>
<tr>
<td>01</td>
<td>1000000000 - 19999999999</td>
</tr>
<tr>
<td>..</td>
<td></td>
</tr>
<tr>
<td>09</td>
<td>9000000000 - 99999999999</td>
</tr>
</tbody>
</table>

These number ranges do not need to be changed unless:

- They are not correctly defined
- The number range statuses are erroneous
- You carry out payment runs in parallel frequently in which case you should increase the number or number ranges.
Payment Orders

To change the number ranges, from the Accounts Receivable or Accounts Payable menus, choose Periodic Processing → Payments → Environment → Payment orders → Process number ranges.

Changing the System Parameters in Customizing

If you want the system to create a payment order instead of a payment posting, you define this per payment method. The appropriate code for the payment order is entered in the country-specific data.

Payment methods for bills of exchange, bill of exchange payment requests or payment requests cannot be converted into payment orders. At present payment orders cannot be used in conjunction with enhanced withholding tax processing (withholding tax 2). For further information on withholding tax, see the documentation FI - General Topics.

To be able to select a payment order by number when posting an account statement manually, you must define the field Payment order (field name: PYORD) as a permitted selection field for clearing transactions.

If Cash Management is to be updated in the same way as it would be if posting using the payment program, you must maintain account determination in Customizing for automatic payment transactions. For the paying company code, enter a bank subaccount for the house bank, payment method, and currency. This account is not required for posting, but to determine the planning level for Cash Management.

Changes to Procedure

The payment program creates payment orders automatically. Payment orders are deleted once the open items they contain are cleared (when the account statement is posted).

When carrying out a clearing transaction, you can select the items to be cleared by payment transaction. The items belonging to the payment transactions are then selected and are active. This means that you cannot make changes manually (deactivating line items, deactivating cash discount, changing cash discount, partial payments or residual items and so on). Neither can you select further line items, unless you select them via additional payment orders.

If you carry out a clearing transaction and do not select the open items to be cleared via payment orders, the system ignores every item contained in a payment order.

To view payment orders that have not yet been completed, from the Accounts Receivable or Accounts Payable menus, choose Periodic → Payments → Environment → Payment orders → Display overview. To display an overview of payment orders you require the following authorizations for payment transactions with the activity “23”:

- Company code authorization (F_REGU_BUK)
- Account type authorization (F_REGU_KOA)

To delete a payment order, from the Accounts Receivable or Accounts Payable menus, choose Periodic processing → Payments → Environment → Payment orders → Delete. To carry out an update run of the deletion program, you require the following authorizations for payment transactions with activity “26”:

- Company code authorization (F_REGU_BUK)
- Account type authorization (F_REGU_KOA)

As a rule, you should only need to delete payment orders if forms or data media have not yet been sent or are recalled.


**Dependent Functions**

When payment runs are reorganized, only those payment runs are deleted for which no outstanding payment orders exist.

If you delete payment data relating to a payment run, the system prompts you as to whether there are any payment orders outstanding.

When you change documents, open items in a payment order are treated as cleared items.

When you create and delete payment orders, Cash Management can also be updated. This is true, provided (for the paying company code) you enter a bank subaccount for the house bank, payment method, and currency. You make these entries in Customizing for the paying company code and this data is used to determine the planning level. You make these entries in Customizing for the paying company code, and this data is used to determine the planning level.
Payment Requests

Use

Payment requests are used mainly in France. Instead of a payment form, a letter is sent to the debtor, requesting him/her to settle the listed items.

You must define a separate payment method for the payment request.

The items to be paid are selected in the same way as items for bill of exchange payment requests or bills of exchange generated before the item due date.