Flexible General Ledger (FI-GL)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
# Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Caution" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image" alt="Example" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image" alt="Note" /></td>
<td>Note</td>
</tr>
<tr>
<td><img src="image" alt="Recommendation" /></td>
<td>Recommendation</td>
</tr>
<tr>
<td><img src="image" alt="Syntax" /></td>
<td>Syntax</td>
</tr>
</tbody>
</table>
Contents

Flexible General Ledger (FI-GL) ................................................................. 7
Flexible General Ledger Structure ........................................................... 9
G/L Documents .......................................................................................... 11
Allocation ................................................................................................... 13
Allocation ................................................................................................... 14
  Allocation Types ......................................................................................... 16
  Allocation Rules ......................................................................................... 19
    Sender Rules ............................................................................................ 20
  Receiver Rules ........................................................................................... 22
  Allocation Cycle ........................................................................................ 26
    Allocation Segment .................................................................................. 28
  Selection Criteria ......................................................................................... 32
    Rules for Selection Criteria ....................................................................... 33
  Dimensions in Allocation ............................................................................ 35
Tips for Optimizing System Runtime .......................................................... 39
Overview: Carrying out the Allocation ......................................................... 40
  Creating Allocation Cycles .......................................................................... 42
    Creating Header Data for an Allocation Cycle ........................................... 44
    Cumulative Processing of Allocation Cycles ................................................. 46
    Iterative Processing of Allocation Cycles .................................................... 48
    Creating a Segment for an Allocation Cycle ................................................. 50
      Creating Sender Values for a Segment ....................................................... 53
      Creating a Receiver Tracing Factor for a Segment ...................................... 55
    Scaling of Negative Tracing Factors .......................................................... 57
    Defining Receiver Weighting Factors ......................................................... 59
    Allocating Plan and Actual Values ............................................................. 60
    Locking Segments in an Allocation Cycle ................................................... 61
    Copying Segments ....................................................................................... 62
  Displaying Allocation Cycles ...................................................................... 63
  Changing Allocation Cycles ........................................................................... 65
  Deleting Allocation Cycles .......................................................................... 67
  Executing Allocation Cycles ........................................................................ 68
    Executing an Allocation Cycle Online ......................................................... 70
    Defining an Allocation Job for Background Processing ................................. 72
    Settings for Execution of Cycles ................................................................. 73
  Reversing Allocation Cycles ........................................................................ 75
  Deleting Allocation Line Items .................................................................... 76
  Displaying Allocation Results ...................................................................... 77
    Displaying Cycle Overviews ....................................................................... 79
    Displaying Standard Settings ..................................................................... 80
    Displaying Messages .................................................................................. 81
    Displaying Line Items ................................................................................ 83
    Displaying Segment Lists .......................................................................... 84
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollup</td>
<td>92</td>
</tr>
<tr>
<td>Sets and Rollups</td>
<td>96</td>
</tr>
<tr>
<td>Field Movements and Rollups</td>
<td>99</td>
</tr>
<tr>
<td>Line Item Database and Rollups</td>
<td>102</td>
</tr>
<tr>
<td>Types of Rollups</td>
<td>103</td>
</tr>
<tr>
<td>Special Periods and Rollups</td>
<td>104</td>
</tr>
<tr>
<td>User Exits and Rollups</td>
<td>105</td>
</tr>
<tr>
<td>Using FI-SL on Distributed Systems</td>
<td>106</td>
</tr>
<tr>
<td>Carrying out Drill Downs on Rollup Line Items</td>
<td>108</td>
</tr>
<tr>
<td>Defining Rollups</td>
<td>111</td>
</tr>
<tr>
<td>Overview: Executing Rollups</td>
<td>112</td>
</tr>
<tr>
<td>Creating Rollups</td>
<td>114</td>
</tr>
<tr>
<td>Creating Rollup Headers for Standard Rollups</td>
<td>115</td>
</tr>
<tr>
<td>Creating Rollup Headers for Hierarchical Rollups</td>
<td>119</td>
</tr>
<tr>
<td>Creating Rollup Headers for Export Rollups</td>
<td>123</td>
</tr>
<tr>
<td>Creating a Rollup Sequence</td>
<td>125</td>
</tr>
<tr>
<td>Creating Field Movement</td>
<td>127</td>
</tr>
<tr>
<td>Entering Substitution Activity Information</td>
<td>129</td>
</tr>
<tr>
<td>Checking Rollups</td>
<td>132</td>
</tr>
<tr>
<td>Documenting Rollups</td>
<td>133</td>
</tr>
<tr>
<td>Displaying Rollups</td>
<td>134</td>
</tr>
<tr>
<td>Defining a Rollup for Background Processing</td>
<td>135</td>
</tr>
<tr>
<td>Reversing a Rollup</td>
<td>136</td>
</tr>
<tr>
<td>Executing Rollups</td>
<td>138</td>
</tr>
<tr>
<td>Exporting/Importing Rollup Data</td>
<td>141</td>
</tr>
<tr>
<td>Deleting Rollups</td>
<td>142</td>
</tr>
<tr>
<td>Changing Rollups</td>
<td>143</td>
</tr>
<tr>
<td>Planning</td>
<td>144</td>
</tr>
<tr>
<td>Master Data and Planning</td>
<td>147</td>
</tr>
<tr>
<td>Setting Up Planning</td>
<td>148</td>
</tr>
<tr>
<td>Planning Layout</td>
<td>149</td>
</tr>
<tr>
<td>Planner Profile</td>
<td>150</td>
</tr>
<tr>
<td>Creating Plan Data</td>
<td>152</td>
</tr>
<tr>
<td>Creating Plan Data</td>
<td>153</td>
</tr>
<tr>
<td>Planning Functions</td>
<td>155</td>
</tr>
<tr>
<td>Reload Data</td>
<td>156</td>
</tr>
<tr>
<td>Clear Row, Undo, Redo</td>
<td>157</td>
</tr>
<tr>
<td>Cut</td>
<td>158</td>
</tr>
<tr>
<td>Copy</td>
<td>160</td>
</tr>
<tr>
<td>Paste</td>
<td>162</td>
</tr>
</tbody>
</table>
Flexible General Ledger (FI-GL)

Purpose

The Flexible General Ledger is a type of data storage. The account assignment objects of the Flexible General Ledger are saved in various applications as master data, such as cost center in Cost Center Accounting and profit center in Profit Center Accounting.

The business processes are transacted in the individual applications, and the data is transferred to the Flexible General Ledger. If the cost center is posted in Cost Center Accounting, the data is transferred to the Flexible General Ledger by means of the accounting interface. The Flexible General Ledger runs parallel to the previous general ledger.

You can include the following dimensions in the Flexible General Ledger:

- SAP dimensions (such as profit center, cost center, functional area)
- Customer-defined fields (such as region)

These dimensions are then available for planning and reporting use.

Unlike the Special Purpose Ledger, you only need to make minimal changes to the configuration in order to activate the Flexible General Ledger. You can make year-end closings based on period accounting as well as cost of sales accounting.

Implementation Considerations

The current version of the Flexible General Ledger is a pilot version. Whether this version is to be a final solution is presently being discussed. Please note this before implementing the Flexible General Ledger.

SAP can only provide the same support for this pilot version of the Flexible General Ledger as that provided for the Special Purpose Ledger. SAP is also unable to presently make a statement about the further development of the current version. Before implementing the Flexible General Ledger, you should thus check to see if the functions currently provided will meet your future needs.

Before implementation, contact your SAP consultant. Your consultant can tell you how to access the application menu and the Implementation Guide for the Flexible General Ledger.

Features

The Flexible General Ledger contains the following functions:

- The general ledger can be expanded to include SAP fields (such as profit center, cost center) or your own customer fields.
- You can carry out allocations (assessment and distribution) as in the application component Special Purpose Ledger (FI-SL).
- You can carry out as summarization of data (rollup) for reporting as in the application component Special Purpose Ledger (FI-SL).
- You can carry out multidimensional planning (that is, you can use various account assignments/dimensions for planning).
- You can carry out multidimensional reporting (that is, you can use various dimensions for balance lists and financial statements).
Flexible General Ledger (FI-GL)

- You can use all dimensions of the Flexible General Ledger (business area, profit center, cost center, and so on) as characteristics for the breakdown in the financial statements.
- The cost of sales accounting ledger 0F has been replaced by the Flexible General Ledger. The Flexible General Ledger contains the “functional area” dimension in the standard system

Constraints

The following functions are currently not available:

- No statistical sizes are stored in the Flexible General Ledger. If both an order and a cost center are to be posted at the same time, and if cost center was included in the Flexible General Ledger as a dimension, the statistical cost center is not transferred to the corresponding line item posting in the general ledger. You are thus not able to create reports on the combinations of actual and statistical postings. If the cost center and order are to be stored parallel within a posting, you have to set up Cost Center Accounting or order settlement completely.
- Postings between cost centers in controlling are not automatically entered in the general ledger. Postings to a prior period from controlling to accounting only include the dimensions company code, business area, and functional area. If you include additional account assignment objects of controlling in the Flexible General Ledger (such as cost center), and you then repost these objects within controlling, a reconciliation between the controlling and Flexible General Ledger data will not longer be possible.
Flexible General Ledger Structure

Definition
The Flexible General Ledger can be expanded to include SAP dimensions (such as cost center, profit center) and customer dimensions (such as region). These dimensions are then available for planning and reporting use. A dimension is a single field or column of a database table.

The Flexible General Ledger runs parallel to the previous general ledger. Data is transferred to the Flexible General Ledger via the accounting interface.

Using SAP Dimensions
You decide on which dimensions you want to include in the Flexible General Ledger. These dimensions are fields that are already available in the standard system, such as cost center, profit center, and transaction type.

If you have made the corresponding settings in Customizing, entries are made for these fields in the Flexible General Ledger. To do this, carry out the activity “Select scenarios” in the Flexible General Ledger Implementation Guide.

The following table shows the individual scenarios provided in the standard system along with the fields in which data entries are made, once they are activated.

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Field Description</th>
<th>Technical name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account/business area</td>
<td>Account</td>
<td>RACCT</td>
</tr>
<tr>
<td></td>
<td>Business area</td>
<td>RBUSA</td>
</tr>
<tr>
<td>Cost of sales accounting</td>
<td>Functional area</td>
<td>RFAREA</td>
</tr>
<tr>
<td></td>
<td>Partner functional area</td>
<td>SFAREA</td>
</tr>
<tr>
<td></td>
<td>Account</td>
<td>RACCT</td>
</tr>
<tr>
<td></td>
<td>Business area</td>
<td>RBUSA</td>
</tr>
<tr>
<td>Profit center update</td>
<td>Profit center</td>
<td>PRCTR</td>
</tr>
<tr>
<td></td>
<td>Partner profit center</td>
<td>PRCTR</td>
</tr>
<tr>
<td></td>
<td>Account</td>
<td>RACCT</td>
</tr>
<tr>
<td></td>
<td>Business area</td>
<td>RBUSA</td>
</tr>
<tr>
<td>Cost center update</td>
<td>Cost Center</td>
<td>RCNTR</td>
</tr>
<tr>
<td></td>
<td>Sender cost center</td>
<td>SCNTR</td>
</tr>
<tr>
<td></td>
<td>Account</td>
<td>RACCT</td>
</tr>
<tr>
<td></td>
<td>Business area</td>
<td>RBUSA</td>
</tr>
<tr>
<td>Preparation for consolidation</td>
<td>Trading partner</td>
<td>RASSC</td>
</tr>
<tr>
<td></td>
<td>Transaction type</td>
<td>RMVCT</td>
</tr>
<tr>
<td></td>
<td>Account</td>
<td>RACCT</td>
</tr>
<tr>
<td></td>
<td>Business area</td>
<td>RBUSA</td>
</tr>
</tbody>
</table>
### Flexible General Ledger Structure

<table>
<thead>
<tr>
<th>Business area consolidation</th>
<th>Trading partner business area</th>
<th>SBUSA</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Account</td>
<td>RACCT</td>
</tr>
<tr>
<td></td>
<td>Business area</td>
<td>RBUSA</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Offsetting account update</th>
<th>Trading partner account number</th>
<th>SACCT</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Account</td>
<td>RACCT</td>
</tr>
<tr>
<td></td>
<td>Business area</td>
<td>RBUSA</td>
</tr>
</tbody>
</table>

### Using Customer-Defined Dimensions

You can add your own fields to the tables provided in the standard system. In this case, you enhance the database. For more information about this, in the Flexible General Ledger Implementation Guide (IMG) see the “Create enhancements” activity.

### Additional Information

You can find additional information on the capabilities of the Flexible General Ledger in the Implementation Guide of the Flexible General Ledger.
G/L Documents

Definition

The G/L document contains the line items and is thus a record of the balances in the Flexible General Ledger. The G/L document is a view of the accounting document that contains all account assignments. The G/L document only contains the account assignments or dimensions that are needed for the Flexible General Ledger.

Use

When updating the Flexible General Ledger, you can split documents.

The purpose of document splitting is to transport account assignment objects into document items containing no account assignments. You could, for example, assign the business area of the expense items to the payable items.

Line items are split, that is, a line from the accounting document is retrieved and several line items are updated in the Flexible General Ledger.

Example: Vendor invoice

Document items in the document entry (financial accounting document):

<table>
<thead>
<tr>
<th>Posting key</th>
<th>Account</th>
<th>Business area</th>
<th>Amount/USD</th>
</tr>
</thead>
<tbody>
<tr>
<td>40</td>
<td>300000</td>
<td>0001</td>
<td>40,00</td>
</tr>
<tr>
<td>40</td>
<td>300000</td>
<td>0002</td>
<td>60,00</td>
</tr>
<tr>
<td>31</td>
<td>Vendor A</td>
<td>0001</td>
<td>100,00</td>
</tr>
</tbody>
</table>

Document items in the Flexible General Ledger after document splitting (G/L document):

<table>
<thead>
<tr>
<th>Posting key</th>
<th>Account</th>
<th>Business area</th>
<th>Amount/USD</th>
</tr>
</thead>
<tbody>
<tr>
<td>40</td>
<td>300000</td>
<td>0001</td>
<td>40,00</td>
</tr>
<tr>
<td>40</td>
<td>300000</td>
<td>0002</td>
<td>60,00</td>
</tr>
<tr>
<td>31</td>
<td>Vendor A</td>
<td>0001</td>
<td>40,00</td>
</tr>
<tr>
<td>31</td>
<td>Vendor A</td>
<td>0002</td>
<td>60,00</td>
</tr>
</tbody>
</table>

Previously, you were not able to keep any independent accounting units in the general ledger (such as fund, profit center) other than company code and business area. This is due to the fact that the profit center, for example, is stored in the cost item of an invoice receipt, but the profit center is no longer contained in the payable item (that is, in the reconciliation account). This is the result of the fact that a payable item is not created for each expense item. With an outgoing payment, the profit center is also no longer available. The profit center could thus not be used as a balancing unit.

This problem could be solved by providing the corresponding offsetting items with the desired account assignments. The offsetting items would thus have to be split based on the number of assignments. For example, the payable side of an invoice is split according to the account assignments on the expense or profit side. The G/L document would thus be expanded to include additional document items.
G/L Documents

Constraints
Document splitting is a function that only works with G/L documents. It cannot be used for accounting or financial accounting documents.

Activities
The following functions are available in the Flexible General Ledger menu for G/L documents.

- Document display under Document → G/L document
- Document search under Document → G/L document search
- Document archiving under Periodic processing → G/L Documents → Archive

You make the Customizing settings for the document splitting in the Flexible General Ledger Implementation Guide.
**Allocation**

**Use**

You can execute an assessment and distribution of amounts from a sender field to a receiver field just like you can in the Special Purpose Ledger (FI-SL) application component (for example, from one cost center to other cost center).

**Prerequisites**

You have made the Customizing settings for allocation in the Flexible General Ledger Implementation Guide.

**Activities**

To carry out an allocation, select the following activities in the Flexible General Ledger menu:

- Periodic processing → Allocation → Actual assessment
- Periodic processing → Allocation → Plan assessment
- Periodic processing → Allocation → Actual distribution
- Periodic processing → Allocation → Plan distribution

The procedure for allocation corresponds to the allocation procedure in the application component Special Purpose Ledger (FI-SL). The following is thus a description of the allocation function as contained in the “FI Special Purpose Ledger” documentation. Different than allocation in the Special Purpose Ledger, no distinction is made in the Flexible General Ledger between local ledgers and global ledgers. There are only local ledgers in the Flexible General Ledger.

The Flexible General Ledger is also different from the Special Purpose Ledger in the following ways:

- Only financial accounting document types are valid.
- Only one table (GLFLEXT) is used.
- For the field movement, other table fields play a role.
Allocation

**Purpose**
You can periodically allocate amounts and quantities from sender objects to receiver objects using allocations. The two main types of allocations are assessments and distributions. You can allocate both plan and actual data. You carry out the allocation using the allocation cycle function. You use allocation rules to determine how amounts and quantities should be allocated from sender object to receiver object. It is possible to assess/distribute amounts and quantities according to the following criteria, for example:

- Headcount
- Sales costs
- Sales for a particular period

**Implementation Considerations**
In order to effect the allocation, you have to make various settings in Customizing. You make the settings in Customizing under *Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation.*

**Integration**
You can process data both from other SAP application components as well as from external systems with the allocation.

**Features**
You can choose between the Allocation Types [Page 16] “distribution” and “assessment”. In this way, you determine how the allocation process is carried out.

You use Allocation Rules [Page 19] to determine how amounts and quantities should be allocated from sender object to receiver object. You can choose between various Sender Rules [Page 20] and Receiver Rules [Page 22].

Processing of the data is effected using the Allocation Cycle [Page 26]. Within an allocation cycle, you can define allocation segments. You determine allocation rules in an Allocation Segment [Page 28].

The header data of the allocation cycle contains information valid for all segments contained in the cycle. Both Iterative Processing of Allocation Cycles [Page 48] and Cumulative Processing of Allocation Cycles is possible. You can distribute or assess quantities and/or transaction currency amounts. You can define Selection Criteria [Page 32] and Rules for Selection Criteria [Page 33]. You determine the processing of the allocation cycle using Dimensions in Allocation [Page 35].

You can lock individual segments in an allocation cycle so that they are not included in processing. See Locking Segments in an Allocation Cycle [Page 61].

You can choose whether to execute allocation cycles in online mode or batch mode. See Executing Allocation Cycles [Page 68]. You can determine how the system handles errors that occur during processing. Click here [Page 73] for more information on errors.
Information is also available on Reversing Allocation Cycles [Page 75] and Deleting Allocation Line Items [Page 76].

See also Displaying Allocation Results [Page 77] and Printing Detail Lists [Page 91].
Allocation Types

Definition
Summary of processes that can occur in connection with an allocation.

- **Distribution**
  Amounts and quantities of one or more sender objects are distributed to one or more receiver objects, from service cost centers to production cost centers, for example. The debit and credit postings for the distribution occur under the original account/original cost element with which the amounts and quantities are posted at the sender. The information of the original account/original cost element remains intact.
  The distribution can be carried out with actual and plan data.

- **Assessment**
  The assessment works in the same way as the distribution. However, with the assessment, the debit and credit postings do not occur under the original account or the original cost element but under an assessment account or an assessment cost element. The information of the original account/original cost element are lost.
  The assessment can be carried out with actual and plan data.

Structure
During the allocation, the following allocation types are distinguished:

- *Actual assessment → Change/Display/Delete*
- A planned assessment
- An actual distribution
- A planned distribution

An allocation using assessment can occur if the composition of the accounts or cost elements does not contain any important information for the receiver.

Assessed/distributed data records are stored separately in the summary tables. For this reason, you can view actual or plan data, with or without the allocated values.

For more information on displaying actual and plan data records, see [Displaying Actual Documents [Ext.]] and [Displaying Plan Documents [Page 200]].

In the information system, you can display the results of the allocation under the respective account or the respective cost element according to sender and receiver relationships. Sender and receiver information is documented in the line item document.

Example

Assessment
With an assessment, both sender and receiver amounts are posted to an assessment account.
The allocation is performed as follows:

1. Assessment account 600000 accumulates the balances of the accounts (510000, 520000, and 530000).

2. Assessment account 600000 equally allocates the balance from the utilities accounts (EUR 1,500) to EDP (cost center 100), Sales (cost center 300), and Marketing (cost center 400).

3. The amount EUR 500 is debited from each of the receiving cost centers in account 600000.

4. The assessment account 600000 is credited with the amount EUR 1,500.

**Distribution**

When you carry out a distribution, you allocate the balance from the original sender to the receiver. During the distribution, the original sender account is credited and the receiver account debited.

The allocation is processed as follows:
Allocation Types

1. The amounts of the sender accounts (510000, 520000, 530000) are distributed equally to EDP (cost center 100), Sales (cost center 300), and Marketing (cost center 400).

2. The amount EUR 500 is charged to each of the receiving cost centers in accounts 510000, 520000, and 530000. The original account is therefore retained.

3. The accounts 510000, 520000, and 530000 of the Administration cost center are credited.
Allocation Rules

Definition

You use allocation rules to determine how amounts and quantities are allocated between sender objects (sender values) and receiver objects (receiver tracing factor). The rules for the allocation types are made up of sender and receiver rules.

- **Sender rules**
  - **Determination of the sender values** for the distribution/assessment can occur according to the following rules:
    - Posted amounts
    - Fixed amounts
    - Fixed rates

- **Receiver rules**
  - **Determination of the sender values** for the distribution/assessment can occur according to the following rules:
    - Variable portions
    - Fixed amounts
    - Fixed percentages
    - Fixed portions

Use

You can combine all sender and receiver rules for the distribution/assessment.

Combination of sender and receiver rules

<table>
<thead>
<tr>
<th>Sender</th>
<th>Receiver</th>
<th>Fixed amounts</th>
<th>Fixed percentages</th>
<th>Fixed portions</th>
<th>Variable portions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Posted amounts</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fixed amounts</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fixed rates</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
Sender Rules

Sender Rules

Sender rules control how sender values are determined. You can use the following sender rules for sender values:

- Posted balances
- Fixed amounts
- Fixed rates

If you choose the sender rule *posted amounts*, you can choose the selection criteria in the Sender values tab.

If you choose the sender rule fixed amounts or *fixed rates*, the Distribution Criteria List dialog box appears on the Sender values tab page. Here, you have to choose the allocation criteria.

**Posted balances**

The posted balance (amount) stored in the database for the sender is posted to the receiver. When you define the allocation rule for the sender, you can determine what percentage of the sender balance should be credited with the allocation amount.

The sender balance is 50,000 EUR. You define a percentage of 50% to be credited to the sender. The amount 25,000 EUR is credited to the sender. The sender balance is now 25,000 EUR.

You want to credit an allocation to sender accounts 501000 through 502000. For this allocation, you want to use the balances of accounts 601000 through 602000 as sender. You create an allocation cycle in the following steps:

a) Use the *posted amounts* allocation rule for the sender.

b) Define accounts 501000 to 502000 as sender and accounts 601000 to 602000 as sender values.

c) The system distributes the balances of accounts 601000 through 602000, but posts these as a credit to accounts 501000 through 502000.

**Fixed amounts**

You can allocate a specific fixed amount of the sender. The balance of the sender is not crucial here. The following options are available:

- You can allocate a specific, fixed amount from each sender
- You can allocate amounts in any currency

Each time the allocation cycle is carried out, the same amount is assessed/distributed from the sender. The allocated amount does not depend on the current balance of the sender.

**Fixed rates**
If you determine a fixed rate for each unit of the receiver tracing factor,

- The sender is not credited with a specific amount (unlike with fixed amounts). The sender is credited with the amount that results from multiplying the fixed rate with the total of the respective receiver tracing factors. This sender value is then assessed/distributed to the receiver according to the receiver tracing factor.

- The receiver is debited with an amount that results from multiplying its tracing factor by the sender fixed rate.

In the example, fixed rates are allocated as sender rule.

The receiver tracing factor is the statistical key figure “CANTEEN”.

The number of employees in cost centers PERSON 1, PERSON 2, and PERSON 3 is 50, 100 and 150 respectively (total = 300).

The sender allocation rule is a fixed rate of 10 EUR/employee.

### Before assessment

<table>
<thead>
<tr>
<th>Sender</th>
<th>Sender rule</th>
<th>Receiver tracing factor</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center: “CANTEEN” (300 empl.) + EUR 3000</td>
<td>Fixed rate 10 EUR per empl.</td>
<td>Statistical key figure “CANTEEN”</td>
<td>Cost center:</td>
</tr>
</tbody>
</table>

### After assessment

<table>
<thead>
<tr>
<th>Sender</th>
<th>Sender rule</th>
<th>Receiver tracing factor</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center: “CANTEEN”</td>
<td>Fixed rate 10 EUR per empl.</td>
<td>Statistical key figure “CANTEEN”</td>
<td>Cost center:</td>
</tr>
</tbody>
</table>

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>- EUR 3000</td>
<td>10 EUR per empl. * 50 (total empl.) =</td>
<td>Person 1: + 500 EUR</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10 EUR per empl. * 100 (total empl.) =</td>
<td>Person 2: + 1000 EUR</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10 EUR per empl. * 150 (total empl.) =</td>
<td>Person 3: + 1500 EUR</td>
<td></td>
</tr>
</tbody>
</table>
Receiver Rules

Receiver rules control how receiver tracing sizes are determined. The following receiver rules can be used for receiver tracing factors:

- Variable portions
- Fixed amounts
- Fixed percentages
- Fixed portions

Variable portions

A variable portion is allocated to each receiver, based on values found in the FI-SL summary database (which is used as the basis for the allocation). The totals table is thus used as the basis for the allocation.

To define an allocation with variable portions, you specify dimensions and values for determination of the variable portions under Receiver tracing factors.

You could define an allocation so that the system checks the headcount of the cost centers in the receiver(s) to determine how the amount from the sender(s) should be assessed/distributed. This example assumes that the headcount was entered in the system by cost center (for example, as the statistical key figure Employees). Before the allocation is carried out, the system uses the variable portions in the summary database to check the personnel level of the cost centers.

Variable portions
### Receiver Rules

<table>
<thead>
<tr>
<th>Sender</th>
<th>Receiver tracing factor</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center 200 (administration)</td>
<td>Statistical key figure Employees</td>
<td>Cost centers 100 (EDP): 300 (Marketing) and (Sales): 400</td>
</tr>
</tbody>
</table>

1. **Sender**
   - Cost center 200
   - Assess./dist. amnt: **1,000**

2. **Receiver control**
   - (Headcount (HdC))

3. **Total HdC = 200**

4. **Calculations**
   - CC100: 40/200 = 20%
   - CC300: 60/200 = 30%
   - CC400: 100/200 = 50%

5. **Amounts**
   - CC100: 20% of 1,000 = **200**
   - CC300: 30% of 1,000 = **300**
   - CC400: 50% of 1,000 = **500**

When allocating amounts using variable portions, the system:

1. Checks the database summary records of the sender, for the cost center 200 *administration*. Finds the amount 1,000 that will be assessed/distributed.

2. Checks the database records defined as a result of the tracing factor for the personnel level of the cost centers *EDP*, *Marketing*, and *Sales* to determine the current receiver tracing factors. The amounts are:

<table>
<thead>
<tr>
<th>EDP (100)</th>
<th>Personnel level 40</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales (300)</td>
<td>Personnel level 60</td>
</tr>
<tr>
<td>Marketing (400)</td>
<td>Personnel level 100</td>
</tr>
</tbody>
</table>

3. Totals the database summary records of the tracing factor for the headcount in EDP, Marketing, and Sales. The total headcount is 200.
Receiver Rules

4. Divides the amounts of the receiver control objects (individual receiving cost centers) by the total amount, in other words 200, to determine a percentage for each variable portion value. The percentages are:

<table>
<thead>
<tr>
<th>Control Object</th>
<th>Percentage Calculation</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>EDP (100)</td>
<td>40/200 = 20%</td>
<td>20%</td>
</tr>
<tr>
<td>Sales (300)</td>
<td>40/300 = 30%</td>
<td>30%</td>
</tr>
<tr>
<td>Marketing (400)</td>
<td>40/400 = 50%</td>
<td>50%</td>
</tr>
</tbody>
</table>

5. Uses the determined percentages to perform allocation to the relevant cost centers (receiver). Each of these contain the percentage that was determined. The allocation result is as follows:

<table>
<thead>
<tr>
<th>Control Object</th>
<th>Allocation Calculation</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>EDP (100)</td>
<td>20% of 1000 = 200</td>
<td>200</td>
</tr>
<tr>
<td>Sales (300)</td>
<td>30% of 1000 = 300</td>
<td>300</td>
</tr>
<tr>
<td>Marketing (400)</td>
<td>50% of 1000 = 500</td>
<td>500</td>
</tr>
</tbody>
</table>

Fixed amounts

A specific fixed amount is allocated to each receiver. The amount credited to the original sender or assessment account is the sum of the receiver's fixed amounts and is also dependent upon the sender rule.

When you assess/distribute data using fixed amounts:

- You can allocate a specific, fixed amount to each receiver
- You can assess/distribute amounts in any currency
- The total of assessed/distributed fixed amounts are credited to the sender according to the sender rule.

The same fixed amount is assessed/distributed to the receiver each time the allocation cycle is executed.

Fixed percentages

A fixed percentage is assessed/distributed to each receiver, based on the amount to be allocated from the sender. You can define the percentage that should be assessed/distributed to each receiver. This percentage cannot be over 100%.

When you process data records using fixed percentages:

- You can assess/distribute a specific, fixed percentage to each receiver
- The system calculates the assessed/distributed amounts based on the percentage you entered for each receiver and sender value
- The credit to the sender or the assessment account is based on the amount available to be allocated from the sender (sender rule)

Each time the allocation cycle is carried out, the same percentage amount is assessed/distributed to the receiver. If you enter less than 100%, the sender is only credited with the percentage amount that you enter. The sender base is always 100%. 
Fixed percentages

<table>
<thead>
<tr>
<th>Sender (amount)</th>
<th>Receiver values</th>
<th>Result (amount)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000 EUR</td>
<td>Cost center 100: 10%</td>
<td>Cost center 100: 100 EUR</td>
</tr>
<tr>
<td></td>
<td>Cost center 200: 10%</td>
<td>Cost center 200: 100 EUR</td>
</tr>
<tr>
<td></td>
<td>Cost center 300: 50%</td>
<td>Cost center 300: 500 EUR</td>
</tr>
</tbody>
</table>

The sender balance is 300 EUR after the allocation is carried out.

Fixed portions

A fixed portion is assessed/distributed for each receiver. The system handles fixed portions in the same way as variable portions.

The only difference with fixed portions is that you determine which portion is assessed/distributed.
Allocation Cycle

Definition

Allocation cycles summarize the rules and settings to enable an allocation to occur. An allocation cycle consists of header data and one or more allocation segments that are processed together.

Use

The header data of the allocation cycle contains information valid for all segments contained in the cycle. Within a cycle, you can define several segments. In one segment you determine the rules by which an allocation is carried out.

You can carry out the entire allocation operations of the allocation in one cycle.

You can define several cycles that are then processed by the system in the order in which they were entered. The system ensures that a cycle is processed in full before the next cycle is carried out.

Splitting into several cycles can be beneficial for the following reasons:

- **Performance reasons**

  System run time rises considerably the more segments you process in an allocation, and where the value intervals are too large

- **Allocation relevant reasons**

  Where subsequent changes are required, it is not necessary to repeat the entire allocation operations. You just repeat the cycles affected.

  Using several cycles means that the allocation can occur at different times.

  Cycles are saved time-based. For each cycle, you have to enter a validity period in the header data. The selected cycle has to be valid in the posting period. It is not possible, for example, to carry out an allocation with a cycle in the second half-year of a fiscal year where that cycle is defined solely for the first half-year.

Dependent allocation cycles

You can create allocation cycles that are based on one another. Cycles are deemed to be dependent on each other where one cycle uses the result of an allocation of a previous cycle. In the case of dependent cycles, it is imperative that the order of execution is observed. Before execution, be sure that:

- If you have entered several cycles in the initial screens (**collective execution**), the system effects the cycles in the order in which they were entered. The allocation results of a cycle are transferred internally to the subsequent cycle. Iterative relationships between cycles are **not** taken into consideration.

- If you start dependent cycles separately (**individual execution**), data transfer occurs via the database but the end results correspond to those of collective execution.
Dependent segments
The segment order within a cycle has no bearing on the result of cycle execution. The following execution types exist:

With Iterative indicator
When you process an allocation cycle iteratively, the result of one segment is then used by the other segments and processed further. The system continues to process the segments until all senders are completely credited.

Without Iterative indicator
When you do not process an allocation cycle iteratively, each segment in the cycle is processed independently of the other segments in the cycle. The result of one segment is not used by the following segments.

With Cumulative indicator
When you process an allocation cycle cumulatively, receiver tracing factor fluctuations or sender amounts to be allocated are cleared. In this way, a correct assignment of the allocated quantities and amounts is possible. Cumulative allocation smoothes the allocation over the periods.

You can find more information under Iterative/Cumulative Processing of Allocation Cycles [Page 48].
Allocation Segment

Definition

Summary of the rules for the allocation. The following information is summarized in an allocation segment:

Rules for sender objects

All values to be allocated that are determined according to the same rules are summarized for the sender objects.

Rules for receiver objects

All receiver trace objects that are determined according to the same rules are summarized for the receiver objects.

Use

You can define several segments within a cycle.

Overview: Sender values/receiver tracing factors per allocation

<table>
<thead>
<tr>
<th>Allocation</th>
<th>Sender values</th>
<th>Tracing factors of the receiver objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution</td>
<td>- Posted amounts</td>
<td>- Variable portions</td>
</tr>
<tr>
<td></td>
<td>- Fixed amounts</td>
<td>- Fixed amounts</td>
</tr>
<tr>
<td></td>
<td>- Fixed rates</td>
<td>- Fixed percentages</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Fixed portions</td>
</tr>
<tr>
<td>Assessment</td>
<td>- Posted amounts</td>
<td>- Variable portions</td>
</tr>
<tr>
<td></td>
<td>- Fixed amounts</td>
<td>- Fixed amounts</td>
</tr>
<tr>
<td></td>
<td>- Fixed rates</td>
<td>- Fixed percentages</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Fixed portions</td>
</tr>
</tbody>
</table>

Structure

An allocation segment consists of the following elements:

- **Segment header**
  The segment header contains information that is valid for the whole segment. The sender and receiver rules determine how data records are assessed/distributed. You can find more information on allocation rules under Allocation Rules [Page 19].
  With the sender values, you can:
  - Define a percentage of the sender value that is credited to the sender
  - Determine whether plan or actual values are allocated
  The segment header data determines the sender and receiver values for the segment.

- **Sender/receiver**
You define sender and receiver object data, (cost center, account number, and business area, for example). You are able to use sets. For more information, see Sets [Ext.].

- **Sender values**
  Depending on the sender rule that you enter in the segment header, the following possible entries will be available to you for sender values: If you entered the sender rule
  - **Posted amounts**, you can enter sender values for these.
  - **Fixed rates**, you must enter sender values for these.
  - **Fixed amounts**, you must enter sender values for these.

- **Receiver tracing factors**
  If you specified:
  - **Variable portions**, you enter the receiver values for the receiver(s).
  - **Fixed amounts**, you enter the fixed amounts that should be allocated to each receiver.
  - **Fixed percentages**, you enter the fixed percentages (not more than 100%) that should be allocated to each receiver.
  - **Fixed portions**, you enter the fixed portions.

  For more information, see Creating a Receiver Tracing Factor for a Segment [Page 55].

**Example**
The following graphic is an example of a simple allocation segment.
In this graphic

- The allocation type is an assessment; Therefore, the allocated amount from the sender (accounts 500000-510000) is accumulated into an assessment account (400000).
- The cycle contains header data (1), company code 0001, and version 001. In addition to the local and group currency that are always usually allocated, the transaction currency should also be allocated.
- The segment header (2) contains the allocation rules for the assessment of the data of cost center 200 (administration). The allocation rule uses posted amounts for the sender and fixed percentages for the receiver.
- The sender (3) consists of all existing data records for the administration cost center (200) and accounts 500000-510000.
- The receivers (4) of the allocation are EDP (cost center 100), Sales (cost center 300), and Marketing (cost center 400).
- The tracing factors (5) are the percentages that are assigned to the receiver values (cost center 100: 10%; cost center 300: 30%; cost center 400: 60%).

For a further example of allocation with segments, see Segment [Ext.].
Selection Criteria

You can define selection criteria for the allocation. You use:

- **Values**
  You can allocate from and to specific values and/or ranges of values.

- **Sets**
  Using sets, you can allocate from a sender and/or to a receiver.

You can use both Basic Sets [Ext.] and Single-Dimension Sets [Ext.] as selection criteria for the allocation. For more information, see Sets [Ext.].

To specify values used during the allocation, you can determine a **value, value interval, or set name** for each of the following dimensions that are used in selection:

- Sender/receiver
- Sender values
- Receiver tracing factor
Rules for Selection Criteria

There are special rules for using values for different dimensions of a segment:

Dimensions as selection criteria

Identical dimensions (for example for senders and receivers) only need to be entered once in the sender selection criteria, since they will be inherited. You can find more information on inherited dimensions under Dimensions in Allocation [Page 35].

If you do not enter a dimension as selection criteria, the dimension is not included in the data records for the allocation cycle and the data is summarized for this dimension. For undefined dimensions, the system will select all values.

In iterative processing, the system will allocate back to the sender if a dimension value is the same in the sender as it is in the receiver.

- The sender value is 400000 for the dimension account. The receiver values are 400000 for the dimension account and 110 and 120 for the dimension cost center. Segment processing will result in an endless loop because the receiver continues to assess/distribute back to the sender value 400000.

Sets as selection criteria

The following rules control the use of set values, if you use sets as selection criteria for your dimensions:

- You cannot use a variable in a set used in an allocation.
- To select or allocate all data records for a dimension, use the Insert all values function (in set maintenance under Edit). The system uses data records for all values in the dimension and creates data records for all values.

If you do not define a dimension, all data records for this dimension are selected; however, the initial value of the dimension is summarized in the created sender and receiver data records.

If you select all values for a dimension (for example, using a range of values or the set value All values), all data records for the dimension are selected and sender and receiver data records are created for every field value (the dimension will not be summarized).

- In Customizing for the Special Purpose Ledger you can define the following fields more precisely:
  - Sender/receiver
  - Sender values
  - Receiver tracing factor

You can determine:

- Which fields can be used for receiver, sender, sender values, and/or tracing factor.
- Whether a user can enter a value, a range of values, and/or a set name for a field.
Rules for Selection Criteria

For more information, refer to the activities under *Allocation* in the Implementation Guide (IMG) for *Special Purpose Ledger*. 
Dimensions in Allocation

Use
The processing of an allocation cycle is dependent on the dimensions that you use.

Features
You can choose between the following dimensions:
- Inherited Dimensions
- Distribution Dimensions
- Fixed Dimensions

Inherited Dimensions
Dimensions that are automatically transferred from a sender to a receiver or to sender control, or from a receiver to tracing factor, are called inherited dimensions. Dimensions are inherited as follows:

- **Cycle dimensions** (for example, company code) entered on the Create <Allocation Type>: Initial and Header screens are automatically inherited by the segments in the allocation cycle. Within the individual segments, you can overwrite these dimension values as needed.

- **Segment dimensions** are inherited as follows:

Sender and receiver dimensions are inherited from the sender. Tracing factor dimensions are inherited from the receiver.

A dimension is defined in the **sender**, but not in the sender control or receiver:

The sender contains values 500000, 510000, and 520000 for the dimension "account" and the values 10 and 20 for the dimension "plant". No selection criteria are defined for the dimensions “account” and “plant” in the receiver. For this reason, the receiver inherits the values 500000, 510000, and 520000 for the dimension “account” and the values 10 and 20 for the dimension “plant".
A dimension is defined or inherited in the receiver, but not in the tracing factor:

From the sender, the receiver inherits the values 500000, 510000, and 520000 for the dimension “account” and the values 10 and 20 for the dimension “plant”. No selection criteria are defined for the dimensions “account” and “plant” in the tracing factors. The tracing factor therefore inherits the values 500000, 510000, and 520000 for the dimension “account” and the values 10 and 20 for the dimension “plant”.

- If you want your sender values to use some of the dimensions that are defined in your sender (but not all), only define the dimensions that you do not want the sender values to inherit from the sender.
- If you want your receiver to use some of the dimensions of your sender, you do not have to enter these dimensions for your receiver again.
- If you want your tracing factor to use the same dimensions that are defined or inherited in your receiver, you do not have to define the dimensions in your tracing factor.

Do not define the value for your receiver if the allocation is to occur from one value in a dimension to the same value in this dimension. This value is inherited from sender to receiver automatically.

Do not define the dimension “plant” in your receiver if the allocation is to be from plant 10 and cost center 100 (sender) to cost centers 200 and 300 for plant 10 (receiver), and from plant 20 and cost center 100 (sender) to cost centers 200 and 300 for plant 20 (receiver). The values of this dimension are inherited automatically from sender to receiver. The allocation is then carried out:

<table>
<thead>
<tr>
<th>From:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant 10, cost center 100</td>
<td>Plant 10, cost center 200</td>
</tr>
<tr>
<td></td>
<td>Plant 10, cost center 300</td>
</tr>
<tr>
<td>Plant 20, cost center 100</td>
<td>Plant 20, cost center 200</td>
</tr>
<tr>
<td></td>
<td>Plant 20, cost center 300</td>
</tr>
</tbody>
</table>

Define the value for your receiver if the allocation is to occur from one value in a dimension to the same value in this dimension. The value is not inherited from the sender to the receiver in this case.

Define the dimension “plant” (10, 20) in your receiver if the allocation is from plant 10 (sender) to cost centers 200 and 300 for plant 10 and 20 (receiver), and from plant 20 (sender) to cost centers 200 and 300 for plant 10 and 20 (receiver). The allocation is then carried out:

<table>
<thead>
<tr>
<th>From:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant 10, cost center 100</td>
<td>Plant 10, cost center 200</td>
</tr>
<tr>
<td></td>
<td>Plant 10, cost center 300</td>
</tr>
</tbody>
</table>
If you do not define a dimension in the receiver and/or sender control, the values from the sender are automatically inherited. All dimensions in the cycle header are usually distributed to all segments.

**Distribution Dimensions**

The distribution dimension defines to which dimensions data is distributed. If you define more than one dimension as selection criteria for receiver(s), you need to instruct the system from which receiver values it should allocate data. You can specify more than one distribution dimension for the receiver.

If you use the fixed amount or fixed portion allocation rule for your receiver(s), and more than one dimension is defined for the receiver, you must specify for which dimension(s) you want to enter receiver values.

You enter the following receiver selection criteria for the dimensions “plant” and “cost center”.

<table>
<thead>
<tr>
<th>Plant</th>
<th>Cost center</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>100</td>
</tr>
<tr>
<td>20</td>
<td>300</td>
</tr>
<tr>
<td></td>
<td>400</td>
</tr>
</tbody>
</table>

If the **distribution dimension** is “plant”, you can enter amounts or portions for plants 10 and 20 (for cost centers 100, 300, 400).

If the **distribution dimension** is “cost center”, you can enter amounts or portions for cost centers 100, 300, and 400 (for plants 10 and 20).

If the distribution dimensions are both “cost center” and “plant”, you can enter amounts or portions for the following combinations:

- Cost center 100/plant 10
- Cost center 100/plant 20
- Cost center 300/plant 10
- Cost center 300/plant 20
Features

- Cost center 400/plant 10
- Cost center 400/plant 20

When you select a distribution dimension, you do not change the amount or portion that is allocated. You only determine to which values data will be allocated.

If there is only one dimension defined for the receiver, that dimension automatically becomes the distribution dimension.

Fixed Dimensions

A fixed dimension is any dimension that contains **exactly** one value in the receiver. This value always appears in the data records for the receiver of the allocation.
Tips for Optimizing System Runtime

To optimize system performance and run time, please observe the following:

Avoid having more than 50 segments in an allocation cycle, as this will otherwise cause a considerable rise in system run time.

Check whether it is necessary to set the *iterative* indicator in the relevant cycle.

The processing of the assessment occurs more quickly than processing of the distribution as, in the case of the assessment, the data is summarized via an account.

The optimal database access strategy depends heavily on the definition of a cycle. You can define the type of database access strategy via an indicator.

From the *Execute <Allocation Type>: Initial Screen*, choose *Settings* → *Database selection*. Here, you can choose between the following database access strategies:

- **Selection by cycle**
  
  For each field in the cycle that is accessed, the largest and smallest value is determined in the whole cycle and used for database selection.

  **Advantage:** Database is accessed exactly once.

  **Disadvantage:** There is the risk that too many objects are selected. You have to eliminate the excess afterwards.

- **Selection by segment**
  
  For each field in the cycle that is accessed, the largest and smallest value is determined in the segment.

  **Advantage:** The performance of database selection with number of segments is virtually linear and no longer exponential.

  **Disadvantage:** Occasionally, the hit list is rather high.
Overview: Carrying out the Allocation

Procedure

To carry out an allocation, proceed as follows:

1. **Make the system settings:**
   - Determine the structure for your allocations. You define the dimensions and the appropriate values from/to which the allocation is to occur.
   - Maintain the field usage for the allocation. In Customizing for Special Purpose Ledger, define the fields that can be used for assessment and distribution allocations.
   - Define the allocation field group information, data fields, text for the data fields, and system information, if necessary. You only need to maintain this information in exceptional cases.
   - Check all settings made in Customizing. To do this, choose Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation → Check Allocation Settings. You only need to complete this step once.

2. **Create the sets that you want to use for the allocation, if required.**
   - You can assess/distribute fixed values.
   - You can use sets to determine the sender(s) and the receiver(s) for an allocation. When you define allocation segments, you can enter set names for the sender, receiver, sender values, and tracing factor selection criteria.

3. **Create the allocation cycle.**
   - Define the header data of the allocation cycle. The header data of the allocation cycle contains information valid for all segments contained in the cycle.

4. **Define the allocation segments in the allocation cycle.**
   - When you create an allocation cycle, you define information for one or more allocation segments.
   - You define the rules for allocating from the sender(s) and the selection criteria for the sender(s) and receiver(s). For more information, see Creating Allocation Cycles [Page 42].

5. **Execute the allocation.**
   - You can execute allocation cycles in both online and background processing.
   - The system locates data records to be used for the allocation, according to the selection criteria defined in the sender.
   - The system allocates the data according to the allocation type (assessment or distribution) and the allocation rule.
   - The system writes the data records for the allocation.
   - The system generates lists of allocation results and errors (if the allocation process included errors).

For more information, see Executing Allocation Cycles [Page 68].
6. **Display the allocation results.**

After the allocation is carried out, a basic list is output, that permits you to control and verify processing.

For more information, see:

- Displaying Cycle Overviews [Page 79]
- Displaying Standard Settings [Page 80]
- Displaying Messages [Page 81]
- Displaying Line Items [Page 83]
- Displaying Segment Lists [Page 84]
- Displaying Sender Lists [Page 85]
- Displaying Receiver Lists [Page 86]
- Displaying Journals [Page 87]
- Technical Statistics, Expert Trace, and Divergence Analysis [Page 88]
- Printing Detail Lists [Page 91]
- Displaying Previous Processing [Page 90]
Creating Allocation Cycles

Use

You define allocations in cycles in the FI-SL System if you want to carry out an assessment or a distribution. Every cycle consists of one or more segments. Within each segment, you define the sender and receiver for the segment, as well as the rules for allocating data.

Prerequisites

To create allocation cycles and allocation segments, choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation, and then either:

- Actual assessment / Actual distribution → Create
- Plan assessment / Plan distribution → Create

The system displays the **FI-SL: Create <Allocation Type>: Initial Screen**.

You can also enter actual data via Actual posting. (Actual posting → Actual closing → Actual assessment or Actual distribution → Create).

You can also enter plan data via Planning. (Planning → Plan closing → Plan assessment or Plan distribution → Create).

Procedure

1. Make the following entries:
   - Ledger name
   - Name for the allocation cycle
   - Start date for the allocation cycle

   The first character of the allocation name cannot be a number. If you use the same name for an allocation more than once, the allocations must have different starting dates. When allocation cycles have the same name, but different starting dates, the system processes the cycles as independent objects. In the event of a change, this allows you to keep your old cycle and to create a new cycle with the same name but a different start date. If you define cycles that have the same name, the valid period of the first cycle should normally end before the second cycle starts.

   - Use the reference information, if you want to copy an existing allocation cycle, for example.

2. Choose Execute.

   The system displays the **FI-SL: Create <Allocation Type> Cycle: Header Data** screen.

   For more information, see:
Creating Header Data for an Allocation Cycle [Page 44]
Creating a Segment for an Allocation Cycle [Page 50]
Creating Sender Values for a Segment [Page 53]
Creating a Receiver Tracing Factor for a Segment [Page 55]
Creating Header Data for an Allocation Cycle

Use
The information that you enter in the cycle header applies to every segment that you create for the cycle.

Procedure
1. On the FI-SL: Create <Allocation Type>: Header Data screen, enter the following data:
   - End date for the allocation cycle
   - Description for the allocation cycle. This description appears when you execute the allocation.
2. In the Indicators group box:
   - Deselect Iterative if you do not want to process the allocation cycle iteratively.
   - Select the Cumulative indicator if you want to process the allocation cycle as a cumulative allocation.
     You can find more information under Iterative Processing of Allocation Cycles [Page 48].
3. Select the field groups to be used in the cycle:
   - Select Actual quantities, if you want to allocate amounts and quantities.
   - Select Act. tr., if you want to allocate transaction currency. If you do not set this indicator, the system uses the second or third currency (depending on your system configuration) and writes it as transaction currency to the sender(s) and receiver(s) data records. This reduces the number of records stored on the database, since the system does not take into consideration the different transaction currencies.
4. Enter the selection criteria in the Preset selection criteria group box.
   The selection criteria fields that appear depend on the system structures you have defined for allocations in Customizing for Special Purpose Ledger. The values you enter in these fields are valid for all senders and receivers in all segments (unless specified in the segment definition).
   Enter the company code or the company: The allocation does not work company code/company independent.
5. You can use the following additional functions on this screen.

   Additional functions (FI-SL: Create <Allocation Type>: Header Data screen)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Attach segment</td>
<td>Add a segment to the cycle</td>
</tr>
<tr>
<td>Edit → Copy segment...</td>
<td>Copy an existing segment to the cycle</td>
</tr>
<tr>
<td>Goto → Overview segments...</td>
<td>Display an overview of segments contained in the cycle</td>
</tr>
</tbody>
</table>
6. Save your data.
**Cumulative Processing of Allocation Cycles**

**Use**

When you process an allocation cycle cumulatively, tracing factor fluctuations or sender amounts to be allocated are cleared. The allocation is usually carried out by period, meaning that posted values are allocated for a sender in a period according to tracing factors entered in this period. If the tracing factors or the sender amounts to be allocated fluctuate to a great extent, an assignment of the allocated costs based on source is not possible during processing by period. Cumulative processing of tracing factors or sender values can negate these fluctuations. Cumulative processing smoothes the allocations over the periods.

A publishing company produces periodicals that appear at least once a month, and also other less frequent publications. Sales and administration costs are assessed to cost centers with the monthly sales volume serving as the allocation base. With a non-cumulative assessment, overhead costs are not debited for periodicals that do not appear in certain months. Nonetheless, production of these goods does generate sales and administration costs even in such months. The periodicals that appear at least once a month are additionally debited with the sales and administration costs. Over a period of time, the periodicals that appear at least once a month have to bear too large a share (and the others too small a share) of the sales and administration costs.

With a cumulative assessment, allocation of the sales and administration costs is smoothed over the months. Periodicals that do not appear for a certain month are debited with sales and administration costs according to their share of cumulative sales volume.

In some countries, “smoothing” with allocation is a legal requirement. Using cumulative allocation, therefore, these legal obligations are fulfilled.

Some sold-to parties (public sold-to parties, for example) even stipulate such a smoothing to prevent manipulation of expenses.

**Prerequisites**

To carry out effective cumulative processing:

- Sender/receiver relationships must be stable within the fiscal year.

Within the fiscal year, senders or receivers must not be deleted. The system checks this condition during cumulative processing.

Deleting senders or receivers that existed in previous periods that no longer exist (or are no longer valid) in the current period due to master data checks or cycle changes will cause erroneous allocations. Increasing the allocation network is, however, non-critical.

- The sender rule *Posted amounts* and the receiver rule *Variable portions* should be used.

Only with this rule combination will a cumulation on sender and receiver-side actually occur.
Collective execution of cumulative and non-cumulative cycles is not possible.

Features

Executing Cumulative Processing

If you execute an allocation cycle cumulatively, the sender amounts posted up to the current period are allocated to the receiver as a result of tracing factors. Cumulative processing always cumulates from period 1.

The determined allocation amounts, too, are cumulated for each receiver and posted in the current period minus the amounts allocated to the respective receiver in the previous periods. Postings in previous periods are thus unchanged.

Only those amounts for the receivers that were posted in the previous periods using the appropriate cumulative processing are taken into account.

If you carry out cumulative processing for a period interval and have already posted cycles from the “To” period, the SAP System reverses all periods from the “To” period up to and including the last posted period. The system displays a confirmation messages. In the background, a log message is generated.

You should not change the Cumulative indicator during the current fiscal year.

The scaling of negative tracing factors is only applied to the cumulative total tracing factor for one receiver, not to the values of the tracing factors in the individual periods. For more information, see Scaling of Negative Tracing Factors [Page 57]

Reversing Cumulative Processing

If you wish to reverse cumulative processing, you must reverse up to the last posted period due to period-independent work methods.

In online execution, you can trigger reversal of subsequent already posted periods via a dialog box. If subsequent periods are already posted, reversal is not carried out in the background.

You wish to reverse a cumulative cycle in period 3, however periods 1 to 5 were already posted. Reversal of period 3 is only possible in conjunction with periods 4 and 5.

For more information, see Example of Cumulative Processing [Ext.].
Iterative Processing of Allocation Cycles

Use
You can process allocation cycles iteratively or non-iteratively.

Features

Iteratively
When you process an allocation cycle iteratively, the result of one segment is then used by the other segments and processed further. The segments are processed dependent on each other. This means, for example, that an account that is used as the receiver in one segment can be used again in another segment as the sender. The system continues to process the segments until all senders are completely credited. The order of the segments has no bearing on the allocation results.

The following graphic shows an allocation cycle with allocation segments that are processed iteratively. In this example, amounts are assessed/distributed from cost centers 100 (EDP) and 200 (Administration). As these cost centers also assess/distribute amounts between each other, the allocation cycle is processed iteratively:

Segment 1: The amounts of cost center 100 (EDP) are assessed/distributed to cost centers 200 (Administration), 300 (Sales), and 400 (Marketing).

Segment 2: The amounts of cost center 200 (from segment 1) are assessed/distributed to cost centers 100 (EDP), 300 (Sales), and 400 (Marketing).
Next, the amounts of cost center 100 from segment 2 is then assessed/distributed again to cost centers 200, 300, and 400 in segment 1. The allocation cycle is processed until the balance of all senders is zero.

When you process an allocation cycle iteratively, the system processes the segments until all senders have the balance 0. If your allocation is defined so that two or more senders/receivers in a cycle completely allocate in a non-solvable relationship, the system will end processing and display an error. For more information, see Iterative Processing of Cycles [Ext.]

**Non-iteratively**

When you do **not** process an allocation cycle iteratively, each segment in the cycle is processed independently of the other segments in the cycle. The values allocated from previous segments are not used by the following segments in the allocation cycle. The order of the segments in the cycle is irrelevant to the allocation results.
Creating a Segment for an Allocation Cycle

Use
To carry out an allocation, you have to define an allocation cycle. Every cycle consists of one or more segments. Within each segment, you define the sender and receiver for the segment, as well as the rules for allocating data.

Prerequisites
You chose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing and then selected the allocation type. The system displays the FI-SL: Create <Allocation Type>: Header Data screen.

Procedure
1. To create a segment, choose Attach segment. The system displays the FI-SL: <Allocation Type> Cycle: Segment screen.
2. Enter a name and description for the segment.
3. Set the block indicator if you want the system to temporarily ignore this segment in the allocation cycle.
   - When processing the allocation cycle, the system ignores this segment.
   - When you create an actual or plan assessment, the Assessment acct entry field is displayed. Enter the account number that will be used to accumulate data from the original sender account(s).
4. Choose the tab strip Segment header and enter the required data.
   - In Sender values, select the appropriate sender rule. You use sender rules to control how sender values are determined. For more information, see Creating Sender Values for a Segment [Page 53].
   - To credit the sender a certain percentage rate, enter the proportionate share in % of the sender value.
     - The entry of a percentage rate greater than 100% is not permitted.
   - To assess or distribute actual/plan data to the receiver(s), set the appropriate indicator. For more information, see Allocating Plan and Actual Values [Page 60].
   - On the Segment header tab page, under Receiver tracing factor, select the required receiver rule. You use receiver rules to control how receiver tracing bases are determined. For more information, see Creating a Receiver Tracing Factor for a Segment [Page 55].
5. Select the Senders/receivers tab and enter the required data. If you specified:
Creating a Segment for an Allocation Cycle

- A fixed value, you only enter a value in the From field
- A range of values, you only enter values in the From and To fields
- A mixture of fixed values and/or ranges of values, you only enter a value in the Set field

The dimensions that were defined in Customizing for your table are displayed. For more information about how your allocations software is configured, see the steps under Allocation in the FI-SL Implementation Guide (IMG).

6. Choose the tab strip Sender values and enter the required Selection criteria.

7. Choose the Receiver tracing factor tab and enter:
   - Type of variable portions, if you are working with a variable receiver tracing factor.
   - Scale neg. tracing factors, to control the scaling that is carried out in the event of negative tracing factors for the receivers.
   - Required selection criteria.

8. Select the Rec.wght.factors tab and enter a factor to determine the number of decimal places for the weighting factor.

9. You can use the following additional functions on this screen:

**Additional Functions**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Copy segment...</td>
<td>Copy an existing segment to the cycle</td>
</tr>
<tr>
<td>Edit → Delete segment</td>
<td>Delete the segment from the cycle</td>
</tr>
<tr>
<td>Goto → Header data</td>
<td>Enter header data for the cycle</td>
</tr>
<tr>
<td>Goto → Overview segments...</td>
<td>View an overview of segments contained in the cycle</td>
</tr>
<tr>
<td>Goto → Cycle run group</td>
<td>Process cycles of an allocation type in parallel</td>
</tr>
<tr>
<td>Extras → History...</td>
<td>View the revision history of the cycle</td>
</tr>
<tr>
<td>Extras → Error log</td>
<td>Display error log</td>
</tr>
<tr>
<td>Extras → Create set</td>
<td>Create a set for the segment</td>
</tr>
<tr>
<td>Extras → Change set</td>
<td>Change a set used in the segment</td>
</tr>
<tr>
<td>Extras → Display senders</td>
<td>Display a list of senders for the segment</td>
</tr>
<tr>
<td>Extras → Display receivers</td>
<td>Display a list of receivers for the segment</td>
</tr>
<tr>
<td>Extras → Change documents</td>
<td>Display change documents</td>
</tr>
<tr>
<td>Extras → Combinations → Senders</td>
<td>Change the distribution dimension(s) for the senders in the segment</td>
</tr>
</tbody>
</table>
Creating a Segment for an Allocation Cycle

| Extras → Combinations → Receivers | Change the distribution dimension(s) for the receivers in the segment |

10. To save the data, choose ☒.
Creating Sender Values for a Segment

Use

You control determination of sender values with sender rules. You can choose between the following sender rules:

- Posted amounts
- Fixed amounts
- Fixed rates

When you select **posted amounts**, these are assessed/distributed to each sender value.

When you select **fixed amounts**, these are assessed/distributed independent of the sender amounts.

When you select **fixed rates**, you have to enter these for each sender and for each unit of the receiver tracing factor.

Prerequisites

You chose `Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing` and then selected the allocation type. The system displays the `FI-SL: <Allocation Type> Cycle: Header Data` screen. You selected `Attach segment` and are now on the `FI-SL Create <Allocation Type>: Segment` screen.

Procedure

1. Choose the tab strip **Segment header** and enter the required data.
   - Under **Sender-val.**, select the required sender rule.
   - To credit the sender a certain percentage rate, enter the proportionate share in % of the sender value.
     
     The entry of a percentage rate greater than 100% is not permitted.
   - To assess or distribute actual/plan data to the receiver(s), set the appropriate indicator. For more information, see Allocating Plan and Actual Values [Page 60]

2. Select the **Senders/receivers** tab and enter the required data.

3. Choose the **Sender values** tab strip and enter the required data.
   - If you have selected the **posted amounts** sender rule, make the following entries:
     
     - Enter the percentage rate that reflects what percentage of the sender control values should be used for the allocation. The respective sender is credited with the remaining percentage.
     - To assess or distribute actual/plan data to the receiver(s), set the appropriate indicator.
     - Make the required settings under **Selection criteria**.
Creating Sender Values for a Segment

The dimensions are displayed that were defined in the IMG under Allocation for your table. For more information about how your allocations software is configured, see the steps under Allocation in the FI-SL Implementation Guide (IMG).

- If you have selected the **fixed amounts** sender rule, make the following entries:
  - Enter the currency in which the sender data is assessed/distributed.
  - For each sender value defined in the segment, enter the fixed amount to be assessed/distributed.

- If you have selected the **fixed rates** sender rule, make the following entries:
  - Enter the currency in which the sender data is assessed/distributed.
  - Specify a fixed rate for every sender and for each unit of the receiver tracing factor.

4. You can use the following additional functions on this screen:

### Additional Functions

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Copy segment...</td>
<td>Copy an existing segment to the cycle</td>
</tr>
<tr>
<td>Edit → Delete segment</td>
<td>Delete the segment from the cycle</td>
</tr>
<tr>
<td>Goto → Header data</td>
<td>Enter header data for the cycle</td>
</tr>
<tr>
<td>Goto → Overview segments...</td>
<td>View an overview of segments contained in the cycle</td>
</tr>
<tr>
<td>Goto → Cycle run group</td>
<td>Process cycles of an allocation type in parallel</td>
</tr>
<tr>
<td>Goto → First segment</td>
<td>Access segment header data for the cycle</td>
</tr>
<tr>
<td>Extras → History...</td>
<td>View the revision history of the cycle</td>
</tr>
<tr>
<td>Extras → Create sets</td>
<td>Create a set for the segment</td>
</tr>
<tr>
<td>Extras → Change sets</td>
<td>Change a set used in the segment</td>
</tr>
<tr>
<td>Extras → Display senders</td>
<td>Display a list of senders for the segment</td>
</tr>
<tr>
<td>Extras → Display receivers</td>
<td>Display a list of receivers for the segment</td>
</tr>
</tbody>
</table>

5. To save the data, choose 📝.
Creating a Receiver Tracing Factor for a Segment

Use
You control determination of receiver tracing factors with receiver rules. You can choose between the following receiver rules:

- Variable portions
- Fixed amounts
- Fixed percentages
- Fixed portions

If you choose variable portions, these are used by the system as tracing factor and assessed/distributed to the receiver.

If you select fixed amounts, the receivers are debited directly with these amounts. The amount credited to the sender results from the total of receiver amounts. The rule for determination of sender values is not used in this instance. Also, posted sender amounts or created fixed sender amounts are not taken into consideration.

If you select fixed percentages, you define fixed percentages for the receiver. The sender value is distributed to the receivers according to these percentages. The total of receiver tracing factors must not exceed 100%. The system assumes a sender tracing factor of 100%. If the total of receiver tracing factors is smaller than 100%, a part of the sender value remains with the sender.

If you select fixed portions, you define fixed portions for the receiver. The procedure is similar to fixed percentages. With this procedure, the sender is credited completely, unless you have defined a percentage residual value.

Prerequisites
You chose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing and then selected the allocation type. The system displays the FI-SL: Create <Allocation Type>: Header Data screen. You selected Attach segment and are now on the FI-SL Create <Allocation Type>: Segment screen.

Procedure
1. Choose the Segment header tab page and enter the required data (according to the sender rule you selected) under Receiver tracing factor.
   - If you selected the variable portions receiver rule, you must:
     - Select the Type of var. portions. The system controls how the receiver tracing factor of the respective allocation is determined.
     - Determine scaling of negative tracing factors. For more information, see Scaling of Negative Tracing Factors [Page 57]

2. Select the Senders/receivers tab and enter the required data.
3. Choose the Receiver tracing factor tab and enter the required data.
Creating a Receiver Tracing Factor for a Segment

The dimensions are displayed that were defined in the IMG under Allocation for your table. For more information about how your allocations software is configured, see the steps under Allocation in the FI-SL Implementation Guide (IMG).

- If you selected the **fixed amounts** receiver rule, you must:
  - Currency in which the receiver data is assessed/distributed.
  - Enter a fixed amount to be assessed/distributed for each receiver value in the segment.

- If you selected the **fixed percentage/fixed portion** receiver rule, you must:
  - For each receiver value defined for the segment, enter a fixed portion/percentage to be assessed/distributed to the value.

For the receiver rule **fixed percentages**, you cannot enter more than 100%.
For the receiver rule **fixed portions**, you enter fixed portions.

4. You can use the following additional functions on this screen:

**Additional Functions**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Edit</em> → Copy segment...</td>
<td>Copy an existing segment to the cycle</td>
</tr>
<tr>
<td><em>Edit</em> → Delete segment</td>
<td>Delete the segment from the cycle</td>
</tr>
<tr>
<td>Goto → Header data</td>
<td>Enter header data for the cycle</td>
</tr>
<tr>
<td>Goto → Overview segments...</td>
<td>View an overview of segments contained in the cycle</td>
</tr>
<tr>
<td>Goto → Cycle run group</td>
<td>Process cycles of an allocation type in parallel</td>
</tr>
<tr>
<td>Goto → First segment</td>
<td>Access segment header data for the cycle</td>
</tr>
<tr>
<td>Extras → History...</td>
<td>View the revision history of the cycle</td>
</tr>
<tr>
<td>Extras → Create sets</td>
<td>Create a set for the segment</td>
</tr>
<tr>
<td>Extras → Change sets</td>
<td>Change a set used in the segment</td>
</tr>
<tr>
<td>Extras → Display senders</td>
<td>Display a list of senders for the segment</td>
</tr>
<tr>
<td>Extras → Display receivers</td>
<td>Display a list of receivers for the segment</td>
</tr>
</tbody>
</table>

5. To save the data, choose 📝.
Scaling of Negative Tracing Factors

Use

Negative tracing factors can occur if the tracing factors are given not as quantities or percentage rates, but are taken from the database. This is the case, for example, with a distribution by activity types or statistical key figures.

The scaling of negative tracing factors is only of importance when the receiver tracing factors have different +/- signs.

If part of the receiver has positive and part negative tracing factors, we distinguish between two cases:

- If the total of all the receiver tracing factors is greater than zero, then the system credits (without scaling) the receiver as well as the sender with negative tracing factors. In the process, receivers with positive tracing factors are debited more heavily.

- If the total of all the receiver tracing factors is less than zero, the system credits (without scaling) the receiver as well as the sender with positive tracing factors. The receivers with negative tracing factors are thus debited more heavily.

In iterative processing, this can mean that the iteration does not converge, leading to cancellations or incorrect results.

Features

You have the following options for scaling negative tracing factors:

No scaling (1)

Negative tracing factors are allowed for.

Standard scaling (2)

The scaling depends on the total of the receiver tracing factors:

- If the total of the receiver tracing factors is positive or zero, then the largest negative tracing factor is set to zero. The other tracing factors are increased correspondingly. This ensures that all the receiver tracing factors are positive.

- If the total of the receiver tracing factors is negative, the largest positive tracing factor is set to zero. The other tracing factors are reduced correspondingly. This ensures that all the receiver tracing factors are negative.

Absolute value (negative value becomes positive) (3)

For negative tracing factors, the +/- sign is reversed. This ensures that all the receiver tracing factors are positive.

Negative tracing factors become zero (4)

Negative tracing factors are set to zero. Therefore, you do not allocate costs to these receivers.

Smallest negative tracing factor becomes zero (5)
Scaling of Negative Tracing Factors

The largest negative tracing factor is set to zero. All other tracing factors are increased correspondingly. This ensures that all the receiver tracing factors are positive. Receivers, which before the scaling had the tracing factor 0, are given a positive tracing factor.

Smallest negative tracing factor becomes zero, but zero remains zero (6)

The largest negative tracing factor is set to zero. All other tracing factors are increased correspondingly. Receivers, which before the scaling had the tracing factor 0, are given tracing factor 0.

Example of Scaling Negative Tracing Factors

<table>
<thead>
<tr>
<th></th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tra. fac. rec. 1</td>
<td>-100</td>
<td>0</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Tra. fac. rec. 2</td>
<td>200</td>
<td>300</td>
<td>200</td>
<td>200</td>
<td>300</td>
<td>300</td>
</tr>
<tr>
<td>Tra. fac. rec. 3</td>
<td>-50</td>
<td>50</td>
<td>50</td>
<td>0</td>
<td>50</td>
<td>50</td>
</tr>
<tr>
<td>Tra. fac. rec. 4</td>
<td>0</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>100</td>
<td>0</td>
</tr>
<tr>
<td><strong>Total tra. factors</strong></td>
<td><strong>+ 50</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The scaling of negative tracing factors can be set only for single segments and not for the entire cycle.
Defining Receiver Weighting Factors

Use
The tracing factors selected for the given receiver are multiplied by a weighting factor.

Procedure
1. To establish receiver-specific weighting factors, choose the Rec.wght.factors tab page.
2. If you want to use a receiver weighting factor other than 1, simply overwrite the default setting under Factor.
   
   When you make the entry, note that you must take into account the factor of the decimal places of the receiver weighting factor.
3. Choose ❯
4. If more than one segment exists in an allocation cycle, choose Previous segment or Next segment to scroll through the existing segments.
   
   The system informs you if no other segment exists.
5. To access another segment of the cycle, choose ❯
6. To access the header data of the cycle, choose ❯
7. Choose Edit → Delete segment to delete the segment for the receiver weighting factor.

Result
The allocation is made using a tracing factor determined by the system on the basis of the weighting factor.
Allocating Plan and Actual Values

Use

Allocating plan values in an actual allocation cycle
Separate allocation cycles are created for plan and actual allocations. In segment definition you can specify that the plan data is allocated in actual instead of the posted actual amounts and actual quantities. To do this, in segment definition select Plan values. Actual amounts and actual quantities are allocated analogous to the plan amounts and plan quantities.

⚠️
Allocations that have already occurred in the plan are not taken into account.

Allocating actual values in a plan allocation cycle
Separate allocation cycles are created for plan and actual allocations. In segment definition you can specify that the actual data is allocated in plan instead of the posted plan amounts and plan quantities. To do this, in segment definition select Actual values. Plan amounts and plan quantities are allocated analogous to the actual amounts and actual quantities.

⚠️
Allocations that have already occurred in actual are not taken into account.
Locking Segments in an Allocation Cycle

Use
You can lock individual segments in an allocation cycle. These segments do not participate in the processing of the allocation cycle.

Blocking of a segment is useful if data in your segment has changed and you wish to repeat a periodic allocation for this segment only. By locking the other segments in the allocation cycle, processing time is reduced.

Activities
You can lock the individual segments of a cycle when you create or change a cycle or a tracing factor. To do this, select Lock indicator.
Copying Segments

Use
You can copy existing segments. These copied segments can then be changed.

Prerequisites
You are on the FI-SL: Create / Change <Allocation Type>: Header Data screen.

Procedure
1. Select.
2. Select the segment that you want to copy and choose.
3. Choose Edit → Copy segment. The system displays the Copy segment dialog box.
   - Enter data for Copy from.
   - Enter data in the To field.

   You can copy segments within an allocation cycle or from another allocation cycle.
4. Choose Continue to leave the dialog box.

Result
You can now process the copied segments.
Displaying Allocation Cycles

Use

You can display a certain allocation cycle using the combination ledger, cycle, and start date. You can use this function to check whether an allocation cycle was created for a specific ledger and time period.

Prerequisites

You created a cycle. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation → <Allocation type> → Display.

The FI-SL: Display <Allocation Type>: Initial Screen appears.

Procedure

1. Make the following entries:
   - Ledger name
   - Name of allocation cycle

   Allocation cycles with the same name must have different starting dates. When allocation cycles have the same name, but different starting dates, the system views them as independent objects.
   - Start date of the allocation cycle

   The start date of the cycle is used for the following control reasons: The start date determines the earliest validity time of the cycle and you can define various versions for a cycle using different start dates. Allocations are only possible with a cycle valid in the posting period.

2. Choose . The FI-SL: Display <Allocation Type>: Header Data screen appears.

3. The system displays the following allocation cycle header data:
   - The system displays whether the allocation cycle is processed iteratively or cumulatively. For more information, see Iterative Processing of Allocation Cycles [Page 48] and Cumulative Processing of Allocation Cycles.
   - The system displays whether quantities or transaction currencies are taken into account.
   - The system displays the defaulted selection criteria.

You can use the following additional functions on this screen:

- To display the segment overview of the segments contained within the cycle, choose .
- To search for segments that match your requirements, select .
- To display the first segment for the cycle, choose First segment.
Displaying Allocation Cycles

- To check whether all relevant entries have been made, choose \( \text{View} \). Here, you can analyze the messages.

- To run cycles of an allocation type in parallel (assuming objects do not overlap) choose \text{Goto} \( \rightarrow \text{Cycle run group} \).

- To display change and execution history of the cycle, choose \text{Extras} \( \rightarrow \text{History} \).
Changing Allocation Cycles

Prerequisites

You created a cycle. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation → <Allocation type> → Change.

The FI-SL: Display <Allocation Type>: Initial Screen appears.

Procedure

1. Make the following entries:
   - Ledger name
   - Name of allocation cycle

      Allocation cycles with the same name must have different starting dates. When allocation cycles have the same name, but different starting dates, the system views them as independent objects.

   - Start date of the allocation cycle

      The start date of the cycle is used for the following control reasons: The start date determines the earliest validity time of the cycle and you can define various versions for a cycle using different start dates. Allocations are only possible with a cycle valid in the posting period.

2. Choose . The FI-SL: Change <Allocation Type>: Header Data screen appears.

3. You can change the header data of the allocation cycle:
   - Iterative Processing of Allocation Cycles [Page 48]
   - Cumulative Processing of Allocation Cycles [Page 46]
   - Consider amounts or transaction currencies
   - Change selection criteria

You can use the following additional functions on this screen:

   - To display the segment overview of the segments contained within the cycle, choose .

   - To search for segments that match your requirements, select .

   - To display the first segment for the cycle, choose First segment.

   - To add a segment to the cycle, choose Attach segment.

   - To check whether all relevant entries have been made, choose . Here, you can analyze the messages.

   - To run cycles of an allocation type in parallel (assuming objects do not overlap) choose Goto → Cycle run group.
Changing Allocation Cycles

- To display change and execution history of the cycle, choose *Extras → History.*
Deleting Allocation Cycles

Prerequisites
You created a cycle. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation → <Allocation type> → Delete.

The FI-SL: Delete <Allocation Type> :Initial Screen appears.

Procedure
2. Make the following entries:
   – Ledger name
   – Name of allocation cycle

   Allocation cycles with the same name must have different starting dates. When allocation cycles have the same name, but different starting dates, the system views them as independent objects.

   – Start date of the allocation cycle

   The start date of the cycle is used for the following control reasons: The start date determines the earliest validity time of the cycle and you can define various versions for a cycle using different start dates. Allocations are only possible with a cycle valid in the posting period.

3. Choose Yes. The system displays the Delete Cycle dialog box.

   You cannot restore a cycle once it has been deleted.

3. To delete the cycle, choose Yes.

Result
The system displays a message stating that the cycle has been deleted.
Executing Allocation Cycles

Use
You can execute the allocation cycle in two different ways:

- In online mode. Executing an Allocation Cycle Online [Page 70]
- In batch mode. Defining an Allocation Job for Background Processing [Page 72]

Line item records are always written to the database when an allocation cycle is executed.

Prerequisites
You created an allocation cycle. For more information, see Creating Allocation Cycles [Page 42]
You selected Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation and then chose Actual/Plan Assessment or Actual/Plan Distribution → Create.

You can, though, also reach the screen for execution of allocation cycles this way:

- **Actual posting** → Actual closing → Actual assessment or Actual distribution → Create.
- **Planning** → Plan closing → Plan assessment or Plan distribution → Create.

The system displays the **FI-SL: Execute <Allocation Type>: Initial Screen**.

Features

a) **Process control**
With **Process control**, you can determine how the allocation cycle is carried out and which information is displayed by the system:

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process control → Background processing</td>
<td>Processing runs in the background.</td>
</tr>
<tr>
<td>Process control → Test run</td>
<td>The system only generates a log. No data is changed, no new data is written to the database.</td>
</tr>
<tr>
<td>Process control → Detail lists</td>
<td>List selection is prepared.</td>
</tr>
<tr>
<td>Process control → Detail lists → List selection</td>
<td>Basic list is configured. The sender and receiver list information and the journal information can be displayed.</td>
</tr>
</tbody>
</table>

b) **Settings**
You can use Settings to determine the functions that the system takes into consideration during execution. For more information, see Settings for Execution of Cycles [Page 73].

c) Goto

Use Goto to display previous processing. For more information, see Displaying Previous Processing [Page 90]. You can check whether an allocation cycle has already been processed for a ledger within a specific period.

d) Extras

- You can make currency settings. Select Extras → Value date, and enter the key that you use to define exchange rates in the system.
- You can determine the cumulation start period.

![Tip]

This value specifies from which period the values are added up to calculate the tracing factors and the values to be allocated in the current processing period. Normally this is period 1. With the special purpose ledgers, the start period can also be zero.

- You can get/save/delete variants.
- You can display a cycle overview.

![Tip]

You can get an overview of the current status of allocation execution with Selection criteria, cycle information, and previous processing.

- You can process allocation cycles.
- You can assign cycles to groups.

![Tip]

To execute cycles of an allocation type in parallel, these have to be assigned to various cycle run groups.

e) Execute

After you have entered all relevant data and have made all appropriate settings, choose Execute.

The Display <Allocation Type>: Basic List screen appears. Use the basic list to check the processing results.

![Tip]

For more information, see Displaying Allocation Results [Page 77].
Executing an Allocation Cycle Online

Prerequisites

The system displays the *FI-SL: Execute <Allocation Type>: Initial Screen*. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation and then chose Actual/Plan Assessment or Actual/Plan Distribution → Create.

To assess/distribute data records, the company code or company has to be assigned to the ledger.

Procedure

1. Enter the Ledger and the relevant Parameters.
2. Under Process control, you have the following options:
   a. Set the Background processing indicator if you want to execute the allocation in background processing. For more information, see Defining an Allocation Job for Background Processing [Page 72].
   b. Set the Test run indicator if you want to test the allocation.
      - The allocation does not update the database.
   c. Set the Detailed lists indicator if you want to display a list of assessed/distributed records after the allocation is executed.
      - Choose List selection. The system displays a dialog box. The Basic list is defaulted.
      - In addition, there are three detail lists that you can select. For more information, see Displaying Sender Lists [Page 85], Displaying Receiver Lists [Page 86], and Displaying Journals [Page 87]. You choose the list you require by selecting the appropriate indicator.
3. Enter relevant data for Cycle and Start date of the allocation, or choose input help. You can execute more than one cycle per execution.
   - The order you execute the cycles impacts how the data is allocated.
   - Receivers of allocation cycle 1 are cost centers 200 and 300. Receivers of allocation cycle 3 are cost centers 300, 400, and 500. The allocation cycle 3 uses the results of allocation cycle 1 if a group of cycles is executed.
If you are executing a cycle that has the same name as another allocation cycle, the system displays all allocation cycles that have the same name, with the cycle starting dates.

2. You can determine how the system is to react when it encounters errors during execution by choosing Settings.

3. You can save the entries you make on the initial screen as a variant. To do so, choose Extras → Variant → Save and enter a name and a short text for the variant.

   To execute a particular variant, choose Extras → Variant → Get.

4. Choose 📣. The system displays the Fi-SL: Display <Allocation Type> Special Purpose Ledger Basic List screen. You can display all relevant information here.

   For more information, see Displaying Allocation Results [Page 77].
Defining an Allocation Job for Background Processing

Use
You can run processing in the background so as not to place demands on the system in times of high load.

Prerequisites
The system displays the **FI-SL: Execute <Allocation Type>: Initial Screen.**

Procedure
1. Enter data on the initial screen.
2. Under *Process control*, select the *Background processing* indicator.
3. Choose 🎉.
4. Enter the relevant print parameters.
5. Choose *Continue*.
6. The system displays a dialog box. Enter the job name in which the allocation cycles should be included and enter appropriate settings.
7. Choose 🎉.

Result
The system displays confirmation that the job has been scheduled.

💡
For more information on how to define and execute a background job, see *Working with R/3 → Getting Started with R/3* documentation in the SAP Library.
Settings for Execution of Cycles

Use

Select Settings to make technical settings.

Prerequisites

You have created an allocation cycle and are on the Fi-SL: Execute <Allocation Type> : Initial Screen. To be able to carry out the appropriate settings, you have to have entered (or selected) the ledger, the parameters, and the flow control.

Features

Display variant

You use this indicator to control how the results list is compiled. The following information is stored in a display variant:

- Column layout of the list
- Sort criteria
- Filter conditions

Database selection

You use this indicator to control how database access is to occur, in other words, how the data is selected from the database during allocation execution. The selected setting is only valid for the current cycle execution. However, you can save it as a variant. To save your settings permanently, choose . The following database selection methods are available:

Selection by cycle

For each dimension used in the cycle, the system determines the smallest and greatest value for this dimension in the entire cycle and uses this value interval as the basis for the database selection.

Advantage: Database is accessed exactly once.

Disadvantage: There is the risk that too many objects are selected. You have to eliminate the excess afterwards. The number of segments should not exceed 50.

Selection by segment

For each dimension used in the segment, the system determines the smallest and greatest value for this dimension in the entire segment and uses this value interval as the basis for the database selection.

Advantage: Performance is good, as database selection with number of segments is virtually linear and no longer exponential.

Disadvantage: Occasionally, the hit list is rather high.

Save extract

You can use this indicator to specify that reports are saved in extracts. The results lists are stored on the database after cycle execution (background processing/online). Enter a name for
Settings for Execution of Cycles

the extract. The system will propose this name again if you wish to view the results lists via Goto → Extract management.

Flow trace on

You can use this indicator to define how data is selected from the database during the allocation execution. During execution of a cycle, the system logs all data relevant to error processing. You should activate this indicator if a cycle terminates with an error message or supplies erroneous results. It easier to identify errors when you are able to refer to runtime log data. You can call up this data in the system via the "Technical statistics" function. If you use background processing to process your cycle, the system generates a separate spool request that you are able to print out.

Runtime analysis on

You use this indicator to specify that runtimes of the various sections (database selection, iteration, and so on) are saved. If errors occurred during processing, you can display the runtime analysis for cycles and steps. You can then display this information on the Execution Screen via Goto → Runtime analysis. To save your settings permanently, choose .

Technical settings

You can specify the way that the system reacts when errors occur.

Exit program

The subsequent cycles displayed on the initial screen of the allocation are not processed, the program terminates.

You should set this indicator if the cycles build on each other and subsequent errors are to be expected.

Change to simulation mode

The subsequent cycles displayed on the allocation initial screen are processed. (“Change to simulation mode”).

You should set this indicator if cycles do not build upon each other and you wish to output all possible error sources in a program run for the defined allocation.
Reversing Allocation Cycles

Use
You should reverse an allocation cycle when:

- You have executed an allocation cycle in error (for example, if you execute an allocation cycle on the wrong date).
- You have executed an allocation cycle that contains errors (for example, if you execute an allocation cycle that contains a segment that uses the wrong dimension).

Procedure
You reverse allocations using the Execute function.

1. On the Execute <Allocation Type>: Initial Screen, enter data as required.
2. Choose <Allocation Type> → Reverse.
   
   The allocation cycle(s) has been reversed. The Display <Allocation Type>: Basic List screen appears.
3. On this screen, you can use the additional functions in the table for the Display <Allocation Type> Basic List in Executing an Allocation Cycle Online [Page 70].

You can also reverse allocation cycles in background processing. For more information, see Defining an Allocation Job for Background Processing [Page 72].
Deleting Allocation Line Items

Use
You can delete allocation line items that you no longer require in your system. You delete the line items per allocation cycle. You should delete allocation line items when:

- You have executed and subsequently reversed an allocation cycle. You can then delete the line items from the allocation runs that have been reversed.

- You want to create memory space on your database. The repeated execution and reversal of allocation cycles can take up considerable memory space. It is therefore recommended that you periodically delete the allocation line items that you no longer require.

Prerequisites
Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic processing → Allocation → Delete line items.
The Allocation: Delete Line Items No Longer Needed screen appears.

Procedure
1. Make the following entries:
   - Ledger name of the allocation cycle(s)
   - Name of the allocation cycle for which you want to delete the allocation line items.
   - Name of a second allocation cycle if you want to delete line items for a range of allocation cycles.

2. Select Test run if you want to perform a test run of the deletion program.
   The allocation line items are not deleted from the database.

3. Choose Program → Execute.

Result
The system deletes the line items for the allocation cycle(s) you entered on the previous screen.
If you set the Test run indicator, the system displays a list of allocation cycles for which you can delete line items.
Displaying Allocation Results

Use

After the allocation is carried out, a basic list is output, that permits you to control and verify processing. The basic list specifies the number of senders, receivers, and messages for each allocation cycle that is executed.

Prerequisites

You have carried out an allocation.

Features

a) You are able to display the current status of allocation processing. For more information, see Displaying Cycle Overviews [Page 79].

b) You can find out whether (and how many) errors occurred during cycle processing. For more information, see Displaying Messages [Page 81].

You set as default the Runtime analysis on the initial screen under Settings.

c) From the line items, you can branch into the sender and receiver-side generated plan and actual line items. For more information, see Displaying Line Items [Page 83].

d) You can also display a Segment list for each segment. For more information, see Displaying Segment Lists [Page 84].

e) You can display sender lists, receiver lists, and journals. For more information, see Displaying Sender Lists [Page 85], Displaying Receiver Lists [Page 86], or Displaying Journals [Page 87].

You can display sender lists, receiver lists, and journals. For more information, see Displaying Sender Lists [Page 85], Displaying Receiver Lists [Page 86], or Displaying Journals [Page 87].

On the initial screen, under Detail list settings, you set the appropriate indicator.

f) You can display Technical Statistics, Expert Trace, and Divergence Analysis [Page 88].

On the initial screen, under, you set the appropriate indicator. You can only display divergence analysis with iteratively processed cycles.

g) You can display previous processing for the combination ledger, fiscal year, and period. For more information, see Displaying Previous Processing [Page 90].

Activities

You can print out the following lists:

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>List → Print → Trace</td>
<td>Print contents of individual database fields of a particular cycle.</td>
</tr>
</tbody>
</table>
Deleting Allocation Line Items

<table>
<thead>
<tr>
<th><strong>List → Print → Journal</strong></th>
<th>Print overview of the receivers, senders and corresponding values existing in a segment.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>List → Print → Results lists</strong></td>
<td>Print results of all cycles.</td>
</tr>
<tr>
<td><strong>List → Print → Individual list</strong></td>
<td>Print a particular cycle.</td>
</tr>
</tbody>
</table>
Displaying Cycle Overviews

Use
You can display all relevant information pertaining to previous allocation cycles on one overview screen. You can select allocation cycles, choose cycle information, or previous processing, according to certain criteria on three tab pages.

Prerequisites
You have carried out several cycles and are on the Fi-SL: Execute <Allocation Type>: Initial Screen.

Procedure
1. Choose Extras → Cycle → Display overview.
2. The system displays the Set Ledger dialog box. Enter the ledger name.
3. The system shows the Display Cycle Overview screen.

Selection Criteria
5. Choose Execute selection. The system displays the allocation cycles that meet your criteria in the structure tree.

To delete the selection criteria again, select Delete entries.

Cycle information
To display cycle information, you entered the desired allocation cycles under Additional selection criteria on the tab page under Selection criteria. You can display general information on the allocation cycle or process the allocation cycle from here. You can choose between sender and receiver information.

Previous processing
You can display executed or reversed allocation cycles as well as cycles with segment reversal.

For more information, see Displaying Allocation Results [Page 77].
Displaying Standard Settings

**Prerequisites**
You have executed one or more cycles and are in one of the following result lists:

- Basic list
- Segment list
- Sender list
- Receiver list

You can return to the standard list settings if you have:

a) Entered your own display variant
b) Additionally created totals or subtotals
c) Hidden totals or subtotals

**Procedure**
To return to the standard list settings, choose **Settings → Standard settings.**
Displaying Messages

Use
You can display messages to help analyze errors that occurred during the allocation run. If you wish, you can restrict the display of messages to one cycle or one segment.

Prerequisites
Errors occurred during the allocation run. The system displays the errors in one of the following lists.

- **Basic list**
  The system displays the total number of errors in the *Number of messages* column of the *Basic list*, as well as in the basic list header. The system also displays an error message in the basic list header data.

- **Segment list**
  The system displays the number of messages for the errors that occurred in the allocation cycle in the corresponding segment list header data.

- **Sender list/receiver list**
  The number of messages for errors that occurred in a segment is displayed in the corresponding sender or receiver list header data.

Procedure

**Display all messages** as follows:
- Click on the number of errors in the *Disp messages* row of the basic list header data.
- From one of the other lists, choose Goto → Messages → Selection.

**Display all messages of a cycle** as follows:
- Click on the number of errors in the *Disp messages* row of the basic list header data.
- In the segment list, choose Goto → Messages → Selection.
- Position your cursor in the basic list on the cycle and choose Goto → Messages → Select.

**Display all messages of a segment** as follows:
- In sender or receiver list header data, select the *No. of errors*.
- In the sender or receiver list, choose Goto → Messages → Selection.

1. The system displays a dialog box for display of messages.
2. To display more information on an error, either select the message by double-clicking it, or position your cursor on the message and choose .
3. Choose to leave the dialog box.
Displaying Messages

**Result**

You can analyze errors. You can redefine the cycles in accordance with the message and then execute the allocation again.

💡

If the message analysis is not sufficient, repeat the allocation and create a runtime log. To do this, select *Runtime log* in the dialog box via *Settings.*
Displaying Line Items

Prerequisites
You are displaying one of the following results lists:
- Basic list
- Segment list
- Sender list
- Receiver list

Procedure
1. To branch to the line item display with sender- and receiver-side generated plan or actual line items, position your cursor:
   - In the basic list on an allocation cycle
   - In the segment list on a segment
   - In the sender list on a sender
   - In the receiver list on a receiver
2. Select or double-click on the appropriate line.

Result
The system displays the Ledger <Ledger Name> Display of All Data Records and Key ... screen.

Here, you can continue to process the line items.
Displaying Segment Lists

Prerequisites

You are on the FI-SL: Display <Allocation Type>: Special Purpose Ledger screen.

- Basic list
- Sender list
- Receiver list

Procedure

1. To display the segment list, position your cursor:
   - In the basic list on an allocation cycle
   - In the sender list on a sender
   - In the receiver list on a receiver

2. Choose Segment.

   The segment list displays the segments for the selected cycle, sender, or receiver.

   The system displays the following information on a segment:
   - g lock indicator (segment not included in processing)
   - U invalid indicator (an error arose during processing)
   - Sender rules and receiver rules
   - Number of senders and receivers
   - Number of messages

3. To hide fields, choose Current display variant.

4. From the segment list, you can (per segment) branch to the:
   - Basic list
   - Sender list
   - Receiver list
   - Line items

   For more information, see Displaying Allocation Results [Page 77].
Displaying Sender Lists

Prerequisites
On the initial screen in *List selection*, you selected *Sender and Receiver*.

Procedure
You can call up the sender list from the basic list, segment list, or receiver list.

1. To display the sender list, position your cursor:
   - In the basic list on an allocation cycle
   - In the segment list on a segment
   - In the receiver list on a sender

2. Choose 📃 Sender.
   The sender list displays the senders for the selected cycle or segment. The system displays the following information on a sender:
   - The *invalid* indicator (an error arose during processing)
   - The posted amounts

3. To display the amounts in object currency or the sender base, choose 📃 *Current display variant*.

4. From the sender list, you can (per sender) branch to the following lists: Choose:
   - Basic list
   - 📃 Segments
   - 📃 Receiver
   - 📃 Line items

For more information, see *Displaying Allocation Results [Page 77]*.
Displaying Receiver Lists

Prerequisites
On the initial screen in List selection, you selected Sender and Receiver.

Procedure
You can call up the sender list from the basic list, segment list, or receiver list.

1. To display the receiver list position your cursor:
   - In the basic list on an allocation cycle
   - In the segment list on a segment
   - In the sender list on a sender

2. Choose 📊.
   The receiver list displays the receivers for the selected cycle, segment or sender. The system displays the following information on a receiver:
   - The invalid indicator (an error arose during processing)
   - The posted amounts

3. To display the amounts in object currency, or the receiver tracing factor and the receiver weighting factor, choose 📊 Current display variant.

4. From the receiver list, you can (per sender) branch to the following lists. Choose:
   - Basic list
   - 📊 Segments
   - 📊 Line items

For more information, see Displaying Allocation Results [Page 77].
Displaying Journals

Use
The journal offers you an overview of the receivers, senders and corresponding values existing in a segment.

The journal is especially suited for the analysis of allocated values for iterative segment processing.

Prerequisites
To display the journal, you must first select Journal on the initial screen (under List selection).

You can only call up the journal from the basic list.

Procedure
1. To display the journal, choose Journal in the basic list.
   For all segments in the cycle, the journal displays:
   - The determined sender values
   - The allocated sender values
   - The allocated receiver values
2. To display the amounts in object currency, the sender or receiver tracing factor, choose Current display variant.
3. To return to the basic list, choose Basic list.

For more information, see Displaying Allocation Results [Page 77].
Technical Statistics, Expert Trace, and Divergence Analysis

Use

If errors have occurred during processing of the allocation cycle, the technical statistics, expert trace and divergence analysis let you analyze those errors that you cannot solve using the system messages.

The technical statistics and the divergence analysis enable user analysis. The expert trace requires analysis by experts.

Prerequisites

Before you executed the cycle, you selected Flow trace on in the dialog box via Settings.

In addition, divergence analysis requires that:

a) You use a cycle with iterative sender/receiver relationships
b) These relationships are taken into account when you execute the cycle
c) An error occurred that led to a divergence

Procedure

Displaying Technical Statistics

1. To execute an error analysis using technical statistics, in the periodic allocation basic list choose (Technical statistics) or Tools → Technical statistics. The system displays all relevant information in a tree structure (trace function).

2. The following functions let you change the tree structure display:

   a) Expand
      To expand the tree structure or a subtree, position your cursor on the appropriate node and choose Expand.

   b) Collapse
      To collapse the tree structure or a subtree, position your cursor on the appropriate node and choose Collapse.

   c) Position...
      To reach a particular point in the tree structure, position your cursor on the appropriate node and choose Position.

   d) Set focus
      To display only a subtree, position your cursor on the appropriate node and choose Set focus. To display the higher subtrees once again, click on the cycle named in the first row.
Displaying the Expert Trace

1. To display the expert trace, choose Tools → Expert trace.

2. The Display <Allocation Type>: Special Purpose Ledger Trace Function screen appears.

3. Choose the required information.

4. Position the cursor on the cycle for which you require information.

5. Select to view information on the contents of the individual database fields.

6. To return to the basic list, choose Basic list.

Displaying Divergence Analysis

To analyze divergences occurring for cycles with iterative sender/receiver relationships, choose Tools → Divergence analysis.

For more information, see Displaying Allocation Results [Page 77].
Displaying Previous Processing

Use
You can display an overview of processed allocation cycles for a certain combination of ledger, fiscal year, and period. This function is helpful when you want to see if an allocation cycle has already been processed for a particular ledger within a specific period and fiscal year.

Prerequisites
The system displays the FI-SL: Execute <Allocation Type>: Initial Screen.

Procedure
1. Choose Goto → Previous processing.
2. The <Allocation Type> Overview: Initial Screen appears.
3. Enter data as required.
4. Choose .
5. The system displays the <Allocation Type> Overview: Basic List screen.

Result
The system displays a list of processed allocation cycles. To display the document list, choose .

For more information, see Displaying Allocation Results [Page 77].
Printing Detail Lists

Use

- You can print individual lists from the following lists:
  - Basic list
  - Segment list
  - Sender list
  - Receiver list
  - Journal list

- You can only print results lists from the basic list. The results lists contain:
  - Basic list
  - All segment lists
  - All sender lists for all periods
  - All receiver lists for all periods

Prerequisites

If you selected Journal under List selection on the initial screen, you can also print the journal from the basic list. For more information, see Displaying Journals [Page 87].

On the initial screen, if you selected Flow trace on you can also print the expert trace from the basic list. For more information, see Technical Statistics, Expert Trace, and Divergence Analysis [Page 88].

Procedure

1. To print the relevant list, choose:
   - List → Print trace
   - List → Print journal
   - List → Print results list
   - List → Print individual list

2. Choose User-specific print parameters and enter the appropriate data.

3. Choose Continue.

Result

The system confirms that printing was carried out.
Flexible General Ledger (FI-GL)

Rollup

**Rollup**

**Use**

In the Flexible General Ledger, you can summarize data for the purpose of higher efficiency when reporting. Since the general ledger contains information that is irrelevant to certain reports, you can summarize this information in a rollup ledger. When creating reports using rollup ledgers, you have an improved processing time when compared to creating reports in the general ledger.

**Prerequisites**

You have made the Customizing settings for rollup ledgers in the Flexible General Ledger Implementation Guide.

**Activities**

To carry out a rollup, choose *Periodic processing → Rollup* from the flexible general ledger menu.

The procedure for rollups corresponds to the allocation procedure in the application component Special Purpose Ledger (FI-SL). The following is thus a description of the rollup function as found in the “FI Special Purpose Ledger” documentation. Different than rollups in the Special Purpose Ledger, no distinction is made in the Flexible General Ledger between local ledgers and global ledgers. There are only local ledgers in the Flexible General Ledger.

The Flexible General Ledger is also different from the Special Purpose Ledger in the following ways:

- Only financial accounting document types are valid.
- Only one table (GLFLEXT) is used.
- For the field use, other table fields play a role.
Rollup

Purpose

A rollup [Ext.] is used to determine how data is "rolled up" (i.e. summarized) from several source ledgers into a single rollup ledger. Since you can use several different ledgers in FI-SL, you can have different levels of detail and/or different dimensions. Some ledgers may contain too much detailed information or irrelevant dimensions for some cumulative reports; you can summarize this information in a rollup ledger.

Implementation Considerations

If you only want to run a report once, it is more efficient for the Report Writer to summarize the data. However, if you must select the same data for your report more than once, the report data should be summarized in a rollup ledger. You can use rollup ledgers to improve system performance when you are creating reports.

Integration

With the rollup, you can process data both from other SAP application components as well as from external systems. A rollup ledger is the summarization of information from one or more ledgers (source ledgers) into a single ledger. The following graphic shows the data from several source ledgers being summarized in one rollup ledger.

To summarize data in a rollup ledger, you have to define a rollup. Before you can create a rollup, you must first define a ledger as a rollup ledger. In Customizing for Special Purpose Ledger, you...
Rollup

activate the Rollup allowed indicator in the ledger definition to define whether you can rollup data into the ledger. For more information about defining ledgers and ledger classes, see the Implementation Guide (IMG) under Special Ledger → Basic Settings → Master Data → Maintain Ledger.

Features

You can use sets in rollups [Page 96].

With field movement [Page 99], you can define which fields are to be transferred from a sender table to an FI-SL receiver table.

You can also define whether a rollup should update the line item database [Page 102].

By defining the rollup type [Page 103], you define how the data is to be summarized.

You can use user exits [Page 105] to call up other programs.

Using Application Link Enabling (ALE) and IDoc, you can transfer FI-SL ledger data across separate SAP systems [Page 106].

You can drill down to data in rollup line items [Page 108] in the source ledger.

When you create a rollup [Page 114] (rollup header and rollup sequence), you define how data is to be selected from the sender table, summarized in the rollup and posted to the receiver table. For more information, see:

- Creating a Rollup Header for a Standard Rollup [Page 115]
- Creating a Rollup Header for a Hierarchy Rollup [Page 115]
- Creating a Rollup Header for an Export Rollup [Page 115]
- Creating a Rollup Sequence [Page 125]

You can check [Page 132], document [Page 133], display [Page 134], change [Page 143] and reverse [Page 136] and execute [Page 138] the rollup. You can also execute a rollup in the background [Page 135].

Example

If you want to create a report that only uses account data from a source ledger containing 100 different accounts and 100 different cost centers for each account, the system has to read at least 10,000 totals records (100 accounts * 100 cost centers). This report would take an extremely long time to process. To improve system performance, you can summarize the account data from the source ledger(s) into a rollup ledger that contains only 100 totals records (one totals record for each account). The rollup summarizes the cost center values for each account into one totals record for all cost centers.
To roll up data into FI-LC, the companies into which data is rolled must have the data transfer indicator O (rollup from FI-SL; you set this indicator in FI-LC Customizing). For more information about setting these parameters in Customizing, see the Implementation Guide for Special Purpose Ledger.
Sets and Rollups

Use

You have the option of using sets [Ext.] in rollups. These select data for a rollup ledger, to rollup data based on a hierarchical set definition, and to select data to be reset to zero. You can use the following types of sets:

- Basic sets
- Single dimension sets
- Multi-dimension sets

You can use sets in the following rollup components:

- Rollup header, as rollup sets or reset sets
- Rollup sequences, as rollup sequence sets

You can also use value variables in your rollup header, sequence, and reset sets, as well as set variables in your rollup sets.

When you use a set variable and/or value variable in a rollup, the system will prompt you to enter information for the variable when you execute the rollup.

Features

Rollup Sets

The rollup set values apply to all sequences within the rollup.

A rollup header set is always a multi-dimension set and must contain the following dimensions:

- Ledger
- Record type
- Version
- Company code or company (local or global)

You cannot use the following dimensions in your rollup header set:

- Client
- Period
- Year

Your multi-dimension header set can include basic and/or single-dimension sets.
You can define a multi-dimension set that contains the following values:

- Ledger 01 (dimension Ledger)
- Record Type 0 (dimension Record Type)
- Version 001 (dimension Version)
- Companies 1000 and 1001 (dimension Company)
- Fixed Asset Accounts 500000-501000 (dimension Account)

You can enter the name of the multi-dimension reset set in the rollup header. When the system processes the rollup, fixed asset accounts 500000-501000 for ledger 01, record type 0, version 001, and companies 1000 and 1001 will be rolled up according to the field movement information you enter for the rollup.

If you want to create a hierarchical rollup, you include your cost center and/or business area hierarchy in the rollup header set (single-dimension set).

For more information, see Types of Rollups [Page 103].

**Rollup Sequence Sets**

A rollup sequence set can be defined per sequence. The values you define in a rollup sequence set determine which data for a specific sequence will be rolled up.

The rollup header set determines the data that is selected for all sequences, and the rollup sequence set further defines the data to be selected for the specific rollup sequence. You can create a basic set that contains only the fixed asset accounts 500000-500020 (dimension Account). You can then enter the set name in the rollup sequence and enter a specific field movement and substitution activity for the sequence. In this case, the system will roll up accounts 500000-500020 only for ledger 01, record type 0, version 001, and companies 1000 and 1001 in the appropriate sequence according to the field movement information you enter for the rollup.

**Reset Sets**

A reset set is used to select data fields from a rollup ledger and reset the data fields to zero before the rollup is executed.

A rollup reset set is a multi-dimension set and must contain the following dimensions:

- Ledger
- Record type
- Version
- Company code or company (local or global)
Features

You cannot use the following dimensions in your rollup reset set:

- Client
- Period
- Year

Your multi-dimension reset set can include basic and/or single-dimension sets.

You can define a multi-dimension set that contains the following values:

- Ledger 01 (dimension Ledger)
- Record Type 0 (dimension Record Type)
- Version 001 (dimension Version)
- Companies 1000 and 1001 (dimension Company)
- Fixed Asset Accounts 500000-501000 (dimension Account)

You can enter the name of the multi-dimension reset set in the rollup header. When the system processes the rollup, the data records for fixed asset accounts 500000-501000 for ledger 01, record type 0, version 001, and companies 1000 and 1001 will be reset to zero before the rollup is executed.

You can find more information on creating sets under Creating Sets [Ext.].
Field Movements and Rollups

Use

Field movement [Page 99] defines which fields are to be transferred from a sender table to an FI-SL receiver table. There are two types of field movement:

Fixed field movement

When you execute a rollup, the data from the following dimensions is automatically transferred from the source ledger(s) into the dimensions in the rollup ledger:

- Ledger
- Record type
- Version
- Company code or company (local or global)
- Transaction currency (depending on the rollup ledger definition)
- Unit of measure (depending on the rollup ledger definition)
- Debit/credit indicator (depending on the rollup ledger definition)

The data in dimensions Year and Period is determined by the period definition of the rollup ledger.

For further information, see Customizing, under Special Ledger → Basic Settings → Maintain Fixed Field Movement.

Variable Field Movement

If you want to include other dimensions in your rollup ledger, such as account, cost center or business area, you have to define a field movement for these dimensions.

For further information, see the Implementation Guide (IMG), under Special Ledger → Basic Settings → Master Date → Maintain Field Movement.

The following fields are defined in field movement

- **Sender fields**: Dimensions in the source ledger(s).
- **Receiver fields**: Dimensions in the rollup ledger.

The following graphic shows a simple field movement example. The dimensions Account, Cost Center, and Business Area are transferred from the source ledger to the rollup ledger.
Field Movements and Rollups

Field movement rule: WXYZ

<table>
<thead>
<tr>
<th>Dimension</th>
<th>From field (table)</th>
<th>To field (table)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>RACCT (GLT1)</td>
<td>RACCT (GLT1)</td>
</tr>
<tr>
<td>Cost center</td>
<td>RCNTR (GLT1)</td>
<td>RCNTR (GLT1)</td>
</tr>
<tr>
<td>Bus.area</td>
<td>RBUSA (GLT1)</td>
<td>RBUSA (GLT1)</td>
</tr>
</tbody>
</table>

In this example, the data from the dimensions Account, Cost Center, and Business Area, is transferred to the rollup ledger according to field movement rule WXYZ.

When field movements are not defined for dimensions, the data for those dimensions is summarized within the dimensions that have defined field movements but the dimensions themselves are not transferred to the rollup ledger.

If you selected data for the dimensions Cost Center and Account, but you have only defined a field movement for the dimension Account, then the data for the selected cost centers is summarized and included in the data for the dimension Account.

Field Movement Rule

Using the field movement rule, you define how dimensions are taken over into the rollup ledger.

If you want to take over all of your data on a one-to-one basis, you must define all of your dimensions in the rollup field movement.

When you define your field movements, you can also define a field movement so that a dimension from the sender table is transferred to a receiver dimension in the line item database, even though the dimension does not exist in the receiver summary table.

You define a field movement as follows:

- **Sender**: Table GLT1, Dimension Account
- **Receiver**: Table GLT1, Dimension Original Account

The dimension Original Account does not exist in the summary table GLT1; however, the dimension could be defined in the data part of the line item database GLS1 that corresponds to the summary table GLT1. In this case, the dimension Account would be transferred to the dimension Original Account only in table GLS1.

For more information about creating field movements in Customizing, see the *Maintain Field Movement*. 
Field Movements and Substitution Activities

You can assign a substitution activity [Ext] to each field movement.

When defining a field grouping code for a rollup, you can assign a substitution activity code to a field movement. A substitution activity code identifies a substitution activity; a substitution activity transfers substituted data to receiver dimensions during the rollup process.

If you want to summarize a group of products under a product group, you can define a substitution activity that substitutes the product group for the products during the rollup process. You enter the substitution activity code for the substitution activity in the field movement.

If you are using substitution rules, you can define more than one substitution value for a substitution activity.

For more information, see Entering Substitution Activities [Page 129] and the Implementation Guide (IMG) under Special Ledger → Basic Settings → Substitution.
Line Item Database and Rollups

Use

You can also define whether a rollup should update the line item database. If a rollup updates the line item database, a line item is written for each record that is rolled up.

When line items have been written to the line item database for a rollup, you can reverse the rollup.

Using rollup line items, you can also drill down from the summary rollup data to the original data stored in the source ledger.

In the following steps, you can define whether a rollup should update the line item database.

Creating a Rollup Header [Page 115]
Execute Rollup [Page 138]

The line item update information you entered in the rollup header is proposed as a default when you execute a rollup.

If line items are not created, you cannot reverse the rollup.

If you do not plan to reverse the rollup (or if you are rolling up large quantities of data), you should leave the Write line items indicator blank to avoid unnecessary database updates. Line item updates are only useful in exceptional cases and slow down processing dramatically. For the reasons listed below, line item updates are not normally necessary:

- They can overwrite existing data
- They can reset data

For more information, see Creating a Standard Rollup Header [Page 115] and Drilling Down to Rollup Line Items [Page 108].

To post line item data for rollups, you must install a line item database for your 1) actual rollup data, and 2) plan rollup data. For more information about installing line item databases, see the Implementation Guide (IMG) for Special Ledger.
Types of Rollups

Use

By defining the rollup type, you define how the data is to be summarized. You can choose between the following rollup types:

- Standard Rollup
- Hierarchical Rollup
- Export Rollup

Standard Rollup

In a standard rollup, you rollup data from one or more sender ledgers into one or more rollup ledgers, using one or more rollup sequences. To do this, you proceed as follows:

1. Leave fields blank in field movement
2. Substitute certain fields

Hierarchical Rollup

With a hierarchical rollup, you can summarize data from bottom to top from a source ledger, in accordance with a hierarchy structure of your choosing (such as a cost center hierarchy). In a hierarchical rollup, you rollup data according to the structure of the single-dimension set defined in your rollup header set.

Export Rollup

An export rollup is used to transfer data from local systems to a central system. You can transfer data in either unsummarized or summarized form (using field movement) and update it in the central system.

Special Periods

You can also roll up data for special periods (for example, 13 through 16) when you execute and/or reverse a rollup. For further information, see Special Periods and Rollup [Page 104].
Special Periods and Rollups

Use
You have the option of summarizing data for special periods (such as 13 to 16). If you set this flag, the system will roll up or delete all existing special periods for the fiscal years defined by the execution period.

Procedure
2. Enter the special periods (From period field, To period field) which you want to be used when executing/reversing the rollup.
3. Choose .

Result
The Execute Rollup: Statistics screen appears. Here, you can see the statistics for the rollups.

💡 If the fiscal year variants are different in the source ledger(s) and rollup ledger, you cannot rollup/reverse a specific special period(s).

Instead, you can either rollup/reverse all or none of the special periods (Special periods indicator).

For example, source ledger 01 has twelve posting periods and rollup ledger R1 has four posting periods.

For more information about setting the fiscal year variant for a ledger/local company or ledger/global company combination, see the Implementation Guide (IMG) for Special Purpose Ledger.
User Exits and Rollups

Use

A user exit is a three character code that instructs the system to access a program during system processing. You can use the following user exits in rollups:

Exit in rollup header

You enter this user exit in the User exit field on the Create Rollup <Name>: Header screen. The system accesses the user exit after it has filled the internal tables for executing the rollup. At this point, you can process general validations, for example, to check the period interval for the rollup.

Field movement header table, exit 1

You enter this user exit in the User exit after selection field on the Change Field Movement: Data screen. The system uses this exit to further define the conditions for selecting data to be rolled up.

Field movement header table, exit 2

You enter this user exit in the User exit before update field on the Change Field Movement: Data screen. The system accesses the user exit after the receiver records have been completely created. The user exit is only used to process data field substitutions.

Exit in field movements/substitution activities

You enter this user exit in the Exit field on the Change Field Movement: Data screen or the User exit field on the Change View “Rollup Substitution”: Overview screen. (Both exits perform the same function.) This user exit can be used to perform key field substitutions. The system accesses the user exit when the specific dimension is moved from the sender to the receiver.

Enter user exits in the following formats:

SXX:  S is for standard exits that are delivered by SAP. XX represents the 2-digit exit number.

UXX:  U is for user exits that are defined by the user. XX represents the 2-digit exit number.

💡

Standard user exits delivered by SAP are stored in program RGLVS000.

You can define your own user exit programs. If you create a user exit program, this program name must be defined in the table for client-dependent user exits (table T80D) in Customizing. For more information, see the Maintain Client-Dependent User Exits step in the Implementation Guide (IMG) for Special Purpose Ledger.
Using FI-SL on Distributed Systems

Use

Using Application Link Enabling [Ext.] (ALE) and IDoc, you can transfer FI-SL ledger data across separate SAP systems. Using an export rollup, you can distribute ledger data from a local system to a central system.

Advantages of using FI-SL on distributed systems include:

- Ability to export data as often as necessary within a period, since the buffer memory is handled via the export rollup.
- Transferred data volumes are not extensive since only total records are transferred.

The FI-SL database table that you distribute must have the same name and the same basic structure in all systems. However, you can define the table structure in the central system so that it contains fewer fields than in the local systems, because the central system may not need to store all detailed information. Nevertheless, table definitions should not be too different.

Also, the Customizing settings for the ledgers and local or global companies that are to be distributed must be identical to ensure data consistency.

Procedure

To distribute ledger data from a local system to a central system, you:

1. Define a distribution model.
   
   The distribution model determines to which logical system (central system) the ledger data is to be distributed. You define the logical system either at ledger level or at ledger–local company/ledger–global company level. Once the logical system is defined, all local systems are informed that this is the logical system to which they must send their data.

   You define a distribution model in ALE Customizing (Cross-Application Components → Distribution (ALE) → Distribution customer model).

2. Define an error workflow in the central system.

   The error workflow is used to detect and process any errors that occur when the FI-SL data is transferred to the central system.

   You define workflows using the Make basic settings for Workflow step in ALE Customizing (Cross-Application Components → Distribution (ALE) → Basic configuration).

3. Update the field assignment table EDIMAP in the central system.

   The EDIMAP table must be updated in order to export data from a local system to a central system. This table determines the assignment of the field(s) in the FI-SL database table to the field(s) in the data transfer structure (IDoc field).
You update the EDIMAP table using the Update Assignment Table EDIMAP step in FI-SL Customizing (Financial Accounting → Special Purpose Ledger → Tools → Distribution (ALE)).

4. Generate the export and import programs.
   The export and import programs must be generated in both the central system and all local systems.
   You generate these programs using the Generate Import/Export Programs step in FI-SL Customizing (Financial Accounting → Special Purpose Ledger → Tools → Distribution (ALE)).

5. Define an export ledger in the local system(s).
   If the data of a FI-SL ledger is to be sent to a central system, you must assign an export ledger to the FI-SL ledger.
   The export ledger stores the balances of all previous data transfers. If you export data more than once within one period, only the difference amounts from the last data transfer are sent to the central system.
   You define export ledgers using the Maintain Ledgers step in FI-SL Customizing (Financial Accounting → Special Purpose Ledger → Basic Settings → Master Data).

6. Create an export rollup in the local system(s).
   When you create the export rollup, you determine how data should be transferred from the local system to the central system. You can transfer data on a one-to-one basis or summarize data using a user-defined field movement.
   For more information, see Creating a Rollup [Page 114].

7. Execute the export rollup in the local system(s).
   When you execute the rollup, the data is posted to the central system, which is defined in the distribution model, according to the criteria you have defined in the export rollup. You can execute the export rollup as often as you want within a period, since only difference amounts from the last data transfer are exported. The export ledger stores all data amounts that have been transferred.
   For more information, see Executing a Rollup [Page 138].
Carrying out Drill Downs on Rollup Line Items

Use

You have the option of carrying out a drilldown to the rollup line item data in the source ledger. You do this using a Report Writer report that you define for the rollup ledger.

⚠️ With larger data quantities, this function causes a huge increase in processing time. If you set the *Write line items* indicator, the system writes line items to the line item database.

If you do not plan to reverse the rollup or drill down to rollup line items in a report created for the rollup ledger (or if you are rolling up large quantities of data), you should leave the *Write line items* indicator blank to avoid unnecessary database updates and increased runtime.

Procedure

1. Define and install rollup line item tables.

   Data of the source ledger is saved in special rollup line item tables. It is not currently possible to automatically install these tables using the FI-SL Define Table Group functions. You should copy the standard example tables delivered with your system (GLREFU: rollup actual line item table and GLREFV: rollup plan line item table), and modify them according to your requirements.

   For more information about installing rollup line item tables, see the Implementation Guide (IMG) for Special Purpose Ledger.

2. Write line item records when you execute the rollup.

   To display the original data, line item records, which contain the original data, must be written when the rollup is executed. If no line item records are updated, the drilldown report will display incorrect data.

   To update rollup line items, set the *Write line items* indicator in the rollup definition (*Processing optn* indicator).

   For more information, see Creating Rollups [Page 114].

3. Create the rollup report and the drill-down report.

   For more information, see Creating a Report Painter Report [Ext.].

   To carry out the drilldown, use the *Call up report* function. You must therefore define the drilldown report as a receiver report in the rollup report’s report group. The drilldown report is called up via the report/report interface when you select an area of data in the rollup report.

💡 The drill-down report is similar to a standard line item report, but you can only use data set entries defined for the rollup line item tables when you create the report (for example, RBHSL-0 for rollup documents in local currency for actual data).
It is not currently possible to drill down to both actual and plan data in a rollup report. You must therefore define two separate reports for displaying actual and plan rollup line items.

The rollup line items are only relevant for rollups and the Report Writer. You cannot therefore display rollup line items using the summary record and document display functions.

The reversal function can be used both with the 'normal' line item tables and with the special rollup line item tables. When writing line item records, the system checks if rollup line item tables are defined. If so, the line item records are written to these tables. If no rollup line item tables are defined, the line item records are written to the 'normal' line item tables.

Example

The accounts 101000, 102000 and 103000 are summarized into account 100000 using a rollup. A Report Writer report is defined for the rollup ledger. Data for account 100000 is output in this report after the report group is carried out.

Using the drilldown function, you can display the original posted data that makes up the total for account 100000.

If the following graphic, you can see the drill down report for account 100000. The report contains the data of the source ledger for accounts 101000, 102000, and 103000.

In the report for the rollup ledger, the data for accounts 101000, 102000 and 103000 is summarized and substituted into account 100000 and the cost center data is summarized and included in the records for the accounts.
Carrying out Drill Downs on Rollup Line Items

**Report Writer Report for Rollup Ledger**

<table>
<thead>
<tr>
<th>Accounts/Totals</th>
<th>ACTUAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>* Total</td>
<td>10000.00</td>
</tr>
<tr>
<td>Account 100000</td>
<td>1000.00</td>
</tr>
<tr>
<td>Account 200000</td>
<td>200.00</td>
</tr>
<tr>
<td>Account 300000</td>
<td>500.00</td>
</tr>
<tr>
<td>Account 400000</td>
<td>200.00</td>
</tr>
</tbody>
</table>

**Drilldown Report for Account 100000**

<table>
<thead>
<tr>
<th>Accounts/Line Items</th>
<th>ACTUAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>* Account 100000</td>
<td>1000.00</td>
</tr>
<tr>
<td>Account 101000</td>
<td>500.00</td>
</tr>
<tr>
<td>Cost center 100</td>
<td></td>
</tr>
<tr>
<td>Account 102000</td>
<td>300.00</td>
</tr>
<tr>
<td>Cost center 200</td>
<td></td>
</tr>
<tr>
<td>Account 103000</td>
<td>200.00</td>
</tr>
<tr>
<td>Cost center 300</td>
<td></td>
</tr>
</tbody>
</table>
Defining Rollups

Use
By defining the rollup, you define how data is to be summarized from one or more source ledgers to one or more rollup ledgers. This means defining the rollup type, rollup header and rollup sequence.

Rollup Type
By defining the rollup type [Page 103], you define how the data is to be summarized. You can choose between the following rollup types:

Standard
In a standard rollup, you rollup data into one or more rollup ledgers, using rollup sequence(s) and sender ledger(s). You do this by leaving fields empty for field movement and by substituting certain fields.

Hierarchy
In a hierarchical rollup, you rollup data according to the structure of the single-dimension set defined in your rollup header set.

Export
An export rollup is used to transfer data from local systems to a central system. For further information on export rollups, see FI-SL and Distributed Systems [Page 106]. The rollup header contains cross-sequence information that is relevant for all rollup sequences. You have to define a rollup header in accordance with the type of rollup you have chosen.

Rollup sequences
The rollup sequences are the basic units of rollups. You can use them to carry out several actions within one rollup. By using sequences, you avoid having to create and execute separate rollups when you want to execute a series of different actions. Each rollup sequence contains information such as the sequence set, a rule for selecting data, the field grouping code, and the ledger.
Overview: Executing Rollups

Use
Rollups allow you to store commonly-used data in a summarized form, depending on the level of detail you require. By using rollups, you can achieve a significant reduction in processing time.

Procedure
1. Define a rollup ledger.
   The rollup ledger receives summarized data from one or more source ledgers and must be defined before you can define a rollup. You must activate the Rollup allowed indicator in Customizing for Special Purpose Ledger if you want to define a ledger as a rollup ledger.
   For more information about defining a ledger, see the Maintain Ledgers step in the Implementation Guide (IMG) for Special Purpose Ledger.
2. Create field movements and substitution activities.
   Before you create a rollup, you must define a field grouping code that contains field movements. Field movements determine which dimensions from the source ledger(s) are transferred to the rollup ledger.
   If you want to substitute data being transferred from the source ledger(s) to the rollup ledger, you need to create a substitution activity and enter a substitution activity code as part of the field movement. You enter the field movement code in each rollup action sequence you define.
   For more information, see Field Movements and Rollups [Page 99].
   You can create field movements and substitution activities in Customizing. Detailed procedures for creating field movements and substitution activities in Customizing are described in the Maintain Field Movements and Maintain Substitution steps in the Implementation Guide (IMG) for Special Purpose Ledger.
3. Create sets.
   Before you define a rollup, you must create sets for the rollup. The header set used in a rollup determines the data to be summarized into a rollup ledger, and the reset set determines the data fields in the rollup ledger to be reset to zero. The sequence set restricts the data to be processed for the respective rollup sequence.
   For more information, see Sets and Rollups [Page 96] and Creating Sets. [Ext.]
   You can find more information on creating sets under Set Creation [Ext.].
4. Create the rollup.
   You create an allocation cycle in the following steps:
   a) Create the rollup and choose a rollup type
   b) Define the rollup header.
   b) Define the rollup sequences (for standard rollups).
   c) Enter the field movement information.
For more information, see Creating Rollups [Page 114].

5. Verify the rollup.

After you have created a rollup, you can use the Check rollup function to check for any errors in your rollup definition.

For more information, see Checking Rollups [Page 132].


If you want to print a detailed listing of your rollup definition and statistics, you can use the Document rollup function.

For more information, see Documenting Rollups [Page 133].

7. Execute the rollup.

To execute a rollup, you use the Execute function.

For more information, see Executing Rollups [Page 138].

8. Reverse a rollup, if desired.

If you want to reverse a rollup, you use the Reverse function. Reversing a rollup is different from resetting data with a reset set. When you reverse a rollup the system creates reversing documents that offset the original line items. When you reset data with a reset set, the system resets selected data fields to zero but does not create any new documents. Refer to the online documentation for the Write line items field for further information.

For more information, see Reversing Rollups [Page 136].

9. Execute or reverse a rollup in background processing.

If executing or reversing your rollup involves large amounts of data and requires a long processing time, you should execute or reverse your rollup in background processing.

For more information, see Defining Rollups for Background Processing [Page 135].
Creating Rollups

Use

Using the Rollup function, you can summarize information from one or more source ledgers into a rollup ledger(s). To do so, you have to define the rollup.

Procedure

2. Enter a name for the rollup.
3. Choose a rollup type.
4. Choose 📝. The Create Rollup <Name>: Header screen appears. Various entry fields can now appear, depending on the rollup type you have chosen.
5. If you want to use an existing rollup as a template, enter the name of a rollup you have previously defined and choose 📝. The Create Rollup <Name>: Header screen appears. The fields are filled with data from the template.

Result

By defining the rollup type, you have defined the first part of the rollup. You are now in the Create Rollup <Name>: Header screen. Here, you create the rollup header.

Creating Rollup Headers for Standard Rollups [Page 115]
Creating Rollup Headers for Hierarchy Rollups [Page 119]
Creating Rollup Headers for Export Rollups [Page 123]
Creating Rollup Sequences [Page 125]
Maintaining Field Movement [Page 127]
Entering Substitution Activities [Page 129]
Creating Rollup Headers for Standard Rollups

Use

The rollup header contains information that is valid for the entire rollup. With a standard rollup, you can rollup data up into one or more rollup ledgers. To do so, you use one or more rollup sequences.

Prerequisites

On the Create Rollup initial screen, you have flagged the rollup type standard and chosen.

Procedure

1. Under Title, enter a name for your rollup.
2. If you want to require that a user have authorization for creating, displaying, maintaining, executing, and reversing this rollup, enter the name of an authorization group in the authorization group field.
3. Under Tables, enter the name of the sender table and receiver table.
4. Under reset, if required, enter the name of the reset set.

You can use the reset set to reset the data in the rollup ledger for the relevant periods to 0 prior to the actual rollup and before new data is summarized into the rollup ledger. A reset set is normally necessary, as the default active overwrite (see step 6: Cumulating Values) makes it possible for a rollup to be executed more than once in a given period.

A reset set is useful in the following situations:

The rollup field movement was changed after execution. When a rollup is executed again for a given period, different rollup records are created to the ones created on previous execution. The new rollup records do not overwrite the old ones. The old rollup records remain, therefore leading to incorrect results. By using a reset set, these old records can be set to 0.

If you want to roll up data from several source ledgers together in a rollup ledger, the Cumulate Values flag must be active for all affected rollups. If you then have to repeat these rollups in a given period, you can enter a reset set in one of the rollups. This will reset the values for this period to 0. Subsequently, all rollups can be executed again with the Cumulate Values flag.

To optimize performance, your reset set must contain the following dimensions:

- Ledger
- Record type
- Version
Creating Rollup Headers for Standard Rollups

- Company code or company (local or global)

Your reset set must **not** use the following dimensions:

- Client
- Period
- Year

You can create a reset set to set the data fields in account 100000 to zero. When you execute the rollup, the data fields in account 100000 will be set to zero in the receiver table before the rollup fills all fields that meet the selection criteria for the set specified in the rollup header. For further information, see **Sets and Rollups [Page 96]**.

5. If required, enter a user exit and/or a rollup set under **Roles**.

You have to enter the number of the user exit in the **user exit** field. For further information, see **User Exits and Rollups [Page 105]**.

The rollup set is used for all sequences in the rollup. Using the multi-dimension set specified in this field, the system chooses the data that is to be taken from the source ledger(s) and summarized.

To optimize performance, your rollup set must contain the following dimensions:

- Ledger
- Record type
- Version
- Company code or company (local or global)

Your rollup set must **not** contain the following dimensions:

- Client
- Period
- Year

6. To enter default values for processing the rollup, choose **Processing Options**. The **Default Values** dialog box appears. You can choose between the following functions:

   a. **Write Line Items**

      If you set the **Write Line Items** flag, a line item will be written for every you totals record when you execute the rollup. This line item will flag the totals record during drilldown. It will then be possible to reverse this rollup run.

      **WARNING**

      Only set the **Write line items** indicator if you want the option of reversing the rollup or if you only want to roll up a small amount of data. If you set the **Write line items** indicator, processing time will be increased enormously.
Creating Rollup Headers for Standard Rollups

Writing line items is something you should only do in exceptional cases. With an extremely long rollup, a very large amount of data is rolled up to a rollup ledger. With a second rollup, a smaller amount of data is to be cumulated to the same ledger, meaning that the rollup must be performed again, as repostings will take place. In this case, you can reverse the data from the second rollup specifically and execute the rollup again. Should no line items be stored, you would have to execute both rollups again.

b. Cumulate Values

If you do not set the Cumulate Values flag (standard setting), the existing records in the rollup ledger will be overwritten by the rollup records in the current run. This only applies for periods for which the rollup is currently being executed. The other periods are not affected. It is not possible to execute a rollup more than once for a given period, as the values will simply be overwritten.

If you set the Cumulate Values flag, the currently records currently being rolled up will be added to the existing records in the rollup ledger. As a consequence, repeated execution of the rollup leads to a multiplication of the totals.

Cumulating values is only useful if you want to roll up data from several source ledgers to a rollup ledger in a series of rollups.

c. Write Records with Amount 0

If you want the system to insert blank records (records with the value zero in their amount fields) in the rollup ledger, set the Write records with amount 0 indicator.

If you want to create a report that shows all accounts in a group of accounts (including accounts that have amounts equal to zero), you must include records that have zero in their amount fields. If blank records are not included in your rollup ledger, then the summary records of those accounts that are equal to zero will not be created or available for reporting.

You can use the following additional functions on this screen:

To check the rollup for errors, choose . For further information, see Checking Rollups [Page 111].

To create rollup sequence, choose Rollup Sequence. You can define a rollup sequence set for each rollup sequence, or you can define the rollup so that only the rollup header set applies to the rollup sequences. For further information, see Creating Rollup Sequences [Page 125].

To display and maintain sets or field movements in the rollup header, choose . Move the cursor to the set or field movement you want to display. You can define field movement information for as many dimensions that you want to roll up in the ledger. You can define substitution activities for as many dimensions that you want to substitute in the ledger.

To create sets, move your cursor to required set, enter the name and choose Set.
Creating Rollup Headers for Standard Rollups

Additional Processing Functions in the Create Rollup <Name>: Header screen

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollup → Document</td>
<td>Document the rollup definition and rollup records</td>
</tr>
<tr>
<td>Extras → History</td>
<td>Display change history for the rollup</td>
</tr>
<tr>
<td>Extras → Different Currencies</td>
<td>Set the currency fields to zero</td>
</tr>
</tbody>
</table>

7. To save the settings, choose 🗳.

**Result**

You have completed rollup definition. For more information, see:

- Executing Rollups [Page 138]
- Defining Background Jobs for Rollup Definition [Page 135]
- Changing Rollups [Page 143]
- Reversing Rollups [Page 136]
- Deleting Rollups [Page 142]
Creating Rollup Headers for Hierarchical Rollups

Use

The rollup header contains information that is valid for the entire rollup. In a hierarchical rollup, you rollup data according to the structure of the single-dimension set defined in your rollup header set.

Prerequisites

You have flagged a rollup type and chosen on the Create Rollup: Initial screen.

Procedure

1. Under Title, enter a name for your rollup.
2. If you want to require that a user have authorization for creating, displaying, maintaining, executing, and reversing this rollup, enter the name of an authorization group in the authorization group field.
3. Under Summarize from, enter the name of the table in which you want the data to be summarized.
4. If required, enter the name of the reset set under Reset. You can use the reset set to reset the data in the rollup ledger for the relevant periods to 0 prior to the actual rollup and before new data is summarized into the rollup ledger.

You can use the reset set to reset the data in the rollup ledger for the relevant periods to 0 prior to the actual rollup and before new data is summarized into the rollup ledger. A reset set is normally necessary, as the default active overwrite (see step 6: Cumulating Values) makes it possible for a rollup to be executed more than once in a given period.

A reset set is useful in the following circumstances:

Rollup field movement has been changed following execution of a rollup. When this rollup is executed again for a period, different rollup records are created to those created previously. The new rollup records do not match the old ones and therefore do not overwrite them. The old rollup records remain, therefore leading to incorrect results. By using a reset set, these old records can be set to 0.

If you want to roll up data from several source ledgers together in a rollup ledger, the Cumulate Values flag must be active for all affected rollups. If you then have to repeat these rollups in a given period, you can enter a reset set in one of the rollups. This will reset the values for these periods to 0. Subsequently, all rollups can be executed again with the Cumulated Values flag.

For performance reasons, you must include the following dimensions in your reset set:
Creating Rollup Headers for Hierarchical Rollups

- Ledger
- Record type
- Version
- Company code or company (local or global)

You must not include the following dimensions in your reset set:

- Client
- Period
- Year

You can define a reset set to reset the data fields for account 100000 to zero. When you execute the rollup, the data fields for account 100000 will first be reset to zero in the receiver table, then the rollup will add data to all data fields that meet the selection condition in the rollup header set. For further information, see Sets and Rollups [Page 96].

5. If required, enter a user exit and/or a rollup set under Roles.

To refer the system to a user exit, enter the user exit number in the User exit field. For further information, see User Exits and Rollups [Page 105].

The rollup set will be used for all sequences defined for the rollup. The multi-dimension set name you enter in this field selects the data to be rolled up from the source ledger(s).

For performance reasons, you must include the following dimensions in your rollup set:

- Ledger
- Record type
- Version
- Company code or company (local or global)

You must not use the following dimensions in your rollup set:

- Client
- Period
- Year

If you are defining a hierarchical rollup, you must include the single-dimension set of the hierarchy dimension in the header set. For more information about sets and rollups, see Sets and Rollups [Page 96].
Creating Rollup Headers for Hierarchical Rollups

6. Under **Hierarchy Dimension**, enter the dimension that you want to use for processing the rollup (for example, cost center). This hierarchical dimension then determines the single-dimension set in the rollup set, over with the hierarchical summarization is to be made.

   Enter a representative value for each set in your hierarchy set. This representative value represents, for example, the node cost centers to which you want to roll up data. When the set is processed in the rollup, the system creates data records using the representative values. For more information about hierarchical rollups, see *Rollup Types* [Page 103].

7. Under **Field Movement**, enter the name of the field movement rule that should be used for the rollup. The field movement determines which dimensions will be transferred from the source ledger(s) to the rollup ledger.

8. Under **Receiver Ledger**, specify how the data is to be summarized in the receiver system when you create an export rollup:

9. Select the **Processing optn** indicator to enter default values for processing rollups. The **Default Values** dialog box appears. You can choose between the following functions:

   a. **Cumulate Values**
      
      If you want new rollup data to be added to existing rollup data in the rollup ledger, set the **Cumulate Values** flag. Do not set this flag if you want new rollup data to overwrite existing rollup data.

   b. **Write Records with Amount 0**
      
      If you want the system to insert blank records (records with the value zero in their amount fields) in the rollup ledger, set the **Write records with amount 0** indicator.

      If you want to create a report that shows **all** accounts in a group of accounts (including accounts that have amounts equal to zero), you must include records that have zero in their amount fields. If blank records are not included in your rollup ledger, then the summary records of those accounts that are equal to zero will not be created or available for reporting.

   c. **Elimination of Internal Business Volume**
      
      If you want to eliminate internal business volume within a set hierarchy, set the **Elim.of int.bus.vol frm bus** indicator. You can only use this field for hierarchical rollups. Elimination of internal business volume is only possible with dimensions for which a partner dimension has been defined in the master files (for example, SCNTR for SCNTR). If you have allocated costs between the final cost centers within a cost center area, you can eliminate inter-company business volume.

   d. **Summarize Partners**
      
      Set the **Summarize partner** indicator to summarize data across sender and receiver cost center (only for hierarchical rollups).

You can use the following additional functions on this screen:

To display and maintain sets or field movements in the rollup header, choose . Move the cursor to the set or field movement you want to display. You can define field movement information for as many dimensions that you want to roll up in the ledger. You can define substitution activities for as many dimensions that you want to substitute in the ledger.
Creating Rollup Headers for Hierarchical Rollups

To check the rollup for errors, choose 🔄. For further information, see Checking Rollups [Page 111].

To create sets, choose 🔄 Set. Position your cursor on the required set.

To create a field movement, choose 🔄 Field Movement.

Additional Processing Functions in the Create Rollup <Name>: Header screen

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollup → Document</td>
<td>Document the rollup definition and Rollup Records</td>
</tr>
<tr>
<td>Extras → History</td>
<td>Display change history for the rollup</td>
</tr>
<tr>
<td>Extras → Different Currencies</td>
<td>Set the currency fields to zero</td>
</tr>
</tbody>
</table>

9. To save the settings, choose 🔄.

Result

You have ended rollup definition. For more information, see:

- Executing Rollups [Page 138]
- Defining Background Jobs for Rollup Definition [Page 135]
- Changing Rollups [Page 143]
- Reversing Rollups [Page 136]
- Deleting Rollups [Page 142]
Creating Rollup Headers for Export Rollups

Use
The rollup header contains information that is valid for the entire rollup. You can use an export rollup to distribute data contained in totals records from a local system to a central system.

Prerequisites
You have flagged a rollup type and chosen on the Create Rollup: Initial screen.

5. Under **Title**, enter a name for your rollup.
6. If you want to require that a user have authorization for creating, displaying, maintaining, executing, and reversing this rollup, enter the name of an authorization group in the **authorization group** field.
7. Under **Transfer Data**, enter the name of the table in which you want the data to be summarized.
8. Under **Data Selection**, enter the name of the rollup set in which you want the data to be selected.
9. Set the **No summarization** indicator if you do not want to summarize the data when it is transferred to the receiver system. Data will be transferred on a 1:1 basis.
10. Set the **Field movement** indicator if you want to summarize the data when it is transferred to the receiver system using a field movement. Enter the name of the field movement rule.

You can use the following additional functions on this screen:

To display and maintain sets or field movements in the rollup header, choose . Move the cursor to the set or field movement you want to display. You can define field movement information for as many dimensions that you want to roll up in the ledger. You can define substitution activities for as many dimensions that you want to substitute in the ledger.

To check the rollup for errors, choose . For further information, see Checking Rollups [Page 111].

To create sets, choose . Set. Position your cursor on the required set.

To create a field movement, choose .

Additional Processing Functions (*Create Rollup <Name>*: **Header** screen)

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollup → Document</td>
<td>Document the rollup definition and Rollup Records</td>
</tr>
<tr>
<td>Extras → History</td>
<td>Display change history for the rollup</td>
</tr>
<tr>
<td>Extras → Different Currencies</td>
<td>Set the currency fields to zero</td>
</tr>
</tbody>
</table>

11. To save the settings, choose .
Creating Rollup Headers for Export Rollups

Result

You have ended rollup definition. For more information, see:

- Executing Rollups [Page 138]
- Defining Background Jobs for Rollup Definition [Page 135]
- Changing Rollups [Page 143]
- Reversing Rollups [Page 136]
- Deleting Rollups [Page 142]
Creating a Rollup Sequence

Use

Rollup sequences allow you to execute multiple rollup sequences without having to create and execute separate rollups. You can only create rollup sequences for standard rollups. All necessary information for a hierarchical and export rollup is defined on the Create Rollup <Name>: Header screen.

You can create a rollup with three rollup sequences. Each sequence within the rollup rolls up data from three different sources into three different rollup ledgers. When you execute the rollup, all three sequences will be processed (record by record) in order of sequence number.

Procedure

You are now in the Create Rollup <Name>: Header screen.

1. Choose Rollup Sequence. The Create Rollup <Name>: Rollup Sequence screen appears.
2. Under Sequence Definition, enter the following information:
   - Name of the rollup sequence set
     With the sequence set, you determine which data should be rolled up for the specific sequence. The sequence set can be a single-dimension or basic set. For further information, see Sets and Rollups [Page 96] [Page 104].
   - A selection rule, if your sequence set cannot completely define the data to be rolled up
     You use the selection rule to further limit the data to be chosen by the sequence set. The selection rule must conform to Boolean Logic syntax rules [Ext.].
   - Name of the field movement for the rollup sequence
     Using the field movement, you determine which dimensions will be transferred from the source ledger(s) to the rollup ledger.
   - Enter a name for the rollup ledger.
     When you create a rollup sequence, you can now enter the ledger to which you want to rollup data.
   - Set the Blocked indicator if you want to block the sequence from rollup processing
   - Rollup sequence description
3. To save the rollup sequence, choose .

You can use the following additional functions on this screen:

To return to the Create Rollup <Name>: Header screen, choose .
To delete a given rollup sequence, choose Sequence.
Creating a Rollup Sequence

To choose and edit an object in the rollup sequence (set, rule or field movement), place your cursor on the object and choose \[\text{Edit}\].

To check the rollup for errors, choose \[\text{Check}\].

To create a set, choose \[\text{Create} \].

To create a field movement, choose a sequence set, enter the field movement information and choose \[\text{Field Movement} \].

Additional Processing Functions (Create Rollup <Name>: Rollup Sequence Screen)

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → History</td>
<td>Display change history for the rollup</td>
</tr>
<tr>
<td>Extras → Document Rollup</td>
<td>Document rollup definition and rollup records</td>
</tr>
</tbody>
</table>
Creating Field Movement

Use

With field movement [Page 99], you can define how data/which fields is/are transferred to and summarized in a database. Field movements contain:

- Sender fields (dimensions of the source database)
- Receiver fields (dimensions of the receiver database)

You have to assign a field movement rule to each group of field movements.

Procedure

You are now in the Create Rollup <Name>: Rollup Sequence screen.

1. Enter the name of the field movement that you want to create and choose Field Movement.
   - The Create Rollup Field Movement: Data screen appears.

2. Enter the following data:
   - A description of the field movement
   - A user exit to be performed after data is selected from the database, if required.
   - A user exit to be performed before the database is updated with receiver records, if required.
   - Receiver field name
     - The receiver field is the field to which the sender field name is assigned.
   - A sender field name that is to be assigned from the source table.
     - The data from this field is assigned to the Rec. fld field.
   - A substitution activity code
   - A user exit number to be performed when the data from the sender field is moved to the receiver field during rollup execution, if required.

   For more information about user exits, see User Exits and Rollups [Page 105].

3. To save the field movement information, choose Save.

   This screen contains the following additional functions:

   To delete a row from the field movement information, choose Delete.

   To enter substitution information for the rollup, choose Substitutions. For further information, see Entering Substitution Processes [Page 129].

   To display additional entries for entering field movements, choose New Entries.

   To delete all rows from the field movement information, choose Edit → Delete All Rows.
Creating Field Movement

You use the Edit $\rightarrow$ Choose function on the Create Rollup <Name>: Rollup Sequence screen to display a field movement already defined in the rollup sequence.

**Result**

You have created/edited a field movement for the rollup, thus defining which data/fields are to be transferred and summarized from the source database to the receiver database.
Enetering Substitution Activity Information

Use

A substitution activity allows you to transfer substituted data to receiver dimensions during the rollup process. A substitution activity is identified by its substitution activity code, and you enter the substitution activity code in a field movement. You can use the same substitution activity code for more than one rollup sequence.

You could define a substitution activity called CONV to substitute the value 300000 for account numbers between 500000 and 500020 (number 1) and to substitute the value 400000 for account numbers between 600000 and 600020 (number 2). Next, you enter the substitution activity code CONV in a field movement that transfers the data for the dimension Account. When you execute your rollup, account numbers between 500000 and 500020 will be changed to and summarized under account number 300000, and account numbers between 600000 and 600020 will be changed to and summarized under 400000.

Procedure

You are currently in the Create Field Movement: Data screen:

3. Enter the following data:
   - Name of the substitution activity
   - A consecutive number
   - Name of the summary table (receiver table)
   - Name of the receiver field (receiver dimension)
   - Constant value (substitution value)
     The value you enter in this field will be substituted for the original value if the substitution condition is met.
     For substitution activity code CONV (above example), you could enter the value 300000.
   - User exit number, to refer the system to a rollup substitution exit
     If your substitution condition is too complicated to define here (for example, if you want to read a user-defined table), you can define the substitution in a user-defined routine called a substitution exit. Generally, if you enter a user exit, it is not necessary to enter a value in the Constant value field. For more information about user exits, see User Exits and Rollups [Page 105].
   - A substitution rule
Entering Substitution Activity Information

The substitution activity (replacement by constant value or execution of a user-exit) is only executed if the rule entered for it is complied with.

All substitution rules that are used in rollup substitution activities must be created for table GLU1 (application area GU, callup point 0002).

For more information about creating substitution rules, see Creating Rules [Ext.].

4. To save the substitution activity, choose .

Result

You have created substitution activities. When you execute the rollup, the substituted data will be transferred to the receiver dimensions.

You can use the following additional functions in this screen:

To position the cursor on a substitution activity that has already been defined, choose .

To switch between display mode and change mode in the table view, choose .

To delete a substitution activity, select the row and choose .

To select all substitution entries for further processing, choose .

To select a block of substitution activities for further processing, choose .

To delete the selection for all selected substitution activities, choose .

Additional Processing Functions – Change View “Rollup Substitution”: Overview Screen

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Table View → Save</strong></td>
<td>Save the substitution activity definitions.</td>
</tr>
<tr>
<td><strong>Table View → Transport</strong></td>
<td>Prepare the table for transport under a correction number.</td>
</tr>
<tr>
<td><strong>Table View → Print → Standard List</strong></td>
<td>Print all substitution activities defined on the system.</td>
</tr>
<tr>
<td><strong>Table View → Print → Variable List</strong></td>
<td>Print specific substitution activities based on user-defined selection criteria.</td>
</tr>
<tr>
<td><strong>Edit → New Entries</strong></td>
<td>Create a new substitution activity.</td>
</tr>
<tr>
<td><strong>Edit → Copy as</strong></td>
<td>Copy a selected substitution activity.</td>
</tr>
<tr>
<td><strong>Edit → Change Field Content</strong></td>
<td>Change a selected substitution activity.</td>
</tr>
<tr>
<td><strong>Edit → Reverse Change</strong></td>
<td>Change a selected substitution activity back to its previous definition.</td>
</tr>
<tr>
<td><strong>Goto → Next Entry</strong></td>
<td>Move to the next substitution activity.</td>
</tr>
<tr>
<td><strong>Goto → Previous Entry</strong></td>
<td>Move to the previous substitution activity.</td>
</tr>
<tr>
<td><strong>Goto → Other Entry</strong></td>
<td>Move to a specific substitution activity.</td>
</tr>
</tbody>
</table>
### Entering Substitution Activity Information

<table>
<thead>
<tr>
<th><strong>Selection → By Content</strong></th>
<th>View substitution activities according to the fields displayed on the screen.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Selection → All Selected Entries</strong></td>
<td>View all substitution activities that have been selected.</td>
</tr>
<tr>
<td><strong>Selection → All Changed Entries</strong></td>
<td>View all substitution activities that have been changed.</td>
</tr>
<tr>
<td><strong>Selection → All Created Entries</strong></td>
<td>View all substitution activities that have just been created.</td>
</tr>
<tr>
<td><strong>Selection → Display Deleted Entries</strong></td>
<td>View all substitution activities that have just been deleted.</td>
</tr>
<tr>
<td><strong>Utilities → Other Systems</strong></td>
<td>Compare the substitution activity entries with the entries in another system (for example, a test system vs. a productive system).</td>
</tr>
<tr>
<td><strong>Utilities → Requests (Organizer)</strong></td>
<td>Call up the Workbench Organizer, for example, to maintain and display transport requests.</td>
</tr>
</tbody>
</table>
Checking Rollups

Use

After you have created a rollup, you should check that it you have defined it correctly.

You are in one of the following screens: Create/Change/ Rollup <Name>: Header or Create/Change/ Rollup <Name>: Rollup Sequence.

Procedure

1. Choose . If the rollup is correct, the system displays the following message: Rollup <Rollup Name> is formally correct

   If the rollup contains errors, error messages appear.

   When displaying error messages for a rollup definition, you can display a more detailed explanation. To do this, proceed as follows:

2. Move the cursor to the error message for which you want to display additional information.

3. Choose or double-click the message.

4. You must correct these errors before executing the rollup. (However, you can ignore warning messages.)

Result

If the system displays the following message: Rollup <Rollup Name> is formally correct, you can execute the rollup.
Documenting Rollups

Use
With the Document Rollup function, you can display and print all of the rollup screens (including all rollup sequences).

Procedure
1. You are in one of the following screens: Create/Change/ Rollup <Name>: Header or Create/Change/ Rollup <Name>: Rollup Sequence.
3. Enter texts as required.
4. Choose ✎. The Document Rollup Definition screen appears. You can use the following additional functions on this screen:

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>List → Print</td>
<td>The documented rollup definition is printed in a list.</td>
</tr>
<tr>
<td>List → Save/Send → Office</td>
<td>You can create and send the rollup definition as a document.</td>
</tr>
<tr>
<td>List → Save/Send → Report Tree</td>
<td>You can save the documented rollup definition as public or private. You can attach the rollup definition to an existing list and optically archive it.</td>
</tr>
<tr>
<td>List → Save/Send → File</td>
<td>You can save the list in various formats.</td>
</tr>
</tbody>
</table>
5. To get a variant, choose ✎.
6. Choose Program → Execute + Print. The system prints the rollup documentation at the selected printer or writes the documentation to the spool file to be printed later.

Result
You have documented the rollup definition. You can now display, print, save and send the rollup documentation.
Displaying Rollups

Procedure

   
   The Display Rollup: Initial Screen appears.

2. Enter the name of the rollup that you want to display.

3. Choose 📊.
   
   The Display Rollup <Name>: Header screen appears.

Result

You are now in rollup display mode and can also display the rollup sequence(s).
Defining a Rollup for Background Processing

Use

You can execute or reverse a rollup in either online or background processing. Normally, executing or reversing your rollup involves large amounts of data and requires extensive processing time; in this case, you should execute or reverse your rollup in background processing.

Procedure

   The Execute/Reverse Rollup: Initial Screen appears.

2. In the Rollup field, enter the name of the rollup for which you want to create a job for background processing and choose 🔍.
   The Execute/Reverse Rollup <Name>: Parameter Screen appears.

3. Enter data as required.

   For more information about entering the values in these fields, see Executing a Rollup [Page 138] and Reversing a Rollup [Page 136].

4. Set the Background processing indicator and choose Execute or Reverse.
   A dialog box appears, prompting you for job information.

5. Enter the information for executing/reversing the rollup in background processing and choose 🔍. The Simple Job Selection screen appears.

6. Enter the following data as required:

   You can also use a more flexible job selection. Further selection criteria are available for this: Choose 🔍 with quick text Extended Job Selection.

7. Choose Execute.

Result

The Job Overview screen appears. Here, you can edit your job(s).

For more information on background jobs, see the SAP Library under Getting Started → Basis → Computing Center Management System (BC-CCM) → Computing Center Management System (BC-CCM) → Background Processing → Managing Jobs with the Job Overview.
Reversing a Rollup

Use
When you reverse a rollup the system creates reversing documents that offset the original line items. When you reset a rollup, the system resets selected data fields to zero but does not create any new documents.

You can reverse a rollup only if the rollup data has been posted to the line item database(s).

Procedure
2. Enter the name of the rollup that you want to reverse.
3. Choose . The Reverse Rollup <Name>: Parameter Screen appears.
4. Enter the following data:
   * **Parameters fields:**
     - For standard and hierarchical rollups (when the fiscal year variants are the same for the source ledger(s) and rollup ledger):
       - Beginning period for which you want to reverse rollup data.
       - Fiscal year for the value entered in the *From period* field.
       - End period for which you want to reverse rollup data.
       - Fiscal year for the value entered in the *To period* field.
     - For standard and hierarchical rollups (when the fiscal year variants are different for the source ledger(s) and the rollup ledger):
       - Start date for the rollup reversal
       - End date for the rollup reversal
       - Set the *Carry-frwrd period frm yr* indicator if you want to reverse the carry forward period of a specific year. In the second field, enter the fiscal year for which you want to reverse the carry forward period.
       - Set the *Special periods* indicator if you want to reverse all special periods.
   * **Processing options fields:**
     - If you want to reverse your rollup in the background, set the *Background processing* indicator.
     - For more information about reversing your rollup in the background, see Defining a Rollup for Background Processing [Page 135].
     - If you want to output a list containing details on all the records read and generated during the rollup reversal, set the *Detail list* indicator.
5. You can use the following additional processing functions on the Reverse Rollup <Name>: Parameter Screen.

**Additional Processing Functions – Reverse Rollup <Name> Parameter Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → History</td>
<td>View the execution history of the rollup.</td>
</tr>
<tr>
<td>Extras → Delete history</td>
<td>Delete the execution history information for the rollup.</td>
</tr>
<tr>
<td>Extras → Document rollup</td>
<td>Document the rollup and record results of the rollup.</td>
</tr>
</tbody>
</table>

6. Choose Reverse.

   A list of statistics for the reversed rollup appears on the Reverse Rollup <Name>: Statistics screen.

**Result**

A list of statistics for the reversed rollup appears on the Reverse Rollup <Name>: Statistics screen.
Executing Rollups

Procedure


2. Enter the name of the rollup that you want to execute.

3. Choose . The Execute Rollup <Name>: Parameter Screen appears.

   If you entered a value or set variable in one of your rollup sets, a dialog box appears, prompting you to confirm or change the default value of the variable.

   The dialog box for set variables appears first, followed by the dialog box for value variables. The Execute Rollup <Name>: Parameter Screen appears.

   If there are errors in the rollup definition, a screen appears, listing errors that you have to correct. If the errors are only warnings, choose . The Execute Rollup <Name>: Parameter Screen appears.

4. Enter the following information:

   **Parameter fields:**

   For standard, hierarchical and export rollups (when the fiscal year variants are the same for the source ledger(s) and rollup ledger):

   Enter the beginning period for which you want to reverse rollup data.

   Enter the fiscal year for the value entered in the From period field.

   Enter the end period for which you want to reverse rollup data.

   Enter the fiscal year for the value entered in the To period field.

   For standard rollups (when the fiscal year variants are different for the source ledger(s) and the rollup ledger):

   Enter the start date for the rollup execution.

   Enter the end date for the rollup execution.

   Set the Carry-frwrd period frm yr indicator if you want to reverse the carry forward period of a specific year. In the second field, enter the fiscal year for which you want to roll up the carry forward period.

   Set the Special periods indicator if you want to roll up all special periods.

   **Processing options fields:**

   If you want to execute your rollup in the background, set the Background processing indicator.

   For more information on background processing for rollups, see Defining Background Jobs for Rollup Execution [Page 135].
Executing Rollups

If you want the option of reversing the rollup after it has been executed, set the *Write line items* indicator.

If you set the *Write line items* indicator, the system writes line items to the line item database. If you do not plan to reverse the rollup or drill down to rollup line items in a report created for the rollup ledger (or if you are rolling up large quantities of data), you should leave the *Write line items* indicator blank to avoid unnecessary database updates and increased runtime.

Enter the document type for the rollup, if line items should be created for the rollup. The document type groups together documents that are processed in the same way.

If you want new rollup data to be added to existing rollup data in the rollup ledger, set the *Accumulate values* indicator. If you want new rollup data to overwrite existing rollup data, do not set this indicator.

If you want the system to insert blank records (records with the value zero in their amount fields) in the rollup ledger, set the *Write records with amount 0* indicator.

If you want to create a report that shows all accounts in a group of accounts (including accounts that have amounts equal to zero), you must include records that have zero in their amount fields. If blank records are not included in your rollup ledger, then the summary records of those accounts that are equal to zero will not be created or available for reporting.

If you want to eliminate internal business volume within a set hierarchy, set the *Elim.of int.bus.volfrm bus* indicator. You can only use this field for hierarchical rollups. Elimination of internal business volume is only possible with dimensions for which a partner dimension has been defined in the master files (for example, SCNTR for SCNTR).

If you have allocated costs between the final cost centers within a cost center area, you can eliminate inter-company business volume.

If you also want to summarize data for sender objects parallel to the receiver object, set the *Summarize partner by level* indicator. You can only use this indicator if the rollup is a hierarchical rollup.

If you want to output a list containing details on all the records read and created during the rollup execution, set the *Detail list* indicator.

Processing time could take longer if you are processing a large volume of data and set the *Detail list* indicator.

5. You can use the following additional functions in this screen:

**Additional Functions (Screen Execute Rollup <Name of Rollup>: Parameter Screen)**

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → Export File</td>
<td>Import data from a sequential file or PC file or export data to a sequential file or PC file.</td>
</tr>
</tbody>
</table>
Executing Rollups

<table>
<thead>
<tr>
<th>Extras → History</th>
<th>View the execution history of the rollup.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → Delete History</td>
<td>Delete the execution history information for the rollup.</td>
</tr>
<tr>
<td>Extras → Document Rollup</td>
<td>Document the rollup definition and record results of the rollup.</td>
</tr>
</tbody>
</table>

6. Choose 🎨.

**Result**

A list of the records read and created for the executed rollup appears.
Exporting/Importing Rollup Data

Use
You can export/import rollup data to/from a PC file. This is advantageous when rolling up data across separate R/3 Systems or clients.

Procedure
You are now in the Execute Rollup <Name>: Parameter screen.

1. Choose Extras → Export File.
   A dialog box appears, displaying the options for importing/exporting rollup data.

2. Enter the following information:
   - **Input data fields:**
     You enter values in these fields when you want to import the rollup data from a sequential file or PC file.
     Enter the file name from which you want to import data in the field under the file type you have marked.
   - **Output data fields:**
     You enter values in these fields when you want to export the rollup data to a sequential file or PC file.
     Enter the file name to which you want to export data in the field under the file type you have marked.

3. Choose .

Result
When you execute the rollup, the system imports the data from or exports the data to the files you have specified.
Deleting Rollups

Use
If you delete a rollup, do not delete the rollup ledger that is assigned to it. You should delete only the rollup definition that is used to define how the data is summarized in the rollup ledger.

⚠️ You should only delete a rollup definition from your productive system if this is absolutely necessary.

Procedure
   The Delete Rollup: Initial Screen appears.
2. Enter the name of the rollup that you want to delete.
3. Choose ✅.
   A dialog box appears, asking you if you want to delete the rollup.
4. To delete the rollup, choose Yes.

Result
The system has deletes the rollup definition. You cannot restore a rollup definition after it has been deleted.
Changing Rollups

Use

⚠️

You should use caution when changing the structure of your productive system. Structure changes that you make in a productive system may violate the integrity of your data.

If you need to change a rollup definition, proceed as follows.

Procedure


   The Change Rollup: Initial Screen appears.

2. Enter the name of the rollup that you want to change.

3. Choose Rollup header.

   The Change Rollup <Name>: Header screen appears.

4. Type over existing values with your changes.

5. To save your changes, choose Rollup → Save.
Planning

Use

Using the Flexible General Ledger, you can carry out multidimensional planning. Not only can you plan for accounts as in the previous general ledger, you can also plan for other dimensions (cost center, profit center, and so on).

Prerequisites

You have made the Customizing settings for planning in the Flexible General Ledger Implementation Guide.

If you want to use dimensions other than the account level for planning, you have to create a set which contains the corresponding dimensions. The “account” dimension may not be contained in this set. You create sets for planning in the Flexible General Ledger Implementation Guide.

Features

You have the following functions available for planning:

- Planning for accounts (balance sheet/ profit and loss version)
- Planning for other account assignments/dimensions of the general ledger (that is, the dimension contained in the R/3 system, such as cost center and profit center)
- Planning for you own account assignments (fields with which you have expanded the Flexible General Ledger)

Activities

To set up planning, choose Period processing → Planning from the Flexible General Ledger menu.

You always access planning via the balance sheet/profit and loss version. If you want additional account assignments for planning, enter a set with the corresponding account assignments or dimensions in the “Additional account assignments” field.

The procedure for planning corresponds to the planning procedure in the application component Special Purpose Ledger (FI-SL). Following is a description of the planning function as found in the FI Special Purpose Ledger documentation. Different than planning in the Special Purpose Ledger, no distinction is made in the Flexible General Ledger between local ledgers and global ledgers. There are only local ledgers in the flexible general ledger.
Planning

Purpose
With the Planning function in the Special Purpose Ledger [Ext.], you can enter and distribute plan data to create budgets, forecasts, and other reports.

You can quickly and easily enter large amounts of plan data. Generally, you can enter plan amounts in the following ways:

- You can enter amounts as plan totals that are (automatically or manually) distributed to the planning periods.
- You can enter amounts as period amounts that are automatically totaled.
- You can enter a combination of both totals and period amounts.

For information on creating plan data, see Creating Plan Data [Page 152].

Implementation Considerations
Before you can complete planning in the Special Purpose Ledger, you have to set up planning in Customizing. For more information, see Setting Up Planning [Page 148].

Integration
You can transfer plan data from the following SAP components to complete planning:

- Overhead Cost Controlling (CO-OM)
- Profitability Analysis (CO-PA)

To transfer data, choose Accounting → Financial accounting → Special Purpose Ledger → Periodic processing → Data transfer → CO plan data object/document or CO-PA plan data.

CO plan data is only posted directly to FI-SL when a plan version is defined for the ledger to which the CO data is to be posted. If you want to post planning data to a FI-SL ledger, you must maintain a plan version for the ledger in Customizing. Additionally, you have to activate plan integration in Controlling Customizing.

Features
The following options are available in Special Purpose Ledger planning:
Planning

- Your planning can be completed centrally or locally. When setting up planning, you provide a framework for the individual planners and assign authorizations. You can also adapt the entry screen layout.

- You can use Microsoft Excel to enter the data. The individual planners can enter their plan data using Microsoft Excel. You can then import this plan data to the SAP System. See Excel Integration in Planning [Ext.].

- You can post plan data to a nearly unlimited number of forecast versions per year. You define plan versions in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Planning → Plan Settings → Maintain Plan Versions [Ext.].

- You can use existing actual and/or plan data (for example, from previous years) as a reference for a new plan. To do so, choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Copy model plan → Local or Global. See Using a Model Plan [Page 197].

- You can compare actual and plan data.

- You can display totals records of your plan data. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Display totals. See Displaying Totals Records [Page 198].

- You can display individual plan documents. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Display plan documents. → Local or global plan documents. See Displaying Plan Documents [Page 200].

- With the allocation functions, you can assess or distribute plan data. To do so, choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Planned close → Plan assessment or Plan distribution.

- With rollups [Ext.] you can summarize plan data.
Master Data and Planning

Planning uses master data to validate entries and to store other master data information. If no master data exists for the dimensions of your plan sets, the system cannot check the values entered. In this case, you would receive an error message.

If your set contains the cost centers 100 and 200, but these cost centers are not in the master data, the system displays an error message.

Master data information may be located in different places in the system. When the system searches master data information, it checks the settings in Customizing. The master data being searched for is stored here.

For information about defining and editing FI-SL master data, see Creating Master Data [Ext.].
Setting Up Planning

Purpose
Before you can complete planning in the Special Purpose Ledger, you have to set up planning in Customizing.

The activities for setting up planning are found in Customizing under Financial Accounting → Special Purpose Ledger → Planning.

Process flow
You have to complete the following activities:

1. Define one or more planning layouts [Page 149].
   For each planning layout, you determine which summary table your planning is to be based on, which characteristics and key figures are to be used, and the layout of the creation screen. You can also enter certain values for selected characteristics and key figures.
   You define a planning layout for each variant of your planning.

2. Define one or more planner profiles [Page 150] and assign the desired planning layouts to each planner profile.
   Planner profiles are used to provide the individual planner a selection of the plan tasks that are created for his/her area of responsibility.
   With a planner profile, you control the planning process. For each summary table, you determine which plan tasks are to be used, that is, which planning layouts with which default parameters. You also determine which users are allowed to complete which planning activities by assigning an authorization group to each planner profile.

3. A planner profile must be assigned to each user who is to carry out planning. To assign a planner profile, from the main menu choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Set planner profile.

Result
You have set up planning. The individual planners can now enter their plan data. You can read more about how to create plan data and the functions available in Entering Plan Values [Page 153].
Planning Layout

Definition
Form that determines how planning is carried out based on the characteristics and key figures of a summary table and how the screen is set up for completing planning.

Use
Since the tables you installed serve as the basis in the Special Purpose Ledger, you have to specify the tables on which the planning layout is based.

With a planning layout, you define:

- How you want to carry out planning, based on the characteristics and key figures
- How the screen is set up for planning, that is, you define how the characteristics and key figures are arranged
- Whether you want to enter default values of intervals for selected characteristics and key figures
- Whether you want to include actual key figures in your planning

You define planning layouts in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Planning → Define Planning Layout [Ext.].

Planning layouts are created using the Report Painter [Ext.]. You can use all the functions of the Report Painter when editing your planning layouts.

💡 You cannot use sets for periods in your planning layout.

Structure
A planning layout consists of the following parts:

- **Header area**
  - The header area is defined by the general selection criteria.

- **Key column(s)**
  - The key columns contain the characteristics that identify the individual lines in the planning layout, such as account or cost center.

- **Value columns**
  - The value columns contain the key figures to be planned, that is, the plan values.
Planner Profile

Definition
Hierarchically structured overview of plan tasks [Ext.].
Defined per summary table in a planner profile are the plan tasks and the order they are used in planning.

Use
Planner profiles are used to provide the planner a selection of the plan tasks that are created for his/her area of responsibility. Before a planner can start planning, he/she has to assign a planner profile to him/herself.

With planner profiles, you control the planning process. For each summary table, they determine which plan tasks are used with which default parameters. For each table, you can create multiple plan tasks.

The plan tasks are assigned to a planner profile and profile items. The profile items determine the order of the plan tasks in a planner profile. You can assign the same plan task multiple times to a planner profile, but only with different default parameters.

In a planner profile, you set the following default parameters for planning:

- **Authorizations**
  You can assign an authorization group to each planner profile.
  By defining planner profiles specifically for the planners and by assigning corresponding authorization groups to the planner profiles, you can ensure that the individual planners can only complete planning in their individual areas of responsibility.

- **Default parameters**
  You can assign default parameters to your planning layouts. The combination of planning layout and default settings is a plan task.
  With the default parameters, you provide default values for variables of a planning layout.
  In a planner profile, you define whether values can be overwritten when completing planning.

You define planner profiles in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Planning → Define Planner Profile [Ext.].

⚠️
When defining the planner profile, you can set an indicator for the second and third currencies, so that entries can be made in these fields. This allows you to make entries in these currencies without the amounts in the first currency being translated to the second and third currencies.

If this indicator is not set, the amounts in the first currency are automatically translated into the second and third currencies, if you have included these fields in your planning.
Structure
Planner profiles are structured hierarchically.
General planner profiles
  Plannable tables
    Plan tasks for a table
    Default parameters

Integration
You can use planner profiles from other application components such as Profitability Analysis (CO-PA) or Cost Center Accounting (CO-OM) and enhance them to include plan tasks from the Special Purpose Ledger.
Creating Plan Data

Use
You have various options available to you for creating and displaying plan data.

- You can create your plan data in a R/3 screen. See Entering Plan Values [Page 153].
- You can activate Microsoft Excel as an interface for entering your plan data. See Excel Integration in Planning [Ext.].

When entering plan data, various functions such as copy, cut, and paste are available. See Planning Functions [Page 155].

Prerequisites
Before you can enter plan data, your planning has to be set up, that is, your planner profiles and plan tasks have to be defined. For more information, see Setting Up Planning [Page 148].
Creating Plan Data

Use

The following options are available for creating plan data:

- You can create plan data by entering plan totals, which you then distribute to the individual plan periods using a distribution key [Page 176].
- You can enter plan data for the individual plan periods and have the system total these amounts.
- You can enter both total amounts and period amounts.

Prerequisites

Before you can enter plan data, the following settings have to be made:

- Planning must be set up. For more information, see Setting Up Planning [Page 148].
- A planner profile has to be assigned to you, that is, a planner profile and the related summary table must be entered in your user master record. To assign a planner profile, from the main menu choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Set planner profile.

Procedure

To create plan data, proceed as follows:

1. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Planned values → Enter.

   The initial screen appears. In the initial screen, the first plan task of the current planner profile is displayed. You can switch between the plan tasks of the planner profile. To do so, choose or.

   The system displays the planner profile that was last saved in your user master record. If, for example, you completed a planning session in the planning tool [Page 193], the planner profile from this session is displayed.

2. Enter values for the characteristics.

   You can overwrite default characteristic values, if they are defined in the plan task as such.

   If fixed values were preassigned for all characteristics when the plan task was defined, the overview screen is displayed, that is, you can enter the plan data directly.

3. Choose.

   The overview screen appears.

4. Enter your plan data.
Creating Plan Data

The following functions are available for entering and processing plan data. You can find the documentation for these functions under Planning Functions [Page 155].

5. Save your entries.

6. Select a plan value with the cursor and choose ☐.

The period screen appears.

7. The system displays the distribution of the selected plan value to the individual periods. You can switch between the screens of the individual periods. To do so, choose ⬇️ or ⬆️.

The distribution depends on the distribution key [Page 176] that was entered when the plan task was defined. The following options are available for distributing a plan value to periods.

− You can change the distribution key in the overview screen.
− You can overwrite the displayed period values. The new is automatically stored under the manual distribution key 0 when saving and the new plan total is calculated.

8. Save your changes.
Planning Functions

Use

When creating and editing plan data, various functions are available such as cut, copy, and paste. You can also enter a long text.

Features

The following functions are available:

- Reload data [Page 156]
- Reverse row/Entries, restore [Page 157]
- Cut [Page 158]
- Copy [Page 160]
- Insert [Page 162]
- Change values [Page 164]
- Line item display [Page 165]
- Long text [Page 166]
- Target value search [Page 167]
- Sort [Page 169]
- Print preparation [Page 170]
- Number format [Page 171]
- Key columns [Page 172]
- Header display on/off [Page 174]
- All key values on/off [Page 175]
Reload Data

**Use**

With this function you can reload plan or actual data, that is, you can update this information. This function is useful in the following cases:

- If you want to display actual data in your plan task, you can update the data.
- If you are working with several people on a plan task, you can display the current plan values.
Clear Row, Undo, Redo

Clear Row
This function is only active when you make an entry that is not allowed.

It allows you to reverse the entries made in the row where the error occurred, thus returning the row to its last valid state in the planning session. The system then continues checking the entries with the next row.

Undo
This function (pushbutton 🔄) reverses all the entries in the last dialog step. The system always stores the five last states so that you can restore these. However, these states are lost each time you switch from the overview screen to the period screen or back. After that you can no longer undo the previous step.

💡
If you choose this function by mistake, you can “undo” the “undo” using the Redo function.

Redo
The Redo function (pushbutton 🔄) is only active after you have used the Undo function.
Cut

Use

This function lets you move all the data in the selected range to the clipboard. When you do that, the system clears the selected cells.

You can select any of the following:

- An entire value column
- A block within a value column
- A block of value cells within a row

You can select an entire column by clicking on the column header. To select a block, use the Select block function. You can also select areas by positioning the cursor. The system interprets the cursor position as follows:

<table>
<thead>
<tr>
<th>Where is the cursor?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>in a lead column (not a blank row)</td>
<td>the row where the cursor is positioned</td>
</tr>
<tr>
<td>on a data cell (not a blank row)</td>
<td>the cell where the cursor is positioned</td>
</tr>
<tr>
<td>any other position</td>
<td>nothing</td>
</tr>
</tbody>
</table>

If you have explicitly selected a block or entire column, the system ignores the cursor position.

Prerequisites

The selected area may not contain any attribute cells (such as distribution keys), since these cannot be cleared.

Features

When you choose Cut, all the selected cells are cleared (set to "0") and the values contained there are moved to the clipboard. The contents are the clipboard are

- Overwritten, the next time you use the Cut or Copy function or
- Deleted as soon as you switch from the overview screen to the period screen or back.

The function Paste [Page 162] lets you insert the values from the clipboard to another position on the entry screen.

If you want to reverse the Cut function, choose Undo entries or the corresponding icon.
Copy

Use

This function lets you copy all the data in the selected range to the clipboard. You can select any of the following:

- An entire value column
- A block within a value column
- A block of value cells within a row
- An entire row

You can only paste a row into another row if the target row is ready for input. Consequently, the screen must contain rows that are ready for input before you can copy entire rows to the clipboard.

You can select an entire row or column by clicking on the row or column header. To select a block, use the Select block function. You can also select areas by positioning the cursor. The system interprets the cursor position as follows:

<table>
<thead>
<tr>
<th>Where is the cursor?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>in a lead column (not a blank row)</td>
<td>the row where the cursor is positioned</td>
</tr>
<tr>
<td>on a data cell (not a blank row)</td>
<td>the cell where the cursor is positioned</td>
</tr>
<tr>
<td>any other position</td>
<td>nothing</td>
</tr>
</tbody>
</table>

💡 If you have explicitly selected a block or entire column, the system ignores the cursor position.

Features

When you choose Copy, the values contained in the selected cells are copied to the clipboard. The contents are the clipboard are

- Overwritten, the next time you use the Cut or Copy function or
- Deleted as soon as you switch from the overview screen to the period screen or back.

The function Paste [Page 162] lets you insert the values from the clipboard to another position on the entry screen.
Paste

Prerequisites
You can only use this function if you have already cut or copied data to the clipboard. For details, see Cut [Page 158] and Copy [Page 160].

Use
The function Paste lets you insert the values from the clipboard to the selected area on the entry screen.

Where the data is inserted depends on what is in the clipboard and what you have selected (either explicitly or by positioning the cursor) on the entry screen.

<table>
<thead>
<tr>
<th>What is in the clipboard?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>an entire column</td>
<td>You can select either the entire target column or the first cell in that column.</td>
</tr>
<tr>
<td>an entire row</td>
<td>You can either select the entire target row (blank row) or position the cursor on the target row in the lead column.</td>
</tr>
<tr>
<td>a block within a column</td>
<td>Select the first cell (on the left) of the area where you want to insert the data from the clipboard. The data is inserted there and in the cells to the right.</td>
</tr>
<tr>
<td>a block within a row</td>
<td>Select the first cell (on the left) of the area where you want to insert the data from the clipboard. The data is inserted there and in the cells to the right.</td>
</tr>
</tbody>
</table>

 nok
If you have explicitly selected a block or entire column, the system ignores the cursor position.

Tips
When using the Paste function, note the following:

- You can copy entire rows to the clipboard. If you do, you can only insert the row in a blank row that allows data entry.
  The system inserts the characteristic values in the lead columns along with the values in the value columns. However, if you only copied the row, note that the combination of characteristics already exists. You therefore need to change the new row.

- If some cells in the target range are in display mode, the values in those cells are not overwritten. However, if you change values that are used to calculate other values, this could also change those calculated values, even if they are in cells that are not ready for input.

- The Paste function does not change or delete the content of the clipboard.
If you want to reverse the Cut function, choose Undo entries or the corresponding icon.
Change Values

Use
To use the function Change values, you first need to select a range of data cells that does not contain any attributes (such as distribution keys). You can then change the values in the selected range using the functions Revaluate and Add.

Features
- Revaluate
  This function increases the values in the selected cells by a percentage that you enter. You can also enter a negative sign, in which case the values in the selected cells are decreased by that percentage.

- Add
  The Add button lets you add the value you specify in the Value field to the values in the selected cells. Again, you can enter a negative sign, in which case the value you entered is subtracted from the previous values.

  If you want to reverse the Change values function, choose Undo entries or the pushbutton (see Clear Row, Undo, Redo [Page 157]).
Line Item Display

Use
With this function, you can display the change documents of a plan value.
Long Text

Use
With this function, you can create a long text for a plan value or display an existing long text. If, for example, you are working together with several people on the planning, you could enter explanations for the individual plan values.

Features
You create long texts with the SAPscript [Ext.] editor. All the functions of this editor are available.
Goal Seek Function

Use

The goal seek function is used in manual planning to find the content of a cell automatically by referencing another cell that shares the first cell's function. The cell whose content is to be sought is referred to as the source cell. The target cell must be linked to the source cell by a formula and must represent the result of this formula.

You can enter a value - the target value - for the target cell in the goal seek function. After the function has been carried out, the value necessary for reaching the target value is written to the source cell. In this way, the system simulates manual entry.

Your planning layout contains, among others, the following columns: planned revenue, planned quantity and planned price. The planned revenue is the product of planned quantity and planned price.

When entering planning figures, you can use the goal seek function to produce in the planned price cell the value required in order to attain a certain target revenue, such as 120,000 USD. Select the planned price as the source cell and the revenue as the target cell. Ensure that there is a value in the planned quantity cell.

![Diagram showing goal seek function](image)

Since the source cell must always be the cell unlocked for manual entry, the system automatically designates as source cell that cell of the selected pair that is unlocked. If both of the selected cells are unlocked for entry, you can switch the cells round after having selected the goal seek function and then specify the source cell.

Prerequisites

- Your current planning layout should always contain formulas or ratios.
Goal Seek Function

- You need to select two cells and ensure that at least one of those selected - the **source cell** - is unlocked for manual entry.
- All cells used to calculate between the source and target cells must have entries.
- Neither of the selected cells should be the totals row.

**Activities**

1. Select just two cells.
2. Choose *Edit → Goal seek*.
3. If necessary, change around the source and target cells.
4. Enter a target value.
5. If you want to cancel the result produced by the goal seek function, choose *Edit → Undo → Undo entry.*
Insert

This function lets you insert new lines between existing ones.
Format to Print

This function lets you display the data you are currently displaying in list form, so that you can then do the following:

- print it
- send it as an attachment in SAPmail
- save it in a report tree
- download it to a file on your PC

It is technically not possible to print directly from the data entry screen. Consequently, the system formats all the data that meets the current selection criteria as a report list. This list looks exactly like the data entry screen. This means, for example, that if you change the width of a column on the entry screen, that will affect the width in the report list. It is not possible to change the report list directly.
**Number Format**

This function lets you change the way the values in a specific column are displayed. For example, you can display the values in millions with one decimal place. This does not affect the way the data is stored.

💡

The number formats used when you first call up the planning screen are taken from the definition of the planning layout.
Lead Columns

Use

When planning data is entered, the total for all entries in the planning layout is always displayed in several lead columns. Furthermore, you can choose to have a subtotal displayed for each characteristic in the lead column. To make this setting, select/deselect the option Total in the relevant dialog box. If you are working with two lead columns and you select the option Total for just one of them, all the value fields for the characteristics in the other lead column are then summarized.

Planning layouts with only one lead column are the exception. The default setting is for no total to be displayed, but you can have it displayed by selecting the option Total.

With the default settings, an overview screen could appear as in the following example:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
</tr>
<tr>
<td>4711</td>
<td>410000</td>
<td>20</td>
</tr>
<tr>
<td>4711</td>
<td>420000</td>
<td>30</td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
</tr>
<tr>
<td>4712</td>
<td>410000</td>
<td>50</td>
</tr>
<tr>
<td>4712</td>
<td>420000</td>
<td>60</td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
</tr>
<tr>
<td>4713</td>
<td>410000</td>
<td>80</td>
</tr>
<tr>
<td>4713</td>
<td>420000</td>
<td>90</td>
</tr>
<tr>
<td>*Cost center</td>
<td>*Cost element</td>
<td>450</td>
</tr>
</tbody>
</table>

If you select the option Total in the dialog box for the cost center, the following representation appears:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
</tr>
<tr>
<td>4711</td>
<td>410000</td>
<td>20</td>
</tr>
<tr>
<td>4711</td>
<td>420000</td>
<td>30</td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
</tr>
<tr>
<td>4712</td>
<td>410000</td>
<td>50</td>
</tr>
<tr>
<td>4712</td>
<td>420000</td>
<td>60</td>
</tr>
<tr>
<td>*Cost center</td>
<td>*Cost element</td>
<td>60</td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
</tr>
<tr>
<td>4713</td>
<td>410000</td>
<td>80</td>
</tr>
<tr>
<td>4713</td>
<td>420000</td>
<td>90</td>
</tr>
<tr>
<td>*Cost center</td>
<td>*Cost element</td>
<td>150</td>
</tr>
</tbody>
</table>

*Cost center  *Cost element  450
In Customizing, you can make the subtotals be displayed using default parameters: when you are in CO-PA, you do this in the parameter set, when you are in other applications, you do this during planner profile definition. When entering planning data in the application, you can alter this setting for the duration of that planning session.

Activities

By choosing Settings → Lead Columns... in Customizing as well as in the application, you can access the dialog box to set the subtotals display.
Header Display On/Off

Use

The function *Header display on/off* allows you to display or hide information at the top of the overview screen and of the period screen. The setting is only valid during that particular planning session.

Activities

Choose *Settings → Header display on/off*. 
All Key Values On/Off

Use

In planning layouts containing with several lead columns, it can occur that several characteristic values relate to the same value in another column. In such cases, the system default is to display the repeated characteristic only once in the overview screen.

By choosing Settings → All key values on/off, you can set the repeated characteristic values to be displayed or hidden. The selected setting, however, is only valid for the planning session you are working in.

Standard Setting All Key Values Off.

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brown plc</td>
<td>Pump P-100</td>
<td>100 000.00</td>
</tr>
<tr>
<td></td>
<td>Pump P-110</td>
<td>50 000.00</td>
</tr>
<tr>
<td></td>
<td>Pump P-200</td>
<td>120 000.00</td>
</tr>
<tr>
<td>Smith Ltd</td>
<td>Pump P-200</td>
<td>200 000.00</td>
</tr>
</tbody>
</table>

All Key Values On

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brown plc</td>
<td>Pump P-100</td>
<td>100 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-110</td>
<td>50 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-200</td>
<td>120 000.00</td>
</tr>
<tr>
<td>Smith Ltd</td>
<td>Pump P-200</td>
<td>200 000.00</td>
</tr>
</tbody>
</table>

In order that you can distinguish the initial value of a characteristic from a hidden value, the initial value is displayed with the special character "#".
Distribution Key

Definition
Key which specifies the rules to be used to distribute a plan value to the individual plan periods.

Use
With the distribution key, you distribute your plan values or plan totals for the year to the individual plan periods. The distribution key contains information on the rules used for distribution.

Structure
The following distribution keys are available:

- **Standard distribution keys**
  You can use the standard distribution keys that are included in the standard system. See [Standard Distribution Keys](Page 178).

- **Customer-defined distributions keys**
  You can define your own distribution keys to meet your specific needs. You can specify that each period receive a relative portion of the plan total. See [Defining a Distribution Key](Page 183).

Integration
Distribution keys are application independent, that is, you can use distribution keys from other applications such as Controlling when planning in the Special Purpose Ledger. You can also use distributions keys you created for planning in the Special Purpose Ledger in other applications.
Standard Distribution Keys

Use

SAP provides the following standard distribution keys:

- **Distribution key 0**
  Used to enter values manually for each period.

- **Distribution key 1**
  Used to distribute the input value (annual plan value) equally across all plan periods.

- **Distribution key 2**
  Used to distribute the input value (annual plan value) according to the last distribution key used.

- **Distribution key 3**
  Interprets the input value as a percentage rate and multiplies it each period by the previous value.

- **Distribution key 4**
  Used to distribute period values not equal to zero to the subsequent empty periods.

- **Distribution key 5**
  Copies period values not equal to zero to the subsequent empty periods.

The SAP R/3 System differentiates between true distribution keys and input help.

- If a plan value is distributed on periods using a true distribution key, the sum of all period values always equals the sum of the original plan values entered.
- If you use an input help, the original value entered may change.

  The standard distribution keys 0, 3, 4, and 5 are input helps only. You change the entered parameters. The system does not save these distribution keys. This is so that new changes to the plan values can be avoided. Instead, it resets them to zero after use.

- **Distribution key 6**
  Copies a given period value to subsequent periods.

  This distribution key has no effect on the manually planned values, as it is used on the period level. The distribution keys are, however, available on the annual level.

- **Distribution key 7**
  Used to distribute the input value (annual plan value) among the individual periods in line with the number of calendar days per period.

- **Distribution key 11**
Can only be used in Cost Center Accounting for planning activity-dependent costs or activity-dependent statistical key figures.

The input value (annual plan value) is distributed in line with the activity quantity planned on the cost center.

⚠️

The R/3 System uses only those activity quantities planned at the time of the distribution key’s use. If you change activity quantities later or copy plan values to another version, the R/3 System does not automatically carry out new distributions.
Examples of Standard Distribution Keys

The following graphics illustrate distribution, based on the various distribution keys. The examples use monthly planning. Distribution keys can also be used in the same manner for other period cycles (for example, quarterly planning).

### Distribution Key 0
- **Individual values entered manually for each period**

<table>
<thead>
<tr>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
</tr>
<tr>
<td>3</td>
<td>1,500</td>
</tr>
<tr>
<td>4</td>
<td>1,500</td>
</tr>
<tr>
<td>5</td>
<td>2,000</td>
</tr>
<tr>
<td>6</td>
<td>2,500</td>
</tr>
<tr>
<td>7</td>
<td>2,500</td>
</tr>
<tr>
<td>8</td>
<td>2,500</td>
</tr>
<tr>
<td>9</td>
<td>2,000</td>
</tr>
<tr>
<td>10</td>
<td>2,000</td>
</tr>
<tr>
<td>11</td>
<td>2,000</td>
</tr>
<tr>
<td>12</td>
<td>1,500</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td><strong>24,000</strong></td>
</tr>
</tbody>
</table>

### Distribution Key 1
- **Equal distribution across the individual periods**

<table>
<thead>
<tr>
<th>Input value: 24,000</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td><strong>Total</strong></td>
</tr>
</tbody>
</table>

### Distribution Key 2
- **Distribution according to an existing distribution**

<table>
<thead>
<tr>
<th>Input value: 36,000</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td><strong>Total</strong></td>
</tr>
</tbody>
</table>

### Distribution Key 3
- **Input value is interpreted as a percentage and refers to previous values**

<table>
<thead>
<tr>
<th>Input value: 50(%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td><strong>Total</strong></td>
</tr>
</tbody>
</table>
Examples of Standard Distribution Keys

<table>
<thead>
<tr>
<th>Distribution Key</th>
<th>4</th>
<th>Distribution Key</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period values are distributed to subsequent empty periods</td>
<td></td>
<td>Period values are copied to subsequent empty periods</td>
<td></td>
</tr>
<tr>
<td>Period</td>
<td>Input</td>
<td>Subs. value</td>
<td>Period</td>
</tr>
<tr>
<td>1</td>
<td>8,000</td>
<td>2,000</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
<td>2,000</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>2,000</td>
<td>2,000</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>2,000</td>
<td>2,000</td>
<td>4</td>
</tr>
<tr>
<td>5</td>
<td>10,000</td>
<td>2,500</td>
<td>5</td>
</tr>
<tr>
<td>6</td>
<td>2,500</td>
<td>2,500</td>
<td>6</td>
</tr>
<tr>
<td>7</td>
<td>2,500</td>
<td>2,500</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>2,500</td>
<td>1,500</td>
<td>8</td>
</tr>
<tr>
<td>9</td>
<td>6,000</td>
<td>1,500</td>
<td>9</td>
</tr>
<tr>
<td>10</td>
<td>1,500</td>
<td>1,500</td>
<td>10</td>
</tr>
<tr>
<td>11</td>
<td>1,500</td>
<td>1,500</td>
<td>11</td>
</tr>
<tr>
<td>12</td>
<td>1,500</td>
<td>1,500</td>
<td>12</td>
</tr>
<tr>
<td>Total</td>
<td>24,000</td>
<td></td>
<td>Total</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Distribution Key</th>
<th>6</th>
<th>Distribution Key</th>
<th>7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period value is copied to subsequent periods</td>
<td></td>
<td>Input value is apportioned to the periods based on the number of calendar days in each period</td>
<td></td>
</tr>
<tr>
<td>Period</td>
<td>Prev. value</td>
<td>Input</td>
<td>Subs. value</td>
</tr>
<tr>
<td>1</td>
<td>2,000</td>
<td>2,000</td>
<td>2,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
<td>3,000</td>
<td>3,000</td>
</tr>
<tr>
<td>3</td>
<td>2,000</td>
<td>3,000</td>
<td>3,000</td>
</tr>
<tr>
<td>4</td>
<td>2,000</td>
<td>3,000</td>
<td>3,000</td>
</tr>
<tr>
<td>5</td>
<td>2,000</td>
<td>3,000</td>
<td>3,000</td>
</tr>
<tr>
<td>6</td>
<td>2,000</td>
<td>3,000</td>
<td>3,000</td>
</tr>
<tr>
<td>7</td>
<td>2,000</td>
<td>2,500</td>
<td>2,500</td>
</tr>
<tr>
<td>8</td>
<td>2,000</td>
<td>2,500</td>
<td>2,500</td>
</tr>
<tr>
<td>9</td>
<td>2,000</td>
<td>2,500</td>
<td>2,500</td>
</tr>
<tr>
<td>10</td>
<td>2,000</td>
<td>2,500</td>
<td>2,500</td>
</tr>
<tr>
<td>11</td>
<td>2,000</td>
<td>2,000</td>
<td>2,000</td>
</tr>
<tr>
<td>12</td>
<td>2,000</td>
<td>2,000</td>
<td>2,000</td>
</tr>
<tr>
<td>Total</td>
<td>24,000</td>
<td></td>
<td>31,000</td>
</tr>
</tbody>
</table>
### Distribution Key

<table>
<thead>
<tr>
<th>Distribution Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
</tr>
</tbody>
</table>

### Input value is apportioned to the costs centers corresponding to the activity quantity (only applies to Cost Center Accounting)

### Input value: 24.000

<table>
<thead>
<tr>
<th>Period</th>
<th>Planned activity</th>
<th>Subs. value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>30h</td>
<td>3,000</td>
</tr>
<tr>
<td>2</td>
<td>60h</td>
<td>4,000</td>
</tr>
<tr>
<td>3</td>
<td>45h</td>
<td>4,500</td>
</tr>
<tr>
<td>4</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>5</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>6</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>7</td>
<td>30h</td>
<td>3,000</td>
</tr>
<tr>
<td>8</td>
<td>60h</td>
<td>6,000</td>
</tr>
<tr>
<td>9</td>
<td>45h</td>
<td>4,500</td>
</tr>
<tr>
<td>10</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>11</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>12</td>
<td>15h</td>
<td>1,500</td>
</tr>
</tbody>
</table>
Defining a Distribution Key

Use
In addition to the standard distribution keys [Page 178] included in the standard system, you can also define your own distribution keys [Page 176] to allow for variances such as seasonal fluctuations.

For each distribution key, you define which periods receive distribution amounts, and for each period, how much of the total amount the period receives.

Features
The following functions are available:

- Create
  You can create a distribution key. One possibility is to use an existing distribution key as a reference and to adjust it as needed.

  ![Note]

  If the referenced distribution key is one of the standard distribution keys (delivered with your system), you cannot change the number of periods or the relative factor of the distribution key.

- Change
  You can change a distribution key. Note that if plan data was already distributed with this key, this data is not affected by these changes.

- Display
  You can display a distribution key.

- Delete
  You can only delete a distribution key if it is not used in existing plan tasks or planning layouts. You cannot restore a distribution key once it has been deleted.

Activities
To define or edit a distribution key, in Customizing choose Accounting → Financial Accounting → Special Purpose Ledger → Planning → Plan Settings → Define Distribution Key [Ext].
Flexible General Ledger (FI-GL)

Excel Integration in Planning

Excel Integration in Planning

Use
When planning with Excel integration, you use Microsoft Excel as the entry screen for your SAP plan data.

You have the following options when using Excel for the entry of your SAP plan data:

- **Excel as the interface in the SAP System**
  Excel replaces the SAP entry screen. This enables the use of SAP and Excel functions.

- **Local planning in Excel with the upload of plan data to the SAP System**
  Plan data can be entered de-centrally in multiple excel sheets on one or more computers without a SAP connection. This data is imported and combined via an upload to the SAP System. You can then edit the data using the planning functions in the SAP System.

Prerequisites

**Software**
To use the Excel integration function in conjunction with planning, you must have the following software installed on your computer:

- Windows NT 4.0 or Windows 95
- Microsoft Excel 97
- A SAP GUI (32 Bit) that corresponds to your system release

**Hardware**
To obtain faster run times, your PC should have a Pentium II processor and at least 64 MB of memory.

Features

**Connection of Excel and the SAP System**
Technically, Excel is connected to the SAP System using OLE (object linking and embedding), an interface of the Microsoft Office programs. This means that the same Excel functions are available that would be available, for example, when connecting to Word.

For the single planning session, the connection between the Excel sheet and the SAP planning layout is created using the position of the data in the Excel sheet: In Customizing, the SAP System is notified as to the position of the SAP data in Excel. This position may not be changed during the planning session in order to maintain a proper import of the data. The file name is the object that is used for the field assignment between the planning layout and the Excel sheet.

**Restrictions**
You cannot create plan data via a period screen with Excel integration.
Planning with Excel Integration

Use

You can use Microsoft Excel as your interface to enter plan data in the SAP System. Microsoft Excel can be connected to your SAP System as an interface.

Prerequisites

The entry of plan data is based on the planning layout [Page 149]. In order to complete planning using Excel as the creation screen, the following prerequisites have to be met:

- You have to first define the planning layout which serves as the basis for the entry of plan data.

   ![Warning]
   
   If you change a planning layout after creating an Excel template, you can no longer use this Excel template. In this case, you have to create a new Excel template.

- Plan data has to already be in the system that matches the planning layout (at least one row). If no plan data is present, enter this data using the desired planning layout without Excel integration.

Procedure

Preparations for planning with Excel integration

1. In Financial Accounting Customizing, choose Special Purpose Ledger → Planning → Define Planner Profile.

2. Navigate to the desired plan task and set the indicator Excel int. This activates Excel integration for this plan task.

3. Open the default settings for your plan task.

   Enter the values for the variables defined in the planning layout. This entry is necessary so that the Excel sheet can be opened in the next step.

4. Choose This opens Microsoft Excel as the entry screen.

   The system automatically assigns a file name [Ext.]. A connection between the plan task and the Excel spreadsheet is created by the file name, that is, a connection between the cells of the spreadsheet and the cells of the planning layout.

   ![Tip]
   
   You can also enter a file name. To do so, you have to go to the column file name in the plan task when editing your plan task and enter your own file name.

5. This takes you to the screen Maintain File Name with Excel as the entry screen.

   The planning layout is displayed as an Excel spreadsheet. You can individually set up the spreadsheets. Various functions are available for this purpose. For more information see Functions for Editing Excel Templates [Page 191].
7. To save your Excel template, choose the Save icon. This saves your file name and the Excel layout.

8. To return to the default parameters, choose .

9. You can delete the values that you entered for the default parameters, if you do not want to display them for planning. Choose .

⚠️

The default parameters are only temporarily saved at this point. To assign the file name to the planning layout and to save the values for the variables, you have to save the planner profile.

**Entering plan data with Excel as the entry screen**

Once you have set up and activated the Excel integration for a planning layout, you can enter your plan data in the Excel entry screen.

1. Make certain the planner profile and totals table, to which the desired planning layout is assigned, are assigned to your user master data. To assign a planner profile and totals table to your user master data, from the SAP Easy Access menu choose Accounting → Financial Accounting → Special Purpose Ledger → Planning → Set planner profile.

2. From the Special Purpose Ledger planning menu, choose Plan values → Enter. Excel opens as the entry screen within the SAP System. Your planning layout is displayed as an Excel spreadsheet.

3. Enter your plan data.

⚠️

You should **not** use the following functions:

- Delete
- Insert
- Sort

If you use these functions, the data **cannot** be properly imported into the SAP System.

4. Save your plan data.

You can find additional information on creating plan data under Creating Plan Data [Page 153].
Planning Locally with Excel Upload

Use
You can complete planning decentrally with Excel, that is, you enter the plan data locally with multiple Excel files on one or more computers. The plan data entered in Excel sheets can then be imported to the SAP System using an upload.

Prerequisites
Planning with Excel upload is based on the planning layout [Page 149]. In order to prepare and complete the Excel upload, the following prerequisites have to be met for the planning layout:

- You have to first define the planning layout which serves as the basis for the entry of plan data.

If you change a planning layout after creating an Excel template, you can no longer use this Excel template. In this case, you have to create a new Excel template.

- Plan data has to already be in the system and has to match the planning layout (at least one row). If no plan data is present, enter this data using the desired planning layout without Excel integration.

- In order to import the plan data into the SAP System using an upload, you have to enter the characteristic value in the key column of the planning layout used. The characteristic text alone is not enough.

Procedure
Preparing the Excel upload
In order to enter plan data in Excel and to then import it to the SAP System using an Excel upload, you first have to prepare the Excel upload. To do so, you have to set up a connection between the planning layout and the Excel file. Proceed as follows:

5. In Financial Accounting Customizing, choose Special Purpose Ledger → Planning → Define Planner Profile.

6. Goto the desired plan task and set the Excel Int indicator, that is, make certain it is set.

7. Open the default settings for your plan task.

Enter the values for the variables defined in the planning layout. This entry is necessary so that the Excel sheet can be opened in the next step.

8. Choose This opens Microsoft Excel as the entry screen.

The system automatically assigns a file name [Ext.]. A connection between the plan task and the Excel spreadsheet is created by the file name, that is, a connection between the cells of the spreadsheet and the cells of the planning layout.

You can also enter a file name. To do so, you have to go to the column File name in the plan task when editing your plan task and enter your own file name.
5. This takes you to the screen Maintain File Name with Excel as the entry screen. The screen defined in the planning layout is displayed in the upper left hand corner of the Excel spreadsheet. You can individually set up the spreadsheets. Various functions are available for this purpose. For more information see Functions for Editing Excel Templates [Page 191].

6. Under Generic file, enter a generic file name. The generic file name creates the connection between the file on the local PC and the file name during the upload.

⚠️

The generic file name must consist of a group of characters (capitals), the generic sign *, and the file ending .TXT; for example PLANNING*.TXT.

💡

The name ranges of the various generic file names may not overlap, since this would not allow a unique assignment of the local file to the file name. If for example, the generic file name PLAN*.TXT was assigned at one position and PLANN*.TXT at another, the system would not be able to uniquely assign the upload of file PLANN5.TXT.

You can display an overview of all file names with the generic file names. Using the ABAP Editor, start program RKCDPREO. You can delete file names and generic file names from this list, if they are no longer being used.

7. In Excel, save one copy of the Excel file on your computer and give it a name that matches the generic file name. If you, for example, choose SALES*.TXT as the generic file name, you can name the local file on your PC SALES1, SALES2, or SALES_D.

⚠️

As file format, you first have to use the Excel format .XLS. The file can now be opened, independent of the SAP System, in Excel. If you want to upload this file to the SAP System, you have to save the file as a text file (.TXT).

8. Save your file name. To do so, choose Save file name.

9. You can copy the downloaded copy of the Excel sheet as often as needed and make it available for decentral planning.

⚠️

Make certain that the individual file names correspond to the generic file name so that you can upload the data correctly to the SAP System.

Creating plan data locally using Excel

1. Open the downloaded copy of the excel sheet on your local PC.

2. Enter your plan data. During planning, keep a copy saved with the excel format .XLS.

⚠️

Do not use the following Excel functions:
Planning Locally with Excel Upload

- Delete
- Insert
- Sort

If you use these functions, you cannot import the data correctly to the SAP System.

When entering your plan data in the Excel sheet, the following functions are available:

- In a second spreadsheet, you can complete your own calculations or insert diagrams. When saving the Excel folder as a TXT file prior to the upload, only the first spreadsheet page is saved. The additional pages are not relevant for the upload.

- If you want to delete a value for a characteristic, such as cost center, in the SAP System, enter the value 0 for it in the Excel sheet. This is necessary, since all objects contained in the local file are processed during the upload. If you delete the characteristic value in the Excel sheet, it is not reset in the SAP System.

Prior to the Excel upload, complete the following:

- Remove the totals row from the first spreadsheet page. Otherwise, the system searches in the master data for the entry "Total" and the upload is cancelled.

- Save the Excel file using the text format .TXT.

- Make certain that the local file name matches the generic file name in order to ensure a correct assignment to the file name.

Completing the Excel upload

1. To start the upload, from the SAP Easy Access menu, choose Accounting → Financial Accounting → Special Purpose Ledger → Planning → Planned values → Upload from Excel.

2. Enter the file or file directory to be imported.

   The path and file names on your computer, in which your plan data is saved, must not have any spaces, such as the directory "My Documents".

3. In the file name file, you enter a file name, which the system uses to import the file(s). If you do not enter a file name, the system determines the file name automatically using the generic file name.

4. Start the upload.
Functions for Editing Excel Templates

Use

If you implement the Excel integration for entering plan data, you can personally set up the Excel sheet in which you enter the data. The functions for editing the Excel sheet are, however, limited, since the connection of the cells in the sheet to the cells in the planning layout must be kept.

Prerequisites

When you open the Excel input screen from the default settings of a planning layout for the first time, the first Excel sheet is protected. Only the cells, which were also available for input from the SAP entry screen, are excluded from this protection.

If you want to change this Excel sheet, you have to remove the sheet protection in Excel.

You should reset the sheet protection in Excel after editing the sheet. This ensures that any additional entries of plan data are only made for data as defined in the SAP System.

Features

The following functions are available for editing the Excel template:

You should not use the following functions:

- Delete
- Insert
- Sort

If you use these functions, the data cannot be properly imported into the SAP System.

- Move

You can only move plan data within a spreadsheet using the SAP function. To do so, select the data to be moved by choosing and then choosing at the target position. Save the connection of the old position to the new position by choosing Save File name.

- Delete

To delete data, return to the SAP System and choose .

- Insert

Insert new objects to be planned directly under the existing SAP data, for example, below the totals line. To insert, choose (SAP possible entries).
Do not insert any empty rows. The system does not recognize data that is separated from the existing SAP data by a blank row.

- **Insert**
  To insert additional data, from the SAP Menu choose *Edit → Insert.*

- **Formatting cells**
  You can use the formatting functions of Excel to change the font or color, for example.

- **Additional calculations**
  Outside of the SAP data range, you can make additional calculations or evaluations. For example, you could insert diagrams or use formulas and macros.

  SAP recommends you make additional calculations on a second spreadsheet. This ensures that there are no conflicts with the actual plan data during import. SAP plan data is always imported into the SAP System from the first spreadsheet.

- **Formulas**
  You can enter formulas in the **SAP data range.** However, the formula is overwritten by the result when saving and the formula is lost.

- **Save**
  You can save your Excel spreadsheet. To do so, choose *Save Excel layout.*
Working with the Planning Tool

Use
With the planning tool, you can execute the following functions in one step:

- Create a plan task
- Enter default parameters for the plan task
- Execute planning

Working with the planning tool is an alternative method to the activities described in Setting Up Planning [Page 148].

⚠️

The functions of the Report Painter are limited in the planning tool. The planning tool is useful if you want to create less complex planning layouts. If, for example, you want to create planning layouts with formula rows, you should complete this using the alternative individual steps.

Prerequisites
To create a plan task using the planning tool, the planner profile, to which you want to assign this plan task, has to be defined. You define planner profiles in Customizing under Financial Accounting → Special Purpose Ledger → Planning → Define Planner Profile [Ext.].

Features

Screen layout
The screen of the planning tool is made up of two areas:

- Navigation and display areas
  On the Plan task tab, which is on the left-hand side of the screen, the planner profiles with their assigned plan tasks are displayed. On the Online help tab, detailed information on the individual activities is displayed.

- Entry area
  On the right side of the screen, you define your plan task and execute planning.

Functions
The planning tool contains the following functions:

- You can create a plan task and assign it to an existing planner profile.
- You can change an existing plan task. To do so, select a plan task in the Plan tasks tab and choose Change.
- You can still use plan parameters. To import your plan parameters, choose Import Plan. Save the imported data as a plan task.
- You can select or change the characteristics and key figures for a plan task.
- You can display the layout of your R/3 entry screen. To do so, choose Layout.
Working with the Planning Tool

- You can complete planning, that is, you can enter the plan values. For more information, see Creating Plan Data [Page 152]. You can also use Microsoft Excel [Ext.] to enter data. To do so, select Use Excel.

You cannot use sets for periods.

Activities

You can access the planning tool by choosing Accounting → Financial accounting → Special Purpose Ledger → Planning → Plan values → Planning tool.

Detailed information on the individual activities is displayed on the left-hand side of the screen. Choose the information button to display information on the desired field group.
Transferring CO Plan Data

Use
CO plan data can be posted to the Special Purpose Ledger. Certain ledgers can contain certain plan versions.

Prerequisites
CO plan data can only be transferred if the CO plan versions are permitted in your special ledgers.

Note that when you plan in CO in a version which you have not assigned, the plan data cannot be transferred to the ledger. The system does not post an error message.

Ledger Za should contain CO plan data in version 002.
Ledger Z2 should contain CO plan data in version 003.
Both ledgers have the same activities assigned to them.
If you now transfer CO plan data in version 002, the system would post an error message, as ledger Z2 is not assigned to version 002.
If you now transfer CO plan data in version 003, the system would post an error message, as ledger Z1 is not assigned to version 003.
This would lead to the system posting error messages permanently. As a result, no error message is posted.

CO plan data is posted if you have made the following settings in Customizing.

1. In CO Customizing, planning integration must have been activated. Choose Cost Center Accounting → Planning → Planning Aids → Plan Version → Epos and Integration.
   Here, you have to activate plan integration.
   You can activate planning integration for each controlling area, version and fiscal year.

2. In FI-SL Customizing, the plan version that CO is sending must be allowed. Choose Planning → Plan Versions.
   Here, you assign the plan versions that are transferred from CO to the ledger which you want the plan data to be transferred to.

   Here, you make the assignment ledger - version - company code - fiscal year.

4. If you want line items to be updated during transfer of data to FI-SL, set the corresponding flag. In Customizing, choose Planning → Line Items → Activate → Local/Global.
   Here, you can activate line item update at the level ledger - version - company code - fiscal year.
Using a Plan Template

Use
You can use existing actual and/or plan data (for example, from previous years) as a reference for a new plan.

For example, you can use the actual values of the current year as the basis for planning for the next year.

Procedure
To use a plan template, proceed as follows:

1. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Copy model plan → Local (for local ledgers) or Global (for global ledgers).
   The Copy <Local or Global> Data to Plan screen appears.
2. Enter the source ledger and the type of data (such as 0 for actual data, 1 for plan data) you want to copy as well as the target ledger.
3. Activate the Copy data without summarization field group, if you want to copy the data as not summarized or if you want to limit the data selection.
4. You can copy the data without reevaluating it. The following options are available for doing this:
   - You can multiply the existing currency and quantity amounts by a factor. To do so, enter the factor for the currency and quantity amounts.
     The currency amount is 500 and the revaluation factor for currencies (Currencies field) is 2. The plan currency amount in the new plan will be 1000.
   - You can enter a user exit for reevaluating the data.
5. In the field group Existing data, specify whether you want to cumulate the values, that is, if the new plan data should be added to or if it should replace the old plan data.
6. Activate the Background processing indicator, if you want to run this as a batch job.
7. Choose Execute.

Result
If the data was successfully copied, a statistic display shows you how many records were, read, summarized, processed, and created.
Displaying Totals Records

Use

Totals record display [Ext.] is also used in Profit Center Accounting (EC-PCA). See Displaying Totals Records [Ext.].

Procedure

Totals record display is found under Accounting → Financial accounting → Special Purpose Ledger →

- Planning → Display totals
- Actual posting → Display totals
- Information system → Reports for the Special Purpose Ledger → Totals Record Display

To display totals records, proceed as follows:

1. Enter the name of the ledger for which you want to display totals records.
   
   You can define the following:
   
   - In the output list, you can display totals records with a zero value. To do so, select Display zero records.
   
   - Under Settings..., you can directly select the totals records you want displayed.
     
     • You can enter a user table to display its data.
     
     • Under Variant for list, you can select a display variant for the output list. Included in the SAP Standard System are the display variants 0F_1 and 0F_2 for cost of sales ledger 0F.

   ![Tip]

   If you select a display variant, the totals records in the output list are automatically summarized. This means that totals records that match each other as to the displayed key fields are summarized and displayed as one totals record. With Restore, you can display the individual totals records.

   • You can also summarize the totals record when you select the data. To do so, select No individual records.

   ![Tip]

   If you use this function, you increase the performance when generating the output list. However, you cannot display the individual totals records using the restore function.

   - Under Maintain user table..., you can create or change a user table.

2. Choose Execute.

Selection screen

3. Enter your selection criteria.
Enter 0 as the record type to display actual data and 1 to display plan data.
You are also able to display archived totals records. To do so, choose Data sources..., select archive and enter the archive data. For additional information press the information button.

4. Choose Execute.

Output list

5. The totals records you selected are displayed in the output list.

The amounts and totaled amounts are displayed for all currencies kept in the ledger. The amounts are totaled for the posting periods you selected. The totaled amounts consist of the amounts from previous periods and the balance carried forward (period 0).

If you select posting periods 2 to 4 in the selection screen, the totals of periods 2 to 4 are displayed as well as the total of periods 0 to 4.

In the output list, you can:

- You can edit the output list by using display variants, by displaying or suppressing columns, or by forming totals. The functions of the ABAP List Viewer [Ext.] are available for this. You can find additional information on the functions of the ABAP List Viewer under SAP List Viewer (ALV): Classic [Ext.].
- If you suppress individual key fields in the output list, the summarize function is activated. This allows you to summarized the remaining totals records that have the same key fields. With Restore, the summarization is reversed.
- You can display long texts for the dimensions account number, cost center, business area, profit center, and functional area.
- From the output list, you can access the following information on the individual totals records:
  - Period breakdown: You can display period information for an individual totals record. To do so, double-click the totals record.
  - Line items: You can display the original document lines of a totals record if the document lines are stored in a line item table. To do so, double-click the totals record in the period screen.

You can only display a document in FI-SL if the document lines are stored in the line item table or in the source application database (if the document was posted to FI-SL from another application).
Displaying Plan Documents

Use
You can display plan documents that were posted to local and global ledgers.

Prerequisites
To display plan documents, these documents have to stored in the FI-SL line item table of the ledger you want to plan. Before doing so, you have to make the following settings in Customizing:

- The line item indicator must be set for your ledger. You make this setting in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Basic Settings → Master Data → Maintain Ledgers [Ext.].
- You have to activate the update of local or global line items for your ledger. This setting is made in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Planning → Plan Settings → Activate Line Items → Activate Local Line Items [Ext.] or Activate Global Line Items [Ext.].

Procedure
To display a plan document, proceed as follows:

1. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Display plan documents. → Local or global plan documents.
2. Enter your selection criteria:
   - Enter a document number range.
   - Enter the fiscal year, ledger, company code, and document type.
   
   To improve the processing time for displaying plan documents, enter additional ranges of values in the From value and To value fields for the dimensions listed.
3. Choose Execute.
   The output list is displayed.
4. The plan documents you selected are in the output list.

You can edit the output list by using display variants, by displaying or suppressing columns, or by forming totals. The functions of the ABAP List Viewer [Ext.] are available for this. You can find additional information on the functions of the ABAP List Viewer under SAP List Viewer (ALV): Classic [Ext.].
Reporting

Use
As in the previous general ledger, you can use the drilldown reporting method to evaluate your dataset. You have transactions figures and the balance sheet/profit and loss versions available as the basis for evaluations.

A listing method for the display of balance lists is also available.

Prerequisites
If you want to use the drilldown reporting method, you must define forms and reports in Customizing for the Flexible General Ledger.

Features
You can carry out the following evaluations and reports with the Flexible General Ledger.

- List display of balances
- Balance lists based on drilldown reporting
- Financial statements based on drilldown reporting

Activities
- List display of balances
  If you want a list display of the balances, choose Account → Balance list from the Flexible General Ledger menu. Here, you have various functions available, such as summarization of data, Excel export, sort, and drilldown to document level.

- Balance lists based on drilldown reporting
  If you want a balance list based on drilldown reporting, choose Account → Flex. balance analysis from the Flexible General Ledger menu. A SAP report is available here for your use. Additionally, you can define your own forms or reports for balance evaluation.

- Financial statements based on drilldown reporting
  If you want to create a financial statement based on drilldown reporting, choose Periodic processing → Report selection from the Flexible General Ledger menu. A SAP report tree is available, and you can use it for your financial statement. Additionally, you can define your own forms or reports for balance evaluation.
Displaying Account Balances

Use

You can display account balances using the list display method. Here you can see the balances for the dimensions of the Flexible General Ledger selected (account, business area, cost center, and profit center). Additionally, the balances are displayed in all currencies of the general ledger.

Features

The following functions are available for the listing of account balances:

- Print list
- Export list for table calculation or word processing.
- Send list using SAP Office
- Summarize list using certain key fields (such as account)
- Sort list
- Create subtotals using certain key fields (such as account)
- Define variants to be displayed
- You can also use the standard variants provided by SAP.

Activities

If you want a list display of the balances, choose Account → Account balances from the Flexible General Ledger menu.

Enter the relevant selection characteristics (fiscal year, company code, account number, posting period).
Defining Drilldown Reports

Use
You can define the following reports using the drilldown technique.

- Financial statement reports
- Account balances

Prerequisites
In Flexible General Ledger Customizing, you define reports and forms. To do this, in the Flexible General Ledger Implementation Guide select the application area Information System and complete each activity.

Procedure
The procedure for creating reports and forms corresponds to the procedure in the previous general ledger. Here, the differences between the previous general ledger and the Flexible General Ledger are described. The exact procedure can be found in the R/3 Library under Financial Accounting in the General Ledger documentation. Read the “Information System” documentation in this section.

Financial statement reports (one axis with key figures)
The following rules apply to forms:

- Select “One axis with key figure” as the form type.
- In the “Handling the currency” screen, select indicator “Currency per element, with currency translation”. Only one currency is possible for a financial statement report.
- If you want define the characteristics for all columns, choose Edit → General selections → Display/change. Here you enter the general selection criteria such as ledger and business area. You can assign fixed values to these characteristics.
- If you want to define the characteristics of the individual columns, note that you always have to select “Balance sheet value” as the key figure. This value is then entered in the column.

After you have determined the key figure, you can select the characteristics you want such as fiscal year and company code.

Afterwards, enter the values for your characteristics. You can enter either fixed values or variables for your characteristics. Select Variable on/off to enter variables. The entry field is then changed accordingly. Unlike with the present general ledger, there are no predefined global variables. Rather, you have to define local variables at this point. A local variable has to begin with a “$” sign.

The following rules apply to creating reports:

- When determining the breakdown characteristics with Goto → Characteristics, you have to select either “Financial statement item” or “Financial statement item/account”. Additionally, you can select the relevant general ledger dimensions (such as functional area, cost center, and profit center).
- Choose Edit → Hierarchy selection to select the “Financial statement version” indicator.
Defining Drilldown Reports

Note the following when carrying out this report:

- When including a report in the report tree, select application class FBRG.
- To carry out the report, choose Account → More reports in the Flexible General Ledger.

B. Balance sheet key figure reports (2 axes)

The following rules apply to forms:

- Select “Two axes (matrix)” as the form type.
- In the “Handling the currency” screen, select the “Currency per element, with currency translation” indicator. You can only use one currency for a financial statement report.
- If you want define the characteristics for all columns, choose Edit → General selections → Display/change. You have to select “Financial statement version” as a general selection. All other selection criteria are optional, such as ledger, business area. You can assign fixed values to these characteristics.
- If you want to define the characteristics of the individual columns, note that you always have to select “Financial statement item” as the key figure for the first column. On the next screen, position your cursor on the hierarchy nodes button and select the desired financial statement item using the F4 key. You can extend these reports by including the financial statement items desired in the individual rows.
- You can also have values calculated for the individual lines of the key column. To do this, you have to select the “Formula” element type. You can, for example, have totals from the financial statement items be calculated for defined rows.
- If you want to define the characteristics of the other columns, note that you always have to select “Balance sheet value” as the key figure. This value is then entered in the column.

After you have determined the key figure, you can select the characteristics you want such as fiscal year and company code.

Afterwards, enter the values for your characteristics. You can enter either fixed values or variables for your characteristics. Select Variable on/off to enter variables. The entry field is then changed accordingly. Unlike with the present general ledger, there are no predefined global variables. Rather, you have to define local variables at this point. A local variable has to begin with a “$” sign.

The following rules apply to creating reports:

- When determining the breakdown characteristics, you can select the characteristics desired by choosing Goto → Characteristics. You can also select the relevant general ledger dimensions (such as functional area, cost center, and profit center).
- No hierarchies are selected for this report.

The following rules apply to creating reports:

- When including a report in the report tree, select application class FBRG.
- To carry out the report, choose Account → More reports in the Flexible General Ledger.

C: Account balances

The following rules apply to forms:

- You can select each type of form.
In the "Handling the currency" screen, select indicator "Any currency, no currency translation". All currencies can be used for account balances.

If you want define the characteristics for all columns, choose Edit → General selections → Display/change. You can select the selection characteristics needed, such as ledger, version, and profit center, and you can enter fixed values for them.

If you defined the individual columns, you can select any key figure for each row; for example, the total of the debit posting for one row, total of the credit postings for the second row, and balance for the third row.

After you have determined the key figure, you can select the characteristics you want, such as fiscal year and company code.

Afterwards, enter the values for your characteristics. You can enter either fixed values or variables for your characteristics. Select Variable on/off to enter variables. The entry field is then changed accordingly. Unlike with the present general ledger, there are no predefined global variables. Rather, you have to define local variables at this point. A local variable has to begin with a “$” sign.

The following rules apply to creating reports:

- When determining the breakdown characteristics, you can select the characteristics desired by choosing Goto → Characteristics. You can also select the relevant general ledger dimensions (such as functional area, cost center, and profit center).

- No hierarchies are selected for this report.

The following rules apply to creating reports:

- When including a report in the report tree, select application class FBRG.

- To carry out the report, choose Account → More reports from the Flexible General Ledger menu.