Special Purpose Ledger
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Caution</td>
</tr>
<tr>
<td>🎈</td>
<td>Example</td>
</tr>
<tr>
<td>📝</td>
<td>Note</td>
</tr>
<tr>
<td>🧪</td>
<td>Recommendation</td>
</tr>
<tr>
<td>🧰</td>
<td>Syntax</td>
</tr>
<tr>
<td>🤔</td>
<td>Tip</td>
</tr>
</tbody>
</table>
# Contents

**Special Purpose Ledger** ................................................................. 18  
**The FI-SL System and Other SAP Applications: Shared Functions** ............. 21  
**Integration of FI-SL with Other SAP Applications** ........................................... 23  
**Configuration** .......................................................................................... 25  
**Overview: Configuring and Using the FI-SL System** ............................................ 26  
**FI-SL Database Tables** ............................................................................. 30  
- Object Tables ................................................................................................ 32  
- FI-SL Summary Database .................................................................................. 34  
- FI-SL Line Item Databases .................................................................................. 36  
- Database Definition and Installation ................................................................. 38  
- Indices .............................................................................................................. 39  
**Master Data** ............................................................................................... 40  
- FI-SL Master Data: Special Purpose Ledgers ...................................................... 42  
- FI-SL Master Data: Companies .......................................................................... 49  
- FI-SL Master Data: Field Movements ................................................................ 51  
- FI-SL Master Data: Activities ............................................................................ 53  
- Introduction to Master Data ................................................................................ 54  
  - Creating Master Data ........................................................................................ 57  
  - Displaying Master Data ...................................................................................... 59  
  - Changing Master Data ....................................................................................... 60  
  - Deleting Master Data ....................................................................................... 61  
  - Reinstating a Deleted Master File Value ............................................................ 63  
  - Displaying the Source of Master File Values .................................................... 64  
**Additional FI-SL System Prerequisites** .......................................................... 65  
- Posting Periods ............................................................................................... 66  
- Versions ............................................................................................................ 69  
- Validations, Substitutions, and Rules ................................................................. 70  
**Planning** ..................................................................................................... 72  
**Master Data and Planning** .......................................................................... 74  
**Setting Up Planning** ................................................................................... 75  
- Planning Layout ............................................................................................... 76  
- Planner Profile ................................................................................................. 77  
**Creating Plan Data** .................................................................................... 79  
- Creating Plan Data ........................................................................................... 80  
  - Planning Functions .......................................................................................... 82  
  - Reload Data .................................................................................................... 83  
  - Clear Row, Undo, Redo ................................................................................... 84  
  - Cut .................................................................................................................. 85  
  - Copy .............................................................................................................. 87  
  - Paste ............................................................................................................. 89  
  - Change Values ............................................................................................... 91  
  - Line Item Display ........................................................................................... 92  
  - Long Text ..................................................................................................... 93  
  - Goal Seek Function ....................................................................................... 94
Using FI-SL on Distributed Systems ................................................................. 264
Carrying out Drill Downs on Rollup Line Items .............................................. 266
Defining Rollups .................................................................................................. 269
Overview: Executing Rollups ............................................................................. 270
Creating Rollups ................................................................................................... 272
Creating Rollup Headers for Standard Rollups ................................................ 273
Creating Rollup Headers for Hierarchical Rollups ............................................ 277
Creating Rollup Headers for Export Rollups ...................................................... 281
Creating a Rollup Sequence .............................................................................. 283
Creating Field Movement .................................................................................. 285
Entering Substitution Activity Information ....................................................... 287
Checking Rollups ................................................................................................. 290
Documenting Rollups .......................................................................................... 291
Displaying Rollups ............................................................................................... 292
Defining a Rollup for Background Processing .................................................. 293
Reversing a Rollup ............................................................................................... 294
Executing Rollups ............................................................................................... 296
Exporting/Importing Rollup Data ....................................................................... 299
Deleting Rollups ................................................................................................. 300
Changing Rollups ............................................................................................... 301

**Currency Translation** ................................................................................... 302
Translation Methods ............................................................................................ 305
Exchange Rate Indicator ...................................................................................... 306
Currency Translation Key .................................................................................... 307

**Carrying Forward Balances** ........................................................................ 309

Archiving ............................................................................................................ 312

**Information System** ..................................................................................... 314

**Report Painter / Report Writer** ................................................................. 315
Report Painter or Report Writer? ....................................................................... 316
Report Painter ...................................................................................................... 318
  Working with the Report Painter ..................................................................... 320
  Defining Reports for the Report/Report Interface .......................................... 323
  Creating a Report Painter Report ................................................................. 326
     Creating an Example Actual/Plan Comparison Report Using the Report Painter 328
     Create Actual/Plan Comparison Report ...................................................... 333
     Defining Row and Column Models ........................................................... 336
        Creating a Model ...................................................................................... 337
        Inserting a Model .................................................................................... 338
        Transporting Models .............................................................................. 339
     Defining Columns ....................................................................................... 340
     Defining Rows ........................................................................................... 343
     Exploding Report Rows ........................................................................... 345
     Formatting Report Rows .......................................................................... 347
     Defining Cells ............................................................................................ 350
     Defining Sections ....................................................................................... 351
     Defining Horizontal Pages ....................................................................... 353
     General Data Selection .......................................................................... 354
     Defining Report Headers ....................................................................... 357

April 2001

7
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deleting a Standard Layout</td>
<td>619</td>
</tr>
<tr>
<td>Section Layout</td>
<td>620</td>
</tr>
<tr>
<td>Report Layout</td>
<td>621</td>
</tr>
<tr>
<td>Displaying the Report Layout</td>
<td>622</td>
</tr>
<tr>
<td>Defining Report Layout</td>
<td>623</td>
</tr>
<tr>
<td>Saving Changed Report Layout Parameters</td>
<td>625</td>
</tr>
<tr>
<td>Summation Levels</td>
<td>626</td>
</tr>
<tr>
<td>Terminology</td>
<td>629</td>
</tr>
<tr>
<td>Drilldown Reporting Tool</td>
<td>630</td>
</tr>
<tr>
<td>Tools</td>
<td>631</td>
</tr>
<tr>
<td>Sets</td>
<td>633</td>
</tr>
<tr>
<td>Set Hierarchies</td>
<td>635</td>
</tr>
<tr>
<td>Set Types</td>
<td>638</td>
</tr>
<tr>
<td>Basic Sets</td>
<td>639</td>
</tr>
<tr>
<td>Key Figure Sets</td>
<td>641</td>
</tr>
<tr>
<td>Single-Dimension Sets</td>
<td>643</td>
</tr>
<tr>
<td>Multi-Dimension Sets</td>
<td>645</td>
</tr>
<tr>
<td>Use of Sets</td>
<td>647</td>
</tr>
<tr>
<td>Sets in the Report Writer</td>
<td>649</td>
</tr>
<tr>
<td>Creating Sets</td>
<td>651</td>
</tr>
<tr>
<td>Creating a Set Header</td>
<td>653</td>
</tr>
<tr>
<td>User Tables</td>
<td>656</td>
</tr>
<tr>
<td>Representative Values in Sets</td>
<td>657</td>
</tr>
<tr>
<td>Entering Basic Set Values</td>
<td>659</td>
</tr>
<tr>
<td>Entering Value and Formula Variables in a Set</td>
<td>661</td>
</tr>
<tr>
<td>Entering Formulas in a Set</td>
<td>662</td>
</tr>
<tr>
<td>Entering Key Figure Set Values</td>
<td>663</td>
</tr>
<tr>
<td>Entering Subordinate Sets in Single-Dimension Sets</td>
<td>665</td>
</tr>
<tr>
<td>Entering Multi-Dimension Set Values</td>
<td>667</td>
</tr>
<tr>
<td>Entering Set Variables in a Set</td>
<td>669</td>
</tr>
<tr>
<td>Displaying Sets</td>
<td>670</td>
</tr>
<tr>
<td>Changing Sets</td>
<td>671</td>
</tr>
<tr>
<td>Deleting Sets</td>
<td>673</td>
</tr>
<tr>
<td>Transporting Sets</td>
<td>674</td>
</tr>
<tr>
<td>Exporting Sets</td>
<td>675</td>
</tr>
<tr>
<td>Importing Sets</td>
<td>676</td>
</tr>
<tr>
<td>Copying Sets from a Client</td>
<td>677</td>
</tr>
<tr>
<td>Set Utilities</td>
<td>678</td>
</tr>
<tr>
<td>Checking Field and Set Value Usage</td>
<td>679</td>
</tr>
<tr>
<td>Checking Set Usage</td>
<td>680</td>
</tr>
<tr>
<td>Displaying and Deleting Non-Used Sets</td>
<td>682</td>
</tr>
<tr>
<td>Displaying Set Graphics</td>
<td>683</td>
</tr>
<tr>
<td>Checking for Overlapping Values in Sets</td>
<td>684</td>
</tr>
<tr>
<td>Displaying a Set Directory</td>
<td>685</td>
</tr>
<tr>
<td>Formulas</td>
<td>686</td>
</tr>
<tr>
<td>Variables</td>
<td>689</td>
</tr>
<tr>
<td>Creating Variables</td>
<td>692</td>
</tr>
</tbody>
</table>
Creating Value Variables ................................................................. 693
Creating Formula Variables ............................................................... 695
Creating Set Variables .......................................................................... 697
Displaying Variables ............................................................................. 699
Changing Variables ............................................................................... 700
Deleting Variables ................................................................................ 701
Transporting Variables ......................................................................... 702
Exporting Variables ............................................................................. 703
Importing Variables ............................................................................. 704
Copying Variables from a Client .......................................................... 705
Displaying a Variable Directory .......................................................... 706
Displaying and Deleting Non-Used Variables ...................................... 707

Key Figures .......................................................................................... 708
Creating/Changing Key Figures ............................................................ 712
Displaying Key Figures ......................................................................... 714
Defining Key Figures ........................................................................... 715
Inserting Key Figures in Row Blocks ................................................. 722

Report Painter / Report Writer ............................................................. 723
Report Painter or Report Writer? .......................................................... 724
Report Painter ..................................................................................... 726
  Working with the Report Painter ....................................................... 728
  Defining Reports for the Report/Report Interface ................................ 731
  Creating a Report Painter Report ..................................................... 734
    Creating an Example Actual/Plan Comparison Report Using the Report Painter 736
    Create Actual/Plan Comparison Report ........................................... 741
    Defining Row and Column Models ............................................... 744
      Creating a Model .......................................................................... 745
      Inserting a Model ....................................................................... 746
      Transporting Models .................................................................. 747
    Defining Columns ......................................................................... 748
    Defining Rows ............................................................................. 751
    Exploding Report Rows ............................................................... 753
    Formatting Rows and Columns ..................................................... 755
    Defining Cells ............................................................................. 758
    Defining Sections ....................................................................... 759
    Defining Horizontal Pages ......................................................... 761
    General Data Selection ................................................................ 762
    Defining Report Headers ............................................................. 765
    Extracts ....................................................................................... 766
      Create Extract ........................................................................... 768
      Managing Extracts .................................................................... 769
      Example Process: Report Callup with Extract Management .... 771
    Report Text ................................................................................ 774
      Defining Report Texts ............................................................... 775
    Layout ........................................................................................ 776
      Standard Layouts ..................................................................... 777
        Creating a Standard Layout..................................................... 779
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extracts</td>
<td>883</td>
</tr>
<tr>
<td>Create Extract</td>
<td>885</td>
</tr>
<tr>
<td>Managing Extract</td>
<td>886</td>
</tr>
<tr>
<td>Example Process: Report Callup with Extract Management</td>
<td>888</td>
</tr>
<tr>
<td>Sets in the Report Writer</td>
<td>891</td>
</tr>
<tr>
<td>Defining Report Data</td>
<td>893</td>
</tr>
<tr>
<td>Sets in Report Rows</td>
<td>894</td>
</tr>
<tr>
<td>Sets in Report Columns</td>
<td>898</td>
</tr>
<tr>
<td>Suppressing Rows and Columns</td>
<td>899</td>
</tr>
<tr>
<td>Using Sets to Select Report Data</td>
<td>900</td>
</tr>
<tr>
<td>Entering Set Text for Reports</td>
<td>901</td>
</tr>
<tr>
<td>Sets in the Report Writer</td>
<td>903</td>
</tr>
<tr>
<td>Set Formulas in the Report Writer</td>
<td>906</td>
</tr>
<tr>
<td>Symbolic Names in the Report Writer</td>
<td>909</td>
</tr>
<tr>
<td>Setting Format Groups in Sets</td>
<td>910</td>
</tr>
<tr>
<td>Report Writer Utilities</td>
<td>912</td>
</tr>
<tr>
<td>Listing Report Writer Objects</td>
<td>914</td>
</tr>
<tr>
<td>Transport of Report Writer Objects</td>
<td>915</td>
</tr>
<tr>
<td>Exporting Report Writer Objects</td>
<td>916</td>
</tr>
<tr>
<td>Importing Report Writer Objects</td>
<td>918</td>
</tr>
<tr>
<td>Copying Report Writer Objects from Other Clients</td>
<td>919</td>
</tr>
<tr>
<td>Transporting Report Writer Objects</td>
<td>921</td>
</tr>
<tr>
<td>Listing a Report Definition</td>
<td>923</td>
</tr>
<tr>
<td>Defining Reports for the Report/Report Interface</td>
<td>924</td>
</tr>
<tr>
<td>Libraries</td>
<td>927</td>
</tr>
<tr>
<td>Creating a Library</td>
<td>929</td>
</tr>
<tr>
<td>Displaying a Library Definition</td>
<td>934</td>
</tr>
<tr>
<td>Changing a Library</td>
<td>935</td>
</tr>
<tr>
<td>Deleting a Library</td>
<td>936</td>
</tr>
<tr>
<td>Report Groups</td>
<td>937</td>
</tr>
<tr>
<td>Creating a Report Group</td>
<td>941</td>
</tr>
<tr>
<td>Entering Header Information for a Report Group</td>
<td>943</td>
</tr>
<tr>
<td>Defining Report Documentation</td>
<td>945</td>
</tr>
<tr>
<td>Adding Reports to a Report Group</td>
<td>946</td>
</tr>
<tr>
<td>Entering Selection Texts for a Report Group</td>
<td>947</td>
</tr>
<tr>
<td>Creating a Report Group from the Report Definition</td>
<td>948</td>
</tr>
<tr>
<td>Displaying a Report Group</td>
<td>949</td>
</tr>
<tr>
<td>Changing a Report Group</td>
<td>950</td>
</tr>
<tr>
<td>Deleting a Report Group</td>
<td>951</td>
</tr>
<tr>
<td>Generating a Report Group</td>
<td>952</td>
</tr>
<tr>
<td>Generating Report Groups (Mass Generator)</td>
<td>954</td>
</tr>
<tr>
<td>Scheduling a Report Group as a Background Job</td>
<td>956</td>
</tr>
<tr>
<td>Deleting Generated Code for Report Groups</td>
<td>957</td>
</tr>
<tr>
<td>Creating Report Group Variants</td>
<td>958</td>
</tr>
<tr>
<td>Exporting and Importing Report Group Variants</td>
<td>960</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Copying Report Group Variants from Other Clients</td>
<td>961</td>
</tr>
<tr>
<td>Report Group Execution</td>
<td>962</td>
</tr>
<tr>
<td>Executing a Report Group</td>
<td>964</td>
</tr>
<tr>
<td>Saving Report Data in Microsoft Excel</td>
<td>967</td>
</tr>
<tr>
<td>Exporting Report Data to the Executive Information System (EC-EIS)</td>
<td>968</td>
</tr>
<tr>
<td>Executing a Report Group in the Background</td>
<td>969</td>
</tr>
<tr>
<td>Varying Report Data</td>
<td>970</td>
</tr>
<tr>
<td>Functions in the Report Output</td>
<td>974</td>
</tr>
<tr>
<td>Expert Mode</td>
<td>978</td>
</tr>
<tr>
<td>Printing Report Data</td>
<td>982</td>
</tr>
<tr>
<td>Freezing Page Headers</td>
<td>984</td>
</tr>
<tr>
<td>Exporting a Report to an External File</td>
<td>985</td>
</tr>
<tr>
<td>Exporting a Report to a Presentation Server</td>
<td>986</td>
</tr>
<tr>
<td>Exporting a Report to an Application Server</td>
<td>988</td>
</tr>
<tr>
<td>Office Integration</td>
<td>990</td>
</tr>
<tr>
<td>Sending Reports to Mail Users</td>
<td>992</td>
</tr>
<tr>
<td>Selecting and Deselecting Report Data</td>
<td>993</td>
</tr>
<tr>
<td>Entering Threshold Value Conditions</td>
<td>994</td>
</tr>
<tr>
<td>Sorting Report Rows</td>
<td>997</td>
</tr>
<tr>
<td>Navigating Within a Report</td>
<td>998</td>
</tr>
<tr>
<td>Calling Up Report Graphics</td>
<td>999</td>
</tr>
<tr>
<td>Calling Up Reports via the Report/Report Interface</td>
<td>1000</td>
</tr>
<tr>
<td>Navigation in the Variation Settings</td>
<td>1002</td>
</tr>
<tr>
<td>Editing Variation Ranges in Report Painter</td>
<td>1003</td>
</tr>
<tr>
<td>Editing Variation Ranges in Report Writer</td>
<td>1005</td>
</tr>
<tr>
<td>Navigating in the Report Hierarchy</td>
<td>1007</td>
</tr>
<tr>
<td>Extracts</td>
<td>1008</td>
</tr>
<tr>
<td>Create Extract</td>
<td>1010</td>
</tr>
<tr>
<td>Managing Extracts</td>
<td>1011</td>
</tr>
<tr>
<td>Example Process: Report Callup with Extract Management</td>
<td>1013</td>
</tr>
<tr>
<td>Layout</td>
<td>1016</td>
</tr>
<tr>
<td>Standard Layouts</td>
<td>1017</td>
</tr>
<tr>
<td>Creating a Standard Layout</td>
<td>1019</td>
</tr>
<tr>
<td>Parameters for the Standard Layout</td>
<td>1022</td>
</tr>
<tr>
<td>Displaying a Standard Layout</td>
<td>1024</td>
</tr>
<tr>
<td>Changing a Standard Layout</td>
<td>1025</td>
</tr>
<tr>
<td>Deleting a Standard Layout</td>
<td>1027</td>
</tr>
<tr>
<td>Section Layout</td>
<td>1028</td>
</tr>
<tr>
<td>Report Layout</td>
<td>1029</td>
</tr>
<tr>
<td>Displaying the Report Layout</td>
<td>1030</td>
</tr>
<tr>
<td>Defining Report Layouts</td>
<td>1031</td>
</tr>
<tr>
<td>Saving Changed Report Layout Parameters</td>
<td>1033</td>
</tr>
<tr>
<td>Summation Levels</td>
<td>1034</td>
</tr>
<tr>
<td>Terminology</td>
<td>1037</td>
</tr>
</tbody>
</table>

**Validations, Substitutions, and Rules** ................................................. 1038
What Are Validations?........................................................................................................................ 1040
What Are Substitutions?..................................................................................................................... 1043
Overview of Validations/Substitutions ............................................................................................ 1046
Boolean Logic Statements and Rules ............................................................................................... 1048
Application Areas ............................................................................................................................ 1050
Validation/Substitution Callup Points .............................................................................................. 1051
Boolean Classes .............................................................................................................................. 1052
User Exits in Validations/Substitutions/Rules ................................................................................. 1053
Formula Builder ............................................................................................................................. 1055
Validation........................................................................................................................................... 1056
  Creating a Validation..................................................................................................................... 1057
  Validation Messages .................................................................................................................... 1062
  Validation Message Classes .......................................................................................................... 1065
  Displaying a Validation .............................................................................................................. 1066
  Changing a Validation ................................................................................................................. 1067
  Deleting a Validation ................................................................................................................ 1068
  Activating a Validation in FI-SL ............................................................................................... 1069
  Deactivating a Validation ......................................................................................................... 1072
  Validation (old) ......................................................................................................................... 1073
    Creating a Validation (old) ....................................................................................................... 1074
    Displaying a Validation (old) ................................................................................................. 1079
    Changing a Validation (old) ................................................................................................. 1081
    Deleting a Validation (old) ................................................................................................. 1082
Substitution....................................................................................................................................... 1083
  Creating a Substitution .............................................................................................................. 1084
  Displaying a Substitution ......................................................................................................... 1088
  Changing a Substitution .......................................................................................................... 1089
  Deleting a Substitution ........................................................................................................... 1090
  Activating a Substitution in FI-SL .......................................................................................... 1091
  Deactivating a Substitution ...................................................................................................... 1094
  Substitution (old) ..................................................................................................................... 1095
    Creating a Substitution (old) ................................................................................................. 1096
    Displaying a Substitution (old) ............................................................................................ 1100
    Changing a Substitution (old) ............................................................................................... 1102
    Deleting a Substitution (old) ............................................................................................... 1103
Rules ................................................................................................................................................. 1104
  Introduction to Rules ................................................................................................................. 1105
  Creating a Rule ........................................................................................................................ 1107
  Displaying a Rule .................................................................................................................... 1109
  Changing a Rule ...................................................................................................................... 1110
  Deleting a Rule ........................................................................................................................ 1111
  Examples of Rules .................................................................................................................... 1112
Rules (old) ...................................................................................................................................... 1113
  Creating a Rule (old) .............................................................................................................. 1114
  Displaying a Rule (old) ........................................................................................................... 1117
  Changing a Rule (old) ............................................................................................................. 1118
  Deleting a Rule (old) .............................................................................................................. 1119
Boolean Logic/Syntax......................................................... 1120
Introduction to Boolean Logic................................................ 1121
Creating Boolean Statements for the FI-SL System................. 1125
Using Boolean Statements in FI-SL........................................ 1126
Types of FI-SL Statements................................................... 1129
Syntax Rules for Boolean Statements.................................. 1133
Old Syntax Rules for Boolean Statements............................ 1138
Example Boolean Statements ............................................. 1143
Using Boolean Operators in Truth Tables............................ 1145

   AND (Conjunction) ........................................................... 1146
   OR (Disjunction) .............................................................. 1148
   NOT (Negation) ............................................................... 1150
   NAND (NOT AND) ........................................................... 1151
   NOR (NOT OR) ................................................................. 1153
   --> (Implication) ............................................................. 1155
   <-> (Equivalence) .......................................................... 1157
Miscellaneous Procedures.................................................... 1159

    Adding Fields to and Deleting Fields from a Boolean Class........... 1160
    Setting the User Exit File Name ......................................... 1162
    Setting the Message Class .............................................. 1163
    Using the Rule Manager Reports ....................................... 1164
    Transporting Validations/Substitutions/Rules ....................... 1166
    Displaying a Directory of Validations/Substitutions/Rules ......... 1168
    Tracing a Validation/Substitution/Rule ................................ 1169
    Simulating a Validation/Substitution/Rule ........................... 1170
    Using the Analysis Tool .................................................. 1171
Using the Ledger Statistics Tool .......................................... 1174
Using the Diagnosis Tool .................................................... 1175
Using the Control Report Tool .............................................. 1179
Special Purpose Ledger

Purpose
In the application component Special Purpose Ledger, you can define ledgers for reporting purposes. You can keep these user-defined ledgers as general ledgers or subsidiary ledgers with various account assignment objects. Account assignment objects can either be SAP dimensions from various applications (such as account, cost center, business area, profit center) or customer-defined dimensions (such as region).

The Special Purpose Ledger allows you to report at various levels using the values from the various application components. The modules in the Special Purpose Ledger allow you to collect information, combine information, and create totals. You can also modify, assess, and distribute actual and plan values that are transferred from other SAP applications or external systems to the Special Purpose Ledger.

The use of the Special Purpose Ledger has no effect on the actual functions of other SAP applications.

Features
The use of the Special Purpose Ledger offers the following advantages:

- **Flexible database structures with additional fields**
  You can create your own database tables and define non-standard dimensions (such as valuation area) that meet your business needs. With this you are able to combine and total information for each account assignment combination at the desired level of detail.

- **Selective data retrieval**
  Data flow is flexible in the Special Purpose Ledger. With the assignment of transactions to specific company code/ledger company/ledger combinations, you decide which ledgers are to be updated by the data created. You can further limit the number of ledgers that are updated by entering ledger selection criteria.

- **Correction postings**
In the Special Purpose Ledger you can make adjustment and correction postings. You are able, for example, to post data to various versions. Correction postings, for example, are useful for valuating currencies.

- **Alternative charts of accounts**
  You can use various charts of accounts in the Special Purpose Ledger (operating, group, and country-specific charts of accounts).

- **Alternative fiscal year with various fiscal year variants**
  In the Special Purpose Ledger, you can define your own posting periods. Accounting period definitions determine the fiscal calendar, which defines the fiscal year and the posting periods within the fiscal year.
  If you define your own posting periods, you could then create weekly or monthly reports.

- **Specific modifications for data creation**
  If you want to ensure that only valid data is received by the Special Purpose Ledger, you can use validations and substitutions to check and substitute data at the time it is entered.

- **Totaled line items from other applications**
  With the broad function palette of the Special Purpose Ledger, you can total, modify, assess, or distribute actual and plan data from SAP and external applications.

- **SAP reporting**
  With the Special Purpose Ledger, you can evaluate data from various SAP applications and organizational units and report on this information.

This graphic offers an overview of the functions available in the FI-SL System.

### Constraints
The Special Purpose Ledger (FI-SL) is a receiver system to which data created in other SAP applications is sent. It is **not** a sender system for other SAP applications.
The FI-SL System and Other SAP Applications: Shared Functions

Use
The FI-SL System has interfaces with other SAP applications and shares many functions and processing techniques with these systems.

There are two types of ledgers in the FI-SL System:

- Standard ledgers
- Special purpose ledgers

Integration
For further information, see the SAP Library, under Accounting → Financial Accounting → Special Purpose Ledger → Integration of the FI_SL System with other SAP Applications [Seite 23].

Prerequisites
The functions shared by FI-SL and other systems depends on the standard ledgers delivered with the various SAP applications.

Features
Standard ledgers are configured and delivered by SAP and are controlled within the individual applications.

- Standard ledgers are delivered in the following SAP applications:
  - General Ledger Accounting (FI-GL)
  - Consolidation (FI-LC)
  - Profit Center Accounting (CO-PCA)
  - Reconciliation Ledger (CO-OM-CEL)

The individual applications are responsible for determining which of the FI-SL functions are to be used and integrated into the respective application. For example, all applications that use standard ledgers use the same data collection techniques as FI-SL (via the ledger/organizational unit and ledger/organizational unit/activity assignments). FI-SL and Consolidation (FI-LC) also use the same currency translation functions.

Special purpose ledgers are user-defined ledgers designed to meet your specific business requirements according to the dimensions you specify. Special purpose ledgers are the only types of ledger you can create within the FI-SL System.

See also:
FI-SL Master Data: Special Purpose Ledgers [Seite 42]
The FI-SL System and Other SAP Applications: Shared Functions
Integration of FI-SL with Other SAP Applications

Use

All SAP applications are based on the concept that you only enter a business transaction once. The information that you enter is however then immediately available to all other SAP applications.

FI-SL collects data from other systems at the original point of entry and validates it immediately as it is being entered. With this maximum integration, you do not need to run batch interfaces; the data can be copied to the FI-SL System directly.

Features

Interfaces with Other SAP Application Components

The data that is saved in the FI-SL System can be collected in various ways: Business transactions can be copied from other SAP applications or external systems, or they can be entered in the FI-SL System directly.

The Integration Manager processes all data that enters the FI-SL System. Through user-defined selection, validation, and substitution conditions, the Integration Manager determines whether and how data should be posted to the FI-SL tables.

- In Logistics, the Material Management System (MM) supplies information on inventory movements, as well as the results of invoice verification. Data can also be transmitted from Sales and Distribution (SD).

- Data can also be transmitted from Financial Systems (FI). The Cost Accounting modules (CO) transmit relevant data about costs on cost centers (CO-CCA) or orders/projects (CO-OPA).
The data is transferred to the FI-SL System using a new structure. This new structure is an accounting document that gives you more flexibility when posting data from other applications. For example, you can post data for several different dimensions. In addition, the document number of the original document is always copied into the FI-SL System.

If you defined user exits for copying data to FI-SL before Release 3.0, you need to change the user exits and adapt them to the new accounting document structure. For more information, see the “Data Transfer to FI-SL for FI, MM, AM, SD, and CO Documents” Release Note.

For more information about transferring data to the FI-SL System, see:

Actual Postings [Seite 128]
Data Transfer from SAP Components [Seite 132].
Data Input from External Sources [Seite 134]
Data Input Directly in FI-SL [Seite 135]
Data Transfer Programs [Extern]
Configuration

Purpose
This section explains basic concepts for configuring your FI-SL System.

FI-SL Database Tables [Seite 30]
FI-SL Master Data [Seite 40]
Additional FI-SL System Requirements [Seite 65]

For more detailed information about system configuration, see the Implementation Guide (IMG) for Special Purpose Ledger.
Overview: Configuring and Using the FI-SL System

This section explains the basic steps for configuring and using your FI-SL System. For more detailed information about system configuration, see the Implementation Guide (IMG) for Special Purpose Ledger.

1. **Designing your FI-SL system structure**

   Before you install and set up your FI-SL System, you must carefully design your system structure. It is very important that you take time to design your system and data structures. A well-organized system structure leads to efficient running of your production system and improves system performance.

   Depending on your reporting requirements, you must determine which dimensions and field movements you want to use in your ledgers. (A dimension represents specific criteria in business processes. Technically, a dimension is a single field or column of a database table.)

   In the above graphic, Ledger 1 uses the dimensions "Account" and "Cost Center"; Ledger 2 uses the dimensions "Cost Center" and "Plant"; and Ledger 3 uses the dimensions "Product" and "Product Number". Since Ledgers 1 and 2 share the dimension "Cost Center" and all the dimensions used by the ledgers are defined in one table group, both ledgers can use one table structure (Table Group 1). Since the dimensions "Product" and "Product Number" do not exist in Table Group 1, Ledger 3 must use a different table group.

2. **Creating your FI-SL database tables**

   Once you have designed your FI-SL system structure, you can create your database tables and specify which dimensions you want to include in your tables.

   FI-SL uses the following table types:
- Object tables
  (for receiver/sender and transaction attributes)
- Summary tables
- Actual line item tables
- Plan line item tables

For more information about these table types, see FI-SL Database Tables [Seite 30].

You use the Define Table Group function to define your database tables and store them in the ABAP Dictionary. A table group is a group of interdependent tables (object tables, summary tables, actual and plan line item tables).

For more information about creating a table group, see the Define Table Group activity in the Special Purpose Ledger Implementation Guide (IMG).

You can also create a rollup actual line item table and a rollup plan line item table, if, for example, you want to drill down from the rollup summary data to the original data in a Report Writer report.

It is not currently possible to automatically install these tables using the Define Table Group function. If you want to use a rollup table, you must copy the standard tables delivered with your system (GLREFU: Rollup actual line item table and GLREFV: Rollup plan line item table) using the Copy table function in Customizing and modify them according to your requirements.

For more information, see the Copy Table activity in the Implementation Guide (IMG) for Special Purpose Ledger.

When you create your database tables, you must decide among other things the following:
- Whether you require a local table (for a company code) or a global table (for a global company).
- Which dimensions you want to include in the object/partner object table (for example, account, cost center, business area, and so on) and which of these dimensions you also require as partner dimensions (sender/receiver relationship).
- Whether you require a second object table for transaction attributes.
- Whether you want to include additional dimensions in the data part of the summary table. These dimensions are known as derived dimensions because they must be uniquely derivable from the other dimensions in a specific summary record.
- Whether you want to include additional dimensions in your actual line item table. These dimensions are only used in document display (or in line item reporting).
- Which currencies and quantities you want to use in your database tables
- How many periods you require in your summary records
- Which database indices you want to define for your FI-SL tables

See also:
Database Definition and Installation [Seite 38]
3. Installing your FI-SL database tables

Once you have defined, saved, and activated your table group, you can install your database tables directly using the Table Group function.

For more information, see the Define Table Group activity in the Implementation Guide (IMG) for Special Purpose Ledger.

See also:

Database Definition and Installation [Seite 38]

4. Creating your FI-SL master data

After you have defined the dimensions that you want to use in your ledgers (table structure), you can define the master data (special purpose ledgers, companies, activities, and field movements) that you want to use in your system (see the following graphic).

**Special purpose ledgers:** When you create your special purpose ledgers, you define, among other things, the ledger master data (such as the currencies and quantities the ledger should use, whether the ledger is open for posting, and whether the ledger can be used as a rollup ledger). You must also assign a company code or global company to your ledger so that data can be posted to the ledger. You then define which activities can update the ledger (company code/ledger/activity or global company/ledger/activity assignment). If you want to define additional criteria for posting data to your ledger, you can enter ledger selection conditions.

**Company codes and global companies:** You can use company codes and global companies in your FI-SL system. Company codes are defined in the FI System and are the most commonly used companies in the FI-SL System. You can set up your system so that a company code directly updates a local ledger (ledger/company code assignment). Global companies usually group together one or more company codes. You can assign a company code to a global company so that the company code updates a global ledger (ledger/global company assignment) and a local ledger.
Activities: The data entered in other SAP application areas or external systems is transferred into the FI-SL System using an activity. You must assign activities to your ledgers so that data can be updated in these ledgers.

Field movements: You can create field movements to define which dimensions are filled within the FI-SL System. Field movements determine which dimensions from other SAP applications are transferred to the dimensions in the FI-SL System.

For more information about creating master data, see the activities under Master Data in the Implementation Guide (IMG) for Special Purpose Ledger.

You can also define your master data using the Graphic navigation function, which allows you to graphically display relationships between company codes, global companies, ledgers, and activities. If required, you can also branch to the assignment to change it. For more information about using the Graphic navigation function, see the Use Graphic Navigation activity in the Implementation Guide (IMG) for Special Purpose Ledger.

See also:
Master Data [Seite 40]

5. Defining additional requirements for working with your system

After you have created the master data that you want to use in your system, you have to maintain additional system settings (such as posting periods and versions) required for working in your productive system.

You can also define your own validations and substitutions for your system to check and/or substitute values and combinations of values as they are being entered in your system. Since validation and substitution occur before data is posted, only valid information enters the FI-SL System.

For more information, see the Special Purpose Ledger Implementation Guide (IMG).

See also:
Additional FI-SL System Requirements [Seite 65]

6. Working with your FI-SL System

After you have completed the above steps, you can work in your FI-SL System, using the available functions to meet your specific business requirements.
FI-SL Database Tables

Use
The SAP-delivered database tables are only *suggested example structures*.

![Warning Symbol]

You **cannot** use these database tables as delivered.

Activities
Copy the delivered tables and make necessary changes according to your system requirements.
FI-SL is delivered with the following group of interdependent database tables (see the above graphic):

- **Object Tables** [Seite 32]
- **FI-SL Summary Database** [Seite 34]
- **FI-SL Line Item Databases** [Seite 36]

You can only define and use these table structures for FI-SL special purpose ledgers. You *cannot* use them for standard ledgers that have been defined within another application.

For more information about ledgers, see **FI-SL Master Data: Special Purpose Ledgers** [Seite 42].

For more information, see:

- **Database Definition and Installation** [Seite 38]
- **Indices** [Seite 39]
Object Tables

Use
SAP stores its data in standard relational databases: Oracle, Informix, and Entire SQL (ADABAS). Relational databases select information using key fields. The highest number of key fields supported in an underlying database is 16, which limits the number of key fields possible for customer definition. FI-SL uses object tables to display coding block fields, as well as to increase the number of possible coding block fields. The object table structures also allow you to directly maintain and validate dimension combinations. Technically, these object tables are spliced into a longer "virtual" coding block to overcome the underlying technical database limitations.

Features
SAP delivers two types of object tables: object/partner and transaction attributes

A) Object/Partner (Receiver/Sender)

This object table supports 15 variable dimensions, including the local company code/global company. Two of the variable dimensions are used for internal purposes, leaving 13-14 variable dimensions available for customer definition.

The variable dimensions defined in this object table have a sender/receiver relationship (for example, receiver account (RACCT) and sender account (SACCT)).

Fixed Dimensions
You cannot change fixed dimensions.

Client, object number for object (receiver) and partner (sender) dimensions, valid period intervals, local company code/global company

Object numbers determine how the summary and line item database tables will be accessed via the object tables. The object numbers for the object (receiver) and partner (sender) dimensions are defined in object table 1.

Variable Dimensions

The variable dimensions are the key dimensions of the coding block. These dimensions are defined in object table 1 and can be used in the summary and line item database tables as object dimensions (receivers) and/or partner dimensions (senders). Object and partner dimensions have a direct relationship, where partner dimensions are the senders of data, and object dimensions are the receivers of data.

Account (ACCT), cost center (CNTR).

An example of an object/partner object table delivered with FI-SL is GLREFO (only for local ledgers).
B) Transaction Attributes

This object table supports 15 variable dimensions. The variable dimensions defined in this object table are transaction attribute-dependent and do not have a sender/receiver relationship (for example, controlling area (KOKRS)). The optional transaction attributes table (object table 2) contains:

**Fixed Dimensions**

You cannot change fixed dimensions.

Client, object number for the transaction attribute dimensions

Object numbers determine how the summary and line item database tables will be accessed via the object tables. The object number for the transaction attribute dimensions are defined in object table 2.

**Variable Dimensions**

These variable dimensions do not have a direct sender/receiver relationship; instead, the variable dimensions are transaction attribute-dependent.

Within one business transaction, you are posting CO data to FI-SL, and the cost centers to which you are posting are defined within a specific controlling area. You only post to FI-SL for this controlling area. Since 1) the controlling area remains the same for the sender cost center (SCNTR) and receiver cost center (RCNTR), and 2) the controlling area does not have a sender/receiver relationship with another field (for example, sender controlling area, receiving controlling area), you can include the controlling area dimension as a transaction attribute in the transaction attributes table.

Example variable dimensions in object table 2 include controlling area, movement type, and activity.

An example of a transaction attribute object table delivered with FI-SL is GLREFC (only for local ledgers).
FI-SL Summary Database

Use
The summary database contains summarized transaction data across documents for business transactions that enter the FI-SL System. Data is summarized for each period.

Features
The summary database contains:

Fixed Dimensions
You cannot change fixed dimensions.

Client, ledger, record type, version, fiscal year, object numbers
(object/partner/transaction attribute), currency key, quantity unit, debit/credit indicator, and maximum period

Object numbers determine how the summary and line item database tables will be accessed via the object tables. The object number (receiver – ROBJNR) points to the variable dimensions defined in object table 1; the partner number (sender – SOBJNR) also points to the variable dimensions defined in object table 1. The transaction attributes number (COBJNR) points to the variable dimensions defined in object table 2.

Variable Dimensions
The variable dimensions that can be used in the summary database table are determined by the dimensions defined in object tables 1 and 2.

If the dimension was defined in object table 1:
The variable dimension can be an object (receiver) dimension, such as RCNTR, and/or a partner (sender) dimension, such as SCNTR; the dimension can be up to 10 characters long, of which up to the last nine characters must be defined in object table 1.

Object table 1 contains dimension ACCT.
The summary database table can contain an object (receiver) dimension RACCT, as well as a partner (sender) dimension SACCT.

Object (receiver) dimensions must begin with R, and partner (sender) dimensions, must begin with S.

If the dimension was defined in object table 2:
The dimension is taken over on a 1:1 basis into the summary database table.

Derived Fields
Derived fields are those fields that you do not want to include as key fields, but that you want to include in the data part of the database table (for example, Controlling Area (KOKRS) that is derived from the company code). Derived fields can only be used for reporting purposes; you cannot use derived fields in allocations or in other FI-SL functions.
An example of a summary database table structure delivered with the standard system is GLREFT (only for local ledgers). This table is only an example and must be copied for use in your system.
**FI-SL Line Item Databases**

**Use**

Normally, most of the business transactions affecting the FI-SL System will come from other SAP R/3 Systems (for example, transactions for material purchases or customer invoicing). Documents are stored in the source application database where the documents are entered. You can also store these documents, along with the detailed transaction information, in an optional FI-SL line item database.

You usually store data in an FI-SL line item database when:

- You want to input data directly to the FI-SL System, for example, when data comes from an external system or when the data is only used by the FI-SL System.

- You want to create a detailed audit trail of document information that is posted to the FI-SL System.

- You want to store line items for your rollups, for example, to reverse the rollup after it has been executed and/or drill down from the summary rollup data to the original data in reporting.

With the added flexibility of storing documents in an FI-SL line item database, you can define when you need an audit trail in the FI-SL System. By storing documents in an FI-SL line item database, you can also retrieve and review the documents in more detail from the FI-SL System.

In Customizing for *Special Purpose Ledger*, you can define at which levels an FI-SL line item database should be updated:

- For a company
- For a ledger
- For a ledger/activity combination
- For a company/ledger combination
- For an activity/ledger/company combination
- For an activity

If you set the line item update indicator in any one of the above places in the FI-SL system, the line item database will be updated; however, the line item database will only be updated for the item(s) you select.

If you set the line item indicator for a specific activity, only documents with the activity will update the line item database.

One record per document line will be written to the line item database for a ledger, regardless of how many times you set the line item update indicator in your system setup. For information about setting the line item update indicator, see the Implementation Guide (IMG) for *Special Purpose Ledger*. 

---

**April 2001**

---
Features
The actual line item database contains:

Fixed Dimensions
You cannot change fixed dimensions.

Variable Dimensions
The variable dimensions are the same as those defined in the summary database table.

Derived Fields
The derived fields are the same as those defined in the summary database table.

Additional Fields
These optional fields are only defined in the line item database if you want to include additional information for a document, for example, if you want to store the document line description.

The plan line item table contains:
- detailed information about document lines for plan documents entered into the FI-SL system.
You use this table to store plan data from previous plans and to make changes to the plan data.

Fixed Dimensions
You cannot change fixed dimensions.

Variable Dimensions
The variable dimensions are the same as those defined in the summary database table.

Derived Fields
The derived fields are the same as those defined in the summary database table.

Additional Fields
These optional fields are only defined in the line item database if you want to include additional information for a document, for example, if you want to store the document line description.

Examples of line item database table structures are delivered with your standard system: GLREFA (for actual data/local ledgers), and GLREFP (for plan data/local ledgers). These tables are only examples and must be copied for use in your system.
Database Definition and Installation

One of the first tasks in setting up your FI-SL System is to determine the variable dimensions that your ledger(s) will use. Next you must define your database structure.

Variable dimensions determine which dimensions will be stored in the key part of a data record. They also determine which variable fields of the data record key can be filled when a document is posted to FI-SL.

When you set up your system, you should first determine the dimension combinations and ledger structures that you will use in your system. Efficient structuring of your variable dimensions will result in reduced amount of required data storage.

You use the Define Table Group function to define a complete table group and store it in the ABAP Dictionary. A table group is a group of interdependent database tables (object/summary/actual and plan line item tables).

When you use the Define Table Group function, you no longer need to maintain object tables and their underlying structures in the ABAP Dictionary. You can define the variable dimensions for two object tables (partner/object and/or transaction attributes). The system automatically generates the summary and line item database tables assigned to these object tables.

Detailed procedures for defining table groups are described in the Define Table Group step in the Implementation Guide (IMG) for Special Purpose Ledger.

Once you have saved your table group, you can activate it.

You should only activate your table group when it is complete and you want to save it permanently. Any changes made to active tables can often be problematic since in some circumstances manual conversions must be made in the ABAP Dictionary.

Once you have created and activated the table group, you can install it directly from the Define Table Group transaction.

You can also inactivate FI-SL database tables, for example, if syntax errors have occurred during installation. You inactivate database tables in the table directory in Customizing. When you use the inactivation function, all tables that belong to the same table group will be inactivated. For more information, see the Maintain Table Directory step in the Implementation Guide (IMG) for Special Purpose Ledger.
Indices

In addition to the primary key, which you define in the ABAP Dictionary when creating a table, you can also define additional indices (called database indices) for transparent tables. Using indices, you can improve the time needed to access and read your database table.

You can define one index that is structured by Account, Cost Center, and Business Area. You can define another index that is structured by Cost Center, Account, and Plant.

The structure of your indices is determined by the table dimensions that you access most often.

You should exercise caution when defining database indices or contact your SAP consultant for advice on how to define efficient database indices.

For more information about database indices, see the Implementation Guide (IMG) for Special Purpose Ledger.
Master Data

Features

For each dimension in a database table, you can define master data in the ABAP Data Dictionary. Master data can be defined for each dimension that is used in a table.

The FI-SL System uses master data to:

- Validate a dimension used within the FI-SL System
- Provide text for the Report Writer
- Check values entered with direct input
- Search for valid combinations from an interval of values

You can also use master data information in document input, allocations, planning, and when working with the Report Writer.

For standard dimensions, such as "Account", "Company Code", "and Cost Center", FI-SL uses master data information from other SAP applications. However, if you define new dimensions in FI-SL that are not used in other SAP applications, you have to enter master data information for the new dimensions.

You can use master data at client level and/or at the company code or global company level. When searching for master data information, the system first checks for master data information at the company code or global company level. If master data information does not exist at this level, the system checks for master data information at the client level.

Every time you change the master data, the system records the date of the change. You can therefore check, at any time, when the master data was last changed. (This feature only applies to master data for dimensions in FI-SL and not for master data in other applications.)

Integrated Master Data

For standard dimensions, FI-SL uses master data information from other SAP applications. However, if you define new dimensions in FI-SL that are not used in other SAP applications, you have to enter master data information for the new dimensions. You use the Integrated Master Data function to define master data information for dimensions that are not used in other applications.

1. Your table contains the dimension "Evaluation area".

2. There is no master data for this dimension in the original SAP application.

   You must create a group of valid evaluation areas for the dimension "Evaluation area" within the FI-SL System.

   You should only maintain master data information in FI-SL if the data is to be used exclusively in the FI-SL System and is not to be stored in other applications.

In the integrated FI-SL master data, you can enter values for individual dimensions and for each of these values, enter a language-specific text, which describes the value.
You can only create master data for the dimensions that are specifically defined for FI-SL in table T800D (FI-SL Data Dictionary). For information about adding dimensions to table T800D, see the Maintain Integrated Master Data activity in the Implementation Guide (IMG) for Special Purpose Ledger.

You can also create FI-SL tables with names other than T830X for your FI-SL master data and master data text. These tables have the same structure as tables T830A and T831A. For information about creating FI-SL tables for master data, see the Implementation Guide (IMG) for Special Purpose Ledger.

You can only use master data in the FI-SL System to carry out validations on a field-to-field basis.

You can use the master data to validate a region, but you cannot use it to check whether a region is valid for specific countries.

For more information about creating FI-SL master data, see Creating Master Data [Seite 57].

You can use the following master data in the FI-SL System:

FI-SL Master Data: Special Purpose Ledgers [Seite 42]
FI-SL Master Data: Company Codes and Global Companies [Seite 49]
FI-SL Master Data: Field Movements [Seite 51]
FI-SL Master Data: Activities [Seite 53]
FI-SL Master Data: Special Purpose Ledgers

There are two types of ledgers used in the Special Purpose Ledger component:

**Standard Ledgers**

Standard Ledger are configured and delivered by SAP and are controlled within the individual applications. These ledgers cannot be edited using FI-SL tools (such as FI-SL’s posting functions) unless the functions are defined for the application of the standard ledger.

Standard ledgers include:
- FI’s General Ledger
- FI-LC/EC-MC’s Consolidation Ledger
- EC-PCA’s Profit Center Ledger
- CO-OM-CEL’s Reconciliation Ledger

**Special Purpose Ledgers**

Special purpose ledgers are ledgers defined to meet your specific business requirements, according to the dimensions you define. They contains the dimensions that you specify. This is the only type of ledger you can create in your FI-SL system.

FI-SL databases are sub-divided into separate logical units, or special purpose ledgers. A special purpose ledger is a collection of data in an FI-SL database.

You can create one special purpose ledger that contains cost center-related information and another special purpose ledger that contains product-related information.

Each ledger uses several dimensions that define a sub-set of the coding block of an object table. You can define your system so that you have one ledger for each database table structure, and/or more than one ledger per table structure. After you have defined the maximum coding block in the ABAP Dictionary, you define which dimensions will be used by each ledger.
The dimensions that can be used in a special purpose ledger, are determined by the field grouping code assigned to the ledger. The field grouping code contains the dimensions that are taken over from the source database table into the FI-SL database table.

**Defining Special Ledgers**

When you create a special ledger, you define:

- The dimensions used

  The dimensions used are determined by the field movement that has been defined for the special ledger and the table that is assigned to it.
FI-SL Master Data: Special Purpose Ledgers

- Ledger master data
  
  In the master data information, you can also define how the ledger is posted to, whether data in a ledger can be summarized and whether transaction data can be deleted from the ledger using the source application’s reset program.

- "Ledger/controlling area" assignment
  
  (for local ledgers) or "ledger/company" (for global ledgers)

- "Activity/ledger" assignment

- Ledger selection conditions

  Fiscal calendar for the combination "ledger/company code" or "ledger/company"
  
  (The fiscal calendar does not have to be identical to the local company code which is assigned to the company.)

- The currencies that are to be used in the special purpose ledger

  You can store three currencies in parallel in an FI-SL table:

  - **Transaction currency**: The transaction currency is the currency in which business transactions are entered into the FI-SL system.

  - **Second currency**: The second currency is the currency (previously known as local currency) that you enter in your ledger alongside the transaction currency.

  - **Third currency**: The second currency is the currency (previously known as group currency) that you enter in your ledger alongside the transaction currency and the second currency.

  You can assign various currency types to your ledgers. When you define a ledger, the system proposed possible currency combinations. When you install your system tables, the system also asks you to enter currency information for the posting (for example which currency a ledger is to be posted to).

Selecting Special Ledgers

If you are working with ledger selection conditions, you can define exactly when the ledger is to be posted to. Using the ledger selection conditions, the FI-SL Integration-Manager (the posting interface) decides which ledger(s) is/are to posted to for a given business transaction.

For each business transaction, the FI-SL tables are updated according to the rules defined by the user.

You can define that a special purpose ledger is booked to when one of the following applies:

- The business transaction affects a certain account group.

- The business transaction affects a certain product group.

- The business transaction affects a certain group of transaction types.

You can define simple and complex ledger selection conditions. Each field value or combination of field values that is affected by a business transaction can be used in the ledger selection conditions. This does not apply for amounts and quantities.
You cannot enter ledger selection conditions for standard ledgers.

For further information on defining ledgers, see the Implementation Guide (IMG) under Special Purpose Ledger ➔ Maintain Ledger.

Use

When creating special ledgers, you can use the following criteria:

- **Time** (years, quarters, months, weeks, days)
- **Dimensions** or combinations of dimensions (such as “account”, “cost center”, “product”, “region” or “account/cost center”)
- **Control criteria** (local ledgers, global ledgers)
- **Currency** (transaction currency, second currency, third currency)
- **Amounts** and additional amounts (“with amounts/additional amounts” or “without amounts/additional amounts”)
- **Different group currencies**

Several special purpose ledgers can use the same dimensions defined in a database table.

In the above graphic, the database table contains the variable dimensions Account, Cost Center, Product, Plant, and Source.

You want to create two reports:

- **Report 1** uses the dimensions Cost Center and Product.
Special Purpose Ledger

FI-SL Master Data: Special Purpose Ledgers

- **Report 2** uses the dimensions Cost Center and Account.

When you define the special purpose ledger for the reports, you could define one special purpose ledger that uses the dimensions Product, Account, and Cost Center. However, a more efficient use of the database storage might be to define two special purpose ledgers:

- **Special Purpose Ledger 1**, with the dimensions Cost Center and Product
- **Special Purpose Ledger 2**, with the dimensions Cost Center and Account

When the system selects and stores data records for Report 1 (dimensions Cost Center and Product), it only selects and stores data records for the two dimensions, instead of for all three dimensions (Product, Account, and Cost Center). You could also create a report (Report 3), which is a combination of Special Purpose Ledgers 1 and 2.

The structure you use for your special purpose ledger(s) depends on your specific reporting needs. When determining your ledger's structure(s), you should remember that every combination of dimensions that a ledger uses results in a new data record in the database.

One large special purpose ledger that contains many of the dimensions of your database table may serve the purpose of many smaller special purpose ledgers. But by using two smaller special purpose ledgers that contain specific dimension combinations, you can reduce the volume of data records in the database. For more information about summarization of data in ledgers, see [Data Summarization](#).

Each special purpose ledger contains some or all of the dimensions defined in the database table that the special purpose ledger uses. For any particular business transaction, one or more ledgers can be selected for posting.

Depending on the database structures you use, your ledgers are either:

**Local Ledgers**

You can use local ledgers to store data posted for local company codes.

**Global Ledgers**

You can use global ledgers to store data posted for:

- Global company codes
- Local company codes that are assigned to global company codes.

You can assign a local company code to a local ledger. You can also assign the same local company code to a global company code (which is assigned to a global ledger). When a document for the local company code posts to the system, it posts to the local ledger and to the global ledger.

**Naming convention:** You **cannot** use a number as the first character of a special purpose ledger name (for example, 0A, 1R, 27). If your system currently contains special purpose ledgers that are defined with a number as the first character, please contact your SAP consultant for assistance.
**Average Balance Ledger**

You can also create an average balance ledger, based on the summary data stored in a special purpose ledger. The average balance ledger automatically inherits the attributes (such as the fiscal year variant, the assigned table, and so on) of the special purpose ledger to which it is assigned. You can only use this ledger when creating reports using the average balance ledger or displaying summary records from the ledger. It is also possible to create a user exit for posting to this ledger, in the case where the posting date should not be used to determine the average balance.

**Multiple Special Purpose Ledgers**

In the FI-SL System you can summarize different kinds of business transactions into different special purpose ledgers, or have many business transactions update many different ledgers. You can also define if a special purpose ledger is mandatory for all business transactions.

In the following graphic, the same document posts to more than one special purpose ledger, but with different information.

When you define a special purpose ledger, you assign one or more companies to the ledger. When a transaction is entered for a company code, the system posts the transaction to the assigned ledgers.
You can also create multiple special purpose ledgers according to your financial needs. You do this by specifying which dimensions the special purpose ledger should use.

You may need several special purpose ledgers if you:

- Report in more than one group currency
- Simultaneously process different fiscal calendars using different fiscal year variants
- Use different levels of detail in your FI-SL System
- Simultaneously process different types of data using different activities for a special purpose ledger (for example, specific activities are assigned to a ledger; other activities are not assigned)

**Parallel Posting of Ledgers**

You can define which business transactions and dimensions flow into a special purpose ledger, and you can specify if a special purpose ledger is mandatory for a business transaction. You can also summarize different kinds of business transactions into a special purpose ledger, or post one business transaction to many different special purpose ledgers.

If a ledger selection condition is met for more than one special purpose ledger for one business transaction, the business transaction will be posted to more than one special purpose ledger.


**FI-SL Master Data: Companies**

A company code is normally defined as a balanced set of legal books. In certain environments, a company could be a subset or division of a legal entity.

For special purpose ledgers, the requirement of a balanced set of books is not mandatory.

You cannot use the prefix SAP at the beginning of your global company code.

You can use the global company code 001SAP, but you cannot use SAP001 as a global company code.

If your system currently contains companies defined with the prefix SAP, please contact your SAP consultant for assistance.

The FI-SL System uses two types of company codes:

**Local Company Codes**

These four-digit company codes are defined in the FI System and are the most commonly used company codes in the FI-SL System. You can set up your system so that a local company code directly updates a local ledger, or you can assign a local company code to a global company code so that the local company code updates a global ledger.

For more information, see the Corporate Structure Implementation Guide (under Definition → Financial accounting → Maintain company code).

**Global Company Codes**

These six-digit company codes are defined in the FI-SL System, and allow you to consolidate information in a one-to-one relationship with the company code.

Your company is a tax entity and is different from the legal company, and you also want to store more detailed information for the tax entity as for the legal company. You would then define the legal company (company code) in your system that would post to the tax entity (global company code). It is also possible for additional information to post to the tax entity.

You can also use a global company code when you want to eliminate generated revenue for a partner company.

When setting up a global company in the FI-SL System, you:

1. Define the global companies, which are to be included in your FI-SL System, using a six-digit code.
FI-SL Master Data: Companies

2. Assign an SAP four-digit company code to the global company code, if desired.

3. Assign the global company to your global ledger.

For more information, see the Maintain Global Companies step in the Implementation Guide (IMG) for Special Purpose Ledger.

Since the FI-SL System uses global company codes, you can combine local company codes within one global company code.

Multiple Companies

The six-digit global company code is a subdivision within a client and is usually defined as a balancing set of books. You can maintain any number of companies within an FI-SL client.

Normally, the company codes in other SAP applications are transferred into FI-SL on a one-to-one basis – for each local company code there can be a global company. If no data has been posted in the system, it is possible to reorganize and combine local company codes within a global company, for example, if you have many companies within one company.
FI-SL Master Data: Field Movements

Use

In addition to setting up special purpose ledgers and companies, you must also define field movement information. Field movements determine which dimensions are used within the FI-SL System. You use these dimensions to define your special purpose ledger(s). You cannot define field movements for standard ledgers that are defined in other applications.

Naming convention: You must use a letter as the first character of a user-defined field movement name (for example, R000, M001). If your system currently contains field movements defined with a number as the first character, contact your SAP consultant for assistance.

For more information about defining field movements, see the Implementation Guide (IMG) for Special Purpose Ledger.

Features

You can also determine if CO information from FI/MM/SD is to be posted as actual or statistical data. You define this information per field within a field movement. For each field in the field movement, you can enter a standard exit, which determines whether you want to take over actual data only or also statistical data.

For the field Project, you enter a standard exit so that only actual data is taken over for this field.

Posting CO Actual and Statistical Data

<table>
<thead>
<tr>
<th>To</th>
<th>You</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take over both statistical and actual data</td>
<td>Do not need to enter a standard exit.</td>
</tr>
<tr>
<td>Take over actual data only</td>
<td>Use the SAP-delivered standard exits.</td>
</tr>
<tr>
<td>Take over statistical data only</td>
<td>Need to define your own exit.</td>
</tr>
</tbody>
</table>

For more information, see the “Standard Exits for Field Movements in Special Purpose Ledger” Release Note.

User Exits in Field Movements

Within field movements, you can also enter user exits. In previous releases, user exits for field movements were stored in the following programs:

- RGIFU000, for user exits in fixed field movements (such as, Currency)
- RGIVUxxx (xxx = client), for user exits in user-defined field movements (such as Account and Cost Center)
FI-SL Master Data: Field Movements

Beginning with Release 3.0, you can define your own user exit programs. If you create a user exit program, this program name must be defined in the table for client-dependent user exits (table T80D) in Customizing. (For more information, see the Maintain Client-Dependent User Exits step in the Implementation Guide (IMG) for Special Purpose Ledger.) If you do not change table T80D, the exit programs RGIFU000 and RGIVUxxx are used.
FI-SL Master Data: Activities

Use

Each SAP application or external system, which sends data to the Integration Manager, transfers the data into the FI-SL System with a corresponding activity. An activity classifies each source of data sent to the Integration Manager and groups together data that is to be processed the same way.

Common activities are grouped together (for example, all Materials Management (MM) activities), so that it is no longer important for you to assign a specific activity to a ledger. You simply assign the activity group code to a ledger, and the system automatically assigns the relevant activities.

You can select a ledger for update based on a particular activity or group of activities. Selection of an activity can be further restricted by defining selection conditions that are based on system values. This is done by entering selection conditions for a ledger.

For more information about assigning activities to a ledger, defining selection criteria for posting to a ledger, and assigning activities from SAP applications to FI-SL, see the Implementation Guide (IMG) for Special Purpose Ledger. For a description of possible activities that can be posted to FI-SL, see the “Activity Descriptions” Release Note.
Introduction to Master Data

Use
Within the Special Purpose Ledger (FI-SL) System, you can enter master data information for any dimension used by the FI-SL System.

What Is Master Data Maintenance?
The FI-SL System uses master data values that can be found in other applications’ databases and in FI-SL tables. Master data contain the valid values for most of the dimensions that are defined in the FI-SL coding block. The location of master data is defined in Customizing during the installation of the FI-SL System. How you define master file location during installation determines where the FI-SL System accesses master data for a dimension.

You do not need to maintain standard dimensions, like Account, Cost Center, Company Code, since master data for these dimensions exist in the standard system. You only enter master data for non-standard dimensions.

For the dimension Profit Center, the system might find master data values in Controlling (CO). If you do not use the SAP CO software, you could set up the FI-SL System so that it finds Profit Center master file values in an FI-SL table.

Overview of Master File Maintenance
You use the FI-SL master file function to create master file values that are not included in the common master files of other applications.

If master file information for the dimension Profit Center does not exist in other SAP applications’ master files and the dimension Profit Center is defined in your FI-SL coding block, you can enter master file values for the dimension Profit Center.

In the following graphic, FI-SL master file values are created for the dimension Profit Center for Company Code 1000. Company Code 1000 also uses master file information from the SAP Controlling (CO) and Finance (FI) applications.
You do not need to add master data for all of the dimensions used by the FI-SL System. If the master data is defined in other databases, you can use the values entered in those master files without entering the values in FI-SL. To determine which master file values are used, the system refers to the conditions defined during installation.

You should only maintain FI-SL master data when (1) you want to add master data only for the FI-SL System (and not other applications), or (2) the master data is not stored by another application in the system.

The system uses master data to provide text for the Report Writer and to find valid values for the FI-SL Allocation and Planning components. The system also uses master data to check if values are valid during FI-SL document entry.

You can define master data at a client level and at a local/global company code level. The system first checks for master data values at the local/global company code level. If the values are not there, the system then checks for master data at the client level. In the FI-SL System, you can define master data for dimensions that are not defined in other applications' master files.

Master data is stored by dimension; therefore, a dimension must exist in the FI-SL coding block before you can enter master data values for the dimension. Also, you can only add master data for dimensions that are defined specifically for FI-SL. For more information about changing the conditions for entering master data (so that you can enter FI-SL master data for a dimension), refer to the Implementation Guide (IMG) for Special Purpose Ledger.

You can also create FI-SL tables with names other than T830X, which contain your FI-SL master data and text. These tables have the same structure as the T830A and T831A tables. For more information about creating FI-SL tables for master data and text, refer to the Implementation Guide (IMG) for Special Purpose Ledger.
Introduction to Master Data

In the FI-SL master data, you can enter values for a dimension, as well as language-specific text, which describes each value. These values only update FI-SL tables; they do not update other applications’ databases. In most cases, you will not add values for master data that exist in other systems.

The values you set up in the FI-SL master data can be different from the values that are set up in the databases of other applications. The FI-SL System can use both FI-SL master data values and master data values in other applications’ databases, but it does not mix the values for a single dimension.

If you execute user-defined user exits to validate a master file value, you can execute these user exits using the CMOD function. This allows you to create and activate user exits without having to modify the master data maintenance program.

You can still use existing exits, but new user exits must be named =Uxx to distinguish them from the previous exits (=xx).

Validating Master File Combinations

An additional function is available for validating combinations of dimensions and dimension values. By choosing Basic Settings → Master Data → Maintain Code Combination in Customizing for Special Purpose Ledger, you can maintain the dimensions stored in object tables for FI-SL summary tables so that:

- Only combinations of specific dimensions are valid.
- Dimensions or dimension combinations are only valid for a specific period of time.

When a posting is made to the ledgers that use the table, the system validates the dimension combinations.

Before you can maintain the dimension combinations of an object table, entries must be maintained in Customizing (table T800D) for the individual dimensions of the table. For more information, refer to the Maintain Integrated Master Data activity in the Implementation Guide (IMG) for Special Purpose Ledger.

You must also activate the dimension combinations so that the FI-SL programs can validate them.

Dimension validation is different from the validation/substitution functions. With dimension validations, you can perform simple validations on combinations of dimensions stored in object tables when data is being posted. Validations/substitutions allow you to create complex Boolean formulas for validating/substituting data, according to your individual system setup and requirements.
Creating Master Data

Use
You create master file values when you first set up the master files, or when no information currently exists for a master file.

If you add the dimension Profit Center to the FI-SL coding block, you can create Profit Center values in your master files.

Each dimension has its own master file. You can enter FI-SL master file values for individual local/global companies or for all of the companies within a client. It is possible to have a mixture of master file values for all companies and for individual local/global companies.

For the dimension Profit Center you can enter one set of master file values for one local/global company and another set of master file values for all of the companies within the client.

Procedure
To create master file values:


   The Create Master Data: Initial Screen appears.

2. Enter the following data:
   – Table name for the dimension values that you want to create.
   – Database field name to which the master file values will refer.
   – Beginning date for the master file values
   – End date for the master file values

3. Set the following indicators as required:
   – Select Do not post, if you do not want a user to post actual data for this master data.
   – Select Invalid for plan, if you do not want a user to use this master data for planning.

4. Choose Enter.

   A dialog box appears.

5. Enter the name of the local/global company that uses the master file values.

   If the master file values are for all companies, leave this field blank.

6. Choose Enter.

   The Create Master Data: Basic Screen appears.

7. Enter the following data:
Creating Master Data

− A value for the dimension.
  For example, if you are entering information for the dimension Business Area, you could enter 0001 for the first value, 0002 for the second value, and so on.

− Brief text for the value, up to 30 characters long

− Description for the value, up to 50 characters long

− Beginning date for the value you entered in the Value field.
  The system begins validating the value starting from this date; as of this date, the value you entered for the master file definition is valid

− An end date for the value you entered in the Value field.
  The system stops validating the value on this date; as of this date, the value you entered for the master file definition is no longer valid.

8. Set the following indicators as required:

− Select Do not post, if you do not want the system to allow actual data for a value (for example, if you only want to use the value for planning purposes).
  If you want the system to allow posting of actual data for this value, leave this indicator blank.

− Select Do not plan, if you do not want the system to allow planning for a field value.
  If you want the system to allow planning with this value, leave this indicator blank.

9. To save the information entered, choose Master Data → Save.

Result

You have created master data for a new dimension. Alternatively, you have created master data for an existing dimension for which no master data had previously been created.

Additional Processing Functions – Create Master Data: Basic Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → New lines</td>
<td>Enter additional FI-SL master file values.</td>
</tr>
<tr>
<td>Edit → Sort entry</td>
<td>Sort the FI-SL master file values in numerical or alphabetical order.</td>
</tr>
<tr>
<td>Edit → Delete line</td>
<td>Delete an FI-SL master file value.</td>
</tr>
</tbody>
</table>
Displaying Master Data

Procedure

   The Display Master Data: Initial Screen appears.

2. Enter the following data:
   – Table name for the dimension values that you want to display.
   – Database field name to which the master data refers.
   – First master file value that you want to display.
   – Last value in the range of values that you want to display.

3. Choose Enter.
   A dialog box appears.

4. Enter the name of the local/global company that uses the master file values.
   If master file values are for all companies, leave this field blank.

5. Choose Enter.
   The Display Master Data: Basic Screen appears.
Changing Master Data

Use
In certain cases, you need to change master file information for a dimension. If for example a business area name changes, you can change the text in the company's master file for the dimension Business Area.

⚠️ Use caution when changing dimension information since you may be changing values that affect existing data in your summary database.

Procedure
To change master file values:
   The Change Master Data: Initial Screen appears.
2. Enter the following data:
   - Table name for the dimension values that you want to change.
   - Database field name to which the master data refers.
   - First master file value that you want to change.
   - Last value in the range of values that you want to change.
3. Choose Enter.
   A dialog box appears.
4. Enter the name of the local/global company that uses the master file values.
   If the master file values are for all companies, leave this field blank.
5. Choose Enter.
   The Change Master Data: Basic Screen appears.
6. Type over existing data with your changes.
7. To save your changes, choose Master data → Save.

Result
You have changed the master data value(s).
Deleting Master Data

Use
When you are no longer using a master file value, you can delete it.

Use caution when deleting dimension information since you may be deleting values that affect existing data in your summary database. When you “delete” master file values, values are only inactivated and can be reactivated at a later time.

Procedure
To delete master file values:
   The Delete Master Data: Initial Screen appears.
2. Enter the following data:
   – Table name for the dimension information that you want to delete.
   – Database field name to which the master data refers.
   – First master file value that you want to delete.
   – Last value in the range of values that you want to delete.
3. Choose Enter.
   A dialog box appears.
4. Enter the name of the local/global company that uses the master file values.
   If the master file values are for all companies, leave this field blank.
5. Choose Enter.
   The Delete Master Data: Basic Screen appears.
6. Move the cursor to the master file value that you want to delete and choose Edit → Deletion mark.
   The message ** deleted ** appears next to the master file value.
   The value is flagged by the system and is no longer valid. To reinstate a value that is flagged for deletion, see Reinstating a Deleted Master File Value [Seite 63]
7. To save your changes, choose Master data → Save.

Result
You have deleted the chosen master data value. The value is flagged by the system and is no longer valid.

To reinstate a value that is flagged for deletion, see Reactivating Master Data That is Flagged for Deletion [Seite 63].
Deleting Master Data

For more information about deleting a dimension from the FI-SL coding block, see the Implementation Guide (IMG) for *Special Purpose Ledger*. 
Reinstating a Deleted Master File Value

You may decide that you want to reinstate a dimension value that you previously selected for deletion. You can reinstate the value using the Deletion mark function on the Delete Master Data: Basic Screen.

To reinstate a master file value from the Delete Master Data: Initial Screen:

1. Enter the following data:
   – Table name for the dimension information that you want to reinstate.
   – Database field name to which the master data refers.
   – First master file value that you want to reinstate.
   – Last value of the range of values that you want to reinstate.
2. Choose Enter.
   A dialog box appears.
3. Enter the name of the local/global company that uses the master file values.
   If the master file values are for all companies, leave this field blank.
4. Choose Enter.
   The Delete Master Data: Basic Screen appears.
5. Move the cursor to the master file value you want to reinstate and choose Edit → Deletion mark.
   The master file value is again valid.
6. To save your changes choose Master data → Save.
Displaying the Source of Master File Values

To view the source of master file values:

In Customizing for Special Purpose Ledger, choose Basic Settings → Master Data → Maintain Integrated Master Data.

The Change View “Fields for Master Data Validation” Overview screen appears.

The Validation field determines where the system searches for master file values. If the value in the field is preceded by an = sign, the system uses a user exit to access the FI-SL master file values for a dimension.

If you created a user-defined user exit for your master data, this user exit must be included in program SAPLGUMD. For more information about program SAPLGUMD, see the online documentation for this program.

You can also execute user-defined user exits using the CMOD function. This allows you to create and activate user exits without having to modify the above master file management program.

If the value is not proceeded by an = sign, the system refers to an FI-SL table to access master file values for a dimension. (This table number appears in the Validation field).
Additional FI-SL System Prerequisites

This section gives an overview of the additional system settings required for working in the FI-SL System once you have defined your FI-SL database tables and master data.

Posting Periods [Seite 66]
Versions [Seite 69]
Validations, Substitutions and Rules [Seite 1038]
Posting Periods

Use

Before data can be posted in FI-SL, you must define accounting periods and allowed accounting periods. Accounting period definitions determine the fiscal year(s) and posting periods that are available on the system; allowed accounting periods determine which posting periods are open for posting data.

You can define your fiscal calendars so that the system identifies data by a unique posting period. You only define the end date for the period. The system uses the business transaction date (posting date) to calculate to which fiscal period of a special purpose ledger the transaction data should be posted.

Features

• Each business transaction can be posted to different periods in different special purpose ledgers, depending on the accounting period definition of the ledgers.

  One special purpose ledger may only contain information necessary for a weekly sales report, but the same business transaction may also flow into a general special purpose ledger, used to create a monthly balance sheet. The first special purpose ledger would have 52 periods; the second ledger would have 12 periods.

• You can define as many concurrent fiscal calendars as you need, and you can define up to 366 posting periods (for example, for an average daily balance ledger) in a fiscal calendar.

  When posting from outside of FI-SL (for example, via FI or CO), the Integration Manager does not check if a period is open for posting. This check should be completed in the system from which you are posting (sender system).

Accounting Period Definition

When you set up your FI-SL System, you must designate accounting period definitions for the system. Accounting period definitions determine the fiscal calendar, which defines the fiscal year and the posting periods within the fiscal year.

For more information about defining accounting periods, see the Implementation Guide (IMG) for Special Purpose Ledger.

Allowed Accounting Period Definition

You must designate allowed accounting periods for each company/ledger combination. Allowed accounting periods determine which periods are open for posting for data to post for a company/ledger combination. If you do not open an accounting period for a company/ledger combination, data cannot be posted to the company/ledger combination.
You can define a fiscal year variant for a local company code, and then define a **different** fiscal year variant for the local company code/ledger combination.

You can define allowed accounting periods for different versions and for different record types (for example, plan data, actual data). You can open or close the accounting periods at any time for a version/record type combination within a company/ledger combination.

For more information about defining allowed accounting periods, see the Implementation Guide (IMG) for *Special Purpose Ledger*.

### Special Periods

Using the fiscal year variant, it is now possible to use special periods in FI-SL. When you define a fiscal year variant, you enter the periods and special periods for a fiscal year. You then assign the fiscal year variant to a company. You also assign a fiscal year variant to a company/ledger combination when you define a special purpose ledger. The fiscal year variant(s) assigned to a company and to a company/ledger combination determines if special periods are used.

Using the fiscal year variant, the system posts to special periods as described in the following table.

#### If/Then Table for Posting to Special Periods

<table>
<thead>
<tr>
<th>If the fiscal year variants assigned to the company and to the company/ledger combination are:</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>The same</td>
<td>Data is posted to the corresponding special periods defined for the ledger/company combination.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Different, and there are <strong>fewer</strong> special periods in the ledger fiscal year variant as in the company fiscal year variant</th>
<th>Data is posted to the last available special period defined for the ledger/company combination. If no special period is defined, the highest normal period is used.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Example:</strong></td>
<td></td>
</tr>
<tr>
<td>The company fiscal year variant has four special periods, and the ledger/company fiscal year variant has two. You post to the fourth special period. The system would post to the second special period of the ledger.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Different, and there are <strong>more</strong> special periods in the ledger fiscal year variant as in the company fiscal year variant</th>
<th>Data is posted to the corresponding special period defined for the ledger/company combination.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Example:</strong></td>
<td></td>
</tr>
<tr>
<td>The company fiscal year variant has two special periods and the ledger/company fiscal year variant has four. You post to the second special period. The system would post to the second special period of the ledger.</td>
<td></td>
</tr>
</tbody>
</table>
Posting Periods

When posting to a special period in FI-SL using the *Actual posting* function from the *Special Purpose Ledger* screen, you can only post to the special period when the posting date occurs within the last normal period of the fiscal year.

To post to special periods for a global company, you must assign a local company code to the global company. If you are posting to a global company and a local company code is *not* assigned to the global company, you cannot post to special periods for the global company.
Versions

Use
Within a special purpose ledger, you can store different versions of data. You can also store a specific record type per version.

A record type can be one of the following:

- Actual data
- Plan data
- Actual allocation data
- Planned allocation data

You define a version by record type and version number.

You can define two different versions for your plan data – plan version 1 and plan version 2.

Versions within a record type are already defined on your FI-SL system.

You can add more versions using the in Customizing for Special Purpose Ledger.

The FI-SL version concept is a result of the planning portion of the FI-SL software package. Using FI-SL’s planning software, you can maintain various planning versions for the same or different periods. SAP uses plan versions as well as allocation versions; under carefully controlled circumstances, FI-SL also uses various actual data versions. The FI-LC System also uses versions to establish various consolidation options and to determine which consolidation versions are the most desirable.

Until Release 3.0, actual data was always taken over into FI-SL’s version 001. Now, you can store actual CO data in different FI-SL versions. The versions must be assigned to the ledger in order for the data that uses the version to be updated in the ledger. Version 001 is still reserved for FI, SD, and MM actual data.

For more information about defining versions, see the Maintain Plan Versions and Maintain Actual Versions steps in the Implementation Guide (IMG) for Special Purpose Ledger.
Validations, Substitutions, and Rules

Purpose
With the validations and substitutions software, you can validate and/or substitute data at the time of entry in the FI-SL System and other SAP Systems.

Implementation Considerations
You do not need to change the standard system to customize your validations and substitutions. For each installation, you can define exactly which validations and substitutions are necessary to ensure the integrity of your data.

Features

Validation
In the SAP System, almost all input values are validated by a program or against tables or master files. Since some types of validations cannot be standardized, you can use FI-SL’s validations program to create validations for your system.

With validations, you can check values and combinations of values as they are being entered in the SAP environment. Validation rules are stored in the Rule Manager; as data is entered, the Integration Manager validates the data against the validation rules stored in the Rule Manager. Because data is validated before it is posted, only valid information enters the FI-SL System.

You define validation rules using Boolean logic. When you define a validation rule, the system checks the validation rule to ensure that it is syntactically correct.

You can also define the result of breaking the validation rule. For instance, you can specify that a message is issued but the user can continue processing. You can also force the user to correct the error before processing can continue.

For more information, see Validation [Seite 1056] or What Are Validations? [Seite 1040]. For more information on using validations, see Creating a Validation [Seite 1057]. For more information on Boolean Logic, see Introduction to Boolean Logic [Seite 1121].

Substitution
Substitution rules are stored in the Rule Manager. When data is entered in the system, it is substituted by the Integration Manager. The Integration Manager calls the Rule Manager. Substitution occurs before the data is posted to the FI-SL databases.

You define substitution rules using Boolean logic. When you define a substitution rule, the system checks the substitution rule to ensure that it is syntactically correct.

For more information, see Substitution [Seite 1083] or What Are Substitutions? [Seite 1043]. For more information on using substitutions, see Creating a Substitution [Seite 1084]. For more information on Boolean Logic, see Introduction to Boolean Logic [Seite 1121].

Rules
A rule is a Boolean expression that you can use as a condition, as a check, or in another rule. Rules enable you to refer to frequently used Boolean statements simply by specifying the rule name.
The FI-SL Integration Manager uses Boolean logic. When you use Boolean logic and syntax, you can:

- Validate data
- Substitute data
- Select ledgers for posting
- Transfer substitution data to a rollup ledger
- Select report data

The Rule Manager stores the Boolean rules used to analyze data. The Integration Manager calls the Rule Manager and determines whether entered data should be used. If a Boolean statement is true, an action is taken; if a statement is false, no action is taken.

Boolean logic is used in the following FI-SL modules:

- Validation
- Substitution
- Ledger selection
- Report Writer
- Rollups

To use Boolean Logic in one of the functions listed, you create statements that are used as formulas in the FI-SL System. For more information on using Boolean Logic, see Introduction to Boolean Logic [Seite 1121] or Boolean Logic Statements and Rules [Seite 1048].
Planning

Purpose
With the Planning function in the Special Purpose Ledger [Extern], you can enter and distribute plan data to create budgets, forecasts, and other reports.

You can quickly and easily enter large amounts of plan data. Generally, you can enter plan amounts in the following ways:

- You can enter amounts as plan totals that are (automatically or manually) distributed to the planning periods.
- You can enter amounts as period amounts that are automatically totaled.
- You can enter a combination of both totals and period amounts.

For information on creating plan data, see Creating Plan Data [Seite 79].

Implementation Considerations
Before you can complete planning in the Special Purpose Ledger, you have to set up planning in Customizing. For more information, see Setting Up Planning [Seite 75].

Integration
You can transfer plan data from the following SAP components to complete planning:

- Overhead Cost Controlling (CO-OM)
- Profitability Analysis (CO-PA)

To transfer data, choose Accounting → Financial accounting → Special Purpose Ledger → Periodic processing → Data transfer → CO plan data object/document or CO-PA plan data.

Additional information:

CO plan data is only posted directly to FI-SL when a plan version is defined for the ledger to which the CO data is to be posted. If you want to post planning data to a FI-SL ledger, you must maintain a plan version for the ledger in Customizing. Additionally, you have to activate plan integration in Controlling Customizing.

Features
The following options are available in Special Purpose Ledger planning:
Your planning can be completed centrally or locally. When setting up planning, you provide a framework for the individual planners and assign authorizations. You can also adapt the entry screen layout.

You can use Microsoft Excel to enter the data. The individual planners can enter their plan data using Microsoft Excel. You can then import this plan data to the SAP System. See Excel Integration in Planning [Extern].

You can post plan data to a nearly unlimited number of forecast versions per year. You define plan versions in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Planning → Plan Settings → Maintain Plan Versions [Extern].

You can use existing actual and/or plan data (for example, from previous years) as a reference for a new plan. To do so, choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Copy model plan → Local or Global. See Using a Model Plan [Seite 124].

You can compare actual and plan data.

You can display totals records of your plan data. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Display totals. See Displaying Totals Records [Seite 168].

You can display individual plan documents. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Display plan documents. → Local or global plan documents. See Displaying Plan Documents [Seite 127].

With the allocation functions, you can assess or distribute plan data. To do so, choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Planned close → Plan assessment or Plan distribution.

With rollups [Extern] you can summarize plan data.
Master Data and Planning

Planning uses master data to validate entries and to store other master data information. If not master data exists for the dimensions of your plan sets, the system cannot check the values entered. In this case, you would receive an error message.

If your set contains the cost centers 100 and 200, but these cost centers are not in the master data, the system displays an error message.

Master data information may be located in different places in the system. When the system searches master data information, it checks the settings in Customizing. The master data being searched for is stored here.

For information about defining and editing FI-SL master data, see Creating Master Data [Seite 57].
Setting Up Planning

Purpose
Before you can complete planning in the Special Purpose Ledger, you have to set up planning in Customizing.

The activities for setting up planning are found in Customizing under Financial Accounting → Special Purpose Ledger → Planning.

Process flow
You have to complete the following activities:

1. Define one or more planning layouts [Seite 76].
   
   For each planning layout, you determine which summary table your planning is to be based on, which characteristics and key figures are to be used, and the layout of the creation screen. You can also enter certain values for selected characteristics and key figures.
   
   You define a planning layout for each variant of your planning.

2. Define one or more planner profiles [Seite 77] and assign the desired planning layouts to each planner profile.
   
   Planner profiles are used to provide the individual planner a selection of the plan tasks that are created for his/her area of responsibility.
   
   With a planner profile, you control the planning process. For each summary table, you determine which plan tasks are to be used, that is, which planning layouts with which default parameters. You also determine which users are allowed to complete which planning activities by assigning an authorization group to each planner profile.

3. A planner profile must be assigned to each user who is to carry out planning. To assign a planner profile, from the main menu choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Set planner profile.

Result
You have set up planning. The individual planners can now enter their plan data. You can read more about how to create plan data and the functions available in Entering Plan Values [Seite 80].
Planning Layout

Definition
Form that determines how planning is carried out based on the characteristics and key figures of a summary table and how the screen is set up for completing planning.

Use
Since the tables you installed serve as the basis in the Special Purpose Ledger, you have to specify the tables on which the planning layout is based.

With a planning layout, you define:

• How you want to carry out planning, based on the characteristics and key figures
• How the screen is set up for planning, that is, you define how the characteristics and key figures are arranged
• Whether you want to enter default values of intervals for selected characteristics and key figures
• Whether you want to include actual key figures in your planning

You define planning layouts in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Planning → Define Planning Layout [Extern].

Planning layouts are created using the Report Painter [Seite 726]. You can use all the functions of the Report Painter when editing your planning layouts.

You cannot use sets for periods in your planning layout.

Structure
A planning layout consists of the following parts:

• Header area
  The header area is defined by the general selection criteria.

• Key column(s)
  The key columns contain the characteristics that identify the individual lines in the planning layout, such as account or cost center.

• Value columns
  The value columns contain the key figures to be planned, that is, the plan values.
Planer Profile

Definition
Hierarchically structured overview of plan tasks [Exterm].
Defined per summary table in a planner profile are the plan tasks and the order they are used in planning.

Use
Planer profiles are used to provide the planner a selection of the plan tasks that are created for his/her area of responsibility. Before a planner can start planning, he/she has to assign a planner profile to him/herself.

With planner profiles, you control the planning process. For each summary table, they determine which plan tasks are used with which default parameters. For each table, you can create multiple plan tasks.

The plan tasks are assigned to a planner profile and profile items. The profile items determine the order of the plan tasks in a planner profile. You can assign the same plan task multiple times to a planner profile, but only with different default parameters.

In a planner profile, you set the following default parameters for planning:

- **Authorizations**
  
  You can assign an authorization group to each planner profile.
  
  By defining planner profiles specifically for the planners and by assigning corresponding authorization groups to the planner profiles, you can ensure that the individual planners can only complete planning in their individual areas of responsibility.

- **Default parameters**
  
  You can assign default parameters to your planning layouts. The combination of planning layout and default settings is a plan task.
  
  With the default parameters, you provide default values for variables of a planning layout.
  
  In a planner profile, you define whether values can be overwritten when completing planning.

You define planner profiles in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Planning → Define Planner Profile [Exterm].

When defining the planner profile, you can set an indicator for the second and thire currencies, so that entries can be made in these fields. This allows you to make entries in these currencies **without** the amounts in the first currency being translated to the second and third currencies.

If this indicator is **not** set, the amounts in the first currency are automatically translated into the second and third currencies, if you have included these fields in your planning.
Planner Profile

**Structure**

Planner profiles are structured hierarchically.

General planner profiles
  - Plannable tables
    - Plan tasks for a table
    - Default parameters

**Integration**

You can use planner profiles from other application components such as Profitability Analysis (CO-PA) or Cost Center Accounting (CO-OM) and enhance them to include plan tasks from the Special Purpose Ledger.
Creating Plan Data

Use
You have various options available to you for creating and displaying plan data.

- You can create your plan data in a R/3 screen. See Entering Plan Values [Seite 80].
- You can activate Microsoft Excel as an interface for entering your plan data. See Excel Integration in Planning [Extern].

When entering plan data, various functions such as copy, cut, and paste are available. See Planning Functions [Seite 82].

Prerequisites
Before you can enter plan data, your planning has to be set up, that is, your planner profiles and plan tasks have to be defined. For more information, see Setting Up Planning [Seite 75].
Creating Plan Data

Use

The following options are available for creating plan data:

- You can create plan data by entering plan totals, which you then distribute to the individual plan periods using a [distribution key](#).
- You can enter plan data for the individual plan periods and have the system total these amounts.
- You can enter both total amounts and period amounts.

Prerequisites

Before you can enter plan data, the following settings have to be made:

- Planning must be set up. For more information, see [Setting Up Planning](#).
- A planner profile has to be assigned to you, that is, a planner profile and the related summary table must be entered in your user master record. To assign a planner profile, from the main menu choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Set planner profile.

Procedure

To create plan data, proceed as follows:

1. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Planned values → Enter.

   The initial screen appears. In the initial screen, the first plan task of the current planner profile is displayed. You can switch between the plan tasks of the planner profile. To do so, choose or .

   ![Switching between plan tasks]

   The system displays the planner profile that was last saved in your user master record. If, for example, you completed a planning session in the planning tool [Page 120], the planner profile from this session is displayed.

2. Enter values for the characteristics.

   You can overwrite default characteristic values, if they are defined in the plan task as such.

   ![Overwriting default characteristic values]

   If fixed values were preassigned for all characteristics when the plan task was defined, the overview screen is displayed, that is, you can enter the plan data directly.

3. Choose .

   The overview screen appears.

4. Enter your plan data.
The following functions are available for entering and processing plan data. You can find the documentation for these functions under Planning Functions [Seite 82].

5. Save your entries.

6. Select a plan value with the cursor and choose 📊.

   The period screen appears.

7. The system displays the distribution of the selected plan value to the individual periods. You can switch between the screens of the individual periods. To do so, choose 📊 or 📊.

   The distribution depends on the distribution key [Seite 103] that was entered when the plan task was defined. The following options are available for distributing a plan value to periods.

   - You can change the distribution key in the overview screen.
   - You can overwrite the displayed period values. The new is automatically stored under the manual distribution key 0 when saving and the new plan total is calculated.

8. Save your changes.
Planning Functions

Use
When creating and editing plan data, various functions are available such as cut, copy, and paste. You can also enter a long text.

Features
The following functions are available:

- Reload data [Seite 83]
- Reverse row/Entries, restore [Seite 84]
- Cut [Seite 85]
- Copy [Seite 87]
- Insert [Seite 89]
- Change values [Seite 91]
- Line item display [Seite 92]
- Long text [Seite 93]
- Target value search [Seite 94]
- Sort [Seite 96]
- Print preparation [Seite 97]
- Number format [Seite 98]
- Key columns [Seite 99]
- Header display on/off [Seite 101]
- All key values on/off [Seite 102]
Reload Data

Use

With this function you can reload plan or actual data, that is, you can update this information. This function is useful in the following cases:

- If you want to display actual data in your plan task, you can update the data.
- If you are working with several people on a plan task, you can display the current plan values.
Clear Row, Undo, Redo

Clear Row

This function is only active when you make an entry that is not allowed.

It allows you to reverse the entries made in the row where the error occurred, thus returning the row to its last valid state in the planning session. The system then continues checking the entries with the next row.

Undo

This function (pushbutton) reverses all the entries in the last dialog step. The system always stores the five last states so that you can restore these. However, these states are lost each time you switch from the overview screen to the period screen or back. After that you can no longer undo the previous step.

If you choose this function by mistake, you can “undo” the “undo” using the Redo function.

Redo

The Redo function (pushbutton) is only active after you have used the Undo function.
Cut

Use
This function lets you move all the data in the selected range to the clipboard. When you do that, the system clears the selected cells.
You can select any of the following:
• An entire value column
• A block within a value column
• A block of value cells within a row
You can select an entire column by clicking on the column header. To select a block, use the Select block function. You can also select areas by positioning the cursor. The system interprets the cursor position as follows:

<table>
<thead>
<tr>
<th>Where is the cursor?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>in a lead column (not a blank row)</td>
<td>the row where the cursor is positioned</td>
</tr>
<tr>
<td>on a data cell (not a blank row)</td>
<td>the cell where the cursor is positioned</td>
</tr>
<tr>
<td>any other position</td>
<td>nothing</td>
</tr>
</tbody>
</table>

If you have explicitly selected a block or entire column, the system ignores the cursor position.

Prerequisites
The selected area may not contain any attribute cells (such as distribution keys), since these cannot be cleared.

Features
When you choose Cut, all the selected cells are cleared (set to “0”) and the values contained there are moved to the clipboard. The contents are the clipboard are
• Overwritten, the next time you use the Cut or Copy function or
• Deleted as soon as you switch from the overview screen to the period screen or back.
The function Paste [Seite 89] lets you insert the values from the clipboard to another position on the entry screen.

If you want to reverse the Cut function, choose Undo entries or the corresponding icon.
Copy

Use
This function lets you copy all the data in the selected range to the clipboard.
You can select any of the following:

- An entire value column
- A block within a value column
- A block of value cells within a row
- An entire row

You can only paste a row into another row if the target row is ready for input. Consequently, the screen must contain rows that are ready for input before you can copy entire rows to the clipboard.

You can select an entire row or column by clicking on the row or column header. To select a block, use the Select block function. You can also select areas by positioning the cursor. The system interprets the cursor position as follows:

<table>
<thead>
<tr>
<th>Where is the cursor?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>in a lead column (not a blank row)</td>
<td>the row where the cursor is positioned</td>
</tr>
<tr>
<td>on a data cell (not a blank row)</td>
<td>the cell where the cursor is positioned</td>
</tr>
<tr>
<td>any other position</td>
<td>nothing</td>
</tr>
</tbody>
</table>

If you have explicitly selected a block or entire column, the system ignores the cursor position.

Features
When you choose Copy, the values contained in the selected cells are copied to the clipboard. The contents are the clipboard are

- **Overwritten**, the next time you use the Cut or Copy function or
- **Deleted** as soon as you switch from the overview screen to the period screen or back.

The function Paste [Seite 89] lets you insert the values from the clipboard to another position on the entry screen.
Paste

Prerequisites
You can only use this function if you have already cut or copied data to the clipboard. For details, see Cut [Seite 85] and Copy [Seite 87].

Use
The function Paste lets you insert the values from the clipboard to the selected area on the entry screen.

Where the data is inserted depends on what is in the clipboard and what you have selected (either explicitly or by positioning the cursor) on the entry screen.

<table>
<thead>
<tr>
<th>What is in the clipboard?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>an entire column</td>
<td>You can select either the entire target column or the first cell in that column.</td>
</tr>
<tr>
<td>an entire row</td>
<td>You can either select the entire target row (blank row) or position the cursor on the target row in the lead column.</td>
</tr>
<tr>
<td>a block within a column</td>
<td>Select the first cell (on the left) of the area where you want to insert the data from the clipboard. The data is inserted there and in the cells to the right.</td>
</tr>
<tr>
<td>a block within a row</td>
<td>Select the first cell (on the left) of the area where you want to insert the data from the clipboard. The data is inserted there and in the cells to the right.</td>
</tr>
</tbody>
</table>

If you have explicitly selected a block or entire column, the system ignores the cursor position.

Tips
When using the Paste function, note the following:

- You can copy entire rows to the clipboard. If you do, you can only insert the row in a blank row that allows data entry. The system inserts the characteristic values in the lead columns along with the values in the value columns. However, if you only copied the row, note that the combination of characteristics already exists. You therefore need to change the new row.
- If some cells in the target range are in display mode, the values in those cells are not overwritten. However, if you change values that are used to calculate other values, this could also change those calculated values, even if they are in cells that are not ready for input.
- The Paste function does not change or delete the content of the clipboard.
If you want to reverse the Cut function, choose Undo entries or the corresponding icon.
Change Values

Use
To use the function Change values, you first need to select a range of data cells that does not contain any attributes (such as distribution keys). You can then change the values in the selected range using the functions Revaluate and Add.

Features
• Revaluate
  This function increases the values in the selected cells by a percentage that you enter. You can also enter a negative sign, in which case the values in the selected cells are decreased by that percentage.

• Add
  The Add button lets you add the value you specify in the Value field to the values in the selected cells. Again, you can enter a negative sign, in which case the value you entered is subtracted from the previous values.

If you want to reverse the Change values function, choose Undo entries or the pushbutton (see Clear Row, Undo, Redo [Seite 84]).
Line Item Display

Use

With this function, you can display the change documents of a plan value.
Long Text

Use
With this function, you can create a long text for a plan value or display an existing long text. If, for example, you are working together with several people on the planning, you could enter explanations for the individual plan values.

Features
You create long texts with the SAPscript [Extern] editor. All the functions of this editor are available.
Goal Seek Function

Use

The goal seek function is used in manual planning to find the content of a cell automatically by referencing another cell that shares the first cell’s function. The cell whose content is to be sought is referred to as the source cell. The target cell must be linked to the source cell by a formula and must represent the result of this formula.

You can enter a value - the target value - for the target cell in the goal seek function. After the function has been carried out, the value necessary for reaching the target value is written to the source cell. In this way, the system simulates manual entry.

Your planning layout contains, among others, the following columns: planned revenue, planned quantity and planned price. The planned revenue is the product of planned quantity and planned price.

When entering planning figures, you can use the goal seek function to produce in the planned price cell the value required in order to attain a certain target revenue, such as 120,000 USD. Select the planned price as the source cell and the revenue as the target cell. Ensure that there is a value in the planned quantity cell.

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity</th>
<th>Price</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>P-100</td>
<td>20</td>
<td>5000</td>
<td>100,000</td>
</tr>
<tr>
<td>P-100</td>
<td>20</td>
<td>6000</td>
<td>120,000</td>
</tr>
</tbody>
</table>

Since the source cell must always be the cell unlocked for manual entry, the system automatically designates as source cell that cell of the selected pair that is unlocked. If both of the selected cells are unlocked for entry, you can switch the cells round after having selected the goal seek function and then specify the source cell.

Prerequisites

- Your current planning layout should always contain formulas or ratios.
You need to select two cells and ensure that at least one of those selected - the source cell - is unlocked for manual entry.

All cells used to calculate between the source and target cells must have entries.

Neither of the selected cells should be the totals row.

**Activities**

1. Select just two cells.
2. Choose *Edit ➔ Goal seek*.
3. If necessary, change around the source and target cells.
4. Enter a target value.
5. If you want to cancel the result produced by the goal seek function, choose *Edit ➔ Undo ➔ Undo entry*. 
Insert

This function lets you insert new lines between existing ones.
Format to Print

This function lets you display the data you are currently displaying in list form, so that you can then do the following:

- print it
- send it as an attachment in SAPmail
- save it in a report tree
- download it to a file on your PC

It is technically not possible to print directly from the data entry screen. Consequently, the system formats all the data that meets the current selection criteria as a report list. This list looks exactly like the data entry screen. This means, for example, that if you change the width of a column on the entry screen, that will affect the width in the report list. It is not possible to change the report list directly.
Number Format

This function lets you change the way the values in a specific column are displayed. For example, you can display the values in millions with one decimal place. This does not affect the way the data is stored.

The number formats used when you first call up the planning screen are taken from the definition of the planning layout.
Lead Columns

Use

When planning data is entered, the total for all entries in the planning layout is always displayed in several lead columns. Furthermore, you can choose to have a **subtotal** displayed for each characteristic in the lead column. To make this setting, select/deselect the option **Total** in the relevant dialog box. If you are working with two lead columns and you select the option **Total** for just one of them, all the value fields for the characteristics in the other lead column are then summarized.

Planning layouts with only one lead column are the exception. The default setting is for no total to be displayed, but you can have it displayed by selecting the option **Total**.

With the default settings, an overview screen could appear as in the following example:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
</tr>
<tr>
<td>4711</td>
<td>410000</td>
<td>20</td>
</tr>
<tr>
<td>4711</td>
<td>420000</td>
<td>30</td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
</tr>
<tr>
<td>4712</td>
<td>410000</td>
<td>50</td>
</tr>
<tr>
<td>4712</td>
<td>420000</td>
<td>60</td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
</tr>
<tr>
<td>4713</td>
<td>410000</td>
<td>80</td>
</tr>
<tr>
<td>4713</td>
<td>420000</td>
<td>90</td>
</tr>
<tr>
<td>*Cost center</td>
<td>*Cost element</td>
<td>450</td>
</tr>
</tbody>
</table>

If you select the option **Total** in the dialog box for the cost center, the following representation appears:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
</tr>
<tr>
<td>4711</td>
<td>410000</td>
<td>20</td>
</tr>
<tr>
<td>4711</td>
<td>420000</td>
<td>30</td>
</tr>
<tr>
<td>*Cost element</td>
<td>60</td>
<td></td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
</tr>
<tr>
<td>4712</td>
<td>410000</td>
<td>50</td>
</tr>
<tr>
<td>4712</td>
<td>420000</td>
<td>60</td>
</tr>
<tr>
<td>*Cost element</td>
<td>150</td>
<td></td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
</tr>
<tr>
<td>4713</td>
<td>410000</td>
<td>80</td>
</tr>
<tr>
<td>4713</td>
<td>420000</td>
<td>90</td>
</tr>
<tr>
<td>*Cost element</td>
<td>240</td>
<td></td>
</tr>
<tr>
<td>*Cost center</td>
<td>*Cost element</td>
<td>450</td>
</tr>
</tbody>
</table>
Lead Columns

In Customizing, you can make the subtotals be displayed using default parameters: when you are in CO-PA, you do this in the parameter set, when you are in other applications, you do this during planner profile definition. When entering planning data in the application, you can alter this setting for the duration of that planning session.

Activities

By choosing Settings → Lead Columns... in Customizing as well as in the application, you can access the dialog box to set the subtotals display.
**Header Display On/Off**

**Use**

The function *Header display on/off* allows you to display or hide information at the top of the overview screen and of the period screen. The setting is only valid during that particular planning session.

**Activities**

Choose *Settings → Header display on/off*. 
All Key Values On/Off

Use

In planning layouts containing with several lead columns, it can occur that several characteristic values relate to the same value in another column. In such cases, the system default is to display the repeated characteristic only once in the overview screen.

By choosing Settings → All key values on/off, you can set the repeated characteristic values to be displayed or hidden. The selected setting, however, is only valid for the planning session you are working in.

Standard Setting All Key Values Off.

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brown plc</td>
<td>Pump P-100</td>
<td>100 000.00</td>
</tr>
<tr>
<td></td>
<td>Pump P-110</td>
<td>50 000.00</td>
</tr>
<tr>
<td></td>
<td>Pump P-200</td>
<td>120 000.00</td>
</tr>
<tr>
<td>Smith Ltd</td>
<td>Pump P-200</td>
<td>200 000.00</td>
</tr>
</tbody>
</table>

All Key Values On

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brown plc</td>
<td>Pump P-100</td>
<td>100 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-110</td>
<td>50 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-200</td>
<td>120 000.00</td>
</tr>
<tr>
<td>Smith Ltd</td>
<td>Pump P-200</td>
<td>200 000.00</td>
</tr>
</tbody>
</table>

In order that you can distinguish the initial value of a characteristic from a hidden value, the initial value is displayed with the special character "#".
Distribution Key

Definition
Key which specifies the rules to be used to distribute a plan value to the individual plan periods.

Use
With the distribution key, you distribute your plan values or plan totals for the year to the individual plan periods. The distribution key contains information on the rules used for distribution.

Structure
The following distribution keys are available:

- **Standard distribution keys**
  You can use the standard distribution keys that are included in the standard system. See [Standard Distribution Keys](#)

- **Customer-defined distributions keys**
  You can define your own distribution keys to meet your specific needs. You can specify that each period receive a relative portion of the plan total. See [Defining a Distribution Key](#)

Integration
Distribution keys are application independent, that is, you can use distribution keys from other applications such as Controlling when planning in the Special Purpose Ledger. You can also use distributions keys you created for planning in the Special Purpose Ledger in other applications.
Distribution Key
Standard Distribution Keys

Use
SAP provides the following standard distribution keys:

- **Distribution key 0**
  Used to enter values manually for each period.

- **Distribution key 1**
  Used to distribute the input value (annual plan value) equally across all plan periods.

- **Distribution key 2**
  Used to distribute the input value (annual plan value) according to the last distribution key used.

- **Distribution key 3**
  Interprets the input value as a percentage rate and multiplies it each period by the previous value.

- **Distribution key 4**
  Used to distribute period values not equal to zero to the subsequent empty periods.

- **Distribution key 5**
  Copies period values not equal to zero to the subsequent empty periods.

The SAP R/3 System differentiates between true distribution keys and input help.

- If a plan value is distributed on periods using a true distribution key, the sum of all period values always equals the sum of the original plan values entered.

- If you use an input help, the original value entered may change.

  The standard distribution keys 0, 3, 4, and 5 are input helps only. You change the entered parameters. The system does not save these distribution keys. This is so that new changes to the plan values can be avoided. Instead, it resets them to zero after use.

- **Distribution key 6**
  Copies a given period value to subsequent periods.

  This distribution key has no effect on the manually planned values, as it is used on the period level. The distribution keys are, however, available on the annual level.

- **Distribution key 7**
  Used to distribute the input value (annual plan value) among the individual periods in line with the number of calendar days per period.

- **Distribution key 11**
Standard Distribution Keys

Can only be used in Cost Center Accounting for planning activity-dependent costs or activity-dependent statistical key figures.

The input value (annual plan value) is distributed in line with the activity quantity planned on the cost center.

⚠️ The R/3 System uses only those activity quantities planned at the time of the distribution key’s use. If you change activity quantities later or copy plan values to another version, the R/3 System does not automatically carry out new distributions.
Examples of Standard Distribution Keys

The following graphics illustrate distribution, based on the various distribution keys. The examples use monthly planning. Distribution keys can also be used in the same manner for other period cycles (for example, quarterly planning).

### Distribution Key 0
- **Individual values entered manually for each period**

<table>
<thead>
<tr>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
</tr>
<tr>
<td>3</td>
<td>1,500</td>
</tr>
<tr>
<td>4</td>
<td>1,500</td>
</tr>
<tr>
<td>5</td>
<td>2,000</td>
</tr>
<tr>
<td>6</td>
<td>2,500</td>
</tr>
<tr>
<td>7</td>
<td>2,500</td>
</tr>
<tr>
<td>8</td>
<td>2,500</td>
</tr>
<tr>
<td>9</td>
<td>2,000</td>
</tr>
<tr>
<td>10</td>
<td>2,000</td>
</tr>
<tr>
<td>11</td>
<td>2,000</td>
</tr>
<tr>
<td>12</td>
<td>1,500</td>
</tr>
</tbody>
</table>

**Total:** 24,000

### Distribution Key 1
- **Equal distribution across the individual periods**

<table>
<thead>
<tr>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
</tr>
<tr>
<td>3</td>
<td>2,000</td>
</tr>
<tr>
<td>4</td>
<td>2,000</td>
</tr>
<tr>
<td>5</td>
<td>2,000</td>
</tr>
<tr>
<td>6</td>
<td>2,000</td>
</tr>
<tr>
<td>7</td>
<td>2,000</td>
</tr>
<tr>
<td>8</td>
<td>2,000</td>
</tr>
<tr>
<td>9</td>
<td>2,000</td>
</tr>
<tr>
<td>10</td>
<td>2,000</td>
</tr>
<tr>
<td>11</td>
<td>2,000</td>
</tr>
<tr>
<td>12</td>
<td>2,000</td>
</tr>
</tbody>
</table>

**Input value:** 24,000

### Distribution Key 2
- **Distribution according to an existing distribution**

<table>
<thead>
<tr>
<th>Period</th>
<th>Prev. value</th>
<th>Subs. value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,000</td>
<td>3,000</td>
</tr>
<tr>
<td>2</td>
<td>4,000</td>
<td>6,000</td>
</tr>
<tr>
<td>3</td>
<td>3,000</td>
<td>4,500</td>
</tr>
<tr>
<td>4</td>
<td>3,000</td>
<td>1,500</td>
</tr>
<tr>
<td>5</td>
<td>1,000</td>
<td>1,500</td>
</tr>
<tr>
<td>6</td>
<td>1,000</td>
<td>1,500</td>
</tr>
<tr>
<td>7</td>
<td>2,000</td>
<td>3,000</td>
</tr>
<tr>
<td>8</td>
<td>4,000</td>
<td>6,000</td>
</tr>
<tr>
<td>9</td>
<td>3,000</td>
<td>4,500</td>
</tr>
<tr>
<td>10</td>
<td>1,000</td>
<td>1,500</td>
</tr>
<tr>
<td>11</td>
<td>1,000</td>
<td>1,500</td>
</tr>
<tr>
<td>12</td>
<td>1,000</td>
<td>1,500</td>
</tr>
</tbody>
</table>

**Input value:** 36,000

**Total:** 24,000 36,000

### Distribution Key 3
- **Input value is interpreted as a percentage and refers to previous values**

<table>
<thead>
<tr>
<th>Period</th>
<th>Prev. value</th>
<th>Subs. value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,000</td>
<td>1,000</td>
</tr>
<tr>
<td>2</td>
<td>4,000</td>
<td>2,000</td>
</tr>
<tr>
<td>3</td>
<td>3,000</td>
<td>1,500</td>
</tr>
<tr>
<td>4</td>
<td>1,000</td>
<td>500</td>
</tr>
<tr>
<td>5</td>
<td>1,000</td>
<td>500</td>
</tr>
<tr>
<td>6</td>
<td>1,000</td>
<td>500</td>
</tr>
<tr>
<td>7</td>
<td>2,000</td>
<td>1,000</td>
</tr>
<tr>
<td>8</td>
<td>4,000</td>
<td>2,000</td>
</tr>
<tr>
<td>9</td>
<td>3,000</td>
<td>1,500</td>
</tr>
<tr>
<td>10</td>
<td>1,000</td>
<td>500</td>
</tr>
<tr>
<td>11</td>
<td>1,000</td>
<td>500</td>
</tr>
<tr>
<td>12</td>
<td>1,000</td>
<td>500</td>
</tr>
</tbody>
</table>

**Input value:** 50(%) 12,000

**Total:** 24,000 12,000
## Examples of Standard Distribution Keys

### Distribution Key 4

<table>
<thead>
<tr>
<th>Period</th>
<th>Input</th>
<th>Subs. value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>8,000</td>
<td>2,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2,000</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>2,000</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>10,000</td>
<td>2,500</td>
</tr>
<tr>
<td>6</td>
<td>2,500</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>2,500</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>2,500</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>6,000</td>
<td>1,500</td>
</tr>
<tr>
<td>10</td>
<td>1,500</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>1,500</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>1,500</td>
</tr>
<tr>
<td>Total</td>
<td>24,000</td>
<td></td>
</tr>
</tbody>
</table>

### Distribution Key 5

<table>
<thead>
<tr>
<th>Period</th>
<th>Input</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,000</td>
<td>2,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
<td>2,000</td>
</tr>
<tr>
<td>3</td>
<td>2,000</td>
<td>2,000</td>
</tr>
<tr>
<td>4</td>
<td>2,000</td>
<td>2,000</td>
</tr>
<tr>
<td>5</td>
<td>2,500</td>
<td>2,500</td>
</tr>
<tr>
<td>6</td>
<td>2,500</td>
<td>2,500</td>
</tr>
<tr>
<td>7</td>
<td>2,500</td>
<td>2,500</td>
</tr>
<tr>
<td>8</td>
<td>2,500</td>
<td>2,500</td>
</tr>
<tr>
<td>9</td>
<td>1,500</td>
<td>1,500</td>
</tr>
<tr>
<td>10</td>
<td>1,500</td>
<td>1,500</td>
</tr>
<tr>
<td>11</td>
<td>1,500</td>
<td>1,500</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>1,500</td>
</tr>
<tr>
<td>Total</td>
<td>24,000</td>
<td></td>
</tr>
</tbody>
</table>

### Distribution Key 6

<table>
<thead>
<tr>
<th>Period</th>
<th>Prev. value</th>
<th>Input</th>
<th>Subs. value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,000</td>
<td>2,000</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
<td>3,000</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2,000</td>
<td>3,000</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>2,000</td>
<td>3,000</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>2,000</td>
<td>3,000</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>2,000</td>
<td>3,000</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>2,000</td>
<td>2,500</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>2,000</td>
<td>2,500</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>2,000</td>
<td>2,500</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>2,000</td>
<td>2,500</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>2,000</td>
<td>2,000</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>2,000</td>
<td>2,000</td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td>24,000</td>
<td>31,000</td>
<td></td>
</tr>
</tbody>
</table>

### Distribution Key 7

**Input value: 24,000**

<table>
<thead>
<tr>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,032.79</td>
</tr>
<tr>
<td>2</td>
<td>1,901.64</td>
</tr>
<tr>
<td>3</td>
<td>2,032.79</td>
</tr>
<tr>
<td>4</td>
<td>1,967.21</td>
</tr>
<tr>
<td>5</td>
<td>2,032.79</td>
</tr>
<tr>
<td>6</td>
<td>1,967.21</td>
</tr>
<tr>
<td>7</td>
<td>2,032.79</td>
</tr>
<tr>
<td>8</td>
<td>2,032.79</td>
</tr>
<tr>
<td>9</td>
<td>1,967.21</td>
</tr>
<tr>
<td>10</td>
<td>2,032.79</td>
</tr>
<tr>
<td>11</td>
<td>1,967.21</td>
</tr>
<tr>
<td>12</td>
<td>2,032.78</td>
</tr>
</tbody>
</table>
Input value: 24,000

<table>
<thead>
<tr>
<th>Period</th>
<th>Planned activity</th>
<th>Subs. value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>30h</td>
<td>3,000</td>
</tr>
<tr>
<td>2</td>
<td>60h</td>
<td>4,000</td>
</tr>
<tr>
<td>3</td>
<td>45h</td>
<td>4,500</td>
</tr>
<tr>
<td>4</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>5</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>6</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>7</td>
<td>30h</td>
<td>3,000</td>
</tr>
<tr>
<td>8</td>
<td>60h</td>
<td>6,000</td>
</tr>
<tr>
<td>9</td>
<td>45h</td>
<td>4,500</td>
</tr>
<tr>
<td>10</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>11</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>12</td>
<td>15h</td>
<td>1,500</td>
</tr>
</tbody>
</table>

Input value is apportioned to the costs centers corresponding to the activity quantity (only applies to Cost Center Accounting).
Defining a Distribution Key

Use
In addition to the standard distribution keys [Seite 105] included in the standard system, you can also define your own distribution keys [Seite 103] to allow for variances such as seasonal fluctuations.

For each distribution key, you define which periods receive distribution amounts, and for each period, how much of the total amount the period receives.

Features
The following functions are available:

• Create
  You can create a distribution key. One possibility is to use an existing distribution key as a reference and to adjust it as needed.

  If the referenced distribution key is one of the standard distribution keys (delivered with your system), you cannot change the number of periods or the relative factor of the distribution key.

• Change
  You can change a distribution key. Note that if plan data was already distributed with this key, this data is not affected by these changes.

• Display
  You can display a distribution key.

• Delete
  You can only delete a distribution key if it is not used in existing plan tasks or planning layouts. You cannot restore a distribution key once it has been deleted.

Activities
To define or edit a distribution key, in Customizing choose Accounting → Financial Accounting → Special Purpose Ledger → Planning → Plan Settings → Define Distribution Key [Extern].
Excel Integration in Planning

Use
When planning with Excel integration, you use Microsoft Excel as the entry screen for your SAP plan data.

You have the following options when using Excel for the entry of your SAP plan data:

- **Excel as the interface in the SAP System**
  
  Excel replaces the SAP entry screen. This enables the use of SAP and Excel functions.

- **Local planning in Excel with the upload of plan data to the SAP System**
  
  Plan data can be entered de-centrally in multiple excel sheets on one or more computers without a SAP connection. This data is imported and combined via an upload to the SAP System. You can then edit the data using the planning functions in the SAP System.

Prerequisites

Software
To use the Excel integration function in conjunction with planning, you must have the following software installed on your computer:

- Windows NT 4.0 or Windows 95
- Microsoft Excel 97
- A SAP GUI (32 Bit) that corresponds to your system release

Hardware
To obtain faster run times, your PC should have a Pentium II processor and at least 64 MB of memory.

Features

Connection of Excel and the SAP System
Technically, Excel is connected to the SAP System using OLE (object linking and embedding), an interface of the Microsoft Office programs. This means that the same Excel functions are available that would be available, for example, when connecting to Word.

For the single planning session, the connection between the Excel sheet and the SAP planning layout is created using the position of the data in the Excel sheet: In Customizing, the SAP System is notified as to the position of the SAP data in Excel. This position may not be changed during the planning session in order to maintain a proper import of the data. The file name is the object that is used for the field assignment between the planning layout and the Excel sheet.

Restrictions
You cannot create plan data via a period screen with Excel integration.
Excel Integration in Planning
Planning with Excel Integration

Use

You can use Microsoft Excel as your interface to enter plan data in the SAP System. Microsoft Excel can be connected to your SAP System as an interface.

Prerequisites

The entry of plan data is based on the planning layout [Seite 76]. In order to complete planning using Excel as the creation screen, the following prerequisites have to be met:

- You have to first define the planning layout which serves as the basis for the entry of plan data.

  If you change a planning layout after creating an Excel template, you can no longer use this Excel template. In this case, you have to create a new Excel template.

- Plan data has to already be in the system that matches the planning layout (at least one row). If no plan data is present, enter this data using the desired planning layout without Excel integration.

Procedure

Preparations for planning with Excel integration

1. In Financial Accounting Customizing, choose Special Purpose Ledger → Planning → Define Planner Profile.

2. Navigate to the desired plan task and set the indicator Excel int. This activates Excel integration for this plan task.

3. Open the default settings for your plan task.

   Enter the values for the variables defined in the planning layout. This entry is necessary so that the Excel sheet can be opened in the next step.

4. Choose 📁. This opens Microsoft Excel as the entry screen.

   The system automatically assigns a file name [Extern]. A connection between the plan task and the Excel spreadsheet is created by the file name, that is, a connection between the cells of the spreadsheet and the cells of the planning layout.

   You can also enter a file name. To do so, you have to go to the column file name in the plan task when editing your plan task and enter your own file name.

5. This takes you to the screen Maintain File Name with Excel as the entry screen.

   The planning layout is displayed as an Excel spreadsheet. You can individually set up the spreadsheets. Various functions are available for this purpose. For more information see Functions for Editing Excel Templates [Seite 118].
Planning with Excel Integration

7. To save your Excel template, choose the Save icon. This saves your file name and the Excel layout.

8. To return to the default parameters, choose .

9. You can delete the values that you entered for the default parameters, if you do not want to display them for planning. Choose .

The default parameters are only temporarily saved at this point. To assign the file name to the planning layout and to save the values for the variables, you have to save the planner profile.

Entering plan data with Excel as the entry screen

Once you have set up and activated the Excel integration for a planning layout, you can enter your plan data in the Excel entry screen.

1. Make certain the planner profile and totals table, to which the desired planning layout is assigned, are assigned to your user master data. To assign a planner profile and totals table to your user master data, from the SAP Easy Access menu choose Accounting → Financial Accounting → Special Purpose Ledger → Planning → Set planner profile.

2. From the Special Purpose Ledger planning menu, choose Plan values → Enter. Excel opens as the entry screen within the SAP System. Your planning layout is displayed as an Excel spreadsheet.

3. Enter your plan data.

You should not use the following functions:

- Delete
- Insert
- Sort

If you use these functions, the data cannot be properly imported into the SAP System.

4. Save your plan data.

You can find additional information on creating plan data under Creating Plan Data [Seite 80].
Planning Locally with Excel Upload

Use
You can complete planning decentrally with Excel, that is, you enter the plan data locally with multiple Excel files on one or more computers. The plan data entered in Excel sheets can then be imported to the SAP System using an upload.

Prerequisites
Planning with Excel upload is based on the planning layout [Seite 76]. In order to prepare and complete the Excel upload, the following prerequisites have to be met for the planning layout:

- You have to first define the planning layout which serves as the basis for the entry of plan data.

  If you change a planning layout after creating an Excel template, you can no longer use this Excel template. In this case, you have to create a new Excel template.

- Plan data has to already be in the system and has to match the planning layout (at least one row). If no plan data is present, enter this data using the desired planning layout without Excel integration.

- In order to import the plan data into the SAP System using an upload, you have to enter the characteristic value in the key column of the planning layout used. The characteristic text alone is not enough.

Procedure

Preparing the Excel upload
In order to enter plan data in Excel and to then import it to the SAP System using an Excel upload, you first have to prepare the Excel upload. To do so, you have to set up a connection between the planning layout and the Excel file. Proceed as follows:

5. In Financial Accounting Customizing, choose Special Purpose Ledger → Planning → Define Planner Profile.

6. Goto the desired plan task and set the Excel Int indicator, that is, make certain it is set.

7. Open the default settings for your plan task.
   Enter the values for the variables defined in the planning layout. This entry is necessary so that the Excel sheet can be opened in the next step.

8. Choose 📝. This opens Microsoft Excel as the entry screen.
   The system automatically assigns a file name. A connection between the plan task and the Excel spreadsheet is created by the file name, that is, a connection between the cells of the spreadsheet and the cells of the planning layout.

   You can also enter a file name. To do so, you have to go to the column File name in the plan task when editing your plan task and enter your own file name.
Planning Locally with Excel Upload

5. This takes you to the screen *Maintain File Name* with Excel as the entry screen.

   The screen defined in the planning layout is displayed in the upper left hand corner of the Excel spreadsheet. You can individually set up the spreadsheets. Various functions are available for this purpose. For more information see *Functions for Editing Excel Templates* [Seite 118].

6. Under *Generic file*, enter a generic file name.

   The generic file name creates the connection between the file on the local PC and the file name during the upload.

   ![Warning]

   The generic file name must consist of a group of characters (capitals), the generic sign ", and the file ending \*.TXT, for example **PLANNING*.TXT**.

   ![Important]

   The name ranges of the various generic file names may not overlap, since this would not allow a unique assignment of the local file to the file name. If for example, the generic file name PLAN*.TXT was assigned at one position and PLANN*.TXT at another, the system would not be able to uniquely assign the upload of file PLANN5.TXT.

   You can display an overview of all file names with the generic file names. Using the *ABAP Editor*, start program RKCDPREO. You can delete file names and generic file names from this list, if they are no longer being used.

7. In Excel, save one copy of the Excel file on your computer and give it a name that matches the generic file name. If you, for example, choose SALES*.TXT as the generic file name, you can name the local file on your PC SALES1, SALES2, or SALES_D.

   ![Warning]

   As file format, you first have to use the Excel format .XLS. The file can now be opened, independent of the SAP System, in Excel. If you want to upload this file to the SAP System, you have to save the file as a text file (\*.TXT).

8. Save your file name. To do so, choose ![Save file name].

9. You can copy the downloaded copy of the Excel sheet as often as needed and make it available for decentral planning.

   ![Warning]

   Make certain that the individual file names correspond to the generic file name so that you can upload the data correctly to the SAP System.

Creating plan data locally using Excel

1. Open the downloaded copy of the excel sheet on your local PC.

2. Enter your plan data. During planning, keep a copy saved with the excel format .XLS.

   ![Warning]

   **Do not use** the following Excel functions:
Planning Locally with Excel Upload

- Delete
- Insert
- Sort

If you use these functions, you cannot import the data correctly to the SAP System.

When entering your plan data in the Excel sheet, the following functions are available:

- In a second spreadsheet, you can complete your own calculations or insert diagrams. When saving the Excel folder as a TXT file prior to the upload, only the first spreadsheet page is saved. The additional pages are not relevant for the upload.

- If you want to delete a value for a characteristic, such as cost center, in the SAP System, enter the value 0 for it in the Excel sheet. This is necessary, since all objects contained in the local file are processed during the upload. If you delete the characteristic value in the Excel sheet, it is not reset in the SAP System.

Prior to the Excel upload, complete the following:

- Remove the totals row from the first spreadsheet page. Otherwise, the system searches in the master data for the entry “Total” and the upload in cancelled.

- Save the Excel file using the text format .TXT.

- Make certain that the local file name matches the generic file name in order to ensure a correct assignment to the file name.

Completing the Excel upload

1. To start the upload, from the SAP Easy Access menu, choose Accounting → Financial Accounting → Special Purpose Ledger → Planning → Planned values → Upload from Excel.

2. Enter the file or file directory to be imported.

The path and file names on your computer, in which your plan data is saved, must not have any spaces, such as the directory “My Documents”.

3. In the file name file, you enter a file name, which the system uses to import the file(s). If you do not enter a file name, the system determines the file name automatically using the generic file name.

4. Start the upload.
Functions for Editing Excel Templates

**Use**

If you implement the Excel integration for entering plan data, you can personally set up the Excel sheet in which you enter the data. The functions for editing the Excel sheet are, however, limited, since the connection of the cells in the sheet to the cells in the planning layout must be kept.

**Prerequisites**

When you open the Excel input screen from the default settings of a planning layout for the first time, the *first* Excel sheet is protected. Only the cells, which were also available for input from the SAP entry screen, are excluded from this protection.

If you want to change this Excel sheet, you have to remove the sheet protection in Excel.

![Sheet Protection]

You should reset the sheet protection in Excel after editing the sheet. This ensures that any additional entries of plan data are only made for data as defined in the SAP System.

**Features**

The following functions are available for editing the Excel template:

![Caution Symbol]

You should **not** use the following functions:

- Delete
- Insert
- Sort

If you use these functions, the data **cannot** be properly imported into the SAP System.

- **Move**
  
  You can only move plan data within a spreadsheet using the SAP function. To do so, select the data to be moved by choosing  and then choosing  at the target position.
  
  Save the connection of the old position to the new position by choosing  *Save File name*.

- **Delete**

  To delete data, return to the **SAP System** and choose  .

- **Insert**

  Insert new objects to be planned directly under the existing SAP data, for example, below the totals line. To insert, choose  *(SAP possible entries).*
Do not insert any empty rows. The system does not recognize data that is separated from the existing SAP data by a blank row.

- **Insert**
  
  To insert additional data, from the SAP Menu choose *Edit → Insert*.

- **Formatting cells**
  
  You can use the formatting functions of Excel to change the font or color, for example.

- **Additional calculations**
  
  Outside of the SAP data range, you can make additional calculations or evaluations. For example, you could insert diagrams or use formulas and macros.

  SAP recommends you make additional calculations on a second spreadsheet. This ensures that there are no conflicts with the actual plan data during import. SAP plan data is always imported into the SAP System from the first spreadsheet.

- **Formulas**
  
  You can enter formulas in the **SAP data range**. However, the formula is overwritten by the result when saving and the formula is lost.

- **Save**
  
  You can save your Excel spreadsheet. To do so, choose ➕ *Save Excel layout*. 
Working with the Planning Tool

Use
With the planning tool, you can execute the following functions in one step:

• Create a plan task [Extern]
• Enter default parameters for the plan task
• Execute planning

Working with the planning tool is a alternative method to the activities described in Setting Up Planning [Seite 75].

The functions of the Report Painter [Extern] are limited in the planning tool. The planning tools is useful if you want to create less complex planning layouts. If, for example, you want to create planning layouts with formula rows, you should complete this using the alternative individual steps.

Prerequisites
To create a plan task using the planning tool, the planner profile, to which you want to assign this plan task, has to be defined. You define planner profiles in Customizing under Financial Accounting → Special Purpose Ledger → Planning → Define Planner Profile [Extern].

Features

Screen layout
The screen of the planning tool is made up of two areas:

• Navigation and display areas
  On the Plan task tab, which is on the left-hand side of the screen, the planner profiles with their assigned plan tasks are displayed. On the Online help tab, detailed information on the individual activities is displayed.

• Entry area
  On the right side of the screen, you define your plan task and execute planning.

Functions
The planning tool contains the following functions:

• You can create a plan task and assign it to an existing planner profile.
• You can change an existing plan task. To do so, select a plan task in the Plan tasks tab and choose Change.
• You can still use plan parameters. To import your plan parameters, choose Import Plan.. Save the imported data as a plan task.
• You can select or change the characteristics and key figures for a plan task.
• You can display the layout of your R/3 entry screen. To do so, choose Layout.
• You can complete planning, that is, you can enter the plan values. For more information, see Creating Plan Data [Seite 79]. You can also use Microsoft Excel [Extern] to enter data. To do so, select Use Excel.

You cannot use sets for periods.

Activities

You can access the planning tool by choosing Accounting → Financial accounting → Special Purpose Ledger → Planning → Plan values → Planning tool.

Detailed information on the individual activities is displayed on the left-hand side of the screen. Choose the information button to display information on the desired field group.
Transferring CO Plan Data

Use

CO plan data can be posted to the Special Purpose Ledger. Certain ledges can contain certain plan versions.

Prerequisites

CO plan data can only be transferred if the CO plan versions are permitted in your special ledgers.

⚠️ Note that when you plan in CO in a version which you have not assigned, the plan data cannot be transferred to the ledger. The system does not post an error message.

Ledger Za should contain CO plan data in version 002.
Ledger Z2 should contain CO plan data in version 003.
Both ledgers have the same activities assigned to them.
If you now transfer CO plan data in version 002, the system would post an error message, as ledger Z2 is not assigned to version 002.
If you now transfer CO plan data in version 003, the system would post an error message, as ledger Z1 is not assigned to version 003.

This would lead to the system posting error messages permanently. As a result, no error message is posted.

CO plan data is posted if you have made the following settings in Customizing.

1. In CO Customizing, planning integration must have been activated. Choose Cost Center Accounting → Planning → Planning Aids → Plan Version → Epos and Integration.

   Here, you have to activate plan integration.

   You can activate planning integration for each controlling area, version and fiscal year.

2. In FI-SL Customizing, the plan version that CO is sending must be allowed. Choose Planning → Plan Versions.

   Here, you assign the plan versions that are transferred from CO to the ledger which you want the plan data to be transferred to.


   Here, you make the assignment ledger - version - company code - fiscal year.

4. If you want line items to be updated during transfer of data to FI-SL, set the corresponding flag. In Customizing, choose Planning → Line Items → Activate → Local/Global.

   Here, you can activate line item update at the level ledger - version - company code - fiscal year.
Using a Plan Template

Use
You can use existing actual and/or plan data (for example, from previous years) as a reference for a new plan.

For example, you can use the actual values of the current year as the basis for planning for the next year.

Procedure
To use a plan template, proceed as follows:

1. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Copy
   model plan → Local (for local ledgers) or Global (for global ledgers).
   The Copy <Local or Global> Data to Plan screen appears.

2. Enter the source ledger and the type of data (such as 0 for actual data, 1 for plan data) you
   want to copy as well as the target ledger.

3. Activate the Copy data without summarization field group, if you want to copy the data as not
   summarized or if you want to limit the data selection.

4. You can copy the data without reevaluating it. The following options are available for doing
   this:
   – You can multiply the existing currency and quantity amounts by a factor. To do so, enter
     the factor for the currency and quantity amounts.

   The currency amount is 500 and the revaluation factor for currencies (Currencies
   field) is 2. The plan currency amount in the new plan will be 1000.

   – You can enter a user exit for reevaluating the data.

5. In the field group Existing data, specify whether you want to cumulate the values, that is, if
   the new plan data should be added to or if it should replace the old plan data.

6. Activate the Background processing indicator, if you want to run this as a batch job.

7. Choose Execute.

Result
If the data was successfully copied, a statistic display shows you how many records were, read,
summarized, processed, and created.
Displaying Totals Records

Use
Totals record display [Seite 167] is also used in Profit Center Accounting (EC-PCA). See Displaying Totals Records [Extern].

Procedure
Totals record display is found under Accounting → Financial accounting → Special Purpose Ledger→

- Planning → Display totals
- Actual posting → Display totals
- Information system → Reports for the Special Purpose Ledger → Totals Record Display

To display totals records, proceed as follows:

1. Enter the name of the ledger for which you want to display totals records.
   
   You can define the following:
   
   - In the output list, you can display totals records with a zero value. To do so, select Display zero records.
   - Under Settings..., you can directly select the totals records you want displayed.
     
     - You can enter a user table to display its data.
     
     - Under Variant for list, you can select a display variant for the output list. Included in the SAP Standard System are the display variants 0F_1 and 0F_2 for cost of sales ledger 0F.

     If you select a display variant, the totals records in the output list are automatically summarized. This means that totals records that match each other as to the displayed key fields are summarized and displayed as one totals record. With Restore, you can display the individual totals records.

     - You can also summarize the totals record when you select the data. To do so, select No individual records.

     If you use this function, you increase the performance when generating the output list. However, you cannot display the individual totals records using the restore function.

     - Under Maintain user table..., you can create or change a user table.

2. Choose Execute.

Selection screen

3. Enter your selection criteria.
Displaying Totals Records

Enter 0 as the record type to display actual data and 1 to display plan data.

You are also able to display archived totals records. To do so, choose *Data sources...*, select *archive* and enter the archive data. For additional information press the information button.

4. Choose *Execute*.

Output list

5. The totals records you selected are displayed in the output list.

The amounts and totaled amounts are displayed for all currencies kept in the ledger. The amounts are totaled for the posting periods you selected. The totaled amounts consist of the amounts from previous periods and the balance carried forward (period 0).

If you select posting periods 2 to 4 in the selection screen, the totals of periods 2 to 4 are displayed as well as the total of periods 0 to 4.

In the output list, you can:

- You can edit the output list by using display variants, by displaying or suppressing columns, or by forming totals. The functions of the *ABAP List Viewer [Extern]* are available for this. You can find additional information on the functions of the ABAP List Viewer under *SAP List Viewer (ALV): Classic [Extern]*.

- If you suppress individual key fields in the output list, the *summarize* function is activated. This allows you to summarized the remaining totals records that have the same key fields. With *Restore*, the summarization is reversed.

- You can display long texts for the dimensions account number, cost center, business area, profit center, and functional area.

- From the output list, you can access the following information on the individual totals records:
  - **Period breakdown**: You can display period information for an individual totals record. To do so, double-click the totals record.
  - **Line items**: You can display the original document lines of a totals record if the document lines are stored in a line item table. To do so, double-click the totals record in the period screen.

You can only display a document in FI-SL if the document lines are stored in the line item table or in the source application database (if the document was posted to FI-SL from another application).
Displaying Plan Documents

Use
You can display plan documents that were posted to local and global ledgers.

Prerequisites
To display plan documents, these documents have to stored in the FI-SL line item table of the ledger you want to plan. Before doing so, you have to make the following settings in Customizing:

- The lint item indicator must be set for your ledger. You make this setting in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Basic Settings → Master Data → Maintain Ledgers [Extern].
- You have to activate the update of local or global line items for your ledger. This setting is made in Customizing under Accounting → Financial Accounting → Special Purpose Ledger → Planning → Plan Settings → Activate Line Items → Activate Local Line Items [Extern] or Activate Global Line Items [Extern].

Procedure
To display a plan document, proceed as follows:

1. Choose Accounting → Financial accounting → Special Purpose Ledger → Planning → Display plan documents. → Local or global plan documents.
2. Enter your selection criteria:
   - Enter a document number range.
   - Enter the fiscal year, ledger, company code, and document type.

   To improve the processing time for displaying plan documents, enter additional ranges of values in the From value and To value fields for the dimensions listed.
3. Choose Execute.
   The output list is displayed.
4. The plan documents you selected are in the output list.

You can edit the output list by using display variants, by displaying or suppressing columns, or by forming totals. The functions of the ABAP List Viewer [Extern] are available for this. You can find additional information on the functions of the ABAP List Viewer under SAP List Viewer (ALV): Classic [Extern].
Actual Posting

Purpose
With the Special Purpose Ledger [Extern] actual posting, you are able to transfer data/business transactions to the FI-SL system in one of the following ways:

- From other SAP application components, such as Financial Accounting (FI), Materials Management (MM), Controlling (CO), and Sales and Distribution (SD)
- Directly, using FI-SL’s document entry function (for example, when posting correction documents)
- From external systems (for non-FI-SL data)

You can enter a transaction into the “MM” system as a “material receipt”. This transaction could then update an FI-SL ledger in real-time mode.

The document principle controls the input and storage of documents in the SAP R/3 Systems. A document is the basic unit for recording and tracking business transactions through the SAP R/3 System. One document exists for each business transaction. Each document is assigned a document type. The document type groups together documents that are to be processed in the same way. In the FI-SL System, document types determine:

- Whether a document is stored as plan or actual data.
- Which currency fields appear on the document entry screens.
- Whether or not the document has to balance.
- How the document number is assigned.

Integration
All SAP Systems operate under the philosophy that business transactions should only enter the system once. These transactions are then available to all other SAP Systems real-time.

The FI-SL System collects data at the original entry point and validates it immediately during entry. Update into FI-SL from other SAP applications is real-time; you can also update the FI-SL System at a later time. For external data, an interface framework is provided with your delivered system.

An SAP accounting document is similar to a conventional accounting entry, since it can contain debit and credit amounts. However, the SAP accounting document allows you to enter additional information about the business transaction, such as quantities and statistical values. The information you can enter is only limited by the dimensions contained in your database table.

Features
The following graphic shows the basic processing of transaction data that enters the FI-SL System.
Information is processed by the FI-SL System as follows:

1. A business transaction is transmitted real-time or in non-dialog mode (for external data) to the FI-SL Integration Manager.

   *In real-time processing:*

   FI-SL's Integration Manager receives and processes all data that enters the FI-SL System. The Integration Manager validates, and substitutes, and then summarizes data according to user-defined conditions.

   *In non-dialog mode:*

   Data can be read from (1) an external file and sent to the Integration Manager, or (2) from a source application database (FI) and then be sent to the Integration Manager via a utility program, such as RGUREC10.

2. The Integration Manager processes the transaction data.

   Within the FI-SL System, you define ledgers that contain dimensions from an FI-SL database table. Depending on how you define a ledger, the Integration Manager determines:

   - Which data is posted to a ledger.
   - How data is summarized in a ledger.

   The Integration Manager also processes incoming transaction data according to certain user-defined conditions, such as validation, substitution, and ledger selection conditions. The system also checks if a dimension combination is valid, depending on how the dimension(s) is defined in the database table. These conditions determine if transaction data can post to the FI-SL System.
You could define a ledger selection condition in FI-SL that states that transaction data for specific cost centers should not update a ledger.

3. The entered data is posted to an FI-SL table. Transaction data is posted to a summary database and, if specified, a line item database.
   - If necessary, currency translation occurs before transaction data is posted to the databases.
   - For more information about summary databases and line item databases, see FI-SL Database Tables [Seite 30]

When you enter a document, the system provides you with online assistance to ensure that you enter valid data. Data that enters the FI-SL System is analyzed and processed by the Integration Manager.

The Integration Manager reviews incoming business transactions and posts them to the relevant ledgers at the desired level of detail. The Integration Manager can also:

- Validate a business transaction and then send error messages or warnings to the user making the data input.
- Substitute certain values before posting data to the FI-SL System.

The document is posted to the system after full validation by the Integration Manager has taken place. The FI-SL System then summarizes the document according to user-defined summarization rules.

During posting, the system translates currency as you have defined it in your system for example, from local/global currencies to group currencies. For data that enters FI-SL, currency translations are made based on the rates defined in table TCURR (Foreign Exchange Rates). You can maintain the rates in this table as often as necessary.

When translating currency, the system:

4. Checks the currency type that is defined for the document.
   - If the currency type is defined for the document, the system posts the currency as entered in the document.

5. If the currency type is not defined for the document, the system checks if the currency is the same as another currency type that is defined for the document. If yes, the system posts the document using the other currency type defined for the document.
   - If the currency is different from all currency types defined for the document, the system translates the currency using table TCURR.

Currency types are defined in Customizing. For more information about currency types and currencies, see the FI System Administration Guide documentation and the Global Settings Implementation Guide (IMG).

Additional posting information can be found under:

Data Input from Other SAP Systems [Extern]
Data Input Directly in FI-SL [Seite 135]
Data Input from External Sources [Seite 134]
Data Transfer Programs [Extern]
Data Transfer from SAP Application Components

Use
You can transfer data from other SAP application components to your Special Purpose Ledger using the subsequent posting procedure. This is especially useful prior to a production start for entering beginning balances in your special purpose ledgers. After a production start, you transfer the data continually using an online method.

Prerequisites
Note the following points before transferring data from other SAP application components to your special purpose ledgers.

- Only complete the data transfer when no other users are making postings in the system.
- Make certain that data from these application components is not already in your ledger(s). If you transfer the data twice, the data will be entered twice in the ledger(s). You can delete existing data. You can also check whether the data is already present.
- You have to set posting indicator 2 (ledger is updated by subsequent postings) or 3 (ledger is updated directed and by subsequent postings) for the ledger that is to receive data from other application components.

You make this setting in Customizing under Financial Accounting → Special Purpose Ledger → Basic Settings → Master Data → Maintain Ledgers (Extern).

Features
Using the subsequent posting procedure, you can transfer data from the following application components:

<table>
<thead>
<tr>
<th>Component</th>
<th>Actual data</th>
<th>Plan data</th>
<th>Statistical key figures</th>
</tr>
</thead>
<tbody>
<tr>
<td>Financial Accounting (FI)</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Materials Management (MM)</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales and Distribution (SD)</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Controlling (CO)</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>(Controlling objects)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Overhead Cost Controlling (CO-OM)</td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Profitability Analysis (CO-PA)</td>
<td></td>
<td></td>
<td>x</td>
</tr>
</tbody>
</table>

Activities
You can find the functions for data transfer in Customizing under Financial Accounting → Special Purpose Ledger → Basic Settings → Production Start-Up Preparation.

For more information on the individual functions, see Data Transfer Programs [Seite 136].
Data Input from External Sources

Use

In rare cases (for example, when FI-SL is purchased independently of any other SAP System), you can load data into the FI-SL System from external systems.

Examples of how to load data are delivered with various ABAP programs (beginning with RGUREC).

These programs are only examples and should be copied and then modified according to your needs when you process postings.

With the RGUREC00 program, you can load data from an external source (non-SAP R/3 System) to the FI-SL System.

RGUREC00 is only an example program and should be copied and modified according to your needs when you process postings.

If you changed the standard coding block delivered with your FI-SL System, you will need to change the RGUREC00 program so that it reflects new dimensions that you have defined.

You use the transfer program RGUREC00 from the ABAP: Execute Program screen. You access the ABAP: Execute Program function by choosing System → Services → Reporting.

You should not start RGUREC00 in dialog when other users are posting.

To ensure that data is transferred correctly during the initial use of this program, contact your SAP consultant.
Data Input Directly in FI-SL

If you use other SAP Systems, most of your data will probably come from those systems. However, you can also enter data directly into the FI-SL System when necessary.

You enter documents into the FI-SL System when you want to:

- Enter a document into the FI-SL System without posting it to other SAP applications (for example, when posting corrections)
- Post documents to different versions
- Manually enter additional currency amounts
- Post statistical entries using only quantity values
- Post one-sided documents

You can also reverse an FI-SL actual document posting.

When you enter data using the FI-SL Actual posting function, other SAP Systems are not affected by the data. Direct entries in FI-SL are marked separately in the FI-SL line item databases, so that you can determine which entries came from other SAP Systems and which were entered directly into the FI-SL System. In the summary database, direct entries made with the Actual posting function are marked separately via the version.

For more information about entering data into the FI-SL System, see Entering an Actual Document [Seite 159].
Data Transfer Programs

Use

With the RGUREC00 program, you can load data from an external source (non-SAP R/3 System) to the FI-SL System.

RGUREC00 is only an example program and should be copied and modified according to your needs when you process postings.

If you changed the standard coding block delivered with your FI-SL System, you will need to change the RGUREC00 program so that it reflects new dimensions that you have defined.

You use the transfer program RGUREC00 from the ABAP: Execute Program screen.

You access the ABAP: Execute Program screen by choosing System → Services → Reporting.

You should not start RGUREC00 in dialog when other users are posting.

To ensure that data is transferred correctly during the initial use of this program, contact your SAP consultant.

For more information, see:

- Transferring Data from Financial Accounting (FI) [Seite 137]
- Transferring Data from Materials Management [Seite 139]
- Transferring Data from Sales [Seite 141]
- Transferring Data from Controlling [Seite 143]
- Transferring the Opening Balance of CO Statistical Key Figures [Seite 145]
- Transferring Plan Documents from Controlling (CO) [Seite 147]
- Transferring Planning Data Posted to CO Objects [Seite 149]
Transferring Data from Financial Accounting (FI)

Use

Use transfer program RGUREC10 to transfer data from FI to FI-SL.

Procedure

   The Data Transfer from Financial Accounting screen appears.

2. Enter the following:
   – the company code for which you want the data to be transferred
   – the fiscal year for which you want the data to be transferred
   – the period for which you want the data to be transferred
     If you leave this field blank, data will be transferred for all periods.
   – Information about the business transaction (such as the activity and/or origin of the document)
   – the valid range of document numbers for the data you want to be transferred
   – the document date of the data that you want to transfer
   – the posting date of the data that you want to transfer
   – the creation date of the data that you want to transfer

3. Set the required flags:
   – If you only want to test the data transfer, set the test run flag. If you select this field, the FI-SL tables will not be updated.
   – If you want to display a statistical list of the data transfer, set the List Required flag.
   – If you want to check whether data records already exist in FI-SL for the documents that you want to transfer, set the check flag. If data already exists, this will not be transferred to FI-SL.

   A prerequisite for using the check function is that the data which you want to transfer must be saved in FI-SL.

   – If you want to transfer FI documents that originate from Materials Management (MM) or Sales and Distribution (SD), set the Also Transfer MM and SD Documents flag. In certain circumstances (for example if data is summarized in FI) it is not possible to save information from the source documents. In this case, only data from the FI document is available.

4. Enter the name of the target ledger to which you want to transfer the data.
Transferring Data from Financial Accounting (FI)

For the ledgers which you want to be updated, the company code flag on the Change Ledger: Activity Assignment screen, posting assignment field, must be set on either 2 (ledger posted when data is posted subsequently) or 3 (ledger posted directly and also when data is posted subsequently). You set the posting flag in Customizing. You should also set the line item flag for ledger to which you want data to be transferred. For further information, see the Implementation Guide (IMG) for Special Purpose Ledger.

If other users are posting data, you should be cautious when using this program in online mode. In this case, you should only transfer old data. We recommend that you only start these programs if no other users are posting data.

5. Choose Program → Execute.

Result
The system transfers the data from Financial Accounting to FI-SL.
Transferring Data from Materials Management (MM)

Use
Use transfer program RGUREC30 MM to transfer data from Materials Management.

Prerequisites
This program can only be used for MM documents posted in Release 3.0. For MM documents posted in earlier release versions, you have to use the FI transfer program.

Procedure
   The Data Transfer from Materials Management screen appears.
2. Enter the following:
   - the company code for which you want the data to be transferred
   - the fiscal year for which you want the data to be transferred
   - the period for which you want the data to be transferred
     If you leave this field blank, data will be transferred for all periods.
   - Information about the business transaction (such as the activity and/or origin of the document)
   - the valid range of document numbers for the data you want to be transferred
   - the document date of the data that you want to transfer
   - the posting date of the data that you want to transfer
   - the creation date of the data that you want to transfer
3. Set the required flags:
   - If you only want to test the data transfer, set the test run flag. If you select this field, the FI-SL tables will not be updated.
   - If you want to display a statistical list of the data transfer, set the List Required flag.
   - If you want to check whether data records already exist in FI-SL for the documents that you want to transfer, set the check flag. If data already exists, this will not be transferred to FI-SL.
   A prerequisite for using the check function is that the data which you want to transfer must be saved in FI-SL.
4. Enter the name of the target ledger to which you want to transfer the data.
Special Purpose Ledger

Transferring Data from Materials Management (MM)

For the ledgers which you want to be updated, the company code flag on the Change Ledger: Activity Assignment screen, posting assignment field, must be set on either 2 (ledger posted when data is posted subsequently) or 3 (ledger posted directly and also when data is posted subsequently). You set the posting flag in Customizing. You should also set the line item flag for ledger to which you want data to be transferred. For further information, see the Implementation Guide (IMG) for Special Purpose Ledger.

If other users are posting data, you should be cautious when using this program in online mode. In this case, you should only transfer old data. We recommend that you only start these programs if no other users are posting data.

5. Choose Program → Execute.

Result

The system transfers the data from Materials Management to FI-SL.
Transferring Data from Sales and Distribution (SD)

Use

Use transfer program RKEPCU40 SD actual data to transfer data from Sales and Distribution.

Procedure

   The Post Billing Documents screen appears.
2. Enter the following data:
   - the company code for which you want the data to be transferred
   - the sales organization for which you want the data to be transferred (optional)
   - the distribution channel for which you want the data to be transferred (optional)
   - the division which you want the data to be transferred (optional)
   - information about the billing document (such as the document number and the date of the billing document)
3. Set the required flags:
   - If you only want to test the data transfer, set the test run flag. If you select this field, the FI-SL tables will not be updated.
   - If you want to display a statistical list for the data transfer, set the log flag.
   - If you want to check whether data records already exist in FI-SL for the documents that you want to transfer, set the check flag. If data already exists, this will not be transferred to FI-SL.

A prerequisite for using the check function is that the data which you want to transfer must be saved in FI-SL.
4. Enter the name of the target ledger to which you want the data to be transferred.

For the ledgers which you want to be updated, the company code flag on the Change Ledger: Activity Assignment screen, posting assignment field, must be set on either 2 (ledger posted when data is posted subsequently) or 3 (ledger posted directly and also when data is posted subsequently). You set the posting flag in Customizing. You should also set the line item flag for ledger to which you want data to be transferred. For further information, see the Implementation Guide (IMG) for Special Purpose Ledger.
Transferring Data from Sales and Distribution (SD)

If other users are posting data, you should be cautious when using this program in online mode. In this case, you should only transfer old data. We recommend that you only start these programs if no other users are posting data.

5. Choose Program → Execute.

Result

The system transfers the data from Sales and Distribution to FI-SL.
Transferring Data from Controlling (CO)

Use
Use transfer program **RGUCRE20** CO actual data to transfer data from Controlling.

Procedure
1. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Data Transfer → Controlling
   The CO Actual Data Transfer to FI-SL screen appears.
2. Enter the following:
   - the controlling area for which you want the data to be transferred
   - the document number range for which you want the data to be transferred
   - the fiscal year for which you want the data to be transferred
   - the activity/activity range for which you want the data to be transferred
   - the cost element/cost element range for which you want the data to be transferred
   - the company code/company code range for which you want the data to be transferred
3. Set the required flags:
   - If you want to display a statistical list of the data transfer, set the List Required flag.
   - If you only want to test the data transfer, set the test run flag. If you select this field, the FI-SL tables will not be updated.
   - If you want to check whether data records already exist in FI-SL for the documents that you want to transfer, set the check flag. If data already exists, this will not be transferred to FI-SL.
   
   →
   A prerequisite for using the check function is that the data which you want to transfer must be saved in FI-SL.
4. Enter the name of the target ledger to which you want the data to be transferred.

→
For the ledgers which you want to be updated, the company code flag on the Change Ledger: Activity Assignment screen, posting assignment field, must be set on either 2 (ledger posted when data is posted subsequently) or 3 (ledger posted directly and also when data is posted subsequently). You set the posting flag in Customizing. You should also set the line item flag for ledger to which you want data to be transferred. For further information, see the Implementation Guide (IMG) for Special Purpose Ledger.
Transferring Data from Controlling (CO)

If other users are posting data, you should be cautious when using this program in online mode. In this case, you should only transfer old data. We recommend that you only start these programs if no other users are posting data.

5. Choose *Program → Execute*.

**Result**

The system transfers the data from Controlling to FI-SL.
Transferring the Opening Balance of Statistical Key Figures from CO

Use
Use transfer program RGUREC40 to transfer the opening balance of statistical key figures from CO into FI-SL.

Procedure
1. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Data Transfer → CO Statistical Key Figures
   The RGUREC40 - Transfer Opening Balance of Stat.Key Figures (Type 1) screen appears.
2. Enter the following information:
   – Controlling area for which you want to transfer the opening balance.
   – Fiscal year for which you want to transfer the opening balance.
   – CO object type for which you want to transfer the opening balance (for example, KS for cost center).
3. Specify whether you want to delete existing key figures in FI-SL.
   When you transfer CO statistical key figures with type 1 (fixed values) into FI-SL, the value entered in the document is transferred as a total value (not as a delta value) and is therefore valid for all follow-up periods up to the year-end.
   The opening balance must therefore be transferred before statistical key figures are updated in FI-SL. If statistical key figure data already exists in FI-SL before the first data transfer, incorrect data will be updated in FI-SL.
   When you use program RGUREC40, you must specify whether existing key figures in FI-SL are to be deleted before the data transfer:
   – Select No deletion in FI-SL if you do not want to delete existing key figures in FI-SL before the data transfer.
   – Select Delete FI-SL data for all yrs if you want to delete existing key figures in FI-SL for all years before the data transfer (if several fiscal year variants are used).
   – Select Delete FI-SL data for year if you want to delete existing key figures in FI-SL for the current year before the data transfer (if one fiscal year variant is used).
4. Set the following indicators as required:
   – If you want to view a list of statistics for the data transfer, set the List desired indicator.
   – If you only want to test the data transfer, set the Test run indicator. The FI-SL databases are not updated when you set this indicator.
Transferring the Opening Balance of Statistical Key Figures from CO

You should exercise caution when using program RGUREC30 in dialog when other users are posting. In this case, you should transfer old data only. It is recommended that you start this program when other users are not posting in your system.

5. Choose *Program → Execute*.

**Result**

The opening balance of the CO statistical key figures is transferred into FI-SL.
Transferring Plan Documents from Controlling (CO)

Use

Use transfer program RGUREC50 to transfer plan documents from CO into FI-SL. To transfer CO plan documents into FI-SL using transfer program RGUREC50, proceed as follows:

Procedure

   The Transfer CO Plan Documents to FI-SL screen appears.

2. Enter the following information:
   - Controlling area or range of controlling areas for which you want to transfer data.
   - Document number or range of document numbers that you want to transfer.
   - Fiscal year or range of fiscal years for which you want to transfer data.
   - Version or range of versions for which you want to transfer data.
   - CO activity or range of CO activities for which you want to transfer data.
   - Cost element or range of cost elements for which you want to transfer data.

3. Set the following indicators as required:
   - If you want to view a list of statistics for the data transfer, set the List desired indicator.
   - If you only want to test the data transfer, set the Test run indicator. The FI-SL databases are not updated when you set this indicator.
   - If you want to check if data records currently exist in FI-SL for the documents you want to transfer, set the Check for existing records indicator. If the data currently exists, the system does not take over the data into FI-SL.

   To use the Check for existing records function, line item data records for the data to be transferred must be stored in the FI-SL component.

4. Enter the name of a specific target ledger to which the data should be transferred, if required.

   The ledgers that are to be updated must have a posting value of 2 (ledger only posted to at subsequent posting) or 3 (ledger posted to directly and at subsequent posting) in the Post. ind. field on the Change Ledger: Assign Activity screen. You define this value in Customizing for Special Purpose Ledger by choosing Basic Settings → Master Data → Maintain Ledgers.
Transferring Plan Documents from Controlling (CO)

You should exercise caution when using program RGUREC30 in dialog when other users are posting. In this case, you should transfer old data only. It is recommended that you start this program when other users are not posting in your system, and you set the line item indicator for at least one ledger.

5. Choose Program → Execute.

Result

The CO plan documents are transferred into the FI-SL component.
Transferring Plan Data Posted to CO Objects

Use
Use transfer program RGUREC20 to transfer to FI-SL plan data that has been posted to CO objects (such as cost centers, internal orders, projects, and so on).

Procedure
1. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Data Transfer → CO Plan Data Objects.
   The FI-SL: Transfer Plan Data from CO Objects screen appears.
2. Enter the following information:
   – Controlling area for which you want to transfer planning data.
   – Plan version for which you want to transfer planning data.
   – Fiscal year or range of fiscal years for which you want to transfer data.
3. Select the CO objects for which you want to transfer planning data into the FI-SL component.
4. Enter the activity or range of activities for which you want to transfer planning data.
5. Enter the characteristic values for the CO objects you selected.
   You can enter individual values, ranges of values, or groups.
6. Set the following indicators as required:
   – If you only want to test the data transfer, set the Test run indicator. The FI-SL databases are not updated when you set this indicator.
   – If you want to view a list of statistics for the data transfer, set the Log indicator.
7. Enter the name of a specific target ledger to which the data should be transferred, if required.
   The ledgers that are to be updated must have a posting value of 2 (ledger only posted to at subsequent posting) or 3 (ledger posted to directly and at subsequent posting) in the Post. ind. field on the Change Ledger: Assign Activity screen. You define this value in Customizing for Special Purpose Ledger by choosing Basic Settings → Master Data → Maintain Ledgers.
   You should exercise caution when executing program RKEPCU20 because the system does not check whether data already exists for the CO objects in the FI-SL component.
8. Choose Program → Execute.

Result
The CO plan data is transferred into the FI-SL component.
Document

In the SAP System, you enter all the information regarding a specific business transaction in the form of a document. A **document** is the smallest unit in which a business transaction can be created and processed in the SAP System. A document is created for each business transaction and can be uniquely identified by its document number.

Data is posted to the FI-SL system via a new structure, the accounting document. The accounting documents give you more flexibility when posting from other applications. For example, you can transfer and post data for multiple dimensions.

Each document contains one or more line items. A **line item** is an entry in the database that contains all or part of the information resulting from a business transaction.

A document could have three line items such as the following:

**Line item 1:** Account 600000, Business area 10, Cost center 200, and a debit amount of 3000.

**Line item 2:** Account 650000, Business area 10, Cost center 200, and a debit amount of 2000.

**Line item 3:** Account 750000, Business area 10, Cost center 300, and a debit amount of 5000.

These three line items are part of **one** business transaction.

An SAP accounting document is similar to a conventional accounting entry since it contains debit and credit amounts. In SAP accounting documents, you can however enter additional information related to the business transaction such as the cost center, plant, and business area. The information you can enter is only limited by the dimensions contained in your coding block. You can enter document information for local and global ledgers as follows (see the following graphic):

- Directly into FI-SL
- Via other SAP applications
- Using an FI-SL tool to transfer data from external systems
The following section explains how to enter and display actual documents for local and global ledgers.

**Totals Record [Seite 166]**

**Document Entry in the FI-SL System [Seite 153]**

**Document Display [Seite 158]**

**Totals Record Display [Seite 167]**

**Document Types and Number Assignment [Seite 156]**

**Entering Actual Documents [Seite 159]**

**Displaying Actual Documents [Seite 163]**

**Reversing Actual Documents [Seite 165]**

**Displaying Totals Records [Seite 168]**
Document Entry in the FI-SL System

Use

When you enter information about a business transaction into the SAP System, you enter it in the form of a document. You can enter documents in other SAP applications, directly in the FI-SL System, or with an FI-SL tool.

You can set all FI-SL ledgers for delayed posting. For example, you may decide to set the ledgers to delayed posting if you have slow system performance as a result of extensive online posting transactions. When you delay document posting to FI-SL, the documents are posted in the source application first (for example, FI), and then later in FI-SL. You set this indicator in Special Purpose Ledger Customizing by choosing Basic Settings → Tables → Technical Help → Maintain Update Type.

You should exercise caution when using the delayed posting function because data inconsistencies can occur if the system terminates processing during the delayed posting, making it necessary to make subsequent postings for the documents that have not been posted into FI-SL - you will need to contact your SAP consultant for this.

The master data validation refers to tables GB01 and GB11 rather than the customer summary table GLU1.

Features

Document Entry via Other SAP Application Components

You can process data from other SAP applications in the FI-SL System by assigning local company codes to local ledgers, or by assigning local company codes to global companies and then to a global ledger. When you enter a business transaction for the local company code, the business transaction is transferred directly to the FI-SL Integration Manager. The Integration Manager analyzes the data and then determines to which ledger(s) the data should be posted.

By assigning activities to a ledger, you can determine which document data is posted to the ledger for a company code or global company. An activity classifies each source of data sent to the Integration Manager.

For more information about activities, see the Maintain Activities activity in the Implementation Guide (IMG) for Special Purpose Ledger.

When posting from outside FI-SL (for example, via FI or CO), the system does not check whether a period is open for posting. This check should be completed in the system from which you are posting (sender system).

You can use program RGUREC10 to transfer data from the FI System to the FI-SL System. When you start the transfer program, you can specify which data is to be transferred to FI-SL.
Document Entry in the FI-SL System

You can use program RGUREC20 to transfer actual data from the CO System into the FI-SL System. When you start the transfer program, you can specify which data is to be transferred to FI-SL.

Program RGUREC40 enables you to transfer the opening balance of CO statistical key figures into the FI-SL System. When you start the transfer program, you can specify which data is to be transferred to FI-SL.

With program RGUREC30, you can transfer actual data from Materials Management (MM) to FI-SL. When you start the transfer program, you can specify which data is to be transferred to FI-SL.

You can use program RKEPCU40 to transfer actual data from Sales and Distribution (SD) to FI-SL. When you start the transfer program, you can specify which data is to be transferred to FI-SL.

With program RGUREC50, you can transfer CO planning data to FI-SL. This program is mainly used for transferring CO planning data to a new ledger. When you start the program, you can specify the data to be transferred to FI-SL.

Program RKEPCU20 enables you to transfer CO planning data that has been posted to CO objects (such as cost centers, internal orders, projects, and so on) to FI-SL. When you start the program, you can specify the data to be transferred to FI-SL.

For more information, see Transferring Data from SAP Components [Seite 132].

Document Entry Directly in FI-SL

If you use other SAP applications, most of your data probably comes from these applications.

You usually enter documents directly into FI-SL when you want to:

- Enter a document in the FI-SL System without posting it in other SAP applications.
- Carry out adjustment postings.
- Post documents to different FI-SL versions.
  
  When you enter a document in another SAP application, you can only post to FI-SL version 1 for actual data from FI, SD, and MM. (Beginning with Release 3.0, you can post certain CO data to a version other than version 1.) If you enter documents directly in FI-SL, you can post to other FI-SL versions in addition to version 1.
- Manually enter additional currency amounts.
  
  In FI-SL, if a manually entered additional currency is the same as the additional currency of the ledger to which the amount is posted, the amount is posted directly instead of being calculated. Additional currency amounts are automatically calculated when document data is transferred from other SAP applications.
- Post statistical entries using only quantity values.
- Post documents that do not balance to zero.

Document Entry via External Systems

In rare cases, you may need to load data into FI-SL from external systems. Examples of how to transfer data from external systems are included with program RGUREC00. With this program, you can upload data from external systems to FI-SL. RGUREC00 is only an example program and should be copied and then modified according to your requirements when you process...
postings. For information about loading data from external systems using RGUREC00, you should contact an SAP consultant.
Document Types and Number Assignment

Use
When you enter a document, you must also enter a document type, which determines whether the document’s number assignment is external (user-defined) or internal (system-defined).

Features

Document Types
The document type groups together documents that are processed in the same way. In the FI-SL System, document types determine whether the document is stored as plan or actual data. The FI-SL System is delivered with two document types:

- **A0**: Document entry with actual data
- **P0**: Document entry with plan data
- In the FI-SL system, the document type determines which currency fields appear on the document entry screens.

You can maintain the delivered document types and create new ones in Customizing for Special Purpose Ledger. For more information about defining document types, see the Maintain Valid Document Types activity (Actual Posting) in the Implementation Guide (IMG) for Special Purpose Ledger.

Activities
When you define the currency fields for the document type, you define:

- The currency type for the document type (transaction, second, and/or third currency)
- How currency types are posted for the document type (for example, if the transaction currency type is not defined for the document type, you can enter an = sign from transaction to local currency, so that transaction currency is posted in the same currency as the local currency).
- Which currency types can be posted to the database for the document type.

- Whether or not the document has to balance.
- How the document number is assigned.

If you select a document type that requires you to enter a document number and requires that a document must balance, then you must enter a valid document number, and the document must balance. The entries you make are valid only if they conform to the document type.

Data that you can enter into the FI-SL System is:

- **Actual**: Entering an Actual Document [Seite 159] explains how to enter actual data into the FI-SL System.
**Plan:** Entering Planned Values explains how to enter plan data in the FI-SL System.

**Actual and plan assessments**

**Actual and plan distributions**

**Document Number Assignment**

The document type determines how document numbers are assigned. During your system installation, each document type was assigned to a number range code. For each number range code and its related document type, you can define whether document numbers are assigned by the system or entered by the user. You can also define the valid document number interval.

For the document type A0, you can define that the valid document interval must be between 500000 and 600000, and that the document number must be entered manually.

**Activities**

- You can assign more than one document type to the same number range code.

Both system-defined and user-defined document numbers must be valid. A valid number is one that is not yet used and lies within the valid document number interval. When a document number is assigned by the system, valid numbers are assigned sequentially. If a document number is entered manually, it must be a valid number but does not need to be entered sequentially.

- When you define number intervals for local and global ledgers, you define intervals for a specific local/global company. You can also define number intervals for a specific year(s).

We recommend that you use a number range for the document number that is independent from the year. For example, you must use a year-independent number range if you are using a fiscal year variant that starts in the middle of a year.

For more information about assigning number intervals to local and global companies, see the **Number Ranges** activity (Actual Posting) in the Implementation Guide (IMG) for **Special Purpose Ledger**.
Document Display

Using the Display function for local and global ledgers, you can display documents stored in a line item table. You can select the document(s) you want to display by specifying the document number (or document number interval), year, company code or global company, and ledger.

You can also display documents that have been archived.

For more information on displaying documents, see Displaying Actual Documents [Seite 163].

FI-SL Line Item Table and Document Display

The FI-SL System uses two types of tables: The line item table contains the individual line items of the documents entered, the summary table contains totals information about the documents entered. You can only display a document in FI-SL if it is stored in the line item table.

If the document information you want to display only exists in a summary table, you cannot view the individual documents that make up the totals. Therefore, if you are entering a document directly in FI-SL and plan to display it, you should also store it in an FI-SL line item table. This is true for documents originating in other SAP applications as well as those entered directly in FI-SL.

When you define companies, ledgers, and activities in Special Purpose Ledger Customizing, you determine whether documents update a line item table. For documents that are entered directly in FI-SL, we recommend that you update the line item table, since these documents are not stored in any other application component. For more information, see the Special Purpose Ledger Implementation Guide (IMG).
Creating Actual Documents

Use

You can enter a document for:

- **Local company codes**
  
  When you enter a document for a local company code, the document is posted to all local ledgers to which the local company code and activity are assigned. If a document is entered for a local company and the local company code is assigned to a global company code, the document posts to both a local ledger and a global ledger.

- **Global companies**
  
  When you enter a document for a global company code, the document is posted to all global ledgers to which the global company code and activity are assigned.

Documents can also be entered from other SAP application components. This section only describes document entry directly in FI-SL. For more information about using the document entry transactions from other applications, refer to the documentation of those application components.

You cannot post to standard ledgers (for example, the FI General Ledger) using this transaction.

For more information about entering plan documents, see [Entering Planning Data](#).

For more information about entering documents for allocations (assessment/distribution), see [Creating Allocation Cycles](#).

Procedure

You can use an existing document as a reference when posting a document. To do this, choose *Post with reference*.

To enter a document for a company code or global company, proceed as follows:

1. Choose *Accounting → Financial accounting → Special Purpose Ledger, Actual posting → Local documents* or *Global documents → Enter*.

   The *Enter FI-SL Document: Initial Screen* appears.

2. Enter the following information:
   - Company code or global company for which you want to enter a document
   - Document type
   - FI-SL version for which you want to create the document

   You can now use different versions for certain CO data. For data that is posted from FI, SD, and MM, you can only use version 1.
Special Purpose Ledger

Creating Actual Documents

You can maintain multiple FI-SL versions.

For more information about adding or changing FI-SL versions, in the *Special Purpose Ledger* Implementation Guide (IMG) see the *Maintain Actual Versions* (Actual Posting) activity.

- Table name of the document you want to create.
  
  You can also create documents using user table GLU1. This table allows you to update multiple tables with different fields.

- A document number if you want to manually assign a document number for the posting.
  
  If you do not enter a document number, the system automatically assigns the document number from the number range assigned to the company code/global company per document type.

3. Enter the following data for the date and period:

- Posting date
  
  Enter the posting date. The default value is the current date. To post to a special period, the posting date must lie in the last normal period of the fiscal year.

  ![Tip]

  If you post a local or global document for the previous fiscal year and the balance carry forward indicator is set in the ledger master data, the system automatically carries forward the balance to the new fiscal year (as of release 3.0E).

- Date that the system should use for translating the transaction currency.
  
  The default value is the current date.

- Special period or carry-forward period (period 0) to which the document should post, if desired
  
  To post to a special period, the posting date must lie in the last normal period of the fiscal year. To post to the carry-forward period (period 0), the posting date must occur in the first period of the fiscal year.

  ![Tip]

  When posting local documents, the system checks the fiscal year variant of the local company code to which you are posting to determine if a posting period is open.

  When posting global documents, the system checks the fiscal year variant of the local company code assigned to the global company to which you are posting to determine if a posting period is open.

  For more information about defining and opening posting periods, in the *Special Purpose Ledger* Implementation Guide (IMG), see the *Posting Periods* activity.

4. Enter the following for currency and unit of measure:

- Currency key that matches the transaction currency

- Currency key that matches the additional currency

  If you enter an additional currency key, the additional currency amount that you later enter for the document line is used **only** for ledgers that have the additional currency key that you enter in this field.
The document type determines which currency fields appear. For example, if the document type is not set for an additional currency, then the Additional currency field does not appear. For more information on document types, see Document Types and Number Assignment [Seite 156].

– A base unit of measure, if desired
– An additional unit of measure, if desired

5. Enter a ledger for master record validation, if required.

The ledger that you enter determines which chart of accounts is used for validating the master records (in particular, the dimension "Account"). The chart of accounts is defined at the ledger/company code or ledger/global company level. If you do not enter a ledger, the system uses the chart of accounts of the local company code or the local company code assigned to the global company.

6. If you assigned more than one ledger in Customizing, but only want this posting to update one of the ledgers, you can enter a specific ledger by choosing Enter target ledger.

The target ledger you enter must be assigned to a company code/activity or global company/activity combination in Customizing.

7. Choose Initial screen.

The Enter FI-SL Document: Item Screen appears.

8. Enter the line item information.

For a credit amount, you must enter a minus sign (-) after the amount.

To enter the credit amount 500.00, you enter 500.00-.

If you do not enter a local or additional currency for the transaction currency, the system automatically calculates the amounts using the value that appears in the TCurrency field. You can change the value in this field as needed.

If you want to make statistical entries involving only quantities, you can enter quantity values without entering currency amounts.

The fields that appear under Account assignment depend on the dimensions defined in the user table you entered in the Enter FI-SL Document: Initial Screen. The values you enter determine how a document is stored in the summary table. You must make an entry in at least one of the Account assignment fields.

You can also enter a description for the line item, if desired.

9. You can use the following additional functions in the Enter FI-SL Document: Item Screen.

**Additional Processing Functions (Enter FI-SL Document: Item Screen)**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Enter new line item</td>
<td>Enter the next line item.</td>
</tr>
</tbody>
</table>
Creating Actual Documents

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit → Delete document line</strong></td>
<td>Delete a line item</td>
</tr>
<tr>
<td><strong>Edit → Hold/release kp line</strong></td>
<td>Hold a dimension value (for example, a specific account number) so that the value appears for a dimension each time you add a document line. If the dimension value is already held, you can also use this function to release the value so that it does not appear when you add a document line.</td>
</tr>
<tr>
<td><strong>Goto → Previous document line</strong></td>
<td>Access the previous document line.</td>
</tr>
<tr>
<td><strong>Goto → Next document line</strong></td>
<td>Access the next document line.</td>
</tr>
<tr>
<td><strong>Environment → DispLocalActDocument</strong></td>
<td>Display a local document that contains actual data.</td>
</tr>
<tr>
<td><strong>Environment → DispGlobalActDocument</strong></td>
<td>Display a global document that contains actual data.</td>
</tr>
<tr>
<td><strong>Environment → Display plan docmnt</strong></td>
<td>Display a document containing plan data.</td>
</tr>
</tbody>
</table>

You cannot delete or change a document after it has been posted. Therefore, you should review your documents and make any corrections **before** making postings. If you post a document that is incorrect, you can reverse the document. For more information, see **Reversing Actual Documents** [Seite 165].

10. Once you have entered all line items for the document, choose **FI-SL document → Post.**
Display Actual Documents

This section explains how to display actual documents stored in an FI-SL line item table. The documents stored in a FI-SL line item table are entered directly in FI-SL or in a different SAP application component, such as Financial Accounting.

You can only display documents that are stored in the line item table. For more information about the document display and FI-SL line item tables, see Document Display [Seite 158].

If a document is stored in the FI-SL line item table, you can display the actual documents that were posted to the local and global ledgers.

You can also display documents that have been archived. To do this, choose Data sources… and enter the database and/or archive from which the documents should be read.

If you want to display an actual document that was posted to a local or global ledger, proceed as follows:

1. Choose Accounting → Financial accounting → Special Purpose Ledger, Actual posting → Local documents or Global documents → Display.

   The Display <Local or Global> FI-SL Actual Documents: Selection screen appears.

2. Enter the following selection criteria:
   – The first document number in the interval you want to display
   – The last document number in the interval you want to display
   – The fiscal year for which you want to display actual documents
   – The name of the local or global ledger containing the documents you want to display.
   – Company code or global company for which you want to display documents
   – The document type of the documents you want to display
     If you enter "*", all document types are displayed. Additionally, the original document and the reversal document are displayed.
   – Name of the user table you want to use.
     If you leave this field blank, the system uses the summary table of the selected local or global ledger

3. Choose Execute.

   The Display FI-SL <Local or Global> Actual Documents: List screen appears.

4. You can use the following additional functions in this screen:

   Additional functions (Display FI-SL <Local or Global> Actual Documents: List screen)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Order</td>
<td>Enter new criteria for the document display</td>
</tr>
</tbody>
</table>
### Display Actual Documents

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Right field</td>
<td>Move one dimension to the right.</td>
</tr>
<tr>
<td>Edit → Left field</td>
<td>Move one dimension to the left.</td>
</tr>
<tr>
<td>Edit → Right page</td>
<td>Move one page to the right</td>
</tr>
<tr>
<td>Edit → Left page</td>
<td>Move one page to the left</td>
</tr>
<tr>
<td>Goto → Display orig. document</td>
<td>Display original document (FI or CO) (You can only display actual data for CO documents)</td>
</tr>
<tr>
<td>Goto → Document reversal</td>
<td>Document reversal</td>
</tr>
</tbody>
</table>

If a document is posted to FI-SL from FI, SD, or MM, you can use the original application functions to display the ledger in which the document was posted. You can find additional information on this subject in the documentation of the respective applications.
Reversing Actual Documents

Use

Using the Reverse function, you can reverse local and global documents that have been posted to the FI-SL System.

You can only reverse FI-SL documents if all updated ledgers have line items.

Procedure

1. Choose Actual posting → Local documents (for local ledgers) or Global documents (for global ledgers) → Reverse.
   The Reverse <Local or Global> FI-SL Actual Documents screen appears.

2. Enter the following data:
   - Local or global company code of the document you want to reverse
   - Fiscal year of the document you want to reverse
   - Document number of the document you want to reverse

3. Choose Program → Execute.
   The reversal document data has been posted.
   The reversed document has the same document number as the original posting document, but a different document type (U for local documents, T for global documents).

Result

The reversal document data has been posted.
The reversed document has the same document number as the original posting document, but a different document type (U for local documents, T for global documents).
Totals Record

Definition
Total of the values of one or more document lines. The document information contained in a totals record contains the same dimensions as the line items of the totals record.

Use
Normally, only totals records are needed for reporting. For example, year-end financial statements are comprised of data collected over the course of a fiscal year. Therefore, the FI-SL System maintains a summary database that collects and summarizes document data in totals records.

You can display totals records. By entering selection criteria, you determine which totals records are displayed. See Totals Record Display [Seite 167].
Totals Record Display

Use
You can display totals records [Seite 166]. By entering selection criteria in the selection screen, you determine which totals records are displayed in the output list.
In the output list, you have various functions available for evaluating the displayed totals records.

Features
The totals record display contains the following functions:
• You can display actual and plan data
• You can display archived data records
• You can use the functions of the ABAP List Viewer [Extern] in the output list.
• You can summarize multiple totals records in one totals record.
• You can display the original document lines of a totals record if the document lines are stored in a line item table.
For the exact information on how to display totals records, see Displaying Totals Records [Seite 168].

Activities
Totals record display is found under Accounting → Financial accounting → Special Purpose Ledger→
• Planning → Display totals
• Actual posting → Display totals
• Information system → Reports for the Special Purpose Ledger → Totals Record Display
Displaying Totals Records

Use

Totals record display [Seite 167] is also used in Profit Center Accounting (EC-PCA). See Displaying Totals Records [Extern].

Procedure

Totals record display is found under Accounting → Financial accounting → Special Purpose Ledger→

- Planning → Display totals
- Actual posting → Display totals
- Information system → Reports for the Special Purpose Ledger → Totals Record Display

To display totals records, proceed as follows:

2. Enter the name of the ledger for which you want to display totals records.

   You can define the following:
   - In the output list, you can display totals records with a zero value. To do so, select Display zero records.
   - Under Settings..., you can directly select the totals records you want displayed.
     - You can enter a user table to display its data.
     - Under Variant for list, you can select a display variant for the output list. Included in the SAP Standard System are the display variants 0F_1 and 0F_2 for cost of sales ledger 0F.

       If you select a display variant, the totals records in the output list are automatically summarized. This means that totals records that match each other as to the displayed key fields are summarized and displayed as one totals record. With Restore, you can display the individual totals records.

       - You can also summarize the totals record when you select the data. To do so, select No individual records.

       If you use this function, you increase the performance when generating the output list. However, you cannot display the individual totals records using the restore function.

   - Under Maintain user table..., you can create or change a user table.

3. Choose Execute.

Selection screen

4. Enter your selection criteria.
Enter 0 as the record type to display actual data and 1 to display plan data.

You are also able to display archived totals records. To do so, choose Data sources..., select archive and enter the archive data. For additional information press the information button.

5. Choose Execute.

Output list

6. The totals records you selected are displayed in the output list.

The amounts and totaled amounts are displayed for all currencies kept in the ledger. The amounts are totaled for the posting periods you selected. The totaled amounts consist of the amounts from previous periods and the balance carried forward (period 0).

If you select posting periods 2 to 4 in the selection screen, the totals of periods 2 to 4 are displayed as well as the total of periods 0 to 4.

In the output list, you can:

- You can edit the output list by using display variants, by displaying or suppressing columns, or by forming totals. The functions of the ABAP List Viewer [Extern] are available for this. You can find additional information on the functions of the ABAP List Viewer under SAP List Viewer (ALV): Classic [Extern].

- If you suppress individual key fields in the output list, the summarize function is activated. This allows you to summarized the remaining totals records that have the same key fields. With Restore, the summarization is reversed.

- You can display long texts for the dimensions account number, cost center, business area, profit center, and functional area.

- From the output list, you can access the following information on the individual totals records:
  
  • **Period breakdown:** You can display period information for an individual totals record. To do so, double-click the totals record.
  
  • **Line items:** You can display the original document lines of a totals record if the document lines are stored in a line item table. To do so, double-click the totals record in the period screen.

You can only display a document in FI-SL if the document lines are stored in the line item table or in the source application database (if the document was posted to FI-SL from another application).
Updating Totals Records

For each ledger/company code/activity or ledger/global company/activity combination, you can define whether the ledger should be updated directly (real time) or in the background (batch mode).

If the ledger is updated directly, the FI-SL Integration Manager analyzes the incoming data and then transfers it to ledgers that are defined as real-time ledgers.

If the ledgers are updated in batch mode, the Integration Manager performs the same tasks as for real-time update but in the background. (Checks and validations can be made in real-time mode to reduce errors during batch processing.)

When you define companies, ledgers, and activities, you can also determine whether your documents should update the FI-SL line item table. For more information about the FI-SL line item table, see FI-SL Line Item Tables [Seite 36].

Summarizing Data in Ledgers

The data entered or transferred into the FI-SL System is summarized in the dimensions that are defined for the individual ledgers. Each document can contain data that affects several dimensions. However, only the data that affects the dimensions of a ledger is posted to that particular ledger.

Ledger 1 contains the dimensions "Account", "Cost Center", and "Article Number". All business transactions that affect these dimensions are then posted to Ledger 1.

You can also set all ledgers for delayed posting. For example, you may decide to set the ledgers to delayed posting if you have slow system performance as a result of a large volume of online postings. When you delay document posting into FI-SL, the documents are posted in the source application first (for example, FI), and then posted to FI-SL later. You can set this indicator for all FI-SL ledgers in Customizing. For more information, see the Maintain Update Type activity in the Implementation Guide (IMG) for Special Purpose Ledger.

Summarizing Currency Amounts

Each company or subsidiary has a local/global currency (local currency for local company codes, global currency for global companies). The group currency is defined per ledger; therefore, companies assigned to the same ledger have the same group currency.

You can have a maximum of three currencies in each ledger. The currency types defined in the ledger master data determine the currencies that are used. In addition to the transaction currency, you can define two additional currencies.
Periodic Processing

Purpose
This section describes the processes and functions that are relevant for periodic processing.

Integration
You can process data both from other SAP application components as well as from external systems.

Features

Allocation
You can periodically allocate amounts and quantities from sender objects to receiver objects using allocations.
For more information, see Allocation [Seite 173].

Rollup
You can use rollup to summarize information from one or more source ledgers in a rollup ledger in order to improve system performance.
For more information, see Rollup [Seite 251].

Currency Translation
The currency translation function enables you to translate group currency amounts that have already been posted to FI-SL.
For more information, see Currency Translation [Seite 302].

Balance Carryforward
The balance carryforward enables you to carry forward account balances from the previous fiscal year to the new fiscal year. You can carry forward:

- Balance sheet account balances from the previous fiscal year to the new fiscal year
- The profit and loss statement balance from the previous fiscal year to the retained earnings account of the new fiscal year

For more information, see Balance Carryforward [Seite 309].

Archiving
The data archiving function enables you to retrieve application data that is no longer needed in the system but is still required for analyses from the database and store it in accessible archive files.

The archiving activity consists of three activities:

- Generating archive files
- Storing archive files
Periodic Processing

- Starting the deletion program

For more information, see Archiving [Seite 312] and the SAP Library under Cross-Application Components → Archiving Application Data (CA-ARC) → Financial Accounting (FI).
Allocation

Purpose
You can periodically allocate amounts and quantities from sender objects to receiver objects using allocations. The two main types of allocations are assessments and distributions. You can allocate both plan and actual data. You carry out the allocation using the allocation cycle function. You use allocation rules to determine how amounts and quantities should be allocated from sender object to receiver object. It is possible to assess/distribute amounts and quantities according to the following criteria, for example:

- Headcount
- Sales costs
- Sales for a particular period

Implementation Considerations
In order to effect the allocation, you have to make various settings in Customizing. You make the settings in Customizing under Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation.

Integration
You can process data both from other SAP application components as well as from external systems with the allocation.

Features
You can choose between the Allocation Types [Seite 175] “distribution” and “assessment”. In this way, you determine how the allocation process is carried out.

You use Allocation Rules [Seite 178] to determine how amounts and quantities should be allocated from sender object to receiver object. You can choose between various Sender Rules [Seite 179] and Receiver Rules [Seite 181].

Processing of the data is effected using the Allocation Cycle [Seite 185]. Within an allocation cycle, you can define allocation segments. You determine allocation rules in an Allocation Segment [Seite 187].

The header data of the allocation cycle contains information valid for all segments contained in the cycle. Both Iterative Processing of Allocation Cycles [Seite 207] and Cumulative Processing of Allocation Cycles is possible. You can distribute or assess quantities and/or transaction currency amounts. You can define Selection Criteria [Seite 191] and Rules for Selection Criteria [Seite 192]. You determine the processing of the allocation cycle using Dimensions in Allocation [Seite 194].

You can lock individual segments in an allocation cycle so that they are not included in processing. See Locking Segments in an Allocation Cycle [Seite 220].

You can choose whether to execute allocation cycles in online mode or batch mode. See Executing Allocation Cycles [Seite 227]. You can determine how the system handles errors that occur during processing. Click here [Seite 232] for more information on errors.
Allocation

Information is also available on Reversing Allocation Cycles [Seite 234] and Deleting Allocation Line Items [Seite 235].

See also Displaying Allocation Results [Seite 236] and Printing Detail Lists [Seite 250].
Allocation Types

Definition

Summary of processes that can occur in connection with an allocation.

- **Distribution**
  
  Amounts and quantities of one or more sender objects are distributed to one or more receiver objects, from service cost centers to production cost centers, for example. The debit and credit postings for the distribution occur under the original account/original cost element with which the amounts and quantities are posted at the sender. The information of the original account/original cost element remains intact.

  The distribution can be carried out with actual and plan data.

- **Assessment**
  
  The assessment works in the same way as the distribution. However, with the assessment, the debit and credit postings do not occur under the original account or the original cost element but under an assessment account or an assessment cost element. The information of the original account/original cost element are lost.

  The assessment can be carried out with actual and plan data.

Structure

During the allocation, the following allocation types are distinguished:

- **Actual assessment** → Change/Display/Delete
- A planned assessment
- An actual distribution
- A planned distribution

An allocation using assessment can occur if the composition of the accounts or cost elements does not contain any important information for the receiver.

Assessed/distributed data records are stored separately in the summary tables. For this reason, you can view actual or plan data, with or without the allocated values.

For more information on displaying actual and plan data records, see Displaying Actual Documents [Seite 163] and Displaying Plan Documents [Seite 127].

In the information system, you can display the results of the allocation under the respective account or the respective cost element according to sender and receiver relationships. Sender and receiver information is documented in the line item document.

Example

Assessment

With an assessment, both sender and receiver amounts are posted to an assessment account.
The allocation is performed as follows:

1. Assessment account 600000 accumulates the balances of the accounts (510000, 520000, and 530000).

2. Assessment account 600000 equally allocates the balance from the utilities accounts (EUR 1,500) to EDP (cost center 100), Sales (cost center 300), and Marketing (cost center 400).

3. The amount EUR 500 is debited from each of the receiving cost centers in account 600000.

4. The assessment account 600000 is credited with the amount EUR 1,500.

**Distribution**

When you carry out a distribution, you allocate the balance from the original sender to the receiver. During the distribution, the original sender account is credited and the receiver account debited.

The allocation is processed as follows:
1. The amounts of the sender accounts (510000, 520000, 530000) are distributed equally to EDP (cost center 100), Sales (cost center 300), and Marketing (cost center 400).

2. The amount EUR 500 is charged to each of the receiving cost centers in accounts 510000, 520000, and 530000. The original account is therefore retained.

3. The accounts 510000, 520000, and 530000 of the Administration cost center are credited.
Allocation Rules

Definition
You use allocation rules to determine how amounts and quantities are allocated between sender objects (sender values) and receiver objects (receiver tracing factor). The rules for the allocation types are made up of sender and receiver rules.

- **Sender rules**
  
  **Determination of the sender values** for the distribution/assessment can occur according to the following rules:
  
  - Posted amounts
  - Fixed amounts
  - Fixed rates

- **Receiver rules**
  
  **Determination of the sender values** for the distribution/assessment can occur according to the following rules:
  
  - Variable portions
  - Fixed amounts
  - Fixed percentages
  - Fixed portions

Use
You can combine all sender and receiver rules for the distribution/assessment.

Combination of sender and receiver rules

<table>
<thead>
<tr>
<th>Sender</th>
<th>Receiver</th>
<th>Fixed amounts</th>
<th>Fixed percentages</th>
<th>Fixed portions</th>
<th>Variable portions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Posted amounts</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fixed amounts</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fixed rates</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
Sender Rules

Sender rules control how sender values are determined. You can use the following sender rules for sender values:

- Posted balances
- Fixed amounts
- Fixed rates

If you choose the sender rule \textit{posted amounts}, you can choose the selection criteria in the Sender values tab.

If you choose the sender rule \textit{fixed amounts} or \textit{fixed rates}, the Distribution Criteria List dialog box appears on the Sender values tab page. Here, you have to choose the allocation criteria.

Posted balances

The posted balance (amount) stored in the database for the sender is posted to the receiver. When you define the allocation rule for the sender, you can determine what percentage of the sender balance should be credited with the allocation amount.

The sender balance is 50,000 EUR. You define a percentage of 50\% to be credited to the sender. The amount 25,000 EUR is credited to the sender. The sender balance is now 25,000 EUR.

You want to credit an allocation to sender accounts 501000 through 502000. For this allocation, you want to use the balances of accounts 601000 through 602000 as sender. You create an allocation cycle in the following steps:

a) Use the \textit{posted amounts} allocation rule for the sender.

b) Define accounts 501000 to 502000 as \textit{sender} and accounts 601000 to 602000 as \textit{sender values}.

c) The system distributes the balances of accounts 601000 through 602000, but posts these as a credit to accounts 501000 through 502000.

Fixed amounts

You can allocate a specific fixed amount of the sender. The balance of the sender is not crucial here. The following options are available:

- You can allocate a specific, fixed amount from each sender
- You can allocate amounts in any currency

Each time the allocation cycle is carried out, the same amount is assessed/distributed from the sender. The allocated amount does not depend on the current balance of the sender.

Fixed rates
Sender Rules

If you determine a fixed rate for each unit of the receiver tracing factor,

- The sender is **not** credited with a specific amount (unlike with fixed amounts). The sender is credited with the amount that results from multiplying the fixed rate with the total of the respective receiver tracing factors. This sender value is then assessed/distributed to the receiver according to the receiver tracing factor.

- The receiver is debited with an amount that results from multiplying its tracing factor by the **sender fixed rate**.

In the example, *fixed rates* are allocated as sender rule.

The **receiver tracing factor** is the statistical key figure “CANTEEN”.

The number of employees in cost centers PERSON 1, PERSON 2, and PERSON 3 is 50, 100 and 150 respectively (total = 300).

The **sender allocation rule** is a *fixed rate* of 10 EUR/employee.

### Before assessment

<table>
<thead>
<tr>
<th>Sender</th>
<th>Sender rule</th>
<th>Receiver tracing factor</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>“CANTEEN”</td>
<td>Fixed rate</td>
<td>Statistical key figure</td>
<td>Cost center:</td>
</tr>
<tr>
<td>(300 empl.)</td>
<td>10 EUR per empl.</td>
<td>“CANTEEN”</td>
<td>Person 1: (50 empl.)</td>
</tr>
<tr>
<td>+ EUR 3000</td>
<td></td>
<td></td>
<td>Person 2: (100 empl.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Person 3: (150 empl.)</td>
</tr>
</tbody>
</table>

### After assessment

<table>
<thead>
<tr>
<th>Sender</th>
<th>Sender rule</th>
<th>Receiver tracing factor</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>“CANTEEN”</td>
<td>Fixed rate</td>
<td>Statistical key figure</td>
<td>Cost center:</td>
</tr>
<tr>
<td>(300 empl.)</td>
<td>10 EUR per empl.</td>
<td>“CANTEEN”</td>
<td></td>
</tr>
<tr>
<td>- EUR 3000</td>
<td>10 EUR per empl. * 50 (total empl.) =</td>
<td>Person 1: 500 EUR</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10 EUR per empl. * 100 (total empl.) =</td>
<td>Person 2: 1000 EUR</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10 EUR per empl. * 150 (total empl.) =</td>
<td>Person 3: +1500 EUR</td>
<td></td>
</tr>
</tbody>
</table>
**Receiver Rules**

Receiver rules control how receiver tracing sizes are determined. The following receiver rules can be used for receiver tracing factors:

- Variable portions
- Fixed amounts
- Fixed percentages
- Fixed portions

**Variable portions**

A variable portion is allocated to each receiver, based on values found in the FI-SL summary database (which is used as the basis for the allocation). The totals table is thus used as the basis for the allocation.

To define an allocation with variable portions, you specify dimensions and values for determination of the variable portions under *Receiver tracing factors*.

You could define an allocation so that the system checks the headcount of the cost centers in the receiver(s) to determine how the amount from the sender(s) should be assessed/distributed. This example assumes that the headcount was entered in the system by cost center (for example, as the statistical key figure *Employees*). Before the allocation is carried out, the system uses the variable portions in the summary database to check the personnel level of the cost centers.

**Variable portions**

<table>
<thead>
<tr>
<th>Sender</th>
<th>Receiver tracing factor</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center 200 (administration)</td>
<td>Statistical key figure Employees</td>
<td>Cost centers 100 (EDP): 300 (Marketing) and (Sales): 400</td>
</tr>
</tbody>
</table>
When allocating amounts using variable portions, the system:

1. Checks the database summary records of the sender, for the cost center 200 *administration*. Finds the amount 1,000 that will be assessed/distributed.

2. Checks the database records defined as a result of the tracing factor for the personnel level of the cost centers *EDP*, *Marketing*, and *Sales* to determine the current receiver tracing factors. The amounts are:

<table>
<thead>
<tr>
<th>Cost Center</th>
<th>Personnel Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>EDP (100)</td>
<td>40</td>
</tr>
<tr>
<td>Sales (300)</td>
<td>60</td>
</tr>
<tr>
<td>Marketing (400)</td>
<td>100</td>
</tr>
</tbody>
</table>

3. Totals the database summary records of the tracing factor for the headcount in EDP, Marketing, and Sales. The total headcount is 200.

4. Divides the amounts of the receiver control objects (individual receiving cost centers) by the **total** amount, in other words 200, to determine a percentage for each variable portion value. The percentages are:

<table>
<thead>
<tr>
<th>Cost Center</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>EDP (100)</td>
<td>40/200 = 20%</td>
</tr>
<tr>
<td>Sales (300)</td>
<td>40/300 = 30%</td>
</tr>
<tr>
<td>Marketing (400)</td>
<td>40/400 = 50%</td>
</tr>
</tbody>
</table>

5. Uses the determined percentages to perform allocation to the relevant cost centers (receiver). Each of these contain the percentage that was determined. The allocation result is as follows:
Fixed amounts

A specific fixed amount is allocated to each receiver. The amount credited to the original sender or assessment account is the sum of the receiver's fixed amounts and is also dependent upon the sender rule.

When you assess/distribute data using fixed amounts:

- You can allocate a specific, fixed amount to each receiver
- You can assess/distribute amounts in any currency
- The total of assessed/distributed fixed amounts are credited to the sender according to the sender rule.

The same fixed amount is assessed/distributed to the receiver each time the allocation cycle is executed.

Fixed percentages

A fixed percentage is assessed/distributed to each receiver, based on the amount to be allocated from the sender. You can define the percentage that should be assessed/distributed to each receiver. This percentage cannot be over 100%.

When you process data records using fixed percentages:

- You can assess/distribute a specific, fixed percentage to each receiver
- The system calculates the assessed/distributed amounts based on the percentage you entered for each receiver and sender value
- The credit to the sender or the assessment account is based on the amount available to be allocated from the sender (sender rule)

Each time the allocation cycle is carried out, the same percentage amount is assessed/distributed to the receiver. If you enter less than 100%, the sender is only credited with the percentage amount that you enter. The sender base is always 100%.

<table>
<thead>
<tr>
<th>Receiver values</th>
<th>Result (amount)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center 100: 10%</td>
<td>Cost center 100: 100 EUR</td>
</tr>
<tr>
<td>Cost center 200: 10%</td>
<td>Cost center 200: 100 EUR</td>
</tr>
<tr>
<td>Cost center 300: 50%</td>
<td>Cost center 300: 500 EUR</td>
</tr>
</tbody>
</table>

The sender balance is 300 EUR after the allocation is carried out.

Fixed portions
Receiver Rules

A fixed portion is assessed/distributed for each receiver. The system handles fixed portions in the same way as variable portions.

The only difference with fixed portions is that you determine which portion is assessed/distributed.
**Allocation Cycle**

**Definition**

Allocation cycles summarize the rules and settings to enable an allocation to occur. An allocation cycle consists of header data and one or more allocation segments that are processed together.

**Use**

The header data of the allocation cycle contains information valid for all segments contained in the cycle. Within a cycle, you can define several segments. In one segment you determine the rules by which an allocation is carried out.

You can carry out the entire allocation operations of the allocation in one cycle.

You can define several cycles that are then processed by the system in the order in which they were entered. The system ensures that a cycle is processed in full before the next cycle is carried out.

Splitting into several cycles can be beneficial for the following reasons:

- **Performance reasons**
  
  System run time rises considerably the more segments you process in an allocation, and where the value intervals are too large

- **Allocation relevant reasons**
  
  Where subsequent changes are required, it is not necessary to repeat the entire allocation operations. You just repeat the cycles affected.

  Using several cycles means that the allocation can occur at different times.

  Cycles are saved time-based. For each cycle, you have to enter a validity period in the header data. The selected cycle has to be valid in the posting period. It is not possible, for example, to carry out an allocation with a cycle in the second half-year of a fiscal year where that cycle is defined solely for the first half-year.

**Dependent allocation cycles**

You can create allocation cycles that are based on one another. Cycles are deemed to be dependent on each other where one cycle uses the result of an allocation of a previous cycle. In the case of dependent cycles, it is imperative that the order of execution is observed. Before execution, be sure that:

- If you have entered several cycles in the initial screens (**collective execution**), the system effects the cycles in the order in which they were entered. The allocation results of a cycle are transferred internally to the subsequent cycle. Iterative relationships between cycles are **not** taken into consideration.

- If you start dependent cycles separately (**individual execution**), data transfer occurs via the database but the end results correspond to those of collective execution.
Allocation Cycle

Dependent segments
The segment order within a cycle has no bearing on the result of cycle execution. The following execution types exist:

With Iterative indicator
When you process an allocation cycle iteratively, the result of one segment is then used by the other segments and processed further. The system continues to process the segments until all senders are completely credited.

Without Iterative indicator
When you do not process an allocation cycle iteratively, each segment in the cycle is processed independently of the other segments in the cycle. The result of one segment is not used by the following segments.

With Cumulative indicator
When you process an allocation cycle cumulatively, receiver tracing factor fluctuations or sender amounts to be allocated are cleared. In this way, a correct assignment of the allocated quantities and amounts is possible. Cumulative allocation smoothes the allocation over the periods.

You can find more information under Iterative/Cumulative Processing of Allocation Cycles [Seite 207].
**Allocation Segment**

**Definition**

Summary of the rules for the allocation. The following information is summarized in an allocation segment:

**Rules for sender objects**

All values to be allocated that are determined according to the same rules are summarized for the sender objects.

**Rules for receiver objects**

All receiver trace objects that are determined according to the same rules are summarized for the receiver objects.

**Use**

You can define several segments within a cycle.

**Overview: Sender values/receiver tracing factors per allocation**

<table>
<thead>
<tr>
<th>Allocation</th>
<th>Sender values</th>
<th>Tracing factors of the receiver objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution</td>
<td>- Posted amounts</td>
<td>- Variable portions</td>
</tr>
<tr>
<td></td>
<td>- Fixed amounts</td>
<td>- Fixed amounts</td>
</tr>
<tr>
<td></td>
<td>- Fixed rates</td>
<td>- Fixed percentages</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Fixed portions</td>
</tr>
<tr>
<td>Assessment</td>
<td>- Posted amounts</td>
<td>- Variable portions</td>
</tr>
<tr>
<td></td>
<td>- Fixed amounts</td>
<td>- Fixed amounts</td>
</tr>
<tr>
<td></td>
<td>- Fixed rates</td>
<td>- Fixed percentages</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Fixed portions</td>
</tr>
</tbody>
</table>

**Structure**

An allocation segment consists of the following elements:

- **Segment header**
  
  The segment header contains information that is valid for the whole segment. The sender and receiver rules determine how data records are assessed/distributed. You can find more information on allocation rules under Allocation Rules [Seite 178].

  With the sender values, you can:

  - Define a percentage of the sender value that is credited to the sender
  - Determine whether plan or actual values are allocated

  The segment header data determines the sender and receiver values for the segment.

- **Sender/receiver**
Allocation Segment

You define sender and receiver object data, (cost center, account number, and business area, for example). You are able to use sets. For more information, see Sets [Seite 633].

- Sender values
  Depending on the sender rule that you enter in the segment header, the following possible entries will be available to you for sender values: If you entered the sender rule
  - **Posted amounts**, you **can** enter sender values for these.
  - **Fixed rates**, you **must** enter sender values for these.
  - **Fixed amounts**, you **must** enter sender values for these.

- Receiver tracing factors
  If you specified:
  - **Variable portions**, you enter the receiver values for the receiver(s).
  - **Fixed amounts**, you enter the fixed amounts that should be allocated to each receiver.
  - **Fixed percentages**, you enter the fixed percentages (not more than 100%) that should be allocated to each receiver.
  - **Fixed portions**, you enter the fixed portions.

  For more information, see Creating a Receiver Tracing Factor for a Segment [Seite 214].

Example

The following graphic is an example of a simple allocation segment.
In this graphic:

- The **allocation type** is an assessment; Therefore, the allocated amount from the sender (accounts 500000-510000) is accumulated into an assessment account (400000).

- The **cycle contains header data** (1), company code 0001, and version 001. In addition to the local and group currency that are always usually allocated, the transaction currency should also be allocated.

- The **segment header** (2) contains the allocation rules for the assessment of the data of cost center 200 (administration). The allocation rule uses *posted amounts* for the sender and *fixed percentages* for the receiver.

- The **sender** (3) consists of all existing data records for the administration cost center (200) and accounts 500000-510000.

- The **receivers** (4) of the allocation are EDP (cost center 100), Sales (cost center 300), and Marketing (cost center 400).

- The **tracing factors** (5) are the percentages that are assigned to the receiver values (cost center 100: 10%; cost center 300: 30%; cost center 400: 60%).

For a further example of allocation with segments, see Segment [Extern].
Allocation Segment
Selection Criteria

You can define selection criteria for the allocation. You use:

- **Values**
  
  You can allocate from and to specific values and/or ranges of values.

- **Sets**
  
  Using sets, you can allocate from a sender and/or to a receiver.

You can use both Basic Sets [Seite 639] and Single-Dimension Sets [Seite 643] as selection criteria for the allocation. For more information, see Sets [Seite 633].

To specify values used during the allocation, you can determine a value, value interval, or set name for each of the following dimensions that are used in selection:

- Sender/receiver
- Sender values
- Receiver tracing factor
Rules for Selection Criteria

There are special rules for using values for different dimensions of a segment:

Dimensions as selection criteria

Identical dimensions (for example for senders and receivers) only need to be entered once in the sender selection criteria, since they will be inherited. You can find more information on inherited dimensions under Dimensions in Allocation [Seite 194].

If you do not enter a dimension as selection criteria, the dimension is not included in the data records for the allocation cycle and the data is summarized for this dimension. For undefined dimensions, the system will select all values.

In iterative processing, the system will allocate back to the sender if a dimension value is the same in the sender as it is in the receiver.

The sender value is 400000 for the dimension account. The receiver values are 400000 for the dimension account and 110 and 120 for the dimension cost center. Segment processing will result in an endless loop because the receiver continues to assess/distribute back to the sender value 400000.

Sets as selection criteria

The following rules control the use of set values, if you use sets as selection criteria for your dimensions:

- You cannot use a variable in a set used in an allocation.
- To select or allocate all data records for a dimension, use the Insert all values function (in set maintenance under Edit). The system uses data records for all values in the dimension and creates data records for all values.

If you do not define a dimension, all data records for this dimension are selected; however, the initial value of the dimension is summarized in the created sender and receiver data records.

If you select all values for a dimension (for example, using a range of values or the set value All values), all data records for the dimension are selected and sender and receiver data records are created for every field value (the dimension will not be summarized).

In Customizing for the Special Purpose Ledger you can define the following fields more precisely:

- Sender/receiver
- Sender values
- Receiver tracing factor

You can determine:

- Which fields can be used for receiver, sender, sender values, and/or tracing factor.
- Whether a user can enter a value, a range of values, and/or a set name for a field.
For more information, refer to the activities under Allocation in the Implementation Guide (IMG) for Special Purpose Ledger.
Dimensions in Allocation

Use
The processing of an allocation cycle is dependent on the dimensions that you use.

Features
You can choose between the following dimensions:

- Inherited Dimensions
- Distribution Dimensions
- Fixed Dimensions

Inherited Dimensions
Dimensions that are automatically transferred from a sender to a receiver or to sender control, or from a receiver to tracing factor, are called inherited dimensions. Dimensions are inherited as follows:

- **Cycle dimensions** (for example, company code) entered on the Create <Allocation Type>: Initial and Header screens are automatically inherited by the segments in the allocation cycle. Within the individual segments, you can overwrite these dimension values as needed.

- **Segment dimensions** are inherited as follows:

Sender and receiver dimensions are inherited from the sender.
Tracing factor dimensions are inherited from the receiver.

A dimension is defined in the sender, but not in the sender control or receiver:

The sender contains values 500000, 510000, and 520000 for the dimension “account” and the values 10 and 20 for the dimension “plant”. No selection criteria are defined for the dimensions “account” and “plant” in the receiver. For this reason, the receiver inherits the values 500000, 510000, and 520000 for the dimension “account” and the values 10 and 20 for the dimension “plant”.
A dimension is defined or inherited in the **receiver**, but not in the tracing factor:

From the sender, the receiver inherits the values 500000, 510000, and 520000 for the dimension “account” and the values 10 and 20 for the dimension “plant”. No selection criteria are defined for the dimensions “account” and “plant” in the tracing factors. The tracing factor therefore inherits the values 500000, 510000, and 520000 for the dimension “account” and the values 10 and 20 for the dimension “plant”.

- If you want your sender values to use some of the dimensions that are defined in your sender (but not all), only define the dimensions that you do **not** want the sender values to inherit from the sender.
- If you want your receiver to use some of the dimensions of your sender, you do not have to enter these dimensions for your receiver again.
- If you want your tracing factor to use the same dimensions that are defined or inherited in your receiver, you do not have to define the dimensions in your tracing factor.

**Do not** define the value for your receiver if the allocation is to occur from one value in a dimension to the **same value in this dimension**. This value is **inherited** from sender to receiver automatically.

**Do not** define the dimension “plant” in your receiver if the allocation is to be from plant 10 and cost center 100 (sender) to cost centers 200 and 300 for plant 10 (receiver), and from plant 20 and cost center 100 (sender) to cost centers 200 and 300 for plant 20 (receiver). The values of this dimension are **inherited** automatically from sender to receiver. The allocation is then carried out:

<table>
<thead>
<tr>
<th>From:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant 10, cost center 100</td>
<td>Plant 10, cost center 200</td>
</tr>
<tr>
<td>Plant 10, cost center 100</td>
<td>Plant 10, cost center 300</td>
</tr>
<tr>
<td>Plant 20, cost center 100</td>
<td>Plant 20, cost center 200</td>
</tr>
<tr>
<td>Plant 20, cost center 100</td>
<td>Plant 20, cost center 300</td>
</tr>
</tbody>
</table>

Define the value for your receiver if the allocation is to occur from one value in a dimension to the **same value in this dimension**. The value is **not inherited** from the sender to the receiver in this case.

Define the dimension “plant” (10, 20) in your receiver if the allocation is from plant 10 (sender) to cost centers 200 and 300 for plant 10 and 20 (receiver), and from plant 20 (sender) to cost centers 200 and 300 for plant 10 and 20 (receiver). The allocation is then carried out:

<table>
<thead>
<tr>
<th>From:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant 10, cost center 100</td>
<td>Plant 10, cost center 200</td>
</tr>
<tr>
<td>Plant 10, cost center 100</td>
<td>Plant 10, cost center 300</td>
</tr>
</tbody>
</table>
Features

<table>
<thead>
<tr>
<th>Plant 20, cost center 200</th>
<th>Plant 20, cost center 300</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant 20, cost center 100</td>
<td>Plant 10, cost center 200</td>
</tr>
<tr>
<td>Plant 10, cost center 300</td>
<td>Plant 20, cost center 200</td>
</tr>
<tr>
<td>Plant 20, cost center 300</td>
<td>Plant 20, cost center 300</td>
</tr>
</tbody>
</table>

If you do not define a dimension in the receiver and/or sender control, the values from the sender are automatically inherited. All dimensions in the cycle header are usually distributed to all segments.

Distribution Dimensions

The distribution dimension defines to which dimensions data is distributed. If you define more than one dimension as selection criteria for receiver(s), you need to instruct the system from which receiver values it should allocate data. You can specify more than one distribution dimension for the receiver.

If you use the fixed amount or fixed portion allocation rule for your receiver(s), and more than one dimension is defined for the receiver, you must specify for which dimension(s) you want to enter receiver values.

You enter the following receiver selection criteria for the dimensions “plant” and “cost center”.

<table>
<thead>
<tr>
<th>Plant</th>
<th>Cost center</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>100</td>
</tr>
<tr>
<td>20</td>
<td>300</td>
</tr>
<tr>
<td>400</td>
<td></td>
</tr>
</tbody>
</table>

If the distribution dimension is “plant”, you can enter amounts or portions for plants 10 and 20 (for cost centers 100, 300, 400).

If the distribution dimension is “cost center”, you can enter amounts or portions for cost centers 100, 300, and 400 (for plants 10 and 20).

If the distribution dimensions are both “cost center” and “plant”, you can enter amounts or portions for the following combinations:

- Cost center 100/plant 10
- Cost center 100/plant 20
- Cost center 300/plant 10
- Cost center 300/plant 20
• Cost center 400/plant 10
• Cost center 400/plant 20

When you select a distribution dimension, you do not change the amount or portion that is allocated. You only determine to which values data will be allocated.

If there is only one dimension defined for the receiver, that dimension automatically becomes the distribution dimension.

**Fixed Dimensions**

A fixed dimension is any dimension that contains *exactly* one value in the receiver. This value always appears in the data records for the receiver of the allocation.
**Tips for Optimizing System Runtime**

To optimize system performance and run time, please observe the following:

Avoid having more than 50 segments in an allocation cycle, as this will otherwise cause a considerable rise in system run time.

Check whether it is necessary to set the *iterative* indicator in the relevant cycle.

The processing of the assessment occurs more quickly than processing of the distribution as, in the case of the assessment, the data is summarized via an account.

The optimal database access strategy depends heavily on the definition of a cycle. You can define the type of database access strategy via an indicator.

From the *Execute <Allocation Type>: Initial Screen*, choose ![Settings](image) → *Database selection.* Here, you can choose between the following database access strategies:

- **Selection by cycle**
  
  For each field in the cycle that is accessed, the largest and smallest value is determined in the whole cycle and used for database selection.
  
  **Advantage:** Database is accessed exactly once.
  
  **Disadvantage:** There is the risk that too many objects are selected. You have to eliminate the excess afterwards.

- **Selection by segment**
  
  For each field in the cycle that is accessed, the largest and smallest value is determined in the segment.
  
  **Advantage:** The performance of database selection with number of segments is virtually linear and no longer exponential.
  
  **Disadvantage:** Occasionally, the hit list is rather high.
Overview: Carrying out the Allocation

Procedure

To carry out an allocation, proceed as follows:

1. **Make the system settings:**
   - Determine the structure for your allocations. You define the dimensions and the appropriate values from/to which the allocation is to occur.
   - Maintain the field usage for the allocation. In Customizing for Special Purpose Ledger, define the fields that can be used for assessment and distribution allocations.
   - Define the allocation field group information, data fields, text for the data fields, and system information, if necessary. You only need to maintain this information in exceptional cases.
   - Check all settings made in Customizing. To do this, choose Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation → Check Allocation Settings. You only need to complete this step once.

2. **Create the sets that you want to use for the allocation, if required.**
   - You can assess/distribute fixed values.
   - You can use sets to determine the sender(s) and the receiver(s) for an allocation. When you define allocation segments, you can enter set names for the sender, receiver, sender values, and tracing factor selection criteria.

3. **Create the allocation cycle.**
   - Define the header data of the allocation cycle. The header data of the allocation cycle contains information valid for all segments contained in the cycle.

4. **Define the allocation segments in the allocation cycle.**
   - When you create an allocation cycle, you define information for one or more allocation segments.
   - You define the rules for allocating from the sender(s) and the selection criteria for the sender(s) and receiver(s). For more information, see Creating Allocation Cycles [Seite 201].

5. **Execute the allocation.**
   - You can execute allocation cycles in both online and background processing.
   - The system locates data records to be used for the allocation, according to the selection criteria defined in the sender.
   - The system allocates the data according to the allocation type (assessment or distribution) and the allocation rule.
   - The system writes the data records for the allocation.
   - The system generates lists of allocation results and errors (if the allocation process included errors).

For more information, see Executing Allocation Cycles [Seite 227].
Overview: Carrying out the Allocation

6. Display the allocation results.

After the allocation is carried out, a basic list is output, that permits you to control and verify processing.

For more information, see:

- Displaying Cycle Overviews [Seite 238]
- Displaying Standard Settings [Seite 239]
- Displaying Messages [Seite 240]
- Displaying Line Items [Seite 242]
- Displaying Segment Lists [Seite 243]
- Displaying Sender Lists [Seite 244]
- Displaying Receiver Lists [Seite 245]
- Displaying Journals [Seite 246]
- Technical Statistics, Expert Trace, and Divergence Analysis [Seite 247]
- Printing Detail Lists [Seite 250]
- Displaying Previous Processing [Seite 249]
Creating Allocation Cycles

Use
You define allocations in cycles in the FI-SL System if you want to carry out an assessment or a distribution. Every cycle consists of one or more segments. Within each segment, you define the sender and receiver for the segment, as well as the rules for allocating data.

Prerequisites
To create allocation cycles and allocation segments, choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation, and then either:

- Actual assessment / Actual distribution → Create
- Plan assessment / Plan distribution → Create

The system displays the FI-SL: Create <Allocation Type>: Initial Screen.

You can also enter actual data via Actual posting. (Actual posting → Actual closing → Actual assessment or Actual distribution → Create).

You can also enter plan data via Planning. (Planning → Plan closing → Plan assessment or Plan distribution → Create).

Procedure
1. Make the following entries:
   - Ledger name
   - Name for the allocation cycle
   - Start date for the allocation cycle

   The first character of the allocation name cannot be a number. If you use the same name for an allocation more than once, the allocations must have different starting dates. When allocation cycles have the same name, but different starting dates, the system processes the cycles as independent objects. In the event of a change, this allows you to keep your old cycle and to create a new cycle with the same name but a different start date. If you define cycles that have the same name, the valid period of the first cycle should normally end before the second cycle starts.

   - Use the reference information, if you want to copy an existing allocation cycle, for example.

2. Choose Execute.

   The system displays the FI-SL: Create <Allocation Type> Cycle: Header Data screen.

   For more information, see:
Creating Allocation Cycles

- Creating Header Data for an Allocation Cycle [Seite 203]
- Creating a Segment for an Allocation Cycle [Seite 209]
- Creating Sender Values for a Segment [Seite 212]
- Creating a Receiver Tracing Factor for a Segment [Seite 214]
Creating Header Data for an Allocation Cycle

Use

The information that you enter in the cycle header applies to every segment that you create for the cycle.

Procedure

1. On the FI-SL: Create <Allocation Type>: Header Data screen, enter the following data:
   - End date for the allocation cycle
   - Description for the allocation cycle. This description appears when you execute the allocation.

2. In the Indicators group box:
   - Deselect Iterative if you do not want to process the allocation cycle iteratively.
   - Select the Cumulative indicator if you want to process the allocation cycle as a cumulative allocation.

   You can find more information under Iterative Processing of Allocation Cycles [Seite 207].

3. Select the field groups to be used in the cycle:
   - Select Act. tr., if you want to allocate transaction currency and quantities.
   - Select Act. tr., if you want to allocate transaction currency. If you do not set this indicator, the system uses the second or third currency (depending on your system configuration) and writes it as transaction currency to the sender(s) and receiver(s) data records. This reduces the number of records stored on the database, since the system does not take into consideration the different transaction currencies.

4. Enter the selection criteria in the Preset selection criteria group box.

   The selection criteria fields that appear depend on the system structures you have defined for allocations in Customizing for Special Purpose Ledger. The values you enter in these fields are valid for all senders and receivers in all segments (unless specified in the segment definition).

   Enter the company code or the company: The allocation does not work company code/company independent.

5. You can use the following additional functions on this screen.

   **Additional functions (FI-SL: Create <Allocation Type>: Header Data screen)**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Attach segment</td>
<td>Add a segment to the cycle</td>
</tr>
<tr>
<td>Edit → Copy segment</td>
<td>Copy an existing segment to the cycle</td>
</tr>
</tbody>
</table>

April 2001
Creating Header Data for an Allocation Cycle

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Overview segments...</td>
<td>Display an overview of segments contained in the cycle</td>
</tr>
<tr>
<td>Extras → History...</td>
<td>View the revision history of the cycle</td>
</tr>
</tbody>
</table>

6. Save your data.
Cumulative Processing of Allocation Cycles

Use

When you process an allocation cycle cumulatively, tracing factor fluctuations or sender amounts to be allocated are cleared. The allocation is usually carried out by period, meaning that posted values are allocated for a sender in a period according to tracing factors entered in this period. If the tracing factors or the sender amounts to be allocated fluctuate to a great extent, an assignment of the allocated costs based on source is not possible during processing by period. Cumulative processing of tracing factors or sender values can negate these fluctuations. Cumulative processing smooths the allocations over the periods.

A publishing company produces periodicals that appear at least once a month, and also other less frequent publications. Sales and administration costs are assessed to cost centers with the monthly sales volume serving as the allocation base.

With a non-cumulative assessment, overhead costs are not debited for periodicals that do not appear in certain months. Nonetheless, production of these goods does generate sales and administration costs even in such months. The periodicals that appear at least once a month are additionally debited with these sales and administration costs. Over a period of time, the periodicals that appear at least once a month have to bear too large a share (and the others too small a share) of the sales and administration costs.

With a cumulative assessment, allocation of the sales and administration costs is smoothed over the months. Periodicals that do not appear for a certain month are debited with sales and administration costs according to their share of cumulative sales volume.

In some countries, “smoothing” with allocation is a legal requirement. Using cumulative allocation, therefore, these legal obligations are fulfilled.

Some sold-to parties (public sold-to parties, for example) even stipulate such a smoothing to prevent manipulation of expenses.

Prerequisites

To carry out effective cumulative processing:

- Sender/receiver relationships must be stable within the fiscal year.

  Within the fiscal year, senders or receivers must not be deleted. The system checks this condition during cumulative processing.

  Deleting senders or receivers that existed in previous periods that no longer exist (or are no longer valid) in the current period due to master data checks or cycle changes will cause erroneous allocations. Increasing the allocation network is, however, non-critical.

- The sender rule *Posted amounts* and the receiver rule *Variable portions* should be used.

  Only with this rule combination will a cumulation on sender and receiver-side actually occur.
Cumulative Processing of Allocation Cycles

Collective execution of cumulative and non-cumulative cycles is **not** possible.

**Features**

**Executing Cumulative Processing**

If you execute an allocation cycle cumulatively, the sender amounts posted up to the current period are allocated to the receiver as a result of tracing factors. Cumulative processing always cumulates from period 1.

The determined allocation amounts, too, are cumulated for each receiver and posted in the current period minus the amounts allocated to the respective receiver in the previous periods. Postings in previous periods are thus unchanged.

Only those amounts for the receivers that were posted in the previous periods using the appropriate cumulative processing are taken into account.

If you carry out cumulative processing for a period interval and have already posted cycles from the “To” period, the SAP System reverses all periods from the “To” period up to and including the last posted period. The system displays a confirmation messages. In the background, a log message is generated.

You should not change the *Cumulative* indicator during the current fiscal year.

The scaling of negative tracing factors is only applied to the cumulative total tracing factor for one receiver, not to the values of the tracing factors in the individual periods. For more information, see [Scaling of Negative Tracing Factors][1] [Seite 216]

**Reversing Cumulative Processing**

If you wish to reverse cumulative processing, you must reverse up to the last posted period due to period-independent work methods.

In online execution, you can trigger reversal of subsequent already posted periods via a dialog box. If subsequent periods are already posted, reversal is **not** carried out in the background.

You wish to reverse a cumulative cycle in period 3, however periods 1 to 5 were already posted. Reversal of period 3 is only possible in conjunction with periods 4 and 5.

For more information, see [Example of Cumulative Processing][2] [Extern].
Iterative Processing of Allocation Cycles

Use
You can process allocation cycles iteratively or non-iteratively.

Features
Iteratively
When you process an allocation cycle iteratively, the result of one segment is then used by the other segments and processed further. The segments are processed dependent on each other. This means, for example, that an account that is used as the receiver in one segment can be used again in another segment as the sender. The system continues to process the segments until all senders are completely credited. The order of the segments has no bearing on the allocation results.

The following graphic shows an allocation cycle with allocation segments that are processed iteratively. In this example, amounts are assessed/distributed from cost centers 100 (EDP) and 200 (Administration). As these cost centers also assess/distribute amounts between each other, the allocation cycle is processed iteratively:

Segment 1: The amounts of cost center 100 (EDP) are assessed/distributed to cost centers 200 (Administration), 300 (Sales), and 400 (Marketing).

Segment 2: The amounts of cost center 200 (from segment 1) are assessed/distributed to cost centers 100 (EDP), 300 (Sales), and 400 (Marketing).
Iterative Processing of Allocation Cycles

Next, the amounts of cost center 100 from segment 2 is then assessed/distributed again to cost centers 200, 300, and 400 in segment 1. The allocation cycle is processed until the balance of all senders is zero.

When you process an allocation cycle iteratively, the system processes the segments until all senders have the balance 0. If your allocation is defined so that two or more senders/receivers in a cycle completely allocate in a non-solvable relationship, the system will end processing and display an error. For more information, see Iterative Processing of Cycles [Extern]

Non-iteratively

When you do not process an allocation cycle iteratively, each segment in the cycle is processed independently of the other segments in the cycle. The values allocated from previous segments are not used by the following segments in the allocation cycle. The order of the segments in the cycle is irrelevant to the allocation results.
Creating a Segment for an Allocation Cycle

Use

To carry out an allocation, you have to define an allocation cycle. Every cycle consists of one or more segments. Within each segment, you define the sender and receiver for the segment, as well as the rules for allocating data.

Prerequisites

You chose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing and then selected the allocation type. The system displays the FI-SL: Create <Allocation Type>: Header Data screen.

Procedure

1. To create a segment, choose Attach segment. The system displays the FI-SL: <Allocation Type> Cycle: Segment screen.
2. Enter a name and description for the segment.
3. Set the block indicator if you want the system to temporarily ignore this segment in the allocation cycle.
   
   When processing the allocation cycle, the system ignores this segment.
   
   When you create an actual or plan assessment, the Assessment acct entry field is displayed. Enter the account number that will be used to accumulate data from the original sender account(s).
4. Choose the tab strip Segment header and enter the required data.
   
   − In Sender values, select the appropriate sender rule. You use sender rules to control how sender values are determined. For more information, see Creating Sender Values for a Segment [Seite 212].
   
   − To credit the sender a certain percentage rate, enter the proportionate share in % of the sender value.
   
   The entry of a percentage rate greater than 100% is not permitted.
   
   − To assess or distribute actual/plan data to the receiver(s), set the appropriate indicator. For more information, see Allocating Plan and Actual Values [Seite 219].
   
   − On the Segment header tab page, under Receiver tracing factor, select the required receiver rule. You use receiver rules to control how receiver tracing bases are determined. For more information, see Creating a Receiver Tracing Factor for a Segment [Seite 214].
5. Select the Senders/receivers tab and enter the required data. If you specified:
Creating a Segment for an Allocation Cycle

- A fixed value, you only enter a value in the From field
- A range of values, you only enter values in the From and To fields
- A mixture of fixed values and/or ranges of values, you only enter a value in the Set field

The dimensions that were defined in Customizing for your table are displayed. For more information about how your allocations software is configured, see the steps under Allocation in the FI-SL Implementation Guide (IMG).

6. Choose the tab strip Sender values and enter the required Selection criteria.

7. Choose the Receiver tracing factor tab and enter:
   - Type of variable portions, if you are working with a variable receiver tracing factor.
   - Scale neg. tracing factors, to control the scaling that is carried out in the event of negative tracing factors for the receivers.
   - Required selection criteria.

8. Select the Rec.wght.factors tab and enter a factor to determine the number of decimal places for the weighting factor.

9. You can use the following additional functions on this screen:

**Additional Functions**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Copy segment...</td>
<td>Copy an existing segment to the cycle</td>
</tr>
<tr>
<td>Edit → Delete segment</td>
<td>Delete the segment from the cycle</td>
</tr>
<tr>
<td>Goto → Header data</td>
<td>Enter header data for the cycle</td>
</tr>
<tr>
<td>Goto → Overview segments...</td>
<td>View an overview of segments contained in the cycle</td>
</tr>
<tr>
<td>Goto → Cycle run group</td>
<td>Process cycles of an allocation type in parallel</td>
</tr>
<tr>
<td>Extras → History...</td>
<td>View the revision history of the cycle</td>
</tr>
<tr>
<td>Extras → Error log</td>
<td>Display error log</td>
</tr>
<tr>
<td>Extras → Create set</td>
<td>Create a set for the segment</td>
</tr>
<tr>
<td>Extras → Change set</td>
<td>Change a set used in the segment</td>
</tr>
<tr>
<td>Extras → Display senders</td>
<td>Display a list of senders for the segment</td>
</tr>
<tr>
<td>Extras → Display receivers</td>
<td>Display a list of receivers for the segment</td>
</tr>
<tr>
<td>Extras → Change documents</td>
<td>Display change documents</td>
</tr>
<tr>
<td>Extras → Combinations → Senders</td>
<td>Change the distribution dimension(s) for the senders in the segment</td>
</tr>
</tbody>
</table>
Creating a Segment for an Allocation Cycle

| Extras → Combinations → Receivers | Change the distribution dimension(s) for the receivers in the segment |

10. To save the data, choose 📋.
Creating Sender Values for a Segment

Use
You control determination of sender values with sender rules. You can choose between the following sender rules:

- Posted amounts
- Fixed amounts
- Fixed rates

When you select posted amounts, these are assessed/distributed to each sender value.

When you select fixed amounts, these are assessed/distributed independent of the sender amounts.

When you select fixed rates, you have to enter these for each sender and for each unit of the receiver tracing factor.

Prerequisites
You chose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing and then selected the allocation type. The system displays the Fi-SL: <Allocation Type> Cycle: Header Data screen. You selected Attach segment and are now on the Fi-SL Create <Allocation Type>: Segment screen.

Procedure
1. Choose the tab strip Segment header and enter the required data.
   - Under Sender-val., select the required sender rule.
   - To credit the sender a certain percentage rate, enter the proportionate share in % of the sender value.

   The entry of a percentage rate greater than 100% is not permitted.

   - To assess or distribute actual/plan data to the receiver(s), set the appropriate indicator.
     For more information, see Allocating Plan and Actual Values [Seite 219]

2. Select the Senders/receivers tab and enter the required data.

3. Choose the Sender values tab strip and enter the required data.
   - If you have selected the posted amounts sender rule, make the following entries:
     - Enter the percentage rate that reflects what percentage of the sender control values should be used for the allocation. The respective sender is credited with the remaining percentage.
     - To assess or distribute actual/plan data to the receiver(s), set the appropriate indicator.
     - Make the required settings under Selection criteria.
The dimensions are displayed that were defined in the IMG under Allocation for your table. For more information about how your allocations software is configured, see the steps under Allocation in the FI-SL Implementation Guide (IMG).

If you have selected the fixed amounts sender rule, make the following entries:

- Enter the currency in which the sender data is assessed/distributed.
- For each sender value defined in the segment, enter the fixed amount to be assessed/distributed.

If you have selected the fixed rates sender rule, make the following entries:

- Enter the currency in which the sender data is assessed/distributed.
- Specify a fixed rate for every sender and for each unit of the receiver tracing factor.

4. You can use the following additional functions on this screen:

**Additional Functions**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Copy segment...</td>
<td>Copy an existing segment to the cycle</td>
</tr>
<tr>
<td>Edit → Delete segment</td>
<td>Delete the segment from the cycle</td>
</tr>
<tr>
<td>Goto → Header data</td>
<td>Enter header data for the cycle</td>
</tr>
<tr>
<td>Goto → Overview segments...</td>
<td>View an overview of segments contained in the cycle</td>
</tr>
<tr>
<td>Goto → Cycle run group</td>
<td>Process cycles of an allocation type in parallel</td>
</tr>
<tr>
<td>Goto → First segment</td>
<td>Access segment header data for the cycle</td>
</tr>
<tr>
<td>Extras → History...</td>
<td>View the revision history of the cycle</td>
</tr>
<tr>
<td>Extras → Create sets</td>
<td>Create a set for the segment</td>
</tr>
<tr>
<td>Extras → Change sets</td>
<td>Change a set used in the segment</td>
</tr>
<tr>
<td>Extras → Display senders</td>
<td>Display a list of senders for the segment</td>
</tr>
<tr>
<td>Extras → Display receivers</td>
<td>Display a list of receivers for the segment</td>
</tr>
</tbody>
</table>

5. To save the data, choose ☑.
Creating a Receiver Tracing Factor for a Segment

Use
You control determination of receiver tracing factors with receiver rules. You can choose between the following receiver rules:

- Variable portions
- Fixed amounts
- Fixed percentages
- Fixed portions

If you choose variable portions, these are used by the system as tracing factor and assessed/distributed to the receiver.

If you select fixed amounts, the receivers are debited directly with these amounts. The amount credited to the sender results from the total of receiver amounts. The rule for determination of sender values is not used in this instance. Also, posted sender amounts or created fixed sender amounts are not taken into consideration.

If you select fixed percentages, you define fixed percentages for the receiver. The sender value is distributed to the receivers according to these percentages. The total of receiver tracing factors must not exceed 100%. The system assumes a sender tracing factor of 100%. If the total of receiver tracing factors is smaller than 100%, a part of the sender value remains with the sender.

If you select fixed portions, you define fixed portions for the receiver. The procedure is similar to fixed percentages. With this procedure, the sender is credited completely, unless you have defined a percentage residual value.

Prerequisites
You chose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing and then selected the allocation type. The system displays the FI-SL: Create <Allocation Type>: Header Data screen. You selected Attach segment and are now on the FI-SL Create <Allocation Type>: Segment screen.

Procedure
1. Choose the Segment header tab page and enter the required data (according to the sender rule you selected) under Receiver tracing factor.
   - If you selected the variable portions receiver rule, you must:
     - Select the Type of var. portions. The system controls how the receiver tracing factor of the respective allocation is determined.
     - Determine scaling of negative tracing factors. For more information, see Scaling of Negative Tracing Factors [Seite 216]

2. Select the Senders/receivers tab and enter the required data.
3. Choose the Receiver tracing factor tab and enter the required data.
Creating a Receiver Tracing Factor for a Segment

The dimensions are displayed that were defined in the IMG under Allocation for your table. For more information about how your allocations software is configured, see the steps under Allocation in the FI-SL Implementation Guide (IMG).

- If you selected the **fixed amounts** receiver rule, you must:
  - Currency in which the receiver data is assessed/distributed.
  - Enter a fixed amount to be assessed/distributed for each receiver value in the segment.

- If you selected the **fixed percentage/fixed portion** receiver rule, you must:
  - For each receiver value defined for the segment, enter a fixed portion/percentage to be assessed/distributed to the value.

For the receiver rule **fixed percentages**, you cannot enter more than 100%.
For the receiver rule **fixed portions**, you enter fixed portions.

4. You can use the following additional functions on this screen:

**Additional Functions**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Copy segment...</td>
<td>Copy an existing segment to the cycle</td>
</tr>
<tr>
<td>Edit → Delete segment</td>
<td>Delete the segment from the cycle</td>
</tr>
<tr>
<td>Goto → Header data</td>
<td>Enter header data for the cycle</td>
</tr>
<tr>
<td>Goto → Overview segments...</td>
<td>View an overview of segments contained in the cycle</td>
</tr>
<tr>
<td>Goto → Cycle run group</td>
<td>Process cycles of an allocation type in parallel</td>
</tr>
<tr>
<td>Goto → First segment</td>
<td>Access segment header data for the cycle</td>
</tr>
<tr>
<td>Extras → History...</td>
<td>View the revision history of the cycle</td>
</tr>
<tr>
<td>Extras → Create sets</td>
<td>Create a set for the segment</td>
</tr>
<tr>
<td>Extras → Change sets</td>
<td>Change a set used in the segment</td>
</tr>
<tr>
<td>Extras → Display senders</td>
<td>Display a list of senders for the segment</td>
</tr>
<tr>
<td>Extras → Display receivers</td>
<td>Display a list of receivers for the segment</td>
</tr>
</tbody>
</table>

5. To save the data, choose 📝.
Scaling of Negative Tracing Factors

Use

Negative tracing factors can occur if the tracing factors are given not as quantities or percentage rates, but are taken from the database. This is the case, for example, with a distribution by activity types or statistical key figures.

The scaling of negative tracing factors is only of importance when the receiver tracing factors have different +/- signs.

If part of the receiver has positive and part negative tracing factors, we distinguish between two cases:

- If the total of all the receiver tracing factors is greater than zero, then the system credits (without scaling) the receiver as well as the sender with negative tracing factors. In the process, receivers with positive tracing factors are debited more heavily.

- If the total of all the receiver tracing factors is less than zero, the system credits (without scaling) the receiver as well as the sender with positive tracing factors. The receivers with negative tracing factors are thus debited more heavily.

In iterative processing, this can mean that the iteration does not converge, leading to cancellations or incorrect results.

Features

You have the following options for scaling negative tracing factors:

No scaling (1)

Negative tracing factors are allowed for.

Standard scaling (2)

The scaling depends on the total of the receiver tracing factors:

- If the total of the receiver tracing factors is positive or zero, then the largest negative tracing factor is set to zero. The other tracing factors are increased correspondingly. This ensures that all the receiver tracing factors are positive.

- If the total of the receiver tracing factors is negative, the largest positive tracing factor is set to zero. The other tracing factors are reduced correspondingly. This ensures that all the receiver tracing factors are negative.

Absolute value (negative value becomes positive) (3)

For negative tracing factors, the +/- sign is reversed. This ensures that all the receiver tracing factors are positive.

Negative tracing factors become zero (4)

Negative tracing factors are set to zero. Therefore, you do not allocate costs to these receivers.

Smallest negative tracing factor becomes zero (5)
Scaling of Negative Tracing Factors

The largest negative tracing factor is set to zero. All other tracing factors are increased correspondingly. This ensures that all the receiver tracing factors are positive. Receivers, which before the scaling had the tracing factor 0, are given a positive tracing factor.

Smallest negative tracing factor becomes zero, but zero remains zero (6)

The largest negative tracing factor is set to zero. All other tracing factors are increased correspondingly. Receivers, which before the scaling had the tracing factor 0, are given tracing factor 0.

Example of Scaling Negative Tracing Factors

<table>
<thead>
<tr>
<th></th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tra. fac. rec. 1</td>
<td>-100</td>
<td>0</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Tra. fac. rec. 2</td>
<td>200</td>
<td>300</td>
<td>200</td>
<td>200</td>
<td>300</td>
<td>300</td>
</tr>
<tr>
<td>Tra. fac. rec. 3</td>
<td>-50</td>
<td>50</td>
<td>50</td>
<td>0</td>
<td>50</td>
<td>50</td>
</tr>
<tr>
<td>Tra. fac. rec. 4</td>
<td>0</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>100</td>
<td>0</td>
</tr>
<tr>
<td><strong>Total tra. factors</strong></td>
<td><strong>+ 50</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The scaling of negative tracing factors can be set only for single segments and not for the entire cycle.
Defining Receiver Weighting Factors

Use
The tracing factors selected for the given receiver are multiplied by a weighting factor.

Procedure
1. To establish receiver-specific weighting factors, choose the Rec.wght.factors tab page.
2. If you want to use a receiver weighting factor other than 1, simply overwrite the default setting under Factor.

   ➤

   When you make the entry, note that you must take into account the factor of the decimal places of the receiver weighting factor.

3. Choose 🗑.
4. If more than one segment exists in an allocation cycle, choose Previous segment or Next segment to scroll through the existing segments.

   ➤

   The system informs you if no other segment exists.

5. To access another segment of the cycle, choose 🗑.
6. To access the header data of the cycle, choose 🗑.
7. Choose Edit → Delete segment to delete the segment for the receiver weighting factor.

Result
The allocation is made using a tracing factor determined by the system on the basis of the weighting factor.
Allocating Plan and Actual Values

Use

Allocating plan values in an actual allocation cycle
Separate allocation cycles are created for plan and actual allocations. In segment definition you can specify that the plan data is allocated in actual instead of the posted actual amounts and actual quantities. To do this, in segment definition select Plan values. Actual amounts and actual quantities are allocated analogous to the plan amounts and plan quantities.

⚠️ Allocations that have already occurred in the plan are not taken into account.

Allocating actual values in a plan allocation cycle
Separate allocation cycles are created for plan and actual allocations. In segment definition you can specify that the actual data is allocated in plan instead of the posted plan amounts and plan quantities. To do this, in segment definition select Actual values. Plan amounts and plan quantities are allocated analogous to the actual amounts and actual quantities.

⚠️ Allocations that have already occurred in actual are not taken into account.
Locking Segments in an Allocation Cycle

Use
You can lock individual segments in an allocation cycle. These segments do not participate in the processing of the allocation cycle.

Blocking of a segment is useful if data in your segment has changed and you wish to repeat a periodic allocation for this segment only. By locking the other segments in the allocation cycle, processing time is reduced.

Activities
You can lock the individual segments of a cycle when you create or change a cycle or a tracing factor. To do this, select Lock indicator.
Copying Segments

Use
You can copy existing segments. These copied segments can then be changed.

Prerequisites
You are on the FI-SL: Create / Change <Allocation Type>: Header Data screen.

Procedure
1. Select 🕵️.
2. Select the segment that you want to copy and choose 🕵️.
3. Choose Edit → Copy segment. The system displays the Copy segment dialog box.
   • Enter data for Copy from.
   • Enter data in the To field.

You can copy segments within an allocation cycle or from another allocation cycle.
4. Choose Continue to leave the dialog box.

Result
You can now process the copied segments.
Displaying Allocation Cycles

Use
You can display a certain allocation cycle using the combination ledger, cycle, and start date. You can use this function to check whether an allocation cycle was created for a specific ledger and time period.

Prerequisites
You created a cycle. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation → <Allocation type> → Display.
The FI-SL: Display <Allocation Type>: Initial Screen appears.

Procedure
1. Make the following entries:
   – Ledger name
   – Name of allocation cycle

      Allocation cycles with the same name must have different starting dates. When allocation cycles have the same name, but different starting dates, the system views them as independent objects.
   – Start date of the allocation cycle

      The start date of the cycle is used for the following control reasons: The start date determines the earliest validity time of the cycle and you can define various versions for a cycle using different start dates. Allocations are only possible with a cycle valid in the posting period.

2. Choose . The FI-SL: Display <Allocation Type>: Header Data screen appears.
3. The system displays the following allocation cycle header data:
   – The system displays whether the allocation cycle is processed iteratively or cumulatively. For more information, see Iterative Processing of Allocation Cycles [Seite 207] and Cumulative Processing of Allocation Cycles.
   – The system displays whether quantities or transaction currencies are taken into account.
   – The system displays the defaulted selection criteria.

You can use the following additional functions on this screen:
- To display the segment overview of the segments contained within the cycle, choose .
- To search for segments that match your requirements, select .
- To display the first segment for the cycle, choose First segment.
Displaying Allocation Cycles

- To check whether all relevant entries have been made, choose 📋. Here, you can analyze the messages.
- To run cycles of an allocation type in parallel (assuming objects do not overlap) choose Goto → Cycle run group.
- To display change and execution history of the cycle, choose Extras → History.
Changing Allocation Cycles

Prerequisites
You created a cycle. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation → <Allocation type> → Change.

The Fl-SL: Display <Allocation Type>: Initial Screen appears.

Procedure
1. Make the following entries:
   - Ledger name
   - Name of allocation cycle

   Allocation cycles with the same name must have different starting dates. When allocation cycles have the same name, but different starting dates, the system views them as independent objects.
   - Start date of the allocation cycle

   The start date of the cycle is used for the following control reasons: The start date determines the earliest validity time of the cycle and you can define various versions for a cycle using different start dates. Allocations are only possible with a cycle valid in the posting period.


3. You can change the header data of the allocation cycle:
   - Iterative Processing of Allocation Cycles [Seite 207]
   - Cumulative Processing of Allocation Cycles [Seite 205]
   - Consider amounts or transaction currencies
   - Change selection criteria

You can use the following additional functions on this screen:
   - To display the segment overview of the segments contained within the cycle, choose .
   - To search for segments that match your requirements, select .
   - To display the first segment for the cycle, choose First segment.
   - To add a segment to the cycle, choose Attach segment.
   - To check whether all relevant entries have been made, choose . Here, you can analyze the messages.
   - To run cycles of an allocation type in parallel (assuming objects do not overlap) choose Goto → Cycle run group.
To display change and execution history of the cycle, choose Extras → History.
Deleting Allocation Cycles

Prerequisites
You created a cycle. Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation → <Allocation type> → Delete.
The Fi-SL: Delete <Allocation Type> :Initial Screen appears.

Procedure
2. Make the following entries:
   - Ledger name
   - Name of allocation cycle

   Allocation cycles with the same name must have different starting dates. When allocation cycles have the same name, but different starting dates, the system views them as independent objects.
   - Start date of the allocation cycle

   The start date of the cycle is used for the following control reasons: The start date determines the earliest validity time of the cycle and you can define various versions for a cycle using different start dates. Allocations are only possible with a cycle valid in the posting period.

3. Choose ✓. The system displays the Delete Cycle dialog box.

   You cannot restore a cycle once it has been deleted.
3. To delete the cycle, choose Yes.

Result
The system displays a message stating that the cycle has been deleted.
Executing Allocation Cycles

Use
You can execute the allocation cycle in two different ways:
• In online mode. Executing an Allocation Cycle Online [Seite 229]
• In batch mode. Defining an Allocation Job for Background Processing [Seite 231]

Line item records are always written to the database when an allocation cycle is executed.

Prerequisites
You created an allocation cycle. For more information, see Creating Allocation Cycles [Seite 201]

You selected Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation and then chose Actual/Plan Assessment or Actual/Plan Distribution → Create.

You can, though, also reach the screen for execution of allocation cycles this way:
• Actual posting → Actual closing → Actual assessment or Actual distribution → Create.
• Planning → Plan closing → Plan assessment or Plan distribution → Create.

The system displays the FI-SL: Execute <Allocation Type>: Initial Screen.

Features
a) Process control
With Process control, you can determine how the allocation cycle is carried out and which information is displayed by the system:

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process control → Background processing</td>
<td>Processing runs in the background.</td>
</tr>
<tr>
<td>Process control → Test run</td>
<td>The system only generates a log. No data is changed, no new data is written to the database.</td>
</tr>
<tr>
<td>Process control → Detail lists</td>
<td>List selection is prepared.</td>
</tr>
<tr>
<td>Process control → Detail lists → List selection</td>
<td>Basic list is configured. The sender and receiver list information and the journal information can be displayed.</td>
</tr>
</tbody>
</table>

b) Settings
Executing Allocation Cycles

You can use Settings to determine the functions that the system takes into consideration during execution. For more information, see Settings for Execution of Cycles [Seite 232].

c) Goto

Use Goto to display previous processing. For more information, see Displaying Previous Processing [Seite 249]. You can check whether an allocation cycle has already been processed for a ledger within a specific period.

d) Extras

- You can make currency settings. Select Extras → Value date, and enter the key that you use to define exchange rates in the system.
- You can determine the cumulation start period.

  This value specifies from which period the values are added up to calculate the tracing factors and the values to be allocated in the current processing period. Normally this is period 1. With the special purpose ledgers, the start period can also be zero.
- You can get/save/delete variants.
- You can display a cycle overview.

  You can get an overview of the current status of allocation execution with Selection criteria, cycle information, and previous processing.
- You can process allocation cycles.
- You can assign cycles to groups.

  To execute cycles of an allocation type in parallel, these have to be assigned to various cycle run groups.

e) Execute

After you have entered all relevant data and have made all appropriate settings, choose .

The Display <Allocation Type>: Basic List screen appears. Use the basic list to check the processing results.

For more information, see Displaying Allocation Results [Seite 236].
Executing an Allocation Cycle Online

Prerequisites

The system displays the *FI-SL: Execute <Allocation Type>: Initial Screen.*

Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic Processing → Allocation and then chose Actual/Plan Assessment or Actual/Plan Distribution → Create.

To assess/distribute data records, the company code or company has to be assigned to the ledger.

Procedure

1. Enter the *Ledger* and the relevant *Parameters*.
2. Under *Process control*, you have the following options:
   a. Set the *Background processing* indicator if you want to execute the allocation in background processing. For more information, see *Defining an Allocation Job for Background Processing* [Seite 231].
   b. Set the *Test run* indicator if you want to test the allocation.

     The allocation does not update the database.
   c. Set the *Detailed lists* indicator if you want to display a list of assessed/distributed records after the allocation is executed.
      - Choose *List selection*. The system displays a dialog box. The *Basic list* is defaulted.
      - In addition, there are three detail lists that you can select. For more information, see *Displaying Sender Lists* [Seite 244], *Displaying Receiver Lists* [Seite 245], and *Displaying Journals* [Seite 246]. You choose the list you require by selecting the appropriate indicator.

1. Enter relevant data for *Cycle* and *Start date* of the allocation, or choose input help. You can execute more than one cycle per execution.

   The order you execute the cycles impacts how the data is allocated.

   Receivers of allocation cycle 1 are cost centers 200 and 300. Receivers of allocation cycle 3 are cost centers 300, 400, and 500. The allocation cycle 3 uses the results of allocation cycle 1 if a group of cycles is executed.
Executing an Allocation Cycle Online

If you are executing a cycle that has the same name as another allocation cycle, the system displays all allocation cycles that have the same name, with the cycle starting dates.

2. You can determine how the system is to react when it encounters errors during execution by choosing Settings.

3. You can save the entries you make on the initial screen as a variant. To do so, choose Extras → Variant → Save and enter a name and a short text for the variant.

   To execute a particular variant, choose Extras → Variant → Get.

4. Choose 📊. The system displays the Fl-SL: Display <Allocation Type> Special Purpose Ledger Basic List screen. You can display all relevant information here.

   For more information, see Displaying Allocation Results [Seite 236].
Defining an Allocation Job for Background Processing

Use
You can run processing in the background so as not to place demands on the system in times of high load.

Prerequisites
The system displays the Fl-SL: Execute <Allocation Type>: Initial Screen.

Procedure
1. Enter data on the initial screen.
2. Under Process control, select the Background processing indicator.
3. Choose .
4. Enter the relevant print parameters.
5. Choose Continue.
6. The system displays a dialog box. Enter the job name in which the allocation cycles should be included and enter appropriate settings.
7. Choose .

Result
The system displays confirmation that the job has been scheduled.

For more information on how to define and execute a background job, see Working with R/3 → Getting Started with R/3 documentation in the SAP Library.
Settings for Execution of Cycles

Use
Select Settings to make technical settings.

Prerequisites
You have created an allocation cycle and are on the **Fi-SL: Execute <Allocation Type> : Initial Screen**. To be able to carry out the appropriate settings, you have to have entered (or selected) the ledger, the parameters, and the flow control.

Features

Display variant
You use this indicator to control how the results list is compiled. The following information is stored in a display variant:

- Column layout of the list
- Sort criteria
- Filter conditions

Database selection
You use this indicator to control how database access is to occur, in other words, how the data is selected from the database during allocation execution. The selected setting is only valid for the current cycle execution. However, you can save it as a variant. To save your settings permanently, choose . The following database selection methods are available:

  **Selection by cycle**
  For each dimension used in the cycle, the system determines the smallest and greatest value for this dimension in the entire cycle and uses this value interval as the basis for the database selection.
  Advantage: Database is accessed exactly once.
  Disadvantage: There is the risk that too many objects are selected. You have to eliminate the excess afterwards. The number of segments should not exceed 50.

  **Selection by segment**
  For each dimension used in the segment, the system determines the smallest and greatest value for this dimension in the entire segment and uses this value interval as the basis for the database selection.
  Advantage: Performance is good, as database selection with number of segments is virtually linear and no longer exponential.
  Disadvantage: Occasionally, the hit list is rather high.

Save extract
You can use this indicator to specify that reports are saved in extracts. The results lists are stored on the database after cycle execution (background processing/online). Enter a name for
the extract. The system will propose this name again if you wish to view the results lists via Goto → Extract management.

Flow trace on
You can use this indicator to define how data is selected from the database during the allocation execution. During execution of a cycle, the system logs all data relevant to error processing. You should activate this indicator if a cycle terminates with an error message or supplies erroneous results. It easier to identify errors when you are able to refer to runtime log data. You can call up this data in the system via the “Technical statistics” function. If you use background processing to process your cycle, the system generates a separate spool request that you are able to print out.

Runtime analysis on
You use this indicator to specify that runtimes of the various sections (database selection, iteration, and so on) are saved. If errors occurred during processing, you can display the runtime analysis for cycles and steps. You can then display this information on the Execution Screen via Goto → Runtime analysis. To save your settings permanently, choose .

Technical settings
You can specify the way that the system reacts when errors occur.

Exit program
The subsequent cycles displayed on the initial screen of the allocation are not processed, the program terminates.
You should set this indicator if the cycles build on each other and subsequent errors are to be expected.

Change to simulation mode
The subsequent cycles displayed on the allocation initial screen are processed. (“Change to simulation mode”).
You should set this indicator if cycles do not build upon each other and you wish to output all possible error sources in a program run for the defined allocation.
Reversing Allocation Cycles

Use
You should reverse an allocation cycle when:

- You have executed an allocation cycle in error (for example, if you execute an allocation cycle on the wrong date).
- You have executed an allocation cycle that contains errors (for example, if you execute an allocation cycle that contains a segment that uses the wrong dimension).

Procedure
You reverse allocations using the Execute function.

1. On the Execute <Allocation Type>: Initial Screen, enter data as required.
2. Choose <Allocation Type> → Reverse.
   
   The allocation cycle(s) has been reversed. The Display <Allocation Type>: Basic List screen appears.
3. On this screen, you can use the additional functions in the table for the Display <Allocation Type> Basic List in Executing an Allocation Cycle Online [Seite 229].

You can also reverse allocation cycles in background processing. For more information, see Defining an Allocation Job for Background Processing [Seite 231].
Deleting Allocation Line Items

Use
You can delete allocation line items that you no longer require in your system. You delete the line items per allocation cycle. You should delete allocation line items when:

- You have executed and subsequently reversed an allocation cycle. You can then delete the line items from the allocation runs that have been reversed.
- You want to create memory space on your database. The repeated execution and reversal of allocation cycles can take up considerable memory space. It is therefore recommended that you periodically delete the allocation line items that you no longer require.

Prerequisites
Choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic processing → Allocation → Delete line items.
The Allocation: Delete Line Items No Longer Needed screen appears.

Procedure
1. Make the following entries:
   - Ledger name of the allocation cycle(s)
   - Name of the allocation cycle for which you want to delete the allocation line items.
   - Name of a second allocation cycle if you want to delete line items for a range of allocation cycles.
2. Select Test run if you want to perform a test run of the deletion program.
   - The allocation line items are not deleted from the database.
3. Choose Program → Execute.

Result
The system deletes the line items for the allocation cycle(s) you entered on the previous screen.
If you set the Test run indicator, the system displays a list of allocation cycles for which you can delete line items.
Deleting Allocation Line Items

Displaying Allocation Results

Use
After the allocation is carried out, a basic list is output, that permits you to control and verify processing. The basic list specifies the number of senders, receivers, and messages for each allocation cycle that is executed.

Prerequisites
You have carried out an allocation.

Features
a) You are able to display the current status of allocation processing. For more information, see Displaying Cycle Overviews [Seite 238].

b) You can find out whether (and how many) errors occurred during cycle processing. For more information, see Displaying Messages [Seite 240].

You set as default the Runtime analysis on the initial screen under Settings.

c) From the line items, you can branch into the sender and receiver-side generated plan and actual line items. For more information, see Displaying Line Items [Seite 242].

d) You can also display a Segment list for each segment. For more information, see Displaying Segment Lists [Seite 243].

e) You can display sender lists, receiver lists, and journals. For more information, see Displaying Sender Lists [Seite 244], Displaying Receiver Lists [Seite 245], or Displaying Journals [Seite 246].

On the initial screen, under Detail list settings, you set the appropriate indicator.

f) You can display Technical Statistics, Expert Trace, and Divergence Analysis [Seite 247].

On the initial screen, under you set the appropriate indicator. You can only display divergence analysis with iteratively processed cycles.

g) You can display previous processing for the combination ledger, fiscal year, and period. For more information, see Displaying Previous Processing [Seite 249].

Activities
You can print out the following lists:

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>List → Print → Trace</td>
<td>Print contents of individual database fields of a particular cycle.</td>
</tr>
</tbody>
</table>
### Deleting Allocation Line Items

| List → Print → Journal | Print overview of the receivers, senders and corresponding values existing in a segment. |
| List → Print → Results lists | Print results of all cycles. |
| List → Print → Individual list | Print a particular cycle. |
Displaying Cycle Overviews

Use
You can display all relevant information pertaining to previous allocation cycles on one overview screen. You can select allocation cycles, choose cycle information, or previous processing, according to certain criteria on three tab pages.

Prerequisites
You have carried out several cycles and are on the FL-SL: Execute <Allocation Type>: Initial Screen.

Procedure
1. Choose Extras → Cycle → Display overview.
2. The system displays the Set Ledger dialog box. Enter the ledger name.
3. The system shows the Display Cycle Overview screen.

Selection Criteria
5. Choose Execute selection. The system displays the allocation cycles that meet your criteria in the structure tree.

To delete the selection criteria again, select Delete entries.

Cycle information
To display cycle information, you entered the desired allocation cycles under Additional selection criteria on the tab page under Selection criteria. You can display general information on the allocation cycle or process the allocation cycle from here. You can choose between sender and receiver information.

Previous processing
You can display executed or reversed allocation cycles as well as cycles with segment reversal.

For more information, see Displaying Allocation Results [Seite 236].
Displaying Standard Settings

Prerequisites
You have executed one or more cycles and are in one of the following result lists:

- Basic list
- Segment list
- Sender list
- Receiver list

You can return to the standard list settings if you have:

a) Entered your own display variant
b) Additionally created totals or subtotals
c) Hidden totals or subtotals

Procedure
To return to the standard list settings, choose Settings → Standard settings.
Displaying Messages

Use
You can display message to help analyze errors that occurred during the allocation run. If you wish, you can restrict display of messages to one cycle or one segment.

Prerequisites
Errors occurred during the allocation run. The system displays the errors in one of the following lists.

- **Basic list**
  The system displays the total number of errors in the *Number of messages* column of the Basic list, as well as in the basic list header. The system also displays an error message in the basic list header data.

- **Segment list**
  The system displays the number of messages for the errors that occurred in the allocation cycle in the corresponding segment list header data.

- **Sender list/receiver list**
  The number of messages for errors that occurred in a segment is displayed in the corresponding sender or receiver list header data.

Procedure
**Display all messages** as follows:
- Click on the number of errors in the *Disp messages* row of the basic list header data.
- From one of the other lists, choose Goto → *Messages* → *Selection*.

**Display all messages of a cycle** as follows:
- Click on the number of errors in the *Disp messages* row of the basic list header data.
- In the segment list, choose Goto → *Messages* → *Selection*.
- Position your cursor in the basic list on the cycle and choose Goto → *Messages* → *Select*.

**Display all messages of a segment** as follows:
- In sender or receiver list header data, select the *No. of errors*.
- In the sender or receiver list, choose Goto → *Messages* → *Selection*.

1. The system displays a dialog box for display of messages.
2. To display more information on an error, either select the message by double-clicking it, or position your cursor on the message and choose 📔.
3. Choose 🚪 to leave the dialog box.
Result
You can analyze errors. You can redefine the cycles in accordance with the message and then execute the allocation again.

If the message analysis is not sufficient, repeat the allocation and create a runtime log. To do this, select *Runtime log* in the dialog box via *Settings*. 
Displaying Line Items

Prerequisites
You are displaying one of the following results lists:
- Basic list
- Segment list
- Sender list
- Receiver list

Procedure
1. To branch to the line item display with sender- and receiver-side generated plan or actual line items, position your cursor:
   - In the basic list on an allocation cycle
   - In the segment list on a segment
   - In the sender list on a sender
   - In the receiver list on a receiver
2. Select or double-click on the appropriate line.

Result
The system displays the Ledger <Ledger Name> Display of All Data Records and Key ... screen.

Here, you can continue to process the line items.
Displaying Segment Lists

Prerequisites

You are on the Fl-SL: Display <Allocation Type>: Special Purpose Ledger screen.

- Basic list
- Sender list
- Receiver list

Procedure

1. To display the segment list, position your cursor:
   - In the basic list on an allocation cycle
   - In the sender list on a sender
   - In the receiver list on a receiver

2. Choose Segment.

   The segment list displays the segments for the selected cycle, sender, or receiver.

   The system displays the following information on a segment:
   - g lock indicator (segment not included in processing)
   - U invalid indicator (an error arose during processing)
   - Sender rules and receiver rules
   - Number of senders and receivers
   - Number of messages

3. To hide fields, choose Current display variant.

4. From the segment list, you can (per segment) branch to the:
   - Basic list
   - Sender list
   - Receiver list
   - Line items

For more information, see Displaying Allocation Results [Seite 236].
Displaying Sender Lists

Prerequisites
On the initial screen in List selection, you selected Sender and Receiver.

Procedure
You can call up the sender list from the basic list, segment list, or receiver list.

1. To display the sender list, position your cursor:
   – In the basic list on an allocation cycle
   – In the segment list on a segment
   – In the receiver list on a sender

2. Choose Sender.
   The sender list displays the senders for the selected cycle or segment. The system displays the following information on a sender:
   – The invalid indicator (an error arose during processing)
   – The posted amounts

3. To display the amounts in object currency or the sender base, choose Current display variant.

4. From the sender list, you can (per sender) branch to the following lists: Choose:
   – Basic list
   – Segments
   – Receiver
   – Line items

For more information, see Displaying Allocation Results [Seite 236].
Displaying Receiver Lists

Prerequisites

On the initial screen in List selection, you selected Sender and Receiver.

Procedure

You can call up the sender list from the basic list, segment list, or receiver list.

1. To display the receiver list position your cursor:
   - In the basic list on an allocation cycle
   - In the segment list on a segment
   - In the sender list on a sender

2. Choose 📅.

   The receiver list displays the receivers for the selected cycle, segment or sender. The system displays the following information on a receiver:
   - The invalid indicator (an error arose during processing)
   - The posted amounts

   If you call up the receiver list from the sender list, the system displays the tracing factor in place of the allocated amounts and the currency. The amounts allocated to the receiver do not have to originate from the same sender for which the sender list is generated.

3. To display the amounts in object currency, or the receiver tracing factor and the receiver weighting factor, choose 📅 Current display variant.

   You cannot display any values when you call up the receiver list from the sender list. The only extra field available is the Factor.

4. From the receiver list, you can (per sender) branch to the following lists. Choose:
   - Basic list
   - 📉 Segments
   - 📉 Line items

   For more information, see Displaying Allocation Results [Seite 236].
Displaying Journals

Use
The journal offers you an overview of the receivers, senders and corresponding values existing in a segment.

The journal is especially suited for the analysis of allocated values for iterative segment processing.

Prerequisites
To display the journal, you must first select Journal on the initial screen (under List selection).

You can only call up the journal from the basic list.

Procedure
1. To display the journal, choose Journal in the basic list.
   For all segments in the cycle, the journal displays:
   - The determined sender values
   - The allocated sender values
   - The allocated receiver values
2. To display the amounts in object currency, the sender or receiver tracing factor, choose Current display variant.
3. To return to the basic list, choose Basic list.

For more information, see Displaying Allocation Results [Seite 236].
Technical Statistics, Expert Trace, and Divergence Analysis

Use
If errors have occurred during processing of the allocation cycle, the technical statistics, expert trace and divergence analysis let you analyze those errors that you cannot solve using the system messages.

The technical statistics and the divergence analysis enable user analysis. The expert trace requires analysis by experts.

Prerequisites
Before you executed the cycle, you selected Flow trace on in the dialog box via Settings.

In addition, divergence analysis requires that:
a) You use a cycle with iterative sender/receiver relationships
b) These relationships are taken into account when you execute the cycle
c) An error occurred that led to a divergence

Procedure
Displaying Technical Statistics
1. To execute an error analysis using technical statistics, in the periodic allocation basic list choose (Technical statistics) or Tools → Technical statistics. The system displays all relevant information in a tree structure (trace function).
2. The following functions let you change the tree structure display:
a) Expand
   To expand the tree structure or a subtree, position your cursor on the appropriate node and choose Expand.
b) Collapse
   To collapse the tree structure or a subtree, position your cursor on the appropriate node and choose Collapse.
c) Position...
   To reach a particular point in the tree structure, position your cursor on the appropriate node and choose Position.
d) Set focus
   To display only a subtree, position your cursor on the appropriate node and choose Set focus. To display the higher subtrees once again, click on the cycle named in the first row.
Technical Statistics, Expert Trace, and Divergence Analysis

**Displaying the Expert Trace**

1. To display the expert trace, choose *Tools* → *Expert trace*.
2. The *Display <Allocation Type>: Special Purpose Ledger Trace Function* screen appears.
3. Choose the required information.
4. Position the cursor on the cycle for which you require information.
5. Select ✏️ to view information on the contents of the individual database fields.
6. To return to the basic list, choose *Basic list*.

**Displaying Divergence Analysis**

To analyze divergences occurring for cycles with iterative sender/receiver relationships, choose *Tools* → *Divergence analysis*.

For more information, see *Displaying Allocation Results [Seite 236]*.
Displaying Previous Processing

Use
You can display an overview of processed allocation cycles for a certain combination of ledger, fiscal year, and period. This function is helpful when you want to see if an allocation cycle has already been processed for a particular ledger within a specific period and fiscal year.

Prerequisites
The system displays the FL-SL: Execute <Allocation Type>: Initial Screen.

Procedure
1. Choose Goto → Previous processing.
2. The <Allocation Type> Overview: Initial Screen appears.
3. Enter data as required.
4. Choose .
5. The system displays the <Allocation Type> Overview: Basic List screen.

Result
The system displays a list of processed allocation cycles. To display the document list, choose .

For more information, see Displaying Allocation Results [Seite 236].
Printing Detail Lists

Use

- You can print individual lists from the following lists:
  - Basic list
  - Segment list
  - Sender list
  - Receiver list
  - Journal list
- You can only print results lists from the basic list. The results lists contain:
  - Basic list
  - All segment lists
  - All sender lists for all periods
  - All receiver lists for all periods

Prerequisites

If you selected Journal under List selection on the initial screen, you can also print the journal from the basic list. For more information, see Displaying Journals [Seite 246].

On the initial screen, if you selected Flow trace on you can also print the expert trace from the basic list. For more information, see Technical Statistics, Expert Trace, and Divergence Analysis [Seite 247].

Procedure

1. To print the relevant list, choose:
   - List → Print trace
   - List → Print journal
   - List → Print results list
   - List → Print individual list
2. Choose User-specific print parameters and enter the appropriate data.
3. Choose Continue.

Result

The system confirms that printing was carried out.
Rollup

Purpose
A rollup [Extern] is used to determine how data is "rolled up" (i.e. summarized) from several source ledgers into a single rollup ledger. Since you can use several different ledgers in FI-SL, you can have different levels of detail and/or different dimensions. Some ledgers may contain too much detailed information or irrelevant dimensions for some cumulative reports; you can summarize this information in a rollup ledger.

Implementation Considerations
If you only want to run a report once, it is more efficient for the Report Writer to summarize the data. However, if you must select the same data for your report more than once, the report data should be summarized in a rollup ledger. You can use rollup ledgers to improve system performance when you are creating reports.

Integration
With the rollup, you can process data both from other SAP application components as well as from external systems. A rollup ledger is the summarization of information from one or more ledgers (source ledgers) into a single ledger. The following graphic shows the data from several source ledgers being summarized in one rollup ledger.

To summarize data in a rollup ledger, you have to define a rollup. Before you can create a rollup, you must first define a ledger as a rollup ledger. In Customizing for Special Purpose Ledger, you
Rollup

activate the Rollup allowed indicator in the ledger definition to define whether you can rollup data into the ledger. For more information about defining ledgers and ledger classes, see the Implementation Guide (IMG) under Special Ledger → Basic Settings → Master Data → Maintain Ledger.

Features

You can use sets in rollups [Seite 254].

With field movement [Seite 257], you can define which fields are to be transferred from a sender table to an FI-SL receiver table.

You can also define whether a rollup should update the line item database [Seite 260].

By defining the rollup type [Seite 261], you define how the data is to be summarized.

You can use user exits [Seite 263] to call up other programs.

Using Application Link Enabling (ALE) and IDoc, you can transfer FI-SL ledger data across separate SAP systems [Seite 264].

You can drill down to data in rollup line items [Seite 266] in the source ledger.

When you create a rollup [Seite 272] (rollup header and rollup sequence), you define how data is to be selected from the sender table, summarized in the rollup and posted to the receiver table.

For more information, see:

- Creating a Rollup Header for a Standard Rollup [Seite 273]
- Creating a Rollup Header for a Hierarchy Rollup [Seite 273]
- Creating a Rollup Header for an Export Rollup [Seite 273]
- Creating a Rollup Sequence [Seite 283]

You can check [Seite 290], document [Seite 291], display [Seite 292], change [Seite 301] and reverse [Seite 294] and execute [Seite 296] the rollup. You can also execute a rollup in the background [Seite 293].

Example

If you want to create a report that only uses account data from a source ledger containing 100 different accounts and 100 different cost centers for each account, the system has to read at least 10,000 totals records (100 accounts * 100 cost centers). This report would take an extremely long time to process. To improve system performance, you can summarize the account data from the source ledger(s) into a rollup ledger that contains only 100 totals records (one totals record for each account). The rollup summarizes the cost center values for each account into one totals record for all cost centers.
To roll up data into FI-LC, the companies into which data is rolled must have the data transfer indicator 0 (rollup from FI-SL; you set this indicator in FI-LC Customizing). For more information about setting these parameters in Customizing, see the Implementation Guide for Special Purpose Ledger.
Sets and Rollups

Use
You have the option of using sets [Extern] in rollups. These select data for a rollup ledger, to
rollup data based on a hierarchical set definition, and to select data to be reset to zero. You can
use the following types of sets:
• Basic sets
• Single dimension sets
• Multi-dimension sets
You can use sets in the following rollup components:
• Rollup header, as rollup sets or reset sets
• Rollup sequences, as rollup sequence sets

You can also use value variables in your rollup header, sequence, and reset sets, as
well as set variables in your rollup sets.

When you use a set variable and/or value variable in a rollup, the system will prompt
you to enter information for the variable when you execute the rollup.

Features

Rollup Sets
The rollup set values apply to all sequences within the rollup.

A rollup header set is always a multi-dimension set and must contain the following
dimensions:
• Ledger
• Record type
• Version
• Company code or company (local or global)
You cannot use the following dimensions in your rollup header set:
• Client
• Period
• Year

Your multi-dimension header set can include basic and/or single-dimension sets.
You can define a multi-dimension set that contains the following values:
  - Ledger 01 (dimension Ledger)
  - Record Type 0 (dimension Record Type)
  - Version 001 (dimension Version)
  - Companies 1000 and 1001 (dimension Company)
  - Fixed Asset Accounts 500000-501000 (dimension Account)

You can enter the name of the multi-dimension reset set in the rollup header. When the system processes the rollup, fixed asset accounts 500000-501000 for ledger 01, record type 0, version 001, and companies 1000 and 1001 will be rolled up according to the field movement information you enter for the rollup.

If you want to create a hierarchical rollup, you include your cost center and/or business area hierarchy in the rollup header set (single-dimension set).

For more information, see Types of Rollups [Seite 261].

**Rollup Sequence Sets**

A rollup sequence set can be defined per sequence. The values you define in a rollup sequence set determine which data for a specific sequence will be rolled up.

The rollup header set determines the data that is selected for all sequences, and the rollup sequence set further defines the data to be selected for the specific rollup sequence. You can create a basic set that contains only the fixed asset accounts 500000-500020 (dimension Account). You can then enter the set name in the rollup sequence and enter a specific field movement and substitution activity for the sequence. In this case, the system will roll up accounts 500000-500020 only for ledger 01, record type 0, version 001, and companies 1000 and 1001 in the appropriate sequence according to the field movement information you enter for the rollup.

**Reset Sets**

A reset set is used to select data fields from a rollup ledger and reset the data fields to zero before the rollup is executed.

A rollup reset set is a multi-dimension set and must contain the following dimensions:

- Ledger
- Record type
- Version
- Company code or company (local or global)
Features

You cannot use the following dimensions in your rollup reset set:

- Client
- Period
- Year

Your multi-dimension reset set can include basic and/or single-dimension sets.

You can define a multi-dimension set that contains the following values:

- Ledger 01 (dimension Ledger)
- Record Type 0 (dimension Record Type)
- Version 001 (dimension Version)
- Companies 1000 and 1001 (dimension Company)
- Fixed Asset Accounts 500000-501000 (dimension Account)

You can enter the name of the multi-dimension reset set in the rollup header. When the system processes the rollup, the data records for fixed asset accounts 500000-501000 for ledger 01, record type 0, version 001, and companies 1000 and 1001 will be reset to zero before the rollup is executed.

You can find more information on creating sets under Creating Sets [Seite 651].
Field Movements and Rollups

Use

Field movement [Seite 257] defines which fields are to be transferred from a sender table to an FI-SL receiver table. There are two types of field movement:

**Fixed field movement**

When you execute a rollup, the data from the following dimensions is automatically transferred from the source ledger(s) into the dimensions in the rollup ledger:

- Ledger
- Record type
- Version
- Company code or company (local or global)
- Transaction currency (depending on the rollup ledger definition)
- Unit of measure (depending on the rollup ledger definition)
- Debit/credit indicator (depending on the rollup ledger definition)

The data in dimensions Year and Period is determined by the period definition of the rollup ledger.

For further information, see Customizing, under Special Ledger → Basic Settings → Maintain Fixed Field Movement.

**Variable Field Movement**

If you want to include other dimensions in your rollup ledger, such as account, cost center or business area, you have to define a field movement for these dimensions.

For further information, see the Implementation Guide (IMG), under Special Ledger → Basic Settings → Master Date → Maintain Field Movement.

The following fields are defined in field movement

- **Sender fields**: Dimensions in the source ledger(s).
- **Receiver fields**: Dimensions in the rollup ledger.

The following graphic shows a simple field movement example. The dimensions Account, Cost Center, and Business Area are transferred from the source ledger to the rollup ledger.
Field Movements and Rollups

In this example, the data from the dimensions Account, Cost Center, and Business Area, is transferred to the rollup ledger according to field movement rule WXYZ.

When field movements are not defined for dimensions, the data for those dimensions is summarized within the dimensions that have defined field movements but the dimensions themselves are not transferred to the rollup ledger.

If you selected data for the dimensions Cost Center and Account, but you have only defined a field movement for the dimension Account, then the data for the selected cost centers is summarized and included in the data for the dimension Account.

Field Movement Rule

Using the field movement rule, you define how dimensions are taken over into the rollup ledger.

If you want to take over all of your data on a one-to-one basis, you must define all of your dimensions in the rollup field movement.

When you define your field movements, you can also define a field movement so that a dimension from the sender table is transferred to a receiver dimension in the line item database, even though the dimension does not exist in the receiver summary table.

You define a field movement as follows:

- **Sender:** Table GLT1, Dimension Account
- **Receiver:** Table GLT1, Dimension Original Account

  The dimension Original Account does not exist in the summary table GLT1; however, the dimension could be defined in the data part of the line item database GLS1 that corresponds to the summary table GLT1. In this case, the dimension Account would be transferred to the dimension Original Account only in table GLS1.

For more information about creating field movements in Customizing, see the *Maintain Field Movement*. 

---

**Field movement rule: WXYZ**

<table>
<thead>
<tr>
<th>Dimension</th>
<th>From field (table)</th>
<th>To field (table)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>RACCT (GLT1)</td>
<td>RACCT (GLT1)</td>
</tr>
<tr>
<td>Cost center</td>
<td>RCNTR (GLT1)</td>
<td>RCNTR (GLT1)</td>
</tr>
<tr>
<td>Bus.area</td>
<td>RBUSA (GLT1)</td>
<td>RBUSA (GLT1)</td>
</tr>
</tbody>
</table>
Field Movements and Substitution Activities

You can assign a substitution activity [Extern] to each field movement.

When defining a field grouping code for a rollup, you can assign a substitution activity code to a field movement. A substitution activity code identifies a substitution activity; a substitution activity transfers substituted data to receiver dimensions during the rollup process.

If you want to summarize a group of products under a product group, you can define a substitution activity that substitutes the product group for the products during the rollup process. You enter the substitution activity code for the substitution activity in the field movement.

If you are using substitution rules, you can define more than one substitution value for a substitution activity.

For more information, see Entering Substitution Activities [Seite 287] and the Implementation Guide (IMG) under Special Ledger → Basic Settings → Substitution.
Line Item Database and Rollups

Use

You can also define whether a rollup should update the line item database. If a rollup updates the line item database, a line item is written for each record that is rolled up.

When line items have been written to the line item database for a rollup, you can reverse the rollup.

Using rollup line items, you can also drill down from the summary rollup data to the original data stored in the source ledger. In the following steps, you can define whether a rollup should update the line item database.

Creating a Rollup Header [Seite 273]
Execute Rollup [Seite 296]

The line item update information you entered in the rollup header is proposed as a default when you execute a rollup.

If line items are not created, you cannot reverse the rollup.

If you do not plan to reverse the rollup (or if you are rolling up large quantities of data), you should leave the Write line items indicator blank to avoid unnecessary database updates. Line item updates are only useful in exceptional cases and slow down processing dramatically. For the reasons listed below, line item updates are not normally necessary:

- They can overwrite existing data
- They can reset data

For more information, see Creating a Standard Rollup Header [Seite 273] and Drilling Down to Rollup Line Items [Seite 266].

To post line item data for rollups, you must install a line item database for your 1) actual rollup data, and 2) plan rollup data. For more information about installing line item databases, see the Implementation Guide (IMG) for Special Ledger.
Types of Rollups

Use
By defining the rollup type, you define how the data is to be summarized. You can choose between the following rollup types:

- Standard Rollup
- Hierarchical Rollup
- Export Rollup

Standard Rollup
In a standard rollup, you rollup data from one or more sender ledgers into one or more rollup ledgers, using one or more rollup sequences. To do this, you proceed as follows:

1. Leave fields blank in field movement
2. Substitute certain fields

Hierarchical Rollup
With a hierarchical rollup, you can summarize data from bottom to top from a source ledger, in accordance with a hierarchy structure of your choosing (such as a cost center hierarchy). In a hierarchical rollup, you rollup data according to the structure of the single-dimension set defined in your rollup header set.

Export Rollup
An export rollup is used to transfer data from local systems to a central system. You can transfer data in either unsummarized or summarized form (using field movement) and update it in the central system.

Special Periods

You can also roll up data for special periods (for example, 13 through 16) when you execute and/or reverse a rollup. For further information, see Special Periods and Rollup [Seite 262].
Special Periods and Rollups

Use
You have the option of summarizing data for special periods (such as 13 to 16). If you set this flag, the system will roll up or delete all existing special periods for the fiscal years defined by the execution period.

Procedure
2. Enter the special periods (From period field, To period field) which you want to be used when executing/reversing the rollup.
3. Choose 📊.

Result
The Execute Rollup: Statistics screen appears. Here, you can see the statistics for the rollups.

If the fiscal year variants are different in the source ledger(s) and rollup ledger, you cannot rollup/reverse a specific special period(s).

Instead, you can either rollup/reverse all or none of the special periods (Special periods indicator).

For example, source ledger 01 has twelve posting periods and rollup ledger R1 has four posting periods.

For more information about setting the fiscal year variant for a ledger/local company or ledger/global company combination, see the Implementation Guide (IMG) for Special Purpose Ledger.
User Exits and Rollups

Use

A user exit is a three character code that instructs the system to access a program during system processing. You can use the following user exits in rollups:

Exit in rollup header

You enter this user exit in the User exit field on the Create Rollup <Name>: Header screen. The system accesses the user exit after it has filled the internal tables for executing the rollup. At this point, you can process general validations, for example, to check the period interval for the rollup.

Field movement header table, exit 1

You enter this user exit in the User exit after selection field on the Change Field Movement: Data screen. The system uses this exit to further define the conditions for selecting data to be rolled up.

Field movement header table, exit 2

You enter this user exit in the User exit before update field on the Change Field Movement: Data screen. The system accesses the user exit after the receiver records have been completely created. The user exit is only used to process data field substitutions.

Exit in field movements/substitution activities

You enter this user exit in the Exit field on the Change Field Movement: Data screen or the User exit field on the Change View “Rollup Substitution”: Overview screen. (Both exits perform the same function.) This user exit can be used to perform key field substitutions. The system accesses the user exit when the specific dimension is moved from the sender to the receiver.

Enter user exits in the following formats:

SXX:  S is for standard exits that are delivered by SAP. XX represents the 2-digit exit number.

UXX:  U is for user exits that are defined by the user. XX represents the 2-digit exit number.

Standard user exits delivered by SAP are stored in program RGLVS000.

You can define your own user exit programs. If you create a user exit program, this program name must be defined in the table for client-dependent user exits (table T80D) in Customizing. For more information, see the Maintain Client-Dependent User Exits step in the Implementation Guide (IMG) for Special Purpose Ledger.
Using FI-SL on Distributed Systems

**Use**

Using Application Link Enabling [Extern] (ALE) and IDoc, you can transfer FI-SL ledger data across separate SAP systems. Using an export rollup, you can distribute ledger data from a local system to a central system.

Advantages of using FI-SL on distributed systems include:

- Ability to export data as often as necessary within a period, since the buffer memory is handled via the export rollup.
- Transferred data volumes are not extensive since only total records are transferred.

The FI-SL database table that you distribute must have the same name and the same basic structure in all systems. However, you can define the table structure in the central system so that it contains fewer fields than in the local systems, because the central system may not need to store all detailed information. Nevertheless, table definitions should **not** be too different.

Also, the Customizing settings for the ledgers and local or global companies that are to be distributed must be identical to ensure data consistency.

**Procedure**

To distribute ledger data from a local system to a central system, you:

1. **Define a distribution model.**
   
   The distribution model determines to which logical system (central system) the ledger data is to be distributed. You define the logical system either at ledger level or at ledger–local company/ledger–global company level. Once the logical system is defined, all local systems are informed that this is the logical system to which they must send their data.

   You define a distribution model in ALE Customizing (Cross-Application Components → Distribution (ALE) → Distribution customer model).

2. **Define an error workflow in the central system.**

   The error workflow is used to detect and process any errors that occur when the FI-SL data is transferred to the central system.

   You define workflows using the Make basic settings for Workflow step in ALE Customizing (Cross-Application Components → Distribution (ALE) → Basic configuration).

3. **Update the field assignment table EDIMAP in the central system.**

   The EDIMAP table must be updated in order to export data from a local system to a central system. This table determines the assignment of the field(s) in the FI-SL database table to the field(s) in the data transfer structure (IDoc field).
You update the EDIMAP table using the Update Assignment Table EDIMAP step in FI-SL Customizing (Financial Accounting → Special Purpose Ledger → Tools → Distribution (ALE)).

4. Generate the export and import programs.

   The export and import programs must be generated in both the central system and all local systems.

   You generate these programs using the Generate Import/Export Programs step in FI-SL Customizing (Financial Accounting → Special Purpose Ledger → Tools → Distribution (ALE)).

5. Define an export ledger in the local system(s).

   If the data of a FI-SL ledger is to be sent to a central system, you must assign an export ledger to the FI-SL ledger.

   The export ledger stores the balances of all previous data transfers. If you export data more than once within one period, only the difference amounts from the last data transfer are sent to the central system.

   You define export ledgers using the Maintain Ledgers step in FI-SL Customizing (Financial Accounting → Special Purpose Ledger → Basic Settings → Master Data).

6. Create an export rollup in the local system(s).

   When you create the export rollup, you determine how data should be transferred from the local system to the central system. You can transfer data on a one-to-one basis or summarize data using a user-defined field movement.

   For more information, see Creating a Rollup [Seite 272].

7. Execute the export rollup in the local system(s).

   When you execute the rollup, the data is posted to the central system, which is defined in the distribution model, according to the criteria you have defined in the export rollup. You can execute the export rollup as often as you want within a period, since only difference amounts from the last data transfer are exported. The export ledger stores all data amounts that have been transferred.

   For more information, see Executing a Rollup [Seite 296].
Carrying out Drill Downs on Rollup Line Items

Use
You have the option of carrying out a drilldown to the rollup line item data in the source ledger. You do this using a Report Writer report that you define for the rollup ledger.

⚠️ With larger data quantities, this function causes a huge increase in processing time. If you set the Write line items indicator, the system writes line items to the line item database.

If you do not plan to reverse the rollup or drill down to rollup line items in a report created for the rollup ledger (or if you are rolling up large quantities of data), you should leave the Write line items indicator blank to avoid unnecessary database updates and increased runtime.

Procedure
1. Define and install rollup line item tables.

   Data of the source ledger is saved in special rollup line item tables. It is not currently possible to automatically install these tables using the FI-SL Define Table Group functions. You should copy the standard example tables delivered with your system (GLREFU: rollup actual line item table and GLREFV: rollup plan line item table), and modify them according to your requirements.

   For more information about installing rollup line item tables, see the Implementation Guide (IMG) for Special Purpose Ledger.

2. Write line item records when you execute the rollup.

   To display the original data, line item records, which contain the original data, must be written when the rollup is executed. If no line item records are updated, the drilldown report will display incorrect data.

   To update rollup line items, set the Write line items indicator in the rollup definition (Processing optn indicator).

   For more information, see Creating Rollups [Seite 272].

3. Create the rollup report and the drill-down report.

   For more information, see Creating a Report Painter Report [Seite 811].

   To carry out the drilldown, use the Call up report function. You must therefore define the drilldown report as a receiver report in the rollup report’s report group. The drilldown report is called up via the report/report interface when you select an area of data in the rollup report.

   🔷 The drill-down report is similar to a standard line item report, but you can only use data set entries defined for the rollup line item tables when you create the report (for example, RBHSL-0 for rollup documents in local currency for actual data).
Carrying out Drill Downs on Rollup Line Items

For more information on using the Call up report function, see Functions in the Report Output [Seite 974]

It is not currently possible to drill down to both actual and plan data in a rollup report. You must therefore define two separate reports for displaying actual and plan rollup line items.

The rollup line items are only relevant for rollups and the Report Writer. You cannot therefore display rollup line items using the summary record and document display functions.

The reversal function can be used both with the ‘normal’ line item tables and with the special rollup line item tables. When writing line item records, the system checks if rollup line item tables are defined. If so, the line item records are written to these tables. If no rollup line item tables are defined, the line item records are written to the ‘normal’ line item tables.

Example

The accounts 101000, 102000 and 103000 are summarized into account 100000 using a rollup. A Report Writer report is defined for the rollup ledger. Data for account 100000 is output in this report after the report group is carried out.

Using the drilldown function, you can display the original posted data that makes up the total for account 100000.

If the following graphic, you can see the drill down report for account 100000. The report contains the data of the source ledger for accounts 101000, 102000, and 103000.

In the report for the rollup ledger, the data for accounts 101000, 102000 and 103000 is summarized and substituted into account 100000 and the cost center data is summarized and included in the records for the accounts.
### Carrying out Drill Downs on Rollup Line Items

**Report Writer Report for Rollup Ledger**

<table>
<thead>
<tr>
<th>Accounts/Totals</th>
<th>ACTUAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>10000.00</td>
</tr>
<tr>
<td>Account 100000</td>
<td>1000.00</td>
</tr>
<tr>
<td>Account 200000</td>
<td>2000.00</td>
</tr>
<tr>
<td>Account 300000</td>
<td>5000.00</td>
</tr>
<tr>
<td>Account 400000</td>
<td>2000.00</td>
</tr>
</tbody>
</table>

**Drilldown Report for Account 100000**

<table>
<thead>
<tr>
<th>Accounts/Line Items</th>
<th>ACTUAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account 100000</td>
<td>1000.00</td>
</tr>
<tr>
<td>Cost center 100</td>
<td>500.00</td>
</tr>
<tr>
<td>Account 101000</td>
<td></td>
</tr>
<tr>
<td>Cost center 100</td>
<td>300.00</td>
</tr>
<tr>
<td>Account 102000</td>
<td></td>
</tr>
<tr>
<td>Cost center 200</td>
<td>200.00</td>
</tr>
<tr>
<td>Account 103000</td>
<td></td>
</tr>
<tr>
<td>Cost center 300</td>
<td>200.00</td>
</tr>
</tbody>
</table>
Defining Rollups

Use
By defining the rollup, you define how data is to be summarized from one or more source ledgers to one or more rollup ledgers. This means defining the rollup type, rollup header and rollup sequence.

Rollup Type
By defining the rollup type [Seite 261], you define how the data is to be summarized. You can choose between the following rollup types:

Standard
In a standard rollup, you rollup data into one or more rollup ledgers, using rollup sequence(s) and sender ledger(s). You do this by leaving fields empty for field movement and by substituting certain fields.

Hierarchy
In a hierarchical rollup, you rollup data according to the structure of the single-dimension set defined in your rollup header set.

Export
An export rollup is used to transfer data from local systems to a central system. For further information on export rollups, see FI-SL and Distributed Systems [Seite 264]. The rollup header contains cross-sequence information that is relevant for all rollup sequences. You have to define a rollup header in accordance with the type of rollup you have chosen.

Rollup sequences
The rollup sequences are the basic units of rollups. You can use them to carry out several actions within one rollup. By using sequences, you avoid having to create and execute separate rollups when you want to execute a series of different actions. Each rollup sequence contains information such as the sequence set, a rule for selecting data, the field grouping code, and the ledger.
Overview: Executing Rollups

Use
Rollups allow you to store commonly-used data in a summarized form, depending on the level of detail you require. By using rollups, you can achieve a significant reduction in processing time.

Procedure
1. Define a rollup ledger.
   The rollup ledger receives summarized data from one or more source ledgers and must be defined before you can define a rollup. You must activate the Rollup allowed indicator in Customizing for Special Purpose Ledger if you want to define a ledger as a rollup ledger.
   For more information about defining a ledger, see the Maintain Ledgers step in the Implementation Guide (IMG) for Special Purpose Ledger.

2. Create field movements and substitution activities.
   Before you create a rollup, you must define a field grouping code that contains field movements. Field movements determine which dimensions from the source ledger(s) are transferred to the rollup ledger.
   If you want to substitute data being transferred from the source ledger(s) to the rollup ledger, you need to create a substitution activity and enter a substitution activity code as part of the field movement. You enter the field movement code in each rollup action sequence you define.
   For more information, see Field Movements and Rollups [Seite 257].
   You can create field movements and substitution activities in Customizing. Detailed procedures for creating field movements and substitution activities in Customizing are described in the Maintain Field Movements and Maintain Substitution steps in the Implementation Guide (IMG) for Special Purpose Ledger.

3. Create sets.
   Before you define a rollup, you must create sets for the rollup. The header set used in a rollup determines the data to be summarized into a rollup ledger, and the reset set determines the data fields in the rollup ledger to be reset to zero. The sequence set restricts the data to be processed for the respective rollup sequence.
   For more information, see Sets and Rollups [Seite 254] and Creating Sets, [Seite 651]
   You can find more information on creating sets under Set Creation [Seite 651].

4. Create the rollup.
   You create an allocation cycle in the following steps:
   a) Create the rollup and choose a rollup type
   b) Define the rollup header.
   b) Define the rollup sequences (for standard rollups).
   c) Enter the field movement information.
For more information, see Creating Rollups [Seite 272].

5. **Verify the rollup.**
   After you have created a rollup, you can use the *Check rollup* function to check for any errors in your rollup definition.
   For more information, see Checking Rollups [Seite 290].

6. **Document your rollup.**
   If you want to print a detailed listing of your rollup definition and statistics, you can use the *Document rollup* function.
   For more information, see Documenting Rollups [Seite 291].

7. **Execute the rollup.**
   To execute a rollup, you use the *Execute* function.
   For more information, see Executing Rollups [Seite 296].

8. **Reverse a rollup, if desired.**
   If you want to reverse a rollup, you use the *Reverse* function. Reversing a rollup is different from resetting data with a reset set. When you reverse a rollup the system creates reversing documents that offset the original line items. When you reset data with a reset set, the system resets selected data fields to zero but does not create any new documents. Refer to the online documentation for the *Write line items* field for further information.
   For more information, see Reversing Rollups [Seite 294].

9. **Execute or reverse a rollup in background processing.**
   If executing or reversing your rollup involves large amounts of data and requires a long processing time, you should execute or reverse your rollup in background processing.
   For more information, see Defining Rollups for Background Processing [Seite 293].
Creating Rollups

Use
Using the Rollup function, you can summarize information from one or more source ledgers into a rollup ledger(s). To do so, you have to define the rollup.

Procedure
2. Enter a name for the rollup.
3. Choose a rollup type.
4. Choose . The Create Rollup <Name>: Header screen appears. Various entry fields can now appear, depending on the rollup type you have chosen.
5. If you want to use an existing rollup as a template, enter the name of a rollup you have previously defined and choose . The Create Rollup <Name>: Header screen appears. The fields are filled with data from the template.

Result
By defining the rollup type, you have defined the first part of the rollup. You are now in the Create Rollup <Name>: Header screen. Here, you create the rollup header.

Creating Rollup Headers for Standard Rollups [Seite 273]
Creating Rollup Headers for Hierarchy Rollups [Seite 277]
Creating Rollup Headers for Export Rollups [Seite 281]
Creating Rollup Sequences [Seite 283]
Maintaining Field Movement [Seite 285]
Entering Substitution Activities [Seite 287]
Creating Rollup Headers for Standard Rollups

Use
The rollup header contains information that is valid for the entire rollup. With a standard rollup, you can rollup data up into one or more rollup ledgers. To do so, you use one or more rollup sequences.

Prerequisites
On the Create Rollup initial screen, you have flagged the rollup type standard and chosen .

Procedure
1. Under Title, enter a name for you rollup.
2. If you want to require that a user have authorization for creating, displaying, maintaining, executing, and reversing this rollup, enter the name of an authorization group in the authorization group field.
3. Under Tables, enter the name of the sender table and receiver table.
4. Under reset, if required, enter the name of the reset set.

You can use the reset set to reset the data in the rollup ledger for the relevant periods to 0 prior to the actual rollup and before new data is summarized into the rollup ledger. A reset set is normally necessary, as the default active overwrite (see step 6: Cumulating Values) makes it possible for a rollup to be executed more than once in a given period.

A reset set is useful in the following situations:
The rollup field movement was changed after execution. When a rollup is executed again for a given period, different rollup records are created to the ones created on previous execution. The new rollup records do not overwrite the old ones. The old rollup records remain, therefore leading to incorrect results. By using a reset set, these old records can be set to 0.

If you want to roll up data from several source ledgers together in a rollup ledger, the Cumulate Values flag must be active for all affected rollups. If you then have to repeat these rollups in a given period, you can enter a reset set in one of the rollups. This will reset the values for this period to 0. Subsequently, all rollups can be executed again with the Cumulate Values flag.

To optimize performance, your reset set must contain the following dimensions:

- Ledger
- Record type
- Version
Creating Rollup Headers for Standard Rollups

- Company code or company (local or global)

Your reset set must **not** use the following dimensions:

- Client
- Period
- Year

You can create a reset set to set the data fields in account 100000 to zero. When you execute the rollup, the data fields in account 100000 will be set to zero in the receiver table before the rollup fills all fields that meet the selection criteria for the set specified in the rollup header. For further information, see [Sets and Rollups](#) [Seite 254].

5. If required, enter a user exit and/or a rollup set under *Roles*.

You have to enter the number of the user exit in the *user exit* field. For further information, see [User Exits and Rollups](#) [Seite 263].

The rollup set is used for all sequences in the rollup. Using the multi-dimension set specified in this field, the system chooses the data that is to be taken from the source ledger(s) and summarized.

To optimize performance, your rollup set must contain the following dimensions:

- Ledger
- Record type
- Version
- Company code or company (local or global)

Your rollup set must **not** contain the following dimensions:

- Client
- Period
- Year

6. To enter default values for processing the rollup, choose *Processing Options*. The *Default Values* dialog box appears. You can choose between the following functions:

   **a. Write Line Items**

   If you set the *Write Line Items* flag, a line item will be written for every you totals record when you execute the rollup. This line item will flag the totals record during drilldown. It will then be possible to reverse this rollup run.

   ![Warning]

   Only set the *Write line items* indicator if you want the option of reversing the rollup or if you only want to roll up a small amount of data. If you set the *Write line items* indicator, processing time will be increased enormously.
Creating Rollup Headers for Standard Rollups

Writing line items is something you should only do in exceptional cases.

With an extremely long rollup, a very large amount of data is rolled up to a rollup ledger. With a second rollup, a smaller amount of data is to be cumulated to the same ledger, meaning that the rollup must be performed again, as repostings will take place. In this case, you can reverse the data from the second rollup specifically and execute the rollup again. Should no line items be stored, you would have to execute both rollups again.

b. Cumulate Values

If you do not set the Cumulate Values flag (standard setting), the existing records in the rollup ledger will be overwritten by the rollup records in the current run. This only applies for periods for which the rollup is currently being executed. The other period are not affected. It is not possible to execute a rollup more than once for a given period, as the values will simply be overwritten.

If you set the Cumulate Values flag, the currently records currently being rolled up will be added to the existing records in the rollup ledger. As a consequence, repeated execution of the rollup leads to a multiplication of the totals.

Cumulating values is only useful if you want to roll up data from several source ledgers to a rollup ledger in a series of rollups.

c. Write Records with Amount 0

If you want the system to insert blank records (records with the value zero in their amount fields) in the rollup ledger, set the Write records with amount 0 indicator.

If you want to create a report that shows all accounts in a group of accounts (including accounts that have amounts equal to zero), you must include records that have zero in their amount fields. If blank records are not included in your rollup ledger, then the summary records of those accounts that are equal to zero will not be created or available for reporting.

You can use the following additional functions on this screen:

To check the rollup for errors, choose . For further information, see Checking Rollups [Seite 269].

To create rollup sequence, choose Rollup Sequence. You can define a rollup sequence set for each rollup sequence, or you can define the rollup so that only the rollup header set applies to the rollup sequences. For further information, see Creating Rollup Sequences [Seite 283].

To display and maintain sets or field movements in the rollup header, choose . Move the cursor to the set or field movement you want to display. You can define field movement information for as many dimensions that you want to roll up in the ledger. You can define substitution activities for as many dimensions that you want to substitute in the ledger.

To create sets, move your cursor to required set, enter the name and choose Set.
Creating Rollup Headers for Standard Rollups

Additional Processing Functions in the Create Rollup <Name>: Header screen

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollup → Document</td>
<td>Document the rollup definition and rollup records</td>
</tr>
<tr>
<td>Extras → History</td>
<td>Display change history for the rollup</td>
</tr>
<tr>
<td>Extras → Different Currencies</td>
<td>Set the currency fields to zero</td>
</tr>
</tbody>
</table>

7. To save the settings, choose \(\text{Save}\).

**Result**

You have completed rollup definition. For more information, see:

- Executing Rollups [Seite 296]
- Defining Background Jobs for Rollup Definition [Seite 293]
- Changing Rollups [Seite 301]
- Reversing Rollups [Seite 294]
- Deleting Rollups [Seite 300]
Creating Rollup Headers for Hierarchical Rollups

Use
The rollup header contains information that is valid for the entire rollup. In a hierarchical rollup, you rollup data according to the structure of the single-dimension set defined in your rollup header set.

Prerequisites
You have flagged a rollup type and chosen on the Create Rollup: Initial screen.

Procedure
1. Under Title, enter a name for your rollup.
2. If you want to require that a user have authorization for creating, displaying, maintaining, executing, and reversing this rollup, enter the name of an authorization group in the authorization group field.
3. Under Summarize from, enter the name of the table in which you want the data to be summarized.
4. If required, enter the name of the reset set under Reset. You can use the reset set to reset the data in the rollup ledger for the relevant periods to 0 prior to the actual rollup and before new data is summarized into the rollup ledger.

You can use the reset set to reset the data in the rollup ledger for the relevant periods to 0 prior to the actual rollup and before new data is summarized into the rollup ledger. A reset set is normally necessary, as the default active overwrite (see step 6: Cumulating Values) makes it possible for a rollup to be executed more than once in a given period.

A reset set is useful in the following circumstances:
Rollup field movement has been changed following execution of a rollup. When this rollup is executed again for a period, different rollup records are created to those created previously. The new rollup records do not match the old ones and therefore do not overwrite them. The old rollup records remain, therefore leading to incorrect results. By using a reset set, these old records can be set to 0.

If you want to roll up data from several source ledgers together in a rollup ledger, the Cumulate Values flag must be active for all affected rollups. If you then have to repeat these rollups in a given period, you can enter a reset set in one of the rollups. This will reset the values for these periods to 0. Subsequently, all rollups can be executed again with the Cumulated Values flag.

For performance reasons, you must include the following dimensions in your reset set:
Creating Rollup Headers for Hierarchical Rollups

- Ledger
- Record type
- Version
- Company code or company (local or global)

You must not include the following dimensions in your reset set:

- Client
- Period
- Year

You can define a reset set to reset the data fields for account 100000 to zero. When you execute the rollup, the data fields for account 100000 will first be reset to zero in the receiver table, then the rollup will add data to all data fields that meet the selection condition in the rollup header set. For further information, see Sets and Rollups [SAP AG Seite 254].

5. If required, enter a user exit and/or a rollup set under Roles.

To refer the system to a user exit, enter the user exit number in the User exit field. For further information, see User Exits and Rollups [SAP AG Seite 263].

The rollup set will be used for all sequences defined for the rollup. The multi-dimension set name you enter in this field selects the data to be rolled up from the source ledger(s).

For performance reasons, you must include the following dimensions in your rollup set:

- Ledger
- Record type
- Version
- Company code or company (local or global)

You must not use the following dimensions in your rollup set:

- Client
- Period
- Year

If you are defining a hierarchical rollup, you must include the single-dimension set of the hierarchy dimension in the header set. For more information about sets and rollups, see Sets and Rollups [SAP AG Seite 254].
Creating Rollup Headers for Hierarchical Rollups

6. Under *Hierarchy Dimension*, enter the dimension that you want to use for processing the rollup (for example, cost center). This hierarchical dimension then determines the single-dimension set in the rollup set, over with the hierarchical summarization is to be made.

   Enter a representative value for each set in your hierarchy set. This representative value represents, for example, the node cost centers to which you want to roll up data. When the set is processed in the rollup, the system creates data records using the representative values. For more information about hierarchical rollups, see Rollup Types [Seite 261].

7. Under *Field Movement*, enter the name of the field movement rule that should be used for the rollup. The field movement determines which dimensions will be transferred from the source ledger(s) to the rollup ledger.

8. Under *Receiver Ledger*, specify how the data is to be summarized in the receiver system when you create an export rollup:

9. Select the *Processing optn* indicator to enter default values for processing rollups. The *Default Values* dialog box appears. You can choose between the following functions:
   
a. **Cumulate Values**
   
   If you want new rollup data to be added to existing rollup data in the rollup ledger, set the *Cumulate Values* flag. Do not set this flag if you want new rollup data to overwrite existing rollup data.

b. **Write Records with Amount 0**

   If you want the system to insert blank records (records with the value zero in their amount fields) in the rollup ledger, set the *Write records with amount 0* indicator.

   ![Icon](image)

   If you want to create a report that shows all accounts in a group of accounts (including accounts that have amounts equal to zero), you must include records that have zero in their amount fields. If blank records are not included in your rollup ledger, then the summary records of those accounts that are equal to zero will not be created or available for reporting.

c. **Elimination of Internal Business Volume**

   If you want to eliminate internal business volume within a set hierarchy, set the *Elim.of int.bus vol.frm bus* indicator. You can only use this field for hierarchical rollups. Elimination of internal business volume is only possible with dimensions for which a partner dimension has been defined in the master files (for example, SCNTR for SCNT). If you have allocated costs between the final cost centers within a cost center area, you can eliminate inter-company business volume.

d. **Summarize Partners**

   Set the *Summarize partner* indicator to summarize data across sender and receiver cost center (only for hierarchical rollups).

You can use the following additional functions on this screen:

To display and maintain sets or field movements in the rollup header, choose ‐. Move the cursor to the set or field movement you want to display. You can define field movement information for as many dimensions that you want to roll up in the ledger. You can define substitution activities for as many dimensions that you want to substitute in the ledger.
Creating Rollup Headers for Hierarchical Rollups

To check the rollup for errors, choose $3. For further information, see Checking Rollups [Seite 269].

To create sets, choose Set. Position your cursor on the required set.

To create a field movement, choose Field Movement.

Additional Processing Functions in the Create Rollup <Name>: Header screen

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollup → Document</td>
<td>Document the rollup definition and Rollup Records</td>
</tr>
<tr>
<td>Extras → History</td>
<td>Display change history for the rollup</td>
</tr>
<tr>
<td>Extras → Different Currencies</td>
<td>Set the currency fields to zero</td>
</tr>
</tbody>
</table>


Result

You have ended rollup definition. For more information, see:

- Executing Rollups [Seite 296]
- Defining Background Jobs for Rollup Definition [Seite 293]
- Changing Rollups [Seite 301]
- Reversing Rollups [Seite 294]
- Deleting Rollups [Seite 300]
Creating Rollup Headers for Export Rollups

Use
The rollup header contains information that is valid for the entire rollup. You can use an export rollup to distribute data contained in totals records from a local system to a central system.

Prerequisites
You have flagged a rollup type and chosen on the Create Rollup: Initial screen.

5. Under Title, enter a name for you rollup.
6. If you want to require that a user have authorization for creating, displaying, maintaining, executing, and reversing this rollup, enter the name of an authorization group in the authorization group field.
7. Under Transfer Data, enter the name of the table in which you want the data to be summarized.
8. Under Data Selection, enter the name of the rollup set in which the you want the data to be selected.
9. Set the No summarization indicator if you do not want to summarize the data when it is transferred to the receiver system. Data will be transferred on a 1:1 basis.
10. Set the Field movement indicator if you want to summarize the data when it is transferred to the receiver system using a field movement. Enter the name of the field movement rule.

You can use the following additional functions on this screen:
To display and maintain sets or field movements in the rollup header, choose . Move the cursor to the set or field movement you want to display. You can define field movement information for as many dimensions that you want to roll up in the ledger. You can define substitution activities for as many dimensions that you want to substitute in the ledger.

To check the rollup for errors, choose . For further information, see Checking Rollups [Seite 269].

To create sets, choose . Set. Position your cursor on the required set.

To create a field movement, choose . Field Movement.

Additional Processing Functions (Create Rollup <Name>: Header screen)

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollup → Document</td>
<td>Document the rollup definition and Rollup Records</td>
</tr>
<tr>
<td>Extras → History</td>
<td>Display change history for the rollup</td>
</tr>
<tr>
<td>Extras → Different Currencies</td>
<td>Set the currency fields to zero</td>
</tr>
</tbody>
</table>

11. To save the settings, choose .
Creating Rollup Headers for Export Rollups

**Result**

You have ended rollup definition. For more information, see:

- [Executing Rollups][296]
- [Defining Background Jobs for Rollup Definition][293]
- [Changing Rollups][301]
- [Reversing Rollups][294]
- [Deleting Rollups][300]
Creating a Rollup Sequence

Use
Rollup sequences allow you to execute multiple rollup sequences without having to create and execute separate rollups. You can only create rollup sequences for standard rollups. All necessary information for a hierarchical and export rollup is defined on the Create Rollup <Name>: Header screen.

You can create a rollup with three rollup sequences. Each sequence within the rollup rolls up data from three different sources into three different rollup ledgers. When you execute the rollup, all three sequences will be processed (record by record) in order of sequence number.

Procedure
You are now in the Create Rollup <Name>: Header screen.

1. Choose Rollup Sequence. The Create Rollup <Name>: Rollup Sequence screen appears.
2. Under Sequence Definition, enter the following information:
   - Name of the rollup sequence set
     With the sequence set, you determine which data should be rolled up for the specific sequence. The sequence set can be a single-dimension or basic set. For further information, see Sets and Rollups [Seite 254] [Seite 262].
   - A selection rule, if your sequence set cannot completely define the data to be rolled up
     You use the selection rule to further limit the data to be chosen by the sequence set. The selection rule must conform to Boolean Logic syntax rules [Seite 1120].
   - Name of the field movement for the rollup sequence
     Using the field movement, you determine which dimensions will be transferred from the source ledger(s) to the rollup ledger.
   - Enter a name for the rollup ledger.
     When you create a rollup sequence, you can now enter the ledger to which you want to rollup data.
   - Set the Blocked indicator if you want to block the sequence from rollup processing
   - Rollup sequence description

3. To save the rollup sequence, choose .

You can use the following additional functions on this screen:
To return to the Create Rollup <Name>: Header screen, choose .
To delete a given rollup sequence, choose Sequence.
Creating a Rollup Sequence

To choose and edit an object in the rollup sequence (set, rule or field movement), place your cursor on the object and choose 📝.

To check the rollup for errors, choose 📝.

To create a set, choose 📝 Create.

To create a field movement, choose a sequence set, enter the field movement information and choose 📝 Field Movement.

### Additional Processing Functions (Create Rollup <Name>: Rollup Sequence Screen)

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → History</td>
<td>Display change history for the rollup</td>
</tr>
<tr>
<td>Extras → Document Rollup</td>
<td>Document rollup definition and rollup records</td>
</tr>
</tbody>
</table>
Creating Field Movement

Use

With field movement [Seite 257], you can define how data/which fields is/are to transferred to and summarized in a database. Field movements contain:

- Sender fields (dimensions of the source database)
- Receiver fields (dimensions of the receiver database)

You have to assign a field movement rule to each group of field movements.

Procedure

You are now in the Create Rollup <Name>: Rollup Sequence screen.

1. Enter the name of the field movement that you want to create and choose Field Movement.

   The Create Rollup Field Movement: Data screen appears.

2. Enter the following data:

   - A description of the field movement
   - A user exit to be performed after data is selected from the database, if required.
   - A user exit to be performed before the database is updated with receiver records, if required.
   - Receiver field name

      The receiver field is the field to which the sender field name is assigned.

   - A sender field name that is to be assigned from the source table.

      The data from this field is assigned to the Rec. fld field.

   - A substitution activity code

   - A user exit number to be performed when the data from the sender field is moved to the receiver field during rollup execution, if required.

      For more information about user exits, see User Exits and Rollups [Seite 263].

3. To save the field movement information, choose .

This screen contains the following additional functions:

To delete a row from the field movement information, choose .

To enter substitution information for the rollup, choose Substitutions. For further information, see Entering Substitution Processes [Seite 287].

To display additional entries for entering field movements, choose New Entries.

To delete all rows from the field movement information, choose Edit → Delete All Rows.
Creating Field Movement

You use the Edit → Choose function on the Create Rollup <Name>: Rollup Sequence screen to display a field movement already defined in the rollup sequence.

Result

You have created/edited a field movement for the rollup, thus defining which data/fields are to be transferred and summarized from the source database to the receiver database.
Entering Substitution Activity Information

Use
A substitution activity allows you to transfer substituted data to receiver dimensions during the rollup process. A substitution activity is identified by its substitution activity code, and you enter the substitution activity code in a field movement. You can use the same substitution activity code for more than one rollup sequence.

You could define a substitution activity called CONV to substitute the value 300000 for account numbers between 500000 and 500020 (number 1) and to substitute the value 400000 for account numbers between 600000 and 600020 (number 2). Next, you enter the substitution activity code CONV in a field movement that transfers the data for the dimension Account. When you execute your rollup, account numbers between 500000 and 500020 will be changed to and summarized under account number 300000, and account numbers between 600000 and 600020 will be changed to and summarized under 400000.

Procedure
You are currently in the Create Field Movement: Data screen:

3. Enter the following data:
   – Name of the substitution activity
   – A consecutive number
   – Name of the summary table (receiver table)
   – Name of the receiver field (receiver dimension)
   – Constant value (substitution value)
     The value you enter in this field will be substituted for the original value if the substitution condition is met.

For substitution activity code CONV (above example), you could enter the value 300000.

   – User exit number, to refer the system to a rollup substitution exit
     If your substitution condition is too complicated to define here (for example, if you want to read a user-defined table), you can define the substitution in a user-defined routine called a substitution exit. Generally, if you enter a user exit, it is not necessary to enter a value in the Constant value field. For more information about user exits, see User Exits and Rollups [Seite 263] .

   – A substitution rule
Entering Substitution Activity Information

The substitution activity (replacement by constant value or execution of a user-exit) is only executed if the rule entered for it is complied with.

All substitution rules that are used in rollup substitution activities must be created for table GLU1 (application area GU, callup point 0002).

For more information about creating substitution rules, see Creating Rules [Seite 1107].

4. To save the substitution activity, choose 

Result

You have created substitution activities. When you execute the rollup, the substituted data will be transferred to the receiver dimensions.

You can use the following additional functions in this screen:

To position the cursor on a substitution activity that has already been defined, choose 

To delete a substitution activity, select the row and choose 

To select all substitution entries for further processing, choose 

To select a block of substitution activities for further processing, choose 

To delete the selection for all selected substitution activities, choose 

Additional Processing Functions – Change View “Rollup Substitution”: Overview Screen

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table View → Save</td>
<td>Save the substitution activity definitions.</td>
</tr>
<tr>
<td>Table View → Transport</td>
<td>Prepare the table for transport under a correction number.</td>
</tr>
<tr>
<td>Table View → Print → Standard List</td>
<td>Print all substitution activities defined on the system.</td>
</tr>
<tr>
<td>Table View → Print → Variable List</td>
<td>Print specific substitution activities based on user-defined selection criteria.</td>
</tr>
<tr>
<td>Edit → New Entries</td>
<td>Create a new substitution activity.</td>
</tr>
<tr>
<td>Edit → Copy as</td>
<td>Copy a selected substitution activity.</td>
</tr>
<tr>
<td>Edit → Change Field Content</td>
<td>Change a selected substitution activity.</td>
</tr>
<tr>
<td>Edit → Reverse Change</td>
<td>Change a selected substitution activity back to its previous definition.</td>
</tr>
<tr>
<td>Goto → Next Entry</td>
<td>Move to the next substitution activity.</td>
</tr>
<tr>
<td>Goto → Previous Entry</td>
<td>Move to the previous substitution activity.</td>
</tr>
</tbody>
</table>
## Entering Substitution Activity Information

<table>
<thead>
<tr>
<th><strong>Operation</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Other Entry</td>
<td>Move to a specific substitution activity.</td>
</tr>
<tr>
<td>Selection → By Content</td>
<td>View substitution activities according to the fields displayed on the screen.</td>
</tr>
<tr>
<td>Selection → All Selected Entries</td>
<td>View all substitution activities that have been selected.</td>
</tr>
<tr>
<td>Selection → All Changed Entries</td>
<td>View all substitution activities that have been changed.</td>
</tr>
<tr>
<td>Selection → All Created Entries</td>
<td>View all substitution activities that have just been created.</td>
</tr>
<tr>
<td>Selection → Display Deleted Entries</td>
<td>View all substitution activities that have just been deleted.</td>
</tr>
<tr>
<td>Utilities → Other Systems</td>
<td>Compare the substitution activity entries with the entries in another system (for example, a test system vs. a productive system).</td>
</tr>
<tr>
<td>Utilities → Requests (Organizer)</td>
<td>Call up the Workbench Organizer, for example, to maintain and display transport requests.</td>
</tr>
</tbody>
</table>
Checking Rollups

Use

After you have created a rollup, you should check that it you have defined it correctly.

You are in one of the following screens: Create/Change/ Rollup <Name>: Header or Create/Change/ Rollup <Name>: Rollup Sequence.

Procedure

1. Choose ⬛. If the rollup is correct, the system displays the following message: Rollup <Rollup Name> is formally correct
   
   If the rollup contains errors, error messages appear.
   
   When displaying error messages for a rollup definition, you can display a more detailed explanation. To do this, proceed as follows:

2. Move the cursor to the error message for which you want to display additional information.

3. Choose 📔 or double-click the message.

4. You must correct these errors before executing the rollup. (However, you can ignore warning messages.)

Result

If the system displays the following message: Rollup <Rollup Name> is formally correct, you can execute the rollup.
Documenting Rollups

Use
With the Document Rollup function, you can display and print all of the rollup screens (including all rollup sequences).

Procedure
1. You are in one of the following screens: Create/Change/ Rollup <Name>: Header or Create/Change/ Rollup <Name>: Rollup Sequence.
3. Enter texts as required.
4. Choose . The Document Rollup Definition screen appears. You can use the following additional functions on this screen:

   Additional Processing Functions (Document Rollup Definition Screen)

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>List → Print</td>
<td>The documented rollup definition is printed in a list.</td>
</tr>
<tr>
<td>List → Save/Send → Office</td>
<td>You can create and send the rollup definition as a document.</td>
</tr>
<tr>
<td>List → Save/Send → Report Tree</td>
<td>You can save the documented rollup definition as public or private. You can attach the rollup definition to an existing list and optically archive it.</td>
</tr>
<tr>
<td>List → Save/Send → File</td>
<td>You can save the list in various formats.</td>
</tr>
</tbody>
</table>

5. To get a variant, choose .
6. Choose Program → Execute + Print. The system prints the rollup documentation at the selected printer or writes the documentation to the spool file to be printed later.

Result
You have documented the rollup definition. You can now display, print, save and send the rollup documentation.
Displaying Rollups

Procedure

   The Display Rollup: Initial Screen appears.

2. Enter the name of the rollup that you want to display.

3. Choose  
   The Display Rollup <Name>: Header screen appears.

Result

You are now in rollup display mode and can also display the rollup sequence(s).
Defining a Rollup for Background Processing

Use
You can execute or reverse a rollup in either online or background processing. Normally, executing or reversing your rollup involves large amounts of data and requires extensive processing time; in this case, you should execute or reverse your rollup in background processing.

Procedure
   The Execute/Reverse Rollup: Initial Screen appears.
2. In the Rollup field, enter the name of the rollup for which you want to create a job for background processing and choose ☐.
   The Execute/Reverse Rollup <Name>: Parameter Screen appears.
3. Enter data as required.
   For more information about entering the values in these fields, see Executing a Rollup [Seite 296] and Reversing a Rollup [Seite 294] .
4. Set the Background processing indicator and choose Execute or Reverse.
   A dialog box appears, prompting you for job information.
5. Enter the information for executing/reversing the rollup in background processing and choose ☐. The Simple Job Selection screen appears.
6. Enter the following data as required:
   You can also use a more flexible job selection. Further selection criteria are available for this: Choose ☐ with quick text Extended Job Selection.
7. Choose ☐ Execute.

Result
The Job Overview screen appears. Here, you can edit your job(s).
For more information on background jobs, see the SAP Library under Getting Started → Basis → Computing Center Management System (BC-CCM) → Computing Center Management System (BC-CCM) → Background Processing → Managing Jobs with the Job Overview.
Reversing a Rollup

Use

When you reverse a rollup the system creates reversing documents that offset the original line items. When you reset a rollup, the system resets selected data fields to zero but does not create any new documents.

You can reverse a rollup only if the rollup data has been posted to the line item database(s).

Procedure

2. Enter the name of the rollup that you want to reverse.
3. Choose 🌔. The Reverse Rollup <Name>: Parameter Screen appears.
4. Enter the following data:

   **Parameters fields:**
   - For standard and hierarchical rollups (when the fiscal year variants are the same for the source ledger(s) and rollup ledger):
     - Beginning period for which you want to reverse rollup data.
     - Fiscal year for the value entered in the From period field.
     - End period for which you want to reverse rollup data.
     - Fiscal year for the value entered in the To period field.
   - For standard and hierarchical rollups (when the fiscal year variants are different for the source ledger(s) and the rollup ledger):
     - Start date for the rollup reversal
     - End date for the rollup reversal
     - Set the Carry-fnrd period frm yr indicator if you want to reverse the carry forward period of a specific year. In the second field, enter the fiscal year for which you want to reverse the carry forward period.
     - Set the Special periods indicator if you want to reverse all special periods.

   **Processing options fields:**
   - If you want to reverse your rollup in the background, set the Background processing indicator.
     - For more information about reversing your rollup in the background, see Defining a Rollup for Background Processing [Seite 293].
   - If you want to output a list containing details on all the records read and generated during the rollup reversal, set the Detail list indicator.
5. You can use the following additional processing functions on the Reverse Rollup <Name>: Parameter Screen.

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → History</td>
<td>View the execution history of the rollup.</td>
</tr>
<tr>
<td>Extras → Delete history</td>
<td>Delete the execution history information for the rollup.</td>
</tr>
<tr>
<td>Extras → Document rollup</td>
<td>Document the rollup and record results of the rollup.</td>
</tr>
</tbody>
</table>

6. Choose Reverse.

A list of statistics for the reversed rollup appears on the Reverse Rollup <Name>: Statistics screen.

**Result**

A list of statistics for the reversed rollup appears on the Reverse Rollup <Name>: Statistics screen.
Executing Rollups

Procedure


2. Enter the name of the rollup that you want to execute.

3. Choose 🔄. The Execute Rollup <Name>: Parameter Screen appears.
   
   If you entered a value or set variable in one of your rollup sets, a dialog box appears, prompting you to confirm or change the default value of the variable.
   
   The dialog box for set variables appears first, followed by the dialog box for value variables. The Execute Rollup <Name>: Parameter Screen appears.
   
   If there are errors in the rollup definition, a screen appears, listing errors that you have to correct. If the errors are only warnings, choose 🔄. The Execute Rollup <Name>: Parameter Screen appears.

4. Enter the following information:
   
   **Parameter fields:**
   
   For standard, hierarchical and export rollups (when the fiscal year variants are the same for the source ledger(s) and rollup ledger):
   
   Enter the beginning period for which you want to reverse rollup data.
   
   Enter the fiscal year for the value entered in the *From period* field.
   
   Enter the end period for which you want to reverse rollup data.
   
   Enter the fiscal year for the value entered in the *To period* field.
   
   For standard rollups (when the fiscal year variants are different for the source ledger(s) and the rollup ledger):
   
   Enter the start date for the rollup execution
   
   Enter the end date for the rollup execution
   
   Set the *Carry-fnwd period frm yr* indicator if you want to reverse the carry forward period of a specific year. In the second field, enter the fiscal year for which you want to roll up the carry forward period.
   
   Set the *Special periods* indicator if you want to roll up all special periods.

   **Processing options fields:**
   
   If you want to execute your rollup in the background, set the *Background processing* indicator.
   
   For more information on background processing for rollups, see Defining Background Jobs for Rollup Execution [Seite 293].
If you want the option of reversing the rollup after it has been executed, set the *Write line items* indicator.

If you set the *Write line items* indicator, the system writes line items to the line item database. If you do not plan to reverse the rollup or drill down to rollup line items in a report created for the rollup ledger (or if you are rolling up large quantities of data), you should leave the *Write line items* indicator blank to avoid unnecessary database updates and increased runtime.

Enter the document type for the rollup, if line items should be created for the rollup. The document type groups together documents that are processed in the same way.

If you want new rollup data to be added to existing rollup data in the rollup ledger, set the *Accumulate values* indicator. If you want new rollup data to overwrite existing rollup data, do not set this indicator.

If you want the system to insert blank records (records with the value zero in their amount fields) in the rollup ledger, set the *Write records with amount 0* indicator.

If you want to create a report that shows all accounts in a group of accounts (including accounts that have amounts equal to zero), you must include records that have zero in their amount fields. If blank records are not included in your rollup ledger, then the summary records of those accounts that are equal to zero will not be created or available for reporting.

If you want to eliminate internal business volume within a set hierarchy, set the *Elim.of int.bus.vol frm bus* indicator. You can only use this field for hierarchical rollups. Elimination of internal business volume is only possible with dimensions for which a partner dimension has been defined in the master files (for example, SCNTR for SC cnt).

If you have allocated costs between the final cost centers within a cost center area, you can eliminate inter-company business volume.

If you also want to summarize data for sender objects parallel to the receiver object, set the *Summarize partner by level* indicator. You can only use this indicator if the rollup is a hierarchical rollup.

If you want to output a list containing details on all the records read and created during the rollup execution, set the *Detail list* indicator.

Processing time could take longer if you are processing a large volume of data and set the *Detail list* indicator.

5. You can use the following additional functions in this screen:

**Additional Functions (Screen Execute Rollup <Name of Rollup>: Parameter Screen)**

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → Export File</td>
<td>Import data from a sequential file or PC file or export data to a</td>
</tr>
<tr>
<td></td>
<td>sequential file or PC file.</td>
</tr>
</tbody>
</table>
## Executing Rollups

<table>
<thead>
<tr>
<th>Extras → History</th>
<th>View the execution history of the rollup.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → Delete History</td>
<td>Delete the execution history information for the rollup.</td>
</tr>
<tr>
<td>Extras → Document Rollup</td>
<td>Document the rollup definition and record results of the rollup.</td>
</tr>
</tbody>
</table>

6. Choose 🔄.

### Result

A list of the records read and created for the executed rollup appears.
Exporting/Importing Rollup Data

Use
You can export/import rollup data to/from a PC file. This is advantageous when rolling up data across separate R/3 Systems or clients.

Procedure
You are now in the Execute Rollup <Name>: Parameter screen.

1. Choose Extras → Export File.
   A dialog box appears, displaying the options for importing/exporting rollup data.
2. Enter the following information:
   - **Input data fields:**
     You enter values in these fields when you want to import the rollup data from a sequential file or PC file.
     Enter the file name from which you want to import data in the field under the file type you have marked.
   - **Output data fields:**
     You enter values in these fields when you want to export the rollup data to a sequential file or PC file.
     Enter the file name to which you want to export data in the field under the file type you have marked.
3. Choose 🌲.

Result
When you execute the rollup, the system imports the data from or exports the data to the files you have specified.
Deleting Rollups

Use
If you delete a rollup, do not delete the rollup ledger that is assigned to it. You should delete only the rollup definition that is used to define how the data is summarized in the rollup ledger.

⚠️
You should only delete a rollup definition from your productive system if this is absolutely necessary.

Procedure
   The Delete Rollup: Initial Screen appears.
2. Enter the name of the rollup that you want to delete.
3. Choose 📧.
   A dialog box appears, asking you if you want to delete the rollup.
4. To delete the rollup, choose Yes.

Result
The system has deletes the rollup definition. You cannot restore a rollup definition after it has been deleted.
Changing Rollups

Use

⚠️

You should use caution when changing the structure of your productive system. Structure changes that you make in a productive system may violate the integrity of your data.

If you need to change a rollup definition, proceed as follows.

Procedure

1. Choose **Accounting → Financial Accounting → Special Purpose Ledger → Periodic Tasks → Rollup → Change.**
   - The Change Rollup: Initial Screen appears.
2. Enter the name of the rollup that you want to change.
3. Choose **Rollup header.**
   - The Change Rollup <Name>: Header screen appears.
4. Type over existing values with your changes.
5. To save your changes, choose **Rollup → Save.**
Currency Translation

Use
With currency translation in the Special Purpose Ledger [Extern], you can translate amounts that were posted in local and global ledgers.

Program RGUUMR00 is available for the currency translation and contains the following functions:

- The translation is made from the local currency to the group currency. By making the necessary settings in Customizing, you can, however, translate the transaction currency to the group currency.
- You can group accounts into item groups that you translate using various translation methods [Seite 305].

The following accounts can, for example, be grouped in an item group and translated using a specific translation method:

<table>
<thead>
<tr>
<th>Item group</th>
<th>Translation method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asset accounts</td>
<td>Translation using historical exchange rates</td>
</tr>
<tr>
<td>Balance sheet accounts</td>
<td>Translation for spot rate exchange</td>
</tr>
<tr>
<td>P&amp;L accounts</td>
<td>Translation for each period</td>
</tr>
</tbody>
</table>

Integration
For ledger 0 (general ledger), you run a currency translation as part of the foreign currency valuation [Extern] in the General Ledger application component.

To do so, from the SAP Easy Access menu choose Accounting → Financial Accounting → General Ledger → Periodic processing → Closing → Valuate → Foreign currency valuation.

Different than the foreign currency valuation in General Ledger Accounting, the translation in the Special Purpose Ledger is made at the totals record level during currency translation, and the system does not create any documents.

Prerequisites
In order to run the currency translation, you have to make various settings in Customizing. You can find the settings in Financial Accounting Customizing under Special Purpose Ledger → Periodic Processing → Currency Translation.

- You have to have defined the translation exchange rates. For more information, see Translation Exchange Rates [Extern].
- You have to define a translation version for each ledger for which you want to run a currency translation. To do so, choose Define Versions.
- You have to specify a translation method. To do so, choose Define Translation Method.
• You have to define for version and company code or company the translation method you want to use. To do so, for company codes choose Assign Local Translation Methods and for companies Assign Global Translation Methods.

• If you want to complete a currency translation using historical figures, choose Maintain Historical Currency Translation.

• You have to have defined your exchange rate types or exchange rate indicators [Seite 306]. To do so, choose Set up exchange rate types.

Features

The currency translation takes place in four steps:

1. Reference currency translation
   
   All accounts are translated using a reference exchange rate indicator (such as spot exchange rate). You enter the reference exchange rate indicator in the selection screen.

   ![Reference currency translation](image)

   In the Special Purpose Ledger, you normally enter the reference exchange rate indicator *. The exchange rate difference is determined by comparing the group currency values that are already contained on the database.

2. Translation of the account groups

   The accounts that are combined in item groups are translated using the translation method defined in Customizing. The amounts translated into the group currency are updated in the group currency fields.

3. Calculating the translation differences

   The difference is calculated from the results of the two methods. The translation differences are posted directly to the accounts set up for exchange rate differences.

   You can also specify whether the rounding difference are to be posted to and identified by specific accounts.

   ![Warning](image)

   If you use exchange rate indicator *, you should first make a test run and check its results. When defining the translation method for the update run, you should specify that the system posts documents.

   This is necessary, since the system uses existing group currency values for the currency translation with reference exchange rate indicator *. The existing group currency values are replaced with every translation run. You thus have to check whether the group currency values that you want to use as a reference have already been replaced by a translation run.

   ![Tip](image)

   You execute a currency translation for item group GWUL_DEMO that only contains account 100000 cash.

   The account has a balance of 10,000 USD. From a previous reference translation, a reference value of 19,000 DEM exists in the group currency. The current USD/DEM exchange rate is 2.00.
Currency Translation

The currency translation makes the calculation with reference exchange rate indicator *, resulting in a value of 20,000 and a translation difference of 1,000. The translation difference is posted to the account specified for differences (399999).

Activities

To carry out currency translation, from the SAP Easy Access menu choose Accounting → Financial Accounting → Special Purpose Ledger → Periodic processing → Currency translation → Local for local ledgers or Global for global ledgers.

In the selection screen, you can also enter the following:

- You can specify the level of detail of the output list. To do so, specify a list type.
- You can specify whether you want to first make a test run. In this case, the system makes no changes to the database.
- You can allocate the translation differences to the affiliated companies. To do so, set the affiliated companies indicator.
- You can also allocate the differences by transaction currency. To do so, set the Transaction currencies indicator.
Translation Methods

Definition
Definition with which an account group or item group is translated from the local currency (or transaction currency) to the group currency.

Use
You have to define translation methods in order to complete a currency translation.

For your various account groups or item groups, you can define various translation methods, such as spot exchange rate for asset accounts.

To define exchange rate types, in Financial Accounting Customizing choose Special Purpose Ledger → Periodic Processing → Currency Translation → Set Up Exchange Rate Types.

Structure
In a translation method, you define the following:

- Whether documents are to be updated during the currency translation
- Which accounts are to be combined in an account group (or an item set)
- Whether the translation is only allowed for certain transaction types
- With which exchange rate indicator [Seite 306] the account group is to be translated (such as spot rate, average rate, historical exchange rate)
- With which currency translation key [Seite 307] the account group is to be translated, that is, which method for determining the exchange rate is to be used (historical or spot exchange rates)

Using the translation type, you can also define whether you want to translate the local currency or the transaction currency to the group currency.

- To which accounts the debit and credit translation differences are to be posted

Integration
You can also use translation methods in Consolidation. Under Use, you should thus specify in which application component the translation method is to be used.
Exchange Rate Indicator

**Definition**
Classification of exchange rates
Examples:
- Spot exchange rate
- Average rate
- Historical rate

**Structure**
The following relationship exists between exchange rate indicator, exchange rate type, and exchange rate.
- An exchange rate type consists of a 3 character rate version and a 1 character exchange rate indicator.
- You save exchange rates in the system using an exchange rate type. This enables the entry of various exchange rates for a currency pair, so conversions can be made for various purposes.

The SAP Standard System includes exchange rate types. To define exchange rate types, in Financial Accounting Customizing choose Special Purpose Ledger → Periodic Processing → Currency Translation → Set Up Exchange Rate Types.

**Use**
The exchange rate indicator is relevant in the following cases during currency translation:
- **Reference exchange rate indicator**
  For the reference translation, you have to specify an exchange rate indicator. All accounts with this exchange rate indicator are translated.
  You can also enter reference exchange rate indicator *. The exchange rate difference is determined by comparing the group currency values that are already contained on the database.
- **Translation method**
  You have to enter an exchange rate indicator when defining a translation method [Seite 305]. From this entry, the system determines the exchange rate version and the translation rate for the currency translation. This allows you to use various translation rates in various versions for testing purposes.
Currency Translation Key

Definition
Definition as to how the exchange rate is determined during currency translation (such as historical or spot rate exchange rates).

The currency translation key also determines the output currency for the currency translation into the group currency. The output currency can be:

- Local currency (standard)
- Transaction currency

Use
You have to enter a currency translation key when defining a translation method [Seite 305].

Structure
Currency translation keys of importance in the Special Purpose Ledger:

<table>
<thead>
<tr>
<th>Technical entry</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Zero translation</td>
<td>The group currency values of the current period are calculated so that the total of all values for the current period equals zero.</td>
</tr>
<tr>
<td>1</td>
<td>Spot exchange rate translation</td>
<td>The exchange rate is determined from the year and period at the time of the program run. A cumulated group currency value is determined. For use with balance sheet accounts</td>
</tr>
<tr>
<td>2</td>
<td>Historical exchange rate</td>
<td>This exchange rate is determined from the acquisition year and period of the asset. In Customizing, you need to complete the Maintain Historical Currency Translation activity. For use with assets</td>
</tr>
<tr>
<td>5</td>
<td>Translation using exchange rate for month</td>
<td>The local currency values for all periods are calculated using the exchange rate for the period. For use with P&amp;L accounts</td>
</tr>
<tr>
<td>6</td>
<td>No repeated translation</td>
<td>The existing group currency values are not replaced. The translation differences are posted, however, to the accounts as specified in Customizing.</td>
</tr>
</tbody>
</table>
## Currency Translation Key

|   | Translation of transaction currency | The translation exchange rate is determined as with spot exchange rate (currency translation key 1)  
The output currency is, however, the transaction currency |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>9</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Carrying Forward Balances

Use
This process involves carrying forward account balances into the new fiscal year. The balance to be carried forward is shown in the account balance display. To carry forward balances, you can use separate programs for G/L accounts, and for customer and vendor accounts.

You therefore do not even have to carry out the balance carry forward manually if you have already posted to the new fiscal year.

The balance carry forward is executed as follows:

**Balance Sheet and Customer and Vendor Accounts**
- The balances on the balance sheet accounts are simply carried forward into the new fiscal year.
- Additional account assignments are transferred.

**Profit and Loss Accounts**
- Profit and loss accounts are carried forward to retained earnings accounts. The balances of the profit and loss accounts are set to 0.
- Additional account assignments are **not** transferred.
- Transaction currencies are no longer applicable and the profit and loss accounts are summarized in local currency.

**Prerequisites**

**Balance Sheet and Customer and Vendor Accounts**
- There are no prerequisites for carrying forward balance sheet and customer and vendor accounts.

**Profit and Loss Accounts**
- The following prerequisites must be fulfilled for profit and loss accounts:
  - Specify a profit and loss account type in the master record of every profit and loss account. This is a key, under which you define a retained earnings account for each chart of accounts.
  - You must define your retained earnings account.

You can make the setting in Customizing under Financial Accounting → General Ledger Accounting → Business Transactions → Closing → Carrying Forward → Define Retained Earnings Account [Extern]

You can make the settings for the Special Purpose Ledger in Customizing for Financial Accounting under Special Purpose Ledger → Periodic Processing → Balance Carry Forward → Retained Earnings Accounts → Maintain Local/Global Retained Earnings Accounts.
Carrying Forward Balances

Most companies use only one retained earnings account. If you use the profit and loss account type, you can use more than one retained earnings account. This might be useful for example, for international corporations that have to meet various requirements when producing the profit and loss statement. For more information, see Special Features of Profit and Loss Statements [Extern]

Features

General Functions

- **Automatically Adjusting Balances Carried Forward**
  
  When you carry forward the balances for G/L accounts at the end of a fiscal year, the system automatically adjusts the balances when you post values to the previous year. The system uses an indicator to determine whether the balances have been carried forward. Once this has been done, the balance is automatically carried forward whenever a posting is made, even when a posting is made to the previous year. It is therefore not necessary to execute the balance carry forward again.

- **Account Adjustment**

  If, in the new fiscal year, you find that a G/L account was mistakenly set up as a P&L account in the prior year instead of as a balance sheet account (or vice versa), you should rerun the balance carry forward program after adjusting the G/L account master record so that the balance carried forward can be adjusted.

Special Features in General Ledger Accounting

- **Parallel Currencies**

  If you run parallel currencies in the general ledger, and the second or third currency is the group currency, the balances are run in this group currency in ledger 00, and carried forward as part of the balance carry forward.

  If you run parallel currencies in other additional general ledgers than ledger 00, you have to carry out the balance carry forward separately for the parallel general ledgers.

Special Features in the Special Purpose Ledgers

- **User-Defined Field Movements**

  If you carry forward additional account assignments, such as profit center or functional area, to the new fiscal year, or you want to summarize using additional account assignments, you must assign field movements for balance sheet and profit and loss accounts to your ledger. To assign the field movements, choose the following in Customizing for Financial Accounting: Special Purpose Ledger → Periodic Processing → Balance Carry Forward → Assign Field Movements.

  😱

  If you want to use a field movement for balance sheet accounts, your field movement must contain the dimension Account. However, the field movement for profit and loss accounts must not contain the dimension Account (except for when you want to change the account using a user exit).

- **Secondary Cost Elements**
In the standard system, the program only carries forward G/L accounts from Financial Accounting. If you also want to carry forward secondary cost elements in your ledger, you do this with a user exit (transaction SMOD/CMOD, enhancement GVTRS001).

**Activities**

You run the balance carry forward program as follows:

- **G/L Accounts**

  From the SAP Easy Access screen, choose Accounting → Financial accounting → General ledger → Periodic processing → Closing → Carry forward → Balance carry forward.

- **Customer and Vendor Accounts**

  From the SAP Easy Access screen, choose Accounting → Financial accounting → Accounts receivable/Accounts payable → Periodic processing → Closing → Carry forward → Balances.

  You can only carry forward balances in Accounts Receivable or Accounts Payable for individual accounts. In General Ledger Accounting, however, you have to carry forward balances for all G/L accounts.

- **Special Purpose Ledger**

  From the SAP Easy Access screen, choose Accounting → Financial accounting → Special purpose ledger → Periodic processing → Balance carry forward.
Archiving

Use

When you use the Archiving function, the R/3 System transfers the data that is no longer required in your online system to an archive file and deletes this data once it has been successfully archived in the file.

You need to archive data if you want to reduce the load on your system’s memory and improve processing times. When you no longer need to access certain data but nevertheless want to keep the data available for possible use in the future, you can archive the data. When you use the archiving function, data is transferred from the Special Purpose Ledger (FI-SL) databases to a sequential file and then deleted from the online system. If necessary, you can retrieve the archived data from the archive files by reloading it into your system.

In FI-SL, you can archive and reload the following:

- Summary records
- Line items

Features

You can archive and delete data that you no longer require in your online system. The standard system archiving programs process and store this data in sequential archive files (such as a UNIX file).

Archiving is performed in two steps. The archiving program first selects the data to be archived from the database and transfers it into the archive files. It then starts a delete program for each archive file. The delete program reads the data from the files and then deletes it from the database. This two-step procedure improves processing time and ensures that the data has been read and stored before being deleted from the database. This maintains the integrity of your data.

The archive program does the following:

- Selects and reads data from the database.
- Checks whether the data can be archived
- Transfers and saves the data in archive files
- Starts the delete programs

The delete program does the following:

- Reads the archived data
- Deletes the data in the database
- Transfers the archive files to an external archive system using an archive link

Both the archiving programs and the delete programs are executed in the background.
Displaying a Hierarchy of FI-SL Tables

You can display a hierarchical listing of all FI-SL tables for which you can archive data records by choosing Periodic processing > Archiving > Hierarchy on the Special Purpose Ledger screen.

Executing Archive Reports

In archive reporting, you can execute reports that evaluate archived data and/or database data. You access archive reporting by choosing Periodic processing > Archiving > Archive reporting from the Special Purpose Ledger screen.

SAP provides ABAP report programs for some of the standard tables delivered with the Special Purpose Ledger application component (for example, GLT1, GLS1, GLP1, GLFUNCT, GLFUNCA, GLFUNCP). These generated programs allow you to output summary reports and actual and plan line item reports. In archive reporting, you can execute both these generated programs and the reports contained in report groups that you have created.

For more information on archiving in the application component Special Ledger, refer to the SAP Library under Cross-Application Components → Archiving Application Data (CA-ARC) → Financial Accounting.
Information System

Purpose
The SAP system includes an extensive and flexible Information System for analysis of cost flows that occur in an organization. You can use this both to carry out recurring standard evaluations and create reports for extraordinary queries and tasks. It is possible to analyze all data interactively, directly after input into the SAP R/3 System. Data can be traced right back to document level. All reports that are available online can be executed in the background. This is particularly important in the case of very extensive datasets.

Features
The information system contains the following functions:

• Calling of reports
• Processing of reports
• Definition of reports using the Report Painter [Seite 726] and the Report Writer [Seite 797]
• Creation and output of reports and evaluation of FI-SL summary tables with Drilldown Reporting [Seite 630].
Report Painter / Report Writer

Purpose
The SAP System provides comprehensive and flexible reporting tools for the analysis of existing cost flows in an enterprise. You can use these both to carry out recurring standard evaluations and to create reports for extraordinary queries and tasks. You can analyze data interactively as soon as it has been created in the SAP System and trace its origins right down to document level. All reports that are available online can also be executed in the background. This is particularly important in the case of very extensive datasets.

For objects with a hierarchical structure, such as cost centers, you can either create single reports for all the nodes in the hierarchy and for the individual objects, or you can generate all the relevant reports via the database in a selection run. If you choose the second possibility, you can navigate interactively within the hierarchy. This offers, among other things, a very flexible control of cost center areas, for example.

Report Painter and Report Writer are two very comprehensive reporting tools provided by SAP, using which you can report data from the Special Purpose Ledger (FI-SL) and other application components.

Integration
When defining reports using Report Painter or Report Writer, FI-SL tools, such as sets [Seite 633], variables [Seite 689] and key figures [Seite 708], are also used.

Features
The Report Painter [Extern] and Report Writer [Extern] provide the following functions:

- Report call
- Report processing
- Report definition

For more information on working with reporting tools, see:

Report Painter or Report Writer? [Seite 724]
Report Painter [Seite 726]
Working with the Report Painter [Seite 728]
Report Writer [Seite 797]
Working with the Report Writer [Seite 800]

Example
You can see an example of a Report Painter report under Creating an Example Actual/Plan Comparison Report Using the Report Painter [Seite 736].
Report Painter or Report Writer?

**Use**

The Report Painter and Report Writer are tools used to define reports.

The **Report Painter** is similar to the Report Writer, but is simpler to use. Most of the functions in the Report Writer are also available in the Report Painter. To create Report Painter reports, you do not need extensive knowledge of Report Writer concepts (such as sets [Seite 633]).

When Report Painter reports are executed they are displayed as Report Writer reports. They thus have the same functions as correspondingly defined Report Writer reports and can be combined with Report Writer reports in one report group.

The Report Painter uses a graphical report structure, which forms the basis for your report definition and displays the rows and columns as they will appear in the final report output, making test runs unnecessary.

To facilitate report definition, you can use many of the standard reporting objects provided by SAP, such as libraries, row/column models, and standard layouts, in your own specific reports. When you define a Report Painter report, you can use groups (sets), but you can also enter the characteristic values directly.

For more information on the Report Painter, see **Report Painter [Seite 726]**.

The **Report Writer** has extensive functions that require a certain amount of familiarization.

As the Report Painter includes most of the functions available in Report Writer and is also simpler to use, we recommend that you use the Report Painter as a general rule.

For more information on Report Writer, see **Report Writer [Seite 797]**.

**Integration**

The main difference between the two tools is the graphical user interface of the Report Painter. The use of sets in Report Writer is another difference. The differences are presented in the following diagram:
For more information, see Report Painter reports [Externa] and Report Writer reports [Sia 804].
Report Painter

Purpose
You use the Report Painter to create reports from data in the Special Purpose Ledger (FI-SL) application component and other R/3 application components to meet your specific reporting requirements.

Many reporting requirements can be met using the standard reports provided by various R/3 application components. However, if your reporting requirements are not fulfilled by SAP’s standard reports, you can use the Report Painter to quickly and easily define your own reports.

The Special Purpose Ledger (FI-SL) application component does not provide any standard Report Painter reports because you must first install your FI-SL system setup (database tables and so on) to meet your specific business requirements.

Advantages of the Report Painter include:

- Easy and flexible report definition
- Report definition without using sets
- Direct layout control

Integration
The Report Painter is similar to the Report Writer [Seite 797], but is easier to use. Many of the Report Writer functions are available in the Report Painter, but you do not need to be familiar with Report Writer concepts (such as sets) to be able to use the Report Painter.

To facilitate report definition, you can use many of the standard reporting objects provided by SAP (such as libraries, row/column models, and standard layouts) in your own specific reports. When you create a Report Painter report, you can use groups (sets), but you can also enter characteristic values directly.

Features
You define Report Painter reports using a graphical report structure, which forms the basis for the report definition. This graphical structure displays the report rows and columns as they will appear in the final report when the report data is output. When you execute a Report Painter report, the system automatically converts the Report Painter report into Report Writer format.

You will find a procedure for creating a Report Painter report under Creating a Report Painter Report [Seite 811].

You can add multiple reports to a report group. You can switch back and forth between the reports in a report group.
If the system takes a long time to select the data for the report, SAP recommends that you store the selected data in an extract. Once data is stored in an extract, it can be output later without having to be selected again.

**Converting a Report Painter Report into a Report Writer Report**

Since the Report Painter does not currently support all the functions of the Report Writer, you can convert a Report Painter report into a Report Writer report so that you can use the complete range of functions provided by the Report Writer. To do this, follow the procedure for creating a new Report Writer report using the Report Painter report as a basis. The Report Painter report is copied and becomes available as a Report Writer report. The system generates the required sets automatically.

You cannot, however, edit the sets generated in this way using the set maintenance function. Nor can you use these sets in other reports or functions.

**Example**

You will find a detailed example for creating a Report Painter report under Create Actual/Plan Comparison Report [Seite 741].
Working with the Report Painter

**Purpose**

This process describes the main steps in creating a Report Painter report.

The steps that you carry out to create a Report Painter report may deviate slightly from the following description. This depends on how complex your reports are and whether you are using the standard objects of SAP reporting.

**Process Flow**

1. **Select a library for your report.**

   All reports are assigned to libraries. A library is a collection of characteristics, basic key figures, and key figures. Reports that are assigned to a particular library can use only the characteristics, basic key figure, and key figures of that library.

   You can either use the standard SAP libraries or create your own.

   For more information, see Libraries [Seite 927].

2. **Select a standard layout for the report.**

   The standard layout [Seite 1017] determines the layout features of the report and the format of your report data.

   If the SAP standard layouts do not meet your reporting requirements, you can create a new standard layout or change an existing one.

   You can also adapt the report layout [Seite 1029] to your individual requirements, and define special section layouts [Seite 1028] for particular sections of the report.

   For more information, see Layout [Seite 1016].

3. **Define row and column models.**

   A model is a one-dimensional, predefined reporting structure, which you can insert in either the rows or columns of your report.

   If you often use the same or similar row or column definitions in your reports, we recommend that you create row or column models.

   You must define the row and/or column models that you want to include in your report definition before you define the report.

   You can also use the standard models provided by SAP. For more information, see Defining Row and Column Models [Seite 744].

4. **Define the report.**

   a) **Define the report columns.**

      You define the report columns using the key figures selected for the library that the report uses. The key figures consist of the basic key figure and any characteristics you added.
Alternatively, you can use a column model for your column definition.

For more information, see Defining Columns [Seite 748].

b) Define the report rows.

You define the report rows using the characteristics selected for the library that the report uses.

Alternatively, you can use a row model for your row definition.

For more information, see Defining Rows [Seite 751].

c) Edit and format the report rows and columns in accordance with your requirements. (For example, you can hide rows and columns, and change the column widths and row colors.)

For more information, see Formatting Rows and Columns [Seite 755].

d) Define the general data selection criteria for selecting report data.

The selection criteria are the characteristics used to select data for the entire report. You cannot enter characteristics as data selection criteria if they are already being used in the report rows or columns.

For more information, see General Data Selection [Seite 762].

5. Assign the report to a report group.

Once you have defined a report, you assign it to a report group. A report group can contain one or more reports from the same library.

You can assign Report Painter reports and Report Writer reports to the same report groups.

For more information, see Report Groups [Seite 937].
Working with the Report Painter

6. **Generate the report group.**

   During this step, the system generates the programs necessary for processing the reports.

   When you generate a report group, the Report Painter reports are converted into Report Writer format. However, you can only change or display Report Painter reports using the Report Painter tool.

   For more information, see [Generating a Report Group][952].

7. **Execute the report group.**

   In this step, the system selects the data records specified by the report definition, and outputs them in the specified format.

   For more information, see [Report Group Execution][962].
Defining Reports for the Report/Report Interface

Use

The report/report interface allows you to call reports from other R/3 application components when you output your report data. You can call up report portfolio reports, drilldown reports, transactions, receiver reports, Report Writer reports, Report Painter reports, and ABAP programs.

If you define reports for the report/report interface in both the report group header and in the report group’s library, the system uses the reports that you have defined specifically for the report group.

Example

Your system is delivered with an ABAP program called RGGD1300, which displays line items for the FI-SL summary tables. The program reads the data from the FI-SL line item table and outputs a list of the line items.

You can call up program RGGD1300 directly (System → Services → Reporting) or from the report/report interface if it is defined as a receiver report for another Report Writer report. In a report that displays totals, you can then display the line items for a specific totals record.

To call program RGGD1300 as a receiver report to display line items for totals data in a report:

Procedure for Example

   Choose the symbol ☟ Header.
2. The group box Report/report interface contains information on the current assignment of the reports in this report group to the library of the report group. To assign a report to the report group, choose Configure…. The Assign Reports dialog box appears.
3. To enter a receiver report for the report/report interface, choose Insert row ☞.
4. To enter program RGGD1300 as the receiver report, choose Other Report Type.
   A dialog box appears, listing the possible report types.
   The receiver reports you assign can be report portfolio reports, drilldown reports, transactions, Report Writer reports, and ABAP programs. This enables you to call receiver reports from other R/3 application components once you have output your report data.
Defining Reports for the Report/Report Interface

You should normally assign receiver reports to the report group.

In this example, we are using the ABAP program RGGD1300 as the receiver report.


6. Enter RGGD1300 as the receiver report and choose 🍃.

   The default text of program RGGD1300 is displayed in the Assign Reports dialog box.

7. You can use the following additional processing functions in this dialog box:

   **Additional Processing Functions - Dialog Box for Report/Report Interface**

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save receiver report for report/report interface</td>
<td>✉️ Save</td>
</tr>
<tr>
<td>Add receiver report to report/report interface definition</td>
<td>✉️ Insert row</td>
</tr>
<tr>
<td>Delete entry in report/report interface definition</td>
<td>✉️ Delete row</td>
</tr>
<tr>
<td>Insert report from another system (cross-system report assignment).</td>
<td>✉️ Add external report</td>
</tr>
<tr>
<td>You log on to the other system, select a receiver report, and transfer it to the sender system.</td>
<td></td>
</tr>
<tr>
<td>Select one or more receiver reports for further processing (for example, to move the selected report to another position in the list)</td>
<td>✉️ Select line</td>
</tr>
<tr>
<td>Move selected receiver report to another position in the list. If the cursor is positioned on a receiver report, the selected report is inserted before this receiver report. If the cursor is not positioned on a receiver report, the selected report is inserted at the end of the list.</td>
<td>✉️ Move</td>
</tr>
<tr>
<td>Display default text of a receiver report if you have previously overwritten the default text of the report. Note: when you first enter a receiver report, the default text for this report is automatically displayed.</td>
<td>✉️ Default text</td>
</tr>
<tr>
<td>Display all reports to which the specified sender report is assigned as the receiver report. If you activate this function again, the original list is displayed.</td>
<td>✉️ Sender &lt;-&gt; Receiver</td>
</tr>
<tr>
<td>Display technical information on the receiver report(s) (for example, the report tool and the technical report name)</td>
<td>✉️ Technical names on/off</td>
</tr>
<tr>
<td>Documentation on displaying and maintaining the report assignment in the report/report interface</td>
<td>✉️ Help</td>
</tr>
</tbody>
</table>

8. Choose 🍃 to save your entries.

**Example**

The Report Writer uses ABAP program RGGD1300 as shown in the following graphic:
The report in the graphic displays accounts by periods. This report is assigned to report group TD00. Report group TD00 has been defined such that ABAP program RGGD1300 is a receiver report in the report group (on the Create Report Group: Header screen).

Program RGGD1300 is called up with the Report Writer as follows:

a) After selecting the report data for the report, the system displays the report.
   You can select part of the displayed report and have the system display the
   associated line items.

b) Select amount 600 for account 4000020 in period 1 from the report.

c) When you choose Reports, the system generates a list of the reports that are defined
   as receiver reports in report group TD00 (Create Report Group: Header screen).

d) Select program RGGD1300.

e) The Report Writer adopts the selection criteria from the report (such as the company
   code, ledger, account, and period) and starts the ABAP program RGGD1300. This
   program displays the line items that meet the selection criteria (company code TD11,
   ledger D2, account 4000020, period 1).

For more information on calling receiver reports, see Functions in the Report Output
[Seite 974].
Creating a Report Painter Report

Procedure

1. From the relevant application, choose Tools → Report Painter → Report → Create.

Enter the name of the library the report is to use, and a name and description for the report. The report name can be a maximum of eight characters long.

If you want to create your report using an existing Report Painter report as a basis, enter the name of the report that you want to copy under Copy from. Both reports must use the same library.

4. Choose Create.
   The next screen displays an empty report containing four rows and four columns (this is the basic structure for a report). You define your report on this screen.

5. Enter or change the description for the report by double-clicking the report description field.
   A dialog box appears in which you can enter a short, medium, and long text for the report description.

6. Define the rows of your report (see Defining Rows [Seite 751]).
   Rows contain a combination of characteristic values or formulas. Note the lead column at the first position of the rows. The Report Painter uses the lead column to access the rows. You can replace the description Lead column with a different term.

7. Define the columns of your report (see Defining Columns [Seite 748]).
   Columns contain a combination of a basic key figure and optional restricting characteristic values. You can also use predefined key figures to present key figures and characteristics that make business sense. For example, a number of predefined key figures are delivered for the libraries in Overhead Cost Controlling that can be copied directly into the reports, where they can be modified as required.

8. Define general data selection criteria (see General Data Selection [Seite 762]).
   The general data selection criteria restrict data selection for the report.

9. Choose Save and then Execute to create the report.

10. Assign the report to a report group [Seite 937].

   You have to display the report before you execute it, so that you can later change the report layout directly from the report list.
Once you have defined a report, you can display and print out a table of contents with *Extras → Overview*.

The overview contains the characteristics and characteristic values used in the individual sections, column blocks, and general data selection criteria. It also provides general information such as the user who last changed the report, the report name, and the standard layout assigned to the report, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.

For more information, see:
- Defining Report Headers [Seite 817]
- Defining Report Text [Seite 825]
- Defining Report Layouts [Seite 1031]
- Defining Cells [Seite 864]
- Defining Global Cells [Seite 870]
- Defining Report Documentation [Seite 945]
Creating an Example Actual/Plan Comparison Report Using the Report Painter

This section shows how a Report Painter report is created, using the example of an actual/plan comparison report.

Reporting Requirements

You want the actual/plan comparison report to contain the following information:

- Actual and plan values from different business areas
- The absolute and percentage variances between the actual and plan values
- All periods in the fiscal year

Before you define the report, you must decide the following:

- Which characteristics should be used in the report?
- Where should the characteristics be entered in the report definition (in the rows, columns, or as data selection criteria)?
- Which characteristics should be entered as variables, individual values, value intervals, or groups?

A given characteristic can only be used once in a report: in the report rows, report columns, or as data selection criteria.

The following characteristics are used in the example actual/plan comparison report:

- Characteristics in general data selection:
  - Ledger
  - Company code
  - Fiscal year
  - Period

- Characteristics in the report rows:
  - Account
  - Business area

- Characteristics in the report columns:
  - Basic key figures
  - Record type
  - Version

Before you define your report, you must define the variables that you want to use in the report definition.

Define the following variables for the actual/plan comparison report (the names for the variables are example names only):
Creating an Example Actual/Plan Comparison Report Using the Report Painter

Variables Used in the Example Actual/Plan Comparison Report

<table>
<thead>
<tr>
<th>Variables</th>
<th>Variable type</th>
<th>Default value</th>
<th>Used in the report</th>
</tr>
</thead>
<tbody>
<tr>
<td>YEAR</td>
<td>Formula</td>
<td>Current year (for example, 2001)</td>
<td>As data selection criteria for the characteristic Fiscal Year</td>
</tr>
<tr>
<td>FPER</td>
<td>Value</td>
<td>01</td>
<td>As data selection criteria for the characteristic Period</td>
</tr>
<tr>
<td>TPER</td>
<td>Value</td>
<td>12</td>
<td>As data selection criteria for the characteristic Period</td>
</tr>
<tr>
<td>PLANVER</td>
<td>Value</td>
<td>001</td>
<td>In the report column for the characteristic Version</td>
</tr>
</tbody>
</table>

To create variables on the Report Painter screen, choose Report Writer → Variable → Create. For more information, see Creating Variables [Seite 692].

Defining Report Rows

You define the report rows by choosing Edit → Elements → Insert element or by double-clicking on the relevant cell.

Accounts and business areas should be listed in the report rows. To enter this information, you can define one report row that contains the characteristics Account and Business Area. You select the characteristics from the list in the dialog box. This list contains all the characteristics selected for the report’s library.

To define values for the characteristics Account and Business Area, enter specific values, value intervals, or groups. The report will always be created for the values you enter here.

To be able to vary the input values for the characteristics when you run the report, you should enter variables using 

In this example report, we have not entered variables for the characteristics Account and Business Area.

Exploding Report Rows

If you entered a group for the characteristics Account and/or Business Area, you should display the values in the report for the individual accounts/business areas and create subtotals for the different hierarchy levels of the group.

Choose Edit → Rows → Explode. The default setting Do not expand means that only a row total is displayed for the account/business area group. The SingleVals indicator displays individual values, but no subtotals or totals. Select PartSets to display the individual values, subtotals, and a total for the characteristic Account and/or Business Area. Exploded subtotals and totals are displayed in the report definition with summation levels (asterisk).

For more information, see Exploding Report Rows [Seite 753].
Defining Report Columns

In the report columns, you want to display the actual and plan values for the selected periods. In addition, you want the columns to display the variance between actual and plan in absolute numbers and as percentages.

You define report columns using the same procedure as that used for defining the report rows.

You can also enter basic key figures in your report columns. These are the basic key figures selected for the library that your report uses.

- **Column 1: Actual Values in Local Currency**

  You should enter the following characteristics and characteristic values for the *Actual* column:

<table>
<thead>
<tr>
<th>Basic key figure</th>
<th>“Local currency” (HSL)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Characteristic 1: record type</td>
<td>0 (actual)</td>
</tr>
<tr>
<td>Characteristic 2: version</td>
<td>001</td>
</tr>
</tbody>
</table>

- **Column 2: Plan Values in Local Currency**

  You should enter the following characteristics and characteristic values for the *Plan* column:

<table>
<thead>
<tr>
<th>Basic key figure</th>
<th>“Local currency” (HSL)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Characteristic 1: record type</td>
<td>1 (plan)</td>
</tr>
<tr>
<td>Characteristic 2: version</td>
<td>&amp;PLANVER</td>
</tr>
</tbody>
</table>

  The *Plan* column uses a variable for the characteristic *Version*.

To simplify defining the report, you can create the *Plan* column by copying the *Actual* column. You use the *Select and Copy* functions to copy the column element. You can then modify the copied column as required.

- **Column 3 and 4: Absolute Variance/Percentage Variance**

  You define the absolute and percentage variance columns by entering formulas in the formula builder. The formulas are calculated using the column elements that you have just defined. Before leaving the formula builder, you should check that the formula is correct using the *Check* function.

Enter text for the report columns. Enter the column text the same way you enter row text.

Defining General Data Selection Criteria

The characteristics entered as data selection criteria determine which data is selected for the entire report.

You define general data selection criteria under *Edit → General data selection*.

Enter the following characteristics and characteristic values for the example actual/plan comparison report:
Creating an Example Actual/Plan Comparison Report Using the Report Painter

- Company code: As required
- Ledger: As required
- Fiscal year: &YEAR
- From period: &FPER
- To period: &TPER

The characteristics Fiscal Year and Period are variables. This allows you to run the report for any periods within a given fiscal year. When you execute the report’s report group, the system prompts you to enter values for these variables on the selection screen. You can either use the default value of the variable or overwrite the default with a different value.

**Defining Report Texts**

You can define texts for the title page, headers, footers, end page (last page), and for the text for export under Extras → Report texts.

You can define normal text, as well as text variables in your report text. You can use the following types of text variable:

- Standard text variables
- Special text variables
- Text variables for selection parameters
- Text variables for characteristics

For more information about these text variables and entering report texts, see Using Variables in Report Text Definition [Seite 826].

**Changing the Standard Layout**

The standard layout determines the layout of your report. For example, the standard layout defines the page format (such as the margins) and the numerical format of the data in the report. The standard layout SAP is assigned to your report automatically. To assign a different standard layout to your report, choose Formatting → Report layout.

If you assign a new standard layout to your report, the layout formats of the new standard layout replace any layout changes you made that are specific to the report you are editing. (The system displays a dialog box, asking you if you want to change the current format settings.)

You can also make certain layout changes within the report definition under Formatting.

**Checking the Report, Assigning a Report Group, Report Execution**

After you have saved your report definition, make sure it does not contain any errors by choosing Report → Check. If there are any errors, the system lists them in an error log. You should correct the errors shown in the error log before assigning the report to a report group.

Once the report definition is free of errors, you can assign your report to a report group by choosing Environment → Assign report group. If the report group you enter does not exist, a
Creating an Example Actual/Plan Comparison Report Using the Report Painter

dialog box asks if you want to create the report group. To create the report group and add the report to it, choose Yes.

To execute the report, choose Report → Execute. If you have not yet assigned the report to a report group, you can do so at this point. Once the system has generated the report group, you can enter the criteria for selecting the data records on the selection screen.

For more information on executing report groups, see Report Group Execution [Seite 962].
Create Actual/Plan Comparison Report

Use

This section shows you step by step how to create an actual/plan comparison report with the Report Painter. The report contains information about the actual and plan values of various business areas.

The following information is contained in the report:

<table>
<thead>
<tr>
<th></th>
<th>Actual costs</th>
<th>Plan costs</th>
<th>Difference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Salaries</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Office space</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Travel costs</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Office supplies</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>*Total of all accounts</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Procedure

1. Choose Information systems → Ad-Hoc Reports → Report Painter → Report → Create. In the Report Painter: Create Report screen, enter Library 1VK, assign your report an name, such as Test01, and a description, such as report with totals. Choose Create.

2. Defining Rows:

   You can edit a row by double-clicking on it. For the first row, choose Cost element from the available characteristics in the dialog box Element definition: Row 1. In the From field for the cost element, enter 430000 (Wages account). Choose the Change short, middle and long texts button and enter wages as the short text. Press the Copy short text button to copy the short text entered to the other two text fields. Exit the text creation screen with Confirm. The dialog box Element definition: Wages screen is displayed. Choose confirm. The definition of row 1 is now complete.

   For all other rows, proceed in the same manner. When creating additional rows, you can select the element type. Select Characteristics in the Select element type dialog box and then choose Confirm. Use the following accounts:

<table>
<thead>
<tr>
<th>Account name</th>
<th>Accounts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Office space</td>
<td>470000</td>
</tr>
<tr>
<td>Travel costs</td>
<td>474100</td>
</tr>
<tr>
<td>Office supplies</td>
<td>476000</td>
</tr>
</tbody>
</table>

3. Defining a formula row (totals row)

   To enter the totals row (row 5), in the Select element type dialog box, select Formula and then choose Confirm. In the Enter formula dialog box, add all parts of the formula: Y001 + Y002 + Y003 + Y004 and then choose Confirm. In the Enter texts dialog box, enter a text such as total of accounts in the short text field and copy it to the other text fields.

4. Define Column 1 (Actual costs)
Create Actual/Plan Comparison Report

You can edit a column by double-clicking on it. For the first column, in the Select element type dialog box select the element type Predefined key figure and choose confirm. In the Choose predefined column dialog box, select Actual costs and choose confirm. In the following Element definition: Actual cost screen, you can see how the predefined key figure has been defined. Choose confirm. Column 1 is defined.

5. Define Column 2 (Plan costs)

To define the second column, in the Select element type dialog box select the element type Key figure with characteristics and choose confirm. In the Element definition: Column 2 dialog box, enter value type 01 in the From field for plan values. Enter 0 for the version (current version). Enter 0 for the actual valuation. Choose the Change short, middle and long texts button and enter a text such as plan costs. Choose Confirm in the Element definition: Plan cost dialog box. Column 2 is defined.

6. Define formula column (difference)

To define the third column, in the Select element type dialog box select the element type Formula and choose confirm. In the Enter formula dialog box, enter the parts of the formula (X001 - X002) to define the difference. Choose Confirm and enter Difference as the text in the Enter text dialog box. Copy the short text and choose Confirm. The formula column is defined.

7. Define General Selections

Choose Edit \rightarrow General data selection. The Element definition: General data selection dialog box is displayed. Select the values controlling area, fiscal year, period, and cost center from the available characteristics. Make the following entries for these characteristics:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Entry field</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area</td>
<td>From</td>
<td>1000</td>
</tr>
<tr>
<td>Fiscal year</td>
<td>From</td>
<td>Current fiscal year</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(2000, for example)</td>
</tr>
<tr>
<td>Period</td>
<td>From</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>To</td>
<td>12</td>
</tr>
<tr>
<td>Cost center</td>
<td>Select the Group field and make your entry in the From field.</td>
<td>H1010</td>
</tr>
</tbody>
</table>

Choose confirm. The general data selections are defined.

8. Check and save report

Check the report for errors or missing characteristics by choosing Report \rightarrow Check. Save your report by choosing Report \rightarrow Save.

9. Assign report to a report group

Choose Environment \rightarrow Assign report group to assign your report to a report group. In the Insert Report in Report Group dialog box, enter the name of the report group to which the report is to be assigned. You can use an existing report group for library 1VK or you can create a new report group for library 1VK. Enter a name for the report group, such as TEST. If this is a new report group, a dialog box will appear and you will be asked if you want to create a new report group. If you choose Yes, your report is included in this report group.
10. Execute report

Defining Row and Column Models

Purpose

If you often use the same or similar row or column definitions in your reports, it is recommended that you create row or column models.

A model is a one-dimensional, predefined reporting structure which you can insert in either the rows or columns of your report.

The following graphic shows how you can use row and column models in a report definition.

Process Flow

To be able to use models in a report, you need to carry out the following steps:

Creating a Model [Seite 745]
Applying a Model [Seite 746]
Transporting Models [Seite 747]
Creating a Model

1. To create a row or column model, choose Model → Create from the Report Painter [Extern] menu.

2. In the initial screen, you enter whether you want to define a column or a row model. This is where you determine the functions available for editing purposes.

3. Before you create the model, you must first assign it to a library [Extern]. The library contains the characteristics, key figures, and predefined columns which you can use in your model. All models and reports that use these models must be assigned to the same library.

4. Enter a name and short description for each model.

5. If you want to create a model using an existing model as a reference, enter the name of the existing model you wish to copy, or choose Model Copy, then enter the model and library.

6. You create row and column models with Report Painter in the same way as you create rows and columns in a report (see Creating Report Painter Reports [Seite 811]). In contrast to a report, however, models are only one-dimensional and do not contain any report texts.

   When defining a column model, you can only use the functions available for defining columns. You cannot use the Explode, Expand or Collapse functions for column models.

7. You can define several column blocks within column models. However, you cannot define different report sections within models.

8. Once you have defined your model, you should check for any errors using Model → Check.

9. After you have defined your row and column models, you can go directly to the report definition with Environment → Create report.

   Simplified definition of reports is made possible by a number of predefined row and column models.

   Row model 1-LM-BEL-ENT identifies all cost elements separately according to debit and credit postings and calculates any over- or under-absorption in a totals row.

   Column model 1-CM-QUARTAL displays the actual costs for all four quarters as well as for the complete fiscal year.
Inserting a Model

To insert row or column models in your report, put your cursor in the corresponding place and choose:

1. **Edit → Rows → Get row model**
   or **Edit → Columns → Get column model**
   When you insert the model, it overwrites all previously defined row and column definitions for that report section. For this reason, you should define additional report rows/columns only after you insert the model.

2. **Edit → Rows → Insert row model**
   or **Edit → Columns → Insert column model**
   The model is added to the defined report as the last row or column. No other row or column is overwritten.

   You can only use a characteristic in the report rows, columns or in the general selection criteria.

   Ensure that when you define a row, the characteristics used for it are not already being used in a column or in the general selection.

   Ensure that when you define a column, the characteristics used for it are not already being used in a row or in the general selection.
Transporting Models

Choose Utilities → Transport → Models in the Report-Painter [Extern] menu to export models to external files, import models from external files or to copy models from a source client.

The procedure is the same as for transporting Report-Writer [Extern] objects.

For more information on transport functions, see the SAP Library under AC - Accounting → FI - Financials → Special Purpose Ledger → Report-Writer Utilities → Transporting Report-Writer-Objects [Seite 915].
Defining Columns

1. Position the cursor on the column you want to define, and choose Edit → Elements → Insert element, or double-click the element.

2. In the subsequent dialog box, specify what type the element should be:
   - Key figure with characteristics
     You combine a basic key figure with the characteristics you require.
   - Predefined key figure
     An appropriate combination of a basic key figure and one or more characteristics is offered by the system. You can accept the predefined key figure or change it.
   - Formula
     This option is only available if other elements are already defined.
     You can use the formula builder to calculate the values of the column. You can use other columns or previously defined cells for the calculation.

For information on the terminology of the elements, see Terminology [Seite 1037].

3. Choose Confirm.
   a. If you chose key figure with characteristics,
      a dialog box appears on which you can select the combination of basic key figure and associated characteristics to be displayed in the column being defined.
      In the upper area of the dialog box, select the basic key figure that you want to use in the report.
      From the list of available characteristics on the right-hand side of the dialog box, choose the characteristics you want to use. Move these to the left-hand side of the screen with the arrow. The characteristics displayed are those of the library assigned to your report. The order in which the characteristics appear in the selection list is determined by the Position field in the library definition.
      On the left-hand side of the dialog box, enter the values for the selected characteristic(s):
        - You can enter individual values, intervals of values, or groups for the chosen characteristic(s).
        - If you want to define all possible values for the chosen characteristic(s), enter an asterisk (*).
        - If you want to specify an initial value for the chosen characteristic(s), enter a pound sign (#).
        - If you want to enter a variable instead of a characteristic value, select . Enter the name of the variable and choose Confirm. You can only enter variables that already exist in your system. For more information, see Variables [Seite 689].
        - If you want to enter a characteristic value in the form of a set, select . Enter the name of the set and choose Confirm. You can only enter sets that already
exist in the system. For more information, see [Sets in Report Columns [Seite 898]].

b. If you chose predefined key figure,
a list of predefined key figures is displayed, from which you can choose the key figure you want to use.

In the subsequent dialog box, you only need to enter the values for the characteristics. You can also change the key figure at this point, as described under key figure with characteristics.

c. If you chose formula,
a formula builder is displayed with which you can define a formula using other report columns and the previously defined cells. The column is calculated using the formula.

You can define formulas that refer to elements in different column blocks. However, you can only define formulas within one report section.

4. Choose and enter short, medium, and long texts for the column.
5. Choose Check and then Confirm.
6. To define additional columns, carry out steps 1 to 5 again.

You can copy report columns. Select a column and position the cursor where you want to insert the column. Choose Edit → Selected area → Copy. You can then change the copied column as desired.

You may find it useful to use sets to define entire blocks of columns. For more information, see the SAP Library under Creating Sets [Seite 651] and Using Sets in Report Columns [Seite 898].

**Column Texts**

If you want to change the text you entered for the report column, you can simply overtype the column text or position the cursor on the column element and choose Edit → Elements → Change text.

Under Formatting → Row/column texts you can specify which of the three text formats (short, medium, long) you want to use in the column header.

You can also use variables in your column headings. When you execute the report, the variables will be replaced with their default values if the column text type Key is selected in the report’s standard layout. To use a variable for the column text, enter the variable in the dialog box for the three column texts. First enter & and then the name of the variable.

Suppose your report uses the value variable &PERIOD for the period, and you want to display the current value for the period in a column heading. Enter <&PERIOD> in the column heading of the report. If the column text type Key is selected in your report’s standard layout, the variable is replaced with the period value (for example,
5) when you execute the report. The description is printed for all other column text types (for example, May).

**Editing Columns**

The options under *Edit → Columns* allow you to select a variety of functions for editing report columns.

The option *Edit → Get column model or Insert column model* inserts a predefined column structure into your report columns. For more information, see *Defining Row and Column Models [Seite 744]*.

The *Edit → Columns → Hide* function hides the report row on which the cursor is positioned. You can process hidden columns in the same manner as the hidden rows.

**Using Formula Variables in Report Columns**

A formula variable represents a user-defined formula that establishes a value for the variable. Numerical value variables and formula variables can be used as operands in column formulas. Using formula variables in report columns enables you to create new types of reports.

For more information, see *Formula Variables in Reports [Seite 859]*.
Defining Rows

Rows in a report are defined in a similar way to columns. However, you cannot enter predefined key figures in rows. You define row elements using basic key figures in combination with the characteristics selected for the library that the report uses. You can also use formulas.

Procedure

3. Position the cursor on the row you want to define, and choose Edit → Elements → Insert element, or double-click the element. For information on the terminology of elements, see Terminology [Seite 1037].

2. Define the row.

   If no other rows exist in the section, a dialog box appears on which you can select the combination of basic key figure and associated characteristics to be displayed in the row being defined.

   In the upper area of the dialog box, select the basic key figure that you want to use in the report.

   From the list of available characteristics on the right-hand side of the dialog box, choose the characteristics you want to use. Use the arrow to move these to the left-hand side of the screen. The characteristics displayed are those of the library assigned to your report. The order in which the characteristics appear in the selection list is determined by the Position field in the library definition.

   On the left-hand side of the dialog box, enter the values for the selected characteristic(s):

   - You can enter individual values, intervals of values, or groups for the chosen characteristic(s).

   - If you want to define all possible values for the chosen characteristic(s), enter an asterisk (*).

   - If you want to specify an initial value for the chosen characteristic(s), enter a pound sign (#).

   - If you want to enter a variable instead of a characteristic value, select . Enter the name of the variable and choose Confirm. You can only enter variables that already exist in your system. For more information, see Variables [Seite 689].

   - If you want to enter a characteristic value in the form of a set, select . Enter the name of the set and choose Confirm. You can only enter sets that already exist in the system. For more information, see Sets in Report Rows [Seite 898].

   For performance reasons, you should use sets whenever possible.

   If rows have been defined in the section, you can also insert a formula. From the dialog box, choose Formula. A formula builder is displayed with which you can define a formula using other report rows and the previously defined cells. The row is calculated using the formula.
Defining Rows

You can define formulas that refer to elements in different row blocks. However, you can only define formulas within one report section.

7. Choose and enter short, medium, and long texts for the row.
8. Choose Check and then Confirm.
9. To define additional rows, carry out steps 1 to 5 again.

   You can copy report rows. Select a row and position the cursor where you want to insert it. Choose Edit → Selected area → Copy. You can then modify the copied row as desired.

   You may find it useful to use sets to define entire blocks of rows. For more information, see the SAP Library under Creating Sets [Seite 651] and Sets in Report Rows [Seite 894].

Editing Rows

Under Edit → Rows there are a number of special functions for editing report rows. Get row model inserts a predefined row structure in your report rows. For more information, see Defining Row and Column Models [Seite 744]. Insert blank line inserts a blank line in the current row (where the cursor is positioned).

Edit → Rows → Hide hides the row on which the cursor is positioned. The hidden row retains its contents and can still be used in formulas. You can edit hidden rows with Hidden rows → Change. You can also delete and display the hidden rows (Delete and Show functions).

Edit → Rows → Explode expands the hierarchical levels of the group/value interval defined for the row characteristic. For more information, see Exploding Report Rows [Seite 753].
Exploding Report Rows

Use

You use the Explode function to specify whether individual values only, a sum only, or individual values with totals and subtotals are to be displayed for the characteristics used in the report rows.

If you have defined more than one characteristic in a report row, you can define the order in which the characteristics are displayed in the report.

Procedure

1. To explode a report row, position the cursor on the report row and choose Edit → Rows → Explode.

2. The Explode characteristics dialog box lists the row characteristics for which you have entered an interval of values, a group, or a variable. You can use the Explode function for each of these characteristics.

   In the standard system, the No explode indicator is set as the default. A row total only is displayed in the report for the characteristic.

   a. If you select Single values, only individual values are displayed in the report for the characteristic. Sums are not displayed in the report.

      It is advisable to select Single values for characteristics for which you do not usually calculate sums, such as statistical key figures or activity types.

   b. If you select Explode, the report displays single values, subtotals, and a grand total. Subtotals are calculated based on the hierarchical structure of the characteristic.

      You can specify the hierarchical sequence in which the characteristics are output in the report rows. The characteristic assigned number 1 appears at the highest level of the hierarchy. For each value defined for this characteristic, data is summarized for all of the characteristics below it in the hierarchy.

      You entered the characteristics cost center and account in a report row for cost centers 100, 200, and 300 and accounts 4000010 and 4000020. If you assign number 1 to cost center and number 2 to account, the report breaks down cost centers by accounts. If you switch the order, the report breaks down accounts by cost centers.

   c. You can use the function Display sort order to display the characteristics in the order you have defined.

      Exploded report rows are displayed with one or more asterisks in the report definition, depending on the row summation level.

      If you enter a group as the characteristic value for a report row, the hierarchical structure of this group is depicted in the report definition. If you set the Explode indicator for this row, all subtotals and the sum total are displayed for this group in the report definition,
Exploding Report Rows

together with the corresponding number of asterisks. The lowest level in the group (usually the individual values) are not displayed in the report definition.

Suppose you define a report row for the characteristic account and enter the group (the set) ACCOUNTS as the characteristic value. (The group ACCOUNTS is a single-dimension set containing income and expense accounts.) If you select *Explode* for the ACCOUNTS group, the report definition displays a totals row for all accounts, and subtotals rows for the income and expense accounts. The individual account values, however, are not displayed in the report definition.

If you enter a set variable as the characteristic value, the row structure is only determined when you output the report. The default set assigned to the set variable displays in the report definition. When you execute the report, you can overtype this default set on the selection screen if you want.

Suppose you define a report row for the characteristic account and enter the set variable ACCT as the group characteristic value. The default set of the variable only has one summation level. In the report definition, the exploded row is displayed with only one asterisk.
Formatting Rows and Columns

Column Formats

• Assigning a Standard Layout and Format Groups

You define the format of your report columns using format groups. These format groups tell the Report Painter which format to use in each report column. You can define up to five format groups, allowing you to use five different column formats in your report.

A format group is used to determine the following layout parameters:

– Column width
– Right column margin
– Display unit
– Decimal places
– Scaling factor
– Reverse +/- sign

You define the layout parameters for the different format groups in the report layout [Seite 1029] assigned to the report. The report layout also contains information on the report page layout and text formats. For more information on standard layouts, see Standard Layouts [Seite 1017] and Creating a Standard Layout [Seite 1019].

You can display the standard layout assigned to your report with Formatting → Report layout. In the dialog box displayed, you can make changes to the report layout. The function Use standard layout assigns the new layout to the report as the standard layout.

The Format group row in the report definition displays the format group currently assigned to each report column. Format group 0 is automatically set as the default for all columns. To change the format group assigned to a column, double-click the format group field and select the desired format group. The column is then formatted according to the layout parameters for the specified format group.

• Changing the Default Settings of Format Groups

You can overwrite the default layout parameters for individual format groups in your report. These changes are only valid for the report that you are currently editing. To do so, position the cursor on the column to which the format group is assigned, and choose Formatting → Column.

You can overwrite the default parameters of the standard layout using the Column width, Numerical format, and Reverse sign functions. The numerical format controls how values are displayed in your report (scaling factor and number of decimal places).

If you specify one decimal place and a scaling factor of 1000 for the value 1000000, this value will be displayed as 1000.0 in the report.
Formatting Rows and Columns

The formatting functions under Formatting → Column change the format of all columns that use the same format group. If you want to change the format of a single column, you must assign a different format group to this column.

- **Aligning Column Headings and Selecting the Text Length**
  
  You establish the alignment of the column headings for all report columns. To change the horizontal alignment of text (left-justified, centered, or right-justified), choose Formatting → All columns → Text alignment.

  You can also specify which type of text you want to use in all column headings (short, medium, or long text). To do so, choose Formatting → Row/column texts and select the text type you want to display.

Row Formats

- **Overscore/Underscore**
  
  You can use the Over-/Underscore functions to highlight individual report rows. For example, you can have the system display lines above and/or below totals rows. To do so, position the cursor on the row and choose Formatting → Row. In the subsequent dialog box, activate Underscore and/or Overscore.

- **Row Colors**
  
  You can add color highlighting to individual report rows. To do so, position the cursor on the row and choose Formatting → Row. In the following dialog box, select a color (for totals, subtotals, inserted rows, or for emphasis). The system assigns a color based on the selection you make here.

  You can format more than one row at a time by selecting the rows and then formatting them, as desired. The rows remain selected once you have completed the format changes. You must remove the selections manually using the Deselect all function. Formatting commands that affect all rows or columns are independent of any selections you have made.

- **Text Type**
  
  You can specify which type of text you want to use in the report lead column (short, medium, or long text). To do so, choose Formatting → Row/column texts. In the dialog box, select the text type you want to display.

- **Expand to/Collapse to**
  
  You can only use the Expand to/Collapse functions for report rows that are exploded in the report definition and contain totals rows. You must therefore select a group as the characteristic value for the row and explode that row. The lowest level in a group hierarchy (usually the individual values) are not displayed in the report definition.

  If you position the cursor on an exploded row in the report definition and choose Collapse to or Formatting → Collapse to, you can specify the summation level up to which you want to collapse exploded report rows.
By choosing *Formatting → Expand to*, you can specify the summation level up to which you want to expand exploded report rows.

The summation levels you define in the report definition are used when you output the report. You can, however, expand or collapse these rows again in the report output.

The Report Painter does not process exploded report rows as individual row elements. You cannot therefore use all functions on exploded rows, which can be used on other report rows.

For example, if you use the *Delete* function on an exploded row, the system deletes the entire row element and not just the exploded row.

If you use the *Underscore/Overscore* and *Color settings* functions on exploded report rows, any changes you make are valid for all rows at the same characteristic level.

For more information, see Layout [Seite 1016] and Section Layout [Seite 1028]
Defining Cells

Use

Cells enable you to use values that the report displays for particular row/column combinations as operands in formulas. A cell pinpoints a particular location or range within the column-row matrix of a report. In the Report Painter, you can work with rows, columns, and individual cells. If you want to work with cells, you must select the relevant cells.

Procedure

You edit cells in the same way you edit row and column elements.

1. Position the cursor on the cell and choose edit → Elements → Change/display, or simply double-click the cell.

   The cell is selected. All cells you select in this way can then be used in the formula builder in the entire report (all sections and horizontal pages) as operands for the definition of formulas.

2. If you don’t enter a text for the selected cell, the system automatically assigns a description to it. This description is the lead column/column header.

   To enter your own cell text, position the cursor on the cell and choose edit → Element → Change text. You can then enter a short, medium, and long text for the cell.

   • If you use cells as operands in formulas, but do not want to display or print these cells in your report, you can hide the rows and columns used to create the cell by choosing edit → Rows/Columns → Hide. If you have selected the affected cells, you can still use them in the formula builder.

   • If you want to select cells in exploded rows of a group (set), the selected cell always refers to the highest summation level in the group. If you want to select cells for a subgroup, you must define an additional report row for the subgroup, select the cell you want to use, and then hide the report row.
Defining Sections

Use

A section consists of one or more physical rows and columns forming a logical unit. In the vertical direction, a report consists of one or more sections. Each section is displayed on a new screen. You can define sections with key figures and characteristics, as well as sections with derived basic key figures.

In a section that contains calculated key figures, you can create an overview of the most important values used in your report. A section with calculated key figures is a new report section and is displayed on a new screen. You normally define a section with basic key figures at the end of your report.

Sections with Calculated Key Figures

1. To define a section with calculated key figures, first select the cells you want to use in the section. For information on selecting cells, see Defining Cells [Seite 758]. You can also enter your own text for these cells.

2. Choose Edit → Sections → New section. In the New Report Section dialog box, select Section with calculated key figures.

3. Position the cursor on the row or column and choose Edit → Elements → Define element or double-click on the row or column.

   The section with calculated key figures is made up of a row/column structure in which you enter short, medium, and long texts.

4. Define the cells you want to use in the section at the point of intersection of the row/column combination. Position the cursor on the appropriate cell and choose Edit → Elements → Define element, or double-click on the cell.

   You enter cell calculations for the section with key figures in the Formula Builder. All selected cells of the report are displayed in the Formula Builder as buttons. You can then define your key figure formula as required.

   The Formula Builder enables you to use the selected cells in the section with calculated key figures. You can also use cells that were calculated using the selected cells.

   Another feature is that you can reselect cells used in the section with calculated key figures to calculate values for other cells within the section (recursive cell definition).

   If you don’t want to display or print the cells you use in your section with calculated key figures in the other sections of your report, you can hide the corresponding rows and columns by choosing Edit → Rows/Columns → Hide.

Sections with Characteristics and Key Figures

1. To define a new section in your report, choose Edit → Sections → New section.

2. In the following dialog box, select Section with characteristics and key fig.
Defining Sections

A new row and column structure appears for you to define your new report section. You define rows and columns as described under Defining Columns [Seite 748] and Defining Rows [Seite 751].

3. You can switch between the different sections by choosing Goto → Section → and then First section, Previous section, Next section, or Last section.

You can only perform calculations using columns within the same section. For calculations between sections that use columns, you must select cells. For more information, see Defining Cells [Seite 758].

Once you have defined a report, you can display and print out a table of contents of the report with Formatting → Section overview.

The overview contains the characteristics and characteristic values used in the individual sections, horizontal pages, and general data selection criteria. It also provides general information such as the user who last changed the report and the report name, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.
Defining Horizontal Pages

Use

A horizontal page consists of one or more physical report columns that form a logical unit. Each horizontal page is defined and displayed on a new report page and on a separate screen. When you define a new horizontal page, the report row definitions remain the same.

Procedure

To define a new horizontal page, choose Edit → Horizontal page → New column block.

- A row/column structure appears in which the rows are already defined. For information on defining columns, see Defining Columns [Seite 748].
- The icons and move the display back and forth between the horizontal pages.

You can perform calculations involving more than one horizontal page. You can therefore define formulas that refer to columns in different horizontal pages.
General Data Selection

Use
To define a report, you define the rows and column structure and the general selection criteria that apply to the report as a whole. The general selection criteria are the characteristics used to select data for your report. Your general data selection criteria can only contain those characteristics that are not already being used in the report rows and columns.

Features
To define the general data selection criteria for your report, choose Edit → General data selection.

If you define data selection in a report with more than one account assignment object (such as cost centers and internal orders), you must make sure that all account assignment objects are completely defined in all sections.

In the orders section [Extern], you must add the characteristic cost center, while in the cost centers section you must add the characteristic order. The value for the cost centers in the order section, and for orders in the cost centers section, is always a pound sign (#).

Definition of 1st section:
- Cost center: &1KOSET
- Order: #

Definition of 2nd section:
- Cost center: #
- Order: &6-AUFGR

In the dialog box Element definition: General data selection, select from among the available characteristics those characteristics you want to use in general data selection. To select the characteristics, choose .

Enter values for the selected characteristics under Selected characteristics. You can enter individual values, intervals of values, groups, or variables.

The following characteristics must be defined in your report, either as data selection criteria, report rows, or report columns:
- Company
- Ledger
- Version
- Record type
- Period

To improve processing time, you should specify all characteristics in general data selection that are not needed in the report rows or columns.

- In the reports assigned to table CCSS, the controlling area characteristic must always be used in general data selection. The controlling area characteristic can only be used as a single value or variable.

- The company code characteristic depends on the time-dependent characteristic cost center. If the cost center is not valid during the current time period, the system cannot determine a valid company code for the data records of the selected cost center, and therefore no data can be displayed. If the cost center was valid in a different company code in the previous year, the system assigns the values posted on the cost center to the company code that is valid for the master data date of the report.

Since the relevant date for time-dependent master data in the Report Painter and Report Writer reports is the master data date, you should set this date explicitly such that all cost centers used in the report are valid on that date. To do this, choose Output parameters → Master data date in the selection screen of the report.

If you enter specific values, intervals of values, or groups for a characteristic, your report is always executed using these values. The More indicator displays a list in which you can enter several intervals or individual values for the characteristic on which the cursor is positioned.

You define the characteristic Year as data selection criteria for your report and enter 2000 as the year. When the report is executed, the system only selects data records for the year 2000.

If you enter a variable [Seite 689] for a characteristic, the system prompts you to enter a value for the variable on the Selection screen when you execute the report’s report group. The single value/set assigned to the variable appears as the default value on the selection screen. You can overwrite this default value if you want.

If you enter a variable as data selection criteria, the values you enter on the selection screen when executing the report’s report group are only valid for one report run. Each time you run the report, you can enter a different value for the variable.

To define a variable for a selection characteristic, turn on the Variable indicator in the relevant entry field in the column. Then choose Check to check the entry and refresh the screen. The input help function (F4) displays a list of available variables for the characteristic.

You create a set variable called CSTCTR for the characteristic Cost Center and enter a set name as the default value for the set variable. If you use this variable as
General Data Selection

data selection criteria in your report, the system asks you to enter a set name when
you select the report data records. You can use the default set name assigned to the
variable or another set.

The input help function always displays all variables for the relevant characteristic.
Variables are displayed even if they are already being used in rows or columns.

You create variables within set maintenance. For more information, see Creating Variables [Seite 692].

Choose Confirm to conclude the definition of general data selection.

Variation

The variation [Extern] function allows you to create a separate report for each element in a group
(set) that is used as general data selection criteria in your report.

When you execute a report for which variation has been defined, you can enter a variation range
for report execution on the selection screen or specify the output of reports for single values.

For more information, see Executing a Report Group [Seite 964]. Within the report, you can then
output individual reports online for the groups or individual values in the variation range.

Elimination of Internal Business Volume

For each characteristic, you can use the Elimination of internal business indicator to eliminate or
display internal business volume in the report. Internal business volume represents the
allocations that take place within one characteristic group.

For more information, see Elimination of Internal Business Volume [Extern] and Activating
Elimination of Internal Business Volume [Extern].

If both the variation of the selection and the internal business volume elimination are
activated, the internal business volume is eliminated dynamically. When you
navigate between the reports for the elements of the group in the report output, the
internal business volume is redetermined for each element and then eliminated in the report.
Defining Report Headers

1. In the menu of the Report Painter [Seite 726], choose Edit → Report header.

   
   If you want authorization protection for the report, enter an authorization group.

3. Enter the name of the standard layout assigned to the report.
   
   When you first create a report, the default standard layout is SAP. This standard layout [Seite 1017] is shipped with all SAP R/3 Systems. For more information, see Layout [Seite 1016].

4. To make default settings for exporting the report to an application or presentation server, choose Export parameters.
   
   In the subsequent dialog box, enter the required data. You can see the default values you entered in the report output under Report → Export. You can change these default settings as required.
   
   For more information on exporting reports, see Exporting Reports to an External File [Seite 985].

5. To save the report header, choose Continue.
Excerpts

**Use**

To reduce the necessary runtime for formatting report data, you can create an extract when you execute a report. An extract is a dataset that contains the report data selected at the time the extract was created.

Extracts provide the same navigation and formatting options as reports selected directly from the database.

The main differences between an extract and a report are shown in the following table:

**Main Differences Between Report and Extract**

<table>
<thead>
<tr>
<th></th>
<th>Report (Newly Selected)</th>
<th>Extract</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Currentness of data</strong></td>
<td>Data is current</td>
<td>Data is no more recent than the time the extract was created</td>
</tr>
<tr>
<td><strong>Authorization check</strong></td>
<td>On each record</td>
<td>Only on entire report</td>
</tr>
<tr>
<td><strong>Runtime</strong></td>
<td>Generally long runtimes with large database structures, plus additional time for report output</td>
<td>Runtime only for report output</td>
</tr>
</tbody>
</table>

Aside from these differences, extracts offer full report functionality. When you call up a report that uses an extract, the system does not have to select the report data directly from the database. As a result, processing time improves considerably.

⚠️ If you create an extract and then make changes to the data structure in Customizing, this can result in inconsistencies between the current data structure and the structure in the extract. The data of the extract can therefore no longer be displayed.

⚠️ After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

**Integration**

The final step in defining a report group [Seite 937] is executing the report group. You generate an extract when you execute the report with reference to the selection parameters entered at the time the report is executed. You can therefore create multiple extracts of the same report by entering different selection criteria each time.

If you called up the report using an extract, the system outputs the report using the extract data.

If you called up your report by selecting data from the database, the system outputs the report according to the selection criteria you specified and formats the report according to the report definition.

For more information, see Executing a Report Group [Seite 964].
Features

In expert mode [Seite 978], you can create extracts on the selection screen (for more information, see General Data Selection [Seite 762]) if you execute a report group and choose the button Extract parameters... and then the mode Create extract. Alternatively, you can save your report output as an extract when you exit the report. In this case, the system displays a dialog box, asking whether you want to save the report in an extract file.

If you call up a report when Display extract is selected as the data source, the system checks whether any extracts are available that match the selection criteria. You can then choose from among the available extracts. You can also search for, display, and print extracts using extract management. In both cases, direct access is possible to all extracts generated within a variation.

Extracts are deleted either manually in extract management or automatically based on an expiration date that you can specify when you create the extract.

⚠️

Once an extract has been deleted, it cannot be retrieved.

For more information, see Creating an Extract [Seite 1010] and Managing Extracts [Extern].
Create Extract

Use
There are two different ways of creating an extract [Seite 1008]:

- You can create extracts on the selection by choosing Extract Parameters and then choosing Create Extract in the dialog box.
- You can generate an extract when executing a report. To do this, follow the steps under Procedure.

You can only create extracts in expert mode [Seite 978]. Make sure that expert mode has been activated. You can make these settings from the selection screen by choosing Environment → Options.

Procedure
2. Enter the required report group and choose 📄.
3. Enter the required selection parameters and choose 📄.
   If extracts already exist for the selection criteria you have specified, the system will display a list of extracts that you can choose.
4. The report is now displayed. Choose Report → Save. In the Enter: Extract Parameters dialog box, you can define the parameters for your extract. For further information about extract parameters, see Expert Mode [Seite 978]. To complete your entries, choose 📄.
Managing Extracts

Use
When you save reports in extracts, you can then access the data at any time without having to select the data from the database.

You can use extract management to:

• Display extracts
• Print extracts
• Change the extract priority
• Change the expiration date of an extract
• Delete extracts

After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Prerequisites
You have saved your reports in extract files. For more information, see Creating an Extract [Seite 1010].

Procedure
1. On any Create/Change/Display/Execute Report Group screen, choose Utilities → Extracts → Display or Delete or Print or Change expiry date, depending on the function you want to use.
   

   You can also access extract management from the screen Execute Report Group: Initial Screen using the button Data extracts when you execute a report group from the first selection screen with Environment → Extract directory...

2. Enter the criteria according to which the extracts should be selected:
   
   • If you are searching for a particular extract, enter the description of the extract.
   • Specify whether extracts should be displayed that were generated by your or by a particular user, or whether all extracts should be displayed regardless of the user.
   • Specify when the extracts were generated, or whether all extracts should be generated regardless of the date.
   • You can select the extracts of a particular report group [Seite 937] or report group range.
   • You can select the extracts according to their priority, and restrict the selection to unread extracts.
Managing Extracts

- If you want to further restrict the selection criteria (for example, according to a specific characteristic or group of characteristics), choose Additional selections and enter the criteria. You can expand the number of selection conditions as required, and delete selection conditions you entered.

3. Choose 

The system displays a list of extracts that meet the selection criteria you entered.

4. Select the desired extract and choose one of the following functions:

   a. Display extract
      Choose 

   b. Print extract
      You can print extracts immediately or in the background.
      - To print the selected extracts, choose Extrakte and enter the output device and other parameters for print control.
      - To print in the background, choose Background and specify when the job should be started.

   c. Change the extract priority
      Choose and change the priority of the extract.

   d. Change expiration date
      You can change the expiration date that was specified when the extract was created.
      Choose . If you want the extract to be deleted automatically after a specified time, enter the number of days in the dialog box Change expiration date under Expires in or choose Expires on and enter an expiration date.

      If you don’t want the extract to be deleted after a specified time, choose No expiration date. This is appropriate when the report is required for an undeterminable length of time or the report takes a long time to execute.
      Choose to exit the dialog box and save your entries.

   e. Delete extract

      Once an extract has been deleted, it cannot be retrieved.
      Choose to delete extracts. If you answer the question whether the selected extracts should be deleted with Yes, the extracts are deleted.

      For information on settings for extract management, see the Implementation Guide for Cost Center Accounting under Information System → User Settings → Specify Settings for Extract Management.
Example Process: Report Callup with Extract Management

Purpose

At the end of each month, the reports (important to cost center managers in the entire organization) are executed, and the data is stored in extracts. Reports that contain data for individual cost centers or cost center groups are executed using variation, so that a separate report can be created for each cost center and cost center group.

You can set the user parameters for your cost center managers so that they can automatically access the most current extracts.

When calling up a report from the report tree, each manager receives the relevant individual data. The manager does not need to select the data from the database again, which reduces the workload of the system.

The cost center manager cannot navigate to areas within the extracts that do not belong to the authorized CO-OM responsibility area.

The system administrator who sets up these reports needs to have authorization to select the data from the database. However, this does not authorize the administrator to display the data in those reports.

The cost center managers need authorization to display the reports for their CO-OM responsibility area. However, this does not entitle them to select the data from the database or to create extracts.

The following graphic displays the way in which a report is executed in extracts, in the background with the variation. It also shows how you can save it in extracts.
Process Flow

1. Initial setups include creating the authorizations for system administrators and cost center managers [Extern].

2. The system administrator arranges for all the reports to be accessible to all users in EUROs. The system administrators execute the report (such as the Cost Centers: Actual/Plan Variance report) in the background and with the variation, and save the report in extracts (see: Executing a Cost Center Report with Variation and Saving it in Extracts [Extern]).

3. The system administrator makes the settings for extract management for the cost center managers in Customizing (see: Specifying Settings for Extract Management [Extern]). In their user-specific settings, the cost center managers save their selection criteria for the reports they want to display (see Customizing for Controlling under Cost Center Accounting → Information System → User Settings → Specify User Settings [Extern]).

4. The cost center manager accesses the report (see: Calling Up Cost Center Reports [Extern]).

This procedure is shown in more detail in the following sections using the Cost Centers: Actual/Plan/Variance report.

Result

Each cost center manager can quickly and easily display the relevant reports required.
Example Process: Report Callup with Extract Management
Report Text

Use
In a Report Painter or Report Writer report, you can enter texts for the following:

• Title page
• Headers
• Footers
• End page
These texts are used for list output and exports in text format.

• Text for export
The text for export is used for Office integration and for exports into HTML or spreadsheet format.

The definition of report texts in the Report Painter is similar to that in the Report Writer.

You can also define report texts in the report output. SAP recommends that you enter report texts only after the report has been executed and output. This allows you to see which values the report text variables will use.

Prerequisites

You can only change texts in the report output if the report uses a standard layout [Seite 1017] in which the Change alld ur excn indicator is selected on the Page/Control screen. You cannot change texts in standard reports included with your SAP R/3 System.

Features

You can enter the following types of texts for report texts:

• Normal text
• Standard text variables such as the date, user name, and page number
• Special text variables
• Text variables for selection parameters
• Text variables for characteristics used in the text
For more information, see Variables in Report Text Definition [Seite 826].
Defining Report Texts

To enter report texts from any Create Report screen:

1. **Report Writer**
   - From the screen Create Report or Change Report or Display Report: Initial Screen, choose Goto → Texts.

2. **Report Painter**

2. To enter text, choose one of the processing functions in the following table.

### Processing Functions for Text Definition

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose (Report Painter)</th>
<th>Choose (Report Writer)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter text for title page</td>
<td>Title page</td>
<td>Title page</td>
</tr>
<tr>
<td>Enter text for headers</td>
<td>Headers</td>
<td>Headers</td>
</tr>
<tr>
<td>Enter text for footers</td>
<td>Footers</td>
<td>Footers</td>
</tr>
<tr>
<td>Enter text for last page</td>
<td>End page</td>
<td>End page</td>
</tr>
<tr>
<td>Enter text for export of report to HTML and Office Integration</td>
<td>Text for export</td>
<td>Text for export</td>
</tr>
</tbody>
</table>

   The screen Change <text position> <report name> in Language <language code> appears.

   If these functions are not available, choose Formatting → Report layout and check whether Change allowed during execution is selected on the tab Page/control.

3. Choose Text → Save.

4. Choose Text → Exit.

   The text appears on the Create Report: Texts screen.

5. To save the report, choose Report → Save.

### Entering Variables in Report Text

In the report output, you can insert text variables, frames, and rows with Insert. For more information about the different types of text variables you can define in your report text, and how to enter variables in report text, see Using Variables in Report Text Definition [Seite 826].
Layout

Purpose
In Report Painter and Report Writer reports, you can modify the layout of your report at different levels.

Features
The layout parameters for the report output are determined by the standard layout [Seite 1017] assigned to the report. This includes the page format of the report and the numerical format of the report data.

A section layout [Seite 1028] can be defined separately for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

You assign an individual report layout [Seite 1029] to each report. Initially, each report receives the standard layout SAP. You can assign an individual section layout to each section in the report. The standard layout then only applies to the sections to which no section layout was assigned.

The section layout and the report layout allow you to define layout settings such as form printout or the width and position of the lead columns separately for each section.

Specify whether it should be possible to change and save the layout parameters in the report output:

- If you do not select Change alwd dur extcn, the layout parameters cannot be changed when the report is executed.
- If you deselect Change alwd dur extcn, the layout parameters cannot be changed when the report is executed.

For more information, see Parameters for the Standard Layout [Seite 1022].

You can change the report’s layout parameters under Settings → Report layout.

If you change the layout parameters, but then decide that you want to reuse the default values from the standard layout, you can do so by choosing Settings → Report layout → Use standard layout.
Standard Layouts

Use
You assign a standard layout to each report that you create. This standard layout determines the layout features of the report, such as the page format of the report and the numeric format of the report data. The system assigns a default standard layout called SAP to each report. You receive the SAP standard layout with each SAP R/3 System. The standard layout provides a default value for every layout parameter.

Features

Report Painter
When a layout is assigned in the Report Painter [Seite 726], the layout parameters are copied from the standard layout to the report layout. There is no permanent reference to the standard layout. Thus, changing the standard layout has no effect on the report layout.

In the report layout, you can recopy the layout parameters of the standard layout with the button Use standard layout.

Report Writer
Before a report layout has been defined for a Report Writer [Seite 797] report, a link exists between the report layout and the standard layout for all parameters. With the button Define report layout, you can create an independent report layout that is a copy of the standard layout. With Report Writer reports, the button Use standard layout restores the link to the standard layout. In this case, changes made to the standard layout would affect the report layout.

When you define a report, you can do any of the following:

• Use the SAP standard layout for the report
• Assign a different standard layout to the report
• Revise the standard layout parameters so that the parameters are specific to the report

In the report definition, you can assign a standard layout to the report in the report header. These settings then take effect for that report. You will find more information on headers for the Report Painter under Defining Report Headers [Seite 765] and for the Report Writer under Defining Report Headers [Seite 817].

There are two ways in which you can use the standard layout settings in a report:

• Execute the report and then choose Settings → Report layout → Use standard layout
• In the report definition (Change Report), choose (for Report Painter reports) Edit → Report header. Here you need to enter a different standard layout (such as SAP) and then reenter the standard layout you require.

The indicator Change allwd dur exctn allows you to save any changes you make to the layout when executing the report. Set this indicator in the report layout.

If you only change the indicator in the standard layout, the change will only be effective in the Report Painter report if you reassign the standard layout to the report.
Standard Layouts

For more information about assigning a standard layout to a report and changing report parameters, see Defining Report Layouts [Seite 1031].

The standard layout is used in all sections to which no section layout [Seite 1028] is assigned.

For more information on processing and changing the standard layout, see:

Creating a Standard Layout [Seite 1019]
Displaying a Standard Layout [Seite 1024]
Changing a Standard Layout [Seite 1025]
Deleting a Standard Layout [Seite 1027]
Parameters for the Standard Layout [Seite 1022]
Creating a Standard Layout

Use

When you first define a report, the default standard layout assigned to the report is always **SAP**. **SAP** appears in the *Standard layout* field at the top of each report parameters screen. This standard layout is shipped with your SAP R/3 System.

When you define a standard layout, you can assign parameters to format groups for certain fields. For parameters that are assigned format groups, you can define up to six different versions of the parameter. Each row and column in a report can use a unique format group. For more information, see [Setting Format Groups in Sets][1] [Seite 910].

Procedure

2. Enter the following information:
   - The name of the standard layout you want to create
   - The name of the existing standard layout you want to copy
3. Choose *Continue*.
   The *Create Standard Layout* screen appears.
4. Enter the following information:
   - Description of the standard layout
   - Authorization group for the standard layout. This authorization group is defined in the user's profile.

   ![Note](image)

   Suppose you define an authorization group called **AUTH**. If you assign this authorization group to a standard layout, only users with this authorization group can change, display, and/or delete this standard layout for their reports.

   Using the tab pages you can make the changes to the layout that you require. The following table gives you an overview of the different possibilities that you have for defining the standard layout parameters. Each function is assigned to the respective tab page index.

**Defining the Standard Layout Parameters**

<table>
<thead>
<tr>
<th>Function</th>
<th>Tab page index</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting the column headings</td>
<td>Column headings</td>
</tr>
<tr>
<td>Defining area for the totals output</td>
<td>Rows</td>
</tr>
<tr>
<td>Setting width and position of lead column</td>
<td>Lead column</td>
</tr>
<tr>
<td>Defining detail level for row totals</td>
<td>Rows</td>
</tr>
</tbody>
</table>

[1]: https://example.com
### Creating a Standard Layout

| Setting number of decimal places | Representation |
| Defining unit | Representation |
| Setting colors | Graphics |
| Using form printout | Rows |
| Setting graphic type | Graphics |
| Defining content of lead column | Lead column |
| Defining content of column headings | Column headings |
| Allowing changes to layout parameters during execution of the report | Page/control |
| Output of zero values | Representation |
| Suppressing zero columns | Columns |
| Printing or hiding zero rows | Rows |
| Indenting lead column | Lead column |
| Repeating lead column | Lead column |
| Setting page format | Page/control |
| Printing selection log at end of report | Page/control |
| Setting scaling | Representation |
| Setting column break character underline | Column headings |
| Defining column layout | Columns |
| Setting column break character | Columns |
| Assigning a language | Language dependent |
| Using standard colors | Page/control |
| Suppressing duplicated totals | Rows |
| Marking totals | Rows |
| Defining position of totals items | Columns |
| Defining text type for the row text description in the lead column | Lead column |
| Displaying undeterminable values | Representation |
| Setting +/- sign | Representation |
| Defining +/- sign editing | Rows |

For more information on the layout parameters, see [Parameters for the Standard Layout](#) [Seite 1022].

You can use the following additional functions from the Create Standard Layout screen:

### Additional Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
</table>

372 April 2001
## Creating a Standard Layout

<table>
<thead>
<tr>
<th>Action</th>
<th>Command Chain</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display directory of existing standard layouts</td>
<td>Utilities → Catalog...</td>
</tr>
<tr>
<td>Export standard layout to an external file (see Exporting Report Writer Objects [Seite 916])</td>
<td>Utilities → Transport → Export</td>
</tr>
<tr>
<td>Import standard layout from an external file (see Importing Report Writer Objects [Seite 918])</td>
<td>Utilities → Transport → Import</td>
</tr>
</tbody>
</table>

5. To save the standard layout header, choose Standard layout → Save.
Parameters for the Standard Layout

The standard layout provides a default value for all the layout parameters that you can change.

When creating the standard layout you can overwrite the default parameter values on the following tab pages:

- **Page/control**
  
The page format parameter values determine the layout of a report when it is output. *Page control* (to determine if you can change the layout parameters in the report output and if you want to print the selection log at the end of a report). For *Margins* you can define parameters for the top, bottom, right and left margins and in *Print sequence* you can choose between printing by column or by row. With *Color settings* you can specify that the standard SAP colors be used for the report output.

- **Rows**
  
  With *Summation level* you define the level of detail to be used for the row totals. With *Totals item* you specify where the totals are to be output, for example above or below the detailed report results. For *Treatment of zero rows* you define whether zero rows are to be printed or hidden, or whether you want to use form printout. You can also mark totals and suppress duplicated totals.

  You can deactivate +/- *sign editing*, or activate it for all columns or for a certain column.

- **Lead column**
  
  With these layout parameters you define the content of the lead column (description, key and description, characteristic name and key, key). You can also determine the text type that is to be used for the row text in the lead column. You can choose between short text, long text, or a text that is proposed automatically by the system. If there is no short text in the master data, the system uses the corresponding long text.

  With *Indentation* you can specify the number of spaces the lead column is to be indented by.

  In the group box *Lead column* you can define the width and position of the lead column.

  In the group box *Miscellaneous* you can activate the underscoring of the text and the repetition of the lead column.

- **Columns**
  
  *Totals position* (to determine if totals columns are positioned to the left or right of the columns containing the corresponding detail values).

  In the group box *Column break character* you specify the type of column break character to be used. In the group box *Treatment of zero columns* you can select that the zero columns be suppressed. In the group box *Layout* you define the column width and the right margin.

- **Column headings**
  
  With these layout parameters you define the *Content and Orientation* (left-justified, centered, right-justified) of the column headings. In the group box *Miscellaneous* you can define that the column break character be underlined.

- **Representation**
With these layout parameters you define how the numerical format is to be displayed. You can determine the number of decimal places and the scaling, as well as make specifications concerning the +/- sign and the units. You can also specify how the zero values and undeterminable values are to be displayed.

Undeterminable values appear in a report when values with different currency units or units of measure are totaled. You can display these values in your report with a space or using a symbol.

- **Language dependent** (language-dependent parameters)
  With these parameters you can assign different values for decimal display, +/- sign and date to different languages. With Other languages you can switch to another language to enter the language-dependent parameters. When you execute the report's report group, the Report Writer uses the value of the logon language.

- **Graphics**
  With these parameters you determine the graphic type that you want to use. The color palette determines the color palette that is to be used for the business graphic. For more information on calling the report graphics from the executed report, see calling report graphics [Seite 999].

For more information, see creating a standard layout [Seite 1019].
Displaying a Standard Layout

   The Display Standard Layout: Initial Screen appears.

2. In the Standard layout field, enter the name of the standard layout that you want to display and choose Continue.
   The Display Standard Layout screen appears.

3. On this screen, you can use the additional processing functions in the table in Creating a Standard Layout [Seite 1019], as well as the Extras → History function to display the revision history of the standard layout.
Changing a Standard Layout

Prerequisites
Changes you make to a standard layout will affect other users’ reports that use that standard layout.

You should only change a standard layout if the change is required for all reports that use that standard layout. If changes are only needed for one report run or for a specific report, you should change the report parameters using the Layout functions on the Change Report: Initial Screen. For more information, see Defining Report Layouts [Seite 1031].

The layout parameters are copied from the standard layout into the report layout. There is no permanent reference to the standard layout. When you create a report, the layout settings are copied from the standard layout into the report layout.

If the standard layout is changed, the layout parameters in the report are not updated automatically.

Do not change the standard layout (SAP) that is delivered with your SAP R/3 System.

Procedure
   
   The Change Standard Layout: Initial Screen appears.

2. In the Standard layout field, enter the name of the standard layout you want to change and choose Header.

   The Change Standard Layout: Header screen appears.

3. On this screen, you can use the additional processing functions in the table in Creating a Standard Layout [Seite 1019], as well as the Extras → History function to display the revision history of the standard layout.

4. Type over current values with your changes.

5. Choose Standard layout → Save.

Suppose you give the report the standard layout SAP and then change the report width to 60. Then you assign a different standard layout to the report. The report width remains at 60, since it is a change that you made that is specific to the report.

For information on transferring the settings of the standard layout to a report, see Standard Layouts [Seite 1017].
Changing a Standard Layout

If the standard layout is changed, the layout parameters in the report are not automatically updated. The indicator Change allwd dur exctn allows you to save any changes you make to the layout when executing the report.

Select the Change allowed during execution indicator only in the report header.

If a user has authorization to change a report, he can change this indicator in the report output with Settings → report layout → Page/control → Change allowed during execution. Another place you can change the setting of this indicator is in the report definition with Report header. If you only change the indicator Change allowed during execution in the standard layout, the change will only be effective in the report if you reassign the standard layout to the report.
Deleting a Standard Layout

   
   The Delete Standard Layout: Initial Screen appears.

2. In the Standard layout field, enter the name of the standard layout you want to delete.

3. Choose Delete.
   
   A dialog box asks if you want to delete the standard layout.

   You cannot delete a standard layout that is being used in a report. You cannot delete the SAP standard layout delivered with the SAP R/3 System.

4. Choose Yes.
   
   The standard layout is deleted. You cannot restore a standard layout once it has been deleted.
Section Layout

Use
There are a number of different ways you can modify the layout of the sections in a report:

- You can apply the parameters specified in the report layout
- You can apply a section-specific layout

Features
You can use a different layout for each section. Section layouts contain control information on:

- Row totals
- Row texts
- Column texts

You can also apply the report layout [Seite 1029] to sections. Any changes you make to the report layout then become effective automatically in the sections where it was applied.

The section layout can be defined differently for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

In the section overview in the Report Painter, you can change the attributes of the sections, the sequence of the sections, and the page breaks between the sections. This includes overscores and underscores, and how the headers should be printed.

For more information on formatting, see Summation Levels [Seite 1034].
Report Layout

Use
You can assign a report layout to each report that you create. The report layout defines the layout features of the report, such as the page format of the report and the numeric format of the report data. When you use the Layout functions, you can set parameters for the report.

Features
You have two options for assigning a layout:

- Report Writer: link to standard layout [Seite 1017]
  Report Painter: copy of standard layout (may not be current)
- A separate report layout that is not linked to the standard layout

The report layout establishes layout parameters that apply to the whole report (such as the page layout). It also contains parameters that can be defined separately for each section (such as summation levels [Seite 1034]). These section-specific parameters defined by the report layout are valid only for report sections that do not have their own section layout [Seite 1028].

For more information, see Displaying Report Layouts [Seite 1030] and Defining Report Layouts [Seite 1031].
Displaying the Report Layout


For more information on additional functions that are available on this screen, see Functions in the Report Output [Seite 974].
Defining Report Layouts

Use

For each report that you create, you can assign a report layout. Via the report layout you define the layout features of the report, such as the page format of the report and the numeric format of the report data. When you use the Layout functions, you can set parameters for the report.

You received the SAP standard layout with your R/3 System. This standard layout is automatically assigned to each report you create. If you want to use the SAP standard layout, you can skip the following steps and go directly to defining rows [Seite 841]. When you first define a report, the default standard layout is always SAP. SAP appears in the Standard layout field at the top of each report layout dialog box.

When you define a report layout, you can define a layout specifically for a report and you can change the standard layout assigned to a report.

Procedure

1. To define a report layout, choose Goto → Report layout and work with the following tabs:

   - Page/Control: Here you define general page format parameters, such as the length and width of a page
   - Rows: Here you define row total parameters, such as the positioning and summation levels for report row totals
   - Lead column: Here you define row text parameters, such as the text type and row length
   - Columns: Here you define the type of column break and the treatment of zero columns
   - Column headings: Here you define orientation of the column headings, such as the position and layout of the columns
   - Representation: Here you can define the numerical formats
   - Language dependent: Here you define the language dependent report parameters
   - Graphics: Here you define the graphical presentation and color palette

   You can switch between the change mode of your report layout and the default parameters of the standard layout using the pushbutton Use standard layout or Define report layout. To change a parameter so that the standard layout value is not used in a report, you type over the current value. The value is not changed in the standard layout; it is only changed for that specific report.

2. Type over current values with the values you want to use for the report layout.

3. Choose Continue.

4. To save the report layout parameters, choose Report → Save.
Defining Report Layouts

Changes that you make to the report layout parameter values do not affect the standard layout values that are stored in the system. The report parameter values that you enter only affect the specific report that you are working on.

You can change standard layouts for reports; however, any changes you make affect other users' reports. For more information, see standard layouts [Seite 1017].

For more information on the standard layout screens or for information about changing the standard layout, see creating a standard layout [Seite 1019].

For information on how to change the standard layout assigned to a report, see changing a standard layout [Seite 1025].

The system determines which format group to use based on the format group defined in the sets that are used in the report definition. Some report parameters can be defined using six variants of the parameter. These variants correspond to the format groups 0 through 5. Depending on the value entered in the format group field for a set, the Report Writer selects one of the six values. For more information on format groups, see setting format groups in sets [Seite 910].
Saving Changed Report Layout Parameters

Use
When processing a report in expert mode, such as when executing a report group [Seite 962], you can make changes to the report layout and save them.

Procedure
1. When executing a report, choose from the report output screen Settings → Report layout. A dialog box appears where you can overwrite the layout parameters.
2. Make any required changes to the report layout.
3. To save the changed layout parameters, you can choose from the following alternative functions:
   • To save the changes, choose Settings → Save settings.
   • To save the layout changes you made and then block all users from making layout changes in the report, choose Settings → Save and block settings. The system automatically deselects the Change allwd dur exctn indicator in the Page/Control layout parameters. If you need to remove the block, choose Change report, then Formatting → Report layout. On the tab page Page/control in the group box Control data, select the indicator Change allwd dur exctn.

SAP recommends that you save your report data as an extract [Extern]. This allows you to call up your report at any time and the system does not have to reselect the data from the database. You can save the report as an extract using the Report → Save function. If you have not already saved the report as an extract, the system displays a dialog box, asking you whether you want to do so when you exit the report. For more information, see Extracts [Seite 1008], Creating an Extract [Seite 1010], and Managing Extracts [Seite 1011].
Summation Levels

Use

In Report Painter reports and Report Writer reports you can use sets [Extern], groups, or set variables to display a hierarchy in the rows. The totals rows in a report are represented by summation levels.

Features

Each summation level is represented by one or more asterisks. In the report definition, you can specify in the layout that this hierarchy should be marked with special characters. You activate this function with Settings → Layout → Row totals → Mark totals.

In the layout, you can specify whether you can choose the position of the totals (top or bottom) in the display.

For more information, see Layout [Seite 1016].

The number of masking characters within a report depends on the number of hierarchy levels. Row totals at the lowest level in a hierarchy display with one asterisk. Individual values receive the summation level zero (no masking characters).

Hierarchy Levels and Their Representation by Masking Characters

<table>
<thead>
<tr>
<th>Hierarchy Level</th>
<th>Number of Masking Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Highest level of hierarchy</td>
<td>n</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-1</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-2</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-3</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-4</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Lowest hierarchy level</td>
<td>n-(n-1) = 1</td>
</tr>
<tr>
<td>Single values</td>
<td>No masking character (n-n)</td>
</tr>
</tbody>
</table>

There are two types of hierarchies:

- Balanced hierarchy
  
  If values exist for all levels and branches of the hierarchy, the hierarchy is balanced. A balanced hierarchy looks symmetrical.
• Unbalanced hierarchy

Which hierarchy level is the highest depends on which levels have values. The individual branches of the hierarchy can differ considerably from one another, resulting in an asymmetrical hierarchy.
Summation Levels

**Summation Level with Unbalanced Hierarchy**

If not every level of the hierarchy has a value, the maximum summation level can take on widely different values.

- If the hierarchy consists only of Set 1, Set 12 and values, Set 1 will have the maximum summation level **.
- If the hierarchy consists of Set 1, Set 12 with values, Set 13, Set 131 with value, and Set 132 with Set 1311 with values, Set 1 will have the maximum summation level ****.

The method for determining the maximum summation level always starts at the lowest set level.

**Summation Level with Balanced Hierarchy**

With a balanced hierarchy, the maximum summation level is always the same, regardless of the selected data.

**Summation Levels in Report Layout/Section Layout**

When you set the summation level in the report layout or section layout of reports with an unbalanced hierarchy, you should take into account how the maximum summation level is determined, as described above.

Different hierarchy levels will be displayed, depending on the selected data.

In the above examples for the summation level with an unbalanced hierarchy, if you specify the interval 2 to 3 for the summation level, the result is:

- For the first example: Set 1 **
- For the second example: Set 12 ***, Set 13***, Set 131**, Set 132**

You can avoid this discrepancy by inserting dummy nodes into the unbalanced hierarchy to balance it. This results in additional rows in the report, which you can hide with the layout setting *Suppress duplicated totals.*
Report Writer

Purpose
In addition to the Report Painter [Seite 726], you can use the Report Writer to define reports. You use the Report Writer to create reports from data in the Special Purpose Ledger (FI-SL) application component and other SAP application components to meet your specific reporting requirements.

The Report Writer is a tool using which you can define reports.

Many reporting requirements can be met using the standard reports provided by various SAP application components. However, if your reporting requirements are not fulfilled by SAP’s standard reports, you can also define complex reports using the Report Writer.

With the Report Writer, you can organize reports to meet the specific needs of your enterprise. The Report Writer uses reporting building blocks, such as sets, which can be used in any report.

Integration
The Report Writer fulfills a similar function to the Report Painter, is however more complex and requires a certain amount of familiarization time.

To facilitate report definition, you can use many of the standard reporting objects provided by SAP (such as libraries [Seite 927], row/column models, and standard layouts [Seite 1017]) in your own specific reports. You also use the following additional functions to create Report Writer reports:

- **Sets [Seite 633]**
- **Key figures [Seite 708]**
- **Variables [Seite 689]**

Features
The Report Writer report definition is based on sets [Seite 633], which means that the look of the report is determined by the set construction used to define the report. There are a number of ways you can use these sets in the rows, columns and general selection data.

A set is a system structure that you can use to link together specific values or ranges of values under a name. These values exist within one characteristic of a coding block. A characteristic is a single field or column of a database table. Account, cost center, and business area are examples of characteristics. Within these characteristics, you can store specific characteristic values under a set name.

![Set example]

You create a set called TD-RACCT-EXP. This set uses the characteristic Account and contains all of your expense accounts.

Using sets, you define which data is used in your report and how the data appears in report rows and columns.

Using sets in the Report Writer offers the following advantages:

- Simple creation and editing of reports
Report Writer

- Multiple usage of the same sets in many reports
- Multidimensional reporting

Sub-totals at levels defined by the user

The Report Writer is a multidimensional reporting tool. When you use the Report Writer, you can easily rearrange the characteristics within a report. In the following graphic, the characteristics **Cost Center** and **Account** make up the rows of the report; local and group currency make up the columns of the report.

![Cost Center and Account Matrix](image)

Changing the order of characteristics used in this report involves only a small change in a set used in the report; you do not have to change the report itself. You can easily report on any combination of characteristics without having to maintain complicated user tables in the background.

Using **variables** [Seite 689] (value, formula or set variables) provides you with great flexibility via different options for characteristic and group values in the report design.

You have many possibilities for portraying Report Writer reports: You can, for example, vary the level of detail.

You can convert a Report Painter report to a Report Writer report in Report Writer. In this way you can use all the functions available in Report Writer for the report that was originally a Report Painter report. For more information, see **Report Writer reports** [Seite 804].

For more information about Report Writer, see:

- **Report Writer Reports** [Seite 804]
- **Report Writer Utilities** [Seite 912]
- **Report Groups** [Seite 937]
- **Report Painter** [Seite 726]
- **Report Painter or Report Writer?** [Seite 724]
Report Painter Reports [Extern]

For information about terminology within reporting, see terminology [Seite 1037].
Working with the Report Writer

**Purpose**

This process describes the main steps in creating a Report Writer report.

**Process flow**

The following graphic is an example report. Cost centers and accounts are listed in the rows of the report and currency types (local and group) are listed in the columns.

<table>
<thead>
<tr>
<th>08.09.1995</th>
<th>Revenue&amp;Expense/Cost Center</th>
<th>Local Curr.</th>
<th>Group curr.</th>
</tr>
</thead>
<tbody>
<tr>
<td>400010</td>
<td>Sales revenue</td>
<td>800,000.00</td>
<td>1,272,000.00</td>
</tr>
<tr>
<td>400020</td>
<td>Investment income</td>
<td>900,000.00</td>
<td>1,433,999.95</td>
</tr>
<tr>
<td>* Revenue accounts</td>
<td>1,700,000.00</td>
<td>2,705,999.95</td>
<td></td>
</tr>
<tr>
<td>300010</td>
<td>Sales costs</td>
<td>90,000.00</td>
<td>145,800.00</td>
</tr>
<tr>
<td>300010</td>
<td>Wages and salaries</td>
<td>12,000.00</td>
<td>19,440.00</td>
</tr>
<tr>
<td>* Expense accounts 100 Administration</td>
<td>102,000.00</td>
<td>166,240.00</td>
<td></td>
</tr>
<tr>
<td>* * 400010</td>
<td>Sales revenue</td>
<td>275,000.00</td>
<td>421,500.00</td>
</tr>
<tr>
<td>400020</td>
<td>Investment income</td>
<td>289,000.00</td>
<td>444,180.01</td>
</tr>
<tr>
<td>* Revenue accounts</td>
<td>564,000.00</td>
<td>865,680.01</td>
<td></td>
</tr>
<tr>
<td>300010</td>
<td>Sales costs</td>
<td>120,000.00</td>
<td>194,400.00</td>
</tr>
<tr>
<td>300020</td>
<td>Wages and salaries</td>
<td>20,000.00</td>
<td>32,400.05</td>
</tr>
<tr>
<td>* Expense accounts 200 DP</td>
<td>140,000.00</td>
<td>226,800.05</td>
<td></td>
</tr>
<tr>
<td>* * * Cost centers</td>
<td>2,022,000.00</td>
<td>3,179,639.91</td>
<td></td>
</tr>
</tbody>
</table>

You can define the above report in the following steps:

1. **Create sets for the report rows and columns and sets to select data for the report.**
   
   You use a set to determine which data appears in the rows and columns of a report and to determine which data is selected for the report.

   - You can use a set as a row, column, or as selection criteria, depending on how you want to display the data in the report. Also, since the same set can be used in many different reports, you do not need to create new sets each time you define a report. Instead, you can use existing sets that meet your reporting needs.

   - You **must** use certain set characteristics in a report. You must use sets that contain values for the characteristics "Ledger", "Company", "Version", "Period", and "Record Type" either in the report rows, the report columns, or as data selection criteria.

**Sets for Report Rows:**
The set you use in a report row is referred to as a row block and may consist of one or more physical rows. In the above report, the set TD-CC-ACCT is used as a row block. It contains the following sets:

- **TD-RCNTR-12**
  This basic set contains cost centers 100 and 200.

- **TD-RACCT-IE**
  This single-dimension set contains the basic sets **TD-RACCT-INC** (containing income accounts 4000010 and 4000020) and **TD-RACCT-EXP** (containing expense accounts 3000010 and 3000020).

**Sets for Report Columns:**

The set you use in a report column is referred to as a column block and may consist of one or more physical columns.

In the above report, the column set, or column block, is TD-ACT-TL (actual data in local and group currency). This data set contains the following values:

- **HSL-0** (local currency, actual data)
- **KSL-0** (group currency, actual data)

For each value in the set, the Report Writer creates a physical column.

**Sets as General Selection Criteria for Report Data:**

You also create sets that determine the data that is selected for a report.

You create a set with the characteristic “Year” that contains the value **1995**. If you use this set as selection criteria in a report, the Report Writer only extracts data for 1995.

For more information on using sets for Report Writer, see [uses of sets in Report Writer](#).

**2. Select a library for the report.**

Before defining the actual report, you need to select a library for the report. A library is a collection of characteristics (such as “account”, “cost center”, “company”), basic key figures (such as local costs, total costs and activity quantity), and key figures (such as actual costs in the current fiscal year) used in a report definition. Report definitions in one library can only use the characteristics, basic key figures, and key figures that are defined for that library.

For more information, see [library](#).

**3. Define the report.**

a) Define the report row(s).

On the Create Report: Rows screen, you enter the set(s) that you want to include in the report row block(s). The set you choose determines the row items that are in the report. You can also enter additional text to define your own text for the lead column/sum total, instead of using the text from the set header. You can also define formulas and key figures in a row block.

b) Define the report column(s).
Working with the Report Writer

On the Create Report: Columns screen, you enter the set(s) that you want to include in the report column block(s). The set you choose determines the columns that are in the report. You can also enter additional text to define your own text for the lead column/sum total, instead of using the text from the set header.

**c)** Enter the sets to be used as selection criteria for selecting report data.

On the Create Report: General Data Selection screen, you enter the set(s) that you want to be used to select the report data. You can also enter a selection rule for further defining selection criteria.

**d)** Enter report text, if required.

You can enter report texts on the Create Report: Texts screen. You can enter texts for the title page, headers, footers and the last page of your report. In addition, you can enter a special text that is used when exporting the report to Microsoft Excel. You can also enter various text variables, such as the date and user name, which appear when the report is output.

**e)** Review the default report layout and change as necessary.

SAP supplies you with a default standard layout for all of your reports. Standard layouts determine the page layout of the report and the numeric format of the report data. If you use the default parameters, you can skip this step. If you want to change some of the parameters, you use the Create/Change Standard Layout screens.

For more information about creating standard layouts, see standard layouts [Seite 1017].

For more information about changing default parameters for a specific report, see defining report layouts [Seite 1031].

For more information on defining reports, see Report Writer reports [Seite 804].

**4. Check the report.**

Once the report definition has been completed, you should check the report for errors and warnings. Using the Report → Check function, you can list any errors and warnings associated with producing the report.

**5. Assign the report to a report group.**

After you have defined a report, you assign it to a report group. A report group can contain one or more reports from the same library. When reports contain the same characteristics and share the same data, data is selected faster and processing time is quicker because report data is only selected once.

For more information, see report groups [Seite 937].

**6. Generate a report group.**

During this step, the Report Writer generates the programs necessary for processing the reports.

For more information, see generating a report group [Seite 952].

**7. Execute the report group.**

In this step, the Report Writer selects all the database records used in the report and outputs them in the specified format.
For more information, see report group execution [Seite 962] and the procedure executing a report group [Seite 964].
Report Writer Reports

Use
In addition to the Report Painter [Seite 726], you can also define reports using the more comprehensive functions of the Report Writer. The following components are required to define Report Writer reports:

- Report texts
- Report layout
- Report rows and columns
- Selection criteria for the report data
- Cells and key figures

Features
Before defining a report, you must create sets [Seite 633] to use in the report. Using sets, you create report row and column blocks and store the selection criteria for selecting report data. For more information, see Sets in the Report Writer [Seite 891].

Converting a Report Painter Report into a Report Writer Report
Although the Report Painter does not currently support all the functions of the Report Writer, you can convert a Report Painter report into a Report Writer report in order to use the complete range of functions provided by the Report Writer. To do this, follow the procedure for creating a new Report Writer report using the Report Painter report as a reference. The Report Painter report is copied and becomes available as a Report Writer report. The system automatically generates the necessary sets, so that you do not have to enter the prefixes for the set names.

You can not, however, edit the sets generated in this way using the set maintenance function. Nor can you use these sets in other reports or functions.

For more information on creating reports, see:
- Creating a Report Painter Report [Seite 811]
- Process Example: Creating a Report Writer Report [Seite 806]
- Defining Report Headers [Seite 817]
- Defining Report Texts [Seite 825]
- Using Variables in Report Text Definition [Seite 826]
- Defining Report Layouts [Seite 1031]
- Defining Selection Criteria [Seite 835]
- Defining Rows [Seite 841]
- Defining Columns [Seite 854]
- Defining Cells [Seite 864]
- Defining Global Cells [Seite 870]
Defining Key Figures [Seite 875]
Defining Report Documentation [Seite 945]
For more information on editing reports, see:
Checking a Report [Seite 813]
Displaying a Report [Seite 814]
Changing a Report [Seite 815]
Deleting a Report [Seite 816]

Parallel reports are no longer officially supported. You can no longer call up the maintenance transactions for parallel reports from the system menus. You can only create and maintain parallel reports using the respective transaction codes. You can still use parallel reports in report groups.

Alternatively, you can include several reports in one report group or use several sections within one report. You can then switch between the reports or sections within one report group.

A second alternative is to display two reports or two sections in two separate windows. If the system takes a long time to select the data for the report, we recommend that you store the selected data in an extract and display the extract in a second window.
Process Example: Creating a Report Writer Report

Purpose
The following example shows you how to construct the cost center report 1 SIP-001 (described in the Example process: Creating a Report Painter Report [Extern] section) using the Report Writers [Extern].

You will learn how to create new reports using existing Report Writer sets and variables. To create a cost center report, access Cost Center Accounting and choose:


Prerequisites
You first define your report requirements.

The cost center report should provide the following information:

- The actual and plan costs of a cost center [Extern] or cost center group [Extern] should be structured by cost elements [Extern] and displayed with the absolute and relative variances [Extern].
- Debit and credits are to be displayed in different rows.
- The reporting period may include as many periods per fiscal year as required.
- You should be able to call up the report for specific cost centers or cost center groups.
- The appropriate actual and plan figures should be displayed on a separate page, sorted by cost element, together with absolute and relative variances.
- Actual and plan statistical postings (postings that are updated with a different cost element type) together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.
- Actual and plan activity types [Extern] together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.
- Actual and plan statistical key figures [Extern] together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.

Before you define the report, you must decide:

- Which characteristics should appear in the report?
- Where are these characteristics to be entered?
- Which report characteristics should be variable and which should be fixed?
- Can variables already defined for report requirements be used with the new report?

A characteristic can only be used once in a report, in report rows, report columns, or data selection criteria. You decide the most appropriate location for the characteristic.
The following characteristics are required for the example cost center report.

<table>
<thead>
<tr>
<th>General data selection characteristics</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>KOKRS</td>
<td>Controlling Area [Extern]</td>
</tr>
<tr>
<td>KOSTL</td>
<td>Cost center group</td>
</tr>
<tr>
<td>GJAHR</td>
<td>Fiscal Year [Extern]</td>
</tr>
<tr>
<td>PERBL</td>
<td>Periods</td>
</tr>
</tbody>
</table>

The characteristics "Fiscal year and "Period" can remain general data selection criteria, since every column of the report will contain values from the same time period. If you want the report columns to represent different reporting periods, however, you must place these characteristics in the appropriate columns.

<table>
<thead>
<tr>
<th>Report row characteristics</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>KSTAR</td>
<td>Cost element</td>
</tr>
<tr>
<td>BELKZ</td>
<td>CO debit/credit indicator</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Report column characteristics</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>WRTTP</td>
<td>Value type (actual, plan)</td>
</tr>
<tr>
<td>VERSN</td>
<td>Version [Extern] (actual version is always 0)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Key figures in the report columns</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>SWKG</td>
<td>Costs</td>
</tr>
</tbody>
</table>

The next step when defining the report is to check whether you can use existing sets for rows, columns, and general data selection criteria.

**Process Flow**

1. **Defining Report Rows**

To access row maintenance, choose Rows in the *Report Definition* screen.

You can use row sets to display the hierarchical structure of the cost elements and to calculate group totals at various levels. In the Cost Center Accounting menu you have created at least one cost element group. The SAP R/3 System created cost element sets, which you can now use as row sets. By entering such a set in the row definition, the report is always be generated using the cost elements entered for those rows.
Process Example: Creating a Report Writer Report

If instead you wish to enter the cost element group when the report is started, you must enter a multi-dimensional set in a report row containing a set variable. This set variable acts as a placeholder for the cost element group. When such a variable is defined in the report, the SAP R/3 System allows you to enter the cost element group or interval in the report selection screen.

The example cost center report should also distinguish between debit and credit postings. This is done by including characteristic BELKZ in the multi-dimensional set in addition to the cost element. The value of characteristic BELKZ can either be D (for debit) or C (for credit).

Use multi-dimensional set 1-L-IP-SH for the example cost center report. Note that the single dimension set 1-S-BELKZ is located in the first set row, followed by the set variable &1KSTAR in the second set row. As a result, the report first displays all debit postings for the cost center, followed by all credit postings. The cost elements are be sorted and totaled in these logical rows according to the set structure for the indicated cost element groups. Report Writer generates a subtotal at every set level.

In addition to the group totals derived from the cost element structure, the report also generates a total for each BELKZ characteristic value and a grand total for the multi-dimensional set.

The SAP R/3 System automatically identifies a logical report row within a given report, based on the row set description (such as 1-L-IP-SH “Cost elements”). The system derives the ID for the highest order group total from the first set in the multi-dimensional set found in the report row (such as 1-S-BELKZ “Over-/underabsoption”). All other lower order group total IDs are likewise derived from the respective set description (such as 1-S-BELKZ-S “Total costs”).

You can create other report texts that differ from the set descriptions defined in Set Maintenance. Choose Extras → Additional texts from the row or column definition dialog box and enter the specific report text for the lead column and a grand total in either Texts for Column Block or Texts for Row Block.

You can use characteristic BEKNZ in addition to characteristic BELKZ. If you use characteristic BELKZ, the report totals the debit and credit postings per cost element for both manual or periodic repostings. These postings are displayed as total costs. Moreover, reversing FI documents with the cost center account assignment feature balances out any credit posting entries by using the original debit entry for the account. Alternatively, using characteristic BEKNZ results in the debit and credit postings being displayed in separate rows, even in the case of repostings.

2. Defining Additional Report Rows

Just as with report 1SIP-001, you can also define additional logical report rows for the example cost center report that represent activity types, statistical key figures, and
statistical postings. The latter postings are those made to the cost element records, but which are updated later using a different cost element category.

You may use a characteristic value within the report rows more than once. The same applies to report columns. However, you cannot use a characteristic in a row and a column.

3. Defining Report Columns

Assume you now want to display the actual and plan figures for particular posting periods in the columns of the example cost center report, including absolute and percentage variances. You need to enter the predefined column 1-C-IP in the report, containing the predefined columns ISWKG (actual costs) and PSWKG (plan costs). The characteristics VERSN (=version) and WRTTP (=value type) are stored in additional sets for the predefined columns ISWKG and PSWKG.

Use the Layout variation function to establish how the values are displayed in the report. Each report has five variations available for this purpose. A single variation establishes column width, the column number for the value’s unit, and the number of decimal places and exponents for the report output. You can change these values for a particular report with the report layout function or save them in a standard layout. You can assign a display variant to each column in the report. You define this in the “P” column in the basic entries for the predefined columns.

The first three columns have been assigned display variant “0” in data set 1-C-IP, and the fourth column has been assigned variant “2.” The fourth column will thus be 10 characters wide, not 20.

You can only perform arithmetic calculations within a column block. This means that the formulas may not refer to other predefined columns.

In the event your report uses more than one logical row or column, you must be sure only to activate logically permitted combinations so that your report generates useful results.

Assume that the cost center report should now display statistical key figures. In this case, it only makes sense to use a column set that also displays the statistical key figure values. All other columns for these report rows should be deactivated. In this instance, the appropriate column set is 1-C-SSK.

To deactivate individual columns in the row definition dialog, place the cursor on the desired row and choose Inactive columns. In the Inactive Columns dialog box, select the columns you wish to deactivate.

4. Defining General Data Selection Criteria

Use general data selection to define the characteristics you wish to use to select the data for the entire report. You can only use characteristics as general data selection criteria that you have not yet used in the individual rows or columns of the report.
Process Example: Creating a Report Writer Report

With the exception of multi-dimensional sets, you can use all set types as general data selection criteria. You can also use set variables. However, you can only use those characteristics that have not been entered in the row or column definitions.

In the case of the example cost center report, the reporting objects are the cost centers themselves. Set variable &1KOSET was used for this characteristic. As a result, you are able to enter a cost center set or individual cost center values when you call up the report. Report Writer creates a report that sums up all postings for the selected cost centers and displays the same by cost element.

On the other hand, you should use a variation if you want to generate a report for each individual cost center for the set and for all levels of the cost center set. Use the Vary function to enter the group level for characteristic KOSTL to which Report Writer should expand the cost center set. The default value is 1 to 99, with level 1 being the highest hierarchical node and level 99 the lowest. If you also want to create a report for each individual cost center, you must additionally set the “I” indicator (individual value).

If you do not want to vary your cost center set on all levels, use other values. Level 1 indicates the highest hierarchical node and level 99 the lowest.

You can only activate the variation when you start your report if you have set this indicator.

You must use the characteristic "Controlling area" for reports assigned to table CCSS. The controlling area characteristic can only be used as an individual value, and then only in the general data selection criteria.

Before saving the report and assigning it to a report group, check your report definition for syntax errors. Choose Report → Check The SAP R/3 System generates an error log listing any errors found.
Creating a Report Painter Report

Procedure

2. From the relevant application, choose Tools → Report Painter → Report → Create.


   Enter the name of the library the report is to use, and a name and description for the report. The report name can be a maximum of eight characters long.

   If you want to create your report using an existing Report Painter report as a basis, enter the name of the report that you want to copy under Copy from. Both reports must use the same library.

5. Choose Create.

   The next screen displays an empty report containing four rows and four columns (this is the basic structure for a report). You define your report on this screen.

6. Enter or change the description for the report by double-clicking the report description field.

   A dialog box appears in which you can enter a short, medium, and long text for the report description.

7. Define the rows of your report (see Defining Rows [Seite 751]).

   Rows contain a combination of characteristic values or formulas. Note the lead column at the first position of the rows. The Report Painter uses the lead column to access the rows. You can replace the description Lead column with a different term.

8. Define the columns of your report (see Defining Columns [Seite 748]).

   Columns contain a combination of a basic key figure and optional restricting characteristic values. You can also use predefined key figures to present key figures and characteristics that make business sense. For example, a number of predefined key figures are delivered for the libraries in Overhead Cost Controlling that can be copied directly into the reports, where they can be modified as required.

9. Define general data selection criteria (see General Data Selection [Seite 762]).

   The general data selection criteria restrict data selection for the report.

11. Choose Save and then Execute to create the report.

12. Assign the report to a report group [Seite 937].

   You have to display the report before you execute it, so that you can later change the report layout directly from the report list.
Creating a Report Painter Report

Once you have defined a report, you can display and print out a table of contents with Extras → Overview.

The overview contains the characteristics and characteristic values used in the individual sections, column blocks, and general data selection criteria. It also provides general information such as the user who last changed the report, the report name, and the standard layout assigned to the report, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.

For more information, see:

Defining Report Headers [Seite 817]
Defining Report Text [Seite 825]
Defining Report Layouts [Seite 1031]
Defining Cells [Seite 864]
Defining Global Cells [Seite 870]
Defining Report Documentation [Seite 945]
Checking a Report

Use
Once you have created or changed a report, you should run the check report function to check the report for errors. When you run the check report function, the system lists any errors or warnings in the report definition.

Prerequisites
A report cannot be generated if it contains any errors. If only warnings are issued, you can still generate the report. However, you may experience long runtimes.

Procedure
From the screen Create Report, choose Report → Check.

- If there are no errors or warnings in the report definition, the following message appears:
  
  No errors found in the report

- If there are errors in the report definition, a dialog box lists the errors and/or warnings in the report. For detailed information on the errors or warnings, double-click the relevant message.

  Errors can sometimes occur because a set has been changed since the report was last generated.
Displaying a Report

   The Display Report: Initial Screen appears.

2. Enter the following information:
   - The name of the library to which the report is assigned
   - The name of the report you want to display

3. On this screen, the additional processing functions in the table for Create Report: Initial Screen are available in Creating a Report [Seite 811].
Changing a Report Definition

Prerequisites

If you change a report [Extern] definition or a set [Extern] that is used in a report definition, you must regenerate all report groups [Seite 952] that contain the report. When a report and/or set definition within a report group is changed, the report group is flagged; when you attempt to execute the flagged report group, the system prompts you to regenerate the report group before the system executes it. Once the report group has been regenerated, the report will reflect your changes.

Procedure

   The Change Report: Initial Screen appears.
2. Enter the following data and choose Header:
   – The library name of the report definition you want to change
   – The name of the report definition you want to change
3. Type over existing values with your changes.
4. To save your changes, choose Report → Save.

   For Report Writer reports you can use the function Utilities → Layout control to view your changed report, without data having to be loaded. For more information, see displaying report layouts [Seite 1030].
Deleting a Report

You **cannot** restore a report once it has been deleted.

   
   The screen **Delete Report: Initial Screen** appears.

2. Enter the following information:
   
   – The name of the library to which the report is assigned
   
   – The name of the report you want to delete

3. Choose **Delete**.

   A dialog box asks if you want to delete the report.

4. Choose **Yes**.

   The report is deleted.

   ![Green Arrow](Image)

   You cannot delete a report if it is used in a report group [Seite 937].
Defining Report Headers

1. In the Report Writer [Seite 797], you choose the Header button from one of the Create Report screens.

   The Create Report: Header screen appears.

2. Enter the following information:
   - A short description of the report
   - If you want user authorization to be required for creating, displaying, changing, and deleting this report, enter an authorization group. If you do not want to require user authorization, leave this field blank.
   - The standard layout that you want to assign to your report
   - The language in which you want to maintain the report, and the original language. The default language is the logon language.

   You can specify your characteristics to be unique or non-unique (multiple usage allowed) as required.

3. To enter default parameters for exporting the report to an application or presentation server when executing the report's report group, choose Extras → Export parameters.

   A dialog box appears in which you enter export data as required. The default values you enter appear when you call up the Report → Export function in the report output. You can change these default parameters as required.

   For more information about the data you enter in the export dialog box, see Exporting a Report to an External File [Seite 985].

4. This screen includes the following additional processing functions.

   Additional Processing Functions (Create Report: Header Screen)

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check report for errors before you execute it</td>
<td>Report → Check</td>
</tr>
<tr>
<td>Define report layout, or reset layout parameters to default values of standard layout</td>
<td>Goto → Report layout</td>
</tr>
<tr>
<td>Display list of characteristics used in the report</td>
<td>Extras → List of characteristics</td>
</tr>
<tr>
<td>Switch to a new report language (for example, to enter language-specific text)</td>
<td>Extras → Maintenance language...</td>
</tr>
<tr>
<td>Assign new standard layout to the report</td>
<td>Extras → Other std layout...</td>
</tr>
<tr>
<td>Define default export parameters for exporting the report</td>
<td>Extras → Export parameters...</td>
</tr>
</tbody>
</table>
Entering Language-Specific Report Header Information

Use
On the Create Report: Header screen, you can enter a report description that is specific to a language.

Suppose you define a report in English, but you also want the report to be used by your German subsidiary. You use the Maintenance lang. function to set the language for entering report information (such as the report title) that is specific to the language of the foreign subsidiary.

You can enter language-specific report text for the report description (Create Report: Header screen) and the report texts (Create Report: Texts screen). Valid languages for report texts are defined in Customizing. For more information, see the Implementation Guide (IMG) for Special Purpose Ledger under Information System → Define Report Writer Languages.

Procedure
1. Choose Extras → Maintenance lang.
2. In the dialog box, select the language you want to maintain for the report.
3. Choose ✓ Choose.
   You can now enter a report description on the Create Report: Header screen that is specific to the report.

When you use the Maintenance lang. function and switch to a new language, the information you enter for the report continues to be displayed in that language until you switch back to your first language.

For example, if you switch to language DE (German) from EN (English) and then define report texts, the information you enter will be displayed in German until you switch back to English. SAP recommends that you first define and save a report in one language before switching to another language.
Freezing Page Headers

Use

In the on-screen report output in list format, you can freeze the page headers (headers and column headings) to prevent them from disappearing when you scroll.

When the freeze page header function is activated, the headers and the column headings (if the page only contains a single section) are frozen in position. On pages that contain multiple sections, only the headers can be frozen, since otherwise the column headings of the first section of the page will be displayed on all following sections.

Procedure

In the report output, you freeze the page headers under Settings → Options... by selecting Freeze page header in the group header List output.

If the window height is less than the frozen area, you cannot scroll vertically. Increase the size of the window or unfreeze the page headers.
Sections

Use
A Report Writer report [Seite 804] consists of one or more sections. The sections are output in the order specified by the sequence number.

A section consists of multiple row blocks that form a logical unit. When the report is edited, the rows of a section are displayed on a separate screen.

Features
• You can enter text for each section.
• You can specify whether new column headings should be printed separately for each section.
• You can define a page break for each section.
• You can use a different section layout [Seite 1028] for each section.
  Section layouts contain control information on how row totals, row texts, and column texts. For more information, see Report Text [Seite 824].
  You can also apply the report layout [Seite 1029] to sections. Any changes you make to the report layout then become effective automatically in the sections where it was applied.
• You can define threshold values for each section. For more information, see Entering Threshold Value Conditions [Seite 994].
• Sorting conditions can be defined for the rows of a section.
• The section settings can also be changed in the report output.
Defining Sections

Use
A section consists of one or more physical rows and columns forming a logical unit. In the vertical direction, a report consists of one or more sections. Each section is displayed on a new screen. You can define sections with key figures and characteristics, as well as sections with derived basic key figures.

In a section that contains calculated key figures, you can create an overview of the most important values used in your report. A section with calculated key figures is a new report section and is displayed on a new screen. You normally define a section with basic key figures at the end of your report.

Sections with Calculated Key Figures
3. To define a section with calculated key figures, first select the cells you want to use in the section. For information on selecting cells, see Defining Cells [Seite 758]. You can also enter your own text for these cells.

4. Choose Edit → Sections → New section. In the New Report Section dialog box, select Section with calculated key figures.

5. Position the cursor on the row or column and choose Edit → Elements → Define element or double-click on the row or column.

The section with calculated key figures is made up of a row/column structure in which you enter short, medium, and long texts.

6. Define the cells you want to use in the section at the point of intersection of the row/column combination. Position the cursor on the appropriate cell and choose Edit → Elements → Define element, or double-click on the cell.

You enter cell calculations for the section with key figures in the Formula Builder. All selected cells of the report are displayed in the Formula Builder as buttons. You can then define your key figure formula as required.

The Formula Builder enables you to use the selected cells in the section with calculated key figures. You can also use cells that were calculated using the selected cells.

Another feature is that you can reselect cells used in the section with calculated key figures to calculate values for other cells within the section (recursive cell definition).

If you don’t want to display or print the cells you use in your section with calculated key figures in the other sections of your report, you can hide the corresponding rows and columns by choosing Edit → Rows/Columns → Hide.

Sections with Characteristics and Key Figures
3. To define a new section in your report, choose Edit → Sections → New section.

4. In the following dialog box, select Section with characteristics and key fig.
Defining Sections

A new row and column structure appears for you to define your new report section. You define rows and columns as described under Defining Columns [Seite 748] and Defining Rows [Seite 751].

4. You can switch between the different sections by choosing Goto → Section → and then First section, Previous section, Next section, or Last section.

You can only perform calculations using columns within the same section. For calculations between sections that use columns, you must select cells. For more information, see Defining Cells [Seite 758].

Once you have defined a report, you can display and print out a table of contents of the report with Formatting → Section overview.

The overview contains the characteristics and characteristic values used in the individual sections, horizontal pages, and general data selection criteria. It also provides general information such as the user who last changed the report and the report name, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.
Section Layout

Use
There are a number of different ways you can modify the layout of the sections in a report:

- You can apply the parameters specified in the report layout
- You can apply a section-specific layout

Features
You can use a different layout for each section. Section layouts contain control information on:

- Row totals
- Row texts
- Column texts

You can also apply the report layout [Seite 1029] to sections. Any changes you make to the report layout then become effective automatically in the sections where it was applied.

The section layout can be defined differently for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

In the section overview in the Report Painter, you can change the attributes of the sections, the sequence of the sections, and the page breaks between the sections. This includes overscores and underscores, and how the headers should be printed.

For more information on formatting, see Summation Levels [Seite 1034].
Report Text

Use

In a Report Painter or Report Writer report, you can enter texts for the following:

- Title page
- Headers
- Footers
- End page

These texts are used for list output and exports in text format.

- Text for export

The text for export is used for Office integration and for exports into HTML or spreadsheet format. The definition of report texts in the Report Painter is similar to that in the Report Writer.

You can also define report texts in the report output. SAP recommends that you enter report texts only after the report has been executed and output. This allows you to see which values the report text variables will use.

Prerequisites

You can only change texts in the report output if the report uses a standard layout [Seite 1017] in which the Change alwd dur exctn indicator is selected on the Page/Control screen. You cannot change texts in standard reports included with your SAP R/3 System.

Features

You can enter the following types of texts for report texts:

- Normal text
- Standard text variables such as the date, user name, and page number
- Special text variables
- Text variables for selection parameters
- Text variables for characteristics used in the text

For more information, see Variables in Report Text Definition [Seite 826].
Defining Report Texts

To enter report texts from any Create Report screen:

6. Report Writer

   From the screen Create Report or Change Report or Display Report: Initial Screen, choose Goto → Texts.


   Report Painter


7. To enter text, choose one of the processing functions in the following table.

   Processing Functions for Text Definition

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose (Report Painter)</th>
<th>Choose (Report Writer)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter text for title page</td>
<td>Title page</td>
<td>Title page</td>
</tr>
<tr>
<td>Enter text for headers</td>
<td>Headers</td>
<td>Headers</td>
</tr>
<tr>
<td>Enter text for footers</td>
<td>Footers</td>
<td>Footers</td>
</tr>
<tr>
<td>Enter text for last page</td>
<td>End page</td>
<td>End page</td>
</tr>
<tr>
<td>Enter text for export of report to HTML and Office Integration</td>
<td>Text for export</td>
<td>Text for export</td>
</tr>
</tbody>
</table>

   The screen Change <text position> <report name> in Language <language code> appears.

   If these functions are not available, choose Formatting → Report layout and check whether Change allowed during execution is selected on the tab Page/control.

8. Choose Text → Save.
9. Choose Text → Exit.

   The text appears on the Create Report: Texts screen.

10. To save the report, choose Report → Save.

Entering Variables in Report Text

In the report output, you can insert text variables, frames, and rows with Insert. For more information about the different types of text variables you can define in your report text, and how to enter variables in report text, see Using Variables in Report Text Definition [Seite 826].
Variables for The Definition of Report Texts

You can use the following categories of text variables when defining report texts:

- **Standard text variables**
  For more information, see Using Standard Text Variables In Report Text Definition

- **Special text variables**
  For more information, see Using Special Text Variables in Report Text Definition

- **Text variables for selection parameters**
  For more information, see Using Text Variables For Selection Parameters in Report Text Definition

- **Text variables for characteristics used in the report**
  For more information, see Using Text Variables For Characteristics in Report Text Definition

[Using Standard Text Variables in Report Text Definition [Seite 827]]
[Using Special Text Variables in Report Text Definition [Seite 829]]
[Using Text Variables for Selection Parameters in Report Definition [Seite 831]]
[Using Text Variables for Characteristics in Report Definition [Seite 833]]
Using Standard Text Variables in Report Texts

Use

A standard text variable is an SAP-delivered variable, which you can enter directly into a report when defining report text. The system calculates the value for the variable based on current system records.

- Author of report
- Date of report creation
- Time of report creation
- Page number

The standard text variables Horizontal double line in report width and Horizontal line in the report width replace the %FILL- and %FILL= variables for filling a line with the non-alphabetic characters - and =.

Procedure

To enter standard text variables when defining report text on the Change <Text Position> <Report Name> in Language <Language Code> screen:

1. Position the cursor at the point where you want to insert the variable and choose Insert → Standard variables.

   The Standard Text Variables dialog box appears. A list of the standard text variables that can be used is displayed.

2. Move the cursor to the standard text variable that you want to include in your report text and choose Choose.

   The text variable is inserted at the point where you positioned the cursor on the Change <Text Position> <Report Name> in Language <Language code> screen.

3. If you want to change the parameters controlling the display of the text variable in the report output:

   a) Choose Edit → Attributes.

      The Change Attributes dialog box appears.

   b) Enter the display attributes for the text variable:

      - Define whether the color used for the text variable is intense or the standard color.
      - Enter a color code if you want to display the variable in color.
      - Define the width of the text variable.
      - Define the offset for the text variable.

      For example, if you define a width of 20 and an offset of 5, characters 6 to 25 will be printed.
Using Standard Text Variables in Report Texts

4. You can use the following additional processing functions on this screen.

**Additional Processing Functions**

**Change** <Text Position> <Report Name> in Language <Language Code> Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text → Template</strong></td>
<td>Copy existing text as your report text (for example, header text from a different report or in a different language). You can then overwrite this text and save it.</td>
</tr>
<tr>
<td><strong>Text → Save</strong></td>
<td>Save the report text.</td>
</tr>
<tr>
<td><strong>Text → Delete</strong></td>
<td>Delete report text in all languages.</td>
</tr>
<tr>
<td><strong>Edit → Cut</strong></td>
<td>Cut the selected variable and place it in the clipboard.</td>
</tr>
<tr>
<td><strong>Edit → Copy</strong></td>
<td>Copy the selected variable and place it in the clipboard.</td>
</tr>
<tr>
<td><strong>Edit → Paste</strong></td>
<td>Insert the contents of the clipboard at a selected position in the report text.</td>
</tr>
<tr>
<td><strong>Edit → Insert row</strong></td>
<td>Insert a line for entering report text.</td>
</tr>
<tr>
<td><strong>Edit → Attributes</strong></td>
<td>Change the parameters controlling the display of the text variable in the report output.</td>
</tr>
<tr>
<td><strong>Edit → Page width</strong></td>
<td>Change the page width for entering report text.</td>
</tr>
<tr>
<td><strong>Edit → Delete row</strong></td>
<td>Delete the text line.</td>
</tr>
<tr>
<td><strong>Edit → Delete variable</strong></td>
<td>Delete the selected text variable.</td>
</tr>
<tr>
<td><strong>Insert → Standard variables</strong></td>
<td>Insert standard text variables in the report text.</td>
</tr>
<tr>
<td><strong>Insert → Selctn parameters</strong></td>
<td>Insert text variables for selection parameters in the report text.</td>
</tr>
<tr>
<td><strong>Insert → Special variables</strong></td>
<td>Insert special text variables in the report text.</td>
</tr>
<tr>
<td><strong>Insert → Characteristics</strong></td>
<td>Insert text variables for characteristics in the report text.</td>
</tr>
<tr>
<td><strong>Insert → Frame</strong></td>
<td>Draw a frame around the report text.</td>
</tr>
<tr>
<td><strong>Insert → Insert row</strong></td>
<td>Insert a line for entering report text.</td>
</tr>
<tr>
<td><strong>Extras → Master language...</strong></td>
<td>Change the master language in which you want to enter the report text. (The logon language is automatically defaulted as the master language.)</td>
</tr>
</tbody>
</table>

5. Choose **Text → Save**.

6. Choose **Text → Exit**.

The variable appears on the *Create Report: Texts* screen.
Using Special Text Variables when Defining Report Texts

A special text variable provides information from master data files associated with characteristics used in a report. Special text variables are supplied for each reporting table delivered with the SAP R/3 System.

In a Controlling report, you could use special text variables to enter the name of the cost center manager and the manager’s department.

To enter special text variables when defining report text on the Change <Text Position> <Report Name> in Language <Language Code> screen:

1. Position the cursor at the point where you want to insert the variable and choose Insert → Special variable.
   The Choose Master Data Table dialog box appears. A list of the reporting master data tables defined for the table your report uses is displayed.
2. Select the table that contains the characteristics for the variables you want to use and choose Choose.
   The Choose Master Data Field dialog box appears.
3. Enter the following information:
   - Select the text type that you want to use for the text variable (characteristic description, characteristic value, short text of the characteristic, long text of the characteristic).
   - Select the master data field for which you want to display the text variable in the report text.
4. Choose Continue.
   The variable is inserted at the point where you positioned the cursor on the Change <Text Position> <Report Name> in Language <Language Code> screen.
5. If you want to change the parameters controlling the display of the text variable in the report output:
   a) Choose Edit → Attributes.
      The Change Attributes dialog box appears.
   b) Enter the display attributes for the text variable:
      - Define whether the color used for the text variable is intense or the standard color.
      - Enter a color code if you want to display the variable in color.
      - Define the width of the text variable.
      - Define the offset for the text variable.
      For example, if you define a width of 20 and an offset of 5, characters 6 to 25 will be printed.
Using Special Text Variables when Defining Report Texts

6. On this screen, the additional processing functions in the table in Using Standard Text Variables in Report Text Definitions [Seite 827] are available.

7. Choose Text → Save.

8. Choose Text → Exit.

   The variable appears on the Create Report: Texts screen.
Report Definition: Using Text Variables for Selection Parameters

Text variables for selection parameters are variables defined in the sets that are entered in the report definition. A selection parameter variable can be:

- A value variable
- A set variable

These variables replace the variables of the type %%<variable name>, %%<variable name>-TEXT (short text) and %%<variable name>-TXTL (long text), which were used in releases prior to 3.0.

When you define the general data selection criteria for your report, you enter a set that contains the variable COMP (for the characteristic Company). You can now enter a text variable for the characteristic Company in the report text, for example, the header.

To enter selection parameter text variables when defining report text on the Change <Text Position> <Report Name> in Language <Language Code> screen:

1. Position the cursor at the point where you want to insert the variable and choose Insert → Selctn parameters.
   The Selection Parameters dialog box appears.
2. Enter the following information:
   - Select the text type that you want to use for the text variable (characteristic description, characteristic value, short text of the characteristic, long text of the characteristic).
   - Select the characteristic for which you want to display the text variable in the report text.
3. Choose Continue.
   The variable is inserted at the point where you positioned the cursor on the Change <Text Position> <Report Name> in Language <Language Code> screen.
4. If you want to change the parameters controlling the display of the text variable in the report output:
   a) Choose Edit → Attributes.
      The Change Attributes dialog box appears.
   b) Enter the display attributes for the text variable:
      - Define whether the color used for the text variable is intense or the standard color.
      - Enter a color code if you want to display the variable in color.
      - Define the width of the text variable.
      - Define the offset for the text variable.
      
      For example, if you define a width of 20 and an offset of 5, characters 6 to 25 will be printed.
Report Definition: Using Text Variables for Selection Parameters

5. On this screen, the additional processing functions in the table in Using Standard Text Variables in Report Text Definitions [Seite 827] are available.

6. Choose Text → Save.

7. Choose Text → Exit.

   The variable appears on the Create Report: Texts screen.
Report Definition: Using Text Variables for Characteristics

A characteristic variable represents data for the characteristics used in the report definition. Characteristic text variables replace the variables of the type %<field name>-F, %<field name>-T, %<field name>-FTEXT and %<field name>-TXTL, which were used in releases prior to Release 3.0.

When you define report columns, you enter a set that contains the characteristic Year. You can now enter a variable for the characteristic Year in the report text (for example, in the header). When the report is output, the system displays the current year in the report header.

To enter text variables for characteristics when defining report text on the Change <Text Position> <Name of Report> in Language <Language Code> screen:

1. Position the cursor at the point where you want to insert the variable and choose Insert → Characteristics.
   The Characteristics dialog box appears.
2. Enter the following information:
   – Select the text type that you want to use for the text variable (characteristic description, characteristic value, short text of the characteristic, long text of the characteristic).
   – Select how the variable values are to be displayed (single value, set of values, from value, to value).
   – Select the characteristic for which you want to display the text variable in the report text.
3. Choose Continue.
   The variable is inserted at the point where you positioned the cursor on the Change <Text Position> <Report Name> in Language <Language Code> screen.
4. If you want to change the parameters controlling the display of the text variable in the report output:
   a) Choose Edit → Attributes.
      The Change Attributes dialog box appears.
   b) Enter the display attributes for the text variable:
      – Define whether the color used for the text variable is intense or the standard color.
      – Enter a color code if you want to display the variable in color.
      – Define the width of the text variable.
      – Define the offset for the text variable.
      For example, if you define a width of 20 and an offset of 5, characters 6 to 25 will be printed.
Report Definition: Using Text Variables for Characteristics

5. On this screen, the additional processing functions in the table in Using Standard Text Variables in Report Text Definitions [Seite 827] are available.

6. Choose Text → Save.

7. Choose Text → Exit.

   The variable appears on the Create Report: Texts screen.

   The system determines the characteristic value for the text variable from the first row/column of the current page.
Defining Selection Criteria

You enter the selection criteria for your report data on the Create Report: General Data Selection screen. These sets, together with the sets used in rows and columns, define the data in a report.

On the Create Report: General Data Selection screen, enter the set TD-LEDGER. This set contains the value AB for the characteristic Ledger. When the report is executed, the system only selects data records for the ledger AB.

You should use a set as selection criteria when one of the following conditions applies:

- The set contains only one value.
- The set contains more than one value, but you only want to use the total for the set and not each set value.

The following characteristics must be defined in your report, either as selection criteria, a row block, or a column block:

- Company
- Ledger
- Version
- Record type
- Period

To reduce processing time, you should specify all characteristics in the general data selection that need not be used in the report rows or columns.

Procedure

   
The Create Report: General Data Selection screen appears.

   Sets that have been defined as default selection sets are listed on the screen. You define default selection sets in the library of the report. These sets appear as selection criteria for each report in a certain library.

   You define default selection sets for the characteristics Company Code (TD-COCDE-TDG), Ledger (TD-RLDNR-D4), Version (TD-RVERS-02), and Year (TD-RYEAR-95). These selection sets automatically appear each time a new report is created for the library.

   For information about default selection sets, see Libraries [Seite 927].

2. Enter the name(s) of the set(s) that you want to use as selection criteria for the report data.
Defining Selection Criteria

You cannot use a set containing characteristics that are already being used in a row or column block. You also cannot use a multidimension set as selection criteria. You can use a data set as selection criteria, but only when there is exactly one value in the set.

You can enter a set that has not yet been created in your system. The system asks you whether you want to create the set and displays a series of dialog boxes in which you choose whether you want to create a report set or a general set and then select the relevant set type.

You can enter basic and multidimension sets that have been created for characteristics from tables other than the table that the report uses. To do so, the characteristic of the row block set must be compatible with the corresponding characteristic in the report’s table.

The Report Writer can use sets from all set classes. However, a set name is only unique within one set class.

If you entered a set name that exists in two different set classes, the system displays a dialog box in which you select the set that you want to use as the row block.

You can also enter set variables as report selection criteria. For more information, see Entering a Variable as Selection Criteria below.

3. If you want to eliminate internal business volume within a set hierarchy that you entered as selection criteria, set the IntBusVolElim indicator.

You can set the IntBusVolElim indicator and use the selection variation for a characteristic of the screen Create Report: General Data Selection. This allows you to eliminate internal business volume within a set hierarchy and also create reports for the different levels in the set hierarchy.

4. Enter variation data for a selection set in the Vary From/Vary To and S fields as required.

If a selection set contains more than one value, the Report Writer normally accumulates the data for the different values. By entering appropriate values in the Vary Frm, Vary To, and S fields, you can instruct the Report Writer to create different reports for the different characteristic values, as well as for the different set levels (if the selection set is a single-dimension set).

When you enter variation data, variation of the selection is automatically activated when you execute the report’s report group.

The levels within a set hierarchy are numbered as follows: The uppermost set node is assigned level 1. The set node directly underneath this is assigned level 2, and so on. Characteristic values in basic sets are always assigned level 1- and basic sets are always assigned level 2-.

Enter the following information:

– The upper hierarchy level for selecting report data. You can enter a number greater or less than 0.
The lower hierarchy level for selecting report data. You can enter a number greater or less than 0.

Set the S indicator (Single value) if you also want different reports for the detail/single values contained in the selection set. If you want the system to summarize all records, do not set the S indicator (Single value).

You create a single-dimension set called TD-COCDE-TD that contains three basic sets: TD-COCDE-TD1 (local companies TD11, TD12, TD13), TD-COCDE-TD2 (local companies TD21, TD22, and TD23), and TD-COCDE-TD3 (local companies TD31, TD32, and TD33). You then use the set as selection criteria for your report. The system selects and summarizes data records for all nine companies.

If you entered 1 in the Vary Frm field and 2 in the Vary To field and left the S field blank, the system would create four different reports for the three companies.

Refer to the following table for using additional data selection methods with the Vary Frm, Vary To, and S fields.

### Using the Vary Frm, Vary To and S Fields (Example TD-COCDE-TD)

<table>
<thead>
<tr>
<th>From</th>
<th>To</th>
<th>S</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Space</td>
<td>Display one report with the data summarized for the single-dimension set TD-COCDE-TD.</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>Space</td>
<td>Display three separate reports with the data summarized for the basic sets TD-COCDE-TD1, TD-COCDE-TD2, and TD-COCDE-TD3.</td>
</tr>
<tr>
<td>1</td>
<td>2</td>
<td>Space</td>
<td>Display four reports; one with the summarized data for set TD-COCDE-TD and three separate reports for the data summarized in sets TD-COCDE-TD1, TD-COCDE-TD2, and TD-COCDE-TD3.</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>X</td>
<td>Display nine separate reports; one for each company (set value) in sets TD-COCDE-TD1, TD-COCDE-TD2, and TD-COCDE-TD3.</td>
</tr>
</tbody>
</table>

You can further limit selection criteria when you execute a report group. For more information, see Report Group Execution [Seite 962] and the procedure Executing a Report Group [Seite 964].

When displaying a report that varies the level of selection data, you can use the View functions to switch between the different reports that have been created as a result of the variation levels. For more information about the View functions, see Functions in the Report Output [Seite 974].

If a report is executed in the background, reports that are created as a result of variation levels are printed consecutively.

5. On this screen you can use the additional processing functions shown in the following table.

### Additional Processing Functions (Create Report: General Data Selection Screen)
Defining Selection Criteria

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Display set</td>
<td>Display set used as selection criteria</td>
</tr>
<tr>
<td>Edit → Change set</td>
<td>Change set used as selection criteria. You must save your report before you can call up the set maintenance transactions.</td>
</tr>
<tr>
<td>Edit → Insert set...</td>
<td>Insert a set as selection criteria. The Select Sets dialog box appears. You can enter selection criteria to search for a set.</td>
</tr>
<tr>
<td>Edit → Insert variable...</td>
<td>Insert an existing set variable as selection criteria</td>
</tr>
<tr>
<td>Edit → Delete row</td>
<td>Delete a row</td>
</tr>
<tr>
<td>Edit → Selection rule</td>
<td>Enter a selection rule</td>
</tr>
<tr>
<td>Edit → Delete sel. rule</td>
<td>Delete a selection rule</td>
</tr>
<tr>
<td>Goto → Report layout → Use standard layout</td>
<td>Reset layout parameters to default values of standard layout</td>
</tr>
<tr>
<td>Extras → List of characteristics</td>
<td>Display list of characteristics used in the report</td>
</tr>
<tr>
<td>Extras → Maintenance language</td>
<td>Switch language for report texts (for example, to enter text for the report description in another language)</td>
</tr>
<tr>
<td>Extras → Other std layout</td>
<td>Assign new standard layout to the report</td>
</tr>
<tr>
<td>Extras → Threshold value</td>
<td>Enter threshold value condition to highlight in color or print report rows, depending on the values in a specific report column</td>
</tr>
</tbody>
</table>

You can also use the Insert line and Delete line icons positioned below the list of data selection sets to insert a new blank line and delete a line.

Entering a Formula to Select Report Data

If you cannot completely define the selection criteria using a set or set variable, you can use a selection formula. To use a selection formula, you must first enter the selection formula as a rule. You then use the rule name when you define a report. You define rules and selection formulas in Customizing.

For more information on defining selection formulas in rules, see the IMG for the Special Purpose Ledger under Tools → Maintain Validation/Substitution/Rules → Logical Rules for Validation and Substitution [Extern].

To improve processing time, you should use a set rather than a selection formula. You should only use a selection formula if a condition cannot be defined with a set. You would use a selection formula, for example, when you want to select only certain value combinations for different characteristics.
If you want to enter rule names as selection criteria on the Create Report: General Data Selection screen, proceed as follows:

1. Choose Edit → Selection rule.
   The Choose Rule dialog box appears.

2. Enter the name of the selection rule.
   The selection rule name that you use must be defined in Customizing. Also, the selection formula used in a report definition can only refer to the table defined in the report's library.
   For example, a formula can only refer to the table GLT1 if the report is in a library that uses the table GLT1.

3. Choose Continue.
   The Create Report: General Data Selection screen appears, displaying the rule name that you entered.

**Entering Variables as Selection Criteria**

You can use set variables as selection criteria. When you execute a report that uses a set variable, the system prompts you to enter a set name for the variable.

You can enter set variables whose default set uses a table that is not the table of the report. A prerequisite is that the table field of the default set is compatible with the relevant characteristic of the report table.

For example, you can:

(a) Create a set variable called BUSAREA. The default set of the variable is a basic set created for table CCSS and the characteristic "Business area" (GSBER). The set contains a range of business areas.

(b) You create a Report Writer report for a library that uses table GLT1 and enter the set variable BUSAREA as data selection criteria.

Since the variable uses a default set for table CCSS, the system selects the corresponding characteristic from table GLT1. If there is more than one compatible characteristic in table GLT1, the system displays a dialog box listing these characteristics. You then select the characteristic that you want to use in the report definition. In this example, you can choose the characteristic business area (RBUSA) or trading partner's business area (SBUSA).

To enter a set variable as selection criteria:

1. Choose Edit → Insert variable.
   The Selection Conditions for Variables dialog box appears. Enter the selection criteria to search for an existing set variable.

2. Enter your selection criteria and select the variable that you want to use.

For more information on creating set variables, see Creating Set Variables [Seite 697].
Defining Selection Criteria
Defining Rows

Procedure

   The Create Report: Row Overview screen appears.
2. Enter the name of the set(s) to be used as the report row block.
   You can use a basic, data, single-dimension, or multi-dimension set.
   You cannot enter a set that contains characteristics that are already being used in a column block or as selection criteria in the report. You can use the same characteristic in more than one row block and you can use more than one characteristic in a row block(s); however, you cannot use the characteristic again in a column block or as selection criteria in the report.
   You can enter a set that has not yet been created in your system. The system asks you whether you want to create the set and displays a series of dialog boxes in which you choose whether you want to create a report set or a general set and then select the relevant set type.
   You can enter basic and multi-dimension sets that have been created for characteristics from tables other than the table that the report uses. To do so, the characteristic of the row block set must be compatible with the corresponding characteristic in the report’s table.

You create a report for a library that uses table GLT1 and want to enter a hierarchy of accounts in the report rows. You could enter a Controlling cost element group created for the characteristic "Cost element" (KSTAR) in table CCSS as the row block. In this case, characteristic “Cost element” is compatible with the characteristic "Account" in table GLT1.

The table-independent usage of sets in reports is not possible for data and multi-dimension sets.

3. For each row block, enter the following data as required:
   – Specify whether you want to insert a page break before a row block or insert blank lines between row blocks.
     To insert a page break before a row block, enter * in the Page break field.
     To insert a specific number of blank row lines before a row block, enter the number of blank row lines you want in the Page break field.
   – Specify whether or not the system should insert column headings before a specific row block (set text for the row block). Select Print heading if you want the system to insert a column heading for the corresponding row block.
   – Specify if you want to hide the row block. The row block is then hidden for all column blocks. You can refer to a hidden row block in a formula and/or key figure; however, the row block is not displayed in the report.
Defining Rows

– Specify whether you want to inactivate the row block so that it is ignored in the report.

When you set a row block as inactive, the Report Writer completely ignores the row block. You cannot refer to an inactive row block in a key figure or a row formula. This function can be used for test purposes.

– Specify whether you want to switch the +/- sign for all report rows in the row block. If you set this checkbox, the +/- sign will always be switched for the values in the respective report rows.

The Change +/- indicator assigned to a row block overrides the format group settings specified for the Change +/- sign indicator in the standard layout parameters (Create Report: Report layout: Representation screen).

– Enter the lower summation level (From level) for displaying totals for the row block. You can enter a number greater or less than 0.

– Enter the upper summation level (To level) for displaying totals for the row block. You can enter a number greater or less than 0.

Summation levels assigned to a row block override the summation levels assigned to the entire report in the standard layout parameters (Create Report: Report Layout: Row Totals screen). You can change these summation levels after you have output a report to your screen. For more information see sorting report rows [Seite 997] and functions in the report output [Seite 974].

4. Choose Enter.

The descriptions for the row blocks appear. The Set, Formula, and Key fig. block fields are set accordingly, depending on if you entered a set, formula, or key figure in the Row block field(s).

The Report Writer can use sets from all set classes. However, a set name is only unique within one set class. If you entered a set name that exists in two different set classes, the system displays a dialog box in which you select the set that you want to use as the row block.

5. If you want to enter additional text for the row blocks:
   a) Position the cursor on the row block for which you want to enter the texts and choose Extras → Additional texts.

   The Texts for Row Block No. <Number> dialog box appears.

   b) Make the following entries:

   Lead column fields:

   Select the Text indicator if you want to enter your own text for the lead column. Enter the text in the field next to the Text indicator.

   Select the Text from set indicator if you want to use the description entered in the row set as the lead column text. This option is the default setting.
Sum total fields:
Select the Text indicator if you want to enter your own text for the highest row block total. Enter the text in the field next to the Text indicator.
Select the Text from set indicator if you want to use the description entered in the row set as the text for the row sum total. This option is the default setting.

6. On this screen, you can use the additional processing functions in the table for the Create Report: Initial Screen as described in creating a Report Painter report [Seite 811] as well as the functions in the following table.

Additional Processing Functions (Create Report: Row Overview Screen)

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display a set used as a row block.</td>
<td>Edit → Display set</td>
</tr>
<tr>
<td>Change a set used as a row block. You have to save your report before</td>
<td>Edit → Change set</td>
</tr>
<tr>
<td>you can call up the set maintenance transactions.</td>
<td></td>
</tr>
<tr>
<td>Enter characteristic information for a row set. For more information,</td>
<td>Edit → Choose</td>
</tr>
<tr>
<td>see entering characteristic information for a row block [Seite 846].</td>
<td></td>
</tr>
<tr>
<td>Inactivate row/column block combinations. For more information, see</td>
<td>Edit → Inactive columns</td>
</tr>
<tr>
<td>inactivating column for a row block [Seite 845].</td>
<td></td>
</tr>
<tr>
<td>Insert a set in the row block. The Select Sets dialog box appears. You</td>
<td>Edit → Insert set</td>
</tr>
<tr>
<td>can enter selection criteria to search for a set.</td>
<td></td>
</tr>
<tr>
<td>Insert a formula. For more information, see inserting formulas in row</td>
<td>Edit → Insert formula</td>
</tr>
<tr>
<td>block [Seite 850].</td>
<td></td>
</tr>
<tr>
<td>Insert a key figure. For more information, see inserting key figures in</td>
<td>Edit → Insert key figures</td>
</tr>
<tr>
<td>row block [Seite 853].</td>
<td></td>
</tr>
<tr>
<td>Delete a row block.</td>
<td>Edit → Delete row block</td>
</tr>
<tr>
<td>Reset all layout parameters to the default values from the standard</td>
<td>Goto → Report layout → Use standard layout</td>
</tr>
<tr>
<td>layout.</td>
<td></td>
</tr>
<tr>
<td>Display a list of characteristics that are used in the report.</td>
<td>Extras → List of charact.</td>
</tr>
<tr>
<td>Go to a new report language (for example, to enter language-specific</td>
<td>Extras → Maintenance lang...</td>
</tr>
<tr>
<td>text for the report description).</td>
<td></td>
</tr>
<tr>
<td>Assign a new standard layout to the report.</td>
<td>Extras → Other std layout</td>
</tr>
<tr>
<td>Enter additional row block text for the lead column and/or sum total.</td>
<td>Extras → Additional texts...</td>
</tr>
</tbody>
</table>
### Defining Rows

Define a row block as a row block for non-assigned values. A **row block for non-assigned values** is assigned to another row block in order to determine the values that fulfill the data selection criteria, but are not already included in the row block to which it refers. For more information, call up the additional documentation by choosing Help.

---

You can also use the *Insert line* and *Delete line* icons positioned below the list of row blocks to insert a new blank row block line and delete a row block line.

**See also:**

- Inactivating Columns for a Row Block [Seite 845]
- Entering Characteristic Information for a Row Block [Seite 846]
- Inserting Formulas in Row Blocks [Seite 850]
- Inserting Key Figures in Row Blocks [Seite 853]
Inactivating Columns for a Row Block

Normally, each column block is printed for every row block in a report. However, for each row block, you can inactivate specific column blocks. Using the Edit → Inactive columns function, you can define which combinations of row and column blocks should be printed in a report.

Procedure

1. On the Create Report: Rows screen, move the cursor to the row block for which you want to inactivate a column block and choose Edit → Inactive columns.

   The Inactive Column Blocks dialog box appears, displaying the possible column blocks that you can inactivate.

2. Set the Inactv indicator for each column block that you want to inactivate for the row block and choose Continue.

   You cannot refer to inactive combinations of row/column blocks in a key figure and/or cell definition.
Entering Characteristic Information for a Row Block

Once you have entered a row set on the *Create Report: Rows* screen, you can enter additional information for each characteristic used in the report row, such as page breaks and additional space between physical report rows.

**Procedure**

1. On the *Create Report: Rows* screen, move the cursor to the row set for which you want to enter characteristic information and choose *Edit* → *Choose*.

   The *Row Characteristic* dialog box appears. You can switch between characteristics using the *Prev. characteristic* and *Next characteristic* buttons.

2. Enter the following data in the *Settings for totals* group box as required:

   - The total level to control the total level of data shown in the report.

   ![Image](https://example.com)

   You can decide to display only the total of a set, and ignore the set's individual values. The default (blank) displays all levels of values, including the individual values in a basic set. (If you set the S indicator (Suppression) in a multi-dimension or single-dimension set, this value overrides the value entered in the *Total Level* field.)

   To change the level of data displayed, you enter a level number in the *Total level* field.

   You can enter the following values:

   - **0** Display all levels of values contained in the set.
   - **1** Display only values at the first level of the set characteristic.
   - **2** Display only values at the first and second levels of the set characteristic.
   - **n** Display only values at the first up to the nth level of the set characteristic.
   - **1-** Display only basic set values (lowest level).
   - **2-** Display only basic set values and the total for each basic set.

   For this field, you can only use as many numeric values as there are levels within the set hierarchy. 1- and 2- are the only negative values possible.

   For example, you cannot enter 5 in this field if there are only four levels within the set hierarchy.

   The sets that appear at the highest level of a characteristic are assigned the level 1.

   ![Image](https://example.com)

   The single-dimension set TD-RACCT-IE ("Levels for Characteristic Account" graphic in *Using Sets in Report Rows* [Seite 894]) is assigned the level 1 because it is at the highest level of the characteristic Account (field RACCT); basic set TD-RCNTR-12 is also assigned level 1 because it is at the highest level of the characteristic Cost Center (field RCNTR).
Entering Characteristic Information for a Row Block

If you enter 1 in the *Total level* field for the set TD-RACCT-IE and enter 0 in the *Total level* field for the set TD-RCNTR-12, the system only prints total values for the set TD-RACCT-IE, but prints individual values for the cost centers. (The set structure of this row block is shown in the "Levels for Characteristic Account" graphic in Using Sets in Report Rows [Seite 894].)

- Specify whether you want the system to suppress the entire characteristic (*Suppress charact.* indicator). The text of the corresponding row total line is printed, but the amount is not. This field does not appear for the last characteristic listed for the current row set.

  If you set the *Suppress charact.* indicator for the set TD-RACCT-IE, the system would not print individual totals for the set. It would only print "Total Accounts"; no amount is printed.

- Specify whether you want to eliminate internal business volume for the characteristic. To activate the *Int.Bus.Vol.Elim.* indicator, the receiver field and a corresponding sender field must exist in table T804C.

  For example, if you want to eliminate internal business volume for the receiver field Business Area (RBUSA), a corresponding sender field (SBUSA) must be entered in table T804C.

  Internal business volume is eliminated hierarchically within the set.

You create a single-dimension set called RBUSA-11 that contains the basic sets RBUSA-21 (containing the range of business areas from 0001 to 1000) and RBUSA-22 (containing the range of business areas from 1001 to 2000).

If a database record has the receiver field (RBUSA) value 0001 and the sender field (SBUSA) value 0500, all corresponding subtotals at the basic set level are eliminated, since both values are included in the same basic set (RBUSA-21).

If a database record has the receiver field (RBUSA) value 1500 and the sender field (SBUSA) value 0600, amounts are only eliminated from the total sum of sets RBUSA-21 and RBUSA-22 (at the single-dimension set level), since this is the lowest sum in the hierarchy where the data records for business areas 1500 and 0600 are included.

3. Enter the following page break information as required:

- The level you enter in the *Unconditional* field tells the Report Writer at which level to place horizontal page breaks in the report. The default (blank) places page breaks at fixed intervals as defined by the *Length* field in the Create Report: Layout: Page/Control dialog box.

  You can specify the following values:

  0 Place page break at fixed intervals as defined by the *Length* field in the Create Report: Layout: Page/Control dialog box.

  1 Place page breaks at the end of every first level of the set characteristic.

  2 Place page breaks at the end of every second level of the set characteristic.
Entering Characteristic Information for a Row Block

- Place page breaks at the nth level of the set characteristic.
- Place page breaks at the lowest level of the set characteristic.
- Place page breaks at the end of every basic set.

You can only use a value for a specific level if it is not suppressed via the S indicator (Suppression) within the set hierarchy.

For this field, you can only use as many numeric values as there are levels within the set hierarchy. 1- and 2- are the only negative values possible.

For example, you cannot enter 5 in this field if there are only four levels within the set hierarchy.

- The Conditional field implements an "intelligent" page break facility. The system checks if there is enough room on a page for all of the lines at the next level before inserting an automatic page break after a specified level. The default (blank) is no intelligent page breaks.

Values are the same as for the Unconditional field.

You can use the Conditional field in the following cases:

- You do not want the accounts for a company on two different pages.
- There is enough room on a page for all of the accounts for the next group of company accounts; the accounts should print on the same page.

The system only starts a new page for the next group of company accounts if the group does not fit on the same page.

4. Enter data in the Totals display group box as required:

The Totals display fields allow you to enter a number range of levels and then:

- Underscore or overscore with single or double lines or format characters at these levels.
- Insert additional blank lines between levels.
- Highlight lines between levels.
- Define colors for lines.

Use the From level indicators to select a beginning level number for the Lower border and Upper border fields (explained later in this section). Valid values are the same as the Unconditional field.

Use the To level indicators to select an ending level number for the Lower border and Upper border fields (explained later in this section). Valid values are the same as the Unconditional field.

For example, if you enter 1 as the From level value and 1 as the To level, the system only formats totals at level 1.

If you enter a negative value as the From level value, you cannot enter a To level value.
For example, if you enter 2– in the From level field, you cannot enter a value in the To level field.

Select the Highlight row indicator if you want to highlight the row characteristic total.

Enter a code for the color in which you want to display the row characteristic total in the Color field.

If you want to use SAP standard colors in your report, you only need to set the Standard colors indicator in the layout parameters assigned to the report (Page/Control screen). You do not need to enter a color code here.

Set the Lower border indicators depending on how you want the lower border for the row characteristic totals to appear. You can define the lower border so that no lower border appears, a single line appears, a double line appears, or a user-defined character is used for the border.

Set the Upper border indicators depending on how you want the upper border for the row characteristic totals to appear. You can define the upper border so that no upper border appears, a single line appears, a double line appears, or a user-defined character is used for the border.

5. If you want to enter additional level information for displaying row totals (for example, to underline sub-totals or to display sub-totals in a different color than totals), choose Additional.

A dialog box appears, displaying the Totals display fields for the additional level.

6. If there are additional characteristics to define for the row set, select the Next characteristic button.

7. Choose Continue.

You return to the Create Report: Rows screen.
Inserting Formulas in Row Blocks

1. On the Create Report: Rows screen, move the cursor to below the row block line where you want the formula to appear.

2. Choose Edit → Insert formula.
   
   The Define Row Formula dialog box appears.

3. Enter the following data:
   
   – The text that you want to appear in the report row for the formula.
   
   – A formula

   You defined two multi-dimension sets for row blocks 1 and 2. You want to define a row containing the difference between the highest totals of the row blocks. In line 3, you enter the formula ‘001’ – ‘002’.

   – Number of the row block that you want to use as the representative row block to define the column structure of a formula row. The active column blocks of the representative row block determine the column structure of the formula row.

   The representative row block must be a set and must be entered as an operand in the formula.

   If you do not make an entry in this field, the system automatically determines the representative row block. If you make an incorrect entry in this field, the system automatically corrects the entry.

   The Report Writer automatically assigns a summation level to the formula row. This level is calculated from the highest total of the rows used in the formula plus one.

   For example, you defined two single-dimension sets for row blocks 1 and 2. You defined an additional row containing the grand total of the highest totals of the row blocks, using the formula ‘001’ + ‘002’ in line 3 of the row definition. The highest summation levels of the sets used in row blocks one and two are 3 and 2 respectively. The Report Writer automatically assigned summation level 4 to the formula row (using the highest summation level of the row block totals (3) plus one).

When building a formula, you can use the operators in the table in Using Set Formulas in Report Writer [Seite 906].

Within a row formula you can use various operands.

Beginning with Release 3.0C, the syntax used to enter formula operands has changed. You now enter formula operands in the form ‘nnn’ (for example, ‘001’ to enter the row block 001). In releases prior to Release 3.0C, you enter formula operands using angle brackets around the operand (for example <001>).
The system automatically converts any existing formulas into the new format. You do not therefore need to change your sets or reports that contain formulas.

You can use the following operands in row formulas:

- Line numbers in the form ‘\n’ (for example ‘001’ for line 001)
- Value variables (for example, ‘\&PERIOD’ for the value variable PERIOD)
- Symbolic names for cells (for example, ‘TOTAL’ for a specific totals row in a report)
  Within a formula you can also use:
- Absolute values (for example, 10 or 20)
- Combinations of absolute values and line numbers, for example, 10 + ‘002’
- Boolean Logic

The following rules apply to formulas:

- Operands for formulas use the value of the highest sum of the row set. (The value at level 1 of the set.) If you use negative values when defining your levels for a set characteristic, the system cannot process the formula.
- If a report contains more than one row block, the resulting formula columns will have the lowest number of columns defined for the row blocks.

Row block one contains 5 columns. Row block two contains 3 columns. The row formula is ‘001’ + ‘002’. The results of the formula will be presented in 3 columns.

- When processing a report for which print classes are defined, the result of the formula uses the highest defined print class, except when the print class is zero. Print class 0 takes priority over the other print classes.

Report row one uses print class 5 and row two uses print class 3. When you define a formula to calculate the total of the two rows, the result of the formula uses print class 5.

- When processing a report that contains both row formulas and column formulas, the system processes the column formula at the point of intersection.
- If a row block is suppressed, the row block can still be used in formula processing; however, the row block data is not displayed in the report output.

4. Enter information to determine how the formula row is displayed in the report output:
   - If you want to highlight the row formula total, select Highlight row.
   - Enter a code for the color in which you want to display the row formula total.
   - Set the Lower border indicators depending on how you want the lower border for the row formula totals to appear. You can define the lower border so that no lower border appears, a single line appears, a double line appears, or a user-defined character is used for the border.
Inserting Formulas in Row Blocks

- Set the Upper border indicators depending on how you want the upper border for the row formula totals to appear. You can define the upper border so that no upper border appears, a single line appears, a double line appears, or a user-defined character is used for the border.

5. To check that the syntax in the formula is correct, choose Check formula.

6. Choose Continue.

The formula appears on the Create Report: Rows screen.

You can enter a formula that refers directly to the result of another formula line.

Example:

Your report contains the following rows:

- Income Accounts (row block 1)
- Expense Accounts (row block 2)
- Sum total of the Income and Expense Accounts (row block 3)
  You enter this total using the formula ‘001’ + ‘002’
- 50% of the sum total (row block 4)
  You enter this row using the formula ‘003’ / 2
  The operand ‘003’ in this formula refers to the result of the formula calculated for row block 3.
Inserting Key Figures in Row Blocks

1. On the Create Report: Rows screen, move the cursor to the row block line where you want the key figure to appear.

2. Choose Edit → Insert key figures.
   A list of defined key figures appears in a dialog box. If only one key figure is defined for the report, it automatically appears on the Create Report: Rows screen.

3. Select the key figure that you want to include in the report and choose Choose.
   The selected key figure appears on the Create Report: Rows screen.

For more information about defining key figure blocks, see Defining Calculated Key Figures [Seite 875].
**Defining Columns**

   
   The Create Report: Columns screen appears.

2. Enter the name of the set(s) to be used as the column block.
   
   You can use a basic, data, single-dimension, or multi-dimension set as the column block.

   You cannot enter a set that contains characteristics that are already being used in a row block or as selection criteria in the report. You can use the same characteristic in more than one column block and you can use more than one characteristic in a column block(s); however, you cannot use the characteristic again in a row block or as selection criteria in the report.

   You can enter a set that has not already been created in your system. The system asks you whether you want to create the set and displays a series of dialog boxes in which you choose whether you want to create a report set or a general set and then select the relevant set type.

   Beginning with Release 4.0, you can enter basic and multi-dimension sets that have been created for characteristics from tables other than the table that the report uses. To do so, the characteristic of the column block set must be compatible with the corresponding characteristic in the report’s table.

   The table-independent usage of sets in reports is not possible for data and multi-dimension sets.

   ![Image]

   You can use variables in your column headings. The variables are replaced with the default variable value when you execute your report if the column text type Key is selected in the report’s standard layout (Create Report: Layout: Column Texts screen).

   You enter the variable for the column heading in your column set (Short text of set line field in the set maintenance transactions).

   For example, your report uses the value variable &PERIOD for the period and you want to display the current value for the period in a column heading. You enter the variable &PERIOD in your column set as the set line description for the relevant period and enter the set in the column definition of your report. If the column text type Key is selected in your report’s standard layout, the variable &PERIOD will be replaced with the period value (for example, 5) when you execute the report. The description is printed for all other column text types (for example, May).

3. For each column block, enter the following data as required:
   
   - Specify whether you want to insert a page break before a column block or insert blank lines between column blocks.

     To insert a page break before a column block, enter * in the Page break field.

     To insert a specific number of blank column lines before a column block, enter the number of blank column lines you want in the Page break field.
Define Columns

Specify whether you want to inactivate the column block. The column block is then inactivated for all row blocks. You cannot refer to an inactive column block in a key figure.

For more information about inactivating a column block for a specific row block, see Inactivating Columns for a Row Block [Seite 845].

If you want to suppress a column in a report and refer to it in a key figure, you can do this by assigning the column width 0 (using format groups).

For example, your column block is a basic set that uses the characteristic Year (value: 1997). You want to suppress the column for 1997, but still refer to it in a key figure. You:

a) Assign a format group to the basic set value 1997 (for example, 5).

b) Define the column width for format group 5 as 0 in the report parameters.

4. Choose Enter.

The descriptions for the column blocks appear.

The Report Writer can use sets from all set classes. However, a set name is only unique within one set class.

If you entered a set name that exists in two different set classes, the system displays a dialog box in which you select the set that you want to use as the column block.

5. If you want to enter additional text for the column blocks:

Position the cursor on the column block for which you want to enter the texts and choose Extras → Additional texts.

The Texts for Column Block No. <Number> dialog box appears.

For more information about entering additional text for the column blocks, see step five in Defining Rows [Seite 841].

6. On this screen, you can use the additional processing functions in the following table, as well as the functions in the table for the Create Report: Initial Screen in Creating a Report Definition [Seite 811].

Additional Processing Functions – Create Report: Columns Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Display set</td>
<td>Display a set used as a column block.</td>
</tr>
<tr>
<td>Edit → Change set</td>
<td>Change a set used as a column block. You have to save your report before you can call up the set maintenance transactions.</td>
</tr>
<tr>
<td>Edit → Choose...</td>
<td>Enter characteristic information for a column set. For more information, see Entering Characteristic Information for a Column Block [Seite 857].</td>
</tr>
</tbody>
</table>
Defining Columns

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Insert column block</td>
<td>Insert a column block.</td>
</tr>
<tr>
<td>Edit → Delete column block</td>
<td>Delete a column block.</td>
</tr>
<tr>
<td>Goto → Layout → Reset layout</td>
<td>Reset all layout parameters to the default values from the standard layout.</td>
</tr>
<tr>
<td>Extras → List of charact.</td>
<td>Display a list of characteristics that are used in the report.</td>
</tr>
<tr>
<td>Extras → Maintenance lang...</td>
<td>Go to a new report language (for example, to enter language-specific text for the report description).</td>
</tr>
<tr>
<td>Extras → Other std layout...</td>
<td>Assign a new standard layout to the report.</td>
</tr>
<tr>
<td>Extras → Threshold value...</td>
<td>Enter a threshold value condition to highlight in color or print report rows, depending on the values in a specific report column.</td>
</tr>
<tr>
<td>Extras → Additional texts...</td>
<td>Enter additional column block text.</td>
</tr>
</tbody>
</table>

You can also use the Insert line and Delete line icons positioned below the list of column blocks to insert a new blank column block line and delete a column block line.

See also:

- Entering Characteristic Information for a Column Block [Seite 857]
- Using Formula Variables in Reports: Examples [Seite 859]
Entering Characteristic Information for a Column Block

Once you have entered a column set on the Create Report: Columns screen, you can enter additional information for each characteristic used in the report column, such as page breaks and additional space between physical report columns.

Procedure

1. On the Create Report: Columns screen, move the cursor to the column set for which you want to enter characteristic information and choose Edit → Choose.

   The Column Characteristic dialog box appears.

2. Enter the following data in the Settings for totals group box as required:
   - See the definition for the Total level field in Entering Characteristic Information for a Row Block [Seite 846].
   - Specify whether you want the system to suppress the sum column for the characteristic ( Suppress charact. indicator). If you set this indicator, only columns for the detailed values of the characteristic are printed. This field does not appear for the last characteristic listed of the current column set.
   - See the definition for the Int.Bus.Vol.Elim. field in Entering Characteristic Information for a Row Block [Seite 846].

3. Enter the following page break information as required:
   - The level you enter in the Unconditional field tells the Report Writer at which level to place vertical page breaks in the report. The default (blank) places page breaks at fixed intervals as defined by the Width field in the Create Report: Layout: Page/Control dialog box.

      You can enter the following values:

      0 Place page break at fixed intervals as defined by the Width field in the Create Report: Layout: Page/Control dialog box.

      1 Place page breaks at the end of every first level of the set characteristic.

      2 Place page breaks at the end of every second level of the set characteristic.

      n Place page breaks at the nth level of the set characteristic.

      1- Place page breaks at the lowest level of the set characteristic (all levels).

      2- Place page breaks at the end of every basic set.

      You can only use a value for a specific level if it is not suppressed via the S indicator (Suppression) within the set hierarchy.

      For this field, you can only use as many numeric values as there are levels within the set hierarchy. 1- and 2- are the only negative values possible.

      For example, you cannot enter 5 in this field if there are only four levels within the set hierarchy.

      The Conditional field implements an "intelligent" vertical page break facility. The system checks if there is enough room on a page for the next level of columns before inserting
Entering Characteristic Information for a Column Block

an automatic page break after a specified level. The default (blank) is no intelligent page breaks.

Values are the same as for the Unconditional field.

You can use the Conditional field:

a) If you want all of the months in a quarter to appear on one page.

b) If there is enough room on the current page for all of the months in a quarter; the months should print on the same page.

The system only starts a new page for the next group of months in a quarter if the group does not fit on the same page.

4. Enter data in the Totals display group box as required:

The Totals display fields allow you to enter a number range of levels and then:

- Place characters to the left and/or right of a column
- Insert additional blank columns between levels

Use the From level field to select a beginning level number for the Left border and Right border fields (explained later in this section). Valid values are the same as the Unconditional field.

Use the To level field to select an ending level number for the Left border and Right border fields (explained later in this section). Valid values are the same as the Unconditional field.

Set the Left border indicators depending on how you want the left border for the column characteristic totals to appear. You can define the left border so that no left border appears, a single line appears, or a user-defined character is used for the border.

Set the Right border indicators depending on how you want the right border for the column characteristic totals to appear. You can define the right border so that no right border appears, a single line appears, or a user-defined character is used for the border.

5. If you want to enter additional level information for displaying column totals, choose Additional.

A dialog box appears, displaying the Totals display fields for the additional level.

6. If there are additional characteristics to define for the column set, select the Next characteristic button.

7. Choose Continue.

You return to the Create Report: Columns screen.
Formula Variables in Reports

A formula variable represents a user-defined formula, which determines a value for the variable. In contrast to a value variable, the default value for a formula variable is not fixed. When you execute a report that uses formula variables, the system calculates values for the formula variables automatically (for example, using the system date or other variables).

- The Report Writer only generates input fields for independent variables on the report selection screen when you execute the report’s report group. An independent variable does not depend on the value of another variable. You should define your variables so that you only have to enter independent values on the report selection screen.
  
  For example, your report displays data for the current year and the previous year. If you create two independent variables for the current and previous year, you have to enter both years on the selection screen when you output the report. If you define the variable for the previous year as a formula variable, which derives its value from the current year variable, you only have to enter the current year on the selection screen.

- You do not have to use independent variables in the actual report definition. If a report only uses dependent variables, the Report Writer determines the values of the independent variables and creates input fields for these variables on the report selection screen.

For more information on creating formula variables, see Creating Formula Variables [Seite 695].

Using formula variables, you can create several new types of reports. The following examples illustrate how you can use formula variables in your reports.

Example 1: Rolling Periods

See the example report 0R-FOVAR (library 0R1) delivered with the Special Purpose Ledger (FI-SL) application component.

This report uses formula variables to create report columns containing twelve periods. When you enter the reporting period and the reporting year during report execution, the system outputs data for the reporting period and the previous eleven periods.

To define the example report with rolling periods, you need to create twelve formula variables for the twelve periods, and twelve formula variables for the corresponding fiscal year. You should create the variables in the order listed in the table below.

You create a key figure for each pair of variables when you create a Report Writer report. (You must first create basic and multidimension sets that contain the formula variables.) Alternatively, you can enter the variables directly in the report definition if you are creating a Report Painter report.

Formula Variables Used in the Example Rolling Periods Report

<table>
<thead>
<tr>
<th>Period variable</th>
<th>Formula</th>
<th>Year variable</th>
<th>Formula</th>
</tr>
</thead>
</table>

April 2001 451
### Formula Variables in Reports

<table>
<thead>
<tr>
<th>Column</th>
<th>&amp;0R-RP00</th>
<th>‘#S002’</th>
<th>&amp;0R-RY00</th>
<th>‘#S001’</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 12</td>
<td>&amp;0R-RP00</td>
<td>IF ‘OR-RP00’ &gt; 1 THEN ‘OR-RP00’ - 1 ELSE 12</td>
<td>&amp;0R-RY00</td>
<td>IF ‘OR-RY01’ &lt; ‘OR-RP01’ THEN ‘OR-RY00’ ELSE ‘OR-RY00’ – 1</td>
</tr>
<tr>
<td>Column 11</td>
<td>&amp;0R-RP01</td>
<td>IF ‘OR-RP01’ &gt; 1 THEN ‘OR-RP01’ - 1 ELSE 12</td>
<td>&amp;0R-RY01</td>
<td>IF ‘OR-RP02’ &lt; ‘OR-RP01’ THEN ‘OR-RY01’ ELSE ‘OR-RY01’ – 1</td>
</tr>
<tr>
<td>Column 10</td>
<td>&amp;0R-RP02</td>
<td>IF ‘OR-RP02’ &gt; 1 THEN ‘OR-RP02’ - 1 ELSE 12</td>
<td>&amp;0R-RY02</td>
<td>IF ‘OR-RP03’ &lt; ‘OR-RP02’ THEN ‘OR-RY02’ ELSE ‘OR-RY02’ – 1</td>
</tr>
<tr>
<td>Column 9</td>
<td>&amp;0R-RP03</td>
<td>IF ‘OR-RP03’ &gt; 1 THEN ‘OR-RP03’ - 1 ELSE 12</td>
<td>&amp;0R-RY03</td>
<td>IF ‘OR-RP04’ &lt; ‘OR-RP03’ THEN ‘OR-RY03’ ELSE ‘OR-RY03’ – 1</td>
</tr>
<tr>
<td>Column 8</td>
<td>&amp;0R-RP04</td>
<td>IF ‘OR-RP04’ &gt; 1 THEN ‘OR-RP04’ - 1 ELSE 12</td>
<td>&amp;0R-RY04</td>
<td>IF ‘OR-RP05’ &lt; ‘OR-RP04’ THEN ‘OR-RY04’ ELSE ‘OR-RY04’ – 1</td>
</tr>
<tr>
<td>Column 7</td>
<td>&amp;0R-RP05</td>
<td>IF ‘OR-RP05’ &gt; 1 THEN ‘OR-RP05’ - 1 ELSE 12</td>
<td>&amp;0R-RY05</td>
<td>IF ‘OR-RP06’ &lt; ‘OR-RP05’ THEN ‘OR-RY05’ ELSE ‘OR-RY05’ – 1</td>
</tr>
<tr>
<td>Column 6</td>
<td>&amp;0R-RP06</td>
<td>IF ‘OR-RP06’ &gt; 1 THEN ‘OR-RP06’ - 1 ELSE 12</td>
<td>&amp;0R-RY06</td>
<td>IF ‘OR-RP07’ &lt; ‘OR-RP06’ THEN ‘OR-RY06’ ELSE ‘OR-RY06’ – 1</td>
</tr>
<tr>
<td>Column 5</td>
<td>&amp;0R-RP07</td>
<td>IF ‘OR-RP07’ &gt; 1 THEN ‘OR-RP07’ - 1 ELSE 12</td>
<td>&amp;0R-RY07</td>
<td>IF ‘OR-RP08’ &lt; ‘OR-RP07’ THEN ‘OR-RY07’ ELSE ‘OR-RY07’ – 1</td>
</tr>
<tr>
<td>Column 4</td>
<td>&amp;0R-RP08</td>
<td>IF ‘OR-RP08’ &gt; 1 THEN ‘OR-RP08’ - 1 ELSE 12</td>
<td>&amp;0R-RY08</td>
<td>IF ‘OR-RP09’ &lt; ‘OR-RP08’ THEN ‘OR-RY08’ ELSE ‘OR-RY08’ – 1</td>
</tr>
<tr>
<td>Column 3</td>
<td>&amp;0R-RP09</td>
<td>IF ‘OR-RP09’ &gt; 1 THEN ‘OR-RP09’ - 1 ELSE 12</td>
<td>&amp;0R-RY09</td>
<td>IF ‘OR-RP10’ &lt; ‘OR-RP09’ THEN ‘OR-RY09’ ELSE ‘OR-RY09’ – 1</td>
</tr>
<tr>
<td>Column 2</td>
<td>&amp;0R-RP10</td>
<td>IF ‘OR-RP10’ &gt; 1 THEN ‘OR-RP10’ - 1 ELSE 12</td>
<td>&amp;0R-RY10</td>
<td>IF ‘OR-RP11’ &lt; ‘OR-RP10’ THEN ‘OR-RY10’ ELSE ‘OR-RY10’ – 1</td>
</tr>
</tbody>
</table>

The formula variables &0R-RP00 (period of the last column) and &0R-RY00 (fiscal year of the last column) are the only independent variables in the report columns. Each pair of variables calculates the period and fiscal year of the preceding period. The year changes when the system calculates the preceding periods based on period one.

**Example 2: Displaying Periods of Quarter q**

This example report displays three columns for the periods of quarter q.
To define the report columns, you must first create the value variable &QUARTER for the characteristic Period. You enter Quarter as the variable description. This variable is the independent variable. You then need to create three formula variables (listed in the table below) for the three periods in the quarter.

**Formula Variables Used to Calculate the Periods in Quarter q**

<table>
<thead>
<tr>
<th>Period variable</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 1 &amp;QPER1</td>
<td>‘QUARTER’ * 3 − 2</td>
</tr>
<tr>
<td>Column 2 &amp;QPER2</td>
<td>‘QUARTER’ * 3 − 1</td>
</tr>
<tr>
<td>Column 3 &amp;QPER3</td>
<td>‘QUARTER’ * 3</td>
</tr>
</tbody>
</table>

The above example assumes that the first quarter consists of periods one, two, and three. You enter the formula variables &QPER1, &QPER2 and &QPER3 in key figures if you are creating a Report Writer report. Alternatively, you can enter the variables directly in the column definition if you are creating a Report Painter report.

The independent variable &QUARTER is not used directly in the report; it is used indirectly via the formula variables. When you execute the report's report group, the Report Writer creates the input field Quarter for the independent variable &QUARTER. You can then enter quarter one, two, three, or four to output your report for the respective quarter.

**Example 3: Displaying Periods of Quarter q Based on Period p**

This example report displays three columns for the periods of quarter q. Unlike the report in example two, you enter one period in the quarter and not the quarter itself on the report selection screen to determine the three period columns.

To define the report columns, you must first create the value variable &PERIOD for the characteristic Period. Enter Period as the variable name. This variable is the independent variable. You then need to create three formula variables (listed in the table below), which determine the three periods in the quarter.

- The DIV operator in the formulas denotes division without remainder (for example, 8 DIV 3 = 2).
- The system processes the formula enclosed in parentheses first to determine the quarter based on the period you enter on the report selection screen. It then processes the rest of the formula to calculate the periods in the first quarter.

**Formula Variables Used to Calculate the Periods of Quarter q Based on Period p**

<table>
<thead>
<tr>
<th>Period variable</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 1 &amp;QPER1</td>
<td>(‘PERIOD’ − 1) DIV 3 + 1 * 3 − 2</td>
</tr>
<tr>
<td>Column 2 &amp;QPER2</td>
<td>(‘PERIOD’ − 1) DIV 3 + 1 * 3 − 1</td>
</tr>
<tr>
<td>Column 3 &amp;QPER3</td>
<td>(‘PERIOD’ − 1) DIV 3 + 1 * 3</td>
</tr>
</tbody>
</table>
Formula Variables in Reports

The above example assumes that the first quarter consists of periods one, two, and three. The independent variable &PERIOD is not used directly in the report; it is used indirectly via the formula variables. When you execute the report’s report group, the Report Writer creates the input field Period for the independent variable &PERIOD. You can then enter period one, two or three to output your report for the periods in the first quarter.

Example 4: Displaying a Variable Number of Columns for Periods p1 to p12

This example report allows you to create a report containing a variable number of columns for periods one to twelve. It is not possible to define a variable number of columns directly in the report definition; you can do so, however, by creating a column block consisting of twelve columns, each represented by a formula variable.

The formula variables map the unwanted periods up to period 16. If data has been posted for period 16 in your system, you should use a different period that does not contain data (for example, period 17).

To define the report columns, you must first create the value variables &PER_FROM and &PER_TO for the characteristic Period. These variables are the independent variables. You must then create the formula variables (listed in the table below), which all refer to the independent period variables. Once you have created the formula variables, you must enter them in a basic set (created for the characteristic Period) if you are creating a Report Writer report. Alternatively, you can enter them directly in the column definition if you are creating a Report Painter report.

<table>
<thead>
<tr>
<th>Column 1</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;PER01</td>
<td>IF 1 &gt;= ‘PER_FROM’ AND 1 &lt;= ‘PER_TO’ THEN 1 ELSE 16</td>
</tr>
<tr>
<td>Column 2</td>
<td>Formula</td>
</tr>
<tr>
<td>&amp;PER02</td>
<td>IF 2 &gt;= ‘PER_FROM’ AND 2 &lt;= ‘PER_TO’ THEN 2 ELSE 16</td>
</tr>
<tr>
<td>Column 3</td>
<td>Formula</td>
</tr>
<tr>
<td>&amp;PER03</td>
<td>IF 3 &gt;= ‘PER_FROM’ AND 3 &lt;= ‘PER_TO’ THEN 3 ELSE 16</td>
</tr>
<tr>
<td>Column 4</td>
<td>Formula</td>
</tr>
<tr>
<td>&amp;PER04</td>
<td>IF 4 &gt;= ‘PER_FROM’ AND 4 &lt;= ‘PER_TO’ THEN 4 ELSE 16</td>
</tr>
<tr>
<td>Column 5</td>
<td>Formula</td>
</tr>
<tr>
<td>&amp;PER05</td>
<td>IF 5 &gt;= ‘PER_FROM’ AND 5 &lt;= ‘PER_TO’ THEN 5 ELSE 16</td>
</tr>
<tr>
<td>Column 6</td>
<td>Formula</td>
</tr>
<tr>
<td>&amp;PER06</td>
<td>IF 6 &gt;= ‘PER_FROM’ AND 6 &lt;= ‘PER_TO’ THEN 6 ELSE 16</td>
</tr>
<tr>
<td>Column 7</td>
<td>Formula</td>
</tr>
<tr>
<td>&amp;PER07</td>
<td>IF 7 &gt;= ‘PER_FROM’ AND 7 &lt;= ‘PER_TO’ THEN 7 ELSE 16</td>
</tr>
<tr>
<td>Column 8</td>
<td>Formula</td>
</tr>
<tr>
<td>&amp;PER08</td>
<td>IF 8 &gt;= ‘PER_FROM’ AND 8 &lt;= ‘PER_TO’ THEN 8 ELSE 16</td>
</tr>
<tr>
<td>Column 9</td>
<td>Formula</td>
</tr>
<tr>
<td>&amp;PER09</td>
<td>IF 9 &gt;= ‘PER_FROM’ AND 9 &lt;= ‘PER_TO’ THEN 9 ELSE 16</td>
</tr>
</tbody>
</table>
The **Suppress zero columns** indicator must be set in the standard layout assigned to the report, so that columns that do not contain any values are not displayed in the report output.

When you execute the report’s report group, the Report Writer creates input fields for the independent variables &PER_FROM and &PER_TO, which determine the period range.

**Example 5: Calculating Defaults for a Non-Calendar Fiscal Year**

You can create formula variables that default to the current period and fiscal year taken from the system date. If you work with a non-calendar fiscal year, you can create formula variables that calculate the correct period and fiscal year using the current system date and period.

**Example Formula Variables to Calculate Defaults for a Non-Calendar Fiscal Year**

<table>
<thead>
<tr>
<th>Description</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calendar year from the system date</td>
<td>‘$001’</td>
</tr>
<tr>
<td>Calendar month from the system date</td>
<td>‘$002’</td>
</tr>
<tr>
<td>Non-calendar fiscal year calculated from the system date (the non-calendar fiscal year starts in July)</td>
<td>IF ‘$002’ &gt; 6 THEN ‘$001’ + 1 ELSE ‘$001’</td>
</tr>
<tr>
<td>Period calculated from the system date (the non-calendar fiscal year starts in July)</td>
<td>IF ‘$002’ &gt; 6 THEN ‘$002’ – 6 ELSE ‘$002’ + 6</td>
</tr>
</tbody>
</table>
Defining Cells

Use

You use cells to perform mathematical operations within a report. A cell pinpoints a particular location or range within the column-row matrix of a report. Once the Report Writer has located a point/range (or coordinate), it can then use the cell in formulas. Report Writer cells are used much like the cell address or range in a spreadsheet program. However, since the Report Writer uses row/column blocks instead of physical rows and columns, cells are located using symbolic names stored in sets.

When you define a report that contains a cell used as an operand in a formula, you must define the coordinates of the cell (the row coordinate and the column coordinate). These coordinates tells the Report Writer which values to use to calculate totals in the report.

You define the coordinates of a cell using symbolic names. A symbolic name is a name assigned to a set line and/or to a set, which defines the row and column coordinates for a report cell. You can use a symbolic name to represent all of the values in a set (set header symbolic name) or to represent an individual set value (set line symbolic name). For more information on symbolic names, see Symbolic Names in the Report Writer [Seite 909].

Suppose you create the same report as in Working with the Report Writer [Seite 800] and then create an additional column (% of Total) that provides a percentage for each cost center of the total income and expense accounts. You create this column using a formula.

Cell $ in the graphic below identifies the value 409,600.00. The cell was assigned the symbolic names SN-HSL0 (column coordinate) and SN-KSTL (row coordinate). Symbolic name SN-HSL0 was assigned to the set line HSL-0 in the set TD-ACT-CELL; the symbolic name SN-CNTR was assigned to the entire set TD-RCNTR-12.
The formula used in the above graphic is \(100 \times \frac{001}{A}\). The value 001 refers to the set line 001 (containing the value HSL-0) in the data set TD-ACT-CELL (used in the report column).

“\(A\)” is the cell that must be defined before the Report Writer can perform the calculation. (For more information on defining formulas, see Formulas [Seite 686]). The Report Writer knows that it must multiply 100 by the actual local currency amount (HSL-0), but it does not know what it should divide the amount by.

Given the column coordinate SN-HSL0 and the row coordinate SN-CNTR, the system performed the calculation of the % of Total column as follows:

1. It read formula \(100 \times \frac{001}{A}\) from set TD-ACT-CELL, set line 002.
## Defining Cells

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>'001'</td>
<td>HSL-0 (actual data in local currency)</td>
</tr>
<tr>
<td>'A'</td>
<td>Column coordinate SN-HSL0 (actual data in local currency)</td>
</tr>
<tr>
<td></td>
<td>Row coordinate SN-CNTR (all cost centers)</td>
</tr>
</tbody>
</table>

2. It multiplied the values for each report row by 100 and then divided the amount by the total amount (409,600.00).

3. It created a column listing the percentages of the individual rows.

A cell can only appear in a formula that is used as a column block. A cell cannot appear in a formula that is used as a row block. For more information about using formulas, see Formulas [Seite 686].

For more information on defining global cells, see Defining Global Cells [Seite 870].

### Procedure

1. From the screen Create report or Change report, choose Goto → Cells.

   The Create Report: Cells screen appears.

   If there is more than one cell in a report, they are listed on this screen.

2. To define a cell in your report, position the cursor on the cell that you want to define and choose Edit → Choose cell.

   The Create Report: Define Cells screen appears.

   The following entries were made on the Create Report: Define Cells screen:

   - The column coordinate is the symbolic name SN-HSL0 (local currency column)

   - The row coordinate is the symbolic name SN-CNTR (for all cost centers in the report rows).

3. To select a symbolic name used as a column coordinates for the cell:
   a) Position the cursor on the Column coordinate - Coordinate field.
   b) Choose Define.

   A dialog box appears, listing the symbolic names that you can use as a column coordinate. You can choose from set header and set line symbolic names. A set header symbolic name is defined in a set header and the symbolic name applies to all values contained in the set. A set line symbolic name is defined in a set line and the symbolic name applies only to the value defined for the set line.
In the previous graphic, the set line symbolic name SN-HSL0 is assigned as the column coordinate. SN-HSL0 refers to set line 001 with the value HSL-0.

c) Select the symbolic name that you want to use as a column coordinate and choose Choose.

The symbolic name appears in the Column coordinate - Coordinate field.

4. To assign a specific level to the column symbolic name, enter a number in the Level field.

The level number determines at what set hierarchy level a value is used for the cell.

You can only assign level numbers for set header symbolic names (for an entire set). You cannot assign a level number for a set line symbolic name.

5. To select a symbolic name as a row coordinate for the cell:

a) Position the cursor on the Row coordinate - Coord. field.

b) Choose Define.

A dialog box appears, listing the symbolic names that you can use as a row coordinate. You can choose from set header and set line symbolic names. A set header symbolic name is defined in a set header and the symbolic name applies to all values contained in the set. A set line symbolic name is defined in a set line and the symbolic name applies only to the value defined for the set line.

In the previous graphic, the set header symbolic name SN-CNTR is assigned as the row coordinate. SN-CNTR refers to set TD-RCNTR-12 and all values contained in the set.

c) Select the symbolic name that you want to use as a row coordinate and choose Choose.

The symbolic name appears in the Row coordinate - Coord. field.

6. To assign a specific level to the row symbolic name, enter a number in the Level field.

The level number determines at what hierarchy level a value is used for the cell.

Valid values for this field are as follows:

1. Use values at the first level of a set characteristic for the cell.

2. Use values at the second level of a set characteristic for the cell.

n. Use values at the nth level of the set characteristic for the cell.

1- Use basic set values for the cell.

2- Use the total for each basic set value for the cell.

For this field, you can only use as many numeric values as there are levels within the set hierarchy. 1- and 2- are the only negative values possible.

For example, you cannot enter 5 in this field if there are only four levels within the set hierarchy.
Defining Cells

You can only assign level numbers for set header symbolic names (for an entire set). You cannot assign a level number for a set line symbolic name.

In the report in the previous graphic, you may want to see the account percentages for each cost center total, instead of the account percentages for the total amount. The report in the following graphic shows the account percentages for each cost center.

<table>
<thead>
<tr>
<th>Inc. &amp; Exp. /Cost Centers</th>
<th>Transaction</th>
<th>% of Total</th>
<th>% of Subtotal</th>
</tr>
</thead>
<tbody>
<tr>
<td>400010 Sales Revenue</td>
<td>245,600.00</td>
<td>59.96</td>
<td>117.18</td>
</tr>
<tr>
<td>400020 Revenue fr. Investments</td>
<td>254,000.00</td>
<td>62.01</td>
<td>121.18</td>
</tr>
<tr>
<td>Income Accounts</td>
<td>499,600.00</td>
<td>121.97</td>
<td>238.36</td>
</tr>
<tr>
<td>300010 Cost of Goods Sold</td>
<td>150,000.00</td>
<td>36.62</td>
<td>71.56</td>
</tr>
<tr>
<td>300010 Wages and Salaries</td>
<td>140,000.00</td>
<td>34.18</td>
<td>66.79</td>
</tr>
<tr>
<td>Expense Accounts</td>
<td>290,000.00</td>
<td>70.80</td>
<td>138.36</td>
</tr>
<tr>
<td>100 Administration</td>
<td>209,600.00</td>
<td>51.17</td>
<td>100.00</td>
</tr>
<tr>
<td>400010 Sales Revenue</td>
<td>263,000.00</td>
<td>64.21</td>
<td>131.50</td>
</tr>
<tr>
<td>400020 Revenue fr. Investments</td>
<td>267,000.00</td>
<td>65.19</td>
<td>133.50</td>
</tr>
<tr>
<td>Income Accounts</td>
<td>530,000.00</td>
<td>129.39</td>
<td>265.00</td>
</tr>
<tr>
<td>300010 Cost of Goods Sold</td>
<td>230,000.00</td>
<td>56.15</td>
<td>115.00</td>
</tr>
<tr>
<td>300010 Wages and Salaries</td>
<td>100,000.00</td>
<td>24.41</td>
<td>50.00</td>
</tr>
<tr>
<td>Expense Accounts</td>
<td>330,000.00</td>
<td>80.57</td>
<td>165.00</td>
</tr>
<tr>
<td>200 EDP</td>
<td>200,000.00</td>
<td>48.83</td>
<td>100.00</td>
</tr>
</tbody>
</table>

Cost Centers 409,600.00 100.00

To create the percentage column in the above graphic, you enter 2 in the Level field next to the row symbolic name SN-CNTR. Based on this entry, the system uses the totals at the second level of the basic set TD-RCNTR-12. The following table contains the formulas used to calculate the columns shown in the above report.

Table for Producing Percentage Columns

<table>
<thead>
<tr>
<th>Column</th>
<th>Level</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>% of Total</td>
<td>1</td>
<td>100*’010’/’A’;A=409,600.00</td>
</tr>
<tr>
<td>% of Subtotal</td>
<td>2</td>
<td>For cost center 100: 100*’010’/’B’; B=209,600.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For cost center 200: 100*’010’/’B’; B=200,000.00</td>
</tr>
</tbody>
</table>

7. The additional functions available on this screen are shown in the following table.

Additional Functions on Screen Create/Change Report: Define Cells
## Defining Cells

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit  →  Choose coordinate</td>
<td>Define row or column coordinate for cell</td>
</tr>
<tr>
<td>Edit  →  Delete coordinate</td>
<td>Delete coordinate assigned to a cell</td>
</tr>
<tr>
<td>Goto  →  Layout  →  Reset layout</td>
<td>Reset all layout parameters to the default values of the standard layout</td>
</tr>
<tr>
<td>Extras  →  List of characteristics</td>
<td>Display a list of characteristics used in the report</td>
</tr>
<tr>
<td>Extras  →  Maintenance language</td>
<td>Switch to a new report language (for example, to enter language-specific text for the report description)</td>
</tr>
<tr>
<td>Extras  →  Threshold value</td>
<td>Enter threshold value condition to highlight in color or print report rows, depending on the values in a specific report column</td>
</tr>
<tr>
<td>Extras  →  Other std layout</td>
<td>Assign a new standard layout to the report</td>
</tr>
</tbody>
</table>

8. To save the cell information, choose **Report  →  Save**.

When the cell definition has been saved, the **Def** indicator is set on the **Create Report: Cells** screen.
Defining Global Cells

When you want to perform cell calculations over more than one row or column block, you use global cells. You define global cells by specifying the row and column block coordinate, which pinspoints an exact location in the report matrix.

When you define a report that contains a global cell, you define the coordinates of the cell using symbolic names. A symbolic name is a name assigned to a set line and/or set header, which defines the row and column coordinates for a report cell. A set header symbolic name represents all of the values in the set and a set line symbolic name represents an individual set value. (For more information on symbolic names, see Using Symbolic Names in the Report Writer [Seite 909].)

You can define global cells that reference report rows for which you have entered a formula and/or key figure block.

The procedure for defining global cells has therefore changed slightly to accommodate this new enhancement.

This procedure is the same as that used for entering key figure cells. For more information, see Defining Key Figure Cells in Defining Key Figures [Seite 875].

You create a report that displays the actual personnel costs that have been incurred in a specific department (for example, the marketing department) and the actual number of employees in the department. You then define a global cell to create an additional column that displays personnel costs per employee (see the graphic below).

<table>
<thead>
<tr>
<th>Cost per Employee</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>07.01.1995</td>
<td></td>
</tr>
<tr>
<td><strong>Personnel Costs</strong></td>
<td><strong>Actual Costs</strong></td>
</tr>
<tr>
<td>Direct labor costs</td>
<td>1,234.00</td>
</tr>
<tr>
<td>Labor costs</td>
<td>1,234.00</td>
</tr>
<tr>
<td>Salaries</td>
<td>1,000.00</td>
</tr>
<tr>
<td>Salary costs</td>
<td>1,000.00</td>
</tr>
<tr>
<td>Personnel costs</td>
<td>2,234.00</td>
</tr>
</tbody>
</table>

**Employees**

<table>
<thead>
<tr>
<th>EMPLOY</th>
<th>Actual</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>4</td>
</tr>
</tbody>
</table>
The following graphic illustrates the row block, column block, and global cell definitions used to create the above example report. The example report is defined for table CCSS.

The global cell ‘EMPL’ points to the value 4 (see the above graphic). The symbolic names EMPLOYEE (row coordinate) and ACTQTY (column coordinate) are assigned to the cell. Symbolic name EMPLOYEE is assigned to the set line EMPLOY in the set EMPLOYEES (row block two); the symbolic name ACTQTY is assigned to the set line ISSME in the set COL-QTY (column block two).

The formula used in the above graphic is ‘001’ / ‘EMPL’ (column block one). ‘001’ refers to the set line 001 (containing the value ISWKG (actual costs)) in the data set COL-COSTS.

The global cell ‘EMPL’ must be defined before the Report Writer can perform the calculation. (For more information on defining formulas in cells, see Formulas [Seite 686]).

Using the row coordinate EMPLOYEE and the column coordinate ACTQTY, the Report Writer performs the calculation of the Costs/Employee column as follows:

1. It reads formula ‘001’ / ‘EMPL’ from set COL-COSTS, set line 002:
   ‘001’ = ISWKG (actual costs)
   ‘EMPL’ = Row coordinate EMPLOYEE (number of employees)
   Column coordinate ACTQTY (actual quantity)

2. It divides the actual costs for each report row by the total number of employees (4).

3. It creates an additional report column listing the costs per employee.

Since no data records would be displayed in the report for the combinations personnel costs/actual quantity and number of employees/actual costs, you must inactivate these row/column combinations to produce the report illustrated in the first graphic of this section.

April 2001
Defining Global Cells

To create the above example report, you define the report as follows:

1. Create the sets to be used in the row and column block definitions (if they do not already exist in your system).

   The following sets are used in the above report:

<table>
<thead>
<tr>
<th>Report rows:</th>
<th>Report columns:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single-dimension set <strong>0HBAB-PERSON</strong> for the characteristic <strong>KSTAR</strong> (cost element), containing personnel costs</td>
<td>Data set <strong>COL-QTY</strong>, containing the predefined column <strong>ISSME</strong> (actual quantity) in line 001. The symbolic name <strong>ACTQTY</strong> is assigned to set line 001 (for the predefined column called actual quantity).</td>
</tr>
<tr>
<td>Basic set <strong>EMPLOYEES</strong>, containing the statistical key figure <strong>EMPLOY</strong> (number of employees). The symbolic name <strong>EMPLOYEE</strong> is assigned to set line 001 (for the statistical key figure <strong>EMPLOY</strong>).</td>
<td>Data set <strong>COL-QTY</strong>, containing the predefined column <strong>ISSME</strong> (actual quantity) in line 001. The symbolic name <strong>ACTQTY</strong> is assigned to set line 001 (for the predefined column called actual quantity).</td>
</tr>
</tbody>
</table>

2. Define the report rows.

   To define a row block from any **Create Report** screen:

   a) Choose Goto → Rows.

      The **Create Report: Row Overview** screen appears.

   b) Enter the following information:

      – Set **0HBAB-PERSON** as row block one

      – Set **EMPLOYEES** as row block two

3. Define the report columns.

   To define a column block from any **Create Report** screen:

   a) Choose Goto → Columns.

      The **Create Report: Columns** screen appears.

   b) Enter the following information:

      – Set **COL-COSTS** as column block one

      – Set **COL-QTY** as column block two

4. Define the global cell used in the formula `‘001’ / ‘EMPL’` in line 002 of set **COL-COSTS**.

   To define the global cell from the **Create Report: Columns** screen:

   a) Choose Goto → Cells.

      The **Create Report: Cells <report name>** screen appears.

   b) The cell name **EMPL** is automatically displayed in the Cell field.

      Select Global to define cell **EMPL** as a global cell.
If you don’t set the Global indicator, the cell you define is a normal cell (also called a local cell). The coordinates in a local cell can only reference one characteristic in the current row and column block. A local cell is only valid within one row/column block.

c) Choose Edit → Choose cell.

The Definition of Cell Empl dialog box appears.

d) In the Block number field, you enter the number of the row block for which you want to enter the row coordinate of the global cell. Enter 2 in this field. The system then recognizes that the cell is located somewhere in row block 2.

e) Choose Continue.

The Definition of Cell Empl dialog box appears. On this screen, you define the row and column coordinates for cell EMPL.

f) To select the symbolic name used as the row coordinate for the cell:
   – Check that the row block number in the Row - Block number field is correct. The number you entered in the previous dialog box (in this case, 2) appears as the default value.
   – Choose Define row coordinates.

      The symbolic name EMPLOYEE from set EMPLOYEES is displayed in the Coord. field, pinpointing the exact row coordinate of the cell.

      If more than one symbolic name has been defined in the set(s) used in the row block, a dialog box appears, listing the symbolic names that you can use as the row coordinate. You can then select the symbolic name that you want to use as the row coordinate in the cell.

g) To select the symbolic name used as the row coordinate for the cell:
   – Enter 2 in the Column - Block number field. The system then recognizes that the column coordinate of the cell is located somewhere in column block 2.
   – Choose Define column coordinates.

      The symbolic name ACTQTY from set COL-QTY is displayed in the Coord. field, pinpointing the exact column coordinate of the cell.

      If more than one symbolic name has been defined in the set(s) used in the column block, a dialog box appears listing the symbolic names that you can use as the column coordinate. You can then select the symbolic name that you want to use as the column coordinate in the cell.

h) Choose Continue.

The Def indicator is set, showing that the cell is now defined.

5. Deactivate the following row/column block combinations:
   – Personnel costs (row block one)/actual quantity (column block two)
Defining Global Cells

- **Number of employees (row block two)/actual costs (column block one)**

  For more information on deactivating row/column block combinations, see Deactivating Columns for a Row Block [Seite 845].

6. On this screen you can use the additional processing functions in the table for the screen Create Report: Initial Screen, as well as the functions in the table in Defining Cells [Seite 864].


8. To save the report definition, choose Report → Save.

When you execute the report’s report group and output the report, it displays the additional report column Costs/Employee, showing the actual personnel costs per employee (see the first graphic in this section).
Defining Key Figures

Within the Report Writer, a key figure is an extension of the cell concept. A key figure performs various cell calculations within a report, such as subtracting subtotals within a column. The key figure pinpoints particular locations of a key figure block within the column-row matrices of a report.

The following graphic is an example of a key figure in a report.

<table>
<thead>
<tr>
<th>08.09.1995</th>
<th>Assets/Liabilities</th>
<th>Local/Actual</th>
</tr>
</thead>
<tbody>
<tr>
<td>100010</td>
<td>Bank Accounts</td>
<td>750,000.00</td>
</tr>
<tr>
<td>100020</td>
<td>Accounts Receivable</td>
<td>400,000.00</td>
</tr>
<tr>
<td>100030</td>
<td>Merchandise Inventory</td>
<td>600,000.00</td>
</tr>
<tr>
<td>100040</td>
<td>Property</td>
<td>150,000.00</td>
</tr>
<tr>
<td>100050</td>
<td>Investments</td>
<td>370,000.00</td>
</tr>
<tr>
<td>** Asset Accounts</td>
<td>2,270,000.00</td>
<td></td>
</tr>
<tr>
<td>200010</td>
<td>Accounts Payable</td>
<td>650,000.00</td>
</tr>
<tr>
<td>200020</td>
<td>Notes Payable</td>
<td>350,000.00</td>
</tr>
<tr>
<td>200030</td>
<td>Common Stock</td>
<td>270,000.00</td>
</tr>
<tr>
<td>200040</td>
<td>Long-Term Liabilities</td>
<td>800,000.00</td>
</tr>
<tr>
<td>200050</td>
<td>Retained Earnings</td>
<td>200,000.00</td>
</tr>
<tr>
<td>** Liability Accounts</td>
<td>2,270,000.00</td>
<td></td>
</tr>
</tbody>
</table>

Current Key Figure 1995

Current Key Figure 1

In the above graphic, the current key figure (current assets/current liabilities) for 1995 is displayed in the lower portion of the balance sheet report. You can define this key figure using a formula whose operands are cells. These cells are addressed through the symbolic names contained in the row and column sets of the report.

To define the example key figure in the above graphic, you perform the following steps:

1. Define key figure text.
   - You define key figure text for the following objects:
     - Key figure block
       - A key figure block is a matrix of key figures and lists all key figures that you want to use in the report. You can define a key figure block that contains one or more key figures.
     - Key figure row(s)
       - You define this text for the key figure row(s) of your key figure block. The text appears in the report row(s) of the key figure block. For each row you enter, the system creates a row for the current key figure block. The text you enter appears in the report row for the key figure result.
Defining Key Figures

1. Define the key figure column(s).

You define this text for the key figure column(s) of your key figure block. This text appears in the report column(s) of your key figure block. For each row you enter, the system creates a column for the current key figure block.

For the report in the above graphic, the key figure block text is Current Key Figure, the row text is also Current Key Figure, and the column text is 1995.

2. Define the key figure formula.

For each key figure row/column intersection that you define for your key figure block, you define a key figure formula that calculates the amount that should appear for the row/column intersection.

For the report in the above graphic, you would have to define a key figure formula for the row Current Key Figure and column 1995.

To calculate the key figure in the above graphic, the Report Writer uses set symbolic names to identify the current assets total (CA) and the current liabilities total (CL). It then divides the current assets by the current liabilities and displays them in the report (as defined in the report row definition). The key figure formula is CA/CL.

3. Define the cells for the key figure.

You need to define each cell (row/column coordinate) that you use in a key figure formula.

The key figure formula for the report in the above graphic contains the cells CA (Current Assets) and CL (Current Liabilities). In this key figure, the current assets (cell name CA) are divided by the current liabilities (cell name CL).

- **Cell A**: The row coordinate is the symbolic name ASSETS (total of the assets in single-dimension set TD-RACCT-GBS) and the column coordinate is the symbolic name TD-HSL0 (total of local currency in data set TD-ACT-HSL).

- **Cell B**: The row coordinate is the symbolic name LIABLIT (total of the liabilities in single-dimension set TD-RACCT-GBS) and the column coordinate is the symbolic name TD-HSL0 (total of local currency in data set TD-ACT-HSL).

You can also define key figure cells that refer to report rows for which you have entered a formula and/or key figure block.

4. Insert the key figure in a row block of the report.

Once you have defined the key figure, you insert the key figure block in a row block of the report.

To define a key figure block from any Create Report screen:
1. Choose Goto → Key figures.
   The Create Report: Key Figure Blocks screen appears.

**Entering Text for Key Figures**

2. In the Name field, enter a description for the key figure block that you want to define.

3. Choose Edit → Rows.
   The Rows from <key figure block name> screen appears.

4. Enter the necessary data and choose Continue:
   – Enter the code that represents the character you want to appear before the key figure row (B field).
   – Enter the code that represents the character you want to appear after the key figure row (A field).
   – Set the H indicator if you want to highlight the key figure row.
   – Enter the code for the color in which you want the key figure row to be displayed (C field).
   – Specify whether you want to insert a page break or blank lines between the individual logical rows in a key figure block.
   – Enter the text that you want to appear for the key figure row. The text you enter appears in the row for the key figure block.

5. Choose Edit → Columns.
   The Columns from <key figure block name> screen appears.

6. Enter the following data as required and choose Continue:
   – The print class that you want to use for the key figure column.
   – Specify whether you want to insert a page break or blank lines between the individual logical columns in a key figure block.
   – Enter the text that you want to appear for the key figure column. The text that you enter appears in the column for the key figure block.

**Entering Formulas for Key Figures**

7. Choose Edit → Formulas.
   The Formulas from <key figure block name> screen appears. For each key figure that you use in a report, you must define the formula used to create the key figure.

8. Position the cursor where the key figure amount should appear, and choose Formula.
   A dialog box appears.

9. Enter a formula in the dialog box. This formula must describe a key figure that you want to use in your report. Choose Continue.
   If you define a key figure formula, use the mathematical operations contained in the table in Using Set Formulas in the Report Writer [Seite 906]. You can enter as many cell names as necessary to calculate your key figure.
Defining Key Figures

The key figure appears at the intersection of the key figure row and column text on the 
Formulas from <Key Figure Block Name> screen.

When you defined cells, you entered apostrophes around the name of the cell. You 
must also enter apostrophes when defining cells for key figures.

10. To exit the Formulas from <Key Figure Block Name> screen, choose Continue.

Defining Cells for Key Figures

11. Choose Edit → List of cells.

The List of All Cells screen appears.

When a cell has been defined, the Def indicator is set. The No. uses field displays how 
many times the cell is used in report key figures or column formulas.

You define key figure cells in a similar way to defining report cells. A cell pinpoints a 
particular location within a report. Once the Report Writer has located a point, it can then 
use the corresponding value (amount) for the key figure formula.

You define the coordinates of a cell using symbolic names. A symbolic name is a name 
assigned to a set line or to a set header, which defines the row and column coordinates 
for a report cell. You can use a symbolic name to represent all of the values in a set or to 
represent an individual set value.

For more information on symbolic names, see Using Symbolic Names in the Report 
Writer [Seite 909].

You can also define key figure cells that refer to report rows for which you have 
entered a formula and/or key figure block.

Example:

Your report contains the following rows:

- Income Accounts (row block 1)
- Expense Accounts (row block 2)
- Sum of the Income and Expense Accounts (row block 3)

This sum is calculated with the formula ‘001’ + ‘002’

You can now define a cell in a key figure block that references the sum of the income 
and expense accounts (the formula entered in row 3 of your report definition).

The procedure for defining key figure cells has therefore changed slightly to 
accommodate this new enhancement.

12. Position your cursor on the first cell you want to define, and choose Define cell.

The Definition of Cell <Cell Name> dialog box appears. In the Block number field, enter 
the number of the row block for which you want to enter the row coordinate of the cell.

13. Choose Continue.
The dialog box that appears depends on the type of row block you entered in the Block number field in the previous dialog box.

If the row block is a Set row block:

The Definition of Cell <Cell Name> dialog box appears.

On this screen, you define the row and column coordinates for the cell.

To select a symbolic name used as a row coordinate for the cell:

a) Check the row block number in the Row - Block number field. The row block number you entered in the previous dialog box appears as the default value. You can choose a different row block for the row coordinate by choosing Other row block next to the field.

b) Choose Define row coordinates.

A dialog box appears, listing the symbolic names that you can use as a row coordinate.

c) Select the symbolic name that you want to use as a row coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

To select a symbolic name as a column coordinate for the cell:

a) In the Block number field, enter a block number.

b) Choose Define column coordinates.

A dialog box appears, listing the symbolic names that you can use as a column coordinate.

c) Select the symbolic name that you want to use as a column coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

If the row block is a Formula row block:

The Definition of Cell <Cell Name> dialog box appears.

On this screen, you define the column coordinate of the cell. The row coordinate is already determined from the row block number you entered in the previous dialog box because a formula row only comprises one report row.

To select a symbolic name used as the column coordinate of the cell:

a) In the Block number field, enter a block number.

b) Choose Define column coordinates.

A dialog box appears, listing the symbolic names that you can use as a column coordinate.

c) Select the symbolic name that you want to use as a column coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

If the row block is a Key figure row block:
Define Key Figures

The Definition of Cell <Cell Name> dialog box appears.

On this screen, you define the row and column coordinates for the key figure block.

a) Enter the row number of the key figure block.
b) Enter the column number of the key figure block.

If you want to define a key figure cell that refers to a key figure block, you must first insert the key figure as a row block in the row definition of your report.

For more information, see the following subsection Inserting Key Figures in Row Blocks.

14. Define additional key figure cells.

Refer to steps 12-13 for more information.

15. On this screen, you can use the additional processing functions in the table Create Report: Initial Screen as well as the functions in the following table.

Additional Processing Functions (Create Report: Key Figure Blocks)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Rows</td>
<td>Define text for the key figure rows</td>
</tr>
<tr>
<td>Edit → Columns</td>
<td>Define text for the key figure columns</td>
</tr>
<tr>
<td>Edit → Formulas</td>
<td>Define key figure formulas</td>
</tr>
<tr>
<td>Edit → List of cells</td>
<td>Define key figure cells</td>
</tr>
<tr>
<td>Edit → Insert block</td>
<td>Insert a key figure block</td>
</tr>
<tr>
<td>Edit → Delete block</td>
<td>Delete a key figure block</td>
</tr>
<tr>
<td>Goto → Report layout → Use standard layout</td>
<td>Reset layout parameters to default values of standard layout</td>
</tr>
<tr>
<td>Extras → List of characteristics</td>
<td>Display a list of characteristics that are used (or can be used) in the report</td>
</tr>
<tr>
<td>Extras → Maintenance language</td>
<td>Switch to a new report language (for example, to enter text for the report description in another language).</td>
</tr>
<tr>
<td>Extras → Other std layout</td>
<td>Assign new standard layout to the report</td>
</tr>
<tr>
<td>Extras → Threshold value</td>
<td>Enter threshold value condition to highlight in color or print report rows, depending on the values in a specific report column</td>
</tr>
</tbody>
</table>

Inserting Key Figures in Row Blocks

To use the key figure in the report, you must insert the key figure into a report row:
1. Choose Goto → Rows.
   The Create Report: Rows screen appears.
2. Position the cursor on the row block in which you want the key figure to appear.
3. Choose Edit → Insert key figures.
   A list of defined key figures appears in a dialog box. If only one key figure is defined for the report, it automatically appears on the Create Report: Rows screen.
4. Select a key figure and choose Choose.
   The selected key figure appears on the Create Report: Rows screen.
Defining Report Documentation

1. From any Create Report screen, choose Goto → Documentation.

2. Enter the report documentation as desired.
   For more information about the use of the SAPscript editor for word processing, see the SAP Library under Basis Components → Basis Services/Communication Interfaces (BC-SRV) → SAPscript (BC-SRV-SCR).

3. Choose Text → Save.
   You will now be able to display the report documentation when you output the report.
   The name under which the documentation is stored is also displayed.

   The name of your report library is Z01, and your report name is Z-REPO. When you define report documentation, it is stored under the report name R_Z01_Z-REPO, where R is for report, Z01 is the library name, and Z-REPO is the report name.
Extracts

Use
To reduce the necessary runtime for formatting report data, you can create an extract when you execute a report. An extract is a dataset that contains the report data selected at the time the extract was created.

Extracts provide the same navigation and formatting options as reports selected directly from the database.

The main differences between an extract and a report are shown in the following table:

<table>
<thead>
<tr>
<th>Main Differences Between Report and Extract</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Report (Newly Selected)</strong></td>
</tr>
<tr>
<td><strong>Extract</strong></td>
</tr>
<tr>
<td>Currentness of data</td>
</tr>
<tr>
<td>Data is current</td>
</tr>
<tr>
<td>Data is no more recent than the time the extract was created</td>
</tr>
<tr>
<td>Authorization check</td>
</tr>
<tr>
<td>On each record</td>
</tr>
<tr>
<td>Only on entire report</td>
</tr>
<tr>
<td>Runtime</td>
</tr>
<tr>
<td>Generally long runtimes with large database structures, plus additional time for report output</td>
</tr>
<tr>
<td>Runtime only for report output</td>
</tr>
</tbody>
</table>

Aside from these differences, extracts offer full report functionality. When you call up a report that uses an extract, the system does not have to select the report data directly from the database. As a result, processing time improves considerably.

If you create an extract and then make changes to the data structure in Customizing, this can result in inconsistencies between the current data structure and the structure in the extract. The data of the extract can therefore no longer be displayed.

After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Integration
The final step in defining a report group [Seite 937] is executing the report group. You generate an extract when you execute the report with reference to the selection parameters entered at the time the report is executed. You can therefore create multiple extracts of the same report by entering different selection criteria each time.

If you called up the report using an extract, the system outputs the report using the extract data.

If you called up your report by selecting data from the database, the system outputs the report according to the selection criteria you specified and formats the report according to the report definition.

For more information, see Executing a Report Group [Seite 964].
Extracts

Features

In expert mode [Seite 978], you can create extracts on the selection screen (for more information, see General Data Selection [Seite 762]) if you execute a report group and choose the button Extract parameters... and then the mode Create extract. Alternatively, you can save your report output as an extract when you exit the report. In this case, the system displays a dialog box, asking whether you want to save the report in an extract file.

If you call up a report when Display extract is selected as the data source, the system checks whether any extracts are available that match the selection criteria. You can then choose from among the available extracts. You can also search for, display, and print extracts using extract management. In both cases, direct access is possible to all extracts generated within a variation.

Extracts are deleted either manually in extract management or automatically based on an expiration date that you can specify when you create the extract.

⚠️

Once an extract has been deleted, it cannot be retrieved.

For more information, see Creating an Extract [Seite 1010] and Managing Extracts [Extern].
Create Extract

Use
There are two different ways of creating an extract [Seite 1008]:

- You can create extracts on the selection by choosing Extract Parameters and then choosing Create Extract in the dialog box.
- You can generate an extract when executing a report. To do this, follow the steps under Procedure.

You can only create extracts in expert mode [Seite 978]. Make sure that expert mode has been activated. You can make these settings from the selection screen by choosing Environment → Options.

Procedure
5. Enter the required report group and choose .
6. Enter the required selection parameters and choose .

If extracts already exist for the selection criteria you have specified, the system will display a list of extracts that you can choose.
5. The report is now displayed. Choose Report → Save. In the Enter: Extract Parameters dialog box, you can define the parameters for your extract. For further information about extract parameters, see Expert Mode [Seite 978]. To complete your entries, choose .
Managing Extracts

Use
When you save reports in extracts, you can then access the data at any time without having to select the data from the database.

You can use extract management to:

- **Display extracts**
- **Print extracts**
- **Change the extract priority**
- **Change the expiration date of an extract**
- **Delete extracts**

⚠️ After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Prerequisites
You have saved your reports in extract files. For more information, see Creating an Extract [Seite 1010].

Procedure
2. On any Create/Change/Display/Execute Report Group screen, choose Utilities → Extracts → Display or Delete or Print or Change expiry date, depending on the function you want to use.


   ![Report Writer: Extract Management screen](image)

   You can also access extract management from the screen Execute Report Group: Initial Screen using the button Data extracts when you execute a report group from the first selection screen with Environment → Extract directory...

3. Enter the criteria according to which the extracts should be selected:
   - If you are searching for a particular extract, enter the description of the extract.
   - Specify whether extracts should be displayed that were generated by your or by a particular user, or whether all extracts should be displayed regardless of the user.
   - Specify when the extracts were generated, or whether all extracts should be generated regardless of the date.
   - You can select the extracts of a particular report group [Seite 937] or report group range.
   - You can select the extracts according to their priority, and restrict the selection to unread extracts.
Managing Extracts

- If you want to further restrict the selection criteria (for example, according to a specific characteristic or group of characteristics), choose Additional selections and enter the criteria. You can expand the number of selection conditions as required, and delete selection conditions you entered.

4. Choose .

The system displays a list of extracts that meet the selection criteria you entered.

5. Select the desired extract and choose one of the following functions:

  c. Display extract

     Choose .

  d. Print extract

     You can print extracts immediately or in the background.

     - To print the selected extracts, choose Extraks and enter the output device and other parameters for print control.

     - To print in the background, choose Background and specify when the job should be started.

  f. Change the extract priority

     Choose and change the priority of the extract.

  g. Change expiration date

     You can change the expiration date that was specified when the extract was created.

     Choose . If you want the extract to be deleted automatically after a specified time, enter the number of days in the dialog box Change expiration date under Expires in or choose Expires on and enter an expiration date.

     If you don’t want the extract to be deleted after a specified time, choose No expiration date. This is appropriate when the report is required for an undeterminable length of time or the report takes a long time to execute.

     Choose to exit the dialog box and save your entries.

  h. Delete extract

     Once an extract has been deleted, it cannot be retrieved.

     Choose to delete extracts. If you answer the question whether the selected extracts should be deleted with Yes, the extracts are deleted.

     For information on settings for extract management, see the Implementation Guide for Cost Center Accounting under Information System → User Settings → Specify Settings for Extract Management.
Example Process: Report Callup with Extract Management

Purpose
At the end of each month, the reports (important to cost center managers in the entire organization) are executed, and the data is stored in extracts [Extern]. Reports that contain data for individual cost centers [Extern] or cost center groups [Extern] are executed using variation, so that a separate report can be created for each cost center and cost center group.

You can set the user parameters for your cost center managers so that they can automatically access the most current extracts.

When calling up a report from the report tree, each manager receives the relevant individual data. The manager does not need to select the data from the database again, which reduces the workload of the system.

The cost center manager cannot navigate to areas within the extracts that do not belong to the authorized CO-OM responsibility area.

The system administrator who sets up these reports needs to have authorization to select the data from the database. However, this does not authorize the administrator to display the data in those reports.

The cost center managers need authorization to display the reports for their CO-OM responsibility area. However, this does not entitle them to select the data from the database or to create extracts.

The following graphic displays the way in which a report is executed in extracts, in the background with the variation. It also shows how you can save it in extracts.
Process Flow

5. Initial setups include creating the authorizations for system administrators and cost center managers [Extern].

6. The system administrator arranges for all the reports to be accessible to all users in EUROs. The system administrators execute the report (such as the Cost Centers: Actual/Plan Variance report) in the background and with the variation, and save the report in extracts (see: Executing a Cost Center Report with Variation and Saving it in Extracts [Extern]).

7. The system administrator makes the settings for extract management for the cost center managers in Customizing (see: Specifying Settings for Extract Management [Extern]). In their user-specific settings, the cost center managers save their selection criteria for the reports they want to display (see Customizing for Controlling under Cost Center Accounting → Information System → User Settings → Specify User Settings [Extern]).

8. The cost center manager accesses the report (see: Calling Up Cost Center Reports [Extern]).

This procedure is shown in more detail in the following sections using the Cost Centers: Actual/Plan/Variance report.

Result

Each cost center manager can quickly and easily display the relevant reports required.
Sets in the Report Writer

Use

The Report Writer uses sets to structure and select report data. Report structure and contents are defined according to the sets that are used for rows, columns, and selection criteria. These sets include basic, key figure, single-dimension, and multi-dimension sets.

You can use sets as:

- **A row block**
  The row block contains the characteristics that you want to include in the rows of your report (for example, cost center and account numbers).

- **A column block**
  The column block contains the characteristics that you want to include in the columns of your report (for example, periods, currencies, and amounts).

- **General selection criteria**
  The selection criteria contain the characteristics that you want to use to select the report data (for example, year, period, company, and ledger).

Before you can begin creating a report, you must first create the sets that the report will use. If the sets you need already exist in your system, you do not need to create new sets for a report. Also, since sets are not report-specific, you can use the same sets for more than one report.

You can only use a characteristic once in a report - in a row block, column block, or as selection criteria. For example, if a characteristic in a set is already used in a row block, you cannot use the characteristic in a column block.

But you can use the same characteristic in multiple row blocks or multiple column blocks. You can not use the same characteristic in a row block and a column block.

If you use the characteristic “account” in row block 1, you can also use the same characteristic in row block 2. However, you can not use the characteristic “account” in a row block and a column block.

This section contains:

- Defining Report Data [Seite 893]
- Using Sets in Report Rows [Seite 894]
- Using Sets in Report Columns [Seite 898]
- Suppressing Rows and Columns [Seite 899]
- Using Sets as Selection Criteria [Seite 900]
- Entering Set Text for Reports [Seite 901]
- Using Variables in Report Writer [Seite 903]
Sets in the Report Writer

Using Set Formulas in Report Writer [Seite 906]
Using Symbolic Names in Report Writer [Seite 909]
Setting Format Groups in Sets [Seite 910]

For more information on creating sets, see creating sets [Seite 651].
Defining Report Data

Key figure sets are used only by the Report Writer and contain specific key figures. A key figure refers to a numerical value field stored in a database table. Such key figures are called basic key figures. You can combine a basic key figure with one or more additional characteristics entered in a set to create a key figure. The set determines additional selection conditions, such as the record type (actual or plan data) and the plan version.

Examples of basic key figures used in key figure sets include:

- Transaction currency
- Local currency
- Group currency
- Quantity

Examples of additional characteristics that can be combined with a basic key figure include:

- Actual amount (record type)
- Plan amount (record type)
- Allocated actual (record type)
- Allocated plan (record type)
- Year
- Period

When you use a key figure set in a report, the system selects the currency/quantity and record type specified in the key figure set.

You create a key figure set that contains actual data (record type) in local currency (key figure). If you use this set in a report, the system displays actual data in local currency.
Sets in Report Rows

When you define a report, you select a set as a row block for the report. A row block can consist of one or more physical rows.

For example, if you select a basic set containing account numbers as a row block, the report contains a physical row for each account number in the set.

The order in which values are defined within the set determines how data is sorted and how totals and subtotals are generated. The set hierarchy also determines the report structure and layout. For each set in the set hierarchy, the system creates a subtotal.

If you use a single-dimension set that contains only basic sets in a row block, the system creates subtotals for each basic set, as well as a grand total for the single-dimension set. The system also creates physical rows for each value in the basic sets in the row block.

The row block is the set defined on the Create Report: Rows screen; the physical rows are the detail levels within the set. You can use a basic set, key figure set, single-dimension set, or multidimension set as a row block.


The following graphic shows the multidimension set TD-CC-ACCT.

![Diagram of TD-CC-ACCT set hierarchy]

In the above graphic, the sets and set values contained in the multidimension set TD-CC-ACCT are displayed along with text describing the sets.

For each characteristic in a row block, you specify the level of detail that appears in the report rows. Each detail level contained in a basic set, key figure set, or single-dimension set is
assigned a level number. The following graphic shows the levels of detail found in the set TD-CC-ACCT for the characteristic Account (single-dimension set TD-RACCT-IE).

The multidimension set TD-CC-ACCT (row block) is at the top of the set hierarchy. The name that you assign to a multidimension set appears as the header for the physical rows contained in the report.

If you do not want to use the set text, you can also define your own text for the row block in the report lead column.

Level 1 consists of the single-dimension set TD-RACCT-IE. If you enter level 1 for this characteristic, you only see the sum of income and expense accounts in the report for the cost centers in basic set TD-RCNTR-12.

Level 2 (2-) includes the basic sets TD-RACCT-INC and TD-RACCT-EXP. The sets are ordered in the hierarchy in the same order as they appear in the single-dimension set TD-RACCT-IE. Both sets have the characteristic account. If you specify this detail level in a report, you only see:

1. The total of the cost centers and accounts
2. The sum of the income accounts
3. The sum of the expense accounts

The detail level (1-) includes the details of all the basic sets included for the report, that is, the income accounts, expense accounts, and cost center numbers.

The set that appears at the highest level of a characteristic is assigned the level 1.

For example, level 1 is assigned to the single-dimension set TD-RACCT-IE (see above graphic) because it leads the hierarchy of the characteristic account. Level 1 would also be assigned to the basic set TD-RCNTR-12, since it leads the hierarchy of the characteristic cost center.

You can only use the negative values 1- and 2- as detail levels. 1- displays only basic set values; 2- displays the basic set values and the total for the basic set.
Sets in Report Rows

You can use detail levels to highlight and underline totals and subtotals in a report, as well as display totals and subtotals in different colors.

The report in Working with the Report Writer: Overview [Seite 800] lists the following row information for the row block TD-CC-ACCT:

- The set name of the multidimension set TD-CC-ACCT appears as the row heading for the physical rows in the multidimension set.
- The report contains the row text cost centers. This text comes from basic set TD-RCNTR-12 (with the set text cost centers) which appears first in multidimension set TD-CC-ACCT. The sequence of the row texts (from top to bottom) depends on the sequence of the characteristics in the multidimension set (from left to right).
- The report lists totals for individual income and expense accounts according to cost centers. Accounts appear within the subheading Cost Center because the single-dimension set TD-RACCT-IE appears second in the multi-dimension set. (In our example, the totals are output at the end. If you change the layout, however, you can have the totals output at the top of the report.) For more information, see Defining Report Layouts [Seite 1031].

If you reorder the set contents, the report contents are also reordered.

In the following graphic, the multidimension set TD-CC-ACCT was changed. Set TD-RACCT-IE is now in the first position, and set TD-RCNTR-12 is in the second position.

Level 1 still consists of single-dimension set TD-RACCT-IE and basic set TD-RCNTR-12. Set TD-RACCT-IE now appears before set TD-RCNTR-12, since in multidimension set TD-CC-ACCT the characteristic account has moved to position 1 and the characteristic cost center to position 2.

A report printed with this multi-dimension set as a row block would look like the following graphic. To see the differences that result from moving the characteristics in a multidimension set, compare this report to the report in Working with the Report Writer: Overview [Seite 800].
### Sets in Report Rows

#### 08.09.1995

<table>
<thead>
<tr>
<th>Inc. &amp; Exp./Cost Centers</th>
<th>Local</th>
<th>Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>100 Administration</td>
<td>800,000.00</td>
<td>1,272,000.00</td>
</tr>
<tr>
<td>200 EDP</td>
<td>275,000.00</td>
<td>421,500.00</td>
</tr>
<tr>
<td>400010 Sales Revenue</td>
<td>1,075,000.00</td>
<td>1,681,500.00</td>
</tr>
<tr>
<td>100 Administration</td>
<td>900,000.00</td>
<td>1,433,999.95</td>
</tr>
<tr>
<td>* 200 EDP</td>
<td>289,000.00</td>
<td>444,180.01</td>
</tr>
<tr>
<td>* 400020 Rev. fr. Investments</td>
<td>1,189,000.00</td>
<td>1,878,179.96</td>
</tr>
<tr>
<td>* Income Accounts</td>
<td>2,264,000.00</td>
<td>3,571,679.96</td>
</tr>
<tr>
<td>100 Administration</td>
<td>90,000.00</td>
<td>145,800.00</td>
</tr>
<tr>
<td>* 200 EDP</td>
<td>120,000.00</td>
<td>194,400.00</td>
</tr>
<tr>
<td>* 300010 Cost of Goods Sold</td>
<td>210,000.00</td>
<td>340,200.00</td>
</tr>
<tr>
<td>100 Administration</td>
<td>12,000.00</td>
<td>19,440.00</td>
</tr>
<tr>
<td>* 200 EDP</td>
<td>20,000.00</td>
<td>32,400.05</td>
</tr>
<tr>
<td>* 300020 Wages and Salaries</td>
<td>32,000.00</td>
<td>51,840.05</td>
</tr>
<tr>
<td>Expense Accounts</td>
<td>242,000.00</td>
<td>392,040.05</td>
</tr>
<tr>
<td>*** Income/Expense Accounts</td>
<td>2,022,000.00</td>
<td>3,179,639.91</td>
</tr>
</tbody>
</table>

In this report you see that:

- Subheading row texts are now by account (income and expense) rather than by cost center.
- Individual amounts are ordered by cost centers within the income and expense account subheadings.
- Totals are by income and expense accounts rather than by cost center.

For more information on using sets in reports, see [Defining Rows [Seite 841]].
Sets in Report Columns

When you create a report, you select a set as a column block for the report. A column block can consist of one or more physical columns.

If you select a key figure set containing two different currency types (local and group currency) as a column block, the report contains a physical column for each currency type in the set.

The set that you entered on the screen Create Report: Columns forms the column block of your report. The physical columns correspond to the detail levels within the set.

The physical column Local appears first in the example report in Working with the Report Writer [Seite 800] because it is listed first in the data set TD-ACT-TL (column block). The physical column Group appears at the second position. This column is therefore also at the second position in the data set TD-ACT-TL (column block). If you rearrange the set lines in the set, the physical columns in the report are also rearranged.

Set TD-ACT-TL was used as a column block in the report in Working with the Report Writer [Seite 800]. Key figure set TD-ACT-TL contains the two values HSL-0 (local currency in actual data) and KSL-0 (group currency in actual data).

You can use a basic set, key figure set, single-dimension set, or multidimension set as a column block.

A set that you use as a column block contains all values that you want in the physical columns of your report. The values must be defined in their sets in the same order you want them to appear in the report.

For more information about using sets in report columns, see Defining Columns [Seite 854].
Suppressing Rows and Columns

You can suppress individual values, ranges of values, or total set values within a report. Setting the suppression indicator on a multi-dimension, single-dimension, or basic set screen tells the Report Writer to ignore individual amounts and totals at lower levels of set hierarchies.

For columns, the value intervals (ranges) in basic sets are suppressed automatically; only the interval total is displayed.

In a basic set, the value intervals (ranges) are printed as individual amounts. You use the suppression indicator to suppress the individual interval amounts in a set row.

If a basic set line has an interval of account numbers 1000020 to 1000050, the system prints the amounts for all the account numbers from 1000020 to 1000050, if data has been posted for these accounts. If you set the suppression indicator in the basic set for this line, the system prints only the total for the account numbers 1000020 to 1000050 instead of the individual amounts.

In single-dimension and multi-dimension sets, you use the suppression indicator to suppress individual amounts for an entire set.

If you set the suppression indicator for the set TD-RACCT-EXP in the multi-dimension set TD-CC-ACCT, the individual amounts of the set TD-RACCT-EXP are suppressed, but the total amount of the set TD-RACCT-EXP is printed.

In the following graphic, the individual totals for the expense accounts are suppressed.
Using Sets to Select Report Data

You also use sets to further define the data that you want to select for your report.

You can use row and column sets to specify for example which accounts and types of currencies are output in your report. You can also narrow data selection for your report even further by specifying a ledger, a fiscal year, and a company. You can also enter these selection criteria on the screen Create Report: General Data Selection using selection sets in your report definition.

When you use sets as criteria for selecting data, the sets must contain all the characteristics you want to use to select data. If a characteristic is already defined in a row or column, you cannot enter the characteristic for selecting data.

Multidimension sets cannot be used as selection sets. Key figure sets can only be used as selection sets when there is exactly one value in the set.

To improve processing time when you execute the report’s report group, it is important to specify all characteristics as data selection criteria, which need not be used in the report rows or columns.

For the example report in Working with the Report Writer [Seite 800], you could select the report for Company TD11 during the first quarter of 1995. You would enter sets that use the characteristics Company, Period, and Fiscal Year.

You can also use set variables as general data selection criteria. For more information about the uses of sets in the Report Writer, see Using Variables in Report Writer [Seite 903].

For more information about using sets as selection criteria, see Defining Selection Criteria [Seite 835].
Entering Set Text for Reports

Unless otherwise defined in the report, the Report Writer prints the text that you enter in your sets when you use the sets in report row/column blocks. You can enter text for reports in the text fields on the Create and Change Set screens for basic sets, key figure sets, single-dimension sets, and multidimension sets.

You can also use the Extras → Additional texts function on the Create Report: Rows/Columns screens to enter specific row/column block text for the lead column and the report total when you define the report rows/columns. This text is used instead of the text from the set header.

• Basic Sets

For basic sets, you can enter text for each line of the set in the Short text of set line field on the Create Set: Basic Entries screen. If you then use this set in a row or column block, text appears describing the values for each set line that includes text. If you do not enter set line text, the Report Writer uses the text from the appropriate master files.

The Report Writer uses the set header text as the description for the corresponding subtotal. You can enter text for the set name in the Description field on the Create and Change Set: Header screens.

In the report in Working with the Report Writer [Seite 800], the basic set TD-RCNTR-12 contains the set header text Cost Centers, the basic set TD-RACCT-INC contains the set header text Income Accounts, and the basic set TD-RACCT-EXP contains the set header text Expense Accounts. (Account text is read from the account master files in FI, and cost center text is read from the cost center master files in CO.)

• Key Figure Sets

In key figure sets, you can enter text for each line of the set in the Short text of set line field on the Create Set: Basic Entries screen. If you then use this key figure set in a row or column block, text appears describing the values for each set line that includes text. If you do not enter text for a key figure set line, the Report Writer uses the text from the predefined column.

In the report in Working with the Report Writer [Seite 800], the key figure set value HSL-0 contains the lead column Local, and the key figure set value KSL-0 contains the lead column Group.

As with basic sets, you can enter set header text in the Description field on the Create and Change Set: Header screens.

• Single-Dimension Sets

For single-dimension sets, you can enter set header text in the Description field on the Create and Change Set: Header screens.
Entering Set Text for Reports

In the example report with switched characteristics (see Using Sets in Report Rows [Seite 894]), the single-dimension set TD-RACCT-IE contains the set header text Income/Expense Accounts.

- Multidimension Sets

For multidimension sets, you can only enter set header text in the Description field on the Create and Change Set: Header screens. When you use a multidimension set in a report row block, the set header text appears as the heading for the lead column.

In the report in Working with the Report Writer [Seite 800], the multidimension set TD-CC-ACCT contains the set header text Inc.& Exp/Cost Centers. This text appears as the lead column heading in the report.
Sets in the Report Writer

Use
You can also use variables in your reports. A variable is a placeholder for data that you can enter as required, when you run a report.

You can use **general selection variables** in your reports. General selection variables determine the data that is selected for a report. General selection variables include the following variable categories:

- **Value variables**
  These variables represent specific values. You enter a value variable in a basic set and you determine the value for the variable when you run a report that uses the set containing the variable. You can only use value variables in basic sets.

- **Formula variables**
  These variables represent formulas that determine a value for the variable. You can only use formula variables in basic sets.

- **Set variables**
  These variables represent sets and the values in those sets. You can only use set variables in multi-dimension sets. You cannot use multi-dimension sets that contain set variables as column blocks in your report.

Features

Value variables
A **value variable** is a user-defined variable that you can enter directly into a set. You can only use value variables in basic sets.

You can create a variable called YEAR. If you enter the YEAR variable in a basic set and then use the basic set in a report, the system prompts you to enter a year when you run the report.

Value variables that you use for the Report Writer, are displayed on the selection screen when you select the records for the report. When you use a value variable in a report, the value that you choose for the variable is valid for only one report run. Each time you run the report, you can enter a different value for the variable. You can also enter a default value for a variable; this value then appears each time a report is run.

For more information, see Creating Value Variables [Seite 693].

Formula variables
A **formula variable** represents a user-defined formula, which determines a value for the variable. You can only use formula variables in basic sets.
You want to create a formula that automatically calculates the previous year based on the variable for the current year. To do this, proceed as follows:

1. Create a formula variable called YEAR (current year), which uses the user exit S001 to determine the current year.

2. Refer to this formula in another formula variable called PR-YEAR (previous year). You can enter the formula as follows: 

   "&YEAR"-1. The system determines the current year using the user exit S001 and then subtracts one year for the value of the formula variable PR-YEAR.

   If you use both variables YEAR and PR-YEAR in a report, the system only prompts you to enter the current year, with the default current year being taken from the system date. The value for PR-YEAR is automatically calculated by the system (by subtracting 1 from the year you entered for YEAR). You can also define PR-YEAR by using the user exit S001 in a formula ("#S001-1").

For more information, see Creating Formula Variables [Seite 695].

If you use formula variables in report columns, you can also create more than one new report category. For more information, see using formula variables in reports: examples [Seite 859].

**Set variables**

A set variable represents a basic or single-dimension set that was created for a particular characteristic. You can enter set variables in a multi-dimension set, or directly as a selection set in a report.

You create a set variable called CNTR-V for the "Cost Center" characteristic. When you create the set variable, enter a set name (such as TD-RCNTR-12 for the characteristic Cost Center) as the default value for the set variable.

You can then use the set variable for either of the following objects:

- A multi-dimension set that is used as a row block (set variables cannot be used in column blocks of a report definition)
- A selection criterion on the Create Report: General Selection screen

   When you enter the CNTR-V set variable in a set that is used in a report, the Report Writer prompts you to enter a set name when you select the report data. In this case, the default value for the set name is TD-RCNTR-12. If required, you can enter another set and/or single cost centers.

   You can enter set variables whose default set uses a table that differs from the report table. However, the table field of the default set must be the same as the relevant characteristic of the report table.

Set variables that are used by the Report Writer are displayed on the selection screen when you select the data for your report. For each set variable used in a report, the Report Writer creates an entry field on the selection screen. You can enter either a set, or single value or an interval of values in this field.

For more information, see Creating Set Variables [Seite 697].
Set Formulas in the Report Writer

Use

In sets, you can use formulas to perform calculations within the set. When the set is used in a report, the result of these calculations then appears in a report column or row.

You can only use formulas in basic sets and key figure sets.

You create a key figure set called TD-ACT-PLN-V, which uses the formula ‘001’ ‘002’. Line 001 of the set TD-ACT-PLN-V is plan data in local currency (HSL-1) and line 002 is actual data in local currency (HSL-0).

The formula ‘001’ ‘002’ creates the Variance column in the report in the following graphic. To create this column, the system subtracted line 002 (actual data) from line 001 (plan data).

Using a Formula to Create a Variance Column in a Report

<table>
<thead>
<tr>
<th>08.09.1995 Inc. &amp; Exp./Cost Centers</th>
<th>Plan Data</th>
<th>Actual Data</th>
<th>Variance</th>
</tr>
</thead>
<tbody>
<tr>
<td>400010 Sales Revenue</td>
<td>120,000.00</td>
<td>245,600.00</td>
<td>-125,600.00</td>
</tr>
<tr>
<td>400020 Revenue fr. Investment.</td>
<td>420,000.00</td>
<td>254,000.00</td>
<td>-166,000.00</td>
</tr>
<tr>
<td>Expense Accounts</td>
<td>540,000.00</td>
<td>499,600.00</td>
<td>-40,400.00</td>
</tr>
<tr>
<td>300010 Cost of Goods Sold</td>
<td>100,000.00</td>
<td>150,000.00</td>
<td>-50,000.00</td>
</tr>
<tr>
<td>300020 Wages and Salaries</td>
<td>90,000.00</td>
<td>140,000.00</td>
<td>-50,000.00</td>
</tr>
<tr>
<td>Expense Accounts</td>
<td>190,000.00</td>
<td>290,000.00</td>
<td>-100,000.00</td>
</tr>
<tr>
<td>** 100 Administration</td>
<td>350,000.00</td>
<td>209,600.00</td>
<td>-140,400.00</td>
</tr>
<tr>
<td>400010 Sales Revenue</td>
<td>120,000.00</td>
<td>263,000.00</td>
<td>-143,000.00</td>
</tr>
<tr>
<td>400020 Revenue fr. Investment.</td>
<td>450,000.00</td>
<td>267,000.00</td>
<td>-183,000.00</td>
</tr>
<tr>
<td>Expense Accounts</td>
<td>570,000.00</td>
<td>330,000.00</td>
<td>-240,000.00</td>
</tr>
<tr>
<td>** 300010 Cost of Goods Sold</td>
<td>100,000.00</td>
<td>230,000.00</td>
<td>-130,000.00</td>
</tr>
<tr>
<td>** 300020 Wages and Salaries</td>
<td>100,000.00</td>
<td>200,000.00</td>
<td>-100,000.00</td>
</tr>
<tr>
<td>** 200 EDP</td>
<td>370,000.00</td>
<td>200,000.00</td>
<td>-170,000.00</td>
</tr>
</tbody>
</table>

| Cost Centers                        | 720,000.00| 409,600.00  | 310,400.00 |

A formula consists of operators, operands, absolute values, and parentheses.

When you enter a formula in a set, you can use the operators in the following table.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
</tbody>
</table>

April 2001
You can use the following operands in set formulas:

- Line numbers in the form ‘nnn’ (for example ‘001’ for line 001)
- Value variables (for example, ‘&PERIOD’ for the value variable PERIOD)
- Symbolic names for cells (for example, ‘TOTAL’ for a specific totals row in a report)

You enter formula operands in the form ‘nnn’ (for example, ‘001’ to enter the row block 001). In earlier releases, you enter formula operands using angle brackets around the operand (for example <001>).

The system automatically converts any existing formulas into the new format. You do not therefore need to change your sets or reports that contain formulas.

Within a formula you can also use:

- Absolute values (for example, 10 or 20)
- Combinations of absolute values and operands (for example, 10 * ‘002’ (line 2))
- Boolean logic

You enter the following formula in the second line of a set defined for a report column:

\[ \text{IF } '001' > 1000 \text{ THEN } '001' \text{ ELSE 0} \]
Set Formulas in the Report Writer

If the value in the first column (set line 001) is greater than 1000, then this value displays in the second column; if the value in the first column is less than 1000, the value 0 displays in the second column.

For more information on Boolean logic, see Introduction to Boolean Logic [Seite 1121].

If you use set formulas that only use the addition and subtraction operators (also known as linear formulas), you can display the units (for example, currency units and units of measure) in the report columns that are calculated using the formula.

You define a data set for the column block, which contains actual and plan costs. You want to define a variance column containing the difference between the actual and plan costs. In line three of the column block, you define the formula ‘001’ – ‘002’. If the data for the actual and plan costs is displayed with the currency unit USD, the unit USD also displays in the variance column.

The unit is only displayed when the unit displayed in both columns is the same and if the formula only uses the addition and subtraction operators. For example, if actual costs are displayed in USD and plan costs are displayed in DEM, a unit is not displayed in the variance column.

For more information on entering formulas, see Formulas [Seite 686].
Symbolic Names in the Report Writer

A **symbolic name** can represent the row or column coordinate for a single cell or a range of cells within a report. The system uses cells to determine locations within the column-row matrix of a report. For more information, see Defining Cells (Seite 864).

Symbolic names are defined within sets. You can assign symbolic names to:

- **Set lines**
  
  Set line symbolic names refer to a value or a set name in a set line. For basic, data, and single-dimension sets, you define set line symbolic names using the Symbolic Name field on the Create and Change Set: Basic Entries screens.

  Set line symbolic names can also be used in multi-dimension sets, for example, for set variables that have been entered directly into a multi-dimension set. You enter symbolic names for set lines under Create Set: Basic Entries and Change Set: Basic Entries. This way you can address the highest row total in cell calculations.

  The symbolic name that you assign to a set line in a multi-dimension set does **not** overwrite existing header symbolic names, which have been defined in the set entered in the multi-dimension set. Instead, two symbolic names exist for the set line and the set header.

- **An entire set**

  Set header symbolic names refer to all values within a set. For basic, data, and single-dimension sets, you define symbolic names for the entire set using the Symbolic Name field on the Create and Change Set: Header screens.
Setting Format Groups in Sets

In sets, you can specify format groups. A format group represents a version of layout parameters for a report. You can specify format groups in:

- Set rows of basic, data, single-dimension, and multi-dimension sets
- The set header of basic and single-dimension sets to represent the set total

The format groups instruct the Report Writer which format to use for the set total represented by the set header or the data in the set rows. Report rows and columns corresponding to these set totals and set rows are then formatted according to the layout parameters for the specified format group.

The report portrayed in using set formulas in Report Writer [Seite 906] uses the column block TD-ACT-PLN-V and lists the following columns:

- Plan data in local currency (HSL-1)
- Actual data in local currency (HSL-0)
- Variance (difference between plan and actual data in local currency)

By assigning a different format group to set row 003 (the variance column) in data set TD-ACT-PLN-V, you can change the layout of this column, such as the column width and number of decimal places.

You can specify a format group for:

- **Basic and single-dimension sets**
  - You enter a format group in the format group field on the Create and Change Set: Basic Entries screens to represent the individual set rows.
  - You enter a format group in the format group field on the Create and Change Set: Header screens.

  Format groups entered in the set header represent the total level in the set. In set hierarchies, the format group entered in the set header is only used for the highest total in the row or column block. For all other report rows and columns, the format group entered in the set row is used.

- **Data sets**
  You enter a format group in the format group field on the Create and Change Set: Basic Entries screens to represent the individual set rows.

- **Multi-dimension sets**
  You enter a format group for a set row in the format group field on the Create and Change Set: Basic Entries screen. You can use the format groups, for example, for set variables that have been entered directly into a multi-dimension set.

The value you enter in the format group fields instructs the Report Writer to select a specific format group value listed in the report parameters for the set row or set header for which you enter the format group.
The format groups refer to certain parameters that are displayed on the Create Report: Layout or Create Standard Layout screens. Each of the fields listed below is made up of six input fields; each of these six input fields stands for one of the six format group 0 through 5. The Report Writer selects the corresponding format information according to the value you entered for the format group.

On the Create Report: Column Totals screen, the format group applies to the following parameter fields affecting column format:

- Column width
- Right margin

On the Create Report: Layout: Representation screen, the format group applies to the following parameter fields affecting numeric format:

- Decimal places
- Scaling
- Change +/- sign
- Print unit

To enter the format groups, from the Create Report: Layout: Column Totals and Create Report: Layout: Representation screens, choose the function Variants. A dialog box appears with additional entry fields for the format groups 1 to 5.

For a basic set row value, enter in the format group field the format group 1. When you use this set in a report, the Report Writer looks to the second input field of the parameter for the format it should use in the report.

The format group values for the number of decimal places, scaling, column width, currency/quantity width, and the right margin are only valid for columns. This means that the format group value you enter in a set (for these fields) is only valid if the set is used in a column.

You can find more information on creating sets under creating sets [Seite 651].
Report Writer Utilities

Use

Report Writer utilities provide you with different functions, which you can use on a report level to make more specifications to your Report Writer report [Seite 804] and on a report group level to transport and generate report groups [Seite 937] and their variants.

Activities

Report Writer Reports

- For an overview of existing reporting objects, choose Report Writer → Report → Utilities → Catalog. For more information, see Listing Report Writer Objects [Seite 914].
- For layout control, during editing of a Report Writer report choose from the initial screen Utilities → Layout control. For more information, see Displaying Report Layouts [Seite 1030] and Defining Report Layouts [Seite 1031].
- To transport Report Writer objects, first choose Utilities → Transport and then, as appropriate:
  - to export to external files → Export For more information, see Exporting Report Writer Objects [Seite 916].
  - To import from external files → Import For more information, see Importing Report Writer Objects [Seite 918].
  - To copy a report from a different client → Copy from client For more information, see Copying Report Writer Objects from Other Clients [Seite 919].
  - For a transport request → Transport request For more information, see Transporting Report Writer Objects [Seite 921].
- To list the report definition, choose Utilities → List definition. For more information, see Listing a Report Definition [Seite 923].

Report Groups

- For an overview of existing report groups, choose Report Writer → Report group → Utilities → Catalog. For more information, see Listing Report Writer Objects [Seite 914].
- Use the mass generator to generate as many report groups as you require. Choose Report Writer → Report group → Utilities → Mass generator. For more information, see Generating Report Groups (Mass Generator) [Seite 954].
- To display, delete or print and to change the expiry date of extracts [Extern], choose Report Writer → Report group → Utilities → Extracts → Display/Delete/Print/Change expiry date. For more information, see Extracts [Seite 1008].
- To delete generated program includes that are no longer used, choose Report Writer → Report group → Utilities → Delete programs. For more information, see Deleting Generated Code for Report Groups [Seite 957].
- To maintain variants, choose Report Writer → Report group → Utilities → Variant maintenance. For more information, see Creating Report Group Variants [Seite 958].
Exporting and Importing Report Group Variants [Seite 960] and Copying Report Group Variants from Other Clients [Seite 961].

- To schedule report groups as a background job, choose Report Writer → Report group → Utilities → Background job. For more information, see Scheduling a Report Group as a Background Job [Seite 956].

- To transport report groups, choose Report Writer → Report group → Utilities → Transport. The procedure is the same as described above for Report Writer reports.
Listing Report Writer Objects


   If you want to display a list of defined reports, you choose Utilities → Catalog. The

2. Enter data as required.
   The data you enter determines the objects that are selected for display.

3. Choose Program → Execute.
   A list of objects meeting the criteria you entered on the previous screen appears.
   From the report and report group catalog, you can change, display, delete, and execute
   the selected report(s) and report group(s) using the respective functions under the Goto
   menu option.

   The report group catalog also provides statistics on the number of data selections made
   for each report group, together with the name of the user who last selected data for the
   report group.
Transport of Report Writer Objects

Use

When processing Report Writer reports you can use the function Utilities → Transport to export, import, copy from other clients or add to a transport request Report Writer objects, such as libraries [Seite 927], reports, report groups [Seite 937] and standard layouts [Seite 1017].

Features

With the functions under Utilities → Transport, you have the following possibilities:

- The Export function allows you to export Report Writer objects (such as libraries, reports, report groups, and standard layouts) from an SAP R/3 System to an external file. For more information, see exporting Report Writer objects [Seite 916].

- The Import function to allows you to import Report Writer objects (such as libraries, reports, report groups, and standard layouts) from an external file to an SAP R/3 System. For more information, see importing Report Writer objects [Seite 918].

- The Copy from client function allows you to copy Report Writer objects between different clients within an SAP R/3 System.

  Several SAP R/3 application components deliver example Report Writer objects, such as libraries, reports, report groups, and standard layouts (stored in client 000). You can use the Copy from client function to copy these objects from client 000 (or another client) to the client in which you are working.

  For more information, see copying Report Writer objects from other clients [Seite 919].

- The function Transport request allows you to copy Customizing settings for standard layouts, libraries, reports, Report Writer report groups, report groups variants, key figures and Report Painter models in a transport request. For more information, see transporting Report Writer objects [Seite 921].

For more information on processing Report Writer reports, see functions in the report output [Seite 974].
Exporting Report Writer Objects


   ![Image]

   If you want to export reports, you choose Utilities → Transport → Export on any
   then appears.

2. Enter the selection criteria as required.
   The data you enter determines the data that is selected for export.

3. Set the indicators in the Further details group box, as required:
   - Indicator that determines if the objects are exported directly.
     In this case, you do not select the objects to be exported from an object list.
   - Indicator that determines if all dependent objects are transported.
     For example, if you are exporting reports and select With dependent objects, the
     system exports all reports and the objects defined for the reports (sets, variables,
     formulas, libraries, and standard layouts).
     This indicator does not appear if you are exporting standard layouts.

   ![Image]

   CO groups (such as cost center groups, cost element groups, profit center groups,
   and so on) are no longer exported as dependent objects. This prevents CO groups
   being overwritten unintentionally in the target client. If you want to copy CO groups to
   another client, you do so in a separate step using the set or hierarchy maintenance
   functions.

   The following table shows the dependent objects that are exported for a specific Report
   Writer object.

<table>
<thead>
<tr>
<th>If the Report Writer object is a</th>
<th>Then the following dependent objects are exported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library</td>
<td>Default selection sets (except CO groups)</td>
</tr>
<tr>
<td>Report</td>
<td>Sets (except CO groups), key figures, libraries, standard layouts</td>
</tr>
<tr>
<td>Report group</td>
<td>Reports, sets (except CO groups), key figures, libraries, standard layouts</td>
</tr>
</tbody>
</table>

   - Indicator that determines if the objects are exported to a presentation server (for
     example, a PC).
     If you do not set this indicator, the objects are exported to an application server.
You cannot export objects to the presentation server in background processing. You must export objects to the presentation server online.

- Export file to which you want to export the objects.
  
  If the file does not exist, the system creates it; if the file exists, the system overwrites the existing file.

  For a UNIX operating system, the file name consists of a path and a name, such as /TEMP/EXPORT.

  For a Windows operating system, the file name consists of a drive, a path, and a name, such as C:\DATA\EXPORT.

4. Choose Program → Execute.

   The reports are exported to the file you specified in the Export file field.

   If you did not select Without selection list, a selection screen of Report Writer objects appears:

   a. Select the Report Writer objects that you want to export.

   b. Choose Execute.
Importing Report Writer Objects


2. Enter the following data:
   - Indicator that determines if the objects are imported from a presentation server (for example, a PC).
     If you do not set this indicator, the objects are imported from an application server.
     You cannot import objects from the presentation server in background processing.
     You must import objects from the presentation server online.
   - Name of the file from which you want to import the objects.

   
   When you import objects from an external file, the system overwrites existing objects without warning.

3. Choose Program → Execute.
   The objects are imported from the file you specified in the Export file field.
Copy copies Report Writer Objects from Other Clients

Prerequisites

You can only use this function if you are copying Report Writer objects from/to clients that exist in the same system. If the Report Writer objects you want to copy are stored in a different system than the one to which you want to copy, you must use the Utilities → Transport → Import and Export functions.

When you copy Report Writer objects to the client in which you are working, the system overwrites existing objects without warning.

Procedure


   The Report Writer: Copy <Object> from Source Client screen appears.

2. Enter the source client and the selection criteria as required.

   The data you enter determines the data that is copied from the source client to the client in which you are working.

3. Set the indicators in the Further details group box, as required:

   – If you select Copy without selection list, the objects are copied directly to the client in which you are working.

      In this case, you do not select the objects to be copied from an object list.

   – If you select Copy with dependent objects, the Report Writer objects are copied with all their dependent objects.

      For example, if you are exporting reports and select Copy with dependent objects, the system exports all reports and the objects defined for the reports (sets, variables, formulas, libraries, and standard layouts).

      This field does not appear if you are copying standard layouts to another client.

      Refer to the table in Exporting Report Writer Objects [Seite 916] to determine dependent objects that are copied for a Report Writer object.

4. Choose Program → Execute.

   If you selected Copy without selection list, the system automatically copies the Report Writer objects from the source client to the client in which you are working, according to the criteria you entered on the Report Writer: Copy <Object> from Source Client screen.
Copying Report Writer Objects from Other Clients

If you did not select Copy without selection list, the system lists all objects from the source client that meet the criteria you entered on the Report Writer. Copy <Object> from Source Client screen:

a) Select each object that you want to copy.

b) Choose <Object> → Copy.

The system copies the Report Writer objects to the client in which you are working.
Transferring Report Writer Objects

Use
You can copy the Customizing settings for the following to a transport request using the function "Transport request":

- Standard layouts
- Libraries
- Reports
- Report Writer report groups
- Report group variants
- Key figures
- Report Painter models

Procedure
1. From one of the Report Writer screens, choose Utilities → Transport → Transport request. The Transport: Report Writer screen appears:
2. Select the object for which you want to include the Customizing settings in the transport request and choose Execute.
3. The Report Writer: Include <Object Name> in Transport Request screen appears. Enter the selection criteria as required.
4. In the group box Further details, depending on the object you selected, you can select at least one and at the most three of the following settings.
   - If you want to execute the request for all the selected objects directly, select the Without selection list indicator. This makes particularly good sense for batch processing. If you do not select this indicator the system displays a list of all the selected objects and you can choose the object you want to transport.
   - Indicator that determines if all dependent objects are transported.

   ![Icon]

   If you transport a report and select the With dependent objects indicator, the system includes the report and all the objects defined for the report (sets, variables, formulas, libraries and standard layouts) in the transport request.

   - For report groups, you can specify whether you also want to transport the variants.

The following table shows the dependent objects that are transported for a specific Report Writer object.

<table>
<thead>
<tr>
<th>If the Report Writer object is</th>
<th>Then the following dependent objects are transported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Libraries</td>
<td>Default selection sets (except CO groups)</td>
</tr>
</tbody>
</table>
### Transporting Report Writer Objects

<table>
<thead>
<tr>
<th>Reports</th>
<th>Sets (except CO groups), key figures, libraries, standard layouts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report group</td>
<td>Reports, sets (except CO groups), key figures, libraries, standard layouts</td>
</tr>
</tbody>
</table>

5. Choose *Program → Execute.*

   If you did not select *Without selection list*, a selection screen of Report Writer objects appears:

   a. Select the Report Writer objects that you want to transport.
   b. Choose *Execute*.

   The objects are included in your chosen Customizing request.
Listing a Report Definition

2. Enter the library and name of the report that you want to display.
3. If you want to display the report texts (title page, header, footer, last page, and text for export), select List texts.
4. If you want to display the graphics of the sets used in the report, select Set graphics.
5. Choose Program → Execute.
   The List Report Definition: <Report Name> screen appears, displaying a complete definition of the report you entered on the previous screen.
   You can print the complete report definition using the Print function.
Defining Reports for the Report/Report Interface

Use

The report/report interface allows you to call reports from other R/3 application components when you output your report data. You can call up report portfolio reports, drilldown reports, transactions, receiver reports, Report Writer reports, Report Painter reports, and ABAP programs.

If you define reports for the report/report interface in both the report group header and in the report group's library, the system uses the reports that you have defined specifically for the report group.

Example

Your system is delivered with an ABAP program called RGGD1300, which displays line items for the FI-SL summary tables. The program reads the data from the FI-SL line item table and outputs a list of the line items.

You can call up program RGGD1300 directly (System → Services → Reporting) or from the report/report interface if it is defined as a receiver report for another Report Writer report. In a report that displays totals, you can then display the line items for a specific totals record.

To call program RGGD1300 as a receiver report to display line items for totals data in a report:

Procedure for Example


5. The group box Report/report interface contains information on the current assignment of the reports in this report group to the library of the report group. To assign a report to the report group, choose Configure.... The Assign Reports dialog box appears.

6. To enter a receiver report for the report/report interface, choose Insert row.


5. To enter program RGGD1300 as the receiver report, choose Other Report Type.

   A dialog box appears, listing the possible report types.

   The receiver reports you assign can be report portfolio reports, drilldown reports, transactions, Report Writer reports, and ABAP programs. This enables you to call receiver reports from other R/3 application components once you have output your report data.
You should normally assign receiver reports to the report group.

In this example, we are using the ABAP program RGGD1300 as the receiver report.


10. Enter RGGD1300 as the receiver report and choose 🔄.

The default text of program RGGD1300 is displayed in the Assign Reports dialog box.

11. You can use the following additional processing functions in this dialog box:

### Additional Processing Functions - Dialog Box for Report/Report Interface

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save receiver report for report/report interface</td>
<td>![Save]</td>
</tr>
<tr>
<td>Add receiver report to report/report interface definition</td>
<td>![Insert row]</td>
</tr>
<tr>
<td>Delete entry in report/report interface definition</td>
<td>![Delete row]</td>
</tr>
<tr>
<td>Insert report from another system (cross-system report assignment)</td>
<td>![Add external report]</td>
</tr>
<tr>
<td>You log on to the other system, select a receiver report, and transfer it to the sender system.</td>
<td></td>
</tr>
<tr>
<td>Select one or more receiver reports for further processing (for example, to move the selected report to another position in the list)</td>
<td>![Select line]</td>
</tr>
<tr>
<td>Move selected receiver report to another position in the list. If the cursor is positioned on a receiver report, the selected report is inserted before this receiver report. If the cursor is not positioned on a receiver report, the selected report is inserted at the end of the list.</td>
<td>![Move]</td>
</tr>
<tr>
<td>Display default text of a receiver report if you have previously overwritten the default text of the report. Note: when you first enter a receiver report, the default text for this report is automatically displayed.</td>
<td>![Default text]</td>
</tr>
<tr>
<td>Display all reports to which the specified sender report is assigned as the receiver report. If you activate this function again, the original list is displayed.</td>
<td>![Sender &lt;-&gt; Receiver]</td>
</tr>
<tr>
<td>Display technical information on the receiver report(s) (for example, the report tool and the technical report name)</td>
<td>![Technical names on/off]</td>
</tr>
<tr>
<td>Documentation on displaying and maintaining the report assignment in the report/report interface</td>
<td>![Help]</td>
</tr>
</tbody>
</table>

12. Choose 🔄 to save your entries.

**Example**

The Report Writer uses ABAP program RGGD1300 as shown in the following graphic:
The report in the graphic displays accounts by periods. This report is assigned to report group TD00. Report group TD00 has been defined such that ABAP program RGGD1300 is a receiver report in the report group (on the Create Report Group: Header screen).

Program RGGD1300 is called up with the Report Writer as follows:

f) After selecting the report data for the report, the system displays the report.
   You can select part of the displayed report and have the system display the associated line items.

g) Select amount 600 for account 4000020 in period 1 from the report.

h) When you choose Reports, the system generates a list of the reports that are defined as receiver reports in report group TD00 (Create Report Group: Header screen).

i) Select program RGGD1300.

j) The Report Writer adopts the selection criteria from the report (such as the company code, ledger, account, and period) and starts the ABAP program RGGD1300. This program displays the line items that meet the selection criteria (company code TD11, ledger D2, account 4000020, period 1).

For more information on calling receiver reports, see Functions in the Report Output [Seite 974].
Libraries

Definition

All reports are in libraries. A library is a collection of characteristics, basic key figures, and key figures that have been selected from the entries of a Report Writer table.

- A characteristic (called a field or dimension in previous releases) is a nonnumeric field. Examples of characteristics are account, cost center, and business area.
- A basic key figure (key figure in previous releases) is a numerical value field. Examples of basic key figures: local currency, total costs, and activity quantity.
- A key figure consists of a basic key figure and one or more characteristics. Using predefined columns, you can define standard columns that you can then use in your reports repeatedly. Examples of key figures: actual costs in current year, plan costs in closed year.

The reports contained in the library can only use the characteristics, basic key figures, and key figures defined for this specific library.

If report X is assigned to library ABC, you can only use characteristics in that report that are contained in library ABC. This applies to all the reports in library ABC, not just to report X.

Use

The transfer structure for transfer to the Report Painter [Seite 726] or Report Writer [Seite 797] is a reporting table. This reporting table is predefined in the SAP R/3 System and cannot be changed. The reporting table is a logical view of different database tables and contains all characteristics, basic key figure, and key figures.

In Cost Center Accounting, the transfer structure is reporting table CCSS.

You have the following options when working with libraries:

- You can separate development reports from production reports.
- You can subdivide your reports by user group.
- You can assign user authorizations for each library.

When you create a library, you decide which characteristics, basic key figures, and key figures you want to include in the library. To do this, you can either copy an existing library or enter a table (such as GLT1) and select the required characteristics, basic key figures, and key figures from this table.

You can also define standard selection sets for reports in a library. These standard selection sets are automatically displayed when you define a report that uses the library concerned.
If you want all reports in a library to use the set UN-LEDGER (containing the value AB for the ledger) when the report data is selected, you can use the set UN-LEDGER as a default set for the characteristic Ledger. When you define a report that is assigned to the library concerned, the set UN-LEDGER appears in the report definition as the selection set. You can, however, overwrite this set.

You can also assign user authorizations for your libraries.

For example, you can specify that only a certain user group shall have access to the reports from a particular library.

For more information on libraries, see:

- Creating a Library [Seite 929]
- Defining Reports for the Report/Report Interface [Seite 924]
- Displaying a Library [Seite 934]
- Changing a Library [Seite 935]
- Deleting a Library [Seite 936]
Creating a Library


Create Library: Initial Screen appears.

2. Enter the following information:
   – Name of the library
   – Table name for the library

   This table contains the data you want to use in your report. You only need to enter a table in this field if you do not want to copy an existing table.

3. If you want to create a library by copying an existing library, enter the name of the library that you want to copy in the Copy from - Library field.

4. Choose Header.

   The screen Create Library: Header appears.

Entering Header Information

1. Enter the following information:
   – Description of the library
   – Authorization group for the library (if required)

   This authorization group is defined in the user’s profile.

   ![Information](image)

   You can define an authorization group called COST. If you assign this authorization group to a report library, only users with this authorization group can use the reports in the library.

2. In the Report/report interface group box, choose Configure to define receiver reports that you want to call up when you output your report data.

   The receiver reports you assign here are valid for all the reports that use this library. You can also assign reports for the report/report interface in the header of a report group. If you assign receiver reports in both the header of the library and the header of the report group, the system uses the reports you assigned to the report group.

   The receiver reports you assign can be report portfolio reports, drilldown reports, transactions, Report Writer reports, Report Painter reports, and ABAP programs.

   ![Information](image)

   You must save the library before you can enter receiver reports for the report/report interface.

   For more information, see Defining Reports for the Report/Report Interface [Seite 924].

3. You can use the following additional functions in this screen:

   Additional Functions (Create Library: Header Screen)
Creating a Library

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Characteristics</td>
<td>Add characteristics</td>
</tr>
<tr>
<td>Goto → Basic key figures</td>
<td>Add key figures</td>
</tr>
<tr>
<td>Goto → Key figures</td>
<td>Add key figures</td>
</tr>
<tr>
<td>Extras → Use…</td>
<td>Display list of reports and report groups that use the library</td>
</tr>
<tr>
<td>Utilities → Catalog…</td>
<td>Display list of libraries</td>
</tr>
<tr>
<td>Utilities → Transport → Export</td>
<td>Transport libraries to an external file</td>
</tr>
<tr>
<td>Utilities → Transport → Import</td>
<td>Import libraries from an external file</td>
</tr>
</tbody>
</table>

4. To save the library, choose Library → Save.

Adding Characteristics

The characteristics you assign to the library determine the characteristics you can use in the reports contained in the library. The system automatically adds the characteristics to the library that are needed in any case.

To add characteristics to a library:

1. From the Create Library: Header screen, choose Goto → Characteristics.
   The screen Create Library: Characteristics appears.

2. Select the characteristics you want to add to the library.
   If a characteristic is already selected, this means that it was selected by the system automatically.
   To remove a characteristic from the library, deselect the characteristic. You cannot deselect the characteristics that are selected by the system automatically.

3. Enter the following information:
   – If required, enter a standard selection set for the characteristic.
     If all or most of the reports contained in the library use the same set as the selection set, you should enter this as the standard selection set. This standard selection set is then displayed when you create a report assigned to this library.

        ![Standard selection set](image)

        You enter the standard selection set UN-LEDGER (with the value AB) for the characteristic Ledger. When you create a report with this library, the set UN-LEDGER is displayed on the Create Report: General Data Selection screen.

        When you create a report, you can change or delete the standard selection set.

        ![Standard selection set](image)

        If you delete a standard selection set from the report definition, this set is not automatically deleted from the library concerned. If you want to also delete the selection set from the library, go to the Change Library: Characteristics screen and
delete the set from that screen. The reverse also applies: If you want to change the name of a standard selection set in a library, the set name in the reports assigned to the library are not automatically changed at the same time – you must also change the set name in each of the affected reports assigned to the library. There is no association between the set name you enter in a library and the value you enter in the report.

– Enter a consecutive number; this defines the order in which the characteristics defined in the library appear in the Report Painter selection lists.

This allows you to position the characteristics that you use regularly in your reports at the beginning of the selection lists.

In the following table are example entries entered in the Pos field for certain library characteristics.

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Pos field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ledger</td>
<td>1</td>
</tr>
<tr>
<td>Company code</td>
<td>2</td>
</tr>
<tr>
<td>Fiscal year</td>
<td>3</td>
</tr>
<tr>
<td>Period</td>
<td>4</td>
</tr>
<tr>
<td>Account</td>
<td>5</td>
</tr>
</tbody>
</table>

If you create a report using the Report Painter, the characteristics will appear in the selection list in the following order: Ledger, followed by Company code, then Fiscal year, Period, and Account.

4. On this screen you can use the additional functions in the table for the Create Library: Header screen (see Entering Header Information), as well as the functions in the following table.

**Additional Functions (Create Library: Characteristics Screen)**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Select all</td>
<td>Select all the characteristics for the library</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all selected items</td>
</tr>
<tr>
<td>Edit → Display set</td>
<td>Display standard default set for a characteristic</td>
</tr>
</tbody>
</table>

5. To save the information entered, choose Library → Save.

**Adding Basic Key Figures**

When you define a library, you can also define the data types that can be used in the reports contained in the library.
Creating a Library

If you only want to create reports that use transaction currency, you can define your library so that the reports contained in the library can only use transaction currency.

To add basic key figures to a library:

1. On the Create Library screen, choose the pushbutton Basic key figures.
   The Create Library: Basic Key Figures screen appears. All basic key figures are automatically assigned to the library.

2. Deselect the basic key figures that you do not want to add to the library.
   If you want to reassign certain basic key figures to the library, you have to reselect the relevant key figures.

3. Enter a consecutive number. This number determines the order in which the basic key figures defined in the library appear in the Report Painter selection lists.
   This allows you to position basic key figures that you use regularly in your reports at the beginning of the selection lists.

4. On this screen, you can use the additional functions in the table for the Create Report: Header screen as well as the functions in the following table.

   **Additional Functions (Create Library: Basic Key Figures Screen)**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Select all</td>
<td>Select all key figures</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all selections</td>
</tr>
</tbody>
</table>

5. To save the basic key figure information, choose Library → Save.

Adding Key Figures

You can use the key figures you define for a library in the column definition of the reports contained in the library. Key figures are made up of a basic key figure and selection criteria for one or more characteristics.

If you only want to create reports that use transaction currency, you can define your library so that the reports contained in the library can only use transaction currency.

To add key figures to a library:

1. On the Create Library screen, choose the pushbutton Key figures.
   The Create Library: Key Figures screen appears. All key figures are automatically assigned to the library.

2. Deselect the key figures that you do not want to add to the library.
   If you want to reassign certain key figures to the library, you must reselect the relevant key figures.
3. Enter a consecutive number. This number determines the order in which the key figures defined in the library appear in the Report Painter selection lists.

This allows you to position key figures that you use regularly in your reports at the beginning of the selection lists.

4. On this screen, you can use the additional functions in the table for the Create Report: Header screen as well as the functions in the following table.

### Additional Functions (Create Library: Key Figures Screen)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Select all</td>
<td>Select all key figures</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all selections</td>
</tr>
<tr>
<td>Edit → Display definition</td>
<td>Display detailed information for the key figure, such as the basic key figure and the additional set used in the key figure</td>
</tr>
</tbody>
</table>

5. To save the key figure information, choose Library → Save.

You can create your own key figures. For more information, see Creating/Changing Key Figures [Seite 712].
Displaying a Library Definition

   The Display Library: Initial Screen appears.

2. In the Library field, enter the name of the library that you want to display and choose Header.

3. On this screen, you can use the additional processing functions in the table for the Create Library: Header screen in Creating a Library [Seite 929], as well as the Extras → History function to display the revision history of the library.
Changing a Library

   The Change Library: Initial Screen appears.

2. In the Library field, enter the name of the library that you want to change and choose Header.

3. On this screen, you can use the additional processing functions in the table for the Create Library: Header screen in Creating a Library [Seite 929], as well as the Extras → History function to display the revision history of the library.

4. Type over existing values with your changes.

   If you delete existing library characteristics, basic key figures, or key figures, an error will occur during the next generation of any reports in this library that still use the deleted characteristics, basic key figures, and/or key figures.

   Also, if you change and/or add a default selection set for a characteristic, the default selection set will only appear when you create future reports; the default selection set will not appear for reports that were defined before you changed or added the default selection set.

5. To save the changes to the library, choose Library → Save.
Deleting a Library

You cannot restore a library once it has been deleted.

Procedure


   The Delete Library: Initial Screen appears.

2. In the Library field, enter the name of the library that you want to delete.

3. Choose Delete.

   A dialog box appears, asking you if you want to delete the library.

   You cannot delete a library that is being used by a report. To see if a library is being used by a report, choose Extras → Use on any library screen.

4. To delete the library, choose Yes.

Result

The system deletes the library.
Report Groups

Use

Before you can output reports, they must be assigned to a report group. With a report group, you can group together reports from one library [Extern] that use similar data but present it in different forms. The database selections from all the reports in a report group are collated, thus avoiding the necessity multiple selections. This improves processing times.

It is appropriate to assign reports to a report group when the reports evaluate essentially the same data. This is because the data is only read once and then distributed to the individual reports.
Integration

In order to output a report, you must have assigned it to a report group. Reports that contain the same characteristics and access the same data are contained in one report group. This speeds up processing because the report data is only selected once for all reports and not for each.
report individually. Once the report group has been generated the data is selected from the database and can be output.

Prerequisites
To process reports in a report group, they must be assigned to the same library.

Features
Once you have created a report you have to create a report group for this report or assign the report to an existing report group. A report group can contain one or more reports. When reports use the same characteristics and share the same data, data is selected faster and processing time is quicker since report data is only selected once for all reports within a report group.

The reports in a report group are executed at the same time, so that in the report display you can switch between the individual reports.

The report group name has four characters. As a rule the report group name matches the first four characters of the reports assigned to it. The characters are limited to letters from A to Z, numbers from 0 to 9, and two special characters (- and _).

A number of ABAP programs are generated when a report group is created:
- Program for processing the initial screen
- Program for selecting (reading) the data
- Program to output the selected data
- Program for multiple selection (multiple selection and output for different input data – only if the corresponding indicator is selected)

There are four ways to determine the name of the ABAP program for your report group:
- On the selection screen, choose Environment → Technical information
- On the list output, choose Extras → Technical information
- Transaction GRPE
- Function module G_PROGRAMME_NAME

If a set definition or report definition is changed after the report group is generated, the report group will be regenerated at the time of the next selection unless this function is explicitly switched off in the report group definition.

Activities
To create a report group, proceed as follows:
Activities

1. **Create the report group.**

   Specify which reports the report group is to contain. For more information on creating a report group, see Creating a Report Group [Seite 941] and Creating a Report Group from the Report Definition [Seite 948].

   You can also change the texts that appear on the selection screen when you execute the report group. For more information, see Report Group Execution [Seite 962], Executing a Report Group [Seite 964], and Executing a Report Group in the Background [Seite 969].

2. **Generate the report group.**

   For more information on generating a report group, see Generating a Report Group [Seite 952] and Generating Report Groups (Mass Generator) [Seite 954]. The report group was generated successfully if there are no errors in the report group.

3. **Select the data for the report group.**

   The system selects the data that appears in the reports defined in the report group.

4. **Display or print the reports in the report group.**

   The system edits and formats the data that has been selected for the report group and then presents the report group’s reports in the output medium requested (online, printer, spool file, external file, and so on). For more information on displaying a report group, see Displaying a Report Group [Seite 949]. For information on printing, see Functions in the Report Output [Seite 974].

   If you want to display a new report, you must add the report to an existing report group or create a new report group that contains the report.

   If you output a report that has been changed, you only need to regenerate the report group and select and display report data. The report group does not need to be redefined.

   Suppose you change the set used as a row block in report TD-ASSETS. You must regenerate the report group, select the report data, and display the report. You do not need to change the report or the report group.

For more information on working with report groups and reports, see:

- Changing a Report Group [Seite 950]
- Deleting a Report Group [Seite 951]
- Varying Report Data [Seite 970]
- Extracts [Seite 1008]
Creating a Report Group

Use
A report group is a collection of reports from one library [Extern] that are to be output together. You use a report group to collate reports that are similar in order to improve performance.

Before you can output reports, you must have assigned them to a report group. You can either assign a report to an existing report group or create a new report group for it. For more information on report groups, see Report Groups [Seite 937].

To create a report group you can either proceed as described below or create the report group from the report definition. For more information, see Creating a Report Group from the Report Definition [Seite 948].

Procedure


2. Enter a name for the report group. The name must have four characters. You can create a report group in either of the following ways:
   - Copy an existing report group
     Enter the name of the existing report group that you want to copy in the Copy from - Report group field. When the report group is copied, the library assigned to it is copied automatically as well.
   
   or

   - Create a new report group based on a library
     Enter the name of the library of the reports you want to include in the report group in the New entry - Library field. All reports in a report group must be in the same library.

3. Enter header information for the report group. To do this, choose Goto → Header. The Create Report Group: Header screen appears. For more information about entering header information, see Entering Header Information for a Report Group [Seite 943].

4. If you want to enter detailed documentation for the report group, choose Goto → Documentation. This procedure is the same as the one used to define report documentation. For more information, see Defining Report Documentation [Seite 945].

5. To add reports to the report group, choose Goto → Reports from one of the Create Report Group screens. The Create Report Group: Reports screen appears. For more information on entering reports, see Adding Reports to a Report Group [Seite 946].

Creating a Report Group

7. To save your entries, choose Report group → Save. You can now execute the report group. For more information, see Report Group Execution [Seite 962], Executing a Report Group [Seite 964], and Executing a Report Group in the Background [Seite 969].
Entering Header Information for a Report Group

Use

A report group contains reports from one library that use similar data and present this data in different ways. The header information of a report group contains information that is valid for the report group as a whole (such as setting or suppressing the indicator for the regeneration of the report group and the configuration of the report/report interface).

If you define reports for the report/report interface in both the report group header and in the report group’s library, the system uses the reports that you have defined specifically for the report group.

Prerequisites

You have reached step 3 of the procedure Creating a Report Group [Seite 941]. On the Create Report Group screen you have already chosen Goto → Header and are on the screen Create Report Group: Header.

Procedure

1. Enter a short description for the report group. If you have copied an existing report group, the description of this report group is displayed here automatically. You can, however, change it.

2. In the group box Generation, you should only select the Not automatic indicator if you do not want the system to display a dialog box asking whether you want to regenerate the report group when a report definition or report sets have been changed.

If you select this indicator, when you call the report group only a warning message will appear telling you that this is not an up-to-date generated report group. Until the report group is regenerated, you can only call it with the definitions valid at the time of the last generation.

Report groups are regenerated automatically after importing Support Packages, after an upgrade or after a release upgrade, even if you have set the Not automatic indicator. The system also automatically regenerates report groups if the programs generated, or the stored definitions and sets, have been deleted.

4. If you want user authorization to be required for creating, displaying, maintaining, and executing the report group, enter the name of an authorization group in this field.

5. In the Report/report interface group box, choose Configure to define receiver reports that you want to call up when you output your report data.

You can define reports for the report/report interface in both the report group header and in the report group’s library. The reports you enter in the library are valid for all reports that use the same library. If you define reports for the report/report interface in both the report group header and in the report group’s library, the system uses the reports that you have defined specifically for the report group.
Entering Header Information for a Report Group

The reports you enter as the receiver reports can be Report Writer reports, Report Painter reports, ABAP programs, report portfolio reports, drilldown reports, or transactions.

For more information about defining reports for the report/report interface, see Defining Reports for the Report/Report Interface [Seite 924].

You must save your report group definition before you can enter receiver reports for the report/report interface.

You can use the following processing functions on the Create Report Group: Header screen:

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter reports for the report group</td>
<td>Goto → Reports</td>
</tr>
<tr>
<td>Enter text for the selection screens</td>
<td>Goto → Texts</td>
</tr>
<tr>
<td>View revision history of report group</td>
<td>Extras → History...</td>
</tr>
<tr>
<td>For utilities, see Report Writer Utilities [Seite 912]</td>
<td>Utilities</td>
</tr>
</tbody>
</table>

6. To save the report group, choose Report group → Save.

Result

You have entered header information for a report group and can now continue with step 4 of the procedure for creating a report group [Seite 941].
Defining Report Documentation

   

5. Enter the report documentation as desired.
   
   For more information about the use of the SAPscript editor for word processing, see the SAP Library under Basis Components → Basis Services/Communication Interfaces (BC-SRV) → SAPscript (BC-SRV-SCR).

6. Choose Text → Save.
   
   You will now be able to display the report documentation when you output the report. The name under which the documentation is stored is also displayed.

   ![Image]
   
   The name of your report library is Z01, and your report name is Z-REPO. When you define report documentation, it is stored under the report name R_Z01_Z-REPO, where R is for report, Z01 is the library name, and Z-REPO is the report name.
Adding Reports to a Report Group

Prerequisites
You have reached step 5 of the procedure creating a report group [Seite 941] or you want to add an additional report to a report group. On the Create Report Group screen you have already chosen Goto → Reports and are on the screen Create Report Group: Reports.

Procedure
1. In the Report field, enter the name of the report that you want to add to the report group. You can enter more than one report.

   The Report Writer processes the reports in the same order that you list them. To optimize processing time, the reports that you include in a report group should have the same characteristics and use the same data.

2. To save the report group, choose Report group → Save.

   You can use the following additional processing functions on the Create Report Group: Reports screen:

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add additional reports to report group</td>
<td>Edit → New entries</td>
</tr>
<tr>
<td>Insert report between two other reports</td>
<td>Edit → Insert row</td>
</tr>
<tr>
<td>Delete report from report group</td>
<td>Edit → Delete row</td>
</tr>
<tr>
<td>Enter header information for the report group</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>Enter text for the selection screens</td>
<td>Goto → Texts</td>
</tr>
<tr>
<td>Display where a report defined for the report group is used</td>
<td>Extras → Report usage...</td>
</tr>
<tr>
<td>Change definition of report assigned to report group</td>
<td>Extras → Report definition</td>
</tr>
<tr>
<td>For utilities, see Report Writer Utilities [Seite 912]</td>
<td>Utilities</td>
</tr>
</tbody>
</table>

Result
You have added a report to a report group and can now continue with step 6 of the procedure for creating a report group [Seite 941].
Entering Selection Texts for a Report Group

Prerequisites

Procedure
1. Enter texts as required.
   The text that you enter for the fields on this screen appears on the selection screen when you execute the report group.
2. To save the report group, choose Report group → Save.
   You can use the following additional functions on the screen Create Report Group: Texts for Selection Screens:

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add additional reports to report group</td>
<td>Edit → New entries</td>
</tr>
<tr>
<td>Insert report between two other reports</td>
<td>Edit → Insert row</td>
</tr>
<tr>
<td>Delete report from report group</td>
<td>Edit → Delete row</td>
</tr>
<tr>
<td>Enter header information for the report group</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>Enter reports for the report group</td>
<td>Goto → Reports</td>
</tr>
<tr>
<td>Display where a report defined for the report group is used</td>
<td>Extras → Usage → Report usage...</td>
</tr>
<tr>
<td>Enter additional parameters for displaying selection texts (for example, to specify whether selection values should appear before selection sets)</td>
<td>Extras → Additional parameters</td>
</tr>
<tr>
<td>For utilities see Report Writer Utilities [Seite 912]</td>
<td>Utilities</td>
</tr>
</tbody>
</table>

Result
You have entered selection texts for a report group and can now continue with step 7 of the procedure for creating a report group [Seite 941].
Creating a Report Group from the Report Definition

Use
You can use this function to create a new report group without having to call the Create Report Group function. When you create, change, or display a report definition, you can execute the report’s report group directly and output the report.

Prerequisites
You want to create, change, or display a report. You have called one of the functions Create/Change/Display Report and have saved your report.

Procedure
1. Choose Report → Execute. If the report is not already assigned to a report group, a dialog box appears asking whether you want to perform this assignment.
2. To assign the report to a report group, choose Yes.
3. If you enter a report group that does not exist, a dialog box appears asking whether you want to create the report group.
4. If you want the system to create the report group automatically and assign your report to it, choose Yes.
5. You can then execute the report group on the screen Execute Report Group: Initial Screen. For more information, see Report Group Execution [Seite 962], Executing a Report Group [Seite 964] and Executing a Report Group in the Background [Seite 969].

For more information on creating report groups, see Creating a Report Group [Seite 941].
Displaying a Report Group


2. Enter the name of the report group you want to display. You can use the following processing functions on the Display Report Group: Initial Screen:

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display header information for the report group</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>Display reports of the report group</td>
<td>Goto → Reports</td>
</tr>
<tr>
<td>Display texts for the selection screens</td>
<td>Goto → Texts</td>
</tr>
<tr>
<td>Display report group documentation. See defining report documentation [Seite 945]</td>
<td>Goto → Documentation</td>
</tr>
<tr>
<td>Display report group directory</td>
<td>Utilities → Catalog</td>
</tr>
<tr>
<td>Generate report group. See generating report groups [Seite 954]</td>
<td>Utilities → Mass generator</td>
</tr>
</tbody>
</table>
Changing a Report Group

Prerequisites
If you change a report definition and/or the sets used in the report, you do not have to change the report groups that contain the report. You must, however, regenerate the report group that contains the changed reports.

Procedure
2. Enter the name of the report group you want to change and choose Header.
3. Type over existing values with your changes.
   For more information about the functions you can use on the Change Report Group screens, see the tables in creating a report group [Seite 941].
4. To save the report group, choose Report group → Save.

Displaying Selection Statistics for a Report Group
You can display statistics on the number of data selections made for a particular report group. This allows you to determine which reports are often or seldom used in a productive system.

To display the selection statistics for a report group:
Choose Extras → History.

The Report Group: History dialog box appears, displaying the revision history of the report group, as well as the name of the user who made the last data selection and the number of times that data has already been selected for the report group.

You can reset the data selection counter to zero by choosing Reset.

You can also display data selection statistics in the report output (Edit → Selection log) and in the report group directory (Utilities → Catalog).
Deleting a Report Group

You cannot restore a report group once it has been deleted.


2. Enter the name of the report group that you want to delete.

3. Choose Delete. A dialog box appears, asking you if you want to delete the report group.

4. To delete the report group, choose Yes. The system deletes the report group.
Generating a Report Group

Use

Once you have defined a report group, the next step is to generate the report group. When you generate a report group, any errors and/or warnings found in the report group's reports are displayed on the screen. Since the Generate function uses your report definition to generate ABAP programs, you must regenerate the report group whenever you change the report definition or when you change the sets used in the report.

Before you generate a report group, you should check all of the report group's reports for errors using the Report → Check function. Your processing time will be quicker if you check the reports and then correct the errors and warnings in the reports before you generate the report group. For more information, see Checking a Report [Seite 813].

Report groups are regenerated automatically after a Support Package has been imported. If you change an object used in a report group and in the header attributes of the report group, in the group box Generation, the indicator Not automatic is not checked, the system regenerates the report group without issuing a query.

When you generate a report group, the system uses the standard layout and texts that are assigned to the report according to the language you signed on in.

- If you sign on to the system in English, the system uses the English version of the standard layout and texts assigned to the report.
- If you sign on to the system in German, the system uses the German version of the standard layout and texts assigned to the report.

If reports are to be available in several languages, you must define the languages concerned in Customizing. For more information, see the Implementation Guide (IMG) for Special Purpose Ledger under Information System → Define Report Writer Languages [Extern].

For more information about standard layouts and the languages assigned to them, see Standard Layouts [Seite 1017].

Procedure

   
   The Execute Report Group: Initial Screen appears.

   You can also generate a report group from the Create/Change/Display Report Group screens by choosing Report group → Generate.

2. Enter the name of the report group that you want to generate.
When you generate a report group, the system deletes any existing data extracts defined for the report group. The system first displays a dialog box where you can either select the extract stored or a new selection is made. For more information on defining saved report data, see Executing Report Groups [Seite 964].

   
The system begins to generate the report group. When the system has finished generating the report group, a dialog box appears, displaying any errors or warnings that occurred during generation.
Generating Report Groups (Mass Generator)


2. Enter the data as required.

   The data you enter determines the report groups that are selected for display.

3. Check the following settings according to your requirements:

   - **Generate w/o selection list** determines whether the report groups are generated automatically. If you select Generate w/o selection list, you do not select the report groups to be generated from a selection list.

     If you are generating report groups in the background, you should select Generate w/o selection list, since it is not possible to manually select the report groups to be generated in background processing.

   - **Generate only if necessary** determines that the system only generates the report groups if necessary. For example, it would be necessary to regenerate a report group if the set definition in a row block has changed. If you do not select Generate only if necessary, all report groups that meet the criteria entered on this selection screen are generated.

4. Choose Program → Execute.

   A directory listing of generated report groups that meet the criteria you entered appears.

5. You can use the following additional processing functions after you have displayed a directory listing of generated report groups.

   **Additional Processing Functions - Directory Listing of Generated Report Groups**

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter new selection criteria for generating report groups</td>
<td><strong>Generate → New selection</strong></td>
</tr>
<tr>
<td>Select a report group for generation</td>
<td><strong>Select</strong></td>
</tr>
<tr>
<td>Select all report groups for generation</td>
<td><strong>Edit → Select all</strong></td>
</tr>
<tr>
<td>Deselect the selected report groups</td>
<td><strong>Edit → Deselect all</strong></td>
</tr>
<tr>
<td>Display all report groups (you can use this function after you have selected the <em>Disp. selctd entries</em> function)</td>
<td><strong>Edit → Display all</strong></td>
</tr>
<tr>
<td>Display only the report groups that have been selected for generation</td>
<td><strong>Edit → Disp. selctd entries</strong></td>
</tr>
</tbody>
</table>

6. Select the report groups that you want to generate.
7. Choose *Generate*. Statistical details about the report groups generated by the system are displayed on the *Report Writer: Generate Report Groups* screen.
Scheduling a Report Group as a Background Job

1. On the Execute Report Group: Initial Screen, choose Utilities → Background job →
   - Mass generator (to define a background job for report data selection)
   - Multiple selection (to define a background job for a report group that has variable input parameters)
   - Mass generator (to define a background job for generating report groups)
     The Define Background Job screen appears.

2. Enter a job name and the target host on which the background job should run.
   You use the job name to execute the report group in the background.
   For more information on defining and executing a background job, see the SAP Library under Getting Started → Background Processing.
   
   To execute report groups in the background use the program RGRWSUBMIT. For more information, see the corresponding program documentation.
Deleting Generated Code for Report Groups

Prerequisites
Extensive programming code is generated when a report group is generated. Since many report groups are usually created during system testing, extensive storage space is needlessly allocated. In this case, you may want to use the Delete programs function to delete all generated report group code.

If you delete generated report group code, only the generated programming code is deleted and not the report definitions. When you execute a report group, any deleted code is automatically regenerated.

Procedure
   A dialog box appears, asking you if you want to delete the generated code.
2. Choose Yes to delete the generated code.
   A dialog box appears, asking you if you want to delete the generated code online or in the background.

   Since this program can require extensive system processing time to execute, it is recommended that you execute the program in the background.
3. Select either Online or Background.
   If you select Online, the system begins deleting the generated code.
   If you select Background, the screen for defining a background job appears.

   For more information about defining and executing a background job, see the SAP Library Background Processing System: Overview documentation (Working with R/3 → Getting Started with R/3 → Background Processing).
Creating Report Group Variants

You can define several variants for the same report group. A variant is a group of selection criteria values that have been saved for a report group. Instead of entering the same selection criteria each time you execute a report group, you can create a variant for each set of selection criteria.

You create a variant for a report group specifying that only report data for cost center 100 is selected for the report. You can create a second variant where report data for all the cost centers is selected.

Procedure

1. On the Execute Report Group: Initial Screen, choose Utilities → Variant maintenance →
   - Execute (to create a variant for report data selection)
   - Multiple selection (to create a variant for a report group that has variable input parameters)
   - Mass generator (to create a variant for generating report groups)
     The ABAP: Variants - Initial Screen appears.
     The Program field is automatically filled. The report names appear as follows, depending on the function you selected:
     - J<Report Group><Client>X when you are creating a variant for report data selection.
     - J<Report Group><Client>T when you are creating a variant for a report group that has variable input parameters (multiple selection).
     - RGRJBGOO when you are creating a variant for generating report groups.

2. In the Variant field, enter the variant name.

3. Choose Variants → Create.
   The Maintain Variants: <Program Name> Variant <Variant Name> screen appears.

4. Enter the data as required.
   - For selecting report data, enter the values and sets for selecting report data. Enter extract and output data as required.
   - For entering variable input parameters for a report group, enter the variable values and/or sets and the output parameters for the variant.
   - For generating report groups, enter the selection criteria for generating the report groups.

5. Choose Continue.
   The ABAP: Save Variant <Variant Name> screen appears.

6. Enter the data as required.
Creating Report Group Variants

For more information about the fields on this screen and creating a variant, see the SAP Library *Pre-Setting Selections Using Variants* documentation (*Basis Components* → *ABAP Workbench (BC-DWB)* → *ABAP User's Guide* → *Writing ABAP Reports*).
Exporting and Importing Report Group Variants

You can use the *Transport variants* function to transport report group selection variants between different systems. A *selection variant* is a group of selection criteria values that have been saved for a report group when the report group was executed.

To transport variants, you first export them to a local file and then import them from the local file into the target system.

**Procedure**

   
   The *Export/Import Report Group Variants* screen appears.

2. Enter data as required.
   
   The report group(s) and/or library(ies) that you enter determine which variants are exported or imported.
   
   If you enter both several report groups and libraries, the system selects only those report groups that use the specified libraries.

3. Choose whether you want to export the variants to a local file or import the variants from a local file.

4. Enter the export or import file name.
   
   If the export file does not exist, the system creates it; if the file already exists, the system overwrites the existing file without warning.

   ![Note]

   For a Windows operating system, the file name consists of a drive, path, and a name, such as `C:\TEMP\VARIANTS`.

5. Choose *Program → Execute*.

**Result**

The variants in the current client are exported to or imported from the file you specified in the *Local export/import file* field. The system displays a message informing you that the export/import has been successfully completed and lists the variants that have been exported to or imported from the local file.

During import, the system only imports variants for existing report groups.
Copying Report Group Variants from Other Clients

You can use the Copy var. frm client function to copy report group selection variants between different clients in the same system. A selection variant is a group of selection criteria values that have been saved for a report group when the report group was executed.

Procedure

   The Copy Report Group Variants from Client screen appears.

2. Enter the following data:
   - Source client from which you want to copy the variant(s)
   - Report group(s) and or library(ies) to determine which variants are copied to the client in which you are working
     If you enter both several report groups and libraries, the system selects only those report groups that use the specified libraries.

3. Choose Program → Execute.
   The system copies the variants that meet the selection criteria from the source client to the client in which you are working.
Report Group Execution

Use

The final step in defining a report group [Seite 937] is executing the report group.

When you execute a report group, the system selects the data for the report group’s reports according to the selection criteria you enter. The system selects the data from either the original database or from an extract file.

When the system selects data from the original database, it must first select and then format the relevant data records. Depending on the volume of data, the selection process can be very time-consuming, especially for the analysis of larger data volumes.

To improve processing times, we recommend that you save your reports periodically in extracts. An extract [Seite 1008] only contains the report data (including the structure information) needed to display the report. When you call up an extract, the system only accesses the extract file and therefore reads fewer data records. When you call up a report using an extract, the system only accesses the extract file and therefore reads fewer data records. As a result, processing time improves considerably.

Features

You can either execute a report group [Seite 964] directly or execute a report group in the background [Seite 969]. When you execute a report group, the system determines whether data extracts already exist for the selection criteria you enter. If data extracts already exist, the system displays a dialog box, listing the existing extracts. Additionally, you can choose the option Display Newest Extract.

If there are no extracts for the selection criteria you enter, the system selects the data from the database and displays the report.

You can retrieve and analyze the data stored in an extract file at any time without impairing the system load.

When you perform a release upgrade, all reports that you saved as extracts are deleted because the Report Writer regenerates all report groups. However, the extracts are not deleted when you upgrade the maintenance level of your R/3 System.

At a release upgrade, the only way to save the report list is to archive the spool list using the print function. In the Print dialog box, you must change the archiving mode to Archive only or Print and archive. A spool file is then archived. You can later retrieve the archived spool file to print your report list.

You can also execute a report group in the following ways:

- Vary input parameters for a report group using the Multiple selection function.
You should only use multiple selection when absolutely necessary, for example for variation over a controlling area in Overhead Cost Controlling).

The reports in your report groups should usually all contain the same variables, so that the input parameters are used for all reports in the report group.

For more information, see varying report data [Seite 970].

• Select and output data that has been saved in archive files.

• Select report data, display the report, and vary input parameters in the background.

To improve performance, you should use background processing to execute reports that analyze larger volumes of data. For more information, see executing a report group in the background [Seite 969].

• Create variants for executing reports in the background. For more information, see creating report group variants [Seite 958].

For more information on processing report output, see functions in the report output [Seite 974].
Executing a Report Group

You can execute reports from two different menus that have different functions. The standard mode contains all the basic functions that you require to execute a report. Special functions, that experience has shown to be used by only a few users or that require special knowledge of the Report Writer, can only be used in expert mode. You can call the expert mode from the selection screen or activate/deactivate it from the report output screen at any time. The expert mode is not connected to any authorization. For more information on the advanced functions available for executing report groups, see Expert Mode [Seite 978].

   The Execute Report Group: Initial Screen appears.
2. Enter the name of the report group and choose Execute.
   The <Report Group Name>: Selection screen appears.
3. Enter values for selecting the report data.
   If your report group contains more than one report, use Reports to select a report. The data is always selected for all reports in the report group.
   If there are variables in your report, the system prompts you to enter information for the variables in the selection screen.
   - If you defined value variables in your report, enter a value(s) for the selection of report data.
   - If you defined set variables in your report, enter a set name and/or values for selecting report data.

   For example, suppose you enter a set variable for the characteristic Account in a report created for table GLT1. When you execute the report, you can use a cost element group (characteristic Cost Element in table CCSS) to replace the default set.

   If you don’t enter a set or value on the selection screen, data is selected for all possible values for the relevant characteristic.

   For example, you can enter set variables for the characteristics Cost Center and Cost Element in the general data selection criteria of your report. When you execute the report’s report group, you do not enter a set or value for the cost element, and you enter 100 for the cost center. When the Report Writer selects the report data, it selects data for cost center 100 and for all possible cost elements.

4. To determine which data is used in the report, use the Data source… button.
   Set one of the following indicators as required:
If you want to display a list of extracts that have already been saved for the selection criteria you entered, select **Display extract**. The system displays a dialog box listing the extracts. For more information, see [Extracts][1008].

- If you want to reselect data from the database, choose **New selection**. You can create an extract for the selection criteria you enter using the **Create extract** function (see step eight).

- If you want to read data from archive files, choose **Read from archive**. This indicator only appears for reporting tables that allow you to read data from archives.

  For the system to read data from the archive, you must enter an archiving object in the subsequent dialog box. You then select the archive file from which the system reads the data by choosing **Archive selection**.

  If you have chosen the data source **New selection** or **Read from archive**, you can save the selected data as an extract by choosing **Extract Parameters** on the screen `<Name of report group> > Selection` and then choosing **Create extract** in the dialog box. You can choose between **Do not create extract** and **create extract**. When you create your selection criteria for an extract, the system selects the data from the database if you have not selected the data source **Read from archive**. For more information, see [Extracts][1008] and [Creating an Extract][1010].

It is important that you enter extract data if you execute the report in the background. For more information on executing reports in the background, see [Executing a Report Group in the Background][969] and [Scheduling a Report Group as a Background Job][956].

5. To execute the report, choose .

Depending on the settings under data source and the settings for extract management, existing extracts are shown in a dialog box for your selection criteria.

- If you want to use one of the existing extracts, double-click the relevant extract.

- If you do not want to use any of the existing extracts, you can choose **New selection** to select the data from the database.

The dialog box also appears if an extract has been saved for a report that contains a variation hierarchy and the selection criteria you enter correspond to a report **within** the variation hierarchy. In this case, the system directly accesses the relevant report within the existing variation hierarchy. That is, the system processes each report within the variation as if it were a separate data extract.

**Result**

If you called up the report using an extract, the system outputs the report using the extract data.

If you called up your report by selecting data from the database, the system outputs the report according to the selection criteria you entered and formats the report according to the report definition.

For more information on the functions you can use in the report output, see [Functions in the Report Output][974].

---

[1]:#
Saving Report Data in Microsoft Excel

Exporting a report in RPW format (export to Microsoft Excel) has been superseded by Office Integration [Seite 990]. This can be activated from the selection screen or in the report output by the user. The Excel export in RPW format is no longer supported. Display the report with Office Integration and save it as an XLS file, for example.
Exporting Report Data to the Executive Information System (EC-EIS)

Use
You can export report data to the Executive Information System [Extern] (EIS) when you execute a report group [Extern]. The report is generated and the data is transferred directly to EIS.

You can transfer report data to EIS for report groups that only contain one report.

Prerequisites
The report must fulfill the following requirements before it can be transferred to EIS:

• Zero rows and zero columns must not be hidden in the report’s standard layout [Seite 1017].
• Row blocks:
  – All row blocks must contain the same characteristics in the same order.
  – The suppress indicator may not be set in any row block.
  – All row block characteristics must have total level 0, 1-, or 2-.
  – If the Form printout indicator is set, intervals may not be entered in any row block.
• Column blocks must be key figure sets.
  These key figure sets must not contain any formulas and the key figures cannot have an additional set.
• Only basic [Seite 639] or single-dimension [Seite 643] sets can be used as selection criteria in general data selection. These sets can only contain one value.

Procedure
When executing a report, choose from the selection screen Output parameters... and then in the Output medium group box, Data transfer to EIS.

Result
The report is generated and the data is transferred directly to EIS. You can also transfer the report data in the background.

For more information about executing report groups, see Executing a Report Group [Seite 964].
Executing a Report Group in the Background

   The Execute Report Group: Initial Screen appears.
2. Enter the name of the report group and choose Execute.
   The <Report Group Name>: Selection screen appears.
3. Enter the report selection criteria as required.
4. Choose Program → Execute in background.
   The Background Print Parameters dialog box appears.
5. Enter the printer name to which you want to send the report and other data as required
   (spool request, and so on).
6. Choose Continue.
   The background job is executed.

For more information on creating a background job, see the SAP Library under Getting Started → Background Processing.
Varying Report Data

Use

You can vary report data directly within a report on the screen Create Report: General Data Selection. Both functions are used to create the same type of report (with a common report definition), but using different input data.

SAP recommends that you use variation, and only use multiple selection in exceptional cases.

The following table gives an overview of the main differences between the Variation of the selection and Multiple selection functions. For more information on these functions, see the Varying Levels of Data in a Report Definition (Variation of the Selection) and Varying Input Parameters for a Report Group (Multiple Selection) below.

Advantages of Variation Compared with Multiple Selection

<table>
<thead>
<tr>
<th>Variation of the selection</th>
<th>Multiple selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ Individual values in sets/hierarchies can be broken down and output in the report.</td>
<td>− Individual values cannot be broken down; only the set/hierarchy nodes can be varied.</td>
</tr>
<tr>
<td>+ Improved system performance since data is selected once only.</td>
<td>− System performance is slower since data must be selected for each report.</td>
</tr>
<tr>
<td>+ Report output can be viewed directly online; you can navigate within the report online.</td>
<td>− You cannot navigate within the report.</td>
</tr>
<tr>
<td>Variation using characteristics in general data selection</td>
<td>Multiple selection using variables</td>
</tr>
</tbody>
</table>

For more information, see Variation [Extern].

Varying Levels of Data in a Report Definition (Variation of the Selection)

Using the Vary Frm/To and S fields on the Create Report: General Data Selection screen, you can define the variation level in a report. When you enter variation data in the report definition, the variation function is automatically activated.

When you execute the report, the system generates a report for each hierarchy element within the variation levels defined in the report. That is, it creates a summarized report for all characteristic values, plus a report for every node and single value in the hierarchy. The database is read only once during the data selection process for all variation levels.

If a report definition includes a definition for the Vary Frm/To and S fields, you can execute a report group in the following ways:

- Select data and output it to the screen.
  
  You can use the navigation bar to navigate back and forth between reports. (You activate the navigation bar with on the output screen)
You can select data and print the report.
   All existing variation reports are printed.

You can create a background job for the report group and print the output.
   All existing variation reports are printed.

For more information on using the Vary Frm/To and S fields, see Defining Selection Criteria [Seite 835].

Varying Input Parameters for a Report Group (Multiple Selection)

You use the multiple selection function when you want to execute a report group and enter different values for the variables of the report group.

When you use value and set variables within a report and you execute the report's report group using the Multiple selection function, the system prompts you to enter values/sets for the variables defined in the report.

   • When you use value variables in a report, you can enter single values or value ranges for executing reports.

   • If you use set variables in a report, you can vary the data for the different set levels. (You cannot use single values to vary the data.)

The system generates a separate report for each value entered in the input parameters and sends the report data directly to a spool file or saves the report in an extract. The database is read separately for each report that is produced.

In your report definition, you enter a value variable for the characteristic "Year" as general data selection criteria. When you execute the report using the Multiple selection function, the system prompts you to enter a specific year or years and/or a range of years. The system creates a separate report for each year you have specified in the input parameters.

If you want to vary the input parameters, either do this directly in the report definition (using the Vary Frm/To and S fields) or during report execution (using the Multiple selection function); do not do both for a given characteristic.

In Overhead Cost Controlling, you can use multiple selection for the characteristic controlling area and variation using the characteristic cost center.

Procedure

   The Execute Report Group: Initial Screen appears.

2. Enter the name of the report group and choose Multiple selection.
   The <Report Group Name>: Multiple Selection screen appears.

3. Enter the data as required.
Varying Report Data

**Fixed values fields**
Enter the fixed values for the report group.

**Vary values fields**
Enter the selection values for the report group.

**Vary sets fields**
Enter the selection sets for the report group.

The set that you enter in place of the default set variables does not have to belong to the same table and characteristic as the set variable. However, the field used by the set must be compatible with the field of the default set.

For example, suppose you enter a set variable for the characteristic *Account* in a report created for table GLT1. When you execute the report, you can use a cost element group (characteristic *Cost Element* in table CCSS) for the set variable.

You create a report group containing a report that uses the value variable TD-YEAR (characteristic *fiscal year*, default value 1997) and the set variable TD-COMP (characteristic *fiscal year*). For this report group, you enter several years for the value variable TD-YEAR. The system then creates a report for each year that you specify. For the set variable TD-COMP, you could create a report for each set node of the set hierarchy that has been entered for the set variable TD-COMP.

If you enter a set, you have to define how you want to process the set when you output the report:

Set the *Fixed* indicator if you do **not** want to explode all nodes of the set hierarchy in the report output. The system only outputs report data for the set you enter.

Do not set the *Fixed* indicator if you want to explode the set hierarchy. The *Hierarchy* indicator determines how the set hierarchy is exploded in the report output:

- If you select *Hierarchy*, the system processes the set you enter, as well as all sets at lower levels in the hierarchy.
- If you do not select *Hierarchy*, the system only processes the set nodes at the lowest level in the hierarchy (the basic sets).

4. To enter output information for the report, choose *Output parameters*.

   For more information, see Expert Mode [Seite 978] and Executing Report Groups [Seite 984].

5. To save the output parameters, choose *Continue*.

6. You can save the reports as extracts by choosing *Generate extract*. When you create an extract for your selection criteria, the system selects data from the database.

   For more information on the data you enter in the extract dialog box, see Extracts [Seite 1008].
If you upgrade the release (such as from 4.5B to 4.6C), the reports saved as extracts can no longer be displayed. If you upgrade the maintenance level of your R/3 System (such as from 4.6A to 4.6B), the extracts can still be displayed.

The only way to save the report list when you upgrade the release is to archive the spool list using the print function. In the Print dialog box, you must change the archiving mode to Archive only or Print and archive. A spool file is then archived. You can later retrieve the archived spool file to print your report list.

7. To save the extract parameters, choose Continue.

8. Specify whether you want to perform a test run of multiple selection.
   - If you select Test run, the system only outputs the report log.

9. To execute the multiple selection, choose Program → Execute.

Result

If you selected Test run, the system displays the report protocol of values that were input for the report, as well as the value variable(s) and set variable(s) used to select report data. The protocol also lists the number of reports created.

If you did not select Test run, the system outputs the reports according to the selection criteria and the output medium you entered.
Functions in the Report Output

Use
When you execute a report group, the system selects the data for the report group’s reports according to the selection criteria you enter. The system selects the data from either the database or reads the required report from an extract file, and then outputs the report.

The report data is presented according to the output format you defined.

If you specified that the report be displayed on your screen, you can perform various functions in the report. For example, you can navigate through the report data.

Additional functions are available in Expert Mode. For more information, see Expert Mode [Seite 978].

Features
The most important functions available in the report output include:

- Print report
  For more information, see Printing Report Data [Seite 982].

- Send report to mail user
  For more information, see Sending Reports to Mail Users [Seite 992].

- Select report data
  For more information, see Selecting and Deselecting Report Data [Seite 993].

- Sort report rows
  For more information, see Sorting Report Rows [Seite 997].

- Navigate within a report
  For more information, see Navigating Within a Report [Seite 998].

- Call up report graphics
  For more information, see Calling Up Report Graphics [Seite 999].

- Call up reports using the report/report interface
  For more information, see Calling Up Reports via the Report/Report Interface [Seite 1000].

- Navigate within variation settings

  Varied data selection characteristics are those characteristics that you entered for selecting report data (on the Create Report: General Data Selection screen), for which you have also entered values in the *Vary Frm/To* and *S* fields. When you enter varied data selection characteristics, you can control the level of detail that appears in the report.

  When the report is output, you can use the *Goto → Variation → ...* function to display varied detail levels of report data for the data selection characteristics.

  Using the *Graphical selection* function, you can:
Functions in the Report Output

- Select (highlight) a new characteristic value within the active characteristic.
- Select a new characteristic and display the set structure of the characteristic.
  Variation functions under the Goto → Variation menu option include:
  - Variation left and Variation right
    Using these functions, you can navigate within one hierarchy level.
  - Variation previous level and Variation next level
    Using these functions, you can navigate to the next higher level or the next lower level of the displayed characteristic.
    For example, if you select a single-dimension set that contains a basic set and choose Goto → Variation → Variation next level, you navigate to the basic set level.
  - First/Previous/Next/Last setting
    For more information, see Navigation in the Variation Settings [Seite 1002].

- Work with report hierarchies
  Expand/collapse
  You can expand and collapse rows, sections, and reports (completely or individual levels).
  Summation level
  The totals rows in a report are represented by summation levels.
  For more information, see Summation Levels [Seite 1034].

- Modify the report layout [Seite 1029]
  - Layout parameters
    The layout parameters for the report output are determined by the standard layout assigned to the report. This includes the page format of the report and the numerical format of the report data.
    A section layout [Seite 1028] can be defined separately for each section. To define a layout [Seite 1016] for a certain section, double-click on the section and then make the settings for the column attributes.
    You can change the report’s layout parameters under Settings → Report layout.
    If you change the layout parameters, but then decide that you want to reuse the default values from the standard layout, you can do so by choosing Settings → Report layout → Use standard layout.
    For more information on standard layouts, see Standard Layouts [Seite 1017].
  - Column width
    You can change the widths of the lead column and the data columns by choosing Settings → Column attributes.
    You can also define the column widths for individual format groups in the layout parameters under Settings → Report layout → Columns → Other format groups.

- Numerical format
Functions in the Report Output

You can change the format of the displayed report values using the *Settings → Report layout → Representation → Numerical format* function. You can enter the following data for each format group:

- Number of decimal places
- Scaling
- Column width
- Unit column in the report (that is, whether the column for the currency units or units of measure is displayed in the report).
- Change +/- sign information

You can also enter the numerical format data for individual format groups here by choosing *Other format groups*.

- Define report texts

  You can only change texts in the report output if the report uses a standard layout in which the *Change allwd dur exctn* indicator is set on the Page/Control screen. You cannot change texts in standard reports included with your SAP R/3 System.

  For more information on entering report texts, see *Defining Report Texts [Seite 825]*.

- Selection log

  You can display and print the report’s selection log using the *Extras → Selection log* function.

  The selection log provides statistics on the data selection. These include:

  - Runtime of the selection and output programs
  - Number of records read from the database tables
  - Percentage of the data records used in the report
  - Number of records not used in the report on the basis of authorization checks
  - Number of data records used in the current report group

- Messages

  If the system issues any warning messages when the report is executed, you can display these messages using the *Extras → Messages* function.

  If more than one message is issued when the report data is selected and formatted, the system displays only one message, informing you that several messages have been issued.

- Technical information

  You can display technical information on the report execution using the *Extras → Tech. information* function. The system displays the program names for the selection, output, and multiple selection, as well as information on the report’s library and report group.

- Annotations
You can enter explanatory text for the report using the *Extras → Annotation* function. This text displays after the last report page. You enter annotation text using the SAPscript editor.

- **Report documentation**
  
  You can display and print the report documentation by choosing *Extras → Documentation → Report*.

- **List/display/change report definition**
  
  You can switch to the report definition by choosing *Extras → Definition → Display/Change*. You can then display or change the report definition, depending on the function you chose.

  You can list the entire report definition using the *Extras → Definition → List* function.

- **Graphical column heading**
  
  If your report columns contain several headings, you can use the *Settings → Graph. column heading* function to choose the column heading that you want to use as the heading for the output in the graphic display.
Expert Mode

Use
You can execute reports from two different menus that have different functions. The standard mode contains all the basic functions that you require to execute a report. Special functions that are generally only used by a few users, or that require special knowledge of the Report Writer, are only available in expert mode [Seite 797].

You can call the expert mode from the selection screen or activate/deactivate it from the report output screen at any time. Expert mode does not require authorization to use.

Prerequisites
You can activate expert mode on the selection screen when executing a report, or in the report output:
On the selection screen, choose Environment → Options... and select the option Expert mode (under General settings).

You can also activate expert mode in the report output under Settings → Options.

Features
Expert mode offers the user more functions than are available in the standard mode.

The following functions are available in expert mode:

On the selection screen:

Variation
You can display the report in different levels of detail and different variation ranges.

If you have defined variation levels in your report (Vary Frm/To/S fields on the Create Report: General Data Selection screen), the variation function is activated automatically.
You can change the variation settings with the button Variation.

The default settings in the Additional Entries: Variation dialog box are taken from the report definition. You can change these settings as required.

The Explode option creates a summarized report for all characteristic values, plus a report for each node and single value in the interval of the group.

The SingleVal function creates a report for every single value in the interval or group.

The Do not explode function creates one report containing summarized data for all characteristic values.

To enter detailed variation levels in your report, choose (Detail). In the subsequent dialog box, you can enter a variation range and activate the variation of the single values if desired.

If you want to navigate between variation levels in the report output, you must enter a range of variation levels (such as 1 to 99) in the from and to fields. The SingleVal
indicator determines whether different reports are output for the single values contained in the group (set).

The following table shows the correlation between the variation indicators and the variation range/single value combination.

**Variation vs. Variation Range/Single Value**

<table>
<thead>
<tr>
<th>Variation indicator</th>
<th>Variation range</th>
<th>Single values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explode</td>
<td>1 to 99</td>
<td>Active</td>
</tr>
<tr>
<td>Single values</td>
<td>1-</td>
<td>Active</td>
</tr>
<tr>
<td>Do not explode</td>
<td>1 to 1</td>
<td>Inactive</td>
</tr>
</tbody>
</table>

If you have set the variation indicator to *Single values* in the report definition, you cannot change this default setting in the variation dialog boxes. Reports are always output for the single values contained in the selected group (set).

For more information, see *Variation [Extern]* and *General Data Selection [Seite 762]*.

**Currency Translation**

You can use the currency translation function to translate currency key figures into a joint target calculation. For currency translation, choose 📋. Enter the information required for currency translation in the dialog box.

**Output Parameters**

In expert mode, you can also establish default settings that apply when you exit the report:

- Save settings
- Generate extract

For more information on extracts, *Extracts [Seite 1008]*.

**Extract Parameters**

Choose *Extract parameters*... to define the extract parameters. From the *Entry: Extract Parameters* screen, you can make the following settings:

The default setting is *Do not create extract*. If you select this setting, you can exit the entry screen with 🚪.

To save your report selection data as an extract, set the *Create extract* indicator and enter the extract parameters.

In the group box *Extract parameters*, enter a description for the extract in the *Description* field.

Expiration date of the extract

If you want the extract to be deleted after a specific period of time, select *Expires in* and enter the number of days for which the extract is valid or select *Expires on* and enter an expiry date for the extract.
Expert Mode

⚠️ Once an extract has been deleted, it **cannot** be retrieved.

If you do **not** want the extract to be deleted after a specific period of time, select *No expiration date*.

👉 You should select this indicator if you want to keep the extract for a longer period of time.

👉 The expiration date is only effective within a given release version. If you upgrade to a later release, all report extracts are deleted. However, extracts are not deleted when you upgrade the maintenance level of your SAP R/3 System.

To save the extract parameters, choose 📋.

👉 When you exit a report that has not been saved in an extract file, a dialog box appears asking whether you want to save the report as an extract. If you choose *Yes*, the system calls up the extract dialog box in which you enter the above information.

For more information, see [Extracts][1], [Creating an Extract][2], and [Managing Extracts][3].

Selecting Reports

By choosing *Reports* you can select particular reports in your report group.

👉 This functionality is available should your report group contain more than one report.

**In the report output:**

**Export report**

The symbol 📄 exports a report to a presentation server or application server. For more information, see [Exporting a Report to an External File][4].

**Presentation graphics**

The symbol 📚 calls up a business graphic. For more information, see [Calling Up Report Graphics][5].

**Layout settings**

*Fully expand report*

*Fully collapse report*

*Expand section*

For more information, see [Layout][6] and [Saving Changed Report Layout Parameters][7].

---

[1]: #/SEITE_1108
[2]: #/SEITE_1101
[3]: #/SEITE_1101
[4]: #/SEITE_985
[5]: #/SEITE_999
[6]: #/SEITE_1016
[7]: #/SEITE_1033
Currency translation
Define threshold value

For more information, see Entering Threshold Value Conditions [Seite 994].

Navigation
Previous section
Next section
Printing Report Data

Use

Depending on the size of a report and the page size specified in the layout parameters, a report can cover several horizontal and vertical pages. You can print either the whole report or just parts of it.

Procedure

To print a report, choose Report → Print....

If variations exist for your chosen report, you can either print the current report or all the variation reports. If you decide to print the variation reports, you can specify whether they are to be printed in separate spool requests or all in one spool request. Make your choice in the dialog box, which only appears if variation reports exists, and choose Continue.

On the selection screen for the output parameters, in the group box Output medium, you can specify that reports are to be attached. Here you specify whether variation reports are to be printed in a single or in separate spool requests.

Specify which pages of the report you want to print. You have the choice between all pages, the current page, or you can select the pages you want to print. If you select Print all pages, the Report Writer reads the number of rows per report page from the standard layout assigned to the report. Choose Continue.

If the print page formatting is not active, you can specify in a dialog box, whether you want to activate print page formatting.

You activate print page formatting via Settings → Options... in the group box List output.

Headers or column headings are only displayed in regular intervals if print page formatting is activated.

In the Print Parameters dialog box, you enter printer data such as the output device, the number of copies, and spool information. To complete your entries, choose Continue.

If the headers and column headings disappear when you scroll, it is possible to “freeze” them. For more information, see Freezing Page Headers [Seite 984].

Result

The report or the parts of the report you specified are printed.
Freezing Page Headers

Use

In the on-screen report output in list format, you can freeze the page headers (headers and column headings) to prevent them from disappearing when you scroll.

When the freeze page header function is activated, the headers and the column headings (if the page only contains a single section) are frozen in position. On pages that contain multiple sections, only the headers can be frozen, since otherwise the column headings of the first section of the page will be displayed on all following sections.

Procedure

In the report output, you freeze the page headers under Settings → Options... by selecting Freeze page header in the group header List output.

If the window height is less than the frozen area, you cannot scroll vertically. Increase the size of the window or unfreeze the page headers.
Exporting a Report to an External File

Use
You can export reports to an external file on the presentation server or to a file on the application server.

Features
The application server is the computer that is running the SAP R/3 System (for example, a UNIX-based workstation assigned to your department).

The presentation server is the computer that is running your R/3 interface (for example, a PC linked to an R/3 application server).

For more information on these two alternative functions, see Exporting a Report to a Presentation Server [Seite 986] and Exporting a Report to an Application Server [Seite 988].
Exporting a Report to a Presentation Server

Use
You can export a report in an external file to the application server or to a presentation server. The presentation server is the computer that is running your R/3 interface, such as a PC that is linked to an R/3 application server.

On the output parameters selection screen in the group box Output medium, you can select the checkbox Append reports to specify whether an existing export file is to be extended or overwritten.

Procedure
Choose Report → Export... The dialog box Export to Presentation Server appears.

The current output medium is marked by a green traffic light. Ensure that the pushbutton Local PC file is selected.

Specify the export format you require:

To export data to a file in a table format, choose Spreadsheet. Lead columns and values are exported in a table format. Column headings and the text for export are also exported. This format is especially suited for processing your report in spreadsheet programs.

To export the report to DBASE or a compatible database program, choose DBASE format.

To export the report in a Lotus spreadsheet format, choose WK1 format.

These three export formats are table formats. For these table formats you can also check the function Format figures.

Choose this if you want the following column attributes (the settings in the report layout [Seite 1029]) to be taken into consideration when exporting in table format: scaling, decimal places, change +/- sign.

If you do not choose the indicator Format figures, all the figures are exported in an unformatted form. The column attribute Print unit is not taken into consideration during the export.

To export the report to a file in text format, choose Word processing. The report is exported as it appears on the screen. This format is especially suited for processing your report in word processing programs.

To export the report to a file in HTML (HyperText Markup Language) format, choose HTML format. The system automatically starts the default Internet browser (such as Netscape Navigator or Microsoft Internet Explorer) and then displays the report using that browser. Each report section is converted into an HTML table. If you have defined a specific text for the export, this text is displayed at the beginning of the report page. Otherwise, the title page of the report is displayed.

In the group box Output file, enter the file name for exporting the report.

In the group box Launch PC application, enter the program that is to be launched after the report has been exported to the presentation server. Select one of the following variations:
Exporting a Report to a Presentation Server

If the output file is to be opened directly by the PC application, choose Open file.

If you want to launch the PC application using parameters, choose Parameters for application. Enter the parameters in the input field next to the indicator.

If you enter && in this field, the system replaces the && characters with the current file name (File name field) when the program is executed.

If you only want to export the report to the presentation server, choose Export only. The system does not launch the PC application in this case.

Choose Continue.

Result

The system exports the report.
Exporting a Report to an Application Server

Use
You can export a report in an external file to the application server or to a presentation server. The application server is the computer that is running the SAP R/3 System, such as a UNIX-based workstation assigned to your department.

On the output parameters selection screen in the group box Output medium, you can select the checkbox Append reports to specify whether an existing export file is to be extended or overwritten.

Procedure
Choose Report → Export... The dialog box Export to Presentation Server appears.

The current output medium is marked by a green traffic light. Choose the pushbutton Application server... Specify the export format you require:

To export data to a file in a table format, choose Spreadsheet. Lead columns and values are exported in a table format. Texts for export are also exported. This format is especially suited for processing your report in spreadsheet programs.

For this table format you can also check the function Format figures.

Choose this if you want the following column attributes (the settings in the report layout [Seite 1029]) to be taken into consideration when exporting in table format: scaling, decimal places, change +/- sign.

If you do not choose the indicator Format figures, all the figures are exported in an unformatted form. The column attribute Print unit is not taken into consideration during the export.

To export the report to a file in text format, choose Word processing. The report is exported as it appears on the screen. This format is especially suited for processing your report in word processing programs.

To export the report to a file in HTML (HyperText Markup Language) format, choose HTML format. The system automatically starts the default Internet browser (such as Netscape Navigator or Microsoft Internet Explorer) and then displays the report using that browser. Each report section is converted into an HTML table. If you have defined a specific text for the export, this text is displayed at the beginning of the report page. Otherwise, the title page of the report is displayed.

In the group box Output file, enter the file name for exporting the report.

Choose Continue.

Result
The system exports the report.
Office Integration

Use
In the report output of Report Writer reports, Office Integration is available as an alternative to list output. It also replaces the previous Excel export in RPW format.

Prerequisites
Office Integration places higher demands on front-end hardware than does normal list output. For more information, see Desktop Office Integration [Extern].

Features
Office Integration enables reports to be output as Office documents (Microsoft Excel, Lotus 123). The Office application runs as a control within the R/3 window. With a few exceptions, all R/3 functions are available on the worksheet of the Office application. The functions are as follows:

Display can be switched interactively
Using the dialog settings, you can switch between displaying the report in the normal list format and displaying it as an Office document. The selected setting is saved permanently in the user parameters. The dialog settings can also be changed on the initial screen of the report group in the output parameters.

If the selected Office application is not installed on the user’s PC, the report is output in normal list format.

Worksheet protection
When a report is output into an Office document, the worksheets are protected. This is to assure consistency of the data on the front end with R/3. This consistency is necessary for context-sensitive functions such as report calls and changing column attributes.

You can permanently deactivate worksheet protection in the dialog settings, or temporarily in the Office application, allowing you to change the worksheet locally. However, if rows and columns are then inserted into the worksheet, the correct cell reference for context-sensitive functions may be lost. Any changes made locally will be overwritten in R/3 in the next dialog step.

Mail connection
You can send the current Office document as an attachment to an email.

It is not necessary to have saved the report as an extract.

Local structuring functions
Office Integration supports local hierarchical structuring functions in the Office application. This enables you to change the breakdown of rows and columns locally, without having to communicate with the SAP R/3 System. This function is also available with mailed Office documents.
Headers in worksheets

The headers of worksheets are created from the text for export. The headers and footers defined for the report are normally adapted for list output and are therefore not used for the worksheet. Likewise, the title page and end page are ignored.

Output of sections

Each section that has an explicit page break (default setting in Report Painter) is output in the Office document as a new worksheet. Sections that follow each other without explicit page breaks are output together in one worksheet. The name of the worksheet is the title of the first section on the worksheet. The title may get changed slightly to meet the naming restrictions of the Office application (non-permitted characters such as *, :, \, /, and ?, length restrictions, uniqueness of the name).

For more information, see Desktop Office Integration [Extern].
Sending Reports to Mail Users

Use

From the report output screen, you can send the current report in HTML format to an internal or external user. You can also send reports independently of your SAP R/3 System. The report is sent to the mail recipient's inbox or mailbox. The recipient can then display the report data, as well as additional information (such as the report group name and time of data selection).

If the report has been saved as an extract [Seite 1008], the recipient in the SAP R/3 System receives the document in HTML format plus a link to the extract. To display the extract, choose Document → Execute in the SAP R/3 System in the document display.

If you send a report while it is still displayed on the screen, this current report is always attached to the mail in HTML format.

If Office Integration [Seite 990] is active, the current report is attached to the mail as an Excel file or Lotus 123 file.

Procedure

Choose Report → Send... The screen Send with Note appears.

Enter the name of the recipient and assign a corresponding recipient type.

Select the required send options.

You can also write a note to the recipient. This note is displayed in a dialog box when the recipient calls up the report from the mail inbox.

Choose Send.

Result

The report is sent and the recipient receives it in his/her mail inbox.
Selecting and Deselecting Report Data

Procedure
To select a block of report data for further processing, position the cursor on the first row of the block that you want to select.

Choose Edit → Select block.

Position the cursor on the last line of the block you want to select.

Choose Edit → Select block.

To deselect the block, choose Edit → Deselect block.

Result
The system highlights the block of report data you selected.
Entering Threshold Value Conditions

Use

You can specify a threshold value condition so that report rows are highlighted or hidden depending on the numerical values of a certain report column (reference column).

You can only define threshold value conditions in the displayed report in expert mode [Seite 978].

You can define a threshold value condition while creating, changing, or displaying a report, or define it from the output report.

Suppose your report has three columns: actual costs, plan costs, and variances between actual and plan costs. You want to highlight in red all rows with variances of at least 10,000. To do so, you enter a threshold value. In this example, the threshold value is 10,000 and the reference column is 3 (variance between actual and plan costs).

You can define a maximum of two threshold value conditions for each report.

Procedure

To define the threshold value condition from either the Create Report/Change Report/Display Report initial screens, choose the Sections pushbutton and select the required report column. Choose the Threshold values pushbutton. The system displays the Maintain Threshold Value Condition for <section number> dialog box. Continue with step 3.

In report output, select the required report and then highlight the section for which you wish to define the threshold value condition.

Select Edit → Threshold value... The system displays the Maintain Threshold Value Condition for <section number> dialog box.

Enter the following information:

Specify a condition for the threshold value. For example, if you want to display values for a certain report column greater than 10,000, you enter => in the Condition field.

Enter the threshold value. You can enter the threshold value with or without decimal places. You can only use a period or comma for the decimal places. The threshold value itself must not contain a period or comma.

Enter the position number of the reference column. The columns are numbered from left to right, starting from the first report column.
Columns with a column width of zero (defined in the layout parameters) which are therefore not displayed are nevertheless included in the numbering. This means that your reference column does not have to be displayed.

Use the Active indicator to specify whether the threshold value condition is active or not.

You can enter additional threshold value information in the Extras group box:

The Ignore +/- sign indicator tells the system whether it should ignore the +/- sign when determining which values fulfil the threshold value condition. Select this indicator if you want the report writer to ignore the +/- sign.

To highlight all row values exceeding a specific threshold (whether positive or negative) in an actual/plan/variance report, turn on the Ignore +/- sign indicator.

You use the indicator Only detail rows to restrict the where-used area of the threshold value condition. If you select this indicator, the totals rows are not included in the threshold value condition. They are printed unchanged when the report is output.

If you just want to print the report rows conforming to the threshold value condition, choose the Print selected rows only indicator. The system hides all other report rows.

To highlight the rows fulfilling the threshold condition in red, choose the Highlight selected rows (red) indicator.

To highlight the rows fulfilling the threshold value condition in green, choose the Highlight selected rows (green) indicator.

To specify a second threshold value condition, proceed in accordance with steps 2 and 3.

**Example**

Suppose a report contains the following columns:

- Actual costs (column 1)
- Plan costs (column 2)
- Actual/plan variance (column 3).

You want to highlight in red all rows where the variance is greater than or equal to 10,000. You enter the following threshold value condition:

```
Condition >=
Threshold value condition 10000
Reference column 3
```

Choose Highlight selected rows (red).

In the same report, you want to highlight in red all rows where the variance is greater than or equal to 10,000. To do this, you enter the same conditions but select Print selected rows only. All other report rows are hidden.
Entering Threshold Value Conditions
Sorting Report Rows

Use

You can sort report rows in reports that have been output in various ways by using the functions under Edit → Sorting.

Depending on where you have positioned the cursor in the report, there are two ways in which you can sort the report. You can use the hierarchical sort function to sort the entire row hierarchy on all summation levels. It is also possible to sort the rows just on the summation level of the row you have selected.

Procedure

Defining the Sorting Function

You can tailor the sorting function to your requirements under Edit → Sorting → Define....

Hierarchical Sorting Function

If you position the cursor on the heading of a certain report column and choose Edit → Sorting → Sort ascending or Edit → Sorting → Sort descending, the system sorts the entire row hierarchy on all summation levels.

Sorting Function on a Summation Level

If you position the cursor on a report row within a certain report column and choose Edit → Sorting → Sort ascending or Edit → Sorting → Sort descending, the system sorts the rows on the summation level of the row you selected.

When you use the sorting function, the system displays a symbol in the heading of the column for which you have sorted report rows.

Undoing a Sort

To restore the original order of the report rows, choose Edit → Sorting → Undo sorting.
Navigating Within a Report

Use
From the report output of one report you can also display a different report. You can also navigate within different column blocks.

Procedure
If your report group contains more than one report, you can display another report included in the report group by choosing Goto → Other report.

Navigating in Column Blocks
In large reports that contain several row and column blocks, you can navigate within the report using the Goto → Position → Pages/Sections/Columns functions.

These functions allow you to locate and display a specific report page, report section, or column block.

You can navigate within the column blocks of a report using the functions Goto → Scroll horizontally → To the far left/Page left/Page right/To the far right.

Navigating with the Navigation Bar
In the report output, you can turn on the navigation bar in the left-hand screen area. Choose Settings → Options. In the Options dialog box, select Display navigation bar (in the General settings group). You can use this navigation bar to navigate within the reports of the report group and in the variation reports.
Calling Up Report Graphics

Use
You can display a report or a block of selected report data in different forms (two- or three-dimensional) using the SAP Business Graphic.

When you call up the SAP Business Graphic, you can:
Display graphics for the pages of a report in a separate window
Select certain areas of the report and display this report data as a graphic in a separate window

Prerequisites
The system can display the graphic type you specified in the standard layout. For more information, see Creating a Standard Layout [Seite 1019] and Parameters for the Standard Layout [Seite 1022].

Procedure
In the executed report, select the area you want to display as a graphic and choose Report → Graphic.

Result
The report (or the selected area of the report) is displayed in a separate window.
Calling Up Reports via the Report/Report Interface

Use

The report/report interface allows you to interactively start report groups, ABAP programs, report portfolio reports, drilldown reports, and transactions while displaying the report output.

Prerequisites

If receiver reports have been defined for the report's report group [Extern] or library [Extern], you can call up these reports using the Call up report function.

Procedure

You can generally access the receiver report from the sender report by selecting a cell and then double clicking this or choosing 🔄.

When you call the receiver report, the characteristics’ restrictions that gave rise to the value in the sender report are passed on to the receiver report.

If, for example, a value is characterized in the sender report by the characteristics year, cost element, period, and value type, these characteristics are passed on to the receiver report.

There are four different ways of calling up a report using the report/report interface, whereby the starting position is the deciding factor for the receiver report:

If you want to call up a receiver report with the restrictions that are valid for a certain value in a cell, position the cursor on a value in the report and double click it or choose 🔄.

The receiver report is called up with the selection criteria that gave rise to this particular value.

If there is only one receiver report, this is displayed immediately; otherwise a list appears from which you can select a report that is then displayed.

If you want to call up a receiver report with selection criteria that are valid for a certain row, position the cursor on the row text in the lead column and choose 🔄. The receiver report is called up with the selection criteria that are valid for the whole row.

If you want to call up a receiver report with selection criteria that are valid for a certain column, position the cursor on the column heading and choose 🔄. The receiver report is called up with the selection criteria that are valid for the whole column.

If you want to call up a receiver report with selection criteria that are valid for a certain area, select two cells with 🔄. The entire rectangular area between these two cells is selected.

In the following example the cells have been given coordinates for easier identification. Cells B2 and D4 have been selected and thus the entire rectangular area between them is selected as well.
You can display or change the receiver reports that you want to call up from the report output using Settings → Report/report interface.... To change receiver reports in this way, you must first select Change allowed during execution (under Settings → Report layout, tab page Page/control, group box Control data).

For more information on defining reports for the report/report interface, see Defining Reports for the Report/Report Interface [Seite 924].
Navigation in the Variation Settings

Use

Depending on the report type (Report Painter or Report Writer report), there are different functions for navigating in the variation settings in the report definition and in the executed report.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Definition</td>
<td>Only degree of explosion can be defined</td>
<td>Levels of detail can be defined</td>
</tr>
<tr>
<td>Executed Report</td>
<td>Levels of detail can be defined</td>
<td>Levels of details can be edited</td>
</tr>
</tbody>
</table>

If a selection set contains more than one value, the Report Writer accumulates the data for the different values. By entering appropriate values in the Vary Frm and Vary To fields (to define a variation range), you can instruct the Report Writer to create different reports for the different characteristic values, as well as for the different set levels (if the selection set is a single-dimension set [Extern]).

Once you have entered the variation data and executed the report's report groups the selection variation is activated automatically.

Features

Report Painter Report

For information on variation ranges, see Editing Variation Ranges in Report Painter [Seite 1003] and Working with Variation Ranges in Report Painter [Extern].

Report Writer Report

For information on variation ranges, see Editing Variation Ranges in Report Writer [Seite 1005] and Working with Variation Ranges in Report Writer [Extern].
Editing Variation Ranges in Report Painter

Use
You can edit variations of Report Painter reports in two ways:
- In the report definition
- On the selection screen of the executed report

Procedure
Once you have defined the general data selections for the characteristics, you can define the variation range in the report definition with the following:

On the selection screen of the executed Report Painter report, you can define the level of details for the row explosion as follows:

On the selection screen, choose the radio button for the required degree of explosion.

In the dialog box *Additional Entries: Variation*, choose the radio button for the required degree of explosion.

You can restrict the characteristic values further by assigning them *from* and *to* levels (variation range) using the following:

**Entries possible for the *from* level of the variation range and the resulting restrictions for the *to* level**

<table>
<thead>
<tr>
<th>From level</th>
<th>To level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Positive [&gt;0]</td>
<td>Greater/Less From level</td>
</tr>
<tr>
<td>Negative [-1; -2]</td>
<td>No entry</td>
</tr>
</tbody>
</table>

The following example illustrates the variation range levels possible within a cost center hierarchy:
Cost Center Hierarchy

BSG Inc.
- ADMIN
  - 100
  - 110
- DIST
  - 200
  - 210
- PROD
  - 300
  - 310

Level
1
2 (= -2)
3 (= -1)

For more information, see Working with Variation Ranges in Report Painter [Extern].
Editing Variation Ranges in Report Writer

Use

You can edit variations of Report Writer reports in two ways:
In the report definition
On the selection screen of the executed report

Procedure

In the report definition, choose General data selectn and then in the screen Create Report:
General Data Selection <Name of Library><Name of Report Writer Report> you can define a
from and to level for the variation range of each set. You can also define an individual value
flag for each set, indicating that the variation range contains individual values.

To change the variation range in an executed report, from the selection screen choose Variation and make your changes.

⚠️

The following restrictions apply for the variation range (from and to level).

Entries possible for the from level of the variation range and the resulting restrictions for
the to level

<table>
<thead>
<tr>
<th>From level</th>
<th>To level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Positive [&gt;0]</td>
<td>Greater than/less than From level</td>
</tr>
<tr>
<td>Negative [-1; -2]</td>
<td>No entry</td>
</tr>
</tbody>
</table>

⚠️

The following example illustrates the variation range levels possible within a cost
center hierarchy:
Navigating Within an Executed Report

For information on navigating within a report, see Navigating Within a Report [Seite 998].

To display the report data levels of detail for the data selection characteristics you can use the functions under the menu option View. You can vary the level of detail on a report, section or row level.

To navigate to the next level up of the displayed characteristic, choose \( \text{Variation previous level} \)

To navigate to the next level down of the displayed characteristic, choose \( \text{Variation next level} \)

If you select a single-dimension set containing a basic set, you navigate to the basic set level using \( \text{Variation next level} \).

For more information on defining selection criteria, see Defining Selection Criteria [Seite 835].
Navigating in the Report Hierarchy

Use
You can vary the level of detail of an executed report on a report, section or row level.

Procedure
To expand or collapse a certain area of the report, position the cursor in the desired area and choose the required function under the menu option View as follows:

Expand report fully or 📊
Collapse report fully or 📊
Expand section or 📊
Expand section fully
Collapse section or 📊
Collapse section fully
Expand section to...
Expand row
Collapse row
Extracts

Use
To reduce the necessary runtime for formatting report data, you can create an extract when you execute a report. An extract is a dataset that contains the report data selected at the time the extract was created.

Extracts provide the same navigation and formatting options as reports selected directly from the database.

The main differences between an extract and a report are shown in the following table:

<table>
<thead>
<tr>
<th>Main Differences Between Report and Extract</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Report (Newly Selected)</strong></td>
</tr>
<tr>
<td>Currentness of data</td>
</tr>
<tr>
<td>Authorization check</td>
</tr>
<tr>
<td>Runtime</td>
</tr>
</tbody>
</table>

Aside from these differences, extracts offer full report functionality. When you call up a report that uses an extract, the system does not have to select the report data directly from the database. As a result, processing time improves considerably.

⚠️ If you create an extract and then make changes to the data structure in Customizing, this can result in inconsistencies between the current data structure and the structure in the extract. The data of the extract can therefore no longer be displayed.

⚠️ After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Integration
The final step in defining a report group [Seite 937] is executing the report group. You generate an extract when you execute the report with reference to the selection parameters entered at the time the report is executed. You can therefore create multiple extracts of the same report by entering different selection criteria each time.

If you called up the report using an extract, the system outputs the report using the extract data.

If you called up your report by selecting data from the database, the system outputs the report according to the selection criteria you specified and formats the report according to the report definition.

For more information, see Executing a Report Group [Seite 964].
Features

In expert mode [Seite 978], you can create extracts on the selection screen (for more information, see General Data Selection [Seite 762]) if you execute a report group and choose the button Extract parameters... and then the mode Create extract. Alternatively, you can save your report output as an extract when you exit the report. In this case, the system displays a dialog box, asking whether you want to save the report in an extract file.

If you call up a report when Display extract is selected as the data source, the system checks whether any extracts are available that match the selection criteria. You can then choose from among the available extracts. You can also search for, display, and print extracts using extract management. In both cases, direct access is possible to all extracts generated within a variation.

Extracts are deleted either manually in extract management or automatically based on an expiration date that you can specify when you create the extract.

⚠️

Once an extract has been deleted, it cannot be retrieved.

For more information, see Creating an Extract [Seite 1010] and Managing Extracts [Extern].
Create Extract

Use
There are two different ways of creating an extract:

• You can create extracts on the selection by choosing Extract Parameters and then choosing Create Extract in the dialog box.

• You can generate an extract when executing a report. To do this, follow the steps under Procedure.

You can only create extracts in expert mode. Make sure that expert mode has been activated. You can make these settings from the selection screen by choosing Environment → Options.

Procedure

8. Enter the required report group and choose .

9. Enter the required selection parameters and choose .

If extracts already exist for the selection criteria you have specified, the system will display a list of extracts that you can choose.

6. The report is now displayed. Choose Report → Save. In the Enter: Extract Parameters dialog box, you can define the parameters for your extract. For further information about extract parameters, see Expert Mode. To complete your entries, choose .
Managing Extracts

Use
When you save reports in extracts, you can then access the data at any time without having to select the data from the database.

You can use extract management to:

• Display extracts
• Print extracts
• Change the extract priority
• Change the expiration date of an extract
• Delete extracts

⚠️
After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Prerequisites
You have saved your reports in extract files. For more information, see Creating an Extract [Seite 1010].

Procedure

3. On any Create/Change/Display/Execute Report Group screen, choose Utilities → Extracts → Display or Delete or Print or Change expiry date, depending on the function you want to use.


   ![Report Writer: Extract Management screen](image)

   You can also access extract management from the screen Execute Report Group: Initial Screen using the button Data extracts when you execute a report group from the first selection screen with Environment → Extract directory...

4. Enter the criteria according to which the extracts should be selected:
   • If you are searching for a particular extract, enter the description of the extract.
   • Specify whether extracts should be displayed that were generated by your or by a particular user, or whether all extracts should be displayed regardless of the user.
   • Specify when the extracts were generated, or whether all extracts should be generated regardless of the date.
   • You can select the extracts of a particular report group [Seite 937] or report group range.
   • You can select the extracts according to their priority, and restrict the selection to unread extracts.
Managing Extracts

- If you want to further restrict the selection criteria (for example, according to a specific characteristic or group of characteristics), choose Additional selections and enter the criteria. You can expand the number of selection conditions as required, and delete selection conditions you entered.

5. Choose .

The system displays a list of extracts that meet the selection criteria you entered.

6. Select the desired extract and choose one of the following functions:
   
   e. Display extract
      
      Choose .
   
   f. Print extract
      
      You can print extracts immediately or in the background.
      
      - To print the selected extracts, choose Extracts and enter the output device and other parameters for print control.
      
      - To print in the background, choose Background and specify when the job should be started.
   
   i. Change the extract priority
      
      Choose and change the priority of the extract.
   
   j. Change expiration date
      
      You can change the expiration date that was specified when the extract was created.
      
      Choose . If you want the extract to be deleted automatically after a specified time, enter the number of days in the dialog box Change expiration date under Expires in or choose Expires on and enter an expiration date.
      
      If you don’t want the extract to be deleted after a specified time, choose No expiration date. This is appropriate when the report is required for an undeterminable length of time or the report takes a long time to execute.
      
      Choose to exit the dialog box and save your entries.
   
   k. Delete extract
      
      Once an extract has been deleted, it cannot be retrieved.
      
      Choose to delete extracts. If you answer the question whether the selected extracts should be deleted with Yes, the extracts are deleted.
      
      For information on settings for extract management, see the Implementation Guide for Cost Center Accounting under Information System → User Settings → Specify Settings for Extract Management.
Example Process: Report Callup with Extract Management

Purpose

At the end of each month, the reports (important to cost center managers in the entire organization) are executed, and the data is stored in extracts [Extern]. Reports that contain data for individual cost centers [Extern] or cost center groups [Extern] are executed using variation, so that a separate report can be created for each cost center and cost center group.

You can set the user parameters for your cost center managers so that they can automatically access the most current extracts.

When calling up a report from the report tree, each manager receives the relevant individual data. The manager does not need to select the data from the database again, which reduces the workload of the system.

The cost center manager cannot navigate to areas within the extracts that do not belong to the authorized CO-OM responsibility area.

The system administrator who sets up these reports needs to have authorization to select the data from the database. However, this does not authorize the administrator to display the data in those reports.

The cost center managers need authorization to display the reports for their CO-OM responsibility area. However, this does not entitle them to select the data from the database or to create extracts.

The following graphic displays the way in which a report is executed in extracts, in the background with the variation. It also shows how you can save it in extracts.
Process Flow

9. Initial setups include creating the authorizations for system administrators and cost center managers [Extern].

10. The system administrator arranges for all the reports to be accessible to all users in EUROs. The system administrators execute the report (such as the Cost Centers: Actual/Plan Variance report) in the background and with the variation, and save the report in extracts (see: Executing a Cost Center Report with Variation and Saving it in Extracts [Extern]).

11. The system administrator makes the settings for extract management for the cost center managers in Customizing (see: Specifying Settings for Extract Management [Extern]). In their user-specific settings, the cost center managers save their selection criteria for the reports they want to display (see Customizing for Controlling under Cost Center Accounting → Information System → User Settings → Specify User Settings [Extern]).

12. The cost center manager accesses the report (see: Calling Up Cost Center Reports [Extern]).

This procedure is shown in more detail in the following sections using the Cost Centers: Actual/Plan/Variance report.

Result

Each cost center manager can quickly and easily display the relevant reports required.
Example Process: Report Callup with Extract Management
**Layout**

**Purpose**

In Report Painter and Report Writer reports, you can modify the layout of your report at different levels.

**Features**

The layout parameters for the report output are determined by the standard layout [Seite 1017] assigned to the report. This includes the page format of the report and the numerical format of the report data.

A section layout [Seite 1028] can be defined separately for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

You assign an individual report layout [Seite 1029] to each report. Initially, each report receives the standard layout SAP. You can assign an individual section layout to each section in the report. The standard layout then only applies to the sections to which no section layout was assigned.

The section layout and the report layout allow you to define layout settings such as form printout or the width and position of the lead columns separately for each section.

Specify whether it should be possible to change and save the layout parameters in the report output:

- If you do not select Change alwd dur exctn, the layout parameters cannot be changed when the report is executed.
- If you deselect Change alwd dur exctn, the layout parameters cannot be changed when the report is executed.

For more information, see Parameters for the Standard Layout [Seite 1022].

You can change the report’s layout parameters under Settings → Report layout.

If you change the layout parameters, but then decide that you want to reuse the default values from the standard layout, you can do so by choosing Settings → Report layout → Use standard layout.
Standard Layouts

Use

You assign a standard layout to each report that you create. This standard layout determines the layout features of the report, such as the page format of the report and the numeric format of the report data. The system assigns a default standard layout called SAP to each report. You receive the SAP standard layout with each SAP R/3 System. The standard layout provides a default value for every layout parameter.

Features

Report Painter

When a layout is assigned in the Report Painter [Seite 726], the layout parameters are copied from the standard layout to the report layout. There is no permanent reference to the standard layout. Thus, changing the standard layout has no effect on the report layout.

In the report layout, you can recopy the layout parameters of the standard layout with the button Use standard layout.

Report Writer

Before a report layout has been defined for a Report Writer [Seite 797] report, a link exists between the report layout and the standard layout for all parameters. With the button Define report layout, you can create an independent report layout that is a copy of the standard layout. With Report Writer reports, the button Use standard layout restores the link to the standard layout. In this case, changes made to the standard layout would affect the report layout.

When you define a report, you can do any of the following:

- Use the SAP standard layout for the report
- Assign a different standard layout to the report
- Revise the standard layout parameters so that the parameters are specific to the report

In the report definition, you can assign a standard layout to the report in the report header. These settings then take effect for that report. You will find more information on headers for the Report Painter under Defining Report Headers [Seite 765] and for the Report Writer under Defining Report Headers [Seite 817].

There are two ways in which you can use the standard layout settings in a report:

- Execute the report and then choose Settings → Report layout → Use standard layout
- In the report definition (Change Report), choose (for Report Painter reports) Edit → Report header. Here you need to enter a different standard layout (such as SAP) and then reenter the standard layout you require.

The indicator Change allwd dur exctn allows you to save any changes you make to the layout when executing the report. Set this indicator in the report layout.

If you only change the indicator in the standard layout, the change will only be effective in the Report Painter report if you reassign the standard layout to the report.
Standard Layouts

For more information about assigning a standard layout to a report and changing report parameters, see Defining Report Layouts [Seite 1031].

The standard layout is used in all sections to which no section layout [Seite 1028] is assigned.

For more information on processing and changing the standard layout, see:
- Creating a Standard Layout [Seite 1019]
- Displaying a Standard Layout [Seite 1024]
- Changing a Standard Layout [Seite 1025]
- Deleting a Standard Layout [Seite 1027]
- Parameters for the Standard Layout [Seite 1022]
Creating a Standard Layout

Use
When you first define a report, the default standard layout assigned to the report is always SAP. SAP appears in the Standard layout field at the top of each report parameters screen. This standard layout is shipped with your SAP R/3 System.

When you define a standard layout, you can assign parameters to format groups for certain fields. For parameters that are assigned format groups, you can define up to six different versions of the parameter. Each row and column in a report can use a unique format group. For more information, see Setting Format Groups in Sets [Seite 910].

Procedure
6. Enter the following information:
   – The name of the standard layout you want to create
   – The name of the existing standard layout you want to copy
7. Choose Continue.
   The Create Standard Layout screen appears.
8. Enter the following information:
   – Description of the standard layout
   – Authorization group for the standard layout. This authorization group is defined in the user's profile.

   Suppose you define an authorization group called AUTH. If you assign this authorization group to a standard layout, only users with this authorization group can change, display, and/or delete this standard layout for their reports.

Using the tab pages you can make the changes to the layout that you require. The following table gives you an overview of the different possibilities that you have for defining the standard layout parameters. Each function is assigned to the respective tab page index.

<table>
<thead>
<tr>
<th>Function</th>
<th>Tab page index</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting the column headings</td>
<td>Column headings</td>
</tr>
<tr>
<td>Defining area for the totals output</td>
<td>Rows</td>
</tr>
<tr>
<td>Setting width and position of lead column</td>
<td>Lead column</td>
</tr>
<tr>
<td>Defining detail level for row totals</td>
<td>Rows</td>
</tr>
</tbody>
</table>

Defining the Standard Layout Parameters
## Creating a Standard Layout

<table>
<thead>
<tr>
<th>Setting number of decimal places</th>
<th>Representation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defining unit</td>
<td>Representation</td>
</tr>
<tr>
<td>Setting colors</td>
<td>Graphics</td>
</tr>
<tr>
<td>Using form printout</td>
<td>Rows</td>
</tr>
<tr>
<td>Setting graphic type</td>
<td>Graphics</td>
</tr>
<tr>
<td>Defining content of lead column</td>
<td>Lead column</td>
</tr>
<tr>
<td>Defining content of column headings</td>
<td>Column headings</td>
</tr>
<tr>
<td>Allowing changes to layout parameters during execution of the report</td>
<td>Page/control</td>
</tr>
<tr>
<td>Output of zero values</td>
<td>Representation</td>
</tr>
<tr>
<td>Suppressing zero columns</td>
<td>Columns</td>
</tr>
<tr>
<td>Printing or hiding zero rows</td>
<td>Rows</td>
</tr>
<tr>
<td>Indenting lead column</td>
<td>Lead column</td>
</tr>
<tr>
<td>Repeating lead column</td>
<td>Lead column</td>
</tr>
<tr>
<td>Setting page format</td>
<td>Page/control</td>
</tr>
<tr>
<td>Printing selection log at end of report</td>
<td>Page/control</td>
</tr>
<tr>
<td>Setting scaling</td>
<td>Representation</td>
</tr>
<tr>
<td>Setting column break character underline</td>
<td>Column headings</td>
</tr>
<tr>
<td>Defining column layout</td>
<td>Columns</td>
</tr>
<tr>
<td>Setting column break character</td>
<td>Columns</td>
</tr>
<tr>
<td>Assigning a language</td>
<td>Language dependent</td>
</tr>
<tr>
<td>Using standard colors</td>
<td>Page/control</td>
</tr>
<tr>
<td>Suppressing duplicated totals</td>
<td>Rows</td>
</tr>
<tr>
<td>Marking totals</td>
<td>Rows</td>
</tr>
<tr>
<td>Defining position of totals items</td>
<td>Columns</td>
</tr>
<tr>
<td>Defining text type for the row text description in the lead column</td>
<td>Lead column</td>
</tr>
<tr>
<td>Displaying undeterminable values</td>
<td>Representation</td>
</tr>
<tr>
<td>Setting +/- sign</td>
<td>Representation</td>
</tr>
<tr>
<td>Defining +/- sign editing</td>
<td>Rows</td>
</tr>
</tbody>
</table>

For more information on the layout parameters, see Parameters for the Standard Layout [Seite 1022].

You can use the following additional functions from the Create Standard Layout screen:

### Additional Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
</table>
### Creating a Standard Layout

| Display directory of existing standard layouts | Utilities → Catalog... |
| Export standard layout to an external file (see Exporting Report Writer Objects [Seite 916]) | Utilities → Transport → Export |
| Import standard layout from an external file (see Importing Report Writer Objects [Seite 918]) | Utilities → Transport → Import |

6. To save the standard layout header, choose *Standard layout → Save.*
Parameters for the Standard Layout

The standard layout provides a default value for all the layout parameters that you can change.

When creating the standard layout you can overwrite the default parameter values on the following tab pages:

- **Page/control**
  
  The page format parameter values determine the layout of a report when it is output. 
  
  *Page control* (to determine if you can change the layout parameters in the report output and if you want to print the selection log at the end of a report). For *Margins* you can define parameters for the top, bottom, right and left margins and in *Print sequence* you can choose between printing by column or by row. With *Color settings* you can specify that the standard SAP colors be used for the report output.

- **Rows**
  
  With *Summation level* you define the level of detail to be used for the row totals. With *Totals item* you specify where the totals are to be output, for example above or below the detailed report results. For *Treatment of zero rows* you define whether zero rows are to be printed or hidden, or whether you want to use form printout. You can also mark totals and suppress duplicated totals.

  You can deactivate *+/− sign editing*, or activate it for all columns or for a certain column.

- **Lead column**
  
  With these layout parameters you define the content of the lead column (description, key and description, characteristic name and key, key). You can also determine the text type that is to be used for the row text in the lead column. You can choose between short text, long text, or a text that is proposed automatically by the system. If there is no short text in the master data, the system uses the corresponding long text.

  With *Indentation* you can specify the number of spaces the lead column is to be indented by.

  In the group box *Lead column* you can define the width and position of the lead column.

  In the group box *Miscellaneous* you can activate the underscoring of the text and the repetition of the lead column.

- **Columns**
  
  *Totals position* (to determine if totals columns are positioned to the left or right of the columns containing the corresponding detail values).

  In the group box *Column break character* you specify the type of column break character to be used. In the group box *Treatment of zero columns* you can select that the zero columns be suppressed. In the group box *Layout* you define the column width and the right margin.

- **Column headings**
  
  With these layout parameters you define the *Content and Orientation* (left-justified, centered, right-justified) of the column headings. In the group box *Miscellaneous* you can define that the column break character be underlined.

- **Representation**
With these layout parameters you define how the numerical format is to be displayed. You can determine the number of decimal places and the scaling, as well as make specifications concerning the +/- sign and the units. You can also specify how the zero values and undeterminable values are to be displayed.

Undeterminable values appear in a report when values with different currency units or units of measure are totaled. You can display these values in your report with a space or using a symbol.

- **Language dependent** (language-dependent parameters)

  With these parameters you can assign different values for decimal display, +/- sign and date to different languages. With *Other languages* you can switch to another language to enter the language-dependent parameters. When you execute the report’s report group, the Report Writer uses the value of the logon language.

- **Graphics**

  With these parameters you determine the graphic type that you want to use. The color palette determines the color palette that is to be used for the business graphic. For more information on calling the report graphics from the executed report, see [*calling report graphics*](#).

For more information, see [*creating a standard layout*](#).
Displaying a Standard Layout

   The Display Standard Layout: Initial Screen appears.

5. In the Standard layout field, enter the name of the standard layout that you want to display and choose Continue.
   The Display Standard Layout screen appears.

6. On this screen, you can use the additional processing functions in the table in Creating a Standard Layout [Seite 1019], as well as the Extras → History function to display the revision history of the standard layout.
Changing a Standard Layout

Prerequisites
Changes you make to a standard layout will affect other users’ reports that use that standard layout.

You should only change a standard layout if the change is required for all reports that use that standard layout. If changes are only needed for one report run or for a specific report, you should change the report parameters using the Layout functions on the Change Report: Initial Screen. For more information, see Defining Report Layouts [Seite 1031].

The layout parameters are copied from the standard layout into the report layout. There is no permanent reference to the standard layout. When you create a report, the layout settings are copied from the standard layout into the report layout.

If the standard layout is changed, the layout parameters in the report are not updated automatically.

Do not change the standard layout (SAP) that is delivered with your SAP R/3 System.

Procedure


   The Change Standard Layout: Initial Screen appears.

7. In the Standard layout field, enter the name of the standard layout you want to change and choose Header.

   The Change Standard Layout: Header screen appears.

8. On this screen, you can use the additional processing functions in the table in Creating a Standard Layout [Seite 1019], as well as the Extras → History function to display the revision history of the standard layout.

9. Type over current values with your changes.


Suppose you give the report the standard layout SAP and then change the report width to 60. Then you assign a different standard layout to the report. The report width remains at 60, since it is a change that you made that is specific to the report.

For information on transferring the settings of the standard layout to a report, see Standard Layouts [Seite 1017].
Changing a Standard Layout

If the standard layout is changed, the layout parameters in the report are not automatically updated. The indicator "Change allwd dur exctn" allows you to save any changes you make to the layout when executing the report.

Select the "Change allowed during execution" indicator only in the report header.

If a user has authorization to change a report, he can change this indicator in the report output with Settings → report layout → Page/control → Change allowed during execution. Another place you can change the setting of this indicator is in the report definition with Report header. If you only change the indicator "Change allowed during execution" in the standard layout, the change will only be effective in the report if you reassign the standard layout to the report.
Deleting a Standard Layout

   The Delete Standard Layout: Initial Screen appears.

4. In the Standard layout field, enter the name of the standard layout you want to delete.

4. Choose Delete.
   A dialog box asks if you want to delete the standard layout.

   You cannot delete a standard layout that is being used in a report. You cannot delete the SAP standard layout delivered with the SAP R/3 System.

5. Choose Yes.
   The standard layout is deleted. You cannot restore a standard layout once it has been deleted.
Section Layout

Use
There are a number of different ways you can modify the layout of the sections in a report:

- You can apply the parameters specified in the report layout
- You can apply a section-specific layout

Features
You can use a different layout for each section. Section layouts contain control information on:

- Row totals
- Row texts
- Column texts

You can also apply the report layout [Seite 1029] to sections. Any changes you make to the report layout then become effective automatically in the sections where it was applied.

The section layout can be defined differently for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

In the section overview in the Report Painter, you can change the attributes of the sections, the sequence of the sections, and the page breaks between the sections. This includes overscores and underscores, and how the headers should be printed.

For more information on formatting, see Summation Levels [Seite 1034].
Report Layout

Use
You can assign a report layout to each report that you create. The report layout defines the layout features of the report, such as the page format of the report and the numeric format of the report data. When you use the Layout functions, you can set parameters for the report.

Features
You have two options for assigning a layout:

- Report Writer: link to standard layout [Seite 1017]
  Report Painter: copy of standard layout (may not be current)
- A separate report layout that is not linked to the standard layout

The report layout establishes layout parameters that apply to the whole report (such as the page layout). It also contains parameters that can be defined separately for each section (such as summation levels [Seite 1034]). These section-specific parameters defined by the report layout are valid only for report sections that do not have their own section layout [Seite 1028].

For more information, see Displaying Report Layouts [Seite 1030] and Defining Report Layouts [Seite 1031].
Displaying the Report Layout


For more information on additional functions that are available on this screen, see Functions in the Report Output [Seite 974].
Defining Report Layouts

Use
For each report that you create, you can assign a report layout. Via the report layout you define the layout features of the report, such as the page format of the report and the numeric format of the report data. When you use the Layout functions, you can set parameters for the report.

You received the SAP standard layout with your R/3 System. This standard layout is automatically assigned to each report you create. If you want to use the SAP standard layout, you can skip the following steps and go directly to defining rows [Seite 841]. When you first define a report, the default standard layout is always SAP. SAP appears in the Standard layout field at the top of each report layout dialog box.

When you define a report layout, you can define a layout specifically for a report and you can change the standard layout assigned to a report.

Procedure
2. To define a report layout, choose Goto → Report layout and work with the following tab pages:
   - Page/Control: Here you define general page format parameters, such as the length and width of a page
   - Rows: Here you define row total parameters, such as the positioning and summation levels for report row totals
   - Lead column: Here you define row text parameters, such as the text type and row length
   - Columns: Here you define the type of column break and the treatment of zero columns
   - Column headings: Here you define orientation of the column headings, such as the position and layout of the columns
   - Representation: Here you can define the numerical formats
   - Language dependent: Here you define the language dependent report parameters
   - Graphics: Here you define the graphical presentation and color palette

You can switch between the change mode of your report layout and the default parameters of the standard layout using the pushbutton Use standard layout or Define report layout. To change a parameter so that the standard layout value is not used in a report, you type over the current value. The value is not changed in the standard layout; it is only changed for that specific report.

5. Type over current values with the values you want to use for the report layout.
6. Choose Continue.
7. To save the report layout parameters, choose Report → Save.
Defining Report Layouts

Changes that you make to the report layout parameter values do not affect the standard layout values that are stored in the system. The report parameter values that you enter only affect the specific report that you are working on.

You can change standard layouts for reports; however, any changes you make affect other users’ reports. For more information, see standard layouts [Seite 1017].

For more information on the standard layout screens or for information about changing the standard layout, see creating a standard layout [Seite 1019].

For information on how to change the standard layout assigned to a report, see changing a standard layout [Seite 1025].

The system determines which format group to use based on the format group defined in the sets that are used in the report definition. Some report parameters can be defined using six variants of the parameter. These variants correspond to the format groups 0 through 5. Depending on the value entered in the format group field for a set, the Report Writer selects one of the six values. For more information on format groups, see setting format groups in sets [Seite 910].
Saving Changed Report Layout Parameters

Use

When processing a report in expert mode, such as when executing a report group [Seite 962], you can make changes to the report layout and save them.

Procedure

4. When executing a report, choose from the report output screen Settings → Report layout. A dialog box appears where you can overwrite the layout parameters.

5. Make any required changes to the report layout.

6. To save the changed layout parameters, you can choose from the following alternative functions:

   • To save the changes, choose Settings → Save settings.

   • To save the layout changes you made and then block all users from making layout changes in the report, choose Settings → Save and block settings. The system automatically deselects the Change allwd dur exctn indicator in the Page/Control layout parameters. If you need to remove the block, choose Change report, then Formatting → Report layout. On the tab page Page/control in the group box Control data, select the indicator Change allwd dur exctn.

SAP recommends that you save your report data as an extract [Extern]. This allows you to call up your report at any time and the system does not have to reselect the data from the database. You can save the report as an extract using the Report → Save function. If you have not already saved the report as an extract, the system displays a dialog box, asking you whether you want to do so when you exit the report. For more information, see Extracts [Seite 1008], Creating an Extract [Seite 1010], and Managing Extracts [Seite 1011].
Summation Levels

Use

In Report Painter reports and Report Writer reports you can use sets [Extern], groups, or set variables to display a hierarchy in the rows. The totals rows in a report are represented by summation levels.

Features

Each summation level is represented by one or more asterisks. In the report definition, you can specify in the layout that this hierarchy should be marked with special characters. You activate this function with Settings → Layout → Row totals → Mark totals.

In the layout, you can specify whether you can choose the position of the totals (top or bottom) in the display.

For more information, see Layout [Seite 1016].

The number of masking characters within a report depends on the number of hierarchy levels. Row totals at the lowest level in a hierarchy display with one asterisk. Individual values receive the summation level zero (no masking characters).

Hierarchy Levels and Their Representation by Masking Characters

<table>
<thead>
<tr>
<th>Hierarchy Level</th>
<th>Number of Masking Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Highest level of hierarchy</td>
<td>n</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-1</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-2</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-3</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-4</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Lowest hierarchy level</td>
<td>n-(n-1) = 1</td>
</tr>
<tr>
<td>Single values</td>
<td>No masking character (n-n)</td>
</tr>
</tbody>
</table>

There are two types of hierarchies:

- Balanced hierarchy

  If values exist for all levels and branches of the hierarchy, the hierarchy is balanced. A balanced hierarchy looks symmetrical.
• Unbalanced hierarchy

Which hierarchy level is the highest depends on which levels have values. The individual branches of the hierarchy can differ considerably from one another, resulting in an asymmetrical hierarchy.
Summation Levels

Summation Level with Unbalanced Hierarchy
If not every level of the hierarchy has a value, the maximum summation level can take on widely different values.

- If the hierarchy consists only of Set 1, Set 12 and values, Set 1 will have the maximum summation level **.
- If the hierarchy consists of Set 1, Set 12 with values, Set 13, Set 131 with value, and Set 132 with Set 1311 with values, Set 1 will have the maximum summation level ****.

The method for determining the maximum summation level always starts at the lowest set level.

Summation Level with Balanced Hierarchy
With a balanced hierarchy, the maximum summation level is always the same, regardless of the selected data.

Summation Levels in Report Layout/Section Layout
When you set the summation level in the report layout or section layout of reports with an unbalanced hierarchy, you should take into account how the maximum summation level is determined, as described above.

Different hierarchy levels will be displayed, depending on the selected data.

In the above examples for the summation level with an unbalanced hierarchy, if you specify the interval 2 to 3 for the summation level, the result is:

- For the first example: Set 1 **
- For the second example: Set 12 ***, Set 13***, Set 131**, Set 132**

You can avoid this discrepancy by inserting dummy nodes into the unbalanced hierarchy to balance it. This results in additional rows in the report, which you can hide with the layout setting Suppress duplicated totals.
Terminology

Reporting terminology has been standardized across all modules. For this reason, some reporting terms had to be replaced by new, standard terms that are valid across the whole SAP System. The following table lists the original terms (sorted alphabetically) with the new term and a description to give you an overview of the terminology changes.

Terminology changes in reporting

<table>
<thead>
<tr>
<th>Original Term</th>
<th>Current Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing class</td>
<td>Format group</td>
<td></td>
</tr>
<tr>
<td>Basic key figure</td>
<td>Basic key figure</td>
<td></td>
</tr>
<tr>
<td>Data field (Report Painter)</td>
<td>Basic key figure</td>
<td></td>
</tr>
<tr>
<td>Data selection</td>
<td>General data selection</td>
<td></td>
</tr>
<tr>
<td>Data set (Report Writer)</td>
<td>Key figure set</td>
<td></td>
</tr>
<tr>
<td>Data set entry (Report Writer)</td>
<td>Key figure</td>
<td>Predefined, business key figure</td>
</tr>
<tr>
<td>Dimension</td>
<td>Characteristic</td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Characteristic</td>
<td></td>
</tr>
<tr>
<td>Key figure (Report Painter)</td>
<td>Basic key figure</td>
<td></td>
</tr>
<tr>
<td>Column text</td>
<td>Column heading</td>
<td></td>
</tr>
<tr>
<td>Column text type</td>
<td>Content</td>
<td>Column heading content</td>
</tr>
<tr>
<td>Statistics</td>
<td>Selection log</td>
<td></td>
</tr>
<tr>
<td>Text column</td>
<td>Lead column</td>
<td></td>
</tr>
<tr>
<td>Vary</td>
<td>Multiple selection</td>
<td></td>
</tr>
<tr>
<td>Predefined column (Report Painter)</td>
<td>Key figure</td>
<td>Predefined, business key figure</td>
</tr>
<tr>
<td>Row text</td>
<td>Lead column</td>
<td></td>
</tr>
<tr>
<td>Row text type</td>
<td>Content</td>
<td>Lead column content</td>
</tr>
</tbody>
</table>

For more information on these subjects, see Report Painter [Seite 726], Report Writer [Seite 797] and key figures [Seite 708].
Drilldown Reporting Tool

Use

The drilldown reporting tool [Extern] enables you to evaluate FI-SL summary tables. You can create and print reports.

Integration

You can process data from various SAP components.

Features

You can create the following reports:

- Account balances
- Financial statement reports
- Line item reports called up from the totals report
- Flexible reports on the SAP account assignments and the customer-specific additional account assignments.

You can define drilldown reports in Customizing. There you make the required settings for evaluating FI-SL summary tables. For more information, see the Implementation Guide under Financial Accounting → Special Purpose Ledger → Information System → Drilldown Reports and the activity Activate Drilldown Reporting for FI-SL Tables [Extern].

For more detailed information about drilldown reporting, see the SAP Library under Cross-Application Components → CA - Drilldown Reporting Ledger [Extern].
Tools

Purpose
The FI-SL system offers a wide array of different tools that you can use to create reports, check and test settings, and trigger evaluations, validations, and substitutions. You can create sets, check the posting structures in your system, and display the contents of your FI-SL direct posting tables.

Integration
The FI-SL tools are used in the various areas of the FI-SL System:
In reporting - Report Painter [Seite 726] and Report Writer [Seite 797]
With Validations, Substitutions and Rules [Seite 1038]
In Allocation [Seite 173]
In Planning [Seite 72]
With Rollups [Seite 251]
During Currency Translation [Seite 302]
When selecting ledgers

Features
FI-SL contains the following tools to help you improve your system performance and setup:

Sets
Sets are used throughout the FI-SL System as the building blocks for many of the FI-SL modules. In FI-SL, you use sets to group together data and to define data hierarchies. Under a set name, you can store specific values or ranges of values. These values exist within one dimension.

There are four different types of set. These are Basic Sets [Seite 639], Data Sets [Seite 641], Single-Dimension Sets [Seite 643], and Multi-Dimension Sets [Seite 645]. Using these set types, you can create a Set Hierarchy [Seite 635] with as many levels as you require.

You can create a basic set [Extern] that uses the dimension cost center. You can then enter specific cost center numbers in the basic set.

For more information, see Sets [Seite 633].

Report Painter and Report Writer
The FI-SL-System reporting tools Report Painter and Report Writer are used for creation of reports on totals information from various applications.

For more information, see Report Painter / Report Writer [Seite 723], Report Painter Reports [Extern], and Report Writer Reports [Seite 804].

Diagnosis Tool
Tools

You use the diagnosis tool when you want to test your system setup and determine how and where a document will post or has posted to the FI-SL System. You can then determine why a specific document is not posting to a ledger.

For a specific document number, company code, and fiscal year, you can use this online function to check to which ledgers the document posted or will post. You can also check to which ledgers a specific activity (such as RFBU for FI postings) will post to FI-SL.

For more information, see Using the Diagnosis Tool [Seite 1175]

Control Report Tool

You use the control report tool when you want to display and/or print the contents of the FI-SL direct posting tables (ATAB tables). FI-SL posting tables are defined in Customizing. These tables control how documents are posted into the FI-SL system.

Once you have installed your system, you can use this tool to check your system structures before implementing your productive system.

For more information, see Using the Control Report Tool [Seite 1179].

Ledger Statistics Tool

You use this tool to display the number of records that have posted for a ledger, as well as the database tables to which records have been posted.

For more information, see Using the Ledger Statistics Tool [Seite 1174]

Drilldown Reporting Tool

You can use this tool to evaluate FI-SL summary tables and create reports. For more information, see Drilldown Reporting [Seite 630].

Validations, Substitutions, and Rules

In Customizing for Special Purpose Ledger, you can also use tools for checking, transporting, validating, substituting, deleting, and comparing data. For more information, see Validation, Substitution, and Rules [Seite 1038]. See also the IMG for Special Purpose Ledger.
Sets

Purpose
A set [Extern] is used to group data and to define data hierarchies. A set links together specific values or ranges of values under a set name. These values exist within one or more characteristics of a database table. A characteristic is a single field or column of a logical database (table). Account, cost center, and business area are examples of characteristics.

Using sets, you can group together values within a particular characteristic.

For the Account characteristic, you can collate values under the following set names: ASSETS, LIABILITIES, SALES, EXPENSES and EQUITY.

Sets are easy to create and maintain, and they give you more flexibility when maintaining your system. Also, with sets you do not have to maintain master data or tables. Advantages of sets include:

Single definition
You define a set once, as an independent object.

Multiple usage
You can use the same set in many other different modules. For example, if you create a set for reporting, you can also use the set for allocations [Extern].

Flexible processing
When you add a new value to a set, the value is automatically stored in the system.

You can create a set that contains a range of accounts, such as all cash accounts. You can then use the set in a report. If you add a new account to your system, you do not need to change the set or report definition; you only need to execute the report.

Efficient and unique structuring of values
With sets, you can organize your system values into logical groups and hierarchies according to your individual needs.

Table-independent usage
You can use sets for all characteristics (table fields) that use the same or compatible data elements.

In FI-SL, for example, you can use groups that have been created in the Controlling (CO) application component if the characteristic is compatible with the characteristic of the CO group.

You create a report for table GLFUNCT and want to enter accounts in the report rows. You could enter a cost element group as the row block (table CCSS,
characteristic KSTAR). In this case, characteristic CCSS-KSTAR is compatible with characteristic GLFUNCT-RACCT.

**Integration**

You can use sets and set values in other Special Purpose Ledger (FI-SL) sub-components, such as:

In reporting ([Report Writer][Seite 797]) In a Report Writer report the row structure, column structure and the general data selection are defined using sets.

In [allocations][Seite 173]
In [planning][Seite 72]
In [rollups][Seite 251]
During [currency translation][Seite 302]
For [Boolean Logic/syntax][Seite 1120]

For more information on sets, see [uses of sets][Seite 647].

**Features**

When you create sets, you decide how to organize set structures and which values should be included in a set. You can use the following types of sets:

- [Basic sets][Seite 639]
- [Data sets][Seite 641]
- [Single-dimension sets][Seite 643]
- [Multi-dimension sets][Seite 645]

For more information, see [set types][Seite 638] and [set hierarchies][Seite 635].

A set consists of the following parts:

- **Set name** (max. 24 characters)
  - In FI-SL the set name uniquely identifies the set.

- **Set header information** (such as the database table and characteristic that the set uses, the set description, and symbolic name)
  - This information applies to all values within the set.

- **Set values** (such as specific accounts or cost centers or other sets)
  - Set value information also includes data that is used by the Report Writer (such as symbolic names, format groups, and set row text).

In sets, you can use [formulas][Seite 686] to perform calculations within the set. For more information, see [variables][Seite 689] and [key figures][Seite 708].
Set Hierarchies

Use

When you create basic, single-dimension, data, and multi-dimension sets, you create the building blocks for a set hierarchy. Using single-dimension sets, you create a set hierarchy that links together sets with the same dimensions. Using multi-dimension sets, you link together sets with different dimensions.

You do not have to include all set types in a set hierarchy. For example, you could define a hierarchy of only basic sets within a single-dimension set.

Before you begin building a set hierarchy, you must plan the structure of your hierarchy and know how you will use the hierarchy. You should also know which dimensions, sets, and values you want to use in the hierarchy.

Features

When you create a set hierarchy, you create different levels of information. You can define up to 99 levels in a set hierarchy.

You can combine single-dimension sets and basic sets to create the multi-dimension set hierarchy in the following graphic. In the set CC-ACCT, the dimension "Cost Center" occurs first and the dimension "Account" is second. When you use the set CC-ACCT as a row of a report, overhead accounts are listed by account number within cost centers.

Example Set Hierarchy
Set Hierarchies

By moving the order of a value in a set, you can change the order of set values in a report or produce reports with the same information, but in different formats.

The following graphic contains the same sets as in the previous graphic; however the dimension “Account” occurs first in the set, and the dimension “Cost Center” is second. When this set is used as a row of a report, cost centers are listed within overhead accounts.

Changed Set Hierarchy
If you change a set, you do not have to change the definition of a report that uses the set; you only need to regenerate the report. For more information, see uses of sets in Report Writer [Seite 891].
Set Types

You can use the following types of sets:

**Basic sets**

These contain specific values, such as account and cost center numbers.

**Data sets**

These contain specific basic key figures (such as transaction and local currency). You can combine a basic key figure with one or more additional dimensions to create your own key figures.

**Single-dimension sets**

Single-dimension sets are used to create set hierarchies by combining basic sets and other single-dimension sets that use the same dimension.

As in basic sets you can also include values in single-dimension sets.

**Multi-dimension sets**

Multi-dimension sets are used to create set hierarchies with sets that use different dimensions.

For more information about the different set types, see:

- Basic Sets [Seite 639]
- Data Sets [Seite 641]
- Single-Dimension Sets [Seite 643]
- Multi-Dimension Sets [Seite 645]
Basic Sets

Definition

A basic set contains values from one dimension. If you define a basic set for the dimension Account, all values in the set must be accounts.

Values in a basic set can be single values and/or a range of values. If you add a new value to your system, and the value is included in a range of values already defined in a set, the new value is already included in the set.

You create a set that contains a single account number of 1000010 and a range of account numbers, 1000020 to 1000050. If you add a new account number to your account master files, such as 1000030, the new number is already included in the set.

When you add new master record values, the master record does not update sets. You must manually maintain set values, unless a new master record value is already included in a range of set values.

The following graphic shows the basic sets ASSETS, LIABILITIES, OHD-ACCT (dimension Account), CENTERS (dimension Cost Center), BUS-AREA (dimension Business Area) and YEAR (dimension Year).
Each of the basic sets contains different values. Each of the basic sets also uses different dimensions except for the ASSETS, LIABILITIES, and OHD-ACCT sets, which use the dimension Account. If you want to keep your asset and liability accounts separate (as shown in the above graphic), you would need to create two sets that use the same dimension.

If you use the set ASSETS in a report, you could, for example, create a simple report that lists the assets for a company.
Key Figure Sets

Definition

A key figure set is similar to a basic set because it contains specific set values. However, a key figure set contains specific key figures. A basic key figure refers to a numerical value field stored in a database table. You can combine a basic key figure with one or more additional characteristics entered in a set to create a key figure. The set determines additional selection conditions, such as the record type (actual or plan data) and the plan version.

Examples of basic key figures used in key figure sets include:
- Transaction currency
- Local currency
- Group currency
- Quantity

Examples of additional characteristics that can be combined with a basic key figure include:
- Actual amount (record type)
- Plan amount (record type)
- Allocated actual (record type)
- Allocated plan (record type)
- Year
- Period

Key figure sets are only used by the Report Writer in reporting.

When you use a key figure set in a report, the system selects the currency/quantity and record type specified in the key figure set.

You create a key figure set that contains actual data (record type) in local currency (key figure). If you use the data set in a report column, the system displays actual data in local currency.

The following graphic shows the key figure sets ACT-GRP, PLN-QTY, and ACT-PLN-LC.
Each of the key figure sets in the above graphic contains different values (depending on the kind of data you want to use).

You can also create your own key figures. For more information, see creating/changing key figures [Seite 712].
Single-Dimension Sets

Definition

You use single-dimension sets to build hierarchies within a dimension. You create single-dimension sets by combining basic sets and/or other single-dimension sets that use the same dimension.

As in basic sets you can also include values in single-dimension sets.

You can combine the basic sets ASSETS and LIABILITIES because they use the same dimension - "Account".

In a single-dimension set, you can not combine sets that use different dimensions. You use multi-dimension sets to combine sets that use more than one dimension.

The following graphic shows a single-dimension set called BAL-SHEET, which contains the basic sets ASSETS and LIABILITIES (dimension "Account").

Use

If you use the above set in a report row, the report lists your asset accounts (1000010, 1000020-1000050) and then your liability accounts (2000010, 2000020-2000050).

The following graphic shows an example balance sheet that uses the single-dimension set BAL-SHEET in the report rows.
In the above graphic, the Report Writer uses the data set ACT-GRP to select data for the report. The report only contains actual data in group currency for the year 1995. The accounts in the report appear in the order defined in the single-dimension set BAL-SHEET (basic sets ASSETS and LIABILITIES). If you change the sequence of the values in the set, then the order of the values also changes in a report.

In the above graphic, assets are listed before liabilities. If you wanted to list liabilities before assets, you would change the single-dimension set BAL-SHEET, so that LIABILITIES is the first set in the single-dimension set.

<table>
<thead>
<tr>
<th>B/Sheet</th>
<th>1995</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000010</td>
<td>750,000,00</td>
</tr>
<tr>
<td>1000020</td>
<td>480,000,00</td>
</tr>
<tr>
<td>1000030</td>
<td>680,000,00</td>
</tr>
<tr>
<td>1000040</td>
<td>150,000,00</td>
</tr>
<tr>
<td>1000050</td>
<td>370,000,00</td>
</tr>
</tbody>
</table>

* Assets 2,270,000,00
  - 2000010 (650,000,00)
  - 2000020 (350,000,00)
  - 2000030 (270,000,00)
  - 2000040 (600,000,00)
  - 2000050 (200,000,00)

* Liabilities (2,270,000,00)

** B/Sheet 0,00
Multi-Dimension Sets

Definition

You use multi-dimension sets to create combinations of sets that use more than one dimension. You create multi-dimension sets using basic, data, and single-dimension sets.

You create a multi-dimension set (called CC-ACCT) that contains the basic set CENTERS (dimension Cost Center) and the basic set OHD-ACCT (dimension Account). This multi-dimension set contains cost centers 100, 200, 300, and 400, and accounts 3000010, 3000020, and 3000030 (see the following graphic).

Multi-Dimension Set CC-ACCT

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Multi-Dimension Set:</th>
</tr>
</thead>
<tbody>
<tr>
<td>CC-ACCT</td>
<td>BASIC SETS</td>
</tr>
<tr>
<td>COST CENTER</td>
<td>CENTERS</td>
</tr>
<tr>
<td>100</td>
<td>200</td>
</tr>
<tr>
<td>300</td>
<td>400</td>
</tr>
<tr>
<td>ACCOUNT</td>
<td>OHD-ACCT</td>
</tr>
<tr>
<td>3000010</td>
<td>3000020</td>
</tr>
<tr>
<td>3000030</td>
<td></td>
</tr>
</tbody>
</table>

You cannot combine multi-dimension sets. Also, a dimension can only appear once in a multi-dimension set.

For example, you cannot define a multi-dimension set that contains the basic set ASSETS and the basic set LIABILITIES (dimension Account). You should first define a single-dimension set that contains the basic set ASSETS and the basic set LIABILITIES, and then include the single-dimension set in the multi-dimension set.

Use

The primary use of multi-dimension sets is to combine sets with values from different dimensions to create set hierarchies.

You could define a multi-dimension set that contains the dimensions Business Area and Account (sales accounts). When you use the set in a report row, you could display the sales within each business area.
Multi-Dimension Sets
Use of Sets

Use

You can use sets and set values in other Special Purpose Ledger (FI-SL) sub-components, such as:
- Boolean Logic formulas
- Report Writer
- Allocations
- Planning
- Rollups
- Currency translation

Features

Sets in Boolean Logic Formulas

You can use sets in Boolean Logic formulas to refer the system to values that are contained in a set. (The set name is used in a Boolean Logic formula.)

You create a basic set called CENTERS that contains cost centers 100, 200, 300, and 400. You then include the set name CENTERS in a Boolean Logic formula:

```
CCSS=KOSTL IN CENTERS
```

If you use the Boolean Logic formula as a selection criterion, the system checks set CENTERS when selecting data. If the entered data is not for cost centers 100, 200, 300, or 400 in the CENTERS set, then it is not selected for posting to the ledger for which the selection condition was defined.

For more information, see types of FI-SL statements [Seite 1129].

Sets in Reporting

The Report Writer uses sets as the modules for report rows, columns, and for the data selected for a report. The set hierarchy corresponds to the hierarchy of row and column totals in a report.

You can use sets to create simple or complex reports.

For more information, see Sets in the Report Writer [Seite 891].

Sets in Allocations

You can use sets in allocations [Seite 173] to:

Select data records that are to be assessed or distributed (senders)

Determine the objects to which data is to be assessed or distributed (receivers)
Use of Sets

The CENTERS set contains specific cost centers. If you use this set as a receiver set, the relevant data is assessed or distributed to all of the cost centers in the CENTERS set.

For more information, see rules for selection criteria [Seite 192] and selection criteria [Seite 191].

Sets in Planning

You use sets in planning to determine the objects to be used for planning, and the order in which you enter planning data. When you use sets you can determine which accounts should be planned in a group of cost centers, and the order in which the accounts are planned.

For plan variant 01, you can specify that only accounts in the OHD-ACCT set that use cost centers in the CENTERS set can be used for planning. The accounts are planned in the order that they appear in the set OHD-ACCT.

For more information, see sets in planning [Extern].

Sets in Rollups

You use sets in rollups to select the data for summarization in the rollup ledger, and how this data is to be updated.

For example, you can use the set OHD-ACCT to specify that only overhead accounts are to be summarized in a rollup ledger.

For more information, see sets and rollups [Seite 254].

Sets in Currency Translation

You can also use sets to define currency translation methods.

You create a set that contains certain transaction types, such as acquisitions and depreciations. You then use the set to limit a currency translation method to only line items that contain the transaction types found in the set.

For more information, see currency translation [Seite 302].
Sets in the Report Writer

Use

The Report Writer uses sets to structure and select report data. Report structure and contents are defined according to the sets that are used for rows, columns, and selection criteria. These sets include basic, key figure, single-dimension, and multi-dimension sets.

You can use sets as:

- **A row block**
  
  The row block contains the characteristics that you want to include in the rows of your report (for example, cost center and account numbers).

- **A column block**
  
  The column block contains the characteristics that you want to include in the columns of your report (for example, periods, currencies, and amounts).

- **General selection criteria**
  
  The selection criteria contain the characteristics that you want to use to select the report data (for example, year, period, company, and ledger).

Before you can begin creating a report, you must first create the sets that the report will use. If the sets you need already exist in your system, you do not need to create new sets for a report. Also, since sets are not report-specific, you can use the same sets for more than one report.

You can only use a characteristic once in a report - in a row block, column block, or as selection criteria. For example, if a characteristic in a set is already used in a row block, you cannot use the characteristic in a column block.

But you can use the same characteristic in multiple row blocks or multiple column blocks. You can **not** use the same characteristic in a row block **and** a column block.

If you use the characteristic “account” in row block 1, you can also use the same characteristic in row block 2. However, you can **not** use the characteristic “account” in a row block **and** a column block.

This section contains:

- Defining Report Data [Seite 893]
- Using Sets in Report Rows [Seite 894]
- Using Sets in Report Columns [Seite 898]
- Suppressing Rows and Columns [Seite 899]
- Using Sets as Selection Criteria [Seite 900]
- Entering Set Text for Reports [Seite 901]
- Using Variables in Report Writer [Seite 903]
Sets in the Report Writer

Using Set Formulas in Report Writer [Seite 906]
Using Symbolic Names in Report Writer [Seite 909]
Setting Format Groups in Sets [Seite 910]

For more information on creating sets, see creating sets [Seite 651].
Creating Sets

Purpose
Sets are used in many components and subcomponents of the SAP R/3 System (such as reporting, planning, and currency translation). Before you can begin working with these components, you must first create the sets that you want to use.

Prerequisites
Before you create sets, you must decide how you want to use the sets to meet your business requirements. It is important that you determine how best to organize your set structures and which values you want to include in the sets.

For an overview of the different set types, see set types [Seite 638]. Basic rules for creating sets are as follows:

- Basic sets and single-dimension sets must use one dimension.
- Single-dimension sets are a combination of basic and single-dimension sets with the same dimension.
- As in basic sets you can also include values in single-dimension sets.
- Multi-dimension sets are a combination of basic, data, and single-dimension sets with different dimensions.

Process flow
To create a set, you perform the following steps:

1. Create the set header.
   - The information you enter in the set header applies to all values within the set.
   - For more information, see creating a set header [Seite 653].

2. Enter the set values.
   - The values you enter depend upon the type of set you are creating:
     - In basic sets, you enter specific values or ranges of values within one dimension. You can also enter all values defined for a specific dimension.
       - You can also include value and formula variables in a basic set when you want the system to prompt you for information when it uses the set. A variable is a placeholder for data to be specified when you run a report that uses the variable.
       - If you want to perform simple calculations within a set, you can enter formulas in basic sets.
       - If you create a basic set that is to be used by the Report Writer, you can enter data that the Report Writer uses for reports (such as symbolic names and format groups).
   - For more information, see entering basic set values [Seite 659].
Creating Sets

In **data sets**, you enter basic key figures and key figures for currencies and quantities. You can also enter data that the Report Writer uses for reports (such as symbolic names and format groups).

If you want to perform simple calculations within a set, you can also enter formulas in data sets.

For more information, see [entering data set values][1].

In **single-dimension sets**, you enter basic and single-dimension sets to build hierarchies with sets that use the same dimension.

As in basic sets you can also include values in single-dimension sets.

If you create a single-dimension set that is to be used by the Report Writer, you can also enter data that the Report Writer uses for reports (such as symbolic names and format groups).

For more information, see [entering subordinate sets in single-dimension sets][2].

In **multi-dimension sets**, you enter basic, data, and single-dimension sets to build hierarchies with sets that use different dimensions.

You can also enter set variables in a multi-dimension set. A set variable is a variable that represents a defined set. Set variables give you the flexibility to change set values when a set is used by another system function (for example, in reporting).

If you create a multi-dimension set that is to be used by the Report Writer, you can enter data that the Report Writer uses for reports (such as symbolic names and format groups).

For more information, see [entering multi-dimension set values][3].

Sets you created prior to Release 4.0 (Releases 3.x), are converted to these structures automatically. You do not need to recreate or change your existing sets.

However, the conversion program changes the names of the sets. The set names are followed by the suffix `.<table name>`.

In Release 3.0 or 3.1 you created a set for table GLT1 with the name **ACCOUNTS**. This set is automatically converted to a current set with the name **ACCOUNTS.GL1**. You should note, however, that you only need to enter the name **ACCOUNTS** (and not **ACCOUNTS.GL1**) when you use the set in the system. If there is more than one set called **ACCOUNTS**, the system displays a dialog box in which you select the appropriate set.
Creating a Set Header


The Create Set: Initial Screen appears.

Enter the following data:

- Set name
  
  You should not use a number as the first character of the set name.

  Beginning with Release 4.0, the set name can contain up to 24 characters for sets created in the Special Purpose Ledger (FI-SL) application component.

  Sets that you created in Releases 3.0 or 3.1 are automatically converted into the new set structures for Release 4.0. You do not need to recreate or change your existing sets. The new sets are fully compatible with Release 4.0.

- Table name that contains the dimensions the set will use.
  
  You can create sets using a user table that contains specific dimensions from a table. For more information, see User Tables [Seite 656].

Select the set type.

If you want to create the set by copying data from an existing set, enter the name of the set from which you want to copy data.

  The table of the set you are creating must contain a dimension that is compatible with the dimension used by the reference set.

Choose Header.

If you are creating a basic or single-dimension set:

  A dialog box appears asking for the dimension that will be used by the set.

  Enter the name of the dimension that the basic or single-dimension set will use, and choose Continue.

  The Create Set: Header screen appears.

If you are creating a data or multi-dimension set:

  The Create Set: Header screen appears.

Enter the following data:

- Set description

- Symbolic name for the set contents, if the set is used for calculating cells and key figures in the Report Writer.

  This field does not appear if you are creating a multi-dimension set.

  For more information, see Using Symbolic Names in Report Writer [Seite 909].

- Representative value, if the set is used for planning, hierarchical rollups, or reporting.
Creating a Set Header

A representative value represents all values in the set. This field does not appear if you are creating a data or multi-dimension set.

For more information, see Representative Values in Sets [Seite 657].

- Print class for the set header

This field does not appear if you are creating a data or multi-dimension set.

For more information, see Setting Print Classes in Sets [Seite 910].

Set the appropriate indicator for checking overlapping values in a basic or single-dimension set.

To enter overlapping values in your set:

Select No check.

You can now enter a range of set values in one set line, which overlap with values in another set line.

The Ambiguity check indicators do not appear if you are creating a data or multi-dimension set.

Enter an authorization group, if required.

You can use the following additional functions on this screen.

Additional Processing Functions – Create Set: Header Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Set lines</td>
<td>Enter set values.</td>
</tr>
<tr>
<td>Utilities → Set directory</td>
<td>Display a directory of sets.</td>
</tr>
<tr>
<td>Utilities → Find values in sets</td>
<td>Display a list of sets that contain specific values.</td>
</tr>
<tr>
<td>Utilities → Set usage</td>
<td>Display a list of where sets are used.</td>
</tr>
<tr>
<td>Utilities → Graphics</td>
<td>Display a graphic of a set.</td>
</tr>
<tr>
<td>Utilities → Transport → Export</td>
<td>Export sets to an external file.</td>
</tr>
<tr>
<td>Utilities → Transport → Import</td>
<td>Import sets from an external file.</td>
</tr>
<tr>
<td>Utilities → Transport → Copy from client</td>
<td>Copy sets from client 000 (or another client) to the client in which you are working.</td>
</tr>
<tr>
<td>Utilities → Transport → Transport request</td>
<td>Include a set in a Customizing transport request and transport the set with or without its dependent objects. For more information, see the Transport Sets/Variables activity in the Implementation Guide (IMG) for Special Purpose Ledger (FI-SL).</td>
</tr>
<tr>
<td>Utilities → Non-used sets</td>
<td>Display a directory of sets that are not used in the system. You can then delete these sets if required.</td>
</tr>
<tr>
<td>Utilities → Ambiguity check</td>
<td>Check if values in a set are overlapping.</td>
</tr>
</tbody>
</table>

To save the set header information, choose Set → Save.
User Tables

When you create a basic or single-dimension set, you enter the name of the table that the set uses and then choose a table field (dimension) for the set.

If you do not use most of the fields in a table, you can create your own user table. This table contains only the fields that you need to work with sets.

Once you have created the user table, you can use it when creating a set. When you choose the name of the field that the set uses, the system displays only those fields from your user table.

You create user tables in Customizing for Special Purpose Ledger by choosing Basic Settings → Master Data → Maintain User Tables.

You no longer use the Table maintenance transaction to create your own user tables.
Representative Values in Sets

Representative values are used to represent all the values entered in a basic or single-dimension set and can be used in planning, hierarchical rollups, and reporting.

Planning

You can use a representative value in planning to represent a group of dimensions for which you want to enter planning values.

You create a basic set of accounts and enter a representative value called ACCTS. When you use this set in your planning parameters and enter planning values, you can enter a total amount for the representative value ACCTS. The amount you enter for the representative value ACCTS represents the total plan amount for all accounts entered in the basic set.

Hierarchical Rollups

When you define a hierarchical rollup, your rollup header set includes a single-dimension set that contains the hierarchy for the dimension you want to rollup (for example, a cost center hierarchy). You enter a representative value for each set within the single-dimension set of your dimension hierarchy. This representative value represents, for example, the node cost center to which you want to roll up data from all other cost centers in the hierarchy set. When the set is processed in the rollup, the system creates data records using the representative values.

Reporting

You can use representative values as part of the authorization check in reporting.

You create a report containing a cost center hierarchy. When you display your report using the Variation function, a data extract is created for each hierarchy level. You can use the representative value as an authorization check to prevent users from accessing specific data extracts. Only those users who have authorization for the representative value are allowed to display the report extracts.

If you want to print out a reporting hierarchy and the area of responsibility changes at each hierarchy level, you can enter a representative value for each hierarchy node to assign the report printout to a specific printer.

If you want to display master data for the dimensions used in your report rows and columns (for example, in the report header), the representative value is used to replace the text variables you enter in the report header.

You create a report containing a cost center hierarchy and want to display the name of the cost center manager in the report header. The name of the cost center manager is defined in the cost center’s master data. If you enter a representative value for a specific cost center node in the hierarchy, the name of the manager of the representative cost center displays in the report header when you display the report.
Entering Basic Set Values

On the Create Set: Header Screen, choose Goto → Values.

The Create Set: Values screen appears for basic sets.

You enter values in a basic set according to the field type that is defined for the set’s characteristic. The field type is defined in the ABAP Dictionary.

Enter basic set values as required.

You can enter single values, a range of values, a variable, and/or a formula in a basic set.

- You can use the Insert all values function to insert all possible values for the characteristic that the set uses. You can only use this function for basic sets.
- If you want to enter the initial value of space in a set row, enter a space with the space bar in the From value field.

If the basic set is to be used by the Report Writer in reporting, enter the following data as required:

- Short text describing the set row
  
  This text is displayed in the row of a report when you use the set in a report.

- Indicator that determines whether the Report Writer only prints the total for a specified row and not individual values.
  
  When you use the set in a report, the system only prints the sum of the set row instead of the individual values of the set row.

- Field that determines how report rows are displayed depending on whether the value in the report column is positive (+) or negative (-).
  
  The Chk clmn f. +/- sign field in the report’s layout parameters determines which column is used for the +/- sign check.

- Format group for the set row
  
  For more information, see setting format groups in sets [Seite 910].

- Symbolic name for the set row
  
  This value is used in Report Writer cells to represent a set row. For more information, see using symbolic names in Report Writer [Seite 909].

- Field that determines if values should be checked against a specific application check routine.
Entering Basic Set Values

You can use the following additional functions in this screen:

Additional Functions (Create Set: Values Screen for Basic Sets)

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter additional set values.</td>
<td>Edit → New entries</td>
</tr>
<tr>
<td>Insert a set row.</td>
<td>Edit → Insert row</td>
</tr>
<tr>
<td>Enter a formula in the set.</td>
<td>Edit → Insert formula</td>
</tr>
<tr>
<td>Insert all possible values for the characteristic</td>
<td>Edit → Insert all values</td>
</tr>
<tr>
<td>that the set uses</td>
<td></td>
</tr>
<tr>
<td>Delete a set row.</td>
<td>Edit → Delete row</td>
</tr>
<tr>
<td>Enter a variable in the set.</td>
<td>Edit → Variable...</td>
</tr>
<tr>
<td>Enter set header information.</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>For additional functions using Utilities, see the</td>
<td></td>
</tr>
<tr>
<td>table in creating a set header [Seite 653].</td>
<td></td>
</tr>
</tbody>
</table>

To save the set, choose Set → Save.

See also:

Entering Value and Formula Variables in a Set [Seite 661]
Entering Formulas in a Set [Seite 662]
Entering Value and Formula Variables in a Set

On the Create Set: Basic Entries screen, move the cursor to the line and field where you want to enter the variable.

Choose Edit → Variable.

A dialog box appears, asking you to enter the name of the variable.

Enter the name of the variable.

The variable must use a dimension that is compatible with the dimension of the basic set you are creating or changing.

From the dialog box, you can create the variable if it does not yet exist. You can also change and display an existing variable. The system then branches to the respective transaction.

Choose Continue.

The Create Set: Basic Entries screen appears, displaying the variable in the set line you selected.

To save the set, choose Set → Save.
Entering Formulas in a Set

On the Create Set: Basic Entries screen, move the cursor to the line above which you want to insert the formula.

Choose Edit → Insert formula.

A dialog box appears in which you enter the formula.

Enter the formula.

For more information about the rules for creating formulas, see Formulas [Seite 686].

The following table contains example formulas that can be used in sets.

<table>
<thead>
<tr>
<th>Example formulas</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>‘001’+10</td>
<td>Line 001 plus 10</td>
</tr>
<tr>
<td>‘002’–’001’</td>
<td>Line 002 minus line 001</td>
</tr>
<tr>
<td>(’002’–’001’)+0.15</td>
<td>Line 002 minus line 001; multiply the result by 0.15</td>
</tr>
</tbody>
</table>

You can also enter cells in your formula. (Cells are used by the Report Writer.) For more information about cells, see Defining Cells [Seite 864].

Check that formula syntax is correct by choosing Check formula.

Choose Continue.

The Create Set: Basic Entries screen appears, displaying the formula you entered.

To save the set, choose Set → Save.
Entering Key Figure Set Values

On the Create Set: Header Screen, choose Goto → Values.

The Create Set: Values screen appears for key figure sets.

Make the following entries:

– Basic key figure or key figure

   If, for example, you entered g1t1 in the Table field on the Create Set: Initial Screen, you can only enter the basic key figures/key figures allowed for table GLT1.

   You can also enter a formula in the Key figure field. For more information on entering formulas, see entering formulas in a set [Seite 662].

– Format group for a set row

   For more information, see setting format groups in sets [Seite 910].

– Page break information

   If the key figure set is used as a column block in a report, specify whether you want to insert a page break before a column block or insert blank lines between column blocks.

   For example, if you convert a Report Painter report into a Report Writer report and later want to change the Report Writer report in order to insert either a page break or a specific number of blank lines before a column block, you make an entry in this field for the corresponding column set.

– Symbolic name for a set row

   This value is used in Report Writer cells to represent a set row. For more information, see using symbolic names in Report Writer [Seite 909].

– Short text describing the set row

   This text is displayed in the row of a report when you use the set in a report.

   You cannot enter variables in a key figure set.

You can use the following additional functions in this screen:

Additional Functions (Create Set: Values Screen for Key Figure Sets)

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter additional set values.</td>
<td>Edit → New entries</td>
</tr>
<tr>
<td>Insert a set row.</td>
<td>Edit → Insert row</td>
</tr>
<tr>
<td>Enter a formula in the set.</td>
<td>Edit → Insert formula</td>
</tr>
<tr>
<td>Delete a set row.</td>
<td>Edit → Delete row</td>
</tr>
<tr>
<td>Enter set header information.</td>
<td>Goto → Header</td>
</tr>
</tbody>
</table>
For additional functions using Utilities, see the table in creating a set header [Seite 653].

Utilities → <Options>

To save the key figure set values, choose Set → Save.

See also:

Entering Formulas in a Set [Seite 662]
Entering Subordinate Sets in Single-Dimension Sets

From the Create Set: Header screen, choose Goto → Subordinate sets.

The Create Set: Subordinate sets screen for single-dimension sets appears.

In the Set ID field, enter a basic or single-dimension set name.

You can enter all sets whose dimensions are compatible with the dimension of the single-dimension set you are creating. This allows you, for example, to enter CO groups in single-dimension sets.

A set name is only unique within one set class. If you enter a set name that exists in two different set classes, the system displays a dialog box in which you select the set that you want to enter in the single-dimension set.

You cannot enter variables or formulas in a single-dimension set.

In your single-dimension set you can enter sets that do not yet exist. The system displays a dialog box, asking you if you want to create the set. You can then create the new set(s) and afterwards continue to maintain the original single-dimension set.

This means that you do not have to create the sets that you want to include in your single-dimension set before you actually create the single-dimension set.

Enter additional set names as required.

If the single-dimension set is to be used by the Report Writer in reporting, enter the following data as required:

Indicator that determines whether the Report Writer only prints the total for a specified line and not individual values.

When you use the set in a report, the system only prints the sum of the set row instead of the individual values of the set row.

Field that determines how report rows are displayed depending on whether the value in the report column is positive (+) or negative (-).

The Chk ctmn f. +/- sign field in the report’s layout parameters determines which column is used for the +/- sign check.

If you use asset accounts for a balance sheet in your set, you can enter a plus sign (+) for every asset account. When the asset accounts appear in a report, the account amount must be greater than or equal to zero before the account amount is displayed in the report. If the amount is less than zero, a zero displays for the asset account.

Format group for the set row

For more information, see setting format groups in sets [Seite 910].

Symbolic name for the set row
**Special Purpose Ledger**

**Entering Subordinate Sets in Single-Dimension Sets**

This value is used in Report Writer cells to represent a set row. For more information, see using symbolic names in Report Writer [Seite 909].

You can use the following additional functions on this screen:

**Additional Processing Functions (Create Set: Subordinate Sets Screen for Single-Dimension Sets)**

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entering additional set values</td>
<td><em>Edit → New entries</em></td>
</tr>
<tr>
<td>Inserting a set row</td>
<td><em>Edit → Insert row</em></td>
</tr>
<tr>
<td>Deleting a set row</td>
<td><em>Edit → Delete row</em></td>
</tr>
<tr>
<td>Entering set header information</td>
<td><em>Goto → Header</em></td>
</tr>
<tr>
<td>Entering a range for the set</td>
<td><em>Goto → Values</em></td>
</tr>
<tr>
<td>See the table in creating a set header [Seite 653] for additional processing functions using Utilities.</td>
<td><em>Utilities → &lt;Options&gt;</em></td>
</tr>
</tbody>
</table>

To save the set values, choose *Set → Save.*
Entering Multi-Dimension Set Values

On the Create Set: Header Screen, choose Goto → Subordinate sets.

The Create Set: Subordinate sets screen for multi-dimension sets appears.

Make the following entries:

- Sets that you want to include in your multi-dimension set.
  
  You can enter a basic, data, and/or single-dimension set that uses the same table as the multi-dimension set you are creating.

  A set name is only unique within one set class. If you enter a set name that exists in two different set classes, the system displays a dialog box in which you select the set that you want to enter in the multi-dimension set.

  You can also enter set variables in a multi-dimension set. The set variable must use the same table as the multi-dimension set you are creating.

  If you want to use the multi-dimension set in a report, the order of your sets is important. The report displays the set values in the order that you enter them on the Create Set: Basic Entries screen.

- You can enter sets that do not yet exist in your multi-dimension set. The system displays a dialog box, asking you if you want to create the set. You can then create the new set(s) and afterwards continue to maintain the original multi-dimension set.

  This means that you do not have to create the sets that you want to include in your multi-dimension set before you actually create the multi-dimension set.

- Indicator that determines whether the Report Writer only prints the total for a specified row and not individual values.

  When you use the set in a report, the system only prints the sum of the set row instead of the individual values of the set row.

- Format group for the set row

  For more information, see setting format groups in sets [Seite 910].

- Symbolic name for the set row

  For more information, see using symbolic names in Report Writer [Seite 909].

You can use the following additional functions in this screen:

Additional Processing Functions (Create Set: Basic Entries Screen for Multi-Dimension Sets)

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entering additional set values</td>
<td>Edit → New entries</td>
</tr>
<tr>
<td>Inserting a set row</td>
<td>Edit → Insert row</td>
</tr>
</tbody>
</table>
Entering Multi-Dimension Set Values

<table>
<thead>
<tr>
<th>Action</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deleting a set row</td>
<td>Edit → Delete row</td>
</tr>
<tr>
<td>Entering a variable in the set</td>
<td>Edit → Variable…</td>
</tr>
<tr>
<td>Entering set header information</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>For additional processing functions using Utilities, see the table in creating a set header [Seite 653].</td>
<td>Utilities → &lt;Options&gt;</td>
</tr>
</tbody>
</table>

To save the set, choose Set → Save.

See also:

Entering Set Variables in a Set [Seite 669]
Entering Set Variables in a Set

On the Create Set: Basic Entries screen, move the cursor to the line where you want to enter the variable.

Choose Edit → Variable.

A dialog box appears, asking you to enter the name of the variable.

Enter the name of the set variable.

From the dialog box, you can create the set variable if it does not yet exist. You can also change and display an existing variable. The system then branches to the relevant transaction.

Choose Continue.

The Create Set: Basic Entries screen appears, displaying the variable in the set line you selected.

To save the set, choose Set → Save.
Displaying Sets

Choose Accounting → Financial Accounting → Special Purpose Ledger → Tools → Set maintenance → Sets → Display.

The Display Set: Initial Screen appears.

Enter the name of the set that you want to display.

You can use the following additional functions to display set information.

**Additional Processing Functions - Display Set: Initial Screen**

<table>
<thead>
<tr>
<th>Function</th>
<th>Menu path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display set header information.</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>Display set values.</td>
<td>Goto → Values</td>
</tr>
<tr>
<td>Display subordinate sets.</td>
<td>Goto → Subordinate sets</td>
</tr>
<tr>
<td>Graphically change the hierarchy structure of a set.</td>
<td>Goto → Hierarchy maintenance</td>
</tr>
<tr>
<td>View the revision history of the set.</td>
<td>Extras → History...</td>
</tr>
<tr>
<td>See the table in Creating a Set Header [Seite 653] for additional processing functions using Utilities.</td>
<td>Utilities → &lt;Options&gt;</td>
</tr>
</tbody>
</table>

for further information on maintaining hierarchies see the SAP Library under Financials → CO Controlling → Cost Center Accounting → Cost Center Accounting Master Data → Processing Master Data → Master Data Groups → Processing Master Data Groups.

When you display a single- or multi-dimension set, you can also display the values that are contained in the subordinate sets that comprise the single- or multi-dimension set.

To display set values from the Display Set: Basic Entries screen (for single- and multi-dimension sets) double-click the required set name. The contents of the set is displayed.
Changing Sets

From the SAP R/3 menu, choose Accounting → Financial Accounting → Special Purpose Ledger → Tools → Set maintenance → Sets → Change.

The Change Set: Initial Screen appears.

Enter the name of the set that you want to change.

Choose one of the following functions to change the set.

### Additional Processing Functions – Change Set: Initial Screen

<table>
<thead>
<tr>
<th>Function</th>
<th>Menu path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change set header information.</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>Change set values.</td>
<td>Goto → Set lines</td>
</tr>
<tr>
<td>View the revision history of the set.</td>
<td>Extras → History...</td>
</tr>
<tr>
<td>See the table in Creating a Set Header [Seite 653] for additional processing functions using the Utilities menu option.</td>
<td>Utilities → &lt;Options&gt;</td>
</tr>
<tr>
<td>Graphically change the hierarchy structure of a set.</td>
<td>Goto → Hierarchy maintenance</td>
</tr>
</tbody>
</table>

For more information about the Hierarchy maintenance function, see the SAP Library Master Data Groups documentation (CO Controlling → Cost Center Accounting → Cost Center Accounting Master Data → Processing Master Data → Master Data Groups → Processing Master Data Groups).

Type over existing data with your changes.

To save your changes, choose Set → Save.

### Inserting a Set Line

On the Create/Change Set: Values screens, move the cursor to the line under the line where you want to insert the new value.

Choose Edit → Insert line.

A new line appears on the screen.

Enter the new value.

To save the set, choose Save.

### Deleting a Set Line

Move the cursor to the line you want to delete.

Choose Edit → Delete line.

The system deletes the line from the set.
Changing Sets

To save the set, choose Save.

**Changing Variables in a Set**

On the *Create/Change Set: Values* screens, move the cursor to the variable you want to change. Choose *Edit → Variable*.

A dialog box appears with the variable.

Type over the existing variable with the new variable name.

To return to the previous screen, choose *Continue*.

To save the set, choose *Save*.

**Changing Formulas in a Set**

On the *Create/Change Set: Values* screens, move the cursor to the formula you want to change. Double-click the set line containing the formula.

A dialog box appears displaying the formula.

Type over the existing formula with the new formula and choose *Continue*.

For more information about creating formulas, see [Formulas [Seite 686]] .

To save the set, choose *Save*. 
Deleting Sets

Prerequisites

You cannot delete a set that is used in another set, a set variable, a report, a planning parameter, an allocation, a Boolean logic formula, a rollup, or in currency translation. You can use the Set usage utility to see if a set is being used elsewhere in the system. For more information, see Checking Set Usage [Seite 680].

If you want to delete a large number of sets, we recommend that you use the Non-used sets utility to delete the sets. For more information, see Displaying and Deleting Non-Used Sets [Seite 682].

Procedure


The Delete Set: Initial Screen appears.

Enter the name of the set that you want to delete.

Choose Enter.

A dialog box appears, asking you if you want to delete the set.

To delete the set, choose Yes.

The system deletes the set. You cannot restore a set after it has been deleted.
Transporting Sets

Use

With the transport utilities, you can:

Export sets to external files

The *Export* function allows you to export sets from an SAP R/3 System to an external file.

Refer to [Exporting Sets](#) [Seite 675].

Import sets from external files

The *Import* function allows you to import sets from an external file to an SAP R/3 System.

Refer to [Importing Sets](#) [Seite 676].

Copy sets between different clients in the same SAP R/3 System

Many SAP R/3 application components are delivered with example sets (stored in client 000). You can use the *Copy from client* function to copy sets from client 000 (or another client) to the client in which you are working.

Refer to [Copying Sets from a Client](#) [Seite 677].

You can use the *Utilities* → *Transport* → *Transport request* function to include sets and variables in a Customizing transport request. For more information, refer to the *Transport Sets/Variables* activity in the Implementation Guide (IMG) for *Special Purpose Ledger*. 
Exporting Sets

On the Create/Display/Change/Delete Set screens, choose Utilities → Transport → Export.

The Export Sets screen appears.

Enter the name of the set(s) that you want to export and additional selection criteria, as required.

In the Further details group box, enter the following data:

- Indicator that determines if the sets are exported immediately (without selecting sets from a selection screen).
- Indicator that determines if the sets are exported with their complete structures and dependent objects (for example, the variables and sets that comprise the set, and the set variables and the default sets used in the set variables).

Beginning with Release 3.1G, CO groups (such as cost center groups, cost element groups, profit center groups, and so on) are no longer exported as dependent objects. For example, if you are exporting a multi-dimension set that contains a CO group, the CO group is not exported to the target system.

If you want to export CO groups, you do so in a separate step using the set or hierarchy maintenance functions. In this case, all CO groups contained in the single-dimension set are exported to the target system.

- Indicator that determines if the data is exported to the presentation server.
  
  If you do not set this indicator, the sets are exported to the application server (default setting).

- Export file to which you want to export the sets.

  If the file does not exist, the system creates it; if the file exists, the system overwrites the existing file.

  For a UNIX operating system, the file name consists of a path and a name, such as /TEMP/EXPORT.

  For a Windows operating system, the file name consists of a drive, path, and a name, such as C:\TEMP\EXPORT.

Choose Program → Execute.

The sets are exported to the file you specified in the Export file field.

If you did not set the Without selection list indicator, the Export Sets screen appears:

Select the set(s) that you want to export.

Choose Sets → Execute.
Importing Sets

On the Create/Display/Change/Delete Set screens, choose Utilities → Transport → Import.

The Import Sets screen appears.

Enter the following data:
- Indicator that determines if the data is imported from the presentation server.
- Name of the file from which you want to import sets.

⚠️

Existing sets, which have the same names as the sets being imported, are overwritten without warning.

Choose Program → Execute.

The sets are imported from the file you specified in the Export file field.
Copy Sets from a Client

Prerequisites
You can only use this function if you are copying sets from/to clients that exist in the same system. If the sets you want to copy are stored in a different system than the one to which you want to copy, you must use the export and import functions.

Procedure
On the Create/Display/Change/Delete Set screens, choose Utilities → Transport → Copy from client.

The Copy Sets From Source Client screen appears.

Enter the source client, the set(s) that you want to copy, and additional selection criteria, as required.

The data you enter determines the data that is copied from the source client to the client in which you are working.

Set the indicators in the Further details group box, as required:

- If you select Copy without selection list, the sets are exported immediately.
- If you select Copy with dependent objects, the sets are copied with their complete structures and dependent objects (for example, the variables and sets that comprise the set; and the set variables and the default sets used in the set variables).

Beginning with Release 3.1G, CO groups (such as cost center groups, cost element groups, profit center groups, and so on) are no longer transported as dependent objects. For example, if you are copying a multi-dimension set that contains a CO group, the CO group is not copied to the target client.

If you want to copy CO groups to another client, you do so in a separate step using the set or hierarchy maintenance functions. In this case, all CO groups contained in the single-dimension set are copied to the target client.

Choose Program → Execute.

If you selected Copy without selection list, the system automatically copies the sets from the source client to the client in which you are working, according to the criteria you entered on the Copy Sets From Source Client screen.

If you did not select Copy without selection list, the system lists all sets from the source client that meet the criteria you entered on the Copy Sets From Source Client screen:

Select the set(s) that you want to copy.

Choose Sets → Copy.

The system copies the set(s) to the client in which you are working.
Set Utilities

You can use set utilities to call additional information on sets, such as:
- Displaying a set directory
- Checking field and set value usage
- Checking set usage
- Displaying set graphics
- Transporting sets
- Displaying and deleting non-used sets
- Checking for overlapping values in sets
Checking Field and Set Value Usage

You can use the Utilities → Find values in sets function to see if a field value is being used in a set. You can use this function from the Create/Display/Change/Delete Set screens.

Procedure

Choose Utilities → Find values in sets.

The Find Values in Sets screen appears.

Enter data as required.

The data you enter determines the data that is selected for display.

Set the indicators in the Output options group box, as required.

If you want to display where the set is used in the system (for example, in another set or in a report), select With usage.

If the set value you enter is included in an interval of values, you can display the interval in which the set value is found by selecting Display values found.

Choose Program → Execute.

The system displays information about the value(s) you entered on the previous screen, such as the sets that use the value(s).

You can use the following additional processing functions on the Find Values in Sets screen.

**Additional Processing Functions – Find Values in Sets Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report → Print</td>
<td>Print the list of sets that use the value(s) entered on the selection screen.</td>
</tr>
<tr>
<td>Edit → Change set/group</td>
<td>Change the set or CO group on which the cursor is positioned.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> You cannot change sets that are delivered with your SAP R/3 System. In this case, the system branches to the Display Set transaction.</td>
</tr>
<tr>
<td>Edit → Display usage</td>
<td>Display where the set(s) is used (for example, in another set, a report, a rollup, and so on).</td>
</tr>
</tbody>
</table>
Checking Set Usage

You can use the Utilities → Set usage function to find out if a set is being used in:

- Another set
- A report
- A rollup
- A data set
- An allocation
- A planning parameter
- A variable
- A validation/substitution
- Currency translation

You can use this function from the Create/Display/Change/Delete Set screens.

Procedure

Choose Utilities → Set usage.

The Display Set Usage screen appears.

Enter data as required.

The data you enter determines the data that is selected for display.

Choose Program → Execute.

The Where-Used List screen appears, displaying information about the set you entered on the previous screen, such as the set name, the table that uses the set, and where the set is used.

You can use the following additional processing functions on this screen.

Additional Processing Functions – Where-Used List Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object → Print</td>
<td>Print the list of sets and their set usage.</td>
</tr>
<tr>
<td>Edit → Choose</td>
<td>Display the object on which the cursor is positioned (for example, a set, report, and so on). The system branches to the respective Display transaction.</td>
</tr>
<tr>
<td>View → Expand/collapse</td>
<td>Expand or collapse the hierarchy of the set on which the cursor is positioned, if the set consists of more than one hierarchical level.</td>
</tr>
<tr>
<td>View → Expand all</td>
<td>Expand all hierarchical levels of the set on which the cursor is positioned.</td>
</tr>
</tbody>
</table>
Displaying and Deleting Non-Used Sets

You can use the Utilities → Non-used sets function to see if sets are not being used in your system. You can then delete the sets, if required. You can use this function from the Create/Display/Change/Delete Set screens.

Procedure

Choose Utilities → Non-used sets.

The Non-Used Sets screen appears.

Enter data as required.

The data you enter determines the data that is selected for display.

Choose Program → Execute.

A list of sets that are not being used are listed by set name, table, and set description.

You can use the following additional processing functions on the Non-Used Sets screen.

**Additional Processing Functions – Non-Used Sets Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sets → Print</td>
<td>Print the list of non-used sets.</td>
</tr>
<tr>
<td>Edit → Select all</td>
<td>Select all sets in the list for further processing.</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all the selected sets.</td>
</tr>
<tr>
<td>Edit → Change set</td>
<td>Change the selected set. The system branches to the Change Set transaction.</td>
</tr>
<tr>
<td>Edit → Delete sets</td>
<td>Delete the selected set(s).</td>
</tr>
<tr>
<td>Edit → Delete hierarchies</td>
<td>Delete the selected sets and all sets below them in the respective set hierarchies, provided the sets are not used elsewhere in the system.</td>
</tr>
</tbody>
</table>
Displaying Set Graphics


The Set Graphics screen appears.

Enter the name of the set for which you want to display a graphic.

Choose Program → Execute.

A graphic of the set is displayed on the Display Set screen.

You can use the following additional processing functions on this screen.

Additional Processing Functions – Display Set Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sets → Details</strong></td>
<td>Display detailed information on the set (for example, the print class and symbolic names used for reporting) or the set value(s).</td>
</tr>
<tr>
<td><strong>Sets → Print</strong></td>
<td>Print the set graphic.</td>
</tr>
<tr>
<td><strong>Edit → Choose</strong></td>
<td>Display detailed information on the set (for example, the print class and symbolic names used for reporting) or the set value(s).</td>
</tr>
<tr>
<td><strong>Edit → Set focus</strong></td>
<td>Display a separate graphic of the set on which the cursor is positioned.</td>
</tr>
<tr>
<td><strong>Edit → Expand all</strong></td>
<td>Expand all hierarchical levels of the set on which the cursor is positioned.</td>
</tr>
<tr>
<td><strong>Edit → Collapse all</strong></td>
<td>Collapse all hierarchical levels of the set on which the cursor is positioned.</td>
</tr>
<tr>
<td><strong>Edit → Find</strong></td>
<td>Search for a specific set or set value.</td>
</tr>
<tr>
<td><strong>Extras → Color key</strong></td>
<td>Display the colors used to represent the different set types, set variables, set values, and characteristics in the graphic.</td>
</tr>
</tbody>
</table>
Checking for Overlapping Values in Sets

On the Create/Display/Change/Delete Set screens, choose Utilities → Ambiguity check.

The Ambiguity Check screen appears.

You can only check for overlapping values in basic and single-dimension sets.

Enter the name of the set in which you want to check for overlapping values.

The Path specification indicator is set as a default setting. If a set contains the same set more than once, the system lists the set hierarchy path to help you locate the overlapping sets.

Choose Program → Execute.

The Ambiguity Check screen appears, listing values that occur more than once in the set.

You can use the following additional functions on this screen.

**Additional Processing Functions – Ambiguity Check Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>List → Print</td>
<td>Print the list of sets that contain overlapping values.</td>
</tr>
<tr>
<td>Edit → Change set</td>
<td>Change the set(s) that contain overlapping values. The system branches to the Change Set transaction.</td>
</tr>
</tbody>
</table>
Displaying a Set Directory

You can use the Utilities → Set directory function to produce a directory listing of all or selected sets. You can use this function from the Create/Display/Change/Delete Set screens.

Procedure

Choose Utilities → Set directory.

The Set Directory screen appears.

Enter data as required.

The data you enter determines the data that is selected for display.

If you want to display the graphics of the selected sets, select Display graphics.

Choose Program → Execute.

A list of the sets meeting the criteria you entered on the previous screen appears.

You can use the following additional processing functions on the Set Directory screen.

Additional Processing Functions – Set Directory Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Directory → Print</td>
<td>Print the list of sets meeting the criteria you entered on the selection screen.</td>
</tr>
<tr>
<td>Edit → Display graphic</td>
<td>Display the graphic of the set on which the cursor is positioned.</td>
</tr>
<tr>
<td>Goto → New selection</td>
<td>Enter new selection criteria for displaying a directory listing of sets.</td>
</tr>
</tbody>
</table>
Formulas

Use
Within a set, you can use formulas to perform calculations.

You can use a formula in a set and instruct the system to subtract a set line from another set line. When you use the set to define report columns, the system calculates a variance column in the report.

A formula consists of operators, operands, absolute values, and parentheses.

You can use formulas in any basic set or data set; you cannot use formulas in a single-dimension or multi-dimension set.

Features

Rules for Creating Formulas
When building a formula, you can use the operators in the following table.

Operators in Formulas

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>−</td>
<td>Subtraction</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
</tr>
<tr>
<td>**</td>
<td>Exponential value</td>
</tr>
<tr>
<td>( )</td>
<td>Parentheses</td>
</tr>
<tr>
<td>SIN</td>
<td>Sine</td>
</tr>
<tr>
<td>COS</td>
<td>Cosine</td>
</tr>
<tr>
<td>TAN</td>
<td>Tangent</td>
</tr>
<tr>
<td>SQRT</td>
<td>Square root</td>
</tr>
<tr>
<td>TRUNC</td>
<td>Truncation to integer</td>
</tr>
<tr>
<td>INT</td>
<td>Truncation to integer</td>
</tr>
<tr>
<td>DIV</td>
<td>Quotient of whole number division</td>
</tr>
<tr>
<td>MOD</td>
<td>Remainder of whole number division</td>
</tr>
<tr>
<td>ABS</td>
<td>Absolute value</td>
</tr>
<tr>
<td>EXP</td>
<td>Exponential function (n^x)</td>
</tr>
<tr>
<td>LOG</td>
<td>Logarithm</td>
</tr>
</tbody>
</table>
You can use the following operands in set formulas:

- Line numbers in the form ‘nnn’ (for example, ‘001’ for line 001)
- Value variables (for example, ‘&YEAR’ for the value variable YEAR)
- Formula variables

Beginning with Release 3.0C, the syntax used to enter formula operands has changed. You enter formula operands in the form ‘nnn’ (for example, ‘001’ to enter the set line 001). In releases prior to Release 3.0C, you enter formula operands using angle brackets around the operand (for example, <001>).

The system automatically converts existing formulas into the new format. You do not therefore need to change your sets that contain formulas.

Within a formula you can also use:

- Absolute values (for example, 10 or 20)
- Combinations of absolute values and line numbers (for example, 10 * ‘002’)
- Boolean Logic

You enter the following formula in the second line of a set defined for a report column:

\[
\text{IF} \ '001' > 1000 \ \text{THEN} \ '001' \ \text{ELSE} \ 0
\]

If the value in the first report column (set line 001) is greater than 1000, then this value is displayed in the second column; if the value in the first column is less than 1000, the value 0 is displayed in the second column.

For more information, see Introduction to Boolean Logic [Seite 1121].

To enter line numbers, enter:

- The complete 3-digit line number, including the leading zero
- Single quotation marks ‘ ’ around the line number

You can enter a formula that refers directly to the result of another formula line.

You enter the formula ‘001’ + ‘002’ in set line 003 to add together set lines 001 and 002.

You want to enter a second formula (set line 004) to calculate 50% of the total of set lines 001 and 002. You do so by entering the formula ‘003’ / 2. The operand ‘003’ in this formula refers to the result of the formula calculated in set line 003.
Formulas

You enter formulas in a set on the Create/Change Set: Basic Entries screens. For more information about entering a formula in a basic or data set, see Entering Value and Formula Variables in a Set [Seite 661].

Using Formulas in Formula Variables

You can create variables called formula variables, which determine the value for a variable.

You can use the operators in the previous table for a formula variable.

In your formula, you can also use:

Variables

The variables you use must use the same table name that you entered for the formula variable.

User exits

When you enter variables and user exits in your formula, you must enter single quotation marks (') around them. When creating a formula for a variable, you use the same syntax rules described in the above "Rules for Creating Formulas" section.

See also:

Creating Formula Variables [Seite 695]
Variables

Purpose
A variable is a placeholder for data to be specified when you run a report that uses the variable. Variables are used in many areas, for example in reporting (Report Painter / Report Writer [Seite 723]). For example, a variable could be a company, the current year, the current month, a date, or a user name.

When you use a variable in a report, the value that you choose for the variable is valid for only one report run. Each time you run a report, you can enter a new value for the variables used in the report.

Features
You can create the following types of variables:

Value variables
This variable represents a specific value that you can enter directly. You can only use value variables in basic sets. For more information, see entering value and formula variables in a set [Seite 661].

You can create a variable called YEAR. When you enter the variable YEAR in a basic set, and then you use the basic set in a report, the system prompts you to enter a year when you run the report.

Formula variables
This variable represents a formula, which determines a value for the variable. You can only use formula variables in basic sets [Seite 639]. For more information, see creating formula variables [Seite 695].

You want to create a formula that automatically calculates the previous year based on the current year on your system. To do this, proceed as follows:

Create a formula variable called YEAR (current year), which uses the user exit S001 to determine the current year.

Refer to this formula in another formula variable called PR-YEAR (previous year). You enter this formula as:

'&YEAR' - 1

The system determines the current year using the value determined by formula variable YEAR, and then subtracts one year for the value of the formula variable PR-YEAR.

Set variables
Variables

This variable represents a defined set [Seite 633] and the values contained in the set. A set variable can also be used for all values defined for the characteristic that the set variable uses.

You can only use set variables in multi-dimension sets [Seite 645]. For more information, see creating set variables [Seite 697].

Multi-Dimension Set with Set Variables

You would create the multi-dimension set with set variables in the above graphic as follows:

Define three basic sets called:

- CENTERS (cost centers)
- OHD-ACCT (overhead accounts)
- BUS-AREA (business areas)

Create set variables that use the sets as default values. For example, you could create the set variables:

- CENT-V (default set CENTERS)
- OHDA-V (default set OHD-ACCT)
- BA-V (default set BUS-AREA)

Define a multi-dimension set called CC-OHD-BA and include the three set variables.

Use the multi-dimension set CC-OHD-BA in a report.

When you use the multi-dimension set CC-OHD-BA in a report, the Report Writer prompts you with the default sets when you execute the report. You can use the default sets or enter new set names for the set variables.

Variable Utilities
You can call up additional information on the variables using the variable utilities. For more information, see displaying a variable directory [Seite 706], displaying and deleting non-used variables [Seite 707] and transporting variables [Seite 702].
Creating Variables


The Create Variable: Initial Screen appears.

Enter the following data:

- Variable name
- Table name for the variable
- Field name for the variable

This field name refers to the dimension that the variable uses.

Select the variable type by setting one of the indicators in the Variable type group box.

If you want to create the variable by copying data from an existing variable, enter the name of the variable from which you want to copy data in the Copy from - Variable field.

The variable must have the same field name as the variable you are creating.

Choose Basic data.

The Create Variable: Basic Data screen appears for the variable type you specified.

See also:

Creating Value Variables [Seite 693]
Creating Formula Variables [Seite 695]
Creating Set Variables [Seite 697]
Creating Value Variables

On the Create Value Variable: Basic Data screen, enter the following data:

- Description of the variable
  The name of the field used for the variable is defaulted as the variable description. You can change this description as required.

- Default value for the variable
  This value automatically appears when the system prompts you to enter a variable.

- Indicator that determines if the variable is an internal variable.
  If you set this indicator, the default value of the variable cannot be changed when a report is run that uses the variable. If you do not set this indicator, the default value of the variable is displayed, and you can change it when a report is run that uses the variable.

- Indicator that determines if the parameter ID of the table field is used as the SET/GET parameter for the variable.
  The system uses the last value you entered as the default value of the variable. This indicator does not appear if a parameter ID does not exist for the field name you used when defining the value variable.

  On a previous screen, you entered the value 1000 for Company Code. When you run a report with a value variable for Company Code, the value variable appears with the value 1000 for the variable.

  The parameter ID can only be used for sets that are used in reporting.

- Authorization group for the variable, if required

You can use the following additional functions on this screen.

**Additional Processing Functions – Create Value Variable: Basic Data Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Edit → Type change: Formula</em></td>
<td>Change the variable type from a value variable to a formula variable.</td>
</tr>
<tr>
<td><em>Goto → Parameter ID...</em></td>
<td>Enter a SET/GET parameter for the default value of the variable.</td>
</tr>
<tr>
<td><em>Utilities → Variable directory</em></td>
<td>Display a directory of variables.</td>
</tr>
<tr>
<td><em>Utilities → Non-used variables</em></td>
<td>Display a directory of variables that are not used in the system. You can then delete these variables if required.</td>
</tr>
<tr>
<td><em>Utilities → Transport → Export</em></td>
<td>Export variables to an external file.</td>
</tr>
</tbody>
</table>
Creating Value Variables

<table>
<thead>
<tr>
<th>Utilities → Transport → Import</th>
<th>Import variables from an external file.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Utilities → Transport → Copy from client</td>
<td>Copy variables from client 000 (or another client) to the client in which you are working.</td>
</tr>
<tr>
<td>Utilities → Transport → Transport request</td>
<td>Include a variable in a Customizing transport request and transport the variable. For more information, see the Transport Sets/Variables activity in the Implementation Guide (IMG) for Special Purpose Ledger (FI-SL).</td>
</tr>
</tbody>
</table>

To save the variable, choose Variable → Save.
Creating Formula Variables

On the Create Formula Variable: Basic Data screen, enter the following data:

- **Description of the variable**
  The name of the field used for the variable is defaulted as the variable description. You can change this description as required.

- **A formula for the variable in the Formula field.**
  This field appears if the field name for which you are defining the formula variable is a numeric field. The formula determines the default value for the variable. See the table in Formulas [Seite 686] for the operators that you can use in a variable formula.

  You create a formula variable called YEAR (current year), which uses the user exit S001 to determine the current year. You enter this user exit as ‘#S001’ in the Formula field. You then refer to this formula in another formula variable called PR-YEAR (previous year). You enter this formula as:
  ```
  'YEAR' - 1
  ```
  The system determines the current year using the value determined by formula variable YEAR, and then subtracts one year for the value of the formula variable PR-YEAR.

- **An SAP standard or user-defined exit for the formula variable in the Formula exit field.**
  This field appears if the field name for which you are defining the formula variable is a non-numeric field. If you enter a user-defined exit, this user exit must be defined in a user exit form pool. You can specify the name of this form pool in Customizing for Special Purpose Ledger by choosing Basic Settings → User Exits → Maintain Client-Independent User Exits. Example user exits are defined in form pool RGSVU00.

  The dimension Account (field name RACCT) is a non-numeric field. You cannot enter a formula; you **must** enter a formula exit name.

- **Indicator that determines if the variable is an internal variable.**
  If you set this indicator, the default value of the variable cannot be changed when a report is run that uses the variable. If you do not set this indicator, the default value of the variable is displayed, and you can change it when a report is run that uses the variable.

- **Authorization group for the variable, if required**

You can use the following additional functions on this screen.

**Additional Processing Functions – Create Formula Variable: Basic Data Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
</table>

April 2001 695
## Creating Formula Variables

<table>
<thead>
<tr>
<th>Menu Path</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Type change: Value</td>
<td>Change the variable type from a formula variable to a value variable.</td>
</tr>
<tr>
<td>Extras → Formula exits...</td>
<td>Display a list of existing user exits defined for formulas.</td>
</tr>
<tr>
<td>Utilities → Variable directory</td>
<td>Display a directory of variables.</td>
</tr>
<tr>
<td>Utilities → Non-used variables</td>
<td>Display a directory of variables that are not used in the system. You can then delete these variables if required.</td>
</tr>
<tr>
<td>Utilities → Transport → Export</td>
<td>Export variables to an external file.</td>
</tr>
<tr>
<td>Utilities → Transport → Import</td>
<td>Import variables from an external file.</td>
</tr>
<tr>
<td>Utilities → Transport → Copy from client</td>
<td>Copy variables from client 000 (or another client) to the client in which you are working.</td>
</tr>
<tr>
<td>Utilities → Transport → Transport request</td>
<td>Include a variable in a Customizing transport request and transport the variable. For more information, see the Transport Sets/Variables activity in the Implementation Guide (IMG) for Special Purpose Ledger (FI-SL).</td>
</tr>
</tbody>
</table>

To save the variable, choose Variable → Save.
Creating Set Variables

On the Create Set Variable: Basic Data screen, enter a description for the variable.

The name of the table field used for the variable is defaulted as the variable description. You can change this description as required.

Set one of the indicators in the Default entries group box to determine which default values are used for the set variable:

- If you select All values, you do not have to enter a default set for the variable. The system automatically creates a set containing all possible values defined for the field that the variable uses.

  You create a set variable called VAR-CTR for the dimension Cost center and set the All values indicator. If you use variable VAR-CTR in a report definition and execute the report, the system selects data for all cost centers according to the selection criteria you enter.

- If you select Default set, enter the name of default set for the variable. You can only enter basic and single-dimension sets. The table field of the default set must be compatible with the table field of the set variable you are creating.

  The default set automatically appears when the system prompts you to enter a variable (for example, when you are executing a Report Writer report). You can use the default set or enter a new set name for the set variable.

Specify which input fields you want to appear on the selection screens in reporting when you execute a report that contains a set variable. You can replace a set variable with either a set or individual values.

  If you select Set and value entry, the report selection screen contains one input field for a set and input fields for specific values or ranges of values.

If you create a set variable for a field in a Controlling (CO) table, specify whether the set variable can only be replaced with CO groups when you execute a report that contains the set variable.

  For example, if you create a set variable for the field Cost element (KSTAR) in table CCSS and select Only replace with groups, you can only replace the set variable with cost element groups and no other sets.

Enter an authorization group for the variable, if required

You can use the following additional functions on this screen.

Additional Processing Functions – Create Set Variable: Basic Data Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Parameter ID...</td>
<td>Enter a SET/GET parameter for the default value of the variable.</td>
</tr>
</tbody>
</table>
### Creating Set Variables

<table>
<thead>
<tr>
<th>Utilities → Variable directory</th>
<th>Display a directory of variables.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Utilities → Non-used variables</td>
<td>Display a directory of variables that are not used in the system. You can then delete these variables if required.</td>
</tr>
<tr>
<td>Utilities → Transport → Export</td>
<td>Export variables to an external file.</td>
</tr>
<tr>
<td>Utilities → Transport → Import</td>
<td>Import variables from an external file.</td>
</tr>
<tr>
<td>Utilities → Transport → Copy from client</td>
<td>Copy variables from client 000 (or another client) to the client in which you are working.</td>
</tr>
<tr>
<td>Utilities → Transport → Transport request</td>
<td>Include a variable in a Customizing transport request and transport the variable. For more information, see the Transport Sets/Variables activity in the Implementation Guide (IMG) for Special Purpose Ledger (FI-SL).</td>
</tr>
</tbody>
</table>

To save the variable, choose Variable → Save.
Displaying Variables


The Display Variable: Initial Screen appears for the variable type you entered.

In the Variable field, enter the name of the variable you want to display.

Choose Basic data.

The Display <Variable Type> Variable: Basic Data screen appears.

Displaying Where a Variable Is Used

To view a list of the sets and reports that use a variable on the Display/Change/Delete Variable screens:

Choose Extras → Usage.

A dialog box appears, listing the sets and reports that use the variable.
Changing Variables


The Change Variable: Initial Screen appears.

In the Variable field, enter the name of the variable you want to change.

Choose Basic data.

The Change <Variable Type> Variable: Basic Data screen appears for the variable type you entered.

Change the current values as needed.

You cannot change the name of an existing variable.

To save the changes to the variable, choose Variable → Save.
Deleting Variables

Prerequisites

You cannot delete a variable that is used elsewhere in the system (for example, in a set). You can display where a variable is used in the system using the Variable directory utility. On the selection screen, you set the Display usage indicator. For more information, see Displaying a Variable Directory [Seite 706].

If you want to delete a large number of variables, it is recommended that you use the Non-used variables utility to delete the variables. For more information, see Displaying and Deleting Non-Used Variables [Seite 707]

Procedure


The Delete Variable: Initial Screen appears.

In the Variable field, enter the name of the variable you want to delete.

Choose Enter.

A dialog box displays a warning message.

To delete the variable, choose Yes.

The system deletes the variable.
Transporting Variables

Use

With the transport utilities, you can:

Export variables to external files

The Export function allows you to export variables from an SAP R/3 System to an external file.

Refer to Exporting Variables [Seite 703].

Import variables from external files

The Import function allows you to import variables from an external file to an SAP R/3 System.

Refer to Importing Variables [Seite 704].

Copy variables between different clients in the same SAP R/3 System

Many SAP R/3 application components are delivered with example variables (stored in client 000). You can use the Copy from client function to copy variables from client 000 (or another client) to the client in which you are working.

Refer to Copying Variables from a Client [Seite 705].

You can use the Utilities → Transport → Transport request function to include variables and sets in a Customizing transport request. For more information, refer to the Transport Sets/Variables activity in the Implementation Guide (IMG) for Special Purpose Ledger.
Exporting Variables


The Export Variables screen appears.

Enter the name of the variable(s) that you want to export and additional selection criteria, as required.

In the Further details group box, enter the following data:

- Indicator that determines if the variables are exported immediately (without selecting variables from a selection screen).
- Indicator that determines if the variables are exported with their dependent objects.

Beginning with Release 3.1G, CO groups (such as cost center groups, cost element groups, profit center groups, and so on) are no longer exported as dependent objects. For example, if you are exporting a set variable that uses a CO group as the default set, the CO group is not exported to the target system. If you want to export CO groups, you do so in a separate step using the set or hierarchy maintenance functions.

- Indicator that determines if the data is exported to the presentation server.
  
  If you do not set this indicator, the variables are exported to the application server (default setting).

- Export file to which you want to export the variables.
  
  If the file does not exist, the system creates it; if the file exists, the system overwrites the existing file.

For a UNIX operating system, the file name consists of a path and a name, such as /TEMP/EXPORT.

For a Windows operating system, the file name consists of a drive, path, and a name, such as C:\TEMP\EXPORT.

Choose Program → Execute.

The variables are exported to the file you specified in the Export file field.

If you did not set the Without selection list indicator, the Export Variables screen appears:

Select the variable(s) that you want to export.

Choose Variables → Execute.
Importing Variables


The Import Variables screen appears.

Enter the following data:

- Indicator that determines if the data is imported from the presentation server.
- Name of the file from which you want to import variables.

Choose Program → Execute.

The variables are imported from the file you specified in the Export file field.
Copying Variables from a Client

Prerequisites
You can only use this function if you are copying variables from/to clients that exist in the same system. If the variables you want to copy are stored in a different system than the one to which you want to copy, you must use the export and import functions.

Procedure

The Copy Variables From Source Client screen appears.

Enter the source client, the variable(s) that you want to copy, and additional selection criteria, as required.

The data you enter determines the data that is copied from the source client to the client in which you are working.

Set the indicators in the Further details group box, as required:

- If you select Copy without selection list, the variables are exported immediately.
- If you select Copy with dependent objects, the variables are copied with their dependent objects.

Beginning with Release 3.1G, CO groups (such as cost center groups, cost element groups, profit center groups, and so on) are no longer transported as dependent objects. For example, if you are copying a set variable that uses a CO group as the default set, the CO group is not copied to the target client. If you want to copy CO groups to another client, you do so in a separate step using the set or hierarchy maintenance functions.

Choose Program → Execute.

If you selected Copy without selection list, the system automatically copies the variables from the source client to the client in which you are working, according to the criteria you entered on the Copy Variables From Source Client screen.

If you did not select Copy without selection list, the system lists all variables from the source client that meet the criteria you entered on the Copy Variables From Source Client screen:

Select the variable(s) that you want to copy.

Choose Variables → Copy.

The system copies the variable(s) to the client in which you are working.
Displaying a Variable Directory

You can use the Utilities → Variable directory function to produce a directory listing of all or selected variables. You can use this function from the Create/Display/Change/Delete Variable screens.

Procedure

Choose Utilities → Variable directory.

The Variable Directory screen appears.

Enter data as required.

The data you enter determines the data that is selected for display.

If you want to display where the variable is used in the system (for example, in a set or in a report), select Display usage.

Choose Program → Execute.

A list of the variables meeting the criteria you entered on the previous screen appears.

You can use the following additional processing functions on the Variable Directory screen.

### Additional Processing Functions – Variable Directory Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Directory → Print</strong></td>
<td>Print the list of variables meeting the criteria you entered on the selection screen.</td>
</tr>
<tr>
<td><strong>Edit → Choose variable</strong></td>
<td>Display the definition of the selected variable. The system branches to the Display Variable transaction.</td>
</tr>
</tbody>
</table>
Displaying and Deleting Non-Used Variables

You can use the Utilities → Non-used variables function to see if variables are not being used in your system. You can then delete the variables, if required. You can use this function from the Create/Display/Change/Delete Variable screens.

Procedure

Choose Utilities → Non-used variables.

The Non-Used Variables screen appears.

Enter data as required.

The data you enter determines the data that is selected for display.

Choose Program → Execute.

Variables that are not being used in the system are listed by variable name and variable description.

You can use the following additional processing functions on the Non-Used Variables screen.

Additional Processing Functions – Non-Used Variables Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variables → Print</td>
<td>Print the list of non-used variables.</td>
</tr>
<tr>
<td>Edit → Display variable</td>
<td>Display the variable on which the cursor is positioned. The system branches to the Display Variable transaction.</td>
</tr>
<tr>
<td>Edit → Select all</td>
<td>Select all variables in the list for further processing.</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all the selected variables.</td>
</tr>
<tr>
<td>Edit → Delete variables</td>
<td>Delete the selected variable(s).</td>
</tr>
</tbody>
</table>
Key Figures

Definition
A key figure is a basic key figure (value or quantity field), which has additional, restricting, characteristics (collected in a basic set [Seite 639], single-dimension set [Seite 643] or multi-dimension set [Seite 645]) that are linked to this basic key figure. Key figures that are used frequently can thus be predefined and then entered in key figure sets or directly in Report Painter [Seite 726].

Use
The columns of a report contain the values and quantities from the Controlling databases, for example, actual and plan data. The figures can originate from different versions or have been entered in different periods or years. In the report definition these characteristics have to be made available to the Report Writer. In a multi-dimension set, enter all the characteristics that describe the value columns (such as period, year, value type ACT, version 0). You combine these criteria in the key figures by entering an additional set containing these characteristics.

You need key figures to build the sets for the report columns. These sets contain more key figures and possibly also arithmetic formulas and are created as data sets.

Each row in a data set is one column of your report.

Structure
Basic key figures define which value fields are displayed in a report (for example, transaction currency, local currency, group currency, and quantity). You can combine a basic key figure with one or more additional characteristics entered in a set to create a key figure. The set determines additional selection conditions, such as the record type (actual or plan data) and the plan version. For Report Writer reports, you enter key figures directly in key figure sets. In Report Painter reports, you can enter key figures directly in the report columns.
Basic key figures, such as costs or quantities, are technical descriptions of value fields for the Report Writer. A basic key figure can be linked with additional conditions in a set and this forms a key figure. Using the entries from the key figure sets you can determine the values that are to be output in a report.

Your additional set can be a multi-dimension, single-dimension, or basic set. It can contain any values or value ranges.

Before you can access the actual cost totals, you have to specify the value type (04 = actual) and the version (000) more precisely. Value type and version are elements of the additional set represented by the key figure ISWKG.

**Example**

You want to create a Report Writer report that contains the following three columns of local currency (HSL):

Physical column 01: Plan Data (1), Year 1996, Version (value variable)

Physical column 02: Actual Data (0), Year 1997, Version 001

Physical column 03: Variance between columns 01 and 02

The column block in the report definition is data set COLUMN and contains the key figures ZHSL-1-96 and ZHSL-0-97 and the variance formula ‘001’ - ‘002’.

Using the key figures you can create a report as follows:

Create the key figures ZHSL-1-96 and ZHSL-0-97.
Example

Physical column 01 (key figure ZHSL-1-96):

– Create the multi-dimension set OZ-PLAN-96, containing basic sets:
  
  OZRRCTY-1: Characteristic "Record Type" (field RRCTY); containing value 1
  OZ-YEAR-96: Characteristic "Year" (field RYEAR); containing value 1996
  OZ-PVERS: Characteristic "Version" (field RVERS); containing value variable &PVERS

  Multi-dimension set OZ-PLAN-96 can now be used as an additional set for key figure ZHSL-1-96.

– Define the key figure ZHSL-1-96 using the Maintain Key Figure function and assign multi-dimension set OZ-PLAN-96 to the key figure.

Physical column 02 (key figure ZHSL-0-97):

– Create the multi-dimension set OZ-ACT-97, containing basic sets:
  
  OZ-RRCTY-00: Characteristic "Record Type" (field RRCTY); containing value 0
  OZ-YEAR-97: Characteristic "Year" (field RYEAR); containing value 1997
  OZ-SEL-PVERS: Characteristic "Version" (field RVERS); containing value 001

  Multi-dimension set OZ-ACT-97 can now be used as an additional set for key figure ZHSL-0-97.

– Define the key figure ZHSL-0-97 using the Maintain Key Figure function and assign multi-dimension set OZ-ACT-97 to the key figure.

Create the key figure set COLUMN. Assign the key figures ZHSL-1-96 and ZHSL-0-97 and the variance formula to this set.

For more information on creating sets, see creating sets [Seite 651].

Add the key figures ZHSL-1-96 and ZHSL-0-97 to the library of the report definition in which you want to use key figure set COLUMN.

For more information about changing libraries, see changing a library [Seite 935].

Enter the key figure set COLUMN as the column block of your report definition.

For more information on defining reports, see creating a Report Painter report [Seite 811].

You can only use a characteristic once in a report; in a row or column block or as selection criteria. If a characteristic is used in a set assigned to a key figure and the key figure is used in the report definition, you cannot use the characteristic in the report rows or as selection criteria.

For example, the characteristic "Year" is defined in a set assigned to a key figure. The key figure is then used in a column block. You cannot use the characteristic "Year" again in a row block or as selection criteria.

You can use the same characteristic more than once in different row blocks (also true for column blocks); however, you cannot use the same characteristic for a row and a column block.
For example, if you use the characteristic "Account" in row block one, you can use the characteristic "Account" again in row block two; however, you cannot use the characteristic "Account" in row block one and column block one.

For more information about key figures, see:

Creating/Changing Key Figures [Seite 712]
Displaying Key Figures [Seite 714]
Defining Key Figures [Seite 875]
Inserting Key Figures in Row Blocks [Seite 853]
Terminology [Seite 1037]
Creating/Changing Key Figures


The Maintain Key Figures: Initial Screen appears.

Make the following entries:
- Name of the table for which you want to create/change a key figure
- Language for which you want to create/change the key figure. Key figure texts are language-specific.

Choose Change.

The Report Writer: Maintain Key Figures for Table <Name of Table> screen appears. Here you see a list of all the key figures and basic key figures available in the table you specified.

When you create a key figure, you:

a) Move the cursor to an existing key figure that you want to copy and choose Edit → Copy.

The Copy key figure dialog box appears, where you enter the name for your new key figure and then choose Enter. The Create Key Figure dialog box appears.

b) Make the following entries:

Name for the key figure

User-defined key figures must begin with Y or Z.
- Row text for the key figure
  When the key figure is used in a row block of a report definition, this text is displayed in the appropriate report row.
- Column text for the key figure
  When the key figure is used in a column block of a report definition, this text is displayed in the appropriate report column.
- Basic key figure for the key figure (for example, TSL for transaction currency)
- Additional set that is to be used for the key figure.
  You can use basic, single-dimension, and multi-dimension sets as additional sets.
  You can use value and set variables in the sets you assign to a key figure.
- Type of key figure for use in the Report Painter
  You can classify the key figure as a base or extended entry.

c) Choose Save.

To change an existing key figure:
a) Move the cursor to the key figure that you want to change and choose Change/display.

The Change Key Figure dialog box appears, displaying the existing definition for the key figure.

b) Type over existing values with your changes.

c) Choose Save, or to save and exit the dialog box, choose Continue.

You can use the following additional functions in this screen:

**Additional Functions (Report Writer: Maintain Key Figures for Table <Name of Table> Screen)**

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort the key figures in alphabetical order by description</td>
<td>Edit → Sort → Description</td>
</tr>
<tr>
<td>Sort the key figures in alphabetical order by name</td>
<td>Edit → Sort → Key figure</td>
</tr>
<tr>
<td>Sort the key figures in alphabetical order by basic key figure</td>
<td>Edit → Sort → Basic key figure</td>
</tr>
<tr>
<td>Sort the key figures in alphabetical order by additional set</td>
<td>Edit → Sort → Additional set</td>
</tr>
<tr>
<td>Sort the key figures so that key figures that are not used in a set are displayed inversely</td>
<td>Edit → Sort → Usage</td>
</tr>
<tr>
<td>Delete key figures</td>
<td>Edit → Delete</td>
</tr>
<tr>
<td>Change detailed information for a key figure, such as the data set currency. You can also display set graphics and set values for the additional set with this option</td>
<td>Edit → Change/display</td>
</tr>
<tr>
<td>Copy key figures</td>
<td>Edit → Copy</td>
</tr>
<tr>
<td>View where the key figure is used in the Report Writer</td>
<td>Utilities → Usage</td>
</tr>
<tr>
<td>Export key figure to an external file</td>
<td>Utilities → Transport → Export</td>
</tr>
<tr>
<td>Import key figure from an external file</td>
<td>Utilities → Transport → Import</td>
</tr>
<tr>
<td>Copy key figure from a source client into the client in which you are working</td>
<td>Utilities → Transport → Copy from client</td>
</tr>
</tbody>
</table>

To exit the screen, choose Back.

Once you have defined a key figure and you want to use it in a report definition, you must call the report's library and add the key figure to the library. For more information about changing libraries, see changing a library [Seite 935].
Displaying Key Figures


The Display Key Figures: Initial Screen appears.

Make the following entries:

– Name of the table for which you want to display key figures
– Language for which you want to display key figures.

Key figure texts are language-specific

Choose Display.

A list of key figures for the table you specified appears.
Defining Key Figures

Within the Report Writer, a key figure is an extension of the cell concept. A key figure performs various cell calculations within a report, such as subtracting subtotals within a column. The key figure pinpoints particular locations of a key figure block within the column-row matrices of a report.

The following graphic is an example of a key figure in a report.

```
<table>
<thead>
<tr>
<th>Assets/Liabilities</th>
<th>Local/Actual</th>
</tr>
</thead>
<tbody>
<tr>
<td>100010 Bank Accounts</td>
<td>750,000.00</td>
</tr>
<tr>
<td>100020 Accounts Receivable</td>
<td>400,000.00</td>
</tr>
<tr>
<td>100030 Merchandise Inventory</td>
<td>600,000.00</td>
</tr>
<tr>
<td>100040 Property</td>
<td>150,000.00</td>
</tr>
<tr>
<td>100050 Investments</td>
<td>370,000.00</td>
</tr>
<tr>
<td>* Asset Accounts</td>
<td>2,270,000.00</td>
</tr>
<tr>
<td>200010 Accounts Payable.</td>
<td>650,000.00</td>
</tr>
<tr>
<td>200020 Notes Payable</td>
<td>350,000.00</td>
</tr>
<tr>
<td>200030 Common Stock</td>
<td>270,000.00</td>
</tr>
<tr>
<td>200040 Long-Term Liabilities</td>
<td>800,000.00</td>
</tr>
<tr>
<td>200050 Retained Earnings</td>
<td>200,000.00</td>
</tr>
<tr>
<td>* Liability Accounts</td>
<td>2,270,000.00</td>
</tr>
</tbody>
</table>

** Assets/Liabilities

| Current Key Figure       | 1995          |
| Current Key Figure       | 1.00          |
```

In the above graphic, the current key figure (current assets/current liabilities) for 1995 is displayed in the lower portion of the balance sheet report. You can define this key figure using a formula whose operands are cells. These cells are addressed through the symbolic names contained in the row and column sets of the report.

To define the example key figure in the above graphic, you perform the following steps:

5. Define key figure text.

   You define key figure text for the following objects:

   - Key figure block
     
     A key figure block is a matrix of key figures and lists all key figures that you want to use in the report. You can define a key figure block that contains one or more key figures.

   - Key figure row(s)
     
     You define this text for the key figure row(s) of your key figure block. The text appears in the report row(s) of the key figure block. For each row you enter, the system creates a row for the current key figure block. The text you enter appears in the report row for the key figure result.
Defining Key Figures

6. Define the key figure column(s).

You define this text for the key figure column(s) of your key figure block. This text appears in the report column(s) of your key figure block. For each row you enter, the system creates a column for the current key figure block.

For the report in the above graphic, the key figure block text is **Current Key Figure**, the row text is also **Current Key Figure**, and the column text is **1995**.

7. Define the key figure formula.

For each key figure row/column intersection that you define for your key figure block, you define a key figure formula that calculates the amount that should appear for the row/column intersection.

For the report in the above graphic, you would have to define a key figure formula for the row **Current Key Figure** and column **1995**.

To calculate the key figure in the above graphic, the Report Writer uses set symbolic names to identify the current assets total (CA) and the current liabilities total (CL). It then divides the current assets by the current liabilities and displays them in the report (as defined in the report row definition). The key figure formula is **CA/CL**.

8. Define the cells for the key figure.

You need to define each cell (row/column coordinate) that you use in a key figure formula.

The key figure formula for the report in the above graphic contains the cells **CA** (Current Assets) and **CL** (Current Liabilities). In this key figure, the current assets (cell name CA) are divided by the current liabilities (cell name CL).

- **Cell A**: The row coordinate is the symbolic name **ASSETS** (total of the assets in single-dimension set TD-RACCT-GBS) and the column coordinate is the symbolic name **TD-HSL0** (total of local currency in data set TD-ACT-HSL).

- **Cell B**: The row coordinate is the symbolic name **LIABILIT** (total of the liabilities in single-dimension set TD-RACCT-GBS) and the column coordinate is the symbolic name **TD-HSL0** (total of local currency in data set TD-ACT-HSL).

You can also define key figure cells that refer to report rows for which you have entered a formula and/or key figure block.

8. Insert the key figure in a row block of the report.

Once you have defined the key figure, you insert the key figure block in a row block of the report.

To define a key figure block from any **Create Report** screen:
16. Choose Goto → Key figures.  
   The Create Report: Key Figure Blocks screen appears.

**Entering Text for Key Figures**

17. In the Name field, enter a description for the key figure block that you want to define.

18. Choose Edit → Rows.  
   The Rows from <key figure block name> screen appears.

19. Enter the necessary data and choose Continue:

   – Enter the code that represents the character you want to appear before the key figure row (B field).
   – Enter the code that represents the character you want to appear after the key figure row (A field).
   – Set the H indicator if you want to highlight the key figure row.
   – Enter the code for the color in which you want the key figure row to be displayed (C field).
   – Specify whether you want to insert a page break or blank lines between the individual logical rows in a key figure block.
   – Enter the text that you want to appear for the key figure row. The text you enter appears in the row for the key figure block.

20. Choose Edit → Columns.
   The Columns from <key figure block name> screen appears.

21. Enter the following data as required and choose Continue:

   – The print class that you want to use for the key figure column.
   – Specify whether you want to insert a page break or blank lines between the individual logical columns in a key figure block.
   – Enter the text that you want to appear for the key figure column. The text that you enter appears in the column for the key figure block.

**Entering Formulas for Key Figures**

22. Choose Edit → Formulas.
   The Formulas from <key figure block name> screen appears. For each key figure that you use in a report, you must define the formula used to create the key figure.

23. Position the cursor where the key figure amount should appear, and choose Formula.
   A dialog box appears.

24. Enter a formula in the dialog box. This formula must describe a key figure that you want to use in your report. Choose Continue.

   If you define a key figure formula, use the mathematical operations contained in the table in Using Set Formulas in the Report Writer [Seite 906]. You can enter as many cell names as necessary to calculate your key figure.
Defining Key Figures

The key figure appears at the intersection of the key figure row and column text on the Formulas from <Key Figure Block Name> screen.

When you defined cells, you entered apostrophes around the name of the cell. You must also enter apostrophes when defining cells for key figures.

25. To exit the Formulas from <Key Figure Block Name> screen, choose Continue.

Defining Cells for Key Figures


The List of All Cells screen appears.

When a cell has been defined, the Def indicator is set. The No. uses field displays how many times the cell is used in report key figures or column formulas.

You define key figure cells in a similar way to defining report cells. A cell pinpoints a particular location within a report. Once the Report Writer has located a point, it can then use the corresponding value (amount) for the key figure formula.

You define the coordinates of a cell using symbolic names. A symbolic name is a name assigned to a set line or to a set header, which defines the row and column coordinates for a report cell. You can use a symbolic name to represent all of the values in a set or to represent an individual set value.

For more information on symbolic names, see Using Symbolic Names in the Report Writer [Seite 909].

You can also define key figure cells that refer to report rows for which you have entered a formula and/or key figure block.

Example:

Your report contains the following rows:

- Income Accounts (row block 1)
- Expense Accounts (row block 2)
- Sum of the Income and Expense Accounts (row block 3)

This sum is calculated with the formula ‘001’ + ‘002’

You can now define a cell in a key figure block that references the sum of the income and expense accounts (the formula entered in row 3 of your report definition).

The procedure for defining key figure cells has therefore changed slightly to accommodate this new enhancement.

27. Position your cursor on the first cell you want to define, and choose Define cell.

The Definition of Cell <Cell Name> dialog box appears. In the Block number field, enter the number of the row block for which you want to enter the row coordinate of the cell.

28. Choose Continue.
The dialog box that appears depends on the type of row block you entered in the Block number field in the previous dialog box.

If the row block is a Set row block:

The Definition of Cell <Cell Name> dialog box appears.

On this screen, you define the row and column coordinates for the cell.

To select a symbolic name used as a row coordinate for the cell:

a) Check the row block number in the Row - Block number field. The row block number you entered in the previous dialog box appears as the default value. You can choose a different row block for the row coordinate by choosing Other row block next to the field.

b) Choose Define row coordinates.

A dialog box appears, listing the symbolic names that you can use as a row coordinate.

c) Select the symbolic name that you want to use as a row coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

To select a symbolic name as a column coordinate for the cell:

a) In the Block number field, enter a block number.

b) Choose Define column coordinates.

A dialog box appears, listing the symbolic names that you can use as a column coordinate.

c) Select the symbolic name that you want to use as a column coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

If the row block is a Formula row block:

The Definition of Cell <Cell Name> dialog box appears.

On this screen, you define the column coordinate of the cell. The row coordinate is already determined from the row block number you entered in the previous dialog box because a formula row only comprises one report row.

To select a symbolic name used as the column coordinate of the cell:

a) In the Block number field, enter a block number.

b) Choose Define column coordinates.

A dialog box appears, listing the symbolic names that you can use as a column coordinate.

c) Select the symbolic name that you want to use as a column coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

If the row block is a Key figure row block:
Defining Key Figures

The Definition of Cell <Cell Name> dialog box appears.
On this screen, you define the row and column coordinates for the key figure block.

a) Enter the row number of the key figure block.
b) Enter the column number of the key figure block.

If you want to define a key figure cell that refers to a key figure block, you must first insert the key figure as a row block in the row definition of your report.

For more information, see the following subsection Inserting Key Figures in Row Blocks.

29. Define additional key figure cells.
Refer to steps 12-13 for more information.

30. On this screen, you can use the additional processing functions in the table Create Report: Initial Screen as well as the functions in the following table.

Additional Processing Functions (Create Report: Key Figure Blocks)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Rows</td>
<td>Define text for the key figure rows</td>
</tr>
<tr>
<td>Edit → Columns</td>
<td>Define text for the key figure columns</td>
</tr>
<tr>
<td>Edit → Formulas</td>
<td>Define key figure formulas</td>
</tr>
<tr>
<td>Edit → List of cells</td>
<td>Define key figure cells</td>
</tr>
<tr>
<td>Edit → Insert block</td>
<td>Insert a key figure block</td>
</tr>
<tr>
<td>Edit → Delete block</td>
<td>Delete a key figure block</td>
</tr>
<tr>
<td>Goto → Report layout → Use standard layout</td>
<td>Reset layout parameters to default values of standard layout</td>
</tr>
<tr>
<td>Extras → List of characteristics</td>
<td>Display a list of characteristics that are used (or can be used) in the report</td>
</tr>
<tr>
<td>Extras → Maintenance language</td>
<td>Switch to a new report language (for example, to enter text for the report description in another language).</td>
</tr>
<tr>
<td>Extras → Other std layout</td>
<td>Assign new standard layout to the report</td>
</tr>
<tr>
<td>Extras → Threshold value</td>
<td>Enter threshold value condition to highlight in color or print report rows, depending on the values in a specific report column</td>
</tr>
</tbody>
</table>

Inserting Key Figures in Row Blocks
To use the key figure in the report, you must insert the key figure into a report row:
5. Choose Goto → Rows.
   The Create Report: Rows screen appears.

6. Position the cursor on the row block in which you want the key figure to appear.

7. Choose Edit → Insert key figures.
   A list of defined key figures appears in a dialog box. If only one key figure is defined for
   the report, it automatically appears on the Create Report: Rows screen.

8. Select a key figure and choose Choose.
   The selected key figure appears on the Create Report: Rows screen.
Inserting Key Figures in Row Blocks

4. On the Create Report: Rows screen, move the cursor to the row block line where you want the key figure to appear.

5. Choose Edit → Insert key figures.
   A list of defined key figures appears in a dialog box. If only one key figure is defined for the report, it automatically appears on the Create Report: Rows screen.

6. Select the key figure that you want to include in the report and choose Choose.
   The selected key figure appears on the Create Report: Rows screen.

For more information about defining key figure blocks, see Defining Calculated Key Figures [Seite 875].
Report Painter / Report Writer

Purpose

The SAP System provides comprehensive and flexible reporting tools for the analysis of existing cost flows in an enterprise. You can use these both to carry out recurring standard evaluations and to create reports for extraordinary queries and tasks. You can analyze data interactively as soon as it has been created in the SAP System and trace its origins right down to document level. All reports that are available online can also be executed in the background. This is particularly important in the case of very extensive datasets.

For objects with a hierarchical structure, such as cost centers, you can either create single reports for all the nodes in the hierarchy and for the individual objects, or you can generate all the relevant reports via the database in a selection run. If you choose the second possibility, you can navigate interactively within the hierarchy. This offers, among other things, a very flexible control of cost center areas, for example.

Report Painter and Report Writer are two very comprehensive reporting tools provided by SAP, using which you can report data from the Special Purpose Ledger (FI-SL) and other application components.

Integration

When defining reports using Report Painter or Report Writer, FI-SL tools, such as sets [Seite 633], variables [Seite 689] and key figures [Seite 708], are also used.

Features

The Report Painter [Extern] and Report Writer [Extern] provide the following functions:

- Report call
- Report processing
- Report definition

For more information on working with reporting tools, see:

Report Painter or Report Writer? [Seite 724]
Report Painter [Seite 726]
Working with the Report Painter [Seite 728]
Report Writer [Seite 797]
Working with the Report Writer [Seite 800]

Example

You can see an example of a Report Painter report under Creating an Example Actual/Plan Comparison Report Using the Report Painter [Seite 736].
Report Painter or Report Writer?

Use

The Report Painter and Report Writer are tools used to define reports.

The Report Painter is similar to the Report Writer, but is simpler to use. Most of the functions in the Report Writer are also available in the Report Painter. To create Report Painter reports, you do not need extensive knowledge of Report Writer concepts (such as sets [Seite 633]).

When Report Painter reports are executed they are displayed as Report Writer reports. They thus have the same functions as correspondingly defined Report Writer reports and can be combined with Report Writer reports in one report group.

The Report Painter uses a graphical report structure, which forms the basis for your report definition and displays the rows and columns as they will appear in the final report output, making test runs unnecessary.

To facilitate report definition, you can use many of the standard reporting objects provided by SAP, such as libraries, row/column models, and standard layouts, in your own specific reports. When you define a Report Painter report, you can use groups (sets), but you can also enter the characteristic values directly.

For more information on the Report Painter, see Report Painter [Seite 726].

The Report Writer has extensive functions that require a certain amount of familiarization.

As the Report Painter includes most of the functions available in Report Writer and is also simpler to use, we recommend that you use the Report Painter as a general rule.

For more information on Report Writer, see Report Writer [Seite 797].

Integration

The main difference between the two tools is the graphical user interface of the Report Painter. The use of sets in Report Writer is another difference. The differences are presented in the following diagram:
For more information, see Report Painter reports [Extern] and Report Writer reports [Seite 804].
Report Painter

Purpose
You use the Report Painter to create reports from data in the Special Purpose Ledger (FI-SL) application component and other R/3 application components to meet your specific reporting requirements.

Many reporting requirements can be met using the standard reports provided by various R/3 application components. However, if your reporting requirements are not fulfilled by SAP’s standard reports, you can use the Report Painter to quickly and easily define your own reports.

The Special Purpose Ledger (FI-SL) application component does not provide any standard Report Painter reports because you must first install your FI-SL system setup (database tables and so on) to meet your specific business requirements.

Advantages of the Report Painter include:
• Easy and flexible report definition
• Report definition without using sets
• Direct layout control

Integration
The Report Painter is similar to the Report Writer [Seite 797], but is easier to use. Many of the Report Writer functions are available in the Report Painter, but you do not need to be familiar with Report Writer concepts (such as sets) to be able to use the Report Painter.

To facilitate report definition, you can use many of the standard reporting objects provided by SAP (such as libraries, row/column models, and standard layouts) in your own specific reports. When you create a Report Painter report, you can use groups (sets), but you can also enter characteristic values directly.

Features
You define Report Painter reports using a graphical report structure, which forms the basis for the report definition. This graphical structure displays the report rows and columns as they will appear in the final report when the report data is output. When you execute a Report Painter report, the system automatically converts the Report Painter report into Report Writer format.

You will find a procedure for creating a Report Painter report under Creating a Report Painter Report [Seite 811].

You can add multiple reports to a report group. You can switch back and forth between the reports in a report group.
If the system takes a long time to select the data for the report, SAP recommends that you store the selected data in an extract. Once data is stored in an extract, it can be output later without having to be selected again.

**Converting a Report Painter Report into a Report Writer Report**

Since the Report Painter does not currently support all the functions of the Report Writer, you can convert a Report Painter report into a Report Writer report so that you can use the complete range of functions provided by the Report Writer. To do this, follow the procedure for creating a new Report Writer report using the Report Painter report as a basis. The Report Painter report is copied and becomes available as a Report Writer report. The system generates the required sets automatically.

You cannot, however, edit the sets generated in this way using the set maintenance function. Nor can you use these sets in other reports or functions.

**Example**

You will find a detailed example for creating a Report Painter report under Create Actual/Plan Comparison Report [Seite 741].
Working with the Report Painter

Purpose

This process describes the main steps in creating a Report Painter report.

The steps that you carry out to create a Report Painter report may deviate slightly from the following description. This depends on how complex your reports are and whether you are using the standard objects of SAP reporting.

Process Flow

2. Select a library for your report.

All reports are assigned to libraries. A library is a collection of characteristics, basic key figures, and key figures. Reports that are assigned to a particular library can use only the characteristics, basic key figure, and key figures of that library.

You can either use the standard SAP libraries or create your own.

For more information, see Libraries [Seite 927].

4. Select a standard layout for the report.

The standard layout [Seite 1017] determines the layout features of the report and the format of your report data.

If the SAP standard layouts do not meet your reporting requirements, you can create a new standard layout or change an existing one.

You can also adapt the report layout [Seite 1029] to your individual requirements, and define special section layouts [Seite 1028] for particular sections of the report.

For more information, see Layout [Seite 1016].

5. Define row and column models.

A model is a one-dimensional, predefined reporting structure, which you can insert in either the rows or columns of your report.

If you often use the same or similar row or column definitions in your reports, we recommend that you create row or column models.

You must define the row and/or column models that you want to include in your report definition before you define the report.

You can also use the standard models provided by SAP. For more information, see Defining Row and Column Models [Seite 744].

5. Define the report.

a) Define the report columns.

You define the report columns using the key figures selected for the library that the report uses. The key figures consist of the basic key figure and any characteristics you added.
Alternatively, you can use a column model for your column definition.

For more information, see Defining Columns [Seite 748].

b) Define the report rows.

You define the report rows using the characteristics selected for the library that the report uses.

Alternatively, you can use a row model for your row definition.

For more information, see Defining Rows [Seite 751].

c) Edit and format the report rows and columns in accordance with your requirements. (For example, you can hide rows and columns, and change the column widths and row colors.)

For more information, see Formatting Rows and Columns [Seite 755].

d) Define the general data selection criteria for selecting report data.

The selection criteria are the characteristics used to select data for the entire report. You cannot enter characteristics as data selection criteria if they are already being used in the report rows or columns.

For more information, see General Data Selection [Seite 762].

6. **Assign the report to a report group.**

Once you have defined a report, you assign it to a report group. A report group can contain one or more reports from the same library.

You can assign Report Painter reports and Report Writer reports to the same report groups.

For more information, see Report Groups [Seite 937].
Working with the Report Painter

7. **Generate the report group.**

   During this step, the system generates the programs necessary for processing the reports.

   When you generate a report group, the Report Painter reports are converted into Report Writer format. However, you can only change or display Report Painter reports using the Report Painter tool.

   For more information, see [Generating a Report Group](Seite 952).

8. **Execute the report group.**

   In this step, the system selects the data records specified by the report definition, and outputs them in the specified format.

   For more information, see [Report Group Execution](Seite 962).
Defining Reports for the Report/Report Interface

Use

The report/report interface allows you to call reports from other R/3 application components when you output your report data. You can call up report portfolio reports, drilldown reports, transactions, receiver reports, Report Writer reports, Report Painter reports, and ABAP programs.

If you define reports for the report/report interface in both the report group header and in the report group’s library, the system uses the reports that you have defined specifically for the report group.

Example

Your system is delivered with an ABAP program called RGGD1300, which displays line items for the FI-SL summary tables. The program reads the data from the FI-SL line item table and outputs a list of the line items.

You can call up program RGGD1300 directly (System → Services → Reporting) or from the report/report interface if it is defined as a receiver report for another Report Writer report. In a report that displays totals, you can then display the line items for a specific totals record.

To call program RGGD1300 as a receiver report to display line items for totals data in a report:

Procedure for Example

   Choose the symbol 📃 Header.


8. The group box Report/report interface contains information on the current assignment of the reports in this report group to the library of the report group. To assign a report to the report group, choose Configure.... The Assign Reports dialog box appears.


6. To enter program RGGD1300 as the receiver report, choose Other Report Type.

   A dialog box appears, listing the possible report types.

   The receiver reports you assign can be report portfolio reports, drilldown reports, transactions, Report Writer reports, and ABAP programs. This enables you to call receiver reports from other R/3 application components once you have output your report data.
You should normally assign receiver reports to the report group.

In this example, we are using the ABAP program RGGD1300 as the receiver report.


14. Enter RGGD1300 as the receiver report and choose 🍀.

The default text of program RGGD1300 is displayed in the Assign Reports dialog box.

15. You can use the following additional processing functions in this dialog box:

### Additional Processing Functions - Dialog Box for Report/Report Interface

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save receiver report for report/report interface</td>
<td>🍀 Save</td>
</tr>
<tr>
<td>Add receiver report to report/report interface definition</td>
<td>🍀 Insert row</td>
</tr>
<tr>
<td>Delete entry in report/report interface definition</td>
<td>🍀 Delete row</td>
</tr>
<tr>
<td>Insert report from another system (cross-system report assignment).</td>
<td>🍀 Add external report</td>
</tr>
<tr>
<td>You log on to the other system, select a receiver report, and transfer it to the sender system.</td>
<td></td>
</tr>
<tr>
<td>Select one or more receiver reports for further processing (for example, to move the selected report to another position in the list)</td>
<td>🍀 Select line</td>
</tr>
<tr>
<td>Move selected receiver report to another position in the list.</td>
<td>🍀 Move</td>
</tr>
<tr>
<td>Display default text of a receiver report if you have previously overwritten the default text of the report. Note: when you first enter a receiver report, the default text for this report is automatically displayed.</td>
<td>🍀 Default text</td>
</tr>
<tr>
<td>Display all reports to which the specified sender report is assigned as the receiver report. If you activate this function again, the original list is displayed.</td>
<td>🍀 Sender &lt;-&gt; Receiver</td>
</tr>
<tr>
<td>Display technical information on the receiver report(s) (for example, the report tool and the technical report name)</td>
<td>🍀 Technical names on/off</td>
</tr>
<tr>
<td>Documentation on displaying and maintaining the report assignment in the report/report interface</td>
<td>🍀 Help</td>
</tr>
</tbody>
</table>

16. Choose 🍀 to save your entries.

### Example

The Report Writer uses ABAP program RGGD1300 as shown in the following graphic:
The report in the graphic displays accounts by periods. This report is assigned to report group TD00. Report group TD00 has been defined such that ABAP program RGGD1300 is a receiver report in the report group (on the Create Report Group: Header screen).

Program RGGD1300 is called up with the Report Writer as follows:

k) After selecting the report data for the report, the system displays the report.

You can select part of the displayed report and have the system display the associated line items.

l) Select amount 600 for account 4000020 in period 1 from the report.

m) When you choose Reports, the system generates a list of the reports that are defined as receiver reports in report group TD00 (Create Report Group: Header screen).

n) Select program RGGD1300.

o) The Report Writer adopts the selection criteria from the report (such as the company code, ledger, account, and period) and starts the ABAP program RGGD1300. This program displays the line items that meet the selection criteria (company code TD11, ledger D2, account 4000020, period 1).

For more information on calling receiver reports, see Functions in the Report Output [Seite 974].
Creating a Report Painter Report

Procedure

3. From the relevant application, choose Tools → Report Painter → Report → Create.


   Enter the name of the library the report is to use, and a name and description for the report. The report name can be a maximum of eight characters long.

   If you want to create your report using an existing Report Painter report as a basis, enter the name of the report that you want to copy under Copy from. Both reports must use the same library.

6. Choose Create.

   The next screen displays an empty report containing four rows and four columns (this is the basic structure for a report). You define your report on this screen.

7. Enter or change the description for the report by double-clicking the report description field.

   A dialog box appears in which you can enter a short, medium, and long text for the report description.

8. Define the rows of your report (see Defining Rows [Seite 751]).

   Rows contain a combination of characteristic values or formulas. Note the lead column at the first position of the rows. The Report Painter uses the lead column to access the rows. You can replace the description Lead column with a different term.

9. Define the columns of your report (see Defining Columns [Seite 748]).

   Columns contain a combination of a basic key figure and optional restricting characteristic values. You can also use predefined key figures to present key figures and characteristics that make business sense. For example, a number of predefined key figures are delivered for the libraries in Overhead Cost Controlling that can be copied directly into the reports, where they can be modified as required.

10. Define general data selection criteria (see General Data Selection [Seite 762]).

    The general data selection criteria restrict data selection for the report.

13. Choose Save and then Execute to create the report.

14. Assign the report to a report group [Seite 937].

   You have to display the report before you execute it, so that you can later change the report layout directly from the report list.
Once you have defined a report, you can display and print out a table of contents with *Extras* → *Overview*.

The overview contains the characteristics and characteristic values used in the individual sections, column blocks, and general data selection criteria. It also provides general information such as the user who last changed the report, the report name, and the standard layout assigned to the report, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.

For more information, see:

- Defining Report Headers [Seite 817]
- Defining Report Text [Seite 825]
- Defining Report Layouts [Seite 1031]
- Defining Cells [Seite 864]
- Defining Global Cells [Seite 870]
- Defining Report Documentation [Seite 945]
Creating an Example Actual/Plan Comparison Report Using the Report Painter

This section shows how a Report Painter report is created, using the example of an actual/plan comparison report.

Reporting Requirements

You want the actual/plan comparison report to contain the following information:

- Actual and plan values from different business areas
- The absolute and percentage variances between the actual and plan values
- All periods in the fiscal year

Before you define the report, you must decide the following:

- Which characteristics should be used in the report?
- Where should the characteristics be entered in the report definition (in the rows, columns, or as data selection criteria)?
- Which characteristics should be entered as variables, individual values, value intervals, or groups?

A given characteristic can only be used once in a report: in the report rows, report columns, or as data selection criteria.

The following characteristics are used in the example actual/plan comparison report:

- Characteristics in general data selection:
  - Ledger
  - Company code
  - Fiscal year
  - Period

- Characteristics in the report rows:
  - Account
  - Business area

- Characteristics in the report columns:
  - Basic key figures
  - Record type
  - Version

Before you define your report, you must define the variables that you want to use in the report definition.

Define the following variables for the actual/plan comparison report (the names for the variables are example names only):
Creating an Example Actual/Plan Comparison Report Using the Report Painter

Variables Used in the Example Actual/Plan Comparison Report

<table>
<thead>
<tr>
<th>Variables</th>
<th>Variable type</th>
<th>Default value</th>
<th>Used in the report</th>
</tr>
</thead>
<tbody>
<tr>
<td>YEAR</td>
<td>Formula</td>
<td>Current year (for example, 2001)</td>
<td>As data selection criteria for the characteristic Fiscal Year</td>
</tr>
<tr>
<td>FPER</td>
<td>Value</td>
<td>01</td>
<td>As data selection criteria for the characteristic Period</td>
</tr>
<tr>
<td>TPER</td>
<td>Value</td>
<td>12</td>
<td>As data selection criteria for the characteristic Period</td>
</tr>
<tr>
<td>PLANVER</td>
<td>Value</td>
<td>001</td>
<td>In the report columns for the characteristic Version</td>
</tr>
</tbody>
</table>

To create variables on the Report Painter screen, choose Report Writer → Variable → Create. For more information, see Creating Variables [Seite 692].

Defining Report Rows

You define the report rows by choosing Edit → Elements → Insert element or by double-clicking on the relevant cell.

Accounts and business areas should be listed in the report rows. To enter this information, you can define one report row that contains the characteristics Account and Business Area. You select the characteristics from the list in the dialog box. This list contains all the characteristics selected for the report’s library.

To define values for the characteristics Account and Business Area, enter specific values, value intervals, or groups. The report will always be created for the values you enter here.

To be able to vary the input values for the characteristics when you run the report, you should enter variables using $$. The system prompts you to enter values for these variables on the selection screen during report execution.

In this example report, we have not entered variables for the characteristics Account and Business Area.

Exploding Report Rows

If you entered a group for the characteristics Account and/or Business Area, you should display the values in the report for the individual accounts/business areas and create subtotals for the different hierarchy levels of the group.

Choose Edit → Rows → Explode. The default setting Do not expand means that only a row total is displayed for the account/business area group. The SingleVals indicator displays individual values, but no subtotals or totals. Select PartSets to display the individual values, subtotals, and a total for the characteristic Account and/or Business Area. Exploded subtotals and totals are displayed in the report definition with summation levels (asterisk).

For more information, see Exploding Report Rows [Seite 753].
Creating an Example Actual/Plan Comparison Report Using the Report Painter

Defining Report Columns

In the report columns, you want to display the actual and plan values for the selected periods. In addition, you want the columns to display the variance between actual and plan in absolute numbers and as percentages.

You define report columns using the same procedure as that used for defining the report rows.

You can also enter basic key figures in your report columns. These are the basic key figures selected for the library that your report uses.

- **Column 1: Actual Values in Local Currency**
  
  You should enter the following characteristics and characteristic values for the Actual column:

<table>
<thead>
<tr>
<th>Basic key figure</th>
<th>“Local currency” (HSL)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Characteristic 1: record type</td>
<td>0 (actual)</td>
</tr>
<tr>
<td>Characteristic 2: version</td>
<td>001</td>
</tr>
</tbody>
</table>

- **Column 2: Plan Values in Local Currency**
  
  You should enter the following characteristics and characteristic values for the Plan column:

<table>
<thead>
<tr>
<th>Basic key figure</th>
<th>“Local currency” (HSL)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Characteristic 1: record type</td>
<td>1 (plan)</td>
</tr>
<tr>
<td>Characteristic 2: version</td>
<td>&amp;PLANVER</td>
</tr>
</tbody>
</table>

  The Plan column uses a variable for the characteristic Version.

To simplify defining the report, you can create the Plan column by copying the Actual column. You use the Select and Copy functions to copy the column element. You can then modify the copied column as required.

- **Column 3 and 4: Absolute Variance/Percentage Variance**
  
  You define the absolute and percentage variance columns by entering formulas in the formula builder. The formulas are calculated using the column elements that you have just defined. Before leaving the formula builder, you should check that the formula is correct using the Check function.

Enter text for the report columns. Enter the column text the same way you enter row text.

Defining General Data Selection Criteria

The characteristics entered as data selection criteria determine which data is selected for the entire report.

You define general data selection criteria under Edit → General data selection.

Enter the following characteristics and characteristic values for the example actual/plan comparison report:
Creating an Example Actual/Plan Comparison Report Using the Report Painter

- Company code: As required
- Ledger: As required
- Fiscal year: &YEAR
- From period: &FPER
- To period: &TPER

The characteristics Fiscal Year and Period are variables. This allows you to run the report for any periods within a given fiscal year. When you execute the report’s report group, the system prompts you to enter values for these variables on the selection screen. You can either use the default value of the variable or overtype the default with a different value.

Defining Report Texts

You can define texts for the title page, headers, footers, end page (last page), and for the text for export under Extras → Report texts.

You can define normal text, as well as text variables in your report text. You can use the following types of text variable:

- Standard text variables
- Special text variables
- Text variables for selection parameters
- Text variables for characteristics

For more information about these text variables and entering report texts, see Using Variables in Report Text Definition [Seite 826].

Changing the Standard Layout

The standard layout determines the layout of your report. For example, the standard layout defines the page format (such as the margins) and the numerical format of the data in the report. The standard layout SAP is assigned to your report automatically. To assign a different standard layout to your report, choose Formatting → Report layout.

If you assign a new standard layout to your report, the layout formats of the new standard layout replace any layout changes you made that are specific to the report you are editing. (The system displays a dialog box, asking you if you want to change the current format settings.)

You can also make certain layout changes within the report definition under Formatting.

Checking the Report, Assigning a Report Group, Report Execution

After you have saved your report definition, make sure it does not contain any errors by choosing Report → Check. If there are any errors, the system lists them in an error log. You should correct the errors shown in the error log before assigning the report to a report group.

Once the report definition is free of errors, you can assign your report to a report group by choosing Environment → Assign report group. If the report group you enter does not exist, a
Creating an Example Actual/Plan Comparison Report Using the Report Painter

dialog box asks if you want to create the report group. To create the report group and add the report to it, choose Yes.

To execute the report, choose Report → Execute. If you have not yet assigned the report to a report group, you can do so at this point. Once the system has generated the report group, you can enter the criteria for selecting the data records on the selection screen.

For more information on executing report groups, see Report Group Execution [Seite 962].
Create Actual/Plan Comparison Report

Use

This section shows you step by step how to create an actual/plan comparison report with the Report Painter. The report contains information about the actual and plan values of various business areas.

The following information is contained in the report:

<table>
<thead>
<tr>
<th></th>
<th>Actual costs</th>
<th>Plan costs</th>
<th>Difference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Salaries</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Office space</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Travel costs</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Office supplies</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>*Total of all accounts</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Procedure

11. Choose Information systems → Ad-Hoc Reports → Report Painter → Report → Create. In the Report Painter: Create Report screen, enter Library 1VK, assign your report an name, such as Test01, and a description, such as report with totals. Choose Create.

12. Defining Rows:

You can edit a row by double-clicking on it. For the first row, choose Cost element from the available characteristics in the dialog box Element definition: Row 1. In the From field for the cost element, enter 430000 (Wages account). Choose the Change short, middle and long texts button and enter wages as the short text. Press the Copy short text button to copy the short text entered to the other two text fields. Exit the text creation screen with Confirm. The dialog box Element definition: Wages screen is displayed. Choose confirm. The definition of row 1 is now complete.

For all other rows, proceed in the same manner. When creating additional rows, you can select the element type. Select Characteristics in the Select element type dialog box and then choose Confirm. Use the following accounts:

<table>
<thead>
<tr>
<th>Account name</th>
<th>Accounts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Office space</td>
<td>470000</td>
</tr>
<tr>
<td>Travel costs</td>
<td>474100</td>
</tr>
<tr>
<td>Office supplies</td>
<td>476000</td>
</tr>
</tbody>
</table>

13. Defining a formula row (totals row)

To enter the totals row (row 5), in the Select element type dialog box, select Formula and then choose Confirm. In the Enter formula dialog box, add all parts of the formula: Y001 + Y002 + Y003 + Y004 and then choose Confirm. In the Enter texts dialog box, enter a text such as total of accounts in the short text field and copy it to the other text fields.

14. Define Column 1 (Actual costs)
Create Actual/Plan Comparison Report

You can edit a column by double-clicking on it. For the first column, in the Select element type dialog box select the element type Predefined key figure and choose confirm. In the Choose predefined column dialog box, select Actual costs and choose confirm. In the following Element definition: Actual cost screen, you can see how the predefined key figure has been defined. Choose confirm. Column 1 is defined.

15. Define Column 2 (Plan costs)

To define the second column, in the Select element type dialog box select the element type Key figure with characteristics and choose confirm. In the Element definition: Column 2 dialog box, enter value type 01 in the From field for plan values. Enter 0 for the version (current version). Enter 0 for the actual valuation. Choose the Change short, middle and long texts button and enter a text such as plan costs. Choose Confirm in the Element definition: Plan cost dialog box. Column 2 is defined.

16. Define formula column (difference)

To define the third column, in the Select element type dialog box select the element type Formula and choose confirm. In the Enter formula dialog box, enter the parts of the formula (X001 - X002) to define the difference. Choose Confirm and enter Difference as the text in the Enter text dialog box. Copy the short text and choose Confirm. The formula column is defined.

17. Define General Selections

Choose Edit -> General data selection. The Element definition: General data selection dialog box is displayed. Select the values controlling area, fiscal year, period, and cost center from the available characteristics. Make the following entries for these characteristics:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Entry field</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area</td>
<td>From</td>
<td>1000</td>
</tr>
<tr>
<td>Fiscal year</td>
<td>From</td>
<td>Current fiscal year</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(2000, for example)</td>
</tr>
<tr>
<td>Period</td>
<td>From</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>To</td>
<td>12</td>
</tr>
<tr>
<td>Cost center</td>
<td>Select the Group field and make your entry in the From field.</td>
<td>H1010</td>
</tr>
</tbody>
</table>

Choose confirm. The general data selections are defined.

18. Check and save report

Check the report for errors or missing characteristics by choosing Report -> Check. Save your report by choosing Report -> Save.

19. Assign report to a report group

Choose Environment -> Assign report group to assign your report to a report group. In the Insert Report in Report Group dialog box, enter the name of the report group to which the report is to be assigned. You can use an existing report group for library 1VK or you can create a new report group for library 1VK. Enter a name for the report group, such as TEST. If this is a new report group, a dialog box will appear and you will be asked if you want to create a new report group. If you choose Yes, your report is included in this report group.
20. Execute report

Defining Row and Column Models

Purpose
If you often use the same or similar row or column definitions in your reports, it is recommended that you create row or column models.

A model is a one-dimensional, predefined reporting structure which you can insert in either the rows or columns of your report.

The following graphic shows how you can use row and column models in a report definition.

Process Flow
To be able to use models in a report, you need to carry out the following steps:

Creating a Model [Seite 745]
Applying a Model [Seite 746]
Transporting Models [Seite 747]
Creating a Model

10. To create a row or column model, choose Model → Create from the Report Painter [Extern] menu.

11. In the initial screen, you enter whether you want to define a column or a row model. This is where you determine the functions available for editing purposes.

12. Before you create the model, you must first assign it to a library [Extern]. The library contains the characteristics, key figures, and predefined columns which you can use in your model. All models and reports that use these models must be assigned to the same library.

13. Enter a name and short description for each model.

14. If you want to create a model using an existing model as a reference, enter the name of the existing model you wish to copy, or choose Model Copy, then enter the model and library.

15. You create row and column models with Report Painter in the same way as you create rows and columns in a report (see Creating Report Painter Reports [Seite 811]). In contrast to a report, however, models are only one-dimensional and do not contain any report texts.

   When defining a column model, you can only use the functions available for defining columns. You cannot use the Explode, Expand or Collapse functions for column models.

16. You can define several column blocks within column models. However, you cannot define different report sections within models.

17. Once you have defined your model, you should check for any errors using Model → Check.

18. After you have defined your row and column models, you can go directly to the report definition with Environment → Create report.

   Simplified definition of reports is made possible by a number of predefined row and column models.

   Row model 1-LM-BEL-ENT identifies all cost elements separately according to debit and credit postings and calculates any over- or under-absorption in a totals row.

   Column model 1-CM-QUARTAL displays the actual costs for all four quarters as well as for the complete fiscal year.
Inserting a Model

To insert row or column models in your report, put your cursor in the corresponding place and choose:

3. Edit → Rows → Get row model
   or Edit → Columns → Get column model
   When you insert the model, it overwrites all previously defined row and column definitions for that report section. For this reason, you should define additional report rows/columns only after you insert the model.

4. Edit → Rows → Insert row model
   or Edit → Columns → Insert column model
   The model is added to the defined report as the last row or column. No other row or column is overwritten.

   You can only use a characteristic in the report rows, columns or in the general selection criteria.

   Ensure that when you define a row, the characteristics used for it are not already being used in a column or in the general selection.

   Ensure that when you define a column, the characteristics used for it are not already being used in a row or in the general selection.
Transporting Models

Choose Utilities → Transport → Models in the Report-Painter [Extern] menu to export models to external files, import models from external files or to copy models from a source client.

The procedure is the same as for transporting Report-Writer [Extern] objects.

For more information on transport functions, see the SAP library under AC - Accounting → FI - Financials → Special Purpose Ledger → Report-Writer Utilities → Transporting Report-Writer-Objects [Seite 915].
Defining Columns

4. Position the cursor on the column you want to define, and choose Edit → Elements → Insert element, or double-click the element.

5. In the subsequent dialog box, specify what type the element should be:
   - Key figure with characteristics
     You combine a basic key figure with the characteristics you require.
   - Predefined key figure
     An appropriate combination of a basic key figure and one or more characteristics is offered by the system. You can accept the predefined key figure or change it.
   - Formula
     This option is only available if other elements are already defined.
     You can use the formula builder to calculate the values of the column. You can use other columns or previously defined cells for the calculation.

For information on the terminology of the elements, see Terminology [Seite 1037].

4. Choose Confirm.
   b. If you chose key figure with characteristics,
      a dialog box appears on which you can select the combination of basic key figure and associated characteristics to be displayed in the column being defined.
      In the upper area of the dialog box, select the basic key figure that you want to use in the report.
      From the list of available characteristics on the right-hand side of the dialog box, choose the characteristics you want to use. Move these to the left-hand side of the screen with the arrow. The characteristics displayed are those of the library assigned to your report. The order in which the characteristics appear in the selection list is determined by the Position field in the library definition.
      On the left-hand side of the dialog box, enter the values for the selected characteristic(s):
      - You can enter individual values, intervals of values, or groups for the chosen characteristic(s).
      - If you want to define all possible values for the chosen characteristic(s), enter an asterisk (*).
      - If you want to specify an initial value for the chosen characteristic(s), enter a pound sign (#).
      - If you want to enter a variable instead of a characteristic value, select . Enter the name of the variable and choose Confirm. You can only enter variables that already exist in your system. For more information, see Variables [Seite 689].
      - If you want to enter a characteristic value in the form of a set, select . Enter the name of the set and choose Confirm. You can only enter sets that already
Defining Columns

exist in the system. For more information, see Sets in Report Columns [Seite 898].

c. If you chose predefined key figure,

a list of predefined key figures is displayed, from which you can choose the key figure you want to use.

In the subsequent dialog box, you only need to enter the values for the characteristics. You can also change the key figure at this point, as described under key figure with characteristics.

d. If you chose formula,

a formula builder is displayed with which you can define a formula using other report columns and the previously defined cells. The column is calculated using the formula.

You can define formulas that refer to elements in different column blocks. However, you can only define formulas within one report section.

10. Choose and enter short, medium, and long texts for the column.
11. Choose Check and then Confirm.
12. To define additional columns, carry out steps 1 to 5 again.

You can copy report columns. Select a column and position the cursor where you want to insert the column. Choose Edit → Selected area → Copy. You can then change the copied column as desired.

You may find it useful to use sets to define entire blocks of columns. For more information, see the SAP Library under Creating Sets [Seite 651] and Using Sets in Report Columns [Seite 898].

Column Texts

If you want to change the text you entered for the report column, you can simply overtype the column text or position the cursor on the column element and choose Edit → Elements → Change text.

Under Formatting → Row/column texts you can specify which of the three text formats (short, medium, long) you want to use in the column header.

You can also use variables in your column headings. When you execute the report, the variables will be replaced with their default values if the column text type Key is selected in the report’s standard layout. To use a variable for the column text, enter the variable in the dialog box for the three column texts. First enter & and then the name of the variable.

Suppose your report uses the value variable &PERIOD for the period, and you want to display the current value for the period in a column heading. Enter &PERIOD in the column heading of the report. If the column text type Key is selected in your report’s standard layout, the variable is replaced with the period value (for example,
Defining Columns

5) when you execute the report. The description is printed for all other column text types (for example, May).

Editing Columns

The options under Edit → Columns allow you to select a variety of functions for editing report columns.

The option Edit → Get column model or Insert column model inserts a predefined column structure into your report columns. For more information, see Defining Row and Column Models [Seite 744].

The Edit → Columns → Hide function hides the report row on which the cursor is positioned. You can process hidden columns in the same manner as the hidden rows.

Using Formula Variables in Report Columns

A formula variable represents a user-defined formula that establishes a value for the variable. Numerical value variables and formula variables can be used as operands in column formulas. Using formula variables in report columns enables you to create new types of reports.

For more information, see Formula Variables in Reports [Seite 859].
Defining Rows

Rows in a report are defined in a similar way to columns. However, you cannot enter predefined key figures in rows. You define row elements using basic key figures in combination with the characteristics selected for the library that the report uses. You can also use formulas.

Procedure

6. Position the cursor on the row you want to define, and choose Edit → Elements → Insert element, or double-click the element. For information on the terminology of elements, see Terminology [Seite 1037].

3. Define the row.

   If no other rows exist in the section, a dialog box appears on which you can select the combination of basic key figure and associated characteristics to be displayed in the row being defined.

   In the upper area of the dialog box, select the basic key figure that you want to use in the report.

   From the list of available characteristics on the right-hand side of the dialog box, choose the characteristics you want to use. Use the arrow to move these to the left-hand side of the screen. The characteristics displayed are those of the library assigned to your report. The order in which the characteristics appear in the selection list is determined by the Position field in the library definition.

   On the left-hand side of the dialog box, enter the values for the selected characteristic(s):

   − You can enter individual values, intervals of values, or groups for the chosen characteristic(s).

   − If you want to define all possible values for the chosen characteristic(s), enter an asterisk (*).

   − If you want to specify an initial value for the chosen characteristic(s), enter a pound sign (#).

   − If you want to enter a variable instead of a characteristic value, select . Enter the name of the variable and choose Confirm. You can only enter variables that already exist in your system. For more information, see Variables [Seite 689].

   − If you want to enter a characteristic value in the form of a set, select . Enter the name of the set and choose Confirm. You can only enter sets that already exist in the system. For more information, see Sets in Report Rows [Seite 898].

      For performance reasons, you should use sets whenever possible.

   If rows have been defined in the section, you can also insert a formula. From the dialog box, choose Formula. A formula builder is displayed with which you can define a formula using other report rows and the previously defined cells. The row is calculated using the formula.
You can define formulas that refer to elements in different row blocks. However, you can only define formulas within one report section.

13. Choose and enter short, medium, and long texts for the row.

14. Choose Check and then Confirm.

15. To define additional rows, carry out steps 1 to 5 again.

You can copy report rows. Select a row and position the cursor where you want to insert it. Choose Edit → Selected area → Copy. You can then modify the copied row as desired.

You may find it useful to use sets to define entire blocks of rows. For more information, see the SAP Library under Creating Sets [Seite 651] and Sets in Report Rows [Seite 894].

**Editing Rows**

Under Edit → Rows there are a number of special functions for editing report rows. Get row model inserts a predefined row structure in your report rows. For more information, see Defining Row and Column Models [Seite 744]. Insert blank line inserts a blank line in the current row (where the cursor is positioned).

Edit → Rows → Hide hides the row on which the cursor is positioned. The hidden row retains its contents and can still be used in formulas. You can edit hidden rows with Hidden rows → Change. You can also delete and display the hidden rows (Delete and Show functions).

Edit → Rows → Explode expands the hierarchical levels of the group/value interval defined for the row characteristic. For more information, see Exploding Report Rows [Seite 753].
Exploding Report Rows

Use

You use the *Explode* function to specify whether individual values only, a sum only, or individual values with totals and subtotals are to be displayed for the characteristics used in the report rows.

If you have defined more than one characteristic in a report row, you can define the order in which the characteristics are displayed in the report.

Procedure

3. To explode a report row, position the cursor on the report row and choose *Edit → Rows → Explode*.

4. The *Explode characteristics* dialog box lists the row characteristics for which you have entered an interval of values, a group, or a variable. You can use the *Explode* function for each of these characteristics.

   In the standard system, the *No explode* indicator is set as the default. A row total only is displayed in the report for the characteristic.

   d. If you select *Single values*, only individual values are displayed in the report for the characteristic. Sums are not displayed in the report.

      It is advisable to select *Single values* for characteristics for which you do not usually calculate sums, such as statistical key figures or activity types.

   e. If you select *Explode*, the report displays single values, subtotals, and a grand total. Subtotals are calculated based on the hierarchical structure of the characteristic.

      You can specify the hierarchical sequence in which the characteristics are output in the report rows. The characteristic assigned number 1 appears at the highest level of the hierarchy. For each value defined for this characteristic, data is summarized for all of the characteristics below it in the hierarchy.

      You entered the characteristics *cost center* and *account* in a report row for cost centers 100, 200, and 300 and accounts 4000010 and 4000020. If you assign number 1 to *cost center* and number 2 to *account*, the report breaks down cost centers by accounts. If you switch the order, the report breaks down accounts by cost centers.

   f. You can use the function *Display sort order* to display the characteristics in the order you have defined.

      Exploded report rows are displayed with one or more asterisks in the report definition, depending on the row summation level.

      If you enter a group as the characteristic value for a report row, the hierarchical structure of this group is depicted in the report definition. If you set the *Explode* indicator for this row, all subtotals and the sum total are displayed for this group in the report definition,
Exploding Report Rows

together with the corresponding number of asterisks. The lowest level in the group (usually the individual values) are not displayed in the report definition.

Suppose you define a report row for the characteristic account and enter the group (the set) ACCOUNTS as the characteristic value. (The group ACCOUNTS is a single-dimension set containing income and expense accounts.) If you select Explode for the ACCOUNTS group, the report definition displays a totals row for all accounts, and subtotals rows for the income and expense accounts. The individual account values, however, are not displayed in the report definition.

If you enter a set variable as the characteristic value, the row structure is only determined when you output the report. The default set assigned to the set variable displays in the report definition. When you execute the report, you can overtype this default set on the selection screen if you want.

Suppose you define a report row for the characteristic account and enter the set variable ACCT as the group characteristic value. The default set of the variable only has one summation level. In the report definition, the exploded row is displayed with only one asterisk.
Formatting Rows and Columns

Column Formats

- Assigning a Standard Layout and Format Groups

You define the format of your report columns using format groups. These format groups tell the Report Painter which format to use in each report column. You can define up to five format groups, allowing you to use five different column formats in your report.

A format group is used to determine the following layout parameters:

- Column width
- Right column margin
- Display unit
- Decimal places
- Scaling factor
- Reverse +/- sign

You define the layout parameters for the different format groups in the report layout assigned to the report. The report layout also contains information on the report page layout and text formats. For more information on standard layouts, see Standard Layouts and Creating a Standard Layout.

You can display the standard layout assigned to your report with Formatting → Report layout. In the dialog box displayed, you can make changes to the report layout. The function Use standard layout assigns the new layout to the report as the standard layout.

The Format group row in the report definition displays the format group currently assigned to each report column. Format group 0 is automatically set as the default for all columns. To change the format group assigned to a column, double-click the format group field and select the desired format group. The column is then formatted according to the layout parameters for the specified format group.

- Changing the Default Settings of Format Groups

You can overwrite the default layout parameters for individual format groups in your report. These changes are only valid for the report that you are currently editing. To do so, position the cursor on the column to which the format group is assigned, and choose Formatting → Column.

You can overwrite the default parameters of the standard layout using the Column width, Numerical format, and Reverse sign functions. The numerical format controls how values are displayed in your report (scaling factor and number of decimal places).

If you specify one decimal place and a scaling factor of 1000 for the value 1000000, this value will be displayed as 1000.0 in the report.
Formatting Rows and Columns

The formatting functions under Formatting → Column change the format of all columns that use the same format group. If you want to change the format of a single column, you must assign a different format group to this column.

- **Aligning Column Headings and Selecting the Text Length**
  You establish the alignment of the column headings for all report columns. To change the horizontal alignment of text (left-justified, centered, or right-justified), choose Formatting → All columns → Text alignment.
  
  You can also specify which type of text you want to use in all column headings (short, medium, or long text). To do so, choose Formatting → Row/column texts and select the text type you want to display.

**Row Formats**

- **Overscore/Underscore**
  You can use the Over-/Underscore functions to highlight individual report rows. For example, you can have the system display lines above and/or below totals rows. To do so, position the cursor on the row and choose Formatting → Row. In the subsequent dialog box, activate Underscore and/or Overscore.

- **Row Colors**
  You can add color highlighting to individual report rows. To do so, position the cursor on the row and choose Formatting → Row. In the following dialog box, select a color (for totals, subtotals, inserted rows, or for emphasis). The system assigns a color based on the selection you make here.

  You can format more than one row at a time by selecting the rows and then formatting them, as desired. The rows remain selected once you have completed the format changes. You must remove the selections manually using the Deselect all function. Formatting commands that affect all rows or columns are independent of any selections you have made.

- **Text Type**
  You can specify which type of text you want to use in the report lead column (short, medium, or long text). To do so, choose Formatting → Row/column texts. In the dialog box, select the text type you want to display.

- **Expand to/Collapse to**
  You can only use the Expand to/Collapse functions for report rows that are exploded in the report definition and contain totals rows. You must therefore select a group as the characteristic value for the row and explode that row. The lowest level in a group hierarchy (usually the individual values) are not displayed in the report definition.

  If you position the cursor on an exploded row in the report definition and choose Collapse to or Formatting → Collapse to, you can specify the summation level up to which you want to collapse exploded report rows.
By choosing Formatting → Expand to, you can specify the summation level up to which you want to expand exploded report rows.

The summation levels you define in the report definition are used when you output the report. You can, however, expand or collapse these rows again in the report output.

The Report Painter does not process exploded report rows as individual row elements. You cannot therefore use all functions on exploded rows, which can be used on other report rows.

For example, if you use the Delete function on an exploded row, the system deletes the entire row element and not just the exploded row.

If you use the Underscore/Overscore and Color settings functions on exploded report rows, any changes you make are valid for all rows at the same characteristic level.

For more information, see Layout [Seite 1016] and Section Layout [Seite 1028]
Defining Cells

Use

Cells enable you to use values that the report displays for particular row/column combinations as operands in formulas. A cell pinpoints a particular location or range within the column-row matrix of a report. In the Report Painter, you can work with rows, columns, and individual cells. If you want to work with cells, you must select the relevant cells.

Procedure

You edit cells in the same way you edit row and column elements.

2. Position the cursor on the cell and choose Edit → Elements → Change/display, or simply double-click the cell.

   The cell is selected. All cells you select in this way can then be used in the formula builder in the entire report (all sections and horizontal pages) as operands for the definition of formulas.

3. If you don’t enter a text for the selected cell, the system automatically assigns a description to it. This description is the lead column/column header.

   To enter your own cell text, position the cursor on the cell and choose Edit → Element → Change text. You can then enter a short, medium, and long text for the cell.

• If you use cells as operands in formulas, but do not want to display or print these cells in your report, you can hide the rows and columns used to create the cell by choosing Edit → Rows/Columns → Hide. If you have selected the affected cells, you can still use them in the formula builder.

• If you want to select cells in exploded rows of a group (set), the selected cell always refers to the highest summation level in the group. If you want to select cells for a subgroup, you must define an additional report row for the subgroup, select the cell you want to use, and then hide the report row.
Defining Sections

Use
A section consists of one or more physical rows and columns forming a logical unit. In the vertical direction, a report consists of one or more sections. Each section is displayed on a new screen. You can define sections with key figures and characteristics, as well as sections with derived basic key figures.

In a section that contains calculated key figures, you can create an overview of the most important values used in your report. A section with calculated key figures is a new report section and is displayed on a new screen. You normally define a section with basic key figures at the end of your report.

Sections with Calculated Key Figures
5. To define a section with calculated key figures, first select the cells you want to use in the section. For information on selecting cells, see Defining Cells [Seite 758]. You can also enter your own text for these cells.
6. Choose Edit \rightarrow Sections \rightarrow New section. In the New Report Section dialog box, select Section with calculated key figures.
7. Position the cursor on the row or column and choose Edit \rightarrow Elements \rightarrow Define element or double-click on the row or column.
   The section with calculated key figures is made up of a row/column structure in which you enter short, medium, and long texts.
8. Define the cells you want to use in the section at the point of intersection of the row/column combination. Position the cursor on the appropriate cell and choose Edit \rightarrow Elements \rightarrow Define element, or double-click on the cell.
   You enter cell calculations for the section with key figures in the Formula Builder. All selected cells of the report are displayed in the Formula Builder as buttons. You can then define your key figure formula as required.
   The Formula Builder enables you to use the selected cells in the section with calculated key figures. You can also use cells that were calculated using the selected cells.
   Another feature is that you can reselect cells used in the section with calculated key figures to calculate values for other cells within the section (recursive cell definition).

If you don’t want to display or print the cells you use in your section with calculated key figures in the other sections of your report, you can hide the corresponding rows and columns by choosing Edit \rightarrow Rows/Columns \rightarrow Hide.

Sections with Characteristics and Key Figures
5. To define a new section in your report, choose Edit \rightarrow Sections \rightarrow New section.
6. In the following dialog box, select Section with characteristics and key fig.
Defining Sections

A new row and column structure appears for you to define your new report section. You define rows and columns as described under Defining Columns [Seite 748] and Defining Rows [Seite 751].

5. You can switch between the different sections by choosing Goto → Section → and then First section, Previous section, Next section, or Last section.

You can only perform calculations using columns within the same section. For calculations between sections that use columns, you must select cells. For more information, see Defining Cells [Seite 758].

Once you have defined a report, you can display and print out a table of contents of the report with Formatting → Section overview.

The overview contains the characteristics and characteristic values used in the individual sections, horizontal pages, and general data selection criteria. It also provides general information such as the user who last changed the report and the report name, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.
Defining Horizontal Pages

Use

A horizontal page consists of one or more physical report columns that form a logical unit. Each horizontal page is defined and displayed on a new report page and on a separate screen. When you define a new horizontal page, the report row definitions remain the same.

Procedure

To define a new horizontal page, choose Edit → Horizontal page → New column block.

- A row/column structure appears in which the rows are already defined. For information on defining columns, see Defining Columns [Seite 748].
- The icons 🔄 and 🔄 move the display back and forth between the horizontal pages.

You can perform calculations involving more than one horizontal page. You can therefore define formulas that refer to columns in different horizontal pages.
General Data Selection

Use
To define a report, you define the rows and column structure and the general selection criteria that apply to the report as a whole. The general selection criteria are the characteristics used to select data for your report. Your general data selection criteria can only contain those characteristics that are not already being used in the report rows and columns.

Features
To define the general data selection criteria for your report, choose Edit → General data selection.

⚠️
If you define data selection in a report with more than one account assignment object (such as cost centers and internal orders), you must make sure that all account assignment objects are completely defined in all sections.

In the orders section [Extern], you must add the characteristic cost center, while in the cost centers section you must add the characteristic order. The value for the cost centers in the order section, and for orders in the cost centers section, is always a pound sign (#).

Definition of 1st section:
– Cost center: &1KOSET
– Order: #

Definition of 2nd section:
– Cost center: #
– Order: &6-AUFGR

In the dialog box Element definition: General data selection, select from among the available characteristics those characteristics you want to use in general data selection. To select the characteristics, choose .

Enter values for the selected characteristics under Selected characteristics. You can enter individual values, intervals of values, groups, or variables.

➡️

The following characteristics must be defined in your report, either as data selection criteria, report rows, or report columns:
– Company
– Ledger
– Version
Record type

Period

To improve processing time, you should specify all characteristics in general data selection that are not needed in the report rows or columns.

In the reports assigned to table CCSS, the controlling area characteristic must always be used in general data selection. The controlling area characteristic can only be used as a single value or variable.

The company code characteristic depends on the time-dependent characteristic cost center. If the cost center is not valid during the current time period, the system cannot determine a valid company code for the data records of the selected cost center, and therefore no data can be displayed. If the cost center was valid in a different company code in the previous year, the system assigns the values posted on the cost center to the company code that is valid for the master data date of the report.

Since the relevant date for time-dependent master data in the Report Painter and Report Writer reports is the master data date, you should set this date explicitly such that all cost centers used in the report are valid on that date. To do this, choose Output parameters → Master data date in the selection screen of the report.

If you enter specific values, intervals of values, or groups for a characteristic, your report is always executed using these values. The More indicator displays a list in which you can enter several intervals or individual values for the characteristic on which the cursor is positioned.

You define the characteristic Year as data selection criteria for your report and enter 2000 as the year. When the report is executed, the system only selects data records for the year 2000.

If you enter a variable [Seite 689] for a characteristic, the system prompts you to enter a value for the variable on the Selection screen when you execute the report’s report group. The single value/set assigned to the variable appears as the default value on the selection screen. You can overwrite this default value if you want.

If you enter a variable as data selection criteria, the values you enter on the selection screen when executing the report’s report group are only valid for one report run. Each time you run the report, you can enter a different value for the variable.

To define a variable for a selection characteristic, turn on the Variable indicator in the relevant entry field in the column. Then choose Check to check the entry and refresh the screen. The input help function (F4) displays a list of available variables for the characteristic.

You create a set variable called CSTCTR for the characteristic Cost Center and enter a set name as the default value for the set variable. If you use this variable as
General Data Selection

data selection criteria in your report, the system asks you to enter a set name when you select the report data records. You can use the default set name assigned to the variable or another set.

The input help function always displays all variables for the relevant characteristic. Variables are displayed even if they are already being used in rows or columns.

You create variables within set maintenance. For more information, see Creating Variables [Seite 692].

Choose Confirm to conclude the definition of general data selection.

Variation

The variation [Extern] function allows you to create a separate report for each element in a group (set) that is used as general data selection criteria in your report.

When you execute a report for which variation has been defined, you can enter a variation range for report execution on the selection screen or specify the output of reports for single values.

For more information, see Executing a Report Group [Seite 964]. Within the report, you can then output individual reports online for the groups or individual values in the variation range.

Elimination of Internal Business Volume

For each characteristic, you can use the Elimination of internal business indicator to eliminate or display internal business volume in the report. Internal business volume represents the allocations that take place within one characteristic group.

For more information, see Elimination of Internal Business Volume [Extern] and Activating Elimination of Internal Business Volume [Extern].

If both the variation of the selection and the internal business volume elimination are activated, the internal business volume is eliminated dynamically. When you navigate between the reports for the elements of the group in the report output, the internal business volume is redetermined for each element and then eliminated in the report.
Defining Report Headers

4. In the menu of the Report Painter [Seite 726], choose Edit \(\rightarrow\) Report header.


   If you want authorization protection for the report, enter an authorization group.

6. Enter the name of the standard layout assigned to the report.

   When you first create a report, the default standard layout is SAP. This standard layout [Seite 1017] is shipped with all SAP R/3 Systems. For more information, see Layout [Seite 1016].

6. To make default settings for exporting the report to an application or presentation server, choose Export parameters.

   In the subsequent dialog box, enter the required data. You can see the default values you entered in the report output under Report \(\rightarrow\) Export. You can change these default settings as required.

   For more information on exporting reports, see Exporting Reports to an External File [Seite 985].

7. To save the report header, choose Continue.
Extracts

Use
To reduce the necessary runtime for formatting report data, you can create an extract when you execute a report. An extract is a dataset that contains the report data selected at the time the extract was created.

Extracts provide the same navigation and formatting options as reports selected directly from the database.

The main differences between an extract and a report are shown in the following table:

<table>
<thead>
<tr>
<th>Main Differences Between Report and Extract</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report (Newly Selected)</td>
</tr>
<tr>
<td>Currentness of data</td>
</tr>
<tr>
<td>Authorization check</td>
</tr>
<tr>
<td>Runtime</td>
</tr>
</tbody>
</table>

Aside from these differences, extracts offer full report functionality. When you call up a report that uses an extract, the system does not have to select the report data directly from the database. As a result, processing time improves considerably.

⚠️

If you create an extract and then make changes to the data structure in Customizing, this can result in inconsistencies between the current data structure and the structure in the extract. The data of the extract can therefore no longer be displayed.

⚠️

After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Integration
The final step in defining a report group [Seite 937] is executing the report group. You generate an extract when you execute the report with reference to the selection parameters entered at the time the report is executed. You can therefore create multiple extracts of the same report by entering different selection criteria each time.

If you called up the report using an extract, the system outputs the report using the extract data.

If you called up your report by selecting data from the database, the system outputs the report according to the selection criteria you specified and formats the report according to the report definition.

For more information, see Executing a Report Group [Seite 964].
Features

In expert mode [Seite 978], you can create extracts on the selection screen (for more information, see General Data Selection [Seite 762]) if you execute a report group and choose the button Extract parameters... and then the mode Create extract. Alternatively, you can save your report output as an extract when you exit the report. In this case, the system displays a dialog box, asking whether you want to save the report in an extract file.

If you call up a report when Display extract is selected as the data source, the system checks whether any extracts are available that match the selection criteria. You can then choose from among the available extracts. You can also search for, display, and print extracts using extract management. In both cases, direct access is possible to all extracts generated within a variation.

Extracts are deleted either manually in extract management or automatically based on an expiration date that you can specify when you create the extract.

⚠️

Once an extract has been deleted, it cannot be retrieved.

For more information, see Creating an Extract [Seite 1010] and Managing Extracts [Extern].
Create Extract

Use

There are two different ways of creating an extract [Seite 1008]:

- You can create extracts on the selection by choosing Extract Parameters and then choosing Create Extract in the dialog box.
- You can generate an extract when executing a report. To do this, follow the steps under Procedure.

You can only create extracts in expert mode [Seite 978]. Make sure that expert mode has been activated. You can make these settings from the selection screen by choosing Environment → Options.

Procedure


11. Enter the required report group and choose .

12. Enter the required selection parameters and choose .

If extracts already exist for the selection criteria you have specified, the system will display a list of extracts that you can choose.

The report is now displayed. Choose Report → Save. In the Enter: Extract Parameters dialog box, you can define the parameters for your extract. For further information about extract parameters, see Expert Mode [Seite 978]. To complete your entries, choose .
Managing Extracts

Use
When you save reports in extracts, you can then access the data at any time without having to select the data from the database.

You can use extract management to:

- Display extracts
- Print extracts
- Change the extract priority
- Change the expiration date of an extract
- Delete extracts

⚠️ After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Prerequisites
You have saved your reports in extract files. For more information, see Creating an Extract [Seite 1010].

Procedure
4. On any Create/Change/Display/Execute Report Group screen, choose Utilities → Extracts → Display or Delete or Print or Change expiry date, depending on the function you want to use.


   You can also access extract management from the screen Execute Report Group: Initial Screen using the button Data extracts when you execute a report group from the first selection screen with Environment → Extract directory...

5. Enter the criteria according to which the extracts should be selected:

- If you are searching for a particular extract, enter the description of the extract.
- Specify whether extracts should be displayed that were generated by your or by a particular user, or whether all extracts should be displayed regardless of the user.
- Specify when the extracts were generated, or whether all extracts should be generated regardless of the date.
- You can select the extracts of a particular report group [Seite 937] or report group range.
- You can select the extracts according to their priority, and restrict the selection to unread extracts.
Managing Extracts

- If you want to further restrict the selection criteria (for example, according to a specific characteristic or group of characteristics), choose Additional selections and enter the criteria. You can expand the number of selection conditions as required, and delete selection conditions you entered.

6. Choose .

The system displays a list of extracts that meet the selection criteria you entered.

7. Select the desired extract and choose one of the following functions:

**g. Display extract**

Choose .

**h. Print extract**

You can print extracts immediately or in the background.

- To print the selected extracts, choose Extraks and enter the output device and other parameters for print control.
- To print in the background, choose Background and specify when the job should be started.

**i. Change the extract priority**

Choose and change the priority of the extract.

**m. Change expiration date**

You can change the expiration date that was specified when the extract was created.

Choose . If you want the extract to be deleted automatically after a specified time, enter the number of days in the dialog box Change expiration date under Expires in or choose Expires on and enter an expiration date.

If you don’t want the extract to be deleted after a specified time, choose No expiration date. This is appropriate when the report is required for an undeterminable length of time or the report takes a long time to execute.

Choose to exit the dialog box and save your entries.

**n. Delete extract**

Once an extract has been deleted, it cannot be retrieved.

Choose to delete extracts. If you answer the question whether the selected extracts should be deleted with Yes, the extracts are deleted.

For information on settings for extract management, see the Implementation Guide for Cost Center Accounting under Information System → User Settings → Specify Settings for Extract Management.
Example Process: Report Callup with Extract Management

Purpose

At the end of each month, the reports (important to cost center managers in the entire organization) are executed, and the data is stored in extracts. Reports that contain data for individual cost centers or cost center groups are executed using variation, so that a separate report can be created for each cost center and cost center group.

You can set the user parameters for your cost center managers so that they can automatically access the most current extracts.

When calling up a report from the report tree, each manager receives the relevant individual data. The manager does not need to select the data from the database again, which reduces the workload of the system.

The cost center manager cannot navigate to areas within the extracts that do not belong to the authorized CO-OM responsibility area.

The system administrator who sets up these reports needs to have authorization to select the data from the database. However, this does not authorize the administrator to display the data in those reports.

The cost center managers need authorization to display the reports for their CO-OM responsibility area. However, this does not entitle them to select the data from the database or to create extracts.

The following graphic displays the way in which a report is executed in extracts, in the background with the variation. It also shows how you can save it in extracts.
Example Process: Report Callup with Extract Management

**Process Flow**

13. Initial setups include creating the authorizations for system administrators and cost center managers [Extern].

14. The system administrator arranges for all the reports to be accessible to all users in EUROs. The system administrators execute the report (such as the Cost Centers: Actual/Plan Variance report) in the background and with the variation, and save the report in extracts (see: Executing a Cost Center Report with Variation and Saving it in Extracts [Extern]).

15. The system administrator makes the settings for extract management for the cost center managers in Customizing (see: Specifying Settings for Extract Management [Extern]). In their user-specific settings, the cost center managers save their selection criteria for the reports they want to display (see Customizing for Controlling under Cost Center Accounting → Information System → User Settings → Specify User Settings [Extern]).

16. The cost center manager accesses the report (see: Calling Up Cost Center Reports [Extern]).

   ![Diagram of Process Flow]

This procedure is shown in more detail in the following sections using the Cost Centers: Actual/Plan/Variance report.

**Result**

Each cost center manager can quickly and easily display the relevant reports required.
Example Process: Report Callup with Extract Management
Report Text

Use
In a Report Painter or Report Writer report, you can enter texts for the following:

- Title page
- Headers
- Footers
- End page

These texts are used for list output and exports in text format.

- Text for export

The text for export is used for Office integration and for exports into HTML or spreadsheet format.

The definition of report texts in the Report Painter is similar to that in the Report Writer.

You can also define report texts in the report output. SAP recommends that you enter report texts only after the report has been executed and output. This allows you to see which values the report text variables will use.

Prerequisites

You can only change texts in the report output if the report uses a standard layout [Seite 1017] in which the Change allwd dur exctn indicator is selected on the Page/Control screen. You cannot change texts in standard reports included with your SAP R/3 System.

Features

You can enter the following types of texts for report texts:

- Normal text
- Standard text variables such as the date, user name, and page number
- Special text variables
- Text variables for selection parameters
- Text variables for characteristics used in the text

For more information, see Variables in Report Text Definition [Seite 826].
Defining Report Texts

To enter report texts from any Create Report screen:

11. Report Writer

   From the screen Create Report or Change Report or Display Report: Initial Screen, choose Goto → Texts.


   Report Painter


12. To enter text, choose one of the processing functions in the following table.

   Processing Functions for Text Definition

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose (Report Painter)</th>
<th>Choose (Report Writer)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter text for title page</td>
<td>Title page</td>
<td>Title page</td>
</tr>
<tr>
<td>Enter text for headers</td>
<td>Headers</td>
<td>Headers</td>
</tr>
<tr>
<td>Enter text for footers</td>
<td>Footers</td>
<td>Footers</td>
</tr>
<tr>
<td>Enter text for last page</td>
<td>End page</td>
<td>End page</td>
</tr>
<tr>
<td>Enter text for export of report to HTML and Office Integration</td>
<td>Text for export</td>
<td>Text for export</td>
</tr>
</tbody>
</table>

   The screen Change <text position> <report name> in Language <language code> appears.

   If these functions are not available, choose Formatting → Report layout and check whether Change allowed during execution is selected on the tab Page/control.

13. Choose Text → Save.


   The text appears on the Create Report: Texts screen.

15. To save the report, choose Report → Save.

   Entering Variables in Report Text

   In the report output, you can insert text variables, frames, and rows with Insert. For more information about the different types of text variables you can define in your report text, and how to enter variables in report text, see Using Variables in Report Text Definition [Seite 826].
Layout

Purpose
In Report Painter and Report Writer reports, you can modify the layout of your report at different levels.

Features
The layout parameters for the report output are determined by the standard layout assigned to the report. This includes the page format of the report and the numerical format of the report data.

A section layout can be defined separately for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

You assign an individual report layout to each report. Initially, each report receives the standard layout SAP. You can assign an individual section layout to each section in the report. The standard layout then only applies to the sections to which no section layout was assigned.

The section layout and the report layout allow you to define layout settings such as form printout or the width and position of the lead columns separately for each section.

Specify whether it should be possible to change and save the layout parameters in the report output:

- If you do not select Change allwd dur exctn, the layout parameters cannot be changed when the report is executed.
- If you deselect Change allwd dur exctn, the layout parameters cannot be changed when the report is executed.

For more information, see Parameters for the Standard Layout.

You can change the report’s layout parameters under Settings → Report layout.

If you change the layout parameters, but then decide that you want to reuse the default values from the standard layout, you can do so by choosing Settings → Report layout → Use standard layout.
Standard Layouts

Use
You assign a standard layout to each report that you create. This standard layout determines the layout features of the report, such as the page format of the report and the numeric format of the report data. The system assigns a default standard layout called SAP to each report. You receive the SAP standard layout with each SAP R/3 System. The standard layout provides a default value for every layout parameter.

Features

Report Painter
When a layout is assigned in the Report Painter [Seite 726], the layout parameters are copied from the standard layout to the report layout. There is no permanent reference to the standard layout. Thus, changing the standard layout has no effect on the report layout.

In the report layout, you can recopy the layout parameters of the standard layout with the button Use standard layout.

Report Writer
Before a report layout has been defined for a Report Writer [Seite 797] report, a link exists between the report layout and the standard layout for all parameters. With the button Define report layout, you can create an independent report layout that is a copy of the standard layout.

With Report Writer reports, the button Use standard layout restores the link to the standard layout. In this case, changes made to the standard layout would affect the report layout.

When you define a report, you can do any of the following:

- Use the SAP standard layout for the report
- Assign a different standard layout to the report
- Revise the standard layout parameters so that the parameters are specific to the report

In the report definition, you can assign a standard layout to the report in the report header. These settings then take effect for that report. You will find more information on headers for the Report Painter under Defining Report Headers [Seite 765] and for the Report Writer under Defining Report Headers [Seite 817].

There are two ways in which you can use the standard layout settings in a report:

- Execute the report and then choose Settings → Report layout → Use standard layout
- In the report definition (Change Report), choose (for Report Painter reports) Edit → Report header. Here you need to enter a different standard layout (such as SAP) and then reenter the standard layout you require.

The indicator Change all wd dur exctn allows you to save any changes you make to the layout when executing the report. Set this indicator in the report layout.

If you only change the indicator in the standard layout, the change will only be effective in the Report Painter report if you reassign the standard layout to the report.
Standard Layouts

For more information about assigning a standard layout to a report and changing report parameters, see Defining Report Layouts [Seite 1031].

The standard layout is used in all sections to which no section layout [Seite 1028] is assigned.

For more information on processing and changing the standard layout, see:

Creating a Standard Layout [Seite 1019]
Displaying a Standard Layout [Seite 1024]
Changing a Standard Layout [Seite 1025]
Deleting a Standard Layout [Seite 1027]
Parameters for the Standard Layout [Seite 1022]
Creating a Standard Layout

Use

When you first define a report, the default standard layout assigned to the report is always SAP. SAP appears in the Standard layout field at the top of each report parameters screen. This standard layout is shipped with your SAP R/3 System.

When you define a standard layout, you can assign parameters to format groups for certain fields. For parameters that are assigned format groups, you can define up to six different versions of the parameter. Each row and column in a report can use a unique format group. For more information, see Setting Format Groups in Sets [Seite 910].

Procedure


10. Enter the following information:
   – The name of the standard layout you want to create
   – The name of the existing standard layout you want to copy
11. Choose Continue.

   The Create Standard Layout screen appears.

12. Enter the following information:
   – Description of the standard layout
   – Authorization group for the standard layout. This authorization group is defined in the user's profile.

   Suppose you define an authorization group called AUTH. If you assign this authorization group to a standard layout, only users with this authorization group can change, display, and/or delete this standard layout for their reports.

Using the tab pages you can make the changes to the layout that you require. The following table gives you an overview of the different possibilities that you have for defining the standard layout parameters. Each function is assigned to the respective tab page index.

<table>
<thead>
<tr>
<th>Function</th>
<th>Tab page index</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting the column headings</td>
<td>Column headings</td>
</tr>
<tr>
<td>Defining area for the totals output</td>
<td>Rows</td>
</tr>
<tr>
<td>Setting width and position of lead column</td>
<td>Lead column</td>
</tr>
<tr>
<td>Defining detail level for row totals</td>
<td>Rows</td>
</tr>
</tbody>
</table>
### Creating a Standard Layout

| Setting number of decimal places | Representation |
| Defining unit                   | Representation |
| Setting colors                  | Graphics       |
| Using form printout             | Rows           |
| Setting graphic type            | Graphics       |
| Defining content of lead column | Lead column    |
| Defining content of column headings | Column headings |
| Allowing changes to layout parameters during execution of the report | Page/control |
| Output of zero values           | Representation |
| Suppressing zero columns        | Columns        |
| Printing or hiding zero rows    | Rows           |
| Indenting lead column           | Lead column    |
| Repeating lead column           | Lead column    |
| Setting page format             | Page/control   |
| Printing selection log at end of report | Page/control |
| Setting scaling                 | Representation |
| Setting column break character underline | Column headings |
| Defining column layout          | Columns        |
| Setting column break character  | Columns        |
| Assigning a language            | Language dependent |
| Using standard colors           | Page/control   |
| Suppressing duplicated totals   | Rows           |
| Marking totals                  | Rows           |
| Defining position of totals items | Columns     |
| Defining text type for the row text description in the lead column | Lead column |
| Displaying undeterminable values | Representation |
| Setting +/- sign                | Representation |
| Defining +/- sign editing       | Rows           |

For more information on the layout parameters, see [Parameters for the Standard Layout][1] [Seite 1022].

You can use the following additional functions from the Create Standard Layout screen:

### Additional Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display directory of existing standard layouts</td>
<td>Utilities → Catalog...</td>
</tr>
<tr>
<td>Export standard layout to an external file (see Exporting Report Writer Objects [Seite 916])</td>
<td>Utilities → Transport → Export</td>
</tr>
<tr>
<td>Import standard layout from an external file (see Importing Report Writer Objects [Seite 918])</td>
<td>Utilities → Transport → Import</td>
</tr>
</tbody>
</table>

7. To save the standard layout header, choose Standard layout → Save.
Parameters for the Standard Layout

The standard layout provides a default value for all the layout parameters that you can change. When creating the standard layout you can overwrite the default parameter values on the following tab pages:

- **Page/control**
  
  The page format parameter values determine the layout of a report when it is output. 
  
  *Page control* (to determine if you can change the layout parameters in the report output and if you want to print the selection log at the end of a report). 
  
  For *Margins* you can define parameters for the top, bottom, right and left margins and in *Print sequence* you can choose between printing by column or by row. With *Color settings* you can specify that the standard SAP colors be used for the report output.

- **Rows**
  
  With *Summation level* you define the level of detail to be used for the row totals. With *Totals item* you specify where the totals are to be output, for example above or below the detailed report results. 
  
  For *Treatment of zero rows* you define whether zero rows are to be printed or hidden, or whether you want to use form printout. You can also mark totals and suppress duplicated totals.
  
  You can deactivate +/- *sign editing*, or activate it for all columns or for a certain column.

- **Lead column**
  
  With these layout parameters you define the content of the lead column (description, key and description, characteristic name and key, key). You can also determine the text type that is to be used for the row text in the lead column. You can choose between short text, long text, or a text that is proposed automatically by the system. If there is no short text in the master data, the system uses the corresponding long text.
  
  With *Indentation* you can specify the number of spaces the lead column is to be indented by.
  
  In the group box *Lead column* you can define the width and position of the lead column.
  
  In the group box *Miscellaneous* you can activate the underscoring of the text and the repetition of the lead column.

- **Columns**
  
  *Totals position* (to determine if totals columns are positioned to the left or right of the columns containing the corresponding detail values).
  
  In the group box *Column break character* you specify the type of column break character to be used. In the group box *Treatment of zero columns* you can select that the zero columns be suppressed. In the group box *Layout* you define the column width and the right margin.

- **Column headings**
  
  With these layout parameters you define the *Content and Orientation* (left-justified, centered, right-justified) of the column headings. In the group box *Miscellaneous* you can define that the column break character be underlined.

- **Representation**
Parameters for the Standard Layout

With these layout parameters you define how the numerical format is to be displayed. You can determine the number of decimal places and the scaling, as well as make specifications concerning the +/- sign and the units. You can also specify how the zero values and undeterminable values are to be displayed.

Undeterminable values appear in a report when values with different currency units or units of measure are totaled. You can display these values in your report with a space or using a symbol.

- **Language dependent** (language-dependent parameters)

  With these parameters you can assign different values for decimal display, +/- sign and date to different languages. With Other languages you can switch to another language to enter the language-dependent parameters. When you execute the report's report group, the Report Writer uses the value of the logon language.

- **Graphics**

  With these parameters you determine the graphic type that you want to use. The color palette determines the color palette that is to be used for the business graphic. For more information on calling the report graphics from the executed report, see calling report graphics [Seite 999].

For more information, see creating a standard layout [Seite 1019].
Displaying a Standard Layout

   The Display Standard Layout: Initial Screen appears.

8. In the Standard layout field, enter the name of the standard layout that you want to display
   and choose Continue.
   The Display Standard Layout screen appears.

9. On this screen, you can use the additional processing functions in the table in Creating a
   Standard Layout [Seite 1019], as well as the Extras → History function to display the revision
   history of the standard layout.
Changing a Standard Layout

Prerequisites
Changes you make to a standard layout will affect other users’ reports that use that standard layout.

You should only change a standard layout if the change is required for all reports that use that standard layout. If changes are only needed for one report run or for a specific report, you should change the report parameters using the Layout functions on the Change Report: Initial Screen. For more information, see Defining Report Layouts [Seite 1031].

The layout parameters are copied from the standard layout into the report layout. There is no permanent reference to the standard layout. When you create a report, the layout settings are copied from the standard layout into the report layout.

If the standard layout is changed, the layout parameters in the report are not updated automatically.

Do not change the standard layout (SAP) that is delivered with your SAP R/3 System.

Procedure

The Change Standard Layout: Initial Screen appears.

12. In the Standard layout field, enter the name of the standard layout you want to change and choose Header.

The Change Standard Layout: Header screen appears.

13. On this screen, you can use the additional processing functions in the table in Creating a Standard Layout [Seite 1019], as well as the Extras → History function to display the revision history of the standard layout.

14. Type over current values with your changes.

15. Choose Standard layout → Save.

Suppose you give the report the standard layout SAP and then change the report width to 60. Then you assign a different standard layout to the report. The report width remains at 60, since it is a change that you made that is specific to the report.

For information on transferring the settings of the standard layout to a report, see Standard Layouts [Seite 1017].
Changing a Standard Layout

If the standard layout is changed, the layout parameters in the report are not automatically updated. The indicator \textit{Change allowed during execution} allows you to save any changes you make to the layout when executing the report.

Select the \textit{Change allowed during execution} indicator only in the report header.

If a user has authorization to change a report, he can change this indicator in the report output with \textit{Settings $\rightarrow$ report layout $\rightarrow$ Page/control $\rightarrow$ Change allowed during execution}. Another place you can change the setting of this indicator is in the report definition with \textit{Report header}. If you only change the indicator \textit{Change allowed during execution} in the standard layout, the change will only be effective in the report if you reassign the standard layout to the report.
Deleting a Standard Layout

   The Delete Standard Layout: Initial Screen appears.

6. In the Standard layout field, enter the name of the standard layout you want to delete.
5. Choose Delete.
   A dialog box asks if you want to delete the standard layout.

   You cannot delete a standard layout that is being used in a report. You cannot delete the SAP standard layout delivered with the SAP R/3 System.

6. Choose Yes.
   The standard layout is deleted. You cannot restore a standard layout once it has been deleted.
Section Layout

Use
There are a number of different ways you can modify the layout of the sections in a report:

- You can apply the parameters specified in the report layout
- You can apply a section-specific layout

Features
You can use a different layout for each section. Section layouts contain control information on:

- Row totals
- Row texts
- Column texts

You can also apply the report layout [Seite 1029] to sections. Any changes you make to the report layout then become effective automatically in the sections where it was applied.

The section layout can be defined differently for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

In the section overview in the Report Painter, you can change the attributes of the sections, the sequence of the sections, and the page breaks between the sections. This includes overscores and underscores, and how the headers should be printed.

For more information on formatting, see Summation Levels [Seite 1034].
Report Layout

Use

You can assign a report layout to each report that you create. The report layout defines the layout features of the report, such as the page format of the report and the numeric format of the report data. When you use the Layout functions, you can set parameters for the report.

Features

You have two options for assigning a layout:

• Report Writer: link to standard layout [Seite 1017]
  
  Report Painter: copy of standard layout (may not be current)

• A separate report layout that is not linked to the standard layout

The report layout establishes layout parameters that apply to the whole report (such as the page layout). It also contains parameters that can be defined separately for each section (such as summation levels [Seite 1034]). These section-specific parameters defined by the report layout are valid only for report sections that do not have their own section layout [Seite 1028].

For more information, see Displaying Report Layouts [Seite 1030] and Defining Report Layouts [Seite 1031].
Displaying the Report Layout


For more information on additional functions that are available on this screen, see Functions in the Report Output [Seite 974].
Defining Report Layouts

Use

For each report that you create, you can assign a report layout. Via the report layout you define the layout features of the report, such as the page format of the report and the numeric format of the report data. When you use the Layout functions, you can set parameters for the report.

You received the SAP standard layout with your R/3 System. This standard layout is automatically assigned to each report you create. If you want to use the SAP standard layout, you can skip the following steps and go directly to defining rows [Seite 841]. When you first define a report, the default standard layout is always SAP. SAP appears in the Standard layout field at the top of each report layout dialog box.

When you define a report layout, you can define a layout specifically for a report and you can change the standard layout assigned to a report.

Procedure

3. To define a report layout, choose Goto → Report layout and work with the following tab pages:
   - Page/Control: Here you define general page format parameters, such as the length and width of a page
   - Rows: Here you define row total parameters, such as the positioning and summation levels for report row totals
   - Lead column: Here you define row text parameters, such as the text type and row length
   - Columns: Here you define the type of column break and the treatment of zero columns
   - Column headings: Here you define orientation of the column headings, such as the position and layout of the columns
   - Representation: Here you can define the numerical formats
   - Language dependent: Here you define the language dependent report parameters
   - Graphics: Here you define the graphical presentation and color palette

   You can switch between the change mode of your report layout and the default parameters of the standard layout using the pushbutton Use standard layout or Define report layout. To change a parameter so that the standard layout value is not used in a report, you type over the current value. The value is not changed in the standard layout; it is only changed for that specific report.

8. Type over current values with the values you want to use for the report layout.

9. Choose Continue.

10. To save the report layout parameters, choose Report → Save.
Changes that you make to the report layout parameter values do not affect the standard layout values that are stored in the system. The report parameter values that you enter only affect the specific report that you are working on.

You can change standard layouts for reports; however, any changes you make affect other users’ reports. For more information, see standard layouts [Seite 1017].

For more information on the standard layout screens or for information about changing the standard layout, see creating a standard layout [Seite 1019].

For information on how to change the standard layout assigned to a report, see changing a standard layout [Seite 1025].

The system determines which format group to use based on the format group defined in the sets that are used in the report definition. Some report parameters can be defined using six variants of the parameter. These variants correspond to the format groups 0 through 5. Depending on the value entered in the format group field for a set, the Report Writer selects one of the six values. For more information on format groups, see setting format groups in sets [Seite 910].
Saving Changed Report Layout Parameters

Use
When processing a report in expert mode, such as when executing a report group [Seite 962], you can make changes to the report layout and save them.

Procedure
7. When executing a report, choose from the report output screen Settings → Report layout. A dialog box appears where you can overwrite the layout parameters.
8. Make any required changes to the report layout.
9. To save the changed layout parameters, you can choose from the following alternative functions:
   • To save the changes, choose Settings → Save settings.
   • To save the layout changes you made and then block all users from making layout changes in the report, choose Settings → Save and block settings. The system automatically deselects the Change allwd dur exctn indicator in the Page/Control layout parameters. If you need to remove the block, choose Change report, then Formatting → Report layout. On the tab page Page/control in the group box Control data, select the indicator Change allwd dur exctn.

SAP recommends that you save your report data as an extract [Extern]. This allows you to call up your report at any time and the system does not have to reselect the data from the database. You can save the report as an extract using the Report → Save function. If you have not already saved the report as an extract, the system displays a dialog box, asking you whether you want to do so when you exit the report. For more information, see Extracts [Seite 1008], Creating an Extract [Seite 1010], and Managing Extracts [Seite 1011].
### Summation Levels

#### Use

In Report Painter reports and Report Writer reports you can use sets [Extern], groups, or set variables to display a hierarchy in the rows. The totals rows in a report are represented by summation levels.

#### Features

Each summation level is represented by one or more asterisks. In the report definition, you can specify in the layout that this hierarchy should be marked with special characters. You activate this function with Settings \(\rightarrow\) Layout \(\rightarrow\) Row totals \(\rightarrow\) Mark totals.

In the layout, you can specify whether you can choose the position of the totals (top or bottom) in the display.

For more information, see Layout [Seite 1016].

The number of masking characters within a report depends on the number of hierarchy levels. Row totals at the lowest level in a hierarchy display with one asterisk. Individual values receive the summation level zero (no masking characters).

#### Hierarchy Levels and Their Representation by Masking Characters

<table>
<thead>
<tr>
<th>Hierarchy Level</th>
<th>Number of Masking Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Highest level of hierarchy</td>
<td>n</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-1</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-2</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-3</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-4</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Lowest hierarchy level</td>
<td>n-(n-1) = 1</td>
</tr>
<tr>
<td>Single values</td>
<td>No masking character (n-n)</td>
</tr>
</tbody>
</table>

There are two types of hierarchies:

- **Balanced hierarchy**

  If values exist for all levels and branches of the hierarchy, the hierarchy is balanced. A balanced hierarchy looks symmetrical.
• **Unbalanced hierarchy**

Which hierarchy level is the highest depends on which levels have values. The individual branches of the hierarchy can differ considerably from one another, resulting in an asymmetrical hierarchy.
Summation Levels

**Summation Level with Unbalanced Hierarchy**

If not every level of the hierarchy has a value, the maximum summation level can take on widely different values.

- If the hierarchy consists only of Set 1, Set 12 and values, Set 1 will have the maximum summation level **.
- If the hierarchy consists of Set 1, Set 12 with values, Set 13, Set 131 with value, and Set 132 with Set 1311 with values, Set 1 will have the maximum summation level ****.

The method for determining the maximum summation level always starts at the lowest set level.

**Summation Level with Balanced Hierarchy**

With a balanced hierarchy, the maximum summation level is always the same, regardless of the selected data.

**Summation Levels in Report Layout/Section Layout**

When you set the summation level in the report layout or section layout of reports with an unbalanced hierarchy, you should take into account how the maximum summation level is determined, as described above.

Different hierarchy levels will be displayed, depending on the selected data.

In the above examples for the summation level with an unbalanced hierarchy, if you specify the interval 2 to 3 for the summation level, the result is:

- For the first example: Set 1 **
- For the second example: Set 12 ***, Set 13***, Set 131**, Set 132**

You can avoid this discrepancy by inserting dummy nodes into the unbalanced hierarchy to balance it. This results in additional rows in the report, which you can hide with the layout setting *Suppress duplicated totals.*
Report Writer

Purpose
In addition to the Report Painter [Seite 726], you can use the Report Writer to define reports. You use the Report Writer to create reports from data in the Special Purpose Ledger (FI-SL) application component and other SAP application components to meet your specific reporting requirements.

The Report Writer is a tool using which you can define reports.

Many reporting requirements can be met using the standard reports provided by various SAP application components. However, if your reporting requirements are not fulfilled by SAP’s standard reports, you can also define complex reports using the Report Writer.

With the Report Writer, you can organize reports to meet the specific needs of your enterprise. The Report Writer uses reporting building blocks, such as sets, which can be used in any report.

Integration
The Report Writer fulfills a similar function to the Report Painter, is however more complex and requires a certain amount of familiarization time.

To facilitate report definition, you can use many of the standard reporting objects provided by SAP (such as libraries [Seite 927], row/column models, and standard layouts [Seite 1017]) in your own specific reports. You also use the following additional functions to create Report Writer reports:

- Sets [Seite 633]
- Key figures [Seite 708]
- Variables [Seite 689]

Features
The Report Writer report definition is based on sets [Seite 633], which means that the look of the report is determined by the set construction used to define the report. There are a number of ways you can use these sets in the rows, columns and general selection data.

A set is a system structure that you can use to link together specific values or ranges of values under a name. These values exist within one characteristic of a coding block. A characteristic is a single field or column of a database table. Account, cost center, and business area are examples of characteristics. Within these characteristics, you can store specific characteristic values under a set name.

You create a set called TD-RACCT-EXP. This set uses the characteristic Account and contains all of your expense accounts.

Using sets, you define which data is used in your report and how the data appears in report rows and columns.

Using sets in the Report Writer offers the following advantages:

- Simple creation and editing of reports
Report Writer

- Multiple usage of the same sets in many reports
- Multidimensional reporting

Sub-totals at levels defined by the user

The Report Writer is a multidimensional reporting tool. When you use the Report Writer, you can easily rearrange the characteristics within a report. In the following graphic, the characteristics Cost Center and Account make up the rows of the report; local and group currency make up the columns of the report.

<table>
<thead>
<tr>
<th>Currencies</th>
<th>LC</th>
<th>GC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Center 1</td>
<td>200</td>
<td>300</td>
</tr>
<tr>
<td>Account 1</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Account 2</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Account 3</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Cost Center 2</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Account 1</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Account 2</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Account 3</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Cost Center 3</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Account 1</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Account 2</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Account 3</td>
<td>---</td>
<td>---</td>
</tr>
</tbody>
</table>

Changing the order of characteristics used in this report involves only a small change in a set used in the report; you do not have to change the report itself. You can easily report on any combination of characteristics without having to maintain complicated user tables in the background.

Using variables [Seite 689] (value, formula or set variables) provides you with great flexibility via different options for characteristic and group values in the report design.

You have many possibilities for portraying Report Writer reports: You can, for example, vary the level of detail.

You can convert a Report Painter report to a Report Writer report in Report Writer. In this way you can use all the functions available in Report Writer for the report that was originally a Report Painter report. For more information, see Report Writer reports [Seite 804].

For more information about Report Writer, see:

- Report Writer Reports [Seite 804]
- Report Writer Utilities [Seite 912]
- Report Groups [Seite 937]
- Report Painter [Seite 726]
- Report Painter or Report Writer? [Seite 724]
Report Painter Reports [Extern]

For information about terminology within reporting, see terminology [Seite 1037].
Working with the Report Writer

Purpose
This process describes the main steps in creating a Report Writer report.

Process flow
The following graphic is an example report. Cost centers and accounts are listed in the rows of the report and currency types (local and group) are listed in the columns.

<table>
<thead>
<tr>
<th>08.09.1995</th>
<th>Revenue &amp; Expense/Cost Center</th>
<th>Local Curr.</th>
<th>Group curr.</th>
</tr>
</thead>
<tbody>
<tr>
<td>400010</td>
<td>Sales revenue</td>
<td>800,000.00</td>
<td>1,272,000.00</td>
</tr>
<tr>
<td>400020</td>
<td>Investment income</td>
<td>900,000.00</td>
<td>1,433,999.95</td>
</tr>
<tr>
<td>*</td>
<td>Revenue accounts</td>
<td>1,700,000.00</td>
<td>2,705,999.95</td>
</tr>
<tr>
<td>300010</td>
<td>Sales costs</td>
<td>90,000.00</td>
<td>145,800.00</td>
</tr>
<tr>
<td>300010</td>
<td>Wages and salaries</td>
<td>12,000.00</td>
<td>19,440.00</td>
</tr>
<tr>
<td>*</td>
<td>Expense accounts</td>
<td>102,000.00</td>
<td>166,240.00</td>
</tr>
<tr>
<td>*</td>
<td>100  Administration</td>
<td>1,598,000.00</td>
<td>2,540,759.95</td>
</tr>
<tr>
<td>*</td>
<td>Sales revenue</td>
<td>275,000.00</td>
<td>421,500.00</td>
</tr>
<tr>
<td>400020</td>
<td>Investment income</td>
<td>289,000.00</td>
<td>444,180.01</td>
</tr>
<tr>
<td>*</td>
<td>Revenue accounts</td>
<td>564,000.00</td>
<td>865,680.01</td>
</tr>
<tr>
<td>300010</td>
<td>Sales costs</td>
<td>120,000.00</td>
<td>194,400.00</td>
</tr>
<tr>
<td>300020</td>
<td>Wages and salaries</td>
<td>20,000.00</td>
<td>32,400.05</td>
</tr>
<tr>
<td>*</td>
<td>Expense accounts</td>
<td>140,000.00</td>
<td>226,800.05</td>
</tr>
<tr>
<td>*</td>
<td>200  DP</td>
<td>424,000.00</td>
<td>550,000.00</td>
</tr>
<tr>
<td>**</td>
<td>Cost centers</td>
<td>2,022,000.00</td>
<td>3,179,639.91</td>
</tr>
</tbody>
</table>

You can define the above report in the following steps:

8. **Create sets for the report rows and columns and sets to select data for the report.**

You use a set to determine which data appears in the rows and columns of a report and to determine which data is selected for the report.

- You can use a set as a row, column, or as selection criteria, depending on how you want to display the data in the report. Also, since the same set can be used in many different reports, you do not need to create new sets each time you define a report. Instead, you can use existing sets that meet your reporting needs.

- You **must** use certain set characteristics in a report. You must use sets that contain values for the characteristics "Ledger", "Company", "Version", "Period", and "Record Type" either in the report rows, the report columns, or as data selection criteria.

Sets for Report Rows:
The set you use in a report row is referred to as a row block and may consist of one or more physical rows. In the above report, the set TD-CC-ACCT is used as a row block. It contains the following sets:

- TD-RCNTR-12
  This basic set contains cost centers 100 and 200.
- TD-RACCT-IE
  This single-dimension set contains the basic sets TD-RACCT-INC (containing income accounts 4000010 and 400020) and TD-RACCT-EXP (containing expense accounts 3000010 and 300020).

Sets for Report Columns:
The set you use in a report column is referred to as a column block and may consist of one or more physical columns.

In the above report, the column set, or column block, is TD-ACT-TL (actual data in local and group currency). This data set contains the following values:

- HSL-0 (local currency, actual data)
- KSL-0 (group currency, actual data)

For each value in the set, the Report Writer creates a physical column.

Sets as General Selection Criteria for Report Data:
You also create sets that determine the data that is selected for a report.

You create a set with the characteristic “Year” that contains the value 1995. If you use this set as selection criteria in a report, the Report Writer only extracts data for 1995.

For more information on using sets for Report Writer, see uses of sets in Report Writer [Seite 891].

9. Select a library for the report.
Before defining the actual report, you need to select a library for the report. A library is a collection of characteristics (such as “account”, “cost center”, “company”), basic key figures (such as local costs, total costs and activity quantity), and key figures (such as actual costs in the current fiscal year) used in a report definition. Report definitions in one library can only use the characteristics, basic key figures, and key figures that are defined for that library.

For more information, see library [Seite 927].

10. Define the report.

a) Define the report row(s).

On the Create Report: Rows screen, you enter the set(s) that you want to include in the report row block(s). The set you choose determines the row items that are in the report. You can also enter additional text to define your own text for the lead column/sum total, instead of using the text from the set header. You can also define formulas and key figures in a row block.

b) Define the report column(s).
Working with the Report Writer

On the Create Report: Columns screen, you enter the set(s) that you want to include in the report column block(s). The set you choose determines the columns that are in the report. You can also enter additional text to define your own text for the lead column/sum total, instead of using the text from the set header.

c) Enter the sets to be used as selection criteria for selecting report data.

On the Create Report: General Data Selection screen, you enter the set(s) that you want to be used to select the report data. You can also enter a selection rule for further defining selection criteria.

d) Enter report text, if required.

You can enter report texts on the Create Report: Texts screen. You can enter texts for the title page, headers, footers and the last page of your report. In addition, you can enter a special text that is used when exporting the report to Microsoft Excel. You can also enter various text variables, such as the date and user name, which appear when the report is output.

e) Review the default report layout and change as necessary.

SAP supplies you with a default standard layout for all of your reports. Standard layouts determine the page layout of the report and the numeric format of the report data. If you use the default parameters, you can skip this step. If you want to change some of the parameters, you use the Create/Change Standard Layout screens.

For more information about creating standard layouts, see standard layouts [Seite 1017].

For more information about changing default parameters for a specific report, see defining report layouts [Seite 1031].

For more information on defining reports, see Report Writer reports [Seite 804].

11. Check the report.

Once the report definition has been completed, you should check the report for errors and warnings. Using the Report → Check function, you can list any errors and warnings associated with producing the report.

12. Assign the report to a report group.

After you have defined a report, you assign it to a report group. A report group can contain one or more reports from the same library. When reports contain the same characteristics and share the same data, data is selected faster and processing time is quicker because report data is only selected once.

For more information, see report groups [Seite 937].

13. Generate a report group.

During this step, the Report Writer generates the programs necessary for processing the reports.

For more information, see generating a report group [Seite 952].

14. Execute the report group.

In this step, the Report Writer selects all the database records used in the report and outputs them in the specified format.
For more information, see report group execution [Seite 962] and the procedure executing a report group [Seite 964].
Report Writer Reports

Use

In addition to the Report Painter [Seite 726], you can also define reports using the more comprehensive functions of the Report Writer. The following components are required to define Report Writer reports:

- Report texts
- Report layout
- Report rows and columns
- Selection criteria for the report data
- Cells and key figures

Features

Before defining a report, you must create sets [Seite 633] to use in the report. Using sets, you create report row and column blocks and store the selection criteria for selecting report data. For more information, see Sets in the Report Writer [Seite 891].

Converting a Report Painter Report into a Report Writer Report

Although the Report Painter does not currently support all the functions of the Report Writer, you can convert a Report Painter report into a Report Writer report in order to use the complete range of functions provided by the Report Writer. To do this, follow the procedure for creating a new Report Writer report using the Report Painter report as a reference. The Report Painter report is copied and becomes available as a Report Writer report. The system automatically generates the necessary sets, so that you do not have to enter the prefixes for the set names.

You can not, however, edit the sets generated in this way using the set maintenance function. Nor can you use these sets in other reports or functions.

For more information on creating reports, see:

Creating a Report Painter Report [Seite 811]
Process Example: Creating a Report Writer Report [Seite 806]
Defining Report Headers [Seite 817]
Defining Report Texts [Seite 825]
Using Variables in Report Text Definition [Seite 826]
Defining Report Layouts [Seite 1031]
Defining Selection Criteria [Seite 835]
Defining Rows [Seite 841]
Defining Columns [Seite 854]
Defining Cells [Seite 864]
Defining Global Cells [Seite 870]
Parallel reports are no longer officially supported. You can no longer call up the maintenance transactions for parallel reports from the system menus. You can only create and maintain parallel reports using the respective transaction codes. You can still use parallel reports in report groups.

Alternatively, you can include several reports in one report group or use several sections within one report. You can then switch between the reports or sections within one report group.

A second alternative is to display two reports or two sections in two separate windows. If the system takes a long time to select the data for the report, we recommend that you store the selected data in an extract and display the extract in a second window.
Process Example: Creating a Report Writer Report

**Purpose**

The following example shows you how to construct the cost center report 1 SIP-001 (described in the Example process: Creating a Report Painter Report [Extern] section) using the Report Writers [Extern].

You will learn how to create new reports using existing Report Writer sets and variables. To create a cost center report, access Cost Center Accounting and choose:


**Prerequisites**

You first define your report requirements.

The cost center report should provide the following information:

- The actual and plan costs of a cost center [Extern] or cost center group [Extern], should be structured by cost elements [Extern] and displayed with the absolute and relative variances [Extern].
- Debit and credits are to be displayed in different rows.
- The reporting period may include as many periods per fiscal year as required.
- You should be able to call up the report for specific cost centers or cost center groups.
- The appropriate actual and plan figures should be displayed on a separate page, sorted by cost element, together with absolute and relative variances.
- Actual and plan statistical postings (postings that are updated with a different cost element type) together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.
- Actual and plan activity types [Extern] together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.
- Actual and plan statistical key figures [Extern] together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.

Before you define the report, you must decide:

- Which characteristics should appear in the report?
- Where are these characteristics to be entered?
- Which report characteristics should be variable and which should be fixed?
- Can variables already defined for report requirements be used with the new report?

A characteristic can only be used once in a report, in report rows, report columns, or data selection criteria. You decide the most appropriate location for the characteristic.
The following characteristics are required for the example cost center report.

<table>
<thead>
<tr>
<th>General data selection characteristics</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>KOKRS</td>
<td>Controlling Area [Extern]</td>
</tr>
<tr>
<td>KOSTL</td>
<td>Cost center group</td>
</tr>
<tr>
<td>GJAHFR</td>
<td>Fiscal Year [Extern]</td>
</tr>
<tr>
<td>PERBL</td>
<td>Periods</td>
</tr>
</tbody>
</table>

The characteristics "Fiscal year and "Period" can remain general data selection criteria, since every column of the report will contain values from the same time period. If you want the report columns to represent different reporting periods, however, you must place these characteristics in the appropriate columns.

<table>
<thead>
<tr>
<th>Report row characteristics</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>KSTAR</td>
<td>Cost element</td>
</tr>
<tr>
<td>BELKZ</td>
<td>CO debit/credit indicator</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Report column characteristics</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>WRTTP</td>
<td>Value type (actual, plan)</td>
</tr>
<tr>
<td>VERSN</td>
<td>Version [Extern] (actual version is always 0)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Key figures in the report columns</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>SWKRG</td>
<td>Costs</td>
</tr>
</tbody>
</table>

The next step when defining the report is to check whether you can use existing sets for rows, columns, and general data selection criteria.

**Process Flow**

1. **Defining Report Rows**

   To access row maintenance, choose Rows in the *Report Definition* screen.

   You can use row sets to display the hierarchical structure of the cost elements and to calculate group totals at various levels. In the Cost Center Accounting menu you have created at least one cost element group. The SAP R/3 System created cost element sets, which you can now use as row sets. By entering such a set in the row definition, the report is always be generated using the cost elements entered for those rows.

   Report 1BAB-001
Process Example: Creating a Report Writer Report

If instead you wish to enter the cost element group when the report is started, you must enter a multi-dimensional set in a report row containing a set variable. This set variable acts as a placeholder for the cost element group. When such a variable is defined in the report, the SAP R/3 System allows you to enter the cost element group or interval in the report selection screen.

Set variable &1KSTAR

The example cost center report should also distinguish between debit and credit postings. This is done by including characteristic BELKZ in the multi-dimensional set in addition to the cost element. The value of characteristic BELKZ can either be D (for debit) or C (for credit).

Use multi-dimensional set 1-L-IP-SH for the example cost center report. Note that the single dimension set 1-S-BELKZ is located in the first set row, followed by the set variable &1KSTAR in the second set row. As a result, the report first displays all debit postings for the cost center, followed by all credit postings. The cost elements are be sorted and totaled in these logical rows according to the set structure for the indicated cost element groups. Report Writer generates a subtotal at every set level.

In addition to the group totals derived from the cost element structure, the report also generates a total for each BELKZ characteristic value and a grand total for the multi-dimensional set.

The SAP R/3 System automatically identifies a logical report row within a given report, based on the row set description (such as 1-L-IP-SH “Cost elements”). The system derives the ID for the highest order group total from the first set in the multi-dimensional set found in the report row (such as 1-S-BELKZ “Over-/underabsorption”). All other lower order group total IDs are likewise derived from the respective set description (such as 1-S-BELKZ-S “Total costs”).

You can create other report texts that differ from the set descriptions defined in Set Maintenance. Choose Extras → Additional texts from the row or column definition dialog box and enter the specific report text for the lead column and a grand total in either Texts for Column Block or Texts for Row Block.

You can use characteristic BEKNZ in addition to characteristic BELKZ. If you use characteristic BELKZ, the report totals the debit and credit postings per cost element for both manual or periodic repostings. These postings are displayed as total costs. Moreover, reversing FI documents with the cost center account assignment feature balances out any credit posting entries by using the original debit entry for the account. Alternatively, using characteristic BEKNZ results in the debit and credit postings being displayed in separate rows, even in the case of repostings.

2. Defining Additional Report Rows

Just as with report 1SIP-001, you can also define additional logical report rows for the example cost center report that represent activity types, statistical key figures, and
statistical postings. The latter postings are those made to the cost element records, but which are updated later using a different cost element category.

You may use a characteristic value within the report rows more than once. The same applies to report columns. However, you cannot use a characteristic in a row and a column.

3. Defining Report Columns

Assume you now want to display the actual and plan figures for particular posting periods in the columns of the example cost center report, including absolute and percentage variances. You need to enter the predefined column 1-C-IP in the report, containing the predefined columns ISWKG (actual costs) and PSWKG (plan costs). The characteristics VERSN (=version) and WRTTP (=value type) are stored in additional sets for the predefined columns ISWKG and PSWKG.

Use the Layout variation function to establish how the values are displayed in the report. Each report has five variations available for this purpose. A single variation establishes column width, the column number for the value’s unit, and the number of decimal places and exponents for the report output. You can change these values for a particular report with the report layout function or save them in a standard layout. You can assign a display variant to each column in the report. You define this in the “P” column in the basic entries for the predefined columns.

The first three columns have been assigned display variant “0” in data set 1-C-IP, and the fourth column has been assigned variant “2.” The fourth column will thus be 10 characters wide, not 20.

You can only perform arithmetic calculations within a column block. This means that the formulas may not refer to other predefined columns.

In the event your report uses more than one logical row or column, you must be sure only to activate logically permitted combinations so that your report generates useful results.

Assume that the cost center report should now display statistical key figures. In this case, it only makes sense to use a column set that also displays the statistical key figure values. All other columns for these report rows should be deactivated. In this instance, the appropriate column set is 1-C-SSK.

To deactivate individual columns in the row definition dialog, place the cursor on the desired row and choose Inactive columns. In the Inactive Columns dialog box, select the columns you wish to deactivate.

4. Defining General Data Selection Criteria

Use general data selection to define the characteristics you wish to use to select the data for the entire report. You can only use characteristics as general data selection criteria that you have not yet used in the individual rows or columns of the report.
With the exception of multi-dimensional sets, you can use all set types as general data selection criteria. You can also use set variables. However, you can only use those characteristics that have not been entered in the row or column definitions.

In the case of the example cost center report, the reporting objects are the cost centers themselves. Set variable &1KOSET was used for this characteristic. As a result, you are able to enter a cost center set or individual cost center values when you call up the report. Report Writer creates a report that sums up all postings for the selected cost centers and displays the same by cost element.

On the other hand, you should use a variation if you want to generate a report for each individual cost center for the set and for all levels of the cost center set. Use the Vary function to enter the group level for characteristic KOSTL to which Report Writer should expand the cost center set. The default value is 1 to 99, with level 1 being the highest hierarchical node and level 99 the lowest. If you also want to create a report for each individual cost center, you must additionally set the “I” indicator (individual value).

If you do not want to vary your cost center set on all levels, use other values. Level 1 indicates the highest hierarchical node and level 99 the lowest.

You can only activate the variation when you start your report if you have set this indicator.

You must use the characteristic “Controlling area” for reports assigned to table CCSS. The controlling area characteristic can only be used as an individual value, and then only in the general data selection criteria.

Before saving the report and assigning it to a report group, check your report definition for syntax errors. Choose Report → Check The SAP R/3 System generates an error log listing any errors found.
Creating a Report Painter Report

Procedure


   Enter the name of the library the report is to use, and a name and description for the report. The report name can be a maximum of eight characters long.

   If you want to create your report using an existing Report Painter report as a basis, enter the name of the report that you want to copy under `Copy from`. Both reports must use the same library.

7. Choose `Create`.

   The next screen displays an empty report containing four rows and four columns (this is the basic structure for a report). You define your report on this screen.

8. Enter or change the description for the report by double-clicking the report description field.

   A dialog box appears in which you can enter a short, medium, and long text for the report description.

9. **Define the rows of your report** (see Defining Rows [Seite 751]).

   Rows contain a combination of characteristic values or formulas. Note the lead column at the first position of the rows. The Report Painter uses the lead column to access the rows. You can replace the description `Lead column` with a different term.

10. **Define the columns of your report** (see Defining Columns [Seite 748]).

    Columns contain a combination of a basic key figure and optional restricting characteristic values. You can also use predefined key figures to present key figures and characteristics that make business sense. For example, a number of predefined key figures are delivered for the libraries in Overhead Cost Controlling that can be copied directly into the reports, where they can be modified as required.

11. **Define general data selection criteria** (see General Data Selection [Seite 762]).

    The general data selection criteria restrict data selection for the report.

15. Choose `Save` and then `Execute` to create the report.

16. Assign the report to a `report group` [Seite 937].

    You have to display the report before you execute it, so that you can later change the report layout directly from the report list.
Creating a Report Painter Report

Once you have defined a report, you can display and print out a table of contents with Extras → Overview.

The overview contains the characteristics and characteristic values used in the individual sections, column blocks, and general data selection criteria. It also provides general information such as the user who last changed the report, the report name, and the standard layout assigned to the report, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.

For more information, see:

- Defining Report Headers [Seite 817]
- Defining Report Text [Seite 825]
- Defining Report Layouts [Seite 1031]
- Defining Cells [Seite 864]
- Defining Global Cells [Seite 870]
- Defining Report Documentation [Seite 945]
Checking a Report

Use
Once you have created or changed a report, you should run the check report function to check the report for errors. When you run the check report function, the system lists any errors or warnings in the report definition.

Prerequisites
A report cannot be generated if it contains any errors. If only warnings are issued, you can still generate the report. However, you may experience long runtimes.

Procedure
From the screen Create Report, choose Report → Check.

• If there are no errors or warnings in the report definition, the following message appears:

  No errors found in the report

• If there are errors in the report definition, a dialog box lists the errors and/or warnings in the report. For detailed information on the errors or warnings, double-click the relevant message.

Errors can sometimes occur because a set has been changed since the report was last generated.
Displaying a Report


5. Enter the following information:
   – The name of the library to which the report is assigned
   – The name of the report you want to display

6. On this screen, the additional processing functions in the table for Create Report: Initial Screen are available in Creating a Report [Seite 811].
Changing a Report Definition

Prerequisites

If you change a report [Extern] definition or a set [Extern] that is used in a report definition, you must regenerate all report groups [Seite 952] that contain the report. When a report and/or set definition within a report group is changed, the report group is flagged; when you attempt to execute the flagged report group, the system prompts you to regenerate the report group before the system executes it. Once the report group has been regenerated, the report will reflect your changes.

Procedure


   The Change Report: Initial Screen appears.

6. Enter the following data and choose Header:
   – The library name of the report definition you want to change
   – The name of the report definition you want to change

7. Type over existing values with your changes.

8. To save your changes, choose Report → Save.

   For Report Writer reports you can use the function Utilities → Layout control to view your changed report, without data having to be loaded. For more information, see displaying report layouts [Seite 1030].
Deleting a Report

You cannot restore a report once it has been deleted.

   The screen Delete Report: Initial Screen appears.

6. Enter the following information:
   – The name of the library to which the report is assigned
   – The name of the report you want to delete

7. Choose Delete.
   A dialog box asks if you want to delete the report.

8. Choose Yes.
   The report is deleted.

   You cannot delete a report if it is used in a report group [Seite 937].
### Defining Report Headers

3. In the Report Writer [Seite 797], you choose the Header button from one of the Create Report screens.

   The Create Report: Header screen appears.

4. Enter the following information:
   - A short description of the report
   - If you want user authorization to be required for creating, displaying, changing, and deleting this report, enter an authorization group. If you do not want to require user authorization, leave this field blank.
   - The standard layout that you want to assign to your report
   - The language in which you want to maintain the report, and the original language. The default language is the logon language.

   You can specify your characteristics to be unique or non-unique (multiple usage allowed) as required.

5. To enter default parameters for exporting the report to an application or presentation server when executing the report’s report group, choose Extras → Export parameters.

   A dialog box appears in which you enter export data as required. The default values you enter appear when you call up the Report → Export function in the report output. You can change these default parameters as required.

   For more information about the data you enter in the export dialog box, see Exporting a Report to an External File [Seite 985].

6. This screen includes the following additional processing functions.

### Additional Processing Functions (Create Report: Header Screen)

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check report for errors before you execute it</td>
<td>Report → Check</td>
</tr>
<tr>
<td>Define report layout, or reset layout parameters to default values of standard layout</td>
<td>Goto → Report layout</td>
</tr>
<tr>
<td>Display list of characteristics used in the report</td>
<td>Extras → List of characteristics</td>
</tr>
<tr>
<td>Switch to a new report language (for example, to enter language-specific text)</td>
<td>Extras → Maintenance language...</td>
</tr>
<tr>
<td>Assign new standard layout to the report</td>
<td>Extras → Other std layout...</td>
</tr>
<tr>
<td>Define default export parameters for exporting the report</td>
<td>Extras → Export parameters...</td>
</tr>
</tbody>
</table>
Entering Language-Specific Report Header Information

Use

On the Create Report: Header screen, you can enter a report description that is specific to a language.

Suppose you define a report in English, but you also want the report to be used by your German subsidiary. You use the Maintenance lang. function to set the language for entering report information (such as the report title) that is specific to the language of the foreign subsidiary.

You can enter language-specific report text for the report description (Create Report: Header screen) and the report texts (Create Report: Texts screen). Valid languages for report texts are defined in Customizing. For more information, see the Implementation Guide (IMG) for Special Purpose Ledger under Information System → Define Report Writer Languages.

Procedure

5. In the dialog box, select the language you want to maintain for the report.
6. Choose ✅ Choose.

You can now enter a report description on the Create Report: Header screen that is specific to the report.

When you use the Maintenance lang. function and switch to a new language, the information you enter for the report continues to be displayed in that language until you switch back to your first language.

For example, if you switch to language DE (German) from EN (English) and then define report texts, the information you enter will be displayed in German until you switch back to English. SAP recommends that you first define and save a report in one language before switching to another language.
Freezing Page Headers

Use
In the on-screen report output in list format, you can freeze the page headers (headers and column headings) to prevent them from disappearing when you scroll.

When the freeze page header function is activated, the headers and the column headings (if the page only contains a single section) are frozen in position. On pages that contain multiple sections, only the headers can be frozen, since otherwise the column headings of the first section of the page will be displayed on all following sections.

Procedure
In the report output, you freeze the page headers under Settings → Options... by selecting Freeze page header in the group header List output.

If the window height is less than the frozen area, you cannot scroll vertically. Increase the size of the window or unfreeze the page headers.
Sections

Use

A **Report Writer report [Seite 804]** consists of one or more sections. The sections are output in the order specified by the sequence number.

A section consists of multiple row blocks that form a logical unit. When the report is edited, the rows of a section are displayed on a separate screen.

Features

- You can enter text for each section.
- You can specify whether new column headings should be printed separately for each section.
- You can define a page break for each section.
- You can use a different **section layout [Seite 1028]** for each section.
  
  Section layouts contain control information on how row totals, row texts, and column texts. For more information, see **Report Text [Seite 824]**.
  
  You can also apply the **report layout [Seite 1029]** to sections. Any changes you make to the report layout then become effective automatically in the sections where it was applied.

- You can define threshold values for each section. For more information, see **Entering Threshold Value Conditions [Seite 994]**.

- Sorting conditions can be defined for the rows of a section.

- The section settings can also be changed in the report output.
## Defining Sections

### Use

A section consists of one or more physical rows and columns forming a logical unit. In the vertical direction, a report consists of one or more sections. Each section is displayed on a new screen. You can define sections with key figures and characteristics, as well as sections with derived basic key figures.

In a section that contains calculated key figures, you can create an overview of the most important values used in your report. A *section with calculated key figures* is a new report section and is displayed on a new screen. You normally define a section with basic key figures at the end of your report.

### Sections with Calculated Key Figures

1. To define a section with calculated key figures, first select the cells you want to use in the section. For information on selecting cells, see [Defining Cells](Seite 758). You can also enter your own text for these cells.

2. Choose *Edit → Sections → New section*. In the *New Report Section* dialog box, select *Section with calculated key figures*.

3. Position the cursor on the row or column and choose *Edit → Elements → Define element* or double-click on the row or column.

   The section with calculated key figures is made up of a row/column structure in which you enter short, medium, and long texts.

4. Define the cells you want to use in the section at the point of intersection of the row/column combination. Position the cursor on the appropriate cell and choose *Edit → Elements → Define element*, or double-click on the cell.

   You enter cell calculations for the section with key figures in the Formula Builder. All selected cells of the report are displayed in the Formula Builder as buttons. You can then define your key figure formula as required.

   The Formula Builder enables you to use the selected cells in the *section with calculated key figures*. You can also use cells that were calculated using the selected cells.

   Another feature is that you can reselect cells used in the section with calculated key figures to calculate values for other cells within the section (recursive cell definition).

   If you don’t want to display or print the cells you use in your section with calculated key figures in the other sections of your report, you can hide the corresponding rows and columns by choosing *Edit → Rows/Columns → Hide*.

### Sections with Characteristics and Key Figures

1. To define a new section in your report, choose *Edit → Sections → New section*.

2. In the following dialog box, select *Section with characteristics and key fig.*
Defining Sections

A new row and column structure appears for you to define your new report section. You define rows and columns as described under Defining Columns [Seite 748] and Defining Rows [Seite 751].

6. You can switch between the different sections by choosing Goto → Section → and then First section, Previous section, Next section, or Last section.

You can only perform calculations using columns within the same section. For calculations between sections that use columns, you must select cells. For more information, see Defining Cells [Seite 758].

Once you have defined a report, you can display and print out a table of contents of the report with Formatting → Section overview.

The overview contains the characteristics and characteristic values used in the individual sections, horizontal pages, and general data selection criteria. It also provides general information such as the user who last changed the report and the report name, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.
Section Layout

Use
There are a number of different ways you can modify the layout of the sections in a report:

• You can apply the parameters specified in the report layout
• You can apply a section-specific layout

Features
You can use a different layout for each section. Section layouts contain control information on:

• Row totals
• Row texts
• Column texts

You can also apply the report layout [Seite 1029] to sections. Any changes you make to the report layout then become effective automatically in the sections where it was applied.

The section layout can be defined differently for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

In the section overview in the Report Painter, you can change the attributes of the sections, the sequence of the sections, and the page breaks between the sections. This includes overscores and underscores, and how the headers should be printed.

For more information on formatting, see Summation Levels [Seite 1034].
Report Text

Use
In a Report Painter or Report Writer report, you can enter texts for the following:

- Title page
- Headers
- Footers
- End page

These texts are used for list output and exports in text format.

- Text for export

The text for export is used for Office integration and for exports into HTML or spreadsheet format.

The definition of report texts in the Report Painter is similar to that in the Report Writer.

You can also define report texts in the report output. SAP recommends that you enter report texts only after the report has been executed and output. This allows you to see which values the report text variables will use.

Prerequisites

You can only change texts in the report output if the report uses a standard layout [Seite 1017] in which the Change allwd dur exctn indicator is selected on the Page/Control screen. You cannot change texts in standard reports included with your SAP R/3 System.

Features

You can enter the following types of texts for report texts:

- Normal text
- Standard text variables such as the date, user name, and page number
- Special text variables
- Text variables for selection parameters
- Text variables for characteristics used in the text

For more information, see Variables in Report Text Definition [Seite 826].
Defining Report Texts
To enter report texts from any Create Report screen:

16. **Report Writer**

From the screen Create Report or Change Report or Display Report: Initial Screen, choose Goto → Texts.


**Report Painter**


17. To enter text, choose one of the processing functions in the following table.

### Processing Functions for Text Definition

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose (Report Painter)</th>
<th>Choose (Report Writer)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter text for title page</td>
<td>Title page</td>
<td>Title page</td>
</tr>
<tr>
<td>Enter text for headers</td>
<td>Headers</td>
<td>Headers</td>
</tr>
<tr>
<td>Enter text for footers</td>
<td>Footers</td>
<td>Footers</td>
</tr>
<tr>
<td>Enter text for last page</td>
<td>End page</td>
<td>End page</td>
</tr>
<tr>
<td>Enter text for export of report to HTML and Office Integration</td>
<td>Text for export</td>
<td>Text for export</td>
</tr>
</tbody>
</table>

The screen Change <text position> <report name> in Language <language code> appears.

If these functions are not available, choose Formatting → Report layout and check whether Change allowed during execution is selected on the tab Page/control.

18. Choose Text → Save.

19. Choose Text → Exit.

The text appears on the Create Report: Texts screen.

20. To save the report, choose Report → Save.

**Entering Variables in Report Text**

In the report output, you can insert text variables, frames, and rows with Insert. For more information about the different types of text variables you can define in your report text, and how to enter variables in report text, see Using Variables in Report Text Definition [Seite 826].
Variables for The Definition of Report Texts

You can use the following categories of text variables when defining report texts:

- Standard text variables
  For more information, see Using Standard Text Variables In Report Text Definition

- Special text variables
  For more information, see Using Special Text Variables in Report Text Definition

- Text variables for selection parameters
  For more information, see Using Text Variables For Selection Parameters in Report Text Definition

- Text variables for characteristics used in the report
  For more information, see Using Text Variables For Characteristics in Report Text Definition

Using Standard Text Variables in Report Text Definition [Seite 827]
Using Special Text Variables in Report Text Definition [Seite 829]
Using Text Variables for Selection Parameters in Report Definition [Seite 831]
Using Text Variables for Characteristics in Report Definition [Seite 833]
Using Standard Text Variables in Report Texts

Use

A standard text variable is an SAP-delivered variable, which you can enter directly into a report when defining report text. The system calculates the value for the variable based on current system records.

- Author of report
- Date of report creation
- Time of report creation
- Page number

The standard text variables *Horizontal double line in report width* and *Horizontal line in the report width* replace the %FILL- and %FILL= variables for filling a line with the non-alphabetic characters - and =.

Procedure

To enter standard text variables when defining report text on the *Change <Text Position> <Report Name> in Language <Language Code>* screen:

7. Position the cursor at the point where you want to insert the variable and choose Insert → Standard variables.
   
The Standard Text Variables dialog box appears. A list of the standard text variables that can be used is displayed.

8. Move the cursor to the standard text variable that you want to include in your report text and choose Choose.
   
The text variable is inserted at the point where you positioned the cursor on the *Change <Text Position> <Report Name> in Language <Language code>* screen.

9. If you want to change the parameters controlling the display of the text variable in the report output:
   
a) Choose Edit → Attributes.
   
The Change Attributes dialog box appears.
   
   b) Enter the display attributes for the text variable:
      
      - Define whether the color used for the text variable is intense or the standard color.
      
      - Enter a color code if you want to display the variable in color.
      
      - Define the width of the text variable.
      
      - Define the offset for the text variable.

      For example, if you define a width of 20 and an offset of 5, characters 6 to 25 will be printed.
10. You can use the following additional processing functions on this screen.

### Additional Processing Functions

**Change <Text Position> <Report Name> in Language <Language Code> Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text → Template</strong></td>
<td>Copy existing text as your report text (for example, header text from a different report or in a different language). You can then overwrite this text and save it.</td>
<td></td>
</tr>
<tr>
<td><strong>Text → Save</strong></td>
<td>Save the report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Text → Delete</strong></td>
<td>Delete report text in all languages.</td>
<td></td>
</tr>
<tr>
<td><strong>Edit → Cut</strong></td>
<td>Cut the selected variable and place it in the clipboard.</td>
<td></td>
</tr>
<tr>
<td><strong>Edit → Copy</strong></td>
<td>Copy the selected variable and place it in the clipboard.</td>
<td></td>
</tr>
<tr>
<td><strong>Edit → Paste</strong></td>
<td>Insert the contents of the clipboard at a selected position in the report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Edit → Insert row</strong></td>
<td>Insert a line for entering report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Edit → Attributes</strong></td>
<td>Change the parameters controlling the display of the text variable in the report output.</td>
<td></td>
</tr>
<tr>
<td><strong>Edit → Page width</strong></td>
<td>Change the page width for entering report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Edit → Delete row</strong></td>
<td>Delete the text line.</td>
<td></td>
</tr>
<tr>
<td><strong>Edit → Delete variable</strong></td>
<td>Delete the selected text variable.</td>
<td></td>
</tr>
<tr>
<td><strong>Insert → Standard variables</strong></td>
<td>Insert standard text variables in the report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Insert → Selctn parameters</strong></td>
<td>Insert text variables for selection parameters in the report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Insert → Special variables</strong></td>
<td>Insert special text variables in the report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Insert → Characteristics</strong></td>
<td>Insert text variables for characteristics in the report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Insert → Frame</strong></td>
<td>Draw a frame around the report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Insert → Insert row</strong></td>
<td>Insert a line for entering report text.</td>
<td></td>
</tr>
<tr>
<td><strong>Extras → Master language...</strong></td>
<td>Change the master language in which you want to enter the report text. (The logon language is automatically defaulted as the master language.)</td>
<td></td>
</tr>
</tbody>
</table>

11. Choose **Text → Save**.

12. Choose **Text → Exit**.

The variable appears on the *Create Report: Texts screen*. 

---

828

April 2001
Using Special Text Variables when Defining Report Texts

A special text variable provides information from master data files associated with characteristics used in a report. Special text variables are supplied for each reporting table delivered with the SAP R/3 System.

In a Controlling report, you could use special text variables to enter the name of the cost center manager and the manager’s department.

To enter special text variables when defining report text on the Change <Text Position> <Report Name> in Language <Language Code> screen:

9. Position the cursor at the point where you want to insert the variable and choose Insert → Special variable.

The Choose Master Data Table dialog box appears. A list of the reporting master data tables defined for the table your report uses is displayed.

10. Select the table that contains the characteristics for the variables you want to use and choose Choose.

The Choose Master Data Field dialog box appears.

11. Enter the following information:
   − Select the text type that you want to use for the text variable (characteristic description, characteristic value, short text of the characteristic, long text of the characteristic).
   − Select the master data field for which you want to display the text variable in the report text.

12. Choose Continue.

The variable is inserted at the point where you positioned the cursor on the Change <Text Position> <Report Name> in Language <Language Code> screen.

13. If you want to change the parameters controlling the display of the text variable in the report output:
   a) Choose Edit → Attributes.

The Change Attributes dialog box appears.

b) Enter the display attributes for the text variable:
   − Define whether the color used for the text variable is intense or the standard color.
   − Enter a color code if you want to display the variable in color.
   − Define the width of the text variable.
   − Define the offset for the text variable.

   For example, if you define a width of 20 and an offset of 5, characters 6 to 25 will be printed.
Using Special Text Variables when Defining Report Texts

14. On this screen, the additional processing functions in the table in Using Standard Text Variables in Report Text Definitions [Seite 827] are available.

15. Choose Text → Save.


   The variable appears on the Create Report: Texts screen.
Report Definition: Using Text Variables for Selection Parameters

Text variables for selection parameters are variables defined in the sets that are entered in the report definition. A selection parameter variable can be:

- A value variable
- A set variable

These variables replace the variables of the type %<variable name>, %<variable name>-TEXT (short text) and %<variable name>-TXTL (long text), which were used in releases prior to 3.0.

When you define the general data selection criteria for your report, you enter a set that contains the variable COMP (for the characteristic Company). You can now enter a text variable for the characteristic Company in the report text, for example, the header.

To enter selection parameter text variables when defining report text on the Change <Text Position> <Report Name> in Language <Language Code> screen:

8. Position the cursor at the point where you want to insert the variable and choose Insert → Select parameters.

   The Selection Parameters dialog box appears.

9. Enter the following information:

   - Select the text type that you want to use for the text variable (characteristic description, characteristic value, short text of the characteristic, long text of the characteristic).
   - Select the characteristic for which you want to display the text variable in the report text.

10. Choose Continue.

    The variable is inserted at the point where you positioned the cursor on the Change <Text Position> <Report Name> in Language <Language Code> screen.

11. If you want to change the parameters controlling the display of the text variable in the report output:

    a) Choose Edit → Attributes.

       The Change Attributes dialog box appears.

    b) Enter the display attributes for the text variable:

       - Define whether the color used for the text variable is intense or the standard color.
       - Enter a color code if you want to display the variable in color.
       - Define the width of the text variable.
       - Define the offset for the text variable.

       For example, if you define a width of 20 and an offset of 5, characters 6 to 25 will be printed.
Report Definition: Using Text Variables for Selection Parameters

12. On this screen, the additional processing functions in the table in Using Standard Text Variables in Report Text Definitions [Seite 827] are available.

13. Choose Text → Save.


The variable appears on the Create Report: Texts screen.
Report Definition: Using Text Variables for Characteristics

A characteristic variable represents data for the characteristics used in the report definition. Characteristic text variables replace the variables of the type %<field name>-F, %<field name>-T, %<field name>-FTEXT and %<field name>-TXTL, which were used in releases prior to Release 3.0.

When you define report columns, you enter a set that contains the characteristic Year. You can now enter a variable for the characteristic Year in the report text (for example, in the header). When the report is output, the system displays the current year in the report header.

To enter text variables for characteristics when defining report text on the Change <Text Position> <Name of Report> in Language <Language Code> screen:

8. Position the cursor at the point where you want to insert the variable and choose Insert → Characteristics.

   The Characteristics dialog box appears.

9. Enter the following information:
   - Select the text type that you want to use for the text variable (characteristic description, characteristic value, short text of the characteristic, long text of the characteristic).
   - Select how the variable values are to be displayed (single value, set of values, from value, to value).
   - Select the characteristic for which you want to display the text variable in the report text.

10. Choose Continue.

    The variable is inserted at the point where you positioned the cursor on the Change <Text Position> <Report Name> in Language <Language Code> screen.

11. If you want to change the parameters controlling the display of the text variable in the report output:
   a) Choose Edit → Attributes.

       The Change Attributes dialog box appears.

   b) Enter the display attributes for the text variable:
      - Define whether the color used for the text variable is intense or the standard color.
      - Enter a color code if you want to display the variable in color.
      - Define the width of the text variable.
      - Define the offset for the text variable.

         For example, if you define a width of 20 and an offset of 5, characters 6 to 25 will be printed.
Report Definition: Using Text Variables for Characteristics

12. On this screen, the additional processing functions in the table in Using Standard Text Variables in Report Text Definitions [Seite 827] are available.

13. Choose Text → Save.


   The variable appears on the Create Report: Texts screen.

   The system determines the characteristic value for the text variable from the first row/column of the current page.
Defining Selection Criteria

You enter the selection criteria for your report data on the Create Report: General Data Selection screen. These sets, together with the sets used in rows and columns, define the data in a report.

On the Create Report: General Data Selection screen, enter the set TD-LEDGER. This set contains the value AB for the characteristic Ledger. When the report is executed, the system only selects data records for the ledger AB.

You should use a set as selection criteria when one of the following conditions applies:

- The set contains only one value.
- The set contains more than one value, but you only want to use the total for the set and not each set value.

The following characteristics must be defined in your report, either as selection criteria, a row block, or a column block:

- Company
- Ledger
- Version
- Record type
- Period

To reduce processing time, you should specify all characteristics in the general data selection that need not be used in the report rows or columns.

Procedure


The Create Report: General Data Selection screen appears.

Sets that have been defined as default selection sets are listed on the screen. You define default selection sets in the library of the report. These sets appear as selection criteria for each report in a certain library.

You define default selection sets for the characteristics Company Code (TD-COCDE-TDG), Ledger (TD-RLDR-D4), Version (TD-RVERS-02), and Year (TD-RYEAR-95). These selection sets automatically appear each time a new report is created for the library.

For information about default selection sets, see Libraries [Seite 927].

7. Enter the name(s) of the set(s) that you want to use as selection criteria for the report data.
Defining Selection Criteria

You cannot use a set containing characteristics that are already being used in a row or column block. You also cannot use a multidimension set as selection criteria. You can use a data set as selection criteria, but only when there is exactly one value in the set.

You can enter a set that has not yet been created in your system. The system asks you whether you want to create the set and displays a series of dialog boxes in which you choose whether you want to create a report set or a general set and then select the relevant set type.

You can enter basic and multidimension sets that have been created for characteristics from tables other than the table that the report uses. To do so, the characteristic of the row block set must be compatible with the corresponding characteristic in the report’s table.

The Report Writer can use sets from all set classes. However, a set name is only unique within one set class.

If you entered a set name that exists in two different set classes, the system displays a dialog box in which you select the set that you want to use as the row block.

You can also enter set variables as report selection criteria. For more information, see Entering a Variable as Selection Criteria below.

8. If you want to eliminate internal business volume within a set hierarchy that you entered as selection criteria, set the IntBusVolElim indicator.

You can set the IntBusVolElim indicator and use the selection variation for a characteristic of the screen Create Report: General Data Selection. This allows you to eliminate internal business volume within a set hierarchy and also create reports for the different levels in the set hierarchy.

9. Enter variation data for a selection set in the Vary From/Vary To and S fields as required.

If a selection set contains more than one value, the Report Writer normally accumulates the data for the different values. By entering appropriate values in the Vary Frm, Vary To, and S fields, you can instruct the Report Writer to create different reports for the different characteristic values, as well as for the different set levels (if the selection set is a single-dimension set).

When you enter variation data, variation of the selection is automatically activated when you execute the report’s report group.

The levels within a set hierarchy are numbered as follows: The uppermost set node is assigned level 1. The set node directly underneath this is assigned level 2, and so on. Characteristic values in basic sets are always assigned level 1- and basic sets are always assigned level 2-.

Enter the following information:

– The upper hierarchy level for selecting report data. You can enter a number greater or less than 0.
The lower hierarchy level for selecting report data. You can enter a number greater or less than 0.

Set the S indicator (Single value) if you also want different reports for the detail/single values contained in the selection set. If you want the system to summarize all records, do not set the S indicator (Single value).

You create a single-dimension set called TD-COCDE-TD that contains three basic sets: TD-COCDE-TD1 (local companies TD11, TD12, TD13), TD-COCDE-TD2 (local companies TD21, TD22, and TD23), and TD-COCDE-TD3 (local companies TD31, TD32, and TD33). You then use the set as selection criteria for your report. The system selects and summarizes data records for all nine companies.

If you entered 1 in the Vary Frm field and 2 in the Vary To field and left the S field blank, the system would create four different reports for the three companies.

Refer to the following table for using additional data selection methods with the Vary Frm, Vary To, and S fields.

Using the Vary Frm, Vary To and S Fields (Example TD-COCDE-TD)

<table>
<thead>
<tr>
<th>From</th>
<th>To</th>
<th>S</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td></td>
<td>Display one report with the data summarized for the single-dimension set</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Space</td>
<td>TD-COCDE-TD.</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td></td>
<td>Display three separate reports with the data summarized for the basic sets</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Space</td>
<td>TD-COCDE-TD1, TD-COCDE-TD2, and TD-COCDE-TD3.</td>
</tr>
<tr>
<td>1</td>
<td>2</td>
<td></td>
<td>Display four reports; one with the summarized data for set TD-COCDE-TD</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Space</td>
<td>and three separate reports for the data summarized in sets TD-COCDE-TD1,</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>TD-COCDE-TD2, and TD-COCDE-TD3.</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>X</td>
<td>Display nine separate reports; one for each company (set value) in sets</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>TD-COCDE-TD1, TD-COCDE-TD2, and TD-COCDE-TD3.</td>
</tr>
<tr>
<td>1-</td>
<td>1-</td>
<td>X</td>
<td>Display one report with the data summarized for the single-dimension set</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>TD-COCDE-TD.</td>
</tr>
</tbody>
</table>

You can further limit selection criteria when you execute a report group. For more information, see Report Group Execution [Seite 962] and the procedure Executing a Report Group [Seite 964].

When displaying a report that varies the level of selection data, you can use the View functions to switch between the different reports that have been created as a result of the variation levels. For more information about the View functions, see Functions in the Report Output [Seite 974].

If a report is executed in the background, reports that are created as a result of variation levels are printed consecutively.

10. On this screen you can use the additional processing functions shown in the following table.

Additional Processing Functions (Create Report: General Data Selection Screen)
Defining Selection Criteria

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Display set</td>
<td>Display set used as selection criteria</td>
</tr>
<tr>
<td>Edit → Change set</td>
<td>Change set used as selection criteria. You must save your report before you can call up the set maintenance transactions.</td>
</tr>
<tr>
<td>Edit → Insert set...</td>
<td>Insert a set as selection criteria. The Select Sets dialog box appears. You can enter selection criteria to search for a set.</td>
</tr>
<tr>
<td>Edit → Insert variable...</td>
<td>Insert an existing set variable as selection criteria</td>
</tr>
<tr>
<td>Edit → Delete row</td>
<td>Delete a row</td>
</tr>
<tr>
<td>Edit → Selection rule</td>
<td>Enter a selection rule</td>
</tr>
<tr>
<td>Edit → Delete sel. rule</td>
<td>Delete a selection rule</td>
</tr>
<tr>
<td>Goto → Report layout → Use standard layout</td>
<td>Reset layout parameters to default values of standard layout</td>
</tr>
<tr>
<td>Extras → List of characteristics</td>
<td>Display list of characteristics used in the report</td>
</tr>
<tr>
<td>Extras → Maintenance language</td>
<td>Switch language for report texts (for example, to enter text for the report description in another language)</td>
</tr>
<tr>
<td>Extras → Other std layout</td>
<td>Assign new standard layout to the report</td>
</tr>
<tr>
<td>Extras → Threshold value</td>
<td>Enter threshold value condition to highlight in color or print report rows, depending on the values in a specific report column</td>
</tr>
</tbody>
</table>

You can also use the Insert line and Delete line icons positioned below the list of data selection sets to insert a new blank line and delete a line.

Entering a Formula to Select Report Data

If you cannot completely define the selection criteria using a set or set variable, you can use a selection formula. To use a selection formula, you must first enter the selection formula as a rule. You then use the rule name when you define a report. You define rules and selection formulas in Customizing.

For more information on defining selection formulas in rules, see the IMG for the Special Purpose Ledger under Tools → Maintain Validation/Substitution/Rules → Logical Rules for Validation and Substitution [Extern].

To improve processing time, you should use a set rather than a selection formula. You should only use a selection formula if a condition cannot be defined with a set. You would use a selection formula, for example, when you want to select only certain value combinations for different characteristics.
If you want to enter rule names as selection criteria on the Create Report: General Data Selection screen, proceed as follows:

4. Choose Edit → Selection rule.
   The Choose Rule dialog box appears.

5. Enter the name of the selection rule.
   The selection rule name that you use must be defined in Customizing. Also, the selection formula used in a report definition can only refer to the table defined in the report's library.
   For example, a formula can only refer to the table GLT1 if the report is in a library that uses the table GLT1.

6. Choose Continue.
   The Create Report: General Data Selection screen appears, displaying the rule name that you entered.

**Entering Variables as Selection Criteria**

You can use set variables as selection criteria. When you execute a report that uses a set variable, the system prompts you to enter a set name for the variable.

You can enter set variables whose default set uses a table that is not the table of the report. A prerequisite is that the table field of the default set is compatible with the relevant characteristic of the report table.

For example, you can:

(c) Create a set variable called BUSAREA. The default set of the variable is a basic set created for table CCSS and the characteristic "Business area" (GSBER). The set contains a range of business areas.

(d) You create a Report Writer report for a library that uses table GLT1 and enter the set variable BUSAREA as data selection criteria.

Since the variable uses a default set for table CCSS, the system selects the corresponding characteristic from table GLT1. If there is more than one compatible characteristic in table GLT1, the system displays a dialog box listing these characteristics. You then select the characteristic that you want to use in the report definition. In this example, you can choose the characteristic *business area* (RBUSA) or *trading partner's business area* (SBUSA).

To enter a set variable as selection criteria:

3. Choose Edit → Insert variable.
   The Selection Conditions for Variables dialog box appears. Enter the selection criteria to search for an existing set variable.

4. Enter your selection criteria and select the variable that you want to use.

For more information on creating set variables, see [Creating Set Variables][Seite 697].
Defining Rows

Procedure

   The Create Report: Row Overview screen appears.

8. Enter the name of the set(s) to be used as the report row block.
   You can use a basic, data, single-dimension, or multi-dimension set.
   You cannot enter a set that contains characteristics that are already being used in a column block or as selection criteria in the report. You can use the same characteristic in more than one row block and you can use more than one characteristic in a row block(s); however, you cannot use the characteristic again in a column block or as selection criteria in the report.
   You can enter a set that has not yet been created in your system. The system asks you whether you want to create the set and displays a series of dialog boxes in which you choose whether you want to create a report set or a general set and then select the relevant set type.
   You can enter basic and multi-dimension sets that have been created for characteristics from tables other than the table that the report uses. To do so, the characteristic of the row block set must be compatible with the corresponding characteristic in the report's table.
   You create a report for a library that uses table GLT1 and want to enter a hierarchy of accounts in the report rows. You could enter a Controlling cost element group created for the characteristic "Cost element" (KSTAR) in table CCSS as the row block. In this case, characteristic "Cost element" is compatible with the characteristic "Account" in table GLT1.

9. For each row block, enter the following data as required:
   - Specify whether you want to insert a page break before a row block or insert blank lines between row blocks.
     To insert a page break before a row block, enter * in the Page break field.
     To insert a specific number of blank row lines before a row block, enter the number of blank row lines you want in the Page break field.
   - Specify whether or not the system should insert column headings before a specific row block (set text for the row block). Select Print heading if you want the system to insert a column heading for the corresponding row block.
   - Specify if you want to hide the row block. The row block is then hidden for all column blocks. You can refer to a hidden row block in a formula and/or key figure; however, the row block is not displayed in the report.
Defining Rows

- Specify whether you want to inactivate the row block so that it is ignored in the report.

  When you set a row block as inactive, the Report Writer completely ignores the row block. You cannot refer to an inactive row block in a key figure or a row formula. This function can be used for test purposes.

- Specify whether you want to switch the +/- sign for all report rows in the row block. If you set this checkbox, the +/- sign will always be switched for the values in the respective report rows.

  The Change +/- indicator assigned to a row block overrides the format group settings specified for the Change +/- sign indicator in the standard layout parameters (Create Report: Report layout: Representation screen).

- Enter the lower summation level (From level) for displaying totals for the row block. You can enter a number greater or less than 0.

- Enter the upper summation level (To level) for displaying totals for the row block. You can enter a number greater or less than 0.

  Summation levels assigned to a row block override the summation levels assigned to the entire report in the standard layout parameters (Create Report: Report Layout: Row Totals screen). You can change these summation levels after you have output a report to your screen. For more information see sorting report rows [Seite 997] and functions in the report output [Seite 974].

10. Choose Enter.

The descriptions for the row blocks appear. The Set, Formula, and Key fig. block fields are set accordingly, depending on if you entered a set, formula, or key figure in the Row block field(s).

  The Report Writer can use sets from all set classes. However, a set name is only unique within one set class. If you entered a set name that exists in two different set classes, the system displays a dialog box in which you select the set that you want to use as the row block.

11. If you want to enter additional text for the row blocks:

   a) Position the cursor on the row block for which you want to enter the texts and choose Extras → Additional texts.

      The Texts for Row Block No. <Number> dialog box appears.

   b) Make the following entries:

      Lead column fields:

      Select the Text indicator if you want to enter your own text for the lead column. Enter the text in the field next to the Text indicator.

      Select the Text from set indicator if you want to use the description entered in the row set as the lead column text. This option is the default setting.
**Defining Rows**

*Sum total fields:*

Select the *Text* indicator if you want to enter your own text for the highest row block total. Enter the text in the field next to the *Text* indicator.

Select the *Text from set* indicator if you want to use the description entered in the row set as the text for the row sum total. This option is the default setting.

12. On this screen, you can use the additional processing functions in the table for the *Create Report: Initial Screen* as described in *creating a Report Painter report [Seite 811]* as well as the functions in the following table.

**Additional Processing Functions (Create Report: Row Overview Screen)**

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display a set used as a row block.</td>
<td><em>Edit → Display set</em></td>
</tr>
<tr>
<td>Change a set used as a row block. You have to save your report before you can call up the set maintenance transactions.</td>
<td><em>Edit → Change set</em></td>
</tr>
<tr>
<td>Enter characteristic information for a row set. For more information, see entering characteristic information for a row block [Seite 846].</td>
<td><em>Edit → Choose</em></td>
</tr>
<tr>
<td>Inactivate row/column block combinations. For more information, see inactivating column for a row block [Seite 845].</td>
<td><em>Edit → Inactive columns</em></td>
</tr>
<tr>
<td>Insert a set in the row block. The Select Sets dialog box appears. You can enter selection criteria to search for a set.</td>
<td><em>Edit → Insert set</em></td>
</tr>
<tr>
<td>Insert a formula. For more information, see inserting formulas in row block [Seite 850].</td>
<td><em>Edit → Insert formula</em></td>
</tr>
<tr>
<td>Insert a key figure. For more information, see inserting key figures in row block [Seite 853].</td>
<td><em>Edit → Insert key figures</em></td>
</tr>
<tr>
<td>Delete a row block.</td>
<td><em>Edit → Delete row block</em></td>
</tr>
<tr>
<td>Reset all layout parameters to the default values from the standard layout.</td>
<td><em>Goto → Report layout → Use standard layout</em></td>
</tr>
<tr>
<td>Display a list of characteristics that are used in the report.</td>
<td><em>Extras → List of charact.</em></td>
</tr>
<tr>
<td>Go to a new report language (for example, to enter language-specific text for the report description).</td>
<td><em>Extras → Maintenance lang...</em></td>
</tr>
<tr>
<td>Assign a new standard layout to the report.</td>
<td><em>Extras → Other std layout</em></td>
</tr>
<tr>
<td>Enter additional row block text for the lead column and/or sum total.</td>
<td><em>Extras → Additional texts...</em></td>
</tr>
</tbody>
</table>
Define a row block as a row block for non-assigned values. A **row block for non-assigned values** is assigned to another row block in order to determine the values that fulfill the data selection criteria, but are not already included in the row block to which it refers. For more information, call up the additional documentation by choosing Help.

You can also use the *Insert line* and *Delete line* icons positioned below the list of row blocks to insert a new blank row block line and delete a row block line.

**See also:**
- Inactivating Columns for a Row Block [Seite 845]
- Entering Characteristic Information for a Row Block [Seite 846]
- Inserting Formulas in Row Blocks [Seite 850]
- Inserting Key Figures in Row Blocks [Seite 853]
Inactivating Columns for a Row Block

Normally, each column block is printed for every row block in a report. However, for each row block, you can inactivate specific column blocks. Using the Edit → Inactive columns function, you can define which combinations of row and column blocks should be printed in a report.

Procedure

3. On the Create Report: Rows screen, move the cursor to the row block for which you want to inactivate a column block and choose Edit → Inactive columns.

   The Inactive Column Blocks dialog box appears, displaying the possible column blocks that you can inactivate.

4. Set the Inactiv indicator for each column block that you want to inactivate for the row block and choose Continue.

   You cannot refer to inactive combinations of row/column blocks in a key figure and/or cell definition.
Entering Characteristic Information for a Row Block

Once you have entered a row set on the Create Report: Rows screen, you can enter additional information for each characteristic used in the report row, such as page breaks and additional space between physical report rows.

Procedure

8. On the Create Report: Rows screen, move the cursor to the row set for which you want to enter characteristic information and choose Edit → Choose.
   The Row Characteristic dialog box appears. You can switch between characteristics using the Prev. characteristic and Next characteristic buttons.

9. Enter the following data in the Settings for totals group box as required:
   – The total level to control the total level of data shown in the report.

   ![Image]

   You can decide to display only the total of a set, and ignore the set's individual values. The default (blank) displays all levels of values, including the individual values in a basic set. (If you set the S indicator (Suppression) in a multi-dimension or single-dimension set, this value overrides the value entered in the Total Level field.)

   To change the level of data displayed, you enter a level number in the Total level field.

   You can enter the following values:

   **0**  Display all levels of values contained in the set.
   **1**  Display only values at the first level of the set characteristic.
   **2**  Display only values at the first and second levels of the set characteristic.
   **n**  Display only values at the first up to the nth level of the set characteristic.
   **1-** Display only basic set values (lowest level).
   **2-** Display only basic set values and the total for each basic set.

   For this field, you can only use as many numeric values as there are levels within the set hierarchy. 1- and 2- are the only negative values possible.

   For example, you cannot enter 5 in this field if there are only four levels within the set hierarchy.

   The sets that appear at the highest level of a characteristic are assigned the level 1.

   ![Image]

   The single-dimension set TD-RACCT-IE ("Levels for Characteristic Account" graphic in Using Sets in Report Rows [Seite 894]) is assigned the level 1 because it is at the highest level of the characteristic Account (field RACCT); basic set TD-RCNTR-12 is also assigned level 1 because it is at the highest level of the characteristic Cost Center (field RCNTR).
Entering Characteristic Information for a Row Block

If you enter 1 in the Total level field for the set TD-RACCT-IE and enter 0 in the Total level field for the set TD-RCNTR-12, the system only prints total values for the set TD-RACCT-IE, but prints individual values for the cost centers. (The set structure of this row block is shown in the "Levels for Characteristic Account" graphic in Using Sets in Report Rows [Seite 894].)

– Specify whether you want the system to suppress the entire characteristic (Suppress charact. indicator). The text of the corresponding row total line is printed, but the amount is not. This field does not appear for the last characteristic listed for the current row set.

  If you set the Suppress charact. indicator for the set TD-RACCT-IE, the system would not print individual totals for the set. It would only print "Total Accounts"; no amount is printed.

– Specify whether you want to eliminate internal business volume for the characteristic. To activate the Int.Bus.Vol.Elim. indicator, the receiver field and a corresponding sender field must exist in table T804C.

  For example, if you want to eliminate internal business volume for the receiver field Business Area (RBUSA), a corresponding sender field (SBUSA) must be entered in table T804C.

  Internal business volume is eliminated hierarchically within the set.

  You create a single-dimension set called RBUSA-11 that contains the basic sets RBUSA-21 (containing the range of business areas from 0001 to 1000) and RBUSA-22 (containing the range of business areas from 1001 to 2000).

  If a database record has the receiver field (RBUSA) value 0001 and the sender field (SBUSA) value 0500, all corresponding subtotals at the basic set level are eliminated, since both values are included in the same basic set (RBUSA-21).

  If a database record has the receiver field (RBUSA) value 1500 and the sender field (SBUSA) value 0600, amounts are only eliminated from the total sum of sets RBUSA-21 and RBUSA-22 (at the single-dimension set level), since this is the lowest sum in the hierarchy where the data records for business areas 1500 and 0600 are included.

10. Enter the following page break information as required:

  – The level you enter in the Unconditional field tells the Report Writer at which level to place horizontal page breaks in the report. The default (blank) places page breaks at fixed intervals as defined by the Length field in the Create Report: Layout: Page/Control dialog box.

  You can specify the following values:

  0 Place page break at fixed intervals as defined by the Length field in the Create Report: Layout: Page/Control dialog box.

  1 Place page breaks at the end of every first level of the set characteristic.

  2 Place page breaks at the end of every second level of the set characteristic.
Entering Characteristic Information for a Row Block

- Place page breaks at the \textbf{n}th level of the set characteristic.
- Place page breaks at the lowest level of the set characteristic.
- Place page breaks at the end of every basic set.

You can only use a value for a specific level if it is not suppressed via the \textit{S} indicator (Suppression) within the set hierarchy.

For this field, you can only use as many numeric values as there are levels within the set hierarchy. \textbf{1-} and \textbf{2-} are the only negative values possible.

For example, you cannot enter \textbf{5} in this field if there are only four levels within the set hierarchy.

- The \textit{Conditional} field implements an "intelligent" page break facility. The system checks if there is enough room on a page for all of the lines at the next level before inserting an automatic page break after a specified level. The default (blank) is no intelligent page breaks.

Values are the same as for the \textit{Unconditional} field.

You can use the \textit{Conditional} field in the following cases:

- You do not want the accounts for a company on two different pages.
- There is enough room on a page for all of the accounts for the next group of company accounts; the accounts should print on the same page.

The system only starts a new page for the next group of company accounts if the group does not fit on the same page.

11. Enter data in the \textit{Totals display} group box as required:

The \textit{Totals display} fields allow you to enter a number range of levels and then:

- Underscore or overscore with single or double lines or format characters at these levels.
- Insert additional blank lines between levels.
- Highlight lines between levels.
- Define colors for lines.

Use the \textit{From level} indicators to select a beginning level number for the \textit{Lower border} and \textit{Upper border} fields (explained later in this section). Valid values are the same as the \textit{Unconditional} field.

Use the \textit{To level} indicators to select an ending level number for the \textit{Lower border} and \textit{Upper border} fields (explained later in this section). Valid values are the same as the \textit{Unconditional} field.

For example, if you enter \textbf{1} as the \textit{From level} value and \textbf{1} as the \textit{To level}, the system only formats totals at level \textbf{1}.

If you enter a negative value as the \textit{From level} value, you cannot enter a \textit{To level} value.
For example, if you enter 2– in the From level field, you cannot enter a value in the To level field.

Select the Highlight row indicator if you want to highlight the row characteristic total.

Enter a code for the color in which you want to display the row characteristic total in the Color field.

If you want to use SAP standard colors in your report, you only need to set the Standard colors indicator in the layout parameters assigned to the report (Page/Control screen). You do not need to enter a color code here.

Set the Lower border indicators depending on how you want the lower border for the row characteristic totals to appear. You can define the lower border so that no lower border appears, a single line appears, a double line appears, or a user-defined character is used for the border.

Set the Upper border indicators depending on how you want the upper border for the row characteristic totals to appear. You can define the upper border so that no upper border appears, a single line appears, a double line appears, or a user-defined character is used for the border.

12. If you want to enter additional level information for displaying row totals (for example, to underline sub-totals or to display sub-totals in a different color than totals), choose Additional.

A dialog box appears, displaying the Totals display fields for the additional level.

13. If there are additional characteristics to define for the row set, select the Next characteristic button.


You return to the Create Report: Rows screen.
Inserting Formulas in Row Blocks

7. On the Create Report: Rows screen, move the cursor to below the row block line where you want the formula to appear.

8. Choose Edit → Insert formula.
   The Define Row Formula dialog box appears.

9. Enter the following data:
   - The text that you want to appear in the report row for the formula.
   - A formula

   You defined two multi-dimension sets for row blocks 1 and 2. You want to define a row containing the difference between the highest totals of the row blocks. In line 3, you enter the formula ‘001’ - ‘002’.

   - Number of the row block that you want to use as the representative row block to define the column structure of a formula row. The active column blocks of the representative row block determine the column structure of the formula row.

   The representative row block must be a set and must be entered as an operand in the formula.

   If you do not make an entry in this field, the system automatically determines the representative row block. If you make an incorrect entry in this field, the system automatically corrects the entry.

The Report Writer automatically assigns a summation level to the formula row. This level is calculated from the highest total of the rows used in the formula plus one.

For example, you defined two single-dimension sets for row blocks 1 and 2. You defined an additional row containing the grand total of the highest totals of the row blocks, using the formula ‘001’ + ‘002’ in line 3 of the row definition. The highest summation levels of the sets used in row blocks one and two are 3 and 2 respectively. The Report Writer automatically assigned summation level 4 to the formula row (using the highest summation level of the row block totals (3) plus one).

When building a formula, you can use the operators in the table in Using Set Formulas in Report Writer [Seite 906].

Within a row formula you can use various operands.

Beginning with Release 3.0C, the syntax used to enter formula operands has changed. You now enter formula operands in the form ‘nnn’ (for example, ‘001’ to enter the row block 001). In releases prior to Release 3.0C, you enter formula operands using angle brackets around the operand (for example <001>).
The system automatically converts any existing formulas into the new format. You do not therefore need to change your sets or reports that contain formulas.

You can use the following operands in row formulas:

- Line numbers in the form ‘\texttt{\textbackslash nnn}’ (for example ‘\texttt{001}’ for line 001)
- Value variables (for example, ‘\texttt{\&PERIOD}’ for the value variable PERIOD)
- Symbolic names for cells (for example, ‘\texttt{\textsc{total}}’ for a specific totals row in a report)

Within a formula you can also use:
- Absolute values (for example, 10 or 20)
- Combinations of absolute values and line numbers, for example, 10 + ‘\texttt{002}’
- Boolean Logic

The following rules apply to formulas:

- Operands for formulas use the value of the highest sum of the row set. (The value at level 1 of the set.) If you use negative values when defining your levels for a set characteristic, the system cannot process the formula.

- If a report contains more than one row block, the resulting formula columns will have the lowest number of columns defined for the row blocks.

Row block one contains 5 columns. Row block two contains 3 columns. The row formula is ‘\texttt{001}’ + ‘\texttt{002}’. The results of the formula will be presented in 3 columns.

- When processing a report for which print classes are defined, the result of the formula uses the highest defined print class, except when the print class is zero. Print class \texttt{0} takes priority over the other print classes.

Report row one uses print class 5 and row two uses print class 3. When you define a formula to calculate the total of the two rows, the result of the formula uses print class 5.

- When processing a report that contains both row formulas and column formulas, the system processes the column formula at the point of intersection.

- If a row block is suppressed, the row block can still be used in formula processing; however, the row block data is not displayed in the report output.

10. Enter information to determine how the formula row is displayed in the report output:

- If you want to highlight the row formula total, select \textit{Highlight row}.
- Enter a code for the color in which you want to display the row formula total.
- Set the \textit{Lower border} indicators depending on how you want the lower border for the row formula totals to appear. You can define the lower border so that no lower border appears, a single line appears, a double line appears, or a user-defined character is used for the border.
Inserting Formulas in Row Blocks

- Set the *Upper border* indicators depending on how you want the upper border for the row formula totals to appear. You can define the upper border so that no upper border appears, a single line appears, a double line appears, or a user-defined character is used for the border.

11. To check that the syntax in the formula is correct, choose *Check formula*.

12. Choose *Continue*.

The formula appears on the *Create Report: Rows* screen.

You can enter a formula that refers directly to the result of another formula line.

**Example:**

Your report contains the following rows:

- **Income Accounts** (row block 1)
- **Expense Accounts** (row block 2)
- **Sum total of the Income and Expense Accounts** (row block 3)
  - You enter this total using the formula `001 + 002`
- **50% of the sum total** (row block 4)
  - You enter this row using the formula `003 / 2`
  - The operand ‘003’ in this formula refers to the result of the formula calculated for row block 3.
Inserting Key Figures in Row Blocks

7. On the Create Report: Rows screen, move the cursor to the row block line where you want the key figure to appear.

8. Choose Edit → Insert key figures.

A list of defined key figures appears in a dialog box. If only one key figure is defined for the report, it automatically appears on the Create Report: Rows screen.

9. Select the key figure that you want to include in the report and choose Choose.

The selected key figure appears on the Create Report: Rows screen.

For more information about defining key figure blocks, see Defining Calculated Key Figures [Seite 875].
Defining Columns


   The Create Report: Columns screen appears.

8. Enter the name of the set(s) to be used as the column block.

   You can use a basic, data, single-dimension, or multi-dimension set as the column block.

   You cannot enter a set that contains characteristics that are already being used in a row block or as selection criteria in the report. You can use the same characteristic in more than one column block and you can use more than one characteristic in a column block(s); however, you cannot use the characteristic again in a row block or as selection criteria in the report.

   You can enter a set that has not already been created in your system. The system asks you whether you want to create the set and displays a series of dialog boxes in which you choose whether you want to create a report set or a general set and then select the relevant set type.

   Beginning with Release 4.0, you can enter basic and multi-dimension sets that have been created for characteristics from tables other than the table that the report uses. To do so, the characteristic of the column block set must be compatible with the corresponding characteristic in the report’s table.

   The table-independent usage of sets in reports is not possible for data and multi-dimension sets.

   You can use variables in your column headings. The variables are replaced with the default variable value when you execute your report if the column text type Key is selected in the report’s standard layout (Create Report: Layout: Column Texts screen).

   You enter the variable for the column heading in your column set (Short text of set line field in the set maintenance transactions).

   For example, your report uses the value variable &PERIOD for the period and you want to display the current value for the period in a column heading. You enter the variable &PERIOD in your column set as the set line description for the relevant period and enter the set in the column definition of your report. If the column text type Key is selected in your report’s standard layout, the variable &PERIOD will be replaced with the period value (for example, 5 ) when you execute the report. The description is printed for all other column text types (for example, May).

9. For each column block, enter the following data as required:

   – Specify whether you want to insert a page break before a column block or insert blank lines between column blocks.

      To insert a page break before a column block, enter * in the Page break field.

      To insert a specific number of blank column lines before a column block, enter the number of blank column lines you want in the Page break field.
– Specify whether you want to inactivate the column block. The column block is then inactivated for all row blocks. You cannot refer to an inactive column block in a key figure.

For more information about inactivating a column block for a specific row block, see Inactivating Columns for a Row Block [Seite 845].

If you want to suppress a column in a report and refer to it in a key figure, you can do this by assigning the column width 0 (using format groups).

For example, your column block is a basic set that uses the characteristic Year (value: 1997). You want to suppress the column for 1997, but still refer to it in a key figure. You:

a) Assign a format group to the basic set value 1997 (for example, 5).

b) Define the column width for format group 5 as 0 in the report parameters.

10. Choose Enter.

The descriptions for the column blocks appear.

The Report Writer can use sets from all set classes. However, a set name is only unique within one set class.

If you entered a set name that exists in two different set classes, the system displays a dialog box in which you select the set that you want to use as the column block.

11. If you want to enter additional text for the column blocks:

Position the cursor on the column block for which you want to enter the texts and choose Extras → Additional texts.

The Texts for Column Block No. <Number> dialog box appears.

For more information about entering additional text for the column blocks, see step five in Defining Rows [Seite 841].

12. On this screen, you can use the additional processing functions in the following table, as well as the functions in the table for the Create Report: Initial Screen in Creating a Report Definition [Seite 811].

### Additional Processing Functions – Create Report: Columns Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Display set</td>
<td>Display a set used as a column block.</td>
</tr>
<tr>
<td>Edit → Change set</td>
<td>Change a set used as a column block. You have to save your report before you can call up the set maintenance transactions.</td>
</tr>
<tr>
<td>Edit → Choose...</td>
<td>Enter characteristic information for a column set. For more information, see Entering Characteristic Information for a Column Block [Seite 857].</td>
</tr>
</tbody>
</table>
### Defining Columns

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → <strong>Insert column block</strong></td>
<td>Insert a column block.</td>
</tr>
<tr>
<td>Edit → <strong>Delete column block</strong></td>
<td>Delete a column block.</td>
</tr>
<tr>
<td>Goto → Layout → <strong>Reset layout</strong></td>
<td>Reset all layout parameters to the default values from the standard layout.</td>
</tr>
<tr>
<td>Extras → <strong>List of charact.</strong></td>
<td>Display a list of characteristics that are used in the report.</td>
</tr>
<tr>
<td>Extras → <strong>Maintenance lang...</strong></td>
<td>Go to a new report language (for example, to enter language-specific text for the report description).</td>
</tr>
<tr>
<td>Extras → <strong>Other std layout...</strong></td>
<td>Assign a new standard layout to the report.</td>
</tr>
<tr>
<td>Extras → <strong>Threshold value...</strong></td>
<td>Enter a threshold value condition to highlight in color or print report rows, depending on the values in a specific report column.</td>
</tr>
<tr>
<td>Extras → <strong>Additional texts...</strong></td>
<td>Enter additional column block text.</td>
</tr>
</tbody>
</table>

You can also use the **Insert line** and **Delete line** icons positioned below the list of column blocks to insert a new blank column block line and delete a column block line.

**See also:**

- Entering Characteristic Information for a Column Block [Seite 857]
- Using Formula Variables in Reports: Examples [Seite 859]
Entering Characteristic Information for a Column Block

Once you have entered a column set on the Create Report: Columns screen, you can enter additional information for each characteristic used in the report column, such as page breaks and additional space between physical report columns.

Procedure

8. On the Create Report: Columns screen, move the cursor to the column set for which you want to enter characteristic information and choose Edit → Choose.

The Column Characteristic dialog box appears.

9. Enter the following data in the Settings for totals group box as required:

   – See the definition for the Total level field in Entering Characteristic Information for a Row Block [Seite 846].

   – Specify whether you want the system to suppress the sum column for the characteristic (Suppress charact. indicator). If you set this indicator, only columns for the detailed values of the characteristic are printed. This field does not appear for the last characteristic listed of the current column set.


10. Enter the following page break information as required:

    – The level you enter in the Unconditional field tells the Report Writer at which level to place vertical page breaks in the report. The default (blank) places page breaks at fixed intervals as defined by the Width field in the Create Report: Layout: Page/Control dialog box.

        You can enter the following values:

        0   Place page break at fixed intervals as defined by the Width field in the Create Report: Layout: Page/Control dialog box.

        1   Place page breaks at the end of every first level of the set characteristic.

        2   Place page breaks at the end of every second level of the set characteristic.

        n   Place page breaks at the n-th level of the set characteristic.

        1-   Place page breaks at the lowest level of the set characteristic (all levels).

        2-   Place page breaks at the end of every basic set.

        You can only use a value for a specific level if it is not suppressed via the S indicator (Suppression) within the set hierarchy.

        For this field, you can only use as many numeric values as there are levels within the set hierarchy. 1- and 2- are the only negative values possible.

        For example, you cannot enter 5 in this field if there are only four levels within the set hierarchy.

        – The Conditional field implements an "intelligent" vertical page break facility. The system checks if there is enough room on a page for the next level of columns before inserting
Entering Characteristic Information for a Column Block

an automatic page break after a specified level. The default (blank) is no intelligent page breaks.

Values are the same as for the Unconditional field.

You can use the Conditional field:

a) If you want all of the months in a quarter to appear on one page.

b) If there is enough room on the current page for all of the months in a quarter; the months should print on the same page.

The system only starts a new page for the next group of months in a quarter if the group does not fit on the same page.

11. Enter data in the Totals display group box as required:

The Totals display fields allow you to enter a number range of levels and then:

- Place characters to the left and/or right of a column
- Insert additional blank columns between levels

Use the From level field to select a beginning level number for the Left border and Right border fields (explained later in this section). Valid values are the same as the Unconditional field.

Use the To level field to select an ending level number for the Left border and Right border fields (explained later in this section). Valid values are the same as the Unconditional field.

Set the Left border indicators depending on how you want the left border for the column characterist totals to appear. You can define the left border so that no left border appears, a single line appears, or a user-defined character is used for the border.

Set the Right border indicators depending on how you want the right border for the column characteristic totals to appear. You can define the right border so that no right border appears, a single line appears, or a user-defined character is used for the border.

12. If you want to enter additional level information for displaying column totals, choose Additional.

A dialog box appears, displaying the Totals display fields for the additional level.

13. If there are additional characteristics to define for the column set, select the Next characteristic button.


You return to the Create Report: Columns screen.
Formula Variables in Reports

A formula variable represents a user-defined formula, which determines a value for the variable. In contrast to a value variable, the default value for a formula variable is not fixed. When you execute a report that uses formula variables, the system calculates values for the formula variables automatically (for example, using the system date or other variables).

- The Report Writer only generates input fields for **independent** variables on the report selection screen when you execute the report’s report group. An independent variable does not depend on the value of another variable. You should define your variables so that you only have to enter independent values on the report selection screen.

  For example, your report displays data for the current year and the previous year. If you create two independent variables for the current and previous year, you have to enter both years on the selection screen when you output the report. If you define the variable for the previous year as a formula variable, which derives its value from the current year variable, you only have to enter the current year on the selection screen.

- You do not have to use independent variables in the actual report definition. If a report only uses dependent variables, the Report Writer determines the values of the independent variables and creates input fields for these variables on the report selection screen.

For more information on creating formula variables, see Creating Formula Variables [Seite 695].

Using formula variables, you can create several new types of reports. The following examples illustrate how you can use formula variables in your reports.

**Example 1: Rolling Periods**

See the example report **0R-FOVAR** (library **0R1**) delivered with the **Special Purpose Ledger** (FI-SL) application component.

This report uses formula variables to create report columns containing twelve periods. When you enter the reporting period and the reporting year during report execution, the system outputs data for the reporting period and the previous eleven periods.

To define the example report with rolling periods, you need to create twelve formula variables for the twelve periods, and twelve formula variables for the corresponding fiscal year. You should create the variables in the order listed in the table below.

You create a key figure for each pair of variables when you create a Report Writer report. (You must first create basic and multidimension sets that contain the formula variables.) Alternatively, you can enter the variables directly in the report definition if you are creating a Report Painter report.

**Formula Variables Used in the Example Rolling Periods Report**

<table>
<thead>
<tr>
<th>Period variable</th>
<th>Formula</th>
<th>Year variable</th>
<th>Formula</th>
</tr>
</thead>
</table>

April 2001
## Formula Variables in Reports

<table>
<thead>
<tr>
<th>Column</th>
<th>&amp;0R-RP00</th>
<th>‘#S002’</th>
<th>&amp;0R-RY00</th>
<th>‘#S001’</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 12</td>
<td>&amp;0R-RP01</td>
<td>IF ‘OR-RP00’ &gt; 1 THEN ‘OR-RP05’ – 1 ELSE 12</td>
<td>&amp;0R-RY01</td>
<td>IF ‘OR-RP01’ &lt; ‘OR-RP00’ THEN ‘OR-RY01’ ELSE ‘OR-RY00’ – 1</td>
</tr>
<tr>
<td>Column 11</td>
<td>&amp;0R-RP02</td>
<td>IF ‘OR-RP01’ &gt; 1 THEN ‘OR-RP01’ – 1 ELSE 12</td>
<td>&amp;0R-RY02</td>
<td>IF ‘OR-RP02’ &lt; ‘OR-RP01’ THEN ‘OR-RY02’ ELSE ‘OR-RY01’ – 1</td>
</tr>
<tr>
<td>Column 10</td>
<td>&amp;0R-RP03</td>
<td>IF ‘OR-RP02’ &gt; 1 THEN ‘OR-RP02’ – 1 ELSE 12</td>
<td>&amp;0R-RY03</td>
<td>IF ‘OR-RP03’ &lt; ‘OR-RP02’ THEN ‘OR-RY03’ ELSE ‘OR-RY02’ – 1</td>
</tr>
<tr>
<td>Column 9</td>
<td>&amp;0R-RP04</td>
<td>IF ‘OR-RP03’ &gt; 1 THEN ‘OR-RP03’ – 1 ELSE 12</td>
<td>&amp;0R-RY04</td>
<td>IF ‘OR-RP04’ &lt; ‘OR-RP03’ THEN ‘OR-RY04’ ELSE ‘OR-RY03’ – 1</td>
</tr>
<tr>
<td>Column 8</td>
<td>&amp;0R-RP05</td>
<td>IF ‘OR-RP04’ &gt; 1 THEN ‘OR-RP04’ – 1 ELSE 12</td>
<td>&amp;0R-RY05</td>
<td>IF ‘OR-RP05’ &lt; ‘OR-RP04’ THEN ‘OR-RY05’ ELSE ‘OR-RY04’ – 1</td>
</tr>
<tr>
<td>Column 7</td>
<td>&amp;0R-RP06</td>
<td>IF ‘OR-RP05’ &gt; 1 THEN ‘OR-RP05’ – 1 ELSE 12</td>
<td>&amp;0R-RY06</td>
<td>IF ‘OR-RP06’ &lt; ‘OR-RP05’ THEN ‘OR-RY06’ ELSE ‘OR-RY05’ – 1</td>
</tr>
<tr>
<td>Column 6</td>
<td>&amp;0R-RP07</td>
<td>IF ‘OR-RP06’ &gt; 1 THEN ‘OR-RP06’ – 1 ELSE 12</td>
<td>&amp;0R-RY07</td>
<td>IF ‘OR-RP07’ &lt; ‘OR-RP06’ THEN ‘OR-RY07’ ELSE ‘OR-RY06’ – 1</td>
</tr>
<tr>
<td>Column 5</td>
<td>&amp;0R-RP08</td>
<td>IF ‘OR-RP07’ &gt; 1 THEN ‘OR-RP07’ – 1 ELSE 12</td>
<td>&amp;0R-RY08</td>
<td>IF ‘OR-RP08’ &lt; ‘OR-RP07’ THEN ‘OR-RY08’ ELSE ‘OR-RY07’ – 1</td>
</tr>
<tr>
<td>Column 4</td>
<td>&amp;0R-RP09</td>
<td>IF ‘OR-RP08’ &gt; 1 THEN ‘OR-RP08’ – 1 ELSE 12</td>
<td>&amp;0R-RY09</td>
<td>IF ‘OR-RP09’ &lt; ‘OR-RP08’ THEN ‘OR-RY09’ ELSE ‘OR-RY08’ – 1</td>
</tr>
<tr>
<td>Column 3</td>
<td>&amp;0R-RP10</td>
<td>IF ‘OR-RP09’ &gt; 1 THEN ‘OR-RP09’ – 1 ELSE 12</td>
<td>&amp;0R-RY10</td>
<td>IF ‘OR-RP10’ &lt; ‘OR-RP09’ THEN ‘OR-RY10’ ELSE ‘OR-RY09’ – 1</td>
</tr>
<tr>
<td>Column 2</td>
<td>&amp;0R-RP11</td>
<td>IF ‘OR-RP10’ &gt; 1 THEN ‘OR-RP10’ – 1 ELSE 12</td>
<td>&amp;0R-RY11</td>
<td>IF ‘OR-RP11’ &lt; ‘OR-RP10’ THEN ‘OR-RY10’ ELSE ‘OR-RY10’ – 1</td>
</tr>
</tbody>
</table>

The formula variables &0R-RP00 (period of the last column) and &0R-RY00 (fiscal year of the last column) are the only independent variables in the report columns. Each pair of variables calculates the period and fiscal year of the preceding period. The year changes when the system calculates the preceding periods based on period one.

### Example 2: Displaying Periods of Quarter q

This example report displays three columns for the periods of quarter q.
To define the report columns, you must first create the value variable &QUARTER for the characteristic Period. You enter quarter as the variable description. This variable is the independent variable. You then need to create three formula variables (listed in the table below) for the three periods in the quarter.

**Formula Variables Used to Calculate the Periods in Quarter q**

<table>
<thead>
<tr>
<th>Period variable</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 1 &amp;QPER1</td>
<td>‘QUARTER’ * 3 - 2</td>
</tr>
<tr>
<td>Column 2 &amp;QPER2</td>
<td>‘QUARTER’ * 3 - 1</td>
</tr>
<tr>
<td>Column 3 &amp;QPER3</td>
<td>‘QUARTER’ * 3</td>
</tr>
</tbody>
</table>

The above example assumes that the first quarter consists of periods one, two, and three. You enter the formula variables &QPER1, &QPER2 and &QPER3 in key figures if you are creating a Report Writer report. Alternatively, you can enter the variables directly in the column definition if you are creating a Report Painter report.

The independent variable &QUARTER is not used directly in the report; it is used indirectly via the formula variables. When you execute the report’s report group, the Report Writer creates the input field Quarter for the independent variable &QUARTER. You can then enter quarter one, two, three, or four to output your report for the respective quarter.

**Example 3: Displaying Periods of Quarter q Based on Period p**

This example report displays three columns for the periods of quarter q. Unlike the report in example two, you enter one period in the quarter and not the quarter itself on the report selection screen to determine the three period columns.

To define the report columns, you must first create the value variable &PERIOD for the characteristic Period. Enter Period as the variable name. This variable is the independent variable. You then need to create three formula variables (listed in the table below), which determine the three periods in the quarter.

- The DIV operator in the formulas denotes division without remainder (for example, 8 DIV 3 = 2).
- The system processes the formula enclosed in parentheses first to determine the quarter based on the period you enter on the report selection screen. It then processes the rest of the formula to calculate the periods in the first quarter.

**Formula Variables Used to Calculate the Periods of Quarter q Based on Period p**

<table>
<thead>
<tr>
<th>Period variable</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 1 &amp;QPER1</td>
<td>‘(‘PERIOD’ - 1) DIV 3 + 1) * 3 - 2</td>
</tr>
<tr>
<td>Column 2 &amp;QPER2</td>
<td>‘(‘PERIOD’ - 1) DIV 3 + 1) * 3 - 1</td>
</tr>
<tr>
<td>Column 3 &amp;QPER3</td>
<td>‘(‘PERIOD’ - 1) DIV 3 + 1) * 3</td>
</tr>
</tbody>
</table>
Formula Variables in Reports

The above example assumes that the first quarter consists of periods one, two, and three. The independent variable &PERIOD is not used directly in the report; it is used indirectly via the formula variables. When you execute the report’s report group, the Report Writer creates the input field Period for the independent variable &PERIOD. You can then enter period one, two or three to output your report for the periods in the first quarter.

Example 4: Displaying a Variable Number of Columns for Periods p1 to p12

This example report allows you to create a report containing a variable number of columns for periods one to twelve. It is not possible to define a variable number of columns directly in the report definition; you can do so, however, by creating a column block consisting of twelve columns, each represented by a formula variable.

The formula variables map the unwanted periods up to period 16. If data has been posted for period 16 in your system, you should use a different period that does not contain data (for example, period 17).

To define the report columns, you must first create the value variables &PER_FROM and &PER_TO for the characteristic Period. These variables are the independent variables. You must then create the formula variables (listed in the table below), which all refer to the independent period variables. Once you have created the formula variables, you must enter them in a basic set (created for the characteristic Period) if you are creating a Report Writer report. Alternatively, you can enter them directly in the column definition if you are creating a Report Painter report.

Formula Variables Used to Display a Variable Number of Report Columns

<table>
<thead>
<tr>
<th>Column</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 1</td>
<td>&amp;PER01 IF 1 &gt;= 'PER_FROM' AND 1 &lt;= 'PER_TO' THEN 1 ELSE 16</td>
</tr>
<tr>
<td>Column 2</td>
<td>&amp;PER02 IF 2 &gt;= 'PER_FROM' AND 2 &lt;= 'PER_TO' THEN 2 ELSE 16</td>
</tr>
<tr>
<td>Column 3</td>
<td>&amp;PER03 IF 3 &gt;= 'PER_FROM' AND 3 &lt;= 'PER_TO' THEN 3 ELSE 16</td>
</tr>
<tr>
<td>Column 4</td>
<td>&amp;PER04 IF 4 &gt;= 'PER_FROM' AND 4 &lt;= 'PER_TO' THEN 4 ELSE 16</td>
</tr>
<tr>
<td>Column 5</td>
<td>&amp;PER05 IF 5 &gt;= 'PER_FROM' AND 5 &lt;= 'PER_TO' THEN 5 ELSE 16</td>
</tr>
<tr>
<td>Column 6</td>
<td>&amp;PER06 IF 6 &gt;= 'PER_FROM' AND 6 &lt;= 'PER_TO' THEN 6 ELSE 16</td>
</tr>
<tr>
<td>Column 7</td>
<td>&amp;PER07 IF 7 &gt;= 'PER_FROM' AND 7 &lt;= 'PER_TO' THEN 7 ELSE 16</td>
</tr>
<tr>
<td>Column 8</td>
<td>&amp;PER08 IF 8 &gt;= 'PER_FROM' AND 8 &lt;= 'PER_TO' THEN 8 ELSE 16</td>
</tr>
<tr>
<td>Column 9</td>
<td>&amp;PER09 IF 9 &gt;= 'PER_FROM' AND 9 &lt;= 'PER_TO' THEN 9 ELSE 16</td>
</tr>
</tbody>
</table>
The Suppress zero columns indicator must be set in the standard layout assigned to the report, so that columns that do not contain any values are not displayed in the report output.

When you execute the report's report group, the Report Writer creates input fields for the independent variables &PER_FROM and &PER_TO, which determine the period range.

**Example 5: Calculating Defaults for a Non-Calendar Fiscal Year**

You can create formula variables that default to the current period and fiscal year taken from the system date. If you work with a non-calendar fiscal year, you can create formula variables that calculate the correct period and fiscal year using the current system date and period.

**Example Formula Variables to Calculate Defaults for a Non-Calendar Fiscal Year**

<table>
<thead>
<tr>
<th>Description</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calendar year from the system date</td>
<td>‘#S001’</td>
</tr>
<tr>
<td>Calendar month from the system date</td>
<td>‘#S002’</td>
</tr>
<tr>
<td>Non-calendar fiscal year calculated from the system date (the non-calendar fiscal year starts in July)</td>
<td>IF ‘#S002’ &gt; 6 THEN ‘#S001’ + 1 ELSE ‘#S001’</td>
</tr>
<tr>
<td>Period calculated from the system date (the non-calendar fiscal year starts in July)</td>
<td>IF ‘#S002’ &gt; 6 THEN ‘#S002’ − 6 ELSE ‘#002’ + 6</td>
</tr>
</tbody>
</table>
Defining Cells

Use

You use cells to perform mathematical operations within a report. A cell pinpoints a particular location or range within the column-row matrix of a report. Once the Report Writer has located a point/range (or coordinate), it can then use the cell in formulas. Report Writer cells are used much like the cell address or range in a spreadsheet program. However, since the Report Writer uses row/column blocks instead of physical rows and columns, cells are located using symbolic names stored in sets.

When you define a report that contains a cell used as an operand in a formula, you must define the coordinates of the cell (the row coordinate and the column coordinate). These coordinates tells the Report Writer which values to use to calculate totals in the report.

You define the coordinates of a cell using symbolic names. A **symbolic name** is a name assigned to a set line and/or to a set, which defines the row and column coordinates for a report cell. You can use a symbolic name to represent all of the values in a set (set header symbolic name) or to represent an individual set value (set line symbolic name). For more information on symbolic names, see [Symbolic Names in the Report Writer][1] [Seite 909].

Suppose you create the same report as in [Working with the Report Writer][2] [Seite 800] and then create an additional column (% of Total) that provides a percentage for each cost center of the total income and expense accounts. You create this column using a formula.

Cell A in the graphic below identifies the value **409,600.00**. The cell was assigned the symbolic names SN-HSL0 (column coordinate) and SN-KSTL (row coordinate). Symbolic name SN-HSL0 was assigned to the set line HSL-0 in the set TD-ACT-CELL; the symbolic name SN-CNTR was assigned to the entire set TD-RCNTR-12.

---

[1]: #Symbolic Names in the Report Writer
[2]: #Working with the Report Writer
The formula used in the above graphic is $100 \times '001' / 'A'. The value 001 refers to the set line 001 (containing the value HSL-0) in the data set TD-ACT-CELL (used in the report column).

"A" is the cell that must be defined before the Report Writer can perform the calculation. (For more information on defining formulas, see Formulas [Seite 686]). The Report Writer knows that it must multiply 100 by the actual local currency amount (HSL-0), but it does not know what it should divide the amount by.

Given the column coordinate SN-HSL0 and the row coordinate SN-CNTR, the system performed the calculation of the % of Total column as follows:

4. It read formula $100 \times '001' / 'A' from set TD-ACT-CELL, set line 002.
Defining Cells

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>'001'</td>
<td>HSL-0 (actual data in local currency)</td>
</tr>
<tr>
<td>'A'</td>
<td>Column coordinate SN-HSL0 (actual data in local currency)</td>
</tr>
<tr>
<td></td>
<td>Row coordinate SN-CNTR (all cost centers)</td>
</tr>
</tbody>
</table>

5. It multiplied the values for each report row by 100 and then divided the amount by the total amount (409,600.00).

6. It created a column listing the percentages of the individual rows.

A cell can only appear in a formula that is used as a column block. A cell **cannot** appear in a formula that is used as a row block. For more information about using formulas, see [Formulas][1] [Seite 686].

For more information on defining global cells, see [Defining Global Cells][2] [Seite 870].

**Procedure**

9. From the screen Create report or Change report, choose Goto → Cells.

   The Create Report: Cells screen appears.

   If there is more than one cell in a report, they are listed on this screen.

10. To define a cell in your report, position the cursor on the cell that you want to define and choose Edit → Choose cell.

   The Create Report: Define Cells screen appears.

   The following entries were made on the Create Report: Define Cells screen:
   - The column coordinate is the symbolic name SN-HSL0 (local currency column)
   - The row coordinate is the symbolic name SN-CNTR (for all cost centers in the report rows).

11. To select a symbolic name used as a column coordinates for the cell:
   a) Position the cursor on the Column coordinate - Coordinate field.
   b) Choose Define.

   A dialog box appears, listing the symbolic names that you can use as a column coordinate. You can choose from set header and set line symbolic names. A set header symbolic name is defined in a set header and the symbolic name applies to all values contained in the set. A set line symbolic name is defined in a set line and the symbolic name applies only to the value defined for the set line.
In the previous graphic, the set line symbolic name **SN-HSL0** is assigned as the column coordinate. **SN-HSL0** refers to set line 001 with the value HSL-0.

c) Select the symbolic name that you want to use as a column coordinate and choose *Choose*.

The symbolic name appears in the *Column coordinate* - *Coordinate* field.

12. To assign a specific level to the column symbolic name, enter a number in the *Level* field.

The level number determines at what set hierarchy level a value is used for the cell.

You can only assign level numbers for set header symbolic names (for an entire set). You cannot assign a level number for a set line symbolic name.

13. To select a symbolic name as a row coordinate for the cell:

a) Position the cursor on the *Row coordinate* - *Coord.* field.

b) Choose *Define*.

A dialog box appears, listing the symbolic names that you can use as a row coordinate. You can choose from set header and set line symbolic names. A set header symbolic name is defined in a set header and the symbolic name applies to all values contained in the set. A set line symbolic name is defined in a set line and the symbolic name applies only to the value defined for the set line.

In the previous graphic, the set header symbolic name **SN-CNTR** is assigned as the row coordinate. **SN-CNTR** refers to set TD-RCNTR-12 and all values contained in the set.

c) Select the symbolic name that you want to use as a row coordinate and choose *Choose*.

The symbolic name appears in the *Row coordinate* - *Coord.* field.

14. To assign a specific level to the row symbolic name, enter a number in the *Level* field.

The level number determines at what hierarchy level a value is used for the cell.

Valid values for this field are as follows:

1. Use values at the first level of a set characteristic for the cell.
2. Use values at the second level of a set characteristic for the cell.
   
   n. Use values at the nth level of the set characteristic for the cell.
1-. Use basic set values for the cell.
2-. Use the total for each basic set value for the cell.

   For this field, you can only use as many numeric values as there are levels within the set hierarchy. 1- and 2- are the only negative values possible.

   For example, you cannot enter 5 in this field if there are only four levels within the set hierarchy.
Defining Cells

You can only assign level numbers for set header symbolic names (for an entire set). You cannot assign a level number for a set line symbolic name.

In the report in the previous graphic, you may want to see the account percentages for each cost center total, instead of the account percentages for the total amount. The report in the following graphic shows the account percentages for each cost center.

To create the percentage column in the above graphic, you enter 2 in the Level field next to the row symbolic name SN-CNTR. Based on this entry, the system uses the totals at the second level of the basic set TD-RCNTR-12. The following table contains the formulas used to calculate the columns shown in the above report.

### Table for Producing Percentage Columns

<table>
<thead>
<tr>
<th>Column</th>
<th>Level</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>% of Total</td>
<td>1</td>
<td>(100 \times \frac{010'}{A}; A=409,600.00)</td>
</tr>
</tbody>
</table>
| % of Subtotal | 2   | For cost center 100: \(100 \times \frac{010'}{B}; B=209,600.00\)  
  For cost center 200: \(100 \times \frac{010'}{B}; B=200,000.00\) |

15. The additional functions available on this screen are shown in the following table.

### Additional Functions on Screen Create/Change Report: Define Cells
<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Choose coordinate</td>
<td>Define row or column coordinate for cell</td>
</tr>
<tr>
<td>Edit → Delete coordinate</td>
<td>Delete coordinate assigned to a cell</td>
</tr>
<tr>
<td>Goto → Layout → Reset layout</td>
<td>Reset all layout parameters to the default values of the standard layout</td>
</tr>
<tr>
<td>Extras → List of characteristics</td>
<td>Display a list of characteristics used in the report</td>
</tr>
<tr>
<td>Extras → Maintenance language</td>
<td>Switch to a new report language (for example, to enter language-specific text for the report description)</td>
</tr>
<tr>
<td>Extras → Threshold value</td>
<td>Enter threshold value condition to highlight in color or print report rows, depending on the values in a specific report column</td>
</tr>
<tr>
<td>Extras → Other std layout</td>
<td>Assign a new standard layout to the report</td>
</tr>
</tbody>
</table>

16. To save the cell information, choose Report → Save.

When the cell definition has been saved, the Def indicator is set on the Create Report: Cells screen.
Defining Global Cells

When you want to perform cell calculations over more than one row or column block, you use global cells. You define global cells by specifying the row and column block coordinate, which pins points an exact location in the report matrix.

When you define a report that contains a global cell, you define the coordinates of the cell using symbolic names. A symbolic name is a name assigned to a set line and/or set header, which defines the row and column coordinates for a report cell. A set header symbolic name represents all of the values in the set and a set line symbolic name represents an individual set value. (For more information on symbolic names, see Using Symbolic Names in the Report Writer [Seite 909].)

You can define global cells that reference report rows for which you have entered a formula and/or key figure block.

The procedure for defining global cells has therefore changed slightly to accommodate this new enhancement.

This procedure is the same as that used for entering key figure cells. For more information, see Defining Key Figure Cells in Defining Key Figures [Seite 875].

You create a report that displays the actual personnel costs that have been incurred in a specific department (for example, the marketing department) and the actual number of employees in the department. You then define a global cell to create an additional column that displays personnel costs per employee (see the graphic below).

<table>
<thead>
<tr>
<th>Personnel Costs</th>
<th>Actual Costs</th>
<th>Costs / Employee</th>
</tr>
</thead>
<tbody>
<tr>
<td>Direct labor costs</td>
<td>1,234.00</td>
<td>308.50</td>
</tr>
<tr>
<td>Labor costs</td>
<td>1,234.00</td>
<td>308.50</td>
</tr>
<tr>
<td>Salaries</td>
<td>1,000.00</td>
<td>250.00</td>
</tr>
<tr>
<td>Salary costs</td>
<td>1,000.00</td>
<td>250.00</td>
</tr>
<tr>
<td>Personnel costs</td>
<td>2,234.00</td>
<td>558.50</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Employees</th>
<th>Actual</th>
</tr>
</thead>
<tbody>
<tr>
<td>EMPLOY</td>
<td>4</td>
</tr>
</tbody>
</table>
The following graphic illustrates the row block, column block, and global cell definitions used to create the above example report. The example report is defined for table CCSS.

The global cell ‘EMPL’ points to the value 4 (see the above graphic). The symbolic names EMPLOYEE (row coordinate) and ACTQTY (column coordinate) are assigned to the cell. Symbolic name EMPLOYEE is assigned to the set line EMPLOY in the set EMPLOYEES (row block two); the symbolic name ACTQTY is assigned to the set line ISSME in the set COL-QTY (column block two).

The formula used in the above graphic is ‘001’ / ‘EMPL’ (column block one). ‘001’ refers to the set line 001 (containing the value ISWKG (actual costs)) in the data set COL-COSTS.

The global cell ‘EMPL’ must be defined before the Report Writer can perform the calculation. (For more information on defining formulas in cells, see Formulas [Seite 686]).

Using the row coordinate EMPLOYEE and the column coordinate ACTQTY, the Report Writer performs the calculation of the Costs/Employee column as follows:

4. It reads formula ‘001’ / ‘EMPL’ from set COL-COSTS, set line 002:
   - ‘001’ = ISWKG (actual costs)
   - ‘EMPL’ = Row coordinate EMPLOYEE (number of employees)
   Column coordinate ACTQTY (actual quantity)

5. It divides the actual costs for each report row by the total number of employees (4).

6. It creates an additional report column listing the costs per employee.

Since no data records would be displayed in the report for the combinations personnel costs/actual quantity and number of employees/actual costs, you must inactivate these row/column combinations to produce the report illustrated in the first graphic of this section.
Defining Global Cells

To create the above example report, you define the report as follows:

9. Create the sets to be used in the row and column block definitions (if they do not already exist in your system).

   The following sets are used in the above report:

<table>
<thead>
<tr>
<th>Report rows:</th>
<th>Report columns:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single-dimension set <code>0HBAB-PERSON</code> for the characteristic <code>KSTAR</code> (cost element), containing personnel costs</td>
<td>Data set <code>COL-QTY</code>, containing the predefined column <code>ISSME</code> (actual quantity) in line 001. The symbolic name <code>ACTQTY</code> is assigned to set line 001 (for the predefined column called actual quantity).</td>
</tr>
<tr>
<td>Basic set <code>EMPLOYEES</code>, containing the statistical key figure <code>EMPLOY</code> (number of employees). The symbolic name <code>EMPLOYEE</code> is assigned to set line 001 (for the statistical key figure <code>EMPLOY</code>).</td>
<td>Data set <code>COL-QTY</code>, containing the predefined column <code>ISSME</code> (actual quantity) in line 001. The symbolic name <code>ACTQTY</code> is assigned to set line 001 (for the predefined column called actual quantity).</td>
</tr>
</tbody>
</table>

10. Define the report rows.

    To define a row block from any Create Report screen:

    a) Choose Goto → Rows.

       The Create Report: Row Overview screen appears.

    b) Enter the following information:

       – Set `0HBAB-PERSON` as row block one

       – Set `EMPLOYEES` as row block two

11. Define the report columns.

    To define a column block from any Create Report screen:

    a) Choose Goto → Columns.

       The Create Report: Columns screen appears.

    b) Enter the following information:

       – Set `COL-COSTS` as column block one

       – Set `COL-QTY` as column block two

12. Define the global cell used in the formula `‘001’ / ′EMPL’` in line 002 of set `COL-COSTS`.

    To define the global cell from the Create Report: Columns screen:

    a) Choose Goto → Cells.

       The Create Report: Cells <report name> screen appears.

    b) The cell name `EMPL` is automatically displayed in the Cell field.

       Select Global to define cell `EMPL` as a global cell.
Defining Global Cells

If you don’t set the Global indicator, the cell you define is a normal cell (also called a local cell). The coordinates in a local cell can only reference one characteristic in the current row and column block. A local cell is only valid within one row/column block.

c) Choose Edit → Choose cell.

The Definition of Cell Empl dialog box appears.

d) In the Block number field, you enter the number of the row block for which you want to enter the row coordinate of the global cell. Enter 2 in this field. The system then recognizes that the cell is located somewhere in row block 2.

e) Choose Continue.

The Definition of Cell Empl dialog box appears. On this screen, you define the row and column coordinates for cell EMPL.

f) To select the symbolic name used as the row coordinate for the cell:
   – Check that the row block number in the Row - Block number field is correct. The number you entered in the previous dialog box (in this case, 2) appears as the default value.
   – Choose Define row coordinates.

   The symbolic name EMPLOYEE from set EMPLOYEES is displayed in the Coord. field, pinpointing the exact row coordinate of the cell.

   If more than one symbolic name has been defined in the set(s) used in the row block, a dialog box appears, listing the symbolic names that you can use as the row coordinate. You can then select the symbolic name that you want to use as the row coordinate in the cell.

g) To select the symbolic name used as the row coordinate for the cell:
   – Enter 2 in the Column - Block number field. The system then recognizes that the column coordinate of the cell is located somewhere in column block 2.
   – Choose Define column coordinates.

   The symbolic name ACTQTY from set COL-QTY is displayed in the Coord. field, pinpointing the exact column coordinate of the cell.

   If more than one symbolic name has been defined in the set(s) used in the column block, a dialog box appears listing the symbolic names that you can use as the column coordinate. You can then select the symbolic name that you want to use as the column coordinate in the cell.

h) Choose Continue.

   The Def indicator is set, showing that the cell is now defined.

13. Deactivate the following row/column block combinations:
   – Personnel costs (row block one)/actual quantity (column block two)
Defining Global Cells

- **Number of employees (row block two)/actual costs (column block one)**
  
  For more information on deactivating row/column block combinations, see [Deactivating Columns for a Row Block](#) [Seite 845].

14. On this screen you can use the additional processing functions in the table for the screen *Create Report: Initial Screen*, as well as the functions in the table in [Defining Cells](#) [Seite 864].

15. To define general data selection criteria for the report on the screen *Create Report: General Data Selection*, choose *Goto → General data selection*.

16. To save the report definition, choose *Report → Save*.

When you execute the report’s report group and output the report, it displays the additional report column *Costs/Employee*, showing the actual personnel costs per employee (see the first graphic in this section).
Defining Key Figures

Within the Report Writer, a key figure is an extension of the cell concept. A key figure performs various cell calculations within a report, such as subtracting subtotals within a column. The key figure pinpoints particular locations of a key figure block within the column-row matrices of a report.

The following graphic is an example of a key figure in a report.

<table>
<thead>
<tr>
<th>08.09.1995 Assets/Liabilities</th>
<th>Local/Actual</th>
</tr>
</thead>
<tbody>
<tr>
<td>100010 Bank Accounts</td>
<td>750,000.00</td>
</tr>
<tr>
<td>100020 Accounts Receivable</td>
<td>400,000.00</td>
</tr>
<tr>
<td>100030 Merchandise Inventory</td>
<td>600,000.00</td>
</tr>
<tr>
<td>100040 Property</td>
<td>150,000.00</td>
</tr>
<tr>
<td>100050 Investments</td>
<td>370,000.00</td>
</tr>
<tr>
<td>* Asset Accounts</td>
<td>2,270,000.00</td>
</tr>
<tr>
<td>200010 Accounts Payable</td>
<td>650,000.00</td>
</tr>
<tr>
<td>200020 Notes Payable</td>
<td>350,000.00</td>
</tr>
<tr>
<td>200030 Common Stock</td>
<td>270,000.00</td>
</tr>
<tr>
<td>200040 Long-Term Liabilities</td>
<td>800,000.00</td>
</tr>
<tr>
<td>200050 Retained Earnings</td>
<td>200,000.00</td>
</tr>
<tr>
<td>* Liability Accounts</td>
<td>2,270,000.00</td>
</tr>
</tbody>
</table>
** Assets/Liabilities          |
Current Key Figure             | 1995         |
Current Key Figure             | 1.00         |

In the above graphic, the current key figure (current assets/current liabilities) for 1995 is displayed in the lower portion of the balance sheet report. You can define this key figure using a formula whose operands are cells. These cells are addressed through the symbolic names contained in the row and column sets of the report.

To define the example key figure in the above graphic, you perform the following steps:

9. Define key figure text.
   You define key figure text for the following objects:
   - Key figure block
     A key figure block is a matrix of key figures and lists all key figures that you want to use in the report. You can define a key figure block that contains one or more key figures.
   - Key figure row(s)
     You define this text for the key figure row(s) of your key figure block. The text appears in the report row(s) of the key figure block. For each row you enter, the system creates a row for the current key figure block. The text you enter appears in the report row for the key figure result.
Defining Key Figures

- Key figure column(s)

You define this text for the key figure column(s) of your key figure block. This text appears in the report column(s) of your key figure block. For each row you enter, the system creates a column for the current key figure block.

For the report in the above graphic, the key figure block text is Current Key Figure, the row text is also Current Key Figure, and the column text is 1995.

10. Define the key figure formula.

For each key figure row/column intersection that you define for your key figure block, you define a key figure formula that calculates the amount that should appear for the row/column intersection.

For the report in the above graphic, you would have to define a key figure formula for the row Current Key Figure and column 1995.

To calculate the key figure in the above graphic, the Report Writer uses set symbolic names to identify the current assets total (CA) and the current liabilities total (CL). It then divides the current assets by the current liabilities and displays them in the report (as defined in the report row definition). The key figure formula is CA/CL.

11. Define the cells for the key figure.

You need to define each cell (row/column coordinate) that you use in a key figure formula.

The key figure formula for the report in the above graphic contains the cells CA (Current Assets) and CL (Current Liabilities). In this key figure, the current assets (cell name CA) are divided by the current liabilities (cell name CL).

- **Cell A**: The row coordinate is the symbolic name ASSETS (total of the assets in single-dimension set TD-RACCT-GBS) and the column coordinate is the symbolic name TD-HSL0 (total of local currency in data set TD-ACT-HSL).

- **Cell B**: The row coordinate is the symbolic name LIABILIT (total of the liabilities in single-dimension set TD-RACCT-GBS) and the column coordinate is the symbolic name TD-HSL0 (total of local currency in data set TD-ACT-HSL).

You can also define key figure cells that refer to report rows for which you have entered a formula and/or key figure block.

12. Insert the key figure in a row block of the report.

Once you have defined the key figure, you insert the key figure block in a row block of the report.

To define a key figure block from any Create Report screen:
31. Choose Goto → Key figures.
    The Create Report: Key Figure Blocks screen appears.

**Entering Text for Key Figures**

32. In the Name field, enter a description for the key figure block that you want to define.

33. Choose Edit → Rows.
    The Rows from <key figure block name> screen appears.

34. Enter the necessary data and choose Continue:
   - Enter the code that represents the character you want to appear before the key figure row (B field).
   - Enter the code that represents the character you want to appear after the key figure row (A field).
   - Set the H indicator if you want to highlight the key figure row.
   - Enter the code for the color in which you want the key figure row to be displayed (C field).
   - Specify whether you want to insert a page break or blank lines between the individual logical rows in a key figure block.
   - Enter the text that you want to appear for the key figure row. The text you enter appears in the row for the key figure block.

35. Choose Edit → Columns.
    The Columns from <key figure block name> screen appears.

36. Enter the following data as required and choose Continue:
   - The print class that you want to use for the key figure column.
   - Specify whether you want to insert a page break or blank lines between the individual logical columns in a key figure block.
   - Enter the text that you want to appear for the key figure column. The text that you enter appears in the column for the key figure block.

**Entering Formulas for Key Figures**

37. Choose Edit → Formulas.
    The Formulas from <key figure block name> screen appears. For each key figure that you use in a report, you must define the formula used to create the key figure.

38. Position the cursor where the key figure amount should appear, and choose Formula.
    A dialog box appears.

39. Enter a formula in the dialog box. This formula must describe a key figure that you want to use in your report. Choose Continue.

If you define a key figure formula, use the mathematical operations contained in the table in Using Set Formulas in the Report Writer [Seite 906]. You can enter as many cell names as necessary to calculate your key figure.
Defining Key Figures

The key figure appears at the intersection of the key figure row and column text on the Formulas from <Key Figure Block Name> screen.

When you defined cells, you entered apostrophes around the name of the cell. You must also enter apostrophes when defining cells for key figures.

40. To exit the Formulas from <Key Figure Block Name> screen, choose Continue.

Defining Cells for Key Figures

41. Choose Edit → List of cells.

The List of All Cells screen appears.

When a cell has been defined, the Def indicator is set. The No. uses field displays how many times the cell is used in report key figures or column formulas.

You define key figure cells in a similar way to defining report cells. A cell pinpoints a particular location within a report. Once the Report Writer has located a point, it can then use the corresponding value (amount) for the key figure formula.

You define the coordinates of a cell using symbolic names. A symbolic name is a name assigned to a set line or to a set header, which defines the row and column coordinates for a report cell. You can use a symbolic name to represent all of the values in a set or to represent an individual set value.

For more information on symbolic names, see Using Symbolic Names in the Report Writer [Seite 909].

You can also define key figure cells that refer to report rows for which you have entered a formula and/or key figure block.

Example:

Your report contains the following rows:

- Income Accounts (row block 1)
- Expense Accounts (row block 2)
- Sum of the Income and Expense Accounts (row block 3)

This sum is calculated with the formula ‘001’ + ‘002’

You can now define a cell in a key figure block that references the sum of the income and expense accounts (the formula entered in row 3 of your report definition).

The procedure for defining key figure cells has therefore changed slightly to accommodate this new enhancement.

42. Position your cursor on the first cell you want to define, and choose Define cell.

The Definition of Cell <Cell Name> dialog box appears. In the Block number field, enter the number of the row block for which you want to enter the row coordinate of the cell.

43. Choose Continue.
The dialog box that appears depends on the type of row block you entered in the Block number field in the previous dialog box.

If the row block is a Set row block:
The Definition of Cell <Cell Name> dialog box appears.
On this screen, you define the row and column coordinates for the cell.
To select a symbolic name used as a row coordinate for the cell:

a) Check the row block number in the Row - Block number field. The row block number you entered in the previous dialog box appears as the default value. You can choose a different row block for the row coordinate by choosing Other row block next to the field.

b) Choose Define row coordinates.
A dialog box appears, listing the symbolic names that you can use as a row coordinate.

c) Select the symbolic name that you want to use as a row coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

To select a symbolic name as a column coordinate for the cell:

a) In the Block number field, enter a block number.

b) Choose Define column coordinates.
A dialog box appears, listing the symbolic names that you can use as a column coordinate.

c) Select the symbolic name that you want to use as a column coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

If the row block is a Formula row block:
The Definition of Cell <Cell Name> dialog box appears.
On this screen, you define the column coordinate of the cell. The row coordinate is already determined from the row block number you entered in the previous dialog box because a formula row only comprises one report row.

To select a symbolic name used as the column coordinate of the cell:

a) In the Block number field, enter a block number.

b) Choose Define column coordinates.
A dialog box appears, listing the symbolic names that you can use as a column coordinate.

c) Select the symbolic name that you want to use as a column coordinate and choose Choose.

The symbolic name appears in the Coord. field and the set name in which the symbolic name is defined appears in the Set ID field.

If the row block is a Key figure row block:
Defining Key Figures

The Definition of Cell <Cell Name> dialog box appears.

On this screen, you define the row and column coordinates for the key figure block.

a) Enter the row number of the key figure block.

b) Enter the column number of the key figure block.

If you want to define a key figure cell that refers to a key figure block, you must first insert the key figure as a row block in the row definition of your report.

For more information, see the following subsection Inserting Key Figures in Row Blocks.

44. Define additional key figure cells.

Refer to steps 12-13 for more information.

45. On this screen, you can use the additional processing functions in the table Create Report: Initial Screen as well as the functions in the following table.

Additional Processing Functions (Create Report: Key Figure Blocks)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Rows</td>
<td>Define text for the key figure rows</td>
</tr>
<tr>
<td>Edit → Columns</td>
<td>Define text for the key figure columns</td>
</tr>
<tr>
<td>Edit → Formulas</td>
<td>Define key figure formulas</td>
</tr>
<tr>
<td>Edit → List of cells</td>
<td>Define key figure cells</td>
</tr>
<tr>
<td>Edit → Insert block</td>
<td>Insert a key figure block</td>
</tr>
<tr>
<td>Edit → Delete block</td>
<td>Delete a key figure block</td>
</tr>
<tr>
<td>Goto → Report layout → Use standard layout</td>
<td>Reset layout parameters to default values of</td>
</tr>
<tr>
<td></td>
<td>standard layout</td>
</tr>
<tr>
<td>Extras → List of characteristics</td>
<td>Display a list of characteristics that are</td>
</tr>
<tr>
<td></td>
<td>used (or can be used) in the report</td>
</tr>
<tr>
<td>Extras → Maintenance language</td>
<td>Switch to a new report language (for example,</td>
</tr>
<tr>
<td></td>
<td>to enter text for the report description in</td>
</tr>
<tr>
<td></td>
<td>another language).</td>
</tr>
<tr>
<td>Extras → Other std layout</td>
<td>Assign new standard layout to the report</td>
</tr>
<tr>
<td>Extras → Threshold value</td>
<td>Enter threshold value condition to highlight</td>
</tr>
<tr>
<td></td>
<td>in color or print report rows, depending on</td>
</tr>
<tr>
<td></td>
<td>the values in a specific report column</td>
</tr>
</tbody>
</table>

Inserting Key Figures in Row Blocks

To use the key figure in the report, you must insert the key figure into a report row:
   The Create Report: Rows screen appears.

10. Position the cursor on the row block in which you want the key figure to appear.

11. Choose Edit → Insert key figures.
   A list of defined key figures appears in a dialog box. If only one key figure is defined for
   the report, it automatically appears on the Create Report: Rows screen.

12. Select a key figure and choose Choose.
   The selected key figure appears on the Create Report: Rows screen.
Defining Report Documentation

7. From any Create Report screen, choose Goto → Documentation.
   

8. Enter the report documentation as desired.
   
   For more information about the use of the SAPscript editor for word processing, see the 
   SAP Library under Basis Components → Basis Services/Communication Interfaces (BC-SRV) → SAPscript (BC-SRV-SCR).

9. Choose Text → Save.
   
   You will now be able to display the report documentation when you output the report. 
   The name under which the documentation is stored is also displayed.

   The name of your report library is Z01, and your report name is Z-REPO. When you define report documentation, it is stored under the report name R_Z01_Z-REPO, 
   where R is for report, Z01 is the library name, and Z-REPO is the report name.
Extracts

Use

To reduce the necessary runtime for formatting report data, you can create an extract when you execute a report. An extract is a dataset that contains the report data selected at the time the extract was created.

Extracts provide the same navigation and formatting options as reports selected directly from the database.

The main differences between an extract and a report are shown in the following table:

<table>
<thead>
<tr>
<th>Main Differences Between Report and Extract</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report (Newly Selected)</td>
</tr>
<tr>
<td>Currentness of data</td>
</tr>
<tr>
<td>Authorization check</td>
</tr>
<tr>
<td>Runtime</td>
</tr>
</tbody>
</table>

Aside from these differences, extracts offer full report functionality. When you call up a report that uses an extract, the system does not have to select the report data directly from the database. As a result, processing time improves considerably.

⚠️ If you create an extract and then make changes to the data structure in Customizing, this can result in inconsistencies between the current data structure and the structure in the extract. The data of the extract can therefore no longer be displayed.

⚠️ After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Integration

The final step in defining a report group [Seite 937] is executing the report group. You generate an extract when you execute the report with reference to the selection parameters entered at the time the report is executed. You can therefore create multiple extracts of the same report by entering different selection criteria each time.

If you called up the report using an extract, the system outputs the report using the extract data.

If you called up your report by selecting data from the database, the system outputs the report according to the selection criteria you specified and formats the report according to the report definition.

For more information, see Executing a Report Group [Seite 964].
Extraction

Features

In expert mode [SAP SE 978], you can create extracts on the selection screen (for more information, see General Data Selection [SAP SE 762]) if you execute a report group and choose the button Extract parameters... and then the mode Create extract. Alternatively, you can save your report output as an extract when you exit the report. In this case, the system displays a dialog box, asking whether you want to save the report in an extract file.

If you call up a report when Display extract is selected as the data source, the system checks whether any extracts are available that match the selection criteria. You can then choose from among the available extracts. You can also search for, display, and print extracts using extract management. In both cases, direct access is possible to all extracts generated within a variation.

Extraction are deleted either manually in extract management or automatically based on an expiration date that you can specify when you create the extract.

Once an extract has been deleted, it cannot be retrieved.

For more information, see Creating an Extract [SAP SE 1010] and Managing Extracts [Extern].
Create Extract

Use
There are two different ways of creating an extract [Seite 1008]:

- You can create extracts on the selection by choosing Extract Parameters and then choosing Create Extract in the dialog box.
- You can generate an extract when executing a report. To do this, follow the steps under Procedure.

You can only create extracts in expert mode [Seite 978]. Make sure that expert mode has been activated. You can make these settings from the selection screen by choosing Environment → Options.

Procedure


14. Enter the required report group and choose .

15. Enter the required selection parameters and choose .

If extracts already exist for the selection criteria you have specified, the system will display a list of extracts that you can choose.

8. The report is now displayed. Choose Report → Save. In the Enter: Extract Parameters dialog box, you can define the parameters for your extract. For further information about extract parameters, see Expert Mode [Seite 978]. To complete your entries, choose .
Managing Extracts

Use
When you save reports in extracts, you can then access the data at any time without having to select the data from the database.

You can use extract management to:

• Display extracts
• Print extracts
• Change the extract priority
• Change the expiration date of an extract
• Delete extracts

After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Prerequisites
You have saved your reports in extract files. For more information, see Creating an Extract [Seite 1010].

Procedure
5. On any Create/Change/Display/Execute Report Group screen, choose Utilities → Extracts → Display or Delete or Print or Change expiry date, depending on the function you want to use.


   You can also access extract management from the screen Execute Report Group: Initial Screen using the button Data extracts when you execute a report group from the first selection screen with Environment → Extract directory...

6. Enter the criteria according to which the extracts should be selected:

   • If you are searching for a particular extract, enter the description of the extract.
   • Specify whether extracts should be displayed that were generated by your or by a particular user, or whether all extracts should be displayed regardless of the user.
   • Specify when the extracts were generated, or whether all extracts should be generated regardless of the date.
   • You can select the extracts of a particular report group [Seite 937] or report group range.
   • You can select the extracts according to their priority, and restrict the selection to unread extracts.
Managing Extracts

- If you want to further restrict the selection criteria (for example, according to a specific characteristic or group of characteristics), choose Additional selections and enter the criteria. You can expand the number of selection conditions as required, and delete selection conditions you entered.

7. Choose.

The system displays a list of extracts that meet the selection criteria you entered.

8. Select the desired extract and choose one of the following functions:

i. Display extract

Choose.

j. Print extract

You can print extracts immediately or in the background.

- To print the selected extracts, choose Extracts and enter the output device and other parameters for print control.

- To print in the background, choose Background and specify when the job should be started.

o. Change the extract priority

Choose and change the priority of the extract.

p. Change expiration date

You can change the expiration date that was specified when the extract was created.

Choose. If you want the extract to be deleted automatically after a specified time, enter the number of days in the dialog box Change expiration date under Expires in or choose Expires on and enter an expiration date.

If you don’t want the extract to be deleted after a specified time, choose No expiration date. This is appropriate when the report is required for an undeterminable length of time or the report takes a long time to execute.

Choose to exit the dialog box and save your entries.

q. Delete extract

Once an extract has been deleted, it cannot be retrieved.

Choose to delete extracts. If you answer the question whether the selected extracts should be deleted with Yes, the extracts are deleted.

For information on settings for extract management, see the Implementation Guide for Cost Center Accounting under Information System → User Settings → Specify Settings for Extract Management.
Example Process: Report Callup with Extract Management

Purpose

At the end of each month, the reports (important to cost center managers in the entire organization) are executed, and the data is stored in extracts [Extern]. Reports that contain data for individual cost centers [Extern] or cost center groups [Extern] are executed using variation, so that a separate report can be created for each cost center and cost center group.

You can set the user parameters for your cost center managers so that they can automatically access the most current extracts.

When calling up a report from the report tree, each manager receives the relevant individual data. The manager does not need to select the data from the database again, which reduces the workload of the system.

The cost center manager cannot navigate to areas within the extracts that do not belong to the authorized CO-OM responsibility area.

The system administrator who sets up these reports needs to have authorization to select the data from the database. However, this does not authorize the administrator to display the data in those reports.

The cost center managers need authorization to display the reports for their CO-OM responsibility area. However, this does not entitle them to select the data from the database or to create extracts.

The following graphic displays the way in which a report is executed in extracts, in the background with the variation. It also shows how you can save it in extracts.
Process Flow

17. Initial setups include creating the authorizations for system administrators and cost center managers [Extern].

18. The system administrator arranges for all the reports to be accessible to all users in EUROs. The system administrators execute the report (such as the Cost Centers: Actual/Plan Variance report) in the background and with the variation, and save the report in extracts (see: Executing a Cost Center Report with Variation and Saving it in Extracts [Extern]).

19. The system administrator makes the settings for extract management for the cost center managers in Customizing (see: Specifying Settings for Extract Management [Extern]). In their user-specific settings, the cost center managers save their selection criteria for the reports they want to display (see Customizing for Controlling under Cost Center Accounting → Information System → User Settings → Specify User Settings [Extern]).

20. The cost center manager accesses the report (see: Calling Up Cost Center Reports [Extern]).

This procedure is shown in more detail in the following sections using the Cost Centers: Actual/Plan/Variance report.

Result

Each cost center manager can quickly and easily display the relevant reports required.
Example Process: Report Callup with Extract Management
Sets in the Report Writer

Use

The Report Writer uses sets to structure and select report data. Report structure and contents are defined according to the sets that are used for rows, columns, and selection criteria. These sets include basic, key figure, single-dimension, and multi-dimension sets.

You can use sets as:

- **A row block**
  
The row block contains the characteristics that you want to include in the rows of your report (for example, cost center and account numbers).

- **A column block**
  
The column block contains the characteristics that you want to include in the columns of your report (for example, periods, currencies, and amounts).

- **General selection criteria**
  
The selection criteria contain the characteristics that you want to use to select the report data (for example, year, period, company, and ledger).

Before you can begin creating a report, you must first create the sets that the report will use. If the sets you need already exist in your system, you do not need to create new sets for a report. Also, since sets are not report-specific, you can use the same sets for more than one report.

You can only use a characteristic once in a report - in a row block, column block, or as selection criteria. For example, if a characteristic in a set is already used in a row block, you cannot use the characteristic in a column block.

But you can use the same characteristic in multiple row blocks or multiple column blocks. You can **not** use the same characteristic in a row block and a column block.

If you use the characteristic “account” in row block 1, you can also use the same characteristic in row block 2. However, you can **not** use the characteristic “account” in a row block and a column block.

This section contains:

- Defining Report Data [Seite 893]
- Using Sets in Report Rows [Seite 894]
- Using Sets in Report Columns [Seite 898]
- Suppressing Rows and Columns [Seite 899]
- Using Sets as Selection Criteria [Seite 900]
- Entering Set Text for Reports [Seite 901]
- Using Variables in Report Writer [Seite 903]
Sets in the Report Writer

Using Set Formulas in Report Writer [Seite 906]
Using Symbolic Names in Report Writer [Seite 909]
Setting Format Groups in Sets [Seite 910]

For more information on creating sets, see creating sets [Seite 651].
Defining Report Data

Key figure sets are used only by the Report Writer and contain specific key figures. A key figure refers to a numerical value field stored in a database table. Such key figures are called basic key figures. You can combine a basic key figure with one or more additional characteristics entered in a set to create a key figure. The set determines additional selection conditions, such as the record type (actual or plan data) and the plan version.

Examples of basic key figures used in key figure sets include:

- Transaction currency
- Local currency
- Group currency
- Quantity

Examples of additional characteristics that can be combined with a basic key figure include:

- Actual amount (record type)
- Plan amount (record type)
- Allocated actual (record type)
- Allocated plan (record type)
- Year
- Period

When you use a key figure set in a report, the system selects the currency/quantity and record type specified in the key figure set.

You create a key figure set that contains actual data (record type) in local currency (key figure). If you use this set in a report, the system displays actual data in local currency.
Sets in Report Rows

When you define a report, you select a set as a row block for the report. A row block can consist of one or more physical rows.

For example, if you select a basic set containing account numbers as a row block, the report contains a physical row for each account number in the set.

The order in which values are defined within the set determines how data is sorted and how totals and subtotals are generated. The set hierarchy also determines the report structure and layout. For each set in the set hierarchy, the system creates a subtotal.

If you use a single-dimension set that contains only basic sets in a row block, the system creates subtotals for each basic set, as well as a grand total for the single-dimension set. The system also creates physical rows for each value in the basic sets in the row block.

The row block is the set defined on the Create Report: Rows screen; the physical rows are the detail levels within the set. You can use a basic set, key figure set, single-dimension set, or multidimension set as a row block.


The following graphic shows the multidimension set TD-CC-ACCT.

In the above graphic, the sets and set values contained in the multidimension set TD-CC-ACCT are displayed along with text describing the sets.

For each characteristic in a row block, you specify the level of detail that appears in the report rows. Each detail level contained in a basic set, key figure set, or single-dimension set is
assigned a level number. The following graphic shows the levels of detail found in the set TD-CC-ACCT for the characteristic Account (single-dimension set TD-RACCT-IE).

The multidimension set TD-CC-ACCT (row block) is at the top of the set hierarchy. The name that you assign to a multidimension set appears as the header for the physical rows contained in the report.

If you do not want to use the set text, you can also define your own text for the row block in the report lead column.

Level 1 consists of the single-dimension set TD-RACCT-IE. If you enter level 1 for this characteristic, you only see the sum of income and expense accounts in the report for the cost centers in basic set TD-RCNTR-12.

Level 2 (2-) includes the basic sets TD-RACCT-INC and TD-RACCT-EXP. The sets are ordered in the hierarchy in the same order as they appear in the single-dimension set TD-RACCT-IE. Both sets have the characteristic account. If you specify this detail level in a report, you only see:

4. The total of the cost centers and accounts
5. The sum of the income accounts
6. The sum of the expense accounts

The detail level (1-) includes the details of all the basic sets included for the report, that is, the income accounts, expense accounts, and cost center numbers.

The set that appears at the highest level of a characteristic is assigned the level 1.

For example, level 1 is assigned to the single-dimension set TD-RACCT-IE (see above graphic) because it leads the hierarchy of the characteristic account. Level 1 would also be assigned to the basic set TD-RCNTR-12, since it leads the hierarchy of the characteristic cost center.

You can only use the negative values 1- and 2- as detail levels. 1- displays only basic set values; 2- displays the basic set values and the total for the basic set.
Sets in Report Rows

You can use detail levels to highlight and underline totals and subtotals in a report, as well as display totals and subtotals in different colors.

The report in Working with the Report Writer: Overview [Seite 800] lists the following row information for the row block TD-CC-ACCT:

- The set name of the multidimension set TD-CC-ACCT appears as the row heading for the physical rows in the multidimension set.
- The report contains the row text cost centers. This text comes from basic set TD-RCNTR-12 (with the set text cost centers) which appears first in multidimension set TD-CC-ACCT. The sequence of the row texts (from top to bottom) depends on the sequence of the characteristics in the multidimension set (from left to right).
- The report lists totals for individual income and expense accounts according to cost centers. Accounts appear within the subheading Cost Center because the single-dimension set TD-RACCT-IE appears second in the multi-dimension set. (In our example, the totals are output at the end. If you change the layout, however, you can have the totals output at the top of the report.) For more information, see Defining Report Layouts [Seite 1031].

If you reorder the set contents, the report contents are also reordered.

In the following graphic, the multidimension set TD-CC-ACCT was changed. Set TD-RACCT-IE is now in the first position, and set TD-RCNTR-12 is in the second position.

Level 1 still consists of single-dimension set TD-RACCT-IE and basic set TD-RCNTR-12. Set TD-RACCT-IE now appears before set TD-RCNTR-12, since in multidimension set TD-CC-ACCT the characteristic account has moved to position 1 and the characteristic cost center to position 2.

A report printed with this multi-dimension set as a row block would look like the following graphic. To see the differences that result from moving the characteristics in a multidimension set, compare this report to the report in Working with the Report Writer: Overview [Seite 800].
In this report you see that:

- Subheading row texts are now by account (income and expense) rather than by cost center.
- Individual amounts are ordered by cost centers within the income and expense account subheadings.
- Totals are by income and expense accounts rather than by cost center.

For more information on using sets in reports, see Defining Rows [Seite 841].
Sets in Report Columns

When you create a report, you select a set as a column block for the report. A column block can consist of one or more physical columns.

If you select a key figure set containing two different currency types (local and group currency) as a column block, the report contains a physical column for each currency type in the set.

The set that you entered on the screen Create Report: Columns forms the column block of your report. The physical columns correspond to the detail levels within the set.

The physical column Local appears first in the example report in Working with the Report Writer [Seite 800] because it is listed first in the data set TD-ACT-TL (column block). The physical column Group appears at the second position. This column is therefore also at the second position in the data set TD-ACT-TL (column block). If you rearrange the set lines in the set, the physical columns in the report are also rearranged.

Set TD-ACT-TL was used as a column block in the report in Working with the Report Writer [Seite 800]. Key figure set TD-ACT-TL contains the two values HSL-0 (local currency in actual data) and KSL-0 (group currency in actual data).

You can use a basic set, key figure set, single-dimension set, or multidimension set as a column block.

A set that you use as a column block contains all values that you want in the physical columns of your report. The values must be defined in their sets in the same order you want them to appear in the report.

For more information about using sets in report columns, see Defining Columns [Seite 854].
Suppressing Rows and Columns

You can suppress individual values, ranges of values, or total set values within a report. Setting the suppression indicator on a multi-dimension, single-dimension, or basic set screen tells the Report Writer to ignore individual amounts and totals at lower levels of set hierarchies.

For columns, the value intervals (ranges) in basic sets are suppressed automatically; only the interval total is displayed.

In a basic set, the value intervals (ranges) are printed as individual amounts. You use the suppression indicator to suppress the individual interval amounts in a set row.

If a basic set line has an interval of account numbers 1000020 to 1000050, the system prints the amounts for all the account numbers from 1000020 to 1000050, if data has been posted for these accounts. If you set the suppression indicator in the basic set for this line, the system prints only the total for the account numbers 1000020 to 1000050 instead of the individual amounts.

In single-dimension and multi-dimension sets, you use the suppression indicator to suppress individual amounts for an entire set.

If you set the suppression indicator for the set TD-RACCT-EXP in the multi-dimension set TD-CC-ACCT, the individual amounts of the set TD-RACCT-EXP are suppressed, but the total amount of the set TD-RACCT-EXP is printed.

In the following graphic, the individual totals for the expense accounts are suppressed.
Using Sets to Select Report Data

You also use sets to further define the data that you want to select for your report.

You can use row and column sets to specify for example which accounts and types of currencies are output in your report. You can also narrow data selection for your report even further by specifying a ledger, a fiscal year, and a company. You can also enter these selection criteria on the screen Create Report: General Data Selection using selection sets in your report definition.

When you use sets as criteria for selecting data, the sets must contain all the characteristics you want to use to select data. If a characteristic is already defined in a row or column, you cannot enter the characteristic for selecting data.

Multidimension sets cannot be used as selection sets. Key figure sets can only be used as selection sets when there is exactly one value in the set.

To improve processing time when you execute the report’s report group, it is important to specify all characteristics as data selection criteria, which need not be used in the report rows or columns.

For the example report in Working with the Report Writer [Seite 800], you could select the report for Company TD11 during the first quarter of 1995. You would enter sets that use the characteristics Company, Period, and Fiscal Year.

You can also use set variables as general data selection criteria. For more information about the uses of sets in the Report Writer, see Using Variables in Report Writer [Seite 903].

For more information about using sets as selection criteria, see Defining Selection Criteria [Seite 835].
Entering Set Text for Reports

Unless otherwise defined in the report, the Report Writer prints the text that you enter in your sets when you use the sets in report row/column blocks. You can enter text for reports in the text fields on the Create and Change Set screens for basic sets, key figure sets, single-dimension sets, and multidimension sets.

You can also use the Extras → Additional texts function on the Create Report: Rows/Columns screens to enter specific row/column block text for the lead column and the report total when you define the report rows/columns. This text is used instead of the text from the set header.

• Basic Sets

For basic sets, you can enter text for each line of the set in the Short text of set line field on the Create Set: Basic Entries screen. If you then use this set in a row or column block, text appears describing the values for each set line that includes text. If you do not enter set line text, the Report Writer uses the text from the appropriate master files.

The Report Writer uses the set header text as the description for the corresponding subtotal. You can enter text for the set name in the Description field on the Create and Change Set: Header screens.

In the report in Working with the Report Writer [Seite 800], the basic set TD-RCNTR-12 contains the set header text Cost Centers, the basic set TD-RACCT-INC contains the set header text Income Accounts, and the basic set TD-RACCT-EXP contains the set header text Expense Accounts. (Account text is read from the account master files in FI, and cost center text is read from the cost center master files in CO.)

• Key Figure Sets

In key figure sets, you can enter text for each line of the set in the Short text of set line field on the Create Set: Basic Entries screen. If you then use this key figure set in a row or column block, text appears describing the values for each set line that includes text. If you do not enter text for a key figure set line, the Report Writer uses the text from the predefined column.

In the report in Working with the Report Writer [Seite 800], the key figure set value HSL-0 contains the lead column Local, and the key figure set value KSL-0 contains the lead column Group.

As with basic sets, you can enter set header text in the Description field on the Create and Change Set: Header screens.

• Single-Dimension Sets

For single-dimension sets, you can enter set header text in the Description field on the Create and Change Set: Header screens.
Entering Set Text for Reports

In the example report with switched characteristics (see Using Sets in Report Rows [Seite 894]), the single-dimension set TD-RACCT-IE contains the set header text Income/Expense Accounts.

- Multidimension Sets

For multidimension sets, you can only enter set header text in the Description field on the Create and Change Set: Header screens. When you use a multidimension set in a report row block, the set header text appears as the heading for the lead column.

In the report in Working with the Report Writer [Seite 800], the multidimension set TD-CC-ACCT contains the set header text Inc.& Exp/Cost Centers. This text appears as the lead column heading in the report.
Sets in the Report Writer

Use

You can also use variables in your reports. A variable is a placeholder for data that you can enter as required, when you run a report.

You can use general selection variables in your reports. General selection variables determine the data that is selected for a report. General selection variables include the following variable categories:

- **Value variables**
  
  These variables represent specific values. You enter a value variable in a basic set and you determine the value for the variable when you run a report that uses the set containing the variable. You can only use value variables in basic sets.

- **Formula variables**
  
  These variables represent formulas that determine a value for the variable. You can only use formula variables in basic sets.

- **Set variables**
  
  These variables represent sets and the values in those sets. You can only use set variables in multi-dimension sets. You cannot use multi-dimension sets that contain set variables as column blocks in your report.

Features

**Value variables**

A value variable is a user-defined variable that you can enter directly into a set. You can only use value variables in basic sets.

You can create a variable called YEAR. If you enter the YEAR variable in a basic set and then use the basic set in a report, the system prompts you to enter a year when you run the report.

Value variables that you use for the Report Writer, are displayed on the selection screen when you select the records for the report. When you use a value variable in a report, the value that you choose for the variable is valid for only one report run. Each time you run the report, you can enter a different value for the variable. You can also enter a default value for a variable; this value then appears each time a report is run.

For more information, see Creating Value Variables [Seite 693].

**Formula variables**

A formula variable represents a user-defined formula, which determines a value for the variable. You can only use formula variables in basic sets.
Sets in the Report Writer

You want to create a formula that automatically calculates the previous year based on the variable for the current year. To do this, proceed as follows:

3. Create a formula variable called YEAR (current year), which uses the user exit S001 to determine the current year.

4. Refer to this formula in another formula variable called PR-YEAR (previous year). You can enter the formula as follows: 

   "&YEAR"-1

   If you use both variables YEAR and PR-YEAR in a report, the system only prompts you to enter the current year, with the default current year being taken from the system date. The value for PR-YEAR is automatically calculated by the system (by subtracting 1 from the year you entered for YEAR). You can also define PR-YEAR by using the user exit S001 in a formula ("#S001"-1).

For more information, see Creating Formula Variables [Seite 695].

If you use formula variables in report columns, you can also create more than one new report category. For more information, see using formula variables in reports: examples [Seite 859].

Set variables

A set variable represents a basic or single-dimension set that was created for a particular characteristic. You can enter set variables in a multi-dimension set, or directly as a selection set in a report.

You create a set variable called CNTR-V for the "Cost Center" characteristic. When you create the set variable, enter a set name (such as TD-RCNTR-12 for the characteristic Cost Center) as the default value for the set variable.

You can then use the set variable for either of the following objects:

- A multi-dimension set that is used as a row block (set variables cannot be used in column blocks of a report definition)
- A selection criterion on the Create Report: General Selection screen

When you enter the CNTR-V set variable in a set that is used in a report, the Report Writer prompts you to enter a set name when you select the report data. In this case, the default value for the set name is TD-RCNTR-12. If required, you can enter another set and/or single cost centers.

You can enter set variables whose default set uses a table that differs from the report table. However, the table field of the default set must be the same as the relevant characteristic of the report table.

Set variables that are used by the Report Writer are displayed on the selection screen when you select the data for your report. For each set variable used in a report, the Report Writer creates an entry field on the selection screen. You can enter either a set, or single value or an interval of values in this field.

For more information, see Creating Set Variables [Seite 697].
Set Formulas in the Report Writer

Use

In sets, you can use formulas to perform calculations within the set. When the set is used in a report, the result of these calculations then appears in a report column or row.

You can only use formulas in basic sets and key figure sets.

You create a key figure set called TD-ACT-PLN-V, which uses the formula ‘001’ ‘002’. Line 001 of the set TD-ACT-PLN-V is plan data in local currency (HSL-1) and line 002 is actual data in local currency (HSL-0).

The formula ‘001’ ‘002’ creates the Variance column in the report in the following graphic. To create this column, the system subtracted line 002 (actual data) from line 001 (plan data).

Using a Formula to Create a Variance Column in a Report

<table>
<thead>
<tr>
<th>08.09.1995</th>
<th>Inc. &amp; Exp./Cost Centers</th>
<th>Plan Data</th>
<th>Actual Data</th>
<th>Variance</th>
</tr>
</thead>
<tbody>
<tr>
<td>400010</td>
<td>Sales Revenue</td>
<td>120,000.00</td>
<td>245,600.00</td>
<td>125,600.00-166,000.00</td>
</tr>
<tr>
<td>400020</td>
<td>Revenue fr. Investment.</td>
<td>420,000.00</td>
<td>254,000.00</td>
<td>460,000.00</td>
</tr>
<tr>
<td>**</td>
<td>Income Accounts</td>
<td>540,000.00</td>
<td>499,600.00</td>
<td>50,000.00</td>
</tr>
<tr>
<td>300010</td>
<td>Cost of Goods Sold</td>
<td>100,000.00-150,000.00</td>
<td>50,000.00</td>
<td></td>
</tr>
<tr>
<td>300010</td>
<td>Wages and Salaries</td>
<td>90,000.00-140,000.00</td>
<td>50,000.00</td>
<td></td>
</tr>
<tr>
<td>**</td>
<td>Expense Accounts</td>
<td>190,000.00-290,000.00</td>
<td>100,000.00</td>
<td></td>
</tr>
<tr>
<td>400010</td>
<td>Sales Revenue</td>
<td>350,000.00</td>
<td>209,600.00</td>
<td>140,400.00</td>
</tr>
<tr>
<td>**</td>
<td>100 Administration</td>
<td>120,000.00</td>
<td>263,000.00</td>
<td>143,000.00</td>
</tr>
<tr>
<td>400020</td>
<td>Revenue fr. Investment.</td>
<td>450,000.00</td>
<td>267,000.00</td>
<td>183,000.00</td>
</tr>
<tr>
<td>**</td>
<td>Income Accounts</td>
<td>570,000.00</td>
<td>330,000.00</td>
<td>240,000.00</td>
</tr>
<tr>
<td>300010</td>
<td>Cost of Goods Sold</td>
<td>100,000.00-230,000.00</td>
<td>130,000.00</td>
<td></td>
</tr>
<tr>
<td>300020</td>
<td>Wages and Salaries</td>
<td>100,000.00-100,000.00</td>
<td>130,000.00</td>
<td></td>
</tr>
<tr>
<td>**</td>
<td>Expense Accounts</td>
<td>200,000.00-330,000.00</td>
<td>130,000.00</td>
<td></td>
</tr>
<tr>
<td>**</td>
<td>200 EDP</td>
<td>370,000.00</td>
<td>200,000.00</td>
<td>170,000.00</td>
</tr>
</tbody>
</table>

|       | Cost Centers             | 720,000.00 | 409,600.00 | 310,400.00 |

A formula consists of operators, operands, absolute values, and parentheses.

When you enter a formula in a set, you can use the operators in the following table.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
</tbody>
</table>
Set Formulas in the Report Writer

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/</td>
<td>Division</td>
</tr>
<tr>
<td>**</td>
<td>Exponential value</td>
</tr>
<tr>
<td>( )</td>
<td>Parentheses</td>
</tr>
<tr>
<td>SIN</td>
<td>Sine</td>
</tr>
<tr>
<td>COS</td>
<td>Cosine</td>
</tr>
<tr>
<td>TAN</td>
<td>Tangent</td>
</tr>
<tr>
<td>SQRT</td>
<td>Square root</td>
</tr>
<tr>
<td>TRUNC</td>
<td>Truncation to integer</td>
</tr>
<tr>
<td>INT</td>
<td>Truncation to integer</td>
</tr>
<tr>
<td>DIV</td>
<td>Quotient of whole number division</td>
</tr>
<tr>
<td>MOD</td>
<td>Remainder of whole number division</td>
</tr>
<tr>
<td>ABS</td>
<td>Absolute value</td>
</tr>
<tr>
<td>EXP</td>
<td>Exponential function (n^x)</td>
</tr>
<tr>
<td>LOG</td>
<td>Logarithm</td>
</tr>
<tr>
<td>ROUND</td>
<td>Rounding</td>
</tr>
</tbody>
</table>

**Features**

You can use the following operands in set formulas:

- Line numbers in the form ‘nnn’ (for example ‘001’ for line 001)
- Value variables (for example, ‘&PERIOD’ for the value variable PERIOD)
- Symbolic names for cells (for example, ‘TOTAL’ for a specific totals row in a report)

You enter formula operands in the form ‘nnn’ (for example, ‘001’ to enter the row block 001). In earlier releases, you enter formula operands using angle brackets around the operand (for example <001>).

The system automatically converts any existing formulas into the new format. You do not therefore need to change your sets or reports that contain formulas.

Within a formula you can also use:

- Absolute values (for example, 10 or 20)
- Combinations of absolute values and operands (for example, 10 * ‘002’ (line 2))
- Boolean logic

You enter the following formula in the second line of a set defined for a report column:

```
IF ‘001’ > 1000 THEN ‘001’ ELSE 0
```
Set Formulas in the Report Writer

If the value in the first column (set line 001) is greater than 1000, then this value displays in the second column; if the value in the first column is less than 1000, the value 0 displays in the second column.

For more information on Boolean logic, see *Introduction to Boolean Logic [Seite 1121]*.

If you use set formulas that only use the addition and subtraction operators (also known as linear formulas), you can display the units (for example, currency units and units of measure) in the report columns that are calculated using the formula.

You define a data set for the column block, which contains actual and plan costs. You want to define a variance column containing the difference between the actual and plan costs. In line three of the column block, you define the formula ‘001’ – ‘002’. If the data for the actual and plan costs is displayed with the currency unit USD, the unit USD also displays in the variance column.

The unit is only displayed when the unit displayed in both columns is the same and if the formula only uses the addition and subtraction operators. For example, if actual costs are displayed in USD and plan costs are displayed in DEM, a unit is not displayed in the variance column.

For more information on entering formulas, see *Formulas [Seite 686]*.
Symbolic Names in the Report Writer

A symbolic name can represent the row or column coordinate for a single cell or a range of cells within a report. The system uses cells to determine locations within the column-row matrix of a report. For more information, see Defining Cells [Seite 864].

Symbolic names are defined within sets. You can assign symbolic names to:

- **Set lines**

  Set line symbolic names refer to a value or a set name in a set line. For basic, data, and single-dimension sets, you define set line symbolic names using the Symbolic Name field on the Create and Change Set: Basic Entries screens.

  Set line symbolic names can also be used in multi-dimension sets, for example, for set variables that have been entered directly into a multi-dimension set. You enter symbolic names for set lines under Create Set: Basic Entries and Change Set: Basic Entries. This way you can address the highest row total in cell calculations.

  The symbolic name that you assign to a set line in a multi-dimension set does not overwrite existing header symbolic names, which have been defined in the set entered in the multi-dimension set. Instead, two symbolic names exist for the set line and the set header.

- **An entire set**

  Set header symbolic names refer to all values within a set. For basic, data, and single-dimension sets, you define symbolic names for the entire set using the Symbolic name field on the Create and Change Set: Header screens.
Setting Format Groups in Sets

In sets, you can specify format groups. A format group represents a version of layout parameters for a report. You can specify format groups in:

- Set rows of basic, data, single-dimension, and multi-dimension sets
- The set header of basic and single-dimension sets to represent the set total

The format groups instruct the Report Writer which format to use for the set total represented by the set header or the data in the set rows. Report rows and columns corresponding to these set totals and set rows are then formatted according to the layout parameters for the specified format group.

The report portrayed in using set formulas in Report Writer [Seite 906] uses the column block TD-ACT-PLN-V and lists the following columns:

- Plan data in local currency (HSL-1)
- Actual data in local currency (HSL-0)
- Variance (difference between plan and actual data in local currency)

By assigning a different format group to set row 003 (the variance column) in data set TD-ACT-PLN-V, you can change the layout of this column, such as the column width and number of decimal places.

You can specify a format group for:

- **Basic and single-dimension sets**
  - You enter a format group in the format group field on the Create and Change Set: Basic Entries screens to represent the individual set rows.
  
  Format groups entered in the set header represent the total level in the set. In set hierarchies, the format group entered in the set header is only used for the highest total in the row or column block. For all other report rows and columns, the format group entered in the set row is used.

- **Data sets**
  
  You enter a format group in the format group field on the Create and Change Set: Basic Entries screens to represent the individual set rows.

- **Multi-dimension sets**
  
  You enter a format group for a set row in the format group field on the Create and Change Set: Basic Entries screen. You can use the format groups, for example, for set variables that have been entered directly into a multi-dimension set.

The value you enter in the format group fields instructs the Report Writer to select a specific format group value listed in the report parameters for the set row or set header for which you enter the format group.
The format groups refer to certain parameters that are displayed on the Create Report: Layout or Create Standard Layout screens. Each of the fields listed below is made up of six input fields; each of these six input fields stands for one of the six format group 0 through 5. The Report Writer selects the corresponding format information according to the value you entered for the format group.

On the Create Report: Column Totals screen, the format group applies to the following parameter fields affecting column format:

- Column width
- Right margin

On the Create Report: Layout: Representation screen, the format group applies to the following parameter fields affecting numeric format:

- Decimal places
- Scaling
- Change +/- sign
- Print unit

To enter the format groups, from the Create Report: Layout: Column Totals and Create Report: Layout: Representation screens, choose the function Variants. A dialog box appears with additional entry fields for the format groups 1 to 5.

For a basic set row value, enter in the format group field the format group 1. When you use this set in a report, the Report Writer looks to the second input field of the parameter for the format it should use in the report.

The format group values for the number of decimal places, scaling, column width, currency/quantity width, and the right margin are only valid for columns. This means that the format group value you enter in a set (for these fields) is only valid if the set is used in a column.

You can find more information on creating sets under creating sets [Seite 651].
Report Writer Utilities

Use

Report Writer utilities provide you with different functions, which you can use on a report level to make more specifications to your Report Writer report [Seite 804] and on a report group level to transport and generate report groups [Seite 937] and their variants.

Activities

Report Writer Reports

- For an overview of existing reporting objects, choose Report Writer → Report → Utilities → Catalog. For more information, see Listing Report Writer Objects [Seite 914].
- For layout control, during editing of a Report Writer report choose from the initial screen Utilities → Layout control. For more information, see Displaying Report Layouts [Seite 1030] and Defining Report Layouts [Seite 1031].
- To transport Report Writer objects, first choose Utilities → Transport and then, as appropriate:
  - to export to external files → Export For more information, see Exporting Report Writer Objects [Seite 916].
  - To import from external files → Import For more information, see Importing Report Writer Objects [Seite 918].
  - To copy a report from a different client → Copy from client For more information, see Copying Report Writer Objects from Other Clients [Seite 919].
  - For a transport request → Transport request For more information, see Transporting Report Writer Objects [Seite 921].
- To list the report definition, choose Utilities → List definition. For more information, see Listing a Report Definition [Seite 923].

Report Groups

- For an overview of existing report groups, choose Report Writer → Report group → Utilities → Catalog. For more information, see Listing Report Writer Objects [Seite 914].
- Use the mass generator to generate as many report groups as you require. Choose Report Writer → Report group → Utilities → Mass generator. For more information, see Generating Report Groups (Mass Generator) [Seite 954].
- To display, delete or print and to change the expiry date of extracts [Extern], choose Report Writer → Report group → Utilities → Extracts → Display/Delete/Print/Change expiry date. For more information, see Extracts [Seite 1008].
- To delete generated program includes that are no longer used, choose Report Writer → Report group → Utilities → Delete programs. For more information, see Deleting Generated Code for Report Groups [Seite 957].
- To maintain variants, choose Report Writer → Report group → Utilities → Variant maintenance. For more information, see Creating Report Group Variants [Seite 958].
Exporting and Importing Report Group Variants [Seite 960] and Copying Report Group Variants from Other Clients [Seite 961].

- To schedule report groups as a background job, choose Report Writer → Report group → Utilities → Background job. For more information, see Scheduling a Report Group as a Background Job [Seite 956].

- To transport report groups, choose Report Writer → Report group → Utilities → Transport. The procedure is the same as described above for Report Writer reports.
Listing Report Writer Objects

   
   If you want to display a list of defined reports, you choose Utilities → Catalog. The Report Writer: Report Catalog screen appears.

5. Enter data as required.
   The data you enter determines the objects that are selected for display.

6. Choose Program → Execute.
   A list of objects meeting the criteria you entered on the previous screen appears.
   From the report and report group catalog, you can change, display, delete, and execute the selected report(s) and report group(s) using the respective functions under the Goto menu option.
   The report group catalog also provides statistics on the number of data selections made for each report group, together with the name of the user who last selected data for the report group.
Transport of Report Writer Objects

Use

When processing Report Writer reports you can use the function Utilities → Transport to export, import, copy from other clients or add to a transport request Report Writer objects, such as libraries [Seite 927], reports, report groups [Seite 937] and standard layouts [Seite 1017].

Features

With the functions under Utilities → Transport, you have the following possibilities:

- The Export function allows you to export Report Writer objects (such as libraries, reports, report groups, and standard layouts) from an SAP R/3 System to an external file. For more information, see exporting Report Writer objects [Seite 916].

- The Import function to allows you to import Report Writer objects (such as libraries, reports, report groups, and standard layouts) from an external file to an SAP R/3 System. For more information, see importing Report Writer objects [Seite 918].

- The Copy from client function allows you to copy Report Writer objects between different clients within an SAP R/3 System.

  Several SAP R/3 application components deliver example Report Writer objects, such as libraries, reports, report groups, and standard layouts (stored in client 000). You can use the Copy from client function to copy these objects from client 000 (or another client) to the client in which you are working.

  For more information, see copying Report Writer objects from other clients [Seite 919].

- The function Transport request allows you to copy Customizing settings for standard layouts, libraries, reports, Report Writer report groups, report groups variants, key figures and Report Painter models in a transport request. For more information, see transporting Report Writer objects [Seite 921].

For more information on processing Report Writer reports, see functions in the report output [Seite 974].
Exporting Report Writer Objects


   If you want to export reports, you choose Utilities → Transport → Export on any
   then appears.

3. Enter the selection criteria as required.
   The data you enter determines the data that is selected for export.

4. Set the indicators in the Further details group box, as required:
   – Indicator that determines if the objects are exported directly.
     In this case, you do not select the objects to be exported from an object list.
   – Indicator that determines if all dependent objects are transported.
     For example, if you are exporting reports and select With dependent objects, the
     system exports all reports and the objects defined for the reports (sets, variables,
     formulas, libraries, and standard layouts).
     This indicator does not appear if you are exporting standard layouts.

   CO groups (such as cost center groups, cost element groups, profit center groups,
   and so on) are no longer exported as dependent objects. This prevents CO groups
   being overwritten unintentionally in the target client. If you want to copy CO groups to
   another client, you do so in a separate step using the set or hierarchy maintenance
   functions.

   The following table shows the dependent objects that are exported for a specific Report
   Writer object.

<table>
<thead>
<tr>
<th>If the Report Writer object is a</th>
<th>Then the following dependent objects are exported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library</td>
<td>Default selection sets (except CO groups)</td>
</tr>
<tr>
<td>Report</td>
<td>Sets (except CO groups), key figures, libraries, standard layouts</td>
</tr>
<tr>
<td>Report group</td>
<td>Reports, sets (except CO groups), key figures, libraries, standard layouts</td>
</tr>
</tbody>
</table>

   – Indicator that determines if the objects are exported to a presentation server (for
     example, a PC).
     If you do not set this indicator, the objects are exported to an application server.
You cannot export objects to the presentation server in background processing. You must export objects to the presentation server online.

- Export file to which you want to export the objects.
  
  If the file does not exist, the system creates it; if the file exists, the system overwrites the existing file.
  
  For a UNIX operating system, the file name consists of a path and a name, such as /TEMP/EXPORT.
  
  For a Windows operating system, the file name consists of a drive, a path, and a name, such as C:\DATA\EXPORT.

5. Choose Program → Execute.

   The reports are exported to the file you specified in the Export file field.
   
   If you did not select Without selection list, a selection screen of Report Writer objects appears:
   
   c. Select the Report Writer objects that you want to export.
   
   d. Choose Execute.
Importing Report Writer Objects


5. Enter the following data:

   - Indicator that determines if the objects are imported from a presentation server (for example, a PC).
     
     If you do not set this indicator, the objects are imported from an application server.
     You cannot import objects from the presentation server in background processing.
     You must import objects from the presentation server online.

   - Name of the file from which you want to import the objects.

     When you import objects from an external file, the system overwrites existing objects without warning.

6. Choose Program → Execute.

   The objects are imported from the file you specified in the Export file field.
Copying Report Writer Objects from Other Clients

Prerequisites
You can only use this function if you are copying Report Writer objects from/to clients that exist in the same system. If the Report Writer objects you want to copy are stored in a different system than the one to which you want to copy, you must use the Utilities → Transport → Import and Export functions.

When you copy Report Writer objects to the client in which you are working, the system overwrites existing objects without warning.

Procedure
   The Report Writer: Copy <Object> from Source Client screen appears.
6. Enter the source client and the selection criteria as required.
   The data you enter determines the data that is copied from the source client to the client in which you are working.
7. Set the indicators in the Further details group box, as required:
   – If you select Copy without selection list, the objects are copied directly to the client in which you are working.
     In this case, you do not select the objects to be copied from an object list.
   – If you select Copy with dependent objects, the Report Writer objects are copied with all their dependent objects.
     For example, if you are exporting reports and select Copy with dependent objects, the system exports all reports and the objects defined for the reports (sets, variables, formulas, libraries, and standard layouts).
     This field does not appear if you are copying standard layouts to another client.
     Refer to the table in Exporting Report Writer Objects [Seite 916] to determine dependent objects that are copied for a Report Writer object.
8. Choose Program → Execute.
   If you selected Copy without selection list, the system automatically copies the Report Writer objects from the source client to the client in which you are working, according to the criteria you entered on the Report Writer: Copy <Object> from Source Client screen.
Copying Report Writer Objects from Other Clients

If you did not select Copy without selection list, the system lists all objects from the source client that meet the criteria you entered on the Report Writer: Copy <Object> from Source Client screen:

c) Select each object that you want to copy.

d) Choose <Object> → Copy.

The system copies the Report Writer objects to the client in which you are working.
Transporting Report Writer Objects

Use
You can copy the Customizing settings for the following to a transport request using the function Transport request:

- Standard layouts
- Libraries
- Reports
- Report Writer report groups
- Report group variants
- Key figures
- Report Painter models

Procedure
5. From one of the Report Writer screens, choose Utilities → Transport → Transport request. The Transport: Report Writer screen appears:
6. Select the object for which you want to include the Customizing settings in the transport request and choose Execute.
7. The Report Writer: Include <Object Name> in Transport Request screen appears. Enter the selection criteria as required.
8. In the group box Further details, depending on the object you selected, you can select at least one and at the most three of the following settings.
   - If you want to execute the request for all the selected objects directly, select the Without selection list indicator. This makes particularly good sense for batch processing. If you do not select this indicator the system displays a list of all the selected objects and you can choose the object you want to transport.
   - Indicator that determines if all dependent objects are transported.
     
If you transport a report and select the With dependent objects indicator, the system includes the report and all the objects defined for the report (sets, variables, formulas, libraries and standard layouts) in the transport request.
   - For report groups, you can specify whether you also want to transport the variants.

The following table shows the dependent objects that are transported for a specific Report Writer object.

<table>
<thead>
<tr>
<th>If the Report Writer object is a</th>
<th>Then the following dependent objects are transported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Libraries</td>
<td>Default selection sets (except CO groups)</td>
</tr>
</tbody>
</table>
### Transporting Report Writer Objects

<table>
<thead>
<tr>
<th>Reports</th>
<th>Sets (except CO groups), key figures, libraries, standard layouts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report group</td>
<td>Reports, sets (except CO groups), key figures, libraries, standard layouts</td>
</tr>
</tbody>
</table>

6. Choose *Program → Execute.*
   
   If you did not select *Without selection list*, a selection screen of Report Writer objects appears:
   
   c. Select the Report Writer objects that you want to transport.
   
   d. Choose *Execute*.
   
   The objects are included in your chosen Customizing request.
Listing a Report Definition


7. Enter the library and name of the report that you want to display.

8. If you want to display the report texts (title page, header, footer, last page, and text for export), select List texts.

9. If you want to display the graphics of the sets used in the report, select Set graphics.

10. Choose Program → Execute.

   The List Report Definition: <Report Name> screen appears, displaying a complete definition of the report you entered on the previous screen.

   You can print the complete report definition using the Print function.
Defining Reports for the Report/Report Interface

Use
The report/report interface allows you to call reports from other R/3 application components when you output your report data. You can call up report portfolio reports, drilldown reports, transactions, receiver reports, Report Writer reports, Report Painter reports, and ABAP programs.

If you define reports for the report/report interface in both the report group header and in the report group's library, the system uses the reports that you have defined specifically for the report group.

Example
Your system is delivered with an ABAP program called RGGD1300, which displays line items for the FI-SL summary tables. The program reads the data from the FI-SL line item table and outputs a list of the line items.

You can call up program RGGD1300 directly (System → Services → Reporting) or from the report/report interface if it is defined as a receiver report for another Report Writer report. In a report that displays totals, you can then display the line items for a specific totals record.

To call program RGGD1300 as a receiver report to display line items for totals data in a report:

Procedure for Example


11. The group box Report/report interface contains information on the current assignment of the reports in this report group to the library of the report group. To assign a report to the report group, choose Configure.... The Assign Reports dialog box appears.

12. To enter a receiver report for the report/report interface, choose Insert row ☰.


7. To enter program RGGD1300 as the receiver report, choose Other Report Type.

A dialog box appears, listing the possible report types.

The receiver reports you assign can be report portfolio reports, drilldown reports, transactions, Report Writer reports, and ABAP programs. This enables you to call receiver reports from other R/3 application components once you have output your report data.

You should normally assign receiver reports to the report group.
In this example, we are using the ABAP program RGGD1300 as the receiver report.

17. Position the cursor on ABAP Report and choose 🏛️. The Add ABAP/4 Report dialog box appears.

18. Enter RGGD1300 as the receiver report and choose 🏛️.

The default text of program RGGD1300 is displayed in the Assign Reports dialog box.

19. You can use the following additional processing functions in this dialog box:

**Additional Processing Functions - Dialog Box for Report/Report Interface**

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save receiver report for report/report interface</td>
<td>📄 Save</td>
</tr>
<tr>
<td>Add receiver report to report/report interface definition</td>
<td>⌨️ Insert row</td>
</tr>
<tr>
<td>Delete entry in report/report interface definition</td>
<td>🗑️ Delete row</td>
</tr>
<tr>
<td>Insert report from another system (cross-system report assignment). You log on to the other system, select a receiver report, and transfer it to the sender system.</td>
<td>🏛️ Add external report</td>
</tr>
<tr>
<td>Select one or more receiver reports for further processing (for example, to move the selected report to another position in the list)</td>
<td>📙 Select line</td>
</tr>
<tr>
<td>Move selected receiver report to another position in the list. If the cursor is positioned on a receiver report, the selected report is inserted before this receiver report. If the cursor is not positioned on a receiver report, the selected report is inserted at the end of the list.</td>
<td>⏯️ Move</td>
</tr>
<tr>
<td>Display default text of a receiver report if you have previously overwritten the default text of the report. Note: when you first enter a receiver report, the default text for this report is automatically displayed.</td>
<td>📥 Default text</td>
</tr>
<tr>
<td>Display all reports to which the specified sender report is assigned as the receiver report. If you activate this function again, the original list is displayed.</td>
<td>🏳️ Sender &lt;-&gt; Receiver</td>
</tr>
<tr>
<td>Display technical information on the receiver report(s) (for example, the report tool and the technical report name)</td>
<td>📜 Technical names on/off</td>
</tr>
<tr>
<td>Documentation on displaying and maintaining the report assignment in the report/report interface</td>
<td>📚 Help</td>
</tr>
</tbody>
</table>

20. Choose 📖 to save your entries.

**Example**

The Report Writer uses ABAP program RGGD1300 as shown in the following graphic:
Defining Reports for the Report/Report Interface

The report in the graphic displays accounts by periods. This report is assigned to report group TD00. Report group TD00 has been defined such that ABAP program RGGD1300 is a receiver report in the report group (on the Create Report Group: Header screen).

Program RGGD1300 is called up with the Report Writer as follows:

p) After selecting the report data for the report, the system displays the report.

You can select part of the displayed report and have the system display the associated line items.

q) Select amount 600 for account 4000020 in period 1 from the report.

r) When you choose Reports, the system generates a list of the reports that are defined as receiver reports in report group TD00 (Create Report Group: Header screen).

s) Select program RGGD1300.

t) The Report Writer adopts the selection criteria from the report (such as the company code, ledger, account, and period) and starts the ABAP program RGGD1300. This program displays the line items that meet the selection criteria (company code TD11, ledger D2, account 4000020, period 1).

For more information on calling receiver reports, see Functions in the Report Output [Seite 974].
Libraries

Definition

All reports are in libraries. A library is a collection of characteristics, basic key figures, and key figures that have been selected from the entries of a Report Writer table.

- A **characteristic** (called a field or dimension in previous releases) is a nonnumeric field.
  Examples of characteristics are account, cost center, and business area.

- A **basic key figure** (key figure in previous releases) is a numerical value field. Examples of basic key figures: local currency, total costs, and activity quantity.

- A **key figure** consists of a basic key figure and one or more characteristics. Using predefined columns, you can define standard columns that you can then use in your reports repeatedly.
  Examples of key figures: actual costs in current year, plan costs in closed year.

The reports contained in the library can only use the characteristics, basic key figures, and key figures defined for this specific library.

If report $X$ is assigned to library $ABC$, you can only use characteristics in that report that are contained in library $ABC$. This applies to all the reports in library $ABC$, not just to report $X$.

Use

The transfer structure for transfer to the Report Painter [Seite 726] or Report Writer [Seite 797] is a reporting table. This reporting table is predefined in the SAP R/3 System and cannot be changed. The reporting table is a logical view of different database tables and contains all characteristics, basic key figure, and key figures.

In Cost Center Accounting, the transfer structure is reporting table CCSS.

You have the following options when working with libraries:

- You can separate development reports from production reports.
- You can subdivide your reports by user group.
- You can assign user authorizations for each library.

When you create a library, you decide which characteristics, basic key figures, and key figures you want to include in the library. To do this, you can either copy an existing library or enter a table (such as GLT1) and select the required characteristics, basic key figures, and key figures from this table.

You can also define **standard selection sets** for reports in a library. These standard selection sets are automatically displayed when you define a report that uses the library concerned.

If you want all reports in a library to use the set $UN\text{-LEDGER}$ (containing the value $AB$ for the ledger) when the report data is selected, you can use the set $UN$-
Libraries

LEDGER as a default set for the characteristic Ledger. When you define a report that is assigned to the library concerned, the set UN-LEDGER appears in the report definition as the selection set. You can, however, overwrite this set.

You can also assign user authorizations for your libraries.

For example, you can specify that only a certain user group shall have access to the reports from a particular library.

For more information on libraries, see:

- Creating a Library [Seite 929]
- Defining Reports for the Report/Report Interface [Seite 924]
- Displaying a Library [Seite 934]
- Changing a Library [Seite 935]
- Deleting a Library [Seite 936]
Creating a Library

   Create Library: Initial Screen appears.

6. Enter the following information:
   - Name of the library
   - Table name for the library
     This table contains the data you want to use in your report. You only need to enter a
     table in this field if you do not want to copy an existing table.

7. If you want to create a library by copying an existing library, enter the name of the library
   that you want to copy in the Copy from - Library field.

8. Choose Header.
   The screen Create Library: Header appears.

Entering Header Information

5. Enter the following information:
   - Description of the library
   - Authorization group for the library (if required)
     This authorization group is defined in the user’s profile.

   You can define an authorization group called COST. If you assign this authorization
   group to a report library, only users with this authorization group can use the reports
   in the library.

6. In the Report/report interface group box, choose Configure to define receiver reports that
   you want to call up when you output your report data.

   The receiver reports you assign here are valid for all the reports that use this library. You
   can also assign reports for the report/report interface in the header of a report group. If
   you assign receiver reports in both the header of the library and the header of the report
   group, the system uses the reports you assigned to the report group.

   The receiver reports you assign can be report portfolio reports, drilldown reports,

   You must save the library before you can enter receiver reports for the report/report
   interface.

   For more information, see Defining Reports for the Report/Report Interface [Seite 924].

7. You can use the following additional functions in this screen:

Additional Functions (Create Library: Header Screen)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
</table>

April 2001

929
Creating a Library

<table>
<thead>
<tr>
<th>Goto → Characteristics</th>
<th>Add characteristics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Basic key figures</td>
<td>Add key figures</td>
</tr>
<tr>
<td>Goto → Key figures</td>
<td>Add key figures</td>
</tr>
<tr>
<td>Extras → Use...</td>
<td>Display list of reports and report groups that use the library</td>
</tr>
<tr>
<td>Utilities → Catalog...</td>
<td>Display list of libraries</td>
</tr>
<tr>
<td>Utilities → Transport → Export</td>
<td>Transport libraries to an external file</td>
</tr>
<tr>
<td>Utilities → Transport → Import</td>
<td>Import libraries from an external file</td>
</tr>
</tbody>
</table>

8. To save the library, choose Library → Save.

Adding Characteristics

The characteristics you assign to the library determine the characteristics you can use in the reports contained in the library. The system automatically adds the characteristics to the library that are needed in any case.

To add characteristics to a library:

6. From the Create Library: Header screen, choose Goto → Characteristics.
   The screen Create Library: Characteristics appears.

7. Select the characteristics you want to add to the library.
   If a characteristic is already selected, this means that it was selected by the system automatically.
   To remove a characteristic from the library, deselect the characteristic. You cannot deselect the characteristics that are selected by the system automatically.

8. Enter the following information:
   – If required, enter a standard selection set for the characteristic.
     If all or most of the reports contained in the library use the same set as the selection set, you should enter this as the standard selection set. This standard selection set is then displayed when you create a report assigned to this library.

You enter the standard selection set UN-LEDGER (with the value AB) for the characteristic Ledger. When you create a report with this library, the set UN-LEDGER is displayed on the Create Report: General Data Selection screen.

When you create a report, you can change or delete the standard selection set.

If you delete a standard selection set from the report definition, this set is not automatically deleted from the library concerned. If you want to also delete the selection set from the library, go to the Change Library: Characteristics screen and delete the set from that screen. The reverse also applies: If you want to change the name of a standard selection set in a library, the set name in the reports assigned to the library are not automatically changed at the same time – you must also change
Creating a Library

the set name in each of the affected reports assigned to the library. There is no association between the set name you enter in a library and the value you enter in the report.

- Enter a consecutive number; this defines the order in which the characteristics defined in the library appear in the Report Painter selection lists.

This allows you to position the characteristics that you use regularly in your reports at the beginning of the selection lists.

In the following table are example entries entered in the Pos field for certain library characteristics.

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Pos field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ledger</td>
<td>1</td>
</tr>
<tr>
<td>Company code</td>
<td>2</td>
</tr>
<tr>
<td>Fiscal year</td>
<td>3</td>
</tr>
<tr>
<td>Period</td>
<td>4</td>
</tr>
<tr>
<td>Account</td>
<td>5</td>
</tr>
</tbody>
</table>

If you create a report using the Report Painter, the characteristics will appear in the selection list in the following order: Ledger, followed by Company code, then Fiscal year, Period, and Account.

9. On this screen you can use the additional functions in the table for the Create Library: Header screen (see Entering Header Information), as well as the functions in the following table.

**Additional Functions (Create Library: Characteristics Screen)**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Select all</td>
<td>Select all the characteristics for the library</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all selected items</td>
</tr>
<tr>
<td>Edit → Display set</td>
<td>Display standard default set for a characteristic</td>
</tr>
</tbody>
</table>

10. To save the information entered, choose Library → Save.

**Adding Basic Key Figures**

When you define a library, you can also define the data types that can be used in the reports contained in the library.

If you only want to create reports that use transaction currency, you can define your library so that the reports contained in the library can only use transaction currency.

To add basic key figures to a library:
Creating a Library

6. On the Create Library screen, choose the pushbutton Basic key figures.
   The Create Library: Basic Key Figures screen appears. All basic key figures are automatically assigned to the library.

7. Deselect the basic key figures that you do not want to add to the library.
   If you want to reassign certain basic key figures to the library, you have to reselect the relevant key figures.

8. Enter a consecutive number. This number determines the order in which the basic key figures defined in the library appear in the Report Painter selection lists.
   This allows you to position basic key figures that you use regularly in your reports at the beginning of the selection lists.

9. On this screen, you can use the additional functions in the table for the Create Report: Header screen as well as the functions in the following table.

Additional Functions (Create Library: Basic Key Figures Screen)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Select all</td>
<td>Select all key figures</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all selections</td>
</tr>
</tbody>
</table>

10. To save the basic key figure information, choose Library → Save.

Adding Key Figures

You can use the key figures you define for a library in the column definition of the reports contained in the library. Key figures are made up of a basic key figure and selection criteria for one or more characteristics.

If you only want to create reports that use transaction currency, you can define your library so that the reports contained in the library can only use transaction currency.

To add key figures to a library:

6. On the Create Library screen, choose the pushbutton Key figures.
   The Create Library: Key Figures screen appears. All key figures are automatically assigned to the library.

7. Deselect the key figures that you do not want to add to the library.
   If you want to reassign certain key figures to the library, you must reselect the relevant key figures.

8. Enter a consecutive number. This number determines the order in which the key figures defined in the library appear in the Report Painter selection lists.
   This allows you to position key figures that you use regularly in your reports at the beginning of the selection lists.

9. On this screen, you can use the additional functions in the table for the Create Report: Header screen as well as the functions in the following table.
### Additional Functions (Create Library: Key Figures Screen)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit → Select all</td>
<td>Select all key figures</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all selections</td>
</tr>
<tr>
<td>Edit → Display definition</td>
<td>Display detailed information for the key figure, such as the basic key figure and the additional set used in the key figure</td>
</tr>
</tbody>
</table>

10. To save the key figure information, choose Library → Save.

You can create your own key figures. For more information, see [Creating/Changing Key Figures](#).
Displaying a Library Definition

   
   The Display Library: Initial Screen appears.

5. In the Library field, enter the name of the library that you want to display and choose Header.

6. On this screen, you can use the additional processing functions in the table for the Create Library: Header screen in Creating a Library [Seite 929], as well as the Extras → History function to display the revision history of the library.
Changing a Library


7. In the Library field, enter the name of the library that you want to change and choose Header.

8. On this screen, you can use the additional processing functions in the table for the Create Library: Header screen in Creating a Library [Seite 929], as well as the Extras → History function to display the revision history of the library.

9. Type over existing values with your changes.

⚠️ If you delete existing library characteristics, basic key figures, or key figures, an error will occur during the next generation of any reports in this library that still use the deleted characteristics, basic key figures, and/or key figures.

Also, if you change and/or add a default selection set for a characteristic, the default selection set will only appear when you create future reports; the default selection set will not appear for reports that were defined before you changed or added the default selection set.

10. To save the changes to the library, choose Library → Save.
Deleting a Library

You cannot restore a library once it has been deleted.

Procedure

   The Delete Library: Initial Screen appears.
5. In the Library field, enter the name of the library that you want to delete.
6. Choose Delete.
   A dialog box appears, asking you if you want to delete the library.
   You cannot delete a library that is being used by a report. To see if a library is being used by a report, choose Extras → Use on any library screen.
5. To delete the library, choose Yes.

Result
The system deletes the library.
Report Groups

Use

Before you can output reports, they must be assigned to a report group. With a report group, you can group together reports from one library [Extern] that use similar data but present it in different forms. The database selections from all the reports in a report group are collated, thus avoiding the necessity multiple selections. This improves processing times.

It is appropriate to assign reports to a report group when the reports evaluate essentially the same data. This is because the data is only read once and then distributed to the individual reports.
In order to output a report, you must have assigned it to a report group. Reports that contain the same characteristics and access the same data are contained in one report group. This speeds up processing because the report data is only selected once for all reports and not for each.
report individually. Once the report group has been generated the data is selected from the database and can be output.

**Prerequisites**

To process reports in a report group, they must be assigned to the same library.

**Features**

Once you have created a report you have to create a report group for this report or assign the report to an existing report group. A report group can contain one or more reports. When reports use the same characteristics and share the same data, data is selected faster and processing time is quicker since report data is only selected once for all reports within a report group.

- The reports in a report group are executed at the same time, so that in the report display you can switch between the individual reports.

- The report group name has four characters. As a rule the report group name matches the first four characters of the reports assigned to it. The characters are limited to letters from A to Z, numbers from 0 to 9, and two special characters (- and _).

A number of ABAP programs are generated when a report group is created:

- Program for processing the initial screen
- Program for selecting (reading) the data
- Program to output the selected data
- Program for multiple selection (multiple selection and output for different input data – only if the corresponding indicator is selected)

There are four ways to determine the name of the ABAP program for your report group:

- On the selection screen, choose Environment → Technical information
- On the list output, choose Extras → Technical information
- Transaction GRPE
- Function module G_PROGRAMME_NAME

If a set definition or report definition is changed after the report group is generated, the report group will be regenerated at the time of the next selection unless this function is explicitly switched off in the report group definition.

**Activities**

To create a report group, proceed as follows:
Activities

2. Create the report group.

Specify which reports the report group is to contain. For more information on creating a report group, see Creating a Report Group [Seite 941] and Creating a Report Group from the Report Definition [Seite 948].

You can also change the texts that appear on the selection screen when you execute the report group. For more information, see Report Group Execution [Seite 962], Executing a Report Group [Seite 964], and Executing a Report Group in the Background [Seite 969].

3. Generate the report group.

For more information on generating a report group, see Generating a Report Group [Seite 952] and Generating Report Groups (Mass Generator) [Seite 954]. The report group was generated successfully if there are no errors in the report group.

5. Select the data for the report group.

The system selects the data that appears in the reports defined in the report group.

6. Display or print the reports in the report group.

The system edits and formats the data that has been selected for the report group and then presents the report group’s reports in the output medium requested (online, printer, spool file, external file, and so on). For more information on displaying a report group, see Displaying a Report Group [Seite 949]. For information on printing, see Functions in the Report Output [Seite 974].

If you want to display a new report, you must add the report to an existing report group or create a new report group that contains the report.

If you output a report that has been changed, you only need to regenerate the report group and select and display report data. The report group does not need to be redefined.

Suppose you change the set used as a row block in report TD-ASSETS. You must regenerate the report group, select the report data, and display the report. You do not need to change the report or the report group.

For more information on working with report groups and reports, see:

Changing a Report Group [Seite 950]
Deleting a Report Group [Seite 951]
Varying Report Data [Seite 970]
Extracts [Seite 1008]
Creating a Report Group

Use

A report group is a collection of reports from one library [Extern] that are to be output together. You use a report group to collate reports that are similar in order to improve performance.

Before you can output reports, you must have assigned them to a report group. You can either assign a report to an existing report group or create a new report group for it. For more information on report groups, see Report Groups [Seite 937].

To create a report group you can either proceed as described below or create the report group from the report definition. For more information, see Creating a Report Group from the Report Definition [Seite 948].

Procedure


4. Enter a name for the report group. The name must have four characters. You can create a report group in either of the following ways:
   - Copy an existing report group

     Enter the name of the existing report group that you want to copy in the Copy from - Report group field. When the report group is copied, the library assigned to it is copied automatically as well.

   or

   - Create a new report group based on a library

     Enter the name of the library of the reports you want to include in the report group in the New entry - Library field. All reports in a report group must be in the same library.

8. Enter header information for the report group. To do this, choose Goto → Header. The Create Report Group: Header screen appears. For more information about entering header information, see Entering Header Information for a Report Group [Seite 943].

9. If you want to enter detailed documentation for the report group, choose Goto → Documentation. This procedure is the same as the one used to define report documentation. For more information, see Defining Report Documentation [Seite 945].

10. To add reports to the report group, choose Goto → Reports from one of the Create Report Group screens. The Create Report Group: Reports screen appears. For more information on entering reports, see Adding Reports to a Report Group [Seite 946].

Creating a Report Group

12. To save your entries, choose Report group → Save. You can now execute the report group. For more information, see Report Group Execution [Seite 962], Executing a Report Group [Seite 964], and Executing a Report Group in the Background [Seite 969].
**Entering Header Information for a Report Group**

**Use**

A report group contains reports from one library that use similar data and present this data in different ways. The header information of a report group contains information that is valid for the report group as a whole (such as setting or suppressing the indicator for the regeneration of the report group and the configuration of the report/report interface).

If you define reports for the report/report interface in both the report group header and in the report group’s library, the system uses the reports that you have defined specifically for the report group.

**Prerequisites**

You have reached step 3 of the procedure Creating a Report Group [Seite 941]. On the Create Report Group screen you have already chosen Goto → Header and are on the screen Create Report Group: Header.

**Procedure**

3. Enter a short description for the report group. If you have copied an existing report group, the description of this report group is displayed here automatically. You can, however, change it.

4. In the group box Generation, you should only select the Not automatic indicator if you do not want the system to display a dialog box asking whether you want to regenerate the report group when a report definition or report sets have been changed.

   If you select this indicator, when you call the report group only a warning message will appear telling you that this is not an up-to-date generated report group. Until the report group is regenerated, you can only call it with the definitions valid at the time of the last generation.

   Report groups are regenerated automatically after importing Support Packages, after an upgrade or after a release upgrade, even if you have set the Not automatic indicator. The system also automatically regenerates report groups if the programs generated, or the stored definitions and sets, have been deleted.

6. If you want user authorization to be required for creating, displaying, maintaining, and executing the report group, enter the name of an authorization group in this field.

7. In the Report/report interface group box, choose Configure to define receiver reports that you want to call up when you output your report data.

   You can define reports for the report/report interface in both the report group header and in the report group’s library. The reports you enter in the library are valid for all reports that use the same library. If you define reports for the report/report interface in both the report group header and in the report group’s library, the system uses the reports that you have defined specifically for the report group.
Entering Header Information for a Report Group

The reports you enter as the receiver reports can be Report Writer reports, Report Painter reports, ABAP programs, report portfolio reports, drilldown reports, or transactions.

For more information about defining reports for the report/report interface, see Defining Reports for the Report/Report Interface [Seite 924].

You must save your report group definition before you can enter receiver reports for the report/report interface.

You can use the following processing functions on the Create Report Group: Header screen:

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter reports for the report group</td>
<td>Goto → Reports</td>
</tr>
<tr>
<td>Enter text for the selection screens</td>
<td>Goto → Texts</td>
</tr>
<tr>
<td>View revision history of report group</td>
<td>Extras → History...</td>
</tr>
<tr>
<td>For utilities, see Report Writer Utilities [Seite 912]</td>
<td>Utilities</td>
</tr>
</tbody>
</table>

7. To save the report group, choose Report group → Save.

Result

You have entered header information for a report group and can now continue with step 4 of the procedure for creating a report group [Seite 941].
Defining Report Documentation


11. Enter the report documentation as desired.

   For more information about the use of the SAPscript editor for word processing, see the SAP Library under Basis Components → Basis Services/Communication Interfaces (BC-SRV) → SAPscript (BC-SRV-SCR).

12. Choose Text → Save.

   You will now be able to display the report documentation when you output the report. The name under which the documentation is stored is also displayed.

   The name of your report library is Z01, and your report name is Z-REPO. When you define report documentation, it is stored under the report name R_Z01_Z-REPO, where R is for report, Z01 is the library name, and Z-REPO is the report name.
Adding Reports to a Report Group

Prerequisites
You have reached step 5 of the procedure creating a report group [Seite 941] or you want to add an additional report to a report group. On the Create Report Group screen you have already chosen Goto → Reports and are on the screen Create Report Group: Reports.

Procedure
2. In the Report field, enter the name of the report that you want to add to the report group. You can enter more than one report.
   The Report Writer processes the reports in the same order that you list them. To optimize processing time, the reports that you include in a report group should have the same characteristics and use the same data.
3. To save the report group, choose Report group → Save.
   You can use the following additional processing functions on the Create Report Group: Reports screen:

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add additional reports to report group</td>
<td>Edit → New entries</td>
</tr>
<tr>
<td>Insert report between two other reports</td>
<td>Edit → Insert row</td>
</tr>
<tr>
<td>Delete report from report group</td>
<td>Edit → Delete row</td>
</tr>
<tr>
<td>Enter header information for the report group</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>Enter text for the selection screens</td>
<td>Goto → Texts</td>
</tr>
<tr>
<td>Display where a report defined for the report group is used</td>
<td>Extras → Report usage...</td>
</tr>
<tr>
<td>Change definition of report assigned to report group</td>
<td>Extras → Report definition</td>
</tr>
<tr>
<td>For utilities, see Report Writer Utilities [Seite 912]</td>
<td>Utilities</td>
</tr>
</tbody>
</table>

Result
You have added a report to a report group and can now continue with step 6 of the procedure for creating a report group [Seite 941].
Entering Selection Texts for a Report Group

Prerequisites

Procedure
3. Enter texts as required.
   The text that you enter for the fields on this screen appears on the selection screen when you execute the report group.

4. To save the report group, choose Report group → Save.
   You can use the following additional functions on the screen Create Report Group: Texts for Selection Screens:

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add additional reports to report group</td>
<td>Edit → New entries</td>
</tr>
<tr>
<td>Insert report between two other reports</td>
<td>Edit → Insert row</td>
</tr>
<tr>
<td>Delete report from report group</td>
<td>Edit → Delete row</td>
</tr>
<tr>
<td>Enter header information for the report group</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>Enter reports for the report group</td>
<td>Goto → Reports</td>
</tr>
<tr>
<td>Display where a report defined for the report group is used</td>
<td>Extras → Usage → Report usage...</td>
</tr>
<tr>
<td>Enter additional parameters for displaying selection texts (for example, to specify whether selection values should appear before selection sets)</td>
<td>Extras → Additional parameters</td>
</tr>
<tr>
<td>For utilities see Report Writer Utilities [Seite 912]</td>
<td>Utilities</td>
</tr>
</tbody>
</table>

Result
You have entered selection texts for a report group and can now continue with step 7 of the procedure for creating a report group [Seite 941].
Creating a Report Group from the Report Definition

Use

You can use this function to create a new report group without having to call the Create Report Group function. When you create, change, or display a report definition, you can execute the report’s report group directly and output the report.

Prerequisites

You want to create, change, or display a report. You have called one of the functions Create/Change/Display Report and have saved your report.

Procedure

6. Choose Report → Execute. If the report is not already assigned to a report group, a dialog box appears asking whether you want to perform this assignment.
7. To assign the report to a report group, choose Yes.
8. If you enter a report group that does not exist, a dialog box appears asking whether you want to create the report group.
9. If you want the system to create the report group automatically and assign your report to it, choose Yes.
10. You can then execute the report group on the screen Execute Report Group: Initial Screen. For more information, see Report Group Execution [Seite 962], Executing a Report Group [Seite 964] and Executing a Report Group in the Background [Seite 969].

For more information on creating report groups, see Creating a Report Group [Seite 941].
Displaying a Report Group


4. Enter the name of the report group you want to display. You can use the following processing functions on the Display Report Group: Initial Screen:

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display header information for the report group</td>
<td>Goto → Header</td>
</tr>
<tr>
<td>Display reports of the report group</td>
<td>Goto → Reports</td>
</tr>
<tr>
<td>Display texts for the selection screens</td>
<td>Goto → Texts</td>
</tr>
<tr>
<td>Display report group documentation. See defining report documentation [Seite 945]</td>
<td>Goto → Documentation</td>
</tr>
<tr>
<td>Display report group directory</td>
<td>Utilities → Catalog</td>
</tr>
<tr>
<td>Generate report group. See generating report groups [Seite 954]</td>
<td>Utilities → Mass generator</td>
</tr>
</tbody>
</table>
Changing a Report Group

Prerequisites
If you change a report definition and/or the sets used in the report, you do not have to change the report groups that contain the report. You must, however, regenerate the report group that contains the changed reports.

Procedure
6. Enter the name of the report group you want to change and choose Header.
7. Type over existing values with your changes.
   For more information about the functions you can use on the Change Report Group screens, see the tables in creating a report group [Seite 941].
8. To save the report group, choose Report group → Save.

Displaying Selection Statistics for a Report Group
You can display statistics on the number of data selections made for a particular report group. This allows you to determine which reports are often or seldom used in a productive system.

To display the selection statistics for a report group:
Choose Extras → History.

The Report Group: History dialog box appears, displaying the revision history of the report group, as well as the name of the user who made the last data selection and the number of times that data has already been selected for the report group.

You can reset the data selection counter to zero by choosing Reset.

You can also display data selection statistics in the report output (Edit → Selection log) and in the report group directory (Utilities → Catalog).
Deleting a Report Group

You cannot restore a report group once it has been deleted.


6. Enter the name of the report group that you want to delete.

7. Choose Delete. A dialog box appears, asking you if you want to delete the report group.

8. To delete the report group, choose Yes. The system deletes the report group.
Generating a Report Group

Use

Once you have defined a report group, the next step is to generate the report group. When you generate a report group, any errors and/or warnings found in the report group’s reports are displayed on the screen. Since the Generate function uses your report definition to generate ABAP programs, you must regenerate the report group whenever you change the report definition or when you change the sets used in the report.

Before you generate a report group, you should check all of the report group’s reports for errors using the Report → Check function. Your processing time will be quicker if you check the reports and then correct the errors and warnings in the reports before you generate the report group. For more information, see Checking a Report [Seite 813].

Report groups are regenerated automatically after a Support Package has been imported. If you change an object used in a report group and in the header attributes of the report group, in the group box Generation, the indicator Not automatic is not checked, the system regenerates the report group without issuing a query.

When you generate a report group, the system uses the standard layout and texts that are assigned to the report according to the language you signed on in.

- If you sign on to the system in English, the system uses the English version of the standard layout and texts assigned to the report.
- If you sign on to the system in German, the system uses the German version of the standard layout and texts assigned to the report.

If reports are to be available in several languages, you must define the languages concerned in Customizing. For more information, see the Implementation Guide (IMG) for Special Purpose Ledger under Information System → Define Report Writer Languages [Exter].

For more information about standard layouts and the languages assigned to them, see Standard Layouts [Seite 1017].

Procedure

   
   The Execute Report Group: Initial Screen appears.

   You can also generate a report group from the Create/Change/Display Report Group screens by choosing Report group → Generate.

3. Enter the name of the report group that you want to generate.
When you generate a report group, the system deletes any existing data extracts defined for the report group. The system first displays a dialog box where you can either select the extract stored or a new selection is made. For more information on defining saved report data, see Executing Report Groups [Seite 964].


The system begins to generate the report group. When the system has finished generating the report group, a dialog box appears, displaying any errors or warnings that occurred during generation.
Generating Report Groups (Mass Generator)

   

5. Enter the data as required.
   
   The data you enter determines the report groups that are selected for display.

6. Check the following settings according to your requirements:

   **Generate w/o selection list** determines whether the report groups are generated automatically. If you select **Generate w/o selection list**, you do not select the report groups to be generated from a selection list.

   If you are generating report groups in the background, you should select **Generate w/o selection list**, since it is not possible to manually select the report groups to be generated in background processing.

   **Generate only if necessary** determines that the system only generates the report groups if necessary. For example, it would be necessary to regenerate a report group if the set definition in a row block has changed. If you do not select **Generate only if necessary**, all report groups that meet the criteria entered on this selection screen are generated.

5. Choose Program → Execute.

   A directory listing of generated report groups that meet the criteria you entered appears.

6. You can use the following additional processing functions after you have displayed a directory listing of generated report groups.

**Additional Processing Functions - Directory Listing of Generated Report Groups**

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter new selection criteria for generating report groups</td>
<td>Generate → New selection</td>
</tr>
<tr>
<td>Select a report group for generation</td>
<td>Select</td>
</tr>
<tr>
<td>Select all report groups for generation</td>
<td>Edit → Select all</td>
</tr>
<tr>
<td>Deselect the selected report groups</td>
<td>Edit → Deselect all</td>
</tr>
<tr>
<td>Display all report groups (you can use this function after you have selected the <strong>Disp. selctd entries</strong> function)</td>
<td>Edit → Display all</td>
</tr>
<tr>
<td>Display only the report groups that have been selected for generation</td>
<td>Edit → Disp. selctd entries</td>
</tr>
</tbody>
</table>

7. Select the report groups that you want to generate.
8. Choose Generate. Statistical details about the report groups generated by the system are displayed on the Report Writer: Generate Report Groups screen.
Scheduling a Report Group as a Background Job

2. On the Execute Report Group: Initial Screen, choose Utilities → Background job →
   - Mass generator (to define a background job for report data selection)
   - Multiple selection (to define a background job for a report group that has variable input parameters)
   - Mass generator (to define a background job for generating report groups)

   The Define Background Job screen appears.

3. Enter a job name and the target host on which the background job should run.

   You use the job name to execute the report group in the background.

   For more information on defining and executing a background job, see the SAP Library under Getting Started → Background Processing.

   To execute report groups in the background use the program RGRWSUBMIT. For more information, see the corresponding program documentation.
Deleting Generated Code for Report Groups

Prerequisites

Extensive programming code is generated when a report group is generated. Since many report groups are usually created during system testing, extensive storage space is needlessly allocated. In this case, you may want to use the Delete programs function to delete all generated report group code.

If you delete generated report group code, only the generated programming code is deleted and not the report definitions. When you execute a report group, any deleted code is automatically regenerated.

Procedure

   A dialog box appears, asking you if you want to delete the generated code.

5. Choose Yes to delete the generated code.
   A dialog box appears, asking you if you want to delete the generated code online or in the background.

Since this program can require extensive system processing time to execute, it is recommended that you execute the program in the background.

6. Select either Online or Background.
   If you select Online, the system begins deleting the generated code.
   If you select Background, the screen for defining a background job appears.

For more information about defining and executing a background job, see the SAP Library Background Processing System: Overview documentation (Working with R/3 → Getting Started with R/3 → Background Processing).
Creating Report Group Variants

You can define several variants for the same report group. A **variant** is a group of selection criteria values that have been saved for a report group. Instead of entering the same selection criteria each time you execute a report group, you can create a variant for each set of selection criteria.

You create a variant for a report group specifying that only report data for cost center 100 is selected for the report. You can create a second variant where report data for all the cost centers is selected.

**Procedure**

7. On the **Execute Report Group: Initial Screen**, choose **Utilities → Variant maintenance →**
   - **Execute** (to create a variant for report data selection)
   - **Multiple selection** (to create a variant for a report group that has variable input parameters)
   - **Mass generator** (to create a variant for generating report groups)

   The ABAP: **Variants - Initial Screen** appears.

   The **Program** field is automatically filled. The report names appear as follows, depending on the function you selected:
   - **J<Report Group><Client>X** when you are creating a variant for report data selection.
   - **J<Report Group><Client>T** when you are creating a variant for a report group that has variable input parameters (multiple selection).
   - **RGRJBG00** when you are creating a variant for generating report groups.

8. In the **Variant** field, enter the variant name.

9. Choose **Variants → Create**.

   The **Maintain Variants: <Program Name> Variant <Variant Name>** screen appears.

10. Enter the data as required.

    **For selecting report data**, enter the values and sets for selecting report data. Enter extract and output data as required.

    **For entering variable input parameters for a report group**, enter the variable values and/or sets and the output parameters for the variant.

    **For generating report groups**, enter the selection criteria for generating the report groups.

11. Choose **Continue**.

    The **ABAP: Save Variant <Variant Name>** screen appears.

12. Enter the data as required.

    For more information about the fields on this screen and creating a variant, see the SAP Library **Pre-Setting Selections Using Variants** documentation (Basis Components → ABAP Workbench (BC-DWB) → ABAP User’s Guide → Writing ABAP Reports).
Exporting and Importing Report Group Variants

You can use the Transport variants function to transport report group selection variants between different systems. A selection variant is a group of selection criteria values that have been saved for a report group when the report group was executed.

To transport variants, you first export them to a local file and then import them from the local file into the target system.

**Procedure**


   The Export/Import Report Group Variants screen appears.

7. Enter data as required.
   
   The report group(s) and/or library(ies) that you enter determine which variants are exported or imported.

   If you enter both several report groups and libraries, the system selects only those report groups that use the specified libraries.

8. Choose whether you want to export the variants to a local file or import the variants from a local file.

9. Enter the export or import file name.

   If the export file does not exist, the system creates it; if the file already exists, the system overwrites the existing file without warning.

   ![File symbol]

   For a Windows operating system, the file name consists of a drive, path, and a name, such as C:TEMPVARIANTS.

10. Choose Program → Execute.

**Result**

The variants in the current client are exported to or imported from the file you specified in the Local export/import file field. The system displays a message informing you that the export/import has been successfully completed and lists the variants that have been exported to or imported from the local file.

![Message symbol]

During import, the system only imports variants for existing report groups.
Copying Report Group Variants from Other Clients

You can use the Copy var. frm client function to copy report group selection variants between different clients in the same system. A selection variant is a group of selection criteria values that have been saved for a report group when the report group was executed.

Procedure

   
The Copy Report Group Variants from Client screen appears.

5. Enter the following data:
   – Source client from which you want to copy the variant(s)
   – Report group(s) and or library(ies) to determine which variants are copied to the client in which you are working
     If you enter both several report groups and libraries, the system selects only those report groups that use the specified libraries.

6. Choose Program → Execute.

   The system copies the variants that meet the selection criteria from the source client to the client in which you are working.
Report Group Execution

Use

The final step in defining a report group [Seite 937] is executing the report group.

When you execute a report group, the system selects the data for the report group’s reports according to the selection criteria you enter. The system selects the data from either the original database or from an extract file.

When the system selects data from the original database, it must first select and then format the relevant data records. Depending on the volume of data, the selection process can be very time-consuming, especially for the analysis of larger data volumes.

To improve processing times, we recommend that you save your reports periodically in extracts. An extract [Seite 1008] only contains the report data (including the structure information) needed to display the report. When you call up an extract, the system only accesses the extract file and therefore reads fewer data records. When you call up a report using an extract, the system only accesses the extract file and therefore reads fewer data records. As a result, processing time improves considerably.

Features

You can either execute a report group [Seite 964] directly or execute a report group in the background [Seite 969]. When you execute a report group, the system determines whether data extracts already exist for the selection criteria you enter. If data extracts already exist, the system displays a dialog box, listing the existing extracts. Additionally, you can choose the option Display Newest Extract.

If there are no extracts for the selection criteria you enter, the system selects the data from the database and displays the report.

You can retrieve and analyze the data stored in an extract file at any time without impairing the system load.

When you perform a release upgrade, all reports that you saved as extracts are deleted because the Report Writer regenerates all report groups. However, the extracts are not deleted when you upgrade the maintenance level of your R/3 System.

At a release upgrade, the only way to save the report list is to archive the spool list using the print function. In the Print dialog box, you must change the archiving mode to Archive only or Print and archive. A spool file is then archived. You can later retrieve the archived spool file to print your report list.

You can also execute a report group in the following ways:

- Vary input parameters for a report group using the Multiple selection function.
You should only use multiple selection when absolutely necessary, for example for variation over a controlling area in Overhead Cost Controlling).

The reports in your report groups should usually all contain the same variables, so that the input parameters are used for all reports in the report group.

For more information, see varying report data [Seite 970].

- Select and output data that has been saved in archive files.
- Select report data, display the report, and vary input parameters in the background.
  
  To improve performance, you should use background processing to execute reports that analyze larger volumes of data. For more information, see executing a report group in the background [Seite 969].

- Create variants for executing reports in the background. For more information, see creating report group variants [Seite 958].

For more information on processing report output, see functions in the report output [Seite 974].
Executing a Report Group

You can execute reports from two different menus that have different functions. The standard mode contains all the basic functions that you require to execute a report. Special functions, that experience has shown to be used by only a few users or that require special knowledge of the Report Writer, can only be used in expert mode. You can call the expert mode from the selection screen or activate/deactivate it from the report output screen at any time. The expert mode is not connected to any authorization. For more information on the advanced functions available for executing report groups, see Expert Mode [Seite 978].

   
The Execute Report Group: Initial Screen appears.

5. Enter the name of the report group and choose Execute.
   
The <Report Group Name>: Selection screen appears.

6. Enter values for selecting the report data.
   
   If your report group contains more than one report, use Reports to select a report. The data is always selected for all reports in the report group.
   
   If there are variables in your report, the system prompts you to enter information for the variables in the selection screen.
   
   – If you defined value variables in your report, enter a value(s) for the selection of report data.
   
   – If you defined set variables in your report, enter a set name and/or values for selecting report data.
   
   For example, suppose you enter a set variable for the characteristic Account in a report created for table GLT1. When you execute the report, you can use a cost element group (characteristic Cost Element in table CCSS) to replace the default set.

   If you don’t enter a set or value on the selection screen, data is selected for all possible values for the relevant characteristic.

   For example, you can enter set variables for the characteristics Cost Center and Cost Element in the general data selection criteria of your report. When you execute the report’s report group, you do not enter a set or value for the cost element, and you enter 100 for the cost center. When the Report Writer selects the report data, it selects data for cost center 100 and for all possible cost elements.

5. To determine which data is used in the report, use the Data source... button.
   
   Set one of the following indicators as required:
If you want to display a list of extracts that have already been saved for the selection criteria you entered, select Display extract. The system displays a dialog box listing the extracts. For more information, see Extracts [Seite 1008].

If you want to reselect data from the database, choose New selection. You can create an extract for the selection criteria you enter using the Create extract function (see step eight).

If you want to read data from archive files, choose Read from archive. This indicator only appears for reporting tables that allow you to read data from archives.

For the system to read data from the archive, you must enter an archiving object in the subsequent dialog box. You then select the archive file from which the system reads the data by choosing Archive selection.

If you have chosen the data source New selection or Read from archive, you can save the selected data as an extract by choosing Extract Parameters on the screen <Name of report group>. Selection and then choosing Create extract in the dialog box. You can choose between Do not create extract and create extract. When you create your selection criteria for an extract, the system selects the data from the database if you have not selected the data source Read from archive. For more information, see Extracts [Seite 1008] and Creating an Extract [Seite 1010].

It is important that you enter extract data if you execute the report in the background. For more information on executing reports in the background, see Executing a Report Group in the Background [Seite 969] and Scheduling a Report Group as a Background Job [Seite 956].

6. To execute the report, choose .

Depending on the settings under data source and the settings for extract management, existing extracts are shown in a dialog box for your selection criteria.

If you want to use one of the existing extracts, double-click the relevant extract.

If you do not want to use any of the existing extracts, you can choose New selection to select the data from the database.

The dialog box also appears if an extract has been saved for a report that contains a variation hierarchy and the selection criteria you enter correspond to a report within the variation hierarchy. In this case, the system directly accesses the relevant report within the existing variation hierarchy. That is, the system processes each report within the variation as if it were a separate data extract.

**Result**

If you called up the report using an extract, the system outputs the report using the extract data.

If you called up your report by selecting data from the database, the system outputs the report according to the selection criteria you entered and formats the report according to the report definition.

For more information on the functions you can use in the report output, see Functions in the Report Output [Seite 974].
Saving Report Data in Microsoft Excel

Exporting a report in RPW format (export to Microsoft Excel) has been superseded by Office Integration [Seite 990]. This can be activated from the selection screen or in the report output by the user. The Excel export in RPW format is no longer supported. Display the report with Office Integration and save it as an XLS file, for example.
Exporting Report Data to the Executive Information System (EC-EIS)

Exporting Report Data to the Executive Information System (EC-EIS)

Use
You can export report data to the Executive Information System [Extern] (EIS) when you execute a report group [Extern]. The report is generated and the data is transferred directly to EIS.

You can transfer report data to EIS for report groups that only contain one report.

Prerequisites
The report must fulfill the following requirements before it can be transferred to EIS:

- Zero rows and zero columns must not be hidden in the report’s standard layout [Seite 1017].
- Row blocks:
  - All row blocks must contain the same characteristics in the same order.
  - The suppress indicator may not be set in any row block.
  - All row block characteristics must have total level 0, 1-, or 2-.
  - If the Form printout indicator is set, intervals may not be entered in any row block.
- Column blocks must be key figure sets.
  These key figure sets must not contain any formulas and the key figures cannot have an additional set.
- Only basic [Seite 639] or single-dimension [Seite 643] sets can be used as selection criteria in general data selection. These sets can only contain one value.

Procedure
When executing a report, choose from the selection screen Output parameters... and then in the Output medium group box, Data transfer to EIS.

Result
The report is generated and the data is transferred directly to EIS. You can also transfer the report data in the background.

For more information about executing report groups, see Executing a Report Group [Seite 964].
Executing a Report Group in the Background

   The Execute Report Group: Initial Screen appears.
8. Enter the name of the report group and choose Execute.
   The <Report Group Name>: Selection screen appears.
9. Enter the report selection criteria as required.
10. Choose Program → Execute in background.
    The Background Print Parameters dialog box appears.
11. Enter the printer name to which you want to send the report and other data as required
    (spool request, and so on).
12. Choose Continue.
    The background job is executed.

For more information on creating a background job, see the SAP Library under Getting Started → Background Processing.
Varying Report Data

Use

You can vary report data directly within a report on the screen Create Report: General Data Selection. Both functions are used to create the same type of report (with a common report definition), but using different input data.

SAP recommends that you use variation, and only use multiple selection in exceptional cases.

The following table gives an overview of the main differences between the Variation of the selection and Multiple selection functions. For more information on these functions, see the Varying Levels of Data in a Report Definition (Variation of the Selection) and Varying Input Parameters for a Report Group (Multiple Selection) below.

Advantages of Variation Compared with Multiple Selection

<table>
<thead>
<tr>
<th>Variation of the selection</th>
<th>Multiple selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ Individual values in sets/hierarchies can be broken down and output in the report.</td>
<td>- Individual values cannot be broken down; only the set/hierarchy nodes can be varied.</td>
</tr>
<tr>
<td>+ Improved system performance since data is selected once only.</td>
<td>- System performance is slower since data must be selected for each report.</td>
</tr>
<tr>
<td>+ Report output can be viewed directly online; you can navigate within the report online.</td>
<td>- You cannot navigate within the report.</td>
</tr>
</tbody>
</table>

Variation using characteristics in general data selection | Multiple selection using variables

For more information, see Variation [Extern].

Varying Levels of Data in a Report Definition (Variation of the Selection)

Using the Vary Frm/To and S fields on the Create Report: General Data Selection screen, you can define the variation level in a report. When you enter variation data in the report definition, the variation function is automatically activated.

When you execute the report, the system generates a report for each hierarchy element within the variation levels defined in the report. That is, it creates a summarized report for all characteristic values, plus a report for every node and single value in the hierarchy. The database is read only once during the data selection process for all variation levels.

If a report definition includes a definition for the Vary Frm/To and S fields, you can execute a report group in the following ways:

- Select data and output it to the screen.
  
  You can use the navigation bar to navigate back and forth between reports. (You activate the navigation bar with on the output screen)
• You can select data and print the report.
  All existing variation reports are printed.
• You can create a background job for the report group and print the output.
  All existing variation reports are printed.

For more information on using the Vary Frm/To and S fields, see Defining Selection Criteria [Seite 835].

Varying Input Parameters for a Report Group (Multiple Selection)

You use the multiple selection function when you want to execute a report group and enter different values for the variables of the report group.

When you use value and set variables within a report and you execute the report's report group using the Multiple selection function, the system prompts you to enter values/sets for the variables defined in the report.

• When you use value variables in a report, you can enter single values or value ranges for executing reports.
• If you use set variables in a report, you can vary the data for the different set levels. (You cannot use single values to vary the data.)

The system generates a separate report for each value entered in the input parameters and sends the report data directly to a spool file or saves the report in an extract. The database is read separately for each report that is produced.

In your report definition, you enter a value variable for the characteristic "Year" as general data selection criteria. When you execute the report using the Multiple selection function, the system prompts you to enter a specific year or years and/or a range of years. The system creates a separate report for each year you have specified in the input parameters.

If you want to vary the input parameters, either do this directly in the report definition (using the Vary Frm/To and S fields) or during report execution (using the Multiple selection function); do not do both for a given characteristic.

In Overhead Cost Controlling, you can use multiple selection for the characteristic controlling area and variation using the characteristic cost center.

Procedure

    The Execute Report Group: Initial Screen appears.
11. Enter the name of the report group and choose Multiple selection.
    The <Report Group Name>: Multiple Selection screen appears.
12. Enter the data as required.
**Varying Report Data**

*Fixed values fields*
Enter the fixed values for the report group.

*Vary values fields*
Enter the selection values for the report group.

*Vary sets fields*
Enter the selection sets for the report group.

The set that you enter in place of the default set variables does not have to belong to the same table and characteristic as the set variable. However, the field used by the set must be compatible with the field of the default set.

For example, suppose you enter a set variable for the characteristic *Account* in a report created for table GLT1. When you execute the report, you can use a cost element group (characteristic *Cost Element* in table CCS) for the set variable.

You create a report group containing a report that uses the value variable TD-YEAR (characteristic *fiscal year*, default value 1997) and the set variable TD-COMP (characteristic *fiscal year*). For this report group, you enter several years for the value variable TD-YEAR. The system then creates a report for each year that you specify. For the set variable TD-COMP, you could create a report for each set node of the set hierarchy that has been entered for the set variable TD-COMP.

If you enter a set, you have to define how you want to process the set when you output the report:

Set the *Fixed* indicator if you do **not** want to explode all nodes of the set hierarchy in the report output. The system only outputs report data for the set you enter.

Do not set the *Fixed* indicator if you want to explode the set hierarchy. The *Hierarchy* indicator determines how the set hierarchy is exploded in the report output:

- If you select *Hierarchy*, the system processes the set you enter, as well as all sets at lower levels in the hierarchy.
- If you do not select *Hierarchy*, the system only processes the set nodes at the lowest level in the hierarchy (the basic sets).

13. To enter output information for the report, choose *Output parameters*.

For more information, see [Expert Mode][1] and [Executing Report Groups][2].

14. To save the output parameters, choose *Continue*.

15. You can save the reports as extracts by choosing *Generate extract*. When you create an extract for your selection criteria, the system selects data from the database.

For more information on the data you enter in the extract dialog box, see [Extracts][3].

---

[1]: #/pages/978
[2]: #/pages/964
[3]: #/pages/1008
If you upgrade the release (such as from 4.5B to 4.6C), the reports saved as extracts can no longer be displayed. If you upgrade the maintenance level of your R/3 System (such as from 4.6A to 4.6B), the extracts can still be displayed.

The only way to save the report list when you upgrade the release is to archive the spool list using the print function. In the Print dialog box, you must change the archiving mode to Archive only or Print and archive. A spool file is then archived. You can later retrieve the archived spool file to print your report list.

16. To save the extract parameters, choose Continue.

17. Specify whether you want to perform a test run of multiple selection.

   If you select Test run, the system only outputs the report log.

18. To execute the multiple selection, choose Program → Execute.

**Result**

If you selected Test run, the system displays the report protocol of values that were input for the report, as well as the value variable(s) and set variable(s) used to select report data. The protocol also lists the number of reports created.

If you did not select Test run, the system outputs the reports according to the selection criteria and the output medium you entered.
Functions in the Report Output

Use
When you execute a report group, the system selects the data for the report group’s reports according to the selection criteria you enter. The system selects the data from either the database or reads the required report from an extract file, and then outputs the report.

The report data is presented according to the output format you defined.

If you specified that the report be displayed on your screen, you can perform various functions in the report. For example, you can navigate through the report data.

Additional functions are available in Expert Mode. For more information, see Expert Mode [Seite 978].

Features
The most important functions available in the report output include:

- Print report
  For more information, see Printing Report Data [Seite 982].
- Send report to mail user
  For more information, see Sending Reports to Mail Users [Seite 992].
- Select report data
  For more information, see Selecting and Deselecting Report Data [Seite 993].
- Sort report rows
  For more information, see Sorting Report Rows [Seite 997].
- Navigate within a report
  For more information, see Navigating Within a Report [Seite 998].
- Call up report graphics
  For more information, see Calling Up Report Graphics [Seite 999].
- Call up reports using the report/report interface
  For more information, see Calling Up Reports via the Report/Report Interface [Seite 1000].
- Navigate within variation settings

  Varied data selection characteristics are those characteristics that you entered for selecting report data (on the Create Report: General Data Selection screen), for which you have also entered values in the Vary Frm/To and S fields. When you enter varied data selection characteristics, you can control the level of detail that appears in the report.

  When the report is output, you can use the Goto → Variation → … function to display varied detail levels of report data for the data selection characteristics.

  Using the Graphical selection function, you can:
Functions in the Report Output

- Select (highlight) a new characteristic value within the active characteristic.
- Select a new characteristic and display the set structure of the characteristic.
  Variation functions under the Goto ➔ Variation menu option include:
  - Variation left and Variation right
    Using these functions, you can navigate within one hierarchy level.
  - Variation previous level and Variation next level
    Using these functions, you can navigate to the next higher level or the next lower level of the displayed characteristic.
    For example, if you select a single-dimension set that contains a basic set and choose Goto ➔ Variation ➔ Variation next level, you navigate to the basic set level.
  - First/Previous/Next/Last setting
    For more information, see Navigation in the Variation Settings [Seite 1002].

- Work with report hierarchies
  Expand/collapse
  You can expand and collapse rows, sections, and reports (completely or individual levels).

  Summation level
  The totals rows in a report are represented by summation levels.
  For more information, see Summation Levels [Seite 1034].

- Modify the report layout [Seite 1029]
  - Layout parameters
    The layout parameters for the report output are determined by the standard layout assigned to the report. This includes the page format of the report and the numerical format of the report data.
    A section layout [Seite 1028] can be defined separately for each section. To define a layout [Seite 1016] for a certain section, double-click on the section and then make the settings for the column attributes.
    You can change the report’s layout parameters under Settings ➔ Report layout.
    If you change the layout parameters, but then decide that you want to reuse the default values from the standard layout, you can do so by choosing Settings ➔ Report layout ➔ Use standard layout.
    For more information on standard layouts, see Standard Layouts [Seite 1017].
  - Column width
    You can change the widths of the lead column and the data columns by choosing Settings ➔ Column attributes.
    You can also define the column widths for individual format groups in the layout parameters under Settings ➔ Report layout ➔ Columns ➔ Other format groups.

- Numerical format
Functions in the Report Output

You can change the format of the displayed report values using the Settings → Report layout → Representation → Numerical format function. You can enter the following data for each format group:

- Number of decimal places
- Scaling
- Column width
- Unit column in the report (that is, whether the column for the currency units or units of measure is displayed in the report).
- Change +/- sign information
  You can also enter the numerical format data for individual format groups here by choosing Other format groups.

• Define report texts

You can only change texts in the report output if the report uses a standard layout in which the Change allwd dur exctn indicator is set on the Page/Control screen. You cannot change texts in standard reports included with your SAP R/3 System.

For more information on entering report texts, see Defining Report Texts [Seite 825].

• Selection log

You can display and print the report’s selection log using the Extras → Selection log function.

The selection log provides statistics on the data selection. These include:

- Runtime of the selection and output programs
- Number of records read from the database tables
- Percentage of the data records used in the report
- Number of records not used in the report on the basis of authorization checks
- Number of data records used in the current report group

• Messages

If the system issues any warning messages when the report is executed, you can display these messages using the Extras → Messages function.

If more than one message is issued when the report data is selected and formatted, the system displays only one message, informing you that several messages have been issued.

• Technical information

You can display technical information on the report execution using the Extras → Tech. information function. The system displays the program names for the selection, output, and multiple selection, as well as information on the report’s library and report group.

• Annotations
You can enter explanatory text for the report using the *Extras → Annotation* function. This text displays after the last report page. You enter annotation text using the SAPscript editor.

- **Report documentation**
  You can display and print the report documentation by choosing *Extras → Documentation → Report*.

- **List/display/change report definition**
  You can switch to the report definition by choosing *Extras → Definition → Display/Change*. You can then display or change the report definition, depending on the function you chose.
  
  You can list the entire report definition using the *Extras → Definition → List* function.

- **Graphical column heading**
  If your report columns contain several headings, you can use the *Settings → Graph. column heading* function to choose the column heading that you want to use as the heading for the output in the graphic display.
Expert Mode

Use
You can execute reports from two different menus that have different functions. The standard mode contains all the basic functions that you require to execute a report. Special functions that are generally only used by a few users, or that require special knowledge of the Report Writer, are only available in expert mode [Seite 797].

You can call the expert mode from the selection screen or activate/deactivate it from the report output screen at any time. Expert mode does not require authorization to use.

Prerequisites
You can activate expert mode on the selection screen when executing a report, or in the report output:
On the selection screen, choose Environment → Options... and select the option Expert mode (under General settings).

You can also activate expert mode in the report output under Settings → Options.

Features
Expert mode offers the user more functions than are available in the standard mode.

The following functions are available in expert mode:

On the selection screen:

Variation
You can display the report in different levels of detail and different variation ranges.

If you have defined variation levels in your report (Vary Frm/To/S fields on the Create Report: General Data Selection screen), the variation function is activated automatically. You can change the variation settings with the button Variation.

The default settings in the Additional Entries: Variation dialog box are taken from the report definition. You can change these settings as required.

The Explode option creates a summarized report for all characteristic values, plus a report for each node and single value in the interval of the group.

The SingleVal function creates a report for every single value in the interval or group.

The Do not explode function creates one report containing summarized data for all characteristic values.

To enter detailed variation levels in your report, choose (Detail). In the subsequent dialog box, you can enter a variation range and activate the variation of the single values if desired.

If you want to navigate between variation levels in the report output, you must enter a range of variation levels (such as 1 to 99) in the from and to fields. The SingleVal
indicator determines whether different reports are output for the single values contained in the group (set).

The following table shows the correlation between the variation indicators and the variation range/single value combination.

**Variation vs. Variation Range/Single Value**

<table>
<thead>
<tr>
<th>Variation indicator</th>
<th>Variation range</th>
<th>Single values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explode</td>
<td>1 to 99</td>
<td>Active</td>
</tr>
<tr>
<td>Single values</td>
<td>1-</td>
<td>Active</td>
</tr>
<tr>
<td>Do not explode</td>
<td>1 to 1</td>
<td>Inactive</td>
</tr>
</tbody>
</table>

If you have set the variation indicator to *Single values* in the report definition, you cannot change this default setting in the variation dialog boxes. Reports are always output for the single values contained in the selected group (set).

For more information, see Variation [Exter] and General Data Selection [Seite 762].

**Currency Translation**

You can use the currency translation function to translate currency key figures into a joint target calculation. For currency translation, choose 🔄. Enter the information required for currency translation in the dialog box.

**Output Parameters**

In expert mode, you can also establish default settings that apply when you exit the report:

- Save settings
- Generate extract

For more information on extracts, Extracts [Seite 1008].

**Extract Parameters**

Choose *Extract parameters...* to define the extract parameters. From the *Entry: Extract Parameters* screen, you can make the following settings:

The default setting is *Do not create extract*. If you select this setting, you can exit the entry screen with 🎅.

To save your report selection data as an extract, set the *Create extract* indicator and enter the extract parameters.

In the group box *Extract parameters*, enter a description for the extract in the *Description* field.

**Expiration date** of the extract

If you want the extract to be deleted after a specific period of time, select *Expires in* and enter the number of days for which the extract is valid or select *Expires on* and enter an expiry date for the extract.
Expert Mode

Once an extract has been deleted, it cannot be retrieved.

If you do not want the extract to be deleted after a specific period of time, select No expiration date.

You should select this indicator if you want to keep the extract for a longer period of time.

The expiration date is only effective within a given release version. If you upgrade to a later release, all report extracts are deleted. However, extracts are not deleted when you upgrade the maintenance level of your SAP R/3 System.

To save the extract parameters, choose .

When you exit a report that has not been saved in an extract file, a dialog box appears asking whether you want to save the report as an extract. If you choose Yes, the system calls up the extract dialog box in which you enter the above information.

For more information, see Extracts [Seite 1008], Creating an Extract [Seite 1010], and Managing Extracts [Seite 1011].

Selecting Reports

By choosing Reports you can select particular reports in your report group.

This functionality is available should your report group contain more than one report.

In the report output:

Export report

The symbol exports a report to a presentation server or application server. For more information, see Exporting a Report to an External File [Seite 985].

Presentation graphics

The symbol calls up a business graphic. For more information, see Calling Up Report Graphics [Seite 999].

Layout settings

Fully expand report

Fully collapse report

Expand section

For more information, see Layout [Seite 1016] and Saving Changed Report Layout Parameters [Seite 1033].

Currency translation
Define threshold value

For more information, see Entering Threshold Value Conditions [Seite 994].

Navigation

Previous section

Next section
Printing Report Data

Use

Depending on the size of a report and the page size specified in the layout parameters, a report can cover several horizontal and vertical pages. You can print either the whole report or just parts of it.

Procedure

To print a report, choose Report → Print....

If variations exist for your chosen report, you can either print the current report or all the variation reports. If you decide to print the variation reports, you can specify whether they are to be printed in separate spool requests or all in one spool request. Make your choice in the dialog box, which only appears if variation reports exists, and choose Continue.

On the selection screen for the output parameters, in the group box Output medium, you can specify that reports are to be attached. Here you specify whether variation reports are to be printed in a single or in separate spool requests.

Specify which pages of the report you want to print. You have the choice between all pages, the current page, or you can select the pages you want to print. If you select Print all pages, the Report Writer reads the number of rows per report page from the standard layout assigned to the report. Choose Continue.

If the print page formatting is not active, you can specify in a dialog box, whether you want to activate print page formatting.

You activate print page formatting via Settings → Options... in the group box List output.

Attention: Headers or column headings are only displayed in regular intervals if print page formatting is activated.

In the Print Parameters dialog box, you enter printer data such as the output device, the number of copies, and spool information. To complete your entries, choose Continue.

If the headers and column headings disappear when you scroll, it is possible to “freeze” them. For more information, see Freezing Page Headers [Seite 984].

Result

The report or the parts of the report you specified are printed.
Freezing Page Headers

Use
In the on-screen report output in list format, you can freeze the page headers (headers and column headings) to prevent them from disappearing when you scroll.

When the freeze page header function is activated, the headers and the column headings (if the page only contains a single section) are frozen in position. On pages that contain multiple sections, only the headers can be frozen, since otherwise the column headings of the first section of the page will be displayed on all following sections.

Procedure
In the report output, you freeze the page headers under Settings → Options... by selecting Freeze page header in the group header List output.

If the window height is less than the frozen area, you cannot scroll vertically. Increase the size of the window or unfreeze the page headers.
Exporting a Report to an External File

Use
You can export reports to an external file on the presentation server or to a file on the application server.

Features
The application server is the computer that is running the SAP R/3 System (for example, a UNIX-based workstation assigned to your department).

The presentation server is the computer that is running your R/3 interface (for example, a PC linked to an R/3 application server).

For more information on these two alternative functions, see Exporting a Report to a Presentation Server [Seite 986] and Exporting a Report to an Application Server [Seite 988].
Exporting a Report to a Presentation Server

Use

You can export a report in an external file to the application server or to a presentation server. The presentation server is the computer that is running your R/3 interface, such as a PC that is linked to an R/3 application server.

On the output parameters selection screen in the group box Output medium, you can select the checkbox Append reports to specify whether an existing export file is to be extended or overwritten.

Procedure

Choose Report → Export... The dialog box Export to Presentation Server appears.

The current output medium is marked by a green traffic light. Ensure that the pushbutton Local PC file is selected.

Specify the export format you require:

To export data to a file in a table format, choose Spreadsheet. Lead columns and values are exported in a table format. Column headings and the text for export are also exported. This format is especially suited for processing your report in spreadsheet programs.

To export the report to DBASE or a compatible database program, choose DBASE format.

To export the report in a Lotus spreadsheet format, choose WK1 format.

To export the report to a file in text format, choose Word processing. The report is exported as it appears on the screen. This format is especially suited for processing your report in word processing programs.

To export the report to a file in HTML (HyperText Markup Language) format, choose HTML format. The system automatically starts the default Internet browser (such as Netscape Navigator or Microsoft Internet Explorer) and then displays the report using that browser. Each report section is converted into an HTML table. If you have defined a specific text for the export, this text is displayed at the beginning of the report page. Otherwise, the title page of the report is displayed.

In the group box Output file, enter the file name for exporting the report.

In the group box Launch PC application, enter the program that is to be launched after the report has been exported to the presentation server. Select one of the following variations:
Exporting a Report to a Presentation Server

If the output file is to be opened directly by the PC application, choose Open file.

If you want to launch the PC application using parameters, choose Parameters for application. Enter the parameters in the input field next to the indicator.

If you enter $& in this field, the system replaces the $& characters with the current file name (File name field) when the program is executed.

If you only want to export the report to the presentation server, choose Export only. The system does not launch the PC application in this case.

Choose Continue.

**Result**

The system exports the report.
Exporting a Report to an Application Server

Use
You can export a report in an external file to the application server or to a presentation server. The application server is the computer that is running the SAP R/3 System, such as a UNIX-based workstation assigned to your department.

On the output parameters selection screen in the group box Output medium, you can select the checkbox Append reports to specify whether an existing export file is to be extended or overwritten.

Procedure
Choose Report → Export... The dialog box Export to Presentation Server appears.

The current output medium is marked by a green traffic light. Choose the pushbutton Application server....

Specify the export format you require:

To export data to a file in a table format, choose Spreadsheet. Lead columns and values are exported in a table format. Texts for export are also exported. This format is especially suited for processing your report in spreadsheet programs.

For this table format you can also check the function Format figures.

Choose this if you want the following column attributes (the settings in the report layout [Seite 1029]) to be taken into consideration when exporting in table format: scaling, decimal places, change +/- sign.

If you do not choose the indicator Format figures, all the figures are exported in an unformatted form. The column attribute Print unit is not taken into consideration during the export.

To export the report to a file in text format, choose Word processing. The report is exported as it appears on the screen. This format is especially suited for processing your report in word processing programs.

To export the report to a file in HTML (HyperText Markup Language) format, choose HTML format. The system automatically starts the default Internet browser (such as Netscape Navigator or Microsoft Internet Explorer) and then displays the report using that browser. Each report section is converted into an HTML table. If you have defined a specific text for the export, this text is displayed at the beginning of the report page. Otherwise, the title page of the report is displayed.

In the group box Output file, enter the file name for exporting the report.

Choose Continue.

Result
The system exports the report.
Exporting a Report to an Application Server
Office Integration

Use
In the report output of Report Writer reports, Office Integration is available as an alternative to list output. It also replaces the previous Excel export in RPW format.

Prerequisites
Office Integration places higher demands on front-end hardware than does normal list output. For more information, see Desktop Office Integration [Extern].

Features
Office Integration enables reports to be output as Office documents (Microsoft Excel, Lotus 123). The Office application runs as a control within the R/3 window. With a few exceptions, all R/3 functions are available on the worksheet of the Office application. The functions are as follows:

Display can be switched interactively
Using the dialog settings, you can switch between displaying the report in the normal list format and displaying it as an Office document. The selected setting is saved permanently in the user parameters. The dialog settings can also be changed on the initial screen of the report group in the output parameters.

If the selected Office application is not installed on the user’s PC, the report is output in normal list format.

Worksheet protection
When a report is output into an Office document, the worksheets are protected. This is to assure consistency of the data on the front end with R/3. This consistency is necessary for context-sensitive functions such as report calls and changing column attributes.

You can permanently deactivate worksheet protection in the dialog settings, or temporarily in the Office application, allowing you to change the worksheet locally. However, if rows and columns are then inserted into the worksheet, the correct cell reference for context-sensitive functions may be lost. Any changes made locally will be overwritten in R/3 in the next dialog step.

Mail connection
You can send the current Office document as an attachment to an email.

It is not necessary to have saved the report as an extract.

Local structuring functions
Office Integration supports local hierarchical structuring functions in the Office application. This enables you to change the breakdown of rows and columns locally, without having to communicate with the SAP R/3 System. This function is also available with mailed Office documents.
Headers in worksheets

The headers of worksheets are created from the text for export. The headers and footers defined for the report are normally adapted for list output and are therefore not used for the worksheet. Likewise, the title page and end page are ignored.

Output of sections

Each section that has an explicit page break (default setting in Report Painter) is output in the Office document as a new worksheet. Sections that follow each other without explicit page breaks are output together in one worksheet. The name of the worksheet is the title of the first section on the worksheet. The title may get changed slightly to meet the naming restrictions of the Office application (non-permitted characters such as *, ;, \, /, and ?, length restrictions, uniqueness of the name).

For more information, see Desktop Office Integration [Extern].
Sending Reports to Mail Users

Use

From the report output screen, you can send the current report in HTML format to an internal or external user. You can also send reports independently of your SAP R/3 System. The report is sent to the mail recipient's inbox or mailbox. The recipient can then display the report data, as well as additional information (such as the report group name and time of data selection).

If the report has been saved as an extract [Seite 1008], the recipient in the SAP R/3 System receives the document in HTML format plus a link to the extract. To display the extract, choose Document → Execute in the SAP R/3 System in the document display.

If you send a report while it is still displayed on the screen, this current report is always attached to the mail in HTML format.

If Office Integration [Seite 990] is active, the current report is attached to the mail as an Excel file or Lotus 123 file.

Procedure

Choose Report → Send... The screen Send with Note appears.

Enter the name of the recipient and assign a corresponding recipient type.

Select the required send options.

You can also write a note to the recipient. This note is displayed in a dialog box when the recipient calls up the report from the mail inbox.

Choose Send.

Result

The report is sent and the recipient receives it in his/her mail inbox.
Selecting and Deselecting Report Data

Procedure
To select a block of report data for further processing, position the cursor on the first row of the block that you want to select.

Choose Edit → Select block.

Position the cursor on the last line of the block you want to select.

Choose Edit → Select block.

To deselect the block, choose Edit → Deselect block.

Result
The system highlights the block of report data you selected.
Entering Threshold Value Conditions

Use

You can specify a threshold value condition so that report rows are highlighted or hidden depending on the numerical values of a certain report column (reference column).

You can only define threshold value conditions in the displayed report in expert mode [Seite 978].

You can define a threshold value condition while creating, changing, or displaying a report, or define it from the output report.

Suppose your report has three columns: actual costs, plan costs, and variances between actual and plan costs. You want to highlight in red all rows with variances of at least 10,000. To do so, you enter a threshold value. In this example, the threshold value is 10,000 and the reference column is 3 (variance between actual and plan costs).

You can define a maximum of two threshold value conditions for each report.

Procedure

To define the threshold value condition from either the Create Report/Change Report/Display Report initial screens, choose the Sections pushbutton and select the required report column. Choose the Threshold values pushbutton. The system displays the Maintain Threshold Value Condition for <section number> dialog box. Continue with step 3.

In report output, select the required report and then highlight the section for which you wish to define the threshold value condition.

Select Edit → Threshold value... The system displays the Maintain Threshold Value Condition for <section number> dialog box.

Enter the following information:

Specify a condition for the threshold value. For example, if you want to display values for a certain report column greater than 10,000, you enter >= in the Condition field.

Enter the threshold value. You can enter the threshold value with or without decimal places. You can only use a period or comma for the decimal places. The threshold value itself must not contain a period or comma.

Enter the position number of the reference column. The columns are numbered from left to right, starting from the first report column.
Columns with a column width of zero (defined in the layout parameters) which are therefore not displayed are nevertheless included in the numbering. This means that your reference column does not have to be displayed.

Use the Active indicator to specify whether the threshold value condition is active or not.

You can enter additional threshold value information in the Extras group box:

The Ignore +/- sign indicator tells the system whether it should ignore the +/- sign when determining which values fulfil the threshold value condition. Select this indicator if you want the report writer to ignore the +/- sign.

To highlight all row values exceeding a specific threshold (whether positive or negative) in an actual/plan/variance report, turn on the Ignore +/- sign indicator.

You use the indicator Only detail rows to restrict the where-used area of the threshold value condition. If you select this indicator, the totals rows are not included in the threshold value condition. They are printed unchanged when the report is output.

If you just want to print the report rows conforming to the threshold value condition, choose the Print selected rows only indicator. The system hides all other report rows.

To highlight the rows fulfilling the threshold condition in red, choose the Highlight selected rows (red) indicator.

To highlight the rows fulfilling the threshold value condition in green, choose the Highlight selected rows (green) indicator.

To specify a second threshold value condition, proceed in accordance with steps 2 and 3.

Example

Suppose a report contains the following columns:

Actual costs (column 1)
Plan costs (column 2)
Actual/plan variance (column 3).

You want to highlight in red all rows where the variance is greater than or equal to 10,000. You enter the following threshold value condition:

Condition >=

Threshold value condition 10000
Reference column 3

Choose Highlight selected rows (red).

In the same report, you want to highlight in red all rows where the variance is greater than or equal to 10,000. To do this, you enter the same conditions but select Print selected rows only. All other report rows are hidden.
Entering Threshold Value Conditions
Sorting Report Rows

Use
You can sort report rows in reports that have been output in various ways by using the functions under Edit → Sorting.

Depending on where you have positioned the cursor in the report, there are two ways in which you can sort the report. You can use the hierarchical sort function to sort the entire row hierarchy on all summation levels. It is also possible to sort the rows just on the summation level of the row you have selected.

Procedure

Defining the Sorting Function
You can tailor the sorting function to your requirements under Edit → Sorting → Define....

Hierarchical Sorting Function
If you position the cursor on the heading of a certain report column and choose Edit → Sorting → Sort ascending or Edit → Sorting → Sort descending, the system sorts the entire row hierarchy on all summation levels.

Sorting Function on a Summation Level
If you position the cursor on a report row within a certain report column and choose Edit → Sorting → Sort ascending or Edit → Sorting → Sort descending, the system sorts the rows on the summation level of the row you selected.

When you use the sorting function, the system displays a symbol in the heading of the column for which you have sorted report rows.

Undoing a Sort
To restore the original order of the report rows, choose Edit → Sorting → Undo sorting.
Navigating Within a Report

Use

From the report output of one report you can also display a different report. You can also navigate within different column blocks.

Procedure

If your report group contains more than one report, you can display another report included in the report group by choosing Goto → Other report.

Navigating in Column Blocks

In large reports that contain several row and column blocks, you can navigate within the report using the Goto → Position → Pages/Sections/Columns functions.

These functions allow you to locate and display a specific report page, report section, or column block.

You can navigate within the column blocks of a report using the functions Goto → Scroll horizontally → To the far left/Page left/Page right/To the far right.

Navigating with the Navigation Bar

In the report output, you can turn on the navigation bar in the left-hand screen area. Choose Settings → Options. In the Options dialog box, select Display navigation bar (in the General settings group). You can use this navigation bar to navigate within the reports of the report group and in the variation reports.
Calling Up Report Graphics

Use
You can display a report or a block of selected report data in different forms (two- or three-dimensional) using the SAP Business Graphic.

When you call up the SAP Business Graphic, you can:
- Display graphics for the pages of a report in a separate window
- Select certain areas of the report and display this report data as a graphic in a separate window

Prerequisites
The system can display the graphic type you specified in the standard layout. For more information, see Creating a Standard Layout [Seite 1019] and Parameters for the Standard Layout [Seite 1022].

Procedure
In the executed report, select the area you want to display as a graphic and choose Report → Graphic.

Result
The report (or the selected area of the report) is displayed in a separate window.
Calling Up Reports via the Report/Report Interface

Use
The report/report interface allows you to interactively start report groups, ABAP programs, report portfolio reports, drilldown reports, and transactions while displaying the report output.

Prerequisites
If receiver reports have been defined for the report's report group [Extern] or library [Extern], you can call up these reports using the Call up report function.

Procedure
You can generally access the receiver report from the sender report by selecting a cell and then double clicking this or choosing

When you call the receiver report, the characteristics' restrictions that gave rise to the value in the sender report are passed on to the receiver report.

If, for example, a value is characterized in the sender report by the characteristics year, cost element, period, and value type, these characteristics are passed on to the receiver report.

There are four different ways of calling up a report using the report/report interface, whereby the starting position is the deciding factor for the receiver report:

If you want to call up a receiver report with the restrictions that are valid for a certain value in a cell, position the cursor on a value in the report and double click it or choose .

The receiver report is called up with the selection criteria that gave rise to this particular value.

If there is only one receiver report, this is displayed immediately; otherwise a list appears from which you can select a report that is then displayed.

If you want to call up a receiver report with selection criteria that are valid for a certain row, position the cursor on the row text in the lead column and choose . The receiver report is called up with the selection criteria that are valid for the whole row.

If you want to call up a receiver report with selection criteria that are valid for a certain column, position the cursor on the column heading and choose . The receiver report is called up with the selection criteria that are valid for the whole column.

If you want to call up a receiver report with selection criteria that are valid for a certain area, select two cells with . The entire rectangular area between these two cells is selected.

In the following example the cells have been given coordinates for easier identification. Cells B2 and D4 have been selected and thus the entire rectangular area between them is selected as well.
You can display or change the receiver reports that you want to call up from the report output using Settings → Report/report interface. To change receiver reports in this way, you must first select Change allowed dur exctn (under Settings → Report layout, tab page Page/control, group box Control data).

For more information on defining reports for the report/report interface, see Defining Reports for the Report/Report Interface [Seite 924].
Navigation in the Variation Settings

Use

Depending on the report type (Report Painter or Report Writer report), there are different functions for navigating in the variation settings in the report definition and in the executed report.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Definition</td>
<td>Only degree of explosion can be defined</td>
<td>Levels of detail can be defined</td>
</tr>
<tr>
<td>Executed Report</td>
<td>Levels of detail can be defined</td>
<td>Levels of details can be edited</td>
</tr>
</tbody>
</table>

If a selection set contains more than one value, the Report Writer accumulates the data for the different values. By entering appropriate values in the *Vary Frm* and *Vary To* fields (to define a variation range), you can instruct the Report Writer to create different reports for the different characteristic values, as well as for the different set levels (if the selection set is a single-dimension set [Extern]).

Once you have entered the variation data and executed the report's report groups the selection variation is activated automatically.

Features

Report Painter Report

For information on variation ranges, see Editing Variation Ranges in Report Painter [Seite 1003] and Working with Variation Ranges in Report Painter [Extern].

Report Writer Report

For information on variation ranges, see Editing Variation Ranges in Report Writer [Seite 1005] and Working with Variation Ranges in Report Writer [Extern].
Editing Variation Ranges in Report Painter

Use
You can edit variations of Report Painter reports in two ways:
In the report definition
On the selection screen of the executed report

Procedure
Once you have defined the general data selections for the characteristics, you can define the variation range in the report definition with $.

On the selection screen of the executed Report Painter report, you can define the level of details for the row explosion as follows:

On the selection screen, choose $ Variation.

In the dialog box Additional Entries: Variation, choose the radio button for the required degree of explosion.

You can restrict the characteristic values further by assigning them from and to levels (variation range) using $.

Entries possible for the from level of the variation range and the resulting restrictions for the to level

<table>
<thead>
<tr>
<th>From level</th>
<th>To level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Positive [&gt;0]</td>
<td>Greater/Less From level</td>
</tr>
<tr>
<td>Negative [-1; -2]</td>
<td>No entry</td>
</tr>
</tbody>
</table>

The following example illustrates the variation range levels possible within a cost center hierarchy:
Cost Center Hierarchy

BSG Inc.

ADMIN

DIST

PROD

100 110 200 210 300 310

Level

1

2 (= -2)

3 (= -1)

For more information, see Working with Variation Ranges in Report Painter [Extern].
Editing Variation Ranges in Report Writer

Use
You can edit variations of Report Writer reports in two ways:
In the report definition
On the selection screen of the executed report

Procedure
In the report definition, choose General data selectn and then in the screen Create Report:
   General Data Selection <Name of Library><Name of Report Writer Report> you can define a
from and to level for the variation range of each set. You can also define an individual value
flag for each set, indicating that the variation range contains individual values.

To change the variation range in an executed report, from the selection screen choose Variety
Variation and make your changes.

The following restrictions apply for the variation range (from and to level).

Entries possible for the from level of the variation range and the resulting restrictions for
the to level

<table>
<thead>
<tr>
<th>From level</th>
<th>To level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Positive [&gt;0]</td>
<td>Greater than/less than From level</td>
</tr>
<tr>
<td>Negative [-1; 2]</td>
<td>No entry</td>
</tr>
</tbody>
</table>

The following example illustrates the variation range levels possible within a cost
center hierarchy:
Navigating Within an Executed Report

For information on navigating within a report, see Navigating Within a Report [Seite 998].

To display the report data levels of detail for the data selection characteristics you can use the functions under the menu option View. You can vary the level of detail on a report, section or row level.

To navigate to the next level up of the displayed characteristic, choose (Variation previous level)

To navigate to the next level down of the displayed characteristic, choose (Variation next level)

If you select a single-dimension set containing a basic set, you navigate to the basic set level using (Variation next level).

For more information on defining selection criteria, see Defining Selection Criteria [Seite 835].
Navigating in the Report Hierarchy

Use

You can vary the level of detail of an executed report on a report, section or row level.

Procedure

To expand or collapse a certain area of the report, position the cursor in the desired area and choose the required function under the menu option View as follows:

- Expand report fully or 
- Collapse report fully or 
- Expand section or 
- Expand section fully 
- Collapse section or 
- Collapse section fully 
- Expand section to... 
- Expand row 
- Collapse row
Extracts

Use
To reduce the necessary runtime for formatting report data, you can create an extract when you execute a report. An extract is a dataset that contains the report data selected at the time the extract was created.

Extracts provide the same navigation and formatting options as reports selected directly from the database.

The main differences between an extract and a report are shown in the following table:

Main Differences Between Report and Extract

<table>
<thead>
<tr>
<th></th>
<th>Report (Newly Selected)</th>
<th>Extract</th>
</tr>
</thead>
<tbody>
<tr>
<td>Currentness of data</td>
<td>Data is current</td>
<td>Data is no more recent than the time the extract was created</td>
</tr>
<tr>
<td>Authorization check</td>
<td>On each record</td>
<td>Only on entire report</td>
</tr>
<tr>
<td>Runtime</td>
<td>Generally long runtimes with large database structures, plus additional time for report output</td>
<td>Runtime only for report output</td>
</tr>
</tbody>
</table>

Aside from these differences, extracts offer full report functionality. When you call up a report that uses an extract, the system does not have to select the report data directly from the database. As a result, processing time improves considerably.

⚠️

If you create an extract and then make changes to the data structure in Customizing, this can result in inconsistencies between the current data structure and the structure in the extract. The data of the extract can therefore no longer be displayed.

⚠️

After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Integration
The final step in defining a report group [Seite 937] is executing the report group. You generate an extract when you execute the report with reference to the selection parameters entered at the time the report is executed. You can therefore create multiple extracts of the same report by entering different selection criteria each time.

If you called up the report using an extract, the system outputs the report using the extract data.

If you called up your report by selecting data from the database, the system outputs the report according to the selection criteria you specified and formats the report according to the report definition.

For more information, see Executing a Report Group [Seite 964].
Features

In expert mode [Seite 978], you can create extracts on the selection screen (for more information, see General Data Selection [Seite 762]) if you execute a report group and choose the button Extract parameters... and then the mode Create extract. Alternatively, you can save your report output as an extract when you exit the report. In this case, the system displays a dialog box, asking whether you want to save the report in an extract file.

If you call up a report when Display extract is selected as the data source, the system checks whether any extracts are available that match the selection criteria. You can then choose from among the available extracts. You can also search for, display, and print extracts using extract management. In both cases, direct access is possible to all extracts generated within a variation.

Extracts are deleted either manually in extract management or automatically based on an expiration date that you can specify when you create the extract.

⚠️

Once an extract has been deleted, it cannot be retrieved.

For more information, see Creating an Extract [Seite 1010] and Managing Extracts [Extern].
Create Extract

Use
There are two different ways of creating an extract [Seite 1008]:

- You can create extracts on the selection by choosing Extract Parameters and then choosing Create Extract in the dialog box.
- You can generate an extract when executing a report. To do this, follow the steps under Procedure.

You can only create extracts in expert mode [Seite 978]. Make sure that expert mode has been activated. You can make these settings from the selection screen by choosing Environment → Options.

Procedure
17. Enter the required report group and choose .
18. Enter the required selection parameters and choose .

If extracts already exist for the selection criteria you have specified, the system will display a list of extracts that you can choose.

9. The report is now displayed. Choose Report → Save. In the Enter: Extract Parameters dialog box, you can define the parameters for your extract. For further information about extract parameters, see Expert Mode [Seite 978]. To complete your entries, choose .
Managing Extracts

Use

When you save reports in extracts, you can then access the data at any time without having to select the data from the database.

You can use extract management to:

- Display extracts
- Print extracts
- Change the extract priority
- Change the expiration date of an extract
- Delete extracts

⚠️

After a release upgrade, it is no longer possible to display reports saved as extracts. However, extracts can still be displayed after an upgrade of the maintenance level of your R/3 System.

Prerequisites

You have saved your reports in extract files. For more information, see Creating an Extract [Seite 1010].

Procedure

6. On any Create/Change/Display/Execute Report Group screen, choose Utilities → Extracts → Display or Delete or Print or Change expiry date, depending on the function you want to use.


   ![Report Writer: Extract Management screen]

   You can also access extract management from the screen Execute Report Group: Initial Screen using the button Data extracts when you execute a report group from the first selection screen with Environment → Extract directory...

7. Enter the criteria according to which the extracts should be selected:

   - If you are searching for a particular extract, enter the description of the extract.
   - Specify whether extracts should be displayed that were generated by your or by a particular user, or whether all extracts should be displayed regardless of the user.
   - Specify when the extracts were generated, or whether all extracts should be generated regardless of the date.
   - You can select the extracts of a particular report group [Seite 937] or report group range.
   - You can select the extracts according to their priority, and restrict the selection to unread extracts.
Managing Extracts

- If you want to further restrict the selection criteria (for example, according to a specific characteristic or group of characteristics), choose Additional selections and enter the criteria. You can expand the number of selection conditions as required, and delete selection conditions you entered.

8. Choose .

   The system displays a list of extracts that meet the selection criteria you entered.

9. Select the desired extract and choose one of the following functions:

   k. Display extract

      Choose .

   l. Print extract

      You can print extracts immediately or in the background.

      - To print the selected extracts, choose Extraks and enter the output device and other parameters for print control.

      - To print in the background, choose Background and specify when the job should be started.

   r. Change the extract priority

      Choose and change the priority of the extract.

   s. Change expiration date

      You can change the expiration date that was specified when the extract was created.

      Choose . If you want the extract to be deleted automatically after a specified time, enter the number of days in the dialog box Change expiration date under Expires in or choose Expires on and enter an expiration date.

      If you don’t want the extract to be deleted after a specified time, choose No expiration date. This is appropriate when the report is required for an undeterminable length of time or the report takes a long time to execute.

      Choose to exit the dialog box and save your entries.

   t. Delete extract

      Once an extract has been deleted, it cannot be retrieved.

      Choose to delete extracts. If you answer the question whether the selected extracts should be deleted with Yes, the extracts are deleted.

      For information on settings for extract management, see the Implementation Guide for Cost Center Accounting under Information System → User Settings → Specify Settings for Extract Management.
Example Process: Report Callup with Extract Management

Purpose
At the end of each month, the reports (important to cost center managers in the entire organization) are executed, and the data is stored in extracts [Extern]. Reports that contain data for individual cost centers [Extern] or cost center groups [Extern] are executed using variation, so that a separate report can be created for each cost center and cost center group.

You can set the user parameters for your cost center managers so that they can automatically access the most current extracts.

When calling up a report from the report tree, each manager receives the relevant individual data. The manager does not need to select the data from the database again, which reduces the workload of the system.

The cost center manager cannot navigate to areas within the extracts that do not belong to the authorized CO-OM responsibility area.

The system administrator who sets up these reports needs to have authorization to select the data from the database. However, this does not authorize the administrator to display the data in those reports.

The cost center managers need authorization to display the reports for their CO-OM responsibility area. However, this does not entitle them to select the data from the database or to create extracts.

The following graphic displays the way in which a report is executed in extracts, in the background with the variation. It also shows how you can save it in extracts.
Example Process: Report Callup with Extract Management

Process Flow

21. Initial setups include creating the authorizations for system administrators and cost center managers [Extern].

22. The system administrator arranges for all the reports to be accessible to all users in EUROs. The system administrators execute the report (such as the Cost Centers: Actual/Plan Variance report) in the background and with the variation, and save the report in extracts (see: Executing a Cost Center Report with Variation and Saving it in Extracts [Extern]).

23. The system administrator makes the settings for extract management for the cost center managers in Customizing (see: Specifying Settings for Extract Management [Extern]). In their user-specific settings, the cost center managers save their selection criteria for the reports they want to display (see Customizing for Controlling under Cost Center Accounting → Information System → User Settings → Specify User Settings [Extern]).

24. The cost center manager accesses the report (see: Calling Up Cost Center Reports [Extern]).

This procedure is shown in more detail in the following sections using the Cost Centers: Actual/Plan/Variance report.

Result

Each cost center manager can quickly and easily display the relevant reports required.
Example Process: Report Callup with Extract Management
Layout

Purpose
In Report Painter and Report Writer reports, you can modify the layout of your report at different levels.

Features
The layout parameters for the report output are determined by the standard layout [Seite 1017] assigned to the report. This includes the page format of the report and the numerical format of the report data.

A section layout [Seite 1028] can be defined separately for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

You assign an individual report layout [Seite 1029] to each report. Initially, each report receives the standard layout SAP. You can assign an individual section layout to each section in the report. The standard layout then only applies to the sections to which no section layout was assigned.

The section layout and the report layout allow you to define layout settings such as form printout or the width and position of the lead columns separately for each section.

Specify whether it should be possible to change and save the layout parameters in the report output:

- If you do not select Change alwd dur exctn, the layout parameters cannot be changed when the report is executed.
- If you deselect Change alwd dur exctn, the layout parameters cannot be changed when the report is executed.

For more information, see Parameters for the Standard Layout [Seite 1022].

You can change the report’s layout parameters under Settings → Report layout.

If you change the layout parameters, but then decide that you want to reuse the default values from the standard layout, you can do so by choosing Settings → Report layout → Use standard layout.
Standard Layouts

Use

You assign a standard layout to each report that you create. This standard layout determines the layout features of the report, such as the page format of the report and the numeric format of the report data. The system assigns a default standard layout called SAP to each report. You receive the SAP standard layout with each SAP R/3 System. The standard layout provides a default value for every layout parameter.

Features

Report Painter

When a layout is assigned in the Report Painter [Seite 726], the layout parameters are copied from the standard layout to the report layout. There is no permanent reference to the standard layout. Thus, changing the standard layout has no effect on the report layout.

In the report layout, you can recopy the layout parameters of the standard layout with the button Use standard layout.

Report Writer

Before a report layout has been defined for a Report Writer [Seite 797] report, a link exists between the report layout and the standard layout for all parameters. With the button Define report layout, you can create an independent report layout that is a copy of the standard layout. With Report Writer reports, the button Use standard layout restores the link to the standard layout. In this case, changes made to the standard layout would affect the report layout.

When you define a report, you can do any of the following:

• Use the SAP standard layout for the report
• Assign a different standard layout to the report
• Revise the standard layout parameters so that the parameters are specific to the report

In the report definition, you can assign a standard layout to the report in the report header. These settings then take effect for that report. You will find more information on headers for the Report Painter under Defining Report Headers [Seite 765] and for the Report Writer under Defining Report Headers [Seite 817].

There are two ways in which you can use the standard layout settings in a report:

• Execute the report and then choose Settings → Report layout → Use standard layout
• In the report definition (Change Report), choose (for Report Painter reports) Edit → Report header. Here you need to enter a different standard layout (such as SAP) and then reenter the standard layout you require.

The indicator Change allwd dur extn allows you to save any changes you make to the layout when executing the report. Set this indicator in the report layout.

If you only change the indicator in the standard layout, the change will only be effective in the Report Painter report if you reassigned the standard layout to the report.
Standard Layouts

For more information about assigning a standard layout to a report and changing report parameters, see Defining Report Layouts [Seite 1031].

The standard layout is used in all sections to which no section layout [Seite 1028] is assigned.

For more information on processing and changing the standard layout, see:

Creating a Standard Layout [Seite 1019]
Displaying a Standard Layout [Seite 1024]
Changing a Standard Layout [Seite 1025]
Deleting a Standard Layout [Seite 1027]
Parameters for the Standard Layout [Seite 1022]
Creating a Standard Layout

Use
When you first define a report, the default standard layout assigned to the report is always SAP. SAP appears in the Standard layout field at the top of each report parameters screen. This standard layout is shipped with your SAP R/3 System.

When you define a standard layout, you can assign parameters to format groups for certain fields. For parameters that are assigned format groups, you can define up to six different versions of the parameter. Each row and column in a report can use a unique format group. For more information, see Setting Format Groups in Sets [Seite 910].

Procedure


14. Enter the following information:
– The name of the standard layout you want to create
– The name of the existing standard layout you want to copy

15. Choose Continue.

The Create Standard Layout screen appears.

16. Enter the following information:
– Description of the standard layout
– Authorization group for the standard layout. This authorization group is defined in the user's profile.

Suppose you define an authorization group called AUTH. If you assign this authorization group to a standard layout, only users with this authorization group can change, display, and/or delete this standard layout for their reports.

Using the tab pages you can make the changes to the layout that you require. The following table gives you an overview of the different possibilities that you have for defining the standard layout parameters. Each function is assigned to the respective tab page index.

<table>
<thead>
<tr>
<th>Function</th>
<th>Tab page index</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting the column headings</td>
<td>Column headings</td>
</tr>
<tr>
<td>Defining area for the totals output</td>
<td>Rows</td>
</tr>
<tr>
<td>Setting width and position of lead column</td>
<td>Lead column</td>
</tr>
<tr>
<td>Defining detail level for row totals</td>
<td>Rows</td>
</tr>
</tbody>
</table>

Defining the Standard Layout Parameters
Creating a Standard Layout

| Setting number of decimal places | Representation |
| Defining unit                   | Representation |
| Setting colors                  | Graphics       |
| Using form printout             | Rows           |
| Setting graphic type            | Graphics       |
| Defining content of lead column | Lead column    |
| Defining content of column headings | Column headings |
| Allowing changes to layout parameters during execution of the report | Page/control |
| Output of zero values           | Representation |
| Suppressing zero columns        | Columns        |
| Printing or hiding zero rows    | Rows           |
| Indenting lead column           | Lead column    |
| Repeating lead column           | Lead column    |
| Setting page format             | Page/control   |
| Printing selection log at end of report | Page/control |
| Setting scaling                 | Representation |
| Setting column break character underline | Column headings |
| Defining column layout          | Columns        |
| Setting column break character  | Columns        |
| Assigning a language            | Language dependent |
| Using standard colors           | Page/control   |
| Suppressing duplicated totals   | Rows           |
| Marking totals                  | Rows           |
| Defining position of totals items | Columns       |
| Defining text type for the row text description in the lead column | Lead column |
| Displaying undeterminable values | Representation |
| Setting +/- sign                | Representation |
| Defining +/- sign editing       | Rows           |

For more information on the layout parameters, see Parameters for the Standard Layout [Seite 1022].

You can use the following additional functions from the Create Standard Layout screen:

**Additional Functions**

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
</table>

1020 April 2001
### Creating a Standard Layout

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display directory of existing standard layouts</td>
<td>Utilities → Catalog...</td>
</tr>
<tr>
<td>Export standard layout to an external file (see Exporting Report Writer Objects [Seite 916])</td>
<td>Utilities → Transport → Export</td>
</tr>
<tr>
<td>Import standard layout from an external file (see Importing Report Writer Objects [Seite 918])</td>
<td>Utilities → Transport → Import</td>
</tr>
</tbody>
</table>

8. To save the standard layout header, choose **Standard layout → Save**.
Parameters for the Standard Layout

Parameters for the Standard Layout

The standard layout provides a default value for all the layout parameters that you can change. When creating the standard layout you can overwrite the default parameter values on the following tab pages:

- **Page/control**
  
  The page format parameter values determine the layout of a report when it is output. *Page control* (to determine if you can change the layout parameters in the report output and if you want to print the selection log at the end of a report). For *Margins* you can define parameters for the top, bottom, right and left margins and in *Print sequence* you can choose between printing by column or by row. With *Color settings* you can specify that the standard SAP colors be used for the report output.

- **Rows**
  
  With *Summation level* you define the level of detail to be used for the row totals. With *Totals item* you specify where the totals are to be output, for example above or below the detailed report results. For *Treatment of zero rows* you define whether zero rows are to be printed or hidden, or whether you want to use form printout. You can also mark totals and suppress duplicated totals.

  You can deactivate +/- sign editing, or activate it for all columns or for a certain column.

- **Lead column**
  
  With these layout parameters you define the content of the lead column (description, key and description, characteristic name and key, key). You can also determine the text type that is to be used for the row text in the lead column. You can choose between short text, long text, or a text that is proposed automatically by the system. If there is no short text in the master data, the system uses the corresponding long text.

  With *Indentation* you can specify the number of spaces the lead column is to be indented by.

  In the group box *Lead column* you can define the width and position of the lead column.

  In the group box *Miscellaneous* you can activate the underscoring of the text and the repetition of the lead column.

- **Columns**
  
  *Totals position* (to determine if totals columns are positioned to the left or right of the columns containing the corresponding detail values).

  In the group box *Column break character* you specify the type of column break character to be used. In the group box *Treatment of zero columns* you can select that the zero columns be suppressed. In the group box *Layout* you define the column width and the right margin.

- **Column headings**
  
  With these layout parameters you define the *Content and Orientation* (left-justified, centered, right-justified) of the column headings. In the group box *Miscellaneous* you can define that the column break character be underlined.

- **Representation**
With these layout parameters you define how the numerical format is to be displayed. You can determine the number of decimal places and the scaling, as well as make specifications concerning the +/- sign and the units. You can also specify how the zero values and undeterminable values are to be displayed.

Undeterminable values appear in a report when values with different currency units or units of measure are totaled. You can display these values in your report with a space or using a symbol.

- **Language dependent** (language-dependent parameters)
  With these parameters you can assign different values for decimal display, +/- sign and date to different languages. With Other languages you can switch to another language to enter the language-dependent parameters. When you execute the report’s report group, the Report Writer uses the value of the logon language.

- **Graphics**
  With these parameters you determine the graphic type that you want to use. The color palette determines the color palette that is to be used for the business graphic. For more information on calling the report graphics from the executed report, see calling report graphics [Seite 999].

For more information, see creating a standard layout [Seite 1019].
Displaying a Standard Layout


The Display Standard Layout: Initial Screen appears.

11. In the Standard layout field, enter the name of the standard layout that you want to display and choose Continue.

The Display Standard Layout screen appears.

12. On this screen, you can use the additional processing functions in the table in Creating a Standard Layout [Seite 1019], as well as the Extras → History function to display the revision history of the standard layout.
Changing a Standard Layout

Prerequisites

Changes you make to a standard layout will affect other users’ reports that use that standard layout.

You should only change a standard layout if the change is required for all reports that use that standard layout. If changes are only needed for one report run or for a specific report, you should change the report parameters using the Layout functions on the Change Report: Initial Screen. For more information, see Defining Report Layouts [Seite 1031].

The layout parameters are copied from the standard layout into the report layout. There is no permanent reference to the standard layout. When you create a report, the layout settings are copied from the standard layout into the report layout.

If the standard layout is changed, the layout parameters in the report are not updated automatically.

Do not change the standard layout (SAP) that is delivered with your SAP R/3 System.

Procedure


The Change Standard Layout: Initial Screen appears.

17. In the Standard layout field, enter the name of the standard layout you want to change and choose Header.

The Change Standard Layout: Header screen appears.

18. On this screen, you can use the additional processing functions in the table in Creating a Standard Layout [Seite 1019], as well as the Extras → History function to display the revision history of the standard layout.

19. Type over current values with your changes.


Suppose you give the report the standard layout SAP and then change the report width to 60. Then you assign a different standard layout to the report. The report width remains at 60, since it is a change that you made that is specific to the report.

For information on transferring the settings of the standard layout to a report, see Standard Layouts [Seite 1017].
Changing a Standard Layout

If the standard layout is changed, the layout parameters in the report are not automatically updated. The indicator *Change allwd dur exctn* allows you to save any changes you make to the layout when executing the report.

Select the *Change allowed during execution* indicator only in the report header.

If a user has authorization to change a report, he can change this indicator in the report output with *Settings → report layout → Page/control → Change allowed during execution*. Another place you can change the setting of this indicator is in the report definition with *Report header*. If you only change the indicator *Change allowed during execution* in the standard layout, the change will only be effective in the report if you reassign the standard layout to the report.
Deleting a Standard Layout

   
   The Delete Standard Layout: Initial Screen appears.

8. In the Standard layout field, enter the name of the standard layout you want to delete.

6. Choose Delete.

   A dialog box asks if you want to delete the standard layout.

   You cannot delete a standard layout that is being used in a report. You cannot delete the SAP standard layout delivered with the SAP R/3 System.

7. Choose Yes.

   The standard layout is deleted. You cannot restore a standard layout once it has been deleted.
Section Layout

Use
There are a number of different ways you can modify the layout of the sections in a report:
- You can apply the parameters specified in the report layout
- You can apply a section-specific layout

Features
You can use a different layout for each section. Section layouts contain control information on:
- Row totals
- Row texts
- Column texts

You can also apply the report layout [Seite 1029] to sections. Any changes you make to the report layout then become effective automatically in the sections where it was applied.

The section layout can be defined differently for each section. To define a layout for a certain section, double-click on the section and you can then make the settings for the column attributes.

In the section overview in the Report Painter, you can change the attributes of the sections, the sequence of the sections, and the page breaks between the sections. This includes overscores and underscores, and how the headers should be printed.

For more information on formatting, see Summation Levels [Seite 1034].
Report Layout

Use
You can assign a report layout to each report that you create. The report layout defines the layout features of the report, such as the page format of the report and the numeric format of the report data. When you use the Layout functions, you can set parameters for the report.

Features
You have two options for assigning a layout:

- Report Writer: link to standard layout [Seite 1017]
  Report Painter: copy of standard layout (may not be current)
- A separate report layout that is not linked to the standard layout

The report layout establishes layout parameters that apply to the whole report (such as the page layout). It also contains parameters that can be defined separately for each section (such as summation levels [Seite 1034]). These section-specific parameters defined by the report layout are valid only for report sections that do not have their own section layout [Seite 1028].

For more information, see Displaying Report Layouts [Seite 1030] and Defining Report Layouts [Seite 1031].
Displaying the Report Layout


For more information on additional functions that are available on this screen, see Functions in the Report Output [Seite 974].
Defining Report Layouts

Use

For each report that you create, you can assign a report layout. Via the report layout you define the layout features of the report, such as the page format of the report and the numeric format of the report data. When you use the Layout functions, you can set parameters for the report.

You received the SAP standard layout with your R/3 System. This standard layout is automatically assigned to each report you create. If you want to use the SAP standard layout, you can skip the following steps and go directly to defining rows [Seite 841]. When you first define a report, the default standard layout is always SAP. SAP appears in the Standard layout field at the top of each report layout dialog box.

When you define a report layout, you can define a layout specifically for a report and you can change the standard layout assigned to a report.

Procedure

4. To define a report layout, choose Goto → Report layout and work with the following tab pages:
   - Page/Control: Here you define general page format parameters, such as the length and width of a page
   - Rows: Here you define row total parameters, such as the positioning and summation levels for report row totals
   - Lead column: Here you define row text parameters, such as the text type and row length
   - Columns: Here you define the type of column break and the treatment of zero columns
   - Column headings: Here you define orientation of the column headings, such as the position and layout of the columns
   - Representation: Here you can define the numerical formats
   - Language dependent: Here you define the language dependent report parameters
   - Graphics: Here you define the graphical presentation and color palette

You can switch between the change mode of your report layout and the default parameters of the standard layout using the pushbutton Use standard layout or Define report layout. To change a parameter so that the standard layout value is not used in a report, you type over the current value. The value is not changed in the standard layout; it is only changed for that specific report.

11. Type over current values with the values you want to use for the report layout.

12. Choose Continue.

13. To save the report layout parameters, choose Report → Save.
Defining Report Layouts

Changes that you make to the report layout parameter values do not affect the standard layout values that are stored in the system. The report parameter values that you enter only affect the specific report that you are working on.

You can change standard layouts for reports; however, any changes you make affect other users’ reports. For more information, see standard layouts [Seite 1017].

For more information on the standard layout screens or for information about changing the standard layout, see creating a standard layout [Seite 1019].

For information on how to change the standard layout assigned to a report, see changing a standard layout [Seite 1025].

The system determines which format group to use based on the format group defined in the sets that are used in the report definition. Some report parameters can be defined using six variants of the parameter. These variants correspond to the format groups 0 through 5. Depending on the value entered in the format group field for a set, the Report Writer selects one of the six values. For more information on format groups, see setting format groups in sets [Seite 910].
Saving Changed Report Layout Parameters

Use

When processing a report in expert mode, such as when executing a report group [Seite 962], you can make changes to the report layout and save them.

Procedure

10. When executing a report, choose from the report output screen Settings → Report layout. A dialog box appears where you can overwrite the layout parameters.

11. Make any required changes to the report layout.

12. To save the changed layout parameters, you can choose from the following alternative functions:

- To save the changes, choose Settings → Save settings.
- To save the layout changes you made and then block all users from making layout changes in the report, choose Settings → Save and block settings. The system automatically deselects the Change allwd dur exctn indicator in the Page/Control layout parameters. If you need to remove the block, choose Change report, then Formatting → Report layout. On the tab page Page/control in the group box Control data, select the indicator Change allwd dur exctn.

SAP recommends that you save your report data as an extract [Extern]. This allows you to call up your report at any time and the system does not have to reselect the data from the database. You can save the report as an extract using the Report → Save function. If you have not already saved the report as an extract, the system displays a dialog box, asking you whether you want to do so when you exit the report. For more information, see Extracts [Seite 1008], Creating an Extract [Seite 1010], and Managing Extracts [Seite 1011].
Summation Levels

Use

In Report Painter reports and Report Writer reports you can use sets [Extern], groups, or set variables to display a hierarchy in the rows. The totals rows in a report are represented by summation levels.

Features

Each summation level is represented by one or more asterisks. In the report definition, you can specify in the layout that this hierarchy should be marked with special characters. You activate this function with Settings → Layout → Row totals → Mark totals.

In the layout, you can specify whether you can choose the position of the totals (top or bottom) in the display.

For more information, see Layout [Seite 1016].

The number of masking characters within a report depends on the number of hierarchy levels. Row totals at the lowest level in a hierarchy display with one asterisk. Individual values receive the summation level zero (no masking characters).

Hierarchy Levels and Their Representation by Masking Characters

<table>
<thead>
<tr>
<th>Hierarchy Level</th>
<th>Number of Masking Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Highest level of hierarchy</td>
<td>n</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-1</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-2</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-3</td>
</tr>
<tr>
<td>Next level down</td>
<td>n-4</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Lowest hierarchy level</td>
<td>n-(n-1) = 1</td>
</tr>
<tr>
<td>Single values</td>
<td>No masking character (n-n)</td>
</tr>
</tbody>
</table>

There are two types of hierarchies:

- Balanced hierarchy
  
  If values exist for all levels and branches of the hierarchy, the hierarchy is balanced. A balanced hierarchy looks symmetrical.
Unbalanced hierarchy

Which hierarchy level is the highest depends on which levels have values. The individual branches of the hierarchy can differ considerably from one another, resulting in an asymmetrical hierarchy.
Summation Levels

**Summation Level with Unbalanced Hierarchy**

If not every level of the hierarchy has a value, the maximum summation level can take on widely different values.

- If the hierarchy consists only of Set 1, Set 12 and values, Set 1 will have the maximum summation level **.
- If the hierarchy consists of Set 1, Set 12 with values, Set 13, Set 131 with value, and Set 132 with Set 1311 with values, Set 1 will have the maximum summation level ****.

The method for determining the maximum summation level always starts at the lowest set level.

**Summation Level with Balanced Hierarchy**

With a balanced hierarchy, the maximum summation level is always the same, regardless of the selected data.

**Summation Levels in Report Layout/Section Layout**

When you set the summation level in the report layout or section layout of reports with an unbalanced hierarchy, you should take into account how the maximum summation level is determined, as described above.

Different hierarchy levels will be displayed, depending on the selected data.

In the above examples for the summation level with an unbalanced hierarchy, if you specify the interval 2 to 3 for the summation level, the result is:

For the first example: Set 1 **

For the second example: Set 12 ***, Set 13***, Set 131**, Set 132**

You can avoid this discrepancy by inserting dummy nodes into the unbalanced hierarchy to balance it. This results in additional rows in the report, which you can hide with the layout setting *Suppress duplicated totals.*
Terminology

Reporting terminology has been standardized across all modules. For this reason, some reporting terms had to be replaced by new, standard terms that are valid across the whole SAP System. The following table lists the original terms (sorted alphabetically) with the new term and a description to give you an overview of the terminology changes.

### Terminology changes in reporting

<table>
<thead>
<tr>
<th>Original Term</th>
<th>Current Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing class</td>
<td>Format group</td>
<td></td>
</tr>
<tr>
<td>Basic key figure</td>
<td>Basic key figure</td>
<td></td>
</tr>
<tr>
<td>Data field (Report Painter)</td>
<td>Basic key figure</td>
<td></td>
</tr>
<tr>
<td>Data selection</td>
<td>General data selection</td>
<td></td>
</tr>
<tr>
<td>Data set (Report Writer)</td>
<td>Key figure set</td>
<td></td>
</tr>
<tr>
<td>Data set entry (Report Writer)</td>
<td>Key figure</td>
<td>Predefined, business key figure</td>
</tr>
<tr>
<td>Dimension</td>
<td>Characteristic</td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Characteristic</td>
<td></td>
</tr>
<tr>
<td>Key figure (Report Painter)</td>
<td>Basic key figure</td>
<td></td>
</tr>
<tr>
<td>Column text</td>
<td>Column heading</td>
<td></td>
</tr>
<tr>
<td>Column text type</td>
<td>Content</td>
<td>Column heading content</td>
</tr>
<tr>
<td>Statistics</td>
<td>Selection log</td>
<td></td>
</tr>
<tr>
<td>Text column</td>
<td>Lead column</td>
<td></td>
</tr>
<tr>
<td>Vary</td>
<td>Multiple selection</td>
<td></td>
</tr>
<tr>
<td>Predefined column (Report Painter)</td>
<td>Key figure</td>
<td>Predefined, business key figure</td>
</tr>
<tr>
<td>Row text</td>
<td>Lead column</td>
<td></td>
</tr>
<tr>
<td>Row text type</td>
<td>Content</td>
<td>Lead column content</td>
</tr>
</tbody>
</table>

For more information on these subjects, see Report Painter [Seite 726], Report Writer [Seite 797] and key figures [Seite 708].
Validations, Substitutions, and Rules

Purpose
With the validations and substitutions software, you can validate and/or substitute data at the time of entry in the FI-SL System and other SAP Systems.

Implementation Considerations
You do not need to change the standard system to customize your validations and substitutions. For each installation, you can define exactly which validations and substitutions are necessary to ensure the integrity of your data.

Features

Validation
In the SAP System, almost all input values are validated by a program or against tables or master files. Since some types of validations cannot be standardized, you can use FI-SL’s validations program to create validations for your system.

With validations, you can check values and combinations of values as they are being entered in the SAP environment. Validation rules are stored in the Rule Manager; as data is entered, the Integration Manager validates the data against the validation rules stored in the Rule Manager. Because data is validated before it is posted, only valid information enters the FI-SL System.

You define validation rules using Boolean logic. When you define a validation rule, the system checks the validation rule to ensure that it is syntactically correct.

You can also define the result of breaking the validation rule. For instance, you can specify that a message is issued but the user can continue processing. You can also force the user to correct the error before processing can continue.

For more information, see Validation [Seite 1056] or What Are Validations? [Seite 1040]. For more information on using validations, see Creating a Validation [Seite 1057]. For more information on Boolean Logic, see Introduction to Boolean Logic [Seite 1121].

Substitution
Substitution rules are stored in the Rule Manager. When data is entered in the system, it is substituted by the Integration Manager. The Integration Manager calls the Rule Manager.

Substitution occurs before the data is posted to the FI-SL databases.

You define substitution rules using Boolean logic. When you define a substitution rule, the system checks the substitution rule to ensure that it is syntactically correct.

For more information, see Substitution [Seite 1083] or What Are Substitutions? [Seite 1043]. For more information on using substitutions, see Creating a Substitution [Seite 1084]. For more information on Boolean Logic, see Introduction to Boolean Logic [Seite 1121].

Rules
A rule is a Boolean expression that you can use as a condition, as a check, or in another rule. Rules enable you to refer to frequently used Boolean statements simply by specifying the rule name.
The FI-SL Integration Manager uses Boolean logic. When you use Boolean logic and syntax, you can:

- Validate data
- Substitute data
- Select ledgers for posting
- Transfer substitution data to a rollup ledger
- Select report data

The Rule Manager stores the Boolean rules used to analyze data. The Integration Manager calls the Rule Manager and determines whether entered data should be used. If a Boolean statement is true, an action is taken; if a statement is false, no action is taken.

Boolean logic is used in the following FI-SL modules:

- Validation
- Substitution
- Ledger selection
- Report Writer
- Rollups

To use Boolean Logic in one of the functions listed, you create statements that are used as formulas in the FI-SL System. For more information on using Boolean Logic, see Introduction to Boolean Logic [Seite 1121] or Boolean Logic Statements and Rules [Seite 1048].
What Are Validations?

In the SAP R/3 System, nearly all input values are validated by a program or against tables or master files. Since some types of validations cannot be standardized, you can use the validations program to create validations for your specific requirements.

The validation function enables you to check values and ranges of values as they are being entered in the SAP R/3 System. Validation rules are stored in the Rule Manager. As data is entered into the system, the Integration Manager validates the data against the validation rules. Because data is validated before it is actually posted, only valid information is posted to the FI-SL application component.

Many values that you enter into the SAP R/3 System are automatically checked against standard validation rules.

The system validates account numbers against a master file or checks that a ledger is assigned to a local company code.

You use validations when you want to create a user-defined Boolean statement to validate an entry in a way that is not defined for the standard system. FI-SL validations allow you to create your own Boolean statements without making any changes to the standard system.

A validation can consist of up to 999 steps. You can therefore validate data against any number of Boolean statements before the data is posted.

A validation step contains the following statements:

**Prerequisite statement**

The prerequisite statement determines whether the entered value(s) should be checked. If the prerequisite statement is false, then the value is valid and the transaction continues.

**Check statement**

The check statement determines whether the entered value(s) are valid. If the check statement is true, then the value is valid and the transaction continues. If the check statement is false, the system displays a message.

You define prerequisite and check statements using Boolean logic. You can define simple statements or create complex statements using rules, user exits, and sets as part of the Boolean statement.

The following table shows examples of user-defined validations:

<table>
<thead>
<tr>
<th>Prerequisite statement</th>
<th>Check statement</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the account is a revenue account,</td>
<td>then only sales centers can be posted.</td>
</tr>
<tr>
<td>If the currency is US dollars and the cost center is 100,</td>
<td>then the business area must be 2 and the plant must be 10.</td>
</tr>
<tr>
<td>If the user is contained in set RGUSER-02 and the currency is in set RGACCT-02,</td>
<td>then the account must be in set RGACCT-02.</td>
</tr>
<tr>
<td>If the user and the currency are contained in the multidimension set USERCUR-02,</td>
<td>then the account must be in set RGACCT-05.</td>
</tr>
</tbody>
</table>
The following graphic illustrates how FI-SL validations interact with values entering the SAP R/3 System:

For each validation step:

Data is entered into the SAP R/3 System.

Data is sent to the FI-SL Integration Manager and to validations.

Validations are part of the Integration Manager along with substitutions, ledger selection rules, and summation rules.

Data is then checked against a prerequisite statement.

If the prerequisite statement is true, the data is checked against the check statement. If the prerequisite statement is false, the data is valid.

If the prerequisite statement is true and the check statement is:

- **True**, then the data is valid
- **False**, then the system displays a message

You need to correct \(E\) (error) type messages before the value you are validating can be posted. You should also correct \(W\) (warning) type messages. \(A\) (abend) type messages result in termination of validation processing.
What Are Validations?

If there are additional steps in the validation process, the system repeats the steps described here.

For more information about creating Boolean statements, see Creating Boolean Statements for the FI-SL System [Seite 1125].

For more information about creating validations, see Creating a Validation [Seite 1057].

Matrix Validations

You can also create matrix validations for certain callup points. Matrix validations allow you to execute a validation for the complete document, including the document header and all document lines.

You create a matrix validation to check that a certain combination of accounts is valid. The validation compares the contents of each document line with all other document lines.

You can only use matrix validations together with callup point code 0003 within the Financial Accounting (FI), Legal Consolidation (FI-LC), and Consolidation (EC-CS) application areas.

Validation Messages

When you create validations, you can also define the result of breaking the validation rule. You can create the message and the message long text that should appear on the user's terminal if a check statement is not met. You can instruct the system to send the user an information message or you can require the user to correct the error before continuing with data entry.

Suppose a user cannot post to cost center 200. When the user attempts to post to cost center 200, a message appears and the user is not allowed to continue with processing.

For more information, see Validation Messages [Seite 1062].
What Are Substitutions?

Substitution rules are stored in the Rule Manager. When data is entered in the system, it is substituted by the Integration Manager. Substitution occurs before the data is added to the FI-SL summary tables.

In FI-SL substitution, the values entered into the SAP R/3 System are validated against a prerequisite defined by the user. When the prerequisite is met, the system replaces the values entered with substitute values, and the substitute values are transferred into the FI-SL application component.

The system first performs validation and then substitution. This gives you the opportunity of having the system validate values that are to be substituted.

A substitution process can contain up to 999 steps. Before posting, therefore, you can substitute the values using any number of Boolean statements.

A substitution step contains the following Boolean statements:

Prerequisite statement

The prerequisite statement establishes which conditions must be fulfilled before the substitution can be performed. If the prerequisite statement is false, the transaction is continued without substitution. If the prerequisite statement is true, the transaction is continued with the substituted values.

Substitution value(s)

The substitution value is a numerical value or a string of letters that replace the value entered. A single substitution process can replace more than one value.

Substitution exit

You can specify that substitution is to be performed through a substitution exit. The substitution exit number directs the system to an ABAP program defined by the user. Substitution exits enable you to define more complex substitutions and replace more than one value in a substitution. For more information, see User Exits in Validations/Substitutions/Rules [Seite 1053].

When you define substitutions, you use the same syntax that you use with validations. The prerequisite statement used in a substitution can consist of a simple statement or a complex combination of statements composed of logical statements, rules, and sets.

The following table contains examples of user-defined substitutions:

<table>
<thead>
<tr>
<th>Prerequisite statement</th>
<th>Substitution</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the cost center is 10,</td>
<td>use the value 01 for the plant and the value 30 for the business area.</td>
</tr>
<tr>
<td>If the account is 100000 and the business area is 20,</td>
<td>use the value 100 for the cost center and the value 012 for the deadline.</td>
</tr>
<tr>
<td>If the account is in set ACCT-23 and the cost center is in set CENTER-56,</td>
<td>use the value “blank” for the product key.</td>
</tr>
</tbody>
</table>
What Are Substitutions?

Substitution enables you to update the data transferred into the application component FI-SL in greater detail.

Suppose you create a substitution that replaces (adds) the value 10 in the dimension plant whenever the account entered is within the range 100000 to 200000 and the cost center is 200. When the entry values are posted in FI-SL, the system uses the value 10 for the dimension plant if the account entered is within the range 100000 to 200000 and the cost center is 200.

The following graphic illustrates how FI-SL substitution interacts with the values entered into the SAP R/3 System.

For each validation step:
Data is entered into the SAP R/3 System.

The data is sent to the FI-SL Integration Manager (IM) and to the substitution rules.
Substitutions are part of the Integration Manager along with validation, ledger selection rules, and summation rules.

The data is then checked against a prerequisite statement.
If the prerequisite statement is true, the substitution is performed. If the prerequisite statement is not true, no substitution takes place.

If there are additional steps in the substitution process, the system repeats the steps described here.

If you want to use data from other SAP applications as substitution values in the application component FI-SL, the dimension to be substituted must be defined for the Boolean class for which the data is to be substituted.
For more information on creating substitution statements, see Creating Boolean Statements for the FI-SL System [Seite 1125].

For more information on creating substitutions, see Creating a Substitution [Seite 1084].

**Matrix Substitutions**

You can also create **matrix substitutions**. Matrix substitutions allow you to execute a substitution for the complete document, including the document header and all document lines.

You can only use matrix substitutions together with callup point code 0003 within the Financial Accounting (FI) application area.
Overview of Validations/Substitutions

To create validations and substitutions, you must complete the following tasks:

Decide where and when the validation or substitution should be performed.

To do this, enter the following codes:

- **Application area** code
  
  This is a 2-place character code that specifies the general application area where the validation or substitution occurs (for example, GL for FI-SL postings).

- **Callup point** code
  
  This is a 4-place number that specifies the exact point of the validation or substitution (for example, 0001 for the posting header check).

The combination application area/callup point code determines the data that you can validate or substitute.

For more information on application areas, see Application Areas [Seite 1050].

For more information on callup points, see Validation/Substitution Callup Points [Seite 1051].

Create a validation or substitution, or change an existing validation or substitution.

To create a validation, proceed as follows:

- Enter the application area and callup point for the validation.
- Define the prerequisite statement, which determines whether or not the data should be checked.
- Define the check statement, which validates the data.
- Define the messages that will appear if a check statement is found to be false during validation.

  For more information, see Creating a Validation [Seite 1057].

To create a substitution, proceed as follows:

- Enter the application area and callup point for the substitution.
- Define the statement to be used for selecting data for substitution, and enter the value that is to replace the selected data.

  For more information, see Creating a Substitution [Seite 1084].

Activate the validation/substitution.

You activate a validation/substitution as follows:

Enter the callup point and company code (for local companies) or the company ID (for global companies) for the validation or substitution.

Assign the validation or substitution name to the callup point or company combination, and enter an activation level.

Once the validation or substitution is activated, the system calls it each time a posting is made.
For more information, see Activating a Validation in FI-SL [Seite 1069] and Activating a Substitution in FI-SL [Seite 1091].

For more information on validations and substitutions in Controlling (CO), see the step Account Assignment Logic in the Implementation Guide (IMG) for General Controlling.
Boolean Logic Statements and Rules

The SAP R/3 System uses the logic of Boolean algebra to define validation and substitution statements. A **Boolean logical statement** is a logical proposition that can be either true or false but not both. Statements can be linked together using operators such as AND, OR, and NOR to create complex statements.

Boolean algebra uses truth tables to determine the truth value (TRUE or FALSE) of logical statements. A truth table assigns the value T (TRUE) or F (FALSE) to each statement in a complex logical statement. This information can then be used to determine whether the complex statement itself is true or false.

The following graphic uses a truth table for the AND (conjunction) operator to determine whether a value should be substituted.

In this example, if the transaction contains account 500000 and cost center 150, then the combined statement is true and the value is substituted. If the transaction does not contain both account 500000 and cost center 150, the combined statement is false and the value is not substituted.

In the FI-SL application component, you can use a Boolean statement in one process and then use the same statement in another process by linking the statement to another statement. To use a Boolean statement in an FI-SL process or in another statement, you create a rule.
Rules

A rule is a Boolean statement that you can use as a prerequisite, as a check, or in another rule. Rules allow you to refer to frequently used Boolean statements by using the rule name.

Rules are used in the following FI-SL components:

Validation
Substitution
Ledger selection

For more information on using rules in ledger selection, see FI-SL Master Data: Special Purpose Ledgers [Seite 42].

Report Writer

For more information on using rules with the Report Writer, see Defining Selection Criteria [Seite 835].

Rollups

For more information on using rules with rollups, see Creating a Rollup [Seite 272].

You create rules in Customizing for Special Purpose Ledger under Tools → Maintain Validation/Substitution/Rules → Maintain Logical Rules. For more information on Boolean logical statements and rules, see Creating Boolean Statements for the FI-SL System [Seite 1125].

Rule Manager

The validation and substitution software also contains a Rule Manager, which contains all rules created in the FI-SL application component. The Rule Manager also processes rules when they are called from a validation/substitution callup point.

If a rule does not exist but is defined for a validation and/or substitution, the Rule Manager displays an error message.
Application Areas

The application area specifies the general application area where the validation, substitution, or rule occurs (for example, GL for FI-SL postings).

Application Areas Used in Validations/Substitutions/Rules

<table>
<thead>
<tr>
<th>Application area</th>
<th>Validations</th>
<th>Substitutions</th>
<th>Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>AM Asset Management</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>CO Controlling</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>CS Consolidation</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FI Financial Accounting</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>GL Special Purpose Ledger</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>GR Report Writer</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>GS Ledger Selection</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>GU Rollups</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>KC Enterprise Controlling: SAP–EIS</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>LC Legal Consolidation</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PC Profit Center Accounting</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>PS Project System</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
Validation/Substitution Callup Points

**Callup points** are specific places in an application that specify the exact location where a validation/substitution occurs. If you want to validate or substitute a value, you must activate validation or substitution for the callup point for which you want the validation or substitution to occur.

If you want to validate account numbers that are directly entered into the FI-SL application component, you must create a validation for callup point 0002 (document line item) with application area GL (Special Purpose Ledger). (Callup point 0001 would validate the document header and not the individual document line items.) You need to activate the validation once you have created it.

At each callup point, the system can use information you have already entered (such as a user name, header information, and information entered in previous callup points) to validate or substitute the values you enter at a callup point.

Suppose your check statement requires that for local company code 0001 and currency code USD, the account number must be between 200000 and 220000. In Financial Accounting (FI), you enter the account number at callup point 0002. However, you enter the local company code and currency code prior to callup point 0002. The system uses the local company code and currency information you entered in the document header (callup point 0001) to validate the account number you enter at callup point 0002.

Different application areas may use the same callup point code, but the callup point code has a different callup point, depending on the application area.

For example, callup point code 0001 is used for the document line item in Controlling (CO) validations and for the document header in Special Purpose Ledger (FI-SL) validations.
Boolean Classes

Boolean classes establish the dimensions that can be used in the definition of validations, substitutions, and rules. They also specify which message classes can be used for validation messages.

Application area CO and callup point 0001 use Boolean class 001, which is a list of all COBK and COBL fields.

If you create a validation that uses Boolean class 001, you can only use the COBK and COBL fields that are defined for Boolean class 001.

When you create validations, substitutions, and rules, you must assign an application area and callup point code to the validation, substitution, or rule. The key for the application area specifies the general application area where the validation/substitution is used (such as GL for FI-SL postings). The key for the callup point establishes the point at which the processing of the validation or substitution (such as 0001 for a check in the document header) starts. The combination of application area and callup point code determines the Boolean class for a validation, substitution, or rule. The Boolean class defined for a validation or substitution is stored in the header of the validation or substitution.

Tables GB01 and GB01C determine which fields can be used for a specific Boolean class. Table GB01 is a client-independent control table shipped with the SAP R/3 System. This table cannot be changed. Table GB01C is client-dependent and is provided specifically for customer configuration.

FI validations will also be performed on posting lines for documents that are posted from other application areas or that are automatically generated.

It is not possible to select another Boolean class for a callup point. However, you can modify the contents of the Boolean class by adding or deleting dimensions. For more information, see Adding Fields to and Deleting Fields from a Boolean Class [Seite 1160].
User Exits in Validations/Substitutions/Rules

User exits are user-defined FORM routines that are used to calculate and/or replace values within a validation, substitution, or rule.

User exits have the following format:

\( u \) (for a user-defined user exit) or \( s \) (for a standard user exit)

The user exit number (three digits)

For example, \( u123 \) is a user exit.

You can configure the form pool name of the user exits and must store it in the table for client-dependent user exits (T80D) in Customizing. Table T80D contains the form pool names for the user exits used in validations, substitutions, and rules. Each validation/substitution form pool is client-dependent. (For more information, refer to the Maintain Client-Dependent User Exits activity in the Implementation Guide (IMG) for Special Purpose Ledger.)

Example form pools RGGBS000 and RGGBR000 for client 000 are shipped with the SAP R/3 System. You must copy these form pools and configure them in T80D. The new form pool name should conform to the customer’s naming convention (beginning with the letter z) so that is not overwritten when the next SAP upgrade is installed (for example, ZGGBR000).

Example FORM routine for substitution exit 001 (U001).

```
TABLES: COBL.

FORM U001.
  COBL-KOSTL = COBL-BUKRS.
ENDFORM.
```

Tables and structures should not be declared in the FORM routines so that the contents can be used together with the calling transaction.

SAP exits are FORM routines that have been programmed by SAP. The name of the form pool for SAP exits is SAPFGBEB.

If you still store your rules in table T890 (interpreted rules), you cannot use user exits in your rule definition. It is recommended that you use report program RGUGBR10 to convert interpreted rules into generated rules so that you can use the Customizing function for maintaining rules. For more information, see Using the Rule Manager Reports [Seite 1164].

The following table shows the types of user exits that can be used in validations, substitutions, and rules.

<table>
<thead>
<tr>
<th>User exit type</th>
<th>Description</th>
<th>Application</th>
<th>Example</th>
</tr>
</thead>
</table>

April 2001
### User Exits in Validations/Substitutions/Rules

<table>
<thead>
<tr>
<th>Exit Type</th>
<th>Description</th>
<th>Rules, validations, and substitutions</th>
<th>Form Pool/Parameter Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>No parameters are defined for the user exit.</td>
<td>Rules, validations, and substitutions (prerequisite)</td>
<td>See form pool RGGBR000, parameter type C_EXIT_PARA M_NONE</td>
</tr>
<tr>
<td>2</td>
<td>Same as user exit type 1, except one parameter (the field to be substituted) is defined in the user exit. For example, you can create a substitution routine that analyzes the cost center irrespective of the field used.</td>
<td>Substitution</td>
<td>See form pool RGGBS000, parameter type C_EXIT_PARA M_FIELD</td>
</tr>
<tr>
<td>3</td>
<td>All data is passed as one parameter; this exit type can only be used in matrix validations and substitutions.</td>
<td>Rules, validations, and substitutions (prerequisite)</td>
<td>See form pool RGGBR000, parameter type C_EXIT_PARA M_CLASS</td>
</tr>
</tbody>
</table>

Validations and rules use exit numbers 1 and 3 from the above table.

Substitutions use all of the exit numbers from the above table.

For substitutions, you can also create user exits that accept a field as one parameter and then return the changed value in this parameter. This allows you to create a user exit that can be used independently of the field and table name. This type of user exit cannot be used as an entry in the Exit only field in the list of values to be substituted; you can only use this exit type in conjunction with a field name. An example of this user exit type is in form pool RGGBS000.

If you want to define a parameter for your user exit that is different from the result of a validation (B_RESULT), you must make an entry for your user exit in the FORM routine GET_EXIT_TITLES in the form pool you defined. It is recommended that you copy the SAP example form pool RGGBR000 for validation exits or RGGBS000 for substitution exits. These example form pools already contain entries in the FORM routine GET_EXIT_TITLES for the examples delivered by SAP.
**Formula Builder**

**Use**

Beginning with Release 4.0A, you can use the Formula Builder to enter logical statements and mathematical formulas.

The Formula Builder provides an easy-to-use interface for entering logical statements in validations, substitutions, and rules.

**Features**

In the Formula Builder, all elements that you can enter in a logical statement (for example, operators, operands, sets, constant values, and so on) are displayed as pushbuttons.

You enter a logical statement by choosing the elements that you want to include in the statement. At each step, the system checks the syntax of the statement (including the use of parentheses) to ensure that it is correct. Depending on your previous entry you can only choose from the highlighted elements. This ensures that the syntax of your logical statement is correct as you define it.

You can work in the Formula Builder using three different settings:

The default setting when you call up the Formula Builder is *Short descriptions*. All operands (such as table fields, sets, exits, and so on) are displayed using their respective descriptions.

If you want to enter statements using the technical names of the operands rather than the descriptions, you change the setting by choosing *Settings → Technical names*.

The *Expert mode* setting displays the technical names of the operands and allows you to enter a statement directly. In this case, the statement field is ready for input.

> When you enter a logical statement directly using the expert mode, you must use the new syntax rules for Release 4.0A. For more information, see [Syntax Rules for Boolean Statements](Seite 1133).

You change the Formula Builder settings using the respective functions under the *Settings* menu option.
Validation

Use

With validations, you can check values and combinations of values as they are being entered in the SAP R/3 System. As data is being entered it is checked against validation rules that are stored in the Rule Manager. Because validation occurs before data is posted, only valid information enters the FI-SL application component.

You can use a validation simultaneously at different callup points and you can create different dependencies for validating data. For more information, see validation/substitution callup points [Seite 1051]. Also, you can create validations in the system, even if they are not used anywhere (for example, for future use).

For more information on the additional functions for validations, see additional functions [Seite 1159].

To troubleshoot validations, substitutions, or rules, you should use the Simulate and Switch on trace functions.

For more information, see:

- Tracing a Validation/Substitution/Rule [Seite 1169]
- Simulating a Validation/Substitution/Rule [Seite 1170]

As from Release 4.6 there is a new interface with controls for processing rules. If you want to continue using the old interface, make the following settings: In the menu, choose System → User profile → Own data. Then choose Parameters and create an entry with the parameter GBK and the value X.

Example

Examples of validation rules:

- If the cost center is 10, then the account must be 400000.
- If the currency is DEM and the document type is SA, then the plant must be 02.
- If the user is contained in set RGUSER-01 and the currency is contained in set RGCUR-02, then the account must be in set RGACCT-02.
Creating a Validation

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Validation. For more information about creating a validation see the Implementation Guide (IMG) under Maintain Validation [Extern].

The Validation Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point.

This node contains both the validation and the rule list that have been created for this application area and callup point. You can also process the rules from here (create/change/display/delete).

Choose Validation → Create.

The Create Validation: New validation (Header data) appears.

Enter the following data:
– Validation name
– Validation description

You can also enter an authorization group to limit the number of users that can process this validation.

To accept these entries, press Enter.

If you want to create a validation by copying an already existing one, choose the corresponding callup point in Control and mark the rule you want to use as a reference. Wait until both screen areas of the system are ready for entry, then choose Validation → Copy. Enter data as described in Step 3 above.

The validation must have the same Boolean class as the validation you are creating.

If you are creating a matrix validation, allowing you to validate data for an entire document, you use callup point code 0003 in Financial Accounting (FI), Legal Consolidation (FI-LC), and Consolidation (EC-CS).

The following table shows example entries for the application area/callup point combinations.

<table>
<thead>
<tr>
<th>Application area</th>
<th>Callup point</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO</td>
<td>0001</td>
<td>Document line item</td>
</tr>
<tr>
<td>GL</td>
<td>0001 0002</td>
<td>Document header</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Document line item</td>
</tr>
</tbody>
</table>
Creating a Validation

<table>
<thead>
<tr>
<th>FI</th>
<th>0001</th>
<th>Document header</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>0002</td>
<td>Document line item</td>
</tr>
<tr>
<td></td>
<td>0003</td>
<td>Total document</td>
</tr>
</tbody>
</table>

Choose Save.

The Create Validation: <Validation Name> (Header data) screen appears.

You can use the following additional functions on this screen.

**Additional Processing Functions** Create Validation: <Validation Name> (Header data) Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation → Create</td>
<td>Create a validation</td>
</tr>
<tr>
<td>Validation → Select</td>
<td>Select a validation. The system expands the corresponding node down to the selected validation automatically. A confirmation prompt gives you the opportunity to change your selection.</td>
</tr>
<tr>
<td>Validation → Copy</td>
<td>The system creates a new validation by copying the validation currently marked.</td>
</tr>
<tr>
<td>Validation → Change</td>
<td>Switch to change mode</td>
</tr>
<tr>
<td>Validation → Display</td>
<td>Switch to display mode</td>
</tr>
<tr>
<td>Validation → Save</td>
<td>Save the validation</td>
</tr>
<tr>
<td>Edit → Insert step</td>
<td>Insert new step (empty). If steps already exist, the new step is inserted as the last step.</td>
</tr>
<tr>
<td>Extras → Flds in Bool.statmnt</td>
<td>Display a list of valid fields that you can use for the validation. These fields are determined based on the Boolean class of the validation.</td>
</tr>
<tr>
<td>Extras → Substitution flds...</td>
<td>Display a list of valid fields that can be changed within a substitution</td>
</tr>
<tr>
<td>Extras → Rule list</td>
<td>Display a list of rules that you can use for the newly created validation</td>
</tr>
<tr>
<td>Extras → Set directory</td>
<td>List sets that have been created in your system. For more information, see Displaying a Set Directory [Seite 685].</td>
</tr>
<tr>
<td>Extras → Switch on trace</td>
<td>Switch on the tracing function. While posting a document, the system calls the validation and shows you which data is used. This function allows you to diagnose possible errors in the validation definition. For further information, see Tracing a Validation/Substitution/Rule [Seite 1169].</td>
</tr>
<tr>
<td>Extras → Switch off trace</td>
<td>Switch off the tracing function</td>
</tr>
<tr>
<td>Extras → Usage</td>
<td>Display where the validation is currently used.</td>
</tr>
</tbody>
</table>
Creating a Validation

| Environment → Maintain rules | Create/change/display rules. Select the node containing the rule list. |
| Environment → Create rule | Create a rule |
| Environment → Select rule | Select a rule |
| Environment → Maintain messages | Create/change/display/delete messages and message classes. |

To create a new step for your validation, choose Edit → Step or choose the corresponding function from the application tool bar. The Create Validation: <validation name> - Step <step number> - Overview appears.

You can use the following additional functions on this screen.

| Edit → Insert step | Insert a new step directly before the step currently being processed |
| Edit → Copy step | Insert a new step with the content of the step currently being processed |
| Edit → Delete step | Delete a step |
| Goto → Header | Return to validation header data |

To process an existing validation step, mark the step <no.> node in Control. You will then see an overview of the prerequisites, checks and messages created for this step,. If required, enter a description for the validation step. To edit any of these elements, either double-click in the corresponding area or navigate in Control by choosing the required node.

Define the Boolean statement used as the prerequisite statement for selecting data for validation.

If the prerequisite statement is false, the entered value is not selected for validation and the transaction continues. If the prerequisite statement is true, the entered value is checked against the check statement entered in the Check field.

The Formula Builder provides an easy-to-use interface for entering logical statements in validations, substitutions, and rules. For more information, see Formula Builder [Seite 1055].

Define the Boolean statement used as the check for validating the data selected by the statement in the Prerequisite field.

If the check statement is true, the entered value is valid and the transaction continues. If the check statement is false, the system sends a message to the user.

The Formula Builder provides an easy-to-use interface for entering logical statements in validations, substitutions, and rules. For more information, see Formula Builder [Seite 1055].

For more information about the syntax rules for entering Boolean statements, see Syntax Rules for Boolean Statements [Seite 1133].
Creating a Validation

You can also enter a user exit (type 1 or 3) in the prerequisite and/or check statement. For further information about user exits, see User Exits in Validations/Substitutions/Rules [Seite 1053].

In the Create Validation: <validation name> - Step <step no.> - Message, enter the following data:

- Message type and number
  You must enter all digits for the number, including the leading zeros.

- Message variables
  There are four (1-4) table/field entry fields for up to four message variables (&). When the system encounters a variable (&) in a message, it replaces the variable with the corresponding table/field value. The order of the table/field names corresponds to the order in which the variables appear in the message.

There are two variables in the following message:

Cost center & cannot be used with account &

The first variable (&) refers to table GLU1 and the dimension "Cost Center" (RCNTR). Therefore, the entries in the first Output fields are as follows:

Output fields 1

GLU1 RCNTR

The second variable (&) refers to table GLU1 and the dimension "Account" (RACCT). Therefore, the entries in the second Output fields are as follows:

Output fields 2

GLU1 RACCT

If the value entered for cost center is 100, the value entered for account is 0000050000, and the check statement is false, the system displays the message:

Cost center 100 cannot be used with account 0000050000

The table/field combinations that can be used for this validation depend on the fields used in the prerequisite and check statements. All fields used in the prerequisite and/or check statements can be used in the validation message. You can call up valid table/field combinations via the entry help.

For more information about entering messages, see Validation Messages [Seite 1062].

Indicator that determines whether a workflow is started from the validation step in addition to a system message, if the prerequisite statement is true and the check statement is false.

If you want to start a workflow from a validation step, you must first define your own workflow and workflow action in the SAP Business Workflow (Development) menu (Tools → SAP Business Workflow → Development).

The object type VALIDATION and the event Triggered, which is started when the validation fails, are delivered with the validations and substitutions software.

The standard function MsgDisplay is also delivered with the validations and substitutions software. This function allows you to display the message to be output by
the validation (including the output fields for the message variables) after a workflow has been started from the validation.

You must specify the name of the user(s) who receive(s) the validation message and workflow. This recipient then receives a list of work items in the system inbox, detailing the activities to be processed.

For more information about workflows in FI-SL, see the SAP Library *Triggering a Workflow From a Validation (FI-SL) documentation* (*Basis Components* → *Business Engineering Workbench* → *Workflow Scenarios in Applications*).

For general information about business workflows, see the SAP Library *SAP Business Workflow documentation* (*Basis Components* → *Business Engineering Workbench*).

During processing of a validation the steps are numbered sequentially by the system automatically. Move steps as follows: Mark the node of the step you wish to move. You can then move the step to the node of a different step. The selected step is inserted after the target step (Drag and Drop method). This only possible within a validation.

Once you have finished processing the validation, choose Validation → Save.
Validation Messages

When you define validations, you can also specify which message will appear on the user’s terminal when a check statement is not met. You can create a long text for each message.

Creating/Changing a Message

Select the desired validation. Choose Environment → Maintain messages.

The screen Maintain Messages: Class &class ID& appears.

You can also access message maintenance when maintaining steps in a validation. If the Message node is marked, you can choose the corresponding pushbutton in the right-hand area of the screen to call up the Maintain messages function.

In the Message class field, enter the message class for which you want to create or change messages.

Choose Messages and then Change.

The screen Maintain Messages: Class &message class& appears. The messages are displayed in the logon language. If you want to create or change messages in another language, you must log off and then log on again in the language in which you want to enter messages.

To create a message:

a) Position the cursor on the first empty message line.

b) Choose Messages → Individual maint.

c) Enter a text for the message.

   If you want to use a variable in the message, enter an ampersand (&) for the variable. You can enter a maximum of four variables in a message.

Cost center & cannot be posted with business area &

   Two variables are used in this message: one for the cost center and one for the business area. You define the table/field name for the variable when you create the validation.

To change a message:

a) Position the cursor on the message you want to change.

b) Choose Messages → Individual maint.

c) Overwrite the current message text with your changes.

You can use the following additional functions in this screen:

Additional Functions on Maintain Messages: Class &Message Class& Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1062

April 2001
<table>
<thead>
<tr>
<th>Message Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Messages → Other message class</td>
<td>Create/change/display messages in another message class.</td>
</tr>
<tr>
<td>Messages → Maintain all</td>
<td>Change all messages</td>
</tr>
<tr>
<td>Messages → Individual maint.</td>
<td>Change a particular message</td>
</tr>
<tr>
<td>Messages → Compact display</td>
<td>Display only the messages that have been defined</td>
</tr>
<tr>
<td>Messages → Save</td>
<td>Save the messages</td>
</tr>
<tr>
<td>Messages → Print</td>
<td>Print the messages</td>
</tr>
<tr>
<td>Edit → Next free number</td>
<td>Create message using next available message number</td>
</tr>
<tr>
<td>Edit → Next used</td>
<td>Display next defined message number</td>
</tr>
<tr>
<td>Edit → Delete</td>
<td>Delete a selected message</td>
</tr>
<tr>
<td>Edit → Select</td>
<td>Select a message for further processing (to delete it, for example)</td>
</tr>
<tr>
<td>Edit → Find...</td>
<td>Search for a particular message text</td>
</tr>
<tr>
<td>Edit → Continue search</td>
<td>Search again for the message text last entered</td>
</tr>
<tr>
<td>Edit → Set as self-explanatory</td>
<td>Mark a message as self-explanatory so that the message does not need to be documented</td>
</tr>
</tbody>
</table>

Goto → Documentation → Long text  | Display or change the long text (documentation) for a message |

Goto → Documentation → Not to be documented | Mark a message as self-explanatory so that the message does not need to be documented |

Goto → Translation          | Translate the message text                                                   |

Goto → Message class        | Display or change the message class for a message                           |

Goto → Additional information | Assign an object type (such as a table view) and subobject to the message, if desired |

Utilities → Message class list  | Display list of defined message classes                                      |

Utilities → Change requests (Organizer) | Call up the Workbench Organizer, for example to maintain and display transport requests |

Utilities → Global search... | Global search for message text as a string or word                           |

Utilities → Global replace... | Global search and replace for message text as a string or word               |

Utilities → Where-used list | Display where a message is used                                               |

To save the message, choose Messages → Save.
Validation Messages

The system saves the message you created or changed.

Displaying a Message

On the screen Create Validation: <Validation Name> (Header data), choose Environment → Maintain messages.

The screen Maintain Messages: Class <class ID> appears.

In the Message class field, enter the message class for which you want to display messages.

For validations messages, the standard version of the application component FI-SL contains message class K2.

Choose Messages and then Display.

The screen Display Messages: Class <message class> appears. The messages are displayed in the logon language. If you want to display messages in another language, you must log off and then log on again in the language for which you want to display messages.

Deleting a Message

On the screen Create Validation: <Validation Name> (Header data), choose Environment → Maintain messages.

The screen Maintain Messages: Class <class ID> appears.

In the Message class field, enter the message class for which you want to delete messages.

Choose Messages and then Change.

The screen Maintain Messages: Class <message class> appears.

Position your cursor on the message you want to delete, and double-click.

Choose Edit → Delete.

A dialog box appears, asking if you want to delete the message.

To delete the message, choose Yes.

You cannot delete a message that is used by another program (for example, in validations or substitutions).
Validation Message Classes

Each validation message is assigned to a message class. The FI-SL application component is delivered with message class K2 containing examples of validation messages.

Creating a Message Class

To create a message class, you should use the ABAP Workbench (Tools → ABAP Workbench → Development → Programming environment → Messages). You can edit messages with the validation editor, but a message class should first be created in the ABAP Workbench. For more information, see the Basis documentation in the SAP library (Basis Components → ABAP Workbench → ABAP User’s Guide → Writing ABAP Transactions → Handling Errors and Messages).

The first time you define validations in the system, the system prompts you to assign a message class to the validation messages you define.

⚠️

The message class must belong to a transportable, customer-specific development class. Otherwise these messages cannot be transported together with the validation.
Displaying a Validation

In Customizing for *Special Purpose Ledger*, choose *Tools → Maintain Validation/Substitution/Rules → Maintain Validation*. For more information, about creating logical rules, see the Implementation Guide (IMG) under *Logical Rules for Validation and Substitution [Extern]*.

The *Validation Maintenance* screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required validation.

Choose *Validation → Display*. The *Display Validation: <Validation Name> (Header data)* screen appears.

You can use the following additional processing functions on this screen.

**Additional Processing Functions Display Validation: <Validation Name> (Header data) Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Validation → Select</strong></td>
<td>Select a validation. The system displays the selected validation and expands the corresponding node automatically.</td>
</tr>
<tr>
<td><strong>Validation → Simulate</strong></td>
<td>Simulate the validation to view which data fields will be used for validation/substitution when the validation is called. For more information, see <em>Simulating a Validation/Substitution/Rule [Seite 1170]</em>.</td>
</tr>
<tr>
<td><strong>Validation → Overview</strong></td>
<td>Display content of validation: Steps with messages, prerequisites and checks with the elements used (structure fields, exits, sets and other rules).</td>
</tr>
<tr>
<td><strong>Validation → Display -&gt; Change</strong></td>
<td>Switch to change mode</td>
</tr>
<tr>
<td><strong>Extras → ...</strong></td>
<td>See: <em>Creating a Validation [Seite 1057]</em></td>
</tr>
<tr>
<td><strong>Environment → ...</strong></td>
<td>See: <em>Creating a Validation [Seite 1057]</em></td>
</tr>
</tbody>
</table>

To display the content of a validation, expand or select the required nodes.
Changing a Validation

In Customizing for Special Purpose Ledger, choose Tools → Maintain

Validation/Substitution/Rules → Maintain Validation. For more information about creating logical rules, see the Implementation Guide (IMG) under Logical Rules for Validation and Substitution [Extern].

The Validation Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required validation. The Change Validation: <Validation Name> (Header data) screen appears.

By expanding and selecting the relevant node you can process the corresponding elements. You change the prerequisites and checks using the Formula Builder.

A prerequisite or check is limited to 33 lines.

**Additional Processing Functions**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation → Transport</td>
<td>Transport the validation to another system. For more information, see Transporting Validations/Substitutions/Rules [Seite 1166].</td>
<td></td>
</tr>
<tr>
<td>Validation → Delete</td>
<td>See: Deleting a Validation [Seite 1068]</td>
<td></td>
</tr>
<tr>
<td>Extras → ...</td>
<td>See: Creating a Validation [Seite 1057]</td>
<td></td>
</tr>
<tr>
<td>Environment → ...</td>
<td>See: Creating a Validation [Seite 1057]</td>
<td></td>
</tr>
</tbody>
</table>

Moving a Validation Step

During processing of a validation the steps are numbered sequentially by the system automatically. Move steps as follows: Mark the node of the step you wish to move. You can then move the step to the node of a different step. The selected step is inserted after the target step (Drag and Drop method). This only possible within a validation.
Deleting a Validation

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Validation.

The Validation Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required validation. The Change Validation: <Validation Name> (Header data) screen appears.

Choose Validation → Delete.

A dialog box appears, asking if you want to delete the validation.

If the validation is currently used in the system, a dialog box appears, displaying the application components where the validation is used.

You cannot delete validations that are being used in an R/3 application component or in another validation.

To delete the validation, choose Yes. The validation has been deleted. You cannot restore a deleted validation.
Activating a Validation in FI-SL

Before you can use a validation, you need to activate it. If, for example, you are using the validation in Controlling (CO), you need to activate it in CO. For information about using validations in CO, see the relevant CO documentation.

If you are using the validation in Special Purpose Ledger (FI-SL), you need to activate it there.

Procedure

In Customizing for Special Purpose Ledger, choose Basic Settings → Validation → Maintain Local Validation (for local company codes) or Maintain Global Validation (for global company codes).

The Change View "Validation for Special Purpose Ledger/CoCode": Overview screen (for local companies) or the Change View "Validation for Spec. Purpose Ledger/Glob. Co.": Overview screen (for global companies) appears.

You can use the following additional processing functions on these screens.

Additional Processing Functions – Change View "Validation for Special Purpose Ledger/CoCode/Glob.Co.”: Overview Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position…</td>
<td>Display a specific company code/application area/callup point combination for a validation.</td>
</tr>
<tr>
<td>Table view → Change → Display</td>
<td>Display the table information.</td>
</tr>
<tr>
<td>Table view → Print → Standard list</td>
<td>Print all validations defined on the system.</td>
</tr>
<tr>
<td>Table view → Print → Variable list</td>
<td>Print specific validations based on user-defined selection criteria.</td>
</tr>
<tr>
<td>Table view → Save</td>
<td>Save the table information you have entered.</td>
</tr>
<tr>
<td>Table view → Transport</td>
<td>Prepare the table for transport under a correction number.</td>
</tr>
<tr>
<td>Edit → New entries</td>
<td>Create a new entry.</td>
</tr>
<tr>
<td>Edit → Selections → Select all</td>
<td>Select all entries for further processing (for example, to delete them).</td>
</tr>
<tr>
<td>Edit → Selections → Deselect all</td>
<td>Deselect all selected entries.</td>
</tr>
<tr>
<td>Edit → Selections → Select block</td>
<td>Select a block of entries for further processing.</td>
</tr>
<tr>
<td>Edit → Delete</td>
<td>Delete an entry(ies).</td>
</tr>
<tr>
<td>Edit → Copy as…</td>
<td>Copy an entry for a new company code/global company.</td>
</tr>
<tr>
<td>Edit → Change fld contents</td>
<td>Change the field contents for a validation definition.</td>
</tr>
<tr>
<td>Edit → Undo change</td>
<td>Change revised validations back to their original definition.</td>
</tr>
</tbody>
</table>
### Activating a Validation in FI-SL

<table>
<thead>
<tr>
<th>Goto → Detail</th>
<th>Display specific information for a validation definition.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Next entry</td>
<td>Display the next validation entry.</td>
</tr>
<tr>
<td>Goto → Previous entry</td>
<td>Display the previous validation entry.</td>
</tr>
<tr>
<td>Goto → Other entry...</td>
<td>Display a specific validation entry.</td>
</tr>
<tr>
<td>Choose → By contents...</td>
<td>Display the validation definitions by the field contents.</td>
</tr>
<tr>
<td>Choose → All selected entries</td>
<td>Display only validation definitions that have been selected using the Edit function.</td>
</tr>
<tr>
<td>Choose → All changed entries</td>
<td>Display only entries that have been changed while using the Change function at this time.</td>
</tr>
<tr>
<td>Choose → All created entries</td>
<td>Display only entries that have been created while using the Create/Change functions at this time.</td>
</tr>
<tr>
<td>Choose → Display del. entries</td>
<td>Display only entries that have been deleted using the Create/Change functions at this time.</td>
</tr>
<tr>
<td>Utilities → Compare → Client 000</td>
<td>Compare the validation entries with the entries delivered in client 000.</td>
</tr>
<tr>
<td>Utilities → Compare → Other client...</td>
<td>Compare the validation entries with the entries in another client.</td>
</tr>
<tr>
<td>Utilities → Compare → Other system...</td>
<td>Compare the validation entries with the entries in another system (for example, a test system versus a productive system).</td>
</tr>
<tr>
<td>Utilities → Request management</td>
<td>Call up the Workbench Organizer, for example, to maintain and display transport requests.</td>
</tr>
<tr>
<td>Environment → Validation</td>
<td>Create a validation.</td>
</tr>
<tr>
<td>Environment → Substitution</td>
<td>Create a substitution.</td>
</tr>
</tbody>
</table>

Choose **Edit → New entries**.

The **New Entries: Overview of Created Entries** screen appears.

Enter the following data:
- Local or global company code for the validation
- Callup point code of the validation
- Validation name
- Activation level for the validation

You can use the additional processing functions in the above table on this screen.

Go back.

To display the validation definition, move the cursor to the validation line and double-click.

To save the activation of the validation, choose **Table view → Save**.
The validation dependency is stored in a table for each application area code.

The following table is an example of the table structure for one application area code.

<table>
<thead>
<tr>
<th>Company</th>
<th>Callup point</th>
<th>Validation</th>
<th>Active</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAPD</td>
<td>0001</td>
<td>VALID1</td>
<td>1</td>
</tr>
<tr>
<td>SAPD</td>
<td>0002</td>
<td>VALID3</td>
<td>1</td>
</tr>
<tr>
<td>SAPGB</td>
<td>0001</td>
<td>VALID2</td>
<td>0</td>
</tr>
<tr>
<td>SAPUSA</td>
<td>0001</td>
<td>VALID1</td>
<td>1</td>
</tr>
</tbody>
</table>

The activation field may vary from one application area code to another.

You can define a validation that uses the application area code CO, but the validation is only active for company 1000 for postings made in CO.
Deactivating a Validation

On the Change View "Validation for Special Purpose Ledger/CoCode/Glob.Co.": Overview screen, enter 0 in the activation level field.

If you choose ENTER, the 0 displays as blank.

Choose Table view → Save.
Validation (old)

With validations, you can check values and combinations of values as they are being entered in the SAP R/3 System. As data is being entered it is checked against validation rules that are stored in the Rule Manager. Because validation occurs before data is posted, only valid information enters the FI-SL application component.

You can use a validation simultaneously at different callup points and you can create different dependencies for validating data. Also, you can create a validation in the system, even if it is not called anywhere (for example, for future use).

As from Release 4.6A there is a new interface with controls for processing rules. If you want to continue using the old interface, you must make the following setting: In the menu choose System → User profile → Own data. Then choose Parameters and create an entry with the parameterGBK and the valueX.

This section contains:

- Creating a Validation (old) [Seite 1074]
- Validation Messages [Seite 1062]
- Validation Message Classes [Seite 1065]
- Displaying a Validation (old) [Seite 1079]
- Changing a Validation (old) [Seite 1081]
- Deleting a Validation (old) [Seite 1082]
- Activating a Validation in FI-SL [Seite 1069]
- Deactivating a Validation [Seite 1072]
Creating a Validation (old)

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Validation.

The Change Validation: Initial Screen appears.

Choose Validation → Create.

The Create Validation: Initial Screen appears.

Enter the following data:

- Validation name
- Application area for the validation
- Callup point code of the validation

The callup point you can enter in this field depends on the application area that you enter for the validation.

If you are creating a matrix validation, allowing you to validate data for an entire document, you use callup point code 0003 in Financial Accounting (FI), Legal Consolidation (FI-LC), and Consolidation (EC-CS).

The following table shows example entries for the application area/callup point combinations.

<table>
<thead>
<tr>
<th>Application area</th>
<th>Callup point</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO</td>
<td>0001</td>
<td>Document line item</td>
</tr>
<tr>
<td>GL</td>
<td>0001</td>
<td>Document header</td>
</tr>
<tr>
<td>GL</td>
<td>0002</td>
<td>Document line item</td>
</tr>
<tr>
<td>FI</td>
<td>0001</td>
<td>Document header</td>
</tr>
<tr>
<td>FI</td>
<td>0002</td>
<td>Document line item</td>
</tr>
<tr>
<td>FI</td>
<td>0003</td>
<td>Total document</td>
</tr>
</tbody>
</table>

If you want to create a validation by copying an existing validation, enter the name of the validation that you want to copy in the Copy from - Validation field.

The validation must have the same Boolean class as the validation you are creating.

Choose Continue.

The Create Validation: <Validation Name> screen (1) appears.

Enter a validation step.

You can use the following additional functions on this screen.

**Additional Processing Functions** Create Validation: <Validation Name> Screen (1)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
</table>

April 2001
Creating a Validation (old)

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation → Save</td>
<td>Save the validation</td>
</tr>
<tr>
<td>Edit → Choose</td>
<td>Change an existing validation step</td>
</tr>
<tr>
<td>Edit → Move</td>
<td>Move a validation step to another position in the validation</td>
</tr>
<tr>
<td>Edit → Insert entry</td>
<td>Add a validation step</td>
</tr>
<tr>
<td>Edit → Delete entry</td>
<td>Delete a validation step</td>
</tr>
<tr>
<td>Goto → Header</td>
<td>Enter an authorization group for the validation and/or change the validation name and/or description. You can also display the Boolean class for the validation.</td>
</tr>
<tr>
<td>Extras → Switch on trace</td>
<td>Switch on the tracing function. While posting a document, the system calls the validation and shows you which data is used for validation. This function allows you to diagnose possible errors in the validation definition. For further information see Tracing a Validation/Substitution/Rule [Seite 1169].</td>
</tr>
<tr>
<td>Extras → Switch off trace</td>
<td>Switch off the tracing function</td>
</tr>
<tr>
<td>Extras → Usage</td>
<td>Display where the validation is currently used</td>
</tr>
<tr>
<td>View → Messages &lt;-&gt; Text</td>
<td>Display only the validation step description or the message description assigned to the validation.</td>
</tr>
<tr>
<td>View → All</td>
<td>Display all steps for the validation</td>
</tr>
<tr>
<td>View → Selected</td>
<td>Display only selected validation steps</td>
</tr>
<tr>
<td>View → Select</td>
<td>Select validation steps using specific search criteria</td>
</tr>
<tr>
<td>Environment → Maintain rules</td>
<td>Create/change/display rules</td>
</tr>
</tbody>
</table>

To create a validation step, choose Edit → Insert entry.

The Create Validation: <Validation Name> screen (2) appears.

Enter a validation step description.

Define the Boolean statement used as the prerequisite statement for selecting data for validation.

If the prerequisite statement is false, the entered value is not selected for validation and the transaction continues. If the prerequisite statement is true, the entered value is checked against the check statement entered in the Check field.

You can enter the prerequisite statement directly or you can use the Formula Builder to enter the statement. The Formula Builder provides an easy-to-use interface for entering logical statements in validations, substitutions, and rules.

To enter your prerequisite statement using the Formula Builder, choose Formula Builder. For more information, see Formula Builder [Seite 1055].

Define the Boolean statement used as the check for validating the data selected by the statement in the Prerequisite field.
Creating a Validation (old)

If the check statement is true, the entered value is valid and the transaction continues. If the check statement is false, the system sends a message to the user.

You can enter the check statement directly or you can use the Formula Builder to enter the statement. The Formula Builder provides an easy-to-use interface for entering logical statements in validations, substitutions, and rules.

To enter your check statement using the Formula Builder, choose Formula Builder. For more information, see Formula Builder [Seite 1055].

For more information about the syntax rules for entering Boolean statements, see Syntax Rules for Boolean Statements [Seite 1133].

You can also enter a user exit (type 1 or 3) in the prerequisite and/or check statement. For further information about user exits, see User Exits in Validations/Substitutions/Rules [Seite 1053].

Enter the following data:

- Message type and number
  You must enter all digits for the number, including the leading zeros.

- Table/field combinations for the message
  There are four (1-4) table/field entry fields for up to four message variables (&). When the system encounters a variable (&) in a message, it replaces the variable with the corresponding table/field value. The order of the table/field names corresponds to the order in which the variables appear in the message.

  There are two variables in the following message:
  Cost center & cannot be used with account &

  The first variable (&) refers to table GLU1 and the dimension "Cost Center" (RCNTR). Therefore, the entries in the first Output fields are as follows:

  Output fields 1  GLU1  RCNTR

  The second variable (&) refers to table GLU1 and the dimension "Account" (RACCT). Therefore, the entries in the second Output fields are as follows:

  Output fields 2  GLU1  RACCT

  If the value entered for cost center is 100, the value entered for account is 0000050000, and the check statement is false, the system displays the message:

  Cost center 100 cannot be used with account 0000050000.

  The table/field combinations that can be used for this validation depend on the fields used in the prerequisite and check statements. All fields used in the prerequisite and/or check statements can be used in the validation message. You can view valid table/field combinations by choosing Extras → Flds in Bool. statmnt.

  For more information about entering messages, see Validation Messages [Seite 1062].
– Indicator that determines whether a workflow is started from the validation step in addition to a system message, if the prerequisite statement is true and the check statement is false.

If you want to start a workflow from a validation step, you must first define your own workflow and workflow action in the SAP Business Workflow (Development) menu (Tools → SAP Business Workflow → Development).

The object type VALIDATION and the event Triggered, which is started when the validation fails, are delivered with the validations and substitutions software.

The standard function MsgDisplay is also delivered with the validations and substitutions software. This function allows you to display the message to be output by the validation (including the output fields for the message variables) after a workflow has been started from the validation.

You must specify the name of the user(s) who receive(s) the validation message and workflow. This recipient then receives a list of work items in the system inbox, detailing the activities to be processed.

For more information about workflows in FI-SL, see the SAP Library Triggering a Workflow From a Validation (FI-SL) documentation (Basis Components → Business Engineering Workbench → Workflow Scenarios in Applications).

For general information about business workflows, see the SAP Library SAP Business Workflow documentation (Basis Components → Business Engineering Workbench).

You can use the following additional functions on this screen.

### Additional Processing Functions  Create Validation: <Validation Name> Screen (2)

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation → Check</td>
<td>Check the syntax of your Boolean statements</td>
</tr>
<tr>
<td>Goto → Header</td>
<td>Enter an authorization group for the validation and/or change the validation name and/or description. You can also display the Boolean class for the validation.</td>
</tr>
<tr>
<td>Goto → Previous step</td>
<td>Display the previous validation step</td>
</tr>
<tr>
<td>Goto → Next step</td>
<td>Display the next validation step</td>
</tr>
<tr>
<td>Extras → Flds in Bool.statmnt</td>
<td>Display a list of valid fields and tables that you can use for the validation. These fields and tables are determined by the Boolean class of the validation.</td>
</tr>
<tr>
<td>Extras → Rule list</td>
<td>Display a list of rules that use the same Boolean class as the validation.</td>
</tr>
<tr>
<td>Extras → Set directory</td>
<td>List sets that have been created in your system. For more information, see Displaying a Set Directory [Seite 685].</td>
</tr>
</tbody>
</table>
Creating a Validation (old)

<table>
<thead>
<tr>
<th>Extras → Switch on trace</th>
<th>Switch on the tracing function. While posting a document, the system calls the validation and shows you which data is used for validation. This function allows you to diagnose possible errors in the validation definition. For further information see Tracing a Validation/Substitution/Rule [Seite 1169].</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extras → Switch off trace</td>
<td>Switch off the tracing function</td>
</tr>
<tr>
<td>Environment → Maintain rules</td>
<td>Create/change/display rules</td>
</tr>
<tr>
<td>Environment → Maintain messages</td>
<td>Create/change/display messages and message classes.</td>
</tr>
</tbody>
</table>

Go back to previous screen.

The Create Validation: <Validation Name> screen (1) appears.

A new step appears for the validation. The system automatically assigns a number to the step.

You can define up to 999 steps for each validation. The validation steps are processed in the order displayed on the screen. To rearrange the order, choose Edit → Move.

If the validation definition is longer than five lines, the system marks the Continue field.

Choose Validation → Save.
Displaying a Validation (old)

1. In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Validation.
   The Change Validation: Initial Screen appears.

2. Choose Validation → Display.
   The Display Validation: Initial Screen appears.

3. Enter the following data:
   – Validation name
   – Application area for the validation (optional)
   – Callup point code for the validation (optional)

4. You can use the following additional functions on this screen.

Additional Processing Functions | Display Validation: Initial Screen
---|---
**Choose** | **Function**
Validation → Create | Create a validation
Validation → Change | Change a validation definition
Validation → Simulate | Simulate the validation to view which data fields will be validated when the validation is called. For more information, see Simulating a Validation/Substitution/Rule [Seite 1170].
Validation → Transport | Transport the validation to another system. For more information, see Transporting Validations/Substitutions/Rules [Seite 1166].
Validation → Print | Print the validation definition
Validation → Delete | Delete a validation
**Extras → Usage** | Display where the validation is currently used
Environment → Directory | Display a directory of validation information. For more information, see Displaying a Directory of Validations/Substitutions/Rules [Seite 1168].
Environment → Val./sub. analysis | Call up the validation/substitution analysis tool. For more information, see Using the Analysis Tool [Seite 1171].

5. Choose Continue.
   The Display Validation: <Validation Name> screen appears.

6. To view detailed information for a validation step, move the cursor to the validation you want to display and choose Edit → Choose.
Displaying a Validation (old)
Changing a Validation (old)

1. In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Validation.
   The Change Validation: Initial Screen appears.
2. Enter the following data:
   – Validation name
   – Application area for the validation (optional)
   – Callup point code for the validation (optional)
3. Choose Continue.
   The Change Validation: <Validation Name> screen appears.
4. Type over existing values with your changes.
5. On this screen you can use the additional functions from the tables described in Creating a Validation [Seite 1057] and Displaying a Validation [Seite 1066].

Moving a Validation Step

1. On the Change Validation: <Validation Name> screen (1), select the step(s) that you want to move.
2. Choose Edit → Move.
3. Move the cursor to the position where the step(s) should be moved and choose Drop.
Deleting a Validation (old)

1. In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Validation.
   The Change Validation: Initial Screen appears.
2. In the Validation field, enter the name of the validation you want to delete.
3. Choose Validation → Delete.
   A dialog box appears, asking if you want to delete the validation.
   If the validation is currently used in the system, a dialog box appears, displaying the application components where the validation is used.
   You cannot delete a validation that is used elsewhere in the system.
4. To delete the validation, choose Yes.
   The validation has been deleted. You cannot restore a deleted validation.
Substitution

Use

Substitution rules are stored in the Rule Manager; as data is being entered, the data is substituted by the Rule Manager. Substitution occurs before the data is summarized in a summary database.

You can use a substitution simultaneously at different callup points and you can create different dependencies for substituting data. For more information, see validation/substitution callup points [Seite 1051]. Also, you can create a substitution in the system, even if it is not used anywhere (for example, for future use).

To troubleshoot substitutions, you should use the Simulate and Switch on trace functions.

For more information, see:

Tracing a Validation/Substitution/Rule [Seite 1169]
Simulating a Validation/Substitution/Rule [Seite 1170]

From Release 4.6 there is a new interface with controls for processing rules. If you want to continue using the old interface, make the following settings: In the menu, choose System → User profile → Own data. Then choose Parameters and create an entry with the parameter GBK and the value X.

For more information about using substitutions, see creating substitutions [Seite 1084].

Example

Examples of substitution rules:

If the account is in the set ACCT-23 and the cost center is in the set CENTER-56, then substitute the value blank for the product code.

If the Cost Center is 300, move the value 121333 to the dimension Region in the FI-SL summary database.
Creating a Substitution

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Substitution. For more information about creating substitutions, see the Implementation Guide (IMG) under Maintain Substitution [Extern].

The Change Substitution: Overview screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point.

This node contains both the substitution and the rule list that have been created for this application area and callup point. You can also process the rules from here (create/change/display/delete).

Choose Substitution → Create.

The Create Substitution: New Substitution (Header data) screen appears. Enter the following data:

– Substitution name

– Substitution description

You can also enter an authorization group to limit the number of users that can process this substitution.

To accept these entries, press Enter.

If you want to create a substitution by copying an already existing one, choose the corresponding callup point in Control and mark the substitution you want to use as a reference. Wait until both screen areas of the system are ready for entry, then choose Substitution → Copy. Enter data as described in Step 3 above.

The substitution must have the same Boolean class as the substitution you are creating.

If you are creating a matrix substitution, allowing you to validate data for an entire document, you use callup point code 0003 in Financial Accounting (FI), Legal Consolidation (FI-LC), and Consolidation (EC-CS). If you want to create a matrix substitution in the FI application component for callup point 0003, use the SAP note no. 42615 (this function is not included in the standard delivery).

The following table shows example entries for application area/callup point combinations.

<table>
<thead>
<tr>
<th>Application area</th>
<th>Callup point</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO</td>
<td>0001</td>
<td>Document line item</td>
</tr>
</tbody>
</table>
The Create Substitution: <Substitution Name> (Header data) screen appears.

You can use the following additional functions in this screen:

### Additional Processing Functions Create Substitution: <Substitution Name> (Header data) Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substitution → Create</td>
<td>Create a substitution</td>
</tr>
<tr>
<td>Substitution → Select</td>
<td>Select substitution: The system expands the corresponding node down to the selected substitution automatically. A confirmation prompt gives you the opportunity to change your selection.</td>
</tr>
<tr>
<td>Substitution → Copy</td>
<td>The system creates a new substitution by copying the substitution currently marked.</td>
</tr>
<tr>
<td>Substitution → Change</td>
<td>Switch to change mode</td>
</tr>
<tr>
<td>Substitution → Display</td>
<td>Switch to display mode</td>
</tr>
<tr>
<td>Substitution → Save</td>
<td>Save the substitution</td>
</tr>
<tr>
<td>Edit → Insert step</td>
<td>Insert new step (empty). If steps already exist, the new step is inserted as the last step.</td>
</tr>
<tr>
<td>Extras → Flds in Bool.statmnt</td>
<td>Display a list of valid fields that you can use for the substitution. These fields are determined based on the Boolean class of the substitution.</td>
</tr>
<tr>
<td>Extras → Substitution flds...</td>
<td>Display a list of valid fields that can be changed within a substitution</td>
</tr>
<tr>
<td>Extras → Rule list</td>
<td>Display a list of rules that you can use for the newly created substitution</td>
</tr>
<tr>
<td>Extras → Set directory</td>
<td>List sets that have been created in your system. For more information, see Displaying a Set Directory [Seite 685].</td>
</tr>
<tr>
<td>Extras → Switch on trace</td>
<td>Switch on the tracing function. While posting a document, the system calls the substitution and shows you which data is used. This function allows you to diagnose possible errors in the substitution definition. For further information, see Tracing a Validation/Substitution/Rule [Seite 1169].</td>
</tr>
<tr>
<td>Extras → Switch off trace</td>
<td>Switch off the tracing function</td>
</tr>
</tbody>
</table>
Creating a Substitution

<table>
<thead>
<tr>
<th>Extra → Usage</th>
<th>Display where the substitution is currently used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Environment → Maintain rules</td>
<td>Create/change/display rules. Select the node containing the rule list.</td>
</tr>
<tr>
<td>Environment → Create rule</td>
<td>Create a rule</td>
</tr>
<tr>
<td>Environment → Select rule</td>
<td>Select a rule</td>
</tr>
</tbody>
</table>

To create a new step for your substitution, choose Edit → Insert step or choose the corresponding function from the application tool bar.

A dialog box appears, listing the fields that you can use for substitution for this Boolean class.

Select the field that you want to use for substitution and choose Choose.

For each of the fields you selected a dialog box appears in which you can define the substitution method. You can choose between:

- Constant value
- Exit

**Field-Field assignment**

You can then later enter either a constant value, the name of an exit to be carried out at runtime or the name of a field, the content of which is to be used for the substitution.

The Create Substitution: <Substitution Name> - Step <Step Number> - Overview appears.

You can use the following additional functions on this screen:

| Edit → Insert step | Insert a new step directly before the step currently being processed |
| Edit → Copy step | Insert a new step with the content of the step currently being processed |
| Edit → Delete step | Delete a step |
| Goto → Header | Return to substitution header data |

To process an existing substitution step, mark the step <no.> node in Control. You will then see an overview of the prerequisites and substitution entries created for this step. Enter a substitution step description. To edit one of these elements, double-click the appropriate area or navigate by selecting the corresponding node in Control.

Define the Boolean statement used as the prerequisite statement for selecting data for substitution.

If the prerequisite is false, the value is not substituted and the transaction continues with the next substitution step.

The Formula Builder provides an easy-to-use interface for entering logical statements in validations, substitutions, and rules. For more information, see Formula Builder [Seite 1055].
Creating a Substitution

For more information about the syntax rules for entering Boolean statements, see Syntax Rules for Boolean Statements [Seite 1133].

You can also enter a user exit (type 1 or 3) in the prerequisite statement. For further information about user exits, see User Exits in Validations/Substitutions/Rules [Seite 1053].

On the Create Substitution: <Substitution Name> - Step <Step Number> - Overview screen you can enter one of the following for each substitution entry, depending on your chosen method:

Constant value
Exit name
Source field of assignment in <structure name> - <field name> format

An input help is available for all three input possibilities.

If the substitution step prerequisite is true at runtime, the system substitutes the contents of the field with a constant value, the contents of the source field or the system carries out an exit.

You use a user-defined exit to create complex substitutions. You use user exits of type 1 or 2 as substitution exits for a normal substitution or exits of type 2 or 3 for a matrix substitution. The substitution entry Exit only, where you can only use exits of type 1 or 3, forms an exception.

You can use the three pushbuttons in the right-hand screen area to insert, delete or move substitution entries:

Select the entries to be deleted and use the pushbutton Delete subst.entry

Select an entry and use the pushbutton Insert subst.entry to insert the new entry before the selected entry

If you want to insert the new entry as the last entry, do not select an entry. Instead, place the cursor on the step description and then use the pushbutton Insert subst.entry.

Select several steps and then use the pushbutton Move subst.entry. A message appears and you can move the steps by placing the cursor on a different entry and pressing Enter. The entries to be moved are inserted in front of the last selected entry.

During processing of a substitution the steps are numbered sequentially by the system automatically. Move steps as follows: Mark the node of the step you wish to move. You can then move the step to the node of a different step. The selected step is inserted after the target step (Drag and Drop method). This is only possible within a substitution.

Once you have finished processing the substitution, choose Substitution → Save.
Displaying a Substitution

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Substitution. For more information about creating logical rules, see the Implementation Guide (IMG) under Logical Rules for Validation and Substitution [Extern].

The Substitution Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required substitution.

Choose Substitution → Display. The Display Substitution: <Substitution Name> screen appears.

You can use the following additional processing functions on this screen.

**Additional Processing Functions**  
**Display Substitution: <Substitution Name> (Header data) Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substitution → Select</td>
<td>Select substitution: The system displays the selected substitution and expands the corresponding node automatically.</td>
</tr>
<tr>
<td>Substitution → Simulate</td>
<td>Simulate the substitution to view which data fields will be used for validation/substitution when the substitution is called. For more information, see Simulating a Validation/Substitution/Rule [Seite 1170].</td>
</tr>
<tr>
<td>Substitution → Overview</td>
<td>Display content of substitution with elements used (structure fields, exits, sets or other rules)</td>
</tr>
<tr>
<td>Substitution → Display -&gt; Change</td>
<td>Switch to change mode</td>
</tr>
<tr>
<td>Extras → ...</td>
<td>See: Creating a Rule [Seite 1107]</td>
</tr>
<tr>
<td>Environment → ...</td>
<td>See: Creating a Rule [Seite 1107]</td>
</tr>
</tbody>
</table>

If you want to display a substitution that is longer than 5 lines, you can use the Formula Builder either directly in the Control area by selecting the Substitution definition node or on the right-hand screen area (Substitution content) by double clicking.
Changing a Substitution

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Substitution. For more information about creating logical rules, see the Implementation Guide (IMG) under Logical Rules for Validation and Substitution [Extern].

The Substitution Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required substitution. The Change Substitution: <Substitution Name> screen appears.

You can change a substitution statement using the Formula Builder. Call up the Formula Builder either by selecting the Substitution definition node in Control or by double-clicking the Substitution contents in the right-hand screen area.

A substitution is limited to 33 lines.

Additional Processing Functions  Change Substitution: <Substitution Name> (Header data) Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substitution → Create</td>
<td>Create substitution</td>
</tr>
<tr>
<td>Substitution → Select</td>
<td>Select substitution: The system expands the corresponding node down to the selected substitution automatically. A confirmation prompt gives you the opportunity to change your selection.</td>
</tr>
<tr>
<td>Substitution → Copy</td>
<td>The system creates a new substitution by copying the substitution currently marked.</td>
</tr>
<tr>
<td>Substitution → Display</td>
<td>Switch to display mode</td>
</tr>
<tr>
<td>Substitution → Simulate</td>
<td>Simulate the substitution to view which data fields will be used for validation/substitution when the substitution is called. For more information, see Simulating a Validation/Substitution/Rule [Seite 1170].</td>
</tr>
<tr>
<td>Substitution → Save</td>
<td>Save substitution</td>
</tr>
<tr>
<td>Substitution → Transport</td>
<td>Transport the substitution to another system. For more information, see Transporting Validations/Substitutions/Rules [Seite 1166].</td>
</tr>
<tr>
<td>Substitution → Overview</td>
<td>Display content of substitution with elements used (structure fields, exits, sets or other rules)</td>
</tr>
<tr>
<td>Substitution → Delete</td>
<td>See: Deleting a Substitution [Seite 1090]</td>
</tr>
<tr>
<td>Extras → ...</td>
<td>See: Creating a Rule [Seite 1107]</td>
</tr>
<tr>
<td>Environment → ...</td>
<td>See: Creating a Rule [Seite 1107]</td>
</tr>
</tbody>
</table>
Deleting a Substitution

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Substitution.

The Substitution Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required substitution. The Change Substitution: <Substitution Name> screen appears.

Choose Substitution → Delete.

A dialog box appears, asking you if you want to delete the substitution.

If the substitution is currently used in the system, a dialog box appears, displaying the application components where the substitution is used.

You cannot delete substitutions that are being used in an R/3 application component or in another substitution.

To delete the substitution, choose Yes. The substitution is deleted. You cannot restore a deleted substitution.
Activating a Substitution in FI-SL

Before you can use a substitution, you need to activate the substitution. If, for example, you are using the substitution in Controlling (CO), you need to activate the substitution in CO. For information about using substitutions in CO, see the relevant CO documentation.

If you are using the substitution in Special Purpose Ledger (FI-SL), you need to activate it there.

Procedure

In Customizing for Special Purpose Ledger, choose Basic Settings → Substitution → Maintain Local Substitution (for local companies) or Maintain Global Substitution (for global companies).

The Change View “Substitution for Special Purpose Ledger/CoCde”: Overview screen (for local companies) or the Change View "Substitution for Spec.Purpose Ledger/Glob.Co.": Overview screen (for global companies) appears.

You can use the following processing functions on these screens.

Processing Functions – Change View “Substitution for Special Purpose Ledger/CoCde/Glob.Co.” Overview Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position…</td>
<td>Display a specific company code/application area/callup point combination for a substitution.</td>
</tr>
<tr>
<td>Table view → Change → Display</td>
<td>Display the table information.</td>
</tr>
<tr>
<td>Table view → Print → Standard list</td>
<td>Print all substitutions defined in the system.</td>
</tr>
<tr>
<td>Table view → Print → Variable list</td>
<td>Print specific substitutions based on user-defined selection criteria.</td>
</tr>
<tr>
<td>Table view → Save</td>
<td>Save the table information you have entered.</td>
</tr>
<tr>
<td>Table view → Transport</td>
<td>Prepare the table for transport under a correction number.</td>
</tr>
<tr>
<td>Edit → New entries</td>
<td>Create a new entry.</td>
</tr>
<tr>
<td>Edit → Selections → Select all</td>
<td>Select all entries for further processing (for example, to delete them).</td>
</tr>
<tr>
<td>Edit → Selections → Deselect all</td>
<td>Deselect all selected entries.</td>
</tr>
<tr>
<td>Edit → Selections → Select block</td>
<td>Select a block of entries for further processing.</td>
</tr>
<tr>
<td>Edit → Delete</td>
<td>Delete an entry(ies).</td>
</tr>
<tr>
<td>Edit → Copy as…</td>
<td>Copy an entry for a new company code/global company.</td>
</tr>
<tr>
<td>Edit → Change fld contents</td>
<td>Change the field contents for a substitution definition.</td>
</tr>
<tr>
<td>Edit → Undo change</td>
<td>Change revised substitutions back to their original definition.</td>
</tr>
</tbody>
</table>
## Activating a Substitution in FI-SL

<table>
<thead>
<tr>
<th>Goto → Detail</th>
<th>Display specific information for a substitution definition.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Next entry</td>
<td>Display the next substitution entry.</td>
</tr>
<tr>
<td>Goto → Previous entry</td>
<td>Display the previous substitution entry.</td>
</tr>
<tr>
<td>Goto → Other entry...</td>
<td>Display a specific substitution entry.</td>
</tr>
<tr>
<td>Choose → By contents...</td>
<td>Display the substitution definitions by the field contents.</td>
</tr>
<tr>
<td>Choose → All selected entries</td>
<td>Display only substitution definitions that have been selected using the <em>Edit</em> function.</td>
</tr>
<tr>
<td>Choose → All changed entries</td>
<td>Display only entries that have been changed while using the <em>Change</em> function at this time.</td>
</tr>
<tr>
<td>Choose → All created entries</td>
<td>Display only entries that have been created while using the <em>Create/Change</em> functions at this time.</td>
</tr>
<tr>
<td>Choose → Display del. entries</td>
<td>Display only entries that have been deleted using the <em>Create/Change</em> functions at this time.</td>
</tr>
<tr>
<td>Utilities → Compare → Client 000</td>
<td>Compare the substitution entries with the entries delivered in client 000.</td>
</tr>
<tr>
<td>Utilities → Compare → Other client...</td>
<td>Compare the substitution entries with the entries in another client.</td>
</tr>
<tr>
<td>Utilities → Compare → Other system...</td>
<td>Compare the substitution entries with the entries in another system (for example, a test system versus a productive system).</td>
</tr>
<tr>
<td>Utilities → Request management</td>
<td>Call up the Workbench Organizer, for example, to maintain and display transport requests.</td>
</tr>
<tr>
<td>Environment → Validation</td>
<td>Create a validation.</td>
</tr>
<tr>
<td>Environment → Substitution</td>
<td>Create a substitution.</td>
</tr>
</tbody>
</table>

Choose *Edit* → New entries.

The *New Entries: Overview of Created Entries* screen appears.

Enter the following data:

- Local or global company code of the substitution
- Callup point code for the substitution
- Substitution name
- Activation level for the substitution

You can use the additional processing functions in the above table on this screen.

Go back.

The *Change View* "*Substitution for Special Purpose Ledger/CoCode/Glob.Co.*: Overview screen appears."
To display the substitution definition, move the cursor to the substitution line and double-click.

To save the activation of the substitution, choose Table view → Save.

The substitution dependency is stored in a table for each application area code.

The following table is an example of the table structure for one application area code.

<table>
<thead>
<tr>
<th>Company</th>
<th>Callup point</th>
<th>Substitution</th>
<th>Active</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAPD</td>
<td>0001</td>
<td>SUB1</td>
<td>1</td>
</tr>
<tr>
<td>SAPD</td>
<td>0002</td>
<td>SUB3</td>
<td>1</td>
</tr>
<tr>
<td>SAPGB</td>
<td>0001</td>
<td>SUB2</td>
<td>0</td>
</tr>
<tr>
<td>SAPUSA</td>
<td>0001</td>
<td>SUB1</td>
<td>1</td>
</tr>
</tbody>
</table>

The activation field may vary from one application area code to another.
Deactivating a Substitution

On the Change View "Substitution for Special Purpose Ledger/CoCde/Glob.Co." screen, enter 0 in the activation level field.

If you choose ENTER, the 0 displays as blank.

Choose Table view → Save.
Substitution (old)

Substitution rules are stored in the Rule Manager that, as data is being entered, substitutes this data. Substitution occurs before the data is summarized in a summary database.

You can use a substitution simultaneously at different callup points and you can create different dependencies for substituting data. Also, you can create a substitution in the system, even if it is not called anywhere (for example, for future use).

As from Release 4.6A there is a new interface with controls for processing rules. If you want to continue using the old interface, you must make the following setting: In the menu choose System → User profile → Own data. Then choose Parameters and create an entry with the parameter GBK and the value X.

This section contains:

Creating a Substitution (old) [Seite 1096]
Displaying a Substitution (old) [Seite 1100]
Changing a Substitution (old) [Seite 1102]
Deleting a Substitution (old) [Seite 1103]
Activating a Substitution in FI-SL [Seite 1091]
Deactivating a Substitution [Seite 1094]
Creating a Substitution (old)

Use

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Substitution.

The Change Substitution: Initial Screen appears.

Choose Substitution → Create.

The Create Substitution: Initial Screen appears.

Enter the following data:

- Substitution name
- Application area code for the substitution
- Callup point code for the substitution

The callup point that you can enter in this field depends upon the application area that you enter for the substitution.

If, for example, you are creating a matrix substitution, which allows you to substitute data for an entire document, you use callup point code 0003 (complete document) in Financial Accounting (FI).

Example entries for the application area/callup point combinations are shown in the table in Creating a Validation [Seite 1057].

If you want to create a substitution by copying an existing substitution, enter the name of the substitution that you want to copy in the Copy from - Substitution field.

The substitution must have the same Boolean class as the substitution you are creating.

Choose Continue.

The Create Substitution: <Substitution Name> screen (1) appears.

Enter a substitution description.

You can use the following additional functions on this screen.

<table>
<thead>
<tr>
<th>Additional Processing Functions</th>
<th>Create Substitution: &lt;Substitution Name&gt; Screen (1)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Choose</strong></td>
<td><strong>Function</strong></td>
</tr>
<tr>
<td>Substitution → Save</td>
<td>Save the substitution</td>
</tr>
<tr>
<td>Edit → Deselect all</td>
<td>Deselect all selected steps</td>
</tr>
<tr>
<td>Edit → Choose</td>
<td>Select a substitution step for further processing (for example, for deletion).</td>
</tr>
<tr>
<td>Edit → Move</td>
<td>Move a selected substitution step to a new position</td>
</tr>
<tr>
<td>Edit → Insert entry</td>
<td>Add a substitution step</td>
</tr>
</tbody>
</table>
Choose Edit → Insert entry.

A dialog box appears, listing the fields that you can use for substitution for this Boolean class.

Select the field that you want to use for substitution and choose Choose.

The Create Substitution: <Substitution Name> screen (2) appears.

Enter a substitution step description.

Enter the Boolean statement used for selecting data for substitution (prerequisite).

If the prerequisite statement is false, then a value is not substituted.

You can enter the prerequisite statement directly or you can use the Formula Builder to enter the statement. The Formula Builder provides an easy-to-use interface for entering logical statements in validations, substitutions, and rules.

To enter your prerequisite statement using the Formula Builder, choose Formula Builder. For more information, see Formula Builder [Seite 1055].

For more information about the syntax rules for entering Boolean statements, see Syntax Rules for Boolean Statements [Seite 1133].
Use

You can also enter a user exit (type 1 or 3) in the prerequisite statement. For further information about user exits, see User Exits in Validations/Substitutions/Rules [Seite 1053].

Select the field to be used for the substitution step and enter the following data:

- Substitution value
  If the substitution statement is true, the system substitutes the numeric value entered as the constant value.

- Substitution exit number (optional)
  When the prerequisite statement is true, the substitution exit number refers the system to a user-defined program. You use a user-defined program to create complex substitutions.
  You can only use user exit type 2 as the substitution exit number. For further information about user exits, see User Exits in Validations/Substitutions/Rules [Seite 1053].

You can use the following additional functions on this screen.

Additional Processing Functions

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substitution → Check</td>
<td>Check the syntax of your Boolean statement</td>
</tr>
<tr>
<td>Edit → Move</td>
<td>Move a selected substitution step to a new position</td>
</tr>
<tr>
<td>Edit → Insert entry</td>
<td>Add a substitution step</td>
</tr>
<tr>
<td>Edit → Delete entry</td>
<td>Delete a substitution step</td>
</tr>
<tr>
<td>Goto → Header</td>
<td>Enter authorization group for the substitution and/or change the substitution name and/or description. You can also display the Boolean class for the substitution.</td>
</tr>
<tr>
<td>Goto → Next step</td>
<td>Display the next substitution step</td>
</tr>
<tr>
<td>Goto → Previous step</td>
<td>Display the previous substitution step</td>
</tr>
<tr>
<td>Extras → Flds in Bool.statmtn</td>
<td>Display a list of valid fields that you can use for the substitution rules. These fields are determined based on the Boolean class of the substitution.</td>
</tr>
<tr>
<td>Extras → Substitution fids...</td>
<td>Display a list of valid fields and tables that you can use for the substitution. These fields and tables are determined by the Boolean class of the substitution.</td>
</tr>
<tr>
<td>Extras → Rule list</td>
<td>Display a list of rules that use the same Boolean class as the substitution</td>
</tr>
<tr>
<td>Extras → Set directory</td>
<td>List sets that have been created. For more information, see Displaying a Set Directory [Seite 685]</td>
</tr>
</tbody>
</table>
### Use

<table>
<thead>
<tr>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Extras → Switch on trace</strong></td>
<td>Switch on the tracing function. While posting a document, the system calls the substitution and shows you which data is used for substitution. This function allows you to diagnose possible errors in the substitution definition. For further information, see [Tracing a Validation/Substitution/Rule][1] [Seite 1169].</td>
</tr>
<tr>
<td><strong>Extras → Switch off trace</strong></td>
<td>Switch off the tracing function</td>
</tr>
<tr>
<td><strong>Environment → Maintain rules</strong></td>
<td>Create/change/display rules</td>
</tr>
</tbody>
</table>

Go back to previous screen.

The Create Substitution: &lt;Substitution Name&gt; screen (1) appears.

A new step appears for the substitution. The system automatically assigns a number to the step.

You can define up to 999 steps for each substitution. The substitution steps are processed in the order displayed on the screen. To rearrange the order, choose Edit → Move.

If the substitution definition is longer than five lines, the system marks the Continue field.

Choose Substitution → Save.

---
[1]: #/Tracing a Validation/Substitution/Rule

April 2001

1099
Displaying a Substitution (old)


2. Choose Substitution → Display. The Display Substitution: Initial Screen appears.

3. Enter the following data:
   - Substitution name
   - Application area code for the substitution (optional)
   - Callup point code for the substitution (optional)

4. You can use the following additional functions on this screen.

   **Additional Processing Functions**

   **Display Substitution: Initial Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substitution → Create</td>
<td>Create a substitution</td>
</tr>
<tr>
<td>Substitution → Change</td>
<td>Change a substitution definition</td>
</tr>
<tr>
<td>Substitution → Simulate</td>
<td>Simulate the substitution to view which data fields will be substituted when the substitution is called. For more information, see Simulating a Validation/Substitution/Rule [Seite 1170].</td>
</tr>
<tr>
<td>Substitution → Transport</td>
<td>Transport the substitution to another system. For more information, see Transporting Validations/Substitutions/Rules [Seite 1166] .</td>
</tr>
<tr>
<td>Substitution → Print</td>
<td>Print the substitution definition</td>
</tr>
<tr>
<td>Substitution → Delete</td>
<td>Delete a substitution</td>
</tr>
<tr>
<td>Extras → Usage</td>
<td>Display where the substitution is currently used</td>
</tr>
<tr>
<td>Environment → Directory</td>
<td>Display a directory of substitution information. For more information, see Displaying a Directory of Validations/Substitutions/Rules [Seite 1168].</td>
</tr>
<tr>
<td>Environment → Val./sub. analysis</td>
<td>Call up the validation/substitution analysis tool. For more information, see Using the Analysis Tool [Seite 1171].</td>
</tr>
</tbody>
</table>

5. Choose Continue. The Display Substitution: <Substitution Name> screen appears.

6. To view detailed information for a substitution step, move the cursor to the substitution you want to display and choose Edit → Choose.
Changing a Substitution (old)

1. In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Substitution.

   The Change Substitution: Initial Screen appears.

2. Enter the following data:
   – Substitution name
   – Application area code for the substitution (optional)
   – Callup point code for the substitution (optional)

3. Choose Continue.

   The Change Substitution: <Substitution Name> (1) screen appears.

4. Type over existing values with your changes.

5. On this screen you can use the additional functions from the tables described in Creating a Substitution [Seite 1084] and Displaying a Substitution [Seite 1088].

Moving Substitution Steps

1. On the Change Substitution: <Substitution Name> screen (2), select the step(s) that you want to move.

2. Choose Edit → Move.

3. Move the cursor to the position where the steps should be moved and choose Drop.
Deleting a Substitution (old)

1. In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Substitution.
   The Change Substitution: Initial Screen appears.
2. In the Substitution field, enter the name of the substitution you want to delete.
3. Choose Substitution → Delete.
   A dialog box appears, asking you if you want to delete the substitution.
   If the substitution is currently used in the system, a dialog box appears, displaying the application components where the substitution is used.
   You cannot delete a substitution that is currently used elsewhere in the system.
4. To delete the substitution, choose Yes.
   The substitution has been deleted. You cannot restore a deleted substitution.
Rules

Use

Using rules, you can use a statement in one process and then use the same statement in another process by linking the statement to another statement.

To troubleshoot validations, substitutions, or rules, you should use the Simulate and Switch on trace functions.

For more information, see:
Tracing a Validation/Substitution/Rule [Seite 1169]
Simulating a Validation/Substitution/Rule [Seite 1170]

As from Release 4.6A there is a new interface with controls for processing rules. If you want to continue using the old interface, you must make the following setting: In the menu choose System → User profile → Own data. Then choose Parameters and create an entry with the parameter GBK and the value X.
Introduction to Rules

A rule is a Boolean expression that you can use in a prerequisite statement, in a check, or in another rule. Rules enable you to refer to frequently used Boolean statements simply by specifying the rule name.

RULE1 AND COBOL-BLART <> 'SB'

In this example, the rule is named RULE1. When the system processes this statement, it first processes RULE1 and then checks whether the document type is SB.

To create a rule:

Enter a rule name.

The rule name can be a maximum of 11 characters long.

Create a statement in accordance with the rules described in Creating Boolean Statements for the Fi-SL System [Seite 1125].

Starting with Release 4.0A you can enter a rule statement either directly or using the Formula Builder.

If you enter the statement with the Formula Builder, the system uses the new syntax rules for Release 4.0A. For more information, see Syntax Rules for Boolean Statements [Seite 1133] and Formula Builder [Seite 1055].

If you enter the statement directly, you must use the old syntax rules valid in Release 3.0 or 3.1. For more information, see Old Syntax Rules for Boolean Statements [Seite 1138].

Enter the name of the rule in another statement.

RULE1 OR GLT1-RACCT IN ACCOUNTS

You can use rules in:

Validations
Substitutions
Ledger selection

For more information on using rules in ledger selection, see Fi-SL Master Data: Special Purpose Ledgers [Seite 42].

Rollups

For more information on using rules with rollups, see Creating a Rollup [Seite 272].

Report Writer

For more information on using rules with the Report Writer, see Defining Selection Criteria [Seite 835].
Introduction to Rules

When you use rules in validations and substitutions, the rule must belong to the same Boolean class as the validation or substitution you are creating. For more information on Boolean classes, see Boolean Classes [Seite 1052].

If you still store your rules in table T890 (interpreted rules), SAP recommends that you use report RGUGBR10 to convert interpreted rules into generated rules. For more information, see Using the Rule Manager Reports [Seite 1164].

If you use the rules in table T890 as ledger selection criteria, you must ensure that the rules use the correct Boolean class.
Creating a Rule

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Logical Rules. For more information about creating logical rules, see the Implementation Guide (IMG) under Logical Rules for Validation and Substitution [Extern].

The Rule Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point.

Choose Rule → Create.

The Create Rule: New Rule screen appears.

Enter the following data:

- Rule name
- Rule description
- You can also enter an authorization group to limit the number of users that can process this rule.

To accept these entries, press Enter.

If you want to create a rule by copying an already existing one, choose the corresponding callup point in Control and mark the rule you want to use as a reference.

Wait until both screen areas of the system are ready for entry, then choose Rule → Copy. Enter data as described in Step 3 above.

The rule must have the same Boolean class as the rule you are creating.

You can change a rule statement using the Formula Builder. The Formula Builder provides an easy-to-use interface for entering logical statements. Call up the Formula Builder either by selecting the Rule definition node in Control or by double-clicking the Rule contents in the right-hand screen area.

A rule is limited to 33 lines.

Entering a Statement using the Formula Builder

Define the Boolean statement. If you switch to the expert mode in the Formula Builder, you enter the statement using the new syntax rules.

For further information, see Syntax Rules for Boolean Statements [Seite 1133] and Formula Builder [Seite 1055].

You can also enter a user exit (type 1 or 3) in the Boolean statement. For further information about user exits, see User Exits in Validations/Substitutions/Rules [Seite 1053].

Return to the previous screen with F3 and save the rule.
Creating a Rule

If you still store your rules in table T890 (interpreted rules), we recommend that you use report RGUGBR10 to convert interpreted rules into generated rules. For more information, see Using the Rule Manager Reports [Seite 1164].

You can use the following additional functions in this screen:

**Additional Processing Functions  Create Rule: <Rule Name> Screen**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rule → Save</td>
<td>Save the rule definition</td>
</tr>
<tr>
<td>Extras → Flds in Bool.statmnt</td>
<td>Display a list of valid fields that you can use for the rule. These fields are determined based on the Boolean class of the rule.</td>
</tr>
<tr>
<td>Extras → Substitution fids...</td>
<td>Display a list of valid fields that can be changed within a substitution</td>
</tr>
<tr>
<td>Extras → Rule list</td>
<td>Display a list of rules that use the same Boolean class as the rule</td>
</tr>
<tr>
<td>Extras → Set directory</td>
<td>List sets that have been created in your system. For more information, see Displaying a Set Directory [Seite 685].</td>
</tr>
<tr>
<td>Extras → Switch on trace</td>
<td>Switch on the tracing function. While posting a document, the system calls the rule and shows you which data is used. This function allows you to diagnose possible errors in the rule definition. For further information, see Tracing a Validation/Substitution/Rule [Seite 1169].</td>
</tr>
<tr>
<td>Extras → Switch off trace</td>
<td>Switch off the tracing function</td>
</tr>
<tr>
<td>Extras → Usage</td>
<td>Display where the rule is currently used</td>
</tr>
<tr>
<td>Environment → Maintain rules</td>
<td>Jump back to call up point node</td>
</tr>
</tbody>
</table>

**Result**

You can now use the rule in:

A validation and/or substitution prerequisite or check

Another rule

Ledger selection

Rollups

Report Writer
Displaying a Rule

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Logical Rules. For more information about creating logical rules, see the Implementation Guide (IMG) under Logical Rules for Validation and Substitution [Extern].

The Rule Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required rule.

Choose Rule → Display. The Display Rule: <Rule Name> screen appears.

You can use the following additional processing functions on this screen.

### Additional Processing Functions  Display Rule: <Rule Name> Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rule → Select</td>
<td>Select rule: The system displays the selected rule and expands the corresponding node automatically.</td>
</tr>
<tr>
<td>Rule → Simulate</td>
<td>Simulate the rule to view which data fields will be used for validation/substitution when the rule is called. For more information, see Simulating a Validation/Substitution/Rule [Seite 1170].</td>
</tr>
<tr>
<td>Rule → Overview</td>
<td>Display content of rule with elements used (structure fields, exits, sets or other rules)</td>
</tr>
<tr>
<td>Rule → Display -&gt; Change</td>
<td>Switch to change mode</td>
</tr>
<tr>
<td>Extras → ...</td>
<td>See: Creating a Rule [Seite 1107]</td>
</tr>
<tr>
<td>Environment → ...</td>
<td>See: Creating a Rule [Seite 1107]</td>
</tr>
</tbody>
</table>

If you want to display a rule that is longer than 5 lines, you can use the Formula Builder either directly in the Control area by selecting the Rule definition node or on the right-hand screen area (Rule content) by double clicking.

You can also display rules when creating, changing or displaying validations and substitutions. To do this, choose Environment → Maintain rules.
Changing a Rule

In Customizing for Special Purpose Ledger, choose Tools → Maintain Validation/Substitution/Rules → Maintain Logical Rules for Validation and Substitution. For more information about creating logical rules, see the Implementation Guide (IMG) under Logical Rules for Validation and Substitution [Extern].

The Rule Maintenance screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required rule. The Change Rule: <Rule Name> screen appears.

You can change a rule statement using the Formula Builder. Call up the Formula Builder either by selecting the Rule definition node in Control or by double-clicking the Rule contents in the right-hand screen area.

A rule is limited to 33 lines.

Additional Processing Functions  Change Rule: <Rule Name> Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rule → Create</td>
<td>Create a rule</td>
</tr>
<tr>
<td>Rule → Select</td>
<td>Select rule: The system expands the corresponding node down to the selected rule automatically. A confirmation prompt gives you the opportunity to change your selection.</td>
</tr>
<tr>
<td>Rule → Copy</td>
<td>The system creates a new rule by copying the rule currently marked.</td>
</tr>
<tr>
<td>Rule → Display</td>
<td>Switch to display mode</td>
</tr>
<tr>
<td>Rule → Simulate</td>
<td>Simulate the rule to view which data fields will be used for validation/substitution when the rule is called. For more information, see Simulating a Validation/Substitution/Rule [Seite 1170].</td>
</tr>
<tr>
<td>Rule → Save</td>
<td>Save rule</td>
</tr>
<tr>
<td>Rule → Transport</td>
<td>Transport the rule to another system. For more information, see Transporting Validations/Substitutions/Rules [Seite 1166].</td>
</tr>
<tr>
<td>Rule → Overview</td>
<td>Display content of rule with elements used (structure fields, exits, sets or other rules)</td>
</tr>
<tr>
<td>Rule → Delete</td>
<td>See: Deleting a Rule [Seite 1111]</td>
</tr>
<tr>
<td>Extras → ...</td>
<td>See: Creating a Rule [Seite 1107]</td>
</tr>
<tr>
<td>Environment → ...</td>
<td>See: Creating a Rule [Seite 1107]</td>
</tr>
</tbody>
</table>
Deleting a Rule

1. In Customizing for *Special Purpose Ledger*, choose *Tools → Maintain Validation/Substitution/Rules → Maintain Logical Rules*.

2. The *Rule Maintenance* screen appears. In the Control area on the left, expand the node for the required application area. You can then expand the node for your required callup point. Select the node of the required rule. The *Change Rule: <Rule Name>* screen appears.

3. Choose *Rule → Delete*.
   
   A dialog box appears, asking you if you want to delete the rule.
   
   If the rule is currently used in the system, a dialog box appears, displaying the application components where the rule is used.
   
   ![You cannot delete rules that are being used in an R/3 application component or in another rule.](image)

4. To delete the rule, choose *Yes*. The rule has been deleted. You cannot restore a deleted rule.
Examples of Rules

RULE1:

\texttt{COBL-WAERS IN CURRENCY AND COBL-HKONT >= '5000000' AND COBL-HKONT <= '5000050'}

This rule refers to:

The set \texttt{CURRENCY}

Account 5000000

Account 5000050

The set \texttt{CURRENCY} contains the currency codes DEM, SFR, LIT, BRF, or HFL. The rule is true when the document's currency code is DEM, SFR, LIT, BRF, or HFL \textbf{and} the account is between 5000000 and 5000050, including accounts 5000000 and 5000050.

The following are examples of the use of the rule RULE1:

\texttt{RULE1 AND COBL-BLART <> 'SB'}

\texttt{RULE1 AND NOT COBL-BLART = 'SB'}

\texttt{NOT COBL-BLART = 'SB' AND RULE1}

The above linked statements have the same result. Each combined statement is true when the following conditions are met:

The document's currency code is DEM, SFR, LIT, BRF, or HFL.

The account is between 5000000 and 5000050, including 5000000 and 5000050.

The document type is not SB.
Rules (old)

Using rules, you can use a statement in one process and then use the same statement in another process by linking the statement to another statement.

As from Release 4.6A there is a new interface with controls for processing rules. If you want to continue using the old interface, you must make the following setting: In the menu choose System → User profile → Own data. Then choose Parameters and create an entry with the parameter GBK and the value X.

This section contains:

Introduction to Rules [Seite 1105]
Creating a Rule (old) [Seite 1114]
Displaying a Rule (old) [Seite 1117]
Changing a Rule (old) [Seite 1118]
Deleting a Rule (old) [Seite 1119]
Creating a Rule (old)

   The Change Rule: Initial Screen appears.

6. Choose Rule → Create.
   The Create Rule: Initial Screen appears.

7. Enter the following data:
   - Rule name
   - Rule description
   - Application area code for the rule
   - Callup point code for the rule
   Example entries for the application area/callup point combinations are shown in the table in Creating a Validation [Seite 1057].

8. If you want to create a rule by copying an existing rule, enter the name of the rule that you want to copy in the Copy from - Rule name field.
   The rule must have the same Boolean class as the rule you are creating.

9. Enter the statement for the rule. A rule is limited to 999 lines.
   You can enter a rule statement either directly or using the Formula Builder. The Formula Builder provides an easy-to-use interface for entering logical statements.

   If you want to enter the statement using the Formula Builder:
   a) Choose Formula Builder.
   b) Define the Boolean statement. If you switch to the export mode in the Formula Builder, you enter the statement using the new syntax rules.
      For further information, see Syntax Rules for Boolean Statements [Seite 1133] and Formula Builder [Seite 1055].
   c) Save your entries.

   If you want to enter the statement directly:
   a) Choose Continue.
      The Create Rule: <Rule Name> screen appears.
   b) Enter the Boolean statement using the old syntax rules. For further information, see Old Syntax Rules for Boolean Statements [Seite 1138].
      You can also enter a user exit (type 1 or 3) in the Boolean statement. For further information about user exits, see User Exits in Validations/Substitutions/Rules [Seite 1053].
If you still store your rules in table T890 (interpreted rules), it is highly recommended that you use report RGUGBR10 to convert interpreted rules into generated rules. For more information, see Using the Rule Manager Program [Seite 1164].

c) You can use the following additional functions on this screen.

**Add Additional Processing Functions**

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rule → Check</td>
<td>Check the syntax of your Boolean statement</td>
</tr>
<tr>
<td>Rule → Save</td>
<td>Save the rule definition</td>
</tr>
<tr>
<td>Edit → Insert line</td>
<td>Add another line to the Boolean statement</td>
</tr>
<tr>
<td>Edit → Delete line</td>
<td>Delete a line from the Boolean statement</td>
</tr>
<tr>
<td>Goto → Header</td>
<td>Enter an authorization group for the rule and/or change the rule name and/or description</td>
</tr>
<tr>
<td>Extras → Fids in Bool.statmmt</td>
<td>Display a list of valid fields that you can use for the rule. These fields are determined based on the Boolean class of the rule.</td>
</tr>
<tr>
<td>Extras → Rule list</td>
<td>Display a list of rules that use the same Boolean class as the rule</td>
</tr>
<tr>
<td>Extras → Set directory</td>
<td>List sets that have been created in your system. For more information, see Displaying a Set Directory [Seite 685].</td>
</tr>
<tr>
<td>Extras → Switch on trace</td>
<td>Switch on the tracing function. While posting a document, the system calls the rule and shows you which data is used. This function allows you to diagnose possible errors in the rule definition. For further information, see Tracing a Validation/Substitution/Rule [Seite 1169].</td>
</tr>
<tr>
<td>Extras → Switch off trace</td>
<td>Switch off the tracing function</td>
</tr>
<tr>
<td>Extras → Usage</td>
<td>Display where the rule is currently used</td>
</tr>
</tbody>
</table>

d) To save the rule, choose Rule → Save.

**Result**

You can now use the rule in:

- A validation and/or substitution prerequisite or check
- Another rule
- Ledger selection
- Rollups
- Report Writer
Creating a Rule (old)
Displaying a Rule (old)

   The Change Rule: Initial Screen appears.

2. Choose Rule → Display.
   The Display Rule: Initial Screen appears.

3. Enter the following data:
   - Rule name
   - Application area code for the rule (optional)
   - Callup point code for the rule (optional)

4. You can use the following additional functions on this screen.

<table>
<thead>
<tr>
<th>Additional Processing Functions</th>
<th>Display Rule: Initial Screen</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Choose</strong></td>
<td><strong>Function</strong></td>
</tr>
<tr>
<td>Rule → Create</td>
<td>Create a rule</td>
</tr>
<tr>
<td>Rule → Change</td>
<td>Change a rule definition</td>
</tr>
<tr>
<td>Rule → Simulate</td>
<td>Simulate the rule to view which data fields will be used for validation/substitution when the rule is called. For more information, see Simulating a Validation/Substitution/Rule [Seite 1170].</td>
</tr>
<tr>
<td>Rule → Transport</td>
<td>Transport the rule to another system. For more information, see Transporting Validations/Substitutions/Rules [Seite 1166].</td>
</tr>
<tr>
<td>Rule → Print</td>
<td>Print the rule definition</td>
</tr>
<tr>
<td>Rule → Delete</td>
<td>Delete a rule</td>
</tr>
<tr>
<td>Extras → Usage</td>
<td>Display where the rule is currently used</td>
</tr>
<tr>
<td>Environment → Directory</td>
<td>Display a directory of rule information. For more information, see Displaying a Directory of Validations/Substitutions/Rules [Seite 1168].</td>
</tr>
<tr>
<td>Environment → Val./sub. analysis</td>
<td>Call up the validation/substitution analysis tool. For more information, see Using the Analysis Tool [Seite 1171].</td>
</tr>
</tbody>
</table>

5. Choose Formula Builder or Continue.
You can also display rules when creating, changing or displaying validations and substitutions.
To do this, choose Environment → Maintain rules.
Changing a Rule (old)

   The Change Rule: Initial Screen appears.

2. Enter the following data:
   - Rule name
   - Application area code for the rule (optional)
   - Callup point code for the rule (optional)

3. Choose Formula Builder or Continue.

4. Change the rule as required and save your changes.
Deleting a Rule (old)

   The Change Rule: Initial Screen appears.

2. In the Rule name field, enter the name of the rule you want to delete.

3. Choose Rule → Delete.
   A dialog box appears, asking you if you want to delete the rule.
   If the rule is currently used in the system, a dialog box appears, displaying the application components where the rule is used.
   
   You cannot delete rules that are being used in an R/3 application component or in another rule.

4. To delete the rule, choose Yes.
   The rule has been deleted. You cannot restore a deleted rule.
Boolean Logic/Syntax

This section contains:

- Introduction to Boolean Logic [Seite 1121]
- Using Boolean Operators in Truth Tables [Seite 1145]
- Creating Boolean Statements for the FI-SL System [Seite 1125]
- Using Boolean Statements in FI-SL [Seite 1126]
Introduction to Boolean Logic

What Is Boolean Logic?
Boolean logic refers to the system of mathematical logic called Boolean algebra, named after the English mathematician George Boole. It is used to create logical rules or statements. These logical statements are used to analyze, select, and process data that enters the FI-SL application component.

In the FI-SL application component, you can use Boolean logic to:
- Select data for a report
- Select ledgers for posting
- Substitute data in local, global, and rollup ledgers
- Validate data that enters the FI-SL application component

The FI-SL application component first analyzes the data using logical statements and then determines whether the data should be used. If the logical statement is true, the data is used; if the statement is false, the data is not used.

Uses of Boolean Logic
Boolean logic is used in:
- Ledger selection
- Report Writer
- Rollups
- Validation
- Substitution

To use Boolean logic in these programs, you create logical statements that are then used as formulas in the FI-SL system. For more information, see the following section Boolean Logical Statements.

For more information on using Boolean logic in ledger selection, Report Writer, rollups, validations, and substitutions, see Using Boolean Statements in FI-SL [Seite 1126].

Boolean Logical Statements
A Boolean logical statement is a logical proposition that is either true or false. The following are examples of true and false statements:
- Los Angeles is in California. (TRUE)
- Boston lies on the Mississippi River. (FALSE)
- $2 + 2 = 4$ (TRUE)
- $10 < 6$ (FALSE)

Logical statements can be linked using operators. An operator links logical statements and defines how the statements should be processed. A combined statement is two or more logical statements linked together.
Introduction to Boolean Logic

Boolean logic uses the following operators:

AND (conjunction)

When you use this operator, both statements must be true for the combined statement to be true.

1. Los Angeles is a city in California AND (2 + 2 = 4)  (TRUE)
2. (2 + 2 = 4) AND (10 < 6)  (FALSE)
3. (10 < 6) AND (2 + 2 = 4)  (FALSE)
4. (2 + 3 = 4) AND (10 < 6)  (FALSE)

OR (disjunction)

When you use this operator, at least one of the statements must be true for the combined statement to be true.

1. Los Angeles is a city in California OR (2 + 2 = 4)  (TRUE)
2. Los Angeles is a city in California OR (10 < 6)  (TRUE)
3. (10 < 6) OR Los Angeles is a city in California  (TRUE)
4. Los Angeles is a city in Texas OR (10 < 6)  (FALSE)

NOT (negation)

When you use this operator, the statement that follows the NOT operator must be false for the statement to be true.

1. NOT (2 + 2 = 4)  (FALSE)
2. NOT (10 < 6)  (TRUE)

NAND (NOT AND)

When you use this operator, at least one statement must be false for the combined statement to be true.

1. (2 + 2 = 4) NAND Los Angeles is a city in California  (FALSE)
2. (2 + 2 = 4) NAND (10 < 6)  (TRUE)
3. (10 < 6) NAND (2 + 2 = 4)  (TRUE)
4. (2 + 3 = 4) NAND (10 < 6)  (TRUE)

NOR (NOT OR)

When you use this operator, both statements must be false for the combined statement to be true.
Introduction to Boolean Logic

1. \((2 + 2 = 4)\) NOR Los Angeles is a city in California (FALSE)
2. \((2 + 2 = 4)\) NOR \((1 = 2)\) (FALSE)
3. \((2 + 1 = 4)\) NOR \((2 + 2 = 4)\) (FALSE)
4. \((2 + 1 = 4)\) NOR \((10 < 6)\) (TRUE)

---> (implication)

When you use this operator, the two statements depend on each other to determine the truth value of the statement ("IF A, THEN B"). However, if the second statement is true or the first statement is false, the combined truth value is true.

1. \((1 = 1) \rightarrow (2 + 4 = 6)\) (TRUE)
2. \((2 + 2 = 4) \rightarrow (10 < 6)\) (FALSE)
3. \((10 < 6) \rightarrow (2 + 2 = 4)\) (TRUE)
4. \((10 < 6) \rightarrow (2 + 3 = 4)\) (TRUE)

<-> (equivalence)

When you use this operator, both statements must be true or both statements must be false for the combined statement to be true.

1. \((1 = 1) \leftrightarrow (2 + 2 = 4)\) (TRUE)
2. \((1 = 1) \leftrightarrow (10 < 6)\) (FALSE)
3. \((10 < 6) \leftrightarrow (1 = 1)\) (FALSE)
4. \((2 + 3 = 4) \leftrightarrow (10 < 6)\) (TRUE)

For more information on Boolean statements, see Creating Boolean Statements for the FI-SL System [Seite 1125].

Truth Tables

Because statements can be linked with other statements and because logical statements are sometimes unclear, Boolean logic uses truth tables to determine if a combined statement is true or false.

A truth table assigns values (TRUE or FALSE) to each statement in a combined statement. Once the system has assigned a truth value to an individual statement, the system determines a truth value for the combined statements, depending on the operator that is used to link the statements.

The following is an example of a truth table:

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>X</td>
</tr>
</tbody>
</table>

April 2001 1123
This truth table shows all possible TRUE and FALSE combinations for statement A and statement B. The combined statement truth value (x) is determined by the operator that is used in the truth table. You can find truth tables for all Boolean operators under Using Boolean Operators in Truth Tables [Seite 1145].
Creating Boolean Statements for the FI-SL System

In the FI-SL application component, you can use Boolean Logic to create statements that can be used in the Report Writer and the ledger selection, rollup, validation, and substitution functions.

A Boolean statement can contain:
- Specific values
- Set names (a set of values)
- A TRUE or FALSE statement
- User exits (user-defined ABAP routines)
- Field comparisons
- Rule names
- Mathematical processing

Beginning with Release 4.0A, the syntax used to enter Boolean statements has changed. The new syntax is supported in validation and substitution statements that you enter directly and using the Formula Builder.

However, if you enter statements in rules directly (and not using the Formula Builder), you must use the syntax rules that applied in releases prior to Release 4.0A. (For more information, see Old Syntax Rules for Boolean Statements [Seite 1138].)

The old syntax rules are no longer supported when you maintain statements in validations and substitutions.

You do not have to recreate or change your existing validations and substitutions to conform with the new syntax rules. The system automatically converts your existing validations and substitutions so that they use the new syntax.

This section describes:
- Types of FI-SL Statements [Seite 1129]
- Syntax Rules for Boolean Statements [Seite 1133]
Using Boolean Statements in FI-SL

You can enter Boolean Logic statements for:

**Validations**
You can enter statements that define the conditions for using and validating incoming data.

**Substitutions**
You can enter statements that define the conditions for substituting incoming data.

**Ledger selection**
You can enter statements that define the conditions for selecting a ledger for posting.

**Report Writer**
You can enter statements that define conditions for selecting report data.

**Rollups**
You can enter statements that define the conditions for transferring substitution data to rollup ledgers.

### Boolean Statements in Ledger Selection

In ledger selection, you can use a Boolean statement to select a ledger for posting.

- If an account is a profit and loss account, then post the transaction to the ledger.

When you determine which activities will update a ledger, you can also define specific ledger selection conditions for selecting the ledger for posting. You can enter Boolean Logic statements in the *Condition* field on the *Change Ledger: Ledger Selection* screen.

- Activity grouping code: RFXX
- Ledger: D4
- Condition: GLT1–RCNTR = '100'

In this example, transaction data is posted to ledger D4 for all RFXX activities, when the cost center is 100.

When data is transferred into the FI-SL application component, you can post the data to a ledger according to the statement entered in the *Condition* field.

- For improve system performance, you should enter a Boolean Logic rule rather than a statement.
**Boolean Statements in Report Writer**

In Report Writer, you can use a Boolean statement to select data for reports. Using Boolean statements results in slower processing, but you can define more complex selection criteria.

If the cost center is 100 and the company code is not 2000, select the data for a report.

You enter Boolean Logic rules in the *Rule name* field, which appears in a dialog box when you choose *Edit → Selection rule* on the Create Report: General Data Selection screen.

You create a selection rule called AR-REPORT. This selection rule contains the following selection statement:

```java
GLT1-RCNTR = '100' AND GLT1-BUKRS <> '2000'
```

This statement instructs the system to select all records where the cost center is 100 and the company code is not 2000.

The selection statement you use in a report definition can only refer to the table defined in the report’s library.

A statement can only refer to table GLT1 if the report is in a library that uses table GLT1.

To improve system performance, you should use a set as a selection condition so that no selection statement is needed.

For more information about using statements in the Report Writer, see Defining Selection Criteria [Seite 835].

**Boolean Statements in Rollups**

In rollups, you can use Boolean statements entered in rules to transfer substituted data to receiver fields during the rollup process and to define which data should be rolled up in a rollup ledger.

If an account is greater than or equal to 200000 and less than 250000, the account should be substituted with the account 300000.

You enter Boolean Logic rules to:

Select data to be rolled up, in the *Rule* field on the Create Rollup *<Name>*: Rollup Sequence screen

Substitute data, in the *Rule* field on the Change View “Rollup Substitution”: Overview screen
Using Boolean Statements in FI-SL

You create a substitution rule called AR-ROLLUP. This substitution rule contains the following statement:

GLU1-RACCT >= '200000' AND GLU1-RACCT < '250000'

In the Rule field on the Change View “Rollup Substitution”: Overview screen, you enter the substitution rule AR-ROLLUP. You also enter the value with which transaction data is substituted (for example account 300000). When the transaction account is greater than or equal to 200000 and less than 250000, then the account is substituted with account 300000.

For more information about using statements in rollups, see Creating a Rollup Sequence [Seite 283].

Boolean Statements in Validations

In validations, you use Boolean statements to validate incoming data. The process for validating data is a two-step process, much like an IF/THEN condition (<>):

The system first checks if the validation prerequisite is TRUE for a transaction. If the transaction is TRUE, the system checks the data against the check statement (validation rule).

The system then checks the transaction against the validation rule. If the transaction is TRUE, the data is posted.

When a transaction’s plant is 10, transaction data is only valid for company 1000 when the cost center is between 110 and 180. If you try to enter transaction data when the plant is 10 and the cost center is not between 110 and 180, the system displays an appropriate system message.

Boolean Statements in Substitutions

In substitutions, you use Boolean statements to define the conditions under which a substitution is to be performed.

You create a dimension called Region in your coding block. You instruct the system to move the value 121223 to dimension Region in the FI-SL summary database when a transaction with cost center 300 enters FI-SL from another R/3 application component.
Types of FI-SL Statements

Using Boolean Logic, you can create different types of statements in the FI-SL application component. This statement is the smallest unit of an FI-SL statement.

You can create simple statements that use only one of the statement types or you can create complex statements that use combinations of the statement types. For more information about using these statements, see Syntax Rules for Boolean Statements [Seite 1133].

Specific Values

In this type of statement, you refer to a specific value or values.

\[ \text{COBL-RACCT} = '50000100' \]

In this example, the account must be 50000100.

Set Names

In this type of statement, you refer to a basic, single-dimension, or multi-dimension set name that contains the values you want to use in the statement.

Beginning with Release 4.0A, sets are no longer table-dependent. The set name and the table are no longer the key fields that uniquely identify the set. Sets are uniquely identified by the set name.

The format used to enter sets in statements has therefore changed, depending on whether you use the new syntax rules for Release 4.0 or the syntax rules that existed in releases prior to Release 4.0. You only use the old syntax rules when you enter a statement in a rule directly (that is, not using the Formula Builder).

For more information about the format for entering sets using the new syntax rules, see step four in Syntax Rules for Boolean Statements [Seite 1133].

For more information about the format for entering sets using the old syntax rules, see step five in Old Syntax Rules for Boolean Statements [Seite 1138].

If you enter a set name that is not unique (that is, there is more than one set in the system that uses this name), the system displays a dialog box in which you select the set that you want to use.

Sets that you created in Releases 3.0 and 3.1 are automatically converted into the new set structures for Release 4.0. You do not need to recreate or change your existing sets. The new sets are fully compatible with Release 4.0 and you can still use them in validation and substitution statements and rules.

Basic or single-dimension sets:

To improve system performance, you should use basic or single-dimension sets, rather than long lists of Boolean statements or user exits.
Types of FI-SL Statements

You can refer to a basic or single-dimension set in a statement even if the set has been created for a table that is not supported by the statement’s Boolean class. You cannot use this function with multi-dimension sets.

In the following example, the basic set ACCOUNTS is created using the table BSEG, but the field HKONT refers to table COBL. The statement is true if the account is found in the set ACCOUNTS.

<table>
<thead>
<tr>
<th>COBL–HKONT IN ACCOUNTS</th>
<th>This is the only format that you can use for basic and single-dimension sets using the new syntax rules.</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;COBL&gt; $HKONT IN &lt;BSEG&gt; ACCOUNTS</td>
<td>Optional table name using the old syntax rules</td>
</tr>
</tbody>
</table>

You can also search for partial values in a set. If the value is found in the set, the statement is true.

⚠️ If your statements and rules are still stored in table T890, you cannot search for partial values in a set or compare set fields used in different tables. It is recommended that you use report RUGBR10 to switch to generated rules. For more information, see Using the Rule Manager Reports [Seite 1164]

Multi-dimension sets:

To improve system performance, you should use multi-dimension sets when you want the system to check that a transaction contains two or more values that use different dimensions (for example, a specific cost center and account). Using one multi-dimension set is more efficient than using two basic or single-dimension sets connected with the AND operator.

The following statement uses the multi-dimension set ACCTSCNTRS that contains account 5000010 (dimension Account) and cost center 100 (dimension Cost Center).

<table>
<thead>
<tr>
<th>IN ACCTSCNTRS</th>
<th>Using the new syntax rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>IN &lt;GLT1&gt; ACCTSCNTRS</td>
<td>Optional table name using the old syntax rules</td>
</tr>
</tbody>
</table>

For more information about creating sets, see Set Creation [Seite 651].

**TRUE or FALSE Statement**

In this type of statement, you simply state that a statement is TRUE or FALSE. It is possible to directly declare a statement as TRUE or FALSE (for example, as a substitute for a set name that will be inserted later).

It is not recommended that you use TRUE or FALSE statements when you enter a statement as a ledger selection condition.
**User Exits**

You can also refer to a user exit within a statement. The user exit accesses a background program; this program is usually more detailed than the statement, allowing for more extensive editing of data. For more information, see *User Exits in Validations/Substitutions/Rules [Seite 1053]*.

You cannot define user exits in rules that are stored in table T890. It is recommended that you use report RGUGBR10 to convert table T890 rules to generated rules. For more information, see *Using the Rule Manager Reports [Seite 1164]*.

**Field Comparisons**

You can also compare field values in a statement.

\[ \text{COBL-BUDAT} \neq \text{SY-DATUM} \]

In this example, when the date in the BUDAT field is not the same as the date in the DATUM field, the statement is TRUE.

When comparing fields, you can also instruct the system to check or compare only part of a field. For more information, see step one in *Syntax Rules for Boolean Statements [Seite 1133]*.

You can also compare text patterns in your statements by using the keyword LIKE.

\[ \text{COBL-KOSTL LIKE '1*1'} \]

In this example, the * sign represents any combination of characters. The system searches for all cost centers (field KOSTL) where the value 1 is used after the first and second combination of characters (for example, 161, 121, and 2101).

Within text pattern searches, you can also use the + sign to represent a single character.

If your statements and rules are still stored in table T890, you cannot use text patterns in your statements. It is recommended that you use report RGUGBR10 to convert table T890 rules to generated rules. For more information, see *Using the Rule Manager Reports [Seite 1164]*.

**Mathematical Processing**

With mathematical processing, you can evaluate and compare two mathematical expressions. The result of the comparisons is either true or false.

\[ \text{AVG ( BSEG-DMBTR )} < 100000 \]

In this example, the system checks that the average amount in local currency is less than 100000.
If your statements and rules are still stored in table T890, you cannot use mathematical processing in your statements. It is recommended that you use report RGUGBR10 to convert table T890 rules to generated rules. For more information, see Using the Rule Manager Reports [Seite 1164].
Syntax Rules for Boolean Statements

When you enter a Boolean Logic statement in the FI-SL application component, you must follow certain syntax rules. This section explains the syntax rules for creating a statement for the FI-SL application component.

The syntax rules described in this section are valid for validation and substitution statements that you enter directly and for statements that you enter using the Formula Builder in Release 4.0A. They do not apply for statements that you enter directly in rules.

You must use the following syntax rules when entering a statement in FI-SL:

Define the table name and field name that you will use in your statement. The field name is the dimension that contains the values that you refer to in your statement.

Enter the table name and field name in the following format:

```plaintext
table_name-field_name
```

You separate the table name and field name with a hyphen.

```
GLT1-RACCT
CCSS-KSTAR
```

The system checks if a value(s) is/are in the dimension entered in front of the value. If the value is in the dimension, the statement is TRUE; if the value is not in the dimension, the statement is FALSE.

You can also instruct the system to check only part of a field value. To enter this type of instruction, you enter the following:

- The table name and field name (```table_name-field_name```
- A blank space
  
  It is important that you insert a blank space before the first colon.
- A colon (```
- The digits that you want to be checked in the field name
- A colon (```

1 always represents the first digit of the field. (The number you enter does not represent a value; it represents the position of a value within the field string.)

- ```GLT1-RACCT :1-3:
  
  The system checks only the first three digits of the field Account to determine if a condition is TRUE.
```
- ```GLT1-RACCT :5-7:
  
  The system checks digits 5, 6, and 7 of the field Account to determine if a condition is TRUE.
```
Syntax Rules for Boolean Statements

- **GLT1-RACCT**: 2: -:
  
  The system checks from digit 2 to the end of the field Account to determine if a condition is TRUE.

Separate the elements of your statement with at least one space.

Enter single quotation marks (') around specific values.

```plaintext
GLT1-RACCT = '500000'
COBL-BLART = 'SA'
```

For more information about the types of values you can refer to in a statement, see *Types of FI-SL Statements [Seite 1129]*.

Enter set names as follows, depending on the type of set you enter:

- **Basic** and **single-dimension** sets, enter the set in the following format:
  a) The table name and the field name of the set (table_name-field_name)
  b) The keyword IN
  c) The set name

```plaintext
GLT1-RACCT IN ACCOUNTS
```

- **Multi-dimension** sets, enter the set in the following format:
  a) The keyword IN
  b) The set name

```plaintext
IN ACCTSCNTRS
```

If you use a rule in your statement, enter the rule name only **without a preceding ampersand sign (&)).**

Enter double quotation marks ("~") around comments in the statement.

Text in double quotation marks is not processed by the system; it is only used to describe the statement.

You must enter comment text **before** the statement when you enter the statement directly or using the expert mode in the Formula Builder.

You cannot use blank spaces in the comment text when you enter the text directly in the statement. Also, the text can be no longer than 58 characters. If you wish to enter comment text that is longer than 58 characters, you must enter the comment text with two sets of comments with a blank space.

Use the Boolean Logic operators NOT, AND, OR, NAND, NOR, -->, and -<>.

The operator NOT has the highest priority and is processed first in the statement, except when parentheses are used within the statement.
In this example, the statement within the parentheses is processed first. The other operators are handled in the order in which they occur in the statement.

For more information, see Using Boolean Operators in Truth Tables [Seite 1145].

Use the standard mathematical operators in the following table.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
</tr>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
</tbody>
</table>

If entering a user exit in a statement:

a) Enter the character 'u' (for a user-defined user exit) or 'v' (for a standard SAP user exit).

b) Enter the user exit number (three digits) (for example, u123).

You configure the form pool name that contains user exits in the table for client-dependent user exits (table T80D) in Customizing for Special Purpose Ledger by choosing Basic Settings → User Exits → Maintain Client-Dependent User Exits. The form pool name should conform to the customer naming convention (beginning with the letter z) so that is not overwritten when the next SAP upgrade is installed.

If using mathematical processing in a statement:

a) Use the mathematical operators in the following table.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>−</td>
<td>Subtraction</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
</tr>
</tbody>
</table>

b) Use parentheses to define the order in which the mathematical expressions are to be evaluated.
Syntax Rules for Boolean Statements

If you are creating a matrix validation or substitution, you can also use the operators in the following table when validating or substituting line items in a document.

You must enter a blank space after the keyword and immediately before the opening parenthesis.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM (      )</td>
<td>Total of the document</td>
</tr>
<tr>
<td>AVG (      )</td>
<td>Average sum of the document</td>
</tr>
<tr>
<td>MAX (      )</td>
<td>Maximum value of all document lines</td>
</tr>
<tr>
<td>MIN (      )</td>
<td>Minimum value of all document lines</td>
</tr>
<tr>
<td>GROUP_BY</td>
<td>Compare a group of totals with another group of totals.</td>
</tr>
</tbody>
</table>

SUM ( BSEG-DMBTR ) < 50000

In this example, the user cannot post more than the amount 50000 in local currency for a document.

AVG ( TABLE-FIELD1 ) GROUP_BY TABLE-RYEAR TABLE-RVERS = AVG ( TABLE-FIELD2 ) GROUP_BY TABLE-RYEAR TABLE-RVERS

In this example, the statement is true if the average value for each year/version combination for FIELD1 is the same as the average value for the year/version combination for FIELD2.

You can also use rules within a statement that uses mathematical processing.

SUM ( BSEG-DMBTR ) WHERE RULE_1 < SUM ( BSEG-DMBTR ) WHERE RULE_2

In this example, the system calculates the total of the local currency (DMBTR) for the document lines where RULE1 is true. The system then calculates the total of the local currency for the document lines where RULE2 is true. The statement is TRUE if the first total is less than the second total.

To enter a statement as true or false, you can enter TRUE or FALSE.

To enter currency types in a Boolean statement, enter parentheses around the currency code.

You must specify a currency code in a Boolean statement when the currency amount has more or less than two decimal places.

You can only enter currency types in a Boolean statement when you enter the statement directly or using the expert mode in the Formula Builder.

BSEG-DMBTR < ‘10000 (BEF)’
See also:

Example Boolean Statements [Seite 1143]
Old Syntax Rules for Boolean Statements

When you create rules in Release 4.0A by entering the Boolean statement directly (that is, not using the Formula Builder), you must use the old syntax rules that were used in releases prior to Release 4.0A.

When you enter statements in validations and substitutions either directly or using the expert mode in the Formula Builder, you use the new syntax rules for Release 4.0A. For more information, see Syntax Rules for Boolean Statements [Seite 1133].

You must use the following syntax rules when entering a statement directly in a rule:

Define the table name first in your statement.

A statement must always refer to a table name. This table contains the dimensions that you will use in your statement.

Enter arrow brackets around the table name.

<GLT0>
<GLT1>
<COBL>

Within one statement, the table name is valid until you enter a new table. You can refer to more than one table in a statement.

When you enter a rule in a statement, you do not have to enter a table name for the rule; the table name that the rule uses should have been entered when the rule was defined. For more information about rules, see Introduction to Rules [Seite 1105].

For basic and single-dimension sets, you do not need to enter a table name for the set within the statement.

Separate the elements of your statement with at least one space.

Enter a $ sign and the field name that you will use in the statement.

The field name is the dimension that contains the values that you refer to in your statement.

<GLT1> $RACCT
<COBL> $BLRT

The system checks if a value(s) is/are in the dimension entered in front of the value. If the value is in the dimension, the statement is TRUE; if the value is not in the dimension, the statement is FALSE.
Old Syntax Rules for Boolean Statements

You can also instruct the system to check only part of a field value. To enter this type of instruction, you enter a $ sign, the field name, a colon (:), the digits that you want to be checked in the field name, and then a colon (:). 1 always represents the first digit of the field. (The number you enter does not represent a value; it represents the position of a value within the field string.)

- $GLT1 $RACCT:1-3:
The system checks only the first three digits of the field Account to determine if a condition is TRUE.
- $GLT1 $RACCT:5-7:
The system checks digits 5, 6, and 7 of the field Account to determine if a condition is TRUE.
- $GLT1 $RACCT:2-:
The system checks from digit 2 to the end of the field Account to determine if a condition is TRUE.

Enter single quotation marks (‘) around specific values.

If you use a set in a statement, you do not enter single quotation marks around the set name.

- $GLT1 $RACCT = '500000'
- $COBL $BLART = 'SA'

Enter set names as follows:
a) The keyword IN
b) The set name

The system still allows you to enter the table that the set uses before the set name (IN <table_name> set_name).

The following example uses the basic set ACCOUNTS created for table GLT1.

IN ACCOUNTS
IN <GLT1> ACCOUNTS (with optional table name)

Use parentheses to summarize independent parts of your statement.

- $COBL ($HKONT = '500000' AND $HKONT = '600000') OR $KOSTL = '100'

Enter double quotation marks (") around comments in the statement.
Old Syntax Rules for Boolean Statements

Text in double quotation marks is not processed by the system; it is only used to describe the statement.

Use the Boolean Logic operators NOT, AND, OR, NAND, NOR, -->, and <-->.

The operator NOT has the highest priority and is processed first in the statement, except when parentheses are used within the statement.

\[ \text{NOT} \ (A \text{ OR } B) \]

In this example, the statement within the parentheses is processed first. The other operators are handled in the order in which they occur in the statement.

For more information, see Using Boolean Operators in Truth Tables [Seite 1145].

Use the standard mathematical operators in the following table.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
</tr>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
</tbody>
</table>

If entering a user exit in a statement:

a) Enter =

b) Enter the character U (for a user-defined user exit) or S (for a standard SAP user exit).

c) Enter the user exit number (three digits) (for example, =U123).

You configure the form pool name that contains user exits in the table for client-dependent user exits (table T80D) in Customizing for Special Purpose Ledger by choosing Basic Settings → User Exits → Maintain Client-Dependent User Exits. The form pool name should conform to the customer naming convention (beginning with the letter Z) so that is not overwritten when the next SAP upgrade is installed.

If using mathematical processing in a statement:

a) Enter the keyword MATHS (in front of the mathematical expression).

b) Enter parentheses after the mathematical expression.

c) Use the mathematical operators in the following table.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
</tr>
</thead>
</table>

1140 April 2001
Old Syntax Rules for Boolean Statements

d) Use parentheses to define the order in which the mathematical expressions are to be evaluated.

If you are creating a matrix validation or substitution, you can also use the operators in the following table when validating or substituting line items in a document.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM(    )</td>
<td>Total of the document</td>
</tr>
<tr>
<td>AVG(    )</td>
<td>Average sum of the document</td>
</tr>
<tr>
<td>MAX(    )</td>
<td>Maximum value of all document lines</td>
</tr>
<tr>
<td>MIN(    )</td>
<td>Minimum value of all document lines</td>
</tr>
<tr>
<td>GROUP BY</td>
<td>Compare a group of totals with another group of totals.</td>
</tr>
</tbody>
</table>

\[
\text{MATHS} \left( \text{SUM}( $\text{HSL} ) < 50000 \right)
\]

In this example, the user cannot post more than the amount 50000 in local currency for a document.

\[
\text{MATHS} \left( \text{AVG}( $\text{FIELD1} ) \text{ GROUP BY } $\text{YEAR} $\text{VERSION} = \text{AVG}( $\text{FIELD2} ) \text{ GROUP BY } $\text{YEAR} $\text{VERSION} \right)
\]

In this example, the statement is true if the average value for each year/version combination for FIELD1 is the same as the average value for the year/version combination for FIELD2.

You can also use rules within a statement that uses mathematical processing.

\[
\text{MATHS} \left( \text{SUM}( $\text{DMBTR} ) \text{ WHERE } &\text{RULE}_1 < \text{SUM}( $\text{DMBTR} ) \text{ WHERE } &\text{RULE}_2 \right)
\]

In this example, the system calculates the total of the local currency (DMBTR) for the document lines where RULE1 is true. The system then calculates the total of the local currency for the document lines where RULE2 is true. The statement is TRUE if the first total is less than the second total.

To enter a statement as true or false, you can enter TRUE or FALSE.

To enter currency types in a Boolean statement, enter parentheses around the currency code.
Old Syntax Rules for Boolean Statements

You must specify a currency code in a Boolean statement when the currency amount has more or less than two decimal places.

<BSEG> $DMBTR < '10000 (BEF)'
Example Boolean Statements

COBL-BLART = 'SA'
In this statement, the statement is TRUE if the document type is SA.

COBL-BLART = 'SA' OR COBL-BLART = 'SB' AND COBL-HKONT <> '5000000'
In this statement, the combined statements are TRUE if the document type is SA or SB, and the account of the document item is not account 5000000.

COBL-BLART IN DOCMNT-TYPE OR COBL-WAERS IN CURRENCY
This statement contains two sets: DOCMNT-TYPE and CURRENCY. The set DOCMNT-TYPE contains the values SA and SB; the set CURRENCY contains the currency codes DEM, SFR, LIT, BRF, and HFL. Both sets use dimensions from table COBL.

The combined statement is true if the document type is SA or SB, or the document’s currency code is DEM, SFR, LIT, BRF, or HFL.

COBL-BLART IN DOCMNT-TYPE --> COBL-HKONT IN ACCOUNTS
This statement contains two sets: DOCMNT-TYPE and ACCOUNTS. The set DOCMNT-TYPE contains the values SA and SB and uses dimension Document Type in table COBL; the set ACCOUNTS contains the accounts 5000000, 5000010, and 5000020 and uses dimension Account in table COBL.

If the document type is SA or SB, then the account must be 5000000, 5000010 or 5000020 for the combined statement to be TRUE. The document types SA and SB can only post to these accounts.

GLT0-BUKRS :1-2: = '00'
This statement instructs the system to check part of the company code. The first two digits of the company code dimension must be 00 for the statement to be TRUE.

IN ACCTS-CNTRS
The following graphic illustrates the multi-dimension set ACCTS-CNTRS.
Example Boolean Statements

In the above example, the multi-dimension set ACCTS-CNTRS contains the basic sets CASH-ACCTS (dimension Account) and ADMIN-CNTRS (dimension Cost Center). If a transaction contains account 5000010 and cost center 200, the statement would be TRUE. If a transaction has the values account 5000010 and cost center 300, the statement would be FALSE.
Using Boolean Operators in Truth Tables

A Boolean statement is a logical proposition that is either true or false. Logical statements can be linked together using operators (such as AND, OR, NOT, NAND, NOR, -->, and <-->). The system uses these operators to decide how to process the Boolean statements.

When you link statements together, you form a combined statement. Each individual statement in a combined statement is assigned either the value TRUE or FALSE in a truth table. Which truth value (TRUE or FALSE) the combined statement receives depends on the operator.

This section contains:

AND (Conjunction) [Seite 1146]
OR (Disjunction) [Seite 1148]
NOT (Negation) [Seite 1150]
NAND (NOT AND) [Seite 1151]
NOR (NOT OR) [Seite 1153]
--> (Implication) [Seite 1155]
<-- (Equivalence) [Seite 1157]
AND (Conjunction)

You use the AND (conjunction) operator when both of your logical statements must be true for the combined statement to be true.

1. Los Angeles is a city in California AND (2 + 2 = 4) (TRUE)
2. (2 + 2 = 4) AND (10 < 6) (FALSE)
3. (10 < 6) AND (2 + 2 = 4) (FALSE)
4. (2 + 3 = 4) AND (10 < 6) (FALSE)

The following table is the truth table for the AND (conjunction) operator.

<table>
<thead>
<tr>
<th>Statement A</th>
<th>Statement B</th>
<th>A AND B</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>TRUE</td>
</tr>
<tr>
<td>TRUE</td>
<td>FALSE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>TRUE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>FALSE</td>
<td>FALSE</td>
</tr>
</tbody>
</table>

In the FI-SL application component, you use the AND (conjunction) operator when you want the system to check that both statements are true before using the data.

The following graphic uses a truth table for the AND (conjunction) operator to determine if a transaction posts to a ledger.

If the transaction is for account 500000 and cost center 150, then the combined statement is TRUE and the data is posted to the ledger. If the transaction is not for account 500000 or if it is...
not for cost center 150, then the combined statement is FALSE and the data is not posted to the ledger.
**OR (Disjunction)**

You use the OR (disjunction) operator when at least one of your logical statements must be true for the combined statement to be true.

<table>
<thead>
<tr>
<th>Statement A</th>
<th>Statement B</th>
<th>A OR B</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>TRUE</td>
</tr>
<tr>
<td>TRUE</td>
<td>FALSE</td>
<td>TRUE</td>
</tr>
<tr>
<td>FALSE</td>
<td>TRUE</td>
<td>TRUE</td>
</tr>
<tr>
<td>FALSE</td>
<td>FALSE</td>
<td>FALSE</td>
</tr>
</tbody>
</table>

The following table is the truth table for the OR (disjunction) operator.

In the FI-SL application component, you use the OR (disjunction) operator when you want the system to check that at least one statement is true before using the data.

The following graphic uses a truth table for the OR (disjunction) operator to determine if transaction data should be substituted.
If the transaction is for account 500000 or for cost center 150, then the combined statement is TRUE and the data is substituted. If the transaction is not for account 500000 or for cost center 150, then the combined statement is FALSE and the data is not substituted.
NOT (Negation)

When you use the NOT (negation) operator, the statement that follows the NOT operator must be false for the statement to be true.

1. NOT (2 + 2 = 4) (FALSE)
2. NOT (10 < 6) (TRUE)

The following table is the truth table for the NOT (negation) operator.

<table>
<thead>
<tr>
<th>Statement A</th>
<th>NOT A</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

In the FI-SL application component, you use the NOT operator when you want the system to check that the data is not <x>, before the system uses the data.

The following graphic uses a truth table for the NOT operator to determine if the data is used to select a ledger for posting.

If the transaction is for account 500000, the statement is FALSE and the data is not posted to the ledger. If the transaction is not for account 500000, the statement is TRUE and the data is posted to the ledger.
**NAND (NOT AND)**

When you use the NAND (NOT AND) operator, at least one statement must be false for the combined statement to be true. This operator is the same as using the statement NOT (A AND B).

1. \( (2 + 2 = 4) \) NAND Los Angeles is a city in California (FALSE)
2. \( (2 + 2 = 4) \) NAND \( (10 < 6) \) (TRUE)
3. \( (10 < 6) \) NAND \( (2 + 2 = 4) \) (TRUE)
4. \( (2 + 3 = 4) \) NAND \( (10 < 6) \) (TRUE)

The following table is the truth table for the NAND (NOT AND) operator.

<table>
<thead>
<tr>
<th>Statement A</th>
<th>Statement B</th>
<th>A NAND B</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>FALSE</td>
</tr>
<tr>
<td>TRUE</td>
<td>FALSE</td>
<td>TRUE</td>
</tr>
<tr>
<td>FALSE</td>
<td>TRUE</td>
<td>TRUE</td>
</tr>
<tr>
<td>FALSE</td>
<td>FALSE</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

In the FI-SL application component, you use the NAND (NOT AND) operator when you want the system to check (1) first, that the data is not \(<x>\), and (2) that the data is \(<y>\), before the system uses the data.

The following graphic uses a truth table for the NAND (NOT AND) operator to determine if a transaction posts to a ledger.
If the transaction is for account 500000 and cost center 150, then the combined statement is FALSE and the data is not posted to the ledger. If the transaction is not for account 500000 or not for cost center 150, then the combined statement is TRUE and the data is posted to the ledger.
NOR (NOT OR)

When you use the NOR (NOT OR) operator, both statements must be false for the combined statement to be true. This operator is the same as using the statement \( NOT (A \ OR \ B) \).

1. \((2 + 2 = 4) \ NOT \ Los \ Angeles \ is \ a \ city \ in \ California \) (FALSE)
2. \((2 + 2 = 4) \ NOT \ (1 = 2) \) (FALSE)
3. \((2 + 1 = 4) \ NOT \ (2 + 2 = 4) \) (FALSE)
4. \((2 + 1 = 4) \ NOT \ (10 < 6) \) (TRUE)

The following table is the truth table for the NOR (NOT OR) operator.

<table>
<thead>
<tr>
<th>Statement A</th>
<th>Statement B</th>
<th>A NOR B</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>FALSE</td>
</tr>
<tr>
<td>TRUE</td>
<td>FALSE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>TRUE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>FALSE</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

In the FI-SL application component, you would use the NOR (NOT OR) operator when you want the system to check that at least one statement is not \(<x>\) (before the system uses the data).

The following graphic uses a truth table for the NOR (NOT OR) operator to determine if transaction data should be substituted.
If the transaction is for account 500000 and/or for cost center 150, then the combined statement is FALSE and the data is not substituted. If the transaction is not for account 500000 or for cost center 150, then the combined statement is TRUE and the data is substituted.
-- (Implication)

When you use the --> (implication) operator, the two statements depend on each other to determine the truth value of the statement ("IF A, THEN B"). However, if the second statement is true or the first is false, the combined truth value is true.

<table>
<thead>
<tr>
<th>1. (1 = 1) --&gt; (2 + 4 = 6)</th>
<th>TRUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. (2 + 2 = 4) --&gt; (10 &lt; 6)</td>
<td>FALSE</td>
</tr>
<tr>
<td>3. (10 &lt; 6) --&gt; (2 + 2 = 4)</td>
<td>TRUE</td>
</tr>
<tr>
<td>4. (10 &lt; 6) --&gt; (2 + 3 = 4)</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

The following table is the truth table for the --> operator.

<table>
<thead>
<tr>
<th>Statement A</th>
<th>Statement B</th>
<th>A --&gt; B</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>TRUE</td>
</tr>
<tr>
<td>TRUE</td>
<td>FALSE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>TRUE</td>
<td>TRUE</td>
</tr>
<tr>
<td>FALSE</td>
<td>FALSE</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

In the FI-SL application component, you use the --> (implication) operator when you want the system to check that based on the first statement, the second statement is true (before the system uses the data).

The following graphic uses a truth table for the --> (implication) operator to determine if a transaction is used for posting to a ledger.
If the transaction is for account 500000, the system checks if the transaction cost center is 150. If the cost center is not 150, then the combined statement is FALSE and the data is not posted to the ledger. If the cost center is 150, then the combined statement is TRUE and the data is posted to the ledger.

If the transaction is not for account 500000 and is not for cost center 150, the combined statement is TRUE and the data is posted. If the transaction is not for account 500000 and is for cost center 150, the combined statement is TRUE and the data is posted.
<-> (Equivalence)

You use the <-> (equivalence) operator when both statements must be true or both statements must be false for the combined statement to be true.

1. \( (1 = 1) \leftrightarrow (2 + 2 = 4) \) (TRUE)
2. \( (1 = 1) \leftrightarrow (10 < 6) \) (FALSE)
3. \( (10 < 6) \leftrightarrow (1 = 1) \) (FALSE)
4. \( (2 + 3 = 4) \leftrightarrow (10 < 6) \) (TRUE)

The following table is the truth table for the <-> (equivalence) operator.

<table>
<thead>
<tr>
<th>Statement A</th>
<th>Statement B</th>
<th>A &lt;-&gt; B</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>TRUE</td>
</tr>
<tr>
<td>TRUE</td>
<td>FALSE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>TRUE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>FALSE</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

In the FI-SL application component, you use the <-> (equivalence) operator when you want the system to check that both statements are false for the incoming data or both statements are true for the incoming data (before the system uses the data).

The following graphic uses a truth table for the <-> (equivalence) operator to determine if a transaction is selected for a report.
If the transaction is for account 500000 and for cost center 150, then the combined statement is TRUE and the data is selected for a report. If the transaction is not for account 500000 and cost center 150, then the combined statement is TRUE and the data is selected for a report.

If the transaction is not for account 500000 and for cost center 150, then the combined statement is FALSE and the data is not selected for a report. If the transaction is for account 500000 but not for cost center 150, then the combined statement is also FALSE and the data is not selected for a report.
Miscellaneous Procedures

This section describes:

Adding Fields to and Deleting Fields from a Boolean Class [Seite 1160]
Setting the User Exit File Name [Seite 1162]
Setting the Message Class [Seite 1163]
Using the Rule Manager Reports [Seite 1164]
Transporting Validations/Substitutions/Rules [Seite 1166]
Displaying a Directory of Validations/Substitutions/Rules [Seite 1168]
Tracing a Validation/Substitution/Rule [Seite 1169]
Simulating a Validation/Substitution/Rule [Seite 1170]
Using the Analysis Tool [Seite 1171]
Adding Fields to and Deleting Fields from a Boolean Class

If a field is not defined for a Boolean class, it cannot be used in a validation, substitution, and/or rule. If you want to use a specific field in a validation, substitution, and/or rule and the field is not defined for the Boolean class, you must add the field to the Boolean class. If you do not want a field used for a Boolean class, you must exclude the field from the Boolean class.

Procedure

In the command field, enter /NSM30 and choose Enter.

The Maintain Table Views: Initial Screen appears.

In the Table/View field, enter v_gb01c and choose Maintain.

View GB01C contains the customer configuration fields that can be used for each Boolean class.

The Boolean class type can be:

- **A** Used for rules, conditions, and substitutions (read/write)
- **B** Used for rules and conditions only (read)
- **S** Used only for fields that can be substituted (write)

Boolean class type **S** is not used for substitution conditions.

You can specify all fields for a particular table by using * for the field name. The following table shows examples of how you can use Boolean class type **B** for Boolean class **8**.

<table>
<thead>
<tr>
<th>Boolean class</th>
<th>Table – Field</th>
<th>Type</th>
<th>Exclude</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>COBL – *</td>
<td>B</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>COBL – MENG</td>
<td>B</td>
<td>X</td>
</tr>
</tbody>
</table>

For Boolean class 8, type **B** (B = Read only) all fields except the Quantity field (MENGE) can be used for validations and rules.

To add a field to a Boolean class:

Deselect the Exclude indicator for each field you want to include in the Boolean class.

To exclude a field from a Boolean class:

Select the Exclude indicator for each field that you do not want included in the Boolean class.

It is not possible to remove a table entry (or the last field belonging to a table), as this could create a syntax error in the generated code.
Adding Fields to and Deleting Fields from a Boolean Class

SAP-delivered table GB01 (together with GB01C) is also used to specify the fields allowed for a Boolean class; however, you cannot change table GB01. If a field is excluded in table GB01 and you include the excluded field in GB01C, the field will not be included, since GB01 has priority.

You can only add fields to a Boolean class if they are already defined in table GB01 for the respective Boolean class.

Choose Table view → Save.
Setting the User Exit File Name

User exits are user-defined FORM routines, which are used to calculate and/or replace values within a validation, substitution, or rule. The form pool name of the user exit is configurable and must be stored in the table for client-dependent user exits (table T80D) in Customizing for Special Purpose Ledger. Table T80D contains the form pool names for the user exits used in validations, substitutions, and rules. Each validation/substitution form pool is client-dependent.

It is recommended that you edit table T80D so that the generic form pool name of your user exits complies with the naming convention for customer files.

You edit table T80D in Customizing for Special Purpose Ledger by choosing Basic Settings → User Exits → Maintain Client-Dependent User Exits.

The form pool name you enter can be up to five characters and must begin with the letter z. You enter the form pool name next to each application area for which you want to have user exits. Valid application areas include:

**GBLR:** Validation/substitution: Exits for rules (user exit types 1 or 3)

**GBLS:** Validation/substitution: Exits for substitutions (user exit types 1, 2, or 3 for substitutions)

For more information about user exits, see User Exits in Validations/Substitutions/Rules [Seite 1053]
Setting the Message Class

Before you begin using validations, the system prompts you to enter a message class for the validations when you first create a validation.

This message class must belong to the customer base. Z should be entered as the first character.

If you want to change the assignment of the message class to a Boolean class, you can do so by choosing Environment → Change message class on the Create/Change Validation: Initial Screens.

Any changes you make to the message class are valid in all clients.
Using the Rule Manager Reports

The following Rule Manager reports are delivered with the system. You can only access these reports using the Reporting function.

**RGUGBR00**

If you suspect that information about the usage of validations/substitutions/sets/rules is not current or consistent, you can use this report to regenerate this information. When you regenerate validation/substitution usage, you receive a list of all current definitions for the validations/substitutions. In Release 2.1A, this code is client-independent. Therefore, report RGUGBR00 must be run in client 000 and then in all other clients.

**RGUGBR10**

This report converts table T890 rules to generated rules (defined using the Customizing function).

If you still use rules stored in table T890, it is highly recommended that you use report RGUGBR10 to convert table T890 rules to generated rules.

**RGUGBR15**

This report checks whether interpreted rules (defined in table T890) or generated rules (defined using the Customizing function) are used in the system. You can also use this report to change the method used for defining rules; however, you cannot use this report to convert the rules. If you have made changes in the system after running report RGUGBR10 (to convert T890 rules to generated rules), table T890 is no longer accurate.

**RGUGBR18**

This report converts Release 2.2 programs so that they can be used in Release 3.0. In Release 3.0, the code is generated for each application and client. In Release 2.2, the code is only generated for each client.

**RGUGBR19**

This report checks the syntax in all validations, substitutions, and rules.

**RGUGBR28**

This report changes the assignment of message classes to Boolean classes.

The changes made to the tables and generated code are valid in all clients.

**RGUGBR33**

This report is used to analyze and test validations and substitutions. You can use the report to:

- Activate a validation/substitution.
- Find out in which validation(s) a specific user-defined message is used.
- Find out which substitution was used to replace a specific dimension value.

For more information, see [Using the Analysis Tool](Seite 1171).
Procedure

Choose System → Services → Reporting.

The ABAP: Execute Program screen appears.

In the Program field, enter the name of the report you want to execute and choose Program → Execute.

A selection screen appears.

Enter data as required.

The data you enter determines the data that is used during the report processing and execution.

Choose Program → Execute.

The report is executed based on the selection data you entered.
Transporting Validations/Substitutions/Rules

You can use the <Validation/Substitution/Rule> → Transport function to transport a validation, substitution, or rule to another system. You can use this function for:

- **Validations**, on the Display or Change Validation: Initial Screen
- **Substitutions**, on the Display or Change Substitution: Initial Screen
- **Rules**, on the Display or Change Rule: Initial Screen

### Procedure

Choose:

- **Validation** → Transport for validations.
- **Substitution** → Transport for substitutions.
- **Rule** → Transport for rules.

A dialog box appears, prompting you for a correction number for the transport.

Enter a correction number for the transport.

You can either search for an existing correction number by choosing *Find* or create a new correction number by choosing *Create*.

Choose *Continue*.

The Transport: <Validations/Substitutions/Rules> screen appears.

Enter the name of the validation, substitution, or rule that you want to transport.

Set the appropriate indicators, depending on the information that you want to transport.

For *validations*, you can transport logical rules, sets, validation messages, the application area, and Boolean classes.

For *substitutions* and *rules*, you can transport logical rules, sets, and Boolean classes.

You can use the following additional processing functions on this screen.

### Additional Processing Functions – Transport: <Validations/Substitutions/Rules> Screen

<table>
<thead>
<tr>
<th>Choose</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transport → Include in request</td>
<td>Transport the validation, substitution, or rule and include it in the correction request.</td>
</tr>
<tr>
<td>Transport → Delete from request</td>
<td>Transport the validation, substitution, or rule and delete it from the correction request.</td>
</tr>
<tr>
<td>Edit → Choose all</td>
<td>Select all information for a validation, substitution, or rule.</td>
</tr>
<tr>
<td>Edit → Cancel selection</td>
<td>Deselect all information selected for a validation, substitution, or rule.</td>
</tr>
<tr>
<td>Environment → Create request</td>
<td>Create a correction request for the transport.</td>
</tr>
</tbody>
</table>
Choose *Transport → Include in request*. If you did not enter a correction number in step two, a dialog box appears, prompting you for a correction number.

Enter a correction number and choose *Continue*.

The validation, substitution, or rule is transported in the next transport of corrections.

When you transport ledgers, you can also transport the validations and substitutions used by the ledgers.
Displaying a Directory of Validations/Substitutions/Rules

You can use the Environment → Directory function to produce a directory listing of all or selected validations, substitutions, and rules. You can use this function for:

- **Validations**, on the Display or Change Validation: Initial Screen
- **Substitutions**, on the Display or Change Substitution: Initial Screen
- **Rules**, on the Display or Change Rule: Initial Screen

**Procedure**

Choose Environment → Directory.

The <Validation/Substitution/Rule> Directory screen appears.

Enter data as required.

The data you enter determines the data that is selected for display.

You want to display the fields and exits used for a group of validations. You:

- a) Enter the range of validations.
- b) Select Display used fields and Display used exits.

Choose Program → Execute.

A detailed directory of validations, substitutions, or rules appears, depending on the criteria you entered on the <Validation/Substitution/Rule> Directory screen.
Tracing a Validation/Substitution/Rule

Using the Extras → Switch on trace function, you activate a tracing function that allows you to test a validation/substitution/rule during the posting process. While posting a document, the system calls the validation/substitution/rule and displays the rule contents, as well as how the data is used for validation or substitution. This function allows you to diagnose possible errors in the validation/substitution/rule definition.

You can only trace one validation at a time, but one substitution and one rule can also be active simultaneously; this is also true when you are tracing a substitution or rule. The tracing function is only activated for the user who has turned on the trace function.

You can use the trace function for one validation/substitution/rule, for all validations/substitutions/rules or not for any validations/substitutions/rules.

Procedure

Display the validation/substitution/rule that you want to trace.

Choose Extras → Switch on trace.

If you want to use the trace function for all validations/substitutions/rules, choose Extras → Switch on total trace.

In a separate session, call the posting transaction that you want to trace.

When the validation/substitution/rule is called, the system displays the result of the validation/substitution/rule that is used within the posting transaction.

To turn off the tracing function, choose Extras → Switch off total trace.

If you use the single trace switch off, this switches off the trace function automatically for all the other validations/substitutions/rules.
Simulating a Validation/Substitution/Rule

Display the validation/substitution/rule that you want to check.
Position your cursor on the validation/substitution step or rule that you want to check.
Choose <Validation/Substitution/Rule> → Simulate.

The Data Entry for Validation/Substitution/Rule screen appears, listing the fields defined in the validation/substitution/rule that you want to simulate.

You cannot use the Simulate function for matrix validations and substitutions.

Enter the values that you want to check against the validation/substitution/rule and choose Execute.

The Results of Validation/Substitution/Rule: <Validation/Substitution/Rule> screen appears, listing the results of the check of the entered data against the validation/substitution/rule.

To exit the screen, choose Data → Exit.
Using the Analysis Tool

You can use the analysis tool to:

- Activate a validation/substitution for a specific application component.
- Find out in which validation(s) a specific user-defined message is used.
- Find out which substitution was used to replace a specific dimension value.

You access the analysis tool on the Change Validation/Change Substitution: <Validation/Substitution Name> screen by choosing Environment → Val./sub. analysis.

Activating a Validation/Substitution


The Activation of Validation/Substitution screen appears.

Select the application component for which you want to access the activation screen.

Choose whether you want to activate a validation or substitution.

The system calls up the relevant activation transaction of the application component you selected.

If you selected the Special purpose ledger or Asset accounting application components, a dialog box appears in which you are required to enter further information. In the Selection: Special Purpose Ledger dialog box, you specify whether you want to access the activation screen for local or global ledgers. In the Selection: Asset Accounting dialog box, you specify whether you want to access the activation screen for master data or transaction data.

Activate your validation or substitution if required or check the activation status of existing validations or substitutions.

Displaying Message Usage

You use the Message usage option to determine in which validation(s) a specific user-defined message is being used.

When you post a document in Financial Accounting, the system displays the following message:

**User JONES cannot post to account 100000**

(Message ID = Z1 003)

This is a user-defined message (Z is the naming convention for user-defined system messages), which suggests that a validation produced this message.

Using the Message usage option, you can enter the message class (Z1) and number (003) to determine in which validation this message is used. The system displays a list of validations that could have produced the above message.
Using the Analysis Tool

To check in which validation a system message is used:


The Enter Message Number dialog box appears.

Enter the appropriate message class and message number and choose Continue.

The Valid./Subst.: Use of Messages in Validations screen appears. The system displays a list of the validations in which the user-defined message you specified is used.

You can display the validation definition by choosing Edit → Display validation.

Displaying Substituted Fields

You use the Substituted fields option to find out which substitution was used to replace a specific dimension value.

You post a document in Special Purpose Ledger. When you display the posting document, the cost center field does not contain the value that you originally entered during posting.

Using the Substituted fields option, you can enter the name of the cost center field to establish which substitution was used to replace the value you entered. The system displays a list of substitutions that could have been used to substitute the original cost center value.

To find out which substitution was used to replace a specific dimension value:


The Enter Table and Field dialog box appears.

Enter the table name and field name for which you want to display a list of possible substitutions and choose Continue.

The Valid./Subst.: List for Substituted Fields screen appears, listing the names of the substitutions defined for the table and field name you entered.

You can display the substitution definition by choosing Edit → Display substitution.

Regenerating ABAP Programs

Validations, substitutions and rules use the following automatically generated ABAP programs during runtime (e.g. during a posting):

GBAAAAAA
GBS<cc>SET
GBT<cc><aa>0

Where cc stands for a two-digit client code and aa for the application area (e.g. "FI" for Financial Accounting. You can decode the two-digit client using a test run of the function module G_CLIENT_DECODE.

If you encounter problems using this program (syntax error or runtime error such as PERFORM_NOT_FOUND), trigger the generation of this program. To do this, choose from the
menu Edit → Regenerate ABAPs. For the last two programs mentioned, do this in the respective client.
Using the Ledger Statistics Tool

Procedure

Choose Accounting → Financial accounting → Spec. Purpose Ledger, then Tools → Ledger statistics.

The Number of Data Records in the FI-SL Ledgers screen appears. The system lists the data dimensions that can be used as criteria for selecting ledger statistics. These dimensions are stored in table GLU1.

Enter data as required.

The data you enter determines the data that is used to display data record statistics for a ledger(s).

- It is useful to use the Ledger statistics tool before you archive data records to see how many records have already been posted to your ledger(s). Based on the ledger statistics results, you can decide which data records you want to archive.

For information about using the archiving program, see Archiving [Seite 312] and the Application Data Archiving and Reorganization documentation in the R/3 Library.

Choose Program → Execute.

The system lists statistics for each ledger, according to the criteria you entered on the Number of Data Records in the FI-SL Ledgers screen. For each ledger, the database tables to which records were posted are listed, as well as the number of records that have been posted to each ledger and to each database table.
Using the Diagnosis Tool

Use
The diagnosis tool allows you to check postings and look for errors.

Procedure

Choose Accounting → Financial Accounting → Special Purpose Ledger → Tools → Diagnosis.

The Diagnosis: Initial Screen appears.

Make the following entries:

- Under Origin of original document, set the indicator for the application from which the document was or will be posted.
- If the document was or is to be posted directly in FI-SL, set the indicator Posting status - Direct posting.
- If the document was posted from an external system (or indirectly) to FI-SL, set the Posting status - Subsequent posting.

If a document was posted using the RGUREC10 program (transferring data from Financial Accounting (FI)), the document was posted indirectly to the FI-SL System.

On the Diagnosis: Initial Screen, you can use the following additional functions:

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto → Posting test</td>
<td>Display all ledgers that would be posted to for a specific combination of activity, company code, posting date, fiscal year, and period.</td>
</tr>
<tr>
<td>Goto → Direct posting stat.</td>
<td>Display all ledgers that are being posted to for a specific combination of document, company code, and fiscal year.</td>
</tr>
<tr>
<td>Goto → Troubleshooting</td>
<td>Check why a specific combination of document, company code, fiscal year, and ledger is not posting to a ledger.</td>
</tr>
</tbody>
</table>

Checking Postings

To check the posting settings for a specific combination of activity, company code, posting date, fiscal year, and period from the Diagnosis: Initial Screen proceed as follows:

Choose Goto → Posting test.

The Diagnosis: Posting Test <Application> screen appears.

Make the following entries:

If you set the FI, AM, SD, or MM indicator on the previous screen, enter the following data:
Using the Diagnosis Tool

- Activity code that was used for posting the document (for example, RFBU).
- Company code: Local company code for which you want to display posting settings.
- Posting date for which you want to display posting settings.
- Fiscal year for which you want to display posting settings.
- Posting period for which you want to display posting settings.
- Ledger information:
  
  If you want to test postings for all ledgers, select All posted ledgers. If you want to test postings for a specific ledger, select One ledger not postd and enter the ledger name in the second field. You should set this indicator if you are trying to find out why a ledger is not being posted to.

If you set the FI-SL indicator on the previous screen, enter the following data:

- Activity code that was used for posting the document (for example, RFBU).
- Version number for which you want to display posting settings.
- Posting date for which you want to display posting settings.
- MAKE AN ENTRY IN ONLY ONE OF THE FOLLOWING FIELDS:
  
  Company code: Local company code for which you want to display posting settings.
  
  Name of the company for which you want to display posting settings.

- Ledger information:
  
  If you want to test postings for all ledgers, select All posted ledgers. If you want to test postings for a specific ledger, select One ledger not postd and enter the ledger name in the second field. You should set this indicator if you are trying to find out why a ledger is not being posted to.

If you set the CO indicator on the previous screen, enter the following data:

- Activity code that was used for posting the document (for example, RFBU).
- Controlling area for which you want to display posting settings.
- Posting date for which you want to display posting settings.
- Fiscal year for which you want to display posting settings.
- Period for which you want to display posting settings.
- Plan version for which you want to display posting settings.
- Ledger information:
  
  If you want to test postings for all ledgers, select All posted ledgers. If you want to test postings for a specific ledger, select One ledger not postd and enter the ledger name in the second field. You should set this indicator if you are trying to find out why a ledger is not being posted to.

You can directly access the configuration settings while testing if a document would be posted to a ledger based on the data that you enter using the Posting test function. If the document would not be posted, the system displays an error.
message explaining the cause of the error. When you double-click the error message, you display the long text for the error message. From this screen, you can directly access and change the applicable configuration settings so that the document can be posted to the ledger.

This function is only available when you test the posting for a specific ledger that has not been posted to.

Choose **Diagnosis → Execute**.

The system displays the ledger(s) that the document will post to. You can use the following additional processing functions on this screen.

### Additional Processing Functions:

<table>
<thead>
<tr>
<th>Choose</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Diagnosis → Print</strong></td>
<td>Print the results of the analysis.</td>
</tr>
<tr>
<td><strong>Edit → Choose (or double-click)</strong></td>
<td>Select a ledger. The system displays information about the ledger definition, such as ledger master data, activities, and posting information.</td>
</tr>
</tbody>
</table>

### Checking the Settings for Direct Postings

To check the posting settings for a specific combination of document, company code, and fiscal year from the **Diagnosis: Initial Screen** proceed as follows:

Choose **Goto → Direct posting stat**.

The **Diagnosis: Direct Posting Statistics <Application>** screen appears.

Make the following entries:

If you set the FI, AM, or MM indicator on the previous screen, enter the following data:
- Document number for which you want to display posting settings.
- (Local) company code for which you want to display posting settings.
- Fiscal year for which you want to display posting settings.

If you set the FI-SL indicator on the previous screen, enter the following data:
- Document number for which you want to display posting settings.
- Fiscal year for which you want to display posting settings.
- MAKE AN ENTRY IN ONLY ONE OF THE FOLLOWING FIELDS:
  - (Local) company code for which you want to display posting settings.
  - Name of the (global) company for which you want to display posting settings.

If you set the CO indicator on the previous screen, enter the following data:
- Document number for which you want to display posting settings.
- Controlling area for which you want to display posting settings.

Choose **Diagnosis → Execute**.
Using the Diagnosis Tool

The system displays the posting statistics for the ledger(s) to which the document has been posted. On this screen, you can use the additional processing functions in the Diagnosis: Posting Test <Application> table in the above “Testing Postings” section.

Troubleshooting Postings

To check the posting settings for a specific combination of document, company code, fiscal year, and ledger from the Diagnosis: Initial Screen proceed as follows:

Choose Goto → Troubleshooting.

The Diagnosis: Troubleshooting <Application> screen appears.

Make the following entries:

If you set the Fi, AM, or MM indicator on the previous screen, enter the following data:

– Number of the document for which you want to display statistical information.
– (Local) company code for which you want to display posting settings.
– Fiscal year for which you want to display posting settings.
– Name of the ledger for which you want to display posting settings.

If you set the Fi-SL indicator on the previous screen, enter the following data:

– Number of the document for which you want to display statistical information.
– Fiscal year for which you want to display posting settings.
– Name of the ledger for which you want to display posting settings.
– MAKE AN ENTRY IN ONLY ONE OF THE FOLLOWING FIELDS:
  (Local) company code for which you want to display posting settings.
  Name of the company for which you want to display posting settings.

If you set the CO indicator on the previous screen, enter the following data:

– Number of the document for which you want to display statistical information.
– Controlling area for which you want to display posting settings.
– Name of the ledger for which you want to display posting settings.

Choose Diagnosis → Execute.

The system displays the ledger(s) to which the document has been posted. On this screen, you can use the additional processing functions in the Diagnosis: Posting Test <Application> table in the above “Testing Postings” section.
Using the Control Report Tool

Procedure

Choose Accounting → Financial accounting → Spec. Purpose Ledger, then Tools → Control report.

The Contents of FI-SL Direct Posting Tables screen appears.

Enter the following data:

- Set the List all settings indicator if you want to display the complete contents of all FI-SL direct posting tables. If you set this indicator, skip step three.
- The level of detail for which you want to display table information. Values include:
  - Display only master data for selected objects
  - Display master data and ledger-company code assignments for selected objects
  - Display master data, ledger-company code assignments and activity assignments for selected objects
  - Display all table information for selected objects

Enter values for displaying contents of FI-SL direct posting tables.

You can only enter one of the following field combinations:

- From ledger and To ledger
  
  From ledger Enter the name of the first ledger in the range of ledgers for which you want to display table contents.
  
  To ledger Enter the name of the last ledger in the range of ledgers for which you want to display table contents.

- From global company and To global company
  
  From global company Enter the name of the first global company code in the range of company codes for which you want to display table contents.
  
  To global company Enter the name of the last global company code in the range of company codes for which you want to display table contents.

- From company code and To company code
  
  From company code Enter the name of the first local company code in the range of company codes for which you want to display table contents.
  
  To company code Enter the name of the last local company code in the range of company codes for which you want to display table contents.

To display the contents of the FI-SL direct posting tables, choose Program → Execute.