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Icons 
 

Icon Meaning 

 
Caution 

 
Example 

 
Note 

 
Recommendation 

 
Syntax 

 

 

Typographic Conventions 
 

Type Style Description 

Example text Words or characters that appear on the screen. These include field 
names, screen titles, pushbuttons as well as menu names, paths and 
options. 

Cross-references to other documentation 
Example text Emphasized words or phrases in body text, titles of graphics and tables

EXAMPLE TEXT Names of elements in the system. These include report names, 
program names, transaction codes, table names, and individual key 
words of a programming language, when surrounded by body text, for 
example, SELECT and INCLUDE. 

Example text Screen output. This includes file and directory names and their paths, 
messages, names of variables and parameters, source code as well as 
names of installation, upgrade and database tools. 

Example text Exact user entry. These are words or characters that you enter in the 
system exactly as they appear in the documentation. 

<Example text> Variable user entry. Pointed brackets indicate that you replace these 
words and characters with appropriate entries. 

EXAMPLE TEXT Keys on the keyboard, for example, function keys (such as F2) or the 
ENTER key 
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  Cross-Application Components (CA) 

Cross-Application Components (CA) 
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Application Link Enabling (ALE) - Distribution of Material Master [Page 8] 
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Application Link Enabling (ALE) - Distribution of Material Master 

Application Link Enabling (ALE) - Distribution of 
Material Master 
Purpose 
This process shows you how to centrally create and maintain material master records and then 
distribute these data to the local system. Depending on the authorizations, the local system can 
then enhance the existing master record (for example, by creating new views). 

Special Note 
The steps for displaying logical messages are specific to ALE (for example, the movement of  
intermediate documents – IDocs – between systems). These ALE steps are optional and can be 
used to display ALE in more detail. 

Process Flow 
You can find the data for this process under  [Page 9]. 

1. Creating a Material Master Record [Page 10] 

2. Sending a Material Master to a Local System [Page 13] 

3. Displaying the Outgoing Logical Messages (IDocs) in the Central System [Page 14] 

4. Displaying the Material in the Local (Sales) System [Page 15] 

5. Displaying the Incoming Logical Messages (IDocs) in the Sales System (Optional) [Page 16] 
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Data Used During this Process 
Field Data 

Material Leave blank; The system will assign a material number. If, however, you 
change or display a material, you can use the number assigned in 
Creating a Material Master Record [Page 10]. 

Industry sector Mechanical engineering 

Plant 2300 

Sales organization 2300 

Distribution channel 10 

Language EN 

Material text AS-100 T-Shirt 

Base unit PC 

Material group 02004 

Division 09 

Net weight 0.2 

Gross weight 0.2 

Unit of weight KG 

Tax classification 0 

Availability check 01 

TranspGr 0001 

Loading group 0001 

Long text AS-100 T-Shirt 

Standard price 50 

Message type MATMAS 

Logical system SALES 
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Creating a Material Master Record 

Creating a Material Master Record 
Prerequisites 
Before distributing the material master record, you need to create the record with the necessary 
views. The following steps show how you create a material master record with the views for sales 
and distribution and accounting. 

Procedure 
1. Log on to the central system (client 800). 

2. Call up the transaction as follows: 

Menu Path Logistics → Materials Management → Material Master → Material → 
Create (Special) → Finished Product 

Transaction Code MMF1 

3. Enter the following data: 

Field Data 

Material Leave blank; the system assigns a material number 

Industry sector Mechanical engineering 

4. Choose . 

5. In the dialog box, select the following fields: 

• Basic Data 1 

• Sales: Sales Org. Data 1 

• Sales: General/Plant Data 

• Sales Text 

• Accounting 1 

6. Choose . 

7. Enter the following data: 

Field Data 

Plant 2300 

Sales org. 2300 

Distribution channel 10 

8. Choose . 

9. Enter the following data: 

Field Data 

Material short text AS-100 T-Shirt 
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Base unit PC 

Material group 02004 

Division 09 

Gross weight 0.2 

Net weight 0.2 

Unit of weight KG 

10. Choose . 

11. Check that the following data have been entered: 

Field Data 

Base unit PC 

Division 09 

Material group 02004 

12. On the same screen, enter the following data: 

Field Data 

Tax classification 0 

13. Choose . 

14. Enter the following data: 

Field Data 

Availability check 01 

TranspGr 0001 

Loading group 0001 

15. Choose . 

16. On the Sales text tab page, enter the following data: 

Field Data 

Language EN 

Long text AS-100 T-Shirt 

17. Choose . 

18. Confirm your entries by choosing . 

19. On the Accounting 1 tab page, enter the following data: 

Field Data 

Standard price 50 

20. Choose . 

Write down the material number assigned by the system. 
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Creating a Material Master Record 

21. Choose . 
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Sending a Material Master to a Local System 
Use 
After creating or maintaining a material record (updated), it can be distributed to the local system 
(for example, the sales system). Make sure that you are logged on to the central system. 

Procedure 
1. Make sure that you are logged on to the central system. (Client 800). 

2. Call up the transaction as follows: 

Menu Path Tools →  ALE → Master Data Distribution → Cross-Application → Material 
→ Send 

Transaction Code BD10 

3. Enter the following data: 

Field Data 

Material Number of material created in Creating a Material Master 
Record 

Message type (R/3 Standard) MATMAS 

Logical system SALES 

4. Choose . 

The system distributes the material created centrally to the sales system and confirms 
that this event has happened.  

To confirm the message in the dialog box, choose . 

5. Choose . 
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Displaying the Outgoing Logical Messages (IDocs) in the Central System 

Displaying the Outgoing Logical Messages (IDocs) in 
the Central System 
1. To view the status of the outgoing material master data, log on to the central system (client 

800). 

2. Call up the transaction as follows: 

Menu Path Tools → ALE → ALE Administration → Monitoring → Status Monitor for 
ALE Messages 

Transaction Code BD87 

The system displays the selection screen for IDocs. 

3. In the Logical message type field, enter MATMAS, then choose . 

The system displays a list of MATMAS logical messages. Note the direction of "1", which 
indicates that this is an outgoing message. If this process has already been run today, 
the system may display more than one logical message. (This report is time and date 
dependent).  

4. You can also display IDoc details such as status, control, and data records by double-clicking 
on the IDoc number. 

5. Choose . 
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  Displaying the Material in the Local (Sales) System 

Displaying the Material in the Local (Sales) System 
Use 
You now display the new material in the local sales system. 

Procedure 
1. Log on to the sales system (client 810). 

2. Call up the transaction as follows: 

Menu Path Logistics → Materials Management → Material Master → Material → 
Display → Display Current 

Transaction Code MM03 

3. Enter the number of your material. 

4. Choose Select view(s). 

5. In the dialog box, select the following views: 

• Basic Data 1 

• Sales: Sales Org. Data 1 

• Sales: General/Plant Data 

• Sales Text 

• Accounting 1 

6. Choose . 

7. Enter the following data: 

Field Data 

Plant 2300 

Sales org. 2300 

Distribution channel 10 

8. Choose . 

The material is now available for further processing. 

9. Choose . 
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Displaying the Incoming Logical Messages (IDocs) in the Sales System (Optional) 

Displaying the Incoming Logical Messages (IDocs) in 
the Sales System (Optional) 
Use 
Once you have received the logical message MATMAS, the sales system processes the IDoc 
and generates a material master record. 

Procedure 
1. To view the status of the incoming material master data, log on to the sales system (client 

810). 

2. Call up the transaction as follows: 

Menu Path Tools → ALE → ALE Administration → Monitoring → Status Monitor for 
ALE Messages 

Transaction Code BD87 

The system displays the selection screen for IDocs. 

3. In the Logical message type field, enter MATMAS, then choose . 

The system displays a list of MATMAS logical messages. Note the direction of "2", which 
indicates that this is an incoming message. If this process has already been run today, 
the system may display more than one logical message. (This report is time and date 
dependent).  

You can also display IDoc details such as status, control, and data records by double-
clicking on the IDoc number. 

4. Choose . 
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  Goods Receipt in a Decentralized Warehouse 

Goods Receipt in a Decentralized Warehouse 
Purpose 
In the Dallas plant of IDES Corp., the warehouse stock is administered in a decentralized 
warehouse management system. As the Dallas plant is a delivering plant with a closed 
distribution center, all stock receipts are handled as goods receipts for purchase orders with an 
external vendor.  

In this example, you create a purchase order for trading goods and process the goods receipt 
from the creation of the inbound delivery, through the putaway of the materials in the warehouse 
management system and the goods receipt in inventory management. The warehouse 
management system is located in a different logical system. This is because the distribution 
center should work independently of the processes in the central system. While processes in 
Accounting, Purchasing, Inventory Management or Sales and Distribution are executed in the 
central system (Enterprise Resource Planning System, ERP), the concrete, physical processing 
of the stock placement occurs in the warehouse management system. The Warehouse 
Management System, WMS, is located in its own, decentralized system, which communicates 
with the central system via ALE. The Dallas warehouse complex is set up as just such a 
decentralized warehouse. 

In this example you will work in both the central system and the decentralized system, and switch 
between the ERP and the WMS. 

You can find more information about this process under  [Page 18]. 

Process Flow 
You can find the data for this process under  [Page 20]. 

1. Creating a Purchase Order [Page 21] 

2. Creating an Inbound Delivery in the Central System [Page 23] 

3. Processing an Inbound Delivery in the Dezentralized Warehouse [Page 24] 

4. Checking an Inbound Delivery in the Central System [Page 26] 
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Additional Information About this Demo 

Additional Information About this Demo 
The following additional information is aimed at IDES users with prior knowledge in the areas of 
Warehouse Management (WM) and ALE. 

In the Dallas plant, storage location 0095 is managed as a decentralized warehouse. This is 
determined by the assignment of the plant – storage location combination for warehouse number 
005, which is defined in Customizing. To see the Customizing of the decentralized warehouse 
management, see the IMG, under Logistics Execution → Decentralized WMS Integration. This is 
where the settings are made for the central and decentralized processing.  

In this example, the warehouse is a distribution center for trading goods. In the Dallas plant, PCs 
and accessories are procured via purchase orders and put into stock in the WM-administrated 
warehouse complex. To ensure permanent availability and the greatest possible independence of 
the warehouse processes, this warehouse complex should be administered in a separate 
system. Processes for Inventory Management, Financial Accounting and Controlling are 
executed in the central R/3 System. Physical warehouse processes such as creating transfer 
orders for putaway, the picking of outbound deliveries or the planning and monitoring of stock 
movements are handled separately. The warehouse processes are also executed in an SAP R/3 
System in warehouse management. The two systems are represented by different logical 
systems.  

In order to separate the functions, the master data and transaction data must also be split up. 
Information concerning the valuation of materials is not relevant to the decentralized Warehouse 
Management System (WMS). The basic data of a material must be identical in both systems. The 
warehouse-management specific material data, however, are only relevant to the WMS. The 
material mater data are therefore distributed between the central ERP and the decentralized 
WMS via message type MATMAS_WMS to reduce the number of fields not relevant to the WMS. 
Transaction data, such as the inbound delivery of a vendor, must exist in both systems. An 
inbound delivery is generated for the purchase order in the ERP. This inbound delivery contains 
information for the putaway, and is therefore distributed to the WMS. A transfer order is 
generated for the putaway in Warehouse Management.  

The PCs are placed in bulk storage, the monitors are put in a high rack storage area. For this 
reason, material M-01 has a stock placement and stock removal type indicator in the material 
master, which controls the stock placement in warehouse type 004 (bulk storage). Once the 
transfer order has been created, the physical transfer is carried out, and then confirmed to the 
warehouse management system through the confirmation of the transfer order. Only when the 
physical stock placement in the relevant storage bins has been completed, is the goods receipt 
posted for the inbound delivery. The confirmation of the goods receipt is distributed from the 
WMS to the ERP, where it is posted in inventory management. 

Communication between the logical systems is defined through the WMS distribution model. You 
can find the distribution model in Customizing, under Logistics Execution → Decentralized WMS 
Integration → Central Processing → Distribution → Generate Distribution Model. You can also 
find this distribution model in Customizing for ALE.  

The following steps describe how you set up a decentralized warehouse. 

1. Create a warehouse number in the central system (do not make a copy), then activate it for 
decentralized processing. This warehouse number is not used in the ERP. It is required only 
to assign a delivery to the decentralized processing. 

2. Create the warehouse number in the decentralized system and set up the processes for 
warehouse management.  
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3. Define the interface for warehouse management to inventory management. 

4. Define the necessary message categories (for example, the reduced messages for the 
material master). 

5. Generate the distribution model in the central system. 

6. Generate the partner agreements in the central system. 

7. Distribute the distribution model to the decentralized system. 

8. Generate the partner agreements in the central system. 

9. Define the number range for the warehouse document in the decentralized system and 
assign it. 

10. Activate the link to the ERP system. 

11. Define the conversion of the delivery types between ERP and WMS. 

12. Define the requirement types for the WMS. 

13. Define the confirmation control for the creation of inbound deliveries. 
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Data Used During This Example 

Data Used During This Example 
Field Data Description 

Vendor 3740 Materials vendor 

Order type Standard purchase order Standard purchase order 

Purch. organization IDES USA or 3000 Purchasing organization  
North America 

Plant 3500 Dallas plant 

Storage location 0095 Decentralized WM-administered warehouse 
location Dallas 

Warehouse number 005 Decentralized warehouse in Dallas 

Material M-01 Sunny Sunny 01 

Material M-08 Flatscreen MS 

Material M-10 Flatscreen MS 

 

20  April 2001 



 SAP AG Cross-Application Components (CA) 

  Creating a Purchase Order 

Creating a Purchase Order 
Use 
At the start of the process you create a purchase order in the central system via the materials. 

Procedure 
1. Log on to the central system (client 800). 

2. Call up the transaction as follows: 

Menu Path Logistics → Materials Management → Purchasing → Purchase Order → 
Create → Vendor/supplying plant known 

Transaction Code ME21N 

3. Enter the following data: 

Field Data 

Vendor 3740 

Shopping basket/Order type Standard purchase order 

Document date Today‘s date 

4. Choose . 

If a dialog box appears, choose New purchase order. 

If any warning messages appear, choose . 

5. Choose the Org. data tab page. 

6. Use the F4 input help to enter the following data: 

Field Data 

Purch. organization IDES USA or 3000 

Purchasing group Corporate Purchasing or 100 

Company code IDES US INC or 3000 

7. Choose  Item overview. 

8. Enter the following data: 

Field Data 

Plant 3500 

Storage location 0095 

Material M-01 

PO quantity 50 

Material M-08 

PO quantity 48 
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Creating a Purchase Order 

Material M-10 

PO quantity 24 

9. Choose . 

10. Note the purchase order number. 

11. Choose . 
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  Creating an Inbound Delivery in a Central System 

Creating an Inbound Delivery in a Central System 
1. Call up the transaction as follows: 

Menu Path Logistics → Logistics Execution → Inbound Process → Goods Receipt for 
Inbound Delivery → Inbound Delivery → Create → Single Documents 

Transaction Code VL31N 

2. Enter the following data: 

Field Data 

Vendor 3740 

Purchase order Your purchase order 

3. Choose . 

Check the different statuses of the inbound delivery. 

4. Select an item of the inbound delivery, then choose . 

You can see the putaway status of the item. 

The warehouse number assigned to this inbound delivery is the decentralized warehouse 
in Dallas. As this is a decentralized warehouse, the Putaway status in the central system 
is Not for putaway. 

5. Choose . 

You can see the distribution status of the decentralized warehouse processing. As the 
warehouse number for Dallas is decentralized, this inbound delivery is relevant for 
distribution and therefore has the status Relevant. 

6. Choose . 

When you save your entries, the inbound delivery is sent via ALE to the decentralized 
system. This changes the status of the inbound delivery in the central system. Check the 
status of the inbound delivery. 

7. Note the shipping notification number. 

8. Choose Inbound delivery → Display, then choose . 

9. To check the distribution status of the decentralized warehouse processing, choose . 

The inbound delivery has now been distributed to the decentralized system and therefore 
has the status Distributed. 

10. Choose . 
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Processing an Inbound Delivery in a Decentralized Warehouse 

Processing an Inbound Delivery in a Decentralized 
Warehouse 
Use 
You should now switch to the decentralized WMS (client 812) to put the incoming materials into 
stock. You create a transport request for the incoming delivery, and quit this once you have 
completed the putaway into the relevant storage bin. 

Procedure 
1. Sign in to the decentralized WMS (client 812) with the User WMS-User and the Password 

WELCOME. 

2. Call up the transaction as follows: 

Menu Path Logistics → Logistics Execution → Inbound Process → Goods Receipt for 
Inbound Delivery → Inbound Delivery → Lists → Inbound Delivery Monitor 

Transaction Code VL06i 

3. Choose For putaway. 

4. Enter the following data: 

Field Data 

Warehouse number 005 

Vendor 3740 

5. Choose . 

6. Double-click on your inbound delivery. 

7. Select an item, then choose  to display the status of the inbound delivery. 

As the inbound delivery is only relevant for the stock placement in the decentralized 
system, it has the putaway status For putaway and a status for Warehouse Management 
Activities WM-TA trnsf order reqd. 

8. Choose  twice. 

9. Choose your inbound delivery and choose TO in foregr. 

10. Choose Foreground. 

11. Choose . 

12. To put away the first item, choose Palletization. 

13. To display the destination storage bins for the individual pallets, choose . If a warning 
message appears for the individual items, choose . 

14. To create the transfer order item for this material, choose Gen + next material. 

15. To create the transfer order item for the next material, choose Gen + next material. 

16. To create the remaining TO items, choose Transfer order → Post. 
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17. Choose  twice. 

18. Choose For confirmatn. 

19. Enter the following data: 

Field Data 

Warehouse number 005 

Vendor 3740 

20. Choose . 

21. Select both of your inbound delivery numbers and choose . 

22. In the dialog box, choose . 

23. Choose  twice. 

24. Choose For gds receipt. 

25. Enter the following data: 

Field Data 

Warehouse number 005 

Vendor 3740 

26. Choose . 

27. Select your inbound delivery and choose Post goods receipt. 

28. In the dialog box, choose . 

29. Choose . 
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Checking the Inbound Delivery in a Central System 

Checking the Inbound Delivery in a Central System 
Use 
Once the completed putaway has been confirmed, the inbound delivery is distributed to the 
central system (client 800) and posted there with the relevant goods receipt quantity. 

Procedure 
1. Log on to the central system (client 800). 

2. Call up the transaction as follows: 

Menu Path Logistics → Logistics Execution → Inbound Process → Goods Receipt for 
Inbound Delivery → Inbound Delivery → Display → Single Document 

Transaction Code VL33N 

3. Enter your inbound delivery number, then choose . 

Check the different statuses of the inbound delivery. 

4. Select an item of the inbound delivery, then choose . 

You can see the putaway status of the item. The putaway process is now complete, 
which is why the goods movements status now shows as Completed. 

5. Choose . 

You can see the distribution status of the decentralized warehouse processing. The 
status for the decentralized warehouse is now Confirmed. 

6. Choose . 
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Goods Issue in a Decentralized Warehouse 
Purpose 
In the Dallas plant of IDES Corp., the warehouse stock is administered in a decentralized 
warehouse management system. As the Dallas plant is a delivering plant with a closed 
distribution center, all stock receipts are handled as goods receipts for purchase orders with an 
external vendor. 

In this example, you create a purchase order for trading goods and process the goods receipt 
from the creation of the inbound delivery, through the putaway of the materials in the warehouse 
management system and the goods receipt in inventory management. The warehouse 
management system is located in a different logical system. This is because the distribution 
center should work independently of the processes in the central system. While processes in 
Accounting, Purchasing, Inventory Management or Sales and Distribution are executed in the 
central system (Enterprise Resource Planning System, ERP), the concrete, physical processing 
of the stock placement occurs in the warehouse management system. The Warehouse 
Management System, WMS, is located in its own, decentralized system, which communicates 
with the central system via ALE. The Dallas warehouse complex is set up as just such a 
decentralized warehouse. 

In this example you will work in both the central system and the decentralized system, and switch 
between the ERP and the WMS. 

You can find more information about this process under  [Page 28]. 

Process Flow 
You can find the data for this process under  [Page 30]. 

1. Creating a Sales Order [Page 31] 

2. Creating an Outbound Delivery in the Central System [Page 33] 

3. Displaying an Outbound Delivery in a Decentralized Warehouse [Page 34] 

4. Creating and Confirming a Transport Order for the Outbound Delivery [Page 35] 

5. Posting a Goods Issue [Page 37] 

6. Checking an Outbound Delivery in the Central System [Page 38] 

7. Billing a Sales Order [Page 39] 
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Additional Process Information 
The following additional information is aimed at IDES users with prior knowledge in the areas of 
Warehouse Management (WM) and ALE. 

In the Dallas plant, storage location 0095 is managed as a decentralized warehouse. This is 
determined by the assignment of the plant – storage location combination for warehouse number 
005, which is defined in Customizing. To see the Customizing of the decentralized warehouse 
management, see the IMG, under Logistics Execution → Decentralized WMS Integration. This is 
where the settings are made for the central and decentralized processing.  

In this example, the warehouse is a distribution center for trading goods. In the Dallas plant, PCs 
and accessories are delivered via purchase orders and picked in the WM-administrated 
warehouse complex. To ensure permanent availability and the greatest possible independence of 
the warehouse processes, this warehouse complex should be administered in a separate 
system. Processes for Inventory Management, Financial Accounting and Controlling are 
executed in the central R/3 System. Physical warehouse processes such as creating transfer 
orders for putaway, the picking of outbound deliveries or the planning and monitoring of stock 
movements are handled separately. The warehouse processes are also executed in an SAP R/3 
System in warehouse management. The two systems are represented by different logical 
systems.  

In order to separate the functions, the master data and transaction data must also be split up. 
Information about the valuation of materials is not relevant to the decentralized warehouse 
management system (WMS). The basic data of a material must be identical in both systems, but 
the warehouse-management specific material data, however, are relevant only to the WMS. The 
material mater data are therefore distributed between the central ERP and the decentralized 
WMS via message type MATMAS_WMS to reduce the number of fields not relevant to the WMS. 
Transaction data, such as the outbound delivery of a vendor, must exist in both systems. An 
outbound delivery is generated for the sales order in the ERP. This outbound delivery contains 
information for picking, and is therefore distributed to the WMS. A transfer order is generated for 
the picking in Warehouse Management.  

The PCs are placed in bulk storage, the monitors are put in a high rack storage area. For this 
reason, material M-01 has a stock placement and stock removal type indicator in the material 
master, which controls the picking in warehouse type 004 (bulk storage). Once the transfer order 
has been created, the physical transfer is carried out, and then confirmed to the warehouse 
management system through the confirmation of the transfer order. Only when the physical 
picking from the relevant storage bins has been completed, is the goods issue posted for the 
outbound delivery. The confirmation of the goods issue distributed from the WMS to the ERP, 
where it is posted in inventory management. 

Communication between the logical systems is defined through the WMS distribution model. You 
can find the distribution model in Customizing, under Logistics Execution → Decentralized WMS 
Integration → Central Processing → Distribution → Generate Distribution Model. You can also 
find this distribution model in Customizing for ALE.  

The following steps describe how you set up a decentralized warehouse. 

1. Create a warehouse number in the central system (do not make a copy), then activate it for 
decentralized processing. This warehouse number is not used in the ERP. It is required only 
to assign a delivery to the decentralized processing. 

2. Create the warehouse number in the decentralized system and set up the processes for 
warehouse management.  

28  April 2001 



 SAP AG Cross-Application Components (CA) 

  Additional Process Information 

3. Define the interface for warehouse management to inventory management. 

4. Define the necessary message categories (for example, the reduced messages for the 
material master). 

5. Generate the distribution model in the central system. 

6. Generate the partner agreements in the central system. 

7. Distribute the distribution model to the decentralized system. 

8. Generate the partner agreements in the central system. 

9. Define the number range for the warehouse document in the decentralized system and 
assign it. 

10. Activate the link to the ERP system. 

11. Define the conversion of the delivery types between ERP and WMS. 

12. Define the requirement types for the WMS. 

13. Define the confirmation control for the creation of inbound deliveries. 
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Data Used During This Process 
Field Data Description 

Customer 4130 Sold-to party 

Order type OR Standard order 

Sales organization 3000 Purchasing organization North America 

Plant 3500 Dallas plant 

Storage location 0095 Decentralized warehouse in Dallas 

Warehouse number 005 Decentralized warehouse in Dallas 

Material M-01 Sunny Sunny 01 

Material M-08 Flatscreen MS 

Material M-10 Flatscreen MS 
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Creating a Sales Order 
Use 
You first create a sales order using several materials. 

Procedure 
1. Log on to the central system (client 800). 

2. Call up the transaction as follows: 

Menu Path Logistics → Sales and Distribution → Sales → Order ### Create 

Transaction VA01 

3. Enter the following data: 

Field Data 

Order type OR (standard order) 

4. Choose . 

5. Enter the following data: 

Field Data 

Sold-to party 4130 

PO number K-WMS-01 

Purchase order date Today‘s date 

Material M-01 

Order quantity 5 

Material M-10 

Order quantity 5 

Plant 3500 

Storage location 0095 

6. Choose . 

7. Position your cursor on sales area 3000/10/00 in the dialog box and choose . 

8. Select the items, then choose . 

9. Choose the Schedule lines tab page.  

10. Select the item with the confirmed order quantity, then choose . 

11. Choose , then choose  Shipping. 

To ensure that the most important shipping activities begin on time, for example, picking, 
loading and transport, the R/3 System automatically executes delivery scheduling. You 
can see the necessary entries for this shipment. 
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12. Make a note of the Material availability date, as you will need this as a selection criterion to 
create the delivery. 

If the Transport planning date is earlier than the material availability date, you can create 
the delivery on this date. You can also see the shipping point responsible for delivering 
this order. 

13. Return to the Create Standard Order: Overview screen, then choose Next item and repeat 
your entries as of step 8 for the next item. 

14. Choose , then note the sales order number. 

15. Choose . 
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Creating an Outbound Delivery in a Central System 
1. Call up the transaction as follows: 

Menu Path Logistics → Logistics Execution → Outbound Process → Goods Issue for 
Outbound Delivery → Outbound Delivery → Create → Single Document 
→ With Reference to Sales Order 

Transaction Code VL01N 

2. Enter the following data: 

Field Data 

Shipping point 3500 

Selection date The material availability date or the transport planning date of the first item 

Order Your order number 

3. Choose . 

Check the different statuses of the inbound delivery. 

4. Select an item of the outbound delivery, then choose . 

You can see the picking status of the item. 

The warehouse number assigned to this outbound delivery is the decentralized 
warehouse in Dallas. As this is a decentralized warehouse, the Picking status in the 
central system is Not relevant for picking. 

5. Choose . 

You can see the distribution status of the decentralized warehouse processing. As the 
warehouse number for Dallas is decentralized, this outbound delivery is relevant for 
distribution and therefore has the status Relevant.  

6. Choose , then make a note of the outbound delivery number. 

When you save your entries, the inbound delivery is sent via ALE to the decentralized 
system. This changes the status of the outbound delivery in the central system. Check 
the status of the outbound delivery.  

7. Choose Delivery → Display, then choose . 

8. To check the distribution status of the decentralized warehouse processing, choose . 

The outbound delivery has now been distributed to the decentralized system and 
therefore has the status Distributed. 

9. Choose . 
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Displaying an Outbound Delivery in a Decentralized 
Warehouse 
Prerequisites 
You should now switch to the decentralized WMS (client 812) to pick the delivery. You create a 
transfer request for the outbound delivery, then you confirm this once the outbound delivery has 
been completed. 

Procedure 
1. Sign in to the decentralized WMS (client 812) with the User WMS-User and the Password 

WELCOME. 

2. Call up the transaction as follows: 

Menu Path Logistics → Logistics Execution → Outbound Process → Goods Issue for 
Outbound Delivery → Outbound Delivery → Display 

Transaction Code VL03N 

3. Enter your outbound delivery number, then choose . 

4. Select an item, then choose  to display the status of the outbound delivery. 

As the outbound delivery is only relevant for the picking process in the decentralized 
system, it has picking status Not yet picked and a status for Warehouse Management 
Activities WM-TO required. 

5. Choose  and remain in the decentralized system. 
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Creating and Confirming a Transfer Order for Outbound 
Delivery 
1. Call up the transaction as follows: 

Menu Path Logistics → Logistics Execution → Outbound Process → Goods Issue for 
Outbound Delivery → Picking → Create Transfer Order → Single 
Document 

Transaction Code LT03 

2. Enter the following data: 

Field Data 

Warehouse number 005 

Delivery Your outbound delivery number 

Select items Select 

Process Flow Foreground 

3. Choose . 

4. Select the first item, then choose Stor.type srch seq.. 

You see an overview of the picking of this material. In the Storage type search area, you 
see the sequence of warehouse type 004 (bulk storage) and 001 (high rack storage), 
which are to be searched for the requested material. Material M-01 is generally kept in 
bulk storage, which is why an indicator in the material master proposes this search 
sequence. However, no partial pallets are to be kept in bulk storage, so any pallets with a 
quantity of less than 25 pieces are placed in the high storage rack. As some of the stock 
could be in this storage type, the search is continued in the high rack storage, once the 
bulk storage area has been searched. 

5. Choose . 

You can see that the source storage type is a bulk storage location in storage type 004, 
from which the entire pallet is to be picked. As only a partial quantity is removed, a partial 
pallet remains. The required quantity for the delivery is transferred to the goods issue 
zone (storage type 916), and the partial pallet is transferred to the high rack storage 
(storage type 001). 

6. Confirm the warning message. 

7. Choose Generate + Next mat.. 

8. To save the remaining items in the background, choose . 

9. Make a note of the transfer order number. 

10. Choose . 

The pallets are now transferred to the goods issue zone, and the partial pallet is returned 
to stock. Once this transfer has been completed, you can confirm the transfer order. 

11. Call up the transaction as follows: 
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Menu Path From the Picking node, choose → Confirm Transfer Order → Single 
Document → In One Step 

Transaction Code LT12 

12. Enter the following data: 

Field Data 

Transfer order no. Your transfer order number 

Warehouse number 005 

Foreground/background Foreground 

13. Choose Input list. 

You now confirm the entire transfer order. You can also confirm the items individually. 

14. To confirm that the picking is now complete, choose . 

15. Choose . 
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Posting the Goods Issue 
Prerequisites 
You now need to post the goods issue for the delivery. You execute the posting in the 
decentralized warehouse, the delivery is then sent to the central system, where it is posted in 
Inventory Management as a goods issue for the delivery. This step can occur when the transfer 
order is confirmed. 

Procedure 
1. Call up the transaction as follows: 

Menu Path Logistics → Logistics Execution → Outbound Process → Goods Issue for 
Outbound Delivery → Outbound Delivery → Change → Single Document 

Transaction Code VL02N 

2. Enter your outbound delivery number, then choose Post goods issue. 

The system confirms that outbound delivery WMS XXX has been saved. 

3. Choose . 
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Checking the Outbound Delivery in a Central System 
Use 
Once the picking has been confirmed, the outbound delivery is distributed to the central system, 
where it is posted with the relevant goods issue quantity. 

Procedure 
1. Switch to the central system (client 800) 

2. Call up the transaction as follows: 

Menu Path Logistics → Sales and Distribution → Shipping and Transportation → Outbound 
Delivery → Display 

Transaction VL03N 

3. Enter your delivery number, then choose . 

Check the status of the outbound delivery. 

4. Choose . 

You can see the decentralized warehouse processing status confirmed. 

5. Choose . 
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Billing a Sales Order 
1. Call up the transaction as follows: 

Menu Path Logistics → Sales and Distribution → Billing → Billing Document → Create

Transaction Code VF01 

Enter your outbound delivery number, if it has not already been defaulted by the R/3 
System. 

2. Choose . 

The system branches to the billing items overview screen. 

3. Select both of the billing items, then choose . 

4. Choose . 
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Introductory Workflow Example (Leave Form) 
Purpose 
This demo shows how an IDES employee fills in a leave form. The applicant ii informed whether 
the leave application has been approved or rejected by the manager. If the leave has been 
rejected, the employee can decide whether to revise and resubmit the leave form or withdraw 
and delete it. Depending on this decision, the leave is resubmitted to the manager or the 
workflow is finished. 

 
This demo shows workflow functions without reference to the Human Resources module. 
It is a pure demo example. The same scenario with integration to Human Resources is in 
the demo Absence Approval/Rejection [Page 59]  

 
The workflow template used for this demo and its embedding in the organizational plan 
of the IDES AG are displayed in the demo Introducing WF Example (Leave Form) : 
Selected Details of the Workflow Definition [Page 47]. 

Process Flow 
You can find the data for this process under  [Page 41]. 

1. Employee: Filling in Notification of Absence [Page 42] 

2. Superior: Approving Notification of Absence [Page 43] 

3. Employee: Notification of Leave Request [Page 44] 

4. Variant: Rejecting the Leave Request (optional) [Page 45] 
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Data Used During This Process 
Field Data Description 

Name (applicant) Karl-Heinz Quartz Skilled worker Karl-Heinz Quartz (User WF-MM-1) 

Department PC Production 1  

Personnel number 1286  

Superior Frank Schmidtrohr Plant manager Dresden (User WF-MM-3) 
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Employee: Filling in Notification of Absence 
Use 
The skilled worker Karl-Heinz Quartz (User WF-MM-1) who works in the PC production in the 
Dresden plant wants to take a one week vacation. 

Procedure 
1. Log on to your IDES system as user WF-MM-1, password WELCOME, language EN. 

2. Call the transaction as follows: 

Menu Path Tools → Business Workflow → Development → Environment → Demo: 
Fill out form  

Transaction Code SWXF 

3. Enter the following data: 

Field Data 

Name Karl-Heinz Quartz 

Department PC Production 1 

Personnel number 1286 

Absent from (1st day) < Monday next week > 

Absent until (last day) < Friday next week > 

Reason < user-defined entry > 

Contact at < user-defined entry > 

4. Choose . 

5. Choose . 

Do not log off the system as you will be the applicant WF-MM-1 again in the next 
process. 

 
Saving the form in the database triggers off a workflow for approval of the leave request. 

If the vacation is not approved, proceed with the process step 2 in Variant: Rejection of 
leave request (optional) [Page 45]. 
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Superior: Approving Notification of Absence 
Use 
Plant manager Frank Schmidtrohr (User WF-MM-3), Karl-Heinz Quartz´ superior, checks and 
approves of the leave request that the workflow has put in his inbox. 

Procedure 
1. Log on to your IDES system as user WF-MM-3, password WELCOME, language EN. 

2. Call the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

3. Mark the row Employee Karl-Heinz Quartz: Approve absence.  

4. Choose . 

You see the data that you just entered as employee Karl-Heinz Quartz.  

5. Choose Approve. 

The system confirms the action with the message Application approved in the status line.  

6. Choose . 

7. Choose End Workitem in the dialog box to confirm the completion of the work item. 

8. Choose . 

Do not log off the system if you want to perform the process variant Rejection of a leave 
request at a later time. 
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Employee: Notification of Leave Request 
Use 
The employee Karl-Heinz Quartz is notified immediately of his superior’s decision after the 
approval of his leave request via an express mail. 

Procedure 
Make sure that you are logged on as user WF-MM-1 in the IDES System. 

 
You may be informed in a dialog-box about the reception of an express message. 
Choose Inbox and continue with step 3. 

1. Call the transaction as follows: 

Menu Path Office → Workplace → Inbox 

Transaction Code SWBP 

2. Mark the line Notification of absence no. 000000xxx.... and choose . 

The text contains the current data from the leave request just entered and approved 
(date of approval, request number, start of absence). 

3. Choose . 

Do not log off the system if you want to perform the next process step Rejection of a 
leave request. 
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Variant: Rejecting the Leave Request (Optional) 
Use 
A leave request can be rejected. The applicant is notified via a work item and has to decide 
whether to withdraw or change his or her request. 

Procedure 
1. Go back to the process step Employee: Filling in notification of absence [Page 42] and 

complete another notification of absence form as user WF-MM-1. After the creation of the 
leave request return to this step and continue with the following steps.  

2. Make sure that you are logged in as user WF-MM-3 (password WELCOME).  
Should a message appear that there are unread documents in your inbox, choose . 

3. Call the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SWXF 

4. Mark the row Employee Karl-Heinz Quartz: Approve absence and choose . 

You see the data that you just entered as employee Karl-Heinz Quartz.  

5. Choose Reject. 

The system confirms the action with the message Application rejected in the status line. 

6. Choose . 

7. Choose attachment in the menu bar in the dialog box to tell the employee the reason for the 
rejection of the notification request.  

8. Enter the following data: 

Field Data 

Type SCR 

Title Reason 

9. Choose . 

Enter a text, for example ‘Next week we will need you for an extra shift.’  

10. Choose  and . 

11. Choose Completend work item. 

12. Choose . 

The employee Karl-Heinz Quartz can now look in his inbox to see whether his leave 
request has been approved or rejected. 

13. Go to the session in which you are logged on as user WF-MM-1. 

If there is a message that you have received an express document, choose . 

14. Call up the transaction as follows: 
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Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SWXF 

15. Select the row line Abs.notif.no. 000000XXXX rejected. What action? 

16. Choose . 

17. To read the reason for the rejection, choose Edit → Attachment → Display. 

18. Choose . 

19. Choose Withdraw notification of absence. 

The leave request is deleted. 

20. Choose . 
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Workflow Demo (Leave Form): Workflow Definition 
Details 
Purpose 
This demo example shows the usage of the SAP Business Workflow tools and guides you 
through the modules of the workflow “Process notification of absence” (cf. Introductory Workflow 
Example (Leave Form) [Page 40]). That script describes an example workflow model, here you 
can learn about the different elements of a workflow and how to edit them with workflow tools. 
The main focus of this demo is therefore not a particular SAP R/3 System business function but 
on the use of an innovative tool to support and optimize business processes from any application 
modules.  

 

You will see a flow log of a workflow model, the definition of the workflow model, selected 
organizational and technical details of various workflow steps (tasks, object methods) and the 
part of the organizational plan of the model company IDES AG used. This script gives you an 
overview of the SAP Business Workflow tools as introduces you to the creation of your own 
workflow definitions.  

Prerequisites 
Perform the Introductory Workflow Example (Leave Form) [Page 40] first. You can only then 
perform the first (optional) process step.  

 

Process Flow 
You can find the data for this process under  [Page 48]. 

1. Display Workflow Step Log (Optional) [Page 49] 

2. Workflow Definition and Triggering Events [Page 50] 

3. Workflow Step ‘Approving the Notification of Absence’ [Page 52] 

4. Task ‘Approving the Notification of Absence’ [Page 53] 

5. Object ‘Form: Notification of Absence’ (Optional) [Page 55] 

6. Organizational Plan [Page 57] 
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Data Used During This Example 
Field Data Description 

Task type WS Workflow sample from SAP 

Task number 30000015 Workflow sample “Process notification of absence” 

Task type TS Standard task from SAP 

Task number 30000016 Standard task “Approve notification of absence” 

Business Object FormAbsenc Form “Notification of absence” 

Organizational Unit 00000001 IDES AG 
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Displaying the Workflow Step Log (Optional) 
Use 
Log on to the IDES System as user WF-MM-1 with password WELCOME and language EN who 
made the leave request in the demo Introductory Workflow Demo (Leave Form) [Page 40] [Page 
40]. Go from a workflow model log to the workflow definition that describes the procedure of the 
workflow. 

Procedure 
1. Call up the transaction as follows: 

Menu Path Tools → Business Workflow → Development → Runtime tools → 
Business Workplace → Outbox 

Transaction Code SW13, SBWP 

 
If you have not performed the Introductory Workflow Example (Leave Form) you can 
skip the following steps and proceed with the second process step. 

2. Select the row Demo Workflow for Notification of Absence and choose . 

3. Choose  Log. 

4. Drag the window so that you can see the result and the agent for all workflow steps. 

5. To see details such as start and finish date of the workflow model, double-click on the first, 
green line Demo workflow for notification of absence. 

6. You can go to the (single or multiple-step) task. Choose Extras → Display task. 

You can see the name of the Workflow task, for example. 

 

The next process step will continue here, so do not choose . 
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Workflow Definition and Triggering Events 
Use 
In the workflow editor you can see the activities in a workflow necessary for the workflow control. 
Before viewing single activities in more detail, take a look at the triggering events in the workflow 
Process Notification of Absence to get an overview of it. 

Procedure 

 
If you executed the first process step and reached the screen Workflow Template: 
Display, continue with step 8. Choose the Triggering Events tab. 

1. Call up the transaction as follows: 

Menu Path Tools → Business Workflow  → Development → Definition Tools → 
Tasks/Task Groups → Display 

Transaction Code PFTC_DIS 

2. Choose WS (Workflow sample) from the possible entries help for the Task type field to find 
the Workflow task ”Process Notification of Absence”.  

3. Enter Absence as the search term in the possible entries help for the Task field. Choose . 

4. Double-click on the Workflow sample AF_process Process Notification of Absence. The 
workflow template has the number WS30000015.  

5. Choose . 

6. The start of the workflow sample is linked to a change in status (event) of the business object 
Notification of absence. To see this triggering event, choose the Triggering Events tab page. 

7. The green light in the first line of the standard events table indicates that the link to the event 
Notif. of Absence Created is active. 

Each time a form Notification of Absence is created the workflow system starts this 
workflow sample. The workflow task link definition means that you do not have to change 
the Notification of absence application program to start a different workflow task in 
reaction to the event.  

8. Choose the Basic data tab page. 

Now observe the flow of the workflow. 

9. Choose the step Workflow  Builder. 

The Workflow Editor starts. 

 
Technical information (Workflow steps, events, operators and containers) is displayed on 
the left side of the screen 

You can see a section of the flow definition in the middle of the Display area. You can 
display a particular section in the area by moving the green rectangle to the right of the 
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Navigation Area. The activities and workflow control flow operations are displayed as 
green symbols. After each activity one or more rhombuses display its results or the 
scheduled events. 

By scrolling forward or backwards in the flow description you will get an overview of the 
activities in the Process notification of absence workflow sample: 
The two events on the top show that the workflow can either be started by the triggering 
event Form created or by hand in the dialog. The first activity Approve notification of 
absence either has the result Approved or Rejected. If it is approved, a flag is set and the 
applicant is notified. If the leave has been rejected, the applicant is informed and can 
decide whether to revise and resubmit the leave form or withdraw and delete it. 
Depending on this decision, the leave is resubmitted to the manager or the workflow is 
finished (‘loop: resubmit NoA). 

10. Do not choose , the next step continues here. 
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Workflow Step ‘Approving the Notification of Absence’ 
Use 
Now view the activity ‘Approve notification of absence’ of the workflow definition in more detail. 
An activity is a workflow step in which a task is called from the process structure and given data, 
dates and an agent. When the workflow is performed, a work item which can be executed at the 
push of a button is created from these details and it appears in the inbox of the selected agent. 
Any results of this work item that are needed later in the workflow are copied into the workflow 
data container. 

Procedure 
1. 

2. 

If the screen header is not to be Workflow Builder: Display ‘AF_process’ [active, saved, 
choose Extras → Options. 

Choose  in the Options dialog box. 

Go to the Approve notification of absence step and double-click on . 3. 

4. 

5. 

6. 

7. 

This activity calls the standard task TS30000016 ‘Approve notification of absence’. 

The agent for activity 0000168 is displayed in the Person Responsible field in the Agent 
section of the Control tab. 

The appropriate agent is selected via the role ‘Superior of...’. 

Choose Data flow exists in the Agent section. The role determines the superior of the 
workflow initiator. 

Confirm the dialog box with . 

8. 

9. 

Choose the Latest Start tab. The initiator is informed if the workflow execution deadline is 
exceeded (container element _WF_INITIATOR). 

The Latest Start value specifies that the superior must start processing this activity no 
more than 5 minutes after the creation of the work item (for demo purposes). The initiator 
is informed if this deadline is exceeded in this example.  

Select the Control tab to display the basic data of this activity again. 
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Task ‘Approving the Notification of Absence’ 
Use 
In this process step you change from the process level to the organizational level to view the 
detail data of the standard task on which it is based and its classification into the organizational 
plan. 

Procedure 
1. 

2. 

To see which employees of the IDES AG have the task Approve notification of absence in 
their activity profile, select Agent assignment for task next to the selection ‘Agent 
assignment’. 

Choose View → Key on to display the numbers of the organizational units. 

 
If the organizational units are already displayed skip this step. 

3. 

4. 

Choose View → Color legend and make yourself familiar with the meaning of the different 
organizational elements. 

Choose  in the dialog box. 

5. 

6. 

7. 

8. 

To verify that Mr. Frank Schmidtrohr (user WF-MM-3), superior of Karl-Heinz Quartz (User 
WF-MM-1) is allowed to execute the task select the sign ‘+’ of the task group T 50000185 
Personnel management. 

A list of position (descriptions) appears showing the tasks of the task group ‘Personnel 
management’ . 

Select the sign ‘+’ at the position Head of Department with the number C 50011879. 

A list of positions (yellow) is displayed. 

Select the ‘+’ before the position Plant Manager Dresden D with the number S 50012181. 

The person (P) Frank Schmidtrohr is displayed. 

Select the ‘+’ of the person Frank Schmidtrohr. 

The user (US) WF-MM-3 is displayed. 

 
You could go from here to the Human Resources module to edit a position, a 
personnel master record, etc. via Goto → Display object. 

9. 

10. 

Go back to the Workflow Builder screen. 

Position the cursor on the task number TS30000016 and choose . 

11. Choose Edit → Work item text → Redefine. 

The text in the inbox of the selected agent is displayed in the dialog box. 
&_WI_OBJECT_ID.CREATOR.NAME& is a placeholder for the applicant and is a 
reference for the attribute CREATOR of the object that is edited in the work item method, 
see next process step. 
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12. Choose . 

13. 

14. 

15. 

Choose the Description tab page to see the task description for the agent. 

Choose Display Text. 

Read the displayed text. The placeholders are replaced by the current values of the 
associated object attributes as in the work item text.  

Choose  until you reach the Workflow Builder screen. 

 
The Task Description dialog box may appear. Choose Cancel  to close it. 

 

 

54  April 2001 



 SAP AG Cross-Application Components (CA) 

  Object ‘Form: Notification of Absence’ (Optional) 

Object ‘Form: Notification of Absence’ (Optional) 
Use 
In this process step you change to the business object levels that implement those business 
objects which have been edited in a workflow. Its methods, attributes and events are the 
operational elements of a workflow and implement an object-oriented access to the SAP R/3 
System functionality. From the process level (flow description) you can easily access the 
methods, attributes and events of an object in the SAP R/3 System without any programming 
knowledge. This simplifies the workflow creation. 

 
This process step is particularly interesting for developers. Other user groups can ignore 
it. 

Procedure 
1. Position the cursor on the task number TS30000016 in the Workflow Builder: Display step: 

Activity screen and choose . 

This standard task is implemented by calling the method APPROVE of the object type 
FORMABSENC. 

2. 

3. 

4. 

To view the object type FORMABSENC more closely, position the cursor onto it and select 
Goto → Select line/object. 

Select the ‘+’ before attributes, methods and events. 

Mark the method Absence Form. Approve and choose . 

The Method Approve dialog box indicates that it is a synchronous, interactive method 
with a user dialog.  

5. 

6. 

To find out how the method is implemented, select the ABAP/4 tab. The method calls the 
function module SWX_FORMABS_APPROVE.  

Choose . 

7. 

8. 

If you want to see the ABAP implementation of the method, choose Program. 

The code frame for the method and the function call has been automatically generated 
according to the approve method details above. 

Choose  until you reach the Workflow Builder screen. 

9. 

10. 

Choose Data flow exists in the top section of the screen to see the input and output data of 
the task. 

The contents of the workflow container elements AbsenceForm are passed to the task as 
an input parameter (<==) with the name Notif. of absence. (Technically this is the link to 
the edited object Notification of absence which you just displayed.) 
The task does not return any result data to the workflow container, so no entries have the 
‘==>‘arrow. 

To display the access to the attributes, position the cursor on the element &AbsenceForm& 
and click the right-hand mouse key and Possible Entries. 
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The elements of the workflow container are displayed in the dialog-box. The Notif. of 
absence element is the only one highlighted in blue/green because it has only one data 
type which matches the input parameter of the task or object method. 

11. 

12. 

To display the attributes available for the notification of absence, select the ‘+’ sign in front of 
the element. The ‘+’ sign on front of Approver indicates that this attribute links in turn to an 
object containing the attributes address, cost center, department etc. 

In change mode you could use one of these attributes, for example to formulate a link 
condition, as input parameter for an activity to be executed, as agent of an activity, or as 
reference point for deadline monitoring. 

Choose . 

 
You must also close the Workflow Builder. Choose Workflow → Exit. 

 

 

 

56  April 2001 



 SAP AG Cross-Application Components (CA) 

  Organizational plan 

Organizational plan 
Use 
This process step is concerned with the section of the organizational plan of the IDES AG which 
is relevant for this demo workflow. You navigate from top to bottom until you display the positions 
and persons participating in this workflow, to see their activity profile and their organizational 
position in the IDES AG. 

Procedure 
1. Call up the transaction as follows: 

Menu Path Tools → Business Workflow → Organizational Plan → Organizational Plan 
→ Organization and Assignment → Display 

Transaction Code PP0SE 

2. Choose Organizational unit and enter 1200 in the "with description" field. 

3. Choose  Search. 

4. Choose Setting → Change Maintenance Interface. 

5. Make the following entries in the Organizational Plan screen: 

Field Data 

Organizational Unit 1200 

6. Choose . 

7. Choose Staff assignments. 

8. Select View → Color legend to see the meanings of the colors. 

9. Choose  in the dialog box. 

10. The hat symbol in front of the plant manager Dresden shows that this is a management 
position. Choose the ‘+’ sign in this row. This position is occupied by Frank Schmidtrohr.  

11. To display the workflow tasks for which Frank Schmidtrohr is responsible, mark this line and 
select Task profile. 

12. Select the ‘+’ sign of the line Plant Manager Dresden and then the ‘+’ in front of Head of 
Department. Frank Schmidtrohr is for example the manager of the task group Personnel 
management. 

13. Choose the "+" sign in the Personnel management row. The task Approve notification of 
absence is in this group. 

14. Choose . 

15. Select ‘+’ in front of the Production of Personal Computers (D) row and then the ‘+’ in front of 
the Skilled PC production worker row. 

16. Repeat step 9 for the Skilled PC production worker Karl-Heinz Quartz. 

17. Choose . 
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Absence Approval/Rejection 
Purpose 
This scenario describes how an employee creates a leave request, which is locked because it 
has not been approved. Two subsequent processes are possible: If the employee's superior 
approves the leave request, the employee's personnel administrator has to unlock the leave 
request and check the employee's leave entitlement.  The employee's superior rejects the leave 
request, adding an explanatory note. The employee is informed automatically. 

Process Flow 
You can find the data for this process under  [Page 60]. 

1. Entering a Leave Request [Page 61]  

2. Approving a Leave Request [Page 62]  

3. Unlocking a Leave Request [Page 63]  

4. Checking the Status of a Leave Request [Page 64]  

5. Rejecting a Leave Request [Page 65]  
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Data Used During This Process 
Field Data 

Personnel number 1001 

Steps 1, 4, 5 
Person entering 
request 

WF-HR-A 

Steps 2, 5 
Head of 
department 

WF-HR-M 

Step 3 
Administrator 

WF-HR-2 
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Entering a Leave Request 
Use 
During this exercise, you will log on under various logon names. You are recommended to keep 
them open. 

 
You can find out which logon and user the current work area belongs to by choosing 
System → Status. 

Procedure 
1. Log on as the user WF-HR-A using the password Welcome. 

2. Call up the transaction as follows: 

Menu path Human Resources → Personnel Management → Administration → HR 
Master Data → Maintain 

Transaction code PA30 

3. Enter the following data: 

Field Data 

Personnel number 1001 

4. Choose . 

5. Choose the Working times tab page. 

6. Select Absences. 

7. In the Period field, select Today. 

8. Choose . 

The Subtypes for infotype Absences dialog box appears. 

9. Select 0100 in the A/AType column. 

10. Choose . 

11. On the Create absences screen, choose . 

The message Record created is displayed in the status bar. 

 
Creating the leave request triggers an event that starts the Absence Approval 
workflow. 

12. Choose  until the overview tree appears. 
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Approving a Leave Request 
Use 
The leave request is first approved by the head of the department, David Grecco, and then 
unlocked by the personnel administrator.  The administrator, Michaela Maier, can then view the 
result in her Office Inbox. 

Procedure 
1. Log on as the user WF-HR-M using the password Welcome. 

If a message appears saying that you have unread documents in your inbox, choose  . 

2. Call up the transaction as follows: 

Menu path Office → Workplace 

Transaction code SBWP 

3. Choose Inbox → Workflow. 

4. In the Workflow area, select the line Approval of Absence Request for Michaela Maier. 

5. Choose . 

6. On the Approval Leave for Michaela Maier for <today's date> screen, choose . 

The system displays the Display Absences screen with the leave request previously 
submitted by Michaela Maier. 

7. Choose  until the Decision Step in Workflow screen appears. 

8. Choose Approve absence. 

9. In the dialog box, choose  Complete work item. 

10. Choose  until the overview tree appears. 
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Unlocking a Leave Request 
Use 
After the employee’s superior has approved the leave request, the personnel administrator, Mike 
Kaufmann (WF-HR-2), still has to check the employee’s leave entitlement and unlock the leave 
request. 

Procedure 
1. Log on as the user WF-HR-2 using the password Welcome. 

2. Call up the transaction as follows: 

Menu path Office → Workplace 

Transaction code SBWP 

3. Choose Inbox → Workflow. 

4. In the Workflow area, select the line Absence: Leave for Employee Michaela Maier. 

5. Choose . 

6. In the Approve absence Leave for employee Michaela Maier by unlocking it screen, choose 
. 

7. Choose . 

8. In the dialog box, choose  Complete work item. 

9. Choose  until the overview tree appears. 
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Checking the Status of a Leave Request 
Use 
The administrator Michaela Maier can now check her inbox to see if the leave request was 
completely approved, partially approved, or if it was rejected. 

Procedure 
1. Log on as the user WF-HR-A using the password Welcome. 

If a message appears saying that you have unread documents in your inbox, choose,  
. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace 

Transaction Code SBWP 

3. Choose Inbox. 

4. In the Inbox area, select the line Leave from <today's date> to <today's date> was 
approved... 

5. Choose . 

The Display Absences screen appears, showing the leave request that was approved by 
the head of department and unlocked by the personnel administrator. 

6. Choose . 

7. In the dialog box, choose  Complete work item. 

8. Choose  until the overview tree appears. 
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Rejecting a Leave Request 
Use 
Administrator Michaela Maier (WF-HR-A) wants to enter a leave request for a day of leave. 

Procedure 
1. Log on as the user WF-HR-A using the password Welcome. 

2. Call up the transaction as follows: 

Menu Path Human Resources → Personnel Management → Administration → HR 
Master Data → Maintain 

Transaction Code PA30 

3. Enter the following data: 

Field Data 

Personnel number 1001 

4. Choose . 

5. Choose the Working times tab page. 

6. Select Absences. 

7. In the Period field, select Today. 

8. Choose . 

The Subtypes for infotype "Absences" dialog box appears. 

9. Select 0100 in the A/AType column. 

10. Choose . 

11. On the Create absences screen, choose . 

 
Creating the leave request triggers an event that starts the Absence Approval 
workflow. 

12. Choose  until the overview tree appears. 

13. Log on as the user WF-HR-M using the password Welcome. 

If a message appears saying that you have unread documents in your inbox, choose  . 

14. Call up the transaction as follows: 

Menu Path Office → Workplace 

Transaction Code SBWP 

15. Choose Inbox → Workflow. 

16. In the Workflow area, select the line Approval of Absence Request for Michaela Maier. 
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17. Choose . 

The Display Absences screen appears. 

18. Choose  until the Decision Step in Workflow screen appears. 

19. Choose Not approved. 

20. In the dialog box, choose  Attachments. 

21. In the dialog box, enter the following data: 

Field Data 

Class SCR 

Title Leave not approved 

22. Choose . 

23. The Change Document: MESSAGE Language EN screen appears, where you can enter a 
text giving reasons for the refusal, for example, “Your presence is absolutely necessary on 
this date”. 

24. Choose . 

25. Choose . 

26. In the dialog box, choose  Complete work item. 

27. Choose  until the overview tree appears. 

The administrator Michaela Maier can now check her inbox to see if the leave request 
was completely approved, partially approved, or if it was rejected. 

28. Log on as the user WF-HR-A using the password Welcome. 

If a message appears saying that you have unread documents in your inbox, choose, . 

29. Call up the transaction as follows: 

Menu Path Office → Workplace 

Transaction Code SBWP 

30. Choose Inbox. 

31. Select the line Requested Leave from <today's date> to <today's date>. 

32. Choose . 

A dialog box appears, informing you that your leave request was not approved. 

33. To see the reason for the rejection, choose Edit → Attachments → Display. 

34. To exit the document display, choose . 

35. In the Decision Step in Workflow screen, choose Cancel request. 

The Delete Absences screen appears. 

Michaela Maier can now delete her leave request. 

36. Choose . 
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The system displays a message confirming that the record was deleted. 

37. In the dialog box, choose  Complete work item. 

38. Choose  until the overview tree appears. 
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Workflow for Travel Management 
Purpose 
Both workflow processes demonstrate an approval and settlement process for Travel 
Management that is typical for Human Resources. The approval process outlined here is 
indicative of other workflow processes in Human Resources (see, for example, Leave Approval). 

Approving a Travel Request 
An employee enters a travel request in the SAP R/3 system. It is automatically forwarded through 
the SAP R/3 system to a preset superior, who then checks the request. 

The superior checks the travel request and then approves, rejects, or returns the request to the 
employee for corrections. The scenario for the process in this exercise is based on the 
assumption that superior approves the employee's request. 

After the superior has approved the request, the employee receives an automatically generated 
mail with the approval message.  

Approving a Business Trip 
After the business trip, the employee enters the trip facts in the R/3 system. The Expenses 
department then checks whether the employee's trip facts must be corrected or whether they are 
consistent. If the trip facts are consistent with the original request, they are forwarded to the 
superior to be checked for approval. The superior can then reject the reimbursement, send the 
trip facts back to the employee to be corrected, or, as in this scenario, approve the 
reimbursement of expenses. The results of trip costs accounting are transferred to payroll directly 
for payment during the payroll run. 

You can find more information about this process under  [Ext.]. 

Process Flow 
You can find the data about this process under  [Page 69]. 

1. Entering a Travel Request [Page 70]  

2. Approving a Travel Request [Page 72]  

3. Displaying the Approval Notification for the Employee [Page 73]  

4. Entering Trip Facts [Page 74]  

5. Checking Trip Facts [Page 76]  

6. Approving a Trip [Page 77]  

7. Settling a Trip [Page 78]  
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Data Used During This Process 
Field Data 

User  

 

 

Password 

WF-TR-1 

Employee: Chris Miller (personnel no.: 1309) 

Submits a Travel Request 

welcome 

User  

 

 

Password 

WF-TR-2 

Superior: Dr. Martin Jost (personnel no.: 1027) 

Checks the travel request and expense reimbursement 

welcome 

User  

 

 

 

Password 

WF-TR-3 

Administrator in the Expense Department: 

Manfred Mannheim (personnel no.: 1052) 

Checks trip data 

welcome 
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Entering a Travel Request 
Use 
During this exercise, you will logon under various logon names. Ensure that you keep them open. 

 
Under System → Status you can find out which logon the open work area belongs to. 

Procedure 
1. Log on as the user WF-TR-1 (Chris Miller PerNo: 1309) using the password welcome. 

2. Call up the transaction as follows: 

Menu Path Accounting → Financial Accounting → Travel Management →  Travel 
Expenses → Travel Expense Manager 

Transaction Code PR05 

3. Enter the following data: 

Field Data 

Personnel no. 1309 

You see a list of all trips that have already been entered. 

4. Choose . 

If the Business Trip dialog box appears, choose . 

5. Enter the following data: 

Field Data 

From 19.06.2000 10:00 

End 23.06.2000 18:00 

Reason Trade fair 

City Berlin 

6. Choose the Advances tab page. 

If an additional dialog box appears, choose OK. 

7. Enter the following data: 

Field Data 

Amount 1.000,- 

Currency DEM 

CaOff Select 

Date 18.06.2000 
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8. Choose  Trip Status. 

9.  Enter the following data in the New Status area: 

Field Data 

Request entered Select 

To be settled Select 

10. Choose . 

11. Choose Yes in the dialog box that appears. 

12. Choose . 
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Approving a Travel Request 
1. Log on as the user WF-TR-2 (Dr. Martin Jost, personnel no.: 1027) using the password 

welcome. 

2. Choose . 

3. Choose Inbox → Workflow. 

4. Select the travel request submitted by Chris Miller. 

5. Double click on the EX...(Executable) field. 

In the upper part of the screen, you can choose various buttons in order to approve a 
request, send the request back for corrections, or reject a request. In the bottom part of 
the screen, you see the details for the travel request. 

6. In the Approve Travel Request of Chris Miller field: Choose Approve Travel Request. 

7. Choose . 
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Displaying the Approval Notification for the Employee 
1. Log on as the user WF-TR-1 (Chris Miller, personnel no.: 1309) using the password 

welcome. 

2. Call up the transaction as follows: 

Menu path Office → Workplace 

Transaction code SBWP 

3. Choose Inbox. 

4. Choose the approved travel request by double-clicking it. 

A personal message from your superior is displayed. 

5. Choose  until the overview tree appears. 
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Entering Trip Facts 
1. Log on as the user WF-TR-1 (Chris Miller PerNo: 1309) using the password welcome. 

2. Call up the transaction as follows: 

Menu Path Accounting → Financial Accounting → Travel Management →  Travel 
Expenses → Travel Expense Manager 

Transaction Code PR05 

3. Enter the following data: 

Field Data 

Personnel no. 1309 

4. Select the current trip. 

5. Choose . 

6. Choose the Receipts tab page. 

7. In the ExpTy (Expenses type) field in the first line (001) of the receipts area, select the 
appropriate value by using the F4 help. 

8. In the dialog box that appears, choose the entry for HOTL by double clicking Hotel. 
9. On the Receipts tab page, enter the following data: 

Field Data 

Amount 790 

Currency DEM 

10. Choose . 

11. Enter the following data in the dialog box: 

Field Data 

From 19.06.2000 

To 23.06.2000 

Nbr of beakfasts 4 

Description Holi_Inn 

Business purpose Enter any reason 

Location Berlin 

Country DE 

Region Blank 

12. Choose . 

You have entered a hotel receipt from 06/19 - 06/23/2000. The receipt included 4 
breakfasts. 
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The start date for the trip must be in the past in order to be valid for payroll. 

13. Enter the following data: 

Expense type Amount Tax...(Tax ID) Date 

TAXI 25,50   

TELE 15,00 V1  

PARK 60,00   

14. Choose . 

 
To navigate between the individual fields, use the Tab key. It is easier to make all the 
entries first and then choose  . This enable you to enter the trip data more quickly; 
the required checks occur only after you have made all entries. 

15. Choose  Trip Status. 

16. Assign a new status. Set the status to Trip completed / Report recorded and To be settled. 

17. Choose . 

18. ChooseYes in the dialog box that appears. 

The new status is displayed in the Approval and Settlement fields. 

19. Choose . 
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Checking the Trip Facts 
1. Logon as user WF-TR-3 (Manfred Mannheim, personnel no.: 1052) using the password 

welcome. 

2. Choose . 

3. Choose Inbox → Workflow. 

4. Select Chris Miller's trip. 

5. Double click on the Ex...(Executable) field. 

6. Choose Trip facts are consistent. 

7. Choose . 
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Approving a Business Trip 
1. Log on as the user WF-TR-2 (Dr. Martin Jost, personnel no.: 1027) using the password 

welcome. 

2. Choose . 

3. Choose Inbox → Workflow. 

4. Select Chris Miller's trip. 

5. Double click on the Ex...(Executable) field. 

6. To approve the expenses reimbursement, choose Approve trip from the subsequent screen. 

7. Choose . 
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Settling a Trip 
1. Logon as user WF-TR-3 (Manfred Mannheim, personnel no.: 1052) using the password 

welcome. 

2. Call up the transaction as follows: 

Menu Path Accounting → Financial Accounting → Travel Management →  Travel 
Expenses → Travel Expense Manager 

Transaction Code PR05 

3. Enter the following data: 

Field Data 

Personnel no. 1309 

4. Choose . 

In the Approval field, you see the new status Trip approved / to be settled. 

5. Select the trip. 

6. Choose . 

7. Choose . 

You can display a history of the approval statuses. 

8. Choose  until the Travel Expense Manager screen appears. 

9. Choose  Settle. 

10. In the dialog box, choose . 

11. Choose . 
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Workflow - Service Management 
Purpose 
There is a growing trend for companies to provide certain services for other companies, either in 
conjunction with a specific product that they manufacture, or simply as a main line of business. 
Consequently, customer expectations of improved after-sales service have risen. 

When a machine installed at a customer site breaks down or requires servicing, the customer 
contact person can either log a call directly in the R/3 System, or contact the customer service 
department of the equipment supplier or manufacturer by phone, fax or mail, who in turn logs the 
call in the system. 

In this scenario, a call has been received reporting a malfunctioning hard drive on a PC. The PC 
manufacturer receives the call and resolves the customer’s problem through its hotline service. 

You can find more information about this process under  [Page 81]. 

Process Flow 
You can find the data for this process under  [Page 80]. 

1. Logging the Service Notification [Page 82] 

2. Processing and Completing the Service Notification [Page 83] 
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Data Used During This Process 
Field Data Description 

Workflow User ID WF-SM-1 Service technician 

Equipment 10003594 Personal computer 

Damage EN Hard disk out of order 

Task code TEL Call back customer 

Person responsible 1527 Alexander Maroto 

Sales document 40000076 Service contract 
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Additional Process Information 
Further information about the technical realization of this demo with the SAP Business Workflow 
tools and the necessary preparations and customizing settings can be found in the SAP Library. 

Call up the transaction as follows: 

Menu Path R/3 Basis Library → Business Engineering Workbench → SAP Business 
Workflow → Application Workflow Scenarios → PM Plant Maintenance and 
Service Management → Service Management (PM-SMA). 
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Logging the Service Notification 
Use 
Log on to the IDES system. This user reports the service notification. 

Procedure 
1. Call up the transaction as follows: 

Menu Path Logistics → Customer Service → Service Processing → Notification → 
Create (Special) → Problem Notification. 

Transaction Code IW54 

2. Enter the following data: 

Field Data 

Equipment 10003594 

3. Choose . 

The system calls up the service contract data (40000076) for this equipment. 

The system also informs you that the catalog profile has been copied from the 
equipment. This means that information related to the equipment, such as contact 
information, has been included in the service notification. 

4. Choose the Items tab page, then position your cursor on the Damage field and choose the 
F4 input help. 

You see a catalog selection. 

5. Choose E (Hard disk out of order) and  Select in the dialog box. 

6. Choose . 

Note the notification number. 

7. Choose . 

8. Choose No in the Confirmation Prompt dialog box. 

 
The Confirm. Prompt dialog box refers to the creation of a new service notification.  

9. Log off from this IDES system. 
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Processing and Completing the Service Notification 
Use 
The service technician who processed this call has solved the problem by telephone and now 
records the results. 

Procedure 
1. Log on to your IDES system as user WF-SM-1, password WELCOME. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

On the Workflow screen, you see a list of service notifications. 

3. Double-click on  for your notification number. 

4. Choose the Tasks tab page. 

5. Position your cursor on the Task code field, then choose the F4 input help. 

You see a catalog selection. 

6. Choose the "+" character before PC, select the task code TEL and choose  Select. 

7. Enter the following data: 

Field Data 

Responsible 1527 

8. Choose . 

9. Select the task you have just created. 

10. To complete the task, choose . 

In the Status field, the status is now TSCO. 

11. Choose Service Notification → Functions → Complete. 

12. In the Complete dialog box, verify the date and time of the completion of this service 
notification, then choose . 

The system saves the data. 

The work item you have processed is no longer displayed, indicating that the work is 
completed. 

13. Choose . 
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Engineering Change Management (ECM) 
Purpose 
For technical and commercial reasons, it is necessary to change industrial products from time to 
time. 

Technical reasons for changes include, for example, technical faults which have to be corrected 
and the introduction of new environmental or safety regulations. For commercial reasons, it may 
be necessary to start using cheaper materials or to change a product to suit customer 
requirements. 

In the R/3 System, changes to objects can be made with or without history. 

• Changes without history: These are changes which occur during the development phase of a 
product and which are not documented. The state of the object (for example, bill of material 
or task list) before the change is not documented. 

• Changes with history: These are changes which may affect further activities within the 
organization and which are to be documented (for example, a change to a material, resulting 
in a change to the bill of materials, resulting in a change to task list, resulting in a change to 
the inspection plan). The state of the object before the change is saved. 

Engineering Change Management (ECM) in the R/3 System offers you a comprehensive solution 
for documenting such changes. 

In this process, a customer has reported an ignition problem with a particular motorcycle in wet 
weather. We follow the changes made from the receipt of the customer report to the completion 
and release of the requested change. 

 
This script makes use of the ArchiveLink simulation functionality for processing 
incoming faxes or scanned-in documents. To check if ArchiveLink has been set-up, 
please see the customizing information for ArchiveLink. 

Process Flow 
You can find the data for this process under  [Page 85]. 

1. Simulating an incoming Fax for ECM using ArchiveLink [Page 86] 

2. Processing the Customer Complaint [Page 87] 

3. Determining Material Requirements and Checking the Customer Complaint [Page 88] 

4. Checking the Feasibility of the Change Request [Page 90] 

5. Checking the Change Request [Page 91] 

6. Approving and Converting the Change Request [Page 92] 

7. Setting the Completion Indicator for the Change Object [Page 93] 

8. Completing and Releasing the Change Request [Page 94] 
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Data Used During This Process 
Field Data Description 

UserID for various steps, 
starting with Processing the 
Customer Complaint 

WF-PP-P; password 
WELCOME 

Workflow user, seen as the 
management level this 
business scenario 

UserID for steps Checking the 
Feasibility of the Change 
Request and Setting the 
Completion Indicator for the 
Change Request 

WF-PP-E; password 
WELCOME 

Workflow user, seen as the 
product engineer in this 
business scenario 

Material HD-1300 Motorcycle 

Plant 1000  

Selection date No entry  

Document type PPICOMPLAI PP Customer complaint 

Change type 003 and 004  

Change status 01 Active 

BOM usg 1  
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Simulating an Incoming Fax for ECM Using ArchiveLink 
Use 
This step simulates an incoming customer complaint received by Fax. The Fax is assigned to a 
document type which links it to the workflow template (in this case, the SAP Business Workflow 
for Engineering Change Management). 

 
This procedure assumes that the ArchiveLink functionality is available and that the 
corresponding customizing functions for ArchiveLink have been completed. If this 
has not been done, the demo script will not work. 

Procedure 
1. Call up the transaction as follows: 

Menu Path Office → Workplace → Shared folders 

Transaction Code SBWP 

2. Choose the ‘+’ to the left of the AL:DOCS folder.  

The entries under AL:DOCS are displayed. 

3. Double-click on the ECM folder. 

4. Select the Christal Clear Corp. document. 

5. Choose Document → Execute with the right-hand mouse key. 

The receipt of a fax is simulated. The ArchiveLink display function opens the Archive Link 
dialog box to see this example fax. 

6. Close the fax window to see the dialog box. 

7. In the dialog box, enter the following data: 

Field Data 

Document type PPICOMPLAI 

 
Choose the F4 input help to call up a list of possible entries. 

8. Choose . 

The Workflow utility now begins to route the invoice to the user responsible for 
processing customer complaints, (in this case WF-PP-P). 

9. Choose . 

10. Log off from this IDES system. 

 
Logon as user WF-PP-P in the next process step to process the complaint further. 
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Processing the Customer Complaint 
1. Log on to your IDES system as user WF-PP-P, password Welcome, language EN. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

3. Choose PP customer complaint. 

4. Choose . 

The fax from Christal Clear is displayed again in a separate dialog box Archive Link. 

5. Close the fax window to see the dialog box. The document type PP customer complaint is 
displayed in the dialog box. 

6. Choose Process. 

7. Enter the following data: 

Field Data 

Change number No entry 

Change type 003 

8. Choose . 

9. Enter the following data: 

Field Data 

Change number Christal complaint 

Reason for change Descriptive text, such as “Customer complaint, ignition failure” 

Change no. status 01 (active) 

10. Choose . 

11. Choose  to accept the default object types. 

12. Choose  to refresh the Workflow Inbox. 

13. Choose . 

 
Do not log off, the next step is performed by the same user. 
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Determining Material Requirements and Checking Cust. 
Complaint 
1. Make sure that you are still logged-on as User WF-PP-P (the same user as the previous 

step). You can verify this in the User field in the System → Status menu. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP; SO01; CC32 

3. Select your engineering change request and choose . 

4. Choose Goto  → Object → All objects. 

5. Choose . 

6. Enter the following data: 

7. Choose the Mater. BOM tab. 

Field Data 

Material HD-1300 

Plant 1000 

BOM usg 1 

8. Choose . 

9. Select the item, then choose . 

10. Enter the following data: 

Field Data 

Description Ignition change - wet weather problem 

Change type 004 

11. Choose Goto → Change header. 

12. Choose  (with the status management function key). 

13. Choose  Check request in the dialog box. 

The System status field now confirms the change request status to be CRTD CECR. 

14. Choose Continue. 

15. Choose . 

The Workflow Inbox (WF-PP-P) screen is displayed again. The work item remains in the 
Inbox of user WF-PP-P until all necessary actions for the change request have been 
completed. 

16. Choose  to refresh the Workflow Inbox. 

17. Choose , but do not log off. 
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In the next process step you will open another IDES session and logon as user WF-PP-E 
to further process the complaint. You can keep both windows open for the rest of this 
example, and will move back and forth between them. 
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Checking the Feasibility of the Change Request 
Use 
In light of the customer’s request, a quick review is necessary to see if a change can be made to 
solve the problem reported. Based upon review and discussion within the engineering team, a 
minor change can be made to the ignition wiring. The customer’s requested change can be 
incorporated. The change request status will be updated to reflect this decision. 

Procedure 
1. Log on to the IDES system in another session as user WF-PP-P, password Welcome, 

language EN. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP; CC32 

3. Select your engineering change request and choose . 

Two windows are opened: the Display material BOM: Material Item Overview screen and 
the Change Object Mgmt Record: Material BOM: Details screen. The Display material 
BOM: Material Item Overview screen provides more information about the various 
components in the product (Material - in this case the Harvey-Davidson GLAD BOY 
motorbike). 

4. Close the Display material BOM: Material Item Overview screen. 

5. Choose  in the Change Object Mgmt Record: Material BOM: Details screen (with the 
status management function key). 

6. Choose Change possible In the dialog box. 

The System status field now confirms the change request status to be CRTD CC01. 

7. Choose Continue. 

8. Choose . 

9. Choose . 

The work item disappears. 

10. Choose . 

You perform the next step as user WF-PP-P again. 
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Checking the Change Request 
1. Switch back to the IDES session for user WF-PP-P. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

3. Select your engineering change request and choose . 

4. When you have checked the request, choose  (with the Status Management function key). 

5. Choose  Request Checked in the dialog box. 

The System status field now confirms the change request status to be CRTD CC01. 

6. Choose Continue. 

7. Choose . 

8. Choose . 

 
Do not log off, the next step is performed by the same user. 
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Approving and Converting the Change Request 
1. Make sure that you still in the session for user WF-PP-P. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

3. Select your engineering change request and choose . 

4. Enter the following data: 

Field Data 

Valid from Today’s date (format DD.MM.YY) 

5. Choose  (with the Status Management function key). 

6. Choose  Request Approved in the dialog box. 

The System status field now confirms the change request status to be CRTD ECRC 
ECRA. 

7. Choose Continue. 

8. Choose . 

9. Choose . 

 

If Request 500000000xxx can be fulfilled is not displayed, choose  again. 

10. Select Request 500000000xxx can be fulfilled and choose . 

11. Choose  (with the Status Management function key). 

12. Choose  Fulfill Request in the dialog box. 

The System status field now confirms the change request status to be CRTD CC01. 

13. Choose Continue. 

14. Choose . 

15. Choose . 

 
In the next exercise you will be WF-PP-E once again, so that you can further process 
the complaint. 
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Setting the Completion Indicator for a Change Object 
1. Return to the user mode WF-PP-E. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

3. Select your engineering change request and choose . 

Two screens are opened in display mode. 

4. Close the Display Engineering Change Order: Material BOM: Details window by selecting 
Exit. 

 
The product developer would change the BOM in this screen to solve the ignition 
problem notified. The changes are not shown in this example. 

5. Choose . 

 
When saving the changed bill of material the system automatically sets the object 
management record to the status Change completed. The changes are released 
however, by the coordinator WF-PP-P in the next step. 

6. Choose  End Work Item. 

7. Choose . 

The work item will now be transferred do the next user responsible WF-PP-P. 

8. Choose . 

 
You perform the next step as user WF-PP-P again. 
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Completing and Releasing a Change Request 
1. Switch back to the session for user WF-PP-P. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP;CC32 

3. Select your engineering change request and choose . 

4. Choose Goto → Objects → All Objects to release the changed objects. 

5. Select the item, then choose . 

6. Choose  (with the Status Management function key). 

7. Choose  Release Change in the dialog box. 

The System status field now confirms the change request status to be CRTD CCO1 
CCOF. 

8. Choose Continue. 

9. Choose  until you return to the Change Change Request: Change header screen. 

10. Choose  (with the Status Management function key). 

11. Choose  End Request in the dialog box. 

The System status field now confirms the change request status to be ECRC ECRA 
ECCF CCFO. 

12. Choose  Release Request. 

13. Choose  in the dialog box. 

14. Confirm the change request release. 

The System status field now confirms the change request status to be ECRC ECRA 
ECCF ECCM ECOR.  

15. Choose Continue. 

16. Choose . 

17. Choose . 

The processing of this change request is now completed so the system deletes the item 
from the inbox.  

18. Choose . 
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FI Prelim. Posting. Fax Invoice Receipt, Multi-Level Rel. 
Appr. 
Purpose 
In this business scenario, you first simulate the receipt of an invoice by fax. This invoice is then 
automatically routed to an invoice entry clerk for data entry into the system. During invoice entry, 
the invoice is parked and routed to one, two, or three levels of authorizations, depending on the 
value of the invoice. 

Alternatively, you can also enter an invoice that has not arrived via Fax, for example if 
ArchiveLink is not installed. 

Special Notes 
This script makes use of the ArchiveLink simulation functionality for processing incoming faxes or 
scanned-in documents. ArchiveLink is normally set-up as part of the for the SAP R/3 System 
front-end software (SAPGUI) installation procedure. 

Four user IDs (for four positions in the IDES model company) are used during this business 
process: 

Faxed Invoice Recipient In the first step you simulate the receipt of an incoming 
fax. You use your normal IDES user ID to initiate this 
process. 

Invoice Entry Clerk WF-FI-C is used to enter the faxed invoice. 

First Level Approval Manager: User WF-FI-1 is used to release invoices for both single 
and multi-level approval. 

Second Level Approval Manager: User WF-FI-2 is used to release invoices for multi-level 
approval. 

Account Assignment Approval Agent: User WF-MM-3 is used to check and confirm the 
account assignment of the invoice. 

The Preliminary Posting Configuration rules are in the IMG: 

Tools → Business Engineering → Customizing → Implement. Projects → SAP Reference IMG → 
Financial Accounting → Financial Accounting Global Settings → Document → Parked 
Documents →... 

 

You can find more information about this process under  [Page 98]. 

Process Flow 
You can find the data for this process under  [Page 97]. 

1. Preliminary Posting of an Invoice: Simulating an Incoming Fax Document Using ArchiveLink 
[Page 99] 

2. Preliminary Posting of an Incoming Faxed Invoice [Page 101] 

3. Multi-Level Amount Approval Review and Release of Parked Documents [Page 104] 
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4. Completing the Parked Document [Page 106] 

5. Account Assignment Approval [Page 108] 
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Data Used During This Example 
Field Europe North America 

User for Faxed Invoice Recipient 
step: Simulating an Incoming 
Invoice (Faxed Document) with 
ArchiveLink 

Your normal IDES logon ID Your normal IDES logon ID 

The Invoice Entry Clerk for the 
step: Preliminary Posting of an 
Incoming Invoice (Faxed Invoice) 

WF-FI-C 

Password WELCOME 

WF-FI-C 

Password WELCOME 

First manager to approve the 
invoice in the step: Multi-level 
Amount Approval Review and 
Release of Parked Document (First 
level of approval) 

WF-FI-1 

Password WELCOME 

WF-FI-1 

Password WELCOME 

Second manager to approve the 
invoice in the step: Multi-level 
Amount Approval Review and 
Release of Parked Document 

 (Second level of approval) 

WF-FI-2 

 

Password WELCOME 

WF-FI-2 

 

Password: WELCOME 

Document date Today’s date Today’s date 

Document type KR KR 

Company code 1000 3000 

Currency DEM USD 

Posting key 31 31 

Vendor 2200 2210 

Tax code V1 I0 

Posting key 40 40 

Account 476000 476000 

Tax jurisdiction code N/Z Derived from cost center 

Cost center 4275 1000 
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Additional Process Information 
Document parking enables you to enter and save (park) incomplete FI documents in the SAP 
System without making extensive entry checks. When you park a document, the system 
allocates a document number and lets you view the parked documents online. When you park a 
vendor invoice, the system does not update the balance of the vendor. Instead, you can display 
individual item lists for this vendor and display this document in a special category, ‘Parked 
Documents’. Taking the individual item list as a starting-point, you can display the document to 
check the information. This gives you a complete overview of the vendor debits. Documents can 
be parked without triggering an approval workflow. This can be necessary, for example, if an 
invoice arrives before a service has been performed. 

Two prerequisites must be fulfilled before a document can be automatically routed for approval 
via workflow. First, the user must park the document. Second, the system analyses the amount 
of the parked document. If the amount is equal to or greater than the base trigger amount defined 
for the “workflow variant” in the Preliminary Posting configuration, the workflow is activated. The 
routing of the document and levels of approval rules are defined in Customizing for Preliminary 
Posting workflow. Once the authorizations have been released by authorized persons, parked 
documents can be completed, checked, and then posted by the system at a later date, even by a 
different data entry clerk. 

Three different levels of approval have been defined in the IDES system. 

• Under 500.00  No Approval Necessary 

• From 500.00 to 1,000.00 One Approval Level Required 

• From 1,000.00 to 10,000 Two Approval Levels Required 

• Greater than 10,000  Three Approval Levels Required 

In this business scenario the system automatically forwards an incoming invoice to a superior, if 
the invoiced amount is above DEM 500.00, but below DEM 1000.00. Further information about 
the technical realization of this demo with the SAP Business Workflow tools and the necessary 
preparations and Customizing settings can be found in the online help under R/3 Library → BC-
Basis → Business engineering workbench → SAP Business workflow → BC-Workflow 
Application Scenarios: FI - Financial Accounting  

Workflow scenarios in Financial Accounting (FI) - Preliminary Posting 

 

 

 

 

98  April 2001 



 SAP AG Cross-Application Components (CA) 

  Prelim. Invoice Posting: Simulate Incoming Fax Using ArchiveLink 

Prelim. Invoice Posting: Simulate Incoming Fax Using 
ArchiveLink 
Use 
In this section we will simulate an incoming faxed invoice and/or scanned image. The invoice is 
assigned to a document type which links it to an SAP Business workflow process - in this case 
the SAP Business Workflow for preliminary posting. The incoming image will automatically be 
routed to the data entry clerk for initial entry as an invoice into the system. 

This procedure assumes that the ArchiveLink functionality is available and that the corresponding 
customizing functions for ArchiveLink have been completed. 

Procedure 

 
If the Archive Link functionality is not available, you can enter the invoice data manually 
without workflow and skip the first processing section. Log on to your IDES system as 
user WF- FI-C, password WELCOME, language EN. Call the transaction as follows: 

Menu Path Accounting → Financial Accounting → Accounts Payable → Posting → 
Preliminary Posting of Invoice 

Transaction Code F-63 

Continue with step 7 of the section Preliminary Posting of an Incoming Faxed Invoice 
[Page 101]. 

1. In this section we will simulate the receipt of our fax. Log on to the IDES system with your 
normal user. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Shared folders 

Transaction Code SBWP 

There is a scanned document already stored in this folder which we will use to simulate 
our incoming fax. 

3. Choose the “+” before the AL:DOCS folder. 

4. Double-click on the FI folder. 

5. Select the document HTG Component 3-level. 

6. Press the right-hand mouse key and choose Execute. 

An incoming fax/scanned image is simulated. You can display this sample document with 
the ArchiveLink display function. 

7. Behind the Archive Link dialog box there is another dialog box called which proposes the 
document type FIIINVPREL. 

Choose  to confirm the proposal.  
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The Workflow now routes the invoice to the invoice data entry clerk (in this case WF-FI-
C) responsible for preliminary posting of incoming invoices. 

8. ArchiveLink is still displayed in the background. Choose File → Exit to close the ArchiveLink 
dialog box. ArchiveLink closes. 

9. Choose . 
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Preliminary Posting of an Incoming Faxed Invoice 
Use 
In this section we will log on as the invoice data entry clerk who has received the faxed invoice 
via workflow. From our inbox we will call a parked document and attach the archived document to 
it. Depending on the value of this invoice it will require one, two or three levels of approval before 
it can be released. This means that one, two or three approvers must check and release the 
document. 

Procedure 
1. Log on to your IDES system as user WF-FI-C, password WELCOME, language EN. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code FBV1 

3. Choose  to the left of the Incoming invoice preliminary posting received today. 

The system first brings up ArchiveLink and displays the scanned image, and then the 
dialog box for processing the document appears. This dialog box may be hidden behind 
the Archive Link window. 

4. Choose Process in the dialog box to continue processing. 

5. Enter the following data: 

Field Europe North America 

Document date Today’s date Today’s date 

Document type KR KR 

Company code 1000 3000 

Currency DEM USD 

Reference MLXXX (the vendor invoice number) MLXXX (the vendor invoice number) 

PstKy 31 31 

Account 2200 2210 

6. Choose . 

 
In the following step the number of approval levels is determined by the invoiced amount. 
The following steps are defined in the IDES system: 

• Under 500.00   No Approval Necessary 

• From 500.00 to 1,000.00 One Approval Level Required 

• From 1,000.00 to 10,000 Two Approval Levels Required 

• Greater than 10,000  Three Approval Levels Required 
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If you want to run the procedure with one approval level enter the amount of 850.00 
in the Amount field; for two approval levels enter 9800.00 and for three levels enter 
47,437.50. 

7. Enter the following data: 

Field Europe North America 

Amount <amount from step 6> <amount from step 6> 

Calculate tax X (mark) X (mark) 

Tax code V1 I0 

PstKy (posting key) 40 40 

Account 476000 476000 

8. Choose . 

9. Enter the following data: 

Field Europe North America 

Amount * (the amounts and tax code from the 
previous screen are used) 

* (the amounts and tax code from the 
previous screen are used) 

Tax code blank (values taken from „Preliminary 
Posting: Get Vendor Items “screen) 

blank (values taken from „Preliminary 
Posting: Get Vendor Items “screen) 

10. Choose . 

The R/3 System uses the values from the previous screen. 

11. Save your work with Document → Park. 

 
When you have performed the first process step Preliminary Posting of an Invoice: 
Simulating an Incoming Fax Document Using ArchiveLink, the ArchiveLink window is 
still displayed in the background. Choose File → Exit to close the ArchiveLink dialog 
box. 

12. Choose  to display your parked document. 

13. Call up the transaction as follows: 

Menu Path Accounting → Financial Accounting → Accounts Payable → Account → 
Display/change line items 

Transaction Code FBL1 

14. Enter the following data: 

Field Europe North America 

Vendor account  2200 2210 

Company code  1000 3000 

Open items  X (mark) X (mark) 

Parked items  X (mark) X (mark) 
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15. Choose . 

Open and parked items are displayed. Your document is displayed in the Parked items 
section of the listing and is not included in your normal accounts payable balance. 

16. Mark your parked document and choose . 

17. Choose . 

You can see in the Entry data section that this document needs to be released. 

18. Choose . 

19. To display the ArchiveLink document, choose Environment → Object Links. 

 
You can only display the ArchiveLink documents when you have performed the first 
process step Preliminary Posting of an Invoice: Simulating an Incoming Fax Document 
Using ArchiveLink. Otherwise, proceed with step 24. 

A dialog box appears. 

20. Choose Archived Documents and Continue. The R/3 System displays the scanned image of 
the invoice. 

21. To close the ArchiveLink dialog box, choose Document → Exit. 

22. Choose . 

Do not log off the IDES system as user WF-FI-C. 
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Multi-Level Amount Approval and Release of Parked 
Docs 
Use 
The approval process for multi-level approvals is similar to the single level process. The system 
routes the document to each approver based on the amount. In this section, we will log on as 
each of the two approvers and release the document. 

 
A two-level approval process is described here. A three-level amount release has been 
defined in the IDES system for invoice amounts greater than 10,000. To perform this 
process, follow the release steps and then release again with the user WF-FI-3, 
password WELCOME. 

Procedure 
1. Log on to your IDES system as user WF-FI-1, password WELCOME, language EN. Now 

perform the steps of the first person to approve the invoice. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

3. Select 19XXXXXXXX where XXXXXXX is the number of the document you created in the 
previous step. 

4. Choose . 

5. Choose Release. 

The first manager has now released the invoice. 

6. Choose . 

7. Log off from the IDES system as user WF-FI-1. 

 
If you have chosen a single-level release with an invoice amount less than 1000 
continue with the next process step –Completing the Parked Document [Page 106]. 

If the invoice amount is greater than 1000, a second accounts department clerk must 
release the invoice. 

8. Log on to your IDES system as user WF-FI-2, password WELCOME, language EN. 

9. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

10. Select the item Release amount 19XXXXXXXX where XXXXXXX is the number of the 
document you created in the previous step. 
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11. Choose . 

12. Choose Release. 

The invoice has been approved and can now be completed as described in the next 
step.  

13. Choose . 

14. Log off from the IDES system as user WF-FI-2. 

 
If you have chosen a three level release (amount > 10000), release again with the 
user WF-FI-3, password WELCOME, and repeat steps 9.-14. Then logoff user WF-
FI-3. 
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Completing the Parked Document 
Use 
During or after the amount release, the original data entry clerk or another person can enter any 
missing data to complete the invoice. Once completed, the document is automatically posted and 
its status is changed from Parked to Open. Log on with the original user ID and complete the 
parked invoice. 

Procedure 
1. Logon with the clerk user ID WF-FI-C and the password WELCOME. 

2. Call up the transaction as follows: 

Menu Path Accounting → Financial Accounting → Accounts Payable → Document → 
Parked Documents → Change 

Transaction code FBV2 

3. Choose List. 

4. Enter the following data: 

Field Europe North America 

Company code 1000 3000 

Fiscal year Current year Current year 

Document type KR KR 

Entered by WF-FI-C WF-FI-C 

 
The user ID which you enter in the selection list has to be the user ID of the data 
entry clerk, not the approver. 

5. Choose . 

6. Mark the document number and choose Select. 

7. Choose Document → Check. 

8. Enter the following data: 

Field Europe North America 

Tax code V1 I0 

Cost center 4275 4275 

9. Choose . 

The R/3 System automatically makes the default entries and makes sure that all of the 
required fields have been correctly filled. The Check successful message is sent. 

10. Choose Documents → Complete. 
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The R/3 System shows you that the parked document 19XXXXXXXX has been changed. 

11. Choose . 

12. Log off from the system as user WF-FI-C. 

 

 

April 2001  107 



Cross-Application Components (CA)  SAP AG 

Account Assignment Approval 

Account Assignment Approval 
Use 
Before posting the completed invoice, the responsible account manager has to confirm the G/L 
account which the financial agent has entered for the line item. In our example, user WF-MM-3 is 
responsible for the cost center 4275. 

Procedure 
1. Log on to your IDES system as user WF-MM-3, password WELCOME. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace → Inbox → Workflow 

Transaction Code SBWP 

3. Mark 19XXXXXXXX, where XXXXXXX is the number of the previously created document. 

4. Choose . 

5. Choose Release. 

The completed work item is removed from your inbox. The system (the preliminary 
posting workflow) updates and posts the invoice. The invoice status change is checked. 

6. Choose  to verify that the line item is now payable. 

7. Call up the transaction as follows: 

Menu Path Accounting → Financial Accounting → Accounts Payable → Account → 
Display/change line items 

Transaction Code FBL1N 

8. Enter the following data: 

Field Europe North America 

Vendor account 2200 2210 

Company code 1000 3000 

Open items X X 

Parked items X X 

9. Choose . 

The R/3 System displays the posted document under Open Items. Your document is no 
longer parked, it is payable. 

 
You may be told that the document is locked by another user. In this case, the 
workflow background step to post the document has not yet been completed. Try 
again to display the document a few seconds later. 

10. Choose . 
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Pur. Req. – Rel. Proc. with Classification and Workflow 
Purpose 
In this process, you create a purchase requisition with account assignment that is subject to a 
release strategy with classification and linked to the workflow system. You execute the entire 
release process. 

We have already entered settings in the application, under Classification System, and in 
Customizing, under Release Procedure for Purchase Requisitions. The release strategy 
comprises a three-step release procedure that allows the executive board member to use release 
code EX to release the purchase requisition for the purchase order. 

The release procedure contains the following three levels: 

Level Position Release code 

1 Technical department TD 

2 Key account KY 

3 Executive board member EX 

The release strategy is triggered if the following prerequisites are fulfilled: 

Fields Data Description 

Account assignment category K Cost center 

Material group 002 Electronics/Hardware 

Plant  1000 Hamburg 

Purchasing group 001 Dietl, B. 

Total value > 5000 EUR  

Process Flow 
You can find the data for this process under  [Page 111]. 

1. Creating a Purchase Requisition [Page 112] 

2. Releasing Purchase Requisitions Individually [Page 114] 

3. Releasing Purchase Requisitions Via the Workflow Inbox [Page 115] 

4. Rejecting Purchase Requisitions Via the Workflow Inbox [Page 116] 

5. Confirming the Rejection Via the Workflow [Page 117] 
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Data Used During This Process 
Field Data Description 

Company code  1000 IDES AG 

Plant  1000 Hamburg 

Cost center  1000 Corporate Services 

Material number R-1003 CD Multimedia 

Purchasing organization 1000 IDES Germany 

Purchasing group 001 Dietel, B. 

Process phase 1  WF-MM-1 PReq Creator 

Process phase 2  WF-MM-2 Technical dept. 

Process phase 3  WF-MM-3 Key account 

Process phase 4  WF-MM-4 Executive board member 

Password WELCOME  

Release group 01 Demo PReq 

Release code EX 

KY 

TD 

Executive board member 

Key account 

Technical dept. 

Release indicator L 

1 

2 

Blocked 

RFQ 

RFQ/Purchase order 

Release strategy TF Technical release 
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Creating a Purchase Requisition 
Use 
The person responsible wishes to order PCs for several work centers in plant 1000. 

Procedure 
1. Log on to your IDES system as user WF-MM-1, password WELCOME, language EN. 

2. Call up the transaction as follows: 

Menu Path Logistics → Materials Management → Purchasing → Purchase 
Requisition → Create 

Transaction Code ME51N 

3. Enter the following data: 

Field Data 

 
 

Purchase requis. Standard 

4. To open the item overview area, choose  Item overview. 

5. Enter the following data: 

Field Europe 

A (Account assignment category) K 

Material R-1003 

Quantity requested 500 

Delivery date Two weeks from today 

Plant  1000 

PGr (purchasing group) 001 

6. Choose . 

To skip any warning messages, choose . 

7. On the Account assignment tab page in the item detail area, enter the following data: 

Field Data 

Cost center 1000 

8. Choose . 

9. To check whether a release strategy has been determined, choose the Release strategy tab 
page. 

The release indicator is set to S for Blocked. A release strategy has been determined (TF - 
Release/BoD GE). This means that all the criteria from the release strategy have been 
fulfilled. In our case, the total value of the purchase requisition item exceeds 5000 EUR. 
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10. To check that the release is technically possible, position the cursor on  in the TD line. 

11. Choose . 

 
The system confirms the posting and assigns a document number. Make a note of 
the number that appears in the status bar. 

12. Choose  until the overview tree appears. 

 
Do not log off yet as user WF-MM-1. You will need this user when you confirm the 
rejection via the workflow in a later process step. 
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Releasing Purchase Requisitions Individually 
Use 
In the second activity, the Technical Services department checks the PC configuration. 

Procedure 
1. Log on to your IDES system as user WF-MM-2, password WELCOME, language EN. 

2. Call up the transaction as follows: 

Menu Path Logistics → Materials Management → Purchasing → Purchase 
Requisition → Release → Individual Release 

Transaction Code ME54 , ME53 

3. Enter the following data: 

Field Data 

Purchase requisition Your noted purchase requisition number 

Release code TD 

4. Choose .  

5. Select the item you want to release and choose Release + save. 

In the status line, the system informs you that the purchase requisition has been changed. 

6. Choose Purchase requisition → Display. 

7. Enter the purchase requisition number. 

8. Choose . 

9. Select your item, then choose . 

In the dialog box, the system displays the current status of the purchase requisition. The 
release indicator is S for Blocked and release TD has been effected.  

10. Choose . 

11. Choose  until the overview tree appears. 

 
Log off from the system as user WF-MM-2. 
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Releasing Purchase Requisitions Via the Workflow 
Inbox 
Prerequisites 
A senior member of staff must release the purchase requisition because their cost center will be 
charged with the costs. 

Procedure 
1. Log on to your IDES system as user WF-MM-3, password WELCOME, language EN. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace 

Transaction Code SBWP, ME54 

3. Choose Inbox → Workflow. 

Click on the workflow icon to display the work item with your purchase requisition number 
and the creation date. 

4. Select the purchase requisition number. 

5. Choose . 

6. To display the release status of the purchase requisition, choose . 

The Release Strategy Requis. XXX Item XXX dialog box appears. KY is displayed in the 
Release Code field.  

7. Choose . 

8. To release the purchase requisition, choose  Release. 

In the dialog box, you see the new release indicator 1 (requisition) and the system 
informs you that the release has already been effected. 

9. Choose . 

10. Choose . 

In the status line, the system informs you that the purchase requisition has been 
changed. 

11. To update the display, select your purchase requisition number and choose . 

The system has now deleted your work item from the inbox list. 

12. Choose  until the overview tree appears. 

 
Log off from the system as user WF-MM-3. 
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Rejecting Purchase Requisitions Via the Workflow Inbox 
Use 
The Executive Board wishes to scrutinize all purchase requisitions with order values that exceed 
a specified limit. 

Procedure 
1. Log on to your IDES system as user WF-MM-4, password WELCOME, language EN. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace 

Transaction Code SBWP, ME54 

3. Choose Inbox → Workflow. 

Click on the workflow icon to display the work item with your purchase requisition number 
and the creation date. 

4. Select your purchase requisition number, then choose . 

5. Choose Edit → Release → Reject. 

In this case, the purchase requisition is rejected and not released. The reason for the 
rejection is entered in the item note for the PReq item. 

6. Choose Goto → Texts → Text overview. 

7. In the Item Note enter the text on two lines "The specified qty cannot be justified. Please 
check". 

8. Choose . 

9. Choose . 

The system confirms that the purchase requisition has been changed. You can not repeat the 
release function. 

10. To update the display, select your purchase requisition number and choose . 

The system has now deleted your work item from the inbox list. 

11. Choose  until the overview tree appears. 

 
Log off from the system as user WF-MM-4. 
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Confirming the Rejection Via the Workflow 
1. Open the session for the user WF-MM-1. 

2. Call up the transaction as follows: 

Menu Path Office → Workplace 

Transaction Code SBWP, ME54 

3. Choose Inbox → Workflow. 

Click on the workflow icon to display the work item with your purchase requisition number 
and the creation date. 

4. Position your cursor on the released purchase requisition, then choose . 

The system has now deleted your work item from the workflow inbox. 

5. Position your cursor on the rejected purchase requisition, then choose . 

6. Choose . 

You can read the reason for the rejection in the item note. 

7. Choose  until the Business Workplace of WF-MM-1 screen appears. 

8. To update the display, select your purchase requisition number and choose . 

The system has now deleted your work item from the inbox list. 

9. Choose  until the overview tree appears. 

 
Following the rejection, the purchase requisition item is closed and cannot be 
processed further. The user therefore needs to either create a new purchase 
requisition or open a new item in the existing one. The release process then starts all 
over again. 

If you wish to create a new purchase requisition, restart at process step Creating a 
Purchase Requisition [Page 112]. 
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Evaluations in the Intranet Using the Web Reporting 
Browser 
Prerequisites 
You can only execute this process if you have an IDES system with a connection to an Internet 
Transaction Server (ITS). 

Displaying Sales Statistics of Sales Employees Via Intranet 
In this scenario, the sales manager wants to analyze the sales figures of the sales employees. To 
achieve this, the sales manager does not access the R/3 System via the SAPGUI, but starts the 
appropriate report via the Internet Browser. 

After checking the key figures, the sales manager wants to know more about one of the best-
performing employees. This transaction is also processed via a web browser. 

Process Flow 
You can find the data for this process under  [Page 119]. 

 
The processes which are performed in the Intranet are flagged: Their headers start 
with ‘In Intranet..’. 

1. Calling Up a Sales Report in the Intranet [Page 120] 

2. Displaying HR Data in the Intranet [Page 121] 
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Data Used During This Process 
Web Reporting Fields Content Description 

Login: User R/3 User ID 

Password Password Password 

Sales org. 1000 Sales organization 1000 (DE) 

Sales employee (from) 1000  

To 1999  

From month for example, 200001 Year and start month 

To month for example, 200012 Year and start month 

Job SE* Sales employee 
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Calling Up a Sales Report in the Intranet 
Prerequisites 
You can only execute this process if you have an IDES system with a connection to an Internet 
Transaction Server (ITS). 

Procedure 
1. Switch to your Internet Browser (for example, Netscape Navigator or Microsoft Internet 

Explorer). 

2. Call up the IDES Home Page, then choose your preferred language. 

 
If you do not know the internet address of the IDES Home Page, ask your system 
administrator. 

3. Call the transaction as follows: 

Menu Path Internal Services → Management Services → Reporting → Reporting 
Browser 

Transaction Code SA38 

4. Enter your user and password to access the R/3 System. 

5. Choose Logon. 

6. Call up the menu path as follows: 

Menu Path Report selection → Sales → Sales Employee → Sales → SIS: Employee Sales 
Selection 

7. Enter the following data: 

Field Content 

Sales org. 1000 

Sales employee (from) 1000 

Sales employee (to) 1999 

From month 200001 (year and start month) 

To month 200012 (year and start month) 

8. Choose Execute report. You see a list of all sales employees, the incoming orders, and their 
revenues. The lines indicated with stars are the results of the sales group manager. 

Note the name of a particular successful employee. 

9. Choose Back, until the IDES Homepage appears. 
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Displaying HR Data in the Intranet 
1. Call up the menu path as follows: 

Menu Path Internal Service → Management Services → Financials and Administration → 
Who is Who 

2. Enter the following data: 

Field Content 

Job SE* 

3. Choose Find. 

The system displays a list of all sales employees, with links. 

If you select one of the employee names – for example of a particularly successful 
employee, on the right side of the screen, you can see a picture of the employee as well 
as some organizational data. 

4. Choose the house in the top screen section to return to the IDES Homepage. 
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Sending and Receiving Messages via Intranet 
Prerequisites 
You can only execute this process if you have an IDES system with a connection to an Internet 
Transaction Server (ITS). 

Purpose 
Company employees who do not work at the main business location, or who travel frequently, do 
not always have direct access to the SAP R/3 System. This has meant, until now, that these 
employees are often cut off from important information and decision-making processes within the 
company.  

SAP now offers these employees the following possibilities via the Intranet: 

• Displaying the SAPoffice inbox with incoming messages and work items, 

• Reading folders and documents in shared folders 

• Processing user decisions in workflows via the Internet. 

 
The main focus of this IDES process is the use of SAP office functionality via Intranet. To 
see an example of processing workflow items via the internet, see Procuring 
Consumable Materials Via Internet. 

Process Flow 
Working With the Inbox in the Internet [Page 123] 
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Working With the Inbox in the Internet 
Use 
After logging on to the R/3 System via the Internet, an employer can display their Office Inbox 
and incoming mails, as well as the workflow work list. They can read documents in the inbox, 
download them to the PC and either edit them offline or delete them. Deleted documents can be 
recovered from the recycle bin. Work items implementing a user decision in a workflow can be 
processed via Internet. They can display folders and documents in the shared folders, or create 
and delete documents, if they have the corresponding authorization. Unlike the R/3 System, you 
can only create RAW type documents via Internet. 

Prerequisites 
You can only execute this process if you have an IDES system with a connection to an Internet 
Transaction Server (ITS). 

Procedure 
1. Switch to your Internet Browser (for example, Netscape Navigator or Microsoft Internet 

Explorer). 

2. Call up the IDES Home Page, then choose your preferred language. 

 
If you do not know the internet address of the IDES Home Page, ask your system 
administrator. 

3. Choose Internal Services → Management Services → Financials and Administration → Mail 
and Workflow Inbox 

4. Logon via your internet browser to the R/3 IDES system as user WF-MM-1, with password 
WELCOME and choose your desired language. 

5. Choose Office → Inbox. 

6. To see if there are any work items in your workflow inbox, choose Workflow. 

7. Choose Outbox. 

8. On the main screen area, choose Short message. 

9. At the bottom of the screen, enter WF-MM-3 as the receiver, the name of the document and 
a short text. 

10. Choose Send. 

The system informs you that the document was sent successfully. 

11. Return to the IDES Homepage.  

12. Log on to your IDES system as user WF-MM-3, password WELCOME. 

If a dialog box appears, choose . 

13. Call the transaction as follows: 

Menu Path Office → Workplace → Inbox → Unread Documents 
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Transaction Code SBWP 

Create an answer for the message and send it to user WF-MM-1. 

14. Select the document, then choose . 

15. Choose Reply. 

16. Enter your reply, then choose . 

17. Choose  in the dialog box. 

18. To check whether the message has been received via Internet; switch back to your IDES 
Homepage. 

19. Choose a language and choose Internal Service → Management Service → Finance and 
Administration → Mail and Workflow Inbox again. 

20. On the ITS Information screen, log on to the R/3 IDES System as user WF-MM-1 with 
password WELCOME and choose your desired language. 

21. Choose Inbox → Documents. 

22. Read the reply that you sent to user WF-MM-1. 

23. To delete the message, choose Delete. 

The system informs you that the document has been deleted successfully. 

24. To delete the document created earlier, choose Outbox. 

25. Select this document. 

26. Choose Delete. 

The system informs you that the document has been deleted successfully. 

27. Choose Logoff to return to the IDES Homepage. 
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