Sales & Operations Planning (LO-LIS-PLN)

Release 4.6C

SAP
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caution icon</td>
<td>Caution</td>
</tr>
<tr>
<td>Example icon</td>
<td>Example</td>
</tr>
<tr>
<td>Note icon</td>
<td>Note</td>
</tr>
<tr>
<td>Recommendation icon</td>
<td>Recommendation</td>
</tr>
<tr>
<td>Syntax icon</td>
<td>Syntax</td>
</tr>
</tbody>
</table>
Contents

Sales & Operations Planning (LO-LIS-PLN) ..................................................... 8
Basics of Sales & Operations Planning ......................................................... 11
Information Flow Between SOP and Other R/3 Applications ..................... 13
Planning Methods .......................................................................................... 14
Planning Methods at a Glance ................................................................. 16
    Example of Consistent Planning ............................................................. 17
    Examples of Level-By-Level Planning .................................................. 19
    Example of Delta Planning .................................................................... 21
Master Data .................................................................................................... 23
What Is a Planning Hierarchy? ............................................................... 24
    Planning Hierarchy Maintenance ....................................................... 26
        Master Data Generator in Flexible Planning .................................. 29
            Running the Master Data Generator in Flexible Planning .......... 31
            Creating a Planning Hierarchy .................................................... 32
            Revising the Planning Hierarchy ................................................ 33
            Mass Characteristics .................................................................. 35
                Creating Mass Characteristics ............................................. 36
            Planning Hierarchies Containing Product Groups ................. 37
            Automatic Calculation of the Constant Proportional Factors in Consistent Planning 38
            Automatic Calculation of the Constant Proportional Factors in Level-By-Level Planning 41
            Calculating the Proportional Factors Automatically ................. 43
What Is a Product Group? .......................................................................... 46
    Product Group Maintenance ............................................................... 47
        Master Data Generator in Standard SOP ....................................... 50
            Running the Master Data Generator in Standard SOP .............. 51
            Creating a Product Group .......................................................... 52
Master Data Graphics .................................................................................. 53
    Planning Hierarchy Graphic ............................................................... 54
        Calling Up a Planning Hierarchy Graphic ..................................... 55
    Product Group Graphic ....................................................................... 56
        Calling Up a Product Group Graphic ........................................... 57
    Graphical Overview of Product Group Hierarchies ......................... 58
        Calling Up the Graphical Overview of Product Group Hierarchies 59
Planning Types and Macros ......................................................................... 60
Creating a Planning Type ............................................................................ 63
    Defining the Lines in a Planning Type ............................................... 66
Defining a Macro in a Planning Type ......................................................... 69
    Macros for Stock Balance, Production, Days’ Supply, and Historical Totals 72
Translating Planning Type, Freely Defined Line, and Macro Texts ............. 76
Assigning an Event to a Planning Type ...................................................... 77
Viewing a Planning Type in Different Formats .......................................... 78
Events .......................................................................................................... 79
Creating and Scheduling a Background Job for High-Level Copying Between Information Structures ............................................................... 213
How to Execute a Macro with Mass Processing ................................................. 214
How to Transfer Data to Demand Management with Mass Processing ................. 215
  Creating a Transfer Profile ................................................................................. 216
  Transfer Profiles ................................................................................................. 217
  Creating a Planning Activity ............................................................................... 218
  Creating a Mass Processing Job .......................................................................... 219
  Scheduling a Mass Processing Job ....................................................................... 220
How to Copy a Version with Mass Processing .................................................... 221
  Copying a Planning Version with Mass Processing .............................................. 222
How to Delete a Version with Mass Processing .................................................. 223
  Deleting a Planning Version with Mass Processing ............................................. 224
How to Set Opening Stock Levels with Mass Processing ..................................... 225
  Setting Opening Stock Levels ............................................................................ 226
How to Check a Mass Processing Job ................................................................. 228
  Checking a Mass Processing Job ....................................................................... 230
Mass Job Reports ................................................................................................. 231
Defining User Methods ....................................................................................... 232
Transferring SOP Data to Other R/3 Applications .............................................. 234
Transfer to Demand Management ...................................................................... 235
  Transferring SOP Data to Demand Management Asynchronously, Online ........ 238
  Plant Distribution Quotas ................................................................................... 239
Transferring SOP Data to Profitability Analysis (CO-PA) ..................................... 241
Use of SOP Data in Cost Center Accounting ...................................................... 243
  What You Need to Know Before Transferring SOP Data to Cost Center Accounting 244
  Transferring SOP Data to Cost Center Accounting ............................................ 245
  Displaying a Report of Planned Costs at a Cost Center .................................... 246
Transferring Standard SOP Data to Activity-Based Costing .................................... 247
Application Link Enabling (ALE) .......................................................................... 248
Example of ALE Implementation ...................................................................... 249
  Using ALE with SOP .......................................................................................... 250
    SOP Distribution Scenario I ............................................................................. 251
    SOP Distribution Scenario II .......................................................................... 252
Reporting ............................................................................................................. 253
Product Group Breakdown ................................................................................. 254
Product Group Usage .......................................................................................... 255
Material Usage ..................................................................................................... 256
Planning Situation ............................................................................................... 257
Standard Analysis for Information Structure ...................................................... 258
What Is Sales & Operations Planning?

Purpose
Sales & Operations Planning (SOP) is a flexible forecasting and planning tool with which sales, production, and other supply chain targets can be set on the basis of historical, existing, and estimated future data. Rough-cut planning can also be carried out to determine the amounts of the capacities and other resources required to meet these targets.

Use SOP to streamline and consolidate your company’s sales and production operations.

SOP is particularly suitable for long- and medium-term planning.

Integration
SOP constitutes the planning functionality of the LIS information systems.

You pass on SOP plans to Demand Management (PP-MP-DEM) in the form of independent requirements. In turn, this data is fed to Master Production Scheduling (PP-MP-MPS) and Material Requirements Planning (PP-MRP).

An interface with Profitability Analysis (CO-PA) allows you to use CO-PA data as the basis for sales planning in SOP.

You can also pass on the results of SOP to Profitability Analysis (CO-PA), Cost Center Accounting (CO-OM-CCA), and Activity-Based Costing (CO-OM-CCA).

Application Link Enabling (CA-BFA-ALE) supports the distribution of data to different operating units in your enterprise.

See also Information Flow Between SOP and Other R/3 Applications [Page 13].

Features
SOP is made up of two application components:

- Standard SOP (PP-SOP)
- Flexible Planning (LO-LIS-PLN)

Standard SOP
Standard SOP comes largely preconfigured with the system.

Flexible Planning
Flexible Planning offers multiple options for customized configuration: you can plan on any organizational level, and also define the content and the layout of the planning screens.

You can process your planning data from the standpoint of almost any organizational unit (for example, sales organization, material group, production plant, product group, material) and even from the standpoint of the entire enterprise.

The planning table in which you work resembles a spreadsheet. You have enormous scope to track previous planning data, anticipate market demand, run analyses, and perform what-if simulations.

A series of mass processing functions automate the planning of large volumes of data.
What Is Sales & Operations Planning?

See also Basics of Sales & Operations Planning [Page 11].

Constraints

SOP is suitable for the planning of finished materials, but not for the planning of the materials’ component parts. The one exception is Characteristics Planning.
Basics of Sales & Operations Planning


Planning Based on Information Structures

The Sales & Operations Planning (SOP) application is based on information structures. An information structure is a statistics file containing operational data. This can be either planning data you anticipate will happen or actual data that happened. An information structure contains three kinds of information: characteristics, key figures, and a period unit. Information structures are used for data evaluation, projection, and analysis in all the logistics information systems.

To find out more about information structures, see LO Logistics Information System.

Menus

The SOP application is offered in two menus: the Standard SOP menu and the Flexible Planning menu.

With Standard SOP, you work with just one organizational unit, the product group hierarchy, and plan predefined key figures in a planning table with a set layout. All plans in Standard SOP are based on the standard information structure S076.

To access Standard SOP, choose Logistics → Production → Standard SOP from the main R/3 menu. Alternatively, from the Flexible Planning menu, choose Planning → Standard SOP.

Planning carried out in Flexible Planning, on the other hand, can be based on any information structure of your choice, either a self-defined information structure or a standard information structure. (For an explanation of these two kinds of information structure, see LO Logistics Information System.) This means you can plan any combination of organizational units and any key figures. In addition, you can design your own planning table layouts, known as planning types.

To access Flexible Planning, choose Logistics → Logistics Controlling → Flexible Planning from the main R/3 menu. Alternatively, from the Standard SOP menu, choose Planning → Flexible Planning.

You can also maintain plans using the Planning menu in the logistics information systems.

Planning Methods

Of key importance in SOP is the planning method applied to the information structure. The planning method determines how data is distributed to different corporate units. You define your planning methods in Customizing (in Set parameters for info structures and key figures). Three planning methods are available:

- Consistent planning
- Level-by-level planning
- Delta planning

See also:

SOP Planning Methods [Page 14]
Example of Consistent Planning [Page 17]
Basics of Sales & Operations Planning

Examples of Level-By-Level Planning [Page 19]
Example of Delta Planning [Page 21]
Planning Methods at a Glance [Page 16]
Information Flow Between SOP and Other R/3 Applications

SOP integrates with other applications in R/3. The figure below illustrates a typical information flow. See also What Is Sales & Operations Planning? [Page 9]
Planning Methods

SOP offers three different planning methods:

- Consistent planning
- Level-by-level planning
- Delta planning

A planning method must be set for any information structure [Ext.] you wish to plan. The planning method of an information structure is defined in Customizing for Sales & Operations Planning (in Set parameters for info structures and key figures).

Consider your choice of planning method carefully because there are significant differences between them (see Planning Methods at a Glance [Page 16]).

The planning method for the Standard SOP information structure (S076) is level-by-level planning.

The main features of each planning method are listed below.

Consistent Planning

- Data is stored at the most detailed level of the planning hierarchy.
- Planning levels are interdependent: changes made at one planning level immediately affect all other planning levels. The system performs aggregation and disaggregation at runtime.
- The proportional factors needed for this automatic disaggregation can be defined in one of two ways: either with reference to previously planned data, or in accordance with constant proportional factors. You can have the system calculate the proportional factors. For more information, see:
  - Automatic Calculation of the Proportional Factors in Consistent Planning [Page 38]
  - Calculating the Proportional Factors Automatically [Page 43]
  - Ways to Aggregate and Disaggregate in Consistent Planning [Page 194]
- Planning is based on a self-defined information structure.
- You can access planning data from any level.
- Your view on the planning table is non-hierarchical: you plan one or more characteristic value combinations.

Advantages of Consistent Planning

- Ease of use: you enter planning figures at one level and can rely on data consistency at all other levels.
- You create planning data from any perspective you want.

See Example of Consistent Planning [Page 17].
Level-By-Level Planning

- Data is stored at all planning levels.
- You can plan each planning level separately.
- Planning levels are independent of each other; plans at different levels need not necessarily be consistent.
- Both top-down and bottom-up planning are possible.
- You can have the system predefine the proportional factors of characteristic values automatically, on the basis of existing (actual or planned) data. For more information, see:
  - Automatic Calculation of the Proportional Factors in Level-By-Level Planning [Page 41]
  - Calculating the Proportional Factors Automatically [Page 43]
  - Ways to Aggregate and Disaggregate in Level-By-Level Planning [Page 198]
- Your view on the planning table is hierarchical.

Advantages of Level-By-Level Planning

- You have the chance to check and, if necessary, change your data before aggregating or disaggregating it up or down the planning hierarchy.

See Example of Level-By-Level Planning [Page 19].

Delta Planning

- Data entered at one level is aggregated automatically to higher levels at runtime.
- Changes made at one level are not automatically disaggregated. The difference remains between the sum of the individual values at the lower level and the total shown at the higher level.
  
  See Ways to Aggregate and Disaggregate in Delta Planning [Page 199].

Advantages of Delta Planning

- You do not need to create a planning hierarchy in order to plan.
- This is the planning method available for information structures in the R/3 System Release 2.1 and later.

See also: Example of Delta Planning [Page 21].
# Planning Methods at a Glance

## Comparison of the Different Planning Methods in SOP

<table>
<thead>
<tr>
<th>Function</th>
<th>Consistent</th>
<th>Level-By-Level</th>
<th>Delta</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic aggregation</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Automatic disaggregation based on factors saved in database</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Automatic time-dependent disaggregation based on previous planning data</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Create planning hierarchy</td>
<td>Yes</td>
<td>Yes</td>
<td>No (not necessary)</td>
</tr>
<tr>
<td>Planning types and macros</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Set opening stock automatically in background</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Forecast</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes (but not possible to save different forecast versions)</td>
</tr>
<tr>
<td>Events</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Resource leveling</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Background processing</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Fix key figure values in the planning table</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Long texts for versions and periods in the planning table</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Standard analysis for info structure</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Transfer to Demand Management</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>

---

**See also:**
- [SOP Planning Methods](#) [Page 14]
- [Example of Consistent Planning](#) [Page 17]
- [Examples of Level-By-Level Planning](#) [Page 19]
- [Example of Delta Planning](#) [Page 21]
Example of Consistent Planning

The following planning hierarchy exists for your information structure:

```
          S891
             |
      North
             |
-
          |
          |
   Wholesale       Retail
             |
          |
          |
  Textiles       Household goods       Electrical appliances       Furniture
             |
          |
          |
        Plush carpet       Cotton roll   Toaster      Vacuum cleaner       Coffee table       Telephone stand
```

You create a plan for information structure S891 or for a planning type based on information structure S891.

You specify sales organization NORTH in the initial dialog box. In the planning table, you can enter planning data at either the aggregate level (in this case, the sales organization level) or the detailed level (in this case, the material level).

You plan the following invoiced sales values for the first quarter at the sales organizational level, that is, at the **aggregate level**:

<table>
<thead>
<tr>
<th>January 1999</th>
<th>February 1999</th>
<th>March 1999</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>10000</td>
<td>11000</td>
<td>12000</td>
<td>USD</td>
</tr>
</tbody>
</table>

You then switch to the **detailed level** and change the planning data for material TOASTER:

<table>
<thead>
<tr>
<th></th>
<th>January 1999</th>
<th>February 1999</th>
<th>March 1999</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Old</td>
<td>2450</td>
<td>2695</td>
<td>2940</td>
<td>USD</td>
</tr>
<tr>
<td>New</td>
<td>3000</td>
<td>3500</td>
<td>4000</td>
<td>USD</td>
</tr>
</tbody>
</table>
Example of Consistent Planning

In this example, the R/3 System carries out disaggregation on the basis of the proportional factors obtained with Master data → Calculate proportions → Using planning hierarchy. For more information, see Automatic Calculation of the Proportional Factors in Consistent Planning [Page 38].

You then switch back to the aggregate level (the sales organizational level) and see that its planning data has changed:

<table>
<thead>
<tr>
<th>January 1999</th>
<th>February 1999</th>
<th>March 1999</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>10550</td>
<td>11805</td>
<td>13060</td>
<td>USD</td>
</tr>
</tbody>
</table>

The aggregate data has changed automatically to reflect the changes you made at the detailed level.

You now save your data. The following data is stored on the database:

<table>
<thead>
<tr>
<th>Product</th>
<th>January 1999</th>
<th>February 1999</th>
<th>March 1999</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plush carpet</td>
<td>750</td>
<td>825</td>
<td>900</td>
<td>USD</td>
</tr>
<tr>
<td>Cotton roll</td>
<td>1750</td>
<td>1925</td>
<td>2100</td>
<td>USD</td>
</tr>
<tr>
<td>Toaster</td>
<td>3000</td>
<td>3500</td>
<td>4000</td>
<td>USD</td>
</tr>
<tr>
<td>Vacuum cleaner</td>
<td>3050</td>
<td>3355</td>
<td>3660</td>
<td>USD</td>
</tr>
<tr>
<td>Coffee table</td>
<td>1000</td>
<td>1100</td>
<td>1200</td>
<td>USD</td>
</tr>
<tr>
<td>Telephone stand</td>
<td>1000</td>
<td>1100</td>
<td>1200</td>
<td>USD</td>
</tr>
</tbody>
</table>

Because the data at the aggregate level is always the sum of the data at the detailed level, you save data at the detailed level only.
Examples of Level-By-Level Planning

Example 1: Flexible Planning

The following planning hierarchy exists for your information structure:

```
Region
  SOUTH EAST

Plant
  LONDON

Material
  101  102  103  104  105
```

You create a plan using a planning type that is based on this information structure. You specify region SOUTH EAST and plant LONDON in the initial dialog box.

In the planning table, you can enter data at either the owner level (in this case, the plant level) or the member level (in this case, the material level).

You plan the following production quantities for the first quarter at the plant level, that is, at owner level:

<table>
<thead>
<tr>
<th></th>
<th>January 2000</th>
<th>February 2000</th>
<th>March 2000</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>20</td>
<td>21</td>
<td>22</td>
<td>PC</td>
</tr>
</tbody>
</table>

You then switch to the member level and see that no production quantities have been planned for any of the materials. You enter the following production quantities:

<table>
<thead>
<tr>
<th>Material</th>
<th>January 2000</th>
<th>February 2000</th>
<th>March 2000</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material 101</td>
<td>4</td>
<td>5</td>
<td>5</td>
<td>PC</td>
</tr>
<tr>
<td>Material 102</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>PC</td>
</tr>
<tr>
<td>Material 103</td>
<td>4</td>
<td>4</td>
<td>5</td>
<td>PC</td>
</tr>
<tr>
<td>Material 104</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>PC</td>
</tr>
<tr>
<td>Material 105</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>PC</td>
</tr>
</tbody>
</table>
Examples of Level-By-Level Planning

You then switch back to the owner level (the plant level) and see that the planned production quantities have not changed, although the sum of the member quantities is different from the owner quantity.

At this point, you can either save your plan and retain this difference, or use a macro that you have created in the planning type to cumulate the planned production quantities of the different materials and write the total to the owner level (plant level). If you use such a macro, you also need to define the proportional factors in the planning hierarchy.

For more information on proportional factors, see Automatic Calculation of the Proportional Factors in Level-By-Level Planning [Page 41].

Example 2: Standard SOP

In Standard SOP, you disaggregate the following product group (using Disaggregation → Break down product group plan):

Product group

<table>
<thead>
<tr>
<th>Material</th>
<th>Fr. Nut Bar</th>
<th>Peanut Brittle</th>
<th>Chocolate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Percentage</td>
<td>20%</td>
<td>40%</td>
<td>40%</td>
</tr>
</tbody>
</table>

On the selection screen, you select all the product group members and specify the strategies by which member sales plans and production plans are to be created. First, the product group sales plan is to be disaggregated using the proportional factors maintained in the product group master record (20%, 40%, 40%), thus creating member sales plans. In addition, the target days’ supply of the product group is to be copied to the target days’ supplies of the materials, and these target days’ supplies are to be used to create production plans for the materials.

On the planning screen, you see both the aggregated information of the owner product group CANDY BAR and the detailed information of the product group members (in this case, the materials FRUIT & NUT BAR, PEANUT BRITTLE BAR, and CHOCOLATE BAR). You change the production quantities of the material FRUIT & NUT BAR. This does not affect the production quantities displayed at owner (product group) level. You check the production quantities of the other product group members, PEANUT BRITTLE BAR, and CHOCOLATE BAR.

You now execute the Aggregate production macro. The production quantities at owner level change. They are now the sum of the member production quantities.
Example of Delta Planning

No planning hierarchy exists for your information structure. Planning hierarchies are not necessary for delta planning.

You create a planning version. On the initial screen, you specify sales organization SOUTH and distribution channel SMITH. In the planning table, you enter the following incoming order values for the first quarter:

<table>
<thead>
<tr>
<th>January 1997</th>
<th>February 1997</th>
<th>March 1997</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>40000</td>
<td>41000</td>
<td>44000</td>
<td>USD</td>
</tr>
</tbody>
</table>

You save the planning version.

You now change this planning version. On the initial screen, you specify sales organization SOUTH and distribution channel JONES. In the planning table, you enter the following incoming order values for the first quarter:

<table>
<thead>
<tr>
<th>January 1997</th>
<th>February 1997</th>
<th>March 1997</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>50000</td>
<td>50000</td>
<td>53000</td>
<td>USD</td>
</tr>
</tbody>
</table>

You save the planning version.

You now display the planning version for all distribution channels in sales organization SOUTH. On the initial screen, you specify sales organization SOUTH but no distribution channel. In the planning table, the following incoming order values are shown for the first quarter:

<table>
<thead>
<tr>
<th>January 1997</th>
<th>February 1997</th>
<th>March 1997</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>90000</td>
<td>91000</td>
<td>97000</td>
<td>USD</td>
</tr>
</tbody>
</table>

The incoming order values of the distribution channels have been aggregated automatically.

You now change the planning version at sales organization level. You specify sales organization SOUTH on the initial screen but no distribution channel. In the planning table, you change the incoming order values in the first quarter as follows:

<table>
<thead>
<tr>
<th>January 1997</th>
<th>February 1997</th>
<th>March 1997</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>100000</td>
<td>100000</td>
<td>105000</td>
<td>USD</td>
</tr>
</tbody>
</table>

You save the planning version.

You now display the planning version for sales organization SOUTH, distribution channel SMITH. The incoming order values at this level have not changed. You display the planning version for
Example of Delta Planning

sales organization SOUTH, distribution channel JONES and see that the incoming order values have not changed here either. In other words, the incoming order values at owner level have not been disaggregated to member level.

The sales organization level displays the difference between the two levels of the planning version stored on the database:

<table>
<thead>
<tr>
<th>January 1997</th>
<th>February 1997</th>
<th>March 1997</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>10000</td>
<td>9000</td>
<td>8000</td>
<td>USD</td>
</tr>
</tbody>
</table>
Master Data

Definition

In Sales & Operations Planning (SOP), you can manage plans for various types of master data:

- Manually created planning hierarchies [Page 24]
- Automatically generated planning hierarchies
- Product groups [Page 46]
- Materials

You maintain plans for planning hierarchies, or branches of planning hierarchies, in Flexible planning.

You maintain plans for product groups in Standard SOP.
What Is a Planning Hierarchy?

Definition

A planning hierarchy represents the organizational levels and units in your company for which you want to plan. A planning hierarchy is a combination of characteristic values [Ext.] based on the characteristics [Ext.] of one information structure [Ext.].

Planning hierarchies provide a framework for your planning activities in consistent planning and level-by-level planning. With these planning methods, a planning hierarchy must exist for the information structure before you can plan its key figures. You can create only one planning hierarchy for an information structure. However, a hierarchy can have as many different branches as you like. See also Planning Hierarchies Containing Product Groups [Page 37].

You can create one or more planning hierarchies automatically when you install Release 3.0, with the Master Data Generator [Page 29].

You can also create a planning hierarchy manually (see Creating a Planning Hierarchy [Page 32]). It consists of one or more planning levels to which you assign characteristic values.

You maintain planning hierarchies in much the same way as you maintain product groups, on a level-by-level basis, and define the aggregation factor and the proportional factor of each characteristic value just as you define them for the members of a product group. For more information, see Planning Hierarchy Maintenance Functions [Page 26].

Example of a Planning Hierarchy
You might extend this planning hierarchy to include further branches, such as branches to represent the organizational structure of the company in sales organizations South, East, and West.
Planning Hierarchy Maintenance

This section describes some of the functions available for maintaining a planning hierarchy [Page 24].

Adding New Members

To add a new characteristic value to an existing hierarchy, choose Master data → Planning hierarchy → Revise. See also Revising the Planning Hierarchy [Page 33].

Deleting Members

If you use the Delete member function in the Planning hierarchy → Create or Planning hierarchy -> Change function, all planned key figures in existing planning versions are also deleted. To avoid this, delete a characteristic value by choosing Master data → Planning hierarchy → Revise. See also Revising the Planning Hierarchy [Page 33].

Assigning Characteristic Values to a Planning Level

Use these functions if you create a planning hierarchy manually. Assign characteristic values to a planning level either manually, by choosing Goto → Next level or by double-clicking on the level, or by copying existing assignments with Edit → Copy from.

The Copy from function allows you to copy characteristic values [Ext.] from an owner characteristic value on the next higher level. This higher-level characteristic value must be different from the one to which you now want to assign members and which you specified in the Characteristics dialog box. Any aggregation factors, proportional factors, fixed branch indicators, or units are also copied. You can overwrite, delete, or add to this system-proposed data.

You want to define the distribution channels (characteristic values) in sales organization WEST (higher-level characteristic value). To do so, you copy the distribution channels that already exist in sales organization EAST and change the data as necessary:

1. Choose Edit → Copy from.
2. Specify the characteristic value you want to use as a reference, in this case, sales organization EAST.
3. Choose ENTER.

The required data is copied to your planning level where you are free to change it.

Moving between Planning Levels

You can create a complete multi-level planning hierarchy manually, in one processing step.

You start at the top of the planning hierarchy. To assign the characteristic values of the next lower level, you select it. You proceed in this way for as many hierarchical levels as you want. The same approach applies to the displaying of planning hierarchies.
If your planning method is consistent planning, you must specify characteristic values at all levels. This is because data is stored at the detailed level with this planning method.

To move from one planning level to the next lower level in the hierarchy, choose Goto → Next level.

**Proportional Factors**

The proportional factors determine how a key figure at one level of your organization is distributed to another level. The R/3 System uses the proportional factors in conjunction with the units of measure conversion factors to calculate planning data.

The proportional factors you see in the planning hierarchy define the relationships between characteristic values on adjacent planning levels. The initial value of a proportional factor in the planning hierarchy is 0 %. The total of the proportional factors at one level is usually 100 %, although it does not have to be. For example, you might decide to plan more than 100 % in order to have a buffer for inventory that has to be written off.

You maintain proportional factors in the planning hierarchy in the following ways:

- Enter them manually
- Use the Copy from function
  The Copy from function proposes the proportional factors of the copied characteristic values. You can change any of them manually.
- Distribute them evenly across the planning level
  The R/3 System divides 100 by the number of characteristic values on that planning level to obtain the proportional factors.
  To distribute the proportional factors evenly across all the characteristic values on a planning level, choose Edit → Distribute proportions.
- Calculate them automatically
  In consistent planning, you always calculate the proportional factors automatically—possibly in combination with one of the above methods.

**See also:**

- [Automatic Calculation of the Constant Proportional Factors in Consistent Planning](Page 38)
- [Automatic Calculation of the Proportional Factors in Level-By-Level Planning](Page 41)
- [Calculating the Proportional Factors Automatically](Page 43)

**Units**

The default units of the information structure on which your planning hierarchy is based are defined in Customizing (in Set parameters for info structures and key figures). They are:

- Period indicator
- Currency
Planning Hierarchy Maintenance

- Base unit of measure

The base units of measure of materials are taken from the material master records. If the base unit of measure if a material is different than the base unit of measure of the information structure, you must define the base unit of the information structure as an alternative unit of measure in the material master record.

See also:
- Switching Units in the Planning Table [Page 110]
- Transfer to Demand Management [Page 235]

Graphical Support

The management of planning hierarchies is supported graphically. You can display either the entire planning hierarchy or all characteristic values from the top down to the current level in the planning hierarchy. See also Master Data Graphics [Page 53].

Generating the Planning Hierarchy Automatically

See Master Data Generator in Flexible Planning [Page 29].

See also:
- Revising the Planning Hierarchy [Page 33]
Master Data Generator in Flexible Planning

The Master Data Generator creates planning objects for an information structure [Ext.] on the basis of existing or planned data, thus creating a planning hierarchy [Page 24]. You access the Master Data Generator in flexible planning with Master data → Generate master data (see Running the Master Data Generator in Flexible Planning [Page 31]).

If you wish to run the Master Data Generator, SAP strongly recommends that you do so before you start using Sales & Operations Planning. Background processing is the most suitable mode of execution for this program.

If necessary, you can change the results manually with Planning hierarchy → Change. This might happen if you want to plan a new product line that has not existed until now.

You can also reduce the number of records found by the Master Data Generator to those which are relevant for sales and operations planning. SOP allows you to define your own user method for this purpose so that the unique planning requirements of your company can be met. For more information, see Defining User Methods [Page 232].

To decide whether a user method is required to reduce the number of records included in the planning process, run the Master Data Generator with the Simulation indicator switched on. The system then tells you how many records would be generated by the Master Data Generator for a particular information structure.

After you have created a planning hierarchy with the Master Data Generator, you redefine its proportional factors. For more information, see:

- Automatic Calculation of the Constant Proportional Factors in Consistent Planning [Page 38]
- Automatic Calculation of the Proportional Factors in Level-By-Level Planning [Page 41]
- Calculating the Proportional Factors Automatically [Page 43]
- Ways to Aggregate and Disaggregate in Consistent Planning [Page 194]
- Ways to Aggregate and Disaggregate in Level-By-Level Planning [Page 198]
- Ways to Aggregate and Disaggregate in Delta Planning [Page 199]

There are two situations in which you run the Master Data Generator in flexible planning.

1. You want to plan key figures for a large number of characteristic value combinations in an information structure; for example, for a great many materials. It would take a long time to create these characteristic value combinations manually. You therefore run the Master Data Generator. The system creates a planning object for each characteristic values combination for which actual data has been recorded in this information structure.

Example of Planning Objects created by the Master Data Generator
Master Data Generator in Flexible Planning

<table>
<thead>
<tr>
<th>Sales organization</th>
<th>Distribution channel</th>
<th>Division</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planning object</td>
<td>NORTH</td>
<td>Wholesale</td>
<td>Household goods</td>
</tr>
<tr>
<td>Planning object</td>
<td>NORTH</td>
<td>Wholesale</td>
<td>Household goods</td>
</tr>
<tr>
<td>Planning object</td>
<td>NORTH</td>
<td>Wholesale</td>
<td></td>
</tr>
<tr>
<td>Planning object</td>
<td>NORTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Planning object*</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*The final level represents planning across all sales organizations.

2. You created planning data for an information structure in Release 2.2 and want to use consistent planning for this information structure in Release 3.0.

The planning method for information structures in Release 2.2 was delta planning. The system creates planning objects on the basis of the data in an existing planning version [Page 186] of your information structure.

See also:

Master Data Generator in Standard SOP [Page 50]
Running the Master Data Generator in Flexible Planning

In flexible planning, you can either have the system create the planning hierarchy [Page 24] or you can create it yourself manually. To find out how to create a planning hierarchy manually, see Creating a Planning Hierarchy [Page 32].

To have the system create a planning hierarchy:

1. From the flexible planning menu, choose Master data → Generate master data. This takes you to the Set Up Master Data screen.
2. Enter the information structure [Ext.] for which you want the planning hierarchy to be created.
3. Enter the of the information structure on which you want master data generation to be based. This will normally be the actual version, version 000.
4. If a method has been defined to restrict the number of records found by the Master Data Generator to those that are relevant for planning, enter the name of this method.
5. To define the period on which you want master data generation to be based, enter dates in the To and From fields.
6. To simulate master data generation, set the Simulation indicator. In this way, you can find out how many records would be created by the Master Data Generator and decide whether you need to create a method.
7. Choose Program → Execute/Execute + print/Execute in the background. For more information on background processing, see BC Computing Center Management System.

See also:

Master Data Generator in Flexible Planning [Page 29]
Creating a Planning Hierarchy

In flexible planning, you can either have the system create the planning hierarchy or you can create it manually. To find out how to create a planning hierarchy automatically, see Master Data Generator in Flexible Planning [Page 29].

You do not need to create a planning hierarchy for delta planning.

To create a planning hierarchy [Page 24] manually:

1. From the flexible planning menu, choose Master data → Planning hierarchy → Create. The initial screen for creating a planning hierarchy appears.

2. Enter the name of the information structure [Ext.] on which you want to base your planning hierarchy. A dialog box appears inviting you to enter values for the characteristics from your information structure.

   The units of the information structure on which you base your planning hierarchy must be defined in Customizing (in “Set parameters for info structures and key figures”).

3. If you want to define characteristic values at all levels of your planning hierarchy, leave the fields blank. Otherwise, enter one or more characteristic values corresponding to the desired hierarchical levels.

   Do not leave gaps between characteristic values; that is, for every characteristic value that you enter, you must also enter characteristic values in the fields above it.

4. To continue, choose ENTER. The data maintenance screen for the first level in your planning hierarchy appears.

5. Now enter the characteristic values that you want to be members of your planning hierarchy together with their aggregation and proportional factors. (You proceed to the next level with Goto → Next level.)

   If your planning method is consistent planning, you must specify characteristic values at all levels.

See also:

Calculating the Proportional Factors Automatically [Page 43]
Planning Hierarchy Maintenance Functions [Page 26]

6. Save the planning hierarchy.
Revising the Planning Hierarchy

Use

You can change the planning hierarchy in the following ways by choosing Master data → Planning hierarchy → Revise. This function allows you to amend whole branches of the planning hierarchy at once, rather than in individual steps as you do when choosing Master data → Planning hierarchy → Change.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a characteristic value</td>
<td>You add a characteristic value that has not existed before in the planning hierarchy. The characteristic value is added to all relevant branches of the planning hierarchy.</td>
<td>Add a characteristic value to represent a new product line or a new customer.</td>
</tr>
<tr>
<td>Delete a characteristic value</td>
<td>You cannot retrieve characteristic values that have been deleted from the planning hierarchy. No planning versions are deleted.</td>
<td>Delete a material that your company no longer produces.</td>
</tr>
<tr>
<td>Exclude a characteristic values combination</td>
<td>Any characteristic value combinations that you define as non-plannable are not deleted from the planning hierarchy: you can retrieve them at any time. You temporarily exclude a characteristic values combination that you may want to include again in a later planning process.</td>
<td>Exclude a material that is not important enough to be planned at this stage.</td>
</tr>
<tr>
<td>Include a characteristic values combination</td>
<td>You reinclude a characteristic values combination that you had temporarily excluded from the planning process.</td>
<td>Reinclude a material that has become important enough to be planned separately.</td>
</tr>
</tbody>
</table>

Activities

Before you amend the hierarchy, simulate the results first by choosing Simulation only.

<table>
<thead>
<tr>
<th>To...</th>
<th>Choose...</th>
</tr>
</thead>
</table>

April 2001 33
## Revising the Planning Hierarchy

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a characteristic value to the planning hierarchy</td>
<td>Add member. On the next screen, specify the branches of the planning hierarchy to which the characteristic value should be added. The bottom characteristic value is the new one. If you enter no values in the characteristic fields above the bottom level, the characteristic value will be added to all branches of the planning hierarchy. To copy the bottom level of an existing branch of the hierarchy (for example, all materials in a particular plant) to the new branch (for example, a new plant), choose <em>Append existing sub-tree.</em></td>
</tr>
<tr>
<td>Delete a characteristic value from the planning hierarchy</td>
<td>Delete member. On the next screen, specify the branches of the planning hierarchy from which the characteristic value should be deleted. If you enter no values in the characteristic fields, the characteristic value will be deleted from all branches of the planning hierarchy.</td>
</tr>
<tr>
<td>Temporarily exclude a characteristic values combination from the planning process</td>
<td>Set plannability and use the <em>Choose</em> pushbutton in the Values of Information Structure dialog box</td>
</tr>
<tr>
<td>To reininclude a characteristic values combination in the planning process</td>
<td>Set plannability and use the <em>Choose</em> pushbutton in the Values of Information Structure dialog box</td>
</tr>
</tbody>
</table>
Mass Characteristics

Mass characteristics allow you to plan less important materials together rather than separately or not at all. In other words, you can plan all your less important materials in one big “container”. If you create a product group containing all these materials and copy the mass characteristic’s planning data to it from Flexible Planning, you can then transfer the product group planning data to Demand Management (see Transfer to Demand Management [Page 235]).

You can add mass characteristics directly to the information structure with Master data → Mass characteristics → Create. The planning hierarchy is updated automatically in this process. The name of the mass characteristics depends on the masking symbol you specify on the selection screen. The key field of each mass characteristic is filled in its entire length with this symbol. You also specify the level at and below which mass characteristics are to be created in the planning hierarchy.

See also:

Documentation of program RMCP3INS
Creating Mass Characteristics [Page 36]
Creating Mass Characteristics

To create mass characteristics in the planning hierarchy:

1. Choose Master data → Mass characteristics → Create.
2. Enter the information structure on which your planning hierarchy is based.
3. Specify the masking symbol that will represent the mass characteristics.
4. If you want to see how the planning hierarchy would be changed before you carry out this function, select the Test indicator.
5. Choose Program → Execute.

See also:
Mass Characteristics [Page 35]
Planning Hierarchies Containing Product Groups

To plan product groups as part of a planning hierarchy, you must adopt the following approach:

1. In standard SOP, create product group hierarchies, starting with top-level product groups and finishing with materials.

2. In flexible planning, create a planning hierarchy, defining the most detailed planning level as product groups or materials and their plants. These must be the product group(s) or materials of one of the planning levels in the product group hierarchies you created in step 1.

   If you want to define product groups at the most detailed level, base the planning hierarchy on an information structure for which level-by-level planning is defined.

3. In flexible planning, plan a characteristic values combination from the planning hierarchy.

4. Copy this planning data from the most detailed level (that is, the product group or material level) to information structure S076 using SOP’s key figure copy function.

5. In standard SOP, aggregate and/or disaggregate the copied data up/down the product group hierarchies you created in step 1. Since you are planning information structure S076, the planning method in this step is always level-by-level.
Automatic Calculation of the Constant Proportional Factors in Consistent Planning

Purpose

In consistent planning, you can use constant proportional factors to disaggregate your planning data. Alternatively, you can base disaggregation on existing planned data. To find out about the different disaggregation methods in consistent planning, see Ways to Aggregate and Disaggregate in Consistent Planning [Page 194]. For a definition of disaggregation, see Concepts of Aggregation and Disaggregation [Page 189].

In consistent planning, the proportional factors maintained at individual levels of the planning hierarchy are not used directly to disaggregate data. However, the proportional factors maintained at individual levels of the planning hierarchy can serve as the basis for calculating the proportional factors of the detailed nodes (see below).

💡

The consistent planning method gives you a non-hierarchical view on your data. The role of the proportional factors is to describe the relationship between the details and the sum of the details in that part of the planning hierarchy which you are planning, as well as the relationships of the details to each other. The most detailed level in the planning table corresponds to the lowest level of the planning hierarchy or of a branch of the planning hierarchy. The aggregate (“total”) level in the planning table represents the sum of the details; it is not analogous with any level in the planning hierarchy.

The constant proportional factors are not specific to any key figure, characteristic, period, or planning version.

Process Flow

You predefine the proportional factors for consistent planning in one of two ways:

- You base the proportional factors on past history. Choose Master data → Calculate proportions → Using actual data from the flexible planning menu.

  The system totals the data (data from either the actual version, version 000, or a planning version) at the detailed level and divides the key figure of each characteristic value by this total to obtain the proportional factors.

  To see the results at the lowest level of the planning hierarchy, set the indicator Adjust plng hierarchy proportions.

Example of Constant Proportional Factors Based on Actual Data
You base the proportional factors on the proportional factors entered at individual levels in the planning hierarchy:

1. Maintain proportional factors at each level in the planning hierarchy.
2. Choose Master data → Calculate proportions → Using planning hierarchy.

The system now works out the relationships of the most detailed nodes to all other nodes.

**Example of Proportions Based on the Planning Hierarchy: Step 1**

<table>
<thead>
<tr>
<th>Detailed Node</th>
<th>Calculation</th>
<th>Proportional Factor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales organization 01</td>
<td>100%</td>
<td></td>
</tr>
<tr>
<td>Distribution channel 01</td>
<td>38%</td>
<td>60%</td>
</tr>
<tr>
<td>Division 01</td>
<td>40%</td>
<td>40%</td>
</tr>
<tr>
<td>Material 1</td>
<td></td>
<td>60%</td>
</tr>
<tr>
<td>Material 2</td>
<td></td>
<td>40%</td>
</tr>
<tr>
<td>Material 3</td>
<td></td>
<td>20%</td>
</tr>
<tr>
<td>Material 4</td>
<td></td>
<td>40%</td>
</tr>
<tr>
<td>Material 5</td>
<td></td>
<td>57%</td>
</tr>
<tr>
<td>Material 6</td>
<td></td>
<td>29%</td>
</tr>
<tr>
<td>Material 7</td>
<td></td>
<td>14%</td>
</tr>
<tr>
<td>Material 8</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Automatic Calculation of the Constant Proportional Factors in Consistent Planning

<table>
<thead>
<tr>
<th>Material</th>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>01, 01, 01, material 1</td>
<td>$65 % \times 100 % \times 38% \times 60 %$</td>
<td>14.82 %</td>
</tr>
<tr>
<td>01, 01, 01, material 2</td>
<td>$65 % \times 100 % \times 38% \times 40 %$</td>
<td>9.88 %</td>
</tr>
<tr>
<td>01, 01, 02, material 3</td>
<td>$65 % \times 100% \times 62 % \times 40 %$</td>
<td>16.12 %</td>
</tr>
<tr>
<td>01, 01, 02, material 4</td>
<td>$65 % \times 100% \times 62 % \times 20 %$</td>
<td>8.06 %</td>
</tr>
<tr>
<td>01, 01, 02, material 5</td>
<td>$65 % \times 100% \times 62 % \times 40 %$</td>
<td>16.12 %</td>
</tr>
<tr>
<td>02, 02, 03, material 6</td>
<td>$35 % \times 100% \times 100 % \times 57 %$</td>
<td>19.95 %</td>
</tr>
<tr>
<td>02, 02, 03, material 7</td>
<td>$35 % \times 100% \times 100 % \times 29 %$</td>
<td>10.15 %</td>
</tr>
<tr>
<td>02, 02, 03, material 8</td>
<td>$35 % \times 100% \times 100 % \times 14 %$</td>
<td>4.9 %</td>
</tr>
</tbody>
</table>

**Result**

If you base the proportional factors on past history, the results of this calculation are visible at the lowest level of the planning hierarchy as well as when you choose Master Data → Planning hierarchy → Revise. If you are using a planning type in which the Aggr. planning indicator is switched off, you can also choose Goto → Select details in the planning table.

If you base the proportional factors on the planning hierarchy, the results of this calculation are visible when you choose Master Data → Planning hierarchy → Revise. If you are using a planning type in which the Aggr. planning indicator is switched off, you can also choose Goto → Select details in the planning table.

If you change the planning hierarchy—for example, if you add a new product with a proportional factor—make sure that you also recalculate the proportional factors of the detailed nodes by choosing Master data → Calculate proportions → Using planning hierarchy.

**See also:**
Calculating the Proportional Factors Automatically [Page 43]
“Proportional Factors” in Planning Hierarchy Maintenance Functions [Page 26]
Automatic Calculation of the Constant Proportional Factors in Level-By-Level Planning

In level-by-level planning, disaggregation from one level to the next—insofar as it is carried out at all—is carried out separately for each level and is based on the proportional factors in the planning hierarchy. These proportional factors describe the relationship of characteristic values on adjacent levels.

For a brief outline of aggregation and disaggregation, see Concepts of Aggregation and Disaggregation [Page 189].

You can have the system calculate the proportional factors on the basis of any version of an information structure’s data. This will normally be the version containing actual data, version 000. However, should you wish to use planning data as a basis for this calculation, you simply enter the appropriate planning version in the Version field.

This calculation is performed with reference to a specified time period and key figure.

If you carry out this function in the planning hierarchy, it is single-level; that is, the system calculates proportional factors for the planning level you are currently maintaining. Choose Edit → Calculate proportions.

The system totals the data of the characteristic values at the lowest level in the planning hierarchy and cumulates it “bottom-up” through the planning hierarchy until it reaches the current planning level. It then divides the key figure for each characteristic value at this level by the total key figure. This gives the proportional factor of each characteristic value.

To have the system calculate the proportional factors at more than one level in the planning hierarchy, you choose Master data → Calculate proportions → Using actual data from the flexible planning menu. On the selection screen, you enter your selection criteria including the desired characteristic values. The function is then carried out for the specified planning level (given by the characteristic values) as well as all planning levels beneath it. Thus, if you want proportional factors to be calculated for all planning levels in the planning hierarchy, you leave the characteristic fields blank. In addition, you specify in the Operation field whether you want the calculation to be single-level or multi-level. The calculation method is as described in the previous paragraph.

The function Goto → Select details in the planning table gives you a quick overview of the proportional factors.

Example of Proportional Factors Calculated for a Planning Hierarchy
Automatic Calculation of the Constant Proportional Factors in Level-By-Level Planning

See also:

Ways to Aggregate and Disaggregate in Level-By-Level Planning [Page 198]
Calculating the Proportional Factors Automatically [Page 43]
“Proportional Factors” in Planning Hierarchy Maintenance [Page 26].
Calculating the Proportional Factors Automatically

The procedures for calculating the proportional factors automatically depend on your planning method.

Consistent Planning

You can predefine the proportional factors in one of two ways.

- To calculate the proportional factors between the total and the details on the basis of factors already saved for specific levels in the planning hierarchy:
  1. Enter proportional factors at all levels in the planning hierarchy.
  2. From the flexible planning menu, choose *Master data* → *Calculate proportions* → *Using planning hierarchy*.
  3. On the next screen, enter an information structure.
  4. Choose *Program* → *Execute*.
     
     The system now calculates the proportions at the most detailed level in the information structure as proportions of the information structure as a whole.

- To calculate the proportional factors between the total and the details on the basis of actual data or existing planned data:
  1. From the flexible planning menu, choose *Master data* → *Calculate proportions* → *Using actual data*.
  2. Enter the information structure on which the planning hierarchy [Page 24] is based.
  3. Choose *ENTER*.
     
     A dialog box appears.
  4. Enter the as well as the start and finish dates of the time frame on which you want the calculation to be based.
     
     In most cases, you enter the version that contains actual data, version 000.
  5. If you wish the results of the calculation to be shown in the planning hierarchy, select the indicator *Adjust plng hierarchy proportions*.
  6. Choose *Continue*.
     
     The Key Figure(s) box appears.
  7. Select the key figure on which you want the calculation to be based.
  8. Choose *Continue*.
     
     The system now calculates the proportions at the most detailed level in the information structure as proportions of the information structure as a whole.

Level-By-Level Planning

You can predefine the proportional factors in one of two ways. In either case, the system bases the calculation on the version of the information structure which you specify. This will normally be the version 000 which contains actual data.
Calculating the Proportional Factors Automatically

- To calculate the proportional factors of each characteristic value level by level:
  1. From the desired level of the planning hierarchy, choose Edit → Calculate proportions.
  2. Enter the as well as the start and finish dates of the planning horizon on which you want the calculation to be based.
     In most cases, you enter the version that contains actual data, version 000.
  3. Choose Continue.
     The Key Figure(s) box appears.
  4. Select the key figure on which you want the calculation to be based.
  5. Choose Continue.
     The system now calculates the proportional factors at this level in the planning hierarchy.

- To calculate the proportional factors at one or more levels in the planning hierarchy:
  1. Choose either Master data → Calculate proportions → Using actual data from the flexible planning menu or Product group → Calculate proportions from the standard SOP menu.
     In standard SOP, proceed to step 4.
  2. Enter the information structure on which the planning hierarchy is based.
  3. Choose ENTER.
     The selection screen appears.
  4. If you do not wish the calculation to be carried out at all levels, specify the characteristic values for which it is to be performed. The system then calculates proportional factors for all the characteristic values assigned to these planning levels.
  5. Enter the start and finish dates of the planning horizon on which you want the calculation to be based.
  6. Using the possible entries button, specify the key figure on which you want the calculation to be based.
  7. In the Operation field, specify whether you want the calculation to be single-level or multi-level.
  8. Enter the version on which you want the calculation to be based.
     In most cases, you enter the version of the information structure that contains actual data, version 000.
  9. Choose Program → Execute.
     The system now calculates the proportional factors for the desired levels of the planning hierarchy.

See also:
Automatic Calculation of the Constant Proportional Factors in Consistent Planning [Page 38]
Automatic Calculation of the Proportional Factors in Level-By-Level Planning [Page 41]
Ways to Aggregate and Disaggregate in Consistent Planning [Page 194]
Ways to Aggregate and Disaggregate in Level-By-Level Planning [Page 198]

“Proportional Factors” under Planning Hierarchy Maintenance [Page 26].
What Is a Product Group?

Definition

You plan product group data in standard SOP (for an explanation of standard SOP, see Basics of Sales & Operations Planning [Page 11]).

If you want to include product groups in a planning hierarchy, use level-by-level planning. Do not use the planning hierarchy function to create product group hierarchies; for this purpose, use the product group function. See also Planning Hierarchies Containing Product Groups [Page 37].

A product group combines other product groups and materials according to whatever criteria best meet the needs of your enterprise; for example, manufacturing procedure, product design, or market niche.

Product groups are classified according to whether they are multi-level or single-level.

A product group is multi-level if it contains other product groups. However, the lowest level in a product group hierarchy always consists of materials.

A product group is single-level if its members are materials only.

A material or product group can be a member of more than one owner product group.

Example of a Multi-Level Product Group

![Diagram of a multi-level product group hierarchy]
Product Group Maintenance

This topic describes some of the functions with which you can maintain product groups.

Assigning Members

You can create a complete multi-level product group hierarchy in one processing step.

You start at the root of the product group hierarchy. To create the data for a member product group, you double-click on it with the mouse. You proceed in this way for as many hierarchical levels as you want. The same approach applies to displaying product groups.

You can specify product group members either by entering them manually or by selecting them from a list of existing product groups or materials.

If you specify them manually, you must enter a description, a plant, a unit of measure, and—with the exception of internally assigned product group numbers—a number. If the product group member is a material, the system reads the description and the base unit of measure from the material master record. If the product group member is a new product group, a master record is created for it when you have made all the required entries and choose ENTER.

To select product group members from a list of master records, choose Edit → Selection list → Parameters. If the members are product groups, you must specify a unit of measure, plant, MRP controller, and/or period indicator. If the members are materials, you must specify a material type, material group, unit of measure, division, plant, ABC indicator, purchasing group, MRP type, MRP controller, and/or period indicator. To obtain the selection list, choose Continue. Now select your product group members. To include them in your product group, choose Copy.

To select product group members via the Classification system, choose Edit → Selection list → Classification.

Proportional Factors

When you disaggregate planning data, the proportional factors determine how the product group quantity is distributed to individual members. The system uses the proportional factors in conjunction with the units of measure conversion factors to calculate the members’ planning data.

The default proportional factor of each product group is 0 %. You can overwrite this value. The total of the proportional factors does not have to be 100 %. When you save or exit the product group, the system checks whether the sum of the proportional factors is 100 %. If it is not, a warning message appears.

You create proportional factors in one of three ways:

- Enter them manually
- Distributing them evenly across the planning level
  The system divides 100 by the number of product group members on that planning level to obtain the proportional factors.
- Have the system calculate them automatically
Product Group Maintenance

If you access this function from the standard SOP or flexible planning menu, and specify the information structure S076, all proportional factors in all product groups will be calculated or recalculated. Any existing proportional factors will be overwritten. Therefore, a good time to use this function is before you start creating planning data.

The system calculates the proportional factors of the product group members on the basis of actual consumption data. This calculation is performed for a planning horizon which you specify.

The system totals the consumption data of the materials at the lowest level in the product group hierarchy and cumulates it “bottom-up” until it reaches the current planning level. It then divides the quantity for each product group member at this level by the total quantity. This gives the proportional factor of each product group member.

If you carry out this function in the product group master record, the function is single-level; that is, the system calculates only proportional factors for the planning level that you are currently maintaining. You choose Edit → Calculate proportions.

To have the system calculate the proportional factors at all levels in all product group hierarchies (see note above), choose Product group → Calculate proportions from the standard SOP menu.

Units of Measure Conversion

The system determines the units of measure conversion factor if it is stored either in the central units of measure conversion table or in the material master record. You cannot change the conversion factor in Standard SOP.

If no units of measure conversion factor has been maintained, the system proposes a default value of 1.

If the product group is managed in pieces and the product group members in pairs, and there are two pieces in every pair, then the conversion factor is 2.

Cross-Plant Planning

You can assign materials or product groups from different plants to the same owner product group. This allows you to plan both product groups and materials across different plants and even company codes. Thus, you can create an initial plan to cover all plants, and then define plant-specific production quotas in a subsequent step.

Any Units of Measure Combination

A product group may have a different unit of measure than one or more of its members. This means that you can plan, for example, at an aggregate level in pallets, and at a detailed level in pieces. The units of product group members may also be different.

The required conversion factor is stored in either the material master record (for example, pieces to kilograms) or the central conversion table (for example, kilogrammes to tonnes). This allows you to:

- Group together materials with different units of measure
- Define conversion factors separately for each member
- Aggregate or disaggregate using any unit of your choice

**Generating Planning Objects for Standard SOP**
See [Master Data Generator in Standard SOP](Page 50).

**Graphical Support**
See [Product Group Graphic](Page 56) and [Graphical Overview of Product Group Hierarchies](Page 58).
Master Data Generator in Standard SOP

The Master Data Generator creates planning objects for an information structure [Ext.] on the basis of existing or planned data. You access the Master Data Generator in standard SOP with Product group → Generate master data.

If you wish to run the Master Data Generator, SAP strongly recommends that you do so before you start using Sales & Operations Planning. Background processing is the most suitable mode of execution for this program.

The Master Data Generator functions similarly in standard SOP and flexible planning (see Master Data Generator in Flexible Planning [Page 29]). However, when you run the Master Data Generator in standard SOP, the internal planning objects of the standard SOP information structure, S076, are generated from the master data of another information structure. This is any information structure specified by you which contains the characteristic “material”. If “plant” is also a characteristic of this information structure, a planning object is created in S076 for each combination of material and plant found in it. If “plant” is not a characteristic of the source information structure, planning objects are created in S076 for each plant in which a material is managed in the system (this information is stored in the material master record).

The generated planning objects are stored on the database but are not visible to the end user. However, they are needed in standard SOP for the copying of data to information structure S076 with mass processing.
Running the Master Data Generator in Standard SOP

To run the Master Data Generator in standard SOP:

1. From the standard SOP menu, choose Product group → Generate master data.
2. On the next screen, enter the information structure (not S076) from which you want the master data to be generated.
3. Choose Program → Execute/Execute + Print/Execute in the background.

For more information on background processing, see BC Computing Center Management System.

See also:

Master Data Generator in Standard SOP [Page 50]
Creating a Product Group

1. From the main menu of standard SOP, choose Product group → Create.
   The initial screen for creating a planning hierarchy appears.
2. Enter a description, a plant, a unit of measure, and—if required—a number for the product group. Both external and internal number assignment are possible.
3. Indicate whether the product group members are to be materials or product groups.
4. Choose ENTER.
   A master record is created for your product group and the screen for product group maintenance appears.
5. Specify your product group members in one of two ways:
   – Enter them manually
   – Choose them with Edit → Selection list → Parameters or Edit → Selection list → Classification
6. Enter the proportional, aggregation, and conversion factors of each product group member.
   See also Product Group Maintenance Functions [Page 47].
7. To specify master data for a member, place the cursor on it and choose Extras → Master data.
   This step is optional.
8. To assign members to a product group at the next level down, place the cursor on it and choose Goto → Assign members (or double-click on it with the mouse).
   A dialog box appears.
9. Specify whether the members are to be materials or product groups.
   Steps 8 and 9 are not relevant if your product group is single-level, that is, if you selected materials as your members on the initial screen.
10. Choose Continue.
    You can continue assigning members to product groups until your reach material level.
11. To save your product group hierarchy, choose Product group → Save.

See also:
Product Group Maintenance Functions [Page 47]
Master Data Graphics
Planning Hierarchy Graphic

Definition

The planning hierarchy graphic shows you the planning levels in your planning hierarchy. You can view up to nine levels at a time.

Displaying Characteristic Values at the Next Level Down

When you are in the graphic, you can show or hide characteristic values at the next level down using Extras → Next level → Hide or Show.

Accessing Flexible Planning Transactions

You can also branch to a number of the Flexible Planning transactions: planning hierarchy maintenance (change, display), planning (create, change, display), rough-cut planning profile (create, change, display).

The graphic remains in the background. When you exit the transaction, you return to the planning hierarchy graphic.

Refreshing the Planning Hierarchy Graphic

If you change the structure of the planning hierarchy during your processing session by adding or deleting members, you refresh the planning hierarchy graphic by choosing Extras → Refresh graphic.
Calling Up a Planning Hierarchy Graphic

1. From the Flexible Planning menu, choose Master data → Planning hierarchy → Graphics.

   The initial planning hierarchy graphic screen appears.

2. Enter the information structure whose planning hierarchy you want to see, together with the desired number of planning levels.

   If you leave the No. of levels field blank, you are invited to enter values for all characteristics in the information structure.

   The Characteristics dialog box appears.

3. Specify the characteristic values you require.

   To see all the characteristic values that have been defined as members of this information structure’s planning hierarchy, do not make any entries.

4. To continue, choose Enter.

   The planning hierarchy graphic appears.

See also:

Planning Hierarchy Graphic [Page 54]
**Product Group Graphic**

**Definition**
This graphic shows you a product group hierarchy. No materials of any product group are initially visible. What you see are the product groups in the hierarchy.

**Displaying Descriptions and Materials**
The Extras menu provides functions to show further information on a product group within the graphic. You select a product group by positioning the cursor on it and clicking with the mouse. You can now show or hide any materials that are members of this product group.

You can also show or hide a product group or material description. If you do not select a product group, the system displays all the descriptions of all product groups in the hierarchy.

**Displaying Unit of Measure and Proportional Factor**
To access additional information on a product group such as its unit of measure or proportional factor, click on the product group and choose Product group → Display.

**Accessing Standard SOP Transactions**
From within the graphic, you can choose many of the Standard SOP functions: product group maintenance (change, display), planning (create, change, display), or disaggregation (transfer to Demand Management, break down plan, display plan).

You can also carry out the planning functions for materials. You must start by selecting a node in the product group hierarchy. The product group graphic remains in the background. When you exit the transaction, you return to the graphic.

**Refreshing a Graphic**
If you change the structure of one of the product groups in your graphic by, for example, deleting or adding members, you can refresh the display of the product group hierarchy by choosing Extras → Refresh graphic.
Calling Up a Product Group Graphic

1. From the Standard SOP menu, choose Product group → Graphics → Product group.
   (Alternatively, from the Flexible Planning menu, choose Master data → Product group
   → Graphics → Product group.)
   
   The selection screen appears.

2. Specify the product group you want to process.

3. Choose Enter.

   A graphical representation of this product group hierarchy appears.

See also:

Product Group Graphic [Page 56]
Graphical Overview of Product Group Hierarchies

Definition
In contrast to the product group graphic [Page 56], the graphical overview shows you all product group hierarchies. You see the root of every hierarchy in the system. Product groups that are members of other product groups are not displayed.

Displaying Product Groups Without Members
Product groups without members are not shown since they contain no hierarchy. To display them, choose Extras → PG without members.

Displaying Descriptions
You can show or hide the description of a selected product group, or all product groups, using the Extras menu.

Calling Up a Hierarchy Graphic
From the graphical overview, you can select a specific product group hierarchy for further processing by choosing Extras → Hierarchy graphic.

You can carry out many of the Standard SOP functions from within a hierarchy graphic: product group maintenance (create, change, display), planning, disaggregation, and so on.
Calling Up the Graphical Overview of Product Group Hierarchies

From the Standard SOP menu, choose Product group → Graphics → Overview. (Alternatively, from the Flexible Planning menu, choose Master data → Product group → Graphics → Overview.)

See also:
Graphical Overview of Product Group Hierarchies [Page 58]
Planning Types and Macros

Planning Types and Macros

A planning type is a customized view on the planning table; for example, you might have one
view for the sales planner and another for the production planner.

A planning type is based on an information structure [Ext.]. This can be either a standard
information structure or a self-defined information structure. You therefore have almost infinite
possibilities with regard to the information you can plan. In other words, planning types provide a
flexible tool for the planning, storage, and analysis of any logistics data. In consistent planning,
the information structure on which a planning type is based is always self-defined.

Information structures are maintained in Customizing for the Logistics Information System (in
Maintain self-defined information structures). If you intend to use the consistent planning method
[Page 14], you must create your own information structure.

A planning type defines the content and layout of the lines in the planning table as well as the
mathematical operations, in the form of macros, which can be performed on these lines.

There are no restrictions on the number of planning types you can create for one information
structure.

💡 Planning data is saved in the information structure, not in the planning type. The
planning type merely acts as a template on the information structure. This means
that if you plan a key figure of an information structure in one planning type and save
it, and then call up the planning table for a second planning type which is based on
the same information structure and contains the same key figures, the values you
planned for the key figures in the first planning type appear.

For more information on information structures, see:

LO Logistics Information System

Implementation Guide for the Logistics Information System

Lines in a Planning Type

Contents of a Line

A line in a planning type contains one of the following:

- Planned key figure
- Actual key figure from the current year
- Actual key figure from the previous year
- Cumulative events for a key figure
- Proportional events for a key figure
- Corrected key figure as the result of the events
- User exit data
- Freely defined text or numbers
Only the planned and actual key figures are saved in the information structure. Data on the other lines is calculated or read into the planning table at runtime.

**Line Descriptions**

A line in a planning type has one of three different types of text that describe the function of the line:

- The line description is a key figure [Ext.] text from the information structure (the line refers to a key figure from the information structure on which the planning type is based).
- You define the line description yourself.
- The line description is the text of the currently planned characteristic [Ext.].

**Ready-for-Input Status of a Line**

You can set the ready-for-input status of a line. There are four options:

- Planning line
  You can plan, and therefore overwrite, the key figures on a planning line.
- Output line
  You can see, but not enter or change, key figures on an output line. You might use an output line to show the results of a macro calculation.
- Text line
  A text line has a description, but no numerical values. You might define the heading of one section of the planning table as a text line.
- Auxiliary line
  An auxiliary line is visible in the planning type, but not in the planning table. If you use only proportional events for this planning type and information structure, you might define the cumulative events line as an auxiliary line.

**Aggregation Type**

Specifies how a specific key figure from the information structure is aggregated and disaggregated if the consistent planning method is used. Alternatively, the aggregation type of a key figure can be set in the Customizing activity “Set parameters for info structures and key figures”. Three options are available:

- No aggregation or disaggregation.
- Data is totaled (aggregation) and distributed proportionally (disaggregation).
- An average is calculated.

See also:

*Ways to Aggregate and Disaggregate in Consistent Planning [Page 194]*
Planning Types and Macros

Planning Horizon
A planning type also describes a planning horizon. You can enter the number of historical periods and future periods to be shown in the planning table. Historical periods are not ready for input unless you specify otherwise.

Planning Strategies
Two planning strategies are available: either single-level (owner) or dual-level (owner and members) planning. Which strategy you use depends on the planning method. If consistent planning or delta planning has been defined for the information structure on which your planning type is based, the strategy is always dual-level planning. If level-by-level planning has been defined, you can choose between single-level and dual-level planning.

See also:
Planning Methods [Ext.]

Self-Defined Macros
A macro is a mathematical operation made up of a sequence of instructions. These instructions are carried out together when you execute the macro. It is useful to define macros for frequently required, sometimes complicated, series of instructions. Macros save time and eliminate the possibility of typing errors during the planning process. You execute a macro with a single keystroke or mouse-click.

In SOP, you use macros to perform calculations involving several lines; for example, the multiplication of one line by another line, the result of which is shown on a third line.

Standard Planning Types
Standard SOP comes with three planning types:

- SOPKAPA
  This planning type is used for the planning of individual product groups.
- SOPKAPAM
  This planning type is used for the planning of individual materials.
- SOPDIS
  This planning type is used for the dual-level planning of product group hierarchies.

These planning types are used automatically when you plan in standard SOP. You do not have to enter them before calling up the planning table.
Creating a Planning Type

Before Creating a Planning Type

A planning type is based on an information structure. A suitable information structure [Ext.] must therefore exist before you can create a planning type. You create an information structure in Customizing for the Logistics Information System (in “Maintain self-defined information structures”).

This information structure needs to have been configured in Customizing for Sales & Operations Planning before you can use it as the basis for creating plans in SOP. You carry out this configuration in the step “Set parameters for info structures and key figures”.

Where to Create a Planning Type

You can maintain planning types and macros in the Tools menu.

Alternatively, you can maintain planning types and macros in the step Maintain planning types in Customizing for Sales & Operations Planning.

How to Create a Planning Type

To create a planning type:

1. From the Tools menu, choose Planning type/macro → Create.
   
   The initial screen for creating a planning type appears.

2. Enter the name of your new planning type in the first Planning type field. It must begin with the letter Y or Z and may be up to 11 characters long.

3. If you want to base your planning type on an existing planning type:
   a) Enter the existing planning type’s name in the Copy from box
   b) To copy the line layout of the reference planning type, choose the Line layout checkbox
   c) To copy the macros of the reference planning type, choose the Macros checkbox

   If you copy the macros of the reference planning type, you must also copy its line layout. This is because the system needs to know to which lines it should apply the macros.

4. Choose ENTER.
   
   If you have specified a reference planning type, the Define Planning Type screen appears. Proceed to step 17.

   If you have not specified a reference planning type, a window appears asking you to enter an information structure.

5. Enter the name of the information structure on which you want to base your planning type.
Creating a Planning Type

Make sure that the desired planning method has been defined for this information structure.

6. Choose ENTER.

The Define Planning Type dialog box appears. If you have specified a reference planning type, the system will have copied its planning type info to the new planning type and you can proceed to step 18.

7. In the Text field, enter a text up to 60 characters long to describe your planning type.

8. If you want to plan owner data only, select the radio button for Single-level planning. If you want to plan owner and member data, select the radio button for Dual-level planning.

If consistent planning or delta planning [Ext.] has been defined for the information structure on which this planning type is based, only dual-level planning is possible.

9. If desired, select Aggr. planning and Extended selection. These checkboxes considerably affect both the functionality and the look of the planning table. For detailed information, see F1 Help.

10. Define when planning is to start:
   a) Either enter the date on which you want plans of this planning type to begin in the Planning start field.
   b) Or enter the number of periods into the future that you want plans of this planning type to begin in the Period offset field.

   The planning period of your chosen information structure as configured in the Customizing activity “Set parameters for info structures and key figures” determines whether the period is month, week, day, or posting period.

11. In the Future periods field, specify the number of future periods that you want to plan in plans of this planning type.

12. In the Historical periods field, specify the number of historical periods that you want to be displayed in plans of this planning type.

   The days between the current date and your planning start date count as "historical" and cannot be overwritten unless you select the Ready for input checkbox.

13. If you want to be able to overwrite the data in historical periods, select the Ready for input checkbox. For example, you may want to correct past planning data or revise planning data in the periods between the current date and planning start start.

14. If more than one planning period has been defined for this information structure, use F4 to select or enter time buckets grids for the past and future sections of the planning horizon.

   The planning period(s) of an information structure are defined in Customizing (in Set parameters of info structures and key figures).
15. In the Default macro field, enter the name you want to give to your default macro. This entry is optional.
   A default macro is a macro which the system runs every time the planning screen is regenerated, for example, when the user chooses ENTER. You define macros on the next screen.

16. In the Final macro field, enter the name you want to give to the macro which is run before the planning data is stored. This entry is optional.

17. In the Initial macros field, enter the name you want to give to the macro which is run when the planning data is read in. This entry is optional.

18. In the Initial display box, specify whether you want
   - Both owner and member data (Disaggregation) or
   - Just owner data (Charac.)
   to be displayed when you call up a plan of this planning type. The user can change this setting interactively in the planning table.

   You can only make this setting if dual-level planning was chosen in step 7 and level-by-level planning has been defined for the information structure.

19. To continue, choose ENTER.
   The Define Planning Type screen appears.

20. Define the lines in your planning type.
    See Defining the Lines in a Planning Type [Page 66].

21. Define the macros in your planning type.
    See Defining a Macro in a Planning Type [Page 69].

22. Assign, if necessary, events to the key figures in your planning type.
    See Assigning an Event to a Planning Type [Page 77].

23. If you want more than one language group to use this planning type, translate its language-dependent texts.
    See Translating Planning Type, Freely Defined Line, and Macro Texts [Page 76].

24. To save the planning type, choose Planning type → Save.
Defining the Lines in a Planning Type

Having created the initial definition for your planning type (see Creating a Planning Type [Page 63]), you can now define its lines.

If your planning type is dual-level and level-by-level planning is defined for the information structure, you create lines, define line attributes, assign key figures, and define macros at both owner and member level.

The initial planning table contains ten blank lines. You can assign key figures and some other types of data to these lines.

Assigning a Key Figure to a Line

To assign a key figure [Ext.] from the information structure to a line:

1. Place your cursor on the line.
2. Choose Edit → Assign structure.
   A dialog box appears inviting you to choose a key figure.
3. Choose the key figure you want to be displayed in this line.
4. To continue, choose ENTER.
   The selected key figure now appears in the planning table.
5. Repeat this procedure until you have assigned all the key figures you require in this planning type.

Creating Lines in a Planning Type

You can add extra lines in several ways:

- You choose Edit → Add line.
  A blank line appears at the bottom of the planning table.
- You choose Edit → Insert line.
  A blank line appears at the point in the planning table where you positioned your cursor.
- You choose Edit → Propose lines.
  This causes lines to appear containing all key figures from the information structure. You can delete any lines you do not need.
- You place your cursor on a key figure line and choose Edit → Actual data.
  A line is inserted below the current line. In the planning table, the actual values of this key figure will be displayed here, that is, the values from version 000. You cannot enter or overwrite values on this line.
Defining the Lines in a Planning Type

This line is useful for comparing planned data with actual data. In retail, for example, you can use it to track open-to-buy.

- You place your cursor on a key figure line and choose Edit → Actual data, previous year.

A line is inserted below the current line. In the planning table, the actual values of this key figure from the previous year will be displayed here. You cannot enter or overwrite values on this line.

This line is useful for comparing planned data with actual data from the previous year.

- You place your cursor on a key figure line and choose Edit → User exit data.

A line for external data is inserted below the current line. You can write your own coding for function module EXIT_SAPMMCP6_001 to display data—for example, auxiliary data—on this line in the planning table. The function module will be called when you create or change a plan of this planning type.

- You place your cursor on a key figure and choose Edit → Insert event.

Lines to show the values of events for this key figure are inserted. See also Assigning an Event to a Planning Type [Page 77].

Defining Line Attributes

Each line has certain attributes that define how its contents are processed and displayed in the planning table.

To define the attributes of a line:

1. Place the cursor on the line and choose Edit → Line attributes.
   The Line Attributes dialog box appears.

2. In the Line text field, enter the text that you want to be displayed on this line if it is different from the standard text. You can also enter such a text in the main planning type screen.

3. Specify a text type:
   Standard text indicates that the text comes from the key figure in the information structure.
   Freely defined text indicates that the text is entered by the user (see step 2 above).
   Planning object indicates any characteristic value, such as a material number or a work center capacity.

4. Specify the Ready for input status:
   Planning line indicates that you want to be able to plan, that is, overwrite the figures in this line.
   Output line indicates that you want to be able to see, but not enter or change, values in this line.
   Text line indicates that the line contains a text but no numerical values.
   Auxiliary line indicates that the line acts, for example, as an intermediate step, but is displayed only in the planning table definition (Goto → Format → Definition) and not in the planning table (Goto → Format → Layout).
Defining the Lines in a Planning Type

5. Check and, if necessary, change the Disaggregation type (see “Consistent Planning: Default Setting” and “Consistent Planning: Special Settings” in Ways to Aggregate and Disaggregate in Consistent Planning [Page 194]).

6. Choose Continue.
Defining a Macro in a Planning Type

The definition of macros is optional.

In the case of consistent planning, the macros for aggregation and disaggregation come predefined with the system. You do not have to write them yourself. In both consistent and level-by-level planning, a function for disaggregating a line using the predefined proportional factors is available.

See also:

Ways to Aggregate and Disaggregate in Consistent Planning [Page 194]
Disaggregating a Line Using the Proportional Factors [Page 126]

You can define a macro in one of two ways:

- with the Record function
  The Record function allows you to define a macro directly in the planning screen. It is therefore quicker than the Create function. The operands can be either texts from lines in the planning table or numerical values. The operators are displayed in the application toolbar. Standard operators are provided for the calculation of stock balance, production, days’ supply, and historical totals (see Macros for Stock Balance, Production, Days’ Supply, and Historical Totals [Page 72]).

- with the Create function
  The Create function allows you to define a macro in a separate window. You therefore see exactly how each macro is calculated. You also set two indicators that determine how the macro is handled in the planning table. The operands can be either texts from lines in the planning table or numerical values. This function is suitable for complicated macros consisting possibly of several lines.

You can also write your own coding for function module EXIT_SAPMMCP6_002 to define a highly complicated macro. See also the Implementation Guide for Sales & Operations Planning (the step “Develop functional enhancement to calculate a macro”).

To define a macro using the Record function:

1. Choose Macro → Record.
   The Define Macro dialog box appears.
2. Enter here the name and description of your macro.
   To continue, choose ENTER.
3. Choose the first line, that is, the first operand for your macro (place the cursor on it and choose Choose or double-click with the mouse).
4. From the application toolbar, choose the operation you wish to perform.
Defining a Macro in a Planning Type

5. Define the second operand for your macro (either choose a line or enter a value using the pushbutton Enter value).
6. Choose the line in which you want the results of the operation to be displayed.
7. To save your macro, choose Macro → Save.
8. To exit Record mode, choose Macro → Exit macro.
9. You can now try out your macro by entering values in the appropriate lines and choosing Macro → Execute.

To define a macro for stock balances, production, days’ supply, or a historical total using the Record function:

1. Choose Macro → Record.
   The Define Macro dialog box appears.
2. Enter here the name and description of your macro.
   To continue, choose ENTER.
3. Choose Special operation.
   See also Macros for Stock Balance, Production, Days’ Supply, and Historical Totals [Page 72].
4. Choose the desired operation and choose ENTER.
5. Choose the lines to be included in the calculation by following the instructions at the bottom of the screen (to choose a line, place the cursor on it and choose Choose or double-click with the mouse).
   The mathematical operations to be performed by this operator are recorded internally.
6. When the message Choose first line reappears, either specify further calculations or save the macro with Macro → Save.
7. To exit Record mode, choose Macro → Exit macro.
8. You can now try out your macro by entering values in the appropriate lines and choosing Macro → Execute.
   ![Note]
   You cannot try out macros for production or days’ supply in the planning type. This is because these macros depend on the number of workdays in a period and the period length is not specified in the planning type.

To define a macro using the Create function:

1. Choose Macro → Create.
   The Define Macro dialog box appears.
2. Enter here the name and description of your macro.
   To continue, choose ENTER.
3. In the first *Operand* field, enter the first operand for your macro. This operand must be a line text from the planning table.

4. Choose an operation.

5. In the second *Operand* field, enter the second operand for your macro. This operand can either be a line text from the planning table, or a number, or a blank.
   
   You leave the field blank if, for example, you want to aggregate members (first *Operand*) to owner level (*Result*).

6. In the *Result* field, enter the text of the line on which you want the macro result to appear.

7. If your macro requires more than one line for its calculation, repeat steps 3 to 6 until your macro is complete.

8. Set or not, as necessary, the *Display* and *Disregard selection* indicators.

9. Choose *Macro* → *Save*.

10. To return to the main definition screen, choose *Goto* → *Back*.

11. You can now try out your macro by entering values in the appropriate lines and choosing *Macro* → *Execute*.

To change or display an existing macro, choose *Macro* → *Edit*. To try out a macro, choose *Macro* → *Execute*. To delete a macro, choose *Macro* → *Delete*. 
Macros for Stock Balance, Production, Days’ Supply, and Historical Totals

You can use the following special operators to record a macro:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>L0</td>
<td>Stock balance</td>
</tr>
<tr>
<td>L1</td>
<td>Target stock/receipts</td>
</tr>
<tr>
<td>L2</td>
<td>Receipts</td>
</tr>
<tr>
<td>L3</td>
<td>Issues</td>
</tr>
<tr>
<td>L4</td>
<td>Target stock/issues</td>
</tr>
<tr>
<td>PR</td>
<td>Target supply/production</td>
</tr>
<tr>
<td>RW</td>
<td>Days’ supply</td>
</tr>
<tr>
<td>ZS</td>
<td>Historical total</td>
</tr>
</tbody>
</table>

The operations performed by these operators are defined internally as described below. All you need to do is specify which lines in the planning type are to represent which operands in the macro (see Defining a Macro in a Planning Type [Page 69]); for example, you might define the sales line as goods issues and the production line as goods receipts.

**Stock Balance**

The operator $L0$ *Stock balance* calculates stock levels. As the basis for this calculation, you specify goods receipts, goods issues, and (if required) an opening stock level.

For every period $i$:

\[
\text{stock level}(i) = \text{receipts}(i) + \text{stock level}(i - 1) - \text{issues}(i)
\]

where stock level $(i - 1)$ is the closing stock from the previous period

**Receipts Based on Target Stock**

The operator $L1$ *Target stock/receipts* calculates goods receipts and stock levels. You specify target stock levels, goods issues, and (if required) an opening stock level as the basis for this calculation.

For every period $i$:

\[
\begin{align*}
\text{receipts}(i) &= \text{target stock}(i) + \text{issues}(i) - \text{stock}(i - 1) \\
\text{if receipts}(i) < 0, \text{then receipts}(i) &= 0 \\
\text{stock}(i) &= \text{receipts}(i) + \text{stock}(i - 1) - \text{issues}(i)
\end{align*}
\]
Receipts
The operator L2 Receipts calculates goods receipts. You specify goods issues, stock levels, and (if required) an opening stock level as the basis for this calculation.

For every period (i):
receipts (i) = stock (i) + issues (i) - stock (i - 1)

Issues
The operator L3 Issues calculates goods issues. You specify goods receipts, stock levels, and (if required) an opening stock level as the basis for this calculation.

For every period (i):
issues (i) = receipts (i) + stock (i - 1) - stock (i)

Issues Based on Target Stock
The operator L4 Target stock/issues calculates goods issues and stock levels. You specify target stock levels, goods receipts, and (if required) an opening stock level as the basis for this calculation.

For every period (i):
issues (i) = receipts (i) + stock (i - 1) - target stock (i)
if issues (i) < 0, then issues (i) = 0
stock (i) = receipts (i) + stock (i - 1) - issues (i)

Production Based on Target Days’ Supply
The operator PR Target supply/production calculates goods receipts. As the basis for this calculation, you specify goods issues, target days’ supply, and (if required) an opening stock level. In the macro, you record which lines represent goods issues and goods receipts; typically, you define the sales line as goods issues and the production line as goods receipts. The system works out for each period the quantity that will need to be received (that is, produced) in order to cover both sales and target days’ supply in the current period, where one day’s supply is the quantity sold in the next period divided by the number of workdays in that period.

<table>
<thead>
<tr>
<th>Key Figure</th>
<th>0 column</th>
<th>Month 1 (20 workdays)</th>
<th>Month 2 (19 workdays)</th>
<th>Month 3 (23 workdays)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Issues (sales)</td>
<td></td>
<td>190</td>
<td>230</td>
<td></td>
</tr>
<tr>
<td>Target days’ supply</td>
<td></td>
<td>15</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Opening stock level</td>
<td></td>
<td>100</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Receipts (production)</td>
<td></td>
<td>50</td>
<td>190</td>
<td>80</td>
</tr>
</tbody>
</table>
This is what happens when target days’ supply exceeds the number of workdays in the month.

### Key Figure

<table>
<thead>
<tr>
<th>Key Figure</th>
<th>0 column</th>
<th>Month 1</th>
<th>Month 2</th>
<th>Month 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workdays</td>
<td></td>
<td>20</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>Issues (sales)</td>
<td>1000</td>
<td>1200</td>
<td>1400</td>
<td></td>
</tr>
<tr>
<td>Target days’ supply</td>
<td>24</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Opening stock level</td>
<td>100</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Receipts (production)</td>
<td>(1000-100) + 1200/20<em>20 + 1400/20</em>4 = 2380</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Days’ Supply

The operator **RW Days’ supply** calculates days’ supply. As the basis for this calculation, you specify stock levels and goods issues. Typically, you define the sales line as goods issues. The system works out the days’ supply in a period according to the closing stock level and goods issues (that is, sales) in that period.

<table>
<thead>
<tr>
<th>Key Figure</th>
<th>Month 1 (20 workdays)</th>
<th>Month 2 (19 workdays)</th>
<th>Month 3 (23 workdays)</th>
<th>Month 4 (22 workdays)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Issues (sales)</td>
<td>200</td>
<td>190</td>
<td>230</td>
<td>220</td>
</tr>
<tr>
<td>Stock</td>
<td>0</td>
<td>100</td>
<td>200</td>
<td>...</td>
</tr>
<tr>
<td>Days’ supply</td>
<td>0</td>
<td>10</td>
<td>20</td>
<td>...</td>
</tr>
</tbody>
</table>

Days’ supply is calculated only up to the end of the planning horizon, even if stocks would last for longer.

### Historical Total

The operator **ZS Historical total** calculates the sum of all the historical values of a chosen key figure, and displays the result in the first future period of either the same or a different key figure. You use this operator to calculate a backlog such as open orders.

In this context, historical periods are historical periods that have not been defined as ready for input in the planning type.
Translating Planning Type, Freely Defined Line, and Macro Texts

If you want more than one language group to be able to use a planning type, you need to translate the planning type text as well as any freely defined line texts and macro texts so that they are available in systems with different logon languages.

You implement Application Link Enabling in order to carry out sales and operations planning in distributed systems around the world.

To translate planning type, freely defined line and macro texts:

1. In the planning type, choose Go to → Translation.
   A window appears showing the planning type text(s) in the top half of the screen and any freely defined line texts in the bottom half of the screen.

2. In the To language field, enter your target language.
   The source language (your logon language) is displayed in the field above.

3. Choose Continue.
   The fields for the planning type and freely defined texts in the target language are ready for input.

4. Enter your translations.

5. Choose Macro texts.
   The bottom half of the screen now shows the macros defined for this planning type.

6. Enter your translations of the macro texts on the bottom right of the screen.

7. To flag your translations of all texts for saving and return to the planning table, choose Adopt texts.
   The translations will be saved when you save the planning type.
Assigning an Event to a Planning Type

You create events in the Tools menu of standard SOP or flexible planning. To make them visible while you are planning an information structure, you need to assign them to a planning type based on this information structure.

To assign events to a planning type:

1. Place the cursor on the key figure to which the events will apply.
2. Choose Edit → Insert event.
   - Three lines are inserted below the selected key figure line:
     - A line for cumulative events
     - A line for proportional events
     - A line for the corrected planning results
3. From the dialog box that now appears, choose a key figure. The contents of the Corrected line will automatically be copied to this key figure line. This means that the corrected planning results become directly available on the database for copying to another information structure or for transfer to Demand Management. However, this key figure line is not visible in the planning table because the system defines it as an auxiliary line.
4. To see the effect of these changes, save the planning type.
Viewing a Planning Type in Different Formats

You can view a planning type in

- either Definition mode (Goto → Format → Definition)
- or Layout mode (Goto → Format → Layout).

In Definition mode, you see all the lines that have been defined. In Layout mode, you see the lines that will be visible during planning; these do not include auxiliary lines.

In addition, there are a number of formats that apply only to the level-by-level planning method in dual-level planning types:

- owner data only (Goto → Format → Owner)
- member data only (Goto → Format → Member)
- owner data and all members at the lower level (Goto → Format → Dual-level → All members)
- owner data and just one member at the lower level (Goto → Format → Dual-level → One member)
Events

The statistical forecast allows you to make projections on the basis of historical data. For more information, see Planning Table: the Forecast [Page 146].

In addition, SOP comes with a function that allows you to predict the impact of events whose influence on your logistics plans cannot be derived from historical patterns. For example, you can record the following situations as events:

- Changes in price such as promotions
- Special deals with major customers
- Special deals with vendors
- Management overrides
- Delivery problems of a competitor
- Market intelligence

A typical event curve is shown in the figure below:

The corrected sales curve represents the effect of a promotion. Sales figures increase during week 1 (07/99) and climb further in week 2 (08/99) as word of the promotion spreads. In week 3 (09/99), sales are still up on the original prediction. In weeks 4 (10/99) and 5 (11/99), there is a drop in sales since market demand is temporarily satisfied. By week 6 (12/99), the impact of the promotion has become negligible.
Examples of Events

Cumulative Event

Your event type is cumulative and your period length is two weeks. You forecast normal sales in sales organization MAINE at 5,000 tonnes for each two-week period of the next quarter. In the fifth period, you also expect to do a deal with a major customer and make an extra sale of 2,000 tonnes. Therefore, your sales predictions for the quarter are as follows:

<table>
<thead>
<tr>
<th></th>
<th>W1+2</th>
<th>W3+4</th>
<th>W5+6</th>
<th>W7+8</th>
<th>W9+10</th>
<th>W11+12</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td>5000</td>
<td>5000</td>
<td>5000</td>
<td>5000</td>
<td>5000</td>
<td>5000</td>
<td>Tonnes</td>
</tr>
<tr>
<td>Event</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>2000</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>Total sales</td>
<td>5000</td>
<td>5000</td>
<td>5000</td>
<td>5000</td>
<td>7000</td>
<td>5000</td>
<td>Tonnes</td>
</tr>
</tbody>
</table>

Proportional Event

Your event type is proportional and your period length is two weeks. You forecast normal sales in sales organization TEXAS at 1,000 tonnes for each two-week period of the next quarter. In the first three periods, you also intend to run a promotion and increase your sales by 20 %, 30 %, and 10 % respectively. In the two periods following the promotion, you expect demand to be 10 % less than normal. Therefore, your sales predictions for the quarter are as follows:

<table>
<thead>
<tr>
<th></th>
<th>W1+2</th>
<th>W3+4</th>
<th>W5+6</th>
<th>W7+8</th>
<th>W9+10</th>
<th>W11+12</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>Tonnes</td>
</tr>
<tr>
<td>Event</td>
<td>+20%</td>
<td>+30%</td>
<td>+10%</td>
<td>-10%</td>
<td>-10%</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>Total sales</td>
<td>1200</td>
<td>1300</td>
<td>1100</td>
<td>900</td>
<td>900</td>
<td>1000</td>
<td>Tonnes</td>
</tr>
</tbody>
</table>
Event Management

You store events in event master records.
The use of events in SOP consists of three procedures:

- Creating an event [Page 84]
- Assigning the event to a planning type [Page 77]
- Viewing the impact of the event in the planning table

Points to Note When Creating an Event

Event Type
An event can be one of two types:

- Cumulative
  You define the event as a whole number or numbers, which are then added to or subtracted from a key figure.
- Proportional
  You define the event as a percentage of a key figure.

Event Status
An event can have one of two statuses:

- Active
- Inactive

If an event is inactive, it is stored in the system but not planned in the planning table. You can reset the status of an event at any time in the List of Assignments (see Changing an Event [Page 86]).

Event Period
An event always exists with reference to one or more time periods. The event period must be either one of periods in your time buckets grid, if you have maintained one, or the fixed planning period of the information structure. The number of periods is freely definable; for example, 2 days, 3 weeks, 2 months, or 1 posting period. If you choose posting period, you must also specify a fiscal year variant. On the first definition screen, you enter cumulative or proportional values for as many time periods as you expect to be affected by the event.

Assignment to an Information Structure
You always specify the information structure to which the event applies. On a second definition screen, you then specify the characteristic value(s), the key figure(s), and the planning version(s) of the information structure which you expect to be affected by the event. The planning version(s) must be planning version that you have already created in the system.

An event cannot be assigned to an information structure whose planning method is delta planning.
Event Management

Next to the selected planning versions, you enter an assignment date. This is the date on which you want the event to come into effect, that is, the beginning of the first event period. The default assignment date is the current date. If you enter several assignment dates, the impact of the event becomes visible in all the selected planning versions on all these dates.

You can also set the status of the event to active or inactive, and enter a description of the assignment for each information structure version.

**Points to Note When Assigning the Event to a Planning Type**

To make an event visible in the planning table, you need to include lines for it in the planning type. This is a planning type based on the information structure to which you have assigned the event. The key figure for which you include event lines is the key figure to which the event has been assigned. The lines represent cumulative events, proportional events, and the corrected values.

You must also choose a key figure to which the Corrected line is automatically copied. The system defines this key figure as an auxiliary line. Since the corrected values are automatically saved in this key figure, they are available on the database for copying to another information structure or for transfer to Demand Management.

For more information, see Assigning an Event to a Planning Type [Page 77].

**Points to Note When Viewing an Event in the Planning Table**

The results of an event become visible when you plan using the planning type to which the event is assigned and change data for the key figure(s) and characteristic values combination defined in the event. You see the original key figure values, total cumulative events for this key figure, total proportional events for this key figure, and the corrected values. In order to make the results of an event visible in the Corrected line of the planning table, you must change the original planning figures and resave the planning version. In periods where you have not changed the original planning figures, the impact of the events is not shown in the Corrected line even if you have resaved the planning version.

In consistent planning, the Details view on the planning table must be active. In level-by-level planning, the view on the planning level (characteristic value) to which the event is assigned must be active.

The system applies the event starting on the assignment date specified in the event master record. If the event period is different from the period unit in which the planning table is displayed (normally the storage periodicity [Page 97]), the system automatically distributes the event values to the correct periods.

The amount of a cumulative event in consistent planning is disaggregated to the planning objects for which it is active. Disaggregation [Page 194] is based on the proportional factors saved on the database, not on the temporary factors.

By double-clicking in the left-hand column of the planning table, you can see the results of individual events. This function is particularly useful if you have more than one cumulative or proportional event.

See also:
What Kind of Information Can I Record in an Event? [Page 79]
Examples of Events [Page 80]
Creating an Event [Page 84]
Changing an Event [Page 86]
Assigning an Event to a Planning Type [Page 77]
Creating an Event

1. From the flexible planning or standard SOP menu, choose Tools → Event → Create. The initial screen for creating events appears.

2. Either enter an event number in the field of that name or leave the field blank, depending on whether you want to assign the number internally or externally.

   An externally assigned number can be numeric or alphanumeric. If it is numeric, the system checks that it falls within the allowed number range.

3. To continue, choose ENTER.

   The General Information box appears.

4. Enter a description, define the event type and event status, and specify the length of an event period.

5. Choose Continue.

   The first event definition screen appears.

6. Enter values for the event in the desired periods.

   If the event is cumulative, you enter positive or negative numbers in the Value changed column. These numbers give the values by which the key figure changes.

   If the event is proportional, you enter percentages in the Change column. These express, as percentages, the new key figure values. When you choose ENTER, the percentages by which the key figure values change are displayed in the Changed by column.

7. Choose Goto → Assignment.

   A dialog box appears.

8. Enter the name of the information structure to which you want to assign the event.

9. Choose Continue.

   The second event definition screen appears.

10. Specify the characteristic value(s) which will be affected by the event.

11. Select the key figure which will be affected by the event.

    You can scroll in this list by clicking on it with the cursor and using the arrow keys on your keyboard.

12. Select the version(s) of the information structure to which you want the event to apply.

    You can only select planning versions that have already been created in the system.

13. For each version that you select, enter next to it an assignment date. Entry of a description is optional.

14. If you want to create another assignment, choose Event → Flag assignment and then choose Goto → Other info structure.

15. Enter the same or a different information structure.

16. Repeat steps 9 to 14 until you have assigned the event to as many information structures as you need.
17. To save the event master record, choose *Event* → *Save*.

**See also:**

*Event Management [Page 81]*
Changing an Event

1. From the flexible planning or standard SOP menu, choose Tools → Event → Change.
   The initial screen for changing events appears.
2. Either enter an event number in the field of that name or search for one.
   To search for an event, do one of the following:
   - Choose Event → Overview for a list of all existing events and then choose one.
   - Enter an information structure and then specify the desired characteristic value combination.
   The Event Value(s) screen appears.
3. To change the status of the event:
   a) Choose Goto → List of assignments.
   b) Check the boxes of any planning objects whose event status you want to change.
   c) Choose Edit → Change assignment status.
      The changed statuses will be saved when you save the event.
4. To delete specific planning objects from the event altogether:
   a) Choose Goto → List of assignments.
   b) Check the boxes of any planning objects which you want to delete from this event assignment.
   c) Choose Edit → Delete selected lines.
      Your changes will be saved when you save the event.
5. To create a new assignment for the event, choose Goto → Assignment and follow steps 8 to 16 in Creating an Event [Page 84].
6. To save the changed event, choose Event → Save.
Displaying an Event

1. From the flexible planning or standard SOP menu, choose Tools → Event → Display.
   The initial screen for displaying events appears.

2. Either enter an event number in the field of that name or search for one.
   To search for an event, do one of the following:
   - Choose Event → Overview for a list of all existing events and then choose one.
   - Enter an information structure and then specify the desired characteristic value combination.
   The Event Value(s) screen appears.

3. To view the rest of the information recorded in this event, choose Goto → Event header or List of assignments.
Planning Table: Structure, Navigation, and Display

This section explains the structure and concepts of the planning table, and describes how to display and navigate in it.

Introduction

Structure and Concepts of the Planning Table [Page 89]
Standard Planning Table [Page 96]
Accessing the Planning Table in Standard SOP [Page 95]
Accessing the Planning Table in Flexible Planning [Page 90]
Period Units [Page 97]

Functions

Changing the Period Unit in the Planning Table [Page 99]
Selecting Columns in the Planning Table [Page 105]
Setting the Decimal Places of Key Figures [Page 104]
Switching Display Formats in Standard SOP [Page 102]
Switching Display Formats in Flexible Planning [Page 100]
Selecting Details in the Planning Table [Page 106]
Displaying Selection Criteria in the Planning Table [Page 118]

Reporting in the Planning Table [Page 117].
Viewing Data in Microsoft Excel [Page 116]
Maintaining/Displaying a Planning Version [Page 115]
Creating a Long Text for a Planning Version [Page 114]
Creating a Long Text for a Period [Page 113]
Calculating Row Totals [Page 112]
Choosing Header Info [Page 111]
Switching Units in the Planning Table [Page 110]
Structure and Concepts of the Planning Table

You carry out sales and operations planning in the “planning table”. The planning table is made up of two areas:

- a header area
- an input matrix

The appearance of these two areas depends on which master data and which key figures you are planning.

Header Area

The header area shows which master data you are planning. This may be a characteristic values combination [Page 24], a product group [Page 46], or a material. You also see information on the planning version [Page 186]: the name of the version, the description of the version, and whether the version is active or inactive. See also Choosing Header Info [Page 111].

Input Matrix

The input matrix is laid out in rows and columns. In the left column, you see which key figures are being planned; by switching to the key figure view [Page 100], you can also see which characteristic values are being planned. In the right column, you see the unit [Page 110] (unit of measure, currency, or time unit) in which the key figure is recorded. In the other columns, you enter values for your key figures. Each of these columns represents a time bucket [Page 97]. The period of time that it represents is displayed in the column header. To scroll through the planning horizon, use the scroll buttons in the application toolbar.

Split Planning Screen

The split planning screen shows aggregate data in the top half and detailed data in the bottom half. You can work in a split planning screen if:

- you are disaggregating a product group plan in standard SOP (Disaggregation → Break down product group plan)
- you are carrying out level-by-level planning for an information structure whose planning type is defined as dual-level
Accessing the Planning Table in Flexible Planning

Prerequisites

1. If you want to plan with the consistent or level-by-level planning method, create an information structure. You do this in Customizing for the Logistics Information System under Maintain information structure.

2. Set the parameters of this information structure in Customizing for Sales & Operations Planning under Set parameters of info structures and key figures.

3. Fill your information structure with actual data in one of the following ways:
   - Either define updating for the information structure. Do this in Customizing for the Logistics Information System.
   - Or copy the data from another source, for example, another information structure, using Copy Management. You find Copy Management in Customizing for the Logistics Information System.

4. If you want to plan with the consistent or level-by-level planning method, create a planning hierarchy [Page 24]. See Creating a Planning Hierarchy [Page 32] and Master Data Generator in Flexible Planning [Page 29].

5. If you wish to plan using a self-defined planning screen, create a planning type.

Procedure

1. From the flexible planning menu, choose Planning → Create/Change/Display. Alternatively, you can access the planning table via the Planning menu in any of the logistics information systems.

2. Enter the desired planning type or information structure.

   ![Tip]

   You can enter either a planning type or an information structure in the field Planning type. It is important that the desired planning method has been set in Customizing for Sales & Operations Planning (in Set parameters for info structures and key figures).

3. Specify the characteristic values combination or combinations you want to plan.

   If you are using either an information structure or a planning type for which the Extended selection indicator has been set, you can enter ranges of values for each characteristic. Moreover, you can save this selection criteria as a variant. You can then use this variant again and again to plan the same characteristic value combinations.

4. If you are in Change or Display mode, use the Active version or Inactive version pushbuttons to select a version (an active version or one of the inactive versions).

5. Choose ENTER.

   The planning table appears.

6. If you are in Create or Change mode, maintain your data.

   See Planning Table: Structure, Navigation, and Display [Page 88], Planning Table: Data Maintenance [Page 119], and Planning Table: the Forecast [Page 146].
7. Save your data.

Planning data is saved in the information structure [Ext], not in the planning type. The planning type merely acts as a template on the information structure. This means that if you plan a key figure of an information structure in one planning type and save it, and then call up the planning table for a second planning type which is based on the same information structure and contains the same key figure, the values you planned for the key figure in the first planning type appear.

See also:

Examples of How to Access the Planning Table in Flexible Planning [Page 92]
Examples of How to Access the Planning Table in Flexible Planning

How to Access Consistent Planning: Example 1

You create a plan based on a planning type that has been defined by your company. **Consistent planning** has been set as the planning method for the information structure on which this planning type is based. The *Extended selection* indicator has been set in this planning type. You specify the characteristic values as follows:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Characteristic values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>Canada, USA</td>
</tr>
<tr>
<td>Plant</td>
<td>Toronto, Montreal, Chicago</td>
</tr>
<tr>
<td>Material</td>
<td></td>
</tr>
</tbody>
</table>

This means that you are planning all materials produced at plants Toronto, Montreal, and Chicago in the regions Canada and USA. These materials are at the bottom level of the planning hierarchy [Page 24] you created for this information structure.

How to Access Consistent Planning: Example 2

You create a plan based on a planning type which has been defined by your company. **Consistent planning** has been set as the planning method of the information structure on which this planning type is based. You specify the following characteristic value:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Characteristic value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales organization</td>
<td></td>
</tr>
<tr>
<td>Distribution channel</td>
<td></td>
</tr>
<tr>
<td>Division</td>
<td>01</td>
</tr>
<tr>
<td>Material</td>
<td></td>
</tr>
</tbody>
</table>

This means you are planning all the materials in division 01 as well as all sold-to parties, sales organizations, and distribution channels to which division 01 belongs, that is, all characteristic value combinations which include division 01. The characteristic values are all defined in the planning hierarchy [Page 24] which has been created for this information structure.

How to Access Consistent Planning: Example 3

You create a planning version based on a self-defined information structure for which **consistent planning** has been defined. You specify the characteristic values as follows:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Characteristic values</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Examples of How to Access the Planning Table in Flexible Planning

<table>
<thead>
<tr>
<th>Purchasing organization</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Material group</td>
<td>Fluids, solids</td>
</tr>
<tr>
<td>Material</td>
<td></td>
</tr>
<tr>
<td>Plant</td>
<td>Pennsylvania</td>
</tr>
</tbody>
</table>

This means that you plan all the materials in material groups FLUIDS and SOLIDS which are managed in plant PENNSYLVANIA. Moreover, all the key figures in your information structure appear in the planning table.

**How to Access Level-By-Level Planning**

You create a plan based on a planning type which has been defined by your company. *Level-by-level planning* has been set as the planning method of the information structure on which this planning type is based. You specify the characteristic values as follows:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Characteristic value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales organization</td>
<td>0001</td>
</tr>
<tr>
<td>Distribution channel</td>
<td></td>
</tr>
<tr>
<td>Division</td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td></td>
</tr>
</tbody>
</table>

This means that you are planning sales organization 0001. In the planning table, you can disaggregate manually to distribution channel level. The distribution channels in this sales organization are defined in the planning hierarchy [Page 24] which has been created for this information structure. You will plan the divisions and the materials separately.

**How to Access Delta Planning**

You create a plan based on standard information structure S001 for which *delta planning* is defined. You specify the characteristic values as follows:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Characteristic values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sold-to party</td>
<td>1</td>
</tr>
<tr>
<td>Sales organization</td>
<td>0001</td>
</tr>
<tr>
<td>Distribution channel</td>
<td>01</td>
</tr>
<tr>
<td>Division</td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td></td>
</tr>
</tbody>
</table>

This means you are planning all sales made to sold-to party 1 through distribution channel 01 in sales organization 0001. Any planning data that has already been maintained for these
Examples of How to Access the Planning Table in Flexible Planning

characteristic values and this version at division or material level is aggregated and displayed when you enter the planning table.
Accessing the Planning Table in Standard SOP

To access the planning table in standard SOP:

1. From the standard SOP menu, choose Planning → For product group → Create/Change/Display or Planning → For material → Create/Change/Display.

2. Enter the product group or material that you want to plan, together with its plant.

3. If you are in Change or Display mode, use the Active version or Inactive version pushbuttons to select a version (an active version or one of the inactive versions).

4. Choose ENTER.

   The planning table appears.

5. If you are in Create or Change mode, maintain your data.

   For information on data maintenance in the planning table, see Planning Table: Data Maintenance [Page 119] and Planning Table: the Forecast [Page 146].

6. Save your data.
Standard Planning Table

The standard planning table is the planning table you use in standard SOP. It is made up of six lines containing key figures for:

- **Sales**
  You plan sales quantities in the sales line.

- **Production**
  You plan production quantities in the production line.

- **Stock level**
  The stock level derived from your sales and production figures is displayed on this line. You cannot overwrite it.

- **Target stock level**
  You can generate a production plan from a sales plan in conjunction with the values you enter on this line and the selected strategy “target stock level”.

- **Days’ supply**
  The days’ supply is shown on this line. You cannot overwrite it.

- **Target days’ supply**
  You can generate a production plan from a sales plan in conjunction with the values you enter on this line and the selected strategy “target days’ supply”.

For information on planning functions specific to standard SOP, see:

- Sales Plans in Standard SOP [Page 137]
- Sales Plans in Standard SOP: Copying Data from SIS [Page 138]
- Copying Data from SIS [Page 139]
- Sales Plans in Standard SOP: Copying Data from CO-PA [Page 140]
- Copying Data from CO-PA to Standard SOP [Page 141]
- Production Plans in Standard SOP [Page 143]
- Creating a Production Plan in Standard SOP [Page 144]
- Setting an Opening Stock Level Manually in Standard SOP [Page 145]
Period Units

Use

The period unit or units of the planning table is defined by the storage periodicity of the information structure. You set this storage periodicity in Customizing (in Set parameters for info structures and key figures). The period unit of the standard SOP information structure (S076) is posting period.

The start of the planning horizon and the number of plannable periods are defined in the planning type [Page 60].

You can move around the planning horizon in the planning table using the scroll buttons on the bottom right.

Information structures that use level-by-level planning do not require a storage periodicity to be defined in Customizing, although it is possible to define one. If an information structure uses level-by-level planning and has no storage periodicity, you call it up in the period unit in which it was last saved.

In consistent planning, you can plan using more than one period indicator. For these period indicators, you generate a technical period that is saved in the form of a fiscal year variant. You maintain the forecast period in the Period ind. field of the forecast profile.

Activities

The following example explains how to plan in weeks and months.

1. Set the following information structure parameters for this function in Set parameters of info structures and key figures:
   a) Press F4 on the Planning periods field. (The Storage periodicity field is not ready for input.)
   b) In the planning periods box on the next screen, enter 'W' and 'M' in the PI column.
   c) Enter a name for your technical fiscal year variant. This name should consist of two letters.
   d) Enter a generation horizon. This horizon should encompass the planning horizon—both past and future periods—that you wish to plan with this information structure.
   e) Save these settings.

   A technical fiscal year variant is automatically generated. You return to the information structure parameters screen. The name of your technical fiscal year variant (see step 1c) appears as the fiscal year variant. A 'G' appears in the Planning periods field. This 'G' stands for generated.

   Exactly which weeks and which months are displayed in the planning table depends on the time buckets grid. A time buckets grid specifies the number and sequence of the time buckets that you wish to plan. You define and assign a time buckets grid in the planning type.

2. Create a time buckets grid in your planning type [Page 60] as follows:
   a) Create the following time buckets grid for future periods:
b) Create the following time buckets grid for historical periods:

<table>
<thead>
<tr>
<th>Selection</th>
<th>Sequence</th>
<th>Number</th>
<th>Remaining</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weeks</td>
<td>1</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Months</td>
<td>2</td>
<td>11</td>
<td>x</td>
</tr>
</tbody>
</table>

The planning table looks like this:

| 11 months | 4 weeks | | 4 weeks | 11 months |
|-----------|---------| |---------|-----------|
| Historical periods | | | Future periods | |
Changing the Period Unit in the Planning Table

You can change the period unit of either the entire planning horizon or a preselected part of it on the following conditions:

- The planning method of your information structure is level-by-level (standard SOP or flexible planning).
- No storage periodicity has been defined for the information structure in Customizing (in Set parameters for info structures and key figures).

You can plan in days, weeks, months, or posting periods. You can also disaggregate part of the planning horizon on a time basis: the system then breaks it down into smaller period units.

Most changes of period unit are possible. However, the system does not allow you to switch between month and posting period.

- Changing the period unit of the entire planning horizon
  To change the period unit of the entire planning period, choose *Edit → Period split → Total* and the desired option.

- Changing the period unit of part of the planning horizon
  To change the period unit of part of the planning horizon, select this block in the planning table and then choose *Edit → Period split → Selective* and the desired option.

- Disaggregating part of the planning horizon on a time basis
  To disaggregate part of the planning horizon on a time basis (for example, from week to day), select this block in the planning table and then choose *Edit → Period split → Selective → Time-based disaggregation (disagg.)*.

See also:

Period Units [Page 97]
Switching Display Formats in Flexible Planning

In flexible planning, you can view the planning table in a number of different display formats:

- **Goto → Total**
  
  This takes you to the aggregate view on your data.
  
  If the planning method is **consistent planning** and the *Aggr. planning* indicator has been set in the planning type, you drill up one level in the planning hierarchy. If the planning method is consistent planning and the *Aggr. planning* indicator has not been set in the planning type, you see the total key figure values for all selected characteristic value combinations.

  If the planning method is **level-by-level planning**, you see the total key figure values at owner level. The owner characteristic value is the last characteristic value you specified in the Characteristics box before entering the planning table. You can also use the pushbutton *Owner* to carry out this function.

  If the planning method is **delta planning**, you see the total key figure values at the level above the detailed level.

- **Views → Member**
  
  This takes you to the detailed view on your data.
  
  If the planning method is **consistent planning** and the *Aggr. planning* indicator has been set in the planning type, you drill down one level in the planning hierarchy. If the planning method is consistent planning and the *Aggr. planning* indicator has not been set in the planning type, you see the key figure values at the most detailed level of the characteristic values combination. This is often the material level.

  If the planning method is **level-by-level planning**, you see the key figure values at member level. The member level is one level below the owner level in a planning hierarchy. You can also use the pushbutton *Member* to carry out this function.

  If the planning method is **delta planning**, you see the key figure values at the detailed level. This is the last characteristic value you specified in the characteristics box before entering the planning table.

- **Goto → Next detail**
  
  This takes you from the current characteristic values combination at this hierarchy level to the next characteristic values combination.

  In level-by-level planning, you can also use the pushbutton *Next member* to carry out this function.

- **Goto → Previous detail**
  
  This takes you from the current characteristic values combination at this hierarchy level to the preceding characteristic values combination.

  In level-by-level planning, you can also use the pushbutton *Previous member* to carry out this function.

- **Views → Key figure format**
  
  Place your cursor on a key figure before you choose this option.
If the planning method is level-by-level planning, or if the planning method is consistent planning and the *Aggr. planning* indicator has been set in the planning type, you see the values of the key figure for characteristic values at the next lower level. If the planning method is consistent planning and the *Aggr. planning* indicator has not been set in the planning type, you see the values of this key figure for all characteristic values at the detailed level. In either case, the sum of the key figure values appears in the top line of the input matrix.

You can view the characteristic values in the left column as either numbers or texts: choose Settings → Characteristic display → Description or Settings → Characteristic display → Number.

**See also:**

Choosing Header Info [Page 111]

- **Views → All key figures**
  
  If the planning method is consistent planning and the *Aggr. planning* indicator has been set in the planning type, this takes you from the key figure format back to all the key figures at the owner planning level.

- **Views → All members**
  
  This shows you the values of all key figure for all characteristic values at the detailed (consistent planning) or member (level-by-level planning) level.
Switching Display Formats in Standard SOP

If you are disaggregating a product group plan in standard SOP, you can view the planning table in a number of different formats:

- **Goto → Owner**
  This takes you to the aggregate view on your data.

- **Views → Member**
  This takes you to the detailed view on your data.

- **Goto → Next member**
  In the detailed view on your data, this takes you from the current member to the next member.

- **Goto → Previous member**
  In the detailed view on your data, this takes you from the current member to the preceding member.

- **Views → All members**
  This takes you to the owner view and all member views on the data.
Setting the Decimal Places of Freely Defined Lines

Purpose
You want to make the decimal places of self-defined planning type lines visible in the planning table.

You have recorded the following macro in your planning type:

– Planned incoming orders - planned invoiced sales = NotSold
  (that is, the difference between orders taken and orders billed)

No decimal places are visible for the line “NotSold” in the planning table. This is because the line does not have a unit.

Process Flow
1. Create an additional structure for your information structure, and give it the name ZSxxxZ, where Sxxx is the name of the information structure. To do this, choose Tools → ABAP/4 Workbench → Development → Dictionary.

2. In the additional structure, create a field with a data element for the self-defined line. In the above example, you would create a field for “NotSold.”

   Choose a reference field with the required number of decimal places.

3. Change your planning type by adding to it the key figure you created in step 2. Key figures in additional structure ZSxxxZ are automatically offered to you in planning types based on information structure Sxxx. In the above example, you would choose the key figure “NotSold.” You would define this key figure as the macro’s result line.

Result
The number of decimal places of the reference field determines the number of decimal places of the new key figure that are visible in the planning table.

See also:
Setting the Decimal Places of Key Figures [Page 104]
ABAP Dictionary (R/3 Library under Basis)
Implementation Guide for the Logistics Information System
Setting the Decimal Places of Key Figures

To change the number of decimal places of key figure [Ext.] values in the planning table:

1. Place your cursor on the key figure and characteristic value whose number of decimal places you want to change.

2. Choose Settings → Places after point.

   A dialog box appears.

3. In the field No. places after pt., enter or change the number of decimal places of the chosen key figure. This key figure is displayed in the field to the left.

4. To confirm the use of these settings and return to the planning table, choose ENTER.

   The specified number of decimal places is now displayed for that key figure and characteristic value.

The number of decimal places saved on the database is determined by the Global Settings made in Customizing for that unit (unit of measure or currency unit). If no entry has been made in Customizing, the number of decimal places saved for this key figure and characteristic value is the number of decimal places shown in the planning table at the time of saving. If the key figure has no displayable unit (for example, if it is a percentage), all the decimal places are saved.

To cut off any decimal places in excess of the specified number, set the indicator Fix places after pt. You thereby lose the decimal places in excess of those you have fixed.

See also:

Setting the Decimal Places of Freely Defined Lines [Page 103]
Selecting Columns in the Planning Table

You can select sections of the planning table for further processing. For example, you might select a section of the planning table and change its period split in order to plan in greater detail; or you might decide to run the forecast for a limited section of the planning horizon.

- **Selecting individual period splits**
  
  To select a period split, double-click on that column or position the cursor on its heading, and choose `Edit → Select → Select periods`.

- **Selecting a block**
  
  To select a block, select the first and the last period split in the block.

- **Selecting all period splits starting from a specific column**
  
  To select all periods starting from a specific column, position the cursor on the period heading in that column and choose `Edit → Select → Select from column`.

- **Deselecting all periods**
  
  To deselect all periods, choose `Edit → Select → Deselect periods`.

- **Deselecting all period splits starting from a specific column**
  
  To deselect all periods starting from a specific column, position the cursor on the period heading in that column and choose `Edit → Select → Deselect from column`. 
Selecting Details in the Planning Table

Use
You gain a quick overview of all the characteristic value combinations you are planning, together with their proportional factors.

In consistent planning, you can use this function if you are planning with a planning type in which Aggr. planning has not been selected.

Activities
In the planning table, choose Goto → Select details.

See also:
Examples of Detail Selection in Consistent Planning [Page 107]
Examples of Detail Selection in Level-By-Level Planning [Page 109]
Examples of Detail Selection in Consistent Planning

The following planning hierarchy exists for your information structure:

You specify sales organization North on the initial screen. The following characteristic values combinations are shown in the *Select Member(s)* dialog box:

<table>
<thead>
<tr>
<th>Sales organization</th>
<th>Distribution channel</th>
<th>Division</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>North</td>
<td>Wholesale</td>
<td>Textiles</td>
<td>Plush carpet</td>
</tr>
<tr>
<td>North</td>
<td>Wholesale</td>
<td>Textiles</td>
<td>Cotton roll</td>
</tr>
<tr>
<td>North</td>
<td>Wholesale</td>
<td>Household goods</td>
<td>Toaster</td>
</tr>
<tr>
<td>North</td>
<td>Wholesale</td>
<td>Household goods</td>
<td>Vacuum cleaner</td>
</tr>
<tr>
<td>North</td>
<td>Retail</td>
<td>Electrical appliances</td>
<td>Toaster</td>
</tr>
<tr>
<td>North</td>
<td>Retail</td>
<td>Electrical appliances</td>
<td>Vacuum cleaner</td>
</tr>
<tr>
<td>North</td>
<td>Retail</td>
<td>Furniture</td>
<td>Coffee table</td>
</tr>
<tr>
<td>North</td>
<td>Retail</td>
<td>Furniture</td>
<td>Telephone stand</td>
</tr>
</tbody>
</table>

The following planning hierarchy exists for your information structure:
Examples of Detail Selection in Consistent Planning

![Diagram showing the selection of planning objects.]

You specify material Toaster on the initial screen. The following planning objects are shown in the Select Member(s) dialog box:

<table>
<thead>
<tr>
<th>Sales organization</th>
<th>Distribution channel</th>
<th>Division</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>North</td>
<td>Wholesale</td>
<td>Household goods</td>
<td>Toaster</td>
</tr>
<tr>
<td>North</td>
<td>Retail</td>
<td>Electrical appliances</td>
<td>Toaster</td>
</tr>
</tbody>
</table>
Examples of Detail Selection in Level-By-Level Planning

Example of Detail Selection in Flexible Planning

The following planning hierarchy exists for your information structure:

```
Purchasing organization

---------------------------------------------
Vendor

---------------------------------------------
Material

LIGHTING

BULBS & SONS

40w 60w 100w
```

You specify purchasing organization LIGHTING and vendor BULBS & SONS in the initial dialog box. The following information is shown in the Select Member(s) dialog box:

<table>
<thead>
<tr>
<th>Selection indicator</th>
<th>Material</th>
<th>Proportional factor</th>
<th>Aggregation factor</th>
<th>Fixing indicator</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>40w</td>
<td>50</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>60w</td>
<td>30</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>100w</td>
<td>20</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

Example of Detail Selection in Standard SOP

In standard SOP, you disaggregate the active version of the planning data for product group HIKING BOOTS. This product group contains the materials WOMEN'S CLIMBERS, MEN'S CLIMBERS, WOMEN'S CROSS-COUNTRY, and MEN'S CROSS-COUNTRY.

The dialog box that appears when you choose Goto → Select member(s) shows the information that is stored in the product group master record for all members of the product group HIKING BOOTS; that is, for the materials WOMEN'S CLIMBERS, MEN'S CLIMBERS, WOMEN'S CROSS-COUNTRY, and MEN'S CROSS-COUNTRY.
Switching Units in the Planning Table

You can change the unit of a key figure in the planning table. If you change a currency unit, the values of that key figure are automatically converted to the new currency. If you change a unit of measure, the system converts the quantities of that key figure provided that one of the following conditions is fulfilled:

- Conversion is possible via the SI system (e.g. 1 tonne = 1000 kg)
- You are planning a specific material at the detailed level and the necessary conversion factor has been defined in the material master record.

You can change the unit of a key figure in two ways:

- By overwriting it
- By using the options Settings → Units → Planning unit and Settings → Units → Hierarchy unit

The planning unit is the unit set for the planned information structure in Customizing (in "Set parameters for info structures and key figures"). The hierarchy unit is the unit set for the characteristic value in the planning hierarchy or, if the characteristic value is a material, the base unit of measure of the material.

See also:

Transfer to Demand Management [Page 235]
Choosing Header Info

You can display a maximum of six characteristics in the planning table’s header at any one time. The header information varies depending on whether the total view or a more detailed view on the planning table is active.

To define which characteristics you want to be displayed in the header:

1. In the planning table, choose Settings → Choose header info.
   A dialog box of characteristics appears.
2. Number the characteristics in the order in which you want them to be displayed.
3. To continue, choose ENTER.
   The requested header information now appears.

To change the sequence of the characteristic values in the first column of the key figure view, switch to the detailed view and proceed as described above. Then switch to the key figure view.
Calculating Row Totals

You can display the sum of a key figure’s values on a chosen line of the planning table. The sum is displayed before the start of the planning horizon. Six options are available:

<table>
<thead>
<tr>
<th>To calculate the sum of a key figure’s values:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>In the visible section of the planning horizon</td>
<td>1. Place your cursor on the line of the key figure whose total you want to be displayed.</td>
</tr>
<tr>
<td></td>
<td>2. Choose Settings → Show row totals → Current columns.</td>
</tr>
<tr>
<td>Throughout the planning horizon</td>
<td>1. Place your cursor on the line of the key figure whose total you want to be displayed.</td>
</tr>
<tr>
<td></td>
<td>2. Choose Settings → Show row totals → All columns.</td>
</tr>
<tr>
<td>In a selected section of the planning horizon</td>
<td>1. Select [Page 105] the section of the planning table whose key figures you wish to be added together.</td>
</tr>
<tr>
<td></td>
<td>2. Choose Settings → Show row totals → Selected columns.</td>
</tr>
<tr>
<td>In all historical periods (in this context, historical periods are those that are not ready for input)</td>
<td>Choose Settings → Show row totals → Historical periods.</td>
</tr>
<tr>
<td>In all future periods</td>
<td>Choose Settings → Show row totals → Future periods.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>To hide row totals:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Choose Settings → Show row totals → Hide.</td>
</tr>
</tbody>
</table>
Creating a Long Text for a Period

The planning table comes with a function that allows you to store a long text relating to a particular period. For example, you might write a long text to explain the sudden increase or decrease of a key figure in a particular period.

Procedure

1. Create a planning type [Page 60] and insert a line above the key figure lines.
2. Define the attributes of this line as follows:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Attribute value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line description</td>
<td>Planned characteristic</td>
</tr>
<tr>
<td>Ready for input status</td>
<td>Text line</td>
</tr>
</tbody>
</table>

3. Plan using this planning type. At the desired planning level, double-click on the new line in the period you want to annotate, or place your cursor in the period and choose Extras → Long text: period.

A text editor screen appears showing the current version and date on the first line.

4. Enter a text.

5. Choose Text → Save.

6. Before leaving the planning table, save your plan. Otherwise, the long text will not be saved.

Annotation icons are visible at any planning level and in any period for which you created a long text. To see the long text of a period, double-click on its icon.
Creating a Long Text for a Planning Version

The planning table comes with a function for storing a long text for a planning version. You might write a long text to explain, for example, the purpose of a particular planning version.

Procedure

1. Create a planning type [Page 60] and insert a line above the key figure lines.
2. Define the attributes of this line as follows:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Attribute value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line description</td>
<td>Planned characteristic</td>
</tr>
<tr>
<td>Ready for input status</td>
<td>Text line</td>
</tr>
</tbody>
</table>

3. Plan using this planning type. At the desired planning level, double-click on the new line in the first column of the planning table, or choose Extras → Planning version → Long text: version.

A text editor screen appears showing the current version and date on the first line.

4. Enter a text.
5. Choose Text → Save.
6. Before leaving the planning table, save your plan. Otherwise, the long text will not be saved.

Annotation icons are visible in the first column of the planning table at any planning level for which you have created a version long text. To see the long text of a planning version, double-click on its icon.
Maintaining/Displaying a Planning Version

You can maintain the description of a planning version and view its administrative data from within the planning table.

To call up planning version data:

1. Choose Extras → Planning version → Maintain/display.
   
   A window appears showing the planning version number, the planning version description, the fiscal year variant, and the planning version’s administrative data.

2. If necessary, change the version description by overtyping it.

3. To continue working in the planning table, choose ENTER.
   
   Any changes you have made to the planning version description are saved when you save the overall plan.

See also:

Creating a Long Text for a Planning Version [Page 114]
Viewing Data in Microsoft Excel

To download your planning data direct from the planning table to Microsoft Excel:

1. Choose Extras → Microsoft Excel.
   A dialog box appears.

2. Enter the path name where the excel.exe file is to be found on your computer.

3. Choose Continue.
   Excel is now opened and your planning data displayed.

4. To retain this data as an Excel file, you must save it in Excel.
Reporting in the Planning Table

To call up a standard analysis of a plan based on the consistent planning method, choose Goto \( \rightarrow \) Reporting.

See also:

Standard Analysis for Information Structure [Page 258]
Displaying Selection Criteria in the Planning Table

Use

You see the characteristic values that you selected when calling the planning table. If you used the extended selection screen, you also see the planning version.

Integration

To use the extended selection screen, you set the Extended selection checkbox in the planning type.

Activities

In the planning table, choose Goto → Display selection.
Planning Table: Data Maintenance

This section explains how to enter and maintain data in the planning table.

Macros [Page 120]

Executing a Macro [Page 124]

Working with the 0 Column of the Planning Table [Page 125]

Disaggregating a Line Using the Proportional Factors [Page 126]

Fixing Key Figure Values [Page 127]

Interactive Graphics in the Planning Table [Page 128]

Modifying Planning Data Using the Characteristic Graphic [Page 129]

Modifying Planning Data Using the Key Figure Graphic [Page 130]

Distributing Data in the Planning Table [Page 131]

Copying Data from One Information Structure to Another [Page 132]

Standard Copying Methods [Page 134]

Standard SOP

The following topics describe data entry and maintenance functions that are special to standard SOP.

Standard Macros [Page 122]

Sales Plans in Standard SOP [Page 137]

Sales Plans in Standard SOP: Copying Data from SIS [Page 138]

Copying Data from SIS [Page 139]

Sales Plans in Standard SOP: Copying Data from CO-PA [Page 140]

Copying Data from CO-PA to Standard SOP [Page 141]

Transferring Product Group Proportions in Standard SOP [Page 142]

Production Plans in Standard SOP [Page 143]

Creating a Production Plan in Standard SOP [Page 144]

Setting an Opening Stock Level Manually in Standard SOP [Page 145]
Macros

A macro is a mathematical operation that consists of a sequence of instructions. These instructions are carried out when the macro is executed. Macros are therefore useful for frequently required and/or complicated series of instructions. Although the instructions themselves may be complex, the execution of the macro by the user is very simple. S/he does not even need to be familiar with the calculation being performed. Thus, macros save time and prevent typing errors.

You can use two kinds of macros in Sales & Operations Planning (SOP):

- **Standard macros**
  
  Standard SOP comes supplied with macros for the dual-level planning of product groups and materials (see Standard Macros [Page 122]).

- **User-defined macros**
  
  You can define your own macros in a planning type. You then apply these macros in plans which are based on this planning type.

You can execute macros either in the background or online. In background processing, the system calculates the results at the planning level defined in the variant. In online processing, the system calculates the results in one of two ways:

- At the level of the planning table at which you currently find yourself
  
  The Aggr. planning indicator in the planning type is switched on.

- At the detailed level
  
  The Aggr. planning indicator in the planning type is switched off.

The planning level at which you execute the macro makes a difference to the results, as the following example illustrates.

The planned sales values of your company are as follows:

<table>
<thead>
<tr>
<th>Sales organization</th>
<th>$100</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant</td>
<td>$50</td>
</tr>
<tr>
<td>Material</td>
<td>$10</td>
</tr>
<tr>
<td></td>
<td>$40</td>
</tr>
<tr>
<td></td>
<td>$20</td>
</tr>
<tr>
<td></td>
<td>$30</td>
</tr>
</tbody>
</table>

You record the following macro:

<table>
<thead>
<tr>
<th>Operand</th>
<th>Operator</th>
<th>Operand</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
If you execute this macro at the sales organizational level, you get the following result:

<table>
<thead>
<tr>
<th>Operand</th>
<th>Operator</th>
<th>Operand</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>+</td>
<td>1</td>
<td>101</td>
</tr>
</tbody>
</table>

The total is 101. This total is disaggregated to the detailed level.

If you execute the macro at the material level (that is, the detailed level), you get the following result:

<table>
<thead>
<tr>
<th>Operand</th>
<th>Operator</th>
<th>Operand</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>+</td>
<td>1</td>
<td>11</td>
</tr>
<tr>
<td>40</td>
<td>+</td>
<td>1</td>
<td>41</td>
</tr>
<tr>
<td>20</td>
<td>+</td>
<td>1</td>
<td>21</td>
</tr>
<tr>
<td>30</td>
<td>+</td>
<td>1</td>
<td>31</td>
</tr>
</tbody>
</table>

These results are aggregated to the total level. The total is 104.
Standard Macros

Definition

The following standard macros are provided in standard SOP for the dual-level planning of product groups and materials (Disaggregation → Break down product group plan). All of them are offered in the split-screen planning table.

- **Aggregate production**
  Aggregates the production quantities maintained at the detailed information level to the aggregated information level; that is, the production figures are cumulated and the result written to the aggregate production line. Existing production quantities at the aggregate level are overwritten.

- **Aggregate sales**
  Aggregates the sales quantities maintained at the detailed information level to the aggregated information level; that is, the sales figures are cumulated and the result written to the aggregate sales line. Existing sales quantities at the aggregate level are overwritten.

- **Disaggregate production → production**
  Disaggregates the production quantities maintained at the aggregated information level to the detailed information level; that is, the system distributes the aggregate production data to the production lines of the product group members using the proportional factors maintained in the product group master record. Existing production quantities at the detailed level are overwritten.

- **Disaggregate production → sales**
  Disaggregates the production quantities maintained at the aggregated information level to the detailed information level; that is, the system distributes the aggregate production data to the sales lines of the product group members using the proportional factors maintained in the product group master record. Existing sales quantities at the detailed level are overwritten.

- **Disaggregate sales**
  Disaggregates the sales quantities maintained at the aggregated information level to the detailed information level; that is, the system distributes the aggregate sales data to the sales lines of the product group members using the proportional factors maintained in the product group master record. Existing sales quantities at the detailed level are overwritten.

- **Disaggregate target days' supply**
  Copies the target days' supply maintained at the aggregated information level to the detailed information level; that is, the system copies the aggregate target days' supply to the target days' supply lines of the product group members. Existing target days' supplies at the detailed level are overwritten.

- **Disaggregate target stock level**
  Disaggregates the target stock level maintained at the aggregated information level to the detailed information level; that is, the system distributes the aggregate target stock
level to the target stock level lines of the product group members, using the proportional factors maintained in the product group master record. Existing target stock levels at the detailed level are overwritten.

- Production synchronous to sales

Causes the production quantities at the detailed information level to be the same as the sales quantities maintained at that level. Production quantities at the aggregated information level are not affected.

See also:

Macros [Page 120]
Executing a Macro [Page 124]
Defining a Macro in a Planning Type [Page 69]
Macros for Stock Balance, Production, Days’ Supply, and Historical Totals [Page 72]
Executing a Macro

Macros are a quick way to perform calculations.

To execute a macro:

1. In the planning table, choose Edit → Macro.
   The Macro Selection dialog box appears.
2. Select a macro.
3. Choose Continue.
   The macro is executed at the level at which you run it, and the results appear in the planning table.

This procedure applies both to standard SOP and to flexible planning.

See also:
- Macros [Page 120]
- Standard Macros [Page 122]
- Defining a Macro in a Planning Type [Page 69]
- Macros for Stock Balance, Production, Days' Supply, and Historical Totals [Page 72]
Working with the 0 Column of the Planning Table

In flexible planning, you can set an initial value or quantity for a key figure at the beginning of the planning horizon, for example, for the key figure “stock level”. This value or quantity is displayed in the “0 column”, so called because it represents the time prior to the first period in which planning data is maintained.

Key figures in the 0 column are aggregated and disaggregated just like any other key figures.

To display the 0 column:

1. Choose Settings → 0 column.
   
   The 0 column appears at the beginning of the planning horizon. If you have calculated opening stock levels using mass processing, these are now shown here.

2. If desired, enter an opening value or quantity manually for one or more key figures.
   
   This value or quantity will be saved when you save the planning version.

3. To hide the 0 column, choose Settings → 0 column again.

See also:

How to Set Opening Stock Levels with Mass Processing [Page 225]

Setting Opening Stock Levels [Page 227]

Setting an Opening Stock Level Manually in Standard SOP [Page 145]
Disaggregating a Line Using the Proportional Factors

One way to disaggregate data in flexible planning is to use constant proportional factors.

To disaggregate a line’s data using the constant proportional factors:

1. Place the cursor on the line whose data you want to be disaggregated.
2. Choose Edit → Disaggregate row.

   The data is distributed to the detailed level in accordance with the constant proportional factors. You can view the proportional factors with Goto → Select detail(s).

See also:

Automatic Calculation of the Constant Proportional Factors in Consistent Planning [Page 38]
Automatic Calculation of the Proportional Factors in Level-By-Level Planning [Page 41]
Calculating the Proportional Factors Automatically [Page 43]
Fixing Key Figure Values

Use
You can fix the value of a key figure in the planning table such that this value will not change when you change other values of this key figure at other planning levels. Where a change to the sum of the details’ values conflicts with the individual details’ values, the values of the details take precedence.

This function is designed for use with consistent planning.

💡
SAP recommends that you switch to the key figure view before fixing any values. Otherwise, you will not be able to see how a change to a key figure value at one planning level affects the other levels.

Prerequisites
1. The information structure you are planning was created with the Planning possible indicator switched on.
2. In the information structure, the fixing indicator has been set for the key figures with which you wish to use this function.
3. The Aggr. planning indicator has been set in the planning type. Key figures values you fix in the planning table are then fixed on the database when you save the planning version.

Activities

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fix a key figure value</td>
<td>Double-click in the key figure value’s cell</td>
</tr>
<tr>
<td>Unfix a key figure value</td>
<td>Double-click in the key figure value’s cell</td>
</tr>
<tr>
<td>Fix a key figure value at the moment you enter it</td>
<td>Choose Settings → Fix key figure → Switch on, enter the value, and choose ENTER</td>
</tr>
<tr>
<td>Fix the values of an entire line</td>
<td>Double-click on that line in the initial column (the column showing the key figures or characteristics values)</td>
</tr>
</tbody>
</table>
Interactive Graphics in the Planning Table

All the data in the planning table is available in graphical form. Thus, you can assess your planning data at a glance. Moreover, these graphics are interactive: you can change key figure values quickly and easily and then copy these changes to the planning table by simple manipulation of the mouse.

Exactly what data is displayed depends on which option you select. You are offered a choice of two interactive graphics:

- **Characteristic graphic [Page 129]**
  A characteristic graphic shows you all the key figures for a selected characteristic value.
- **Key figure graphic [Page 130]**
  A key figure graphic shows you all the characteristic values for a selected key figure.

For each graphic, there are two options:

- Business graphic
- Statistics graphic

A window containing a series of interactive pushbuttons allows you to vary which key figures are displayed.

**Business Graphic**

The business graphic has both a three-dimensional diagram and a two-dimensional diagram which you can display either together or separately. In the selection screen, you can vary the section visible for processing using the pushbuttons to the right of the graphics. You can change planning data in the business graphic.

**Statistics Graphic**

The statistics graphic gives an overview of the entire planning horizon. If you change your planning data in the business graphic, the statistics graphic alters its shape automatically to reflect this change.
Modifying Planning Data Using the Characteristic Graphic

To modify your planning data using the characteristic graphic:

1. From the planning table, choose Edit → Interactive graphics → Graphic - characteristic.
2. Select the key figures you want to view in the interactive graphics pushbutton window.
3. Click on the headings Business graphic and Statistics graphic.
   The business graphic and the statistics graphic appear showing the current planning level, for example, material “hair-dryer” in plant “London” where the member characteristic is material and the owner characteristic is plant.
4. Select the key figure whose values you want to change in the panel to the left of the business graphic.
5. In the 2D diagram of the business graphic, click on the column whose value you want to change, hold the mouse button down, and move the mouse until the object acquires the desired value. In the statistics graphic, the line depicting this key figure alters its shape automatically to match.
   You can change any key figure values in this way.
6. To copy the revised values to the planning table, choose Save mod. (Save modification) in the business graphic.
7. To return to the planning table, choose Goto → Back.
   The new key figure values are shown in the planning table. They will be saved when you save the planning table.

For more information, see Interactive Graphics in the Planning Table [Page 128].
Modifying Planning Data Using the Key Figure Graphic

To modify your planning data using the key figure graphic:

1. Position your cursor on the desired key figure.
2. From the planning table, choose Edit → Interactive graphics → Graphic - key figure.
3. Select the characteristic values you want to view in the interactive graphics pushbutton window.
4. Click on the headings Business graphic and Statistics graphic.
   The business graphic and the statistics graphic appear showing the key figure for the specified characteristic values.
5. Select the characteristic value whose values you want to change in the panel to the left of the business graphic.
6. In the 2D diagram of the business graphic, click on the column whose value you want to change, hold the mouse button down, and move the mouse until the object acquires the desired value. In the statistics graphic, the line depicting this key figure alters its shape automatically to match.
7. To copy the revised values to the planning table, choose Save mod. (Save modification) in the business graphic.
8. To return to the planning table, choose Goto → Back.
   The new key figure values are shown in the planning table. They will be saved when you save the planning table.

For more information, see Interactive Graphics in the Planning Table [Page 128].
Distributing Data in the Planning Table

This function allows you to distribute data horizontally across one or more lines in the planning table. This is particularly useful if you want to make entries or changes that apply to a large section of the planning horizon.

The system offers you many different operands. For example, you can add a specified value or percentage to each time bucket on a line, or distribute a value evenly across the time series.

To distribute a value across the planning table:

1. Select the section of the planning horizon to which you want the distribution to apply (see Selecting Columns in the Planning Table [Page 105]).

2. Choose Edit → Distribute.
   
   A dialog box appears showing the selected planning periods and all the key figures for which a distribution operation can be performed.

3. Specify the value or values which you want to be distributed and the desired operand(s).

4. Choose Distribute to have the system perform the operation.
   
   You return to the planning table.
Copy Data from One Information Structure to Another

This function allows you to copy key figure values from a planning version of one information structure to a planning version of another information structure. Thus, you can copy, for example, the sales quantities you have planned in one information structure to the production line of another information structure.

It is possible to copy the values of any key figure.

In some cases, you need to create your own copying method. This depends on the planning methods defined for the source and target information structures and on the characteristics in each of the information structures. For more information, see Standard Copying Methods and Defining User Methods.

To copy data from one information structure to another in the planning table:

1. From the planning table, choose Extras → Copy data.
   A dialog box entitled Source Info Structure appears.
2. Specify the source information structure, the desired planning version of this information structure, and the opening and closing dates of the period for which you want data to be copied. You can make all these entries including the dates using the F4 button.
   The source information structure must be different from the target information structure, that is, different from the information structure you are currently planning.
3. To continue, choose ENTER.
   The Assign Key Figure window appears.
4. You define the key figure assignment:
   a) If you are copying from consistent planning to consistent planning and require an aggregate copy with subsequent distribution, set the Aggregate copy indicator.
      For more information, see Standard Copying Methods.
   b) To specify a key figure from the source information structure, select the radio button next to it (you are in the top half of the window), and choose Choose (or double-click on the key figure).
      The key figure is copied to the group box Key figure(s) assignment.
      To scroll up and down the key figures list, use the buttons underneath it.
   c) To specify the key figure in the target information structure to which you want the data to be copied, select the radio button next to it (you are in the top half of the window), and choose Choose (or double-click on the key figure).
      The key figure is copied to the group box Key figure(s) assignment.
d) Repeat steps 4b and 4c until you have listed all the key figures you want to be copied together under the same assignment key.

e) To save this key figure assignment, choose Save assignment.
   The Save Key Figure Assignment dialog box appears.

f) Enter a key figure assignment key.
   This is any string of characters that you will be able to remember. The system now creates a key figure assignment profile.

g) Choose Save assignment.

5. To have the system copy the data, choose Continue.

Using an Existing Key Figure Assignment Profile

To use an existing key figure assignment profile in addition to or instead of a new one:

1. In the Assign Key Figures box, choose Open assignment.
   The Display Key Figure Assignments box appears. It shows key figure assignment profiles that have already been created either online or in Customizing.

2. Click on the relevant assignment key and choose Choose.
   To copy these figures to the Assign Key Figures box, choose Continue.

See also:
How to Copy Key Figure Values Between Information Structures with Mass Processing [Page 203]
Key Figure Assignment Profiles and Copy Profiles [Page 206]
Standard Copying Methods [Page 134]
Standard Copying Methods

SOP allows you to copy key figures from one information structure to another.

How this is done depends on the planning methods defined for the source and target information structures and on the characteristics in each one. The system takes care of any conversion from one unit of measure to another.

SOP comes with standard copying methods for three combinations of planning methods:

- Consistent -> consistent
- Consistent -> level-by-level
- Delta -> level-by-level

Otherwise, you can create your own copying method (see Defining User Methods).

The standard copying methods are as follows:

**Consistent -> Consistent**

There are two possibilities for copying data from consistent planning to consistent planning:

1. The system attempts to match planning objects with identical characteristic values in the source and target information structures. It then copies key figures to the target information structure for each planning object in the source information structure in which the characteristic value can be found.

   If you are copying online, the characteristic values for which key figures are copied depend on the characteristics for which you specified values when calling up the planning screen. In background processing, key figures are copied according to the characteristic values defined in the variant.

   **Source Information Structure**

<table>
<thead>
<tr>
<th>Region</th>
<th>01</th>
<th>02</th>
<th>03</th>
<th>01</th>
</tr>
</thead>
<tbody>
<tr>
<td>Division</td>
<td>01</td>
<td>02</td>
<td>01</td>
<td>02</td>
</tr>
<tr>
<td>Material</td>
<td>A</td>
<td>A</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Key figure</td>
<td>10</td>
<td>10</td>
<td>20</td>
<td>20</td>
</tr>
</tbody>
</table>

   The sum of the key figures at the detailed level for material A is 60.

   **Target Information Structure**

<table>
<thead>
<tr>
<th>Sales organization</th>
<th>0001</th>
<th>0001</th>
<th>0002</th>
<th>0002</th>
<th>0001</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution channel</td>
<td>01</td>
<td>02</td>
<td>01</td>
<td>02</td>
<td>01</td>
</tr>
<tr>
<td>Material</td>
<td>A</td>
<td>A</td>
<td>A</td>
<td>A</td>
<td>B</td>
</tr>
<tr>
<td>Plant</td>
<td>0001</td>
<td>0001</td>
<td>0001</td>
<td>0001</td>
<td>0001</td>
</tr>
</tbody>
</table>
The key figure has been copied to the four planning objects which contain material A. Only material A was specified when the planning screen was called (online processing) or when the variant was defined (background processing), not material B.

2. The system attempts to match planning objects with identical characteristic values in the source and target information structures. It copies a key figure once only for each characteristic value. This key figure is then distributed among the planning objects which contain this characteristic value. The key figure is distributed either equally or in accordance with the predefined proportional factors.

If you are copying online, the characteristic values for which key figures are copied depend on the characteristics for which you specified values when calling up the planning screen. If you use background processing, key figures are copied for all planning objects with identical characteristic values in the source and target information structures.

If you desire an aggregate copy with subsequent distribution (see example below), you must perform one of two actions depending on whether you will be copying data online or in the background:

– Online processing
  
  You set the *Aggregate copy* indicator in the second dialog box that appears after you have chosen *Extras -> Copy data* in the planning table.

– Background processing
  
  You carry out the function *Planning -> Mass processing -> Delete/copy -> High-level copy* in the flexible planning menu (see also *How to Copy Key Figure Values Between Information Structures with Mass Processing* [Page 203]).

### Source Information Structure

<table>
<thead>
<tr>
<th>Region</th>
<th>01</th>
<th>01</th>
<th>02</th>
<th>03</th>
<th>01</th>
</tr>
</thead>
<tbody>
<tr>
<td>Division</td>
<td>01</td>
<td>02</td>
<td>01</td>
<td>02</td>
<td>01</td>
</tr>
<tr>
<td>Material</td>
<td>A</td>
<td>A</td>
<td>A</td>
<td>A</td>
<td>B</td>
</tr>
<tr>
<td>Key figure</td>
<td>10</td>
<td>10</td>
<td>20</td>
<td>20</td>
<td>10</td>
</tr>
</tbody>
</table>

The sum of the key figures at the detailed level for material A is 60.

### Target Information Structure

<table>
<thead>
<tr>
<th>Sales organization</th>
<th>0001</th>
<th>0001</th>
<th>0002</th>
<th>0002</th>
<th>0001</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution channel</td>
<td>01</td>
<td>02</td>
<td>01</td>
<td>02</td>
<td>01</td>
</tr>
</tbody>
</table>
Standard Copying Methods

<table>
<thead>
<tr>
<th>Material</th>
<th>A</th>
<th>A</th>
<th>A</th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant</td>
<td>0001</td>
<td>0001</td>
<td>0001</td>
<td>0001</td>
<td>0001</td>
</tr>
<tr>
<td>Key figure</td>
<td>15</td>
<td>15</td>
<td>15</td>
<td>15</td>
<td>-</td>
</tr>
</tbody>
</table>

The key figure has been copied to material A and then distributed among the planning objects which contain this material. Only material A was specified when the planning screen was called (online processing) or when the variant was defined (background processing), not material B.

**Consistent -> Level-By-Level**

The target information structure can be either the standard information structure S076 or an information structure you have created yourself. The level to which the key figures are copied depends on the characteristics. When planning online, you specify these when calling up the planning table. When planning in the background, you specify the characteristics in the variant.

If the target information structure is S076, you need to have run the Master Data Generator before you copy data. For more information, see [Master Data Generator in Standard SOP](#) [Page 50].

If plant is a specified characteristic of the target information structure but is not contained in the source information structure, the system distributes the key figures across the different plants of each material provided that two conditions are fulfilled:

- The target information structure is S076 or a similar information structure with the same characteristic [Ext.] fields.
- The proportions by which the key figure is to be distributed have been defined (see [Plant Distribution Quotas](#) [Page 239]).

**Delta -> Level-By-Level**

This method is used when you create sales plans in standard SOP by copying data from the Sales Information System in which one of the standard information structures for sales has been planned.

You need to have run the Master Data Generator before you copy data. For more information, see [Master Data Generator in Standard SOP](#) [Page 50].

If plant is a specified characteristic of the target information structure but is not contained in the source information structure, the system distributes the key figures across the different plants of each material either equally or in accordance with the plant distribution quotas [Page 239].

See also:

- [Copying Data from One Information Structure to Another](#) [Page 132]
- [How to Copy Key Figure Values Between Information Structures with Mass Processing](#) [Page 203]
- [Key Figure Assignment Profiles and Copy Profiles](#) [Page 206]
Sales Plans in Standard SOP

Various functions are available for creating and modifying sales plans in standard SOP:

- Manual data entry
- Arithmetic distribution functions [Page 131]
- Copying data from SIS [Page 139]
- Copying data from CO-PA [Page 141]
- Forecasting sales quantities on the basis of past usage [Page 159]
- Transferring product group proportions [Page 142]
- Interactive graphics [Page 128]
Sales Plans in Standard SOP: Copying Data from SIS

The planning functionality of Sales & Operations Planning is part of the Logistics Information System (LIS). Thus, you have direct access to the quantities planned in the Sales Information System (SIS) from SOP. All you need to do is specify the information structure, the planning version, and the key figure whose data you want to copy. If you want to use these settings on a regular basis, you can predefine them in your user-defined values. The only requirement is that your chosen information structure contains material as one of its characteristics.

What you are in fact doing is copying data from one information structure to another (see also Copying Data from One Information Structure to Another [Page 132]): product group plans are based on information structure S076.

You can copy the values of any quantity key figures in your specified information structure. For example, you can copy planned order quantities, planned invoiced quantities, or planned delivery quantities.

In order to create a sales plan for a product group, the system aggregates the planning data of all the materials in the product group hierarchy with reference to the plant and period indicator. If plant is not contained in the information structure key, the system distributes the quantities across a material’s plants in accordance with the settings made in the Customizing activity “Define proportional distribution across plants”.

For more information, see Copying Data from SIS [Page 139].
Copying Data from SIS

To copy data from the Sales Information System in standard SOP:

1. Choose Edit → Create sales plan → Transfer plan from SIS.
   The Source Info Structure dialog box appears.

2. Specify the name of the information structure in which the planning data was created, the number of the desired planning version, and the start and finish dates of the planning horizon for which you want to copy the data.

3. To continue, choose ENTER.
   The Key Figure dialog box appears.

4. Select one of the quantity key figures in the list.

5. To continue, choose ENTER.
   The key figure values from SIS now appear in the sales line of the planning table.

See also:
Sales Plans in Standard SOP: Copying Data from SIS [Page 138]
Sales Plans in Standard SOP: Copying Data from CO-PA

Sales Plans in Standard SOP: Copying Data from CO-PA

Sales & Operations Planning is integrated with Profitability Analysis. Thus, you have direct access to the quantities planned in CO-PA from Sales & Operations Planning.

The system needs to know the CO-PA field name and the CO-PA version in order to copy data from CO-PA. You can maintain a CO-PA field name for a product group in the master data of the product group’s master record. This establishes the link between the SOP product group and the desired CO-PA hierarchical level. If you carry out this function for a single material, the CO-PA field name is predefined and you cannot change it.

You can copy quantity key figures only.

If the plant of the material or product group is specified in CO-PA, it is this plant’s data that is copied. Otherwise, the system breaks down the quantities of the material or product group into plants using the settings made in the Customizing activity Define proportional distribution across plants.

See also:

Copying Data from CO-PA to Standard SOP [Page 141]
Transferring SOP Data to Profitability Analysis (CO-PA) [Page 241]
Copy data from CO/PA to standard SOP:

1. Choose Edit → Create sales plan → Transfer CO-PA plan.
   The Transfer Area dialog box appears.

2. Specify the number of the planning version within CO-PA, and the start and finish dates of the planning horizon for which you want to copy the data.
   
   The CO-PA field name of a product group is maintained in the product group master record. It establishes the link between the SOP product group and the desired CO-PA hierarchical level.

3. To continue, choose ENTER.
   The key figure values from CO-PA now appear in the planning table.

For more information on this method of creating sales plans in standard SOP, see Sales Plans in Standard SOP: Copying Data from CO-PA [Page 140].
Transferring Product Group Proportions in Standard SOP

If you are disaggregating a product group plan in standard SOP (Disaggregation → Break down product group plan), you can create sales plans for product group members as proportions of the owner product group’s sales or production plan. The system calculates these proportions using the proportional factors in the product group’s master record.

To transfer product group proportions:

1. In the planning table (split screen), choose Edit → Create sales plan → Transfer PG proportion → PG: production or PG: sales.

   The calculated sales quantities appear in the bottom half of the screen.
Production Plans in Standard SOP

In a production plan, you plan the quantities you need to produce in order to meet your sales plan. The system then calculates stock levels and days’ supply for each period on the basis of the sales and production quantities and any target data. In standard SOP, you create a production plan using one of the following:

- Manual data entry
- Arithmetic distribution functions [Page 131]
- Strategy: production plan synchronous to sales plan [Page 144]
  
  If you select this strategy, the system copies the sales quantities into the production quantities line. Thus, planned production is exactly the same as planned sales in this planning horizon.

- Strategy: zero stock level [Page 144]
  
  If you select this strategy, the system uses any existing stock to cover sales quantities. When this stock has been used up, production quantities are planned in synchronization with sales quantities.

- Strategy: target stock level [Page 144]
  
  If you select this strategy, the system calculates the production quantities needed to achieve target stock levels. You specify target stock levels on the target stock level line (if desired, using the distribution functions). The system then works out the production quantities on the basis of the sales quantities and your target stock levels.

- Strategy: target days’ supply [Page 144]
  
  If you select this strategy, the system calculates the production quantities needed to achieve target days’ supplies. You specify target days’ supplies on the target days’ supply line (if desired, using the distribution functions). The system then works out the production quantities. The days’ supply for a period is the stock level divided by the average requirements (where average requirements = sales/number of workdays, and the number of workdays is given in the factory calendar defined in Customizing).

- Interactive graphics [Page 128]
- External optimization interface through external planning profile EXTERNPLAN

See LO Supply Chain Planning Interfaces.
Creating a Production Plan in Standard SOP

To create a production plan in standard SOP:

1. If you are going to use the strategy “target stock level” or the strategy “target days’ supply”, specify target stock level values or target days' supplies.

2. In the standard planning table, choose Edit → Create production plan → and the desired strategy (either Synchronous to sales, Zero stock level, Target stock level, Target days’ supply, or Plan externally).

   Production quantities now appear in the production line. If the line already contained production figures, these are overwritten by the new quantities.

See also:

Production Plans in Standard SOP [Page 143]

LO Supply Chain Planning Interfaces
Setting an Opening Stock Level Manually in Standard SOP

You can set an opening stock level manually in the standard planning table. This is the stock level at the start of the planning horizon. The default opening stock level is zero.

The stock levels shown in each column represent the stock levels at the end of each period.

To set an opening stock level manually in standard SOP:

1. In the standard planning table, choose Goto → Opening stock level.
2. Enter the opening stock level of your product group or material.
3. Choose Continue.

The stock levels change to reflect the change in the opening stock levels.

You can also set opening stock levels using one of the methods offered with mass processing. For more information, see How to Set Opening Stock Levels with Mass Processing [Page 225] and Setting Opening Stock Levels [Page 227].
Planning Table: the Forecast

This section explains the functions of the automatic forecast and how to use them.

Basics

- The Forecast in SOP [Page 147]
- Forecast Models [Page 148]
- Forecast Parameters [Page 150]
- Model Selection [Page 152]
- Manual Model Selection [Page 153]
- Automatic Model Selection [Page 155]
- Model Initialization [Page 157]
- Ex-Post Forecast [Page 158]

Handling the Forecast Tools

- Forecasting Online [Page 159]
- Analyzing the Time Series and Modifying the Historical Values [Page 161]
- Interpreting the Forecast Results [Page 162]
- Changing the Forecast Results [Page 163]
- Forecast Profiles [Page 164]
- Creating a Forecast Profile [Page 166]
- Forecast Versions [Page 167]
- Copying a Historical Time Series [Page 168]

Formulas

- Forecast Formulas [Page 169]
The Forecast in SOP

With the forecast, you can estimate the future progression of values in a time series on the basis of past history. You do this either online or in the background.

In standard SOP, you can forecast the sales quantities of a product group or material. The system bases the forecast on the historical consumption of materials. It then aggregates these results to the product group level. Consumption data includes every kind of goods issue, even goods that have been written off as scrap.

In flexible planning, you can forecast any key figure that you want, provided that it has been defined for forecasting in Customizing (in Set parameters for info structures and key figures). The system bases the forecast on the actual values of this key figure. In level-by-level planning, you can also base the forecast on historical consumption data. In this case, the information structure must contain the characteristics “material” and “plant,” and you must set the Consumpn. indicator in the forecast profile.

In level-by-level planning, you can base the forecast on the consumption quantities of a “reference material.” This is useful if you do not have any historical values for a material; for example, because it is new. You define the reference material in the material master record.

The historical data is automatically aggregated to the current planning level before the forecast is carried out. If you run the forecast online, this is the planning level on which you are working in the planning table. If you run the forecast in the background, this is the planning level you define in the job variant.

![Tip]

If you run the forecast at a high level and the results are disaggregated to the detailed level, the results will be different than if you carry out the forecast at the detailed level.

See also:

Forecasting Online [Page 159]
Mass Processing in SOP [Page 200]
Forecast Models

When a series of consumption values is analyzed, it normally reveals a pattern or patterns. These patterns can then be matched up with one of the forecast models listed below:

- **Constant**—consumption values vary very little from a stable mean value
- **Trend**—consumption values fall or rise constantly over a long period of time with only occasional deviations
- **Seasonal**—periodically recurring peak or low values differ significantly from a stable mean value
- **Seasonal trend**—continual increase or decrease in the mean value
- **Copy of actual data** (no forecast is executed)—copies the historical data updated from the operative application, which you can then edit
- **Irregular**—no pattern can be detected in a series of historical consumption values
Forecast Parameters

Maintenance of the following parameters is optional or mandatory, depending on how you carry out model selection and which model you choose; that is, the forecast parameters are dependent on the forecast model. Which parameters are required for which model is shown in the table below.

Forecast Parameters Dependent on the Forecast Model

<table>
<thead>
<tr>
<th>Specified model/model to be tested</th>
<th>Mandatory parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constant models:</td>
<td></td>
</tr>
<tr>
<td>First-order exponential smoothing model</td>
<td>Alpha factor</td>
</tr>
<tr>
<td>First-order exponential smoothing model with optimization of the</td>
<td>-</td>
</tr>
<tr>
<td>smoothing factors</td>
<td></td>
</tr>
<tr>
<td>Moving average model</td>
<td>Number of historical values</td>
</tr>
<tr>
<td>Weighted moving average model</td>
<td>Weighting group</td>
</tr>
<tr>
<td>Trend models:</td>
<td></td>
</tr>
<tr>
<td>First-order exponential smoothing model</td>
<td>Alpha and beta factors</td>
</tr>
<tr>
<td>Second-order exponential smoothing model</td>
<td>Alpha factor</td>
</tr>
<tr>
<td>Second-order exponential smoothing model with optimization of the</td>
<td></td>
</tr>
<tr>
<td>smoothing factors</td>
<td></td>
</tr>
<tr>
<td>Seasonal model: Winters' method</td>
<td>Alpha and gamma factors</td>
</tr>
<tr>
<td></td>
<td>Periods per season</td>
</tr>
<tr>
<td>Seasonal trend model:</td>
<td>Alpha, beta, and gamma factors</td>
</tr>
<tr>
<td>First-order exponential smoothing model</td>
<td>Periods per season</td>
</tr>
</tbody>
</table>

Weighting group

You only have to maintain this field if you selected the forecast model "weighted moving average". This key specifies how many historical values are included in the forecast and how these values are weighted in the forecast calculation.

Periods per seasonal cycle

You only have to specify the number of periods per season if you have selected the seasonal model or if you want the system to carry out a seasonal test.
The following factors are used by the system, depending on the model, for exponential smoothing. Thus, for example, only the alpha and the delta factors are required for the constant model, whereas all the smoothing factors are required for the seasonal trend model.

**Alpha factor**

The system uses the alpha factor to smooth the basic value. If you do not specify an alpha factor, the system will automatically use the alpha factor set in the profile. In the standard SAP profile, this is the factor 0.2.

**Beta factor**

The system uses the beta factor to smooth the trend value. If you do not specify a beta factor, the system will automatically use the beta factor set in the profile. In the standard SAP profile, this is the factor 0.1.

**Gamma factor**

The system uses the gamma factor to smooth the seasonal index. If you do not specify a gamma factor, the system will automatically use the gamma factor set in the profile. In the standard SAP profile, this is the factor 0.3.

**Delta factor**

The system uses the delta factor 0.3 in every forecast model to smooth the mean absolute deviation.
Model Selection

Before you run a forecast, you must specify which model the system should use to calculate the forecast values.

There are three possibilities:

- Manual model selection
- Automatic model selection
- Manual model selection with the system also testing for a pattern
Manual Model Selection

If you want to select a model manually, you must first analyze the historical data to determine whether a distinct pattern or trend exists. You then define your forecast model accordingly.

**Constant pattern**

If your historical data represents a constant consumption flow, you select either the constant model or the constant model with adaptation of the smoothing factors. In both cases, the forecast is carried out using first-order exponential smoothing. When adapting the smoothing parameters, the system calculates different parameter combinations and then selects the optimum parameter combination. The optimum parameter combination is the one which results in the lowest mean absolute deviation.

You have another two possibilities if the historical pattern is constant; either the moving average model or the weighted moving average model.

In the weighted moving average model, you weight individual historical values with the result that the system does not give equal value to historical data when calculating the forecast values. By so doing, you can influence the calculation so that more recent historical values play a more important role in the forecast than less recent ones—as is also the case with exponential smoothing.

**Trend pattern**

If your historical data represents a trend, you should select either the trend model or a second-order exponential smoothing model. In the trend model, the system calculates the forecast values using first-order exponential smoothing.

In the second-order exponential smoothing models, you can choose a model with or without a model parameter optimization.

**Seasonal pattern**

If your historical data represents a seasonal pattern, you specify the seasonal model. The system calculates the forecast values for the seasonal model using first-order exponential smoothing.

**Seasonal trend pattern**

If your historical data represents a seasonal trend pattern, you select a seasonal trend model. The system calculates the forecast values using first-order exponential smoothing.

**Irregular pattern**

If you cannot detect any of the above trends or patterns, and you still want the system to carry out a forecast, it is usually advisable to select either the moving average model or the weighted moving average model.

**Forecast Models for Different Historical Patterns**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Forecast model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constant pattern</td>
<td></td>
</tr>
<tr>
<td>Trend pattern</td>
<td></td>
</tr>
<tr>
<td>Seasonal pattern</td>
<td></td>
</tr>
<tr>
<td>Seasonal trend pattern</td>
<td></td>
</tr>
<tr>
<td>Irregular pattern</td>
<td></td>
</tr>
<tr>
<td>Manual Model Selection</td>
<td></td>
</tr>
<tr>
<td>-------------------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Constant</strong></td>
<td></td>
</tr>
<tr>
<td>Constant model</td>
<td></td>
</tr>
<tr>
<td>Constant model with smoothing factor adaptation</td>
<td></td>
</tr>
<tr>
<td>Moving average model</td>
<td></td>
</tr>
<tr>
<td>Weighted moving average model</td>
<td></td>
</tr>
<tr>
<td><strong>Trend</strong></td>
<td></td>
</tr>
<tr>
<td>Trend model (1st-order exponential smoothing)</td>
<td></td>
</tr>
<tr>
<td>Trend model (2nd-order exponential smoothing model, with and without parameter optimization)</td>
<td></td>
</tr>
<tr>
<td><strong>Seasonal</strong></td>
<td></td>
</tr>
<tr>
<td>Seasonal model (Winters’ method)</td>
<td></td>
</tr>
<tr>
<td><strong>Seasonal trend</strong></td>
<td></td>
</tr>
<tr>
<td>Seasonal trend model (1st-order exponential smoothing model)</td>
<td></td>
</tr>
<tr>
<td><strong>Irregular</strong></td>
<td></td>
</tr>
<tr>
<td>No forecast</td>
<td></td>
</tr>
<tr>
<td>Moving average model</td>
<td></td>
</tr>
<tr>
<td>Weighted moving average model</td>
<td></td>
</tr>
</tbody>
</table>
Automatic Model Selection

If you do not want to specify a forecast model manually, you must instruct the system to make an automatic selection. With automatic selection, the system analyzes the historical data and then selects the most suitable model. The following models are possible:

- Constant
- Trend
- Seasonal
- Seasonal trend

If the system cannot detect any regular pattern in the historical data, it automatically selects the constant model.

The system requires a different number of historical values for different tests. For further information, see Model Initialization [Page 157].

Model Selection Procedures

You choose between two procedures for automatic model selection:

Procedure 1

If you want the system to select the forecast model, you can choose between various statistical tests and test combinations which determine the model. The test that is carried out depends on your level of knowledge (see table below).

Trend test

In the trend test, the system subjects the historical values to a regression analysis and checks to see whether there is a significant trend pattern.

Seasonal test

In the seasonal test, the system clears the historical values of any possible trends and then carries out an auto-correlation test.

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Test</th>
</tr>
</thead>
<tbody>
<tr>
<td>No information</td>
<td>Test for trend and seasonal patterns</td>
</tr>
<tr>
<td>No trend</td>
<td>Test for seasonal pattern</td>
</tr>
<tr>
<td>No season</td>
<td>Test for trend pattern</td>
</tr>
<tr>
<td>Trend</td>
<td>Test for seasonal pattern</td>
</tr>
<tr>
<td>Season</td>
<td>Test for trend pattern</td>
</tr>
</tbody>
</table>

If you know that a particular pattern exists or does not exist before the model is selected, you can have the system test the historical time series for a trend pattern or a seasonal pattern.
Automatic Model Selection

If you are unable to make any statement about the historical pattern, the system carries out a trend test and a seasonal test. The forecast model is determined on the basis of which test produces the more significant results (see table below).

<table>
<thead>
<tr>
<th>Level of Knowledge</th>
<th>Trend</th>
<th>Season</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>No trend pattern</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>No seasonal pattern</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Trend pattern</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Seasonal pattern</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

Procedure 2

The system calculates the models to be tested using various combinations for alpha, beta, and gamma. The smoothing factors are also varied between 0.1 and 0.5 in intervals of 0.1. The system then chooses the model which displays the lowest mean absolute deviation (MAD). Procedure 2 is more precise than procedure 1, but takes much longer.

To use procedure 2 in mass processing, set forecast strategy 56 in the forecast profile. If you run the forecast online and set Automatic model selection in the Model Selection dialog box, a further dialog box appears in which you can set procedure 2 as one of your forecast parameters.
Model Initialization

Model initialization is the process of determining the necessary model parameters—such as the basic value, the trend value, and the seasonal indices—for the selected forecast model. Initialization takes place each time a planning time series is forecasted.

The following table shows you which model parameters are necessary for each forecast model.

<table>
<thead>
<tr>
<th>Model</th>
<th>Model parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constant model</td>
<td>Basic value</td>
</tr>
<tr>
<td>Trend model</td>
<td>Basic value, trend value</td>
</tr>
<tr>
<td>Seasonal model</td>
<td>Basic value, seasonal indices</td>
</tr>
<tr>
<td>Seasonal trend model</td>
<td>Basic value, trend value, seasonal indices</td>
</tr>
</tbody>
</table>

As a general rule, the forecast model is initialized automatically. In order to do this, the system requires a certain number of historical values. This number depends on the forecast model, as shown in the following table.

<table>
<thead>
<tr>
<th>Model</th>
<th>No. of historical values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constant model</td>
<td>1</td>
</tr>
<tr>
<td>Trend model</td>
<td>3</td>
</tr>
<tr>
<td>Seasonal model</td>
<td>1 season</td>
</tr>
<tr>
<td>Seasonal trend model</td>
<td>1 season + 3</td>
</tr>
<tr>
<td>2nd-order exp. smoothing</td>
<td>3</td>
</tr>
<tr>
<td>Moving average</td>
<td>1</td>
</tr>
<tr>
<td>Weighted moving average</td>
<td>1</td>
</tr>
</tbody>
</table>

The system calculates the basic value on the basis of the average and the trend using the results of the regression analysis. The seasonal indices are given by the actual historical value divided by the basic value adjusted for the trend value.

These calculation methods are used for the constant, trend, seasonal, and seasonal trend models, depending on which parameters are to be determined.

A regression analysis is carried out for the second-order exponential smoothing model.

For the moving average and weighted moving average models, the system calculates an average value.
Ex-Post Forecast

If more historical values are available than are required for the system needs initialize the model, an ex-post forecast is carried out automatically as follows:

- The historical values are divided into two groups: the first group with the older values is used for initialization; the more recent values in the second group are used to carry out an ex-post forecast (see the figure below).
- The basic value, the trend value, the seasonal index, and the mean absolute deviation (MAD) are modified in every ex-post period. These values are used to calculate the forecast results in the future.
- The error total is calculated using the ex-post forecast results. The error total allows you to assess the accuracy of the chosen forecast model.

![Diagram showing consumption over time with historical values and forecast values]
Forecasting Online

The forecast is one way to obtain planning data in Sales & Operations Planning (SOP). If necessary, you can change the forecast results after you have copied them to the planning table.

1. Place the cursor in the planning table on the key figure (if you are planning the characteristic view) or the characteristic (if you are planning the key figure view) for which you want to carry out a forecast.

2. Select the columns of the periods you want to be forecasted by choosing Edit → Select.

See also Selecting Columns in the Planning Table [Page 105].

3. Choose Edit → Forecast. Or, if you are planning product group or material sales quantities in the standard planning table, choose Edit → Sales plan → Forecast → Execute.

The Model Selection dialog box appears.

4. Specify the start and finish dates of the period for which you want to forecast data.

5. Specify the start and finish dates of the historical period on which the forecast is to be based.

   In standard SOP, the forecast is based on consumption data (historical usage data). In flexible planning, the historical values on which the forecast is based are actual data; that is, the forecast is based on the key figure values updated to information structures from the operational applications. In the case of level-by-level planning, you can define the forecast profile such that the forecast is based on consumption data or on the consumption data of a reference material. You maintain the reference material in the material master record.

6. Analyze the time series and, if necessary, correct the historical values (see Analyzing the Time Series and Modifying the Historical Values [Page 161]). Alternatively, you can base the forecast on the corrected historical values of the previous forecast version by setting the Corr. vals indicator in the forecast profile.

7. Check to see if the forecast profile displays settings you want to use. If not, choose a different forecast profile with Forecast profile.

   Do not try to choose a different forecast profile by using the possible entries button in the field Profile.

8. Choose Perform forecast.

   The Forecast Parameters dialog box appears.

9. Define the forecast parameters for the selected model.

10. Choose Perform forecast.

    A dialog box displaying the forecast results appears (see Interpreting the Forecast Results [Page 162]).
If the forecast results are not what you expected, check the settings in your forecast profile.

11. If necessary, change the forecast results (see Changing the Forecast Results [Page 163]).

12. Flag the forecast results for saving in one of two ways:
   - Choose *Copy results* if you want to copy the forecast results into the planning table.
   - Choose *Save* if you want to save the forecast results in the forecast versions database but do not want to copy the forecast results into the planning table. The prerequisite for saving the results to the forecast database is that you have *not* set the indicator *Do not save to forecast DB* in Customizing (the Customizing activity is *Set parameters of info structures and key figures*).

13. To save the forecast version, you must save the planning version by choosing *Planning → Save* in the planning table.

See also:

Forecast Versions [Page 167]

How to Run the Forecast with Mass Processing [Page 202]
Analyzing the Time Series and Modifying the Historical Values

Before you run the forecast, you can check and, if necessary, change the historical values on which the forecast will be based.

1. From the initial forecast dialog box in the planning table, choose Historical.
   A dialog box appears listing historical data from the specified period. Historical data is displayed in the \textit{Val.fld} column for each period.

2. Make any necessary corrections to the original values in the \textit{Corr.value} column.
   These are the values that will be used in the forecast.

Time Series Analysis Using Interactive Graphics

The interactive graphics help you to spot patterns and trends at a glance. You can modify your historical data directly in the graphic.

1. Choose \textit{Interact.graphics}.
   A business graphic appears showing the historical values for the specified period.

2. Choose \textit{Edit} \rightarrow \textit{Modify objects (analog)}.

3. Analyze the time series by comparing the graphic with the models listed in \textit{Forecast Parameters [Page 150]}.

4. Fine-tune the forecast by correcting unusual or extreme values directly in the business graphic: click on the relevant column, hold the mouse button down, and move the mouse until the desired value is obtained.

5. To accept the corrected values for use in the forecast, choose \textit{Copy}.
   A dialog box appears in which you see the revised historical data.

6. Choose \textit{Perform forecast}.
   A dialog box appears in which you define the forecast parameters (see \textit{Forecast Parameters [Page 150]}).

7. To carry out the forecast, choose \textit{Perform forecast}.
   A dialog box appears displaying the forecast results.
Interpreting the Forecast Results

The dialog box containing the forecast results shows the most important model parameters in the header (basic value, trend value, mean absolute deviation, and error total).

The list of forecast results shows:

- Original historical values
- Corrected historical values
- Values determined by the ex-post forecast
- Original values determined by the forecast
- Corrected forecast values
- Seasonal indices

A message is displayed at the bottom of this window, informing you of any unusual or unexpected values detected during the forecast.

1. To view all the forecast messages, choose Messages (click the right mouse button and choose the function).

2. To copy the forecast results into the planning table, choose Copy results.
Changing the Forecast Results

You correct the forecast results in the same way as you correct the historical values on which the forecast is based.

One method is to enter a new value in the Corrected forecast value column of the Forecast Results dialog box.

Alternatively, you can use the interactive graphics:

1. From the Forecast Results dialog box, choose Interact.graphics.
   A business graphic and a statistics graphic appear. You can modify forecast values in the business graphic. The statistics graphic gives you an overview of the forecast and shows all the forecasted data. Thus, the statistics graphic provides a good basis for evaluating the quality of the forecast.

2. In the business graphic, choose Edit → Modify objects (analog).

3. To change a forecast value, click on the relevant column, hold the mouse button down, and move the mouse until the item acquires the desired value.

4. To adopt the corrected value(s) in your forecast results, choose Copy.
   A dialog box appears showing the revised forecast results.

5. To copy the forecast results into the planning table, choose Copy results. You can make further revisions to your forecast results in the planning table.
Forecast Profiles

Forecast profiles allow you to run the forecast over and over again without redefining the forecast settings. The forecast settings are stored in a forecast profile.

You can use a forecast profile as often as you want to forecast a key figure. Because you define the forecast profile separately from the key figure, you can use the same forecast profile to forecast several key figures, or you can forecast the same key figure several times using different profiles.

You run the forecast based on a forecast profile, either online or in the background.

The forecast profiles in SOP are different than those in the material master. In SOP, you can use one forecast profile to forecast a whole group of materials. In the material master, each material has its own forecast profile.

Forecast Period

The period indicator on which you base the forecast can be different than the storage periodicity. You maintain the forecast period in the Period ind. field of the forecast profile.

See also Period Units [Page 97].

Forecast Strategy

Each profile includes a forecast strategy. This specifies the forecast model together with the desired parameters, or the model selection procedure. The following strategies are available:

<table>
<thead>
<tr>
<th>Forecast Strategy</th>
<th>Forecast Strategy Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Constant model</td>
</tr>
<tr>
<td>11</td>
<td>Constant model with first-order exponential smoothing</td>
</tr>
<tr>
<td>12</td>
<td>Constant model with automatic alpha adaptation and first-order exponential smoothing</td>
</tr>
<tr>
<td>13</td>
<td>Constant model based on the moving average model</td>
</tr>
<tr>
<td>14</td>
<td>Constant model based on the weighted moving average model</td>
</tr>
<tr>
<td>20</td>
<td>Trend model</td>
</tr>
<tr>
<td>21</td>
<td>Trend model with first-order exponential smoothing</td>
</tr>
<tr>
<td>22</td>
<td>Trend model with second-order exponential smoothing</td>
</tr>
<tr>
<td>23</td>
<td>Trend model with automatic alpha adaptation and second-order exponential smoothing</td>
</tr>
<tr>
<td>30</td>
<td>Seasonal model</td>
</tr>
<tr>
<td>31</td>
<td>Seasonal model based on the Winters’ method</td>
</tr>
<tr>
<td>40</td>
<td>Seasonal trend model</td>
</tr>
</tbody>
</table>
### Forecast Profiles

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>41</td>
<td>Seasonal trend model with first-order exponential smoothing</td>
</tr>
<tr>
<td>50</td>
<td>Automatic model selection</td>
</tr>
<tr>
<td>51</td>
<td>Automatic model selection with test for trend</td>
</tr>
<tr>
<td>52</td>
<td>Automatic model selection with test for season</td>
</tr>
<tr>
<td>53</td>
<td>Automatic model selection with test for trend and season</td>
</tr>
<tr>
<td>54</td>
<td>Automatic model selection assuming a seasonal pattern and with an additional test for a trend pattern</td>
</tr>
<tr>
<td>55</td>
<td>Automatic model selection assuming a trend pattern and with an additional test for a seasonal pattern</td>
</tr>
<tr>
<td>60</td>
<td>Historical data is copied</td>
</tr>
</tbody>
</table>

For more information on individual parameters in the forecast profile, please see the F1 Help.

**See also:**

- Forecast Models [Page 148]
- Forecast Parameters [Page 150]
- Manual Model Selection [Page 153]
- Automatic Model Selection [Page 155]
Creating a Forecast Profile

To create a forecast profile:

1. Choose **Settings** → *Forecast profile* from one of the main SOP menus. The forecast profile configuration overview appears.

2. Choose **Edit** → *New entries*. The new entries screen appears.

3. Enter a unique name for your forecast profile and a profile description.

4. Make your settings. The forecast strategy is either a forecast model or a model selection procedure. For further information on this and other settings, see Forecast Models, Forecast Parameters, Manual Model Selection, and Automatic Model Selection.

5. To save your forecast profile, choose **Table view** → *Save*.

You can also create forecast profiles in Customizing for Sales & Operations Planning (SOP).
Forecast Versions

By saving many versions of the forecast for one key figure and characteristic values combination, you can compare, for example, forecasts based on different models but using the same historical data, or forecasts with corrected and uncorrected historical time series.

In consistent planning, forecast versions are saved at the detailed level only.

In level-by-level planning, forecast versions are saved at the level on which you create them.

This function is not available with delta planning.

To access the forecast versions of a product group, material, or other characteristic value, choose Versions in the model selection dialog box. For each version, you see:

- The date on which the forecast was run.
- The version’s history number.
  The version numbers show you the sequence in which forecast versions based on this forecast model were created.
- The version number of the forecast profile, that is, of the forecast parameters.
  Each forecast profile has its own version number. The combination of history number and forecast profile version number uniquely identifies a forecast version.
- The description of the forecast profile.
- The status of the forecast profile.
  - Status 1 designates the last version to be copied to the planning table.
  - Status 2 designates the last version to be saved but not copied to the planning table.
  - A blank designates any older version that was saved or copied to the planning table.

To copy a previously saved forecast version into the planning table, select the version you want to copy in the Versions dialog box and then use the Choose and Copy results pushbuttons.

To delete one or more forecast versions in the background, choose Planning → Mass processing → Reorg. forecast. You can opt to delete one or more forecast versions based on a particular forecast model (that is, a particular combination of forecast parameters). You can also delete individual forecast versions online, by choosing Versions and Delete in the forecast dialog box.

By setting the indicator Do not save to forecast DB, you can switch off the use of forecast versions. You set this indicator by choosing Set parameters of info structures and key figures in Customizing. The forecast results are then saved in the information structure but not in the forecast database. Therefore, if you run the forecast and copy the results to the planning table, any previous forecast results are lost. The advantage of setting this indicator is that you achieve performance improvements.

See also:
Forecasting Online [Page 159]
Copying a Historical Time Series

To copy a historical time series from one forecast version to another:

1. From the planning table in flexible planning, choose Edit → Forecast → Execute. Or, in standard SOP, choose Edit → Sales plan → Forecast → Execute.
   - The model selection box appears.

2. Choose Versions.
   - The forecast version selection box appears.

3. To identify the forecast version whose historical time series you want to copy, select a version and then press Display. Repeat this process until you find the desired time series.

4. To copy this historical time series to a new forecast version, choose Copy.
   - The forecast version selection box appears again.

5. Choose Choose.
   - The model selection box appears.

6. To view the historical time series you have just copied, choose Historical.

7. Make any necessary corrections to the historical data before continuing with the forecast.
Forecast Formulas

The statistical forecast is based on several types of formula:

- Formulas on which the forecast models are based
- Formulas that are used to evaluate the forecast results
- Formula to calculate the tolerance lane for automatic outlier correction

Formulas for Forecast Models

Moving Average Model

This model is used to exclude irregularities in the time series pattern. The average of the n last time series values is calculated. The average can always be calculated from n values according to formula (1).

Formula for the Moving Average

\[
(1) \quad M(t) = \frac{V(t) + V(t-1) + \ldots + V(t-n+1)}{n}
\]

\[
(2) \quad M(t+1) = M(t) + \frac{V(t+1) - V(t-n+1)}{n}
\]

Thus, the new average is calculated from the previous average value and the current value weighted with 1/n, minus the oldest value weighted with 1/n.

This procedure is only suitable for time series that are constant, that is, for time series with no trend-like or season-like patterns. As all historical data is equally weighted with the factor 1/n, it takes precisely n periods for the forecast to adapt to a possible level change.

Weighted Moving Average Model

You achieve better results than those obtained with the moving average model by introducing weighting factors for each historical value. In the weighted moving average model, every historical value is weighted with the factor R. The sum of the weighting factors is 1 (see formulas (3) and (4) below).

Formula for the Weighted Moving Average
Determining the Basic Value

\[
M(t) = \frac{V(t)}{n} + \frac{V(t-1)}{n} + \ldots + \frac{V(t-n+1)}{n}
\]

\[
M(t) = R(t) \times V(t) + R(t-1) \times V(t-1) + \ldots + R(t-n+1) \times V(t-1)
\]

\[
M = \text{Average} \\
V = \text{Actual value} \\
R = \text{Weighting factor}
\]

If the time series to be forecasted contains trend-like variations, you will achieve better results by using the weighted moving average model rather than the moving average model. The weighted moving average model weighs recent data more heavily than older data when determining the average, provided you have selected the weighting factors accordingly. Therefore, the system is able to react more quickly to a change in level.

The accuracy of this model depends largely on your choice of weighting factors. If the time series pattern changes, you must also adapt the weighting factors.

First-Order Exponential Smoothing Model

The principles behind this model are:

- The older the time series values, the less important they become for the calculation of the forecast.
- The present forecast error is taken into account in subsequent forecasts.

Constant Model

The exponential smoothing constant model can be derived from the above two considerations (see formula (5) below). In this case, the formula is used to calculate the basic value. A simple transformation produces the basic formula for exponential smoothing (see formula (6) below).

Formulas for Exponential Smoothing

Determining the Basic Value

\[
G(t) = G(t-1) + \alpha (V(t) - G(t-1))
\]

\[
G(t) = \alpha V(t) + (1 - \alpha) G(t-1)
\]
To determine the forecast value, all you need is the preceding forecast value, the last historical value, and the "alpha" smoothing factor. This smoothing factor weights the more recent historical values more than the less recent ones, so they have a greater influence on the forecast.

How quickly the forecast reacts to a change in pattern depends on the smoothing factor. If you choose 0 for alpha, the new average will be equal to the old one. In this case, the basic value calculated previously remains; that is, the forecast does not react to current data. If you choose 1 for the alpha value, the new average will equal the last value in the time series.

The most common values for alpha lie, therefore, between 0.1 and 0.5. For example, an alpha value of 0.5 weights historical values as follows:

1st historical value: 50%
2nd historical value: 25%
3rd historical value: 12.5%
4th historical value: 6.25%

The weightings of historical data can be changed by a single parameter. Therefore, it is relatively easy to respond to changes in the time series.

The constant model of first-order exponential smoothing derived above can be applied to time series that do not have trend-like patterns or seasonal variations.

**General Formula for First-Order Exponential Smoothing**

Using the basic formula derived above (6), the general formula for first-order exponential smoothing (7) is determined by taking both trend and seasonal variations into account. Here, the basic value, the trend value, and the seasonal index are calculated as shown in formulas (8) - (10).

**Formulas for First-Order Exponential Smoothing**
Determining the Basic Value

Forecast value for the period \( t+i \)

\[
(7) \quad P(t+i) = (G(t) + i \cdot T(t)) \cdot S(t-L+i)
\]

where:

<table>
<thead>
<tr>
<th>Basic value:</th>
</tr>
</thead>
</table>
| \[
(8) \quad G(t) = G(t-1) + T(t-1) + \frac{V(t)}{S(t)} \cdot \frac{G(t-1) - T(t-1)}{S(t)}
\]

<table>
<thead>
<tr>
<th>Trend value:</th>
</tr>
</thead>
</table>
| \[
(9) \quad T(t) = T(t-1) + \beta \left[ G(t) - (G(t-1) - T(t-1)) \right]
\]

<table>
<thead>
<tr>
<th>Seasonal index:</th>
</tr>
</thead>
</table>
| \[
(10) \quad S(t+L) = S(t) + \gamma \left[ \frac{V(t)}{G(t)} - \frac{S(t)}{S(t)} \right]
\]

For the constant model

\( T(t) = 0, \beta = 0, S(t) = 1.0, \gamma = \text{Gamma} = 0 \)

For the trend model

\( S(t) = 1.0, \gamma = \text{Gamma} = 0 \)

For the seasonal model

\( T(t) = 0, \beta = 0 \)

\[ P(t+i) = \text{The forecast calculated for the period } (t+i) \text{ in the current period } (t) \]

\[ i = \text{Forecast horizon} \]

\[ G(t) = \text{The current basic value for the current period } (t) \]

\[ G(t-1) = \text{The previous basic value from the previous period} \]

\[ L = \text{Period length (often 12)} \]
Determining the Basic Value

\[
\begin{align*}
V(t) &= \text{Actual demand (history) for the current period (t)} \\
T(t) &= \text{The current trend value calculated for the current period} \\
T(t-1) &= \text{The previous trend value from the previous period} \\
S(t) &= \text{The seasonal index for the period (t)} \\
S(t-L) &= \text{The previous seasonal index for the period (t)}
\end{align*}
\]

\[
\begin{align*}
\alpha &= \text{Smoothing factor for the basic value 'G', } \\
&\quad 0 < \alpha < 1 \\
\beta &= \text{Smoothing factor for the trend value 'T', } \\
&\quad 0 < \beta < 1 \\
\gamma &= \text{Smoothing factor for the seasonal indices 'S', } \\
&\quad 0 < \gamma < 1
\end{align*}
\]

**Second-Order Exponential Smoothing Model**

If, over several periods, a time series shows a change in the average value which corresponds to the trend model, the forecast values always lag behind the actual values by one or several periods in the first-order exponential smoothing procedure. You can achieve a more efficient adjustment of the forecast to the actual values pattern by using second-order exponential smoothing.

The second-order exponential smoothing model is based on a linear trend and consists of two equations (see formula (11)). The first equation corresponds to that of first-order exponential smoothing except for the bracketed indices. In the second equation, the values calculated in the first equation are used as initial values and are smoothed again.

**Formulas for Second-Order Exponential Smoothing**
Error Total

Seasonal index:

\[
G(t) = \alpha V(t-1) + (1- \alpha) G(t-1)
\]

\[
G(t) = \alpha G(t) + (1- \alpha) G(t-1)
\]

\[
G^{(1)} = \text{Simply smoothed basic}
\]

\[
G^{(2)} = \text{Doubly smoothed basic}
\]

\[
V = \text{Historical value}
\]

\[
\alpha = \text{Smoothing factor}
\]

Forecast Evaluation Criteria

Every forecast should provide some kind of basis for a decision. The SAP R/3 System calculates the following parameters for evaluating a forecast’s quality:

- Error total
- Mean absolute deviation (MAD)
- Tracking signal
- Theil coefficient

Error Total

\[
ET = \sum_{t=1}^{n} [V(t) - P(t)]
\]

Mean Absolute Deviation for Forecast Initialization

\[
MAD = \frac{1}{n} \sum_{t=1}^{n} |P(t) - V(t)|
\]

\[
n = \text{Number of periods for initialization}
\]

Mean Absolute Deviation for Ex-Post Forecast

\[
MAD(t) = (1 - \delta) \cdot MAD(t-1) + \delta \cdot |V(t) - P(t)|
\]
Tracking Signal

\[
(15) \quad TS = \left| \frac{ET}{MAD} \right|
\]

Theil Coefficient

\[
(16) \quad U = \frac{\sum_{t=1}^{T} (P(t) - V(t))^2}{\sum_{t=1}^{T} (V(t) - V(t-1))^2}
\]

- \(P(t)\) = Forecast value
- \(V(t)\) = Actual value
- \(ET\) = Error total
- \(TS\) = Tracking signal

Formula for the Tolerance Lane

To correct outliers automatically in the historical data on which the forecast is based, you select Outlier control in the forecast profile. The system then calculates a tolerance lane for the historical time series, based on the sigma factor. Historical data that lies outside the tolerance lane is corrected so that it corresponds to the ex-post value for that point in time. If you run the forecast online, historical data that has been automatically corrected by this function is indicated in column \(C\) of the Forecast: Historical Values dialog box.
Tolerance Lane

The width of the tolerance lane for outlier control is defined by the sigma factor. The smaller the sigma factor, the greater the control. The default sigma factor is 1, which means that 90 % of the data remains uncorrected. If you set the sigma factor yourself, set it at between 0.6 and 2.

Tolerance Lane

(17) Tolerance lane = ep ± σ * MAD
where ep = ex-post forecast
How to Carry Out Resource Leveling

Use

Effective resource planning is vital to the realization of operational targets. With SOP’s resource leveling function, you can assess the viability of your targets in terms of the resources required to meet them. This gives you the knowledge you need to fine-tune your targets and optimize the use of resources.

SOP’s resource leveling function enables you to take the resource load into account when planning, by allowing you to directly check how changes to your plans affect the resource situation. You can adjust your plans to make optimum use of available resources.

Since sales and operations planning is generally carried out at an early stage in the planning cycle and on an aggregate level, the resource load for work center groups or product families—rather than individual work centers or materials—is of particular interest. SOP typically focuses on a superior work center in the hierarchy (for example, the root of the hierarchy), a bottleneck work center, or a product grouping.

Prerequisites

Before you can carry out resource leveling in SOP, you must:

- Create a PP task list (a routing, a rate routing, or a rough-cut planning profile [Page 179]) for the material, product group, or characteristic values combination whose resources you want to plan.

- Configure resources planning in Customizing for Sales & Operations Planning.

- If you use routings or rate routings to do resource leveling, define the key figure to which the resources are tied. Do this in Customizing for Sales & Operations Planning under Set parameters for info structures and key figures.

- Define the planning plant of any information structure whose plant is not uniquely identifiable (that is, either your information structure does not contain the characteristic “plant” or your rough-cut planning profile covers more than one plant). Do this in Customizing for Sales & Operations Planning under Set parameters for info structures and key figures.

- Set the default SOP plant for Sales & Operations Planning. Do this in Customizing for Sales & Operations Planning under Set planning plant for SOP.

Process Flow in Standard SOP

You perform resource leveling for the production quantities of a product group or material. The following resources are possible: work center capacities, materials, production resources/tools and costs. These resources are recorded in a rough-cut planning profile [Page 179]. Work center capacities may also be read from a routing or rate routing.

Resource leveling may be carried out for the active version or any inactive version in a single-level planning screen.

You view the capacity load for work centers at the following scheduling levels:

- Detailed planning

- Rate-based planning
How to Carry Out Resource Leveling

- Rough-cut planning

The system generates resource requirements for the quantities that you have entered in the Production line of the standard planning table.

From the split planning screen of the standard planning table, you can branch into a standard analysis of the resource loads for materials and production resources/tools or costs.

**Process Flow in Flexible Planning**

In Flexible Planning, you perform resource leveling in the same way. Here, however, a resource may be tied to any key figure (not just production) and characteristic values combination (not just to a product group or material).

The system generates resource requirements for the planned key figure. If resource leveling is based on a rough-cut planning profile, this is the key figure defined here. If resource leveling is based on a routing or rate routing, this is the key figure defined in the information structure parameters (see “Prerequisites” above).

If resource leveling is based on a rough-cut planning profile, it must contain the same characteristic values combination as the one you are planning in the planning table. This means, for example, that you cannot view the resource requirements of just one product if you created the rough-cut planning profile for the whole product family.

See also:

- Resource Leveling [Page 183]
- Rough-Cut Planning Profiles [Page 179]
- Carrying Out Resource Leveling [Page 185]
Rough-Cut Planning Profiles

Definition

Rough-cut planning profiles are used in resource leveling. In a rough-cut planning profile, you plan the requirements of one or more of the following resources:

- Work center capacities
- Materials (typically, raw materials)
- Production resources/tools
- Costs

These are the resources you will require to meet a sales target, production target, purchasing target, or any other logistic target you have set for a material, product group, or characteristic value combination.

Rough-cut planning profiles are designed to give you an aggregate view on your resources; that is, you look at workdays rather than hours or minutes, and work center groups and product groups rather than individual work center or products. They are therefore an ideal tool for medium- and long-term planning or for the planning of hierarchies.

You enter your resources data in a few easy steps: the system guides you through a series of dialog boxes. The results of your entries are shown in a resources table which is laid out along the time axis.

The resources table displays a lot of information at a glance, that is, the resources required not just for the final assembly but for the entire production process, starting with the lowest-level components and ending with the finished product. Planned resources are displayed in the periods to which they relate.

In a rough-cut planning profile, you define the following:

- The material, product group, or (in the case of an information structure) combination of characteristic values requiring the resources.
- The key figure causing the resource load (if the rough-cut planning profile is defined for an information structure).
- The time span of one planning period in the resources table, expressed in workdays.
- The status of the rough-cut planning profile (as in a routing).
- The planner group of the rough-cut planning profile (as in a routing).
- The usage of the rough-cut planning profile (as in a routing).
- How much of which resource is required for the base quantity. For example, if the base quantity is 1 piece, the amounts you enter on one line of the resources table are the amounts required to produce 1 piece. Moreover, if you enter amounts in four columns, each column representing a timespan of one workday, then you are saying that it will take four workdays to produce 1 piece using this resource. The amounts you enter for the resource "work center" apply to each capacity category at the work center.
- The base quantity; that is, the number of units for which the resource is required. You cannot change the base quantity once you have saved the rough-cut planning profile. (In
Rough-Cut Planning Profiles

Release 3.0 the base quantity was always 1. In Release 4.0 you define the base quantity as required.

- The lot size range if the quantity of the resources required depends on lot size. Different lot sizes can have different base quantities. For example, a lot size of 1-10 may have a resource requirement of 1, and a lot size of 11-100 a resource requirement of 10.

See also:

Maintaining Rough-Cut Planning Profiles [Page 181]

How to Carry Out Resource Leveling [Page 177]
Resource Leveling [Page 183]
Carrying Out Resource Leveling [Page 185]
Maintaining Rough-Cut Planning Profiles

1. From the standard SOP or flexible planning menu, choose Tools → Rough-cut planning profile → Create (or Change or Display).
   
   A selection screen appears.

2. Enter the material, product group, or information structure to which you want the rough-cut planning profile to apply. In the case of a material or product group, enter a plant as well. In the case of an information structure, specify the characteristic values and key figures that generate the resource requirements.

3. Choose Execute.
   
   The dialog box General Data appears.

4. Enter a time span; the default time span is five days. As necessary, enter a status, a planner group, a usage, and/or a lot-size range.

5. Choose ENTER.
   
   The resources table appears.

6. Choose Choose.
   
   A dialog box appears asking you to choose between the four resource types.

7. Select a resource type and choose Continue.
   
   A dialog box appears in which you specify a resource.

8. Enter the resource which your material, product group, or information structure requires and choose ENTER.
   
   You return to the resources table.

9. In the resources table, enter the amount of the resource, per unit of the planning object, that you estimate will be consumed in each period.
   
   The amounts you enter for the resource "work center" apply to each capacity category at the work center.

10. Repeat steps 6 to 9 until you have entered all relevant resources.

    To delete a line in the rough-cut planning profile, place the cursor on it and choose Edit → Delete line.

11. To check an entry, place the cursor on it and choose Check.
   
   The system checks whether the selected resource exists. It also checks that at least one planned figure has been entered on every line. It does not check at this point whether the resource requirements can be met.

12. To save your rough-cut planning profile, choose Rough-cut planning profile → Save.

See also:
Rough-Cut Planning Profiles [Page 179]
Resource Leveling

Use: Resource Leveling for Work Center Capacities

SOP comes with a split screen for the planning and leveling of work center capacities. The advantage of the split planning screen is that you can compare the capacity situation directly with your plan. In the lower section of the screen, the available capacity, capacity requirements, and capacity load are displayed for each work center used in production and each capacity category. The system reads the available capacity from the work center, and the capacity requirements from the routing or rough-cut planning profile. If you change the production quantities/key figure values in the upper section of the screen, the new capacity requirements and capacity load appear in the lower section of the screen.

Planning is related to specific periods. For example, your company might plan to produce 1,000 units of the product group “chairs” in the month of May. In the same way, available capacity and capacity requirements are displayed on a period-by-period basis. For example, the system works out that 100 machine hours of an available 160 hours will be required at work center “assembly” in the month of May to produce 1,000 units of the product group “chairs”. You cannot overwrite the capacity requirements in the planning table. To change the capacity requirements in the planning table, you change the quantities in the production line (if you are working in standard SOP) or the key figure to which the capacities are tied (if you are working in flexible planning), and then you choose Enter.

Of particular interest is the capacity load. The capacity load shows you instantly whether you have sufficient capacities to realize your plan. Capacity load is expressed as a percentage. In our example, if the work center “assembly” requires 100 of the 160 available machine hours to produce 1,000 units of the product group “chairs”, then the capacity load is 62.5%.

SOP gives you an all-embracing view of the capacity situation. It takes into account the requirements of all materials, product groups, or characteristic value combinations for the same capacities. The Capacity requirements and Capacity load lines reflect total requirements for a particular capacity. To view the source of the capacity requirements in a period, place your cursor on them and choose Views → Capacity situation → Pegged requirements.

The system creates an SOP order for each production target in each period when you save the planning version. SOP orders are used internally. If capacity requirements exist, the system records these, too, with reference to the internal SOP order when you save the planning version.

If you run a background job (for example, a macro) that creates or changes the key figure to which the resources are tied, the new capacity requirements are automatically computed and updated internally for the SOP order.

If you change the rough-cut planning profile, the new capacity requirements are not shown in the planning table unless you change the production line or key figure to which the resources are tied. You can do this, for example, by defining a default macro (-1, +1).
Resource Leveling

In standard SOP, if you carried out capacity leveling at product group level before disaggregating the production line to the material level, the capacity requirements of the materials are not recorded internally for their SOP orders. However, these requirements need to exist if the Capacity requirements and Capacity load lines at the material level in the planning table are to show total requirements for a particular capacity. To create these requirements for the materials’ SOP orders, set up a macro to run in the background [Page 214]. Define this macro so that it changes the production line of the materials (for example, “production - 1, production + 1”). Where rough-cut planning profiles or routings exist for the materials, the system computes their capacity requirements and records them for their internal SOP orders.

How capacities are scheduled depends on whether the Scheduling indicator has been set and, in detailed planning, on which Scheduling type has been set (in Customizing for Sales & Operations Planning under Configure scheduling parameters).

Use: Resource Leveling for Materials, Production Resources/Tools, and Costs

You display the requirements for materials and production resources/tools or costs in a standard analysis. From here, you can drill down to further levels of detail on an item. For example, you can find out the amount of each material and production resource/tool required in a particular plant, or all the cost elements in a controlling area that will be affected by this consumption of resources.

You maintain requirements for materials, production resources/tools, and costs in a rough-cut planning profile [Page 179].

You can also create the planned availability of a material in a particular plant with Planning → Material availability. The availability of the material is then displayed in the standard analysis next to its planned requirements. You create the availability of a material with reference to a planning version. Different available quantities are possible in different planning versions. You can therefore simulate the effects of different availability situations in different planning versions.

You can save the results of a standard analysis as a version of information structure S093 (materials and production resources/tools) or S092 (costs).

For more information on standard analyses, see LO Logistics Information System.

See also:
How to Carry Out Resource Leveling [Page 177]
Rough-Cut Planning Profiles [Page 179]
Carrying Out Resource Leveling [Page 185]
Carrying Out Resource Leveling

1. From a single-level screen in the planning table, choose Views → Capacity situation and either Detailed planning, Rate-based planning, or Rough-cut planning → Show.

The split planning table appears. In the lower section of the screen, you see the available capacity, capacity requirements, and capacity load for each work center used in production and each capacity category.

In the event of an error, check that the prerequisites for resource leveling have been fulfilled (see How to Carry Out Resource Leveling [Page 177]).

2. Adjust the planning data in the upper section of the screen until you arrive at a plan which is also acceptable from the point of view of capacity.

3. To view the source of the capacity requirements in a period, place your cursor on them and choose Views → Capacity situation → Pegged requirements.

4. If desired, branch into a standard analysis of other resources with Views → Capacity situation → Rough-cut planning and either → Materials/PRT or Costs.

See also:

How to Carry Out Resource Leveling [Page 177]
Resource Leveling [Page 183]
Rough-Cut Planning Profiles [Page 179]
Maintaining Rough-Cut Planning Profiles [Page 181]
Version Management

Sales & Operations Planning (SOP) allows you to plan the same information structure as often as you like. You store each planning version under a version number with a description. This means you can construct different planning scenarios for one information structure. For example, you might plan your data several times using different forecasting techniques or with the exclusion and inclusion of events you expect to happen in the future.

A version number is numerical and consists of three digits.

Active versus Inactive Versions

Only one planning version of an information structure is “active”. This is version A00. All the other planning versions are “inactive”. The version of the information structure that contains actual as opposed to planned data is version 000.

A version is automatically active if it is the only planning version that exists for an information structure. If several versions exist, the active version is the first one you created unless you have copied data from an inactive version to the active version (see below). The active version contains the version of your planning data that you wish to be regarded as valid, whereas you use inactive versions as test versions to try out different scenarios.

In standard SOP, versions of plans for different product groups and/or materials are all stored in information structure S076.

Copying Versions

You can copy any version of an information structure to any other version of the same information structure. A series of pushbuttons supports your choice of version. You can limit the scope of the planning horizon for which the data is to be copied.

To copy data between versions of different information structures, you use a different transaction.

Activating Versions

To activate a planning version, you copy its data to version A00. This overwrites any existing data in A00, so if you want to keep this data you should copy it to another version first.

Deleting Versions

A facility for deleting versions is also available.

It is often advisable to use background processing to copy or delete versions because of the large volumes of data involved.
Copying a Version to another Version of the Same Information Structure

To copy a version to another version of the same information structure:

1. From the standard SOP or flexible planning menu, choose Planning → Version management → Copy.
2. In flexible planning, enter the information structure. In standard SOP, the system sets the information structure S076.
3. Specify the source version using the pushbuttons Active or Inactive.
4. Specify the target version using the pushbuttons Active, Inactive or New.
5. If necessary, define the scope of the planning horizon for which the data is to be copied.
6. Choose Copy.

💡

To copy large volumes of data, use background processing. For more information, see How to Copy a Version with Mass Processing [Page 221].
Deleting a Planning Version of an Information Structure

To delete a planning version:

1. From the standard SOP or flexible planning menu, choose Planning → Version management → Delete.
2. In flexible planning, enter the information structure. In standard SOP, the system sets the information structure S076.
3. Choose the version(s) you want to delete.
4. If necessary, define the scope of the planning horizon in which the data is to be deleted.
5. Choose Delete.

To delete large volumes of data, use background processing. For more information, see How to Delete a Version with Mass Processing [Page 223].
Aggregation and Disaggregation

A significant feature of Sales & Operations Planning (SOP) is its multi-level capabilities. You can plan both top-down and bottom-up throughout a complex planning hierarchy. Thus, both centralized and decentralized planning are supported.

The functions that enable you to do this are known as aggregation and disaggregation. In SOP, **aggregation** is the process by which planning data at an aggregate level is generated through the totaling, copying, or averaging of key figure values at a more detailed level. **Disaggregation**, on the other hand, is the process by which planning data at a detailed level is generated through the distribution of key figure values from an aggregate level.

Aggregation and disaggregation in SOP are supported by Application Link Enabling (ALE). This is a technique similar to EDI whereby data is exchanged between centralized and distributed applications running on different computers in a network. Thus, you can plan across regional and even national boundaries.

**Standard SOP**

In standard SOP, planning typically begins at an approximate, general level and is then gradually refined as you move down the product group hierarchy. Since both an active and an inactive planning version can be disaggregated, you can try out several different scenarios for the same hierarchy.

Whether you disaggregate sales volumes or production volumes or both depends on the current emphasis of your planning activities. Have you planned just the sales quantities of the product hierarchy root, which you now want to distribute to different sales regions—modeled as product groups? Or have you already taken your production decisions, in which case your objective is to distribute production over several plants, product lines, or manufacturing methods that are also represented in the product group hierarchy?

The planning method in standard SOP is level-by-level planning; aggregation or disaggregation, if desired, is triggered by the user.

**See also:**
- SOP Planning Methods [Page 14]
- Aggregation and Disaggregation in Standard SOP [Page 191]
- Disaggregating a Product Group Plan [Page 193]

**Flexible Planning**

Thanks to SOP’s different planning methods, you have a wide choice of possibilities for aggregating and disaggregating your planning data:

- **Consistent planning**
  
  Data is aggregated and disaggregated throughout the planning hierarchy **automatically**, whatever the level at which data is entered.

- **Level-by-level planning**
  
  **Manual intervention** by the user is required for both aggregation and disaggregation. You use the planning table function *Edit → Disaggregate line* to disaggregate data and a self-defined macro in the planning type to aggregate data.
Aggregation and Disaggregation

- Delta planning
  
  Data is aggregated, but not disaggregated, automatically.

The degree to which you wish aggregation and disaggregation to be automated, and therefore the decision on which planning method to use, will depend on a number of considerations. Do you want to plan top-down or bottom-up? Is data consistency your primary concern—for example, in a complex planning hierarchy with multiple nodes and a great many materials? Or is it more important for you to be able to keep a check on data at individual planning levels?

See also:

Planning Methods [Ext.]

Ways to Aggregate and Disaggregate in Consistent Planning [Page 194]

Ways to Aggregate and Disaggregate in Level-By-Level Planning [Page 198]

Ways to Aggregate and Disaggregate in Delta Planning [Page 199]
Ways to Aggregate and Disaggregate in Standard SOP

Selection of Product Group Members

You can carry out disaggregation of a product group either for all its members (product groups or materials) or for selected members only. This second option is particularly useful if you want to plan different branches of the product group hierarchy at different times. You select product group members in the dialog box via which you access the split planning screen. As a default, the system offers you all members of the owner product group, but you can change this selection in the checkboxes to their left.

Creation of Members' Sales Plans

You can set your disaggregation parameters for creation of members’ sales plans in the dialog box that appears before you reach the planning table. To have the system create members’ sales plans, check the box Create sales plans and select one of the two disaggregation strategies:

- Disaggregate production plans
- Disaggregate sales plans

You can also create members’ sales plans in the planning table using a function and/or a macro.

Creation of Members’ Production Plans

You can set your disaggregation parameters for creation of members’ production plans in the dialog box that appears before you reach the planning table. Five strategies are available for this purpose:

- Stock balance
  No production plans are created for the product group members.
- Target days’ supply
  The production quantities of the product group members are calculated such that a target days’ supply is met. To obtain this target days’ supply, you copy the days’ supply of the owner product group by checking the box Copy target days’ supply.
- Target stock level
  The production quantities of the product group members are calculated such that a target stock level is met. To obtain this target stock level, you copy the stock level of the owner product group by checking the box Disaggregate target stock.
- Stock level = zero
  The production quantities of the product group members are calculated such that their stock levels at the end of each period are zero.
- Synchronous to sales
  The production quantities of the product group members are calculated such that they are the same as the sales quantities.

You can also create members’ production plans in the planning table using a function and/or a macro.
Ways to Aggregate and Disaggregate in Standard SOP

**Macros to Perform Aggregation and Disaggregation**

Once you are in the planning table, you can perform aggregation or disaggregation between the owner product group and product group members using one of the standard macros (Edit $\rightarrow$ Macro). For a detailed description of each of these macros, see Macros [Page 120].
Disaggregating a Product Group Plan

To disaggregate a product group plan in standard SOP:

1. From the standard SOP menu, choose Disaggregation → Break down product group plan.

2. Enter the name of the product group you want to disaggregate together with its plant, and use the pushbuttons Active version and Inactive version to select a planning version.
   The screen in which you set your disaggregation parameters appears.

3. Select the product group members you want to plan and specify the desired disaggregation strategies.
   For more information, see Aggregation and Disaggregation in Standard SOP [Page 191].

4. To continue, choose ENTER.
   The standard planning table appears as a split screen.

5. Make any necessary adjustments to your data.
   All the standard planning table functions are available to you as well as a series of aggregation and disaggregation macros.

6. To save your plan, choose Planning → Save.
Ways to Aggregate and Disaggregate in Consistent Planning

For a brief outline of aggregation and disaggregation, see Concepts of Aggregation and Disaggregation [Page 189].

The way a key figure is aggregated and disaggregated depends on its aggregation type. This is defined in Customizing for Sales & Operations Planning (in Set parameters for info structures and key figures). The following graphic summarizes the principles by which data is aggregated and disaggregated in consistent planning. The only exception to these principles is aggregation and disaggregation in Characteristics Planning (see Aggregation and Disaggregation in Characteristics Planning [Page 197]).

Aggregation Type “Total Created”

The default aggregation type for planned key figures is Total created.

The system performs aggregation by adding together the key figure values at the detailed level and displaying the results on the total level at run time.

The system performs disaggregation as follows.

<table>
<thead>
<tr>
<th>If you are...</th>
<th>And...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a planning version and entering data for the first time.</td>
<td>You have already calculated the constant proportional factors for this planning hierarchy.</td>
<td>The data is distributed using the constant proportional factors.</td>
</tr>
<tr>
<td>Creating a planning version and entering data for the first time.</td>
<td>You have not already calculated the constant proportional factors for this planning hierarchy.</td>
<td>The data is distributed evenly.</td>
</tr>
<tr>
<td>Creating a planning version and overwriting data that you have entered during this planning session.</td>
<td>You have NOT applied the function Edit (\rightarrow) Disaggregate line to a key figure.</td>
<td>The data is distributed in accordance with the proportions that the system derives from the existing planned data.</td>
</tr>
<tr>
<td>Creating a planning version and overwriting data that you have entered during this planning session.</td>
<td>You have applied the function Edit (\rightarrow) Disaggregate line to a particular line and key figure.</td>
<td>The data is distributed using the constant proportional factors.</td>
</tr>
<tr>
<td>Changing a planning version.</td>
<td>You have NOT applied the function Edit (\rightarrow) Disaggregate line to a key figure.</td>
<td>The data is distributed in accordance with the proportions that the system derives from the existing planned data.</td>
</tr>
<tr>
<td>Changing a planning version.</td>
<td>You have applied the function Edit (\rightarrow) Disaggregate line to a particular line and key figure.</td>
<td>The data is distributed using the constant proportional factors.</td>
</tr>
</tbody>
</table>
Ways to Aggregate and Disaggregate in Consistent Planning

See also:
Automatic Calculation of the Proportional Factors in Consistent Planning [Page 38]
Calculating the Proportional Factors Automatically [Page 43]

Aggregation Type “Average Calculated”

The second option available for the aggregation and disaggregation of a key figure in consistent planning is the calculation of an average. It works like this:

- If you are in Create mode and enter or overwrite data at the aggregate level, this data is copied to the detailed level.
- If you are in Change mode and overwrite data at the aggregate level, the values at the detailed level change so that each one represents the same proportion of the aggregate value as before.
- If you create or change data at the detailed level, the new value at the aggregate level is calculated as the mean average of the values at the detailed level.

This option is designed for key figures that represent prices (for example, sales price per unit) or percentages (for example, percentage of purchasing budget already released).

Aggregation Type “No Aggregation”

This option is designed for key figures which do not need to be aggregated or disaggregated, such as text lines or auxiliary lines.

It is the default aggregation type for actual data.

Aggregation costs system performance, so select this option for lines that you do not need to aggregate.
Disaggregation in Consistent Planning

Start

Is the aggregation type “total created”? No

Is the aggregation type “average calculated”? Yes

Average is calculated

Is the aggregation type “no aggregation”? Yes

No aggregation takes place

Is the data being changed? Yes

Has “Edit -> Disaggregate line” been selected? Yes

Data is disaggregated according to the constant proportional factors

No

Data is disaggregated according to the existing planning data in each period

Is the data being created and entered for the first time? Yes

Do constant proportional factors exist? Yes

Data is disaggregated according to the constant proportional factors

No

Data is distributed evenly

No aggregation takes place
Aggregation Logic in Characteristics Planning

Use

You use a self-defined information structure for the high-level planning of products with many variants. The bottom level of this structure must contain the characteristic [Ext.] "combination value key". The next level must contain the characteristic [Ext.] "characteristics combination". You must set the consistent planning method for this information structure [Ext.]. However, aggregation and disaggregation function in a slightly different way than with other consistently planned information structures: data is copied, and not added together, between the levels “characteristics combination” and “material.”

Example of Characteristics Planning with Self-Defined Information Structure
Ways to Aggregate and Disaggregate in Level-By-Level Planning

For a brief outline of aggregation and disaggregation, see Concepts of Aggregation and Disaggregation [Page 189].

In level-by-level planning, manual intervention by the user is required for both aggregation and disaggregation.

You can use the planning table function Edit → Disaggregate line to disaggregate data and a self-defined macro (created in the planning type) to aggregate data. Disaggregation is carried out on the basis of the proportional factors stored in the planning hierarchy master record.

See also:

Implementation Guide for Sales & Operations Planning (“Set parameters for info structures and key figures”)

Automatic Calculation of the Proportional Factors in Level-By-Level Planning [Page 41]
Calculating the Proportional Factors Automatically [Page 43]
Ways to Aggregate and Disaggregate in Delta Planning

For a brief outline of aggregation and disaggregation, see Concepts of Aggregation and Disaggregation [Page 189].

In delta planning, data is aggregated automatically. Disaggregation is not defined for this planning method.
Mass Processing in SOP

Use

SOP comes with a mass processing function that allows you to process large volumes of data in a few simple steps. To optimize the use of system resources, you run mass processing jobs in the background. Actions supported by mass processing are:

- Forecasting [Page 202]
- Copying key figures from one information structure to another [Page 203]
- Executing macros [Page 214]
- Transferring SOP Data to Demand Management (PP-MP-DEM) [Page 215]
- Transferring SOP Data to Profitability Analysis (CO-PA) [Page 241]
- Copying a planning version to another planning version of the same information structure [Page 221]
- Deleting a planning version [Page 223]
- Setting opening stock levels [Page 227]

Features

- Planning horizon
  With the exception of the forecast, the planning horizon of a mass processing job is the one you define in the planning type. You define the planning horizon for the forecast in the forecast profile.

- Planning hierarchy
  A mass processing job uses the planning hierarchy that existed when you created the job. Therefore, a job that is scheduled to run at periodic intervals will not automatically take into account changes to the planning hierarchy. To avoid getting incorrect results with such jobs, include in the variant all the new characteristic value combinations that were not part of the original planning hierarchy.

- Execution level (aggregation level)
  The planning level at which a mass processing job is executed is determined by the planning level given in the variant. The execution level (that is, the aggregation level) can make a major difference to the results. For example, if you run the forecast at an aggregate level, the system aggregates the historical data before it carries out the forecast. However, if you run the forecast at the detailed level, the system carries out the forecast based on the historical data at this level, and then aggregates the forecast results in the planning table at run time. See also Macros [Page 120].

- Checking the job
  You can check a mass processing job before you run it. See How to Check a Mass Processing Job [Page 228].

- Saving the results
If you want to carry out several actions of different types, SAP recommends that you define a planning activity [Page 209] and a planning job [Page 219] for each action. This is particularly important because the quantities transferred to Demand Management are those that the system finds in the database. For example, if the key figure you want to transfer changes as the result of a macro, the results of this macro need to have been saved in the database first.

- **Seeing the results**

  You can see a job’s processing status in the job overview (Planning → Mass processing → Job overview). Via the job overview, you can also access a log that shows what the job consisted of and when it started and finished. In addition, you can access a spool list via the job overview. For a detailed breakdown of the job results, see the mass job report [Page 231].

**See also:**

BC System Services
How to Run the Forecast with Mass Processing

You can use SOP’s mass processing function to run the forecast. In this process:

1. You create a forecast profile. [Page 166]
2. You create a planning activity and include in it this action (the forecast profile). [Page 218]
3. You create a mass processing job for this activity. [Page 219]
4. You schedule this mass processing job. [Page 220]

The results of the forecast will be different if the forecast is run at a high level and the results then disaggregated to the detailed level than if you carry out the forecast at the detailed level.
How to Copy Key Figure Values Between Information Structures with Mass Processing

You can use SOP's mass processing function to copy key figure values from one information structure to another. There are two procedures for this:

- You carry out an aggregate copy from consistent planning to consistent planning with subsequent distribution.
  - For more information, see Standard Copying Methods [Page 134].
- All other situations

Aggregate Copy from Consistent Planning to Consistent Planning

1. You create a key figure assignment profile [Page 204].
   - This procedure can be performed either online or in Customizing.
2. You create and schedule a mass processing job for high-level copying [Page 213].

All Other Situations

1. If the copying method is not defined in the standard SAP R/3 System, you create a user method.
   - For more information, see Standard Copying Methods [Page 134] and Defining User Methods [Page 232].
2. You create a key figure assignment profile [Page 204].
   - This procedure is performed either online or in Customizing for Sales & Operations Planning (SOP).
3. You create a copy profile [Page 207].
   - This procedure is performed either online or in Customizing for Sales & Operations Planning (SOP).
4. You create a planning activity and include this action (the copy profile) in it [Page 218].
5. You create a mass processing job for this activity [Page 219].
6. You schedule this mass processing job [Page 220].
Creating a Key Figure Assignment Profile

You can create a key figure assignment profile either online or in Customizing (in “Maintain key figure assignment profiles”).

To create a key figure assignment profile from the standard SOP or flexible planning menu:

1. Choose Settings → Mass processing → Copying → Key figure assignments.
   The Specify Information Structures dialog box appears.
2. Enter a source information structure and a target information structure; that is, the names of the information structures from and to which you want to copy your data.
3. To continue, choose ENTER.
   The Assign Key Figures dialog box appears.
4. To specify a key figure from the source information structure, select the radio button next to it (you are in the top half of the window) and choose Choose (or simply double-click on the key figure).
   The key figure is copied to the group box Key figure(s) assignment.

   ![Tip]

   You can scroll up and down the key figures list using the buttons underneath it.
5. To specify the key figure in the target information structure to which you want data to be copied, select the radio button next to it (you are in the top half of the window) and choose Choose (or simply double-click on the key figure).
   The key figure is copied to the group box Key figure(s) assignment.

   ![Tip]

   You can also save several key figures under the same assignment key in the event that you want several key figures to be copied together. Repeat steps 4 and 5 until you have listed all the key figure assignments you require.
6. Choose Save assignment.
   The Save Key Figure Assignment dialog box appears.
7. Enter a key for your key figure assignment profile.
   This is any string of characters that you will be able to remember and find easily. It will provide the link to the copy profile or planning job. You can display existing key figure assignments with Display existing.
8. To save the key figure assignment profile, choose Save assignment.
9. To exit this transaction, choose Continue.
Using an Existing Key Figure Assignment Profile to Create a New One

If you want to combine an existing key figure assignment profile with a new one that you have not yet created, you copy the existing one as follows:

1. In the Assign Key Figures box, choose Open assignment.
   The Display Key Figure Assignments box appears.
2. Click on the required assignment key and choose Choose.
3. To copy these figures to the Assign Key Figures box, choose Continue.
Key Figure Assignment Profiles and Copy Profiles

To copy key figure [Ext.] values from one information structure [Ext.] to another with mass processing, you use a combination of two profiles:

- Key figure assignment profile
  This defines the information structures and the key figures on which the copy process is based.

- Copy profile
  This defines the planning versions and the dates on which the copy process is based.

In the event that you want to copy several key figures between the same source and target information structures, you define these key figures in one key figure assignment profile.

You can use one key figure assignment profile with as many copy profiles as you like, which means you can copy the same key figures as often as you like between different versions of the same information structures.

The combination of a copy profile and a key figure assignment profile facilitates data entry since you make the necessary settings once only.

Your company uses one information structure to plan sales and another information structure to plan production.

You can use the combination of a copy profile and a key figure assignment profile to define that the key figures for "planned sales quantities" are copied from version A00 of the first information structure to the key figures for "planned production quantities" in version A00 of the second information structure.

To find out how to copy data directly in the planning table, see Copying Data from One Information Structure to Another [Page 132].

To find out how to create a key figure assignment profile, see Creating a Key Figure Assignment Profile [Page 204].

To find out how to create a copy profile, see Creating a Copy Profile [Page 207].
Creating a Copy Profile

You can create a copy profile either online or in Customizing (in Maintain copy profile).

To create a copy profile [Page 206] from the standard SOP or flexible planning menu:

   The Copy Profiles window appears.
2. Choose New entries.
3. Make the necessary entries for your copy profile:
   a) Enter a key for your copy profile.
   b) Specify the versions of the source and target information structures.
      These are the information structures defined in the key figure assignment profile.
   c) Enter a key figure assignment profile.

   The “from” and “to” dates for the copying action are taken from the planning type you enter in the activity.
4. Choose Table view → Save.
Creating a Planning Activity

You can create an activity for mass processing either online or in Customizing (in “Define activities”).

To create a planning activity for mass processing online:

1. From the standard SOP or flexible planning menu, choose Settings → Mass processing → Activities.
2. Choose Edit → New entries.
3. Enter a key to identify the mass processing activity.
4. If the activity includes more than one action, specify a number to determine the sequence in which the actions in this activity are carried out. Otherwise, leave this field blank.
   
   The system performs all actions for one characteristic value before moving on to the next characteristic value. See also Planning Activities.
5. In the field Planning type, specify the planning type to which the activity refers.
   
   If you are copying key figure values from one information structure to another, this is a planning type of the target information structure.
6. In the field Action, specify whether the action is a macro, a transfer to Demand Management, the copying between versions of different information structures, or forecasting.
7. Depending on the action you have specified, enter a macro, a transfer profile, a copy profile, or a forecast profile.
8. If the action is forecasting, enter the field of the key figure to be forecasted in the field Field name.
9. Choose Table view → Save.
Planning Activities

You create a planning activity in order to carry out mass processing [Page 200] for the following actions:

- Forecasting
- Copying key figures from one information structure to another
- Executing macros
- Transferring data to Demand Management
- Transferring data to Profitability Analysis

When copying key figures from one information structure to another, you do not need to create an activity if both of the following apply:

- Consistent planning is defined for both the source and the target information structures.
- You require a high-level copy with subsequent distribution.

For more information on high-level copying, see Standard Copying Methods [Page 134].

An activity can comprise one or more actions. For example, you might run a mass processing job that executes several macros at the same time. The sequence in which these actions are processed depends on the sequential numbers you define for them in the activity. The system performs all actions for the first characteristic value before processing the second characteristic value.

<table>
<thead>
<tr>
<th>Characteristic value</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales organization NORTH</td>
<td>First macro</td>
</tr>
<tr>
<td></td>
<td>Second macro</td>
</tr>
<tr>
<td></td>
<td>Third macro</td>
</tr>
<tr>
<td>Sales organization SOUTH</td>
<td>First macro</td>
</tr>
<tr>
<td></td>
<td>Second macro</td>
</tr>
<tr>
<td></td>
<td>Third macro</td>
</tr>
</tbody>
</table>

Consequently, if you want the system to perform one action for all characteristic values before it starts the next action, you must define separate planning activities.

If you want to carry out several actions of different types, SAP recommends that you define a planning activity and a planning job for each action. This is particularly important because the quantities transferred to Demand Management are those that the system finds in the database. For example, if the key figure you want to transfer changes as the result of a macro, the results of this macro need to have been saved in the database first.
Planning Activities

For the following four actions, you create four planning activities:
- Forecast sales of materials
- Copy this sales data into another information structure
- Execute a macro on this data thereby generating production quantities
- Transfer this production data to Demand Management

See also:
Creating a Planning Activity [Page 218]
Creating a Mass Processing Job

To create a job for mass processing:

1. From the standard SOP or flexible planning menu, choose Planning → Mass Processing → Create.
2. Enter a number and description for the job.
3. Choose Planning job → Execute.
4. Enter the information structure for which you want to run the job together with the desired planning version of this information structure.
   If you are copying key figure values from one information structure to another, these are the target information structure and the target version.
5. Choose Planning job → Execute.
6. Choose a planning type.
   If you are copying key figure values from one information structure to another, this is a planning type of the target information structure.
7. Either choose an existing variant or create one.

- Planning hierarchy
  A mass processing job uses the planning hierarchy that existed when you created the job. Therefore, a job that is scheduled to run at periodic intervals will not automatically take into account changes to the planning hierarchy. To avoid getting incorrect results with such jobs, include in the variant all the new characteristic value combinations that were not part of the original planning hierarchy.

- Execution level
  The planning level at which a mass processing job is executed is determined by the planning level given in the variant. The execution level can make a major difference to the results. For example, if you run the forecast at an aggregate level, the system aggregates the historical data before it carries out the forecast. However, if you run the forecast at the detailed level, the system carries out the forecast based on the historical data at this level, and then aggregates the forecast results in the planning table at run time. See also Macros [Page 120].

- Variant control parameter
  If you create a variant, you must specify the planning activity as the variant control parameter. If necessary, you can limit the scope of the job by entering values for the characteristics. On a separate screen, you enter a description for your variant. For more information on variants, see the BC ABAP/4 User’s Guide.

The mass processing job is now created. Proceed to Scheduling a Mass Processing Job [Page 220].
Scheduling a Mass Processing Job

To schedule a mass processing job:


2. Enter the number of the job you wish to schedule, if necessary, using the possible entries button.

3. Choose Program → Execute.
   The Start Time window appears.

4. Specify the time when you wish the job to start.

5. Choose Save.
   The job has now been scheduled.

For more information on background jobs, see BC Computing Center Management System.
Creating and Scheduling a Background Job for High-Level Copying Between Information Structures

To carry out a high-level copy between information structures for which consistent planning has been defined:

1. From the flexible planning menu, choose Planning → Mass processing → Copy/delete version → High-level copy.
2. Enter the target information structure and target planning version, together with a planning type of the target information structure.
3. Enter the source information structure and the source planning version.
4. In the From date and To date fields, specify the period for which you want data to be copied.
5. Enter an existing key figure assignment profile.
   To find out how to create a key figure assignment profile, see Creating a Key Figure Assignment Profile [Page 204].
6. Choose Program → Execute.
   The Start Time window appears.
7. Specify the time when you wish the job to start.
8. Choose Save.
   The job has now been scheduled.

For more information on background jobs, see BC Computing Center Management System.

See also:

Standard Copying Methods [Page 134]
How to Copy Key Figure Values Between Information Structures with Mass Processing [Page 203]
Defining User Methods [Page 232]
How to Execute a Macro with Mass Processing

You can use SOP's mass processing function to execute a macro. In this process:

1. You create a planning type and define it in the macro
   This procedure can be performed either online or in Customizing.
2. You create a planning activity and include in it this action (the macro). [Page 218]
3. You create a mass processing job for this activity. [Page 219]
4. You schedule this mass processing job. [Page 220]
How to Transfer Data to Demand Management with Mass Processing

You can use SOP's mass processing function to transfer the results of SOP to Demand Management. In this process:

1. You create a transfer profile [Page 216].
   This procedure can be performed either online or in Customizing.
2. You create a planning activity and include in it the transfer profile [Page 218].
3. You create a mass processing job for this activity [Page 219].
4. You schedule this mass processing job [Page 220].

See also:
Transfer to Demand Management [Page 235]
Plant Distribution Quotas [Page 239]
Creating a Transfer Profile

To create a transfer profile [Page 217] for the transfer of SOP data to Demand Management:

1. From the standard SOP or flexible planning menu, choose Settings → Mass processing → Transfer profiles.
2. Choose New entries.
3. Enter a name for your transfer profile. This name can be numeric or alphanumeric and up to 10 characters long.
4. Enter a transfer strategy.

The “from” and “to” dates for the transfer action are taken from the planning type you enter in the activity.

5. In the field Table, enter the table that has been generated for the information structure from which you want to transfer data. This table has the same name as the information structure itself. If you are transferring data from standard SOP, this is the information structure S076.

6. In the field Field name, enter the field of the key figure which you want to transfer.

7. If you do not want the system to define the requirements type, enter a requirements type in the field Requirements type. Otherwise, the requirements type will be determined automatically.

8. If required, enter a version number to identify your data as a particular version of the demand program.

9. To indicate that this version of the demand program is relevant to MRP, set the Active indicator. Otherwise, leave this field blank.

10. Choose Table view → Save.

See also:

How to Transfer Data to Demand Management with Mass Processing [Page 215]
Transfer to Demand Management [Page 235]
Transfer Profiles [Page 217]
Transfer Profiles

You can transfer SOP data to Demand Management where it is processed further. To do this, you create a transfer profile.

Transfer profiles facilitate data entry since you do not have to make the necessary settings every time you transfer planning data to Demand Management; instead, you simply choose a transfer profile.

A critical setting in a transfer profile is the transfer strategy. The transfer strategy specifies the method by which data is transferred to Demand Management. There are five possible strategies:

- You transfer the planning data of a material direct from the sales plan (created in the standard planning table).
- You transfer the planning data of a material from the sales plan (created in the standard planning table) as a proportion of the product group of which it is a member.
- You transfer the planning data of a material direct from the production plan (created in the standard planning table).
- You transfer the planning data of a material from the production plan (created in the standard planning table) as a proportion of the product group of which it is a member.
- You transfer the planning data of a material from an information structure (either a planned information structure or a planning type based on an information structure).

To learn how to create a transfer profile, see Creating a Transfer Profile [Page 216].
Creating a Planning Activity

You can create an activity for mass processing either online or in Customizing (in “Define activities”).

To create a planning activity [Page 209] for mass processing online:

10. From the standard SOP or flexible planning menu, choose Settings → Mass processing → Activities.
12. Enter a key to identify the mass processing activity.
13. If the activity includes more than one action, specify a number to determine the sequence in which the actions in this activity are carried out. Otherwise, leave this field blank.

The system performs all actions for one characteristic value before moving on to the next characteristic value. See also Planning Activities [Page 209].

14. In the field Planning type, specify the planning type to which the activity refers.

If you are copying key figure values from one information structure to another, this is a planning type of the target information structure.

15. In the field Action, specify whether the action is a macro, a transfer to Demand Management, the copying between versions of different information structures, or forecasting.

16. Depending on the action you have specified, enter a macro, a transfer profile, a copy profile, or a forecast profile.

17. If the action is forecasting, enter the field of the key figure to be forecasted in the field Field name.

18. Choose Table view → Save.
Creating a Mass Processing Job

To create a job for mass processing:

8. From the standard SOP or flexible planning menu, choose Planning → Mass Processing → Create.

9. Enter a number and description for the job.


11. Enter the information structure for which you want to run the job together with the desired planning version of this information structure.

   If you are copying key figure values from one information structure to another, these are the target information structure and the target version.


13. Choose a planning type.

   If you are copying key figure values from one information structure to another, this is a planning type of the target information structure.

14. Either choose an existing variant or create one.

   • Planning hierarchy
     A mass processing job uses the planning hierarchy that existed when you created the job. Therefore, a job that is scheduled to run at periodic intervals will not automatically take into account changes to the planning hierarchy. To avoid getting incorrect results with such jobs, include in the variant all the new characteristic value combinations that were not part of the original planning hierarchy.

   • Execution level
     The planning level at which a mass processing job is executed is determined by the planning level given in the variant. The execution level can make a major difference to the results. For example, if you run the forecast at an aggregate level, the system aggregates the historical data before it carries out the forecast. However, if you run the forecast at the detailed level, the system carries out the forecast based on the historical data at this level, and then aggregates the forecast results in the planning table at run time. See also Macros [Page 120].

   • Variant control parameter
     If you create a variant, you must specify the planning activity as the variant control parameter. If necessary, you can limit the scope of the job by entering values for the characteristics. On a separate screen, you enter a description for your variant. For more information on variants, see the BC ABAP/4 User’s Guide.

The mass processing job is now created. Proceed to Scheduling a Mass Processing Job [Page 220].
Scheduling a Mass Processing Job

To schedule a mass processing job:

6. Choose *Planning* → *Mass processing* → *Schedule*.

7. Enter the number of the job you wish to schedule, if necessary, using the possible entries button.

8. Choose *Program* → *Execute*.
   
The Start Time window appears.

9. Specify the time when you wish the job to start.

10. Choose *Save*.
    
The job has now been scheduled.

For more information on background jobs, see *BC Computing Center Management System*. 
How to Copy a Version with Mass Processing

You can use SOP's mass processing function to copy the contents of one planning version to another planning version of the same information structure. In this process:

1. You define the job parameters.
2. You get or create a variant for this job.
3. You schedule the job.

For a step-by-step description of this process, see Copying a Planning Version with Mass Processing [Page 222].
Copying a Planning Version with Mass Processing

To copy the contents of one planning version to another planning version of the same information structure using a mass processing job:

1. From the standard SOP or flexible planning menu, choose Planning → Mass processing → Copy/delete version → In info structure.
   The screen in which you specify the parameters for your job appears.
2. Enter the information structure(s) to which the job is to apply.
3. If you want to limit the scope of the planning horizon, enter dates in the From date and To date fields.
4. Enter the source version, that is, the planning version from which you want the data to be copied.
5. Enter the target version, that is, the planning version to which you want the data to be copied.
   If this version does not already exist, the system will create it.
6. Choose either Edit → Get variant to use an existing variant or Edit → Save as variant to create a variant.
7. On the next screen, specify your variant attributes.
   For more information on variants, see the BC ABAP/4 User’s Guide.
8. Choose Save.
9. To schedule the job, choose Program → Execute and specify a start time.
10. Choose Save.
    Your job will run at the time specified.

To find out how to perform this task online, see Copying a Version to another Version of the Same Information Structure [Page 187].
How to Delete a Version with Mass Processing

You can use SOP’s mass processing function to delete a planning version. In this process:

1. You define the job parameters.
2. You create a variant for this job.
3. You schedule the job.

For a step-by-step description of this process, see Deleting a Planning Version with Mass Processing [Page 224].
Deleting a Planning Version with Mass Processing

To delete a planning version using SOP's mass processing function:

1. From the standard SOP or flexible planning menu, choose Planning → Mass processing → Copy/delete version → In info structure.
   The screen in which you specify the parameters for your job appears.
2. Enter the information structure(s) to which the job is to apply.
3. If you want to limit the scope of the planning horizon, enter dates in the From date and To date fields.
4. Enter the version whose data you want to be deleted.
5. Choose either Edit → Get variant to use an existing variant or Edit → Save as variant to create a variant.
6. On the next screen, specify your variant attributes.
   For more information on variants, see the BC ABAP/4 User’s Guide.
7. Choose Save.
8. To schedule the job, choose Program → Execute and specify a start time.
9. Choose Save.
   Your job will run at the time specified.

To find out how to perform this task online, see Deleting a Planning Version of an Information Structure [Page 188].
How to Set Opening Stock Levels with Mass Processing

You can use SOP’s mass processing function to set opening stock levels in information structures [Ext.] which contains the characteristic “material”. In this context, a material can also be a product group [Page 46].

This function is available with consistent planning [Page 14] and level-by-level [Page 14] planning.

These stock levels are visible in the 0 column of the planning table every time you plan a chosen planning version of the information structure. You can change them in the planning table if necessary.

The procedure for setting opening stock levels consists of three steps:

1. You specify the information structure.
2. You create a variant for this job.
3. You schedule the job.

You set the variant parameters as follows:

- **Characteristics [Ext.]**
  Specify the ranges of characteristic values [Ext.] for which you want opening stock levels to be set. If consistent planning is used for this information structure, you can specify any planning level. If level-by-level planning is used, you must specify the characteristic values down to the material level.

  The materials you enter can include product groups. In other words, you can set the opening stock levels of any combinations of product groups and/or materials in one mass processing job.

- **Key figure [Ext.]**
  Enter the field name of the key figure in which you want the opening stock levels to appear.

- **From date/to date**
  Enter dates here if you select Average stock below.

- **Method of determining opening stock levels**
  Select either Average stock, or Current stock, or Self-defined.

  The Average stock option allows you to use average daily stock levels over a specified period of time as your initial stock levels.

  The Current stock option allows you to use the current stock levels as your initial stock levels.
How to Set Opening Stock Levels with Mass Processing

The *Self-defined* option allows you to use a method. In the field underneath it, you enter the name of the method. For more information, see [Defining User Methods](Page 232).

See also:

[Setting Opening Stock Levels](Page 227)
Setting Opening Stock Levels

To set opening stock levels using SOP’s mass processing function:

1. From the flexible planning menu, choose Planning → Mass processing → Opening stock levels.

2. Specify the information structure [Ext.] in which you want to set the stock levels.
   
   ![Tip](image)

   This must be an information structure which contains the characteristic [Ext.] “material”. Choose Program → Execute.

3. Create a variant or choose an existing variant. You create a variant with Create if no variant yet exists or with Cancel if variants already exist.

4. Define the selection parameters of the new variant.
   
   See How to Set Opening Stock Levels with Mass Processing [Page 225].

5. Choose Edit → Continue.

6. Enter a description for your variant and choose Background only.

7. Save the variant.

8. Choose Variant → Exit.

9. Specify the date and time when the job is to start.

10. Choose Save.

   Your job will run at the time specified.

For more information on variants, see the BC ABAP/4 User’s Guide.
How to Check a Mass Processing Job

You can carry out the following checks on a mass processing job:

**All Planning Jobs**
- Does the variant (still) exist?

**Copying Data from One Information Structure to Another**
- Does the activity contain the name of a copy profile?
  - If so, the copy profile will be visible when you carry out the Customizing activity *Define activities*.
- Does the copy profile exist?
  - If so, it will be visible when you carry out the Customizing activity *Maintain copy profiles*.

**Transferring Data to Demand Management**
- Does the activity contain the name of a transfer profile?
  - If so, the transfer profile will be visible when you carry out the Customizing activity *Define activities*.
- Does the transfer profile exist?
  - If so, it will be visible when you carry out the Customizing activity *Maintain transfer profiles*.

**Executing a Macro**
- Does the activity contain the name of a macro?
  - If so, the macro will be visible when you carry out the activity *Define activities*.
- Does the macro exist?
  - If so, it will be visible when you carry out the Customizing activity *Maintain planning types*.
- Does more than one aggregation/disaggregation macro exist for the job?
  - This is not allowed because the results of such macros may conflict.

💡

In level-by-level planning, you can set the Sort indicator to have the characteristic values sorted sequentially:
- From top to bottom if the macro carries out disaggregation
- From bottom to top if the macro carries out aggregation

**Carrying Out the Forecast**
- Does the activity contain the name of a forecast profile?
  - If so, it will be visible when you carry out the Customizing activity *Define activities*.
- Does the forecast profile exist?
If so, it will be visible when you carry out the Customizing activity *Maintain forecast profiles*

- Do the start dates precede the finish dates in the forecast profile?
- Have the dates been entered in the forecast profile in the format YYYYMMDD?
- If no forecast finish date has been entered, has the number forecast periods been maintained? If so, the system will carry out the forecast on the basis of the forecast start date and the number of forecast periods.
- If neither a forecast start date nor a forecast finish date has been entered, has the number of forecast periods been maintained? If so, the system will carry out the forecast on the basis of the current date and the number of forecast periods.
- Has a valid storage periodicity been maintained in the Customizing activity *Set parameters for info structures and key figures*?
- If the storage periodicity is "P", has a fiscal year variant also been maintained in Customizing?
- Does the forecast horizon fall within the planning horizon defined in the planning type?
  
    - The forecast horizon and the planning horizon are displayed, insofar as they can be determined.
    - The section of the planning horizon for which the forecast can be out is displayed.

**See also:**

*Checking a Mass Processing Job* [Page 230]

*Mass Job Reports* [Page 231]
Checking a Mass Processing Job

To check a mass processing job, choose Planning → Mass processing → Check from the flexible planning or standard SOP menu.

See also:
How to Check a Mass Processing Job [Page 228]
Mass Job Reports [Page 231]
Mass Job Reports

Use

Before you run a mass processing job, use this report to see which characteristic value combinations will be processed. You can exclude from the report any characteristic value combinations that you do not wish to process with this job.

After a mass processing job has run, you can see which characteristic values combinations were processed using Planning → Mass processing → Revise. The mass job report shows you not only the status of the job, but also the status of each characteristic values combination. If the job contained errors (status E), you know for which characteristic value combinations you need to repeat the job. The Step column indicates the sequence in which different actions were carried out: for example, forecast = 1 and macro = 2.

You can process this report in a number of different ways:

<table>
<thead>
<tr>
<th>Function</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>View the status message of a characteristic values combination.</td>
<td>Select it and choose Edit → Display message.</td>
</tr>
<tr>
<td>Sort the report in ascending or descending order.</td>
<td>Choose Edit → Sort ascending or Edit → Sort descending.</td>
</tr>
<tr>
<td>Find a characteristic values combination.</td>
<td>Choose Edit → Find and enter the desired search criteria.</td>
</tr>
<tr>
<td>Download the report to a PC file.</td>
<td>Choose List → Save as PC file, select the desired format, and enter the desired path and file name.</td>
</tr>
<tr>
<td>Print the report.</td>
<td>Choose List → Print.</td>
</tr>
<tr>
<td>Delete a characteristic values combination from the report.</td>
<td>Select it and choose Edit → Delete.</td>
</tr>
<tr>
<td>Save the report.</td>
<td>Choose List → Save.</td>
</tr>
</tbody>
</table>
Defining User Methods

A user method is a program or programs written by your company to perform a clearly defined, highly specific task when certain conditions are fulfilled. For example, a method allows you to perform complex transformations on statistical data. It consists of administrative information and an ABAP/4 FORM routine which you write yourself.

In Sales & Operations Planning, you can define methods for the following situations:

- the setting of initial stock values (B)
  For full information on the different possibilities for setting opening stock levels in the background, see:
  - How to Set Opening Stock Levels with Mass Processing [Page 225]
  - Setting Opening Stock Levels [Page 227]
- the copying of planned key figure values from one information structure to another (Y)
  If the combination of planning methods from and to which you want to copy is not defined in the R/3 System (see Standard Copying Methods [Page 134]), you create a copying method.
- the reduction in the number of fully qualified records from an information structure, determined by the Master Data Generator, to those records relevant for planning (P)
  For information on the Master Data Generator, see:
  - Master Data Generator in Flexible Planning [Page 29]
  - Master Data Generator in Standard SOP [Page 50]
  - Running the Master Data Generator in Flexible Planning [Page 31]
  - Running the Master Data Generator in Standard SOP [Page 51]

  You can also create a method to plan characteristic values that are not updated from the operative applications. For an example, see “Copy Management” in Customizing for the Logistics Information System.

In a method, you maintain the following:

- method usage (B, Y, or P)
- method
  This is a four-character key of your choice which denotes the method.
- source table
  This is the source information structure.
- target table
  This is the target information structure. If the method usage is ‘B’ or ‘P’, you enter the same information structure for both the source and the target table.
- program
This is the program in which you create the FORM routine for the transformation.

- subroutine
  This is the FORM routine with which the data transformation is carried out.

- description
  This is a description of the method.

**To create a method:**

1. From the flexible planning or standard SOP menu, choose *Settings → User methods*.
2. Enter the method usage (B, Y, or P) and press *Enter*.
3. To see an example of this method usage, place your cursor on one of the scenarios and click the pushbuttons *Documentation* and *Reference*.
5. Maintain your entries (see above).

   To branch into the editor for program or subroutine maintenance, double-click on the field *Program* or *Subroutine*.

6. Choose *Table view → Save*. 
Transferring SOP Data to Other R/3 Applications

You have the following options for transferring SOP data to other R/3 applications:

- Transfer to Demand Management (PP-MP-DEM) [Page 235]
- Transfer to Profitability Analysis (CO-PA) [Page 241]
- Transfer to Cost Center Accounting (CO-OM-CCA) [Page 243]
- Transfer to Activity-Based Costing (CO-OM-ABC) [Page 247]
Transfer to Demand Management

Use

You can pass on data planned in Flexible Planning or Standard SOP to Demand Management. Demand Management determines the requirement dates and requirement quantities for important assemblies and specifies the strategies for planning and producing/procuring finished products. The result of Demand Management is the demand program. The demand program differentiates planned independent requirements and customer independent requirements. It gives the information needed in MPS and MRP for planning at SKU level. The placing of sales orders eventually consumes planned requirements and triggers updating to the Sales Information System. This actual data can then be used as input for future sales planning. For more information, see PP Demand Management.

Prerequisites

The system distributes the data to the appropriate plants in Demand Management on the basis of the quotas you set in Customizing (in Define proportional distribution across plants). You can also make these settings in the Flexible Planning or Standard SOP menu by choosing Settings → Plant distribution. Plant distribution works as follows:

1. If a plant or plants can be found for the material in the planning hierarchy, data is transferred to Demand Management for these plants.
2. If no plant can be found in the planning hierarchy, the system checks to see which plants have been maintained for the material in the material master record. It then checks to see whether distribution quotas have been maintained for the material. If quotas have been maintained, the transfer to Demand Management is based on these quotas.
3. If no distribution quotas are found for the material, the system checks to see whether you have set generic distribution quotas; that is, distribution quotas that apply to all materials. If so, the transfer to Demand Management is based on these quotas. If generic quotas exist for some but not all plants maintained in the material master record, the system assumes that the distribution quotas of plants without generic quotas are 0.
4. If no distribution quotas are found at all—neither material-specific nor generic ones—, the system splits the data equally among all the plants in the material master record.

See also:

Plant Distribution Quotas [Page 239]

Features

Independent requirements are created in Demand Management for all materials whose data has been transferred. These independent requirements are created in the base unit of measure of the material. The base unit of measure of the material is not necessarily the same as the base unit of measure of the information structure or the unit in which you planned the material. See also Switching Units in the Planning Table [Page 110].

You can transfer SOP data to Demand Management in the following ways:

- Using mass processing
  See How to Transfer Data to Demand Management with Mass Processing [Page 215].
Transfer to Demand Management

- Online, synchronously and automatically
  See below.
- Online, asynchronously and manually
  See below.

Transferring Online, Synchronously and Automatically

You set the following information structure parameters in Customizing for Sales & Operations Planning (in *Set parameters of info structures and key figures*).

- Field name of the key figure whose values are to be transferred
- Planning version from which the data is to be transferred
- Demand version to which the data is to be transferred

The system creates or overwrites independent requirements in Demand Management every time you save this planning version of the information structure in Flexible Planning.

Transferring Online, Asynchronously and Manually

1. You choose between the following options:
   - Transfer of the planning data of all members of a single-level product group [Page 46] from standard SOP (a single-level product group is a product group whose members are materials)
   - Transfer of the planning data created for one material from standard SOP
   - Transfer of key figure values from an information structure

2. You make the following general settings:
   - The material or product group whose data you want to be transferred
   - The plant of this material or product group
   - The planning version of the information structure in which the data is stored
   - The dates for which you want the data to be transferred
   - Whether you want to check what the data looks like as independent requirements before you transfer it
   - The requirements type
     If you do not make an entry, the system sets the requirements type via the MRP group which is maintained in the material master record.
   - The version of the demand program to which you want the data to be transferred
   - Whether this version of the demand program is active and therefore relevant to MRP

3. Depending on the option you chose in step 1, you set one of the following strategies.
   **Transferring Planning Data from a Single-Level Product Group**
   - You transfer the sales plans of the materials direct.
   - You transfer the sales plans of the materials as proportions of their owner product group (using the proportional factors defined in the product group master record).
– You transfer the production plans of the materials direct.
– You transfer the production plans of the materials as proportions of their owner product group (using the proportional factors defined in the product group master record).

**Transferring Planning Data of One Material from Standard SOP**
– You transfer the sales plan of the material direct
– You transfer the sales plan of the material as a proportion of the product group of which it is a member (using the proportional factor defined in the product group master record)
– You transfer the production plan of the material direct
– You transfer the production plan of the material as a proportion of the product group of which it is a member (using the proportional factor defined in the product group master record)

**Transferring Key Figure Data of One Material from Flexible Planning**
– The information structure from which you want the key figure data to be transferred
– The key figure whose values you want to be transferred
  This key figure must be a **quantity** key figure.

**See also:**
[Transferring SOP Data to Demand Management Asynchronously, Online][238]
Transferring SOP Data to Demand Management Asynchronously, Online

1. Do one of the following:
   - From the standard SOP menu, choose Disaggregation \(\rightarrow\) Transfer product group to Demand Management or Transfer material to Demand Management.
   - From the flexible planning menu, choose Environment \(\rightarrow\) Transfer material to Demand Management.
   - From the planning table, choose Edit \(\rightarrow\) Transfer to Demand Management.
   The Transfer Planning Data screen appears.

2. Make your settings (see Transfer to Demand Management [Page 235]).
   If you want to check the planning data as independent requirements before it is transferred, do not select the field Invisible transfer.

3. Choose Edit \(\rightarrow\) Transfer now.
   A warning message appears if the version to be transferred is not the active version.

4. Either confirm this message by choosing ENTER or enter a different planning version.
   The Planned Independent Requirements screen appears.

5. To confirm the data transfer, choose ENTER.
   The planned quantities of each material appear.

6. To view the schedule lines of a material, check the box next to it and choose Goto \(\rightarrow\) Schedule lines.

7. Review and, if necessary, change the individual quantities.
   Note that planned independent requirements are created in the base unit of measure of the material. This may be different than the base unit of measure of the information structure.

8. Choose Goto \(\rightarrow\) Back.
   If you have changed any of the individual quantities, a message appears asking if you wish to accept the total values.

9. Confirm or not, as desired, the changes you have made.

10. To carry out the data transfer, choose Independent requirements \(\rightarrow\) Save.

To transfer the data of multiple materials to Demand Management, use mass processing (see How to Transfer Data to Demand Management with Mass Processing [Page 215]).
Plant Distribution Quotas

Use

You use plant distribution quotas in two situations:

- When copying key figure values from one information structure to another
  See below.
- When transferring data to Demand Management
  See the prerequisites of Transfer to Demand Management [Page 235].

Features

When you copy a key figure from one information structure to another, it may be that the source information structure does not contain the characteristic “plant”, but that the target information structure does contain it. In such situations, you can define how the key figure values of materials are distributed proportionally across their different plants.

If you do not enter any proportions, the system will distribute the data evenly across all plants in which the material is managed.

You want to create sales plans in standard SOP by transferring the sales quantities already planned in the Sales Information System (SIS). However, the sales quantities in SIS are not planned with reference to plants, while product groups and materials in SOP are defined in terms of their plant.

Product group PGTB contains two members: the material MTB “touring bike” in plant 1 and plant 2. The system treats them as the same planning object in the Sales Information System and as separate planning objects in standard SOP. For standard SOP, you define the proportion of this material’s sales in plant 1 as 0.7 and the proportion of sales in plant 2 as 0.3.

Activities

To define the proportional distribution of material data across plants:

1. From the flexible planning or standard SOP menu, choose Settings → Plant distribution.
2. Enter your plants.
3. Specify the proportions of these plants, for example, 0.75 and 0.25.
4. Enter materials to which these proportions do not apply, including materials which are managed in only one plant.
   You enter a material as many times as it has plants.
5. For each material, enter the plants in which it is managed.
6. Specify the proportions of your materials in each plant.
   If a material is managed in only one plant, the proportion for this plant will be 1.
Plant Distribution Quotas

You do not have to enter proportions for each material separately, but only for materials to which the usual distribution does not apply. To specify the usual distribution, you enter the proportions of your plants leaving the material column blank.
Transferring SOP Data to Profitability Analysis (CO-PA)

Use
You can transfer data both to and from Profitability Analysis (CO-PA). For example, you might use the sales and profitability plans you receive from Sales & Profit Planning (CO-PA-SPP) as the basis for creating sales and production plans in Flexible Planning. Having finalized these plans, you might pass the results back to CO-PA-SPP, which works out the cost of producing the planned number of units.

You trigger the transfer of data from Flexible Planning to CO-PA in Flexible Planning. This is done with mass processing. You trigger the transfer of data from CO-PA to Flexible Planning in CO-PA. This is done either online or in the background.

This function is also supported for standard SOP.

Actual data that you transfer from an information structure to CO-PA is integrated into the actual data of CO-PA.

Features
This function is supported for the consistent and level-by-level planning methods.

The system converts automatically between units; that is, currency units, units of measure, and period units.

Activities
The following steps describe how, starting from Flexible Planning, you transfer flexible planning data to CO-PA.

1. Create a key figures assignment profile in Customizing view V_LISCOPAK.
   This profile specifies which key figure and information structure in Flexible Planning corresponds to which key figure and operating concern in CO-PA. This profile is used by both Flexible Planning and CO-PA. It can be used to copy data in both directions. However, we are here describing the transfer of data from Flexible Planning to CO-PA. Therefore, the key figure in Flexible Planning is the source key figure and the key figure in CO-PA is the target key figure.

   The system converts automatically between currencies or units of measure. However, the units of the key figures must be of the same type; that is, you can transfer from one currency unit to another, or from one unit of measure to another, but not from a currency unit to a unit of measure or from a unit of measure to a currency unit.

   Note that this key figures assignment profile is different than the one you use to copy key figure values from one information structure to another.

2. Create a characteristics assignment profile in Customizing view V_LISCOPAM.
   This profile specifies which information structure and characteristic in Flexible Planning correspond to which operating concern and characteristic in CO-PA. This profile is used by both Flexible Planning and CO-PA. It can be used to copy data in both directions. However, we are here describing the transfer of data from Flexible Planning to CO-PA. Therefore, the characteristic in Flexible Planning is the source characteristic and the characteristic in CO-PA is the target characteristic.
Transferring SOP Data to Profitability Analysis (CO-PA)

If you transfer to an information structure for which level-by-level planning is defined, make sure you define the level to which the transfer should be made precisely; that is, enter the characteristic of that level as well as all the characteristics on all higher levels, without leaving any gaps.

<table>
<thead>
<tr>
<th>Counter</th>
<th>CO-PA Characteristic</th>
<th>LIS Characteristic</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>VKORG</td>
<td>VKORG</td>
</tr>
<tr>
<td>2</td>
<td>ARTNR</td>
<td>MATNR</td>
</tr>
<tr>
<td>3</td>
<td>KUNDE</td>
<td>KUNNR</td>
</tr>
</tbody>
</table>

In this example, data is transferred to the customer level of the information structure.

If you transfer to an information structure for which consistent planning is defined, the data will automatically be aggregated and/or disaggregated from the level to which you transfer it.

3. Create a CO-PA profile in Customizing view V_LISCOPAZ.
   This profile brings together the profiles you created in steps 1 and 2. It also specifies which flexible planning version corresponds to which CO-PA version. This profile is used by both Flexible Planning and CO-PA. It can be used to copy data in both directions. However, we are here describing the transfer of data from Flexible Planning to CO-PA. Therefore, the flexible planning version is the source version and the CO-PA version is the target version.

4. Create a mass processing activity. Enter COPA as the action and the name of the profile you created in step 3 as the CO-PA profile. The future periods of the planning type you enter here define the planning horizon for which the data will be transferred.

5. Create a mass processing job with a variant. The activity is the one you created in step 4.

6. Schedule this mass processing job.

See also:
Mass Processing in SOP [Page 200]
Creating a Planning Activity [Page 218]
Creating a Mass Processing Job [Page 219]
Scheduling a Mass Processing Job [Page 220]
Sales Plans in Standard SOP: Copying Data from CO-PA [Page 140]
CO Profitability Analysis
Use of SOP Data in Cost Center Accounting

If you have planned product group and/or material quantities in standard SOP, you can pass on your production planning data to Cost Center Accounting (CO-OM-CCA) where the cost of producing the planned volumes is determined. Cost Center Accounting is part of Overhead Cost Controlling (CO-OM).

Thus, your company has access to accurate, up-to-date estimates of the costs that will be charged by a particular cost center for different types of production activity. In addition, the availability of activity requirements data from SOP can benefit your actual cost accounting procedures; for example, where activity prices are fed from Cost Center Accounting to Product Costing and used to work out the cost of sales. The results of these calculations can even be passed on to Profitability Analysis (CO-PA) where the overall profitability of a venture can be determined.

See also:

CO Overhead Cost Controlling

What You Need to Know Before Transferring SOP Data to Cost Center Accounting [Page 244]
Transferring SOP Data to Cost Center Accounting [Page 245]
Displaying a Report of Planned Costs at a Cost Center [Page 246]
What You Need to Know Before Transferring SOP Data to Cost Center Accounting

The units (measured as quantities or time) of each activity type to be provided for a cost center are defined in the work center master record by means of formulas. The system transfers the results of these formulas from SOP to Cost Center Accounting as activity requirements.

For more information on work center data, see PP Work Centers.

To transfer SOP data to Cost Center Accounting, you need to specify:

- the plant whose data you wish to be transferred
  Every plant is assigned to a controlling area, so the plant determines the controlling area.
- the CO version to which you want the data to be transferred
  This is a version which has already been set in Customizing.
- the posting periods for which you want the data to be transferred
- the fiscal year for which you want the data to be transferred
  This is a fiscal year which has been set for this version in Customizing.
- whether you want the data to be transferred in the background
- whether you want a detailed log of the transfer procedure to be issued

Before data can be transferred, a number of Customizing settings need to have been made. These relate to the level at which the data is transferred and ensure, for example, that material data is not transferred more than once. Particularly important are the:

- planning version
  This is the SOP version of the product groups or materials whose capacity requirement data you want to transfer; for example, active version A00. Each product group or material may have any number of planning versions, but you transfer only one of them to CO-OM-CCA.
- PRGRP usage
  Capacity leveling in SOP can be performed both at material and at product group level. This indicator specifies whether the capacity requirements of materials will be transferred direct or as a proportion of the product groups of which they are members.
- scheduling type
  This indicator determines the scheduling level (detailed planning, rate-based planning, or rough-cut planning) for which data is transferred. Rough-cut planning is normally set for data transfer from SOP.

For more information on this configuration, see the Implementation Guide for Cost Center Accounting.
Transferring SOP Data to Cost Center Accounting

To transfer SOP data to Cost Center Accounting:

1. From the standard SOP menu, choose Environment → CO activity requirements → Transfer to cost center.

   The screen for transferral of planned activity requirements appears.

2. To check and, if necessary, change the Customizing settings for this transaction, choose Environment → Transfer control.

3. Enter the plant whose data you want to be transferred.

   The controlling area is set automatically on the basis of this plant. You can display the controlling area with Extras -> Set controlling area.

4. Enter the version to which you want the data to be transferred.

   This is a plan version used by CO-OM-CCA, not an SOP planning version.

5. Enter the posting periods and the fiscal year for which you want to transfer the data.

   The fiscal year must be the fiscal year defined in Customizing for Cost Center Accounting for this version.

6. If required, set the Background processing and Detail list indicators.

   Background processing is recommended for this procedure because of the large volume of data being transferred.
Displaying a Report of Planned Costs at a Cost Center

You can display a report of the planned costs incurred by a particular cost center. To call up this report:

1. From the standard SOP menu, choose Environment → CO activity requirements → Cost center planning report.
   A dialog box appears.
2. Enter a controlling area.
   A controlling area identifies an area within an organization that uses the same cost accounting configuration. If you are not sure what to enter here, talk to your cost accounting department.
3. Specify the report parameters.
4. Choose Planning report → Execute or, if you want the report to run in the background, Planning report → Run in background.

The report lists by cost element the costs incurred as well as the activity types to which they relate.
Transferring Standard SOP Data to Activity-Based Costing

Use
If you have planned product group and/or material quantities in standard SOP, you can pass on your production planning data to Activity-Based Costing (CO-OM-ABC). Choose Environment → CO activity reqmts → Transfer to Activity-Based Costing.

Prerequisites
You have planned product group and/or material quantities in standard SOP.

Features
You transfer the quantities you plan to produce in a particular plant at either product group or finished product level. If you transfer at product group level, the quantities are automatically disaggregated to finished product level by means of the materials' proportional factors. The planning version from which the quantities are transferred is a version of the standard information structure S076.
Application Link Enabling (ALE)

Application Link Enabling (ALE) is the R/3 technology that enables you to construct and operate distributed applications, sometimes in different countries. It involves the controlled exchange of business information between SAP applications with consistent data management. Application integration is achieved not through a central database but via synchronous and asynchronous communications.

ALE consists of three layers:
- Application services
- Distribution services
- Communications services

For transmitting data, ALE provides you with standard technical bases such as:
- X.400 as the e-mail standard
- X.435 as the application to application extension of X.400
- General messaging infrastructure with proximity to mail systems
- Messaging support using software such as Microsoft Exchange and Novell applications.

ALE must both satisfy customers' needs today and remain open for future developments. It has therefore been designed to meet the following key requirements:
- Communication between different update versions is made possible
- Data exchange continues to run without maintenance after a release upgrade
- The technical format of a message is independent of the content
- Enhancements can be carried out simply, by the customer if necessary
- The application is detached from communication
- Non-SAP applications can be attached via communication interfaces
- R/2-R/3 and R/3-R/3 scenarios are taken into account

For full information on ALE, see:

ALE Consultant’s Guide
Implementation Guide for Application Link Enabling
Example of ALE Implementation

Below is an example of how a company might implement the ALE concept.

This compound scenario consists of three ALE-communicating application systems as follows:

- In the company head office, a reference system is implemented for master data and control data. The applications Accounting, Human Resources, Central Purchasing and Sales Planning are run here. At the same time, it is used as an intercompany information system for Logistics.

- In the production plants, R/3 is used as a local sales and operations planning system (SOP) and as a production planning and control system (PPC). Local purchasing and inventory management are also carried out using R/3.

- In the sales agencies, R/3 handles the sale, dispatch, inventory management, and purchasing of trading goods.
Using ALE with SOP

Communication between applications in ALE is carried out via the medium of the IDOC (intermediate document). In SOP, the configuration of all information structures for use in ALE is based on one central reference IDOC. This has ten segments for key figures, one segment for characteristic values, and one segment for the planning version.

You maintain a distribution model for the IDOC of each information structure, in which you define the reference as the sender and the client as the receiver. You can then set up this distribution model such that organizational units (characteristic values) receive only data (key figures) which is relevant to them. For example, you specify that sales organization Florida is to be sent its own target sales quantities but not the target sales quantities of sales organization Texas, and not the total target sales quantities for all sales organizations. You configure distribution models in Customizing for Application Link Enabling.

In order to be able to send the data of a particular information structure, you must have the system generate a message type for it. You do this in Customizing for Sales & Operations Planning (in “Application Link Enabling” under “Functions”). This ensures that an IDOC containing planning data is transmitted to the receiver whenever the data of this information structure is saved. This may be a sales plan, a production plan, or any planning data saved in an information structure. Previous planning data at the receiver location is overwritten in this process. Thus, if the user wishes to resend data for any reason, he or she must call up the planning data and save it. All message types generated for Sales & Operations Planning have the format “LIPxxx” (xxx stands for the three figures after the leading “S” in the name of the information structure).

At the receiving end, the Workflow Management module records the arrival of an IDOC, checks its date, and ensures that the most recent data is saved. If subsequently it is decided that the older data is needed after all, it has to be sent again.

💡

The information structure must be present both centrally and locally so that characteristic values can be recognized on both sides.

It is possible to define a line in the planning table such that it is not ready for input, for example, such that planning figures set centrally cannot be changed decentrally.

For full information on ALE, see:

**ALE Consultant’s Guide**

**Implementation Guide for Application Link Enabling**
SOP Distribution Scenario I

A typical ALE distribution scenario for SOP is outlined below:

1. A central planning system exists in conjunction with local systems that can also plan. If sales and operations planning is conducted in all systems, it is carried out in the form of competitive planning.

2. Central targets for key figures are transferred to the local systems where planning is carried out based on the central targets.

3. After the key figures have been passed back to the central system and aggregated, the results of local planning and central planning are compared.
SOP Distribution Scenario II

1. Sales plans are created decentrally by the company's sales organizations and passed to head office.

2. Head office creates an overall production plan based on the cumulated sales plans, perhaps adjusting the targets set by the individual sales organizations, and then distributes production quotas to each of the company’s plants.

3. These, in turn, report their ability to meet these targets back to head office, which adjusts the production quotas as necessary. Reasons why production plants might not be able to meet the central targets include machine failure or a staff shortage.

The planning table contains a line showing the difference between the quotas set by head office and those set decentrally.

Because the criteria which determine a sales plan are very different from the criteria which determine a production plan, there is no need for the sales planner and the production planner to communicate directly with each other. Sales and production are planned in separate information structures, with head office using SOP’s key figure copy function to create the overall production plan in step 2.
**Reporting**

This section explains the SOP reporting functions. Four reports are offered in standard SOP:

- **Product Group Breakdown [Page 254]**
- **Product Group Usage [Page 255]**
- **Material Usage [Page 256]**
- **Planning Situation [Page 257]**

One report is available in flexible planning:

- **Standard Analysis for Information Structure [Page 258]**

You access all reports via the *Environment* menu.
Product Group Breakdown

The *Product group breakdown* function shows you a lot of information on a product group hierarchy. It has two possible display formats:

1. You see the entire product group hierarchy.
2. You see just the direct members of the product group hierarchy.

In the report, you click on the pushbuttons **More** and **Less** to vary the level of detail. Up to three levels of detail can be displayed. An extended report shows:

- The hierarchical level of each product group member in ascending order down the hierarchy
- The plant, number, and description of each hierarchy node
- Any planning versions that exist for that node
- The proportional, aggregation, and conversion factors of that node in relation to the directly superior product group
- The proportional, aggregation, and conversion factors at each hierarchical level in relation to the specified product group

Use the pushbutton **Details** (or double-click) to obtain detailed data on a particular node. From the Detailed Data window, you can branch to a list of the planning versions that exist for that node.
Product Group Usage

The Product group usage function shows you a lot of information on a product group’s membership of other product groups. It has two possible display formats:

1. You see all the product groups of which the specified product group is a member.
2. You see only those product groups of which the specified product group is a direct member.

In the report, you click on the pushbuttons More and Less to vary the level of detail. Up to three levels of detail can be displayed. An extended report shows:

- The hierarchical level of each product group in ascending order up the hierarchy
- The plant, number, and description of the product group
- Any planning versions that exist for that product group
- The proportional, aggregation, and conversion factors of each product group in relation to the directly superior product group
- The proportional, aggregation, and conversion factors of the specified product group in relation to each hierarchical level

Use the pushbutton Details (or double-click) to obtain detailed data on a particular product group node. From the Detailed Data window, you can branch to a list of the planning versions that exist for that node.
Material Usage

The Material usage function shows you a lot of information on a material’s membership of product groups. It has two possible display formats:

1. You see all the product groups of which the specified material is a member.
2. You see only those product groups of which the specified material is a direct member.

In the report, you click on the pushbuttons More and Less to vary the level of detail. Up to three levels of detail can be displayed. An extended report shows:

- The hierarchical level of each node in ascending order up the hierarchy
- The plant, number, and description of the hierarchy node
- Any planning versions that exist for that node
- The proportional, aggregation, and conversion factors of each node in relation to the directly superior product group
- The proportional, aggregation, and conversion factors of the specified material in relation to each hierarchical level

Use the pushbutton Details (or double-click) to obtain detailed data on a particular node. From the Detailed Data window, you can branch to a list of the planning versions that exist for that node.
Planning Situation

The Planning situation function allows you to compare the results of standard SOP with the quantities planned in MRP. The sales and operations planner can thus check the extent to which the MRP controller has adopted the SOP data at different points on the planning horizon.

The SAPSOP layout of this report shows you the SOP information—sales, production, and warehouse stock—in the upper half of the screen, and the MRP information—goods issues, goods receipts, and available quantities—in the lower half of the screen.

For a detailed description of this function, see PP Material Requirements Planning under “Evaluating the Planning Result”.
Standard Analysis for Information Structure

You can run a standard analysis for any planning version [Ext.] of any information structure [Ext.] for which consistent planning [Page 17] is used. This allows you to drill down and roll up between many different levels and rapidly identify potential successes and problems.

You can call this analysis both from the Environment menu and in the planning table with Goto → Reporting.

This function is not offered with level-by-level planning or delta planning because planning levels are independent of each other. There would therefore be no point in comparing them.

For more information on standard analyses and drilling down, see LO Logistics Information System.