Costs

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Caution Icon]</td>
<td>Caution</td>
</tr>
<tr>
<td>![Example Icon]</td>
<td>Example</td>
</tr>
<tr>
<td>![Note Icon]</td>
<td>Note</td>
</tr>
<tr>
<td>![Recommendation Icon]</td>
<td>Recommendation</td>
</tr>
<tr>
<td>![Syntax Icon]</td>
<td>Syntax</td>
</tr>
</tbody>
</table>
Contents

Costs ................................................................................................................................. 8
Cost Planning ...................................................................................................................... 9
Currencies in Planning ..................................................................................................... 10
Easy Cost Planning and Execution Services ................................................................. 13
    Editing Costing Models and Assigning Attributes ...................................................... 17
    Creating and Assigning Characteristics .................................................................... 22
    Structuring the Entry Screen ..................................................................................... 24
    Defining Derivation Rules ......................................................................................... 26
    Template for Easy Cost Planning ............................................................................. 27
Easy Cost Planning in the Project System ....................................................................... 29
    Executing Easy Cost Planning .................................................................................. 31
    Triggering the Execution Services ............................................................................ 33
    Example of the Easy Cost Planning of a Project ...................................................... 36
Manual Cost Planning in the Work Breakdown Structure ........................................... 40
    Plan Line Items .......................................................................................................... 43
    Totaling Up Plan Values ............................................................................................. 45
    Adjusting Plan Values ................................................................................................. 47
    Presenting Planning Values ....................................................................................... 48
    Planning Costs ............................................................................................................ 50
    Checking Cost Planning ............................................................................................. 51
    Planning Annual Values ............................................................................................. 52
Cost Planning in Networks .............................................................................................. 53
    Network Planned Costs ............................................................................................... 54
    Calculating Planned Costs .......................................................................................... 57
    Basis Values for Network Costings ............................................................................ 59
    Costing by Period ......................................................................................................... 62
    Determining Planned Costs in Networks ................................................................ 63
    Displaying Planned Costs ........................................................................................... 64
    Calling Up the Cost Determination Error Log ......................................................... 65
Invoicing Plans in Networks ........................................................................................... 66
    Creating Invoicing Plans ............................................................................................ 68
    Generating Dates from Milestones ............................................................................ 70
Unit Costing in Networks ............................................................................................... 72
    Unit Costings in General Costs Activities ................................................................. 74
    Unit Costings in Material Components ..................................................................... 76
    Creating Unit Costings in Networks ......................................................................... 78
    Asynchronous Network Costing ................................................................................ 79
    Executing the Asynchronous Network Costing ....................................................... 80
Copying Planning ........................................................................................................... 82
    Copying Plan and Actual Data in the WBS ................................................................. 84
    Copying Project Costing ............................................................................................. 86
Orders for Projects .......................................................................................................... 87
    Plan Costs from Orders for Projects ......................................................................... 88
    Displaying Plan Costs for Orders for Projects in the Cost Information System ........ 90
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assigned Value In Internal Orders</td>
<td>170</td>
</tr>
<tr>
<td>Assigned Value In Projects</td>
<td>171</td>
</tr>
<tr>
<td>Entering Settings For Availability Control</td>
<td>172</td>
</tr>
<tr>
<td>Basic Settings for Availability Control in Budget Profile</td>
<td>173</td>
</tr>
<tr>
<td>Specifying Tolerance Limits</td>
<td>174</td>
</tr>
<tr>
<td>Availability Control Actions</td>
<td>176</td>
</tr>
<tr>
<td>Transaction Group</td>
<td>177</td>
</tr>
<tr>
<td>Activating Availability Control</td>
<td>179</td>
</tr>
<tr>
<td>Activating Availability Control with Budget Allocation</td>
<td>180</td>
</tr>
<tr>
<td>Activating Availability Control In The Background</td>
<td>181</td>
</tr>
<tr>
<td>Activating Availability Control Online</td>
<td>182</td>
</tr>
<tr>
<td>Checking Whether Availability Control is Active</td>
<td>183</td>
</tr>
<tr>
<td>Deactivating Availability Control</td>
<td>185</td>
</tr>
<tr>
<td>Excluding WBS Elements From Availability Control</td>
<td>186</td>
</tr>
<tr>
<td>Referencing Availability Control In Projects</td>
<td>187</td>
</tr>
<tr>
<td>Reconstructing Availability Control</td>
<td>188</td>
</tr>
<tr>
<td>Notes for Problems with Availability Control</td>
<td>189</td>
</tr>
<tr>
<td>Commitments Management (CO)</td>
<td>191</td>
</tr>
<tr>
<td>Commitment</td>
<td>193</td>
</tr>
<tr>
<td>Activate Commitments Management</td>
<td>195</td>
</tr>
<tr>
<td>Commitments Management Flow</td>
<td>197</td>
</tr>
<tr>
<td>How Purchase Order Commitments are Created</td>
<td>199</td>
</tr>
<tr>
<td>Creating Purchase Order Commitments</td>
<td>201</td>
</tr>
<tr>
<td>Reducing Purchase Order Commitments to Zero</td>
<td>203</td>
</tr>
<tr>
<td>Example: Individual Purchase Order on an Internal Order</td>
<td>205</td>
</tr>
<tr>
<td>Example: Creating Purchase Order Commitments</td>
<td>207</td>
</tr>
<tr>
<td>Example: Partial Reduction of Purchase Order Commitments</td>
<td>208</td>
</tr>
<tr>
<td>Example: Updating Purchase Order Commitments</td>
<td>209</td>
</tr>
<tr>
<td>Example: Reducing Purchase Order Commitments to Zero</td>
<td>210</td>
</tr>
<tr>
<td>Example: Increasing the Actual Costs</td>
<td>211</td>
</tr>
<tr>
<td>Commitments Information System</td>
<td>212</td>
</tr>
<tr>
<td>Calling Up Total Cost Reports</td>
<td>213</td>
</tr>
<tr>
<td>Calling Up Cost Element Reports</td>
<td>215</td>
</tr>
<tr>
<td>Calling Up Line Item Reports</td>
<td>216</td>
</tr>
<tr>
<td>Funds Commitment (Cost Centers, Internal Orders, Projects)</td>
<td>217</td>
</tr>
<tr>
<td>Creating Funds Commitments</td>
<td>219</td>
</tr>
<tr>
<td>Changing Funds Commitments</td>
<td>221</td>
</tr>
<tr>
<td>Reducing Funds Commitments</td>
<td>222</td>
</tr>
<tr>
<td>Evaluating Funds Commitment Documents in The Information System</td>
<td>224</td>
</tr>
<tr>
<td>Requesting an Adjustment Posting from the Intranet (AC)</td>
<td>226</td>
</tr>
<tr>
<td>Processing Request Forms</td>
<td>231</td>
</tr>
<tr>
<td>Processing a Request in the SAP System</td>
<td>233</td>
</tr>
<tr>
<td>Processing Notifications</td>
<td>234</td>
</tr>
<tr>
<td>Process Notification</td>
<td>235</td>
</tr>
<tr>
<td>Processing Notifications Using Worklist</td>
<td>237</td>
</tr>
<tr>
<td>Task Processing</td>
<td>238</td>
</tr>
<tr>
<td>Processing Tasks Using Worklist</td>
<td>239</td>
</tr>
</tbody>
</table>
Costs

Purpose
You use this component to plan, monitor, and control project costs, thereby achieving comprehensive cost accounting.

Integration
The component is thoroughly integrated with other components, such as:

- CO - Controlling
- FI - Financial Accounting
- PP - Production Planning and Control
- MM - Materials Management

Features
The component contains the following functions:

- Cost planning in various degrees of detail
- Automatic cost calculation wherever there are price and quantity structures
- Funds management, effected by means of budget allocation
- Integration of project costs with Enterprise Controlling, such as reconciliation with cost center accounting
Cost Planning

Purpose
Cost planning deals with the costs you expect to incur in connection with your project as it is executed.

Cost planning has different aims at different stages of the project:

- At the concept and rough planning stage, cost planning acts as the base for an initial cost estimate.
- At the approval stage, it forms the basis for the budget allocation.
- During project execution, you use cost planning to monitor and control cost variances.

Cost planning in the Project System is effected by means of the WBS and networks.

In the network, the emphasis is on planning not costs, but dates, human resources, and operating resources. The costs are calculated automatically on the basis of an existing price/quantity structure. You always use cost planning by means of networks if you are using complex project processing - that is, if dates and resources, as well as costs, are relevant to you.

If planning and monitoring of costs is most important, as in, say, capital investment projects or overhead cost projects, you should plan your costs using manual cost planning in the WBS. Integration with Controlling and Financial Accounting is effected by means of the WBS.

Features

- Planning Costs in Networks [Page 52], based on price and quantity structures
- Planned costs from assigned orders recorded in the project.
- Cost forecast for calculated plan costs, based on variances during project execution.
Currencies in Planning

Use

Currencies can be updated for both plan and actual values. The use of more than one currency must be allowed in the controlling area.

You can plan in the following currencies:

- Controlling area currency [Ext.]
- Object currency [Ext.]
- Transaction currency [Ext.]
- Currency of the user’s choice

The controlling area is always used, regardless of whether you have selected All currencies in the control indicators for your controlling area.

You specify the object currency in the master data of the given planning object, for example, a cost center. The object and transaction currencies are only active if you have selected All currencies in the controlling area for the relevant fiscal year.

You can select any permitted currency as the transaction currency. The system always derives the value date and the exchange rate type from the fiscal-year dependent data of the version.

User-Definable Currency

In addition to planning in controlling area, object or transaction currencies, you can also plan in a currency of your choice. You can also translate your plan values, for example, into euro. You can include the user-definable currency in additional columns or rows of the planning layout for cost element planning. You can then display or maintain this currency.

💡 If you have made a change to the exchange rates between two planning meetings for activity input (for example, due to the EURO changeover), this may cause large differences between the values in the object currency for the receiver, and for the sender, even though both have the same currency.

This is due to the fact that the system does not revaluate when the exchange rates change.

To avoid data inconsistencies, you can create a new version as a buffer, and copy your prices into it.

Then copy the prices back to your original version.

You need to copy the objects as well as the prices for orders and projects that are not plan integrated.

The following key figures are available for plan values in user-definable currency:

- Planned fixed costs
- Planned variable costs
- Planned total costs
- Actual total costs

If the appropriate rows or columns exist in the planning layout, you can set your user-definable currency in the initial screen for manual planning. Choose Settings → User-definable currency.

If you use the user-definable currency, you can enter the following attributes:

- Currency
- Exchange rate type
- Value date for the translation

If you do not specify a currency, the system uses the controlling area currency. If you do not enter an exchange rate type, the SAP R/3 System derives the exchange rate type and the value date from the fiscal-year dependent version parameters.

You can make default settings for your user-definable currency in Customizing for Cost Center Accounting or Activity-Based Costing. Choose Planning → Manual Planning → Create User-Defined Planner Profiles.

You can also define the relevant Set/Get parameters as user parameters in your user master data.

The SAP R/3 System translates into the user-definable currency, or from the user-definable currency into controlling area currency, regardless of whether you have selected All currencies in the control indicators for the controlling area.

The SAP R/3 System does not write the user-definable currency to the database when postings occur.

**Currencies in Planning Layouts**

If you do not use the transaction currency as a characteristic in your planning layout:

- The SAP R/3 System automatically uses the object currency for newly created planning records
- As of Release 4.0, the system updates the accumulated plan and actual costs in controlling area and object currencies across all data records, even if the costs were updated under different transaction currencies.

If you change these accumulated costs, the system updates under the transaction currency corresponding to the object currency, if such a record already existed. Otherwise, the update is executed using the first transaction currency that the system finds in the database.

You can only include the key figure “Actual costs in transaction currency” in those planning layouts that use the characteristic “Transaction currency”.

If you plan in the transaction currency, the system automatically translates the plan data to cost center and controlling area currency during the planning process.

When planning in different currencies, the planning results are always stored in transaction currency, object currency, and controlling area currency.
You plan raw materials on cost center 4210 in Japanese Yen JPY (the raw materials come from Japan, and are invoiced in Yen). However, you plan personnel costs in US dollars USD.

The following situations might exist:

1. You want to plan in USD only
   Enter USD as the transaction currency.

2. You want to plan in JPY only.
   Enter JPY as transaction currency.

3. You want to plan in both currencies.
   Enter an asterisk (*).
Easy Cost Planning and Execution Services

Purpose

Easy Cost Planning and Execution Services is a simplified form of cost planning that is integrated into the SAP System. It is of particular use when several planners are involved or when your planning is carried out using similar methods.

Example of the Easy Cost Planning of a Project [Page 35]

You can use this method for the following:

- Internal orders [Ext.]
- WBS elements [Ext.]
- Internal Service Requests [Ext.]
- Appropriation requests [Ext.]
- Ad hoc cost estimates [Ext.]

The Execution Services enable you to trigger the following processes based on the costing results:

- Purchase requisitions [Ext.]
- Purchase orders [Ext.]
- Reservation [Ext.]
- Goods issue [Ext.]
- Internal activity allocation [Ext.] either with or without Workflow [Ext.]

For more information about how Easy Cost Planning can be used, see the following:

- Easy Cost Planning for Internal Orders [Ext.]
- Easy Cost Planning in the Project System [Page 28]
- Cost-Incurring Scenarios [Ext.]
- Easy Cost Planning for Appropriation Requests [Ext.]

Integration

Cost planning for the object concerned is carried out in the corresponding application component, namely Internal Orders (CO-OM-OPA) [Ext.], Project System (PS) [Ext.], Investment Management (IM) [Ext.], Product Cost Planning (CO-PC-PCP) or using the mySAP Workplace.

The following components are used (called up) in the background. User knowledge in these areas is not required.

In order to complete the respective Execution Service, the application components Purchasing (MM-PUR), Inventory Management (MM-IM), Cost Center Accounting (CO-OM-CCA), and/or Activity-Based Costing (CO-OM-ABC) are used, either with or without the SAP Business Workflow.
Easy Cost Planning and Execution Services

Easy Cost Planning uses unit costing from Product Cost Planning (CO-PC-PCP), the characteristics function of the Classification system (CA-CL) and the template [Ext.] function from Activity-Based Costing (CO-OM-ABC) to calculate the costs.

Features

Easy Cost Planning enables you to represent the structure of the planning processes in the system [Page 16]. These can then be used as planning forms by all cost planners [Ext.]. The use of this planning form ensures that all of the relevant cost incurring functions are included. This means you can avoid errors.

The intentions of the planner are translated into the terms and data of the unit costing [Page 25]. When planning, the planner enters the cost incurring functions in the form of characteristics, from which the system generates and then costs costing items for the unit costing.

The planning object can be structured whichever way the planner chooses, and the substructures that the user defines can be costed separately. Existing structures, such as those in the Project System for example, are included in the costing.

You can define the entry screen in accordance with your individual [Page 23] requirements for each planning form. It is automatically generated in HTML format and you can enhance it, for example with hyperlinks for the planner to determine additional data, and to include your company logo. You can also insert information in the form of explanatory text. A notes field has been created in the entry screen so that planners can enter notes either for themselves or other users who need to analyze the costing, which are saved together with the entries for the costing.

You can adapt the display of individual screens for individual roles [Page 16], for example to simplify the display for planners who only use this function occasionally and do not need to know about every single function.

The Execution Services function selects the costing items for the process to be triggered. You can change, delete and add the costing items selected. From this display it is possible to trigger the process for the selected items [Page 32].

It is possible for you to display existing postings, that are already in the system for the respective object, for the services selected. For example, if you want to trigger a purchase order for an internal order, you can display the existing postings for this order, in order to avoid a duplication of the purchase order.
Standardized Planning Method using Easy Cost Planning & Execution Services

Request → Model Construction → Planning using Execution Services

Idea of planning procedures to be completed that are always similar

Entry screen

Charact. 1
Charact. 2
Charact. 3

Quest. 1
Quest. 2
Quest. 3

Yes
No

100
50

50
100

Large
Small

Small
Large

Entry screen

Template

Cost Estimate → Execution Services → Postings

Constraints

You cannot use this costing method for the following unit costing reference objects:

- Materials
Easy Cost Planning and Execution Services

- Sales documents
- CO production orders
- General cost objects
- Network activities

You cannot use the Execution Services for appropriation requests. You can only use them for ad hoc cost estimates if you have assigned an account assignment object [Ext.] to the ad hoc cost estimate.
Editing Costing Models and Assigning Attributes

Use

In Easy Cost Planning [Page 13] the planner can use the costing model that you create with this function as a planning form. This enables the costs to be calculated from the planner's point of view. You can use the costing model for all similar planning processes.

By assigning attributes to the role of the planner, you decide which screen areas are displayed for the planner in the cost estimate and also to what extent they can be changed. This assignment applies across all models and hence is only required once for each role.

Prerequisites

To be able to define costing models, experience in using the SAP System is required, particularly in the following areas:

<table>
<thead>
<tr>
<th>Application</th>
<th>Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Classification System (CA-CL)</td>
<td>Characteristics</td>
</tr>
<tr>
<td>Activity-Based Costing (CO-OM-ABC)</td>
<td>Templates</td>
</tr>
<tr>
<td>Product Cost Controlling (CO-PC)</td>
<td>Costing tools, special unit costing and costing items</td>
</tr>
<tr>
<td>Overhead Cost Controlling (CO-OM)</td>
<td>Chart of accounts, cost centers, cost elements and activity types, internal orders, overhead</td>
</tr>
<tr>
<td>Materials Management (MM)</td>
<td>Purchasing, services, material valuation, inventory management</td>
</tr>
</tbody>
</table>

In order to carry out cost planning, a costing variant must have been defined in Customizing for every object to be planned. If you want to view the costs in groups, you must have already defined cost component groups in Customizing for the application component concerned under Define Cost Component Structure.

During the implementation phase, organizational limits must have been made for the namespaces of the characteristics, to control the use of characteristics that use the Classification System (CA-CL).

For the Execution Services, you must have made the required settings in Customizing for the respective application component under Execution Services.

Features

The following graphic gives you an overview of the costing run:
You can show or hide (⋯) the screen area *Worklists* and also change the size of the screen areas.

*Worklists area*
This area contains the planning forms, characteristics and roles. These are the predefined directories. The worklists provide an overview of the data present in the system and a user-friendly view of its structure. Once you have loaded the most frequently used planning forms, characteristics and roles into the worklists, they are always available for you to use. The directories can be made available to everyone, or limited to a specific role to which you must have been assigned, or defined in such a way that they are only available for your yourself to use.

To load available data in the worklists either choose immediately next to the node, or . You can create, insert ( ), rename worklists and extend the display of worklists (from user-specific to role-specific or globally to all users), or restrict ( ) them. You can copy planning forms, characteristics or roles to other worklists of the same category per drag & drop. Make sure that you select nodes supplied with a hyperlink together with the symbol in front of them. It is not possible to copy subdirectories. Using ( ) you can call up any worklists that are in the system but have not yet been displayed. To delete worklists, choose . To remove subdirectories or loaded data from a worklist choose . To save worklists, choose in the screen area Worklists.

You can call a costing model and role directly by clicking on the relevant node in the worklist.

You can assign a characteristic directly to a model. To do so, you must have chosen the model and called up the assignment of the characteristics in the work area. You can copy the characteristic into the table in the work area using drag and drop.

**Definition area**

Here you can edit a costing model or role. If you want to switch from editing the costing model to editing the roles either choose or choose the role directly in the worklist. Choose to return to editing the costing model, or choose it directly in the worklist.

Having selected a costing model or created a new one, you can carry out all changes or definitions (by clicking on the nodes) in this area. You can create a description for the model ( ). You can then use it to document the model. When the planner wants to create a cost estimate, this description is available for finding a planning form. For information on the editor, see the PC editor [Ext.] and editing text [Ext.].

If you have selected a role, you can select here the attributes which should be assigned to the role.

If you assign the attribute Hide cost estimate item view to the single role Maintain internal orders (SAP_CO_OM_JOB_INTORDER_MAINT) then the relevant button is hidden, meaning it is no longer possible to show the item view. This applies to all planners to whom this role has been assigned. If you want to make it impossible to show the item view for a planner to whom several roles have been assigned, then you have to assign this attribute to all of this planner’s roles. The simplification of the screen achieved by this is particularly useful for occasional users, especially if they do not have extensive knowledge of Controlling in the SAP System. However, for the planner it also means that it is no longer possible to change the costing items manually.

**Work and Display area**

In this area, you can assign the characteristics. When you create new characteristics, you can define the characteristics directly from here. If the characteristics exist already, you can change them using in the Characteristics maintenance column.
Editing Costing Models and Assigning Attributes

In addition to this, you can display a preview on the entry screen by clicking on the node Structure model entry screen. You can then edit it here.

If you delete, change, edit or create new characteristics then these changes will only be displayed in the preview once you have saved the model.

Activities

- Select:
  - Choose Logistics → Project System → Basic Data → Templates → Models for Easy Cost Planning.
  - Accounting → Investment Management → Appropriation Requests → Environment → Maintain Costing Model.

- Create costing model:
  Choose create entry. Enter a name for the costing model. The name must not begin with a number or contain any blanks. If you do not enter a description, the system copies the name automatically into the Description field. You can change the description at any time by choosing edit.

  If you are copying a model (copy), enter yes to the dialog box Save template? Otherwise the template will not be copied.

- Creating and Assigning Characteristics [Page 21]
- If you want to structure the automatically-created entry screen [Page 23] to suit your requirements, select this node in the definition area.
- Defining Derivation Rules [Page 25]
- If you want to display the screen areas in the cost estimate on a role-specific basis, select a role and assign the relevant attributes to it by setting the indicator. Save your settings in the screen area Definition using (Save attribute assignment).
- Save your entries.

Multilingual capability

If the planner needs the costing model to be available in more than one language, you need to carry out the following activities, noting the special features:

Characteristics

When creating the characteristic, enter the description of the characteristic on the tab Descriptions in all the languages that you require.

If you want to set default Values, go to the Values tab, select a value and choose Enter the description in all of the languages that you require.

If you choose Extras → Change Language, you can enter the characteristic description and the descriptions for all values for the language selected.
Entry screen
Do not change the characteristic descriptions on the entry screen. Additional text (for example notes or texts for hyperlinks) and changes can only be entered in one language, and consequently are only available in that language. The Confirm button and the heading Comment are automatically displayed in the correct language.

Derivation rules
You must ensure that descriptions are available in all of the languages that you require. Make sure when you use a costing model (item category J) that this also applies for the description of the model used. Do not enter any descriptions in the item lines. The descriptions are then automatically displayed in the correct language. Exception: you can only enter the description for item categories comment line, calculation line (process and cost center/activity type), text item and variable item in one language, which in turn are only available in that particular language.

Costing Model Description
Once you have created the model, log on to the system in each language in turn which you need to be available. Call up the model for editing and choose . Enter the description for each model in the correct language and save your entries. To ensure the description of the model is available in the languages you require, enter it in each of the relevant languages.

Result
The costing model is available as a template on a permanent basis. For more information, see Using Easy Cost Planning [Ext.].

Example
Example of the Easy Cost Planning of a Project [Page 35]
Creating and Assigning Characteristics

Use
Characteristics represent the cost incurring functions of a planning process in the costing model. A characteristic can be assigned to more than one costing model.

Prerequisites
You have created a costing model.

Procedure
1. Define the characteristics by clicking on the node Assign characteristics to the model.
   The system displays a table in the work/display area.
2. Under Characteristic name, enter the name of an existing characteristic, or create a new one. Then choose Continue.
   a. If you are using an existing characteristic, the data is copied into the table.
   b. If you are not using an existing characteristic, the system asks you if you are creating a new one. Choose Yes.
      The Create Characteristic screen appears.
      Enter the required data. SAP recommends that you select a characteristic group containing characteristics that you have created specifically for costing models. You should note the following:
      i. The system cannot interpret user-defined data formats or multiple value characteristics.
      ii. If you enter values to be available in a dropdown box, you should not set the indicator Additional values. If you want to enable planners to define their own characteristics in addition to the values that you have entered, you must define a specific characteristic for this purpose. You do this when you define the derivation rules, for instance by creating a variable item.
      iii. If you want a value to appear in the entry screen as a default setting, set the indicator D for this value.
3. Save your entries.

You should note that on the Restrictions tab page, the characteristics are always assigned to class type 051 (which is not displayed in the input help). This ensures that the characteristics are only available for Easy Cost Planning. If you want to use characteristics with a different class type, you have to enter class type 051 for these in addition.

You should also bear in mind that characteristics may be used in a variety of costing models, which means that if you change a characteristic this could affect more than one costing model. If you create new characteristics, you can identify them as yours by the name that you give them. Heed any naming conventions that may apply in this
regard. Characteristics to which further class types are assigned in addition to class
type 051 may be used by other application components which similarly use the
Classification System (CA-CL).

Result
The characteristic is assigned to the costing model and can be specified in the entry screen.
Structuring the Entry Screen

Prerequisites
You have created a costing model and assigned characteristics to it.
If you do not want to make the changes directly in HTML, you must have installed an HTML editor.

Procedure
1. Call a preview of the automatically-created entry screen by clicking on the node Structure model entry screen.
2. In the work/display area, choose .
3. If you want to make the changes using your own HTML editor, you can download the HTML code as a local file to your PC by choosing . To import the changed file back, choose .
   If you want to change the HTML code directly, you should note the following points:
   You must not delete the variables for the field values, because if you do the values of the characteristics cannot be interpreted correctly. The variables are generated in the form of `<CHARACTERISTIC NAME>.value` or `<CHARACTERISTIC NAME>.name`. The system replaces the variables with the value entered. The entire expression for the variable must not exceed one line (there must not be a line break).
   If you insert a hyperlink, you should display the Internet page in a new window. To do this, you must enter the command `target="_blank"` in HTML code in the following position: `<a href="http://www. ... " target="_blank"><Text of link in entry screen></a>`. If you display the Internet page directly in the same screen area as the entry screen, the planner can only go back to the entry screen by right-clicking on the mouse. However, this would mean that the data entered before the link sequence is lost.
4. To display the changed HTML code from the editor in the preview, choose .
   You can generate the entry screen in SAP style (standard setting) or in Web style. When you save the costing model, the style generated last is saved.

Result
When the costing model is saved, the changed entry screen is stored as a file by means of the Business Document Service [Ext.]. However, this only happens if you have made changes in the automatically-generated entry screen (with or ). You can save multiple versions. The most recent version is always the active one. You can manage the files with the Business Document Navigator (): If, for example, you want to use an older version, you have to delete the newer ones.

If you subsequently change a characteristic and have altered the automatically-generated entry screen with or , you must regenerate the entry screen in order to include the changes. If you have changed the HTML code, it will be overwritten by the regeneration. To prevent this from happening with multiple changes, proceed as follows: Download the previous HTML code to your PC. Regenerate and compare.
the HTML codes. Using cut and paste, insert the position at which the change to the characteristic has affected the HTML code into the HTML code in the local file, and import this back into the SAP System. Confirm the changes with ⏪.
Defining Derivation Rules

Use

Using the derivation rules the view and thinking of the planner is transferred to the costing items of the unit costing. This is where you enter the resources needed for the planning.

If the costing model is to offer a choice between several resources of the same sort, enter all of the resources and use Activation to regulate which resource in the planning case is entered in the cost estimate. You define the activation via the prompt for a particular specification of the related characteristic, for example if characteristic LENGTH = 10, the line with resource (material) A10 is used, and if LENGTH = 20 the line with resource A20 is used.

To determine the quantity of the respective resource you use a characteristic, for example, the characteristic NUMBER OF WORKING HOURS for an internal activity item.

Prerequisites

You have created a costing model.

Procedure

You can only define the derivation rules (of the template) for the costing model when you define the model.

1. Click on the node in the definition area of the costing model.

   The screen Create template <NAME OF COSTING MODEL> appears. The template automatically receives the name of the costing model and is created in a specific environment, depending on the planning object.

2. Enter the costing items required for the planning object. For more information, see Templates for Easy Cost Planning [Page 26].

3. Go back and save the template.
Template for Easy Cost Planning

Definition

The template is a dynamic calculation tool that uses [functions] and [formulas] to calculate numerical values and determine the results of Boolean expressions (true or false). Templates for Easy Cost Planning are created in environments 200, 205-208, and 214-215. The environment is defined automatically by the system depending on the object to be planned (internal order, WBS element, and so on). With the exception of environment 214, you cannot create environments through Customizing. Instead, you can only do so by defining a costing model.

Structure

The template contains a table in which you can make the following line entries:

<table>
<thead>
<tr>
<th>Column</th>
<th>Possible Entry/Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item category in template</td>
<td>Comment line, process, calculation row (process), cost center/activity type, calculation row (cost center/activity type), costing model, external activities, subcontracting, material, service, base planning object, text item, variable item</td>
</tr>
<tr>
<td></td>
<td>For the item category calculation row, you cannot call the editor or define methods in the object column.</td>
</tr>
<tr>
<td></td>
<td>You can only select costing models that are valid either for all planning objects or for the same planning object as the costing model in which you want to insert this model as a submodel.</td>
</tr>
<tr>
<td>Description</td>
<td>The description is displayed in the cost estimate as the description for the costing items. The system determines the description for most of the item categories automatically once you have confirmed your entries. (The description is used in the case of the base planning object.) Consequently you only need to make an entry here if the description cannot be determined by the system or if you need to overwrite it.</td>
</tr>
</tbody>
</table>
### Template for Easy Cost Planning

| Object | Enter the object (such as a material), depending on the item category specified. You can either enter the object directly, or define methods [Ext.].  
For item categories of the template J to R, you can use the input help to make the required entries. Always enter a cost element if the system is unable to determine one. This applies to those item categories for which the cost element was requested in the possible entries help; with base planning objects the cost element can be determined via the master data providing you have entered one there. If the item does not have a cost element, it is not possible to assign the costs to a cost component. This means that the costs cannot be rolled up if they are incurred in a cost estimate which is part of a costing structure with superior cost estimates.  
For the categories Process and Cost center/Activity type, you can either predefine an object or determine dynamically one or more processes or cost centers/activity types. For more information, see Object Determination [Ext.]. |
| Quantity | Enter a quantity or characteristic directly. You can enter the appropriate characteristic by defining a formula [Ext.].  
For more information, see Activity Quantity Determination [Ext.]. |
| Activation | Specify the condition under which an item is active. For the activation of an item, you can predefine values as active or inactive or define a method that returns active or inactive at the point of evaluation. If you do not enter anything in the column, the item is active.  
The item (MATERIAL: Gravel; 0001 / GRAVEL01; M3; QUANTITY_ FILLER; METHOD) with method: FILLER = “Gravel” is only active if gravel was selected as the FILLER.  
For all other characteristic values, the item is not included in the costing.  
For more information, see Activation [Ext.]. |
| Price | Price for a variable item. This column is not utilized for any other item category. |

Depending on the item category in the template, there are various functions available to define methods and formulas.

For more information on the costing item categories, refer to Master Data for Unit Costing [Ext.].
Easy Cost Planning in the Project System

Use

The Easy Cost Planning tool enables you to plan costs at WBS level, based on quantities and characteristics.

You use it to create a quantity structure (possibly temporary) for the cost calculation, starting from the project structure. The system valuates your entries using the prices and rates defined in the system, then distributes the costs in line with the basic dates for the respective WBS elements.

You can make best use of this tool in the following processes:

- Project processing concentrating on cost controlling
- Preliminary costing for complex projects

Project Processing Concentrating on Cost Controlling

If you use projects as cost control tools, cost planning which is high performance, clear, and easy to use is particularly important.

Easy Cost Planning meets this requirement. It has the additional advantage that, as the project progresses, you can trigger a range of follow-up processes, called the "execution services", from the costing. The Execution Services include the purchase requisitions, purchase orders, material reservations, goods issues, and internal activity allocation. As the system carries out Execution Services with the help of the data entered for the costing, there is no need for duplicated data entry for further processing to take place. If necessary, you can overwrite the data taken over; the values are only intended as default values.

Simplified Preliminary Costing for Complex Projects

You use the Project System to process complex overhead cost projects or customer projects. In this case, you need a preliminary costing tool that is easy to use, but high performance, to serve as the basis for creating quotations.

You can use Easy Cost Planning to carry out preliminary costing, using data from a temporary WBS.

You can also use Easy Cost Planning to carry out sales pricing and, if required, create a corresponding quotation.

You create your concurrent costing after the project is approved or when the order is received, using the networks from your WBS. The preliminary costing is preserved for analysis purposes in a separate CO version.

The integration of Easy Cost Planning and sales pricing with the Project Builder means that you can control the whole business process - from creating the project to carrying out the sales pricing - using just one tool.

Prerequisites

For information on the prerequisites for using Easy Cost Planning, see Carrying Out Easy Cost Planning [Page 30].

For information on the prerequisites for using Execution Services, see Starting Execution Services [Page 32].
Easy Cost Planning in the Project System

Features

You access the function via the Project Builder.

The WBS forms the basis for the costing structure, which you use to plan and calculate costs. You can subdivide the costing structure as you want; the changes you make will not affect the WBS. This way, you retain a clear overview of your cost planning at project level.

You enter the data for the costing in the planning templates you have defined; these are the costing models [Ext.] . You use the costing models to reproduce typical business processes, whose costs always occur in the same way. You enter data typical of the business process in the model. This data is known as the "characteristics" and includes things like required quantity, number of days, and number of documents to be produced. The system uses the chosen characteristics to generate the costing items for the unit costing. If necessary, you can postprocess the unit costing.

The system distributes the planned costs along the time axis, in line with the basic dates in the WBS elements. The system adapts the cost distribution automatically if the project schedule changes. If you have not maintained basic dates, the system automatically takes the data from date control, which you maintain in the Project System IMG (by choosing Costs → Planned Costs → Easy Cost Planning and Execution Services → Create Costing Variant).

You can also carry out costing from Easy Cost Planning in a simulation version, which you can also create and process in the Project Builder.

You can use the planned values calculated as the basis for carrying out sales pricing from the Project Builder.

You can trigger the following activities (the Execution Services) using the quantity structure entered in the costing:

- Purchase requisition [Ext.]
- Purchase order
- Reservation [Ext.]
- Goods issue [Ext.]
- Internal activity

The Execution Services function selects the costing items relevant for the process to be triggered. At the same time, the system displays the postings already made for the relevant service. For example, if you want to trigger a purchase order for a WBS element, the system displays the purchase orders already posted for this WBS element, to avoid duplication.

The structure, hierarchy, and cost element reports are also available, along with those from the Business Information Warehouse (BW).
Executing Easy Cost Planning

Prerequisites

You are authorized to maintain the project structure in the [Project Builder [Ext.]].

The WBS elements where you want to calculate costs must be flagged as planning elements.

You set the relevant indicator in the Project Builder WBS overview, in the Basic Data tab page.

Use simulation versions if you want to create alternative plans.

You must have entered the following settings in Project System customizing, under Costs → Planned Costs → Easy Cost Planning and Execution Services:

- You have defined a CO version for Easy Cost Planning.
  
  In the standard, the values calculated in Easy Cost Planning are recorded in CO version 000.
  
  However, if you want to use Easy Cost Planning for preliminary costing of complex projects, you should stipulate that the values are recorded in a CO version other than 000.
  
  **Why?**
  
  After preliminary costing, concurrent planning using networks takes place when the project starts. However, the system can only record the data from the network costing in CO version 000.
  
  You define a CO version other than 000 for values from Easy Cost Planning so that the system does not add that data and the data from network costing together.

- You have maintained a costing variant for Easy Cost Planning and assigned it to a project profile by means of a plan profile.

şı

We recommend that you use either costing variant PS06, which we deliver in the standard, or a copy of it.

- You have used the execution profile to stipulate which execution services (purchase requisitions, material reservations, and so on) are available to the user.

- The Integrated Planning indicator in the Controlling tab of the project profile must not be set.
  
  You cannot use Easy Cost Planning for plan-integrated projects.

For most information on the settings, go to the Project System IMG and read the documentation under Costs → Planned Costs → Easy Cost Planning and Execution Services.

Procedure

1. Logistics or Accounting → Project System → Project → Project Builder.
   
   The Project Builder screen.

2. If you want to calculate costs for all the planning elements in your project, access your project in the Project Builder [Ext.].
Executing Easy Cost Planning

If you want to calculate costs for just one planning element, access that element only in the Project Builder.

3. Choose 📋.

The Create Costing dialog box appears, containing default values for the costing variant and costing data.

4. Confirm or change the default values and choose 📋 Create Costing.

The Easy Cost Planning screen appears.

If you accessed your whole project in the Project Builder, the system displays the whole project structure at top left, under the heading Costing Structure.

If you access only one planning element for your project, the costing structure shown comprises only the WBS element and all the WBS elements subordinate to it.

The planning elements are flagged as follows: 📋.

WBS elements that are not planning elements are flagged as follows: 📍.

For details of further processing and a detailed description of the functions, read Cost Planning with Easy Cost Planning [Ext.].
Triggering the Execution Services

Use

Having planned costs using Easy Cost Planning [Ext.], you want to trigger one of the following processes: Purchase requestion [Ext.], purchase order [Ext.], reservation [Ext.], goods issue [Ext.], or internal activity allocation [Ext.] with and without Workflow [Ext.]. To do this, the system will utilize the data that you entered for planning the costs.

This is possible for:

- Internal orders
- WBS elements
- Ad hoc cost estimates to which you have assigned an account assignment object.

Integration

The application components triggered for the Execution Service are the application components Purchasing (MM-PUR), Inventory Management (MM-IM), Cost Center Accounting (CO-OM-CCA), Activity-Based Costing (CO-OM-ABC) and SAP Business Workflow [Ext.].

Prerequisites

The required settings have been made in Customizing under Execution Services.

You have executed the cost planning, and the object (internal order or WBS element) exists in the system.

Showing the Item view must not be excluded by your Role [Ext.].

Features

The costing screen is constructed as follows:
Triggering the Execution Services

Under *Execution Services* you are offered all of the Execution Services that are possible for the object to be planned. Before you select an Execution Service, it is possible to obtain an overview of all the existing purchase requests, purchase orders and so on for the costing items that have been created through the Execution Service. Click on the costing item in the screen area *Costing structure*, and choose the entry screen. The items relevant to the Execution Service are selected and, where applicable, expanded to include additional data. By using the Document overview you can also display the *Document overview* for the Execution Service and the object in question, enabling you to avoid a double posting.

The Execution Service is posted in the system. Choose in the *document overview* to display the document posted.

**Activities**

1. Choose *Show Execution Services* and select an Execution Service. The system automatically selects those items relevant to the Service you selected, for instance for internal activity allocations E (*internal activity*), P (*Process - manual*), X (*Process costs ABC*) and V (*variable*) items are selected.

2. Select the costing items for which the Execution Service is to be triggered. You can also change the items, for example by entering a different quantity.

3. Post the items.

If an employee of the cost center that supplied the internal activity is also to post the internal activity allocation, you can start a *Workflow*. Select *Internal activity allocation* in order to select the relevant costing items. Select the item(s) and choose the entry screen. The screen *Change Document: Cost Center XYZ: Create Note* appears. In this screen, you can create messages for the workflow processor. Save (even if you have not created a message) and go back to the initial screen.
Result:
The items are in the processor's workflow inbox [Ext.]. When the processor calls the task, the screen *Easy Cost Planning: Execution Services* appears. The processor can then post the internal activity allocation in this screen. By confirming the processing when leaving the screen, the task is deleted from the processor's inbox.

💡 You cannot start a workflow for business process items.

See also:

[SAP List Viewer [Ext.]]
Example of the Easy Cost Planning of a Project

Initial Situation

Your company frequently handles projects in which supply ditches are dug, pipes laid, and the ditches filled in again. These projects vary according to the size of the ditch and the diameter of the pipe.

Prerequisites

For this example, the following data must be available in the system in controlling area 1000:

- In Customizing (Cross-Application Components → Classification System → Characteristics → Define Characteristics Groups) the characteristic group Banks has been created for you (Banks). You use this group to flag the characteristics that you created.
- Cost center 4298 (engineering) with activity types 1420 (machine hours) and 1421 (labor hours)
- Cost element 420 000 (direct labor costs)
- Materials PIPE 10 and PIPE 20 (Logistics → Materials Management → Material Master → Material → Create (General) → Immediately)

Creating the costing model

You can gain an overview of creating a costing model under Editing Costing Models and Assigning Attributes [Page 16].

Choose Logistics → Project System → Basic Data → Templates → Models for Easy Cost Planning. Choose on the right hand side of the screen. Create costing model DITCH_A with the description Ditch of category A.

Assign characteristics to the model. To do this enter the respective name under Characteristic name in the table in the bottom right of the screen, and choose Continue. This way you access the transaction for creating the characteristics. Once you have created a characteristic save it and then create the next one.

Create the following characteristics and attributes:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Data type</th>
<th>No. of chars</th>
<th>Decimal places</th>
<th>Unit of measure</th>
<th>Template</th>
</tr>
</thead>
<tbody>
<tr>
<td>DITCH LENGTH</td>
<td>Length of ditch</td>
<td>Numeric format</td>
<td>4</td>
<td>1</td>
<td>M</td>
<td><em><strong>-</strong></em></td>
</tr>
<tr>
<td>DITCH WIDTH</td>
<td>Width of ditch</td>
<td>Numeric format</td>
<td>2</td>
<td>1</td>
<td>M</td>
<td><em><strong>-</strong></em></td>
</tr>
<tr>
<td>DITCH DEPTH</td>
<td>Depth of ditch</td>
<td>Numeric format</td>
<td>2</td>
<td>1</td>
<td>M</td>
<td><em><strong>-</strong></em></td>
</tr>
</tbody>
</table>
Example of the Easy Cost Planning of a Project

<table>
<thead>
<tr>
<th>DURATION</th>
<th>No. of days required</th>
<th>Numeric format</th>
<th>2</th>
<th>0</th>
<th>required</th>
</tr>
</thead>
<tbody>
<tr>
<td>FLAT RATE</td>
<td>Travel costs flat rate</td>
<td>Currency format</td>
<td>4</td>
<td></td>
<td>EUR</td>
</tr>
<tr>
<td>PIPE</td>
<td>Supply pipe</td>
<td>Character format</td>
<td>20</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can only define and change the attributes when you maintain the characteristics. To change a characteristic, choose 🔄 in the table.

For all characteristics, choose Characteristic group Banks.

Set the indicator Entry required for all characteristics. If you also want to use the model for projects that do not involve the laying of a pipe, do not set the indicator for the characteristic PIPE. The cost planner should not select a value and no costs will be calculated.

Define the following values for the characteristic PIPE:

<table>
<thead>
<tr>
<th>Characteristic value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Diameter 10 cm</td>
</tr>
<tr>
<td>2</td>
<td>Diameter 20 cm</td>
</tr>
</tbody>
</table>

For more information, see Creating and Assigning Characteristics [Page 21].

The entry screen appears in the cost estimate as below:
Example of the Easy Cost Planning of a Project

Click on the node *Define the derivation rules (template)*. Select WBS element under *Reference object*. Enter the following lines in the template:

In the *Type* column, select the item category for the template using the input help. Use the input help also in the *Object* column and call the formula editor in the *Quantity* and *Activation* columns by double-clicking in the cell, if characteristics are being used.

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Object</th>
<th>Quantity</th>
<th>Activation</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center/</td>
<td>Labor costs for the diging of the ditch</td>
<td>4298 / 1421</td>
<td>DITCH LENGTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td>activity type</td>
<td></td>
<td></td>
<td>* DITCH WIDTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* DITCH DEPTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>/ 10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost center/</td>
<td>Machine costs for the diging of the ditch</td>
<td>4298 / 1420</td>
<td>DITCH LENGTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td>activity type</td>
<td></td>
<td></td>
<td>* DITCH WIDTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* DITCH DEPTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>/ 10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Supply pipe</td>
<td>0001 / PIPE-10</td>
<td>DITCH LENGTH</td>
<td>PIPE =</td>
<td>'Diameter 10 cm'</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>Supply pipe</td>
<td>0001 / PIPE-20</td>
<td>DITCH LENGTH</td>
<td>PIPE =</td>
<td>'Diameter 20 cm'</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost center/</td>
<td>Labor costs for the laying of the pipe</td>
<td>4298 / 1421</td>
<td>DITCH LENGTH</td>
<td>PIPE =</td>
<td>'Diameter 10 cm' OR</td>
</tr>
<tr>
<td>activity type</td>
<td></td>
<td></td>
<td></td>
<td>PIPE =</td>
<td>'Diameter 20. cm'</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* 5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost center/</td>
<td>Labor costs for the filling in of the ditch</td>
<td>4298 / 1421</td>
<td>DITCH LENGTH</td>
<td>PIPE =</td>
<td>'Diameter 10 cm'</td>
</tr>
<tr>
<td>activity type</td>
<td></td>
<td></td>
<td>* DITCH WIDTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* (DITCH DEPTH -0.1) / 10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost center/</td>
<td>Machine costs for the filling in of the ditch</td>
<td>4298 / 1420</td>
<td>DITCH LENGTH</td>
<td>PIPE =</td>
<td>'Diameter 10 cm'</td>
</tr>
<tr>
<td>activity type</td>
<td></td>
<td></td>
<td>* DITCH WIDTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* (DITCH DEPTH -0.1) / 10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost center/</td>
<td>Labor costs for the filling in of the ditch</td>
<td>4298 / 1421</td>
<td>DITCH LENGTH</td>
<td>PIPE =</td>
<td>'Diameter 20.cm'</td>
</tr>
<tr>
<td>activity type</td>
<td></td>
<td></td>
<td>* DITCH WIDTH</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* (DITCH DEPTH -0.2) / 10</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Example of the Easy Cost Planning of a Project

<table>
<thead>
<tr>
<th>Cost center/ activity type</th>
<th>Machine costs for the filling in of the ditch</th>
<th>DITCH LENGTH</th>
<th>PIPE = 'Diameter 20,cm'</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>4298 / 1420</td>
<td>* DITCH WIDTH * (DITCH DEPTH -0.2) / 10</td>
<td></td>
</tr>
</tbody>
</table>

### Variable item

<table>
<thead>
<tr>
<th>Travel costs</th>
<th>DURATION</th>
<th>FLAT RATE</th>
</tr>
</thead>
<tbody>
<tr>
<td>420000 / H</td>
<td>DURATION</td>
<td>FLAT RATE</td>
</tr>
</tbody>
</table>

For further information, see *Defining Derivation Rules [Page 25]*.

### Result

You can now use the costing model to plan the costs for WBS elements. Assume that you have a project to develop a residential area and one of the WBS elements for the project is *Lay supply pipe in Tony Benn Street*. You can call Easy Cost Planning for the project, select the WBS element node and then select the planning form DITCH_A. After you have entered the data for Tony Benn Street and chosen *Confirm*, the costing results are displayed in the *Costing Structure* screen area. For more information, see *Using Easy Cost Planning [Ext.]* and *Easy Cost Planning in the Project System [Page 28]*.
Manual Cost Planning in the Work Breakdown Structure

Purpose

If controlling and cost planning are the most important elements of project processing for you, use manual cost planning to enter the costs, activities, and business processes you expect to occur as your project is executed. You can use cost planning to compare plan and actual costs and analyze variances.

Implementation Considerations

If you use the bottom-up procedure, you enter the planned values in the lower planning elements, and the system then totals them up. If you use the top-down procedure, the planned values are distributed manually from the higher planning elements to the lower ones.

Integration

You use budget management [Ext.] to manage the approved cost framework for a project.

The graphic below shows how cost planning and budgeting complement each other.

Features

There are various planning methods and functions, designed to cover the various degrees of detail available at the different stages of the project.

Plan Integration

Within the framework of integrated project planning, you can settle plan data or business processes, and pass them on to profit centers and the general ledger.

Plan integration in projects is the same as plan integration in internal orders.
See also Plan Integration for Internal Orders [Ext.]

**Plan-Integrated Projects**
Plan-integrated projects offer integrated planning of cost elements and activity inputs with cost centers and business processes in one plan version. The system updates allocations directly in the cost center or business process.

**Non-Plan-Integrated Projects**
In projects which are not plan-integrated, you can only plan costs and activities locally. No planning takes place in the performing cost centers or business processes.

**Planning in More Than One Plan Version**
The information available on a project changes as the planning phase progresses. This sometimes makes cost planning in more than one version a good idea. This also how planning usually proceeds in everyday business. For this reason, you can plan projects in any CO versions you like.

See Plan Versions [Ext.]

**Planning Methods**
The WBS includes various planning methods in the WBS element, from which you can choose depending on the state of the project and the degree of detail you need.

You can use these methods alternatively or together.

You decide this on the basis of the information available. For example, you can use a unit costing or cost element planning for particular partial tasks and use cost-element-independent hierarchy planning to estimate the costs for the rest.

Hierarchy planning is the simplest type of cost planning. You enter the planned values hierarchically, and they are displayed in the same way.
Manual Cost Planning in the Work Breakdown Structure

You estimate the expected costs for a project or planning element by, for example:

- Taking cost information from comparison objects
- Deriving costs from contract totals

Hierarchy planning in the work breakdown structure is the same as overall planning in internal orders [Ext.].

As more information becomes available as planning progresses, hierarchy planning can act as a starting point for two alternative methods of detailed project cost planning.

- **Cost Element Planning and Activity Input Planning [Ext.]**

  You can plan primary costs, revenues, activity inputs, and statistical key figures on a cost element basis.

- **See Unit Costings [Ext.]**

  If you have information on sources of supply, quantities, and prices, the unit costing is the most detailed project cost planning method available. You can use it to calculate overall and annual costs.
Plan Line Items

Definition
The following changes in costing planning can be documented in the system as line items:
Changes in:
- Structure oriented cost planning (independent of cost elements)
- Planning primary costs and activity input
- Unit costing (independent of cost elements)
Plan line items are not written for changes in:
- Network costing
- Unit costing (by cost element)
The project or the WBS element must have a user status, to which the Plan line items business transaction is assigned. This enables the system to write line items.
Writing line items means that:
- Planning changes are possible at any time
- Each change is recorded with the date and who made the change (plan line items are written) so that you can track these changes at any time later on.

Use
For more information on how to create a user status, see Status Management [Ext.].
To display the plan line items (independent of cost elements) for a WBS element, go to Cost Planning and choose Extras -> Display line items
The plan line items (dependent on cost elements) are displayed in the information system.

💡
If line items can be written in the project, then changes are documented in line items, in the different versions.
The system only creates line items from the time when you set this up. This means that the planning value of a cost element may, in certain circumstances, vary from the total of the planning line items.
In WBS elements that are plan integrated, the system writes line items (regardless of the user status) for cost planning (dependent on cost elements), if you activated the integrated planning indicator in the fiscal year-dependent parameters for each planning version.

💡
On WBS element 2000.1, you have already planned EUR 10,000.00 under the External activity cost element (415000). Now activate the line item writing function within the project. The system now documents all planning changes in line items. Another EUR 2,000.00 and EUR 3,000.00 are planned. The total of the planning line items is EUR 5,000 as a result. However, the total of the...
Plan Line Items

cost element planning is EUR 15,000, therefore the result of the totals record planning is not the same as for line items.

Line items are identified by a unique number. In customizing for the project system, you need to specify number range intervals under Check Number Ranges for Rough Planning [Ext].
Totaling Up Plan Values

Use
Projects can generally be planned top-down from a central instance. However, some projects are planned at local level, by different people who are, for example, responsible for particular subprojects or WBS elements.

If planning is at local level (called “bottom-up” planning), the planning manager needs an overview of planning. As the plan values are arranged in a hierarchy, the values in the hierarchy levels must agree. Cost planning can only be deemed correct if the planned values in lower levels do not exceed those in higher levels. The plan values must be totaled up.

Which values are totaled up?

- Structure plan values from subordinate WBS elements
- Cost element plan values from subordinate WBS elements
- Unit costing values from subordinate WBS elements

\[ \text{Structure plan value from the directly superior WBS element} \]

Note that this total is not identical with the “plan total” because the latter still contains the plan values from the networks and appended orders assigned to the WBS elements.

Procedure
1. Choose Logistics or Accounting → Project System → Financials → Planning → Costs in WBS → Overall Values → Change.
   This brings you to the initial screen for changing cost planning.
2. Enter the necessary data.
   This brings you to the screen Change Cost Planning: WBS Element Overview.
   The Total up dialog box appears.
4. Choose whether you want to total up the annual and/or overall values.
   The year fields already contain the years for which the planning profile envisages cost planning.
5. Choose .
   The system overwrites the structure plan value for a WBS element with the total of the structure plan values, cost element plan values, and unit costings from the WBS elements directly subordinate to it.
6. Choose Save.
**Example**

A planning element has a plan value of $80,000, of which $50,000 and $25,000 respectively are distributed to two planning elements in the next level down. The two planning elements also have plan values from cost element planning of $10,000 each. If you now trigger the totaling up function, the structure plan value of $80,000 is overwritten with the plan total of $95,000.

You can trigger the totaling up function at any time during the planning procedure.

You can use the cost plan profile in the Project System IMG to stipulate that plan values are totaled up automatically when you save your planning (bottom-up planning).

---

**Totaling Up Plan Values**

<table>
<thead>
<tr>
<th>Structure plan</th>
<th>28,000</th>
<th>Old</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>75,000</td>
<td>New</td>
</tr>
<tr>
<td>Cost element plan</td>
<td>30,000</td>
<td></td>
</tr>
<tr>
<td>Unit costing</td>
<td>40,000</td>
<td></td>
</tr>
<tr>
<td>Plan total</td>
<td>145,000</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Structure plan</th>
<th>35,000</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost element plan</td>
<td>15,000</td>
</tr>
<tr>
<td>Unit costing</td>
<td>25,000</td>
</tr>
<tr>
<td>Plan total</td>
<td>75,000</td>
</tr>
</tbody>
</table>
Adjusting Plan Values

Use

You can adjust the plan values in a project or in selected WBS elements - that is, you can increase or decrease them by a particular percentage or amount.

Procedure

1. In the WBS element overview in cost planning, select the WBS elements whose values you want to adjust.
2. Choose Edit → Adjust.
   The Adjustment dialog box appears.
3. Enter the percentage or amount by which you want to change the plan value.
   If you want to reduce the plan value, enter a minus sign ("-") after the figure.
4. Choose ✓.
   The system updates the plan values per your input.
5. Choose Save.
Presenting Planning Values

Features
In addition to overall and annual planning values, you can see the following values by choosing Views:

Distributed Value
This is calculated as follows:

| Structure planning values of lower-level WBS elements |
| Planning values for cost elements, from lower-level WBS elements |
| Unit costings from lower-level WBS elements |

If you planned by cost element in an earlier release, then you can convert these planning values with the BPDIST00 report.

Distributable Value
This is the difference between the planning value and the distributed value.

Plan Total of a WBS Element
This is calculated as follows:

| Structure planning value (independent of cost element) |
| Cost element planning value |
| Unit costing value |
| Value of the additive orders for the project, meaning the orders assigned to this and all lower-level WBS elements. |
| Value of the additive networks and network activities that are assigned to this and all lower-level WBS elements (= planning costs for networks or network activities) |
| Plan total |

Additive values consist of:

| Overall planning value (independent of cost element) |
| Cost element planning value |
| Unit costing values |

Order / Network
This consists of the planning values of additive orders or networks.
Presenting Planning Values

Planning values for **additive orders** consist of:

| + | Approximate planning values |
| + | Planning values for cost elements |
| + | Unit costing |

Planning values for **additive networks** consist of:

| + | Costings from internally and externally processed business transactions |
| + | Values from cost transactions |

**Previous Year**
These are the planning values of the previous year

**Cumulated Value**
This is the plan total of all years.

**Remainder**
This is the difference between the total planning value and the cumulated value.

**Unit costing values**

**Values from Cost element Planning**

You use the parameters in the planning profile to specify which default values the system displays with the planning value, when you access cost planning.

**Settings**

You determine whether you want to enter planning values in 1; 10; 100; 1,000; 10,000; 100,000; or millions (**0 to **6) of currency units via Settings → Scaling. Depending on the currency, you can also choose more than one decimal place for the display of your planning values.
Planning Costs

Prerequisites
To be able to plan overall costs for a project, you must first create a work breakdown structure [Ext.]

Procedure
1. Choose Logistics or Accounting → Project System → Financials → Planning → Costs in WBS → Overall Values → Change.
   This brings you to the initial screen for changing cost planning.
2. Enter the necessary data.
   The first time you run cost planning for a project, this automatically creates version 0.
3. Choose Cost Planning.
   This brings you to the screen Change Cost Planning: WBS Element Overview. It shows the project, its WBS elements, and the field ready to receive overall plan values entries.
   Cost planning first refers to the overall costs which may occur for a project.
   In the plan profile, you can stipulate whether cost planning is possible in all WBS elements or only in those defined as planning elements. You define planning elements in the project master data (Operative Indicators).
4. Enter plan values in the WBS elements for which you want to plan.
5. Use Annual overview or Annual values to distribute the plan values over time.
6. Choose .
   The system checks your cost planning. For more information, refer to Checking Cost Planning [Page 50].
7. Choose Save.
Checking Cost Planning

Use

Having planned your costs, you can then check the plan.

- **Within the project structure**, check whether the plan totals in a subordinate WBS level exceed the plan value in the superior level.

- If you have selected overall value planning in the planning profile, you need to check **over time** whether the total of the annual plan values exceeds the overall plan value.

Procedure

1. Go to the screen *Change Cost Planning: WBS Element Overview*.
2. Choose 📈.
   
   The dialog box *Structure Planning: Display Messages* appears.
   
   A list is displayed, showing the WBS elements where there are planning errors. You can access error logs for the WBS elements. The logs explain what caused the errors.
3. Close the window by choosing 🔄 *Continue*.
   
   This returns you to the screen *Change Cost Planning: WBS Element Overview*.
   
   The WBS elements where there are planning errors are displayed in red.
4. Correct your planning as necessary:
   
   a. Overwrite the incorrect plan values.
   
   b. Choose 📈.
   
   c. Choose 📂 *Save*.

Result

In the event of an error, the following happens:

- The WBS elements with planning errors are highlighted in the overview screen and the annual overview.

- In addition, the system displays a message, directing your attention to an error log. Choose *Extras → Error log* to display and/or print the error log. The log shows the WBS/planning elements where there are errors, including a comparison of the plan values and distributed values. Choose *Long text* or double click a line in the log to access an explanatory text.
Planning Annual Values

Use

You can plan the years that are likely to be needed to realize a project either before or after you plan overall cost.

Planning Annual Values for a WBS Element

1. Call up the project that you wish to plan for. The Change Cost Planning: WBS Element Overview screen displays the project with its WBS elements in the start year.
2. Select the planning element for which you want to plan the annual values.
3. Choose Annual values. The system displays the overview screen for the annual planning, and the overall planning value (if one exists) for the selected planning element and the fields (ready for entry) for the annual values.
4. Enter your annual planning value for the selected planning element.
5. Execute your annual planning for all of the planning elements in the same way.
6. Check the planning by choosing .
7. Save the planning values by choosing .

The Adjust and Total up functions are also available for planning annual values.

Planning Annual Values for all WBS Elements

Instead of specifying the annual values for a particular planning element using the annual overview, you can also plan on all the planning elements for a particular year.

1. Choose Year. The system displays the element overview for the start year, with the fields ready for planning value entry. If you do not want to start planning with the project start year, then choose Goto -> Timeframe -> Timeframe... The system displays the Timeframe dialog box. Enter the required planning year, and choose .
2. If you want to plan for the following year, choose . You can choose and to choose the following or previous year for planning. The system displays the element overview with the fields ready for input in the planning element.
Cost Planning in Networks

Purpose
In integrated project management, plan costs are first calculated using valuation rates or the prices for internal and external activities and the required operating resources. In networks, you plan services, internally/externally processed work, and the required resources in network activities. The system then calculates the plan costs, taking account of the dates. The cost determination is based on the quantities and prices stored in the system.

The planned costs are distributed over time, based on the distribution over time of the activities and operating resources planned in the activity.

Integration
- Simulation Version
  Simulation versions are also available in connection with network costings. This is the only means available there for planning and transferring costs in simulation versions. You can use simulation versions to depict different cost planning scenarios.

- Resource-related quotations
  The costs determined using costings serve as the basis for creating resource-related quotations.

Features
- Calculating plan costs on the basis of planned activities and operating resources
  You can calculate plan costs for networks either in network maintenance, using the network costing, or outside network maintenance, using the asynchronous network costing. With this, you can calculate costs for several projects simultaneously.

  See Asynchronous Network Costing [Page 78].

- Unit costings
  You use the unit costing for detailed cost planning, particularly in the early stages of a project when you have not yet created detailed structures.

  See also Unit Costings in Networks [Page 71].

- Invoicing plan
  You use the invoicing plan to reproduce when costs occur for externally procured services (externally processed activities) and materials (non-stock components) as well as general costs activities.

  See also Network Invoicing Plans [Page 65].
Network Planned Costs

Purpose

The system uses the calculation of plan costs in the network to determine their development over time, based on the available quantity and price structures.

Depending on whether the network is header-assigned or activity-assigned, the system records the costs so calculated in the:

- Network header
- Activity

Further functions, such as the asynchronous network costing and the cost forecast, are available for activity-assigned networks.

Prerequisites

There must be a network schedule.

The costing variant must be defined in the Project System IMG and stored in the network header control data. In the IMG, you can define the planned costing variant as a default value in the network type parameters.

The activity/activity element must be flagged as “costing relevant”, using the control key. You maintain the control key in the Project System IMG and define it in the detailed data for activities and activity elements.

For the purpose of overhead calculation, you must also enter a costing sheet in the detailed data for activities or activity elements. If you have not maintained a costing sheet for the activity, the system uses the costing sheet from the network header.

Process Flow

1. Plan the services to be rendered and the required operating resources in the activities, activity elements, and components.

   Even at early planning stages, where the structure is not detailed and the exact nature of materials is still unclear, you can use the unit costing to plan costs in detail for general costs activities or material components. If the necessary information is available, you can replace the activity with a subnetwork.

   You use the invoicing plan to determine when and in what amount costs for materials and services procured externally, and general costs activities, are expected to occur.

2. Calculate the planned costs The system determines the plan costs:

   - When you save the network, provided you have activated the automatic costing indicator in the network header control data.

     You use the planned cost determination indicator to stipulate whether and when the planned costs are determined when you save the network:

     3. Value 4. Action
Network Planned Costs

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>When saved, from release</td>
</tr>
<tr>
<td>2</td>
<td>When you save</td>
</tr>
<tr>
<td>0</td>
<td>Planned costs not determined when network saved</td>
</tr>
</tbody>
</table>

- If you call up the Calculate costs function in network processing.
  In this case, the system recalculates all the costs, taking account of price changes. You can execute the planned cost calculation function at any time during network maintenance.

- If you access the asynchronous network costing in the Project Planning menu
  You can run the asynchronous network costing for one or more networks at any time, regardless of the costing in network maintenance. If Project Cash Management is active, the system uses the asynchronous network costing to determine planned payments for the network.
  See Asynchronous Network Costing [Page 78].

Planned costs are calculated for the following network objects:

- Internally processed activities
-Externally processed activities
- General costs activities
- Activity elements
- Material
- Services

See also: Basis Values for the Network Costing [Page 58].

3. The system determines the planned overhead (overhead or process costs) as well as the planned costs. Depending on the network type in question, the planned costs are recorded in the network header or activity.

See Calculating Planned Costs [Page 56] and Overhead [Ext.].

If the activity is assigned to a WBS element, the network type and status determine whether the network is appended and/or apportioned. Plan values in appended networks increase the plan values in the relevant WBS element: apportioned values increase the assigned value. Networks flagged as preliminary planning networks (network type 21) are always appended.

See also Orders for Projects [Page 86].

4. You can evaluate the network plan costs online, using various criteria:

- In the plan/actual comparison, totaled up by cost element
- As a cost itemization
  The planned costs are calculated and displayed by cost element or origin each time you access them.
- In the cost component split
  The planned costs are displayed, classified by cost component.

If an activity is technically complete or flagged for deletion, the planned costs are not determined and cannot be displayed in the itemization. The plan costs determined before the
Network Planned Costs

Technically complete status was set remain in place in activity-assigned networks. You can evaluate them in the project information system.

See Representing Planned Costs [Page 63].

Activities

As the project progresses, actual costs will arise relating to the planned costs. Network actual costs arise from:

- Postings in Financial Accounting
- Goods movements in Materials Management
- Internal activity allocations
- Overhead in cost accounting
- Confirmations
- Invoice receipts

In valuated project stock, actual costs from material procurement are recorded in the WBS element and those from materials usage are recorded in the activity.

See also Valuated Project Stock [Ext.]

You determine the overhead on actual costs periodically, as part of periodic processing.

Actual costs, commitments, and data from network activity confirmations, or changes to the forecast work and forecast completion of the project, mean that the actual development of costs will often vary from what you have planned. To achieve a realistic cost forecast, you can use this data to update your cost expectations.

See also Project Cost Forecast [Page 96].

For more information on cost planning and actual costs, refer to Cost Object Accounting [Ext.].
Calculating Planned Costs

Purpose
The network costing is used to determine, automatically, the planned costs for the activities and operating resources entered in network activities, activity elements, and components.

Prerequisites
The costing variant must be defined in the Project System IMG and stored in the network header control data. In the IMG, you can define the planned costing variant as a default value in the network type parameters.
For overhead calculation purposes, you must define a costing sheet in the activity.

Process Flow
The graphic illustrates how the system determines network planned costs:

[Diagram showing the process flow]

1. **Quantity Structure**
2. **Costing variant**
   - Costing type
   - Valuation variant
3. **Prices x Quantity**
4. **CO Object**
   - Planned Costs w/o Overhead
     - Cost element
     - 400000 RM consumed 4,000.00
     - 415000 Ext. proc. costs 20,500.00
   - Cost elements 24,500.00
5. **Overhead**
   - Planned Costs with Overhead
     - Cost element
     - 400000 RM consumed 4,000.00
     - 415000 Ext. proc. costs 20,500.00
     - 661000 Overhead 1,200.00
     - 662000 Mat. overhead 2,000.00
   - Cost elements 27,700.00
Calculating Planned Costs

First, the system creates a quantity structure. The quantity structure is the basis for the costing. It contains all the network data needed for the calculation.

The system valuates this quantity structure using a costing variant [Ext]. Costing variants contain the criteria for the costing and comprises:

- Costing type
- Valuation variant, containing the:
  - Strategy sequence for rate and price determination
  - Costing sheet for overhead calculation
  - Costing variant as a default value for the unit costing in the general costs activity or material component.

Result

You now have planned costs and overheads. The planned overhead is calculated automatically as part of costing. Depending on the network type in question, the planned costs are recorded in the network header or activity.

Depending on the costing sheet, the planned overheads are calculated using either overheads or process cost accounting.

If errors occur in the costing, the system directs your attention to the error log.

See Calling Up the Cost Determination Error Log [Page 64].

The system does not recalculate the plan costs for activities with final confirmation in activity-assigned networks. However, the procedure is different for header assigned networks. Here, the system determines the planned costs again for activities with final confirmations. If it did not, it would not be possible to correctly determine the costs in header-assigned networks.
Basis Values for Network Costings

Use
Planned costs for activities, activity elements, and material costs are calculated using the existing quantity and price structure.

Features
The system determines the basis values for the costing on the basis of the activity type and the type of material component.

Internally Processed Activities
You use internally-processed activities to plan work to be performed internally. You specify the:
- Required work time
- Duration and dates of activities
- Work center at which an activity will be carried out
- Activity type (if desired, from the work center)

The system uses the values stored in the activity or work center to determine the price for the actual type and cost center which applies in cost center accounting.

The relevant cost center is determined from the work center or using the activity type.

The planned costs are calculated on the basis of the planned work time and the valid price.

In addition to the planned work, you can define a preliminary planning amount for materials on the Assignments tab page in the detailed view. You might do this, for example, if you are not yet sure what materials you will use. If you add the material components later, the system reduces the preliminary planning amount by the amount of the material components. This function is only available if a primary cost element for preliminary material planning is defined for internally processed activities in the network profile. The preliminary planning amount is included in the costing and increases the planned costs for the activity. If the planned costs of the material components assigned to the activity exceed the amount planned for the material, the amount in the costing is set to zero.

Externally Processed Activities
You use externally-processed activities to plan work to be performed externally. The system calculates the planned costs using the price which:
- You have defined manually in the activity
- Is defined in the purchasing info record

If you change dates or quantities in detailed activity maintenance, the price is updated in line with the fixed price indicator for the purchase info record.

If you maintain an invoicing plan for the activity, the system copies the price from the activity into the invoicing plan as the overall price, or vice versa.
Basis Values for Network Costings

You use the reservation/requisition indicator in the detailed data for the externally processed activity to stipulate whether and when the system creates a purchase requisition for the activity. If the purchase info record changes, you can use the asynchronous network costing to update the activities. This also updates the data in the network.

General Costs Activities

You can maintain the planned costs for the general costs activity (primary costs) in the following ways:

- As the overall value for a cost element
- Using the invoicing plan
- Using unit costing

![Tip]

If you have maintained unit costings for a general costs activity, you cannot also maintain an invoicing activity for the activity, or vice versa.

In the network profile, you can define a default cost element for the general costs activity.

Activity Elements

The procedure for determining plan costs for activity elements is the same as for activities.

Material Components

Material components for the activity are differentiated, by means of item categories, as follows:

- Stock material, item category L
- Non-stock material, item category N

Various prices are stored for stock material in the accounting view of its material master record. For more information, read the Material Component Inventory Management [Ext.]

Pricing takes place using the matching strategy from the valuation variant. You define the valuation variant in the costing variant [Ext.] IMG.

In the case of components managed in valuated project stock, you can also use the unit costing to plan the costs for the material component. See Unit Costing in the Material Component [Page 75].

Plan costs for material not managed as inventory are determined using the purchasing info record or from the activity item.

Prices are calculated in one of the following ways:

- Using the strategy in the valuation variant
- Manually, using the invoicing plan
- Using unit costing

You use the reservation/requisition indicator in the detailed data for the material component to stipulate whether and when the system creates a purchase requisition for the component.

Configurable Materials
Configurable material components in the valuated project stock can only be valuated using the asynchronous network costing, by means of a multi-level product costing in line with the configuration settings entered. The prerequisite for this is that you enter a costing variant for valuation of configurable materials as the network costing variant.

The configurable materials are valuated at the standard price (the price stored in the material component), as part of network costing. Your configuration settings do not affect this.

Configurable materials in non-valuated project stock are always valued at the standard price.

Services

You plan services for externally-processed activities in which the Service indicator is set. The services you assign to the activity as service specifications are differentiated into the following:

- Planned services
- Unplanned services

The term “planned services” refers to services known to you when you start the procurement process. Planned costs for these services are determined using the price determined from the service conditions and the quantity in the service specification.

“Unplanned services” are services whose procurement cannot or should not be specified. The value you have defined as the “expected value” in the service specification for the activity is adopted as the planned costs figure.
Costing by Period

Use
In the case of internally-processed activities and general costs activities, you can distribute the costs calculated by period.

Prerequisites
In Project System customizing, select pricing by period in the valuation variant. You use the costing variant to assign the valuation variant to the activity.

You must define a distribution key for the activity. If you do not, the system uses the standard distribution key, SAP 020. This key distributes the planned work evenly over the activity per the earliest set of dates - that is, to the time between the earliest start date and earliest finish date for the activity.

You define the activity key for:

- Internally processed activities in the activity overview
- General costs activities in the Costs detail screen for the activity

Features
When you cost internally-processed activities by period, the system uses the distribution key from the capacity requirement to distribute the work planned in the activity and values it at the price for the relevant period.

If no planned price has been defined for future period, you can use the strategy for the valuation variant to stipulate that the system should value the planned activity input.

The distribution key used to distribute the planned work to the individual periods can be defined in the activity or the work center. When using this facility, note the following:

- If you have maintained distribution keys in both the activity and the work center, the planned work is distributed to the periods per the distribution key in the activity.
- If you have not maintained any distribution keys, the planned work is distributed evenly to all periods.

Overhead is calculated on the basis of the distribution of planned work or costs by period.

In the case of general costs activities, the planned costs are distributed in the activity by period, using the distribution key.
Determining Planned Costs in Networks

Prerequisite
Depending on what settings you have entered in the network header control data, the system automatically calculates the planned costs:

- When you save
- When you save, if the network has been released
- Not at all

Regardless of this, you can determine the planned costs at any time, using network maintenance.

Procedure
1. Choose Logistics or Accounting → Project System → Basic Data → Project → Special Maintenance Functions → Network → Change.
   This brings you to the initial screen for changing networks.
2. Enter the relevant data and choose ☑.
   The Change Network: Header Data screen appears.
3. Choose 📊.
   The system determines the costs:

Result
The system calculates the current planned costs for the network. If errors occur, the system directs your attention to the error log [Page 64]. You can evaluate the result of the costing directly from the network.

See Displaying Planned Costs [Page 63].
Displaying Planned Costs

Prerequisite

You can access cost analysis reports directly from your network. Different reports are available, depending on whether you access the evaluation from the network header or at activity level.

Procedure

In Header-Assigned Networks

To display the planned costs for a header-assigned network, proceed as follows:

1. Choose Logistics or Accounting → Project System → Basic Data → Project → Special Maintenance Functions → Network → Change.
   
   This brings you to the initial screen for changing networks.

2. Enter the number of the relevant network and choose ✔.
   
   The Change Network: Header Data screen appears.

3. You have the following alternatives:
   
   - Choose Edit → Costs → Plan/actual → Network to obtain a comparison of plan and actual costs for the header-assigned network.
   
   - To recalculate and display the costs by cost element and cost origin, choose:
     
     Edit → Costs → Itemization or Edit → Costs → Cost split.

In Activity-Assigned Networks

To display the planned costs for an activity-assigned network, proceed as follows:

1. Access the appropriate activity overview in network maintenance.

2. Select the activity whose plan costs you want to see.

3. Choose Edit → Costs → Planned/actual → Activity/element or choose the detailed view for the activity Planned/actual costs.
   
   You see the plan and actual costs for the activity.

Result

The plan costs are shown differently for header- and activity-assigned networks.
Calling Up the Cost Determination Error Log

Prerequisites
The error log is only available immediately after costs have been determined in the network.

⚠️
The error log is not stored. It ceases to be available once you have left the network.

Procedure
1. Choose Extras → Logs → Cost determination.
   An overview of the collected messages is displayed.
2. Choose Log → Display.
   A list of all errors which occurred in cost determination is displayed.
3. If you need more information on a particular message, select it.

Result
The error log gives you an overview of the errors which have occurred in cost determination. The error log collects the system messages which occurred, and sorts them per various criteria.

In Customizing, you can change the message type the system defaults for particular messages. This is how you regulate how the system handles each individual message.
Invoicing Plans in Networks

Use

You can use an invoicing plan to plan dates when payments are due in your network. The invoicing plan thus performs the function of a credit-side time schedule containing detailed cost and payment information for:

- General costs activities
- Externally-processed activities
- Non-stock material components

Planned costs and planned outgoing payments are updated from the invoicing plan.

💡

The system records payment data in the asynchronous network costing only.

For more information, see Asynchronous Network Costing [Page 78].

Integration

If Project Cash Management is active, the system uses the invoicing plan to derive the planned outgoing payments for the asynchronous network costing. You can evaluate the planned outgoing payments on a daily basis (see Calculating Payment Planning Automatically [Ext.]).

💡

An invoicing plan maintained for a purchase order item is the only way to update the purchase order commitment and payment commitment for purchase orders by period.

You can use an invoicing plan already maintained in the network as a template for an invoicing plan for purchase orders.

For more information on the invoicing plan for a purchase order item, read Procurement via Invoicing Plan in the External Services Management section of the MM - Materials Management documentation.

Features

The invoicing plan also includes the following functions:

- You can enter your own search term for each invoicing plan. The system uses the search term to build up an input help, making it easy for you to find existing invoicing plans to use as templates.
- You can delete individual invoicing dates or the whole invoicing plan at any time.
- You can copy dates from a template.

If you are working with templates, the dates from the template act as relative dates. This means that the invoicing data from the template must be adjusted to match the start date the system has determined for the activity or component (latest end or requirement date).
In the case of general costs activities and externally processed activities, the “earliest finish” from the activity is taken as the start date.

In the component, the system takes the requirements date as the start date.

If the dates for the activities or components change, and this leads to a change in the start date for the invoicing plan, the system automatically adapts the dates in the invoicing plan.

This also happens if you change the start date manually (exception: dates from milestones). The dates for the relevant activity or component in the network do not change.

If you adapt the start date manually, the system does not automatically change the dates in the invoicing plan if the activity date or requirement date changes.

See Creating Invoicing Plans [Page 67]

- The system can generate items for milestones and automatically refresh them if the schedule changes, if you so stipulate in customizing.

  See: Generating Dates from Milestones [Page 69]

- If you have chosen partial billing by percentage as your invoicing rule, the system automatically adjusts the dates in the invoicing plan if any of the following changes:
  - Quantity or execution factor
  - Price or pricing unit
  - Currency
  - Dates in the activity or component (if you work with templates and do not change the start date manually)
    - If automatic adjustment is not possible, the system draws your attention to the facility for adjusting the invoicing plan manually.

- In line with the invoicing rule, the planned costs are determined for the individual dates in the invoicing plan and recorded in the activity. Down payment dates have no cost effect and are not included in the calculation.

- The same functions are available in the simulation versions. If you create a project with a template, the invoicing plan is also copied. Invoicing plans are also copied to simulation versions. The system uses each activity to determine the starting date.
Creating Invoicing Plans

Use

The invoicing plan is a tool for planning dates in networks for general costs activities, externally processed activities, and non-stock material components.

Prerequisites

Project Cash Management must be active, so that the system can determine and update the payment data.

You can maintain an invoicing plan in the Project System IMG (under Maintain Invoicing Plan Type) for later use as a template.

The standard system we deliver includes invoicing plan type 30 as a template. However, you can create your own in the IMG, or you can use the existing invoicing plan in an activity, component, or purchase order. The template contains dates, percentages, and absolute amounts.

Procedure

1. In network maintenance, select the appropriate activity or component overview.
2. Select the activity or component for which you want to create an invoicing plan.
3. Choose Detail → Invoicing plan.
    The Choose Invoicing Plan Type dialog box may appear. Choose an invoicing plan type. This takes you to the screen Change Invoicing Plan.
4. Enter the necessary data.
    If you want to work with a template, enter the number of the relevant invoicing plan template in the Template field.
    You must always enter the template number as a ten-digit figure. For example, if the template number is 492, you must enter 0000000492 in the template field.
    The system displays the dates and percentage apportionment, updated, in the invoicing plan. You can overwrite this data.
5. Return to network maintenance.
6. Save the network.
    The system saves the invoicing plan also.

Result

When you save the invoicing plan, the system automatically assigns it a unique number. The system displays this number when you call up the invoicing plan again.
In the network costing, the system determines the planned costs from the invoicing plan and updates them in the activity, by period.

Planned payments out are not recorded. If you want outgoing payments recorded, carry out an asynchronous network costing.

For more information, see Asynchronous Network Costing [Page 78].

If you are working with a template, the system determines the dates in line with the template for the invoicing plan. The dates are determined on the basis of the start date. The start date for the invoicing plan is the earliest finish date for the relevant activity or the requirement date for the component.

The percentage apportionment is also taken from the template.

The advantage of working with templates is that the dates in the invoicing plan are adjusted automatically if the dates in the network change.

If you want to work with fixed dates, you must not use templates to create your invoicing plan.
Generating Dates from Milestones

Use
If you use this function, the system copies the invoicing plan data from the milestones when you create items for your invoicing plan.

In customizing, you can stipulate whether the invoicing plan data is adjusted automatically when the dates in the milestones change.

Prerequisites
The date category has been maintained in Project System customizing, step Maintain Date Category for Invoicing Plan. If you have so specified in customizing, the system adjusts the dates in the invoicing plan if the milestone dates change.

In the milestone detail screen, you must maintain the sales document date and Date key 01.

If you are working with a template, you can only use the milestone date function to generate new dates for the invoicing plan.

Procedure
1. From the detail screen, call up the invoicing plan for an activity or a component.
   This takes you to the screen for changing dates in the invoicing plan.
2. Choose Dates for milestones.
   The system displays the dialog box Enter Selection Conditions.
3. In the Selection criteria dialog box, specify the network or WBS element from which you want to copy milestones.
   The dialog box Milestones for Invoicing Plan appears.
4. Select the milestones you want to take over as dates.
5. Choose Copy.

Result
In the invoicing plan, the system takes over the date of the milestone as the invoice date and the description from the milestone key as the description.

When you define or change milestones, you must then save the WBS again. Only then can you generate or update the dates from the milestones in the invoicing plan.

If you later move dates in the schedule, the system automatically adjusts those linked to milestones, if you have so specified in customizing.
Unit Costing in Networks

Definition
The unit costing is a universal tool, used to plan costs and determine prices. It has the character of a table costing which can use the master data and prices in the system.

In activity-assigned networks, you can use the unit costing to plan costs for:

- General costs activities
- Costing-relevant material components in valuated project stock

For more information on the functions in the unit costing, read Unit Costing [Ext.] in the CO - Product Cost Planning documentation.

Use
You use the unit costing as follows in networks:

- General costs activities
  - To obtain detailed cost information at an early stage in planning without matching network detail
- Material components
  - To determine the material price if no quantity structure, in the form of routings and BOMS, is available yet
- As a calculation tool
  - For example, to calculate a price you can then distribute over time in the invoicing plan

Integration
Creating from Templates
When you create a network using a template, the system considers the existing unit costings. The unit costing items are created afresh and valued accordingly. Valuation is as follows:

- In general costs activities, as of the activity start date, per the valuation key
- In material components, as of the component requirement date

Project Builder/Planning Board/Structure Planning
You can also maintain unit costings for networks in the Project Builder, project planning board, or structure planning.

Simulation Version
You can use simulation versions to depict planning alternatives. The simulation version includes all the functions available in the unit costing. When you copy a project into a simulation version, the unit costing is copied too.

Date Shifts in Networks
In network costing, the costs are redistributed over the duration of the activity.
The unit costing is not revalued at the current price. However, you do have the option of changing key date in the unit costing manually.

Replace with Subnetwork

If more detailed information on the required activities or materials is available, you can replace the general costs activity with a subnetwork. You then plan your costs using the activities in the subnetwork. To ensure that the costs from the unit costing are no longer included in the calculation, you must do the following:

- Enter a control key which is not costing relevant in the control data for the general costs activity.
  The system does not then include the costs from the unit costing. In the standard we deliver, control key PS08 is not costing relevant.
- Delete the unit costing for the general costs activity.

Deleting Unit Costings

To delete the items for the unit costing, go to the main R/3 menu and choose Logistics or Accounting → Project System → Basic data → Projekt → Special Maintenance Functions → Network → Change.

Enter the number of the relevant network and choose Activity overview.

The Change Network: Activity Overview appears.

Choose Edit → Costs → Unit Costing → Delete.
Unit Costings in General Costs Activities

Purpose
With the unit costing in general costs activities, you can carry out detailed cost planning at an early stage in the planning process, when the matching level of network detail is not yet available. You use it to plan materials, activities, and other costs. The costs from the unit costing are distributed over the duration of the activity. At a later stage in planning, you can replace the activity with a subnetwork. You then plan your costs using the activities in the subnetwork.

Integration
You cannot simultaneously maintain an invoicing plan and a unit costing for the activity. If you have already maintained a unit costing for an activity, you cannot then maintain an invoicing plan for it.

Process Flow
1. Create a unit costing for the general costs activity or copy an existing unit costing/base object costing.
2. Save the unit costing. The system values the items in the unit costing as of the starting date for the activity (key date). You can change this key date manually at any time. If you shift the network dates, the system does not automatically adjust the key date.
   
   The items are only valued in the unit costing. The planned costs are not recorded in the activity. This happens later as part of network costing.
3. The system does not calculate overhead in the unit costing in the general costs activity. This happens as part of network costing, and in line with the costing sheet for the activity.
4. Within the framework of network costing, the system takes over the items from the unit costing. The system distributes the costs over the duration of the activity and records them by cost element in the activity in accordance with the distribution key from the activity. The system only updates the resulting costs if the activity is flagged as costing relevant.
   
   In the unit costing, the system first values the unit costing items as of the key date. The planned costs calculated are then distributed over the duration of the activity. In the case of internally processed activities, the work is first distributed over the duration of the activity as part of network costing. It is then valued. Depending on whether you maintain work in the unit costing or in the internally processed activity, this may lead to the system using different prices for the valuation.
5. You can evaluate the planned costs with the usual reports in the Project Information System. There are no reports specific to unit costing.

Result
The system records the costs from the unit costing by cost element in the activity.
The overall costs for the unit costing are displayed in the amount fields for the general costs activity. The cost element for the general costs activity is deleted.
Unit Costings in Material Components

Purpose
You can use the unit costing to plan costs for materials for which no adequate price is maintained in the system. You can analyze the individual costing items in the unit costing itemization.

In the case of material manufactured in-house, the most useful information is the split of the production costs by cost element. You can use the unit costing for this.

In the case of material components procured externally, the most important information is the distribution of costs over time, which you reproduce in the invoicing plan. The unit costing acts as an aid to calculating prices in the early stages of planning.

Prerequisites
You can only maintain unit costings for costing-relevant material components which are managed in valuated project stock.

In the Project System IMG, you can enter a default value for the material component unit costing variant in the costing variant used for the network.

Process Flow
1. Create a unit costing for the material component or copy an existing unit costing.
2. Save the unit costing. The system values the items in the unit costing as of the material component requirement date (key date).
3. If a costing sheet is maintained in the costing variant used for the unit costing, the system calculates the overhead for the costs as viewed from procurement. Cost overhead as viewed from consumption in the activity is calculated as part of network costing.
4. The system records the costs from the unit costing as of the procurement date, by cost element, in the material component (procurement view) and as of the requirements date in the network activity, under a consumption cost element (consumption view).
5. The costs are recorded as follows:
   - Debit: under the cost element of the unit costing items, as of the requirement date
   - Credit: under the cost element per Materials Management account determination, as of the consumption date

Result
The system records the overall costs viewed from consumption in the activity. In the component, the system records the costs per the unit costing line items. This enables you to reproduce the material component cost element split.

If there is an invoicing plan for the materials procured externally, the costs are distributed per the dates in the invoicing plan.
Creating Unit Costings in Networks

Prerequisites

You can only maintain a unit costing for material components which are managed in valuated project stock and are flagged as costing-relevant. You set the Costing relevant indicator in the material component detail data.

For the unit costing, you must maintain the appropriate costing variant for each object. You can store this costing variant as a default value in the costing variant used in the network.

Procedure

1. In network processing, access the activity/component detail screen.
2. Choose .
   The Create Costing with Template dialog box appears.
3. Specify a costing variant.
   The overhead calculation in material components is controlled by means of the costing variant.
4. If you want to work with templates, specify the template you want to use.
   – Base object
   – Unit costing for an activity
   – Simulation version in which the template is maintained
5. Choose .
   The Create Unit Costing screen appears.
6. Specify the items for the unit costing.
7. Save your input.
   The detail screen for the activity or component is displayed.
8. Choose the Determine costs function to carry out the network costing or save the network if the costs are determined automatically when you save.

   The planned costs from the unit costing are not updated in the activity until you carry out the network costing.
Asynchronous Network Costing

Use
You can use the asynchronous network costing to:

- Update the network costing
- Reproduce plan payment data in Project Cash Management
- Have the system value configurable materials per the configuration settings entered
- Refresh the purchase info record data for goods and services procured externally

You can run the asynchronous network costing for one or more networks at any time, regardless of the costing in network maintenance.

Prerequisites
The network must be activity assigned.

Project Cash Management must be active, so that the system can determine and update the payment data.

To have the system value the configurable materials in line with configuration, you must maintain an appropriate costing variant for the network.

Features
You can use the asynchronous network costing to calculate or update the plan values for several activity-assigned networks simultaneously. The system determines and updates the following values:

- All planned costs (similar to the network costing within network maintenance)
- Planned outgoing payments (if Project Cash Management is active)
- Costing for configurable materials in valuated project stock, per the configuration settings entered

If you have set the Read purchasing info records indicator, the system updates the purchasing data for externally processed activities and non-stock materials.

Overhead and process costs are also included as part of network maintenance.

💡

If errors messages occur during the network costing, the networks concerned are not updated.
Executing the Asynchronous Network Costing

Procedure

1. Choose Logistics or Accounting → Project System → Financials → Planning → Network Costing.
   
   The system may ask you to specify a controlling area and database profile.
   
   This brings you to the screen Asynchronous Network Costing: Planned Costs and Planned Payments.

2. Specify one or more projects, WBS elements, or networks.

3. Select the indicator Read purchasing info records if you want the system to read the current purchasing info records for external activities and non-stock material components and use the updated data for:
   
   - Planned costs
   - Planned payments
   - Invoicing plans with percentage partial billing

   !

   Note that reading the purchasing data can lead to significantly longer program run times.

4. Select the process control fields you require:
   
   You can run the network costing in the following ways:
   
   - Online or in background processing
   - As a test run or a live run
   - With a detailed list; the program then generates a list of all the networks included.

5. Choose 📌.

6. Depending on the settings you enter, the system displays a list or asks you to schedule a background processing job.

Result

The system carries out the following actions as part of network costing:

- Determines all planned costs (similar to the network costing within network maintenance)
- Determines and records the planned outgoing payments (if Project Cash Management is active)

   See Planned Payments Out from the Invoicing Plan [Ext.]

- Planned costs are updated in the valuated project stock as viewed from procurement and usage, as follows:
Executing the Asynchronous Network Costing

- If an invoicing plan has been maintained for the component, the costs are updated in the component in line with the time structure of the invoicing plan. The system considers all cost-relevant invoice plan items - that is, not down payments.

  The full credit takes places as of the component requirement date. The amount credited is the invoicing plan total.

  The planned costs are recorded in the externally processed activity, regardless of whether or not an invoicing plan has been maintained.

- If you have not maintained an invoicing plan, the system records the debit and credit in the component as of the date the component is required by the activity. Data is updated under the separate value types:

<table>
<thead>
<tr>
<th>Commercial Activity</th>
<th>Value Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Debit</td>
<td>KPPP</td>
</tr>
<tr>
<td>Credit</td>
<td>KPPE</td>
</tr>
</tbody>
</table>

From Release 4.6A, the planned costs are recorded automatically in the material component when the network costing is carried out.

- A two-level log is output.

  From here, choose Messages to access the relevant error message.

  Processing, the update, and error handling are on a network by network basis.

  For more information on settlement, read CO - Information [Ext].
Copying Planning

Use
With this function, you can have the system copy your plan and actual values into plan versions. For more information on the use of plan version, see Plan Versions [Ext.].

With this function, you can:

- Copy your manual planning from a past planning period to the current one or a future one
- Copy plan values between periods within a fiscal year
- Use the actual values from a past period or fiscal year as the basis for new planning

Prerequisites
You have maintained the appropriate plan versions in Customizing.

Features

Which data is copied?

- Your current plan, meaning:
  - The costs and revenues you have planned manually in WBS elements
  - The revenues calculated in WBS elements
  - The costs you have planned in networks, network activities, and material components
  - The costs you have planned in orders for projects
  - The statistical key figures in WBS elements, networks, and network activities
  - The transaction you use is called Copy Project Costing.
  
  You can evaluate and compare the plan values so copied in reporting.

- The costs and revenues you planned in WBS elements, along with your statistical key figures
  
  The transaction here is Copy WBS Plan to Plan.

  You can edit the plan values so copied in the relevant plan versions.

- The actual values in your WBS elements
  
  The transaction here is Copy WBS Actual to Plan.

  You can edit the actual values so copied in the relevant plan versions.

⚠️

If, for example, you delete a WBS element from your WBS, the system deletes the relevant plan values from all plan versions.

If you want to keep a permanent record of your project structure and the matching values at a particular point, copy your plan to a project version [Ext.] and not to a plan version. Any objects you delete from your operative project remain in the project version.
How is the data copied?

You can choose between individual and collective processing.

In individual processing, the system copies the plan values for one project to one plan version.

In collective processing, the system copies the plan values from a number of projects you have specified using a selection variant to a plan version. The full range of selection variant [Ext.] functions is available for this purpose.

You define the planning timeframe (period, fiscal year) and version from which the system copies the plan/actual values.

You define the planning timeframe (period, fiscal year) and version to which the system copies the plan/actual values.

You choose whether the system copies all plan data or only the data from selected planning forms.

You use the following indicators to regulate process control:

<table>
<thead>
<tr>
<th>Indicator</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Do not change</td>
<td>Select this indicator if you do not want the system to overwrite any data already in the target version.</td>
</tr>
<tr>
<td>Reset and overwrite</td>
<td>Select this indicator if you do not want the system to overwrite any data already in the target version. Remember to check the data in the target version first.</td>
</tr>
<tr>
<td>Background</td>
<td>If you want to copy a lot of planning work, we recommend you do so in background processing, scheduling the background job(s) for times when few people are using the system.</td>
</tr>
<tr>
<td>Test run</td>
<td>Select this indicator if you do not want to update any data. The system then generates a log, but does not change the data.</td>
</tr>
<tr>
<td>Detailed list</td>
<td>If you flag this indicator, the system generates a list showing all the data records copied and the planning activities you selected for copying.</td>
</tr>
</tbody>
</table>
Copying Plan and Actual Data in the WBS

Prerequisite
Plan versions are defined in customizing.

Procedure

1. Choose Logistics or Accounting → Project System → Financials → Planning → Copy Costs and Prices. Depending on your objective, choose one of the following:
   - To copy your manually planned costs and revenues within a version or to another version, choose Copy WBS Plan to Plan.
     The initial screen for copying planning appears.
   - To copy your actual values (costs and revenues) to a plan version or to copy them as plan values to a new planning period, choose Copy WBS Actual to Plan.
     The initial screen for copying actual values to the plan appears.
     
     With both of these transactions, you are copying your plan values in the WBS elements. Plan values calculated in networks and network activities are not copied.

2. Enter the relevant data on the initial screen and choose one of the following:
   - Reset and overwrite
     The system resets all the data in the target version for the planning activity in question and overwrites it with the plan data from the reference version.
   - Do not change
     The system checks whether the target version already contains plan data for the relevant degree of planning detail. If it does, the system does not overwrite that data.

     Select the process control fields you require:

     For more information on entering data in the initial screen and on process control, see Copying Planning [Page 81].

3. Choose .

Result
The system copies the plan values into a plan version in line with the settings you entered. You can further process the plan values copied. For example, you can compare a worst-case scenario with a best-case scenario.

When copying has been successfully completed, the system displays a list showing the number of data records copied.

If you flagged the detail list indicator, the system also generates a list showing all the data records copied and the planning activities you selected.
Example: Copying Plan Versions

There are two plan versions containing the following cost element plan values:

**Version 000:**

<table>
<thead>
<tr>
<th>Cost Element/Year</th>
<th>Plan Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>400000/1998</td>
<td>1 000</td>
</tr>
<tr>
<td>415000/1998</td>
<td>1 500</td>
</tr>
</tbody>
</table>

**Version 001:**

<table>
<thead>
<tr>
<th>Cost Element/Year</th>
<th>Plan Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>400000/1998</td>
<td>2 000</td>
</tr>
</tbody>
</table>

The system copies the plan values in version 000 to version 001. The *Do not change* indicator is selected.

The plan value in cost element 400000 remains unchanged because the *Do not change* indicator means that existing plan values cannot be overwritten.

The plan value in cost element 415000 is copied to version 001.

After copying, version 001 contains the following values:

**Version 001:**

<table>
<thead>
<tr>
<th>Cost Element/Year</th>
<th>Plan Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>400000/1998</td>
<td>2 000</td>
</tr>
<tr>
<td>415000/1998</td>
<td>1 500</td>
</tr>
</tbody>
</table>
Copy Project Costing

Prerequisites
Plan versions are defined in customizing.

Procedure
1. Choose Logistics or Accounting → Project System → Financials → Planning → Copy Costs and Revenues → Copy Project Costing (Indiv) or Copy Project Costing (Collective).
   The initial screen for copying planning appears.
2. Enter the relevant data and choose the relevant process control.
   For more information on entering data in the initial screen and on process control, see Copying Planning [Page 81].
3. Choose .

Result
The system copies the plan data from the template to the plan version. You can evaluate the plan version in reporting and compare it with other plan versions.
When copying has been successfully completed, the system displays a list showing the number of data records copied.
If you flagged the detail list indicator, the system also generates a list showing all the data records copied and the planning activities you selected.
Orders for Projects

Use

You can assign various types of orders to a WBS element provided the WBS element is an account assignment element.

The assignment means that the order is managed along with the project. The plan costs for the orders are recorded in the project in summarized form.

In the SAP System, you can use orders for different purposes. You can assign the following orders to a project:

- Internal orders
  Internal orders are used at the level of cost and service accounting - for example, to monitor costs

- Plant maintenance orders
  You use plant maintenance orders to plan plant-maintenance measures, and to enter and settle the resulting costs.

- Production orders
  Production orders are used in the manufacture of goods.

- Sales orders
  Sales orders are contractual agreements between a sales organization and a sold-to party concerning the supply of materials or the rendering of services at defined prices and times, and in defined quantities.
  You can assign sales order items or customer quotation items to a WBS element (billing element). If you do, revenue and cost controlling takes place wholly within the project. The quotation/order does not bear either costs or revenues.

In the following, the term “orders for the project” covers networks and activities too. You cannot enter a budget for orders for networks.
Plan Costs from Orders for Projects

**Use**
When you assign an order to a project, the system takes over the plan costs when you save them, and records them in the project.

**Prerequisite**
In Project System customizing, you define, for the various order types, how the plan costs for orders are recorded in projects.

**Features**
There are two options:

- **Appended**
- **Apportioned**

These two options are independent of each other. An order may be either of these, or both.

**Updating Appended Orders**
If the order is “appended”, the plan costs for the order increases the plan values in the project. They form the basis for determining the budget. This is a good idea, for example, if you are only planning in orders. The project plan is then the total of the order values.

**Updating Apportioned Orders**
The plan costs in an apportioned order increase the assigned values for the relevant WBS element. These values bind the budget until you close the order.

💡
Changes to the actual and commitment values in an apportioned order only lead to changes in the assigned values in the relevant WBS element if the total for actual costs and commitments in the order exceeds the value of the order requisition (order plan costs).

In the standard system, networks and orders are flagged as “apportioned”. For the planning phase, you can go to Project System customizing menu and switch off the “Funds assignments in plan” parameter for networks or orders. The order plan values do not then become part of the assigned values for the WBS element. If you release the order, the order plan values are recorded as funds commitments in the WBS element; the released order is automatically flagged as an appended order.

An exception is the case of the networks for preliminary planning. In Project System customizing, you stipulate which network types are used for preliminary planning. Such preliminary planning networks are never appended. The related plan values do not, therefore, increase the assigned value for the relevant WBS element.

You cannot enter a budget for orders for projects.
If you use active availability control, you must reconstruct the assigned values if you change how orders are updated. For more information, read the chapter on availability control [Ext.].

Displaying Plan Costs for Orders for Projects in the Cost Information System [Page 89]
Displaying Plan Costs for Orders for Projects in the Cost Information System

The table below illustrates how the costs for a WBS element are represented in the cost information system. The plan costs and assigned values for the WBS element change, depending on what you have entered in the Project System implementation guide. In the example, the WBS element already has a planned value of $100,000 and an assigned value of $30,000.

**Representation in the Cost Information System**

<table>
<thead>
<tr>
<th>Plan Value Order ($)</th>
<th>The order is:</th>
<th>Representation in Information System For plan and Assigned ($)</th>
</tr>
</thead>
<tbody>
<tr>
<td>20 000,- Appended</td>
<td></td>
<td>120 000,- 30 000,-</td>
</tr>
<tr>
<td>20 000,- Not appended</td>
<td></td>
<td>100 000,- 30 000,-</td>
</tr>
<tr>
<td>20 000,- Appended</td>
<td></td>
<td>120 000,- 50 000,-</td>
</tr>
<tr>
<td>20 000,- Not appended</td>
<td></td>
<td>100 000,- 50 000,-</td>
</tr>
</tbody>
</table>

The project summarization only takes account of plan costs in appended orders.
Plan Values from Customer Quotations and Sales Orders

Use

The values from a customer quotation item or sales order item are recorded in the relevant WBS element (billing element). The basis for this are the condition values and the revenue elements determined in the Sales and Distribution system. The period allocation is based on the billing plan or is derived from the delivery date for the item.

Prerequisite

In Project System customizing, you must activate automatic recording of planned revenues and, if required, planned payments from sales documents assigned to the project.

See Creating/Changing Plan Profiles [Ext.].

Features

Three types of values are recorded in the WBS element:

- Value of the quotation/sales order
- Revenue plan
- Payment plan

The quotation and sales order values are updated separately. The sales order value does not reduce the quotation value.

The revenue plan and payment plan values are generated by the quotation and updated by the sales order. To these are added the values for any revenue plan or financial budget values entered manually.

Characteristics of the Update Process

Actual values (invoices, down payments, payments) do not change the created values. The process is not part of commitment management.

The plan values for customer quotations and sales orders are managed separately. In the revenue/payment plan, a sales order item only reduces the plan values of the customer quotation item to which it relates, not those for all the customer quotation values in this WBS element.

Each change to the customer quotation/sales order leads to the plan values in the project being updated. If a customer quotation item/sales order item is canceled in the Sales and Distribution system, the matching values are usually reduced.

The process only takes account of the plan values for those conditions in the sales document for which an account was determined. You can see whether an account has been determined by displaying the Conditions screen in the customer quotation or sales order. Account determination takes place in Sales and Distribution only if the item is billing-relevant and the assigned billing type includes an account determination procedure.

In the case of customer quotations with alternative items, the system takes account of the most probable items. There is no weighted proportion calculation.
Plan Values from Customer Quotations and Sales Orders

For more information on sales orders and how to assign sales orders to a WBS element, refer to the document SD - Sales [Ext.].
Settling Orders for Projects

Use

You can settle an order for a project:

- Case 1: To the WBS element to which it is assigned
- Case 2: To a different WBS element or to a different order
- Case 3: To a different receiver (such as a cost center, asset, or profitability segment)

In the structure report, the order is displayed with its full costs, regardless of the type of settlement. The view for the relevant WBS element, however, shows the following differences:

- Case 1: The actual costs for the order are added to the WBS element as usual. The settlement is eliminated as internal business volume.
- Case 2: Only the costs not yet settled are displayed in the WBS element. The settled costs are displayed in the settlement receiver, and may be totaled up within the hierarchy.
- Case 3: The actual costs are totaled up as in case 1. The settlement is ignored.

The settlement logic for orders for projects provides that, when costs are settled, responsibility for them passes to the receiver. If you settle to a different object in the project hierarchy, the costs are reassigned from the sender to the receiver. The same logic applies to settlement between WBS elements. Elimination of internal business volume always takes place in the WBS element superior to the sender in the hierarchy.

For more information, refer to Hierarchy Structure and its Effects on the Values Displayed [Ext.].
Settling Orders for Projects

Order A1 is assigned to WBS element W1 and has settled $1000 to it. Order A1 is then moved to WBS element W2. The order incurs further costs of $2000, making $3000 in total. WBS element W2 (the superior element) shows only the portion not yet settled - that is, $2000. The original $1000 continues to be shown in WBS element W1.

See Project Settlement [Page 247]
Deleting and Archiving Orders

Use
With this function, the system deletes orders from the database and writes them to archive fields of an external storage medium. This reduces the load on the system, thereby improving system performance.

Features
If you set the deletion flag in an order for the project, the system continues to show the following data from the order in the higher-level WBS element:
- Planned costs, if the order is appended [Ext.]
- Actual costs
- Actual payments
Recording the order data in the higher-level WBS element ensures that the overall value for your project does not change.
If you undo the deletion flag in an order, the system removes the order data from the higher-level WBS element and the data appears in the order again.
Deleting and archiving orders has the following effects in the information system:

Commercial Reports
The commercial reports do not show the deleted order. However, the order data continues to appears in the higher-level WBS element.
The commercial reports do show the archived order and the order data if you:
- Set the Archive Data indicator in the database profile
- Set the Data from the Archive indicator in the initial screen for the report and enter the appropriate archive number

Structure Overview
The structure overview shows the deleted order. However, the costs for the order are not displayed in the order itself, but in the higher-level WBS element.
This only happens if make the following settings in Project System customizing:
- Choose Project System → Information System → Technical Project Reports → Define Profiles for Calling Overviews.
  The system displays the Enter Profile dialog box.
- Set the Structure Overview indicator and choose Execute.
  This brings you to the screen for changing settings in the overviews.
- Select your profile and choose 📅.
  The profile processing screen appears.
- Set the deleted objects indicator and save your settings by choosing 📁.
Deleting and Archiving Orders

The structure overview shows the archived order and the order data if you:

- Set the Archive Data indicator in the database profile
- Set the Data from the Archive indicator in the initial screen for the report and enter the appropriate archive number

Line Item Reports

The system shows the data for a deleted order in the totals records in the higher-level WBS element. If you delete an order, the line items for it are lost. As a results, the line item report does not show the order data in the higher-level WBS element.

For more information on deleting and archiving internal orders, see Archiving [Ext.]

See also: Archiving Operative Project Structures [Ext.].
Project Cost Forecast

Purpose

As a project is executed, variances occur between the original cost and process planning and the actual course of the project. Simply shifting activities within floats is enough to change the pattern of costs in the project. Once the first actual costs have been incurred, you will find it necessary to check and possibly update the figures for the remaining costs. This is the only way to preserve a base for a realistic cost forecast during the whole of a project’s life cycle.

The cost forecast is a process you can use to adapt cost planning to constantly changing circumstances. For the cost to complete, the system determines and values the remaining activities on the basis of the plan, forecast, and actual values in the network. The resulting figure is arrived at by adding the actual and commitment costs already incurred in the project to the updated cost to complete.

The values so determined are default values which act as the basis for your cost forecast.

You can carry out the cost forecast at any time for one or more projects. To this end, the system copies the updated costs to complete, along with the actual and commitment values, into a separate forecast version, which you can then evaluate in the information system. If required, you can manage more than one forecast version in parallel. The standard version is CO version 110 for the exclusive use of forecast costs.

Cost forecasts are normally performed as part of periodic processing. If you want to run the cost forecast at a particular time and/or in background processing, you can plan it as a job in the Schedule Manager. Use the Schedule Manager monitor to check the scheduled job both during and after processing.

For more information on the Schedule Manager, refer to Individual Functions in the Schedule Manager [Ext.].
Prerequisites
The system determines cost to complete only for activity-assigned networks which are both appended and apportioned. Preliminary planning networks are not included.
The activity is assigned to a WBS element.

Process Flow
1. Before accessing the cost forecast, you need to do the following:
   a. Reschedule
      No activity scheduling takes place in the cost forecast. You must reschedule first, so that the calculation of the cost to complete takes account of the changed dates.
   b. Calculate overhead on actual and commitment values
      You must calculate the overhead on actual and commitment values separately for the calculation of the estimated costs at completion. The system determines the planned overhead for the cost to complete as part of the cost forecast.
2. Choose Financials → Period-End Closing → Single Functions to access the cost forecast. You can run the cost forecast in individual or collective processing.
3. Based on planned, actual, and commitment values, the system determines the remaining costs in network activities. In doing this, the system includes:
   - All the actual and commitment values in the project
   - The plan values for network activities in CO version 0
   - Forecast values from confirmations
   It does not consider the following:
   - WBS element plan values
   - Network preliminary planning values
   - Plan costs for material components in valuated project stock (planned for a later release)
   The cost to complete cannot be determined for simulation versions.
4. Based on planned, actual, and commitment costs, the system determines what is still to be done in network activities and costs this again. The system records the value so determined as cost to complete, by period, in a forecast version for:
   - Internally processed activities
   - Externally processed activities
   - General costs activities
   - Material components not managed as part of project stock (whether valued or not)
   The values are normally determined as of the first day of the current period, as part of period-end closing. However, you have the option of specifying your own key date for the cost forecast. The system uses the key date to determine the cost distribution.
   Residual costs are determined in the same way as planned values are calculated. The basis for the residual cost calculation is the planned costing variant [Ext.] defined for the activity.
If an activity is marked as complete or there is a final confirmation for it, the system sets the cost to complete to zero.

See also:
- Residual Costs for Internally Processed Activities [Page 100]
- Residual Costs for Externally Processed Activities [Page 102]
- Residual Costs for General Costs Activities [Page 103]
- Residual Costs for Material Components [Page 104]

5. The system copies the cost to complete to the forecast version, along with the actual and commitment values for the project, which it reads from the database. Commitment values from periods before the period of the cost forecast key date are recorded in the forecast version as of the period of the key date (default: current period).

The standard system offers forecast version 110. Forecast versions are CO versions which can only be used to handle forecast costs. You can define additional forecast versions in the Project System IMG.

The graphic below shows which values the system updates in the forecast version.

![Diagram showing the update of values in the forecast version]

**Result**

The following forecast version values are available for evaluation in the Project Information System:

- Cost to complete
- Actual values at the time of the cost forecast
- Commitment values at the time of the cost forecast

You can use hierarchy reports and cost element reports to evaluate the data.

With the standard system, we deliver hierarchy report *Forecast 12CTC1* so that you can evaluate forecast values, the cost to complete, and the estimated costs at completion.
Costs to Complete for Internally Processed Activities

Prerequisites
The activity is assigned to a WBS element.
The activity must be flagged as “costing relevant”, using the control key.

Features
The updated residual costs (or "costs to complete") are calculated on the basis of the forecast work still in the internally processed activity, or the residual work in the cost forecast.
The system determines the costs to complete as follows:

The activity has not yet been confirmed (no actual dates).
- The planned start date is later than the key date in the cost forecast.
  The system recalculates the planned costs in the activity and records them as costs to complete in the forecast version. The estimated costs at completion are the same as the costs to complete.
- The planned start date is earlier than the key date in the cost forecast.
  The system uses the distribution key in the activity to distribute the planned work to the period between the key date in the cost forecast and the planned activity finish. The system recalculates the planned costs in the activity on the basis of the changed duration and records them as costs to complete in the forecast version, by period. The estimated costs at completion are the same as the costs to complete.
- The planned start and finish dates are earlier than the key date in the cost forecast.
  All of the planned work for the activity is valued in the period of the key date.

The activity is partially confirmed (actual costs exist).
When an activity is being confirmed, either you enter the forecast work manually or the system determines the remaining work (forecast work) based on the percentage of completion (POC). If there is no forecast work the system calculates the residual work by deducting the work actually performed from that planned. In addition, you can enter the forecast duration or finish in the confirmation.

The forecast work is distributed and valued in the activity per the distribution key, to the period between the actual date from the confirmation and the activity finish date. The finish date is determined in the following order:
1. Forecast finish from the confirmation, entered manually
2. Calculated forecast finish over the forecast duration
3. Planned finish
The activity is finished or a final confirmation has been entered for it.

The system sets activity costs to complete at zero. You do not expect any further costs in the activity. The estimated costs at completion are the same as the actual costs in the activity.
Costs to Complete for Externally Processed Activities

Prerequisites
The activity is assigned to a WBS element.
The activity must be flagged as “costing relevant”, using the control key.

Features
The updated residual costs (or "costs to complete") are calculated on the basis of planned costs in the externally processed activity.
The system determines the costs to complete as follows:

**There is no purchase requisition or purchase order.**
- The planned start date for the activity is later than the key date.
  
  The system recalculates the planned costs in the activity and records them as costs to complete, in line with the dates in the activity or from the invoicing plan in the forecast version. No actual or commitment costs have been recorded in the project up to now.

  The estimated costs at completion are the same as the costs to complete.

- The planned start date is earlier than the key date.
  
  The system recalculates the planned costs in the activity as of the key date and records them as costs to complete in the period of the key date.

  If the activity has an invoicing plan, cost are distributed as follows:

  - As of the key date, for dates earlier than the key date
  - In line with the dates from the invoicing plan, for dates after the key date

**A purchase requisition or purchase order has been created for the activity.**
The system sets costs to complete at zero. The system calculates the estimated costs at completion for the activity by adding the actual and commitment values.

💡

If there is a purchase requisition or purchase order for the activity, the system pays no regard to the dates from the invoicing plan when calculation the costs to complete.
Costs to Complete for General Costs Activities

Prerequisites

The activity is assigned to a WBS element.

The activity must be flagged as “costing relevant”, using the control key.

Features

The updated residual costs (or “costs to complete”) are calculated on the basis of planned costs in the general costs activity. The system records the value so determined, by period, in the forecast version. If there are no actual or commitment values, the estimated costs at completion are the same as the costs to complete.

The system determines the costs to complete as follows:

No actual costs have been posted for the activity

The planned costs are the same as the costs to complete. The system records the costs to complete as follows:

- The planned start date is later than the key date in the cost forecast.
  
The system records the costs to complete in line with the distribution key for the activity or the dates from the invoicing plan, beginning with the activity start date.

- The planned start date is earlier than the key date in the cost forecast.
  
The system uses the distribution key in the activity to distribute the planned work to the period between the key date in the cost forecast and the planned activity finish.
  
The system records the planned costs in the activity as of the key date period.
  
  If the activity has an invoicing plan, cost are distributed as follows:
  
  - As of the key date, for dates earlier than the key date
  
  - In line with the dates from the invoicing plan, for dates after the key date

- The planned start and finish dates are earlier than the key date in the cost forecast.
  
The planned costs for the activity are recorded in the period of the key date.

Actual costs have been posted for the activity

The system determines the costs to complete as the difference between the planned costs and actual costs and records them by period. The system uses the distribution key in the activity to distribute the overall value in the activity over the period between the key date in the cost forecast and the activity finish date.

Actual costs exceeding the planned costs have been posted to the activity.

The system sets costs to complete at zero. The estimated costs at completion are the same as the actual costs in the activity.
**Costs to Complete for Material Components**

**Prerequisites**

The material component is not managed as part of project stock because calculation of costs to complete for material components in project stock is not supported.

The costing relevance indicator must be set in the detail screen for the material component.

**Features**

The costs to complete in the cost forecast are determined on the basis of the resources (materials) planned for the material component.

The system determines the costs to complete as follows:

**Material component category N (non-stock material component)**

The system records the newly calculated planned, commitment, and actual values in the activity. The values are then included when the system determines the costs to complete for the activity. If a purchase requisition or purchase order has been entered in the system for the component, only the commitment and actual values from the component are included in the activity.

**Stock material component**

The following scenarios may apply in this case:

- There has been no partial issue for the component through the activity.
  
  The system recalculate...}

  If the requirement date for the component is earlier than the key date in the cost forecast, the component is valued and the costs to complete recorded as of the period for the key date.

- There has been a partial issue for the component through the activity.
  
  The system determines the open quantity in the component and values it. The open quantity is the difference between the planned quantity and the quantity in the partial issue. The system records the value so determined as costs to complete at the requirement date in the activity.
Executing the Cost Forecast

Prerequisites
Costing-relevant activities or material components have been planned.

Procedure
1. Choose Logistics or Accounting → Project System → Financials → Period-End Closing → Individual Functions → Cost Forecast.
   - Choose Individual Processing or Collective Processing.
   - The Cost Forecast screen appears.
2. If you are using individual processing, enter a project.
   - If you are using collective processing, enter a selection variant.
   - The standard system offers forecast version 110.
4. Select the process control fields you require:
   - The following options are available:
     - Background processing
     - Test run
     - Detailed list
     - Worklist
   - This field is only available in collective processing.
5. You usually run the cost forecast as part of period-end closing. The default for the key date is the first day of the current period.
   - The key date determines the cost distribution and the date for determining the open quantity for the material component.
   - To set your own key date, choose Set date.
   - The dialog box Cost Distribution from appears. Enter the appropriate date here.
6. Choose .

Result
The system determines the cost to complete and records it in the forecast version, by period, along with the actual costs and commitment values.

The system also outputs a two-level log:
- Basic list
  - This contains information on the selection and, if appropriate, references to possible errors during the cost forecast.
- Detailed list
Executing the Cost Forecast

For each object, this shows the forecast version values, cost element by cost element. You can jump directly from the log to the Project Information System.
Budget Management

Purpose

The budget is the approved cost limit for a project.

It differs from project cost planning due to its binding nature. Whereas the project costs need to be estimated as accurately as possible during the planning phase, the funds are predetermined as a budget in the approval phase. The budget is the limit set by management for project costs over a certain period of time.

Features

- **Original budget**
  The original budget is the budget that was allocated originally. From a time that you specify, this budget can only be corrected using budget updates.

- **Budget updates**
  Unforeseen events, extra jobs required, such as an increase in cost of external activity can meant that the original budget needs to be corrected, so budget updates are required. These are made in the following ways:
  - Supplements
  - Returns
  - Budget transfers

- **Current budget**
  The current budget is derived from:
  - Original budget
  - Supplements
Returns

Transfer postings

Current budget

- Returns

+/- Transfer postings

= Current budget

- Releases
In many enterprises, distribution of budget does not mean that the funds have been released. Therefore, in the project system there is a release function with which you can successively release budget. A release is based on the current budget, meaning the original budget that has been changed by supplements, returns, or transfer postings.

This section describes:

- Which prerequisites for budget allocation [Page 113] are required
- How you allocate original budget [Page 114] on a budget
- How you make budget updates [Page 131] in the form of supplements, returns, and transfer postings.
- How you release [Page 146] budget
Budget Management for Internal Orders

Use

The budget is the approved cost structure for an internal order or an order group.

In contrast to planning, budget management is binding. In the planning phase you need to estimate costs, whereas during the approval phase, funds are prescribed by the budget.

Features

The following different budget types exist:

- **Original Budget**
  This is the budget originally assigned, before any updates were made.

- **Budget Updates**
  Unforeseen events, additional requirements, for example, price rises for external activities, and so on. This may mean you need to update the original budget, in the form of:

- **Supplements**

- **Returns**

- **Current Budget**
  This is derived from the budget types already mentioned:

<table>
<thead>
<tr>
<th></th>
<th>Original budget</th>
<th>Supplements</th>
<th>Returns</th>
<th>Current budget</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Original budget</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>+ Supplements</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>- Returns</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>= Current budget</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The method for assigning and updating budget, and for configuring availability control for internal orders or order groups is similar to that for projects, except that projects are organized in a hierarchy.

For more information on budgeting, see: Budget Management [Page 107], and Availability Control [Page 167].

Investment programs enable you to manage and monitor budgets that cover more than one order.

You can find more information in the SAP Library, under Financials → Investment Management (IM) → Investment Management Overview [Ext.].
Budgeting in More Than One Currency

Use

Having multinational locations with different national currencies may mean that you need to use different currencies for budgeting. This can also be useful if your costs are incurred abroad by goods procurement in different currencies.

Features

Each budget line item is saved in the currency in which you entered it. The system also saves the amount in the controlling area object currencies if they differ from the first currency.

The system calculates each exchange rate using the exchange rate type and the value date. These are contained in the budget profile for the total values, and from plan version 0 for the annual values.

In the budget profile or the plan version, if the exchange rate type or the value date are different, the total and annual values may also have different exchange rates, and thus differ from each other.

The budgeting function helps you enter your budgeting data, but has limitations in the following areas:

- **Availability control and distributed value check within a project hierarchy**
  The system only does this in the controlling area currency.

- **Budget carryforward to the following fiscal year**
  The system only does this in the controlling area currency.

For each project profile or order type, you specify in the budget profile in which currency the budget is to be entered in.

- **Budgeting in the controlling area currency**
  The controlling area currency is the currency used for the controlling area. If you are using the controlling area currency for budgeting, you can only use this currency for entering the budget items.

- **Budgeting in the object currency**
  This is the currency used for the object (such as the WBS element), and is specified in the master data for the object (such as, WBS element). If you specify the object currency for budgeting, you can only enter the budget items using their respective object currencies.

- **Budgeting in any currency required**
  Being able to select any currency enables you to budget independently of the controlling area currency and object currencies. If you selected your own currency for budgeting, you can also choose the currency to be used for posting each budget line item. You can use as many currencies as required for budgeting.

The system valuates budget line items using the current exchange rate. If the exchange rate changes after the budget has been entered, this can cause significant
Budgeting in More Than One Currency

differences between budget values that were entered in different currencies. In particular, when you reduce the budget, this may result in values that are difficult to analyze and that are in currencies other than the controlling area currency.

For further information, see:

- Budget Supplements [Page 133]
- Budget Returns [Page 137]
- Budget Transfers [Page 141]

If you use more than one currency for budgeting, it may be more difficult to analyze the values displayed in the budget.
For more information on the values displayed in budgeting, see: Budget Value Display [Page 123]

If you use more than one currency for budgeting, then system checks are very important.
For more information on budget checks, see: Budget Checks [Page 126]

Activities

Scenario 1
You set a global controlling area, and want to monitor the budgets for all international subsidiaries. Your project managers run their national projects in the currency of that country. You should proceed as follows:

1. Use the object currency for budgeting
2. Define the object currencies of all WBS elements for a project depending on each national currency.
3. Assign the budget to the projects in their corresponding country currency. Your project managers then distribute the budget in the country currency within the project hierarchies.

Availability control takes place in the controlling area currency for all budget values, so you can check all budgets at any time.

Even if exchange rates change, the overall budget for the corporate group cannot be exceeded. However, the project managers can only use the budgets entered in the country currency as a guide. They should include exchange rate variances in their budget planning, as the system checks available budget in the controlling area currency.

Scenario 2
You have one controlling area for all countries with global projects and want to monitor the budgets in all of the international subsidiaries. You should proceed as follows:

1. Use the object currency for budgeting
2. Define the object currencies for the WBS elements in different currencies as required.
3. Assign the budget to the projects in the object currency of the top hierarchy node. Your project managers then distribute the budget in the project hierarchies.
There may be budget line items that have a different currency than the object currency when you make budget transfers, supplements and returns. For more information, see Budget Transfers [Page 141].

Availability control takes place in the controlling area currency so you can check all budgets at any time.

**Scenario 3**

You have a global controlling area with global projects. Costs are also incurred in more than one currency on each WBS element. You want to monitor the budgets for all of the international subsidiaries. You should proceed as follows:

1. Select your own currency for budgeting
2. The person responsible for the budget of a project, a subhierarchy, or a WBS element enters the budgets in the currency in which future expenditure is planned.

Availability control takes place in the controlling area currency so you can check all budgets at any time. The system ensures that the total of annual budgets for each currency does not exceed the total budget.

Even if exchange rates change, the overall budget for the corporate group cannot be exceeded. However, the project managers can only use the budgets entered in the country currency as a guide. They should include exchange rate variances in their budget planning, as the system checks available budget in the controlling area currency.

In the project hierarchy, the system checks the distributed values in the controlling area currency, not the individual currencies.

**Recommendations**

- Keep the exchange rates as stable as possible. In particular, you should not change the exchange rates while entering the original budget.

- Define special reports that account for the problems caused by different currencies. For more information, see: Report: Updating Budgets: [Page 145]

- Use as few currencies as possible, as the system often displays totals values in controlling area or object currencies only. You cannot make a direct comparison of budgets that have been entered in different currencies.
Budget Allocation Prerequisites

The following settings determine whether a budget can be allocated to a WBS element:

- **Budget profile in the project definition**
  
  You store a budget profile in the project definition. This profile contains the control parameters for budgeting. In Customizing specify the following under **Project System -> Costs -> Budget -> Specify Default Budget Profile For Project Definitions [Ext.]**:
  
  - The period of time during which budgeting is allowed
  - Whether budgeting is allowed for total annual values, and/or annual values

  The following are ways in which you can assign a budget profile to a project:
  
  - In Customizing under **Project System -> Costs -> Budget -> Maintain Budget Profile [Ext.]** as a default value
  
  - In the profile data of a standard project definition in the application under **Project System -> Basic Data -> Project -> Speical Maintenance Functions -> Work Breakdown Structure -Y Project Definition -> Create -> Control Tab Page -> Group Box for Accounting -> Budget Profile**.

  In the profile data of a project definition in Customizing, under **Project System -> Structures -> Operative Structures -> Work Breakdown Structure -> Create Project Profile. [Ext.]**

  - **Status**

  You can allocate budget after the status *Created* has been reached. If you want to prohibit budget allocation in the *Created* status, you need to define a user status.

  For more information on status management in the project system, and how to create a user status, see **Status Management [Ext.]**
Allocating Original Budget

Once the planning phase is over, a project is approved and budgeted by a decision-making committee, whereby an original budget is assigned to the project. The budget is distributed by the project manager using the top-down method to the individual WBS elements.

You can budget a project by:

- Transferring the values in the cost planning as budget, or
- Entering the budgets directly into the WBS elements.
Transferring Cost Planning Values As Budget

Prerequisites

The budget allocation for a project is generally preceded by cost planning, which is the basis for specifying and approving the budget. As the project system supported detailed planning of project costs, the planning values are transferred as budget for obvious reasons.

To do this, you need to create a project with a work breakdown structure, and execute cost planning.

For more information on creating a work breakdown structure, see the SAP Library under AC-Financials → PS Project System → Structures → Work Breakdown Structure (WBS) → Processing The Work Breakdown Structure [Ext.].

For more information on cost planning on a work breakdown structure, see the SAP Library, under AC-Financials → CO-Controlling → Internal Orders → Internal Order Planning → Manual Internal Order Planning → Manual Cost Planning On Work Breakdown Structures [Page 39].

Procedure

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change.
   The system may request you to set a controlling area. The following screen appears: Change Original Budget: Initial Screen.

2. Enter the required data and choose Original budget.
   The following screen appears: Change Original Budget: WBS Annual Overview.

3. Choose WBS Element overview.

   You can make entries and budget on the WBS elements that allow the budgeting business transaction.

4. Choose the timeframe during which you want to budget via Goto → Timeframe.

5. Choose the Plan Total in CO Area Currency view, via Views.

   The Version dialog box appears.

The Plan total consists of the following:

<table>
<thead>
<tr>
<th>Description</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value of the structure planning (independent of cost element)</td>
<td>= total planning value (independent of cost element) + value of cost element planning + value of unit costing</td>
</tr>
<tr>
<td>Value of cost element planning</td>
<td></td>
</tr>
<tr>
<td>Value of unit costing</td>
<td></td>
</tr>
<tr>
<td>Value of the additive orders for the project, so the orders that are assigned to this and all lower-level WBS elements.</td>
<td></td>
</tr>
</tbody>
</table>
### Transferring Cost Planning Values As Budget

<table>
<thead>
<tr>
<th>+</th>
<th>Value of the additive networks and network activities that are assigned to this and all lower-level WBS elements. (= Plan costs of the networks or activities)</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Plan total</td>
</tr>
</tbody>
</table>

5. Enter the version whose plan values you want to transfer

6. Choose *Continue.*
   The values in the selected plan version are displayed as a view

7. Select the WBS elements whose plan values you want to transfer as budget

8. Choose *Edit → Copy view.*
   If the corresponding budget currencies differ from the controlling area currency, the system translates the plan data in the controlling area currency into the budget currency.

- If you are budgeting in the object currency, the budget values for each object are displayed in its object currency. The object currency is always displayed on the screen behind the budget value.

- If you are budgeting in a freely selected budget, all budget values are displayed in the current currency.

   The *Copy view* dialog box is displayed.

9. Enter the percentage of the plan total and decide whether the value is to:

   - Overwrite the existing value
   - Be added to the existing value

11. Choose *Continue.*
    You transfer the plan totals of the selected WBS elements as budget values (taking the selected percentage). You can adapt the values by overwriting them.

12. Save your budgeting.
Manual Distribution of Budgets

Use
If you do not want to use planning values as budget values, you can enter the budget directly in the WBS elements.
Distribute the total budget (using the top-down method) to the individual elements in the work breakdown structure.

Procedure
Choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Original budget -> Change.
The Change Original Budget: Initial Screen appears.
Enter the necessary data and choose Original budget.
The Change Original Budget: WBS Annual Overview screen appears.
Choose WBS Element overview.

The Budgeting business transaction is allowed only on the WBS elements that are ready for input, and thus can be budgeted.
Distribute the available budget to the individual WBS elements.
If you want to display the time-based distribution to a WBS element, choose Annual values.
If you want to see the budget distribution to the various WBS elements in one year, choose Previous year and Next year.
If you want to call up the distribution for different years, choose Goto -> Timeframe.

Check your budgeting
For more information, see Check Budgeting [Page 126].

Check your budgeting.

Reassigning a WBS element (that has a budget) within the work breakdown structure is not supported.
System Status: Budgeted

After you have allocated a budget to an WBS element for the first time, the budgeted system status is set. The system status is retained if you take the budget back from the WBS element.

In the Budgeted system status, the following business transactions are forbidden:

- Deleting the WBS element
- Reassigning the WBS element and its lower-level objects.

You can set the deletion flag for WBS element that have the budgeted status.

The budgeted system status can be reset for WBS elements with the 0 budget by choosing Logistics or Accounting → Project System → Controlling budgeting → Tools → Reset 'budgeted' status.

The system resets the budgeted status if:

- The budget was taken back with the same business transaction with which it was originally allocated, and
- The selected WBS elements have the 0 budget.
Totaling up Budget Values

Use
Different people who are responsible, for example, for certain project areas or WBS elements, can budget for projects decentrally.

If budgeting is decentral (budgeting upwards or bottom-up), the person responsible for the overall budget requires an overview of the sectional budgets. They need to be totaled up, meaning that the budget values are in a hierarchy, and so that it is not possible for more budget to be distributed "below" than is available "above".

However, there may be more budget on a higher level than is distributed on the lower level.

Features
The Totaling up function provides you with an overview of the budget values that were actually distributed.

You can use this function at any time during budgeting.

Activities
Call up the function by choosing Accounting → Project system → Controlling → Budgeting → Original budget → Change → Original budget → WBS-Element overview → Edit → Total up.

You can select a particular timeframe, or you can total up total values.

The budget values of a project or a project area are totaled up. This means that they are totaled up for the higher level in the work breakdown structure and displayed there. At the same time, the system overwrites a budget value on a WBS element with the distributed value (roll-up), in other words, the total of the distributed budget values from the lower level.

A WBS element has a budget of USD 100,000. USD 50,000 and USD 25,000 of which are distributed to two WBS elements on the level below. If you trigger the totaling up function, the budget of USD 100,000 is overwritten by the distributed value of USD 75,000.
Reevaluating Budget Values

Use
You can reevaluate the budget values of a project or chosen, selected WBS elements. In other words, you can increase or decrease the values by a certain percentage or amount.

Procedure
1. Choose Accounting → Project system → Controlling → Budgeting → Original budget → Change → Original budget → WBS element overview. In the WBS element overview, select the WBS elements that have the budgets to be reevaluated.
2. Choose Edit → Revaluate.
The Revaluate dialog box appears.
3. Enter the percentage or amount by which you want to change the current budget. If you want to reduce the budget, enter " - " after the figure.
4. When you choose Continue, the system changes the values accordingly.
5. Save the budget values.
Entering Budget Texts

Use

You can enter short, explanatory texts and/or long, descriptive texts for a project budget, or for chosen and selected WBS elements.

Procedure

1. Choose Accounting → Project system → Controlling → Budgeting → Original budget → Change → Original budget.
2. In the WBS Element Overview or in the Annual Overview, choose Goto → Document text. The Text dialog box appears. The Document date field is defaulted with today's date.
3. You can store a short text in the Text field.
4. As an alternative or as a supplement, you can enter a long text. Enter a name for the text that you wish to store in the Long text field, and choose Continue. The system informs you that this text was not found.
5. Choose Continue.
   A dialog box appears, in which you are asked if you wish to create the text for the first time.
6. Choose Yes.
   The SAPscript Editor appears.
7. Enter the text.
8. Save your text.
   Choose Back to return to budgeting.

To change a long text, proceed as follows:

1. In the WBS Element Overview or in the Annual Overview, choose Document text. The Text dialog box appears.
2. Enter the text name in the Long text field, and choose Change long text. The SAPscript Editor appears, in which you can change the text.
3. Save your changes.

To find a long text, proceed as follows:

1. Place the cursor on the Long text field in the dialog box, and choose the F4 help. The Find standard texts dialog box appears.
2. Enter one or more search criteria.
3. Choose Proceed to start your text search. The system displays a list of texts found, from which you can make an appropriate selection.
Budget Value Display

Use
In addition to overall and annual budget values, you can see other budget values by choosing Views: If you are using different currencies for budgeting, the system displays the budget values in the currency of each view.

Features
Some values can be displayed only in the controlling area or object currencies.

- **Distributed Value**
  The total of the *current budget* (see below) for each lower-level WBS element. The *distributed values* can be displayed only in the controlling area or object currencies.

- **Distributable value**
  This is the difference between the *current budget* and *distributed value*. The *distributable values* can be displayed only in the controlling area or object currencies.

- **Assigned value**
  Total of commitment and actual postings. This can be displayed when availability control is active. The availability control checks new postings against the available budget regardless of the currency used to enter the budget items. The availability control checks in the controlling area currency, which is why the system displays the *assigned value* in the controlling area currency only.

- **Current Budget**
  Original budget that was changed by budget updates (supplements, returns, transfers). The *current budget* can be displayed only in the controlling area or object currencies.

- **Entered in transaction currency** (only for budgeting with freely chosen currencies)
  Total of the budget values entered in each currency. The system does not include amounts that were entered in a different currency. This view may only display some of the values from the *Current Budget* view.

- **Release**
  Based on the released budget from the current budget. The system checks releases using the controlling area currency. Therefore, you can display releases in the controlling area only.

- **Cumulated value**
  Total of the annual budgets. The system determines the cumulated value always using only the values in the currency that you are currently using for processing the budget.

- **Remaining value**
  Difference between *overall budget* and *cumulated*. The system determines the *remaining value* always using only the values in the currency that you are currently using for processing the budget.

- **Previous year**
  The system determines the values from the previous year always using only the values in the currency that you are currently using for processing the budget.

- **Plan total**
  The system always displays the *Plan total* in the controlling area currency.
The **Plan total** consists of the following

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Structure planning value (independent of cost element)</td>
</tr>
<tr>
<td>+</td>
<td>Cost element planning value</td>
</tr>
<tr>
<td>+</td>
<td>Unit costing value</td>
</tr>
<tr>
<td>+</td>
<td>Value of the additive orders for the project, meaning the orders assigned to this and all lower-level WBS elements. (( = ) Overall planning value that is cost element independent + Value of cost element planning + Unit costing values)</td>
</tr>
<tr>
<td>+</td>
<td>Value of the additive networks and network activities that are assigned to this and all lower-level WBS elements. (( = ) Plan costs of the networks or activities)</td>
</tr>
<tr>
<td>=</td>
<td><strong>Plan total</strong></td>
</tr>
</tbody>
</table>

Note that after budget updates are made by supplements, returns, and transfers, the displayed values (such as the distributed value) are always based on the current budget, not the original budget.

You specify the values displayed next to the budget value in the initial screen for budgeting by determining them in the budget profile, using the **View** parameter.

**Activities**

Choose **Settings -> Scaling factor** to select the currency units for displaying the budget values in 1, 10, 100, 1,000, 10,000, 100,000 or millions (**0** to **6) and to set the number of decimal places.
Copying Views

Use

In the WBS element overview and annual overview, you can choose Views to display different values as well as the budget values. You can transfer a percentage portion of the set view, or add it to existing budget values.

Procedure

1. Choose Accounting → Project System → Controlling → Budgeting → Original budget → Change → Original budget → WBS element overview.

2. Use Views to choose the view that you want to transfer as budget, or add to existing budget values.

3. Select the WBS elements that you want to copy to the selected view.

4. Choose Edit → Copy view.
   The Copy view dialog box appears.

5. Enter the percentage of the set view and decide whether this value is to:
   - Overwrite the existing value, or
   - Be added to the existing value.

6. Choose Continue.
   For the selected WBS elements, the values from the set view (taking the selected percentage into account) are transferred as budget values, or added to existing budgets.
   You can adapt the values by overwriting them.

7. Save your budgeting.
Checking Budgeting

Use
After budget has been distributed, you can check your budgeting for the total or annual values. This check is made when you save the budget.

Features
The system checks the following budget values:

- In the project structure, the system checks whether the budget values from a lower-level of the WBS element (assigned-values) exceed the budget value of the next level up. As this check is made in the controlling area currency, the system also includes budget that was entered in different currencies.

  !

  The system also checks the assigned values in the controlling area currency even if you chose your own currencies for budgeting.

- For each WBS element, the system ensures that the total of the annual budgets does not exceed the overall budget, if budgeting total values is planned (The Total values indicator is set in the budget profile). This check is made in the controlling area currency so that the system can also include the budget values that were entered in another currency.

  !

  Even if the total values and annual values match up in a freely selected currency, the values in the controlling area currency can vary from each other if the exchange rate type or the value date for the total values and the annual values differ.

- In active availability control, the system also checks whether the assigned values exceed the overall or annual budget. This check is made in the controlling area currency, so that the system can include budget values that were entered in a different currency. The budget used for comparison depends on the settings made in the availability control in the budget profile.

  For more information, see Availability Control [Page 167].

If errors occur, the following happens:

- In the overview screen and the annual view, the system selects the budgeted elements in the WBS that contain errors.

- The system issues an error log that you can print out. This log displays the budgeted WBS elements that contain errors, compared with the Budget and assigned values. In active availability control, the log contains the warnings or error messages that were issued due to any excesses of the tolerance limit. You can call up an explanatory text by choosing Long text or by double-clicking on a row in the log.

Activities
Check your budgeting by choosing 🛠️.
Checking Budgeting

Correct your budget allocation if necessary, by processing the corresponding budget values as follows:

1. Overwrite or select, delete and re-enter
2. Re-check and
3. Save.
**Saving Without Checks**

You can save budgeting without checks, providing you have not yet activated availability control for your project.

This is particularly useful if you want to save a budget allocation in the system that has not yet been approved by a decision-making committee. As soon as you activate availability control, it is no longer possible to save without checks.

For more information on availability control, see [Availability Control](Page 167).
Distributing Annual Budgets

You can plan the years that are likely to be needed to realize a project either before or after the distribution of the overall budget.

1. Choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Original budget -> Change.
   The Change Original Budget: Initial Screen appears.
2. Enter the necessary data and choose Continue or Original budget.
3. Choose the WBS Element overview.
5. Place the cursor on the WBS element where you want to distribute annual budgets.
6. To call up the annual overview, choose Years.
7. The Change Original Budget: Annual Overview screen appears. The system displays the overall budget (if any) on the WBS element, and the fields ready for input for the annual values.

Alternative procedure:
Instead of specifying the annual values for a certain WBS element using the annual overview, you can also budget all WBS elements for a certain year.

1. Choose Goto -> Annual values to call up the element overview for the start year with the fields ready for input for the budget values.
2. Choose Goto -> Timeframe -> Timeframe to call up the Timeframe dialog box, with the entry field Year, which contains the start year.
   You can now choose a this timeframe or overwrite the year entry to choose another timeframe.
3. If you choose Continue then the system displays the element overview for the selected timeframe, with the fields ready for input in the WBS elements.
4. Enter your annual budget for the selected WBS element.
5. Use this method to budget for all WBS elements in the project.
6. Check your budgeting and save the budget values.

The Copy view, revaluate, and Total up functions are also available for budgeting annual values.
Displaying Budget Line Items

Each change that you save in budgeting is documented as a line item by the system.

Procedure

To display the budget line items for a WBS element, choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Original budget -> Change.

The Change Original Budget: Initial Screen appears.

Enter the necessary data and choose Continue or Original budget.

Choose the WBS Element overview.

The Change Budget: WBS Element Overview screen appears.

Choose Extras -> Line item.

If you are using more than one currency for budgeting, the system displays all of the line items for the required WBS element. This is independent of the currency that you are currently using for the budget.

You can prohibit line item writing for changes to the original budget by means of a user status, although the system continues to write line items for budget updates.

You can create short texts and/or long texts for budget line items.

Line items are identified by a unique number. You need to specify intervals (number ranges) for this in Customizing for the Project System.

For more information, see the implementation guide (IMG) under Project System -> Costs -> Budget -> Create Number Ranges for Budgeting [Ext].
Budget Updates

Unforeseen events, additional requirements, price rises for external activities, and so on may mean you need to update the original budget.

There are three types of budget update:

Supplements
Returns
Transfers

You can also update the budget using the change function in the budget. The system logs the changes as line items.

The time to “freeze” a budget as an original budget, and to update it with supplements, returns and transfers depends on when you want to log data origins, in other words the sender-receiver relationships for the updates. You therefore use budget updates to prove where supplements, returns and transfers originated, and where they are to be used. You do this using status management.

For example, the Budgeting business transaction is allowed in the Created status. You create a user status in the status profile. This prohibits the Budgeting business transaction, but allows the Budget supplement, Budget return, and Budget transfer business transactions. When you have specified the original budget, you set the user status so that the budget can only be updated using supplements, returns, or transfers.

For more information on status management, see the SAP Library under Accounting → PS-Project System → Structures → Status Management [Ext].

If availability control is activated for a project, then each update is checked. For more information, see: Availability Control [Page 167].

The current budget is calculated as follows:

<table>
<thead>
<tr>
<th>The current budget is calculated as follows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Original budget</td>
</tr>
<tr>
<td>+ Supplements</td>
</tr>
<tr>
<td>- Returns</td>
</tr>
<tr>
<td>+/- Transfers</td>
</tr>
<tr>
<td>= Current budget</td>
</tr>
</tbody>
</table>

The current budget is calculated as follows:
Budget Supplement

Use

If the funds provided are not sufficient, the Project System enables you to use budget supplements, which can be used on the project.

Features

There are two types of supplement:

In The Project

You make a supplement in the project from the top-down, from a higher level WBS element to the one below. You can supplement only as much budget on a WBS element, as is contained in the higher level.

The amount of budget left depends on the distributable or available values. The available value is the difference between distributable and assigned values. The system determines these values in the controlling area currency, and includes budget line items that were entered in different currencies.

To The Project

By making a supplement to a project, you make particular supplements, meaning that you provide a selected WBS element with additional external budget. This is independent of the remaining budget on the higher level. The system updates the supplemented budget on the WBS “upwardly”.

If you use more than one currency for budgeting, the system always translates a supplement with the current exchange rate into the controlling area currency or object currency. If the exchange rate for the supplement is different from what it was when you entered the original budget, the new total budget was translated using an average rate.

💡

Budgeting in the object currency with projects whose WBS elements have different object currencies may mean that there are budget line items on WBS elements in currencies that differ from the object currency.

For more information, see Budget Transfers [Page 141].

You cannot supplement budget in all project statuses. The project or the WBS elements for which budget is to be supplemented need to have a status that allows the Budget supplement business transaction.

See also:

Making Budget Supplements in Projects [Page 134]
Making Budget Supplements to Projects [Page 135]
Making Budget Supplements in Projects

Use
You make a supplement in a project in the same way as manual budget allocation: The values are entered and displayed hierarchically on the WBS. You can allocate supplements to the total budget and/or to individual annual budgets. The order in which you do this is not important, similar to budget allocation.

Procedure
To supplement budget in the project, proceed as follows:

Choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Supplement -> Change.
The Change Supplement: Initial Screen appears.
Enter the necessary data and choose Supplement.
Choose WBS Element overview.
The Change Supplement: WBS Element Overview screen appears.
Enter the corresponding data.

💡
Only the WBS elements where the Budget supplement business transaction is allowed are ready for input.

To select the timeframe for which you want to allocate a supplement, choose Annual values -> Previous or Next.
Allocate the supplements then choose Continue.
The system displays the updated view as well as the supplements, for example, the Distributed value.
Totaling up, adjustment, and other functions in budget allocation, are available for supplements in the project.

Save your supplements.
Making Budget Supplements to Projects

Procedure

To make a budget supplement to a project, proceed as follows:

Choose Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Supplement -> To project.

The Post Supplement: Initial Screen appears.

In the initial screen, enter the required issue date for the original document in the document date field. The system defaults today's date, but you can overwrite this if required.

If you want to enter a lot of similar items, you can enter default values (listed below) in the Template field group for the supplement items that you want to enter afterwards:

- **Receiver year**
  The Receiver year is the year in which the receiver object receives additional budget. To enter budget supplements in different years, leave this field empty.

- **Total values too**
  If you select this indicator, the system changes the total budget for the receiver to the same extent as the annual values. To supplement total values only, select this indicator and leave the Receiver year field empty.

- **Text**
  You can enter a short text in this field to describe the supplement.

- **Long text**
  You can enter the name of a standard text describing the supplement in this field.
  
  You can search for an existing text using the F4 help.
  
  The Find standard texts dialog box appears. You can enter the search criteria for a text search here.
  
  If you want to create a long text, enter a description and choose Execute.
  
  The system displays a message that the text cannot be located.
  
  Choose Continue.
  
  A dialog box appears, in which you are asked if you wish to create the text. Once you have confirmed this, go to the editor for standard texts.

If required, enter short text.

Choose Continue.

The Post Supplements: List Screen appears.

Allocate the supplements by entering the receiver WBS element and the amount. If the template does not specify it, select the year and if required, the option to include total values.

The following functions are provided under Supplement:

- **Hold**
  You can use this function to save entered items before an interruption in your work for example. The entry rows that are put on hold appear automatically when you restart the function, providing they are not posted.

- **Check**
  You can use the checking function before posting to determine whether the entered items contain any errors. The system selects any rows containing errors, and you can display a list of these
errors by choosing Extras -> Display error log. To print out the error log, choose Extras -> Print error log.

Post
The supplement items that you entered are posted. Any rows containing errors found by the system are not posted. These are selected and displayed in the error log. If posting is completed successfully, the system deletes any backups that you made using the Hold function.
Budget Returns

Use

You can return any surplus funds that you have.

Features

There are two types of budget return:

In The Project

*Returns in the project* are made from the bottom-up from a lower-level WBS element to the next one up. You can only return budget that is distributable or available. The system determines the amount of distributable or available budget in the controlling area currency, including budget line items that were entered in different currencies.

From The Project

You submit distributable or available budget on a WBS element from the project. The system updates the returns within the project, meaning that the total budget is reduced accordingly.

⚠️

Budgeting in the object currency with projects whose WBS elements have different object currencies may mean that there are budget line items in currencies that differ from each object currency. For more information, see Budget Transfers [Page 141].

Each return is translated into the controlling area or object currency using its current exchange rate.

A budget of 1000.00 USD translated into the controlling area currency is returned.

<table>
<thead>
<tr>
<th>Object Currency</th>
<th>Exchange Rate</th>
<th>Controlling Area Currency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Budget</td>
<td>2000 EUR</td>
<td>1,- $ = 2 EUR</td>
</tr>
<tr>
<td>Budget is Reduced</td>
<td>-2200 EUR</td>
<td>↓ Change 1,- $ = 2.20 EUR</td>
</tr>
<tr>
<td>Resulting Current Budget</td>
<td>-200 EUR</td>
<td>↑ Negative budget</td>
</tr>
</tbody>
</table>

If the exchange rate for the return is higher than it was when the original budget was entered, then the budget has a negative value in the object currency.
### Budget Returns

| Current Budget | 2000 EUR | 1, $ ≡ 2 EUR | 1000, - $ |
| Budget is Reduced | -1500 EUR | ↓ Change | 1, $ ≡ 1.50 EUR | -1000, - $ |
| Resulting Current Budget | 500 EUR | | 0 $ |

If the exchange rate for the return is higher than it was when the original budget was entered, then the budget has a negative value in the object currency.

You cannot return budget in all project statuses. The project or the WBS elements for which budget is to be returned need to have a status that allows the *Budget return* business transaction.

**See also:**

- [Budget Returns in Projects](Page 139)
- [Budget Returns from Projects](Page 140)
Making Budget Returns in Projects

Use

You make a return in a project in the same way as manual budget allocation: The values are entered and displayed hierarchically on the WBS.

You can return total budget and/or individual annual budgets. The order in which you do this is not important, similar to budget allocation.

Procedure

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Return → In project.
2. Enter the necessary data and choose Return.
   The Change Return: Annual Overview appears.
3. If you want information on the distributable budget of the sender before entering the amount, then leave the Amount column empty, and choose ☑.
   In the amount column, the system displays all the distributable budget of the sender for all items previously entered.

See also:
Making Budget Supplements in Projects [Page 134]
Making Budget Returns From Projects

Use

The method of returning budget from the project corresponds to the method for making a supplement to a project.

Procedure

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Return → From project. The Post Returns: Initial Screen appears, in which you can enter default values for more than one similar return.
2. Enter data as required.
3. If required, choose Settings → Double-line entry to create an entry with two rows.

   ![Double-line entry](image)

   The system displays single-line entry, which you use to initially only enter the Sender WBS element and the returned amount for each return item. The other fields contain default values (Sender year, Total values too, Short text and Long text). Therefore you need to specify default values for single-line entry.

   ![Single-line entry](image)

   To enter individual sender WBS elements, and/or years, then choose double-line entry.
4. The Post Return: List Screen appears.
5. For information on the distributable budget of the sender, leave the Amount column empty, and choose ✅.

   In the amount column, the system displays all the distributable budget of the sender for all items previously entered.

See also:

Making Budget Returns to Projects [Page 135]
Budget Transfer Posting

Use
In an area of responsibility, budget run low on a project, while on another project there is still sufficient budget. You can use transfer postings to provide a project with available budget from another project.

Prerequisites
The currency for a transfer posting must be allowed on both of the WBS elements involved. The WBS elements can belong to different projects or to the same one.

Features
You can differentiate between the following:

- Transfer postings between different WBS elements in the same timeframe. Sender and receiver WBS element must not belong to the same hierarchy branch.
- Transfer postings between different timeframes for the same WBS element (also advances or carryforwards)
- Transfer postings between different WBS elements from different years.

You cannot make transfer postings in every project status. The WBS elements involved must have a status that allows the business transaction Budget transfer posting. There are three business transactions in transfer postings:

- Budget transfer posting - Receiver
  The WBS element that has a status which allows this business transaction can receive in a transfer posting.

- Budget transfer posting - Sender
  The WBS element that has a status which allows this business transaction can send in a transfer posting.

- Budget transfer posting - Transfer
  The WBS element that has a status which allows this business transaction can send and receive budget in a transfer posting.

A transfer posting has the same procedure as a supplement to a project or a return from a project except that you specify a sender and receiver WBS element, or year.

Transfer postings between objects on lower hierarchy levels are also made by the system on the objects in the higher hierarchy levels.

⚠️

During budgeting in the object currency, the following problems may occur during a transfer posting:

The system only regards budget line items in each object currency as the entered budget. Transfer postings that were made in other currencies are therefore not displayed on objects in higher hierarchy levels as entered values.
The system regards all budget line items as *current budget*.

To display the budget line items for a WBS element, choose *Logistics* → or *Accounting* → *Project system* → *Controlling* → *Budgeting* → *Original budget* → *Change*.  
The following screen appears: *Change Original Budget: Initial Screen*.  
Enter the required data, and choose *Continue* or *Original budget*.  
Choose the WBS element overview.  
The following screen appears: *Change Budget: WBS Element Overview*.  
Choose *Extras* → *Line items*.  

You have entered the following budget values on a work breakdown structure with two hierarchy branches, and five objects with different object currencies.  

Now you make a transfer posting between two WBS elements on the lowest hierarchy level: 100 $ from *WBS element 1.1.1* to *WBS element 1.2.1*. The current budget is now as follows on the work breakdown structure:  

*WBS elements 1.1 and 1.2* have EUR as their object currency. The transferred 100 $ is displayed in the line item report. The entered value of the *WBS element 1.1* however, is still 2000 EUR and *WBS element 1.2* is 100 EUR, as the system only includes the budget line items that were entered in EUR.
Activities

To transfer budget, choose Logistics or Accounting → Project system → Controlling → Budgeting → Transfer posting.

In the following initial screen: Transfer Budget: Initial Screen, you can enter a sender and receiver year as a default value for numerous, similar transfer postings. You can also specify whether the total values should be included in the sender WBS element.

Under Settings you can choose Double-row entry to switch from single to double row entry. The default is single row entry, which you can initially use to make entries in the WBS element sender and receiver fields, and to enter the amount and currency of the transfer posting for each transfer item. The other fields Sender year, Include total value, Text and Long text contain default entries. Therefore, you need to specify default values for single row entry.
If you want to enter individual sender WBS elements and / or years for each transfer item, then choose double-row entry.

Note that the sender and receiver year are two subsequent years.
Run **Budget Update Reports**

**Procedure**

To display totals records for supplements, returns and transfers for projects, proceed as follows:

Choose *Logistics or Accounting -> Project System -> Information System -> Controlling -> Costs -> Budget related -> Budget updates*

To display the budget line items for a WBS element, choose *Logistics or Accounting -> Project System -> Controlling -> Budgeting -> Original budget -> Change.*

The *Selection: Budget Updates* screen appears.

Enter a project and choose *Execute.*
You can go from the totals records to the line item display, and call up a document chain that displays the sender-receiver relationship for each budget update.

⚠️

The system displays the totals records for the budget values in the controlling area currency only.

**Recommendation**

If you use more than one currency for budgeting, and require the budget values in the report to be in each currency, then define corresponding reports.

Alternatively, the line item report is available.
Releasing The Budget

Use

In many companies, distributing the budget is not the same as releasing funds. Therefore the Project System enables you to release the budget successively.

You can release budget on a total or an annual level (providing budgeting using total or annual values is included in the budget profile).

Prerequisites

The release is based on the current budget, meaning the original budget changed by supplements, returns, or transfers.

Activities

Releasing The Budget

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Release → Change.
   The Change Release: Initial Screen appears.

2. Enter the necessary data and choose Release.
   The Change Release: Annual Overview screen appears.

   You can release the budget for a project or for an individual WBS element. Enter the corresponding WBS element.

3. Choose WBS Element overview.
   The Change Release: WBS Element Overview screen appears.

   The Budget business transaction is allowed only on the WBS elements that are ready for input, and thus can be released.

4. Choose the timeframe that you want to release by choosing Goto → Timeframe.

5. Choose Views to select the Plan total in COAr Currency view.
   The Version dialog box appears.

6. Enter the version that contains the plan values you want to use as the budget.

7. Choose Continue.
   The system displays the values in the selected plan version as a view.

8. Select the WBS elements that contain the plan values you want to use as the budget.

9. Choose Edit -> Copy view
   If the current budget currency differs from the controlling area currency, the system translates the planning data from the controlling area currency to the budget currency.
Releasing The Budget

- If you use the object currency for budgeting, the system displays the budget values for each object in its own object currency. The system displays the object currency on the screen after the budget value.
- If you chose your own currency for budgeting, the system displays all the budget values in the current currency. The Copy view dialog box appears.

10. Enter the percentage of the plan total and decide whether the value is to
- Overwrite the existing value
- Be added to the existing value

13. Choose Continue.
   You transfer the plan totals for the selected WBS elements as budget values, taking into account the selected percentage. You can adapt the values by overwriting.

14. Save your release.

Check Release

You can check the release at any time by choosing Release -> Check. The system automatically checks the budget release when you save it.

💡 Providing the availability control is **not active** you can save a budget release **without** checking it.
- If availability control is **active** this is no longer possible. The system then only allows you to save a budget release that does not contain any errors.

Checked Values

- **Project structure**
   In the project structure the system checks whether the releases in a lower-level of the WBS element (**Distributed values**) exceed those in the level above. The system uses controlling area currency for the check, and includes budget line items that were entered in different currencies.

- **Time level**
   For each WBS element, the system checks whether the total of the annual releases (cumulated releases) exceeds the total release. This check is made using the current currency. The system does **not** include budget line items that were entered in a different currency.

- **Releasing the current budget**
   The system checks whether
   - The total release exceeds the current total budget
   - The annual releases exceed the current annual budget
   The system uses controlling area currency for the check, and includes budget line items that were entered in different currencies.
Availability control is active
In Customizing under Project System → Costs → Budget → Maintain Budget Profile [Ext.], you can make settings to determine whether the system checks availability for overall budgets, annual budgets, overall releases, or annual releases. If availability control is active, the system also checks the following:

Availability control for overall releases
If this is active, the system checks whether the Assigned values (= actual + commitment) exceed the overall release.

Availability control for annual releases
If this is active, the system checks whether the Assigned values on an annual level exceed the annual release.

The system uses controlling area currency for the check, and includes budget line items that were entered in different currencies.

For more information on availability control, see: Activating Availability Control [Page 178].
Budget Carryforward

Use

The budget carryforward enables you to carry forward budget remainders from projects, internal orders, and plant maintenance orders to the following fiscal year. A budget that has not been used up is mainly defined here as the difference between planned budget and incurred actual costs. Budget carried forward to the following year can also be posted to the previous year in certain circumstances.

Prerequisites

Commitments are not taken into account when the unused budget is calculated. Therefore you need to carry forward commitment before you do so for the budget. To call up commitment carryforward, choose Accounting → Controlling → Internal orders → Year-end closing → Commitment carryforward, or Logistics or Accounting → Project system → Controlling → Year-end closing → Commitment carryforward.

Features

If required, you can carry budget forward at year-end closing. It is generally useful to carry forward budget by project, project interval, or internal order interval. If you do so by internal orders, you require a selection variant. You use this to specify which internal orders are to be selected, and to be included in the carryforward run. You may need to maintain the selection variant before carrying forward budget. You do this in Customizing, under Controlling → Internal Orders → Order Master Data → Selection and Collective Processing → Define Selection Variant [Ext.].

You can carry forward budget more than once in a row. Each time, budgets are carried forward that were not included in the previous runs, because the corresponding internal orders or WBS elements were locked, for example. If you make follow-up postings of actual costs, the system posts back budget that was carried forward to the following year (a maximum of the total budget carried forward to the following year).

Budget carryforward is only allowed if the object (WBS element/internal order) has been Created, Released, or Technically completed. Budget carryforward is not possible for Closed objects, or those that have a deletion indicator or deletion flag. Nor can you carry forward negative budget into the following year.

You can start the budget carryforward as a test run or update run.

If you want to check the budgets carried forward, you can choose the detail list and display it.

There is no availability control during the budget carryforward.

Budget is always carried forward in the controlling area currency, meaning that budget line items entered in a different currency are also carried forward.

Activities

To call up budget carryforward, choose Accounting → Controlling → Internal orders → Year-end closing → Budget carryforward in Controlling.
In the Project System, you call up budget carryforward by choosing Logistics or Accounting
Project system → Controlling → Year-end closing → Budget carryforward.
Request For Budget Increase In The Intranet

Use
You want to apply for a budget increase for an order, network, network activity, or a WBS element.
You do not know who approves this operation.

Features
There are two different scenarios:

- **Request for budget increase** (scenario SR61)
  The form is sent to a processor, who changes the budget and executes the budget transactions in the R/3 System.

- **Request for budget with approval** (scenario SR62)
  The form is sent to an approving manager, who is determined as follows:
  
  - If you enter an approving manager, then they receive a message.
  
  - Otherwise, the budget manager or WBS manager stored in Customizing receives the message.
  
  - If you did not enter an approving manager and do not have any budget or WBS manager in Customizing, then the role determines the approving manager.

  The manager approves the request. The request processor receives a message via the role determined in Customizing, and via workflow.

For more information on Customizing scenarios, see the implementation guide (IMG) under Cross-Application Components → Internet / Intranet Services → Internal Service Request → Definition of Scenarios → Define Scenarios [Ext.] or in the SAP-Library under Cross-Application Components → Internal Service Request [Ext.].
Form for the budget increase request without approval

The form for the request that requires approval is different in that the Processed by field is replaced by the Approved by field.

Activities

You (the person entering the request) call up the internal service request [Ext.] from the LaunchPad in the mySAP.com Workplace via Create internal service request.
Jeanette, what can I do for you?

Initiated by

My request

Request or problem

Delete Status Solutions

Initial screen for an internal service request

You select the form *Request for budget increase*.

You (the person entering or initiating the request) enter an object, the required budget increase, and the required currency in the form.

The system determines the approving manager or the processor of the notification as required.

The request is forwarded to the approving manager or the processor.

The applicant often specifies the object to which they want to post costs to be included in the active availability control. Examples of this are plan data, actual costs or commitments.

The object that actually carries budget (and may be different than the specified object) may be unknown or not of interest to the applicant.

*See also:*

[Special Fields In The Form](Page 154)
**Special Fields In The Form**

The form for the request with approval differs in that the Processed by field is replaced with the Approved by field.

**Budget User**
- Can always be changed by person entering request
- The object is always entered manually
- Possible entries:
  - Order
  - WBS element
  - Network
  - Network activity

💡 You can apply for one object budget increase in one request.

**Budget Object**
- Not changeable
- The system provides the budget carrying object for the budget user
- Options:
Request For Budget Increase In The Intranet

- WBS element and WBS element number
- Order and order number

- Always changeable by the person making the entry
- Is specified by the system using standard role
- If no standard role was stored, then the budget manager is the processor.

Amount

- Always changeable by the person making the entry

Currency

- Changeable if contains no entry
- Currency determination
  - No entry
    - The system chooses the budget currency from the budget object.
    
    If the budget currency is the group currency or the object currency, then this currency is the only currency that can be freely selected for the amount.
  - Entry made by the person entering the request
- Budgeting currency = Group or object currency
  - If the budget currency is the group currency or the object currency, then the system issues an error message if you enter a different currency, and the system provides the correct currency.
- Budgeting currency = Freely selectable transaction currency
  - The currency entered is accepted.

The system determines the budgeting currency using the Customizing settings

- For internal orders under Accounting → Controlling → Internal Orders → Budgeting and Availability Control → Maintain Budget Profiles [Ext.]
- For projects under Project System → Costs → Budget → Maintain Budget Profiles [Ext.]

Approved by

- Always changeable
- The approving manager is determined as follows:
  - The person entering the data enters the name of an approving manager. This entry is prioritized over the settings in Customizing.
  - If an approving manager's name is not entered, the system uses the Customizing settings to determine someone for approval.

- For internal orders under Accounting → Controlling → Internal Orders → Budgeting and Availability Control → Maintain Budget Manager. [Ext.]
- **For projects** under *Project System → Structures → Operative Structures → Work Breakdown Structure → Create WBS Element Manager [Ext.]*.  
  - If you did not store a budget or project manager in Customizing, and the person entering the data does not specify anyone, then the system creates an approving manager using the roles stored in scenario Customizing. For more information on customizing scenarios, see the implementation guide (IMG), under *Cross-Application Components → Internet / Intranet Services → Internal Service Request → Definition of Scenarios → Define Scenarios [Ext.]*.

**Remarks**

Enables you to enter a short reason or description for a budget increase.

**See also:**

*Customizing Settings For Form Fields [Page 157]*
Customizing Settings For Form Fields

**Determining The Budgeting Currency**

The budgeting currency is determined by the budget profile.

For more information on budget profile settings, see the implementation guide (IMG):

- **For internal orders** under Accounting → Controlling → Internal Orders → Budgeting and Availability Control → [Maintain Budget Profile [Ext.]].
- **For projects** under Project System → Costs → Budget → [Maintain Budget Profile [Ext.]].

**Determining The Budget Manager**

For internal orders:

You can define a manager in Customizing for each controlling area, object class, and order type.

⚠️

You can have more than one budget manager or WBS element manager in Customizing. If there is more than one manager, the system chooses the first from the list.

For WBS elements:

The budget managers are always the WBS element manager and the project manager.

If you did not enter a budget manager, or store a manager in Customizing, then the system determines a manager using the role stored in the Customizing for scenarios.

For more information on customizing scenarios, see the implementation guide (IMG) under Cross-Application Components → Internet / Intranet Services → Internal Service Request → Definition of Scenarios → [Define Scenarios [Ext.]].

**Determining The Budget Object**

The system checks to which budget object a budget consumer was assigned.

If budget is already allocated on the potential budget object, then this budget object is used for the request.

If no budget was allocated on the potential budget object, the system checks the path in the hierarchy from the bottom upwards to the TOP WBS element. The first object with budget that the system finds in the hierarchy is the budget object for the request.

If no budget object is found in the entire hierarchy, where budget was already allocated, then the system uses the object initially specified as the potential budget object for the request.

**Examples For Finding Budget Objects**

**Example One**

<table>
<thead>
<tr>
<th>Object</th>
<th>Budget</th>
<th>Actual</th>
<th>Assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top WBS element</td>
<td>1000</td>
<td>1000</td>
<td></td>
</tr>
<tr>
<td>WBS element one</td>
<td></td>
<td></td>
<td>1000</td>
</tr>
<tr>
<td>Order</td>
<td>1000</td>
<td></td>
<td>1000</td>
</tr>
</tbody>
</table>
Budget object = Top WBS element

**Example Two**

<table>
<thead>
<tr>
<th>Object</th>
<th>Budget</th>
<th>Actual</th>
<th>Assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top WBS element</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>WBS element one</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Order</td>
<td></td>
<td></td>
<td>1000</td>
</tr>
</tbody>
</table>

Budget object = WBS element one

**Example Three**

<table>
<thead>
<tr>
<th>Object</th>
<th>Budget</th>
<th>Actual</th>
<th>Assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top WBS element</td>
<td>1000</td>
<td>1000</td>
<td></td>
</tr>
<tr>
<td>WBS element</td>
<td>1000</td>
<td>1000</td>
<td></td>
</tr>
<tr>
<td>Order</td>
<td></td>
<td>1000</td>
<td>1000</td>
</tr>
</tbody>
</table>

Budget object = WBS element one

**Determining The Processor**

The processor is located using the standard role stored in Customizing for the scenario. If you did not store a standard role, the budget manager is informed as the processor. You can also enter a person as a processor.
Form For The Approving Manager Or Processor

The object that the applicant specified is displayed in the initial screen. The approving manager can go from each budget report for the budget object to the budget previously allocated. In addition, the manager can, if required, decide which object is to receive budget there.

In WBS elements, the report automatically contains the corresponding project. For WBS elements, the processor decides whether to make a budget supplement or to release the budget.

Budget Allocation With Hierarchy

The initial screen for budget allocation with hierarchy automatically contains the budget object. For WBS elements, the initial screen for budget allocation with hierarchy automatically contains the entire project.

Budget Allocation Without Hierarchy

The initial screen for budget allocation without hierarchy automatically contains the budget object. For WBS elements, the initial screen for budget allocation without hierarchy automatically contains the WBS element.

Budget Release (Projects Only)

For the budget release (access with hierarchy), the initial screen for the budget allocation with hierarchy automatically contains the entire project.
Task Processing

Purpose
Using the functions for task processing, you can change or display the tasks in a notification independently of the notification itself. In this way, you can:

- Process tasks quickly and easily
- Execute tasks using the functions of the action box
- Access the information in the associated notification at any time

Process Flow
1. You process the tasks using one of the following options, depending on your job duties or method of working:
   - **Worklist [Page 236]**
     You call up the worklist for tasks to determine whether tasks exist that you must process.
   - **Workflow [Page 237]**
     You check your workflow inbox determine whether tasks exist that you must process.
   - **Functions for Task Processing [Ext.]**
     If you want to process a specific task in a specific notification, use the transactions for processing or displaying a task.

2. After you have selected and executed one of the above options, you process a task by either:
   - Forwarding the task to another person, if you cannot process the task yourself
   - Carrying out the instructions specified in the task
   - Documenting the information for a task that has just been executed; for example, as a task long text or via a follow-up function in the action box (internal remark)
   - Setting the status of the task to "completed," once you have carried out the instructions specified in the task
   - Executing additional follow-up functions in the action box, if additional tasks need to be implemented

Result
Once you have processed and completed a task, you can complete the notification (provided there are no other tasks in the notification that need to be processed).
Processing Tasks Using Worklist

Use
Using the worklist for tasks, you can select notification tasks on the basis of different criteria and process them. You can select the tasks as follows:

- You select the tasks using the *My worklist* function. The system then displays the following tasks for further selection and processing:
  - All outstanding tasks to be processed by you as the "person responsible"
  - All tasks to be processed by you as a *Partner function*
  - All tasks you created
  - All tasks you completed
- You select the tasks using the *General selection* function. The system then displays all tasks for further selection and processing. Make sure the preset selection criteria contain the values you want (for example, selection period, outstanding tasks only).

Prerequisites
If you use the *General selection* function and you want to process tasks for which you are not responsible or which you did not create, you must have the corresponding authorization.

Activities
You choose *Logistics* → *Central functions* → *Notification* → *Worklist* → *Tasks* to call up the worklist for tasks.

You enter the required data and choose *Execute*.

See also:
Select and Process Tasks Using the Worklist [Ext.]
Processing Tasks Using Workflow

Use

If a task is created in a notification or if the person responsible for a task is changed, the system can automatically notify the person or department responsible via the SAP Business Workflow that a task needs to be processed.

You receive the information about the task that needs to be processed as a work item in your inbox (Business Workplace). Your inbox provides an overview of all tasks that you are responsible for processing. You can begin processing the work item directly from your business workplace.

Integration

You can access your business workplace by choosing Office → Workplace from the SAP menu. Then choose Inbox → Workflow to display any work items that may be present.

Prerequisites

The required system settings to activate the SAP Business Workflow have been made.

Activities

If there is a work item in your inbox, proceed as follows to begin processing the work item:

- You double click the work item to display a description of the task to be executed.
- You choose Execute to process the work item. The system calls up the transaction to process the task.
**Document Flow**

**Use**
You can use this function to display the document flow for a notification as a list or network graphic. The document flow allows you to identify:

- Preceding documents (documents from which the current notification originated)
- Subsequent documents (documents that originated from the current notification)
- "To-and-from" references between documents

Each document contains the following information:

- Document number
- Document number
- Additional data (if available)
- Logical system (if any of the other documents was created in a logical system other than the one in which the original notification was created)

You can also display the detailed information for each document.

**Integration**
The document flow is integrated in the following processes:

- Materials Management (MM)
- Production Planning and Control (PP)
- Sales and Distribution (SD)
- Customer Service (CS)
- Plant Maintenance (PM)
- Financials (FI)
- Controlling (CO)
- Project System (PS)

**Features**
The document flow, for example, can display the following objects (among others):

- Quality notification
- Service notification
- Maintenance notification
- General notification
- Claim
- Service order
Document Flow

- Sales order
- Production order
- Run schedule header
- Goods movement
- Purchase order
- Inspection lot
Displaying the Document Flow for a Notification

Procedure

1. Call up a notification in the create or change mode.
2. Choose one of the following menu paths, depending on whether you want to display the document flow as a list or graphic:
   - Extras → Notification documents → Document flow → List
   - Extras → Notification documents → Document flow → Graphic

   The notifications that reference other subsequent documents in the list display are labeled with a (Ref.) designation.
3. If you displayed the document flow as a graphic, select a document and choose Goto → Display document.
   The detailed information for the selected document is displayed.
Status Query

During the whole runtime of an internal service request [Ext.], you can obtain the current status.

See also:

- Status Management For Notifications [Ext.]
- Display Status Information [Ext.]
- Assigning System Statuses [Ext.]
- Assigning And Changing User Statuses [Ext.]
- Status Management For Tasks [Ext.]
Availability Control

Use
These components enable you to monitor and control project costs. The project manager can use availability control to call up an overview of the assigned funds and see which type they are. Availability control enables you to control costs actively by issuing warnings and error messages when costs are incurred.

Implementation Considerations
The component is fully integrated with upstream and downstream components, for example:

- Controlling (CO)
- Financial Accounting (FI)
- Production Planning and Control (PP)
- Materials Management (MM)

Features
Availability control monitors funds using budget allocation.

- **Passive Availability Control**
  Overview of funds, their assignment and type

- **Active Availability Control**
  Prevents the assignment of too many funds.

  If you enter business transactions that create costs on a Controlling element [Ext.] (for example, posting of an invoice), the system checks whether there is still sufficient budget available for the controlling element. For projects, you can also use releases as an alternative to the current budget. It uses the tolerance limits specified in Customizing for the check.

- For internal orders, see Controlling → Internal Orders → Budgeting and Availability Control → Define Tolerance Limits for Availability Control [Ext.].
- For projects, see Project System → Costs → Budget → Define Tolerance Limits [Ext.].
  
  For more information, see Defining Tolerance Limits [Page 173].

Availability control checks the current distributable budget (or release) against the assigned value.

- **Distributable Budget**
  The budget from the controlling element that is not yet distributed to other, lower-level WBS elements.

- **Assigned Value**
  Costs incurred by a Controlling element.
  For more information on the calculation of assigned values, see

- **Assigned Values in Internal Orders [Page 169].**
- **Assigned Values in Projects [Page 170].**

Warning! Budget Excess!!!
Assigned Value In Internal Orders

The assigned value for internal orders consists of:

- Actual costs
- Statistical actual costs
- Commitment
- Debit by settlement to an internal order
- Credit by settlement to a budget controlled object (such as an internal order, or a WBS element)

⚠️ The following is not used for calculation of the assigned value:

- Actual costs with a cost element that was defined as exempt in Customizing for availability control.
  For more information, see the implementation guide (IMG) under Controlling → Internal Orders → Budgeting and Availability Control → Specify Exempt Cost Elements For Availability Control [Ext.].

- Actual costs that were incurred by a business transaction that does not belong to the allowed transactions groups [Page 176] in the availability control. This can happen if you have not maintained the tolerance limits [Page 173] in customizing.
  For more information, see the implementation guide (IMG) under Controlling → Internal Orders → Budgeting and Availability Control → Specify Tolerance Limits For Availability Control [Ext.].

- Credits by settlement to an object that is not budget controlled (such as a cost center)
- Revenues
**Assigned Value In Projects**

The *assigned value* for projects is calculated from:

- Actual costs on the budget carrying WBS element
- Statistical actual costs on the budget carrying WBS element
- Actual costs from lower-level WBS elements, if these do not have any budget
- Statistical actual costs from lower-level WBS elements, if these do not have any budget
- Commitments on the budget carrying WBS element
- Commitments from lower-level WBS elements, if these do **not** have any budget.
- Maximum from plan and actual costs + commitments from assigned networks or orders.

For more information, see the implementation guide (IMG) under *Project System → Costs → Plan Costs → Specify Order Value Update Of Orders For Projects [Ext.]*.

- Debit by settlement to WBS element
- Credit by settlement to a budget controlled object (such as an internal order, or WBS element)

The following is **not** relevant for calculation of the assigned value:

- Actual costs with a cost element that was defined in Customizing for availability control as an exempt cost element.
  For more information, see the implementation guide (IMG) under *Project System → Cost → Budget → Specify Cost Elements [Ext.]*.
- Actual costs that were incurred by a business transaction that does not belong to the valid transaction groups [Page 176] in availability control.
  This situation cannot occur if you did **not** maintain the tolerance limits [Page 173] as a transaction group in Customizing.
  For more information, see the implementation guide (IMG) under *Project System → Costs → Budget → Specify Tolerance Limits [Ext.]*.
- Credits by settlement to an object that is **not** budget controlled (such as a cost center)
- Revenues
Entering Settings For Availability Control

Mandatory Customizing Settings

1. In the budget profile, you store all the values needed for the budgeting process, by choosing the following in Customizing:

- For projects Project System → Costs → Budget → Maintain Budget Profile [Ext.].
- For internal orders Controlling → Internal Orders → Budgeting and Availability Control → Maintain Budget Profile [Ext.].
  For more information, see Basic Settings For Availability Control In The Budget Profile [Page 172].

2. The tolerance limits that availability control uses for checks are stored for each transaction group for a budget profile, by choosing the following in Customizing:

- For internal orders Controlling → Internal Orders → Budgeting and Availability Control → Specify Tolerance Levels For Availability Control [Ext.].
- For projects Project System → Costs → Budget → Specify Tolerance Limits [Ext.].
  For more information, see Specifying Tolerance Limits [Page 173].

Optional Customizing Settings

Exempt cost elements are cost elements that are not included in availability control (such as interest or credit notes for activities that were provided in a joint venture of a project for a partner project).

Choose the following in Customizing

- For projects Project System → Costs → Budget → Specify Exempt Cost Elements [Ext.]
- For internal orders Controlling → Internal Orders → Budgeting and Availability Control → Specify Exempt Cost Elements For Availability Control [Ext.].
Basic Settings for Availability Control in Budget Profile

Use

In the budget profile you determine whether/how availability control is to be activated and which budget values should be checked by availability control.

Features

You control whether/how availability control should be activated using activation types (0=not activated, 1=Automatic Activation with Budget Allocation [Page 179], 2=Backround Activation [Page 180]). More information is available in Activating Availability Control [Page 178].

For projects, availability control can check against the current budget or the released budget. Furthermore, you can decide whether availability control is carried out on the basis of year-independent (= total values) or year-dependent values. Depending on the settings of the budget profile, the availability control checks against the

- actual overall budget
- actual annual budget
- released overall budget (only for projects)
- released annual budget (only for projects)

The current budget is made up of

- Original Budget [Page 114]
- Supplement [Page 133]
- Return [Page 137]
- Repostings from the Budget [Page 141]
Specifying Tolerance Limits

Use
When certain business transactions are entered that create costs on the corresponding Controlling-Element [Ext.], the system checks whether the available budget or available released budget is sufficient. It uses the tolerance limits specified in Customizing for this check.

For more information on specifying tolerance limits, see the implementation guide (IMG).

- For internal orders, see Controlling → Internal Orders → Budgeting and Availability Control → Define Tolerance Limits for Availability Control [Ext.].
- For projects, see Project System → Costs → Budget → Define Tolerance Limits [Ext.].

Features
You can specify tolerance limits for each controlling area, budget profile, and different Business Transaction Group [Page 176].

You can specify different tolerance levels with three possible options (issue with a warning [1], a warning and a mail to the project manager [2], or an error message [3]).

You can define the tolerance limits as the usage level, and / or as an absolute variance from the current budget or the release.

Usage Level
This is the relationship between assigned funds and the budget, displayed as a percentage.

Absolute Variance
This is the difference between assigned funds and budget, displayed in an absolute amount.

SAP recommends that you either specify a percentage usage rate, or an absolute variance for tolerance limits in availability control.

If you defined a percentage usage rate and an absolute variance as a tolerance limit for a budget profile and a transaction group, the action you specified is triggered if the assignments exceed one of the two tolerance limits.

Example
Availability control of a current overall budget (EUR 100,000)

<table>
<thead>
<tr>
<th>Business Transaction Group</th>
<th>Action</th>
<th>Percentage Usage Level</th>
<th>Absolute Variance</th>
<th>System Reaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>++</td>
<td>1</td>
<td>80 %</td>
<td></td>
<td>For all business transactions, a warning is issued once EUR 80,000 assigned value reached.</td>
</tr>
</tbody>
</table>
### Specifying Tolerance Limits

<table>
<thead>
<tr>
<th>++</th>
<th>2</th>
<th>1000</th>
<th>For all business transactions, a warning is issued and a mail is sent to project manager once assigned value of EUR 101,000 is reached.</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>3</td>
<td>110%</td>
<td>Purchase orders are prevented by error message once the assigned value of EUR 110,000 has been reached.</td>
</tr>
</tbody>
</table>

See also:

*Set up Availability Control [Page 171]*
Availability Control Actions

When the tolerance limit is exceeded, the system does one of the following:

**Warning (Action One)**

The system informs you when the tolerance limit is exceeded. You can still execute the business transaction that triggered this (such as posting an FI document).

**Warning and Mail to The Project Manager (Action Two)**

The system sends the project manager a message containing the WBS element on which the budget was exceeded, and the business transaction triggered the excess. The amount by which the budget was exceeded and the document number are also specified.

If no manager name is stored in the master record for the project or the WBS element, the system issues an error message instead of a warning and a mail. For orders, you maintain the budget manager in Customizing, under Controlling → Internal Orders → Budgeting and Availability Control → Maintain Budget Manager [Ext.].

**Warning (Action Three)**

The system issues an error message if an action leads to the specified tolerance limit being exceeded. The system rejects the business transaction (such as a purchase order) that causes the budget to be exceeded.
Transaction Group

All business transactions are assigned to a transaction group in availability control.

You can store an action for the system to execute for a business transaction that triggers too many allotted funds.

For more information, see Availability Control Actions [Page 178].

For the following transaction groups, you can specify tolerance limits for each budget profile, for the different actions. To do so, go to Customizing and choose:

- For internal orders, Controlling → Internal Orders → Budgeting and Availability Control → Specify Tolerance Limits For Availability Control [Ext.].
- For projects, Project System → Costs → Budget → Specify Tolerance Limits [Ext.].
- All transaction groups
  This general transaction group is designed to facilitate your entries, and is useful if you do not want to define separate tolerance limits for each transaction group. In addition to a tolerance limit defined for All transaction groups, you can specify a limit for one transaction group. This limit takes precedence over the "generally" valid tolerance limit. The tolerance limit and action specified for all transaction groups is thus ignored if there are additional entries for a special transaction group.

- Purchase requisition
- Purchase order
- Orders for the project
  When planning on an order for a project, the system checks the change to the rest of the plan for the order. It also checks the assignment and detachment of an order/network that already has assigned values, using this transaction group.

  Postings to orders for the project are checked in each transaction group, for example, the purchase order from an order for the project is checked in the Purchase order transaction group.

- Goods withdrawal
- FI Document
  Suitable for postings in FI
- Controlling document
  Suitable for postings in cost accounting.

- Budgeting
  During the life cycle of a project, the budget may be reduced, although allotted funds have already arisen on the project. You need this transaction group to enable the availability control to include subsequent budget changes.
  If this means that the allotted funds exceed a tolerance limit in availability control, the system
Transaction Group

tells you to see the error log when you make checks or save. The log contains the warnings or error messages that were issued as a result of the tolerance limit being exceeded.

- *Funds reservation* (manual commitment)
- *Fixed prices in the project*
Activating Availability Control

Use

In the budget profile, you use the Activation type to specify whether and/or how the availability control is to be activated.

Features

There are three different types of activation:

- **0** = Cannot be activated
- **1** = Automatic activation when budget is allocated [Page 179]
- **2** = Background activation [Page 180]

If you selected background activation, you can activate the availability control online [Page 181] for a particular project.

Activities

When availability control is activated, the system does the following:

- It determines the WBS elements that carry budget - these are controlling elements.
- It determines the corresponding assigned funds.
  It checks the assigned funds against the controlling element budgets. The assigned funds can be on the budget-carrying WBS element, the lower-level WBS elements and their assigned project orders.

After activation, each posting to the project is checked by the availability control.

As availability control affects system performance, you should activate it in the background for projects with less detail, only when you think that the budget may be exceeded.
Activating Availability Control with Budget Allocation

Use

In the budget profile, you selected *Activation type 1* for availability control. This means that the availability control is automatically activated when you make entries (or release budget, if this is to be checked).

Availability control is always defined for a particular budget profile, and you need to define a tolerance limit for at least **one** business transaction group for the budget profile. Once you enter a budget for a project with the corresponding budget profile, the availability control is activated.

💡

For technical reasons, availability control cannot be activated automatically for projects (assigned to an investment program) when budget is allocated from the investment program item to the top WBS element. Activation follows automatically during the next background activation run.
Activating Availability Control In The Background

Prerequisites

In the budget profile, you selected Activation type two for availability control (background activation).

During background activation of availability control, the system checks whether the limit of the usage level stored in the budget profile has been reached or not. If it has been exceeded, then availability control is activated.

You can start the background run for availability control automatically and on a regular basis.

In The Project System (Same Procedure For Internal Orders)

In the Project System, select the projects for which you want to start the background run.

1. Choose Logistics or Accounting → Project system → Controlling → Budgeting → Tools → Activate availability control
2. For internal orders, choose Accounting → Controlling → Internal orders → Budgeting → Availability control → Activate.
3. If required, enter the controlling area and the database profile. The Background Activation of Availability Control For Projects appears.
4. Enter the required data.

During background activation of availability control, the system creates a log for the objects for which you activated availability control. If you set the indicator for a complete log, all the other projects in the variant (object selection) are displayed, for which you did not activate availability control.

4. To save the project selection as a variant, choose Goto → Variants → Save as variant.... The ABAP: Save as variant screen appears.

2. Enter a variant name and text (meaning) and set the indicator For Background processing only.
3. Save the variant using .

The initial screen appears again, and the system informs you that the variant was saved.

Job Definition

You can start the background run for availability control on a regular basis by using a job definition.
Activating Availability Control Online

Activating Availability Control Online

In the budget profile you selected activation type two for availability control (background activation). You can now activate availability control in advance for one particular project online.

You can therefore activate availability control for a project before the usage level has been reached for background processing, or before the next background run.

In The Project System (Same Procedure For Internal Orders)

You activate availability control online as follows:

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change.
   For internal orders, choose Accounting → Controlling → Internal orders → Budgeting → Original budget → Change.
   The Change Original Budget: Initial Screen appears.

2. Enter the required data and choose Original budget.

   The system confirms activation with a message.

   Availability control is activated only when you next Save or make a Check. After activation, each posting that follows is checked for availability.

4. The system determines the assigned values that you can compare with the budget values by choosing Views → Assigned in CO area currency.

   If you now want to reduce the budget (for example), and the allotted funds thus exceed the tolerance limit in the availability control, you are notified when you check or save the budget.
Checking Whether Availability Control is Active

You can see whether availability control is active by looking at the system status of the potential budget object, or the display and change mode in the budgeting function (original budget, release, and so on).

Availability control is active in the following cases:

- The Availability control activated system status is set for the WBS element budget object.

1. Choose Logistics or Accounting → Project System → Basic data → Project → Special maintenance functions → Structure planning → Change project.
   The Change Project: WBS Element Overview screen appears.

2. The system displays the system status of the WBS elements via basic data.

In The Project System (Same as for Internal Orders)

- The display and change sessions in the budgeting function contain a corresponding message.

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change or Display.
   For internal orders, choose Accounting → Controlling → Internal orders → Budgeting → Original budget → Change or Display.

2. Enter the necessary data and choose Continue.

3. Choose Extras → Availability control → Information.
   You can now see whether the system issued a corresponding message.

- The Assigned column is visible in the budgeting transactions.

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change or display.

2. Enter the necessary data and choose Continue.

- For an overview of the assigned amounts on the WBS-Element overview, choose Extras → Availability control → Reference.

1. Choose Logistics or Accounting → Project System → Controlling → Budgeting → Original budget → Change or display.

2. Enter the necessary data and choose Continue.

3. Choose WBS Element overview → Extras → Availability control → Reference.

As well as the assigned and the distributable budget, the system displays the element with budget (which is on a higher level in the project structure) in the Controlling element column for each WBS element without budget. The system posts assigned funds from the WBS element and all lower-level WBS elements (that do not have any budget) to the controlling element.

The current assigned and distributable values are displayed after the budget is checked.
Activating Availability Control Online
Deactivating Availability Control

You can deactivate activated availability control for one or more projects. This is useful, if for example:

- Availability control was activated by mistake
- Availability control was already active for the previous year for annual budgets, but activation for the fiscal year just started is not yet required.

Procedure

In The Project System (Same For Internal Orders)

1. Choose Logistics or Accounting → Project system → Controlling → Budgeting → Tools → Deactivate availability control.
   For internal orders, choose Accounting → Controlling → Internal orders → Budgeting → Availability control → Deactivate.

   ![Tip]

   If you choose activation type one, the system reactivates availability control for the next budget.

   You can ensure long-term activation with activation type zero only.
Excluding WBS Elements From Availability Control

A project and its WBS elements go through different stages, or statuses. The status determines whether you can use certain business transactions or not. You can exclude a WBS element with budget and the lower-level account assignment elements from availability control. You do this by activating a user status for the controlling element, for which the availability control business transaction is not allowed.

If a WBS element has this status, then the assigned funds are not included in the availability control, in other words, no action is triggered. However, the assigned values are still updated on the controlling element.

For more information on how to create a user status, see the SAP Library under Financials → PS-Project System → Structures → Status Management [Ext].
Referencing Availability Control In Projects

Use
You can obtain an overview of the allotted funds in the display and change modes of the budgeting function.

Prerequisites
You have activated availability control.

Procedure
Choose Accounting → Project System → Controlling → Budgeting → Original budget → Change or Display → Original budget → Extras → Availability control. → Reference.

Result
As well as the assigned and distributable (=budget - assigned) budget, the system displays (under controlling element) the budget carrying element that is on the next level up from a WBS element that does not have any budget in the project structure. On this controlling element, all postings (that were made on WBS elements with no budget) are cumulated as allotted funds.

The current assigned and distributable values are displayed after checks are made.
Reconstructing Availability Control

In Customizing, you can start reconstruction of the assigned values. You need to do so if:

- You are introducing a new release
- You have changed the settings for availability control in the budget profile
- You have changed the tolerance limits for availability control
- You have redefined exempt cost elements
- You have changed the settings for updating order values on orders for the project
- You suspect that there may be data inconsistencies, for example in objects from older releases, or after corrections were installed for budgeting / availability control.

When you execute this function, the system redetermines the assigned values for the selected projects. It also creates references to the budget carrying objects, and transfers the new settings for the budget profile to the budget table.
# Notes for Problems with Availability Control

<table>
<thead>
<tr>
<th>Problem</th>
<th>Symptom</th>
<th>Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Availability control is not reacting, despite correct settings and activation.</td>
<td></td>
<td></td>
<td>Check to see if the corresponding entries are in the control tables TRWCI and TRWCA (see below: Entries in TRWCI and TRWCA).</td>
</tr>
</tbody>
</table>
| **Activation type 1** (activation with budget allocation) was selected for activation of availability control. Availability control is to be executed on a project, although the project has not yet been budgeted. | | | Post an original budget to the top WBS element. Then execute a return for the same amount. The current budget is zero.  
_avoid_  
Availability control is now active. |
| Availability control with **action two** (mail to project manager) does not send a mail when the assigned values are exceeded. | An error message appears. | No manager name has been entered in the WBS element, or in the project definition. | Enter the project manager name in Customizing, under Project System → Structures → Operative Structures → Work Breakdown Structure → Create Manager for WBS Element. [Ext.] |
| | A warning appears. | In Customizing for the project manager, the user has not been entered correctly. | Enter the user name of the project manager in Customizing, under Project System → Structures → Operative Structures → Work Breakdown Structure → Create Manager for WBS Element. [Ext.]  
_warn_  
Note that you need to enter the name in upper case letters. |
## Notes for Problems with Availability Control

<table>
<thead>
<tr>
<th>Neither a warning nor an error message appears.</th>
<th>Availability control is not active, or the tolerance limits have not yet been exceeded.</th>
<th>Activate availability control or maintain the tolerance limit accordingly. For more information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>When you post a goods receipt or enter an activity, this does not trigger an availability control action, although the tolerance limit was exceeded.</strong></td>
<td><strong>The system does not check the assigned values during goods receipt.</strong></td>
<td><strong>Check whether you can solve the problem by using one of the solutions suggested below (see below: Posting a goods receipt or entering an activity).</strong></td>
</tr>
</tbody>
</table>

### Entries in TRWCI and TRWCA

The program control table TRWCI (in which the installed components are stored) must contain the COFC entry (Controlling Funds Control).

The TRWCA table contains the same components (fiscal year-related) as the TRWCI table. You can use this table to deactivate specific components for certain fiscal years. In the TRWCA table, the COFC component should be active until the year 2050.

### Posting a Goods Receipt or Entering an Activity

- Use the commitment values from the purchase order for the budget check.
- Check whether tolerance limits were maintained for the purchase order transaction group. Before the purchase order, activate availability control.
- Check whether you can work with unvaluated goods receipts. In this case, the system updates the assigned values only once the goods receipt has taken place. When goods are received, the system checks the assigned values and if necessary, triggers the corresponding actions.
- Do not allow any more account assignment changes for the goods receipt posting.
Commitments Management (CO)

Purpose

CO Commitments Management enables you to enter and analyze commitments at an early stage, and thus to account for them in controlling.

Implementation Considerations

Purchase orders or purchase requisitions lead to financial commitments with varying degrees of obligation (See also: Commitments Management Flow [Page 196]). Commitments reserve funds for costs that will be incurred at a future date. Therefore, commitments must be included in funds monitoring.

For more information on funds commitment, see SAP Library under Financials → Controlling → Internal Orders → Funds Commitment (Cost Centers, Internal Orders, Projects) [Page 216].

Integration

In Commitments Management, data from the following SAP components is processed integrally:

- **Controlling (CO)**
  
  In Controlling you can perform tasks such as planning, checking and controlling costs. Commitments management is a part of the cost monitoring process. Commitments are displayed either on internal orders, cost centers, or projects.

- **Materials Management (MM)**
  
  This covers tasks such as material requirements planning, purchasing, goods receipt, inventory management, and invoice verification. Commitments are created through purchase requisitions and purchase orders. Commitments are reduced by various business transactions such as goods receipt. The commitments data is transferred to Controlling.

Features

- **Creation of Commitments**
  
  For example, specific goods are ordered for an internal order, a cost center, or a project. A purchase order commitment is created that is equivalent to the purchase order value.

- **Commitments Display**
  
  Commitments are always displayed with a value and, if required, a quantity for the cost element, the fiscal year, and the period when the costs are expected to be incurred (See also: Commitments Information System [Page 211]).

- **Commitments Currency**
  
  The system executes all commitments in the currency used, in the original business transaction (for example in the ordering transaction). It then translates the amount into the controlling area currency, company code currency and the object currency. The PO currency exchange rate is used for currency translation.

- **Reducing the Commitment:**
  
  The commitment is reduced by business transactions (such as goods receipts) and actual costs are incurred by the corresponding account assignment object. This
Commitments Management (CO)

continues until, for example, the business transaction "Purchase order" is closed and the purchase order commitment is reduced to zero.

- **Carrying Forward Commitments at Year-End-Closing**

  At year-end closing, you can carry the open commitment values from purchase requisitions, purchase orders and fund commitments forward to the first period of the next fiscal year. You can select by account assignment object (order, cost center or project). You can also process individual documents if required.

  Commitments are carried forward for each controlling area.
Commitment

Definition

Identifies costs that will be incurred in the future for materials and services that you have requested or ordered. Commitments [Ext.] reserve funds that will become costs at a future date.

Use

On the account assignment objects, Commitments Management portrays the cost side of the procurement process for MM Purchasing. The costs incurred are assigned to business objects, such as orders, cost centers, or projects.

In Commitments Management, you can specify which object the costs are to be assigned to (for example, purchase order costs). In this case, this is known as an Initial Account Assignment.

Commitments Management distinguishes between three types of commitments, depending on the account assignment object:

- **Order Commitment:**
  The commitment is initially assigned to an order.

- **Cost Center Commitment:**
  The commitment is initially assigned to a cost center.

- **Project Commitment:**
  The commitment is initially assigned to a project, or to a work breakdown structure element.

For more information, see the SAP Library:

<table>
<thead>
<tr>
<th>For Internal Orders</th>
<th>Financials → Controlling → Internal orders → Manual Actual Postings On Internal Orders [Ext.]</th>
</tr>
</thead>
<tbody>
<tr>
<td>For Cost Center Accounting</td>
<td>Financials → Controlling → Cost Center Accounting → Manual Actual Postings [Ext.]</td>
</tr>
<tr>
<td>For Project System</td>
<td>Financials → Controlling → Commitments/Actual Updates Of Transaction Data [Ext.]</td>
</tr>
</tbody>
</table>

Integration

Commitments occur

- In Purchasing, due to:
  - **Purchase requisitions (purchase requisition commitment)** define the internal requirement for a material or a service. Purchase requisitions have a control function and you change them at any time.
  - Purchase orders (purchase order commitment): Purchase orders are contractual requests to a vendor, to supply certain goods or services according to the agreed conditions. No short-term, unilateral changes can be made.

- due to **funds commitments (commitment for funds commitments):**
Commitment

- You can use Funds Commitments to reserve funds for costs you are fairly certain to incur, but you cannot yet assign to a specific business transaction (such as, a purchase order or a purchase requisition).
Activate Commitments Management

You activate commitments management:

- For each controlling area from a chosen fiscal year
- For orders per order type
- For cost centers per cost center type

If Commitments Management is activated in the controlling area, then it is automatically activated at the same time for projects.

Activating Commitments Management for Controlling Area

1. In Customizing under Controlling → Cost Center Accounting → Commitments and Funds Commitments
   - Activate Commitments Management [Ext.]
2. In Customizing, chose Controlling → Internal Orders → Commitments and Funds Commitments
   - Activate Commitments Management [Ext.]
3. Project System → Costs
   - Activate Project Management in Controlling Area [Ext.]


Activating Commitments Management for Order Types

1. In Customizing, chose Controlling → Internal Orders → Define Order Types [Ext.]

Activate Commitments Management for Cost Center Types (Default Value for Cost Centers)

1. In Customizing, choose Controlling → Cost Center Accounting → Master Data → Cost Centers → Maintain Cost Center Types [Ext.]
2. In the cost center category that you want to activate commitments management for, deselect the commitments-lock indicator. Save your entries.
   - You activated commitments management for the selected cost element. The setting is used as a default value for cost centers that are to be created. You can change the setting if required.

Activating Commitments Management for Cost Centers

1. Choose Financials → Controlling → Cost Center Accounting → Master data → Cost center → Individual processing → Create/Change.
2. Choose Master data.
Activate Commitments Management

3. Choose Control

4. If you require the system to update commitments to the cost center, do not select the Commitments update lock indicator
Commitments Management Flow

Purpose
The SAP Purchasing component (MM-PUR) is responsible for the external procurement of materials and services. The system displays the different types of business transaction in Purchasing (on the cost side) on the account assignment objects (such as internal order, cost center). It does this using various commitment categories.

Prerequisites
You must activate Commitments Management before you can use it. For more information, see Activating Commitment Management [Page 194].

Process flow
1. The system uses purchase requisitions to create purchase requisition commitments. For more information, see How Purchase Requisition Commitments Are Created [Page 198].
   A purchase order is created from purchase requisitions. This is a result of quotation processing and requests for quotations (RFQs) in purchasing. On the commitment side, purchase order commitments are created from purchase orders. Purchase order commitments reduce each purchase requisition commitment by referencing to a purchase requisition. For more information, see How Purchase Order Commitments Are Created [Page 200].

2. Purchase order commitments are reduced according to the goods / invoice receipt logic. For more information, see Reducing Purchase Order Commitments to Zero [Page 202]

See also: Example: Individual Purchase Order on an Internal Order [Page 204].
Commitments Management Flow

The example shows

- How a purchase order commitment is created by a purchase order
- How the purchase order commitment is reduced
- How the data is displayed on the account assignment object
How Purchase Order Commitments are Created

Use
The system calculates purchase requisition commitments (PReq commitments) from the remaining quantity of a purchase requisition [Ext.]. The system then multiplies this by the price from the purchase requisition.

The following data is relevant to creating the PReq commitment:

- The value of the purchase requisition
- Planned delivery date
- Account assignment

Features
The system reduces PReq commitments on a quantity basis, using purchase orders referring to the corresponding purchase requisition. The system reduces a PReq commitment to zero using a purchase order with the full amount, or using a change in the purchase requisition.

You create a purchase requisition for five PCs at USD 1,500.00 each. This leads to a purchase order commitment for USD 7,500.00.

The purchasing department orders 3 PCs at USD 2,000.00 each. This causes a purchase order commitment for USD 6,000.00 (3 x USD 2,000.00).

The system reduces the purchase requisition commitment in proportion to quantity to USD 3,000.00 (3 x USD 1,500.00 = USD 4,500.00).

Integration

Purchase Requisitions using Consumption-Based Planning
The SAP Consumption-Based Planning component proposes the materials to be ordered. These proposals are based on previous consumption and existing warehouse stocks.

Manually Entered Purchase Requisitions
A purchase requisition is created manually in the requesting department. The person creating the purchase requisition defines what is to be ordered, in what quantity, and when the order is to occur.

For more information, see SAP Library under Logistics → Materials Management → Purchasing → Purchase Requisitions [Ext.].

Purchase Requisitions Created Automatically in Networks

- You can create activities in the network as externally processed activities. The system automatically generates a purchase requisition from the data you maintain for the activity, when you save your entries.
How Purchase Order Commitments are Created

- To plan the material required for a project, you can assign the materials you need (to carry out the project) to business transactions. The system generates a purchase requisition if you assign material that is not in stock to a business transaction.

The resulting purchase requisition commitment also forms part of the availability control.
Creating Purchase Order Commitments

Usage
The system derives purchase order commitments from the order value. It is the value of goods ordered, but for which no actual costs have yet been incurred.

The following purchase order data affects the creation and reduction of purchase order commitments:
- The purchase order value
- Delivery date
- Account assignment

Prerequisites
For this data transfer to take place from Purchasing, the purchase order must be assigned to an order, a cost center, or a project.

Features
The system uses the following to create purchase order commitments:
- Individual purchase order
  As well as an accurate description of what is ordered, individual purchase orders specify what is to be ordered, and a deadline for the delivery of the material or the service.
- Releases for outline agreements [Ext.]
  There is no specific date for a confirmed purchase order. You determine the date when you execute the release [Ext.] for a delivery.

You create commitments using the expected delivery date, not the date the purchase order was created.

Delivery Costs
A purchase order commitment includes anticipated delivery costs. These costs are managed separately by the system. They are displayed individually according to origin (for example, freight costs, duty costs, packaging). This distinction between the delivery costs and the purchase order itself ensures that you can clearly display the different currencies in which the individual cost components are incurred.

Multiple Account Assignment
In the Purchasing component, you can assign a purchase order item to several account assignment objects (for example, you can distribute the costs for an item to several orders or cost centers). The system updates the purchase order commitment on the corresponding account assignment objects accordingly.

For more information on specifying a multiple account assignment, see SAP Library under Logistics → Materials Management → Purchasing → Purchase Orders → Account Assignment → Specifying Multiple Account Assignment [Ext].
Creating Purchase Order Commitments

Reassignment

You can change the account assignment for a purchase order item so that, for example, the costs are assigned to an item on order 2 instead of order 1. You can only do this if no actual costs have yet been incurred. Therefore, no goods receipt or invoice receipt may already have occurred. The system displays the purchase order commitment on the new account assignment object.
Reducing Purchase Order Commitments to Zero

Use

The system reduces purchase order commitments to zero according to goods or invoice receipts and converts them into actual costs. As the quantity (down to zero) determines the reduction of a purchase order commitment to zero, you need quantity-based commitment management.

If values for purchase orders, goods to be delivered, and invoices are to determine the reduction (to zero) of a purchase order commitment, then you need value-based commitment management. To set up value-based commitment management per unit of measurement, choose General Settings → Check Unit of Measurement [Ext.] in Customizing.

Unlike purchase orders for materials, those for services are monitored on the basis of value, not quantity.

Features

When the Commitment is Reduced

The goods receipt indicator in the purchase order determines when the commitment is reduced and actual costs are set up (that is, in the detail screen for the purchase order item).

- GR indicator set: Commitment is reduced when goods are received.
- GR Indicator is not set: Commitment is reduced when invoices are received.

Reducing Commitments to Zero

You can reduce the purchase order commitment proportionally. To do this, you need to enter a goods receipt or invoice receipt for a purchase order.

The system reduces purchase order commitments completely:

- If you indicate the business transaction as closed, with a goods receipt for a purchase order item.
  It could be that the total quantity for a purchase order item has not been delivered, but you expect no further deliveries. In this case, you must set the “Delivery completed” indicator when you post the goods receipt.

- If you indicate the business transaction as closed, with an invoice receipt for a purchase order item.
  when you post the invoice, you can set the indicator in the purchase order item to indicate that you do not expect any more incoming invoices

- If you set the “Delivery completed” indicator in the purchase order item.
  Assuming that you ordered six pieces of a given item and only five were delivered, and if you agree with the vendor that the missing item no longer need be supplied. If you end the business transaction by setting the indicator in the purchase order item.

- If you lock a purchase order item to prevent goods receipt for that item.
  This is possible providing no goods or invoices have been received.
Reducing Purchase Order Commitments to Zero

- *If you delete a purchase order item.*
  The purchase order item is marked for deletion but initially stays inactive in the system. You can only delete completed purchase order items (for example, there can be no deliveries or invoices outstanding, either for the quantity ordered or for the quantity which appears in the invoice). If you wish to delete outstanding items, you need to set the “Delivery completed” indicator in the purchase order item first.
**Example: Individual Purchase Order on an Internal Order**

This example of an individual purchase order describes how the system deals with the different business transactions in the purchase order commitment. The example explains how the purchase order commitment originates and how it is assigned to an internal order using a goods purchase order.

It is irrelevant for the update of the purchase order commitment, whether the purchase order is assigned to an internal order, a cost center or a project. The account assignment only indicates the object on which the commitment is displayed, and where the actual costs are incurred.

**Prerequisites for the Example**

<table>
<thead>
<tr>
<th>You must know how to...</th>
<th>For more information, see the SAP Library under...</th>
</tr>
</thead>
<tbody>
<tr>
<td>• activate commitments management</td>
<td>Activate Commitments Management [Page 194].</td>
</tr>
<tr>
<td>• create an internal order</td>
<td>Financials → Controlling → Internal Orders [Ext.]</td>
</tr>
<tr>
<td>• create a purchase order and assign it to an internal order</td>
<td>Logistics → Materials Management → Purchasing [Ext.]</td>
</tr>
<tr>
<td>• post a goods receipt</td>
<td>Logistics → Materials Management → Inventory Management [Ext.]</td>
</tr>
<tr>
<td>• post an invoice receipt</td>
<td>Logistics → Materials Management → Logistics Invoice Verification [Ext.]</td>
</tr>
</tbody>
</table>

**Example process**

<table>
<thead>
<tr>
<th>Business Transaction</th>
<th>Commitment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purchase order for three PCs at USD 1,500.00 each:</td>
<td>Creating the Purchase Order Commitment [Page 206]</td>
</tr>
<tr>
<td>15.12.1998</td>
<td></td>
</tr>
<tr>
<td>15.01.1999</td>
<td></td>
</tr>
<tr>
<td>15.02.1999</td>
<td></td>
</tr>
<tr>
<td>Shipping charges are fixed at USD 150.00</td>
<td></td>
</tr>
<tr>
<td>Goods receipt for two PCs</td>
<td>Reduction of the Purchase Order Commitment [Page 207]</td>
</tr>
<tr>
<td>Goods receipt for three PCs; the price is greater than the purchase order price: USD 2,000.00</td>
<td>Updating Purchase Order Commitments [Page 208] due to new goods price</td>
</tr>
<tr>
<td>Remaining delivery: Goods receipt for one PC</td>
<td>Reduction of Purchase Order Commitment [Page 209] to zero</td>
</tr>
<tr>
<td>Invoice receipt for freight costs: USD 180.00 instead of USD 150.00</td>
<td>Increasing the Actual Costs [Page 210]</td>
</tr>
</tbody>
</table>
Example: Individual Purchase Order on an Internal Order
Example: Creating Purchase Order Commitments

1. In the IMG, activate commitments management for your controlling area from the fiscal year 1998 (see Maintain Controlling Area [Ext.]). Additionally, activate the order type you are using (see Define Order Types [Ext.]).

   If you want to assign purchase orders to a cost center, activate commitments management for the cost center type you are using in the IMG (see Maintain Cost Center Categories [Ext.]).

2. Create an internal order.

3. Create the purchase requisition and assign it to the internal order. As a result, the system creates a purchase order commitment of USD 4,650.00 for the order.

Creating a Purchase Order Commitment

<table>
<thead>
<tr>
<th>Business Transaction</th>
<th>Actual</th>
<th>Commitment</th>
<th>Assigned (actual + commitment)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Purchase order for 3 PCs at USD 1,500.00 each + USD 150.00 shipping charges</td>
<td>./</td>
<td>4,650.00</td>
<td>4,650.00</td>
</tr>
</tbody>
</table>

4. The purchase order commitment is displayed in the Internal Orders information system (See also: Internal Orders Information System [Ext.]). Choose Accounting → Controlling → Internal orders → Information system → Reports for internal orders.

5. Choose Plan/Actual comparisons → Additional key figures → Order: Actual/Plan/Commitment.

6. Enter the order number and execute the report.

   The order report displays the commitment of USD 4,650.00 resulting from the purchase order.

You can find further information on commitment reporting under Information System for Commitments [Page 211].
Example: Partial Reduction of Purchase Order Commitments

In inventory management for your purchase order, you post a goods receipt for two PCs. The internal order has now incurred actual costs equal to the purchase order value of the two PCs, plus the proportionate delivery costs. The purchase order commitment is partially reduced by the value of the goods receipt. The actual costs and the purchase order commitment added together provide the total amount of assigned funds:

<table>
<thead>
<tr>
<th>Business transaction</th>
<th>Actual</th>
<th>Commitment</th>
<th>Assigned (actual + commitment)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Purchase order for 3 PCs at USD 1,500.00 each + USD 150.00 shipping charges</td>
<td>./.</td>
<td>4,650.00</td>
<td>4,650.00</td>
</tr>
<tr>
<td>2. Goods receipt for two PCs</td>
<td>3,100.00</td>
<td>1,550.00</td>
<td>4,650.00</td>
</tr>
</tbody>
</table>

You can display the current actual and commitment values in reporting.
Example: Updating Purchase Order Commitments

In the invoice verification for your purchase order, you post an invoice receipt for three PCs at USD 2000.00.

The invoice value is therefore USD 500.00 higher for each PC than the purchase order value. For that reason, the actual costs increase for both of the delivered PCs by USD 1,000.00. The commitment value for the outstanding PC increases by USD 500.00. In reporting for the internal order, the following actual and commitment values are displayed:

Updating the purchase order commitment

<table>
<thead>
<tr>
<th>Business Transaction</th>
<th>Actual</th>
<th>Commitment</th>
<th>Assigned (actual + commitment)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Purchase order for 3 PCs at USD 1,500.00 each + USD 150.00 shipping charges</td>
<td>./.</td>
<td>4,650.00</td>
<td>4,650.00</td>
</tr>
<tr>
<td>2. Goods receipt for two PCs</td>
<td>3,100.00</td>
<td>1,550.00</td>
<td>4,650.00</td>
</tr>
<tr>
<td>3. Invoice receipt for three PCs, USD 2,000.00 each</td>
<td>4,100.00</td>
<td>2,050.00</td>
<td>6,150.00</td>
</tr>
</tbody>
</table>
Example: Reducing Purchase Order Commitments to Zero

You post the final goods receipt for one PC. The purchase order commitment is reduced to zero and fully converted into actual costs. The order report documents the reduction to zero of the purchase order commitment:

**Reducing the purchase order commitment to zero**

<table>
<thead>
<tr>
<th>Business Transaction</th>
<th>Actual</th>
<th>Commitment</th>
<th>Assigned (actual + commitment)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Purchase order for 3 PCs at USD 1,500.00 each</td>
<td>./.</td>
<td>4,650.00</td>
<td>4,650.00</td>
</tr>
<tr>
<td>+ USD 150.00 shipping charges</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2. Goods receipt for two PCs</td>
<td>3,100.00</td>
<td>1,550.00</td>
<td>4,650.00</td>
</tr>
<tr>
<td>3. Invoice receipt for three PCs, USD 2,000.00 each</td>
<td>4,100.00</td>
<td>2,050.00</td>
<td>6,150.00</td>
</tr>
<tr>
<td>4. Goods receipt for one PC</td>
<td>6,150.00</td>
<td>./.</td>
<td>6,150.00</td>
</tr>
</tbody>
</table>
Example: Increasing the Actual Costs

An invoice of USD 180.00 is received for shipping charges. The actual costs increase from USD 6,150.00 to USD 6,180.00.

The purchase order is closed with this business transaction.

**Increase actual costs**

<table>
<thead>
<tr>
<th>Business Transaction</th>
<th>Actual</th>
<th>Commitment</th>
<th>Assigned (actual + commitment)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Purchase order for 3 PCs at USD 1,500.00 each + USD 150.00 shipping charges</td>
<td>./.</td>
<td>4,650.00</td>
<td>4,650.00</td>
</tr>
<tr>
<td>2. Goods receipt for two PCs</td>
<td>3,100.00</td>
<td>1,550.00</td>
<td>4,650.00</td>
</tr>
<tr>
<td>3. Invoice receipt for three PCs, USD 2,000.00 each</td>
<td>4,100.00</td>
<td>2,050.00</td>
<td>6,150.00</td>
</tr>
<tr>
<td>4. Goods receipt for one PC</td>
<td>6,150.00</td>
<td>./.</td>
<td>6,150.00</td>
</tr>
<tr>
<td>5. Invoice receipt for freight costs: USD 180.00</td>
<td>6,180.00</td>
<td>./.</td>
<td>6,180.00</td>
</tr>
</tbody>
</table>
## Commitments Information System

Depending on the account assignment object used, you can display commitments using the information system for Internal Orders, Cost Center Accounting, or for Project Systems.

<table>
<thead>
<tr>
<th>Further information on the information system</th>
<th>is available in the SAP Library under..</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Center Accounting</td>
<td>Financials → Controlling → Cost Center Accounting → Information System [Ext.]</td>
</tr>
<tr>
<td>Internal Orders</td>
<td>Financials → Controlling → Internal Orders → Information System for Internal Orders [Ext.]</td>
</tr>
<tr>
<td>Projects</td>
<td>Financials → Project System → Project Information System [Ext.]</td>
</tr>
</tbody>
</table>

You can display the commitment values for a specific controlling area at three different levels of detail. You can either call these up directly, or branch to one after the other:

- [Calling Up Total Cost Reports](Page 212)
- [Calling Up Cost Element Reports](Page 214)
- [Calling Up Line Item Reports](Page 215)
Calling Up Total Cost Reports

In addition to the actual values and plan values, this report displays commitment values, independent of cost element, for an individual or group of account assignment objects.

If the system is to display the commitment for each account assignment object that belongs to a group, enter an order group or a cost center group.

Calling up Total Cost Reports for Order Commitments

Choose Accounting → Controlling → Internal orders → Information system → Reports for internal orders → Plan / Actual comparisons → Additional key figures → List: Actual / Plan / Commitments.

Calling up Total Cost Reports for Cost Center Commitments


2. If you want to:
   • Evaluate a cost center hierarchy, choose Plan/Actual comparisons → Additional key figures → Area: Actual/Plan/Commitment.
   • Evaluate a cost center hierarchy, choose Plan/Actual comparisons → Additional key figures → Cost centers: Actual/Plan/Commitment.

Calling up Total Cost Reports for Project Commitments

1. Choose Accounting → Project system → Information system → Controlling → Costs → Plan-based → Hierarchical.

2. Choose one of the following standard reports.
   • Plan/Actual/Commitment/Rem.Plan/Assigned.
   • Commitment detail
     The report compares the commitment values (such as purchase requisition commitments, purchase order commitments, funds reservation commitments) for an object in the project (WBS element, network, order, network activity).

Results

The value displayed is the total of the liabilities existing for all the cost elements of the account assignment object.

In these reports, you can call up each cost element report as follows:
   • Internal orders and cost centers
     Double-click on the required report row.
   • Projects
Calling Up Total Cost Reports

Place the cursor on the required report row, row, column, then choose Goto \rightarrow Callup report \rightarrow Cost element reports.
Calling Up Cost Element Reports

You can summarize cost elements into cost element groups. If you want the system to classify the commitment values for a single account assignment object, or for a group of account assignment objects, using each cost element, then enter a cost element group when calling up the cost element report.

Calling up Cost Element Reports for Order Commitments
Choose Accounting → Controlling → Internal orders → Information system → Reports for internal orders → Plan / Actual comparisons → Additional key figures → Order: Actual/Plan/Commitments.

Calling up Cost Element Reports for Cost Center Commitments
Choose Accounting → Controlling → Cost Center Accounting → Information system → Reports for Cost Center Accounting → Plan / Actual comparisons → Additional key figures → Cost centers: Actual / Plan / Commitments.

Calling up Cost Element Reports for Project Commitments
Choose Accounting → Project system → Information system → Controlling → Costs → Plan-based → Hierarchical → Plan/Actual/Commitments/Rem. Plan/Assigned.

Results
To call up each line item report, double-click on the report row in the cost element report.
Calling Up Line Item Reports

The line item report enables you to display the line items for the quantity and value-based commitments for an account assignment object and cost element.

Calling up line item reports for order commitments

Choose Accounting → Controlling → Internal orders → Information system → Reports for internal orders → Line items → Orders: Line items, Commitments

Calling up line item reports for cost center commitments

Choose Accounting → Controlling → Cost Center Accounting → Information system → Reports for Cost Center Accounting → Line items → Orders: Line items, Commitments

Calling up line item reports for project commitments

Choose Accounting → Project system → Information system → Controlling → Line items → Commitments.

Results

Once the system creates the report, you can display the documents. Choose Edit → Document.

You can also display various fields with the line items, for example:

- Number of the reference document
- Reference item (for the purchase order)
- Text (for the purchase order)
- Debit date and document date
- Fiscal year, period
- Plan / controlling area currency
- Creditor

To do this, choose Settings → Extra field.

The system does not display line items that no longer have any commitments.
Funds Commitment (Cost Centers, Internal Orders, Projects)

Use

You use this function to enter anticipated costs or revenues where you do not yet know which business transaction will later cause them (purchase order, material reservation and so on). In this way, you can reserve parts of the budget in advance.

You can assign funds commitment to internal orders, cost centers, or projects.

Integration

A funds commitment that is assigned to a WBS element, a network, or an internal order is part of the active budget availability control. The funds commitment checks whether the available budget is still sufficient. The system includes defined tolerance limits below and above the budget.

For more information, see Availability Control [Page 167].

The system displays the funds commitment as a commitment in the information system for the account assignment objects. For more information, see Commitments Management [Page 190].

You can archive the documents for funds commitment. For more information on archiving, see: CA - Archiving Application Data [Ext.].

Prerequisites

To process the funds commitment, you need the corresponding authorizations for each document type from the K_KMOB_DCT authorization object.

Features

Funds commitment includes the following single activities:

- **Creating Funds Commitments [Page 218]**
  - You create a funds commitment as a marked document, which contains:
    - Data in the document header, that is valid for the entire document
    - At least one funds commitment item that contains the actual data on the funds commitment.

- **Changing Funds Commitments [Page 220]**
  - You can change the funds commitment as well as enter more items for funds commitment.

- **Reducing Funds Commitments [Page 221]**
  - When you manually reduce a funds commitment, you enter the reduction amount for the funds commitment item. You use the open amount to determine the reduction amount. The reduction amount is always the difference between the funds commitment amount, and the total of the partial amounts already reduced. The reduction amount must not be greater than the open amount.

  You can:
Funds Commitment (Cost Centers, Internal Orders, Projects)

- Reduce **one** funds commitment
  You can reduce the items for **one** marked document by specifying the document number for a funds commitment.

- Reduce **more than one** funds commitment
  You can reduce the items in marked documents for **more than one** funds commitment when you are in a list.

  **Calling Up Reduction History [Ext.]**
  
  **Reduction reference**
  For information purposes, you can make reference to a follow-up document (such as, order, purchase order, FI document) through which the actual costs will be or have been incurred.

  - To enter a reduction reference for **reduction documents already entered**, choose 
    *Edit → Reduction references* in the reduction history.

  - To enter reduction references for the **current reduction document**, choose *Extras → Reduction references* from the list screen or detail screen.

  **Reversing reduction references**
  You can reverse individual reduction postings. Place the cursor on a reduction document in the reduction history, and choose *Reverse*. The system indicates the reduction document in the STO column as reversed.

- **Evaluations Of Funds Commitment Documents In The Information System [Ext.]**
Creating Funds Commitments

Procedure

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Actual postings → Funds commitment → Create.
   - Accounting → Controlling → Internal orders → Actual postings → Funds commitment → Create.
   - Accounting → Controlling → Project System → Actual postings → Funds commitment → Create.

   The Create Funds Commitments screen appears.

2. Enter data as required.
   - Document type
     The document type categorizes your documents, and controls whether you can enter negative values for funds commitment (to display credits for example). See also: Document Type / Number Assignment [Ext.]
   - Document date (issue date of the original document)
     The system defaults today's date, but you can overwrite this if required.
   - Document number
     If you specified an external number assignment for the funds commitment, enter the required document number here. You can define the number interval for the internal or external number assignment in the implementation guide for each application.

3. You have the following options:
   a. If you want to enter more than one funds commitment item, then choose Fast entry. You can specify a reference to another funds commitment, as well as account assignments and an amount for each funds commitment item.
   b. If you want to enter a funds commitment item, then choose Detail screen. You can use all functions that are available for processing a funds commitment item.

4. Enter data as required.
   - Order, WBS element or cost center.
     The account assignment objects (order and WBS element) must have a status that allows the funds commitment business transaction. For more information on status management, see General SAP Status Management [Ext.].

     You need to specify another true account assignment object (such as a cost center) for statistical internal orders or WBS elements. The system does not debit these with costs, but records the values for information purposes only.
Creating Funds Commitments

- On the Detail screen enter the following information if required:
  - Cost center
    The cost center account assignment object does not have status management.
  - Material or vendor.
    If you know which material or which vendor is going to require the funds commitment, you can specify this. The system checks whether material or the vendor exist in the system.
  - Quantity and price
    As an alternative to a funds commitment amount, you can enter a quantity and a unit price.

5. Save your entries with 

Results

For internal number assignment, the system determines the document number when you save. The document number is used for posting the funds commitment.

During funds commitment, the system updates a cost commitment on the account assignment object. This update is independent of commitments management activation in Customizing for

- Your controlling area
- Your order type
- Your cost center

A funds commitment that is assigned to a WBS element, a network, or an internal order is part of the active budget availability control. The funds commitment checks whether the available budget is still sufficient. The system includes defined tolerance limits below and above the budget.

If a specified tolerance limit is exceeded by a funds commitment, the system can trigger different actions when you save:

- Warning
- Mail to the order or project manager
- Error message

For more information on availability control, see: Availability Control [Page 167].
Changing Funds Commitments

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Actual postings → Funds commitment → Change.
   - Accounting → Controlling → Internal orders → Actual postings → Funds commitment → Change.
   - Logistics or Accounting → Project System → Controlling → Actual postings → Funds commitment → Change.

   The Change Funds Commitment screen appears.

2. Enter the necessary data and choose Fast entry or Detail screen
   - You can switch between the fast entry and the detail screen at any time.

   In the detail screen, you can switch between the document items using and .

3. Change the document item, or create a new one.

   Once a funds commitment item is completed with the reduction of this document, select Completed in the detail screen. The system displays the completed funds commitment item and then reduces the funds commitment completely. If the system is to reconstruct the funds commitment, undo the selection.
Reducing Funds Commitments

Reducing Funds Commitments Manually

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Actual postings → Funds commitment → Reduce.
   - Accounting → Controlling → Internal orders → Actual postings → Funds commitment → Reduce.
   - Logistics or Accounting → Project System → Controlling → Actual postings → Funds commitment → Reduce.

   The Reduce Funds Commitments Manually screen appears.

2. Enter the necessary data and choose .

3. If the system is to reduce the funds commitment completely, select the completion indicator for this funds commitment item in the detail screen. You can also enter a reduction reference.

4. To reduce the funds commitment by amount, enter the reduction amount and if required, a descriptive short text in the detail screen, under Reduction information.

5. If you want to complete a funds commitment item with a reduction posting, select the Item completed indicator.

6. If you want to reduce commitments for more funds commitment items, choose .

7. Save the funds commitment reduction with .

Reduce Funds Commitments with Invoices

Prerequisites

In Customizing under Financial Accounting → Basic Settings for Financial Accounting → Document → Line Item → Control → Maintain Field Status Variants [Ext.] the Earmarked funds field is selected as a mandatory or an optional entry.

Procedure

1. When you post a vendor invoice in the account assignment block, enter the document number of a funds commitment in the Earmarked funds field.

Results

To obtain an overview of reduced funds commitments, choose Environment → Usage history. The system displays a list of the reduction amounts with the following information:

- Document amount
- Number, amounts and data from the reduction postings
- Open amount
Reducing Funds Commitments
Evaluating Funds Commitment Documents in The Information System

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Information system → Reports for Cost Center Accounting → Line items → Cost centers: Commitment line items
   - Accounting → Controlling → Internal orders → Information system → Reports for internal orders → Line items → Orders: Commitment line items
   - Logistics or Accounting → Controlling → Project System → Information System → Controlling → Actual postings → Commitments.

   The Display Line Item Commitments for Projects screen appears.

2. Enter the necessary data and choose More selection criteria. The Define More Selection Criteria screen appears.


4. From the overview tree, choose Documents/Objects → Reference document category. In the right-hand screen area, the system displays the Dynamic selections group box.

5. Enter the reference document category MIVO and save your entry with .

6. The Display Commitment Line Items for Projects screen appears.

7. Use to run the report.

For more information, see Commitments Management [Page 190].

Results
You receive a list of all fund commitment documents that fulfill the specified selection conditions.
Requesting an Adjustment Posting from the Intranet (AC)

Purpose

You can request an adjustment posting from the Intranet. You do not have to know the name of the processor, since the system automatically determines it. The request is transferred to the SAP R/3 System and can be processed there with the functions of the message processing.

You can call up the request form

- From the employee Workplace [Ext.] launchpad
- From line item reports [Ext.] in Controlling (CO)
- From line items for vendor/customer [Ext.] and G/L accounts [Ext.]
- From the general document display in Controlling [Ext.] (CO)
- From the general document display in Financial Accounting [Ext.] (FI)

You can call up the reports and the document display from the workplace as well as in the SAP R/3 System.

Prerequisites

- You have defined the process for requesting an adjustment posting in a scenario and have entered the name of the processor in the SAP System.

  To do so, in Customizing choose Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing → Request for an Adjustment Posting → Define Own Scenarios For The Request For An Adjustment Posting [Ext.].

- You have specified from which applications (such as document display, CO line item report) the request form for adjustment postings can be accessed.

  To do so, in Customizing choose Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing → Request for an Adjustment Posting → Assign Own Scenarios For The Request For An Adjustment Posting [Ext.].

- You have set up the corresponding posting transactions for the adjustment postings.

  To do so, choose Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing → Request for an Adjustment Posting → Assign Adjustment Postings To The Scenarios [Ext.].

Process Flow

1. You call up the request form for an adjustment posting.
   a. To call up the form from the Employee Workplace launchpad, choose Create internal service request.
   b. To call up the form in the SAP System, choose Extras → Correction request.
The system transfers the data of the incorrect posting.

In the cost center line item report, you notice that an amount was incorrectly entered. However, you do not know the name of the processor. From the line item report, you access the request form for an adjustment posting by choosing Extras → Correction request.

2. You request an adjustment posting via the form in the Intranet (see Processing Request Form [Page 228])

When you send the request, the information is transferred to the SAP R/3 System. The system determines the responsible processor based on entries made in Customizing (see Define Own Scenarios For Requesting an Adjustment Posting [Ext.]).

3. The processor receives the request for an adjustment posting in their worklist or workflow inbox (see Task Processing [Page 235]).

4. The following options are available to the processor:

a. They may require additional information, should the request be incomplete. They attach a note to the requests and enter the person making the request as the processor.

b. The processor rejects the request for an adjustment posting.

c. They approve the request and makes the necessary adjustments in the SAP R/3 System.

d. They forward the request.

In the second decision level, the options a to d are available again.

In the last three cases, the processor can enter a text to explain the reason for his/her decision.

You can check the current state of the request at any time (see Status Query of a Request [Page 241]).
Requesting an Adjustment Posting from the Intranet (AC)

Request for an Adjustment Posting
Result

The adjustment posting is either completed or the request is rejected.

For more information, see the SAP Library under Cross-Application Components → Internal Service Request [Ext.].
Processing Request Forms

Use
With a request form, you can request an adjustment posting from the Intranet.
The SAP standard includes a predefined form for adjustment postings. This form is divided into various areas, but you can adjust the layout and the individual fields individually.

Prerequisites

- You first need to define in Customizing which fields are to be available on the form.
  
  See Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing Request for an Adjustment Posting → Define Own Scenarios For The Request Of Adjustment Postings [Ext.]

- You have defined the layout of the form
  a. Using the SAP@Web Studios [Ext.]
  b. Using the Web Application Builder [Ext.] in the ABAP Development Workbench

- If you access the form via Create an Internal Service Request from the launchpad of the Employee Workplace, you first have to select the right request from (see Creating an Internal Service Request [Ext.]).
Processing Request Forms

Procedure

1. Enter the data regarding the incorrect posting.
   If you access the form from the SAP R/3 System, these fields contain this information.

2. Enter a text to describe the problem.
   This is an optional entry.

3. If you know the name of the processor for this problem, enter it in the processor field.
   If a processor or a standard role was entered in Customizing, these fields contain the corresponding entries. The partner role setting in Customizing controls whether an individual employee or a department is entered as the problem processor. You can find additional information about roles in Defining Roles based on Responsibilities [Ext.].

   !
   If an entire department was entered as the processor, you cannot overwrite the Processor field. The system displays a list of the processors.

4. The fields for Created by contain your data.

5. Check your entries.

6. Send the request.
   Confirm the message, that your request has been saved.

Result

The request is transferred to the SAP R/3 System and assigned to a processor.
Processing a Request in the SAP System

Use
You have made one of the following requests using an Intranet/Internal request form:

- Request Change to Master Data [Ext.]
- Request an Adjustment Posting [Page 225]

The request is automatically transferred to the SAP System and assigned to a processor.

Integration
The system creates a message [Ext.] when the request form is sent. The following functions are available for processing messages [Page 231] in the SAP System.

- Task processing [Page 235]
  The following jumps to the following activities are available in task processing:
  - Access to the request form
  - Access to the processing transactions in the SAP R/3 System
    that were set up in Customizing for the related requests.
    
    See Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing → Request for a Master Data Change (Request for an Adjustment Posting) → Define Own Scenarios For The Request For Master Data Change [Ext.] (Define Own Scenarios For The Request For Adjustment Postings [Ext.]).

- Status query [Page 241]
- Document Flow Display [Page 238]
  The document flow display is only relevant for the request for an adjustment posting.

Activities
To call up the functions for message processing, in the SAP Easy Access Menu choose Office → Message.

💡
You can find additional information about messages in the SAP Library under Cross-Application Components (CA-NO) → Messages [Ext].
Processing Notifications

To process the internal service request [Ext.], you can do the following:

- Processing notifications [Page 232]
- Processing notifications using the worklist [Page 234]

You call up processing via:

- Office → Notification → Worklist → Notifications or
- Office → Notification → Change
Process Notification

Use

Put notification in process
Once you have created a notification and entered all relevant information, you can put the notification in process. When you put a notification in process, you release the notification for processing.

A notification can be put in process in the following ways:

- You can put a notification in process manually.
- The system puts a notification in process automatically if an order was created for the notification.

When a notification is put in process, the system changes the status of the notification from "outstanding" (OSNO) to "notification in process" (NOPR).

Postpone notification
In some cases, it may be necessary to delay the processing of a notification (for example, if the assigned tasks cannot be carried out yet).

Using this function, you can postpone the processing of a notification. When you postpone a notification, it receives the status NOPO (notification postponed).

💡
You cannot postpone a notification that has already been put in process.

Complete notification
You complete a notification when the problem has been solved and no further processing is necessary. Once you complete a notification, you can no longer change any data in the notification. You can then only display the notification.

When a notification is completed, it receives the status NOCO (notification completed).

💡
You cannot complete a notification if outstanding tasks still exist in the notification.

Categorizing a notification problem
When you complete a notification, the system displays a dialog box with the current date and time. You can accept the displayed date and time as the completion time or you can change it. In this dialog box, you must specify whether the problem arose because of an internal or external cause. For example, if a vendor delivers a defective product, you are dealing with an externally caused problem.

Put notification in process again
You can put a completed notification in process again, if you determine that additional processing is necessary.

Archive completed notification
Process Notification

Completed notifications are automatically archived and are deleted from the database after a specific, predefined time interval. This time interval is defined in Customizing. Therefore, make sure you have finished processing the notification before you complete it.

Delete notification

In some cases, you may want to delete a notification. You cannot, however, delete a notification directly. You must set a deletion flag in the notification which identifies it as one that can be deleted.

A company typically runs an archiving program at regular intervals. This program searches for the notifications with deletion flags, converts the deletion flags to deletion indicators, and copies the notifications to an archive. The system then deletes the notifications from the database.

Before you delete a notification, make sure that it is no longer needed.

Once you set a deletion flag for a notification, you can no longer change the data in the notification. It then receives the status Deletion flag and Completed. You can now only display the notification. For more information about notification statuses, see Status Management [Ext.].

If you set a deletion flag in the notification header, the system also sets deletion flags for the individual notification tasks.

You can cancel the deletion flag as long as it has not been converted to a deletion indicator. You can then put the notification back in process and change or display it in the usual manner.

Procedure

<table>
<thead>
<tr>
<th>Desired processing type</th>
<th>What you should know</th>
</tr>
</thead>
<tbody>
<tr>
<td>Put notification in process</td>
<td>Call up the notification in the create or change mode and then choose Notification → Functions → Put in process.</td>
</tr>
<tr>
<td>Postpone notification</td>
<td>Call up the notification in the change mode, choose Notification → Functions → Postpone, and then save the notification.</td>
</tr>
<tr>
<td>Complete notification</td>
<td>Call up a notification in the change mode and choose Notification → Functions → Complete. Specify the completion date/time and the cause of the problem; then close the dialog box and save the notification.</td>
</tr>
<tr>
<td>Delete notification</td>
<td>To set a deletion flag, call up the notification in change mode and then choose Notification → Functions → Deletion flag → Set.</td>
</tr>
<tr>
<td></td>
<td>To reset the deletion flag, choose Notification → Functions → Deletion flag → Deselect.</td>
</tr>
</tbody>
</table>
Processing Notifications Using Worklist

Use
Using the worklist for notifications, you can select notifications on the basis of different criteria and process them. You can select the notifications as follows:

- You select the notifications using the *My worklist* function. The system then displays the following notifications for further selection and processing:
  - All notifications to be processed by you as the "person responsible" or that fall within your department's area of responsibility
  - All notifications to be processed by you as a <Partner function>
  - All notifications you created
  - All notifications that were last processed by you
- You select the notifications using the *General selection* function. The system then displays all notifications for further selection and processing. Make sure the preset selection criteria contain the values you want (for example, notification status, selection period).

Prerequisites
If you use the *General selection* function and you want to process notifications for which you are not responsible or which you did not create, you must have the corresponding authorization.

Activities
You choose *Logistics → Central Functions → Notification → Worklist → Notifications* to call up the worklist for notifications.

You enter the required data and choose *Execute*.

See also:
*Select and Process Notifications Using Worklist [Ext.]*
Task Processing

Purpose
Using the functions for task processing, you can change or display the tasks in a notification independently of the notification itself. In this way, you can:

- Process tasks quickly and easily
- Execute tasks using the functions of the action box
- Access the information in the associated notification at any time

Process Flow
2. You process the tasks using one of the following options, depending on your job duties or method of working:
   - Worklist [Page 236]
     You call up the worklist for tasks to determine whether tasks exist that you must process.
   - Workflow [Page 237]
     You check your workflow inbox determine whether tasks exist that you must process.
   - Functions for Task Processing [Ext.]
     If you want to process a specific task in a specific notification, use the transactions for processing or displaying a task.
3. After you have selected and executed one of the above options, you process a task by either:
   - Forwarding the task to another person, if you cannot process the task yourself
   - Carrying out the instructions specified in the task
   - Documenting the information for a task that has just been executed; for example, as a task long text or via a follow-up function in the action box (internal remark)
   - Setting the status of the task to "completed," once you have carried out the instructions specified in the task
   - Executing additional follow-up functions in the action box, if additional tasks need to be implemented

Result
Once you have processed and completed a task, you can complete the notification (provided there are no other tasks in the notification that need to be processed).
Processing Tasks Using Worklist

Use

Using the worklist for tasks, you can select notification tasks on the basis of different criteria and process them. You can select the tasks as follows:

- You select the tasks using the My worklist function. The system then displays the following tasks for further selection and processing:
  - All outstanding tasks to be processed by you as the "person responsible"
  - All tasks to be processed by you as a <Partner function>
  - All tasks you created
  - All tasks you completed

- You select the tasks using the General selection function. The system then displays all tasks for further selection and processing. Make sure the preset selection criteria contain the values you want (for example, selection period, outstanding tasks only).

Prerequisites

If you use the General selection function and you want to process tasks for which you are not responsible or which you did not create, you must have the corresponding authorization.

Activities

You choose Logistics → Central functions → Notification → Worklist → Tasks to call up the worklist for tasks.

You enter the required data and choose Execute.

See also:

Select and Process Tasks Using the Worklist [Ext.]
Processing Tasks Using Workflow

Use

If a task is created in a notification or if the person responsible for a task is changed, the system can automatically notify the person or department responsible via the SAP Business Workflow that a task needs to be processed.

You receive the information about the task that needs to be processed as a work item in your inbox (Business Workplace). Your inbox provides an overview of all tasks that you are responsible for processing. You can begin processing the work item directly from your business workplace.

Integration

You can access your business workplace by choosing Office → Workplace from the SAP menu. Then choose Inbox → Workflow to display any work items that may be present.

Prerequisites

The required system settings to activate the SAP Business Workflow have been made.

Activities

If there is a work item in your inbox, proceed as follows to begin processing the work item:

- You double click the work item to display a description of the task to be executed.
- You choose Execute to process the work item. The system calls up the transaction to process the task.
Document Flow

Use
You can use this function to display the document flow for a notification as a list or network graphic. The document flow allows you to identify:

- Preceding documents (documents from which the current notification originated)
- Subsequent documents (documents that originated from the current notification)
- "To-and-from" references between documents

Each document contains the following information:

- Document number
- Document number
- Additional data (if available)
- Logical system (if any of the other documents was created in a logical system other than the one in which the original notification was created)

You can also display the detailed information for each document.

Integration
The document flow is integrated in the following processes:

- Materials Management (MM)
- Production Planning and Control (PP)
- Sales and Distribution (SD)
- Customer Service (CS)
- Plant Maintenance (PM)
- Financials (FI)
- Controlling (CO)
- Project System (PS)

Features
The document flow, for example, can display the following objects (among others):

- Quality notification
- Service notification
- Maintenance notification
- General notification
- Claim
- Service order
Document Flow

- Sales order
- Production order
- Run schedule header
- Goods movement
- Purchase order
- Inspection lot
Displaying the Document Flow for a Notification

Procedure

3. Call up a notification in the create or change mode.

4. Choose one of the following menu paths, depending on whether you want to display the document flow as a list or graphic:
   - Extras → Notification documents → Document flow → List
   - Extras → Notification documents → Document flow → Graphic

   The notifications that reference other subsequent documents in the list display are labeled with a (Ref.) designation.

4. If you displayed the document flow as a graphic, select a document and choose Goto → Display document.

   The detailed information for the selected document is displayed.
Status Query For Request

Use
You can call up the status of the request at any time during its runtime.

See also:
Status Management For Notifications [Ext.]
Display Status Information [Ext.]
System Status Assignment [Ext.]
Assigning And Changing User Statuses [Ext.]
Status Management For Tasks [Ext.]
Automatic and Periodic Allocations

Purpose

As you plan and execute your project, you carry out periodic processing to determine all the project-specific data and make it available for Enterprise Controlling.

Periodic processing covers both plan data (allocations) and actual data (period-end closing).

See also:

- Periodic Allocations [Page 243]
- Period-End Closing in Projects [Page 245]

Integration

Archiving orders for projects

You can archive orders for projects at an early stage. However, the order values remain available for display in the project information system, because they are updated in the WBS element to which the orders are assigned.

For more information, read the orders for projects [Page 86] documentation.

No settlement information is evaluated in resource-related billing. The line-item information is evaluated in the objects originally charged. If you delete orders which have not been settled in full, this information is lost.
Periodic Allocations

Purpose
Periodic allocations are used to determine all the planned data to be considered for a period, and to make it available for enterprise planning.

Implementation Considerations
The functions and processes are largely the same as for overhead cost controlling. For more information, refer to the documentation for internal orders.

Features

<table>
<thead>
<tr>
<th>Function</th>
<th>Use</th>
<th>See also:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic repostings in planning</td>
<td>Correction postings in the project - for example, if a shift in dates leads to planned costs being incurred in different periods.</td>
<td>Periodic repostings in planning [Ext.]</td>
</tr>
<tr>
<td>Planning overhead</td>
<td>Allocation of planned overhead in the WBS element.</td>
<td>Planning Overhead [Ext.]</td>
</tr>
<tr>
<td></td>
<td>In addition to the flat rate distribution of overheads in proportion to the unit costs, you can also determine overhead using template allocation.</td>
<td>Template Allocation of Plan Values [Ext.]</td>
</tr>
<tr>
<td></td>
<td>In template allocation, the system distributes the overhead using precisely defined business processes or cost centers/activity types.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>In networks, the system automatically determines the overhead as part of costing and records it in the header or activity.</td>
<td></td>
</tr>
<tr>
<td>Project planned interest calculation</td>
<td>Inclusion of costs for tied-up capital to improve planning quality.</td>
<td>Planned interest calculation [Page 276]</td>
</tr>
<tr>
<td></td>
<td>Particularly in capital-intensive projects, you can use the planned interest calculation to achieve the best possible cost/revenue distribution in your project.</td>
<td></td>
</tr>
<tr>
<td>Planned results analysis for projects</td>
<td>Periodic valuation of the planned project result.</td>
<td>Planned Results Analysis [Ext.]</td>
</tr>
<tr>
<td></td>
<td>Planned results analysis normally takes place in the billing element.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>You can settle the planned operating result so determined to Profitability Analysis.</td>
<td></td>
</tr>
</tbody>
</table>
### SAP AG Costs

#### Periodic Allocations

| Planned settlement and planned data transfer for projects | Used to allocate planned costs to cost centers, business processes, or profitability segments for a view over the whole business - for example, to determine planned prices in cost centers. The planned settlement is only available for plan-integrated objects. Objects which are not plan-integrated are settled to Profitability Analysis using the planned date transfer. | Settlement of orders and projects [Ext.] |

To access the various activities, choose **Logistics or Accounting → Project System → Financials Planning → Allocations.**

**Planned Result Simulation and Planned Data Transfer**

Data from the simulation is settled to Profitability Analysis as follows:

- **Using the plan settlement**
  - If both the sender WBS element and the CO version to be settled are plan-integrated.

- **Using the planned data transfer**
  - If either the sender WBS element or the CO version to be settled is not plan-integrated.

Only the results analysis objects are included in the transfer. There is no additional credit in the project. The planned data transfer is used to provide a detailed basis for annual planning in profitability analysis. You should execute it no more than once a year.

You access it in the Profitability Analysis menu by choosing **Planning → Integrated planning.**

💡 You have maintained a settlement rule for actual settlement to profitability analysis. The first time you run the planned settlement or planned data transfer the system automatically uses this settlement rule if there is no separate one for planned settlement. This means it is not necessary to define a separate rule for planned settlement.
## Period-End Closing in Projects

### Purpose

Period-end closing is the framework for carrying out period-related commercial transactions. You use it to ensure that all the data belonging to a period is determined and that data is available for enterprise controlling purposes.

### Implementation Considerations

The functions and processes are largely the same as for overhead cost controlling. For more information, refer to the documentation for internal orders.

### Features

<table>
<thead>
<tr>
<th>Function</th>
<th>Use</th>
<th>See also:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic transfers</td>
<td>Correction of incorrect postings in the project</td>
<td>Periodic Repostings [Ext.]</td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>The system uses the planned price to value activities or business processes called in as part of project processing. The actual price is not determined until the period-end closing phase. You carry out the revaluation to determine the actual costs based on actual prices.</td>
<td>Revaluation at Actual Prices [Ext.]</td>
</tr>
<tr>
<td>Overhead</td>
<td>So that materials, personnel, and machines are made available, the system calculates the overhead on a quantity basis or proportional to the unit costs.</td>
<td>Overhead [Ext.]</td>
</tr>
<tr>
<td>Template allocation of overhead</td>
<td>While overhead is distributed flat rate, template allocation distributes overhead from business processes or cost centers/activity types.</td>
<td>Template Allocation of Actuals [Ext.]</td>
</tr>
<tr>
<td>Payment transfer</td>
<td>The system uses this function to update payments and partial payments in Project Cash Management.</td>
<td>Transferring Payments [Ext.]</td>
</tr>
<tr>
<td>Interest calculation</td>
<td>Valuation of funds commitments using costs, revenues, or payments, and to achieve the best possible project payment flow.</td>
<td>Interest Calculation</td>
</tr>
</tbody>
</table>
Period-End Closing in Projects

<table>
<thead>
<tr>
<th>Results analysis</th>
<th>Periodic valuation of the project result. You can use results analysis to WBS element costs which can be capitalized and set up provisions. Results analysis normally takes place in the billing element.</th>
<th>Results Analysis [Ext.]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Incoming order values</td>
<td>The system uses this function to determine the costs and revenues expected to arise from orders closed or changed in the current period. You can evaluate the values for incoming orders and open orders in the project information system and can settle them to Profitability Analysis.</td>
<td>Project-Related Incoming Orders [Ext.]</td>
</tr>
<tr>
<td>Settlement</td>
<td>The system settles some or all of the actual costs incurred in the project to one or more receivers. In the process, offset entries crediting the project are generated automatically. If you have already carried out results analysis, you can capitalize the costs capable of being capitalized by settling them to Financial Accounting.</td>
<td>See Project Settlement [Page 247]</td>
</tr>
</tbody>
</table>

Period-end closing work is made much easier if you use the Period-End Partner (PEP).

See PEP Log.

The various period end activities can be found in the menu option *Period-end closing* in the *Project Execution* menu.
Project Settlement

Purpose
Costs and revenues are collected in projects only temporarily. They are settled to one or more receivers as part of period-end processing.

You use settlement to:

- Capitalize the balance from results analysis which is capable of capitalization in the balance sheet.
- Obtain detailed data in results analysis for enterprise controlling.
- In capital-investment measures, to settle the charge to assets under construction which can or must be capitalized.
  
  See also Settlement Functions [Ext.] for capital investment.
- Include actual costs from the project in actual price calculation in Cost Center Accounting.

Integration
You cannot transfer settlement rules to simulation versions or maintain them there.

You use the settlement profile to define the following for actual costs:

- Must be settled in full
- Can be settled
- Must not be settled

Depending on the settings in the settlement profile, you must settle the costs of an object in full before you can archive it.

Prerequisite
A system status which allows settlement must be set for the objects you want to settle.

You must also maintain a settlement rule in each sender before you can settle a project.

You define the settlement criteria in the project master data.

- Settlement profile
  
  You maintain profiles in the Project System IMG. You store the settlement profile in the project profile or in the network type. It then acts as a default value for the individual objects. The profile regulates, for example, whether settlement is allowed, prohibited, or required.

- Settlement rule
  
  You must enter a settlement rule for each object you want to settle. The settlement rule contains the receiver, the apportionment rule, and other settlement parameters. You can change the profile settings in the settlement rule parameters for an object.

- Results analysis key
If you only want to settle amounts from results analysis, you must maintain results analysis keys for the relevant objects. The key contains all the control data necessary for results analysis.

**Features**

Settlement is the process where the actual costs incurred for a WBS element, network, or activity are allocated, in whole or in part, to one or more receivers. In the process, offset entries crediting the project are generated automatically. The debit postings remain in the receivers after settlement. You can display them in the information system. The settled costs are recorded in the relevant receiver, and you can evaluate them in reporting.

You have the following options for settling objects within a project (WBS elements, orders, networks, activities):

- **Direct settlement**
  
  Each object is settled directly to the external cost object (examples: cost center, profitability segment).

- **Multi-level settlement**

  You settle individual objects in the project to the higher-level WBS element first. This then settles the costs collected to the external receiver.

  ![Lightbulb](Image)

  Do not use multi-level settlement for the phased roll-up of values within the project hierarchy.

Failure to do this may lead to incorrect cost figures being displayed for the higher-level WBS element in the Project Information System. The structure overview and hierarchy reports take account of internal settlements. To ensure consistent reporting, note the following:

- You must always settle WBS elements to the element directly above them in the hierarchy.
- You must always settle orders, suborders, networks, and activities to the relevant WBS element.
- Do not move the settled objects.

**Hierarchy Structure and the Effects on Values Displayed [Ext.]**

![Lightbulb](Image)

Check whether your project needs multilevel settlement. The documents also generated for settlement to the interim receivers may adversely affect system performance during settlement, in the information system, and in archiving.

Which of these you use depends on the project type. We recommend that you have the system generate the settlement rule.

See also:

- Settlement in overhead cost projects [Page 251]
- Settlement in capital investment projects [Page 252]
- Recommendations for customer projects [Page 253]
Project Settlement

As settlement rule maintenance can be very time consuming if the project hierarchy structure is complex, we offer the following support:

- **Automatically Generated Settlement Rules [Page 254]** in WBS elements
- Strategy for generating settlement rules in networks
- **Consistency Check on Master Data/Settlement Rule [Page 259]**
  
  You can use this report profile to check, among other things, the settlement rule in the billing element according to particular criteria.

The settlement logic is the same throughout the various SAP applications.

For more information on settlement, read **CO - Settlement [Ext.]**.
Project Settlement Recommendations

You have the following options for settling objects within a project (WBS elements, orders, networks, activities):

- **Direct settlement**
  
  Each object is settled directly to the external cost object (examples: cost center, profitability segment).

- **Multilevel settlement**
  
  You settle individual objects in the project to the higher-level WBS element first. This then settles the costs collected to the external receiver.

  ![Tip]

  Multilevel settlement circumvents the danger of incorrect values being displayed in reporting. Do not use multilevel settlement for the phased roll-up of values within the project hierarchy.

Multilevel settlement may cause incorrect cost figures to be displayed for the higher-level WBS element. In multi-level settlement, the system takes account of elimination of internal business volume in the structure overview and hierarchy reports only if you:

- Always settle WBS elements to the element directly above them in the hierarchy.
- Always settle orders, suborders, networks, and activities to the relevant WBS element.
- Do not move the settled objects.

**Hierarchy Structure and the Effects on Values Displayed [Ext.]**

Check whether your project needs multilevel settlement. The documents also generated for settlement to the interim receivers may adversely affect system performance during settlement, in the information system, and in archiving.

Which of these you use depends on the project type. We recommend that you have the system generate the settlement rule.

See:

- [Settlement in Overhead Cost Projects [Page 251]]
- [Settlement in Capital Investment Projects [Page 252]]
- [Recommendations for Customer Projects [Page 253]]
Recommendations in Overhead Cost Projects

When choosing the settlement type for overhead cost projects, bear the following in mind:

- **Plan integration**
  
  If plan integration is active, you can only settle to cost centers in one go. Multilevel settlement is not supported by plan integration.

- **Data volumes**
  
  The volume of settlement information in direct settlement is much less than in multilevel settlement because no additional settlement is made to interim receivers.

- **Settlement statement**
  
  Direct settlement leads to very detailed information in the settlement receiver page on the object from which the costs were settled.

- **Reassigning objects in projects**
  
  The type of settlement you choose has an effect on how the values are displayed in reporting.
  
  In multilevel settlement, responsibility for the settled costs passes to the receiver. If you then move the settled object, the system displays the costs correctly in the settled object, and shows the amount not yet settled in the superior cost element. The reason for this is the logic for the elimination of internal business volume. Internal business volume is not eliminated until you call up the report, and usually takes place in the project higher up in the hierarchy display.
  
  To avoid errors you should not shift any objects after settlement.
  
  In direct settlement, for example settlement of WBS elements to cost centers, responsibility for the costs in the settlement object. As a result, the system continues to show the total cost amount even after the object has been shifted.

- **Maintenance effort, change service, and error tolerance**
  
  If you have maintained an incorrect settlement receiver as the final cost object, there will be a lot of maintenance work in direct settlement because you have to edit several objects.
  
  If you are using the automatically generated settlement rule [Page 254], the system generates a settlement rule to a profitability segment, manager, or requesting cost center. This significantly reduces the maintenance work involved in direct settlement.

We recommend that you use direct settlement in overhead cost projects.
Recommendations in Capital-Investment Projects

In addition to the aspects described in Recommendations for Overhead Cost Projects [Page 251], you must consider the following for capital investment projects:

- **Object retention period in projects**
  
  In direct settlement, the settlement senders must, for verification reasons, exist for as long as the asset is under construction. This can delay project reorganization for several years.
  
  However, in multilevel settlement, earlier reorganization of orders is possible after they are settled completely.

- **Data volumes**
  
  When you settle to assets, the system generates both CO settlement documents and FI postings. There are a lot more of these postings in direct settlement than in multilevel settlement.

- **Runtime**
  
  The fewer objects in the project, the better the performance of the project functions. If your project has a long runtime, you should reorganize the orders at regular intervals.

In capital-investment projects, multilevel settlement is preferable to direct settlement.

A basic rule to follow is that you first settle all the costs to the WBS elements which are flagged for the capital-investment measure. You can then use these WBS elements as the base for capitalization in the asset under construction, and for settling components which cannot be capitalized to receivers outside the project.

For more information on settling capital investment projects, read CO - Capital Investment Management [Ext.].

- **In the case of WBS elements flagged as capital investment measures, you must carry out separate settlement runs for costs which can be capitalized and costs which cannot. To this end, conduct settlement periodically and by cost element.**

- **You must settle the costs of orders assigned to projects which are capital investment measures directly to the final receivers.**
Recommendations in Customer Projects

In customer projects, the actual costs are settled, but accrued amounts (such as costs of sales or inventory from which revenue can be generated) are not. You carry out this settlement at billing element level.

For customer projects which you settle in full to Profitability Analysis, it is a good idea to generate the settlement rule using a strategy defined in the IMG. The standard system we deliver includes a strategy for automatically generated settlement rules [Page 254] for customer projects.

The system uses this strategy to generate the following:

- For all billing elements:
  - Results analysis key
  - Settlement to profitability segment
  - A settlement profile providing for settlement in full

- For all other WBS elements
  - No results analysis key
  - A settlement profile providing for no settlement

If account assignment elements within a billing structure do not contribute to the cost of sales, you can change the settlement rule manually.

If you maintain the settlement rule manually, we recommend you proceed as follows:

- Use a project profile with a settlement profile that forbids settlement. This initially prevents settlement for all the WBS elements in the project.

- Change the settlement profile in the billing elements manually. Define a settlement profile that permits settlement.

- If you want to settle account assignment elements (in whole or in part), you must change the settlement profile for account assignment elements manually.

You change the settlement profile in the settlement rule for the object by choosing Goto → Settlement parameters. There is a parameter in the settlement profile which you can use to define whether settlement is forbidden, allowed, or required.

Avoid making settlements within the project hierarchy. These can adversely affect system performance.

For more information on settling customer projects, refer to Settlement in Product Cost Controlling [Ext.].
Automatically Generated Settlement Rules

Purpose
Experience has shown that manual settlement rule maintenance for very complex project hierarchy structures is very time-consuming and brings with it the risk of inconsistent characteristics in settlement of customer projects to the profitability segment. The system uses automatic generation to create the settlement rule and parameters, in accordance with the strategy defined in the IMG. The type of planning decides which strategy applies to which object:

- Planning element
- Account assignment element
- Billing element
- WBS element with change of organization re the superior WBS element

Prerequisite
You must define the strategy for automatic settlement rule generation in the WBS element using the Project System IMG.
You must also define a strategy in the project profile you are using.
WBS elements from capital investment projects assigned to capital investment measures are excluded from settlement rule generation.

Process Flow
1. To generate settlement rules automatically, choose Logistics or Accounting → Project System → Financials → Period-End Closing → Individual Functions → Settlement Rule. See also Generating Settlement Rules [Page 256].
2. The system selects the objects according to the selection criteria in the database.
3. Using the project profile, the system determines which strategy to use for automatic rule generation. In line with the strategy, the system generates:
   - The settlement profile for the WBS element
     This determines, for example, which receivers are allowed for settlement
   - The results analysis key in the WBS element control data
     This stipulates how valuation and results analysis take place.
   - The settlement rule for the WBS element
     In the settlement rule, you stipulate the apportionment rules and settlement parameters. The system generates the actual settlement rule.
   - Characteristic derivation for settlement to profitability segments
As a rule, the system generates a periodic settlement of 100% to the receiver entered in the strategy. You can stipulate the following account assignment categories in the strategy.
   - Settlement to profitability segment
Automatically Generated Settlement Rules

- Settlement to the responsible cost center
- Settlement to the requesting cost center
- Adopting the settlement rule from the superior object
- No settlement

4. For settlement to profitability segments, the system determines the characteristics per the derivation rule defined in the Profitability Analysis (CO-PA) IMG as follows:
   - From the master data for the assigned sales order (if there is one)
   - From the WBS element

   When determining the profitability segment for the account assignment, the system runs the standard derivation, including the customer enhancements in Profitability Analysis.

Result

The system generates the settlement rule and its parameters in the object master data.

Settlement rules generated automatically are updated under the SRGN commercial transaction. You can use a user status to forbid later changes to a settlement rule by automatic settlement rule generation.

You can change the rule generated automatically later in the project master data.
Generating Settlement Rules

Use
If the settlement rules for a project can be represented using a strategy, this function supports your settlement rule generation work.

Automatic settlement rule generation is a particularly good idea:
- In the case of direct settlement for each WBS element, to reduce maintenance work
- In settlement to profitability segments, it reduces the likelihood of errors when characteristics to determine the segment are derived.
  In complex customer projects with more than one settlement object, manual maintenance may lead to inconsistencies in the characteristic derivation for settlement to profitability segments. In the automatically generated settlement rule, the system uses the project master data and accompanying sales order item as the basis for deriving the characteristics.

You should generate the settlement rules periodically, as part of period-end closing.

Automatic settlement rule generation is integrated with the period-end partner.

Prerequisite
Automatic settlement rule generation is not available for capital-investment projects. WBS elements in whose control data a capital investment profile with accompanying measures has been maintained are not included in settlement rule generation.

However, WBS elements which are used only for the depreciation simulation (that is, they are not assigned to a capital investment measure) are included.

Procedure
1. Choose Logistics or Accounting → Project System → Financials → Period-End Closing → Single Functions → Settlement Rule → Individual processing or Collective processing.
2. Select one of the following objects:
   - Sales document
   - Project definition
   - WBS element
3. Select the With hierarchy indicator.
   The system then selects the subtree for the WBS element specified and processes all of it. Otherwise, a settlement rule is generated only for the WBS element specified.
4. Enter the Period and Fiscal year for the settlement rule change check.
   When generating the settlement rule, the system only creates a new settlement rule if one of the following parameters has changed between the existing rule and the period you enter:
   - Settlement profile
Generating Settlement Rules

- Settlement receiver

5. Select the process control fields you require: The following options are available:

- Background processing
- Test run
- Detailed lists

6. Choose.

Result

Depending on the process control settings, the system outputs either a simple log or a detailed list.

The log contains information on:

- Selection criteria and process control
- Number of objects processed
- Processing category

For each object, the detailed list shows the strategy used and the strategy settings. In update runs, you can branch from the detailed list to the settlement rule for the object, by choosing Master data.

When generating the settlement rule, the system checks whether there is already a valid settlement rule for this object and period.

The system proceeds, depending on the account assignment category:

1. Categories 1-3:

   - No valid settlement rule exists
     The system generates the following in the WBS element master data:
     - Settlement profile
     - Results analysis key
     - Settlement rule
     The system creates a settlement rule for the current period, with unrestricted validity.

   - A valid settlement rule exists
     The system verifies that the valid settlement rule satisfies the strategy:
     - Satisfies the strategy
       The system does not generate a new settlement rule. The rule is flagged Old in the detailed log.
     - Does not satisfy the strategy
       The system limits the validity of the existing rule to the period between the time it was first used and the time it was last used. It creates a new rule applying from the subsequent current period, with unrestricted validity.

2. Category 4:
No valid settlement rule exists
   The system generates the following in the WBS element master data:
      - Settlement profile
      - Results analysis key
      - Settlement rule
   The system creates a settlement rule for the current period, with unrestricted validity.

A valid settlement rule exists
   The system generates an error message and does not generate a settlement rule.
Consistency Check on Master Data/Settlement Rule

Use

You can use this report program to conduct consistency checks (master data reconciliations) between sales orders and projects.

The check is between sales documents, billing elements, and billing element settlement rules.

Features

The following checks are possible:

- Unique SD-PS assignment
  Only one sales document item per sales document type may be assigned to a WBS element.

- Check settlement rule

The system checks the settlement rule per the criteria you enter. You can specify the following criteria:

- Settlement to only one settlement receiver
- Settlement to Profitability Analysis only
- Characteristics in the settlement rule

The system checks that the characteristics in the billing element settlement rule are consistent with other objects.

- Validation
  If you have selected a validation for the report program, this is triggered in the course of the check on a sales document against the relevant billing element.
  
  For more information on the validation, go to the R/3 Library and choose Financial Accounting -> Special Ledger, chapter “Validation and Substitution”.

- Objects to be checked
  In the selection screen, you specify the type of check to be carried out on the individual objects. The options are:
  
  - No check
  - Check consistency only
    If an object exists, the system checks the consistency of the fields/characteristics selected from the sales document, billing element, and, if required, the billing element settlement rule.
  - Check consistency and existence
    If no object exists, the system displays an appropriate message. Otherwise, it moves on to the consistency check.
    
    The relevant billing elements are always checked.

- Fields/characteristics to be checked
Consistency Check on Master Data/Settlement Rule

The fields/characteristics you have selected, such as business areas or profit centers, are checked in the relevant objects.
In the selection, it does not matter whether all the fields appear in the sales documents and billing elements to be checked, nor need all the characteristics appear in the relevant settlement rules.

See also: Example: Consistency Check and Validation [Ext.]

Activities

When the consistency check is complete, the system outputs a log which shows, among other things, the errors and inconsistencies found. You access this by choosing Log.

You can branch from the log directly to the object affected, to scrutinize the errors and correct them as necessary.
**Interest Calculation**

**Use**

The interest calculation is an important feature of long-term projects. The SAP System offers a tool for calculating planned and actual interest. Use of the planned interest calculation improves the quality of your planning. The actual interest calculation calculates the interest on posted costs, revenues, and, where appropriate, payments. Both the planned and actual interest calculations calculate the interest on balances.

The following data is included in the planned interest calculation:

- Planned costs, planned revenues, and planned payments in projects
- Planned costs and planned revenues in internal orders that do not reference projects.

Planned interest is recorded:

- By period, for planned costs and planned revenues
- To the day, for planned payments, if planned line items are written for the planned payments

The following data is included in the actual interest calculation:

- Costs, revenues, and payments in projects
- Costs and revenues in internal orders and capital investment orders that do not reference projects.

You can choose whether the actual interest is recorded by period or to the day.

**Integration**

- Statistical WBS elements
  
  The system calculates interest for statistical WBS elements and posts it in the balancing object [Ext.]. That is, the update is not statistical.

- Currency
  
  Interest is calculated in the controlling area currency. The transaction currency for the interest calculation is identical to the controlling area currency.

- Settlement
  
  If settlement is to an irrelevant CO object, such as cost centers, the credit from settlement is not included in the interest calculation. However, if interest is calculated on the debit to the settlement receiver, it is also calculated in the balancing object.

  The graphic below illustrates the role played by the interest calculation in the elimination of internal business volume.
Interest Calculation

**Prerequisites**

For a project to be included in the interest calculation, the following conditions must be met:

**Settings in the Implementation Guide (IMG) for Controlling or the Project System:**

- Define interest indicator and stipulate conditions
- Assign cost elements and, if required, commitment items to the value categories
- Define interest profile and make detailed settings
- Define the interest relevance of the value categories for an interest profile/interest indicator combination
- Define posting profile
- Maintain a number range
- Enter period control for the compound interest calculation in capital investment projects if you want to calculate this separately.

For more information on the settings, read the documentation in the Project System/Controlling Implementation Guide (IMG).

**User Status**

The user status must allow the following transaction:

- **KZRI** - Actual interest calculation.
- **KZRP** - Planned interest calculation.

**Interest profile**

You must enter an interest profile in the control data for the project, WBS element, or order.

In the case of a project or WBS element, you can do this in one of the following ways:

- In Project System customizing:
Interest Calculation

Enter a default value in the project profile used in the project definition.

- In the Project System application menu:
  Enter the profile in the control data for the relevant project definition or WBS element.

In the case of orders, you can enter the interest profile in the model order or directly in the master data for the relevant order.

If you have entered interest calculation conditions in the interest profile, such as threshold values, the system checks these as part of the actual interest calculation run. The check is controlled by the interest profile for the balancing object.

Features

The interest calculation (planned and actual) has the following functions:

- Interest determined and posted per balancing object
  A balancing object is a CO object, such as a WBS element, in which costs, revenues, and payments are summarized, interest is calculated for them, and they are posted.

- Inclusion of
  - In the case of the actual interest calculation: value dates in the past (postings in periods for which interest is already calculated)
  - Interest rate changes during a period

- To-date balances, by calendar

- Various calendars available

- Optional compound interest calculation

- Use of FI indicators to determine interest rate

- Use of FI account determination to find posting accounts

- Customer enhancements for individual adaptation of document selection

The functions and processing logic are largely the same for both the planned and actual interest calculations. No separate settings are necessary in the IMG.

Activities

- Executing the Actual Interest Calculation [Page 273] Executing the Planned Interest Calculation [Page 280]

You can run the interest calculation in the following ways:

- Individual processing
  Here, you select a single object, and the hierarchy subject to it, for processing in the interest run.

- Collective processing
  In collective processing, you can run the interest calculation for more than one object. You can only start collective processing by means of variants.
For more information on how the interest calculation runs, see Actual Interest Calculation [Page 265]. The planned interest calculation follows the same procedure. Details of the differences can be found in Planned Interest Calculation [Page 276].

- **Hierarchy Processing and Interest Calculation Control [Page 267].**
  You use the interest profile to determine whether a balancing object takes part in the interest calculation. The interest profile controls the formation of balances in the hierarchy.

- **Canceling the Interest Run [Page 283]**
  The system always cancels the most recent interest run and, in the actual interest calculation, dates the leveling postings as of the last day in the period you specify. Alternatively, you can specify postings to the the day.
  In the planned interest calculation, all the interest postings for the specified interest period are canceled.

- **Changes to the hierarchy**
  If the balancing object is a billing element, you must cancel all interest runs before moving the billing element.
  Hierarchy changes do not significantly affect the planned interest calculation.
  See Taking Account of Changes in the Hierarchy [Page 269]

- **You can use customer enhancements to:**
  - Modify document selection
  Maintain separate control data for the interest calculation in different value categories
  - Process the interest figures calculated and transfer them to the R/3 System or an external system
  The customer enhancements are available for both the planned and actual interest calculations. In the case of the planned interest calculation, you can also use enhancements to control the finish date. For more information on settings and customer enhancements, read the documentation in the Project System IMG.
Actual Interest Calculation

Purpose

The actual interest calculation is a tool you can use in projects or orders which last several years to calculate the interest on the posted costs, revenues, and, where appropriate, payments.

Process Flow

The interest run first selects all the payment and cost line items or totals records which meet the selection criteria you have entered. This is done according to the posting dates for the documents or the payment date from the payment view.

The system determines the relevant value category from the cost element or commitment item in the document.

The interest profile defined in the balancing object controls:

- Which value categories (cost elements, commitment items) are included in the interest calculation
- Hierarchy Processing and Interest Calculation Control [Page 267].

The system uses the interest indicator defined in the IMG to determine:

- Which interest rate is relevant (detailed interest indicator setting)
- Account determination for the update

The system uses these criteria to select the interest-relevant items and calculate interest for them. You can use combinations of interest profiles and interest indicators to keep various value categories apart in the interest calculation. For example, interest on costs, revenues, and payments can be separated in this way. The system calculates the interest. Account determination is per interest indicator.

In the case of an interest calculation on totals records for capital-investment projects, the system does not check the interest relevance of value categories. The interest calculation takes account of all costs, revenues, and payments already capitalized in the asset under construction.
The system generates a source document for each interest posting. The system records the date of the last interest run for each balancing object. Interest amounts are posted on the last day of the selected period.

Depending on the settings entered in Customizing, the balance carried forward is made up of either totals records or line items. The system chooses the line items for the last four periods before the interest run. For periods longer ago than that, the system uses the totals records. For the first interest run, the line items are always used.

This has the following repercussions for line-item archiving:

- If you are using the interest calculation based on line items, line items more than four periods old can be archived.
- If you are using the interest calculation based on totals records, all line items can be archived.
- The first interest run uses the line items. If you have already archived documents before the first interest run, this may lead to an incorrect interest calculation.
Hierarchy Processing in and Control of the Interest Calculation

In the interest calculation, the system processes the hierarchy top-down. The interest profile controls how balances are formed and how interest is posted. The following settings are possible:

- **Derive automatically**
  Hierarchy processing is dependent on the project type:
  - Capital investment projects
  - Customer projects
  - Overhead cost projects

- **Calculate interest separately**
- **Do not calculate interest**

For CO internal orders, interest is calculated (or not calculated) on a balancing object basis.

**Capital Investment Projects**

The interest calculation only takes account of cost, revenues, and payments already capitalized in an asset under construction. Interest processing is per WBS element. The values from orders, network, and activities assigned to the WBS element are not included. If you want to include the values from orders for the project, you must first settle the orders to the WBS element.

In hierarchy processing, the system treats WBS elements with capital-investment profiles as if you had selected a separate interest calculation for them.

This means that the interest calculation ignores capital investment projects.

**Prerequisite Applying to Capital Investment Projects:**

You must have maintained a capital-investment profile for the WBS element.

💡

If you want to include the values from assigned orders and networks in the interest calculation, you must first settle these objects to the WBS element and then execute an interest run.

As far as the interest calculation is concerned, billing elements take precedence over WBS elements with capital investment profiles.

**Customer Projects**

Balances are formed on billing elements for the subhierarchies below them. The system updates the interest in the billing element.

**Prerequisite Applying to Customer Projects**

The project hierarchy must include at least one WBS element flagged as a billing element.

**Cost Projects**

Balances are formed and figures updated per account assignment object. Account assignment objects are:
• WBS element
• Internal order
• Plant maintenance order
• Service order
• Network
• Network activity

Prerequisites Applying to Cost Projects
The WBS element is not below a billing element in the project hierarchy. No capital-investment profile has been maintained.

Manual Settings
The manual settings you enter override the interest calculation logic derived automatically. The following alternatives exist:

• Calculate interest separately
• Do not calculate interest

In manual control, costs, revenues, and payment in subordinate objects with no interest profile play no part in the interest calculation.

Logical Interest Profile Processing
The interest profile is passed on to lower-level objects which do not have their own interest profiles within a hierarchy at the time of the interest run. Interest profile inheritance ends with manually controlled objects or WBS elements with interest profiles. The interest profile is not inherited by the subtrees below these WBS elements.

See Hierarchy Processing Examples [Page 271]
The interest calculation deals with changes in the work breakdown structure hierarchy differently, depending on the object involved:

- Account assignment elements where no interest is posted are moved. The basis values in this account assignment element have an effect on the interest balance shown in a higher-level balancing element.
  - Interest posting
    The next interest run processes the moved object in accordance with its new position. If an interest run has already taken place in the relevant period, you must cancel it. Otherwise, the interest within the period is not uniformly updated per the new item.
  - Cancellation
    The system posts the cancellation according to the hierarchy as it was at the time of the interest run being cancelled. If there has been another interest run since the hierarchy changed, you must cancel this first.

- Moving a billing element where an interest balance is formed and updated
  Only the position of the billing element in the hierarchy changes.
  - Interest posting and cancellation
    The interest posting and cancellation are treated in the same way as for the account assignment element (described above).

- You delete the billing indicator in a WBS element and flag a different WBS element as the billing element.
  - Interest posting
    The next interest run processes the WBS in accordance with the new structure. If an interest run has already taken place in the relevant period, you must cancel it. Otherwise, the interest within the period is not uniformly updated per the new item.
  - Cancellation
    Cancellation is not possible after the billing element has been changed. If you want to cancel an interest run, you must do so before changing the billing element.
Taking Account of Changes in the Hierarchy
Hierarchy Processing Examples

Example 1
You have a customer project. Automatic derivation means that the balances are formed and the update made in the billing element. You manage overhead costs which are not billed to the customer in WBS element P4 (see diagram below). You set the indicator *Do not calculate interest* so that P4 is not included in the interest calculation. This means that the interest calculation only covers P2, P3, and the assigned order.

The costs in P4 and P5 have no effect on the balance in the billing element. Only the costs in P1 and P3 have any effect.

<table>
<thead>
<tr>
<th>Object</th>
<th>Hierarchy Processing</th>
<th>Interest Calculation</th>
<th>Actual Costs</th>
<th>Balance</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Automatic</td>
<td>Yes</td>
<td></td>
<td>400</td>
</tr>
<tr>
<td>P1</td>
<td>Automatic</td>
<td>Yes</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>P2</td>
<td>Separate</td>
<td>Yes</td>
<td>150</td>
<td>150</td>
</tr>
<tr>
<td>P3</td>
<td>No interest profile</td>
<td>Yes</td>
<td>100</td>
<td></td>
</tr>
<tr>
<td>P4</td>
<td>Do not calculate interest</td>
<td>No</td>
<td>130</td>
<td></td>
</tr>
<tr>
<td>P5</td>
<td>No interest profile</td>
<td>No</td>
<td>60</td>
<td></td>
</tr>
</tbody>
</table>

Example 2
You have a cost project, meaning that interest is posted per account assignment object. The graphic below shows how the logic for WBS element hierarchy processing was maintained.
This results in an interest calculation as follows:

<table>
<thead>
<tr>
<th>Object</th>
<th>Hierarchy Processing</th>
<th>Interest Calculation</th>
<th>Actual Costs</th>
<th>Balance</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>Automatic</td>
<td>Yes</td>
<td>300</td>
<td>300</td>
</tr>
<tr>
<td>P2</td>
<td>Separate</td>
<td>Yes</td>
<td>150</td>
<td>150</td>
</tr>
<tr>
<td>P3</td>
<td>Automatic</td>
<td>Yes</td>
<td>100</td>
<td>100</td>
</tr>
<tr>
<td>P4</td>
<td>Do not calculate interest</td>
<td>No</td>
<td>130</td>
<td></td>
</tr>
<tr>
<td>P5</td>
<td>No interest profile</td>
<td>No</td>
<td>60</td>
<td></td>
</tr>
<tr>
<td>A1</td>
<td>No interest profile</td>
<td>Yes</td>
<td>60</td>
<td>60</td>
</tr>
</tbody>
</table>

P5 has no interest profile of its own and does not inherit the interest profile from the higher level WBS element, P2. This means that the interest calculation ignores P5.

Similarly, order A1 does not contain an interest profile, but it does inherit the interest profile from the higher-level WBS element (P2). This means that the interest calculation takes account of order A1.
Executing the Actual Interest Calculation

Procedure

1. Choose *Logistics* or *Accounting → Project System → Financials → Period-End Closing → Individual Functions → Individual Processing or Collective Processing.*
   - The system may ask you to enter the controlling area for which you want to carry out the interest calculation.
   - This takes you to the screen *Actual Interest Calculation: Project/WBS Element/Network.*

2. Enter the necessary data.
   - In individual processing, you can also activate an *Include orders* indicator if you want to include assigned networks or orders in your selection.
   - If you want to define the period for the interest calculation very precisely, choose *Extras → To date* and enter the appropriate date.

3. Select the process control fields you require: You can run the interest calculation in the following ways:
   - Online or in background processing
   - As a test run or a live run
   - With a detail list, showing all the interest line items

4. Choose 🔄.
   - Depending on the settings you enter, the system displays a list or asks you to schedule a background processing job.

Result

Whether you execute the interest run in test or live mode, the system outputs a log showing the update and, where appropriate, errors.

See *Update Log [Page 275]*

If errors have occurred, the system directs your attention to the error log. You access this by choosing *Goto → Messages.*

In the initial screen for the interest calculation, you can choose *Extras → Log options* which hides error messages of type /. These contain information on the processing for the interest calculation, such as the objects for which no interest profile has been maintained.

The accrued costs from the interest calculation are recorded in the balancing object as of the last day in the specified period.

The system generates a source document for each interest posting; you can display the document in the information system.

💡

Depending on the settings entered in Customizing, the balance carried forward is made up of either totals records or line items. The system chooses the line items for
Executing the Actual Interest Calculation

the last four periods before the interest run. For periods longer ago than that, the system uses the totals records.

Value dates in the past from periods for which interest has been calculated can only be included on a line-item basis. The interest amounts are recorded in the current period.
If you are calculating interest on the basis of totals records, the value dates in the past only contribute to the balance carryforward.
Update Log

The update log takes the form of a two-level list containing the following information:

- **Basic list**
  This list shows the parameter output and statistics on the number of objects processed and documents produced.

- **Detailed list Interest posting**
  - Project
  - Balancing object
  - Cost element
  - Interest amount
  Choose *Display variant* to have the system show additional fields in the detail list, such as:
    - Original document number
    - Interest calculation profile
    - Capital investment profile

You can view additional detailed information by choosing:

- **Dependent objects**
  The system displays a list showing all the account assignment objects which have contributed to the balance shown in the balancing object.

- **Interim balances**
  List of interim balances to the data, with information on:
    - Interest rate
    - Number of interest days
    - Interest amount calculated
  In the case of the planned interest calculation, the system shows the interim balances by period. Costs and revenues planned in a period lead to more detailed interim balances.
  See *Detail Display for Planned Interim Balances [Page 282]*.

- **Interest-relevant postings**
  The system displays a list of the interest-relevant line items that have contributed to the relevant interim balance.
**Planned Interest Calculation**

**Use**
You use the planned interest calculation to improve planning quality in projects and CO internal orders which either last several years or are capital-intensive.

The planned interest calculation is not available for capital-investment projects.

![Lightbulb icon]

The planned interest calculation takes no account of the hierarchically oriented planning of overall costs for projects and orders.

**Features**

The planned interest calculation offers you periodic interest calculation on balances. The balances are formed on the basis of costs, revenues, and, if required, payments planned by cost element.

The balances for planned costs and revenues are always calculated on the basis of totals records. Balances for payments are based on line items, if the system writes line items. You determine whether line items are written in the IMG, by assigning activity FIPA to a number range.

The interest calculation logic is the same as for the actual interest calculation.

See [Hierarchy Processing and Interest Calculation Control](Page 267).

![Lightbulb icon]

This means that the interest calculation includes appended orders. If you do not want this in your planned interest calculation, choose an interest profile for it that declares such orders “not interest relevant”.

The following special considerations apply to the planned interest calculation:

- Each planned interest run covers one CO plan version. You specify the CO version number in the initial screen for the planned interest calculation. Only complete versions are included in the planned interest calculation.

  ![Lightbulb icon]

  If the CO version is managed in profit-center valuation, the hierarchy display for the interest calculation is different. The interest calculation interprets the delivering WBS element in the transfer price agreement as the billing element. This may cause the system to interpret an account assignment object as the balancing object [Ext.].

- The planned interest calculation takes place for either the whole interest period, or for a more restricted period which you can enter in the initial screen.

  If you do not specify any restrictions, each planned interest run recalculates the planned interest for the whole period. The system takes account of the effects of planned changes for the whole period. If you do specify restrictions, the system takes account of planned changes only for the period you specify.

  See [Planned Interest Calculation Period](Page 278).
Planned Interest Calculation

- After successful interest runs, the system records the calculated interest in the balancing object under the cost element defined in the posting profile, under transaction KZRP.

- Simulation versions are available for the planned interest calculation. The interest calculation is based on the entries in the planned interest calculation initial screen:
  - For the current project, if you specify only one project definition.
  - For the simulation version, if you specify a project definition and simulation version.
Planned Interest Calculation Period

The duration of the interest run determines the period from which the system includes costs, revenues, and payments in the planned interest calculation.

The planned interest calculation takes place for either the whole project duration or for a more restricted period which you can enter in the initial screen. If you do not enter any restrictions, the system calculates the planned interest for the whole project duration. For performance reasons, you may choose to restrict the calculation for a period in which changes to the plan have taken place.

The planned interest calculation does not take account of changes which took place before or after the period entered.

To avoid errors, do not enter any restrictions in the first interest run.

The system determines the interest run duration for each balancing object [Ext.].

If you do not specify a start date in the initial screen, the system calculates interest from the day the costs are incurred. If you do not specify a start date in the initial screen, the system calculates interest from:

- The start date, if the costs were incurred before the start date
- The date on which the costs are incurred, if this is after the start date

The system determines the end of the interest calculation per object, according to the following priority:

- WBS elements
  - Scheduled finish
  - Basic finish date for the WBS element
  - Finish date from the initial screen
- Header-assigned networks
  - Scheduled finish
  - Basic finish date from the network header
  - Finish date from the initial screen
- Network activities
  - Scheduled finish
  - Finish date from the initial screen
- CO internal orders
  - Planned completion date
  - Finish date from the initial screen

If the finish date specified in the initial screen is before the finish date determined by the system, the system calculates the interest up to the specified finish date.
Planned Interest Calculation Period

For examples of how the interest period is calculated, see Calculating the Interest Period [Ext.].
Executing the Planned Interest Calculation

Procedure

1. Choose Logistics or Accounting → Project System → Controlling → Planning → Allocations → Interest Calculation → Individual processing or Collective processing.

   The system may ask you to enter the controlling area for which you want to carry out the interest calculation.

   This takes you to the screen Planned Interest Calculation: Project/WBS Element/Network.

2. Enter the necessary data.

   In individual processing, you can also select or specify the following:
   - Project version, if you want to calculate interest for a simulation version
   - Include orders, if you want assigned orders or networks to be included in the calculation

3. Select the process control fields you require: You can run the interest calculation in the following ways:
   - Online or in background processing
   - As a test run or a live run
   - With a detail list, showing all the interest line items

4. Choose Execute.

   Depending on the settings you enter, the system displays a list or asks you to schedule a background processing job.

Result

Whether you execute the interest run in test or live mode, the system outputs a log showing the update and, where appropriate, errors.

See Update Log [Page 275]

If errors have occurred, the system directs your attention to the error log. You access this by choosing Goto → Messages.

In the initial screen for the interest calculation, you can choose Extras → Log options which hides error messages of type /. These contain information on the processing for the interest calculation, such as the objects for which no interest profile has been maintained.

💡

In the planned interest calculation, the system always uses the totals records to reproduce the balance carried forward for costs and revenues.

Depending on the settings entered in Customizing, the balance carried forward is made up of either totals records or line items. If you opted to allow planned line items to be written (by assigning a number range to transaction FIPA in the IMG), the
Executing the Planned Interest Calculation

planned interest calculation takes place to the day, based on plan line items. If the line item update is not active, the planned interest calculation uses totals records.
Detail Display for Planned Interim Balances

In the following example, you will plan costs of $10,000 each for August and October 1999. The costs will be planned exactly by period - that is, the costs are expected to occur in the middle of August and October. This results in a planned interest calculation as follows:

- Calculation of planned interest on $10,000 from August 16 to 31.
- Calculation of planned interest on $10,000 (plus calculated interest) from September 1 to 30.
- From October 16, 1999, the planned interest calculation covers the costs expected to occur in October. This results in a planned interest calculation as follows:
  - Calculation of planned interest on $10,000 plus calculated interest from October 1 to 15.
  - Calculation of planned interest on $20,000 plus calculated interest from October 16 to 31.

The system displays the interim balance for each balancing object.

The basic finish date maintained for the balancing object is December 31, 1999. This is, therefore, the finish date for the interest calculation also.

There is a bank calendar (30 days for each month) for the example.

<table>
<thead>
<tr>
<th>Value Date</th>
<th>Balance</th>
<th>Interest Rate</th>
<th>Interest Days</th>
<th>Planned Interest</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dec 01 1999</td>
<td>20,420.16</td>
<td>10%</td>
<td>15</td>
<td>170.17</td>
</tr>
<tr>
<td>Nov 01 1999</td>
<td>20,251.40</td>
<td>10%</td>
<td>30</td>
<td>168.76</td>
</tr>
<tr>
<td>Oct 16 1999</td>
<td>20,125.35</td>
<td>10%</td>
<td>15</td>
<td>83.86</td>
</tr>
<tr>
<td>Oct 01 1999</td>
<td>10,125.35</td>
<td>10%</td>
<td>15</td>
<td>42.19</td>
</tr>
<tr>
<td>Sept 01 1999</td>
<td>10,041.67</td>
<td>10%</td>
<td>30</td>
<td>83.68</td>
</tr>
<tr>
<td>Aug 16 1999</td>
<td>10,000.00</td>
<td>10%</td>
<td>15</td>
<td>41.67</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td></td>
<td>135</td>
<td>590.33</td>
</tr>
</tbody>
</table>
Canceling Interest Runs

Prerequisites
You must first have executed an interest run.

Procedure
1. If you want to cancel an actual interest calculation run, choose Logistics or Accounting → Project System → Controlling → Period-End Closing → Interest Calculation → Individual or Collective Processing.
   If you want to cancel a planned interest calculation run, choose Logistics or Accounting → Project System → Controlling → Planning → Allocations → Interest Calculation → Individual or Collective Processing.
2. Specify a project or, in collective processing, a variant.
   If you want to cancel the planned interest in a simulation version, you must also specify the project version.
3. If you want assigned orders or networks to be included in the selection, select Include orders.
4. Specify a period and fiscal year.
   Regardless of what you enter here, the system always cancels the last interest run. The period you specify regulates the clearance posting for the cancellation run. Alternatively, you can specify the date of the clearance posting yourself by choosing Extras → To date.
   If you specify start and finish dates in the planned interest calculation, only the interest calculation from the relevant period is canceled.
5. Select the process control fields you require:
   You can cancel the interest calculation in the following ways:
   – Online or in background processing
   – As a test run or a live run
   – With a detail list
6. Choose Interest calculation → Cancel.

Result
When the cancellation has run successfully, the system generates a log similar to that for the interest run. The detail list displays only the objects where clearance postings have been made. The values posted are not displayed.
In the actual interest calculation cancellation run, the system makes a clearance posting in the objects as of the last day of the period entered in the initial screen or as of the “to” date you entered.
For the planned interest calculation, either the whole interest run is canceled or only the interest calculations from the period you specified. In the planned interest calculation, all the interest postings are canceled.