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Structures
Purpose
To be able to carry out a project in its entirety, the project goals must be precisely described and
the project activities to be carried out must be structured. A clearly and unambiguously structured
project is the basis for its planning, monitoring, control and success.

Depending on the type of project and the emphasis in project monitoring, you structure your
project in the Project System using the operative structures work breakdown structure (WBS)
and/or networks Standard structures, for example standard WBS and standard networks allow
you standardize and reuse structures and sequences of events in your projects.
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Organizational Assignments in the Project System
Use
The following gives you an overview of the organizational assignments in the project definition,
WBS elements, network headers, network activities (and activity elements), and material
components. The table shows the dependencies which exist between individual organizational
units, where the default values come from, and whether and under what circumstances values
can be changed.

The WBS elements belonging to a project definition, along with assigned networks
and network activities, must be assigned to the controlling area for the project
definition. In the same way, network activities and subnetworks must be assigned to
the controlling area in the header for the network to which they belong. The company
code(s) and business area in the WBS elements, networks, and network activities
must be in the controlling area for the project definition and/or network header.

Project Definition
The values for the project definition are copy from the template or project profile when you create
a work breakdown structure. If you create a work breakdown structure using a template but enter
a project profile different from the one in the template, you can choose whether to adopt the
default values from the template or those from the project profile.

If you make later changes to the project profile, the changes have no effect on the values taken
from the project profile and inserted into existing project definitions.

Controlling Area
Type of field Required
Default value Inherited by any new elements your create or insert

into the WBS.
Can be changed? Yes, but only when you are creating the project

definition. Once you have saved, you cannot change
the controlling area (exception: standard WBS).

(Object) Currency
Type of field Required
Default value Default value for new WBS elements

If you do not fill this field, the system copies the
company code into it.

Can be changed? Only if the controlling area does not allow different
company code currencies.

Company Code
Type of field Required
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Business area
Type of field Required field, if business area balances are managed

in the company code.

Profit Center
Type of field Optional

Plant
Type of field Optional

WBS Element
When you create new WBS elements or incorporate them into a WBS, the values from the
project definition are copied into the WBS elements.

If you change the project definition later, the changes have no effect on the values taken from the
project definition and inserted into existing WBS elements.

Controlling Area
Type of field Display
Can be changed? No

(Object) Currency
Type of field Required
Default value When you create or incorporate new WBS elements,

the value is taken from the project definition or derived
from the company code in the WBS elements.

Can be changed? Only if the controlling area does not allow different
company code currencies and if no plan/actual values,
commitments, or budget exist for the WBS element.

Company Code
Type of field Required
Operating conditions/check The company code must belong to the assigned

controlling area.
Can be changed? Different WBS elements can be assigned to different

company codes.
You cannot change the company code if plan/actual
values, commitments, or budget exist.

Business Area
Type of field Required, if business area balances are managed in

the company code.
Can be changed? You cannot change the business area if plan/actual

values, commitments, or budget exist.
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Profit Center
Type of field Optional

Plant
Type of field Optional
Operating conditions/check The plant must belong to the assigned company code.

Further Dependencies

Statistical Key Figure
Type of field Optional
Default value When you create new WBS elements, the value is

taken from the project definition.
When you use a existing WBS elements as a template
to incorporate new WBS elements, the system takes
the value from the template.

Can be changed? You cannot change the statistical key figure if plan or
actual values exist.

Integrated Planning Indicator
Type of field Optional
Default value When you create or incorporate new WBS elements,

the value is taken from the project definition.
When you create a new WBS using a template, the
system takes the value from the template.

Can be changed? Yes, until plan or actual values exist.

Object Class
Type of field Required value for new WBS elements
Default value When you create new WBS elements, the system

takes the value from the project definition.
When you use a existing WBS elements as a template
to incorporate new WBS elements, the system takes
the value from the template.

Can be changed? Yes, until plan or actual values exist.
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Network Header

Controlling Area
Type of field Display
Default value Inherited by activities and activity elements.
Can be changed? No; determined when the plant is created.

Company Code
Type of field Display
Default value Inherited as default value by new activities and activity

elements.
Operating conditions/check The company code must belong to the assigned

controlling area.
Can be changed? No; determined when the plant is created.

(Object) Currency
Type of field Required
Can be changed? Yes, until the network is released in whole or in part,

provided the controlling area does not permit different
company code currencies.
If it does, no changes are permitted. In such cases, the
currency is taken from the assigned company code.

Activities/Activity Elements in Header-Assigned Networks
The controlling area and company code are copied from the network header to the activity or
activity element.

Activities/Activity Elements in Activity-Assigned Networks

Plant
Type of field Required
Default value Default for components
Operating conditions/check Must belong to the controlling area for the network

header.
Can be changed? Yes, but only within the company code and then not

until (actual) costs or commitments exist for the
activity.

Controlling Area
Can be changed? No. Always the same as the controlling area in the

network header.
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Company Code
Type of field Display
Default value Determined from the plant.
Can be changed? No

Object Currency
Type of field Required
Default value The default value is the currency of the company code

derived from the plant.
Can be changed? Yes, until the network is released in whole or in part,

provided the controlling area does not permit different
company code currencies.
If it does, no changes are permitted. In such cases, the
currency is taken from the assigned company code.

Material Component

Plant
Type of field Required
Default value Default value from activity
Operating conditions/check Any material specified must have a material master in

this plant.
Can be changed? No
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Work Breakdown Structure (WBS)
Purpose
The work breakdown structure (WBS) is a model of the project that organizes project tasks into a
hierarchy.

•  It is the functional basis for further planning steps in a project, for example, for process
planning, cost planning, scheduling, capacity planning or costing, as well as project
control.

•  It gives you a clear picture of the project and facilitates the coordination and
implementation of the project from a management standpoint.

•  It shows the work involved in a project.
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What Makes Up a Work Breakdown Structure (WBS)?
The main objectives of the WBS are to split the project into manageable units, define basic dates,
and determine its costs.

The WBS divides the project step-by-step into structure elements. The elements are called work
breakdown structure elements (WBS elements) in the Project System.

You can structure the WBS from various viewpoints:

•  By phase (logic or process oriented)

•  By function (function-oriented)

•  By object (object-oriented)

PlanningPlanning

EngineeringEngineering Rotor shaftRotor shaft ControlsControls

MechanicsMechanics HydraulicsHydraulics

Legend

Hot airHot air
circulating rotorcirculating rotor

Jigs and fixturesJigs and fixtures EngineeringEngineering

Rotor bladesRotor bladesProductionProduction

ElectronicsElectronics

WBS element

Creating WBS Elements

Creating Project Definitions

Project Profiles

Status Management

Subprojects
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WBS Elements
WBS elements are the only structural element in work breakdown structures. They describe
either a certain task or a partial task that is subdivided further.

According to DIN 69 901 those elements in a work breakdown structure that are not
subdivided are referred to as “work packages”.

In the Project System a work package is not a data object. A work package can be
represented in the SAP System by a WBS element or an activity.
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Project Definition
The project definition is the binding framework for all organizational elements within a project.
You can also define nonbinding start and finish dates for the project.

When you create a work breakdown structure, the corresponding project definition is created
automatically.

In the project definition, you can maintain default values for a project such as the settlement rule.
The default values are copied for new WBS elements that you create for this project.
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Project Profile
A project profile is necessary to create a work breakdown structure.

The project profile contains default values and parameters for managing your project, for
example, the settlement profile, the factory calendar for scheduling, or settings for graphics.

You can maintain the values for the project profile in Customizing for the Project System.

When you create a work breakdown structure, you must enter a project profile  the project
definition. You can change default values from the project profile when you are working in the
work breakdown structure.
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Status Management
Systemstatus in Projektstrukturplänen [Page 347]

The Project System uses the status management of the R/3 System. Depending on the business
transaction that you carry out for a WBS element, the system status of the project changes, and
in turn, influences the processing of other business transactions.

See also:
Status Management [Page 343]
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Subprojects
Transferpreisvereinbarungen [Ext.]

Use subprojects when you have fixed price agreements between WBS elements.

You can create a subproject by dividing the work breakdown structure by sub-tree, that is,
hierarchically-related groups of WBS elements.

Each subproject has an identifier which is stored in the WBS element. If you break down this
WBS element further at a later date, the new subordinate WBS elements will be assigned to the
same subproject..
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Data for WBS elements
This topic describes the data you can enter for WBS elements.

Basic Data [Page 24]

Organization Data [Page 26]

Project Responsibilities [Page 27]

Control Data [Page 28]

Overall View [Page 29]

Documents [Page 30]

Project Summarization Data [Page 32]

Settlement Rules [Page 34]

Tax Depreciation Simulation Data [Page 35]

Assets Under Construction [Page 36]

Capital Investment Measures [Page 37]
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Basic Data
Basic data is general data that is needed for a WBS element over a long period of time and
contains information that is used repeatedly in the project:

Project Type
You can use the project type to sort a WBS element according to particular categories, such as
capital-investment project or customer project, and evaluate it in the information system. You
maintain the project type key in the Project System Implementation Guide.

Priority
You can maintain sort keys for a WBS element for information system evaluation. You define the
priority key in Customizing.

Project Summarization
See Classifying WBS Elements for Summarization [Page 59]

Operative Indicators
With operative indicators, you specify the attributes of a WBS element and determine which tasks
the WBS element can carry out in the project. Whether you can change the operative indicators
in project planning depends on the system status.

You can assign the following operative indicators to WBS elements:

Operative indicator for... Usage...

Cost planning If you want to plan costs for a WBS element, you have to indicate
that the WBS element is a planning element in the WBS.

Account assignment If you want to post actual costs and commitments to a WBS
element, you have to indicate that the WBS element is an account
assignment element in the WBS. All objects that can be assigned
costs and commitments within a project (for example, orders,
networks, or purchase orders) can only be assigned to a WBS
element if you have set the account assignment indicator for the
element.

In Customizing for the Project System, you can set an indicator to
specify that costs are planned for all WBS elements or only for
specific WBS elements.

Billing If you want to post revenues to a WBS element, you have to
indicate that the WBS element is a billing element in the WBS.

See also:
Cost Planning [Ext.]
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Organization Data
Organisatorische Zuordnungen im Projektsystem [Page 10]

Währungen im Projektsystem [Ext.]

Some of the organizational data that you define for a project in the project profile also applies to
all WBS elements. You can only partially change this data. The controlling area in the project
definition is valid for the entire project and cannot be changed in a WBS element. However, WBS
elements can be assigned to different plants, company codes or business areas.

In a WBS element you can also enter the following:

•  For plant maintenance, for example, equipment or functional location

•  Profit center

•  Object class

The object class is used to categorize Controlling objects such as overhead costs (OC)
or investment controlling (IV), according to their business purpose.

In reconciliation ledger reporting, you can obtain a cross-application display showing
these cost flows within Controlling, sorted by object class.

•  Change number

•  Currency

A WBS element can have its own object currency, if you have not defined a different
company code currency in the controlling area. The currency which you entered in the
project definition is a default value for all new WBS elements. You can change the
currency of a WBS element as long as no currency-related data has been saved, for
example actual values or in cost planning.

See also:
Ressourcen
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Project Responsibilities
You can maintain the following responsibility data in the WBS:

•  Name and number of person responsible for project

•  Name and number of project applicant

•  Requesting cost center; area requesting or triggering the WBS element

•  Controlling area for requesting cost center

•  Responsible cost center, area responsible for executing the WBS element

•  Controlling area of the responsible cost center

You can use the responsible cost center to control authorizations.



Structures  SAP AG

Control Data

28 April 2001

Control Data
The work breakdown structure contains the following control data:

•  Costing key

•  Overhead key

•  Interest profile

•  Capital-investment measure profile

•  Results analysis key

•  Statistical indicator: for example, earned value analysis

•  Plan integration indicator
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Overall View
The overall view for the WBS elements combines the following data:

•  Basic Data [Page 24]

•  Organization Data [Page 26]

•  Project Responsibilities [Page 27]

•  Control Data [Page 28]

In addition, you can define values specific to your business in fields you define yourself. A
customer enhancement enables you to have the fields checked per your own criteria.

See Project System customizing for more information.

user fields in
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Documents
You can enter documents for a WBS element or assign existing documents to it. The documents
involved are:

•  PS texts

•  Documents from document management

You can later display these documents either in the information system or in the Intranet.
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Billing Plan
Definition
A billing plan is a time schedule containing individual billing dates. It contains the dates as of
which down payment requests and invoices are sent out and the amounts which appear in them.

Use
To obtain detailed information on planned revenues and incoming payments, you can maintain a
billing plan for a billing element. The billing plan automatically updates the revenue plan and, if
project management is active, the payment plan for the WBS element.

See also:
Billing Plans in WBS Elements [Ext.]

Planned Payment Flow [Ext.]
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Project Summarization Data
Verdichtungshierarchie [Ext.]

Projektverdichtung [Ext.]

Projektverdichtung über Klassifizierung [Ext.]

Projekt für die Verdichtung kennzeichnen [Page 59]

You can classify WBS elements with the SAP class system to be used in cost or project
summarization. Project summarization enables you to summarize and analyze several projects at
the same time under an overall header.

In this way, you can combine and evaluate the costs for all projects in a:

•  Controlling area

•  Business area

•  Cost center

For information on classification, read CA Cross-Application Functions in the  Classification and
Characteristics documentation.
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Defining a Summarization Hierarchy
Verdichtungshierarchie [Ext.]

You define the summarization hierarchy by identifying key WBS elements and their subordinate
WBS elements. You assign characteristics and characteristic values to certain WBS elements.
These values are “inherited” by the subordinate WBS elements.

See also:
Classifying WBS Elements for Summarization [Page 59]

Project Summarization.
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Settlement Rules
Abrechnung [Ext.]

You can settle a project to different cost objects, for example, to an asset, a cost center, or a
sales order. You use the settlement rule to determine to whom and how the costs or revenues
incurred for the WBS element are settled.

See also:
Periodic Processing [Ext.]
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Tax Depreciation Simulation Data
Abschreibungen [Ext.]

For a WBS element, you can enter the planned start-up, depreciation key (calculation method),
and useful life. Based on cost planning of the WBS element and using this information, you can
carry out a tax depreciation simulation in asset management (depreciation forecast).

For additional information about depreciation, refer to the FI Asset Accounting documentation..
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Assets Under Construction
You can assign an asset under construction to a WBS element for capital investment measures.
The cost information from the WBS element will simply be passed on to asset management.

 
You can only assign assets under construction to those WBS element which have
account assignment.
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Capital Investment Measures
Use
You can assign WBS elements to the position in a capital investment program. The WBS
element will get its entire budget from the investment program position. The budget is distributed
in the WBS (over time or over the hierarchy).

For more information, read Assigning WBS Elements [Page 38].

See also:
Capital Investment Measures (Orders/Projects) [Ext.]
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Assignment of WBS Elements
Use
In most cases, an entire project is clearly assigned to one investment program position. In this
case, the assignment to an investment program is made at the level of the top WBS element.
Some projects, however, have a much broader scope within an enterprise. The WBS elements
belonging to such a project receive their budgets from various sources. Therefore it is also
possible to assign non-top WBS elements to different investment program positions.

Features
You can make assignments to the investment program from all levels of the work breakdown
structure. The individual WBS elements in a work breakdown structure can be assigned to
different investment program positions.

The following graphic shows an example of possible assignments. The WBS elements for
Hardware and Application are each assigned to one investment program position, respectively.
None of the other WBS elements are assigned to an investment program position.

Overall Investments
Plan Budget Distrib.
1100 1000 1000

500 500
Business Area 1

600 500
Business Area 3

Investment
Program

500 280
Top WBS: Inf.Sys. 

100 100
WBS: Hardware

200 170
WBS: Software

50 20
WBS: Op.System

150 150
WBS: Application

Project 280

170

100 150

Budget
Distribution

10 10
WBS: Licenses

Automatic rollup: 100 + 150
Assigned directly: 20 + 10

Assignment to Different Program Positions
WBS elements that are assigned to program positions do not have to be at the same level in the
work breakdown structure. It is also permissible for sub-trees of the work breakdown structure
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not to have any assignment at all to an investment program position (in the graphic, the Licenses
sub-tree has no assignment).

The system guarantees the consistency of budget values within a work breakdown structure as
follows:

•  You can assign a WBS element to a program position only if the WBS elements directly
above and below it in the hierarchy are not assigned to a program position.

•  If the WBS element receives its budget from budget distribution from a program position,
then the system automatically rolls up the budget received to the superior WBS elements in
the work breakdown structure. If there are already budget values on the superior WBS
elements, the system adds the rolled up budget to the existing budget.
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Editing the Work Breakdown Structure
Project Builder [Page 221]

There is more than one way of creating and editing a work breakdown structure (WBS).

If you only want to work with the WBS...
Go to the Operative Structures menu and choose Work breakdown structure.

Proceed as follows to create a work breakdown structure:

1. Create the project definition.

2. Create the WBS elements for the individual tasks or subtasks within the project.

3. Maintain the data for the individual WBS elements.

4. Maintain the project hierarchy.

5. Save your data by choosing Project → Save.

If you want to work with an entire project...
Including all networks and activities assigned to the WBS, choose Planning →→→→ Structure planning
from the Project System menu.

See also:
Structure Planning [Page 321]

If you want to edit a project using the project planning board...
Choose Planning  →→→→ Project planning board

See also:
Project Planning Board [Page 252]

The following sections describe how you can maintain WBS elements and the work breakdown
structure under the menu options Operative Structures →→→→ Work breakdown structure

You can copy an existing WBS or a standard project to create a new one, or include WBS
elements from an existing WBS or standard WBS in another work breakdown structure.

Creating Project Definitions

Creating WBS Elements

Maintaining Data for the WBS Elements

Creating WBS Elements in the Hierarchy Graphic

Maintaining the Project Hierarchy
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Creating Project Definitions
Use
You can create and change the project definition independently of the work breakdown structure.

Procedure
1. On the Operative Structures screen choose:

− Work breakdown structure →→→→ Create or

− Work breakdown structure →→→→ Project definition → → → → Create

The initial screen appears.

2. Enter a new number for the project definition or let the system propose the next free number
[Page 61].

3. Enter a project profile and choose Enter.

The Create Project Definition screen appears.

4. Enter the data for the project definition.

The data that is saved in the project profile is copied to the project definition
automatically.  You can change some of this data.

5. Save your data.
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Creating WBS Elements
Use
You can add WBS elements to an existing project.

Procedure
To execute the functions in the following table, choose the corresponding menu path from the
Operative Structures screen.

Function Menu Path Procedure

Create WBS
Elements

Work breakdown structure  →
Change

1. Enter the project definition and
choose Enter.

 The WBS element
overview appears.

2. Create a new WBS element.

Create a single
WBS element

Work breakdown structure  →
Single element → Create

1. Enter the project definition
2. Enter a number for the new

WBS element and choose
Enter.

The detail screen for the
new WBS element
appears.

See also:
Entering WBS Element Numbers [Page 271]

Maintaining Data for WBS Elements [Page 44]
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Entering WBS Element Numbers
Use
If you are working with very large projects and need to create a lot of elements with complex
project numbers, the system can help you enter the numbers.

Prerequisites
You have defined a special character in the Project System IMG to act as the input help.

Features
If you enter the special character in the WBS element field in your project, the system copies the
number of the higher-level WBS elements into the field. If the new WBS element is the first one in
the project hierarchy, the system copies the project definition.

Then you only need to add to the number so that it is different from the one copied. You can also
use the input help in conjunction with a project coding mask. In this case, you do not need to
enter the separator when adding to the WBS element number.

You have specified the character @ as an input help. In the work breakdown
structure, you insert another WBS element under the WBS element A-123-LDZ-10
and only type "20.

Type of Input Help Your Entry

No project coding mask @-20

Using project coding mask A-000-XXX-00-00 @20

The system automatically copies the identifier from the superior WBS element as
follows: A-123-LDZ-10-20.
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Maintaining Data for the WBS Elements
Grunddaten [Page 24]

Zuordnungen [Page 26]

Steuerung [Page 28]

Meilensteinen [Page 192]

Dokumente [Ext.]

PS-Texten [Ext.]

Grunddaten [Page 24]

Zuordnungen [Page 26]

Steuerung [Page 28]

Fortschritt [Ext.]

Abrechnungsvorschrift [Page 34]

PS-Texte [Ext.]

Investitionsprogramm [Page 37]

Projektverdichtung über Klassifizierung [Ext.]

Projektverdichtung über Stammdatenmerkmale [Ext.]

The following table provides you with an overview of where you can maintain detailed data for
individual WBS elements.

Action Edit
Choose Goto →→→→ WBS element overview. All WBS elements in the WBS element overview
Choose Details → WBS detail screen or
Double-click on the WBS element.

Just one WBS element on the detail screen.

The following table shows you where you can maintain data for the WBS elements.

Menu Path WBS Element Data

Goto →→→→ WBS element overview •  Basic data
•  Dates
•  Organization
•  Responsible person
•  Profile data
•  Total

WBS element →→→→ Milestone overview Basic data and dates for milestones
WBS element →→→→ Document overview Documents allocated to the WBS element using

document management

WBS element  →→→→ PS text overview Administrative data and text overview for PS texts
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Details → General •  Basic data
•  Dates
•  Organization
•  Data from the project profile
•  User fields
•  Joint venture
•  Administration
•  Progress Analysis
•  Superior elements
•  Settlement rules
•  Long text
•  PS texts

You change the description of the WBS element detail screens in Project System
Customizing and WBS maintenance. For more information, read the Layout of Detail
Screens [Page 330].

The overview which follows discusses the detail screens using the descriptions we
deliver.

See also:
Data for WBS Elements
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Changing the Project Hierarchy
Use
The Project System distinguishes between changes to the hierarchy and additions to it.

You are adding to the project hierarchy when you do the following:

•  Create new WBS elements

•  Insert WBS elements

•  Incorporate WBS elements

You are changing the project hierarchy when you do the following:

•  Move WBS elements up

•  Move WBS elements down

•  Move WBS elements sideways

•  Detach WBS elements

Features
You can make additions or changes to the project hierarchy until one of the following system
statuses is set for the project definition or the superior WBS elements:

•  MDLK Master data locked

•  LKD Locked

•  CLSD Closed

•  DLFL Deletion flag

•  DLT  Deleted

Adding to the Project Hierarchy
You can add to the project hierarchy if the system or user status allows transaction PSEI Expand
structure.

Changing the Project Hierarchy
You can change the project hierarchy if the system or user status allows transaction PSVE
Change structure.

You cannot move a WBS element if:

•  A budget has already been entered for it

•  There is a fixed price agreement between this WBS element and another

Activities
You can change the project hierarchy in the WBS element overview or the hierarchy graphic.
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See also:
WBS element overview

Creating WBS Elements [Page 42]

Including WBS Elements in the Project Hierarchy [Page 48]

Changing the Hierarchy in the WBS Element Overview [Page 54]

Hierarchy graphic

Creating WBS Elements in the Hierarchy Graphic [Page 50]

Maintaining the WBS in the Hierarchy Graphic [Page 55]
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Including WBS Elements in the Project Hierarchy
Use
You can copy WBS elements into a current project structure. As templates you can use WBS
elements

•  From the current project

•  From another work breakdown structure

•  From a standard work breakdown structure

Procedure
1. Select the WBS element where you want to include the new WBS element.

2. Choose Project → Copy from.

A dialog box appears.

3. Select either of the tab pages, Standard WBS or Operative WBS.

If you want to copy a WBS element from the  current project or a WBS element from
another project, choose Operative WBS.

4. Enter

− Which WBS element you want to include

If the WBS element to be included has additional WBS elements subordinate to it,
the system automatically copies these lower-level hierarchy elements.

− Whether you want to include the new WBS element at the same hierarchy level as the
selected WBS element or below it.

− Which options to use when including the WBS element:

Option Effect
Right/Left The WBS element is positioned to the right or to the left of the selected WBS

element in the hierarchy.
With/without root With root: The selected WBS element is included.

Without root: Only the subordinate WBS elements are included.

5. Choose WBS element overview.

The Copy structure screen appears.

6. Select the WBS element(s) that you want to include.

7. Give the new WBS elements new numbers by using either the Predefine or Replace function.

8. Choose Include.

The system includes the WBS element(s).
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Creating WBS Elements in the Hierarchy Graphic
Use
You can use the hierarchy graphic as a quick, easy way to create WBS elements.

Prerequisite
You have first stipulated how the WBS elements are to be inserted by choosing Edit →→→→ Default
settings →→→→ Insert.

Procedure
Creating WBS Elements

1. Call up the hierarchy graphic by choosing Goto→→→→ Hierarchy graphic.

2. Choose Create.

 The node area is opened under the display area. It contains a new WBS element.

3. Click the blank WBS element in the node area.

 The system moves the WBS element into the display area.

4. Drag the WBS element to the correct position in the hierarchy by holding down on the
right mouse button and moving the mouse.

5. Release the mouse button at the desired place.

 The dialog box Create WBS Element is displayed.

 Here you can see which reference element you have chosen and the relationship
between the reference element and the new WBS element.

6. Choose Confirm.

 The dialog box Change WBS Element appears.

7. Enter a number and other data for the WBS element.

8. Choose Create WBS Elements to create more elements.

9. Choose Confirm.

 The WBS element is inserted into the hierarchy.

10. Return to the WBS element overview.

Maintaining Operative Indicators in the Hierarchy Graphic
You can maintain the operative indicators for individual WBS elements in the hierarchy graphic:
To do this, double click the relevant fields below the WBS element description:

•  Planning elements are flagged Plan

•  Billing elements are flagged Bill

•  Account assignment elements are flagged AcAs
You can cancel these flags by double clicking the relevant fields again.
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Adding WBS Elements
Use
You can add new WBS elements to an existing work breakdown structure with either the insert or
create command.

•  When you insert WBS elements, the system creates new lines above where the cursor
is positioned in the WBS element overview.

•  When you create WBS elements, the system adds new lines at the end of the WBS
element overview.

Procedure
1. Call up the work breakdown structure you want to add to by selecting the menu options

Operative structures  →→→→ Work breakdown struc → Change.

2. Choose Edit → Object → Create or Insert.

 The system creates new lines.

3. Maintain the description and the level in the hierarchy for the WBS element and confirm
your entries.

The system displays a dialog box which you can use to search for the next free number
[Page 32] .

See also:
Changing the Project Hierarchy
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Deriving the Hierarchy from the WBS Element Number
Use
If you are working with very large projects and need to create a lot of elements with complex
project numbers, the system can help you derive the hierarchy.

Prerequisites
You have defined a coding mask for your projects in Customizing for the Project System. In this
coding mask you entered enough dashes to model all the levels in the project hierarchy.

Features
If you have defined a coding mask, you can enter all the WBS elements in a project after each
other without worrying about the hierarchy level. You can, for instance, enter all WBS elements
on level 1.

The system then derives the hierarchy level of each WBS element from the coding mask. The
WBS element with the shortest number is created in level 1. Every further WBS element is
placed on a subordinate level, depending on its number and the number of dashes.

You have defined a project coding mask P-000-XX-00. You have entered all WBS
elements on the same level. The system derives the hierarchy levels as follows:

WBS Element Number Level Superior WBS Element

P-001 1

P-001-AA 2 P-001

P-001-AA-01 3 P-001-AA

Activities
After you have entered all the WBS elements, choose Project → Derive structure → Derive. The
system places the WBS elements in the correct sequence in the project hierarchy.

If the system cannot derive the hierarchy, it prompts you to check the structure. To do this,
choose Project  → Derive structure  → Check. The system then displays a message text,
detailing the errors found.
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Changing the Hierarchy in the WBS Element Overview
Use
Generally speaking, you enter the desired project hierarchy level directly when you create the
WBS element. However, you can also change hierarchy levels of WBS elements afterwards.

See also:
Changing the Project Hierarchy [Page 46]

Procedure
Select a WBS element and choose one of the functions listed in the table below. The functions
also affect the WBS elements subordinate to the one selected.

Function Menu Path What You Should Know

Move WBS element down a
level

Edit → Object → Level down If you are working in a subtree,
the top WBS element cannot
be moved down a level.

Move WBS element up a level Edit → Object → Level up If you are working in a subtree,
the top WBS element cannot
be moved up a level.

Move the WBS element to
another position.

Edit → Object → Move Position the cursor on the
WBS element in front of
which you want to insert the
WBS element.

You cannot insert a moved
WBS element below WBS
elements that are subordinate
to it.

If you are working in a subtree,
the top WBS element cannot
be moved.

Detach WBS element from
project hierarchy and insert it
at level 1.

Edit → Object → Cut If you are working with a
subtree, it is not generally
possible to detach WBS
elements.

See also:
Deriving the Hierarchy from the WBS Element Number [Page 272]
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Maintaining the WBS in the Hierarchy Graphic
Use
You can change the project hierarchy in the the hierarchy graphic. You can use the hierarchy
graphic to change the project hierarchy, for example, you can add unassigned WBS elements to
the project hierarchy or you can move subtrees.

See also:
Creating WBS Elements in the Hierarchy Graphic [Page 50]

Changing the Project Hierarchy [Page 46]

Procedure
Adding WBS Elements to the Hierarchy
To add WBS elements to the project hierarchy, proceed as follows:

1. Choose Connect.

 The cursor becomes a pencil.

2. Click and hold down the left mouse button on the WBS element to be added in the
project hierarchy. While holding down the mouse button use the pencil to draw a line to
new WBS element.

When you release the mouse button, this WBS element is inserted into the project
hierarchy.

The figure shows in which direction you must draw the line in order to add the WBS element to
the hierarchy.

Changing the Project Hierarchy
You can change the project hierarchy, for example, by removing WBS elements or subtrees from
the structure and inserting them at another level in the project hierarchy.

To remove WBS elements or subtrees from the project hierarchy:

1. Click the WBS element that you want to remove from the project hierarchy.

 The WBS element is selected.
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2. Choose Split.

The WBS element and all subordinate elements are removed from the project hierarchy.

If you want to insert the split-off WBS elements or subtrees back in at another level in the project
hierarchy, follow the steps described in the section "Adding WBS Elements to the Hierarchy".

You can change the sequence of WBS elements within a level as described below:

1. Place the cursor on the WBS element that you want to move.

2. Click and hold down either the middle (3-button mouse) or right (2-button mouse) button.

3. Use the mouse to move the WBS element to a new position.

4. Release the mouse button.

The WBS element is relocated.

 
Even if you have budgeted or planned costs for a WBS element, you can still move it
within a level.
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Displaying and Viewing WBS Elements
Display
Select Extras → Settings → options... to display the WBS elements in overviews as follows:

•  Using numbers

•  Using short IDs

•  Using descriptions

View
You can restrict the view of the WBS to a certain number of levels. For example, if you limit the
view to the second level, the system displays only the WBS elements that are on the second
level of the project hierarchy.

To display or suppress WBS elements, choose Edit → View → Expand/Collapse. The following
functions are available:

•  Collapse suppresses all WBS elements from the overview that are below the selected WBS
element.

•  Collapse from level suppresses all levels from the overview that are below the level of the
selected WBS element.

•  Expand shows all WBS elements.

•  Expand all shows all WBS elements that are below the selected WBS element.

•  Set focus shows only those WBS elements that are below the level of the selected WBS
element.

•  Reset focus shows all levels of the WBS hierarchy.
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Deleting WBS Elements
Systemstatus in Projektstrukturplänen [Page 347]

You can only delete WBS elements as long as there have been no postings or allocations to
other objects, such as an activity being allocated to a WBS element, or a purchase order has
been created. Subordinate WBS elements will also be deleted.

1. Select the WBS element you want to delete.

2. Choose Edit → Object → Delete.

The selected WBS element is deleted from the list.

For all other system statuses, you have to set a deletion flag for the WBS element. The WBS
element will be deleted in the next archiving run.

1. Call up the WBS element overview.

2. Select the WBS element you want to delete.

3. Choose Edit → Status → Deletion flag.

The WBS element is now marked for deletion.

You can remove the deletion flag by choosing Edit → Status →

WBS elements which have been marked for deletion, that is, a deletion flag has been
set, will not be displayed in budget management, cost planning or time scheduling.

Displaying Deletion Flags
You can show or hide deletion flags by choosing Edit → Object → Deletion flag → Display or
Hide.
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Marking a Project for Summarization
Use
You can summarize your projects according to the summarization hierarchy using master data
characteristics in the project information system. You can also continue to use the Project
Summarization Using Classification [Ext.] that was used in the previous releases. However, this
type of summarization will not be available in the short-term.

You can change projects which are summarized using classification to projects which
are summarized using master data characteristics.

In order to summarize a project using master data characteristics you must mark the project
definition for summarization. You can mark individual WBS elements in the network as
summarization objects so that the WBS elements do not completely inherit the characteristics
attributes of the higher-level WBS element during the inheritance run, but rather are
supplemented by these characteristics.

See also:
Summarization in Projects [Ext.]

Prerequisites
You have set the indicator for Summarization and Master Data in the project profile in Project
System Customizing. This automatically marks the project definition for summarization. However,
this indicator is not visible in the project definition.

You can make settings in the project profile which specify WBS elements as
summarization objects by default, meaning they are marked automatically when you
create them as summarization objects. If you decide to set this indicator be sure that
the number of summarization objects in the project are kept to a minimum. A large
number of summarization objects can negatively affect the performance of the
inheritance and summarization runs.

Procedure
1. Create a project definition with a project profile wherein the Summarization and Master Data

(Proj. summ.MastDa) indicator is set.

If you create a project with a template, the project is marked for summarization
according to the template, and furthermore independent of the settings in the project
profile. For example, if you use a project or standard project as a template which is
marked for summarization using classification, the new project will also be marked
for summarization using classification.

2. Choose .

3. Create a WBS element.
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4. If you want to mark a WBS element as a summarization object, set the project summarization
indicator on the Basic Data tab page (as well as the indicator Proj. summarization on the
corresponding detail screen).

5. Save your data.
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Finding the Next Available Number
Use
When you create a project definition, WBS element, or project version you can have the system
suggest the next free project number or project key.

 
If you are creating a new WBS element, you only need to enter its level and
description in the WBS element overview. As soon as you confirm, a dialog box
appears which you can use to find the next free number.

Procedure
1. Choose Free No. or Next free number.

 A dialog box appears.

2. Enter a number range for the search.

3. Enter a strategy for the search (search from the beginning or the end of number range).

4. Choose Find.

 Depending on the chosen search strategy, the next free number starting at either the
start value or the finish value is suggested.

 By choosing Find next you can have the system suggest further numbers.

5. Choose Copy.

The system adopts the number.

 
Projects P001, P123, and P126 exist in the system. If you select Next open, the
system will propose P002. If you select After last, the system will propose P127.
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System Statuses in Work Breakdown Structures
The active system status determines which business transactions you can perform with work
breakdown structures and WBS elements. System statuses are passed from the project definition
to the WBS elements and from the WBS elements to the subordinate WBS elements. The
system statuses Locked and Final billing are exceptions to this.

You can cancel certain statuses, for instance Technically completed, Closed and Deletion Flag.
When you do so, the previous status is set. You cancel system statuses on by one, until you
arrive at a status that cannot be canceled. You cannot cancel system statuses that are set
automatically (in the background by the system), for example Partially released.

If you cancel the statuses Technically completed or Closed, the system automatically cancels this
status in the superior WBS element. However, the system does not cancel the status in
subordinate WBS elements.

The Deletion Flag status is not set automatically in superior WBS elements.

Created (CRTD)

Use
This is the initial system status for new WBS elements. In this status you structure the project
and plan dates, costs and revenues. The system sets this status automatically, when you create
a new WBS element.

Prerequisites
The project and, if applicable, the superior WBS element must have Created status.

Features
In Created status, you can create new WBS elements and change the work breakdown structure.

The status

•  Allows you to assign networks, which do not yet have Released status

•  Allows you to plan costs and revenues

•  Allows budgeting

Released (REL)

Use
In this status you can assign costs and revenues to WBS elements.

Prerequisites
The Created status is set.
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Features
In Released status you can create new WBS elements and change the project hierarchy. The
status is passed on to subordinate WBS elements.

The status allows

•  You from assigning networks, production orders or CO orders to the WBS element.

•  You to post actual costs

•  You to transfer actual costs

You cannot change the status from Released to Created, as actual values from, for instance,
purchase orders or confirmations may have been posted

Technically completed (TECO)

Use
You use this status for WBS elements that are completed from a technical point of view, but
where you still expect costs to accrue.

Prerequisites
The Created or Released status must have been set. The completion indicator must be set for
transfer price agreements.

Features
In status Technically completed, you can create new subordinate WBS elements (with a
warning). The status is passed on to subordinate WBS elements.

The status allows

•  You from assigning networks, production orders or CO orders to the WBS element.

•  You to post actual costs

•  You to transfer actual costs

You can cancel the Technically completed status. In this case the system sets the Released
status.

You can prevent the Technically completed status from being canceled. Create a
user status that prohibits the Revoke technical completion business transaction.

Closed (CLSD)

Use
You use this status for a work breakdown structure or WBS element that has been completed
from both a logistic and an accounting point of view.

Prerequisites
You can only set the Closed status, if:
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•  The project definition or the WBS element have either the Released or the Technically
completed status.

Features
In the Closed status you can no longer make any changes to the project hierarchy. The status is
passed on to subordinate WBS elements.

The status allows

•  You to post actual costs to orders and networks that are assigned to the WBS element, as
long as their status permit this

The status prohibits

•  You from assigning networks, production orders or CO orders to the WBS element.

•  You from posting actual costs to the WBS element

The status deactivates assets in construction that are assigned to the WBS element.

You can cancel the Closed status. In this case the system sets the Technically completed status.

Deletion flag (DLFL)

Use
The Deletion flag status designates work breakdown structures or WBS elements that have been
flagged for deletion. This means that the objects are deleted logically, but not physically.

Prerequisites
You can set the Deletion flag if

•  The WBS element has been settled completely or is not relevant for settlement.

If you set the Must not be settled indicator in the settlement profile in Customizing for
Product Cost Controlling, you can still set the Deletion flag status even if the actual
costs are not balanced.

•  Assigned orders and activities also have Deletion flag status.

•  There are no commitments for the WBS element

•  There are no reservations or purchase requisitions that are account assigned to the WBS
element.

•  All the goods issues have been posted in the assigned sales orders and the deliveries have
been billed.

•  A deletion flag has been set in the appropriation request on which the WBS is based.

•  No associated reservations, planned independent requirements or planned orders exist

•  The completion indicator is set in assigned transfer price agreement
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Features
The status is passed on to subordinate WBS elements. It prohibits all business transactions.

The status

•  Deactivates assets in construction that are assigned to the WBS element.

•  Is the prerequisite for setting a deletion indicator.

As long you have not set a deletion indicator, you can cancel the Deletion flag status.

See also:
Archiving Operative Project Structures (PS-ST-OPR) [Ext.]

Final Billing (FNBL)

Use
With this status you can prevent further billing for this WBS element. However, you can still post
costs (for instance, due to warranty claims).

You can set the Final Billing status in addition to every other status except Deletion flag. The
Final Billing status is not passed on to subordinate WBS elements.

Prerequisites
The WBS element is a billing element.

Features
The status prohibits

•  Creation of a billing document

•  Creation of a quotation

•  Creation of an inquiry

You can cancel the status.

Locked

Use
You can either lock individual business transactions or all the data in a work breakdown structure
or WBS element. You can set the following statuses:

•  Date definition locked (DDLK)

•  Planning locked (PLLK)

•  Budget management locked (BMLK)

•  Account assignment locked (AALK)

•  Master data locked (MDLK )

You can set these statuses in addition to every other status except Deletion flag. The statuses
are not passed on to subordinate WBS elements.
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Features
The Master data locked (MDLK) status prohibits

•  Setting of another system status

•  Changing and extending the project hierarchy

You can cancel these statuses.
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Setting the System Status
Procedure
1. Select the WBS elements for which you want to set a system status or call up the project

definition.

2. Choose Edit →  Status and the corresponding status.

The system sets the chosen status.

To view the system status for the selected WBS elements, choose Edit → Status →
System/User status. See Status Overview in Transactions [Page 345].
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Creating a Work Breakdown Structure By Copying
Use
When you create a new work breakdown structure, you can use an existing work breakdown
structure, part of a project hierarchy, or a standard work breakdown structure as a template.

If you have already created a work breakdown structure, you can use WBS elements from other
project or a standard work breakdown structure as a template to be included as new WBS
elements.  For more information, see Including WBS Elements in the Project Hierarchy [Page 48]

When you create a work breakdown structure (project) by copying an existing one, the project
definition and the following master data are copied:

•  Organization Data

•  Calendar

•  Time unit

•  Operative indicators

Procedure
1. From the Operative structures menu choose Work breakdown structure  → Create.

The initial screen appears.

2. Enter the relevant data on the initial screen.

Enter a new number for the work breakdown structure or let the system propose the next free
number [Page 61]

If you enter a project profile, it will override the project profile in the WBS that was
copied.

3. Choose Goto → Project definition.

The Create Project Definition screen appears.

4. Check the data that was copied to the project definition and make any necessary changes.

5. Choose Goto → WBS.

The Create Project: Include WBS Elements screen appears.

6. Select the WBS elements you want to include.

7. Enter new numbers for these WBS elements.

− Choose Edit → Key → Predefine to give all WBS elements the same new number, which
you can use to form new WBS element numbers.

− Choose Edit → Key → Replace to replace part of each WBS element number with a
common character string.

8. Choose Edit → Include.   

You receive an error message if the selected WBS elements could not be included. In
this case, choose Edit → Key → Check. An error log appears. Correct the numbers of
the WBS elements that the system could not include and then choose Edit → Include.
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The system includes the WBS elements in the project The Create Project Definition
screen appears.

9. Enter other data for the work breakdown structure as required.

10. Save the project.
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Determining the Project Number from the Sales
Document
When you create a sales document using assembly processing, the system automatically creates
a project. The project number contains the sales document number.

In assembly processing, the sales document is linked to a standard network which in turn is
assigned to a standard work breakdown structure. When you save the sales document, the
system creates an operative project in the background by copying from the predefined standard
structures.

See also:
Assembly Processing in the Project System [Ext.]

How the system determines the project number from the sales document number, depends on
whether a single structure or several sub-trees are to be created when the work breakdown
structure is created.

You use the SD/PS assignmt indicator in the standard WBS to specify that the
operative work breakdown structure should be created with several sub-trees. You
can only set this indicator, if a project editing mask has been maintained for
standard work breakdown structures in Customizing.

Since the WBS element number always has to be unique, the system uses a search and replace
technique which takes the first WBS element at level one and uses its number as the basis for
creating the number of all other WBS elements in the new project.

 
To ensure a one-to-one match between the project and its related sales document,
the number of the standard WBS element should always be longer than ten
characters.

If you work with a single structure in the operative structure, the sales document number is used
to generate WBS element numbers. How the system determines the project number from the
ten-character sales document number, depends on whether you specified project number editing
in Customizing of the Project System. SAP recommends that you use project number editing if
you are going to be replacing the project number with the sales document number.

In the case of an operative project with several sub-trees, as well as the sales document number,
the sales item number is also used, so that the WBS elements in the different sub-trees have
different numbers.

With Project Number Editing
The area between the first and the second special character in the number of the standard WBS
is replaced by the corresponding number of positions from the sales document number, starting
from the right-hand side of the sales document number. The existing spaces are filled from right
to left starting with the last digit in the sales document. If there are not enough spaces available,
the sales document number is shortened by the first digits. To ensure agreement between the
project and sales document, the area between the first and second special character of the
number should always be at least ten characters long.
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Std. Proj. def. / WBS element Sales document number New number in operative

project
M/12345-001 0066778899 M/78899-001
M/123456789-001 0066778899 M/066778899-001

If several sub-trees are to be generated for a project, the area between the second and third
special characters in the standard WBS number is replaced by the relevant item number of the
sales document number.

 
Std. WBS element Sales document

number
Sales document
item

New number in operative
project

M/1234567890-0000-001 0066778899 1101 M/0066778899-1101-001
M/1234567890-0000-001 0066778899 1102 M/0066778899-1102-001

Without Project Number Editing

Project number is less than ten characters long
When the sales document number is longer than the project number, the system replaces the
entire standard WBS number with part of the sales document number, starting from the right of
the sales document number. The length of the standard WBS number remains the same.

 
Std.proj. def. Sales document number New number in operative project

M12345 0066778899 778899

Std. WBS element Sales document number New number in operative project

M12345
(at level one)

0066778899 778899

M12345-1
(at level two)

0066778899 778899-1

Project number is more than ten characters long
The system replace the first ten characters of the standard WBS number with the sales
document number. Any remaining characters from the original standard WBS number are tacked
on to the end of the new project number.
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Std. Proj. def. / WBS element Sales document number New operative project

definition
M123456789ABC 0066778899 0066778899ABC
M123456789ABC-1 0066778899 0066778899ABC-1
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Using ALE to Distribute the Work Breakdown Structure
Use
You can use the ALE business process to distribute work breakdown structures which you create
in a (master) system to various R/3 (receiver) systems.

See:
Distributing Work Breakdown Structures or Internal Orders [Page 74]
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Work Breakdown Structure or Internal Order
Distribution
Use
To carry out actual postings in distributed systems for internal orders and work breakdown
structures, you can distribute the master data and status information of internal orders and work
breakdown structures to more than one system.

Integration
Functions in the Master System
All functions for internal orders and work breakdown structures are available. However, in the
master system you cannot call up the corresponding line items from line item reports if the line
items all come from one receiving system.

You create the internal orders or the work breakdown structures in the master system. When you
save them, the R/3 System distributes them automatically to one or more receiving systems.
Through the filter objects Controlling area and order type or project profile, you control whether,
and in which system, the internal orders or work breakdown structures are to be distributed.

You can also send released internal orders and work breakdown structures at a later date.

Functions in the Receiving System

•  Master data and status information display
You can only make changes in the original master system. These changes are transferred to
the receiving systems.

•  Postings from other R/3 components (such as, FI, MM)

•  Assessment

•  Distribution

•  Periodic reposting

•  Manual reposting (costs, revenues, line items)

•  Direct and indirect activity allocation

•  Reposting internal activity allocation

•  Accrual calculation

•  Settlement debits

•  Line item reports

Restrictions with Distributing Internal Orders and Work Breakdown Structures

•  WBS elements cannot be distributed individually. Only complete work breakdown structures
are distributed.

•  If a WBS element is assigned to an internal order, the system does not automatically
distribute this WBS element to the receiving system. This means that the assignment of the
WBS element to the internal order is not known in the receiving system.
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f required, you can distribute the work breakdown structure first to the receiving system
and then later on distribute the internal order.

•  If you settle activities of cost centers that do not exist in the master system, you can only
settle the internal order or work breakdown structure using settlement type FUL.

The following business transactions are not possible in the receiving system:

•  Planning of internal orders, costs, and appointments on work breakdown structures

•  Budgeting and availability control

•  Commitment postings

•  Overhead costing

•  Settlement of internal orders and WBS elements

•  Assignments of orders and networks to the work breakdown structure

If you set the deletion indicator in the master system for an internal order or a work
breakdown structure and this change was adopted in the receiving system, the R/3
System also deletes the given internal order or work breakdown structure in the
receiving system. To ensure that in the receiving system you cannot make postings
to deleted objects, you should choose a time period corresponding to the setting of
the deletion flag and the setting of the deletion indicator (for example, for internal
orders by setting residence time 1). You must make sure that the Deletion flag status
has been adopted in all receiving systems before you set the deletion indicator in the
master system.
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Data Flow

System 1

Auftrag 10001Order 10001

Auftrag 10001Order 10001

Auftrag 10001Order 10001

ALE

CO-Beleg 30001CO-Doc. 30001

CO-Beleg 10102CO-Doc. 10102

System 3

System 2

ALE

CO-Beleg 10101CO-Doc. 10101

The data flow between distributed systems is identical for internal orders and work breakdown
structures.  This is described using the example of an internal order:

If you create or change internal order 10001 in system 1, it is automatically distributed to the
receiving systems (in this case: system 2, system 3) and created or changed there using the
same order number. System 1 is the master system of internal order 10001.

•  Postings made in the master system are only available in the master system (CO document
10101 in this case).

•  Postings made in other receiving system (in this case, system 3) are sent via ALE to the
master system. They are available in the both the receiving system and in the master system
(in this case, CO doc. 30001 from system 3 is given its own number CO doc. 10102 in the
master system).

Prerequisites

Whenever possible, you should carry out all cross-system Customizing settings in
one system.

•  The organizational units (e.g. controlling area, company code) are defined identically in
the master system and the receiving systems.

•  The order type or the project profile are defined identically in the master system and in
the receiving systems.

•  The status selection profiles are defined identically in the master system and in the
receiving system.
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•  For internal orders: The number ranges are defined separately in the master system and in
the receiving system. This is because a distributed internal order in the receiving system is
given the same number as in the master system.

or work breakdown structures: The project edit screens are defined identically in the
master system and in the receiving systems. In the receiving systems you should include
a lock indicator for the project edit screens, so that these project numbers cannot be
used for new projects.

Activities
In the Implementation Guide (IMG), choose Basis Components → Distribution (ALE) →
Predefined ALE Business Processes → Accounting → Master Data Distribution →   Distribution
of Internal Orders [Ext.] or Distribution of Work Breakdown Structure [Ext.].

Use the following objects:

Business object Work Breakdown Structure Internal Order

Distribution method SaveReplica SaveReplica

Message type INTERNAL_ORDER

To send internal orders and work breakdown structures at a later time, choose Tools → ALE →
Master data distribution → Accounting → Internal Order or Projects → Send.

For more information about ALE see the SAP Library under Basis → Middleware → ALE-
Introduction and Administration.
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Network
Purpose
A network represents the flow of a project or of a task within a project. You can graphically
display various structural elements of a project and their interdependencies in the Project
System.

During the life of a project, networks are used as a basis for planning, analyzing, controlling and
monitoring schedules, dates and resources.(such as people, machines, PRTs, materials,
documents and drawings). You can assign networks to a project or a sales document, such as a
sales order.

A network is a special type of work order that has the same structure as production orders,
maintenance orders, and inspection orders in the R/3 System.



 SAP AG Structures

How Is a Network Structured?

April 2001 79

How Is a Network Structured?
A network consists of the following:

•  Activities

•  Activity elements

•  Relationships

The following graphic shows you a network with activities and the different types of relationships.

Startup

20 days

Assembly Inspection

Activity RelationshipLegend

10 days

40 50 60 70

30 Fin.prod.
procuremt

20 Work
scheduling

Engineering10 Production

For more information on activities and activity elements, see activities [Page 132] and
relationships [Page 174]

Network Headers
In the network header you can enter the following data, which are used as default values for the
entire network:

•  Assignments to other objects, for example, project definition, WBS element or sales
document

•  System status

•  Basic start and finish dates of the network as well as indicators for scheduling

•  Release and scheduled dates

•  Assignments of organizational data, such as profit center and business area

•  Costing data, for example, costing sheet and results analysis key

•  Administrative Data
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In header-assigned networks the values in the Costing section of the supplementary
data screen of the network header are not default values, but are binding for the
whole network. Even if you overwrite them in the activities, the values from the
header are used.

Execution Factor
The network header also contains an execution factor that determines how often network
activities should be repeated. If the network activities themselves have execution factors, these
are multiplied by the factor in the header. For more information, see Execution Factors [Page
134]
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Network Type and Network Parameters
In Customizing for the Project System you can define the network type and the network
parameters.

The network type specifies how a network is actually used for certain tasks and processes in the
project, for example:

•  Number range assignments and intervals

•  How the estimated costs, which are incurred for materials or services in the network, are
updated as commitments.

•  The status profile for status management

For more information on the status profile, refer to Status Administration [Page 343].

You can enter additional data and control parameters per plant in the parameters for the
network type, such as:

•  Whether costs incurred in the network are assigned to individual activities or to the network
header,

•  The objects for which change documents are written

•  The costing variants used for planned and actual costs

•  The reduction strategy for scheduling

•  Strategy for determining the settlement rule
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Network Profile
When you create a network, you must also enter a network profile for the network.

The network profile contains default values and parameters for working with a network, for
example, the plant, units, control keys for the different activities, or graphic settings.

You can maintain the values for the network profile in Project System Customizing.

The data from the network profile is automatically copied into the network when you create a new
network. You can change the default values from the profile in the network.
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Status Management
Systemstatus in Netzplänen [Page 353]

The Project System uses R/3 status management.  Depending on which business transaction
you carry out in a network or for an activity, the system sets a new status for the network or
activity. Which in turn influences whether or not you can carry out other business transactions.

See also:
For more information on status management, see Status Management [Page 343].
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Settlement Rule
Periodische Arbeiten [Ext.]

Abrechnung [Ext.]

You can settle a network to various objects, for example, to a project, a cost center or a sales
order. The settlement rule determines the objects where the network costs are to be settled and
how they are settled.

If you assign the network to other objects, for example a sales order or a WBS element, you can
use the strategy you defined in Customizing to determine whether and how the settlement rules
are taken from other objects, or whether a standard rule is used.

See also :
For more information on settlement, read CO - Settlement
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Organizational Data
Organisatorische Zuordnungen im Projektsystem [Page 10]

Währungen im Projektsystem [Ext.]

The system determines the controlling area and company code when you create a network and
enter a plant on the initial screen.  These values can not be changed.

If you want to assign a network or an activity in an activity-assigned network to a WBS element,
you must make sure that the plant of the network or the activities and the plant of the WBS
element belong to the same controlling area.

•  For networks with header account assignment, all activities and activity elements must
belong to the same company code as the plant in the network header.

•  For networks with activity account assignment, every plant in every activity and activity
element must belong to the same controlling area as the plant in the network header.

In addition, you can specify the following organizational data for the network:

•  profit center

•  business area

•  jurisdiction code

•  object class

The object class is used for the business classification of controlling objects, for example,
overhead cost management (Overhead Costs OC), investment controlling (Investment -
IV).

In reconciliation ledger reporting within Controlling these cost flows can be displayed
across all applications according to object class.

Currency in Networks
You can only change the object currency up to the partial release or release of the network, if the
currencies in the company codes are not different from the currency in the controlling area.
Otherwise, the system uses currency in the company code as the object currency and you
cannot change it.
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Classification
Classification is used to describe object using characteristics. You can freely definable selection
criteria to form groups of similar objects for various purposes The following class types are used
for the network in classification:

•  Class type 14 for project summarization

•  Class type 13 for order summarization of production orders, maintenance orders, and
networks

•  Class type 21 (networks) for general classification in the SAP System
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Network Maintenance
This topic describes:

•  Creating a Network [Page 88]

•  Creating a Network by Copying [Page 90]

•  Link Between Standard and Operative Structures [Page 92]

•  Creating Networks by Copying Standard Networks [Page 94]

•  Including Standard Networks in a Network [Page 97]

•  Setting the System Status for Networks [Page 103]
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Create Network
1. Netzplan mit Standardnetz als Vorlage anlegen [Page 94]

2. In  the menu options Accounting / Logistics choose  Project management → Operative
structures.

3. Choose Network → Create.

The initial screen appears.

4. Enter the relevant data on the initial screen.

You can copy from either a standard network or another network when creating the new
network.

5. Choose Enter.

The network header appears.

6. Enter general data in the network header:

– Enter a description
You can branch to word processing and enter another description by selecting the
menu options Details → Activity/Element → Long text.

– The current status of the network is displayed on the Scheduling tab page. When you
create a network, the system automatically sets the status created (CRTD) for this
new network.

– You can assign the network header to a WBS element, a project definition, or a sales
document on the tab page Assignments. For more information, refer to Network
Assignments [Page 118].

On this tab page you can also maintain organizational data for the network header,
such as profit center or business area.

– The dates you have to maintain on the Scheduling tab page depend on the
scheduling type.  For example, if you choose forward scheduling, you must enter a
start date.

6. Choose Enter.

If you have not assigned the network to a WBS element or to a sales document, or if you
have not yet maintained a strategy for determining the settlement rule for the network
type, the system branches automatically into the Maintain settlement rule screen.

7. Enter the data relevant for the settlement rule.
You can also maintain the settlement rule later.

Return to the network header by choosing Back.

8. Maintain data for the network.

9. Save your data by choosing Network → Save.

See also:
Maintaining Activities: Overview [Page 162]

Maintaining Relationships [Page 181]
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Creating a Network by Copying
You can copy from a standard network or an operative network to create a new operative
network. When you copy a standard network, all data is automatically copied into the new
operative network. When you copy an operative network, you can select which data you want to
have copied into the new network.

See also:
Standard Network [Page 203]

Copying an operative network
When you create a network by copying another network, you can choose which of the following
objects are copied:

•  Activities

•  Components

•  Relationships

•  Milestones

•  PS texts

•  Settlement rule

•  Production resources/tools (PRT)

Copying a standard network with relationships to other standard networks
If you use a standard network that has relationships to other standard networks, as a source for
copying to an operative network, the system checks whether operative networks have been
created for the other standard networks.

If operative networks exist for these standard networks, the system asks you whether you want to
copy these relationships. If you reply yes, the system lists these operative networks in the
following order:

•  Networks assigned to the project

•  Networks assigned to the sales order

•  All the networks in the system.

If you want to copy one or more of the predefined relationships to the operative network, select
the corresponding networks in the list. If you do not select a network, the new operative network
is created without relationships.

Copying a standard network with a link to a standard WBS
When copying a standard network to create an operative network, the system can create an
operative work breakdown structure from the linked standard WBS. You can, however, create an
operative network from a standard network linked to a standard WBS without also creating an
operative WBS.
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Link Between Standard and Operative Structures [Page 92]



Structures  SAP AG

Link Between Standard and Operative Structures

92 April 2001

Link Between Standard and Operative Structures
If you have assigned a standard network to a standard WBS, you can create an operative WBS
at the same time that you create an operative network. Before you copy a standard network
linked to a standard WBS, read the following information.

Do you want to create a operative WBS at the same time that you create an
operative network? If yes:
Create a new project definition and choose Create in the Create Network: Project Assignment
dialog box. This dialog box is displayed when you save a new network or when you execute the
Replace Standard WBS function.

A new operative work breakdown structure is created with the project name you entered. The
system copies those standard WBS elements which have assignments to the standard network
as well as their superior elements.

The following graphic shows you the result of copying a standard network assigned to standard
WBS elements, as well as the operative work breakdown structure and operative network.
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Do you want to create a  operative network and assign it to an existing
operative work breakdown structure? If yes:
Enter an existing project definition in the network header or in the Create Network: Project
Assignment dialog box. This dialog box is displayed when you save a new network or when you
execute the Replace Standard WBS function.
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The system assigns the network to the existing project in the same manner as the standard
network is assigned to the standard WBS.

If the standard network has an assignment to a standard WBS element that is not currently in the
existing operative WBS, the system will expand the WBS to include this WBS element.

Do you want to create an operative network and assign it to an existing
operative WBS element? If yes:
Enter an operative WBS element either in the header or in the activity of the new operative
network. The header or activity will be assigned to that WBS element. Once you have entered
the WBS element, the system will ignore all assignments that may exist to the standard WBS

When you copy from a standard network, the assignments to a standard WBS are
only created in the first generation operative WBS.

Procedures for Copying Networks:
Creating Networks by Copying Standard Networks [Page 94]

Creating Networks by Copying Other Networks [Page 96]

Including Standard Networks in a Network [Page 97]
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Creating Networks by Copying Standard Networks
When you create a network from a standard network, the system distinguishes whether or not a
standard WBS is assigned to the standard network.

Procedures
Copying Standard Networks Without a Standard WBS

1. In the Operative structures menu choose Network → Create.

The initial screen appears.

2. Enter the network type, plant, MRP controller and profile.

3. Enter the standard network and the alternative (if known) that you want to copy in the Std
network field.

If you do not know the alternative, you can choose from a list of alternatives after you
have maintained data for the network header.

4. Choose Enter.

The network header appears.

5. Enter the relevant data in the network header.

6. Choose Enter.

The standard network is copied into the network.

7. Enter or change the data for the network.

8. Save your entries by choosing Network → Save.

Copying Standard Networks With a Standard WBS
When you copy a standard network that is assigned to a standard WBS, you can let the system
create a new operative work breakdown structure.

1. In the Operative structures menu choose Network → Create.

The initial screen appears.

2. Enter the network type, plant, MRP controller and profile.

3. Enter the standard network and the alternative (if known) that you want to copy in the Std
network field.

If you do not know the alternative, you can choose from a list of alternatives after you
have maintained data for the network header.

4. Choose Enter.

The network header appears.

5. Enter the relevant data in the network header.

If the system is to automatically create an operative work breakdown structure, do
not enter either a project definition or a WBS element in the network header.
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Otherwise, enter the an existing operative project definition or WBS element to which
you want to assign the network.

6. Choose Enter.

The standard network is copied into the network.

7. Enter or change the data for the network.

If you want an operative work breakdown structure to be created automatically, do
not create any assignments from the network to operative WBS elements.

8. Save the network.

If you have not entered a project definition or a WBS element, the Create network dialog
box appears. Project Allocation

You an now create a new operative work breakdown structure from the standard WBS to
which the standard network is linked.

9. Enter an ID for the new WBS and choose Create.

The Create project dialog box appears.

10. Enter or change the data for the project definition and choose WBS structure..

The WBS element overview appears.

11. Change the WBS numbers and choose Include.

You return to the dialog box Create network: Project allocation

12. Choose Copy.

The new operative work breakdown structure is created.

13. Save the network.

See also:
Link Between Standard and Operative Structures [Page 92]
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Creating Networks by Copying Other Networks
When you create a network by copying another network, you can also specify which objects are
to be copied.

Procedure

1. From the Operative Structures menu choose Network → Create.

The initial screen appears.

2. Enter the relevant data and the network to be copied in the Network field.

3. Choose Objects.

A dialog box appears.

4. Select the objects to copy and then Continue.

The network header appears.

5. Enter or change the data for the network.

6. Save your data by choosing Network → Save.

No relationships to other networks are copied.
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Including Standard Networks in a Network
Procedure

1. Call up the activity overview.

2. Select the menu options Network → Include std. network.

 A dialog box appears.

3. Enter a standard network, an alternative and the activities between which the standard
network should be inserted.

4. Choose Continue.

 A dialog box appears.

5. Enter the number for the activities/activity elements or change them.

6. Choose Copy.

The standard network is included. The relationships are copied.

You can also include a configurable standard network in a network. For details about
prerequisites for doing so, refer to Including Standard Networks Using Configuration [Page 108].
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Classifying Networks
Projektverdichtung über Klassifizierung [Ext.]

Verdichtung auf dem Projekt [Ext.]

You can classify networks with the SAP class system. For doing so, you use class type 21

Procedure
1. Call up the activity overview.

2. Select the activity that you wish to classify.

3. Choose Extras → Classification → Classification.

A dialog box appears.

4. Select the class type.

The Change: Classification screen appears.

5. Edit a class and the corresponding status.

You can create further classes by choosing Environment → Class.

6. To return to the activity overview screen, choose Back.

See also:
Classification
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System Statuses in Networks
The active system status determines which business transactions you can perform with network
headers, activities, and activity elements. The system status is passed from the network header
to the activities and from the activities to the activity elements. Exceptions are the Account
assignment locked and Locked statuses.

Created (CRTD)
Use
This is the initial system status for new networks, activities, and activity elements. The system
sets this status automatically, when you create a new network.

Features
In the Created status, you can create new activities and activity elements and change the
network header.

The status, for example,

•  Allows you to directly (physically) delete activities and activity elements

•  Prohibits you from posting actual costs

Released (REL)
Use
The Released status is necessary before you can post actual costs.

Prerequisites
The network header or the activity must have the Created status.

Features
In the Released status, you can create new activities and activity elements and change the
network header. If a network has Released status, new activities and activity elements also have
Released status.

The status

•  Allows you to post actual costs

•  Allows you to confirm activities and activity elements

•  Allows you to create reservations or purchase requisitions for all components, depending on
settings elsewhere.

If the corresponding Customizing setting have been made, the system triggers an availability
check for material and capacities.

You cannot cancel the Released status.
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Technically completed (TECO)
Use
You use this status for networks, activities, and activity elements that are completed from a
technical (logistics) point of view.

Prerequisite
The network header or the activity must have the Released status.

Use
If the status is set in a network header, you cannot change the header data or create new
activities. If it is set in an activity, you cannot change activity data.

The status

•  Allows actual postings, for example confirmations

•  Sets a deletion flag for the material components

•  Removes capacity requirements, provided a final confirmation has not been made

•  Deletes purchase requisitions and requirements for material components, if any exist.

•  Prohibits changes to the characteristic value assignment

•  Prevents you setting a user status

•  Prevents you from changing dependent data such as material and PRT allocations.

You can cancel the Technically completed status. In this case the system sets the Released
status.

If you cancel the Technically completed status in the network header, the status is
not automatically canceled in the activities and activity elements. You can cancel the
status in individual activities or in all activities.

Closed (CLSD)
Use
The Closed status closes a network or an activity from both a logistics point of view and an
accounting point of view.

Prerequisites
You can set the Closed status, if the network header, activity, or activity element has the
Released or Technically completed status, and

•  No balance exists

•  All activities that require confirmation have been confirmed.

Use
If the status is set in the network header, you cannot change the header data or create new
activities. If it is set in an activity, you cannot change activity data.
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The status

•  Prevents you from changing dependent data such as material and PRT allocations.

•  Prevents you making actual postings, for instance, confirmations

•  Removes capacity requirements, as long as a final confirmation has not been made

•  Deletes purchase requisitions and requirements for material components, if any exist.

You can cancel the Closed status. The system then set the previous status (Released or
technically completed).

If you cancel the Technically completed status in the network header, the status is
not automatically canceled in the activities and activity elements. You can cancel the
status in individual activities or in all activities.

Deletion flag (DLFL )
Use
The Deletion flag status designates networks and activities that have been flagged for deletion.
This means that the objects are deleted logically, but not physically.

Prerequisites
You can the Deletion flag, if

•  The actual costs of the network are balanced.

If you set the Must not be settled or Can be settled in the settlement profile in
Customizing for Product Cost Controlling, you can still set the Deletion flag status,
even if the actual costs are not balanced.

•  Assigned orders also have the Deletion flag status

•  There are only relationships to networks that have a Deletion flag.

•  No commitments exist for the network

•  No purchase requisitions or purchase orders exist that are account assigned to the network.

Use
If the status is set in the network header, you cannot change the header data or create new
activities. If it is set in an activity, you cannot change activity data.

The status

•  Removes capacity requirements, as long as a final confirmation has not been made

•  Sets an internal deletion indicator for existing material reservations

•  Can also be set (after a warning is issued), if an activity requires confirmation but has not
been finally confirmed.

•  Is the prerequisite for setting a deletion indicator.
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You can set the Deletion flag status in addition to every other system status. The status is
passed on to activity elements. As long you have not set a deletion indicator, you can cancel the
Deletion flag status.

See also:
Archiving Operative Project Structures (PS-ST-OPR) [Ext.]

Locked (AALK or LKD)
Use
You can prohibit account assignment to a network or lock all data in a network or activity. The
following statuses are available:

•  Account assignment locked (AALK)

Depending on the network type, you can set the Account assignment locked status either
only in the network header or only in the activity

•  Locked (LKD)

You can only set the Locked status in the network header. The status is passed on to all
activities.

You can set the Account assignment locked and Locked statuses in addition to every other status
except Deletion flag.  The Account assignment locked and Locked statuses are not passed on to
activity elements.

You can cancel these statuses.



 SAP AG Structures

Setting the System Status for Networks

April 2001 103

Setting the System Status for Networks
Systemstatus in Netzplänen [Page 353]

You can only carry out business transactions for a network, if the corresponding system status
which allows this business activity has been set. For example, if you want to confirm an activity,
that activity must have the system status released.

When you release a network, all activities, activity elements and production
resources/tools are also released.

Procedure
1. Create a network or open an existing network.

2. Choose Edit → Status and then the required status, for example Released.

The system sets the system status in the network header.
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Configuration
Use
You can use configuration, if you use the Project System to manufacture products with different
features or options. The planning instruments, such as networks and work breakdown structures,
must be basically the same, but can have characteristics specific to the different variants, such
as additional activities or different material components.

When you use configuration, you assume there is a maximum standard structure which contains
all the data. That means, the standard network and the standard WBS contain all activities,
activity elements, materials, etc. that are necessary for any conceivable variation of the product.

Prerequisites
You differentiate between the variants using characteristics. Object dependencies in the standard
structures form a link between the characteristics or their values and the activities and activity
elements that are selected during configuration.

Configuration

Network Configuration

Characteristic value
assignment

Class Standard network
(reference to
material)Assignment

Characteristics Activities/PRT/Material/
Object dependencies

For more information about this subject and its prerequisites see Characteristic Value
Assignment [Page 106].
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Features
When you create an operative network by copying a configurable standard network the
configuration determines which activities, activity elements, PRTs and components are
transferred from the standard network. This applies irrespectively of whether you are working in
the Project System or from a sales document, a customer order for example.

If an activity is not selected in the configuration, the objects that are assigned to this
activity, for example relationships, activity elements or milestones, are not copied.

You can indirectly configure a work breakdown structure while creating it by assigning activities in
the standard network to standard WBS elements. Only those standard WBS elements are copied
that have been assigned to activities selected in the configuration. Superior elements in the
hierarchy are also copied.

For information about including a configurable standard network in an existing network or
replacing an activity with a configurable subnetwork, refer to Including Standard Networks Using
Configuration [Page 108]  Creating Subnetworks using Configuration [Page 191]

You can change the characteristic value assignment for a network later. For information on this,
refer to Configuration Changes in Networks [Page 110].

For more information about variant configuration and how you maintain data for configuration,
see the R/3 Library for Logistics General by choosing LO-Variant Configuration Guide.



Structures  SAP AG

Characteristic Value Assignment

106 April 2001

Characteristic Value Assignment
Use
You use characteristic value assignment to specify various variants while you are creating an
operative network by copying from a configurable standard network.

Prerequisites
Variant classes

You can only configure a standard network, if it is assigned to a class whose class type allows
configuration. In the standard system this is class type 300. By defining a configuration profile
you assign a standard network to a variant class, which contains the characteristics you need to
for specifying a variant.

Object dependencies

You must additionally maintain the object dependencies (selection criteria, actions and
constraints) for the objects that can be selected in configuration (activities, activity elements and
PRTs).

Characteristics

You edit characteristics and their possible values in classification, which you can find in the SAP
menu Logistics →→→→ Central functions.

Activities
Characteristic Value Assignment

The following distinction is made during the assignment of characteristic values:

•  Networks created from a sales document, such as a sales order.

If you assign a characteristic value for the sales document item to the same variant class
as the standard network, then the system copies this characteristic value assignment into
the network created from the standard network.

If you want the characteristic values to be assigned separately, the variant classes must
be different.

•  Networks created in the Project System.

After you have maintained the network header data, the system will prompt you to assign
the characteristic values.

Displaying and Changing Characteristic Value Assignment

You can display the characteristic value assignment in networks by choosing Extras
→ Configuration → Characteristic value assignment.

If the characteristic value assignment was carried in the network, you can change it in the
network, if it was carried out in a sales document, you can only change it in that sales document.
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If the configuration is changed [Page 110], a change comparison [Page 112]  is carried out, in
which the objects affected by the change are deleted, added or changed.
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Including Standard Networks Using Configuration
Use
You can also use configuration when including a configurable standard network in a network.

Prerequisites
•  The network in which the standard network should be included, must have been created

using configuration.

•  The variant class used for assigning characteristic values and that of the network to be
included, must be the same.

The configuration is then carried out using the network characteristic value assignment.

 
Both conditions have to met, otherwise the complete standard network will be
included. No separate characteristic value assignment is carried out.

See also:

Including Standard Networks in a Network [Page 97]
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Subnetwork Creation with Configuration
Use
As with networks, configuration is carried out, when you create a subnetwork using a
configurable standard network as a template.

Activities
If the network that is superior to the subnetwork was created using configuration, the following is
valid for characteristic value assignment:

•  If the variant class of the superior network is the same as the variant class of the standard
network that is being used as the template for the subnetwork, the characteristic value
assignment of the superior network is used.

•  If different variant classes are used, the characteristic value assignment has to be repeated
for the subnetwork.

•  If a configuration profile has not been maintained for the subnetwork, the characteristic value
assignment of the superior network is used.

See also:
Configuration [Page 104]

Characteristic Value Assignment [Page 106]
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Configuration Changes in Networks
Purpose
You can adapt a network to changes in configuration, if for instance, a network has links to a
sales order and the characteristic value in this sales order changes.

Prerequisites
In Customizing the Project System you have to define change profiles (in Structures →
Operative structures → Network) Here you determine how the system show react if there are
conflicts arise in the change comparison (for example what happens if a component is to be
deleted but a purchase order already exists for it).

Process flow
1. Changing the Characteristic Value Assignment

The characteristic value assignment [Page 106] can be changed in the network header by
choosing Extras → Configuration → Characteristic value assignment

If the characteristic value assignment has been copied from a sales document, you can only
change it in the sales document. It can only be displayed in the network.

2. Change Comparison

In order to determine which change steps are necessary as a result of a change in configuration,
a change comparison [Page 112]  is carried out.

This is done immediately.

•  If the value assignment of a network that was created by assembly processing is changed in
the sales document.

•  If the network itself was directly configured, and the value assignment is changed in the
network.

If the characteristic value assignment is changed in a sales document that was assigned to the
network manually, the change comparison can be created in the network.

The change comparison produces the necessary change steps for the objects that are affected
by a change in configuration (which objects have to be deleted, added or changed).

3. Executing the Change Steps

These change steps are executed automatically as long as no conflicts [Page 114]  occur. The
change steps that have been executed and those that are to be executed are listed in an
overview together with conflicts that have arisen.

Her you can - after the causes of the conflicts have been removed if necessary - trigger the
change steps [Page 116]  that are not executed automatically.
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4. Concluding the Change in Configuration

As long as not all the change steps have been executed or if some change steps have the status
Do not execute, the network header has the status Manual adjustment necessary. This status
does not allow another change to the configuration or scheduling of the network.

If all the change steps have been processed, you can close the change comparison. As a result
the Manual adjustment necessary status is removed.

Result
All change comparisons are saved with the corresponding administrative data (change date,
user, change comparison status as well as the old and new characteristic value assignment): To
go to change management from the network header choose Extras → Configuration → Change
management.
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Change Comparison
Use
After a configuration change [Page 110] the operative network is compared with a temporary
network, which contains the current configuration. As a result the necessary change steps are
determined. During this process, the manual changes to the operative network are taken into
account whenever possible.

Integration
A change comparison is started automatically if the characteristic value assignment is changed in
the sales document (assembly processing) or in the network (network was the object originally
configured)

If the value assignment is changed in a sales document that the network has been manually
assigned to, you can trigger the change comparison in the network header by choosing Extras
→ Configuration → Change management and then Change management → Create  change
comparison.  

Features
You can use configuration to select activities, activity elements, material components and
production resources/tools via object dependencies. During a change comparison the following
changes steps are executed for these objects:

Delete: The system tries to delete all objects that exist in the operative network and have a
reference to a standard network, but do not exist in temporary network. Activities that have the
status Created are deleted physically, from status Released on a deletion flag is set. Objects that
were created manually without reference to standard networks remain in the operative network
according to the settings in the change profile.

Add: The system tries to add all the objects in the temporary network that do not have a
counterpart in the operative network. If activities are to be added, all the subordinate objects
(activity elements, milestones, component allocation) are also added from the temporary
network.

Change: The field values of objects that exist in both the operative and the temporary network
are copied from the temporary network to the operative network. This affects data fields that can
be changed by the configuration via object dependencies as well as dependent fields. Scheduled
dates and actual dates are not changed on principle. Deletion flags for activities in the operative
network are reset.

If a conflict [Page 114] occurs during a change step, and this has error or  warning character, the
change step is not automatically executed in the background together with the change
comparison.

All change steps are logged with their processing status and information about the cause of the
conflict (error, warning or information message) in a change step overview. Here you can
manually trigger [Page 116] change steps in which conflicts with warnings have occurred, in the
case of conflicts with errors, you have to resolve the cause of the error first.
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Constraints

Manually deleted objects and manual changes to fields are not recognized and are not upheld
after a change to the configuration.

Subnetworks cannot be deleted automatically. A subnetwork has to be deleted manually or have
a deletion flag set manually before the corresponding activity can be deleted or have a deletion
flag set. Subnetworks are also not compared automatically during change comparison for a
network.
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Conflicts in Change Comparisons
Definition
Conflicts can occur when a change comparison [Page 112]  is run to determine the change steps
for adapting a network to a new characteristic value assignment.

Certain conflict situations have been pre-defined in the system. In addition you must define
change profiles in Customizing by choosing Structures → Operative Structures → Networks. In
these profiles you define the conflict character of further change steps. If steps cannot be
executed automatically because of conflicts, you have to trigger execution manually [Page 116]
in the change step overview after removing the cause of the conflict, if required.

The system reacts as follows:

•  Conflicts with information character: The change step is executed automatically and you
receive a message in the change step overview.

•  Conflicts with warning character: The change step is not executed automatically. You receive
a message in the change step overview, from where you execute the step manually.

•  Conflicts with error character: The change step is not executed. You receive a message in
the change step overview, from where you execute the step manually after you have
remedied the cause of the conflict.

The status Manual adjustment necessary and the business transactions Delete automatically and
Change automatically are used to control the system behavior during configuration changes
[Page 110].

Pre-Defined Conflict Situations with Error Character
Delete Activity/Activity Element

•  Status management (set deletion flag) negative

•  Commitments/balance not balanced

•  Subnetwork exists

•  Business transaction Delete automatically forbidden at header or activity level.

Add/Change Activity/Activity Element

•  Activity/element with the same activity number already exists

•  Business transaction Change automatically forbidden at header or activity level.

•  Activity has status Technically completed or Completed

Delete. Add and Change Material Components or PRTs

•  Superior activity has status Technically completed or Completed
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•  Business transaction Change automatically forbidden at header or activity level.
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Executing Change Steps
1. In the network header choose Extras → Configuration → Change management.

 An overview of the change comparisons appears together with the administrative data for
the network configuration changes. From this list you can display the old and new
characteristic value assignment for every change comparison as well as the change
steps and their status.

2. If the characteristic value assignment was changed in a sales document that was
assigned to the network manually, the change comparison cannot be created
automatically.

 In this case first choose Change management → Create change comparison

3. To display or edit change steps, select the required change steps and choose Change
management → Overview change steps.

 The overview displays all the necessary change steps together with their status and
information about existing conflicts.

  / /  Object to be added / deleted / moved

  Field(s) to be changed

  Execute change steps

  Change steps have been executed

  Change steps can be executed

  Conflict with warning character, change step can be executed

  Conflict with error character, change step cannot be executed (remove cause
of error first)

  Change step has been set to “Do not execute”.

  Object depends on a superior object (for instance component allocations that
are created or deleted with an activity).

  Message log for the conflicts

4. By choosing View → Filter, you can specify that only certain object types or comparison
results are displayed, for instance only objects to be deleted.

5. Edit the individual change steps:

 If you have removed the causes of the conflicts [Page 114] (for errors) that occurred, you
can execute the relevant change steps in the overview. To update the status display,
choose Edit → Check all change steps.

 To execute all the change steps, choose Edit → Execute all change steps

 To execute a single change step, click on   in the relevant row.

 If you do not want to execute a change step, choose Edit → Status  → Set to Do not
execute. You can reset this status later.

6. To leave the processing of change steps, choose Goto → Back.
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 If there are still change steps to be executed, the status of the change comparison is
open. It is complete, if  all the change steps have either been executed or have been set
to “Do not execute”.

7. If the status is complete, you can close the change comparison. To do so, choose
Change management → Close change comparison.

The status Manual adjustment necessary is removed from the network header.
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Network Assignments
You can link different structures within your project in the network header. This can be
necessary, for instance, if you want to link process structures to hierarchical structures or if you
have to plan dates and costs in relation to other objects in the project.

The network can be assigned to

•  a project definition or a WBS element

•  a sales document, such as a sales order or

Project Definitions/WBS Elements Assignments

Sales Document Assignment
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Assigning Networks to Project Definitions/WBS
Elements
Procedures
Assigning a Network to a Project Definition
If you assign the network header to a project definition, you can copy the dates from the project
definition into the basic dates of the network.

1. Call up the network header.

2. On the Assignments tab page maintain a project definition key.

3. Choose Enter.

The Date transfer dialog box appears.

4. If you want to copy the basic dates from the project definition, choose Yes.

The project definition dates are copied into the network as basic dates.

Assigning a Network to a WBS Element
If you assign a network header to a WBS element and have not yet specified a project definition,
the project definition will be copied automatically when the assignment is made.

To be able to assign a network to a WBS element, you must first identify the WBS
element as an account assignment element.

The WBS element is copied into all activities and activity elements as a default value. You can
also assign activities to other WBS elements in the activity overview.

The WBS element is only copied into all activities if you create the network or
activities.

1. Call up the network header.

2. On the Assignments tab page maintain a project definition key.

3. Choose Enter.

The Date transfer dialog box appears.

4. If you want to copy the basic dates from the project definition, choose Yes.

The project definition dates are copied into the network as basic dates.

Dates From the Project Definition/WBS Element
The dates from the project definition or the WBS element are copied into the network header as
follows.

If you entered a project definition and a WBS element the date from the WBS element are used.

If the WBS element does not have a start or finish date, the system copies the dates from the
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superior WBS element or the project definition into the network header.
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Sales Document Assignment
Umsetzung von Angeboten in Kundenaufträge [Ext.]

Kopieren von Belegen [Ext.]

You can only assign a sales document, such as a sales order, when you create or change a
network, before it is released.

If a sales document (follow-up document) originates from another sales document, for example a
sales order from a quotation and/or a request for quotation, the account assignment is to the
original document. The same is valid for inventory management

During assignment you can enter the number of every document in the chain; the system
automatically determines and displays the original document and the last document in the chain

The following applies to the assignment

•  If you assign a sales order, that is settled to a project, you maintain a WBS element in the
network header simultaneously. The WBS element must have the same project definition as
the WBS element which is maintained for account assignment in the sales order.

In this case, the system automatically creates the settlement rules for the network.

•  If you assign a sales order, that is not settled to a project, you cannot maintain any WBS
elements in the network header.

See also:
Sales
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The Network Structure Graphic
In the network structure graphic you have all the functionality for creating a network at your
disposal, such as inserting new activities or creating new relationships.

To be able to work with the network structure graphic, you must have first defined a graphic
profile in the network profile in Customizing.

You can access the network structure graphic from the network header and the individual
overviews, such as the activity overviews or the relationship overview, by choosing Goto →
Graphics → Network structure.

You will find more detailed information on the network structure graphic in the following sections:

Graphic Mode [Page 123]

Network Structure Graphic Menu [Page 124]
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Graphic Mode
When you call up the network structure graphic, the screen is normally divided into two sections:

Display Area
The display area shows the active portion of the navigation area.

•  You can enlarge or reduce the size of the active portion with the function keys F5 and F6.

•  You can collapse either the activities inside a frame or the frame itself.

Navigation Area
In the navigation area you can see the entire network or standard network.

•  The active portion shown in the display area is enclosed by a frame.

•  To view another section of the network in the display area, move the frame within the
navigation area.

•  Change the size of the display frame by dragging the frame to the required size in the
navigation area.

•  Subnetworks or standard network alternatives are displayed in another frame.

There is a toolbox above the display area containing the most important functions for working in
the network structure graphic.

See also:
BC SAP Graphics: User’s Guide [Ext.]
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Network Structure Graphic Menu
The following section gives you a brief overview of the functions available in the network graphic
menu.

Edit

Under the menu option Edit you will find all functions for editing activities and their relationships,
as well as all settings that you could need for the activities, such as the set of dates.

You can check the (standard) network for loops by selecting the menu options Edit →→→→ Functions
→→→→ Loop.

See also:

Loop Analysis [Page 186].

To obtain different views of activities, you can group them according to network or WBS element
by selecting the menu options Edit → → → → Settings  → → → → Grouping  →→→→ Network or WBS element:

•  When you group according to network, the activities are displayed in a frame by network or
subnetwork. The network or subnetwork number is displayed in the frame and the WBS
element is displayed in the activity.

•  When you group according to WBS element, the activities are displayed in a separate frame
for each WBS element. The name of the WBS element to which the activities are assigned is
displayed in the frame and the network number is displayed in the activity.

In both cases you can change the display and the relationships but not the assignments to WBS
elements.

Goto

You can call up the different activity overviews by selecting the menu option Goto.

Details

You can call up the detail screens for activities and relationships by selecting the menu option
Details.

Settings

Under the menu option Settings you can make all the settings relevant to the graphic, as well as
for displaying graphic elements, for example, hiding the navigation area. You can open another
window by choosing View  →→→→ New view.

For ease in editing activities, you can further limit the display area by choosing Settings  →→→→
Restrict area →→→→ On. The display of the selected activities does not change. Activities that are
linked to the selected activities by relationships are displayed as circles.

Extras

From the Extras menu option you can display error logs.
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See also:

BC SAP Graphics: User’s Guide [Ext.]
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Printing Network Graphics
There are the following ways of directly printing graphics in the Project System:

•  You can print directly on a local PostScript printer by choosing Print.

•  You can use the R/3 Spooler to choose any Postscript printer you want.

•  You create a print file in the graphic and print externally -for example, on a plotter.

See also:
BC - Printing Guide [Ext.]

Creating Print Files
You can create the following print files for graphics in the Project System:

•  GRANEDA metafile for output on plotter

•  Postscript, Format DINA4, and 1:1 on laser printer

•  HPGL format in DINA4 to DINA0 for output on plotter



 SAP AG Structures

Sending the Network Structure Graphic via Mail

April 2001 127

Sending the Network Structure Graphic via Mail
You can send another user a “snapshot” of the network graphics via mail.

Procedure
1. Call up the network.

2. Choose Goto → Graphic  → Network structure.

The network graphic appears.

3. Choose Network → Send...

The Send document screen appears

4. Enter a tittle and /or a note and send the graphic.
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Printing Shop Papers for Networks
Use
In the SAP System, the printing of shop papers for networks is carried out in the form of lists.

Lists created and printed by the system refer to all activities, activity elements, components and
production resources/tools in a network.

Features
You can print shop papers directly from the network [Page 129] or in the background [Page 131].

There are three print types in the SAP R/3 System:

•  Original printout, that is, the first printout of the shop papers.

•  Reprint, that is, the subsequent printing of shop papers that have already been completely
printed.

•  Partial print, that is, the print of partially released networks.
This print type is useful if you want to release the individual activities in a network
consecutively. The system prints lists for activities that are released but not yet printed.

If you are in the display mode, you can only reprint lists.

Activities
In order to print shop papers for networks, you must define in Customizing, who can print which
lists using which transaction, the appearance of these lists and which data they should contain.

For details refer to the Implementation Guide for the Project System.
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Printing Directly from Networks
All list types defined in Customizing for the corresponding network type, plant, and MRP
controller can be printed within network processing.

Prerequisites
The following prerequisites must be met, to print lists for activities and activity elements:

1. If the parameters have been set in Customizing so that the control key for the activities is
checked when lists are being printed, then  you must check the control key for each activity
to see whether it allows you to print activities, time tickets and confirmation slips.

If the Customizing parameters do not specify a check on the control key, neither the
control key nor the status is checked. In this case, the system does not set any print
statuses.

2. The status of the network and the activity must allow printing of lists.

Printing of lists is allowed, if the network is:

- either released or partially released
- neither technically complete nor deleted.
The printing of individual activities in a network is allowed if:

- the network is either partially released or released
- the activity is released, but not deleted.

If the network status does not allow printing, no lists are printed. If the network status
allows printing, lists are printed. However, if the network contains activities whose status
does not allow printing, these activities are omitted from the list.

3. If you want to print time tickets or confirmation slips, the number of time tickets or
confirmation slips in the activity must be larger than zero.

The number of time tickets or confirmation slips is a default value you defined in the work
center. It can also be entered by choosing Details → Activity/Element → General and
the tab page additional data.

Whether components or production resources/tools are printed on a list depends on the
status of the activity to which they are allocated. If the activity can be printed, the allocated
components can also be printed.

Phantom assemblies cannot be printed.

Procedure
To print from a network, choose:

•  Network → Print → Shop papers in the network header or
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•  Network → Print → Object overview in the object overview.

If you do not want to print all the list types allowed, you can limit the number of lists to be printed
for a network by selecting the menu options: Network → Print → Print settings → List control.

Results
•  In create mode and change mode, printing is carried out after you save the network.

•  In display mode printing is carried out immediately.
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Printing Shop Papers in the Background
You can print shop papers in the background by creating print indicators for networks. Within
background job scheduling, you can specify that a background printing report is to be started at
regular intervals. This report initiates the printing of lists.

In Customizing, you can set up the parameters for printing in the background by creating print
jobs for activating print indicators.

Prerequisites
The same prerequisites as for directly printing shop papers [Page 129]  must be met.

Procedure
To create a background printing indicator, proceed as follows:

1. Call up the network header.

2. Select the menu options Network → Print → Print settings → Print mode.
A dialog box is displayed in which you can select a print mode.

3. Select background processing. Choose Continue.
The system automatically creates a print indicator when you save the network.

The system only prints one original printout per network, even if you have created
several print indicators.
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Activities
Definition
The German standard DIN 69 900 describes activities as "components of a process " with the
following characteristics:

•  They have a duration.

•  They have a defined start and a defined finish.

•  They are processed without interruption.

•  Resources are needed to execute them.

•  They incur costs.

The Project System distinguishes between the following types of activity:

•  Internally processed activities

•  Externally processed activities

•  General costs activities

You can break down the activities into activity elements for more detail.
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Control Keys
Definition
Control keys stipulate the type of activity and activity element.

Use
You can use the control key to determine:

•  Which business functions can be carried out for the activity, for example, whether costs
can be calculated.

•  How the activity is handled when processed, for example, whether it is costed or whether
it can be confirmed.

You define the control key in Project System customizing. You can enter the defined control key
in the network profile or standard network profile where it acts as a default value for new activities
and activity elements. However, under certain conditions, you can change the control key in the
detail screens for activities and activity elements.

 
You cannot change the control key for general costs activities or services.

Once the activity has been released, no further changes to the control key are
possible.

This is useful if you discover that you cannot carry out an activity in your own organization
(internally) because of capacity or time constraints, and want to have it performed externally.

You can change the following activity types using the control key:

•  Internally processed activities into externally processed activities

•  Externally processed activities into internally processed activities

If you change the control key for an externally processed activity, for which a purchase
requisition has already been created, into an internally processed activity, the system
deletes the purchase requisition.
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Execution Factor
Definition
Determines how often an activity or activity element is executed and refers to:

•  Work

•  Duration

•  Quantity of material

•  Costs

The execution factor of an activity is also the execution factor of the activity elements.

Use
The Effects of an Execution Factor in the Network Header
If an execution factor larger than 1 is entered in the header, you can only enter a multiple of this
factor in the activities.

If the factor in the header changes, the factors in the activity change correspondingly. An
execution factor in the header only effects operations that themselves have an execution factor
(even it is 1).

Execution Factors in Standard Networks
When you enter an execution factor in a standard network, it is a default value for networks that
are created from this standard network.

Execution Factors in Networks
When you copy a standard network to create a network, the values are multiplied by the
execution factor. Example:

Standard network Network
Execution Factor 3 3
Activity duration 2 hours 6 hours
Work 4 hours 12 hours
Material quantity 1 pieces 3 pieces
Costs $ 150 $ 450

Changing the Execution Factor
When you change the execution factor, the system automatically calculates new quantities.
Example:

Old value New value
Execution Factor 3 2
Activity duration 6 hours 4 hours
Work 12 hours 8 hours
Material quantity 3 pieces 2 pieces
Costs $ 450 $ 300
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Execution Factors in Assembly Processing
If, during assembly processing, you enter a value larger than 1 for the quantity in a sales order
item, the system calculates the quantity to be produced and multiplies this number by the
execution factor of the standard network, when it creates an operative network. Example:

Quantity in sales order item = quantity to be produced =  2

Standard network Network
Execution Factor 3 6
Work 10 minutes 60 minutes
Material quantity 4 pieces 24 pieces
Costs $ 150 $ 900
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Activity Elements
You can break down activities into activity elements for more detail. For example, the activity
"Production" can be subdivided into the elements "Produce power unit" and "Produce housing".
Or you can create an external element for the activity "Engineering/Design", if for instance a
detailed design is to be performed by an external company.

There are the same categories for activity elements as for activities themselves in the Project
System:

•  General costs elements

•  External processing elements

•  Internal processing elements

You can create activity elements for every activity.

Activity elements contain the same information as activities:

•  A work center can be assigned to them.

•  They can be assigned to WBS elements

•  The operative level for costing and confirmations is determined by the control key.

•  The dates for the activity elements are calculated with respect to the start date or the finish
date of the corresponding activity. Enter an offset to the start or finish of the activity to specify
the start/finish of the activity element.

You cannot allocate materials, or assign milestones, documents or production
resources/tools to activity elements. Activity elements do not have relationships.
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Resources
Work Resources [Page 138]

External Resources [Page 156]

Services [Page 151]
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Work Resources
To plan the work involved in your project as well as provide the basis for calculating the costs
incurred, you specify in the network activities, for example:

•  how much work must be done to carry out the activity.

•  which capacities (for example, labor or machines) will perform the work.

•  which qualifications are necessary to perform the activity

•  which individual capacities or people are necessary to perform the activity

Work Centers [Page 139]

Work Data in the Activity [Page 144]

Maintaining Work Data in Activities [Page 146]
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Work Centers
PP - Arbeitsplätze [Ext.]

A work center is a physical unit within a company where an activity is performed.  For example, a
work center may be an individual, a group of people, a single machine, or a production line.

The data stored in the work center is required for the following business functions:

•  costing

•  scheduling

•  capacity planning

See also:
For more information on work centers, refer to PP - Work Centers Guide.

(Standard) Networks Without Work Centers
You can also create activities without work centers, for example, when you are not sure where
the activity is to be performed, or if you only want to use the (standard) network to determine the
dates on which the activities should be performed.

When you do not enter any work centers in the activities, the system only calculates the basic
start and finish dates and does not calculate capacity requirements or costs.

Costing Data in the Work Center [Page 140]

Scheduling Data in the Work Center [Page 143]

Capacity Data in the Work Center [Page 141]
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Costing Data in the Work Center
Using the costing application, you can calculate the costs for activities performed with work
resources in the network.

To be able to cost a network, each work center has to be assigned to a cost center, and activity
types (so called “CO activities”) have to be planned for the cost center.  The cost rates in the
activity types  specify how work in an activity is valuated.

The system determines the costs for internal network activities using the formula you maintained
during work center maintenance.  On the Cost Center Assignment screen enter the formula in the
field Other activity type.  Generally, the system uses the value you entered for work in the
network activity in the formula, however, you can specify other formula parameters.

See also:
For more information on how the plan and actual costs are determined for networks, refer to
Planning Costs in Networks [Ext.]
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Capacity Data in the Work Center
Capacity data in the work center and available capacity together tell you what your people and
machines can handle in a certain period of time.  Available capacity tells you how much work the
capacity category can perform per work center.

Capacity categories include:

•  a machine on the shop floor

•  a group of people working on a production line

•  a group of engineers

You can have several capacities per capacity category.

The system calculates the capacity requirements for networks using the formula entered in work
center maintenance.  This formula is maintained on the Overview of Capacity Allocations screen
in the field Other formula.  Generally, the system uses the value you entered for work in the
network activity in the formula, however, you can specify other formula parameters.

If you do not enter a formula to calculate the capacity requirements of internal
activities, the system will not generate capacity requirements during scheduling.

Capacity planning compares the capacity requirements of activities that were calculated in
scheduling with the available capacity defined in the work center.

Capacity Splits
To carry out detailed resource and resource commitment planning, you can divide capacity
categories into individual capacities, for example, into single machines, for which you can enter
specific capacity data.

In the network activity, you can split the capacity requirements into individual capacities
(“capacity splits”).

People
You can assign individual people to a work center or a capacity category.  To be able to do this,
you  must first  enter them in personnel administration

In the network activity, you can split the capacity requirements among the people necessary to
perform the activity.  You can confirm the work that these people have performed as well as their
attendance or absence in a confirmation of the activity.

Positions
By assigning a work center or a capacity category to a position, you can use the position to select
people for their qualifications.  You must first have defined the positions in the Personnel
Planning & Development System (PD).

If you enter qualifications for the activities in a network, you can reference them later via the
position.
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Qualifications
To guarantee a selection among suitable employees, you can enter the qualifications to be “met”
in the work center or the capacity category.  Later, in resource planning you can reference this
information via the position.

Qualifications which you enter for activities in a network will be compared with the qualifications
in the work center or the capacity category when you create a ranking list.  From this list you can
select the people who best meet the requirements for the activity.  The ranking list is created
from the total requirements profile, taking the qualification requirements from the work center,
capacity and activity all into consideration.

Distribution of Capacity Requirements
With the distribution key for capacity requirements you can specify how much of the capacity is
required for a certain percentage of the duration.  This distribution is taken into consideration in
capacity planning.  You can enter the distribution key in the work center, in the activity or in
capacity planning.  In the work center, networks are considered one of the “other types of internal
processing”.  In Customizing of capacity planning you can determine which distribution key will
be used in capacity planning.
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Scheduling Data in the Work Center
In scheduling, the system calculates the start and finish dates of activities, the float times and the
capacity requirements.  Scheduling uses the following data from the work center:

Operating Time
If you specify a unit smaller than "day" for the duration in the activity, scheduling uses the
operating time you maintained in the work center.

Scheduling Formula for Other Types of Internal Processing
The system  calculates the actual duration of the activity using the formula entered on the
scheduling screen of the work center and the duration you specified in the network activity.  In
the work center, networks are considered to be one of the “other types of internal processing”, so
on the Scheduling screen, in the section Execution Time the formula is maintained in the field
Other formula.  Generally, the system uses the value which you entered for Duration in the
network activity, however you can specify other parameters in the formula.

When you enter a work center for an activity, but do not enter a formula for other
types of internal processing in this work center, the system will schedule using the
duration you entered in the activity.

Calendar
If you do not specify a calendar in the work center, the factory calendar is used in scheduling.
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Work Data in the Activity

You can enter more detailed work data for the activity in the “work” activity element.
Work elements contain the same information for planning work as the data for work
in the internally processed activities.

Activity Types (CO Activities)

In activity-based accounting, activity types are used to calculate the costs in
production orders, networks etc.  Within the Project System they are referred to as
“CO activities” to reflect the controlling view of the activity.

If you want to cost networks, you have to enter an activity type in the field other activity type and
a formula key for calculating costs.  In work centers, networks are considered one of the “other
types of internal processing".  You can use the activity type to, add another cost rate for special
qualifications, or weekend work, for example.

What you enter in the field other activity type in the work center is what will be  proposed as a
default value in the activity in the network.  You can also enter a different activity type during
planning or a confirmation.

You can only enter a different activity type in the network activity, if the new activity
type is assigned to the same cost center as the work center.

Work
Here you specify the planned amount of work involved in carrying out the activity.  For example,
you can specify the engineering activity in hours or energy requirements in kilowatt hours.  Using
the value for work and the formula for calculating capacity requirements entered the work center,
the system determines the capacity requirements during scheduling.

You can enter basic and forecast  data for work in network activities.

Number of Required Capacities
Here you specify the how much capacity  is required to do the work in the activity - for example,
two people or three machines.  This number refers to the capacity category, which is entered on
the scheduling screen in the work center.

You should to enter a number in this field if you want to determine the duration of, or the work in
the activity using the calculation key.

Percentage
With this value you specify the percentage of the operating time that is used in the activity.

The percentage is only used when you let the system calculate duration, work or the number of
capacities using the calculation key.

If you do not enter a percentage, the system will assume 100%.
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If you enter a work center in the activity, the system calculates duration using the operating time
defined in the work center.

Calculation Key
You can maintain the data for work, duration, and number of capacities required manually, or,
you can let the system determine it using the calculation key.

Depending on the calculation key you entered in the activity, the system calculates:

•  work

•  duration

•  number of required capacities

The following table lists which data you have to maintain for which calculation key.

You can also use the calculation key to calculate work and duration without entering
a value for the number of capacities.  The system automatically sets the number to
one and 100 percent for the operating time.

Calculation key for... You must enter...

Duration Number of capacities
Percentage for operating time
Work

Work Number of capacities
Percentage for operating time
Activity duration

Number of capacities Percentage for operating time
Work
Activity duration

Distribution of Capacity Requirements
The key for the distribution of capacity requirements specifies how much capacity requirements
are accrued (in percent) after a certain percentage of activity duration.  The resulting distribution
is included in capacity planning based on the distribution key you specified in Customizing.
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Maintaining Work Data in Activities
You maintain work data in the standard network and in the network:

•  for internally processed activities on the basic data overview and the work overview
screen as well as on the respective detail screens.

•  for work elements on the work element overview and the respective detail screen.

1. Select Goto → Internal proc. overv → Work
The Work Overview screen is displayed.

2. Enter the work data.
You can enter additional work data on the detail screen.

3. Select the activities for which you want to maintain further work data.

4. Select Details → Activity/Element → Work.  The detail screen for selected activity is
displayed.

5. Enter the required data on the detail screen or change the existing default values, if
necessary.

6. Return to the basic data overview screen with F3.

7. Save your data..
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Capacity Splits
You can split the capacity requirements among activities and activity elements.

1. Select the menu options Goto → Internal act. overv. → Work

The Work Overview screen is displayed.

2. Select the activities whose capacity requirements you want to split.

3. Select the menu options Details → Activity/ Element → Capacity Splits.

The Capacity Splits screen is displayed.

4. Maintain the data.
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Assigning Qualifications
You can assign qualifications to activities and activity elements.

1. Select the menu options Goto → Internal act. overv. → Work. The Work Overview screen
is displayed.

2. Select the activities to which you want to assign qualifications.

3. Select the menu options Details → Activity/Element → Qualifications
The Qualifications dialog box is displayed.

4. Maintain qualifications in the requirements profile.  You can view them here.

5. Click on the Rnk.list (ranking list) pushbutton to select the people who are best suited for the
activity.

In order for the system to be able to make a suitable match with a specific person,
you  must have maintained qualifications in PD.
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Replacing Work Centers in Standard Networks
You can replace work centers used in standard networks.

1. From the SAP main menu, select the menu options Project management → Basic data →
Standard network → Replace functions →  Work center.  The Replace Work Center:
Selection screen is displayed.

2. Enter the old and new work centers on the selection screen as well as any other relevant
data.  Click on Proceed.

You will get a list of all standard networks and activities which contain the work center.

3. Select the activities, in which the work center should be replaced, and then click on Replace
work center. The work centers are replaced and the standard network is saved.
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Where-used List for Work Centers in Standard Networks
You can create lists showing the standard networks in which specific work centers are used.

This list can be displayed online in an object overview.  Once you have displayed the list you can
choose from several overview variants for different displays.

From the list of the selected standard networks, you can, for example, branch to one particular
standard network and display the detail screens for the various activities.

To display where a work center is used in standard networks, proceed as follows:

1. Select the menu options Logistics /Accounting → Project management → Information
system.

2. Now select the menu options Information system → Structure/Schedule → Where-used lists
→ Wrk cntr in std. net.

3. Enter the data for the where-used list.

4. Click on Proceed.

– If you have not yet entered an overview variant in the profile for standard networks,
the system will display a dialog box where you can choose one.

– If you have entered an overview variant in the profile for standard networks, the
system will automatically call up the correct object overview.

With the menu options Settings → Object overview you can select other overview
variants.

The system displays a list of all standard networks where the work center is used.

5. To display a detail screen for an activity or activity element, select the object and click on
Goto → Detail.

6. To get more information on the standard network, click on Goto → Overview.

The system branches to the alternate overview.  On this screen you can access other
standard network functions.
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Services
Dienstleistung (MM-SRV) [Ext.]

Definition
You can also plan services which are to be performed by an another company using externally
processed activities and external elements. These activities are the link to the SAP application
MM Services (MM-SRV). This application supports the entire cycle in contracting services: from
proposals and awarding contracts to the acceptance of services.

Using the data you have entered for the service, the system automatically creates a purchase
requisition in which all services for an externally processed activity are summarized into the sub-
items.

There are two ways to enter a service in the system:

•  As a planned service

With planned services, you can refer to services that have been entered as a service
master. You can however just enter a text and an amount for services.

The service master is a source of default data. You can reference it for services you want
for your external activity.

•  As an unplanned service

Unplanned services are those tasks which cannot or should not be specified because it
is still unclear what exactly the task involves, for example, the translation of technical
drawings which do not yet exist.

For unplanned services you can only enter a description and an amount. You can set a
value limit for the amount that should not be exceeded. In addition, you can reference
existing contracts in Purchasing.

After the services have been performed, you can record them on service entry sheets and then
accept them. Accepted entry sheets form the basis of invoice verification for services.

In the following graphic you can see the individual steps involved in the procurement cycle from
the solicitation of bids for specific services to invoice verification.
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See also:
MM - Services

When are Purchase Requisitions Created?
You can create purchase requisitions:

•  When you release a network

•  Manually in networks using the menu options Edit →→→→ Functions →→→→ Activate PReq/resrv.

You can use this function if, for example, your project is still in the proposal stage and you do not
want any purchase requisitions to be created yet.

On the external processing detail screen, you can:

•  See the number the system assigned to the purchase requisition

•  Branch to the purchase requisition itself

•  See whether a purchase requisition exists

Changes to Quantities and Dates
If quantities and dates in the activity change, the purchase requisition is automatically corrected,
if it has not yet been converted into a purchase order. Depending on the release procedure in
Purchasing, quantities and changes will be corrected automatically.

If quantities and dates in the activity change and the purchase order has already been created, a
workflow is started. The purchasing agent receives a message in the mail system regarding the
changes that need to be made. This person can then make the necessary changes to the
purchase order directly from the mail system.
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Costs of Services
The system determines the costs of the service from the price you have entered for the service.
With the cost element in the activity, you can determine how the activity should be valuated.

Pricing using conditions is possible in the network.
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Maintaining Data for Services
Leistungsgliederung pflegen [Ext.]

Leistungsverzeichnis (LV) [Ext.]

Prerequisites
In order to plan services for an external activity, you must

•  Enter the relevant control key, or

•  Set the Service indicator on the External processing tab page of the activity overview.

You can also maintain data for services in standard networks.

Maintaining Data for Services
1. In the activity overview choose the External processing tab page.

2. Enter the data for the activity and set the Service indicator.

3. Choose Enter.

You may have to enter some additional data  for external processing, for example the
material group and the purchasing group.

The Service Specifications Maintain screen is displayed

4. Enter the services required for the activity.

Outlining Service Specifications

You can break down the services you enter further and enter additional services for each level in
the outline.

1. On the Service Specifications Maintain screen, select the menu options Goto →→→→ Outline.

The Service Specifications Outline screen is displayed.

2. Position your cursor on the service and click on Edit → New Subgroup.

The Maintain Outline Level screen is displayed.

3. Enter a new outline level, a short text and then choose Continue.

A new subgroup is created.

4. If necessary, create more outline levels.

5. Position your cursor on the service and choose Goto → Services.

6. Enter the services.

7. Choose Back.

The service outline reappears.

8. By choosing Extras →→→→ Total values you can cumulate the planned values on the top outline
level.
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9. You can also view the structure or the service values graphically by selecting the menu
options Goto →→→→ Graphic→ Hierarchy graphic.
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External Processing
Einkauf (MM-PUR) [Ext.]

Definition
You can create externally processed activities in your network - for example, if you award the
contract for designing a machine to an external design agency.

The system takes the data in the activity and creates a purchase requisition which is processed
by the purchasing department. For external processing purposes, you can refer to data from the
purchasing department - for example, to a purchasing info record. This contains the prices and
delivery times applying to external processing.

See also:
For more information on purchase requisitions and purchasing info records, refer to MM
Purchasing .

 
Activities and activity elements are processed in the same way in external
processing. The following describes only the functions for externally processed
activities. Where there are differences, these are mentioned specifically.

The graphic illustrates how the purchase requisition from an externally processed activity is
processed.

Purchase
order

Purchase
requisition

Activity 10Activity 10

Activity 20Activity 20

Activity 30Activity 30

Activity 40Activity 40

Activity 50Activity 50

 Processing at the 
vendor

Goods receiptGoods receipt

External Processing

When are Purchase Requisitions Created?
You can create purchase requisitions:

1. When you release a network

2. Manually in networks by choosing Edit →→→→ Functions →→→→ Activate PReq/resrv.
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You can use this function if, for example, your project is still in the proposal stage and you do not
want any purchase requisitions to be created yet.

In the external processing detail screen, you can:

•  See the number the system assigned to the purchase requisition

•  Branch to the purchase requisition itself

•  See whether a purchase order exists

Changes to Quantities and Dates
If quantities and dates in the activity change, the purchase requisition is automatically corrected,
if it has not yet been converted into a purchase order. Depending on the release procedure in
Purchasing, quantities and dates are corrected automatically.

If quantities and dates in the activity change and the purchase order has already been created, a
workflow is started. The purchasing agent receives a message in the mail system regarding the
changes that need to be made. This person can then make the necessary changes to the
purchase order directly from the mail system.

External Processing in Standard Networks
You can also maintain data for external processing in standard networks. If you use the standard
network as a template for creating a network, the system copies the purchasing date into that
network.

External Processing Costs
The system calculates the costs from external processing using one of the following:

•  The net price, which you enter

•  The data stored in the purchasing info record
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Maintaining External Processing Data
You usually maintain data for external processing for activities outside of your organization.
However, you can also enter data for the external processing in internal activities.  For example,
if you do not yet know whether the activity is to be processed internally or externally.

If you realize in the course of the project that an activity will be have to be performed externally to
keep on schedule, then you only have to change the control key on the detail screen.  The
internal activity then automatically becomes an external activity.  When you save the network, the
system generates a purchase requisition for the external activity.

You can record the following data for external processing in the network profile:

•  control key

•  purchasing organization

•  cost element

Data for Externally Processed Activities
You enter the activity data on the External Processing Overview and on the detail screens.

If you maintain data for an external activity, you must also specify a cost element.  The cost
element determines how the external activity is to be valuated.

You can also define a work center for an activity performed externally.  For example, if a vendor
frequently performs the same activity for your company, and you have promised this vendor a
certain quota of work.  You can then track this vendor’s capacity in the Project System through
the work center and by entering a control key in the external activity which allows capacity
requirements planning.

If you change an external activity to an internal activity by changing the control key, this affects
external processing as follows:

•  If a purchase requisition has already been created for the activity, the requisition gets marked
for deletion.

•  If a purchase order already exists, you receive a warning.  The purchase order is not deleted
automatically.

You can no longer change the control key once the activity has the status “released”.

Data for the Purchase Requisition
You maintain the data for the purchase requisition on the External Processing Overview and the
detail screen.

Purchasing Info Record
The purchasing info record is a source of information for the purchasing department.  It contains
quotation and purchase order data, which are copied into the purchase order.
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When entering the data for an external activity, you do not have to reference an existing info
record, rather you can also enter the data for the purchase requisition manually.

Purchasing info records used for external activities cannot be allocated to a material.

If you enter a purchasing info record, the following data is copied from and cannot be changed:

•  sort string

•  price unit

•  price

•  currency

•  planned delivery time

•  activity quantity

•  material group
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Activity Data
Work
For internally processed activities you determine how much work is needed to conduct the
activity, which capacities are required and which qualifications the personnel should have.

See also :
Work [Page 138]

External processing
Activities and activity elements can also be performed outside of your company. The system
takes the data in the activity and creates a purchase requisition which is processed by the
purchasing department.

See also :
External processing [Page 156]

Material
You can allocate materials to all activities in standard networks and networks.

Production Resources/Tools (PRT)
You can assign production resources/tools (PRT) to each activty Unlike machines and fixed
assets, production resources/tools (PRTs) are movable (non-stationary) operating resources, that
are required to perform an activity and can be used repeatedly.

Documents
There are several ways to assign a document to an activity.

•  In the Document Management System you can create a document for an activity.

•  You can assign the document to an activity as a production resource/tool (category:
document).

•  Long texts describing an activity. On the screen, you usually see only the first line of the long
text.

•  Standard texts are text modules used for descriptions of procedures and other
documentation of how to perform the work in an internally processed activity.

•  PS texts are texts which you can define any way you like and which have text types for
activities and WBS elements.

Classification
You can use the SAP Class System to classify activities. Within the Class System you can
determine the values that are used to valuate an activity. Classification is also used for cost
summarization.
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When you create a network by copying from a standard network with classification
attributes, the classification attributes are not copied. They are only used for
classifying the standard network.

Organizational Data in Activities
The following is valid for activity organizational data :

•  Material components must belong to the same company code as the activity to which they
are allocated.

•  The plant for the work centers used in internally processed activities must belong to the
same company code and controlling area as the plant in the network header.

•  Purchasing organization and plant must belong to the same company code in externally
processed activities.

•  You can enter the plant on the detail screen for a general costs activity. The system
determines the company code from the plant you entered and checks it against the
controlling area in the network header.
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Maintaining Activities: Overview
Project Builder [Page 221]

There are several ways of maintaining activities and their data in the Project System.

Activities in (Standard) Networks

In standard networks and networks you can maintain the data for the activities:

•  On the activity overview

You can maintain the data of internally processed activities on two overviews:

•  The basic data overview shows the general data for the activity such as its duration, control
key and description.

•  The work overview shows the work-related data for the activity such as the work center, CO
activity type, number of required capacities and work percentage.

•  On the activity detail screens
You can maintain various data for activities on the detail screens: You can enter data for
external processing on the detail screen of an internally processed activity. This is useful
if at some point you can no longer perform the activity in-house and have to have it
performed externally.

You can maintain all other activity data under the menus Activity, Details and Extras.

Activities in the Graphic

You can maintain activities in the network graphic, Gantt chart and in the project planning board
[Page 252].

Maintaining Activities and WBS Elements Together

You can edit WBS elements and activities at the same time, for example when you already know
as you are setting up your project which WBS elements will be broken down in more detail with
activities.

To do so, use structure planning [Page 321], if you want to work in list format, or the project
planning board [Page 252], if you want to work graphically.
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Deleting Activities
Use
Under certain prerequisites you can delete activities and activity elements directly, that is, delete
physically.

You cannot undo the physical deletion of activities and activity elements.

You can give activities, and activity elements that cannot be deleted directly the Deletion flag
status. They are deleted from the project logically.

Prerequisites
You can only directly delete activities and activity elements when they have the status Created or
Released.

When deleting activities and activity elements, any residence time that may have
been set up is taken into account. If a residence time has been entered in the
network type, no deletion is carried out as from the Released status and a
corresponding message is issued.

If material components are assigned to an operation with the status Released, the
activity cannot be deleted. First delete the material components.

See also:
System statuses in networks [Page 353]

Features
Set the Deletion flag status for activities, and activity elements if they have any other status than
Created or Released. As long as the activities and activity elements have the status Deletion flag
and deletion indicators have not been set, you can cancel the deletion flag.

Activities
The following table contains the functions with which you can delete or mark for deletion the
activities or activity:

Function Menu Path

Delete activity or activity element directly Edit → Object → Delete

Give activity or activity element the status Deletion flag Edit → Status → Deletion flag

Canceling Deletion Flags Edit → Status → Revoke deletion flag

To be able to revoke the deletion flag, you must first show the activities or activity
elements that have been flagged for deletion. To do this, choose Edit → Object →
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Display deleted → Disp. The activities or activity elements that have been flagged for
deletion are underlined in grey. You can now cancel the deletion flag for the required
activities or activity elements.
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Maintaining Activities on the Activity Overview
You can create additional activities and activity elements in a network or standard network that
already exists.

Procedures
Creating Activities

1. In the initial screen for networks or standard networks choose Activities.

 The activity overview appears.

2. Enter the data for the activities.

3. Select an activity.

4. Choose Detail →→→→ Activity/Element → General.

 The detail screen for the activity appears.

5. Enter the necessary data.

6. Choose Continue.

7. Save the network.

Creating Activity Elements
1. Call up the activity overview.

2. Select an existing activity and choose Activity → Element overview.

 The overview for activity elements appears.

3. Enter the data for the activity elements.

4. Select an activity element.

5. Choose Detail →→→→ Activity/Element → General.

 The detail screen for the activity element appears.

6. Enter the necessary data.

7. Choose Continue.

8. Save the network.

Inserting Activities or Activity Elements

You can create additional activities or activity elements for an existing standard network and
network.

1. Call up the overview for either activities or activity elements.

2. Position the cursor on an activity or an activity element.

3. Choose Edit →→→→ Object →→→→ Insert.

 The system creates a new line above where the cursor is.

4. Enter the necessary data.
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5. Save your data.

Deleting Activities

After you delete an activity and save the (standard) network, the system automatically deletes all
activity elements, milestones, production resources/tools, and material allocations for the activity.

Always proceed as follows when deleting:

•  First delete the relationships for this activity

•  Then delete the activity itself

... In a Standard Network

To delete activities from a standard network, proceed as follows:

1. Call up the activity overview.

2. Select the activity or the activities you want to delete.

3. Choose Edit → Object → Delete.

The activity is deleted.

... in a Network

Before you delete activities from a network, you should pay attention to the following:

•  If the network does not yet have the system status "Released", the activity is deleted from the
data base immediately.

•  If the network already has the system status Released, the system sets the system status to
Deletion flag.

To show or hide the activities with the status Deletion flag in the respective activity list, choose
Edit →→→→ Object →→→→ Display deleted →→→→ On/Off.

To delete activities from a network, proceed as follows:

1. Call up the activity overview.

2. Select the activity or the activities you want to delete.

3. Choose Edit → Object → Delete.

4. Save your data.
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Maintaining Activities in the Network Graphic
When you create activities in graphic mode, you can insert them in the precise location you want
in the network structure.. The system uses the type of relationship that you defined in the
Settings menu for the new activity.

Procedures
Creating Activities

1. In the standard network or network, choose Goto →→→→ Graphic →→→→ Network structure.

The network graphic appears.

2. Choose Insert activity.

The node area is opened under the display area.

3. Click on an activity in the node area that you want to create.

The cursor in the display area changes shape.

4. Move the activity to the desired position in the network.

The activity is inserted.

5. Double click the activity.

The detail screen for the activity is displayed.

6. Maintain the data for the activity on the detail screen. Choose Continue to return to the
network graphic.

7. Create additional activities.

8. To return to the standard network or network, choose Back.

9. Save your data.

Deleting Activities
1. Call up the activity overview.

2. Choose Goto →→→→ Graphic →→→→ Network structure.

3. Click an activity in the node area that you want to delete. The activity is selected.

4. Choose Delete.

A dialog box appears.

5. Choose Continue. The activity is deleted.

6. Choose Back to return to the standard network or network.

Displaying Activities in the Network Graphic
Activities are displayed in the network graphic as follows:

•  Activities from external networks have a dashed black border

•  Activities in the network you are currently editing have a solid black border

•  Activities which are partially confirmed have a diagonal line through them
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•  Activities which have final confirmations are crossed out

•  Activities which have milestones, materials, subnetworks, documents and activity
elements assigned to them, are identified by a color border. In the standard
configuration, all indicators are the same color. You can change the colors in
customizing.

•  Activities in a subnetwork or a standard network alternative are displayed in a frame.

•  Subnetworks or standard network alternatives are displayed in a frame.

•  You can collapse the activities inside a frame or the frame itself.

The following graphic shows how the various activity statuses are displayed in the network
graphic.
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Maintaining Activities in the Gantt Chart
To create new activities in the project planning board, proceed as follows:

1. Select the WBS element for which you want to create the activity.

2. Select the menu options Edit → Activity → Create.

A dialog box appears.

3. Edit the data for the activity.

– Choose New activity, to create additional activities.

– Choose Continue if you do not want to create a new activity.

The activity is inserted.

4. Double click on the activity in the project planning board to call up the detail screen for work
data.
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Maintaining Activities in the Object Overview
If you use the object overview to maintain activities you do not have to maintain each activity
overview individually.

1. Select the menu options Goto → Object overview.

– If you have specified an overview variant in the profile, the system uses this object
overview.

– If you did not specify an overview variant, the system displays a dialog box where
you can select one.

2. Select the activities on the object overview that you want to maintain.

3. To go to the corresponding detail screen, choose Details → Activity /Element

4. Enter the required data in the detail screen or change the existing default values, if
necessary.

5. Goto the next detail screen by clicking on Prev. act. or Next activity and maintain the data.

6. Save your data.
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Setting the System Status for Activities
Systemstatus in Netzplänen [Page 353]

You can set a system status for a single activity. For example, the settings you make in Project
System Customizing for the material availability check, determine whether the system checks
material or PRT availability when you release activities.

If you release activities individually, the system sets the status "Partially released" in the network
header.

You can only release an activity which is assigned to a WBS element if the WBS
element has the status "Partially released" or "Released".

1. Select the relevant overview for the activity from the Goto menu or click on the corresponding
function key.

2. Select the activity or the activities you want to release.

3. Choose Edit → Status → Release actvty/elem.

The activity is released. In the network header, the system status is set to "Partially
released".
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WBS Elements in Activities and Activity Elements
If you create a (standard) network and assign it to a WBS element in the header, the system
copies that WBS element into all activities and activity elements as a default value.

•  You can assign the activities to different WBS elements by selecting the menu options Goto
→ WBS assign.-activity.

•  You can assign activity elements to different WBS elements by selecting the menu options
Activity → WBS assign.-element.
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Relationships
Definition
Relationships determine the chronological sequence of activities in a network or a standard
network.

There is usually a reason for a specific sequence of activities in a network. For example, there
may be technical dependencies between individual activities. These dependencies are
represented by relationships in which one activity is the predecessor or the successor of another
activity.
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Types of Relationships
The type of the relationship determines how the individual activities are linked with each other.

Finish - Start (FS) Relationship
This is the relationship between the end of an activity to the beginning of the following activity.  In
the graphic, the “assembly” activity  cannot start before the  “production” activity has finished.

Production Assembly

Start - Start (SS) Relationship
This is the relationship between the beginning of an activity to the beginning of the following
activity. In the figure, the “component procurement” activity  cannot start before the “design”
activity  has started.

charvov

GERMANY

Design

Component 
procurement

Order

Finish - Finish (FF) Relationship
This is the relationship between the end of an activity to the end of the following activity. In the
figure, the “work scheduling” activity  cannot finish before the “design” activity has finished.

Design

charvov

GERMANY

Work
scheduling

BOMBOM

Start - Finish (SF) Relationship
Relationship from the beginning of an activity to the end of the following activity. In the figure, the
“start-up” activity “start-up” cannot finish before the “inspection” activity  has started.

Inspection

Start-up

TÜV
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SF relationships are seldom used in practice. You can usually change SF
relationships to FS relationships by changing the sequence of the activities.
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Time Interval
The time interval determines the chronological interval between two activities that are linked by a
relationship.

The activity "assembly" is linked to an activity "production" through an FS
relationship with a time interval of two days. Assembly starts at the earliest two days
after the activity "production" has finished.

You can define the time interval in the Project System in several ways:

•  With positive or negative values

•  With absolute values or as a percentage

Minus 10 days

80 %

10 %

= 160 days

= 5 days

200 200 daysdays
EngineeringEngineering

Time Interval

AssemblyAssemblyProductionProduction

AssemblyAssembly
50 50 daysdays

ProductionProduction
200 200 daysdays

25 25 daysdays
Work prep.Work prep.

Positive or Negative Time Interval
You can maintain the time interval with positive or negative values.

 
The time interval between an activity "assembly" and an activity "production" is
minus 10 days. The activities are linked to each other by an FS relationship. The
activity "assembly" starts 10 days before the activity "production" is finished.

Absolute or Percentage Time Interval
You can determine the time interval with absolute or percentage values:

•  Absolute values: In the standard version, the system expects absolute time intervals: for
example, two days or five hours.
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•  Percentages: The percentages for the time interval refer to the duration of the
predecessor or the successor.

Example: Percentage Time Interval [Page 179]

 
If you enter a percent for the time interval, you must specify whether it is a
percentage of the preceding activity or succeeding activity’s duration.
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Example: Percentage Time Interval
Percentage of the Predecessor’s Duration
Suppose the activity "engineering/design" takes 200 days and is the predecessor of the activity
"work scheduling". The time interval is defined as 80% of the duration of the predecessor. When
80% of the duration of the activity "engineering/design" has been reached, the activity "work
scheduling" starts. Thus, the time interval between the two activities is 160 days.

Percentage of the Successor’s Duration
Suppose the activity "assembly" takes 50 days and is the successor of the activity "production".
The time interval is defined as 10% of the duration of the successor. Thus, the time interval
between the two activities is five days.
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Relationships Across Networks
Cross-network relationships enable you to spread the tasks to be performed over several
individual and smaller networks thereby creating an overall network.

You link several (standard) networks with each other when you create a relationship from an
activity in one (standard) network to an activity in another (standard) network.

You use cross-network relationships to link:

•  standard networks with standard networks

When you edit a standard network with cross-network relationships, you lock up all other
standard networks.

When you create operative networks from standard networks with cross-network
relationships, the system will ask you if you want to create the same relationships
between the operative networks.

•  networks with networks

When you edit a network with cross-network relationships, you lock up all the
relationships to all of the linked networks.

Even if you defined a level of detail of "one" in the standard network profile, you can
still create relationships between several standard networks.

See also:
Creating Networks by Copying Standard Networks [Page 94]
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Relationships Maintenance
Use
You can create relationships for

•  Internally processed activities

•  Externally processed activities

•  General costs activities

You cannot create relationships for activity elements.

Activities
You can edit relationships in several ways:

•  In table form

on the relationship overview [Page 182] in networks, in structure planning, and in the
project planning board.

•  In graphic form

− in the network graphic [Page 184]

− in the project planning board [Page 286]

− in the Gantt chart in network maintenance

To process relationships in the Gantt, proceed as described in the project planning
board [Page 286].
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Editing Relationships in the Overview
Use
You can create, edit and delete relationships in a tabular overview.

Prerequisites
You have created activities in a network or standard network.

Procedures
Create relationships
1. Call up the activity overview in a network or standard network.

2. Select the activities for which you wish to create relationships.

3. Choose Activity → Relationship overv.

The relationship overview for the first selected activity appears. All the activities of the
current network are displayed in the Activity selection section (lower list) of the dialog box
If activities in the current network are linked by relationships to other networks, these
activities are also displayed.

You can thus link the current activity with an activity from another network via activity
selection.

You can edit relationships between activities in several ways:

Edit Relationship Procedure

As predecessor 1. In the relationship overview choose the
Predecessor tab page.

2. In the activity selection list select the activity that
should immediately proceed the selected activity.

3. Choose Create relationship.

As successor 1. In the relationship overview choose the Successor
tab page.

2. In the activity selection list select the activity that
should immediately follow the selected activity.

3. Choose Create relationship.
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Mixed (predecessors and successors) 1. In the relationship overview choose the Mixed tab
page.

2. In the activity overview select an activity as a
predecessor or successor.

3. Choose Create relationship.

4. Set the Scs indicator for successors in the
relationship overview.

If you do not set this indicator, the
relationship is a predecessor relationship

4 Select the relationship and choose Details →→→→ Detailed information for object.

The detail screen for the relationship appears.

5 Enter the detailed data for the relationship and choose Back.

The relationship overview appears again.

6. Choose the Next arrow for the next selected activity and repeat steps 2 to 4.

7. When you have created all the required relationships, save.

Delete Relationships

When you delete relationships, you change the structure of the network. This can
affect scheduling and the capacity load.

1. Call up the activity overview.

2. Select the activity whose relationships you want to delete.

3. Choose Activities → Relationship overv.

The relationship overview for the selected activity appears.

4. In the relationship overview select the relationship to delete.

5. Choose Edit →→→→ Object →→→→ Delete and confirm the message.

6. Save your data.
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Editing Relationships with Network Graphics
Procedures
Creating Relationships with Network Graphics

1. To access the network graphic in a standard network or network, choose Goto →→→→ Graphic →→→→
Network structure.

The network graphic appears.

2. Choose Connect.

The mouse pointer takes the form of a pencil.

3. Select the activity from which you want to create a relationship and hold down the mouse
button.

A dashed line is shown on the screen.

4. Draw a line to the other activity in the relationship and release the mouse button.

The system connects the two activities with a line and records the relationship type.

The graphic below illusrates how you draw the line to create the different types of
relationships.

5. To change the pencil back to the normal cursor, click on the left mouse button.

6. To enter detailed data for the relationship, select the relationship and choose Detail →→→→
Relationship.

7. To create more relationships, repeat steps 3 - 7.

8. To return to the standard network or network, choose Back.

9. Save your data.
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Using the Graphic to Maintain Relationships

EngineeringEngineering

WorkWork
preparationpreparation
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FFFF

ProductionProduction
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EngineeringEngineering

EngineeringEngineering

WorkWork
preparationpreparation

Fin.prod.Fin.prod.
procurementprocurement

EngineeringEngineering

ProductionProduction AssemblyAssembly

Deleting Relationships in the Network Graphic

When you delete relationships, you change the structure of the network. This can
affect scheduling and the capacity load.

1. In the standard network or network, choose Goto →→→→ Graphic →→→→ Network structure.

The network graphic appears.

2. Select the relationship you want to delete.

3. Choose Edit →→→→ Object →→→→ Delete and confirm the message displayed.

The relationship is deleted.

4. To return to the standard network or network, choose Back.

5. Save your data.
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Executing Loop Analysis
Use
A loop exists, if relationships lead from an activity via other activities back to the same activity.

Networks and standard networks containing loops cannot be scheduled.

The system automatically checks standard networks and networks for loops when
you schedule them.

Prerequisites
You execute loop analysis for a network structure in the network graphic.

Procedure
1. Call up a network or standard network in create or change mode.

2. Select the menu options Goto →→→→ Graphic →→→→ Network structure.

 The network graphic appears.

3. Select the menu options Edit →→→→ Functions →→→→  Loop analysis →→→→ Proceed.

 Relationships that cause a loop are highlighted in color.

4. Select the relationship that causes the loop.

5. Choose Delete.

 The relationship is deleted.

6. To deselect a loop, select the menu options Edit →→→→ Functions  →→→→  Loop analysis →→→→ Reset.

7. To return to the network or standard network, choose Enter.
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Subnetworks
Definition
A subnetwork is a network which covers only part of a project and is linked in relationships with
other subnetworks in the same project.

Use
You can use subnetworks to refine and detail your networks as planning progresses. The system
treats subnetworks and networks the same, that is, you can plan dates, capacities, costs,
materials and production resource/tools also with a subnetwork.

Settlement rule
Profit center
Business area
and so on

Subnetwork

EngineeringEngineering ProductionProduction AssemblyAssembly

Structure
When creating a subnetwork, you can copy the following data from the superior network and from
the activity to which the subnetwork adds detail:

Taken Over from the
Superior Network

Data What You Should Know

From the network header WBS element

Sales order The sales order can be
assigned to the network or the
relevant WBS.

Configuration characteristics Prerequisite: The network was
created using configuration



Structures  SAP AG

Subnetworks

188 April 2001

From the activity •  Earliest/latest dates
0 or

•  Earliest start and
latest finish date

Depends on the settings in
Customizing for the Project
System

Profit center

Business area

Jurisdiction Code

Long texts in activities The long texts are copied into
the header for the subnetwork.

Relationships

The network profile for the superior network is not copied into the subnetwork.
Materials and PRTs remain assigned to the activity in the superior network.

Control Keys
Among other things, the control key regulates whether dates, capacity requirements, and plan
costs are determined and recorded. In Customizing for the Project System, you set the relevant
indicators in the control key

For example, if you want to add detail to the dates, capacity requirements, and planned costs for
the superior activity by means of the activities in the subnetwork, set the indicators in the control
key as follows:

Indicator in Control Key For Activities in
Subnetwork

For The Activity in the Superior
Network

Scheduling Set Not set

Costing Set Not set

Determining capacity
requirements

Set Not set

When you create a subnetwork, the activity in the superior network receives a control key which
you have defined in Define Parameters for Subnetworks in the Project System IMG. If the activity
already had a control key, the new one overwrites it. The activities in the subnetwork receive their
control keys from the network profile.

In the Project Information System you can analyze the dates of the subnetwork
together with the dates of the superior network.
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Integration
Notes on Using Plant Maintenance Orders as Subnetworks
You can also use plant maintenance orders to add detail to an activity. You make the assignment
to the superior network and its activity in the plant maintenance order itself. Note the following:

•  The dates for the activity are copied into the order.

•  Relationships from the order are not copied.

•  Plant maintenance orders are not taken into account during WBS scheduling.

•  You can only display plant maintenance orders as subnetworks in the structure/date
Project Information System.

See also:
Plant Maintenance Orders [Ext.]



Structures  SAP AG

Creating Subnetworks

190 April 2001

Creating Subnetworks
Prerequisite
The network to whose activity you want to add detail using subnetworks should already exist.
You must have defined the subnetwork parameters in Customizing for the Project System.

Procedure
1. From the Sap Easy Access, choose Logistics/accounting → Project System → Basic data

→   Project → Special maintenance functions → Network → Create.

2. Enter the required subnetwork data in the initial screen for the network.

3. Choose Enter.

The network header for the subnetwork appears.

4. Choose the Assignments  tab page.

5. In the Subnetwork field, specify the numbers of the superior network and the appropriate
activity from it.

This is the activity to which you want to add detail using the subnetwork you are now
creating.

The activity in the superior network must not have status Closed or Technically
complete.

6. Enter the other data in the network header.

7. Complete the data for the subnetwork - for example, activities, components, and so on.

8. Save your data.

If detail has been added to an activity by means of a subnetwork, the Subnetwork exists indicator
in the detail screen for the activity is active.

To switch between the superior network and the subnetwork, choose Goto →→→→ Subnetwork →→→→
Subnetwork overview or Superior network in the network header of the relevant network.
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Subnetwork Creation with Configuration
Use
As with networks, configuration is carried out, when you create a subnetwork using a
configurable standard network as a template.

Activities
If the network that is superior to the subnetwork was created using configuration, the following is
valid for characteristic value assignment:

•  If the variant class of the superior network is the same as the variant class of the standard
network that is being used as the template for the subnetwork, the characteristic value
assignment of the superior network is used.

•  If different variant classes are used, the characteristic value assignment has to be repeated
for the subnetwork.

•  If a configuration profile has not been maintained for the subnetwork, the characteristic value
assignment of the superior network is used.

See also:
Configuration [Page 104]

Characteristic Value Assignment [Page 106]
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Milestones
Purpose
In general milestones are used to mark the transition between various phases or departments.
You can also use Milestones for other tasks and functions in the Project System.

You can create milestones for activities and WBS elements. They can be used for the following
tasks:

•  Milestone Trend Analysis (MTA) [Ext.]

Milestone trend analysis is a simple and effective method of controlling dates in a project.
The milestone dates on different report dates are compared. In the graphical MTA chart
you recognize trends and delays immediately.

•  Conducting earned value analysis using the milestone technique [Ext.]

The milestone technique is one of the measurement techniques for determining the
earned value in earned value analysis. Each milestone represents the portion of the work
that is completed in an activity or in a WBS element.

•  Determining Dates in the Billing Plan [Page 201]

A milestone is linked with a date in the billing plan. When the milestone is reached, the
actual date of the milestone is copied into the billing plan.

•  Triggering predefined Milestone Functions [Page 195]

You trigger a series of events to process a particular business process with milestone
functions.
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Creating Milestones
Anlegen von Projektelementen [Page 264]

Procedure
You can create milestones in networks, standard networks, work breakdown structures (WBS)
and standard work breakdown structures (standard WBS). You can also create milestones for
activities and WBS elements together in the project planning board and structure planning.

You cannot create milestone for activity elements.

Creating Milestones in Networks, Standard Networks, WBS or Standard WBS
1. Call up a network or WBS.

2. Goto the activity or WBS element overview.

3. Select an activity or a WBS element, and then choose Activity → Milestone overview or
WBS element → Milestone overview.

 You can use the function keys Std. milestone and Mile. group in the milestone overview
to insert a standard milestone [Page 218]  or a milestone group [Page 218].

4. Maintain the milestone data.

 The system will automatically assign a number to the milestone.

If you enter a key in the field Usage that was also maintained for the standard
milestone, you can copy the standard milestone data directly.

5. Select the milestone and choose Details →→→→ Milestone.

6. Maintain the data on the details screen.

 For instance, you can set the Sales document date [Page 201] indicator or Trend
analysis indicator [Ext.] here.

 You can also maintain data for milestone functions [Page 197]  for activity milestones
here.

7. Choose Back.

8. Save your data.

Creating milestones in the project planning board
1. Call up the project planning board for an existing project.

2. Select an activity or a WBS element, and then choose Edit → Create→ Milestone.

3. Maintain the milestone data.

 If you want to create more milestones for the activity or WBS element,
choose...Milestone
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4. Choose Continue.

5. Save the project planning board.

Creating milestones in structure planning
1. Call up the structure planning for an existing project.

2. Select an activity or WBS element.

•  For activities choose the Activity data tab page.

The network activity overview appears. Create milestones as in network
maintenance.

•  For WBS elements choose the WBS basic data tab page.

The work breakdown structure WBS overview appears. Create milestones as in
WBS maintenance.

3. Save the structure plan.
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Milestone Functions
Use

Predefined milestone functions are used in networks, to trigger a sequence of events for a
particular business process.

You are planning the construction of a glass elevator using a network. After the
activity approval is released, the network will be automatically updated to include a
standard network procurement containing all activities related to purchasing.

Features
The following milestone functions are available:

•  Release the activities that follow directly

•  Release to release milestone

If no release stop indicator has been defined, all the remaining activities in the network
are released.

•  Include standard network

If you enter both a preceding and successive ending  for the network, the system will
automatically create FS relationships from the preceding activity to the first activity in the
standard network and/or from the final activity in the standard network to the successive
activity.

•  Create Network

You can create a new network by copying an existing standard network.

If the standard network, which is being used to copy the network from, has relationships
to another standard network that has already been used to create another network, the
relationships between the two networks have the same structure as those between the
two standard networks..

•  Include subnetwork

Creates a subnetwork [Page 187]  from an existing standard network. The activity in the
network you enter in Parameters is given extra detail by the subnetwork.

•  Start workflow task

You can use this milestone function to activate one of your own workflow tasks or one of
SAP’s standard workflow task.

See also:
SAP Business Workflow [Ext.]

User-defined Standard Tasks and Workflow Tasks in Milestones [Ext.]
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Triggering Milestone Functions
A milestone function can be automatically triggered by a change of the system or user status of
an activity.

If you enter both a system status and a user status for a milestone function, the system triggers
the function both when the system status changes and when the user status changes. If the
function is only  to be triggered once, then the first status to change will be the one which triggers
the function.

You can trigger a milestone manually during confirmation [Ext.]  of an activity. In this case you
decide when making the confirmation, whether the function is triggered or not.

See also:
Example: Triggering a Milestone Function [Page 198]
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Entering Data for Milestone Functions
Prerequisite
You have created a milestone for an activity.

See:
Creating Milestones [Page 193]

Procedure
1. Select the milestone and choose Details → Milestone

2. Choose the Functions tab page.

3. Set the Functions indicator.

4. Select one or more milestone functions and determine the parameters for triggering them.

 You can enter additional parameters for triggering milestone functions by choosing
Parameters In the following table those functions are listed for which you have to
maintainadditional parameters.

 

 Milestone Functions  Necessary Parameter

 Include standard network  Standard network and alternative, predecessor and
successor activities

 Create Network  standard network, alternative and network type

 Include subnetwork  Standard network, alternative and activity

 Start workflow task  (standard) workflow task

 

5. Choose Back.

6. Save your data.

See also :
Example: Triggering a Milestone Function [Page 198]
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Example: Triggering a Milestones - Function
The activities which immediately follow activity 0040 in network 40000906 should be released
when the activity is confirmed.

Procedure in Milestone Maintenance
Create a milestone for activity 40. You maintain the following fields on the Functions tab page  of
the Milestone detail screen

1. Set the Functions indicator.

2. Select the function Release following activities.
3. Enter the system status CNF for confirmed in the Syst.Sts field.

4. Set the Change Status indicator to +.
The function is then triggered, when the status is set.

5. Set the Once indicator.
The function is then only executed once.

You leave the field Activa (Activate) blank, since the function is to be triggered by the
status change.

Procedure during Confirmation
If you set the Final Confirmation indication when you are confirming activity 40, you receive a
message, when you save, stating that functions are assigned to the operation via  milestones.
The system asks you if you want to execute the function. Confirm this.

A dialog box appears in which the milestone function, the network and the corresponding activity
are listed. The function is executed after you have confirmed this question..
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Dates in Milestones
Features
You can maintain basic dates and forecast dates for milestones. The following is an overview of
dates that you can define for milestones

Actual dates

Actual dates can be either:

•  Manually entered, once a milestone is met, or

•  Automatically copied from the confirmation, if the degree of processing is greater or equal to
the percentage of completion in the milestone.

The confirmed actual date is the default value, however, you can overwrite it.

Fixed Dates

A fixed date is a manually entered finish date on which the milestone should be reached.

To be able to use the milestone technique [Ext.]  for WBS elements in earned value
analysis, you must use fixed dates for the milestone.

Dates

As an alternative to fixed dates, you can also specify the following for a milestone:

•  Whether the offset should be for the earliest or latest set of dates for the activity (only for
activities)

•  Whether the offset should be to the start or finish of the activity or WBS element

•  How long the offset to the scheduled start or finish of the activity or WBS element is You
enter the offset as either a time or a percentage. When the offset is a percentual value, it is a
percentage of the  duration.

The activity has a duration of 50 days and an offset of 20% to the start. The
milestone date is 10 days after the activity start.

Scheduled Dates

Scheduling calculates the scheduled dates in the following manner:

•  If the milestone has a fixed date, this date is automatically copied as a scheduled date.

•  If an offset date was entered for the milestone, the system uses this information in
determining the scheduled date.
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Dates in the Billing Plan
Use
In customer projects, for instance made-to-order production, the customer is usually charged for
services, as soon as certain phases of the project have been finished.

You add dates to billing plans by using milestones in activities or WBS elements. When the
milestone event is reached, the system copies the actual dates of the milestone to the billing plan
and starts the billing process.

There are two principally different ways of copying dates from milestones to the billing plan:

•  Billing with assembly processing

The dates from all milestones, which have the Sales document date indicator set, are
copied from the network, which is automatically created during assembly processing, to
the billing plan for the assembly item in the sales document.

•  Billing without assembly processing

You can manually define milestones and consequently dates to be copied to the billing
plan. In this case the milestones must also have been chosen for the billing plan
previously, the sales order must have the item category TAO.

See also :
Milestone billing [Ext.]

Billing plans [Ext.]

Prerequisites
You have linked the milestone in the activity or WBS element with a date in the billing plan by
using the Sales document date indicator and entering 01 in the Date key of the milestone.
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Standard structures
Purpose
Be defining standard projects and networks you can standardize project management in your
company by referring back to data that has been derived from existing projects.

Standardization is one method of ensuring in the initial phase that projects are structured
efficiently and economically.

A further advantage of standardizing project structures is that it makes the processing of projects
more transparent, enables the comparison of projects and subsequently facilitates project
controlling.

In the Project System there are several different standard structures that you can use as
templates to create operative structures.

•  Standard networks [Page 203] for creating networks

•  Standard project definitions [Page 213] for creating project definitions

•  Standard work breakdown structures [Page 214]  for creating work breakdown structures

•  Standard milestones [Page 218] for creating milestones in networks
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Standard Networks
Montageabwicklung im Projektsystem [Ext.]

Schnittstellen des Projektsystems [Ext.]

Standard networks are neutral network structures that can be used as templates to create other
standard networks or operative networks.

Time Saver
Creating networks from standard networks can save you time and help ensure consistency of
your business processes when different projects have the same activities, for example, in the
engineering phase.

Template Projects
You can link standard networks to standard work breakdown structures to create a template
project which contains both the project structure and the activities assigned to the project. When
you copy a standard network that is linked to a standard WBS, you create an operative WBS at
the same time that you create an operative network. For information on standard work
breakdown structures, refer to Standard Work Breakdown Structure (Standard WBS) [Page 214].

Assembly Processing
A standard network is necessary when you want use assembly processing to create an operative
network from a sales order. The network that is created in the background from a sales order is
always copied from the standard network to which you have allocated the material in the sales
order. For more information on assembly processing, refer to LO- Assembly Processing

Milestone Functions
In addition, when you create operative networks through milestone functions, the system copies
the standard network you specified in the milestone parameters. For more information on
milestones, refer to Milestones [Page 192].

Decentralized Planning
You can also exchange standard networks with PC software such as Microsoft® Project using
the MPX interface. For more information see MPX Interface (Microsoft Project).

More on Standard Networks
Creating Standard Networks

Standard Network Alternatives

Creating Standard Network Alternatives

Material Allocation to Standard Networks

Relationships Across Networks

Standard Settings for Standard Structures
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Creating Standard Networks
1. Materialkomponenten zum Standardnetz zuordnen [Ext.]

2. Vorgängen Vorlagentexte zuordnen [Page 216]

3. From the main menu select the menu options Accounting or Logistics →→→→ Project
management → Basic Data.

4. Select Standard structures → Standard network → Create
The initial screen is displayed.

5. Enter:

•  Alphanumeric key for the standard network (optional)

If you do not enter a key, the system generates a number for the standard network.

•  Standard network profile

•  Key date

The key date determines when the standard network becomes valid. The default
value is today’s date.

If you enter a key date that lies in the future, you must enter this date, or a later one,
every time you change the standard network. The changes only come into effect as
of the key date.

4. Choose Enter.

The system displays the standard network header, which contains data that is valid for
the entire standard network.

5. Enter relevant data, such as a standard WBS element, to create a link between the standard
WBS and the standard network.

6. Use the Goto menu to enter data for the standard network.

Activities [Page 132]

Maintaining Relationships Between Activities [Page 174]

Allocating Materials to Activities

For information on enhancements for customer-specific fields in standard networks, refer
to Project System Customizing.

7. Save.

You can use an existing standard network to create other standard or operative
networks. All data from this standard network is copied into the new (standard)
network, which you can overwrite. However, once you have saved your new
(standard) network any subsequent changes to the original will not be copied.



Structures  SAP AG

Standard Settings for Standard Structures

206 April 2001

Standard Settings for Standard Structures
In Customizing for the Project System you define profiles for standard structures. These profiles
contains defaults for functions, subprofiles, graphics, and settings, which are automatically
copied when you create a standard structure. You can overwrite these defaults.

Functions such as graphics or the Microsoft MPX interface require a certain level of
detail. The level of detail determines how many standard networks are displayed in
the graphic or are transferred to the PC using the MPX interface. You may want to
temporarily change the profile to display several standard networks in the graphic, for
example.

Changing Profile Data in Standard Structures

Standard Structure Menu path

Standard project definition Control tab page

Standard work breakdown structure Control tab page

Standard network Edit → Settings  → Profile.
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Standard Network Alternatives
A standard network can have several alternatives. You can create alternatives for different
usages or validity dates.

You can use an alternative to:

•  Define different network structures for planning your processes. You can create different
activities or other relationships in the alternative, for example.

•  Specify a certain type of usage or processing. For example, if changing directives will alter
the process of your standard network on a specific date, you can define an alternative.

Each time you create an alternative to a standard network the system automatically assigns it a
number. You can overwrite this with an alphanumeric key.
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Creating Standard Network Alternatives
1. Choose Standard structures → Standard network → Create

Specify an existing standard network and confirm your entry. The system then displays
the alternative overview is displayed.

2. Select Edit → Object → Create.

The standard network header is displayed. The system automatically assigns a new
number for the alternative. You can overwrite this.

3. Enter data for the standard network.

4. Save.
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Deleting Standard Network Alternatives
1. Call up a standard network by selecting Standard structures → Standard network →

Change.

2. From the standard network header, select Goto → Alternative overview.

The alternative overview is displayed.

3. Choose the alternative that you want to delete and select Edit → Object → Delete.

4. Save.
The standard network alternative is physically deleted from the database.
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Deleting Standard Networks

Deletion without archiving can lead to loss of data. You should only use this type of
deletion for standard networks you have created for test purposes.

To delete standard networks from the database:
1. In the R/3 main menu choose Project management → Basic data → Standard structures →

Standard network → Delete.

You reach the initial screen Deletion of standard networks without archiving.

2. Maintain selection criteria.

If you do not explicitly enter the selection criterion Deletion flag then the standard
networks are deleted regardless of whether they have a deletion flag.

3. Select the option:

•  Objects deleted online

If you want to archive the standard network activities or standard networks online in
the maintenance transaction.

•  Complete standard networks

If you only want to archive complete standard networks from the database

•  Check task list indicator

If you have maintained the customer enhancement CPRE0001 and want the check
the standard networks to be deleted according to your own criteria.

•  Log

If you want the archiving run to be completed before you see the information
messages. The information for all standard networks that have not been deleted
because of the customer enhancement check CPRE0001 are then collected in a log.

If this indicator is not set the archiving run terminates as soon as a standard network
is still being used according to your criteria.

4. Choose Create job.

The standard networks are deleted online.

See also:
For more information on deleting and archiving standard networks, refer to BC- Archiving of
Application Data
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Assigning Standard Networks to Standard Work
Breakdown Structures
When you create assignments between a standard network and a standard work breakdown
structure, you can create an operative WBS at the same time that you create an operative
network.

The system only creates the WBS elements to which activities from the standard network are
assigned, along with the WBS elements superior to them in the hierarchy.

You cannot assign a standard network directly to a standard project definition; you
must do this indirectly, using a standard WBS.

Assigning a Standard Network to a Standard WBS Element
You can link both the header and the activities of a standard network to a standard WBS
element. When you enter the standard WBS element in the header, this WBS element will be
proposed for the activities as well. You can overwrite it.

1. From the main menu select the menu options Accounting or Logistics →→→→ Project
management → Basic Data.

2. Select Standard structures → Standard network → Change.

3. Enter the identifier of the standard network, and an alternative if required, and confirm.

The standard network header is displayed. If you did not specify an alternative, the
system first displays the overview of alternatives.

4. Enter the standard WBS element in the Std. WBS element field on the header of the
standard network.

5. Save.

Assigning Activities in Standard Networks to Standard WBS Elements
You can link the activities in a standard network with one or more standard WBS elements from
one or more projects. Proceed as follows:

1. From the main menu select the menu options Accounting or Logistics →→→→ Project
management → Basic Data.

2. Select Standard structures → Standard network → Change.

3. Enter the identifier of the standard network and confirm.

The standard network header is displayed.

4. Choose Activity.

5. In the activity overview, enter the standard WBS element(s) for the activities.

6. Save.

When you create an operative network by referencing a standard network, the system also
creates work breakdown structures with the WBS elements to which network activities have been
assigned (along with the part of the structure superior to these elements).
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See also:
For detailed information on the various ways that linked standard networks and standard WBS
can be copied into operative structures, refer to  Creating Networks by Copying Standard
Networks [Page 94]
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Standard Project Definition
Standard project definitions are neutral definitions of projects that can be used as a template to
create standard or operative project definitions. A project definition forms the outline of the
project because it contains the basic organizational data which is valid for the entire project, such
as:

•  Controlling area

•  Business area

•  Company code

•  Plant

•  Factory calendar

Standard Settings for Standard Structures [Page 206]
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Standard Work Breakdown Structure (Standard WBS)
Definition
Neutral work breakdown structure that can be used more than once and serves as a template for
creating operative work breakdown structures.

Use
For future projects with the same structure, you can use standardized work breakdown structures
as a template to create operative work breakdown structures or other standard work breakdown
structures. This not only saves time when creating a project in the system, but also in the design
phase.

A standard work breakdown structure contains the individual elements (WBS elements) that
structure the standard project as well as general organizational data.

You can link standard networks with standard work breakdown structures and so create
templates not only for the organization of a project but also for its processing.

When you use a standard network that is assigned to a standard WBS to create an operative
network an operative WBS is also created. However if you create an operative WBS from a
standard WBS to which a standard network is assigned, an operative network is not created.
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Creating Standard Work Breakdown Structures

Before you create a standard work breakdown structure, you should plan the work
carefully since it is not possible to delete or archive standard project definitions. You
can only delete or archive individual standard WBS elements.

The procedure for creating a standard work breakdown structure is basically the same as for
creating a normal work breakdown structure, however some functions such as document
management, progress analysis or settlement rules are not available.  When you create a
standard WBS a standard project definition is automatically created. We recommend that you
read the information in Work Breakdown Structure (WBS) [Page 15] before you create a standard
WBS.

1. From the R/3 main menu choose Accounting or Logistics  →→→→ Project management →→→→ Basic
data.

2. Choose Standard structures → → → → Standard WBS → → → → Create.
The initial screen appears.

3. Enter the following:

•  The key for the standard project
or choose Open number  to have the system suggest a key.

•  The project profile

4. Choose  to enter the organizational data for the project definition.
The Create Std. WBS: Project Def. Basic Data screen appears.

5. Enter the relevant organizational data.

6. Choose . The WBS element overview screen appears. Here you can enter details of the
WBS elements.

7. You can go to the detail screen for individual WBS elements by double-clicking on the WBS
element key. Here you can also enter detail data.

8. Save your data.

See also:
Creating Standard Work Breakdown Structures by Copying [Page 216]

For information on user fields in standard project definitions and standard WBS elements, refer to
the IMG for the Project System.
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Creating Standard Work Breakdown Structures by
Copying
You can use an existing standard WBS to create other standard or operative WBSs. The data
from this standard WBS is copied into the new standard WBS, where you can overwrite it if you
wish. Any subsequent changes to the original will not be copied to the new standard WBS.

Read Work Breakdown Structure (WBS) [Page 15] for detailed information before creating a
standard WBS.

1. From the main R/3 menu, select Accounting or Logistics → Project management → Basic
data.

2. Select Standard Structures → Standard WBS → Create.
The initial screen is displayed.

3. Enter

•  The key for the standard project, or have the system propose the project identifier by
clicking Open number

•  The project definition of the WBS you want to copy.

You do not have to enter a project profile.

4. Confirm.

The system displays the Create Standard WBS: Project Definition Basic Data screen.
Note that the organizational data cannot be changed. You must first include the structure
before you can change this data.

5. Choose WBS Structure.

The system displays the Create Standard WBS: Include Standard WBS Element screen.
Note that the WBS elements of the standard WBS you copied are displayed.

6. Select all standard WBS elements that are relevant for your new standard project.

7. Choose Replace to rename the standard WBS elements you selected.

8. Choose Include to copy the structure.

The Create Standard WBS: Project Definition Basic Data screen is displayed. Note that
you can now change the organizational data.

9. Change the organization data if necessary.

10. Click Structure to return to the WBS element overview and maintain any additional data.

11. Save.
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Deleting Standard WBS Elements

Standard WBS elements deleted using this procedure cannot be retrieved.

You cannot delete or archive standard project definitions.

1. From the main R/3 menu, select Accounting or Logistics → Project management → Basic
data.

2. Select Standard Structures → Standard WBS → Change.

The initial screen is displayed.

3. Enter the identifier for the standard WBS and choose Structure.

4. Select the standard WBS element(s) that you want to delete.

5. Choose Edit → Object → Delete

The selected standard WBS elements are physically deleted from the database.

6. Save.
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Standard Milestones
Purpose
Standard milestones are used exclusively in the Project System as a source for creating
milestones and other standard milestones.

You can combine different standard milestones in a milestone group. For example, you can
group together all milestones that are relevant for earned value analysis.

See also:
Milestones [Page 192]

Integration
You copy standard milestones to create milestones in activities and WBS elements. You do this
in (standard) network maintenance, (standard) work breakdown structure maintenance as well as
in the project planning board and structure planning.
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Creating Standard Milestones
Procedure

1. From the R/3 main menu choose Accounting or Logistics  →→→→ Project management →→→→
Basic data.

2. Choose Standard structures → → → → Standard milestone → → → → Create.

 The initial screen for standard milestones appears.

3. Enter a name for the standard milestone.

 You can also enter the name of an existing standard milestone to copy from.

4. Choose Enter.

 The milestone detail screen appears.

5. Enter the data for the standard milestone.

6. Choose Functions, if you want to use milestone functions [Page 195] with the standard
milestone.

7. Select one or more milestone functions and determine the parameters for triggering
them.

 
 You can only maintain user statuses [Page 357]  for standard milestones, if you enter
a status profile.
The status profile or the user status that you have maintained is copied from the
standard milestone, if the network has the same status profile as the standard
milestone.

 You can enter additional parameters for triggering milestone functions by choosing
Parameters. In the following table you can see those functions where you have to
maintain additional parameters.

 

 Milestone Functions  Necessary Parameter

 Include standard network  Standard network and alternative, predecessor and
successor activities

 Create Network  standard network, alternative and network type

 Include subnetwork  Standard network, alternative and activity

 Start workflow task  (Standard) workflow task

 

8. Choose Back.
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Project Builder
Purpose
The Project Builder is a user-friendly method of accessing the Project System, which enables you
to edit your projects quickly and efficiently.

Its clear screen structure, split into three, and the ease with which you can use it, combine to
provide you with a comfortable working environment that facilitates your daily work in the Project
System.  It also provides you with an overview of all the projects that interest you.

Context sensitive menus, Drag & Drop, and the capability to define your own worklist and
templates pool, further accelerate your work with projects.

Integration
The Project Builder integrates all the application-specific functions necessary for processing your
projects:

•  It contains almost the entire functionality of structure planning, and is the basis for all
planning steps in a project. It thus facilitates consistent project coordination and execution.

You schedule projects in the project planning board, which you can call up directly
from the Project Builder.

•  All the editing transactions for work breakdown structures and networks can be executed in
the Project Builder. In the Project Builder, you can process WBS structures and networks
individually or integrated in other structures

Features
In the Project Builder

•  You can create, change or display all project structure data in one transaction.

•  All the overview and detail screens from structure planning are available.  You can also go to:

•  Graphic views (hierarchy and network graphic)

•  The project planning board [Page 252] with all its overviews (capacity, costs,
component, and maintenance order overviews)

•  You can define a user-specific worklist and a user-specific templates pool, which you can
then use to process your projects.

•  The hierarchy of your current project is displayed in a separate screen area, while you are
editing it.

•  You can make user-specific changes to the settings, to suit your way of working.

See also:
Structure of the Project Builder [Page 223]

Executing Functions in the Project Builder [Page 227]
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Changing Settings [Page 225]
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Structure of the Project Builder
The following screen areas are available for working in the Project Builder:

Structure tree 

Worklist and templates

Work area

Structure tree
The structure tree displays the project object (project definition, WBS element, activity, activity
element, milestone, document) that you have selected in its hierarchical context.  You can
change the dependencies and assignments of individual project objects in the structure tree
manually (using Drag & Drop).  You can also create or delete project objects. In the user-specific
options you can specify how many hierarchy levels are displayed expanded in the structure tree.
Additionally you can choose whether you want to see a preview of the last project you have
processed, when enter the Project Builder. (see User-Specific Settings [Page 225])

 
In the structure tree itself, you can only carry out tasks that change the structure of
the project, that is create, move and delete objects. Business transactions are not
possible.

For more information, see Functions in the Structure Tree [Page 230].

Worklist/Templates
In this screen area you have access to both the worklist and the templates

You can store user-specifically frequently used project data (project definitions, networks, and
WBS elements) in the worklist, so that you can access them quickly later.  Furthermore, a list of
the last five projects that you have worked on is always displayed in the worklist.
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The templates are available during processing to create new objects or structures in the current
project by.

•  Adding new project objects

•  Copying existing project structures

•  Copying from standard project structures

You can also change the templates screen area user-specifically (see User-Specific Settings
[Page 225]). When you start the Project Builder, the worklist is displayed However, when you
open a project, the system automatically switches to the Templates screen area. When you are
working on a project, you can switch between the worklist and the templates by choosing the
relevant pushbutton. When you are working on a project, you can switch between the worklist
and the templates by choosing the relevant pushbutton.

Work Area
In the work area, you see the details view of the object selected in the structure tree. You can
also directly access overviews of subordinate objects. Here you can execute all the  business
transactions for project coordination and execution. You can always move between the detailed
view of the selected object and the overviews of the subordinate objects.

You can change the size of the three screen areas to suit your own requirements.
When you leave the Project Builder these settings are saved automatically.
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User-Specific Settings
Use
You can make various personal settings for working with the Project Builder.  These are saved
user-specifically and can be changed at any time. If you do not make any user-specific settings,
the systems works with preconfigured standard settings.

Features
There are two ways of maintaining user-specific settings:

•  The first time you call up the Project Builder, a dialog box appears informing you about the
settings that you can make.  You can then go to the User-specific settings dialog box or leave
this dialog box without changing the standard settings.  If you do not change the settings, the
dialog box appears next time you work with the Project Builder. If you do not want this to
happen, select the Never display again indicator.

•  To access the User-specific settings dialog box where you can define or change your
individual settings, choose Settings → Options.

The following options are available:

Option What You Should Know Default Setting

Open project with

•  Structural display

•  Project planning
board

•  Display last used

You choose the display variant for opening
the Project Builder.

Structural display

Editing mode

•  Change

•  Display

If you usually only look at project data
without changing it, you load the data for
display only.  In this case, the database is
not locked and the project can be edited
(changed) by another user.  If you do not
have change authorization, the system
automatically selects display mode.

Change mode

Hierarchy levels

(possible number: 1 - 99)

You determine how many hierarchy levels
are expanded in the structure tree.  If you
do not enter a number, the system displays
all hierarchy levels.

Two hierarchy levels

Preview last project If you select this indicator, the last project
you worked with is automatically displayed
in the structure tree the next time you call
up the Project Builder.

Not active
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Display deleted objects If you select this indicator, the system
displays objects flagged for deletion
(logically deleted objects), highlighting them
in color.

Not active

Templates

•  New objects

•  Projects

•  Standard templates

With these indicators you determine which
object are contained in the Templates
screen area:

•  'Empty' objects for copying (e.g. WBS,
network etc.)

•  Existing projects as templates for
copying from

•  Standard templates (standard project
definitions, standard WBS elements,
standard networks)

All active

Processable objects With these indicators you determine which
objects can be edited in the Project Builder.
Objects that are not to be edited are not
displayed in the screen areas.

All active
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Executing Functions in the Project Builder
In the Project Builder, you can execute most functions using several methods.

Execute Function via What You Should Know

Drag & Drop This technique enables you to move or copy objects from one
screen area to another.  Simply select an object and drag it,
keeping the mouse button pressed, to the position where you
want to insert it.  (The prerequisite is that it is possible to insert
the object at the relevant position.)

It is possible to use Drag & Drop in the following directions:

Worklist → Structure tree

Templates → Structure tree

Structure tree → Worklist

Structure tree → Templates

Pushbuttons The pushbuttons in the work area are context sensitive, which
means that are only those pushbuttons are displayed that are
required at the present stage of processing.

Above the structure tree, again only those pushbuttons are
active whose functions can be executed at the current point of
time.

For more information and an overview of the pushbuttons, see
Working with the Project Builder [Page 228].

The context menu You can call up the context menu, for example, by clicking with
the right-hand mouse button on an object. This menu is object-
specific in all screen areas, which means, that only the
functions that you can execute for that type object are
displayed.

Click/double-click on an object

(Structure tree, worklist)
•   Click in the structure tree:  The detail screen for the

selected object is opened in the work area.

•   Double-click in the worklist:  The selected project data are
loaded in the structure tree and work area.

The menu bar The menu functions only apply to work area and not to the
structure tree, worklist, or templates.  Exception: The moving of
object up and down in the hierarchy also affects the structure
tree. .
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Working in the Project Builder
You access the Project Builder as follows:

In SAP Easy Access choose Logistics or Accounting → Project system → Basic data → Project
→ Project Builder.

Overview of Pushbuttons in the Project Builder
In the Project Builder several pushbuttons are available for displaying and editing projects. In this
topic the general pushbuttons are discussed that are important for working in the Project Builder.
For an explanation of the pushbuttons in the structure tree, see Functions in the Structure Tree
[Page 230].

General Function Pushbuttons
You can access or execute the following functions using pushbuttons:

Pushbutto
n

Function Effect

Back You return to the screen you processed last in the work
area.

Forward If you have used the Back icon, you go forwards again by
clicking on this icon.

Project planning
board

You go directly to the project planning board. From here
you can return to the Project Builder by choosing .

Network structure
graphic

The network structure graphic appears.

Hierarchy graphic The hierarchy graphic for WBS elements appears.

Display<>Change You can switch between change and display mode. This is
also possible, if you chosen the display mode as the
standard setting in the user-specific settings.  If you do not
have change authorization or if the project is currently being
processed by another user, the system remains in display
mode.  When you switch to change mode, the relevant
objects are locked in the database automatically.

Mass change The system goes to the field selection screen for Mass
Changes [Page 342].

Project Object Icons
In all three screen areas the following icons are used to depict project objects.

Icon Description

Project definition

WBS element

Network
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Activity

Activity elements

Material

Milestones

PS texts

Relationship

Documents

In the work area, these icons are also used to call up overviews and detail screens
for the corresponding project objects.
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Functions in the Structure Tree
Use
In the structure tree you can change the structure for planning and executing a project. Business
transactions are not possible.

You can display the following objects in the structure tree:

•  Project definition

•  WBS element

•  Network headers

•  Activity

•  Activity elements

•  Milestones

•  PS texts

•  Material components

•  Production resources/tools (PRT)

•  Documents

Relationships are not displayed in the structure tree.

See also: User-Specific Settings [Page 225]

Features
You can execute functions in the structure tree using icons or the context menu (right-hand
mouse button).  There is a separate tool bar above the structure tree.

Function Icon Context menu What You Should Know

Open Open A dialog box appears in which you enter the
relevant project definition, WBS element, or
network.  You can decide by push-button
whether you

•  Only open the project

•  Only copy the project to the worklist

•  Open the project and copy it to the worklist

You can only call up the context menu for this
function, if you click using the right-hand mouse
button on the empty background of the structure
tree.
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Create

New → Project/
Network /
Simulation

or

Create → WBS
element, network,
etc.

You can use this function to:

•  Create a new project / network / simulation
(You can only call up the context menu for
this function, if you click using the right-hand
mouse button on the empty background of
the structure tree.)

•  Create a new project object for the object
selected in the structure tree (the new object
always appears below the selected object).
It is also possible to create a network by
copying.

Create by
copying

New
→ Copy Project/
Copy Network /
Copy Simulation

  

With this function you can create a new project /
network /simulation by copying a template. You
can only call up the context menu for this
function, if you click using the right-hand mouse
button on the empty background of the structure
tree.

Include Include You can include existing WBS elements or
standard networks in the structure.

Move WBS
element up or
down a level in
the hierarchy

Hierarchy  →
Level up/ Level
down

The selected WBS element is moved up or down
a level in the project hierarchy.

Copy Copy You can copy project objects (and their
subordinate objects) and insert them at another
position in the project hierarchy. All the objects
subordinate to the selected object are highlighted
in color.

Cut Cut The selected objects are cut out of the structure
tree and are copied to the clipboard.

Undo cut Undo cut The objects that were cut out are restored to
their former position in the structure tree (undo
function).

Paste Paste Objects that have been cut out or copied are
inserted from the clipboard in the structure
below the selected object.

Delete Delete The selected object is deleted from the structure
tree.

Find Find in tree A dialog box appears in which you enter an
object or its description to be found in the
structure tree. When the object is found, it is
selected in the structure tree.
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Find next Find next If there are several project objects that have the
search term, you can use this function to find all
the other objects

Expand

Collapse

Expand / collapse The following options are available in the second
level of the context menu:

•  Expand: All the subordinate project objects
on the next level below the selected object
are displayed.

•  Expand all: All the project objects below the
selected node are displayed.

•  Collapse: All the project objects subordinate
to the selected object are no longer
displayed.

•  Collapse from level: All the project objects
on the same level are collapsed.

•  Collapse all: All the project objects below the
selected node are no longer displayed.

Using the icons in the tool bar, you can only
expand or collapse all.

Transfer data to
worklist/
templates

Copy to →
Worklist/
Templates

The selected project objects are copied to the
worklist or the templates.
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Working with the Worklist
Use
In your personal worklist,

•  You can store project definitions, WBS elements, and networks so that you can quickly
access these objects later.

•  The five projects you processed last are displayed.  You can open them directly from the
worklist by double-clicking and continue processing.

All these project objects remain in the worklist after you have left the Project Builder and are
available when you start work again.

Features
If you copy data to the worklist, this is automatically assigned to the relevant category:

•  Project definitions

•  WBS elements

•  Networks

This helps organize the project data in your worklist and gives you a better overview.

You cannot copy other project objects (for example, activities, activity elements,
milestones, documents) individually to your worklist. You can only copy them to the
worklist  as part of a substructure (WBS elements, networks).

The following table lists how to execute various functions in the worklist:

Function Action Note

Open an object (in
the worklist)

•  Double-click on the required project
object in the worklist

•  In the context menu choose Open.

Opens the project object in the
structure tree and the work
area.

If you have processed data in
the work area and not yet
saved it, a warning query
appears.

Copy objects to the
worklist

Select a project object in the structure
tree and

•  Drag and drop it in the worklist

•  In the context menu, choose Copy to
→ Worklist

The system automatically
makes the assignment to the
relevant group (Project
definition, WBS element, or
Network)

Remove objects
from worklist

Select a project object in the worklist and
choose Remove from worklist in the
context menu.

The project object is removed
from the worklist. It is not
deleted from the project
structure.
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Empty worklist In the context menu, choose Empty
worklist.

All the project objects in the
worklist and the history are
deleted.  The system asks you
to confirm this action before it
empties the worklist.

Change display
sequence

In the context menu, choose Display
sequence and then the required
sequence.

You can specify the following
sequences for the
presentation of the worklist:

•  Description/Identification

•  Identification/Description

Changing the sequence here
also changes the sequence in
the Templates screen area
and in the structure tree.
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Use of Templates
Use
‘Empty’ templates that you can use to copy from when creating a new project or project object
are available in the Templates screen area. In this screen area, you can store existing projects,
WBS elements and networks in your personal templates and use them to create new projects. As
templates you can use projects, WBS elements, and activities that come from

•  The current project

•  Another project

•  A standard project or a standard network

Features
The Templates screen area consists of three groups of templates:

•  Individual objects

Here you can find all possible project objects (Project definitions, WBS elements,
networks, activities etc.).  If you want to create a new project object, you can copy the
new project object from this group to the existing project structure. For more information,
see Creating Project Objects [Page 236]

•  Projects

Here you store existing project objects (project definitions, WBS elements, networks) that
you want to use as templates for creating new projects.

•  Standard templates

Here you store standard project definitions, standard WBS elements and standard
networks that you want to use as templates for new project structures.

For information on how to save project structures and standard structures in the Templates
screen area, see Saving Project Objects as Templates [Page 241] and Creating Project Objects
by Copying [Page 238].

In the user-specific settings you can determine which template groups you want to
use.

See: User-Specific Settings [Page 225]
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Creating Project Objects
Use
In the Project Builder, you can create project objects in different ways. You can

•  Create completely new project objects or

•  Use existing project structures or standard structures as templates to copy from.

In the following, only creating completely new objects is described. We recommend that you use
Templates as described below. For information on how to create WBS elements and activities
using templates, see Creating Project Objects by Copying [Page 267].

Procedure
There are several ways of creating new project objects in the Project Builder:

Using Drag & Drop
1. In the Templates screen area, select the project object to create (for instance WBS element,

activity (external), or milestone) in the Individual objects group.

2. To create a new project or network, drag and drop the template Project definition or Network
to an empty structure tree. If you have already opened a project in the structure tree, drag
the new project object to the required position in the structure tree.  If it is possible to assign
the new object to an object in the structure tree, a plus sign appears besides the mouse
cursor.

Using double-click
In the Individual objects group of the Templates screen area, double-click on the new project
object to be created.

Using the context menu
It is possible to create new project objects using the context menu either in the structure tree or in
the Templates screen area.

1. In the Templates screen area, select the project object to create (for instance WBS element,
activity (external), or milestone) in the Individual objects group, or select the object to which
the new object is to be assigned in the structure tree.

2. In the context menu choose Create.

Using the toolbar

1. Choose .

The system opens a list box and displays the project objects that you can create for the
object selected in the structure tree. If you have not yet opened a project, you can create
a new project or a network.

2. Click in the list box on the project object that you want to create.
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Result
In the work area, the system opens the detail screen for the newly created project object. Here
you can enter the necessary project data.  After you have saved the data, the project object
appears in the structure tree.

If you create a project object within an existing project structure, the new object is
always subordinate to the object selected in the structure tree.

You can also create several objects, one after another, without having to enter the details for
each object or save. In this case, the system uses the pre-defined settings and the new objects
appear in the structure without you saving. In this case, the system uses the pre-defined settings
and the new objects appear in the structures without you saving.  You save the data after you
have created the last object.
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Creating Project Objects by Copying
Procedure
In the Project Builder there are several ways of creating project objects by copying:

•  You can create a new project or network directly by copying, that is without using the
Templates screen area.  In this case, after you have called up the function, a dialog box
appears in which you enter the project or network to be copied. I

•  You can store frequently used projects or project objects in the Templates screen area, and
use this templates to create new objects by double-clicking on them or using Drag & Drop.

For information on how to copy project objects to the Templates screen area, see Saving Project
Objects as Templates [Page 241].

Creating a Project or Network Directly by Copying

Function Action Result

Creating a project
by copying

Choose  and then in
the list box Copy project.

or

In the (empty) structure
tree choose New
->Copy project from the
context menu.

A dialog box appears in which you enter
the name of the project or the standard
project that you want to use as a
template for the new project.

You can use F4 help to display all the
project that are saved in the database.
If you have already opened a project in
the Project Builder, a warning appears
before you close this project.

Creating a
network by
copying

Choose  and then in
the list box Copy
network.

or

In the (empty) structure
tree choose New
->Copy network from the
context menu.

A dialog box appears in which you enter
the name of the network or the standard
network that you want to use as a
template for the new project.

Create by Copying from the Templates Screen Area

Using Drag & Drop
1. In the Templates screen area, select the project object (for example, standard WBS element

or an activity in a simulation version).
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2. Keeping the left-hand mouse button pressed, drag the project object to the required position
in the structure tree.

If you use drag & drop to create project objects, the new object is always subordinate
to the object it is positioned after in the project hierarchy.

Using Double-Click or the Context Menu
The following table informs you how to use double-clicks and the context menu to create new
projects and networks..

From the Projects group

Function Prerequisite Action in Templates
Screen Area

Result

Create
WBS
element by
copying

WBS element
has been
selected in the
structure tree

Double-click on the WBS
element that is to serve as
the template

Or select a WBS element
and choose Create in the
context menu    

Copies the WBS element and
inserts the copy at the selected
position.  You can insert the
new WBS element at the same
level as the selected WBS
element or below it in the
hierarchy. Assignment to the
WBS element (for example, long
texts, Ps texts, milestones etc.)
are copied with the WBS
element. Assignment to the
WBS element (for example, long
texts, Ps texts, milestones etc.)
are copied with the WBS
element.

Creating a
network by
copying

WBS element or
network has
been selected in
the structure tree

Double-click on the network
that is to serve as the
template or

In the context menu choose
Create.

Copies the network and inserts
the copy at the selected
position. The new network is
subordinate to the selected
WBS element or network in the
hierarchy.

From the Standard templates group

Function Prerequisite Action in Templates
Screen Area

Effect
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Create
standard
WBS
element
by
copying

WBS element
has been
selected in
the structure
tree

Double-click on the
standard WBS that is to
serve as the template
Or select the standard
WBS element and
choose Create in the
context menu  

Copies the standard WBS
element and inserts the new
WBS element at the
selected position.  You can
insert the new WBS element
at the same level as the
selected WBS element or
below it in the hierarchy.
Assignment to the WBS
element (for example, long
texts, Ps texts, milestones
etc.) are copied with the
WBS element.
Assignments to the WBS
element are also copied.

Creating
a
standard
network
by
copying

WBS element
has been
selected in
the structure
tree

Double-click on the
standard network that is
to serve as the template
Or select the standard
network and choose
Create in the context
menu  

Copies the standard
network and inserts the new
network at the selected
position.

If you have not stored project data in the templates or require more templates, you
can access other templates from the database by choosing Create with other
template in the context menu.

See also:
Working in the Templates Screen Area [Page 235]
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Saving Project Objects as Templates
Use
If you want to use WBS elements, networks or activities (from operative projects, standard
projects or simulations) as templates to create other projects, you can store them in the
Templates screen area. This enables you to retrieve the data from your templates quickly.

Procedure
You can copy project objects from your currently open project as well as other project objects
that have been saved in the database, to your personal templates:

Copying project objects from the current project to the Templates screen area
You have opened a project in the Project Builder.

1. In the structure tree, select the project object that you want to copy to the Templates.

2. Drag and drop the object to the Templates screen area.

or

1. In the structure tree, select the project object that you want to copy to the Templates.

2. In the context menu, choose Copy to → Templates.

Copying other project objects to the Templates screen area
1. In the Templates screen select the group or the category in which you want to copy the new

template.

Example: For instance if you want to store a standard WBS element as a template,
select Standard templates or Standard WBS elements.

2. In the context menu, choose Include in Templates.

A dialog box appears.

3. Enter the necessary data.

4. Choose .

Result
The project object appears in the corresponding category in Templates and can now be used to
Create by Copying [Page 267].

These templates are kept here until you remove them. To do so, choose Remove from templates
or Empty templates in the context menu.  

If you have not stored project data in the templates, you can access other templates
by choosing Create with other template in the context menu.
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Material Management in the Project Builder
Use
As well as creating and editing material assignments (see for example Creating Project Objects
[Page 236]) in the Project Builder, you can also trigger several material management functions

Features
After you have selected a material component in the structure overview or the component
overview the following functions are available:

Some of these functions are only available from particular screens, for examplke the
component overview

Function Menu Path Comments

Availability check Edit → Availability -> Material If you have set availability
checking for the Project
System in Customizing, this
starts an availability check for
the selected component.

For more information, see
Material Availability Check
[Ext.].

Reset availability
check

Edit -> Availability ->Reset material Resets the confirmed dates
and quantities from the
availability check.

Capacity availability
check

Edit -> Availability -> Capacity If capacity requirements are
generated for an activity, this
checks whether the capacity is
available (no overload) at the
required time.

For more information, see
Capacity Requirements in
Projects [Ext.] and Capacity
Availability Check [Ext.].

Change procurement
type

Edit -> Component -> Procurement If applicable, you can change
the procurement type (e.g.
reservation for network or
reservation for WBS element).

See, Managing Stocks of
Material Components [Ext.].

Display purchase
requisition

Edit > Component -> Purchase
Requisition

Displays a purchase
requisition if one exists.
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Change delivery
address

Edit > Component -> Delivery
Address

Changes the delivery address
for third-party orders only.

Change invoicing plan Edit > Component -> Invoicing plan Changes the invoicing plan for
externally procured
components.

For more information, see
Invoicing Plans in Networks
[Ext.].

BOM explosion Edit > Component -> Explode BOM You can only execute this
function from the component
overview. For more
information, see  Exploding
the Bill of Material [Ext.].

Reassign a
component to another
activity

Edit > Component -> Reassign You can only execute this
function from the component
overview. You can only
reassign components within
the same network.

Set the duration of the
activity to the
component lead time

Edit > Component -> Transfer delivery
time -> duration

You can only execute this
function from the component
overview. For more
information, see Aligning
Activity Duration with Material
Lead Time [Ext.].

Align requirement date
with activity finish date

Edit > Component -> Align with finish
date

You can only execute this
function from the component
overview.

If you want to set the duration
to the component lead time,
you have to align the
requirements date with the
finish date.

Copy component data Edit > Component -> Copy
component data

Copies the date from one
component to another in the
same network.

See Copying Component Data
[Ext.].

Batch management Edit -> Component -> Batch
management

Various batch management
functions are available under
this menu point. You can only
execute these functions from
the component overview.

For more information, see
Batch Management [Ext.].
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Assign PS text Edit -> Component -> Assign PS text If a PS text has been assigned
to the activity, you can also
assign it to the selected
component.

Delete PS text
assignment

Edit -> Component -> Delete PS text
assignment

Deletes the above PS text
assignment.
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Scheduling in the Project Builder
Use
In the Project Builder you can schedule a project based on the network activities in the project.

Integration
The scheduling settings are taken from the profile for WBS scheduling. You can change the
scheduling type, method, and parameters in the project planning board that you can call up from
the Project Builder.

Prerequisites
To carry out scheduling in the Project Builder, you must have entered a start and finish date for
the project definition.

Activities
In the structure tree select the project definition of the current project and choose Edit -> Dates ->
Schedule. To change the scheduling parameters switch to the project planning board by
choosing .

For more information on the various dates in the Project System, refer to Dates [Ext.].
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Executing Mass Changes
Prerequisites
You are in a project in the project planning board or the Project Builder.

Procedure
1. Select all the objects that you want to change.

Choose in the Pushbutton/Menu Path

Project Builder

Project planning board Goto → Mass change

The Mass changes: Field view screen appears.

2. Select the fields whose values you want to change. Proceed as described in Executing Mass
Changes Directly [Page 336].

You can go from the field view to the table view by choosing table view. For more
information on the table view, see Executing Mass Changes with Table View [Page
339].

3. Choose Execute.

Result
The system checks the changes and executes them. A log appears. If the system could execute
the changes, you can see information in the log about every object that was changed. You can
display the log with one line for each entry, which is a simple confirmation, or with two lines with
more details for each entry.

If the system could not execute some changes, because fields did not meet the prerequisites, the
entries are highlighted in red.

You cannot save this log.

The system saves the changes when you save the project.
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Evaluating Data in the Project Planning Board
In the project planning board and the Project Builder, you can branch to the complete reporting
functionality of the Project System in the Extras menu. The following are available:

•  Cost reports (Report Writer reports)

•  Capacity load reports

•  Structure/Date reports from the information system.

You can also branch to graphics to evaluate your project hierarchy or network structures by
choosing either Goto → Network graphics or Goto →→→→ Hierarchy Graphics

See also:
Cost Element Reports [Ext.].

Technical Project Reports [Ext.]
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Confirmations
Prerequisites
You are in a project in the project planning board or the Project Builder.

You can only confirm activities and activity elements, if

•  They have been released

•  The confirmation indicator has been set in the control key

•  They have been saved on the database

You must have defined certain confirmation parameters in Customizing for the Project System
previously.

For more information, see Confirmation Directly in the Project System [Ext.].

Procedure
1. Select the activity to be confirmed.

Choose in the Pushbutton/Menu Path

Project Builder Edit -> Activity -> Confirm

Project planning board

The Create Network Confirmation: Actual Data screen appears.

2. Enter the necessary confirmation data.

3. Choose .

Before you leave the confirmation, you can go to a separate dialog box to enter
goods movements.

Result
According to your settings in Customizing, the system executes the confirmation immediately or
later in a background job.
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Deleting Project Objects
Use
Under certain prerequisites you can delete WBS elements, activities, and activity elements
directly, that is, delete physically. You can always delete relationships and milestones directly.

You cannot undo the physical deletion of project objects.

You can give WBS elements, activities, and activity elements that cannot be deleted directly the
Deletion flag status. They are deleted from the project logically.

Prerequisite
You can only delete WBS elements, activities, and activity elements directly, if they have the
status Created and no postings or assignments to other objects exist.

Integrated planning WBS elements can be deleted as long as no planned costs or
revenues have been posted.

Features
Set the Deletion flag status for WBS elements, activities, and activity elements if they have any
other status than Created. As long as the project objects have the status Deletion flag and
deletion indicators have not been set, you can cancel the deletion flag.

See also:
Archiving Operative Project Structures (PS-ST-OPR) [Ext.]

If you delete activities or set a deletion flag for them, the subordinate activity elements,
relationships, milestones, allocations to material components etc. are also deleted or have a
deletion flag set. If you delete WBS elements or set a deletion flag for them, subordinate WBS
elements, and assignments are also deleted or have a deletion flag set

Activities
Function In the Project Builder In the project planning board

Directly delete project
object

Choose  or Delete in the
context menu of the structure
tree.

Choose  or Edit→ Delete→
Delete object.

Set deletion flag for project
object

Edit → Status  → Deletion
flag → Set.

Edit → Delete → Deletion flag

Canceling Deletion Flags Edit → Status  → Deletion
flag → Undo.

Edit → Delete → Cancel deletion
flag
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To cancel deletion flags in the project planning board for project objects, you must
first display the objects with deletion flags. Choose Edit → Show/Hide → Object with
deletion flag.  The objects with deletion flags are highlighted in gray. You can now
cancel the deletion flag for the required objects. In the Project Builder objects that
are flagged for deletion are highlighted in gray.
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Project planning board
Purpose
The project planning board has a central position in the Project System. It simplifies planning and
controlling projects.  The project planning board allows integrated processing of your project,
giving you a graphic overview of the project objects.  In the graphic interface you can create, edit
and evaluate all the data for a project. You can change the appearance of the project planning
board to suit your individual needs and taste.

Features
With the project planning board

•  You obtain an overview about the hierarchy and progress of your project

•  You can see interrelationships in the organization and the schedule.

•  You can access all the important data in your project, and for example

− Calculate costs

− Plan and check dates

− Plan and schedule resources

− Define and distribute work

− Level capacities

− Make assignments

Furthermore with the project planning board you can:

•  Simulate changes

•  Branch to

− Further graphics, for instance network structure graphic, hierarchy graphic etc.

− Further planning boards in capacity planning

− Costs and capacity reports in the Project Information System

•  Call up logs and additional overviews (capacity, costs/revenues, component, and order
overviews)
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Layout of the Project Planning Board
The Gantt chart is the basis of the project planning board. The project planning board consists of
a table area and a graphic area. It displays the hierarchical structure of the project and the
corresponding dates. You edit your project in the Gantt chart:

Project: BD.002   Billing Plan

BD.002
Bd.002.01  (Bill. element)  
10

06/98 07/98 08/98 09/98 10/9805/98

Table area Graphic area

Description

20
Bd.002.02  
30
Bd.002.03  
40
50

You can also display the following charts for WBS elements and activities in the lower part of the
screen:

Component overview
ID
3171
3172
3173

Work center

Capacity overview: per capacity

Costs and revenues overview
Description

Bd.002.01  (B. element)

06/98 07/98 08/98 09/98 10/9805/98

06/98 07/98 08/98 09/98 10/9805/98

06/98 07/98 08/98 09/98 10/9805/98

Table area Graphic area

Description
Maintenance order 

10
Maintenance order

Maintenance order

Maintenance order overview
05/98 06/98 07/98 08/98 09/98 10/98
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•  Component overview

In the component overview you can see the requirements dates and delivery dates as
well as the last goods movement dates for material components. You can also go to an
additional window to see all the goods movement dates for the selected components.

•  Capacity overview

The capacity overview presents the available capacity, the capacity requirements and
the overload for each work center as bars or as curves. You can also go to an additional
window to see the capacity requirements for a work center from which ever source,
sorted according to dates.

•  Cost overview

The cost overview displays the cumulative distribution of costs and revenues (in the
controlling area currency) as the project progresses. You can also go to an additional
window to see the period drilldown for a selected WBS element or activity.

•  Maintenance order overview

The maintenance order overview displays the dates of the maintenance orders based on
the scheduled dates. With the help of the field selection, you can display detailed
information on your maintenance orders.

See also:
Working in the Overviews [Page 309]

Displaying Detail Lists for Overviews [Page 312]

Layout of the Gantt Chart and the Overviews
The Gantt chart and the overviews consist of a table and a graphic area.

There is a legend for the Gantt chart and each overview. This explains what the various colors
and symbols in the table and graphic areas mean. To display the legend for the Gantt chart,
choose Extras → Legend. To display the legends for the overviews, use the context menu (right-
hand mouse button) and choose Display legend.

Table Area
The table area on the left-hand side of the Gantt chart and the overviews contains information
that describes the objects in the graphic area. You can display up to 16 columns (fields), for more
information about these objects.

Graphic Area
The graphic area presents the schedule of the project and the dates for individual objects.
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Engineering

DescriptionLvl
1998

3

1

2

1

4 1 2 Jun '98
 23 25  27  29  31 33 35 37

Jul '98 Aug '98 Sep '98
3

Design planning

Primary coolant circuit

Date line

Post-evalaution
period

Planning periodPre-evalaution
period

Ti
m

e 
ax

is

Power plant

Evaluation period

The time axis consists of several time scales:

•  Planning period

The planning period refers to the start date of the project. If the start is in the past, the
planning period is offset to the current date.

•  Evaluation period

The whole period that you can see in the planning board. The evaluation period is always
based on the project period.

•  Pre-evaluation period

The time interval from the start of the evaluation period to the start of the planning period.

•  Post-evaluation period

The time interval from the end of the planning period to the end of the evaluation period.

The date line represents the current date.

See also:
Settings for Time Display [Page 320]

Executing Function in the Project Planning Board
In the project planning board, you can execute most functions using several methods.

Execute Function via What You Should Know

The menu The menu functions only apply to the Gantt chart and not the
overviews.

Icons The icon functions only apply to the Gantt chart and not the
overviews.

For an overview of the icons in the Gantt chart, see Working in the
Gantt Chart [Page 260]

A double-click on an object The detail screen for the object appears.

Drag & Drop To create project objects [Page 264], you can drag and drop a
object from the Templates screen area to the table area.  Simply
select an object and drag it, keeping the mouse button pressed, to
the position in the table area where you want to insert it.
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The context menu There is a context menu for the Gantt chart and each overview.
You can call up the context menu, for example, by clicking with the
right-hand mouse button on an object in the table area. This menu
is object specific. Only those functions are displayed that you can
execute with the relevant object in the Gantt chart or overview. For
example, if you select a WBS element and call up the context
menu, only those functions relevant for WBS elements are in the
menu.
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Accessing the Project Planning Board
Use
You can access the project planning board by:

•  Creating a project, changing or displaying an existing project

•  In the Project Builder [Page 221], choosing the relevant push-button to switch to the project
planning board

Procedure
On the SAP R/3 main screen choose Logistics or Accounting → Project system → Basic data →
Project → Project planning board.

You now have the following options:

Function/Menu Path What You Should Know

Create project Creates a new project.

You can use another project, a standard project, or a simulation as a
template for the new project. Use the With activities indicator to
determine whether activities are copied from the template. You can also
determine which objects that are assigned to activities (such as material
components, relationships, PS texts and milestones) are also copied to
the new project.

If you always use the With activities indicator, set the Show
activity indicator in the project planning board profile.
Activities are then displayed as a default when you call up
the project planning board.

Change project

Display project

The initial screen of the project planning board [Page 258] appears.

If you want to access the project planning board from the Project Builder, choose  in the Project
Builder. The system goes directly to the project planning board and displays the project data that
you have already opened.
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Initial Screen of the Project Planning Board
Use
On the initial screen you can see an overview of the projects that you are involved with.  You can
quickly access projects that you have recently processed or that you have stored in your
personal worklist.

You access the initial screen of the project planning board by choosing Project planning board →
Change project or Display project.

Features
There are the following screen areas on the initial screen:

Entry area

Worklist
Preview of last project

Preview last project
In the right-hand screen area you always see in the preview the project that you called up last in
the project planning board.   The project definition of this project is automatically copied into the
entry area. You can thus start work immediately with the last project you worked on.

Worklist
You can store frequently used project data (project definitions and WBS elements) in the worklist,
so that you can access them quickly later.  On the initial screen, you can open project elements
from the worklist and include new project objects in the worklist.
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Entry area
The project or the substructure (WBS element) to be opened is displayed in the entry area.  If
you select project data from the preview or the worklist, the system automatically copies the data
to the entry area.  If you want to open a project or the substructure (WBS element) that is not in
either the preview or the worklist, enter the data manually in the relevant field in the entry area.

You can also temporarily change the project planning board profile [Ext.] and determine whether
subordinate activities are loaded as well.

The following table lists how to execute various functions on the initial screen:

Function Action What You Should Know

Open the project in the
preview

Choose  Open project. The project definition for the
project in the preview always
appears automatically in the
entry field, when the system
loads the initial screen.

Open a project from the
worklist

The following alternatives exist:

•  Double-click on the project in
the worklist

•  Select the project in the worklist
and choose Open in the context
menu.

The system opens the project
in the project planning board.

Open another project Enter the project definition on the
entry field and choose  Open
project.

You can find existing project
definitions by using F4 help.

Copy projects to the
worklist

•  To copy projects from the entry
field to the worklist, choose
Include in worklist.

•  To copy project data from
another project  to the worklist,
choose Include in worklist from
the context menu. A dialog box
appears in which you enter a
project definition or a WBS
element to copy to the worklist.

The system automatically
makes the assignment to the
relevant group (Project
definition or WBS element)
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Working in the Gantt Chart
Overview  of the Icons in the Gantt Chart
Several frequently used functions are available in the form of icons on the standard toolbar above
the Gantt chart.

These functions apply only to the Gantt chart and not to the other charts.

Icon Function Icon Function
Select all Open/close left-hand window

Deselect all Open/close bottom window

Move WBS element level up Filters

Move WBS element level down Grouping

Create Sorting

Copy Highlight project objects

Cut Position on highlight

Paste Switch connect mode on/off

Undo Scheduling comparison

Connect selected activities Zoom in on graphic

Edit relationships (tabular) Adapt graphic area

Delete object Adapt time scale

Detailed information for object Planning board assistant

Confirm activity Time scale assistant
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Schedule Set of dates/view

Calculate costs Options

System/User status Field selection

Component overview Logs and lists

Capacity overview Undo user settings

Maintenance orders

Cost overview

Milestone trend analysis

Predecessor/successor

Show all dependent objects

Hide all dependent objects

The icons Undo, Paste, and Position on next highlighted element are context
sensitive. This means that they appear as soon as the relevant function can be
performed.
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Selecting Objects
Use
To execute functions in the project planning board, you must first select objects in the table area.
The system then knows which objects the function refers to.

The selection functions in the menu of the project planning board always refer to the Gantt chart.
To select objects in the overviews, use the relevant functions in the context menu.

Procedure
Selecting Objects

Select in the Gantt Chart Action

Single project object Click the selection field for that object

Several project objects •  Select several individual objects:

Keep the Shift key pressed and click in the selection fields of the
objects

•  Select as block:

Click in the selection field of the first object, keep the CTRL key
pressed and click in the selection of the last object. All the objects
between are selected too.

All project objects Choose Edit →→→→ Select →→→→ Select all

Only certain project objects Choose Edit →→→→ Select → → → → Objects → → → → WBS element, activity etc.

A sub-tree Select a WBS element and choose Edit →→→→ Select → → → → Sub-tree.

Highlighted objects Edit →→→→ Select → → → → Highlighted objects.

The system selects all objects that were previously
highlighted. For more information, see Highlighting
Project Objects [Page 282]

Selecting the Overviews Action

Single project object Click in the first column of the object

Several project objects Keep the Shift key pressed and click in the first column of the
objects

All objects in an overview Choose Select all in the context menu.

Deselecting objects

Deselect in the Gantt Chart Action
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Several project objects Keep the Shift key pressed and click in the first column of the
objects

All project objects Choose Edit →→→→ Select → → → → Deselect all

Deselect in the Overviews Action

Single project object Keep the Shift key pressed and click in the first column of the
objects

All objects Choose Deselect all in the context menu.

If you have set the Add.Sel. Acts indicator in the options profile for the graphics
profile in Customizing for Basis, you can select or deselect several objects without
pressing the Shift key.
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Creating Project Objects
Use
There are various methods of creating project objects in the project planning board. You can

•  Create completely new project objects or

•  Use other project objects, standard templates, or simulations as templates.

In the following, only creating completely new objects is described. For information on how to
copy or create WBS elements and activities using templates, see Creating Project Objects by
Copying [Page 267].

Features
To create project objects, choose  or Create in the context menu in the table area.  On the left-
hand side of the screen a separate Templates window appears, in which there is the Individual
objects group.

Under Individual objects you can find all possible project objects (WBS elements, activities etc.).

Project: BD.002   

     BD.002
     Bd.002.01    

10

06/98 07/98 08/98 09/98 10/9805/98

Table area Graphic area

Description

20
Bd.002.02  
30
Bd.002.03  
40
50

  Templates

- Individual objetcs
*

*

*

If you want to create a new project object or insert a new object in an existing structure, copy the
object in question from the Templates to the selected position in the table area.

There are various ways of doing this:

Using Drag & Drop
3. In the Individual objects of the Templates screen area, select the project object to create (for

instance WBS element, activity (external), or milestone).

4. Keeping the left-hand mouse button pressed, drag the project object to the required position
in the table area.  If it is possible to assign the new object to an object in the table area, a
plus sign appears besides the mouse cursor.
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If you use drag & drop to create project objects, the new object is always subordinate
to the object it is positioned after in the project hierarchy.

Using Double-Click or the Context Menu
The following table describes how you create project object with a double-click or using the
context menu.

Function Prerequisite Action in Templates
Screen Area

Effect

Double-click on WBS
element

Or select WBS-element and
choose Create in the context
menu  

The new WBS element is
always placed on the top level
of the project. The WBS
elements are numbered
automatically.

Create WBS
element

WBS element
has been
selected in
the table area

Double-click on WBS
element

Or select WBS-element and
choose Create in the context
menu  

Assigns the new WBS element
in the project hierarchy to the
selected WBS element.

Create activity WBS element
or activity has
been selected
in the table
area

Double-click on the activity
category (internal, external,
costs, or service)

Or select an activity category
and choose Create in the
context menu    

Creates an activity for the
selected WBS element or
below the selected activity.

Create activity
element

Activity has
been selected
in the table
area

Double-click on the activity
element (work, external,
costs, or service)

Or select an activity element
and choose Create in the
context menu  

Creates an activity element for
the selected activity.

Create
subnetwork

Activity has
been selected
in the table
area

Double-click on Subnetwork

Or select Subnetwork and
choose Create in the context
menu   

Enables you to add more detail
for an activity by creating a
subnetwork. Enter a standard
network as a template.

See also:
Subnetworks [Page 187]
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Create
component
allocation

Activity has
been selected
in the table
area

Double-click on Material
component

Or select Material
component and choose
Create in the context menu  

Creates an material component
allocation for the selected
activity.

See also:
Material [Ext.]

Create
milestones

WBS element
or activity has
been selected
in the table
area

Double-click on Milestone

Or select Milestone and
choose Create in the context
menu  

Creates a milestone for the
selected activity or WBS
element

See also:
Milestones [Page 192]

PS texts WBS element
or activity has
been selected
in the table
area

Double-click on PS text

Or select PS text and
choose Create in the context
menu  

Creates a PS text for the
selected activity or WBS
element

Documents WBS element
or activity has
been selected
in the table
area

Double-click on Document

Or select Document and
choose Create in the context
menu  

Assigns a document to the
selected activity or WBS
element

You can make entries for various project objects (project definitions, WBS elements,
milestones, activities, activity elements) directly in the table area. You can thus
change your entries in the table area without having to go to the corresponding detail
screen. Click on the relevant field. For example, the following fields can be changed
in this way: Description , ID , basic dates, forecast dates, actual dates, Duration,
Work , Work center , long text.
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Create by copying
Use
You can use existing WBS elements and activities as templates to create other WBS elements
and activities.  You can store project elements that you use as templates frequently in the
Templates screen area.  As templates you can use WBS elements and activities that come from

•  Your current project

•  Another project

•  A standard project or a standard network

•  A simulation version

For information on how to copy project objects to the Templates screen area, see Saving Project
Objects as Templates [Page 270].

Features
Choose  or Create in the context menu of the table area.

On the left-hand side of the screen a separate Templates window appears, in which there are the
groups.

•  Individual objects

Here you can find all possible project objects (Project definitions, WBS elements,
networks, activities etc.).  For information on how to create new objects, see Creating
Project Objects [Page 236].

•  Projects

Here you store existing operative project elements (WBS elements and activities) that
you want to use as templates.

•  Standard templates

Here you store standard project definitions, standard WBS elements and standard
networks that you want to use as templates.

•  Simulations

Here you store WBS elements and activities from simulation versions that you want to
use as templates.

There are various options for copying objects from the templates to the current project:

Using Drag & Drop
5. In the Templates screen area, select the project object (for example, standard WBS element

or an activity in a simulation version).

6. Keeping the left-hand mouse button pressed, drag the project object to the required position
in the table area.
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If you use drag & drop to create project objects, the new object is always subordinate
to the object it is positioned after in the project hierarchy.

Using Double-Click or the Context Menu
The following table describes how you create project objects by copying with a double-click or by
using the context menu.

From the Projects group

Function Prerequisite Action in Templates
Screen Area

What You Should Know

Create
WBS
element

WBS element
has been
selected in the
table area

Double-click on the WBS
element that is to serve as
the template

Or select a WBS element
and choose Create in the
context menu    

Copies the WBS element and
inserts the copy at the selected
position.  You can insert the
new WBS element at the same
level as the selected WBS
element or below it in the
hierarchy. Assignment to the
WBS element (for example, long
texts, Ps texts, milestones etc.)
are copied with the WBS
element.

See also: Including WBS
Structures [Page 275]

Create
Network

WBS element or
activity has been
selected in the
table area

Double-click on the network
that is to serve as the
template or

In the context menu choose
Create.

Copies the network and inserts
the copy at the selected
position. The new network is
subordinate to the selected
WBS element or network in the
hierarchy.

You can choose whether
assignments to activities (such
as long texts, PS texts,
milestones etc.) are copied with
the network.  However
relationships are not copied.

From the Standard templates group

Function Prerequisite Action in Templates
Screen Area

Effect
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Create WBS
element by
copying
standard WBS
element

WBS element
has been
selected in
the table area

Double-click on the standard
WBS that is to serve as the
template or

Or select the standard WBS
element and choose Create
in the context menu   

Copies the standard WBS
element and inserts the new
WBS element at the selected
position.  You can insert the
new WBS element at the same
level as the selected WBS
element or below it in the
hierarchy. Assignment to the
WBS element (for example,
long texts, Ps texts, milestones
etc.) are copied with the WBS
element.

See also: Including WBS
Structures [Page 275]

Create
network by
copying
standard
network

WBS element
has been
selected in
the table area

Double-click on the standard
network that is to serve as
the template

Or select the standard
network and choose Create
in the context menu  

Uses the standard network as a
template to create new
activities for the selected WBS
element.

From the Simulations group

Function Prerequisite Action in Templates
Screen Area

Effect

Create WBS
element from
simulation

WBS element
has been
selected in
the table area

Double-click on the WBS
element that is to serve as
the template

Or select a WBS element
and choose Create in the
context menu   

Copies the WBS element from
the simulation and inserts the
copy at the selected position.
You can insert the new WBS
element at the same level as
the selected WBS element or
below it in the hierarchy.
Assignment to the WBS
element (for example, long
texts, PS texts, milestones etc.)
are copied with the WBS
element.

If you have not stored project data in the templates or require more templates, you
can access other templates from the database by choosing Create with other
template in the context menu.
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Saving Project Objects as Templates
Use
If you want to use WBS elements, networks, or activities (from operative projects, standard
projects or simulations) as templates for other projects, you can store them in the Templates
screen area. This enables you to retrieve the data from the templates quickly.

Procedure
You have opened a project in the project planning board.

1. Choose .

The Templates subscreen appears in the left-hand screen area.

2. Here select the group or the category in which you want to copy the new template.

Example: If you want to store a standard WBS element as a template, select Standard
templates or Standard WBS elements.

3. In the context menu, choose Include in Templates.

A dialog box appears.

4. Enter the necessary data.

5. Choose .

Result
The project object appears in the corresponding category in Templates and can now be used to
Create by Copying [Page 267].

These templates are kept here until you remove them.  To do so, choose Remove from
templates or Empty templates in the context menu.  

If you have not stored project data in the templates, you can access other templates
by choosing Create with other template in the context menu.
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Entering WBS Element Numbers
Use
If you are working with very large projects and need to create a lot of elements with complex
project numbers, the system can help you enter the numbers.

Prerequisites
You have defined a special character in the Project System IMG to act as the input help.

Features
If you enter the special character in the WBS element field in your project, the system copies the
number of the higher-level WBS elements into the field. If the new WBS element is the first one in
the project hierarchy, the system copies the project definition.

Then you only need to add to the number so that it is different from the one copied. You can also
use the input help in conjunction with a project coding mask. In this case, you do not need to
enter the separator when adding to the WBS element number.

You have specified the character @ as an input help. In the work breakdown
structure, you insert another WBS element under the WBS element A-123-LDZ-10
and only type "20.

Type of Input Help Your Entry

No project coding mask @-20

Using project coding mask A-000-XXX-00-00 @20

The system automatically copies the identifier from the superior WBS element as
follows: A-123-LDZ-10-20.
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Deriving the Hierarchy from the WBS Element Number
Use
If you are working with very large projects and need to create a lot of elements with complex
project numbers, the system can help you derive the hierarchy.

Prerequisites
You have defined a coding mask for your projects in Customizing for the Project System. In this
coding mask you entered enough dashes to model all the levels in the project hierarchy.

Features
If you have defined a coding mask, you can enter all the WBS elements in a project after each
other without worrying about the hierarchy level. You can, for instance, enter all WBS elements
on level 1.

The system then derives the hierarchy level of each WBS element from the coding mask. The
WBS element with the shortest number is created in level 1. Every further WBS element is
placed on a subordinate level, depending on its number and the number of dashes.

You have defined a project coding mask P-000-XX-00. You have entered all WBS
elements on the same level. The system derives the hierarchy levels as follows:

WBS Element Number Level Superior WBS Element

P-001 1

P-001-AA 2 P-001

P-001-AA-01 3 P-001-AA

Activities
After you have entered all the WBS elements, choose Project → Derive structure → Derive. The
system places the WBS elements in the correct sequence in the project hierarchy.

If the system cannot derive the hierarchy, it prompts you to check the structure. To do this,
choose Project  → Derive structure  → Check. The system then displays a message text,
detailing the errors found.
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Copying Project Objects
Use
In your current project you can use WBS elements, activities, activity elements, and milestones
as templates for new project objects and copy them in the project.

Features
The various options for copying are listed below:

Function Action What You Should Know

Copy WBS elements Select a WBS element in the
table area and choose 

or in the context menu choose
Copy.

Then choose .

In the context menu choose
Paste.

Copies one or more WBS
elements from the current project
as new WBS elements to a new
position. To insert a WBS
element, select another WBS
element.

Copy activities Select an activity in the table area
and choose 

or in the context menu choose
Copy

Then choose .

In the context menu choose
Paste.

Copies one or more activities in
the current project to a new
position. To insert an activity,
select a WBS element.

You can also copy
assignments to an
activity with the
activity (e.g. long
texts and milestones).
However
relationships are not
copied.

Copy activity elements Select an activity element and
choose 

or in the context menu choose
Copy.

Then choose .

In the context menu choose
Paste.

Copies one or more activity
elements in the current project to
a new position. To insert activity
elements, select an activity.
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Copy milestones Select a milestone and choose 

or in the context menu choose
Copy.

Then choose .

In the context menu choose
Paste.

Copies one or more milestones in
the current project to a new
position. To insert a milestone,
select a WBS element or activity.

After you have inserted copied project objects, you can delete them from the project
structure by using the Undo function.  Choose  or Undo in the context menu.
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Including WBS Structures
Procedure
1. Select the WBS element where you want to include the new WBS element.

2. Choose Edit → → → → Copy →  →  →  → WBS structure.

A dialog box appears.

3. Select either of the tab pages, Standard WBS or Operative WBS.

4. Enter

− Which WBS element you want to include

If the WBS element to be included has additional WBS elements subordinate to it,
the system automatically copies these lower-level hierarchy elements.

− Whether you want to include the new WBS element at the same hierarchy level as the
selected WBS element or below it.

− Which options to use when including the WBS element:

Option Effect

Right/Left The WBS element is positioned to the right or to the left of
the selected WBS element in the hierarchy.

With/without root With root: The selected WBS element is included.
Without root: Only the subordinate WBS elements are
included.

With/without activities The WBS element is includes either with or without  its
assigned activities

5. Choose WBS element overview.

The Copy structure screen appears.

6. Select the WBS element(s) that you want to include.

7. Give the new WBS elements new numbers by using either the Predefine or Replace function.

8. Choose Include.

Result
The system includes the WBS element(s). If you have selected With activities, the corresponding
activities are also included.

See also:
Copying Project Objects [Page 273]
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Moving Project Objects
Use
You can change the assignments of objects in a project by moving the objects to another position
in the project.

Features
You can move project objects

•  By using drag and drop

You can only move one project object at a time with drag and drop. These objects can be
WBS elements, activities or activity elements.

•  By using cut and paste

You can cut and paste several project objects at once.  You can use cut & paste for WBS
elements and activities. As of Release 4.5B, you cannot use cut & paste for activity
elements.

Activities
When you move activities, you reassign these activities together with their activity elements and
milestones to another WBS element.

If you move a WBS element , you reassign this WBS element together with its subordinate WBS
elements within the project hierarchy. The WBS element is inserted in the table area above the
target WBS element and in the project hierarchy to the left of the target WBS element.
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Deleting Project Objects
Use
Under certain prerequisites you can delete WBS elements, activities, and activity elements
directly, that is, delete physically. You can always delete relationships and milestones directly.

You cannot undo the physical deletion of project objects.

You can give WBS elements, activities, and activity elements that cannot be deleted directly the
Deletion flag status. They are deleted from the project logically.

Prerequisite
You can only delete WBS elements, activities, and activity elements directly, if they have the
status Created and no postings or assignments to other objects exist.

Integrated planning WBS elements can be deleted as long as no planned costs or
revenues have been posted.

Features
Set the Deletion flag status for WBS elements, activities, and activity elements if they have any
other status than Created. As long as the project objects have the status Deletion flag and
deletion indicators have not been set, you can cancel the deletion flag.

See also:
Archiving Operative Project Structures (PS-ST-OPR) [Ext.]

If you delete activities or set a deletion flag for them, the subordinate activity elements,
relationships, milestones, allocations to material components etc. are also deleted or have a
deletion flag set. If you delete WBS elements or set a deletion flag for them, subordinate WBS
elements, and assignments are also deleted or have a deletion flag set

Activities
Function In the Project Builder In the project planning board

Directly delete project
object

Choose  or Delete in the
context menu of the structure
tree.

Choose  or Edit→ Delete→
Delete object.

Set deletion flag for project
object

Edit → Status  → Deletion
flag → Set.

Edit → Delete → Deletion flag

Canceling Deletion Flags Edit → Status  → Deletion
flag → Undo.

Edit → Delete → Cancel deletion
flag
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To cancel deletion flags in the project planning board for project objects, you must
first display the objects with deletion flags. Choose Edit → Show/Hide → Object with
deletion flag.  The objects with deletion flags are highlighted in gray. You can now
cancel the deletion flag for the required objects. In the Project Builder objects that
are flagged for deletion are highlighted in gray.
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Presentation of Data
Use
In the Gantt chart you can limit which objects are presented. This makes the required information
more manageable and easy to understand.

Features
In the following table you can see the various methods of presenting the data:

Function Icon What You Should Know

Highlight [Page
282]

Choose . The project elements that have the corresponding
assignments or characteristics are highlighted.

Filters [Page
284]

Choose . Only those project objects that meet the filter criteria are
displayed. All other project objects are hidden.

Sort [Page 285] Choose . The project elements are grouped according to particular
selection criteria in ascending or descending order.

Grouping [Page
285]

Choose . The project elements are grouped according to particular
selection criteria in ascending or descending order. The sum
of the objects in the group is displayed in a total bar.
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Displaying Project Objects
Use
In the Gantt chart you can show or hide objects in your project and thus decide on the degree of
detail you display.

Procedure
Project Object Prerequisite Menu Path What You Should

Know

Activity Select WBS element Edit → Show/hide →
Show activity or Hide
activity

The system also
shows or hides the
assigned activity
elements and
milestones You show
or hide sub-networks
and project objects
with deletion flags
separately.

Activity elements Select activity Edit → Show/hide →
Show activity element or
Hide activity element

Milestones Select WBS element
or activity

Edit → Show/hide →
Show milestone or Hide
milestone

You can display the
milestones for an
activity in several
lines or grouped
together in one line.
To do so, choose
Settings → Display →
Milestone → Display
individually or Display
grouped.

Subnetwork Select activity Edit → Show/hide →
Show network or Hide
network

Sub-tree Select WBS element Edit → Object → WBS
element →
Collapse/expand

The system shows or
hides all the
subordinate project
objects in a sub-tree.

Relationship Select WBS element
or activity

Edit → Show/hide →
Show relationship or Hide
relationship

The system shows or
hides the
relationships in the
graphic area.
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Project object with
deletion flag

Select WBS element
or activity

Choose Edit →→→→
Show/Hide → → → → Object with
deletion flag in the
relevant menu section

The system displays
the project object with
a deletion flag and
highlights it in color.

For more information,
see Deleting Project
Objects [Page 277]

If you want to display all the project objects assigned to a project object, select the
object and choose Show all dependent objects. However sub-networks and objects
with deletion flags are not displayed. Display these objects separately.
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Highlighting project objects
Use
You can use highlighting to obtain an overview of project objects that have particular
assignments, characteristics, and states. The system highlights those project objects that meet
your selection criteria. You can always highlight an assignment, characteristic or state in the table
area.

Project: BD.002   

BD.002
Bd.002.01    
10

06/98 07/98 08/98 09/98 10/9805/98

Table area Graphic area

Description

20
Bd.002.02  
30
Bd.002.03  
40
50

The following selection options are available in a separate subscreen:

Object with Assignment
You can use these selection criteria to highlight objects that have assignments, for instance,
maintenance orders, assets under construction, or activities.

WBS Element With Attribute
You can use these selection criteria to highlight WBS elements that are, for instance, account
assignment elements, billing elements, or statistical elements.

Activity with Attribute
You can use these selection criteria to highlight activities that are, for instance, internal
processing activities, external processing activities, or general cost activities.

Object with State
You can use these selection criteria to determine, for example, for which project objects the
scheduled dates are no longer current, maintenance orders are running late, or for which material
components purchase requisitions and reservations have not been activated.

You can then use the relevant function to update the scheduling, or activate purchase
requisitions and reservations etc.. For more information see Functions in the Gantt Chart [Page
292].

Prerequisite
The system can only highlight those project objects that are displayed in the table area. Project
that are hidden are not taken into account.
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Procedure
Highlight project objects

1. Choose .

A selection subscreen appears on the left-hand side of the screen with an overview tree
containing all four selection categories.

2. Open the node of the relevant category and select the required selection criterion.

The system highlights in color those project objects that meet your selection criteria.

Closing the Selection Subscreen

To close the selection subscreen and return to the project planning board, choose  above the
table area. The highlighting in the table area is kept.

Undoing Highlighting

If you want to undo the highlighting, open the list box to the right of   and choose Undo
highlighting. The highlighting disappears.

Highlighting cannot be saved by the system.

Example
You are an MRP controller and want an overview of all the activities that are assigned material
components.  By using highlighting you can select all the relevant activities, and then process the
information further by going to the relevant detail screens.
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Using Filters
Use
In the Gantt chart you can use filters to display only those objects that are of interest. For
instance you can display objects that have a budget of more than USD 10,000.

Procedure
1. Choose .

2. The Select Conditions  dialog box appears.

3. Copy the required selection criteria for project objects from the right-hand column to the left-
hand column.

4. Choose Continue.

The Set User-Defined Conditions dialog box appears.

5. Enter the conditions for your selection criteria.

You can also save the conditions as a variant for later use.

6. Choose Set conditions.

Only those project objects are displayed that meet your conditions.

7. To return to the complete project, open the list box to the right of  and choose Undo.

8. If you want to use the same filter later, for instance after you added more project objects,
open the list box to the right of  and choose Apply.(You cannot use this function after
Undo.)
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Sorting and Grouping Project Objects
Use
The result of sorting and grouping project objects is basically the same in both cases.  The
system sorts the project objects according to the selection criteria in ascending or descending
order. In both cases the system sorts the project objects according to the selection criteria in
ascending or descending order. In grouping a totals bar is also displayed that separates different
values or groups similar values.

Procedure
1. Choose  (sort) or  (group).

The Select Sort Criteria or Select Grouping Criteria dialog box appears.

2. Copy the required selection criteria for project objects from the right-hand column to the left-
hand column.

Here you can select fields that are not displayed in the table area.

3. For each criterion also select Ascending or Descending.

4. After you have defined the selection criteria, choose Continue.

The project objects are sorted according to the selection criteria. In the case of grouping,
colored total bars are also displayed.

If you want to display the original project hierarchy, choose

•  Undo in the list box for the sort icon 

•  Undo in the list box for the group icon 

If you want to use the sort or group criteria again later, choose

•  Apply  in the list box for the sort icon 

•  Apply  in the list box for the group icon 
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Relationships Maintenance
Use
You can edit relationships in the table area or in the graphic area of the Gantt chart using the
mouse.

See also:
Relationships [Page 174]

Features
The following table shows which functions maintain which relationships.

Function Icon/Menu Path What You Should Know

Show/hide relationships Edit → Show/hide  → Show
relationship or Hide
relationship

Grays out/in the relationships
in the diagram area.

Select relationships Edit → Select → Relationships The relationships must be
displayed in the Gantt chart.

Delete relationships Edit → Delete → Delete
Object

Deletes a relationship that you
have selected in the graphic
area.

Display
predecessor/successor

Goto → 
Predecessor/successor

Displays the
predecessor/successor of the
selected activity.

Display the detailed data of a
relationship

Double-click on the
relationship in the graphic
area

Redraw relationships after
changes to subnetworks

Edit → Object → Activity →→→→
Create subnetwork
relationship

When you change the
successor or the predecessor
of an activity replaced by a
subnetwork, you can have the
system recalculate and redraw
relationships.

Create relationships in the
graphic area

Choose . You can use the pencil cursor
to create any relationship in
the graphic area.

See also:
Creating Relationships in the
Graphic Area [Page 289]
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Edit relationship in the
relationship overview

Choose . You can create, edit or delete
the relationships of one or
more selected activities in the
relationship overview.

See also:
Editing Relationships in the
Overview [Page 290]

Automatically create
relationships (as FS
relationships)

Choose . See also:
Automatically Creating
Relationships [Page 288]
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Automatically Creating Relationships
Use
You can let the system create relationships automatically.

Features
If you execute this function,

•  The system creates all relationships between the selected activities as FS relationships.

•  The activities are linked according to their order in the table area.

You can change the order of activities before you create relationships (for instance
by sorting according to work center, status or duration).  The relationships are then
created in this new order.

Activities
To automatically create relationships, you must carry out the following activities:

1. Select all the activities that you want to link with relationships.

2. Choose .

The system displays the relationships in the graphic area of the Gantt chart.

There are the following methods of changing or deleting relationships that have been created
automatically:

All Relationships

1. Select at least one activity.

2. Choose .  The Relationship Overview appears. Here you can change or delete all the
settings for the relationships.

or

1. Select at least one activity.

2. From the context menu choose Relationships list. The Relationship Overview appears.
Proceed as above.

Individual Relationships

Double-click on a relationship in the graphic area of the Gantt chart to call up the detail screen for
the relationship.  Here you can change all the settings for this relationship.

To delete individual relationships click on a relationship in the graphic area and choose Delete in
the context menu.
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Creating Relationships in the Graphic Area
Use
You can create relationships between network activities in the graphic area of the project
planning board.

Procedure
1. Choose  to activate the connection mode.

All relationships are displayed in the graphic area and the mouse pointer takes the form
of a pencil.

2. Position the pencil on the activity, from which you want to draw a relationship. Press the left
mouse button and move the mouse pointer on the activity to which you want to link.

The activities are connected by a line.

Deactivate the connection mode by clicking outside the graphic area. The following figure
shows you the way to draw the line to create the different types of relationships.

Finish-startFinish-start

Start-startStart-start

Finish-finishFinish-finish

3. After you have created the relationship, choose  again.

The connect mode is switched off.
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Editing Relationships in the Overview
Use
You can create, edit and delete relationships in a tabular overview.

Procedure
Create relationships
1. Select the activities for which you wish to create relationships.

2. Choose Edit → Create →→→→ Relationship.

The relationship overview for the first selected activity appears. All the activities of the
current network are displayed in the Activity selection section (lower list) of the dialog box
If activities in the current network are linked by relationships to other networks, these
activities are also displayed.

You can thus link the current activity with an activity from another network via activity
selection.

You can edit relationships between activities in several ways:

Edit Relationship Procedure

As predecessor 1. In the relationship overview choose the
Predecessor tab page.

2. In the activity selection list select the activity that
should immediately proceed the selected activity.

3. Choose Create relationship.

As successor 1. In the relationship overview choose the Successor
tab page.

2. In the activity selection list select the activity that
should immediately follow the selected activity.

3. Choose Create relationship.
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Mixed (predecessors and successors) 1. In the relationship overview choose the Mixed tab
page.

2. In the activity overview select an activity as a
predecessor or successor.

3. Choose Create relationship.

4. Set the Scs indicator for successors in the
relationship overview.

If you do not set this indicator, the
relationship is a predecessor relationship

3. Select the relationship and choose Relationship.

 The detail screen for the relationship appears.

4. Enter the detailed data for the relationship and choose Back.

 The relationship overview appears again.

5. Choose the Next arrow for the next selected activity and repeat steps 2 to 4.

6. When you have created all the required relationships, save.

Delete Relationships

When you delete relationships, you change the structure of the network. This can
affect scheduling and the capacity load.

1. Select the activity whose relationships you want to delete.

2. Choose Edit → Object → Activity →→→→ Relationship overview.

The relationship overview for the selected activity appears.

3. In the relationship overview select the relationship to delete.

4. Choose Delete and confirm the message.

5. Save your data.
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Functions in the Gantt Chart
Use
You can execute various functions for planning and executing projects from the Gantt chart.

Features
Function Icon or Menu Path Effect

Schedule Choose  or

Edit →→→→ Functions → Schedule

Executes WBS scheduling for the
selected WBS elements.

Calculate costs Choose  or

Edit → Functions →→→→ Calculate costs

Executes network costing for the
selected networks.

See also:
Planning Costs in Networks [Ext.]

Material
availability

Edit  →→→→ Functions → Material
availability (network)

Checks material availability for all
components  allocated to networks,
which are assigned to the selected
WBS elements.

See also:
Material Availability Check [Ext.]

Activate purchase
requisition/reserva
tion

Edit  →→→→ Functions → Activate
PurcReq/Resv

Activates purchase requisitions and
reservations for the selected
activities.

See also:
Activating Reservations and
Purchase Requisitions [Ext.]

Activate capacities Edit  →→→→ Functions → Activate
capacities

Determines the capacity
requirements for the activities
assigned to the selected WBS
elements, after scheduling has been
executed.

Activate cost
calculation

Edit  →→→→ Functions → Activate cost
calc.

Determines the costs for the
activities assigned to the selected
WBS elements, after costing has
been executed.

Milestone trend
analysis

Choose  or

Goto → Milestone trend analysis

Executes milestone trend analysis
for the selected WBS elements.

The prerequisites for carrying out a
MTA are listed in:

Milestone Trend Analysis (MTA)
[Ext.]
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Mass change Goto → Mass change Makes mass changes for the
selected attributes of the selected
project objects.

See also:
Mass Change [Page 333]

You can let the system search and highlight activities, for which

•  Reservations and purchase requisitions

•  Capacity requirements

•  Costs

have not been activated. For more information, see Highlighting Project Objects
[Page 282]
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Executing Mass Changes
Prerequisites
You are in a project in the project planning board or the Project Builder.

Procedure
4. Select all the objects that you want to change.

Choose in the Pushbutton/Menu Path

Project Builder

Project planning board Goto → Mass change

The Mass changes: Field view screen appears.

5. Select the fields whose values you want to change. Proceed as described in Executing Mass
Changes Directly [Page 336].

You can go from the field view to the table view by choosing table view. For more
information on the table view, see Executing Mass Changes with Table View [Page
339].

6. Choose Execute.

Result
The system checks the changes and executes them. A log appears. If the system could execute
the changes, you can see information in the log about every object that was changed. You can
display the log with one line for each entry, which is a simple confirmation, or with two lines with
more details for each entry.

If the system could not execute some changes, because fields did not meet the prerequisites, the
entries are highlighted in red.

You cannot save this log.

The system saves the changes when you save the project.
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Dates Maintenance
Setting/Removing Time Constraints in the Graphic Area
When you move the time bar of the activities, the system automatically sets the constraints "no
earlier than/no later than..."

1. Select the activity for which you want to set a time constraint.

2. Choose Edit →→→→ Object → → → → Activity →→→→ Set constraint start or Set constraint fin. By choosing
start_fin. you can set both dates at the same time.

Choose Edit →→→→ Object → → → → Activity →→→→ Delete constraint start or Delete constraint fin. to delete time
constraints. By choosing start_fin. you can delete both dates at the same time.

Setting Dates for Project Objects (Inserting a Time Bar)
If you want to create a time bar for a project object press and hold the mouse button and draw a
time bar. The time bar is inserted.

If you only create one date, that is, a start or a finish date, it is displayed as a circle
not a time bar. You can create a time bar from it.

The default values from the planning board profile apply for the duration, work and unit in
activities. You can change the default values by selecting Settings  →→→→ Options.

If you select several sets of dates, you must specify when you insert the date bar for
which set of dates it is valid for. However, you can shift existing date bars.

Setting Milestone Dates
If you want to maintain a date or date and time for a milestone,

Hold the mouse button and draw a short time bar.

The position where you first positioned the mouse pointer is the date or date and time for
the milestone. The system inserts the symbol for the milestone here.

Shifting a Time Bar in the Graphic Area
1. Position the mouse pointer.

− On the left half of the time bar, if you want to change the start of the project object.

− On the right half of the time bar, if you want to change the finish of the project object.

The mouse pointer takes the form of a double arrow.

− On the middle of the date bar, if you want to change both the start and finish of the
project object.

The mouse pointer takes the form of a double arrow.

2. Press and hold the mouse button, while you move the mouse  to the left or to the right.



Structures  SAP AG

Dates Maintenance

296 April 2001

You can determine in Customizing whether the date is displayed in a dialog box and in
the status line in the lower border of the screen when you move the time bar.

When you release the mouse button, the time bar is lengthened or shortened
correspondingly.

When you shift dates, the system

− Use the dates in the WBS elements

− Duration of activities

Scheduled dates of WBS elements and activity elements cannot be shifted. If you
make changes which affect dates, they receive the system status that rescheduling
is necessary.
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Scheduling Functions
Use
You can execute several scheduling functions in the Gantt chart.

Features
You can start the following functions. for date scheduling from the Edit menu.

Function Icon/Menu Path What You Should Know

Schedule Choose  or Edit → Schedule This calls up WBS
Scheduling [Ext.] .

Shift Dates Choose Edit → Shift dates →

•  Shift project

•  Shift subtree or

•  Shift WBS element

You can enter a new start
date for a project, a sub-
tree or a WBS element.
The system will calculate a
new finish date from the
difference between the “old
start date” and the “new
start date”.

You can use the shift dates
function for both basic and
forecast dates, regardless
of planning method.

Comparing
Dates

Choose  or Edit → Compare dates Use the compare dates
function to compare the
various types, for example
basic dates with forecast
dates.

You can use the Compare
dates function for all sets of
dates regardless of
planning method.

Choose Edit → Reconcile dates  →Reconciling
Dates

•  Copy scheduled dates The scheduled dates are
copied to the basic or
forecast dates.
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•   Copy top-down

•  

You can transfer the dates
from one WBS element to
all subordinate WBS
elements.

You can carry out this
function for all sets of
dates, regardless of
planning method.

•  Extrapolate dates You can transfer the dates
from one WBS element to
all superior WBS
elements, if these higher-
level WBS elements do not
yet have any dates.

You can carry out this
function for all sets of
dates, regardless of
planning method.

•  Transfer forecast dates to basic dates or

•  Transfer basic dates to forecast

The basic dates are
transferred to the forecast
dates and vice versa.

Choose Edit → Check dates →

•  Within WBS The dates of the WBS
element are checked to
see whether the basic or
forecast dates are within
the dates of superior WBS
element.

•  Activity dates for WBS element The system checks
whether the basic or
forecast dates of the
activities lie within the
dates of the WBS element.

•  Scheduled dates in project structure The dates of the WBS
element are checked to
see whether the scheduled
dates are within the dates
of superior WBS element.

Checking
Dates

•  Final confirmation WBS element Makes a final confirmation
for the selected WBS
element.
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For actual dates, you can only use the Final
confirmation WBS function in the Check Dates
menu entry.

The system does not check whether the dates lie
within the framework of the project definition.
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Leveling of Capacities
Use
You can plan and evaluate the capacity load in the bar chart.

Activities
Choose Goto →→→→ Capacity leveling to branch to the following views of the graphical capacity
planning board::

•  WBS element load

This shows the load on the work center that is caused by the selected WBS element.
Capacity requirements from other orders or networks will not be displayed.

•  Total load

This shows the load of the WBS elements, including the capacity requirements from
other orders and networks.

•  Individual capacity WBS element

The load from the individual capacity, which is caused by the selected WBS element.
Capacity requirements from other orders or networks are not displayed.

•  Individual capacity overall load

The load from the individual capacity of the WBS element, including the capacity
requirements from other orders, networks and WBS elements.

See also:
Graphic planning board [Ext.]

To branch to the workforce planning graphical planning board, choose Goto →→→→ Capacity leveling
→ Workforce planning. Here you distribute the work from the selected WBS element amongst the
people based on the corresponding period.

See also:
Workforce Planning [Ext.]
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Cost Planning
Use
Costs and revenues are determined in the project planning board if you have selected the
corresponding fields in the table area of the bar chart or cost overview.

Prerequisites
You can specify in Customizing for the Project System whether fields with project costs and
revenues are to be displayed in the table area of the bar chart or cost overview. If you then call
up a project with the corresponding planning board profile, the costs are determined
automatically.

If the cost fields have not be specified in the planning board profile, you can select these fields in
the bar chart and/or cost overview.

Features
You can determine and display costs:

•  In the bar chart

You display the relevant fields in the table area of the bar chart.

•  In the cost overview

The cost overview displays the cumulative distribution of costs and revenues as the
project progresses. The cost overview refers to a selected WBS element or activity.
Those costs are evaluated that were selected as fields in the cost overview, for instance
planned and actual costs or planned costs and revenues.

In the graphic area of the cost overview chart up to three values can be displayed. If,
for instance, five cost fields are displayed in tabular area, only the first three are
displayed graphically.

•  In the cost reports

You can access all the cost reports that are in the Project Information System. Choose
Extras → Run cost report, to execute the required report.
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Evaluating Data in the Project Planning Board
In the project planning board and the Project Builder, you can branch to the complete reporting
functionality of the Project System in the Extras menu. The following are available:

•  Cost reports (Report Writer reports)

•  Capacity load reports

•  Structure/Date reports from the information system.

You can also branch to graphics to evaluate your project hierarchy or network structures by
choosing either Goto → Network graphics or Goto →→→→ Hierarchy Graphics

See also:
Cost Element Reports [Ext.].

Technical Project Reports [Ext.]
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Printing Directly from the Project Planning Board
Seite einrichten [Page 305]

Seite einrichten [Page 305]

Seite einrichten [Page 305]

Use
If you are working in the project planning board, you can print the individual screen areas directly.
The following options are available:

•  You can print only the Gantt chart.

•  You can print all the overviews (component, capacity, costs, and maintenance order
overviews) individually.

•  You can print the Gantt chart and all the overviews together in a general overview.

You can also write additional information in a print box, which you can integrate in the print-out.

For more information, see Printing Additional Information (Print Box) [Page 307]

Procedure
Printing the General Overview (Gantt Chart and all Overviews)
Before you print the general overview, you must open all the overviews.

1. Choose  or Project → Print → All. A screen appears with a print preview of the general
overview.

2. You can change the print settings by choosing Page Setup... and Printer Setup...

3. When you have completed the setup, choose Print.  

Printing the Gantt Chart

1. Choose Project → Print → Gantt chart. A screen appears with a print preview of the Gantt
chart.

2. You can change the print settings by choosing Page Setup... and Printer Setup...

3. When you have completed the setup, choose Print.

Print the Individual Overviews (Component, Capacity, Costs, and Maintenance Order
Overviews)
Before you print an overview, you must open it in the project planning board.

1. Choose Project → Print → and the required overview. A screen appears with a print preview
of the overview.
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2. You can change the print settings by choosing Page Setup... and Printer Setup...

3. When you have completed the setup, choose Print.  

If you choose , the current view of the project planning board is printed.
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Editing the Page Layout
Use
With the help of the Set up page option, you can determine the page layout of the pages that are
to be printed.

Features
The following options are available:

Controlling the page distribution

Displaying the pages as individual pages

Setting cutting marks

Adjusting the time scale

Defining the margins

Controlling the page distribution   
You can control the page distribution using the adjust to page indicator.

You predefine by which number of pages in width and height the display is to be divided when it
is printed.

If necessary, the System does not take into account one of the two page specifications so that
the individual displays can be reproduced as largely as possible but without distortion.

Displaying the pages as individual pages
Using the indicator Individual pages, you can display each page as an individual graphic with
titles. A prerequisite for this is that the output of the display is divided between more than one
page.

Setting cutting marks:
You can give the pages that are to be printed cutting marks using the Cutting marks indicator.
This is also possible when you only want to print an individual page.

This function is only available when you activate the Enlarge/reduce option.

Adjusting the time scale
You can reduce the time axis with the Adjust time scale indicator so that it fits on one page.

Defining the margins:
Using the fields Top, Bottom, Left and Right, you can define the space between the paper edge
and the display.

You cannot go below the minimum margins that result during printing because of
technical reasons.
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With printers that have predefined minimum margins, the values you enter for the
margins are added to the minimum values. The result of this is that the actual
margins are wider than those that you have defined.
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Printing Additional Information (Print Box)
Use
When printing a project from the project planning board, you can also print additional information
(properties, personal information).   This information appears on the print-out underneath the
selected project view (Gantt chart, overview etc.) in a print box.

The print box consists of a maximum of five display fields that you can choose yourself.

The following information is available in the print box:

•  Project description

•  Project identification

•  Printed on (date)

•  Printed at (time)

•  Printed by (person)

This data is automatically read by the system and entered in the print box.

You can also replace up to three of the five fields with text fields, in which you can manually enter
information (comments and other information).  This data is only used for the current print-out
and cannot be saved.

Procedure
1. Choose Project → Print  → Fill print box. The Print box: Define screen appears with your

personal field selection. If you have not yet selected any fields, the list is empty.

2. If you want to enter fields or to change the selection, choose . The Select fields screen
appears. Here you can select up to five fields for your print box.

The Info text line 1 to 3 fields are empty lines for the manual entry of project-specific
information.

3. Choose .  The system returns to the Print box: Define screen and displays all the selected
fields.

4. To save your settings, choose again.

After you have left the project planning board, the field selection remains until you
change it.   Entries in the info text lines 1 to 3 are not saved.
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Confirmations
Prerequisites
You are in a project in the project planning board or the Project Builder.

You can only confirm activities and activity elements, if

•  They have been released

•  The confirmation indicator has been set in the control key

•  They have been saved on the database

You must have defined certain confirmation parameters in Customizing for the Project System
previously.

For more information, see Confirmation Directly in the Project System [Ext.].

Procedure
2. Select the activity to be confirmed.

Choose in the Pushbutton/Menu Path

Project Builder Edit -> Activity -> Confirm

Project planning board

The Create Network Confirmation: Actual Data screen appears.

4. Enter the necessary confirmation data.

5. Choose .

Before you leave the confirmation, you can go to a separate dialog box to enter
goods movements.

Result
According to your settings in Customizing, the system executes the confirmation immediately or
later in a background job.
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Working in the Overviews
Use
The component overview, the capacity overview, the costs and revenues overview, and the
maintenance orders overview graphically present additional information about the project
elements in the Gantt chart.

Features
You can display the overviews for WBS elements or activities in addition to the Gantt chart. You
can so obtain an overview on the planned material components, capacities, as well as costs and
revenues.

Activities
To show an overview, select a WBS element or activity and choose Details → and then the name
of the required overview (for example, Component overview).

Overview Ico
n

What You Should Know

Component
overview

In the component overview you can use the context menu (e.g.
right-hand mouse button) to execute all editing functions for
component allocations.

Capacity overview This overview displays the capacity load from four weeks before to
four weeks after the period for the capacity is required for the
selected WBS element or activity.

Costs and
revenues overview

In the costs and revenues overview up to three values can be
evaluated. If, for instance, five cost fields are displayed in tabular
area, only the first three are displayed graphically.

It is important that the three fields have the same number format.
The format of the first field determines the format for the evaluation.
If the format of the other fields does not agree with this format, no
evaluation takes place.

Fields that are not displayed in the tabular area are not evaluated in
the graphic area.

Maintenance order
overview

This overview displays the dates of service and maintenance
orders based on the scheduled dates.

In each overview, you can execute functions by using the context menu (right-hand mouse
button). For instance, you can select all object in an overview, display the legend, display an
additional detail list, or close the overview.

See also:
Displaying Detail Lists for Overviews [Page 312]
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Material Management in the Project Planning Board
Use
You use the functions described here to manage your project material components directly in the
project planning board.

Features
Gantt Chart
In the Gantt chart you can carry out the following functions. These functions refer to a selected
WBS element or network activity. It is not possible to select individual components in the Gantt
chart. To do this, call up the component overview.

Function Menu Path Comments

Create component
assignments

Edit → Create... See Creating Project Objects
[Page 264]

Check material availability for
the network

Edit → Functions → Material
availability (network)

Carries out a material
availability check for all the
components in the network
assigned to the selected WBS
element.

See also: Material Availability
Check [Ext.].

Activate purchase
requisition/reservation

Edit → Functions → Activate
Purc Req/Res.

Irrespective of the settings in
the component detail screen,
you can use this function to
manually create purchase
requisitions or reservations for
a WBS element.

See also: Activating
Requirements [Ext.].

Component Overview
Several more functions, for individual components, are available from the component overview.
Apart from detail screen, which can also be called up by double-clicking on the component, all
functions are called up from the context menu.

Function/Menu Entry Comment

Available quantity The system displays the component availability as a bar chart in the
component overview.

Availability check An availability check is carried out for the selected component.

For more information, see Material Availability Check [Ext.].

Detail screen Opens the component detail screen for the selected component.

For more information, see The Component Detail Screen [Ext.].
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GR/GI list A further window opens with  procurement details, such as document
(purchase requistions or reservations etc) details and details of goods
movements etc.

Explode BOM If the selected component has a bill of material, this is exploded, either
level-by level or the whole structure (multi-level).

For more information, see Exploding the Bill of Material [Ext.].

Dates overview If you have maintained the requisite settings in Customizing for
Monitoring Dates [Ext.], the systems displays the dates overview.

Reassign You use this function to reassign a component from one activity to
another in the same network.

Create document You can create a document (document info record and if necessary
original application file) that is assigned to the component

Be sure to a document type that can be assigned to a material
component.

For more information, see Document [Ext.].

Document overview Provides an overview of documents assigned to the component.

Delete Deletes the component assignment, if this is allowed, that is if there
are no open procurement documents such as purchase requisitions or
reservations for the component.



Structures  SAP AG

Displaying Detail Lists for Overviews

312 April 2001

Displaying Detail Lists for Overviews
Use
For every overview in the project planning board you can display a list of details in a separate
dialog box. In the details list the data for the relevant overview is displayed divided up in periods.

Procedure

Display Detail List Procedure What You Should Know

Goods movement overview for
component overview

1. Select a component in the
component overview.

2. In the context menu
choose GR/GI list.

The overview displays all the
goods issue and receipts for
the selected components.

Capacity load overview for the
capacity overview

1. Select a work center.
2. In the context menu

choose Capacity load list.

The capacity load overview
(list) displays the capacity
requirements of all
requirement sources

Period drilldown 1. Select a WBS element or
WBS element in the costs
overview

2. In the context menu
choose Period drilldown.

The list shows a period
drilldown for the selected WBS
element or activity.
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Settings for the Project Planning Board
Use
You can change the graphic presentation of the project planning board to suit your requirements.
There are following types of changes:

•  You can change some settings temporarily, for the current session.

•  You can save some changes user-specifically, the changes are saved for you till you change
them again.

•  Providing you have the necessary authorizations, you can generate a new project planning
board profile in Customizing. Here you can change all of the settings that are listed below.

You can see whether temporary or user-specific changes are possible for individual functions in
the following table.

Features
The functions with which you can change settings are  in the Settings menu.

Setting Options Icon/Menu Path Type of Change Default values from
Customizing for the
Project System

Graphical
Presentation [Page
317]

Choose  or Settings
→ Planning board
assistant

user-specifically Project planning board
profile

Graphical
Presentation of the
Time Scales [Page
320]

Choose  or Settings
→ Time axis assistant

user-specifically Profile for time scales

Scale for time axis

Layout Detail Screens
[Page 330]

Settings → Layout
detail screens → For
WBS element or For
activity

user-specifically Layout for WBS
element detail screens
Layout for activity
detail screens

Evaluation and
Planning Periods
[Page 320]

Settings → Time
settings → Planning
board → Planning
period

temporary (current
session)

Time profile

Workforce Planning Settings → Options →
Application and then
the Workforce
planning tab page

temporary (current
session)

Profile for workforce
planning
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Field Selection for the
Gantt chart and the
Overviews [Page 315]

Double-click on the
column (field) in the
table area

or

Settings → Field
selection (only for field
selection in the Gantt
chart)

or

Settings → Options (
enter another field
selection profile on
the Table area tab
page)

user-specifically Project planning board
profile

Settings in the project
planning board
profiles [Ext.]

Settings → Options →
Planning board and
then the Templates
tab page

user-specifically Project planning board
profile

Default values for
networks

Settings → Options →
Application and then
the Workforce
planning tab page

temporary (current
session)

Project planning board
profile

Scheduling settings Settings → Options →
Scheduling

user-specifically Scheduling Types

Parameters for WBS
scheduling

Activities
When you save a project, the user-specific settings are saved.  Temporary settings are not
saved.
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Table Area
Use
You can change various settings in the table area of the Gantt chart and the overviews.

Features
The settings that you can change in the table area are listed below:

Function Action What You Should Know

Select fields or columns in the
Gantt chart or the overviews

Double-click on the column
titles or for the Gantt chart
choose Settings → Field
selection

The graphical evaluation is
dependent on the displayed
fields and their values.

You can select up
to sixteen fields
for the table area.

The settings are saved with
the project in the project
planning board profile.

Move columns Move column with drag and
drop or choose Settings →
Field selection

The settings are saved with
the project in the project
planning board profile.

Change column width Click on the line between
fields and, keeping the mouse
button pressed, move the line
or choose Settings → Field
selection

The settings are saved with
the project in the project
planning board profile.

Change title of Gantt chart and
overviews

Double-click on title In the standard system the title
of the Gantt chart is the
project definition. For the
overviews the system uses the
name of the overview as the
default, e.g. Component
overview.

These settings are not saved.

Change column title Double-click on title of Gantt
chart or overview

The column titles have the
field labels as defaults.

The changes you make are
not saved.
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Change the contents of fields
in the table area

Choose Settings → Edit →
Change table

Switches on change mode for
date fields (except actual
dates) and the Description and
Identification fields. You then
overwrite the contents of these
fields directly in the table area.

You cannot
change the
description of
activities that have
the network
number displayed.
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Graphical Presentation
Use
You can change the graphical presentation of the project planning board as required with the
planning board assistant.

You can save the settings individually for each user, independently of the graphic
profile. Your changes are not saved in the graphic profile.

Features
You change the following settings in the table area of the Gantt chart and the overviews.

What can you change? Which settings can you
change?

Gantt Chart

Component overview

Capacity overview

Costs/revenues overview

•  Title of the Gantt chart or
overview

•  Field or column heading

•  Table lines (object
dependent)

The pattern and the color for the
foreground, background and the
text, 3D effect, logo

The font, the font style and the
font size

You change the following settings in the graphic area of the Gantt chart and the overviews.

What can you change? Which settings can you change?

Gantt Chart •  Symbols for dates

•  Texts on the dates

•  Relationships

•  Size and color/pattern of the symbols
for the dates (e.g. date bars)

See also:
Changing settings for date symbols
[Page 319]

•  Font, effects and font size of the
texts for the dates

•  Background color

•  Color of the relationships

•  Logo (pre-set or company logo)

For more information on how to include
you own company logo, see note no.
39258.

Capacity overview Vertical and horizontal bars Color and size
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Component overview Symbols for

•  Goods receipt dates

•  Goods issue dates

•  Requirement dates

•  Delivery dates

Color

Cost overview Cost curves Color

Activities
The Gantt chart and the overviews are displayed on the left-hand side of planning board
assistant as nodes in a tree. When you expand on of these nodes the sections and objects in the
Gantt chart or the overviews are displayed. You can then edit these sections. Depending on
which sub-node you select, objects are displayed on tab pages on the right-hand side of the
planning board assistant and can be edited here.

If you change settings, for instance color or font, you can see the effect of your changes in a
small preview window immediately. You can also see the effects of your changes in the planning
board itself without leaving the planning board assistant by choosing .

If you want to work with your own settings for the project planning board, choose Save user
settings. These settings are then saved under your user and are used each time you call up the
project planning board.

If you want to work with the standard settings from Customizing, choose . If you then want to
work with these standard settings in future, choose Save user settings.
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Changing settings for date symbols
Use
You can change the color, size and position of the date symbols in the graphic area of the Gantt
chart using the planning board assistant.

You can change the symbols themselves in Customizing for Basis.

Features
Dates are displayed in the Gantt chart as bars or the start and finish dates are represented by
individual symbols. The system gives dates that belong together the same color. For instance,

•  Start and finish dates

•  Actual dates (WBS)

•  The dates that belong together in the earliest and latest set of dates

•  Actual dates (activity)

For example, if you change the color of the forecast start dates the system also changes the
color of the finish date and the date bar.

The color, pattern, and values such as Edge type and Edge width, are used for the
dates that belong together. Vertical offset and Element height are an exception to
this. Here you can change the values for each date.

You can use a pattern and consequently a background color for most date symbols.

The date symbols for the start, finish, and actual dates are simple circles, whose line
color (edge color) you can change. This means that the background and foreground
color as well as the pattern have no effect.

Activities
Define the colors for the dates in planning board assistant.
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Time Display
Use
You can change various settings for time in the project planning board.

Activities
Function Menu Path What You Should Know

Change the time interval for
the graphic area

Settings →  →  →  →   Options →→→→
Planning board and then
Increment on the Settings tab
page

If you change the time interval,
for example from day to hour,
the accuracy of your planning
will also change. For instance
if you create date bars for
activities in the graphic area,
these are accurate to an hour.

Changing the planning and
evaluation time period

Settings →  →  →  →   Options →→→→
Planing board and then the
Planning period tab page

You can change the start and
finish dates planning and
evaluation periods. The
planning period cannot be
longer than the evaluation
period.

For more information on the
planning and evaluation
periods, see Layout of the
Project Planning Board [Page
253]

Change the date line Settings →  →  →  →   Options →
Planning board → Settings tab
page → Date line

You can choose another date
instead of the current date for
the date line in the graphic
area.

Change set of dates and the
times of activities

Settings →  →  →  →   Options →
Planning board → Settings tab
page →Set of Dates

You can specify which set of
dates, for instance  basic or
actual dates, and whether
these are the earliest or latest
dates.

Graphic representation and
scale of the time axis (only in
bar chart)

Settings →  Time axis
assistant

You can use the time axis
assistant to edit the time axes
of the planning and evaluation
periods.

The changes that you make here are only valid for the current session. An exception
is the time axis assistant, where you can save the user-specific settings.



 SAP AG Structures

Structure planning

April 2001 321

Structure planning
If you want to create or process a project, you can use structure planning in addition to the work
breakdown structure and the network. In structure planning, you can create WBS elements and
activities together and maintain the data for them. You can use structure planning particularly
when you have a more precise idea of the structure of the project - for example which WBS
elements are detailed by activities.

This chapter demonstrates the scope of planning according to structure in the Project System.
You will find further details for the individual functions in the respective chapters.



Structures  SAP AG

Configuration

322 April 2001

Configuration
You enter the defaults for structure planning in the project profile. You can change the settings in
structure planning for further processing.

On the Dates tab pages in Settings →→→→ Options ...
You specify:

•  The scheduling scenario: There are three different scenarios.  Top-down and Bottom-up
are predefined scenarios, whose parameters are determined by the system. These
parameters cannot be changed.  You do not have to edit or check the scheduling
parameters.  On the other hand you have to maintain all the scheduling yourself in the Free
Scheduling scenario. For more information, refer to the Scheduling section under Settings:
Options [Ext.]

•  The Scheduling method for WBS structure: You must specify planning methods for
planning using both basic and forecast dates. This only refers to the work breakdown
structure and not to the activities. Changes apply only for the current session and are not
saved in the project profile.

•  Scheduling parameters for activities: You can change settings for the activities here, for
example, the scheduling type. The activity parameters are taken from the network profile.
Changes apply only for the current session and are not saved in the project profile.

•  Network default value: Here you can change the settings for networks , for instance the
network type. The parameters are originally taken from the network profile. Changes apply
only for the current session and are not saved in the project profile.

•  Assign new activities to: If you create an activity for a WBS element, the system creates a
network in the background. In the control data, you specify how the activities that you create
for the WBS elements are assigned to the network. Activities are assigned either to:

– All networks assigned to the project. When you create an activity a list of networks in
the project appears, from which you select one.

– The network for the WBS element. The system creates a new network for each new
activity entered for a WBS element.

– In general to a new network. The system creates a new network for each new activity
entered for a WBS element.

In Settings →→→→ Capacity leveling and Leveling of ind. cap....

You maintain

•  Profiles and parameters for calling up the planning table in both tabular and graphic form as
well as for creating capacity reports.

•  Dates for the evaluation period.

These menu paths are only available if capacity requirements exists for the selected WBS
element.
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In Settings →→→→ View ...
You specify how the WBS elements are to be displayed, for example by number or description.
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Views and Allocations
The structure overview displays the WBS elements, activities, and activity elements for your
project. By selecting the menu options Settings →  View, you can specify how the objects are
displayed:

•  Including objects flagged for deletion

•  Superior objects when accessing via a subproject

Indicator in the Structure Overview
The structure overview contains several indicators in addition to the objects.

For the WBS Elements

•  The field L indicates the hierarchy level of the element.

•  Field S indicates whether the object is subdivided further.

•  Field Ac indicates whether activities exist for a WBS element.

For the Activities

•  Field IN indicates activities carried out internally (in-house)

•  Field EX indicates activities carried out externally

•  Field SE indicates external services management

•  Field GCS indicates general costs activities

The indicator AI indicates the allocations and characteristics for the WBS elements or activities.
You can call up a specific allocation type or characteristic.

Select Extras → Display allocation to select the elements. The objects with a corresponding
allocation are marked. The following allocation types can be displayed.

•  PS texts

•  Material components

•  Subnetworks

Choose Extras →  Display char., to select the characteristics.

•  Whether WBS elements are scheduled

•  Whether the following business data exists for activities:

– No capacity

– No PReq / RES.

– No costing
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You want to see whether material was allocated to an activity. By selecting the menu
options Extras → Display allocation, you branch into a selection screen showing the
possible allocations. Select Material  and choose Continue. On the structure
overview, the indicator AI is now selected for the activities to which material is
allocated.
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Creating Projects Using Structure Planning
To create a project using structure planning, proceed as follows:

1. From the Planning area menu, choose Project →→→→ Structure planning → Create proejct.

The Create project dialog box appears.

2. Maintain the data in the dialog box.

You can use an existing project or a standard project as a template.

3. Choose CONTINUE.

The screen Change: Structure Planning appears.

4. Maintain the data for your project.

– You maintain WBS elements using the WBS basic data tab page, which takes you to
the WBS element overview.

– You maintain activities and activity elements using the Activity data tab page; this
takes you to the activity overview.

5. Confirm your entries.

The WBS elements, activities, and activity elements are created.

You cannot create subnetworks in the WBS, though you can have the system
indicate whether an activity has subnetworks.

See also:
Work Breakdown Structure (WBS) [Page 15]

Network [Page 78]
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Capacity Leveling
In structure planning, choose Goto → Capacity planning to access evaluations for the capacity
loads and for the individual capacities in the tabular and graphical planning board.

The following evaluations are available:

Capacity Leveling
Choose Goto → Capacity planning → Capacity leveling to see

•  WBS element load

The load which is only caused by the WBS element. Capacity requirements from other
orders, networks, or WBS elements are not displayed.

•  Total load

The load of the WBS element, including capacity requirements from other orders,
networks, and WBS elements.

Leveling Individual Capacities
Choose Goto → Capacity planning → Leveling of individual capacities to see:

•  WBS element load

The load which is only caused by the WBS element. Capacity requirements from other
orders, networks, or WBS elements are not displayed.

•  Total load

The load of the WBS element, including capacity requirements from other orders,
networks, and WBS elements.

Capacity Reports
Choose Goto → Capacity planning → Capacity leveling to access the following capacity
evaluations:

•  Per work center and capacity category

The list shows the available capacity, the capacity requirements, and the utilization of all
capacities for the selected WBS elements.

•  Per WBS element

The list shows the available capacity, the capacity requirements, and the utilization of all
capacities for each WBS element.

•  Cumulated for all WBS elements

The list shows the available capacity, the capacity requirements and the utilization of all
capacities cumulated over all selected WBS elements.



Structures  SAP AG

Capacity Leveling

328 April 2001



 SAP AG Structures

Data for Earned Value Analysis

April 2001 329

Data for Earned Value Analysis
Choose Goto → Earned Value Analysis to maintain the following data for the earned value
analysis:

•  Parameters

•  Planned percentage of completion

•  Actual percentage of completion

See also:
For more information on earned value analysis, refer to Earned Value Analysis [Ext.]



Structures  SAP AG

Layout of Detail Screens

330 April 2001

Layout of Detail Screens
Use
You can use this function to edit the layouts of the following detail screens:

•  WBS elements

•  Network activities

You edit the layout of the WBS element detail screens in WBS maintenance and the layout of the
network activity detail screens in network maintenance. You can edit the layout of both WBS
elements and activities in structure planning and in the project planning board.

Features
In the standard system each detail screen is on a separate tab page. For your own view you can
rearrange the detail screens on the tab pages as you like. You can place several detail screens
on one tab page and only show the tab pages that you require. The finished set of tab pages is
saved for each user and client as a layout.

You must assign every layout that you create to a project profile or network profile. You can edit
both the current layout and other layouts, which you are not using at the moment.

You can also combine detail screens for all users in Project System Customizing.

Activities
The available tab pages are numbered from left to right, starting with “TAB01” through to
“TABnn”. You can assign up to five detail screens to a tab page.

The contents of the detail screens delivered by SAP are defined in the system and
cannot be changed. However you can develop your own detail screens and include
them in Project System Customizing for later use.

You can make the following settings:

•  Enter your own title for tab pages and put an icon on these pages.

•  Hide tab pages that you do not need

•  Determine which detail screens appear on which tab page and where

•  Change the layout according to the transaction (create, change, display)

If you do not want to redefine all the tab pages, copy the SAP standard layout or the Customizing
settings and change these settings to suit your needs.
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Editing the Layout of Detail Screens
Prerequisite
The procedure described below is valid for network and work breakdown structure maintenance
as well as for structure planning and the project planning board.

Procedure
1. Choose:

− In work breakdown structure maintenance: Extras → Settings → Layout detail screens

− In network maintenance: Edit →Settings →Layout detail screens

− In structure planning or the project planning board:

Settings → Layout detail screens → For WBS element or For activity

If no user settings exist or there is only one setting for the current project or network
profile, the Change Detail Screens:Details screen appears. In this case, continue with
step 3. The settings that you make here are assigned to the current project or network
profile.

In structure planning or in the project planning board there can be several networks
in a project and therefore several network profiles. If there are no user settings for
the layout of the activity detail screens and you want to create a layout, the profile of
the first network activity is the current network profile.

If there are already user settings, the screen Change Layout Detail Screens: Overview
appears.

2. Choose one of the following functions.

Function Procedure
Create layout 1. Choose Edit → Create.

2. Specify the project profile or the network profile whose layout
you want to define. Enter the activity type too.

Change layout 3. Select an entry in the list

4. Choose Edit → Display details

The screen Change Detail Screen: Details appears . All the available tab pages are
displayed.

If you are creating a new layout, these tab pages are empty at first. You can redefine
them completely or enter values on the pages in one of the ways described below and
then change these entries.

− By choosing Edit → Copy standard, you copy the standard SAP settings.
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− By choosing Edit → Copy Customizing, you copy the Customizing settings for the same
profile to the tab pages.

3. Edit the tab pages as follows:

a. Enter a new title or change the existing title of a tab page. If required, also choose an
icon to appear on the tab.

b. Set the Active tab page indicator on the tab page. If you want the tab page to appear on
top as the first tab page, also set the First tab page indicator.

c. You can select the detail screens that you want to include on the current tab page one-by
one in the right-hand list and copy them to the left. You proceed in this manner with
further detail screens.

4. Save your data.

In networks some activity detail screens are required by the application. If you have
not included then on the tab pages in your layout, they will be automatically included
by the system on a separate tab page, called Necessary fields.
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Mass change
Use
If you work with complex long-running projects, for instance in make-to-order manufacturing, it is
often necessary to make large scale changes to master data or assignments. You can use mass
changes the change projects and networks in a just a few steps.

Prerequisites
Please note that the mass changes function is a very powerful tool, with which you can change
projects and networks drastically. These changes cannot be undone. Therefore you must have
the requisite knowledge, if you want to use mass changes.

The system only makes  changes to projects and networks , if the corresponding prerequisites
are met and the business transaction is allowed. For instance the system can only set the
Completed status , if the network or work breakdown structure has the status Released or
Technically completed.

You have to have the authorizations necessary for changing the objects in question.

Features
You can make the following changes with mass changes.

•  Change field values in the objects network header, activity, project definition, WBS element
and relationship, for example:

− Plant

− Business area

− Profit-center, etc.

•  Change profile assignments, for instance:

− Interest calculation profile

− Budget profile

− Project profile etc.

•  Schedule and cost networks

•  Change the system statuses Released and Deletion flag.

You cannot process the following objects with mass changes:

•  Components

•  Production resources/tools (PRT)

•  PS texts

•  Long texts
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Activities
You can call up mass changes

•  Directly in the Mass change transaction in the Project System

•  In the Project Information System from the structure overview or the corresponding individual
overviews

In both cases you can either execute it online or schedule it as a background job.

You can select data for mass change in different ways:

•  You can execute mass changes without an optical check [Page 336].

In this case you select the fields to change, before the system selects the projects
and/or networks. The system displays all the objects that can be processed with mass
changes, irrespective of the actual structure of the project or network. For instance the
object Relationships is displayed even if there are no relationships in the network in
question.

The system selects projects and networks, when you execute the mass changes.

•  You can check the changes intended first in a Table view [Page 339] first and then execute
the mass changes.

The system first selects the projects and/or networks. To select the fields, you can go to
a table view and change fields there. In the table view you can see an overview of all the
objects that can be changed in the selected projects and networks.

As long as you are in the table view, you can cancel the intended changes. You can also
compare the old and new values. You can thus check individual changes, before
executing them. You can also make individual changes, for instance by changing the
MRP planner in just some of the selected networks.

The system executes the changes network by network and project definition by
project definition. This means that the mass change treats each network and each
project definition as a separate unit, independently of their assignments. If, for
instance, the system cannot change field values in a network, the system does not
make any changes to this network. However, if you have selected several networks
or project definitions and no further error occur, the system makes the changes in
these networks/projects.

You have selected projects, which have assignments to networks. In WBS elements
you can generally change the business area and in the network activities the work
centers. The system discovers during the check that one of the work centers, you
have entered, does not exist. Consequently the system does not make any changes
to the network activities. On the other hand, the system changes the business area
in the WBS elements, as no errors were found.
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If you want to make mass changes for a single project, it is quickest and easiest to do this in the
project planning board or structure planning [Page 342]. When you save the project, the system
saves the changes.
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Executing Mass Changes Directly
Prerequisites
You want to execute mass changes without an optical check.

If you do want to check the intended changes, proceed as described in Executing Mass Changes
with Table View [Page 339].

Procedure
Executing Mass Changes

1. From the Operative Structures menu choose Tools  → Mass change → Execute.

The first time you call up the function, the Enter Profile dialog box appears. The next time
you work with mass changes, this profile will be used automatically. For more information
on the database profile, see Profiles in the Information System [Ext.].

2. Enter a data base profile and choose Continue.

3. On the selection screen enter selection criteria for the projects and/or networks that you want
to change.

4. Choose Enter field values for mass changes.

The Mass changes: Field view screen appears.

5. Select the tab page of the object that you want to change, for example the tab page for WBS
elements.

The field selection screen appears.

If the field selection does not appear automatically, choose Select fields.

6. Select the field that you want to change and choose Continue.

You return to the tab page.

7. Enter the new value in the selected field.

You can choose whether the system replaces all values of the field with the new value or
only replaces certain values [Ext.] with the new value.

If you leave the field blank, the system deletes the contents of the field when the
mass change is executed. You can use this feature, for instance, to delete
assignments to other objects.

8. To select further fields, proceed as in steps 6 and 7.

9. For the objects, repeat steps 5 to 8.

10. At this stage there are the following options:
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Option Procedure

Execute the mass changes in test mode (the
system does not save the changes)

Choose Test changes.

A log appears.  When you leave the
log the Mass changes dialog box
appears again.

Executing mass changes directly Choose Execute or Execute in background.

Copy settings for mass changes and save as a
selection variant

1. Choose Copy.

You return to the selection screen.

2. Save the selection variant by choosing
Goto → Variants → Save as variant.

For more information on selection variants, see
Working with Variants [Ext.]

Executing Mass Changes in the Project Information System
You can execute mass changes in either the structure overview and or in one of the individual
overviews. The following is the procedure for the structure overview:

1. From the Project Information System screen choose  Structure/dates → Structure overview.

2. On the selection screen enter selection criteria for the projects and/or networks that you want
to change.

3. Choose Extras/environment → Mass change

The Mass changes: Field view screen appears.

4. Select the tab page of the object that you want to change, for example the tab page for WBS
elements.

The field selection screen appears.

If the field selection does not appear automatically, choose Select fields.

5. Select the field that you want to change and choose Continue.

You return to the tab page.

6. Enter the new value in the selected field.

You can choose whether the system replaces all values of the field with the new value or
only replace certain values [Ext.] with the new value.

If you leave the field blank, the system deletes the contents of the field when the
mass change is executed. You can use this feature to delete assignments, for
instance

7. To select further fields, proceed as in steps 5 and 6.

8. For the objects, repeat steps 4 to 7.
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9. To execute mass changes in test mode, choose Test changes.

A log appears. When you leave the log the Mass changes dialog box appears again.

10. Choose Execute.

The mass changes are executed.

Result
When the system has finished the mass changes, a log appears. If the system could execute the
changes, you can see information in the log about every object that was changed . You can
display the log with one line for each entry, which is a simple confirmation, or with two lines with
more details for each entry.

If the system could not execute some changes, because fields did not meet the prerequisites, the
entries are highlighted in red.

You can save the log when you exit. You can then call it up again later. To do so, choose

•  From the Operative Structures screen Tools → Mass Change → Log

•  From the Project Information System: Structure Initial screen Extras/environment → Logs →
Mass change
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Executing Mass Changes with Table View
Prerequisites

•  In the Mass change function itself:

You are in the selection screen for mass changes.

You have maintained the selection criteria for the required projects and/or networks, but
have not yet selected any fields. There is no green checkmark in the Enter field values
for mass changes field.

•  In the Project Information System

You are in either the structure overview or an individual overview. For more information,
see Working with Overviews [Ext.].

You have selected the objects you want to change.

Procedure
1. Choose:

− From the Mass Changes in the Project System screen Program → Execute

− From the Project Information System: Structure Initial screen Extras/environment
→ Mass change

The Mass changes: Field view screen appears.

2. Here you can select fields whose values are to be changed. You can also go directly to the
table view and select the fields there.

For the field selection, proceed as described in Executing Mass Changes Directly [Page
336].

3. Choose Table view.

In the table view the system displays all objects for the selected projects and networks. If
you have entered new values in the field overview, the system displays these values in
the table view. The tab strips of the objects that have been changed have a green
checkmark.

You can execute the following functions in the table view:

Function Procedure What You Should
Know

Change individual field
values (you can cancel these
changes)

1. Position the cursor on the
relevant field in the table.

2. Overwrite the value.
Display original and new
values in the table

Choose View → Show old values.
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Only replace a particular
value by the new value

1. Choose Edit → With
restrictions

 In the table header the line
Only replace is available
for entry.

2. Enter the value that you
want to replace.

If you leave the
Only replace field
blank, the system
only replaces the
value if there was
no entry in the
field.

Add or remove fields from the
table header

Choose View  → Select fields.

Copy field values from the
table header to the table (you
can cancel these changes)

1. In the table, select the
rows of the objects that
you want to change.

2. In the table header, select
the column headers of the
fields you want to copy.

3. Choose Edit → Execute
changes

The system
executes the
changes only on
the active tab
page. Repeat this
procedure on the
other tab pages.

Cancel changes 1. In the table, select the rows of
the objects whose changes you
want to cancel.

2. In the table header, select the
columns of the fields in which
the old value is to be entered.

3. Choose Edit → Undo changes

The system
cancels the
changes only on
the active tab
page.

Execute mass changes in
test mode

1. Select the rows of the objects,
whose changes you want to
test.

2. Choose Edit → Test changes   

All the changes
are executed that
were made in the
table, i.e. either
with Edit →
Execute changes
or by overwriting
values in the
table.
The changes are
made for all tab
pages.

4. Before you can save the changes, it is necessary to copy the new field values from the table
header to the table by choosing Edit → Execute changes. Make sure you select correctly
(see above in the function overview) Do this for all tab pages that are marked with a green
tick.

The new field values are copied to the table. You can still cancel the changes.

5. Select the rows of the objects that you want to irrevocably change on all tab pages.

6. Choose Mass change → Save or Save in the background.
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The mass changes are executed and the projects are saved with the new values.

Result
When the system has finished the mass changes (or test run) the log is displayed. If the system
could execute the changes, you can see information in the log about every object that was
changed. You can display the log with one line for each entry, which is a simple confirmation, or
with two lines with more details for each entry.

If the system could not execute some changes, because fields did not meet the prerequisites, the
entries are highlighted in red.

You can save the log when you exit. You can then call it up again later. To do so, choose

•  From the Operative Structures screen Tools → Mass Change → Log

•  From the Project Information System: Structure Initial screen Extras/environment → Logs
→ Mass change
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Executing Mass Changes
Prerequisites
You are in a project in the project planning board or the Project Builder.

Procedure
7. Select all the objects that you want to change.

Choose in the Pushbutton/Menu Path

Project Builder

Project planning board Goto → Mass change

The Mass changes: Field view screen appears.

8. Select the fields whose values you want to change. Proceed as described in Executing Mass
Changes Directly [Page 336].

You can go from the field view to the table view by choosing table view. For more
information on the table view, see Executing Mass Changes with Table View [Page
339].

9. Choose Execute.

Result
The system checks the changes and executes them. A log appears. If the system could execute
the changes, you can see information in the log about every object that was changed. You can
display the log with one line for each entry, which is a simple confirmation, or with two lines with
more details for each entry.

If the system could not execute some changes, because fields did not meet the prerequisites, the
entries are highlighted in red.

You cannot save this log.

The system saves the changes when you save the project.
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Status Management
Use
The current status of a project or an object in a project determines which business transactions
can be executed. Statuses document the current processing stage of an object. Status
management in R/3 differentiates between system statuses and user statuses.

See also:
Business Transactions [Page 344]

Features
A project is not a static object. It has it own life cycle that begins when it is created and continues
till completion. During this period various business transactions change the project. For instance
you plan tasks, post costs and perform settlements.

Each project passes through various system statuses. One of which is always set. For example,

•  Created

 In this status you cannot, for instance, make actual postings.

•  Released

In this status virtually all business transactions are permitted.

If you want to decide when certain business transactions are permissible, define user statuses.
These enhance existing system statuses.

SAP does not provide an authorization check for setting system statuses.

See also:
User status [Page 357]
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Business Transactions
Use
A business transaction is an action that you perform in the system, when you execute a
transaction or function. Examples of business transactions include:

•  Posting a G/L account

•  Starting cost-center assessment

•  Releasing a network

•  Posting a goods receipt

•  Making a confirmation

Prerequisite
You can perform a business transaction, if

•  At least one user status or system status permits the transaction

•  No user status or system status prohibits the transaction

Activities
A user status or system status can:

•  Allow a business transaction

•  Allow the transaction, but generate a warning

•  Prohibit the transaction

In the second case, you see a warning message while you are carrying out the business
transaction. The decision as to whether to proceed with the transaction, despite the warning, is
left to you.
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Status Overview in Transactions
Use
Use the status overview to inform yourself about the currently active user and system statuses in
a work breakdown structure or network. You can display the status of project definitions, WBS
elements, network headers and activities.

Features
You can see the important statuses directly in the header of project definitions or networks as
well as in the WBS element overview and activity overview.

You can also display a screen with details of user and system statuses for project definitions,
WBS elements, network headers and activities. Here you can see which statuses are active
together with their full name. There is also an overview of the business transactions that these
statuses allow or prohibit. As long as a user status has not been set, you can also assign another
status profile to the object and thus use other user statuses. In this case the assignment does not
depend on the project profile or network profile used.

You can only change the status profile, if no user status has been set.

The system displays statuses as a:

•  30 character text

•  As a four character abbreviation

 Both display formats are language dependent.

 See also:
 User status [Page 357]

 Activities
 You can obtain an overview of the important active user and system statuses:

•  On the Basic data tab page in the project definition

•  On the Scheduling tab page in the network header

•  In the activity overview on the Total tab page, for instance (only system status)

•  On the Total tab page, for instance, in the WBS element overview

You can call up the detail screen for user and system statuses as follows:

To call up the detail screen

In the project definition

In the network header

Choose Edit → Status → System/user status
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In the WBS element overview, select a WBS
element and

In the activity overview, select an activity and
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System Statuses in Work Breakdown Structures
The active system status determines which business transactions you can perform with work
breakdown structures and WBS elements. System statuses are passed from the project definition
to the WBS elements and from the WBS elements to the subordinate WBS elements. The
system statuses Locked and Final billing are exceptions to this.

You can cancel certain statuses, for instance Technically completed, Closed and Deletion Flag.
When you do so, the previous status is set. You cancel system statuses on by one, until you
arrive at a status that cannot be canceled. You cannot cancel system statuses that are set
automatically (in the background by the system), for example Partially released.

If you cancel the statuses Technically completed or Closed, the system automatically cancels this
status in the superior WBS element. However, the system does not cancel the status in
subordinate WBS elements.

The Deletion Flag status is not set automatically in superior WBS elements.

Created (CRTD)

Use
This is the initial system status for new WBS elements. In this status you structure the project
and plan dates, costs and revenues. The system sets this status automatically, when you create
a new WBS element.

Prerequisites
The project and, if applicable, the superior WBS element must have Created status.

Features
In Created status, you can create new WBS elements and change the work breakdown structure.

The status

•  Allows you to assign networks, which do not yet have Released status

•  Allows you to plan costs and revenues

•  Allows budgeting

Released (REL)

Use
In this status you can assign costs and revenues to WBS elements.

Prerequisites
The Created status is set.
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Features
In Released status you can create new WBS elements and change the project hierarchy. The
status is passed on to subordinate WBS elements.

The status allows

•  You from assigning networks, production orders or CO orders to the WBS element.

•  You to post actual costs

•  You to transfer actual costs

You cannot change the status from Released to Created, as actual values from, for instance,
purchase orders or confirmations may have been posted

Technically completed (TECO)

Use
You use this status for WBS elements that are completed from a technical point of view, but
where you still expect costs to accrue.

Prerequisites
The Created or Released status must have been set. The completion indicator must be set for
transfer price agreements.

Features
In status Technically completed, you can create new subordinate WBS elements (with a
warning). The status is passed on to subordinate WBS elements.

The status allows

•  You from assigning networks, production orders or CO orders to the WBS element.

•  You to post actual costs

•  You to transfer actual costs

You can cancel the Technically completed status. In this case the system sets the Released
status.

You can prevent the Technically completed status from being canceled. Create a
user status that prohibits the Revoke technical completion business transaction.

Closed (CLSD)

Use
You use this status for a work breakdown structure or WBS element that has been completed
from both a logistic and an accounting point of view.

Prerequisites
You can only set the Closed status, if:
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•  The project definition or the WBS element have either the Released or the Technically
completed status.

Features
In the Closed status you can no longer make any changes to the project hierarchy. The status is
passed on to subordinate WBS elements.

The status allows

•  You to post actual costs to orders and networks that are assigned to the WBS element, as
long as their status permit this

The status prohibits

•  You from assigning networks, production orders or CO orders to the WBS element.

•  You from posting actual costs to the WBS element

The status deactivates assets in construction that are assigned to the WBS element.

You can cancel the Closed status. In this case the system sets the Technically completed status.

Deletion flag (DLFL)

Use
The Deletion flag status designates work breakdown structures or WBS elements that have been
flagged for deletion. This means that the objects are deleted logically, but not physically.

Prerequisites
You can set the Deletion flag if

•  The WBS element has been settled completely or is not relevant for settlement.

If you set the Must not be settled indicator in the settlement profile in Customizing for
Product Cost Controlling, you can still set the Deletion flag status even if the actual
costs are not balanced.

•  Assigned orders and activities also have Deletion flag status.

•  There are no commitments for the WBS element

•  There are no reservations or purchase requisitions that are account assigned to the WBS
element.

•  All the goods issues have been posted in the assigned sales orders and the deliveries have
been billed.

•  A deletion flag has been set in the appropriation request on which the WBS is based.

•  No associated reservations, planned independent requirements or planned orders exist

•  The completion indicator is set in assigned transfer price agreement
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Features
The status is passed on to subordinate WBS elements. It prohibits all business transactions.

The status

•  Deactivates assets in construction that are assigned to the WBS element.

•  Is the prerequisite for setting a deletion indicator.

As long you have not set a deletion indicator, you can cancel the Deletion flag status.

See also:
Archiving Operative Project Structures (PS-ST-OPR) [Ext.]

Final Billing (FNBL)

Use
With this status you can prevent further billing for this WBS element. However, you can still post
costs (for instance, due to warranty claims).

You can set the Final Billing status in addition to every other status except Deletion flag. The
Final Billing status is not passed on to subordinate WBS elements.

Prerequisites
The WBS element is a billing element.

Features
The status prohibits

•  Creation of a billing document

•  Creation of a quotation

•  Creation of an inquiry

You can cancel the status.

Locked

Use
You can either lock individual business transactions or all the data in a work breakdown structure
or WBS element. You can set the following statuses:

•  Date definition locked (DDLK)

•  Planning locked (PLLK)

•  Budget management locked (BMLK)

•  Account assignment locked (AALK)

•  Master data locked (MDLK )

You can set these statuses in addition to every other status except Deletion flag. The statuses
are not passed on to subordinate WBS elements.
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Features
The Master data locked (MDLK) status prohibits

•  Setting of another system status

•  Changing and extending the project hierarchy

You can cancel these statuses.
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System Status in Standard Work Breakdown Structures
Standard WBS elements do not have their own status. The status of the standard project
definition is valid for all WBS elements.

Released (REL)
Use
You use this status to activate standard work breakdown structures. If a standard work
breakdown structure has Released status, you can use it as a template for creating work
breakdown structures.

Prerequisites
Released status can be set after Created status.

Features
In this status you can change the structure.

You cannot cancel the status.

Closed (CLSD)
Use
You use this status to indicate that a standard work breakdown structure is no longer required.

Prerequisites
You can only set the Closed status after Released status.

 
The Technically completed status does not exist for standard work breakdown
structures.
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System Statuses in Networks
The active system status determines which business transactions you can perform with network
headers, activities, and activity elements. The system status is passed from the network header
to the activities and from the activities to the activity elements. Exceptions are the Account
assignment locked and Locked statuses.

Created (CRTD)
Use
This is the initial system status for new networks, activities, and activity elements. The system
sets this status automatically, when you create a new network.

Features
In the Created status, you can create new activities and activity elements and change the
network header.

The status, for example,

•  Allows you to directly (physically) delete activities and activity elements

•  Prohibits you from posting actual costs

Released (REL)
Use
The Released status is necessary before you can post actual costs.

Prerequisites
The network header or the activity must have the Created status.

Features
In the Released status, you can create new activities and activity elements and change the
network header. If a network has Released status, new activities and activity elements also have
Released status.

The status

•  Allows you to post actual costs

•  Allows you to confirm activities and activity elements

•  Allows you to create reservations or purchase requisitions for all components, depending on
settings elsewhere.

If the corresponding Customizing setting have been made, the system triggers an availability
check for material and capacities.

You cannot cancel the Released status.
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Technically completed (TECO)
Use
You use this status for networks, activities, and activity elements that are completed from a
technical (logistics) point of view.

Prerequisite
The network header or the activity must have the Released status.

Use
If the status is set in a network header, you cannot change the header data or create new
activities. If it is set in an activity, you cannot change activity data.

The status

•  Allows actual postings, for example confirmations

•  Sets a deletion flag for the material components

•  Removes capacity requirements, provided a final confirmation has not been made

•  Deletes purchase requisitions and requirements for material components, if any exist.

•  Prohibits changes to the characteristic value assignment

•  Prevents you setting a user status

•  Prevents you from changing dependent data such as material and PRT allocations.

You can cancel the Technically completed status. In this case the system sets the Released
status.

If you cancel the Technically completed status in the network header, the status is
not automatically canceled in the activities and activity elements. You can cancel the
status in individual activities or in all activities.

Closed (CLSD)
Use
The Closed status closes a network or an activity from both a logistics point of view and an
accounting point of view.

Prerequisites
You can set the Closed status, if the network header, activity, or activity element has the
Released or Technically completed status, and

•  No balance exists

•  All activities that require confirmation have been confirmed.

Use
If the status is set in the network header, you cannot change the header data or create new
activities. If it is set in an activity, you cannot change activity data.
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The status

•  Prevents you from changing dependent data such as material and PRT allocations.

•  Prevents you making actual postings, for instance, confirmations

•  Removes capacity requirements, as long as a final confirmation has not been made

•  Deletes purchase requisitions and requirements for material components, if any exist.

You can cancel the Closed status. The system then set the previous status (Released or
technically completed).

If you cancel the Technically completed status in the network header, the status is
not automatically canceled in the activities and activity elements. You can cancel the
status in individual activities or in all activities.

Deletion flag (DLFL )
Use
The Deletion flag status designates networks and activities that have been flagged for deletion.
This means that the objects are deleted logically, but not physically.

Prerequisites
You can the Deletion flag, if

•  The actual costs of the network are balanced.

If you set the Must not be settled or Can be settled in the settlement profile in
Customizing for Product Cost Controlling, you can still set the Deletion flag status,
even if the actual costs are not balanced.

•  Assigned orders also have the Deletion flag status

•  There are only relationships to networks that have a Deletion flag.

•  No commitments exist for the network

•  No purchase requisitions or purchase orders exist that are account assigned to the network.

Use
If the status is set in the network header, you cannot change the header data or create new
activities. If it is set in an activity, you cannot change activity data.

The status

•  Removes capacity requirements, as long as a final confirmation has not been made

•  Sets an internal deletion indicator for existing material reservations

•  Can also be set (after a warning is issued), if an activity requires confirmation but has not
been finally confirmed.

•  Is the prerequisite for setting a deletion indicator.
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You can set the Deletion flag status in addition to every other system status. The status is
passed on to activity elements. As long you have not set a deletion indicator, you can cancel the
Deletion flag status.

See also:
Archiving Operative Project Structures (PS-ST-OPR) [Ext.]

Locked (AALK or LKD)
Use
You can prohibit account assignment to a network or lock all data in a network or activity. The
following statuses are available:

•  Account assignment locked (AALK)

Depending on the network type, you can set the Account assignment locked status either
only in the network header or only in the activity

•  Locked (LKD)

You can only set the Locked status in the network header. The status is passed on to all
activities.

You can set the Account assignment locked and Locked statuses in addition to every other status
except Deletion flag.  The Account assignment locked and Locked statuses are not passed on to
activity elements.

You can cancel these statuses.
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User Status
Use
You can define and use user statuses in addition to system statuses.

User statuses are not passed on down a hierarchy If you create a project by copying
another project, the user status is not copied either.

Prerequisite
You always define user statuses within a status profile. Therefore you first have to create a status
profile for an object type [Ext.] before you can define a user status. You have to assign a status
profile to a project profile or a network profile, before you can use a status profile in an
application.

To use a user status in a work breakdown structure or a network, use the network or project
profile to which the status profile has been assigned. You can also assign a status profile to a
work breakdown structure or network in the status detail screen in the corresponding transaction.
For more information, see Status Overview in Transactions [Page 345]

Activities
You define status profiles and user statuses in Customizing for the Project System. You can
define as many user statuses as you wish in a status profile.

In the status profile you make the necessary settings for defining user statuses.

•  Short description of the user status with a long text describing its function in more detail.

•  Status number [Page 358] that defines in which order the user statuses are set

•  Initial status that the system sets automatically, when you create a new object

•  Specify whether a matching user status is set automatically when you carry out a business
transaction.

•  Business transactions that are allowed or prohibited, if a user status is set

Status profiles and user statuses are language dependent. If you use status profile and user
statuses in several, note the following:

•  You can only edit user statuses in the language in which they were created.

•  All of the user statuses in a status profile have to be translated. Otherwise all the statuses
appear in the original language.



Structures  SAP AG

Status Number

358 April 2001

Status Number
Definition
Define the sequence in which user statuses [Page 357] can be set.

Use
You can define status numbers for every user status. However only one user status with a status
number can be active at one time in a work breakdown structure or network.

If you want to have several user statuses at the same time, define the additional user statuses in
the status profile without status numbers. You can always set these user statuses.

When you assign a status number to a user status, you must also specify a lowest and highest
status number for that user status.

You use the lowest and highest status number to define:

•  Which user status must be set first

•  Which user status can then be set

•  Whether user statuses can be canceled and if so, which of the previous statuses is set.

See also:
Example: User Status with Status Number [Page 359]
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Example: User Status with Status Number
In your status profile, you have defined the following user status with the status numbers shown:

Status Number User Status Lowest Number Highest Number
Planning locked

1 Idea 1 2
2 Concept 1 3
3 Execution 2 4
4 Valuation 4 4

In this example

•  You can activate the Planning locked status whenever you like, because it has no status
number.

•  The Idea status must always be activated first. If the Idea status is active, it is also possible
to activate the Concept status.

•  If the Concept status is active, you can activate either Idea or Execution

•  The Valuation status cannot be canceled.
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