Versions

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRITPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🚨</td>
<td>Caution</td>
</tr>
<tr>
<td>📜</td>
<td>Example</td>
</tr>
<tr>
<td>📝</td>
<td>Note</td>
</tr>
<tr>
<td>🔄</td>
<td>Recommendation</td>
</tr>
<tr>
<td>🕵️</td>
<td>Syntax</td>
</tr>
</tbody>
</table>
Contents

Versions .................................................................................................................................................. 5
When Are Project Versions Created? .................................................................................................. 6
Profile for Project Versions ............................................................................................................... 7
Manually Creating Project Versions in Networks or the WBS ........................................................ 8
Project Version Keys ........................................................................................................................ 9
Project Versions in the Information System ..................................................................................... 10
Creating Project Versions in the Information System ................................................................. 11
Displaying Project Versions ............................................................................................................. 13
Comparing Project Versions .............................................................................................................. 14
Versions

Purpose
A project version shows the state of the project at a certain point in time or at a certain status.

Project versions:
- Are the basis for statistical evaluations, for example, in earned value analysis
- Can be used in Milestone Trend Analysis [Ext.]
- Document (as a history) the state of the project in the past
- Can be used for comparison purposes

You can create as many project versions in networks, work breakdown structures, and in the information system as you like.

There is a difference between project and plan versions:
- **Project versions** are a “snapshot” of a project at a certain point in time.
- **Plan versions** are created in accounting and store the various costs plans for a project, such as best and worst case scenarios.

See also:
- Different Versions in the Project System [Ext.]
- When Are Project Versions Created? [Page 6]
When Are Project Versions Created?

Project versions are:

- Time-dependent
- Status-dependent

**Time-Dependent**
At a particular point in time, you create a project version manually. You can do this in the WBS, network, or information system.

**Status-Dependent**
The system automatically creates a project version when there is a system and/or user status change in the selected objects. You define the user/system statuses which trigger creation of project versions in Project System customizing.
Profile for Project Versions

In the version profile, you specify the objects to be included in a project version, (for example, WBS elements, activities, production resources/tools, or costs) and when the project version should be created. In the version profile, you can enter as many user and/or system statuses as you want for creating a project version.

For status-dependent project versions, you specify the key [Page 9] to be used every time this status triggers a project version.

The key for status-dependent project versions will be the same for all versions of projects with the same status, regardless of the project name.

You maintain the project version profile in Customizing for the Project System.

See:

Example: status-dependent project version [Ext.]
Profile for Project Versions

Manually Creating Project Versions in Networks or the WBS

When you create a time-dependent project version in a work breakdown structure (WBS) or a network, the system automatically selects all of the objects and their current data. Only when you create a project version in the information system can you limit the objects to be included.

Procedure

The procedure for creating project versions is the same in both network and work breakdown structure maintenance.

1. From the Operative Structures menu, call up a network or work breakdown structure.
2. Choose Edit ➔ Project version.
   The version overview is displayed.
3. Choose Create version.
   A dialog box appears.
4. In the dialog box, enter a version key [Page 9] for the version and a description. Choose Free number to have the system default the next free version number [Ext.].
5. Choose Save.
   You return to the version overview.
   You can display the objects in the version by selecting the menu options Goto ➔ Version objects.
6. Save the network/WBS.
   The system does not create the project version until you do this.

When you create a project version for a network which is assigned to a WBS, the system will only include the network objects and their related data in the project version.
Project Version Keys

The name of a project version or its “key” depends upon how the project version is created:

**Status-dependent project version**
You define the key for each status in Customizing. This means that the key is identical for all project versions triggered by the same status. You cannot change this key.

**Time-dependent project version**
The key you assign to each project version must be unique. You cannot change this key. However, by assigning the same key to a project version of a related project object, you can expand an existing and related project version.

---

You create a project version of a WBS element and give it the key V1. If you create a project version for a network which is assigned to this WBS element and give it the same key, V1, the system will add the network project version to the existing WBS element version V1.

**Version Groups**

When you create a project version in the information system, you must assign it to a version group. You can combine the various project versions by assigning them to the same version group. You may want to organize them according to project, or user, for example.

The version group is helpful when you use F4 to locate project versions because you can limit the selection to those versions that are assigned to the version group you entered.
Project Versions in the Information System

In the information system, you can:

- Create, display and analyze project versions
- Select the objects to be included in a project version
- Compare versions with each other

In the standard Project System, only the data necessary for the selected objects is read when you call up an evaluation. This means that, when you want to create a project version, you must first tell the system to read in all of the data for each object to be included in the project version. For more information, refer to *Limited data/Creating a project version in the evaluation* in *Creating Project Versions in the Information System [Page 11]*.

See also:
- Displaying project versions [Page 13]
- Comparing project versions [Page 14]
Creating Project Versions in the Information System

When you create project versions in the information system, you can choose whether you want all of the current data or a subset of data.

Procedure

Create Project Version with Current Data

To create a time-dependent project version with all of the current data for all objects in the information system, proceed as follows:

1. From the Information System menu, choose Structure/Dates → Structure overview
   Or from the Project Execution menu, choose Period-end closing → Project versions.
2. Enter the PS info profile, as necessary.
   The PS info profile determines which fields are displayed in the structure overview, for example, the project object, actual dates, actual costs, or work.
3. In the initial screen, enter the project, WBS element, network, or sales document.
4. Choose Evaluation → Save project version.
   A dialog box appears.
   The MTA-relevant indicator in this window stipulates that the data from this version can be used in milestone trend analysis [Ext.].
5. Enter a version key [Page 9].
   Choose Free number to have the system default the next free version number [Ext.].
6. Enter a version group [Page 9].
7. Choose Continue.
   The version is saved.

Limited Data/Creating a Project Version in the Evaluation

1. From the Information System menu, choose Structure/Dates → Structure overview
   Or from the Project Execution menu, choose Period-end closing → Project versions.
2. Enter the PS info profile, as necessary.
   The PS info profile determines which fields are displayed in the structure overview, for example, the project object, actual dates, actual costs, or work.
3. In the initial screen, enter the project, WBS element, network, or sales document.
   The evaluation is displayed.
5. Select the objects that should be included in the version.

Only those objects which you have selected and displayed will be saved along with their data in a project version.
Creating Project Versions in the Information System

6. Choose *Evaluation* → *Save project version*. A dialog box appears. The MTA-relevant indicator in this window stipulates that the data from this version can be used in *milestone trend analysis [Ext.]*.

7. Enter a version key [Page 9]. Choose *Free number* to have the system default the next free version number [Ext.].

8. Enter a version group [Page 9].

9. Choose Continue.

The version is saved.

If you access an evaluation by choosing *Execute*, you can still create a project version. First, you must choose *Edit* → *Scope of current data* → *All fields*. In a dialog box the system asks you if the data should refreshed. Answer *Yes* and the system reads in all the data necessary for a project version.
Displaying Project Versions

1. From the Information System menu, select the menu options Structure/dates → Structure overview.

2. Specify the PS info profile.

   The PS info profile determines which fields are displayed in the structure overview, for example, project object, actual dates, actual costs, work.

   ![Tip]

   Make sure that the indicator Version data has been selected for the DB (database) profile.

3. Enter the project and/or network.

4. Set the Current data indicator, if you want to compare current data with the project versions.

5. Choose one or more project versions.

6. Choose Execute.

   The structure overview is displayed.

7. The different project versions are displayed in different colors.

   You can display more fields in the overview by selecting the menu options View → Select fields.

8. You can call up additional project versions by selecting the menu options List → Get proj. version.

   ![Tip]

   Project versions are not created in real time. This means, that under certain circumstances, there is a time lag between the time when you saved the object and the time when the project version is available.
Comparing Project Versions

You can compare as many project versions with each other as you want. The different project versions are displayed in color. The colors follow a five-version cycle.

You can compare the versions by column or by row, for example, to evaluate cost developments and tendencies.

1. From the Information system menu, select the menu options Structure/dates → Structure overview.

2. Specify the PS info profile.
   The PS info profile determines which fields are displayed in the structure overview, for example, project object, actual dates, actual costs, work.
   Make sure that the indicator version data has been selected for the DB (database) profile.

3. Enter the project and/or network.

4. Set the Current data indicator if you want to compare the current data with the project versions.

5. Choose a project version by pressing F4 in project version field. You can select additional project versions by activating the icon Multiple selection.

6. Choose Execute.
   The structure overview is displayed.
   Project versions are displayed in different colors.

Choosing a Leading Project Version for Comparisons

Each version is displayed in a different color. If you compare many project versions, the colors are repeated after every fifth version.

The colors used for each project version are displayed in a legend in the upper portion of the screen on the structure overview. To specify which project version is the starting point for the comparison, double click the version in the legend (see figure).
Comparing Project Versions

You can also choose or cancel the leading project version by selecting the menu options View → Vers. comparison (rows) → Leading version.

Comparing Columns

1. Use Select fields to choose the field(s) that you want to compare.
2. Choose the columns you want to compare.
   A dialog box with the different project versions is displayed.
4. Select a project version and choose Continue.
   A list with the results of the comparison, that is, the differences, is displayed.
5. Return to the structure overview.

Comparing Lines

1. Use Select fields to choose the field(s) that you want to compare.
2. Choose the lines you want to compare.
3. Select the menu options Edit → Comparisons (columns) → Several fields...
   A dialog box where you can select different fields is displayed.
4. Select the relevant fields, then choose Continue.
   A list with the results of the comparison, that is, the differences, is displayed.
5. Return to the structure overview.