Payroll Australia (PY-AU)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Caution" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image" alt="Example" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image" alt="Note" /></td>
<td>Note</td>
</tr>
<tr>
<td><img src="image" alt="Recommendation" /></td>
<td>Recommendation</td>
</tr>
<tr>
<td><img src="image" alt="Syntax" /></td>
<td>Syntax</td>
</tr>
<tr>
<td><img src="image" alt="Tip" /></td>
<td>Tip</td>
</tr>
</tbody>
</table>
Contents

Payroll Australia (PY-AU) ................................................................. 20
Payroll in the SAP System ............................................................... 21
Payroll Basics (PY-XX-BS) .............................................................. 22
  Payroll Driver ........................................................................ 23
  Payroll Schema ..................................................................... 24
  Payroll Relevant Files ............................................................ 25
  Internal Tables ...................................................................... 26
  Payroll Control ...................................................................... 27
    Payroll Control Record ....................................................... 28
    Payroll Status (Infotype 0003) ............................................ 30
    Editing the Payroll Status .................................................. 31
    Locked Personnel Numbers .............................................. 33
    Payroll Area ....................................................................... 34
  Specific Payroll Dates ............................................................ 35
    Period Parameters ............................................................... 36
    Date Modifier ..................................................................... 37
    Payroll Period ................................................................... 38
    Period Number .................................................................... 40
  Retroactive Accounting .......................................................... 42
    Earliest Possible Retroactive Accounting Period .................. 44
    Changing the Earliest Possible Retroactive Accounting Period .. 45
  Transaction Codes for Payroll .................................................. 46
Retroactive Accounting Australia .................................................. 49
  Retroactive Superannuation Calculations ............................... 50
  Retroactive Tax Calculations .................................................. 51
  Retroactive Changes to Leave .................................................. 52
The Payroll Process ....................................................................... 53
  Payroll Control Record .......................................................... 56
  Locked Personnel Numbers ................................................... 58
  Simulating Payroll ................................................................. 59
  Displaying the Payroll Log ....................................................... 60
    Searching in the Payroll Log .............................................. 62
    Creating and Processing Display Variants for the Payroll Log .. 63
  Releasing Payroll ................................................................. 64
    Releasing Several Payroll Areas ......................................... 65
  Running Payroll ..................................................................... 66
  Displaying Personnel Numbers not Included in the Payroll Run ... 68
  Correcting Payroll-Relevant Master and Time Data .................. 69
  Performing a Payroll Correction Run ....................................... 70
  Checking the Payroll Results .................................................. 71
  Simulating a Posting Run ....................................................... 73
  Exiting Payroll ....................................................................... 75
  Displaying Payroll Results ...................................................... 76
Displaying the Payroll Results for a Personnel Number .................................................. 78
Displaying the Overview of Tables for a Payroll Result ................................................. 79
Displaying the Tables for a Payroll Result ..................................................................... 80
Error Search for Several Personnel Numbers: Example ............................................ 81
Deleting the Last Payroll Result .................................................................................... 82
Displaying Deleted Payroll Results ............................................................................... 84
Advance Payments ......................................................................................................... 85
Qualified Advance Payments ....................................................................................... 86
Making a Qualified Advance Payment ...................................................................... 88
Unqualified Advance Payments ................................................................................... 89
Creating a File for an Unqualified Advance Payment ............................................... 91
Payroll in a Background Operation ................................................................................ 92
Parallel Payroll for Personnel Numbers ....................................................................... 93
Payroll Calendar ............................................................................................................. 94
Changing and Displaying Payroll Jobs and Tasks ...................................................... 96
HR Process Workbench ............................................................................................... 98
Process Model .............................................................................................................. 99
Technical Processing of a Process Model ................................................................... 100
Process Model: Example ............................................................................................ 101
Process ......................................................................................................................... 103
Breakpoint .................................................................................................................... 105
Personnel Number Selection ........................................................................................ 106
Mail Connection ............................................................................................................ 108
Copying or Creating a Process Model ......................................................................... 109
Editing a Process Model .............................................................................................. 111
Inserting a Process Step ............................................................................................... 112
Defining the Attributes of a Process Step .................................................................. 113
Defining the Attributes of a Breakpoint ..................................................................... 114
Changing a Process Step ............................................................................................. 115
Changing the Sequence of Process Steps ................................................................... 116
Creating a Process ....................................................................................................... 117
Starting or Repeating a Process or Process Step ........................................................ 118
Closing a Process .......................................................................................................... 120
Deleting a Process ........................................................................................................ 121
Process Control ........................................................................................................... 122
Status Display ............................................................................................................... 123
Changing the Status ..................................................................................................... 125
Off-Cycle Payroll Activities ......................................................................................... 126
Off-Cycle Activities (PY-XX-OC) ............................................................................... 127
Off-Cycle Workbench ................................................................................................. 129
Payroll History ............................................................................................................... 130
Off-Cycle Payroll ......................................................................................................... 131
Bonus Accounting ........................................................................................................ 133
Correction Payroll ....................................................................................................... 135
Regular Payroll On Demand ....................................................................................... 136
Payroll Australia (PY-AU)

Advance Payment ................................................................. 137
Absence Payment ................................................................. 138
Payroll Results Adjustment ..................................................... 139
Running Off-Cycle Payroll ....................................................... 140
Reasons, Types and Categories for Off-Cycle Payroll ............... 141
The One-Time Payments Off-Cycle Infotype (0267) .............. 144
Replacing a Payment ............................................................. 146
Replacing a Payment ............................................................. 148
Assigning Check Numbers ................................................... 150
Reversing Payroll Results ....................................................... 151
Reversing the Payroll Result ................................................... 153
Out-of-Sequence Reversal: Changes in the RT and BT Tables ..... 156
Off-Cycle Subsequent Processing ............................................ 158
Effects on Dependent Functions ............................................ 162
Mass Off-Cycle Payroll Runs .................................................. 163
Gross Part of Payroll ................................................................ 164
Wage Types ............................................................................. 165
Dialog Wage Types ............................................................... 168
Time Wage Type ................................................................. 169
Secondary Wage Type ............................................................ 170
Processing Class ................................................................. 171
Evaluation Class ................................................................. 172
Wage Type Copier ............................................................... 173
Wage Type Catalog .............................................................. 174
Creating the Customer-Specific Wage Type Catalog ............... 175
Copying Model Wage Types Assigned to a Wage Type Group .. 177
Copying a Model Wage Type as a Prototype ......................... 179
Duplicating a Wage Type ...................................................... 181
List of Copied Wage Types .................................................... 182
Copying Wage Types Manually .............................................. 184
Time-Based Delimitation of a Wage Type ............................... 185
Deleting Wage Types .......................................................... 187
List of Deleted Wage Types .................................................. 189
Deleting or Delimiting Wage Types Manually ......................... 190
Assigning Wage Types to Wage Type Groups ......................... 191
Displaying the Assignment of Wage Types to Wage Type Groups 193
Deleting Customer Wage Types from a Wage Type Group ....... 194
Assigning Customer Wage Types to a Wage Type Group ....... 195
Using Wage Types .............................................................. 196
Creating a Wage Type Utilization List ..................................... 197
Wage Type Split ................................................................. 198
Wage Type Split: Example 1 .................................................. 200
Wage Type Split: Example 2 .................................................. 201
Payments ............................................................................. 203
Basic Pay (Infotype 0008) ....................................................... 204
Editing Basic Pay ............................................................... 205
Pay Scale Reclassification ...................................................... 207

April 2001
Performing A Pay Scale Reclassification ......................................................... 208
Standard Pay Increase .................................................................................... 209
Effecting a Standard Pay Increase ................................................................. 210
Recurring Payments/Deductions (Infotype 0014) .............................................. 212
Processing Recurring Payments and Deductions ............................................ 214
Additional Payments (Infotype 0015) ................................................................. 215
Processing Additional Payments ................................................................. 217
Standard Wage Maintenance ............................................................................ 219
Standard Wage Maintenance (Infotype 0052) ................................................ 221
Time Quota Compensation Infotype (0416) .................................................... 222
Employee Remuneration Info Infotype (2010) ................................................ 223

Time Management Aspects in Payroll ........................................................... 225
Integration with Time Management ................................................................. 226
Day Processing of Time Data in Payroll ......................................................... 228
Sequence of Day Processing/Wage Type Selection ..................................... 230
Time Wage Type Selection ............................................................................ 233
Integration Between Time Evaluation and Payroll ....................................... 236
Shift Change Compensation ........................................................................... 238
Activity with a Higher Rate of Pay ................................................................. 239
Entering a Different Payment for Time Infotype Records ............................ 240
Employee Remuneration Information ............................................................. 243
Employee Remuneration Info Infotype (2010) ................................................ 244
Maintain Employee Remuneration Information ........................................... 246
Absences .......................................................................................................... 248
Absence Valuation ......................................................................................... 249
Absence Valuation in Schema xT00: Technical Process ................................. 251

Wage Type Valuation ....................................................................................... 256
Dialog Wage Types Valuation ................................................................. 257
Time Wage Types Valuation ........................................................................... 258
Valuating Wage Types Using Valuation Bases ............................................. 259
Technical Procedure for Wage Type Valuation using Valuation Bases .......... 260
Wage Type-Dependent Constant Valuation Bases ........................................ 264
Personnel Calculation Rule XMOD ............................................................... 268
Constant Valuation Bases that Depend on the Collective Agreement .......... 269
Constant Valuation Bases that Depend on the Collective Agreement Example ........................................... 270
Employee-Related Valuation Basis ................................................................. 272
Person-Related Valuation Bases: Example...................................................... 274
Percentage Advance Pay for Individual Valuation Bases .......................... 275
Valuating using the Principle of Averages ..................................................... 276
Frozen Averages ......................................................................................... 278
Determining the Average Value without a Basis ........................................ 280

Old and New Processing of Averages ............................................................ 281
Technical Process of Average Processing (New) ........................................... 284
Relevancy Test for Valuation According To the New Principle of Averages ...... 288
Technical Process of Average Processing (Old) .......................................... 290
Valuation of Primary Wage Types ............................................................... 295
Relevancy Test for Valuation Using the Principle of Averages (old) ............................................ 296
Cumulating Average Bases ........................................................................................................ 297
Determining Relevant Previous Periods .................................................................................. 298
Final Processing of Averages ................................................................................................. 299
Adapting the Average Bases to Increased Payments ............................................................ 300

Leave Processing ....................................................................................................................... 301
Conversion to Leave Quotas ................................................................................................... 302
Australian Leave Conversion ................................................................................................... 305
Accrual Conversion .................................................................................................................. 308
Entitlement Conversion ............................................................................................................ 309
Anniversary Conversion .......................................................................................................... 311
Provisions Conversion ............................................................................................................. 312
Executing Australian Leave Conversion ................................................................................. 313

Leave Provisions and Payments (New Method) .................................................................... 315
Leave Provisions Based on Leave Quotas ................................................................................ 316
The Leave Provision Process .................................................................................................... 317
Leave Provision Calculation Factors ....................................................................................... 319
Leave Provision Calculations .................................................................................................... 322
Posting Leave Provisions to Accounting ............................................................................... 324
Leave Loading .......................................................................................................................... 325
Leave Loading with Quota Corrections .................................................................................... 327
Leave Payments on Termination ............................................................................................... 329
Projecting Leave Balances ....................................................................................................... 331
Quota Accrual Transfer to Entitlement .................................................................................... 332
Leave Reporting ........................................................................................................................ 334
Executing Leave Reports .......................................................................................................... 337
Printing Leave Reports ............................................................................................................. 339

Partial Period Remuneration (Factoring) .................................................................................. 340
Application Examples for Reductions ...................................................................................... 342
Application Examples for Period-Specific Remuneration Calculation ..................................... 343
Partial Period Factor ................................................................................................................ 344
Factoring Parameter ................................................................................................................ 345
Technical Sequence for Partial Period Remuneration ............................................................. 347
PWS Method ............................................................................................................................. 349
Payment Method ....................................................................................................................... 350
Deduction Method .................................................................................................................... 351
Hybrid of Payment and Deduction Methods ......................................................................... 352
All or Nothing Method .............................................................................................................. 353
Reduction of Payments: Example ............................................................................................. 354
Calculating Period-Specific Remuneration: Example ................................................................. 355

Salary Packaging ..................................................................................................................... 356
Salary Packaging ........................................................................................................................ 357
Salary Package Customizing ..................................................................................................... 359
Creating an Employee's Salary Package ................................................................................... 361
Sample Employee Salary Package (South Africa) .................................................................... 364
Sample Employee Salary Package (Australia) ............................................................ 367
Salary Packaging ......................................................................................................... 369
Salary Packaging / Employee Self Service (ESS) Scenario ........................................ 370
Compare Salary Packages ......................................................................................... 371
Model Salary Packages ............................................................................................. 373

**Advance Payments** ............................................................................................... 375
Advance Payment Reporting ..................................................................................... 376
Creating Advance Payments .................................................................................... 377
Changing Advance Payments .................................................................................. 378
Deleting Advance Payments .................................................................................... 379
Executing the Advance Payment Program .............................................................. 380
Example: Creating an Advance Payment ................................................................. 381
Advance Payment Posting to Accounting ............................................................... 382

**Terminations/Redundancies** .................................................................................. 383
Terminations/Redundancies with Leave Quotas ....................................................... 384
Technical Process of Terminations/Redundancies ................................................... 386
Initial Setup of Terminations/Redundancies ............................................................. 391
Setting up Terminations/Redundancies with Leave Quotas ................................... 393
Determining the Payment Method ........................................................................... 396
Producing Group Certificates on Termination ....................................................... 397
The Recurring Payments Function ......................................................................... 399
Suppressing Recurring Payments .......................................................................... 400
The Lieu of Notice Function .................................................................................... 401
Calculating Payments in Lieu of Notice .................................................................. 403
The ATO LSL Formula Function ............................................................................. 405
Calculating LSL Payments with a Formula ............................................................ 407
Calculating LSL Payments Without a Formula ....................................................... 409
Leave Payments on Termination ............................................................................. 410
Projecting Leave Balances ....................................................................................... 411
Entering Additional Payments ................................................................................ 412
Distributing the ETP Rollover .................................................................................. 413
Projecting Termination Payments .......................................................................... 415
Updating Single and Bulk Terminations ............................................................... 417
Reinstating Terminated Employees ....................................................................... 419
Terminating in the Past ............................................................................................ 420
Making Payments after Termination ..................................................................... 422
Terminations/Redundancies Reporting ................................................................. 423
Producing Payment Summaries on Termination ................................................... 425
Printing Payment Summaries and Reports ......................................................... 427
Terminations/Redundancies with Leave Accruals .................................................... 429
Technical Process of Terminations / Redundancies ............................................... 431
Initial Setup of Terminations / Redundancies .......................................................... 435
Setting up Terminations/Redundancies with Leave Accruals ................................. 437
Determining the Payment Method ......................................................................... 440
Producing Payment Summaries on Termination ................................................... 441
The Recurring Payments Function ....................................................................... 443
Suppressing Recurring Payments ................................................................. 444
The Lieu of Notice Function ............................................................................. 445
Calculating Payments in Lieu of Notice ............................................................... 447
The ATO LSL Formula Function ...................................................................... 449
Calculating LSL Payments with a Formula ........................................................... 451
Calculating LSL Payments Without a Formula ...................................................... 453
Leave Payments on Termination ........................................................................ 454
Projecting Leave Balances ................................................................................ 456
Entering/Deleting Leave Payments ..................................................................... 458
Entering Additional Payments ............................................................................. 460
Distributing the ETP Rollover ............................................................................. 461
Projecting Termination Payments ...................................................................... 463
Updating Single and Bulk Terminations ............................................................ 465
Reinstating Terminated Employees ..................................................................... 467
Terminating in the Past ....................................................................................... 468
Making Payments after Termination ................................................................ 470
Terminations/Redundancies Reporting ............................................................... 471
Producing Payment Summaries on Termination ................................................. 473
Printing Payment Summaries and Reports ......................................................... 475

Change of Group Tax Employer ........................................................................ 477

Net Part of Payroll .............................................................................................. 480

Taxation ............................................................................................................... 481

Employee Tax Information ................................................................................ 482
Tax Australia (Infotype 0188) ............................................................................. 483
TFN Australia (Infotype 0227) ........................................................................... 487
Creating Employee Tax Details ........................................................................ 488
Tax on Bonuses and Commission ..................................................................... 489
Creating a Bonus Payment with Marginal Tax ................................................... 490
Tax Across Multiple Payroll Periods ................................................................. 491
Spreading Tax Across Multiple Payroll Periods ............................................... 492
Tax on Termination ............................................................................................ 493
Leave Payments Tax on Termination ................................................................. 494
Marginal Tax on Termination ........................................................................... 495
Overriding Tax .................................................................................................... 496
Creating a Temporary Tax Override Infotype .................................................... 497
Fixed Tax on Payments ...................................................................................... 498
Tax Reporting ...................................................................................................... 499

Superannuation ................................................................................................. 500

Superannuation (Infotype 0220) ........................................................................ 501
Superannuation Contributions .......................................................................... 502
Employer Contributions ..................................................................................... 503
Employee Contributions ..................................................................................... 504
Super Guarantee Contributions ......................................................................... 505
Super Guarantee Contribution Rules ................................................................. 506
Superannuation Reporting .................................................................................. 507
Executing Superannuation Reports .................................................................... 510
Executing ATO Notification Reports ................................................................. 511
Troubleshooting ........................................................................................................................................ 709
Posting Run Cancelled with Status ........................................................................................................ 710
Personnel Numbers not Selected or Rejected ...................................................................................... 711
Accounting Documents Were not Created ............................................................................................ 712
Posting Run is Missing in the Posting Run Overview ........................................................................... 713
Resetting the Reversal after Termination ............................................................................................... 714

**Reporting Australia** ................................................................................................................................. 716

**The Reporting Process** ............................................................................................................................. 717

**Payroll Reporting** ..................................................................................................................................... 718
  Executing Payroll Reports ....................................................................................................................... 720
  Printing Payroll Reports .......................................................................................................................... 721

**Superannuation Reporting** .................................................................................................................... 722
  Executing Superannuation Reports ........................................................................................................ 725
  Executing ATO Notification Reports ..................................................................................................... 726
  Printing Superannuation Reports .......................................................................................................... 727

**Leave Reporting** ....................................................................................................................................... 728
  Executing Leave Reports ....................................................................................................................... 731
  Printing Leave Reports .......................................................................................................................... 733

**Advance Payment Reporting** ............................................................................................................... 734
  Executing the Advance Payment Program ............................................................................................ 735

**Terminations/Redundancies Reporting** ............................................................................................... 736
  Producing Payment Summaries on Termination ................................................................................ 738
  Printing Payment Summaries and Reports ............................................................................................. 740

**End-of-Year Processing** ......................................................................................................................... 742
  End-of-Year SGC Processing .................................................................................................................. 743
  Group Certificates .................................................................................................................................. 744
    The Group Certificate Process ............................................................................................................. 746
    Group Certificates Setup ..................................................................................................................... 747
    Group Certificates ............................................................................................................................... 748
      Group Certificates 1997/1998 ........................................................................................................... 749
      Group Certificates 1998/1999 ........................................................................................................... 751
      Group Certificates 1999/2000 ........................................................................................................... 753
    Displaying Group Certificates ............................................................................................................ 756
    Printing Group Certificates .................................................................................................................. 757
    Setting the Completion Indicator ......................................................................................................... 758
    Printing One-Off Group Certificates .................................................................................................. 759
    Transferring Group Certificates .......................................................................................................... 760
  End-of-Year Adjustments ......................................................................................................................... 761
  ETP Group Certificates ........................................................................................................................... 763
    Printing ETP Group Certificates .......................................................................................................... 765
  Group Certificate Listings ......................................................................................................................... 766
    Group Certificate Listing 1998/1999 ................................................................................................. 769
    Group Certificate Listing 1999/2000 ................................................................................................. 770
    Executing a Group Certificate Listing ................................................................................................. 771

**Employee Allowances Report** ................................................................................................................ 772
  Displaying and Printing Allowance Reports ........................................................................................... 773
Data Export with the Toolbox ................................................................................................................840
Interface Format ........................................................................................................................................841
Create Objects ........................................................................................................................................844
Database Object .........................................................................................................................................845
Cluster Object ...........................................................................................................................................847
Table Object ...............................................................................................................................................849
Field Object ...............................................................................................................................................851
Creating an Interface Format ..................................................................................................................852
Inserting a Field Object ............................................................................................................................854
Delete Objects ............................................................................................................................................855
Deleting Objects .........................................................................................................................................856
Data Definition for Cluster Objects ........................................................................................................857
Changing or Displaying the Data Definition for a Cluster Object ..........................................................858
Table Entries .............................................................................................................................................859
Selecting Table Entries .............................................................................................................................860
Conversion for Field Objects ....................................................................................................................861
Constant Conversion Type .......................................................................................................................862
   Example: Replacing a Constant Generically ...........................................................................................864
Table Value Conversion Type ....................................................................................................................865
   Database Table .........................................................................................................................................866
   Example: Replacing a Table Value ...........................................................................................................867
User Exit Conversion Type ........................................................................................................................868
   Example: User Exit with Form Routine ....................................................................................................869
Selecting the Conversion for A Field Object ............................................................................................870
Restrictions for Field Objects ....................................................................................................................872
Creating Restrictions for a Field Object ....................................................................................................874
Attributes in the Interface Format .............................................................................................................875
Data Definition Include ............................................................................................................................876
Creating an Include Automatically or Using an Existing Include ..........................................................877
Change Validation .......................................................................................................................................879
Comparison Period for Change Validation .............................................................................................881
Setting the Comparison Period for Multiple Export ...............................................................................882
Setting the Comparison Period for Retroactive Accounting ..................................................................883
   Determination of Comparison Period Using First Method if New change validation Attribute Is Flagged .......................................................................................................................884
   Determination of Comparison Period Using First Method if New change validation Attribute Is Not Flagged .......................................................................................................................886
   Second Method for Setting the Comparison Period ...............................................................................888
Create Objects ............................................................................................................................................890
Creating Objects .........................................................................................................................................891
Delimit Objects ............................................................................................................................................892
   Example: Delimiting an Infotype ............................................................................................................893
   Delimiting Objects ................................................................................................................................894
Single Field Validation .............................................................................................................................895
   Example: Single Field Validation ............................................................................................................896
   Validating Single Fields ........................................................................................................................897
Key Fields ..................................................................................................................................................898
Generating the Secondary File ................................................................. 1007
Import Wage Types ............................................................................... 1008
Starting the Import ............................................................................... 1009
Payroll Australia (PY-AU)

Purpose
This component enables you to run payroll for all employees in line with Australian legal and business requirements.

Implementation Considerations
The SAP HR Payroll Australia component should be implemented in cooperation with the project team implementing other areas of SAP Human Resources (HR), in particular SAP HR Personnel Administration.

Integration
The SAP HR Payroll Australia component is integrated with other SAP HR components such as Personnel Administration and Personnel Time Management. There are interfaces to Financial Accounting and Controlling, and you can run payroll using a combination of SAP and third-party products.

Features
The component uses data from other areas of SAP HR to calculate all statutory and non-statutory additions and deductions for your employees. SAP HR Payroll Australia offers a number of standard reports used in payroll, superannuation, leave, advance payments and taxation.

In addition to standard payroll functions, payroll processing for Australia comprises the following country-specific functions:

- Taxation
- Superannuation
- Advance payments
- Deductions
- Bonuses and commissions
- Salary packaging
- Leave processing
- Leave provisions and payments
- Month-end accruals
- Terminations/redundancies
- Reporting
- End-of-year processing/group certificates
- Bank transfers

SAP HR Payroll Australia also supports retroactive accounting. This function automatically recalculates payroll in the event of changes to master data and time data in periods for which payroll has already been completed.
Payroll in the SAP System

Purpose
You can use this component to calculate the remuneration for work done for each employee.

However, Payroll does not just involve the calculation of remuneration, but consists of a variety of processes that are becoming increasingly important due to the employer’s increased obligation to supply benefits and medical welfare. These benefits are products of:

- Labor law
- Tax law
- Contribution law
- Benefits law
- Civil law
- Reporting law
- Information law
- Statistics law

Integration
Payroll can be integrated in Personnel Administration, Time Management, Incentive Wages and Accounting:

- Standardized data retention enables you to use master data and other payroll relevant data from Personnel Administration.
- Time data, entered via Time Management, is automatically included in the Payroll and is valuated during the payroll run.
- Data from the Incentive Wages component is used to calculate piecework wages and premium wages directly in Payroll.
- Information on expenses and payables from Payroll is posted for accounting directly in Financial Accounting, and you assign the costs to the appropriate cost center. You can also control the financial system of third-party providers.

Features
The System calculates the gross and net pay, which comprises the individual payments and deductions that are calculated during a payroll period, and are received by an employee. These payments and deductions are included in the calculation of the remuneration using different wage types [Extern].

After the remuneration payroll you can carry out various subsequent activities, for example, you can see to remuneration payment or the creation of various lists, and make evaluations.
Payroll Basics (PY-XX-BS)

Purpose
The Payroll is based on an international payroll driver. This payroll driver was modified for each country. The country-specific payroll drivers take the statutory and administrative regulations of a country into account.

Since the payroll driver has a modular structure, you can use the Customizing functions to quickly modify the payroll procedure to meet the particular requirements of your enterprise.

Process Flow
When you access Payroll, the payroll driver calls the accompanying payroll schema, which consists of a sequence of functions. For each activity, the individual functions import data from internal tables and payroll relevant files.

Payroll is then performed as follows:
1. The system updates the databases and imports the master data relevant to payroll.
2. If Off-Cycle Payroll [Seite 131] is to take place, the system deletes the internal table IT.
3. The system imports the last payroll result.
4. The system calculates the gross wage and considers the shift schedule, shift change compensation, and valuation bases. Any master data relevant to payroll is included in the calculation at this point.
5. The system calculates the partial period factors, lump sums and salary elements, and cumulates the gross results.
6. The system calculates the net remuneration and performs retroactive accounting if specific master data has been changed in previous payroll periods.

Result
After the payroll run, you can transfer the payroll results to Financial Accounting, or perform evaluations and create lists and statistics.
**Payroll Driver**

**Definition**

Special report for Payroll. SAP has developed country-specific payroll drivers, which are based on report RPCALCx0. With country-specific reports the penultimate character in the name refers to the country indicator (for example, D for Germany, F for France).

**Use**

Report RPCALCx0 can calculate periodic payments and also off-cycle payroll runs. However, this report does not include tax and social insurance data for net wage calculations. The country specific payroll drivers contain this data.

**Integration**

Calculation rules and other reports are stored in an accompanying schema [Seite 24] which also contains the activities carried out by the payroll driver during payroll. All data is stored in internal tables [Seite 26] and saved in files [Seite 25] with a cluster structure.
Payroll Schema

Definition
The payroll schema contains calculation rules to be used by the payroll driver during payroll. SAP has developed country-specific schemas which are based on schema X000. With country-specific reports, the first character in the name refers to the country indicator (for example, D for Germany, F for France).

Structure
A schema consists of the following parts:

- Initialization
  
  The system performs the following steps:
  - Updates the databases
  - Imports required infotypes

- Gross calculation of pay
  
  The system performs the following steps:
  - Processes basic data and time data
  - Queries off-cycle payroll runs
  - Reads payroll account of the last period accounted
  - Processes time data and calculates the individual gross values
  - Performs factoring

- Net calculation of pay
  
  The system performs the following steps:
  - Calculates net remuneration
  - Performs bank transfers

Integration
All data is stored in internal tables and saved in files with a cluster structure.
Payroll Relevant Files

Definition
Payroll files contain data for payroll and payroll results.

Structure
The system requires the following files for payroll:

- Pnnnn (nnnn = number of the infotype)
  The Pnnnn files contain data that has been entered in the respective infotypes for an employee.

- PCL1
  The PCL1 file contains primary information, in other words, data from the master data and time recording systems.

- PCL2
  The PCL2 file contains secondary information, in other words, derived data and all generated schemas.

Integration
When you start payroll, the system imports the relevant master data from the Pnnnn files (for example, basic pay and tax class) and imports the time data from the PCL1 file to the IT table. The system imports the payroll results from the previous month from table ORT (for example, to form averages). The system processes this data and saves the payroll results and generated schemas in the PLC2 file.
Internal Tables

Definition

Internal tables store data during payroll. The system imports data to these tables and uses them to calculate new data. This data is then also saved in internal tables.

Structure

At the start of the payroll run, the system reads the values from the results tables to the old results table (ORT). Data from the previous period is, therefore, available in the current payroll period.

The most important internal tables are:

- Input table (IT)
  Table IT contains data that can be edited. The table exists only during processing.

- Output table (OT)
  Table OT contains the results of an activity. These results are written to the input table for further processing. The table exists only during processing.

- Results table (RT)
  Table RT contains the results of the period for which payroll has been run. The system saves this data in the PCL2 file in cluster RX.
Payroll Control

Use

This function is used to control Payroll.

During Payroll the master data for the personnel numbers to be included in the payroll run can not be changed for the past or present, for example.
You should not perform payroll, when master data is being processed for the personnel numbers for which payroll should be run.

Scope of Function

- Payroll Control Record [Seite 56]
- Payroll Area [Seite 34]
- Payroll Status [Seite 30]
- Payroll Period [Seite 35]
Payroll Control Record

Definition

Payroll object that is important for the payroll run, and which contains all the information on a payroll area [Seite 34].

Use

The payroll control record [Extern] has the following functions:

- It locks the personnel numbers, for which payroll should be run, against master data changes that affect the payroll past or present.
- It locks the payroll for the period during which payroll-relevant changes are made to the master data for the personnel numbers being processed.
- It makes the following information available for the system:
  - What is the next payroll period for which regular payroll should be run?
  - Up to what date is retroactive accounting [Seite 42] carried out?
  - What status does the payroll currently have? (for example, Released for Payroll or Check Payroll Results)?

When you carry out a payroll run, the system automatically changes the payroll status in the payroll control record. You can also change the status manually under Payroll → Tools → Control Record.

Structure

The control record contains the following information:

- Payroll area
- Payroll status
- Payroll period
- Earliest possible retroactive accounting period [Seite 44]
- Last change made to the control record

When you create the control record in your live system, please note the following: the payroll period that you enter at the start of the live payroll run must be 1 period lower than the period with which you want to perform the live payroll run for the first time.

You want to carry out the first payroll run in period 5 1999. In the payroll control record, you must enter 4 1999 as the period. If you set the payroll control record for the first payroll run to status Released for Payroll, the system increases the period by 1 and payroll is run for period 5 1999.
Payroll Status (Infotype 0003)

**Payroll Status (Infotype 0003)**

**Definition**
Infotype in which data on the *Payroll* status and *Time Management* status is stored.

- For example, the system stores the date of the last payroll run performed for the employee in the *Payroll Status* infotype (0003).
- The system can flag an employee that was rejected in the payroll run.

**Use**
The system automatically creates this infotype when the employee is hired. In general, the system updates the infotype and writes the changes to the payroll past.

**Structure**
You can change the payroll status of an individual employee using *Payroll/Retroactive Accounting* and *Time Evaluation*.

- It is only worthwhile making such changes for a few exceptional cases. For more information, see [Changing The Payroll Status](#).
Editing the Payroll Status

Use

The *Payroll Status* infotype (0003) is usually updated by the system. An exception is manual editing of an employee’s payroll status. The following possibilities exist to edit the infotype:

- **Editing Master Data**
  
  Here, you can edit part of a field.

- **Enhanced Editing**
  
  Here, you can edit all fields.

Prerequisites

**Editing Master Data**

You are authorized to edit master data.

**Enhanced Editing**

During the enhanced maintenance of the *Payroll Status* infotype (0003), you can exclude employees from the payroll run and delete employees from the payroll correction run [Seite 68]. Since such changes are particularly critical, you need special authorization for extended editing of the infotype. If you do not have this authorization, contact your system administrator.

Procedure

**Editing Master Data**

1. Choose *Human Resources → Personnel Management → Administration → HR Master Data → Maintain.*

2. Enter the personnel number and infotype 0003, and select 🖌. You can edit the following fields:
   - *Earl. Pers. RA* (Earliest Possible Personnel Retroactive Accounting Date)
   - *Run Payroll Up To*
   - *Do Not Account After*
   - *Personnel Number Locked*

   For more information on this field, see linked personnel numbers [Seite 58].

- *Earl. Pers. RA* (Earliest Possible Personnel Retroactive Accounting Date Time Evaluation)

**Enhanced Editing**

Editing the Payroll Status

The Change Payroll Status screen appears.

2. Enter the personnel number and choose 📋.

You can enter data in all fields of the Payroll Status (0003) infotype.
Locked Personnel Numbers

In the Payroll Status infotype (0003) [Seite 30] you can exclude an employee from the payroll run by flagging the Pers.no. locked field.

You can **not** set these lock indicators for the current period in the following situations:

- if payroll has already been completed for the current payroll period.
- if the employee has already been paid in the current payroll period.
Payroll Area

**Definition**
A group of employees for whom payroll should be run together, and at the same time.

**Use**
You can perform the Payroll separately for different employee groups, using different payroll areas [Extern]. This is necessary if the payroll period [Seite 35] is not the same for all employee groups.

Salaried employees in your enterprise receive their salary at the end of the month. Hourly wage earners receive their remuneration in the middle of the subsequent month.

You can also group together all employees in one payroll area that should not be included in the payroll run. To do so, you create a payroll area for which you do not select the Run payroll indicator.

When you run payroll, you must specify the payroll area in the payroll driver [Seite 23] selection screen. The payroll area has the following functions:

- In the Payroll Period block it is used to determine the exact payroll period.
- In the Selection block it is used to select the personnel numbers that should be grouped together during the payroll.

**Structure**
The payroll area contains the following information:

- Payroll area text
- Period parameters [Extern]
- Run payroll until indicator
- Date modifier [Extern]

**Integration**
Every payroll area needs its own payroll control record [Seite 56].
Specific Payroll Dates

Definition

Exact period in which the regular payroll is carried out.

14-day payroll periods have been defined for your enterprise. The first period begins on 01 January. If you carry out Payroll for payroll period 09, the specific payroll date is 01 through 15 May.

Use

In regular payroll, payroll is always run for a payroll period. The system determines the specific payroll dates. It also checks if retroactive accounting [Extern] is necessary.

In the case of Off-Cycle-Payroll [Extern] the specific payroll period can be a day. In the case of bonus accounting, the payment date that you use to start the off-cycle payroll is both the start date and the end date of the payroll period. The system generates the payroll result for this day.

For further information see Off-Cycle-Activities [Seite 127].

In the case of regular payroll, the method used to define the specific payroll period is dependent on whether you are carrying out a test run or a live payroll run:

- For a test run, you generally enter the specific payroll period
- For a live payroll run, the system uses the value that is in the payroll control record [Seite 56] as the current payroll period

In the payroll driver [Seite 23] selection screen, enter the payroll area [Seite 34] for which you want to run payroll. The system derives the exact start and end date of the payroll for this payroll area, using the following parameters, which are stored in the payroll area or in the payroll control record:

- In the payroll area
  - Period parameters [Seite 36]
  - Date modifier [Seite 37]
- In the appropriate payroll control record
  - Payroll period [Seite 38]
Period Parameters

Definition

A two-digit numerical parameter that determines the time interval for which payroll is run for a payroll area.

If you assign the period parameter 01 to the payroll area Salaried Employee, payroll is run monthly for this payroll area. If you assign the period parameter 03 to the payroll area Industrial Employee, payroll is run weekly for this payroll area.

Use

The SAP standard system contains period parameters for all the common payroll periods for different countries. However, if you need an individual period parameter for your system, specify this in Customizing for Payroll under Environment → Payroll Organization → Define Period Parameters [Extern].

In Customizing for Payroll under Environment → Payroll Organization → Check Payroll Area [Extern] you assign a period parameter to every payroll area in your system. In this way you determine how frequently regular payroll should be run for this payroll area. You can assign the same period parameter to all payroll areas, if the payroll periods are the same for all employees in your enterprise.

In your system, you must use Report RPUCTP00 (Generation of Payroll Periods) to generate the payroll periods for every period parameter that you have assigned to a payroll area. In this way you determine the concrete start and end date for each period, as well the payday. You generate the payroll periods in Customizing for Payroll under Environment → Payroll Organization → Generate Payroll Periods [Extern].

When you start payroll, enter the payroll area for which you want to run payroll on the payroll driver selection screen. The system derives the payroll period from the period parameter you assigned to this payroll area.

Integration

If you want to specify different date specifications, for example different paydays, for a period parameter, then you also have to define a date modifier [Seite 37].
Date Modifier

Definition
Differentiator that you use to determine different paydays for different employees for whom payroll is run with the same periodicity.

Payroll is run monthly in your enterprise. The payday is the 15th of the month for industrial employees and the 25th for salaried employees. Since the payroll periodicity (monthly) is the same for both groups of employees, the system requires two date modifiers [Extern] as differentiators to be able to determine different paydays.

Use
You determine the date modifiers in Customizing for Payroll under Environment → Payroll Organization → Define Date Modifiers [Extern].

You assign a date modifier to every payroll area in your system in Customizing for Payroll, under Environment → Payroll Organization → Check Payroll Area [Extern].

- If you use the same payday for all payroll areas, assign the SAP standard modifier to all payroll areas.
- If you use different paydays for different payroll areas, assign different date modifiers to these payroll areas that you have created for your enterprise.

In your system, you must generate the payroll periods separately using Report RPUCTP00 (Generation of Payroll Periods) for every combination of period parameters and date modifiers that you have assigned to a payroll area. You generate the payroll periods in Customizing for Payroll under Environment → Payroll Organization → Generate Payroll Periods [Extern].

When you start payroll, enter the payroll area for which you want to run payroll on the payroll driver selection screen. The system recognizes, by means of the date modifier that you assigned to this payroll area, whether different date specifications exist for this payroll area.

Integration
A date modifier always refers to a period parameter [Seite 36].
Payroll Period

Definition
The time interval for which the payroll is regularly performed. In the abstract sense the payroll period refers to the interval during which payroll is regularly performed. For example, weekly or monthly payroll periods. In the concrete sense the payroll period describes a specific period with start and end dates. For example, the (monthly) payroll period from 01 through 31 October.

Use
You specify the concrete payroll periods, with a period number, start and end date and pay day, for your enterprise in Customizing for Payroll under Environment → Payroll Organization → Generate Payroll Periods, using Report RPUCTP00 (Generation of Payroll Periods). The generation of the payroll periods is dependent on the period parameter and the date modifier. The report enters the start and end date of every payroll period in Table T549Q (Payroll Periods) and enters the payday in Table T549S (Personnel Date Specifications Per Payroll Period).

The system automatically creates the payday for all countries when you generate the payroll periods. However, the payday only has a role to play in some countries. For example, if the bank transfer day of the original payroll run (as opposed to a retroactive accounting run) is important for tax purposes.

In some countries the payday is printed on the pay check. The employee can cash the check from this date.

When you start payroll, enter the payroll area for which you want to run payroll on the payroll driver selection screen. Using the payroll control record for this payroll area, the system determines the next period for which payroll is to be run. The procedure is as follows:

1. The system reads the current value that is contained in the Payroll Period field of the payroll control record.

2. Using this value the system reads the Previous Payroll Period field in Table T549Q (Payroll Periods).

3. The system determines which period follows this previous period in accordance with Table T549Q. This subsequent period is the current payroll period.

4. The system also determines the concrete start and end date of the payroll period in Table T549Q.

You have created this date specification with Report RPUCTP00.

Finally, the system reads the relevant infotypes using the date specifications for the start and end dates.
Integration

The payroll periods are defined in the SAP System and are dependent on the period parameter [Seite 36].

In your enterprise, the first payroll period for the year 2000 begins on 01 January. Depending on the period parameter you use as a basis, for example weekly or monthly, the payroll period 05 2000 can have the following meaning:

- Weekly period parameter: Period 05 2000 = 31 January-06 February 2000
- Monthly period parameter: Period 05 2000 = 01-31 May 2000
Period Number

Definition
A two-digit numerical parameter that, together with the date, clearly identifies a concrete payroll period [Seite 38].

The period number [Extern] 08, together with the year 2000, denotes the eighth payroll period in the year 2000. It can depend on the system settings, for example, the calendar month August or the week from 14 through 20 February.

Use
In the payroll control record, the system continuously increases the period numbers of the payroll periods for a fiscal year. Every time you set the status of the payroll control record to Release for Payroll, the period number is increased by one. In this way the system identifies the current payroll period. At the start of a new fiscal year the period number is reset to 01.

The period number that a payroll period contains depends on the following criteria that you enter when generating the payroll periods.

- Period parameter (for example, weekly or monthly)
- Start of fiscal year
  - In most countries the fiscal year starts on 01 January. However, it starts on 06 April in the United Kingdom.
- Indicator for determining the period number
  - This indicator specifies the payroll period date the system should use to determine the period number.
    - Start date
    - End date
    - Payday

Example

Example 1
You make the following specifications when generating the payroll periods:

- Period parameter monthly
- Start of fiscal year 01 January
- Determine the period number depending on the end date of the payroll period.

In this case, the payroll period from 01 through 31 July, for example, has the period number 07 in your system.

Example 2
You make the following specifications when generating the payroll periods:
**Period Number**

- Period parameter *weekly*
- Start of fiscal year 01 January
- Determine the period number depending on the payday
  
  The payday should be four days after the end of the period.

In this case, the payroll period from 01 through 07 January, for example, has the period number 02 in your system. The period from 25 through 31 December of the previous year has the period number 01, because the payday for this period is 04 January.
Retroactive Accounting

Use

If you change the master or time data for an HR master record for a period for which payroll has already been run, the old payroll results must be checked in the next regular payroll run and the payroll run must be repeated. The system automatically creates a retroactive accounting run in the payroll past.

To ensure that not every change triggers a retroactive accounting run, the changes are checked for retroactive accounting relevance. This ensures that only those changes that require a correction of the payroll results, trigger a retroactive accounting run. Moreover, the system determines the retroactive accounting limit for which retroactive accounting can take place, from the Payroll Status infotype (0003) and the payroll control record.

Scope of Function

The retroactive run is limited by basic data:

- Payroll past

  The payroll past includes all periods for which you have already run and exited payroll.

- Retroactive accounting limit

  The retroactive accounting limit determines the date up to which you may change master and time data in the payroll past, and, in the case of a retroactive run, the earliest date to which the system can run retroactive accounting. The retroactive accounting limit always refers to personnel numbers.

You can change the retroactive accounting limit in the following ways:

- for an employee in the Earliest Possible Personal Retroactive Accounting Date field in the Payroll Status infotype (0003)
- for a payroll area in the Earliest Possible Retroactive Accounting Period field in the payroll control record (see Change Earliest Possible Retroactive Accounting Period [Seite 45])

The system uses the following values to determine the retroactive accounting limit:

- for each payroll area, from the earliest possible retroactive accounting period that is stored in the corresponding payroll control record
- for each employee, from the earliest possible personal retroactive accounting date that is stored in the Payroll Status infotype (0003)
- for each employee, using the hiring date of the employee

The system uses these values to select the most recent date.

- Retroactive accounting relevance

  You can determine the retroactive accounting relevance either per infotype or per infotype field. To determine which infotypes or fields are relevant to retroactive
Retroactive Accounting

accounting, see Customizing for Personnel Administration under Customize Procedures → Infotypes → Define Fields Relevant for Retroactive Accounting [Extern].

If you edit infotypes that are relevant to retroactive accounting, you should take note of some particular features. For more information, see Payroll-Relevant Maintenance of HR Master Data [Extern].

- Retroactive accounting recognition

If you maintain an infotype that is relevant to retroactive accounting and its validity period overlaps with the payroll past, the system enters the start date of the changed infotype in the Earliest MD Change (Earliest Master Data Change since Last Payroll Run) field of the Payroll Status infotype (0003). During the next payroll run the system automatically performs retroactive accounting up to this date. Afterwards, the system deletes the entry.

The Earliest MD Change field can also contain a date that occurs in the future. This date is entered in an off-cycle payroll run [Extern].

If you have made at least one change in the payroll past that is relevant to retroactive accounting, the system checks the entry in the Earliest MD Change field and determines the date to which the retroactive accounting run must take place.
Earliest Possible Retroactive Accounting Period

**Definition**

The earliest period for retroactive accounting is the payroll period furthest in the past for which you can run retroactive accounting. This is stored in the payroll control record for the payroll area.

**Use**

This period is determined by your company. You can specify, for example, that retroactive accounting for the previous year is not possible after a particular date in the current year.
Changing the Earliest Possible Retroactive Accounting Period

You can only change the earliest possible retroactive accounting period for a payroll area, whilst exiting payroll [Seite 75].

1. From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Payroll → Tools → Control Record in the SAP menu.

2. Enter the payroll area for which you want to change the earliest possible retroactive accounting period and choose Change.

   The earliest possible retroactive accounting period can only be changed, after you have set payroll status to Exit payroll and before you save the payroll control record.

3. In the Earliest retroactive accounting period field, enter your new earliest retroactive accounting period and save your entries.
## Transaction Codes for Payroll

In Payroll, you can use the following transaction codes:

### Bases

<table>
<thead>
<tr>
<th>Transaction</th>
<th>Activity</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC00_M99_CLSTR</td>
<td>Display Payroll Results</td>
</tr>
<tr>
<td>PC00_M99_CALC</td>
<td>Payroll Driver (International)</td>
</tr>
<tr>
<td>PC00_M99_ABKRS</td>
<td>Specify a payroll area</td>
</tr>
<tr>
<td>PC00_M99_CLSTPC</td>
<td>Display PC Cluster: Personal Calendar</td>
</tr>
<tr>
<td>PC00_M99_TLEA</td>
<td>Leave Overview</td>
</tr>
<tr>
<td>PC00_M99_TLEA30</td>
<td>Batch-Input: Annual Leave</td>
</tr>
<tr>
<td>PC00_M99_CPRC</td>
<td>Access Payroll Calendar</td>
</tr>
<tr>
<td>PC00_M99_MOLGA</td>
<td>Specify a personnel country grouping</td>
</tr>
<tr>
<td>PC00_M99_CLJN</td>
<td>Payroll Journal - International</td>
</tr>
<tr>
<td>PC00_M99_DLGA20</td>
<td>Use of Wage Types in Payroll</td>
</tr>
<tr>
<td>PC00_M99_UDIR</td>
<td>Restore the Payroll Results Directory</td>
</tr>
<tr>
<td>PU00</td>
<td>Delete Personnel Data</td>
</tr>
<tr>
<td>PU01</td>
<td>Delete Current Payroll Result</td>
</tr>
<tr>
<td>PU03</td>
<td>Change Payroll Status</td>
</tr>
<tr>
<td>PU22</td>
<td>Archive Data</td>
</tr>
<tr>
<td>PU30</td>
<td>Wage Type Copier</td>
</tr>
<tr>
<td>PU95</td>
<td>Edit Wage Type Groups and Logical Views</td>
</tr>
<tr>
<td>PU96</td>
<td>Edit Wage Type Groups</td>
</tr>
<tr>
<td>PU97</td>
<td>Edit Logical Views</td>
</tr>
<tr>
<td>PU98</td>
<td>Assign Wage Types to Wage Type Groups</td>
</tr>
<tr>
<td>PUOC_xx (xx = Country Code)</td>
<td>Off-Cycle Workbench</td>
</tr>
<tr>
<td>PEST</td>
<td>Maintenance of Process Model</td>
</tr>
<tr>
<td>PUST</td>
<td>HR Process Workbench</td>
</tr>
</tbody>
</table>

### Pay scales:

<table>
<thead>
<tr>
<th>Transaction</th>
<th>Activity</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC00_M99_U510</td>
<td>Simple Std Pay Increase for Indirectly Valuated WTs</td>
</tr>
<tr>
<td>PC00_M99_IRTF</td>
<td>Enhanced Std Pay Increase (Indirect and Direct WTs) with Batch Input</td>
</tr>
</tbody>
</table>
## Transaction Codes for Payroll

### Pay Scale Reclassification acc.to Age or Pay Scale Membership Period

**PC00_M99_ITUM**

### Acknowledgement Report for Third Party Remittance

**PC00_M99_URMA**

### Update of Remittance Tables from TemSe-Object

**PC00_M99_URMU**

### Remuneration Statements

**PC00_M99_CEDT**

### Delete Form in Customer Client

**PDF7**

### Copy Form from SAP Client to Customer Client

**PDF8**

### Copy Form within Customer Client

**PDF9**

### Wage Type Statement

**PC00_M99_CLGA00**

### Wage Type Distribution

**PC00_M99_CLGV00**

### Payroll Accounts

**PC00_M99_CKTO**

### Conversion Report for Remuneration Statement Forms

**PDF0**

### Conversion of Payroll Journal Forms

**PDFA**

### Posting to Accounting: Create Posting Run

**PC00_M99_CIPE**

### Posting to Accounting: Wage Type Assignment - Display G/L Accounts

**PC00_M99_DKON**

### Posting to Accounting: Search for Payroll Results not Posted

**PC00_M99_CIPC**

### Reconciliation of Transfers

**PC00_M99_URMR**

### Maintain Wage Types According to Assignment to HR Creditors

**PC00_M99_URMW**

### Undo Third-Party Remittance Runs

**PC00_M99_URMD**

### Create Third-Party Remittance Posting Run

**PC00_M99_URMP**

### Cash Breakdown List (International)

**PC00_M99_CMLI0**

### Preliminary Program- Data Medium Exchange for Several Payment Runs

**PC00_M99_CDTA**

### Editor for Calling Functions and Operations

**PE04**

### Editor for Calling Features

**PE03**

### Editor for Calling Personnel Calculation Rules

**PE02**

### Editor for Calling Personnel Calculation Schemas

**PE01**

### Call the Form Editor

**PE51**
## Transaction Codes for Payroll

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PU12</td>
<td>Interface Toolbox</td>
</tr>
<tr>
<td>PDSY</td>
<td>HR-Documentation Maintenance</td>
</tr>
</tbody>
</table>
Retroactive Accounting Australia

Use

Changes to an employee's payroll data in a past payroll period trigger a retroactive payment calculation in the current period. This calculation either takes place automatically or you can force it in the payroll run.

During retroactive accounting, the system recalculates all of the employee’s pay for the affected period(s). The new figure is compared with the original payments that the employee received. The difference in net pay is carried forward and paid in the current payroll period.

The standard system processes retroactive calculations that affect net payments. SAP HR Payroll Australia has three additional functions that process retroactive changes to:

- Superannuation
- Taxation
- Leave accruals and entitlements

Features

Retroactive Superannuation Calculations [Seite 50]
Retroactive Tax Calculations [Seite 51]
Retroactive Changes to Leave [Seite 52]

See also:

Retroactive Accounting [Seite 42]
Retroactive Superannuation Calculations

Use
This function calculates compulsory and discretionary superannuation contributions retroactively.

Features
Retroactive superannuation contributions are split into two parts:

- Retroactive company contributions to super guarantee contribution (SGC) and superannuation funds
  - Super Guarantee Contribution Funds
    The difference in the superable earnings is carried forward to the period when the earnings are actually paid, that is, the current payroll period. The difference is added to the superable earnings of the current payroll period, and the super guarantee contribution is recalculated based on the new earnings figure.
  - Superannuation Funds
    The employer’s contributions are recalculated for the periods for which retroactive accounting is run. The new amounts are compared with the original contributions. The difference in the employer’s contributions is carried forward to the current payroll period and contributed in this period.

- Retroactive employee contributions to superannuation funds
  The employee’s contributions are recalculated for the periods for which retroactive accounting is run. The new amounts are compared with the original contributions. The employee contributions are processed like any other deduction and are carried forward as a difference in net pay in the current payroll period.
Retroactive Tax Calculations

Use
The standard system lets you recalculate tax during a retroactive payroll run. The retroactive payments are taxed in the period in which the payment was originally made.

Integration
Retroactive tax calculations in the original payroll period are processed using the standard SAP retroactive accounting function.

Features
Retroactive tax payments are calculated in the period of the original payment as opposed to the current period. This means that if additional pay or less pay is calculated for a retroactive period, the system recalculates the taxable gross for the original period and taxes the new amount in that period. The standard SAP retroactive accounting function is then used to report on the retroactive tax payments or refunds.

Example
An employee receives a salary of $2,000 per month of which $391,10 is deducted in tax. You are currently running payroll for period 02 and the employee receives a pay increase of $100 backdated to period 01.

Period 01 is recalculated and tax is applied to the new salary amount of $2,100 to give $426,40 in tax. The system calculates the net difference between period 01 in 01 and 01 in 02. The net in period 01 in 01 is $1608,90 ($2000,00 - $391,00), and in period 01 in 02 is $1673,60 ($2100,00 - $426,40). The net difference of $64,70 is then assigned to wage type /552, carried forward to period 02 and added to the net in period 02.

See also:
Retroactive Accounting [Seite 42]
Retroactive Changes to Leave

Use

When a payroll run involves retroactive calculations, the system checks for retroactive changes that may have occurred in leave processing. If there are any differences between the original result and the new result, the system makes the necessary adjustments to accrual and entitlement values.

Features

- Retroactive changes to leave accrual
  
  Leave accrual differences can occur in a retroactive accounting run if adjustments have been made to an employee’s leave types or changes have been made to the leave rules table since the original payroll run.

  Leave accrual recalculation is performed by leave processing whenever a retroactive payroll run is performed. The new payroll results contain the new leave accrual values to be used in the next payroll run.

- Retroactive changes to leave entitlement

  Leave entitlement rollover differences can occur in a retroactive payroll run if adjustments have been made to an employee’s leave types or changes have been made to the leave rules table since the original payroll run.

  The system recalculates leave entitlements whenever a retroactive payroll run is performed. If there are differences between the original leave results and the new leave results, the leave recalculation function creates adjustment leave update records.

  The recalculation adjustment can be to:
  
  - Adjust the original entitlement rollover value
  - Cancel the original entitlement rollover
  - Create an entitlement rollover

  The adjustment leave update records are then picked up by and processed in the batch update process.

See also:

Leave Batch Updating [Extern]
The Payroll Process

Purpose

The payroll program is run at a specific point in time, not only to calculate an employee's basic remuneration but also any special payments, overtime payments or bonuses that must be effected for the period in question.

Prerequisites

Before you start this process, you have to specify for which payroll area(s) payroll should be run. You have the following options:

- From the SAP Easy Access screen, choose Human Resources → Payroll → <Country> → Settings → Set Payroll Area.
- When Releasing the Payroll Run [Seite 64] specify for which payroll area the payroll should be run.
- If you want to execute a payroll run for several payroll areas at the same time, you must release each payroll area individually- release individually [Seite 65].

If you do not want to perform payroll for an employee, you must use the Lock Personnel Number [Seite 58] function.

Before you start the payroll run for all employees, you can run a Payroll Simulation [Seite 59] for individual employees.

Process Flow

The status of the Payroll Control Record [Seite 56] is automatically updated with every step that is carried out during payroll.

1. You release one or several Payroll Areas [Seite 34] for payroll.
   The system increases the period number in the payroll control record of the respective payroll area by 1. You cannot change the master and time data for the personnel numbers belonging to this payroll area if it affects the payroll past or present. Changes affecting the future are still possible.

2. You run payroll.
   The system calls up a country-specific payroll program. It determines the current payroll period from the payroll control record and performs payroll using the values you entered in the payroll program.
   In general, you do not carry out these steps on-line but rather as a background job.

3. You check whether payroll has run correctly, or determine where errors have occurred.
   If the payroll has not run without errors, the system display error messages indicating where the errors have occurred. If desired, you can obtain a detailed payroll log. However, we recommend that you only create a payroll log if you simulate the payroll run.
   If necessary, you can set the status of the payroll to Check Payroll Results during this phase. This way you make sure that no changes are made to payroll-relevant data which could affect the payroll past or present. In addition, the payroll area in question is locked.
for payroll. However, during this phase you can simulate the payroll for individual employees to understand exactly how the errors originated, by means of the payroll log.

If you want to carry out a spot check on the payroll results after a successful payroll run, there is a report available which reads the stored payroll results. The report allows each employee to see the contents of all internal tables containing payroll results. This allows you to check all partial results for a payroll run. In this way you can determine whether the system ran the payroll in accordance with your expectations, for example, for an employee for whom you made complex changes to the master data.

4. You correct master or time data for personnel numbers which contain errors, and which the payroll program could not process.

During the payroll run, the System flags the Payroll Correction field in the Payroll Status infotype (0003) for all rejected personnel numbers. When you correct master or time data for a personnel number, this field is also flagged. These personnel numbers are grouped together in a list under Matchcode [Extern] W (Payroll Correction Run). In a payroll correction run, that is a payroll run with matchcode W, payroll only takes place for the corrected personnel numbers.

5. You release payroll again.

The payroll period does not change.

6. You perform a payroll correction run.

If there are a lot of employees stored in Matchcode W (Payroll Correction Run), you carry out this step as a background job in the same way that you carried out the Start Payroll step. If you only have to run payroll again for a few employees, you can carry out this step on-line.

7. You simulate the posting to Accounting.

Under certain circumstances errors can occur, which mean you must change the payroll-relevant master and time data again. If, for example, a cost center was entered for some employees and it has been deleted in the interim, the system will note this as an error during the posting simulation. Then set the payroll status to Release for Correction once again, and correct the master data for the employees in question. This will cause these personnel numbers to be automatically stored in Matchcode W (Payroll Correction Run). Next, carry out another payroll correction run and simulate the posting to Accounting again.

8. You exit payroll. The personnel numbers for the payroll area can be processed again.

You can only exit payroll when the payroll has run successfully for all personnel numbers in the selected payroll area. This means that payroll is finished for all of the personnel numbers in the payroll area, including the rejected personnel numbers, and the payroll period is complete.

Result

You have run payroll for all the personnel numbers in a payroll area or in several payroll areas.

You can carry out the following steps in the payroll:

- Create a Remuneration Statement [Seite 546]
Wage and salary payments

Wage and salary payments differ from country to country. You can find country-specific information under Payroll <Country> → Subsequent Activities → Wage and Salary Payments.

Posting to Accounting [Seite 576]
Payroll Control Record

Definition

Payroll object that is important for the payroll run, and which contains all the information on a payroll area [Seite 34].

Use

The payroll control record [Extern] has the following functions:

- It locks the personnel numbers, for which payroll should be run, against master data changes that affect the payroll past or present.
- It locks the payroll for the period during which payroll-relevant changes are made to the master data for the personnel numbers being processed.
- It makes the following information available for the system:
  - What is the next payroll period for which regular payroll should be run?
  - Up to what date is retroactive accounting [Seite 42] carried out?
  - What status does the payroll currently have? (for example, Released for Payroll or Check Payroll Results)?

When you carry out a payroll run, the system automatically changes the payroll status in the payroll control record. You can also change the status manually under Payroll → Tools → Control Record.

Structure

The control record contains the following information:

- Payroll area
- Payroll status
- Payroll period
- Earliest possible retroactive accounting period [Seite 44]
- Last change made to the control record

⚠️

When you create the control record in your live system, please note the following: the payroll period that you enter at the start of the live payroll run must be 1 period lower than the period with which you want to perform the live payroll run for the first time.

You want to carry out the first payroll run in period 5 1999. In the payroll control record, you must enter 4 1999 as the period. If you set the payroll control record for the first payroll run to status Released for Payroll, the system increases the period by 1 and payroll is run for period 5 1999.
Locked Personnel Numbers

In the Payroll Status infotype (0003) [Seite 30] you can exclude an employee from the payroll run by flagging the *Pers.no. locked* field.

You can **not** set these lock indicators for the current period in the following situations:

- if payroll has already been completed for the current payroll period.
- if the employee has already been paid in the current payroll period.
Simulating Payroll

Use

You can simulate payroll for individual employees before performing the regular payroll run for all the employees in your enterprise. This is, for example, a good idea, if you have made complex changes to an employee’s master data, which may lead to far-reaching changes in his or her payroll results. In this way, you recognize sources of errors in time to make corrections before the regular payroll run. You can even simulate payroll for individual employees at any time during the regular payroll process, in order to trace the cause of any errors.

⚠️

Is it not necessary to simulate payroll for all employees before every regular payroll run. You can also make corrections at any time during the process of the regular payroll run [Seite 53].

Scope of Function

A simulation run corresponds to a regular payroll run with the following restrictions:

- The results of a simulated payroll run are not saved on the database. You can view and print the results in the payroll log.
- The system does not lock any master data.
- The current payroll period in the payroll control record is not changed.
- The steps Release payroll and Exit payroll do not apply.

Activities

1. From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Payroll → Simulation in the SAP menu.
   
   You access the initial screen of the payroll program. The Test Run (No Update) indicator is set and cannot be changed.

2. Enter the necessary data and choose Execute.
Displaying the Payroll Log

Use

The payroll log gives you clear detailed information on the payroll run and its results. It is divided into different levels that you can display depending on the amount of detail required.

The General data level gives information on the processed data and shows the payroll schema used by the system. The Successful personnel numbers and Rejected personnel numbers include processing of the schema for each personnel number. This expands the Rejected personnel numbers level. However, you can also create and save your own view variants. You can find more information under creating and processing display variants for the payroll log [Seite 63].

If you run payroll in a background operation [Seite 92], you should not switch on the log display as the spool might "overflow". The system still prints data on the schema used, the personnel numbers rejected, and the statistics that appear as the last main level in the log.

Scope of Function

- In the display we differentiate between the log tree and the actual log that you find under Settings → Detailed view.

- The color legend under Utilities gives information on the levels that the log tree displays and the log is divided into.

- Navigation in the log tree.
  
  To display lower levels, click on the structure node belonging to the level that you wish to open. To display all levels behind a higher level, place your cursor on the relevant level and choose Expand.

- Navigation in the log tree.
  
  To display the actual log, call the detailed view of the log by double clicking on the Payroll log in the log tree or on the level of the log that you wish to display.

- You can search in the payroll log [Seite 62] for certain terms, for example, for a wage type name.

- For documentation on functions, personnel calculation rules and schemas select the relevant object and choose Information.

- Old log

  If you use customer functions with their own logs, you can display these logs by clicking on the Old log pushbutton.
You can **not** use this pushbutton to switch to the log display that was valid until Release 4.0.
Searching in the Payroll Log

Use

In the payroll log, you can search for errors or use the search to find out what happened during the process. You can, for example, trace the processing of a wage type in the payroll process.

You can either search in the log tree or in the detailed view of the log.

Prerequisites

You are in the Display log tree screen.

Procedure

Searching in the Log Tree

1. In the standard function bar, choose Search.
2. Enter a search term.
3. Specify if you want to search in the complete log tree or only in the nodes of the log tree that are currently expanded.
4. Choose Search. The system places the cursor on the first line containing the search term.

Searching in the Detailed View of the Log

1. Choose Settings → Search in log and make the entries required.
   - If you search according to wage type, select Also search tables.
   - If you want to display the path that you must choose in the log tree to get to the search term, select Detailed display of hit.
2. In the application function bar, choose Search.
3. Enter a search term, restrict the search area, for example, to certain personnel numbers and choose Search.
   A list of hits is displayed.
4. Choose one or more hits and choose Search. The search terms are displayed in context.
   - You can expand the displayed levels individually. To expand all levels, choose Expand.
   - To display processing within a personnel calculation rule, place your cursor on the relevant line and choose Expand, or display the rule by double clicking on it.
Creating and Processing Display Variants for the Payroll Log

Use
You can create and save variants to display the log and the log tree in a certain way. In this way you can, for example, specify that certain levels of the log tree are already expanded. In the standard system, the display of rejected personnel numbers is always expanded.

Prerequisites
You are in either the Display log tree screen or the Detail view of log screen.

Procedure
2. In the Log Tree Settings dialog box, define a view variant on the tab pages and choose Enter.
   The log tree is displayed in accordance with your settings.
3. Depending on whether your display variants should only apply for the log tree, or if they should also apply for the detailed view of the log, you proceed in the following way:
   - If you only want to specify the log tree display in your variant, choose Settings → Save as variant.
   - If you also want to specify the detailed view display in your variants, proceed in the following way:
     a. Choose Settings → Detailed view.
     b. On the tab pages in the Detail View Settings dialog box, define a view variant and choose Enter.
     c. Choose Settings → Save as variant.

Result
You can display the log tree and the detailed view in the saved display variants. You have the following options:

- When simulating or executing payroll, you specify your display variant in the field Display variant for log in the selection screen of the payroll program.
- First of all, you create the log and then define your display variants in the Display log tree screen. Choose Settings → Get display variant.

To delete a variant, choose Settings → Delete display variant and double-click on the variant you want to delete.
Releasing Payroll

Procedure

1. From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Payroll → Tools → Release Payroll in the SAP menu.

2. Specify the payroll area for which you want to release payroll and choose Continue.

   If you have already specified the payroll area using Settings → Set payroll area, the system releases payroll for this payroll area.

Result

You can run payroll [Seite 66] for this payroll area.

The system has increased the period number in the payroll control record for the payroll area by 1. The payroll control record is used to lock the personnel numbers in the payroll area for changes to the master and time data reflecting the past and present.
Releasing Several Payroll Areas

Use
If you want to execute a payroll run for more than one payroll area at the same time, you must release each payroll area individually. The easiest way to do so is to use the relevant payroll control record for the payroll result.

Procedure
1. From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Tools → Control Record in the SAP menu.
   You access the initial screen of the payroll control record.
2. Enter the payroll area for which you want to release payroll and choose Change.
3. Set the payroll status to Released for payroll and save the payroll control record. Return to the initial screen of the payroll control record.
4. Repeat steps 2 to 4 until you have released all the necessary payroll areas.

Result
You can perform payroll for all the payroll areas that you have released for payroll.
Running Payroll

Prerequisites
You have released the payroll area or areas for which you want to run payroll.

You usually perform this step as a background job. For more information, see payroll in a background operation.

Procedure
1. From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Payroll → Start Payroll in the SAP menu.
   
   You access the selection screen of the payroll program.

2. Enter the data required.
   
   The current period indicator is set in the Payroll period group. Depending on the payroll area specified, the system reads the current period from the payroll control record.

   If you flag Display log, you get a detailed payroll log after the payroll run. However, this is usually only a good idea if you simulate payroll for individual employees and want to accurately trace the calculations made in the process. If you perform payroll as a background job, you should not create the log as vast quantities of data are created.

   The Test run (no update) indicator must not be flagged because otherwise the system will not save the payroll results.

3. Choose Program → Execute or Execute and print.

Result
The system performs payroll (usually in the background). If errors occur, you will get a list with the relevant error messages after payroll.

Use the error messages to check whether personnel numbers have been rejected or not selected.

In some situations, it is difficult to exactly trace the origin of an error using only the error message. If you can not tell how the error occurred from the error message, you can simulate payroll for the relevant employee a second time and create a payroll log. The log enables you to exactly trace all calculations and makes determining the error a lot easier.
The R/3 System stores the employees rejected during a payroll run in Matchcode W. To check which employees are stored in Matchcode W, you can display the personnel numbers not included in the payroll run [Seite 68].

⚠️

If personnel numbers are rejected or not selected, you must not exit [Seite 75] the payroll program. You must correct [Seite 69] the master and time data for the relevant employee and finally perform a correction run [Seite 70].

If you make a qualified advance payment [Seite 86], you must not exit the payroll program. The system treats an advance payment in a similar way to a correction.
Displaying Personnel Numbers not Included in the Payroll Run

Use

The system saves all the personnel numbers for a payroll area, which could not be included in the payroll run for the current period due to incorrect data, in Matchcode W (*Payroll Correction Run*). You can use this procedure to check which employees are saved in Matchcode W.

> You can also find Matchcode W (*Payroll Correction Run*) on the selection screen of the payroll program under *Search help*.

> Personnel numbers rejected for other reasons (for example, because payroll has already been performed for them in the selected period) are not stored in Matchcode W.

Procedure

1. From the *SAP Easy Access* screen, choose *Payroll* → *Payroll <Country>* → *Tools* → *Control Record* in the SAP menu.
2. Specify a payroll area and choose *Display*.

Result

The system shows all the personnel numbers for the payroll area that were rejected in the payroll run due to incorrect data.
Correcting Payroll-Relevant Master and Time Data

Prerequisites
You have run payroll [Seite 66], resulting in errors.

Procedure
1. From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Payroll → Corrections in the SAP menu.

   The system sets the payroll status for the payroll area to Released for correction. Master and time data processing for the personnel numbers in the payroll area has been released again.

   If you want to set the payroll run for several payroll areas to Released for correction, it is easier to use the payroll control record to do so. To do so, proceed as when releasing several payroll areas [Seite 65].

2. Choose Human resources → Personnel management → Administration → HR master data → Maintain.

3. Correct the relevant infotypes.

Result
The system has saved all employees for which you have changed payroll-relevant master or time data in this correction phase of payroll in Matchcode W (Payroll correction run).

After you have completed the corrections, release payroll [Seite 64] a second time. The personnel numbers in the payroll area are again locked for past and future changes to the master and time data.

Finally, you perform a payroll correction run [Seite 70]. If errors occur a second time, repeat these steps until payroll has been performed for all personnel numbers and Matchcode W is empty.

   You can only end the payroll run when Matchcode W no longer contains any personnel numbers.
Performing a Payroll Correction Run

Prerequisites

The system has stored personnel numbers not included in the payroll run [Seite 68] in Matchcode W (Payroll Correction Run). You have performed corrections [Seite 69] for the relevant employees and finally released [Seite 64] payroll a second time.

If only a few employees are saved in Matchcode W (Payroll Correction Run), perform this step on-line. If it was not possible to perform payroll for many employees or if you have made corrections for many employees, you can perform the correction run as a background job. For more information, see payroll in a background operation [Seite 92].

Procedure

1. From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Payroll → Start Payroll in the SAP menu.
   
   You access the selection screen of the payroll program.

2. Specify a payroll area and choose Search help.

3. Select Matchcode W (Payroll Correction Run).
   
   The Restrict value area dialog box appears.

   To further restrict the value area, you can specify an individual personnel number or an interval of personnel numbers. Only the personnel numbers corresponding to these values are selected from the payroll correction run.

   If you do not want to further restrict the value range, all the personnel numbers from the payroll correction run are selected for payroll.

4. Choose Continue.

5. Choose Program → Execute or Execute and Print or Execute in Background.

Result

The system only performs payroll for the personnel numbers that were saved in Matchcode W (Payroll Correction Run).
Checking the Payroll Results

Use
After a successful payroll run, you can check the payroll results for your employees on a random basis. This can, for example, be recommended for employees for whom you have made a complex change to the master data.

In such cases, we recommend that you simulate the payroll run for the relevant employees before starting payroll for all the employees. In this way, you recognize possible sources of errors in time and can make corrections before the payroll run.

You can check the payroll results for an employee using the report Displaying the Payroll Results (H99_DISPLAY_PAYRESULT). You can use this report to display the contents of all tables in which the system has saved data for the employee’s payroll result.

Prerequisites
You have run payroll for one or several payroll areas.

Procedure
1. From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Payroll → Check result in the SAP menu.

   The system locks the payroll program for the payroll area and prevents master and time data relevant to payroll from being processed. This prevents a new payroll run from being performed or master and time data relevant to payroll from being changed.

   if you want to check the payroll run for several payroll areas, it is easier to use the payroll control record. To do so, proceed as when releasing several payroll areas.

2. Choose Tools → Display results.

   You access the initial screen of the report Display Payroll Results.

3. Enter the necessary data and choose Enter.

   The system displays a list of the selected personnel numbers.

4. By clicking on a personnel number, access the list of accompanying payroll results.

5. By double-clicking on a payroll result, call the list of tables in which data for this payroll result is stored.

6. By double-clicking on a line, call the contents of the table that you wish to check.

Result
You have checked in detail whether payroll was performed correctly for one or more employees.
Checking the Payroll Results
Simulating a Posting Run

Use

We recommend that you simulate a posting run both before and after completing payroll. In this way, you can recognize posting-relevant errors in the payroll results early on, and avoid errors when creating a live posting run.

You can repeat simulation of posting runs as often as you require, as this does not, unlike creating a live posting run, lead to the payroll results being selected.

You have two options for simulating a posting run:

- Creating a **test run** without posting documents (limited check). The system performs the following activities:
  - It selects the payroll results.
  - It determines the posting-relevant information and the wage types to be posted.
  - It determines the symbolic accounts and the employee grouping for account determination.

    In this way, the system creates individual items, which, unlike the posting documents for a simulation run, are not saved. The system finally checks if the balance of these individual items is equal to zero for each payroll result.

- Creating a **simulation run** with posting documents (complete posting). The system performs the following activities:
  - It creates a posting run and marks it as being a simulation run. For this reason, the system does not post the posting documents for this posting run.
  - The posting documents are put through the same checks as the posting documents from a live posting run.

Simulating A Posting Run before Finishing Payroll

Before completing payroll, you should create a simulation run to recognize posting-relevant errors in the payroll result early on. If you do not want to create a simulation run at this stage, you should at least create a test run.

Simulating A Posting Run after Finishing Payroll

After finishing payroll, you should create a simulation run in order to check the posting documents (this may have to be approved by Accounting). Remove any possible causes of errors and repeat creation of the simulation run, until technically correct posting documents with the right contents are created. You should only create a live posting run at this point in time.

Procedure

You proceed as described in creating a posting run [Seite 621]. When doing so, bear the following special feature in mind:

- If you want to create a test run, enter the value T in the field *Document creation type* (in the *Run attribute* group box).
Simulating a Posting Run

- If you want to create a simulation run, enter the value $S$ in the field Document creation type (in the Run attribute group box).

If you want to have a complete log of a number of personnel numbers (selected for test purposes) that is easy to keep track of, set the Display log indicator in the Run attribute group box. We advise you against creating a complete log for a larger number of personnel numbers. Even if you do not set the Display log indicator, the system produces a log if there are errors for the personnel numbers affected.

Result if Successful

In the case of test runs, the system displays a detailed log if you have set the Display log indicator in the step Create posting run. If you have not set the Display log indicator, the system displays statistics for the evaluated personnel numbers.

In the case of simulation runs, the system creates a posting run and marks it as a simulation run. This prevents the accompanying posting documents being posted. The simulation run gets the status Documents created and is saved. The accompanying posting documents get the status created. An index is created for all processed payroll results. This ensures that the origin of a document item can be retraced, provided that the original payroll result has not been replaced as the result of a correction run. For more information, see Displaying Revision information [Seite 641]

Result if Unsuccessful

In the case of test runs, the system displays a log containing the relevant error messages.

In the case of simulation runs, various errors can occur:

- If an error occurs when selecting or processing the payroll results for individual employees, the system rejects the incorrect personnel numbers and does not include them in the document. The log contains a relevant error message.

- If an error occurs when creating the document, a relevant error message appears in the document display after the document has been created. The posting run gets the status Documents Incorrect. The accompanying posting documents get the status incorrect.

- Certain situations in which an error occurs (for example, rejection of all personnel numbers) can lead to no documents being created. In this case, the log contains the comment No documents created. The posting run gets deleted status.

Delete the simulation runs you no longer require to avoid creating unnecessarily large amounts of data. For more information, see deleting the posting run [Seite 637]
Exiting Payroll

Prerequisites
You have made all corrections [Seite 69]. If you have made a qualified advance payment [Seite 86], you have run payroll for all the wage and salary elements.

Procedure
From the SAP Easy Access screen, choose Payroll → Payroll <Country> → Payroll → Exit Payroll in the SAP menu.

⚠️
When you exit payroll, payroll is finished for all the personnel numbers in the payroll area and the payroll period is complete.

➡️
If you want to exit the payroll run for several payroll areas, it is easier to use the payroll control record. To do so, proceed as when releasing several payroll areas [Seite 65].

If you exit payroll using the payroll control record, you can simultaneously change the earliest possible retroactive accounting period for the accompanying payroll area. You use this date to specify until which date in the past it is possible to change master and time data for the employees in this payroll area and until which date the payroll program accounts retroactively for a retrospective change in master and time data.

As long as you have not performed the payroll run without errors, it is not a good idea to change the earliest possible retroactive accounting period. For this reason, you can only make entries in this field in the payroll control record after you have chosen End of payroll and before you save the payroll control record.

Result
You have finished payroll for the current payroll period. The personnel numbers for the payroll area can be processed again.
Displaying Payroll Results

Use
You can use report H99_DISPLAY_PAYRESULT to display the payroll results for any personnel numbers.

Integration
- You can access the display or maintenance of HR master data (Goto → HR Master Data → Display/Maintain)
- By selecting Tables → Loans → Display, you can also include loan wage types in the display. In this way report H99_DISPLAY_PAYRESULT replaces the report RPCLSTLO (Printout of Loan Results)

Scope of Function
- You can display the contents of all tables and field strings for any payroll cluster.
- You can temporarily save the selection of tables to be displayed, reducing the calling time.
- Archived payroll results are also displayed.

Selection
You can display the payroll results for several personnel numbers by choosing Multiple Selection. The system displays all the payroll results, for which the start of the for-period [Extern] or the end of the in-periods [Extern] come before the date specified.

Output
The personnel numbers entered so far are displayed on the left side of the screen. The formatted name from the Organizational Assignment infotype (0001) is displayed as a default. To display the sortable first and last names from the Personal Data infotype (0002), choose the First and Last Name pushbutton in the SAP list viewer (ALV) toolbar.

The symbol behind every name in the Results column shows if there are results available in the selected period.
- ✔ Results exist
- ☑ No results exist
- 🗣 You have no authorization to display personnel numbers

Information on the personnel numbers and country-specific information is displayed in the SAP list viewer (ALV).
- Overview of all the payroll results for a personnel number (cluster CU)
- Overview of payroll results tables
- Preselection of payroll tables
Inconsistencies that occur when reading the infotypes and the CU cluster for a personnel number

The contents of the payroll tables are printed in the form of the payroll log in a list.

**Activities**

You can perform the following activities using the report H99_DISPLAY_PAYRESULT:

- Displaying the personnel numbers in the SAP list viewer (ALV) Grid Control
  - By selecting **Personnel number → Name → Formatted last name/first and last name**, you can switch between the various ways of displaying the names
  - By choosing , you can delete the current personnel number from the selection of the displayed personnel numbers.
  - By choosing , you can delete all personnel numbers from the selection of the displayed personnel numbers. Choose *All*.
  - If the selection of current personnel numbers has gone missing (for example, because of a column selection), you can repeat this selection by choosing .

- **Overview of all the payroll results for a personnel number [Seite 78]** (Cluster CU)
  - You can save your own personal standard layout that is used at the start of every program for this overview. There is also a default layout for the relevant country-specific fields for every country. If you have not saved a standard layout, the system selects the default layout based on the personnel number and the country.
  - You can use the following functions for both the overview of the payroll results and the overview of payroll tables:
    - By choosing , you can save a line selection until you leave the program.
    - By choosing , you can delete the saved line selection.
    - You can redisplay a saved line selection by choosing .

- **Overview of the payroll results tables [Seite 79]**
Displaying the Payroll Results for a Personnel Number

Prerequisites
You are in the Display Payroll Results screen.

Procedure
1. In the Personnel number field in the Selection group, enter the personnel number or personnel numbers, for which you want to display the payroll results.
2. By making an entry in the All results from field, you can also specify the Valid from date for the displayed payroll results.
3. Choose Choose.

Result
The selected personnel numbers are displayed on the left of the screen. If you want to display an overview of all the personnel numbers for one of the selected personnel numbers, select the personnel number. The payroll results are displayed on the right of the screen.

You can directly display or process the HR master data for the selected personnel numbers using the path Goto → HR master data → Display or Goto → HR master data → Maintain.

For the displayed payroll results, you can now display the relevant tables [Seite 79].
Displaying the Overview of Tables for a Payroll Result

Prerequisites
You are in the Display Payroll Results screen and have displayed the payroll results for a personnel number.

If you have already saved a certain selection of tables for a payroll result, this selection is automatically displayed when you select a payroll result by double-clicking on it. The system then no longer displays the overview of tables for a payroll result.

Procedure
1. Select a payroll result and choose 
2. The system displays an overview of all the tables that are relevant for this payroll result and the number of entries in the table.

Only the tables that are relevant for the respective country for the employee are included in the overview of a payroll result.

You can also display tables that do not contain any entries for the selected payroll results. If you also want to display these tables, choose Tables → Empty tables → Display.

Result
The system displays an overview of the tables for a payroll result. You can now display the contents of the displayed tables.
Displaying the Tables for a Payroll Result

Prerequisites
You are in the screen Display Payroll Results and have displayed the overview of tables for a certain payroll result for a personnel number.

Procedure
Select one of the displayed tables and choose Print. You can also select several tables.

You access the screen Tables/field strings of payroll result and see the contents of the selected table for the relevant payroll result.

Result
You can print this table by choosing List → Print.

You can search for certain character chains in the table by choosing Edit → Find.
Error Search for Several Personnel Numbers: Example

Use
You suspect that there are inconsistencies in the payroll results for the personnel numbers 232323 and 454545.

Procedure
1. Display the tables in which you suspect there are errors for the personnel number 232323.
   You notice values that you also want to check for the personnel number 454545 in the tables Work Place Basic Pay (WPBP) and Payment Information (BT).
2. Select both tables and choose .
3. Enter the personnel number 454545 and double-click on the payroll result for which you want to display tables WPBP and BT.

Result
The tables required are displayed without you having to select them again.
Deleting the Last Payroll Result

Use
If you have performed payroll for an employee who should not have been included in the payroll run or for whom payroll should have been run differently (for example, if the system has performed a payroll run too far in the past), you can delete these payroll results. You can only delete the last payroll result.

⚠️ To correct errors that occur during payroll, you must **not** delete the payroll results for the respective employee. Instead, proceed as described in correcting payroll-relevant master and time data [Seite 69].

Prerequisites
You can only delete a payroll result in the following cases:

- The employee’s master data are no longer processed.
- Payment was not yet arranged for the employee.
- If you are working in a live system, the payroll control record for the payroll area to which the employee belongs should not yet have the status *End of payroll.*

Procedure
1. From the *SAP Easy Access* screen, choose *Payroll → Payroll <Country> → Payroll → Tools → Problem Solving → Delete Payroll Result* in the SAP menu.
2. Enter the personnel number and choose *Execute.*

   A list of all payroll results generated during the last payroll run is displayed. If payroll has only been run for the current period, the list contains only one entry. If the system has performed a *retroactive accounting run [Seite 42]*, the list contains several entries.
3. Choose *Delete* and confirm the system’s query.

Result
The system performs the following activities:

- The current payroll result is deleted. The previous payroll result becomes the current payroll result.
  
  If retroactive accounting runs were linked to the deleted payroll results, all the payroll results that were affected by this retroactive accounting run will be reset to the original status. That means that these payroll results get the status indicator A instead of the status indicator P that they acquired through retroactive accounting.

- The *Payroll Status* infotype (0003) is updated accordingly.

- The deletion of the payroll result is saved in a log, the application log. You can use the application log to display the deleted payroll results [Seite 84].
Displaying Deleted Payroll Results

You can check whether payroll results have been deleted, which payroll results have been deleted, and who deleted them.

Procedure

1. Choose transaction SLG1.
   
   The *Evaluate application log* screen appears.

2. In the *Object* field, enter HRPU.

3. In the *Time Restriction* group box, enter dates and times to determine the period you want to check.

4. Choose *Program → Execute*.
   
   A list of payroll results deleted during the specified period is displayed. The list displays the deletion date and the administrator who has deleted the payroll result.

5. Select an entry from the list.

6. Choose *Goto → Display messages*.
   
   Further details are displayed for the selected entry.
Advance Payments

Use
The SAP System differentiates between qualified and unqualified advance payments.

Qualified Advance Payments
With qualified advance payments, payroll takes place for some of the payroll elements in the first payroll run, and is transferred if necessary. The payroll run is not ended. Instead, it receives the Payroll Correction status. During the correction phase, you enter more payroll elements. In the subsequent payroll runs you carry out payroll for these remaining payroll elements and transfer them to your employees. The payroll program only finishes when accounting has been performed for all payroll elements.

Unqualified Advance Payments
Employees may receive an advance salary payment prior to the payroll run. In this case, only the employee’s master data is imported for the transfer. No payroll run is performed. Wage types entered in the following infotypes are taken into account:

- External Bank Transfers infotype (0011)
- Recurring Payments and Deductions infotype (0014)
- Additional Payments infotype (0015)

The transfer is effected gross for net, since there is no payroll run to calculate deductions such as taxes and social insurance contributions. Net accounting for the advance payment takes place during the payroll run, which is performed later. This type of advance payment is known as an advance payment on the basis of master data. The payroll run takes place at the end of the payroll period.

An unqualified advance payment is independent of the payroll period and is therefore considered a period-independent activity.
Qualified Advance Payments

Use

Make a qualified advance payment to carry out payroll and to transfer some of an employee’s payments during the current payroll period. Payroll and transfers occur several times within a payroll period.

An employee should receive the basic payments during the current period. Bonuses for overtime or holiday payment should be calculated and paid later.

First Payroll Run

- The Transfers wage type (1559) is found in the Bank Transactions (BT) table of the payroll cluster along with amount to be transferred from the basic payments.

Second Payroll Run

- In the payroll run the System compares the amount to be transferred from all the payments with the Transfers wage type (1559), which was formed in the first payroll run. The System determines the difference between both the transfer amounts and from this it forms the Payment of the Balance wage type (1558).

Integration

To transfer the amounts in connection with the payroll run, you start the preliminary program Data Medium Exchange (RPCDTAx0) by choosing the menu path Payroll → Bank Transfer.
First Transfer Run:
The Indicate Transfers indicator must be set. The Transfer wage type (1559) is then marked as transferred with the date and time.

Second Transfer Run:
You restart the preliminary program Data Medium Exchange. The System recognizes the amount from the Transfer wage type (1559) which has a time stamp as being already transferred and only transfers the amount from the Payment of the Balance wage type (1558).
Making a Qualified Advance Payment

Procedure

1. Release the payroll run (see Releasing the Payroll Run [Seite 64]).
2. Run payroll (see Run Payroll [Seite 66])
3. Make the advance payment (see the respective country-specific section Wage and Salary Payments under Payroll <Country> → Subsequent Activities).
4. Release the payroll for correction (see Correcting Payroll-Related Master Data and Time Data [Seite 69])
5. Enter the data for which you want to perform a payroll run separately.

When an advance payment is created, a flag is set for transferred wage types. You cannot change the payee data and transfer amounts for these wage types, which are flagged as already transferred, during the correction phase. The employee would otherwise be rejected in the payroll run after the correction phase.

6. Repeat steps 1 to 5 until you have entered all data for which split payroll must be performed.
7. Exit the payroll run (see Exiting the Payroll Run [Seite 75])

Result

You have effected a qualified advance payment and have transferred and run payroll separately for several of an employee’s payments.
Unqualified Advance Payments

Use
To give an employee an advance payment from the master data you carry out an unqualified advance payment. You can make advance payments without performing a payroll run. You simply start a transfer run, which reads the wage types from the following infotypes.

- **External Bank Transfers** infotype (0011)
- **Recurring Payments and Deductions** infotype (0014)
- **Additional Payments** infotype (0015)

During the transfer run a file is created, which contains the amounts assigned to these wage types. The file then creates transfer forms as transfer mediums for the bank or data mediums for data medium exchange. An unqualified advance payment is also known as an advance payment based on master data.

The transfer advance payment is an estimation of net pay, without deductions. At a later point, usually at the end of the payroll period, a normal payroll run takes place to calculate the net amounts for the advance payment. The wage types, which were transferred as part of the advance payment, must be included in the ordinary payroll run, but should be considered as already paid. To ensure this, the wage types permitted for above-mentioned wage types must be coded accordingly.

For more information on wage type coding [Extern], see The Implementation Guide.
Use
Creating a File for an Unqualified Advance Payment

1. In the payroll menu choose *Period-Independent → Reporting → Advance Payment.*

2. Enter the appropriate values in the fields and set the required indicators.

3. Flag the *Test* parameter.

   ![This Set flag for transfers parameter prevents the wage type amount from being overwritten and transferred more than once when the payment run is repeated. The system calculates the amount of the difference for the respective wage type in the new payment run instead.]

4. Choose *Program → Execute* or *Execute + Print* or *In Background.*

5. Use the log to check that transfer data is complete and correct. If necessary, correct the data.

6. Deselect the *Test* parameter and run the report again (see step 8).

   ![A process log is displayed after the report has run. The program run date and an identification feature appear below the process log header. Please make a note of both data. The Run Date and Identification Feature parameters are queried in the Create Transfer Medium step.]

7. Lastly create your *Payment medium [Extem]*

You have effected an unqualified advance payment.
Payroll in a Background Operation

Use
This function enables you to automate either the whole or parts of the payroll process. For example, you can let the system execute the payroll program overnight so that you can check the results the next morning.

Scope of Function
You have the following options for running payroll in a background operation:

- As a standard, you can schedule background jobs in the SAP System using the function System → Services → Jobs → Define Job. In this way you can let the payroll program you want to use to run payroll [Seite 66] run in the background. You can find more information in the Background Processing [Extern] section under Scheduling Background Jobs [Extern].

- You can use report RPCSC000 (Scheduler for Parallel Accounting) to split the personnel numbers into small sets and run payroll in parallel [Seite 93] in the background. In this way you reduce the payroll runtime.

- Using the Payroll Calendar [Seite 95] you can create and schedule payroll jobs.

- You can use a Process Model [Seite 98] to define the sequence of all programs that you need for payroll and its subsequent activities. When you start a Process [Seite 103] that is based on such a process model, the system automatically executes the program in the sequence you defined.
Parallel Payroll for Personnel Numbers

Use

If you have to run payroll for a large number of personnel numbers in a payroll period, you can use report RPCSC000 to split the personnel numbers into several background jobs. The system then processes the background jobs simultaneously, using different application servers.

Integration

Report RPCSC000 is used exclusively in Payroll.

Report RPCS0000 [Seite 552] can also be used if you want to run parallel evaluations for payroll.

Prerequisites

You must note the following prerequisites:

- The payroll program is called up using a symbolic name. You must define these symbolic names and the program names in view T596F.

- You must define a suitable program variant in the programs assigned to the symbolic names.

Scope of Function

You specify the number of personnel numbers to be included in the background payroll run, or how many background jobs should be created. Report RPCSC000 selects the personnel numbers to be included in the payroll run from the database, and groups them together in background jobs. You can release each background job for payroll separately, or you can release them together.

You can enter a short title for each payroll run. Each background job contains this short title and a sequential number. The short title can be helpful if you want to display the background jobs in the general job overview.

The program displays a log after the payroll run has been completed.
Parallel Payroll for Personnel Numbers

Prerequisites

You have defined the symbolic names to be used to call the payroll program and the program names in table T596F. You must use the following naming conventions: the symbolic name starts with CALC and contains the country modifier (for example, CALC02).

The system takes the first entry with the symbolic name into account and does not use the date in the table.

You have defined a program variant in the payroll program that is assigned to the symbolic name.

You are in the ABAP Execute Program screen.

Procedure

1. Enter Program RPCSC0000.
2. Choose Execute.
3. Enter the program and a variant.

   The system uses the payroll schema for the variant you have selected for the payroll run.

4. Enter the number of personnel numbers to be included in the parallel payroll run, or enter the number of jobs for which the payroll run should be split.

5. Choose one of the following steps:
   - Program → Execute
   - Program → Execute + Print
   - Program → Execute in Background

Result

The system performs payroll and prints a log. This contains the following information:

- Date and time of the individual program steps
- Error messages
- Warnings
- Overview of generated background processes

   You can clearly identify the jobs using the job numbers and the job names.
Payroll Calendar

Use
You can use the payroll calendar to create payroll jobs and follow how they are executed. The payroll jobs are grouped into tasks according to payroll areas.

Prerequisites
In Customizing for Payroll under Payroll Calendar the following settings must be made:

- Define Schedule for Payroll Calendar [Extern]
- Specify Version for Payroll Driver [Extern]

Scope of Function
The payroll calendar provides you with the following functions:

- **Job Scheduling:**
  
  To create payroll jobs call the **Scheduling of Payroll Jobs** report (RPCPRC10) using this function.

  The documentation for the **Scheduling of Payroll Jobs** report describes how you create a payroll job.

- **Calendar:**
  For example, in the calendar you can:
  - Change and Display Payroll Jobs and Tasks [Seite 96] that have been scheduled
  - display payroll jobs and tasks that have already been processed
  - schedule tasks, that you have already created using the job scheduling function, to occur at a later date
Changing and Displaying Payroll Jobs and Tasks

1. From the SAP Easy Access screen, choose Human Resources → Payroll → <Country> → Tools → Payroll Calendar in the SAP menu.

   You access the initial screen of the payroll calendar.

2. Enter a Schedule and choose Calendar.

   You access the Payroll Calendar <Schedule> screen. The calendar is displayed in two parts:
   - The upper section contains a calendar for three months, beginning with the month of the selected start date. Weekends, public holidays and the days for which payroll jobs are scheduled have a different background color.
   - The tasks for all dates are displayed in the lower part of the screen. These tasks contain the scheduled payroll jobs for a payroll area.

   The following functions, amongst others, are available on the Payroll Calendar <Schedule> screen.

<table>
<thead>
<tr>
<th>Function</th>
<th>Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display payroll jobs that have already been carried out.</td>
<td>Settings → Hist.data on</td>
</tr>
<tr>
<td>Hide payroll jobs that have already been carried out</td>
<td>Settings → Hist.data off</td>
</tr>
<tr>
<td>Display payroll jobs for a task</td>
<td>Double-click on the task</td>
</tr>
<tr>
<td>Display payroll jobs that are scheduled for a certain day, week or month</td>
<td>Double-click on the day, the week number or the name of the month</td>
</tr>
<tr>
<td>Schedule tasks, that you have already created using the job scheduling function, to occur at a later date</td>
<td>Edit → Schedule task</td>
</tr>
<tr>
<td>Delete task</td>
<td>1. Choose Environment → Configuration → Task</td>
</tr>
<tr>
<td></td>
<td>2. Choose Display → Change</td>
</tr>
<tr>
<td></td>
<td>3. Select the task that you want to delete and choose Edit -&gt;Delete</td>
</tr>
<tr>
<td></td>
<td>4. Go back to the Payroll Calendar &lt;Schedule&gt; screen and choose Refresh</td>
</tr>
</tbody>
</table>

3. To obtain further information on a payroll job and to change it if necessary, call the job overview by double-clicking on the payroll job. The following functions, amongst others, are available here:

<table>
<thead>
<tr>
<th>Function</th>
<th>Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display job definition</td>
<td>Job → Display</td>
</tr>
<tr>
<td>Display job steps</td>
<td>Job → Steps</td>
</tr>
</tbody>
</table>
### Changing and Displaying Payroll Jobs and Tasks

<table>
<thead>
<tr>
<th>Task</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cancel job scheduling</td>
<td>Job → Schedule job → Cancel</td>
</tr>
<tr>
<td>Delete payroll job</td>
<td>Job → Delete</td>
</tr>
<tr>
<td>Display spool list with the payroll log</td>
<td>Job → Spool list</td>
</tr>
<tr>
<td>Display job log</td>
<td>Goto → Job log</td>
</tr>
</tbody>
</table>
HR Process Workbench

Purpose
The HR Process Workbench enables you to automate payroll and the subsequent activities and to run them in the background. To do this, you create a process model containing the sequence of all programs to be started by the system. You can restart processes using this process model. When you start a process, the system runs all process steps, in other words, all programs included in the process model. These programs are run in a defined sequence.

Integration
You can use process models to

- Automate the complete regular payroll process [Seite 53] and subsequent activities, for example, the creation of remuneration statements [Seite 546] or posting to Accounting [Seite 576].
- Run off-cycle payroll [Seite 131]

Features

- You can reduce the process runtime by running programs in parallel.
- Processing of the programs can be easily monitored.
- You can check each personnel number during the complete process run.
- You can repeat single process steps, for example, if errors have occurred and you then correct the error.
- At any time, you can check which data is transferred from one process step to the next.
- You can specify that a message is sent in specific conditions.
Process Model

Definition
A process model defines a sequence of programs that automatically follow one another. The process run can be interrupted with breakpoints.

Use
Process models are used as templates for the execution of processes [Seite 103]. Several processes can be based on the same process model.

Structure
In the attributes, you use the personnel number selection program [Seite 106] to specify which personnel numbers are used in the process model.

You define the behavior of the program in the process model by specifying a program category that defines this program. The specifications for the program categories are documented in the system under Edit → Program category. You can assign any number of programs to a program category.
Technical Processing of a Process Model

Purpose
Process models are used as the basis for running processes [Seite 103].

Prerequisites
A workflow user must be set up in Customizing for Basis Components under Business Management → SAP Business Workflow → Maintain Standard Settings for SAP Business Workflow [Extern]. This enables the program to be executed correctly.

For more information on SAP Business Workflow, see BC – SAP Business Workflow – Navigation [Extern].

Process flow
1. The process starts with a selection program which determines the personnel numbers for processing. The selection program can either be started in the background or directly from the HR Process Workbench. It triggers a workflow event [Extern], starts the process, and transfers the process control to a function module, otherwise known as the Process Manager.

2. The Process Manager determines the next step, and starts the accompanying program in the background.

3. At the end of the program, control is given back to the Process Manager. The system checks the status of the process step and checks whether other steps follow. A container [Extern] transfers the information from one process step to the subsequent step. The content of the container is always saved so that the information on the individual steps is never lost.

4. The next program is started with the information from the container and from the results tables for the preceding program.

Result
An overview of the status for the individual process steps is displayed in the HR Process Workbench. A message can be sent to a particular person, depending on the definition of the individual process steps.
Process Model: Example

Personnel number selection

The selection program H99_SELECT_PERNR transfers the personnel numbers to be processed to the process model.

Programs

The program RPCALCX0 with selection variant SAP&PM99 belongs to the PY-Payroll program category.

Form printing and payment are processed together, therefore, the total runtime is reduced.

Sets of personnel numbers

The payroll program simultaneously processes sets of 500 personnel numbers and the transfer program processes sets of 1000 personnel numbers. This means that the runtimes of the programs are reduced.

Programs that process sets of personnel numbers can follow programs that do not split selected personnel numbers, and vice versa.

Breakpoint

The unconditional breakpoint interrupts the process each time it is run and before any documents are created.
Programs that select personnel numbers can only follow programs that also work on the personnel number level. For example, the payment program cannot transfer personnel numbers to the check printing program as a selection criterion. Only a program that does not select personnel numbers can follow the check printing program. The system documentation for the program categories specifies which categories select personnel numbers.
Process

Definition
Execution of programs defined in a process model [Seite 98] in a specified sequence.

Use
Each process is created in the HR Process Workbench using a process model and is assigned a unique number. The process comprises all steps defined in the process model. Closed processes are locked for changes, however they can still be displayed. This ensures that the complete process history is available.

If a process model is used periodically, you create a new process each time. The process ID uniquely identifies each process.

You use the same process model each month to create the bank transfer for an employee and print the forms. Each month you use the process model to create a new process. In December, you may need to use a different process model since additional evaluation reports are required at the end of the year.

Structure

You can check the processing steps using the Status Display [Seite 123] function.

Process step
Process

In a process step, a program is executed in the process model. The process step includes:

The program category, whose specifications have been defined in the process model [Seite 98].

The assigned program with a variant

You can repeat a process step as often as required. The subsequent program that processes the results of the process steps is then also repeated. You start and repeat [Seite 118] processes and process steps in the same way.

Run

A run is equivalent to starting or repeating a process step. The runs in a process step are displayed and numbered sequentially. If a process is repeated, all process steps will also be repeated.

Set

If personnel numbers are processed at the same time in a process step, the system groups together the personnel numbers into a set. The number of sets is determined each time the process step is repeated. The sets are assigned a sequential number, starting from 1 each time.

If the personnel numbers cannot be processed at the same time, they automatically form one set.
Breakpoint

Definition
Specifies whether a process must be interrupted. There are conditional and unconditional breakpoints.

Structure
A breakpoint is defined by a function module. SAP provides the function module HRPY_PROCESS_STOP_CONDITIONAL (conditional breakpoint) and HRPY_PROCESS_STOP_ABSOLUTE (unconditional breakpoint).

You can define your own conditions for a breakpoint in a function module. The function module interface has the following structure:

- Import parameter
  - IMP_PROCESSID LIKE T52SPS-PROCESSID (process object key)
  - IMP_STEPID LIKE T52SPS-STEPID (process step object ID)
  - IMP_RATE LIKE T52SMS-PERCENTAGE (percentage rate)

- Exception
  - STOP_PROCESS (If this exception occurs, the process is interrupted.)
Personnel Number Selection

Use
The process model must start with a program that selects the personnel numbers for the complete process run. Each process model starts with a specific selection program. You specify the selection program when you create the process model.

Integration
Personnel numbers that have not been selected using the selection program defined in the process model can still be included in a process containing payroll. For example, you can include new employees in a process. If the process is repeated, they are read from matchcode W [Seite 68].

SAP provides an international selection program H99_SELECT_PERNR.

If you use your own selection program, base it on the following structure. The given source text must remain.

REPORT MY_SELECTION_PROGRAM.
INCLUDE RPUPMDP1.
RANGE: PROCESS_EMPLOYEES FOR PERNR-PERNR.
DATA: This_report like sy-repid
...
START-OF-SELECTION.
This_report = sy-repid
CALL FUNCTION 'HRPY_PROCESS_INIT_SELECTION'
  EXPORTING
    IMP_PROGRAM     = This_report
  CHANGING
    CHAN_PROCESSID = STPROCID
    CHAN_STEPID    = STSTEPID
    CHAN_CONNECT   = CONNECT
    CHAN_CONT      = CONT
...
Specific processing: In the PROCESS_EMPLOYEES table, enter the personnel numbers to be processed.

END-OF-SELECTION.
CALL FUNCTION 'HRPY_PROCESS_CLOSE_SELECTION'
EXPORTING

IMP_PROCESSID   = STPROCID
IMP_STEPID      = STSTEPID
IMP_CONNECT     = CONNECT
IMP_CONT        = CONT

TABLES

IMP_PERNR_INDEX = PROCESS_EMPLOYEES

LEAVE PROGRAM.
Mail Connection

Use

During a process, the individual steps can have different statuses. When you create a process model, you can define the situations in which you are notified about the status of a process step.

You can send a message by mail or by pager. For more information on communicating by pager, see Sending Messages By Pager [Extern].

Features

You can send a message in the following situations:

- Some personnel numbers contain errors
- Some personnel numbers have no data
- Processing of a set of personnel numbers was canceled
- A step was completed
- The system stopped at a breakpoint
- The system did not stop at a breakpoint

There are standard texts for these mails. The texts are assigned when the process model is created. Each mail has an attachment. If you double-click this attachment, you access the HR Process Workbench at the place where the process was canceled.

Activities

When you create a process model, you specify who should receive the message and which standard text should be used for the mails.

To change the standard texts, from the SAP Easy Access screen, choose the SAP menu Tools → Form Printout → SAPscript → Standard Text. For more information, see the Implementation Guide (IMG) for Payroll under Create Process Model [Extern].
Copying or Creating a Process Model

We recommend that you copy the standard process models and then edit the copies.

Procedure

Copying a Process Model
1. From the SAP Easy Access screen, choose the SAP menu Human Resources → Payroll <country> → Tools → Customizing Tools → Maintain Process Model.
   You access the Maintenance of Process Models screen.
2. In the Process model field, enter a process model.
   - To display the process model before you copy it, choose Model → Display.
   - To display information on the process model, choose Goto → Documentation for model.
3. Choose Model → Copy.
4. In the Target model field, enter the name of your process model and choose Copy.
   You can use names that begin with the digits 0 to 9 or with Z.

Creating a Process Model
1. From the SAP Easy Access screen, choose the SAP menu Human Resources → Payroll <country> → Tools → Customizing Tools → Maintain Process Model.
   You access the Maintenance of Process Models screen.
2. Enter a name and choose Model → Create. You can use names that begin with the digits 0 to 9 or with Z.
3. Maintain the attributes for your process model and choose Save.
   In the attributes, you can define a name and selection program for your process model.
   The selection program transfers the personnel numbers to be processed to the process model.
4. Choose Continue.

Result
You have created a process model and can edit it [Seite 111] if required.

⚠️
To be able to use a process model to execute processes in a live system, you must first activate it.

To store information on your new process model, choose Goto → Documentation on model.
- If you have copied a process model, the system has also copied the accompanying documentation. You can change this documentation if required.
Copying or Creating a Process Model

- If you have created a new process model, you can create new documentation for your model.
Editing a Process Model

Prerequisites
You have created or copied a process model [Seite 109] and are in the Maintenance of Process Models screen.

Procedure
1. Enter the name of the process model that you want to edit and choose Model → Change.
   You access the Maintain Process Model <name> screen. The following areas are displayed:
   - Display area
     The process model you have called is displayed and can be changed.
   - Navigation area
     You can define which section of the process model is shown in the display area.
   - Insertable objects
     The Program and Breakpoint templates are displayed.
2. Insert the Program and Breakpoint objects as process steps in the process model. For more information, see Inserting a Process Step [Seite 112].
Inserting a Process Step

Prerequisites

You are editing a process model [Seite 111] and are in the Maintain Process Model <name> screen. The templates for programs and breakpoints are available in the Insertable objects area.

Procedure

1. In the Insertable objects area, select the object that you want to insert.
2. Click in the display area.
   
   You access the Change Step <number> dialog box.
3. Create the attributes for the program [Seite 113] or the breakpoint [Seite 114].
   
   The inserted object appears separately in the display area.
4. To include the object in the process model, choose Include.
5. Use the cursor to draw a line from the parent object to the child object.

Result

The object is inserted in the process model as a new process step.
Defining the Attributes of a Process Step

Prerequisites

You are inserting a process step in a process model [Seite 112] and are in the Maintain Process Model <name> screen.

Procedure

1. Enter the program category that you want to use.
   
   If you want to create a new category, enter the name of the category and define the following characteristics:
   
   - Unconditional breakpoint before program start
   - Whether the status can be reset
   - Personnel number selection
   - Parallel processing
   - Parent category
   - Child category

   For an overview of the existing program categories and their characteristics, see Maintenance of Process Models under Edit → Program categories. You can also enter a new program category here.

2. Enter the program that you want to use.

3. Enter the program variant that you want to use with this model. You can also enter the name of a new variant and create the variant directly.

4. If the program processes personnel numbers at the same time, enter the size of the personnel number set.

5. If applicable, specify whether somebody should be informed of the status of the process step.

Result

The process step is displayed under the program, variant and set size information.
Defining the Attributes of a Breakpoint

Prerequisites
You are inserting a process step in a process model [Seite 112] and are in the Maintenance of Process Model <name> screen.

Procedure
1. Enter the condition under which the breakpoint will interrupt the process run.

   If you want to use a function module, enter the name of the function module in the Separate function module field. If you then call the field help for this field, the documentation for the specified function module is displayed.

2. If applicable, specify whether somebody should be informed of the status of the breakpoint.

Result
The breakpoint is displayed.
Changing a Process Step

Prerequisites
You are editing a process model [Seite 111] and are in the Maintain Process Model <name> screen.

Procedure
1. Double-click the process step that you want to change. The Change Step <number> dialog box appears.
2. Enter the changes and choose Continue.
   If you are changing a program, you can create new program categories here.
Changing the Sequence of Process Steps

Prerequisites
You are editing a process model [Seite 111] and are in the Maintain Process Model <name> screen.

Procedure
You have the following options:

Cutting and Inserting a Process Step
1. Select the process step that you want to move.
2. Choose Edit → Nodes → Remove to buffer.
3. Choose Edit → Nodes → Insert buffer.
   The process step is displayed separately in the display area. You can now reinsert the process step [Seite 112].

Linking a Process Step to a Preceding Object
1. Choose Connect.
2. Use the cursor to draw a line from the new parent object to the process step that you want to move.
   The process step and the accompanying child objects are now subordinate to the new parent object.
Creating a Process

Prerequisites
You have created the process model [Seite 98] to be used in the process.

Procedure
1. From the SAP Easy Access screen, choose the SAP menu Human Resources → Payroll <country> → Tools → HR Process Workbench.
2. Choose Edit → Process → Create.
   The process number that uniquely identifies the process is assigned automatically. The number range object, which controls the assignment of the numbers, is delivered with the HR Process Workbench.
3. Enter a process name and the process model that you want to use. Choose Continue.

Result
The process has been created. It has the status [Seite 123] Still to run. You can start the process.

To check which process model is used in your created process, flag the process and choose Goto → Additional information.

To display the process model used in your created process, flag the process and choose Goto → Display process model.
Starting or Repeating a Process or Process Step

Use

You start and repeat processes and process steps in the same way. The status indicates whether you need to start or repeat the process.

You may need to start or repeat a process step for the following reasons:

- **Breakpoint**
  A process step follows either a conditional or unconditional breakpoint.

- **Process termination**
  Process steps can be terminated due to a program or technical error. You can see the reason for the program termination by displaying the job log.

- **Personnel numbers with errors**
  Use the spool list and job log to check the process step. Remove the error and repeat the process step.

If a process step or a process is repeated, processing of the following personnel numbers is repeated:

- Personnel numbers *without* the status *Successful*
- Personnel numbers *with* the status *Not selected*

You can only repeat processes, process steps, and personnel number sets that were successful if you change the status for the personnel numbers in question.

Prerequisites

You have created a process in the HR Process Workbench.

Procedure

1. Select the process that you want to start and choose *Edit → Process → Start/repeat.*
2. Specify whether the process will run immediately or at a later point.
   - Immediately: In the personnel number selection screen, either specify a variant or enter the payroll area and payroll period.
   - At a later point: Enter the start date and time. Choose *Continue.* Select the variant for starting the personnel number selection program.
Starting or Repeating a Process or Process Step

If you schedule a process for a later time, you must first create a variant for the selection program. This is possible if, for example, you edit a process model [Seite 111]. From the Maintain Process Model <name> screen, choose Goto → Attributes. From the subsequent dialog box, choose Create variants and create a variant for the selection program.

A process is always executed in the background.

Result

The process is run at a specified time.

You can control the process run using process control [Seite 122].
Closing a Process

Use
We recommend that you close a process if you do not want to repeat it again. The process is then locked for changes. You can close a process even if it still contains incorrect personnel numbers.

Prerequisites
You have started a process [Seite 118] in the HR Process Workbench.

Procedure
1. Select the process that you want to close.

You cannot reverse the Close process activity. You can only display a closed process.

2. Choose Edit → Process → Close. In the subsequent confirmation box, confirm your decision.

Result
The process is displayed in a light gray font in the HR Process Workbench. All process data remains unchanged so that you can see the process history.
Deleting a Process

Prerequisites
You have closed a process [Seite 120] in the HR Process Workbench.

Procedure
1. Select the process that you want to delete.
2. Choose Edit → Process → Delete.

Result
You can no longer access the history for processes that have been deleted.

The application log shows who deleted a process and at what time it was deleted. To access the application log selection screen, choose Goto → Display application log. If you want to accept the default settings, choose Continue. An overview of the processes deleted in the previous year is displayed. If you want to restrict the overview, enter the necessary data in the selection screen.
Process Control

Use

The process steps for a process always run in the background. With this function, you can check that the process steps have been executed in the HR Process Workbench.

Features

The following tools help you to monitor the processing:

- Status display [Seite 123]
- Job log

  The job log contains the date and time of the processing start and end and, if applicable, the termination date and time.

  To display detailed information on the program termination, double-click the Job interrupted message in the job log. Either a short dump or a termination message text will inform you of the cause of the termination.

- Spool list for sets of personnel numbers

Activities

To display the job log, select the set of personnel numbers and choose Goto → Job overview for set.

To display the spool list, select the set of personnel numbers and choose Goto → Spool list for set.
Status Display

Use
You can use the status display to check the status of a process.

For more information on checking the processing status, see Process Control [Seite 122].

Features
In the HR Process Workbench, the system shows the current status for each process.
You can also display the status of the personnel numbers processed in a process.

Process status
The process status is displayed on the process, process step, run, and set level. The icons given to the levels during and after a process run provide information on the processing status. For a legend explaining the symbols, see Utilities.

The process status can be as follows:

- **Stopped**
  A process step follows either a conditional or unconditional breakpoint. To continue the process, start the process step [Seite 118].

- **Successful**
  You can now close the process [Seite 120].

- **Provisional**
  This status is not currently used.

- **Incorrect**
  If process steps are provisionally or incorrectly ended, display the spool list [Seite 122] to analyze the problem. Remove the error and repeat the process step [Seite 118].

- **Canceled**
  Display the job log [Seite 122]. Remove the error and repeat the process step.

Personnel number status
During the process flow, each personnel number receives information on the processing status. This means you can follow the status of a personnel number through the complete process flow. Only correctly processed personnel numbers are transferred from one process step to the next.

You can display the status of a personnel number for all process levels. The status can be as follows:

- **Successful**
- **Provisional**
Status Display

Personnel numbers receive this status if they are processed using incomplete data and the process step was performed correctly.

- **Incorrect**
  
  If the program has identified errors, this status is assigned to personnel numbers.

    ![Image](image.png)

  For example, in the payroll program, personnel numbers have the status *Incorrect* if the system saves them in **matchcode W [Seite 68]** (*Payroll correction run*).

- **Blank**

  This status is for personnel numbers that were incorrect in the previous process step and, as a result, could not be edited. Check the error that has occurred in the previous process step, correct the error, and start the previous process step again.

- **Not selected**

  Personnel numbers with this status are not transferred to the next process step.

**Activities**

To display the status of specific process levels, expand the levels.

To display the status of a personnel number, select the corresponding process level, choose **Goto → Display personnel numbers** and specify whether particular personnel numbers or personnel numbers with a particular status are to be displayed.

![Image](image.png)

To restrict which processes are displayed in the *HR Process Workbench*, choose **Process overview → Set filter**.
Changing the Status

Use
If you repeat processes or process steps, only personnel numbers without the Successful status or with the Not selected status are processed. To be able to edit personnel numbers that have been processed successfully, you must first change the status.

You can only reset the status if this action is permitted for the process step category in question. For more information, see Defining the Attributes of a Process Step [Seite 113].

Prerequisites
You have started a process [Seite 118] in the HR Process Workbench.

Procedure
Select the appropriate level in the process.
Choose Edit → Personnel number → Set to 'Incorrect'.

You have changed the value of a wage type in a table for the process step Payroll. The personnel numbers affected by this change are not grouped in matchcode W (Payroll correction run), however, when the payroll process is repeated, they should be corrected. Change the status to Incorrect and start the process again.
Off-Cycle Payroll Activities

Purpose
This component offers functions that are not a part of regular payroll accounting. Unlike a regular payroll run [Seite 53], which is normally run on a specific day in each payroll period, you can perform off-cycle activities on any day.

Features
Off-Cycle Activities include the Off-Cycle Workbench and its subsequent activities. You can access the Off-Cycle Workbench in the Payroll area menu.

The following functions in the Off-Cycle Workbench have been configured to work with the Payroll Australia component:

- Payroll History [Seite 130]
- Off-Cycle Payroll [Seite 131]

The Off-Cycle Workbench enables you to run payroll online. All subsequent activities related to off-cycle activities are collected together in process models [Seite 98].

In a process model, the SAP System continues processing the payroll results, with the result that, for example, a remuneration statement is created, wages are paid, and the data is transferred to Financial Accounting.

Generally, the process model runs in the background. If you want to perform a process model online, choose Off-cycle → Off-cycle batch: Subsequent activities.

To use the Payroll function, you must specify certain background jobs and process models, so that the results of off-cycle activities can be further processed.

For a description of the process models, refer to the maintenance of the respective process model under Documentation on process model.

Constraints
Not all the functions outlined in this section have been configured to work with Payroll Australia.

See also:
Off-Cycle Activities [Seite 127]
Off-Cycle Activities (PY-XX-OC)

Purpose
As an addition to regular payroll [Seite 53], which carries out payroll at fixed regular intervals, this function enables you to carry out specific off-cycle payroll activities [Extern] for individual employees on any day.

You can issue a check to replace payments that were originally made to an employee by check or by transfer but which the employee did not receive, or if the check is in an unusable condition (for example, torn).

You can reverse payroll results that were created by a regular or off-cycle payroll run.

You can enter a check number into the system retrospectively for a payroll result for which you have already issued a check manually.

Implementation Considerations
To implement the Off-Cycle Activities component, you must edit the Off-Cycle Activities section in Customizing for Payroll.

In the standard system, administrators that use the Off-Cycle Workbench have all authorizations for the whole transaction. To restrict authorizations, refer to the authorization object P_OCWBENCH.

For example, you can give one administrator authorization to carry out off-cycle payroll runs. You can give another administrator the authorization to reverse payroll results.

For more information on authorization maintenance, refer to Users and Authorizations [Extern].

Features
The Off-Cycle Activities component comprises the following areas:

- Off-Cycle Workbench
  This provides a uniform user interface for all off-cycle activities.

- Off-Cycle Subsequent Processing
  Once you have performed a function in the Off-Cycle Workbench, the process still has to be completed. Depending on the function that you have executed, the system still has to carry out various subsequent activities. For example, following an off-cycle payroll run, a remuneration statement must be issued.

Off-Cycle Workbench
The Off-Cycle Workbench offers the following functions:

- Off-Cycle payroll [Seite 131]
  The types of payroll run that you can carry out depend on the settings made in Customizing.
Off-Cycle Activities (PY-XX-OC)

- You can make a bonus payment to an employee for a special occasion.
- You can carry out an immediate correction run if, for example, an employee’s master data was changed.
- You can carry out a regular on demand payroll run for an individual employee independently of the payroll area. This is necessary, for example, if an employee was hired shortly before the payroll date and his or her data could not be entered on time.
- You can run payroll for several periods in advance, if, for example, an employee is to leave the company or wants to take leave and is to receive payment for these periods immediately.
- You can pay an absence, such as leave, in advance.
- You can process payments that you have created in the Payroll Results Adjustment infotype (0221).

- Replace a payment that was made to, but not received by an employee.
- Reverse a payroll result
- Assign at a later date the number of a check - that was issued manually - to the relevant payroll result.

Off-Cycle Subsequent Processing

Depending on the country, off-cycle subsequent processing [Seite 158] is carried out using one or several batch reports. The reports are located in the Off-Cycle menu. When you run the report, you specify on the selections screen of the process model [Seite 98] that you have created for off-cycle subsequent processing. In process models of this kind, you define which subsequent programs are to be run, and in which order. The type of subsequent processing varies, depending on whether an off-cycle payroll result, a payment replacement or a reversal is to be further processed.

Constraints

Off-Cycle Activities are not available in all country versions. In some countries that implement the component not all of the functions outlined here are available.
Off-Cycle Workbench

Definition
User interface enabling you to carry out off-cycle payroll, payment replacement, and reversals conveniently.

Use
You access the Off-Cycle Workbench from the Payroll menu.
You can use the Off-Cycle-Workbench to carry out the following for a specific employee:
- Display payroll results
- Run various types of off-cycle payroll
- Replace by check a payment that was originally made by check or transfer, but not received by the employee
- Reverse an incorrect payroll result
- Add a check number retrospectively to a payroll result for which you have already issued a check manually

Structure
The Off-Cycle Workbench contains the following tab pages:
- History [Seite 130]
- Payroll [Seite 131]
- Replace Payments [Seite 146]
- Reverse payments [Seite 151]
- Assign check number [Seite 150]

Integration
Following a payroll run, payment replacement, or reversal that you have carried out in the Off-Cycle Workbench, the system carries out the off-cycle subsequent processing [Seite 158].
Payroll History

Use

This function enables you to display the previous payroll results relating to payment for a specific employee within the Off-Cycle Workbench. To see the payroll results, you do not have to leave the Off-Cycle Workbench or run a report.

For example, you want to replace a torn check. You can refer to the check number that is displayed in the payroll history to find out for which payroll result the check was issued.

Features

The History tab page in the Off-Cycle Workbench displays an extract from the payroll cluster containing the most important information on the employee’s payroll results.

Payments that you have replaced with a check and payroll results that you have reversed are indicated.

To see more detailed information, you can display the remuneration statement for each payroll result.

For payments, you can display the following information:

- Check number, house bank and company account
- In the case of replaced payments - which payment was replaced by which check
- In the case of reversed payroll results - the reason for reversal and the administrator who carried out the reversal

Activities

To display the remuneration statement for a particular payroll result, select the result and choose Remuneration statement.

For detailed information on a payment, choose .
Off-Cycle Payroll

Use
As an addition to regular payroll [Seite 53], which carries out payroll at fixed regular intervals, this function enables you to carry out specific off-cycle payroll activities for individual employees on any day. Off-Cycle Reasons [Seite 141] differentiate between various types of off-cycle payroll runs.

You carry out off-cycle payroll from the Payroll tab page in the Off-Cycle Workbench [Seite 129].

Prerequisites
- In Customizing for Payroll, under Off-Cycle Activities → Set Up Off-Cycle Reasons [Extern], you have specified which off-cycle reasons are to be available.
- In Customizing for Payroll, under Payroll Data → Additional Payments Off-Cycle [Extern], you have set up the wage types that you require for your off-cycle payroll runs.
- In Customizing for Personal Administration under Off-Cycle Activities → Define Default Values for Payment Methods [Extern], you can also specify which payment method the system proposes for each off-cycle reason in the Off-Cycle Workbench.
- You have scheduled the batch report for subsequent processing of off-cycle activities as a regular background job with a suitable variant by choosing System → Services → Jobs → Define Jobs. The report is located in the Off-Cycle menu. We recommend that you run subsequent processing as a background job on a daily basis.

Features
The tab page Payroll in the Off-Cycle Workbench offers the following options:
- You can select the reason for the off-cycle payroll run. The possible entries that you can make in the lower part of the screen change in accordance with the reason that you specify.
  - The off-cycle reason determines the kind of off-cycle payroll run you want to run. Depending on the settings you have made in Customizing, some or all of the following payroll activities are available:
    - Bonus accounting [Seite 133]
    - Correction accounting [Seite 135]
    - Regular payroll on demand [Seite 136]
    - Advance payment [Seite 137]
    - Absence payment [Seite 138]
    - Payroll results adjustment [Seite 139]
- You can check the payroll calendar. It contains information about planned payroll dates and the date of the employee’s last payroll run.
- You can change the payment method.
  - If you have specified a default payment method for each off-cycle reason in Customizing, the system proposes this payment method.
Off-Cycle Payroll

- If you have not specified a default value in Customizing, the system proposes the payment method from the Bank Details infotype (0009).

  In the Bank Details infotype (0009) you can enter the details of a main or secondary bank for the off-cycle payroll run. The Main bank for off-cycle and Secondary bank for off-cycle are subtypes of infotype 0009.

  If you specify a different payment method, the system creates a record for the current payment in the Bank Details infotype (0009).

- You can split the payment and assign main and secondary bank details.
Bonus Accounting

Use
This function enables you to make a special payment to an employee for a special occasion or for special performance.

An employee is to receive a bonus for outstanding sales performance.
You want to give your employees an end-of-year bonus.

It is advisable to conduct bonus accounting from the Off-Cycle Workbench if you want to pay a bonus to individual employees. It is easier to create mass bonus payments using batch input in the One-Time Payments Off-Cycle infotype (0267). For more information, refer to The One-Time Payments Off-Cycle Infotype (0267) [Seite 144].

Integration
The system creates a record in the One Time Payments Off-Cycle infotype (0267) for each wage type that you enter in bonus accounting. This infotype record contains information on:

- Wage type
- Bonus payment amount
- Reason for off-cycle payroll
- Payroll type [Seite 141]
- Payroll identifier

The payroll identifier is a sequential number allocated by the system to differentiate between several bonus payments or absence payments [Seite 138] made on the same day. This differentiation is necessary, since both of these off-cycle payroll runs belong to the same payroll type. The first bonus accounting run or absence payment has the payroll identifier 0.

Prerequisites
The standard system already contains an off-cycle reason for bonus payments. In Customizing for Payroll, you can, if required, set up one or several off-cycle reasons for bonus accounting. Choose Off-Cycle Activities → Set Up Off-Cycle Reasons [Extern] You must assign the reason to the Category [Seite 141] Bonus.

Under Off-Cycle Activities → Define Default Values for Wage Types [Extern], you have, if required, defined a wage type that the system proposes when you process a bonus.

Features
If you have defined default values for wage types in Customizing and you select the relevant off-cycle reason in the Off-Cycle Workbench, the system proposes a wage type for bonus
Bonus Accounting

accounting in the group header *Create Payments*. You can overwrite the default value that is proposed.
Correction Payroll

Use

This function enables you to make an immediate correction payment if an employee’s master data or time data is changed. The employee does not then have to wait until the system automatically carries out retroactive accounting with the next regular payroll run.

An employee receives a pay check and discovers that overtime hours have not been remunerated correctly. The employee wants to receive the missing amount immediately, rather than wait until the next regular payroll run. You enter the missing overtime in the corresponding time infotype and then run a correction payroll run in the Off-Cycle Workbench.

Integration

In the Earliest master data change field, the system shows the retroactive accounting limit that was set on account of the change in master data in the Payroll Status infotype (0003).

Prerequisites

The standard system already contains an off-cycle reason for correction payroll. In Customizing for Payroll, you can, if required, set up an off-cycle reason for correction payroll. Choose Off-Cycle Activities → Set Up Off-Cycle Reasons [Extern]. You must assign the reason to the Category [Seite 141] Correction.

Features

When you select the relevant off-cycle reason in the Off-Cycle Workbench and run payroll, the system runs retroactive payroll back to the date that is displayed in the Earliest master data change field. The system creates retroactive results for the periods processed. It also creates an original result for the payment date that you use for the correction run.
Regular Payroll On Demand

Use

You can use this function to run regular payroll on demand for a specific employee for a payroll period. You conduct this payroll run independently of the regular payroll run for the payroll area to which the employee is assigned.

An employee is hired shortly before the payroll date. The employee’s data cannot be processed in time for it to be included in the regular payroll run. You can use the Off-Cycle Workbench to run regular on demand payroll for the employee, even if the regular payroll run for the payroll area has already taken place. You do not have to wait until the next regular payroll run for the whole payroll area.

You have hired a new employee. Instead of receiving his or her first pay at the end of the first payroll period, the new employee is to be paid at the start of his period of employment. In the Off-Cycle Workbench, you can run regular on demand payroll for the first period in which he is employed in your enterprise.

Integration

If you want to run off-cycle payroll for an employee for several payroll periods, do not run regular on demand payroll. Instead, make an advance payment [Seite 137].

Prerequisites

The standard system already contains an off-cycle reason for payroll on demand. You can, if required, set up your own off-cycle reason in Customizing for Payroll. Choose Off-Cycle Activities → Set Up Off-Cycle Reasons [Extern]. You must assign the reason to the category [Seite 141] On demand.

Features

If you choose this reason when you are in the Off-Cycle Workbench, the system offers you the next period for which payroll is to be run for the employee. The system then carries out on demand payroll for this period.
**Advance Payment**

**Use**
This function enables you to run payroll for an employee for several periods in advance independently of the regular payroll runs for the payroll area.

An employee leaves the company and is to receive all the money owed immediately. An employee takes leave. You want the employee to receive payment in advance for the payroll periods in which the leave occurs.

**Integration**
If you want to settle an absence, such as leave, in advance, you can also carry out an absence payment [Seite 138]. This means that the employee is only paid in advance for the time that he or she is absent. However, you use the advance payment function to run payroll in advance for all the periods in which the absence takes place.

The employee is to take 10 days leave. The leave period affects three payroll periods. In the case of an absence payment, the employee is paid in advance for 10 days. In the case of an advance payment, the employee is paid in full for all three payroll periods in which the leave takes place.

**Prerequisites**
The standard system already contains an off-cycle reason for advance payments. In Customizing for Payroll, you can, if required, set up an off-cycle reason for payments in advance. Choose Off-Cycle Activities → Set Up Off-Cycle Reasons [Extern]. You must assign the reason to the Category [Seite 141] Advance payment.

In Customizing, under Off-Cycle Activities → Define Default Values for Payments in Advance [Extern], you specify how many payroll periods the system is to propose for payments in advance.

**Features**
When you select the relevant off-cycle reason in the Off-Cycle Workbench, the system offers several periods for payroll. The number of periods proposed depends on the settings in Customizing for Payroll.

If you pay several payroll periods in advance, only one original result is created, and only one payment is effected. The system creates the original result for the latest of the periods for which you run payroll. All other periods prior to this period are processed using retroactive payroll.

The system ensures that the employee who is to receive an advance payment is not processed twice. The employee is then automatically excluded from the payroll area’s regular payroll runs for the periods already processed.
Absence Payment

Use
If an employee is to be absent during future payroll periods, for example, because of leave, you can pay the employee in advance for the period of the absence. The remuneration is calculated using Absence evaluation [Seite 249].

Integration
Contrary to a payment in advance [Seite 137], you do not run payroll for the whole period in which the absence takes place. This means that the employee is only paid in advance for the time that he or she is absent.

Prerequisites
The standard system already contains an off-cycle reason for absence payments. In Customizing for Payroll, you can, if required, set up an off-cycle reason for absence payments. Choose Off-Cycle Activities → Set Up Off-Cycle Reasons [Extern]. You must assign the reason to the category [Seite 141] Absence payment.

In Customizing for Payroll, under Off-Cycle Activities → Off-Cycle Absence Evaluation → Assign Absences to an Off-Cycle Reason [Extern], you have specified which absence types are permitted for off-cycle payroll.

Features
When you select the corresponding off-cycle reason from the Off-Cycle Workbench, the system proposes the absences for processing that have already been entered in the Absences infotype (2001), and that have been set as permitted for off-cycle payroll in Customizing.

When you pay an absence, the system adds the following data to the already created record in the Absences infotype (2001).

- Reason for off-cycle payroll
- Payment date
- Payroll type [Seite 141]
- Payroll identifier

The payroll identifier is a sequential number assigned by the system to differentiate between several absence payments or bonus payments [Seite 133] made on the same day. This differentiation is necessary, since both of these off-cycle payroll runs belong to the same payroll type. The first absence payment or bonus accounting run has the payroll identifier 0.
Payroll Results Adjustment

Use

This function enables you to make payments directly from the Off-Cycle Workbench that you have created in the *Payroll Results Adjustment* infotype (0221). This means that you do not need to wait until the system reads the data from the infotype for processing during the next regular payroll run.

An employee leaves your enterprise whilst working away from the main office in which your HR department is located. The employee’s superior calculates the amount owed manually, and issues a check for the employee manually. To ensure that this payroll result is also available in the system, you enter the relevant data retrospectively in the *Payroll Results Adjustment* infotype (0221) and subsequently run payroll from the Off-Cycle Workbench, specifying payroll results adjustment as the off-cycle reason.

Integration

The payments that you create in the *Payroll Results Adjustment* infotype (0221) are displayed in the Off-Cycle Workbench.

Prerequisites

The standard system already contains an off-cycle reason for payroll results adjustment. You can, if required, set up an off-cycle reason in Customizing for Payroll. Choose Off-Cycle Activities → Set Up Off-Cycle Reasons [Extern]. You must assign the reason to the category [Seite 141] Payroll Results Adjustment.

Features

When you select the relevant off-cycle reason in the Off-Cycle Workbench, the system displays the payments that you created in the infotype. You can select a payment and run payroll.
Running Off-Cycle Payroll

Prerequisites
You are in the Off-Cycle Workbench [Seite 129].

Procedure
1. Enter the personnel number that you want to process and choose the tab page Payroll
2. Select an off-cycle reason [Seite 141]
   This determines the subsequent processing.
3. If required, enter a date other than the one proposed.
4. Copy the payment method from the Bank Details infotype (0009), or enter a different payment method.
5. If required, split the payment and assign the main and secondary bank details.
6. Enter additional data according to the off-cycle reason you have entered.
7. Choose Start payroll
8. After the payroll run, save your data.

Result
Following the off-cycle payroll run, the system makes the following changes:
1. It saves the data in the relevant infotypes, and saves the payroll results to the database.
   At the same time, the system makes an entry in the indicator table for batch processing to show that a payroll result exists that requires further processing.
   
   ![You can display the contents of the indicator table using report H99LT52OCG (Display Indicator Table for Off-Cycle Batch Processing). The report is located in the Off-Cycle menu.]
2. At the regularly scheduled time, the system runs as a background job the country-specific batch report for subsequent processing of off-cycle payroll.
   The report reads the indicator table. Using the payroll results from the indicator table, the system starts the process model that you specified in the report variant.
3. The system carries out all subsequent programs that you specified in the process model. For example, it produces remuneration statements, prints checks or initiates transfers and posts payroll results to Accounting if you have specified these steps in the process model.
Reasons, Types and Categories for Off-Cycle Payroll

Various off-cycle reasons, and assignment to various types and categories are used to distinguish payroll runs.

Off-Cycle Reason

The off-cycle reason differentiates between various business reasons. Off-Cycle reasons enable an administrator to decide conveniently what kind of payroll to run from the Off-Cycle Workbench.

The standard system already contains off-cycle reasons for all kinds of off-cycle payroll. In Customizing for Payroll, you can set up your own reasons that are valid for your enterprise. You assign each off-cycle reason to a specific category. This enables the system to deal with similar payroll runs in the same way. The subsequent assignment to a type of off-cycle reason and to a payroll type is done automatically by the system.

In Customizing, you define the off-cycle reason *Holiday bonus* and assign it to the category *bonus*. The system assigns the type of off-cycle reason *Bonus* and the payroll type *A* to the *Holiday bonus*.

Category for the Off-Cycle Reason

Categories group several off-cycle reasons together so that similar reasons, such as Easter bonus and Christmas bonus are dealt with in the same way by the system.
Reasons, Types and Categories for Off-Cycle Payroll

Which types of off-cycle reason are set up in the system depends on the categories that are required by the country-specific components.

Off-Cycle Reason Type

The system uses the off-cycle reason type to decide what information it must display in the Off-Cycle Workbench. The decision is made in line with the off-cycle reason selected by the administrator.

- **On demand**
  The system proposes the next regular payroll period.

- **Advance Payment**
  The system proposes several future regular payroll periods.

- **Bonus**
  If you have defined a wage type, the system proposes a wage type for bonus accounting that you have set up in Customizing for Payroll.

- **Absence**
  The system proposes for payroll future absences that you have recorded in the Absences infotype (2001).

- **Other**
  For a correction run carried out in the Off-Cycle Workbench, the system displays the date of the retroactive payroll run from the Payroll Status infotype (0003). For a payroll run with the category Payroll Results Adjustment, the system displays payments that you have created in the Payroll Results Adjustment infotype (0221).

Payroll Type

The payroll type enables the payroll driver to decide which of the following kinds of payroll are to be run:

- **Blank = Regular payroll run**
  The system then runs on demand payroll for one or several periods.
  The types of off-cycle reason on demand and advance payment belong to this payroll type.

- **A = Bonus payment**
  The payment date with which you run off-cycle payroll is the start and end date of the payroll period. The system creates the payroll result for this day.
  The types of off-cycle reason bonus and absence belong to this payroll type.

- **B = Correction run**
  The system runs retroactive payroll for past periods on account of a change in master data. Payroll is re-run for all periods that have already been run, back as far as the retroactive accounting date. In addition to these retroactive accounting results, the system creates an original result for the payment date that you use for the off-cycle run.
• **C = Manual check**

The system processes payments that you have entered in the *Payroll Results Adjustment* infotype (0221). This payroll type exists for USA and Canada only.
The One-Time Payments Off-Cycle Infotype (0267)

Definition
Infotype in which additional wage elements that are only made once or irregularly can be stored for off-cycle payroll.

Use
The One-Time Payments Off-Cycle infotype (0267) is not used in all countries.

To create one-time payments, you have the following options:

- If you only want to create a one-time payment for one or a few employees, we recommend that you use the Off-Cycle Workbench. The system thereby saves you from carrying out several steps that you otherwise must carry out manually in the One-Time Payments Off-Cycle infotype (0267).
- If you want to make one-time payments to many employees, we recommend that you use batch input in the One-Time Payments Off-Cycle infotype (0267), or use fast entry.

Structure

- The standard system contains various wage types as subtypes.
- In the Payment date field, the system offers the last day of the current payroll period as the payment date for the one-time payment off-cycle. You can overwrite this default value by entering the required date for the off-cycle payroll run in the Payment date field.
- In the Off-Cycle Reason field, you can only select from reasons that were assigned to payroll type A in Customizing. For more information, refer to Reasons, Types and Categories for Off-Cycle Payroll.
- In the Payrollid (Payroll identifier) field, you must make entries, only if you want to create two infotype records for an employee on the same day. The system requires the payroll identifier to distinguish between two runs with the same date and the same payroll type.

Integration
If you create mass off-cycle payments in the One-Time Payments Off-Cycle infotype (0267), you start the payroll driver using a process model, that you defined in Customizing off-cycle activities. In the HR Process Workbench, you create a Process using this process model. You then run the process model. The process model ensures that payroll is run only for the employees with a relevant entry in the One-Time Payments Off-Cycle infotype (0267).
You can also start the payroll driver without using a process model. However, you must then specify individually each employee who received a one-time payment. Alternatively, you can process the whole payroll area. However, this gives payroll results for all employees, even those who did not receive a one-time payment.

You must make sure that the payroll driver uses the correct data from the infotype during payroll. You must ensure that the data that appears in the Reason for off-cycle payroll and Special run fields, (including the fields: Payroll type, Payroll identifier, and Payment date for off-cycle payroll) which appear on the selection screens for the process and the payroll driver is exactly the same as data you created in the corresponding fields in the One-Time Payments Off-Cycle infotype (0267).

If you create one-time payments in the Off-Cycle Workbench, the system ensures that the payroll driver runs using the correct data.

See also:

Creating bonus payment details in infotype 0267 [Extern] (Payroll Thailand)
Replacing a Payment

Use
You replace a payment if:

- An employee did not receive a payment by transfer
- A check that you issued to an employee is unusable

An employee usually receives payment by transfer. The employee changed bank at short notice, with the result that payment was made to the old bank. The bank rejects the payment.

An employee usually receives payment by check. A check is torn during printing, or is later stolen.

Integration
If you replace a payment that was originally made by check, the system reverses the original check in Accounting.

If you replace a payment that was originally made by transfer, the system makes an entry in the Table T52OCL (Off-Cycle: Transfer replaced by check or reversed) and logs that a payment was replaced.

The table T52OCL is not evaluated by the system. You must ensure that you do not make the payment twice accidentally. To check the table T52OCL, you can run the report H99LT52OCL. (Transfer replaced by check or reversed).

Prerequisites
In Customizing for Payroll, you have edited the following steps in the section on Off-Cycle Activities:

- Check Payment Key [Extern]
- Printing Check with Manual Number Assignment [Extern]
- Replace Checks [Extern]

You have scheduled the batch report for subsequent processing of check replacement as a regular background job with a suitable variant by choosing System → Services → Jobs → Define Jobs. The report is located in the Off-Cycle menu. We recommend that you run subsequent processing as a background job on a daily basis.

Features
The tab page Replace payment in the Off-Cycle Workbench offers you the following options:

- You can issue checks to replace payments by transfers or payments by check.
- You can select a reason for the payment replacement.
- Once the payment by check has been made, you must enter a reason.
- Once the payment by transfer has been made, you do not have to enter a reason.

- You can assign the new check number yourself, or have it assigned by the system.
  - If you apply the check number manually, this number is checked against the check lot.
  - If the check number is to be applied automatically, the system takes the next number from the check lot.

- You can confirm the date proposed by the system, or you can enter another date.
  
  The system proposes the date of the original check or transfer that is being replaced.
Replacing a Payment

Prerequisites
You are in the Off-Cycle Workbench [Seite 129].

Procedure
1. Enter the personnel number that you want to process and choose Replace payment.
   The system displays all payments that you can replace.
2. Select the payment that you want to replace.
   Information relating to this payment is displayed.
3. If required, overwrite the check date that the system proposes.
4. If you want to replace a check, enter the reason for the reversal.
5. Specify whether the new check number is to be applied automatically by the system or whether it is to be applied manually.
   If the check number is to be assigned manually, enter it in the Check number field. The system immediately checks this number with the check lot.
6. Choose Replace.

Result
1. The system runs the Preliminary Program Data Medium Exchange [Extern].
2. It marks the replaced payments with a key that is composed of the program run date and the identification feature CYYYYP:
   - C = check
   - CYYYYYP (Y = the sequence number from a number range that was defined by SAP for check replacement).
   - P = Human Resources
   All replacements carried out on the same day are given the same key. The system enters the details in the indicator table for off-cycle batch processing.
   You can display the contents of the indicator table using report H99LT52OCG (Display Indicator Table for Off-Cycle Batch Processing). The report is located in the Off-Cycle menu. If you choose transaction type R (check replacement) in the report’s selection screen, the data records containing replaced payments in the indicator table are displayed. This enables you, for example, to see which identification feature the system has assigned.
3. The system runs the batch report for the subsequent processing of check replacements as a background job at the time that you have scheduled for the regular processing of the report.
   The report reads the indicator table and runs the process model that you specified in the report variant.
4. The system runs the check print program as part of the process model, and thereby prints the new checks.

   If you have specified that the check number is to be applied automatically, the system uses the next number from the check lot.
Assigning Check Numbers

Use
You have carried out an off-cycle payroll run. You have issued a check manually for this payroll result. You enter the number of this manually issued check into the system retrospectively against the payroll result.

You use the Off-Cycle Workbench to make a bonus payment to an employee. You cannot print the check immediately because the printer is not working. The employee must, nonetheless receive the check immediately. You therefore issue a check manually. You assign the number of this check to the payroll retrospectively so that you can later see which check belongs to which bonus payment.

Prerequisite
You are in the Off-Cycle Workbench [Seite 129].

Procedure
1. Enter the personnel number that you want to process and choose the tab page Assign check number.
2. Mark the payroll result to which you want to assign a check number.
3. Enter the number of the check that you have issued manually.
4. Choose Assign.
Reversing Payroll Results

Use

Depending on the status of the payroll control record, you have various options for making an incorrect payroll result invalid.

- If the control record does not yet have the status *End of payroll*, you can:
  - Repeat the payroll run
  - [Delete the incorrect payroll result][82]

- If the control record already has the status *End of payroll*, you must reverse the payroll result. If the data medium exchange program has already been run, the system also reverses the relevant checks and transfers.

When reversing, the payroll results are not deleted from the data base. They are only marked with the "invalid" indicator. Reversal consequently requires a lot of memory space.

If the payroll control record does not yet have the status *End of payroll*, we recommend that you repeat the payroll or delete the incorrect payroll result.

Integration

In the case of a payment by check, the system reverses the check in *Accounting*.

If the amount was paid by transfer, the system writes the personnel number, sequence number, amount, and [BT split indicator][198] relating to this transfer to the table T52OCL (*Off-Cycle: Transfer by check replaced or reversed*).

This table is not actively evaluated by the system. Instead, it only documents which payments you have replaced or reversed. You must therefore make sure that a reversed payment was definitely not transferred. To check the table T52OCL, you can run the report H99LT52OCL (*Transfer by check replaced or reversed*).

Prerequisites

You have scheduled the batch for subsequent processing of off-cycle activities as a regular background job with a suitable variant by choosing *System → Services → Jobs → Define Jobs*. We recommend that you run subsequent processing as a background job on a daily basis.

Features

The tab page *Reverse payment* in the Off-Cycle Workbench offers you the following options:

- You can reverse the payroll results of a regular payroll run or an off-cycle payroll run, regardless of whether the employee has received a check or transfer.

  The system reverses all payments that belong to that payroll result.
Reversing Payroll Results

- The system offers an overview of all the payroll results. You can display detailed information on the relevant payments.
- You can select a reason for the reversal.
  - If you reverse a check, you must specify a reason.
  - You can reverse a transfer without specifying a reason.
Reversing the Payroll Result

Prerequisites
You have corrected the relevant master data.

If you reverse a payroll result that was the result of bonus accounting, you must also delete the relevant infotype record in the One-Time Payments Off-Cycle infotype (0267).

You are in the Off-Cycle Workbench [Seite 129].

Procedure
1. Enter the personnel number that you want to process and choose the tab page Reverse payment.
2. Select the payroll result that you want to reverse.
3. If you want to reverse a check, enter the reason for the reversal.
5. Confirm the security check.

Result
Depending on whether you have reversed the last payroll result, whether the payroll result was already posted to Accounting, and whether payments were already made to third parties, the system triggers various subsequent activities:
Reversing the Payroll Result

Result 1

Out-of-sequence reversal

1. The system makes Changes [Seite 156] to the tables RT (Results Table) and BT (Bank Transfers).

2. Depending on how the reversed payroll result came about, the system sets the following retroactive accounting date in the Payroll Status infotype (0003):
   - In the case of off-cycle payroll, it writes the payment date for the payroll run in the field Mast.data chng.bonus (Earliest payroll-relevant master data change (Bonus))
   - In the case of regular payroll, it writes the start date of the period for which payroll has been run in the Earliest master data change field (earliest master data change since last payroll).
   This ensures that retroactive accounting takes place.

3. In the payroll result, the system places the indicator R in the invalid field of the payroll directory (RGDIR). It enters the reason, date and time of the reversal in this data record.

4. Following the reversal, you have the following options:
Reversing the Payroll Result

- If the employee is to receive a payment immediately, carry out a correction payroll run in the Off-Cycle Workbench.
- If you do not carry out a correction payroll run in the Off-Cycle Workbench, the system automatically carries out retroactive payroll when the next regular payroll run takes place.

Result 2

"Void"

1. The system places the "void" indicator V in the invalid field of the payroll directory (RGDIR) for the payroll result.

If the V indicator is set, the payroll result can no longer be used for evaluations. Instead, it is only available for the payroll history. The system enters the reason, the date, and the time of the reversal to the data record.

2. The system makes an entry in the indicator table for off-cycle batch processing.

You can display the contents of the indicator table using report H99LT52OCG (Display Indicator Table for Off-Cycle Batch Processing). The report is located in the Off-Cycle menu.

3. The system runs the batch report for subsequent processing of off-cycle activities as a background job at the time that you have scheduled for the regular processing of the report.

The report reads the indicator table and runs the process model that you specified in the report variant. The process model produces reversal documents for reversed payroll results and posts them to Accounting. As a result, the documents that were originally posted are reversed.

4. Depending on which payroll result you reversed, you have the following options:

- If the payroll result arose from an off-cycle payroll run, you can rerun payroll.
- If the payroll result arose from a regular payroll run, retroactive payroll takes place at the next regular payroll run, since the control record already has the status End of payroll.

Result 3

"Void"

The system places the "void" indicator V in the invalid field of the payroll directory (RGDIR) for the payroll result.
Out-of-Sequence Reversal: Changes in the RT and BT Tables

If you reverse the last payroll result and payments have already been made to third parties, or if you reverse a payroll result other than the last, the system makes the following changes in the RT table (Results Table) and the BT table (Bank Transfers):

**Table RT**

- The system produces the technical wage type /568 that contains the payment amount for the reversed payroll result.
- It writes the amount of the wage type /557 cm to the wage type /569.
- It writes the amount of the wage type /558 cm to the wage type /570.
- It writes the amount of the wage type /559 to the wage type /571.
- It stores the former payment method in coded form in the *amount per unit* field in wage types /569, /570 and /571.
  - Payment by check: 1
  - Transfer: 2
  - Check with numbers applied manually: 3

The payment of USD 2,500 to an employee was originally split into a check payment (USD 1,000) and bank transfer (USD 1,500). The following appears in the RT table:

<table>
<thead>
<tr>
<th>Wage type</th>
<th>Amount per unit</th>
<th>Number</th>
<th>Amount</th>
<th>BT</th>
</tr>
</thead>
<tbody>
<tr>
<td>/559</td>
<td></td>
<td>1</td>
<td>1 000</td>
<td>01</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1</td>
<td>1 500</td>
<td>02</td>
</tr>
</tbody>
</table>

After reversal, the following appears in the results table instead:

<table>
<thead>
<tr>
<th>Wage type</th>
<th>Amount per unit</th>
<th>Number</th>
<th>Amount</th>
<th>BT</th>
</tr>
</thead>
<tbody>
<tr>
<td>/568</td>
<td></td>
<td></td>
<td>2 500</td>
<td></td>
</tr>
<tr>
<td>/571</td>
<td>1</td>
<td></td>
<td>1 000</td>
<td>01</td>
</tr>
<tr>
<td>/571</td>
<td>2</td>
<td></td>
<td>1 500</td>
<td>02</td>
</tr>
</tbody>
</table>

- The system deletes the wage types /557, /558, and /559.
BT Table

The system deletes the wage types /557, /558, and /559.

The other wage types in the BT table, for example, wage types from the External Transfers infotype (0011) are not deleted.
Off-Cycle Subsequent Processing

Use

The system uses this function to further process the results of an off-cycle payroll, a replaced payment or a reversed payroll result.

Once you have made a bonus payment using the Off-Cycle Workbench, not all necessary steps have been concluded. A further remuneration statement must be issued, the necessary checks must be printed or the transfers must be made and the payroll results must be posted to Accounting. Further steps may also be necessary, depending on the business processes in your enterprise.

Indicator Table for Batch Subsequent Processing

The system writes all necessary details relating to the results of the off-cycle payroll, the payment replacement or the reversal to the table T52OCG (Off-cycle: Flags for Batch: Payroll, Subsequent Program). The results are thereby made available for subsequent processing.

You can display the contents of the indicator table using report H99LT52OCG (Display Indicator Table for Off-Cycle Batch Processing). The report is located in the Off-Cycle menu.

Report for Batch Subsequent Processing

You start subsequent processing by running one or several batch reports. The batch report ensures that the system runs all necessary subsequent programs in sequence.

Once you have used the functions Run payroll, Replace payment and Reverse payroll result, you must - in line with your country version:

- Run various batch reports
- Run the same batch report separately for each function.

The relevant reports are contained in the standard system of each of the country-specific versions. The reports are located in the Off-Cycle menu.

We recommend that you schedule the report(s) for batch subsequent processing - that are contained in your country-specific standard system - as regular background jobs - for example at the end of each workday. This ensures that subsequent processing is conducted regularly and on time.

Process Model

In a process model, you define which subsequent programs are run, and in what order. On the selection screen of the report for the batch subsequent processing, you specify which process model the report is to use.

Model process models are contained in the standard system. You can use these to create your own process models.
The process models may differ from country to country. For more information on process models, refer to Customizing for Payroll, under Off-Cycle Activities → Create Process Models for Off-Cycle Subsequent Processing - or under Create Process Model for Subsequent Processing Off-Cycle in the maintenance of the relevant process model, . Choose Model documentation.

**Prerequisites**

You have made the following settings for the functions Payroll, Replace payment and Reverse payroll result:

- You have created your own process model for each function in Customizing for Payroll under Off-Cycle Activities → Create Process Models for Off-Cycle Subsequent Processing [Extern].

  If you only implement the Payroll function, create your process model in the step Create Process Model for Subsequent Processing Off-Cycle Payroll [Extern].

- In the country-specific standard system, for each function, you have scheduled the relevant report(s) - with an appropriate variant - for batch subsequent processing as regular background jobs. To do this, choose System → Services → Jobs → Define job.

**Features**

You can schedule the relevant batch report with the corresponding process model as a background job, or you can call it in the Off-Cycle menu and run it from there directly.

Depending on the function you executed in the Off-Cycle Workbench, the system carries out the following activities:

<table>
<thead>
<tr>
<th>Function</th>
<th>Decision criteria</th>
<th>Subsequent processing by system</th>
</tr>
</thead>
</table>

**April 2001 159**
## Off-Cycle Subsequent Processing

| Off-Cycle payroll | • Saves payroll results on database  
| | • Makes an entry in the indicator table for batch processing to show that a payroll result exists that requires further processing  
| | • Runs the batch report for subsequent processing of off-cycle activities as a background job at the time that you have scheduled for the regular processing of the report  
| | • Reads indicator table  
| | • Runs the process model that you have specified in the process model and uses the payroll results from the table  
| | • Runs subsequent programs as part of the process model, for example:  
| | − Creates remuneration statements  
| | − Prints checks or triggers transfers  
| | − Posts payroll results to Accounting  
| | − Runs any further subsequent programs that you have defined in the process model  
| Replacing a Payment | • Runs Preliminary Program Data Medium Exchange  
| | • Indicates each payment replacement with a key composed of program run date and the indicator feature CYYYP (For more information, see replace payment [Seite 148])  
| | • Enters the details in the indicator table for off-cycle batch processing  
| | • Runs the batch report for subsequent processing of check replacement as a background job at the time that you have scheduled for the regular processing of the report  
| | • Reads indicator table  
| | • Runs the process model that you have specified in the report variant  
| | • Prints new checks  

Reversal | You have reversed the last payroll result and payments have already been made to third parties. Or you have reversed a payroll result other than the last one (Out-of-sequence reversal).
---|---
- Makes [Changes][1] to the tables RT (Results Table) and BT (Bank Transfers).
- Places the retroactive accounting date in the Earliest master data change field in the Payroll Status infotype (0003).
- Marks the payroll result with the indicator R in the invalid field of the payroll directory (RGDIR).
- Runs retroactive accounting
  
  If you do not carry out a correction payroll run in the Off-Cycle Workbench, the system automatically carries out retroactive payroll when the next regular payroll run takes place.

| Reversal | You have reversed the last payroll result, which was already posted, although no payments to third parties have taken place (“Void”).
---|---
- Marks the payroll result with the indicator V in the invalid field of the payroll directory (RGDIR).
- Makes an entry in the indicator table for off-cycle batch processing to show that a reversed payroll result exists
- Runs the batch report for subsequent processing of off-cycle activities as a background job at the time that you have scheduled for the regular processing of the report
- Reads indicator table
- Runs the process model that you have specified in the report variant
- Posts payroll results to Accounting
- Runs retroactive accounting (if the reversed payroll result arose as a result of regular payroll)

| Reversal | You have reversed a payroll result, which was already posted, and no payments to third parties have taken place (“Void”).
---|---
- Marks the payroll result with the indicator V in the invalid field of the payroll directory (RGDIR).

See also:

[Running Off-Cycle Payroll][2]
[Replace Payments][3]
[Reversing the Payroll Result][4]

---

[1]: #/g183 Makes Changes [Seite 156] to the tables RT (Results Table) and BT (Bank Transfers).
[2]: #/g183 Places the retroactive accounting date in the Earliest master data change field in the Payroll Status infotype (0003).
[3]: #/g183 Marks the payroll result with the indicator R in the invalid field of the payroll directory (RGDIR).
[4]: #/g183 Runs retroactive accounting

---

Running Off-Cycle Payroll [Seite 140]
Replace Payments [Seite 148]
Reversing the Payroll Result [Seite 153]
Effects on Dependent Functions

Purpose
The SAP HR Payroll Australia component has been modified to cater for off-cycle payroll.

Process Flow

Superannuation
If your bonus payments are configured to contribute to superannuation, the SAP System calculates employee and employer contributions during off-cycle payroll runs. The superannuation contributions are updated accordingly in the superannuation monthly and quarterly tables (SMTH and SQTR) in the payroll results cluster.

Taxation (including average tax calculations)
When you perform an off-cycle bonus run after a regular payroll run, the SAP System reads the payroll results table (table RT) to determine the period-to-date gross and tax amounts.

It then adds the bonus payment to the period-to-date gross amount and recalculates tax based on the new figure.

An employee earns $3,000 in period 01 (July 1 to July 31) and pays $746.40 in tax. On July 18, the employee receives a bonus payment of $300. The bonus is added to the gross to make a total gross of $3,300. This amount is then taxed at the appropriate rate to give $867.10, making a difference of $120.70 in tax.

When you perform an off-cycle bonus run before a regular payroll run, the SAP System applies tax to the bonus payment in consideration of the general tax exemption rate.

Leave
The SAP System does not calculate leave accruals in off-cycle payroll runs. Instead, these are calculated in regular payroll runs.

Group certificates
Off-cycle payroll enables you to perform end-of-year adjustments and to report the adjustments on the group certificates for the current financial year.

Pay slips and reporting
Off-cycle payroll results are included in pay slips and in a number of reports such as the Superannuation, Leave and Payroll reports.
Mass Off-Cycle Payroll Runs

Use
In addition to off-cycle bonus and adjustment runs for individual employees, you can also perform off-cycle runs for a selection of employees or payroll areas.

Integration
You cannot use the Off-Cycle Workbench to perform mass off-cycle payroll runs. Instead, you enter the bonus or adjusted payments in the appropriate infotypes, and then trigger an off-cycle run for multiple employees or payroll areas in the payroll driver.

Prerequisite
The bonus or adjustment must be paid on the same date for all employees.

Activities
1. Create bonus payments for the employees or payroll areas by entering the bonus payments in the One-Time Payments Off-Cycle infotype (0267).
   Or
   Adjust your employees’ pay in the appropriate infotype (for example, the Basic Pay (0008) or the Recurring Payments/Deductions (0014) infotype).

   To simplify processing, the project team can write a batch input report in Customizing that fills the appropriate infotypes for all employees/payroll areas automatically.

2. In the payroll driver, enter the employees/payroll areas, the off-cycle reason, the payroll type, identifier and date.

3. Execute the payroll run, and check the results.

4. When the results are correct, print your pay slips and perform payroll posting to Accounting.
Gross Part of Payroll

Purpose

Using this component you determine an employee’s gross pay, according to contractual requirements, which is composed of payments and deductions.

Examples of payments that are included in the calculation of gross remuneration are as follows:

- Basic pay
- Bonuses
- Vacation allowance
- Holiday bonus
- Gratuities

Deductions include company-owned apartment, company-sponsored day care, and similar benefits.

Different factors determine whether such payments and deductions increase or reduce the taxable income. Such factors include the statutory regulations of a country and, in some countries, the enterprise policy.

Individual gross values are grouped together as bases for taxes or social insurance (SI) contributions according to the specifications of a country, state or region and pay scale regulations for a profession. These gross cumulations are used to calculate specific values.

Some important gross cumulations are:

- Gross tax amount
- Gross social insurance amount

Other gross cumulations are assessment bases for calculating holiday bonuses, vacation allowances, or other employee bonuses.
Wage Types

Definition

Payroll and Personnel Administration objects used to differentiate between monetary amounts or time units that are used in different ways to calculate the employee's remuneration. In the SAP System monetary amounts or time units that serve different business purposes, and that are processed in different ways during the payroll run, are delimited from one another using wage types [Extern].

The Standard Pay wage type has a different business background to the Union Dues wage type.

You enter the number of hours in the Overtime wage type. During the payroll run the Overtime wage type is processed in a different way to the Monthly Salary wage type.

The Overtime Hours wage type is included in a basis for calculating average values [Extern] which is different to the Holiday Bonus wage type.

The standard SAP System contains a wage type catalog [Seite 174] with a large number of different wage types for different business tasks.

Use

There are two categories of wage types:

- **Primary Wage Types**
  - Primary wage types include:
  - Dialog wage types [Seite 168] that you enter when maintaining master data in the infotypes.
  - Time wage types [Seite 169] that the system forms using time information or that you enter online.

- **Secondary Wage Types**
  - Secondary wage types [Seite 170] are technical wage types generated by the system in Payroll during the payroll run.

These wage types have different purposes in the SAP system:

- A wage type is typically evaluated with a monetary amount that should be paid out to the employee or that they should withhold.
- It can also be used to cumulate several amounts for statistical evaluation.
- It can be used by the system in Payroll to temporarily store interim results, and to move from one step to the next.

The business task of a wage type determines whether it is entered online or is generated by the system, and how it is processed during the payroll run.
Wage Types

The Standard Pay wage type is used to assign the collectively agreed and fixed salary to an employee. It is therefore entered as a dialog wage type in the Basic Pay infotype (0008).

The Total Gross Amount wage type is used to cumulate all wage types that belong to an employee's total gross amount. It is therefore generated as a secondary wage type by the system during the payroll run.

The Standard Pay wage type is included in the Total Gross Amount wage type during the payroll run.

Structure

Fields

A wage type consists of the following fields:

- **AMT (Amount)**
  
  In the case of a standard pay wage type, for example, it contains the amount that the employee should receive.

- **RTE (Rate)**
  
  Contains the valuation basis [Extern] therefore in the case of an hourly wage type the hourly rate, which should be multiplied by the number of hours performed by the employee, during the payroll run.

- **NUM (Number)**
  
  In the case of a time wage type, for example, it contains a number of time units such as hours, which, during the payroll run, should be multiplied by the valuation basis that you specified for this time wage type in Customizing.

Depending on the wage type, one of the fields can be filled or entries can be available in two or all of the fields.

Wage Type Characteristics

A wage type is identified by the following characteristics:

- Characteristics that control the entry of the wage type on-line, for example.
  - Can data be entered on-line for an infotype, personnel area, or employee subgroup?
  - Is a wage type regarded as a payment or a deduction?
  - Direct or indirect valuation?
  - Can the amount be overwritten on-line when an indirect valuation is performed?
  - Rounding?

- Characteristics that determine how the wage type will be processed during the payroll run or the evaluation of the payroll results.
  - Processing Class [Seite 171]
  - Evaluation Class [Seite 172]
Wage Types

- Cumulation wage type [Extern], in which the wage type should be included
- Basis for calculating average value, in which the wage type should be included
- Valuation basis, in which the wage type should be included

Wage Type Groups
Several similar wage types are grouped together in wage type groups [Extern]

See also:
Assigning Wage Types to Wage Type Groups [Seite 191]
Using Wage Types [Seite 196]
Valuating Wage Types [Seite 256]
Dialog Wage Types

Definition
Primary wage type that you enter on-line.

Use
You enter a dialog wage type in the following infotypes in the SAP System:

- Basic Pay infotype (0008)
- Recurring Payments and Deductions Infotype (0014)
- Additional Payments infotype (0015)
- EE Remuneration Info infotype (2010)
- External Bank Transfers infotype (0011)
- Time Quota Compensation infotype (0416)

In some Time Management infotypes you can determine a different payment [Seite 240]. Here you also enter a wage type.

Apart from these internationally used infotypes there are additional nationally used infotypes. The dialogue wage types are evaluated [Seite 257] in different ways.
**Time Wage Type**

**Definition**
Primary wage type that:

- The system makes available by means of time data information, if certain conditions that you defined previously have been filled
- You enter on-line

**Use**
Time wage types are selected by the system using time wage type selection [Seite 233] in Time Evaluation.

Time wage types are only written with a number (usually of hours) to the payroll program and, it is only at this point that they are evaluated [Seite 258].

**Example**
The standard system contains a model wage type *Overtime Bonus 50%*. You can use the customizing system to define conditions that must be met before the *Overtime bonus 50%* time wage type can be assigned to an employee.

Such conditions could be as follows:

- The employee must have worked at least 2 hours of overtime.
- The employee must have worked on a weekend.
- The employee must have worked on a public holiday.

Whenever the conditions you defined are met, the system automatically selects the time wage type *Overtime bonus 50%* for the employee in question.
Secondary Wage Type

Definition
A technical wage type generated by the system.

Use
You do not enter secondary wage types on-line. The system generates secondary wage types during the payroll run or derives them from particular factors.

Secondary wage types are also wage type that cumulate several wage types or temporarily store interim results.

Structure
The technical name of a secondary wage type always starts with the character (/), for example, /001.

Example
The standard system includes the secondary wage type /101 (Total Gross Amount). This wage type is created during the payroll run and is used to cumulate all of the wage types that pertain to an employee’s total gross amount.
Processing Class

Definition
A wage type characteristic that controls processing during payroll.

Use
There are different processing classes for the various processing steps that are carried out within payroll. During the payroll run, the system processes a wage type in a certain processing step according to its individual specification in the respective processing class.

The standard system contains processing classes that have different specifications. You can also create customer processing classes and specifications in Customizing for Payroll under Environment → Environment of Wage Type Maintenance → Processing and Evaluation Classes → Maintain Evaluation Classes and their Specifications [Extern].

Structure
A processing class has different specifications.

Example
In the standard system, processing class 15 determines how a wage type is valuated in accordance with the principle of averages.

The standard system permits the following specifications for processing class 15:

- Specification 1: Formula frame for averages over the last 3 months
- Specification 2: Formula frame for averages over the last 12 months
Evaluation Class

Definition
Wage type characteristic, which controls processing when evaluating and displaying the payroll results.

Use
There are various evaluation classes for the different processing steps within the evaluation and displaying of payroll results. During evaluation, the system processes a wage type in a certain processing step according to its individual specification in the respective evaluation class.

The standard system contains evaluation classes with different specifications. You can also create customer evaluation classes and specifications in Payroll Customizing under Environment → Environment of Wage Type Maintenance → Processing and Evaluation Classes → Maintain Evaluation Classes and their Specifications [Extern].

Structure
An evaluation class has different specifications.

Example
In the standard system, the specifications for evaluation class 02 control how a wage type is printed on a form.

- Specification 00: no printing on the form
- Specification 01: prints personal payments/deductions
- Specification 02: prints wage types included in the total gross amount
- Specification 03: prints wage types derived from time-based payments and included in the total gross amount
Wage Type Copier

Definition

Tool used for creating the customer-specific wage type catalog [Seite 175].

Use

We recommend that you only use the wage type copier within Customizing (Transaction OH11). It is available in all the steps in which you copy wage types. You find this, for example, in Customizing for Payroll under Environment → Environment of Wage Type Maintenance → Create Wage Type Catalog.

You can also call up the wage type copier outside of Customizing, using transaction PU30.

The wage type copier provides you with the following functions:

- **Copy wage types**
  
  You copy the model wage types, which are contained in your standard system, into the customer-specific name range. In this way you create your own customer-specific wage type catalog.

- **Delimit or delete wage types (time-based)**
  
  You can delimit or delete wage types that you no longer require.

  *Never* delete SAP model wage types.

  *Never* delete customer-specific wage types in a live system; only ever do this in a test system.

  We recommend that you do **not** delete or delimit customer-specific wage types. Instead, you should no longer allow them to be entered in infotypes. Then the wage type can no longer be used in your system. You also avoid the problems that could arise when deleting or delimiting wage types.

- **Check completeness of wage types**

  The wage types are created in tables. Table T512W (Wage Type Valuation) is a central table that must contain all the customer-specific wage types. You can carry out a test run to check if the wage types included in other tables are also contained in Table T512W. You receive a list of all the wage types that are **not** contained in Table T512W.

- **Documentation for model wage types**

  When you copy a model wage type to the customer-specific name range, the system also copies the documentation. You can change the documentation for the customer-specific wage type using transaction PDSY (HR Documentation Maintenance).
Wage Type Catalog

Definition
A directory of all the wage types used in Payroll.

Use
The wage type catalog in the standard system includes model wage types [Extern] that are configured for the Payroll process. You generate your wage types by copying the model wage types to your customer name range. You can then modify the copies to suit your company-specific requirements.

⚠️ Only use customer-specific wage types [Extern] in your live payroll run.

You edit the wage type catalog, for example:

- in Customizing for Personnel Administration under payroll data [Extern]
- in Customizing for Payroll under Environment of Wage Type Maintenance → Create Wage Type Catalog [Extern].

For more information, see the Implementation Guide (IMG) for Personnel Administration under Payroll Data → Wage Type Concept [Extern].

Structure

- The SAP wage type catalog
  It includes all primary and secondary wage types required for Payroll.

- Customer-specific wage type catalog
  You create the customer-specific wage type catalog in Customizing by copying the SAP model wage types into the customer-specific name range.
Creating the Customer-Specific Wage Type Catalog

Use
You use the wage type copier [Seite 173] to create your own wage type catalog from the SAP wage type catalog, which contains all the model wage types. You copy the model wage types into your customer-specific name range and edit the copied wage types so that they meet your requirements.

We recommend that you create your customer-specific wage type catalog within the Customizing framework. This prevents you forgetting important Customizing settings. For example, certain wage type characteristics are already preconfigured and must not be changed for legal reasons.

Prerequisites
Obtain an overview of the wage types required at your company.

Features
You can create your wage type catalog by copying whole wage type groups [Extern] or using prototypes.

- Copying Model Wage Types Assigned to a Wage Type Group [Seite 177]
  If you do not have much experience of using the wage type catalog, it is best to use this procedure. The disadvantage of this procedure is that it is very time-consuming because you must completely configure each wage type you want to use.

- Copying a Model Wage Type as a Prototype [Seite 179]
  Only use this procedure if you have an exact overview of how you want to implement wage types in your company. This saves time because you must edit less customer-specific wage types in detail.

Activities
1. You copy the SAP model wage types to the customer-specific name range. You have the following options:
   - You copy all the model wage types for a whole wage type group.
   - You copy a model wage type as a prototype [Extern]
   - You use one of the wage types, which you have copied into your customer-specific name range within the framework of a wage type group, as a prototype.

2. If you want to define characteristics for your customer-specific wage types, which are different to the model wage types, then you must edit these wage types with regard to
   - your dialog characteristics (for example, whether it is entered in the infotype)
   - the way it is dealt with in payroll (for example, processing classes and evaluation classes)
Creating the Customer-Specific Wage Type Catalog

If you work with wage type groups you make this specification for every wage type; if you work with prototypes you make this specification for every prototype.

3. If you have copied a sample wage type into your customer-specific name range as a prototype, you then duplicate this prototype. In this way you generate several wage types with the same characteristics from this prototype. You can still correct prototypes you have copied, for example, to adjust them to suit the wage type text.
Copying Model Wage Types Assigned to a Wage Type Group

You can create your customer-specific wage type catalog by copying model wage types for a wage type group from the SAP wage type catalog to the customer-specific name range. You can also copy just some of the model wage types assigned to a wage type group.

Procedure

1. Choose Copy in the initial screen of the wage type copier. The Copy Wage Types screen appears.
   - The Test Run function is active. We recommend that you carry out a test run first of all.
   - To use the wage type copier live, deactivate the Test Run function.

2. Choose Wage Type Group (change wage type group) and specify a wage type group. The wage types from the wage type group are displayed when you enter long and short texts.

3. Select the wage types you want to copy and choose CWT (Automatic Assignment of Customizing Wage Types). The Wage Type Maintenance dialog box appears.

4. Enter the necessary data and choose .

   Only use wage type names from the customer-specific name range, in other words, names that start with a digit. You can also enter the customer wage type names individually.

   The copied wage types are displayed with the copy of the long and short texts.

5. Adapt the wage type texts to meet your requirements, if necessary.

6. Select the wage types you want to copy, and choose Copy.

Result

You have copied sample wage types from a wage type group into the customer-specific name range. A list of the copied wage types is displayed for control purposes.

Your customer-specific wage types have the same wage type characteristics as the SAP sample wage types that you have copied. You can change these characteristics in all the steps in Customizing in which you edit wage type characteristics.

In Customizing for Personnel Administration, the Wage Types section is available in the Payroll Data unit for each infotype. Here you can edit valid wage types for this infotype.
Copying Model Wage Types Assigned to a Wage Type Group

In Customizing for Payroll under Environment → Environment of Wage Type Maintenance → Check Wage Type Characteristics [Extern] you can change the dialog characteristics of your customer-specific secondary wage types.
Copying a Model Wage Type as a Prototype

Use

If some of the wage types that you need have similar wage type characteristics, you can use prototypes to create your customer-specific wage type catalog. In doing this, you copy a sample wage type from a wage type group in the SAP wage type catalog into the customer-specific name range as a prototype. You can adjust the wage type characteristics of the prototype so that they meet the needs of your enterprise. Then you create the remaining customer-specific wage types for this wage type group, by copying the prototype several times.

If you use this procedure you should have an exact overview of how you want to implement wage types in your company.

Procedure

2. Choose Copy in the initial screen of the wage type copier [Seite 173].

The Copy Wage Types screen appears.

- The Test Run function is active. We recommend that you carry out a test run first of all.
- To use the wage type copier live, deactivate the Test Run function.

2. In the Original WT field (Original Wage Type) enter the model wage type for the prototype and choose .

The wage type text for the sample wage type is displayed.

3. In the Customizing WT field (Customizing Wage Type) enter the customer-specific wage type name for the prototype and select .

Only use wage type names from the customer-specific name range, in other words, names that start with a digit.

4. Adapt the wage type texts to meet your requirements, if necessary.

5. Select the wage type and choose Copy.

Result

A model wage type is copied to the customer name range as a prototype. A list of the copied wage types [Seite 182] is displayed for control purposes.

Your customer-specific wage types have the same wage type characteristics as the SAP sample wage type that you have copied. You can change these characteristics in all the steps in Customizing in which you edit wage type characteristics.

In Customizing for Personnel Administration, the Wage Types section is available in the Payroll Data unit for each infotype. Here you can edit valid wage types for this infotype.
Copying a Model Wage Type as a Prototype

In Customizing for Payroll under Environment → Environment of Wage Type Maintenance → Check Wage Type Characteristics [Extern] you can change the dialog characteristics of your customer-specific secondary wage types.
Duplicating a Wage Type

Use

You have copied a wage type as a prototype into your customer-specific name range and now want to duplicate it, so that you have several similar wage types available in your customer-specific wage type catalog.

In general you proceed as in copy model wage types for a wage type group [Seite 177].

Prerequisites

You defined the wage type characteristics of the prototype in Customizing, to meet your requirements.

Procedure

3. Choose Copy in the initial screen of the wage type copier [Seite 173].

   The Copy Wage Types screen appears.
   
   - The Test Run function is active. We recommend that you carry out a test run first of all.
   - To use the wage type copier live, deactivate the Test Run function.

2. In the Original WT field (Original Wage Type) enter the name of your prototype and choose.

   The wage type texts for the prototype are displayed.

3. Select the prototype and select 1 Duplicate WT (duplicate wage type).

   The Wage Type Maintenance dialog box appears.

5. Enter the necessary data and choose.

   Only use wage type names from the customer-specific name range, in other words, names that start with a digit. You can also enter the customer wage type names individually.

   The copied wage types are displayed with the copy of the long and short texts.

6. Adapt the wage type texts to meet your requirements, if necessary.

7. Select the wage types you want to copy, and choose Copy.

Result

You have duplicated the prototype. A list of the copied wage types [Seite 182] is displayed for control purposes.
List of Copied Wage Types

Definition
Overview of the wage types that you have copied in the customer-specific name range and the SAP system tables that belong to them.

Use
The list of the copied wage types is displayed at the end of a copying procedure in the wage type copier [Seite 173]. You can use the list to determine whether

- you have to reprocess table entries manually
  These tables are highlighted in yellow in the tree structure
- a table is locked by another user so that no changes can be made
  These tables are highlighted in red in the tree structure

Do not leave the wage type copier if tables are locked by other users. The information that you have already entered for copying the wage types is therefore not lost. Instead, ask the other users to leave the table. After they have come out of the table in question, you can edit the wage type.

Structure
The list of the copied wage types is represented by the system as a tree structure. It contains

- A list of all tables into which wage types have been copied by the system or should be copied.
- Information on which copied wage types are assigned to the corresponding tables.
  The assignment of the wage type to the table either takes place using the key or the function part of the table:
    - Key
      In this case the table field, which the wage type name contains, is part of the table key. In such tables the system copied the entries.

Table T511 (Wage Types) has the following key fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>000</td>
<td>Client</td>
</tr>
<tr>
<td>99</td>
<td>Country group</td>
</tr>
<tr>
<td>3333</td>
<td>Customer wage type name</td>
</tr>
<tr>
<td>99991231</td>
<td>Expiry date of the wage type</td>
</tr>
</tbody>
</table>

In this table the wage type name is part of the key. The wage type could have been copied by the system.
Function part

In this case, the wage type name is included in the function part of the table rather than the key. The function part of a table consists of all the fields that do not belong to the table key. If the wage type name is in the function part of the table, it is not possible to simply copy the table, because then the table will have several entries with the same key.

In such tables the system could not automatically copy the wage type. You must therefore copy wage types manually [Seite 184].
Copying Wage Types Manually

Use
In the list of copied wage types [Seite 182] the SAP tables, in which the system can not copy the model wage types to the customer-specific name range, have a yellow background. You must copy these wage types manually.

Prerequisites
You have copied model wage types to your customer name range using the wage type copier [Seite 173], and are now in the list of copied wage types.

Procedure
You have two editing possibilities:

Overwrite in Customizing

   We recommend this procedure.
   1. Click on the text Wage type is Not a Key Field, Please Maintain Manually, which is displayed with a yellow background.
      You access the section in Customizing where you can call up the appropriate activity to edit the wage type.
   2. Call the activity.
   3. Overwrite the name of the model wage type with your customer wage type name.

Overwrite Directly
In the list of copied wage types, flag the wage type you want to edit, and choose Overwrite.

This procedure is useful if you have to edit a lot of wage types manually.
Time-Based Delimitation of a Wage Type

Use
If you no longer need a customer-specific wage type, you can delimit this wage type (time-based) using the wage type copier. It is then no longer available in your system.

⚠️ Never delimit SAP model wage types.
Never delimit customer-specific wage types in a live system; only ever do this in a test system.

We recommend that you do not delimit wage types with respect to time, as this can cause problems during the Payroll run. Instead, you should define in Customizing that the wage type should no longer be permitted for entry in any infotype. For example, you have the possibility of doing this for each infotype in Customizing for Personnel Administration in the section Payroll Data [Extern]

Prerequisites
You have copied SAP model wage types to the customer name range.

Procedure
1. Choose Delete in the initial screen of the wage type copier [Seite 173].
   The Delete Wage Types screen appears.
2. In the column Delete WT (wage type to be deleted), enter the name of the wage types that you want to delimit with respect to time.
3. Select the wage types that you want to delimit.
4. Select Limit wage types according to time until... and enter the delimitation date.
   The delimitation date must be a payroll period after the date from which you no longer need the wage type. The system still needs the wage type for another payroll period, to be able to import the payroll result from the previous period.
5. Choose Delete.
   A list of the deleted wage types [Seite 189] is displayed.

Result
The system makes the following changes in the SAP System tables:

- In the date-dependent tables, the system sets the end date of the selected wage type to the delimitation date you have specified. The wage type is still available in this table, but can only be used up until this delimitation date.
  Example: Table T512W (Wage Type Evaluation)
Time-Based Delimitation of a Wage Type

- In the tables that are not date dependent, the system cannot delimit the wage type. The following options are available:
  - If the wage type to be delimited is part of the table key, it is deleted. This means that you will no longer be able to copy the wage type.
    
    Example: Table T555K (Transfer to Time Wage Types)
  - If the wage type to be delimited is not part of the key, you have to manually delimit the wage type.
Deleting Wage Types

Use

If you no longer need a customer-specific wage type, you can delete this wage type from the wage type catalog using the wage type copier. It is then no longer available in your system.

Never delete SAP model wage types.

Never delete customer-specific wage types in a live system; only ever do this in a test system.

We recommend that you do not delete wage types, as this can cause problems during the Payroll run. Instead, you should define in Customizing that the wage type in question should no longer be permitted for entry in any infotype. For example, you have the possibility of doing this for each infotype in Customizing for Personnel Administration in the section Payroll Data [Extern]. As an alternative we recommend that you do not delete the wage type, but rather that it should be delimited with respect to time [Seite 185].

Prerequisites

You have copied SAP model wage types to the customer name range.

Procedure

2. Choose Delete in the initial screen of the wage type copier [Seite 173].

The Delete Wage Types screen appears.

2. In the column Delete WT (wage type to be deleted), enter the name of the wage types that you want to delete.

Only specify wage type names from your customer name range.

3. Select the wage types you want to delete.

4. Select Delete Wage Types.

5. Choose Delete.

A list of the deleted wage types [Seite 189] is displayed.

Result

The system makes the following changes in the SAP System tables:

- If the wage type name is in the table key, the system deletes all table entries for the selected wage type.

- If the wage type name is not in the table key, but is contained in the function part of the table, then the system can not delete the entry. These table entries must therefore be deleted manually [Seite 190].
Deleting Wage Types

The deleted wage type is neither available for wage type copying or for other activities in the SAP system.
List of Deleted Wage Types

Definition
Overview of the customer wage types that you have deleted or delimited with respect to time, and the SAP system tables which belong to them.

Use
The list is displayed if you have deleted or delimited customer wage types in the wage type copier [Seite 173]. You can use the list to determine whether

- you have to reprocess table entries manually
  - These tables are highlighted in yellow in the tree structure
- a table is locked by another user so that no changes can be made
  - These tables are highlighted in red in the tree structure

**Do not** leave the wage type copier if tables are locked by other users. Otherwise, the information that you have already entered for deleting or delimiting the wage types gets lost. Instead, ask the other users to leave the table. After they have come out of the table in question, you can edit the wage type.

Structure
The list of the deleted wage types is represented by the system as a tree structure. It contains

- A list of all the tables in which wage types have been, or should have been, deleted or delimited by the system.
- Information on which deleted /delimited wage types were assigned to the corresponding tables.

The assignment of the wage type to the table either takes place using the key or the function part of the table. For more information, see the list of copied wage types [Seite 182].

- If the table field, which contains the wage type names, is part of the table key, the system has deleted or delimited the entry with respect to time.
- If the wage type name is contained in the function part of the table, the system could not automatically delete or delimit the wage type with respect to time. You must therefore delimit or delete these wage types manually [Seite 190].
Deleting or Delimiting Wage Types Manually

Use
In the list of deleted wage types [Seite 189] the SAP tables, in which the system can not delete or delimit the customer-specific wage types, have a yellow background. You must delete or delimit these wage types manually.

Prerequisites
You have delimited or deleted customer-specific wage types using the wage type copier [Seite 173] and are now in the list of deleted wage types.

Procedure
You have two editing possibilities:

Delete or Delimit in Customizing

We recommend this procedure.

1. Click on the text Wage type is Not a Key Field, Please Maintain Manually, which is displayed with a yellow background.
   You access the section in Customizing where you can call up the appropriate activity to edit the wage type.

2. Call the activity.
3. Delete the customer-specific wage or delimit it with respect to time.

Delete Directly or Delimit (Time-Based)

In the list of deleted wage types, flag the wage type you want to delete or delimit, and choose Delete or Delimit.

This procedure is useful if, for example, you have to delete or delimit a lot of wage types manually.
Assigning Wage Types to Wage Type Groups

Use

The customer-specific wage types, which you have copied from SAP model wage types, are automatically assigned to the same wage type group [Extern] as the model wage types. You can change this assignment. Moreover, you can also obtain an overview of the assignment of wage types to wage type groups.

⚠️

The assignment of wage types to logical views [Extern] takes place using wage type groups. If you remove a wage type from a wage type group, it is no longer available in the logical view to which the wage type group is assigned for editing of the wage type characteristics.

Scope of Function

In transaction PU98 (Assign Wage Types to Wage Type Groups) you have the following options:

- Assign customer wage types to a wage type group

  After a release upgrade from Release 2.1 or 2.2 to Release 3.0 or higher, you must assign all customer-specific wage types to a wage type group. Wage type groups were only introduced with Release 3.0 of the SAP-R/3 System. This means that you must include wage types created in Release 2.1 or 2.2 in wage type groups.

- Delete customer wage types from a wage type group

  When you have created a customer wage type catalog, you can delete a customer wage type from a wage type group.

- Display all wage types that are not assigned to a wage type group

  You can display the customer wage types that have not been assigned to a wage type group.

- Display all wage types assigned to a particular wage type group

  For example, you can display all wage types assigned to the (Basic Pay) wage type group (0008).

- Display assignment of wage types to wage type groups

  You can display the wage type groups to which one or several wage types are assigned.

  If you want to display the assignment of more than one wage type, you have the following options:

  - Display the total quantity:

    All of the wage type groups containing at least one of the selected wage types are displayed.

  - Display the common quantity:

    The wage type groups containing all of the wage types are displayed.
Assigning Wage Types to Wage Type Groups
Displaying the Assignment of Wage Types to Wage Type Groups

Use
If, for example, you delete a customer-specific wage type from a wage type group and you want to assign it to another wage type group, you can first of all check to see the wage type groups to which this wage type is already assigned.

Procedure
1. Select transaction PU98.
2. In the Template Using Model Wage Types block, choose the entry All Wage Types.
3. Select the wage types whose assignment to wage type groups you want to check.
4. Select one of the following indicators:
   - **Total quantity**
     All of the wage type groups containing at least one of the selected wage types are displayed.
   - **Common quantity.**
     The wage type groups, in which all the selected wage types are contained, are displayed.
5. Choose Display Groups.

Result
In the Wage Type Groups block, depending on the indicators you have selected, the corresponding wage type groups are flagged:
- to which at least one of the selected wage types is assigned
- to which all of the selected wage types are assigned
Deleting Customer Wage Types from a Wage Type Group

Use
You want to change the assignment of a customer-specific wage type to the wage type groups. You want to delete the wage type from a wage type group and now want to assign it to another wage type group.

Procedure
1. Select transaction PU98.
2. In the Wage Types to be Assigned block, choose the Customer-Specific Wage Types entry.
   A list is displayed of all customer wage types.
3. Select the customer wage type that you want to delete from a wage type group.
4. In the Wage Type Groups block, select the wage type group from which the wage type should be deleted.
5. Select the Delete indicator.
6. Choose Group assignment.
   The Delete Wage Types in the Wage Type Groups dialog box appears. A dialog box is displayed for control purposes telling you which wage types are deleted from which wage type groups.
7. Choose .

Result
The customer wage type is deleted from the selected wage type group.
Assigning Customer Wage Types to a Wage Type Group

Use
You want to change the assignment of a customer-specific wage type to the wage type groups. You have deleted the wage type from one wage type group and now want to assign it to another wage type group.

After changing from Release 2.1 or 2.2 to Release 3.0 or a later release, you have to first of all assign all the customer-specific wage types, which you created in earlier releases, to a wage type group.

We recommend that you proceed as follows:
1. Choose a customer wage type to be assigned.
2. Select a model wage type that corresponds to the customer wage type.
3. Display the wage type groups [Seite 193], to which the selected model wage type is assigned.
4. Assign the customer wage type to these wage type groups.

Procedure
1. Select transaction PU98.
2. In the Wage Types to be Assigned block, choose the Customer-Specific Wage Types entry.
   A list is displayed of all customer wage types.
3. Select the customer wage type that you want to assign to a particular wage type group.
4. In the Wage Type Groups block, select the wage type group to which the wage type should be assigned.
5. Flag the Insert indicator.
6. Choose Group assignment.
   The Add Wage Types to Wage Type Groups dialog box appears. A dialog box is displayed for control purposes telling you the wage types you have assigned to the wage type groups.
7. Choose .

Result
The customer wage type is assigned to the selected wage type group.
Using Wage Types

Use

The function enables you to obtain an overview of the wage type characteristics for all the primary and secondary wage types that you use. You might want to do this to compare the characteristics of different wage types, for example, or to obtain an overview of the status of your wage types within the system.

To obtain the overview, run report program RPDLGA20 (Use of Wage Types in Payroll). The report generates a list of the wage types available for a selected country.

Scope of Function

The report only evaluates the wage types that affect the Behavior of a Wage Type in Payroll, and not the characteristics that determine the Behavior of a Wage Type On-Line.

The list is arranged according to wage type characteristics and their specifications. The wage types, which are assigned to the following wage type characteristics, are displayed.

- Processing classes
- Evaluation classes
- Cumulations
- Bases for calculating averages
- Valuation bases

In the wage type utilization list, the personnel areas that belong to the selected country are displayed.
Creating a Wage Type Utilization List

1. Choose Human Resources → Payroll → Environment → Wage Type Utilization.

2. In the Country Grouping field of the Selection block, enter the country grouping for which you want to check the wage type utilization.

3. In the Wage Type Validity field enter a validity period.
   - The system only displays the usage of the wage types that are valid within this validity period.

4. If necessary, restrict the evaluation to one or several wage types, by entering it in the Wage Type field.

5. Select Display Logical Views, if necessary.
   - In the generated tables or tree structure, all the logical views [Extern] in which you can edit the corresponding class are displayed for the processing classes, evaluation classes and cumulations, if you flag this option. If there is an IMG section corresponding to the logical view, this will be displayed. You can navigate from the wage type utilization list to the corresponding IMG activity and make the changes there.

6. In the Output block, select the required output form.
   - To display a list with a hierarchical structure, choose Table.
     - If, for example, you are only interested in the use of individual processing classes in wage types, we recommend you use a table as the output form for the results. Displaying the results in table form takes less time, because the system only determines the relevant information when it accesses the next level.
     - In the tables you can double click on a line of the table (for example, Processing Classes) to navigate to the detailed view for the corresponding table entry.
   - To display a list with a tree structure, choose Tree Structure.
   - To obtain a non-hierarchical list of the wage type characteristics, choose Continuous List.
     - If you want to obtain a complete where-used-list, you should use the tree structure or continuous list as the output form for the results. It takes longer, however, if you use the tree structure and the continuous list, because the system has to determine all the information for the sub-nodes and levels before it can display the results.

7. Choose Program → Execute.
Wage Type Split

Definition

The division of payroll periods into partial periods when entries in different infotypes have been changed. The wage types are assigned to these partial periods.

The wage type split has the following significance in the payroll results:

- It defines changes to infotypes for the exact day and indicates these periods in the payroll results using a two-digit number: the split indicator.
- It provides a link from the Results Table RT to other payroll tables. The information relevant for the split is assigned to the infotype using this table.

The Work Center-/Basic Pay Split (WPBP-Split) [Extern] provides a link to table WPBP:

Use

The system uses the following wage type splits:

<table>
<thead>
<tr>
<th>Wage Type Split</th>
<th>Use if</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work Center-/ Basic Pay Split (WPBP-Split)</td>
<td>an employee’s work center and/or basic pay change within a payroll period</td>
</tr>
</tbody>
</table>
### Wage Type Split

<table>
<thead>
<tr>
<th>Split Description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Accounting Split (KR-Split)</td>
<td>An employee's assignment to a cost center changes within a payroll period.</td>
</tr>
<tr>
<td>Split for Different Payments (ALP- Split)</td>
<td>An employee carries out substitution during a payroll period and is remunerated differently than normal.</td>
</tr>
<tr>
<td>Absence Split (AB-Split)</td>
<td>An employee is absent once or several times (for example, leave or illness) during a payroll period.</td>
</tr>
<tr>
<td>Bank-Transfer-Split (BT-Split)</td>
<td>An employee has one main bank account and one, or several, secondary bank accounts.</td>
</tr>
<tr>
<td>Variable Split (VO-Split)</td>
<td>There is special information available for an employee for a payroll period, for example, information on a garnishment, a loan or a company car.</td>
</tr>
<tr>
<td>Country-Specific Splits (C1-Split, C2-Split, C3-Split)</td>
<td>There is country-specific information available for an employee for tax, social insurance and so on.</td>
</tr>
</tbody>
</table>

The WPBP-split is displayed as AP-split in the RT table because of space restrictions.
Wage Type Split: Example 1

An employee's standard pay is changed on January 10 in the Basic Pay (0008) infotype:

01.01. 10.01. 31.01.

<table>
<thead>
<tr>
<th>Standard Pay wage type (MA10)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work Center-/Basic Pay Split (WPBP)</td>
</tr>
</tbody>
</table>

Wage type MA10 is available with a Work Center-/Basic Pay Split (WPBP-Split). The WPBP-split covers two partial periods that are indicated in the payroll results with split indicators:

<table>
<thead>
<tr>
<th>Time Characteristic</th>
<th>Representation in the Payroll Results (Table RT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start date</td>
<td>End date</td>
</tr>
<tr>
<td>01.01.</td>
<td>09.01.</td>
</tr>
<tr>
<td>10.01.</td>
<td>31.01.</td>
</tr>
</tbody>
</table>
Wage Type Split: Example 2

An employee’s standard pay is changed on January 12 in the Basic Pay (0008) infotype: A Work Center-/ Basic Pay Split (WPBP-Split) is created as a result. The employee also takes leave twice in this payroll period. Wage type AB01 is generated to calculate the absences. An Absence Split (AB-Split) exists for this wage type.

<table>
<thead>
<tr>
<th>Start date</th>
<th>01.01.</th>
<th>12.01.</th>
<th>16.01.</th>
<th>25.01.</th>
<th>31.01.</th>
</tr>
</thead>
<tbody>
<tr>
<td>End date</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Wage type</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Character</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AP</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Payroll Period 01 (January)

<table>
<thead>
<tr>
<th>Start date</th>
<th>01.01.</th>
</tr>
</thead>
<tbody>
<tr>
<td>End date</td>
<td>02</td>
</tr>
<tr>
<td>Wage type</td>
<td></td>
</tr>
<tr>
<td>Character</td>
<td></td>
</tr>
<tr>
<td>AB</td>
<td></td>
</tr>
</tbody>
</table>

Work Center-/Basic Pay Split

<table>
<thead>
<tr>
<th>Start date</th>
<th>End date</th>
<th>Wage type</th>
<th>Character</th>
</tr>
</thead>
<tbody>
<tr>
<td>01.01</td>
<td>11.01</td>
<td>ABO1</td>
<td>01</td>
</tr>
<tr>
<td>12.01</td>
<td>31.01</td>
<td>ABO1</td>
<td>02</td>
</tr>
</tbody>
</table>

Absence Split

<table>
<thead>
<tr>
<th>Start date</th>
<th>End date</th>
<th>Wage type</th>
<th>Character</th>
</tr>
</thead>
<tbody>
<tr>
<td>01.01</td>
<td>15.01</td>
<td>ABO1</td>
<td>01</td>
</tr>
<tr>
<td>25.01</td>
<td>31.01</td>
<td>ABO1</td>
<td>02</td>
</tr>
</tbody>
</table>

Both splits are represented in the payroll results as follows:

<table>
<thead>
<tr>
<th>Start date</th>
<th>End date</th>
<th>Wage type</th>
<th>Character</th>
</tr>
</thead>
<tbody>
<tr>
<td>01.01</td>
<td>11.01</td>
<td>ABO1</td>
<td>01</td>
</tr>
</tbody>
</table>
Wage Type Split: Example 2

<table>
<thead>
<tr>
<th>Date</th>
<th>Date</th>
<th>Code</th>
<th>01</th>
<th>02</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.01.</td>
<td>15.01.</td>
<td>ABO1</td>
<td>01</td>
<td>02</td>
</tr>
<tr>
<td>25.01.</td>
<td>31.01.</td>
<td>ABO1</td>
<td>02</td>
<td>02</td>
</tr>
</tbody>
</table>
Payments

Definition

Payments that the employee is entitled to according to the employment contract (= stipulated in the employment contract) or that they accrue (= paid voluntarily by the employer).

The individual payments form the basis for the calculation of an employee’s gross remuneration, which is the core part of payroll. Gross remuneration is the starting point for the calculation of social insurance and tax payments, and also for the calculation of net remuneration.

Structure

In the SAP System, payments are split into the following categories according to their characteristics:

- Basic pay
  
  Basic pay consists of the fixed wage and salary elements that are paid in every payroll period. You enter them in the form of wage types in the Basic Pay(0008) infotype.

- Recurring payments and deductions
  
  Recurring payments and deductions are paid or retained with fixed frequency. The system determines the payments using factors such as overtime, leave or substitutions. You enter the wage types which illustrate these factors in the Recurring Payments and Deductions (0014) infotype. In the processing stage, the system uses the Customizing settings representing the collective agreement.

- Additional Payments
  
  Additional payments are wage and salary elements that are not usually paid in each payroll period, and that are not paid at regular intervals. You enter them in the Additional Payments(0015) infotype.
Basic Pay (Infotype 0008)

You can store the employee’s basic pay in the Basic Pay infotype (0008). You get an overview of the employee’s payroll history using the infotype history.

The standard system contains the following reference types:

- Subtype 0: Basic contract
- Subtype 1: Increase basic contract
- Subtype 2: Comparable domestic pay
- Subtype 3: Refund of costs in foreign currency
- Subtype 4: Local weighting allowance

You can process the Basic Pay infotype (0008) on its own or during a personnel action. If you want to create a new infotype record, enter the reference type on the screen Maintain HR Master Data. The reference type is already set if you carry out a personnel action.

Pay scale

The system automatically proposes the Pay Scale Type and the Pay Scale Area. However, you can overwrite these values.

Wage types

If you want to insert an infotype record, the system automatically suggests the wage types. There are a few wage types which you can not overwrite or delete. You can enter up to 20 wage types.

⚠️

When an employee leaves a company you are not permitted to delimit the Basic Pay infotype (0008). Basic payroll data must remain in the system. This is the only way of ensuring the accuracy of any retroactive accounting runs that need to be performed.

See also:

- Enter Basic Pay [Seite 205]
- Performing a Personnel Action [Seite 208]
- Performing a Standard Pay Increase [Seite 210]
Editing Basic Pay

Procedure

1. Choose the menu path Human Resources → Personnel Management → Administration → HR Master Data → Maintain.

   You access the Basic Pay infotype (0008) by calling up the Display HR Master Data, Maintain HR Master Data or Personnel Actions screens.

2. Check the entries from the collective agreement. If necessary, change the pay scale structure assignment.

3. Check the default wage types from the wage type model.

4. Enter an amount for **directly** valuated wage types.

   Directly valuated wage types with no values entered in the Amount, Number and Unit fields are not saved.

5. If necessary, enter a number and a unit for **indirectly** valuated wage types, for example, for wage types whose amount is calculated as a percentage of the sum of other wage types.

   The amount of the indirectly valuated wage types is only displayed, but is not saved. If your Customizing settings specify that indirect valuation is only valid until a date prior to the validity end date of the infotype record in the Basic Pay infotype (0008), an appropriate message will be displayed. If this is the case you can re-enter the date on which indirect valuation should take place, in the *Ind.Val.* field.

   For indirect valuations, an infotype record must be created for the employee in the Planned Working Time infotype (0007).

   Indirectly valuated wage types must not be overwritten because the indirect valuation will therefore be lost.

   You can enter a maximum of twenty wage types for each employee. If your Customizing settings permit fewer wage types, fewer lines will be available.

6. If necessary, delete any default wage types that are not required.

7. Check the total amount of the wage types.

   The total payment amount is calculated by the system. All wage types to be included in the total amount, in accordance with the Customizing settings, are flagged in field A (*Add to Total Amount*).

8. Choose .

   Depending on the Copy Default Values for Infotypes feature (DFINF), the values in the Pay Scale Type, Pay Scale Area, Capacity Utilization Level and Work Hours/Period fields will be redefined, but not copied. The values in the Capacity Utilization Level and Work Hours/Period fields are copied if the values in the old infotype record do not correspond to the default values at that time.
Editing Basic Pay

If you copy the infotype record in a batch input session and change the validity start date, you should first enter a date in the From field and then copy the data. You can then enter data in other fields, (for example, Wage Types).

For more information on editing basic pay, see Performing a Pay Scale Reclassification [Seite 208].
Pay Scale Reclassification

Use

A pay scale reclassification is the transfer of an employee to a different pay scale group and possibly to a different pay scale level. As a result of this transfer, the employee receives the remuneration for the new pay level assignment.

A pay scale reclassification is usually performed in a payroll period prior to the payroll run. The pay scale reclassification must always take place before the standard pay increase.

Activities

You carry out the pay scale reclassification using Report RPITUM00.

The system takes the basis for the pay scale reclassification from Customizing. For more information, see the Implementation Guide (IMG) for Personnel Management under Personnel Administration → Payroll Data → Basic Pay → Pay Scale Changes → Pay Scale Reclassification [Extern].

Alternatively, you can enter a different date for the next increase in the Basic Pay infotype (0008). This alternative date overrides the entries in Customizing.
Performing A Pay Scale Reclassification

Procedure

1. Choose System → Services → Reporting.

2. In the Program field enter report RPITUM00 and choose ☑.

   The selection screen for the report is displayed.

3. In the sections Period, Selection and Further Selections, enter the selection criteria you want to use to perform a pay scale reclassification. For example, you can make a selection according to payroll administrator or a specific organizational unit.

4. Enter the following parameters in the Data Relevant for Batch Input section:
   a. Choose Create Batch Input Session.
   b. Enter the additional parameters.
   c. If necessary, enter the pay scale structure for which you want to perform a pay scale reclassification.

   These entries further restrict the selected employees.

5. Choose ☑.

   If you do not select Create Batch Input Session, the pay scale reclassification will only be simulated. A results log is displayed, that you can evaluate as required.

   You can use reports RPLTRF00, RPLTRF10, and RPSTRF00 to generate lists containing employees employed on a key date with the pay scale structure and additional information on the current pay scale assignment. For more information, see the report documentation.

6. Process the batch input session.

Result

As a result of the pay scale reclassification, the pay scale structure for the employee in the Basic Pay infotype (0008) will be updated. If you have not reset the default value (1601) of the Action/Action for Pay Scale Reclassification parameter, the action performed will also be logged in the Actions infotype (0000).
Standard Pay Increase

Use
You may encounter automatic standard pay increases for employees whose basic pay has been calculated indirectly, based on the assignment to a particular pay scale structure, in accordance with the Customizing settings. For more information, see the Implementation Guide (IMG) for Personnel Management under Personnel Administration → Payroll Data → Basic Pay → Pay Scale Changes → Pay Scale Increase.

Scope of Function
The system differentiates between the following types of standard pay increases:

Simple Standard Pay Increase
The amounts in the Customizing settings are increased by a specific amount or percentage rate.

Extended Standard Pay Increase
The history in the Basic Pay infotype (0008) is updated. You can also modify directly valuated wage types and use different increase variants. You can use increase variants, for example, to insert new wage types, replace existing wage types with new ones, or delimit existing wage types without replacement.

In the following cases, you can use an extended standard pay increase in addition to a simple standard pay increase:

- You want to update the history in the Basic Pay infotype (0008). This applies to those employees whose pay was adjusted using a simple standard pay increase because of its assignment to a pay scale structure.

  The extended standard pay increase saves infotype records in database PA0008. This reduces memory space on the hard disk.

- You want to use additional increase variants for directly and indirectly valuated wage types.
Effecting a Standard Pay Increase

Simple Standard Pay Increase

1. Choose System → Services → Reporting.
2. In the Program field enter report RPU51000 and choose .
   The selection screen for the report is displayed.
3. In the Pay Scale Group, Pay Scale Level and Wage Type fields, enter the employees who should receive a standard pay increase. Enter the date from which the Customizing settings should be changed.
4. In the Increase and Rounding sections, enter the necessary data, for example, an increase amount or an increase percentage rate.
5. Choose .
   The amount of the indirectly valuated wage types is adjusted according to the data in the Customizing settings. No new infotype records have been created in the Basic Pay infotype (0008).

Extended Standard Pay Increase

1. Choose System → Services → Reporting.
2. In the Program field enter report RPITRF00 and choose .
3. In the Selection section, enter the selection criteria you want to use to effect an extended standard pay increase. For example, you can make a selection according to administrator, or a specific organizational unit.
4. Enter the following parameters in the Further Selections section:
   a. Choose Batch Input.
      If you do not select Batch Input, the pay scale reclassification will only be simulated. A results log is displayed, that you can evaluate as required.
   b. If necessary, enter the pay scale structure for which you want to effect a standard pay increase.
   c. Enter the additional parameters.
      These entries further restrict the selected employee headcount.
5. Choose .
6. Process the batch input session.
The payments for the selected employees have been adjusted in accordance with the data specified in Customizing. New infotype records have been created in the Basic Pay infotype (0008).
Recurring Payments/Deductions (Infotype 0014)

In the Recurring Payments/Deductions infotype (0014), you can enter an amount and/or a value and a unit of measurement for a wage type that is always paid or deducted during payroll. Recurring payments/deductions are wage elements which are paid or deducted in every payroll period. In contrast to additional payments, recurring payments/deductions are paid or deducted within a defined periodicity.

In addition, you have the possibility to enter default cost assignment settings for recurring payments/deductions for the application component Controlling (CO). You can store a different cost center and company code combination than the one in the Organizational Assignment infotype (0001); the additional payments will then be charged to this cost center. Select Edit → Maintain cost assignment. The Default Cost Assignment Settings dialog box appears. Enter the relevant data. If any data has already been entered for the cost assignment it will be displayed on the infotype single screen. You can set up further controlling objects using customizing in the section Enter Default Cost Assignment Settings [Extern] in Personnel Administration.

The standard system contains, amongst others, the following wage types:

- Subtype M110: Vacation allowance
- Subtype M120: Holiday bonus
- Subtype M130: Standard special payment
- ...

Recurr. Pay/Deduc

Enter the wage type that is to be paid or deducted in the Wage Type field. In conjunction with the Wage type you must process either the Amount field or the Number and Unit fields. The system checks the combination you entered. The currency is defaulted according to the company code. This can be overwritten.

Date of Payment

A wage type is only paid in certain periods or on certain days. These periods or days can be defined either in the 1st payment period and Interval in periods fields, thus defining the interval to the next and all subsequent periods, or in the 1st payment date and Interval/Unit fields, thus defining the interval to the next day and all subsequent days. Enter the payment period without the payroll year. The subsequent payment periods will be determined by adding the intervals.

If the report RPCDTBX0 (Preliminary Data Medium Exchange Program for Separate Payment Run) has created a preliminary document for a wage type transfer, the Transfer field is displayed on the infotype screen. You can not delete the wage type in this case.

See also:

Define Recurring Payments and Deductions [Seite 214]
Country-Specific Features

Processing Recurring Payments and Deductions

Use
Using recurring payments and deductions you determine the wage and salary components which under normal circumstances you pay or deduct from an employee. You can pay bonuses for travel costs or holiday pay, for example.

You can enter an additional payment that differs from the cost assignment in the Organizational Assignment infotype (0001) for recurring payments and deductions. If this is the case, the recurring payment/deduction will be taken from the cost center that differs from the master cost center.

Defining Recurring Payments and Deductions

2. Enter the personnel number of the employee concerned and choose the Recurring Payments and Deductions infotype (0014).
3. Choose .
4. Enter the data required in the fields.

The entries in the Amount and Number/Unit fields depend on the selected wage type. For directly valued wage types, enter the amount and the number or unit. This is not necessary for indirectly valued wage types.

You can either make entries in the First Payment Period and Interval in Periods field, or in the First Payment Date and Interval/Unit field. If you have entered the first payment period and the interval in periods, you cannot enter data for the payment date and interval/unit, and vice versa.

5. Choose .

Defining Recurring Payments and Deductions for Varying Account Assignments.

1. On the Recurring Payments and Deductions screen choose .

The Cost Assignment Defaults dialog box appears.
2. Enter the different assignments.
3. Choose Transfer.

You have created a cost assignment for a recurring payment/deduction that differs from the cost assignment in the Organizational Assignment infotype (0001).
Additional Payments (Infotype 0015)

In the infotype Additional Payments (0015), you can enter an amount and/or a value and a unit of measurement in a wage type; these are always paid or deducted in a certain period during payroll. Additional payments are wage elements which are not paid or deducted in every payroll period in contrast to recurring payments and deductions which are paid or deducted within a defined periodicity.

In addition, you have the possibility to enter default cost assignment settings for additional payments for the application component Controlling (CO). You can store a different cost center and company code combination than the one in the Organizational Assignment infotype (0001); the additional payments will then be charged to this cost center. Select Edit → Maintain cost assignment. The Default Cost Assignment Settings dialog box appears. Enter the relevant data. If any data has already been entered for the cost assignment it will be displayed on the infotype single screen. You can set up further controlling objects using customizing in the section Recording Cost Assignment Specifications [Extern] in Personnel Administration.

The standard system contains, amongst others, the following wage types:

- Subtype M110: Vacation bonus
- Subtype M120: Christmas bonus
- Subtype M30: Special payment
- ...

Additional Payments

Enter the wage type that is to be paid or deducted in the Wage Type field. In conjunction with the Wage type you must process either the Amount field or the Number and Unit fields. The system checks the combination entered. The currency is defaulted according to the company code. This can be overwritten.

The system uses the last day of the current payroll period as the date of origin of the additional payment. You can overwrite this default value by

- entering another date in the field Date of origin
- entering the required payroll period and payroll year in the fields Default date.

If you enter a different payroll period in the fields Default date the system defaults the last day of the specified payroll period as the date of origin.

If the report RPCDTBX0 (Preliminary Data Medium Exchange Program for Separate Payment Run) has created a preliminary document for a wage type transfer, the Transfer field is displayed on the infotype screen. You can not delete the wage type in this case.
Additional Payments (Infotype 0015)

See also:
Edit Additional Payments [Seite 217]
Processing Additional Payments

Use

By means of additional payments an employee can receive a one off payment on a fixed date, for example, on their anniversary of years of service.

You can also transfer wage types stored in the Additional Payments infotype (0015) gross for net as an unqualified advance payment [Seite 89] before the actual payment date.

Creating Additional Payments

2. Enter the personnel number of the employee concerned, and choose the Additional Payments infotype (0015).
3. Choose .
4. Enter the required data in the fields.

The entries in the Amount and Number/Unit fields depend on the selected wage type. For directly valuated wage types, enter the amount and the number or unit. This is not necessary for indirectly valuated wage types.

For the date on which the additional payment should take place, the system suggests the last day of the current payroll period from the payroll control record. You can overwrite the default value by entering another payroll period.

5. Choose .

Entering Additional Payments for Varying Account Assignments

You can enter an additional payment that differs from the cost assignment in the Organizational Assignment infotype (0001). If this is the case, the payment will be deducted from the cost center that differs from the master cost center.
Processing Additional Payments

**Procedure**

1. On the *Create Additional Payments* screen, choose...
   
   The *Cost Assignment Defaults* dialog box appears.

2. Enter the different assignments.

3. Choose *Transfer*.

You have created a cost assignment for an additional payment that differs from the cost assignment in the *Organizational Assignment* infotype (0001).
Standard Wage Maintenance

Use

You can use this function to guarantee wage or salary payments for an employee if his or her pay has decreased. The difference between the current pay and guaranteed pay is calculated by the system and is known as the standard wage maintenance amount. The different collective agreements include various types of standard wage maintenance clauses for salaried and hourly-paid employees.

You can create different wage maintenance types for your employees, for example:

- Wage maintenance in the event of a pay scale downgrade
- Provision for old age
- Wage maintenance as part of a social compensation plan or similar action.

You can define a fixed wage maintenance amount, or you can project the amount, in other words, you can reduce or increase the amount in regular intervals.

Features

Standard wage maintenance types

It is possible to create different wage maintenance types in Customizing. These wage maintenance types can then be called as subtypes in the Standard Wage Maintenance infotype (0052) [Seite 221]. You can enter the guaranteed pay for your employee using one or more standard wage maintenance types.

Adjustment types

You can adjust the guaranteed wage and salary payments in the following ways:

- You can periodically increase (or decrease) the payment by a constant value
- You can periodically increase (or decrease) the payment by a percentage value

The adjustment type is defined for a wage maintenance type.

Print to remuneration statement

You can print the difference between an employee’s current pay and the pay guaranteed in wage maintenance as a statement wage type on the remuneration statement.
Standard Wage Maintenance

You make the settings that define functions performed in wage maintenance in Customizing for Personnel Management under Personnel Administration → Payroll Data → Standard Wage Maintenance.
Standard Wage Maintenance (Infotype 0052)

Definition
The wage maintenance amount is calculated by the system and is the difference between the current and guaranteed pay. You enter the guaranteed pay for your employee in the Standard Wage Maintenance infotype (0052).

Use
You can determine the wage maintenance amount using different reasons and different adjustment types. Please refer to the section Standard Wage Maintenance [Seite 219].

Standard wage maintenance type
The wage maintenance types set up in Customizing are called as subtypes. You can create several wage maintenance types for an employee.

Pay scales
You can either enter data in the Pay Scale Type, Pay Scale Area and Pay Scale Group fields, or you can save them without data. The pay scale group and pay scale level are used for the indirect valuation of wage maintenance wage types and are not required for direct valuation.

Wage types
You can only enter wage types set up for wage maintenance in Customizing. The wage type list can include up to 20 wage types.
Wage types that are included in the total are flagged with an X in the T field.

Wage type valuation
You can either valuate the wage types directly, or they can be indirectly valuated by the system.
For indirect valuations, an infotype record must be created for the employee in the Planned Working Time infotype (0007). If the indirect valuation is only valid until a date that is before the validity end of the record, the system displays an appropriate message. If this is the case, you can enter the date on which indirect valuation should take place again.
Indirectly-valuated wage types are flagged with an I after the amount.

For more information on wage type valuation, refer to the section Valuating Wage Types [Seite 256].
Time Quota Compensation Infotype (0416)

Definition

Time quota compensation allows a financial remuneration of absence entitlements that have not been deducted by absences.

Use

You can use the Time Quota Compensation infotype (0416) to remunerate absence entitlements such as Leave or Time in lieu of overtime. When the compensations are recorded, the remaining quota or leave that has not been deducted or compensated is reduced by the specified amount.

Structure

- Various methods for compensating quota remainders are defined in Customizing. They simplify the recording of quota compensation. You choose the method you require by specifying a subtype for the infotype.
  
  For more information, see Methods for Compensating Time Quotas [Extern]

- The list of absence quotas in the infotype shows which quotas can be compensated. It displays all the employee's absence entitlements that are available for deduction on the current day.

  You can branch to the corresponding infotype record by double-clicking the absence quota. This shows additional, detailed information on the quota, such as whether deduction can result in a negative value, for example.

- You can project a recorded compensation. In this process, the SAP System calculates anticipated changes to the quota, without saving the data record. This process is recommended

- If you are unsure whether there is enough remaining quota to perform compensation

- If you want to check which quotas are reduced by a compensation

- You have the option of checking the specified compensation before saving. The check enables you to view which quotas are reduced by the compensation and by how much.

- You can compensate all of an employee's quotas at the same time. This process is recommended if, for example, an employee leaves the company. You must be able to perform free compensation to be able to do this.

  The SAP System automatically writes the quota remainder for each quota type to the number field of the compensation in the list of quotas. You can overwrite the number that is determined automatically.
**Employee Remuneration Info Infotype (2010)**

**Definition**

You can use the *Employee remuneration info* infotype (2010) to enter wage types manually and specify information directly for Payroll.

If you work with time evaluation, you can transfer time balances directly using the *Time Transfer Specifications [Extern]* infotype (2012), which in turn has an effect on remuneration.

**Use**

These wage types are not generated automatically in payroll. Use infotype 2010 to enter wage data that has been calculated manually, such as premiums, bonuses for difficult working conditions or other special wage types.

You can adjust the wage types and subtypes of this infotype to your individual requirements in the Customizing system. Here, you can define, for example:

- The wage types that can be used here
- The fields in which data can be entered
- Whether additional information can be entered for Accounting and Logistics
- Whether a wage type can be used once or several times per payroll period.

**Structure**

The following options can be used to control remuneration for a wage type in the infotype:

1. **Number of hours, number, unit, and amount**

   If these fields contain entries, the system uses the values stored in the Customizing system for this wage type. If no *amount* is specified, you can enter one manually in the infotype.

2. **Different payment**

   It is possible to enter additional data on a different payment for remuneration records on the entry screen or via *Goto → Different payment*.

   - Assign a premium
   - Re-define a payment by assigning a pay scale group and level
   - Control payment by entering a different position
   - Add or deduct a specific amount using the *Extra pay indicator* and the *Valuation basis*. 
Employee Remuneration Info Infotype (2010)

See also:
Maintaining Employee Remuneration Information [Seite 246]
Time Management Aspects in Payroll

The *Time Management* (PT) and *Payroll* (PY) components are closely linked in the R/3 System. The processing of time data for determining the gross wage takes place in the gross part of payroll. Subschema xT00 (x=country indicator) is used to process Time Management aspects within Payroll.

These include:

- Creating the personal work schedule and, if necessary, importing the planned working times.

It is possible that differences between the times from the personal work schedule and the planned times may affect the monetary valuation of work performed. This may happen if an employee has substituted for another employee, for example.

- Forming partial period factors; see also *Partial Period Calculations (Factoring)* [Seite 340]
- Forming valuation bases; see also *Valuating Wage Types Using Valuation Bases* [Seite 259]
- Selecting time wage types for overtime, bonuses, and hourly wages, that is, day processing of time data using schema TC00 (time wage type selection: international) or TC04 (time wage type selection: international for time recording without clock times)
- Performing a shift change compensation; see also *Shift Change Compensation* [Seite 238]
- Processing information on a different payment for work performed; see also *Activity with a Higher Rate of Pay* [Seite 239]
- Processing information on manually calculated wage sizes, bonuses, and so on; see also *Employee Remuneration Information* [Seite 243]
- Processing compensation for time off entitlements; see also *Time Quota Compensation (Infotype 0416)* [Seite 222]
- Valuating time wage types; see also *Time Wage Type Valuation* [Seite 258]
- Valuating absences; see also *Absences* [Seite 248]
- Processing incentive wages; see also *Processing Incentive Wages* [Extern]
Integration with Time Management

Purpose

You use this component to calculate time wage types in Payroll, such as bonuses for overtime, night work, or work on public holidays. The time wage types are formed on the basis of time data information. They are used to form employees’ gross wage.

Implementation Considerations

The component acts as an interface between the Payroll component and the Time Management component. The Integration with Time Management component is supplied with time data from the Time Data Recording and Administration component and with time wage types from the Time Evaluation component.

If you only use the Time Data Recording and Administration component, you can use the Integration with Time Management component to evaluate the employee-related time data information and to determine the time wage types. If you also use the Time Evaluation component, the Integration with Time Management component imports the time wage types determined by Time Evaluation. The Integration with Time Management component determines provisional time wage types for periods for which time evaluation cannot deliver current results (due to a payroll run being moved forward, for example).

Integration

With Other R/3 Human Resources Components

<table>
<thead>
<tr>
<th>Desired Function</th>
<th>Required Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managing time accounts</td>
<td>Time Evaluation</td>
</tr>
<tr>
<td>Checking complex working time regulations</td>
<td>Time Evaluation</td>
</tr>
<tr>
<td>Implementing time recording subsystems</td>
<td>Time Evaluation</td>
</tr>
</tbody>
</table>

With Other R/3 Components

<table>
<thead>
<tr>
<th>Desired Function</th>
<th>Required Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compensating work performed and assigning personnel costs according to the source</td>
<td>Controlling</td>
</tr>
</tbody>
</table>

Features

- The time wage types determined, such as hourly wage, overtime wage, and bonuses, form the specifications for the financial valuation of work performed further on in gross payroll.
- In the case of working times that have no specified attendance or absence times, it is assumed in the standard system that the employee has worked according the planned times from his or her work schedule.
- When selecting time wage types, the system can automatically take account of conditions on the duration or time of an activity, public holidays, or weekdays.
• Cost accounting information can also be assigned to the time data. Payroll passes on this information to the wage types formed. This enables the personnel costs resulting from the time data to be made available to Cost Accounting.
Day Processing of Time Data in Payroll

Use
Employee time data recorded in R/3 Time Management contains information about any relevant time-based location, duration, and quality of work completed. This information allows you to determine bonuses.

Day processing for time data forms time wage types from the information recorded in R/3 Time Management during the payroll run.

Prerequisites
The calculation basis is formed from the time data recorded in R/3 Time Management and scheduled employee working times. The following must first be set up in Customizing or in HR Master Data maintenance:

- Create work schedules in Customizing
- Assign work schedules to the individual employees using the Planned Working Time (0007) infotype
- Complete the prerequisites for recording time data records

For more information, see the Implementation Guide (IMG) for Personnel Time Management.

Features
- Time data is processed by the subschema of schema XT00 (Processing Time Data in Payroll, X = country indicator). The subschema is called by the function DAYPR (Day Processing of Time Data)
  
  In the standard R/3 System, the time data is processed using the schema TC00 (Wage Type Generation International) or TC04 (International Wage Type Generation for Time Evaluation without Clock Times) Both schemas record only the exceptions to the daily work schedule. Schema TC00 processes time data recorded in clock time format and are full-day records. Schema TC04 only records time data in hourly format.

- In schema TC00 and TC04 steps and rules are defined for evaluating the time data. The individual processing steps can be modified to suit your specific requirements in Customizing.

- Day processing is carried out during the payroll run. Time data is processed there for each day to be accounted. In the payroll log, you can see the selected time wage types for each day.

- The close relationship between the Time Management and Payroll component ensures a seamless accounting of time data information, including retroactive accounting at any time when changes are made in the future to the time data.

- For Customizing day processing you can use the functions and operations in R/3 Time Evaluation.

See also: Time Wage Type Selection [Seite 233]
Sequence of Day Processing/Wage Type Selection

Purpose

You use the process described here to form time wage types from time data information. The time wage types form the basis for calculating the gross wage.

Prerequisites

Function DAYPR (Day Processing of Time Data) is contained in schema xT00 (Processing Time Data in Payroll; x = country indicator). The subschema to be processed, TC00 (Wage Type Generation: International) or TC04 (Wage Type Generation International for Time Evaluation Without Clock Times) is entered in parameter 2 of the function. Schema xT00 includes all of the steps that are required to calculate time-related gross remuneration. It is processed in the payroll run.

You have customized the processing steps of schema TC00 or TC04 to suit your requirements.

Process Flow

1. Access day processing

Function DAYPR is used to access the subschema for day processing of time data (TC00 or TC04). If you use the Time Evaluation component, the time wage types that have already been determined are imported from Cluster B2. For more information, see Integration Between Time Evaluation and Payroll [Seite 236].

Actual day processing is in schema TC00 or TC04 between functions BDAY (Begin Processing Block of Time Evaluation) and EDAY (End Processing Block of Time Evaluation). This section is run once per day and per employee.

2. Initialization

Function MOD (Determine Groupings) is used in subschema TC00 or TC04 to call personnel calculation rule TMOD. You can use PC rule TMOD to specify the groupings to be used by the payroll driver to access the tables for time type determination and time wage type selection during processing.

Operation MODIF T specifies the time type determination group to be used by the payroll driver to access entries from table T555Z (Time Type Determination) for the employee.

Operation MODIF W specifies the time wage type selection group to be used by the payroll driver to access entries from table T510S (Time Wage Type Selection) for the employee.

3. Load time data

All necessary time data is supplied in a sequence of functions. This includes the recorded attendances and absences, and the specifications from the work schedule. The information is entered in the work table TIP (Day Input).

Refer to: Processing Using Internal Tables [Extern] and Supplying Time Data [Extern]

4. Classify times

In the next step, all entries of table TIP are classified individually. This determines whether the times are planned times or overtime. The TIP entries are then assigned a processing type [Extern]: M for overtime, or S for planned work.
For detailed information on the classification of times, see:

Classification of Times [Extern]

Break Processing by Time Evaluation [Extern]

Overtime Determination by Time Evaluation [Extern]

These links all relate to Time Evaluation documentation. All information relating to forming and processing time accounts is not relevant to Payroll.

5. **Select time wage types**

These TIP entry/processing type combinations are then compared individually to the conditions required by time wage type selection. Particular features are assigned to each day, such as public holiday class, day type, and so on. These features are checked during time wage type selection.

Function DAYMO is used to specify the *Day grouping for time wage type selection* (working days, Sundays, and public holidays) to be used to check the entries of table T510S. You must assign a particular entry in the schema for each of these cases.

Time wage type selection is performed in the schema using function GWT (*Generate Wage Types*). The time wage types are selected on the basis of the processing type of a TIP entry.

Function GWT is accessed twice in the schema:

- GWT S: for TIP entries with processing type S (planned work)
- GWT M: for TIP entries with processing type M (overtime)

This procedure enables the time wage types selected for planned times and overtime to be collected in various tables. In this way, you can control the compensation of overtime wage types.

Function GWT also selects time wage types for all absence that are evaluated according to the 'as if' principle. In the standard system, the absences are assigned processing type S.

For more information on absence valuation, see Absences [Seite 248].

6. **Compensate overtime**

In overtime compensation, it is specified whether the overtime hours are to be remunerated or compensated with time in lieu.

For more information, see the section *Compensate Overtime* in the Implementation Guide for Payroll.
Sequence of Day Processing/Wage Type Selection

7. **Store results**

Function CUMBT (*Cumulate Interim Results*) is used to store the results of day processing in the results tables. The required time types for all days in the payroll period are now in table ZL. If the time data was recorded together with information on cost assignment or on a different payment, ZL still contains pointers to tables C1 and ALP from Cluster B2.

**Result**

The time wage types are transferred from ZL to work table IT in Payroll. They are now available for monetary valuation.
**Time Wage Type Selection**

**Use**

In time wage type selection, you use employees’ time data to determine the hourly wage and bonuses for overtime, work on a public holiday, and night work.

- You want different time wage types to be selected for work on a public holiday than for work on a workday.
- For up to two hours of overtime you want time wage type Mxxx to be selected in addition to the basic hourly wage. This wage type is valuated with a 25% bonus in comparison with the basic hourly wage.

The monetary valuation of the time wage types determined is performed further on in the payroll process.

**Integration**

Time wage type selection is a processing step in day processing of time data in Payroll or Time Evaluation. It is called by function GWT (*Generate Wage Types*) in the schema (TC00 *Wage Type Generation International* or TC04 *Wage Type Generation International for Time Evaluation Without Clock Times* for Payroll, or in the standard time evaluation schemas.

Function GWT processes the entries of table T510S (*Time Wage Type Selection*), which contains the wage types that can be selected and the conditions that must be met for the selection of a wage type.

**Prerequisites**

You have set up table T510S (*Time Wage Type Selection*) to suit your requirements. This is done in Customizing for *Time Evaluation* or *Payroll*.

For more information, see the Implementation Guide for *Time Evaluation* or *Payroll*.

**Features**

There are many different regulations governing the selection of time wage types. They are formed when several individual rules in T510S are grouped into a rule group. In this way, you can group together all corporate regulations for your employee groupings.

Each individual rule contains the time wage type to be selected. In time wage type selection, all individual rules in a rule group are run. If even one of the conditions specified in an individual rule is not fulfilled, the time wage type is not selected.

**Groupings for time wage type selection**

The rule groups for the selection of time wage types are determined according to the *time wage type selection rule group* and the *day grouping for time wage type selection*, which are the key to reading table T510S.
Time Wage Type Selection

- Whether an employee is an hourly wage earner or a salaried employee, for example, plays an important role in time wage type selection. You can therefore use the time wage type selection rule group to group your employees, and set regulations according to the groupings. The time wage type selection rule group is independent of the other organizational groupings in the Human Resources system. It is only used for time wage type selection.

- You can define various rule groups depending on particular factors relating to the day being evaluated (workdays, normal working days, Sundays, public holidays, and so on). You can use the day grouping for time wage type selection to distinguish between the rule groups.

The conditions on the day being evaluated can also be contained in an individual rule.

For a better system performance, however, it is advisable to create rule groups for the selection of time wage types for certain days. In this case, you specify day-related conditions using the day grouping for time wage type selection.

- In day processing, the times are classified according to the information from the work schedule and the recorded time data. The times are assigned an indicator, the processing type. Its main use is to differentiate planned working time and overtime. You can also use it for additional criteria.

Different time wage types can be selected for a rule group dependent on the processing type.

**Conditions on the time or duration of work performed or on the day being evaluated**

For each time wage type/individual rule, you determine conditions on the day being evaluated for the time or duration of work performed. A time wage type is only selected if all the specified criteria are met.

- Conditions on the day

  The time wage type is only selected if the conditions specified for the day being evaluated are met. In this way you can, for example, determine bonuses automatically for work on weekends, on a public holiday, or the day before or after a public holiday.

  Information from the employee’s planned working time can also be a condition on the selection of a time wage type. This can depend on whether the day is a workday for the employee, for example, or on the information stored in the daily or period work schedule.

  You want employees who work a rotating shift pattern (early, late, and night shift) to be paid higher bonuses than employees who work a normal shift, provided the circumstances are the same (Valuation class of the period work schedule).
Conditions on the time

You can define conditions on the time or duration of work performed to enable bonuses such as overtime, Sunday, or night bonuses to be selected. You can specify that the time wage type is only to be selected within a particular time interval or that it is not selected until a certain number of hours has been worked. You can also specify that a time wage type be chosen only if the employee has already worked a certain number of planned working hours or overtime hours on that day.

Additional options in Customizing

- You can set a time wage type to a fixed value, regardless of the hours worked in one day. This enables you to set up a guaranteed hours regulation, for example.
- You can use the exit regulations in time wage type selection to stipulate that no more time wage types be selected after a certain one has been selected.
Integration Between Time Evaluation and Payroll

Use
The integration between time evaluation and payroll allows the Payroll component access to time wage types determined by time evaluation for the determination of the gross wage.

Features
- The time wage types determined by time evaluation in tables ZL, ALP, and C1 (Cluster B2) represent the interface between time evaluation and payroll.
  
  Table ZL: contains the time wage types
  Table C1: contains the data relevant for cost assignment
  Table ALP: contains the information necessary for a different payment
- Function IMPRT B2 imports the time wage types determined by time evaluation from Cluster B2 to payroll, and valuates them. However, the payroll is often run before the end of the payroll period, which means that time evaluation cannot provide time wage types for all days in the period.

You run the payroll on the fifteenth day of the month. Time evaluation has processed the time data up to and including the fourteenth. For the rest of the month, the employees are to be paid as if they had worked according to their planned working times, combined with existing attendances and/or absences, if applicable.

- Payroll performs a projection according to schema TC00 or TC04 for the days in the payroll run that have not yet been processed by time evaluation.
- The automatic retroactive accounting recognition guarantees that the time data is accounted without gaps. Any differences between the projection and the results determined at the end of the payroll run are balanced out in the following period by a retroactive accounting run.
  
  To do this, payroll sets the date as a retroactive accounting indicator in the Earliest MD change field in the Payroll Status infotype (0003). The prerequisite is that the employee takes part in time evaluation (Time Management status other than 0).
- If time infotypes are created or changed for a payroll period that has already been accounted, time recording or time evaluation sets a retroactive accounting indicator for the corresponding date for payroll in the Earliest MD change field in the Payroll Status infotype (0003). The prerequisites for this are that
  - The time infotypes concerned are flagged as relevant to retroactive accounting for time evaluation or payroll
  - Function CHECK (General Checks Before Evaluations/Status Determination) is in the time evaluation schema with parameter RPR (Recalculation Payroll)
Shift Change Compensation

Purpose
You can use this component to implement company or collective agreements that stipulate that employees should not be disadvantaged financially if their planned working time is changed.

Features

- If an employee’s planned working time is changed in such a way that would cause a financial disadvantage to the employee, he or she is paid on the basis of the original working time (for example, in the case of a change from a night shift with night shift bonuses to an early shift).

- If an employee’s planned working time is changed in such a way that would benefit the employee financially, he or she is paid on the basis of the changed working time (for example, in the case of a change from work on a Friday to a Sunday with Sunday bonuses).

- The shift change compensation can be listed separately on the remuneration statement, for example.

- You can limit the payment of shift change compensation to particular substitution types.
Activity with a Higher Rate of Pay

Purpose
This component is used to provide payroll with hourly rates that are specified in R/3 Time Management with information on a different payment.

Integration
Data records from *Time data recording and administration* and/or *Time evaluation* are processed in this component.

Features
- The time wage types and/or values determined by this component form the specifications for the financial valuation of work performed further on in gross payroll.
- A different payment for work performed can be effected using the following procedure:
  - Allocation of a bonus for particular activities or working conditions (premium)
  - Payment based on an alternative rate
  - Payment based on the specifications of a different position
- In the standard system, the component ensures that an employee cannot be paid at a lower rate than is specified in his or her basic pay on the basis of a different payment.
- In exceptional cases, you can use this component to correct the payroll results for particular hourly rates.

For more information, see *Entering a Different Payment for Time Infotype Records [Seite 240]*.
Entering a Different Payment for Time Infotype Records

Use

You can store information on payment in several of the time infotypes as well as just time data. In this way, employees can receive a special rate of remuneration for certain work activities.

The specifications on a different payment are entered via an additional window in the infotype. The method is different for Employee Remuneration Information (2010). In the standard system, the data is passed on to Payroll to be queried and processed.

You can specify a different rate of payment for the following time infotypes:

- **Attendances** (2002)
- **Substitutions** (2003)
- **Availability** (2004)
- **Overtime** (2005)
- **Employee Remuneration Info** (2010)

The subtypes of certain time infotypes can also have an influence on payment (for example, the subtypes Substitution type and Availability type).

If necessary, ask your system administrator whether the subtypes have an effect on payment.

Note for US customers:

When you enter a different payment, you can enter an alternative work tax area in the Tax area field. This replaces the tax area entered for the employee in the Work Tax Area infotype (0208). For more information, see [Work Tax Area Overrides](Extrem).

Procedure

1. Select an infotype and maintain the record on the entry screen.
2. Choose Goto → Different payment.
In the Employee Remuneration Information infotype (2010), you can enter data on a different payment directly on the entry screen.

3. Specify a different payment.

You can determine the remuneration in the following ways:

- **Assigning a premium**
  You can assign an employee a premium for particular work activities or working conditions. The premium is selected according to a premium number and a premium indicator. Use the possible entries function to display all permitted premiums with corresponding texts and values.

  You can either assign a premium on its own or together with the following options:

- **Payment according to a different pay scale**
  You can use the Pay scale group and Pay scale level fields to enter data on payment for a particular work activity. In this case, the payroll program does not select the rates which are specified for the employee in the Basic Pay infotype (0008), but the employee is paid according to the rates entered here for the duration of the different payment.

- **Payment according to the specifications for a different position**
  You can use the fields Object type and Position to assign the payment for the work activity according to the specifications for a different position.

- **Correcting payroll results**
  The Extra pay and Valuation fields can be used to correct the results of payroll.

  Not every wage type is valued using a fixed amount in payroll. The payroll program calculates a valuation basis during the payroll run which is used to valuate a wage type. The valuation basis is derived from the basic pay and the payments and deductions. You can change the valuation basis for the specified period in the Valuation and Extra pay fields.

  Enter an amount in the Valuation field. The extra pay indicator determines how the new valuation basis is formed:

  - **Extra pay**
    If you enter + in the Extra pay field, the amount in the Valuation field is added to the valuation basis calculated in payroll.

  - **Reduction**
    If you enter - in the Extra pay field, the amount in the Valuation field is deducted from the valuation basis calculated in payroll.

  - **Specifying an alternative amount**
    If you do not make an entry in the Extra pay field, the valuation basis calculated for the wage type in payroll is replaced by the specified amount.
Please note that you should only ever use one of the options for assigning a different rate of payment. An exception is the premium, which you can assign in addition to one of the other options.

4. Choose Transfer.
5. Save your entries.

**Result**

You have entered specifications on a different rate of payment for a time infotype record.
Employee Remuneration Information

Purpose
You can use the Employee Remuneration Information infotype (2010) to process manually calculated wages, bonuses, or other non-standard wage types. The time wage types been determined are entered into payroll and are used to form the gross wage.

Integration
Possible Integration with Other R/3 Components

<table>
<thead>
<tr>
<th>Desired Function</th>
<th>Required Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record wage types for work performed, together with information for other components in the R/3 System.</td>
<td>Cross-Application Time Sheet</td>
</tr>
</tbody>
</table>

Features

- Employee Remuneration Information provides payroll with time- and person-related time wage types. These time wage types form the specifications for the financial valuation of work performed further on in payroll.

- You can include information on a different payment with the employee remuneration information. If you do, the specified wage types are valuated according to the different pay scale group/level or the different position, for example, further on in the payroll run.

- This enables you to use this component as an interface to external time management systems. In this case, a Business Application Interface (BAPI) is used to supply the employee remuneration information with time wage types.

- You can use the Cross-Application Time Sheet to supply Human Resources with information on bonuses (for example, travel allowance).

See also: Cross-Application Time Sheet [Extern]
**Employee Remuneration Info Infotype (2010)**

**Definition**
You can use the *Employee remuneration info* infotype (2010) to enter wage types manually and specify information directly for Payroll.

If you work with time evaluation, you can transfer time balances directly using the *Time Transfer Specifications [Extern]* infotype (2012), which in turn has an effect on remuneration.

**Use**
These wage types are not generated automatically in payroll. Use infotype 2010 to enter wage data that has been calculated manually, such as premiums, bonuses for difficult working conditions or other special wage types.

You can adjust the wage types and subtypes of this infotype to your individual requirements in the Customizing system. Here, you can define, for example:

- The wage types that can be used here
- The fields in which data can be entered
- Whether additional information can be entered for Accounting and Logistics
- Whether a wage type can be used once or several times per payroll period.

**Structure**
The following options can be used to control remuneration for a wage type in the infotype:

1. **Number of hours, number, unit, and amount**
   If these fields contain entries, the system uses the values stored in the Customizing system for this wage type. If no *amount* is specified, you can enter one manually in the infotype.

2. **Different payment**
   It is possible to enter additional data on a different payment for remuneration records on the entry screen or via *Goto → Different payment.*
   - Assign a premium
   - Re-define a payment by assigning a pay scale group and level
   - Control payment by entering a different position
   - Add or deduct a specific amount using the *Extra pay indicator* and the *Valuation basis.*
See also:
Maintaining Employee Remuneration Information [Seite 246]
Maintain Employee Remuneration Information

1. Select the Employee Remuneration Information infotype (2010).
2. Enter a validity period.
3. Select a processing mode.
   The Employee Remuneration Information screen appears.
4. Check the validity date of the record. Correct it if necessary.
5. In the Wage type field, enter the wage type for the remuneration information record. Use the F4 help for a list of permitted wage types.
6. Enter a number of hours, a number / unit and/or an amount.
   Your entries in the Number of hours, Number/unit and Amount fields depend on the selected wage type.
   Certain wage types are valuated indirectly in Payroll. You do not have to specify an amount or number / unit in this case.
   The amount and number / unit can be entered for other wage types, however, and are often mandatory.
   The permitted entries for each wage type are defined in the Customizing settings.
   The system checks your entries at this point and generates an error message if you have made entries which are not permitted.
7. Enter data on a different payment [Seite 240], if required. This is only necessary if you have not made an entry in the Amount field.
8. Maintain the Accounting/Logistics specifications, if necessary.
   It is also possible to maintain additional data when you enter remuneration information using the weekly calendar or fast entry function.
   For more information on Activity Allocation and Cost Assignment, see Integration with Other Components [Extern] [Extern].
9. Save your entries.
Result
You have maintained remuneration information for an employee.
Absences

Purpose
This component is used to define regulations to determine how absences (unpaid leave, paid leave, illness, and so on) are handled in payroll.

You can define specifications to determine:

- Which valuation basis is used to valuate a paid absence
- Which absences are granted bonuses (for example, vacation allowance)
- Which absences cause deductions in pay
- Which absences are used to form statistics

Integration
To be able to use this component, you must record employee absences such as leave, illness, and so on, in the Time Management component or using a third-party system. The component processes absences from the Absences infotype (2001).

Features

- You can valuate absences as if the employee had worked. This enables bonuses for night work or for work on a Sunday or public holiday to be taken into account.
- You can define specifications for determining deductions in pay for an unpaid day of absence.
- You can determine vacation allowances for each day of absence.
- You can specify that an absence be valuated using an average pay, to be defined at a later stage. This means that you can include the average overtime of the previous month in the calculation of vacation allowances, for example.
- You can group absences together for the purposes of cost accounting or statistics to evaluate them subsequently for multiple employees.
- Absences can be valuated according to particular conditions on the day of the absence or the absence entitlement from which they have been deducted.
- You can define rules to process specific requirements.
Absence Valuation

Use
You use this component to valuate employees’ absences (unpaid leave, paid leave, illness, and so on) in Payroll.

Features
Absences recorded for an employee in the Absences infotype (2001) can be valuated in Payroll according to a variety of criteria.

- An employee takes leave. He or she should receive a vacation allowance.
- An employee is ill for a long period of time. There may be certain country-specific criteria that affect the way in which the absence is valuated.
- A employee has taken unpaid leave. His or her pay must be reduced accordingly.

You can define absence valuation rules in Customizing to meet your various requirements. Absence types and subtypes in the Absences infotype (2001) are grouped according to the methods of absence valuation you want to use.

The following procedures for valuating absences are included in the standard system. You can either use one of these procedures, or a combination of more than one:

- **“As if” principle**
  An absence is valuated as if the employee had worked.

- **Formation of counting classes for factoring and cost accounting**
  Absences lead to a reduction in pay. For more information, see Factoring [Seite 340].
  The costs incurred by the enterprise due to periods of paid incapacity to work should be determined.

- **Valuation of absences using averages or constants**
  An absence is valuated according to the average number of hours or days worked, or as a constant using a fixed amount. For more information, see Valuation Using Valuation Bases [Seite 259] and Valuating in Accordance with the Principle of Averages [Seite 276].

- **Individual calculation**
  Special processing is triggered for certain absences. Specific information from the employee’s master data, for example, is taken into account in special processing.
Absence Valuation

The Absences section of the Implementation Guide (IMG) contains detailed information on setting up the system and on the various methods of absence valuation.

Off-cycle payroll runs

In some countries, you can also valuate absences in an off-cycle run. This allows you to effect an advance payment for the duration of the absence. If you implement off-cycle payroll in your country and enterprise, the valuation of absences is dependent on whether it takes place in one of the following payroll runs:

- In a regular run
- In an off-cycle run
- In a regular payroll run after a previous off-cycle valuation

For more information on off-cycle accounting, see Off-Cycle Activities [Seite 127].
Absence Valuation in Schema xT00: Technical Process

Purpose

Absence valuation using the payroll schema xT00 allows you to valuate the absences recorded for an employee according to:

- The type of absence recorded
- The employee’s organizational assignment
- The absence quota from which an absence has been deducted
- Special country-specific features and requirements

Process Flow

<table>
<thead>
<tr>
<th>Func.</th>
<th>Par1</th>
<th>Par2</th>
<th>Par3</th>
<th>Par4</th>
<th>D</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>MOD</td>
<td>XMOD</td>
<td>GEN</td>
<td></td>
<td></td>
<td></td>
<td>Set groupings</td>
</tr>
<tr>
<td>RAB</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Import absences</td>
</tr>
<tr>
<td>PRINT</td>
<td>NP</td>
<td>AB</td>
<td></td>
<td></td>
<td></td>
<td>Print absences</td>
</tr>
<tr>
<td>xNAB</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Country-specific absence routines</td>
</tr>
<tr>
<td>(...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DAYPR</td>
<td>TC00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Day processing of time data</td>
</tr>
<tr>
<td>(...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PAB</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Process absences</td>
</tr>
<tr>
<td>(...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>xAB</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Country-specific absence routines</td>
</tr>
<tr>
<td>(...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Set groupings

The first action in payroll that is relevant to absence processing is function MOD in schema xT00.

The X sign appears in the following text in a number of schemas, functions, and personnel calculation rules. The X stands for the country indicator and also for the international versions of the schemas, functions, and personnel calculation rules. Only use schema xT00, personnel calculation rule XMOD, and so on, if no separate
Absence Valuation in Schema xT00: Technical Process

schemas, functions, and personnel calculation rules have been created for your country.

Function MOD determines the table entries the system accesses to valuate absences.

MOD calls personnel calculation rule XMOD which uses operation MODIF A to determine the employee grouping for absence valuation.

The employee grouping for absence valuation is used in the Valuation of Absences table (T554C) to select an absence valuation rule. The specifications stored in personnel calculation rule XMOD assign a meaning to the employee grouping. You can set individual grouping criteria here.

For more information, see the Implementation Guide for Payroll and choose Absences → Set grouping for absence valuation.

You can define groupings for a particular organizational assignment, for example, in relation to the employee subgroup grouping for personnel calculation rules.

You can use different employee groupings for absence valuation for

- Hourly wage earners
- Salaried employees

In the standard system, the payroll modifier for accessing the Constant Valuations table (T510J) is also set in personnel calculation rule XMOD using operation MODIF 2.

Import absences

After a grouping has been set for the personnel number, function RAB reads the absences recorded for the employee during the relevant period in the Absences infotype (2001).

The absences are assigned to a WPBP split indicator. The absence valuation rule is determined from the Attendances and Absences table (T554S), which groups together different absence types in payroll.

The absences are assigned to a work center split indicator.
An employee has changed work centers within the company during the payroll period. The work center split indicator allows you to take account of this organizational change when valuating absences.

If parameter 3 of function RAB contains the entry X, the absence valuation rule can be changed using the *Breakdown of Absences after Quota Deduction* table (T554A). In this way, you can create a special absence valuation rule that is dependent on the quota from which the absence is deducted.

If an absence is deducted from one or more quotas, an absence record can be broken down if required. If this is not the case, parameter 3 has no effect.

**Take account of country-specific requirements when reading absences**

Special processing may be required to account for country-specific requirements. A common example is absence due to illness. The amount of payment can change in the course of the illness (continued pay).

To ensure that the absence valuation function can deal with such situations, the internal *Absences* table (AB) has been enhanced. If an absence record is affected by country-specific requirements, it is split into smaller sections and then entered in table AB.

In table AB, there are three split indicators in which you can store country-specific indicators.

Split indicators for country XY for

- Social insurance
- Tax

Each section can then be valuated using a different procedure, that is, a different absence valuation rule.

Function XNAB is used for a more detailed version of table AB. Please note that the function must come at a specific position in the schema. It must not be processed until after the absences have been read, but before they are valuated (function PAB).

**Day processing of time data**

During day processing of time data, time wage types are selected using the *Time Wage Type Selection* table (T510S), and the time wage types are entered in the internal *Time Wage Types* table (ZL).

The same applies to all absences for which the *Time Wage Type Selection* field is selected in the *Valuation of Absences* table (T554C).
Absence Valuation in Schema xT00: Technical Process

**Valuate absences**

Absence valuation is triggered using function PAB.

Actual amounts are not calculated at this stage in the payroll process. First, the specifications made for absence valuation in Customizing are processed. Processing these specifications facilitates the subsequent valuation of wage types in amounts and/or factoring.

Function PAB performs the following steps:

- It reads the internal *Absences* table (AB) for each absence or partial interval.
- The system determines the appropriate absence valuation rule on the basis of the absence type and the employee’s organizational assignment, and carries out the actions specified in the *Valuation of Absences* table (T554C):
  - The counting classes that have been determined are cumulated in internal table CABC. The table contains the following information for each split:
    - Number of paid (AP) and unpaid (AU) absences in a counting class
    - Number of calendar days (K), absence days (A), and absence hours (S)
  You can query this information in personnel calculation rules using operation NUM:

<table>
<thead>
<tr>
<th>Partial period parameters for the partial period (=T)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>TKAU</strong> Unpaid absence (AU) expressed in calendar days (K)</td>
</tr>
<tr>
<td>All counting classes (**)</td>
</tr>
<tr>
<td><strong>TAAP</strong> Paid absence (AP) expressed in absence days (A)</td>
</tr>
<tr>
<td>All counting classes (**)</td>
</tr>
<tr>
<td><strong>TSAU33</strong> Unpaid absence (AU) expressed in absence hours (S)</td>
</tr>
<tr>
<td>Counting class 33 (33)</td>
</tr>
</tbody>
</table>

- Bases for calculating average values or wage types valuated using constants are determined. The system enters the wage types in the following tables according to the *time unit* specified in the rule for absence valuation:
Absence Valuation in Schema xT00: Technical Process

- Time unit B, I, E: The wage types are entered in table OT. If you have selected the Basic Pay Split field in the Valuation of Absences table (T554C), the wage types are cumulated for each split.

- Time unit Z: The wage types are entered in table ZL. There is one entry per day and wage type. In this way, you can access the results for a specific day in further processing. Using function ZLIT, table ZL is entered in table IT at the end of the gross part of payroll.

c) If you have created a separate personnel calculation rule for special processing special processing is carried out.

You can use information from the employee's master data or organizational assignment data for special processing. The system calculates temporary values and enters them in record layout fields. For information on record layout fields, see the documentation on the operands for operations NUM, RTE, and AMT.

Take account of country-specific requirements in absence valuation

The processing triggered by function XNAB may have to be continued. This can only take place after the absences have been valuated using function PAB.

Processing can be carried out using function XAB.
Wage Type Valuation

Use

The R/3 system uses primary and secondary wage types. Secondary wage types are formed during the payroll run. The primary wage types must be entered with values, which can be used again during the payroll run. In Customizing for Payroll under Incentive Wage Types → Payroll → Wage Types → Check Wage Type Catalog → Check Wage Type Characteristics you determine how the wage types should be valuated. The Valuation of dialog wage types is different from the Valuation of time wage types.
Dialog Wage Types Valuation

Use

You need this function to assign a value to wage types entered in master data maintenance. The dialog wage types can be valuated directly in different ways.

- **Direct**
  
  Enter the amount used for wage type valuation in the appropriate infotype.

  An employee receives a special payment of 500. In the *Additional Payments* infotype (0015), enter the *Special Payment* wage type with an amount of $500 and directly valuate the *Special Payment*.

- **Indirectly**
  
  The system calculates the amount the wage type should be valuated with, on the basis of certain employee characteristics, with a module that contains all the data necessary for calculation.

  Your employees receive standard pay. This standard salary should be calculated using the pay scale type, pay scale area, pay scale group, and pay scale level entered in the *Basic Pay* infotype (0008). Assign the TARIF module to the appropriate wage type in Customizing for Personnel Management under Personnel Administration → Payroll data → Basic Pay → Check Wage Type Catalog → Check Wage Type Characteristics. The modules included in the standard system for indirect valuation are described in the view *Change Wage Type Characteristics*. Details

- According to the principle of averages [Seite 276]
Time Wage Types Valuation

Use
You need this function to valuate time wage types.

During the payroll run, the system reads various time wage types from tables. These time wage types contain only one number (NUM). To calculate the amount (AMT) of the time wage type, the number must be multiplied by a rate (RTE). The system calculates the rate for each unit.

- using averages

An employee has 14 days leave. The vacation allowance should be made up of the pay and 10% of all overtime bonuses from the last six months. To do this the system must calculate an average value.

- using a valuation basis

Your employee works overtime between 5 p.m. and 7 p.m. In accordance with the company agreement, these two hours of overtime entitle the employee to an overtime bonus in addition to his or her basic remuneration.

Your Time Management system provides you with a Bonus for overtime wage type, which only contains the number of hours of overtime (2 hours in this example). The payroll program requires a rate by which to multiply the number in the Bonus for overtime wage type. To do this, you must define a valuation basis.
Valuating Wage Types Using Valuation Bases

Use

Time wage types are evaluated above all using the valuation bases. In this way bonuses or overtime remuneration is valuated.

You can define different valuation bases.

- Constant valuation bases
  You can define constant valuation bases that are dependent on the wage type to be valuated [Seite 264], or on a collective agreement [Seite 269].

- Employee-related valuation bases
  You can calculate employee-related valuation bases [Seite 272] that are dependent on an employee’s payments.
Technical Procedure for Wage Type Valuation using Valuation Bases

Purpose
For more information on the purpose of this process, see Valuation Using Valuation Bases [Seite 259].

Process Flow

The $X$ sign appears in the following text in a number of schemas, functions, and personnel calculation rules. This abbreviation represents the country indicator and the international versions of the schemas, functions, and personnel calculation rules. You should only use this if schemas, functions, and personnel calculation rules have not been set up specifically for your country or if you do not want to use the country-specific functions that are available.

1. The system determines the work center and basic pay data.
   In personnel calculation schema X000 (Determine gross wage and transfer), subschema XBD0 (Edit basic data) is called up. This subschema contains the WPBP function (Workplace Basic Pay), which causes the following:
   - The system enters the wage types from the Basic Pay infotype (0008) in the input table (IT).
   - The system enter the work center and basic pay data for an employee in the internal table WPBP.
   - The system determines whether several partial periods arise within a payroll period. Partial periods can arise for the following reasons:
     - Because an employee joined or left the company during the period.
     - Because of changes in basic pay, changes in organizational assignment, and changes in the personal work schedule.
     - Because payments are divided for cost accounting into paid and unpaid attendance and absence.
   For more information on the calculation of partial periods see Factoring [Seite 340].
2. For every partial period the system forms **Employee-related valuation bases** [Seite 272].

Subschema XT00 (*Processing of Time Data*) is accessed by personnel calculation schema X000. The personnel calculation rule X010 (*Form valuation bases (Addition)*) is queried in this subschema. This personnel calculation rule valuates processing class 01 for the basic pay wage types in the input table. Depending on the specification of the processing class, the system writes the basic pay wage types to one of the secondary wage types that are used as the valuation bases.

Calculation rule X010 is queried depending on the employee subgroup. In the standard system, the processing steps within personnel calculation rule X010 are the same for all employee subgroup groupings. If you want to set up special processing features for an employee subgroup grouping, you must enter your changes for the correct employee subgroup grouping for personnel calculation rules.

Personnel calculation rule X013 (*Form valuation bases (Division)*) is accessed immediately afterwards. This personnel calculation rule is also queried depending on the employee subgroup. Personnel calculation rule X013 queries the processing class 01 according to specification 5. This query has the following results:

- By means of specification 5 the system recognizes the valuation bases.
- By means of the employee subgroup the system recognizes whether the employee receives an hourly wage or a period-related salary. The entries in the valuation bases for all employees who do not receive an hourly wage are divided by the average number of hours for the period. This result is written as a valuation basis to the *Rate* (RTE) field of wage types /001 and/or /002.

3. The system forms the valuation bases for partial periods that must be paid differently.

In subschema XT00 function PALP (Process alternative payments) is queried. In this function the personnel calculation rule X012 (*Calculate valuation bases for alternative payment*) is queried. This personnel calculation rule checks whether a partial period must be paid differently. The following cases are taken into account:

- The employee works at a work center that is not assigned to them. The valuation bases for this period are determined using data for the work center at which the substitution occurs.
- The collective agreement provisions of a different wage group / wage level apply to the employee. The valuation bases are determined using the wage group or wage level that is valid for this period.

4. The system determines the wage types that are valuated using a valuation basis.

The personnel calculation rule X015 (*Valuation of time wage types*) is queried in subschema XT00. This personnel calculation rule is queried depending on the employee subgroup. The personnel calculation rule X015 checks whether the input table (IT) contains time wage types that should be valuated using valuation bases.
Technical Procedure for Wage Type Valuation using Valuation Bases

Using operations AMT?0, NUM?0 and RTE?0 the system checks the contents of the AMT (Amount), NUM (Number) and RTE (Rate) fields. The following cases are distinguished between:

- If the AMT (Amount) field contains a value, the wage type will be transferred to the output table OT using operation ADDWT.

- If the NUM (Number) and RTE (Rate) fields contain values these are multiplied by each other. The result is entered in the Total Amount field and the wage type is transferred to the output table OT using operation ADDWT.

- If only the Number (NUM) field contains a value, the operation VALBS determines whether a valuation basis has been entered in the Wage Type Valuation table T512W for the wage type. If a valuation basis has been specified, the wage type is valuated accordingly. If no valuation basis has been specified, the wage type is valuated using the principle of averages, in accordance with the specification in processing class 15.

The query of personnel calculation rule X015 is identical for all subareas, in other words, the queries described above are effected at the same time for all employee subgroup groupings (hourly wage earners, monthly wage earners, salaried employees, and so on).

The wage type valuation using a valuation basis is different for wage earners and salaried employees; that is, the wage type valuation depends on the employee subgroup grouping. If no valuation basis exists the wage type is valuated using the principle of averages.

Using personnel calculation rule X015 the system valuates all the determined wage types using the valuation bases. In so doing it distinguishes between the employee subgroup grouping:

- For hourly wage earners (employee subgroup grouping with specification 1):
  a) The base wage type is valuated using operation VALBS0
  b) The first derived wage type is valuated using operation VALBS1
  c) The second derived wage type is valuated using operation VALBS2
  d) Operation ADDNA cumulates the values in the NUM and AMT fields. The RTE field remains unchanged.

- For monthly wage earners and salaried employees (employee subgroup grouping with all other specifications):
  a) The system accesses the personnel calculation rule X115 (Valuation of time wage types) and carries out the following steps:
  b) The system uses this indicator to determine whether the existing wage type must also be paid differently. The alternative payment depends on the specification in processing class 18 (Processing for Work Center-Related Payments):
Technical Procedure for Wage Type Valuation using Valuation Bases

<table>
<thead>
<tr>
<th>Specification of processing class 18</th>
<th>Valuation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0, BLANK</td>
<td>Remuneration with higher valuation basis</td>
</tr>
<tr>
<td>1</td>
<td>Remuneration with difference</td>
</tr>
</tbody>
</table>

c) The base wage type is valuated in accordance with processing class 18 using operation VALBS0.
d) The first derived wage type is valuated using operation VALBS1
e) The second derived wage type is valuated using operation VALBS2
f) Operation ADDNA cumulates the values in the NUM and AMT fields. The RTE field remains unchanged.

**Result**

All wage types are allocated with an amount that can be processed during the payroll run.
Wage Type-Dependent Constant Valuation Bases

Definition
Values for bonuses dependent on the bonus wage type.

Use
The valuation of a time wage type with wage type-dependent constants is often dependent on certain conditions being met. You can define different, wage type dependent constants that depend on a modifier. Different conditions are represented with different modifiers. The value of these modifiers is queried with the function RAB (Read Absences) or the operation VALBS (Valuation bases).

Further conditions can be defined within the personnel calculation rule to determine whether a time wage type is valuated using a wage type-dependent constant valuation basis. In the standard system, the modifier MODIF 2 is used. You set the modifiers in personnel calculation rule XMOD [Seite 268] (Modifiers for Payroll).

Prerequisites
In Customizing for Payroll under Time Wage Type Valuation→Valuation Bases→Assign Valuation Bases you have determined which wage type should be calculated with a wage type dependent constant.

In Customizing for Payroll under Time Wage Type Valuation→Valuation Bases→Constant Valuation Bases→Define Wage Type-Dependent Constants you define the amount with which a wage type should be valuated depending on the wage type constant. The wage type-dependent constants are defined as dependent on a payroll modifier.

The modifier value is set as MODIF 2 within personnel calculation rule XMOD [Seite 268] (employee grouping for payroll). In the personnel calculation rule XMOD, you can define customer-specific conditions depending on this modifier.

For further information on system settings, see the Implementation Guide (IMG) for Payroll:<country> under Time Wage Type Valuation → Valuation Bases → Constant Valuation Bases.

Please take particular care with the Employee Remuneration Information infotype (2010). This infotype allows you to enter manually calculated wage types, for example, bonuses for hazardous or unpleasant work, and premiums. This is also the case for time wage types, for example, for overtime.

If you enter the Bonus for overtime wage type with an Amount in the Employee Remuneration Information infotype (2010), the wage type is included in the payroll run with its amount. In this case, the valuation basis is not used to valuate the wage type. By entering a wage type using the EE Remuneration Information infotype (2010), you can override time wage type valuation using a valuation basis.
The Customizing system enables you to specify the wage types that can be entered in the Employee Remuneration Information infotype (2010). For more information, see the IMG for Personnel Management under Personnel Administration → Payroll Data → Employee Remuneration Information.
Wage Type- Dependent Constant Valuation Bases Example

Initial Situation

The *Overtime on Sunday* wage type is valuated at your company with a constant, wage type-dependent valuation basis. The value of the constant valuation basis is 25 for the hourly paid, and 30 for all other employees.

Procedure

In Customizing for Payroll under *Time Wage Type Valuation → Valuation Bases → Assign Valuation Bases* you determine which time wage type is calculated with which valuation basis. You create entries for the modifier values 01 and 02 in the following way:

<table>
<thead>
<tr>
<th>Modifier value</th>
<th>Wage type</th>
<th>Valuation basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>Overtime on Sunday</td>
<td>25</td>
</tr>
<tr>
<td>02</td>
<td>Overtime on Sunday</td>
<td>30</td>
</tr>
</tbody>
</table>

Calculation rule XMOD (*Employee grouping for payroll*) is called in calculation schema XT00 (*Processing of time data for Payroll*), and is dependent on the employee subgroup grouping for the personnel calculation rule.

Only the entries for modifier 01 in the *Constant Valuations* table (T510J) should be read for the employee subgroup grouping for personnel calculation rule with specification 1 (hourly wage earners). The entries for modifier 02 should be read for all other *employee subgroup groupings for personnel calculation rules*.

The modifier used to read the *Constant valuations* table (T510J) is modifier 2 (MODIF 2). You must set modifier 2 to modifier value 01 for the employee subgroup grouping for personnel calculation rule with the specification 1 (hourly paid): MODIF 2 = 01. You must set modifier 2 to modifier value 02 for all other *employee subgroup groupings*: MODIF 2 = 02

Result

The entry for modifier 01 is read in the *Constant valuations* table (T510J) for the hourly-wage earners. Hourly wage earners are assigned the *Overtime on Sunday* constant with a constant valuation of 25 per hour.

The entry for modifier 02 is read in the *Constant valuations* table (T510J) for all other employees. Overtime worked on Sundays by employees who are not hourly wage earners is valuated at 30.

In personnel calculation rule XMOD (*Employee grouping for Payroll*), other modifiers are set in addition to modifier 2, which reads the *Constant valuations* table (T510J). For information on which modifiers you can use in the standard system, refer to the documentation on the MODIF operation.
Personnel Calculation Rule XMOD

Definition

Personnel calculation rule XMOD (Employee Grouping for Payroll) is used to set modifiers for reading tables relevant to payroll.
Constant Valuation Bases that Depend on the Collective Agreement

Definition

Values for bonuses dependent on pay scale group and pay group level.
Constant Valuation Bases that Depend on the Collective Agreement Example

Initial Situation

In accordance with the collective agreement, overtime on public holidays should always be remunerated with $50 for every overtime hour, for all employees in pay scale group 1 and pay scale level 2. In other words, the overtime on public holidays wage type is always valuated using a constant valuation basis, that depends on the pay scale group and pay scale level. An employee with this pay scale group and level has worked two hours overtime, on a public holiday, which should be remunerated.

In Customizing for Personnel Administration under Check wage type characteristics, you have determined which module should be used to valuate the wage types.

In Payroll Customizing, under Time Wage Type Valuation → Valuation Bases → Constant Valuation Bases → Define Wage Type-Dependent Constants, you have defined the amount a wage type should be valuated with, depending on the wage type constant.

Procedure

In the SAP System, you first enter the overtime hours for the employee in the Time Management application component. The system then uses preset conditions to choose the appropriate time wage type, in this case "Overtime on public holidays", with the number of hours as 2. This wage type is valuated with a valuation basis that is dependent on the following employee characteristics:

- Does the employee belong to pay scale group 1?
- Does the employee belong to pay scale level 2?

The appropriate valuation basis is determined using the Pay scale module. The following values are available for the wage type overtime on public holiday:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Constant Valuation Bases that Depend on the Collective Agreement Example

<table>
<thead>
<tr>
<th>NUM (Number)</th>
<th>2 hours</th>
</tr>
</thead>
<tbody>
<tr>
<td>RTE (Rate)</td>
<td>$50 per hour</td>
</tr>
</tbody>
</table>

The system calculates the wage type amount ($100) by multiplying the number by a rate.

**Result**

The employee receives remuneration of $100 (Number of working hours * valuation basis).
Employee-Related Valuation Basis

Definition

Individual value for every employee for whom payroll is carried out on the basis of wage types.

You can valuate the bonus wage types using a percentage premium [Seite 275] in accordance with the conditions specified in the collective agreement. This premium is a supplement to the employee’s basic remuneration.

Use

You create employee-related valuated bases by copying model wage types in a wage type group [Seite 177]. The standard system contains the secondary wage types /001, /002, /003 and /004. In these secondary wage types the rate of the respective dialog wage types are collected. These rates are the respective valuation bases.

Secondary wage types /001 and /002 are used on an hourly basis for valuating wage types. Secondary wage types /003 and /004 are only used in the German payroll to valuate wage types on a daily basis.

To include a wage type in one of these valuation bases, the wage type in question must be coded in processing class 1 with a specification from the following table.

<table>
<thead>
<tr>
<th>Specification</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>The wage type is not written to a valuation basis.</td>
</tr>
<tr>
<td>1</td>
<td>The wage type is written to secondary wage type /001 (and also to secondary wage type /003 for Germany).</td>
</tr>
<tr>
<td>2</td>
<td>The wage type is written to secondary wage type /002 (and also to secondary wage type /004 for Germany).</td>
</tr>
<tr>
<td>3</td>
<td>The wage type is written to secondary wage types /001, /002, /003 and /004.</td>
</tr>
<tr>
<td>5</td>
<td>The wage type amount is divided by the total hourly amount.</td>
</tr>
</tbody>
</table>

All of the wage types that you enter using the Basic Pay infotype (0008) must be coded in processing class 1.

The secondary wage types /001 and /002, must be coded in processing class 1 with specification 5. In doing this, the basic pay for hourly-wage earners, which is cumulated in these wage types, is divided by the number of working hours in the payroll period. The resulting rate can be used as a valuation basis.
The German payroll system also requires that secondary wage types /003 and /004 are coded with specification 5 in processing class 1. No other wage types may be coded with specification 5.

In Customizing for Payroll under Time Wage Type Valuation → Valuation Bases → Assign Valuation Bases → Maintain Basic Pay for Valuation Bases you determine which dialog wage type is included in which valuation basis.

In Customizing for Payroll under Time Wage Type Valuation → Valuation Bases → Assign Valuation Bases you determine which time wage type is calculated with which valuation basis. Additionally, you can determine the percentage of a valuation basis used to valuate a time wage type, and whether derived wage types are considered.

For further information on system settings, see the Implementation Guide (IMG) for Payroll:<country> under Time Wage Type Valuation → Valuation Bases → Create Person-Related Valuation Bases.
Person-Related Valuation Bases: Example

Initial Situation

In accordance with the collective agreement, all of an employee’s wage elements are used to valuate overtime worked on Sunday. However, voluntary payments are also taken into account when the overtime on public holiday wage type is valuated.

Your employee works two hours on a Sunday and three hours on a public holiday. His/her salary contains the following elements:

<table>
<thead>
<tr>
<th>Wage type:</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard salary</td>
<td>$30 per hour</td>
</tr>
<tr>
<td>Standard bonus</td>
<td>$10 per hour</td>
</tr>
<tr>
<td>Voluntary bonus</td>
<td>$5 per hour</td>
</tr>
</tbody>
</table>

Procedure

The system creates the following person-related valuation bases:

- Valuation basis for working on a Sunday (valuation basis 1)
  
  Valuation basis 1 is calculated from the salary at $30 per hour plus the standard bonus at $10 per hour. $30 + $10 = $40 per hour

  The Overtime on Sundays wage type is created with the number two. This number is valuated with valuation basis 1: $40 per hour x 2 hours = $80

- Valuation basis for working on a public holiday (valuation basis 2)
  
  Valuation basis 2 is created using the salary, the standard bonus, and the voluntary bonus of $5 per hour. $30 + $10 + $5 = $45 per hour

  The Overtime on a Public Holiday wage type is created with the number three. This number is valuated with valuation basis 2: $45 x 3 hours = $135.

Result

In addition to his/her salary, the employee gets $80 Sunday bonus and $135 public holiday bonus.
Percentage Advance Pay for Individual Valuation Bases

Use

Collective agreement provisions usually stipulate that time wage types such as Overtime on Sunday and Overtime on Public Holidays must be valuated with a percentage of the employee’s basic remuneration.

The Overtime on Sunday wage type must be valuated with a 25% increase in basic remuneration, consisting of the salary, standard bonus, and voluntary bonus. Valuation basis 1 is used.

There are two ways of effecting this percentage increase:

- Percentage increase of base wage type
  The base wage type is the Overtime on Sunday time wage type. This wage type is valuated with 125% of valuation basis 1. If an employee works overtime on a Sunday, he or she is assigned the wage type Overtime on Sunday valuated with 125% of valuation basis 1.

- Create a derived wage type
  The Overtime on Sunday base wage type is valuated with 100% of valuation basis 1. You also specify the Overtime on Sunday derived wage type: 25%. This wage type is valuated with 25% of valuation basis 1. In this case, the employee has the following wage types:
  - The Overtime on Sunday base wage type is valuated with 100% of valuation basis 1.
  - The derived wage type Overtime on Sunday is valuated with 25% of valuation basis one 1.

The advantage of this procedure is that the derived wage type enables you to display and print the 25% bonus separately in the form.
Valuating using the Principle of Averages

Purpose

This method is often used to calculate absences [Seite 248], however, it can also be used to calculate holiday pay or other bonuses, for example.

Prerequisites

You make the system settings for calculations using the principle of averages in Customizing for Payroll under Time Wage Type Valuation → Averages New.

Here, you also find the section Previous Averages - Not for Reconfiguration, which refers to the calculation of averages up to Release 4.5. The old version is not further developed and is only available in Customizing to make changes. You can only use one of the two versions; that is, you can not use the old and new tables simultaneously.

In one of the up-coming releases, conversion from the old to new processing of averages will take place automatically.

You perform payroll monthly in your enterprise.

An employee takes 14 days leave in August. In accordance with the company agreement, the employee receives not only basic remuneration during this period of absence, but also extra remuneration to cover unearned bonuses. This extra remuneration is calculated on the basis of the bonuses for night work, work on Sundays and public holidays, which the employee received on average in the three previous months.

As an average calculation basis, on which the calculation of bonuses is based, you have set up the Collected Bonuses wage type in Customizing.

Process Flow

In this example, the absence is calculated using the principle of averages as follows:

1. Creating Average Bases

Therefore, the average calculation basis contains the sum of the wage types that you have selected for valuation using the principle of averages. In each payroll period, average calculation bases are formed in accordance with your settings in Customizing for each employee.
In the above examples the *Bonus for Night Work*, *Bonus for Work on a Sunday*, and *Bonus for Work on a Public Holiday* wage types are collected and added to the *Collected Bonuses* wage type. You can choose to collect the *number* of working hours, the *amount*, or the *rate* for the wage type.

2. Determining the Payroll Periods

For calculations using the principle of averages, only the average calculation bases for specific previous periods are used.

In the above example you have determined in Customizing that the average calculation basis should be based on the three previous months when calculating using the principle of averages. Since your employee was absent in August, that is in payroll period 8, only payroll periods 5, 6 and 7 are included in the *Collected Bonuses* wage type when calculating the average bonus.

3. Determining the Valuation Basis

As a calculation basis the System must determine a *Rate* for the *Collected Bonuses* wage type:

In the above example the *Amount* of the *Collected Bonuses* wage type is divided by the *Number* of working hours. It does not matter whether you have collected the bonuses according to *Number*, *Amount* or *Rate*, you must still change the calculation rule for the standard system according to the entries in Customizing.

If the average value is not recalculated for each absence valuation, you can use *frozen averages* [Seite 278].

If no average bases have been created for an employee, you can use the *EE Remuneration Info.* infotype (2010) to enter the *average value directly* [Seite 259] using a wage type. First, you must define a user-specific wage type for the average value and enter this in the *Calculation Rules for Averages* view (V_T51AV_A). For more information, see Customizing for *Payroll* under *Time Wage Type Valuation → Averages New*.

You can define absence valuation rules for employee groupings (for example, for all salaried employees) and for groups of absence types (for example, paid leave). You define these absence valuation rules in Customizing. Please note, however, that the values used to perform a valuation in accordance with the principle of averages are determined using the average bases for each individual employee and are employee-specific.
Frozen Averages

Use

As an additional function for calculating averages, the R/3 System enables you to freeze average values. This means that you can use an average value calculated on the basis of several periods at the beginning of an absence for all of the periods affected by the absence, instead of always having to recalculate the average value for each period.

An employee takes leave in periods 04 and 05. The Leave absence is valuated according to the principle of averages. Three previous periods are to be used in the calculation.

In this case, the following options are possible:

- Normal valuation using the principle of averages
  The absence is valuated in period 04 for the first time using averages. The relevant previous periods are periods 01, 02, and 03. The second absence valuation takes place in period 05. In this case, the relevant previous periods are 02, 03, and 04. The absence can be valuated differently in periods 04 and 05 because the calculation is performed using average bases from different previous periods in each case.

- Valuation using frozen averages
  The absence is valuated at the start of the absence in period 04 after the average is calculated. The relevant previous periods are periods 01, 02, and 03. The calculated average is then frozen, in other words, it is saved and used again in the subsequent period (period 05). The absence is valuated in exactly the same way in periods 04 and 05 using a frozen average value.

The duration of the employee’s absence determines whether an average should be frozen or whether the absence should be valuated with a frozen average. Up until Release 4.5 the duration of the absence was queried in the R/3 System, in personnel calculation rule X016, once the calculation of averages had been concluded. For more information, see the section Technical Sequence for Processing Averages [Seite 281].
In the processing of averages this information is queried internally in the coding, as of Release 4.6.
Determining the Average Value without a Basis

Use
You can use a wage type to enter an average value for an employee instead of creating the average value using average calculation bases. This is useful if no average bases have been calculated for an employee but you still want to use an average value to valuate the employee absence. Furthermore, this procedure allows you to override the average value calculated by the system, for example, for a new employee, by entering a wage type with an average value for the employee in question.

Activities
Firstly, you must define a user-specific wage type for the average value and enter this in the Calculation Rules for Averages view (V_T51AV_A). For more information, see Customizing for Payroll under Time Wage Type Valuation → Averages New.

You enter this wage type for the employee in the EE Remuneration Info infotype (2010) as follows:

1. Enter the name of the wage type in the Wage and Salary Type field.
2. In the Amount field, enter the rate to be used as the average value.

For this employee, absence valuation is performed using the rate for this wage type, which has been entered in the EE Remuneration Info infotype (2010).
Old and New Processing of Averages

Use

As of Release 4.6B the processing of averages has fundamentally changed. You can find information on the new processing of averages under Technical Sequence for Processing Averages (new) [Seite 284]. You can find information on the old processing of averages under Technical Sequence for Processing Averages (old) [Seite 290].

For some country versions (Argentina, Brazil, Mexico, Sweden, USA and Venezuela) the new version of the processing of averages was delivered with Release 4.5B. These country versions can only use the new processing of averages and cannot choose between the old and new processing of averages. In the IMG for Payroll for these countries, the only section that still exists for the averages is Averages New.

All other countries can choose between the old and new versions for processing averages. In the corresponding IMG for Payroll, you can find both the Averages New and Previous Averages - Not for Reconfiguration sections. However, you can only use one of the two versions; that is, you can not use the old and new versions for processing averages simultaneously. If you have been using the old version for processing averages up until now, you can still continue to use this version. You do not have to convert your system to the new version. The old version for processing averages is no longer being developed.

We recommend that you use the new version for processing averages, if:

- you set up the processing of averages for wage types for the first time in your system
- up until now you have been using the old version for processing averages, but now want to use the additional functions of the new version

Changes in the Processesing of Averages

- The average value is no longer calculated for each wage type in operation MEANV (Calculation of Averages), but rather for each average value calculation rule in function AVERA (Calculation of Averages).
- All the required payroll results are imported with a database access.
Old and New Processing of Averages

- The SAP name space and the customer-specific name space for objects are clearly separated from each other.
- The bases for calculating average values can now also be formed from partial period parameters [Extern].
- You now define the average value calculation rule based on time. For example, you can specify that up until a specific point in time the averages are formed over a three month period, and then from this time over a 5 month period.
- The time unit for average periods is now freely defined For example, you can form averages over five months or 12 weeks.
- Now, you can not only include the regular payroll [Seite 53] run in the calculation of averages, but also the off-cycle payroll [Seite 131] run.
- If an employee changes payroll periodicity [Seite 38], the system adjusts the calculation of averages.
- All the averages are calculated at once. First of all the system collects all the wage types, then every average value calculation rule is applied once.

Changes in Customizing for Averages

You make the Customizing settings for averages, as of Release 4.6B, in the Implementation Guide (IMG) for Payroll under Time Wage Type Valuation → Averages New. The Customizing settings, which were previously made in personnel calculation rules or processing classes, can now be made in the maintenance view.

The following table shows a comparison between the Customizing settings for Release 4.6B and the settings that were made in releases prior to Release 4.6B:

<table>
<thead>
<tr>
<th>Customizing Setting</th>
<th>Before Release 4.6B</th>
<th>From Release 4.6B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forming the Basis for Calculating Average Values</td>
<td>View V_512W_C (Averages)</td>
<td>Table T51AV_2W (Assignment of Primary Wage Types to Average Bases)</td>
</tr>
<tr>
<td>Forming the Basis for Calculating Average Values from Partial Period Parameters</td>
<td>Table T51AV_2P (Assignment of Partial Period Parameters to Average Bases)</td>
<td></td>
</tr>
<tr>
<td>Relevancy Test</td>
<td>Personnel Calculation Rule X017 (Relevancy Test for Averages Calculation)</td>
<td>Table T51AV_R (Relevance Rule for Calculating Averages)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Table T51AV_ROC (Off-Cycle Reasons not Relevant for Calculation of Averages)</td>
</tr>
<tr>
<td>Adjustment Rule</td>
<td>Table T511C (Adjustment Rules for Bases for Calculating Average Values)</td>
<td>Table T51AV_C (Adjustment Rules for Bases for Calculating Average Values)</td>
</tr>
</tbody>
</table>
Old and New Processing of Averages

<table>
<thead>
<tr>
<th>Section</th>
<th>Table T511B (Cumulation Rules for Bases for Calculating Average Values)</th>
<th>Table T51AV_B (Cumulation Rules for Bases for Calculating Average Values)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cumulation Rule</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Final Processing</td>
<td>Personnel Calculation Rule X018 (Calculation of Averages after Cumulation: AMT/NUM)</td>
<td>Table T51AV_E (Final Processing Rules for Averages)</td>
</tr>
<tr>
<td>Average Value Calculation Rules</td>
<td>Table T511A (Calculation Rules for Averages)</td>
<td>Table T51AV_A (Calculation Rules for Averages)</td>
</tr>
<tr>
<td>Assigning the Valuation of Averages to a Primary Wage Type.</td>
<td>Processing Class 15</td>
<td>Table T51AV_P (Assignment of Wage Types to Average Calculation Rules)</td>
</tr>
</tbody>
</table>
The procedure for processing averages described in this and the following sections refers to releases from Release 4.6B. The processing of averages has fundamentally changed since this release.

For more information, see the Implementation Guide (IMG) for Payroll under Time Wage Type Valuation → Averages New → Bases for Valuation of Averages [Extern].

If you have been using the old version for processing averages up until now, you can still continue to use this version. You do not have to convert your system to the new version. However, the old version for processing averages will no longer be developed. If you reconfigure, you should only use the new version for processing averages.

Prerequisites

When setting up the new average valuation of wage types in your system, you must perform the following activities:

- **Forming the Basis for Calculating Average Values**
  
  The average calculation bases are used as a basis for calculating averages. The wage types assigned to the average calculation bases are stored in the secondary wage types /201 to /232.

- **Definition of calculation rules for averages**
  
  The calculation rules are made up of the following rules and values:
  
  - Relevancy rules
  - Cumulation rules
  - Final processing rules
  - Comparison rules
  - Adjustment rules
  - Number of relevant previous periods
  - Specify if the calculated average value should be frozen
  - Manual values (employee- and period-specific)
  - Off-cycle rules
Assignment of calculation rules to wage types

This assignment defines which primary wage type should be calculated according to which calculation rule.

For information on setting up average valuation, see the Implementation Guide (IMG) for Payroll under Time Wage Type Valuation → Averages New.

Process Flow

In the following, certain personnel calculation schemas and rules that start with the letter X serve as an example. The X represents the international personnel calculation schemas and rules and can be replaced with a country-specific letter. For example, there is a German personnel calculation schema D000 for the international personnel calculation schema X000.

The subschema XT00 (Processing of Time Data for Payroll) is accessed by personnel calculation schema X000. The function AVERA (Average Calculation) is called within this schema and performs the whole average calculation.

Averages are calculated in the following sequence:

1. Wage type selection and specification of calculation rules

   You can specify which wage types you want to valuate with an average value in Payroll Customizing under Time Wage Type Valuation → Averages New → Basis for Valuation of Averages. The function AVERA selects the wage types marked in such a way and establishes which calculation rules are assigned to these wage types.

2. The system checks the calculation rules for manual values

   The system checks if a manually assigned value already exists for a wage type in the internal table IT for every calculation rule. The system uses this value from the AMT field as an average value. In this case, the system skips averages calculation and continues processing with step 7.

3. The system checks the calculation rules for frozen averages

   For each calculation rule, the system checks the start and finish date specified in the internal table AVERAGE: If a frozen average already exists for the relevant wage type and is valid for the current period, the system skips the calculation of averages and continues processing with step 7.

4. Selection of all potentially relevant payroll results and creation of average calculation bases

   You have specified under which conditions a period should be relevant for the calculation of averages in the IMG for Payroll using the calculation rule in the relevancy rule. The system selects all payroll results that are, according to the relevancy rule, relevant and checks these according to the Relevancy Test for Valuation According to the New Principle of Averages [Seite 288].
You can also flag the current period as being relevant for the calculation of averages. The system then accesses a preliminary value from the data previously determined for the current period and uses this value for average calculation. The system finally calculates the final value for the current period that is written to the results table RT at the end of averages calculation in step 9.

5. Cumulating average calculation bases

The system cumulates the individual average calculation bases from the selected payroll results (from the relevant periods) for each calculation rule in the internal table MV.

In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create Calculation Rules for Averages [Extern], you can specify which of the values from the fields NUM, RTE or AMT of the wage type are cumulated. Here, you can also specify which sign (+/-) should be used to cumulate each value.

In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create Calculation Rules for Averages, you can make the following settings in the view Adjustment Rules for Bases for Calculating Average Values (V_T51AV_C) using adjustment rules:

- You can decide whether the system reads payroll results that are only partially in the averages period completely, partially or not at all for averages calculation.
- You can take a pay increase or an individual wage increase and, in this way, adjust the average calculation bases to the increased payments.
- You can make both positive and negative adjustments.

6. Calculation of the average value

The average value is calculated in the personnel calculation rule X018. In the standard system, the system divides the cumulated amount calculated in step 5 for all AMT fields by the cumulated amount from all NUM fields of the average calculation bases. You can also specify your own formulas or constants in the personnel calculation rule X018. The result of the calculation is the average value in the RTE field (rate).

In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create Calculation Rules for Averages, you can create your own final processing rules in the view Final Processing Rules for Averages (V_T51AV_E), which you can then assign to a calculation rule.

In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create Calculation Rules for Averages, you can create your own final comparison rules in the view Comparison Rules for Averages (V_T51AV_W), which you can then assign to a calculation rule. For example, you can compare the calculated value with a specified value (for example, standard pay) and specify under which conditions which value should be used as an average value.

7. Multiplying the average value with the number

The system writes the average value calculated in step 6 in the RTE field for every calculation rule to the RTE field for all wage types that are assigned to this calculation rule. The amount of the average value in the field AMT of the wage types is the result of multiplying the contents of the fields RTE and NUM for each wage type.

8. Freezing the average
You may want to freeze the value obtained by calculating averages. To do so, you can save the average value from the RTE field in the payroll results in the internal table AVERAGE for every calculation rule. In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create Calculation Rules for Averages, you can specify the period for which the average should be frozen in the view Calculation Rules for Averages (V_T51AV_A).

9. Creating the average calculation bases for subsequent periods

The function ADDCU (Update Cumulations) checks which wage types from the results table RT should be included in an average calculation basis. These wage types are collected in the relevant average calculation bases and the average calculation bases are finally written to the results table RT. This means that they are available in the payroll results for future calculations according to the principle of averages.
Relevancy Test for Valuation According To the New Principle of Averages

Purpose
When calculating average values, the SAP System uses the average bases that are stored for each employee. You can flag payroll results and average periods as relevant or irrelevant for the calculation of averages, based on particular criteria. Starting at the current period, the system performs a relevancy test for the current and previous periods. If the average period is relevant, cumulation takes place in a secondary wage type.

If you use Off-Cycle Activities [Seite 127] in your system, you can use the new method of calculating averages to exclude certain off-cycle payroll runs from averages valuation if there is an off-cycle reason.

Prerequisites
In Customizing for Payroll you determine via Time Wage Type Valuation → Averages New → Create Calculation Rules for Averages [Extern] the following default values:

- Number and unit of relevant average periods
  Taking the current period as the starting point, the number of previous periods that the system must deem relevant and use to calculate averages. This is independent of payroll periodicity.

- Maximum number of average periods
  The maximum number of periods that the system checks to determine the required number of relevant average periods.

Process Flow
The decision as to whether an average period is relevant for the calculation of averages is made in two steps:

1. Taking the current period as the starting point, the system checks if a payroll result is relevant. It does this for all payroll results that were marked as being potentially relevant.

2. The periodicity of payroll results and average periods can be different, for example, if you have weekly payroll results but use monthly average periods. Using the payroll results that were flagged as being relevant or irrelevant, the system checks if the average period is relevant. You can make the following settings in Customizing for this:
   - An average period is only relevant when all the payroll results assigned to it are relevant.
An average period is only relevant when at least one of the payroll results assigned to it are relevant.

**Result**

The relevancy test can have the following results:

- A period is relevant for the calculation of averages.
  
  In this case, the average calculation bases for the period are cumulated according to the cumulation rule stored in table T51AV_B (Cumulation Rules for Average Calculation Bases).

- A period is not relevant in the calculation of averages.
  
  In this case, the average bases are not cumulated which means that they are not included in the calculation of averages.

**Example**

The number of relevant average periods is two. The maximum number of average periods is four. The calculation of the averages takes place in period 8. You have monthly average periods but run payroll on a weekly basis. An average period is relevant if all the payroll results assigned to it are relevant. The current period should not be taken into consideration in the calculation of averages.

1. Checking the payroll results:

   The system checks all the results of the weekly payroll run, which are assigned to the average periods 7, 6, 5 and 4 and decides if these payroll results are relevant or not.

2. Checking the average periods:

   The system finally checks the average periods until it has found at least two that are relevant. For example, if a payroll result, which is assigned to the average period 6 was flagged as being irrelevant, the average period is, according to the specifications, also irrelevant.

   The system checks a maximum of four previous periods, in this example the periods 7, 6, 5 and 4. If the desired number of periods is not found after the check, the calculation of averages is carried out with the least number of periods. If the system checks the maximum number of previous periods but fails to find a single relevant period, the average value is 0.
Technical Process of Average Processing (Old)

Prerequisites

The procedure for processing averages described in this section, and in the following sections, refers to releases prior to Release 4.6B. The processing of averages as of Release 4.6B has fundamentally changed. For more information, see Old and New Processing of Averages [Seite 281] and the Implementation Guide (IMG) under Payroll → Time Wage Type Valuation → Averages New → Bases for Valuation of Averages [Extern].

If you been using the old version for processing averages up until now, you can now use this version. You do not have to convert your system to the new version. However, the old version for processing averages will no longer be developed. If you reconfigure, you should only use the new version for processing averages.

Process Flow

The old version of average processing takes place in the following sequence:

1. Creating Bases for Calculating Averages

Primary wage types to be included in the average bases are cumulated in one of the secondary wage types for average bases in accordance with the entries you have made. This cumulation is performed in each payroll period for each employee. The average bases are stored in internal table RT at the end of payroll, and are available for future calculations performed in accordance with the principle of averages.

2. Specifying the Wage Types to be Valuated Using the Averages Principle

The subschema XT00 (Processing of Time Data for Payroll) is accessed by personnel calculation schema X000. The calculation rule X015 (Valuation of Time Wage Types) is the first action relevant to the calculation of averages.
In the following, the X sign represents certain personnel calculation schemas and rules. This sign stands for the international versions of the personnel calculation schemas and rules and can be replaced with a country-specific letter. For example, there is a German personnel calculation schema D000 for the international personnel calculation schema X000.

The personnel calculation rule X015 determines whether the internal table IT contains time wage types that should be valuated according to the principle of averages. The contents of the AMT (Amount), NUM (Number), and RTE (Rate) fields are checked using decision operations AMT?0, NUM?0 and RTE?0.

- If the AMT field contains a value, the wage type will be transferred with the operation ADDWT (Add Wage Type to Subsequent Wage Type).
- If the AMT field does not contain a value, but the NUM and RTE fields do contain values, the value in the NUM field will be multiplied by the value in the RTE field. The result is entered in the AMT field and the wage type is transferred with the operation ADDWT.
- If only the NUM field contains a value, the operation VALBS (Evaluate Valuation Bases) queries whether a valuation basis has been entered in table T512W for the wage type. If this is the case, the wage type is valuated using the appropriate valuation basis. If a valuation basis has not been specified, but a specification has been entered for processing class 15, the wage type is valuated in accordance with the principle of averages. Processing is continued using operation GCY with personnel calculation rule X016 (Special Processing for the Valuation of Time Wage Types).

Only wage types that meet the following conditions are calculated according to the principle of averages:

- Only the NUM field (Number) contains a value.
- No valuation basis has been entered.
- A specification has been entered for processing class 15.

3. Defining Calculation Rules

After defining which wage types are to be valuated according to the principle of averages, the calculation rule is defined. This is carried out by the decision operation VWTCL° 15 in the calculation rule X016. This decision operation queries processing class 15. Wage types that are to be evaluated using the principle of averages, are coded in processing class 15 with a particular specification. The operation MEANV <nn> is called for each specification. In this operation, nn stands for a calculation rule from the Calculation Rules for Averages view (V_T511A). Depending on the calculation rule, operation MEANV <nn> performs the actual calculation of average values.
Technical Process of Average Processing (Old)

Your wage type has specification 1 in processing class 15. You have entered personnel calculation rules X017 (Relevancy Test for Averages), X018 (Calculation of Averages after Cumulation) and the cumulation type 01 (from the Cumulation Rules for Bases for Calculating Average Values view (V_T511B)) for calculation rule 01. You have also specified that 3 previous periods should be taken into account when the averages are calculated. In rule X016, the operation MEANV 01 is assigned to specification 1. Using parameter 01, calculation rule 01 is determined using personnel calculation rules X017 and X018, cumulation type 01, and 3 previous periods. Operation MEANV performs the calculation of averages on the basis of these entries.

4. Calculating the Averages

Operation MEANV performs the following steps when calculating averages:

1. The internal table MV is queried and this determines whether averages have already been calculated for the employee concerned within the current payroll period using the same average calculation rule.
   - If this is the case, the value that has already been determined is entered in the RTE field (rate).
   - If this is not the case, step 2 is performed.
2. The internal table IT is queried and determines whether the Average Value wage type exists for the employee concerned (from the Calculation Rules for Averages view (V_T511A)).
   - If this is the case, the value is entered in the RTE field (rate).
   - If this is not the case, step 3 is performed.
3. The individual periods [Seite 298] are processed.
   a. Each previous period to be processed is imported, starting with the current period - 1.
   b. The relevancy test [Seite 296] is performed.
   c. If the period is relevant, the cumulation takes place using the cumulation rule.
4. The system checks whether the maximum number of periods to be taken into account has been reached.
   - If this is not the case, return to step 2.
5. The final processing of averages [Seite 299] is performed:
   a. The average is calculated using personnel calculation rule X016 for final processing of averages from the Calculation Rules for Averages view (V_T511A).
   b. The value is entered in the RTE (Rate) field for the wage type to be valuated.

When the calculation of averages has finished, an average value is entered in the RTE field (Rate) for the appropriate wage type. This average value is used to
effect a valuation (usually of absences). To do this, the values in the RTE and NUM fields are multiplied.

5. Special Processing for Frozen Averages

Special processing for frozen averages is dependent on the specification of a wage type in processing class 15. If a wage type has specification A in processing class 15, the decision operation ABEVL? will be called in the calculation rule X016.

The decision operation ABEVL? determines whether an employee’s absence goes beyond the current period and returns a value (0, 1, 2 or 3) as the result of the query. Based on this value, you can trigger the following absence valuations in the personnel calculation rule X016:

- **Return value 0**: The absence begins and ends in the current period.
  - Operation MEANV calculates the average.

- **Return value 1**: The absence begins in the current period and ends in the next period.
  - In this instance, the average value is calculated for the current period and frozen for the next period.
  - Operation MEANV calculates the average.
  - Operation ZERO=NA sets the NUM (Number) and AMT (Amount) fields to zero.
  - Operation ELIMI deletes split indicators.
  - Operation ADDNAE/02A transfers the value from the RTE field (Rate) to wage type /02A and saves the value in the internal table RT. By placing the value in this wage type, the rate, in other words, the average value, is frozen and can be re-used in the next period to valuate the same absence.

- **Return value 2**: The absence begins in the previous period, continues through the current period, and ends in the next period.
  - The absence is first valuated in the current period using the frozen average value from the previous period. The average value is then frozen again for the next period.
  - Operation RTE=L /02A reads wage type /02A, in which the average value of the previous period was fixed, from internal table LRT.
  - Operation MULTI NRA multiplies the value in the Rate (RTE) field, in other words the average value, by the Number (NUM) field, in other words the number of absence hours or absence days. The result is entered and stored in the Amount (AMT) field.
  - Operation ZERO=NA sets the NUM (Number) and AMT (Amount) fields to zero.
  - Operation ELIMI deletes split indicators.
  - Operation ADDNAE/02A transfers the value from the RTE field (Rate) to wage type /02A and saves the value in the internal table RT. By placing the value in this wage type, the rate, in other words, the average value, is frozen and can be re-used in the next period to valuate the same absence.

- **Return value 3**: The absence starts in the previous period and ends in the current period.
Technical Process of Average Processing (Old)

The absence is valuated using the frozen average value of the previous period.

- Operation RTE=L/02A reads wage type /02A, in which the average value of the previous period was fixed, from internal table LRT.

- Operation MULTI NRA multiplies the value in the Rate (RTE) field, in other words the average value, by the value in the Number (NUM) field, in other words the number of absence hours or absence days. The result is entered and stored in the Amount (AMT) field.
Valuation of Primary Wage Types

Use

To valuate primary wage types using the principle of averages, you must flag these wage types accordingly. To do this, use the Processing Classes, Cumulations, and Evaluation Classes view (8V_512W_D) to enter a specification for primary wage type in processing class 15. Each specification of processing class 15 corresponds to a calculation rule in the Calculation Rules for Averages view (V_T511A).

The following parameters must be set for each calculation rule:

- Personnel calculation rules, used for the relevancy test for valuations in accordance with the principle of averages [Seite 296].
- Conditions for the cumulation of average calculation bases [Seite 297].
- Personnel calculation rules for the final processing of averages [Seite 299].
- Number of periods [Seite 298], used for valuations in accordance with the principle of averages.

The Averages view (V_512W_C) enables you to determine the secondary wage type for average bases in which the primary wage type for the calculation of averages is cumulated. It also enables you to determine whether the RTE (Rate), NUM (Number) or AMT (Amount) field is cumulated.
Relevancy Test for Valuation Using the Principle of Averages (old)

Use

You can flag a payroll period as relevant or irrelevant for the calculation of averages, based on particular criteria. In this respect, you can define a personnel calculation rule according to which a relevancy test is carried out.

The standard system includes the calculation rule X017 (Relevancy Test for Averages). You can modify the calculation rule to meet your enterprise-specific requirements. In the standard system, all previous periods are flagged as relevant in calculation rule X017.

You want to determine that the only payroll periods used in the calculation of averages are those in which the employee has at least 15 social insurance days.

You can create a customer calculation rule to perform this query for each employee and then flag only the periods in which the employee has at least 15 social insurance days as relevant for the calculation of averages.

Prerequisites

In Customizing for Payroll under Time Wage Type Valuation -> Averages Old -> Create Relevancy Test, you can define customer calculation rules for the relevancy test. You must then assign the average calculation rule to a calculation rule in the Calculation Rules for Averages view (V_T511A).

The relevancy test can have the following results:

- A period is relevant for the calculation of averages.
  
  The average bases of the period are cumulated in accordance with the cumulation rules in view V_T511B Cumulation Rules for Average Bases.

- A period is not relevant in the calculation of averages.
  
  The average bases are not cumulated which means that they are not included in the calculation of averages.
Cumulating Average Bases

Use

If the relevancy test has determined that the average bases of a period must be included in the calculation of averages, the average bases are cumulated in internal table MV.

In Customizing for Payroll under Time Wage Type Valuation → Averages Old → Create Cumulation Rules for Bases for Calculating Averages, you can specify which of the values from the following fields are cumulated:

- NUM (Number) of a wage type
- AMT (Amount) of a wage type
- RTE (Rate) of a wage type

You can also specify which sign (+/-) should be used to cumulate each value.

In the Cumulation Rules for Bases for Calculating Average Values view (V_t511B), you create the cumulation rules in accordance with the conditions. You must then assign a cumulation rule to a calculation rule in view V_T511A Calculation Rules for Averages.
Determining Relevant Previous Periods

**Use**

When calculating average values, the SAP System uses the average bases of previous periods that are stored for each employee. Starting at the current period, the system performs a relevancy test for the previous period. If the period is relevant, cumulation takes place in a secondary wage type.

In Customizing for Payroll you determine via *Time Wage Type Valuation → Averages Old → Create Calculation Rules for Averages [Extern]* the following default values:

- **Number of relevant periods**
  
  Taking the current period as the starting point, the number of previous periods that the system must deem relevant and use to calculate averages.

- **Maximum number of periods**
  
  The maximum number of previous periods that the system checks to determine the required number of relevant periods.

The number of relevant periods is two. The maximum number of periods is four. The calculation of the averages takes place in period 8. The system keeps checking previous periods until it has found at least two that are relevant. A maximum of four previous periods are checked, in this example the periods 7, 6, 5 and 4. If the desired number of periods is not found after a maximum check of four previous periods then the calculation of averages is carried out with the fewest number of periods. If the system checks the maximum number of previous periods but fails to find a single relevant period, the average value is 0.
Final Processing of Averages

Use

After the calculation of averages, the Rate field (RTE) must contain a valuation basis for the wage type in question. A formula must be created in the personnel calculation rule used. This formula performs the final processing of averages step.

The standard system contains the calculation rule X018 (Calculation of Averages After Cumulation: AMT/NUM). This calculation rule calculates an hourly rate by dividing the value in the AMT field (Amount) by the value in the NUM field (Number). The hourly rate is entered in the RTE (Rate) field.

Prerequisites

In Customizing for Payroll under Time Wage Type Valuation → Averages Old → Create Final Processing Rule, you can create an individual personnel calculation rule for final processing of averages. You must then assign this personnel calculation rule to a calculation rule in view V_T511A Calculation Rules for Averages.
Adapting the Average Bases to Increased Payments

Use

You can take a standard or individual wage increase into account when creating the average calculation bases. You must define a rule in Customizing to adapt the average bases to the changed pay scale conditions with retroactive effect. For more information see Customizing for Payroll and choose Time Wage Type Valuation → Averages → Create Adjustment Rules for Bases for Calculating Averages.
Leave Processing

In previous releases, leave and absences were processed in the SAP HR Payroll Australia component using the leave accruals method. Release 4.6A marked the first phase of the changeover to processing leave and absences in the SAP HR Personnel Time Management component using the leave quotas method.

The main difference between processing leave using leave accruals and leave quotas is that the Time Evaluation program (RPTIME00) replaces the Australian payroll driver function QLVTY, and calculates leave accrual and entitlement quotas as part of the payroll run. The payroll driver, however, continues to calculate leave loading, leave provisions and termination payments.

Another difference is that with the leave accruals method, the leave batch update process updates the Leave Entitlement infotype (0005) with leave balances calculated during payroll. In SAP HR Personnel Time Management, leave quotas are updated automatically in the Absence Quotas infotype (2006).

The Australia-specific leave provision, leave loading, terminations and leave reporting functions have been modified to work with SAP HR Personnel Time Management.

Note that leave accrual processing will be phased out in future releases. SAP recommends that you convert to leave quota processing.

Effects on Customizing

The settings in Customizing determine whether the SAP System processes leave and absences using leave accruals or leave quotas. The standard system is configured to process leave based on leave and absence quotas in SAP HR Personnel Time Management.


For upgrade customers wanting to change from leave accruals to leave quotas, data conversion routines will be made available in subsequent releases.

See also:

For more information on configuring leave quotas, see SAP Reference IMG → Personnel Time Management → Time Data Recording and Administration → Managing Time Accounts with Attendance/Absence Quotas → Calculating Absence Quota Entitlements → Rules for Generating Absence Quotas.

For more information on leave quotas, see SAP Library → Human Resources → Personnel Time Management → Time Management [Extern].

For more information on leave provisions and payments, see SAP Library → Human Resources → Payroll → Payroll Australia → Gross Part of Payroll → Leave Processing → Leave Provisions and Payments (New Method) [Seite 315].
Conversion to Leave Quotas

Purpose
This component enables you to convert your existing leave processing solution using Leave Accruals to the Leave Provisions based on Leave Quotas.

Implementation Considerations
From Release 4.6B onwards, the Australian Leave Accruals component is no longer supported. Hence all existing customers must convert to the new solution using Leave Quotas.

Integration
The leave provisions based on leave quotas, processes leaves and absences in Personnel Time Management and not in Payroll.

The Terminations/Redundancies component has been modified to work with Personnel Time Management component.

Leave provision and leave loading reports have also been modified to work with Personnel Time Management.

Features
- A conversion program, Australian Leave Conversion RPLCONQ0, has been created for a smooth transition from Leave Accruals to leave processing using Leave Quotas.
- There is a new time management status in Planned Working Time infotype (0007) for employees accruing leave. The status is called Time evaluation for accruals only.
- The Leave types which were previously stored in Leave Entitlements infotype (0005) are now replaced by Leave Quotas, stored in Absence Quotas infotype (2006)
- The initial loading of balances and adjustments was done through Loading Leave Aust. infotype (0261) before. Now it is done through Quota Corrections infotype (2013).
- There is a new Time Quota Compensation infotype (0416) which replaces the Leave Entitlement Compensation infotype (0083) for pay out of unused leave.
- Employee and company anniversary dates are now stored in Date Specifications infotype (0041). Hence leave loading can now be taken on entitlement as well as accrual, and is no longer restricted to a fixed date or anniversary date.
- There is a new Quota Overview transaction (PT50) replacing the Leave Projection transaction (PQLV)
- The Leave Quotas transfer accrual balances at the end of the day on which the anniversary falls. Previously, in the Australian leave, accrual balances were transferred at the beginning of the day on which the anniversary falls.
- Leave Quotas use date types in Date Specifications infotype (0041) to determine anniversaries. Earlier, the LVACC table was used to determine when the next leave anniversary date for an employee.
Constraints

- The Australian Leave Conversion does not make changes to the configuration. It only converts existing employees Australian leave data to Leave Quota data. This means that you must have configured and tested for Leave Quotas before running the conversion program.

- Payroll Cluster Customizing

  If you have customized the payroll results cluster to include more tables, you must take extra care while running the leave conversion. The conversion utilizes the standard cluster input/output modules, and as such will clear any custom tables in the cluster.

- Anniversary dates for employees with no payroll results

  If an employee included in the conversion has no payroll results, then the leave conversion will not be able to create any anniversary dates in Date Specifications infotype (0041). This is because the anniversary dates are extracted from the LVACC payroll cluster table.

  The user will need to manually create the date type entries for employees who do not have payroll results.

- Conversion of leave from days to hours

  This component does not allow you convert the time units for leave. For example, if the users have their Australian leave recorded in days and wish to change this to hours as part of the conversion process, the conversion program only takes the Australian leave in its current format and alters and formats this to be stored in the correct areas for leave quotas to use. It does not covert the time units.

- Absences booked after the conversion, but applicable prior to the conversion

  Any absences that are created after the conversion has been performed, but which apply for a day(s) prior to the conversion date will not be deducted from the new quotas, as the configuration for the quotas will not apply prior to the conversion date. While booking absences under these conditions, you have to alter the quota balances manually.

- Absences that overlap the conversion date

  Absences that start before and end after the conversion date cannot be re-booked during the entitlement conversion process. Instead, the conversion program will produce a warning so that you can manually deal with that absence, for example, splitting it.

  This is because, when an absence is booked, the entire absence is booked against whatever leave or quota type is used for deduction at the begin date of the absence. The quota type is determined from table T554S.

- Retroactive calculation prior to conversion date

  Retroactive re-calculations for leave prior to the conversion date produce wrong leave balances.

  To avoid this, the quota configuration records in the view V_T559L should all have a start date that is the same as the date on which the conversion is executed. This will ensure that the leave balances are not recalculated.

  Alternatively you could also choose to stop all retroactive calculations prior to the conversion date.

- Different accrual id’s to different quota numbers
Conversion to Leave Quotas

With the Australian leave, you can have multiple accrual id’s against a particular leave type. For example, annual leave might have three different accrual id’s with different rates.

It will not be possible for you to create 3 quota id’s for these three leave type and accrual id combinations.

This is because the Leave Entitlements infotype (0005) does not contain leave accrual id’s without which, it is not possible to determine which Leave type or Accrual id, the entitlement originates from.
Australian Leave Conversion

Purpose
This process enables you to convert existing Leave Accruals employee data to Leave Quotas. To create leave quota data for your existing employee data, you need to execute various batch input sessions after the Australian Leave Conversion program has been executed.

Process Flow
1. Execute the Australian Leave Conversion RPLCONQ0 in the test mode.
2. Inspect conversion log for warnings and errors.
3. If you find the conversion results to be accurate, then execute the conversion in the update mode. If the conversion results are incorrect, then re-run the conversion in the test mode, till it produces accurate values.
4. After executing conversion, you must process the first round of Entitlement, Accrual and Anniversary batch input sessions.
5. Perform Time Evaluation RPTIME00 using transaction PT60 for the employees selected in the conversion, for the date of the conversion.
   This will process the records created during the conversion.
6. Process the Absence re-booking batch input sessions.
Australian Leave Conversion

Use

The Australian Leave Conversion RPLCONQ0 enables you to convert your leave balances from the Australian Leave solution to the Leave Quotas solution. This report automates the change process for Leave Quotas by generating and altering various pieces of data.

Integration

The Australian Leave Conversion is a standard tool fully supported by SAP. However, it is not delivered in the standard system or the Support Package Systems. This program can be obtained from the SAPSERV at /dist/general/R3server/abap/note.0196539. The Australian Leave Conversion RPLCONQ0 will be delivered with the standard release from Release 4.6C onwards.

Features

- Using the leave conversion utility, you can configure four different components which are:
  - Accrual conversion \[Seite 308\]
  - Entitlement conversion \[Seite 309\]
  - Anniversary date conversion \[Seite 311\]
  - Provisions conversion \[Seite 312\]

  The following table shows the output created when each component of the conversion is performed:

<table>
<thead>
<tr>
<th>Conversion</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accrual conversion</td>
<td>Batch input session to create IT2013/IT2006.</td>
</tr>
<tr>
<td>Entitlement conversion</td>
<td>Batch input session to create IT2013, and another batch input session to re-book absences IT2001.</td>
</tr>
<tr>
<td>Anniversary date conversion</td>
<td>Batch input session to create/update IT0041.</td>
</tr>
<tr>
<td>Provisions conversion</td>
<td>The payroll cluster is updated directly.</td>
</tr>
</tbody>
</table>

- All conversion types, with the exception of the provision conversion, produce a batch input session.
- The four conversion options can be run either individually or at the same time.
- The program can be executed any number of times in the test mode. However the batch input session created by the conversion when it is run in real mode can only be run once. Executing these sessions more than once will result in doubling up of data.
- The report converts the following data:
  - Leave Entitlement infotype (0005)
  - Accrual information held on the payroll cluster in the cumulated results table (CRT)
  - Anniversary information stored in table LVACC.
  - Leave Provisions data held in tables LVEPR and LSLPR
Accrual Conversion

Purpose
This process will transfer existing Australian leave accrual data into Leave Quota accrual format. The leave accrual balances for selected employees are determined, and an equal amount created as a Leave Quota accrual.

Process Flow
1. The year to date accrual value held in wage type /C02 are read from the last payroll result stored for the employee, and the accrual balances are kept.
2. For each /C02 wage type, the corresponding leave type is determined from table T5QLR.
3. The leave type is then checked against the conversion selection screen to see what quota type it should be converted to.
4. Where leave balances are required to be projected, the Australian leave projection program is invoked to obtain accrual balances.
5. If the leave data has already been projected, the results from the projection are used for conversion.

Result
A batch input session is built to create Quota Corrections infotype (2013) records to adjust quota accrual values. This is achieved by using the quota type from the selection screen and the year to date accrual value from the last payroll result.
Entitlement Conversion

Purpose
This process will transfer existing Australian leave entitlement data into Leave Quota entitlement format. The Australian leave entitlement balances for selected employees are determined, and an equal amount created as a Leave Quota entitlement.

Any absences that will affect days in the future, that is, days after the conversion date, are re-booked so that they will affect the newly created quota entitlements.

However that absences that overlap the conversion date will not be rebooked. This is because the standard SAP system books the entire value of an absence against the leave type or quota type that is valid at the start date of the absence.

Absences that overlap the conversion date must be split and re-booked manually, the conversion program will produce a warning to highlight absences that overlap the conversion date.

Process Flow
1. The Leave Entitlement infotype (0005) is read to determine the current leave balances.
2. The Absences infotype (2001) is also read, as any future absences must be re-booked after the conversion is complete so that they reduce the created quota balance.
3. Where leave balances need to be projected, the Australian leave projection program is invoked to obtain entitlement balances.
4. Leave types from Leave Entitlement infotype (0005) are checked against the conversion selection screen to see what quota types they should be converted to. Any absences booked after the conversion date are then added back to the entitlement balances, and the new balance is kept.
5. Where leave data has been projected, the results from the projection are used.

Result
A batch update session is built to create Quota Corrections infotype(2013) records. These records will create quota entitlement values using the quota type from the selection screen and the entitlement value built during processing.

A second batch update session is then created to “re-book” any absences booked past the conversion date.

Example
This example illustrates why an absence re-booking is required.

Payroll is processed on 31/01/2000. For an employee the Leave Entitlement value is 122.50 hours. The Absence for annual leave value is 7.5 hours, booked for 05/03/2000 to the 05/03/2000. The absence has already reduced the leave balance.

Now, if the conversion did not rebook the absence for the 05/03/2000, then a quota entitlement value of 122.50 would be created.

If the absence were altered for some reason, and increased by a further 7.5 hours. In this case the absence has not yet altered the new quota balance, since it was booked under the old leave
Entitlement Conversion

configuration, the new absence amount of 15 hours would be taken from the 122.50 hours of entitlement, leaving 107.50 hours which is incorrect.

However, since the conversion does rebook future absences, the following changes will occur:

- The entitlement value of 122.50 hours will be combined with the future absence value of 7.5 hours, resulting in a quota entitlement value of 130.00 hours.
- The future absence will then be re-booked, reducing the new quota entitlement down to 122.50 again which is the correct value.

Subsequently, if the absence were further altered to include another 7.5 hours, only the difference in the old and new absence values will affect the quota entitlement value, resulting in a new balance of 115.00 hours. This is because the absence has already altered the new quota entitlement value.
Anniversary Conversion

Purpose
This process transfers existing leave anniversary dates from Australian leave format to Leave Quota format. Anniversary dates are determined for selected employees, and stored in the format and place required by Leave Quotas.

Process Flow
The Leave Accruals stores anniversary dates for leave types in the LVACC payroll table whereas Leave Quotas hold anniversary dates in Date Specifications. infotype (0041).

1. The cluster table LVACC values are read from the last payroll result stored for the employee, and the leave type and last anniversary date values are kept.
2. All the Date Specifications. infotype (0041) records which are valid, as on the conversion date or in the future, are read.
3. The Leave Quotas configuration then determines what date type will be used as the anniversary date for each quota type.
   - If a date type already exists in Date Specifications. infotype (0041) prior to running the conversion, and that date type is required by the conversion to store an anniversary date (i.e. was specified on the selection screen), then the conversion will over-write the date type in the infotype with the anniversary date. A warning will be produced in the conversion report.
   - If a Date Specifications. infotype (0041) record exists at the time of the conversion, but the record is completely filled with date types already, then the leave conversion will not be able to create a new date type. Instead it will generate an error, and the user should audit the entries in the existing infotype.
   - If an employee has been accounted to a date past the conversion date the employee is rejected, as a rollover may have occurred in the time from the conversion date to the ‘accounted to’ date, thus giving an inaccurate anniversary date at the time of conversion.

Result
A batch input session is built to create or update Date Specifications. infotype (0041) records, to include the date types and anniversary dates determined during processing.
Provisions Conversion

Purpose

This process updates the Australian leave provision data to make it compatible with Leave Quotas processing.

Each Australian leave provision record will have the corresponding quota type inserted, thus allowing the records to be picked up and processed by the Leave Quotas functionality. The corresponding quota type is specified on the conversion program selection screen.

Process Flow

1. The cluster tables, LVEPR and LSLPR, are read from the last payroll result stored for the employee.
   
   If an employee has been accounted to a date past the conversion date, a warning is generated. But the conversion of the provisions data will still occur as the data created is not dependant on time (as in the case of accruals and entitlement calculations).

2. For each record in the LVEPR and LSLPR cluster tables, the leave type value is used to determine the required quota type from the selection screen parameters. The quota type is then added into each record.

Result

The LVEPR and LSLPR cluster tables are written back into the last payroll result for the employee.
Executing Australian Leave Conversion

Use
This procedure enables you to convert your existing employee leave data to leave quota data by executing the Australian leave Conversion RPLCONQ0.

Prerequisites
Before executing the Australian Leave Conversion, you must:

- Execute leave batch update up to end of the last pay period for the employee data that is being converted. This will ensure that the Australian leave balances picked up by the conversion are accurate final values.
- Ensure that the system is updated with all the previous changes recommended by SAP.
- Perform a test conversion and examine the log thoroughly before performing a real conversion. This will allow you to correct any undesirable or inaccurate results.

Procedure
1. You must import the Leave Conversion program into your system. Select Program -> Execute

   The selection screen for the program appears.

2. Enter the Data Selection Period for the leave conversion.

3. Enter the personnel selection information.

Conversion Type
4. Specify which type(s) of conversion to perform. If required, you can also name the batch update sessions that will be created by the conversion. But this is optional and default names will be used where names are not supplied.

Conversion Parameters
5. Specify whether the conversion is a simulation or an actual conversion.

6. Enter the date on which you want to perform the conversion. This date should be exactly one day after the last completed payroll period. For example, if payroll is run up to 31/01/2000, the conversion date should be 01/02/2000. You must execute the conversion program separately for each payroll period.

7. Enter the LSL date type that will be created in Date Specifications infotype (0041) for use by long service leave quotas, if required.

   A date type should be nominated to store the start date for an employee’s long service leave accrual period. This start date is required by the leave quotas processing to allow the calculation of pro-rata and actual rollover dates for employee long service leave.

   The conversion program will create an entry in Date Specifications infotype (0041) for the date type nominated here, and the date used will be the employee’s start date.

Conversion Rules
Executing Australian Leave Conversion

8. Specify the leave types to be converted, and the quota types to which they must be converted to.

9. If an anniversary conversion is being performed, then specify the date type that should be used to control anniversary rollovers.

   In case of an anniversary conversion, specify whether or not to subtract one day from the old anniversary date value before it is stored in Date Specifications infotype (0041). This is necessary to cater to the different way in which rollovers are processed within Leave Quotas, as opposed to Australian Leave.

10. Select Program -> Execute
Leave Provisions and Payments (New Method)

Purpose
The Leave Provisions and Payments component lets you process the following Australian leave functions based on leave quotas in SAP HR Personnel Time Management:

- Leave provisions
- Leave loading
- Leave payments on termination
- Quota accrual transfer to entitlement
- Leave reporting

Implementation Considerations
Leave Provisions and Payments should be implemented in cooperation with the project team implementing SAP HR Personnel Time Management.

Integration
Since the SAP HR Personnel Time Management component does not cater for Australian leave provisions, leave loading, leave payments on termination, leave accrual transfers to entitlement and leave reporting, the existing functions have been modified to work with SAP HR Personnel Time Management.

If you use the SAP HR Personnel Time Management component to calculate leave and absences, the Time Evaluation program (RPTIME00) calculates leave quota accruals and entitlements as part of the payroll run.
Leave Provisions Based on Leave Quotas

Purpose

This component enables employers to project their liability to compensate employees for long-service leave (LSL), annual leave (also known as recreational leave) and other leave types in the event of termination of employment.

Implementation Considerations

In SAP HR Payroll Australia, leave liability calculations can be configured to comply with Australian Accounting Standard AASB 1028. According to this standard, employee entitlement liabilities are measured at the present value of the estimated future cash outflows to be made by employers for services provided by employees up to the reporting date.

Integration

The Leave Provisions component is configured by default to work with leave and absence quotas in SAP HR Personnel Time Management.

It reads data stored in various HR infotypes including the Organizational Assignment (0001), Absence Quotas (2006), Planned Working Time (0007), Basic Pay (0008), Contract Elements (0016) and Cost Distribution (0027) infotypes. In addition, it accesses payroll data stored in the results table (RT) in the last payroll run of the calendar month.

The Posting to Accounting program posts leave provision wage types from symbolic accounts [Extern] created during payroll to actual accounts in the Accounting modules. To post the same wage type to different actual accounts according to an employee's subgroup, the SAP System reads the data stored in the Standard Accounts table in the Accounting module.

Features

This component enables you to:

- Calculate leave provisions for LSL using calculation factors [Seite 319] that are based on your employees’ years of service
- Calculate leave provisions for annual leave, overtime leave and LSL based on leave quota projections forecast to the end of the month
- Calculate leave provisions for non-accruing leave using current leave quota balances
- If applicable, include the leave loading liability and other on-costs (for example, payroll tax) in leave provisions for annual leave, non-accruing leave and overtime leave
- Define wage types for the hourly rate used in the leave provision calculation [Seite 322]
- Post leave provision dollar values to Accounting

Constraints

On-costs and other leave provision calculation factors [Seite 319] cannot be varied according to employee attributes such as company, personnel area and personnel subarea.
The Leave Provision Process

Purpose

This process describes how leave provisions are processed, reported and posted to Accounting.

Prerequisites

Before processing leave provisions, you must:


- Maintain various HR infotypes including the Absence Quotas (2006), Planned Working Time (0007), Basic Pay (0008) and Contract Elements (0016) infotypes.

- Set up the Standard Accounts table to convert symbolic accounts [Extern] to actual accounts for posting to Accounting, and to allow the same wage type to be posted to different actual accounts according to employee subgroup.

- Create cost centers in the Organizational Assignment infotype (0001) and, if required, set up cost center splits in the Cost Distribution infotype (0027).
The Leave Provision Process

Process Flow

The Leave Provision Process

1. The payroll program checks if the current payroll run is the last run in the current calendar month. If it is not, then leave provisions are not calculated for this run except for employees terminated in this period. If it is, then the Leave Provision Liability program (RPCPRVQ0) calculates the leave liability hours or days at the end of the calendar month, processes each quota type and multiplies the hours by the hourly rate to produce a liability dollar value.

2. The program reads the cost centers stored in the Organizational Assignment infotype (0001), and if necessary, the cost center splits stored as percentages in the Cost Distribution infotype (0027). It then allocates the employee cost center codes for the payroll period.

3. The SAP System reads the leave provision calculation factors [Seite 319] set up in the Payroll Constants view (V_T511K) and applies the factors to the liability dollar value.

4. The program transfers the values calculated to the Leave Provision Recreation Leave table (LVEPR) and/or the Leave Provision Long Service Leave table (LSLPR). The current month’s values are written as positive postings to the leave provision wage types stored in the Leave Provision Recreation Leave and the Leave Provision LSL tables. The previous month’s values are written as negative postings to the leave provision wage types stored in the results table (RT).

5. After the payroll run, you can create leave provision reports by running the Australian Leave Reporting program (RPLEAVQ0).

6. You then run the Posting to Accounting program (RPCIPE00). This creates an IDoc [Extern] (intermediate document) that loads the results into the Accounting modules.

7. In the event of a termination, function [Extern] QLVPR checks to determine whether an employee has been terminated in the current payroll period. If an employee has been terminated, the SAP System calculates payroll as though it were processing the last complete period of the month. That is, the system reverses the previous month’s values out, and creates a new value for the current month’s leave provisions. In the case of terminated employees, this value will be zero. In addition, the leave provisions value is cancelled out of Accounting.
Leave Provision Calculation Factors

Definition

The leave provision calculation factors are the values, percentage rates and on-costs used to calculate leave provisions for long-service leave (LSL), annual leave and other leave quota types.

Use

You can configure leave liability calculations to comply with Australian Accounting Standard AASB 1028. According to this standard, employee entitlement liabilities are measured as the present value of the estimated future cash outflows to be made by employers for services provided by employees up to the reporting date. The estimated future cash outflows are discounted according to the national government guaranteed security rates that have terms of maturity that match, as closely as possible, the terms of the related liabilities.

Structure

The following factors are used to calculate leave provisions for LSL:

- **Years of service**
  
  The number of years the employee has been employed by the company.

- **Probability factor**
  
  This is a company-specific value that is applied to each year of service based on the probability that the employee will be entitled to LSL. The standard system contains probability factors PRF01–PRF11.

- **Escalation rate**
  
  This is a company-specific rate that is entered for each year of service and used for the addition of on-costs. The standard system contains escalation rates ESC01–ESC11.

- **Inflation rate**
  
  The actual or projected rate for a year. The standard system contains inflation rates INF01–INF11.

- **Bond rate**
  
  The percentage for the net present value. The rate is based on the national government security rate. The standard system contains bond rates BND01–BND11.

The following factors are used to calculate leave provisions for annual and other types of accruing leave:

- **Probability factor**
  
  This is assumed to be 100%.

- **Escalation rate**
  
  This is set to escalation rate ESC11, because rates ESC01–ESC10 are used only in LSL calculations.

The following factors are used to calculate leave provisions for non-accruing leave:

- **Probability factor**
Leave Provision Calculation Factors

This is assumed to be 100%.

- **Escalation rate**
  
  This is set to escalation rate ESC11, because rates ESC01–ESC10 are used only in LSL calculations.

**Example**

LSL liabilities are calculated according to the following example:

<table>
<thead>
<tr>
<th>Years of service</th>
<th>Leave value</th>
<th>Probability factors</th>
<th>Nominal amount</th>
<th>Escalation rate</th>
<th>Escalated sub-total</th>
<th>Inflation rate</th>
<th>Inflation sub-total</th>
<th>Years to liability</th>
<th>Bond rate</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>10+</td>
<td>16000</td>
<td>100.00</td>
<td>16000</td>
<td>17.27</td>
<td>18763</td>
<td>7.50</td>
<td>20170</td>
<td>0</td>
<td>7.60</td>
<td>20170</td>
</tr>
<tr>
<td>9-10</td>
<td>17000</td>
<td>92.00</td>
<td>15640</td>
<td>13.75</td>
<td>17791</td>
<td>7.00</td>
<td>20464</td>
<td>1</td>
<td>7.60</td>
<td>19018</td>
</tr>
<tr>
<td>8-9</td>
<td>34000</td>
<td>90.00</td>
<td>30600</td>
<td>13.75</td>
<td>34808</td>
<td>4.50</td>
<td>38492</td>
<td>2</td>
<td>7.70</td>
<td>36070</td>
</tr>
<tr>
<td>7-8</td>
<td>34000</td>
<td>80.00</td>
<td>27200</td>
<td>13.75</td>
<td>30940</td>
<td>3.50</td>
<td>38492</td>
<td>3</td>
<td>7.85</td>
<td>30684</td>
</tr>
<tr>
<td>6-7</td>
<td>9000</td>
<td>70.00</td>
<td>6300</td>
<td>13.75</td>
<td>7166</td>
<td>3.50</td>
<td>9227</td>
<td>4</td>
<td>8.05</td>
<td>6770</td>
</tr>
<tr>
<td>5-6</td>
<td>7800</td>
<td>60.00</td>
<td>4680</td>
<td>13.75</td>
<td>5324</td>
<td>3.50</td>
<td>7095</td>
<td>5</td>
<td>8.23</td>
<td>4777</td>
</tr>
<tr>
<td>4-5</td>
<td>6700</td>
<td>30.00</td>
<td>2010</td>
<td>13.75</td>
<td>2286</td>
<td>3.50</td>
<td>3154</td>
<td>6</td>
<td>8.42</td>
<td>1942</td>
</tr>
<tr>
<td>3-4</td>
<td>710</td>
<td>20.00</td>
<td>142</td>
<td>13.75</td>
<td>162</td>
<td>3.50</td>
<td>231</td>
<td>7</td>
<td>8.60</td>
<td>129</td>
</tr>
<tr>
<td>2-3</td>
<td>500</td>
<td>20.00</td>
<td>100</td>
<td>13.75</td>
<td>114</td>
<td>3.50</td>
<td>126</td>
<td>8</td>
<td>8.72</td>
<td>65</td>
</tr>
<tr>
<td>1-2</td>
<td>900</td>
<td>20.00</td>
<td>180</td>
<td>13.75</td>
<td>205</td>
<td>3.50</td>
<td>313</td>
<td>9</td>
<td>8.78</td>
<td>147</td>
</tr>
<tr>
<td>0-1</td>
<td>200</td>
<td>0.00</td>
<td>0</td>
<td>13.75</td>
<td>0</td>
<td>3.50</td>
<td>0</td>
<td>10</td>
<td>8.78</td>
<td>0</td>
</tr>
</tbody>
</table>

**Column B**: The result of the calculation of the employees’ entitled and accrued hours multiplied by their rate.

**Column C**: The probability factor is applied to each year of service based on the probability that the employee will be entitled to LSL.

**Column D**: The nominal amount is the leave value multiplied by the probability factor.

**Column E**: The escalation rate is an accumulative figure for all on-costs including payroll tax.
Column F: The nominal amount plus the escalation amount.
Column G: The projected or actual inflation rate for each year.
Column H: The escalation amount plus the inflation amount.
Column I: The number of years until the value becomes an actual liability.
Column J: The rate for the net present value calculation.

See also:
Leave Provision Calculations [Seite 322]
Leave Provision Calculations

Purpose
This process provides an overview of how leave provisions are calculated for long-service leave (LSL), annual leave and other leave types.

Prerequisites

Process Flow
To calculate leave provisions for LSL, you:
1. Forecast leave liabilities to the end of the month using the Leave Liability Projection Accrual program (RPCLPVQ1).
2. Multiply the LSL entitlement hours by the hourly rate and multiply the LSL accrual hours by the hourly rate.
3. Add the two values together.
4. If required, convert the resulting value to days.
5. Define the LSL probability factor based on the employees’ years of service. For example, after three years of service, you apply probability factor PRF03.

To calculate the years of service, the SAP System compares the hiring date in the Actions infotype (0000) with the entry into group date in the Contract Elements infotype (0016) and uses the earlier of the two dates.

6. Define the leave provision factors based on the employees’ years of service. For example, after three years of service, you apply escalation rate ESC03, inflation rate INF03 and bond rate BND03.

7. Increase the value of the LSL provision by all the on-costs.

To calculate leave provisions for annual leave and other accruing leave types, you:
1. Forecast leave liabilities to the end of the month using the Leave Liability Projection Accrual program (RPCLPVQ1) to obtain entitlement and accrual values.
2. To calculate the total liability, valuate entitlement and accrual hours by the hourly rate.
3. If required, add leave loading to the total liability.
4. Increase the calculated value by the escalation rate ESC11.
Use escalation rate ESC11, because escalation rates ESC01 to ESC10 are LSL escalation rates that are based on the employees’ years of service.

To calculate leave provisions for non-accruing leave, you:

1. Determine current entitlement and accrual hours.
2. To calculate the total liability, valuate these hours by the hourly rate.
3. If required, add leave loading to the total liability.
4. Increase the calculated value by the escalation rate ESC11.

**Result**

All the values calculated are factored by any changes in work assignment (for example, changes to cost center).

Two new tables are generated in the payroll results cluster (RQ):

- Leave provision recreation leave (LVEPR)
- Leave provision LSL (LSLPR)

The tables store the details of the leave provision calculations described above and are summarised in the payroll results. The SAP System uses the data to generate leave provision wage types. The wage types are stored in the results table (RT) according to the configuration in the Leave Provisions table (T5QPR) that links leave quota types to wage types. The wage types hold the total leave provision amount for the related leave types.

The wage types must be assigned a leave provision account to facilitate posting to *Accounting*.

The amount that is posted on a wage type is the total leave provision amount for an employee and may include negative amounts for leave liabilities posted in previous payroll periods.

For example, at the end of January an employee accrues a total leave provision of $5,000. At the end of February, the employee’s total leave provision has accumulated to $6,000. The $5,000 posted in the previous month is brought forward as a negative value (-$5,000) so that only $1,000 leave provision is posted for the employee in February.

**See also:**

*Leave Provision Calculation Factors [Seite 319]*
Posting Leave Provisions to Accounting

Use
After an employee’s leave provisions have been calculated, the system creates leave provision wage types to enable dollar values to be posted to the Accounting modules.

Prerequisites
You must successfully complete payroll for your employees and have leave provision data stored in the Leave Provision Recreation Leave table (LVEPR) and/or the Leave Provision LSL table (LSLPR).

Procedure
1. Choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Reporting → Posting to accounting → Execute run.
   The Posting to Accounting: Create Posting Run screen appears.
2. Enter the required details.
3. Choose Programs → Execute.

Result
This creates an IDoc [Extern] (intermediate document) that loads the results into the Accounting modules.

See also:
Help → SAP Library → Human Resources → Payroll → Payroll Australia → Subsequent Activities → Posting to Accounting [Seite 576].
Leave Loading

Purpose
This process describes how leave loading is calculated during payroll based on leave quotas in the SAP HR Personnel Time Management component.

Leave loading is a bonus payment used to compensate employees for extra pay lost when taking leave (for example, overtime pay). It also contributes towards additional expenses incurred while an employee is on leave (for example, travel costs).

Leave loading is calculated as a percentage, usually 17.5%, of an employee’s salary, and generally has a tax-free component of $320.00. Under the terms of most awards, leave loading is paid when an employee goes on holiday. Some awards may allow for loading to be paid out once per year (for example, on the employee’s entitlement date).

The standard system lets you calculate leave loading in one of the following ways:

- **Absences taken**
  That is, leave loading is calculated progressively throughout the year based on the total number of hours taken for an absence regardless of whether the absence is deducted from entitlement or accrual

- **Transfer values**
  That is, the number of hours transferred from accrual to entitlement

When you process leave loading, you must apply one of these methods to each absence quota created per employee subgroup grouping and personnel subgroup grouping for time quotas.

Prerequisites
Before you calculate leave loading, you must configure leave loading in Customizing for Payroll Australia. In Customizing you define:

- Whether leave loading is paid:
  Progressively throughout the year when absences are taken
  or
  on the date when accrued leave transfers to entitled leave

- The wage type used to pay leave loading

You configure leave loading under SAP Reference IMG → Payroll → Payroll: Australia → Leave Provisions and Payments → Leave Loading [Extern].

Process Flow
1. During payroll, the leave loading function determines the wage type used to pay leave loading and the number of hours on which leave loading is paid.

2. If you configure an absence quota to pay leave loading only when an absence is taken, leave loading is calculated based on the total number of hours of the absence regardless of whether the absence is deducted from entitlement or accrual.
Leave Loading

If, however, you configure an absence quota to pay leave loading only on transfer, leave loading is calculated based on the total number of hours that are transferred from accrual to entitlement.

3. The leave loading function then calculates the total leave loading dollar value and determines the tax-free component of leave loading.

See also:

Leave Loading with Quota Corrections [Seite 327]
Leave Loading with Quota Corrections

Purpose

The standard system lets you calculate leave loading either on absences taken or on transfer values. This process only applies to transfer values, and describes how leave loading is processed when you adjust leave quota accruals and entitlements on the same day that leave accruals are transferred to leave entitlement.

When accrual is transferred to entitlement, leave loading is calculated based on the transfer value, that is, the total number of hours transferred from accrual to entitlement.

If you adjust accrued leave in the Quota Correction infotype (2013) on the same date as the transfer from accrual to entitlement (for example, an employee’s anniversary), your adjustment will be reflected in the leave loading calculation.

If, however, you adjust entitled leave in the Quota Correction infotype (2013) on the same date as the transfer from accrual to entitlement, your adjustment will not be reflected in leave loading.

Example

Adjusting leave quota accruals

An employee has 20 hours of accrued leave and has no entitled leave. You want to transfer the 20 hours to entitlement on January 1, 2000. On that date, you create a quota correction record in the Quota Correction infotype (2013) to increase the employee’s accrued hours by 10 hours to make a total of 30 hours of accrued leave. When the transfer takes place, 30 hours of accrued leave are transferred to entitlement and as a result leave loading is calculated based on 30 hours.

Adjusting leave quota entitlements

An employee has 20 hours of accrued leave and has 5 hours of entitled leave. You want to transfer the 20 hours to entitlement on January 1, 2000. On that date, you also create a quota correction record in the Quota Correction infotype (2013) to increase the employee’s entitled leave by 10 hours to make a total of 15 hours of entitled leave. When the transfer takes place, 20 hours of accrued leave are transferred to entitlement and as a result leave loading is calculated based only on the hours transferred, that is, 20 hours.

Prerequisites

You want to adjust accrued leave or entitled leave on the same date as you want to transfer leave accruals to entitlement.

Process Flow

When adjusting leave accruals and entitlements on the same day as transferring accruals to entitlement, SAP recommends that you only adjust the accruals, because any changes to entitlements will not be reflected in leave loading calculations.

If you want to change entitlements, SAP recommends that you create the relevant record in the Quota Correction infotype (2013) on any day other than the day on which your accruals are transferred to entitlement.

See also:
Leave Loading with Quota Corrections

Quota Corrections Infotype (2013) [Extern]
Leave Loading [Seite 325]
Leave Payments on Termination

Use
The Terminations/Redundancies program calculates the amount of leave an employee has remaining up to his or her termination date. The leave data is made up of the leave quota, the expected leave entitlement hours at the termination date and the expected accrual hours at the termination date.

Integration
To determine whether a termination payment should include annual leave, leave loading and long-service leave (LSL), the Terminations/Redundancies program checks each leave quota against the data stored in the Rules for Quota Payment on Termination view (V_T5QTR) to verify if it is valid to be paid out for the award and termination reason. This view also determines whether:
- Leave entitlement and/or accrual or neither is paid out.
- Leave loading is applicable to entitlement and/or accrual or neither.
- Accrual is to be paid out when the entitlement value is less than or equal to zero.
- LSL is to be paid out based on whether the employee’s continuous years of service exceed the minimum years required.

Prerequisites
Processing leave payments on termination based on leave quotas requires project teams to configure a number of settings in Customizing for Personnel Time Management and for Payroll Australia. These include:
- Configuring the Quota Compensation section of Customizing for Personnel Time Management, and in particular the quota compensation types and subtypes used in the Quota Compensation infotype (0416).
  To do this, choose SAP Reference IMG → Personnel Time Management → Time Data Recording and Administration → Managing Time Accounts Using Attendance/Absence Quotas → Processing Absence Quotas in Payroll → Time Quota Compensation → Define Time Quota Compensation Methods [Extern], and then Assign Wage Types to the Quotas to be Compensated [Extern].
- Checking that the correct leave method has been set up. To do this, choose SAP Reference IMG → Payroll → Payroll: Australia → Leave Provisions and Payments → Set Up Leave Method [Extern].
- Configuring the Terminations/Redundancies section of Customizing for Payroll Australia, and in particular the step Set Up Redundancy Rules for Paying Leave Quotas [Extern].

In addition, you must ensure that there is an entry for each quota to be paid in the Absence Quotas infotype (2006).

Features
The Terminations/Redundancies program lists the leave quotas to be included in the termination payment calculation and projects the leave balances.
Leave Payments on Termination

Once you have processed and updated a termination, the program creates records in the *Quota Corrections* (2013) and the *Time Quota Compensation* (0416) infotypes used to compensate leave quotas. In addition, updating terminations triggers time evaluation up to the employee’s termination date.

If you re-instate a terminated employee, you must reverse the compensated quotas by manually deleting the relevant records in the *Quota Corrections* (2013) and the *Time Quota Compensation* (0416) infotypes, and re-running time evaluation.

**See also:**

- Projecting Leave Balances [Seite 331]
- Time Evaluation [Extern]
- Quota Corrections Infotype (2013) [Extern]
- Absence Quotas Infotype (2006) [Extern]
- Time Quota Compensation Infotype (0416) [Seite 222]
- Technical Process of Terminations/Redundancies [Seite 386]
Projecting Leave Balances

Prerequisite

The leave quota must be configured as payable for the termination reason.

Procedure

1. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

2. Enter the employee’s personnel number, the termination date and the termination reason.

3. If necessary, set the payment method and group certificate options indicators.

4. Select Choose from the toolbar.

   The Terminations Australia screen appears.

5. Select an employee’s name, and choose Details.

   The Employee Details screen appears.

6. To project leave accruals and/or entitlements, enter the relevant date in the Notice Date field or the Termination Date field.

Result

The program displays the leave quota, text, entitlement and accrual hours in the Projected leave table. If the leave data is set up in the SAP System, the program projects the relevant leave accruals and entitlements to the notice date or the termination date.

The amount projected is not always the total amount that is paid out. For example, if accrual is not to be paid, the SAP System displays 0 in the Projected leave table.

See also:

Leave Payments on Termination [Seite 329]
Quota Accrual Transfer to Entitlement

Purpose

The SAP HR Payroll Australia component in conjunction with SAP HR Personnel Time Management enables you to:

- Effect a rollover that is more than 12 months into the future
- Extend the rollover date by leave without pay (LWOP) absences
- Pro-rate leave for the portion of the accrual period up to the transfer date
- Include LWOP absences in length of service calculations

The following provides an overview of how the SAP System processes quota accrual transfers to entitlement based on your system configurations in Customizing for Payroll Australia and Personnel Time Management.

Prerequisites

Project teams should configure:

- The Quota Compensation section of Customizing for Personnel Time Management, and in particular the steps Define Rules for Transferring Quota Entitlements [Extern] and Define Generation Rules for Quota Selection [Extern].
- The Quota Accruals Transfer to Entitlement [Extern] section of Customizing for Payroll Australia.

Process Flow

1. To calculate the length of service for a rollover that is greater than one year, you define and configure a three-character transfer rule. The rule is set against each quota type and links quotas to tables that define the length of the accrual to entitlement transfer period and how LWOP absences affect this transfer period.

   If you require different transfer rules for different employee groupings, you must ensure that you have configured the following groupings accordingly:

   - Employee subgroup grouping for time quotas
   - Personnel subarea grouping for time quotas
   - Personnel subarea grouping for time recording

   If you require different transfer rules for the same employee groupings, you must ensure that you have configured a different rule name for each rule – for example, a rule name for long-service leave and another for annual leave.

2. Once the transfer rule has been configured, you define:

   - The date type that holds the start date of the transfer time
     
     This is derived from the Date Specifications infotype (0041).
   - The length of the accrual period in months or years
   - Up to three transfer frequencies
For example, you can define that accrual should transfer to entitlement after 10 years from the date type entered in infotype 0041, and then again after 5 years, and again each year after that. The final transfer frequency entered is repeated continuously. Similarly, if you only define one transfer frequency, this will keep repeating.

- The number of times a transfer frequency is to be repeated

For example, to define that accrual should transfer to entitlement after 10 years of service, then again after five years of service, and again after another five years of service, you enter a transfer frequency of 10 years followed by a transfer frequency of 5 years and a multiplier of 2.

3. You then configure how LWOP absences affect the transfer date. You do this by defining an absence type, and whether you want to extend the transfer date:
   - By the entire length of the LWOP absence
   - Only if the LWOP absence is greater than a defined threshold value
   - Only by the portion of the LWOP absence that is over the threshold value
   - By the entire length of the LWOP absence after the threshold value has been taken into account

4. To calculate the transfer date, the SAP System adds the transfer period to the date type in infotype 0041, and adds any LWOP absences.

**Result**

If you configure a quota type to accrue daily, the SAP System stores the accrual amount each day. If you configure a quota type to accrue on a monthly basis, accrual occurs at the end of the month. However, if a transfer period occurs part-way through a month, the SAP System calculates accrual for part of the month only by pro-rating the amount of the accrual for the month.

For the month of February, the SAP System reads the start date 01.02.1999 and the end date 28.02.1999. If the transfer date is 14.02.1999, it changes the end date to 14.02.1999. This date is then used to pro-rate the amount of leave that the employee accrued for the month.

**See also:**
- Set Up Transfer Rules and Date Types [Extern]
- Set Up Transfer Period and Frequency [Extern]
- Set Up Leave Without Pay Rules [Extern]
Leave Reporting

Use
This function provides leave liability data on long-service leave (LSL), recreational leave and other leave types. The data can be broken down according to user-defined criteria such as company code and personnel number, and can be grouped into key data that is displayed in various leave reports.

Prerequisites
- To process leave based on leave and absence quotas in the SAP HR Personnel Time Management component, you must configure the Leave Provisions and Payments [Extern] section of Customizing for Payroll Australia, and the relevant sections in Customizing for Personnel Time Management.
- To process leave provisions, you must activate the EOM Leave Provisions subschema in Customizing for Payroll Australia, and successfully complete the last payroll run of the calendar month.
- You must have run payroll for your employees and have payroll results.

Features
If you process leave based on leave accruals, the Leave report screen displays the Leave selection group box, and requires entries in either the Leave type or the Leave group field.

If you process leave based on leave and absence quotas, the Leave report screen displays the Quota selection group box, and requires you to enter absence quota types in the Quota selection field or absence quota groupings in the Quota group field.

This function produces the following reports:

Recreational leave provision report
The report displays subtotals based on user-defined selection criteria, and provides the following key data:
- Cost center
- Weekly earnings
- Credit entitlement hours
- Pro rata accrual hours
- Credit entitlement dollar value
- Pro rata accrual dollar value
- Leave loading pro rata accrual dollar value
- Total dollar value of liability
- Escalation dollar value
- Final total dollar value after escalation on-cost has been applied
Only one leave provision factor [Extern] is applied to the result. This factor is the escalation rate for 10+ years of service. Leave loading pro rata is calculated using the leave loading percentage in the leave rules table. If an employee has more than one cost center, the employee’s pay is split between cost centers.

**Long-service leave provision report**

The report displays subtotals based on user-defined selection criteria, and provides the following key data:

- Cost center/personnel number
- Years of service
- LSL liability dollar value calculated using the LSL probability factor
- Escalation factor
- Escalation dollar value
- Subtotal after escalation on-cost has been applied
- Inflation rate
- Inflation dollar value
- Subtotal after inflation on-cost has been applied
- Bond rate
- Bond rate dollar value
- Final total dollar value after the bond rate on-cost has been applied

A different leave provision factor [Extern] is applied to each year of service.

**Leave projection/liability report**

The report displays subtotals based on user-defined selection criteria, and provides the following key data:

- Entitlement and accrual hours
- Liability hours
- Hourly rate
- Liability dollar value
- Estimated leave loading figures
- Total dollar value of liability

The Leave Projection/Liability report can be produced at a given cut-off date. If the cut-off date is before the last completed payroll run, the SAP System determines the end date of the payroll period closest to the cut-off date and triggers evaluation as per this date. If the cut-off date is after the last completed payroll run, it performs a leave projection.

When projecting recreational or other leave data, the report projects leave types to a future date and displays leave entitlement and accrual hours, leave values and estimated leave loading figures. If the leave type changes, the report displays subtotals for the leave type specified. If the company code changes, it displays the total number of employees that have had leave processed for them.
Leave Reporting

When projecting LSL data, the report determines the employer’s liability to provide LSL for an employee. The report projects a specific LSL type or a range of LSL types to a future date and displays leave entitlement and accruals hours, the total leave value, and the employer’s liability value calculated on a percentage based on the number of years the employee has been with the company. If the employer has no liability to the employee, the SAP System will not issue a report for that employee.

See also:

Executing Leave Reports [Seite 731]
Printing Leave Reports [Seite 733]
Leave Provisions Based on Leave Accruals [Extern]
Leave Provisions Based on Leave Quotas [Seite 316]
Executing Leave Reports

Use

This function enables you to display the following reports:

- *Recreational Leave Provision* report
- *Long-Service Leave Provision* report
- *Leave Projection/Liability* report

All the reports are executed in the same way.

Prerequisites

You must have run payroll for your employees and have payroll results.

When projecting leave liability data, the leave projection date (run date) must be after or the same as the system date and after the end date of the last payroll run for the payroll area.

Before you run leave provision reports, you must activate the *EOM Leave Provisions* subschema in the payroll driver, and complete the last payroll run of the calendar month successfully.

Procedure

1. Choose *Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Lists/statistics → Leave reports*.

   The *Leave Reporting* screen appears.

2. Define the period for which you want to run the report.

3. Choose the relevant selection criteria (for example, the payroll areas, employee groups, cost centers or personnel numbers for which you want to run the report).

   When running multiple payroll areas, you must ensure that all the payroll areas have the same period modifier.

4. If you process leave based on leave accruals, enter the leave type(s) or leave group(s)

   Or

   If you process leave based on leave and absence quotas, enter the absence quota types or absence quota groupings in the *Quota selection or Quota group* field.

5. Set the indicator for the report you want to run.
Executing Leave Reports

To perform a leave projection, you must set the Projection/Liability field indicator, and enter a projection date in the Run date field.

To process long-service leave, you must enter the liability percentage for each year of service.

6. Define your report display parameters.

7. Choose Program → Execute.
Printing Leave Reports

Use
In addition to displaying reports, the standard system enables you to print leave reports.

Prerequisite
You must first execute the relevant leave report.

Procedure
1. From the report screen, choose List → Print.
   The Print Screen List screen appears.
2. In the Output device field, enter the printer name.
3. Choose Output → Print.
Partial Period Remuneration (Factoring)

Purpose

If an employee did not work for the whole payroll period, then a partial remuneration is calculated during the payroll run. In this way only results for the current period are considered. Factoring is used in the following cases:

- To reduce payments [Seite 342] made to an employee because he or she joins, leaves, or is absent from the company during a period
- To calculate remuneration for an exact period [Seite 343] because of substitutions, changes in basic pay, organizational reassignments, or changes in the personal work schedule
- To calculate cost accounting wage types for an exact period. This will enable you to decide how much remuneration an employee receives for work done and for paid absences. The different amounts can be assigned to different cost centers.

Scope of Function

To determine an employee’s exact remuneration, the remuneration amount is multiplied by a partial period factor. The partial period factor can be calculated using different methods:

- Payment method
- Deduction method
- Hybrid of payment and deduction methods
- PWS method
- All or nothing method

You find guidelines on which method to select in the collective agreement, the company agreement and in the documentation on the individual methods. The question of which method to use is extremely important, particularly if payroll is run for monthly periods.

The standard system contains a few examples for factoring rules that are needed to determine the partial period factor. You can either use these rules as they are, or adapt them in Customizing for Payroll under Factoring to meet your company requirements. Using Create Wage Types for Cost Accounting, you assign the wage types to different wage types for cost accounting.

The following infotypes are evaluated for factoring in payroll:

- Actions infotype(0000)
- Organizational Assignment infotype(0001)
- Planned Working Time infotype (0007)
- Basic Pay infotype(0008)
- Recurring Payments and Deductions infotype (0014)
- Additional Payments infotype (0015)
- Absences infotype (0015)
- Substitutions infotype (0030)
Application Examples for Reductions

When the following situations arise within a payroll period, the payments made for an exact period are reduced:

- Reduction in basic pay
  - An employee joins the company on a day other than the first day of the period.
  - An employee leaves the company on a day other than the last day of the period.
  - An employee takes one week of unpaid leave.

- Reduction of recurring payments
  - An employee regularly receives a transportation allowance but takes leave for three weeks. The transportation allowance must only be paid for the period during which the employee travels to work.

- Reduction of additional payments
  - Your enterprise only pays a bonus on the condition that the employee will still be working for the enterprise the following month.
Application Examples for Period-Specific Remuneration Calculation

When the following situations arise within a payroll period, wage types are calculated for exact periods. This means that the remuneration elements are calculated separately for each partial period.

- Change in basic pay
  An employee’s payments are increased in the middle of a period. One half of the lower, period-specific remuneration amount is paid for the first partial period, and one half of the higher, period-specific remuneration amount is paid for the second partial period.

- Organizational assignment
  An employee changes department and is, therefore, assigned to a different cost center. This does not mean that the employee receives more or less remuneration, but it does mean that the appropriate amounts must be debited to the cost centers in question for exact periods.
Partial Period Factor

Definition
You can find a definition of the term Partial Period Factor [Extern] in the glossary.

Structure
The SAP System uses the following formula to calculate the partial period factor:

\[
\frac{\text{Planned working time or flat rate period working time} - \text{absence}}{\text{divisor}}
\]

All of this formula's parameters [Seite 345] are time entries that must be based on the same calculation unit. The following calculation units exist:

- Working hours (S)
- Work days (A)
- Calendar days (K)

The parameters for the factoring formula are available in table PSP (Personal Work Schedule) in all three calculation units. In the personnel calculation rule, the calculation unit of the individual parameters is indicated by the above letters.

SSOLL contains the value for planned working time in hours, and ASOLL contains the value in work days.

When calculating the partial period factor you must specify the period that should be used:

- Partial period
  
  If a WPBP split indicator exists for a basic pay wage type, you should use a partial period as the calculation basis. In this case, the period of each partial period is used as planned working time. In this case a "T" is set before the calculation formula parameters in the personnel calculation rules.

- Whole period
  
  If there is no WPBP split indicator or if it is not relevant to the proportional calculation of remuneration, use the whole period as the calculation basis. For example, this is the case for recurring payments/deductions or additional payments. In this case, the period of the whole period is used as planned working time. A "G" is set before the calculation formula parameters in the personnel calculation rules.
Factoring Parameter

The formula, with which the partial period factor is determined, is filled as follows:

- **Planned working time**
  Planned working time is determined using table PSP (*Personal Work Schedule*). The values of the planned working time parameter can be different for employees in the same period if they have different personal work schedules.

- **Flat rate period working time**
  The flat rate period working time is determined using table WPBP (*Work Center/Basic Pay*).

- **Absence**
  In reductions, absence means the working time during which an employee was not at work and did not get paid. The absence is paid out in counting classes.

- **Partial period**
  If remuneration elements are calculated for exact periods, employee remuneration is calculated separately for specific partial periods. These partial periods are determined using table WPBP (*Work Center/Basic Pay*).

- **Divisors**
  The flat rate or individual period working time is used as a divisor in accordance with table PSP (*Personal Work Schedule*).

The parameters have the following meaning:

<table>
<thead>
<tr>
<th>Value of whole period</th>
<th>Value of a partial period</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSSOLL</td>
<td>TSSOLL</td>
<td>Planned working time in hours</td>
</tr>
<tr>
<td>GASOLL</td>
<td>TASOLL</td>
<td>Planned working time in work days</td>
</tr>
<tr>
<td>GKSOLL</td>
<td>TKSOLL</td>
<td>Planned working time in calendar days</td>
</tr>
<tr>
<td>GSAU**</td>
<td>TSAU**</td>
<td>Unpaid absence in hours for all counting classes</td>
</tr>
<tr>
<td>GAAU**</td>
<td>TAAU**</td>
<td>Unpaid absence in work days for all counting classes</td>
</tr>
<tr>
<td>GKAU**</td>
<td>TKAU**</td>
<td>Unpaid absence in calendar days for all counting classes</td>
</tr>
<tr>
<td>GSAP**</td>
<td>TSAP**</td>
<td>Paid absence in hours for all counting classes</td>
</tr>
<tr>
<td>GAAP**</td>
<td>TAAP**</td>
<td>Paid absence in work days for all counting classes</td>
</tr>
<tr>
<td>GKAP**</td>
<td>TKAP**</td>
<td>Paid absence in calendar days for all counting classes</td>
</tr>
</tbody>
</table>
### Factoring Parameter

<table>
<thead>
<tr>
<th>Code</th>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSAX**</td>
<td>TSAX**</td>
<td>Work on public holidays in hours for all counting classes</td>
</tr>
<tr>
<td>GAAX**</td>
<td>TAAX**</td>
<td>Work on public holidays on a work day for all counting classes</td>
</tr>
<tr>
<td>GKAX**</td>
<td>TKAX**</td>
<td>Work on public holidays on a calendar day for all counting classes</td>
</tr>
<tr>
<td>GSDIVI</td>
<td>TSDIVI</td>
<td>Individual period working time in hours</td>
</tr>
<tr>
<td>GADIVI</td>
<td>TADIVI</td>
<td>Individual period working time in work days</td>
</tr>
<tr>
<td>GSDIVP</td>
<td>TSDIVP</td>
<td>Flat rate period working time in hours</td>
</tr>
<tr>
<td>GADIVP</td>
<td>TADIVP</td>
<td>Flat rate period working time in work days</td>
</tr>
<tr>
<td>GKDIVP</td>
<td>TKDIVP</td>
<td>Flat rate period working time in calendar days</td>
</tr>
</tbody>
</table>
Technical Sequence for Partial Period Remuneration

Purpose

For information on the use of partial period remuneration see partial period remuneration (factoring) [Seite 340].

Prerequisites

The following conditions must be met before factoring schema xAL0 can run correctly:

- In Customizing for Payroll under Factoring → Create Reduction Factors you have determined the way in which the system should calculate the employees remuneration in different situations.

- Processing classes 10 (Mark wage types for factoring) and 31 (Split monthly lump sums for cost accounting) must be maintained for the primary wage types that require factoring.

Process Flow

The X sign appears in the following text in a number of schemas, functions, and personnel calculation rules. This abbreviation represents the country indicator and the international versions of the schemas, functions, and personnel calculation rules. You should only use this if schemas, functions, and personnel calculation rules have not been set up specifically for your country or if you do not want to use the country-specific functions that are available.

In personnel calculation schema X000 (Determine gross wage and transfer) subschema xAL9 (factoring and storage) is called up. The country-specific factoring schemas included in the standard system take account of common, country-specific requirements. If a country-specific schema does not exist for your country, make a copy of international subschema XAL9 or a suitable country-specific schema, and adapt the copy to your particular requirements.

1. Using function GEN/8 the system generates the secondary wage types /801 to /8<nn> for every partial period and enters them in the Input Table (IT).

   These wage types contain the partial period factor. The value is set at 1 in each wage type and is then multiplied by the constant GENAU 100,000.00 to increase the accuracy of the calculations. The result is written to the Rate (RTE) field. The partial period factor can be changed in further procedures.

   The employee subgroup grouping for personnel calculation rules and the WPBP split indicator are entered in each generated secondary wage type /8<nn>. 

   The X sign appears in the following text in a number of schemas, functions, and personnel calculation rules. This abbreviation represents the country indicator and the international versions of the schemas, functions, and personnel calculation rules. You should only use this if schemas, functions, and personnel calculation rules have not been set up specifically for your country or if you do not want to use the country-specific functions that are available.
Technical Sequence for Partial Period Remuneration

The standard system generates 16 secondary wage types for the partial period factors. You can use the secondary wage types /801 to /809 for your own partial period factors. The secondary wage types /810 to /816 are used in the R/3 System to calculate monthly lump sums.

2. If no split indicator is available the value of the partial period remains 1. The corresponding wage type is paid out with the whole amount. If the checked wage type contains a split indicator the factoring process continues.

3. Using the personnel calculation rule xPPF the system determines the partial period factor for each partial period.

If the employee worked in the payroll period, the system determines whether he was also absent and using this information calculates the partial period factor. The RTE field (rate) is updated in the input table (IT) for each secondary wage type /8<nn>.

4. Using the personnel calculation rule xCMO the System determines the flat-rate period for cost accounting.

The processing class 31 (Cost distribution) for all wage types in the Input Table (IT) is valuated and the amount of the following cost accounting wage types is calculated:

- /840 (Difference between Working Hours for the Current Month and the Average Value)
- /844 (Paid public holidays)
- /845 (Total paid non-work)
- /846 (Total unpaid absences)

5. Using the personnel calculation rule xVAL the System determines the salary components of the wage types in the Input Table (IT) by multiplying the amount of the primary wage type with the rate of the wage type /80<n>, which corresponds to the specification of processing class 10 (Mark wage types for factoring).

The new calculated value is then entered in the AMT field (Amount) of the corresponding primary wage type.

6. The system determines the hourly rates for cost accounting.

7. The reduced values are written in the Input Table (IT).
PWS Method

Definition
The method used to calculate partial period factors.

Use
If the PWS method is used to calculate the partial period factor, the individual, actual planned working time according to the employee’s personal work schedule (PWS) is used as the divisor.

The PWS method is suitable for use in the following situations:

- for reductions if planned working time is specified exactly and you enter all deviations from planned working time in the following infotypes:
  - Absences infotype (2001)
  - Substitutions infotype (2003)
  - Planned Working Time infotype (0007)
- Rules for calculating partial payments for exact periods

The PWS method is not suitable if the payroll is run for monthly periods. The employee then has a lower reduction amount in periods with less planned working time (short months) than in periods with more planned working time (long months).

Structure
The partial period factor is calculated as follows:

Factor = (planned working time - absence) / individual period working time
Payment Method

Definition

The method used to calculate partial period factors.

Use

If the payment method is employed, the employee is remunerated for the period actually worked or for paid absences. The constant for the flat-rate period working time is used as the divisor.

If the payroll is run for monthly periods, the general divisor determines that each calculation unit (hour or day) has the same value, irrespective of whether the period is a short or long month.

The payment method is **suitable for use** in the following situations:

- The employee has many unpaid absences.
- The actual length of the period is not different from the general length of the period (for example, weekly payment).

The payment method is **not suitable to use** in the following situations:

- Payroll is run for an employee on a monthly basis (monthly or half-monthly) and the employee has only few unpaid absences.
- In long months (for example, July) remuneration could be calculated and the amount could exceed the basic remuneration amount for the period, despite the absences.
- In short months (e.g. February) an employee's remuneration is reduced too much even if there are few absences.
- Partial payments must be calculated for exact periods.
  
  The employee would receive an amount that is different from the remuneration amount for the period because the number of hours or days does not correspond to the average.

Structure

The partial period factor is calculated as follows:

Factor = (planned working time - absence) / general period working time

You can use the average values typical for your particular country, industry, or company as general period working time.
Deduction Method

Definition

The method used to calculate partial period factors.

Use

If the deduction method is employed, a prorata amount is deducted from employee remuneration for the period of his or her unpaid absence. The constant for the flat-rate period work time is used as the divisor.

If the payroll is run for monthly periods, the general divisor determines that each calculation unit has the same value, irrespective of whether the period is a short or long month.

The deduction method is **suitable to use** in the following situations:

- The employee has few unpaid absences.
- The actual length of the period is not different from the general length of the period (for example, weekly payment).

The deduction method is **not suitable to use** in the following situations:

- Payroll is run for an employee on a monthly basis (monthly or half-monthly) and the employee has only a few unpaid absences.
- In long months (e.g. July) a large number of absences could result in negative remuneration, i.e. money would be claimed from the employee.
- In short months (e.g. February) the employee also receives remuneration if he was absent for the whole month.
- Partial payments must be calculated for exact periods.

The employee would receive an amount that is different from the remuneration amount for the period because the number of hours or days does not correspond to the average.

Structure

The partial period factor is calculated as follows:

\[
\text{Factor} = \frac{\text{general period work time} - \text{absence}}{\text{general period work time}}
\]

You can use the average values typical for your particular country, industry, or company as general period working time.
Hybrid of Payment and Deduction Methods

Definition
The method used to calculate partial period factors.

Use
Since the deduction method is used for a lot of absences and the payment method is used for few absences it is recommended that each individual should decide which method should be used. For few absences the payment method should be used because then the remuneration is high. For a lot of absences the deduction method should be used because then the employee would earn less accordingly.

Mary Brown receives a basic monthly pay of 5,456.00 and has a general period working time of 22 workdays. In a month that contains 23 workdays, she has an unpaid absence of 10 workdays.

Reduction using different methods

<table>
<thead>
<tr>
<th>Days of absence</th>
<th>Factoring method</th>
<th>Partial period factor</th>
<th>Standard salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Deduction</td>
<td>(22-10)/22 = 12/22</td>
<td>2 976,00</td>
</tr>
<tr>
<td>10</td>
<td>Payment</td>
<td>(23-10)/22 = 13/22</td>
<td>3 224,00</td>
</tr>
<tr>
<td>11</td>
<td>Deduction</td>
<td>(22-11)/22 = 11/22</td>
<td>2 728,00</td>
</tr>
<tr>
<td>11</td>
<td>Payment</td>
<td>(23-11)/22 = 12/22</td>
<td>2 976,00</td>
</tr>
</tbody>
</table>

The calculation shows: If Mary Brown were to be absent and unpaid for 11 days she would earn just as much if the calculation was made using the payment method as she would if the absence were calculated for 10 days using the deduction method.
All or Nothing Method

Definition
The method used to calculate partial period factors.

Use
If the all or nothing method is employed, the employee receives either the entire wage type amount or nothing at all. A criterion for entitlement to the entire amount could, for example, be a minimum period that the employee must have worked. If the condition is met, the factor is 1. If the condition is not met, the factor is 0.

The all or nothing method is suitable to use in the following situations:

- Cost transfer of travel allowance
- If the employer pays a savings plan allowance
Reduction of Payments: Example

Gertrude Jones has unpaid leave from February 3 to March 29. This means that she works just 2 days in both February (20 workdays) and March (23 workdays). Her monthly basic remuneration is 3252,00. Her weekly working time is based on 37 hours.

Parameter values in hours

<table>
<thead>
<tr>
<th>Parameter</th>
<th>February</th>
<th>March</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planned working time (SSOLL)</td>
<td>148</td>
<td>172</td>
</tr>
<tr>
<td>Absence (SAU)</td>
<td>132</td>
<td>156</td>
</tr>
<tr>
<td>Individual period working time (SDIVI)</td>
<td>148</td>
<td>172</td>
</tr>
<tr>
<td>General period working time (SDIVP)</td>
<td>167,7</td>
<td>167,7</td>
</tr>
</tbody>
</table>

Reduction using different methods

<table>
<thead>
<tr>
<th>Method</th>
<th>Calculation formula</th>
<th>Remuneration for February</th>
<th>Remuneration for March</th>
</tr>
</thead>
<tbody>
<tr>
<td>PWS</td>
<td>a = (SSOLL-SAU**)/SDIVI</td>
<td>0,108</td>
<td>0,093</td>
</tr>
<tr>
<td></td>
<td>Reduced remuneration:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>b x a</td>
<td>351,22</td>
<td>302,44</td>
</tr>
<tr>
<td>Payment</td>
<td>a = (SSOLL-SAU**)/SDIVP</td>
<td>0,095</td>
<td>0,095</td>
</tr>
<tr>
<td></td>
<td>Reduced remuneration:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>b x a</td>
<td>308,94</td>
<td>308,94</td>
</tr>
<tr>
<td>Deduction</td>
<td>a = (SDIVP-SAU**)/SDIVP</td>
<td>0,213</td>
<td>0,070</td>
</tr>
<tr>
<td></td>
<td>Reduced remuneration:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>b x a</td>
<td>692,68</td>
<td>227,64</td>
</tr>
</tbody>
</table>

Legend [Seite 345]

a = Partial period factor  b = basic remuneration

If the payment method is employed, Gertrude Jones receives the same amount of remuneration for both months. If the deduction method is employed, she is significantly overpaid in February and significantly underpaid in March. If the PWS method is used, she would still receive a higher salary in February than in March, however the difference would be significantly lower than when using the deduction method.
Calculating Period-Specific Remuneration: Example

Mary Brown receives a basic monthly pay of 5,456.00 and has a general period working time of 22 workdays. She changes cost center on the 16th of a month containing 23 workdays.

Calculating using different methods

<table>
<thead>
<tr>
<th>Partial period in workdays</th>
<th>Factoring method</th>
<th>Partial Period Factor</th>
<th>Remuneration</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.-15. = 11</td>
<td>Payment</td>
<td>(23–11)/22 = 12/22</td>
<td>2 976,00</td>
</tr>
<tr>
<td></td>
<td>Deduction</td>
<td>(22–11)/22 = 11/22</td>
<td>2 728,00</td>
</tr>
<tr>
<td></td>
<td>PWS</td>
<td>(23–11)/23 = 12/23</td>
<td>2 846,60</td>
</tr>
<tr>
<td>16.-30. = 12</td>
<td>Payment</td>
<td>(23–12)/22 = 11/22</td>
<td>2 728,00</td>
</tr>
<tr>
<td></td>
<td>Deduction</td>
<td>(22–12)/22 = 10/22</td>
<td>2 480,00</td>
</tr>
<tr>
<td></td>
<td>PWS</td>
<td>(23–12)/23 = 11/23</td>
<td>2 609,40</td>
</tr>
<tr>
<td>Total using payment method</td>
<td></td>
<td></td>
<td>5 704,00</td>
</tr>
<tr>
<td>Total using deduction method</td>
<td></td>
<td></td>
<td>5 208,00</td>
</tr>
<tr>
<td>Total using PWS method</td>
<td></td>
<td></td>
<td>5 456,00</td>
</tr>
</tbody>
</table>

Since Mary Brown only changed cost center and was not absent, her basic payments should be calculated using the PWS method. With this calculation method she receives the basic payments that she is entitled to for this month.
Salary Packaging
Salary Packaging

Use

Salary packaging allows you to accurately forecast the impact that various salary components have on an employee's gross and net income. By accurately projecting an employee's total package, employers can streamline remuneration to an employee's individual requirements.

For releases 4.6A, 4.6B and 4.6C, this functionality can only be used by approved pilot customers.

Integration

Salary packaging is integrated into the following SAP components:

- Personnel Administration
- Payroll South Africa
- Payroll Australia

Prerequisites

The following conditions must be fulfilled before setting up salary packaging parameters for an employee.

- An employee must be assigned the following infotypes:
  - Actions (0000)
  - Organizational Assignment (0001)
  - Personal Data (0002)
  - Addresses (0006)
  - Planned Working Time (0007)
  - Basic Pay (0008)
  - Bank Details (0009)
  - Taxes SA (0149) (valid only for South Africa)
  - Social Insurance SA (0150) (valid only for South Africa)
  - Superannuation (0220) (valid only for Australia)

- If an employee receives a total package, they must also be assigned the model wage type /TPA with the total package amount. Note: This amount is set to a per period amount and not an annual amount.
Salary Packaging

- Your company's salary components must be set up in Customizing. To do so, see in the Salary Packaging IMG: Salary Packaging -> Salary Components -> Define Salary Components. For additional Customizing information, see Salary Package Customizing [Seite 359].

To ensure that system parameters are set up for salary packaging, it is recommended to review all the steps in the Salary Packaging IMG before creating individual salary packages for your employees.

Features

- Based on eligibility criteria, employees are only offered those salary components for which they are eligible.

- An employee's total package can be calculated as follows:
  - As a total package where the sum of all the employee's salary components must add up to the total package amount.
  - An employee receives a basic salary. The relevant salary components are then added to the basic salary. The sum of the employee's basic salary and the salary components equal the employee's total package.

  In both cases, you can display the total cost to the company.

- For comparison purposes, you can view the values of an employee's old package against the values of the new package.

- You can run a payroll simulation. By reviewing the employee's payslip, you can check the employee's simulated net pay.

- Upon saving an employee's salary package, all the relevant infotypes will automatically be updated (provided that the salary package is accepted by the system).

- You can optimize the salary component car allowance by simulating an employee's car details against SARS's year-end Travel Allowance Rates. (Note: This feature is only valid for South Africa).

Activities

In the Salary Packaging IMG, perform the relevant customizing steps: see Salary Package Customizing [Seite 359].

To create an employee's salary package, see Creating an Employee's Salary Package [Seite 361].

See also Sample Employee Salary Package (South Africa) [Seite 364] and Sample Employee Salary Package (Australia) [Seite 367].
Salary Package Customizing

Purpose
By performing the Customizing steps in the IMG, you create the basis for which employee salary packages can be created. For example, it is during Customization that you create salary components and also setup eligibility criteria.

Process Flow
In order to perform the salary packaging Customizing steps in the IMG, you must first perform the following steps:
1. In the SAP Easy Access screen, choose Favorites → Insert Transaction and enter SIMGH. The entry IMG hierarchy maintenance appears in your favorites list.
2. Choose IMG hierarchy maintenance.
The Edit IMG structure screen appears.
3. In the IMG Structure field, choose the F4 options.
4. In the Title field, enter Salary Packaging and choose Execute.
5. Select Salary Packaging and choose Favorites.
The IMG structure Salary Packaging is now in your favorites list.

Once you have successfully performed the above steps, you only need to perform steps 2 & 6 to access the Salary Packaging IMG structure.

Customizing
In the Basic Settings section, set up your compensation areas (according to Compensation Management guidelines).
In the Salary Components section, you define:
- Salary Components - which are the elements of an employee’s compensation package. Basic salary and Company car are examples of salary components.
- Salary Component Groups - by setting up salary component groups, you default salary components based on an employee’s organizational assignment.
- Eligibility Criteria - establishing eligibility criteria allow you to create checks (in addition to Salary Component Groups) to determine if an employee will have a specific salary component defaulted into their salary package. For example, an employee may only be eligible for a certain salary component, once they reach a specific pay scale level.
- Additional Settings - you maintain additional features for salary packaging. The following steps are only relevant for South Africa:
Salary Package Customizing

- Maintain Company Car Regulation
- Define Receiver Travel Allowance Rates
- Result

Now that you have performed the necessary Customizing steps for salary packaging, see Creating an Employee’s Salary Package [Seite 361].
Creating an Employee's Salary Package

Prerequisites
You must perform Salary Package Customizing [Seite 359] before performing this step.

Procedure
1. In the SAP Easy Access screen, choose Favorites → Insert Transaction and enter the transaction code.

   Transaction P16A is valid for releases 4.6A and 4.6B. As of release 4.6C, you can use transaction P16B_ADMIN or Salary Packaging as an ESS scenario.

   The entry Salary packaging appears in your favorites list.

2. Choose Salary packaging.

   Once Salary packaging is in your Favorites menu, you only need to perform step 2 (from above).

   The Salary packaging screen appears.

   1. In the Personnel no. field, enter the employee's personnel number for whom you would like to create a salary package.

   2. In the Effect. Date field, enter the date as of when the salary package is valid.

   3. Choose Enter.

   The Salary packaging screen appears (where you create a salary package in the Package distribution section).

   The following is a description on how to proceed for transaction P16A. To model your package with the transaction P16B_ADMIN, see Salary Packaging [Seite 369]. For information on Salary Packaging as an Employee Self Service scenario, see ESS [Seite 370].

   In the Package distribution section, all those salary components are displayed for which the employee previously had data stored in the infotypes. Salary components are the elements of an employee’s salary package. For comparison purposes, this screen stores the current salary
Creating an Employee’s Salary Package

To create a new salary package, enter the new amount and new percentage in the fields New amount and New %, while the employee’s previous salary package (if applicable) is indicated in the Old amount and Old % fields.

- You can select or deselect salary components with the icons Insert salary component and Deselect salary component (which are located towards the bottom left of the screen).

When selecting Insert salary component, all the salary components will be listed for which the employee is eligible. This is based on the employee’s organizational assignment, pay grade, and eligibility criteria (as set up in customizing).

For Australia, Superannuation will not be listed.

- Depending on the type of the salary component selected, you may be required to advise additional information (which varies among salary components). If such is the case, there will be a drop-down box (F4 help) in the Category field. The options include:
  - Complete the category fields in the F4 help (Example: For the salary component Medical Aid (South African), you must choose a company, scheme and contribution class.)
  - Enter an amount
  - Enter a percentage

If the amount field or percentage field is grayed out (input off), the system will automatically calculate the amount or percentage contribution.

Once you have created the employee’s salary package:

1. Run a simulation payroll by selecting Payroll simulation.
   - If the simulation run was successful, a sample payslip is displayed.
   - You can perform the above steps, until the employee’s optimal salary package is achieved.
2. Choose Save to save the new package.
Upon saving the employee's salary package, all the infotypes contained in the salary package will automatically be updated by the system.

3. To optimize an employee's Car allowance perform the following steps. (Note: This step is only valid for South Africa):
   - Choose the Travel allowance optimizing tab strip.
   - Enter all the relevant information.
   - Select calculate.

The system displays the taxable earnings at year end as compared to those from the current period.

The system calculates the travel allowance based on entries entered in the Travel allowance optimizing tab strip on the Salary Packaging screen and the Salary Packaging: ZA receiver rates table, which stores per tax year SARS travel allowance data. You must keep this table up-to-date according to SARS’s specifications. To access this table, see in the Salary Packaging IMG: Additional Settings → Define Receiver Travel Allowance Rates.

**Result**

You have created an employee's salary package.
Sample Employee Salary Package (South Africa)

Purpose

This example serves to illustrate the various ways to use the salary packaging functionality (with transaction P16A).

Based on Salary Package Customizing [Seite 359], the following salary components were created:

- Total package *
- Bonus
- Pension fund *
- Car Allowance
- Company car
- Retirement annuity *
- Entertainment Allowance
- Basic Salary *
- Total cost *

Process Flow

The following example is the process flow of how the South African employee John Khumalo, of the Cape to Cairo trailer company, arrives at his optimal salary package.

By following the instructions in Create an Employee's Salary Package [Seite 361] John's salary package contains the salary components listed above with * (as he previously had that information stored in his infotypes before creating his salary package). His salary package is as follows:

<table>
<thead>
<tr>
<th>Salary Component</th>
<th>New Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total package</td>
<td>R 240,000</td>
</tr>
<tr>
<td>Pension fund</td>
<td>R 16,800</td>
</tr>
<tr>
<td>Retirement annuity</td>
<td>R 24,000</td>
</tr>
<tr>
<td>Basic Salary</td>
<td>R 199,200</td>
</tr>
<tr>
<td>Total cost</td>
<td>R 240,000</td>
</tr>
</tbody>
</table>

The Total package amount is based on the amount entered in the model wage type /TPA in the infotype Basic Pay (0008).
Based on his organizational assignment and pay grade, John is eligible for other salary components (as indicated in the list from Insert salary component). He would therefore like to see what his salary package would look like with an entertainment allowance.

By using Insert salary component, the salary component Entertainment allowance - Standard contribution was chosen.

His salary package is now as follows:

<table>
<thead>
<tr>
<th>Salary Component</th>
<th>New Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total package</td>
<td>R 240,000</td>
</tr>
<tr>
<td>Pension fund</td>
<td>R 16,800</td>
</tr>
<tr>
<td>Retirement annuity</td>
<td>R 24,000</td>
</tr>
<tr>
<td>Entertainment allowance</td>
<td>R 1,000</td>
</tr>
<tr>
<td>Basic Salary</td>
<td>R 198,200</td>
</tr>
<tr>
<td>Total cost</td>
<td>R 240,000</td>
</tr>
</tbody>
</table>

Notice that the salary component Basic salary changed in order to accommodate the salary component Entertainment allowance.

If the salary component Total package is applicable for an employee, the employee must also have at least one salary component in their package with the nature of the salary component as Remainder. The reason for this is that the employee's Total package is a fixed amount. The salary component marked as Remainder (which is setup in the details of table V_T5W7A) will fluctuate according to other salary component added or subtracted, to ensure that the Total package amount remains the same.

John now decides that he no longer wants an entertainment allowance, but a car allowance.

1. By using Delete salary component, the salary component Entertainment allowance was deleted.
2. By using Insert salary component, the salary component Car allowance was chosen.
3. In the category field, the relevant car information was selected.

His salary package is now as follows:

<table>
<thead>
<tr>
<th>Salary Component</th>
<th>New Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total package</td>
<td>R 240,000</td>
</tr>
<tr>
<td>Pension fund</td>
<td>R 16,800</td>
</tr>
<tr>
<td>Retirement annuity</td>
<td>R 24,000</td>
</tr>
<tr>
<td>Car allowance</td>
<td>R 5,000</td>
</tr>
<tr>
<td>Basic Salary</td>
<td>R 194,200</td>
</tr>
<tr>
<td>Total cost</td>
<td>R 240,000</td>
</tr>
</tbody>
</table>
Sample Employee Salary Package (South Africa)

Result

Both John and CCT are in agreement with the above salary package. The salary package was then saved by choosing Save.

Upon saving the salary package, all the infotypes in the salary package were automatically updated by the system.
Sample Employee Salary Package (Australia)

Purpose
This example describes how you can use the salary packaging function (with transaction P16A).

Prerequisites
You have created the following salary components in Customizing [Seite 359]:
- Total package *
- Company super 1 *
- Employee super 1 *
- Fringe benefits tax (FBT)
- Company car
- Basic Salary *
- Total cost *

Process Flow
The following process illustrates how your new employee, Sally Packet, arrives at her optimal salary package:

1. You enter Sally's salary components in the relevant infotypes.
2. You follow the instructions described in Creating an Employee's Salary Package [Seite 361] so that Sally's salary package contains the salary components listed above with *. The resulting salary package is as follows:

<table>
<thead>
<tr>
<th>Salary Component New Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total package</td>
</tr>
<tr>
<td>Company super 1</td>
</tr>
<tr>
<td>Employee super 1</td>
</tr>
<tr>
<td>Basic salary</td>
</tr>
<tr>
<td>Total cost</td>
</tr>
</tbody>
</table>

   The total package amount is based on the amount entered in the model wage type /TPA in the Basic Pay infotype (0008).

3. Based on her organisational assignment and pay scale, Sally is eligible for other salary components (as listed in the Insert salary component field). She would therefore like to see what her salary package would look like if she had a company car and paid FBT.

   In the Insert salary component field, you choose the salary components company car and FBT. Sally's salary package is now as follows:

<table>
<thead>
<tr>
<th>Salary Component New Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total package</td>
</tr>
<tr>
<td>Company super 1</td>
</tr>
<tr>
<td>Employee super 1</td>
</tr>
<tr>
<td>Basic salary</td>
</tr>
<tr>
<td>Total cost</td>
</tr>
</tbody>
</table>
Sample Employee Salary Package (Australia)

<table>
<thead>
<tr>
<th>Component</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total package</td>
<td>$60,000</td>
</tr>
<tr>
<td>Company super 1</td>
<td>$4,200</td>
</tr>
<tr>
<td>Employee super 1</td>
<td>$600</td>
</tr>
<tr>
<td>Company car</td>
<td>$15,000</td>
</tr>
<tr>
<td>FBT</td>
<td>$3672</td>
</tr>
<tr>
<td>Basic salary</td>
<td>$40,728</td>
</tr>
<tr>
<td>Total cost</td>
<td>$64,200</td>
</tr>
</tbody>
</table>

Note how the salary component *basic salary* has changed to accommodate the salary components company car and FBT.

If the salary component *total package* is applicable for an employee, the employee must also have at least one salary component in their package with the nature of the salary component as *Remainder*. The reason for this is that the employee's *total package* is a fixed amount. The salary component marked as *Remainder* (which is set up in the details of view V_T5W7A) will fluctuate according to other salary components added or subtracted to ensure that the *total package* amount remains the same.

4. Sally now decides that she does not want the company car. By choosing *Delete salary component*, you can delete the components company car and FBT. Sally's salary now reverts to the original figures calculated in point 2.

**Result**

Both Sally and your company agree to the salary package, and you save the package.

When you save the salary package, the system automatically updates all the relevant infotypes.
Salary Packaging

Use

On this Salary Packaging screen (transaction P16B_ADMIN), you model your salary package to meet your needs.

The following is some general information about the screen:

- The right side of the screen consists of mandatory components (such as Basic Salary) and the components which are currently part of your package.
- The left side of the screen contains all those additional components for which you are eligible.

For general information on Salary Packaging, see overview documentation [Seite 357].

Procedure

To model your package, perform the following tasks:

1. Click on the salary component text and press the appropriate arrow (to indicate where to move the salary component).
   By performing the above step, you add or remove components from your package variation.
2. To change details for a component, click on the amount On the bottom of the screen, the Edit section appears. This Edit section is specific to each component and contains the relevant amount, percentage, and contribution information valid for the component.
3. Press Accept to include your new attributes to the package.
   Note: Pressing Reset will bring you back to the last saved entry in the edit section.
4. Before leaving the modeling screen you have two options:
   - Pressing Simulation allows you to preview a sample online your payslip.
   - Pressing Accept will include your variation changes in the package.
   - Pressing Update will update the infotypes accordingly.

Result

You have maintained salary components and their respective amount and/or contribution information for your package.
Salary Packaging / Employee Self Service (ESS) Scenario

Purpose
As of Release 4.6C, Salary Packaging is available as an ESS scenario. The advantages of modeling your Salary Package as an ESS scenario include:

- Greater Flexibility
- Workflow enabled managerial approval of your package

Process Flow
The ESS scenario takes you through the following screens:

- The Salary Packaging Compare screen allows you to compare two packages (and their respective payslips) between combinations of the following packages:
  - Old package (if applicable) - this package reflects your package elements prior to modeling your new package.
  - Default package - this package reflects your package elements as of the new effective date.
  - Variation A and Variation B Packages - It is with these packages that you have the opportunity to create different package scenarios. Modeling can take place at your leisure, buy simply saving the package and returning to it at a later point in time. For additional details, click here [Seite 371].

- The Model screen allows you to:
  - Add components to your package
  - Remove components from your package
  - Indicate the applicable amount relevant for certain components.
  
  For additional details, click here [Seite 373].

- Screen to send request your package for approval by your manager.

Result
You have created you preferred Salary Package for managerial approval.
Compare Salary Packages

Use

On this screen, you compare different packages and their respective payslips.
For a general overview of Salary Packaging as an ESS, click here [Seite 370].

Procedure

Choose in the Select field, your respective packages to compare between two different package options.

- The **Old package** (if applicable) reflects your package elements prior to modeling your new package.
- The **Default package** reflects your package elements as of the new effective date.
- The **Variation A** and **Variation B** packages are the packages you can model and it is one of these packages that you request.

1. If you want to preview your payslip for a package, choose **Display the Payslip**.
2. If you want to change components within your package, choose **Change this Package**.
   The modeling [Seite 373] screen appears.

3. There are no restraints as to how often you perform the above steps.

4. Once you have arrived at your preferred package you can save it and send it to your manager for approval.

5. To do so, in the **Request** section, choose the package and click **Submit**.
   The Salary Packaging Request Variation screen appears.

6. From the Salary Packaging Request Variation screen, you have the option to perform the following tasks:
   - Generate a payslip for the package (again).
   - Go back to the compare screen.
   - Request the package.

   By clicking on, **Request the package**, you initiate a workflow in the system (provided that you require managerial approval for your package). Your manager will receive your requested package in their inbox. Intern, you will also receive a message in your inbox.
informing you whether your manager has approved or declined your proposed package. Once your manager has accepted the package, the respective infotypes will be automatically updated in the system.
Model Salary Packages

Use

On this screen, you model your salary package to meet your needs.

The following is some general information about the screen:

- The value of your package and effective date is displayed on the top line.
- The right side of the screen consists of mandatory components (such as Basic Salary) and the components which are currently part of your package.
- The left side of the screen contains all those additional components for which you are eligible.

Salary Component Legend

<table>
<thead>
<tr>
<th>White</th>
<th>Elements of the package</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grey</td>
<td>Remainder element</td>
</tr>
<tr>
<td>Blue</td>
<td>Net deduction (This information is displayed for informational purposes only, as it an amount that is deducted from an employee's net and is not part of the package).</td>
</tr>
</tbody>
</table>

For an overview of Salary Packaging as an ESS, click here [Seite 370].

Procedure

To model your package, perform the following tasks:

1. Click on the salary component text and press the appropriate arrow (to indicate where to move the salary component).
   By performing the above step, you add or remove components from your package variation.

2. To change details for a component, click on the amount.
   On the bottom of the screen, the Edit section appears. This Edit section is specific to each component and contains the relevant amount, percentage, and contribution information valid for the component.

3. Press Accept to include your new attributes to the package.

   Pressing Reset will bring you back to the last saved entry in the edit section.

4. You then have the following options:
   - Pressing Back to compare screen will retain your entry in the current session (allowing you, for example, to view your payslip with your changes).
   - Pressing Save will save your variation changes permanently (allowing you to return to your variation at a later point in time to continue modeling).
Result

You have maintained salary components and their respective amount and/or contribution information for your package variation.
Advance Payments

Purpose
This process enables you to create payments for employees who have been booked on a leave absence that is paid in advance.

Process Flow
To create advance payments, the advance payment program:

- Simulates a payroll run to retrieve the payroll results for the period in which the leave occurs
- Creates an advance payment cluster that contains the payroll results for the period in which the leave occurs and is paid in the period specified by the user
- Locks the absence so that the amount cannot be paid to the employee again
- Produces an advance payment report with details of the advance payment

Result
The SAP System retrieves the payroll results for the specified period from the advance pay cluster. This includes the wage types configured to be paid in advance. The employee receives the future earnings and deductions in the specified period.

When the payroll period that has been paid in advance is reached, the SAP System again retrieves the payroll results from the advance pay cluster. The wage types configured to be paid in advance are included, but this time with the reverse details. These reverse wage types result in a zero net payment to the employee.

If any adjustments occur to the employee’s details while the employee is on leave (for example, a pay increase), the employee receives the difference between the original pay and the new pay in the period in which the change occurred. Any difference in taxable gross is taxed at the employee’s marginal rate as if the employee receives the full pay this period.

See also:
Advance Payment Reporting [Seite 734]
Creating Advance Payments [Seite 377]
Changing Advance Payments [Seite 378]
Deleting Advance Payments [Seite 379]
Executing the Advance Payment Program [Seite 735]
Advance Payment Posting to Accounting [Seite 382]
Advance Payment Reporting

Use

When you create an advance payment, a report is produced detailing the payments that are to be made to the employee. The report shows all the payments to the employee, period by period.

Prerequisites

You must maintain the Absences infotype (2001) in HR master data. In addition, you must define the start and end dates, the date when the advance payment is to be paid, and you must run the advance payment program.

Features

The last page of the report shows the net amount to be paid to the employee and the period in which it is to be paid. The standard system also enables you to print the report.

Advance payment information is also provided in the Employee Pay Details report after payroll has been run for your employees.

See also:

Executing the Advance Payment Program [Seite 735]
Creating Advance Payments [Seite 377]
Changing Advance Payments [Seite 378]
Deleting Advance Payments [Seite 379]
Advance Payment Posting to Accounting [Seite 382]
Creating Advance Payments

Procedure

1. Choose Human Resources → Personnel management → Administration → Maintain master data.

   The HR Master Data screen appears.

2. Enter the personnel number.

3. In the Absences infotype, enter the relevant subtype.

4. Enter your absence details.

5. Save your entries.

6. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Other activities → Advance payments → Create advance payment.

   The Create Advance Payments for Australia screen appears.

7. Enter the personnel number for the advance payment, or a group of numbers.

8. In the date fields, enter the start and end dates of the leave, or if the leave is in the period after the current payroll period, leave the fields blank.

9. Enter the date on which the advance payment is to be paid. If it is the current payroll period, leave the field blank.

10. If you only want to make an inquiry, deselect the Advance Payment field indicator.

11. Execute the program.

   If you set the Advance Payment field indicator, the SAP System creates an advance pay cluster specifying the period’s payroll results.

See also:

Example: Creating an Advance Payment [Seite 381]
Changing Advance Payments

Use
If you change an absence before the payroll period in which it is to be paid, you must delete the advance payment cluster manually and create a new cluster by running the advance payment program. If you do not delete the old advance payment cluster and create a new cluster, payroll performs the adjustment.

Procedure
1. Choose Human Resources → Personnel management → Administration → Maintain master data.
   The Maintain HR Master Data screen appears.
2. In the Personnel number field, enter the personnel number.
3. In the Absences infotype (2001), enter the subtype that the advance leave was entered against, and enter the dates of the leave period.
4. Choose Change.
5. Change the details of the leave period.
6. Save your changes.
7. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Other activities → Advance payments → Delete advance payment.
8. Enter the required data.
9. Execute the program.
10. Execute the advance payment program.

See also:
Executing the Advance Payment Program [Seite 735]
Deleting Advance Payments

Procedure

11. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Other activities → Advance payments → Delete advance payment.

12. Enter the required data.

13. Choose Program → Execute.
Executing the Advance Payment Program

Use
The advance payment program can be run in simulation mode by deselecting the Advance payment field indicator. The program displays an advance payment report.

Prerequisites
You must first maintain the Absences infotype (2001) in HR master data.

Procedure
1. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Other activities → Advance payments → Create advance payment.
   The Create Advance Payment for Australia screen appears.
2. In the Personnel number field, enter the relevant personnel number(s).
3. In the Start of leave and End of leave fields, enter the relevant dates, or leave both fields blank to default to the start and end dates of the next payroll period.
4. In the Date to pay field, enter the relevant date, or leave the field blank to default to the current period.
5. Execute the program.

The advance payment program does not allow the advance payment of leave if the employee is transferred during the payroll periods that are paid in advance.

See also:
Creating Advance Payments [Seite 377]
Example: Creating an Advance Payment

Scenario
Your employee John Smith, who is paid bi-weekly, is going on leave for four weeks. John would like his leave pay before he goes on leave. His leave starts before the payday of period 04 so he would like his pay in period 03.

Period 03 (07/01/1998), Period 04 (07/15/1998)
Leave period 07/17/1998 – 08/14/1998

Procedure
1. Choose Human Resources → Personnel management → Administration → Maintain master data.
   The HR Master Data screen appears.
2. In the Personnel number field, enter John Smith's personnel number.
3. In the Absences infotype (2001), enter a relevant subtype.
4. In the Start and End date fields, enter 17/07/1998 to 14/08/1998
   Choose Enter and the number of days is updated.
5. Save your entries.
6. Choose Human Resources → Payroll → Subsequent activities → Per payroll period → Other activities → Advance payments → Create advance payment.
   The selection screen for Advance Payments appears.
7. In the Personnel number field, enter John Smith’s personnel number.
8. In the Start date field, enter 01/07/1998 and in the End date field, enter 14/07/1998
9. In the Date to pay leave field, enter 01/07/1998
10. If you only want to make an inquiry, deselect the Advance payment field indicator.
11. Execute the Advance Payment Program [Seite 735].

Result
Advance pay clusters with the payroll results for period 04 and period 05 are created. These results are included and paid in period 03.
Advance Payment Posting to Accounting

Purpose
This describes how advance payments are processed in the event of a change in an employee’s organisational assignment, time or pay data after an advance payment has been made.

Prerequisites
You paid an advance payment, and the employee’s organisational, time or pay data has since changed.

Process Flow
The SAP System posts advance payments to the cost center the employee is assigned to in the period the advance is paid. This occurs regardless of future organisational changes, future time or pay data with different cost allocations, or future splits in the Cost Distribution infotype (0027).

To correct cost assignment data in the payroll period for which the advance was paid, you perform a retroactive payroll run to the period in which the advance was originally paid.

Result
The retroactive payroll run assigns all payments to the correct cost center.
Terminations/Redundancies

If you process leave using SAP HR Personnel Time Management, refer to:

Terminations/Redundancies with Leave Quotas [Seite 384]

If you are an upgrade customer and have not yet converted to processing leave using SAP HR Personnel Time Management, refer to:

Terminations/Redundancies with Leave Accruals [Seite 429]
Terminations/Redundancies with Leave Quotas

Purpose

The Terminations/Redundancies component offers an efficient and comprehensive method of processing terminations and termination payments in line with Australian business practices. It calculates the appropriate tax on these payments and, if necessary, calculates special tax according to Australian Taxation Office (ATO) requirements.

Implementation Considerations

You implement the Terminations/Redundancies component in conjunction with the SAP HR Payroll Australia component.

Integration

The Terminations/Redundancies program gathers data from all payroll infotypes, delimits the Recurring Payments/Deductions (0014) infotype, and creates records in the Additional Payments (0015), Quota Corrections (2013), and the Time Quota Compensation (0416) infotypes. In the Actions infotype (0000), it delimits the hiring action, creates a termination action and creates a lieu of notice action, if the employee has a lieu of notice period.

In addition, it triggers the payroll driver in simulation mode to calculate the employee’s final pay from the last payroll period to the termination date.

Features

The component enables you to:

- Process employee resignations
- Process bona fide redundancies and approved early retirement scheme payments
- Process bulk terminations
- Project termination payments into the future
- Effect superannuation payments for company-managed funds
- Perform retroactive terminations
- Reinstate terminated employees
- Calculate leave up to the termination date including:
  - Leave entitlements and accruals
  - Leave balances owing at the termination date
  - Annual leave payments
  - Long-service leave payments
  - Leave loading payments
- Calculate all additional payments including:
  - The employee’s pay from the last payroll period to the termination date
Terminations/Redundancies with Leave Quotas

- Severance pay based on the years of continuous service
- In lieu of notice payments
- ETP rollover payments

- Calculate tax on termination payments:
  - Termination and redundancy tax that includes the age reduction factor
  - Tax on ETP payments
  - Tax on lump sum A, B and D payments

- Issue termination reports:
  - Check report to verify figures prior to proceeding with a termination
  - ETP rollover statements
  - ETP group certificates
  - Standard group certificates

Constraints

The ETP pre-payment statement provided to the employee prior to actual termination is not created automatically. The form must be completed manually by the employer. The same applies to the Employment Separation Certificate, Statement of Reasonable Benefits Limit form and the notification to Centrelink when terminating in excess of 15 employees (section 1/170DD of the Industrial Relations Act 1993).
Technical Process of Terminations/Redundancies

Purpose

The Terminations/Redundancies program calculates termination payments and updates numerous infotypes and tables in the background automatically. It also allows you to define how termination payments are calculated.

This document provides an overview of the processes the Terminations/Redundancies program performs in the background and the functions you must maintain to ensure that termination payments are calculated in line with your company's needs and those of each employee.

Prerequisites

Before processing terminations and redundancies, project teams should perform the following system configurations in the order specified:

1. Define your termination and redundancy actions and reasons. To do this, choose SAP Reference IMG → Personnel Management → Personnel Administration → Customize Procedures → Actions → Set Up Personnel Actions [Extern], and then Create Reasons for Personnel Actions [Extern].

2. Configure the Quota Compensation section of Customizing for Personnel Time Management, and in particular the quota compensation types and subtypes used in the Quota Compensation infotype (0416).
   
   To do this, choose SAP Reference IMG → Personnel Time Management → Time Data Recording and Administration → Managing Time Accounts Using Attendance/Absence Quotas → Processing Absence Quotas in Payroll → Time Quota Compensation → Define Time Quota Compensation Methods [Extern], and then Assign Wage Types to the Quotas to be Compensated [Extern].

3. Check that the correct leave method has been set up. To do this, choose SAP Reference IMG → Payroll → Payroll: Australia → Leave Provisions and Payments → Set Up Leave Method [Extern].

4. Configure termination and redundancy processing. To do this, choose SAP Reference IMG → Payroll → Payroll: Australia → Terminations/Redundancies [Extern].

In addition, you must ensure that there is an entry for each quota to be paid in the Absence Quotas infotype (0206).

Process Flow

1. You call the Terminations/Redundancies program (transaction PQRD), enter the personnel numbers of the employees to be terminated, and define whether the termination payments are to be made by cheque and whether group certificates are to be issued.
If you set the Cheque Payment field indicator, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you issue the cheque manually. The SAP System does not issue cheques.

To issue a group certificate at a later date instead of at the termination date, you leave the Print Group Certificates field blank, and run the Group Certificates program at the relevant time.

2. If an employee has a notice period, the program calculates how many weeks notice to give to the employee based on the termination date and the notice weeks set up in the Terminations Redundancy Payments view (V_T5QRS). At the same time, the program reads the initial data (for example, employee details, leave quotas) for each employee and lists the employees to be terminated on the Terminations Australia screen. You then verify the termination data stored on the Employee Details screen for each employee.

3. You call the Recurring Payments function for each employee. The program displays the wage types stored in the Recurring Payments / Deductions infotype (0014). You flag the wage types that are not to be included in the termination payment. The program includes all other recurring payments and deductions in the employee’s final pay. The recurring payments and deductions do not appear on the Employee Details screen.

4. You check the Lieu of Notice function and, if necessary, run the Calculate Notice function. The program reads the Terminations Redundancy Payments view and calculates a payment in lieu of notice based on whether the wage type for in lieu of notice is in the view for the applicable award and termination reason.

5. The payment in lieu of notice appears in the Additional Payments table. If the employee is not entitled to a payment in lieu of notice, a system message appears stating the reason. You can either accept the message or recalculate the payment by selecting the Calculate Notice function again.

6. If an employee is entitled to long-service leave (LSL), you enter the LSL formula in the ATO LSL Formula function. The program calculates the pre/post 1978 split based on the data you enter, and outputs the split to the Additional Payments table.

You do not have to perform this step if the employee’s LSL has been broken down into three separate leave quotas relating to service before August 16 1978, service after August 16 1978 and service after August 17 1993, and if these leave quotas have been linked to a corresponding wage type.

7. You run the Calculate Pay function. This triggers a simulated payroll run in which the program calculates:
Technical Process of Terminations/Redundancies

a. Leave loading

The program reads the Rules for Quota Payment on Termination view (V_T5QTR) and, depending on the configuration, calculates leave loading on either entitlement, accrual, both or neither. If the leave quota is configured so that accrual is not paid if the entitlement value is less than or equal to zero, then the accrual value is not included in the termination payment.

The leave on termination hours are displayed in the Employee Details screen, but the leave amount is displayed in the termination report issued at the end of the terminations/redundancies process.

b. Redundancy packaging (the tax-free component of lump sum D)

Calculations are based on the redundancy reason, the award, the number of years of service and the wage types the company pays out for bona fide redundancies. The program reads the wage types in the Redundancy Packages view (V_T5QRP).

Lump sum D has a threshold that is based on the number of years of service. The program applies lump sum C to remaining balances that exceed the lump sum D threshold.

c. Severance pay

The program calculates severance pay based on the redundancy reason and the configuration of severance pay wage types in the Terminations Redundancy Payments view (V_T5QRS). If you have not configured severance pay wage types, the severance pay amount can be entered as an additional payment in the Employee Details screen.

Wage types entered previously in the Additional Payments infotype (0015) do not appear on the Employee Details screen.

8. If the calculation includes eligible termination payment (ETP) wage types, the ETP Rollover Distribution screen appears, in which you can specify whether the ETP is paid out in part, in full or is rolled over into an approved rollover fund. If it is paid out, the ETP is taxed at the appropriate rate. If it is rolled over into several funds, you can enter up to eight funds and
distribute the ETP by amount or percentage. Once you have entered the ETP details, the program generates lump sum C non-taxable wage types for employees who roll over all or part of their ETP.

The non-taxable portion of the ETP (lump sum D) cannot be rolled over.

9. The program generates and displays a termination report based on the data you entered.

10. To complete the termination for one employee, you execute the Update function in the Termination Report screen. To complete the termination for several employees, you return to the Terminations Australia screen and execute the Update function in batch mode to terminate several employees at once.

11. The termination report is transferred to the spooler and stored in a spool request.

12. The final payroll run for the employee processes the final termination payment. Note that some terminations payments are taxed marginally using the average gross (wage type /109) and average tax (wage type /410) including any off-cycle payroll results.

The payroll driver delimits the cheque payment wage type. As a result, you must issue the cheque manually, based on the termination payment data displayed in the Terminations report.

**Result**

If the Terminations/Redundancies program generates ETPs and group certificates, you can print standard group certificates, ETP group certificates, the terminations report and, if necessary, ETP rollover statements from the spooler. The spool requests remain in the spooler after printing to enable you to print them again, if necessary.

You cannot retrieve reports after they have been deleted from the spooler. If you inadvertently delete a spool request, the only way to view the report or certificate is to re-run the Terminations/Redundancies program.

If the employee’s gross termination payment exceeds $5,000 and is not rolled over, a message reminding you to complete the Statement of Reasonable Benefits Limit form for the ATO is written to the employee’s termination report. The program does not complete this form automatically.

In addition, the program delimits the Recurring Payments/Deductions (0014) infotype and creates records in the Additional Payments infotype (0015) as well as in the Quota Corrections (2013) and the Time Quota Compensation (0416) infotypes to compensate leave quotas.
Technical Process of Terminations/Redundancies

In the Actions infotype (0000), the program delimits the hiring action, creates a termination action and creates a lieu of notice action, if the employee has a lieu of notice period. If a group certificate has been issued, the program also updates the Tax Australia infotype (0188).

The Update function additionally triggers time evaluation (program RPTIME00) up to the employee’s termination date.

See also:
- Time Evaluation [Extern]
- Quota Corrections Infotype (2013) [Extern]
- Absence Quotas Infotype (2006) [Extern]
- Time Quota Compensation Infotype (0416) [Seite 222]
Initial Setup of Terminations/Redundancies

Purpose
The Terminations/Redundancies program loads employee details and calculates the length of service for each employee in the background automatically by reading and updating the data stored in various features [Extern], tables and infotypes [Extern].

This process describes how the program loads employee details and calculates the length of service for each employee.

Prerequisite
Ensure that there is an entry for each quota to be paid in the Absence Quotas infotype (2006).

Process Flow
1. You enter the employee(s) to be terminated, the termination date, the termination reason and whether the payment is to be made by cheque and printed on a group certificate.

2. The SAP System reads the employee details stored in various infotypes as well as the Recurring Payments/Deductions (0014), the Additional Payments (0015) and the Absence Quotas (2006) infotypes. It also reads the quota accruals from the time evaluation cluster.

3. It locks the employee number so that you can only change employee data through the Terminations/Redundancies program.

4. It calculates the length of service from the employee’s hiring date to his or her termination date.

5. If the ETP Parameters feature (the step Set Up ETP Parameters [Extern] in Customizing for Payroll Australia) is configured to include the Other/Previous Employers infotype (0023) in length of service calculations, the program processes all the records stored in infotype 0023 for all the employees whose attributes match the areas and groupings set up in the feature. Each infotype record with an end date that is less than or equal to the employee’s hiring date is included in the length of service calculation.

   To ensure that the program only includes records that relate to previous employment within your company, you must not create any records in infotype 0023 that relate to previous employment with other companies. To exclude previous employment details from length of service calculations for an individual employee, you must not maintain any records in infotype 0023 for that employee.

6. If the step ETP Parameters feature is configured to include the notice period, the program calculates the length of service from the hiring date to the notice date.

7. The program calculates the number of continuous service days since hiring by subtracting the employee’s hiring date from the termination date and adding any days from the Other/Previous Employers infotype.
Initial Setup of Terminations/Redundancies

The number of days used by the Terminations/Redundancies program to calculate the length of service is displayed on the ETP group certificate and the ETP rollover statement. If the program has included infotype 0023 records that you do not want it to include in length of service calculations for a particular employee (for example, records of previous employment with a company other than your own), you must reinstate the employee, delete the relevant record(s) in infotype 0023 and then re-run the program.

8. The SAP System reads the absence records stored in the Absences infotype (2001). To determine if any of the absence records hold leave without pay (LWOP) absence types, the program reads the Redundancies LWOP Absences view (V_T5QRA). It then subtracts the number of unpaid absence days from the number of continuous service days calculated earlier.

Result

The Employee Details screen displays the employee details, leave quota entitlements, accruals and additional payments.

See also:

Setting up Terminations/Redundancies [Seite 393]
Determining the Payment Method [Seite 440]
Producing Group Certificates on Termination [Seite 738]
Setting up Terminations/Redundancies with Leave Quotas

Prerequisites

If you configure the ETP Parameters feature [Extern] (the step Set Up ETP Parameters [Extern] in Customizing for Payroll Australia) to include the Other/Previous Employers infotype (0023) in length of service calculations, the Terminations/Redundancies program processes all the records stored in infotype 0023 for all the employees whose attributes match the areas and groupings set up in the feature.

To ensure that the program only includes records that relate to previous employment within your company, you must not create any records in infotype 0023 that relate to previous employment with other companies. To exclude previous employment details from length of service calculations for an individual employee, you must not maintain any records in infotype 0023 for that employee.

The number of days used by the Terminations/Redundancies program to calculate the length of service is displayed on the ETP group certificate and the ETP rollover statement. If the program has included infotype 0023 records that you do not want it to include in length of service calculations for a particular employee (for example, records of previous employment with a company other than your own), you must reinstate the employee, delete the relevant record(s) in infotype 0023 and then re-run the program.

Procedure

1. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.
   The Terminations Australia screen appears.
2. To terminate one employee, enter the personnel number in the Personnel number field.
   Or
   To terminate a range of employees according to their personnel areas, personnel subareas or cost centers, choose Preselect and enter the relevant data.
3. Enter the termination date and the termination reason key.
4. To issue a cheque payment, select the Cheque Payment field.
Setting up Terminations/Redundancies with Leave Quotas

If you select the *Cheque Payment* field, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you must issue a cheque manually. The SAP System does not issue cheques.

If you do not select the *Cheque Payment* field, the *Bank Transfers* program must be executed to transfer the payment to the employee’s account after the payroll run.

5. To print a group certificate, select the *Print Group Certificate* field.

   To issue a group certificate at a later date instead of at the termination date, you must leave the *Print Group Certificates* field blank and run the *Group Certificates* program at the relevant time.

6. Select *Choose* from the toolbar.

   The *Terminations Australia* screen appears listing the employees to be terminated.

   If an error occurs while the SAP System is retrieving the employee details, an error message appears in the *System Messages* field. For details, see *Termination System Messages [Extern]*.

7. Select an employee’s name, and choose *Details*.

   The *Employee Details* screen appears.

   In the *Employee Details* screen, you can correct problems encountered by the system when reading the initial data, change the default termination values for all employees and add additional employees by overwriting the relevant data.
Result

The program displays the employee details based on the personal, leave quota and salary data stored in the system.

You can check and, if necessary, modify these details either by overwriting the data or by executing the *Recurring Payments*, *Lieu of Notice* and *ATO LSL Formula* functions in the *Employee Details* screen.

See also:

- Terminations/Redundancies with Leave Quotas [Seite 384]
- Initial Setup of Terminations / Redundancies [Seite 391]
- The Recurring Payments Function [Seite 443]
- The Lieu of Notice Function [Seite 445]
- The ATO LSL Formula Function [Seite 405]
- Leave Payments on Termination [Seite 410]
Determining the Payment Method

Use

You can effect termination payments either by bank transfer or by cheque. If paying by bank transfer, the payment is not transferred until the payroll run after the termination date actually takes place.

If you choose to pay by cheque, the program creates a cheque payment wage type specifying the total termination payment and stores the wage type in the Additional Payments infotype (0015). The wage type appears in the Terminations report, but is excluded from the employee’s final payroll run. You must prepare the cheque manually, based on the amount specified in the Terminations report.

Procedure

7. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

The Terminations Australia screen appears.

8. Enter the employee’s personnel number, the termination date, and the termination reason.

9. To pay by cheque, select the Cheque Payment field.

   Or

   To pay by bank transfer, leave the Cheque Payment field blank.

10. To issue a group certificate immediately, select the Print Group Certificate field.

    Or

    To issue a group certificate at a later date, leave the Print Group Certificate field blank.

    To issue a group certificate at a later date, you must run the Group Certificates program at the relevant time.

11. Select Choose from the toolbar.

    The Terminations Australia screen appears.

See also:
Initial Setup of Terminations / Redundancies [Seite 391]
Producing Group Certificates on Termination

Use
You can determine whether you want a group certificate to be issued immediately from within the Terminations/Redundancies program or whether you want a group certificate to be issued at a later date, for example, at the end of the financial year.

If you choose to print the group certificate immediately, you must update your terminations and then issue the certificate from the spool request created by the Terminations/Redundancies program. If you choose to print the group certificate at a later date, you must run the Group Certificates program at the relevant time.

Prerequisite
You must set up the destination printer for the group certificate.

Procedure
12. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/Redundancies.

The Terminations Australia screen appears.

13. Enter the employee’s personnel number, the termination date, and the termination reason.

14. To pay by cheque, select the Cheque Payment field.

Or

To pay by bank transfer, leave the Cheque Payment field blank.

If you select the Cheque Payment field, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you must issue a cheque manually. The SAP System does not issue cheques.

15. To issue a group certificate immediately, select the Print Group Certificate field.

Or

To issue a group certificate at a later date, leave the Print Group Certificate field blank.
Producing Group Certificates on Termination

These fields are default fields only. You can change the date, reason, payment method and group certificate printing option in the Employee Details screen for each employee.

16. Select Choose from the toolbar.

The Terminations Australia screen appears.

See also:

Initial Setup of Terminations / Redundancies [Seite 391]
Printing Group Certificates and Reports [Seite 740]

For more information on printing group certificates using the Group Certificates program, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia → End-of-Year Processing → Group Certificates [Seite 744].
The Recurring Payments Function

**Use**

The *Terminations/Redundancies* program includes all recurring payments and deductions in an employee’s final termination payment automatically. If you want to exclude a recurring payment or deduction from termination payment calculations, you must maintain the *Recurring Payments* function.

**Integration**

The function reads and retrieves wage type data stored in the *Recurring Payments/Deductions* infotype (0014).

The recurring payments and deductions are not displayed on the *Employee Details* screen. The program calculates the payments/deductions in the background.

**Prerequisites**

This function only operates if an employee has wage types in the *Recurring Payments/Deductions* infotype.

**Features**

The function lists the wage types stored in the *Recurring Payments/Deductions* infotype and allows you to exclude the wage types from an employee’s termination payment.

**See also:**

*Suppressing Recurring Payments* [Seite 444]
Suppressing Recurring Payments

Prerequisites

You use this function only if the employee has wage types in the Recurring Payments/Deductions infotype (0014).

Procedure

17. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

18. Enter the employee’s personnel number, the termination date and the termination reason.

19. If necessary, select the payment method and group certificate options.

20. Select Choose from the toolbar.

   The Terminations Australia screen appears.

21. Select an employee’s name, and choose Details.

   The Employee Details screen appears.

22. Choose Recurring Payments.

   The Suppress Recurring Payments screen appears.

23. To exclude recurring payments and deductions from an employee’s termination payment, select the Suppress in Final Pay field for the relevant wage type.

   If you do not select the Suppress in Final Pay field, the program includes the wage type in the employee’s termination payment.

24. Return to the Employee Details screen.

Result

The recurring payments and deductions do not appear on the Employee Details screen. The program calculates the payments/deductions in the background automatically and displays the results in the Terminations report.

See also:

The Recurring Payments Function [Seite 443]
The Lieu of Notice Function

Use
When an employee resigns or is terminated, an employer can opt to provide payment in lieu of notice. This means that the required period of notice is paid out by the employer. The rate of pay is the employee’s current ordinary rate of pay, including any additional payments or deductions defined by the employer.

If an employee has a notice period and the employer chooses to provide payment in lieu of notice, the Lieu of Notice function calculates the payment and adds it as an additional payment to the employee’s termination payment.

Integration
To calculate payments in lieu of notice, the Terminations/Redundancies program reads the Terminations Redundancy Payments view (V_T5QRS) and retrieves any in lieu of notice wage types for the employee’s award and termination reason. If there are no wage types, the program does not calculate any payments in lieu of notice. If the view holds wage types, the payroll driver calculates the lieu of notice amount in simulation mode.

Prerequisites
Before processing payments in lieu of notice, you must:

- Create a lieu of notice action and reason under SAP Reference IMG → Personnel Management → Personnel Administration → Customize Procedures → Actions → Set Up Personnel Actions [Extern] and Create Reasons for Personnel Actions [Extern].
- Enter the in lieu of notice action in Customizing for Payroll Australia under Terminations/Redundancies → Set Up ETP Parameters [Extern].
- Configure the Terminations/Redundancies section of Customizing for Payroll Australia, and in particular the steps:
  - Define Termination/Redundancy Reasons [Extern]
  - Create Redundancy Models [Extern]
  - Assign Termination Wage Types to Wage Type Group [Extern]
  - Set Up Redundancy Wage Type Categories [Extern]
  - Set Up Severance and In Lieu Payments [Extern]

Features
1. The Terminations/Redundancies program enters a default notice date based on the number of weeks set up in the Terminations Redundancy Payments view.
2. You can either leave or overwrite the default notice date. For example:
   a. In the case of employees who are entitled to a notice period and are dismissed with immediate effect, you can overwrite the default notice date if the number of weeks set up in the Terminations Redundancy Payments view is incorrect.
   b. In the case of employees who work up to their notice date (for example, they give four weeks notice and work the full four weeks), you can overwrite the default notice date to
The Lieu of Notice Function

reflect the termination date. This prevents the program from calculating a payment in lieu of notice.

c. In the case of employees who are dismissed and work some of their notice period, you can overwrite the default notice date to reflect the weeks that the employee is entitled to payment in lieu of notice.

3. Once the notice date has been established, the Lieu of Notice function displays any wage types stored in the Recurring Payments/Deductions infotype (0014) for the employee. To include a wage type in the payment in lieu of notice calculation, you set the Include field indicator.

4. The Calculate Notice function determines the payment for the notice period. The dollar amount is entered against the wage type set up in the Terminations Redundancy Payments view and is displayed as an additional payment in the Employee Details screen.

5. If the lieu of notice date differs from the termination date, the program enters a lieu of notice action in the Actions infotype (0000).

See also:
Calculating Payments in Lieu of Notice [Seite 447]
Calculating Payments in Lieu of Notice

25. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

26. Enter the employee’s personnel number, the termination date and the termination reason.

27. If necessary, select the payment method and group certificate options.

28. Select Choose from the toolbar.

   The Terminations Australia screen appears.

29. Select an employee’s name, and choose Details.

   The Employee Details screen appears.

30. If necessary, overwrite the default notice date to reflect the number of weeks for which the employee is entitled to a payment in lieu of notice.

31. Choose Lieu of Notice.

   The Calculate Lieu of Notice screen appears.

32. To include recurring payments and deductions in an employee’s payment in lieu of notice, select the Include field for the relevant wage type.

   Do not confuse this field with the Suppress in Final Pay field in the Recurring Payments function [Seite 443]. The two fields serve opposite purposes.

9. Choose Calculate Notice.

Result

The payroll driver calculates the payment. The wage type and total amount appear as an additional payment on the Employee Details screen.

If required, you can overwrite the wage type and the amount displayed on the Employee Details screen.

If the lieu of notice date differs from the termination date, the program enters a lieu of notice action in the Actions infotype (0000) when you update the termination.
Calculating Payments in Lieu of Notice

See also:
The Lieu of Notice Function [Seite 445]
The ATO LSL Formula Function

Use
An employee’s long-service leave (LSL) payments may need to be broken down into three parts:

- **An amount relating to service before August 16 1978**
  5% of the payment for unused LSL is included in the employee’s taxable income (lump sum B)

- **An amount relating to service from August 16 1978**
  All of the payment for unused LSL is included in the employee’s taxable income (lump sum A). The employee receives a tax rebate if his or her marginal tax rate is higher than 30 cents in the dollar.

- **An amount relating to service after August 17 1993**
  All of the payment for unused LSL is included in the employee’s taxable income and taxed at normal marginal rates (lump sum A).

The standard system offers two methods of dividing an employee’s LSL payments into these parts:

1. By using a formula that is defined in income tax law. The formula is based on the period of service over which the employee’s LSL entitlement has accrued and takes into account leave already taken.

This function describes how to calculate LSL payments using the ATO LSL Formula function. For information on how to calculate the payments using separate leave quotas, see Calculating LSL Payments Without a Formula [Seite 409].

Integration
To process LSL payments, the ATO LSL Formula function reads the ATO LSL Formula Wage Type view, in which you can nominate the wage types used to pay the pre and post August 16 1978 and the post August 17 1993 parts of LSL. The data you enter in the ATO LSL Formula function is used to create the payments.

Prerequisites
You must configure the Terminations/Redundancies section of Customizing for Payroll Australia, and in particular the steps Set Up Redundancy Rules for Paying Leave Quotas [Extern] and Set Up ATO LSL Formula [Extern].

Features
You enter the employee’s used/unused leave days in the ATO LSL Formula screen. To find the relevant information for each employee, you can run the Quota Overview transaction (PT50), which reads the relevant infotypes and time evaluation data.

The ATO LSL Formula function calculates the LSL payment for the employee. The Terminations/Redundancies program splits the payment into lump sums A and B, that is, pre and...
The ATO LSL Formula Function

post August 16 1978 and post August 17 1993 parts, calculates the appropriate tax on each lump sum and the total LSL payment. The results are listed in the Terminations report.

If you elect to use the ATO LSL formula to calculate LSL components, the program uses the formula entered in the ATO LSL Formula function. Otherwise, it uses the variables defined in the Rules for Quota Payment on Termination view (V_T5QTR) to calculate the components.

See also:

Calculating LSL Payments with a Formula [Seite 407]
Calculating LSL Payments Without a Formula [Seite 409]
Calculating LSL Payments with a Formula

Use

You do not have to perform this procedure if the employee’s long-service leave (LSL) has been broken down into three separate leave quotas relating to service before August 16 1978, service after August 16 1978 and service after August 17 1993, and if these leave quotas have been linked to a corresponding wage type.

Procedure

33. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

34. Enter the employee’s personnel number, the termination date and the termination reason.

35. If necessary, select the payment method and group certificate options.

36. Select Choose from the toolbar.

   The Terminations Australia screen appears.

37. Select an employee’s name, and choose Details.

   The Employee Details screen appears.

38. Choose ATO LSL Formula.

   The ATO LSL Formula Components screen appears.

39. Enter the values used to calculate LSL payments.

   To find the relevant leave data, you can run the Quota Overview transaction (PT50) for each employee. The transaction provides all the details required for the ATO LSL formula by allowing you to project the employee’s leave to the termination date, and reading all the relevant infotypes and time evaluation results.

40. Choose Execute.

Result

The program calculates the LSL payment and splits the payment into pre/post 1978 and post 1993 parts. The resulting amounts are displayed as additional payment wage types in the Employee Details screen and are later included in the termination payment calculation.

See also:

The ATO LSL Formula Function [Seite 405]
Calculating LSL Payments with a Formula

Calculating LSL Payments Without a Formula [Seite 409]
Calculating LSL Payments Without a Formula

Use
This procedure describes how to calculate long-service leave (LSL) payments without using the ATO LSL Formula function.

Prerequisites
You can only use this procedure if the employee’s LSL has been broken down into three separate leave quotas relating to service before August 16 1978, service after August 16 1978 and service after August 17 1993, and if these leave quotas have been linked to a corresponding wage type.

Procedure
41. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.
42. Enter the employee’s personnel number, the termination date and the termination reason.
43. If necessary, select the payment method and group certificate options.
44. Select Choose from the toolbar.

   The Terminations Australia screen appears.
45. Select an employee’s name, and choose Details.

   The Employee Details screen appears.
6.   Check the leave quotas displayed in the Projected leave table.

Result
The Terminations/Redundancies program calculates the LSL payments based on the leave quotas displayed in the Projected leave table. You do not have to run the ATO LSL Formula function.

See also:
The ATO LSL Formula Function [Seite 405]
Calculating LSL Payments with a Formula [Seite 407]
Leave Payments on Termination

Use

The Terminations/Redundancies program calculates the amount of leave the employee has remaining and displays the data on the Employee Details screen. The leave data is made up of the leave quota, the expected leave entitlement hours at the termination date and the expected accrual hours at the termination date.

You cannot delete or change the entries displayed in the Projected Leave table on the Employee Details screen.

Integration

To determine whether the termination payment should include annual leave, leave loading and long-service leave (LSL), the program checks each leave quota against the data stored in the Rules for Quota Payment on Termination view (V_T5QTR) to verify if it is valid to be paid out for the award and termination reason.

The view also determines whether:

- Leave entitlement and/or accrual or neither is paid out
- Leave loading is applicable to entitlement and/or accrual or neither
- Accrual is to be paid out when the entitlement value is less than or equal to zero

The view indicates if LSL is to be paid out based on whether the employee’s continuous years of service exceed the minimum years required.

Prerequisites

You must have configured the Terminations/Redundancies section of Customizing for Payroll Australia, and in particular the step Set Up Redundancy Rules for Paying Leave Quotas [Extern].

Features

The Terminations/Redundancies program lists the leave quotas to be included in the termination payment calculation and projects the leave balances.

The leave on termination hours are displayed on the Employee Details screen, but the leave amount is displayed in the Terminations report issued at the end of the termination payment calculation.

See also:

Projecting Leave Balances [Seite 411]
Projecting Leave Balances

Prerequisite
The leave quota must be configured as payable for the termination reason.

Procedure
46. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

47. Enter the employee’s personnel number, the termination date and the termination reason.

48. If necessary, select the payment method and group certificate options.

49. Select Choose from the toolbar.

   The Terminations Australia screen appears.

50. Select an employee’s name, and choose Details.

   The Employee Details screen appears.

51. To project leave accruals and/or entitlements, enter the relevant date in the Notice Date field or the Termination Date field

Result
The program displays the leave quota, text, entitlement and accrual hours in the Projected leave table. If the leave data is set up in the SAP System, the program projects the relevant leave accruals and entitlements to the notice date or the termination date.

The amount projected is not always the total amount that is paid out. For example, if accrual is not to be paid, the SAP System displays 0 in the Projected leave table.

See also:
Leave Payments on Termination [Seite 410]
Entering Additional Payments

Use

The Terminations/Redundancies program processes the wage types stored in the Additional Payments infotype (0015) as well as any wage types set up for redundancy packaging. You can also enter additional payments in the Additional payments table either by entering the relevant wage type or by overwriting the amount or value of a particular wage type listed in the table.

Wage types stored in the Additional Payments infotype do not appear on the Employee Details screen.

Procedure

52. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

The Terminations Australia screen appears.

53. Enter the employee’s personnel number, the termination date and the termination reason.

54. If necessary, set the payment method and group certificate option indicators.

55. Select Choose from the toolbar.

The Terminations Australia screen appears.

56. Select an employee’s name, and choose Details.

The Employee Details screen appears.

6. In the Additional payments table, create additional payments by entering the wage type and dollar amount, unit of measurement value or both depending on the wage type.

If you enter a wage type that is already in the Additional payments table, the value or number of both payments combine to become one payment.

Result

The Terminations/Redundancies program includes all the wage types in the termination payment calculation.
Distributing the ETP Rollover

Use

If an employee receives an eligible termination payment (ETP) as part of his or her redundancy package, you can specify whether the ETP is paid out in part, in full or is rolled over into an approved rollover fund. If it is paid out, the ETP is taxed at the appropriate rate. If it is rolled over into several funds, you can enter up to eight funds and distribute the ETP by amount or percentage.

Prerequisites

You must have completed the procedure described in Setting up Terminations/Redundancies [Seite 393], and the program has loaded all the initial employee data into the Employee Details screen.

Procedure

1. From the Employee Details screen, check the data displayed for each employee.
2. If necessary, overwrite the data to meet your requirements.
3. If necessary, maintain and execute the Recurring Payments function, the Lieu of Notice function and/or the ATO LSL Formula function.
4. If you have not configured a severance pay wage type and want to effect a severance payment to an employee, enter the amount in the Additional payments table.
5. Choose Calculate Pay.

The ETP Rollover Distribution screen appears.
6. If the screen displays an ETP for the employee, enter the ETP distribution by amount or percentage and the fund details.
7. Choose Continue.

Result

The program triggers the payroll driver in simulation mode and calculates the employee’s total termination payment including:

- Pay from the last payroll period to the termination date
- All additional payments
- If applicable, ETPs

The Terminations report appears, listing all the payments to be made to the employee in the event of termination of employment.
Distributing the ETP Rollover

To leave the Termination report, go Back. Do not choose the Update function unless you want to complete the termination.
Projecting Termination Payments

Use
The Terminations/Redundancies program allows you to forecast termination payments without actually terminating employees. It performs all calculations and system modifications in simulation mode and does not terminate employees until you specifically instruct it to complete the termination.

When projecting termination payments, do not choose the Update function as this will complete the termination and update all the infotypes and records associated with terminations for each employee.

If you inadvertently choose the Update function and thereby complete the termination, you can reverse the termination by choosing the Reinstate function in the Terminations Australia initial screen.

Prerequisites
You must have completed the procedure described in the document Setting up Terminations/Redundancies [Seite 393], and the Terminations/Redundancies program has loaded all the initial employee data into the Employee Details screen.

Procedure
8. From the Employee Details screen, check the data displayed for each employee.
9. If necessary, overwrite the data to meet your requirements.
10. If necessary, maintain and execute the Recurring Payments function, the Lieu of Notice function and/or the ATO LSL Formula function.
11. If you have not configured a severance pay wage type and want to effect a severance payment to an employee, enter the amount in the Additional payments table.
12. Choose Calculate Pay.
   The ETP Rollover Distribution screen appears.
13. If the screen displays an eligible termination payment (ETP) for the employee, enter the ETP distribution and the fund details.

Result
The program triggers the payroll driver in simulation mode and calculates the employee’s total termination payment including:

- Pay from the last payroll period to the termination date
Projecting Termination Payments

- All additional payments
- If applicable, ETPs

The *Terminations* report appears, listing all the payments to be made to the employee in the event of termination of employment.

To leave the *Termination* report, go *Back*. Do **not** choose the *Update* function unless you want to complete the termination.

**See also:**
- Setting up Terminations/Redundancies [Seite 393]
- Updating Single and Bulk Terminations [Seite 417]
- Distributing the ETP Rollover [Seite 413]
- Printing Group Certificates and Reports [Seite 740]
Updating Single and Bulk Terminations

Use

The Terminations/Redundancies program can terminate one to 50 employees. The procedure for terminating one employee differs from the procedure for terminating several employees at the same time.

This procedure will complete termination processing for your employees, that is, the relevant employees will no longer belong to your organisation.

To reverse a termination, choose the Reinstate function in the Terminations Australia initial screen.

Procedure

Updating Single Terminations

15. From the Employee Details screen, check the data displayed for the employee.
16. If necessary, overwrite the data to meet your requirements.
17. If necessary, maintain and execute the Recurring Payments function, the Lieu of Notice function and/or the ATO LSL Formula function.
18. If you have not configured a severance pay wage type and want to effect a severance payment to an employee, enter the amount in the Additional payments table.
   
   The ETP Rollover Distribution screen appears.
20. If the screen displays an eligible termination payment (ETP), enter the ETP distribution and the fund details.
21. Choose Continue.
   
   The Terminations report appears, listing the employee’s termination payment details.
22. To complete the termination, choose Update.

Updating Bulk Terminations

1. From the Employee Details screen, check the data displayed for each employee.
2. If necessary, overwrite the data to meet your requirements.
3. If necessary, maintain and execute the Recurring Payments function, the Lieu of Notice function and/or the ATO LSL Formula function.
Updating Single and Bulk Terminations

4. If you have not configured a severance pay wage type and want to effect a severance payment to an employee, enter the amount in the Additional Payments table.

5. Choose Calculate Pay.

   The ETP Rollover Distribution screen appears.

6. If the screen displays an eligible termination payment (ETP), enter the ETP distribution and the fund details.

7. Choose Continue.

   The Terminations report appears, listing each employee’s termination payment details.

8. To complete the termination, return to the Terminations Australia screen.

9. Choose Update.

   The program terminates all the employees simultaneously.

Result

The program updates all the relevant infotypes and tables so that the employee(s) effectively no longer belong to your organisation.

The Terminations report is transferred to the spooler, where you can print the report and, if required, print group certificates, ETP group certificates and ETP rollover statements for each employee.

If an employee’s gross termination payment exceeds $5,000 and is not rolled over, a message reminding you to complete the Statement of Reasonable Benefits Limit form for the ATO is written to the employee’s termination report.

The program does not complete this form automatically.

In addition, the program delimits the Recurring Payments/Deductions (0014) infotype and creates records in the Additional Payments infotype (0015) as well as in the Quota Corrections (2013) and the Time Quota Compensation (0416) infotypes to compensate leave quotas. In the Actions infotype (0000), it delimits the hiring action, creates a termination action and creates a lieu of notice action, if the employee has a lieu of notice period. If a group certificate has been issued, it also updates the Tax Australia infotype (0188). The Update function additionally triggers time evaluation (program RPTIME00) up to the employee(s) termination date.

See also:

Setting up Terminations/Redundancies [Seite 393]
Projecting Termination Payments [Seite 415]
Distributing the ETP Rollover [Seite 413]
Printing Group Certificates and Reports [Seite 740]
Reinstating Terminated Employees

Use

The Terminations/Redundancies program enables you to re-hire terminated employees. When you re-hire an employee, the Reinstate function re-activates and resets all the infotypes that were delimited during the termination process, except for the:

- **Tax Australia** infotype (0188)

  If you reinstate an employee after issuing a group certificate on termination, you must run the Reinstate function and manually reset the year in the Group certificate issued field of the Tax Australia infotype (0188) to reflect the year in which the group certificate was last issued.

  If you reinstate an employee before issuing a group certificate on termination, you simply run the Reinstate function in the Terminations/Redundancies program.

- **Quota Corrections** (2013) and **Time Quota Compensation** (0416) infotypes

  To reverse the compensated quotas, you must manually delete the relevant records in the infotypes, and re-run the Time Evaluation program (RPTIME00).

Procedure

8. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

9. Activate the Reinstate field.

10. To reinstate one employee, enter the personnel number in the Personnel number field.

    Or

    To reinstate a range of employees according to their personnel areas, personnel subareas or cost centers, choose Preselect and enter the relevant data.

4. Choose Enter.

Result

A message appears confirming that the employee has been reinstated.
Terminating in the Past

Use
You can terminate an employee in a past payroll period, but the termination date must not be before the employee’s hiring date, the payroll area’s earliest recalculation date or the employee’s earliest payroll date.

An employee has been absent for several weeks without notifying anyone in the company. You want to terminate the employee from the first day of his or her absence.

Procedure

57. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

The Terminations Australia screen appears.

58. Enter the employee’s personnel number and the termination reason.

59. Enter a termination date in the past.

60. If necessary, select the payment method and group certificate options.

61. Select Choose from the toolbar.

The Terminations Australia screen appears with a system message stating Retro Term.

62. Select the employee’s name, and choose Details.

The Employee Details screen appears.

63. If necessary, overwrite the notice date.

64. Choose Calculate Pay.

The Terminations report appears.

Result
The SAP System calculates the difference between the amount the employee has been paid after the termination date up to and including the employee’s last completed payroll period, and the amount the employee should have been paid.

If the termination payment is a negative amount, a claim is generated. This is the amount that you have overpaid the employee. Normally, a claim is recovered from future payroll runs, but the employee number is now terminated so there is no automatic recovery.

As a result, the claim either remains against the employee or you can write off the amount of the claim for reporting purposes. If you write off the amount, you configure a wage type for monies
lost on termination. If you recover the overpayment from the employee, you allocate it to a wage type for monies recovered.
Making Payments after Termination

Use

You may be required to make continuous or one-off payments to employees after they have been terminated, for example, workcover payments to employees permanently disabled due to an accident at work.

This procedure describes how you set up the SAP System to make continuous and one-off payments after termination.

Procedure

Making Continuous Payments after Termination

1. Activate and, if necessary, modify the Organizational Assignment (0001), Personal Data (0002), Planned Working Time (0007), Basic Pay (0008), Bank Details (0009) and the Tax Australia (0188) infotypes.

   These infotypes are delimited during the termination process.

2. To ensure that the payroll driver includes the terminated employees in the payroll run, configure the terminated employees into a separate employee subgroup.

3. Enter the continuous payment in either the Recurring Payments/Deductions infotype (0014) or the Additional Payments infotype (0015).

Making One-Off Payments after Termination

1. Change either the Basic Pay infotype (0008) or the Additional Payments (0015) infotype to reflect the one-off payment you want to make.

2. Perform a retroactive payroll run for the employee.

See also:

For information on how to perform retroactive payroll runs, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Payroll in the R/3 System → Basics of Payroll → Payroll Control Record → Retroactive Accounting.
Terminations/Redundancies Reporting

Use

The Terminations/Redundancies program enables you to issue the following reports and certificates:

- Termination report
- Standard group certificate
- ETP group certificate
- ETP rollover statement

Prerequisites

You must have configured the destination printer for the report.

You must have run the Terminations/Redundancies program and updated the terminations.

The Update function completes the termination and updates all the infotypes and records associated with terminations for each employee. Do not choose the Update function if you are only projecting termination payments.

If you inadvertently choose the Update function and thereby complete the termination, you can reverse the termination by choosing the Reinstate function in the Terminations Australia initial screen.

Features

- Termination report
  This lists the components used to calculate the termination payment and displays the total termination amount. You can use the report to verify termination details.

- Standard group certificates
  If you select the Print Group Certificate field on the Terminations Australia initial screen, the Terminations/Redundancies program issues a group certificate on termination. The group certificate is written to a spool request and can be printed from the spooler.
  
  If you want to print the group certificate at a later date (for example, at the end of the year instead of at the termination date), you must leave the Print Group Certificates field blank and run the Group Certificates program at the relevant time.

- ETP group certificates
  If the employee receives an eligible termination payment (ETP), the Terminations/Redundancies program generates an ETP group certificate. The certificate is written to a spool request and can be printed from the spooler.
Terminations/Redundancies Reporting

- ETP rollover statements

  If an employee rolls over all or part of his or her ETP, the Terminations/Redundancies program generates an ETP rollover statement. The statement is written to a spool request and can be printed from the spooler.

The ETP pre-payment statement provided to the employee prior to actual termination is not created automatically. The form must be completed manually by the employer. The same applies to the Employment Separation Certificate, Statement of Reasonable Benefits Limit form and the notification to Centrelink when terminating in excess of 15 employees (section 1/170DD of the Industrial Relations Act 1993).

See also:

Producing Group Certificates on Termination [Seite 738]
Printing Group Certificates and Reports [Seite 740]
Producing Payment Summaries on Termination

Use

You can determine whether you want a payment summary to be issued immediately from within the Terminations/Redundancies program or whether you want a payment summary to be issued at a later date, for example, at the end of the financial year.

If you choose to print the payment summary immediately, you must update your terminations and then issue the certificate from the spool request created by the Terminations/Redundancies program. If you choose to print the payment summary at a later date, you must run the Payment summaries program at the relevant time.

Prerequisites

You must set up the destination printer for the payment summary.

Procedure

65. On the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/Redundancies.

   The Terminations Australia screen appears.

66. Enter the employee’s personnel number, the termination date, and the termination reason.

67. To pay by cheque, flag the Cheque Payment field.

   Or

   To pay by bank transfer, leave the Cheque Payment field blank.

   If you flag the Cheque Payment field, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you must issue a cheque manually. The system does not issue cheques.

68. To issue a payment summary immediately, flag the Print Payment summary field.

   Or

   To issue a payment summary at a later date, leave the Print Payment summary field blank.
Producing Payment Summaries on Termination

These fields are default fields only. You can change the date, reason, payment method and payment summary printing option in the Employee Details screen for each employee.

69. Select Choose from the toolbar.

The Terminations Australia screen appears.

See also:

Printing Payment summaries and Reports [Seite 740]

For more information on printing payment summaries using the Payment summaries program, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia → End-of-Year Processing → Payment summaries [Seite 744].
Printing Payment Summaries and Reports

Use
If the Terminations/Redundancies program generates eligible termination payments (ETP) and payment summaries, you can print standard payment summaries, ETP payment summaries, the terminations report and, if necessary, ETP rollover statements from the spooler.

If you choose to print the payment summary at a later date (for example, at the end of the year instead at the termination date), you must run the Payment summaries program at the relevant time.

Prerequisites
You must have configured the destination printer for the payment summary.
You must have run the Terminations/Redundancies program and updated the terminations.

The Update function completes the termination and updates all the infotypes and records associated with terminations for each employee. Do not choose the Update function if you are only projecting termination payments.

If you inadvertently choose the Update function and thereby complete the termination, you can reverse the termination by choosing the Reinstate function in the Terminations Australia initial screen.

Procedure
70. Choose System → Services → Output controller.

The Spool Request screen appears, listing the payment summaries and reports created by the Terminations/Redundancies program.

71. To view the certificates and reports before they are printed, select the relevant entry and choose Spool request → Display.

72. To print the certificate or report, select the relevant entry and choose Spool request → Print.

The Spool Output Request screen appears.

73. Enter the printer and the printing parameters.

74. Choose Spool request → Print.

Result
The spool requests for payment summaries, ETP payment summaries, the terminations report and the ETP rollover statements remain in the spooler after printing to enable you to print them again, if necessary.
You cannot retrieve any of the reports after they have been deleted from the spooler. The only way to view a report after it has been deleted is to reinstate the employee and re-run the *Terminations/Redundancies* program.

**See also:**

[Producing Payment summaries][738]

For more information on printing payment summaries at a later date, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia → End-of-Year Processing → Payment summaries [Seite 744].
Terminations/Redundancies with Leave Accruals

Purpose
The Terminations/Redundancies component offers an efficient and comprehensive method of processing terminations and termination payments in line with Australian business practices. The component calculates the appropriate tax on these payments and, if necessary, calculates special tax according to Australian Taxation Office (ATO) requirements.

Terminations/Redundancies with Leave Accruals only applies to upgrade customers who have not yet converted to processing leave using SAP HR Personnel Time Management.

If you process leave using SAP HR Personnel Time Management, see Terminations/Redundancies with Leave Quotas [Seite 384].

Implementation Considerations
You implement the Terminations/Redundancies component in conjunction with the SAP HR Payroll Australia component.

Integration
The Terminations/Redundancies program gathers data from all payroll infotypes, delimits the Recurring Payments / Deductions (0014) infotype and creates records in the Additional Payments (0015) infotype. In the Actions infotype (0000), the program delimits the hiring action, creates a termination action and, if the employee has a lieu of notice period, creates a lieu of notice action.

In addition, the program triggers the payroll driver in simulation mode to calculate the employee’s final pay from the last payroll period to the termination date.

Features
The component enables you to:
- Process employee resignations
- Process bona fide redundancies and approved early retirement scheme payments
- Process bulk terminations
- Project termination payments into the future
- Effect superannuation payments for company-managed funds
- Perform retroactive terminations
- Reinstate terminated employees
Terminations/Redundancies with Leave Accruals

- Calculate leave up to the termination date including:
  - Leave entitlements and accruals
  - Leave balances owing at the termination date
  - Annual leave payments
  - Long service leave payments
  - Leave loading payments

- Calculate all additional payments including:
  - The employee’s pay from the last payroll period to the termination date
  - Severance pay based on the years of continuous service
  - In lieu of notice payments
  - ETP rollover payments

- Calculate tax on termination payments:
  - Termination and redundancy tax that includes the age reduction factor
  - Tax on ETP payments
  - Tax on lump sum A, B and D payments

- Issue termination reports:
  - Check report to verify figures prior to proceeding with a termination
  - ETP rollover statements
  - ETP group certificates
  - Standard group certificates

Constraints

The ETP pre-payment statement provided to the employee prior to actual termination is not created automatically. The form must be completed manually by the employer. The same applies to the Employment Separation Certificate, Statement of Reasonable Benefits Limit form and the notification to Centrelink when terminating in excess of fifteen employees (section 1/170DD of the Industrial Relations Act 1993).
Technical Process of Terminations / Redundancies

Purpose

The Terminations/Redundancies program calculates termination payments and updates numerous infotypes and tables automatically in the background. The program also allows you to define how termination payments are calculated.

This document provides an overview of the processes the Terminations/Redundancies program performs in the background and the functions you must maintain to ensure that termination payments are calculated in line with your company’s needs and those of each employee.

Prerequisites

Before processing terminations and redundancies, project teams must perform the following system configurations in the order specified:

5. Define your termination and redundancy actions and reasons. To do this, go to SAP Reference IMG → Personnel Management → Personnel Administration → Adjusting Procedures → Actions → Set Up Personnel Actions [Extern], and then Create Reasons for Personnel Actions [Extern].

6. Check that the correct leave method has been set up. To do this, go to SAP Reference IMG → Payroll → Payroll: Australia → Leave Provisions and Payments → Set Up Leave Method [Extern].

7. Configure termination and redundancy processing. To do this, go to SAP Reference IMG → Payroll → Payroll: Australia → Terminations/Redundancies [Extern].

Process Flow

8. You call the Terminations/Redundancies program (transaction PQRD), enter the personnel numbers of the employees to be terminated, and define whether the termination payments are to be made by cheque and whether group certificates are to be issued.

If you flag the Cheque Payment field, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you issue the cheque manually. The system does not issue cheques.

To issue a group certificate at a later date instead of at the termination date, you leave the Print Group Certificates field blank and run the Group Certificates program at the relevant time.

9. If an employee has a notice period, the program calculates how many weeks notice to give to the employee based on the termination date and the notice weeks set up in the Terminations Redundancy Payments view (V_T5QRS). At the same time, the program reads the initial data (for example, employee details, leave types) for each employee and lists the employees
Technical Process of Terminations / Redundancies

to be terminated on the Terminations Australia screen. You then verify the termination data stored on the Employee Details screen for each employee.

10. You call the Recurring Payments function for each employee. The program displays the wage types stored in the Recurring Payments / Deductions infotype (0014). You flag the wage types that are not to be included in the termination payment. The program automatically includes all other recurring payments and deductions in the employee’s final pay. The recurring payments and deductions do not appear on the Employee Details screen.

11. You check the Lieu of Notice function and, if necessary, run the Calculate Notice function. The program reads the Terminations Redundancy Payments view and, based on whether the wage type for in lieu of notice is in the view for the applicable award and termination reason, calculates a payment in lieu of notice.

12. The payment in lieu of notice appears in the Additional Payments table. If the employee is not entitled to a payment in lieu of notice, a system message appears stating the reason. You can either accept the message or recalculate the payment by selecting the Calculate Notice function again.

13. If an employee is entitled to long service leave (LSL), you enter the LSL formula in the ATO LSL Formula function. The program calculates the pre/post 1978 split based on the data you enter, and outputs the split to the Additional Payments table.

You do not have to perform this step, if the employee’s long service leave has been broken down into three separate leave types relating to service before 16 August 1978, service after 16 August 1978 and service after 17 August 1993, and if these leave types have been linked to a corresponding wage type.

14. You run the Calculate Pay function. This triggers a simulated payroll run in which the program automatically calculates:

d. Leave loading

The program reads the Termination Rules for LSL and Leave Loading view (V_T5QRR) and, depending on the configuration, calculates leave loading on either entitlement, accrual, both or neither. If the leave type is configured so that accrual is not paid if the entitlement value is less than or equal to zero, then the accrual value is not included in the termination payment.

The leave on termination hours are displayed in the Employee Details screen, but the leave amount is displayed in the termination report issued at the end of the terminations/redundancies process.

e. Redundancy packaging (the tax-free component of lump sum D)
Calculations are based on the redundancy reason, the award, the number of years of service and the wage types the company pays out for bona fide redundancies. The program reads the wage types in the Redundancy Packages view (V_T5QRP).

Lump sum D has a threshold that is based on the number of years of service. The program automatically applies lump sum C to remaining balances that exceed the lump sum D threshold.

f. Severance pay

The program automatically calculates severance pay based on the redundancy reason and the configuration of severance pay wage types in the Terminations Redundancy Payments view (V_T5QRS). If you have not configured severance pay wage types, the severance pay amount can be entered as an additional payment directly on the Employee Details screen.

Wage types previously entered in the Additional Payments infotype (0015) do not appear on the Employee Details screen.

9. If the calculation includes eligible termination payment (ETP) wage types, the ETP Rollover Distribution screen appears in which you can specify whether the ETP is paid out in part, in full or is rolled over into an approved rollover fund. If it is paid out, the ETP is automatically taxed at the appropriate rate. If it is rolled over into several funds, you can enter up to eight funds and distribute the ETP by amount or percentage. Once you have entered the ETP details, the program generates lump sum C non-taxable wage types for employees who roll over all or part of their ETP.

The non-taxable portion of the ETP (lump sum D) can not be rolled over.

10. The program generates and displays a termination report based on the data you entered.

11. To complete the termination for one employee, you execute the Update function in the Termination Report screen. To complete the termination for several employees, you return to the Terminations Australia screen and execute the Update function in batch mode to terminate several employees at once.

12. The termination report is transferred to the spooler and stored in a spool request.
Technical Process of Terminations / Redundancies

13. The final payroll run for the employee processes the final termination payment.

The payroll driver automatically delimits the cheque payment wage type. As a result, you must issue the cheque manually based on the termination payment data displayed in the Terminations report.

Result

If the Terminations/Redundancies program generates ETPs and group certificates, you can print standard group certificates, ETP group certificates, the terminations report and, if necessary, ETP rollover statements from the spooler. The spool requests remain in the spooler after printing to enable you to print them again if necessary.

You can not retrieve reports after they have been deleted from the spooler. If you inadvertently delete a spool request, the only way to view the report or certificate is to re-run the Terminations/Redundancies program.

If the employee’s gross termination payment exceeds $5000.00 and is not rolled over, a message reminding you to complete the Statement of Reasonable Benefits Limit form for the ATO is written to the employee’s termination report. The program does not complete this form automatically.

In addition, the program delimits the Recurring Payments / Deductions (0014) infotype and creates records in the Additional Payments (0015) infotype. In the Actions infotype (0000), the program delimits the hiring action, creates a termination action and, if the employee has a lieu of notice period, creates a lieu of notice action. If a group certificate has been issued, the program also updates the Tax Australia infotype (0188).
Initial Setup of Terminations / Redundancies

Purpose

The Terminations/Redundancies program loads employee details and calculates the length of service for each employee automatically in the background by reading and updating the data stored in various features [Extern], tables and infotypes [Extern].

This process describes how the program loads employee details and calculates the length of service for each employee.

Process Flow

9. You enter the employee(s) to be terminated, the termination date, the termination reason and whether the payment is to be made by cheque and printed on a group certificate.

10. The system reads the employee details stored in various infotypes as well as the Leave Entitlement (0005), Recurring Payments / Deductions (0014) and the Additional Payments (0015) infotypes. The system also reads the leave accruals from the year-to-date payroll results.

11. The system locks the employee number so that the user can only change employee data through the Terminations/Redundancies program.

12. The system calculates the length of service from the employee's hiring date to his or her termination date.

13. If the ETP Parameters feature (the step Set Up ETP Parameters [Extern] in Customizing for Payroll Australia) is configured to include the Other / Previous Employers infotype (0023) in length of service calculations, the program processes all the records stored in infotype 0023 for all the employees whose attributes match the areas and groupings set up in the feature. Each infotype record with an end date that is less than or equal to the employee’s hiring date is included in the length of service calculation.

To ensure that the program only includes records that relate to previous employment within your company, you must not create any records in infotype 0023 that relate to previous employment with other companies. To exclude previous employment details from length of service calculations for an individual employee, you must not maintain any records in infotype 0023 for that employee.

14. If the ETP Parameters feature is configured to include the notice period, the program calculates the length of service from the hiring date to the notice date.

15. The program calculates the number of continuous service days since hiring by subtracting the employee’s hiring date from the termination date and adding any days from the Other / Previous Employers infotype.
Initial Setup of Terminations / Redundancies

The number of days used by the Terminations/Redundancies program to calculate the length of service are displayed on the ETP group certificate and the ETP rollover statement. If the program has included infotype 0023 records that you do not want it to include in length of service calculations for a particular employee (for example, records of previous employment with a company other than your own), you must reinstate the employee, delete the relevant record(s) in infotype 0023 and then re-run the program.

16. The system reads the absence records stored in the Absences infotype (2001). To determine if any of the absence records hold leave without pay (LWOP) absence types, the program reads the Redundancies LWOP Absences view (V_T5QRA). It then subtracts the number of unpaid absence days from the number of continuous service days previously calculated.

Result

The Employee Details screen automatically displays the employee details, leave entitlements, accruals and additional payments.

See also:
Setting Up Terminations/Redundancies [Seite 437]
Determining the Payment Method [Seite 440]
Producing Group Certificates on Termination [Seite 738]
Setting up Terminations/Redundancies with Leave Accruals

This document only applies to upgrade customers who have not yet converted to processing leave using SAP HR Personnel Time Management.

If you process leave using SAP HR Personnel Time Management, see Setting up Terminations/Redundancies with Leave Quotas [Seite 393].

Prerequisites

If you configure the ETP Parameters feature [Extern] (the step Set Up ETP Parameters [Extern] in Customizing for Payroll Australia) to include the Other / Previous Employers infotype (0023) in length of service calculations, the Terminations/Redundancies program processes all the records stored in infotype 0023 for all the employees whose attributes match the areas and groupings set up in the feature.

To ensure that the program only includes records that relate to previous employment within your company, you must not create any records in infotype 0023 that relate to previous employment with other companies. To exclude previous employment details from length of service calculations for an individual employee, you must not maintain any records in infotype 0023 for that employee.

The number of days used by the Terminations/Redundancies program to calculate the length of service are displayed on the ETP group certificate and the ETP rollover statement. If the program has included infotype 0023 records that you do not want it to include in length of service calculations for a particular employee (for example, records of previous employment with a company other than your own), you must reinstate the employee, delete the relevant record(s) in infotype 0023 and then re-run the program.

Procedure

11. On the SAP R/3 screen, choose Human Resources → Payroll → Asial/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

    The Terminations Australia screen appears.

12. To terminate one employee, enter the personnel number in the Personnel number field.
Setting up Terminations/Redundancies with Leave Accruals

Or

To terminate a range of employees according to their personnel areas, personnel subareas or cost centers, choose Preselect and enter the relevant data.

13. Enter the termination date and the termination reason key.

14. To issue a cheque payment, flag the Cheque Payment field.


If you flag the Cheque Payment field, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you must issue a cheque manually. The system does not issue cheques.

If you do not flag the Cheque Payment field, the Bank Transfers program must be executed to transfer the payment to the employee’s account after the payroll run.

15. To print a group certificate, flag the Print Group Certificate field.


To issue a group certificate at a later date instead of at the termination date, you must leave the Print Group Certificates field blank and run the Group Certificates program at the relevant time.

16. Select Choose from the toolbar.

   The Terminations Australia screen appears listing the employees to be terminated.


If an error occurs while the system retrieves the employee details, an error message appears in the System Messages field. For details, see Termination System Messages [Extern].

17. Flag an employee’s name, choose Details.

   The Employee Details screen appears.
In the **Employee Details** screen, you can correct problems encountered by the system when reading the initial data, change the default termination values for all employees and add additional employees by overwriting the relevant data.

**Result**

The program displays the employee details based on the personal, leave and salary data stored in the system.

You can check and, if necessary, modify these details either by overwriting the data or by executing the **Recurring Payments, Lieu of Notice** and **ATO LSL Formula** functions in the **Employee Details** screen.

**See also:**
- Terminations / Redundancies [Seite 429]
- Initial Setup of Terminations/Redundancies [Seite 435]
- The Recurring Payments Function [Seite 443]
- The Lieu of Notice Function [Seite 445]
- The ATO LSL Formula Function [Seite 449]
- Leave Payments [Seite 454]
Determining the Payment Method

Use
You can effect termination payments either by bank transfer or by cheque. If paying by bank transfer, the payment is not transferred until the payroll run after the termination date actually takes place.

If you choose to pay by cheque, the program creates a cheque payment wage type specifying the total termination payment and stores the wage type in the Additional Payments infotype (0015). The wage type appears in the Terminations report, but is excluded from the employee’s final payroll run. You must prepare the cheque manually based on the amount specified in the Terminations report.

Procedure
75. On the SAP R/3 screen, choose Human Resources → Payroll → Asial/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

76. Enter the employee’s personnel number, the termination date, and the termination reason.

77. To pay by cheque, flag the Cheque Payment field.

   Or

   To pay by bank transfer, leave the Cheque Payment field blank.

78. To issue a group certificate immediately, flag the Print Group Certificate field.

   Or

   To issue a group certificate at a later date, leave the Print Group Certificate field blank.

   To issue a group certificate at a later date, you must run the Group Certificates program at the relevant time.

79. Select Choose from the toolbar.

   The Terminations Australia screen appears.

See also:
Initial Setup of Terminations / Redundancies [Seite 435]
Producing Payment Summaries on Termination

Use

You can determine whether you want a payment summary to be issued immediately from within the Terminations/Redundancies program or whether you want a payment summary to be issued at a later date, for example, at the end of the financial year.

If you choose to print the payment summary immediately, you must update your terminations and then issue the certificate from the spool request created by the Terminations/Redundancies program. If you choose to print the payment summary at a later date, you must run the Payment summaries program at the relevant time.

Prerequisites

You must set up the destination printer for the payment summary.

Procedure

80. On the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/Redundancies.

The Terminations Australia screen appears.

81. Enter the employee’s personnel number, the termination date, and the termination reason.

82. To pay by cheque, flag the Cheque Payment field.

Or

To pay by bank transfer, leave the Cheque Payment field blank.

If you flag the Cheque Payment field, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you must issue a cheque manually. The system does not issue cheques.

83. To issue a payment summary immediately, flag the Print Payment summary field.

Or

To issue a payment summary at a later date, leave the Print Payment summary field blank.
Producing Payment Summaries on Termination

These fields are default fields only. You can change the date, reason, payment method and payment summary printing option in the Employee Details screen for each employee.

84. Select Choose from the toolbar.

The Terminations Australia screen appears.

See also:

Printing Payment summaries and Reports [Seite 740]

For more information on printing payment summaries using the Payment summaries program, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia → End-of-Year Processing → Payment summaries [Seite 744].
The Recurring Payments Function

Use

The Terminations/Redundancies program includes all recurring payments and deductions in an employee’s final termination payment automatically. If you want to exclude a recurring payment or deduction from termination payment calculations, you must maintain the Recurring Payments function.

Integration

The function reads and retrieves wage type data stored in the Recurring Payments/Deductions infotype (0014).

The recurring payments and deductions are not displayed on the Employee Details screen. The program calculates the payments/deductions in the background.

Prerequisites

This function only operates if an employee has wage types in the Recurring Payments/Deductions infotype.

Features

The function lists the wage types stored in the Recurring Payments/Deductions infotype and allows you to exclude the wage types from an employee’s termination payment.

See also:

Suppressing Recurring Payments [Seite 444]
Suppressing Recurring Payments

Prerequisites
You use this function only if the employee has wage types in the Recurring Payments/Deductions infotype (0014).

Procedure
85. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

86. Enter the employee’s personnel number, the termination date and the termination reason.

87. If necessary, select the payment method and group certificate options.

88. Select Choose from the toolbar.

   The Terminations Australia screen appears.

89. Select an employee’s name, and choose Details.

   The Employee Details screen appears.

90. Choose Recurring Payments.

   The Suppress Recurring Payments screen appears.

91. To exclude recurring payments and deductions from an employee’s termination payment, select the Suppress in Final Pay field for the relevant wage type.

   If you do not select the Suppress in Final Pay field, the program includes the wage type in the employee’s termination payment.

92. Return to the Employee Details screen.

Result
The recurring payments and deductions do not appear on the Employee Details screen. The program calculates the payments/deductions in the background automatically and displays the results in the Terminations report.

See also:
The Recurring Payments Function [Seite 443]
The Lieu of Notice Function

Use
When an employee resigns or is terminated, an employer can opt to provide payment in lieu of notice. This means that the required period of notice is paid out by the employer. The rate of pay is the employee’s current ordinary rate of pay, including any additional payments or deductions defined by the employer.

If an employee has a notice period and the employer chooses to provide payment in lieu of notice, the Lieu of Notice function calculates the payment and adds it as an additional payment to the employee’s termination payment.

Integration
To calculate payments in lieu of notice, the Terminations/Redundancies program reads the Terminations Redundancy Payments view (V_T5QRS) and retrieves any in lieu of notice wage types for the employee’s award and termination reason. If there are no wage types, the program does not calculate any payments in lieu of notice. If the view holds wage types, the payroll driver calculates the lieu of notice amount in simulation mode.

Prerequisites
Before processing payments in lieu of notice, you must:

- Create a lieu of notice action and reason under SAP Reference IMG → Personnel Management → Personnel Administration → Customize Procedures → Actions → Set Up Personnel Actions [Extern] and Create Reasons for Personnel Actions [Extern].
- Enter the in lieu of notice action in Customizing for Payroll Australia under Terminations/Redundancies → Set Up ETP Parameters [Extern].
- Configure the Terminations/Redundancies section of Customizing for Payroll Australia, and in particular the steps:
  - Define Termination/Redundancy Reasons [Extern]
  - Create Redundancy Models [Extern]
  - Assign Termination Wage Types to Wage Type Group [Extern]
  - Set Up Redundancy Wage Type Categories [Extern]
  - Set Up Severance and In Lieu Payments [Extern]

Features
6. The Terminations/Redundancies program enters a default notice date based on the number of weeks set up in the Terminations Redundancy Payments view.

7. You can either leave or overwrite the default notice date. For example:
   a. In the case of employees who are entitled to a notice period and are dismissed with immediate effect, you can overwrite the default notice date if the number of weeks set up in the Terminations Redundancy Payments view is incorrect.
   b. In the case of employees who work up to their notice date (for example, they give four weeks notice and work the full four weeks), you can overwrite the default notice date to
The Lieu of Notice Function

reflect the termination date. This prevents the program from calculating a payment in lieu of notice.

c. In the case of employees who are dismissed and work some of their notice period, you can overwrite the default notice date to reflect the weeks that the employee is entitled to payment in lieu of notice.

8. Once the notice date has been established, the Lieu of Notice function displays any wage types stored in the Recurring Payments/Deductions infotype (0014) for the employee. To include a wage type in the payment in lieu of notice calculation, you set the Include field indicator.

9. The Calculate Notice function determines the payment for the notice period. The dollar amount is entered against the wage type set up in the Terminations Redundancy Payments view and is displayed as an additional payment in the Employee Details screen.

10. If the lieu of notice date differs from the termination date, the program enters a lieu of notice action in the Actions infotype (0000).

See also:
Calculating Payments in Lieu of Notice [Seite 447]
Calculating Payments in Lieu of Notice

93. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

The Terminations Australia screen appears.

94. Enter the employee’s personnel number, the termination date and the termination reason.

95. If necessary, select the payment method and group certificate options.

96. Select Choose from the toolbar.

The Terminations Australia screen appears.

97. Select an employee’s name, and choose Details.

The Employee Details screen appears.

98. If necessary, overwrite the default notice date to reflect the number of weeks for which the employee is entitled to a payment in lieu of notice.

99. Choose Lieu of Notice.

The Calculate Lieu of Notice screen appears.

100. To include recurring payments and deductions in an employee’s payment in lieu of notice, select the Include field for the relevant wage type.

Do not confuse this field with the Suppress in Final Pay field in the Recurring Payments function [Seite 443]. The two fields serve opposite purposes.

10. Choose Calculate Notice.

Result

The payroll driver calculates the payment. The wage type and total amount appear as an additional payment on the Employee Details screen.

If required, you can overwrite the wage type and the amount displayed on the Employee Details screen.

If the lieu of notice date differs from the termination date, the program enters a lieu of notice action in the Actions infotype (0000) when you update the termination.
Calculating Payments in Lieu of Notice

See also:

The Lieu of Notice Function [Seite 445]
The ATO LSL Formula Function

Use
An employee’s long service leave (LSL) payments may need to be broken down into three parts:

- An amount relating to service before 16 August 1978
  5% of the payment for unused long service leave is included in the employee’s taxable income (lump sum B)

- An amount relating to service from 16 August 1978
  All of the payment for unused long service leave is included in the employee’s taxable income (lump sum A). The employee receives a tax rebate if his or her marginal tax rate is higher than 30 cents in the dollar.

- An amount relating to service after 17 August 1993
  All of the payment for unused long service leave is included in the employee’s taxable income and taxed at normal marginal rates (lump sum A).

The standard system offers two methods of dividing an employee’s long service leave payments into these parts:

3. By using a formula that is defined in income tax law. The formula is based on the period of service over which the employee’s long service leave entitlement has accrued and takes into account leave previously taken.


This function describes how to calculate long service leave payments using the ATO LSL Formula function. For information on how to calculate the payments using separate leave types, see Calculating LSL Payments Without a Formula [Seite 453].

Integration
To process long service leave payments, the ATO LSL Formula function reads the ATO LSL Formula Wage Type view in which you can nominate the wage types used to pay the pre and post 16 August 1978 and the post 17 August 1993 parts of long service leave. The data you enter in the ATO LSL Formula function is used to create the payments.

Prerequisites
You must configure the Terminations/Redundancies section of Customizing for Payroll Australia, and in particular the steps Set Up Redundancy Rules for Paying Leave Accruals [Extern] and Set Up ATO LSL Formula [Extern].

Features
You enter the employee’s used/unused leave days in the ATO LSL Formula screen. To find the relevant information for each employee, you can run the Leave View program (RPCLEAQ0), which reads the relevant infotypes and the payroll results.

The ATO LSL Formula function calculates the long service leave payment for the employee. The Terminations/Redundancies program splits the payment into lump sums A and B, that is, pre and
The ATO LSL Formula Function

post 16 August 1978 and post 17 August 1993 parts, calculates the appropriate tax on each lump sum and the total long service leave payment. The results are listed in the Terminations report.

If you elect to use the ATO formula to calculate long service leave components, the program will use the formula entered in the ATO LSL Formula function. Otherwise, the program will use the variables defined in the Termination Rules for LSL and Leave Loading view (V_T5QRR) to calculate the components.

Activities

Calculating LSL Payments with a Formula [Seite 451]
Calculating LSL Payments Without a Formula [Seite 453]
Calculating LSL Payments with a Formula

Use

You do not have to perform this procedure if the employee’s long service leave has been broken down into three separate leave types relating to service before 16 August 1978, service after 16 August 1978 and service after 17 August 1993, and if these leave types have been linked to a corresponding wage type.

Procedure

101. On the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

102. Enter the employee’s personnel number, the termination date and the termination reason.

103. If necessary, flag the payment method and group certificate options.

104. Select Choose from the toolbar.

   The Terminations Australia screen appears.

105. Flag an employee’s name, and choose Details.

   The Employee Details screen appears.

106. Choose ATO LSL Formula.

   The ATO LSL Formula Components screen appears.

107. Enter the values used to calculate long service leave payments.

   To find the relevant leave data, you can run the Leave View program (RPCLEAQ0) for each employee. This program provides all the details required for the ATO LSL formula by allowing you to project the employee’s leave to the termination date, and reading all the relevant infotypes and payroll results.

108. Choose Execute.

Result

The program calculates the long service leave payment and splits the payment into pre/post 1978 and post 1993 parts. The resulting amounts are displayed as additional payment wage types in the Employee Details screen and later included in the termination payment calculation.

See also:

The ATO LSL Formula Function [Seite 449]
Calculating LSL Payments with a Formula

Calculating LSL Payments Without a Formula [Seite 453]
Calculating LSL Payments Without a Formula

Use
This procedure describes how to calculate long service leave payments without using the ATO LSL Formula function.

Prerequisites
You can only use this procedure if the employee’s long service leave has been broken down into three separate leave types relating to service before 16 August 1978, service after 16 August 1978 and service after 17 August 1993, and if these leave types have been linked to a corresponding wage type.

Procedure
109. On the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.
   The Terminations Australia screen appears.
110. Enter the employee’s personnel number, the termination date and the termination reason.
111. If necessary, flag the payment method and group certificate options.
112. Select Choose from the toolbar.
   The Terminations Australia screen appears.
113. Flag an employee’s name, and choose Details.
   The Employee Details screen appears.
7. Check the leave types displayed in the Projected leave table.
8. If necessary, change or delete the existing leave types or add new leave types.

Result
The Terminations/Redundancies program calculates the long service leave payments based on the leave types set up in the Projected leave table. You do not have to run the ATO LSL Formula function.

See also:
The ATO LSL Formula Function [Seite 449]
Calculating LSL Payments with a Formula [Seite 451]
Leave Payments on Termination

Use

The Terminus/Redundancies program calculates the amount of leave the employee has remaining and displays the data on the Employee Details screen. The leave data is made up of the leave type, the expected leave entitlement hours at the termination date and the expected accrual hours at the termination date. You can change, delete or create new leave data. Any leave data that you manually enter into the program is calculated as entered, that is, it is not projected to the termination date.

Integration

To determine whether the termination payment should include annual leave, leave loading and long service leave, the program checks each leave type against the data stored in the Termination Rules for LSL and Leave Loading view (V_T5QRR) to verify if it is valid to be paid out for the award and termination reason.

The view also determines whether:

- Leave entitlement and/or accrual or neither is paid out
- Leave loading is applicable to entitlement and/or accrual or neither
- Accrual is to be paid out when the entitlement value is less than or equal to zero

The view indicates if long service leave is to be paid out based on whether the employee’s continuous years of service exceeds the minimum years required.

Prerequisites

You must have configured the Terminus/Redundancies section of Customizing for Payroll Australia, and in particular the step Set Up Redundancy Rules for Paying Leave Accruals [Extern].

Features

The Terminus/Redundancies program lists the leave types to be included in the termination payment calculation and projects the leave balances.

You can override any leave data projected by the program by overwriting the entries in the Projected Leave table on the Employee Details screen, that is, you can delete or change the data generated by the system and enter new leave types.

The leave on termination hours are displayed on the Employee Details screen, but the leave amount is displayed in the Terminus report issued at the end of the termination payment calculation.
Activities

Projecting Leave Balances [Seite 456]
Entering / Deleting Leave Payments [Seite 458]
Projecting Leave Balances

Prerequisites
The leave type must be configured as payable for the termination reason.

Procedure
114. On the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

115. Enter the employee’s personnel number, the termination date and the termination reason.

116. If necessary, flag the payment method and group certificate options.

117. Select Choose from the toolbar.

   The Terminations Australia screen appears.

118. Flag the employee’s name, and choose Details.

   The Employee Details screen appears.

119. If required, in the Projected leave table, enter the leave payments by entering the leave type, the entitlement or accrual values or both.

   To ensure that you only select the leave types and leave accrual identifiers set up in your system, choose the Possible Entries down arrow for each field. A list of valid leave types and accrual identifiers is displayed.

120. To project leave accruals and/or entitlements, enter the relevant date in the Notice Date field or the Termination Date field.

Result
The program displays the leave type, text, entitlement and accrual hours in the Projected Leave table. If the leave data is set up in the system, the program projects the relevant leave accruals and entitlements to the notice date or the termination date. If you enter the leave data manually, the program calculates the data as entered, that is, it does not project accruals and entitlements to the termination date.
If you enter a leave type that already exists in the *Projected leave* table, the entitlement and accrual hours for both payments combine to become one payment.

The amount projected is not always the total amount that is paid out. The amount paid depends on the configuration in the *Set Up Redundancy Rules for Paying Leave Accruals [Extern]* step of Customizing for Payroll Australia.

**See also:**

- [Leave Payments on Termination](#)
- [Entering / Deleting Leave Payments](#)
Entering/Deleting Leave Payments

Prerequisites
The leave types must be configured as payable for the termination reason.

Procedure

Entering Leave Payments

121. From the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.
   
   The Terminations Australia screen appears.

122. Enter the employee’s personnel number, the termination date and the termination reason.

123. If necessary, select the payment method and group certificate options.

124. Select Choose from the toolbar.
   
   The Terminations Australia screen appears.

125. Select an employee’s name, and choose Details.
   
   The Employee Details screen appears.

126. In the Projected leave table, enter the leave payments by entering the leave type, the leave accrual identifier, the entitlement or accrual values or both.

   To ensure that you only select the leave types and leave accrual identifiers set up in your system, choose the Possible Entries down arrow for each field. A list of valid leave types and accrual identifiers is displayed.

Result

The leave type is included in the termination payment calculation.

If you enter a leave type that is already in the Projected leave table, the entitlement and accrual hours for both payments combine to become one payment.
Deleting Leave Payments

1. Perform steps 1 to 5 as described above.

2. Select the leave type to be deleted. Delete the leave type identifier, and choose Enter.
   The entitlement and accrual hours are removed. Repeat this step until all the system-generated leave types are deleted.

Result

The leave type is not included in the termination payment calculation.
Entering Additional Payments

Use

The Terminations/Redundancies program processes the wage types stored in the Additional Payments infotype (0015) as well as any wage types set up for redundancy packaging. You can also enter additional payments in the Additional payments table either by entering the relevant wage type or by overwriting the amount or value of a particular wage type listed in the table.

Wage types stored in the Additional Payments infotype do not appear on the Employee Details screen.

Procedure

127. From the SAP R/3 screen, choose Human Resources → Payroll → Asial/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

128. Enter the employee’s personnel number, the termination date and the termination reason.

129. If necessary, set the payment method and group certificate option indicators.

130. Select Choose from the toolbar.

   The Terminations Australia screen appears.

131. Select an employee’s name, and choose Details.

   The Employee Details screen appears.

7. In the Additional payments table, create additional payments by entering the wage type and dollar amount, unit of measurement value or both depending on the wage type.

   If you enter a wage type that is already in the Additional payments table, the value or number of both payments combine to become one payment.

Result

The Terminations/Redundancies program includes all the wage types in the termination payment calculation.
Distributing the ETP Rollover

Use
If an employee receives an eligible termination payment (ETP) as part of his or her redundancy package, you can specify whether the ETP is paid out in part, in full or is rolled over into an approved rollover fund. If it is paid out, the ETP is automatically taxed at the appropriate rate. If it is rolled over into several funds, you can enter up to eight funds and distribute the ETP by amount or percentage.

Prerequisites
You have completed the procedure described in Setting Up Terminations/Redundancies [Seite 437], and the program has loaded all the initial employee data into the Employee Details screen.

Procedure
23. On the Employee Details screen, check the data displayed for each employee.
24. If necessary, overwrite the data to meet your requirements.
25. If necessary, maintain and execute the Recurring Payments function, the Lieu of Notice function and/or the ATO LSL Formula function.
26. If you have not configured a severance pay wage type and want to effect a severance payment to an employee, enter the amount directly in the Additional payments table.
27. Choose Calculate Pay.
   The ETP Rollover Distribution screen appears.
28. If the screen displays an eligible termination payment (ETP) for the employee, enter the ETP distribution by amount or percentage and the fund details.
29. Choose Continue.

Result
The program triggers the payroll driver in simulation mode and calculates the employee’s total termination payment including:

- Pay from the last payroll period to the termination date
- All additional payments
- If applicable, eligible termination payments

The Terminations report appears listing all the payments to be made to the employee in the event of termination of employment.
To leave the *Termination* report, choose the *Back* function. Do **not** choose the *Update* function unless you want to complete the termination.
Projecting Termination Payments

Use

The Terminations/Redundancies program allows you to forecast termination payments without actually terminating employees. The program performs all calculations and system modifications in simulation mode and does not terminate employees until you specifically instruct the program to complete the termination.

When projecting termination payments, do not choose the Update function as this will complete the termination and update all the infotypes and records associated with terminations for each employee.

If you inadvertently choose the Update function and thereby complete the termination, you can reverse the termination by choosing the Reinstate function in the Terminations Australia initial screen.

Prerequisites

You have completed the procedure described in the document Setting Up Terminations/Redundancies [Seite 437], and the Terminations/Redundancies program has loaded all the initial employee data into the Employee Details screen.

Procedure

30. On the Employee Details screen, check the data displayed for each employee.
31. If necessary, overwrite the data to meet your requirements.
32. If necessary, maintain and execute the Recurring Payments function, the Lieu of Notice function and/or the ATO LSL Formula function.
33. If you have not configured a severance pay wage type and want to effect a severance payment to an employee, enter the amount directly in the Additional payments table.
34. Choose Calculate Pay.

The ETP Rollover Distribution screen appears.

35. If the screen displays an eligible termination payment (ETP) for the employee, enter the ETP distribution and the fund details.
36. Choose Continue.

Result

The program triggers the payroll driver in simulation mode and calculates the employee’s total termination payment including:

- Pay from the last payroll period to the termination date
Payroll Australia (PY-AU)

Projecting Termination Payments

- All additional payments
- If applicable, eligible termination payments

The *Terminations* report appears listing all the payments to be made to the employee in the event of termination of employment.

To leave the *Termination* report, choose the *Back* function. Do not choose the *Update* function unless you want to complete the termination.

**See also:**
- Setting Up Terminations/Redundancies [Seite 437]
- Updating Single and Bulk Terminations [Seite 465]
- Distributing the ETP Rollover [Seite 461]
- Printing Group Certificates and Reports [Seite 740]
Updating Single and Bulk Terminations

Use
The Terminations/Redundancies program can terminate one to fifty employees. The procedure for terminating one employee differs from the procedure for terminating several employees at the same time.

This procedure will complete termination processing for your employees, that is, the relevant employees will no longer belong to your organisation.

To reverse a termination, choose the Reinstate function in the Terminations Australia initial screen.

Procedure
Updating Single Terminations
37. On the Employee Details screen, check the data displayed for the employee.
38. If necessary, overwrite the data to meet your requirements.
39. If necessary, maintain and execute the Recurring Payments function, the Lieu of Notice function and/or the ATO LSL Formula function.
40. If you have not configured a severance pay wage type and want to effect a severance payment to an employee, enter the amount directly in the Additional payments table.
41. Choose Calculate Pay.
   The ETP Rollover Distribution screen appears.
42. If the screen displays an eligible termination payment (ETP), enter the ETP distribution and the fund details.
43. Choose Continue.
   The Terminations report appears listing the employee’s termination payment details.
44. To complete the termination, choose Update.

Updating Bulk Terminations
10. On the Employee Details screen, check the data displayed for each employee.
11. If necessary, overwrite the data to meet your requirements.
12. If necessary, maintain and execute the Recurring Payments function, the Lieu of Notice function and/or the ATO LSL Formula function.
Updating Single and Bulk Terminations

13. If you have **not** configured a severance pay wage type and want to effect a severance payment to an employee, enter the amount directly in the *Additional Payments* table.

14. Choose *Calculate Pay*.

   The *ETP Rollover Distribution* screen appears.

15. If the screen displays an eligible termination payment (ETP), enter the ETP distribution and the fund details.

16. Choose *Continue*.

   The *Terminations* report appears listing each employee’s termination payment details.

17. To complete the termination, return to the *Terminations Australia* screen.

18. Choose *Update*.

   The program terminates all the employees simultaneously.

**Result**

The program updates all the relevant infotypes and tables so that the employee(s) effectively no longer belong to your organisation.

The *Terminations* report is transferred to the spooler, where you can print the report and, if required, print group certificates, ETP group certificates and ETP rollover statements for each employee.

If an employee’s gross termination payment exceeds $5000.00 and is not rolled over, a message reminding you to complete the *Statement of Reasonable Benefits Limit* form for the ATO is written to the employee’s termination report.

   

   The program does not complete this form automatically.

In addition, the program delimits the *Recurring Payments / Deductions* (0014) infotype and creates records in the *Additional Payments* (0015) infotype. In the *Actions* infotype (0000), the program delimits the hiring action, creates a termination action and, if an employee has a notice period, creates a lieu of notice action. If a group certificate has been issued, the program also updates the *Tax Australia* infotype (0188).

**See also:**

- Setting Up Terminations/Redundancies [Seite 437]
- Projecting Termination Payments [Seite 463]
- Distributing the ETP Rollover [Seite 461]
- Printing Group Certificates and Reports [Seite 740]
Reinstating Terminated Employees

Use

The Terminations/Redundancies program enables you to re-hire terminated employees. When you re-hire an employee, the Reinstall function re-activates and resets all the infotypes that were delimited during the termination process except for the Tax Australia infotype (0188):

If you reinstate an employee after issuing a group certificate on termination, you must run the Reinstall function and manually reset the year in the Group certificate issued field of the Tax Australia infotype (0188) to reflect the year in which the group certificate was last issued.

If you reinstate an employee before issuing a group certificate on termination, you simply run the Reinstall function in the Terminations/Redundancies program.

Procedure

18. On the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

   The Terminations Australia screen appears.

19. Activate the Reinstall field.

20. To reinstate one employee, enter the personnel number in the Personnel number field.

   Or

   To reinstate a range of employees according to their personnel areas, personnel subareas or cost centers, choose Preselect and enter the relevant data.

5. Choose Enter.

Result

A message appears confirming that the employee has been reinstated.
Terminating in the Past

Use

You can terminate an employee in a past payroll period, but the termination date must not be before the employee's hiring date, the payroll area's earliest recalculation date or the employee's earliest payroll date.

An employee has been absent for several weeks without notifying anyone in the company. You want to terminate the employee from the first day of his or her absence.

Prerequisites

The Terminations/Redundancies program does not reverse leave entitlements and accruals in retroactive runs. You must therefore reduce the employee's leave entitlement value in the Leave Entitlement infotype (0005) first.

Procedure

132. On the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/redundancies.

The Terminations Australia screen appears.

133. Enter the employee's personnel number and the termination reason.

134. Enter a termination date in the past.

135. If necessary, flag the payment method and group certificate options.

136. Select Choose from the toolbar.

The Terminations Australia screen appears with a system message stating Retro Term.

137. Flag the employee's name, and choose Details.

The Employee Details screen appears.

138. If necessary, overwrite the notice date.

139. Choose Calculate Pay.

The Terminations report appears.

Result

The system calculates the difference between the amount the employee has been paid after the termination date up to and including the employee's last completed payroll period, and the amount the employee should have been paid.
If the termination payment is a negative amount, a claim is generated. This is the amount that you have overpaid the employee. Normally a claim is recovered by the system from future payroll runs, but the employee number is now terminated so there is no automatic recovery.

As a result, the claim either remains against the employee or you can write off the amount of the claim for reporting purposes. If you write off the amount, you configure a wage type for monies lost on termination. If you recover the overpayment from the employee, you allocate it to a wage type for monies recovered.
Making Payments after Termination

Use

You may be required to make continuous or one-off payments to employees after they have been terminated. For example, workcover payments to employees permanently disabled due to an accident at work.

This procedure describes how you set up the system to make continuous and one-off payments after termination.

Procedure

Making Continuous Payments after Termination

4. Activate and, if necessary, modify the Organizational Assignment (0001), Personal Data (0002), Planned Working Time (0007), Basic Pay (0008), Bank Details (0009) and the Tax Australia (0188) infotypes.

These infotypes are delimited during the termination process.

5. To ensure that the payroll driver includes the terminated employees in the payroll run, configure the terminated employees into a separate employee subgroup.

6. Enter the continuous payment in either the Recurring Payments / Deductions infotype (0014) or the Additional Payments infotype (0015).

Making One-Off Payments after Termination

3. Change either the Basic Pay infotype (0008) or the Additional Payments (0015) infotype to reflect the one-off payment you want to make.

4. Perform a retroactive payroll run for the employee.

See also:

For information on how to perform retroactive payroll runs, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Payroll in the R/3 System → Basics of Payroll → Payroll Control Record → Retroactive Accounting.
Terminations/Redundancies Reporting

Use

The Terminations/Redundancies program enables you to issue the following reports and certificates:

- Termination report
- Standard group certificate
- ETP group certificate
- ETP rollover statement

Prerequisites

You must have configured the destination printer for the report.

You must have run the Terminations/Redundancies program and updated the terminations.

The Update function completes the termination and updates all the infotypes and records associated with terminations for each employee. Do not choose the Update function if you are only projecting termination payments.

If you inadvertently choose the Update function and thereby complete the termination, you can reverse the termination by choosing the Reinstate function in the Terminations Australia initial screen.

Features

- Termination report
  
  This lists the components used to calculate the termination payment and displays the total termination amount. You can use the report to verify termination details.

- Standard group certificates
  
  If you select the Print Group Certificate field on the Terminations Australia initial screen, the Terminations/Redundancies program issues a group certificate on termination. The group certificate is written to a spool request and can be printed from the spooler.

  If you want to print the group certificate at a later date (for example, at the end of the year instead of at the termination date), you must leave the Print Group Certificates field blank and run the Group Certificates program at the relevant time.

- ETP group certificates
  
  If the employee receives an eligible termination payment (ETP), the Terminations/Redundancies program generates an ETP group certificate. The certificate is written to a spool request and can be printed from the spooler.
Terminations/Redundancies Reporting

- ETP rollover statements

  If an employee rolls over all or part of his or her ETP, the Terminations/Redundancies program generates an ETP rollover statement. The statement is written to a spool request and can be printed from the spooler.

  The ETP pre-payment statement provided to the employee prior to actual termination is not created automatically. The form must be completed manually by the employer. The same applies to the Employment Separation Certificate, Statement of Reasonable Benefits Limit form and the notification to Centrelink when terminating in excess of 15 employees (section 1/170DD of the Industrial Relations Act 1993).

See also:

Producing Group Certificates on Termination [Seite 738]
Printing Group Certificates and Reports [Seite 740]
Producing Payment Summaries on Termination

Use

You can determine whether you want a payment summary to be issued immediately from within the Terminations/Redundancies program or whether you want a payment summary to be issued at a later date, for example, at the end of the financial year.

If you choose to print the payment summary immediately, you must update your terminations and then issue the certificate from the spool request created by the Terminations/Redundancies program. If you choose to print the payment summary at a later date, you must run the Payment summaries program at the relevant time.

Prerequisites

You must set up the destination printer for the payment summary.

Procedure

140. On the SAP R/3 screen, choose Human Resources → Payroll → Asia/Pacific → Australia, then Subsequent activities → Per payroll period, and then Other activities → Terminations/Redundancies.

   The Terminations Australia screen appears.

141. Enter the employee’s personnel number, the termination date, and the termination reason.

142. To pay by cheque, flag the Cheque Payment field.

   Or

   To pay by bank transfer, leave the Cheque Payment field blank.

   If you flag the Cheque Payment field, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you must issue a cheque manually. The system does not issue cheques.

143. To issue a payment summary immediately, flag the Print Payment summary field.

   Or

   To issue a payment summary at a later date, leave the Print Payment summary field blank.
These fields are default fields only. You can change the date, reason, payment method and payment summary printing option in the Employee Details screen for each employee.

144. Select Choose from the toolbar.

The Terminations Australia screen appears.

See also:

Printing Payment summaries and Reports [Seite 740]

For more information on printing payment summaries using the Payment summaries program, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia → End-of-Year Processing → Payment summaries [Seite 744].
Printing Payment Summaries and Reports

Use
If the Terminations/Redundancies program generates eligible termination payments (ETP) and payment summaries, you can print standard payment summaries, ETP payment summaries, the terminations report and, if necessary, ETP rollover statements from the spooler.

If you choose to print the payment summary at a later date (for example, at the end of the year instead at the termination date), you must run the Payment summaries program at the relevant time.

Prerequisites
You must have configured the destination printer for the payment summary.
You must have run the Terminations/Redundancies program and updated the terminations.

The Update function completes the termination and updates all the infotypes and records associated with terminations for each employee. Do not choose the Update function if you are only projecting termination payments.

If you inadvertently choose the Update function and thereby complete the termination, you can reverse the termination by choosing the Reinstate function in the Terminations Australia initial screen.

Procedure

145. Choose System → Services → Output controller.

   The Spool Request screen appears, listing the payment summaries and reports created by the Terminations/Redundancies program.

146. To view the certificates and reports before they are printed, select the relevant entry and choose Spool request → Display.

147. To print the certificate or report, select the relevant entry and choose Spool request → Print.

   The Spool Output Request screen appears.

148. Enter the printer and the printing parameters.

149. Choose Spool request → Print.

Result
The spool requests for payment summaries, ETP payment summaries, the terminations report and the ETP rollover statements remain in the spooler after printing to enable you to print them again, if necessary.
Printing Payment Summaries and Reports

You cannot retrieve any of the reports after they have been deleted from the spooler. The only way to view a report after it has been deleted is to reinstate the employee and re-run the Terminations/Redundancies program.

See also:

Producing Payment summaries [Seite 738]

For more information on printing payment summaries at a later date, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia → End-of-Year Processing → Payment summaries [Seite 744].
Change of Group Tax Employer

Purpose
The SAP HR Payroll Australia component lets you process payroll, leave, superannuation, tax, group certificates and other reports for employees who change group tax employer. This describes how a change of group tax employer is processed during payroll.

Prerequisites
An employee has changed group tax employer and requires separate results for each group employer.

To generate the correct data when an employee changes group tax employer, you must enter an action type and reason in the Actions infotype (0000) at the time of changing group employer. In addition, you must ensure that the action type and reason are configured to generate separate results when the action is entered.

To set up the action type and reason, in Customizing for Payroll Australia, go to Group Certificates \(\rightarrow\) Define Action Type and Reason for Change of Group [Extern].

Process Flow
During the payroll run, the payroll program recognises any change of group tax employer by reading the Actions infotype (0000). In the case of a change, the program automatically runs payroll twice – once from the period start date to the date before the change in group tax employer, and a second time from the date of the group tax employer change to the period end date. Each payroll result is stored in a separate payroll results cluster.

The payroll program accurately calculates pay, leave, tax and superannuation for each period, or, if the employee changes group employer during a payroll period, for each partial period.

Leave processing
The payroll program calculates accrued and entitled leave for each run individually. Rollovers of leave are processed in the period in which they occur.

Tax calculations
Tax is applied separately to each payroll result for each group tax employer. The following example shows how tax is calculated when an employee changes group tax employer during a payroll period:

An employee earns $500 per week and pays $104.10 in tax per week. The employee changes group tax employer during the payroll period. The payroll program divides the $500 into $200 against group tax employer A in partial period 01 and $300 against group tax employer B in partial period 02.
Change of Group Tax Employer

The system calculates the tax in partial period 01 as follows:

1. \[ \frac{200}{92.00 \text{ tax}} \times 7 \text{ days in the payroll period} = \frac{1400}{466.66} = \frac{92.00}{466.66} \]

2. \[ \frac{92.00}{3 \text{ days in partial period 01}} \times 3 \text{ days in partial period 01} = \frac{276}{39.43} \]

The system then calculates the tax in partial period 02 as follows:

1. \[ \frac{500 \text{ total gross per payroll period}}{104.10 \text{ tax per payroll period}} = \frac{2600}{104.10} \]

2. \[ \frac{104.10}{39.43 \text{ tax in partial period 01}} \times 39.43 \text{ tax in partial period 02} = \frac{321}{64.67} \]

This results in the employee paying a total of $104.10 ($39.43 + $64.67) in tax when he or she changes group tax employer during a payroll period.

**Superannuation**

Superannuation contributions are calculated based on the pay an employee receives in each payroll run regardless of a change in group tax employer.

Super guarantee contributions are only calculated in the final payroll run of the calendar month. If there is a change in group tax employer in the final payroll period of the month, then the super guarantee contribution is calculated in the second payroll run of the period as illustrated in the following example:

**Group certificates**

The *Group Certificates* program issues separate group certificates on a change of group tax employer. The certificates specify the employee’s earnings within each group employer.

**Reporting**

The leave, superannuation and payroll reports display an employee’s pay details for each group tax employer.
An employee earns $1000 with group tax employer A and then transfers to group tax employer B where he or she earns another $500. The report displays $1,000 against group tax employer A and $500 against group tax employer B.
Net Part of Payroll

Purpose

This component enables you to determine an employee’s net remuneration, according to contractual requirements. Net pay is the amount paid after the deduction of tax and social insurance contributions from gross remuneration.

You can use different gross values to calculate deductions. For this reason, you form different totals during a payroll run which you then use for future processing.
Taxation

Purpose
The Taxation component calculates the amount of tax that an employee must pay each payroll period to the Australian Tax Office.

Features
The standard system enables you to maintain and process the following tax data and calculations:
- Employee Tax Information [Seite 482]
- Tax on Bonuses and Commission [Seite 489]
- Tax Across Multiple Payroll Periods [Seite 491]
- Tax on Termination [Seite 493]
- Overriding Tax [Seite 496]
- Fixed Tax on Payments [Seite 498]
- Tax Reporting [Seite 499]
Employee Tax Information

Definition
Employee tax information is used by the Australian payroll driver to calculate the amount of tax employees must pay each payroll period.

Structure
Employee tax information consists of many pieces of information. To ensure that an employee’s withholdings are processed correctly, the following master data infotypes should be maintained:

- Tax Australia
  The Tax Australia infotype (0188) stores all the details required to tax employees.
- Tax File Number Australia
  The Tax File Number infotype (0227) stores the employee’s tax file number [Extern].

See also:
Tax Australia (Infotype 0188) [Seite 483]
TFN Australia (Infotype 0227) [Seite 487]
Creating Employee Tax Details [Seite 488]
Tax Australia (Infotype 0188)

Definition

The Tax Australia infotype stores all the information required to calculate an employee’s tax contributions in the payroll run.

Employees who do not have a tax infotype are rejected during the payroll run.

Use

The Tax Australia infotype is used to enter, maintain and display the following tax data:

Tax File Number Information

You can display the tax file number [Exter] details on the Tax Australia infotype screen. However, the tax file number details are entered and stored in TFN Australia (Infotype 0227) [Seite 487]. In the Tax Australia infotype, any person not authorized to access the tax file number can see whether a number exists, but cannot see the actual number. The date that the tax file number was entered is also shown.

The TFN Australia infotype can be accessed from the Tax Australia infotype.

Tax Details

- Tax scale

The tax scale is a mandatory field, and is used to determine the level of tax that an employee is to pay. The standard system contains the following tax scales:

<table>
<thead>
<tr>
<th>Tax Scale</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>No Tax</td>
</tr>
<tr>
<td>1</td>
<td>No Tax Free Exemption</td>
</tr>
<tr>
<td>2</td>
<td>Tax Free Threshold</td>
</tr>
<tr>
<td>3</td>
<td>Non-Residents</td>
</tr>
<tr>
<td>4a</td>
<td>No Tax File Number - Residents</td>
</tr>
<tr>
<td>4b</td>
<td>No Tax File Number - Non-Residents</td>
</tr>
<tr>
<td>5</td>
<td>Full Medicare Levy Exemption</td>
</tr>
<tr>
<td>6</td>
<td>Half Medicare Levy Exemption</td>
</tr>
<tr>
<td>7</td>
<td>No Leave Loading</td>
</tr>
<tr>
<td>8</td>
<td>Flat Tax Percentage</td>
</tr>
</tbody>
</table>
If required, you can set up user-defined tax scales. For details on setting up user-defined tax scales, refer to the section Create Tax Scales [Extern] in Customizing for Payroll Australia.

- **HECS/SFSS**

  The HECS/SFSS field is used to indicate whether the employee is paying the Higher Education Contribution Scheme tax or SFSS (Student Financial Supplement Scheme) or both and whether the HECS contribution is normal, voluntary or both.

  If an entry is made in this field, an extra percentage of tax is taken according to the current tax rules.

  The SAP System contains the following HECS/SFSS Contributor Scales:

<table>
<thead>
<tr>
<th>HECS/SFSS Contributor Scale</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank</td>
<td>No HECS/SFSS Contribution</td>
</tr>
<tr>
<td>X</td>
<td>HECS Contributor only</td>
</tr>
<tr>
<td>V</td>
<td>Voluntary HECS Contributor only</td>
</tr>
<tr>
<td>B</td>
<td>Both normal and voluntary HECS Contributor</td>
</tr>
<tr>
<td>S</td>
<td>SFSS Contributor only</td>
</tr>
<tr>
<td>C</td>
<td>Both normal HECS and SFSS</td>
</tr>
<tr>
<td>Y</td>
<td>Both Voluntary HECS and SFSS</td>
</tr>
<tr>
<td>A</td>
<td>All normal HECS, Voluntary HECS and SFSS combined</td>
</tr>
</tbody>
</table>

- **Group certificate issued**

  The Group certificate issued field is updated whenever a group certificate is issued for an employee. The last financial year in which the group certificate was issued is entered in this field. You can update this field manually if a manual group certificate has been issued for the employee. An entry in this field for the current financial year stops a group certificate from being produced for the employee when group certificates are run for the current financial year.

**Flat Tax Details**

- **Tax amount**
This is the flat tax amount that the employee is to pay each payroll period. It is used in conjunction with tax scale 9.

- **Tax percentage**
  This is the tax percentage that the employee is to pay each payroll period. The percentage is based on the employee’s taxable gross income. This field is used in conjunction with tax scale 8.

**Tax Exemption Details**

- **Medicare levy [Extern] exemption**
  A Medicare levy is applied to the standard Australian tax scales. Depending on the number of dependents and the amount earned, some employees are exempt from paying part of the levy.

  This field indicates that an employee is to receive a Medicare levy exemption. The exemption is based on the employee’s taxable gross earnings and on the number of his or her dependents. A Medicare levy exemption is only valid for tax scales 2, 6 and 7.

- **Number of dependents**
  The *Number of dependents* field is used in conjunction with the *Medicare Levy Exemption* field. This field specifies the number of dependents that the employee has declared on the Medicare Levy Variation Declaration.

- **Tax rebate [Extern]**
  Some employees are eligible for a tax rebate. The *Rebate* field holds a key specifying the type of rebate the employee is eligible to receive. The rebate key links to an annual rebate amount received by the employee. This amount is shown in the *Tax rebate amt* field. The standard system contains the following rebate types:

<table>
<thead>
<tr>
<th>Rebate</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CH</td>
<td>Child Housekeeper or Housekeeper</td>
</tr>
<tr>
<td>FA</td>
<td>Family Tax Assistance</td>
</tr>
<tr>
<td>IR</td>
<td>Invalid Relative</td>
</tr>
<tr>
<td>PA</td>
<td>Parent or Parent-In-Law</td>
</tr>
<tr>
<td>SO</td>
<td>Sole Parent</td>
</tr>
<tr>
<td>SP</td>
<td>Spouse, No Dependent Child</td>
</tr>
<tr>
<td>SZ</td>
<td>Special Zone</td>
</tr>
<tr>
<td>ZA</td>
<td>Zone A</td>
</tr>
<tr>
<td>ZB</td>
<td>Zone B</td>
</tr>
</tbody>
</table>
If required, you can set up user-defined rebate keys and amounts. To do this, refer to the sections Create Rebate Codes [Extern] and Define Rebate Amounts [Extern] in the Implementation Guide.

- **Tax rebate amount**

  This field specifies the actual annual amount of tax rebate that an employee receives. The amount can be determined indirectly for a rebate key using a look-up table. The look-up table must store a non-zero amount for an associated rebate key. The rebate key that has been entered can determine this amount, or an annual amount can be entered directly into this field. There are two ways of entering an amount directly for a rebate key:

  - If there is no value in the rebate field when the amount is directly keyed. The amount that is in this field is divided by the number of periods that the employee is paid per year, and the resulting amount is subtracted from the amount of calculated tax each period.

  - If there is a zero rebate amount stored in the look-up table for an associated rebate key. The amount entered is not overridden by the amount held on the look-up table. The annual rebate amount should be entered directly. This can be specifically used for Family Tax Assistance, where each employee may have a different rebate amount. An appropriate warning message is displayed before saving the rebate amount in Taxation Australia (infotype 0188). This is to explain how the rebate amount is saved for the rebate key specified.

  An amount can be indirectly determined on Taxation Australia (infotype 0188) for a rebate key:

  - If there is a non-zero amount held against the field on the look-up table. The amount stored in the look-up table always overrides the amount entered on the annual rebate amount in Taxation Australia (infotype 0188). An appropriate warning message is displayed before the rebate amount is saved.
TFN Australia (Infotype 0227)

Definition

The *Tax File Number* infotype specifies an employee’s tax file number [Extern].

Use

This information is maintained in a separate infotype for security reasons. There are strict rules within Australia regarding the use and display of an employee’s tax file number. By storing the number in a separate infotype you can determine who is authorized to access the number.
Creating Employee Tax Details

Prerequisite
You must create a Tax Australia infotype for all employees.

Procedure
1. Choose Human Resources → Personnel management → Administration → Maintain master data.
   The Maintain HR Master Data screen appears.
2. Enter the employee’s personnel number.
   If you cannot find an employee’s personnel number, use the Matchcode function.
3. In the Infotype field, select Tax Australia (infotype 0188) by entering the name or number.
4. Choose Create.
   The Create Tax Australia screen appears.
5. In the Tax scale field, enter the required tax scale.
   If necessary, use the down arrow to select a tax scale.
6. If required, choose HECS contributor.
7. If required, enter Flat tax details.
8. If required, enter Taxation exemption details.
9. If you have the necessary authorization, choose Tax file number.
   The TFN Australia (infotype 0227) screen appears.
10. Enter the employee’s tax file number.
11. Save your entries.
   The tax file number details for the employee are recorded and the Tax Australia screen appears.
12. Save your entries.
**Tax on Bonuses and Commission**

**Purpose**

Certain bonuses or commissions are paid to employees over a number of payroll periods. As a result, the tax that is paid on the bonus can be spread over the relevant periods. This reduces the amount of tax the employee has to pay on the bonus.

**Prerequisites**

To spread the tax for a bonus payment across a number of payroll periods, the bonus must be paid against a wage type that is set up for marginal (bonus) tax.

When paying a bonus where the tax is spread across more than one period, the bonus payment must be entered into the *Recurring Payments and Deductions* infotype (0014). The number of periods to spread the tax across is entered in the *Interval* field.

The *from* and *to* dates of the infotype must correspond to the date of the payroll period in which you want to pay the bonus. If the date applies to more than one period, the payment can result in the bonus being paid more than once.

**Process Flow**

The following process describes how tax on bonuses is calculated for a number of payroll periods:

1. The number of periods to tax the payment across is derived from the *Interval* field of the bonus payment in infotype 0014.
2. The bonus amount is divided by the number of periods.
3. The resulting amount is added to the normal taxable gross for the period, not including the bonus.
4. This amount is then taxed according to the employee’s tax scale.
5. The tax calculated for the normal taxable gross, without the bonus, is subtracted from the tax calculated in step 4.
6. The resulting tax value is then multiplied by the number of periods determined in step 1, giving the amount of tax for the bonus payment.

**See also:**

*Creating a Bonus Payment with Marginal Tax [Seite 490]*
Creating a Bonus Payment with Marginal Tax

Use
An employee may receive a bonus or commission for several payroll periods. If the bonus is taxed marginally across the relevant periods, the employee pays less tax than if the payment is taxed in the current payroll period only.

Procedure
1. Choose Human Resources → Personnel management → Administration → Maintain master data.
   The Maintain HR Master data screen appears.
2. Enter the employee’s personnel number.
3. In the Infotype field, select the Recurring Payments and Deductions record (infotype 0014) by entering the name or number.
4. Choose Create.
   The Create Recurring Payments/Deductions screen appears.
5. In the From date and the To date fields, enter the dates of the payroll period the bonus covers.
6. Enter the bonus wage type that is set up to be marginally taxed.
7. In the Amount field, enter the bonus amount.
8. In the First payment date field, enter the date of the payment.
9. In the Interval field, enter the number of payroll periods to tax the bonus across.
10. In the Name of unit field, enter the time unit.
11. Save your entries.
Tax Across Multiple Payroll Periods

Purpose
You may be required to spread the tax that an employee has to pay over a number of payroll periods.

Instead of being paid in the first payroll period, a new employee receives two period’s worth of payments in the second payroll period. However, you want the two payments to be taxed as if they came from two periods and not one.

Process Flow
The following process describes how tax is spread across multiple payroll periods:

1. A tax spread wage type is set up in the sections Assign Wage Types to Wage Type Group Tax Spread [Extern] and Define Tax Spread Wage Types [Extern] in Customizing for Payroll Australia.

2. In the Additional Payments infotype (0015), the tax spread wage type is entered in the Wage type field.

3. The number of periods to spread the tax across is entered in the Number field of the Additional Payments infotype.

See also:
Spreading Tax Across Multiple Payroll Periods [Seite 492]
Spreading Tax Across Multiple Payroll Periods

12. Choose Human Resources → Personnel management → Administration → Maintain master data.

   The Maintain HR Master data screen appears.

13. Enter the employee’s personnel number.

14. In the Infotype field, select the Additional Payments record (infotype 0015) by entering the name or number.

15. Choose Create.

   The Create Additional Payments screen appears.

16. In the Wage type field, enter the tax spread wage type set up in Customizing for Payroll Australia.

17. In the Number field, enter the number of periods you want to spread the tax across.

18. Save your entries.
Tax on Termination

Purpose

On termination of employment, there are different payments made to an employee, such as unused leave and redundancy payments. These payments attract different levels of tax.

Process Flow

This process describes how you define which payments attract what type of tax. The type of tax is determined by the wage type against which the payment is made. For details on setting up tax wage types, refer to the section Tax Wage Types [Extern] in Customizing for Payroll Australia.

See also:

Leave Payments Tax on Termination [Seite 494]
Marginal Tax on Termination [Seite 495]
Leave Payments Tax on Termination

Definition

On termination of employment, an employee may have some unused leave. This leave must be paid to the employee at the employee’s current rate of payment. The tax that is applied to the leave payments depends on the type of leave and when it was accrued.

Use

For the leave payments to be taxed correctly on termination, the leave that was accrued in the differing tax brackets must be stored separately under different quota types. For example, annual leave accrued before 08/17/1993 should be stored under one quota type, and leave accrued after 08/17/1993 should be stored under another quota type. The payments of these quota types can then be paid against different wage types, and can therefore have different rates of tax.

Integration

For details on how to set up quota types to be paid against certain wage types, refer to the Implementation Guide.
Marginal Tax on Termination

Definition

Some termination payments are taxed marginally, that is, the payment is taxed as if it was earned over a full year.

Use

To tax payments in this way, they must be paid against specific wage types that are set up to have marginal tax.

The formula for calculating marginal termination tax is as follows:

1. Divide the payment by the number of periods for which the payment is relevant. For weekly paid employees this is 52, for bi-weekly 26, and for monthly 12.
2. Add this amount to the average taxable gross for the year.
3. Tax this amount using the employee’s tax infotype details.
4. Subtract the average tax paid by the employee for the year from the tax calculated in step 3.
5. Multiply the tax result from step 4 by the number of periods determined in step 1 to give the amount of tax payable on the termination payment.

This calculation is done automatically when a payment is set up to have marginal tax on termination.

Integration

For details on setting up marginal tax on wage types, refer to the Implementation Guide.
Overriding Tax

Purpose
This process describes how to override any automatic calculation of tax that is produced by the payroll run.

Process Flow

Overriding Standard Tax
Tax is calculated during each payroll run depending on an employee’s Taxation Australia infotype (0188) and the amount of taxable gross he or she receives. There are two ways that standard taxation can be overridden for a person, and a specific amount of tax paid for the one period.

- Create a temporary Tax override infotype
  With this method, a temporary tax infotype is created only for the specific periods for which the tax is to be a specific amount.

- Override tax in the Additional Payments infotype (0015)
  With this method, a particular wage type that has been defined as a standard tax override wage type can be entered into the Additional Payments infotype (0015) with the amount of tax for the particular period.

Overriding Termination Tax
On termination of employment, different types of tax are applied to the termination payment for the different lump sum calculations. You can override each calculation of termination tax with a different wage type. The wage types should be entered in the Additional Payments infotype (0015) with the tax amount required. Particular wage types override particular termination tax calculations.

For details on setting up tax override wage types, refer to Assign Wage Types to Wage Type Group Tax Overrides [Extern] and Define Tax Override Wage Types [Extern] in Customizing for Payroll Australia.

See also:
Creating a Temporary Tax Override Infotype [Seite 497]
Creating a Temporary Tax Override Infotype

Use

The Taxation infotype (0188) is used within payroll to calculate the tax for a particular employee. You can override the tax value calculated with a fixed tax amount.

You receive a notification from the tax department stating that your employee John Smith must pay a flat amount of tax of $500.00 each payroll period for the period from 01/03/1998 to 01/04/1998.

Procedure

1. Choose Human Resources → Personnel management → Administration → Maintain master data.
   The Maintain HR Master Data screen appears.
2. Enter the employee’s personnel number.
   You can use the Matchcode function to find the relevant personnel number.
3. In the Infotype field, enter the infotype 0188.
4. Choose Create.
5. In the From date field, enter the start date of the period for which you want to override the tax.
6. In the To date field, enter the end date of the period for which you want to override the tax.
7. In the Tax scale field, enter 9.
8. In the Tax amount field, enter the amount of tax to be paid for a payroll period.
9. Save your entries.
Fixed Tax on Payments

Purpose
This process describes how to tax a payment at a particular rate of tax.

The Australian Tax Office (ATO) instructs you to tax a particular allowance at 30%.

Process Flow
1. Assign a tax percentage to the relevant wage types.
   To do this, refer to Assign Taxation Percentage to Fixed Tax Wage Types [Extern] in Customizing for Payroll Australia.
2. Enter the tax percentage in the Tax Australia infotype (0188)
Tax Reporting

Use

Taxation is reported using the standard payroll reports.

For details, see SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia [Seite 716] → Payroll Reporting [Seite 718].
Superannuation

Purpose

The Superannuation component offers a comprehensive method of processing company and employee contributions to superannuation funds. It allows you to record all the information required by the SAP HR Payroll Australia component to calculate the superannuation contributions to be paid into your employees' superannuation funds.

Implementation Considerations

To use the Superannuation component, you must carry out the steps under Superannuation in Customizing for Payroll Australia.

Features

The Superannuation component is broadly divided into two contribution categories:

- Superannuation contributions
  These contributions are discretionary and allow both employers and employees to pay contributions to various superannuation funds.

- Super guarantee contributions (SGC)
  Under super guarantee contributions employers are required to provide a minimum level of superannuation support for their employees. The minimum level of support is prescribed by law and set in scales that can change from year to year. Employers who fail to comply with the prescribed minimum level of support are required to pay a non-tax-deductible charge, known as the superannuation guarantee charge, plus an additional amount as interest that the contributions would have earned.
Superannuation (Infotype 0220)

Definition
For superannuation contributions to be calculated by the SAP HR Payroll Australia component, you must enter data for each employee in the Superannuation infotype [Extern].

The infotype enables you to store:

- Superannuation details such as the fund type and an employee’s medical category
- Discretionary superannuation contributions made by both the employer and the employee
- Super guarantee contributions made by the employer

It is not mandatory to store data in the Superannuation infotype for payroll to run successfully.

Use
All the information required to calculate your employees’ superannuation contributions is stored in this infotype.

For new employees, you can create the Superannuation infotype through a hiring action. If your employees’ superannuation details change, you can create new superannuation records in master data by delimiting the old records and entering a new validity period for the new records.

Structure
The fund code is the only mandatory field in the Superannuation infotype. You must enter a fund code for payroll to perform superannuation calculations successfully.

Integration
If employees decide to change the contributions they make to a particular fund, you need to create new records to reflect these changes. Should you receive a request to change contribution amounts after payroll has been run for a particular period, changing the record will trigger retroactive accounting.
Superannuation Contributions

These contributions are discretionary and can be made by both employers and employees.

Employers usually pay the super guarantee contribution to all employees irrespective of eligibility limits, and may choose to contribute more than the statutory minimum super guarantee contribution.

Employees may choose to pay a voluntary contribution in addition to the super guarantee contribution paid by their employer.
**Employer Contributions**

**Purpose**

In addition to super guarantee contributions, your company may pay superannuation contributions into an award superannuation fund or another type of company superannuation fund. In this case, the superannuation contribution made by your company can be a percentage of an employee’s earnings or a fixed amount that varies from employee to employee.

If the amount contributed into these funds for each employee is below the minimum level specified by the superannuation guarantee contribution (SGC) scheme, then you must either:

- Increase the contribution to at least the minimum contribution specified by SGC legislation
- Set up an SGC fund for each employee to top up the other superannuation contributions

**Process Flow**

Employer contributions for each employee are calculated during payroll, and displayed in the superannuation reports. Contribution calculations and the eligibility of individual employees can be influenced by rules set up for the relevant superannuation fund. The calculation may be based on a percentage of the employee’s earnings, or on superable salary, or on a fixed amount per payroll period.

If you do not want to use the default percentages defined for each fund, you can change the contribution percentage for individual employees in the Superannuation infotype (0220).

By configuring the Superannuation [Extern] section of Customizing for Payroll Australia accordingly, you can have more than one valid superannuation fund.
Employee Contributions

Purpose
This process describes how an employee’s super guarantee contributions are calculated in payroll.

Employees can choose to make percentage contributions in addition to the contributions paid by their employer. The contributions can be made to multiple funds with a different percentage allocated to each fund, and can be treated as a pre-tax contribution, or salary sacrifice, or an after-tax contribution.

Process Flow
The contribution amount can be a percentage of ordinary time earnings or a straight dollar amount per payroll period. Unlike the employer super guarantee contribution, which takes into account an employee’s age and other rules, the employee contribution is a straightforward calculation of a percentage or a fixed amount.

Result
The amounts calculated can be displayed in superannuation reports [Seite 722].
Super Guarantee Contributions

Purpose
This process describes how a company’s super guarantee contributions (SGC) are calculated in payroll for each employee.

Employers must make an SGC percentage contribution for each employee. The contribution can be made to multiple funds with a different percentage allocated to each fund, and the employer can contribute above the SGC minimum.

Process Flow
The employer’s contributions are calculated in the last payroll period of the calendar month. The calculation takes into account SGC rules [Seite 506] governing the employee’s age, the number of hours worked if the employee is under age, and the employee’s wage and salary earnings. The SAP System then calculates the appropriate percentage of the employee’s ordinary time earnings.

You can override the employer’s SGC calculated by the SAP System by entering a fixed amount in the Superannuation infotype (0220). In addition, instead of using the default percentages defined by legislation, you can change the contribution percentage for individual employees.

There can only be one fund set up for SGC contributions at any one time. This fund works as a top-up fund if the employee is a member of other funds as well. The SGC fund tops up the company contribution amount to the minimum levels prescribed by law.

Result
The results of the super guarantee calculations can be displayed in superannuation reports [Seite 722].
Super Guarantee Contribution Rules

Super Guarantee Contribution Rules

Super guarantee contributions (SGC) are governed by a set of rules defined by the federal government. Employers must follow these rules.

SGC Rules

Eligible employees

Employers do not have to provide superannuation support for the following categories of employee:

- Employees paid less than the minimum earnings threshold in a calendar month
  - The figure is based on the employee’s total earnings including basic pay, overtime payments, allowances, bonuses, shift and casual loadings, annual and sick leave payments and redundancy payments.
- Employees under 18 years of age working 30 hours or less per week
- Non-resident employees paid for work outside Australia
- Employees aged 65 and above
- Some foreign executives
- Employees paid to do work of a domestic or private nature for not more than 30 hours per week
- Employees whose earnings amount to more than the maximum earnings ceiling

Contribution amount

The contribution amount is a percentage of your employees’ ordinary time earnings in the calendar month. The ordinary time earnings include the employees’ basic pay, annual leave, and sick leave payments. They do not include any overtime or allowances.

The contribution percentage is based on your company’s annual national payroll in the financial year. The percentage for companies with a payroll greater than $1 million gradually increases from year to year.

Contribution payments

Support has to be provided for each employee, so an employer must keep separate records for every employee. Contribution payments are made monthly and a running total is reported quarterly.

Self-assessment

Employers assess their own liability to pay the superannuation guarantee charge [Seite 500]. They calculate the amount that should be spent on superannuation contributions for each eligible employee, and the amount they actually contribute. If there is a shortfall in contributions, the employer must pay a superannuation guarantee charge.

See also:

Super Guarantee Contributions [Seite 505]
Superannuation Reporting

Use
This function displays and prints reports that provide information on compulsory and voluntary superannuation contributions made by employers and employees to superannuation guarantee contribution (SGC) funds and other superannuation funds.

The data can be broken down according to user-defined criteria such as company code and personnel number, and can be grouped into key data that is displayed in the following reports:

- Superannuation report
- ATO notification report

Prerequisites
In the Superannuation [Extern] section of Customizing for Payroll Australia, you must define whether your superannuation wage type(s) are reported as employer or employee contributions.

You must create a record for each employee in the Superannuation infotype (0220), and have payroll results for your employees.

Features
The reports list superannuation details per fund. You can run the reports for several payroll periods. If the start and end dates of a report do not coincide with a payroll period, the report considers all the payroll periods that overlap with the start and end dates of the report.

If you run a report for more than one payroll area and each area has a different payroll period, the SAP System processes each payroll area separately and prints a separate page for each payroll area.

Superannuation report
From within this report, you can trigger three separate reports:

- Superannuation report
  The report displays subtotals based on user-defined selection criteria, and provides the following key data:
  - “For” period and “In” period
  - “For” period and “In” period end dates
  - Payroll type
  - Fund code and name
  - Employee number and name
  - Employee fund membership number
  - Company contributions
  - Employee contributions
  - Employee ordinary time earnings
Superannuation Reporting

- Wages and salary
- Super guarantee contribution amount
- Messages
- Hiring and termination dates (if they take place within the current payroll period)

- Super guarantee contribution (SGC) report
  This report only produces figures as at the end of a calendar month. You must therefore run the report only in the last payroll period of the month. If the report is run at any other time, a message appears reminding you to run the report at the end of the month.
  
  The report displays subtotals based on user-defined selection criteria, and provides the following key data:
  - “For” period and “In” period
  - “For” period and “In” period end dates
  - Payroll type
  - Fund code and name
  - Employee number and name
  - Employee fund membership number
  - Employee ordinary time earnings
  - Wages and salary
  - Super guarantee contribution amount
  - Company super guarantee contributions
  - Messages
  - Hiring and termination dates (if they take place within the current payroll period)

- Non-SGC report
  This report displays subtotals based on user-defined selection criteria, and provides the following key data:
  - “For” period and “In” period
  - “For” period and “In” period end dates
  - Payroll type
  - Fund code and name
  - Employee number and name
  - Employee fund membership number
  - Company contributions
  - Employee contributions
  - System messages
Employee hiring and termination dates (if they take place within the current payroll period).

**ATO notification report**

The Australian Taxation Office (ATO) notification report calculates company superannuation guarantee contributions (SGC) for a specified period, and compares the statutory SGC amount with the actual amount contributed by the company. If the company contribution is less than the statutory minimum, the shortfall is printed on this report.

The ATO notification report displays SGC shortfall information for all employees or a group of employees. The report displays the employee name, address, date of birth and tax file number, as well as the amount of the shortfall in SGC and the nominal interest calculated on the shortfall. The administration and per employee administration charges are also printed on this report.

If there is no SGC shortfall, a message is displayed on the report.

See also:

- Executing Superannuation Reports [Seite 725]
- Executing ATO Notification Reports [Seite 726]
- Printing Superannuation Reports [Seite 727]
Executing Superannuation Reports

Use
This function enables you to display the following reports:
- Superannuation report
- Super guarantee contribution (SGC) report
- Non-SGC report
All the reports are executed in the same way.

Prerequisites
You must have a record for each employee in the Superannuation infotype (0220), and have payroll results for each employee.

Procedure
1. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Lists/statistics → Superannuation reports → Superannuation report.
   The Australian Superannuation Reporting screen appears.
2. Define the period for which you want to run the report.
3. Choose the relevant selection criteria (for example, the employee groups, cost centers or personnel numbers) for which you want to run the report.
4. Enter the relevant superannuation fund code(s).
5. To run the Superannuation report, set the Display all superannuation information field indicator.
   Or
   To run the SGC report, set the Display only SGC superannuation information field indicator.
   Or
   To run the Non-SGC report, set the Display non-SGC superannuation information field indicator.
6. To display subtotals, set the Display totals only field indicator, and define how you want the data to be sorted.
7. Choose Program → Execute.

See also:
Superannuation Reporting [Seite 722]
Printing Superannuation Reports [Seite 727]
Executing ATO Notification Reports

Prerequisites
You must first create a record for each employee in the Superannuation infotype (0220), and run payroll for your employee(s).
To display SGC shortfalls for the year, you must run the report at the end of the financial year.

Procedure
1. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Lists/statistics → Superannuation reports → ATO notification.
   The SGC - Australian Tax Office Notification Report screen appears.
2. Enter the dates of the financial year for which you want to run the report.
3. To run the report for a selection of employees, enter the relevant personnel numbers, personnel areas, personnel subareas, employee groups and subgroups.
   Or
   To run the report for all employees, leave the fields blank.
4. Choose Program → Execute.

   The report is sorted by default into company code, employee last name and employee first name.
   To display or print further employee numbers, choose Further selections on the SGC - Australian Tax Office Notification screen.

See also:
Superannuation Reporting [Seite 722]
Printing Superannuation Reports [Seite 727]
Printing Superannuation Reports

Use
In addition to displaying reports, the standard system enables you to print your superannuation reports.

Prerequisites
You must first run either the Superannuation report or the ATO notification report.

Procedure
4. In the report screen, choose List → Print.
   The Print Screen List screen appears.
5. In the Output device field, enter the printer name.
6. Choose Output → Print.
Retroactive Superannuation Calculations

Use
This function calculates compulsory and discretionary superannuation contributions retroactively.

Features
Retroactive superannuation contributions are split into two parts:

- Retroactive company contributions to super guarantee contribution (SGC) and superannuation funds
  - Super Guarantee Contribution Funds
    The difference in the superable earnings is carried forward to the period when the earnings are actually paid, that is, the current payroll period. The difference is added to the superable earnings of the current payroll period, and the SGC is recalculated based on the new earnings figure.
  - Superannuation Funds
    The employer’s contributions are recalculated for the periods for which retroactive accounting is run. The new amounts are compared with the original contributions. The difference in the employer’s contributions is carried forward to the current payroll period and contributed in this period.

- Retroactive employee contributions to superannuation funds
  The employee’s contributions are recalculated for the periods for which retroactive accounting is run. The new amounts are compared with the original contributions. The employee contributions are processed like any other deduction and are carried forward as a difference in net pay in the current payroll period.
End-of-Year SGC Processing

Use

If you suspect that certain employees have not received the minimum superannuation guarantee contribution (SGC), you can generate an ATO Notification Report to determine if the actual contribution is less than the statutory minimum contribution. If this is the case, the report displays the amount of the shortfall, the interest payable on the shortfall, and any statutory administration charges.

If the actual contribution is more than the statutory minimum contribution, the report displays a no SGC shortfall message.

See also:

Executing ATO Notification Reports [Seite 726]
Deductions

Purpose

This component calculates all payments to third-parties with the exception of taxes and garnishments, which are deducted directly from the employee’s pay. Maximum thresholds for deductions and outstanding payments are taken into account.

Features

Within payroll, deductions can refer to gross remuneration or to net remuneration. The following types of deductions are differentiated between:

- Statutory deductions
  Statutory deductions include taxes or social insurance payments, for example.

- Voluntary deductions
  Voluntary deductions include payments to a savings plan or a voluntary insurance policy that the employer takes out for the employees.

Moreover, you differentiate between:

- **One-off Deductions [Seite 217]**
  for example a donation

- **Recurring Deductions [Seite 214]**
  for example, in the case of imputed income or a savings plan.
## Arrears Processing for Deductions

### Use

Arrears processing refers to the [Voluntary Deductions](#) that are deducted from the net remuneration. You enter these voluntary deductions using deduction wage types in the [Recurring Payments/Deductions](#) (0014) and [Additional Payments](#) (0015) infotypes, and in country specific infotypes for employer benefits. The system compares the deduction amount with the remaining net amount and, if possible, makes the deduction. When making this comparison the system takes a calculated country-specific minimum net amount into account.

Arrears processing is responsible for determining how payroll is performed if the deductions exceed the net remuneration.

Your employee takes part in a savings plan which means that a fixed amount is withheld from the net remuneration in each payroll period.

Moreover, regular amounts are deducted from the net remuneration and are paid to different institutions or towards company insurance.

If the sum of all the deductions is greater than the net amount, then all the deductions that were entered in the master data cannot be made during the payroll process.

Unpaid absences, for example, can lead to unexpectedly low net remuneration. If all deductions are taken in full, the difference between total net remuneration and the sum of all deductions becomes an outstanding debt owed to the employee.

### Integration

You make the settings for arrears processing in Customizing for Payroll under *Deductions* → *Arrears and Priorities*.

### Features

Arrears processing is controlled using deduction wage type characteristics. You assign the following characteristics to deduction wage types for arrears processing:

- **Priority**

  The priority specifies the sequence in which the deduction wage types are processed. If deduction wage types exist with the same priority in payroll, then the system sorts them according to name.
If you use the Garnishment component, you should assign the garnishment wage type with the highest priority.

- Arrears-characteristics

You must also specify in Customizing the way in which deduction wage types should be processed if the net amount does not provide sufficient cover. The possibilities available for arrears characteristics are described in detail in Customizing for Payroll under Deductions → Arrears and Priorities → Define Priority for Deduction [Extern]
Technical Procedure of Arrears Processing

Purpose
For more information on the purpose of this process, see Arrears Processing for Deductions [Seite 516].

Process Flow

Arrears Processing

Legend:

Tables
- ARRRS Arrears table
  This contains the amounts of the deductions, which could not be processed in the previous period. These amounts are added to the amounts of the deduction wage types for the current period and are included in the current processing. Deduction wage types which cannot be processed in the current period and which are allocated with corresponding arrears characteristics are placed in the ARRRS table to be processed in the next period.
- DDNTK Deductions not taken
  Contains amounts of deductions that could not be taken from the net amount in the current period.

Functions
PRART Processing of Table OARRS
PRART Processing of Table DDNTK
PRPRI Processing of priorities table
PREND Modify table DDNTK at end of loop

For more information on the functions use transaction PDSY HR Documentation Maintenance or go to the menu for Payroll using the menu path Tools→ Maintenance Tools→Function/Operation.

The steps in the graphic are performed in the following way:
1. Import of the deductions
   The following deduction wage types are imported to the input table (IT) for further processing:
   - Amounts from the ARRRS table from the previous period with function PRART
Using personnel calculation rule X014 you can determine whether a deduction wage type, which was not processed in the previous period, should be processed during the current period.

- Current amounts from the Additional Payments (0015) and Recurring Payments/Deductions (0014) infotypes.

2. Processing of table DDNTK: Deductions not taken

This processing step does not take place the first time the loop is run because the table is empty.

The amounts of the deduction wage types in the input table (IT) are reduced by the amounts of table DDNTK in function PRDNT. Further processing, such as tax calculations, is based on these reduced deductions.

3. Processing deductions according to priority

Once the net amount has been calculated, the system processes all of the deduction wage types in accordance with their priority and their arrears characteristics. The system checks, using function PRPRI, whether the remaining net amount is sufficient for the deduction, for every deduction wage type involved.

- If the net amount is sufficient, the deduction is not changed.
- If the net amount were not sufficient, the deduction would result in a negative net amount. Therefore, the amount of the deduction wage type must be reduced by the appropriate difference. This difference is stored in table DDNTK. The amount is also added to the ARRRS table according to the arrears characteristic.

After the deductions have been processed the system checks whether deduction wage types need to be reduced, that is, whether table DDNTK is full.

Processing of steps 1 to 3 takes place in a loop, which is performed several times if the deduction wage types have to be reduced.

Since certain deductions can be made from the remuneration before taxation, and since the gross tax amount can change, processing must therefore take place in a loop. For more information see Processing Reduced Gross Tax Amounts [Seite 521].

4. Adjusting table DDNTK

After the last loop has been run, table DDNTK can contain amounts that must be deducted from the deductions for the current period. However, it can also contain amounts from the ARRRS table. Table DDNTK should, however, only contain the amounts which could not be taken into consideration in the current period. This is implemented using function PREND.
Technical Procedure of Arrears Processing

<p>| ARRRS (Start of processing) | 80,00 | Deductions from the previous period |</p>
<table>
<thead>
<tr>
<th>IT 0014</th>
<th>30,00</th>
<th>Deductions from the current period</th>
</tr>
</thead>
<tbody>
<tr>
<td>IT 0014</td>
<td>110,00</td>
<td>Total deductions</td>
</tr>
<tr>
<td>RT</td>
<td>60,00</td>
<td>Amount that could be deducted from the net amount</td>
</tr>
<tr>
<td>ARRRS (End of processing)</td>
<td>50,00</td>
<td>Amount that could not be deducted from the net amount and which is transferred</td>
</tr>
<tr>
<td>DDNTK</td>
<td>50,00</td>
<td>Amount that could not be deducted from the net amount in the current period</td>
</tr>
</tbody>
</table>

Table DDNTK should in fact only contain the amount 30,00 from the Recurring Payments and Deductions Infotype (0014).

Using function PREND the system compares the values of the deduction wage types in table DDNTK with the values in the RT and ARRRS tables. In this way the amount of the current deduction is determined and is written to table DDNTK.

Tables DDNTK and ARRRS are stored along with the payroll results in cluster table PCL2, and can be displayed using report RPCLSTRX.
Processing Reduced Gross Tax Amounts

Use

If the deductions do not affect an employee’s gross tax amount then processing can take place as described in Technical Procedure of Arrears Processing [Seite 518].

Exceptions are deductions which are made from the net salary amount, but which still reduce the gross tax amount. This is the case with donations or company insurance, for example. The processing class that you use for this determines whether a wage type should be deducted from remuneration before or after taxation.

Features

If such a wage type results in a deduction, and part of the amount is placed in table DDNTK, then the system recalculates the gross tax amount. Previously the deduction that was not reduced was used to calculate the gross tax amount. Calculation of the gross tax amount using the new reduced deduction amount results in a higher gross tax amount.

The result of the higher gross tax amount, using the new tax calculation, is a changed net amount. The deductions are then made from this net amount.

<table>
<thead>
<tr>
<th>Payment/deduction type</th>
<th>Calculation 1</th>
<th>Calculation 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total gross amount</td>
<td>3 000,00</td>
<td>3 000,00</td>
</tr>
<tr>
<td>Donations, deduction from remuneration before taxation</td>
<td>500,00</td>
<td><strong>300,00</strong></td>
</tr>
<tr>
<td>Gross tax amount</td>
<td>2 500,00</td>
<td>2 700,00</td>
</tr>
<tr>
<td>Net amount</td>
<td>1 500,00</td>
<td>1 650,00</td>
</tr>
<tr>
<td>Garnishment.</td>
<td>1 000,00</td>
<td>1 000,00</td>
</tr>
<tr>
<td>Loans</td>
<td>200,00</td>
<td>200,00</td>
</tr>
<tr>
<td>Actual deduction for donation</td>
<td><strong>300,00</strong></td>
<td>300,00</td>
</tr>
<tr>
<td>Remaining amount</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DDNTK</td>
<td>200,00</td>
<td>...—</td>
</tr>
<tr>
<td>Payment Amount</td>
<td></td>
<td>150,00</td>
</tr>
</tbody>
</table>

Calculation 1

The total gross amount is reduced by the amount of the donation to the gross tax amount, from which the net amount is then calculated. The amounts for the garnishment and the repayment of loans are deducted from the net amount first, because they have a higher priority than the donation. Only 300,00 of the net amount remain for the deduction of donations. Since the donations amount to 500,00, the 200,00 which cannot be deducted is placed in table DDNTK.
Processing Reduced Gross Tax Amounts

Calculation 2

The gross tax amount must be redefined starting with reduced donation amounts. The loop must therefore be repeated again to process the new gross tax amount and the new donation amount.
Processing Arrears in Retroactive Accounting

Use

When the original payroll is run for a payroll period, deduction wage types are subtracted and paid. This procedure cannot be reversed. If you have to trigger retroactive accounting in this payroll period after you have changed a deductions wage type, then the deduction wage type is processed specially.

Features

The changed amount of the deduction wage type cannot be taken into consideration by the system. In retroactive accounting the amount of the deductions wage type that was processed in the original run is processed again.

Of course, a positive or negative difference can exist between the deduction amount in the original system and the changed deduction amount. This difference can be written to the next payroll period using the Arrears table (ARRRS).

In Customizing for Payroll under Deductions→Arrears and Priorities→Maintain Arrears Deductions for Retroactive Accounting [Extern] you determine how changed deduction wage types should be processed in retroactive accounting.

In retroactive accounting arrears are processed in a different way to that of an original period. Processing in retroactive accounting takes place in function PRDNT, namely before the tax calculation. The loop must therefore be performed again, there is no iteration. Processing in functions PRPRI and PREND does not take place either.
Subsequent Activities

Purpose
The component comprises the activities that you must carry out after payroll (gross - net - payroll).
Wage and Salary Payments

Purpose
This component enables you to pay wages and salaries to employees, while taking into consideration country and bank-specific requirements and specifications. Moreover, you can make certain employee-specific payments to third parties (dependent on the country version), whereby the employee is not the payment recipient. The system offers different variants of wage and salary payments, which are used in various combinations by the individual country versions.

You can find technical information on wage and salary payments and notes on the necessary Customizing settings in the following sections:

- Payment-Related Information in the Master Data [Seite 526]
- Payment-Related Information in the Payroll Result [Seite 527]
- Preliminary Program for Data Medium Exchange [Seite 529]

You can find information on the posting of payment transactions in the documentation for Posting to Accounting, under Integration with the Posting of Payment Transactions [Seite 592].

Scope of Function
You can find information on wage and salary payments in the following sections.
# Payment-Related Information in the Master Data

Certain information from the master data for your employees reappears in the Payroll results. The Wage and Salary Payments evaluates this Information in the Payroll Results [Seite 527], but also accesses certain infotypes directly.

Below is a list of the international infotypes that contain payment-related information.

- Organizational Assignment (Infotype 0001) [Extern]
- Personal Data (Infotype 0002) [Extern]
- Addresses (Infotype 0006) [Extern]
- Bank Details (Infotype 0009) [Extern]
- External Bank Transfers (Infotype 0011) [Extern]

In addition to the infotypes mentioned above, there are other international wage types (e.g., for capital formation) that contain payment-related information. These infotypes will not be discussed here. For more information on international infotypes, see the SAP Library under Human Resources → Payroll → <Country>.

For more information on how the system evaluates the payment-related information in the master data and the payroll results, see Preliminary Program DME [Seite 529].
Payment-Related Information in the Payroll Results

The following tables in the payroll results contain payment-related information that the system evaluates during the wage and salary payments process.

- Payment Information (BT)
- Work Center/Basic Pay (WPBP)

Payment Information table (BT)

Every entry in the Payment Information table (BT) in an employee's payroll results corresponds to a payment that was created in a payroll period for this employee. However, the employee is not necessarily the payment recipient of all payments. A difference must be made, for entries in the Payment Information table (BT), between payments to the employee and employee-specific payments to third parties.

The origin and treatment of employee-specific payments to third parties is country-specific. If, for example, salary elements for an employee are garnished or are retained for capital formation, an entry is created in the Payment Information table (BT) in the employee's payroll results, for payment of the retained amount to a third party (e.g. the creditor or the capital formation institute). The origin of this entry depends on the county version used, and the settings in Customizing. However, employee-specific payments to third parties do not necessarily create an entry in the Payment Information table (BT) for the employee. The reason for this is that in certain country versions these payments are made independent of the Wage and Salary Payments component.

Entries in the Payment Information Table (BT) for Payments to the Employee

- The Payment Method field is always filled.
- The Bank Number and Bank Account fields are filled, if the payment method requires bank details.
- The Recipient, Postal Code and Location fields are filled, if you have manually overwritten the corresponding fields in the Bank Details infotype (0009) [Extern]. If you have not manually overwritten these fields in the Bank Details infotype (0009), the values from the Personal Data (0002) [Extern] and Addresses (0006) [Extern] infotypes are displayed there. In this case, the Recipient, Postal Code and Location fields are not filled in the Payment Information table (BT).

Entries in the Payment Information Table (BT) for Employee-Specific Payments to Third Parties

- The entry in the Payment Information table (BT) for an employee-specific payment to a third party either contains detailed information from the infotype that forms the basis of the payment (Payment Method, Bank Details, Name and Addresses), or a recipient key in the Recipient field. This recipient key refers to Customizing for Personnel Management, where you must store the detailed information mentioned.
Payment-Related Information in the Payroll Results

- The Purpose field in the Payment Information table (BT) is filled, if a purpose was entered in the infotype that forms the basis of the payment.

Note that not all the fields in the Payment Information table (BT) are discussed here. For more information on how the system determines the information on the payment recipient, see Preliminary Program DME [Seite 529], in the “Scope of Function” section.

Work Center/Basic Pay Table (WPBP)

Certain organizational elements from the Organizational Assignment infotype (0001) are stored in the Work Center/Basic Pay table (WPBP) during payroll. These organizational elements are used in the wage and salary payments process (dependent on Customizing) to determine the house bank and the house bank account.

Furthermore, the system uses the Work Center/Basic Pay table (WPBP) to determine the paying company code. Specification of the paying company code is optional in Customizing. If you have not specified a paying company code in Customizing, the system uses the company code that is stored in the Work Center/Basic Pay table (WPBP) in the employee’s payroll results. If the Work Center/Basic Pay (WPBP) table for the employee contains several partial periods as the result of a WPBP Split [Extern], in the payroll period to be processed, the system uses the company code in the last partial period, in which the employee was active, to determine the paying company code.
Preliminary Program DME

Use

To start the preliminary program DME, choose Human Resources → Payroll → Payroll → Bank Transfer → Pre. Program DME from the SAP Easy Access menu.

You use the preliminary program DME to evaluate the payroll results to create payment data. The creation of payment data is the first step in the wage and salary payments process.

You can also use the preliminary program DME if you want to make several partial payments on different dates within a payroll period (Qualified Advance Payment [Seite 86]).

The preliminary program DME can evaluate payments using different payment methods [Extern] in a payment run. The payment medium programs, which further process the data created by the preliminary program DME, select the relevant data records using the payment method.

The preliminary program DME processes both information from the master data [Seite 526] and information from the payroll results [Seite 527] for an employee.

Integration

The payment data created by the preliminary program DME is processed by the country-specific payment medium programs in Accounting to create payment mediums (for example, DME files for the bank, checks). You must start these subsequent programs after the preliminary program DME has evaluated the payroll results for the employee and has created the payment data.

Prerequisites

You have exited payroll for the payroll periods for which you want to make wage and salary payments. (Exception: You make a Qualified Advance Payment [Seite 86] before exiting payroll.)

You have checked or made the following settings in agreement with Accounting.

- Setting up the payment methods (in Customizing for Personnel Management under Personnel Administration → Personal Data → Bank Details → Define Payment Method [Extern])
- Setting up the house banks and house bank accounts (in Customizing for Payroll under Data Medium Exchange → Preliminary Programs for Data Medium Exchange → Set Up House Banks [Extern])
- Defining the Sending Banks (using the Sender Account Number for Data Medium Exchange feature (DTAKT) in Customizing for Payroll under Data Medium Exchange → Preliminary Programs for Data Medium Exchange → Define Sending Banks [Extern])
**Preliminary Program DME**

- **Defining the paying company code** if you do not want to use the company code stored in the Organizational Assignment (0001) infotype (using the Sender Account Number for Data Medium Exchange feature (DTAKT) in Customizing for Payroll under Data Medium Exchange → Preliminary Programs for Data Medium Exchange → Define Sending Banks [Extern]).

- **Assigning the text key for the payment transaction to transfer wage types** (in Customizing for Payroll under Data Medium Exchange → Preliminary Programs for Data Medium Exchange → Check Text Keys for Payment Transactions [Extern])

  This assignment is not necessary in all country versions.

**Scope of Function**

For every current original result for employees processed in a payment run, the preliminary program DME reads the *Payment Information* table (BT) in the payroll results.

In the process, the system performs the following steps for every entry in this table:

- The system determines the information on the payment recipient
  - from the entry in the *Payment Information* table (BT)
  - from the Payee Keys table (T521B), if the entry in the *Payment Information* table (BT) contains a recipient key
  - from the Personal Data (0002) and Addresses (0006) infotypes, if the entry in the *Payment Information* table (BT) does not contain a recipient key and does not contain any recipient data

- The system evaluates the Sender Account Number for Data Medium Exchange feature (DTAKT) to determine the following information:
  - The paying company code
  - The house bank
  - The house bank account

- The system reads the Purpose field in the *Payment Information* table (BT):
  - If the Purpose field is filled, the contents of the field are transferred to the payment data.
  - If the Purpose field is not filled, the following text is used: "Wage/Salary", <Personnel Number>, <Payroll Period> or "Pension", <Personnel Number>, <Payroll Period>.

- The system determines the payment currency:
  - If the Currency field in the *Payment Information* table (BT) contains a currency, this currency is used for the payment.
  - If the Currency field in the *Payment Information* table (BT) does not contain a currency, the currency from the Currency field in the Payroll Status Information table (VERSC) is used for the payment.

- The system reads the bank codes of the house banks and the recipient bank from the Bank Master Record table (BNKA).
The system checks the payment data for consistency. If a payment with inconsistent data exists for an employee, the system does not make any payment for this employee.

For every entry in the Payment Information table (BT) the system creates an entry in the payment data.

**Selection**

The selection screen for the preliminary program DME is country-specific. The following describes only the most important international parameters.

*Set Flag for Transfers*

We recommend that you mark this indicator. It causes the system to mark every processed entry in the Payment Information table (BT) with date and time, to show payment runs carried out later that it is "processed". This prevents entries in the Payment Information table (BT) being accidently processed more than once. If the payroll run is repeated after you have executed the preliminary program DME, the system does not overwrite the entries marked with date and time but performs a difference calculation. That is why you must mark the *Set Flag for Transfers* indicator if you want to perform a qualified advance payment.

*Wage Type*

You can use these input fields to restrict a payment run to certain wage types, for example, to pay the wage types created for *External bank Transfers* (Infotype 0011) separately from the employee's salary.

*Test*

If you mark this indicator, the system only displays the payments to be made as the result for a payment run. It does not create any payment data and does not change any data in the payroll results.

**Output**

The preliminary program DME creates a payment run, which contains payment data. You can clearly identify every payment run using the *Program Run Date* and *Identification Feature* combination. The *Identification Feature* originates from the six-digit system time, at which you started the preliminary program DME. The system replaces the last digit of the six-digit system time in the *Identification Feature* with a P.

You started the preliminary program DME at 09.25 on 04.14.2000. You can clearly identify the payment run created using the *Program Run Date* (04.14.2000) and *Identification Feature* (09251P) combination.
The payment data contained in a payment run is saved in the following tables:

- Control Records for the Payment Program (REGUV)
- Settlement Data from Payment Program (REGUH)
- Processed Items from Payment Program (REGUP)

The data in these tables is further processed by the payment medium programs in Accounting. For more information, see Payments (FI-BL) [Extern].

See also:

Repeating a Payment Run [Seite 533]
Repeating a Payment Run

Use
If a payment run was not carried out correctly (for example, because of a program termination), you have to repeat this payment run.

Prerequisites
When you created the payment run that you now want to repeat, you marked the Set Flag for Transfers indicator.

Procedure
1. Make the same settings on the Preliminary Program DME [Seite 529] selection screen that you made when you created the original payment run.
2. In the Repeat Run: Date and Time fields, enter the date and time for the payment run to be repeated.
   The system uses this entry to evaluate the entries in the Payment Information table (BT) which the preliminary program DME marked with data and time, but for which the date and time correspond to your entries in the Repeat Run: Date and Time fields.
3. If you only want to evaluate entries in the Payment Information table (BT) which have already been marked, select the Flagged Records Only indicator.
   If you do not set this indicator, the system also evaluates the entries in the Payment Information table (BT) which are still not marked with date and time.
4. Choose

   If you do not know the date and time for the payment run to be repeated, proceed as follows:
1. Use the Display Payroll Results [Seite 76] program (Report H99_DISPLAY_PAYRESULT) to display a payroll result (for any employee) that was evaluated during the original payment run.
2. Display the Payment Information table (BT).
3. Select an entry from the Payment Information table (BT) which the preliminary program DME marked with date and time when creating the original payment run.
Repeating a Payment Run

4. Make a note of the values in the Date and Time fields so that you can enter them in the Repeat Run: Date and Time fields on the Preliminary Program DME selection screen.
Wage and Salary Payments by Bank Transfer

Purpose

The system uses this process to provide all the information your house bank needs to transfer the wage and salary payments to your employees. The system creates a DME file and the DME accompanying sheet. Furthermore, you can print a payment summary which lists the individual payments. You can use the payment summary to, amongst other things, post the wage and salary payments manually to Financial Accounting.

Process Flow

1. The preliminary program DME [Seite 529] evaluates the entries in the Payment Information table (BT) in the payroll results for the employees, and creates a payment run which contains the payment data.

2. The payment medium program [Extern] for the bank transfer evaluates the payment data and creates a DME file, the DME accompanying sheet and the payment summary. The DME file contains all bank transactions and is of the same format as the file used by the bank for your country.

3. You provide your house bank with the DME file created, so that the bank transfer can be made.

The following graphic shows the process flow of wage and salary payments by bank transfer.
Evaluating Payroll Results

Procedure

1. Start the preliminary program DME [Seite 529].
2. Make the required entries for Payroll period, Selection and Wage types.
3. Select the Set flag for transfers indicator (see Preliminary Program DME [Seite 529]), and

   select

   The system produces statistics on the personnel numbers evaluated and the entries in the Payment Information table (BT).

4. Make a note of the program run date and the six-digit identification feature. You will have to enter these values at a later stage on the selection screen of the payment medium program, which you use for creating the DME file [Seite 537].

Result

The system evaluates the payroll results for the employees you selected, and saves the payment information as payment data to the database.
Creating a DME File

Procedure

1. Start the payment medium program used for creating DME files.
2. Enter the *program run date* and the *identification feature* of the payment run to be processed.
3. In the *Print control* section, select the *Data medium exchange* and *Print payment summary* indicators.
4. Enter the additional necessary data, and choose [ ].

Result

The system evaluates the payment data for the payment run you entered, and creates a DME file. The DME file contains all bank transactions and is of the same format as the file used by the bank for your country.

Furthermore, the system creates the DME accompanying sheet and the payment summary for this DME file. You can continue to process the DME file created, using **data medium administration** [Seite 538].
Data Medium Administration

Use

Data medium administration (DME administration) helps you to manage the data media that you create in Financial Accounting and in Human Resources.

In the Accounts Receivable or Accounts Payable menu, choose Periodic processing → Payments. The system displays the Automatic Payment Transactions: Status screen. From here, choose Environment → Payment medium → DME administration to reach the DME administration screen.

In the Payroll country menus, choose Payroll → Bank transfer → DME management.

In the DME administration overview, the system displays all the data media created with the selection criteria you have specified. You can call up further information for each data medium. Select the required data medium.

Features

DME administration includes the following functions:

• Displaying data medium attributes
  
  Choose Extras → DME attributes
  
  The system displays the following information for the selected data medium:
  
  - Payment run ID
  - House bank or clearing house
  - Date and time of data medium creation
  - Responsible person
  - Amount paid in currency specified
  - Further technical data

• Deleting an individual or several data media
  
  The accompanying administrative data is deleted from the system at the same time.

  Select the required data medium and then choose Edit → Delete data medium. A confirmation prompt appears. The selected data media are deleted when you confirm this prompt.

  If you wish to delete data media from several company codes, then you should use the reorganization function within the payment program.

  See also:
  
  Deleting DME Administrative Data Across Company Codes [Extern]

• Downloading one or more files from the SAP system or from the file system to hard drive or disk

  See also:
  
  Downloading a DME File onto Disk [Extern]
• **Displaying the contents of a data medium on the screen or printing the contents**

  Choose *Edit → Display DME contents* from the DME administration overview screen.

  The following functions are **not** available for payments from *Human Resources* (HR).

• **Displaying Documents**

  Choose *Extras → DME attributes* and then *Environment → Display documents*. By selecting *Choose*, you branch into the selected payment document.

• **Displaying the transferred data after receiving and entering the account statement**

  To do this, choose *Extras → Bk transact.attrs* from the DME administration overview screen. If your electronic account statements are processed automatically, then the system fills in the fields within the *Account statement* group.

• **Printing the payment summary for the selected data medium**

  To do this, choose *Extras → Payment summary* from the DME administration overview screen.

• **Creating a payment advice note**

  If you do not use the automatic transfer of electronic account statements but instead enter the account statement data manually, you can simplify this work by means of payment advice notes within DME administration.

  You can create a payment advice note for a specified data medium using *Environment → Generate doc.pmt adv*. You can enter this payment advice number at a later stage when clearing the bank clearing account. During clearing, the system then only proposes those open items which belong to the payments specified in the payment advice.

  You can find more information on the use of this function in Great Britain, (for the creation of a Telepay file, for example) in the documentation of report RFFODTA1.
Cash Payment with Cash Breakdown List

Purpose

The system uses this process to provide all the information you need to pay the wages and salaries, in cash, to your employees. The system creates:

- A cash breakdown list, in the payroll currency, with the number of bank notes and coins you need for the cash payment
- A payment list that lists the individual payments for each employee
- A list of signatures that the employee can sign after receiving the cash payment

In contrast to the other payment processes that the R/3 System offers for wage and salary payments, no data is stored or changed in your system when you use the cash payment with cash breakdown list process. Only the lists mentioned above are created when you use this process.

Prerequisites

You have not entered any payment method in the Bank Details infotype (0009).

If the Payment Method field in the Bank Details infotype (0009) is blank, the system stores the payment amount in the Cash Payment wage type (/557) in the Results Table (RT) in the payroll results for the employees, during the payroll run.

The system does not store the Cash Payment wage type (/557) in the Payment Information table (BT).

Process Flow

The Cash Breakdown List program (Report RPCMLI00 or RPCMLI09) evaluates the entries in the Results Table (RT) in the employee's payroll results, for the wage type you entered on the program selection screen in the Wage Type of Net Amount field. It then creates the following lists:

- Cash breakdown list
- Payment list
- List of signatures
If you use the Off-Cycle Activities component, use report RPCMLI09. If you do not use the Off-Cycle Activities component, use report RPCMLI00.

The following graphic shows the process flow of cash payments with a cash breakdown list.
Pay Slips/Remuneration Statements

Purpose
It is a legal requirement for employers to issue pay slips, also called remuneration statements, to every employee for the period for which the employee is being paid. Pay slips show information such as each employee's gross and net pay, type of earnings, hours, amounts that make up the pay, any additions and deductions, and leave information.

Implementation Considerations
Pay slips are configured and processed using the standard Forms functions. However, the SAP HR Payroll Australia component comprises additional functions required to produce pay slips in line with Australian requirements.

Integration
You configure the format and printing of pay slips in Customizing for Payroll Australia under Forms → Remuneration Statements.

Features
For more information on pay slips, see SAP Library → Human Resources → Payroll → Payroll Australia → Subsequent Activities → Remuneration Statement [Seite 546].

For more information on producing pay slips in line with Australian requirements, see SAP Library → Human Resources → Payroll → Payroll Australia → Subsequent Activities → Pay Slips / Remuneration Statements → Pay Slip Configuration [Seite 543] and Creating Pay Slips [Seite 545].
Pay Slip Configuration

Purpose
This process provides an overview of the various aspects you must consider when setting up pay slips.

Prerequisites
Before running pay slips, you must configure the format and printing of pay slips in Customizing for Payroll: Australia under Forms → Remuneration Statements.

If you are an upgrade customer and process leave based on leave accruals in SAP HR Payroll Australia, you determine whether the pay slips are to be printed before or after the leave batch update that updates leave information. You do this by configuring the feature [Extern] Leave Batch Has Run for Pay Area (13LVB). To configure the feature in Customizing for Payroll: Australia, choose Forms → Remuneration Statements → Set Up Feature for Leave Batch Update [Extern].

If you do not configure the feature accordingly, the leave data printed on pay slips will either double-up on leave entitlement, or not include leave entitlement data for the relevant payroll period.

Leave processing based on Australian leave accruals will be phased out in future releases. It will be replaced by SAP HR Personnel Time Management.

Process Flow
When you configure pay slips, you must consider the following:

- The background of the pay slip form, that is, everything that is to be printed without changes on each single sheet.
- The information that is printed in the same position on each pay slip. This information may include, for example, an employee’s personnel number, name and pay point.
- The use of windows within each form into which data can be printed in a table-like layout. The use of windows within a form cannot be avoided when you print an undetermined amount of similar data.
- The data to be printed in each window. This data is made up of repeated information such as wage types and amounts.

In addition, if you are an upgrade customer and process leave based on Australian leave accruals, you must consider when the pay slips are to be printed. After the payroll run, leave figures are updated in the Leave Entitlements infotype (0005) by creating and processing a leave batch update. Depending on whether the leave batch update program has been run or not, leave data is stored in different parts of the SAP System. To print the correct leave data on pay slips, the pay slips program must retrieve the data from the correct part of the system. You must let the
Pay Slip Configuration

SAP System know when pay slips are to be run by configuring the feature *Leave Batch Has Run for Pay Area* (13LVB) accordingly.

You may be required to convert some information from codes into texts. You do this using form conversions. In addition to the conversions provided by the standard *Forms* functions, the SAP HR Payroll Australia component has some additional conversions:

- Printing the job text instead of the code. (Possible use: classification of employee)
- Printing the position text instead of the code
- Converting leave entitlement from hours to days
- Converting leave entitlement from hours to weeks
- Converting leave entitlement from days to weeks
- Printing leave as entitlement plus accrual
- Converting entitlement plus accrual from hours to days
- Converting entitlement plus accrual from hours to weeks
- Converting entitlement plus accrual from days to weeks

See also:

Creating Pay Slips [Seite 545]
Creating Pay Slips

1. Choose Human Resources → Payroll → Asia/Pacific → Australia, then Payroll → Pay slips.

   The Editing Payroll Results screen appears.

2. Enter the payroll area and the payroll period.

   In the Payroll area field, the SAP System provides a default value corresponding to your user parameter settings or the entries you made when selecting the payroll menu. You can overwrite this default value.

3. In the Personnel number field, enter one or a range of personnel numbers.

4. In the Form name field, enter the name of the form set up in Customizing.

5. If necessary, overwrite the default values in the Output language, Print current period, Print retroactive runs, Layout of retroactive runs, and Sort retroactive runs fields.

6. If necessary, in the Number of test forms field, enter a number between 1 and 9.

   The SAP System will print the corresponding number of test forms.

7. If necessary, set the Print superlines indicator.

   Superlines are lines in which values for more than one wage type are printed. The determining factor is whether or not a wage type has been encoded with column type 1 in the view Form-Related Control of Wage Types (V_T512E).

   If the indicator has been set, a superline is only printed if it contains a wage type with column type 1.

   If the indicator has not been set, all superlines are printed.

8. Execute the program.
Remuneration Statement (Report RPCEDTx0; HxxCEDT0)

Purpose

The R/3 System lists all the payments and deductions made for an employee in a clear format on the remuneration statement. The system also allows you to enter personal or general notifications for your employees. These are printed on the remuneration statement as additional information. This additional information, for example, general information from the management or birthday greetings can be entered in the Notifications infotype (0128).

You usually create the remuneration statement after the payroll run and before the bank transfer. If you perform more than one payroll run in a single period, you can create remuneration statements after each payroll run.

You specify the format, structure and content of the form for the remuneration statement in Customizing for Payroll under Remuneration Statement.
Creating Remuneration Statements

Procedure

1. In the SAP Menu choose Human Resources → Payroll → International → Information System → Employee → Remuneration Statement.

2. Enter the appropriate values in the fields, and set the indicators required.

   The system enters a default value in the Payroll Area field. This corresponds to your entries in the initial payroll or to the settings under Tools → Set Modifiers → Payroll Area. You can overwrite this default value.

3. Choose Program → Execute or Execute + Print or Execute in Background.
Notifications Infotype (0128)

Definition
In the Notifications Infotype (0128) you define the additional information that should be printed on your employee's remuneration statement. For example, messages from management and birthday congratulations.

Structure
The Notifications infotype (0128) has the following subtypes in the standard system.

- **Subtype 1: General notifications**
  In this subtype you assign a text module to a personnel number. You have created the text module previously using the function Tools → SAPscript → Standardtext. You cannot edit the text module directly in the Notifications Infotype (0128).

- **Subtype 2: Personal notifications**
  In this subtype you edit an individual text module for the personnel number in question. You can only edit and display this text directly in the infotype.
Creating a General Notification

Procedure

1. Choose Tools → Form Printout → SAPscript → Standard Text.
2. In the Text Name and Language fields, enter the required data.
3. In the Text ID field, enter HR_G.
4. Choose Create.
5. Choose Goto → Header.
6. Enter a short title for the new text module.

Maintain the short title for the text modules you have used. This provides you with a better overview within the Notifications infotype (0128), because the short title, not the text name, is displayed in the list screen or overview screen for the infotype.

A change to a text module affects all of the personnel numbers to which the text is assigned in subtype 1 (General Notifications).

7. Enter the text for the general notification.

The system does not support formatting within the remuneration statement.

8. Choose Save.
Assigning a Notification to a Remuneration Statement

Prerequisites
You have created a general notification by choosing Tools → Form Printout → SAPscript → Standard Text.

Procedure
1. Choose Human Resources → Personnel Management → Administration → HR Master Data → Maintain.
2. Enter the employee’s personnel number.
3. In the Infotype field, enter 0128 and in the Subtype field, enter 1 for a General Notification.
4. Choose Create.
5. Enter the text name.
6. Enter any other necessary data, if and when required.

You should define the beginning and end date of the notification, as the notification will be printed in every payroll period otherwise.

7. Choose Save.

Result
You have assigned a general notification to an employee’s remuneration statement.
Editing Personal Notifications

Procedure

1. Choose Human Resources → Personnel Management → Administration → HR Master Data → Maintain.

2. Enter the employee’s personnel number.

3. Enter 0128 in the Infotype field and 2 in the Type field for a Personal Notification.

4. Choose Create.

5. Enter a short title for the personal notification.

6. In lower part of the window, enter the personal notification. If this area is too small, you can access the SAPscript editor by choosing Maintain Notification. You can now edit the text again.

The system does not support formatting within the remuneration statement.

You should define the beginning and end date of the notification, as the notification will be printed in every payroll period otherwise.

7. Choose Save.
Parallel Execution of Evaluation Programs

Use

If you want to generate evaluations for a large number of personnel numbers (for example, print remuneration statements), you can use report RPCS0000 to create several background jobs. The system then processes the background jobs simultaneously using different application servers.

You should not use report RPCS0000 to run simultaneous evaluations with only one result (for example, for an employee telephone directory). This is because you cannot combine the results of individual background jobs.

Prerequisites

The following prerequisites must be met if you want to run an evaluation program using report RPCS0000:

- A suitable variant must be defined in the evaluation program.
- The evaluation program must use the logical database PNP.

Scope of Functions

You specify the number of personnel numbers to be evaluated in the background job or how many background jobs should be created. Report RPCS0000 selects the personnel numbers to be evaluated from the database and groups them together in background jobs. You can release each background job separately or you can release them together.

Report RPCS0000 does not use the criteria for the logical database PNP when sorting. Sort sequences defined in the program variants may, therefore, not be performed correctly.

You can enter a short text for each evaluation run. Each background job contains this short title and a sequential number. The short text can be helpful if you want to display the background jobs in the general job overview.

The program displays a log after the evaluation has been completed.
Starting Evaluation Programs Simultaneously

Prerequisites
You have defined a program variant for the evaluation program (for example, for the creation of remuneration documents) and are in the ABAP/4 Execute Program screen.

Procedure
1. Enter program RPCS0000.
2. Choose Execute.
3. Enter the evaluation program and a variant.
4. Enter the number of personnel numbers to be included in the parallel payroll run, or enter the number of jobs for which the payroll run should be split.
5. Choose one of the following steps:
   - Program → Execute
   - Program → Execute + Print
   - Program → Execute in Background

Result
The system performs the evaluation and then prints a log. This contains the following information:

- Date and time of the individual program steps
- Error messages
- Warnings
- Overview of generated background processes
  You can clearly identify the jobs using the job numbers and job names.
Payroll Account (Report RPKTOx0; HxxCKTO0)

Purpose

The Payroll Account provides you with a combination of different wage types for a specific period. This combination is sorted according to personnel number. For example, in Germany you therefore fulfill the regulations for taxes and social insurance. However, you can also use the payroll account for other purposes (for example, for internal revision).

Integration

You can branch from the payroll account view to the remuneration statement [Seite 546] view to obtain detailed information on a payroll result.

The remuneration statement displays an In-period view [Extern]; the payroll account displays a For-period view [Extern]. If you select a For-Period [Extern], the remuneration statement for the corresponding In-Period [Extern] is displayed.

Scope of Function

According to the way the payroll account is set up in Customizing for Payroll, under Forms → Payroll Account, it contains the following specifications:

- The employee's personal data
- The cumulated gross wage
- The net wage for every specific payroll period
- Specifications from additional wage types

An employee's personal data is generally at the top of the payroll account, and all the other details are usually included in the main body of the payroll account.
In-Period / For-Period / In-Period View / For-Period View

In-Period

The in-period (start and end date of a period) is the payroll period in which a payroll result is generated.

For-Period

The for-period (start and end date of a period) is the payroll period for which a payroll result is generated.

In-Period View

An in-period view is a selection of payroll results from the payroll directory (for example, RPCLSTRD Payroll Result for Germany) for a number of in-periods. The payroll results that were generated for the required number of payroll periods in the selected period are selected.

For-Period View

A for-period view is a selection of payroll results from the payroll directory (for example, RPCLSTRC Payroll Result for Switzerland) for a number of for-periods. The payroll results that were generated in the required number of payroll periods for the selected period are selected.

Example: For-Period View / In-Period View

<table>
<thead>
<tr>
<th>Payroll result</th>
<th>For-period view</th>
<th>Start date for-per.view</th>
<th>End date for-per.view</th>
<th>In-period view</th>
<th>End date in-per.view</th>
</tr>
</thead>
</table>

Explanation

The payroll result 1 for the payroll period (for-period) 01/1997 has the start date 01.01.1997 and the end date 31.01.1997. This payroll result was generated in the payroll period (in-period) 02/1997.
Creating a Payroll Account

Prerequisites
You have made the settings required for the payroll account, in Payroll Customizing under Forms → Payroll account.
Payroll results exist.
You are in the initial screen for Payroll.

Procedure
1. In the SAP Menu choose Information Systems → Human Resources → Payroll → Payroll (Country) → Employee → Payroll Accounts.
2. Enter the appropriate values in the fields and set the indicators required.
3. Choose Program → Execute or Execute + Print or In Background.

Result
You create a payroll account.

If you require information on a payroll result, you place the cursor in the column for the period in which the payroll result was created, and choose Detail.
Payroll Journal (Report RPCLJNx0; HxxCLJN0)

Purpose

The payroll journal contains detailed, selected payroll data for several employees, for whom payroll has been run in a particular time interval or a selected payroll period.

You can use the payroll journal to:

- Identify errors that have occurred during the payroll run
- Cumulate payroll data belonging to an organizational unit
- Track the development of data over several payroll periods
- Have an additional, detailed control medium for revisions

Scope of Function

The new version of the payroll journal differentiates between:

- Page headers
  The page header is printed on each page and contains the organizational assignment for the employee.
- Payroll excerpts
  The payroll excerpts contain the payroll data for each employee and the payroll result.
- Continuation excerpts
  If the printed payroll excerpts cover two pages, the continuation excerpts appear in first position on the second page, and then the rest of the payroll excerpt follows.
- Totals page
  The totals page contains the cumulated data from the payroll excerpts for each organizational unit.

In the old version of the payroll journal all this information was grouped together.

When the payroll journal is generated, the system evaluates the data records within Payroll whose In-Periods [Extern] are within the specified time interval. Any retroactive accounting differences that exist for a specific payroll period are first of all evaluated in the payroll journal, with the payroll period during which the retroactive accounting run took place. The selected payroll results are listed one after the other, in accordance with the In-Period View [Extern], in the forms mentioned above.

Restrictions

The payroll journal cannot be used as a basis for reconciliation with the Financial Accounting and Controlling application components.
Creating a Payroll Journal

Prerequisite
You have made the necessary settings for the payroll journal in Customizing for Payroll, under Forms → Payroll Journal, and have ended the payroll run successfully.
You are in the initial screen for Payroll.

Procedure
1. In the SAP Menu choose Human Resources → Payroll → International → Information System → Organizational Entity → Payroll Journal.
2. Enter the appropriate values in the fields, and set the indicators required.
   You can specify a period of time or a payroll period as data selection criteria.
   Fill in the Payroll Type and Payroll Identifier fields, if these are available in your country version, to restrict the payroll results that are to be evaluated.
   You use Delimitation to determine the sorting sequence and the way in which the values for the totals pages should be cumulated.
   You use Format Retroactive Accounting to determine how retroactive accounting should be displayed on the payroll excerpts.
   You use Format Retroactive Accounting to determine how current periods are printed and whether superlines are printed.
3. Choose Program → Execute or Execute + Print or In Background.

Result
The payroll journal was created. According to the settings you have made, you only obtain information concerning the personnel area, or additionally you obtain information concerning the individual employees.
Wage Type Statement

Definition

The wage type distribution is a list that gives you an overview of the wage types in the in-period view. The system evaluates the payroll results from results tables RT and CRT and determines the original payroll result and the retroactive accounting results created in the period in question.

The system also evaluates the employee’s organizational assignment. This is included in the payroll results. This data is taken from the Work Center Basic Pay table (WPBP).

Use

You can use the wage type statement to:

- Identify errors that have occurred during the payroll run
- Cumulate payroll data belonging to an organizational unit
- Have an additional, detailed control medium for revisions

The following evaluation options can be used when creating the wage type statement:

- Individual evaluation
  
  This type of evaluation is performed for each personnel number. The number and amount is printed for each wage type. The individual evaluation can be sorted according to personnel number or employee name within the organizational assignment.

- Totals evaluation
  
  This type of evaluation is performed without specification of personnel number and name. The selected wage types are cumulated and printed for all selected personnel numbers. The totals evaluation can only be sorted according to organizational assignment.

Wage type statements can only be created for one country. Personnel numbers that are assigned to another country are listed in the error log.
Creating a Wage Type Statement

Prerequisites
Payroll results exist.
You are in the initial screen for Payroll.

Procedure
1. In the SAP Menu choose Human Resources → Payroll → International → Information Systems → Wage Type → Wage Type Statement.
2. Enter the appropriate values in the fields, and set the indicators required.
   If you do not enter a wage type, the SAP System selects all wage types that are in the internal Results tables RT or CRT for the selected payroll result.
   If you flag the New Page Per Wage Type field, each new wage type is printed on a new page in the individual statement. This parameter is not used in totals evaluation.
   In the Reference Period field, you can enter a payroll period as a comparison period. The results of the comparison and the absolute and relative differences between the wage types will then be printed on the wage type statement. The comparison values that are generated when a reference period is used cannot be printed on the form.
   If you flag the Read Cumulated Results field, the cumulated annual values for the results table CRT are read and formatted for the wage type statement.
   In the Totals Formation group, you can change the standard output by changing one of the sort criteria.
3. Choose Program → Execute or Execute + Print or Execute in Background.

Result
A wage type statement is displayed.
Wage Type Distribution

Definition

The wage type distribution is a list that gives you an overview of the wage types in the for-period view. The system evaluates the payroll results from results table RT and determines the last payroll result for the for-periods for a period.

The system also evaluates the employee’s organizational assignment. This is included in the payroll results. This data is taken from the Work Center Basic Pay table (WPBP). The system does not include any retroactive accounting differences in the wage type distribution.

When creating the list, the system only considers the current data records that are valid at the time of the evaluation. This means that the evaluation runs that take place later may not have the same result: If retroactive accounting has taken place in this period, a new payroll result exists, which is then displayed.

Use

You can use the wage type distribution to:

- Identify errors that have occurred during the payroll run
- Cumulate payroll data belonging to an organizational unit
- Track the development of data over several payroll periods
- Have an additional, detailed control medium for revisions

The following evaluation options can be used when creating the wage type statement:

- Individual evaluation
  
  This type of evaluation is performed for each personnel number. The number and amount is printed for each wage type. The individual evaluation can be sorted according to personnel number or employee name within the organizational assignment.

- Totals evaluation
  
  This type of evaluation is performed without specification of personnel number and name. The selected wage types are cumulated and printed for all selected personnel numbers. The totals evaluation can only be sorted according to organizational assignment.

Wage type distribution lists can only be created for one country. Personnel numbers that are assigned to another country are listed in the error log.
Creating the Wage Type Distribution List

Prerequisites
Payroll results exist.
You are in the initial screen for Payroll.

Procedure
4. In the SAP Menu choose Human Resources → Payroll → International → Information System → Wage Type → Wage Type Distribution.
5. Enter the appropriate values in the fields, and set the indicators required.

If you do not enter a Wage Type, the SAP System selects all wage types that are in the internal Results tables RT for the selected payroll result.

If you flag the New Page Per Wage Type field, each new wage type is printed on a new page in the individual statement. This parameter is not used in totals evaluation.

If you only flag the Evaluation Start field in the Evaluation Period group, only this period will be evaluated.

In the Totals Formation group, you can change the standard output by changing one of the sort criteria.

6. Choose Program → Execute or Execute + Print or Execute in Background.

Result
You have created a wage type distribution.
Wage Type Reporter (H99CWTR0)

Use
You use the wage type reporter to evaluate wage types that are contained in the payroll results.
Data from the Results Table (RT) and the Work Center Basic Pay table (WPBP) is used in the evaluation.

Data from the Personnel Administration application component (PA-PA) (for example, infotypes), or from other tables in the R/3 System is not included in this evaluation.

Prerequisites
Payroll has been run successfully.

Scope of Function
Evaluation options
- Evaluation of wage types for a selected period
- Overview of the wage types from an in-period view [Extern] or a for-period view [Extern].
- Variable column selection for the list (for example, company code, wage type, and in-period [Extern])
- Selection of wage types to restrict the evaluation
- Summarized output of selected wage types
- Summarized output of selected wage types

List display
- Output and display in
  - SAP List Viewer [Seite 565]
  - Microsoft Excel Table [Seite 566]
SAP List Viewer

Definition
The SAP List Viewer is a user interface, which enables you to display lists in a standardized list format in the R/3 System. The List Viewer uses a simple list format and includes functions for the dynamic creation of display variants.

Use
The List Viewer enables you to
- Use pre-defined SAP standard display variants
- Create display variants
- Sort the data
- Sort the lines according to the values in the columns, either in an ascending or descending sequence
- Set a filter
- Display lines that meet certain criteria
- Form totals and subtotals

The wage type reporter uses the List Viewer as a method for displaying the created list. You can choose how to display the list using the display variants. For example, you can
- Move columns
- Hide columns
- Form totals
- Sort the data

For more information, see the documentation on Cross Application Components (CA-GTF) under SAP List Viewer [Extern].
Displaying the Excel Table

Use

The wage type reporter uses Microsoft Excel to display the list in a table format.

Activities

When you use Microsoft Excel to display the form, SAP recommends that you use an Excel template and use the following procedure:

1. Start the wage type reporter with the required data, however, do not specify an Excel template.
   The system creates a temporary table.
2. Enter suitable column headers in the table. Insert the headers as the first line.
3. Select all columns in the area containing the data.
4. Choose the Pivot Table Report and create the required report.
5. Insert this report in a new Excel sheet.
   The Pivot Table is displayed.
6. To save the Pivot Table as a template, select all data in the temporary table. Do not select the column headers.
7. Delete the selected data and place the cursor in the first column and second line.
8. Save the template in the file format .XLT.

The template can be re-used for other Excel tables; however, the objects selected must be the same as the objects selected when the template was created.

1. In the Excel model template field, enter the path for the template.
2. Start the wage type reporter.
   The new temporary table is displayed.
3. Choose the sheet with the Pivot Table, and update the table.
Creating a List of Wage Types

Prerequisites
Payroll results exist.
You are in the initial screen for Payroll.

Procedure

1. In the SAP Menu choose Human Resources → Payroll → International → Information System → Wage Type → Wage Type Reporter.

2. Enter the appropriate values in the fields, and set the indicators required.

The standard selection fields are available in the Selection group. Note that the selection according to organizational criteria in these fields need not correspond to the selection of payroll results for the selected organizational unit. Differences may occur if master data is changed retroactively. SAP recommends that you include the objects used for selection in the Object Selection function.

If you flag the In-period or For-period view in the Period Determination group, a list is created for the selected view.

If you do not enter a wage type, the SAP System selects all wage types that are in the internal Results Table RT or in the Work Center Basic Pay table for the selected payroll result.

You use the Object Selection function to define which objects are displayed as columns in the list and which objects are summarized. The selected objects are printed as columns in the list and the objects not selected are summarized.

In the Output group, you define whether the list is created with the List Viewer or printed as a Microsoft Excel table.

If Display using list display or Layout list viewer is selected, the list is displayed in the SAP List Viewer [Seite 565].

If Display using Excel or Excel model template is selected, the list is displayed as a Microsoft Excel Table [Seite 566].

3. Choose Program → Execute.

Result
A list is displayed of the wage type evaluation.
Month-End Accruals Concept

Definition

Payroll Accounting is usually carried out in a fixed cycle. This cycle is determined by the length of the periods for which the payroll is run, such as a month or a week.

Once the payroll run is complete, the results are transferred to accounting (Financial Accounting and Cost Accounting) where they are posted using a fixed posting date, such as the check date. Financial Accounting also assigns its accounting transactions to fixed periods, such as months or four weeks.

If the periods used within Human Resources (HR) and Financial Accounting are the same, the posting date enables you to assign the posting of payroll results correctly.

If the payroll periods are not the same as the posting periods used within Financial Accounting, the FROM and TO dates of the payroll period might belong to different posting periods within Financial Accounting. The payroll results are then posted using a fixed posting date, such as the check date. As a result, all of the personnel expenses are assigned to a single posting period within Financial Accounting, even though the expenses were actually incurred in two different posting periods. This makes it difficult to make a meaningful comparison of expenses incurred in different posting periods.

You then need to be able to split personnel expenses so that for exact periods within Financial Accounting they can be assigned to different posting periods.

The month-end accruals function was developed to solve this problem.

Two Ways of Splitting Personnel Expenses for Exact Periods

- **Approach Using Estimates**
  
  The personnel expenses expected for a posting period are estimated on the basis of the results from past payroll periods and the appropriate accruals are created. These accruals are then reversed in the posting period to which the corresponding payroll results are posted.

- **Approach Using Actual Values**
  
  The personnel expenses calculated by the payroll run are split directly for the posting periods in question.

The SAP solution is designed to use a combination of these two methods, but can be configured to use one or the other.

See also:

Approach Using Estimates [Seite 569]
Approach Using Actual Values [Seite 570]
The SAP Solution [Seite 571]
Approach Using Estimates

The Approach Using Estimates is an accounting method frequently used when a pay period intersects two different accounting periods.

Suppose your company’s accounting periods are on a monthly basis and pay period C intersects accounting periods June and July. You can use the actual payroll results of pay period B to estimate the payroll results in pay period C. Financial Accounting will debit the June accounting period for the amount of work in pay period C that occurred in June, and debit the July accounting period for the amount of work in pay period C that occurred in July.

In the June accounting period, Financial Accounting can debit a special expense account with the estimated amount for the part of payroll period C that belongs to June. To balance the postings in the June accounting period, a provisional account can then be credited with the same amount that was debited to the special expense account mentioned above.

In the July accounting period when the actual payroll values are posted, you balance these accounts by reversing the estimated postings. You can credit the special expense account and debiting the provisional account with the original estimated amounts.

If the June accounting period is still open when the payroll results of pay period C are posted, estimated values can have been used although the more accurate actual values were available.
Approach Using Actual Values

The Approach Using Actual Values is an accounting method frequently used when a pay period intersects two different accounting periods.

Suppose your company’s accounting periods are on a monthly basis and pay period C intersects accounting periods June and July. The posting date for pay period C is derived from the end date, or the check date of the pay period. Suppose your posting date for pay period C is in the July accounting period. All the actual values for pay period C, then, can be posted into the July accounting period. Financial Accounting will then determine what amount of the actual values for pay period C should be transferred into the June accounting period.

Financial Accounting can debit a special expense account with this amount for the part of payroll period C that belongs to June. To balance the postings in the June accounting period, a provisional account can then be credited with the same amount that was debited to the special expense account mentioned above.

For the July accounting period, you balance these accounts by reversing the two postings. You can credit the special expense account and debiting the provisional account with the appropriate amounts.

It may occur that, for example, the June accounting period is already closed when you want to post the actual values into June. In this event you must post the actual values into the next, in this case the July, accounting period. One option is to do the posting similar to the way it is done in the Approach Using Estimates [Seite 569].
The SAP Solution

Choice of Method used to Split Expenses

The SAP solution for month end accruals enables you to split personnel expenses for the appropriate posting periods. You can do this by using a combination of Approach Using Estimates [Seite 569] and Approach Using Actual Values [Seite 570]. As a result, such splits are executed using the most up-to-date (and therefore the best) information available.

This means that the splits are based on current values, if possible. This is the case if all of the posting periods in question are still capable of receiving posting data when the payroll results are posted.

Otherwise, the amount of personnel expenses still expected for a posting period is estimated during an earlier payroll run.

You can also set up the system so that only the Approach Using Estimates or Approach Using Actual Values is used.

There are no presettings to determine the date on which the payroll results are posted for a particular payroll period. When customizing the system, you are required to enter dates by which the payroll results must be posted. Using this latest document creation date (LDCD), you can determine the date by which postings must be effected for each subsequent payroll period. You cannot change these dates, which means it is essential that you meet the specified deadline for posting. You must also use the Implementation Guide (IMG) to specify a final date for each posting period with regard to postings from HR. When the payroll is run, the system compares these two dates with each other.

If the LDCD of the payroll period in question is earlier than the final dates for all of the posting periods within Financial Accounting, the system recognizes that the expenses can be split on the basis of the current payroll results.

In the following example, the LDCD of the (current) payroll period C is earlier than the final posting date of the June (and July) posting period (s). For this reason, the expenses can be split using the appropriate basis (see below) in accordance with the Approach Using Actual Values.

If the earlier of the two posting periods can no longer receive posting data by the LDCD of the current payroll period, you can no longer split the current values. The system recognizes this situation during the payroll run for the previous payroll period.

In the next example, the June posting period is no longer capable of receiving posting data by the LDCD of payroll period C. During the payroll run for payroll period B, the system uses the payroll results for payroll period B to estimate the expected amount of June expenses for payroll period C. The system then creates accruals for June in the amount of the estimated expenses.
The current results for the whole of payroll period C are subsequently posted using a posting date in July. For this reason, the accruals created for June must be reversed in July.

See Approach Using Estimates [Seite 569] for a description of how the system splits expenses by creating accruals.

The system also splits the current values (by creating and reversing accruals in accordance with the Approach Using Actual Values [Seite 570].

**Effected Postings: Example**

Of the $1000 incurred for payroll period C that must be posted to July in accordance with the customizing settings, $400 (for example) should actually be posted to the posting period for June. This is achieved by debiting the $400 to an expense account (Accrued Expenses) using a posting date in June. The offsetting entry is made in an accruals account. The actual payroll posting of $1000 (Expenses to Payable) is effected using a posting date in July. A posting date in July is also used to credit the so-called Accrued Expenses account and to reverse the accrual.

If you use the Approach Using Estimates, the additional postings are effected after the payroll run for payroll period B. If you use the Approach Using Actual Values, on the other hand, these postings are not effected until payroll period C.

Note that you must set the Posting date acc. to table parameter when starting Transfer to FI/CO to ensure that the regular posting is effected using the posting date specified during customizing.

**Basis Used to Split Expenses**

The system enables you to split expenses in accordance with:

- Calendar Days
- Workdays According to the Personal Work Schedule
- Working Hours According to the Personal Work Schedule
Effect of an Organizational Reassignment

If an employee’s remuneration or organizational assignment changes during a payroll period (creation of a WPBP split), the calculation of month end accruals is affected as follows:

1. **Approach Using Estimates**

   If expenses for a future payroll period are estimated on the basis of the current payroll results, the system assumes that the employee’s organizational assignments in the period to be estimated are the same as on the last day of the current payroll period. For this reason, the expected personnel expenses are debited to the Cost Center assigned on the last day because the system assumes that the employee will remain on this Cost Center after the change has been effected. However, the entire period is used as the basis of the amount of expected expenses. The following example makes this clearer:

   At the end of payroll period B, the employee works on Cost Center 2 so that the accruals for payroll period C are debited to Cost Center 2. However, the basis of the estimation consists of the entire periodic expenses at the amount of $1000.

   Note the system’s assumption that wage types with an explicit cost assignment (table C1) also occur in the period to be estimated with the same cost assignment. Such payments are assigned to the entire payroll period, irrespective of the exact time at which the payment is effected, and are then split accordingly.

   The system ignores future changes made to the employee’s organizational data, even if they are already entered and stored in the system when the payroll is run. The reason for this is that changes usually compensate for one another. For example, an employee who leaves the company in the payroll period to be estimated and for whom month end accruals are not really required is usually replaced by another employee.

2. **Approach Using Actual Values**

   When expenses are split using the Approach Using Actual Values, all of the required information on the best possible split is already in the system when the posting is effected. All of the partial periods within the payroll period are checked individually and assigned to the posting periods. In the following example, the first of the two partial periods, during which the employee works for Cost Center 1, is assigned in its entirety to the June posting period. The expenses incurred in the second partial period, on the other hand, are distributed to June as well as July, in accordance with the basis used for the split (workdays in this example).
The SAP Solution

Wage types with an explicit cost assignment (table C1) are assigned to the partial period in which they occur. Irrespective of their exact date of origin, they are distributed to the posting periods in accordance with the expenses incurred in the partial period that includes their date of origin.

Regularly Entered Delayed Wage Types

Sometimes, particular wage types, such as overtime bonuses, are regularly entered in the system in the period following the payroll period to which they apply. When the payroll is run, the system has no information on the amount of these wage types for the current payroll period.

Such wage types are not entered until the subsequent payroll run, which triggers a retroactive accounting run for the current payroll period.

If the current period is used as a basis for distributing expenses to two different posting periods, these wage types are ignored because they are not yet available in the system. However, it is possible to estimate the expected amount of such wage types on the basis of the last payroll period for which they are available, which is the preceding period.

You can flag such wage types as Regularly Entered Delayed when customizing the system. They are then taken from the previous period when month end accruals are created.

The following example explains this situation for the Approach Using Actual Values. It illustrates a hybrid form because the amount of Regularly Entered Delayed wage types is estimated.

The basis of the distribution does not merely consist of the $1000 in current payroll period C. Instead, $200 are also used; period C is expected to incur this amount but it is not entered and included in a payroll run until payroll period D. At this time, you can no longer assign part of this amount to the June posting period because this period can no longer receive posting data.

If the Approach Using Estimates is used (see following example), the expenses expected in period C are estimated during the payroll run for period B.

Period A represents the last payroll period for which Regularly Entered Delayed wage types are available at this time. Thus, the basis of the estimation consists of the wage types normally entered for period B and the Regularly Entered Delayed wage types in period A.
The personnel calculation schema determines whether a particular wage type is *Regularly Entered Delayed* for specific employee groupings.

**Posting Retroactive Accounting Differences to Previous Posting Periods**

The section *Regularly Entered Delayed Wage Types* describes how, under certain conditions, expense wage types can be assigned to their appropriate posting periods, despite the fact that retroactive accounting has been performed. You can do this if you know in advance that such wage types are regularly entered one period later than the period to which they actually apply.

However, if retroactive changes are made to *ordinary* wage types, an unexpected retroactive accounting run is triggered for previous payroll periods. Retroactive pay increases are an example of such unexpected changes.

The differences between the new and original payroll results for the retroactively accounted period are usually posted using the posting date of the current period, even if part or all of the retroactively accounted period belongs to a previous posting period.

If the payroll period in question belongs entirely to previous posting periods, you can use the month end accruals function to set up the system so that retroactive accounting differences are posted to the last posting period that can receive such data. For example:

In this example, the basic pay data in payroll period B is increased with retroactive effect from $1000 to $1050. Data can still be posted to June because the LDCD of the current payroll period C is earlier than the final date of the June posting period. The difference of $50 for the retroactively accounted period B is posted to the June posting period because B belongs entirely to June.

You can only use this function if just one previous posting period can still receive such posting data.

Note that *Regularly Entered Delayed* wage types are ignored because accruals are created for these wage types during the normal procedure.
Posting to Accounting (PY-XX-DT)

Purpose

The payroll results contain information that is relevant for Accounting. For this reason, they must be evaluated for posting to Accounting. The Posting to Accounting component performs this task. It is the interface between Payroll and Accounting. It helps to:

- Group together posting-relevant information from the payroll results
- Create summarized documents
- Perform the relevant postings in the Accounting components

Integration

Various components of the R/3 system interact when posting to Accounting:

Payroll (PY)

The Payroll component creates payroll results for each payroll period. To do so, wage types with different business purposes are created. They are created according to tax, social insurance law, industrial law, pay scale and operative points of view.

Financial Accounting (FI)

Financial Accounting illustrates all business transactions in the enterprise using postings to the relevant accounts. Posting to Accounting provides the necessary data for the following components in Financial Accounting:

- General Ledger Accounting (FI-GL)
- Accounts Payable (FI-AP)
- Accounts Receivable (FI-AR)
- Special Ledger (FI-SL)
- Funds Management (FI-FM)

Cost Accounting (CO)

Cost Accounting provides information on the relationship between costs and activities within the enterprise. To do so, costs are either assigned to a cost center or to another account assignment object. The posting to Accounting component usually posts to the following account assignment objects:

- Cost center
- Order

It is also possible to post to the following account assignment objects:

- Cost object
- Work breakdown structure element
- Network number
- Activity number
Sales order
Item in sales order

**Personnel Cost Planning (PA-CM-CP)**

The system can provide Personnel Cost Planning with data based on simulated or actual payroll results from posting to Accounting.

The graphic shows how the components link together when posting to Accounting.

---

**Implementation Considerations**

The components involved in posting to Accounting do not have to be in the same client in the R/3 system. If the components involved are in different R/3 systems, R/2 systems or third-party systems, you can find more information in the following sections:

- Posting from HR Systems < 4.0 [Seite 648]
- Posting to AC Systems < 4.0 [Seite 652]
- Posting Posting Documents [Extern]
- In Customizing of Cross-Application Components, under Predefined ALE Business Processes → Human Resources → HR <-- AC → Posting of Payroll Results to Accounting

**Scope of Function**

- You can use the Accounting interface (AC interface) to directly post the documents created to the Accounting components.
- You can simulate posting runs before the end of the payroll run. In this way, you can check if the payroll results are also correct from the point of view of posting to Accounting.
- You can access information on the creation and processing of posting runs at any time using status management and the history.
- By selecting the payroll results, you prevent them from being evaluated twice. This also lets you check if payroll results were missed out during reporting.
- With the help of layouts, which you can configure to your individual needs (for example, totals formation, sorting, filtering), you can check posting documents efficiently.
- The summarized line items can be traced back to the payroll result for a personnel number at any time. This function is protected by authorizations.
- The data created can be archived. For more information on archiving, see Archiving Posting Documents (PY-XX-DT) [Extern] and Archiving Index Files (PY-XX-DT) [Extern].
- You can provide data for Personnel Cost Planning.
Central Objects

You can use the Central Objects section to gather information on the following objects:

- Posting runs
- Posting documents

To be able to correctly control the process of Posting to Accounting, you must thoroughly understand both these objects and their relationship to one another.
Posting Runs

Definition

Central object in posting to Accounting. The step creating a posting run [Seite 621] creates a posting run based on the payroll results, with a distinctive number, the run type PP and the accompanying posting documents [Seite 583]. A posting run always contains all the posting documents created. Therefore, all activities performed with reference to the posting run affect all of its accompanying posting documents.

During posting to Accounting the posting run takes on various statuses that provide information on the progress of the posting and any errors that may occur.

Use

Posting Document: Assigned Activities

<table>
<thead>
<tr>
<th>Activity</th>
<th>Procedure(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simulate</td>
<td>Simulating a posting run [Seite 618]</td>
</tr>
<tr>
<td>Create</td>
<td>Creating a posting run [Seite 621]</td>
</tr>
<tr>
<td>Display</td>
<td>Displaying the posting run overview [Seite 634]</td>
</tr>
<tr>
<td></td>
<td>Displaying the history [Seite 645]</td>
</tr>
<tr>
<td></td>
<td>Displaying the attributes of a posting run [Seite 636]</td>
</tr>
<tr>
<td></td>
<td>Displaying detailed information [Seite 646]</td>
</tr>
<tr>
<td>Modify</td>
<td>Changing or creating a posting run text [Seite 635]</td>
</tr>
<tr>
<td></td>
<td>Deleting a posting run [Seite 637]</td>
</tr>
<tr>
<td>Post</td>
<td>Posting posting documents [Seite 628]</td>
</tr>
<tr>
<td>Reverse</td>
<td>Reversing a posting run [Seite 643]</td>
</tr>
<tr>
<td>Archive the index files</td>
<td>Archiving index files (PY-XX-DT) [Extern]</td>
</tr>
</tbody>
</table>

The posting run ensures that an employee’s payroll results are only posted once:

- During the step Creating a posting run, the system locks the payroll results for the selected personnel numbers. In this way, it is not possible for either another posting run or the payroll driver to process these payroll results.

- In posting to Accounting, a posting run can only be accessed by one sub-process at a time. Amongst these sub-processes are:
  - Creating a posting run
  - Deleting a posting run
  - Posting posting documents
  - Reversing posting documents
Status management ensures that these sub-processes are listed in a permitted order.

- The system selects the payroll results for a personnel number, which are processed in the step *Create posting run*. When attempting to repeat payroll for the same payroll period, the system rejects a personnel number whose payroll results are selected. It is also not possible to process a payroll result that has already been selected with the step *Create posting run*. However, selection of the payroll results is only cancelled if you delete a posting run for which the accompanying posting documents have not yet been posted or if you reverse posting documents that have already been posted for a posting run.

**Structure**

**Attributes**

A posting run can, depending on Customizing and the country version, have the following attributes:

- Payroll area and period
- Due date
- Country grouping
- Number of personnel numbers selected
- Number of personnel numbers evaluated
- Number of personnel numbers rejected
- Number of personnel numbers skipped
- Payroll type, payroll identifier and payment date for Off-Cycle Payroll
- Program that has generated the run
- R/3 System Release
- Name of accompanying TemSe data object
- Function exit: Account determination is used
- Function exit: Filling out ZUONR/SGTXT is used
- Function exit: Temporary wage type is used
- Number of document archive
- Number of index archive
- Month End Accruals evaluated by posting
- Month End Accruals evaluated by reversal
Posting Runs

You should consider that not every posting run has all attributes named.

**Status History**

The system automatically creates a status history for posting documents, to log changes with the date, time and user responsible.
Posting Documents

Definition

Central object in posting to Accounting, which contains all the information transferred when posting to Accounting. Posting documents are created in the step Create posting run. All posting documents that are created as a result of creating a posting run are grouped together to one unit in this posting run.

Each posting document is given a clear number when it is created. During posting to Accounting, the posting document takes on different statuses, which provide information on which activities were performed with reference to the posting document.

The Accounting components use the posting document as the original document for creating other documents. These accounting documents contain a link to the posting document on which they are based.

The reversal document [Seite 642] is a special form of the posting document. It has the same structure as the posting documents that are created for a regular posting. The system creates reversal documents if you reverse the posting documents for a posting run.

Use

Posting document: assigned activities

<table>
<thead>
<tr>
<th>Activity</th>
<th>Procedure(s)</th>
</tr>
</thead>
</table>
| Display  | Displaying the Document Overview [Seite 639]  
Displaying the Posting Document [Seite 640]  
Analyzing the Line Items [Seite 641]  
Displaying the History [Seite 645]  
Displaying Detailed Information [Seite 646] |
| display the accompanying accounting documents | Checking the Accounting Documents [Seite 630] |
| Release  | Release the Posting Documents [Seite 626] |
| Post     | Posting Posting Documents [Seite 628] |
| Archive  | Archiving Posting Documents (PY-XX-DT) [Extern] |

Structure

Document header and lines

Posting documents always consist of document header and document lines.

The document header contains information on

- Document number
Posting Documents

- Company codes
- Posting date
- Document date

The document header contains information on

- Account number
- Account assignment objects (for example, cost center)
- Amount
- Currency

In Accounting, a document line is also called a document line item.

**Status History**

The system automatically creates a status history for posting documents, to log changes with the date, time and user responsible.
Business Basics

You can use the Business Basics unit to get information on the business aspects of posting to Accounting using examples.
Example: Posting a Salary

Payroll Results (HR)

Payroll calculates wage types with different business tasks. Some of these wage types (for example, the primary wage type MA10 Standard Pay or the secondary wage type /559 Bank Transfer) contain information that is relevant for Accounting. Thus, from the point of view of Financial Accounting, Wage type MA10, Standard Pay, contains a company-related expense while the wage type /559, Bank Transfer, contains a payable.

Within Posting to Accounting, wage type /559 Bank Transfer, is posted to a payables account. In this example, the wage type is posted to the account Wages and salaries payable.

The wage type MA10 Standard Pay is posted to an expenses account. In this example, it is posted to the Salaries account. As additional account assignment, this posting contains the master cost center of the employee, for example, cost center 600 Production.

Posting in Financial Accounting (FI)

Posting payroll results in Financial Accounting takes place in the following way:

<table>
<thead>
<tr>
<th>Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Salaries</td>
<td>2,000</td>
<td></td>
</tr>
<tr>
<td>to Wages and salaries to be paid</td>
<td>2,000</td>
<td></td>
</tr>
</tbody>
</table>

The posting of payment transactions is not part of the technical process of Posting to Accounting. The procedure will, however, be described in the following documentation in order to demonstrate this example’s relevance for business.

If you make payments to the employee, you must (within this payment transaction) make postings from the payables account above to the bank account involved, so that the clearing account is clear again after both posting transactions.

The following posting is to be performed within the payment transaction:

<table>
<thead>
<tr>
<th>Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wages and salaries to be paid</td>
<td>2,000</td>
<td></td>
</tr>
<tr>
<td>to Bank account</td>
<td></td>
<td>2,000</td>
</tr>
</tbody>
</table>

Posting to Cost Accounting (CO)

Cost Accounting interprets the posting of payroll results as the posting of primary costs to the value of the salary paid to the employee (2,000 euro). These costs are posted to cost center 600, Production, with the cost type Salaries.
Complete Posting

Use

The system only assigns an account to the largest part of the wage types to be posted to which the relevant amount is posted. Complete posting is only guaranteed by correctly selecting the wage types to be posted when processing the posting characteristics of wage types in Customizing.

Some of the wage types created in Payroll illustrate employer expenses. They should be posted in the Accounting components.

This expenses posting is offset by posting the receivables against the employees to the account *Wages and Salaries to Be Paid*. Other receivables against different recipients of deductions that are retained from the employee’s salary also arise, depending on the respective country. These are usually posted to a receivables account for each recipient group.

See also:

- Example: Posting A Salary [Seite 586]
- Example for Germany: Complete Posting [Seite 589]
- Example for Switzerland: Complete Posting [Seite 590]

Prerequisites

You must have defined the posting characteristics of the wage types in Payroll Customizing (under *Reporting for Posting Payroll Results to Accounting* → *Activities in the HR System* → *Maintain Wage Types* → *Define Posting Characteristics of Wage Types*).
Example for Germany: Complete Posting

The Standard Salary primary wage type (MA10) is posted as an expense. The secondary wage types Bank Transfer (/559), EE Taxes (/260), and EE SI Shares (/261) are posted to payables accounts. Wage types /351, /361, /371, and /381 (ER Shares for Social Insurance) are posted twice, since they represent both an expense and a payable.

Example Posting for Germany

<table>
<thead>
<tr>
<th>Postings to expense accounts</th>
<th>Postings to payables accounts</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Wage type</strong></td>
<td><strong>Amount</strong></td>
</tr>
<tr>
<td>MA10 Standard Salary</td>
<td>5,000</td>
</tr>
<tr>
<td>/260 EE Taxes</td>
<td></td>
</tr>
<tr>
<td>/261 EE SI Shares</td>
<td></td>
</tr>
<tr>
<td>/351 ER HI share</td>
<td>335.00</td>
</tr>
<tr>
<td>/361 ER PI share</td>
<td>465.00</td>
</tr>
<tr>
<td>/371 ER RP share</td>
<td>162.50</td>
</tr>
<tr>
<td>/3Q1 ER NI share</td>
<td>25.00</td>
</tr>
<tr>
<td></td>
<td>5,987.50</td>
</tr>
</tbody>
</table>

The relevant posting records are as follows:

<table>
<thead>
<tr>
<th>FI accounts in INT account plan</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>430000 Salaries</td>
<td>5,000</td>
<td></td>
</tr>
<tr>
<td>440000 Legal social expenses</td>
<td>987.50</td>
<td></td>
</tr>
<tr>
<td>to 176000 Salaries/wages to be paid</td>
<td></td>
<td>2,902.21</td>
</tr>
<tr>
<td>to 176100 Employment and church tax</td>
<td></td>
<td>1,110.29</td>
</tr>
<tr>
<td>to 176200 Social Insurance</td>
<td></td>
<td>1,975.00</td>
</tr>
<tr>
<td></td>
<td>5,987.50</td>
<td>5,987.50</td>
</tr>
</tbody>
</table>
Example for Switzerland: Complete Posting

### Postings to expense accounts

<table>
<thead>
<tr>
<th>Wage type</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>M100 Monthly salary</td>
<td>5,500</td>
</tr>
<tr>
<td>/559 Bank Transfer</td>
<td>4,694.50</td>
</tr>
<tr>
<td>/411 AHV contribution</td>
<td>277.75</td>
</tr>
<tr>
<td>/420 AHV contribution</td>
<td>82.50</td>
</tr>
<tr>
<td>/430 Non-industrial accident</td>
<td>85.25</td>
</tr>
<tr>
<td>/451 Pension fund</td>
<td>360</td>
</tr>
<tr>
<td>/410 AHV administration costs</td>
<td>3.35</td>
</tr>
<tr>
<td>/412 AHV premium / ER share</td>
<td>277.75</td>
</tr>
<tr>
<td>/429 ALV/ER share</td>
<td>82.50</td>
</tr>
<tr>
<td>/452 EE’s PF/ER share</td>
<td>360</td>
</tr>
<tr>
<td>/43C Industrial accident</td>
<td>75.25</td>
</tr>
<tr>
<td>/40A FAK contribution fund</td>
<td>82.50</td>
</tr>
<tr>
<td>/480 reserve, 13th month wages</td>
<td>458.35</td>
</tr>
</tbody>
</table>

### Postings to payables accounts

<table>
<thead>
<tr>
<th>Wage type</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>400000 Wages and salaries</td>
<td>5,500</td>
</tr>
<tr>
<td>400200 13. 13th Month Wage</td>
<td>458.35</td>
</tr>
<tr>
<td>405100 Social insurance AHV/ALV/FAK</td>
<td>446.10</td>
</tr>
<tr>
<td>405200 Round up pension fund</td>
<td>360.00</td>
</tr>
<tr>
<td>405300 Social insurance BU/NBU</td>
<td>75.25</td>
</tr>
<tr>
<td>to 220100 AHV/ALV Payroll account</td>
<td>723.85</td>
</tr>
<tr>
<td>to 220200 SUVA Premium payroll account</td>
<td>160.50</td>
</tr>
<tr>
<td>to 220600 FAK payroll account</td>
<td>82.50</td>
</tr>
<tr>
<td>to 222100 Pension funds payroll account</td>
<td>720</td>
</tr>
<tr>
<td>to 2251000 Payment account</td>
<td>4,694.50</td>
</tr>
</tbody>
</table>

The relevant posting records are as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>400000 Wages and salaries</td>
<td>5,500</td>
<td></td>
</tr>
<tr>
<td>400200 13. 13th Month Wage</td>
<td>458.35</td>
<td></td>
</tr>
<tr>
<td>405100 Social insurance AHV/ALV/FAK</td>
<td>446.10</td>
<td></td>
</tr>
<tr>
<td>405200 Round up pension fund</td>
<td>360.00</td>
<td></td>
</tr>
<tr>
<td>405300 Social insurance BU/NBU</td>
<td>75.25</td>
<td></td>
</tr>
<tr>
<td>to 220100 AHV/ALV Payroll account</td>
<td>723.85</td>
<td></td>
</tr>
<tr>
<td>to 220200 SUVA Premium payroll account</td>
<td>160.50</td>
<td></td>
</tr>
<tr>
<td>to 220600 FAK payroll account</td>
<td>82.50</td>
<td></td>
</tr>
<tr>
<td>to 222100 Pension funds payroll account</td>
<td>720</td>
<td></td>
</tr>
<tr>
<td>to 2251000 Payment account</td>
<td>4,694.50</td>
<td></td>
</tr>
</tbody>
</table>
### Example for Switzerland: Complete Posting

<table>
<thead>
<tr>
<th>to</th>
<th>226100 Reserve, cash discount 13th salary discount</th>
<th>458.35</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>6,839.70</td>
</tr>
<tr>
<td></td>
<td></td>
<td>6,839.70</td>
</tr>
</tbody>
</table>
Integration with the Posting of Payment Transactions

Use
Posting payroll results ensures that the personnel expenses that arise within the company are posted in Financial Accounting and Cost Accounting. The resulting payables are also offset as follows:

- Payables to employees are offset against the Wages and Salaries Payable account
- Payables to the recipients of the deductions retained from the employees are offset in additional payables accounts. This is country-specific.

Activities
These payables are triggered in Financial Accounting as follows:

- Payables against the employees are settled by payments.
- The receivables against third parties (for example, tax, social insurance) are settled by payments.

The following steps are performed for each transaction:
1. The amounts payable are calculated.
2. The amounts calculated are paid.
3. A Payables account to bank clearing account posting is created.

Steps 2 and 3 are performed either automatically or manually, based on the country and respective payment transaction.

When the appropriate account statements are created, the Bank clearing account to bank posting run clears the bank clearing account.

See also:
Germany: Integration with the Posting of Payment Transactions [Seite 593]
USA: Integration with the Posting of Payment Transactions [Seite 594]
Germany: Integration with the Posting of Payment Transactions

Use

Posting payroll results ensures that the personnel expenses within the company are posted to *Financial Accounting* and *Cost Accounting*. The resulting payables are also offset as follows:

- Payables to employees are offset against the *Wages and Salaries Payable* account.
- Payables to the tax office are offset against the *Taxes Payable* account.
- Payables to the social insurance agencies are offset against the *Social Insurance Contributions Payable* account.

In certain cases, further payables against other recipients can arise.

Activities

These payables are cleared in Financial Accounting as follows:

- Payables to employees are effected using payments (usually bank transfers).
- Taxes are based on the Employment Tax Notification and are transferred to the tax office with the other general company tax payments.
- The social insurance contributions payable are based on the Statement of Contributions and are transferred to the health insurance funds using the *Transfer to HI Fund* function.

The following graphic shows an overview of integration with the posting of payment transactions:

The following steps are performed for each of these payment transactions:

1. The amounts payable are calculated.
2. The amounts calculated are paid. This takes place based on the transaction either automatically or manually.
3. A *Payables account to bank clearing account* posting is created. You must perform this posting manually.

When the appropriate account statements are created, the *Bank clearing account to bank* posting run clears the bank clearing account.
USA: Integration with the Posting of Payment Transactions

In the USA, payables against the tax authorities and other vendors are posted to the relevant vendor accounts using the function Third Party Remittance [Extern], they are then paid by the normal payment run in Financial Accounting.
Technical Aspects

You can use the Technical Aspects unit

- To get an overview of the technical process of Posting to Accounting
- To get information on the technical details
Technical Sequence of Posting

Purpose

Posting to Accounting includes the evaluation of the payroll results, the creation of posting documents and posting them in the Accounting components.

Process Flow

1. Each time Posting to Accounting is started, the system creates a posting run with a distinctive number. The posting run allows you to recreate the information edited at any time. The posting run has a different status at each point between the reporting of the payroll results and the posting of the summarized information.

2. The system evaluates the payroll results in view of information relevant to posting. If payroll results are evaluated for a live posting run, they are flagged. This ensures that the payroll results are not evaluated twice. The system can also use the selection to check whether any payroll results exist in a payroll period that has not been evaluated yet.

3. The system determines the symbolic account assignment from the wage types to be posted using the settings in Customizing. The system derives the employee grouping for the account assignment from certain characteristics of the employee. The system derives the G/L account from the combination of employee grouping and symbolic account. The account assignment objects are determined.

4. The system creates summarized posting documents from the data determined. These only contain information that is relevant for the Accounting components.

5. The system posts the posting documents directly to the Accounting components involved using the Accounting interface [Extern].
Posting-Relevant Information from Master Data, Time Data and Organizational Management

Certain information from master and time data and from Organizational Management [Extern] appears in the payroll result. When evaluating the payroll results for posting to Accounting, the system filters out the posting-relevant information from the payroll results.

Organizational Assignment

The Organizational Assignment infotype (0001) includes the assignment of the employee to a personnel area and a company code. This infotype also includes the assignment to a master cost center and to a business area. If you do not specify any other assignments, the system will use this assignment in posting to Accounting.

Cost Distribution from Organizational Management

In Organizational Management, you can specify a percentage cost distribution to several account assignment objects (cost centers orders or projects) for a position. It is possible to evaluate this cost distribution in Payroll, so that costs for the employee that would otherwise be posted to the master cost center are distributed to the required account assignment objects in the next posting. A cost distribution from Organizational Management can also be a result of the percentage assignment of an employee to several positions.

Cost Distribution from HR Master Data

In the Cost Distribution Infotype (0027) [Extern], you can specify a percentage distribution of costs to several account assignment objects (cost centers, orders or projects) for the employee. If you specify the cost distribution for an employee for a partial period of a payroll period in the Cost Distribution infotype (0027), the account assignments from the Organizational Assignment infotype (0001) (master cost center) and Organizational Management are not taken into consideration for this part of the costs.

Employee Remuneration

Information relevant to posting, in a broader sense, is contained in all infotypes that the system directly or indirectly uses to calculate an employee's remuneration in Payroll. The most important infotypes are:

- Basic Pay infotype (0008)
- Recurring Payments and Deductions infotype (0014)
- Additional Payments (0015)
- Absences infotype (2001)
- Attendances (2002)
- Substitutions (2003)
- Availability (2004)
- Overtime (2005)
- EE Remuneration Info (2010)

With the exception of the Basic Pay infotype (0008), you can specify a cost assignment in all the infotypes listed. If you enter the relevant data for cost assignment in one of these infotypes, this cost assignment and not the cost assignment from the infotypes Organizational Assignment.
Posting-Relevant Information from Master Data, Time Data and Organizational Management

(0001) and Cost Distribution (0027) or from Organizational Management is taken into consideration when posting to Accounting. However, this only applies when wage types are posted that were entered in these infotypes or created using them.

The list above is not a complete list of infotypes in which you can specify a cost assignment.

See also:

Posting to Substitute Cost Centers [Seite 613]
Posting to Fixed Cost Centers [Seite 662]
Posting to Funds Management [Seite 693]
Posting-Relevant Information in the Payroll Result

The following tables in the payroll result contain information relevant to posting:

- The Results Table (RT) contains the wage types saved in the payroll results, with information on the rate (RTE), number (NUM), and amount (AMT), as well as the assignments to other tables. The assignments to the tables Work Center/Basic Pay (WPBP), Cost Distribution (CO), and Cost Assignment from Various Infotypes (C1) play a central role in the posting of payroll results.

- The Work Center/Basic Pay table (WPBP) contains central partial period information from the following infotypes (as well as derived information):
  - Actions (0000)
  - Organizational Assignment (0001)
  - Planned Working Time (0007)
  - Basic Pay (0008)

- The Cost Distribution (CO) table contains information from cost distribution within Organizational Management or from the Cost Distribution infotype (0027). The entries in the Cost Distribution (CO) table are assigned to entries in the Work Center/Basic Pay (WPBP) table.

- The table Cost Distribution from Various Infotypes (C1) contains the cost assignments from various infotypes. For a list of the most important infotypes in which you can specify a cost assignment, see Posting-Relevant Information from Master Data, Time Data and Organizational Management [Seite 597]. Those entries in the Results Table (RT) that contain wage types that were entered in one of these infotypes with a cost assignment or were created from it, link to the relevant entries in the table Cost Distribution from Various Infotypes (C1). A prerequisite for this is that the link to the table Cost Distribution from Various Infotypes (C1) was not deleted in the payroll calculation rules.

You can consider the payroll results from various points of view. The following functions are available:

<table>
<thead>
<tr>
<th>Perspective</th>
<th>Function</th>
<th>Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee</td>
<td>Remuneration Statement</td>
<td>Payroll → Payroll → Remuneration statement</td>
</tr>
<tr>
<td>Department</td>
<td>Wage Type Statement</td>
<td>Payroll → Information System → Wage Type → Wage Type Statement</td>
</tr>
<tr>
<td>Department</td>
<td>Payroll Journal</td>
<td>Payroll → Information System → Organizational Unit → Payroll Journal</td>
</tr>
<tr>
<td>Technical</td>
<td>Display cluster Rx</td>
<td>Payroll → Tools → Display Payroll Results</td>
</tr>
</tbody>
</table>

When posting to Accounting, the system evaluates the information in the payroll result tables for each personnel number in the following way:

- It determines the posting characteristics defined in Customizing for every wage type contained in the Results Table (RT).

- If a wage type should be posted to an expenses account in accordance with Customizing, the system checks if the entry for this wage type in the Results Table (RT) links to an entry in the table Cost Distribution from Various Infotypes (C1). If this is the case, the system posts the wage type amount to this cost assignment. If you have, however, specified that cost
Posting-Relevant Information in the Payroll Result

Assignments from the table *Cost Distribution from Various Infotypes (C1)* should be ignored in the posting characteristics for the wage type, the system does not post the wage type amount to the specified cost assignment.

- If the entry for a wage type in the *Results Table (RT)* does not link to an entry in the table *Cost Distribution from Various Infotypes (C1)* or the cost assignment specified is ignored because of the wage type’s posting characteristics, the system checks if the entry in the *Results Table (RT)* refers to a Partial Period in the *Work Center/Basic Pay Table (WPBP)* [Extern]. If this is the case this partial period is selected. If this is not the case, the system selects the last partial period in the table *Work Center/Basic Pay (WPBP)*.

- The system checks if a cost distribution in the *Cost Distribution (CO)* table is specified for the period defined in the table *Work Center/Basic Pay (WPBP)*.
  - If this is the case, the system posts the wage type amount on a percentage basis to this cost assignment. If a cost assignment of less than 100% is specified in the table *Cost Distribution (CO)*, the system posts the remaining amount to the master cost center that is specified for the respective partial period in the table *Work Center/Basic Pay (WPBP)*.
  - If this is not the case, the system posts the total wage type amount to the master cost center that is specified for the respective partial period in the table *Work Center/Basic Pay (WPBP)*.

- If a wage type is posting-relevant according to Customizing but should not be posted to an expenses account, the system checks if the entry for this wage type in the *Results Table (RT)* links to a partial period in the table *Work Center/Basic Pay (WPBP)*. If this is the case this partial period is selected. If this is not the case, the system selects the last partial period in the table *Work Center/Basic Pay (WPBP)*. The system reads the company code, and if necessary, the business area from the defined partial period, and posts the wage type amount using this information as a basis. The business area is not taken into consideration when posting to customer and vendor accounts.

Evaluating Tables in the Payroll Result for Posting to Accounting
Example: Posting-Relevant Information in the Payroll Result

The following basic conditions apply for an employee:

- Your employee is assigned to the *Central Development* master cost center.
- The basic pay is 5,000.00.
- From January 01 – January 15, the employee works for the *Product Planning* cost center for 50% of the time and for the master cost center for 50% of the time.
- From January 16 - January 31, your employee works for the *Sales* cost center (30%) and for the *Quality assurance* cost center (70%).
- On January 16, your employee receives a one-off payment of 100.00 from the *Training* cost center.

This affects the payroll results for the payroll month of January as follows:

**Work Center / Basic Pay Table (WPBP)**

<table>
<thead>
<tr>
<th>WPBP Partial Period</th>
<th>From - To</th>
<th>Company Code</th>
<th>Master Cost Center</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>01.01-15.01.</td>
<td>0001</td>
<td>Central development</td>
</tr>
<tr>
<td>02</td>
<td>16.01-31.01.</td>
<td>0001</td>
<td>Central development</td>
</tr>
</tbody>
</table>

**Results Table (RT)**

<table>
<thead>
<tr>
<th>Wage type</th>
<th>WPBP Partial Period</th>
<th>Cost Accounting</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly salary (M020)</td>
<td>01</td>
<td></td>
<td>2,400.00</td>
</tr>
<tr>
<td>Monthly salary (M020)</td>
<td>02</td>
<td>0001</td>
<td>2,600.00</td>
</tr>
<tr>
<td>One-off payment (M110)</td>
<td>02</td>
<td>0001</td>
<td>100.00</td>
</tr>
<tr>
<td>Bank transfer (/559)</td>
<td></td>
<td>0001</td>
<td>5,100</td>
</tr>
</tbody>
</table>

**Cost Distribution Table (C0)**

<table>
<thead>
<tr>
<th>WPBP Partial Period</th>
<th>SeqNr</th>
<th>Company Code</th>
<th>Cost Center</th>
<th>Percent</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>01</td>
<td>0001</td>
<td>Product planning</td>
<td>50</td>
</tr>
<tr>
<td>02</td>
<td>01</td>
<td>0001</td>
<td>Sales and distribution</td>
<td>30</td>
</tr>
<tr>
<td>02</td>
<td>02</td>
<td>0001</td>
<td>Quality assurance</td>
<td>70</td>
</tr>
</tbody>
</table>

**Table of Cost Distribution from Different Infotypes (C1)**

<table>
<thead>
<tr>
<th>Cost Accounting</th>
<th>Company codes</th>
<th>Cost center</th>
</tr>
</thead>
<tbody>
<tr>
<td>0001</td>
<td>0001</td>
<td>Training</td>
</tr>
</tbody>
</table>

This information in the payroll results tables is evaluated by the *Posting to Accounting* component as follows:
Example: Posting-Relevant Information in the Payroll Result

**Posting Wage Type Monthly Salary (M020) for WPBP Partial Period 01:**

1. The system reads the *Monthly Salary* wage type (M020) for work center 01 from the *results table* (RT).
2. The system reads the posting characteristics for the wage type in Customizing and identifies that this wage type is to be posted to an expense account.
3. The system checks whether there is an entry for this wage type in the *Cost Distribution from Different Infotypes* table (C1). This is not the case.
4. The system checks whether the entry for this wage type in the *results table* (RT) refers to a partial period in the *Work Center Basic Pay* table (WPBP) and identifies the partial period January 01 – January 15.
5. The system checks whether cost distribution has been specified in the *Cost Distribution* table (C0) for this partial period and identifies a distribution of 50% to the *Product Planning* cost center.
6. The system posts 50% of the wage type amount to this cost center (1,200 to the *Product Planning* cost center).
7. The system checks whether the wage type amount has been distributed at 100%. This is not the case. For this reason, the system posts the remaining amount (50% = 1,200) to the master cost center for the employee (*Central Development*). The wage type amount is then completely posted.

**Posting Wage Type Monthly Salary (M020) for WPBP Partial Period 02:**

1. The system reads the *Monthly Salary* wage type (M020) for work center 02 from the *results table* (RT).
2. The system reads the posting characteristics for the wage type in Customizing and identifies that this wage type is to be posted to an expense account.
3. The system checks whether there is an entry for this wage type in the *Cost Distribution from Different Infotypes* table (C1). This is not the case.
4. The system checks whether the entry for this wage type in the *results table* (RT) refers to a partial period in the *Work Center Basic Pay* table (WPBP) and identifies the partial period January 16 – January 31.
5. The system checks whether cost distribution has been specified in the *Cost Distribution* table (C0) for this partial period and identifies a distribution of 30% to the *Quality Assurance* cost center.
6. The system posts the wage type amount, which is distributed on a percentage basis, to the cost centers (780 to the *Product Planning* cost center and 1,820 to the *Quality Assurance* cost center).
7. The system checks whether the wage type amount has been distributed at 100%. This is the case. The wage type amount is then completely posted.

**Posting the One-Off Payment Wage Type (M110):**

1. The system reads the *One-Off Payment* wage type (M110) from the *results table* (RT).
2. The system reads the posting characteristics for the wage type in Customizing and identifies that this wage type is to be posted to an expense account.
Example: Posting-Relevant Information in the Payroll Result

3. The system checks whether an entry for this wage type exists in the Cost Distribution from Different Infotypes table (C1) and identifies that the wage type amount is to be posted to the Training cost center.

4. The system posts the wage type amount to the cost center.

Posting Bank Transfer Wage Type (/559)

1. The system reads the Bank Transfer wage type (/559) from the results table (RT).

2. The system reads the posting characteristics for the wage type in Customizing and identifies that this wage type is to be posted to a balance sheet account.

3. The system checks whether the entry for this wage type in the results table (RT) refers to a partial period in the Work Center Basic Pay table (WPBP). This is not the case. The system chooses the last partial period in the Work Center/Basic Pay table (WPBP) (16.01 – 31.01).

4. The system reads the company code 0001 from the partial period for the Work Center/Basic Pay table (WPBP) and posts the wage type amount to this company code.

Posting Documents

The system creates the following posting document for the described postings:

Company code 0001

<table>
<thead>
<tr>
<th>G/L account</th>
<th>Cost Center</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Salaries</td>
<td>Product planning</td>
<td>1,200.00</td>
<td></td>
</tr>
<tr>
<td>Salaries</td>
<td>Central development</td>
<td>1,200.00</td>
<td></td>
</tr>
<tr>
<td>Salaries</td>
<td>Sales and distribution</td>
<td>780.00</td>
<td></td>
</tr>
<tr>
<td>Salaries</td>
<td>Quality assurance</td>
<td>1820.00</td>
<td></td>
</tr>
<tr>
<td>Salaries</td>
<td>Training</td>
<td>100.00</td>
<td></td>
</tr>
<tr>
<td>Wages and salaries to be paid</td>
<td></td>
<td></td>
<td>5,100.00</td>
</tr>
</tbody>
</table>
Account Determination

Use

You can use Customizing for Posting to Accounting to determine which wage types are posted, and to which Financial Accounting accounts the amount contained in these wage types should be posted. If you perform posting to Accounting, the wage types from the payroll results to be posted are posted to the assigned accounts. This automatic process is called account determination.

With the help of the report Display Assignment of Wage Types to G/L Accounts (RPDKON00) [Extern], you can specify which wage types are posted to which accounts.

Accounts are determined in the following steps:

1. The system determines the assigned symbolic account from the wage type.
2. The assigned Financial Accounting account (G/L account, customer account or vendor account) is determined from the symbolic account.

The two-stage procedure is advantageous since Payroll is separated from the Accounting components by the “Symbolic Account” interface. If there are organizational changes in Accounting, the symbolic account assignment of the wage types remains unaffected. On the other hand, payroll changes do not necessarily cause changes to the account assignment settings in the Accounting components.

Activities

In Customizing for posting to Accounting, you can assign a G/L account to a symbolic account in the following ways:

- You assign a G/L account to a symbolic account.
- You assign various G/L accounts to a symbolic account, irrespective of the employee grouping for account determination, for example, you assign the G/L account Wages to the symbolic account Wages and salaries for industrial workers, and you assign the G/L account Salaries to the symbolic account Wages and salaries for salaried employees.

For account determination to run successfully, you must specify the account assignment type for every symbolic account in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → Activities in the HR System → Employee Grouping and Symbolic Accounts → Define Symbolic Accounts. This specifies if the posting is a G/L account posting, a customer posting or a vendor posting.

During account determination, the system determines the relevant account in Financial Accounting for every symbolic account using the account assignment type and the value of the employee grouping for account determination.
See also:
Germany: Account Determination for Specific Service Types in Accordance with the KHBV/PBV
[Seite 687]
Document Split Account

Definition

An object in Accounting used as a clearing account within posting to Accounting.

Use

When posting to Accounting, various situations require the posting data to be split into several documents.

If it is necessary to split documents but a document split account was not set up in the system, posting to Accounting cannot take place. For this reason, you should set up a document split account and assign the account planned for this purpose, even if it does not appear necessary to split documents when the system is introduced.

You assign a document-split account to the relevant symbolic accounts in Payroll Customizing (under Reporting for Posting Payroll Results to Accounting → Activities in the AC System → Assign Accounts → Assign Technical Accounts).

The system splits the document in the following situations:

- The posting data contains posting records with a different posting date or different posting periods.
- The posting data contains posting records with different company codes.
- The posting data does not only contain G/L account postings but also payable/receivable postings.
- Document split control that is stored in the posting variant used requires you to split the documents.
- The size of the posting data makes it necessary to split the documents.

If the system splits documents in one of these situations, the posting items do not always have a balance of zero. If the balance of the posting items for a document is not equal to zero, an item for the relevant posting to the document split account is added to this document in order to clear the balance of this document.

If you use business areas [Extern] in Financial Accounting, the system makes sure that the balance within a G/L account document is zero for each business area when posting to Accounting. To do so, the system adds postings to the document split account under specification of the business area. Thus, the document split account is only posted to if the document has not been split but the balance of the posting items has not been cleared for each business area.
Posting Retroactive Accounting Data

Use

When posting retroactive accounting data, the posting run for the previous payroll result is reversed (posting with reversed sign) and the new payroll result is posted for the payroll periods accounted retroactively.

The summarization of posting information performed in posting to Accounting has the following effect when posting retroactive accounting data:

- If only the amount changes, the difference is posted.
- If the account assignment objects also change, the amount in the old account assignment objects is cancelled and posted to the new ones.

At the time of posting, Financial Accounting has usually closed the previous posting periods [Seite 612]. For this reason, the retroactive accounting data is posted in the posting period that belongs to the current payroll period (with the exception of posting to special periods [Seite 664]).

If, at the time of posting retroactive data, the previous payroll result for the retroactively accounted period was already posted in Accounting, the system does not evaluate this payroll result a second time using Customizing to reverse the posting. Instead, the system evaluates the posting run that was created for this payroll result. In the process it determines

- Which wage types were posted
- Which symbolic accounts were used
- With which account assignment type the posting took place
- With which Employee grouping for the account determination this posting took place
- Which entries from the payroll results tables (for example, table WPBP, C0, C1) were evaluated

The system reverses the posting using this information.

See also:

- Example: Posting Retroactive Accounting Data [Seite 608]
- Recalculation Differences [Seite 610]
- Retroactive Accounting [Seite 42]
Example: Posting Retroactive Accounting Runs

In period 1, an employee receives monthly remuneration of 5,000. In period 2, basic remuneration is increased retroactively to 6,000 for period 1 and all subsequent periods. The following graphic shows only the basic wage types that are relevant in posting:

- Since wage type /560 (Net Pay) is not posted, the posting-relevant wage type /559 (Bank Transfer) is taken into account for the payment.
- No other payments or deductions are taken into consideration. The payment amount (wage type /559 Bank Transfer) therefore represents the monthly remuneration for the employee (wage type M020).

Part I: Consideration of Payroll Results

In period 01, the monthly salary for the employee is 5,000 (wage type M020). This amount is paid out to the employee (wage type /559 Bank Transfer). As a result of the retroactive accounting run, a new payroll result is created in period 02 for period 01. In this result, the basic remuneration is increased to the new agreed amount of 6,000 (M020). The payment amount in period 01 remains unchanged (wage type /559 Bank Transfer). The difference of 1,000 is recorded in the separate wage type /551 Recalculation Difference.

In period 2, the employee receives 7,000 (wage type /559 Bank Transfer). This is due to the retroactive remuneration increase. This amount consists of the monthly salary for period 2 (wage type M020 = 6,000) and the retroactive salary increase for period 1 (wage type /552 Subs.clearing/prev.month = 1,000).

If the tax is calculated according to the principle of origin, wage types /551 Recalculation Difference and /552 Subs.clearing/prev.month are formed when retroactive differences are created. However, if the tax is calculated according to the inflow principle, other wage types may be relevant to posting with regard to retroactive differences either instead of or in addition to these wage types.

Part II: Consideration of Postings

When this retroactive run is posted, the posting for payroll result period 01 in period 01 is reversed. In this way, the posting of wage type M020 creates a balance of 7,000, which is posted to the debit side of the remuneration account as an expense. The posting of the payment amount (wage type /559) creates a balance of 7,000, which is posted to the credit side of the Payments...
account as a payable. In the posting, the amounts for wage types /551 and /552 create a balance of zero. Therefore, no posting is created from these recalculation differences.

Part III: Consideration of Accounts

7,000 are posted to the debit side of the Remuneration account. 7,000 are posted to the credit side of the Payments account. There is no posting to the recalculation difference account. A retroactive run can, for example, trigger a posting to the recalculation difference account if several company codes are affected by the retroactive run.

See also:

Recalculation Differences [Seite 610]

Cross-Company Code Transactions [Seite 666]
Recalculation Differences

Use

Creation of Recalculation Differences in Payroll

In retroactive runs, the amounts of the Payment Amount wage type /560 are not changed. The system calculates a new payment amount for the previous period; however; it does not save this amount. Instead, it creates the amount for the Recalculation Difference wage type (/551) from the difference between this amount and the original payment amount.

The system saves this amount in the results table (RT) from the new payroll results for the period recalculated and transfers it to wage type /552 Subs.clearing/prev.month for the current period. The system stores the amount for wage type /552 (Subs.clearing/prev.month) in the results table (RT) from the original results for the current period.

Wage types /551 (Recalculation Difference) and /552 (Subs.clearing/prev.month) have opposite positive (+)/negative (-) signs:

<table>
<thead>
<tr>
<th>Change</th>
<th>Sign /551 Recalculation Difference</th>
<th>Sign for /552 Subs.clearing/prev.month</th>
</tr>
</thead>
<tbody>
<tr>
<td>A remuneration element for an employee is increased retroactively</td>
<td>Negative</td>
<td>Positive</td>
</tr>
<tr>
<td>A remuneration element for an employee is reduced retroactively</td>
<td>Positive</td>
<td>Negative</td>
</tr>
</tbody>
</table>

Posting Recalculation Differences

When the system posts the payroll results to Accounting, it checks that the balance of the single items to be posted is zero for each employee and payroll result. For this reason, you must code the wage types /551 (Recalculation Difference) and /552 (Subs.clearing/prev.month) as relevant to posting in Customizing. If you fail to do so, the balance per payroll result will not be zero if recalculation differences occur, as you cannot change the amount for wage type /559 Bank Transfer retroactively.

Due to the opposite positive/negative signs, the total of wage types /551 (Recalculation Difference) and /552 (Subs.clearing/prev.month) is zero for the employee. For this reason, these wage types do not usually create a posting, even though they are coded as relevant for posting. However, this does not apply if company code clearing is not used, and a retroactive run including the period before the employee changed company code is carried out after a change in company code. For more information and an example of posting, see Retroactive Accounting for
Recalculation Differences

Summary Clearing [Seite 670]. Other exceptions are retroactive runs over the end of the fiscal year and posting to special periods.

We recommend that you set up a different clearing account in Accounting for posting recalculation differences. This clearing account should not be used for any other postings.

If the tax is calculated according to the principle of origin, wage types /551 Recalculation Difference and /552 Subs.clearing/prev.month are formed when retroactive differences are created. However, if tax is calculated according to the inflow principle, other wage types may be relevant to postings concerning retroactive differences (either instead of or in addition to these wage types).

See also:
Posting Retroactive Accounting Data [Seite 607]
Example: Posting Retroactive Accounting Runs [Seite 608]

Prerequisites

You must set up the system correctly in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting, to ensure that recalculation differences are posted correctly to Accounting.

- You must define a symbolic account for recalculation differences (under Activities in the HR System → Employee Grouping and Symbolic Accounts → Define Symbolic Accounts)
- You must assign the symbolic account for recalculation differences to the corresponding wage types (under Activities in the HR System → Maintain Wage Types → Define Posting Characteristics of Wage Types)
- You must assign a balance sheet account from Accounting to the symbolic account (under Activities in AC System→ Assigning Accounts → Assign Balance Sheet Accounts)
Posting Period and Posting Date

Posting Period and Posting Date

The system usually determines the posting date from the current payroll period. As a result, retroactive accounting runs are also posted with the posting date that originates from the current payroll period. Posting to Special Periods [Seite 664] is an exception to this rule.

The Accounting components determine the posting period that is posted to, from the posting date.

Use

You have the following options for specifying the posting date:

- Using the relevant settings in the table of date specifications for a specific period in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → Activities in the HR System → Maintain the Posting Date for Payroll Periods

- By manual entry in the step Create posting run in the Specifications for posting date group box

- By setting the Acc.to payment indicator in the step Create posting run in the Posting date specification group box. However, use of the payment date, as a posting date is only useful in countries in which the payment date is given a relevant meaning (for example, USA, Canada, Japan).

In some countries, payroll periods and posting periods can have different lengths. If the start and finish of a payroll period are in different posting periods for a weekly payroll run, it is necessary to distribute the expense from this payroll period (proportionally) to two posting periods. In some countries, this is possible with the help of the Month-End Accruals [Seite 568] function.
Posting to Substitute Cost Centers

Use

Particularly for objects such as orders or projects to which can only be posted for a limited period of time, or after a change in the cost center structure, it may not be possible to post to certain account assignment objects in cost accounting.

In this case, the system posts to the master cost center instead, which is set in the infotype Organizational Assignment (0001). This master cost center is determined from the last partial period from the table Work Center/Basic Pay (WPBP) for the current payroll result.

If this master cost center is in a different company code, or cannot be posted to, the system posts to a substitute cost center.

The system logs the substitution of account assignment objects in the document. You must check these substitutions and perform manual postings after executing posting to Accounting if the expense should not remain in the account assignment objects determined on a substitution basis.

Prerequisites

You must have set up the substitute cost center in cost accounting, and assigned it in Payroll Customizing (under Reporting for Posting Payroll Results to Accounting → Activities in AC system → Assign Substitute Cost Centers).
Substitution Logic for Closed CO Account Assignment Objects

Purpose

The substitution logic for closed CO account assignment objects assumes that you manually repost posting items, which the system posts to the substitute cost centers, to other account assignment objects. This will be explained in the following example.

An employee gets a salary of 5,000 and changes his/her master cost center on the 1st January 2000 (from the cost center Special Development to the cost center Training). The cost center Special Development is closed as of 31st December 1999. By mistake, you do not enter the employee’s change of cost center in the master data before completing payroll for period 01 in 2000. For this reason, the Workplace/Basic Pay (WPBP) table in the payroll results 01 in 01 contains the Special Development cost center.

Process Flow

Posting for Payroll Period 01

1. As it is not possible to post to the Special Development cost center, the system posts the expense of 5,000 (for the employee’s salary) to the substitute cost center that you have specified in Customizing.

2. The system documents the substitution of the account assignment object in the posting document to remind you that you must manually repost the expense of 5,000 from the substitute cost center to the employee’s new master cost center (Training).

3. You perform the reposting.

Retrospective Change in Master Data and Retroactive Accounting

1. Following the payroll run for period 01/2000, you enter the change in cost center in the employee’s master data.

2. This change in master data leads to a retroactive accounting run in period 02/2000. The Workplace/Basic Pay (WPBP) table in the payroll results 01 in 02 contains the correct Training cost center.

Posting for Payroll Period 02

The system compares the payroll results 01 in 01 and 01 in 02 and (because of the change in cost center) tries to cancel the amount of 5,000 on the cost center for the result 01 in 01 (Special Development) and post it to the cost center for the result 01 in 02 (Training). However, as the cost center Special Development is closed, the system uses the current master cost center (Training), which it determines from the last partial period in the table Workplace/Basic Pay (WPBP) for the current payroll result (02 in 02).
1. The system thus cancels the amount of 5,000 on the *Training* cost center.
2. The system also posts the amount of 5,000 to the *Training* cost center.
3. When checking the posting documents [Seite 625] you realize that these two postings cancel each other out and that the amount of 5,000, which you manually posted to the *Training* cost center remains in this cost center.

**Result**

If you would not repost manually after posting the payroll results 01/2000, the system would still perform the same postings to the *Training* cost center when posting the payroll results 02/2000. In this case, the expense of 5,000 would remain on the substitute cost center and the expense of 5,000 for the salary that the employee received in the payroll period 01/2000 would be missing on the *Training* cost center.

The following table shows an overview of which posting you must perform in this example and which postings are made by the system. To keep the explanation simple, posting the salary for period 02/2000 is not taken into consideration.

<table>
<thead>
<tr>
<th>Posting for Payroll Period</th>
<th>Cost Center Special Development</th>
<th>Cost Center <em>Training</em></th>
<th>Substitute cost centers</th>
<th>Posting performed by</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td></td>
<td>+ 5,000</td>
<td></td>
<td>the system</td>
</tr>
<tr>
<td>01</td>
<td></td>
<td>+ 5,000</td>
<td>- 5,000</td>
<td>the user</td>
</tr>
<tr>
<td>02</td>
<td></td>
<td>- 5,000</td>
<td></td>
<td>the system</td>
</tr>
<tr>
<td>02</td>
<td></td>
<td>+ 5,000</td>
<td></td>
<td>the system</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td>+ 5,000</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>
Steps

You can use the *Steps* unit

- To inform yourself, at a glance, which steps you must carry out to [perform the posting](#)
- To call detailed descriptions of these steps
- To gain information on steps within posting, which you only need to perform in certain situations (for example, deleting a posting run, reversing posting documents)
Performing the Posting

Purpose

Posting to Accounting includes the evaluation of the payroll results, the creation of summarized documents and posting them in the Accounting components.

The documents created in posting to Accounting contain summarized information. However, provided you have authorization, you can trace back which information (from the payroll results) the posting documents are based on for a specific personnel number.

If documents have been posted with an incorrect posting date, you can also reverse [Seite 642] a posting run.

You can also archive the data created in posting to Accounting. For more information, see Archiving Posting Documents (PY-XX-DT) [Extern] and Archiving Index Files (PY-XX-DT) [Extern].

Prerequisites

You have successfully run payroll.

Process Flow

When posting to Accounting, you carry out the following activities:
1. Simulating a Posting Run
2. Creating A Posting Run
3. Checking a Posting Run
4. Checking the Posting Documents
5. Releasing Posting Documents
6. Posting Posting Documents
7. Checking Accounting Documents
8. Checking the Completeness of the Postings
9. Subsequent Activities in Financial Accounting

Result

You have posted the personnel expenses and payables to the accounts and account assignment objects in the Accounting components.
Simulating a Posting Run

Use

We recommend that you simulate a posting run both before and after completing payroll. In this way, you can recognize posting-relevant errors in the payroll results early on, and avoid errors when creating a live posting run.

You can repeat simulation of posting runs as often as you require, as this does not, unlike creating a live posting run, lead to the payroll results being selected.

You have two options for simulating a posting run:

- Creating a **test run** without posting documents (limited check). The system performs the following activities:
  - It selects the payroll results.
  - It determines the posting-relevant information and the wage types to be posted.
  - It determines the symbolic accounts and the employee grouping for account determination.
    - In this way, the system creates individual items, which, unlike the posting documents for a simulation run, are not saved. The system finally checks if the balance of these individual items is equal to zero for each payroll result.

- Creating a **simulation run** with posting documents (complete posting). The system performs the following activities:
  - It creates a posting run and marks it as being a simulation run. For this reason, the system does not post the posting documents for this posting run.
  - The posting documents are put through the same checks as the posting documents from a live posting run.

Simulating A Posting Run before Finishing Payroll

Before completing payroll, you should create a simulation run to recognize posting-relevant errors in the payroll result early on. If you do not want to create a simulation run at this stage, you should at least create a test run.

Simulating A Posting Run after Finishing Payroll

After finishing payroll, you should create a simulation run in order to check the posting documents (this may have to be approved by Accounting). Remove any possible causes of errors and repeat creation of the simulation run, until technically correct posting documents with the right contents are created. You should only create a live posting run at this point in time.

Procedure

You proceed as described in creating a posting run [Seite 621]. When doing so, bear the following special feature in mind:

- If you want to create a test run, enter the value **T** in the field *Document creation type* (in the *Run attribute* group box).
If you want to create a simulation run, enter the value S in the field Document creation type (in the Run attribute group box).

If you want to have a complete log of a number of personnel numbers (selected for test purposes) that is easy to keep track of, set the Display log indicator in the Run attribute group box. We advise you against creating a complete log for a larger number of personnel numbers. Even if you do not set the Display log indicator, the system produces a log if there are errors for the personnel numbers affected.

**Result if Successful**

In the case of test runs, the system displays a detailed log if you have set the Display log indicator in the step Create posting run. If you have not set the Display log indicator, the system displays statistics for the evaluated personnel numbers.

In the case of simulation runs, the system creates a posting run and marks it as a simulation run. This prevents the accompanying posting documents being posted. The simulation run gets the status Documents created and is saved. The accompanying posting documents get the status created. An index is created for all processed payroll results. This ensures that the origin of a document item can be retraced, provided that the original payroll result has not been replaced as the result of a correction run. For more information, see [Displaying Revision information](Seite 641)

**Result if Unsuccessful**

In the case of test runs, the system displays a log containing the relevant error messages.

In the case of simulation runs, various errors can occur:

- If an error occurs when selecting or processing the payroll results for individual employees, the system rejects the incorrect personnel numbers and does not include them in the document. The log contains a relevant error message.

- If an error occurs when creating the document, a relevant error message appears in the document display after the document has been created. The posting run gets the status Documents incorrect. The accompanying posting documents get the status incorrect.

- Certain situations in which an error occurs (for example, rejection of all personnel numbers) can lead to no documents being created. In this case, the log contains the comment No documents created. The posting run gets deleted status.
Simulating a Posting Run

Delete the simulation runs you no longer require to avoid creating unnecessarily large amounts of data. For more information, see deleting the posting run [Seite 637]
Creating a Posting Run

Use
After completing Payroll, you must create a live posting run to post the personnel expenses and payables to the accounts and account assignment objects in the Accounting components.

Before creating a live posting run you should have created a simulation run [Seite 618] with technically correct posting documents containing the correct information.

Prerequisites
You must have successfully run payroll for the personnel numbers, for which the payroll results should be evaluated for posting.

Payroll must have been completed for all payroll areas affected by posting.

A simulation run, with technically correct posting documents containing the correct information should have been created.

Procedure
1. Choose Human Resources → Payroll → Subsequent activities → Per payroll period → Posting to Accounting → Execute run.

2. To select the payroll period, you enter the payroll area and choose
   The current payroll period is displayed.
   If you want to evaluate a different payroll period to the current period, choose Other period and enter the period you require.

3. Make the necessary entries in the Selection group. Entering the payroll area usually makes the selection.

4. Enter the value P in the field Type of document creation.

5. You can enter a Text for the posting run. You can choose this text yourself. It helps identify the posting run in the overview of posting runs.

6. In the Document creation data group, specify the posting variant you require or copy the standard entry.

7. Only make settings for the options described in the following table in special cases.

8. To create the posting run, choose.
Creating a Posting Run

Controlling the Evaluation Report in Special Cases

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off-Cycle Payroll</td>
<td>If you want to evaluate the results of an Off-Cycle Payroll Run [Seite 127], enter the necessary data. Off-Cycle payroll runs only take place in certain countries.</td>
</tr>
<tr>
<td>Display log</td>
<td>If you set this indicator, after creating the posting run the system displays a log that contains detailed information, for example, the wage types evaluated for posting, for every personnel number for which payroll was performed. Only set this indicator if you want to process an easily comprehensible range of personnel numbers. The creation of a log for large numbers of personnel numbers requires a lot of memory space and is not recommended. If you do not set the Display log indicator, errors that occurred when creating the posting run are still displayed in a log for specific personnel numbers.</td>
</tr>
<tr>
<td>Cost planning</td>
<td>If you want to provide the results of the evaluation report as data for personnel cost planning [Seite 707], choose Cost Planning and make the necessary entries.</td>
</tr>
<tr>
<td>Default value for posting date group box</td>
<td>Here, you can specify the posting date [Seite 612] or make further entries for posting for special periods [Seite 664]. You should flag the Acc. to period definition indicator for regular posting runs.</td>
</tr>
<tr>
<td>Document date</td>
<td>You can enter a Document date in the Document creation data group box. If you do not enter a document date, the system uses the date on which the posting documents were created, therefore the current system date.</td>
</tr>
</tbody>
</table>

**Result if Successful**

If you have set the Display log indicator, the system displays a detailed log. If you have not set the Display log indicator, the system displays statistics for the evaluated personnel numbers.

The posting run created gets the status Documents created and is saved. It has a clear number. The accompanying posting documents get the status created.

An index of all processed payroll results is created. This makes it possible to trace creation of a document item although the documents have been summarized.

The system selects the processed payroll results to ensure that they are only posted once.

**Result if Unsuccessful**

The following errors can occur when creating a posting run:

- If an error occurs when selecting or processing the payroll results for individual employees, the system rejects the incorrect personnel numbers and does not include them in the document. The log contains a relevant error message.

- If an error occurs when creating the document, a relevant error message appears in the document display after the document has been created. The posting run gets the status Documents incorrect. The accompanying posting documents get the status incorrect.
Certain situations in which an error occurs (for example, rejection of all personnel numbers) can lead to no documents being created. In this case, the log contains the comment *No documents created*. The posting run gets *deleted* status.

For more information on the treatment of errors in posting, see [unselected or incorrect personnel numbers](#).
Checking a Posting Run

Use
After you have created the posting run, make sure that no errors occurred.

Prerequisites
You have performed the step creating a posting run [Seite 621].

Procedure
Go to the document overview [Seite 634] and check the status of the relevant posting run.

<table>
<thead>
<tr>
<th>Posting run status</th>
<th>Meaning (for live posting runs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents created</td>
<td>You have successfully created a posting run and can continue processing the posting run.</td>
</tr>
<tr>
<td>Incorrect documents</td>
<td>You must remove the error, delete the posting run and create a new posting run.</td>
</tr>
<tr>
<td>Deleted</td>
<td>When creating the posting run, the system rejected all the personnel numbers and did not create any documents. You must remove the error and create a new posting run.</td>
</tr>
<tr>
<td>Selection is running</td>
<td>Creation of the posting run is still running. It is also possible that the system interrupted creation of the posting run after the payroll results for individual personnel numbers were selected. In this case, you must delete the posting run and create a new posting run.</td>
</tr>
<tr>
<td>Document creation is triggered</td>
<td></td>
</tr>
<tr>
<td>Document creation is running</td>
<td></td>
</tr>
</tbody>
</table>

For notes on causes of errors, see the display of the posting documents for a posting run. The display of the history, attributes and details of a posting run can provide further indications of causes of errors. To view this, select the posting run in the overview of posting runs, then choose Go to and the relevant menu option.

See also:
Checking the Completeness of the Postings [Seite 631]
Checking the Posting Documents

Use
If you have performed the step Check posting run, you should check the posting documents for the posting run in question.

Prerequisites
You have created a posting run.

Procedure
1. In the document display [Seite 640], you check the line items in the posting documents created.
2. If necessary, check the revision information [Seite 641] for the individual line items.

If a posting run contains one or more incorrect posting documents, the system cannot post the correct posting documents, as it is only possible to post all the posting documents belonging to a posting run at the same time.

Therefore, if you discover errors when checking the posting documents, you must delete the posting run in question and create and check a new posting run, after removing the cause of the problem.

If the posting documents are correct, you can release them.
Releasing Posting Documents

Use
If, when checking a live posting run and the accompanying posting documents, you establish that all posting documents are technically correct and contain the right contents, you can post the posting documents. To do so, you must first of all release all posting documents for the posting run.

Procedure
1. Display the posting documents for a posting run in the document overview.
2. Select the posting documents that you want to release.
3. Choose \textit{Release posting document}. A dialog box appears in which you must confirm the release of the posting documents.
4. Choose \textbf{Yes} to release the posting documents or \textbf{No} to terminate the process.

Result
The released posting documents have the status \textit{Released}. If you have released all posting documents for a posting run, the posting run has the status \textit{All documents released}.

You should not reset the release status. If you find errors in a posting run after releasing the posting documents, you must delete it and create a new posting run.

Additional Information
You can grant authorization for the release of posting documents for every company code for another person.

However, another authorization is necessary for posting the documents. This authorization is not assigned for each company code, as it is only possible to post all posting documents for a posting run (which may belong to different company codes) at the same time. Posting posting documents should therefore be seen as a technical step, as the person responsible for the individual company codes has already given their approval for posting the posting documents by releasing them.

You can set up a workflow for the release of posting documents. The \texttt{PayrollAccDocument.Release} method from the business object \texttt{BUS7009} is used in this workflow. In Customizing, choose \texttt{Basis} \rightarrow \texttt{Business Management} \rightarrow \texttt{SAP Business Workflow} \rightarrow \texttt{Perform Task-Specific Customizing}, and from there, choose the following path from the component hierarchy under \texttt{Payroll} \rightarrow \texttt{Payroll: General Parts} \rightarrow \texttt{Transfer}, to make settings for the task \texttt{Release posting document}.

The standard task \texttt{PY EVDOCREL} is provided as a model. When this event is triggered, the task sends a work item containing the above method.
For general information on workflows, see the SAP Business Workflow (BC-BMT-WFM) [Extern].
Posting Posting Documents

Use
After you have released all the posting documents for a posting run, and the posting run thus has the status *All documents released*, you can post the posting documents.

You must post all the posting documents belonging to a posting run together in the *Accounting* components. Individual posting documents cannot be posted.

Prerequisites
The posting run has the status *All documents released*.

Procedure
1. Go to the overview of posting runs.
2. Select the required posting runs.
3. Choose [ ].
   A dialog box is displayed, in which you must confirm that you want to post the posting documents for the selected posting runs.
4. Choose *Immediately* or *Create job*, to start the reversal or [ ] to cancel the reversal.

Result if Successful
If you use *Human Resources* and *Accounting* in the same system, the posting documents were posted in the components affected in *Accounting*. The posting run has the status *Documents posted*.

If you use *Human Resources* and *Accounting* in separate systems, posting does not take place simultaneously in the Accounting components. The system creates Idocs for the posting documents for a posting run. The posting run gets the status *Documents transferred*. The Idocs are sent to the logical system, in which the posting documents should be posted, using the ALE interface. When processing the Idoc in the target system, the posting documents are posted in the Accounting components affected.

If agreed with Accounting, you can reverse posting documents [Seite 642] that have been posted, if this is necessary because of an error in the contents.
Result if Unsuccessful

The posting run has the status *Document transfer has failed*. Posting to Accounting did not take place.

Depending on the error that occurred, it may be a good idea to start posting this posting run once again. If the error still occurs and it is not possible to post the posting run, you must delete the posting run and create a new one.
Checking Accounting Documents

Use

The Accounting components create their own posting documents based on the summarized posting documents. You should check these documents after you have posted the posting documents for a posting run.

Prerequisites

- The relevant posting run has the status *Documents posted* when Payroll and Accounting are in one system.
- The relevant posting run has the status *Documents posted* when Payroll and Accounting are in distributed (separate) systems.

Procedure

1. Go to the document overview.
2. Select the posting document you require.
3. Choose Goto → Accounting documents.
   A dialog box appears with a list of the accounting documents created.
4. Selected the accounting document you require.

Result

You see the document that the specified Accounting component has created.

For more information, see Accounting Documents Were Not Created [Seite 712]
Checking the Completeness of the Postings

Use

When checking a posting run or after you have posted the posting documents for one or several posting runs, you can use the completeness check to make sure that all employees that were included in the payroll run were taken into consideration when reporting for posting to Accounting.

During the completeness check, the system checks if all the existing payroll results were evaluated for posting to Accounting and therefore selected.

During this check, the system possibly processes very large amounts of data. It can therefore be time-consuming and put pressure on the system.

Procedure

1. In Payroll, choose Subsequent Activities → Per Payroll Period → Posting to Accounting → Completeness Check.
2. Enter a date, from which the completeness of the posting should be checked and choose

During the check, all the payroll results are checked that were created after the date specified.

Bear in mind that this check can only be made for payroll results that have been included in a payroll run and posted with an R/3 system of 4.0A or above.

Result

The system displays a list of the following information:

- Existing payroll rules that were not evaluated for posting to Accounting.
- Live posting runs that do not have any of the following statuses:
  - Transferred
Checking the Completeness of the Postings

- Posted
- Deleted
- Reversed
- Archived
- Partially archived
**Subsequent Activities in Financial Accounting**

**Use**
After performing *posting to Accounting*, you should perform certain reconciliation tasks and checks in Accounting.

**Prerequisites**
You have performed posting to Accounting and successfully posted the posting documents in the relevant Accounting components.

**Procedure**
For example, in Financial Accounting, the following steps are amongst the checks to be made:

- Comparison of transferred and posted payables.
- Checking of the retention amount for advances.
- Checking of the retention amount for claims.
- Clearing the cross-company-code activities:
Displaying an Overview of the Posting Runs

Use
In the overview of posting runs you can display a list of all available posting runs.

After you have created a posting run, the posting run overview is the starting point for all other actions that you perform with reference to the posting run:

- Checking a posting run
- Posting posting documents
- Reversing posting documents
- Deleting a posting run
- Changing or creating text for a posting run
- Manually setting the status of a posting run to posted

The SAP list viewer [Extern] is used to display the posting runs. It offers a wide range of functions (for example, layouts, sort functions), which you can use to modify the display to meet your requirements.

Procedure
Choose Payroll → Payroll → Subs.Activities → Per Payroll Period → Evaluation → Posting to Accounting → Edit Run.

To go from the log display to the posting run overview after creating a posting run, choose Posting run overview.

Result
You access the posting run overview. In the standard system, the display is limited to posting runs that have not been posted yet using a filter. If you want to see the posting runs that have already been posted, you must delete the filter [Extern].
Changing or Creating a Text for a Posting Run

Use
To identify the posting runs it is useful, particularly when creating posting runs in background processing, to enter a descriptive text for the individual posting runs. In the standard system, this text is displayed in the posting run overview in the column *Run text*.

Procedure

Creating a Text before Creating the Posting Run
Enter the desired text in the *Posting run text* field in the *Run attributes* group box in the selection screen of the program *Create posting run* before executing the program.

Creating or Changing a Text after Creating the Posting Run
1. Go to the overview of posting runs.
2. Select the posting run whose text you want to change.
3. Choose *Edit → Change name*
4. Enter the desired name or make changes and choose...
Displaying the Attributes of a Posting Run

Use
You can use the attributes of a posting run to, amongst other things, access the information that is displayed as statistics after creating the posting run, in other words, the number of selected, evaluated, rejected and missed out personnel numbers.

For more information on posting run attributes, see the Posting Run Documentation [Seite 580].

Procedure
1. Go to the overview of posting runs.
2. Select the required posting run.
3. Choose Goto → Run attribute.
Deleting a Posting Run

Use

If, before posting a live posting run, you realize that it contains errors (either technical, or in the contents), you must create this posting run a second time. As the system has selected the payroll results that were evaluated in this posting run, you must delete the posting run to remove selection of the payroll results. It is only then possible for the system to evaluate the relevant payroll results a second time for posting to Accounting.

If you no longer require simulation runs for test purposes, it is a good idea to delete them.

Prerequisites

If you want to delete a posting run, it should not have any of the following statuses:

- Documents transferred
- Documents posted
- Reversal documents transferred
- Reversal documents posted
- Reversal document creation is running
- Reversal documents created
- Reversal is running
- Reversal was unsuccessful
- Reversal documents are incorrect
- Partially archived
- Archived

Procedure

1. Go to the overview of posting runs.
2. Select the posting runs you want to delete.
3. Choose

A dialog box appears in which you must confirm the deletion procedure.
Deleting a Posting Run

4. Choose *Immediately* or *Create job*, to start the reversal or *Cancel*, to cancel.

**Result**

The result of the deletion procedure depends if you delete a live posting run or a simulation run.

- If you delete a live posting run, the posting documents and index remain. The status of the posting run is set to *Deleted*. Selection of the payroll results is cancelled. This makes it possible for the system to evaluate these payroll results a second time for the creation of a live posting run.

- If you delete a simulation run, the index and document lines are deleted. The status of the simulation run is set to *Deleted*. Only the document header remains.

You can delete the data from deleted live runs or simulation runs that is still on the database after this step, in a subsequent run within Archiving [Extern].
Displaying the Document Overview

Use
In the document overview, you can display which posting documents belong to one or more posting runs.

Procedure
Go to the overview of posting runs.

- To see the posting documents for a posting run, double-click on the posting run required in the document overview.
- To see the posting documents for several posting runs, select the posting runs and choose
Displaying Posting Documents

Use
In the document display, you can display the document line items for one or more posting documents.

Procedure
Go to the document overview.

- To display the **document line items for a posting run**, double-click on the posting run required in the document display.

- To display the **posting documents for several posting runs**, select the posting runs and choose
Displaying Revision Information

An important part of posting to Accounting is the ability to retrace individual line items. This is particularly important if a revision is required. In this case the following occurs:

- Postings are carried out in a summarized form, meaning that the Accounting components are only provided with the information that they require.
- This prevents unauthorized persons from accessing personal data.
- You can still retrace postings at any time, as the system creates an index of the processed payroll results when summarizing the posting data within posting to Accounting. Special authorization allows you to retrace the document line items back to the payroll results for the employee.

The Vacation bonus cost type was posted to a cost center in a payroll period where payment of the vacation bonus was not expected. You want to find out which employee and wage type formed the basis for this posting.

Procedure

Go to the document display [Seite 640] for the document that you want to check.

- To see the revision information for a document line item, double-click on the document line item you require in the revision information display.
- To display the revision information for several document line items, select the document line item and choose [ ].

Check the information displayed for wage types, personnel numbers, payroll periods, accounts, account assignment objects, and so on.

For an overview of the wage types contained in the employee’s payroll result, double-click on a line in the revision information.

To hide all the wage types that are not posted in this overview, choose Only posted wage types.

To return to the full display of wage types, choose all wage types.
Reversal of Posting Documents

Use

If you have successfully posted posting documents and realize that the posted data is incorrect, you can reverse all documents for the posting run in question. You cannot reverse individual posting documents for a posting run. The system uses the same posting run to administer posting documents and reversal documents.

Reversal of Posting Documents

The graphic shows the relationship between posting documents from Human Resources (HR) and the documents from Accounting after a reversal.

The Accounting components use the posting documents as original documents. The Accounting components have created their own documents based on these original documents.

To reverse these accounting documents you must first of all create reversal documents in Human Resources that then serve as original documents for the reversal documents from Accounting.

After a reversal, there is a relevant reversal document for each posting document and each accounting document. The reversal documents contain all the document line items from the documents to be reversed with a reversed sign.

The reversal documents from Human Resources contain a link to the accompanying posting documents. However, the reversal documents from Accounting do not contain a link to the accompanying accounting documents.

Activities

Reversing posting documents [Seite 643]

Resetting the reversal after termination [Seite 714]
Reversing Posting Documents

Use
If you have successfully posted posting documents and realize that the posted data is incorrect, you can reverse all documents for the posting run in question.

See also:
Reversal of posting documents [Seite 642]

Prerequisites
- You have successfully posted the posting documents for a posting run. The posting run has one of the following statuses:
  - Documents transferred
  - Documents posted
- It is initially not possible to reverse posting documents if payroll results were processed for which retroactive accounting runs took place and the results of these runs have already been processed in a live posting run. In this case, you must firstly reverse or delete the posting documents from the posting runs with retroactive accounting, and finally reverse the posting documents from the incorrect posting run.
- Accounting has approved the reversal.
- The system should not have used any line items from the documents created in Accounting for clearing.
- It must be possible to post the reversal documents (for example, the relevant CO account assignments should not yet be closed).

Procedure
1. Go to the overview of posting runs. If the posting run, whose posting documents you want to reverse, is not displayed, choose Edit → Filter → Delete filter.
2. Select the required posting run.
3. Choose Edit → Reverse → Reverse documents.
4. A dialog box appears, in which you must enter information on the reversal date:
   - Choose Yes, to copy the respective posting date of the original documents as the reversal date. A posting run can contain posting documents with different posting dates.
   - Choose No, to enter a different reversal date. If you enter a different posting date, it must be after the posting date for the original documents.
Reversing Posting Documents

You can determine the posting date of the posting documents in the document overview.

5. To start the reversal, choose Immediately or Create job, or choose Cancel to cancel the reversal.

The system prints a log that informs you on the success of the reversal.

**Result if Successful**

- **Reversal documents** are created containing all document line items for the original documents with reversed plus/minus (+/-) signs.

- The reversal documents were transferred to Accounting and posted there. This cancels the original, incorrect posting.

- The selection of accompanying payroll results was reset.

- Links to the reversed posting documents were inserted in the reversal documents. You can see this by showing the Reversal documents column in the document overview.

You must create a new posting run in order to repost the payroll results, which were processed in the posting run whose posting documents you have reversed, in their corrected state.

**Result if Unsuccessful**

For information on the steps that you must perform if the reversal process is terminated due to an error, see Resetting the Reversal after Termination [Seite 714].
Displaying the Status History

Use
The system automatically creates a status history for posting runs and posting documents to log the actions performed with the date, time and person responsible. You can display this status history.

Procedure

Displaying the Status History for a Posting Run
1. Go to the overview of posting runs.
2. Select the required posting run.
3. Choose Goto → Run history.

Displaying the Status History for a Posting Document
1. Go to the document overview.
2. Select the posting document you require.
Displaying Detailed Information

Use
You can access detailed information on posting runs, posting documents and document items. Whereas fields can be hidden in the list display, in the detailed information the system displays the contents of all the fields containing data.

Procedure

Displaying Detailed Information for a Posting Run
1. Go to the overview of posting runs.
2. Select the posting run you require.
3. Choose Goto → Display details.

Displaying Detailed Information for a Posting Document
1. Go to the document overview.
2. Select the posting document you require.
3. Choose Goto → Display details.

Displaying Detailed Information for a Document Item
1. Go to the document display.
2. Select the document item you require.
3. Choose Goto → Display details.
Posting in Previous Releases

It is still possible to post to Accounting if Payroll or Accounting is in an R/3 system with a release status of 4.0A or below, or is in an R/2 system. When performing posting to Accounting, only the functions available in both release statuses are supported.
Posting from HR Systems < 4.0

Use

It is still possible to post to Accounting if Accounting is in an R/3 system with a release status of 4.0A or above and Payroll is in an R/3 system with a release status below 4.0A or is in an R/2 system.

When posting to Accounting, only the functions available in both release statuses are supported. In the following, the most important functions and restrictions are named:

- In Financial Accounting (FI) you have the option of summarized posting [Seite 661].
- When posting to fixed cost centers [Seite 662], you can specify the fixed cost center for each business area.
- In the case of CO account assignments, which cannot be posted to, the system posts to the substitute cost center [Seite 613]. Substitution takes place using the substitute cost center and not the master cost center. The master cost center is not provided in this constellation of the HR system.

Prerequisites

- Accounting is situated in a central system, along with all the components.
- The Accounting master data (for example, cost centers to which you want to post) must be available in the HR system.

Procedure

In order to post from HR systems with a release status lower than 4.0A, you must create a TemSe file, from which posting documents are created, after completing payroll in the Accounting system (AC-system). You have two options for creating this TemSe file:

- Using a file transfer
- Using an ALE business process (using IDocs in the HR system)

If you want to use ALE technology for this purpose, you must make the relevant settings in ALE Customizing.

If the HR system has a release status lower than 3.1G, you can only post using a file transfer.

Posting Using a File Transfer

Steps in the HR System (Sending System)

1. Start the report Payroll program <Country> (RPCALCx0) with the payroll schema x500.
The HR system evaluates the payroll results and writes the posting-relevant information to a TemSe file.

2. **Start the report** *Transfer to Accounting: Export to R/2 or R/3 Release < 4.0 (RPCIPX00).*

   The HR system creates a second modified TemSe file from the first TemSe file.

3. **Start the report** *Posting to Accounting: Transfer Program for RPCIPX00 and RPCIPI00 (RPCIPT00).*

   The HR system creates a work file on the presentation or application server from the second TemSe file.

**Steps in the AC System (Receiving System)**

4. **Start the report** *Posting to Accounting: Transfer Program for RPCIPX00 and RPCIPI00 (RPCIPT00), to further process the file created by the HR system.*

   The AC system creates a TemSe file.

5. **Start the report** *Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00).*

   The AC system creates posting documents from the data for the TemSe file. These documents are grouped together in one posting run.

6. **Check the posting run** [Seite 624]

7. **Check the posting documents** [Seite 625]

   During this procedure, consider that revision information is not available in this constellation. For more information, see *using revision information* [Seite 651].

8. **Release the posting documents** [Seite 626].

9. **Post the posting documents** [Seite 628]

**Posting Using an ALE Business Process**

**Steps in the HR System (Sending System)**

1. **Start the report** *Payroll program <Country> (RPCALCx0) with the payroll schema x500.*

   The HR system evaluates the payroll results and writes the posting-relevant information to a TemSe file.

2. **Start the report** *Transfer to Accounting: Export to R/2 or R/3 Release <4.0 (RPCIPX00).*

   – The HR system creates a master Idoc from the TemSe file.
   – The HR system uses the Customizing for the distribution model to determine from which logical system the Idoc should be received.
   – The data is transferred to the AC system via the ALE layer. Inbound processing takes place there. When doing so, the AC system creates a TemSe file from the data in the Idoc received.

**Steps in the AC System (Receiving System)**

3. **Start the report** *Transfer to Accounting: Import from R/2 or R/3 < 4.0.*

   The AC system creates posting documents from the data for the TemSe file. These documents are grouped together in one posting run.

4. **Check the posting run** [Seite 624]
Posting from HR Systems < 4.0

5. **Check the posting documents [Seite 625]**
   During this procedure, consider that revision information is not available in this constellation. For more information, see **using revision information [Seite 651]**.

6. **Release the posting documents [Seite 626]**.

7. **Post the posting documents [Seite 628]**

Consider that this ALE business process has the following **restrictions**:

- The TemSe objects created are not defined as application objects. For this reason, the system does not update links between the TemSe object and the Idoc.
- The system does not support **serialization [Extern]**.
- In connection with the prerequisite already mentioned, that the Accounting master data must be available in the HR system, the restriction that not all account assignment objects can be distributed using ALE applies for ALE scenarios.

**Result**

The payroll results were transferred and posted to the *Accounting components*. 
Using Revision Information

Use

When posting from HR systems with a release status lower than 4.0A to AC systems, with a release status from 4.0A onwards, it is not possible to access revision information (personnel numbers and wage types) for the documents created using the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00). If you want to use the revision information in this situation, you must perform further steps as well as the actual posting procedure.

Prerequisites

To be able to use the revision information in the combination of systems mentioned, you must store the assignment of symbolic accounts to Accounting accounts in both the HR system and the AC system. To do so, you make the relevant settings in Payroll Customizing under Transfer to FI/CO → Symbolic Accounts.

Procedure

1. Start the report Payroll program <Land> (RPCALCx0) with the payroll schema x500. Set the Activate revision indicator.
   The HR system writes the posting-relevant information, as well as the personnel numbers and wage types, to a TemSe file.
2. Start the report Interface Payroll/Accounting (RPCIPO00), to process the TemSe file created.
3. Make the necessary entries in the selection screen of the report.
4. Set the Revision tool on? indicator
5. Do not set the indicator Create batch-Input?
   The HR system creates a list containing the information required.
Posting to AC Systems < 4.0

Use

It is still possible to post to Accounting if Human Resources is in an R/3 system with a release status of 4.0A or above, and Accounting is in an R/3 system with a release status lower than 4.0A, or is in an R/2 system.

When posting to Accounting, only the functions available in both release statuses are supported. The most important functions and restrictions are named in the following:

- You can repeat creation of the TemSe file. To do so, you must delete live posting runs. If you manually set the status of the posting run to posted in the HR system, in the last step, it is not possible to repeat the creation of the TemSe file.
- It is possible to post to fixed cost centers; however, it is not possible to post using the business area as a basis.
- In Financial Accounting (FI), the system can perform a summarized posting if the AC system has a release status of 3.0A or above. For this purpose, you must specify the clearing cost center in the AC system in Payroll Customizing under Transfer to FI/CO → Concluding Activities → Maintain Clearing Cost Centers. Before starting the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00), set the Assign clearing cost center indicator.
- In the case of closed cost centers, the system does not post to the substitute cost center.

Prerequisites

- Accounting is located in a central system, along with all the components.
- You have specified the company codes that are in the AC system with a release status below 4.0 in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → Special Scenarios → Posting in Previous Releases → Set Up Export to R/2 System or R/3 System < 4.0.
- The Accounting master data (for example, the cost centers to which you want to post) must be available in the HR system.

Procedure

To post to AC systems with a release status lower than 4.0A, you must create a batch-input session after completing payroll in the AC system.

If the AC system has a release status of 3.1G or above, you have two options for performing the posting.

- Using an ALE business process (using IDocs in the HR system)
- Using a file transfer
If you want to use ALE technology for this purpose, you must make the relevant settings in ALE Customizing.

If the HR system has a release status lower than 3.1G, you can only post using a file transfer.

**Posting Using a File Transfer**

**Steps in the HR System (Sending System)**

1. Perform the step creating a posting run [Seite 621]. We recommend that you only create live posting runs even if this is not absolutely necessary in the current constellation. If you want to use the revision information, set the indicator `Revision help Export R/3 3.x`. If you enter a text for the posting run, the first ten characters of this text form the last ten characters of the name of the TemSe file. If you do not enter a text for the posting run, a number is generated for the last ten characters of the name of the TemSe file.

   The HR system evaluates the payroll results and writes the posting-relevant information to a TemSe file.

2. Start the report `Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPX00)`.

   The HR system creates another TemSe file.

3. Start the report `Posting to Accounting: Transfer Program for RPCIPX00 and RPCIPI00 (RPCIPT00)`.

   The HR system creates a work file on the presentation or application server.

**Steps in the AC System (Receiving System)**

4. To further process the file created by the HR system, start the report `Posting to Accounting: Transfer Program for RPCIPX00 and RPCIPI00 (RPCIPT00)`.

   The AC system creates a TemSe file.

5. Start the report `Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00)`.

   The AC system creates batch-input sessions from the data in the TemSe file for the transaction `Post Document (FB01)` and for the transaction `Enter Reposting of Primary Costs (KB11)`, if required.

6. Post the payroll results by processing the batch input session.

7. Select the posting run created in the overview of posting runs in the HR system. Choose `Edit → In old releases → Manually set to posted`.

   Be aware of the following special feature in this step: You must not manually set the posting run to posted if posting documents and the TemSe file exist for this posting run, as the company codes exist in another AC system with release status 4.0A or higher. In this case, you must release the posting documents [Seite 626] in the HR system and finally post [Seite 628].
Posting to AC Systems < 4.0

Posting Using an ALE Business Process

Steps in the HR System (Sending System)

1. Perform the step creating a posting run [Seite 621]. We recommend that you only post live posting runs even if it is possible to post simulation runs [Seite 618] in the current constellation. If you want to use the revision information, set the indicator Revision help Export R/3 3.x. If you enter a text for the posting run, the first ten characters of this text form the last ten characters of the name of the TemSe file. If you do not enter a text for the posting run, a number is generated for the last ten characters of the name of the TemSe file.

   The HR system evaluates the payroll results and writes the posting-relevant information to a TemSe file.

2. Start the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPX00).
   - The HR system creates a master Idoc from the TemSe file.
   - The HR system uses Customizing for the distribution model to determine from which logical system the Idoc should be received.
   - The data is transferred to the AC system via the ALE layer. Inbound processing takes place here. When doing so, the AC system creates a TemSe file from the data in the Idoc it has received.

Steps in the AC System (Receiving System)

3. Start the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00).

   The AC system creates batch-input sessions from the data in the TemSe file for the transaction Post Document (FB01) and, if necessary, for the transaction Enter Reposting of Primary Costs (KB11).

4. Post the payroll results by processing the batch input session.

5. Select the posting run created in the overview of posting runs in the HR system. Choose Edit $\rightarrow$ In old releases $\rightarrow$ Manually set to posted.

   Be aware of the following special feature of this step: You must not manually set the posting run to posted if posting documents and the TemSe file exist for this posting run, as the company codes are in another AC system with release status 4.0A or higher. In this case, you must release the posting documents [Seite 626] in the HR system and finally post [Seite 628].

Bear in mind that this ALE business process has the following restrictions:

- The TemSe objects created are not defined as application objects. For this reason, the system does not update links between the TemSe object and the Idoc.
- The system does not support serialization [Extern].
- In connection with the prerequisite already mentioned, (that the Accounting master data must be available in the HR system), the restriction that the system is unable to distribute all the account assignment objects using ALE applies for ALE scenarios.

Result

The payroll results were transferred and posted to the Accounting components.
Special Business Requirements for Posting

You can use the section *Special Business Requirements for Posting*

- To get a more detailed overview of the functions of *Posting to Accounting*
- To gain information on the way in which the system supports your special business requirements
Posting with Personnel Numbers

Use

If wage types are posted to balance sheet accounts, in particular cases, you can reduce the time spent on checking within Financial Accounting. Posting using personnel numbers and setting the accounts in such a way that they can be cleared automatically does this.

The use of personnel numbers when posting payroll results is only planned for balance sheet accounts, and not for expense accounts, customer or vendor accounts.

See also:

Example: Posting Using Personnel Numbers [Seite 658]
Further Information on Clearing Accounts [Extern]
Example: Posting Using Personnel Numbers

Advances are paid to the cash office. In Financial Accounting, the system makes a respective Advances to cash office posting. The personnel number is assigned to the posting to the advances account.

By entering an Advance wage type in the master data for the employee affected, the system makes a net deduction (to the amount of the advance) within payroll, and posts it to the advance account when posting to Accounting.

You can check the retained advance payments using a list that is generated together with the wage type statement.

If posting to the advance account is based on personnel numbers, Financial Accounting can automatically clear this account, as shown in the following graphic:
Posting to Customer and Vendor Accounts

Use

When posting to expenses and payables accounts, the G/L account is always derived from the symbolic account, and, if necessary, from the Employee Grouping for Account Determination.

When posting to customer and vendor accounts, you have two possibilities for controlling account determination:

- If you want to use fixed customer and vendor accounts, you can directly assign the number of the customer or vendor account to a symbolic account and, if necessary, an employee grouping.
- If you want to run customer and vendor accounts on an employee basis, you can set the system in such a way that the personnel numbers are also included in account determination.

It is not possible to use the special general ledger indicator when posting to customer and vendor accounts.

See also:

- Example: Posting to Customer Accounts for Employees [Seite 660]
- Assign Customer Accounts [Exterm]
- Assign Vendor Accounts [Exterm]
- Assign Customer Accounts for Loan-Specific Posting [Exterm]

Prerequisites

You have made the necessary settings in Payroll Customizing, under → Reporting for Posting Payroll Results to Accounting → Activities in AC System → Assign Accounts.
The graphic shows how the system posts the repayment of company loans to customer accounts for employees.

The employees Murphy, Miller and Smith were all granted a company loan. Each of these employees has their own customer account in Financial Accounting. In Human Resources, a symbolic account is used for the repayment of employee loans in Customizing.

The system does not assign this symbolic account a customer account number in Customizing for posting to Accounting, but assigns a code which takes the personnel numbers into account when determining the account.

In this way, a symbolic account is used in Human Resources Customizing for the repayments specified in the example, however, in Accounting, the system still posts to individual customer accounts for employees.

When posting to these customer accounts, the system automatically posts to the reconciliation account assigned to the customer in the general ledger.
Summarization in the Accounting Components

Use

When posting payroll results to Accounting, it is sometimes useful to have documents in Accounting, which are as small as possible. These documents should be summarized using CO account assignments while detailed information on the CO account assignments should be available to Controlling. This is necessary in the following situations, for example:

- You should remove the information you do not require from Financial Accounting. Due to the longer retention periods for posting documents in Accounting, smaller documents should be created.
- Accounting should not have access to certain detailed information, for example, when posting to cost centers that were set up for individual employees.

You can meet these requirements with the help of Document Summarization for Overhead Costs-Controlling in Accounting.

For information on document summarization in Controlling and Funds Management, see Posting with Position Management [Seite 702].

Prerequisites

To use document summarization in Financial Accounting for posting the payroll results, you must make the relevant settings for HRPAY in Customizing for Financial Accounting, under (General Ledger Accounting → Business Transactions → Integration → Overhead Cost Controlling → Carry Out Document Summarization in Overhead Cost Controlling).
Posting to Fixed Cost Centers

Use

In certain situations it is useful to post particular cost accounting wage types to fixed cost centers or to orders, instead of to the employee's master cost center or to another specified cost assignment. This is known as Posting to a Fixed Cost Center or Posting to Fixed Orders or Standard Orders.

Posting to a fixed cost center is usually necessary if directly assigning costs to an employee’s master cost center would be incorrect from the cost accounting point of view. By posting to a fixed cost center or to a standard order, the Controlling (CO) department receives the costs in a summarized form, separate from the amounts assigned directly. Repostings can then be performed within Controlling, according to other criteria, for example, the number of employees or total remuneration.

• Decrease in expenses to the Canteen cost center
• The employer’s contribution to social insurance and capital formation payments
• Flat-rate taxes paid by the employer
• Vacation bonus with accrual calculation in Controlling
• Holiday bonus with accrual calculation in Controlling

Prerequisites

You have set up posting to fixed cost centers in Payroll Customizing (under Reporting for Posting Payroll Results to Accounting → Activities in the AC System → Set Up Fixed Cost Postings).

See also:

Example: Posting Without and With a Fixed Cost Center [Seite 663]
### Example: Posting With or Without a Fixed Cost Center

#### Posting data

<table>
<thead>
<tr>
<th>Account</th>
<th>Cost center</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>430000 Salaries</td>
<td>711</td>
<td>1,000.00</td>
</tr>
<tr>
<td>435000 Annual bonus</td>
<td>711</td>
<td>200.00</td>
</tr>
<tr>
<td>430000 Salaries</td>
<td>712</td>
<td>1,200.00</td>
</tr>
<tr>
<td>435000 Annual bonus</td>
<td>712</td>
<td>400.00</td>
</tr>
</tbody>
</table>

#### Cost centers without a fixed cost center

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost type</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>711</td>
<td>430000</td>
<td>1,000.00</td>
</tr>
<tr>
<td>711</td>
<td>435000</td>
<td>200.00</td>
</tr>
<tr>
<td>712</td>
<td>430000</td>
<td>1,200.00</td>
</tr>
<tr>
<td>712</td>
<td>435000</td>
<td>400.00</td>
</tr>
</tbody>
</table>

#### Cost centers with fixed cost center 99 for cost element 435000

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost type</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>711</td>
<td>430000</td>
<td>1,000.00</td>
</tr>
<tr>
<td>712</td>
<td>430000</td>
<td>1,200.00</td>
</tr>
<tr>
<td>99</td>
<td>435000</td>
<td>600.00</td>
</tr>
</tbody>
</table>
Posting to Special Periods

Use

If retroactive runs affect the previous fiscal year, you follow a different procedure than described in the section Posting Retroactive Accounting Data [Seite 607]. In this case, the last general posting period is usually already finished. However, posting to special periods in the old fiscal year is sometimes still possible, and usually necessary. This process is called posting to special periods. You can trigger posting to special periods when starting posting to Accounting.

The number and duration of posting periods and special periods are defined within Financial Accounting using fiscal year variants assigned to the company codes. There are usually twelve regular posting periods which, for example, correspond to the calendar months, and four special periods. If the fiscal year has been moved, and in other special cases, the number and dates of the posting periods will be different to this case.

If retroactive accounting runs affect the fiscal year that precedes the previous fiscal year, the resulting data is also posted to the special periods for the previous fiscal year.

See also:
Example: Posting to Special Periods [Seite 665]
Example: Posting to Special Periods

In this example, the fiscal year is made up of 12 regular posting periods, which correspond to the calendar months. In this example, period 13 is a special period.

The right side of the graphic shows a retroactive accounting run that was triggered by a backdated pay increase affecting the previous fiscal year. As a comparison, the left-hand side shows posting a comparable retroactive accounting run during the fiscal year.

In January 2000, an employee gets a backdated pay increase for December 01 1999.

The system posts the pay increase of 1,000 to the credit side of the Salaries account for the special period 13/1999. The offsetting posting in the special period 13/1999 is made to the credit side of a clearing account, to which the system posts the recalculation difference [Seite 610] of 1,000.

In the current posting period, (01/2000), the system posts the regular salary of 6,000 to the debit side of the Salaries account and posts the recalculation difference of 1,000 to the debit side of a clearing account. This is offset by posting 7,000 to the account Wages and salaries to be paid in the current posting period.
Cross-Company Code Transactions

Use
Several company codes can be involved in a payroll run for an employee. In such a cross-company code transaction, receivables and payables can arise between company codes.

In the following situations, cross-company code transactions occur:

- An employee works for several company codes (because of proportional assignment or change of company code within a payroll period) within a payroll period.
- After an employee has changed company code, retroactive accounting is performed for the time before the change of company code.
- An employee changes company code retrospectively.

You can clear the receivables and payables that may arise in these three cases, either on a summarized basis or using company code clearing accounts.

Prerequisites
You have made the necessary settings in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → Activities in HR System → Posting Variants. For the posting variant you use, the Post to company code clearing accounts indicator must

- not be set, if you want to use summary clearing [Seite 667]
- be set, if you want to use clearing using company code clearing accounts [Seite 667]
Summary Clearing

Use

If the Post to company code clearing accounts indicator is not set in Customizing for the posting variant you use, when cross-company code transactions take place, this results in balances on the document-split accounts, the recalculation difference account or the payment accounts. These balances illustrate receivables or payables between the company codes.

You can only use summary clearing if balancing the receivables and payables between the company codes involved is permitted and if it is also sufficient to explain the receivables and payables between the company codes from the procedure only.

Prerequisites

To use summary clearing, you must make sure that the Post to company code clearing accounts indicator is not set for the posting variant that you use. You make these settings in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → Activities in AC System → Create Posting Variants).
Proportional Assignment to Several Company Codes within a Payroll Period with Summary Clearing

Use

If an employee works for several company codes within a payroll period, the expenses incurred are distributed to these company codes on a proportional basis. However, the system assigns the relevant payables to the company code in which the master cost center is located to which the employee was assigned on the last day in the payroll period.

In this way, receivables and payables arise between the company codes, which appear as balances on the document split accounts.

In the following cases, an employee is assigned to several company codes on a proportional basis:

- The employee changes company code during a payroll period.
- You have specified a percentage cost distribution to several company codes for the employee in the Cost Distribution infotype (0027) or in Organizational Management.
- You have specified a different cost assignment for individual wage elements for the employee, which contains a different company code.

You can find more information on cost distribution and cost assignment under Posting-relevant Information from Master Data, Time Data and Organizational Management [Seite 597].

The graphic shows an example of an employee who works for two company codes. To simplify the explanation, no other payments or deductions are taken into consideration in this example.

In this example, the following expenses incur during posting:

- Company code 0001: 7,000
- Company code 0002: 3,000

The payables of 10,000 are posted to company code 0001.

Consequently, the document-split accounts are not cleared in both company codes.

- The balance of the document-split account for company code 0001 shows a receivable of 3,000 against company code 0002.
- The balance of the document-split account for company code 0002 shows a receivable of 3,000 against company code 0001.

Activities

The balances of the document-split accounts correspond to the receivables and payables between the company codes.

You must manually clear the receivables and payables between the company codes. When doing so, you also clear the balances of the document-split accounts.
Proportional Assignment to Several Company Codes within a Payroll Period with Summary Clearing
Retroactive Accounting for Summary Clearing

Use

If an employee changes company code and, for example, after the change receives a backdated pay increase which also affects the time before the change, receivables and payables incur between the two company codes.

Although the relevant expenses wage type changes for the period for which retroactive accounting is run, the amount to be paid to the employee remains the same. The payment amount firstly changes in the current period so that the system transfers the payments that the old company code must make because of the backdated pay increase from the new company code.

In this way, receivables and payables incur between the company codes that appear as balances on the recalculation difference account.

The graphic shows the case where an employee changes from company code 0001 to company code 0003 at the start of period 02. In period 02, his/her monthly salary is increased by 1.000 for period 01.

In period 01, the employee receives a monthly salary of 5,000 (wage type M020). This amount is also paid to the employee (wage type /559) as no other payments and deductions are taken into account in this example.

In period 02, the employee gets a monthly salary of 6,000 for period 02 (wage type M020) as well as a backdated pay increase of 1,000 for period 01.

In this way, expenses of 1,000 incur in company code 0001. The payment amount is not increased retrospectively for period 01, but is transferred to the current period using the wage types /551 Recalculation difference and /552 Subsequent clearing from previous period instead.

The expense of 1,000 in company code is thus offset by a recalculation difference of 1,000 that is posted to the credit side of the recalculation difference account.

A payment amount of 7,000 incurs for the current period in company code 0003; this amount is made up of the increased salary of 6,000 and the subsequent clearing of 1,000 from the previous month. This amount is posted to the Payment account in credit. This is offset by an expense of 6,000 that is posted to the debit side of the Remuneration account, as well as a recalculation difference of 1,000 that is posted in the debit side of the recalculation difference account for company code 0003.

Consequently, the recalculation difference accounts are not cleared in both company codes.

- The balance of the recalculation difference account for company code 0001 shows a payable of 1.000 from company code 0003.
- The balance of the document-split account for company code 0003 shows a receivable of 1.000 from company code 0001.
If, in Payroll Customizing under Reporting for Posting Payroll Results to Accounting - > Activities in HR System -> Employee Grouping and Symbolic Accounts ->Define Symbolic Accounts, you code the symbolic account to which the wage types /551 Recalculation difference and /552 Subsequent clearing from previous period are assigned with the account assignment type FL Balance sheet account for checking the balance in the case of retroactive accounting data, the balance incurs on the document split account instead.

**Activities**

The balances of the recalculation difference accounts correspond to the receivables and payables between the company codes.

You must manually clear the receivables and payables between the company codes. When doing so, you also clear the balances of the recalculation difference accounts.
Retroactive Accounting in Several Company Codes with Summary Clearing

Use

If an employee is retrospectively assigned to another company code, retroactive accounting is triggered. Posting of this retroactive accounting run happens in the following way:

- Posting of the old payroll results from the retroactively accounted period is reversed in the old company code.
- The new payroll result from the retroactively accounted period is posted in the new company code.

Reversal in the old company code and the posting in the new company code also affect the accounts for the outgoing accounts. As the payment can no longer be cancelled, the balances of the outgoing accounts are subsequently no longer balanced.

The graphic shows an example for the case of an employee who has retrospectively changed company code. To simplify matters, the assumption is made that the company code has changed retrospectively for the whole period 01.

Originally, an amount of 5,000 was posted from the Remuneration account to the Outgoing payment account in period 01 in company code 0001. After making the payment, the Payment account was cleared to the amount of 5,000 by the manual posting Payment to company code clearing account.

The backdated change of company code for the employee from company code 0001 to company code 0003 causes the Remuneration to outgoing posting to the amount of 5,000 to be reversed in company code 0001 and posted in company code 0003. As the payment to the employee has, however, already been made and was made by company code 0001, a receivable of 5,000 from company code 0001 incurs against company code 0003.

After making the payment in period 02, the outgoing accounts in both company codes are not cleared.

- The balance of the outgoing account for company code 0001 shows a receivable of 5,000 against company code 0003.
- The balance of the outgoing account for company code 0003 shows a payable of 5,000 against company code 0001.
Retroactive Accounting in Several Company Codes with Summary Clearing

If you code the symbolic account to which the wage type /559 Bank transfer is assigned with the account assignment type FO Balance sheet account in original period only (in Customizing for Payroll under Reporting for Posting Payroll Results to Accounting -> Employee Grouping and Symbolic Accounts -> Define symbolic accounts), the balances do not arise in the outgoing accounts but in the document split accounts.

Activities

The balances of the outgoing accounts correspond to the receivables and payables between the company codes.

You must manually clear the receivables and payables between the company codes. When doing so, you also clear the balances of the outgoing accounts.
Clearing Using Company Code Clearing Accounts

Use

If the Post to company code clearing accounts indicator is set in Customizing for the posting variant that you use, when cross-company code transactions take place, this results in balances on the company code clearing accounts. These balances illustrate receivables or payables between the company codes.

In this way, the company code clearing accounts exactly show which receivables or payables exist between the individual company codes.

You can only use clearing using company code clearing accounts if the company codes in your enterprise only illustrate parts of a legal unit meaning that clearing can take place without any difficulties. If this prerequisite is not met, you cannot make any entries that lead to cross-company code transactions, unless other activities take place in Financial Accounting (for example, issuing an invoice, correcting group turnover).

Prerequisites

To use summary clearing, you must make sure that the Post to company code clearing accounts indicator is set for the posting variant that you use. You make these settings in Payroll Customizing, (under → Reporting for Posting Payroll Results to Accounting → Activities in HR System → Create Posting Variants).

You have created the company code clearing accounts required in Customizing for Financial Accounting, under General Ledger Accounting → Business Transactions → Cross-Company Code Transactions.
Proportional Assignment to Several Company Codes within a Payroll Period when using Company Code Clearing Accounts

Use

If an employee works for several company codes within a payroll period, the expenses incurred are distributed to these company codes on a proportional basis. However, the system assigns the relevant payables to the company code in which the master cost center is located to which the employee was assigned on the last day in the payroll period.

In this way, receivables and payables incur between the company codes. They appear as balances on the company code clearing accounts.

In the following cases, an employee is proportionally assigned to several company codes:

- The employee changes company code during a payroll period.
- You have specified a percentage cost distribution to several cost centers for the employee in the Cost Distribution infotype (0027) or in Organizational Management.
- You have specified a different cost assignment for individual wage elements for the employee. This cost assignment contains a different company code.

You can find more information on cost distribution and cost assignment under Posting-Relevant Information from Master Data, Time Data and Organizational Management [Seite 597].

The graphic shows an example of an employee who works for two company codes. To simplify the explanation, no other payments or deductions are taken into consideration in this example.

In this example, the following expenses incur during posting:

- Company code 0001: 7,000
- Company code 0002: 3,000

The payables of 10,000 are posted to company code 0001.

The receivables and payables between the company codes are paid to the company code clearing accounts set up for this purpose.

- The balance of the company code clearing accounts for company code 0001 shows a receivable of 3,000 from company code 0002.
- The balance of the company code clearing accounts for company code 0002 shows a receivable of 3,000 from company code 0001.
Proportional Assignment to Several Company Codes within a Payroll Period when using Company Code Clearing Accounts

Activities

The balances of the company code clearing accounts correspond to the receivables and payables between the company codes.

You must manually clear the receivables and payables between the company codes. When doing so, you also clear the balances of the company code clearing accounts.
Retroactive Accounting in Several Company Codes - Clearing Using Company Code Clearing Accounts

Use

If an employee changes company code and, for example, after the change receives a backdated pay increase which also affects the time before the change, receivables and payables incur between the two company codes.

Although the relevant expenses wage type changes for the period for which retroactive accounting is run, the amount to be paid to the employee remains the same. The payment amount firstly changes in the current period so that the system transfers the payments that the old company code must make because of the backdated pay increase from the new company code.

In this way, receivables and payables incur between the company codes. They appear as balances on the company code clearing accounts.

The graphic shows the case where an employee changes from company code 0001 to company code 0003 at the start of period 02. In period 02, his/her monthly salary is increased by 1,000 for period 01.

In period 01, the employee receives a monthly salary of 5,000 (wage type M020). This amount is also paid to the employee (wage type /559) as no other payments and deductions are taken into account in this example.

In period 02, the employee gets a monthly salary of 6,000 for period 02 (wage type M020) as well as a backdated pay increase of 1,000 for period 01.

In this way, expenses of 1,000 incur in company code 0001. The payment amount is not increased retroactively for period 01, but is transferred to the current period instead using the wage types /551 Recalculation difference and /552 Subsequent clearing from previous period. The payable against company code 0003 of 1,000 offsets the expense of 1,000 in company code 0001.

A payment amount of 7,000 incurs for the current period in company code 0003; this amount is made up of the increased salary of 6,000 and the subsequent clearing of 1,000 from the previous month. This amount is posted to the Payment account in credit. This is offset by an expense of 6,000 that is posted to the debit side of the Remuneration account, as well as the receivable of 1,000 against company code 0001 that is posted in the debit side of the company code clearing account from company code 0003.

The receivables and payables between the company codes are paid to the company code clearing accounts set up for this purpose.
Retroactive Accounting in Several Company Codes - Clearing Using Company Code Clearing Accounts

- The balance of the company code clearing account for company code 0002 shows a receivable of 1.000 from company code 0001.
- The balance of the company code clearing account for company code 0001 shows a receivable of 1.000 from company code 0002.

The amounts for wage types /551 Recalculation difference and /552 Subsequent clearing from previous period do not, in this case, lead to a posting to the recalculation difference account. As these wage types are posted to a symbolic account with the account assignment type FL Balance sheet account for checking the balance in the case of retroactive accounting data, they are posted to the last company code for the actual payroll result, therefore to company code 0003, in this case. They thus balance to zero so that a posting to the recalculation difference account does not take place.

Prerequisites

The symbolic account to which the wage types /551 Recalculation difference and /552 Subsequent clearing from previous period has the account assignment type FL Balance sheet account for checking the balance in the case of retroactive data. For more information, see the Implementation Guide (IMG) for Payroll, under Reporting for Posting Payroll Results to Accounting → Special Scenarios → Posting to Company Code Clearing Accounts.

Activities

The balances of the company code clearing accounts correspond to the receivables and payables between the company codes.

You must manually clear the receivables and payables between the company codes. When doing so, you also clear the balances of the company code clearing accounts.
Retroactive Accounting after a Retrospective Change of Company Code when Clearing Using Company Code Clearing Accounts

Use
If an employee is retrospectively assigned to another company code, retroactive accounting is triggered. Posting of this retroactive accounting run happens in the following way:

- Posting of the old payroll results from the retroactively accounted period is reversed in the old company code.
- The new payroll result from the retroactively accounted period is posted in the new company code.

The payment that took place in period 01 can no longer be reversed. In this way, a receivable or a payable arises between the two company codes, which then appears on the company code clearing accounts.

The graphic shows an example for the case of an employee who has retrospectively changed company code. To simplify matters, the assumption is made that the company code has changed retrospectively for the whole period 01.

Originally, an amount of 5,000 was posted from the Remuneration account to the Outgoing payment account in period 01 in company code 0001. After making the payment, the Payment account was cleared by the manual posting Payment to bank clearing account to the amount of 5,000.

The backdated change of company code for the employee from company code 0001 to company code 0003 causes the Remuneration to payment posting of 5,000 to be reversed in company code 0001. However, as the payment has already been made to the employee, a receivable of 5,000 incurs from company code 0001 to company code 0003 that appears on the company code clearing account of company code 0001.

In company code 0003, an amount of 10,000 is posted as an expense to the Remuneration account. This amount contains the expense of 5,000 for period 01 and the expense of 5,000 for period 02. This posting of 5,000 to the payment account of company code 0003 and 5,000 to the company code clearing account of company code 0003 offsets this.

After the amount of 5,000 was paid to the employee for period 02, the system performs a manual posting Payments to bank clearing accounts of 5,000. This clears the payment accounts in both company codes, but does not clear the company code clearing accounts.

- The balance of the company code clearing account for company code 0001 shows a receivable of 5,000 against company code 0003.
Retroactive Accounting after a Retrospective Change of Company Code when Clearing Using Company Code Clearing Accounts

- The balance of the company code clearing account for company code 0003 shows a payable of 5,000 against company code 0001.

The amounts of wage type /559 Bank transfer for period 01 do not lead to a posting in this case. As the wage type is posted to a symbolic account with the account assignment type FO Balance sheet account in original period only, only the amount for this wage type from the original period is posted.

Prerequisites

The symbolic account to which wage type /559 Bank transfer is posted, has the account assignment type FO Posting in original period only. For more information, see the Implementation Guide (IMG) for Payroll, under Reporting for Posting Payroll Results to Accounting → Activities in the HR System → Employee Grouping and Symbolic Accounts → Define Symbolic Accounts.

Activities

The balances of the company code clearing accounts correspond to the receivables and payables between the company codes.

You must manually clear the receivables and payables between the company codes. When doing so, you also clear the balances of the company code clearing accounts.
### Postings Relevant to Value-Added Tax

Postings from the payroll results - usually postings in the form of Expenses to Payables - are not usually subject to value-added tax. Neither the expenses, nor the payables contain input or output tax. When posting payroll results, this does not usually affect accounts to which amounts subject to value-added tax as a result of other transactions are posted.

The posting of value-added tax using the posting to Accounting component is only technically possible in a few cases for reasons of upward compatibility. However, we do not recommend this procedure.

If you want to perform the value-added tax posting with posting to Accounting, you must exactly check if the calculation and posting of the value-added tax corresponds with the legal recommendations. In the standard system, it is not planned to perform value-added tax postings using posting to Accounting. For this reason, we can not guarantee that calculation and posting of value-added tax using these components corresponds to the legal recommendations.

If you want to perform value-added tax postings using posting to Accounting against our recommendations, you should consider the following points: Bear in mind that this is not a complete list:

- In the countries in which not all the information for the calculation and posting of value-added tax is available in the payroll results or during the posting of the payroll results to Accounting, no value-added tax postings can be performed using the posting to Accounting component. The USA and Canada are, for example, amongst these countries, as the system requires a Jurisdiction Code in this case, which is not available in Payroll.

- If you want to perform a value-added tax posting using posting to Accounting, there should not only be a check on the legal side, this procedure must also be agreed on internally.

- Using value-added tax postings using posting to Accounting:
  - Separate business transactions are grouped together.
  - Sometimes, amounts are posted using the revenue principle.
  - The value-added tax is posted in the company code in which the accompanying expense is posted. For this reason, this procedure leads to incorrect results if there are cross-company code procedures. This can have serious consequences if the company codes do not belong to the same integrated company liable to sales tax.

In the following sections, you find examples of value-added tax postings and notes on which procedures are planned for these postings in the standard system.

Bear in mind that this is not a complete list: Other procedures are also feasible in which value-added tax postings can occur.

- Travel Expenses [Seite 683]
Postings Relevant to Value-Added Tax

- Invoices to Employees [Seite 684]
- Amounts Paid by the Employee [Seite 686]
Travel Expenses

Separate Posting (Recommended Procedure)

If you reimburse employees’ travel expenses using Payroll, this results in value-added-tax postings. For this reason, you should post the following procedures separately:

- Posting of travel expense to payables for employees. This procedure is performed within the Travel Management component. For more information, see Transfer to Accounting [Extern] and Transfer to HR Payroll [Extern].

- Reimbursement of the amounts to be paid via Payroll and then the value-added tax free posting of payables for employees to wages and salaries to be paid using the Posting to Accounting component.

This procedure has the advantage that it allows a real-time posting of travel expenses and this posting is not linked to the posting of the payroll results.

Combined Posting (Non-Recommended Procedure)

It is technically possible to set up the relevant wage types in such a way that the travel expenses relevant to value-added-tax are not posted using Travel expenses reporting, but are posted using the Posting to Accounting component. The value-added-tax indicator that is transferred from Travel expenses reporting to Payroll is taken into consideration when posting the payroll results to Accounting, so that the value-added tax is calculated and posted.

Bear in mind that we do not recommend this procedure and cannot guarantee that the calculation and posting of the value-added-tax always corresponds to the legal recommendations.

See also:

Posting Value-Added Tax [Seite 681]
Invoices to Employees

Separate Posting (Recommended Procedure)

If the company issues invoices to employees (for example, for company-owned apartments, private conversations using a company-owned telephone, and so on), this results in value-added tax postings. You should therefore perform the following procedures separately, in accordance with the declaration principle.

- Creating an invoice with the subsequent value-added tax posting of employee receivable to income/expense reduction. This procedure is performed in the Financial Accounting component.

- Retaining the amounts claimed via Payroll with the subsequent value-added tax free posting of personnel expense to employee receivable using Posting to Accounting.

Combined Posting (Non-Recommended Procedure)

It is technically possible to group together the posting of both these procedures and perform a value-added tax posting of personnel expenses to income/expense reduction using the Posting to Accounting component. To do so, a fixed value-added tax indicator must be assigned to the income/expenses account to which the relevant wage type is posted. This value-added tax indicator is then taken into consideration when posting the payroll results to Accounting so that the value-added tax is calculated and posted.

Bear in mind that we do not recommend this procedure and cannot guarantee that the calculation and posting of the value-added-tax always corresponds to the legal recommendations.

If one of the following tax categories is assigned to the income/expenses account, and the posting without tax permitted indicator is set in the master data for the account; Posting to Accounting does not calculate the value-added tax when posting to this account.

If one of the following tax categories is assigned to the income/expenses account, and the Posting without tax permitted indicator is not set in the master data for the account; Posting to Accounting can not post to this account in the case described here.

<table>
<thead>
<tr>
<th>Tax category</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>All tax types allowed</td>
</tr>
<tr>
<td>+</td>
<td>Only output tax allowed</td>
</tr>
<tr>
<td>–</td>
<td>Only input tax allowed</td>
</tr>
</tbody>
</table>

See also:

Posting Value-Added Tax [Seite 681]
Amounts Paid by the Employees

Separate Posting (Recommended Procedure)

If you reimburse amounts that were paid by employees, this results in value-added tax postings. You should therefore perform the following procedures separately, in accordance with the declaration principle.

- Receipt of invoice with the subsequent value-added tax posting of expense to payables for employees in Financial Accounting.
- Reimbursement of the amounts via Payroll and value-added tax free posting of payables for employees to wages and salaries to be paid using the Posting to Accounting component.

Combined Posting (Non-Recommended Procedure)

It is technically possible to group together the posting of both these procedures and perform a value-added tax posting of expenses to wages and salaries to be paid using the Posting to Accounting component. To do so, a fixed value-added tax indicator must be assigned to the expense account to which the relevant wage type is posted in Financial Accounting. This value-added tax indicator is then taken into consideration when posting the payroll results to Accounting so that the value-added tax is calculated and posted.

Bear in mind that we do not recommend this procedure and cannot guarantee that the calculation and posting of the value-added-tax always corresponds to the legal recommendations.

If one of the following tax categories is assigned to the expenses account, and the posting without tax indicator is set in the master data for the account, posting to Accounting does not calculate the value-added tax when posting to this account.

If one of the following tax categories is assigned to the expenses account, and the Posting without tax permitted indicator is not set in the master data for the account; Posting to Accounting cannot, in this case, post to this account.

<table>
<thead>
<tr>
<th>Tax category</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>All tax types allowed</td>
</tr>
<tr>
<td>+</td>
<td>Only output tax allowed</td>
</tr>
<tr>
<td>-</td>
<td>Only input tax allowed</td>
</tr>
</tbody>
</table>

See also:
Posting Value-Added Tax [Seite 681]
Germany: Account Determination for Specific Service Types in Accordance with the KHBV/PBV

Use

The Hospitals Accounting Regulation (KHBV) and Nursing Homes Accounting Regulation (PBV) specify for which service types (employee groups) expense accounts must be within Financial Accounting, in the case of public-sector hospitals and nursing homes. These regulations also specify to which service type the employees should be assigned.

You can post the personnel expenses to these expense accounts for a specific service type by making the relevant settings in the system, so that the symbolic account, the employee grouping for account determination, and the service type are all taken into consideration during account determination.

Prerequisites

You have made the relevant settings in Payroll Customizing under Payroll Germany → Industries → Public Sector → Hospitals and Homes → Service Type.

You have made the relevant settings in Payroll Customizing, under Payroll: Germany → Posting to Accounting → Activities in AC System → Assigning Accounts → Assign Expense Accounts.

Scope of Function

- For the hospitals and nursing homes sector, you can assign employees to a service category using the fields Service type and Service category in the Organizational Assignment infotype (0001).
- You can specify a percentage distribution to several service types/categories in the Cost Distribution infotype (0027).
- In certain infotypes you can specify a cost assignment. You can also store a service type/category here. For a list of the most important infotypes in which a cost assignment can be stored, see Posting-Relevant Information from Master Data, Time Data and Organizational Management [Seite 597].
- In Organizational Management, you can store the service type/category in a position.

Payroll reads the information on the service type/category from the master and time data, and from Organizational Management, and saves it in the payroll result.

When posting to Accounting, the system reads this information from the payroll results and includes it in account determination.
EMU: Special Features of Posting to Accounting

The currency conversion for the European Monetary Union is particularly important in Posting to Accounting.

The system uses the currency from the payroll results as the document currency for posting. For this reason you can convert the house currency in Financial Accounting at a different time to the payroll currency used in Human Resources. The document currency transferred from Payroll to Accounting is subsequently interpreted as a foreign currency in Financial Accounting and converted into the house currency.

If retroactive accounting is necessary after the currency conversion in Human Resources, and the retroactive run includes periods before the conversion date, the system creates separate documents during posting using the respective document currency.

You convert the currency used in Payroll on January 01, 2002. If, during the payroll run in January 2002, a retroactive accounting run is required for the period of December 2001, the recalculated “December in January” results for December uses the old country currency as the payroll currency. The difference between the old and new result for December is then posted in the old national currency. The payroll result for January 2002 is posted in euro.

Please note that the retroactive accounting difference is usually posted in the current posting period. The only exception is posting to special periods at the end of the fiscal year.

As a result, retroactive runs after 01.07.02 may create documents in the current period that have the old national currency as the document currency.

Rounding Differences

The payables posted by the posting to Accounting component are cleared during the other subsequent activities for Payroll and the connected postings. After the postings have been performed in connection with the subsequent activities, all the payables are thus cleared and the balances of the payable accounts are equal to zero.

Due to rounding differences resulting from the currency conversion, it may be the case that some payable accounts do not have a balance of zero. This effect can be due to the fact that posting to Accounting transfers the amounts to Accounting without a currency conversion. Here they are converted into the house currency. In contrast, in other subsequent activities in Payroll, it is necessary to convert the currency on a personnel number level and then calculate the totals.

You should also take this into account when the accounts are reconciled. You should manually adjust any balances in these accounts that are not equal to zero due to rounding differences.

See also:
European Monetary Union: Euro (CA-EUR) [Extern]
Treatment of Rounding Differences [Extern]
Integration with Other Components

You can use the section Integration with Other Components to inform yourself on how Posting to Accounting supports the following components:

- Funds Management (with and without using Position Management)
- Personnel Cost Planning
Posting to Funds Management

Use

When posting personnel expenses to Funds Management, the system distinguishes between the following scenarios:

1. Posting to Funds Management without Entering FM Account Assignments [Seite 692]
2. Integration of Funds Management without using Position Management [Seite 693]
3. Integration of Funds Management using Position Management [Seite 695]

For every company code, you can specify if scenario 2 should be used and a date specified on which the integration of Funds Management should be activated. You make the necessary settings in Customizing for Financial Accounting (under Funds Management → Actual and Commitment Update/Integration → Integration → Integration with HR (Human Resources) → Define Begin of HR Integration.

At FM level, you can specify if scenario 3 should be used. However, it is possible to activate this scenario for certain employee groups only, which you create based on certain employee characteristics. You can activate the scenario at a different time for every employee grouping. You make the necessary settings in Customizing for Personnel Management (under, Position Management → Integration → Integration With Funds Management).

In the following cases, scenario 3 does not apply for an employee:

- Scenario 3 is not activated for the employee’s FM area.
- Scenario 3 is only activated for certain employee groupings from the employee’s FM area.
  The employee does not belong to any of these employee groupings.

In both cases, scenario 2 applies for the employee if it is activated for the employee’s company code. If scenario 2 was not activated for the employee’s company code, scenario 1 applies for the employee in both cases.
Posting to Funds Management without Entering FM Account Assignments

Use

You can also post personnel expenses to Funds Management if you do not want to store any Funds Management account assignments in Human Resources. For this purpose, you can define assignments of FM account assignments to CO account assignments in Funds Management so that when posting the payroll results to Accounting the FM account assignments are derived from the CO account assignments that are contained in the posting documents.

It is only possible to post personnel expenses to Funds Management without entering FM account assignments if the master data structure of Funds Management corresponds to the master data structure of Controlling.

For more information, see Assigning FM Account Assignment to CO Account Assignment [Extern].
Integration of Funds Management without using Position Management

Use
You can store the following account assignment objects from Funds Management in the employee’s master data or in Organizational Management to post personnel expenses to these account assignment objects within posting the payroll results to Accounting.

- Funds center
- Commitment item (in certain cases only)
- Fund

Integration
You use the Funds Management component (FI-FM).

Prerequisites
You have specified from when account assignment objects from Funds Management should be transferred when posting to Accounting in Customizing for Financial Accounting under Funds Management -> Actual and Commitment Update -> Integration -> Integration with HR (Human Resources) -> Define Begin of HR Integration. It is only possible to store account assignment objects from Funds Management in the employee’s master data or in Organizational Management from this point in time onwards.

You have made the relevant settings in Customizing for Personnel Administration so that the account assignment objects from Funds Management can be entered in the HR master data.

Scope of Function
You can assign an employee account assignment objects from Funds Management in different ways:

- You can assign a funds center and, optionally, a fund to the employee in the Organizational Assignment infotype (0001).
- Using the Cost Distribution infotype (0027), you can assign the employee to several funds centers and, optionally, funds on a percentage basis so that his/her personnel expenses are distributed to these account assignment objects.
- You can assign the employee to a position to which a cost distribution is assigned that contains one or several funds centers. The employee can also be assigned to several such positions on a percentage basis.
- You can assign individual remuneration elements for an employee to a funds center and, optionally to a commitment item and a fund, by storing a cost assignment in the infotypes intended for this purpose. For a list of the most important infotypes in which you can specify a cost assignment, see Posting-Relevant Information from Master Data, Time Data and Organizational Management [Seite 597].

If the system can no longer post to the fund for the Funds Management account assignment to be used because it’s financial purpose has expired (for example, in the case of a retroactive
Integration of Funds Management without using Position Management

accounting run), the system deletes the fund from the relevant document line of the posting document (a fund is not given for the posting). The system documents deletion of the fund from the document line in the posting document.
Integration of Funds Management without using Position Management

Use

The aim of Position Management is to finance, arrange and plan the work areas and employees as efficiently as possible within the budget allocated. Integration with Funds Management makes it possible for Position Management to access the part of the budget from Funds Management that contains the personnel expenses.

Persons and positions can be financed in Position Management using the budget set for personnel expenses in Funds Management. This creates fund commitments in Funds Management. When posting to Accounting, these funds commitments are used up and an actual posting takes place in Funds Management.

For more information on the environment in Position Management and Funds Management, see Position Management [Extern] and Funds Management [Extern].

Integration

The integration of Position Management (PA-PM) with Funds Management (FI-FM) must be activated. For information on activating the integration, see the Implementation Guide (IMG) for Personnel Management under Position Management -> Integration -> Integration with Funds Management.

Prerequisites

The employees in question must have been financed in Position Management. The master data for this employee must meet the following conditions:

- No account assignments from Funds Management (funds center, commitment item and fund) should be stored in the infotypes Organizational Assignment (0001) and Cost Distribution (0027).

- The account assignment objects from Controlling that are stored in these infotypes, must belong to controlling areas that belong to the same FM area for each employee.

- In the infotypes, in which deviating cost assignments can be specified, you can also store account assignments from Funds Management. For a list of the most important infotypes in which you can specify a cost assignment, see Posting-Relevant Information from Master Data, Time Data and Organizational Management [Seite 597]. If you enter a deviating account assignment in these infotypes and the integration of Funds Management and Controlling are active, you must store account assignment objects for both account assignment objects:

- If a wage type is posted as an expense, you must have specified which expenditure type is used for the accompanying financing in Position Management.
You must have specified to which account assignment objects from Funds Management the system should post if an expenditure type was not financed for an employee.
Process Flow for Integrated Position Management

Purpose

If integration of Position Management (PA-PM) to Funds Management (FI-FM) is activated, financing, payroll and posting take place as in the following example.

Process Flow

1. Financing the Person

The person is financed either directly or via their position in Position Management. In this example, financing of 2,000 is created based on the expenditure type A001 with the following account assignment objects from Funds Management:

- Funds center: S1
- Commitment item: Salaries
- Fund 1: F1

This creates a funds commitment of 2,000 on this account assignment in Funds Management (FM). The funds commitment takes place in the funds commitment document number 00000111 in line 002.

2. Payroll

Position Management provides Payroll with the following information for the period that corresponds to the processed payroll period:

- Account assignment objects from Funds Management that were created when financing the various expenditure types for the employee
- Document number and line number for the funds commitment in Funds Management

The financing amounts on the account assignment objects are converted to percentages and saved in the Funding (FUND) table in the payroll result along with the information mentioned using account assignment objects and funds commitment.
Process Flow for Integrated Position Management

In the example, the expenditure type A001 is 100% financed from the account assignment objects funds center S1, commitment item Salaries and fund F1.

3. Evaluating the Payroll Results

When evaluating the payroll results for posting to Accounting, the system uses the settings in Customizing to determine which expenditure type every expenditure wage type is assigned to that exists in the Results table (RT) in the payroll result for the employee and should be taken into consideration when posting. The Financing (FUND) table in the payroll result for an employee is used to determine with which account assignments from Funds Management these expenditure types were financed and which document and line number the funds commitment created by Position Management in Funds Management has. These account assignments from Funds Management and the document and line number of the funds commitment are given as account assignment information when posting the expenditure wage types to Accounting.

In the example, the expenditure wage type M020 Monthly salary has an amount of 2,125 according to the Results Table (RT). The expenditure type A001 is assigned to this wage type in Customizing. The Financing (FUND) table is used to determine that the expenditure type A001 was financed with the account assignment objects; funds center S1, funds commitment Salaries and fund F1. This information, as well as the document and line number of the funds commitment is contained in the posting document created by posting to Accounting.

4. Posting to Accounting

When posting to Accounting, an actual posting to the account assignment objects specified in the posting document takes place in Funds Management. The funds commitment is reduced by the amount of the actual posting.
In the example, the actual posting to the account assignment objects; funds center S1, funds commitment Salaries and fund F1, takes place in Funds Management. As the amount of the actual posting (2,125) is higher than the funds commitment (2,000), the funds commitment is reduced completely.

See also:

Payroll with Position Management [Seite 700]
Posting with Position Management [Seite 702]
Payroll with Position Management

Purpose

If integration of Position Management (PA-PM) to Funds Management (FI-FM) is activated, the following process takes place in Payroll.

Process Flow

During payroll, the person’s financing for the period of every payroll period processed is read from Position Management (PA-PM). In the process, percentages are calculated from the financing amounts from the account assignment objects in Funds Management (FI-FM), resulting in 100% for each financed expenditure type.

Even if the budget provided only partially covers the financing required, this is also converted to a total of 100%.

### Example 1

<table>
<thead>
<tr>
<th>Financing required:</th>
<th>2,000</th>
</tr>
</thead>
<tbody>
<tr>
<td>Financing from account assignment objects in Funds Management (funds center S1, commitment item <em>Salaries</em>, fund F1)</td>
<td>1,000 = 100%</td>
</tr>
</tbody>
</table>

### Example 2

<table>
<thead>
<tr>
<th>Financing required:</th>
<th>2,000</th>
</tr>
</thead>
<tbody>
<tr>
<td>Financing from account assignment objects in Funds Management (funds center S1, commitment item <em>Salaries</em>, fund F1)</td>
<td>750 = 75%</td>
</tr>
<tr>
<td>Financing from account assignment objects in Funds Management (funds center S2, commitment item <em>Salaries</em>, fund F2)</td>
<td>250 = 25%</td>
</tr>
</tbody>
</table>

A WPBP-Split [Extern] takes place if financing is not provided for the whole of the payroll period, or financing changes within the payroll period.

Financing is stored in the table *Financing* (FUND) in the payroll results for every WPBP period. This table contains the following data for every WPBP period and every expenditure type that was financed in Position Management:

- The Funds Management account assignment (funds center, commitment item and funds), used to finance the employee
- Document number and line of the funds commitment created because of the financing in Position Management in Funds Management.
- Percentage used to fund the expenditure type for the employee in this WPBP period using these Funds Management account assignment objects (the total of all percentages for each expenditure type and WPBP period is always 100%)

- Whether the expenditure type financed is basic pay financing

The financing (FUND) table is stored in the payroll results.

If a person's basic pay is not financed in a period of the payroll period, the system informs you of this during the payroll run.

In Customizing for Personnel Management, you can make settings for the message to be displayed and the relevant system reaction with reference to payroll in Customizing for Personnel Management, under Position Management → Integration → Determining Funds Required → Defining the Process Flow for Payroll Simulations → Define System Reactions for Payroll.

The following reactions are possible:

<table>
<thead>
<tr>
<th>Set system reactions</th>
<th>Message in payroll log</th>
<th>Consequences for payroll</th>
</tr>
</thead>
<tbody>
<tr>
<td>Information (I)</td>
<td>No message</td>
<td>The Financing (FUND) table does not contain any account assignment objects, but only contains an entry in which the Basic pay-financing indicator is set.</td>
</tr>
<tr>
<td>Warning (W)</td>
<td>“The expenditure type Basic pay is not financed without gaps”.</td>
<td>The Financing (FUND) table does not contain any account assignment objects, but only contains an entry in which the Basic pay-financing indicator is set.</td>
</tr>
<tr>
<td>Error message (E)</td>
<td>“The expenditure type Basic pay is not financed without gaps”.</td>
<td>The non-financed person is rejected in the payroll run. You must have created basic pay financing before payroll can be performed for the person.</td>
</tr>
</tbody>
</table>
Posting with Position Management

Purpose
If integration of Position Management (PA-PM) to Funds Management (FI-FM) is activated, the following process takes place in posting to Accounting.

Prerequisites
If a wage type is posted as an expense, you must have specified which expenditure type is used for the accompanying financing in Position Management in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → Special Scenarios → Integration of HR Funds and Position Management → Assign Expenditure Types to Wage Types.

Process Flow
When evaluating the payroll results for posting to Accounting, the system uses Customizing to determine the expenditure type assigned to every wage type that is to be posted as an expense. It uses this expenditure type and the WPBP split [Extern] of the wage type to determine which financing should be used from the Financing (FUND) table in the payroll results.

The relevant posting items contain the information obtained. The subsequent posting then uses up the funds commitment specified in the Financing (FUND) table in Funds Management and creates an actual posting to the Funds Management account assignment stored in the Financing (FUND) table.

If the expenditure type is financed proportionally from several Fund Management account assignments, the wage type amount is distributed to these account assignments based on the portions. Any rounding off differences are added to the greatest share.

If a different Funds Management account assignment was specified in one of the infotypes in which a cost assignment can be specified, this Funds Management account assignment is copied from the table Cost Distribution from Various Infotypes (C1) when posting the relevant expense. The Funds Management account assignment from the Financing (FUND) table is not taken into consideration for this posting. Moreover, the funds commitments are not used up in this expense posting.

For a list of the most important infotypes in which you can specify a cost assignment, see Posting-Relevant Information from Master Data, Time Data and Organizational Management [Seite 597].

If a cost distribution to several CO account assignments was specified in the Cost Distribution infotype (0027), all the CO account assignments are multiplied with the calculated percentages of the financing from Position Management.
Cost center/funds center distribution

Financing of 1,000 takes place using the following account assignment objects from Funds Management.

**Account assignment 1**: Funds center S1, commitment item Salaries, fund F1. (Amount: 500)

**Account assignment 2**: Funds center S2, commitment item Salaries, fund F2. (Amount: 500)

The *Financing* table (FUND) thus shows 50% for account assignment 1 and 50% for account assignment 2.

However, a cost distribution of 40% is entered in the *Cost Assignment* infotype (0027) for the cost center HR-01. The other 60% are posted to the employee’s master cost center (HR-ALL) from the *Organizational Assignment* (0001) infotype.

A wage type with the amount of 1,000 was posted accordingly in the following way:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>FM account assignment</th>
<th>Multiplication</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>HR-ALL</td>
<td>1</td>
<td>1,000 x 60 % x 50 %</td>
<td>300</td>
</tr>
<tr>
<td>HR-ALL</td>
<td>2</td>
<td>1,000 x 60 % x 50 %</td>
<td>300</td>
</tr>
<tr>
<td>HR-01</td>
<td>1</td>
<td>1,000 x 40 % x 50 %</td>
<td>200</td>
</tr>
<tr>
<td>HR-01</td>
<td>2</td>
<td>1,000 x 40 % x 50 %</td>
<td>200</td>
</tr>
</tbody>
</table>

The documents in *Controlling* and in *Funds Management* contain summarized information:

In the *Controlling* document in the example, only the allocation to both the cost centers HR-ALL (amount: 600) and HR-01 (amount: 400) would appear. A prerequisite for this is that you have made the relevant settings for the reference procedure HRPAY in Customizing for *Controllings* under General Controlling → Document Summarization for External Accounting Documents [Extern].

Only the allocation to both the account assignments 1 and 2 (an amount of 500 respectively) would appear in the *Funds Management* document.
Posting with Position Management
Special Cases of Integration between Funds Management and Position Management

If integration of Position Management (PA-PM) to Funds Management (FI-FM) is activated, the following special cases can occur when posting to Accounting.

Special Case 1: Missing Financing for an Expenditure Type

If a wage type is assigned to an expenditure type that was not directly financed or was not financed using a position in Position Management in the period in question, there are no entries for this expenditure type and WPBP period in the Financing (FUND) table. In this case, the system attempts to determine a substitute account assignment by determining the default account assignment of the integration of Funds Management/Position Management from Funds Management. You define the substitute account assignment for each FM area and fiscal year in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → Special Scenarios → Integration of HR Funds and Position Management → Define Posting Collector.

Two-Step Substitution Concept

The system determines the substitute account assignment for wage types that are assigned to an expenditure type, that were not directly financed or were financed using a position in Position Management in the relevant period, in the following way:

1. The system first of all attempts to derive the substitute account assignment from the basic pay financing. If basic pay is financed in the relevant period (that means, there is financing with the Basic pay indicator for this period in the Financing (FUND) table in the payroll results), a substitute account assignment is derived from the Funds Management account assignment for this financing. The system derives the substitute account assignment using the Customizing settings from posting to Accounting named above. The non-financed expense is posted with this substitute account assignment. If basic pay is financed proportionally, the wage type amount with the non-financed expenditure type is distributed proportionally to the substitute account assignments determined in this way.

2. If basic pay is also not financed, the system determines the default account assignment without financed basic pay as the substitute account assignment in a second step, which you have stored in Customizing for posting to Accounting as described above. The account assignment objects stored in this position are used to post the wage type.

When using a substitute account assignment, the funds commitment is not used up when posting. Only an actual posting takes place.

If the system is not able to determine a substitute account assignment or if incorrect account assignment objects are stored (for example, funds whose financing purpose has come to an end), the posting document contains an error message. The posting document has the status Documents incorrect.

Special Case 2: Retroactive Accounting and Substitution

When posting a retroactive accounting run the amounts on the Funds Management account assignments are reversed that were previously posted to. This also applies if the substitute account assignment is posted to because of an incorrect financing. A prerequisite for this is, however, that you have not changed Customizing for the substitute account assignment in the meantime.
Special Cases of Integration between Funds Management and Position Management

If the system posted to the substitute account assignment of the FM area in the previous month because of a lack of basic pay financing and the person was subsequently financed in Position Management, when posting retroactive accounting runs in the subsequent month, the previous month's amount is reversed on the substitute account assignment and the (possibly changed) amount is posted to the Funds Management account assignment of the financing now stored in Position Management. In this case, the prerequisite that you have not, in the meantime, changed Customizing for the substitute account assignment, also applies.

Special Case 3: Fund whose Financing Purpose Has Come To An End

If the system can no longer post to the fund of the Funds Management account assignment to be used because it’s financial purpose has expired (for example, in the case of a retroactive accounting run), the system deletes the fund from the relevant document line of the posting document (a fund is not given for the posting). This does not apply if the fund originates from the default account assignment that you have stored in Customizing for posting to Accounting as described above. The system documents deletion of the fund from the document line in the posting document.

Special Case 4: Funds Commitment with Completed Indicator

If, when posting, the system determines that the funds commitment to be used up in Funds Management is indicated as being completed (this can particularly occur in the case of retroactive accounting runs for the last fiscal year), this funds commitment number is deleted from the relevant document line of the posting document. This only causes the actual posting to be made in Funds Management, without using up a funds commitment in the process. The system documents deletion of the funds commitment number from the document line in the posting document.
Providing Data for Personnel Cost Planning

Use
You can use the program Posting to Accounting: Create Posting Run (Report RPCIPE00) to provide Cost Planning with data based on existing or simulated payroll results.

Procedure
1. Choose Human Resources → Payroll → Subsequent activities → Per payroll period → Posting to Accounting → Execute posting run.

2. To select the payroll period, enter the payroll area and choose

   The current payroll period is displayed.
   If you want to evaluate a different payroll period to the current period, choose Other period and enter the period you require.

3. Make the necessary entries in the Selection group. Entering the payroll area usually makes the selection.

4. In the Run attribute group box, choose the relevant Type of document creation.
   - If you want to provide Cost Planning with data based on payroll results that exist, you have the possibility of using all types of document creation.
   - If you want to provide Cost Planning with data based on simulated payroll results, you must enter a T (test run) in the Type of documentation field

5. Choose Cost Planning (in the Run attribute group box)

6. Set the Cost planning data indicator in the Cost Planning dialog box. If you want to provide Cost Planning with data using simulated payroll results rather than existing ones, set the Simulate payroll indicator and specify the appropriate payroll program and, if necessary, a report variant.

7. In the dialog box, choose Cost Planning

8. Choose
Providing Data for Personnel Cost Planning

**Result**

Cost planning is provided with the data from *Payroll*. For more information, see [Personnel Cost Planning](mailto:Personnel Cost Planning [Extern]).
Troubleshooting

You can use the Troubleshooting section to get help in unexpected situations when posting to Accounting:

- Posting run cancelled with status "selection running" [Seite 710]
- Personnel numbers not selected or rejected [Seite 711]
- Accounting documents were not created [Seite 712]
- Posting run is missing in posting run overview [Seite 713]
- Resetting the reversal after termination [Seite 714]
Posting Run Cancelled with Status "Selection Running"

Use

During creation, a posting run has the status *Selection running*. If the creation of a posting run was cancelled after the payroll results for individual personnel numbers had already been selected, the posting run thus retains the status *Selection running*.

To be able to create a new posting run, you must remove the selection of the payroll results. You do this by deleting the posting run.

Procedure

You delete [Seite 637] the posting run.

Result

By deleting the posting run, you have removed the selection of the payroll results for personnel numbers already processed. You can now create a new posting run.

Troubleshooting [Seite 709]
Personnel Numbers not Selected or Rejected

Use
If personnel numbers were not selected or were rejected when creating a live posting run, you can subsequently select these personnel numbers for evaluation.

Procedure
You have two different options for selecting personnel numbers for evaluation that were not selected or were rejected.

Creating a New Posting Run for All Personnel Numbers
1. Remove the cause of the error stated in the log.
2. Delete the posting.
3. Create a new posting run.

Creating a Separate Posting Run for the Personnel Numbers Skipped
1. Remove the cause of the error stated in the log.
2. Create a new posting run. When doing so, enter the same parameters in the selection screen that you entered when creating the first posting run.

   The payroll results already contained in another live posting run are not evaluated a second time. Only the payroll results for the skipped personnel numbers or for the personnel numbers not selected are included in a separate posting run.

Result
The payroll results for the personnel numbers that were not selected or were skipped are now included in a live posting run.

Troubleshooting [Seite 709]
Accounting Documents Were not Created

Use

If the system has not created any corresponding accounting documents after posting the posting documents in the Accounting components, this can be due to various errors.

Procedure

- First of all, check the status and the history of the posting run in the posting run overview. In this way, you can check if you have actually performed all the steps for posting to Accounting.

  The posting run must have the status *Documents posted* or (in distributed systems) the status *Documents transferred*. If the posting run has a different status, it has not yet been posted.

- If you use ALE technology and the posting run has the status *Documents transferred*, check the status of the Idoc created in the HR system and sent to the AC system with the help of the Idoc list [Extern]. If the Idocs were processed correctly, check the status of the posting [Extern] in the AC system.

- If you do not use ALE technology and the run has the status *Documents posted*, check the status of the posting.

Troubleshooting [Seite 709]
Posting Run is Missing in the Posting Run Overview

Use
After you have posted, reversed, deleted or archived the posting documents for a posting run, the posting run is no longer displayed in the posting run overview. This is due to a filter that is set in the standard system.

Procedure
If you want to display posting runs in the posting run overview whose posting documents were posted, reversed, deleted or archived, choose Edit → Filter → Delete filter in the posting run overview.

See also:
Setting and Deleting Filter [Extern]

Result
The posting runs required are displayed in the posting run overview. The standard settings are not changed by this procedure. For more information, see layouts [Extern].

Troubleshooting [Seite 709]
Resetting the Reversal after Termination

Use
In certain situations, the reversal of posting documents may be cancelled with an error. This may, for example, occur in the following situations:

- The specified posting date is in a posting period that is already closed.
- At the time of the reversal, the posting of the original document had not been completed.
- Account assignment objects (for example, cost centers) which were posted to in the original document are closed at the time of the reversal.
- Posting items that were created by the original document are already cleared at the time of the reversal (for example to customer and vendor accounts).

If the reversal is cancelled with an error, the relevant posting run gets the status *Reversal documents incorrect*. In this case, you must check the incorrect reversal documents and reverse the reversal that went wrong to be able to reverse the posting documents a second time.

If the reversal is cancelled not because of an error but for example, for technical reasons, the posting run in question can have one of the following statuses:

- Reversal document creation is running
- Reversal documents created
- Reversal is running

In this case, it is not necessary to perform the steps for checking the incorrect reversal documents specified below. Only perform the steps that are required to reverse the incorrect reversal.

Procedure

Checking Incorrect Reversal Documents
1. Go to the document overview for the relevant posting run.
2. Select the posting documents that have the status *incorrect (Reversal)* and choose

   ![Document Display]

   The document display is displayed.

3. Read the error messages that were created for the incorrect reversal documents and remove the cause of the error.

Cancelling Incorrect Reversal
1. Go to the overview of posting runs.
2. Select the posting run that contains the incorrect reversal documents.
3. Choose Edit → Reversal → Reset the reversal after termination.

**Result**

The posting run was returned back to the same state as it had after the posting documents to be reversed were posted. It can be reversed again.

The incorrect reversal documents get the status Reversal reset. You no longer have an influence on Posting to Accounting.

Troubleshooting [Seite 709]
Reporting Australia

Purpose
The Reporting component comprises numerous reports required by Australian law as well as additional reports used for other business purposes. These reports can be used to evaluate payroll data and to ensure compliance with government regulations. Further reports can be generated using a query or an ad-hoc query in conjunction with an Australia-specific infotype.

Implementation Considerations
Every effort is made to guarantee the legal compliance of all statutory reports. However, as the laws affecting reports change, you must verify and ensure compliance by performing all the necessary configuration steps. For example, some reports use forms that you must configure in Customizing for Payroll Australia to generate the data required by law.

Integration
Payroll reports access information from all HR infotypes and evaluate data from the payroll results cluster.

Features
SAP HR Payroll Australia comprises statutory reports, such as group certificates, that are used per payroll period and for end-of-year processing. In addition, the component comprises numerous standard reports used to evaluate business and payroll data. These reports are often used to generate forms that are issued to government authorities and employees or kept as company records. The SAP HR Payroll Australia component comprises numerous reports used in the following areas:

- Payroll processing
- Superannuation
- Leave
- Leave provisions
- Advance payments
- Terminations / redundancies
- End-of-year processing
The Reporting Process

Purpose
This process describes how reports are created in the SAP HR Payroll Australia component.

Prerequisites
You must have run payroll for your employees and have payroll results. For some reports, you may have to maintain specific infotypes first.

Process Flow
When you have run payroll for your employees, you can evaluate the payroll results by generating different reports depending on the type of information you require. The process flow for generating reports is:

1. After the payroll run, the system transfers the payroll results to the payroll results cluster (RQ).
2. You choose the report you want to generate and enter the payroll area(s), the payroll period, and whether the report is for one or several employees.
3. The system reads the payroll results from table RT, generates and then outputs the report.

Result
You can either display or print the payroll data output by the report.

The reporting process is the same for all SAP HR Payroll Australia reports except group certificates.

See also:
The Group Certificate Process [Seite 746]
Payroll Reporting

Use
This function lets you display and print a number of reports that provide payroll data for your employees.

Prerequisites
You must perform all the necessary configuration steps in Customizing for Payroll Australia, Personnel Administration and Personnel Time Management.

You must have run payroll for your employees and have payroll results. For some reports, you may have to maintain specific infotypes first.

Features
In addition to regular payroll data, the payroll reports display data on off-cycle bonus and adjustment runs. If an employee changes group tax employer, the reports also display separate results for each group employer under the appropriate company code.

After payroll has been run for your employees, the system reads the payroll data from the payroll results. You can then run the following reports:

Employee pay details report
This displays your employees’ total hours, earnings, allowances, taxes and deductions for the current payroll period, the month-to-date and the year-to-date. The amount paid, retroactive calculations and gross pay are only displayed for the current payroll period.

Employee summary report
This displays your employees’ total hours, taxed and untaxed earnings, a total for gross earnings, a total for each deduction, a total for all deductions and a total for net pay for the current payroll period, the month-to-date and the year-to-date. Adjustments are shown in the period they were paid. The report is sorted and subtotalled by company code and location, and can be scheduled to run automatically after a payroll run.

Run-to-run reconciliation report
This reconciles the year-to-date figures for the last payroll period with the figures for the current payroll period, and generates new year-to-date figures for gross pay, tax, untaxed deductions and the number of employees paid. The report can be scheduled to run automatically after a payroll run.

If you adjust a payment after running the report, the adjusted amount is displayed on the report for the subsequent period.
In period 01, a new employee earns $2000. You run the Run-to-Run Reconciliation report for period 01, and the report displays the following results for the employee:

<table>
<thead>
<tr>
<th>Period 01</th>
<th>Last YTD</th>
<th>This pay in AUD</th>
<th>Current YTD in AUD</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>0</td>
<td>2000</td>
<td>2000</td>
</tr>
</tbody>
</table>

The employee subsequently receives a pay increase of $200 backdated to period 01. Since you have already run the Run-to-Run Reconciliation report for period 01, the new figure is displayed on the report for period 02 as follows:

<table>
<thead>
<tr>
<th>Period 02</th>
<th>Last YTD</th>
<th>This pay in AUD</th>
<th>Current YTD in AUD</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>2200</td>
<td>2200</td>
<td>4400</td>
</tr>
</tbody>
</table>

**Deduction listing report**

This lists your employees’ deductions in amounts and units for the current payroll period, the month-to-date and the year-to-date.

**See also:**

[Executing Payroll Reports [Seite 720]]

[Printing Payroll Reports [Seite 721]]
Executing Payroll Reports

Use
Payroll reports enable you to display payroll data for your employees. The following reports are executed in the same way, but display different payroll data:

- Employee pay details report
- Employee summary report
- Run-to-run reconciliation report

The Deduction Listing Report is executed in the same manner described below except that you can run the report for specific deduction wage types and define the report layout.

Prerequisites
You must have run payroll for your employees and have payroll results.

Procedure
1. Choose Human Resources → Payroll → Asia/Pacific → Australia → Per payroll period → Lists/statistics → Payroll reports
2. Select the payroll report you want to execute.
3. Flag the Current period field.
   Or
   In the Other period field, enter the period number and year.
4. To run the report for a selection of employees, enter a range of personnel numbers in the Personnel number selection fields.
   Or
   To run the report for all employees, leave the Personnel number fields blank.
5. Enter the employees’ status of employment.
6. Enter the payroll area, a range of payroll areas, or leave the field blank for all payroll areas.
7. Choose Program → Execute.
Printing Payroll Reports

Use
In addition to displaying reports, the standard system enables you to print payroll reports.

Prerequisites
You must first execute the relevant payroll report.

Procedure
7. In the report screen, choose \textit{List} $\rightarrow$ \textit{Print}.
   
   The \textit{Print Screen List} screen appears.

8. In the \textit{Output device} field, enter the printer name.

9. Choose \textit{Output} $\rightarrow$ \textit{Print}.
Superannuation Reporting

Use

This function displays and prints reports that provide information on compulsory and voluntary superannuation contributions made by employers and employees to superannuation guarantee contribution (SGC) funds and other superannuation funds.

The data can be broken down according to user-defined criteria such as company code and personnel number, and can be grouped into key data that is displayed in the following reports:

- Superannuation report
- ATO notification report

Prerequisites

In the Superannuation [Extern] section of Customizing for Payroll Australia, you must define whether your superannuation wage type(s) are reported as employer or employee contributions.

You must create a record for each employee in the Superannuation infotype (0220), and have payroll results for your employees.

Features

The reports list superannuation details per fund. You can run the reports for several payroll periods. If the start and end dates of a report do not coincide with a payroll period, the report considers all the payroll periods that overlap with the start and end dates of the report.

If you run a report for more than one payroll area and each area has a different payroll period, the SAP System processes each payroll area separately and prints a separate page for each payroll area.

Superannuation report

From within this report, you can trigger three separate reports:

- Superannuation report
  - The report displays subtotals based on user-defined selection criteria, and provides the following key data:
    - “For” period and “In” period end dates
    - Payroll type
    - Fund code and name
    - Employee number and name
    - Employee fund membership number
    - Company contributions
    - Employee contributions
    - Employee ordinary time earnings
- Wages and salary
- Super guarantee contribution amount
- Messages
- Hiring and termination dates (if they take place within the current payroll period)

**Super guarantee contribution (SGC) report**

This report only produces figures as at the end of a calendar month. You must therefore run the report only in the last payroll period of the month. If the report is run at any other time, a message appears reminding you to run the report at the end of the month.

The report displays subtotals based on user-defined selection criteria, and provides the following key data:

- “For” period and “In” period
- “For” period and “In” period end dates
- Payroll type
- Fund code and name
- Employee number and name
- Employee fund membership number
- Employee ordinary time earnings
- Wages and salary
- Super guarantee contribution amount
- Company super guarantee contributions
- Messages
- Hiring and termination dates (if they take place within the current payroll period)

**Non-SGC report**

This report displays subtotals based on user-defined selection criteria, and provides the following key data:

- “For” period and “In” period
- “For” period and “In” period end dates
- Payroll type
- Fund code and name
- Employee number and name
- Employee fund membership number
- Company contributions
- Employee contributions
- System messages
Superannuation Reporting

- Employee hiring and termination dates (if they take place within the current payroll period).

ATO notification report

The Australian Taxation Office (ATO) notification report calculates company superannuation guarantee contributions (SGC) for a specified period, and compares the statutory SGC amount with the actual amount contributed by the company. If the company contribution is less than the statutory minimum, the shortfall is printed on this report.

The ATO notification report displays SGC shortfall information for all employees or a group of employees. The report displays the employee name, address, date of birth and tax file number, as well as the amount of the shortfall in SGC and the nominal interest calculated on the shortfall. The administration and per employee administration charges are also printed on this report.

If there is no SGC shortfall, a message is displayed on the report.

See also:

Executing Superannuation Reports [Seite 725]
Executing ATO Notification Reports [Seite 726]
Printing Superannuation Reports [Seite 727]
Executing Superannuation Reports

Use
This function enables you to display the following reports:

- Superannuation report
- Super guarantee contribution (SGC) report
- Non-SGC report

All the reports are executed in the same way.

Prerequisites
You must have a record for each employee in the Superannuation infotype (0220), and have payroll results for each employee.

Procedure
8. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Lists/statistics → Superannuation reports → Superannuation report.

   The Australian Superannuation Reporting screen appears.

9. Define the period for which you want to run the report.

10. Choose the relevant selection criteria (for example, the employee groups, cost centers or personnel numbers) for which you want to run the report.

11. Enter the relevant superannuation fund code(s).

12. To run the Superannuation report, set the Display all superannuation information field indicator.

   Or

   To run the SGC report, set the Display only SGC superannuation information field indicator.

   Or

   To run the Non-SGC report, set the Display non-SGC superannuation information field indicator.

13. To display subtotals, set the Display totals only field indicator, and define how you want the data to be sorted.


See also:
Superannuation Reporting [Seite 722]
Printing Superannuation Reports [Seite 727]
Executing ATO Notification Reports

Prerequisites

You must first create a record for each employee in the Superannuation infotype (0220), and run payroll for your employee(s).

To display SGC shortfalls for the year, you must run the report at the end of the financial year.

Procedure

5. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Lists/statistics → Superannuation reports → ATO notification.

The SGC - Australian Tax Office Notification Report screen appears.

6. Enter the dates of the financial year for which you want to run the report.

7. To run the report for a selection of employees, enter the relevant personnel numbers, personnel areas, personnel subareas, employee groups and subgroups.

   Or

   To run the report for all employees, leave the fields blank.

8. Choose Program → Execute.

   The report is sorted by default into company code, employee last name and employee first name.

   To display or print further employee numbers, choose Further selections on the SGC - Australian Tax Office Notification screen.

See also:

Superannuation Reporting [Seite 722]

Printing Superannuation Reports [Seite 727]
Printing Superannuation Reports

Use

In addition to displaying reports, the standard system enables you to print your superannuation reports.

Prerequisites

You must first run either the Superannuation report or the ATO notification report.

Procedure

10. In the report screen, choose List → Print.

   The Print Screen List screen appears.

11. In the Output device field, enter the printer name.

12. Choose Output → Print.
Leave Reporting

Use
This function provides leave liability data on long-service leave (LSL), recreational leave and other leave types. The data can be broken down according to user-defined criteria such as company code and personnel number, and can be grouped into key data that is displayed in various leave reports.

Prerequisites
- To process leave based on leave and absence quotas in the SAP HR Personnel Time Management component, you must configure the Leave Provisions and Payments section of Customizing for Payroll Australia, and the relevant sections in Customizing for Personnel Time Management.
- To process leave provisions, you must activate the EOM Leave Provisions subschema in Customizing for Payroll Australia, and successfully complete the last payroll run of the calendar month.
- You must have run payroll for your employees and have payroll results.

Features
If you process leave based on leave accruals, the Leave report screen displays the Leave selection group box, and requires entries in either the Leave type or the Leave group field.

If you process leave based on leave and absence quotas, the Leave report screen displays the Quota selection group box, and requires you to enter absence quota types in the Quota selection field or absence quota groupings in the Quota group field.

This function produces the following reports:

Recreational leave provision report
The report displays subtotals based on user-defined selection criteria, and provides the following key data:
- Cost center
- Weekly earnings
- Credit entitlement hours
- Pro rata accrual hours
- Credit entitlement dollar value
- Pro rata accrual dollar value
- Leave loading pro rata accrual dollar value
- Total dollar value of liability
- Escalation dollar value
- Final total dollar value after escalation on-cost has been applied
Only one leave provision factor [Extern] is applied to the result. This factor is the escalation rate for 10+ years of service. Leave loading pro rata is calculated using the leave loading percentage in the leave rules table. If an employee has more than one cost center, the employee’s pay is split between cost centers.

**Long-service leave provision report**

The report displays subtotals based on user-defined selection criteria, and provides the following key data:

- Cost center/personnel number
- Years of service
- LSL liability dollar value calculated using the LSL probability factor
- Escalation factor
- Escalation dollar value
- Subtotal after escalation on-cost has been applied
- Inflation rate
- Inflation dollar value
- Subtotal after inflation on-cost has been applied
- Bond rate
- Bond rate dollar value
- Final total dollar value after the bond rate on-cost has been applied

A different leave provision factor [Extern] is applied to each year of service.

**Leave projection/liability report**

The report displays subtotals based on user-defined selection criteria, and provides the following key data:

- Entitlement and accrual hours
- Liability hours
- Hourly rate
- Liability dollar value
- Estimated leave loading figures
- Total dollar value of liability

The Leave Projection/Liability report can be produced at a given cut-off date. If the cut-off date is before the last completed payroll run, the SAP System determines the end date of the payroll period closest to the cut-off date and triggers evaluation as per this date. If the cut-off date is after the last completed payroll run, it performs a leave projection.

When projecting recreational or other leave data, the report projects leave types to a future date and displays leave entitlement and accrual hours, leave values and estimated leave loading figures. If the leave type changes, the report displays subtotals for the leave type specified. If the company code changes, it displays the total number of employees that have had leave processed for them.
Leave Reporting

When projecting LSL data, the report determines the employer’s liability to provide LSL for an employee. The report projects a specific LSL type or a range of LSL types to a future date and displays leave entitlement and accruals hours, the total leave value, and the employer's liability value calculated on a percentage based on the number of years the employee has been with the company. If the employer has no liability to the employee, the SAP System will not issue a report for that employee.

See also:

Executing Leave Reports [Seite 731]
Printing Leave Reports [Seite 733]
Leave Provisions Based on Leave Accruals [Extern]
Leave Provisions Based on Leave Quotas [Seite 316]
Executing Leave Reports

Use
This function enables you to display the following reports:

- Recreational Leave Provision report
- Long-Service Leave Provision report
- Leave Projection/Liability report

All the reports are executed in the same way.

Prerequisites
You must have run payroll for your employees and have payroll results.

When projecting leave liability data, the leave projection date (run date) must be after or the same as the system date and after the end date of the last payroll run for the payroll area.

Before you run leave provision reports, you must activate the EOM Leave Provisions subschema in the payroll driver, and complete the last payroll run of the calendar month successfully.

Procedure
2. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Lists/statistics → Leave reports.

   The Leave Reporting screen appears.

7. Define the period for which you want to run the report.

8. Choose the relevant selection criteria (for example, the payroll areas, employee groups, cost centers or personnel numbers for which you want to run the report).

   When running multiple payroll areas, you must ensure that all the payroll areas have the same period modifier.

9. If you process leave based on leave accruals, enter the leave type(s) or leave group(s)
   Or
   If you process leave based on leave and absence quotas, enter the absence quota types or absence quota groupings in the Quota selection or Quota group field.

10. Set the indicator for the report you want to run.
Executing Leave Reports

To perform a leave projection, you must set the Projection/Liability field indicator, and enter a projection date in the Run date field.

To process long-service leave, you must enter the liability percentage for each year of service.

11. Define your report display parameters.
8. Choose Program → Execute.
Printing Leave Reports

Use

In addition to displaying reports, the standard system enables you to print leave reports.

Prerequisite

You must first execute the relevant leave report.

Procedure

13. From the report screen, choose List → Print.

   The Print Screen List screen appears.

14. In the Output device field, enter the printer name.

15. Choose Output → Print.
Advance Payment Reporting

Use
When you create an advance payment, a report is produced detailing the payments that are to be made to the employee. The report shows all the payments to the employee, period by period.

Prerequisites
You must maintain the Absences infotype (2001) in HR master data. In addition, you must define the start and end dates, the date when the advance payment is to be paid, and you must run the advance payment program.

Features
The last page of the report shows the net amount to be paid to the employee and the period in which it is to be paid. The standard system also enables you to print the report.

Advance payment information is also provided in the Employee Pay Details report after payroll has been run for your employees.

See also:
Executing the Advance Payment Program [Seite 735]
Creating Advance Payments [Seite 377]
Changing Advance Payments [Seite 378]
Deleting Advance Payments [Seite 379]
Advance Payment Posting to Accounting [Seite 382]
Executing the Advance Payment Program

Use
The advance payment program can be run in simulation mode by deselecting the Advance payment field indicator. The program displays an advance payment report.

Prerequisites
You must first maintain the Absences infotype (2001) in HR master data.

Procedure
6. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Per payroll period → Other activities → Advance payments → Create advance payment.
   The Create Advance Payment for Australia screen appears.
7. In the Personnel number field, enter the relevant personnel number(s).
8. In the Start of leave and End of leave fields, enter the relevant dates, or leave both fields blank to default to the start and end dates of the next payroll period.
9. In the Date to pay field, enter the relevant date, or leave the field blank to default to the current period.
10. Execute the program.

The advance payment program does not allow the advance payment of leave if the employee is transferred during the payroll periods that are paid in advance.

See also:
Creating Advance Payments [Seite 377]
Terminations/Redundancies Reporting

Use
The Terminations/Redundancies program enables you to issue the following reports and certificates:

- Termination report
- Standard group certificate
- ETP group certificate
- ETP rollover statement

Prerequisites
You must have configured the destination printer for the report.
You must have run the Terminations/Redundancies program and updated the terminations.

The Update function completes the termination and updates all the infotypes and records associated with terminations for each employee. Do not choose the Update function if you are only projecting termination payments.

If you inadvertently choose the Update function and thereby complete the termination, you can reverse the termination by choosing the Reinstate function in the Terminations Australia initial screen.

Features

- Termination report
  This lists the components used to calculate the termination payment and displays the total termination amount. You can use the report to verify termination details.

- Standard group certificates
  If you select the Print Group Certificate field on the Terminations Australia initial screen, the Terminations/Redundancies program issues a group certificate on termination. The group certificate is written to a spool request and can be printed from the spooler.
  If you want to print the group certificate at a later date (for example, at the end of the year instead of at the termination date), you must leave the Print Group Certificates field blank and run the Group Certificates program at the relevant time.

- ETP group certificates
  If the employee receives an eligible termination payment (ETP), the Terminations/Redundancies program generates an ETP group certificate. The certificate is written to a spool request and can be printed from the spooler.
• ETP rollover statements
  
  If an employee rolls over all or part of his or her ETP, the *Terminations/Redundancies* program generates an ETP rollover statement. The statement is written to a spool request and can be printed from the spooler.

  The ETP pre-payment statement provided to the employee prior to actual termination is not created automatically. The form must be completed manually by the employer. The same applies to the Employment Separation Certificate, Statement of Reasonable Benefits Limit form and the notification to Centrelink when terminating in excess of 15 employees (section 1/170DD of the Industrial Relations Act 1993).

  See also:
  *Producing Group Certificates on Termination* [Seite 738]
  *Printing Group Certificates and Reports* [Seite 740]
Producing Payment Summaries on Termination

**Use**

You can determine whether you want a payment summary to be issued immediately from within the *Terminations/Redundancies* program or whether you want a payment summary to be issued at a later date, for example, at the end of the financial year.

If you choose to print the payment summary immediately, you must update your terminations and then issue the certificate from the spool request created by the *Terminations/Redundancies* program. If you choose to print the payment summary at a later date, you must run the *Payment summaries* program at the relevant time.

**Prerequisites**

You must set up the destination printer for the payment summary.

**Procedure**

150. On the SAP R/3 screen, choose *Human Resources* → *Payroll* → *Asia/Pacific* → *Australia*, then *Subsequent activities* → *Per payroll period*, and then *Other activities* → *Terminations/Redundancies*.

   The *Terminations Australia* screen appears.

151. Enter the employee’s personnel number, the termination date, and the termination reason.

152. To pay by cheque, flag the *Cheque Payment* field.

   Or

   To pay by bank transfer, leave the *Cheque Payment* field blank.

   If you flag the *Cheque Payment* field, the program creates a cheque payment wage type specifying the total termination payment. To effect the payment, you must issue a cheque manually. The system does not issue cheques.

153. To issue a payment summary immediately, flag the *Print Payment summary* field.

   Or

   To issue a payment summary at a later date, leave the *Print Payment summary* field blank.
These fields are default fields only. You can change the date, reason, payment method and payment summary printing option in the Employee Details screen for each employee.

154. Select Choose from the toolbar.

The Terminations Australia screen appears.

See also:

Printing Payment summaries and Reports [Seite 740]

For more information on printing payment summaries using the Payment summaries program, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia → End-of-Year Processing → Payment summaries [Seite 744].
Printing Payment Summaries and Reports

Use

If the Terminations/Redundancies program generates eligible termination payments (ETP) and payment summaries, you can print standard payment summaries, ETP payment summaries, the terminations report and, if necessary, ETP rollover statements from the spooler.

If you choose to print the payment summary at a later date (for example, at the end of the year instead at the termination date), you must run the Payment summaries program at the relevant time.

Prerequisites

You must have configured the destination printer for the payment summary.

You must have run the Terminations/Redundancies program and updated the terminations.

The Update function completes the termination and updates all the infotypes and records associated with terminations for each employee. Do not choose the Update function if you are only projecting termination payments.

If you inadvertently choose the Update function and thereby complete the termination, you can reverse the termination by choosing the Reinstate function in the Terminations Australia initial screen.

Procedure

155. Choose System → Services → Output controller.

The Spool Request screen appears, listing the payment summaries and reports created by the Terminations/Redundancies program.

156. To view the certificates and reports before they are printed, select the relevant entry and choose Spool request → Display.

157. To print the certificate or report, select the relevant entry and choose Spool request → Print.

The Spool Output Request screen appears.

158. Enter the printer and the printing parameters.

159. Choose Spool request → Print.

Result

The spool requests for payment summaries, ETP payment summaries, the terminations report and the ETP rollover statements remain in the spooler after printing to enable you to print them again, if necessary.
You cannot retrieve any of the reports after they have been deleted from the spooler. The only way to view a report after it has been deleted is to reinstate the employee and re-run the *Terminations/Redundancies* program.

**See also:**

Producing Payment summaries [Seite 738]

For more information on printing payment summaries at a later date, see Help → SAP Library → Human Resources → Payroll → Payroll Australia → Reporting Australia → End-of-Year Processing → Payment summaries [Seite 744].
End-of-Year Processing

Use

This function lets you:

- Check, display and print annual data for superannuation guarantee contributions (SGC)
- Check, display and issue group certificates / payment summaries for the relevant financial year
- Check, display and issue ETP group certificates / payment summaries from the 1998/1999 financial year
- Check, display and print one-off group certificates / payment summaries
- Check, display and print group certificates / payment summaries by group tax employer
- Transfer group certificate data to the Australian Tax Office using magnetic media
End-of-Year SGC Processing

Use

If you suspect that certain employees have not received the minimum superannuation guarantee contribution (SGC), you can generate an ATO Notification Report to determine if the actual contribution is less than the statutory minimum contribution. If this is the case, the report displays the amount of the shortfall, the interest payable on the shortfall, and any statutory administration charges.

If the actual contribution is more than the statutory minimum contribution, the report displays a no SGC shortfall message.

See also:

Executing ATO Notification Reports [Seite 726]
Group Certificates

Purpose

It is a legal requirement that employers issue employees with a statement of taxable earnings and tax, known as a group certificate, for the financial year so that employees can lodge a tax statement with the Australian Taxation Office (ATO).

This component enables you to process and print group certificates in line with ATO legal requirements.

Implementation Considerations

Every effort is made to guarantee the legal compliance of group certificates. However, as the laws affecting group certificates change, you must verify and ensure compliance by performing all the necessary configuration steps in the Group Certificates [Extern] section of Customizing for Payroll Australia.

Integration

The Group Certificates program reads data from the Personal Data (0002), Addresses (0006), Tax Australia (0188) and Tax File Number (0227) infotypes. In addition, the program accesses tax and salary data stored in the cumulation results table (CRT) in the last payroll run of the financial year.

Features

The standard system enables you to process:

- Group certificates for each financial year
- Separate group certificates for eligible termination payments (ETP)

Termination payments (lump sum C) and the tax on termination payments are printed on a second group certificate for the financial year 1997/1998 and on a separate ETP group certificate for subsequent financial years.

- Separate group certificates on change of group tax employer
- Group certificate listing reports to verify the year-to-date figures for each employee and to minimise end-of-year processing problems
- Employee allowances reports that list allowances over and above the seven allowances that can be maintained on a standard group certificate
- One-off group certificates that allow you to reprocess group certificates already issued to employees and for which the completion indicator has been set in the Tax Australia infotype (0188)
In the standard system, employers can create group certificates on ATO stationery or on plain paper, and transfer the group certificates to the ATO on a magnetic media. The layout of the group certificate forms and magnetic tape complies with the layout prescribed by the ATO.
The Group Certificate Process

Purpose
This process describes how group certificates are created, processed, printed and transferred to the Australian Taxation Office (ATO).

Prerequisites
Before processing group certificates, you must maintain the relevant infotypes and Customizing settings. For more information, see Group Certificates Setup [Seite 747].

Process Flow
1. During the financial year, you can run the Group Certificates Listing report to check and reconcile year-to-date group certificate data and personal data such as an employee’s name, address and tax file number.

   By running the Group Certificate Listing report during the year, you can avoid a backlog of processing errors at the end of the year. In addition, you can run the report for the whole financial year to check that the group certificate details are correct before you print and issue the forms to employees.

2. After the last successful payroll run of the financial year, you run the Group Certificates program for the relevant year.

3. The SAP System produces a batch input session that updates the year of the current group certificate and sets the completion indicator in the Tax Australia infotype (0188).

4. It prints the group certificates on either ATO stationery or on plain paper.

   If an employee receives more than seven allowances a year, you can execute an allowance listing to print a supplementary page summarising additional allowances.

   If an employee requires a group certificate during the year (for example, a group certificate due to termination of employment), and the completion indicator has been set, the system allows you to print a one-off group certificate.

5. It copies the group certificates to a magnetic tape for transfer to the ATO.

Termination payments (lump sum C) and the tax on termination payments are printed on a second group certificate for the financial year 1997/1998 and on a separate ETP group certificate for subsequent financial years.
Group Certificates Setup

Purpose
To produce group certificates for employees, project teams must configure certain functions in the SAP HR Payroll Australia and SAP HR Personnel Administration components. This process provides an overview of the system configurations that project teams should undertake.

Process Flow
- In the Actions infotype (0000), maintain your employees’ period of employment.
- Create employee records in the Personal Data (0002), Addresses (0006), Tax Australia (0188), Tax File Number (0227), and the Basic Pay (0008) infotypes.
- If an employee regularly pays union fees or regularly receives allowances, create the relevant wage type(s) in the Recurring Payments / Deductions infotype (0014).
  Or
  If an employee pays a one-off union fee or receives a one-off allowance, create the relevant wage type(s) in the Additional Payments infotype (0015).
- In the Cumulation Wage Types [Extern] section of Customizing for Payroll Australia, configure your employees’ wage types to cumulate into the cumulation results table (CRT).
  To print year-to-date allowance amounts separately on group certificates, you configure the allowances to cumulate separately into the cumulation results table.
- Maintain your employees’ total earnings and classify them as gross salary, allowances or termination payments (lump sum A, B, C, D or E).
- In the Group Certificates [Extern] section of Customizing for Payroll Australia, define your wage type groupings, and set up the group certificate layout and printing parameters.

Result
After running payroll for the financial year, you can execute the Group Certificates program for the relevant year.
Group Certificates

Use

The SAP HR Payroll Australia component lets you produce:

- Group certificates for the financial year 1997/1998 [Seite 749]
- Group certificates for the financial year 1998/1999 [Seite 751]
- Group certificates for the financial year 1999/2000 [Seite 753]
- ETP group certificates from the financial year 1998/1999 [Seite 763]

The information printed on group certificates is defined by the Australian Taxation Office (ATO), and may change with each financial year.

Features


<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee details</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Tax file number</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Period of employment</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Union name</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Union deduction</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Allowance description</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Allowance amount</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Lump sums A, B &amp; D</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Lump sum C</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lump sum E</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Tax</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Gross salary</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Financial year</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Employer details</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Supplier details</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Supplier mnemonic</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Fringe benefits tax</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>CDEP* amount</td>
<td></td>
<td></td>
<td>x</td>
</tr>
</tbody>
</table>

* Community Development Employment Program
Group Certificates 1997/1998

Use

A group certificate is a statement of taxable earnings and tax issued to employees at the end of the financial year or on termination of employment. The standard system enables employers to create group certificates for all active and terminated employees in line with Australian Tax Office (ATO) requirements. Group certificates can be printed for issue to employees and copied to a magnetic media for transfer to the ATO.

Features

Group certificates for the 1997/1998 financial year contain the following information:

- Employee personal details, address, tax file number and period of employment
  
  The SAP System reads the data from the Personal Data (0002), Addresses (0006), Tax File Number (0227) and the Actions (0000) infotypes.

- Gross salary
  
  This field states the cumulated year-to-date salary, wage and bonus payments in whole dollars. The system derives the data by evaluating individual wage types in the cumulation results table (CRT) for the financial year.

- Union name and union deduction
  
  If an employee belongs to a union, the system derives the union name from the description field of the wage type for union deductions. Where there is more than one union deduction per employee, the text “various” appears on the group certificate under union name.

  The system derives the deduction amount from the CRT for the total year-to-date union fee and evaluates the individual wage types.

- Allowance description and allowance amount
  
  The system derives the allowance description from the description field of the wage types for allowances. If an employee receives more than seven allowances in the financial year, the allowances are grouped into taxed/untaxed and printed on a supplementary page.

  To print the year-to-date allowance amounts separately on the group certificate, allowances must be configured to cumulate separately into the CRT.

- Lump sums A, B and D
  
  An employee’s total earnings are classified either as lump sum A, B or D, and stored in the CRT. The system evaluates each wage type and prints the relevant lump sum on the group certificate.

- Lump sum C
  
  If an employee receives a termination payment (lump sum C), the payment and associated tax are printed separately on a second group certificate together with a
Group Certificates 1997/1998

Statement of Termination Payment form. On the magnetic tape, however, the second group certificate will also state allowances, gross earnings and standard tax.

- Tax
  The system reads the cumulated year-to-date tax deduction amount in dollars and cents from the CRT for the complete financial year.

- Group certificate financial year
  This field stores the financial year in which a group certificate was last run for an employee. This tells the user whether the group certificate has been issued for an employee for the current year. The system reads the data from the Tax Australia infotype (0188), and updates the data in a batch input session.

- Employer details
  These include the employer’s name, group account number, ACN number as well as a contact name and contact details.

- Supplier mnemonic
  Employers who transfer information to the ATO using magnetic media must be registered with the tape processing services and have a unique, five-character client mnemonic.

See also:

Displaying Group Certificates [Seite 756]
Printing Group Certificates [Seite 757]
Setting the Completion Indicator [Seite 758]
Printing One-Off Group Certificates [Seite 759]
Printing Group Certificates by Group Employer [Extern]
Transferring Group Certificates [Seite 760]
Group Certificate Listings [Seite 766]
Employee Allowances Report [Seite 772]
**Group Certificates 1998/1999**

**Use**

A group certificate is a statement of taxable earnings and tax issued to employees at the end of the financial year. The standard system enables employers to create group certificates for all active and terminated employees in line with Australian Tax Office (ATO) requirements.

Group certificates can be printed for issue to employees and copied to a magnetic media for transfer to the ATO.

This function enables you to process:

- Group certificates for the 1998/1999 financial year
- [ETP group certificates](#)

**Features**

Group certificates for the 1998/1999 financial year contain the following information:

- Employee personal details, address, tax file number and period of employment
  
  The SAP System reads the data from the *Personal Data* (0002), *Addresses* (0006), *Tax File Number* (0227) and the *Actions* (0000) infotypes.

- Gross salary
  
  This field states the cumulated year-to-date salary, wage and bonus payments in whole dollars. The system derives the data by evaluating individual wage types in the cumulation results table (CRT) for the financial year.

- Union name and union deduction
  
  If an employee belongs to a union, the system derives the union name from the description field of the wage type for union deductions. Where there is more than one union deduction per employee, the text “various” appears on the group certificate under union name.

  The system derives the deduction amount from the CRT for the total year-to-date union fee and evaluates the individual wage types.

- Allowance description and allowance amount
  
  The system derives the allowance description from the description field of the wage types for allowances. If an employee receives more than seven allowances in the financial year, the allowances are grouped into taxed/untaxed and printed on a supplementary page.

  To print the year-to-date allowance amounts separately on the group certificate, allowances must be configured to cumulate separately into the CRT.

- Lump sums A, B and D
  
  An employee’s total earnings are classified either as lump sum A, B or D and stored in the CRT. The system evaluates each wage type and prints the relevant lump sum on the group certificate.

- Lump sum C
If an employee receives a termination payment (lump sum C), the payment and associated tax are printed separately on an ETP group certificate.

- **Tax**
  The system reads the cumulated year-to-date tax deduction amount in dollars and cents from the CRT for the complete financial year.

- **Group certificate financial year**
  This field stores the financial year in which a group certificate was last run for an employee. This tells the user whether the group certificate has been issued for an employee for the current year. The system reads the data from the **Tax Australia** infotype (0188), and updates the data in a batch input session.

- **Employer details**
  These include the employer’s name, group account number, ACN number as well as a contact name and contact details.

- **Supplier details**
  If an outside agency, known as a supplier, runs payroll on your behalf, this field provides details about the supplier, including the supplier’s name, a contact person, phone number, postal address and e-mail address.

- **Supplier mnemonic**
  Employers who transfer information to the ATO using magnetic media must be registered with the tape processing services and have a unique, 11-character mnemonic.

**See also:**
- Displaying Group Certificates [Seite 756]
- Printing Group Certificates [Seite 757]
- Setting the Completion Indicator [Seite 758]
- Printing One-Off Group Certificates [Seite 759]
- Printing Group Certificates by Group Employer [Extern]
- Transferring Group Certificates [Seite 760]
- ETP Group Certificates [Seite 763]
- Group Certificate Listings [Seite 766]
- Employee Allowances Report [Seite 772]
Group Certificates 1999/2000

Use

A group certificate is a statement of taxable earnings and tax issued to employees at the end of the financial year. The standard system enables employers to create group certificates for all active and terminated employees in line with Australian Tax Office (ATO) requirements.

Group certificates can be printed for issue to employees and copied to a magnetic media for transfer to the ATO.

This function enables you to process:

- Group certificates for the 1999/2000 financial year
- ETP group certificates [Seite 763]

Features

Group certificates for the 1999/2000 financial year contain the following employer and employee details, and amounts in dollars and cents:

- Employee personal details, address, tax file number and period of employment
  
  The SAP System reads the data from the Personal Data (0002), Addresses (0006), Tax File Number (0227) and the Actions (0000) infotypes.

- Gross salary
  
  This field states cumulated year-to-date salary, wage and bonus payments. The system derives the data by evaluating individual wage types in the cumulation results table (CRT) for the financial year.

- Union name and union deduction
  
  If an employee belongs to a union, the system derives the union name from the description field of the wage type for union deductions. Where there is more than one union deduction per employee, the text “various” appears on the group certificate under union name.

  The system derives the deduction amount from the CRT for the total year-to-date union fee, and evaluates the individual wage types.

- Allowance description and allowance amount
  
  The system derives the allowance description from the description field of the wage types for allowances. If an employee receives more than seven allowances in the financial year, the allowances are grouped into taxed/untaxed and printed on a supplementary page.

  To print the year-to-date allowance amounts separately on the group certificate, allowances must be configured to cumulate separately into the CRT.

- Lump sums A, B, D and E
  
  An employee’s total earnings are classified either as lump sum A, B or D, and stored in the CRT. The system evaluates each wage type and prints the relevant lump sum on the group certificate.
Group Certificates 1999/2000

- **Lump sum C**
  If an employee receives a termination payment (lump sum C), the payment and associated tax are printed separately on an ETP group certificate.

- **Tax**
  The system reads the cumulated year-to-date tax deduction amount in dollars and cents from the CRT for the complete financial year.

- **Fringe benefits tax (FBT)**
  Employers are required to report the gross taxable value of fringe benefits on employees’ group certificates for the corresponding financial year. The group certificates state the total FBT value calculated during the FBT financial year from April 1 to March 31. The system derives the amount from the CRT, evaluates each wage type, and prints the total amount on the group certificate.

- **Community Development Employment Program (CDEP)**
  Group certificates must state income support received through CDEP during the financial year. The system derives the amount from the CRT, evaluates the wage type, and prints the total amount on the group certificate.

- **Group certificate financial year**
  This field stores the financial year in which a group certificate was last run for an employee. This tells the user whether the group certificate has been issued for an employee for the current year. The system reads the data from the **Tax Australia** infotype (0188), and updates the data in a batch input session.

- **Employer details**
  These include the employer’s name, group account number, ACN number as well as a contact name and contact details.

- **Supplier details**
  If an outside agency, known as a supplier, runs payroll on your behalf, this field provides details about the supplier, including the supplier’s name, a contact person, phone number, postal address and e-mail address.

- **Supplier mnemonic**
  Employers who transfer information to the ATO using magnetic media must be registered with the tape processing services and have a unique, 11-character mnemonic.

**See also:**
- Displaying Group Certificates [Seite 756]
- Printing Group Certificates [Seite 757]
- Setting the Completion Indicator [Seite 758]
- Printing One-Off Group Certificates [Seite 759]
- Printing Group Certificates by Group Employer [Extern]
- Transferring Group Certificates [Seite 760]
- ETP Group Certificates [Seite 763]
- Group Certificate Listings [Seite 766]
Employee Allowances Report [Seite 772]
Displaying Group Certificates

Use
By displaying a group certificate before it is printed, you can check that all the details are correct and in the appropriate position on the certificate.

Prerequisite
You must have payroll results for the end of the financial year.

Procedure
1. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Group certificates → yyyy/yyyy Group certificate.
   The Group Certificate Print and Tape Create screen appears.
2. Enter the employee’s personnel number and the payroll period.
3. Enter the financial year the group certificate covers.
4. Select the View group certificates field.
5. Choose Program → Execute.
Printing Group Certificates

Use

Group certificates must be printed for each employee at the end of the financial year. They show the amount of money earned during that year for taxation purposes.

A group certificate is printed after its accuracy is confirmed. You can print group certificates on Australian Taxation Office (ATO) stationery or on plain paper.

You can verify the accuracy of group certificates by running the Group Certificate Listing Report [Seite 769] and the Employee Allowances Report [Seite 772].

Prerequisites

You must have payroll results for the end of the financial year.

Procedure

6. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Group certificates → yyyy/yyyy Group certificate.

The Group Certificate Print and Tape Create screen appears.

7. Enter the employee’s personnel number and the payroll period.

8. Enter the financial year the group certificate covers.

9. To print test certificates, enter the number you require in the Number of test certificates field.

Test certificates let you check the alignment of the data printed on preprinted stationery. You therefore only need to print test certificates if you use preprinted stationery.

10. Enter the destination printer for the group certificate.

11. If necessary, enter the destination printer for the Allowance report.

12. To print the group certificate on plain paper, select the Plain paper printing field.

13. Choose Program → Execute and print.
Setting the Completion Indicator

Use

You can separate the employees who have had their group certificates issued from those who have not. Large companies with many employees tend to issue group certificates in groups of employee numbers, payroll areas and business areas. From a group certificate listing, an employer can identify the employees who have been issued a group certificate for the current financial year by checking the financial year that was last processed. The financial year is used as the completion indicator.

A completion indicator is not only used to identify the employees who have a certificate issued, but also to stop the SAP System from processing a group certificate twice unless forced to do so. The financial year completion indicator is set on the employee’s Tax Australia (0188) infotype record during a batch input session.

Example

An employer might terminate an employee number before the end of a financial year. The employee must be issued a group certificate within a certain time from the date of termination. After issuing the certificate, the completion indicator must be set for the employee for the current financial year to avoid re-issuing the certificate when the employee’s payroll area is processed at the end of the year.

Prerequisites

Before executing the batch input session, you must ensure that your employee numbers are not locked for processing. For example, employee numbers may be locked for processing if you have released a payroll run for those numbers shortly before executing the batch input session.

Procedure

1. Choose System → Services → Batch input → Edit.
2. Choose Goto → Overview.
3. Select GCERTS.
5. Select Display errors only.
6. Exit the program when batch input processing terminates.

Result

Before group certificates can be transferred to the Australian Taxation Office (ATO), you must ensure that no employee numbers were locked during the batch input session and that the completion indicator was set for all employees.

See also:

Tax Australia (Infotype 0188) [Seite 483]
Printing One-Off Group Certificates

Use
You can re-process a group certificate for an employee who has already been issued one and had the completion indicator set in the Tax Australia infotype (0188). This is known as printing one-off group certificates.

Procedure
14. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Group certificates → yyyy/yyyy Group certificate.
   The Group Certificate Print and Tape Create screen appears.
15. Enter the employee’s personnel number and the payroll period.
16. Enter the financial year the group certificate covers.
17. Select the Print certificate regardless of being issued field.
18. If you want to print test certificates, enter the number you require in the Number of test certificates field.
   Test certificates let you check the alignment of the data printed on preprinted stationery. You therefore only need to print test certificates if you use preprinted stationery.
19. Enter the destination printer for the group certificate.
20. If necessary, enter the destination printer for the Allowance report.
21. To print the group certificate on plain paper, select the Plain paper printing field.
22. Choose Program → Execute and print.
Transferring Group Certificates

Use
Employers who print group certificates on plain paper or use special stationery are required by the Australian Tax Office (ATO) to supply the group certificates on a magnetic media, also known as a tax tape. The magnetic media must contain all the group certificates that have been issued to all active and terminated employees during the financial year. The media can be produced in either UNIX or DOS.

All magnetic media must be forwarded to the Magnetic Information Processing Services (MIPS) together with a completed Magnetic Media Information form.

Prerequisites
You can only create a magnetic media after all group certificates have been processed and issued to employees.

If you want to produce a PC (DOS) file, you must use the file format BIN.

Procedure
23. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Group certificates → yyyy/yyyy Group certificate.

The Group Certificate Print and Tape Create screen appears.

24. Enter the employee’s personnel number and the payroll period.

25. Enter the financial year the group certificate covers.

26. Either select PC file or UNIX file.

27. If you select the UNIX file field, enter the UNIX file name and path.

   Or

   If you select the PC file field, the system requests the path and file name after you have executed the program.

28. Specify whether the tape is a test run or a production run.

29. Choose Program → Execute.
End-of-Year Adjustments

Use

In previous releases, any payments made after the final payroll run of the financial year and before the end of the financial year were entered in the Group Certificate Override program together with the financial year in which the payment was made. During group certificate processing, the SAP System added the values stored in the Group Certificate Override table to the employee’s year-to-date values stored in the cumulation results table (CRT), and then printed the values on the group certificate for the appropriate year.

As of Release 4.6B, the Group Certificate Override program must only be used for reference purposes or to re-issue group certificates already issued. Payments that are made between the final payroll run of the financial year and the end of the financial year must be processed using off-cycle payroll [Extern] runs.

The Group Certificates 1997/1998, Group Certificates 1998/1999 and Group Certificates 1999/2000 programs have been configured to include off-cycle payroll results on group certificates automatically.

Prerequisites

You must be an upgrade customer and have maintained the Group Certificate Override program in previous releases. You now want to view the values previously entered or re-issue a group certificate.

Features

The following describes how the Group Certificate Override program processed adjusted payments in previous releases:

When an employee receives a payment after successful completion of the final payroll run of the financial year, but before the end of the financial year, the payment is included in the group certificate for the financial year in which the payment is made.

A monthly company runs its final payroll run of the year for the period 01.06.1999 – 30.06.1999 on June 15. On June 25, an employee is terminated and receives a cheque payment. The system correctly includes the payment on the employee’s 1998/1999 group certificate.

To ensure that any payments made after completion of the final payroll run of the financial year, and before the end of the financial year are reported on the correct group certificate, you enter the payments in the Group Certificate Override program. In this program, you enter the payment against the year in which it is to be adjusted.
End-of-Year Adjustments

An employee receives a bonus payment of $500 on June 30, 1999. The taxable gross is $500 and tax on that gross is $200. You now enter the following information into the Group Certificate Override transaction:

<table>
<thead>
<tr>
<th>Year</th>
<th>Personnel number</th>
<th>Wage type</th>
<th>Amount in AUD</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>13001</td>
<td>/101</td>
<td>500.00</td>
</tr>
<tr>
<td>1999</td>
<td>13001</td>
<td>/411</td>
<td>200.00</td>
</tr>
</tbody>
</table>

After you have maintained the program and run group certificates for the relevant financial year, the system reads your employees’ year-to-date payroll results from the cumulation results table (CRT), and it reads the data captured in the Group Certificate Override table. If it finds any records for an employee and the year for which the group certificates are being run in the Group Certificate Override table, it adds the relevant values to the year-to-date values stored in the CRT, and prints them on the group certificate.

In addition, it reads the previous year’s values and, if necessary, subtracts them from the values for the current year.

Activities

1. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Group certificates → Group certificate override.

   The Group Certificate Override dialog box appears.

2. Enter the year and personnel number that you want to display.

   The system displays the wage types and amounts previously entered in the Group Certificate Override program.

Once you have created a group certificate for a financial year, you cannot change any of the records for that financial year. This ensures that there are no inconsistencies between original group certificates and group certificates re-issued at a later date. To determine whether a group certificate has already been issued for a financial year, the system reads the employee records stored in the Tax Australia infotype (0188).
ETP Group Certificates

Use

An eligible termination payment (ETP) is a payment made to an employee as a result of the termination of employment – for example, through redundancy, invalidity, or death. ETPs include golden handshakes, payments in lieu of notice, compensation for wrongful dismissal, redundancy payments and payments for unused sick leave.

The ETP group certificate replaces the procedure of issuing a second group certificate with some ETP information on it and accompanying this with a Statement of Termination Payment form. Termination payments and the tax on termination payments are classified as lump sum C. If lump sum C appears on a standard group certificate, the SAP System generates an ETP group certificate.

Integration

To process ETP group certificates, the system reads data from the Actions (0000), Personal Data (0002), Addresses (0006), Tax Australia (0188), Tax File Number (0227), Absences (2001) and Other/Previous Employers (0023) infotypes. In addition, the program accesses tax and salary data stored in the cumulation results table (CRT).

Prerequisites

You must have payroll results for the end of the financial year.

You must have set up a valid printer in Customizing for Payroll Australia under Group Certificates → Set Up Default Format and Printers for ETP Group Certificates [Extern].

Features

In addition to the data supplied with standard group certificates [Seite 748], ETP group certificates contain the following data:

- Date of ETP payment
- Eligible service period start date
- Number of service days before July 1983
- Number of service days after July 1983
- ETP component before July 1983
- ETP component after July 1983
- Invalidity component after June 1994
- Gross amount of the ETP component
- Assessable ETP amount
- Tax deducted from the ETP component
- Death benefit
- Trustee of deceased’s estate
ETP Group Certificates

The *Group Certificates* program can print multiple ETP group certificates that are output to a separate spool request and printed directly after all of the standard group certificates have been printed.

**See also:**

[Printing ETP Group Certificates](#)
Printing ETP Group Certificates

Prerequisites
An employee must have received an eligible termination payment (ETP).
You must have payroll results for the end of the financial year.

Procedure

30. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Group certificates → yyyy/yyyy Group certificate.

The Group Certificate Print and Tape Create screen appears.

2. Enter the employee’s personnel number and the payroll period.

3. Enter the financial year the group certificate covers.

4. To print the group certificate on plain paper, select the Plain paper printing for ETP field.

5. To print test certificates, enter the number you require in the Number of test certificates field.

   Test certificates let you to check the alignment of the data printed on preprinted stationery. You therefore only need to print test certificates if you use preprinted stationery.

6. In ETP certificate printer field, enter the destination printer or leave the default printer.

7. Choose Program → Execute and print.
Group Certificate Listings

Use

The SAP HR Payroll Australia component lets you verify and detect errors in year-to-date amounts and employee details before issuing group certificates. In addition, you can identify employees who already have a group certificate issue to them.

You do this using the following reports:

- Group certificate listing for the financial year 1997/1998 [Seite 767]
- Group certificate listing for the financial year 1998/1999 [Seite 769]
- Group certificate listing for the financial year 1999/2000 [Seite 770]

Use
The function generates a Group Certificate Listing that allows you to verify and detect errors in year-to-date amounts and personnel data, such as an employee’s name, address and tax file number, and to correct errors before issuing group certificates. The listing also identifies employees who already have a group certificate issued to them.

Integration
The Group Certificate Listing report reads data from the Personal Data (0002) and Tax Australia (0188) infotypes. In addition, the program accesses tax and salary data for the payroll period you want to verify.

Prerequisites
You must have processed, but not necessarily completed, at least one payroll run.

Features
The program allows you to generate:

- Group certificate listings
  These provide an overview of all the payment-related data printed on an employee’s group certificate.

- Separate group certificates on change of company code
  The SAP System issues a separate group certificate when an employee changes both payroll area and company code. This report allows you to verify separate group certificates issued when there is a change in payroll area and company code.

- An exception report
  If you select the Report by exception field, you can list group certificate details for employees given the following situations:
  - An employee does not have a tax file number
  - An employee has an ATO exemption code set up in their Tax File Number infotype (0227)
  - An employee does not receive a group certificate because all of his or her values are set to zero
  - A group certificate has already been issued to the employee

See also:
Executing a Group Certificate Listing [Seite 771]
Employee Allowances Report [Seite 772]
Group Certificate Listing 1998/1999

Use

The function generates a Group Certificate Listing that allows you to verify and detect errors in year-to-date amounts and personnel data, such as an employee’s name, address and tax file number, and to correct errors before issuing group certificates. The listing also identifies employees who already have a group certificate issued to them.

Integration

The Group Certificate Listing report reads data from the Personal Data (0002) and Tax Australia (0188) infotypes. In addition, the program accesses tax and salary data for the payroll period you want to verify.

Prerequisites

You must have processed, but not necessarily completed, at least one payroll run.

Features

The program allows you to generate the following data for the last updated payroll period or a selected period and year for one or more payroll areas:

- Group certificate listings
  These provide an overview of all the payment-related data printed on an employee’s group certificate.

- Separate group certificates on change of group tax employer
  The SAP System issues a separate group certificate when an employee changes group tax employer. This report allows you to verify separate group certificates issued when there is a change in group tax employer. You can sort the data by group employer or by company code.

- An exception report
  If you select the Report by exception field, you can list group certificate details for employees given the following situations:
  - An employee does not have a tax file number
  - An employee has an ATO exemption code set up in their Tax File Number infotype (0227)
  - An employee does not receive a group certificate because all of his or her values are set to zero
  - A group certificate has already been issued to the employee

See also:

Executing a Group Certificate Listing [Seite 771]
Employee Allowances Report [Seite 772]

Use

The function generates a Group Certificate Listing that allows you to verify and detect errors in year-to-date amounts and personnel data, such as an employee’s name, address and tax file number, and to correct errors before issuing group certificates. The listing also identifies employees who already have a group certificate issued to them.

Integration

The Group Certificate Listing report reads data from the Personal Data (0002) and Tax Australia (0188) infotypes. In addition, the program accesses tax and salary data for the payroll period you want to verify.

Prerequisites

You must have processed, but not necessarily completed, at least one payroll run.

Features

The program allows you to generate the following data for the last updated payroll period or a selected period and year for one or more payroll areas:

- **Group certificate listings**
  These provide an overview of all the payment-related data printed on an employee’s group certificate.

- **Separate group certificates on change of group tax employer**
  The SAP System issues a separate group certificate when an employee changes group tax employer. This report allows you to verify separate group certificates issued when there is a change in group tax employer. You can sort the data by group employer or by company code.

- **An exception report**
  If you select the Report by exception field, you can list group certificate details for employees given the following situations:
  - An employee does not have a tax file number
  - An employee has an ATO exemption code set up in their Tax File Number infotype (0227)
  - An employee does not receive a group certificate because all of his or her values are set to zero
  - A group certificate has already been issued to the employee

See also:

- Executing a Group Certificate Listing [Seite 771]
- Employee Allowances Report [Seite 772]
Executing a Group Certificate Listing

Prerequisites
You must have processed at least one payroll run.

Procedure
1. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Lists/statistics → End-of-year reports → Group certs. listing reports → Group certs. listing yyyy/yyyy.
2. Enter the employee’s personnel number and the payroll period.
3. Make sure that the Group Certificate Listing Report field has been activated.
4. To create a separate group certificate listing on change of group tax employer, select the Produce multiple group certificates by group tax employer field.
   Or
   To create an exceptions report, select the Report by exception field.
5. Choose Program → Execute.
Employee Allowances Report

Use

The Australian Taxation Office (ATO) defines the number of allowances that can be displayed on a group certificate. If the number of allowances earned by an employee exceeds seven, the allowances must be grouped into taxable and non-taxable before they are displayed on a group certificate.

This function groups taxable and non-taxable allowances, displays the total amount and prints the allowances on a separate attachment.

Integration

The Employee Allowances report is triggered by the Group Certificates program, and reads the allowances wage types stored in the payroll results.

Prerequisites

You must have processed at least one payroll run.

You must have set up a valid printer in Customizing for Payroll Australia under Group Certificates. You must activate the Employee Allowances Report field found within the Group Certificates Listing report.

Features

The SAP System generates an Employee Allowances report whenever a group certificate is executed for an employee who has earned more than seven allowances in a financial year. The report:

- Provides a description of each allowance earned by the employee
- Lists the amount associated with the allowance
- Groups taxable and non-taxable allowances

If a valid printer has been set up, the system prints the Employee Allowances report. If the printer specified is not available, the Employee Allowances report remains in the spool queue. You can print the report from the spool queue and then attach a copy to a group certificate.

You can display and verify an Employee Allowances report by activating the Employee Allowances Report field found within the Group Certificates Listing report.

See also:

Displaying and Printing Allowance Reports
Group Certificates
Group Certificate Listings
Displaying and Printing Allowance Reports

Use
This procedure describes how to:

- Display an Employee Allowances report before it is executed by the Group Certificates program
- Print an Employee Allowances report from a spool queue

If an employee receives more than seven allowances in a financial year, the Group Certificates program automatically triggers the Employee Allowances report. However, you can display and detect errors in an Employee Allowances report before running the Group Certificates program. You do this by activating the Employee Allowances Report function found within the Group Certificate Listing report for the relevant financial year. This enables you to correct errors before you run the Group Certificates program and print the Employee Allowances report.

Prerequisites
You must have processed at least one payroll run.

Procedure

Displaying allowance reports
1. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Lists/statistics → End-of-year reports → Group certs. listing yyyy/yyyy.
2. Enter the employee’s personnel number and the payroll period.
3. Select the Employee allowances report field.
4. Choose Program → Execute.

Printing allowance reports
1. Choose System → Services → Output controller.
2. Choose Enter.
3. To print the report, select the allowance listing Allow-gc.
4. Choose Print.
5. In the Output device field, enter the printer name.
6. Choose Print.
Payment Summaries

Purpose

It is a legal requirement that employers issue employees with a statement of taxable earnings and tax, known as a payment summary, for the financial year so that employees can lodge a tax statement with the Australian Taxation Office (ATO).

This component enables you to process and print payment summaries in line with ATO legal requirements.

Note:

Before 2000/2001 financial year, payment summaries were referred to as group certificates. To process and print group certificates for financial years before 2000/2001, refer to the section Group Certificates [Seite 744].

As part of the 2000/2001 financial year changes, the employee can request for payment summaries to be issued anytime during the financial year. In such cases, the payment summary would contain the details of the employee's tax and taxable earnings, up to that period when the payment summary is issued.

When an employee again requests for payment summary subsequently or at the end of the financial year, these do not include any values that were reported on the previous part year payment summaries. The employee must therefore retain all part year payment summaries that are produced throughout the year, and provide a copy of these to the ATO at the end of the financial year.

Implementation Considerations

Every effort is made to guarantee the legal compliance of payment summaries. However, as the laws affecting payment summaries change, you must verify and ensure compliance by performing all the necessary configuration steps of Customizing for Payroll Australia.

Integration

The Payment Summary program reads data from the Personal Data infotype (0002), Addresses infotype (0006) and updates the Payment Summary Infotype (0626). In addition, the program accesses tax and salary data stored in the cumulation results table (CRT) in the payroll run for the previous period or the last payroll run of the financial year.

Features

The standard system enables you to process:

- Payment summaries for each financial year to the ATO for the financial year.
- Separate payment summaries as and when requested by the employee during the year.
- Separate payment summaries for eligible termination payments (ETP)
- Separate payment summaries on change of Australian Business Number (ABN)
- Reprinting of payment summaries previously issued to the employee.
- Payment summary listing reports to verify the year-to-date figures for each employee and to minimize end-of-year processing problems.
• Employee allowances reports that list allowances over and above the seven allowances that can be maintained on a standard payment summary

In addition to the above features, the Payment Summary program also lets you produce:

• ATO file reconciliation reports
  These list all the employee information and values submitted to the ATO. The data can be sorted by ABN or company code. You can display and print the report.

• Summary reports
  When creating payment summaries, the report lists any errors found on the payment summaries as well as all the employees who have received payment summaries in the same order that the summaries were produced by the Payment Summary program.

  When creating the ATO file, the report lists any errors found as well as any mandatory fields that have not been filled.

In the standard system, employers can create payment summaries on ATO stationery or on plain paper, and transfer the payment summaries to the ATO on a magnetic media. The layout of the payment summaries forms and magnetic tape complies with the layout prescribed by the ATO.

**Constraints**

While reprinting payment summaries, it is not possible to reprint just one payment summary for an employee. The program will reprint any payment summaries which had been issued previously for the financial year.
Payment Summary (Infotype 0626)

Definition

A Payment Summary is a statement of earnings issued by the employer to the employee, showing the employment income of the employee for the financial year or on the employee’s termination. The Australian Tax Office (ATO) stipulates the requirements governing Payment Summaries.

The data stored in the infotype includes:

- Whether the payment summary is for all or part of the financial year (available for 2000/2001 payment summaries)
- The date and time that a record is produced
- Whether an ETP payment summary is produced
- The number of reprints requested for the final payment summary
- Whether an ATO file was created using the data stored in the infotype record
- The date and time the ATO file is created
- Whether a manual payment summary was issued to the employee
- All the values that appear on the payment summary and ETP payment summary

Use

It summarizes the employee’s pay details for the financial year, and is used to prepare the employee’s tax return.

You can get the following information from the Payment Summary infotype:

- The payment summary issue date
  
  This means that the Tax Australia infotype must no longer be delimited to correctly store the year in which a payment summary was last issued

- Record of multiple payment summaries created in a single financial year (for example, when an employee changes group tax employer)

- All payment summary information including ETP data for auditing purposes

Additionally, you can also produce a manual payment summary without the employee being listed in the ATO file.

Structure

The Payment Summary infotype is divided into the following groups of data.

- Administration data

  Each record in the Payment Summary infotype has a start date and an end date, which denote the period for which the payment summary is issued to the employee. When you
run the *Payment Summaries* program, the SAP System automatically enters the payment summary start date in this field.

You can only modify the fields, if you choose to **create** a record for an employee in the *Payment Summary* infotype (0626).

Generally, you would only create and modify records if you issue a payment summary manually or withdraw an incorrect payment summary, without running the *Group Certificates/Payment Summaries* program first.

- **Payment Summary Details**
  This contains the gross salary or wages paid to the employee during the period, any tax installment deductions made, any allowances not included in gross income, grossed-up taxable value of fringe benefits and lump sum payments for unused annual leave or long service leave, tax-free part of bona fide redundancy payments or approved early retirement scheme payments and back payments made more than 12 months earlier.

- **Allowances data**
  This displays the wagetypes and the allowance values that are required for the payment summary program. You can only modify the fields in case of entering a manual payment summary. You can store up to 15 allowances in this table.

- **ETP data**
  *ETP includes any lump sum payments paid to the employees in consequence of their termination. This contains gross amount of payment, amount of tax installments deducted from the ETP, assessable amount of ETP for tax calculation and other information relevant for calculating final ETP payment summary amount. This also includes details of death benefit ETP, applicable to a deceased employee.*

- **ATO details**
  ATO details are required to find out the number of times a payment summary has been created for an employee in a specific period. This also contains the date and time of creation of the payment summary.

**Integration**

For 1999/2000 group certificates, the *Group Certificates* program reads both the *Tax Australia* and the *Payment Summary* infotypes to determine if a group certificate has been created for the financial year. However, the program only updates the *Payment Summary* infotype with the payment summary issue date.

From the financial year 2000/2001 onwards, the *Payment Summaries* program automatically creates the records in the *Payment Summary* infotype for each employee.
Payment Summary Process

Purpose

This process describes how you can create, process, print and transfer payment summaries to the Australian Taxation Office (ATO).

Prerequisites

Before processing payment summaries, you must maintain the relevant infotypes and Customizing settings. For more information, see Payment Summaries Setup [Seite 779].

Process Flow

6. During the financial year, you can run the Payment Summary Listing report to check and reconcile year-to-date payment summary data and personal data such as an employee’s name, address and tax file number.

   By running the Payment Summary Listing report during the year, you can avoid a backlog of processing errors at the end of the year. In addition, you can run the report for the whole financial year to check that the payment summary details are correct before you print and issue the forms to employees.

7. After the last successful payroll run for the period or financial year as the case maybe, you run the Payment Summary program for the relevant period or financial year.

8. The SAP System produces a batch input session that updates the period or the year of the current payment summary and the Payment Summary Infotype (0626)

9. It prints the payment summary on either ATO stationery or on plain paper.

   If an employee receives more than seven allowances a year, you can execute an allowance listing to print a supplementary page summarizing additional allowances.

   If an employee requires a payment summary anytime during the year, the system allows you to print a part year payment summary. In this case, the employees must retain all the part year payment summaries that have been produced during the year, and provide a copy of these to the ATO.

10. It copies the payment summary to a magnetic tape for transfer to the ATO.
Payment Summaries Setup

Purpose
To produce payment summaries for employees, project teams must configure certain functions in the SAP HR Payroll Australia and SAP HR Personnel Administration components. This process provides an overview of the system configurations that project teams should undertake.

Process Flow
- In the Actions infotype (0000), maintain your employees’ period of employment.
- Create employee records in the Personal Data (0002), Addresses (0006) and the Basic Pay (0008) infotypes.
- If an employee regularly pays union fees or receives allowances, create the relevant wage type(s) in the Recurring Payments / Deductions infotype (0014).
  - Or
  - If an employee pays a one-off union fee or receives a one-off allowance, create the relevant wage type(s) in the Additional Payments infotype (0015).
- In the Cumulation Wage Types [Extern] section of Customizing for Payroll Australia, configure your employees’ wage types to cumulate into the cumulation results table (CRT).
  - To print year-to-date allowance amounts separately on payment summaries, you configure the allowances to cumulate separately into the cumulation results table.
- Maintain your employees’ total earnings and classify them as gross salary, allowances or termination payments (lump sum A, B, C, D or E).
- In the Group Certificates / Payment Summaries [Extern] section of Customizing for Payroll Australia, define your wage type groupings, and set up the payment summary layout and printing parameters.

Result
After running payroll for the period, you can execute the Payment Summary program when an employee requests for a payment summary to be issued for a relevant period or at the end of the financial year for transferring to the ATO.
Payment Summaries

Use

The SAP HR Payroll Australia component lets you produce:

- Payment Summaries for the financial year 2000/2001
- ETP payment summaries for the financial year [Seite 794] 2000/2001

The Australian Tax Office (ATO) stipulates the requirements governing payment summaries, and issues payment summary stationery to the employers. The information printed on payment summaries may change with each financial year.

Features

The following table provides an comparison of the information supplied in payment summaries for the financial year 2000/2001 and group certificates for the financial 1999/2000:

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee details</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Tax file number</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>ABN</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Branch Number</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Period of employment</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Union name</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Union deduction</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Allowance description</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Allowance amount</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Lump sums A,B &amp; D</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Lump sum E</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Tax</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Gross salary</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Financial year</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Employer details</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Supplier details</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Supplier mnemonic</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Fringe benefits tax</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>CDEP* amount</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td><strong>Payment Summaries</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other Income</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>PAYE¹ Account Number</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Name of Payer</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Payer’s Reference</td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>

* Community Development Employment Program

¹ Pay As You Earn
Payment Summaries 2000/2001

Use

A payment summary is a statement of taxable earnings and tax, issued to employees at the end of the financial year. The standard system enables employers to create payment summaries for all active and terminated employees in accordance with Australian Tax Office (ATO) requirements.

Payment summaries can be printed for issue to employees and copied to a magnetic media for transfer to the ATO.

This function enables you to process:

- Payment summaries for the financial year 2000/2001
- ETP payment summaries [Seite 794]

Features

Payment summaries for the 2000/2001 financial year contain the following employer and employee details, and amounts in dollars and cents:

- Employee personal details, address, tax file number and period of employment
  
  The SAP System reads the data from the Personal Data (0002), Addresses (0006), Tax File Number (0227), Payment Summary (0626) and the Actions (0000) infotypes.

- Australian Business Number (ABN)
  
  The Australian Business Number (ABN) is the identifying number that businesses will use when dealing with other businesses. The ABN details are maintained by the ATO for all Commonwealth purposes.

- Branch Number
  
  This field is displayed only for an employer who has an ABN. In case the employer’s ABN is not available, this field displays 001 which is the default value.

- Gross salary
  
  This field states cumulated year-to-date salary, wage and bonus payments. The system derives the data by evaluating individual wage types in the cumulation results table (CRT) for the financial year.

- Union name and union deduction
  
  If an employee belongs to a union, the system derives the union name from the description field of the wage type for union deductions. Where there is more than one union deduction per employee, the text “various” appears on the payment summary under union name.

  The system derives the deduction amount from the CRT for the total year-to-date union fee, and evaluates the individual wage types.

- Allowance description and allowance amount
The system derives the allowance description from the description field of the wage types for allowances. If an employee receives more than seven allowances in the financial year, the allowances are grouped into taxed/untaxed and printed on a supplementary page.

To print the year-to-date allowance amounts separately on the Payment Summary, allowances must be configured to cumulate separately into the CRT.

- **Lump sums A, B, D and E**
  
  An employee’s total earnings are classified either as lump sum A, B or D, and stored in the CRT. The system evaluates each wage type and prints the relevant lump sum on the Payment Summary.

- **Tax**
  
  The system reads the cumulated year-to-date tax deduction amount in dollars and cents from the CRT for the complete financial year.

- **Fringe benefits tax (FBT)**
  
  Employers are required to report the gross taxable value of fringe benefits on employees’ Payment Summaries for the corresponding financial year. The payment summaries state the total FBT value calculated during the FBT financial year from April 1 to March 31. The system derives the amount from the CRT, evaluates each wage type, and prints the total amount on the Payment Summary.

- **Community Development Employment Program (CDEP)**
  
  Payment summaries must state income support received through CDEP during the financial year. The system derives the amount from the CRT, evaluates the wage type, and prints the total amount on the Payment Summary.

- **Payment summary financial year**
  
  This field stores the financial year in which a Payment Summary was last run for an employee. This tells the user whether the payment summary has been issued for an employee for the current year. The system reads the data from the *Tax Australia* infotype (0188), and updates the data in a batch input session.

- **Employer details**
  
  These include the employer’s name, group account number, ACN number as well as a contact name and contact details.

- **Supplier details**
  
  If an outside agency, known as a supplier, runs payroll on your behalf, this field provides details about the supplier, including the supplier’s name, a contact person, phone number, postal address and e-mail address.

- **Supplier mnemonic**
  
  Employers who transfer information to the ATO using magnetic media must be registered with the tape processing services and have a unique, 11-character mnemonic.

See also:

*Displaying Payment Summaries* [Seite 785]
Payment Summaries 2000/2001

- Printing Payment Summaries [Seite 786]
- Printing One-Off Payment Summaries [Seite 788]
- Printing Payment Summaries by Australian Business Number
- Transferring Payment Summaries [Seite 790]
- ETP Payment Summaries [Seite 794]
- Payment Summary Listings [Seite 797]
- Employee Allowances Report [Seite 801]
Displaying and Printing Payment Summaries

Use
By displaying a payment summary before it is printed, you can check that all the details are correct and in the appropriate position on the certificate. You can also print a part year payment summary through the View payment summaries option.

You can also print a payment summary after displaying it. Printing the payment summary through this option would not update the Payment Summary Infotype (0626) record. Hence, the payment summary will be printed with a title indicating that it is a test print.

Prerequisites
You must have the payroll results for the end of the financial year.

Procedure
31. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Payment Summaries → Payment Summaries yyyy/yyyy.

   The Payment Summary Print and Tape Create screen appears.

32. Enter the employee’s personnel number and the payroll period.

33. Enter the financial year the Payment Summary covers.

34. Select the View Payment Summaries field.

35. Choose Program → Execute.

Result
The payment summary is displayed on your screen. This is how the payment summary appears when issued to the employee.
Printing Payment Summaries

Use

Payment summaries must be printed for each employee. This can either be done in parts as and when required by the employees or at the end of the financial year. They show the amount of money earned during that year for taxation purposes.

Part year payment summaries can be printed on request at any time during the financial year. When a part year payment summary is produced, it will contain details from the end date of the previous part-year payment summary issued to this employee up to the current completed pay run. When an employee requests a second part year payment summary or if it is produced at the end of the year, it will not include any values that were reported on the previous part year payment summaries.

The employee must retain all the part year payment summaries produced during the year and provide a copy of these to the ATO when their tax return is created.

A Payment Summary is printed after its accuracy is confirmed. You can print Payment Summaries on Australian Taxation Office (ATO) stationery or on plain paper.

You can verify the accuracy of Payment Summaries by running the Payment Summary Listing Report [Seite 797] and the Employee Allowances Report [Seite 801].

In case of an employee having been re-assigned to an organizational unit with a different ABN / Branch number, the payment summary generated for the employee will automatically produce part year payment summaries for the employment under each Branch / ABN number.

Prerequisites

You must have the payroll results for the latest period or the end of the financial year.

Procedure

36. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Payment Summaries → Payment Summaries yyyy/yyyy.

The Payment Summary Print and Tape Create screen appears.

37. Enter the employee’s personnel number and the payroll period.

38. Enter the financial year the Payment Summary covers.

39. Select Produce Part Year Payment Summary checkbox, if you want to issue payment summary in parts, that is, other than at the end of the financial year.

40. To print test summaries, enter the number you require in the Number of test summaries field.
Test summaries enable you to check the alignment of the data printed on preprinted stationery. You therefore only need to print test summaries if you use preprinted stationery.

41. Enter the destination printer for the Payment Summary.

42. If applicable, enter the destination printer for the Allowance report.

43. To print the Payment Summary on plain paper, select the Plain paper printing field.

44. Choose Program → Execute and print.

The Payment Summary Program (RPCG00Q0) currently supports the following printers:

- HPLJ4   HP Laserjet 4 series PCL-5
- HPLJ5   HP Laserjet 5   R4.x+ ONLY!
- HPLJ5SI  HP Laserjet 5 Si
- HPLJIIID HP Laserjet 3 series PCL-5
- HPLJMI   HP LaserJet 4 w.JetCAPS MICR
- HPLJSTND HP Laserjet 2,3: driver STN2
- HPLJ_II  HP LaserJet 2 series PCL-4
- I2HP4    HP LJ 4 series Latin 2 charse
Regenerating Part Year Payment Summaries

Use
You can reprint all the payment summaries that have already been issued to an employee during the financial year. If you want to generate a payment summary regardless of whether they were issued previously or not, then:

- If many previous part year payment summaries exist, all previous part year payment summaries are regenerated
- If no previous payment summary exists, a single payment summary for the entire year is generated

Procedure
45. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Payment Summaries → Payment Summary yyyy/yyyy.

   The Payment Summary Print and Tape Create screen appears.

46. Enter the employee’s personnel number and the payroll period.
47. Enter the financial year the payment summary covers.
48. Select the Print summary regardless of being issued field.

   This will regenerate and print all the payment summaries produced for the employee in the financial year. It is not possible to print a payment summary for a specific period. You can only print all the payment summaries issued to the employee.

49. If you want to print test summaries, enter the number you require in the Number of test summaries field.

   Test summaries let you check the alignment of the data printed on preprinted stationery. You therefore only need to print test summaries if you use preprinted stationery.

50. Enter the destination printer for the payment summary.
51. If necessary, enter the destination printer for the Allowance report.
52. To print the payment summary on plain paper, select the Plain paper printing field.
53. Choose Program → Execute and print.
Transferring Payment Summaries

Use

Employers who print payment summaries on plain paper or use special stationery are required to supply the payment summaries on a magnetic media, also known as a tax tape, to the Australian Tax Office (ATO). The magnetic media must contain all the payment summaries that have been issued to all active and terminated employees during the financial year. The media can be produced in either UNIX or DOS.

All magnetic media must be forwarded to the Magnetic Information Processing Services (MIPS) together with a completed Magnetic Media Information form.

Prerequisites

You can only create a magnetic media after all payment summaries have been processed and issued to employees.

If you want to produce a PC (DOS) file, you must use the file format BIN.

Procedure

54. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Payment summaries → Payment summary yyyy/yyy.

   The Payment Summary Print and Tape Create screen appears.

55. Enter the employee’s personnel number and the payroll period.

56. Enter the financial year the payment summary covers.

57. Either select PC file or UNIX file.

58. If you select the UNIX file field, enter the UNIX file name and path.

   Or

   If you select the PC file field, the system requests the path and file name after you have executed the program.

59. Specify whether the tape is a test run or a production run.

60. Choose Program → Execute.
Producing Payment Summaries Manually

Use

You can issue a payment summary manually to tell the system that a payment summary has been issued to the employee. In this case the employee is not included in the Australian Tax Office (ATO) file. This will create a record in the Payment Summary (Infotype 0626).

If a part year payment summary is issued, following the issue of a manual payment summary in the infotype, then the part year payment summary will be generated for the period after the manual payment summary upto the end date of the last run payroll period in that financial year.

Prerequisites

You must issue the payment summary without running the Payment Summaries program.

Procedure

To create the payment summary manually, you must record the issue in the Payment Summary infotype as follows:

1. Create a record for the employee in the Payment Summary infotype.
   
   The Create Payment Summary screen appears with the Withdrawn field set to No and the Manual field defaulted to Yes.

2. In the Payment summary start date field, enter the start date of the period for which the payment summary is being issued.

3. In the Payment summary end date field, enter the end date of the period for which the payment summary is being issued.

4. Save the infotype record.

Result

Manual payment summary has been created. By creating a record in the infotype manually, the Payment Summaries program can determine when a payment summary was last issued for the employee.
Withdrawing Payment Summaries

Use

The SAP standard system allows you to withdraw payment summaries issued to an employee. If you produce a payment summary and subsequently realize that it is not valid (for example, because a terminated employee has been rehired or it contains the wrong values), you can cancel the payment summary by withdrawing the corresponding record in the Payment Summary infotype.

The payment summaries can be withdrawn in the infotype starting from the latest or the most recent payment summary to the first one created in the year.

Procedure

To do this, you:

1. Access the infotype record created by the Payment Summaries program in Change mode. The Change Payment Summary screen appears.
2. Set the Withdrawn field to Yes.
3. Choose Save.

Result

The payment summary is withdrawn. The next time you run the Payment Summaries program, the SAP System ignores the fact that a payment summary has been issued and creates a new payment summary and payment summary record for the employee.
Payment Summary Override (RPCGCOQ0)

Use

The Payment Summary Override program allows you to override values of wagetypes on a specific date in a period in the financial year. The program also enables you to override values for an employee while employed earlier in the year in an organizational unit with a different ABN/branch from the current ABN/branch.

The Payment Summaries 2000-2001 program must have been configured to include off-cycle payroll results on payment summaries automatically.

Prerequisites

You must set up a date specific override only if the payment summary has not been generated for the period in which the date falls.

Override values without a specific date must be setup only if the final payment summary has not been generated. This is applicable to final payment summary.

You must withdraw the corresponding payment summaries to introduce override values during these periods.

Activities

2. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Other activities → Payment Summaries → Payment Summary Override.

   The Payment Summaries Override dialog box appears.

3. Enter the year and personnel number that you want to display.

   The system displays the wage types and amounts previously entered in the Payment Summaries Override program.

3. Enter the date for which you want to execute the override program. If you do not require a date specific override, then you can leave this field blank and the program will automatically make adjustments for the last payment summary report of the year.

4. Select Program → Execute.
ETP Payment Summaries

Use
An Eligible Termination Payment (ETP) is a payment made to an employee as a result of the termination of employment – for example, through redundancy, invalidity, or death. ETPs include golden handshakes, payments in lieu of notice, compensation for wrongful dismissal, redundancy payments and payments for unused sick leave.

The ETP payment summary replaces the procedure of issuing a second payment summary with some ETP information on it and accompanying this with a Statement of Termination Payment form. Termination payments and the tax on termination payments are classified as lump sum C. If lump sum C appears on a standard payment summary, the SAP System generates an ETP payment summary.

Integration
To process ETP payment summaries, the system reads data from the Actions (0000), Personal Data (0002), Addresses (0006), Tax Australia (0188), Tax File Number (0227), Absences (2001) and Other/Previous Employers (0023) infotypes. In addition, the program accesses tax and salary data stored in the cumulation results table (CRT).

Prerequisites
You must have payroll results for the end of the financial year.
You must have set up a valid printer in Customizing for Payroll Australia.

Features
In addition to the data supplied with standard payment summaries [Extern], ETP payment summaries contain the following data:

- Date of ETP payment
- Eligible service period start date
- Number of service days before July 1983
- Number of service days after July 1983
- ETP component before July 1983
- ETP component after July 1983
- Invalidity component after June 1994
- Gross amount of the ETP component
- Assessable ETP amount
- Tax deducted from the ETP component
- Death benefit
- Trustee of deceased’s estate
The *Payment Summaries* program can print multiple ETP payment summaries that are output to a separate spool request and printed directly after all of the standard payment summaries have been printed.

See also:

- Printing ETP Payment Summaries
  
  [Seite 796]
Printing ETP Payment Summaries

Prerequisites
An employee must have received an eligible termination payment (ETP).
You must have payroll results for the end of the financial year.

Procedure
61. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities →
Annual → Other activities → Payment summaries → yyyy/yyyy Payment summary.
The Payment Summary Print and Tape Create screen appears.
3. Enter the employee’s personnel number and the payroll period.
8. Enter the financial year the payment summary covers.
9. To print the payment summary on plain paper, select the Plain paper printing for ETP field.
10. To print test summaries, enter the number you require in the Number of test summaries field.

Test summaries let you to check the alignment of the data printed on preprinted stationery. You therefore only need to print test summaries if you use preprinted stationery.

11. In ETP summary printer field, enter the destination printer or leave the default printer.
12. Choose Program → Execute and print.
Payment Summary Listings

Use

The SAP HR Payroll Australia component lets you verify and detect errors in year-to-date amounts and employee details before issuing payment summaries. In addition, you can identify employees who already have a payment summary issue to them.

You can do this by generating the Payment summary listing for the year 2000/2001.

The Payment Summary Listing report prints the payment summary details and the ETP details in separate reports. You can now specify which report is to be printed by this program.
Payment Summary Listing 2000/2001

Use

The function generates a Payment Summary Listing that allows you to verify and detect errors in year-to-date amounts and personnel data, such as an employee’s name, address and tax file number, and to correct errors before issuing payment summaries. The listing also identifies employees who already have a payment summary issued to them.

Integration

The Payment Summary Listing report reads data from the Personal Data (0002) and Tax Australia (0188) infotypes. In addition, the program accesses tax and salary data for the payroll period you want to verify.

Prerequisites

You must have processed, but not necessarily completed, at least one payroll run.

Features

The program allows you to generate the following data for the last updated payroll period or a selected period and year for one or more payroll areas:

- Payment summary listings
  These provide an overview of all the payment-related data printed on an employee’s payment summary.

- Separate payment summaries on change of Australian Business Number
  The SAP System issues a separate payment summary when an employee changes payment tax employer. This report allows you to verify separate payment summaries issued when there is a change in payment tax employer. You can sort the data by payment employer or by company code.

- Report part year payment summaries separately.
  If you select the Report part year payment summaries field, there will be an additional entry on the report with values which were on the part year payment summary. Otherwise, regardless of whether or not an employee has received part year payment summaries, the program will print only one record for the employee.

- ETP details in a separate report.
  If you select the ETP Payment Summary listing report field, the program will print the ETP details in a separate report.

- An exception report
  If you select the Report by exception field, you can list payment summary details for employees given the following situations:
  - An employee does not have a tax file number
  - An employee has an ATO exemption code set up in their Tax File Number infotype (0227)
- An employee does not receive a payment summary because all of his or her values are set to zero
- A payment summary has already been issued to the employee

See also:

Executing a Payment Summary Listing [Seite 800]
Employee Allowances Report [Seite 801]
Executing a Payment Summary List

Prerequisites
You must have processed at least one payroll run.

Procedure
6. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Lists/statistics → End-of-year reports → Payment Summaries. listing reports → Payment summaries. listing yyyy/yyyy.
   The Payment Summary Listing Report screen appears.
7. Enter the employee’s personnel number and the payroll period.
8. Make sure that the Payment Summary Listing Report field has been activated.
9. To report details of each individual payment summary, select the Report part year payment summary separately option.
10. To create a separate payment summary listing on change of ABN, select the Produce multiple payment summaries by ABN field.
    For each ABN or branch, a total is printed in the report. Within each ABN/Branch number, you can print part year payment summaries individually or summarized into a single line of data by selecting the Report part year payment summary separately option.
    Or
    To create an exceptions report, select the Report by exception field.
11. To print the amounts with decimals truncated, select the Truncate all numeric values to the nearest dollar? field.
12. Choose Program → Execute
Employee Allowances Report

Use

The Australian Taxation Office (ATO) defines the number of allowances that can be displayed on a payment summary. If the number of allowances earned by an employee exceeds seven, the allowances must be grouped into taxable and non-taxable before they are displayed on a payment summary.

The payments taxable and non-taxable allowances function, displays the total amount and prints the allowances on a separate attachment.

Integration

The Employee Allowances report is triggered by the Payment Summaries program, and reads the allowances wage types stored in the payroll results.

Prerequisites

You must have processed at least one payroll run.

You must have set up a valid printer to print the Employee Allowances report.

Features

The SAP System generates an Employee Allowances report whenever a payment summary is executed for an employee who has earned more than seven allowances in a financial year. The report:

- Provides a description of each allowance earned by the employee
- Lists the amount associated with the allowance
- Payments taxable and non-taxable allowances

If a valid printer has been set up, the system prints the Employee Allowances report. If the printer specified is not available, the Employee Allowances report remains in the spool queue. You can print the report from the spool queue and then attach a copy to a payment summary.

You can display and verify an Employee Allowances report by activating the Employee Allowances Report field found within the Payment Summaries Listing report.

See also:

Displaying and Printing Allowance Reports [Seite 802]
Payment Summaries [Seite 780]
Payment Summary Listings [Seite 797]
Displaying and Printing Allowances Report

Use

This procedure describes how to:

- Display an Employee Allowances report before it is executed by the Payment Summaries program
- Print an Employee Allowances report from a spool queue

If an employee receives more than seven allowances in a financial year, the Payment Summaries program automatically triggers the Employee Allowances report. However, you can display and detect errors in an Employee Allowances report before running the Payment Summaries program. You do this by activating the Employee Allowances Report function found within the Payment Summary Listing report for the relevant financial year. This enables you to correct errors before you run the Payment Summaries program and print the Employee Allowances report.

Prerequisites

You must have processed at least one payroll run.

Procedure

Displaying allowance reports

5. Choose Human Resources → Payroll → Asia/Pacific → Australia → Subsequent activities → Annual → Lists/statistics → End-of-year reports → Payment summaries listing yyyy/yyyy.

The Payment Summary Listing Report screen appears.

6. Enter the employee’s personnel number and the payroll period.

7. Select the Employee allowances report field.

8. Choose Program → Execute.

Printing allowance reports

7. Choose System → Services → Output controller.

8. Choose Enter.

9. To print the report, select the allowance listing Allow-pysum.

10. Choose Print.

11. In the Output device field, enter the printer name.

12. Choose Print.
Using Evaluation Schemas

Use

You can evaluate the payroll results using the respective country-specific schema x500. This schema is only used in a few country versions.

The payroll results are evaluated in an additional run, which is carried out by the payroll driver. A sequential file (TemSe object) is generated with the payroll data. The file created in this way is stored under the respective file name, your user ID, and the date and time of the program run. The subsequent evaluations access this data.

Prerequisites

The payroll run must have been completed successfully for the personnel numbers you want to post.

You are in the ABAP Editor: Initial Screen.

Activities

1. You start the payroll driver with the appropriate evaluation schema.
2. Enter the appropriate values in the fields and set the required indicators.
3. Choose Program → Execute or Execute + Print or In Background.

   If you have chosen Display log, after posting, a log will appear on screen which displays the evaluation data.
Evaluating the Payroll Results Using Infotypes or the Logical Database

Use

The following options are available in the SAP system for evaluating the payroll results.

- The payroll infotypes [Seite 807] and the InfoSet Query [Extern]
  
  For detailed information on the InfoSet Query, see the SAP Library under Human Resources → Reporting in Human Resources Management → HR Reporting Tools → SAP Query (BC-ERV-Que) → InfoSet Query.

- Logical Database [Extern]

- Standard reports
  
  You can evaluate the payroll results in direct access with the standard reports.

  - Remuneration statement [Seite 546]
  - Payroll journal [Seite 558]
  - Payroll account [Seite 555]
  - Wage type reporter [Seite 564]

  For detailed information on the standard reports, see the SAP Library under Payroll → Other Countries → Subsequent Activities.

- Business Warehouse
  
  You can also evaluate the payroll results in the SAP Business Warehouse environment. For detailed information on this, see the Business Warehouse in the SAP Library.

Scope of Function

Inform yourself of the evaluation options before you evaluate the payroll results.

Comparison of the Evaluation Options using Payroll Infotypes or using the Logical Database PNP with the Enhancements for the Payroll Results
### Evaluating the Payroll Results Using Infotypes or the Logical Database

<table>
<thead>
<tr>
<th>General criteria for the evaluation</th>
<th>Payroll infotypes for the evaluation with the InfoSet Query</th>
<th>Enhancement of the logical database PNP for Payroll for direct evaluation with reports</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Evaluation path</strong></td>
<td>If you want to evaluate the payroll results using the InfoSet Query [Extern], use the relevant payroll infotype (for example, Monthly Cumulation (0458)). You use the payroll infotype to provide the InfoSet Query with the payroll results for evaluation.</td>
<td>If you want to use reports to evaluate the payroll results, you use the logical database for Payroll. The reports call the logical database to evaluate the payroll results. The InfoSet Query does not use the logical database for Payroll to evaluate the payroll results.</td>
</tr>
</tbody>
</table>
| **Storing the data**               | The SAP system stores the data in the transparent tables for the payroll infotypes. Special wage types called evaluation wage types [Extern] are available for this purpose. | The payroll driver stores the data for the logical database redundantly, in transparent form, in the following tables:  
  - Directory information from the CU cluster is stored in the transparent table HRPY_RGDIR. The cluster remains in the system.  
  - Data for the Work Center/Basic Pay (Table WPBP) from the RX cluster is stored in the transparent table HRPY_WPBP. The RX cluster remains in the system. |
| **Calling the data**               | The SAP system only calls the current payroll results. You can select the evaluation data with the help of wage types. | The SAP system calls all the payroll results from the evaluation period for processing. |
Evaluating the Payroll Results Using Infotypes or the Logical Database

Data Selection

You get a quick selection of the payroll results with the help of the wage types that are provided in the payroll infotype.

You get a high-performance selection of the payroll results with the help of selected fields from the Period group box and the organizational fields from the Selections group box (for example, personnel number, payroll area or company code).

Example in report:
EXAMPLE_PNP_GET_PAYROLL

Programming

You should not change the programming of the payroll infotypes and use (read) them in other programs.

You can use the existing reports to evaluate or write evaluation reports using program examples.

Validity for the countries

As well as payroll infotypes, that are valid internationally (for example, payroll results: Periodical Values (0402), Monthly Cumulation (0458) there are payroll infotypes that are valid for one country.

In the SAP system, there is one logical database for all countries. Country-specific features are provided by standardizing the node PAYROLL (for example, NODES: PAYROLL TYPE PAYUS_RESULT)

Prerequisites

<table>
<thead>
<tr>
<th>Description</th>
<th>Payroll infotypes</th>
<th>Enhancement of the PNP logical database for Payroll</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customizing</td>
<td>In Customizing for Personnel Management under Human Resources Information System → Payroll Results [Extern] you have:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• defined the evaluation wage types</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• assigned the wage types</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• set up the payroll infotype</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• assigned the payroll infotype to Payroll</td>
<td></td>
</tr>
<tr>
<td></td>
<td>In the attributes for the evaluation report, you have specified the following:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Logical database: PNP</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Selection screen version: 900 selection screen for the payroll results</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• HR report class for Payroll (for example, the standard value PY_DEF) and the function Payroll report class selected.</td>
<td></td>
</tr>
</tbody>
</table>
Infotypes for Evaluating Payroll Results

Use

In addition to master data, applicant data, and personnel planning data, you can also evaluate payroll results using a query and InfoSet query.

A number of predefined infotypes are available for the evaluation. The wage types required for the evaluation are entered in these infotypes:

<table>
<thead>
<tr>
<th>Infotype</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>0402</td>
<td>Payroll Results: Period Values</td>
</tr>
<tr>
<td>0403</td>
<td>Payroll Results: Period Values (not required at present)</td>
</tr>
<tr>
<td>0458</td>
<td>Monthly Cumulation of Payroll Results</td>
</tr>
<tr>
<td>0459</td>
<td>Quarterly Cumulation of Payroll Results</td>
</tr>
<tr>
<td>0460</td>
<td>Annual Cumulation of Payroll Results</td>
</tr>
</tbody>
</table>

You can either activate these predefined infotypes or create your own infotypes using the same structures. You can enhance these infotypes by using additional wage types and then activating the infotypes. This makes the necessary data, from the payroll results, available on the PNP logical database.

If an error occurs when filling the payroll infotype, refer to the note *Problems when Filling the Payroll Infotype* (note number 0125921).

Furthermore, we recommend that you create your own payroll infotypes in the customer name range 9^*^ and do not modify the payroll infotypes *Payroll Results: Period Values* (0402 or 0403).

USA: Infotypes for Tax Reporting

The pre-defined infotypes 0446 and 0457 are also used for tax reporting. These infotypes have been created specifically for the USA. For more information, see *US Tax Payroll Infotypes (0446-0457)* [Extern].

Prerequisites

You have performed the following activities before you set up the evaluation of payroll results using a query or InfoSet Query:

1. In Customizing for Personnel Management under Human Resources Information System → Payroll Results → Set Up Payroll Infotypes [Extern], you have activated the payroll infotypes you require. You can create new payroll infotypes based on pre-defined payroll infotypes and then enhance these to meet your requirements.
Infotypes for Evaluating Payroll Results

2. The infotype was filled out with the information from a payroll result. You have two options:
   - As long as Customizing has been set up accordingly, data is automatically transferred to
     the infotype in each payroll run. You do this in Customizing for Personnel Management
     under Human Resources Information System → Payroll Results → Set Up Assignment
     for Payroll [Extern].
   - You can enter data in the infotype without a payroll run using report RPABR100.

Activities

For information on evaluations using a query or InfoSet query, see BC - SAP Query [Extern]. For
information on evaluations in Human Resources, see Maintaining Queries in the HR Application
[Extern].
Payroll Results Infotypes: Period Values (0402 and 0403)

Definition

The Payroll Results: Period Values infotype (0402) contains information from the payroll results of the regular payroll run. Infotype 0403 is identical and is currently not required.

The start and end dates for the infotype correspond to the payroll period.

Structure

You define the structure of the infotype in Customizing for Personnel Management under Payroll Results [Extern].

You cannot maintain the infotype on-line. You can maintain the infotype using one of the following methods:

- The data is automatically updated when the payroll run has been completed successfully, however, this must be set up accordingly in Customizing for Personnel Management under Human Resources Information System → Payroll Results → Set Up Assignment for Payroll [Extern]. We recommend that you use this procedure as the data in the payroll infotype is automatically updated by the system (also in the case of retroactive accounting).

- You can update the data at any time using report RPABRI00. We recommend that you use this procedure if existing payroll results should be evaluated.

Using this infotype as a basis, you can evaluate the results of a regular payroll run using the query and the InfoSet Query.
Monthly Cumulations (Infotype 0458)

Definition

In the standard system, the Monthly Cumulation of Payroll Results infotype (0458) contains general information from the payroll results and cumulation wage types [Extern] referring to one month. This can be useful if the periods for your payroll run are weekly and not monthly, or if payroll is run using a different frequency.

The start and end dates for the infotype correspond to the cumulation period. If your employee, for example, leaves the company in the middle of a cumulation period, you can still access the cumulated values.

Structure

You define the structure of the infotype in Customizing for Personnel Management under Payroll Results.

You cannot maintain the infotype on-line. You can maintain the infotype using one of the following methods:

- The data is automatically updated when the payroll run has been completed successfully, however, this must be set up accordingly in Customizing for Personnel Management under Human Resources Information System → Payroll Results → Set Up Assignment for Payroll [Extern].

- You can update the data at any time using report RPABRI00.

Using this infotype as a basis, you can evaluate payroll results using the query and the InfoSet Query.
Quarterly Cumulations (Infotype 0459)

Definition
In the standard system, the Quarterly Cumulation of Payroll Results infotype (0459) contains general information from the payroll results, as well as cumulation wage types [Extern] that refer to quarterly values.

The start and end dates for the infotype correspond to the cumulation period. If your employee, for example, leaves the company in the middle of a cumulation period, you can still access the cumulated values.

Structure
You define the structure of the infotype in Customizing for Personnel Management under Payroll Results.

You cannot maintain the infotype on-line. You can maintain the infotype using one of the following methods:

- The data is automatically updated when the payroll run has been completed successfully, however, this must be set up accordingly in Customizing for Personnel Management under Human Resources Information System → Payroll Results → Set Up Assignment for Payroll [Extern].

- You can update the data at any time using report RPABRI00.

Using this infotype as a basis, you can evaluate payroll results using the query and the InfoSet Query.
Annual Cumulations (Infotype 0460)

Definition

In the standard system, the infotype Annual Cumulation of Payroll Results (0460) contains general information from the payroll results as well as cumulation wage types [Extern] for annual values.

The start and end dates for the infotype correspond to the cumulation period. If your employee, for example, leaves the company in the middle of a cumulation period, you can still access the cumulated values.

Structure

You define the structure of the infotype in Customizing for Personnel Management under Payroll Results.

You cannot maintain the infotype on-line. You can maintain the infotype using one of the following methods:

- The data is automatically updated when the payroll run has been completed successfully, however, this must be set up accordingly in Customizing for Personnel Management under Human Resources Information System → Payroll Results → Set Up Assignment for Payroll [Extern].

- You can update the data at any time using report RPABRI00.

Using this infotype as a basis, you can evaluate payroll results using the query and the InfoSet Query.
Using the Logical Database for Payroll

Use

From Release 4.6A, the evaluation of payroll results is supported by a logical database that is integrated in the logical database PNP for HR master data [Extern]. This tool enables you to create programs for the evaluation of payroll results both simply and quickly.

Using the logical database for payroll results has the following advantages for the user:

- You can access the payroll results faster and more easily.
- It is a simple and standardized way of evaluating the payroll results.
- Evaluation reports use this standardized interface and have a standard appearance.
- The performance of the evaluation reports is improved by using transparent tables for data selection.
- The number of coding lines in the evaluation programs (reports) is reduced by up to 60 percent.
- An evaluation report can be created in less time.
- The logical database supports use of the HR process workbench [Seite 98]. This improves integration in the whole payroll process.
- The selection screen can be customized. To do this, you use the new report categories [Seite 827]
- Different sort variants (all the fields for WPBP and RGDIR can currently be sorted)
- It is not necessary to customize the payroll infotypes.

Use the logical database for payroll for new reports that evaluate the payroll results.

Scope of Function

The most important functions are:

- Data Retrieval

  The logical database [Extern] consists of special ABAP programs that also provide the programs in Payroll with the evaluation data. All the data in a payroll record is provided in
Using the Logical Database for Payroll

the subobjects for a complex structure [Seite 817] at a selected time. To evaluate the payroll results, you can use reports from the standard system or create your own reports.

- Data Selection

The logical database provides a particular view of the database tables for Personnel Administration (PA-PA) or Payroll (PY) and enables you to select and evaluate payroll results according to particular criteria.

Employees can now be selected on the selection screen of the evaluation report according to organizational criteria, for example, you can select all employees in a payroll area, however, the selection is made using exclusively the payroll results.

- Authorization

The system checks whether the user who started the evaluation has the correct authorization for this evaluation. The authorization concept corresponds to the concept of the previous PNP report.

<table>
<thead>
<tr>
<th>Technical Criteria or Enhancements</th>
<th>Logical Database for HR Master Data (PNP)</th>
<th>Logical Database for Payroll (PNP with Screen 900)</th>
</tr>
</thead>
</table>

Comparison of the Logical Database for HR Master Data and the Logical Database for Payroll
### Time of data retrieval

There is only one date available for data retrieval:
- At the time of GET PERNR, all infotype records are placed in an internal table for one personnel number

Several data retrieval events exist:
- At the time of GET PERNR, all the infotype records are made available in an internal table (infotype table) for one personnel number
- At the time of GET PAYROLL, the payroll results for a personnel number are made available in a complex structure
- If all GET PAYROLL events have run for a personnel number, the event GET PERNR LATE is triggered

### Retrieval of payroll data for the evaluation programs

Each internal table and field string (for example, RT, BT, SV, and so on) must be sorted and processed individually

A complex structure containing all tables (WPBP, SV, BT, and so on) for each country

### Selection

- According to infotypes
- Extends to the HR master data
- According to payroll results
- Extends to the HR master data and payroll results

### Evaluation report

- Uses import macros (for example, RP-IMP-C2-RX)
- Sorting required
- Uses complex structures
  ![Seite 817]
- You can use all fields in the internal tables HRPY_RGDIR and HRPY_WPBP and sort them as required
- Selection of required sort sequence using the Sort function in the report
| Modifying the selection screen | In Customizing for Personnel Management under Human Resources Information System → Reporting using: Report categories (selection criteria [Extern]) | In Customizing (when creating a report) using: Report categories The fields on the selection screen for the evaluation report are controlled using the new report categories. The main procedure for customizing the selection screen corresponds to the familiar procedure for customizing the PNP report categories. |
Structure of Logical Database for Payroll

The logical database for payroll transfers the payroll results to the evaluation reports in a complex structure. This structure contains an international and a national node that are subordinate to the root nodes:

- International node
  
  The international node contains international (non-country-dependent) tables (for example, RT, CRT). The appropriate international tables are filled at runtime and retrieved using the complex structures.

- National node
  
  The national node contains the national tables (for example, SV). The corresponding national tables are determined and filled at runtime using the type assignment.
Conversion of Evaluation Reports

How Do You Convert an Existing Evaluation Report to the Logical Database for Payroll?

In Release 4.6C, we recommend that you first convert any reports (standard reports and customer reports) that are not used by any other report. You should not convert reports that are called using function modules or other reports (for example, the remuneration statement or the payroll account) in this release.

See the release note Using the Logical Database for Payroll for Release 4.6C.

To convert a report to the logical database for payroll, proceed as follows:

- Enter the following in the report attributes:
  - Logical database: PNP
  - Selection screen version: 900 selection screen for the payroll results
  - HR report category for payroll: PY_DEF of a customer report category
    Select Payroll report category.

- Change the following in the coding:
  - The evaluation report is assigned to a country when the coding line NODES: PAYROLL TYPE PAY99_RESULT is inserted.
  - Switch the RP-IMP-C2-xx macro to the event GET PAYROLL. We recommend that you no longer use the macro RP-IMP-C2-xx.

SAP provides the report EXAMPLE_PNP_GET_PAYROLL [Seite 822] as an example.
To convert old evaluation reports, use the utility macros [Seite 823], which are contained in the standard system, and one of the listed variants.

- If you only want to make minor changes to the coding of the report, we recommend that you use variant A for the conversion. With this variant, the conversion effort required is minimal.
  - Example: Old coding [Seite 824]
  - Example: Variant A – New coding [Seite 825]
- We recommend that you use variant B for the conversion if the report is not very large and you want it to be compatible for further developments.
  - Switch macro RP-IMP-C2-xx to the event GET PAYROLL.
  - Example: Old coding [Seite 824]
  - Example: Variant B – New coding [Seite 826]

See also:

Example 1: ABAP Coding: Read International Payroll Results [Seite 820]
Example 2: ABAP Coding: Read National Payroll Results [Seite 821]
Example 3: Utility Macros for Report Conversion [Seite 823]
Example 4: Old Coding [Seite 824]
Example 5: Variant A – New Coding [Seite 825]
Example 6: Variant B – New Coding [Seite 826]
Example 7: Report EXAMPLE_PNP_GET_PAYROLL for Evaluation of Payroll Results [Seite 822]
ABAP Coding: Read International Payroll Results

The system reads the international part of the payroll results for all clusters. The GET PAYROLL event is triggered for all personnel numbers and not just for the international country grouping (99).
ABAP Coding: Read National Payroll Results

The system reads country-specific payroll results (for example, for Germany). The GET PAYROLL event is only triggered for personnel numbers for the specified country.
**ABAP Coding: Report EXAMPLE_PNP_GET_PAYROLL for Evaluation of Payroll Results**

This report uses the logical database PNP to evaluate the payroll results.

Example: Short version of report `EXAMPLE_PNP_GET_PAYROLL`

```abap
REPORT EXAMPLE_PNP_GET_PAYROLL.
 *
 * You find an extended version
 * of this report in your R/3 system !
 TABLES: pernr, pyorgscreen, pytimestcreen.
 NODES: payroll TYPE pay99_result.
 Data: g_result_counter type i.
 GET pernr.
 WRITE: / 'Currently working on:', pernr-pernr.
 GET pernr LATE.
 WRITE: / 'Found', g_result_counter,
     'results for #', pernr-pernr.
 ULINE.
 GET payroll.
 g_result_counter = g_result_counter + 1.
 WRITE: / 'Seq No. = ', payroll-evp-seqnr,
      'In period =', payroll-inter-versc-inper,
      'In period =', payroll-inter-versc-inper,
      'Pay date =', payroll-inter-versc-paydt.
```
Utility Macros for Report Conversion

- For the O tables (for example, ORT), use copytodata_o.
- To transfer the contents of the single tables (for example, RT) to the complex structure, use copytostruc(_o).
- The macro copystruc_o works in the same way as copystruc but for O tables.
Example – Old Coding
Example: Variant A: New Coding

Advantage

Parts of the coding that refer to the single tables (for example, RT, CRT, and so on) need not be changed since the single tables are filled by the macro `copytodate`. 
Example: Variant B: New Coding

Advantage

The use of the complex structure simplifies the layout of the report. This variant does not require the macros. Instead, it uses the new complex structure PAYROLL. You do not need to use an INCLUDE as in the Example – Variant A: New Coding [Seite 825].

Disadvantage

You must replace the link to the single tables (for example, RT, CRT) by a link to the complex structure.
Report Category

Definition

The report category specifies which fields are displayed on the selection screens of evaluation reports in Human Resources.

Use

Report Categories for HR Master Data

The report categories for HR Master Data define which master data fields are displayed on the standard selection screens for standard evaluation reports. Report categories are already assigned to the standard reports.

In Customizing for Personnel Management, you can create report categories [Extern] and assign a report category to an evaluation report [Extern].

Only change the report categories for the standard SAP reports, if the selection screen for the SAP standard system does not meet your requirements and you are aware of the effect this will have on the selection screen.

Report Categories for Payroll

The report categories for the evaluation of payroll results define which master data fields are displayed on the standard selection screens for evaluation reports.

If you want to create a new evaluation report to evaluate the payroll results using the logical database for payroll, use either report category PY_DEF, or create your own report category and assign it to the new report.

See also:

Creating a Report and Report Category [Seite 828]
Creating a Report and Report Category

Use
You want to create a new report to evaluate the payroll results.

Prerequisites
You are in the ABAP Editor in the Change Program Attributes <name report> screen.

Procedure
1. Enter the required values in the fields you are already familiar with.
2. In the Logical database field, enter PNP and in the Selection screen version field, enter 900 for the logical database for payroll.
3. Choose HR report categories.
   The Report Category Assignment dialog box appears.
4. Select Payroll results (Cluster) and enter the name of the new report category.
5. Choose Create report category.
   The View Change “Time Selection Definition” Overview: screen appears.
6. To develop the report further, define the time and organizational selections.
7. Save your entries.

Result
You can use the report to evaluate payroll results.
Interface Toolbox for Human Resources (PX-XX-TL)

Purpose
In the SAP System, you can use the following methods to transfer data from the application components in Human Resources (HR) to a third-party system, or vice versa:

- Interface Toolbox
- Application Link Enabling (ALE [Extern])
- Business Application Programming Interface (BAPI [Extern])

A comparison of the technology [Seite 831] shows which method is most suitable to perform the task.

You use the Interface Toolbox to retrieve data from Human Resources for further processing in a third-party system. The third-party system can be a payroll system used outside of the SAP System. This can be useful if, for example, you run gross payroll in your enterprise and the net payroll takes place in a third-party system.

Alternatively, you can use the Toolbox to import results based on personnel numbers from the third-party system and use them for payroll in the SAP System.

You use the interface to

- Evaluate data from Human Resources in a third-party system
- Run payroll partially or completely in a third-party system

The data is retrieved from the Personnel Administration (PA-PA), Payroll (PY), and Time Management components, or from all three.

Access
You access the Toolbox using transaction PU12.

In the Time Management component (PT), you call the Interface Toolbox from the menu. Choose Time Management → Administration → Environment → Third-party payroll.

In the Payroll component (PY), you also call the Interface Toolbox from the menu. In the SAP Menu, choose Human resources → Payroll → Tools → Maintenance tools → Interface Toolbox.

Features
Selected examples show which scenarios can be performed using the Toolbox:

- Exporting master data to a third-party system [Seite 833]
- Exporting master data and payroll results to a third-party system [Seite 834]
- Gross payroll in an SAP System and net payroll in a third-party system [Seite 836]

The Toolbox enables you to create an interface as well as carry out routine work. The following processes and associated functions are important for using the Interface Toolbox:

- For the data export
  Setting up the interface for exporting with the Toolbox [Seite 838]
Interface Toolbox for Human Resources (PX-XX-TL)

- Data export with the Toolbox [Seite 840]
- For the data import
  - Importing wage types with the Toolbox [Seite 1008]

For detailed information on the required activities, see the individual sections.
## Technology for Interface Scenarios

<table>
<thead>
<tr>
<th>Task</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export HR master data (infotypes) from the SAP System to a third-party system</td>
<td>Interface Toolbox</td>
</tr>
<tr>
<td></td>
<td>• Transport HR master data from all possible infotypes (also customer infotypes)</td>
</tr>
<tr>
<td></td>
<td>• Convert selected data to file format for third-party system</td>
</tr>
<tr>
<td></td>
<td>• Example: [Export master data to a third-party system](Seite 833)</td>
</tr>
<tr>
<td></td>
<td><strong>ALE [Extern]</strong> (Application Link Enabling)</td>
</tr>
<tr>
<td></td>
<td>• The standard system contains an ALE business process for some infotypes</td>
</tr>
<tr>
<td></td>
<td>• You can insert additional infotypes (see note in OSS note system)</td>
</tr>
<tr>
<td></td>
<td>Data is exported in the SAP format only (no conversion)</td>
</tr>
<tr>
<td>Import HR master data (infotypes) from the third-party system to the SAP System</td>
<td>**ALE / BAPI [Extern]**s (Business Application Programming Interface)</td>
</tr>
<tr>
<td></td>
<td>• <a href="Extern">Batch input technology</a></td>
</tr>
<tr>
<td>Export payroll results (infotypes) from the SAP System to a third-party system</td>
<td>Interface Toolbox</td>
</tr>
<tr>
<td></td>
<td>• Select all possible tables in Payroll</td>
</tr>
<tr>
<td></td>
<td>• Additional options for processing wage types (for example, consideration of retroactive accounting)</td>
</tr>
<tr>
<td></td>
<td>• Example: [Export master data and payroll results to a third-party system](Seite 834)</td>
</tr>
<tr>
<td></td>
<td>Combination of Toolbox and ALE</td>
</tr>
<tr>
<td></td>
<td>• The Toolbox fills the IDocs</td>
</tr>
<tr>
<td></td>
<td>• Distribute the complete IDocs using ALE</td>
</tr>
<tr>
<td></td>
<td>• IDocs exist in the SAP interface for North America - they can be used by customers (in IDoc administration, these are the IDoc types that begin with 'HROT')</td>
</tr>
</tbody>
</table>
### Technology for Interface Scenarios

<table>
<thead>
<tr>
<th>Import wage types from a third-party system to the SAP System</th>
<th>Process (See also: Importing Wage Types with the Interface Toolbox [Seite 1008])</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1. Transfer the wage types to interface tables with</td>
</tr>
<tr>
<td></td>
<td>- Transfer by customer program</td>
</tr>
<tr>
<td></td>
<td>- A BAPI (Object: BUS7023 Manager for External Payroll; Method: InsertOutsourcer)</td>
</tr>
<tr>
<td></td>
<td>2. Start payroll to transfer the wage type to the payroll result</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Export time evaluation results (infotypes) from the SAP System to a third-party system</th>
<th>Interface Toolbox</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection of Time Management tables that are relevant for payroll (tables: ZL, C1, ALP)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Import time evaluation results from the third-party system to the SAP System</th>
<th>Human Resources and external applications [Extern]</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Change validation (Transport changed data to third-party system)</th>
<th>Interface Toolbox (See also: Change Validation [Seite 879])</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Change validation is possible for individual fields or for complete infotype records</td>
</tr>
<tr>
<td></td>
<td>• Method: Import all data and compare it with old data (check performance).</td>
</tr>
<tr>
<td></td>
<td>ALE</td>
</tr>
<tr>
<td></td>
<td>• Change validation only possible on infotype record level (export complete infotype record)</td>
</tr>
<tr>
<td></td>
<td>• Method: Change display technology (system recognizes changes to the infotype and only exports these if a change takes place)</td>
</tr>
</tbody>
</table>
Example 1: Export Master Data to a Third-Party System

Task
You want to export HR master data from the SAP System to a third-party system to be used as a basis for
- Evaluations
- Payroll

This application example is simple to effect with the Interface Toolbox.

Only master data is taken from the SAP System. No information is transferred from the third-party system to the SAP System.

Prerequisites
You use the Personnel Administration application component (PA-PA) in your enterprise.

Method

<table>
<thead>
<tr>
<th>Step</th>
<th>in the SAP System</th>
<th>In the Third-Party System</th>
</tr>
</thead>
</table>
| 1.   | Export HR master data (infotypes) from the SAP System to a third-party system | With the Toolbox  
- Set up the interface for the export  
- Run the data export | The master data and payroll results from the SAP System are in the third-party system. |
| 2.   | You start payroll or payroll reporting programs in the third-party system. | The payroll and reporting results are available in the third-party system. |
Example 2: Export Master Data and Payroll Results to Third-Party System

**Task**
You want to use HR master data and payroll results (gross or net) from the SAP System to a third-party system as a basis for

- Evaluations
- Payroll

You can also transfer time results to the third-party system instead of the payroll results.

No information is transferred from the third-party system to the SAP System.

**Prerequisites**
You use the following application components in your enterprise:

- *Personnel Administration (PA-PA)*
- *Time Management (PT)*
- *Payroll (PY)*

You have set up gross payroll in the SAP System.

**Method**

<table>
<thead>
<tr>
<th>Step</th>
<th>in the SAP System</th>
<th>In the Third-Party System</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>You run payroll (gross or net) in the SAP System.</td>
<td>The payroll results are available after a successful payroll run.</td>
</tr>
</tbody>
</table>
| 2.   | You export the master data (infotypes) and the payroll results to the third-party system. | With the Toolbox  
  - Set up the interface for the export  
  - Run the data export | The master data and payroll results from the SAP System are in the third-party system. |
| 3.   | Start the reporting programs in the third-party system. | The reporting results are available in the third-party system. |  |
Example 2: Export Master Data and Payroll Results to Third-Party System
Example 3: Gross Payroll in SAP System, Net Payroll in Third-Party System

Task

You want to use master data and payroll results (gross) from the SAP System as the basis for further payroll in a third-party system. You also want to transfer wage types (net) from the third-party system to the SAP System.

In the SAP System, you require information on the net wage types if you

- Run posting to Accounting with the Human Resources component (HR)
- Print remuneration statements or checks in the SAP System
- Start programs for reporting in the SAP System
- Collect all wage type information in the payroll result for the SAP System

Prerequisites

You use the following application components in your enterprise:

- Personnel Administration (PA-PA)
- Payroll (PY)

You have set up gross payroll in the SAP System.

Method

<table>
<thead>
<tr>
<th>Step</th>
<th>in the SAP System</th>
<th>In the Third-Party System</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>You run payroll (gross) in the SAP System.</td>
<td>The payroll results (gross) are available after a successful payroll run.</td>
</tr>
</tbody>
</table>
| 2.   | You export the master data (infotypes) and the payroll results (gross) to the third-party system. | With the Toolbox  
  - Set up the interface for the export  
  - Run the data export | The master data and payroll results from the SAP System are in the third-party system. |
| 3.   | Start payroll (net) in the third-party system. | | The payroll results (net) are available after a successful payroll run. |
Example 3: Gross Payroll in SAP System, Net Payroll in Third-Party System

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.</td>
<td>You import the payroll wage types (net) from the third-party system to the SAP System.</td>
</tr>
<tr>
<td></td>
<td>With the Toolbox</td>
</tr>
<tr>
<td></td>
<td>• Import the wage types from the third-party system to the SAP System</td>
</tr>
<tr>
<td>5.</td>
<td>Start payroll in the SAP System to transfer the payroll wage types (net) to the payroll results.</td>
</tr>
<tr>
<td></td>
<td>In the SAP System, the wage type information is integrated with the payroll results.</td>
</tr>
</tbody>
</table>
Setting Up the Interface for Export with the Toolbox

Purpose
You use this process to
• Set up the interface for exporting with the Toolbox
• Export the selected data to the third-party system using the Interface Toolbox.

Prerequisites
You use the following application components in your enterprise:
• Personnel Administration (PA-PA)
• Time Management (PT)
• Payroll (PY)

Process flow
The process is split into several steps:
2. You use the Toolbox to create an interface format [Seite 841]. In this step, you select the data and convert [Seite 861] the data to be exported.

   The interface format includes the following functions:
   • Create objects
   • Delete objects
   • Data definition for cluster objects
   • Table entries
   • Convert field objects
   • Restrictions for field objects
   • Attributes

3. You determine which data is only to be exported if it has changed.

   You need only perform this step if only changed data is to be exported.

   You use the change validation functions [Seite 879] to determine the data for the export. These functions include:
   • Create objects
   • Delimit objects
Validating single fields
Key fields
Relations
Wage types

3. You use the data entered in the interface format and in change validation to generate the export program [Seite 939].

You use the functions in the file layout [Seite 954] to set up the required file format for the data to be exported. These functions include:

- Create
- Delete
- Move
- Insert
- Attributes
- Blocks
- Structures
- Fields

4. You use the specifications for the file layout to generate the conversion program [Seite 981].

Result

You have set up an interface for the export. You can start the generated export program to run the data export and convert the data to the required file format.
Data Export with the Toolbox

Purpose
You use this process to retrieve data from the Human Resources application components (HR) for Payroll or for the payroll reporting programs for use in a third-party system.

Prerequisites
You use the following application components in your enterprise:

- Personnel Administration (PA-PA)
- Time Management (PT)
- Payroll (PY)

You have used the Interface Toolbox to set up an interface for the export (see application example 1 [Seite 833]) or you are using an interface from the standard system.

Process flow
The process is split into several steps:

1. With the Toolbox, start the export program [Seite 942].
2. You use the Toolbox to download the export files from the TemSe file to your PC or to an application server (Downloading the Export Files [Seite 953]).
3. If the system administrator for this system is in agreement, you can transfer the data to the third-party system.

Result
The third-party system contains data from the SAP System. You can use this data for Payroll or for the payroll evaluation programs.
Interface Format

Definition

The interface format contains the objects that you want to export from the Human Resources application component (HR) to a third-party system.

Use

The interface format is the basis for data export with the Interface Toolbox. You use the interface format to determine which HR data you want to select, and also how this selection should take place. When you define an interface format, you can access all employee data for the following application components:

- Personnel Administration (PA-PA)
- Time Management (PT)
- Payroll (PY)

Using your defined interface format as a basis, the Interface Toolbox will ultimately generate a program using the Advanced Business Application Programming language (ABAP [Extern]). You use this program to export the data. The system processes the data quickly and effectively during the export.

Structure

The interface format is a hierarchical sequence of objects.

Objects and their hierarchy

<table>
<thead>
<tr>
<th>Object</th>
<th>Hierarchy classification</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database objects [Seite 845]</td>
<td>1</td>
<td>MDTA for HR master data PCL2 for payroll</td>
</tr>
<tr>
<td>Cluster objects [Seite 847]</td>
<td>2</td>
<td>RX, RD, ... for payroll results B2 for time evaluation results</td>
</tr>
<tr>
<td>Table objects [Seite 849]</td>
<td>3</td>
<td>WPBP for work center/basic pay, P0002 for personal data</td>
</tr>
<tr>
<td>Field objects [Seite 851]</td>
<td>4</td>
<td>PERSK for employee group ANZHL for number</td>
</tr>
</tbody>
</table>

Task

To save the personnel number data, the interface format uses the objects in the Human Resources component (HR). You use the interface format to select a data subset that meets your requirements.
Interface Format

You can choose to select only the infotypes that you require for processing in a third-party system.

You can also select particular fields from the fields in an infotype.

The interface format and objects exactly match the definition of the data to be exported later with the export program. For performance reasons, the set of export data should be arranged in the best possible way.

**Characteristic**

Each object in the Interface Toolbox has specific characteristics. The characteristics determine how the object is processed and are assigned as follows:

- **Entered explicitly by the user**

  You assign the *Conversion* characteristic to a field object.

- **Implicitly by the Interface Toolbox**

  The Interface Toolbox automatically assigns the *Length* characteristic to the field object.

- **By the SAP System**

  The SAP System assigns the *Permissibility per infotype* characteristic to the field object.
Create Objects

Use

The Create function is permitted for all objects.

- Database objects [Seite 845]
- Cluster objects [Seite 847]
- Table objects [Seite 849]
- Field objects [Seite 851]

You use the function to create an object in the tree structure and the accompanying characteristics.

Different dialogs are used depending on the object, and you must enter information for the object to be created.

To use the Create function efficiently and to create the data consistently, you must always create the parts of the objects that are subordinate in the hierarchy.

You want to create a database object with the type Master Data (MDTA). To do this, select the required infotypes.

You also want to create a database object with the type Export-Import File (PCL2). To do this, you must select the required cluster object (for example, RX) and then select the required objects from the table objects belonging to the cluster (for example, WPBP).

The field object is an exception. If you create a table object, the system will automatically transfer all assigned field objects to the interface format.

Activities

You create an interface format [Seite 852].
Database Object

Definition
Subset of tables from a database.

You can use the Interface Toolbox to select the following database objects:

- Set of all infotypes (MDTA) with the type *Master Data*
- Payroll and Time Management data (PCL2) with the type *Import/Export file*

Use
You use the database object to create an interface format. When you create an interface format, note the following:

- **Database objects with the type Master Data (MDTA)** are followed by table objects. Infotypes belong to the table objects.
  
  If you create a database object with this type, you can assign required infotypes for the subsequent export.
  
  The table object (infotype) automatically includes all field objects belonging to the relevant infotype.

- **If database objects have the type Import/Export File (PCL2),** then the subordinate hierarchy level consists of cluster objects.

  When you create a database object with this characteristic, you must enter the name of the database table on which the interface format is based (for example, PCL2). The Interface Toolbox will then check whether the specified database table exists in the SAP System.

  You must also maintain the following objects which are lower in the hierarchy:
  - Cluster object
  - Table object

  The table object automatically includes all field objects belonging to the table.

  You can also create an additional database object at a later point.

You then run

- The dialog for a table object for master data
- The dialog for a cluster object for an import/export file
Database Object
Cluster Object

Definition

Each database object, for example, PCL1 or PCL2, with the type Import/Export file consists of related areas. These areas are known as clusters, for example, RX, RD. Cluster objects are dependent on the superordinate database object.

You can select the following cluster objects for database object PCL2:
- Cluster RD
- Cluster RX
- Cluster B2

If the database object has the type Master Data, then there is no cluster object.

Use

If you assign a database object with the type Import/Export file to the interface format, you must select the cluster in which the payroll or time evaluation data is found.

When the interface format is processing cluster data, it uses the existing import macros [Extem] in the SAP System. If you have changed the table objects for the data import in the import macro (for example, if you have deleted or inserted a table object), these changes are automatically transferred to the Interface Toolbox.

The Toolbox checks that the import macro is actually reading the data from the superordinate database object and the specified cluster.

The system checks that the data definition include [Seite 876] and the import macro are syntactically correct.

If you create a new cluster object or change the characteristics of an existing cluster object, you must enter the following information in the system:

- Name of the cluster (for example, B2)
- Name of the data definition include (for example, RPC2RDD0)
  The data definition include contains the definition of the data defined by the import macro.
- Import macro (for example, RP-IMP-C2-RD)
  The import macro determines the set of all possible subsequent table objects.

You then run the dialog for the table objects.
Cluster Object
Table Object

Definition
Table from Human Resources (HR).
The system differentiates between the following types:

- Section of a cluster object
  
  The table object, for example, WPBP, is a section of a cluster object, for example, RX, which belongs in turn to the database object, for example, PCL2.

- Infotype
  
  The table object, for example, P0002, is an infotype whose superordinate database object (MDTA) is the set of all infotypes.

Characteristic
The only available characteristics for the table object are those automatically assigned by the SAP System.

Characteristics that you have assigned using the Table Entries function are an exception. For more information, see Table Entries [Seite 859].

The system derives the characteristics from the data definition include (for example, RPC2RDD0) for the superordinate cluster object (for example, RD).

For more information, see the section on data definition of cluster data with the data definition include [Seite 876].

For table objects with the Set of All Infotypes as the superordinate database object (MDTA), the system derives the characteristics from the ABAP Dictionary (DDIC) [Extern].

Use
If you assign a database object with the type Import/Export file to the interface format, you must select the cluster containing the payroll or time evaluation data.

When you create a table object, the system displays a list of all internal tables and field strings. There following types of lists are available:

- List of all internal tables or field strings, if the table object belongs to a cluster object.
Table Object

- List of all infotypes, if the table object belongs to a database object with the type *Master Data*.

From this list, you can select the table objects for data export. The Interface Toolbox automatically inserts all accompanying field objects for the selected table object.
Field Object

Definition
The field object, for example, BUKRS for company code, is a field in the superordinate table object, for example, the Organizational Assignment infotype (P0001). The system first assigns characteristics to the field object based on the ABAP Dictionary [Extern]. You can change these later by converting the field object.

Characteristic
- Type (for example, CHAR)
- Length (for example, 4)
- Content (for example, 0001)

Use
Each table object contains a particular number of field objects. A list of all fields belonging to the corresponding table object is displayed. The Interface Toolbox creates the list using the structure assigned to the table object from the ABAP Dictionary. From this list you can select all the field objects whose data you want to export.
Creating an Interface Format

Use
You want to create an interface format with the name Z000. The interface format Z000 should contain database objects:

- Personal data (P0002):
- Basic pay (P0008)

You want to use all field objects from both database objects.

Procedure
1. Choose the Configuration tab index.
2. In the Object to be processed group box, choose Interface Format.
3. In the Interface format field, enter the name of your new interface format Z000.
4. Choose Create.
   You access the Create Interface Format dialog box.
5. In the Country grouping field, enter the country indicator and, in the Description of new interface format field, enter a text.
   You access the Create database object dialog box.
6. To create a database object with the type Master Data, choose the Master Data.

To create an interface format with the type Import/Export file, you should be familiar with the import macro for cluster data [Extern] and cluster data definition using a data definition include [Seite 876].

You access the Create master data dialog box.
7. Select the Personal Data (P0002) and Basic Pay (P0008) infotypes.
   The Export program dialog box is displayed.
8. Enter data as required.
If you choose *Suggest values*, the system proposes names for the export program and includes.

9. Choose *Continue*.

10. Choose *Edit → Expand*.
    The system displays all levels of the object tree with the individual field objects for the infotypes.

11. Save your entries.
    You access the *Create object catalog entry* dialog box.

12. Enter the development class and choose *Save*.

**Result**

You have created an interface format with the name **Z000**.

You can use the individual interface format functions to edit the generated interface format. For example, you can insert a field object in an interface format [Seite 854].
Inserting a Field Object

Use
You can use the Create function to insert field objects in a table object and consequently, alter the sequence of the field objects within a table object. The system inserts the selected field objects after the current cursor position.

Prerequisites
You have created an interface format.

Procedure
1. Choose the Configuration tab index.
2. In the Object to be processed group box, choose Interface Format.
3. In the Interface format field, enter the name of your interface format.
4. Choose Change.
   The system displays the tree structure.
5. Choose Edit \( \rightarrow \) Expand.
   The system displays all table objects with the accompanying field objects.
6. In the selected table object, position your cursor on the field object after which you want to insert one or more field objects.
7. Choose Create.
   You access the Add Fields from <name> dialog box.
8. Select the field object(s) you want to add to the table object.
   The system inserts the selected field objects after the current cursor position.
   If you select a field object from the list that is already assigned to the relevant table object, then this field object will be ignored and not transferred.
9. Save your entries.

Result
You have added one or more field objects to the table object.
Delete Objects

Use

The *Delete* function is permitted for all objects.

- Database objects [Seite 845]
- Cluster objects [Seite 847]
- Table objects [Seite 849]
- Field objects [Seite 851]

You use the function to remove an object from the tree structure.

If you delete an object from the tree structure, you also remove all objects below it in the hierarchy.

You also want to create a database object with the type *Export-Import File (PCL2)*. The accompanying cluster objects, table objects, and field objects are also deleted.

Integration

If you delete objects from the tree structure of the Interface Toolbox, the *change validation* [Seite 879] objects derived from these objects will also be deleted.

This means that the relationship between the object in the interface format and in *change validation* is always *consistent*.

For example, if you delete the field object (LGART) from the table object (RT), this field object will also be deleted from the change validation tree structure.

Activities

*Delete an object* [Seite 856].
Deleting Objects

Prerequisites

You have created an interface format.
You are in the tree structure [Seite 854] and all table objects are displayed with all field objects.

Procedure

1. Select the objects to be deleted using Select.

   When you select an object, the Interface Toolbox includes all dependent objects in the object hierarchy. This means that all objects subordinate to the object to be deleted will also be selected.

2. Choose Delete.
   
   The system deletes all selected objects including those subordinate to the object to be deleted.

3. Save your entries.

Result

You have deleted objects from the tree structure.
Data Definition for Cluster Objects

Use

The Data Definition function is only valid for cluster objects [Seite 847].

This function allows you to change the name of a data definition include [Seite 876] for a cluster object.

If you create a new database object or cluster object for the interface format, the Interface Toolbox requires the following information:

- Name of the cluster
- Name of the data definition include
- Name of import macro

If you change the name of the data definition include you should ensure that the new data definition include contains at least all the data definitions from the old include.

Activities

Either change the name of a data definition include [Seite 858] or display the include.
Changing or Displaying the Data Definition for a Cluster Object

Prerequisites

You have created an interface format.

You are in the tree structure [Seite 854] and all table objects are displayed with all field objects.

Procedure

1. Position the cursor on the required cluster object.
2. Choose Data definition.
   
   You access the Data Definition for DB <name>, Cluster <name> dialog box.
3. You can now change the name of the data definition include or display the include.
   
   The dialog box also gives you an overview of the assignment of internal table names or field string names to the corresponding structures in the data dictionary.
4. If you have changed the name of the data definition include, choose Save.

Result

You have changed the name of your data definition include and you have displayed an overview of the assignments to cluster objects.
Table Entries

Use

The Table entries function only applies to table objects [Seite 849].

WPBP (Work center/Basic pay)  
*Basic pay* infotype (P0008)

This function allows you to use the Interface Toolbox to select records for data export from the input data stream. You can specify whether you want to export all table entries or just a selection of entries.

Activities

Select table entries [Seite 860] for a table object.
Selecting Table Entries

Prerequisites
You have created an interface format.
You are in the tree structure [Seite 854] and all table objects are displayed with all field objects.

Procedure
1. Place the cursor on the selected table object.
2. Choose Table entries.
   You access the Table entries for <name> dialog box.
3. Choose an entry for
   a. For an infotype, choose
      – All records valid at the start date of the current period
      – All records valid at the end date of the current period
      – All records valid on at least one day in the current period
      – All existing records, including those outside of the current period
   b. A cluster
      – First entry
      – Last entry
      – All entries in the current period
      – All entries
4. Save your entries.

Result
The result of this selection is only apparent after the data export, for example, in the export program log, or directly in the output file.
Conversion for Field Objects

Use

The Conversion function only applies to field objects [Seite 851].

The Interface Toolbox allows you to modify the export file to meet the requirements of the third-party system, as well as allowing you to transfer the data in the SAP System to the third-party system. The conversion then modifies the data.

During the conversion, the system replaces the old content (value) of the object with the new content (value).

- The Gender Key field object (P0002-GESCH) has the content (value) 2, which should be replaced by the content (value) 1 during the export.
- The Form of Address Key field object (P0002-ANRED) has the content (value) 1, which should be replaced by a text (for example, Dear Sir).
- The names of the wage types in the SAP System (for example, /101) can be replaced by the names of the wage types used in the third-party system (for example, GROSS).

Features

The system differentiates between three conversion types for field objects:

- Direct value [Seite 862]
- Table value [Seite 865]
- User exit [Seite 868]

The Toolbox also includes additional conversion options in the file layout [Seite 954]. You can use these options in addition to or instead of the conversion options in the interface format.

Activities

Select the conversion for a field object [Seite 870].
Constant Conversion Type

Use

The Constant conversion type causes the Interface Toolbox to replace the old value of a field object by a new value during the data export. You can enter the necessary default values for the conversion of the field objects in the <name> (old) and <name>(new) fields of the Direct Value for <name> dialog box.

You want to replace the old value of the ANSSA field object, which is contained in the Addresses infotype (P0006), with a new value.

Enter the following in the Constant for “Address Record Type” dialog box.

<table>
<thead>
<tr>
<th>Field: ANSSA (old)</th>
<th>Field: ANSSA (new)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Main address</td>
</tr>
<tr>
<td>2</td>
<td>Temporary address</td>
</tr>
<tr>
<td>*</td>
<td>Holiday address</td>
</tr>
</tbody>
</table>

Features

Replace Constant Generically

Use the * (asterisk) character to replace values generically. In your selected field object, enter a * (asterisk) in the... (old) field as the first and only character. Enter the new constant in the ... (new) field.

If, when processing the data records, the Toolbox finds the character * (asterisk) for generic replacement, the system replaces all values without a suitable entry in the ...(old) field with the value from the ...(new) field for the generic lines.

See also:

Example: Replacing a Constant Generically [Seite 864]

Length of the Field Object for the Constant Conversion Type

You can use the Length function to redefine the field length of a field object. Normally the Toolbox uses the length in the ABAP dictionary as the length of the field object. The new field length can be either longer than, equal to, or shorter than the length in the ABAP dictionary.

Reference for the Constant Conversion Type

You can use the Reference function to refer to an existing, suitable conversion. You can define a reference to an existing conversion program without creating a new conversion program. If you modify the fields in the Constant Value for <name> dialog box then the Toolbox will also integrate these changes in the referenced fields.
If suitable references for the field object to be converted already exist in the SAP System, then they will be shown in the Reference Conversion Type dialog box and they can be used again.

Your payroll result contains the table objects A and B. The LGART field object is contained in table A and table B.

You define the constant conversion type for the LGART field object from table object A.

You only define one reference from the LGART field object in table object B to the LGART field object in table A.

If you modify the Constant conversion type in one of the two fields (A-LGART, B-LGART), then the Toolbox will automatically integrate these changes in the referenced fields.

**Transfer of Entries for Conversion**

Once you have made all the entries for the conversion of a field object, choose *Transfer.*
Example: Replacing a Constant Generically

Purpose

You want to replace the selected values of the KOSTL field object (cost center) with new values during the data export.

Process flow

Perform the conversion of direct values in two steps:

1. Enter the following values in the KOSTL (old) and KOSTL (new) fields in the Constant for Cost Center dialog box.

<table>
<thead>
<tr>
<th>Field: KOSTL (old)</th>
<th>Field: KOSTL (new)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1111</td>
<td>Z1111</td>
</tr>
<tr>
<td>2222</td>
<td>Z222</td>
</tr>
<tr>
<td>*</td>
<td>ZZZZ</td>
</tr>
</tbody>
</table>

2. When the Interface Toolbox exports data, selected values for the Cost Center (KOSTL) field are contained in the input data stream records. The system replaces these selected input values for the Old cost center (KOSTL (old)) field by the values you have entered in the New cost center (KOSTL (new)) field.

<table>
<thead>
<tr>
<th>Values for the KOSTL field in the input data stream for the export</th>
<th>Content of the KOSTL field after the data export</th>
</tr>
</thead>
<tbody>
<tr>
<td>1111</td>
<td>Z1111</td>
</tr>
<tr>
<td>2222</td>
<td>Z222</td>
</tr>
<tr>
<td>3333</td>
<td>ZZZZZ</td>
</tr>
</tbody>
</table>
Table Value Conversion Type

Use
The *Table Value* conversion type operates in a similar way to the *Constant* conversion type where the Interface Toolbox replaces the old value of the field object with a new value during the export process. However, it differs from the constant conversion type because the new value contained in a field, for example, TITEL for title, comes from a database table, for example, T535N for name supplements. The new value is a value stored in the SAP System and is not determined by a constant.

To use the table value conversion type, you need to know the table names of the required database tables (for example, table T535N for name supplements) and fields (for example, the TITEL field for title).

Key Fields for the Table Value Conversion Type
The content of the key fields defines the access path for the selected field, whose content is to be used as the replacement.

If you enter the name of the database table and field name and choose *Enter*, then the Toolbox automatically enters the default values from the SAP System in the key fields for this table.

The access path for the key fields is a default value in the SAP System. Check and, if necessary, correct this access path so that the correct field object can be used for the table value conversion.

In addition, the SAP System allows you to use system fields that are available in the *System Fields in ABAP Programs (SYST)* table. These are the fields that begin with *SY-* for example, SY-LANGU for the language key in the SAP logon procedure, and SY-DATUM for the current date in the system: You can use these system fields to define the access path to a field object.
Database Table

Database tables used when converting table values are all tables in the SAP System that exist in the ABAP Dictionary (DDIC). This does not just include the database objects used by the Interface Toolbox for the interface format.
Example: Replacing a Table Value

You can use the *table value* conversion type is to replace values that represent a code with values that represent a text and which already exist in a field in the database table.

You want to replace the value in the *Form of Address (ANRED)* field object in the *Personal Data (P0002)* infotype with the value from the *Form of Address text (ATEXT)* in the *Forms of Address (T522T)* database table.

You are in *Conversion → Table value* for the *Form of Address (ANRED)* field object from the *Personal Data (P0002)* table object.

Enter **T522T** in the *Table* field and **ATEXT** in the *Field Name* field in the *Table Values for “Form of Address Key”* dialog box. When you choose *Enter*, the key fields P0002-SPRSL and P002-ANRED are displayed, provided you have selected both fields for the export.

You end the example with the *Transfer* function.
User Exit Conversion Type

Use

If the functions offered by the *Constant* and *Table Value* conversion types do not meet your requirements, the Interface Toolbox allows you to use your own, user-defined conversion program. The *User Exit* conversion type creates the link to the customer conversion program.

Prerequisites

The following conditions must be met before you can define the field object conversion for the *User Exit* conversion type in the interface format:

- You have generated a user-defined program for the conversion of a field object.
  
  The name of the user-defined program matches the program name in the *Program* field.

- The routine specified in the *Form Routine* field is specified in your user-defined program.
  
  The SAP System checks that the specified form routine exists in your user program.

- The Interface Toolbox provides you with a default value for the length of the field object to be converted. You can modify this length to suit your requirements at any time.

The *User Exit* conversion is carried out for each table line in the selected table object (for example, WPBP) in the input data stream. Define the form routine in your user-defined program with two parameters:

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter 1</td>
<td>Current line of the table object in which the field object is contained (input parameter)</td>
</tr>
<tr>
<td>Parameter 2</td>
<td>Result of conversion (return value)</td>
</tr>
</tbody>
</table>

  The return value is interpreted as a character field type.

See also:

*Example: User Exit with Form Routine [Seite 869]*
Example: User Exit with Form Routine

Basic Situation

You use a customer *User Exit* with the program name ZUSEREXI and the form routine with the name KONVERT.

You wish to convert the value in the *Title* (TITEL) field object in the *Personal Data* infotype (P0002) to the text from the *Title* (TTOUT) field in the *Name Supplements* (T535N) table. The title ING (for engineer) should not be used.

Procedure

The customer program for the user exit (including the form routine) could be as follows:

```plaintext
FORM KONVERT TITEL USING VALUE(P0002) STRUCTURE P0002
   CHANGING VALUE(RESULT).
   IF P0002-TITEL <> `ING.`.
       SELECT SINGLE * FROM T535N
           WHERE ART = `T`
           AND TITEL = P0002-TITEL.
       IF SY-SUBRC = 0.
           RESULT = T535N-TTOUT.
       ELSE.
           CLEAR RESULT.
       ENDIF.
   ENDIF.
ENDFORM.
```
Selecting the Conversion for A Field Object

Prerequisites
You have created an interface format.
You are in the tree structure [Seite 854] and all table objects are displayed with all field objects.

Procedure
5. Place the cursor on the selected table object.
6. Choose Table entries.
   You access the Table entries for <name> dialog box.
7. Place the cursor on the selected field object and choose Conversion.
   The Conversion type dialog box appears.
8. Choose one of the following conversion types:
   – Constant
     You access the Direct Value for <name> dialog box.
     a) Enter data as required.
     b) Choose Transfer.
   – Table value
     You access the Table Value for <name> dialog box.
     a) Enter data as required.
     b) Choose Transfer.
   – User Exit
     You access the User Exit for <name> dialog box.
     a) Enter the required data.
     b) Choose Continue.
9. Save your entries.

Result
You have assigned a conversion type to the selected field object.
Restrictions for Field Objects

Use

The Restrictions function only applies to field objects [Seite 851].

The Address record type field (ANSSA) in the Addresses infotype (P0006).

The Pay scale type field (TAFAR) from table WPBP (Work center/Basic pay).

You can use this function to select records from the input data stream to be exported by the Interface Toolbox. The selection criterion is the field object with the predetermined restrictions. You can use your default values to define the restrictions referring to the content of the selected field object. Only the data records whose field object matches that in the Restrictions function will be exported from the input data stream.

You only want to select the main address from the ANSSA (address type) field in the Addresses infotype (P0006). You do not need the other address types.

To do this, enter 1 for address in the Restrictions for “P0006-ANSSA” dialog box and copy the entry.

The Interface Toolbox only exports the input records for the data stream that have 1 (main address) in the ANSSA field. Data records with other addresses are not exported.

Restriction types for field objects

- Special restrictions for wage types

  This type of restriction is only valid for wage types from wage type tables.

  For more information on wage types, see Wage Type Processing in the Interface Toolbox [Seite 910].

- General restrictions
This type of restriction is valid for field objects with the type CHAR and NUM.

**Activities**

Select the restrictions for a field object [Seite 874].
Creating Restrictions for a Field Object

Prerequisites
You have created an interface format.
You are in the tree structure [Seite 854] and all table objects are displayed with all field objects.

Procedure
1. Place the cursor on the selected field object.
2. Choose Restrictions.
   You access the Restrictions for <name> dialog box.
3. If you have already defined restrictions for the field object and want to insert more restrictions, choose New line.
4. Enter the restrictions.
   Several entries for a field object are linked implicitly with the logical operation OR.
5. Choose Transfer.
6. Save your entries.

Result
You have created a restriction for the selected field object.
Attributes in the Interface Format

Use

You use the Attributes function to define the processing parameters for the interface format. These are used by system when the data is exported. They determine how the interface format will be used in the SAP System.

Features

The attributes can be changed during or after the processing of the interface format.

For the process control:

- Interface without payroll
- Check control record
- No retroactive accounting
- Valuate wage types indirectly
- Layout conversion directly after export
- New change validation [Seite 883]

For storing the interface results:

- Do not save to cluster IF
- Save current results only

Activities

You use the Attributes function to assign the attributes at any time during the editing of the interface format.

You must assign the attributes to the interface format before you generate the export program.

If you assign the attributes to the interface format later, you must regenerate the export program.
Data Definition Include

Definition
The data definition include contains the definitions of the internal tables and field strings used in the import macro [Extern]. Like the import macro, it is a further characteristic of the cluster object [Seite 847]. There is just one include for each cluster object, and it contains the definition of the data.

Use
The Interface Toolbox must recognize the structure of the cluster to be able to read cluster objects in the SAP System. The data definition include contains this structure definition. The Toolbox uses the data definition include to read the data from a cluster.

Activities
The Interface Toolbox enables you to generate a data definition include automatically [Seite 877] using the specifications for this program.
Creating an Include Automatically or Using an Existing Include

Procedure

1. Choose the Configuration tab index.
2. In the Object to be processed group box, choose Interface Format.
3. In the Interface format field, enter the name of your new interface format.
4. Choose Create.

You access the Create Interface Format dialog box.
5. In the Country grouping field, enter the country indicator and, in the Description of new interface format field, enter a text.

You access the Create database object dialog box.
6. Choose Payroll results/Time data.

You access the Create Payroll Results/Time Data dialog box.
7. In the File Data data group, enter the following fields:

<table>
<thead>
<tr>
<th>Import/Export Table</th>
<th>Name of import/export file (for example, PCL2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name of the cluster</td>
<td>Name of the cluster (for example, RU)</td>
</tr>
</tbody>
</table>

8. Choose Continue.

The system suggests values for the automatic generation of data definition include.

For example, RP-IMP-C2-RD is displayed in the Name of import macro field.
For example, RPCALCU0 is displayed in the Name of program field.
9. Choose one of the following steps:
   - **Create a data definition include automatically**
     
     a) So that the system will generate the data definition include, enter a new name for the include (for example, ZPC2RU00) in the Include to be created field of the Data definition include group. If necessary, change the names of the import macro and program.
Creating an Include Automatically or Using an Existing Include

The program name for the cluster containing payroll results (Rx) is the program name of the payroll driver that you use in Payroll.

- RPCALCx0; where x is the country indicator, for example, RPCALCD0
- HxxCALC0; where xx is the country indicator, for example, AR for Argentina

The program name for the time evaluation cluster B2 is the international name RPTIME00 (Time Evaluation).

b) To generate the include, choose Continue.

You access the Create Object Catalog dialog box.

c) In the subsequent dialog, enter the corresponding object catalog entry.

You access the Add Tables/Field Strings dialog box.

- Use an existing include

You have already created a data definition include for another interface format for the same cluster object, and want to use this include.

a) To use this data definition include, choose Existing include in the Data definition include data group. In the Name of include field, enter the name.

b) Choose Continue.

The Insert Tables/Field Strings dialog box is displayed.

10. Select the required objects.

11. Choose Continue.

12. Save your entries.

Result

You have created your data definition include automatically or used an existing data definition include.
Change Validation

Use

Most of the data exported to a third-party system using the Interface Toolbox does not change in every payroll period [Extern]. For example, an employee’s personal details (name, first name, personnel number, and so on) rarely differ from one period to the next.

If the Interface Toolbox transfers all data for a payroll period for every data export, the following disadvantages arise:

- Increased redundancy of exported data (larger volume of data)
- Increased transfer load during the data export
- Increased processing

  The receiver must process all transferred information as it is not possible to determine in advance whether or not the information has changed during the payroll periods.

- High probability of errors made by the Interface Toolbox during data export and during the processing of the information by the receiver

It is therefore a good idea to only export data that has changed since the last data export. The third-party system can use the data that has not changed since the last data export again since this data already meets your requirements. Only changes to the data must be transferred to the third-party system for further processing.

The Change Validation function allows you to avoid exporting unchanged data.

Prerequisites

You have created an Interface Format and can only call the objects assigned to the Interface Format for change validation. The objects for change validation include:

- Table objects [Seite 849] (internal tables, field strings, and infotypes)
- Field objects [Seite 851]

For more information on the interface format and objects, see Interface Format [Seite 841].
Change Validation

Features
To deal with this problem, the Interface Toolbox has a *change validation* function with a wide range of functions.

- Create objects [Seite 890]
- Delimit objects [Seite 892]
- Single field validation [Seite 895]
- Key fields [Seite 898]
- Relations [Seite 902]
- Wage types [Seite 905]
- User-defined change validation [Seite 906]

There are special rules for the change validation of wage types from the corresponding wage type tables. For more information, see *Wage Type Processing in the Interface Toolbox* [Seite 910].

See also:
*Comparison Period for Change Validation* [Seite 881]
Comparison Period for Change Validation

Definition
The comparison period is a payroll period used in change validation to determine which data has changed since the last export.

Use
The Change Validation function allows the Interface Toolbox to determine which data has changed from one period to another. This data is then transferred to the export file and this determines the volume of data to be exported.

If retroactive accounting is first excluded from individual payroll periods and from multiple exports, then it is easy to determine which data in a payroll period will be used for comparison. A comparison is always made between the data for the current export and the data for the last export, since it identifies the changes that have occurred in the data to be exported.

Data from the March payroll period is compared with the data from the February payroll period when the data is exported. Differences in the March payroll period when compared to the February payroll period are exported.

If data is exported for an employee for the first time, there is no comparison period for payroll. If this is the case, the system exports the data for the existing payroll period.

The determination of payroll periods for retroactive accounting and multiple exports is explained in the following sections.

See also:
Setting the Comparison Period for Multiple Export [Seite 882]
Setting the Comparison Period for Retroactive Accounting [Seite 883]
Setting the Comparison Period for Multiple Export

Use
If you run the export program several times for the same payroll period, then this is known as multiple export. Multiple export can be split into two types:

- Repeat
- Additional export

To identify the changes in the dataset for multiple export, the system must know the payroll period. When you define the payroll period, you should note the following:

The selection screen for the export program [Seite 942] contains a Repeat run parameter in the Export options group box.

- **Select the checkbox for a repeat run.**
  
  The last data export for this payroll period did not take place for the export program.

  The change validation function uses the last but one data export from the selected payroll period to compare the data. An export must have taken place previously, otherwise the comparison will be made with the most recent comparison period.

- **Do not select the checkbox for an additional export.**
  
  If another export run takes place during the selected payroll period, the export program assumes that the third-party system has received the data from the last export.

  The change validation function uses the last data export from the selected payroll period to compare the data. An export must have taken place previously, otherwise the most recent period will be used for the comparison.

See also:

Setting the Comparison Period for Retroactive Accounting [Seite 883]
Setting the Comparison Period for Retroactive Accounting

Use

There are two ways of setting the comparison period for retroactive accounting:

- **First method**
  
  The third-party system receives the data from the original period as well as from the retroactive accounting period.
  
  - If the *New change validation* attribute is flagged, the Toolbox uses the [new variant for the first method](#).
  
  - If the *New change validation* attribute is not flagged, the Toolbox uses the [old variant for the first method](#).

- **Second method**
  
  The third-party system only receives data from the original period.
Determination of Comparison Period Using First Method if New change validation Attribute Is Flagged

Prerequisites
The Toolbox uses this variant if you
1. Have flagged the New change validation attribute [Seite 875] in the interface format
2. Have not flagged the Only original periods export option for the export.
   It is assumed that the third-party system has received the data from the retroactive accounting periods as well as from the original periods.

Use
We recommend that you use this variant because the disadvantages of the old variant [Seite 886] do not apply. The Toolbox now uses the new variant as the standard for a new interface format.

Advantages
- Each change is only sent once per payroll period. If subsequent exports follow the first export, in contrast to the old variant, these changes are not sent.
- The Toolbox also sends retroactive changes in all cases.

For the first export after a change that covers several payroll periods, the changes are sent for each payroll period affected by the change.

In retroactive accounting for payroll, the preceding payroll periods are defined using the rule that the last original period is always used as the comparison period.

Rule
The system always determines the most recent payroll period in which the for-period view [Extern] matches the payroll period. If this does not exist, the last exported payroll period is used. The payroll period can be a previous retroactive period for the current export if it exists or the last payroll period of the past export.

These rules are described in an example.

The payroll periods listed in the table are applicable for an employee.
## Determination of Comparison Period Using First Method if New change validation Attribute Is Flagged

<table>
<thead>
<tr>
<th>Sequential no.</th>
<th>For-period</th>
<th>In-period</th>
<th>Contents field 1</th>
<th>Contents field 2</th>
<th>Preceding period</th>
<th>Contents field 1 sent</th>
<th>Contents field 2 sent</th>
<th>Preceding period</th>
<th>Contents field 1 sent</th>
<th>Contents field 2 sent</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>01 2000</td>
<td>01 2000</td>
<td>A</td>
<td>X</td>
<td>-</td>
<td>A</td>
<td>X</td>
<td>-</td>
<td>A</td>
<td>X</td>
</tr>
<tr>
<td>2</td>
<td>02 2000</td>
<td>02 2000</td>
<td>B</td>
<td>X</td>
<td>1</td>
<td>B</td>
<td>#</td>
<td>1</td>
<td>B</td>
<td>#</td>
</tr>
<tr>
<td>3</td>
<td>01 2000</td>
<td>02 2000</td>
<td>A</td>
<td>Y</td>
<td>1</td>
<td>#</td>
<td>Y</td>
<td>1</td>
<td>#</td>
<td>Y</td>
</tr>
<tr>
<td>4</td>
<td>02 2000</td>
<td>02 2000</td>
<td>B</td>
<td>Y</td>
<td>2</td>
<td>#</td>
<td>Y</td>
<td>3</td>
<td>B</td>
<td>#</td>
</tr>
</tbody>
</table>
Determination of Comparison Period Using First Method if New change validation Attribute Is Not Flagged

Prerequisites

The Toolbox uses this variant if you
1. Have not flagged the New change validation attribute [Seite 875] in the interface format
2. Have not flagged the Only original periods export option for the export.

It is assumed that the third-party system has received the data from the retroactive accounting periods as well as from the original periods.

Use

The specification of the precedent for the payroll period in change validation has been converted. For compatibility reasons, SAP supports this variant.

Disadvantages

- If a payroll period is exported several times, changes are also transferred several times.
- In certain situations, the Toolbox does not export retroactive changes.

In retroactive accounting for payroll, the preceding payroll periods are defined using the following rules:

Rule 1

For the first retroactive accounting period in payroll, the preceding period is the most recent payroll period in the in-period view [Extern] that matches the current payroll period in the for-period view [Extern]. If this payroll period does not exist, then the system does not call up a preceding period for the data comparison.

Rule 2

For the following retroactive accounting periods and the original period for payroll, the system always uses the preceding retroactive accounting periods.

These rules are described in an example.

<table>
<thead>
<tr>
<th>Sequential no.</th>
<th>For-period</th>
<th>In-period</th>
<th>Preceding period</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>00001</td>
<td>01 2000</td>
<td>01 2000</td>
<td>none</td>
<td>First export</td>
</tr>
</tbody>
</table>
### Determination of Comparison Period Using First Method if New change validation Attribute Is Not Flagged

<table>
<thead>
<tr>
<th>Week Number</th>
<th>From Date</th>
<th>To Date</th>
<th>Previous Week Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>00002</td>
<td>02 2000</td>
<td>02 2000</td>
<td>00001</td>
</tr>
<tr>
<td>00003</td>
<td>03 2000</td>
<td>03 2000</td>
<td>00002</td>
</tr>
<tr>
<td>00004</td>
<td>04 2000</td>
<td>04 2000</td>
<td>00003</td>
</tr>
<tr>
<td>00005</td>
<td>02 2000</td>
<td>05 2000</td>
<td>00002</td>
</tr>
<tr>
<td>00006</td>
<td>03 2000</td>
<td>05 2000</td>
<td>00005</td>
</tr>
<tr>
<td>00007</td>
<td>04 2000</td>
<td>05 2000</td>
<td>00006</td>
</tr>
<tr>
<td>00008</td>
<td>05 2000</td>
<td>05 2000</td>
<td>00007</td>
</tr>
</tbody>
</table>
Second Method for Setting the Comparison Period

Use

It is assumed that the third-party system has not received the data from the retroactive accounting periods. The third-party system only receives data from the original period.

In retroactive accounting for payroll, the preceding payroll periods are defined using the rule that the last original period is always used as the comparison period.

Rule

The system always uses the last original period as the comparison period.

Application and Procedure for this rule

On the selection screen for the export program [Seite 942], select the Only Original Periods radio button in the Export Options group box. The export program then uses the original payroll periods to check for changes.

Result

The retroactive periods in payroll are suppressed for the data export.

The comparison period for change validation is always an original period.

The payroll periods listed in the table are applicable for an employee.

Only the original periods should be called up for the data export. The third-party system does not contain the data from the retroactive accounting periods.

<table>
<thead>
<tr>
<th>Sequential no.</th>
<th>For-period</th>
<th>In-period</th>
<th>Preceding period</th>
<th>Period type</th>
</tr>
</thead>
<tbody>
<tr>
<td>00001</td>
<td>01 1996</td>
<td>01 1996</td>
<td>No preceding period</td>
<td>O</td>
</tr>
<tr>
<td>00002</td>
<td>02 1996</td>
<td>02 1996</td>
<td>00001</td>
<td>O</td>
</tr>
<tr>
<td>00003</td>
<td>03 1996</td>
<td>03 1996</td>
<td>00002</td>
<td>O</td>
</tr>
<tr>
<td>00004</td>
<td>04 1996</td>
<td>04 1996</td>
<td>00003</td>
<td>O</td>
</tr>
<tr>
<td>00005</td>
<td>02 1996</td>
<td>05 1996</td>
<td>No export</td>
<td>R</td>
</tr>
<tr>
<td>00006</td>
<td>03 1996</td>
<td>05 1996</td>
<td>No export</td>
<td>R</td>
</tr>
<tr>
<td>00007</td>
<td>04 1996</td>
<td>05 1996</td>
<td>No export</td>
<td>R</td>
</tr>
<tr>
<td>00008</td>
<td>05 1996</td>
<td>05 1996</td>
<td>00004</td>
<td>O</td>
</tr>
</tbody>
</table>
Legend

O  Original period
R  Retroactive accounting period
Create Objects

Use

The *Create* function for change validation only applies to table objects [Seite 849]. This function checks a table object and accompanying field objects assigned to the interface format for changes to the dataset between two exports. The system compares an object from one data export with the same object from the previous data export and checks for changes. The table object and all field objects lower in the hierarchy are included in data validation.

For example, the *Personal Data* infotype (P0002) includes all field objects that the infotype has in the selected interface format.

If you do not use any other change validation functions, the system performs change validation for the table objects using the accompanying field objects. If change validation identifies at least one change in an object, then the export program will transfer the complete table object with data to the third-party system.

Activities

Create table objects for change validation [Seite 891].
Creating Objects

Prerequisites
You have created an interface format.

Procedure
10. Choose the Configuration tab index.
11. In the Object to be processed group box, choose Interface Format.
12. In the Interface format field, enter the name of your interface format.
13. Choose Change Validation.
   The system changes to the change mode.
15. Choose Create.
   You access the Field Strings/Tables dialog box.
16. Select the table object for change validation.
17. Choose Continue.
   The system displays the tree structure.
18. Choose Edit → Expand.
   The system displays the accompanying field objects for the table object.
19. Save your entries.

Result
You have assigned selected objects in your interface format to change validation, or created objects for the change validation.
Delimit Objects

Use

You can use the Delimit function for table objects (internal tables, field strings, and infotypes).

This function flags a table object and the accompanying field objects in the payroll period to be exported as invalid.

The Delimit function cannot be used separately for an individual field object. If you create this function for a table object, the system includes all field objects belonging to this object in the delimitation.

Features

By delimiting an object, all field objects belonging to this object are flagged with the character "<". The delimitation information "<" is transferred with the respective field object length.

The key fields are exceptions because the system always exports the contents of key fields.

During the data export by the Interface Toolbox, the delimited object is transferred to the third-party system along with all flagged field objects. By looking at the flagged field object the receiver can determine whether or not the object is still valid for the relevant employee.

Activities

Activate the Delimit function for a table object.

See also:

Example: Delimiting an Infotype
Example: Delimiting an Infotype

You have activated Change Validation for the External Bank Transfers infotype (0011). Choose Delimit and define a unique key for the infotypes, for example, the fields BANKL and BANKN.

The normal change validation process is not affected. However, if the infotype record with the defined key is delimited, the Interface Toolbox only defines the values for these key fields. The delimitation character “<” is entered in all other fields.

Your employee was a member of a club, and between January 1996 and March 1996 the membership fees were paid by external bank transfer. This amount is entered in Ext.Bank Transfer (0011) infotype.

The employee ended the club membership on March 31, 1996. You must now set the validity end date for this external bank transfer to March 31, 1996 using master data maintenance.

Use the Interface Toolbox to carry out the data export for April 1996. The following field objects for the Ext. Bank Transfer (0011) infotype are included in the objects transported to the third-party system.

### External Transfers Infotype (0011)

<table>
<thead>
<tr>
<th>Field Object</th>
<th>Name</th>
<th>Field content</th>
</tr>
</thead>
<tbody>
<tr>
<td>P0011-BANKL</td>
<td>Bank key</td>
<td>672922</td>
</tr>
<tr>
<td>P0011-BANKN</td>
<td>Bank account number</td>
<td>700100</td>
</tr>
<tr>
<td>P011-BETRAG</td>
<td>Amount</td>
<td>&lt;... &lt;</td>
</tr>
<tr>
<td>P0011-LGART</td>
<td>Wage types</td>
<td>&lt;... &lt;</td>
</tr>
</tbody>
</table>

The field content "<" (delimitation) means that the Ext.Bank Transfer infotype (0011) and all relevant field objects are invalid for this employee in the export payroll period.
Delimiting Objects

Prerequisites
You have created an interface format.

Procedure
20. Choose the Configuration tab index.
21. In the Object to be processed group box, choose Interface Format.
22. In the Interface format field, enter the name of your interface format.
23. Choose Change Validation.
   The system switches to the change mode and displays the tree structure.
25. Choose Edit → Expand.
   The system displays the accompanying field objects for the table object.
26. Place the cursor on the table object.
27. Choose Delimit.
   The system delimits the selected table objects with the accompanying field objects.
28. Save your entries.

Result
You have delimited the table object and respective field objects for change validation.

You can reverse the delimitation by selecting the table object and choosing the Delimit function again.
**Single Field Validation**

**Use**

The *Single Field Validation* function only applies to table objects [Seite 849].

The *Change Validation* function usually considers the field objects in a table object (internal tables, field strings and infotypes) as a unit. The system exports the complete table object as soon as a field object in the table object has changed.

The *Single Field Validation* function allows you to export just the field objects that have changed. If the field object has not changed, the “#” character is exported.

If no field object in a table object has changed from one payroll period to the next, then the complete table object is ignored. The corresponding table object is not exported.

**Activities**

Activate single field validation [Seite 897] for a table object.

**See also:**

Example: Single Field Validation [Seite 896]
# Single Field Validation

## Example: Single Field Validation

In the **TEST** interface format, the *Work Center/Basic Pay (WPBP)* table object is defined with the Personnel Subarea (BTRTL), Personnel Area (WERKS) and Employee Subgroup Grouping for Personnel Calculation Rule (ABART) field objects. The individual field validation function is activated for the table object (WPBP). The system exports the following values for the displayed payroll results:

### Export with Single Field Validation

<table>
<thead>
<tr>
<th>Object</th>
<th>Previous payroll result</th>
<th>Current payroll result</th>
<th>Data after import</th>
</tr>
</thead>
<tbody>
<tr>
<td>WPBP-BTRTL</td>
<td>0001</td>
<td>0001</td>
<td>#####</td>
</tr>
<tr>
<td>WPBP-WERKS</td>
<td>0002</td>
<td>0003</td>
<td>0003</td>
</tr>
<tr>
<td>WPBP-ABART</td>
<td>1</td>
<td>1</td>
<td>#</td>
</tr>
</tbody>
</table>

**For Comparison:**

### Export Without Single Field Validation

<table>
<thead>
<tr>
<th>Object</th>
<th>Previous payroll result</th>
<th>Current payroll result</th>
<th>Data after import</th>
</tr>
</thead>
<tbody>
<tr>
<td>WPBP-BTRTL</td>
<td>0001</td>
<td>0001</td>
<td>0001</td>
</tr>
<tr>
<td>WPBP-WERKS</td>
<td>0002</td>
<td>0003</td>
<td>0003</td>
</tr>
<tr>
<td>WPBP-ABART</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>
Validating Single Fields

Prerequisites
1. You have created an interface format [Seite 852].
2. You have created the change validation for a table object [Seite 891].
3. The Maintain Change Validation screen appears.
   The system displays the accompanying field objects for the table object [Seite 894].

Procedure
1. Place the cursor on the table object.
2. Choose Single Field Validation.
   The system validates the single fields for the selected table object.
3. Save your entries.

Result
You have activated single field validation for a table object. In the future, only changed field objects will be exported.

You can reverse the single field validation by selecting the table object and choosing the Single Field Validation function again.
Key Fields

Use

You can only use the *Key Fields* function for *field objects* in internal tables or infotypes.

The *Key Field* function cannot be used for the *Field string* table object, since the field string only consists of one entry (for example, the *Personal Features (PERM)* field string in cluster object Rx (for example, RD, RU)).

Change validation for table objects (internal tables) can only function successfully if you specify which line of the current table is to be compared with which line in the table from the comparison period. The *Key Field* function defines those fields which clearly determine a table line as key fields for the table object. This means that one table cannot contain two lines that match in all key fields.

For each current table entry, the SAP System searches in the current payroll period for a table entry with the same key fields in the comparison period and then compares all fields.

Activities

*Define the field objects as key fields* [Seite 901]

See also:

*Example: Key Fields* [Seite 899]
Example: Key Fields

You have defined two field objects, Bank Number (BANKL) and Account Number (BANKN) as key fields in the table object containing the bank transfer amounts.

A bank transfer must exist for each account number so that change validation function can work with the key field function successfully.

<table>
<thead>
<tr>
<th>Payroll Period 01</th>
<th>Payroll Period 02</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>BANKL</td>
<td>BANKN</td>
</tr>
<tr>
<td>Key field</td>
<td>Key field</td>
</tr>
<tr>
<td>672922</td>
<td>700100</td>
</tr>
<tr>
<td></td>
<td>700101</td>
</tr>
<tr>
<td>672922</td>
<td>700102</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BANKL</th>
<th>BANKN</th>
<th>AMOUNT</th>
<th>Legend</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key field</td>
<td>Key field</td>
<td></td>
<td></td>
</tr>
<tr>
<td>672922</td>
<td>700100</td>
<td>950.00</td>
<td>Change in amount</td>
</tr>
<tr>
<td>672922</td>
<td>700101</td>
<td>&lt;...&lt;</td>
<td>If delimitation active</td>
</tr>
<tr>
<td>672922</td>
<td>700103</td>
<td>100.00</td>
<td>Only in period 02</td>
</tr>
<tr>
<td>672922</td>
<td>600500</td>
<td>500.00</td>
<td>Only in period 02</td>
</tr>
</tbody>
</table>

The Bank Number (BANKL) and Account Number (BANKN) field objects are key fields. The content of these fields is exported, not the "<" character (delimitation).
Defining Key Fields

Prerequisites
1. You have created an interface format [Seite 852].
2. You have created the change validation for a table object [Seite 891].
3. The Maintain Change Validation screen appears.
   The system displays the accompanying field objects for the table object [Seite 894].

Procedure
4. Place the cursor on the table object.
5. Choose Key Fields.
   The selected field objects in the tree structure have the key field symbol.
6. Save your entries.

Result
You have defined a key field object for change validation.

You can reverse the definition by selecting the field object and choosing the Key fields again.
Relations

Use

The Relations function only applies to field objects [Seite 851].

To use the Relations Between Field Objects function, single field validation [Seite 895] must be active for the relevant table object.

Features

The single field validation and relations are related as follows:

If single field validation is active for a table object, the system only exports fields from the table object that have changed.

There are often close relationships between individual fields in a table in the SAP System. This means that the fields are only meaningful together. For example, an employee’s personnel subarea data is only meaningful if the personnel area to which the personnel subarea is assigned is also known.

To meet this requirement, you can use the Interface Toolbox to define relations between two or more fields. If at least one field that is linked to one or more other fields by the Relations function changes, then the system exports all linked fields again.

Activities

Create relations [Seite 904] between field objects.

See also:

Example: Relations Between Field Objects [Seite 903]
Example: Relations Between Field Objects

You have already activated single field validation for the Work Center/Basic Pay (WPBP) table object.

You want to link the Personnel Area (WERKS) and Personnel Subarea (BTRTL) field objects using relations.

If the content of one of the two field objects changes from one data export to the next, the system exports both field objects again.

<table>
<thead>
<tr>
<th>Previous payroll period</th>
<th>Current payroll period</th>
<th>Export the following data</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>WPBP-BTRTL=0001</td>
<td>WPBP-BTRTL=0001</td>
<td>WPBP-BTRTL=0001</td>
<td>Export again</td>
</tr>
<tr>
<td>WPBP-WERKS=0002</td>
<td>WPBP-WERKS=0003</td>
<td>WPBP-WERKS=0003</td>
<td>Export again</td>
</tr>
<tr>
<td>WPBP-ABART=1</td>
<td>WPBP-ABART=1</td>
<td>WPBP-ABART=#</td>
<td>No change, single field validation is active</td>
</tr>
</tbody>
</table>

The system also checks field objects with no relations individually.
Creating Relations

Prerequisites
1. You have created an interface format [Seite 852].
2. You have created the change validation for a table object [Seite 891].
3. To perform this function, you must first activate Single Field Validation [Seite 895] for the table object to which the field object belongs.
4. The Maintain Change Validation screen appears.
   
   The system displays the accompanying field objects for the table object [Seite 894].

Procedure
1. Place the cursor on the selected field object.
2. Choose Relations.
   
   You access the Relations for <name> dialog box.
3. Select the field object(s) to be linked to the previously selected field object with a relation.
4. Save your entries.

Result
You have created relations for a field object in change validation.

If you choose the Relations icon in front of the name of the field object, you display a list of all field objects related to the selected field object.

To delete unwanted entries, select the entry and choose Delete.
Wage types

For information on the Wage Types function, see Wage Types in Change Validation [Seite 920].
User-Defined Change Validation

Use

You can use this function to specify that the decision of whether or not to carry out change validation will only be made when the export program runs. If you want to use this function, the Toolbox requires a user-defined program to decide whether or not to activate change validation.

Features

The Interface Toolbox makes demands on the user-defined program so that the change validation can be activated when the program runs.

Program type

The program type can have the following values:

- 1 Executable program
- S Subroutine pool

Parameters

The program must contain a form routine with only one parameter. This parameter displays the return value for the form routine. The return value determines whether or not the export value is to carry out the change validation. The following values are possible for the return value:

- Change validation not active
- Change validation active

The Change Validation function is set to active as default.

INCLUDE

If you include INCLUDE 3 from the Export Program function (interface format [Seite 841]) in the customer program, you can use current export data and the export data from the comparison period to the customer form routine to decide whether to activate change validation.

Activities

Activate the user-defined change validation [Seite 909]

See also:

Naming Conventions for Export Data [Seite 907]

Example: User-Defined Change Validation [Seite 908]
Naming Conventions for Export Data

The following naming conventions apply to the export data:

- `NEW_<table name>` for the current export data (for example, `NEW_WPBP`)
- `OLD_<table name>` for the export data from the comparison period (for example, `OLD_WPBP`)

Example: Customer Program for Change Validation

The following example shows a possible structure for your user-defined program, which will be used to decide whether or not to activate change validation when the export program runs.

```plaintext
REPORT ZPCIFP01.
INCLUDE ZPCIFRX3. "INCLUDE 3 from export program
FORM DIFFERENCE_CHECK USING SWITCH.
   SWITCH = '1'. "change validation is active
   READ TABLE NEW_WPBP INDEX 1.
   IF SY-SUBRC = 0.
      READ TABLE OLD_WPBP INDEX 1.
      IF SY-SUBRC = 0.
         IF (NEW_WPBP-MASSN <> OLD_WPBP-MASSN) AND
            (NEW_WPBP-MASSN = '05').
            SWITCH = '0'. "change validation is not active
      ENDIF.
   ENDIF.
ENDIF.
ENDFORM.

Legend

The form routine uses the SWITCH parameter, which decides whether or not the change validation is active.

The change validation function is set to active as default (SWITCH = 1). If the MASSN field in the Work Center/Basic Pay (WPBP) table for the current export data differs from that in the comparison period, and if the current personnel action (MASSN) is '05', then change validation is not active.
Activating User-Defined Change Validation

Prerequisites
1. You have created an interface format [Seite 852].
2. You have created the change validation for a table object [Seite 891].
3. The Maintain Change Validation screen appears.
   The system displays the accompanying field objects for the table object [Seite 894].

Procedure
5. Choose User-defined change validation.
   The User-Defined Change Validation dialog box appears.
6. In the Program field, enter the customer (user-defined) program. In the Form Routine field, enter the name of the accompanying form routine.
7. Save your entries.

Result
You have specified which user-defined program the Toolbox will use to decide whether or not to activate change validation when the export program is run.
Wage Type Processing with the Toolbox

Use

In payroll, wage types [Extern] are important stores of information which are used to calculate wages and salaries. The wage type is particularly important in the Interface Toolbox, which was developed to export payroll results from the Human Resources (HR) component to a third-party system.

Special, enhanced processing rules apply for particular functions in the Interface Toolbox to meet the demands made on the wage types. These processing rules differ from the processing rules for individual functions. This concerns the following functions:

- Interface Format
  
  Wage Types in the Interface Format [Seite 911]

- Change Validation
  
  Wage Types in Change Validation [Seite 920]

The same processing rules apply to wage types as to other objects for all functions in the interface format or change validation that are not specifically mentioned here (for example, the conversion function for field objects, and so on)
Wage Type Tables in the Interface Format

Definition

A Human Resources (HR) table can be treated as a wage type table in the interface format if the table contains at least one field with the LGART field name.

Use

The Interface Toolbox processes wage types and the accompanying wage type tables in the SAP System separately in the interface format.

Table Types

If there is a field in the table with the name LGART, then one of the following two table types can be set for this table:

- **Regular tables**
  
  The system treats the tables in the interface format as regular tables (for example, WPBP (Work Center/Basic Pay)).

- **Wage type tables**
  
  The system treats the tables in the interface format as wage type tables (for example, RT (Results Table)).

Assign Table Type

The Restrictions function in the interface format allows you to assign one of the two table types to a table containing at least one field with the name LGART. If you select one of the special restrictions for wage types using the Restrictions [Seite 872] function, then the Toolbox will define this table as a wage type table.

The Results Table (RT) table object is automatically defined as a wage type table by the Interface Toolbox.

Other table objects are considered to be regular tables.

See also:

Wage Type Selection in the Interface Format [Seite 912]
Wage Type Selection in the Interface Format

Use

You can select subsets of a wage type table (individual wage types) for export in the same way as when selecting a field object in a regular table. In both cases, use the Restrictions [Seite 872] function in the Interface Format to select a subset of table entries (lines in the table [Seite 913]) for wage types or field objects.

Different From Selecting Other Field Objects

The selection of wage types from wage type tables differs from the selection of other field objects from regular tables.

- If you do not enter any restrictions, all wage types will be exported.
- If you enter restrictions, the only wage types exported are those that you have assigned to the wage type table using the Restrictions function.

To process the wage types, the Interface Toolbox requires additional information that must be entered when the wage types are selected for data export (Restrictions function). This information determines how the wage types are processed in the original payroll run and also in retroactive accounting. This additional information is contained in the different wage type options for retroactive accounting.

If you have entered restrictions, the Interface Toolbox exports all wage types using wage type option [Seite 914] R1.

If the same processing rules apply to a subset of wage types, then you can also select these wage types generically, for example, * or /1*.

Prerequisites

To process wage type tables, you must assign your table objects to the interface format before you can export data.

See also:

Wage Type Options for Retroactive Accounting [Seite 914]
Structure of a Wage Type

Definition
A wage type is a table entry in a wage type table. A wage type consists of the LGART field and the following three numerical fields:

- Amount
- Rate
- Number

Other fields also belong to a wage type (for example, Split Indicator, Currency).

<table>
<thead>
<tr>
<th>Wage types</th>
<th>Amount</th>
<th>Rate</th>
<th>Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>LGART</td>
<td>(RTE)</td>
<td>(AMT)</td>
<td>(NUM)</td>
</tr>
<tr>
<td>For example, MA10</td>
<td>For example, 10</td>
<td>For example, 5</td>
<td>For example, 2</td>
</tr>
</tbody>
</table>

These fields form one line (table entry) in the wage type table for the corresponding wage type.
Wage Type Options for Retroactive Accounting

Use

The ability to run retroactive accounting is one of the most important characteristics of payroll. A retroactive run is necessary, for example, in the following case:

You have made changes to HR master data for the payroll past.

The system must run payroll for these payroll periods again, even though payroll is completed. The modified payroll data must be taken into account.

When comparing the payroll periods (Extern) to be included in retroactive accounting with the original payroll period, the payroll program or reporting programs may identify that corrections are required.

As a result of a retroactive salary increase, an additional amount must be transferred to the employee.

Wage Types in a Retroactive Run

Most wage types are created in the retroactive accounting period with the amount that would have been used in the original period (for example, wage type /101 (Total Gross Amount)).

However, there are wage types that contain the differences between the retroactive period and the original payroll period.

Wage type /553 (Recalculation difference for last payroll run) is the difference between the payment amount for the current payroll period in the payroll run and the previous result.

To support third-party payroll systems that do not use retroactive accounting, or that use a different method to form retroactive accounting differences, the Interface Toolbox has retroactive accounting functions.

Features

- Retroactive Accounting Option R1

  The system processes the selected wage type as in the original payroll period. The system transfers the values in the three wage type fields (Amount, Rate, and Number) unchanged to the third-party system.
Wage Type Options for Retroactive Accounting

- **Retroactive Accounting Option R2**
  The system calculates the difference between the values in the three wage type fields (amount, rate, and number) for the selected wage type from the retroactive accounting period and the comparison period [Seite 916]. These differences are assigned to the respective retroactive accounting period. If the difference for all three fields is 0 (zero) then the system does not export this wage type.

- **Retroactive Accounting Option R3**
  As for option R2, the system calculates the difference between the values in the three wage type fields (amount, rate, and number) from the retroactive accounting period and the comparison period. However, these differences are assigned to the period immediately preceding the current payroll period.

- **Retroactive Accounting Option R4**
  As for options R2 and R3, the system calculates the difference between the values in the three wage type fields (amount, rate, and number) from the retroactive accounting period and the comparison period. These differences are assigned to the current payroll period. If the relevant wage type already exists in the payroll period, then the system cumulates the values for each personnel number. If the third-party system does not use retroactive accounting, you should choose this wage type option.

- **Option DT**
  Options R3 and R4 have a special feature to allow wage types to be assigned to a payroll period, even if they do not originate in this payroll period and come from retroactive accounting periods instead. If you wish to retain information on whether the wage type comes from a retroactive accounting period or from an original period, then choose option DT.

  The system assigns wage types that originate from retroactive accounting to a table with the name $D<name>$, instead of to a table in the original period.

**Activities**

Choose a wage type option [Seite 919]
Comparison Period for Wage Type Options in Retroactive Accounting

Definition
The comparison period is a payroll period used within the Restrictions function in Change validation. It is used to determine which data has changed since the last export.

Use
If you are running first retroactive accounting for the first time for the for-period [Extern] in question, the Interface Toolbox will use the original payroll period as the comparison period. However, it could be the case that several retroactive accounting runs are required for a payroll period [Extern].

You are recalculating payroll period 01 from period 02.
If it is necessary to recalculate payroll period 01 from period 04 again, then the differences are created as follows.

The difference between the payroll period “period 01 recalculated from period 04” and the payroll period “period 01 recalculated from period 02”.

The difference for the original period 01 is not created.

Rule
The payroll period that the system always uses for comparison is the most recent payroll period with the same for-period view [Seite 917] as the payroll period currently being processed.

See also:
Defining the Comparison Period for Generating Wage Type Differences for Several Retroactive Runs [Seite 918]
In-Period Information / For-Period Information

The **for-period information** specifies the payroll period for which the payroll result is valid.
The **in-period information** specifies the payroll period in which the system has created the payroll result.
Together the **in-period information** and the **for-period information** characterize one payroll result.

Example: For-Period Information / In-Period Information

<table>
<thead>
<tr>
<th>Payroll result</th>
<th>For-per. information</th>
<th>Start date of for-per. information</th>
<th>End date of for-per. information</th>
<th>In-per. information</th>
<th>End date of in-per. information</th>
</tr>
</thead>
</table>

**Explanation**

Payroll result 1 for payroll period (for-period) 01/1997 has the start date January 01, 1997 and the end date January 31, 1997. This payroll result was created in payroll period (in-period) 02/1997.
Example: Comparison Period for Wage Type Differences for Several Retroactive Runs

Do not confuse this example with the determination of the comparison period for change validation [Seite 881].

An employee has the payroll results listed in the table. The payroll results contain each relevant payroll comparison period for the creation of wage type differences (changes). The system compares the most recent payroll period with the same for-period information [Seite 917] as the payroll period being processed.

<table>
<thead>
<tr>
<th>Sequential no.</th>
<th>For-period</th>
<th>In-period</th>
<th>Preceding period</th>
</tr>
</thead>
<tbody>
<tr>
<td>00001</td>
<td>01 1996</td>
<td>01 1996</td>
<td>No preceding period</td>
</tr>
<tr>
<td>00002</td>
<td>01 1996</td>
<td>02 1996</td>
<td>00001</td>
</tr>
<tr>
<td>00003</td>
<td>02 1996</td>
<td>02 1996</td>
<td>No preceding period</td>
</tr>
<tr>
<td>00004</td>
<td>03 1996</td>
<td>03 1996</td>
<td>No preceding period</td>
</tr>
<tr>
<td>00005</td>
<td>01 1996</td>
<td>04 1996</td>
<td>00002</td>
</tr>
<tr>
<td>00006</td>
<td>02 1996</td>
<td>04 1996</td>
<td>00003</td>
</tr>
<tr>
<td>00007</td>
<td>03 1996</td>
<td>04 1996</td>
<td>00004</td>
</tr>
<tr>
<td>00008</td>
<td>04 1996</td>
<td>04 1996</td>
<td>No preceding period</td>
</tr>
</tbody>
</table>
Activating Wage Type Options for Retroactive Accounting

Prerequisites
1. You have created an interface format [Seite 852].
2. You are in the object tree [Seite 854] and all table objects are displayed with all field objects.

Procedure
10. Place the cursor on the selected wage type field (LGART) in the table object to be edited.
11. Choose Restrictions.
   You access the Set Restrictions dialog box.
12. Select Special restrictions for wage types.
   You access the Wage Type Restriction for <name> dialog box.
13. Enter the restrictions.

Several entries for a field object are linked implicitly with the logical operation OR.
14. Enter the name of the wage type and select the required option (DT, R1-R4).
15. Choose Transfer.
16. Save your entries.

Result
You have used the Interface Toolbox to activate one of the wage type options for retroactive accounting (R1 to R4) for a wage type field. If you have already activated wage type option DT, wage types used in the retroactive run will be assigned to the table $D<table name >. The information necessary for the data export of a wage type is now complete and the wage type is assigned to the corresponding wage type table.
Wage Types in Change Validation

Use
The Interface Toolbox processes wage types and the accompanying wage type tables separately during change validation.

Just as the Interface Toolbox processes regular tables [Seite 911] in change validation, you can also run change validation [Seite 879] for wage type tables. The system only exports the wage types to the third-party system if they have changed from one data export to another.

The following topics are important for using this transaction:

- Change validation and wage type tables [Seite 921]
- Change validation and wage type comparison [Seite 922]
- Wage types and split indicators [Seite 923]

Features
The following functions are available for wage types in change validation:

- Activate wage types for change validation [Seite 924]
  The functions are only valid for wage types.

You can use the following change validation functions to process wage types. The functions have modified or restricted processing rules.

- Delimit wage types for change validation [Seite 926]

The following functions cannot be used in connection with the change validation:

- Validating single fields
- Key fields
  The explicit definition of key fields is not possible for wage types. The wage type name (LGART) is always used as the key field.
- Relations

Prerequisite
You have assigned the individual wage type to the relevant interface format using the Restrictions [Seite 872] function for field objects in the Interface Format. In this assignment, you have activated one of the wage type options for retroactive accounting (R1 to R4) for each wage type to be included in change validation.

If you have not entered restrictions, all wage types will be exported with wage type option R1.
Change Validation and Wage Type Tables

If it is a regular table, activate change validation for the complete table.

If it is a wage type table, then change validation always refers to a single wage type.

Just as with regular tables, the only field objects included in change validation are those you have already assigned to change validation. You must assign each wage type required for the difference check to change validation.

If you do not specify any wage types, change validation will not take place in the standard system.
Change Validation and Wage Type Comparison

You can set the comparison period for change validation with wage types as for all other objects. When the system checks a wage type for changes, it uses the three fields (amount, rate, and number) that are common to all wage types.

The wage type comparison has the following results:

- If the content of at least one of the three wage type fields has changed then the relevant wage type and the three fields will be exported again.
- If the content of none of the three wage type fields has changed then this wage type will be ignored. The relevant wage type is not exported.

For more information on comparison periods in change validation, see Comparison Periods in Change Validation.

[Seite 913]
Wage Types and Split Indicators

If wage types have split indicators [Extern], there can be several table entries (lines in the table [Seite 913]) for this wage type in the wage type table. As a result the wage type name is not sufficient as a key to identifying a table entry.

The Problem of Wage Types and Split Indicators [Seite 198]

In change validation, it is not clear which table entry for the wage type in the comparison period is to be compared with which table entry in the current payroll period.

Solution

If you want to use change validation for wage types, you must ensure that only one table entry exists per wage type. To ensure that this is the case, do not export split indicators. You must not select the field object containing the split indicator for export. If you have already selected this field object for export, delete it. If the wage type exists several times after the split indicator has been deleted, the system cumulates the multiple entries for this wage type and stores them in one entry.
Activating Wage Types for Change Validation

**Use**

The *Wage Types* function is only allowed for wage types. The system only checks the wage types for changes if you have assigned the wage types to change validation using the *Wage Types* function.

**Activities**

Activate wage types for change validation [Seite 925]
Activating Wage Types for Change Validation

Prerequisites
1. You have created an interface format [Seite 852].
2. You must first use the Restrictions [Seite 872] function to assign the wage type to be processed to the interface format to be processed.
3. You have created the change validation for a table object [Seite 891].
4. The Maintain Change Validation screen appears.
   The system displays the accompanying field objects for the table object [Seite 894].

Procedure
29. Place the cursor on the field object LGART.
30. Choose Wage types.
   You access the Wage Types for <name> dialog box.
31. Select the wage types you want to include in change validation.
32. Choose Continue.
33. Save your entries.

Result
You have assigned individual wage types in a wage type table to change validation.

You can remove individual wage types from the assignment by selecting the wage type symbol. The system displays the wage types. Select the wage type and choose Delete.
Wage Type Delimitation for Change Validation

Use

The Delimit function refers to a single wage type. A wage type table is delimited on the wage type level and must be carried out for each wage type individually.

Alternatively, you can use the Delimit function following the instructions under Delimiting Objects [Seite 892].

Constraints

If you use the Delimit function for wage types, you should note that a wage type is delimited irrespective of the wage type options for retroactive accounting (R1 to R4).

Activities

Delimit wage types for change validation [Seite 927]
Delimiting Wage Types for Change Validation

Prerequisites
1. You have created an interface format [Seite 852].
2. You must first use the Restrictions [Seite 872] function to assign the wage type to be processed to the interface format to be processed.
3. You have created the change validation for a table object [Seite 891].
4. The Maintain Change Validation screen appears.
   The system displays the accompanying field objects for the table object [Seite 894].

Procedure
1. Choose wage types.
   The system displays the accompanying field objects for the LGART field.
2. Place the cursor on a wage type.
3. Choose Delimit.
   The Delimit symbol appears next to the wage type.
4. Save your entries.

Result
You have delimited individual wage types in a wage type table for the data transport.
Examples: Interaction of Wage Types and Wage Type Options for Retroactive Accounting in Change Validation

The following example explains how the individual change validation functions can be used for wage types from wage type tables.

Example: An employee has the following payroll periods

<table>
<thead>
<tr>
<th>Sequential no.</th>
<th>For-period</th>
<th>In-period</th>
<th>Total Gross Amount wage type from the results table (RT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>00001</td>
<td>01 1996</td>
<td>01 1996</td>
<td>3 000.00</td>
</tr>
<tr>
<td>00002</td>
<td>02 1996</td>
<td>02 1996</td>
<td>3 000.00</td>
</tr>
<tr>
<td>00003</td>
<td>01 1996</td>
<td>03 1996</td>
<td>3 500.00</td>
</tr>
<tr>
<td>00004</td>
<td>02 1996</td>
<td>03 1996</td>
<td>3 500.00</td>
</tr>
<tr>
<td>00005</td>
<td>03 1996</td>
<td>03 1996</td>
<td>3 500.00</td>
</tr>
<tr>
<td>00006</td>
<td>03 1996</td>
<td>04 1996</td>
<td>Wage type not available</td>
</tr>
<tr>
<td>00007</td>
<td>04 1996</td>
<td>04 1996</td>
<td>Wage type not available</td>
</tr>
</tbody>
</table>

The following examples consider the generation of a special wage type. The Total Gross Amount wage type (secondary wage type /101) from the Results Table (RT) is used as an example wage type for the employee.

The total gross amount wage type contains an amount of 3,000.00 for the payroll periods 01 and 02.

- Before payroll is run for payroll period 03, the Total Gross Amount wage type is increased retroactively to 3,500.00 as of payroll period 01. This increase corresponds to a salary increase for the employee. The retroactive increase in the total gross amount triggers retroactive accounting for this employee.

- Before the payroll run for payroll period 04, the Total Gross Amount wage type is set to ZERO (0) as of payroll period 03 since the employee should not receive any pay as of payroll period 03. Payroll is run for payroll period 04 with retroactive accounting for period 03.

The following examples show how the Interface Toolbox works in connection with wage type processing in the interface format and change validation.
Examples: Interaction of Wage Types and Wage Type Options for Retroactive Accounting in Change V
Example 1: Third-Party Payroll System Runs Retroactive Accounting (R1)

A third-party payroll system runs retroactive accounting. You want to transfer the Total Gross Amount wage type and all other wage types in the SAP System from the employee's payroll result to the third-party system.

To do this, choose retroactive accounting option R1 [Seite 914]. The Total Gross Amount wage type has the following values after the data export:

<table>
<thead>
<tr>
<th>Payroll period</th>
<th>Total Gross Amount wage type from the results table (RT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>01 in 01</td>
<td>3 000.00</td>
</tr>
<tr>
<td>02 in 02</td>
<td>3 000.00</td>
</tr>
<tr>
<td>01 in 03</td>
<td>3 500.00</td>
</tr>
<tr>
<td>02 in 03</td>
<td>3 500.00</td>
</tr>
<tr>
<td>03 in 03</td>
<td>3 500.00</td>
</tr>
<tr>
<td>03 in 04</td>
<td>---------</td>
</tr>
<tr>
<td>04 in 04</td>
<td>---------</td>
</tr>
</tbody>
</table>

Legend

1. In the 01 in 03 and 02 in 03 payroll periods, the system exports the unchanged total values for the wage type from the original period.

2. The wage type is no longer available in the payroll periods 03 in 04 and 04 in 04 since it was set to ZERO as of payroll period 03, before the payroll run for payroll period 04.
Example 2: Third-Party Payroll System Runs Retroactive Accounting (R1); Change Validation and Delimitation Functions are Active

You only want to export wage types if they have changed from one payroll period to another. You activate change validation for your wage types by assigning single wage types to change validation using the Create function. (For more information on creating objects in change validation, see Creating Objects [Seite 890]).

The following problem can occur in this situation.

A wage type from a payroll period does not exist in the export file. It is unclear whether the wage type did not occur in this payroll period, or whether it has a value identical to the value in the comparison period.

There are two possible solutions to this problem:

- **The user is active:**
  
  You provide information on whether the wage type still exists in the payroll period. You can do this using an additional wage type. This additional wage type acts as a switch (switch wage type). The system generates the switch wage type if the original wage type no longer exists.

- **The Interface Toolbox is active with the Delimit function:**
  
  You can delimit the wage type using the corresponding function. The system generates the character “<“ for the wage type in question. The delimitation sign means that the wage type is no longer valid for the employee.

For more information on delimiting objects within change validation, see Change Validation → Delimiting Objects and Wage Type Processing in the Interface Toolbox → Delimiting Wage Types for Change Validation.

If change validation and delimitation are active for the wage type, then the Total Gross Amount wage type has the following result data for the data export:

<table>
<thead>
<tr>
<th>Payroll period</th>
<th>Total Gross Amount wage type from the results table (RT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>01 in 01</td>
<td>3 000.00</td>
</tr>
<tr>
<td>02 in 02</td>
<td>-----------</td>
</tr>
<tr>
<td>01 in 03</td>
<td>3 500.00</td>
</tr>
</tbody>
</table>
Examples: Interaction of Wage Types and Wage Type Options for Retroactive Accounting in Change Validation

<table>
<thead>
<tr>
<th>Period</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>02 in 03</td>
<td>------------</td>
</tr>
<tr>
<td>03 in 03</td>
<td>------------</td>
</tr>
<tr>
<td>03 in 04</td>
<td>&lt; ... &lt;</td>
</tr>
<tr>
<td>04 in 04</td>
<td>------------</td>
</tr>
</tbody>
</table>

Legend

1. The wage type in the **02 in 02** payroll period is not exported since the total value of the wage type has not changed when compared with the values in the **01 in 01** payroll period.

2. The wage type is not exported in the **02 in 03** and **03 in 03** payroll periods, since the total value for the wage type has not changed from the value in the **01 in 03** payroll period.

3. In the **03 in 04** payroll period, the wage type is delimited, since it no longer exists.

4. The wage type no longer exists in the **04 in 04** payroll period since the system has already transferred the delimitation information to the **03 in 04** payroll period.
Example 3: Third-Party Payroll System Runs Retroactive Accounting (R2)

A third-party payroll system runs retroactive accounting. You only want the SAP System to transfer the differences between the payroll period used in retroactive accounting and the payroll period from the original payroll run to the third-party system for retroactive accounting periods.

To do this, choose retroactive accounting option R2 [Seite 919].

The Total Gross Amount wage type has the following results data for the data export:

<table>
<thead>
<tr>
<th>Payroll period</th>
<th>Total Gross Amount wage type from the results table (RT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>01 in 01</td>
<td>3 000.00</td>
</tr>
<tr>
<td>02 in 02</td>
<td>3 000.00</td>
</tr>
<tr>
<td>01 in 03</td>
<td>500.00</td>
</tr>
<tr>
<td>02 in 03</td>
<td>500.00</td>
</tr>
<tr>
<td>03 in 03</td>
<td>3 500.00</td>
</tr>
<tr>
<td>03 in 04</td>
<td>-3 500.00</td>
</tr>
<tr>
<td>04 in 04</td>
<td>---------------</td>
</tr>
</tbody>
</table>

Legend

1. In the 01 in 03 and 02 in 03 payroll periods, the system only exports differences from the retroactive accounting period and the original period.
   
   \[3 500.00 - 3 000.00 = 500.00\]

2. In the 03 in 04 payroll period, the total wage type amount is -3,500.00, since the value of the wage type was retroactively set to ZERO in payroll period 03.

   \[0 - 3 500.00 = -3 500.00\]

3. The wage type no longer exists in the 04 in 04 period, since it was set to ZERO as of payroll period 03, before the payroll run for payroll period 04.
Example 4: Third-Party Payroll System Runs Retroactive Accounting (R2); Change Validation and Delimitation Functions are Active

A third-party payroll system runs retroactive accounting. You only want the R/3 System to transfer the differences between the retroactive accounting payroll period and the comparison period to the third-party system during retroactive accounting periods.

For more information on the comparison period, see Defining the Comparison Period for Wage Type Options in Retroactive Accounting.

To do this, choose retroactive accounting option R2 [Seite 914].

By activating change validation, you also ensure, as in example 2, that export wage types are only exported again if they have changed.

Make sure that change validation is only activated for the original periods, and not for the retroactive periods in payroll.

The change validation function for retroactive accounting periods is controlled by the R2 retroactive accounting option.

Change validation for the original periods in payroll also refers to the total value of the respective wage type and not to the differences.

To delimit wage types, follow the procedure recommended in example 2.

The system only delimits wage types if the respective wage type exists and has a difference in retroactive accounting.

The Total Gross Amount wage type has the following results data for the data export:
Examples: Interaction of Wage Types and Wage Type Options for Retroactive Accounting in Change V

<table>
<thead>
<tr>
<th>Payroll period</th>
<th>Total Gross Amount wage type from the results table (RT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>01 in 01</td>
<td>3 000.00</td>
</tr>
<tr>
<td>02 in 02</td>
<td>-----------</td>
</tr>
<tr>
<td>01 in 03</td>
<td>500.00</td>
</tr>
<tr>
<td>02 in 03</td>
<td>500.00</td>
</tr>
<tr>
<td>03 in 03</td>
<td>-----------</td>
</tr>
<tr>
<td>03 in 04</td>
<td>-3,500.00 (first entry)</td>
</tr>
<tr>
<td></td>
<td>&lt; ... &lt; (additional delimitation information)</td>
</tr>
<tr>
<td>04 in 04</td>
<td>-----------</td>
</tr>
</tbody>
</table>

Legend

1. The wage type in the **03 in 03** payroll period is **not exported** since the **total value of the wage type** has not changed when compared with the values in the **02 in 03** payroll period.

2. In the **03 in 04** payroll period, the results table (RT) contains **two** entries for the **Total Gross Amount** wage type. On the one hand, the difference between the original **03 in 03** payroll period and **03 in 04** (0.00 - 3,500.00 = -3,500.00) is transferred. On the other hand, the wage type no longer exists in the payroll period, so the “<” delimitation information must be transferred.

3. The wage type no longer exists in the **04 in 04** payroll period since the delimitation information has already been transferred in the **03 in 04** payroll period.
Example 5: Third-Party Payroll System Without Retroactive Accounting (R4)

The third-party system performs payroll without retroactive accounting.

Therefore, you want to collect the differences from the retroactive accounting run and transfer them with the corresponding original period to payroll.

To do this, choose retroactive accounting option R4.\[Seite~914.\]

The Total Gross Amount wage type has the following results data for the data export:

<table>
<thead>
<tr>
<th>Payroll period</th>
<th>Total Gross Amount wage type from the results table (RT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>01 in 01</td>
<td>3 000.00</td>
</tr>
<tr>
<td>02 in 02</td>
<td>3 000.00</td>
</tr>
<tr>
<td>01 in 03</td>
<td>-----------</td>
</tr>
<tr>
<td>02 in 03</td>
<td>-----------</td>
</tr>
<tr>
<td>03 in 03</td>
<td>4 500.00</td>
</tr>
<tr>
<td>03 in 04</td>
<td>-----------</td>
</tr>
<tr>
<td>04 in 04</td>
<td>3 500.00 (Repayment from 03 as recalculation difference)</td>
</tr>
</tbody>
</table>

Legend

1. The differences from the **01 in 03** (500.00) and **02 in 03** (500.00) payroll periods are collected.

   The value of 4,500.00 is calculated as follows:

   \[ 2 \times 500.00 + 3 \times 500.00 = 4 500.00 \]

2. The wage type is no longer available in the payroll periods **03 in 04** and **04 in 04** since it was set to **ZERO** as of payroll period **03**, before the payroll run for payroll period **04**.
Example 6: Third-Party Payroll System Without Retroactive Accounting (R4); Change Validation and Delimitation Functions are Active

The third-party system performs payroll without retroactive accounting. Therefore, you want to collect the differences from the retroactive accounting run and transfer them with the corresponding original period to payroll. To do this, choose retroactive accounting option R4 [Seite 914].

You also want to activate the change validation and delimitation functions for wage types. This can cause problems, since the information (wage type) is condensed in such a way that the result could be interpreted incorrectly.

The Total Gross Amount wage type has the following results data for the data export:

<table>
<thead>
<tr>
<th>Payroll period</th>
<th>Total Gross Amount wage type from the results table (RT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>01 in 01</td>
<td>3 000.00</td>
</tr>
<tr>
<td>02 in 02</td>
<td>---------- (since change validation is not active)</td>
</tr>
<tr>
<td>01 in 03</td>
<td>----------</td>
</tr>
<tr>
<td>02 in 03</td>
<td>----------</td>
</tr>
<tr>
<td>03 in 03</td>
<td>4 500.00</td>
</tr>
<tr>
<td>03 in 04</td>
<td>----------</td>
</tr>
<tr>
<td>04 in 04</td>
<td>-3,500.00 (first entry) &lt; ... &lt; (additional delimitation information)</td>
</tr>
</tbody>
</table>

Problem

- If this information is the only information available for the wage type, then it could be interpreted as follows:
  - In payroll periods 01 and 02 the wage type was worth 3,000.00.
  - This value did not change with retroactive effect in the 01 in 03 and 02 in 03 payroll periods.
  - In payroll period 03, the wage type was worth 4,500.00.
    - The calculation of the amount 4,500.00 (2*500.00 + 3,500.00 = 4,500.00) cannot be reconstructed here. However, it is necessary since change validation is used.
  - This would also mean that the value of the wage type had decreased retroactively for payroll period 03, and would have the value 1,000.00.
  - Payroll period 04 is the first period in which the wage type does not occur.
### Examples: Interaction of Wage Types and Wage Type Options for Retroactive Accounting in Change Validation

#### Solution

To solve this problem, you should activate the DT wage type option for retroactive accounting. The values for the *Total Gross Amount* may appear as follows:

<table>
<thead>
<tr>
<th>Payroll period</th>
<th>Total Gross Amount wage type from the results table (RT)</th>
<th>Total Gross Amount wage type from the table ($DRT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>01 in 01</td>
<td>3 000.00</td>
<td>--------</td>
</tr>
<tr>
<td>02 in 02</td>
<td>---------------</td>
<td>--------</td>
</tr>
<tr>
<td>01 in 03</td>
<td>---------------</td>
<td>--------</td>
</tr>
<tr>
<td>02 in 03</td>
<td>---------------</td>
<td>--------</td>
</tr>
<tr>
<td>03 in 03</td>
<td>3 500.00</td>
<td>1 000.00</td>
</tr>
<tr>
<td>03 in 04</td>
<td>---------------</td>
<td>--------</td>
</tr>
<tr>
<td>04 in 04</td>
<td>&lt; ... &lt;</td>
<td>-3 500.00</td>
</tr>
</tbody>
</table>

#### Legend

1. In the **03 in 03** payroll period, the retroactive accounting difference of 1,000.00 and the amount of 3,500.00 are shown separately. This clearly shows that the current value of the wage type is 3,500.00 for the **03 in 03** payroll period.

   This information would be of particular importance for the payroll run in the **04 in 04** payroll period if the wage type had retained the value of 3,500.00 and no longer occurred because the change validation function was active. It would be unclear whether the employee is entitled to 3,000.00 or 4,500.00.

2. The change validation function sends the delimitation information to the "04 in 04" payroll period even though the wage type no longer exists in the **03 in 04** payroll period.

   The reason for this is the Only Export in Original Period option which is flagged in the selection screen for the export program.

   If you had not selected this option, then the Toolbox would have sent the delimitation information in the **03 in 04** payroll period.
Generation - Interface Format for the Export Program

Use
The Interface Toolbox does not use a standard data export program when exporting data. This means that there is no ready-made program for data export in the SAP System.

Features
The following demands are placed when exporting data from the SAP System to a third-party system.

- Flexibility for the user
- High transfer speed during data export

To meet these requirements, the system generates the export program based on user’s requirements. These user requirements are stored in the tables in the Interface Toolbox.

If you have created an interface format, or have changed one of the following areas, you must regenerate the export program when before you can use it:

- Interface format [Seite 841]
- Import macro for cluster data [Extern]
- Data definition include [Seite 876]
- Change validation [Seite 879]
- Wage type processing [Seite 910]

Prerequisite
Before you generate the export program, you must enter the name of the export program in the interface format for the Toolbox:

- In the Main Program field, enter the name of the export program
- In the Include 1 to 9 fields, enter the name of the data definition include

Do not use the name of a program or include that has already been used for a different purpose.

The Toolbox only receives the names of the export program and includes. The coding for the export program is generated in the interface format via the Generate function.

Activities
Generate the export program [Seite 941]
Generating the Export Program

Prerequisites
You have created an interface format or made changes in one of the following areas:

- Interface format [Seite 841]
- Import macro for cluster data [Extern]
- Data definition include [Seite 876]
- Change validation [Seite 879]
- Wage type processing [Seite 910]

Procedure
13. Choose the Configuration tab index.
14. In the Object to be processed group box, choose Interface Format.
15. In the Interface format field, enter the name of your new interface format.
16. Choose Generate.

Result
The customer export program for the interface format has been generated for data export.
Export Program

Definition
Using your defined interface format as a basis, the Interface Toolbox generates a program using the *Advanced Business Application Programming* language (ABAP). This program is the export program.

Use
The export program transfers payroll results from the SAP System to a third-party system. You must
- generate [Seite 939] and
- execute [Seite 943] the export to suit your requirements.

Structure
When you start the export program, you see a selection screen with several input blocks.
- You can select the payroll period and personnel numbers in the upper areas.
- The lower area allows you set parameters for the export program.

Activities
*Start the export program [Seite 943]*
Starting the Export Program

Prerequisites
You have created an interface format.

Procedure
1. Choose the Export tab index.
2. In the Export activities group box, choose Export with interface format.
3. In the Interface format field, enter the name of your interface format.
4. Choose Execute.
   You access the Export dialog box.
5. In the individual fields, enter the necessary data and select the required export options.
6. Choose Execute.

Result
You have created the export file for the personnel numbers selected from a payroll area.
Infotype: Export Status (0415)

Use

The Interface Toolbox uses the Export Status infotype (0415) to monitor the export status for the individual interface formats.

The infotype enables you to run payroll at the same time as other interface formats (Master Data interfaces and payroll interfaces). Separate administration of retroactive accounting (using the Payroll Status infotype (0003)) and interfaces (using the Export Status infotype (0415) subtype (interface name)) ensures that unwanted interaction is avoided. The retroactive accounting capabilities remain unrestricted.

Structure

Subtype

- Interface name
  
  Name of the interface format from which the export program has been generated.

Fields

The fields correspond to the relevant fields in the Payroll Status infotype (0003).

- Earliest personal RA date
  
  Earliest date from which data can be exported.

- Export until
  
  The employee data is exported until this date, even if the date is after the employee leaving date. The date must be in a period during which the employee is not active.

- Do not export after
  
  The employee data was exported until this date.

- Exported until
  
  The employee data has been exported up to this date.

- Earliest MD change
  
  If payroll data is changed for an employee, the R/3 System stores the validity start date. The export program uses this date to identify whether an export must be repeated, and if so, the date on which the new export must take place to transfer the change to the third-party system.

- Personnel number locked
  
  If this field is flagged, the employee is locked for export and the personnel number will not be exported. In this case, the personnel number is not exported.

Features

The Interface Toolbox creates and maintains the Export Status infotype (0415).
The interface format creates the Export Status infotype (0415) for this personnel number when the personnel number is exported for the first time with a particular interface format.

For each subsequent export, the Interface Toolbox enters the end date of the exported payroll period in the Exported Until field.

The SAP System automatically enters the appropriate date in the Earliest MD Change field at the same time as the Earliest MD change field in the Payroll Status infotype (0003).

You can use the remaining fields to monitor the export of individual personnel numbers. The Interface Toolbox usually maintains the Export Status infotype (0415) for you.
Export History for Interface Results

Use

To carry out detailed change and wage type validation, the export program must be able to access the data from previous exports. For this reason, the Interface Toolbox stores the data for each export.

Just like the payroll results, the stored interface results can be divided as follows:

- **Interface directory**
  
  The interface directory is a table of contents for personnel numbers. It contains all payroll runs, along with other detailed information (for example, for-period, in-period, payroll area.)

- **Interface data**
  
  The interface data contains the individual export data for the personnel number(s).
  
  The interface data is always in its original state, that is, the state before change validation is carried out.

The Interface Toolbox can work with several interface formats. As a result, the interface results are stored for each interface format.

Prerequisites

You must select the *Update* export option before you start the export program [Seite 942].

Features

You can use the Toolbox to

- **Display**

- **Delete**
  
  It is often a good idea to delete interface results in the test system. The Interface Toolbox offers you two options:

  - **Delete the last interface result for one or more personnel number(s).**
    
    The interface results for the selected personnel number(s) are deleted.

  - **Delete all interface results for an interface format.**
    
    If no personnel number is entered, the interface results for all personnel numbers belonging to this interface format are deleted.

  To ensure consistency, it is not possible to delete an individual interface result within the sequence of interface results. The last (current) interface result is the only exception.
Displaying the Interface Format

Prerequisites
You want to display the interface results for an interface format after the data export.

Procedure
1. Choose the Export History tabstrip.
2. In the Interface format field, enter the name of your interface format.
3. If required, you can use the Personnel no. and Payroll area fields to restrict the selection of the data.
4. Choose Display.
5. Select a line from the interface results.
   The system displays the content of the table at the time when the selected interface result was exported.
   To give a complete overview, both the exported entries and those entries not exported due to change validation are displayed. However, wage types with restrictions are not displayed.

Result
You have displayed the interface data for an interface format.
Deleting Interface Results

Prerequisites
You want to display the interface results for an interface format after the data export.

Procedure
1. Choose the Export History tabstrip.
2. In the Interface Format field, enter the name of your interface format and, if required, the personnel number(s).
3. Choose Delete.
   You access the Delete Interface Results screen.
4. If you want to select individual lines in the interface result for deletion, flag Manual selection.
5. If you want to delete all the interface results, flag Delete all to.
   Enter the date up to which you want to delete the interface results.
6. Choose Delete.

Result
You have deleted interface results for an interface format.
Automatic Conversion of Interface Results

Use

The Interface Toolbox saves all values for all exported fields as interface results in cluster IF. The Interface Toolbox uses this information to determine whether the field has changed since the last export. This takes place in change validation. Changes in the data structures (field length or field type in the Data Dictionary) may mean that the Interface Toolbox cannot import results when exporting or displaying the interface results.

If a result with an old data structure cannot be imported, the Interface Toolbox temporarily converts the data to be imported to the new format. This is done using the data definition in the Version Management Cluster IF - Exported Tables (T532K) and Version Management Cluster IF - Fields Structure (T532L) tables.

The Interface Toolbox runs this data conversion automatically when the old results are imported. No further processing by the user is required.

The data is stored in the database in the old data structure. This avoids the loss of information.

Upgrade to Release 4.5

There is no version description for the old version for an upgrade from a previous release. If data structures are changed in an upgrade, you must carry out one-time activities.

For more information, see the documentation for report RPCLSTIF_CONVERSION (Conversion of Interface Results in IF Cluster) under Structure Changes for an Upgrade. When you call the report, choose Help → Application help.
Manual Conversion of Interface Results

Use
In addition to automatic conversion of the interface results without permanent conversion on the database, the Interface Toolbox also enables you to convert and store interface results manually. You use manual conversion to:

- Run a test
- Quickly process old interface results that must be imported frequently (performance)

Prerequisites
You have used the Interface Toolbox to create an interface format and used this format to export payroll results or HR master data. The interface results have been saved in cluster IF. One of the exported data structures was then changed in the Data Dictionary.

You, or SAP, have changed the type or length of a data element.

If you want to import data from the old interface format, you must transfer the data to a new format.

You want to run a conversion of the old interface results on the database, and do not want to convert the interface results automatically [Seite 949].

Features
Manual conversion takes place for a particular interface format, a selected old and new version of the data, and a selection of personnel numbers.

For more information, see the documentation for report RPCLSTIF_CONVERSION (Conversion of Interface Results in IF Cluster). When you call the report, choose Help → Application help.
Displaying TemSe Files

Prerequisites
You have exported the data.

Procedure
1. In the menu, choose File → Display TemSe object.
   The Display TemSe object dialog box appears.
2. In the TemSe object field, enter the names of your export field with the appropriate prefix.
   You want to display the export file with the name TESTFILE, which you have selected from the export program selection screen.
   In the File field, enter HR_PINTFS_TESTFILE and choose Display.
3. Choose Display.
   If the Toolbox identifies an error when export file is displayed, it will display the export file in an unformatted form [Seite 986]. The unformatted display is better for identifying errors.

Result
The content of the TemSe file is displayed.
Managing TemSe Files

Use
You want to use the enhanced TemSe management functions:

- Delete TemSe objects
- Display TemSe files [Seite 951]

Prerequisites
You have exported the data and created a TemSe object.

Procedure
1. In the menu, choose File → TemSe administration.
   You access the TemSe: Request Screen.
2. Enter the required selection criteria.
   If you do not know the exact object name or creator, leave the fields blank and enter an approximate date in the Creation date field. Try to enter a date that is as accurate as possible.
3. Choose Object list.
   You access the TemSe: List of Objects dialog box.
4. To display the contents of an object, select the required object and choose Contents.
   You access the TemSe: Contents of Object screen.
5. Different selection options for the selected objects are now displayed.

Result
You have accessed the TemSe file administration functions.
Downloading an Export File

Use
You can download the exported file from the TemSe file to your PC or application server.

Prerequisites
The data was successfully exported.

Procedure
1. Choose the Export tab index.
2. In the Export activities group box, choose Download from TemSe.
3. In the TemSe object and File name fields, make the appropriate entries.
4. Choose Execute.

Result
The exported TemSe file can be found on your PC or application server.
**File Layout**

**Definition**
The file layout describes the structure of the export file, in particular the sequence and length of the field objects [Seite 854].

**Use**
The File Layout function allows you to convert the export file format, which is known as the SAP export file format, into any user-defined file format. An interface format [Seite 841] is assigned to each file layout.

**File Layout Types for the Export File**
- SAP standard file layout [Seite 987]
- User-defined file layout

The section on the file layout refers to the user-defined file layout.

**Structure**
Like the interface format, the file layout has hierarchical objects.

**Objects in the File Layout and their Hierarchy**

<table>
<thead>
<tr>
<th>Object</th>
<th>Hierarchy classification</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block</td>
<td>1</td>
<td>BEGIN_OF_FILE</td>
</tr>
<tr>
<td>Structure</td>
<td>2</td>
<td>MASTER_DATA</td>
</tr>
<tr>
<td>Field</td>
<td>3</td>
<td>P0002-NACHN</td>
</tr>
</tbody>
</table>

You can define **blocks**, **structures** and **fields** in the file layout. When you create a file layout, use the following sequence:

1. Blocks
2. Assigned structures
3. Fields of the assigned structures
The blocks, structures and fields can have any name.

**Fields**
- You can assign fields in the interface format to the defined fields belonging to the file layout.
  - You can also copy the characteristics and content of these interface format fields.
- You can also define the fields to suit your requirements.

**Structures**
You can group a certain number of fields together in a structure. A structure corresponds to one line in the export file.

**Blocks**
Several structures are grouped together in a block. Blocks are not represented in the export file. They are only used to control the editing of the structures.

**See also:**
- Generating the File Layout [Seite 981]
- Layout Conversion [Seite 983]
Processing the File Layout

Purpose
You use this process to convert the file format for the export file to a user-defined file format.

Prerequisites
The SAP System contains an export file in the SAP standard file layout [Seite 986].

Process flow
1. Creation of file layout [Seite 979].
   The defined blocks, structures, and fields form the file layout for the export file.
2. Generation of file layout [Seite 981]
   You must also generate the file layout at the same time as the export program.
3. Conversion of file layout [Seite 983].
   The Conversion function uses the rules you have defined to process the blocks, structures, and fields. The blocks, structures and fields are processed individually and processing is triggered by specific processing times in the Interface Toolbox. The Interface Toolbox calls these processing times, and processes all blocks that you have assigned to this processing time. The Interface Toolbox subsequently processes all structures assigned to the block, and all fields assigned to the structure.

Result
The SAP System contains an export file with the user-defined file layout.
Editing and Attributes for the File Layout

Use
You use these functions to edit the file layout.

Features

- **Create**
  
  The *Create* function is valid for all objects (block, structure, field).
  
  You **must** assign an existing **interface format** to the file layout.
  
  - If the file layout does not yet have any objects (block, structure, field), choose *Create*.
  
  - If you want to add additional objects to an existing file layout, place the cursor on an object of the same type (block, structure, field) and choose *Create*.

- **Delete**
  
  The *Delete* function is valid for all objects (block, structure, field).
  
  - Select the object to be deleted and choose *Delete*.
    
    The objects located below this object in the hierarchy will also be deleted.
    
    If the object to be deleted (structure, field) is used elsewhere in the file layout, it will **NOT** be deleted there. If you have deleted all occurrences of the object, the Interface Toolbox will query whether you want to delete the object from the object list. If the object remains in the object list, you can use the object again at any time by choosing *Insert*.

  For an alphabetical list of all structures or fields, see *Structures or Fields*.

- **Move**
  
  The *Move* function is valid for all objects (block, structure, field).
  
  - Select the object you wish to move.
    
    - Place the cursor on the object in front of which you wish to insert the object and choose *Move*.

- **Insert**
  
  The *Insert* function is allowed for structures and fields.
  
  You can use structures and fields **several times** in the file layout.

- **Attributes**
  
  The *Attributes* function creates the link with the interface format assigned to the file layout.
User Exits and User-Defined Form Routines

Use

You can use the Interface Toolbox to call your customer form routines during the conversion. This enables you to implement complicated file layouts.

If a user-defined form routine is called up, the Interface Toolbox transfers parameters to the user-defined form routine. The form routine transfers a return value to the Toolbox.

If you want to implement a user-defined form routine using the user exit, you must specify which form routine is used and in which program this form routine can be found.

Prerequisites

The user-defined form routine must meet two criteria:

- It **must** contain **16 parameters**.
- **Parameter 16** is the **return value** for the Interface Toolbox.

If you use a user-defined form routine, you can choose to set the first 15 parameters. These parameters are used as input parameters. If a parameter does not have an entry, then the Interface Toolbox uses SPACE.

You can use the following types of input parameters:

- **Constant values as input parameters** [Seite 959]
- **Interface format values as input parameters** [Seite 960]
- **Interface variables as input parameters** [Seite 961]
Constant Values as Input Parameters

Definition

You can use a constant value as the input parameter for a user-defined form routine. You must enter constant values in quotation marks, for example “CONSTANT_VALUE”.

The FIRST control parameter is used for constant values.
Interface Format Values as Input Parameters

**Definition**

You can use all data defined in the interface format as input parameters for a user-defined form routine.

**Use**

This allows you to use data from the export file, in other words, data from internal tables, field strings, and infotypes.

You enter the data as follows: `<table name>_<field name>` (for example, `P0002-NACHN`, `VERSC-ABKRS`, `WPBP-WERKS`).

You must also use the following control parameters for the interface format:

- **First**
  The system uses the value from the first entry.

- **Last**
  The system uses the value from the last entry.

- **Current**
  The system uses the value from the current work area.

You can only use the Last and All control parameters for internal tables and infotypes. If you use a field string value as the input parameter, you must set the First control parameter.

You should only use the All control parameter if the user exit is called up within a field or structure assigned to a block. The object is processed according to the data in the repeat factor.
Interface Variables as Input Parameters

Definition

The interface format includes numerous internal interface variables. An interface variable always begins with &VAR-.

The Personnel Number interface variable could be used as an input parameter as follows: &VAR-PERNR.

Use

You must also use the First control parameter for the interface variables.

<table>
<thead>
<tr>
<th>Interface variable</th>
<th>Data type</th>
<th>Length</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>PERNR</td>
<td>Numeric</td>
<td>8</td>
<td>Personnel number from BOP</td>
</tr>
<tr>
<td>PERNA</td>
<td>Character</td>
<td>8</td>
<td>Name of export program from BPR</td>
</tr>
<tr>
<td>UNAME</td>
<td>Character</td>
<td>12</td>
<td>User name for export program from BPR</td>
</tr>
<tr>
<td>DATUM</td>
<td>Date</td>
<td>8</td>
<td>Date of export from BPR</td>
</tr>
<tr>
<td>UZEIT</td>
<td>Time</td>
<td>6</td>
<td>Time of export from BPR</td>
</tr>
<tr>
<td>VERSN</td>
<td>Numeric</td>
<td>5</td>
<td>Version number from BPR</td>
</tr>
<tr>
<td>BEGDA</td>
<td>Date</td>
<td>8</td>
<td>Start date of first payroll period from BOP</td>
</tr>
<tr>
<td>ENDDA</td>
<td>Date</td>
<td>8</td>
<td>End date of first payroll period from BOP</td>
</tr>
<tr>
<td>PERIO</td>
<td>Numeric</td>
<td>2</td>
<td>Number of exported payroll period from BOP (in-period)</td>
</tr>
<tr>
<td>PERBE</td>
<td>Date</td>
<td>8</td>
<td>Start date of exported payroll period from BPE (for-period)</td>
</tr>
<tr>
<td>PEREN</td>
<td>Date</td>
<td>8</td>
<td>End date of exported payroll period from BPE (for-period)</td>
</tr>
<tr>
<td>RCALC</td>
<td>Character</td>
<td>1</td>
<td>Retroactive accounting indicator from BPE</td>
</tr>
<tr>
<td>NPERN</td>
<td>Numeric</td>
<td>6</td>
<td>Number of employees from BPO</td>
</tr>
<tr>
<td>VALUE</td>
<td>Character</td>
<td></td>
<td>Value of current structure (dynamic length)</td>
</tr>
<tr>
<td>TABNA</td>
<td>Character</td>
<td>10</td>
<td>Current processed table name from BOT</td>
</tr>
<tr>
<td>ENTRY</td>
<td>Numeric</td>
<td>6</td>
<td>Number of entries in the current processed table from BOT</td>
</tr>
</tbody>
</table>
## Interface Variables as Input Parameters

<table>
<thead>
<tr>
<th>Variable</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NENTR</td>
<td>Numeric</td>
<td>6</td>
<td>Line number of the current entry from BOE</td>
</tr>
<tr>
<td>INFBE</td>
<td>Date</td>
<td>8</td>
<td>Start date for current processed infotype from BOI</td>
</tr>
<tr>
<td>INFEN</td>
<td>Date</td>
<td>8</td>
<td>End date for current infotype from BOI</td>
</tr>
<tr>
<td>WTYEN</td>
<td>Date</td>
<td>8</td>
<td>End date of current processed wage type from BOW</td>
</tr>
<tr>
<td>PERMO</td>
<td>Numeric</td>
<td>2</td>
<td>Period modifier from BPE</td>
</tr>
<tr>
<td>PABRJ</td>
<td>Numeric</td>
<td>4</td>
<td>Payroll year from BPR</td>
</tr>
<tr>
<td>PABRB</td>
<td>Numeric</td>
<td>2</td>
<td>Payroll period BPR</td>
</tr>
<tr>
<td>MFILE</td>
<td>Character</td>
<td>40</td>
<td>Output file for conversion (main export file)</td>
</tr>
<tr>
<td>AFIL1</td>
<td>Character</td>
<td>40</td>
<td>Additional conversion file 1 (additional export file 1)</td>
</tr>
<tr>
<td>AFIL2</td>
<td>Character</td>
<td>40</td>
<td>Additional conversion file 2 (additional export file 2)</td>
</tr>
<tr>
<td>AFIL3</td>
<td>Character</td>
<td>40</td>
<td>Additional conversion file 3 (additional export file 3)</td>
</tr>
<tr>
<td>AFIL4</td>
<td>Character</td>
<td>40</td>
<td>Additional conversion file 4 (additional export file 4)</td>
</tr>
<tr>
<td>APPEN</td>
<td>Character</td>
<td>1</td>
<td>Conversion option</td>
</tr>
</tbody>
</table>

*Append File*
Blocks in the File Layout

Use
The blocks form the highest level in the file layout hierarchy. They control the processing of the structures and fields. The interface format stores the objects (block, structure, field) in a graphical overview.

Features
The functions for the blocks are shown as symbols in the tree structure. To access the appropriate function, select an icon.

- **Processing**
  Determines the processing time for a block.

- **Repeat**
  Determines how often a block is processed.

- **Output to file**
  Name of the file to which the export file is written.

- [User exit before](Seite 964)
- [User exit after](Seite 965)

Activities
To execute this function you must be in the *Change File Layout <name> (Block View)* screen. Choose Block, Structure or Field. The blocks are displayed in the selected sequence. The structure and field strings are arranged alphabetically. This is because fields and structures can be used several times.
User Exit Before (Block)

Use

You use the User Exit Before function to call a user-defined form routine. The form routine is called before the Interface Toolbox starts to process the block, in other words, before the Toolbox processes the structures and fields assigned to a block.

Each user exit must have 16 parameters.

Input Values

Parameters 1 to 15 are available as input values for the user exit. If you use tables, you can select the following parameters for the table entries:

- **First**
  
  The first table entry is transferred to the form routine.

- **Last**
  
  The last table entry is transferred to the form routine.

- **Current**
  
  The current table entry (from the table header) is transferred to the form routine.

Return Value

In the form routine, the return value is parameter 16. The return value of a form routine determines how the block is subsequently processed. The return value can have the following values:

- **0**
  
  The Toolbox does not process the block.

- **1**
  
  The Toolbox processes the block.

Activities

In the User Exit dialog box, enter the data for the program, for the form routine, and for parameters 1 to 15.
User Exit After (Block)

Use
You use the User Exit After function to call a user-defined form routine. The form routine is called after the Interface Toolbox has processed all structures and fields belonging to a block. The result for the currently processed block is stored in the local interface block buffer [Seite 971], which can be accessed in the user exit.

Each user exit must have 16 parameters.

Input Values
Parameters 1 to 15 are available as input values for the user exit.
If you use tables, you can select the following parameters for the table entries:

- **First**
  The first table entry is transferred to the form routine.

- **Last**
  The last table entry is transferred to the form routine.

- **Current**
  The current table entry (from the table header) is transferred to the form routine.

Return Value
In the form routine, the return value is parameter 16. The return value of a form routine determines whether the interface block buffer is written to the export file. The return value can have the following values:

- **0**
  The Interface Toolbox does not write the interface block buffer to the file.

- **1**
  The Interface Toolbox writes the interface block buffer to the file.

Activities
In the User Exit dialog box, enter the data for the program, for the form routine, and for parameters 1 to 15.
Structures in the File Layout

Use
A structure corresponds to one line in the export file.

Features
The functions are represented by icons in the object tree. To access a function, select an icon.

- Export
  The export parameters tell the Interface Toolbox the conditions for writing data to the interface block buffer.
- [User exit before](Seite 967)
- [User exit after](Seite 968)
User Exit Before (Structure)

Use
You use the User Exit Before function to call a user-defined form routine. The form routine is called before the Interface Toolbox starts to process the structure, in other words, before the Toolbox processes a particular structure and related fields.

Each user exit must have 16 parameters.

Input Values
Parameters 1 to 15 are available as input values for the user exit.

If you use tables, you can select the following parameters for the table entries:

- **First**
  The first table entry is transferred to the form routine.

- **Last**
  The last table entry is transferred to the form routine.

- **Current**
  The current table entry (from the table header) is transferred to the form routine.

Return Value
In the form routine, the return value is parameter 16. The return value of a form routine determines how the structure is subsequently processed. The return value can have the following values:

- **0**
  The Interface Toolbox does not process the structure.

- **1**
  The Interface Toolbox processes the structure.

Activities
In the User Exit dialog box, enter the data for the program, for the form routine, and for parameters 1 to 15.
User Exit After (Structure)

Use

You use the User Exit After function to call a user-defined form routine. The form routine is called up after the Interface Toolbox has processed all fields belonging to a structure. The result for the currently processed block is stored in the local interface block buffer [Seite 971], which can be accessed in the user exit.

Each user exit must have 16 parameters.

Input Values

Parameters 1 to 15 are available as input values for the user exit.

If you use tables, you can select the following parameters for the table entries:

- **First**
  
  The first table entry is transferred to the form routine.

- **Last**
  
  The last table entry is transferred to the form routine.

- **Current**
  
  The current table entry (from the table header) is transferred to the form routine.

Return Value

In the form routine, the return value is parameter 16. The return value of a form routine determines whether the interface block buffer is written to the export file. The return value can have the following values:

- **0**
  
  The Toolbox disregards any changes in the form routine and writes the unchanged structure to the interface block buffer.

- **1**
  
  The Interface Toolbox writes the unchanged structure to the interface block buffer.

Activities

In the User Exit dialog box, enter the data for the program, for the form routine, and for parameters 1 to 15.

You can decide whether to transfer the block buffer to the export file in the User Exit After (block).
Field Functions in the File Layout

Use
The fields in the file layout are the lowest level in the object hierarchy. Values are stored in these fields.

Features
The functions are represented by icons in the object tree. To access the appropriate function, select an icon.

- **Length**
  Defines the length of a field.

- **Content**
  Informs the Toolbox how the content of a field is defined.
Calling Specific Interface Data

Use
The Interface Toolbox enables you to select specific data for use in the user-defined form routine.
You can use data from the following areas:
- Interface block buffer [Seite 971]
- Interface format data [Seite 974]
- Access to export data in a user-defined file layout [Seite 976]
- Structure definitions [Seite 977]

See also:
Generating the File Layout [Seite 981]
Layout Conversion [Seite 983]
Interface Block Buffer

Definition
Each file layout, a block buffer is assigned to each block. The Interface Toolbox does not write
the block fields to this block buffer at this point. The block buffer is only transferred to the export
file when the block has been processed.

Use
If you use the User Exit After [Seite 965] function during block processing, you can specify
whether the interface block buffer is written to the export file.

The Toolbox defines the interface block buffer and can be used by the user-defined form routine.
If your program contains the user-defined form routine and uses the RPCIFI26 include in the
Interface Toolbox, you have unlimited access to the interface block buffer.

In the RPCIFI26 include, the interface block buffer is defined as an internal table with the name
BLOCKS_OUTPUT.

```
DATA: BLOCKS_OUTPUT TYPE PINTF_OUTPUT OCCURS 10 WITH HEADER LINE.
TYPES: BEGIN OF PINTF_OUTPUT,
  SNAME(25),
  LENTH(6) TYPE N,
  VALUE TYPE PINTF_MAX_RECORD,
END OF PINTF_OUTPUT.
TYPES: PINTF_MAX_RECORD (4096) TYPE C.
```

The BLOCKS_OUTPUT-SNAME field contains the name of a structure assigned to a block. The
BLOCKS_OUTPUT-LENTH field contains the length of this structure and the
BLOCKS_OUTPUT_VALUE field contains the content.

<table>
<thead>
<tr>
<th>SNAME</th>
<th>LENTH</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>STRUCTURE_01</td>
<td>17</td>
<td>12199601010002X00</td>
</tr>
<tr>
<td>STRUCTURE_02</td>
<td>20</td>
<td>Bond, James</td>
</tr>
<tr>
<td>STRUCTURE_03</td>
<td>8</td>
<td>19961010</td>
</tr>
</tbody>
</table>

The Interface Toolbox writes the value of the BLOCKS_OUTPUT-VALUE field in the length
specified in the BLOCKS_OUTPUT-LENTH field to the output file.

If you use a user-defined form routine that uses the User Exit After function for blocks, you can
maintain the interface block buffer by deleting, changing, moving, or inserting entries.

INCLUDE RPCIFI26.
Interface Block Buffer

FORM MAINTAIN_BLOCK USING PAR_01

    PAR_02
    PAR_03
    PAR_04
    PAR_05
    PAR_06
    PAR_07
    PAR_08
    PAR_09
    PAR_10
    PAR_11
    PAR_12
    PAR_13
    PAR_14
    PAR_15  "Input parameters 1 - 15

    RETURN_VALUE. "return parameter

    RETURN_VALUE = `1`.

    LOOP AT BLOCKS_OUTPUT.

    IF BLOCKS_OUTPUT-SNAME = `STRUCTURE_A` AND
    BLOCKS_OUTPUT-VALUE(2) = `XS`.
    CLEAR BLOCKS_OUTPUT-VALUE.
    BLOCKS_OUTPUT-LENGTH = 10.
    BLOCKS_OUTPUT-VALUE = `DS19960125`.
    MODIFY BLOCKS_OUTPUT.
    ENDF.
    ENDF.
ENDFORM.

If you change the BLOCKS_OUTPUT interface block buffer and the value 1 is returned to the Toolbox, the Interface Toolbox exports the exact content of the interface block buffer. It is not possible to recreate the previous content of the interface block buffer.
You can use the interface block buffer for each customer form routine that uses the User Exit After function for blocks.

Example of an Interface Block Buffer

<table>
<thead>
<tr>
<th>Before</th>
<th>SNAME</th>
<th>LENTH</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>STRUCTURE_A</td>
<td>12</td>
<td>XS0123456789</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>After</th>
<th>SNAME</th>
<th>LENTH</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>STRUCTURE_A</td>
<td>10</td>
<td>DS 19960125</td>
</tr>
</tbody>
</table>
Interface Format Data

Use

If you use the *During Processing of Employee Data* processing time to process blocks, structures, and fields in your user-defined form routine, the data can be used as defined in the interface format. The Interface Toolbox generates coding that represents the internal tables, infotypes, and field strings from the interface format.

The coding for the interface format data is defined in the *first include* used to generate the conversion program for the file layout. If you use this include in the program containing the user-defined form routine, the interface format data can be called up in the form `<table name>-<field name>`. You can also use the standard table operations used in the *Advanced Business Application Programming* (ABAP) language, for example, LOOP, READ TABLE, and so on.

For example, if you have specified that the NACHN, VORNA and GESCH fields from infotype P0002 (*Personal Data*) are used, the Interface Toolbox generates the following coding:

```plaintext
DATA: BEGIN OF P0002 OCCURS 5,
    NACHN(000025) TYPE C,
    VORNA(000025) TYPE C,
    GESCH(000001) TYPE C,
END OF P0002.
```

You can now use the names of the fields defined above (NACHN, P0002-VORNA, and P0002-GESCH):

```plaintext
REPORT ZUSER_EXITS.
INCLUDE ZPCIFT01.
FORM EXAMPLE_P0002 USING PAR_01
    PAR_02
    PAR_03
    PAR_04
    PAR_05
    PAR_06
    PAR_07
```
PAR_08
PAR_09
PAR_10
PAR_11
PAR_12
PAR_13
PAR_14
PAR_15
RETURN_VALUE.

READ TABLE P0002 INDEX 1.
CONCATENATE P0002-NACHN
    P0002-VORNA
    INTO RETURN_VALUE
    SEPARATED BY ``,``
ENDFORM.

Legend

If the first line of infotype P0002 (Personal Data) contains the first name (P0002-VORNA) 'James' and the surname (P0002-NACHN) 'Bond', then the return value is the character string 'Bond, James'.

If the system processes a new payroll period, the Interface Toolbox enters the corresponding payroll period values in the interface format data.

You can also transfer infotype P0002 (Personal Data) directly in parameters 1 to 15, instead of following the above example.
Access to Export Data in a User-Defined File Layout

Use

You can set up user exits in different areas (for example, structure, block) within the file layout. If the change validation functions [Seite 879] provided do not meet your requirements, you can define customer user exits. In your user exits, you use the function modules included in the standard system to define your change validation function.

Features

You can use the function module within the file layout to enter data for the structures (NEW_ and OLD_ structures) that already exist in the export program for the change validation user exit. SAP recommends that you use this procedure in the following situations:

- You want to access the values for the exported files during change validation, although the system has not identified any changes.

- In the standard system, the change validation function uses the last exported payroll period for comparison. You also want to compare the values for a payroll period with the values for a different period.

- If you have flagged the Layout conversion directly after export attribute [Seite 875] in the interface format, the tables and field strings (NEW_ and OLD_ structures) still contain values. You can still use the function module to retrieve another comparison period for change validation or to run the conversion of the file layout.

The standard system contains the following function modules:

1. **HR_INTF_INITIALIZE**
   
   This function module must be called once before all other function module. You must enter the current program name for the Interface Toolbox.

2. **HR_INTF_IMPORT_L**
   
   This function module enters data in the OLD tables in the same way as the Import function (IMPRT with specification L).

3. **HR_INTF_IMPORT_O**
   
   This function module enters data in the OLD tables in the same way as the Import function (IMPRT with specification O).

4. **HR_INTF_IMPORT_CURRENT**
   
   This function module enters the current result in the NEW tables.
Structure Definition

Definition

The Interface Toolbox generates a corresponding field string in the second include for each defined structure. This then generates the conversion program for the file layout. You can call each field assigned to a structure, using `<structure name>-<field name>`.

Use

You have defined the STRUCTURE 01 structure. If you have assigned the NAME (constant length: 24) and GENDER (Constant length: 6) fields to the structure, the system generates the following coding:

```
DATA: BEGIN OF STRUCTURE_01,
    NAME(000024) TYPE C,
    GENDER(000006) TYPE C,
END OF STRUCTURE_01.
```

You can use the generated structure information for the User Exit After [Seite 968] structure function in the user-defined form routine. If the field content is redefined and the value 1 is returned, the Interface Toolbox will write the structure to the interface block buffer [Seite 971] without updating &VAR-VALUE (&VAR-VALUE contains the content of the current structure).

```
REPORT ZUSER_EXITS.
INCLUDE ZPCIFT01.
FORM EXAMPLE_STRUCTURE USING PAR_01
    PAR_02
    PAR_03
    PAR_04
    PAR_05
    PAR_06
    PAR_07
    PAR_08
    PAR_09
    PAR_10
    PAR_11
    PAR_12
    PAR_13
```
Structure Definition

PAR_14
PAR_15 "Input parameters 1 - 15"
RETURN_VALUE. "Return parameter"

RETURN_VALUE = '1'.
READ TABLE P0002 INDEX 1.
CONCATENATE P0002-VORNA, P0002-NACHN INTO STRUCTURE_01-NAME SEPARATED BY ', '.
IF P0002-GESCH = '1'.
  STRUCTURE_01-GENDER = 'MALE'.
ELSE.
  STRUCTURE_01-GENDER = 'FEMALE'.
ENDIF.
ENDFORM.

Legend

If James is the value for P0002-VORNA, Bond is the value for P0002-NACHN and 1 is the value for P0002-GESCH, then the following entry is made in the BLOCKS_OUTPUT interface format block buffer:

<table>
<thead>
<tr>
<th>SNAME</th>
<th>LENGTH</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>STRUCTURE_01</td>
<td>30</td>
<td>Bond, James MALE</td>
</tr>
</tbody>
</table>
Creating a File Layout

Prerequisites
If you want to access the fields in the interface format [Seite 841] when creating the file layout, you must use the following functions for the file layout objects:

- The Processing and Repeat functions for the Block object
- The Export function for the Structure object
- The Length and Content of the field for the Field object

Procedure
1. Choose the Configuration tab index.
2. In the Object to be processed field, enter the name of the new file layout.
3. Choose Create.
   You access the Create New File Layout dialog box.
4. In the Interface Format field, enter the name of the interface format whose export file you want to convert. Also enter a short text for the new file layout.
5. Choose Continue.
   The Change File Layout <Name> (Block View) screen appears.
6. Choose Create.
   You access the Create Block dialog box.
7. In the Block Name field, enter the name of the block and check the default value.
8. Choose Complete.
   The object tree for the block is displayed.
9. Select the appropriate function, for example, Processing or Repeat.
   You access the appropriate dialog box.
10. Make the necessary selection in the dialog box.
11. Place the cursor on the block name and choose Structure.
    You access the Create dialog box.
12. Choose Subordinate structure.
    You access the Create Structure dialog box.
13. In the Structure Name field, enter the name of the structure.
14. Click the plus sign to the left of the structure name.
    The tree structure for the structure is displayed.
15. Choose the appropriate function, for example, Export.
    You access the appropriate dialog box.
Creating a File Layout

16. Make the necessary selection in the dialog box.
17. Place the cursor on the structure name and choose Fields.
   
   You access the Create Field dialog box.
18. In the Field Name field, enter the name of the field.
19. Click the plus sign to the left of the field name.
   
   The tree structure for the field is displayed.
20. Select the appropriate function, for example, Length or Contents.
   
   You access the appropriate dialog box.
21. Make the necessary selection in the dialog box.
22. Save your entries.

Result:

You have created a customer file layout.
Generating the File Layout

Use
After creating a new file layout or modifying an existing file layout, you must generate the file layout.

If you make changes in the following areas, you must generate the file layout again:

- Interface format [Seite 841]
- Import macro for cluster data
- Data definition include [Seite 876]
- Change validation [Seite 879]
- Wage type processing [Seite 910]

Prerequisite
You must enter the following names in the Interface Toolbox before you generate the file layout.

- Name of the file layout program and the include
  You assign the names in the file layout using the File Layout Function program.
- Name of the data definition include

For more information on file layouts, see File Layout [Seite 954].

Activities
Generate the file layout [Seite 982]

See also:
Layout Conversion [Seite 983]
Generating the File Layout

Prerequisites
You have created a file layout.

Procedure
6. Choose the Configuration tab index.
7. In the File Layout field, enter the name of the file layout.
8. Choose Generate.

Result
The file layout has been generated.
Conversion with the File Layout

Use

Layout conversion converts the export file to another format that has been defined in the file layout. You use this function to run the conversion program.

Features

The following parameters can be used:

- **Input file**
  The name of the file to be converted, in other words the export file created by the export program.

- **Output file**
  The name of the output export file. The converted export file is written to this file.

- **Additional export files 1 to 4**
  The file names used if particular blocks are to be written to an additional file.

- **Append on export files**
  The Toolbox adds the specified file or files to the current conversion output.
  If you do not activate this parameter and the specified file(s) already exist, the system will overwrite the existing file(s).

- **Log**
  Detailed information on the conversion procedure.

- **Update**
  If the parameter is flagged, the system writes the output file to the TemSe file.
  If the parameter is not flagged, the system performs a test run.

Prerequisites

Before you can convert the layout, the Interface Toolbox must have successfully exported the data.

For more information on exports, see Export Program [Seite 942].

You must also generate the program for the file layout according to the definitions set for blocks, structures, and fields.
Conversion with the File Layout

For more information, see Generating the File Layout [Seite 981].

Activities

Convert the file layout [Seite 985]
Converting a File Layout

Prerequisites
1. The Interface Toolbox has successfully exported the data.
2. You have generated the conversion program for the file layout.

Procedure
1. Choose the Export tab page.
2. In the Export activities group box, select Conversion with file layout and enter the name of the file layout.
3. Choose Execute.
   The File Layout <name> dialog box is displayed.
4. In the Input and output files group box, enter the names of the files.
5. In the Options group box, enter the name of the required function.
   • Append on export files
   • Log
   • Update
6. Choose Execute.

Result
You have used the file layout to convert the file specified under Import-Export File. The converted export file is written to the TemSe file (Display TemSe File [Seite 951]).
File Format of Export File (SAP Standard)

If an error occurs when the TemSe file is displayed normally [Seite 951], the Toolbox displays the export file in an *unformatted* view.

This detailed information on the file format of the export file is required to trace and remove errors, or if you have created a customer program that is based on the SAP standard file layout.

**Definition**

The export file contains the data that generates the respective export program. The payroll results for each personnel number are grouped together and stored in this file.

The export file is structured so that it has a compact data format and can also be easily read automatically. The compact data format means that majority of data is displayed implicitly, not explicitly. It also ensures that information is saved with minimum redundancy.
Structure of an Export File

Definition

The export file consists of a sequence of bytes that can also be considered to be a sequence of commands in machine language. These commands consist of:

- Operator codes
- Operator parameters (operands)

Structure

Operator Code, Operator Parameter, and Operand

The first two bytes in a command contain the operator code. Several bytes follow the operator code and these form the operator parameter. The operator parameters represent the operands. However, there are also operators without operands.

The BOT operator (Begin operator for table) has two operands. The first operand is 10 bytes long, and the second is 6 bytes long. The first operand contains the table name, and the second operand contains the line number of the table entry.

Structure

An export file begins with a start sequence, the preamble. The preamble is followed by personnel numbers. The postamble constitutes the end sequence.

Preamble

The preamble shows the start of the export file. The operands in the preamble contain information on the export program (for example, creation date). The export file always starts with a preamble.

Personnel number

Each personnel number begins with a BOP operator (begin operator for personnel number). The payroll period that the BPE operator (begin operator period) introduces follows. Within the payroll periods there is the actual export data, which is grouped together in blocks. The EPE operator (end operator for personnel number) forms the end of the payroll period. The EOP operator (end operator for personnel number) is at the end of the personnel number.

Postamble

The postamble is at the end of the export file. The postamble begins with the BPO operator (begin operator for postamble), followed by an operand. The EPO (end operator for postamble) operator forms the end of the postamble.
Structure of an Export File

For more information on operators, see Operators for Export/Import Files [Seite 990].

See also:
Displaying Export Files Using Operator Blocks [Seite 989]
Display Export Files Using Operator Blocks

Definition
Each export file can be displayed as a sequence of operator blocks.

Structure
Each block is introduced by a begin operator and closed by the accompanying end operator. Between the begin and end operators there is a data section. This data section can also consist of a sequence of operator blocks.

The type of operator gives the operator block the following information:

- Number of operands
- Meaning of the operands
- Structure of the data section
- The structure of the data section is determined by the secondary file.

An export file can consist of the following operator blocks:

- Preamble block
- Personnel number block
- Payroll period block
- Postamble block

See also:
Creating the Export File [Seite 990]
Operators for the Export File

Definition

The structure of the export file is determined by operators and operands. A combination of individual operators define the results to be exported. The export file consists of a sequence of operator blocks. Each block begins with a begin operator and ends with an end operator. The type of operator determines how the data between the begin operator and the end operator is interpreted.

Structure

The operator is uniquely defined by the operator code. The operator code is 12 bytes long and contains a hexadecimal number.

The following operator codes are available:

- **Begin of preamble BPR - operator code 01** [Seite 992]
- **End of preamble EPR - operator code 02** [Seite 992]
- **Begin of secondary information BSC - operator code 17** [Seite 993]
- **End of secondary information BSC - operator code 18** [Seite 993]
- **Begin of personnel number BOP - operator code 05** [Seite 994]
- **End of personnel number EOP - operator code 06** [Seite 994]
- **Begin of payroll period BPE - operator code 07** [Seite 995]
- **End of payroll period EPE - operator code 08** [Seite 995]
- **Begin of table BOT - operator code 09** [Seite 996]
- **End of table EOT - operator code 0A** [Seite 996]
- **Begin of table entry BOE - operator code 0B** [Seite 997]
- **End of table entry EOE - operator code 0C** [Seite 997]
- **Begin of field string BOF - operator code 0D** [Seite 998]
- **End of field string EOF - operator code 0E** [Seite 998]
- **Begin of infotype BOI - operator code 0F** [Seite 999]
- **End of infotype EOI - operator code 10** [Seite 999]
- **Begin of wage type BOW - operator code 11** [Seite 1000]
- **End of wage type EOW - operator code 12** [Seite 1000]
- **Begin of postamble BPO - operator code 03** [Seite 1001]
- **End of postamble EPO - operator code 04** [Seite 1001]

See also:

Structure of the Secondary File [Seite 1003]
Begin Preamble BPR (01) / End Preamble (02)

Definition

Each export file starts with the preamble block. This block starts with the BPR operator, and ends with the EPR operator.

The **begin preamble operator** introduces the export file. This operator must be at the beginning of the export file.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name of export program</td>
<td>40</td>
<td>Character</td>
<td>ZPCIFRX0</td>
</tr>
<tr>
<td>2</td>
<td>User name</td>
<td>12</td>
<td>Character</td>
<td>TESTUSER0001</td>
</tr>
<tr>
<td>3</td>
<td>Export date</td>
<td>8</td>
<td>Date</td>
<td>19991013</td>
</tr>
<tr>
<td>4</td>
<td>Time of export</td>
<td>6</td>
<td>Time</td>
<td>150147</td>
</tr>
<tr>
<td>5</td>
<td>Period modifier</td>
<td>2</td>
<td>Numeric</td>
<td>01</td>
</tr>
<tr>
<td>6</td>
<td>Payroll year</td>
<td>4</td>
<td>Numeric</td>
<td>1999</td>
</tr>
<tr>
<td>7</td>
<td>Payroll period</td>
<td>2</td>
<td>Numeric</td>
<td>01</td>
</tr>
<tr>
<td>8</td>
<td>Version number</td>
<td>5</td>
<td>Numeric</td>
<td>00002</td>
</tr>
</tbody>
</table>

The **end preamble operator** closes the begin preamble operator. This operator has no operands.
**Begin of Secondary Information BSC (17)/End of Secondary Information ESC (18)**

**Definition**

Secondary information begins with the **BSC** operator and ends with the **ESC** operator.

Between the BSC operator and the ESC operator, there is a number of table entries and the actual table containing the secondary information.

The **begin secondary information operator** indicates that secondary information follows.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Number of table entries</td>
<td>6</td>
<td>Numeric</td>
<td>000016</td>
</tr>
<tr>
<td>2</td>
<td>Table of secondary information</td>
<td>from ABAP Dictionary</td>
<td>PPU12_SEC</td>
<td></td>
</tr>
</tbody>
</table>

The **end secondary information operator**, which has no operands, closes the begin secondary information operator.
Begin Personnel Number BOP (05) / End Personnel Number EOP (06)

Definition

In the export file, personnel number blocks follow the preamble block. These personnel number blocks start with the BOP operator and end with the EOP operator.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Personnel number</td>
<td>8</td>
<td>Numeric</td>
<td>00900100</td>
</tr>
<tr>
<td>2</td>
<td>Start date of first payroll period</td>
<td>8</td>
<td>Date</td>
<td>19990101</td>
</tr>
<tr>
<td>3</td>
<td>End date of last payroll period</td>
<td>8</td>
<td>Date</td>
<td>19990331</td>
</tr>
<tr>
<td>4</td>
<td>Number of payroll periods</td>
<td>2</td>
<td>Numeric</td>
<td>03</td>
</tr>
</tbody>
</table>

The end personnel number operator closes the begin personnel number operator.
Begin Payroll Period BPE (07) / End Payroll Period EPE (08)

**Definition**

The individual payroll periods in the payroll run are listed within the personnel number blocks. These block begin with the **BPE** operator and end with the **EPE** operator.

The **begin payroll period operator** indicates the beginning of a payroll period.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Start date of payroll period</td>
<td>8</td>
<td>Date</td>
<td>19990101</td>
</tr>
<tr>
<td>2</td>
<td>End date of payroll period</td>
<td>8</td>
<td>Date</td>
<td>19990131</td>
</tr>
<tr>
<td>3</td>
<td>Retroactive accounting indicator</td>
<td>1</td>
<td>Character</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>0=no RA period, 1=RA period</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Payroll type</td>
<td>1</td>
<td>Character</td>
<td>A: bonus accounting</td>
</tr>
<tr>
<td>5</td>
<td>Payroll ID</td>
<td>1</td>
<td>Character</td>
<td>1 to make distinction between several special payroll runs</td>
</tr>
<tr>
<td>6</td>
<td>Payroll area</td>
<td>2</td>
<td>Character</td>
<td>A1</td>
</tr>
<tr>
<td>7</td>
<td>Period modifier</td>
<td>2</td>
<td>Numeric</td>
<td>01</td>
</tr>
<tr>
<td>8</td>
<td>For-period</td>
<td>6</td>
<td>Character</td>
<td>199901</td>
</tr>
<tr>
<td>9</td>
<td>Sequence number for cluster IF</td>
<td>9</td>
<td>Numeric</td>
<td>00001</td>
</tr>
<tr>
<td>10</td>
<td>Sequence number, payroll result</td>
<td>5</td>
<td>Numeric</td>
<td>00001</td>
</tr>
</tbody>
</table>

The **end payroll period operator** closes the begin payroll period operator. This operator has no operands. It indicates that a payroll period has been processed.
Begin Table BOT (09) / End Table EOT (0A)

Definition

Table data begins with the BOT operator and ends with the EOT operator.

For each table entry there is an operator pair BOE and EOE between the BOT operator and the EOT operator. The secondary file defines the data between the BOE and EOE.

The second operand of the BOT operator specifies the number of table entries.

The **begin table operator** indicates that table data follows.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name of table</td>
<td>10</td>
<td>Character</td>
<td>RT</td>
</tr>
<tr>
<td>2</td>
<td>Number of table entries</td>
<td>6</td>
<td>Numeric</td>
<td>000016</td>
</tr>
</tbody>
</table>

The **end table operator** closes the begin table operator. This operator has no operands. It indicates that table data has been processed.
## Begin of Table Entry BOE (0B) / End of Table Entry EOE (0C)

### Definition

For each table entry there is an operator pair BOE and EOE between the BOT operator and the EOT operator. The secondary file defines the data between the BOE and EOE.

The second operand of the BOT operator specifies the number of table entries.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Line number for entry</td>
<td>6</td>
<td>Numeric</td>
<td>000001</td>
</tr>
</tbody>
</table>

The **begin table entry operator** indicates that table entry data follows.

The **end table entry operator**, which has no operands, closes the begin table entry operator. It shows that the table entry data has been processed.
Begin of Field String BOF (0D) / End of Field String EOF (0E)

**Definition**

The **begin of field string operator** indicates that field string data follows.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name of field string</td>
<td>10</td>
<td>Character</td>
<td>VERSC</td>
</tr>
</tbody>
</table>

The **end field string operator** closes the begin field string operator. This operator has no operands. It indicates that the field string data has been processed.
Begin of Infotype BOI (0F) / End of Infotype EOI (10)

Definition

The **begin of infotype operator** indicates that infotype data follows.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name of infotype</td>
<td>10</td>
<td>Character</td>
<td>P0006</td>
</tr>
<tr>
<td>2</td>
<td>Start date for infotype</td>
<td>8</td>
<td>Date</td>
<td>19990101</td>
</tr>
<tr>
<td>3</td>
<td>End date for infotype</td>
<td>8</td>
<td>Date</td>
<td>19990131</td>
</tr>
</tbody>
</table>

The **end of infotype operator** closes the begin infotype operator. This operator has no operands. It indicates that infotype data has been processed.
Begin Wage Type BOW (11) / End Wage Type EOW (12)

Definition

The **begin wage type operator** indicates that wage types follow.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Table name for wage type</td>
<td>10</td>
<td>Character</td>
<td>RT</td>
</tr>
<tr>
<td>2</td>
<td>End date of wage type</td>
<td>8</td>
<td>Date</td>
<td>19990131</td>
</tr>
</tbody>
</table>

The **end wage type operator** closes the begin wage type operator. This operator has no operands. It indicates that wage type data has been processed.
Begin Postamble BPO (03) / End Postamble EPO (04)

Definition

Each export file ends with the postamble block. This block starts with the BPO operator, and ends with the EPO operator.

The **begin postamble operator** is almost at the end of the export file. Only the number of employees whose data was exported and the end post operator come after this operator.

<table>
<thead>
<tr>
<th>No.</th>
<th>Operand</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Number of employees</td>
<td>6</td>
<td>Numeric</td>
<td>000019</td>
</tr>
</tbody>
</table>

The **end postamble operator** closes the begin postamble operator. This operator has no operands. This is the end of the export file.
Display of Export File - Formatted

The following structure is formatted so it is easier to understand.

```plaintext
BPR (01)   ZPCIFX0 TEST_USER_01 19990113 105402 01 1999 01 00002
EPR (02)
  BOP (05)   00900100 19990101 19990131 01
  BPE (07)   19990101 1999131 1
  BOI (0F)   P0002 19990101 19990131
    NACHN   Bond
    VORNA   James
    GESCH   1
EOI (10)
BOT (09)   BT 000001
  BOE (0B)   000001
    BANKL   67290010
    BANKN   123456789
    BETRG   +000500000
EOE (0C)
EOT (0A)
BOW (11)   RT 19990131
    LGART   /101
    BETRG   +00000000500000
EOW (12)
EPE (08)
EOP (06)
BPO (03)   000001
EPO (04)
```
Secondary Files

Definition

The secondary file contains information on each table object (tables, field strings, and infotypes) that you have assigned to the interface format. This is information that can be displayed when you edit the interface format by choosing the Information on table object function. The secondary file ensures that the export file can also be processed outside of the SAP System.

Structure

The secondary file, like the export file, can be found in the TemSe file. Each line in the secondary file contains specific information on a table object.

Line Format of Secondary File

<table>
<thead>
<tr>
<th>No.</th>
<th>Field</th>
<th>Length</th>
<th>Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name of table</td>
<td>10</td>
<td>Character</td>
<td>RT</td>
</tr>
<tr>
<td>2</td>
<td>Field name</td>
<td>10</td>
<td>Character</td>
<td>LGART</td>
</tr>
<tr>
<td>3</td>
<td>Data type</td>
<td>1</td>
<td>Character</td>
<td>D</td>
</tr>
<tr>
<td>4</td>
<td>Field length</td>
<td>6</td>
<td>Numeric</td>
<td>000008</td>
</tr>
<tr>
<td>5</td>
<td>Number of decimal places</td>
<td>6</td>
<td>Numeric</td>
<td>000000</td>
</tr>
<tr>
<td>6</td>
<td>Conversion indicator</td>
<td>1</td>
<td>Character</td>
<td>For internal use only</td>
</tr>
<tr>
<td>7</td>
<td>Conversion type</td>
<td>2</td>
<td>Numeric</td>
<td>For internal use only</td>
</tr>
<tr>
<td>8</td>
<td>Conversion modifier</td>
<td>6</td>
<td>Numeric</td>
<td>For internal use only</td>
</tr>
</tbody>
</table>

Data Types

<table>
<thead>
<tr>
<th>Data type</th>
<th>Meaning</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>Character</td>
<td>ABCD01</td>
</tr>
<tr>
<td>N</td>
<td>Numerical value</td>
<td>038472</td>
</tr>
<tr>
<td>D</td>
<td>Date in the form YYYYYMMDD</td>
<td>19990101</td>
</tr>
<tr>
<td>T</td>
<td>Time in the form HHMMSS</td>
<td>105453</td>
</tr>
<tr>
<td>V</td>
<td>Floating point number (with +/- sign)</td>
<td>+0003450</td>
</tr>
<tr>
<td></td>
<td>• 1 byte is the sign (+ or -)</td>
<td>-003746543</td>
</tr>
<tr>
<td></td>
<td>• The last bytes are the decimal places (according to the value in the Number of decimal places field.)</td>
<td></td>
</tr>
</tbody>
</table>
Secondary Files

The following example shows a characteristic section of a secondary file. The blank characters are represented by periods.

RT........LGART......C0000040000000000000000
RT........ANZHL......V000016000000210000000
RT........BETRG......V000016000000210000000
P0002.....NACHN......C0000250000000000000000
P0002.....VORNA......C0000250000000000000000

See also:
Example: Structure of the Secondary File (Formatted) [Seite 1005]
# Structure of the Secondary File (Formatted)

<table>
<thead>
<tr>
<th>Field</th>
<th>Data type</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>P0002-NACHN</td>
<td>C</td>
<td>20</td>
</tr>
<tr>
<td>P0002-VORDA</td>
<td>C</td>
<td>20</td>
</tr>
<tr>
<td>P0002-GESCH</td>
<td>C</td>
<td>1</td>
</tr>
<tr>
<td>BT-BANKL</td>
<td>N</td>
<td>8</td>
</tr>
<tr>
<td>BT-BANKN</td>
<td>N</td>
<td>9</td>
</tr>
<tr>
<td>BT-BETRG</td>
<td>V</td>
<td>10</td>
</tr>
<tr>
<td>RT-LGART</td>
<td>C</td>
<td>4</td>
</tr>
<tr>
<td>RT-BETRG</td>
<td>V</td>
<td>16</td>
</tr>
</tbody>
</table>
Generation of Secondary File

Use

The secondary file ensures that the export file can also be processed outside of the SAP System. The secondary file contains all information on the structure of the tables to be used, the field strings, and infotypes.

If you transfer the export file to a third-party payroll system that uses the SAP standard file layout in the Interface Toolbox, you must regenerate the secondary file after every change in the interface format.

If you use the import program, you must regenerate the secondary file.

If the third-party payroll system uses neither the unconverted export file nor the import program from the Toolbox, then it is not necessary to regenerate the secondary file.

Activities

Generate the secondary file [Seite 1007]
Generating the Secondary File

Prerequisites
You have created the export file for the personnel numbers selected from a payroll area.

Procedure
   You access the Generate Secondary File dialog box.
10. In the Interface Format and Secondary File fields, enter the names of your interface format and secondary file.

If you leave the Secondary File field blank, the secondary file will only be saved in the Interface Format (IF) cluster.

If you enter a name for the secondary file in the Secondary File field (using the naming conventions), a secondary file will also be saved in the TemSe file (Displaying the TemSe File [Seite 951]).

11. Choose Display.
12. Choose Execute.
13. Choose Generate.

Result
You have generated the secondary file that will be used to further process data from the SAP System.

You can then save the file to a PC by downloading it from the TemSe file.
Import Wage Types

Use

You use the *Import wage types* function to transfer wage types from a third-party system to the payroll results of the SAP System.


Features

The import transfers wage types for payroll from the third-party system to the R/3 System.

Activities

Run the Import [Seite 1009]
Starting the Import

Prerequisites
You have successfully run payroll in a third-party system.

Procedure
1. In the menu, choose Import wage types → Create IDocs.
   You access the IDoc Inbound Processing Via File screen.
2. In the Complete file name field, enter the name of the input file.
3. Choose Execute.
   The system message contains the number of created IDocs.
4. In the menu, choose File → Import wage types → Create IDocs.
   You access the Inbound Processing of IDocs Ready for Transfer screen.
5. Enter MANAGEREXTPAYROLL_INSERTOUT as the Message type and, if required, enter the Creation date and the Creation time.
6. Choose Execute.

Result
The wage types created in the third-party system are available for further processing in the interface tables of the SAP System.

You can then start payroll in the SAP System and perform the subsequent payroll activities:
- Create a remuneration statement
- Run posting to Accounting