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Payroll United States (PY-US) 

Payroll United States (PY-US) 
Purpose 
This component allows you to process payroll for employees in the United States, using data 
from SAP Personnel Administration and Benefits under a wide variety of configurations. You can 
also run payroll using a combination of SAP and third party products. The SAP Payroll system 
also offers a number of standard payroll reports. The Tax Reporter component allows you to 
generate all required state and federal tax forms, such as SUI reports and W-2s. Further reports 
can be generated using Ad Hoc Query in conjunction with an SAP Payroll Infotype.  

Implementation Considerations 
United States Payroll should be implemented in cooperation with the project team implementing 
other areas of SAP HR, particularly Personnel Administration. Since US Payroll uses an interface 
to a separate BSI TaxFactory database to calculate taxes, you need to consult with networking, 
database and Basis personnel during some parts of the implementation. 

Integration 
The Payroll component is integrated with other SAP HR components, such as Personnel 
Administration and Benefits. There are also interfaces to other SAP modules such as Financial 
Accounting and Controlling. 

Features 
SAP Payroll allows American businesses to run payroll for employees in all states. Requisite 
statutory reports, such as Federal forms 940, W-2, W-3, and all state SUI forms are also 
supported by the SAP system.  
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Payroll in the SAP System 
Purpose 
You can use this component to calculate the remuneration for work done for each employee. 

However, Payroll does not just involve the calculation of remuneration, but consists of a variety of 
processes that are becoming increasingly important due to the employer’s increased obligation to 
supply benefits and medical welfare. These benefits are products of: 

• Labor law 

• Tax law 

• Contribution law 

• Benefits law 

• Civil law 

• Reporting law 

• Information law 

• Statistics law 

Integration 
Payroll can be integrated in Personnel Administration, Time Management, Incentive Wages and 
Accounting: 

• Standardized data retention enables you to use master data and other payroll relevant data 
from Personnel Administration. 

• Time data, entered via Time Management, is automatically included in the Payroll and is 
valuated during the payroll run. 

• Data from the Incentive Wages component is used to calculate piecework wages and 
premium wages directly in Payroll.  

• Information on expenses and payables from Payroll is posted for accounting directly in 
Financial Accounting, and you assign the costs to the appropriate cost center. You can also 
control the financial system of third-party providers. 

Features 
The System calculates the gross and net pay, which comprises the individual payments and 
deductions that are calculated during a payroll period, and are received by an employee. These 
payments and deductions are included in the calculation of the remuneration using different wage 
types [Ext.]. 

After the remuneration payroll you can carry out various subsequent activities, for example, you 
can see to remuneration payment or the creation of various lists, and make evaluations. 
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Payroll Basics (PY-XX-BS) 

Payroll Basics (PY-XX-BS) 
Purpose 
The Payroll is based on an international payroll driver. This payroll driver was modified for each 
country. The country-specific payroll drivers take the statutory and administrative regulations of a 
country into account. 

Since the payroll driver has a modular structure, you can use the Customizing functions to 
quickly modify the payroll procedure to meet the particular requirements of your enterprise. 

Process Flow 
When you access Payroll, the payroll driver calls the accompanying payroll schema, which 
consists of a sequence of functions. For each activity, the individual functions import data from 
internal tables and payroll relevant files. 

Payroll is then performed as follows: 

1. The system updates the databases and imports the master data relevant to payroll. 

2. If Off-Cycle Payroll [Page 134] is to take place, the system deletes the internal table IT. 

3. The system imports the last payroll result. 

4. The system calculates the gross wage and considers the shift schedule, shift change 
compensation, and valuation bases. Any master data relevant to payroll is included in the 
calculation at this point. 

5. The system calculates the partial period factors, lump sums and salary elements, and 
cumulates the gross results. 

6. The system calculates the net remuneration and performs retroactive accounting if specific 
master data has been changed in previous payroll periods. 

Result 
After the payroll run, you can transfer the payroll results to Financial Accounting, or perform 
evaluations and create lists and statistics.  
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Payroll Driver 
Definition 
Special report for Payroll. SAP has developed country-specific payroll drivers, which are based 
on report RPCALCx0. With country-specific reports the penultimate character in the name refers 
to the country indicator (for example, D for Germany, F for France). 

Use 
Report RPCALCx0 can calculate periodic payments and also off-cycle payroll runs. However, this 
report does not include tax and social insurance data for net wage calculations. The country 
specific payroll drivers contain this data. 

Integration 
Calculation rules and other reports are stored in an accompanying schema [Page 30] which also 
contains the activities carried out by the payroll driver during payroll. All data is stored in internal 
tables [Page 32] and saved in files [Page 31] with a cluster structure. 

 

 

April 2001  29 



Payroll United States (PY-US)  SAP AG 

Payroll Schema 

Payroll Schema 
Definition 
The payroll schema contains calculation rules to be used by the payroll driver [Page 29] during 
payroll. SAP has developed country-specific schemas which are based on schema X000. With 
country-specific reports, the first character in the name refers to the country indicator (for 
example, D for Germany, F for France). 

Structure 
A schema consists of the following parts: 

• Initialization 

 
The system performs the following steps: 

– Updates the databases 

– Imports required infotypes 

• Gross calculation of pay 

 
The system performs the following steps: 

– Processes basic data and time data 

– Queries off-cycle payroll runs 

– Reads payroll account of the last period accounted 

– Processes time data and calculates the individual gross values 

– Performs factoring 

• Net calculation of pay 

 
The system performs the following steps: 

– Calculates net remuneration 

– Performs bank transfers 

Integration 
All data is stored in internal tables [Page 32]  and saved in files [Page 31] with a cluster structure. 
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Payroll Relevant Files 
Definition 
Payroll files contain data for payroll and payroll results. 

Structure 
The system requires the following files for payroll: 

• Pnnnn (nnnn = number of the infotype) 
The Pnnnn files contain data that has been entered in the respective infotypes for an 
employee.  

• PCL1 
The PCL1 file contains primary information, in other words, data from the master data 
and time recording systems. 

• PCL2 
The PCL2 file contains secondary information, in other words, derived data and all 
generated schemas. 

Integration 
When you start payroll, the system imports the relevant master data from the Pnnn files (for 
example, basic pay and tax class) and imports the time data from the PCL1 file to the IT table. 
The system imports the payroll results from the previous month from table ORT (for example, to 
form averages). The system processes this data and saves the payroll results and generated 
schemas in the PLC2 file. 
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Internal Tables 

Internal Tables 
Definition 
Internal tables store data during payroll. The system imports data to these tables and used them 
to calculate new data. This data is then also saved in internal tables. 

Structure 
At the start of the payroll run, the system reads the values from the results tables to the old 
results table (ORT). Data from the previous period is, therefore, available in the current payroll 
period. 

The most important internal tables are: 

• Input table (IT) 
Table IT contains data that can be edited. The table exists only during processing.  

• Output table (OT) 
Table OT contains the results of an activity. These results are written to the input table 
for further processing. The table exists only during processing.  

• Results table (RT) 
Table RT contains the results of the period for which payroll has been run. The system 
saves this data in the PCL2 file in cluster RX. 
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Payroll Control 
Use 
This function is used to control Payroll. 

 
During Payroll the master data for the personnel numbers to be included in the 
payroll run can not be changed for the past or present, for example. 

You should not perform payroll, when master data is being processed for the 
personnel numbers for which payroll should be run. 

Scope of Function 
• Payroll Control Record [Page 60] 

• Payroll Area [Page 40] 

• Payroll Status [Page 36] 

• Payroll Period [Page 41] 

 

 

April 2001  33 



Payroll United States (PY-US)  SAP AG 

Payroll Control Record 

Payroll Control Record 
Definition 
Payroll object that is important for the payroll run, and which contains all the information on a 
payroll area [Page 40]. 

Use 
The payroll control record [Ext.] has the following functions: 

• It locks the personnel numbers, for which payroll should be run, against master data changes 
that affect the payroll past or present. 

• It locks the payroll for the period during which payroll-relevant changes are made to the 
master data for the personnel numbers being processed. 

• It makes the following information available for the system: 

− What is the next payroll period for which regular payroll should be run? 

− Up to what date is retroactive accounting [Page 48] carried out? 

− What status does the payroll currently have? (for example, Released for Payroll or Check 
Payroll Results)? 

When you carry out a payroll run, the system automatically changes the payroll status in the 
payroll control record. You can also change the status manually under Payroll → Tools → Control 
Record.  

Structure 
The control record contains the following information: 

• Payroll area 

• Payroll status 

• Payroll period 

• Earliest possible retroactive accounting period [Page 50] 

• Last change made to the control record 

 
When you create the control record in your live system, please note the following: the 
payroll period that you enter at the start of the live payroll run must be 1 period lower 
than the period with which you want to perform the live payroll run for the first time. 

 
You want to carry out the first payroll run in period 5 1999. In the payroll control 
record, you must enter 4 1999 as the period. If you set the payroll control record for 
the first payroll run to status Released for Payroll, the system increses the period by 
1 and payroll is run for period 5 1999. 
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Payroll Status (Infotype 0003) 

Payroll Status (Infotype 0003) 
Definition 
Infotype in which data on the Payroll status and Time Management status is stored. 

 
For example, the system stores the date of the last payroll run performed for the 
employee in the Payroll Status infotype (0003). 

The system can flag an employee that was rejected in the payroll run. 

Use 
The system automatically creates this infotype when the employee is hired. In general, the 
system updates the infotype and writes the changes to the payroll past. 

Structure 
You can change the payroll status of an individual employee using Payroll/Retroactive 
Accounting and Time Evaluation. 

 
It is only worthwhile making such changes for a few exceptional cases. For more 
information, see Changing The Payroll Status [Ext.]. 
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Editing the Payroll Status 
Use 
The Payroll Status infotype (0003) is usually updated by the system. An exception is manual 
editing of an employee’s payroll status. The following possibilities exist to edit the infotype. 

• Editing Master Data 

Here, you can edit part of a field. 

• Enhanced Editing 

Here, you can edit all fields. 

Prerequisites 
Editing Master Data 
You are authorized to edit master data. 

Enhanced Editing 
During the enhanced maintenance of the Payroll Status infotype (0003), you can exclude 
employees from the payroll run and delete employees from the payroll correction run [Page 72]. 
Since such changes are particularly critical, you need special authorization for extended editing 
of the infotype. If you do not have this authorization, contact your system administrator. 

Procedure 
Editing Master Data 
1. Choose Human Resources → Personnel Management → Administration → HR Master Data 

→ Maintain. 

2. Enter the personnel number and infotype 0003, and select . 

You can edit the following fields: 

− Earl. Pers. RA (Earliest Possible Personnel Retroactive Accounting Date) 

− Run Payroll Up To 

− Do Not Account After 

− Personnel Number Locked 

 
For more information on this field, see locked personnel numbers [Page 62]. 

− Earl. Pers. RA (Earliest Possible Personnel Retroactive Accounting Date Time 
Evaluation) 

Enhanced Editing 
1. Choose Human Resources → Payroll → <Country> → Tools → Maintain Payroll Status. 
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The Change Payroll Status screen appears. 

2. Enter the personnel number and choose . 

You can enter data in all fields of the Payroll Status (0003) infotype. 
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Locked Personnel Numbers 
In the Payroll Status infotype (0003) [Page 36] you can exclude an employee from the payroll run 
by flagging the Pers.no. locked field. 

You can not set these lock indicators for the current period in the following situations: 

• if payroll has already been completed for the current payroll period. 

• if the employee has already been paid in the current payroll period. 
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Payroll Area 
Definition 
A group of employees for whom payroll should be run together, and at the same time. 

Use 
You can perform the Payroll separately for different employee groups, using different payroll 
areas [Ext.]. This is necessary if the payroll period [Page 41] is not the same for all employee 
groups.  

 
Salaried employees in your enterprise receive their salary at the end of the month. 
Hourly wage earners receive their remuneration in the middle of the subsequent 
month. 

 
You can also group together all employees in one payroll area that should not be 
included in the payroll run. To do so, you create a payroll area for which you do not 
select the Run payroll indicator. 

When you run payroll, you must specify the payroll area in the payroll driver [Page 29] selection 
screen. The payroll area has the following functions: 

• In the Payroll Period block it is used to determine the exact payroll period. 

• In the Selection block it is used to select the personnel numbers that should be grouped 
together during the payroll. 

Structure 
The payroll area contains the following information: 

• Payroll area text 

• Period parameters [Ext.] 

• Run payroll until indicator 

• Date modifier [Ext.] 

Integration 
Every payroll area needs its own payroll control record [Page 60]. 
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Specific Payroll Dates 
Definition 
Exact period in which the regular payroll is carried out. 

 
14-day payroll periods have been defined for your enterprise. The first period begins 
on 01 January. If you carry out Payroll for payroll period 09, the specific payroll date 
is 01 through 15 May. 

Use 
In regular payroll, payroll is always run for a payroll period. The system determines the specific 
payroll dates. It also checks if retroactive accounting [Ext.] is necessary. 

 
In the case of Off-Cycle-Payroll [Ext.] the specific payroll period can be a day. In the 
case of bonus accounting, the payment date that you use to start the off-cycle payroll 
is both the start date and the end date of the payroll period. The system generates 
the payroll result for this day. 

For further information see Off-Cycle-Activities [Page 130]. 

In the case of regular payroll, the method used to define the specific payroll period is dependent 
on whether you are carrying out a test run or a live payroll run: 

• For a test run, you generally enter the specific payroll period 

• For a live payroll run, the system uses the value that is in the payroll control record [Page 60] 
as the current payroll period 

In the payroll driver [Page 29] selection screen, enter the payroll area [Page 40] for which you 
want to run payroll. The system derives the exact start and end date of the payroll for this payroll 
area, using the following parameters, which are stored in the payroll area or in the payroll control 
record: 

• In the payroll area 

− Period parameters [Page 42] 

− Date modifier [Page 43] 

• In the appropriate payroll control record 

− Payroll period [Page 44] 
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Period Parameters 
Definition 
A two-digit numerical parameter that determines the time interval for which payroll is run for a 
payroll area.  

 
If you assign the period parameter [Ext.] 01 to the payroll area Salaried Employee, 
payroll is run monthly for this payroll area. If you assign the period parameter 03 to 
the payroll area Industrial Employee, payroll is run weekly for this payroll area. 

Use 
The SAP standard system contains period parameters for all the common payroll periods for 
different countries. However, if you need an individual period parameter for your system, specify 
this in Customizing for Payroll under Environment → Payroll Organization → Define Period 
Parameters  [Ext.].  

In Customizing for Payroll under Environment → Payroll Organization → Check Payroll Area 
[Ext.] you assign a period parameter to every payroll area in your system. In this way you 
determine how frequently regular payroll should be run for this payroll area. You can assign the 
same period parameter to all payroll areas, if the payroll periods are the same for all employees 
in your enterprise. 

In your system, you must use Report RPUCTP00 (Generation of Payroll Periods) to generate the 
payroll periods for every period parameter that you have assigned to a payroll area. In this way 
you determine the concrete start and end date for each period, as well the payday. You generate 
the payroll periods in Customizing for Payroll under Environment → Payroll Organization → 
Generate Payroll Periods [Ext.]. 

When you start payroll, enter the payroll area for which you want to run payroll on the payroll 
driver selection screen. The system derives the payroll period from the period parameter you 
assigned to this payroll area. 

Integration 
If you want to specify different date specifications, for example different paydays, for a period 
parameter, then you also have to define a date modifier [Page 43]. 
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Date Modifier 
Definition 
Differentiator that you use to determine different paydays for different employees for whom 
payroll is run with the same periodicity. 

 
Payroll is run monthly in your enterprise. The payday is the 15th of the month for 
industrial employees and the 25th for salaried employees. Since the payroll 
periodicity (monthly) is the same for both groups of employees, the system requires 
two date modifiers [Ext.] as differentiators to be able to determine different paydays.  

Use 
You determine the date modifiers in Customizing for Payroll under Environment → Payroll 
Organization → Define Date Modifiers [Ext.]. 

You assign a date modifier to every payroll area in your system in Customizing for Payroll, under 
Environment → Payroll Organization → Check Payroll Area [Ext.]. 

• If you use the same payday for all payroll areas, assign the SAP standard modifier to all 
payroll areas. 

• If you use different paydays for different payroll areas, assign different date modifiers to 
these payroll areas that you have created for your enterprise. 

In your system, you must generate the payroll periods separately using Report RPUCTP00 
(Generation of Payroll Periods) for every combination of period parameters and date modifiers 
that you have assigned to a payroll area. You generate the payroll periods in Customizing for 
Payroll under Environment → Payroll Organization → Generate Payroll Periods [Ext.]. 

When you start payroll, enter the payroll area for which you want to run payroll on the payroll 
driver selection screen. The system recognizes, by means of the date modifier that you assigned 
to this payroll area, whether different date specifications exist for this payroll area. 

Integration 
A date modifier always refers to a period parameter [Page 42].  
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Payroll Period 
Definition 
The time interval for which the payroll is regularly performed. In the abstract sense the payroll 
period [Ext.] refers to the interval during which payroll is regularly performed. For example, 
weekly or monthly payroll periods. In the concrete sense the payroll period describes a specific 
period with start and end dates. For example, the (monthly) payroll period from 01 through 31 
October. 

Use 
You specify the concrete payroll periods, with a period number, start and end date and pay day, 
for your enterprise in Customizing for Payroll under Environment → Payroll Organization →  
Generate Payroll Periods [Ext.] , using Report RPUCTP00 (Generation of Payroll Periods). The 
generation of the payroll periods is dependent on the period parameter and the date modifier. 
The report enters the start and end date of every payroll period in Table T549Q (Payroll Periods) 
and enters the payday in Table T549S (Personnel Date Specifications Per Payroll Period). 

 
The system automatically creates the payday for all countries when you generate 
the payroll periods. However, the payday only has a role to play in some countries. 
For example, if the bank transfer day of the original payroll run (as opposed to a 
retroactive accounting run) is important for tax purposes. 

In some countries the payday is printed on the pay check. The employee can cash 
the check from this date. 

When you start payroll, enter the payroll area for which you want to run payroll on the payroll 
driver selection screen. Using the payroll control record for this payroll area, the system 
determines the next period for which payroll is to be run. The procedure is as follows: 

1. The system reads the current value that is contained in the Payroll Period field of the payroll 
control record. 

2. Using this value the system reads the Previous Payroll Period field in Table T549Q (Payroll 
Periods). 

3. The system determines which period follows this previous period in accordance with Table 
T549Q. 

This subsequent period is the current payroll period. 

4. The system also determines the concrete start and end date of the payroll period in Table 
T549Q. 

You have created this date specification with Report RPUCTP00. 

Finally, the system reads the relevant infotypes using the date specifications for the start and end 
dates. 

Integration 
The payroll periods are defined in the SAP System and are dependent on the period parameter 
[Page 42]. 

44  April 2001 



 SAP AG Payroll United States (PY-US) 

  Payroll Period 

 
In your enterprise, the first payroll period for the year 2000 begins on 01 January. 
Depending on the period parameter you use as a basis, for example weekly or 
monthly, the payroll period 05 2000 can have the following meaning: 

• Weekly period parameter: Period 05 2000 = 31 January-06 February 2000 

• Monthly period parameter: Period 05 2000 = 01-31 May 2000 
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Period Number 
Definition 
A two-digit numerical parameter that, together with the date, clearly identifies a concrete payroll 
period [Page 44]. 

 
The period number [Ext.] 08, together with the year 2000, denotes the eighth payroll 
period in the year 2000. It can depend on the system settings, for example, the 
calendar month August or the week from 14 through 20 February. 

Use 
In the payroll control record, the system continuously increases the period numbers of the payroll 
periods for a fiscal year. Every time you set the status of the payroll control record to Release for 
Payroll, the period number is increased by one. In this way the system identifies the current 
payroll period. At the start of a new fiscal year the period number is reset to 01. 

The period number that a payroll period contains depends on the following criteria that you enter 
when generating the payroll periods. 

• Period parameter (for example, weekly or monthly) 

• Start of fiscal year 

In most countries the fiscal year starts on 01 January. However, it starts on 06 April in 
the United Kingdom. 

• Indicator for determining the period number 

This indicator specifies the payroll period date the system should use to determine the 
period number. 

− Start date 

− End date 

− Payday 

Example 
Example 1 
You make the following specifications when generating the payroll periods: 

• Period parameter monthly 

• Start of fiscal year 01 January 

• Determine the period number depending on the end date of the payroll period. 

In this case, the payroll period from 01 through 31 July, for example, has the period number 07 in 
your system. 

Example 2 
You make the following specifications when generating the payroll periods: 
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• Period parameter weekly 

• Start of fiscal year 01 January 

• Determine the period number depending on the payday 

The payday should be four days after the end of the period. 

In this case, the payroll period from 01 through 07 January, for example, has the period number 
02 in your system. The period from 25 through 31 December of the previous year has the period 
number 01, because the payday for this period is 04 January.  
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Retroactive Accounting 
Use 
If you change the master or time data for an HR master record for a period for which payroll has 
already been run, the old payroll results must be checked in the next regular payroll run and the 
payroll run must be repeated. The system automatically creates a retroactive accounting run in 
the payroll past. 

To ensure that not every change triggers a retroactive accounting run, the changes are checked 
for retroactive accounting relevance. This ensures that only those changes that require a 
correction of the payroll results, trigger a retroactive accounting run. Moreover, the system 
determines the retroactive accounting limit for which retroactive accounting can take place, from 
the Payroll Status infotype (0003) and the payroll control record. 

Scope of Function 
The retroactive run is limited by basic data: 

• Payroll past 

The payroll past includes all periods for which you have already run and exited payroll.  

• Retroactive accounting limit 

The retroactive accounting limit determines the date up to which you may change master 
and time data in the payroll past, and, in the case of a retroactive run, the earliest date to 
which the system can run retroactive accounting. The retroactive accounting limit always 
refers to personnel numbers. 

 
You can change the retroactive accounting limit in the following ways: 

• for an employee in the Earl. Pers. RA (Earliest Possible Personal 
Retroactive Accounting Date) field in the Payroll Status infotype (0003) 

• for a payroll area in the Earliest Possible Retroactive Accounting Period field 
in the payroll control record (see Change Earliest Possible Retroactive 
Accounting Period [Page 51]) 

The system uses the following values to determine the retroactive accounting limit: 

− for each payroll area, from the earliest possible retroactive accounting period that is 
stored in the corresponding payroll control record 

− for each employee, from the earliest possible personal retroactive accounting date 
that is stored in the Payroll Status infotype (0003) 

− for each employee, using the hiring date of the employee 

The system uses these values to select the most recent date. 

• Retroactive accounting relevance 

You can determine the retroactive accounting relevance either per infotype or per 
infotype field. To determine which infotypes or fields are relevant to retroactive 
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accounting, see Customizing for Personnel Administration under Customize Procedures 
→ Infotypes → Define Fields Relevant for Retroactive Accounting [Ext.]. 

 
If you edit infotypes that are relevant to retroactive accounting, you should take note 
of some particular features. For more information, see Payroll-Relevant Maintenance 
of HR Master Data [Ext.]. 

• Retroactive accounting recognition 

If you maintain an infotype that is relevant to retroactive accounting and its validity period 
overlaps with the payroll past, the system enters the start date of the changed infotype in 
the Earliest MD Change (Earliest Master Data Change since Last Payroll Run) field of 
the Payroll Status infotype (0003). During the next payroll run the system automatically 
performs retroactive accounting up to this date. Afterwards, the system deletes the entry. 

 
The Earliest MD Change field can also contain a date that occurs in the future. This 
date is entered in an off-cycle payroll run [Ext.]. 

If you have made at least one change in the payroll past that is relevant to retroactive 
accounting, the system checks the entry in the Earliest MD Change field and determines 
the date to which the retroactive accounting run must take place. 
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Earliest Possible Retroactive Accounting Period 
Definition 
The earliest period for retroactive accounting is the payroll period furthest in the past for which 
you can run retroactive accounting. This is stored in the payroll control record for the payroll area. 

Use 
This period is determined by your company. You can specify, for example, that retroactive 
accounting for the previous year is not possible after a particular date in the current year. 
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Changing the Earliest Possible Retroactive Accounting 
Period 

 
You can only change the earliest possible retroactive accounting period for a payroll 
area, whilst exiting payroll [Page 79]. 

1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll → Tools 
→ Control Record  in the SAP menu. 

2. Enter the payroll area for which you want to change the earliest possible retroactive 
accounting period and choose Change. 

 
The earliest possible retroactive accounting period can only be changed, after you 
have set payroll status to Exit payroll and before you save the payroll control record. 

3. In the Earliest retroactive accounting period field, enter your new earliest retroactive 
accounting period and save your entries. 
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Transaction Codes for Payroll 
In Payroll, you can use the following transaction codes: 

Bases 
Transaction Activity 

PC00_M99_CLSTR Display Payroll Results 

PC00_M99_CALC Payroll Driver (International) 

PC00_M99_ABKRS Specify a payroll area 
PC00_M99_CLSTPC Display PC Cluster: Personal Calendar 

PC00_M99_TLEA Leave Overview 

PC00_M99_TLEA30 Batch-Input: Annual Leave 

PC00_M99_CPRC Access Payroll Calendar 

PC00_M99_MOLGA Specify a personnel country grouping 

PC00_M99_CLJN Payroll Journal - International 

PC00_M99_DLGA20 Use of Wage Types in Payroll 

PC00_M99_UDIR Restore the Payroll Results Directory 

PU00 Delete Personnel Data 

PU01 Delete Current Payroll Result 

PU03 Change Payroll Status 

PU22 Archive Data  

PU30 Wage Type Copier 

PU95 Edit Wage Type Groups and Logical Views 

PU96 Edit Wage Type Groups 

PU97 Edit Logical Views 

PU98 Assign Wage Types to Wage Type Groups 

PUOC_xx (xx = Country Code) Off-Cycle Workbench 

PEST Maintenance of Process Model 

PUST HR Process Workbench 

Pay scales:  

PC00_M99_U510 Simple Std Pay Increase for Indirectly Valuated WTs 

PC00_M99_IRTF Enhanced Std Pay Increase (Indirect and Direct WTs) with 
Batch Input 
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PC00_M99_ITUM Pay Scale Reclassification acc.to Age or Pay Scale 
Membership Period 

Third party  

PC00_M99_URMA Acknowledgement Report for Third Party Remittance 

PC00_M99_URMU Update of Remittance Tables from TemSe-Object 

Forms 
PC00_M99_CEDT Remuneration Statements 

PDF7 Delete Form in Customer Client 

PDF8 Copy Form from SAP Client to Customer Client 

PDF9 Copy Form within Customer Client 

PC00_M99_CLGA00 Wage Type Statement 

PC00_M99_CLGV00 Wage Type Distribution 

PC00_M99_CKTO Payroll Accounts 

PDF0 Conversion Report for Remuneration Statement Forms 

PDFA Conversion of Payroll Journal Forms 

Transfer Activities 
PC00_M99_CIPE Posting to Accounting: Create Posting Run 

PC00_M99_DKON Posting to Accounting: Wage Type Assignment - Display 
G/L Accounts 

PC00_M99_CIPC Posting to Accounting: Search for Payroll Results not Posted 

PC00_M99_URMR Reconciliation of Transfers 

PC00_M99_URMW Maintain Wage Types According to Assignment to HR Creditors 

PC00_M99_URMD Undo Third-Party Remittance Runs 

PC00_M99_URMP Create Third-Party Remittance Posting Run 

PC00_M99_CMLI0 Cash Breakdown List (International) 

PC00_M99_CDTA Preliminary Program- Data Medium Exchange for Several Payment 
Runs 

Tools 
PE04 Editor for Calling Functions and Operations 

PE03 Editor for Calling Features 

PE02 Editor for Calling Personnel Calculation Rules 

PE01 Editor for Calling Personnel Calculation Schemas 

PE51 Call the Form Editor 
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PU12 Interface Toolbox 

PDSY HR-Documentation Maintenance 
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Loading Employee Data from a Non-SAP System into 
SAP Payroll 
Purpose 
If portions of your employee population are paid outside of the SAP payroll system, it may be 
necessary to transfer payroll information between systems. For example, if an employee 
transfers mid-year from a department being paid on a non-SAP system to another department 
who is paid on SAP, it would be necessary to import into SAP all year-to-date payroll results for 
this employee. This ensures that taxes are calculated correctly for this employee and makes 
earnings information available for tax reporting in SAP. 

Prerequisites 
You have access to a program that converts employee data on your non-SAP system to a format 
that is compatible with SAP Payroll.  

Process Flow 

Define period,
wage type,
and tax/ arrears
tables

Payroll Driver (USA)

...
Schema

Execute
payroll using
Schema ULK9

Run payroll data
conversion program

Transferred data
is stored in the
SAP payroll
cluster

RESULT:

 

ULK9

1. Define pay period, wage type, and tax/arrears tables in the Transfer Old Data chapter of the 
Payroll USA Implementation Guide (IMG).  

2. Run a payroll data conversion program to populate the period, wage type, and tax/ arrears 
tables with the employee data to be imported into SAP Payroll from the non-SAP system. 

The conversion program required for this process is not delivered with the standard 
SAP system. 

3. Execute the payroll driver using Schema ULK9. The payroll driver extracts the data stored in 
the pay period, wage type, and tax/ arrears tables and stores this data in the SAP payroll 
results cluster. This data is then available for use in tax reporting. When you run the Tax 
Reporter: Preparation step at the end of a reporting period, the system automatically 
incorporates data for transfer employees in tax reporting for this period. See Transfer In / Out 
in Tax Reporter [Ext.] for further information. 
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Result 
Employee data from the non-SAP payroll system is transferred into SAP and is stored in the 
payroll results cluster.  
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The Payroll Process 
Purpose 
The payroll program is run at a specific point in time, not only to calculate an employee’s basic 
remuneration but also any special payments, overtime payments or bonuses that must be 
effected for the period in question. 

Prerequisites 

• From the SAP Easy Access screen, choose Human Resources → Payroll → <Country> → 
Settings → Set Payroll Area.  

• When Releasing the Payroll Run [Page 68] specify for which payroll area the payroll should 
be run. 

• If you want to execute a payroll run for several payroll areas at the same time, you must 
release each payroll area individually- release individually [Page 69]. 

Before you start this process, you have to specify for which payroll area(s) payroll should be run. 
You have the following options: 

If you do not want to perform payroll for an employee, you must use the Lock Personnel Number 
[Page 62] function. 

Before you start the payroll run for all employees, you can run a Payroll Simulation [Page 63] for 
individual employees. 

Process Flow 
The status of the Payroll Control Record [Page 60] is automatically updated with every step that 
is carried out during payroll. 

1. You release one or several Payroll Areas [Page 40] for payroll. 

2. You run payroll. 

The system calls up a country-specific payroll program. It determines the current payroll 
period from the payroll control record and performs payroll using the values you entered 
in the payroll program. 

In general, you do not carry out these steps on-line but rather as a background job. 

3. You check whether payroll has run correctly, or determine where errors have occurred. 

If the payroll has not run without errors, the system display error messges indicating 
where the errors have occured. If desired, you can obtain a detailed payroll log. 
However, we recommend that you only create a payroll log if you simulate the payroll 
run. 

The system increases the period number in the payroll control record of the respective 
payroll area by 1. You cannot change the master and time data for the personnel 
numbers belonging to this payroll area if it affects the payroll past or present. Changes 
affecting the future are still possible.  

If necessary, you can set the status of the payroll to Check Payroll Results during this 
phase. This way you make sure that no changes are made to payroll-relevant data which 
could affect the payroll past or present. In addition, the payroll area in question is locked 
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for payroll. However, during this phase you can simulate the payroll for individual 
employees to understand exactly how the errors originated, by means of the payroll log. 

If you want to carry out a spot check on the payroll results after a successful payroll run, 
there is a report available which reads the stored payroll results. The report allows each 
employee to see the contents of all internal tables containing payroll results. This allows 
you to check all partial results for a payroll run. In this way you can determine whether 
the system ran the payroll in accordance with your expectations, for example, for an 
employee for whom you made complex changes to the master data. 

4. You correct master or time data for personnel numbers which contain errors, and which the 
payroll program could not process. 

During the payroll run, the System flags the Payroll Correction field in the Payroll Status 
infotype (0003) for all rejected personnel numbers. When you correct master or time data 
for a personnel number, this field is also flagged. These personnel numbers are grouped 
together in a list under Matchcode [Ext.] W (Payroll Correction Run). In a payroll 
correction run, that is a payroll run with matchcode W, payroll only takes place for the 
corrected personnel numbers. 

5. You release payroll again. 

6. You perform a payroll correction run. 

If there are a lot of employees stored in Matchcode W (Payroll Correction Run), you carry 
out this step as a background job in the same way that you carried out the Start Payroll 
step. If you only have to run payroll again for a few employees, you can carry out this 
step on-line. 

7. You simulate the posting to Accounting. 

Under certain circumstances errors can occur, which mean you must change the payroll-
relevant master and time data again. If, for example, a cost center was entered for some 
employees and it has been deleted in the interim, the system will note this as an error 
during the posting simulation. Then set the payroll status to Release for Correction once 
again, and correct the master data for the employees in question. This will cause these 
personnel numbers to be automatically stored in Matchcode W (Payroll Correction Run). 
Next, carry out another payroll correction run and simulate the posting to Accounting 
again. 

8. You exit payroll. The personnel numbers for the payroll area can be processed again. 

The payroll period does not change. 

 
You can only exit payroll when the payroll has run successfully for all personnel 
numbers in the selected payroll area. This means that payroll is finished for all of the 
personnel numbers in the payroll area, including the rejected personnel numbers, 
and the payroll period is complete. 

Result 
You have run payroll for all the personnel numbers in a payroll area or in several payrol areas. 

You can carry out the following steps in the payroll: 

• Create a Remuneration Statement [Page 498] 
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• Wage and salary payments 

Wage and salary payments differ from country to country. You can find country-specific 
information under Payroll <Country> → Subsequent Activities → Wage and Salary 
Payments. 

• Posting to Accounting [Page 525] 
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Payroll Control Record 
Definition 
Payroll object that is important for the payroll run, and which contains all the information on a 
payroll area [Page 40]. 

Use 
The payroll control record [Ext.] has the following functions: 

• It locks the personnel numbers, for which payroll should be run, against master data changes 
that affect the payroll past or present. 

• It locks the payroll for the period during which payroll-relevant changes are made to the 
master data for the personnel numbers being processed. 

• It makes the following information available for the system: 

− What is the next payroll period for which regular payroll should be run? 

− Up to what date is retroactive accounting [Page 48] carried out? 

− What status does the payroll currently have? (for example, Released for Payroll or Check 
Payroll Results)? 

When you carry out a payroll run, the system automatically changes the payroll status in the 
payroll control record. You can also change the status manually under Payroll → Tools → Control 
Record.  

Structure 
The control record contains the following information: 

• Payroll area 

• Payroll status 

• Payroll period 

• Earliest possible retroactive accounting period [Page 50] 

• Last change made to the control record 

 
When you create the control record in your live system, please note the following: the 
payroll period that you enter at the start of the live payroll run must be 1 period lower 
than the period with which you want to perform the live payroll run for the first time. 

 
You want to carry out the first payroll run in period 5 1999. In the payroll control 
record, you must enter 4 1999 as the period. If you set the payroll control record for 
the first payroll run to status Released for Payroll, the system increses the period by 
1 and payroll is run for period 5 1999. 
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Locked Personnel Numbers 
In the Payroll Status infotype (0003) [Page 36] you can exclude an employee from the payroll run 
by flagging the Pers.no. locked field. 

You can not set these lock indicators for the current period in the following situations: 

• if payroll has already been completed for the current payroll period. 

• if the employee has already been paid in the current payroll period. 
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Simulating Payroll 
Use 
You can simulate payroll for individual employees before performing the regular payroll run for all 
the employees in your enterprise. This is, for example, a good idea, if you have made complex 
changes to an employee’s master data, which may lead to far-reaching changes in his or her 
payroll results. In this way, you recognize sources of errors in time to make corrections before the 
regular payroll run. You can even simulate payroll for individual employees at any time during the 
regular payroll process, in order to trace the cause of any errors. 

 
Is it not necessary to simulate payroll for all employees before every regular payroll 
run. You can also make corrections at any time during the process of the regular 
payroll run [Page 57]. 

Scope of Function 
A simulation run corresponds to a regular payroll run with the following restrictions: 

• The results of a simulated payroll run are not saved on the data base. You can view and print 
the results in the payroll log. 

• The system does not lock any master data. 

• The current payroll period in the payroll control record is not changed. 

• The steps Release payroll and Exit payroll do not apply. 

Activities 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll → 

Simulation in the SAP menu. 

You access the initial screen of the payroll program. The Test Run (No Update) indicator 
is set and cannot be changed.  

2. Enter the necessary data and choose Execute. 
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Displaying the Payroll Log 
Use 
The payroll log gives you clear detailed information on the payroll run and it's 
results. It is divided into different levels that you can display depending on the 
amount of detail required. 
The General data level gives information on the processed data and shows the 
payroll schema used by the system. The Successful personnel numbers and 
Rejected personnel numbers include processing of the schema for each 
personnel number. This expands the Rejected personnel numbers level. 
However, you can also create and save your own view variants. You can find 
more information under creating and processing display variants for the payroll log [Page 
67]. 

 
If you run payroll in a background operation [Page 96], you should not switch on the 
log display as the spool might "overflow". The system still prints data on the schema 
used, the personnel numbers rejected, and the statistics that appear as the last main 
level in the log. 

Scope of Function 
• In the display we differentiate between the log tree and the actual log that you find under 

Settings → Detailed view.  

• The color legend under Utilities gives information on the levels that the log tree displays and 
the log is divided into. 

• Navigation in the log tree. 

To display lower levels, click on the structure node belonging to the level that you wish to 
open. To display all levels behind a higher level, place your cursor on the relevant level 
and choose Expand.  

• Navigation in the log tree. 

To display the actual log, call the detailed view of the log by double clicking on the 
Payroll log in the log tree or on the level of the log that you wish to display. 

• You can search in the payroll log [Page 66] for certain terms, for example, for a wage type 
name. 

• For documentation on functions, personnel calculation rules and schemas select the relevant 
object and choose Information. 

• Old log 

If you use customer functions with their own logs, you can display these logs by clicking 
on the Old log pushbutton. 
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You can not use this pushbutton to switch to the log display that was valid until 
Release 4.0. 
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Searching in the Payroll Log 
Use 
In the payroll log, you can search for errors or use the search to find out what 
happened during the process. You can, for example, trace the processing of a 
wage type in the payroll process. 
You can either search in the log tree or in the detailed view of the log. 

Prerequisites 
You are in the Display log tree screen. 

Procedure 
Searching in the Log Tree 
1. In the standard function bar, choose . 

2. Enter a search term. 

3. Specify if you want to search in the complete log tree or only in the nodes of the log tree that 
are currently expanded. 

4. Choose  Search. 

The system places the cursor on the first line containing the search term. 

Searching in the Detailed View of the Log 
1. Choose Settings → Search in log and make the entries required. 

− If you search according to wage type, select Also search tables. 

− If you want to display the path that you must choose in the log tree to get to the search 
term, select Detailed display of hit. 

2. In the application function bar, choose . 

3. Enter a search term, restrict the search area, for example, to certain personnel numbers and 
choose . 

A list of hits is displayed. 

4. Choose one or more hits and choose . 

The search terms are displayed in context.  

− You can expand the displayed levels individually. To expand all levels, choose . 

− To display processing within a personnel calculation rule, place your cursor on the 
relevant line and choose , or display the rule by double clicking on it. 
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Creating and Processing Display Variants for the Payroll 
Log 
Use 
You can create and save variants to display the log and the log tree in a certain way. In this way 
you can, for example, specify that certain levels of the log tree are already expanded. In the 
standard system, the display of rejected personnel numbers is always expanded. 

Prerequisites 
You are in either the Display log tree screen or the Detail view of log screen. 

Procedure 
1. Choose Settings → Log tree. 

2. In the Log Tree Settings dialog box, define a view variant on the tab pages and choose 
Enter. 

The log tree is displayed in accordance with your settings.  

3. Depending on whether your display variants should only apply for the log tree, or if they 
should also apply for the detailed view of the log, you proceed in the following way: 

− If you only want to specify the log tree display in your variant, choose Settings → Save 
as variant. 

− If you also want to specify the detailed view display in your variants, proceed in the 
following way: 

a. Choose Settings → Detailed view. 

b. On the tab pages in the Detail View Settings dialog box, define a view variant and 
choose Enter. 

c. Choose Settings → Save as variant. 

Result 
You can display the log tree and the detailed view in the saved display variants. You have the 
following options: 

• When simulating or executing payroll, you specify your display variant in the field Display 
variant for log in the selection screen of the payroll program. 

• First of all, you create the log and then define your display variants in the Display log tree 
screen. Choose Settings → Get display variant. 

To delete a variant, choose Settings → Delete display variant and double-click on the variant you 
want to delete. 
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Releasing Payroll 
Procedure 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll → Tools 

→ Release Payroll  in the SAP menu. 

2. Specify the payroll area for which you want to release payroll and choose Continue . 

If you have already specified the payroll area using Settings → Set payroll area, the 
system releases payroll for this payroll area. 

Result 
You can run payroll [Page 70] for this payroll area. 
The system has increased the period number in the payroll control record for the 
payroll area by 1. The payroll control record is used to lock the personnel 
numbers in the payroll area for changes to the master and time data reflecting 
the past and present. 
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Releasing Several Payroll Areas 
Use 
If you want to execute a payroll run for more than one payroll area at the same time, you must 
release each payroll area individually. The easiest way to do so is to use the relevant payroll 
control record for the payroll result. 

Procedure 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> →  Tools 

→ Control Record  in the SAP menu. 

You access the initial screen of the payroll control record. 

2. Enter the payroll area for which you want to release payroll and choose Change. 

3. Set the payroll status to Released for payroll and save the payroll control record.Return to 
the initial screen of the payroll control record. 

4. Repeat steps 2 to 4 until you have released all the necessary payroll areas. 

 
Proceed in the same way to correct [Page 73], check [Page 75] or exit [Page 79] 
payroll for several payroll areas, 

Result 
You can perform payroll for all the payroll areas that you have released for payroll. 
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Running Payroll 
Prerequisites 
You have released [Page 68] the payroll area or areas for which you want to run payroll. 

 
You usually perform this step as a background job. For more information, see payroll 
in a background operation [Page 96]. 

Procedure 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll → Start 

Payroll  in the SAP menu. 

You access the selection screen of the payroll program. 

2. Enter the data required. 

 
The current period indicator is set in the Payroll period group. Depending on the 
payroll area specified, the system reads the current period from the payroll control 
record. 

 
If you flag Display log, you get a detailed payroll log [Page 64] after the payroll run. 
However, this is usually only a good idea if you simulate payroll for individual 
employees [Page 63] and want to accurately trace the calculations made in the 
process. If you perform payroll as a background job, you should not create the log as 
vast quantities of data are created. 

The Test run (no update) indicator must not be flagged because otherwise the 
system will not save the payroll results. 

3. Choose Program → Execute or Execute and print. 

Result 
The system performs payroll (usually in the background). If errors occur, you will get a list with 
the relevant error messages after payroll. 

Use the error messages to check whether personnel numbers have been rejected or not 
selected. 

 
In some situations, it is difficult to exactly trace the origin of an error using only the 
error message. If you can not tell how the error occurred from the error message, 
you can simulate payroll for the relevant employee a second time and create a 
payroll log. The log enables you to exactly trace all calculations and makes 
determining the error a lot easier. 
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The R/3 System stores the employees rejected during a payroll run in Matchcode W. To check 
which employees are stored in Matchcode W, you can display the personnel numbers not 
included in the payroll run [Page 72]. 

 
If personnel numbers are rejected or not selected, you must not exit [Page 79] the 
payroll program. You must correct [Page 73] the master and time data for the 
relevant employee and finally perform a correction run [Page 74]. 

If you make a qualified advance payment [Page 90], you must not exit the payroll 
program. The system treats an advance payment in a similar way to a correction. 

 

April 2001  71 



Payroll United States (PY-US)  SAP AG 

Displaying Personnel Numbers not Included in the Payroll Run 

Displaying Personnel Numbers not Included in the 
Payroll Run 
Use 
The system saves all the personnel numbers for a payroll area, which could not be included in 
the payroll run for the current period due to incorrect data, in Matchcode W (Payroll Correction 
Run). You can use this procedure to check which employees are saved in Matchcode W. 

 
You can also find Matchcode W (Payroll Correction Run) on the selection screen of 
the payroll program under Search help. 

 
Personnel numbers rejected for other reasons (for example, because payroll has 
already been performed for them in the selected period) are not stored in Matchcode 
W. 

Procedure 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> →  Tools 

→ Control Record  in the SAP menu. 

2. Specify a payroll area and choose Display. 

3. Choose Goto → Incorrect Pers. Nos. (incorrect personnel numbers). 

Result 
The system shows all the personnel numbers for the payroll area that were rejected in the payroll 
run due to incorrect data. 

 

72  April 2001 



 SAP AG Payroll United States (PY-US) 

  Correcting Payroll-Relevant Master and Time Data 

Correcting Payroll-Relevant Master and Time Data 
Prerequisites 
You have run payroll [Page 70], resulting in errors. 

Procedure 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll 

→ Corrections  in the SAP menu. 

The system sets the payroll status for the payroll area to Released for correction. Master 
and time data processing for the personnel numbers in the payroll area has been 
released again. 

 
If you want to set the payroll run for several payroll areas to Released for correction, 
it is easier to use the payroll control record to do so. To do so, proceed as when 
releasing several payroll areas [Page 69]. 

2. Choose Human resources → Personnel management → Administration → HR master data 
→ Maintain. 

3. Correct the relevant infotypes. 

Result 
The system has saved all employees for which you have changed payroll-relevant master or time 
data in this correction phase of payroll in Matchcode W (Payroll correction run). 

After you have completed the corrections, release payroll [Page 68] a second time. The 
personnel numbers in the payroll area are again locked for past and future changes to the master 
and time data. 

Finally, you perform a payroll correction run [Page 74]. If errors occur a second time, repeat 
these steps until payroll has been performed for all personnel numbers and Matchcode W is 
empty.  

 
You can only end the payroll run when Matchcode W no longer contains any 
personnel numbers. 
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Performing a Payroll Correction Run 
Prerequisites 
The system has stored personnel numbers not included in the payroll run [Page 72] in 
Matchcode W (Payroll Correction Run). You have performed corrections [Page 73] for the 
relevant employees and finally released [Page 68] payroll a second time. 

 
If only a few employees are saved in Matchcode W (Payroll Correction Run), perform 
this step on-line. If it was not possible to perform payroll for many employees or if 
you have made corrections for many employees, you can perform the correction run 
as a background job. For more information, see payroll in a background operation 
[Page 96]. 

Procedure 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll → Start 

Payroll  in the SAP menu. 

You access the selection screen of the payroll program. 

2. Specify a payroll area and choose Search help. 

3. Select Matchcode W (Payroll Correction Run). 

The Restrict value area dialog box appears. 

To further restrict the value area, you can specify an individual personnel number or an 
interval of personnel numbers. Only the personnel numbers corresponding to these 
values are selected from the payroll correction run. 

If you do not want to further restrict the value range, all the personnel numbers from the 
payroll correction run are selected for payroll. 

6. Choose Continue. 

7. Choose Program → Execute or Execute and Print or Execute in Background. 

Result 
The system only performs payroll for the personnel numbers that were saved in Matchcode W 
(Payroll Correction Run). 
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Checking the Payroll Results 
Use 
After a successful payroll run, you can check the payroll results for your employees on a random 
basis. This can, for example, be recommended for employees for whom you have made a 
complex change to the master data. 

 
In such cases, we recommend that you simulate [Page 63] the payroll run for the 
relevant employees before starting payroll for all the employees. In this way, you 
recognize possible sources of errors in time and can make corrections before the 
payroll run. 

You can check the payroll results for an employee using the report Displaying the Payroll Results 
[Page 80] (H99_DISPLAY_PAYRESULT). You can use this report to display the contents of all 
tables in which the system has saved data for the employee’s payroll result. 

Prerequisites 
You have run payroll [Page 70] for one or several payroll areas. 

Procedure 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll 

→ Check result  in the SAP menu. 

The system locks the payroll program for the payroll area and prevents master and time 
data relevant to payroll from being processed. This prevents a new payroll run from 
being performed or master and time data relevant to payroll from being changed. 

 
if you want to check the payroll run for several payroll areas, it is easier to use the 
payroll control record. To do so, proceed as when releasing several payroll areas 
[Page 69]. 

2. Choose Tools → Display results. 

You access the initial screen of the report Display Payroll Results. 

3. Enter the necessary data and choose Enter. 

The system displays a list of the selected personnel numbers. 

4. By clicking on a personnel number, access the list of accompanying payroll results. 

5. By double-clicking on a payroll result, call the list of tables in which data for this payroll result 
is stored. 

6. By double-clicking on a line, call the contents of the table that you wish to check. 

Result 
You have checked in detail whether payroll was performed correctly for one or more employees. 
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Simulating a Posting Run 
Use 
We recommend that you simulate a posting run both before and after completing payroll. In this 
way, you can recognize posting-relevant errors in the payroll results early on, and avoid errors 
when creating a live posting run. 

You can repeat simulation of posting runs as often as you require, as this does not, unlike 
creating a live posting run, lead to the payroll results being selected. 

You have two options for simulating a posting run: 

• Creating a test run without posting documents (limited check). The system performs the 
following activities: 

− It selects the payroll results. 

− It determines the posting-relevant information and the wage types to be posted. 

− It determines the symbolic accounts and the employee grouping for account 
determination. 

In this way, the system creates individual items, which, unlike the posting documents for 
a simulation run, are not saved. The system finally checks if the balance of these 
individual items is equal to zero for each payroll result. 

• Creating a simulation run with posting documents (complete posting). The system performs 
the following activities: 

− It creates a posting run and marks it as being a simulation run. For this reason, the 
system does not post the posting documents for this posting run. 

− The posting documents are put through the same checks as the posting documents from 
a live posting run. 

Simulating A Posting Run before Finishing Payroll 
Before completing payroll, you should create a simulation run to recognize posting-relevant 
errors in the payroll result early on. If you do not want to create a simulation run at this stage, you 
should at least create a test run. 

Simulating A Posting Run after Finishing Payroll 
After finishing payroll, you should create a simulation run in order to check the posting 
documents (this may have to be approved by Accounting). Remove any possible causes of 
errors and repeat creation of the simulation run, until technically correct posting documents with 
the right contents are created. You should only create a live posting run at this point in time. 

Procedure 
You proceed as described in creating a posting run [Page 568]. When doing so, bear the 
following special feature in mind: 

• If you want to create a test run, enter the value T in the field Document creation type (in the 
Run attribute group box).  
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• If you want to create a simulation run, enter the value S in the field Document creation type 
(in the Run attribute group box).  

 
If you want to have a complete log of a number of personnel numbers (selected for 
test purposes) that is easy to keep track of, set the Display log indicator in the Run 
attribute group box. We advise you against creating a complete log for a larger 
number of personnel numbers. Even if you do not set the Display log indicator, the 
system produces a log if there are errors for the personnel numbers affected. 

Result if Successful 
In the case of test runs, the system displays a detailed log if you have set the Display log 
indicator in the step Create posting run. If you have not set the Display log indicator, the system 
displays statistics for the evaluated personnel numbers. 

In the case of simulation runs, the system creates a posting run and marks it as a simulation 
run. This prevents the accompanying posting documents being posted. The simulation run gets 
the status Documents created and is saved. The accompanying posting documents get the 
status created. An index is created for all processed payroll results. This ensures that the origin 
of a document item can be retraced, provided that the original payroll result has not been 
replaced as the result of a correction run. For more information, see Displaying Revision 
information [Page 584] 

Result if Unsuccessful 
In the case of test runs, the system displays a log containing the relevant error messages. 

In the case of simulation runs, various errors can occur: 

• If an error occurs when selecting or processing the payroll results for individual employees, 
the system rejects the incorrect personnel numbers and does not include them in the 
document. The log contains a relevant error message. 

• If an error occurs when creating the document, a relevant error message appears in the 
document display after the document has been created. The posting run gets the status 
Documents incorrect. The accompanying posting documents get the status incorrect. 

• Certain situations in which an error occurs (for example, rejection of all personnel numbers) 
can lead to no documents being created. In this case, the log contains the comment No 
documents created. The posting run gets deleted status. 

 
Delete the simulation runs you no longer require to avoid creating unnecessarily 
large amounts of data. For more information, see deleting the posting run [Page 580] 
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Exiting Payroll 
Prerequisites 
You have made all corrections [Page 73]. If you have made a qualified advance payment [Page 
90], you have run payroll for all the wage and salary elements. 

Procedure 
From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll → Exit 
Payroll  in the SAP menu. 

 
When you exit payroll, payroll is finished for all the personnel numbers in the payroll 
area and the payroll period is complete. 

 
If you want to exit the payroll run for several payroll areas, it is easier to use the 
payroll control record. To do so, proceed as when releasing several payroll areas 
[Page 69]. 

If you exit payroll using the payroll control record, you can simultaneously change the 
earliest possible retroactive accounting period for the accompanying payroll area. 
You use this date to specify until which date in the past it is possible to change 
master and time data for the employees in this payroll area and until which date the 
payroll program accounts retroactively for a retrospective change in master and time 
data. 

As long as you have not performed the payroll run without errors, it is not a good 
idea to change the earliest possible retroactive accounting period. For this reason, 
you can only make entries in this field in the payroll control record after you have 
chosen End of payroll and before you save the payroll control record. 

Result 
You have finished payroll for the current payroll period. The personnel numbers for the payroll 
area can be processed again. 

 

April 2001  79 



Payroll United States (PY-US)  SAP AG 

Displaying Payroll Results 

Displaying Payroll Results 
Use 
You can use report H99_DISPLAY_PAYRESULT to display the payroll results for any personnel 
numbers. 

Integration 
• You can access the display or maintenance of HR master data (Goto → HR Master Data → 

Display/Maintain) 
• By selecting Tables → Loans → Display, you can also include loan wage types in the 

display. In this way report H99_DISPLAY_PAYRESULT replaces the report RPCLSTLO 
(Printout of Loan Results) 

Scope of Function 
• You can display the contents of all tables and field strings for any payroll cluster. 
• You can temporarily save the selection of tables to be displayed, reducing the calling time. 
• Archived payroll results are also displayed. 

Selection 
You can display the payroll results for several personnel numbers by choosing Multiple Selection. 
The system displays all the payroll results, for which the start of the for-period [Ext.] or the end of 
the in-periods [Ext.] come before the date specified. 

Output 
The personnel numbers entered so far are displayed on the left side of the screen. The formatted 
name from the Organizational Assignment infotype (0001) is displayed as a default. To display 
the sortable first and last names from the Personal Data infotype (0002), choose the First and 
Last Name pushbutton in the SAP list viewer (ALV) toolbar. 

The symbol behind every name in the Results column shows if there are results available in the 
selected period. 

  Results exist 

  No results exist 

  You have no authorization to display personnel numbers 

Information on the personnel numbers and country-specific information is displayed in the SAP 
list viewer (ALV).  
• Overview of all the payroll results for a personnel number (cluster CU) 
• Overview of payroll results tables 
• Preselection of payroll tables 
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• Inconsistencies that occur when reading the infotypes and the CU cluster for a personnel 
number 

The contents of the payroll tables are printed in the form of the payroll log in a list. 

You can perform the following activities using the report H99_DISPLAY_PAYRESULT: 
• Displaying the personnel numbers in the SAP list viewer (ALV) Grid Control 

− By choosing , you can delete the current personnel number from the selection of the 
displayed personnel numbers. 

− By choosing , you can delete all personnel numbers from the selection of the 
displayed personnel numbers. Choose All. 

• Overview of all the payroll results for a personnel number [Page 82] (Cluster CU) 

Activities 

− By selecting Personnel number → Name → Formatted last name/first and last name, you 
can switch between the various ways of displaying the names  

− If the selection of current personnel numbers has gone missing (for example, because of 
a column selection), you can repeat this selection by choosing . 

− You can save your own personal standard layout that is used at the start of every 
program for this overview. There is also a default layout for the relevant country-specific 
fields for every country.  If you have not saved a standard layout, the system selects the 
default layout based on the personnel number and the country. 

− You can use the following functions for both the overview of the payroll results and the 
overview of payroll tables: 
• By choosing , you can save a line selection until you leave the program. 
• By choosing , you can delete the saved line selection.  
• You can redisplay a saved line selection by choosing . 

• Overview of the payroll results tables [Page 83] 
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Displaying the Payroll Results for a Personnel Number 
Prerequisites 
You are in the Display Payroll Results screen. 

Procedure 
1. In the Personnel number field in the Selection group, enter the personnel number or 

personnel numbers, for which you want to display the payroll results. 

2. By making an entry in the All results from field , you can also specify the Valid from date for 
the displayed payroll results. 

3. Choose . 

Result 
The selected personnel numbers are displayed on the left of the screen. If you want to display an 
overview of all the personnel numbers for one of the selected personnel numbers, select the 
personnel number. The payroll results are displayed on the right of the screen. 

You can directly display or process the HR master data for the selected personnel numbers using 
the path Goto → HR master data → Display or Goto → HR master data → Maintain. 

For the displayed payroll results, you can now display the relevant tables [Page 83]. 
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Displaying the Overview of Tables for a Payroll Result 
Prerequisites 
You are in the Display Payroll Results screen and have displayed the payroll results for a 
personnel number. 

 
If you have already saved a certain selection of tables for a payroll result, this 
selection is automatically displayed when you select a payroll result by double-
clicking on it. The system then no longer displays the overview of tables for a payroll 
result. 

Procedure 
1. Select a payroll result and choose . 

2. The system displays an overview of all the tables that are relevant for this payroll result and 
the number of entries in the table. 

 
Only the tables that are relevant for the respective country for the employee are 
included in the overview of a payroll result.  

You can also display tables that do not contain any entries for the selected payroll 
results. If you also want to display these tables, choose Tables → Empty tables → 
Display.  

Result 
The system displays an overview of the tables for a payroll result. You can now display the 
contents of the displayed tables. 
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Displaying the Tables for a Payroll Result 
Prerequisites 
You are in the screen Display Payroll Results and have displayed the overview of tables for a 
certain payroll result for a personnel number. 

Procedure 
Select one of the displayed tables and choose . You can also select several tables. 

You access the screen Tables/field strings of payroll result and see the contents of the selected 
table for the relevant payroll result. 

Result 
You can print this table by choosing List → Print. 

You can search for certain character chains in the table by choosing Edit → Find. 

 

84  April 2001 



 SAP AG Payroll United States (PY-US) 

  Error Search for Several Personnel Numbers: Example 

Error Search for Several Personnel Numbers: Example 
Use 
You suspect that there are inconsistencies in the payroll results for the personnel numbers 
232323 and 454545.  

Procedure 
1. Display the tables in which you suspect there are errors for the personnel number 232323. 

You notice values that you also want to check for the personnel number 454545 in the tables 
Work Place Basic Pay (WPBP) and Payment Information (BT). 

2. Select both tables and choose . 

3. Enter the personnel number 454545 and double-click on the payroll result for which you want 
to display tables WPBP and BT. 

Result 
The tables required are displayed without you having to select them again. 
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Deleting the Last Payroll Result 
Use 
If you have performed payroll for an employee who should not have been 
included in the payroll run or for whom payroll should have been run differently 
(for example, if the system has performed a payroll run too far in the past), you 
can delete these payroll results. You can only delete the last payroll result. 

 
To correct errors that occur during payroll, you must not delete the payroll results for 
the respective employee. Instead, proceed as described in correcting payroll-relevant 
master and time data [Page 73]. 

Prerequisites 
You can only delete a payroll result in the following cases: 
• The employee’s master data are no longer processed. 

• Payment was not yet arranged for the employee. 

• If you are working in a live system, the payroll control record for the payroll area to which the 
employee belongs should not yet have the status End of payroll. 

Procedure 
1. From the SAP Easy Access screen, choose Payroll → Payroll  <Country> → Payroll → Tools 

→ Problem Solving → Delete Payroll Result  in the SAP menu. 

2. Enter the personnel number and choose Execute. 

A list of all payroll results generated during the last payroll run is displayed. If payroll has 
only been run for the current period, the list contains only one entry. If the system has 
performed a retroactive accounting run [Page 48], the list contains several entries. 

3. Choose Delete and confirm the system’s query. 

Result 
The system performs the following activities: 
• The current payroll result is deleted. The previous payroll result becomes the current payroll 

result.  

If retroactive accounting runs were linked to the deleted payroll results, all the payroll 
results that were affected by this retroactive accounting run will be reset to the original 
status. That means that these payroll results get the status indicator A instead of the 
status indicator P that they acquired through retroactive accounting. 

• The Payroll Status infotype (0003) is updated accordingly. 

• The deletion of the payroll result is saved in a log, the application log. You can use the 
application log to display the deleted payroll results [Page 88]. 
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Displaying Deleted Payroll Results 
You can check whether payroll results have been deleted, which payroll results have been 
deleted, and who deleted them.  

Procedure 

1. Choose transaction SLG1. 

The Evaluate application log screen appears. 

2. In the Object field, enter HRPU. 

3. In the Time Restriction group box, enter dates and times to determine the period you want to 
check. 

4. Choose Program → Execute. 

A list of payroll results deleted during the specified period is displayed. The list displays 
the deletion date and the administrator who has deleted the payroll result. 

5. Select an entry from the list. 

6. Choose Goto  → Display messages. 

Further details are displayed for the selected entry.  
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Advance Payments 
Use 
The SAP System differentiates between qualified and unqualified advance payments. 

Qualified Advance Payments 
With qualified advance payments, payroll takes place for some of the payroll elements in the first 
payroll run, and is transferred if necessary. The payroll run is not ended. Instead, it receives the 
Payroll Correction status. During the correction phase, you enter more payroll elements. In the 
subsequent payroll runs you carry out payroll for these remaining payroll elements and transfer 
them to your employees. The payroll program only finishes when accounting has been performed 
for all payroll elements. 

Unqualified Advance Payments 
Employees may receive an advance salary payment prior to the payroll run. In this case, only the 
employee’s master data is imported for the transfer. No payroll run is performed. Wage types 
entered in the following infotypes are taken into account: 

• External Bank Transfers infotype (0011) 

• Recurring Payments and Deductions infotype (0014) 

• Additional Payments infotype (0015) 

The transfer is effected gross for net, since there is no payroll run to calculate deductions such as 
taxes and social insurance contributions. Net accounting for the advance payment takes place 
during the payroll run, which is performed later. This type of advance payment is known as an 
advance payment on the basis of master data. The payroll run takes place at the end of the 
payroll period. 

An unqualified advance payment is independent of the payroll period and is therefore considered 
a period-independent activity.  

 

April 2001  89 



Payroll United States (PY-US)  SAP AG 

Qualified Advance Payments 

Qualified Advance Payments 

Use 
Make a qualified advance payment to carry out payroll and to transfer some of an employees 
payments during the current payroll period. Payroll and transfers occur several times within a 
payroll period.  

 
An employee should receive the basic payments during the current period. Bonuses for overtime 
or holiday payment should be calculated and paid later. 

Released for payroll
Period  05.1998

Released for
correction
Period  05.1998

Released for payroll
Period  05.1998

End of payroll run
Period  05.1998

1st payroll run

Payroll result
Table of bank transactions
/559 ... 20.05.1998 15:29:13

Pre. program
DME
(1st payment )

2nd payroll run

Payroll result
Table of bank transactions

/559 ... 20.05.1998 15:29:13

/558 ... 31.05.1998 16:45:03

Pre. program
DME
(2nd payment)

 
The following procedure takes place if you carry out payroll for an employee’s basic payments in 
the first payroll run and for their bonuses in the second run: 

First Payroll Run 

• The Transfers wage type (1559) is found in the Bank Transactions (BT) table of the 
payroll cluster along with amount to be transferred from the basic payments. 

Second Payroll Run 

• In the payroll run the System compares the amount to be transferred from all the 
payments with the Transfers wage type (1559), which was formed in the first payroll run. 
The System determines the difference between both the transfer amounts and from this 
it forms the Payment of the Balance wage type (1558). 

Integration 
To transfer the amounts in connection with the payroll run, you start the preliminary program 
Data Medium Exchange (RPCDTAx0) by choosing the menu path Payroll →Bank Transfer.  
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First Transfer Run: 
The Indicate Transfers indicator must be set. The Transfer wage type (1559) is then marked as 
transferred with the date and time. 

Second Transfer Run: 
You restart the preliminary program Data Medium Exchange  The System recognizes the amount 
from the Transfer wage type (1559) which has a time stamp as being already transferred and 
only transfers the amount from the Payment of the Balance wage type (1558).  
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Making a Qualified Advance Payment 
Procedure 
1. Release the payroll run (see Releasing the Payroll Run [Page 68]). 

2. Run payroll (see Run Payroll [Page 70]) 

3. Make the advance payment ( see the respective country-specific section Wage and Salary 
Payments under Payroll <Country> → Subsequent Activities). 

4. Release the payroll for correction (see Correcting Payroll-Related Master Data and Time 
Data [Page 73] ) 

5. Enter the data for which you want to perform a payroll run separately. 

 
When an advance payment is created, a flag is set for transferred wage types. You 
cannot change the payee data and transfer amounts for these wage types, which are 
flagged as already transferred, during the correction phase. The employee would 
otherwise be rejected in the payroll run after the correction phase. 

6. Repeat steps 1 to 5 until you have entered all data for which split payroll must be performed. 

7. Exit the payroll run (see Exiting the Payroll Run [Page 79]) 

Result 
You have effected a qualified advance payment and have transferred and run payroll separately 
for several of an employee's payments. 
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Unqualified Advance Payments 

Use 
To give an employee an advance payment from the master data you carry out an unqualified 
advance payment. You can make advance payments without performing a payroll run. You 
simply start a transfer run, which reads the wage types from the following infotypes. 

• External Bank Transfers infotype (0011) 

• Recurring Payments and Deductions infotype (0014) 

• Additional Payments infotype (0015) 

Ext. Bank Transfers (Infotype 0011)
Infotype      Edit Goto Extras

Recur. Payments/Deds. (Infotype 0014)
Infotype       Edit Goto Extras

Additional Payments (Infotype 0015)
Infotype       Edit Goto Extras

Wage type Voluntary paymentM140

Amount 500,00 USD

Additional Payments

Personnel No. 1810

Payment 
data

Payment
medium
program

Advance
payment

 
During the transfer run a file is created, which contains the amounts assigned to these wage 
types. The file then creates transfer forms as transfer mediums for the bank or data mediums for 
data medium exchange. An unqualified advance payment is also known as an advance 
payment based on master data. 
The transfer advance payment is an estimation of net pay, without deductions. At a later point, 
usually at the end of the payroll period, a normal payroll run takes place to calculate the net 
amounts for the advance payment. The wage types, which were transferred as part of the 
advance payment, must be included in the ordinary payroll run, but should be considered as 
already paid. To ensure this, the wage types permitted for above-mentioned wage types must be 
coded accordingly. 

For more information on wage type coding [Ext.], see The Implementation Guide. 
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Creating a File for an Unqualified Advance Payment 
1. In the payroll menu choose Period-Independent → Reporting → Advance Payment. 

2. Enter the appropriate values in the fields and set the required indicators.  

3. Flag the Test parameter.  

  
This Set flag for transfers parameter prevents the wage type amount from being 
overwritten and transferred more than once when the payment run is repeated. The 
system calculates the amount of the difference for the respective wage type in the 
new payment run instead. 

4. Choose Program → Execute or Execute + Print or In Background. 

5. Use the log to check that transfer data is complete and correct. If necessary, correct the 
data. 

6. Deselect the Test parameter and run the report again (see step 8). 

  
A process log is displayed after the report has run. The program run date and an 
identification feature appear below the process log header. Please make a note of 
both data. The Run Date and Identification Feature parameters are queried in the  
Create Transfer Medium step. 

7. Lastly create your Payment medium [Ext.] 

You have effected an unqualified advance payment. 

 

 

 

April 2001  95 



Payroll United States (PY-US)  SAP AG 

Payroll in a Background Operation 

Payroll in a Background Operation 
Use 
This function enables you to automate either the whole or parts of the payroll process. For 
example, you can let the system execute the payroll program overnight so that you can check the 
results the next morning. 

Scope of Function 
You have the following options for running payroll in a background operation: 

• As a standard, you can schedule background jobs in the SAP System using the function 
System → Services → Jobs → Define Job. In this way you can let the payroll program you 
want to use to run payroll [Page 70] run in the background. You can find more information in 
the Background Processing [Ext.] section under Scheduling Background Jobs [Ext.]. 

• You can use report RPCSC000 (Scheduler for Parallel Accounting) to split the personnel 
numbers into small sets and run payroll in parallel [Page 97] in the background. In this way 
you reduce the payroll runtime. 

• Using the Payroll Calendar [Page 99] you can create and schedule payroll jobs. 

• You can use a Process Model [Page 102] to define the sequence of all programs that you 
need for payroll and its subsequent activities. When you start a Process [Page 107] that is 
based on such a process model, the system automatically executes the program in the 
sequence you defined. 
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Parallel Payroll for Personnel Numbers 
Use 
If you have to run payroll for a large number of personnel numbers in a payroll period, you can 
use report RPCSC000 to split the personnel numbers into several background jobs. The system 
then processes the background jobs simultaneously, using different application servers. 

Integration 
Report RPCSC000 is used exclusively in Payroll.  

Report RPCS0000 [Page 504] can also be used if you want to run parallel evaluations for payroll. 

Prerequisites 
You must note the following prerequisites: 

• The payroll program is called up using a symbolic name. You must define these symbolic 
names and the program names in view T596F.  

• You must define a suitable program variant in the programs assigned to the symbolic names. 

Scope of Function 
You specify the number of personnel numbers to be included in the background payroll run, or 
how many background jobs should be created. Report RPCSC000 selects the personnel 
numbers to be included in the payroll run from the database, and groups them together in 
background jobs. You can release each background job for payroll separately, or you can release 
them together.  

You can enter a short title for each payroll run. Each background job contains this short title and 
a sequential number. The short title can be helpful if you want to display the background jobs in 
the general job overview. 

The program displays a log after the payroll run has been completed.  
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Parallel Payroll for Personnel Numbers 
Prerequisites 
You have defined the symbolic names to be used to call the payroll program and the program 
names in table T596F. You must use the following naming conventions: the symbolic name starts 
with CALC and contains the country modifier (for example, CALC02). 

 
The system takes the first entry with the symbolic name into account and does not 
use the date in the table. 

You have defined a program variant in the payroll program that is assigned to the symbolic 
name. 

You are in the ABAP Execute Program screen. 

Procedure 
1. Enter Program RPCSC0000. 

2. Choose Execute. 

3. Enter the program and a variant. 

The system uses the payroll schema for the variant you have selected for the payroll run. 

4. Enter the number of personnel numbers to be included in the parallel payroll run, or enter 
the number of jobs for which the payroll run should be split. 

5. Choose one of the following steps: 

Program → Execute • 

• 

• 

Program → Execute + Print 

Program → Execute in Background 

Result 
The system performs payroll and prints a log. This contains the following information: 

• Date and time of the individual program steps 

• Error messages 

• Warnings 

• Overview of generated background processes 

You can clearly identify the jobs using the job numbers and the job names. 
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Payroll Calendar 
Use 
You can use the payroll calendar to create payroll jobs and follow how they are executed. The 
payroll jobs are grouped into tasks according to payroll areas. 

In Customizing for Payroll under Payroll Calendar the following settings must be made: 

• Define Schedule for Payroll Calendar [Ext.] 

Prerequisites 

• Specify Version for Payroll Driver [Ext.] 

Scope of Function 
The payroll calendar provides you with the following functions: 

• Job Scheduling: 

To create payroll jobs call the Scheduling of Payroll Jobs report (RPCPRC10) using this 
function. 

 
The documentation for the Scheduling of Payroll Jobs report describes how you 
create a payroll job. 

• Calendar: 

For example, in the calendar you can: 

− Change and Display Payroll Jobs and Tasks [Page 100] that have been scheduled 

− display payroll jobs and tasks that have already been processed 

− schedule tasks, that you have already created using the job scheduling function, to occur 
at a later date 
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Changing and Displaying Payroll Jobs and Tasks 
1. From the SAP Easy Access screen, choose Human Resources → Payroll → <Country> → 

Tools → Payroll Calendar in the SAP menu. 

You access the initial screen of the payroll calendar. 

2. Enter a Shedule and choose Calendar. 

You access the Payroll Calendar <Schedule> screen. The calendar is displayed in two 
parts: 

− The upper section contains a calendar for three months, beginning with the month of the 
selected start date. Weekends, public holidays and the days for which payroll jobs are 
scheduled have a different background color. 

− The tasks for all dates are displayed in the lower part of the screen. These tasks contain 
the scheduled payroll jobs for a payroll area. 

The following functions, amongst others, are available on the Payroll Calendar 
<Schedule> screen. 

Function Path 

Display payroll jobs that have already been 
carried out. 

Settings → Hist.data on 

Hide payroll jobs that have already been 
carried out 

Settings → Hist.data off 

Display payroll jobs for a task Double-click on the task 

Display payroll jobs that are scheduled for a 
certain day, week or month 

Double-click on the day, the week number or 
the name of the month 

Schedule tasks, that you have already created 
using the job scheduling function, to occur at a 
later date 

Edit → Schedule task 

Delete task 1. Choose Environment → Configuration 
→ Task  

2. Choose Display → Change  

3. Select the task that you want to delete and 
choose Edit ->Delete 

4. Go back to the Payroll Calendar 
<Schedule> screen and choose Refresh 

3. To obtain further information on a payroll job and to change it if necessary, call the job 
overview by double-clicking on the payroll job. The following functions, amongst others, are 
available here: 

Function Path 

Display job definition Job → Display 

Display job steps Job → Steps 
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Cancel job scheduling Job → Schedule job → Cancel 

Delete payroll job Job → Delete 

Display spool list with the payroll log Job → Spool list 

Display job log Goto → Job log 
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HR Process Workbench 
Purpose 
The HR Process Workbench enables you to automate payroll and the subsequent activities and 
to run them in the background. To do this, you create a process model containing the sequence 
of all programs to be started by the system. You can restart processes using this process model. 
When you start a process, the system runs all process steps, in other words, all programs 
included in the process model. These programs are run in a defined sequence.  

Integration 
You can use process models to  

• Automate the complete regular payroll process [Page 57] and subsequent activities, for 
example, the creation of remuneration statements [Page 498] or posting to Accounting [Page 
525].  

• Run off-cycle payroll [Page 134]  

Features 
• You can reduce the process runtime by running programs in parallel. 

• Processing of the programs can be easily monitored. 

• You can check each personnel number during the complete process run. 

• You can repeat single process steps, for example, if errors have occurred and you then 
correct the error. 

• At any time, you can check which data is transferred from one process step to the next. 

• You can specify that a message is sent in specific conditions. 
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Process Model 
Definition 
A process model defines a sequence of programs that automatically follow one another. The 
process run can be interrupted with breakpoints.  

Use 
Process models are used as templates for the execution of processes [Page 107]. Several 
processes can be based on the same process model. 

Structure 
In the attributes, you use the personnel number selection program [Page 110] to specify which 
personnel numbers are used in the process model. 

You define the behavior of the program in the process model by specifying a program category 
that defines this program. The specifications for the program categories are documented in the 
system under Edit → Program category. You can assign any number of programs to a program 
category. 
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Technical Processing of a Process Model 
Purpose 
Process models are used as the basis for running processes [Page 107]. 

Prerequisites 
A workflow user must be set up in Customizing for Basis Components under Business 
Management → SAP Business Workflow → Maintain Standard Settings for SAP Business 
Workflow [Ext.]. This enables the program to be executed correctly. 

 
For more information on SAP Business Workflow, see BC – SAP Business Workflow 
– Navigation [Ext.]. 

Process flow 
1. The process starts with a selection program which determines the personnel numbers for 

processing. The selection program can either be started in the background or directly from 
the HR Process Workbench. It triggers a workflow event [Ext.], starts the process, and 
transfers the process control to a function module, otherwise known as the Process 
Manager. 

2. The Process Manager determines the next step, and starts the accompanying program in the 
background. 

3. At the end of the program, control is given back to the Process Manager. The system checks 
the status of the process step and checks whether other steps follow. A container [Ext.] 
transfers the information from one process step to the subsequent step. The content of the 
container is always saved so that the information on the individual steps is never lost. 

4. The next program is started with the information from the container and from the results 
tables for the preceding program. 

Result 
An overview of the status for the individual process steps is displayed in the HR Process 
Workbench. A message can be sent to a particular person, depending on the definition of the 
individual process steps. 
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Process Model: Example 

Create documents

1
-1000
1
-1000

1001
-2000
1001
-2000

2001
-3000
2001
-3000

Print form
Program: RPCEDTX0
Variant  : SAP&PM99

Print form
Program: RPCEDTX0
Variant  : SAP&PM99

Unconditional 
breakpoint

Unconditional 
breakpoint

Personnel number selection
H99_SELECT_PERNR

Personnel number selection
H99_SELECT_PERNR

Payment
Program: RPCDTAX0
Variant  : SAP&PM99

Payment
Program: RPCDTAX0
Variant  : SAP&PM99

Program: RPCIPE00
Variant  : SAP&PM99

Payroll

1
- 500
1
- 500

501
-1000
501
-1000

1001
-1500
1001
-1500

2001
-2500
2001
-2500

2501
-3000
2501
-3000

Program: RPCALCX0
Variant  : SAP&PM99

 
Personnel number selection 

The selection program H99_SELECT_PERNR transfers the personnel numbers to be processed 
to the process model. 

Programs 

The program RPCALCX0 with selection variant SAP&PM99 belongs to the PY-Payroll program 
category. 

Form printing and payment are processed together, therefore, the total runtime is reduced. 

Sets of personnel numbers 
The payroll program simultaneously processes sets of 500 personnel numbers and the transfer 
program processes sets of 1000 personnel numbers. This means that the runtimes of the 
programs are reduced. 

Programs that process sets of personnel numbers can follow programs that do not split selected 
personnel numbers, and vice versa. 

Breakpoint 
The unconditional breakpoint interrupts the process each time it is run and before any documents 
are created. 
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Programs that select personnel numbers can only follow programs that also work on 
the personnel number level. For example, the payment program cannot transfer 
personnel numbers to the check printing program as a selection criterion. Only a 
program that does not select personnel numbers can follow the check printing 
program. The system documentation for the program categories specifies which 
categories select personnel numbers. 
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Process 
Definition 
Execution of programs defined in a process model [Page 102] in a specified sequence. 

Use 
Each process is created in the HR Process Workbench using a process model and is assigned a 
unique number. The process comprises all steps defined in the process model. Closed 
processes are locked for changes, however they can still be displayed. This ensures that the 
complete process history is available. 

If a process model is used periodically, you create a new process each time. The process ID 
uniquely identifies each process. 

 
You use the same process model each month to create the bank transfer for an 
employee and print the forms. Each month you use the process model to create a 
new process. In December, you may need to use a different process model since 
additional evaluation reports are required at the end of the year.  

Process step
2

Process stepProcess step
22

Process step
3

Process stepProcess step
33

Process step
1

Process stepProcess step
11

Run 2Run 2

Run 1Run 1

Run 2Run 2

Run 1Run 1 PerNo. 2PerNo. 2

PerNo. 1PerNo. 1

PerNo. 3PerNo. 3

PerNo. 4PerNo. 4

PerNo. 2PerNo. 2

PerNo. 1PerNo. 1

PerNo. 3PerNo. 3

PerNo. 4PerNo. 4

OKOK

OKOK

OKOK

ErrorErrorError

OKOK

ErrorErrorError

OKOK

ErrorErrorError

BlankBlankBlank

OKOK

PerNo. 4PerNo. 4

PerNo. 1PerNo. 1

PerNo. 3PerNo. 3 OKOK

OKOK

PerNo. 4PerNo. 4

 
You can check the processing steps using the Status Display [Page 127] function. 

Process step 

Structure 
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In a process step, a program is executed in the process model. The process step includes: 

The program category, whose specifications have been defined in the process model [Page 102]. 

The assigned program with a variant 

You can repeat a process step as often as required. The subsequent program that processes the 
results of the process steps is then also repeated. You start and repeat [Page 122] processes 
and process steps in the same way. 

Run 

A run is equivalent to starting or repeating a process step. The runs in a process step are 
displayed and numbered sequentially. If a process is repeated, all process steps will also be 
repeated. 

Set 
If personnel numbers are processed at the same time in a process step, the system groups 
together the personnel numbers into a set. The number of sets is determined each time the 
process step is repeated. The sets are assigned a sequential number, starting from 1 each time. 

If the personnel numbers cannot be processed at the same time, they automatically form one 
set. 
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Breakpoint 

Specifies whether a process must be interrupted. There are conditional and unconditional 
breakpoints. 

Structure 
A breakpoint is defined by a function module. SAP provides the function module 
HRPY_PROCESS_STOP_CONDITIONAL  (conditional breakpoint) and 
HRPY_PROCESS_STOP_ABSOLUTE  (unconditional breakpoint). 

You can define your own conditions for a breakpoint in a function module. The function module 
interface has the following structure: 

• Import parameter 

− IMP_PROCESSID LIKE T52SPS-PROCESSID (process object key) 

− IMP_STEPID LIKE T52SPS-STEPID (process step object ID) 

− IMP_RATE LIKE T52SMS-PERCENTAGE (percentage rate) 

− STOP_PROCESS (If this exception occurs, the process is interrupted.) 

Definition 

• Exception 
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Personnel Number Selection 
Use 
The process model must start with a program that selects the personnel numbers for the 
complete process run. Each process model starts with a specific selection program. 

You specify the selection program when you create the process model. 

Integration 
Personnel numbers that have not been selected using the selection program defined in the 
process model can still be included in a process containing payroll. For example, you can include 
new employees in a process. If the process is repeated, they are read from matchcode W [Page 
72].  

 
SAP provides an international selection program H99_SELECT_PERNR. 

If you use your own selection program, base it on the following structure. The given source text 
must remain. 

REPORT MY_SELECTION_PROGRAM. 

INCLUDE RPUPMDP1. 

RANGE: PROCESS_EMPLOYEES FOR PERNR-PERNR. 

DATA: This_report like sy-repid 

START-OF-SELECTION. 

This_report = sy-repid 

CALL FUNCTION 'HRPY_PROCESS_INIT_SELECTION’ 

EXPORTING 

IMP_PROGRAM     = This_report 

CHANGING 

CHAN_PROCESSID = STPROCID 

CHAN_STEPID     = STSTEPID 

CHAN_CONT       = CONT 

... Specific processing: In the PROCESS_EMPLOYEES table, enter the 

 personnel numbers to be processed. 
END-OF-SELECTION. 

CALL FUNCTION 'HRPY_PROCESS_CLOSE_SELECTION' 

 

... 

CHAN_CONNECT    = CONNECT 
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EXPORTING 

IMP_PROCESSID     = STPROCID 

IMP_STEPID      = STSTEPID 

IMP_CONT        = CONT 

TABLES 

IMP_PERNR_INDEX = PROCESS_EMPLOYEES 

LEAVE PROGRAM. 

IMP_CONNECT     = CONNECT 
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Mail Connection 
Use 

You can send a message by mail or by pager. For more information on communicating by pager, 
see Sending Messages By Pager [Ext.].  

Features 
You can send a message in the following situations: 

• Some personnel numbers contain errors 

• Some personnel numbers have no data 

• Processing of a set of personnel numbers was canceled 

• A step was completed 

• The system did not stop at a breakpoint 

There are standard texts for these mails. The texts are assigned when the process model is 
created. Each mail has an attachment. If you double-click this attachment, you access the HR 
Process Workbench at the place where the process was canceled. 

Activities 
When you create a process model, you specify who should receive the message and which 
standard text should be used for the mails.  

To change the standard texts, from the SAP Easy Access screen, choose the SAP menu Tools 
→ Form Printout → SAPscript →  Standard Text. For more information, see the Implementation 
Guide (IMG) for Payroll under Create Process Model [Ext.]. 

During a process, the individual steps can have different statuses. When you create a process 
model, you can define the situations in which you are notified about the status of a process step. 

• The system stopped at a breakpoint 
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Copying or Creating a Process Model 

We recommend that you copy the standard process models and then edit the copies.  

Procedure 
Copying a Process Model 
1. From the SAP Easy Access screen, choose the SAP menu Human Resources → Payroll 

<country> → Tools → Customizing Tools → Maintain Process Model. 

You access the Maintenance of Process Models screen. 

2. In the Process model field, enter a process model. 

− To display the process model before you copy it, choose Model → Display. 

− To display information on the process model, choose Goto → Documentation for model. 

4. In the Target model field, enter the name of your process model and choose Copy. 

You can use names that begin with the digits 0 to 9 or with Z. 

Creating a Process Model 
1. From the SAP Easy Access screen, choose the SAP menu Human Resources → Payroll 

<country> → Tools → Customizing Tools → Maintain Process Model. 

You access the Maintenance of Process Models screen. 

2. Enter a name and choose Model → Create. You can use names that begin with the digits 0 
to 9 or with Z. 

3. Maintain the attributes for your process model and choose Save. 

In the attributes, you can define a name and selection program for your process model. 
The selection program transfers the personnel numbers to be processed to the process 
model. 

 

3. Choose Model → Copy. 

4. Choose Continue. 

Result 
You have created a process model and can edit it [Page 115] if required.  

 
To be able to use a process model to execute processes in a live system, you must 
first activate it. 

To store information on your new process model, choose Goto → Documentation on model. 

• If you have copied a process model, the system has also copied the accompanying 
documentation. You can change this documentation if required. 
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• If you have created a new process model, you can create new documentation for your model. 
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Editing a Process Model 
Prerequisites 
You have created or copied a process model [Page 113] and are in the Maintenance of Process 
Models screen. 

Procedure 
1. Enter the name of the process model that you want to edit and choose Model → Change. 

You access the Maintain Process Model <name> screen. The following areas are 
displayed: 

− Display area 

The process model you have called is displayed and can be changed. 

− Navigation area 

You can define which section of the process model is shown in the display area. 

− Insertable objects 

The Program and Breakpoint templates are displayed. 

2. Insert the Program and Breakpoint objects as process steps in the process model. For more 
information, see Inserting a Process Step [Page 116] . 
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Inserting a Process Step 
Prerequisites 
You are editing a process model [Page 115] and are in the Maintain Process Model <name> 
screen. The templates for programs and breakpoints are available in the Insertable objects area. 

Procedure 
1. In the Insertable objects area, select the object that you want to insert.  

2. Click in the display area. 

You access the Change Step <number> dialog box. 

3. Create the attributes for the program [Page 117] or the breakpoint [Page 118]. 

The inserted object appears separately in the display area. 

4. To include the object in the process model, choose Include. 

5. Use the cursor to draw a line from the parent object to the child object. 

Result 
The object is inserted in the process model as a new process step. 
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Defining the Attributes of a Process Step 
Prerequisites 
You are inserting a process step in a process model [Page 116] and are in the Maintain Process 
Model <name> screen. 

Procedure 
1. Enter the program category that you want to use. 

If you want to create a new category, enter the name of the category and define the 
following characteristics: 

− Unconditional breakpoint before program start 

− Whether the status can be reset 

− Personnel number selection 

− Parent category 

− Child category 

 

2. Enter the program that you want to use. 

3. Enter the program variant that you want to use with this model. You can also enter the name 
of a new variant and create the variant directly. 

4. If the program processes personnel numbers at the same time, enter the size of the 
personnel number set. 

− Parallel processing 

For an overview of the existing program categories and their characteristics, see 
Maintenance of Process Models under Edit → Program categories. You can also 
enter a new program category here. 

5. If applicable, specify whether somebody should be informed of the status of the process step. 

Result 
The process step is displayed under the program, variant and set size information. 
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Defining the Attributes of a Breakpoint 
Prerequisites 
You are inserting a process step in a process model [Page 116] and are in the Maintenance of 
Process Model <name> screen. 

Procedure 
1. Enter the condition under which the breakpoint will interrupt the process run. 

 
If you want to use a function module, enter the name of the function module in the 
Separate function module field.  If you then call the field help for this field, the 
documentation for the specified function module is displayed. 

2. If applicable, specify whether somebody should be informed of the status of the breakpoint. 

Result 
The breakpoint is displayed. 
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Changing a Process Step 
Prerequisites 
You are  and are in the Maintain Process Model <name> 
screen. 

editing a process model [Page 115]

Procedure 
1. Double-click the process step that you want to change. The Change Step <number> dialog 

box appears. 

2. Enter the changes and choose Continue. 

If you are changing a program, you can create new program categories here. 
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Changing the Sequence of Process Steps 
Prerequisites 
You are editing a process model [Page 115] and are in the Maintain Process Model <name> 
screen. 

Procedure 
You have the following options: 

Cutting and Inserting a Process Step 
1. Select the process step that you want to move. 

2. Choose Edit → Nodes → Remove to buffer.  

3. Choose Edit → Nodes → Insert buffer. 

The process step is displayed separately in the display area. You can now reinsert the 
process step [Page 116]. 

Linking a Process Step to a Preceding Object 
1. Choose Connect. 

2. Use the cursor to draw a line from the new parent object to the process step that you want to 
move. 

The process step and the accompanying child objects are now subordinate to the new 
parent object. 
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Creating a Process 
Prerequisites 
You have created the process model [Page 102] to be used in the process. 

Procedure 
1. From the SAP Easy Access screen, choose the SAP menu Human Resources → Payroll 

<country> → Tools → HR Process Workbench. 

2. Choose Edit → Process → Create. 

The process number that uniquely identifies the process is assigned automatically. The 
number range object, which controls the assignment of the numbers, is delivered with the 
HR Process Workbench. 

3. Enter a process name and the process model that you want to use. Choose Continue. 

Result 
The process has been created. It has the status [Page 127] Still to run. You can start the 
process. 

 
To check which process model is used in your created process, flag the process and 
choose Goto → Additional information. 

To display the process model used in your created process, flag the process and 
choose Goto → Display process model. 
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Starting or Repeating a Process or Process Step 
Use 
You start and repeat processes and process steps in the same way. The status [Page 127] 
indicates whether you need to start or repeat the process. 

You may need to start or repeat a process step for the following reasons: 

• Breakpoint 

A process step follows either a conditional or unconditional breakpoint. 

• Process termination 

Process steps can be terminated due to a program or technical error. You can see the 
reason for the program termination by displaying the job log [Page 126]. 

• Personnel numbers with errors 

Use the spool list [Page 126] and job log [Page 126] to check the process step. Remove 
the error and repeat the process step. 

 
If a process step or a process is repeated, processing of the following personnel 
numbers is repeated: 

• Personnel numbers without the status Successful 

• Personnel numbers with the status Not selected 

 
You can only repeat processes, process steps, and personnel number sets that were 
successful if you change the status [Page 129] for the personnel numbers in 
question. 

Prerequisites 
You have created a process [Page 121] in the HR Process Workbench. 

Procedure 
1. Select the process that you want to start and choose Edit → Process → Start/repeat. 

2. Specify whether the process will run immediately or at a later point. 

This information refers to starting the selection program [Page 110]. 

− Immediately: In the personnel number selection screen, either specify a variant or enter 
the payroll area and payroll period. 

− At a later point: Enter the start date and time. Choose Continue. Select the variant for 
starting the personnel number selection program. 
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If you schedule a process for a later time, you must first create a variant for the 
selection program. This is possible if, for example, you edit a process model [Page 
115]. From the Maintain Process Model <name> screen, choose Goto → Attributes. 
From the subsequent dialog box, choose Create variants and create a variant for the 
selection program. 

 
A process is always executed in the background. 

Result 
The process is run at a specified time. 

You can control the process run using process control [Page 126]. 
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Closing a Process 
Use 
We recommend that you close a process if you do not want to repeat it again. The process is 
then locked for changes. You can close a process even if it still contains incorrect personnel 
numbers. 

Prerequisites 
You have started a process [Page 122] in the HR Process Workbench. 

Procedure 
1. Select the process that you want to close. 

 
You cannot reverse the Close process activity. You can only display a closed 
process. 

2. Choose Edit → Process → Close. In the subsequent confirmation box, confirm your decision. 

Result 
The process is displayed in a light gray font in the HR Process Workbench. All process data 
remains unchanged so that you can see the process history. 
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Deleting a Process 
Prerequisites 
You have closed a process [Page 124] in the HR Process Workbench. 

Procedure 
1. Select the process that you want to delete. 

2. Choose Edit → Process → Delete. 

Result 
You can no longer access the history for processes that have been deleted.  

 
The application log shows who deleted a process and at what time it was deleted. To 
access the application log selection screen, choose Goto → Display application log. 
If you want to accept the default settings, choose Continue. An overview of the 
processes deleted in the previous year is displayed. If you want to restrict the 
overview, enter the necessary data in the selection screen. 
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Process Control 
Use 
The process steps for a process always run in the background. With this function, you can check 
that the process steps have been executed in the HR Process Workbench. 

Features 
The following tools help you to monitor the processing: 

• Status display [Page 127]  

• Job log 

The job log contains the date and time of the processing start and end and, if applicable, 
the termination date and time. 

 
To display detailed information on the program termination, double-click the Job 
interrupted message in the job log. Either a short dump or a termination message 
text will inform you of the cause of the termination.  

• Spool list for sets of personnel numbers 

Activities 
To display the job log, select the set of personnel numbers and choose Goto → Job overview for 
set. 

To display the spool list, select the set of personnel numbers and choose Goto → Spool list for 
set. 
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Status Display 
Use 
You can use the status display to check the status of a process. 

 
For more information on checking the processing status, see Process Control [Page 
126]. 

Features 
In the HR Process Workbench, the system shows the current status for each process. 

You can also display the status of the personnel numbers processed in a process. 

Process status 

The process status is displayed on the process, process step, run, and set level. The icons given 
to the levels during and after a process run provide information on the processing status. For a 
legend explaining the symbols, see Utilities. 

The process status can be as follows: 

• Stopped 

A process step follows either a conditional or unconditional breakpoint. To continue the 
process, start the process step [Page 122]. 

• Successful 

You can now close the process [Page 124]. 

• Provisional 

This status is not currently used. 

• Incorrect 

If process steps are provisionally or incorrectly ended, display the spool list [Page 126] to 
analyze the problem. Remove the error and repeat the process step [Page 122]. 

• Canceled 

Display the job log [Page 126]. Remove the error and repeat the process step. 

Personnel number status 

During the process flow, each personnel number receives information on the processing status. 
This means you can follow the status of a personnel number through the complete process flow. 
Only correctly processed personnel numbers are transferred from one process step to the next. 

You can display the status of a personnel number for all process levels. The status can be as 
follows: 

• Successful 

• Provisional 
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Personnel numbers receive this status if they are processed using incomplete data and 
the process step was performed correctly. 

• Incorrect 

If the program has identified errors, this status is assigned to personnel numbers.  

 
For example, in the payroll program, personnel numbers have the status Incorrect if 
the system saves them in matchcode W [Page 72] (Payroll correction run). 

• Blank 

This status is for personnel numbers that were incorrect in the previous process step 
and, as a result, could not be edited. Check the error that has occurred in the previous 
process step, correct the error, and start the previous process step again. 

• Not selected 

Personnel numbers with this status are not transferred to the next process step. 

Activities 
To display the status of specific process levels, expand the levels. 

To display the status of a personnel number, select the corresponding process level, choose 
Goto → Display personnel numbers and specify whether particular personnel numbers or 
personnel numbers with a particular status are to be displayed.  

 
To restrict which processes are displayed in the HR Process Workbench, choose 
Process overview → Set filter. 
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Changing the Status 
Use 
If you repeat processes or process steps, only personnel numbers without the Successful status 
or with the Not selected status are processed. To be able to edit personnel numbers that have 
been processed successfully, you must first change the status. 

 
You can only reset the status if this action is permitted for the process step category 
in question. For more information, see Defining the Attributes of a Process Step 
[Page 117]. 

Prerequisites 
You have started a process [Page 122] in the HR Process Workbench. 

Procedure 
Select the appropriate level in the process. 

Choose Edit → Personnel number → Set to ‘Incorrect’. 

 
You have changed the value of a wage type in a table for the process step Payroll. 
The personnel numbers affected by this change are not grouped in matchcode W 
(Payroll correction run), however, when the payroll process is repeated, they should 
be corrected. Change the status to Incorrect and start the process again. 
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Off-Cycle Activities (PY-XX-OC) 
Purpose 
As an addition to regular payroll [Page 57], which carries out payroll at fixed regular intervals, this 
function enables you to carry out specific off-cycle payroll activities [Ext.] for individual employees 
on any day. 

You can issue a check to replace payments that were originally made to an employee by check 
or by transfer but which the employee did not receive, or if the check is in an unusable condition 
(for example, torn).  

You can reverse payroll results that were created by a regular or off-cycle payroll run. 

You can enter a check number into the system retrospectively for a payroll result for which you 
have already issued a check manually. 

Implementation Considerations 
To implement the Off-Cycle Activities component, you must edit the Off-Cycle Activities section in 
Customizing for Payroll. 

In the standard system, administrators that use the Off-Cycle Workbench have all authorizations 
for the whole transaction. To restrict authorizations, refer to the authorization object 
P_OCWBENCH. 

 
For example, you can give one administrator authorization to carry out off-cycle 
payroll runs. You can give another administrator the authorization to reverse payroll 
results. 

For more information on authorization maintenance, refer to Users and Authorizations [Ext.]. 

Features 
The Off-Cycle Activities component comprises the following areas: 

• Off-Cycle Workbench 

This provides a uniform user interface for all off-cycle activities. 

• Off-Cycle Subsequent Processing 

Once you have performed a function in the Off-Cycle Workbench, the process still has to 
be completed. Depending on the function that you have executed, the system still has to 
carry out various subsequent activities. For example, following an off-cycle payroll run, a 
remuneration statement must be issued. 

Off-Cycle Workbench 
The Off-Cycle Workbench offers the following functions: 

• Off-Cycle payroll [Page 134] 

The types of payroll run that you can carry out depend on the settings made in 
Customizing.  
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− You can make a bonus payment to an employee for a special occasion. 

− You can carry out an immediate correction run if, for example, an employee’s master 
data was changed. 

− You can carry out a regular on demand payroll run for an individual employee 
independently of the payroll area. This is necessary, for example, if an employee was 
hired shortly before the payroll date and his or her data could not be entered on time. 

− You can run payroll for several periods in advance, if, for example, an employee is to 
leave the company or wants to take leave and is to receive payment for these periods 
immediately. 

− You can pay an absence, such as leave, in advance. 

− You can process payments that you have created in the Payroll Results Adjustment 
infotype (0221). 

• Replace a payment that was made to, but not received by an employee. 

• Reverse a payroll result 

• Assign at a later date the number of a check - that was issued manually - to the relevant 
payroll result. 

Off-Cycle Subsequent Processing 
Depending on the country,  off-cycle subsequent processing [Page 161] is carried out using one 
or several batch reports. The reports are located in the Off-Cycle menu. When you run the report, 
you specify on the selections screen of the process model [Page 102] that you have created for 
off-cycle subsequent processing. In process models of this kind, you define which subsequent 
programs are to be run, and in which order. The type of subsequent processing varies, 
depending on whether an off-cycle payroll result, a payment replacement or a reversal is to be 
further processed. 

Constraints 
Off-Cycle Activities are not available in all country versions. In some countries that implement the 
component not all of the functions outlined here are available. 
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Off-Cycle Workbench 
Definition 
User interface enabling you to carry out off-cycle payroll, payment replacement, and reversals 
conveniently. 

Use 
You access the Off-Cycle Workbench from the Payroll menu.  

You can use the Off-Cycle-Workbench to carry out the following for a specific employee: 

• Display payroll results 

• Run various types of off-cycle payroll 

• Replace by check a payment that was originally made by check or transfer, but not received 
by the employee 

• Reverse an incorrect payroll result 

• Add a check number retrospectively to a payroll result for which you have already issued a 
check manually 

Structure 
The Off-Cycle Workbench contains the following tab pages: 

• History [Page 133] 

• Payroll [Page 134] 

• Replace Payments [Page 149] 

• Reverse payments [Page 154] 

• Assign check number [Page 153] 

Integration 
Following a payroll run, payment replacement, or reversal that you have carried out in the Off-
Cycle Workbench, the system carries out the off-cycle subsequent processing [Page 161]. 
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Payroll History 
Use 
This function enables you to display the previous payroll results relating to payment for a specific 
employee within the Off-Cycle Workbench. To see the payroll results, you do not have to leave 
the Off-Cycle Workbench or run a report. 

 
For example, you want to replace a torn check. You can refer to the check number 
that is displayed in the payroll history to find out for which payroll result the check 
was issued. 

Features 
The History tab page in the Off-Cycle Workbench displays an extract from the payroll cluster 
containing the most important information on the employee’s payroll results.  

Payments that you have replaced with a check and payroll results that you have reversed are 
indicated. 

To see more detailed information, you can display the remuneration statement for each payroll 
result. 

For payments, you can display the following information: 

• Check number, house bank and company account 

• In the case of replaced payments - which payment was replaced by which check 

• In the case of reversed payroll results - the reason for reversal and the administrator who 
carried out the reversal 

Activities 
To display the remuneration statement for a particular payroll result, select the result and choose 

 Remuneration statement. 

For detailed information on a payment, choose . 
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Off-Cycle Payroll 
Use 
As an addition to regular payroll [Page 57], which carries out payroll at fixed regular intervals, this 
function enables you to carry out specific off-cycle payroll activities for individual employees on 
any day. Off-Cycle Reasons [Page 144] differentiate between various types of off-cycle payroll 
runs. 

You carry out off-cycle payroll from the Payroll tab page in the Off-Cycle Workbench [Page 132]. 

Prerequisites 
• In Customizing for Payroll, under Off-Cycle Activities → Set Up Off-Cycle Reasons [Ext.], you 

have specified which off-cycle reasons are to be available.  

• In Customizing for Payroll, under Payroll Data → Additional Payments Off-Cycle [Ext.], you 
have set up the wage types that you require for your off-cycle payroll runs. 

• In Customizing for Personel Administration under Off-Cycle Activities →  Define Default 
Values for Payment Methods [Ext.], you can also specify which payment method the system 
proposes for each off-cycle reason in the Off-Cycle Workbench. 

• You have scheduled the batch report for subsequent processing of off-cycle activities as a 
regular background job with a suitable variant by choosing System → Services → Jobs → 
Define Jobs. The report is located in the Off-Cycle menu. We recommend that you run 
subsequent processing as a background job on a daily basis. 

Features 
The tab page Payroll in the Off-Cycle Workbench offers the following options: 

• You can select the reason for the off-cycle payroll run. The possible entries that you can 
make in the lower part of the screen change in accordance with the reason that you specify. 

The off-cycle reason determines the kind of off-cycle payroll run you want to run. 
Depending on the settings you have made in Customizing, some or all of the following 
payroll activities are available: 

− Bonus accounting [Page 136] 

− Correction accounting [Page 138] 

− Regular payroll on demand [Page 139] 

− Advance payment [Page 140] 

− Absence payment [Page 141] 

− Payroll results adjustment [Page 142] 

• You can check the payroll calendar. It contains information about planned payroll dates and 
the date of the employee’s last payroll run. 

• You can change the payment method. 

− If you have specified a default payment method for each off-cycle reason in Customizing, 
the system proposes this payment method. 
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− If you have not specified a default value in Customizing, the system proposes the 
payment method from the Bank Details infotype (0009). 

In the Bank Details infotype (0009) you can enter the details of a main or secondary 
bank for the off-cycle payroll run. The Main bank for off-cycle and Secondary bank 
for off-cycle are subtypes of infotype 0009. 

If you specify a different payment method, the system creates a record for the current 
payment in the Bank Details infotype (0009). 

• You can split the payment and assign main and secondary bank details. 
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Bonus Accounting 
Use 
This function enables you to make a special payment to an employee for a special occasion or 
for special performance. 

 
An employee is to receive a bonus for outstanding sales performance. 

You want to give your employees an end-of-year bonus. 

 
It is advisable to conduct bonus accounting from the Off-Cycle Workbench if you 
want to pay a bonus to individual employees. It is easier to create mass bonus 
payments using batch input in the One-Time Payments Off-Cycle infotype (0267). 
For more information, refer to The One-Time Payments Off-Cycle Infotype (0267) 
[Page 147]. 

Integration 
The system creates a record in the One Time Payments Off-Cycle infotype (0267) for each wage 
type that you enter in bonus accounting. This infotype record contains information on: 

• Wage type 

• Bonus payment amount 

• Reason for off-cycle payroll 

• Payroll type [Page 144] 

• Payroll identifier 

The payroll identifier is a sequential number allocated by the system to differentiate 
between several bonus payments or absence payments [Page 141] made on the same 
day. This differentiation is necessary, since both of these off-cycle payroll runs belong to 
the same payroll type. The first bonus accounting run or absence payment has the 
payroll identifier 0. 

Prerequisites 
The standard system already contains an off-cycle reason for bonus payments. In Customizing 
for Payroll, you can, if required, set up one or several off-cycle reasons for bonus accounting. 
Choose Off-Cycle Activities → Set Up Off-Cycle Reasons [Ext.] You must assign the reason to 
the Category [Page 144] Bonus.  

Under Off-Cycle Activities → Define Default Values for Wage Types [Ext.], you have, if required, 
defined a wage type that the system proposes when you process a bonus. 

Features 
If you have defined default values for wage types in Customizing and you select the relevant off-
cycle reason in the Off-Cycle Workbench, the system proposes a wage type for bonus 
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accounting in the group header Create Payments. You can overwrite the default value that is 
proposed. 
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Correction Payroll 
Use 
This function enables you to make an immediate correction payment if an employee’s master 
data or time data is changed. The employee does not then have to wait until the system 
automatically carries out retroactive accounting with the next regular payroll run. 

 
An employee receives a pay check and discovers that overtime hours have not been 
remunerated correctly. The employee wants to receive the missing amount 
immediately, rather than wait until the next regular payroll run. You enter the missing 
overtime in the corresponding time infotype and then run a correction payroll run in 
the Off-Cycle Workbench. 

Integration 
In the Earliest master data change field, the system shows the retroactive accounting limit that 
was set on account of the change in master data in the Payroll Status infotype (0003). 

Prerequisites 
The standard system already contains an off-cycle reason for correction payroll. In Customizing 
for Payroll, you can, if required, set up an off-cycle reason for correction payroll. Choose Off-
Cycle Activities → Set Up Off-Cycle Reasons [Ext.] . You must assign the reason to the Category 
[Page 144] Correction. 

Features 
When you select the relevant off-cycle reason in the Off-Cycle Workbench and run payroll, the 
system runs retroactive payroll back to the date that is displayed in the Earliest master data 
change field. The system creates retroactive results for the periods processed. It also creates an 
original result for the payment date that you use for the correction run. 
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Regular Payroll On Demand 
Use 
You can use this function to run regular payroll on demand for a specific employee for a payroll 
period. You conduct this payroll run independently of the regular payroll run for the payroll area to 
which the employee is assigned. 

 
An employee is hired shortly before the payroll date. The employee’s data cannot be 
processed in time for it to be included in the regular payroll run. You can use the Off-
Cycle Workbench to run regular on demand payroll for the employee, even if the 
regular payroll run for the payroll area has already taken place. You do not have to 
wait until the next regular payroll run for the whole payroll area. 

You have hired a new employee. Instead of receiving his or her first pay at the end of 
the first payroll period, the new employee is to be paid at the start of his period of 
employment. In the Off-Cycle Workbench, you can run regular on demand payroll for 
the first period in which he is employed in your enterprise. 

Integration 
If you want to run off-cycle payroll for an employee for several payroll periods, do not run regular 
on demand payroll. Instead, make an advance payment [Page 140]. 

Prerequisites 
The standard system already contains an off-cycle reason for payroll on demand. You can, if 
required, set up your own off-cycle reason in Customizing for Payroll. Choose Off-Cycle Activities 
→ Set Up Off-Cycle Reasons [Ext.]. You must assign the reason to the category [Page 144] On 
demand. 

Features 
If you choose this reason when you are in the Off-Cycle Workbench, the system offers you the 
next period for which payroll is to be run for the employee. The system then carries out on 
demand payroll for this period. 
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Advance Payment 
Use 
This function enables you to run payroll for an employee for several periods in advance 
independently of the regular payroll runs for the payroll area. 

 
An employee leaves the company and is to receive all the money owed immediately. 

An employee takes leave. You want the employee to receive payment in advance for 
the payroll periods in which the leave occurs. 

Integration 
If you want to settle an absence, such as leave, in advance, you can also carry out an absence 
payment [Page 141]. This means that the employee is only paid in advance for the time that he 
or she is absent. However, you use the advance payment function to run payroll in advance for 
all the periods in which the absence takes place. 

 
The employee is to take 10 days leave. The leave period affects three payroll 
periods. In the case of an absence payment, the employee is paid in advance for 10 
days. In the case of an advance payment, the employee is paid in full for all three 
payroll periods in which the leave takes place. 

Prerequisites 
The standard system already contains an off-cycle reason for advance payments. In Customizing 
for Payroll, you can, if required, set up an off-cycle reason for payments in advance. Choose Off-
Cycle Activities → Set Up Off-Cycle Reasons [Ext.]. You must assign the reason to the Category 
[Page 144] Advance payment.  

In Customizing, under Off-Cycle Activities → Define Default Values for Payments in Advance 
[Ext.], you specify how many payroll periods the system is to propose for payments in advance. 

Features 
When you select the relevant off-cycle reason in the Off-Cycle Workbench, the system offers 
several periods for payroll. The number of periods proposed depends on the settings in 
Customizing for Payroll. 

If you pay several payroll periods in advance, only one original result is created, and only one 
payment is effected. The system creates the original result for the latest of the periods for which 
you run payroll. All other periods prior to this period are processed using retroactive payroll. 

The system ensures that the employee who is to receive an advance payment is not processed 
twice. The employee is then automatically excluded from the payroll area’s regular payroll runs 
for the periods already processed. 
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Absence Payment 
Use 
If an employee is to be absent during future payroll periods, for example, because of leave, you 
can pay the employee in advance for the period of the absence. The remuneration is calculated 
using  Absence evaluation [Page 245]. 

Integration 
Contrary to a payment in advance [Page 140], you do not run payroll for the whole period in 
which the absence takes place. This means that the employee is only paid in advance for the 
time that he or she is absent. 

Prerequisites 
The standard system already contains an off-cycle reason for absence payments. In Customizing 
for Payroll, you can, if required, set up an off-cycle reason for absence payments. Choose Off-
Cycle Activities → Set Up Off-Cycle Reasons [Ext.]. You must assign the reason to the category 
[Page 144] Absence payment. 

In Customizing for Payroll, under Off-Cycle Activities → Off-Cycle Absence Evaluation → Assign 
Absences to an Off-Cycle Reason [Ext.], you have specified which absence types are permitted 
for off-cycle payroll. 

Features 
When you select the corresponding off-cycle reason from the Off-Cycle Workbench, the system 
proposes the absences for processing that have already been entered in the Absences infotype 
(2001), and that have been set as permitted for off-cycle payroll in Customizing. 

When you pay an absence, the system adds the following data to the already created record in 
the Absences infotype (2001). 

• Reason for off-cycle payroll 

• Payment date 

• Payroll type [Page 144] 

• Payroll identifier 

The payroll identifier is a sequential number assigned by the system to differentiate 
between several absence payments or bonus payments [Page 136] made on the same 
day. This differentiation is necessary, since both of these off-cycle payroll runs belong to 
the same payroll type. The first absence payment or bonus accounting run has the 
payroll identifier 0. 
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Payroll Results Adjustment 
Use 
This function enables you to make payments directly from the Off-Cycle Workbench that you 
have created in the Payroll Results Adjustment infotype (0221). This means that you do not need 
to wait until the system reads the data from the infotype for processing during the next regular 
payroll run. 

 
An employee leaves your enterprise whilst working away from the main office in 
which your HR department is located. The employee’s superior calculates the 
amount owed manually, and issues a check for the employee manually. To ensure 
that this payroll result is also available in the system, you enter the relevant data 
retrospectively in the Payroll Results Adjustment infotype (0221) and subsequently 
run payroll from the Off-Cycle Workbench, specifying payroll results adjustment as 
the off-cycle reason. 

Integration 
The payments that you create in the Payroll Results Adjustment infotype (0221) are displayed in 
the Off-Cycle Workbench. 

Prerequisites 
The standard system already contains an off-cycle reason for payroll results adjustment. You 
can, if required, set up an off-cycle reason in Customizing for Payroll. Choose Off-Cycle Activities 
→ Set Up Off-Cycle Reasons [Ext.] . You must assign the reason to the category [Page 144] 
Payroll Results Adjustment. 

Features 
When you select the relevant off-cycle reason in the Off-Cycle Workbench, the system displays 
the payments that you created in the infotype. You can select a payment and run payroll. 
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Running Off-Cycle Payroll 
Prerequisites 
You are in the Off-Cycle Workbench [Page 132]. 

Procedure 
1. Enter the personnel number that you want to process and choose the tab page Payroll 

2. Select an off-cycle reason  [Page 144] 

This determines the subsequent processing. 

3. If required, enter a date other than the one proposed. 

4. Copy the payment method from the Bank Details infotype (0009), or enter a different 
payment method. 

5. If required, split the payment and assign the main and secondary bank details. 

6. Enter additional data according to the off-cycle reason you have entered. 

7. Choose  Start payroll 

8. After the payroll run, save your data. 

Result 
Following the off-cycle payroll run, the system makes the following changes: 

1. It saves the data in the relevant infotypes, and saves the payroll results to the database. 

At the same time, the system makes an entry in the indicator table for batch processing 
to show that a payroll result exists that requires further processing. 

 
You can display the contents of the indicator table using report H99LT52OCG 
(Display Indicator Table for Off-Cycle Batch Processing). The report is located in the 
Off-Cycle menu. 

2. At the regularly scheduled time, the system runs as a background job the country-specific 
batch report for subsequent processing of off-cycle payroll. 

The report reads the indicator table. Using the payroll results from the indicator table, the 
system starts the process model that you specified in the report variant. 

3. The system carries out all subsequent programs that you specified in the process model. For 
example, it produces remuneration statements, prints checks or initiates transfers and posts 
payroll results to Accounting if you have specified these steps in the process model. 

 

April 2001  143 



Payroll United States (PY-US)  SAP AG 

Reasons, Types and Categories for Off-Cycle Payroll 

Reasons, Types and Categories for Off-Cycle Payroll 
Various off-cycle reasons, and assignment to various types and categories are used to 
distinguish payroll runs. 

On
demand

Advance
payment

Bonus Absence Other Other

'  '
(Regular

payroll run)

A
(Bonus payment)

B
(Correction-
accounting)

C
(Manual
check)

On
demand

Advance
payment

Bonus Absence
payment

Correction Payroll
results
adjust-
ment

Regular
period on
demand

Advance
payment
(leave)

Christmas
bonus

Vacation
bonus

Correction
payment

Payroll
Results
Adjust-
ment

Off-Cycle
reason
(example)

Category for off-
cycle reason

Off-cycle
reason type

Payroll type

Off-Cycle Reason  

Off-Cycle Reason  
The off-cycle reason differentiates between various business reasons. Off-Cycle reasons enable 
an administrator to decide conveniently what kind of payroll to run from the Off-Cycle Workbench. 

The standard system already contains off-cycle reasons for all kinds of off-cycle payroll. In 
Customizing for Payroll, you can set up your own reasons that are valid for your enterprise. You 
assign each off-cycle reason to a specific category. This enables the system to deal with similar 
payroll runs in the same way. The subsequent assignment to a type of off-cycle reason and to a 
payroll type is done automatically by the system. 

 
In Customizing, you define the off-cycle reason Holiday bonus and assign it to the 
category bonus. The system assigns the type of off-cycle reason Bonus and the 
payroll type A to the Holiday bonus. 

Category for the Off-Cycle Reason 
Categories group several off-cycle reasons together so that similar reasons, such as Easter 
bonus and Christmas bonus are dealt with in the same way by the system. 
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Which types of off-cycle reason are set up in the system depends on the categories 
that are required by the country-specific components. 

Off-Cycle Reason Type 
The system uses the off-cycle reason type to decide what information it must display in the Off-
Cycle Workbench. The decision is made in line with the off-cycle reason selected by the 
administrator. 

• On demand 

The system proposes the next regular payroll period. 

• Advance Payment 

The system proposes several future regular payroll periods. 

• Bonus 

If you have defined a wage type, the system proposes a wage type for bonus accounting 
that you have set up in Customizing for Payroll.  

• Absence 

The system proposes for payroll future absences that you have recorded in the 
Absences infotype (2001). 

• Other 

For a correction run carried out in the Off-Cycle Workbench, the system displays the date 
of the retroactive payroll run from the Payroll Status infotype (0003). For a payroll run 
with the category Payroll Results Adjustment, the system displays payments that you 
have created in the Payroll Results Adjustment infotype (0221). 

Payroll Type 
The payroll type enables the payroll driver to decide which of the following kinds of payroll are to 
be run: 

• Blank = Regular payroll run 

The system then runs on demand payroll for one or several periods. 

The types of off-cycle reason on demand and advance payment belong to this payroll 
type. 

• A = Bonus payment 

The payment date with which you run off-cycle payroll is the start and end date of the 
payroll period. The system creates the payroll result for this day. 

The types of off-cycle reason bonus and absence belong to this payroll type. 

• B = Correction run 

The system runs retroactive payroll for past periods on account of a change in master 
data. Payroll is re-run for all periods that have already been run, back as far as the 
retroactive accounting date. In addition to these retroactive accounting results, the 
system creates an original result for the payment date that you use for the off-cycle run. 
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• C = Manual check 

The system processes payments that you have entered in the Payroll Results 
Adjustment infotype (0221). This payroll type exists for USA and Canada only. 
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The One-Time Payments Off-Cycle Infotype (0267) 
Definition 
Infotype in which additional wage elements that are only made once or irregularly can be stored 
for off-cycle payroll [Page 134]. 

Use 
The One-Time Payments Off-Cycle infotype (0267) is not used in all countries. 

To create one-time payments, you have the following options: 

• If you only want to create a one-time payment for one or a few employees, we recommend 
that you use the Off-Cycle Workbench [Page 132]. The system thereby saves you from 
carrying out several steps that you otherwise must carry out manually in the One-Time 
Payments Off-Cycle infotype (0267). 

• If you want to make one-time payments to many employees, we recommend that you use 
batch input in the One-Time Payments Off-Cycle infotype (0267), or use fast entry [Ext.]. 

Structure 
• The standard system contains various wage types as subtypes 

• In the Payment date field, the system offers the last day of the current payroll period as the 
payment date for the one-time payment off-cycle. You can overwrite this default value by 
entering the required date for the off-cycle payroll run in the Payment date field. 

• In the Off-Cycle Reason field, you can only select from reasons that were assigned to payroll 
type A in Customizing. For more information, refer to Reasons, Types and Categories for Off-
Cycle Payroll [Page 144]. 

• In the Payrollid (Payroll identifier) field, you must make entries, only if you want to create two 
infotype records for an employee on the same day. The system requires the payroll identifier 
to distinguish between two runs with the same date and the same payroll type. 

 
In the One-Time Payments Off-Cycle infotype (0627), you have created a bonus 
payment of USD 100 for an employee. You have not made any entries in the Payroll 
identifier field. The employee is to receive a further bonus payment on the same day 
of USD 50.  In the Payrollid field, enter a distinguisher for the system, for example, 
the figure 1. 

Integration 
If you create mass off-cycle payments in the One-Time Payments Off-Cycle infotype (0267), you 
start the payroll driver using a process model [Page 102], that you defined in Customizing off-
cycle activities. In the HR Process Workbench, you create a Process [Page 121] using this 
process model. You then run the process model. The process model ensures that payroll is run 
only for the employees with a relevant entry in the One-Time Payments Off-Cycle infotype 
(0267). 
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You can also start the payroll driver without using a process model. However, you 
must then specify individually each employee who received a one-time payment. 
Alternatively, you can process the whole payroll area. However, this gives payroll 
results for all employees, even those who did not receive a one-time payment. 

 
You must make sure that the payroll driver uses the correct data from the infotype 
during payroll. You must ensure that the data that appears in the Reason for off-
cycle payroll and Special run fields, (including the fields: Payroll type, Payroll 
identifier, and Payment date for off-cycle payroll) which appear on the selection 
screens for the process and the payroll driver is exactly the same as data you 
created in the corresponding fields in the One-Time Payments Off-Cycle infotype 
(0267). 

If you create one-time payments in the Off-Cycle Workbench, the system ensures 
that the payroll driver runs using the correct data. 

See also: 
Creating bonus payment details in infotype 0267 [Ext.] (Payroll Thailand) 
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Replacing a Payment 
Use 
You replace a payment if: 

• An employee did not receive a payment by transfer 

• A check that you issued to an employee is unusable 

 
An employee usually receives payment by transfer. The employee changed bank at 
short notice, with the result that payment was made to the old bank. The bank rejects 
the payment. 

An employee usually receives payment by check. A check is torn during printing, or 
is later stolen. 

Integration 
If you replace a payment that was originally made by check, the system reverses the original 
check in Accounting. 

If you replace a payment that was originally made by transfer, the system makes an entry in the 
Table T52OCL (Off-Cycle: Transfer replaced by check or reversed) and logs that a payment was 
replaced. 

 
The table T52OCL is not evaluated by the system. You must ensure that you do not 
make the payment twice accidentally. To check the table T52OCL, you can run the 
report H99LT52OCL. (Transfer replaced by check or reversed). 

Prerequisites 
In Customizing for Payroll, you have edited the following steps in the section on Off-Cycle 
Activities: 

• Check Payment Key [Ext.] 

• Printing Check with Manual Number Assignment [Ext.] 

• Replace Checks [Ext.] 

You have scheduled the batch report for subsequent processing of check replacement as a 
regular background job with a suitable variant by choosing System → Services → Jobs → Define 
Jobs. The report is located in the Off-Cycle menu. We recommend that you run subsequent 
processing as a background job on a daily basis. 

Features 
The tab page Replace payment in the Off-Cycle Workbench offers you the following options: 

• You can issue checks to replace payments by transfers or payments by check. 

• You can select a reason for the payment replacement. 
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− Once the payment by check has been made, you must enter a reason.  

− Once the payment by transfer has been made, you do not have to enter a reason.  

• You can assign the new check number yourself, or have it assigned by the system. 

− If you apply the check number manually, this number is checked against the check lot. 

− If the check number is to be applied automatically, the system takes the next number 
from the check lot. 

• You can confirm the date proposed by the system, or you can enter another date. 

The system proposes the date of the original check or transfer that is being replaced. 
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Replacing a Payment 
Prerequisites 
You are in the Off-Cycle Workbench [Page 132]. 

Procedure 
1. Enter the personnel number that you want to process and choose Replace payment. 

The system displays all payments that you can replace. 

2. Select the payment that you want to replace. 

Information relating to this payment is displayed. 

3. If required, overwrite the check date that the system proposes. 

4. If you want to replace a check, enter the reason for the reversal. 

5. Specify whether the new check number is to be applied automatically by the system or 
whether it is to be applied manually. 

If the check number is to be assigned manually, enter it in the Check number field. The 
system immediately checks this number with the check lot. 

6. Choose   Replace. 

Result 
1. The system runs the Preliminary Program Data Medium Exchange [Ext.]. 

2. It marks the replaced payments with a key that is composed of the program run date and the 
identification feature CYYYYP: 

− C = check 

− CYYYYP (Y = the sequence number from a number range that was defined by SAP for 
check replacement). 

− P = Human Resources 

All replacements carried out on the same day are given the same key. The system 
enters the details in the indicator table for off-cycle batch processing. 

 
You can display the contents of the indicator table using report H99LT52OCG 
(Display Indicator Table for Off-Cycle Batch Processing). The report is located in the 
Off-Cycle menu. If you choose transaction type R (check replacement) in the report’s 
selection screen, the data records containing replaced payments in the indicator 
table are displayed. This enables you, for example, to see which identification feature 
the system has assigned. 

3. The system runs the batch report for the subsequent processing of check replacements as a 
background job at the time that you have scheduled for the regular processing of the report. 

The report reads the indicator table and runs the process model that you specified in the 
report variant. 
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4. The system runs the check print program as part of the process model, and thereby prints 
the new checks. 

If you have specified that the check number is to be applied automatically, the system 
uses the next number from the check lot. 
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Assigning Check Numbers 
Use 
You have carried out an off-cycle payroll run. You have issued a check manually for this payroll 
result. You enter the number of this manually issued check into the system retrospectively 
against the payroll result. 

 
You use the Off-Cycle Workbench to make a bonus payment to an employee. You 
cannot print the check immediately because the printer is not working. The employee 
must, nonetheless receive the check immediately. You therefore issue a check 
manually. You assign the number of this check to the payroll retrospectively so that 
you can later see which check belongs to which bonus payment. 

Prerequisite 
You are in the Off-Cycle Workbench [Page 132]. 

Procedure 
1. Enter the personnel number that you want to process and choose the tab page Assign check 

number. 

2. Mark the payroll result to which you want to assign a check number. 

3. Enter the number of the check that you have issued manually. 

4. Choose  Assign. 
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Reversing Payroll Results 
Use 
Depending on the status of the payroll control record, you have various options for making an 
incorrect payroll result invalid. 

• If the control record does not yet have the status End of payroll, you can: 

− Repeat the payroll run 

− Delete the incorrect payroll result [Page 86] 

• If the control record already has the status End of payroll, you must reverse the payroll result. 
If the data medium exchange program has already been run, the system also reverses the 
relevant checks and transfers. 

 
When reversing, the payroll results are not deleted from the data base. They are only 
marked with the “invalid” indicator. Reversal consequently requires a lot of memory 
space. 

If the payroll control record does not yet have the status End of payroll, we 
recommend that you repeat the payroll or delete the incorrect payroll result. 

Integration 
In the case of a payment by check, the system reverses the check in Accounting. 

If the amount was paid by transfer, the system writes the personnel number, sequence number, 
amount, and BT split indicator [Page 199] relating to this transfer to the table T52OCL (Off-Cycle: 
Transfer by check replaced or reversed). 

 
This table is not actively evaluated by the system. Instead, it only documents which 
payments you have replaced or reversed. You must therefore make sure that a 
reversed payment was definitely not transferred. To check the table T52OCL, you 
can run the report H99LT52OCL (Transfer by check replaced or reversed). 

Prerequisites 
You have scheduled the batch for subsequent processing of off-cycle activities as a regular 
background job with a suitable variant by choosing System → Services → Jobs → Define Jobs. 
We recommend that you run subsequent processing as a background job on a daily basis. 

Features 
The tab page Reverse payment in the Off-Cycle Workbench offers you the following options: 

• You can reverse the payroll results of a regular payroll run or an off-cycle payroll run, 
regardless of whether the employee has received a check or transfer. 

The system reverses all payments that belong to that payroll result. 
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• The system offers an overview of all the payroll results. You can display detailed information 
on the relevant payments. 

• You can select a reason for the reversal. 

− If you reverse a check, you must specify a reason. 

− You can reverse a transfer without specifying a reason. 
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Reversing the Payroll Result 
Prerequisites 
You have corrected the relevant master data. 

 
If you reverse a payroll result that was the result of bonus accounting, you must also 
delete the relevant infotype record in the One-Time Payments Off-Cycle infotype 
(0267). 

You are in the Off-Cycle Workbench [Page 132]. 

Procedure 
1. Enter the personnel number that you want to process and choose the tab page Reverse 

payment. 

2. Select the payroll result that you want to reverse. 

3. If you want to reverse a check, enter the reason for the reversal. 

4. Choose   Reverse. 

5. Confirm the security check. 

Result 
Depending on whether you have reversed the last payroll result, whether the payroll result was 
already posted to Accounting, and whether payments were already made to third parties, the 
system triggers various subsequent activities: 
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Result 1 
Out-of-sequence reversal 
1. The system makes Changes [Page 159] to the tables RT (Results Table) and BT (Bank 

Transfers). 

2. Depending on how the reversed payroll result came about, the system sets the following 
retroactive accounting date in the Payroll Status infotype (0003): 

− In the case of off-cycle payroll, it writes the payment date for the payroll run in the field 
Mast.data chng.bonus (Earliest payroll-relevant master data change (Bonus)) 

− In the case of regular payroll, it writes the start date of the period for which payroll has 
been run in the Earliest master data change field (earliest master data change since last 
payroll). 

This ensures that retroactive accounting takes place. 

3. In the payroll result, the system places the indicator R in the invalid field of the payroll 
directory (RGDIR). It enters the reason, date and time of the reversal in this data record. 

4. Following the reversal, you have the following options: 
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− If the employee is to receive a payment immediately, carry out a correction payroll run in 
the Off-Cycle Workbench. 

− If you do not carry out a correction payroll run in the Off-Cycle Workbench, the system 
automatically carries out retroactive payroll when the next regular payroll run takes place. 

Result 2 
"Void" 
1. The system places the “void” indicator V in the invalid field of the payroll directory (RGDIR) 

for the payroll result. 

 
If the V indicator is set, the payroll result can no longer be used for evaluations. 
Instead, it is only available for the payroll history. The system enters the reason, the 
date, and the time of the reversal to the data record. 

2. The system makes an entry in the indicator table for off-cycle batch processing. 

 
You can display the contents of the indicator table using report H99LT52OCG 
(Display Indicator Table for Off-Cycle Batch Processing). The report is located in the 
Off-Cycle menu. 

3. The system runs the batch report for subsequent processing of off-cycle activities as a 
background job at the time that you have scheduled for the regular processing of the report. 

The report reads the indicator table and runs the process model that you specified in the 
report variant. The process model produces reversal documents for reversed payroll 
results and posts them to Accounting. As a result, the documents that were originally 
posted are reversed. 

4. Depending on which payroll result you reversed, you have the following options: 

− If the payroll result arose from an off-cycle payroll run, you can rerun payroll. 

− If the payroll result arose from a regular payroll run, retroactive payroll takes place at the 
next regular payroll run, since the control record already has the status End of payroll. 

Result 3 
"Void" 
The system places the “void” indicator V in the invalid field of the payroll directory (RGDIR) for 
the payroll result. 
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Out-of-Sequence Reversal: Changes in the RT and BT 
Tables 
If you reverse the last payroll result and payments have already been made to third parties, or if 
you reverse a payroll result other than the last, the system makes the following changes in the 
RT table (Results Table) and the BT table (Bank Transfers): 

Table RT 
• The system produces the technical wage type /568 that contains the payment amount for the 

reversed payroll result. 

• It writes the amount of the wage type /557 cm to the wage type /569. 

• It writes the amount of the wage type /558 cm to the wage type /570. 

• It writes the amount of the wage type /559 to the wage type /571. 

• It stores the former payment method in coded form in the amount per unit field in wage types 
/569, /570 and /571. 

− Payment by check: 1 

− Transfer: 2 

− Check with numbers applied manually: 3 

 
The payment of USD 2,500 to an employee was originally split into a check payment 
(USD 1,000) and bank transfer (USD 1,500). The following appears in the RT table: 

Wage type Amount per unit Number Amount BT 
/559   1 000 

 

01 

/559   1 500 

 

02 

After reversal, the following appears in the results table instead: 

Wage type Amount per unit Number Amount BT 
/568   2 500 

 

 

/571 1  1 000 

 

01 

/571 2  1 500 

 

02 

• The system deletes the wage types /557, /558, and /559. 
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BT Table 
The system deletes the wage types /557, /558, and /559. 

The other wage types in the BT table, for example, wage types from the External Transfers 
infotype (0011) are not deleted. 
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Off-Cycle Subsequent Processing 
Use 
The system uses this function to further process the results of an off-cycle payroll, a replaced 
payment or a reversed payroll result. 

 
Once you have made a bonus payment using the Off-Cycle Workbench, not all 
necessary steps have been concluded. A further remuneration statement must be 
issued, the necessary checks must be printed or the transfers must be made and the 
payroll results must be posted to Accounting. Further steps may also be necessary, 
depending on the business processes in your enterprise. 

Indicator Table for Batch Subsequent Processing 
The system writes all necessary details relating to the results of the off-cycle payroll, the payment 
replacement or the reversal to the table T52OCG (Off-cycle: Flags for Batch: Payroll, Subsequent 
Program). The results are thereby made available for subsequent processing. 

You can display the contents of the indicator table using report H99LT52OCG (Display Indicator 
Table for Off-Cycle Batch Processing). The report is located in the Off-Cycle menu. 

Report for Batch Subsequent Processing 
You start subsequent processing by running one or several batch reports. The batch report 
ensures that the system runs all necessary subsequent programs in sequence. 

Once you have used the functions Run payroll, Replace payment and Reverse payroll result, you 
must - in line with your country version: 

• Run various batch reports 

• Run the same batch report separately for each function. 

The relevant reports are contained in the standard system of each of the country-specific 
versions. The reports are located in the Off-Cycle menu. 

 
We recommend that you schedule the report(s) for batch subsequent processing - 
that are contained in your country-specific standard system - as regular background 
jobs - for example at the end of each workday. This ensures that subsequent 
processing is conducted regularly and on time. 

Process Model 
In a process model, you define which subsequent programs are run, and in what order. On the 
selection screen of the report for the batch subsequent processing, you specify which process 
model the report is to use. 

Model process models are contained in the standard system. You can use these to create your 
own process models. 
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The process models may differ from country to country. For more information on 
process models, refer to Customizing for Payroll, under Off-Cycle Activities → Create 
Process Models for Off-Cycle Subsequent Processing - or under Create Process 
Model for Subsequent Processing Off-Cycle in the maintenance of the relevant 
process model, . Choose Model documentation. 

Prerequisites 
You have made the following settings for the functions Payroll, Replace payment  and Reverse 
payroll result: 

• You have created your own process model for each function in Customizing for Payroll   
under Off-Cycle Activities → Create Process Models for Off-Cycle Subsequent Processing 
[Ext.] . 

 
If you only implement the Payroll function, create your process model in the step 
Create Process Model for Subsequent Processing Off-Cycle Payroll [Ext.]. 

• In the country-specific standard system, for each function, you have scheduled the relevant 
report(s) - with an appropriate variant - for batch subsequent processing as regular 
background jobs. To do this, choose System → Services → Jobs → Define job.  

Features 
You can schedule the relevant batch report with the corresponding process model as a 
background job, or you can call it in the Off-Cycle menu and run it from there directly. 

Depending on the function you executed in the Off-Cycle Workbench, the system carries out the 
following activities: 

Function Decision criteria Subsequent processing by system 
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Off-Cycle payroll  • Saves payroll results on database 

• Makes an entry in the indicator table for batch 
processing to show that a payroll result exists 
that requires further processing 

• Runs the batch report for subsequent 
processing of off-cycle activities as a 
background job at the time that you have 
scheduled for the regular processing of the 
report 

• Reads indicator table 

• Runs the process model that you have specified 
in the process model and uses the payroll 
results from the table 

• Runs subsequent programs as part of the 
process model, for example: 

− Creates remuneration statements 

− Prints checks or triggers transfers 

− Posts payroll results to Accounting 

− Runs any further subsequent programs that 
you have defined in the process model 

Replacing a 
Payment 

 • Runs Preliminary Program Data Medium 
Exchange 

• Indicates each payment replacement with a key 
composed of program run date and the 
indicator feature CYYYP (For more information, 
see replace payment [Page 151]) 

• Enters the details in the indicator table for off-
cycle batch processing 

• Runs the batch report for subsequent 
processing of check replacement as a 
background job at the time that you have 
scheduled for the regular processing of the 
report 

• Reads indicator table 

• Runs the process model that you have specified 
in the report variant 

• Prints new checks 
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Reversal You have reversed 
the last payroll result 
and payments have 
already been made 
to third parties. Or 
you have reversed a 
payroll result other 
than the last one 
(Out-of-sequence 
reversal). 

• Makes Changes [Page 159] to the tables RT 
(Results Table) and BT (Bank Transfers). 

• Places the retroactive accounting date in the 
Earliest master data change field in the Payroll 
Status infotype  (0003). 

• Marks the payroll result with the indicator R in 
the invalid field of the payroll directory (RGDIR) 

• Runs retroactive accounting 

If you do not carry out a correction payroll 
run in the Off-Cycle Workbench, the system 
automatically carries out retroactive payroll 
when the next regular payroll run takes 
place. 

Reversal You have reversed 
the last payroll 
result, which was 
already posted, 
although no 
payments to third 
parties have taken 
place ("Void"). 

• Marks the payroll result with the indicator V  in 
the invalid field of the payroll directory (RGDIR). 

• Makes an entry in the indicator table for off-
cycle batch processing to show that a reversed 
payroll result exists 

• Runs the batch report for subsequent 
processing of off-cycle activities as a 
background job at the time that you have 
scheduled for the regular processing of the 
report 

• Reads indicator table 

• Runs the process model that you have specified 
in the report variant 

• Posts payroll results to Accounting 

• Runs retroactive accounting (if the reversed 
payroll result arose as a result of regular 
payroll) 

Reversal You have reversed a 
payroll result, which 
was already posted, 
and no payments to 
third parties have 
taken place ("Void"). 

Marks the payroll result with the indicator V  in the 
invalid field of the payroll directory (RGDIR). 

See also: 
Running Off-Cycle Payroll [Page 143] 

Replace Payments [Page 151] 

Reversing the Payroll Result [Page 156] 
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Gross Part of Payroll (PY-US-GR) 
Purpose 
The Gross Payroll component processes employee master data from SAP Personnel 
Administration and generates wage types and amounts to be used by the Net Payroll component, 
or to be exported to a third-party product for net calculation. Pre-tax deductions and earnings are 
processed within the Gross Payroll component. 

Integration 
The Gross Payroll component is closely integrated with the SAP Personnel Administration and 
SAP Benefits components. 
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Wage Types 
Definition 
Payroll and Personnel Administration objects used to differentiate between monetary amounts or 
time units that are used in different ways to calculate the employee's remuneration. In the SAP 
System monetary amounts or time units that serve different business purposes, and that are 
processed in different ways during the payroll run, are delimited from one another using wage 
types [Ext.]. 

 
The Standard Pay wage type has a different business background to the Union Dues 
wage type. 

You enter the number of hours in the Overtime wage type. During the payroll run the 
Overtime wage type is processed in a different way to the Monthly Salary wage type. 

The Overtime Hours wage type is included in a basis for calculating average values 
[Ext.] which is different to the Holiday Bonus wage type. 

The standard SAP System contains a wage type catalog [Page 175] with a large number of 
different wage types for different business tasks. 

Use 
There are two categories of wage types: 

• Primary Wage Types 

Primary wage types include: 

− Dialog wage types [Page 169] that you enter when maintaining master data in the 
infotypes. 

− Time wage types [Page 170] that the system forms using time information or that you 
enter online. 

• Secondary Wage Types 

Secondary wage types [Page 171] are technical wage types generated by the system in 
Payroll during the payroll run. 

These wage types have different purposes in the SAP system: 

• A wage type is typically evaluated with a monetary amount that should be paid out to the 
employee or that they should withhold. 

• It can also be used to cumulate several amounts for statistical evaluation. 

• It can be used by the system in Payroll to temporarily store interim results, and to move from 
one step to the next.  

The business task of a wage type determines whether it is entered online or is generated by the 
system, and how it is processed during the payroll run. 
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The Standard Pay wage type is used to assign the collectively agreed and fixed 
salary to an employee. It is therefore entered as a dialog wage type in the Basic Pay 
infotype (0008). 

The Total Gross Amount wage type is used to cumulate all wage types that belong to 
an employee's total gross amount. It is therefore generated as a secondary wage 
type by the system during the payroll run. 

The Standard Pay wage type is included in the Total Gross Amount wage type 
during the payroll run. 

Structure 
Fields 
A wage type consists of the following fields: 

• AMT (Amount) 

In the case of a standard pay wage type, for example, it contains the amount that the 
employee should receive. 

• RTE (Rate) 

Contains the valuation basis [Ext.] therefore in the case of an hourly wage type the 
hourly rate, which should be multiplied by the number of hours performed by the 
employee, during the payroll run. 

• NUM (Number) 

In the case of a time wage type, for example, it contains a number of time units such as 
hours, which, during the payroll run, should be multiplied by the valuation basis that you 
specified for this time wage type in Customizing.  

Depending on the wage type, one of the fields can be filled or entries can be available in two or 
all of the fields. 

Wage Type Characteristics 
A wage type is identified by the following characteristics: 

• Characteristics that control the entry of the wage type on-line, for example. 

− Can data be entered on-line for an infotype, personnel area, or employee subgroup? 

− Is a wage type regarded as a payment or a deduction? 

− Direct or indirect valuation? 

− Can the amount be overwritten on-line when an indirect valuation is performed? 

− Rounding? 

• Characteristics that determine how the wage type will be processed during the payroll run or 
the evaluation of the payroll results. 

− Processing Class [Page 172] 

− Evaluation Class [Page 173] 
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− Cumulation wage type [Ext.], in which the wage type should be included 

− Basis for calculating average value, in which the wage type should be included 

− Valuation basis, in which the wage type should be included 

Wage Type Groups 
Several similar wage types are grouped together in wage type groups [Ext.] 

See also: 
Assigning Wage Types to Wage Type Groups [Page 192] 

Using Wage Types [Page 197] 

Valuating Wage Types [Page 256] 
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Dialog Wage Types 
Definition 
Primary wage type that you enter on-line. 

Use 
You enter a dialog wage type in the following infotypes in the SAP System: 

• Basic Pay infotype (0008) 

• Recurring Payments and Deductions Infotype (0014) 

• Additional Payments infotype (0015)  

• EE Remuneration Info infotype (2010) 

• External Bank Transfers infotype (0011) 

• Time Quota Compensation infotype (0416) 

In some Time Management infotypes you can determine a different payment [Page 237]. Here 
you also enter a wage type. 

Apart from these internationally used infotypes there are additional nationally used infotypes. 

The dialogue wage types are evaluated [Page 257] in different ways. 
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Time Wage Type 
Definition 
Primary wage type that: 

• The system makes available by means of time data information, if certain conditions that you 
defined previously have been filled 

• You enter on-line 

Use 
Time wage types are selected by the system using time wage type selection [Page 231] in Time 
Evaluation. 

Time wage types are only written with a number (usually of hours) to the payroll program and, it 
is only at this point that they are evaluated [Page 258]. 

Example 
The standard system contains a model wage type Overtime Bonus 50%. You can use the 
customizing system to define conditions that must be met before the Overtime bonus 50% time 
wage type can be assigned to an employee. 

Such conditions could be as follows: 

• The employee must have worked at least 2 hours of overtime. 

• The employee must have worked on a weekend. 

• The employee must have worked on a public holiday. 

Whenever the conditions you defined are met, the system automatically selects the time wage 
type Overtime bonus 50% for the employee in question. 
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Secondary Wage Type 
Definition 
A technical wage type generated by the system. 

Use 
You do not enter secondary wage types on-line. The system generates secondary wage types 
during the payroll run or derives them from particular factors. 

Secondary wage types are also wage type that cumulate several wage types or temporarily store 
interim results.  

Structure 
The technical name of a secondary wage type always starts with the character (/), for example, 
/001. 

Example 
The standard system includes the secondary wage type /101 (Total Gross Amount). This wage 
type is created during the payroll run and is used to cumulate all of the wage types that pertain to 
an employee’s total gross amount. 
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Processing Class 
Definition 
A wage type characteristic that controls processing during payroll. 

Use 
There are different processing classes for the various processing steps that are carried out within 
payroll. During the payroll run, the system processes a wage type in a certain processing step 
according to its individual specification in the respective processing class. 

The standard system contains processing classes that have different specifications. You can also 
create customer processing classes and specifications in Customizing for Payroll under 
Environment → Environment of Wage Type Maintenance → Processing and Evaluation Classes 
→ Maintain Evaluation Classes and their Specifications [Ext.]. 

Structure 
A processing class has different specifications. 

Example 
In the standard system, processing class 15 determines how a wage type is valuated in 
accordance with the principle of averages. 

The standard system permits the following specifications for processing class 15: 

• Specification 1: Formula frame for averages over the last 3 months 

• Specification 2: Formula frame for averages over the last 12 months 
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Evaluation Class 
Definition 
Wage type characteristic, which controls processing when evaluating and displaying the payroll 
results. 

Use 
There are various evaluation classes for the different processing steps within the evaluation and 
displaying of payroll results. During evaluation, the system processes a wage type in a certain 
processing step according to it's individual specification in the respective evaluation class. 

The standard system contains evaluation classes with different specifications. You can also 
create customer evaluation classes and specifications in Payroll Customizing under Environment 
→ Environment of Wage Type Maintenance → Processing and Evaluation Classes → Maintain 
Evaluation Classes and their Specifications [Ext.]. 

Structure 
An evaluation class has different specifications. 

Example 
In the standard system, the specifications for evaluation class 02 control how a wage type is 
printed on a form. 

• Specification 00: no printing on the form 

• Specification 01: prints personal payments/deductions 

• Specification 02: prints wage types included in the total gross amount 

• Specification 03: prints wage types derived from time-based payments and included in the 
total gross amount 

 

 

April 2001  173 



Payroll United States (PY-US)  SAP AG 

Wage Type Copier 

Wage Type Copier 
Definition 
Tool used for creating the customer-specific wage type catalog [Page 176]. 

Use 

 
We recommend that you only use the wage type copier within Customizing 
(Transaction OH11). It is available in all the steps in which you copy wage types. You 
find this, for example, in Customizing for Payroll under Environment → Environment 
of Wage Type Maintenance → Create Wage Type Catalog. 

You can also call up the wage type copier outside of Customizing, using transaction 
PU30. 

The wage type copier provides you with the following functions: 

• Copy wage types 

You copy the model wage types, which are contained in your standard system, into the 
customer-specific name range. In this way you create your own customer-specific wage 
type catalog. 

• Delimit or delete wage types (time-based) 

You can delimit or delete wage types that you no longer require. 

 
Never delete SAP model wage types. 

Never delete customer-specific wage types in a live system; only ever do this in a 
test system. 

We recommend that you do not delete or delimit customer-specific wage types. 
Instead, you should no longer allow them to be entered in infotypes. Then the wage 
type can no longer be used in your system. You also avoid the problems that could 
arise when deleting or delimiting wage types. 

• 

• 

Check completeness of wage types 

The wage types are created in tables. Table T512W (Wage Type Valuation) is a central 
table that must contain all the customer-specific wage types. You can carry out a test run 
to check if the wage types included in other tables are also contained in Table T512W. 
You receive a list of all the wage types that are not contained in Table T512W. 

Documentation for model wage types 

When you copy a model wage type to the customer-specific name range, the system 
also copies the documentation. You can change the documentation for the customer-
specific wage type using transaction PDSY (HR Documentation Maintenance). 
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Wage Type Catalog 
Definition 
A directory of all the wage types used in Payroll.  

Use 
The wage type catalog in the standard system includes model wage types [Ext.] that are 
configured for the Payroll process. You generate your wage types by copying the model wage 
types to your customer name range. You can then modify the copies to suit your company-
specific requirements. 

 
Only use customer-specific wage types [Ext.] in your live payroll run. 

You edit the wage type catalog, for example: 

• in Customizing for Personnel Administration under payroll data [Ext.] 

• in Customizing for Payroll under Environment of Wage Type Maintenance →  Create Wage 
Type Catalog [Ext.]. 

For more information, see the Implementation Guide (IMG) for Personnel Administration under 
Payroll Data → Wage Type Concept [Ext.]. 

Structure 
• The SAP wage type catalog 

It includes all primary and secondary wage types required for Payroll. 

• Customer-specific wage type catalog 

You create the customer-specific wage type catalog in Customizing by copying the SAP 
model wage types into the customer-specific name range. 
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Creating the Customer-Specific Wage Type Catalog 
Use 
You use the wage type copier [Page 174] to create your own wage type catalog from the SAP 
wage type catalog, which contains all the model wage types. You copy the model wage types 
into your customer-specific name range and edit the copied wage types so that they meet your 
requirements. 

 
We recommend that you create your customer-specific wage type catalog within the 
Customizing framework. This prevents you forgetting important Customizing settings. 
For example, certain wage type characteristics are already preconfigured and must 
not be changed for legal reasons. 

Prerequisites 
Obtain an overview of the wage types required at your company. 

Features 
You can create your wage type catalog by copying whole wage type groups [Ext.] or using 
prototypes. 

• Copying Model Wage Types Assigned to a Wage Type Group [Page 178] 

If you do not have much experience of using the wage type catalog, it is best to use this 
procedure. The disadvantage of this procedure is that it is very time-consuming because 
you must completely configure each wage type you want to use. 

• Copying a Model Wage Type as a Prototype [Page 180] 

Only use this procedure if you have an exact overview of how you want to implement 
wage types in your company. This saves time because you must edit less customer-
specific wage types in detail. 

Activities 
1. You copy the SAP model wage types to the customer-specific name range. You have the 

following options: 

− You copy all the model wage types for a whole wage type group. 

− You copy a model wage type as a prototype [Ext.] 

− You use one of the wage types, which you have copied into your customer-specific name 
range within the framework of a wage type group, as a prototype. 

2. If you want to define characteristics for your customer-specific wage types, which are 
different to the model wage types, then you must edit these wage types with regard to 

− your dialog characteristics (for example, whether it is entered in the infotype) 

− the way it is dealt with in payroll (for example, processing classes and evaluation 
classes) 
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If you work with wage type groups you make this specification for every wage type; if you 
work with prototypes you make this specification for every prototype. 

3. If you have copied a sample wage type into your customer-specific name range as a 
prototype, you then duplicate this prototype. In this way you generate several wage types 
with the same characteristics from this prototype. You can still correct prototypes you have 
copied, for example, to adjust them to suit the wage type text. 
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Copying Model Wage Types Assigned to a Wage Type 
Group 
You can create your customer-specific wage type catalog by copying model wage types for a 
wage type group  [Ext.] from the SAP wage type catalog to the customer-specific name range. 
You can also copy just some of the model wage types assigned to a wage type group. 

Procedure 
1. Choose Copy in the initial screen of the wage type copier [Page 174]. 

The Copy Wage Types screen appears. 

− The Test Run function is active. We recommend that you carry out a test run first of all. 

− To use the wage type copier live, deactivate the Test Run function. 

2. Choose  Wage Type Group (change wage type group) and specify a wage type group. 

The wage types from the wage type group are displayed when you enter long and short 
texts. 

3. Select the wage types you want to copy and choose  CWT (Automatic Assignment of 
Customizing Wage Types). 

The Wage Type Maintenance dialog box appears. 

4. Enter the necessary data and choose . 

 
Only use wage type names from the customer-specific name range, in other words, 
names that start with a digit. You can also enter the customer wage type names 
individually. 

The copied wage types are displayed with the copy of the long and short texts. 

5. Adapt the wage type texts to meet your requirements, if necessary. 

6. Select the wage types you want to copy, and choose  Copy. 

Result 
You have copied sample wage types from a wage type group into the customer-specific name 
range. A list of the copied wage types [Page 183] is displayed for control purposes. 

Your customer-specific wage types have the same wage type characteristics as the SAP sample 
wage types that you have copied. You can change these characteristics in all the steps in 
Customizing in which you edit wage type characteristics. 

 
In Customizing for Personnel Administration, the Wage Types section is available in 
the Payroll Data unit for each infotype. Here you can edit valid wage types for this 
infotype. 
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In Customizing for Payroll under Environment → Environment of Wage Type 
Maintenance → Check Wage Type Characteristics [Ext.] you can change the dialog 
characteristics of your customer-specific secondary wage types. 
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Copying a Model Wage Type as a Prototype 
Use 
If some of the wage types that you need have similar wage type characteristics, you can use 
prototypes to create your customer-specific wage type catalog. In doing this, you copy a sample 
wage type from a wage type group in the SAP wage type catalog into the customer-specific 
name range as a prototype. You can adjust the wage type characteristics of the prototype so that 
they meet the needs of your enterprise. Then you create the remaining customer-specific wage 
types for this wage type group, by copying the prototype several times. 

 
If you use this procedure you should have an exact overview of how you want to 
implement wage types in your company. 

Procedure 
2. Choose Copy in the initial screen of the wage type copier [Page 174]. 

The Copy Wage Types screen appears. 

− The Test Run function is active. We recommend that you carry out a test run first of all. 

− To use the wage type copier live, deactivate the Test Run function. 

2. In the Original WT field (Original Wage Type) enter the model wage type for the prototype 
and choose . 

The wage type text for the sample wage type is displayed. 

3. In the Customizing WT field (Customizing Wage Type) enter the customer-specific wage type 
name for the prototype and select . 

 
Only use wage type names from the customer-specific name range, in other words, 
names that start with a digit. 

4. Adapt the wage type texts to meet your requirements, if necessary. 

5. Select the wage type and choose  Copy. 

Result 
A model wage type is copied to the customer name range as a prototype. A list of the copied 
wage types [Page 183] is displayed for control purposes. 

Your customer-specific wage types have the same wage type characteristics as the SAP sample 
wage type that you have copied. You can change these characteristics in all the steps in 
Customizing in which you edit wage type characteristics. 

 
In Customizing for Personnel Administration, the Wage Types section is available in 
the Payroll Data unit for each infotype. Here you can edit valid wage types for this 
infotype. 
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In Customizing for Payroll under Environment → Environment of Wage Type 
Maintenance → Check Wage Type Characteristics [Ext.] you can change the dialog 
characteristics of your customer-specific secondary wage types. 
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Duplicating a Wage Type 
Use 
You have copied a wage type as a prototype into your customer-specific name range and now 
want to duplicate it, so that you have several similar wage types available in your customer-
specific wage type catalog. 

In general you proceed as in copy model wage types for a wage type group [Page 178]. 

Prerequisites 
You defined the wage type characteristics of the prototype in Customizing, to meet your 
requirements. 

Procedure 
3. Choose Copy in the initial screen of the wage type copier [Page 174]. 

The Copy Wage Types screen appears. 

− The Test Run function is active. We recommend that you carry out a test run first of all. 

− To use the wage type copier live, deactivate the Test Run function. 

2. In the Original WT field (Original Wage Type) enter the name of your prototype and choose 
. 

The wage type texts for the prototype are displayed. 

3. Select the prototype and select 1 Duplicate WT (duplicate wage type). 

The Wage Type Maintenance dialog box appears. 

5. Enter the necessary data and choose . 

 
Only use wage type names from the customer-specific name range, in other words, 
names that start with a digit. You can also enter the customer wage type names 
individually. 

The copied wage types are displayed with the copy of the long and short texts. 

6. Adapt the wage type texts to meet your requirements, if necessary. 

7. Select the wage types you want to copy, and choose  Copy. 

Result 
You have duplicated the prototype. A list of the copied wage types [Page 183] is displayed for 
control purposes. 
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List of Copied Wage Types 
Definition 
Overview of the wage types that you have copied in the customer-specific name range and the 
SAP system tables that belong to them.  

Use 
The list of the copied wage types is displayed at the end of a copying procedure in the wage type 
copier [Page 174]. You can use the list to determine whether 

• you have to reprocess table entries manually 

These tables are highlighted in yellow in the tree structure 

• a table is locked by another user so that no changes can be made 

These tables are highlighted in red in the tree structure 

 
Do not leave the wage type copier if tables are locked by other users. The 
information that you have already entered for copying the wage types is therefore not 
lost. Instead, ask the other users to leave the table. After they have come out of the 
table in question, you can edit the wage type. 

Structure 
The list of the copied wage types is represented by the system as a tree structure. It contains 

• A list of all tables into which wage types have been copied by the system or should be 
copied. 

• Information on which copied wage types are assigned to the corresponding tables. 

The assignment of the wage type to the table either takes place using the key or the 
function part of the table: 

− Key 

In this case the table field, which the wage type name contains, is part of the table 
key. In such tables the system copied the entries. 

 
Table T511 (Wage Types) has the following key fields: 

000 Client 

99 Country group 

3333 Customer wage type name 

99991231 Expiry date of the wage type 31.12.9999 

In this table the wage type name is part of the key. The wage type could have been 
copied by the system. 
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− Function part 

In this case, the wage type name is included in the function part of the table rather 
than the key. The function part of a table consists of all the fields that do not belong 
to the table key. If the wage type name is in the function part of the table, it is not 
possible to simply copy the table, because then the table will have several entries 
with the same key. 

In such tables the system could not automatically copy the wage type. You must 
therefore copy wage types manually [Page 185]. 
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Copying Wage Types Manually 
Use 
In the list of copied wage types [Page 183] the SAP tables, in which the system can not copy the 
model wage types to the customer-specific name range, have a yellow background. You must 
copy these wage types manually. 

Prerequisites 
You have copied model wage types to your customer name range using the wage type copier 
[Page 174], and are now in the list of copied wage types. 

Procedure 
You have two editing possibilities: 

Overwrite in Customizing 

 
We recommend this procedure. 

1. Click on the text Wage type is Not a Key Field, Please Maintain Manually, which is displayed 
with a yellow background. 

You access the section in Customizing where you can call up the appropriate activity to 
edit the wage type. 

2. Call the activity. 

3. Overwrite the name of the model wage type with your customer wage type name. 

Overwrite Directly 
In the list of copied wage types, flag the wage type you want to edit, and choose Overwrite. 

 
This procedure is useful if you have to edit a lot of wage types manually. 
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Time-Based Delimitation of a Wage Type 
Use 
If you no longer need a customer-specific wage type, you can delimit this wage type (time-based) 
using the wage type copier. It is then no longer available in your system. 

 
Never delimit SAP model wage types. 

Never delimit customer-specific wage types in a live system; only ever do this in a 
test system. 

We recommend that you do not delimit wage types with respect to time, as this can 
cause problems during the Payroll run. Instead, you should define in Customizing 
that the wage type should no longer be permitted for entry in any infotype. For 
example, you have the possibility of doing this for each infotype in Customizing for 
Personnel Administration in the section Payroll Data [Ext.]  

Prerequisites 
You have copied SAP model wage types to the customer name range. 

Procedure 
1. Choose Delete in the initial screen of the wage type copier [Page 174]. 

The Delete Wage Types screen appears. 

2. In the column Delete WT (wage type to be deleted), enter the name of the wage types that 
you want to delimit with respect to time. 

3. Select the wage types that you want to delimit. 

4. Select Limit wage types according to time until... and enter the delimitation date. 

 
The delimitation date must be a payroll period after the date from which you no 
longer need the wage type. The system still needs the wage type for another payroll 
period, to be able to import the payroll result from the previous period. 

5. Choose  Delete. 

A list of the deleted wage types [Page 190] is displayed. 

Result 
The system makes the following changes in the SAP System tables: 

• In the date-dependent tables, the system sets the end date of the selected wage type to the 
delimitation date you have specified. The wage type is still available in this table, but can only 
be used up until this delimitation date. 

Example: Table T512W (Wage Type Evaluation) 
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• In the tables that are not date dependent, the system can not delimit the wage type. The 
following options are available: 

− If the wage type to be delimited is part of the table key, it is deleted. This means that you 
will no longer be able to copy the wage type. 

Example: Table T555K (Transfer to Time Wage Types) 

− If the wage type to be delimited is not part of the key, you have to manually delimit [Page 
191] the wage type. 

 

April 2001  187 



Payroll United States (PY-US)  SAP AG 

Deleting Wage Types 

Deleting Wage Types 
Use 
If you no longer need a customer-specific wage type, you can delete this wage type from the 
wage type catalog using the wage type copier. It is then no longer available in your system. 

 
Never delete SAP model wage types. 

Never delete customer-specific wage types in a live system; only ever do this in a 
test system. 

We recommend that you do not delete wage types, as this can cause problems 
during the Payroll run. Instead, you should define in Customizing that the wage type 
in question should no longer be permitted for entry in any infotype. For example, you 
have the possibility of doing this for each infotype in Customizing for Personnel 
Administration in the section Payroll Data [Ext.]. As an alternative we recommend 
that you do not delete the wage type, but rather that it should be delimited with 
respect to time [Page 186]. 

Prerequisites 
You have copied SAP model wage types to the customer name range. 

Procedure 
2. Choose Delete in the initial screen of the wage type copier [Page 174]. 

The Delete Wage Types screen appears. 

2. In the column Delete WT (wage type to be deleted), enter the name of the wage types that 
you want to delete. 

 
Only specify wage type names from your customer name range. 

3. Select the wage types you want to delete. 

4. Select Delete Wage Types.  

5. Choose  Delete. 

A list of the deleted wage types [Page 190] is displayed. 

Result 
The system makes the following changes in the SAP System tables: 

• If the wage type name is in the table key, the system deletes all table entries for the selected 
wage type.  

• If the wage type name is not in the table key, but is contained in the function part of the table, 
then the system can not delete the entry. These table entries must therefore be deleted 
manually [Page 191].  
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The deleted wage type is neither available for wage type copying or for other activities in the SAP 
system. 
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List of Deleted Wage Types 
Definition 
Overview of the customer wage types that you have deleted or delimited with respect to time, 
and the SAP system tables which belong to them. 

Use 
The list is displayed if you have deleted or delimited customer wage types in the wage type 
copier [Page 174]. You can use the list to determine whether 

• you have to reprocess table entries manually 

These tables are highlighted in yellow in the tree structure 

• a table is locked by another user so that no changes can be made 

These tables are highlighted in red in the tree structure 

 
Do not leave the wage type copier if tables are locked by other users. Otherwise, the 
information that you have already entered for deleting or delimiting the wage types 
gets lost. Instead, ask the other users to leave the table. After they have come out of 
the table in question, you can edit the wage type. 

Structure 
The list of the deleted wage types is represented by the system as a tree structure. It contains 

• A list of all the tables in which wage types have been, or should have been, deleted or 
delimited by the system. 

• Information on which deleted /delimited wage types were assigned to the corresponding 
tables. 

The assignment of the wage type to the table either takes place using the key or the 
function part of the table. For more information, see the list of copied wage types [Page 
183]. 

− If the table field, which contains the wage type names, is part of the table key, the system 
has deleted or delimited the entry with respect to time. 

− If the wage type name is contained in the function part of the table, the system could not 
automatically delete or delimit the wage type with respect to time. You must therefore 
delimit or delete these wage types manually [Page 191]. 
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Deleting or Delimiting Wage Types Manually 
Use 
In the list of deleted wage types [Page 190] the SAP tables, in which the system can not delete or 
deimit the customer-specific wage types, have a yellow background. You must delete or delimit 
these wage types manually. 

Prerequisites 
You have delimited or deleted customer-specific wage types using the wage type copier [Page 
174] and are now in the list of deleted wage types. 

Procedure 
You have two editing possibilities: 

Delete or Delimit in Customizing 

 
We recommend this procedure. 

2. Click on the text Wage type is Not a Key Field, Please Maintain Manually, which is displayed 
with a yellow background. 

You access the section in Customizing where you can call up the appropriate activity to 
edit the wage type. 

2. Call the activity. 

3. Delete the customer-specific wage or delimit it with respect to time. 

Delete Directly or Delimit (Time-Based) 
In the list of deleted wage types, flag the wage type you want to delete or delimit, and choose 
Delete or Delimit. 

 
This procedure is useful if, for example, you have to delete or delimit a lot of wage 
types manually. 
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Assigning Wage Types to Wage Type Groups 
Use 
The customer-specific wage types, which you have copied from SAP model wage types, are 
automatically assigned to the same wage type group [Ext.] as the model wage types. You can 
change this assignment. Moreover, you can also obtain an overview of the assignment of wage 
types to wage type groups. 

 
The assignment of wage types to logical views [Ext.] takes place using wage type 
groups. If you remove a wage type from a wage type group, it is no longer available 
in the logical view to which the wage type group is assigned for editing of the wage 
type characteristics. 

Scope of Function 
In transaction PU98 (Assign Wage Types to Wage Type Groups) you have the following options: 

• Assign customer wage types to a wage type group 

 
After a release upgrade from Release 2.1 or 2.2 to Release 3.0 or higher, you must 
assign all customer-specific wage types to a wage type group. Wage type groups 
were only introduced with Release 3.0 of the SAP-R/3 System. This means that you 
must include wage types created in Release 2.1 or 2.2 in wage type groups. 

• Delete customer wage types from a wage type group 

When you have created a customer wage type catalog, you can delete a customer wage 
type from a wage type group. 

• Display all wage types that are not assigned to a wage type group 

You can display the customer wage types that have not been assigned to a wage type 
group. 

• Display all wage types assigned to a particular wage type group 

For example, you can display all wage types assigned to the (Basic Pay) wage type 
group (0008). 

• Display assignment of wage types to wage type groups 

You can display the wage type groups to which one or several wage types are assigned. 

If you want to display the assignment of more than one wage type, you have the 
following options: 

− Display the total quantity: 

All of the wage type groups containing at least one of the selected wage types are 
displayed. 

− Display the common quantity: 

The wage type groups containing all of the wage types are displayed. 
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Displaying the Assignment of Wage Types to Wage 
Type Groups 
Use 
If, for example, you delete a customer-specific wage type from a wage type group and you want 
to assign it to another wage type group, you can first of all check to see the wage type groups to 
which this wage type is already assigned. 

Procedure 
1. Select transaction PU98. 

2. In the Template Using Model Wage Types block, choose the entry All Wage Types. 

3. Select the wage types whose assignment to wage type groups you want to check. 

4. Select one of the following indicators: 

− Total quantity 

All of the wage type groups containing at least one of the selected wage types are 
displayed. 

− Common quantity. 

The wage type groups, in which all the selected wage types are contained, are 
displayed. 

5. Choose Display Groups. 

Result 
In the Wage Type Groups block, depending on the indicators you have selected, the 
corresponding wage type groups are flagged: 

• to which at least one of the selected wage types is assigned 

•  to which all of the selected wage types are assigned 

 

194  April 2001 



 SAP AG Payroll United States (PY-US) 

  Deleting Customer Wage Types from a Wage Type Group 

Deleting Customer Wage Types from a Wage Type 
Group 
Use 
You want to change the assignment of a customer-specific wage type to the wage type groups. 
You want to delete the wage type from a wage type group and now want to assign it to another 
wage type group. 

Procedure 
1. Select transaction PU98. 

2. In the Wage Types to be Assigned block, choose the Customer-Specific Wage Types entry. 

A list is displayed of all customer wage types. 

3. Select the customer wage type that you want to delete from a wage type group. 

4. In the Wage Type Groups block, select the wage type group from which the wage type 
should be deleted. 

5. Select the Delete indicator. 

6. Choose Group assignment. 

The Delete Wage Types in the Wage Type Groups dialog box appears. A dialog box is 
displayed for control purposes telling you which wage types are deleted from which wage 
type groups. 

7. Choose . 

Result 
The customer wage type is deleted from the selected wage type group. 
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Assigning Customer Wage Types to a Wage Type Group 
Use 
You want to change the assignment of a customer-specific wage type to the wage type groups. 
You have deleted the wage type from one wage type group and now want to assign it to another 
wage type group. 

 
After changing from Release 2.1 or 2.2 to Release 3.0 or a later release, you have to 
first of all assign all the customer-specific wage types, which you created in earlier 
releases, to a wage type group.  

We recommend that you proceed as follows: 

1. Choose a customer wage type to be assigned. 

2. Select a model wage type that corresponds to the customer wage type. 

3. Display the wage type groups [Page 194], to which the selected model wage 
type is assigned. 

4. Assign the customer wage type to these wage type groups. 

Procedure 
1. Select transaction PU98. 

2. In the Wage Types to be Assigned block, choose the Customer-Specific Wage Types entry. 

A list is displayed of all customer wage types. 

3. Select the customer wage type that you want to assign to a particular wage type group. 

4. In the Wage Type Groups block, select the wage type group to which the wage type should 
be assigned. 

5. Flag the Insert indicator. 

6. Choose Group assignment. 

The Add Wage Types to Wage Type Groups dialog box appears. A dialog box is 
displayed for control purposes telling you the wage types you have assigned to the wage 
type groups. 

7. Choose . 

Result 
The customer wage type is assigned to the selected wage type group. 
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Using Wage Types 
Use 
The function enables you to obtain an overview of the wage type characteristics for all the 
primary and secondary wage types that you use. You might want to do this to compare the 
characteristics of different wage types, for example, or to obtain an overview of the status of your 
wage types within the system. 

To obtain the overview, run report program RPDLGA20 (Use of Wage Types in Payroll). The 
report generates a list of the wage types available for a selected country. 

Scope of Function 
The report only evaluates the wage types that affect the Behavior of a Wage Type in Payroll, 
and not the characteristics that determine the Behavior of a Wage Type On-Line. 

The list is arranged according to wage type characteristics and their specifications. The wage 
types, which are assigned to the following wage type characteristics, are displayed. 

• Processing classes 

• Evaluation classes 

• Cumulations 

• Bases for calculating averages 

• Valuation bases 

In the wage type utilization list, the personnel areas that belong to the selected country are 
displayed. 
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Creating a Wage Type Utilization List 
1. Choose Human Resources → Payroll → Environment → Wage Type Utilization. 

2. In the Country Grouping field of the Selection block, enter the country grouping for which you 
want to check the wage type utilization. 

3. In the Wage Type Validity field enter a validity period. 

The system only displays the usage of the wage types that are valid within this validity 
period. 

4. If necessary, restrict the evaluation to one or several wage types, by entering it in the Wage 
Type field. 

5. Select Display Logical Views, if necessary. 

In the generated tables or tree structure, all the logical views [Ext.] in which you can edit 
the corresponding class are displayed for the processing classes, evaluation classes and 
cumulations, if you flag this option. If there is an IMG section corresponding to the logical 
view, this will be displayed. You can navigate from the wage type utilization list to the 
corresponding IMG activity and make the changes there. 

6. In the Output block, select the required output form. 

− To display a list with a hierarchical structure, choose Table. 

If, for example, you are only interested in the use of individual processing classes in 
wage types, we recommend you use a table as the output form for the results. 
Displaying the results in table form takes less time, because the system only 
determines the relevant information when it accesses the next level. 

In the tables you can double click on a line of the table (for example, Processing 
Classes) to navigate to the detailed view for the corresponding table entry. 

− To display a list with a tree structure, choose Tree Structure. 

− To obtain a non-hierarchical list of the wage type characteristics, choose Continuous List. 

If you want to obtain a complete where-used-list, you should use the tree structure or 
continuous list as the output form for the results. It takes longer, however, if you use 
the tree structure and the continuous list, because the system has to determine all 
the information for the sub-nodes and levels before it can display the results. 

7. Choose Program → Execute. 
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Wage Type Split 
Definition 
The division of payroll periods into partial periods when entries in different infotypes have been 
changed. The wage types are assigned to these partial periods. 

The wage type split has the following significance in the payroll results: 

• It defines changes to infotypes for the exact day and indicates these periods in the payroll 
results using a two-digit number: the split indicator. 

• It provides a link from the Results Table RT to other payroll tables. The information relevant 
for the split is assigned to the infotype using this table. 

 
The Work Center-/Basic Pay Split (WPBP-Split) [Ext.] provides a link to table WPBP: 

Table RT Table WPBP

01.01. 10.01. 31.01.

01 02

Standard Pay wage type(MA10)

WPBP-Split

20.01.

03

InfotypesOrganizational
Assignment (0001)

Planned Working
Time (0007)

Basic Pay
(0008)

Infotype 0001
Infotype 0007
Infotype 0008

Infotype 0001
Infotype 0007
Infotype 0008

Infotype 0001
Infotype 0007
Infotype 0008

Division of payroll periods

Assign information from infotypes

Link

Wage Type WPBP ...
MA10 01 ...
MA10 02 ...
MA10 03 ...
MA20 ...

01 Information
from IT 0001

Information
from IT 0007

Information
from IT 0008

...

02 Information
from IT 0001

Information
from IT 0007

Information
from IT 0008

...

03 Information
from IT 0001

Information
from IT 0007

Information
from IT 0008

...

... ... ... ... ...

 

Use 
The system uses the following wage type splits: 

Use if 

an employee's work center and/or basic pay 
change within a payroll period 

an employee's assignment to a cost center 
changes within a payroll period  

Wage Type Split 

Work Center-/ Basic Pay Split (WPBP-Split) 

Cost Accounting Split (KR-Split) 
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Split for Different Payments (ALP- Split) an employee carries out substitution during a 
payroll period and is remunerated differently 
than normal. 

an employee is absent once or several times 
(for example, leave or illness) during a payroll 
period. 

Absence Split (AB-Split) 

Bank-Transfer-Split (BT-Split) an employee has one main bank account and 
one, or several, secondary bank accounts. 

Variable Split (VO-Split) there is special information available for an 
employee for a payroll period, for example, 
information on a garnishment, a loan or a 
company car 

Country-Specific Splits (C1-Split, C2-Split, C3-
Split) 

 
The WPBP-split is displayed as AP-split in the RT table because of space 
restrictions. 

 

there is country-specific information available 
for an employee for tax, social insurance and 
so on. 

200  April 2001 



 SAP AG Payroll United States (PY-US) 

  Wage Type Split: Example 1 

Wage Type Split: Example 1 

 
Wage type MA10 is available with a Work Center-/Basic Pay Split (WPBP-Split). The WPBP-split 
covers two partial periods that are indicated in the payroll results with split indicators: 

Time 
Character
istic 

Representation in the 
Payroll Results 
(Table RT) 

End date Wage 
type 

01.01. 09.01. MA10 01 

An employee's standard pay is changed on January 10 in the Basic Pay (0008) infotype:  

01.01. 10.01. 31.01.

01 02

Standard Pay wage type (MA10)

Work Center-/Basic Pay Split (WPBP)

Start date AP 

10.01. 31.01. MA10 02 
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Wage Type Split: Example 2 
An employee's standard pay is changed on January 12 in the Basic Pay (0008) infotype:  A Work 
Center-/ Basic Pay Split (WPBP-Split) is created as a result. The employee also takes leave 
twice in this payroll period. Wage type AB01 is generated to calculate the absences. An Absence 
Split (AB-Split) exists for this wage type.  

Wage type AB01 is taken from the system and split up among the WPBP periods. Wage type 
AB01 is available with a Work Center-/Basic Pay Split (WPBP-Split) and an Absence Split (AB-
Split). Both the WPBP-split and the AB-split cover two partial periods that are indicated in the 
payroll results with split indicators:  

Work Center-/Basic Pay Split 

Time 
Character
istic 

Representation in the 
Payroll Results 
(Table RT) 

End date Wage 
type 

01.01 

01.01. 31.01.

01

Payroll Period 01 (January)

01 02

12.01.

Work Center-/Basic Pay Split (WPBP)

02 Absence Split (AB)

16.01. 25.01.

 

Start date AP 

11.01. ABO1 01 

12.01. 31.01. ABO1 02 

Absence Split 

Time 
Character
istic 

Representation in the 
Payroll Results 
(Table RT) 

Start date End date Wage 
type 

AB 

01.01. 15.01. ABO1 01 

25.01. 31.01. ABO1 02 

Both splits are represented in the payroll results as follows: 

Time 
Character
istic 

Representation in the 
Payroll Results 
(Table RT) 

Start date End date Wage 
type 

AB AP 

01.01. 11.01. ABO1 01 01 
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12.01. 15.01. ABO1 01 02 

25.01. 31.01. ABO1 02 02 
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Payments 
Definition 
Payments that the employee is entitled to according to the employment contract (= stipulated in 
the employment contract) or that they accrue (= paid voluntarily by the employer). 

The individual payments form the basis for the calculation of an employee’s gross remuneration, 
which is the core part of payroll. Gross remuneration is the starting point for the calculation of 
social insurance and tax payments, and also for the calculation of net remuneration.  

Structure 
In the SAP System, payments are split into the following categories according to their 
characteristics: 

Basic pay 

Basic pay consists of the fixed wage and salary elements that are paid in every payroll 
period. You enter them in the form of wage types in the Basic Pay(0008) [Page 205] 
infotype. 

• 

• Recurring payments and deductions 

Recurring payments and deductions are paid or retained with fixed frequency. The 
system determines the payments using factors such as overtime, leave or substitutions. 
You enter the wage types which illustrate these factors in the 

 infotype. In the processing stage, the system uses the 
Customizing settings representing the collective agreement. 

Recurring Payments and 
Deductions (0014) [Page 213]

Additional Payments 

Additional payments are wage and salary elements that are not usually paid in each 
payroll period, and that are not paid at regular intervals. You enter them in the 

216  infotype. 

• 

Additional 
Payments(0015) [Page ]
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Basic Pay (Infotype 0008) 
You can store the employee’s basic pay in the Basic Pay infotype (0008) . You get an overview 
of the employee’s payroll history using the infotype history. 

The standard system contains the following reference types: 

• Subtype 0: Basic contract 

• Subtype 1: Increase basic contract 

• Subtype 2: Comparable domestic pay 

• Subtype 3: Refund of costs in foreign currency 

• Subtype 4: Local weighting allowance 

You can process the Basic Pay infotype (0008) on its own or during a personnel action. If you 
want to create a new infotype record, enter the reference type on the screen Maintain HR Master 
Data.  The reference type is already set if you carry out a personnel action 

Pay scale 
The system automatically proposes the Pay Scale Type and the Pay Scale Area.  However, you 
can overwrite these values. 

Wage types 
If you want to insert an infotype record, the system automatically suggests the wage types. There 
are a few wage types which you can not overwrite or delete.  You can enter up to 20 wage types.  

 
When an employee leaves a company you are not permitted to delimit the Basic Pay 
infotype (0008).  Basic payroll data must remain in the system. This is the only way 
of ensuring the accuracy of any retroactive accounting runs that need to be 
performed. 

 

See also: 
Enter Basic Pay [Page 206] 

Performing a Personnel Action [Page 20 ]9  

Performing a Standard Pay Increase [Page 211] 
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Editing Basic Pay 
Procedure 
1. Choose the menu path Human Resources → Personnel Management → Administration → 

HR Master Data → Maintain. 

You access the Basic Pay infotype (0008) by calling up the Display HR Master Data, 
Maintain HR Master Data or Personnel Actions screens. 

2. Check the entries from the collective agreement. If necessary, change the pay scale 
structure assignment. 

3. Check the default wage types from the wage type model. 

4. Enter an amount for directly valuated wage types. 

Directly valuated wage types with no values entered in the Amount, Number and Unit 
fields are not saved. 

5. If necessary, enter a number and a unit for indirectly valuated wage types, for example, for 
wage types whose amount is calculated as a percentage of the sum of other wage types. 

The amount of the indirectly valuated wage types is only displayed, but is not saved. If 
your Customizing settings specify that indirect valuation is only valid until a date prior to 
the validity end date of the infotype record in the Basic Pay infotype (0008), an 
appropriate message will be displayed. If this is the case you can re-enter the date on 
which indirect valuation should take place, in the Ind.Val. field. 

  
For indirect valuations, an infotype record must be created for the employee in the 
Planned Working Time infotype (0007). 

Indirectly valuated wage types must not be overwritten because the indirect valuation 
will therfore be lost. 

You can enter a maximum of twenty wage types for each employee. If your Customizing 
settings permit fewer wage types, fewer lines will be available. 

6. If necessary, delete any default wage types that are not required. 

7. Check the total amount of the wage types. 

The total payment amount is calculated by the system. All wage types to be included in 
the total amount, in accordance with the Customizing settings, are flagged in field A (Add 
to Total Amount). 

8. Choose . 

 
Depending on the Copy Default Values for Infotypes feature (DFINF), the values in 
the Pay Scale Type, Pay Scale Area, Capacity Utilization Level and Work 
Hours/Period fields 
 will be redefined, but not copied. The values in the Capacity Utilization Level and 
Work Hours/Period fields are copied if the values in the old infotype record do not 
correspond to the default values at that time 
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If you copy the infotype record in a batch input session and change the validity start 
date, you should first enter a date in the From field and then copy the data. You can 
then enter data in other fields, (for example, Wage Types). 

For more information on editing basic pay, see 
. 

 

Performing a Pay Scale Reclassification [Page 
]209
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Pay Scale Reclassification 
Use 
A pay scale reclassification is the transfer of an employee to a different pay scale group and 
possibly to a different pay scale level. As a result of this transfer, the employee receives the 
remuneration for the new pay level assignment.  

A pay scale reclassification is usually performed in a payroll period prior to the payroll run. The 
pay scale reclassification must always take place before the standard pay increase. 

Activities 
You carry out the pay scale reclassification using Report RPITUM00. 

The system takes the basis for the pay scale reclassification from Customizing. For more 
information, see the Implementation Guide (IMG) for Personnel Management under Personnel 
Administration → Payroll Data → Basic Pay → Pay Scale Changes → Pay Scale Reclassification 
[Ext.]. 

Alternatively, you can enter a different date for the next increase in the Basic Pay infotype (0008). 
This alternative date overrides the entries in Customizing. 
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Performing A Pay Scale Reclassification 
Procedure 
1. Choose System → Services → Reporting. 

2. In the Program field enter report RPITUM00 and choose . 

The selection screen for the report is displayed. 

3. In the sections Period, Selection and Further Selections, enter the selection criteria you want 
to use to perform a pay scale reclassification. For example, you can make a selection 
according to payroll administrator or a specific organizational unit. 

4. Enter the following parameters in the Data Relevant for Batch Input section: 

a. Choose Create Batch Input Session. 

b. Enter the additional parameters. 

c. If necessary, enter the pay scale structure for which you want to perform a pay scale 
reclassification. 

These entries further restrict the selected employees. 

5. Choose . 

 
If you do not select Create Batch Input Session, the pay scale reclassification will 
only be simulated. A results log is displayed, that you can evaluate as required. 

You can use reports RPLTRF00, RPLTRF10, and RPSTRF00 to generate lists 
containing employees employed on a key date with the pay scale structure and 
additional information on the current pay scale assignment. For more information, 
see the report documentation. 

6. Process the batch input session. 

Result 
As a result of the pay scale reclassification, the pay scale structure for the employee in the Basic 
Pay infotype (0008) will be updated. If you have not reset the default value (1601) of the 
Action/Action for Pay Scale Reclassification parameter, the action performed will also be logged 
in the Actions infotype (0000). 
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Standard Pay Increase 
Use 
You may encounter automatic standard pay increases for employees whose basic pay has been 
calculated indirectly, based on the assignment to a particular pay scale structure, in accordance 
with the Customizing settings. For more information, see the Implementation Guide (IMG) for 
Personnel Management under Personnel Administration → Payroll Data → Basic Pay → Pay 
Scale Changes → Pay Scale Increase. 

Scope of Function 
The system differentiates between the following types of standard pay increases: 

Simple Standard Pay Increase 
The amounts in the Customizing settings are increased by a specific amount or percentage rate. 

Extended Standard Pay Increase 
The history in the Basic Pay infotype (0008) is updated. You can also modify directly valuated 
wage types and use different increase variants. You can use increase variants, for example, to 
insert new wage types, replace existing wage types with new ones, or delimit existing wage types 
without replacement. 

In the following cases, you can use an extended standard pay increase in addition to a simple 
standard pay increase: 

• You want to update the history in the Basic Pay infotype (0008). This applies to those 
employees whose pay was adjusted using a simple standard pay increase because of its 
assignment to a pay scale structure. 

 
The extended standard pay increase saves infotype records in database PA0008. 
This reduces memory space on the hard disk. 

• You want to use additional increase variants for directly and indirectly valuated wage types. 
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Effecting a Standard Pay Increase 
Simple Standard Pay Increase 
1. Choose System → Services → Reporting. 

2. In the Program field enter report RPU51000 and choose . 

The selection screen for the report is displayed. 

3. In the Pay Scale Group, Pay Scale Level and Wage Type fields, enter the employees who 
should receive a standard pay increase. Enter the date from which the Customizing settings 
should be changed. 

4. In the Increase and Rounding sections, enter the necessary data, for example, an increase 
amount or an increase percentage rate. 

5. Choose . 

The amount of the indirectly valuated wage types is adjusted according to the data in the 
Customizing settings. No new infotype records have been created in the Basic Pay infotype 
(0008). 

For more information, see the IMG for Personnel Management under Personnel Administration 
→ Payroll Data → Basic Pay → Pay Scale Changes → Pay Scale Increase, or under Personnel 
Administration → Payroll Data → Basic Pay → Revise Pay Scale Groups and Levels. 

Extended Standard Pay Increase 
1. Choose System → Services → Reporting. 

2. In the Program field enter report RPITRF00 and choose . 

3. In the Selection section, enter the selection criteria you want to use to effect an extended 
standard pay increase. For example, you can make a selection according to administrator, or 
a specific organizational unit. 

4. Enter the following parameters in the Further Selections section: 

a. Choose Batch Input. 

 
If you do not select Batch Input, the pay scale reclassification will only be simulated. 
A results log is displayed, that you can evaluate as required. 

b. If necessary, enter the pay scale structure for which you want to effect a standard pay 
increase. 

c. Enter the additional parameters. 

These entries further restrict the selected employee headcount. 

5. Choose . 

6. Process the batch input session. 
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The payments for the selected employees have been adjusted in accordance with the data 
specified in Customizing. New infotype records have been created in the Basic Pay infotype 
(0008). 
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Recurring Payments/Deductions (Infotype 0014) 
In the Recurring Payments/Deductions infotype (0014), you can enter an amount and/or a value 
and a unit of measurement for a wage type that is always paid or deducted during payroll. 
Recurring payments/deductions are wage elements which are paid or deducted in every payroll 
period. In contrast to additional payments, recurring payments/deductions are paid or deducted 
within a defined periodicity. 

In addition, you have the possibility to enter default cost assignment settings for recurring 
payments/deductions for the application component Controlling (CO). You can store a different 
cost center and company code combination than the one in the Organizational Assignment 
infotype (0001); the additional payments will then be charged to this cost center. Select Edit → 
Maintain cost assignment. The Default Cost Assignment Settings dialog box appears. Enter the 
relevant data. If any data has already been entered for the cost assignment it will be displayed on 
the infotype single screen. You can set up further controlling objects using customizing in the 
section  in Personnel Administration Enter Default Cost Assignment Settings [Ext.]

The standard system contains, amongst others, the following wage types: 

• Subtype M110: Vacation allowance 

• Subtype M120: Holiday bonus 

• Subtype M130: Standard special payment 

• … 

Recurr. Pay/Deduc 
Enter the wage type that is to be paid or deducted in the Wage Type field. In conjunction with the 
Wage type you must process either the Amount field or the Number and Unit fields. The system 
checks the combination you entered. The currency is defaulted according to the company code. 
This can be overwritten. 

Date of Payment 
A wage type is only paid in certain periods or on certain days. These periods or days can be 
defined either in the 1st payment period and Interval in periods fields, thus defining the interval to 
the next and all subsequent periods, or in the 1st payment date and Interval/Unit fields, thus 
defining the interval to the next day and all subsequent days. Enter the payment period without 
the payroll year. The subsequent payment periods will be determined by adding the intervals. 

 
If the report RPCDTBX0 (Preliminary Data Medium Exchange Program for Separate 
Payment Run) has created a preliminary document for a wage type transfer, the 
Transfer field is displayed on the infotype screen. You can not delete the wage type 
in this case. 

See also: 
Define Recurring Payments and Deductions [Page 215] 
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Country-Specific Features 
• Great Britain: Recurring Payments/Deductions (Infotype 0014): National Features Great 

Britain [Ext.] 
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Processing Recurring Payments and Deductions 
Use 
Using recurring payments and deductions you determine the wage and salary components which 
under normal circumstances you pay or deduct from an employee. You can pay bonuses for 
travel costs or holiday pay, for example. 

You can enter an additional payment that differs from the cost assignment in the Organizational 
Assignment infotype (0001) for recurring payments and deductions. If this is the case, the 
recurring payment/deduction will be taken from the cost center that differs from the master cost 
center. 

Defining Recurring Payments and Deductions 
1. Choose Human Resources -> Personnel Management -> Administration -> HR Master Data -

>Maintain. 

2. Enter the personnel number of the employee concerned and choose the Recurring Payments 
and Deductions infotype (0014). 

3. Choose . 

4. Enter the data required in the fields. 

 
The entries in the Amount and Number/Unit fields depend on the selected wage 
type. For directly valuated wage types, enter the amount and the number or unit. 
This is not necessary for indirectly valuated wage types. 

You can either make entries in the First Payment Period and Interval in Periods field, 
or in the First Payment Date and Interval/Unit field. If you have entered the first 
payment period and the interval in periods, you cannot enter data for the payment 
date and interval/unit, and vice versa. 

5. Choose . 

Defining Recurring Payments and Deductions for Varying 
Account Assignments. 
1. On the Recurring Payments and Deductions screen choose . 

The Cost Assignment Defaults dialog box appears. 

2. Enter the different assignments. 

3. Choose Transfer. 

You have created a cost assignment for a recurring payment/deduction that differs from the cost 
assignment in the Organizational Assignment infotype (0001). 
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Additional Payments (Infotype 0015) 
In the infotype Additional Payments (0015), you can enter an amount and/or a value and a unit of 
measurement in a wage type; these are always paid or deducted in a certain period during 
payroll. Additional payments are wage elements which are not paid or deducted in every payroll 
period in contrast to recurring payments and deductions which are paid or deducted within a 
defined periodicity. 

In addition, you have the possibility to enter default cost assignment settings for additional 
payments for the application component Controlling (CO). You can store a different cost center 
and company code combination than the one in the Organizational Assignment infotype (0001); 
the additional payments will then be charged to this cost center. Select Edit → Maintain cost 
assignment. The Default Cost Assignment Settings dialog box appears. Enter the relevant data. 
If any data has already been entered for the cost assignment it will be displayed on the infotype 
single screen. You can set up further controlling objects using customizing in the section 

 in Personnel Administration. Recording Cost Assignment Specifications [Ext.]

The standard system contains, amongst others, the following wage types: 

• Subtype M110: Vacation bonus 

• Subtype M120: Christmas bonus 

• Subtype M30: Special payment 

• … 

Additional Payments 
Enter the wage type that is to be paid or deducted in the Wage Type field. In conjunction with the 
Wage type you must process either the Amount field or the Number and Unit fields. The system 
checks the combination entered. The currency is defaulted according to the company code. This 
can be overwritten. 

The system uses the last day of the current payroll period as the date of origin of the additional 
payment. You can overwrite this default value by 

• entering another date in the field Date of origin 

• entering the required payroll period and payroll year in the fields Default date. 

If you enter a different payroll period in the fields Default date the system defaults the last 
day of the specified payroll period as the date of origin. 

 
If the report RPCDTBX0 (Preliminary Data Medium Exchange Program for Separate 
Payment Run) has created a preliminary document for a wage type transfer, the 
Transfer field is displayed on the infotype screen. You can not delete the wage type 
in this case. 

See also: 
Edit Additional Payments [Page 217] 
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Processing Additional Payments 
Use 
By means of additional payments an employee can receive a one off payment on a fixed date, for 
example, on their anniversary of years of service. 

You can also transfer wage types stored in the Additional Payments infotype (0015) gross for net 
as an  before the actual payment date. unqualified advance payment [Page 93]

Creating Additional Payments 
1. Choose Human Resources -> Personnel Management -> Administration -> HR Master Data -

>Maintain. 

2. Enter the personnel number of the employee concerned, and choose the Additional 
Payments infotype (0015). 

3. Choose . 

4. Enter the required data in the fields. 

 
The entries in the Amount and Number/Unit fields depend on the selected wage 
type. For directly valuated wage types, enter the amount and the number or unit. 
This is not necessary for indirectly valuated wage types. 

For the date on which the additional payment should take place, the system 
suggests the last day of the current payroll period from the payroll control record. 
You can overwrite the default value by entering another payroll period. 

5. Choose . 

Entering Additional Payments for Varying Account Assignments 
You can enter an additional payment that differs from the cost assignment in the Organizational 
Assignment infotype (0001). If this is the case, the payment will be deducted from the cost center 
that differs from the master cost center. 

Procedure 
1. On the Create Additional Payments screen, choose . 

The Cost Assignment Defaults dialog box appears. 

2. Enter the different assignments. 

3. Choose Transfer. 

You have created a cost assignment for an additional payment that differs from the cost 
assignment in the Organizational Assignment infotype (0001). 

 

April 2001  217 



Payroll United States (PY-US)  SAP AG 

Standard Wage Maintenance 

Standard Wage Maintenance 
Use 
You can use this function to guarantee wage or salary payments for an employee if his or 
her pay has decreased. The difference between the current pay and guaranteed pay is 
calculated by the system and is known as the standard wage maintenance amount.  The different 
collective agreements include various types of standard wage maintenance clauses for salaried 
and hourly-paid employees. 

You can create different wage maintenance types for your employees, for example: 

Wage maintenance in the event of a pay scale downgrade  

Provision for old age 

Wage maintenance as part of a social compensation plan or similar action.  

You can define a fixed wage maintenance amount, or you can project the amount, in other 
words, you can reduce or increase the amount in regular intervals. 

 

 

Features 
Standard wage maintenance types
It is possible to create different wage maintenance types in Customizing. These wage 
maintenance types can then be called as subtypes in the Standard Wage Maintenance infotype 
(0052) [Page 220]. You can enter the guaranteed pay for your employee using one or more 
standard wage maintenance types. 

Adjustment types 

You can adjust the guaranteed wage and salary payments in the following ways:  

• You can periodically increase (or decrease) the payment by a constant value 

• You can periodically increase (or decrease) the payment by a percentage value 

The adjustment type is defined for a wage maintenance type.  

Print to remuneration statement 
You can print the difference between an employee’s current pay and the pay guaranteed in wage 
maintenance as a statement wage type on the remuneration statement. 

 

 
You make the settings that define functions performed in wage maintenance in 
Customizing for Personnel Management under Personnel Administration → Payroll 
Data → Standard Wage Maintenance. 
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Standard Wage Maintenance (Infotype 0052) 
Definition 
The wage maintenance amount is calculated by the system and is the difference between the 
current and guaranteed pay. You enter the guaranteed pay for your employee in the Standard 
Wage Maintenance infotype (0052),. 

Use 
You can determine the wage maintenance amount using different reasons and different 
adjustment types. Please refer to the section Standard Wage Maintenance [Page 218]. 

Standard wage maintenance type 
The wage maintenance types set up in Customizing are called as subtypes. You can create 
several wage maintenance types for an employee. 

Pay scales 
You can either enter data in the Pay Scale Type, Pay Scale Area and Pay Scale Group fields, or 
you can save them without data. The pay scale group and pay scale level are used for the 
indirect valuation of wage maintenance wage types and are not required for direct valuation. 

Wage types 
You can only enter wage types set up for wage maintenance in Customizing. The wage type list 
can include up to 20 wage types. 

Wage types that are included in the total are flagged with an X in the T field. 

Wage type valuation 

You can either valuate the wage types directly, or they can be indirectly valuated by the system. 

For indirect valuations, an infotype record must be created for the employee in the Planned 
Working Time infotype (0007). If the indirect valuation is only valid until a date that is before the 
validity end of the record, the system displays an appropriate message. If this is the case, you 
can enter the date on which indirect valuation should take place again. 

Indirectly-valuated wage types are flagged with an I after the amount. 

 
For more information on wage type valuation, refer to the section 

. 
Valuating Wage 

Types [Page 256]
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Time Quota Compensation Infotype (0416) 
Definition 
Time quota compensation allows a financial remuneration of absence entitlements that have not 
been deducted by absences. 

Use 
You can use the Time Quota Compensation infotype (0416) to remunerate absence entitlements 
such as Leave or Time in lieu of overtime. When the compensations are recorded, the remaining 
quota or leave that has not been deducted or compensated is reduced by the specified amount.  

Structure 
Various methods for compensating quota remainders are defined in Customizing. They 
simplify the recording of quota compensation. You choose the method you require by 
specifying a subtype for the infotype.  

• 

For more information, see  Methods for Compensating Time Quotas [Ext.]

• The list of absence quotas in the infotype shows which quotas can be compensated. It 
displays all the employee’s absence entitlements that are available for deduction on the 
current day. 

You can branch to the corresponding infotype record by double-clicking the absence 
quota. This shows additional, detailed information on the quota, such as whether 
deduction can result in a negative value, for example. 

• You can project a recorded compensation. In this process, the SAP System calculates 
anticipated changes to the quota, without saving the data record. This process is 
recommended 

• If you are unsure whether there is enough remaining quota to perform compensation 

• If you want to check which quotas are reduced by a compensation 

• You have the option of checking the specified compensation before saving.  The check 
enables you to view which quotas are reduced by the compensation and by how much. 

• You can compensate all of an employee’s quotas at the same time. This process is 
recommended if, for example, an employee leaves the company. You must be able to 
perform free compensation to be able to do this.  

The SAP System automatically writes the quota remainder for each quota type to the 
number field of the compensation in the list of quotas. You can overwrite the number that 
is determined automatically. 
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Employee Remuneration Info Infotype (2010) 
Definition 
You can use the Employee remuneration info infotype (2010) to enter wage types manually and 
specify information directly for Payroll.  

 
If you work with time evaluation, you can transfer time balances directly using the 

 infotype (2012), which in turn has an effect on 
remuneration. 
Time Transfer Specifications [Ext.]

Use 
These wage types are not generated automatically in payroll. Use infotype 2010 to enter wage 
data that has been calculated manually, such as premiums, bonuses for difficult working 
conditions or other special wage types. 

You can adjust the wage types and subtypes of this infotype to your individual requirements in 
the Customizing system. Here, you can define, for example: 

• The wage types that can be used here 

• The fields in which data cen be entered 

• Whether additional information can be entered for Accounting and Logistics 

• Whether a wage type can be used once or several times per payroll period. 

Structure 
The following options can be used to control remuneration for a wage type in the infotype: 

1. Number of hours, number, unit, and amount 
If these fields contain entries, the system uses the values stored in the Customizing 
system for this wage type. If no amount is specified, you can enter one manually in the 
infotype. 

2. Different payment 
It is possible to enter additional data on a different payment for remuneration records on 
the entry screen or via Goto → Different payment. 

• Assign a premium 

• Re-define a payment by assigning a pay scale group and level 

• Control payment by entering a different position 

• Add or deduct a specific amount using the Extra pay indicator and the Valuation basis. 

See also: 
Maintaining Employee Remuneration Information [Page 243]
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Time Management Aspects in Payroll  

The Time Management (PT) and Payroll (PY) components are closely linked in the R/3 System. 

The processing of time data for determining the gross wage takes place in the gross part of 
payroll. Subschema xT00 (x=country indicator) is used to process Time Management aspects 
within Payroll. 

These include: 

• Creating the personal work schedule and, if necessary, importing the planned working 
times 

 
It is possible that differences between the times from the personal work schedule 
and the planned times may affect the monetary valuation of work performed. This 
may happen if an employee has substituted for another employee, for example. 

Forming partial period factors; see also Partial Period Calculations (Factoring) [Page 
316] 

• 

• Forming valuation bases; see also 
 

Valuating Wage Types Using Valuation Bases [Page 
]259

Selecting time wage types for overtime, bonuses, and hourly wages, that is, day 
processing of time data using schema TC00 ( time wage type selection: international) or 
TC04 (time wage type selection: international for time recording without clock times) 

• 

• Performing a shift change compensation; see also Shift Change Compensation [Page 
] 235

Processing information on a different payment for work performed; see also Activity with 
a Higher Rate of Pay [Page 236] 

• 

Processing information on manually calculated wage sizes, bonuses, and so on; see also • 
Employee Remuneration Information [Page 240] 

Processing compensation for time off entitlements; see also Time Quota Compensation 
(Infotype 0416) [Page 22 ]1  

• 

Valuating time wage types; see also Time Wage Type Valuation [Page 258] • 

Valuating absences; see also Absences [Page 244] • 

• Processing incentive wages; see also   Processing Incentive Wages [Page 298]
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Integration with Time Management 
Purpose 
You use this component to calculate  in Payroll, such as bonuses for 
overtime, night work, or work on public holidays. The time wage types are formed on the basis of 
time data information. They are used to form employees’ gross wage.  

time wage types [Page 170]

Implementation Considerations 
The component acts as an interface between the Payroll component and the Time Management 
component. The Integration with Time Management component is supplied with time data from 
the Time Data Recording and Administration component and with time wage types from the Time 
Evaluation component. 

If you only use the Time Data Recording and Administration component, you can use the 
Integration with Time Management component to evaluate the employee-related time data 
information and to determine the time wage types. If you also use the Time Evaluation 
component, the Integration with Time Management component imports the time wage types 
determined by Time Evaluation. The Integration with Time Management component determines 
provisional time wage types for periods for which time evaluation cannot deliver current results 
(due to a payroll run being moved forward, for example). 

Integration 
With Other R/3 Human Resources Components 

Desired Function Required Component 
Managing time accounts Time Evaluation 
Checking complex working time regulations Time Evaluation 
Implementing time recording subsystems Time Evaluation 

 
With Other R/3 Components 

Desired Function Required Component 
Compensating work performed and assigning personnel costs 
according to the source 

Controlling 

Features 
• The time wage types determined, such as hourly wage, overtime wage, and bonuses, 

form the specifications for the financial valuation of work performed further on in gross 
payroll. 

• In the case of working times that have no specified attendance or absence times, it is 
assumed in the standard system that the employee has worked according the planned 
times from his or her work schedule.  

• When selecting time wage types, the system can automatically take account of 
conditions on the duration or time of an activity, public holidays, or weekdays. 
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• Cost accounting information can also be assigned to the time data. Payroll passes on 
this information to the wage types formed. This enables the personnel costs resulting 
from the time data to be made available to Cost Accounting. 
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Day Processing of Time Data in Payroll  
Use 
Employee time data recorded in R/3 Time Management contains information about any relevant 
time-based location, duration, and quality of work completed. This information allows you to 
determine bonuses.  

• For Customizing day processing you can use the functions and operations in R/3 Time 
Evaluation. 

Day processing for time data forms time wage types from the information recorded in R/3 Time 
Management during the payroll run.  

Prerequisites 
The calculation basis is formed from the time data recorded in R/3 Time Management and 
scheduled employee working times. The following must first be set up in Customizing or in HR 
Master Data maintenance: 

• Create work schedules in Customizing 

• Assign work schedules to the individual employees using the Planned Working Time (0007) 
infotype 

• Complete the prerequisites for recording time data records 

For more information, see the Implementation Guide (IMG) for Personnel Time Management. 

Features 
• Time data is processed by the subschema of schema XT00 (Processing Time Data in 

Payroll, X = country indicator). The subschema is called by the function DAYPR (Day 
Processing of Time Data)  

In the standard R/3 System, the time data is processed using the schema TC00 (Wage 
Type Generation International) or TC04 (International Wage Type Generation for 
Time Evaluation without Clock Times) Both schemas record only the exceptions to 
the daily work schedule. Schema TC00 processes time data recorded in clock time 
format and are full-day records. Schema TC04 only records time data in hourly 
format.  

• In schema TC00 and TC04 steps and rules are defined for evaluating the time data.  The 
individual processing steps can be modified to suit your specific requirements in 
Customizing. 

• Day processing is carried out during the payroll run. Time data is processed there for each 
day to be accounted. In the payroll log, you can see the selected time wage types for each 
day. 

• The close relationship between the Time Management and Payroll component ensures a 
seamless accounting of time data information, including retroactive accounting at any time 
when changes are made in the future to the time data. 

See also:  Time Wage Type Selection [Page 231]
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Sequence of Day Processing/Wage Type Selection 
Purpose 
You use the process described here to form time wage types from time data information. The 
time wage types form the basis for calculating the gross wage. 

Prerequisites 
Function DAYPR (Day Processing of Time Data) is contained in schema xT00 (Processing Time 
Data in Payroll; x = country indicator). The subschema to be processed, TC00 (Wage Type 
Generation: International) or TC04 (Wage Type Generation International for Time Evaluation 
Without Clock Times) is entered in parameter 2 of the function.  
Schema xT00 includes all of the steps that are required to calculate time-related gross 
remuneration. It is processed in the payroll run. 

You have customized the processing steps of schema TC00 or TC04 to suit your requirements. 

Process Flow 
1. Access day processing 
Function DAYPR is used to access the subschema for day processing of time data (TC00 or 
TC04). If you use the Time Evaluation component, the time wage types that have already been 
determined are imported from Cluster B2. For more information, see 

. 
Integration Between Time 

Evaluation and Payroll [Page 234]

Actual day processing is in schema TC00 or TC04 between functions BDAY (Begin Processing 
Block of Time Evaluation) and EDAY End Processing Block of Time Evaluation). This section is 
run once per day and per employee.  

2. Initialization 
Function MOD (Determine Groupings) is used in subschema TC00 or TC04 to call personnel 
calculation rule TMOD. You can use PC rule TMOD to specify the groupings to be used by the 
payroll driver to access the tables for time type determination and time wage type selection 
during processing.  

Operation MODIF T specifies the time type determination group to be used by the payroll driver 
to access entries from table T555Z (Time Type Determination) for the employee. 

Operation MODIF W specifies the time wage type selection group to be used by the payroll driver 
to access entries from table T510S (Time Wage Type Selection) for the employee.  

3. Load time data 
All necessary time data is supplied in a sequence of functions. This includes the recorded 
attendances and absences, and the specifications from the work schedule. The information is 
entered in the work table TIP (Day Input).  

Refer to:  and  Processing Using Internal Tables [Ext.] Supplying Time Data [Ext.]

4. Classify times 
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In the next step, all entries of table TIP are classified individually. This determines whether the 
times are planned times or overtime. The TIP entries are then assigned a  processing type [Ext.]: 
M for overtime, or S for planned work.  

For detailed information on the classification of times, see: 

Classification of Times [Ext.]  

Break Processing by Time Evaluation [Ext.] 

Overtime Determination by Time Evaluation [Ext.] 

 
These links all relate to Time Evaluation documentation. All information relating to 
forming and processing time accounts is not relevant to Payroll. 

5. Select time wage types 
These TIP entry/processing type combinations are then compared individually to the conditions 
required by time wage type selection. Particular features are assigned to each day, such as 
public holiday class, day type, and so on. These features are checked during time wage type 
selection.  

Function DAYMO is used to specify the Day grouping for time wage type selection (working days, 
Sundays, and public holidays) to be used to check the entries of table T510S. You must assign a 
particular entry in the schema for each of these cases. 

Time wage type selection is performed in the schema using function GWT (Generate Wage 
Types). The time wage types are selected on the basis of the processing type of a TIP entry. 
Function GWT is accessed twice in the schema: 

- GWT S: for TIP entries with processing type S (planned work) 

- GWT M: for TIP entries with processing type M (overtime) 

This procedure enables the time wage types selected for planned times and overtime to be 
collected in various tables. In this way, you can control the compensation of overtime wage 
types. 

 
Function GWT also selects time wage types for all absence that are evaluated 
according to the ‘as if’ principle. In the standard system, the absences are assigned 
processing type S. 

For more information on absence valuation, see Absences [Page 24 ]4 . 

6. Compensate overtime 
In overtime compensation, it is specified whether the overtime hours are to be remunerated or 
compensated with time in lieu.  

For more information, see the section Compensate Overtime in the Implementation Guide for 
Payroll. 

7. Store results 
Function CUMBT (Cumulate Interim Results) is used to store the results of day processing in the 
results tables. The required time types for all days in the payroll period are now in table ZL. If the 
time data was recorded together with information on cost assignment or on a different payment, 
ZL still contains pointers to tables C1 and ALP from Cluster B2.  
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Result 
The time wage types are transferred from ZL to work table IT in Payroll. They are now available 
for monetary valuation.  
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Time Wage Type Selection 
Use 
In time wage type selection, you use employees’ time data to determine the hourly wage and 
bonuses for overtime, work on a public holiday, and night work. 

 
• You want different time wage types to be selected for work on a public holiday than for work 

on a workday. 

• For up to two hours of overtime you want time wage type Mxxx to be selected in addition to 
the basic hourly wage. This wage type is valuated with a 25% bonus in comparison with the 
basic hourly wage.  

The monetary valuation of the time wage types determined is performed further on in the payroll 
process. 

Integration 
Time wage type selection is a processing step in day processing of time data in Payroll or Time 
Evaluation. It is called by function GWT (Generate Wage Types) in the schema (TC00 Wage 
Type Generation International or TC04 Wage Type Generation International for Time Evaluation 
Without Clock Times for Payroll, or in the standard time evaluation schemas.  

Function GWT processes the entries of table T510S (Time Wage Type Selection), which 
contains the wage types that can be selected and the conditions that must be met for the 
selection of a wage type. 

Prerequisites 
You have set up table T510S (Time Wage Type Selection) to suit your requirements. This is 
done in Customizing for Time Evaluation or Payroll. 

For more information, see the Implementation Guide for Time Evaluation or Payroll. 

Features 
There are many different regulations governing the selection of time wage types. They are 
formed when several individual rules in T510S are grouped into a rule group. In this way, you can 
group together all corporate regulations for your employee groupings.  
Each individual rule contains the time wage type to be selected. In time wage type selection, all 
individual rules in a rule group are run. If even one of the conditions specified in an individual rule 
is not fulfilled, the time wage type is not selected. 

Groupings for time wage type selection 
The rule groups for the selection of time wage types are determined according to the time wage 
type selection rule group and the day grouping for time wage type selection, which are the key to 
reading table T510S.  

• Whether an employee is an hourly wage earner or a salaried employee, for example, plays 
an important role in time wage type selection. You can therefore use the time wage type 
selection rule group to group your employees, and set regulations according to the 
groupings. The time wage type selection rule group is independent of the other 
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organizational groupings in the Human Resources system. It is only used for time wage type 
selection. 

• You can define various rule groups depending on particular factors relating to the day being 
evaluated (workdays, normal working days, Sundays, public holidays, and so on). You can 
use the day grouping for time wage type selection to distinguish between the rule groups.  

 
The conditions on the day being evaluated can also be contained in an individual 
rule.  

For a better system performance, however, it is advisable to create rule groups for 
the selection of time wage types for certain days. In this case, you specify day-
related conditions using the day grouping for time wage type selection.  

• In day processing, the times are classified according to the information from the work 
schedule and the recorded time data. The times are assigned an indicator, the processing 
type. Its main use is to differentiate planned working time and overtime. You can also use it 
for additional criteria.  

Different time wage types can be selected for a rule group dependent on the processing type. 

Conditions on the time or duration of work performed or on the day being evaluated 
For each time wage type/individual rule, you determine conditions on the day being evaluated for 
the time or duration of work performed. A time wage type is only selected if all the specified 
criteria are met. 

• Conditions on the day 

The time wage type is only selected if the conditions specified for the day being 
evaluated are met. In this way you can, for example, determine bonuses automatically 
for work on weekends, on a public holiday, or the day before or after a public holiday.  

Information from the employee’s planned working time can also be a condition on the 
selection of a time wage type. This can depend on whether the day is a workday for the 
employee, for example, or on the information stored in the daily or period work schedule.  

 
You want employees who work a rotating shift pattern (early, late, and night shift) to 
be paid higher bonuses than employees who work a normal shift, provided the 
circumstances are the same (Valuation class of the period work schedule). 

• Conditions on the time 

You can define conditions on the time or duration of work performed to enable bonuses such 
as overtime, Sunday, or night bonuses to be selected. You can specify that the time 
wage type is only to be selected within a particular time interval or that it is not selected 
until a certain number of hours has been worked. You can also specify that a time wage 
type be chosen only if the employee has already worked a certain number of planned 
working hours or overtime hours on that day.  

Additional options in Customizing 

• You can set a time wage type to a fixed value, regardless of the hours worked in one day. 
This enables you to set up a guaranteed hours regulation, for example. 
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• You can use the exit regulations in time wage type selection to stipulate that no more time 
wage types be selected after a certain one has been selected. 
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Integration Between Time Evaluation and Payroll  
Use 
The integration between time evaluation and payroll allows the Payroll component access to time 
wage types determined by time evaluation for the determination of the gross wage.  

Features 
• The time wage types determined by time evaluation in tables ZL, ALP, and C1 (Cluster 

B2) represent the interface between time evaluation and payroll.  

Table ZL: contains the time wage types 

Table C1: contains the data relevant for cost assignment 

Table ALP: contains the information necessary for a different payment 

• Function IMPRT B2 imports the time wage types determined by time evaluation from 
Cluster B2 to payroll, and valuates them. However, the payroll is often run before the end 
of the payroll period, which means that time evaluation cannot provide time wage types 
for all days in the period. 

 
You run the payroll on the fifteenth day of the month. Time evaluation has processed 
the time data up to and including the fourteenth. For the rest of the month, the 
employees are to be paid as if they had worked according to their planned working 
times, combined with existing attendances and/or absences, if applicable. 

• Payroll performs a projection according to schema TC00 or TC04 for the days in the 
payroll run that have not yet been processed by time evaluation. 

• The automatic retroactive accounting recognition guarantees that the time data is 
accounted without gaps. Any differences between the projection and the results 
determined at the end of the payroll run are balanced out in the following period by a 
retroactive accounting run. 

To do this, payroll sets the date as a retroactive accounting indicator in the Earliest MD 
change field in the Payroll Status infotype (0003). The prerequisite is that the 
employee takes part in time evaluation (Time Management status other than 0). 

• If time infotypes are created or changed for a payroll period that has already been 
accounted, time recording or time evaluation sets a retroactive accounting indicator for 
the corresponding date for payroll in the Earliest MD change field in the Payroll Status 
infotype (0003). The prerequisites for this are that 

- The time infotypes concerned are flagged as relevant to retroactive accounting for time 
evaluation or payroll  

- Function CHECK (General Checks Before Evaluations/Status Determination) is in the time 
evaluation schema with parameter RPR (Recalculation Payroll) 
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Shift Change Compensation 
Purpose 
You can use this component to implement company or collective agreements that stipulate that 
employees should not be disadvantaged financially if their planned working time is changed.  

Features 
• If an employee’s planned working time is changed in such a way that would cause a financial 

disadvantage to the employee, he or she is paid on the basis of the original working time (for 
example, in the case of a change from a night shift with night shift bonuses to an early shift). 

• If an employee’s planned working time is changed in such a way that would benefit the 
employee financially, he or she is paid on the basis of the changed working time (for 
example, in the case of a change from work on a Friday to a Sunday with Sunday bonuses).  

• The shift change compensation can be listed separately on the remuneration statement, for 
example. 

• You can limit the payment of shift change compensation to particular substitution types. 
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Activity with a Higher Rate of Pay 
Purpose 
This component is used to provide payroll with hourly rates that are specified in R/3 Time 
Management with information on a different payment. 

Integration 
Data records from Time data recording and administration and/or Time evaluation are processed 
in this component. 

Features 
• The time wage types and/or values determined by this component form the specifications 

for the financial valuation of work performed further on in gross payroll. 

• A different payment for work performed can be effected using the following procedure: 

• Allocation of a bonus for particular activities or working conditions (premium) 

• Payment based on an alternative rate 

• Payment based on the specifications of a different position 

• In the standard system, the component ensures that an employee cannot be paid at a 
lower rate than is specified in his or her basic pay on the basis of a different payment. 

• In exceptional cases, you can use this component to correct the payroll results for 
particular hourly rates.  

For more information, see . Entering a Different Payment for Time Infotype Records [Page 23 ]7

 

 

 

236  April 2001 



 SAP AG Payroll United States (PY-US) 

  Entering a Different Payment for Time Infotype Records 

Entering a Different Payment for Time Infotype Records 
Use 
You can store information on payment in several of the time infotypes as well as just time data. In 
this way, employees can receive a special rate of remuneration for certain work activities. 

The specifications on a different payment are entered via an additional window in the infotype. 
The method is different for Employee Remuneration Information (2010). In the standard system, 
the data is passed on to Payroll to be queried and processed. 

You can specify a different rate of payment for the following time infotypes: 

• Attendances (2002) 

• Substitutions (2003) 

• Availability (2004) 

• Overtime (2005) 

• Employee Remuneration Info (2010) 

 
The subtypes of certain time infotypes can also have an influence on payment (for 
example, the subtypes Substitution type and Availability type). 

If necessary, ask your system administrator whether the subtypes have an effect on 
payment.  

 

Note for US customers: 

When you enter a different payment, you can enter an alternative work tax area in the Tax area 
field.  This replaces the tax area entered for the employee in the Work Tax Area infotype (0208). 
For more information, see . Work Tax Area Overrides [Ext.]

Procedure 
1. Select an infotype and maintain the record on the entry screen. 

2. Choose Goto  → Different payment. 

 
In the Employee Remuneration Information infotype (2010), you can enter data on a 
different payment directly on the entry screen. 

3. Specify a different payment. 

You can determine the remuneration in the following ways: 

– Assigning a premium 

You can assign an employee a premium for particular work activities or working 
conditions. The premium is selected according to a premium number and a premium 
indicator. Use the possible entries function to display all permitted premiums with 
corresponding texts and values. 
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You can either assign a premium on its own or together with the following options: 

– Payment according to a different pay scale 

You can use the Pay scale group and Pay scale level fields to enter data on payment 
for a particular work activity. In this case, the payroll program does not select the 
rates which are specified for the employee in the Basic Pay infotype (0008), but the 
employee is paid according to the rates entered here for the duration of the different 
payment. 

– Payment according to the specifications for a different position 

You can use the fields Object type and Position to assign the payment for the work 
activity according to the specifications for a different position. 

– Correcting payroll results 

The Extra pay and Valuation fields can be used to correct the results of payroll. 

Not every wage type is valuated using a fixed amount in payroll. The payroll program 
calculates a valuation basis during the payroll run which is used to valuate a wage 
type. The valuation basis is derived from the basic pay and the payments and 
deductions. You can change the valuation basis for the specified period in the 
Valuation and Extra pay fields. 

Enter an amount in the Valuation field. The extra pay indicator determines how the 
new valuation basis is formed: 

Extra pay 

If you enter + in the Extra pay field, the amount in the Valuation field is added to the 
valuation basis calculated in payroll. 

Reduction 

If you enter - in the Extra pay field, the amount in the Valuation field is deducted from 
the valuation basis calculated in payroll. 

Specifying an alternative amount 

If you do not make an entry in the Extra pay field, the valuation basis calculated for 
the wage type in payroll is replaced by the specified amount. 

 
Please note that you should only ever use one of the options for assigning a different 
rate of payment. An exception is the premium, which you can assign in addition to 
one of the other options.  

 

4. Choose Transfer. 

5. Save your entries. 

Result 
You have entered specifications on a different rate of payment for a time infotype record. 
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Employee Remuneration Information 
Purpose 
You can use the Employee Remuneration Information infotype (2010) to process manually 
calculated wages, bonuses, or other non-standard wage types. The time wage types been 
determined are entered into payroll and are used to form the gross wage.  

Integration 
Possible Integration with Other R/3 Components 

Desired Function Required Component 
Record wage types for work performed, together with 
information for other components in the R/3 System. 

Cross-Application Time Sheet 

Features 
• Employee Remuneration Information provides payroll with time- and person-related time 

wage types. These time wage types form the specifications for the financial valuation of 
work performed further on in payroll.  

• You can include information on a different payment with the employee remuneration 
information. If you do, the specified wage types are valuated according to the different 
pay scale group/level or the different position, for example, further on in the payroll run. 

• This enables you to use this component as an interface to external time management 
systems. In this case, a Business Application Interface (BAPI) is used to supply the 
employee remuneration information with time wage types.  

You can use the Cross-Application Time Sheet to supply Human Resources with 
information on bonuses (for example, travel allowance). 

• 

See also:  Cross-Application Time Sheet [Ext.]
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Employee Remuneration Info Infotype (2010) 
Definition 
You can use the Employee remuneration info infotype (2010) to enter wage types manually and 
specify information directly for Payroll.  

 
If you work with time evaluation, you can transfer time balances directly using the 

 infotype (2012), which in turn has an effect on 
remuneration. 
Time Transfer Specifications [Ext.]

Use 
These wage types are not generated automatically in payroll. Use infotype 2010 to enter wage 
data that has been calculated manually, such as premiums, bonuses for difficult working 
conditions or other special wage types. 

You can adjust the wage types and subtypes of this infotype to your individual requirements in 
the Customizing system. Here, you can define, for example: 

• The wage types that can be used here 

• The fields in which data cen be entered 

• Whether additional information can be entered for Accounting and Logistics 

• Whether a wage type can be used once or several times per payroll period. 

Structure 
The following options can be used to control remuneration for a wage type in the infotype: 

2. Different payment 

• Re-define a payment by assigning a pay scale group and level 

See also: 

1. Number of hours, number, unit, and amount 
If these fields contain entries, the system uses the values stored in the Customizing 
system for this wage type. If no amount is specified, you can enter one manually in the 
infotype. 

It is possible to enter additional data on a different payment for remuneration records on 
the entry screen or via Goto → Different payment. 

• Assign a premium 

• Control payment by entering a different position 

• Add or deduct a specific amount using the Extra pay indicator and the Valuation basis. 

Maintaining Employee Remuneration Information [Page 243] 
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Maintain Employee Remuneration Information 
1. Select the Employee Remuneration Information infotype (2010). 

2. Enter a validity period. 

3. Select a processing mode. 

The Employee Remuneration Information screen appears. 

4. Check the validity date of the record. Correct it if necessary. 

5. In the Wage type field, enter the wage type for the remuneration information record. Use the 
F4 help for a list of permitted wage types. 

6. Enter a number of hours, a number / unit and/or an amount. 

Your entries in the Number of hours, Number/unit and Amount fields depend on the 
selected wage type. 

Certain wage types are valuated indirectly in Payroll. You do not have to specify an 
amount or number / unit in this case. 

The amount and number / unit can be entered for other wage types, however, and 
are often mandatory. 

The permitted entries for each wage type are defined in the Customizing settings. 
The system checks your entries at this point and generates an error message if you 
have made entries which are not permitted. 

7. Enter data on a different payment [Page 237], if required. This is only necessary if you have 
not made an entry in the Amount field. 

8. Maintain the Accounting/Logistics specifications, if necessary.  

 
It is also possible to maintain additional data when you enter remuneration 
information using the weekly calendar or fast entry function. 

For more information on Activity Allocation and Cost Assignment, see Integration 
with Other Components [Ext.] [Ext.]. 

9. Save your entries. 

 

 

Result 
You have maintained remuneration information for an employee. 
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Absences 
Purpose 

 

This component is used to define regulations to determine how absences (unpaid leave, paid 
leave, illness, and so on) are handled in payroll. 

You can define specifications to determine: 

• Which valuation basis is used to valuate a paid absence 

• Which absences are granted bonuses (for example, vacation allowance) 

• Which absences cause deductions in pay 

• Which absences are used to form statistics 

Integration 
To be able to use this component, you must record employee absences such as leave, illness, 
and so on, in the Time Management component or using a third-party system. The component 
processes absences from the Absences infotype (2001). 

Features 
• You can valuate absences as if the employee had worked. This enables bonuses for 

night work or for work on a Sunday or public holiday to be taken into account. 

• You can define specifications for determining deductions in pay for an unpaid day of 
absence. 

• You can determine vacation allowances for each day of absence. 

• You can specify that an absence be valuated using an average pay, to be defined at a 
later stage. This means that you can include the average overtime of the previous month 
in the calculation of vacation allowances, for example. 

• You can group absences together for the purposes of cost accounting or statistics to 
evaluate them subsequently for multiple employees. 

• Absences can be valuated according to particular conditions on the day of the absence 
or the absence entitlement from which they have been deducted. 

• You can define rules to process specific requirements.  
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Absence Valuation 
Use 
You use this component to valuate employees’ absences (unpaid leave, paid leave, illness, and 
so on) in Payroll. 

Features 
Absences recorded for an employee in the Absences infotype (2001) can be valuated in Payroll 
according to a variety of criteria.  

  

• An employee takes leave. He or she should receive a vacation allowance. 

• An employee is ill for a long period of time. There may be certain country-specific criteria that 
affect the way in which the absence is valuated. 

• A employee has taken unpaid leave. His or her pay must be reduced accordingly. 

You can define absence valuation rules in Customizing to meet your various requirements. 
Absence types and subtypes in the Absences infotype (2001) are grouped according to the 
methods of absence valuation you want to use. 

• 

The following procedures for valuating absences are included in the standard system. You can 
either use one of these procedures, or a combination of more than one: 

• “As if” principle 

An absence is valuated as if the employee had worked. 

Formation of counting classes for factoring and cost accounting 

Absences lead to a reduction in pay. For more information, see . Factoring [Page 316]

The costs incurred by the enterprise due to periods of paid incapacity to work should be 
determined. 

• Valuation of absences using averages or constants 

An absence is valuated according to the average number of hours or days worked, or as 
a constant using a fixed amount. For more information, see Valuation Using Valuation 
Bases [Page 259] and 

. 
Valuating in Accordance with the Principle of Averages [Page 

]275

• Individual calculation 

Special processing is triggered for certain absences. Specific information from the 
employee’s master data, for example, is taken into account in special processing. 

  
The Absences section of the Implementation Guide (IMG) contains detailed 
information on setting up the system and on the various methods of absence 
valuation. 

April 2001  245 



Payroll United States (PY-US)  SAP AG 

Absence Valuation 

Off-cycle payroll runs 

In some countries, you can also valuate absences in an off-cycle run. This allows you to effect an 
advance payment for the duration of the absence. If you implement off-cycle payroll in your 
country and enterprise, the valuation of absences is dependent on whether it takes place in one 
of the following payroll runs: 

• In a regular run 

• In an off-cycle run 

• In a regular payroll run after a previous off-cycle valuation 

For more information on off-cycle accounting, see . Off-Cycle Activities [Page 13 ]0
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Absence Valuation in Schema xT00: Technical Process 
 

Purpose 
Absence valuation using the payroll schema xT00 allows you to valuate the absences recorded 
for an employee according to: 

• The type of absence recorded 

• The employee’s organizational assignment 

• The absence quota from which an absence has been deducted 

• Special country-specific features and requirements 

Process Flow 
Absence Valuation in Schema xT00: Technical Process 

Func. Par1 Par2 Par3 Par4 P D Text 
...        
MOD XMOD GEN     Set groupings 
RAB       Import absences 
PRINT NP AB     Print absences 
xNAB       Country-specific absence routines 
....        
DAYPR TC00      Day processing of time data 
...        
PAB       Process absences 
...        
xAB       Country-specific absence routines 
...        

 

Set groupings 
The first action in payroll that is relevant to absence processing is function MOD in schema xT00.  

  
The X sign appears in the following text in a number of schemas, functions, and 
personnel calculation rules. The X stands for the country indicator and also for the 
international versions of the schemas, functions, and personnel calculation rules.  
Only use schema xT00, personnel calculation rule XMOD, and so on, if no separate 
schemas, functions, and personnel calculation rules have been created for your 
country. 

Function MOD determines the table entries the system accesses to valuate absences. 

MOD calls personnel calculation rule XMOD which uses operation MODIF A to determine the 
employee grouping for absence valuation. 
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The employee grouping for absence valuation is used in the Valuation of Absences table 
(T554C) to select an absence valuation rule. The specifications stored in personnel calculation 
rule XMOD assign a meaning to the employee grouping. You can set individual grouping criteria 
here.  

  
For more information, see the Implementation Guide for Payroll and choose 
Absences  → Set grouping for absence valuation. 

You can define groupings for a particular organizational assignment, for example, in relation to 
the employee subgroup grouping for personnel calculation rules. 

  
You can use different employee groupings for absence valuation for 

• Hourly wage earners 

• Salaried employees 

In the standard system, the payroll modifier for accessing the Constant Valuations table (T510J) 
is also set in personnel calculation rule XMOD using operation MODIF 2.  

Import absences 
After a grouping has been set for the personnel number, function RAB reads the absences 
recorded for the employee during the relevant period in the Absences infotype (2001).  

The absences are assigned to a WPBP split indicator. The absence valuation rule is determined 
from the Attendances and Absences table (T554S), which groups together different absence 
types in payroll. 

The absences are assigned to a work center split indicator. 

  
An employee has changed work centers within the company during the payroll 
period. The work center split indicator allows you to take account of this 
organizational change when valuating absences. 

If parameter 3 of function RAB contains the entry X, the absence valuation rule can be changed 
using the Breakdown of Absences after Quota Deduction table (T554A). In this way, you can 
create a special absence valuation rule that is dependent on the quota from which the absence is 
deducted.  

If an absence is deducted from one or more quotas, an absence record can be broken down if 
required. If this is not the case, parameter 3 has no effect. 

Take account of country-specific requirements when reading absences 
Special processing may be required to account for country-specific requirements.  
A common example is absence due to illness. The amount of payment can change in the course 
of the illness (continued pay).  

To ensure than the absence valuation function can deal with such situations, the internal 
Absences table (AB) has been enhanced. If an absence record is affected by country-specific 

248  April 2001 



 SAP AG Payroll United States (PY-US) 

  Absence Valuation in Schema xT00: Technical Process 

requirements, it is split into smaller sections and then entered in table AB.  
In table AB, there are three split indicators in which you can store country-specific indicators. 

  
Split indicators for country XY for 

• Social insurance 

• Tax 

Each section can then be valuated using a different procedure, that is, a different absence 
valuation rule. 

Function XNAB is used for a more detailed version of table AB. Please note that the function 
must come at a specific position in the schema. It must not be processed until after the absences 
have been read, but before they are valuated (function PAB). 

Day processing of time data 
During day processing of time data, time wage types are selected using the Time Wage Type 
Selection table (T510S), and the time wage types are entered in the internal Time Wage Types 
table (ZL). 

The same applies to all absences for which the Time Wage Type Selection field is selected in the 
Valuation of Absences table (T554C). 

Valuate absences 
Absence valuation is triggered using function PAB. 

  
Actual amounts are not calculated at this stage in the payroll process. First, the 
specifications made for absence valuation in Customizing are processed.  
Processing these specifications facilitates the subsequent valuation of wage types in 
amounts and/or factoring. 

Function PAB performs the following steps: 

• It reads the internal Absences table (AB) for each absence or partial interval. 

• The system determines the appropriate absence valuation rule on the basis of the 
absence type and the employee’s organizational assignment, and carries out the actions 
specified in the Valuation of Absences table (T554C): 

a) The counting classes that have been determined are cumulated in internal table CABC. 
The table contains the following information for each split: 

– Number of paid (AP) and unpaid (AU) absences in a counting class 

– Number of calendar days (K), absence days (A), and absence hours (S) 

You can query this information in personnel calculation rules using operation NUM: 

  
Partial period parameters for the partial period (=T) 
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TKAU** Unpaid absence (AU) expressed in calendar days (K) 

All counting classes (**) 

TAAP** Paid absence (AP) expressed in absence days (A) 

All counting classes (**) 

TSAU33 Unpaid absence (AU) expressed in absence hours (S) 

Counting class 33 (33) 

b) Bases for calculating average values or wage types valuated using constants are 
determined.  
The system enters the wage types in the following tables according to the time unit 
specified in the rule for absence valuation:  

– Time unit B, I, E: The wage types are entered in table OT. If you have selected 
the Basic Pay Split field in the Valuation of Absences table (T554C), the wage 
types are cumulated for each split. 

– Time unit Z: The wage types are entered in table ZL. There is one entry per day 
and wage type. In this way, you can access the results for a specific day in 
further processing. 
Using function ZLIT, table ZL is entered in table IT at the end of the gross part of 
payroll. 

c) If you have created a separate personnel calculation rule for special processing special 
processing is carried out. 

You can use information from the employee’s master data or organizational 
assignment data for special processing. The system calculates temporary values and 
enters them in record layout fields.  
For information on record layout fields, see the documentation on the operands for 
operations NUM, RTE, and AMT. 

Take account of country-specific requirements in absence valuation 
The processing triggered by function XNAB may have to be continued. This can only take place 
after the absences have been valuated using function PAB. 

  
Processing can be carried out using function XAB. 
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Short/ Long-Term Disability Plans 

• You must carry out all configuration in the Short/Long-Term Disability Plans section of the 
Absence chapter of the Payroll USA IMG. 

Purpose 
The SAP Payroll system calculates pay for illness-related absences for employees based on the 
short/long-term disability plan that applies to that particular employee. When you record an 
absence  in Infotype 2001 such as an Illness, Short-Term Disability, or Long -Term Disability, the 
payroll system determines which illness pay plan applies for the employee and calculates 
appropriate pay over multiple pay periods for the absent employee. 

Prerequisites 

• You have created a Date Specifications Infotype (0041) with 01 and the employee's hire date 
as the date. The system uses this date to determine the service years for calculating short-
term disability plan eligiblity. 

Process Flow 

An HR administrator
creates an Absenses
Infotype for this employee

An employee reports that
he/she will be absent from
work due to illness

When the last STD period
expires, the HR administrator
transfers the employee to long-
term disability

Create Absences

STD Pay Periods
STD Period 1

STD Period 2

STD Period 3

…

STD Period end dates are
generated by system based on
the number of illness days and
the STD plan defined for the
employee

 

08/06/1999
06/25/1999
05/14/1999

1. An employee reports that he/she will be absent from work for period of time. 

2. The HR administrator creates an Absences infotype (2001) for this period, with the 
appropriate absence subtypes. 

April 2001  251 



Payroll United States (PY-US)  SAP AG 

Short/ Long-Term Disability Plans 

3. The system defaults the STD period end dates based on the short-term disability plan 
defined for this employee. 

4. Once the employee's illness days have been exhausted (if the employee is eligible for paid 
illness days), the HR administrator creates a second absence record for short-term disability. 

5. When payroll is run during the short-term disability periods, the employee is paid a 
percentage of his or her full salary based on his or her short-term disability plan. For 
example, an employee could receive 100% of his or her salary during the first period; 75% 
during the second, and 50% during the third. 

6. Once third STD period has expired, the employee is tranferred to a long-term disability plan 
funded by a third party, such as a private insurance company or a social insurance program.  

 
See also: 
Example: Recording Illnesses and Intiating STD pl [Page 25 ]ans3  

Recording Modified Work Days [Page 25 ]4  

Short-Term Disability Status Report [Page 255] 
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Recording Absences Relevant for Short-Term Disability: 
Example 
Scenario 
John Smith, employee of Redcar Locomotives, is involved in a serious car accident and is 
therefore unable to report to work for the next 30 weeks. John's benefits with Redcar entitle him 
to 10 paid illness days, and short-term disability providing 100% of his salary during the first six 
weeks, 75% during the second ten weeks, and 50% during the third and final period. After this 
period, John must transfer to a long term disability plan funded by his private insurance policy. 

The HR administrator at Redcar creates an Absences Infotype record for the10 illness days, and 
then a second Absences record for short-term disability. The system automatically calculates and 
displays the end dates for the three short-term disability periods. As time passes and John 
remains absent from work, his STD plan dictates the percentage of his full salary he receives 
each pay period.  During John's last STD period,  the HR administrator prepares the necessary 
paperwork to transfer him to a long-term disability plan. Once John's STD plan expires, an HR 
administrator at Redcar, creates long-term disability Absences infotype record to store the long-
term disability plan details. 

First
STD period

Second
STD period

Third
STD period

Long-term
disability

Paid by employer

Illness
days

100%
salary

100%
salary

75%
salary

50%
salary

Paid by a third party

6
weeks

10
weeks

10
weeks

10
days

20
weeks
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Recording Modified Work Days 
Use 
When an employee is absent from work on a short-term disability plan he or she may at some 
point be able to return to work on a part-time basis, and thus extend the total number of days he 
or she is eligible for short-term disability. For example, if an employee returns to work for four 
hours per day during his or her last two weeks (5-day work-week) of short term disablility, then he 
or she would be entitled to an additional 5 days on short-term disability. You must enter the hours 
for each modified work day as a separate Absences infotype record (with subtype short-term 
disability). 

Prerequisites 
• You must carry out all configuration in the Short/Long-Term Disability Plans section of the 

Absence chapter of the Payroll USA IMG. 

• You have created a Date Specifications Infotype (0041) with 01 and the employee's hire date 
as the date. The system uses this date to determine the service years for calculating an 
employee'sshort-term disability plan eligiblity. 

Procedure 
1. From the main SAP menu, choose Human resources → Personnel management → 

Administration, and then Maintain master data. 

2. On the screen that appears, enter the personnel number for the employee, choose the Time 
recording tab, select Absences, enter the date of the modified work day and choose create. 

3. On the subtypes dialog-box select Short-term disability and then choose Enter. 

4. On the Absences infotype screen that appears, enter either the time range the employee 
worked or reduce the number of absence hours to reflect the length of the work day; and 
enter the Relationships indicator (left box) used in other records for this absence. This 
indicator links the modified work day to other Absences infotype records related to the same 
absence. 

5. Save your entries. 

Result 
The modified work day is recorded and the employee's eligible time on short-term disability is 
extended by the number of hours worked this day. 
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Short-Term Disability Status Report 
Use 
Short/Long-Term Disability Status Report extracts data from absence data stored on the 
Absences infotype (2001) for the group of employees selected for the desired time period and 
displays a list of employees who are on short-tem disability leave. This report enables you to 
track employees on short-term disability leave from work and more effectively plan an employee's 
transfer to long-term disability. 

Activities 
To access this report from the US payroll menu, choose Period-independent → Payroll 
supplement → STD/LTD Report. For further information, see the Application help for this report. 
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Wage Type Valuation 
Use 
The R/3 system uses primary and secondary wage types. Secondary wage types [Page 171] are 
formed during the payroll run. The primary wage types must be entered with values, which can 
be used again during the payroll run. In Customizing for Payroll under Incentive Wage Types → 
Payroll → Wage Types → Check Wage Type Catalog → Check Wage Type Characteristics you 
determine how the wage types should be valuated. The Valuation of dialog wage types [Page 
257] is different from the Valuation of time wage types [Page 258]. 
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Dialog Wage Types Valuation  
Use 
You need this function to assign a value to wage types entered in master data maintenance. 

The dialog wage types can be valuated directly in different ways. 

• Direct 

Enter the amount used for wage type valuation in the appropriate infotype.  

 
An employee receives a special payment of 500. In the Additional Payments infotype 
(0015), enter the Special Payment wage type with an amount of $500 and directly 
valuate the Special Payment. 

• Indirectly 

The system calculates the amount the wage type should be valuated with, on the basis 
of certain employee characteristics, with a module that contains all the data necessary 
for calculation. 

  
Your employees receive standard pay. This standard salary should be calculated 
using the pay scale type, pay scale area, pay scale group, and pay scale level 
entered in the Basic Pay infotype (0008). Assign the TARIF module to the 
appropriate wage type in Customizing for Personnel Management under Personnel 
Administration → Payroll data → Basic Pay → Check Wage Type Catalog → Check 
Wage Type Characteristics. The modules included in the standard system for indirect 
valuation are described in the view Change Wage Type Characteristics.  Details 

• According to the principle of averages [Page 275] 
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Time Wage Types Valuation 
Use 
You need this function to valuate time wage types.  

During the payroll run, the system reads various time wage types  [Page 170] from tables. These 
time wage types contain only one number (NUM). To calculate the amount (AMT) of the time 
wage type, the number must be multiplied by a rate (RTE). The system calculates the rate for 
each unit 

• using averages 

 
An employee has 14 days leave. The vacation allowance should be made up of the 
pay and 10% of all overtime bonuses from the last six months. To do this the system 
must calculate an average value [Page 275]  

• using a valuation basis 

 
Your employee works overtime between 5 p.m. and 7 p.m. In accordance with the 
company agreement, these two hours of overtime entitle the employee to an 
overtime bonus in addition to his or her basic remuneration. 

Your Time Management system provides you with a Bonus for overtime wage type, 
which only contains the number of hours of overtime (2 hours in this example). The 
payroll program requires a rate by which to multiply the number in the Bonus for 
overtime wage type. To do this, you must define a valuation basis [Page 259]. 
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Valuating Wage Types Using Valuation Bases 
Use 
Time wage types are evaluated above all using the valuation bases. In this way bonuses or 
overtime remuneration is valuated. 

You can define different valuation bases. 

Constant valuation bases • 

You can define constant valuation bases that are dependent on the wage type to be 
valuated [Page 264], or on a collective agreement [Page 268]. 

Employee-related valuation bases • 

You can calculate employee-related valuation bases [Page 271] that are dependent on 
an employee’s payments. 
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Technical Procedure for Wage Type Valuation using 
Valuation Bases 
Purpose 
For more information on the purpose of this process, see Valuation Using Valuation Bases [Page 
259]. 

Process Flow 

 
The X sign appears in the following text in a number of schemas, functions, and 
personnel calculation rules. This abbreviation represents the country indicator and 
the international versions of the schemas, functions, and personnel calculation rules. 
You should only use this if schemas, functions, and personnel calculation rules have 
not been set up specifically for your country or if you do not want to use the country-
specific functions that are available. 

1. The system determines the work center and basic pay data. 

In personnel calculation schema X000 (Determine gross wage and transfer), subschema 
XBD0 (Edit basic data) is called up. This subschema contains the WPBP function 
(Workplace Basic Pay), which causes the following: 

• The system enters the wage types from the Basic Pay infotype (0008) in the input table 
(IT). 

• The system enters the work center and basic pay data for an employee in the internal 
table WPBP. 

• The system determines whether several partial periods arise within a payroll period. 
Partial periods can arise for the following reasons: 

• Because an employee joined or left the company during the period. 

• Because of changes in basic pay, changes in organizational assignment, and changes in 
the personal work schedule. 

• Because payments are divided for cost accounting into paid and unpaid attendance and 
absence. 

 
For more information on the calculation of partial periods see Factoring [Page 316]. 

2. For every partial period the system forms Employee-related valuation bases [Page 271]. 

Subschema XT00 (Processing of Time Data) is accessed by personnel calculation 
schema X000. The personnel calculation rule X010 (Form valuation bases (Addition)) is 
queried in this subschema. This personnel calculation rule valuates processing class 01 
for the basic pay wage types in the input table. Depending on the specification of the 
processing class, the system writes the basic pay wage types to one of the secondary 
wage types that are used as the valuation bases. 
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Calculation rule X010 is queried depending on the employee subgroup. In the 
standard system, the processing steps within personnel calculation rule X010 are the 
same for all employee subgroup groupings. If you want to set up special processing 
features for an employee subgroup grouping, you must enter your changes for the 
correct employee subgroup grouping for personnel calculation rules. 

Personnel calculation rule X013 (Form valuation bases(Division)) is accessed 
immediately afterwards. This personnel calculation rule is also queried depending on the 
employee subgroup. Personnel calculation rule X013 queries the processing class 01 
according to specification 5. This query has the following results: 

• By means of specification 5 the system recognizes the valuation bases. 

• By means of the employee subgroup the system recognizes whether the employee 
receives an hourly wage or a period-related salary. The entries in the valuation bases for 
all employees who do not receive an hourly wage are divided by the average number of 
hours for the period. This result is written as a valuation basis to the Rate (RTE) field of 
wage types /001 and/or /002. 

3. The system forms the valuation bases for partial periods that must be paid differently. 

In subschema XT00 function PALP (Process alternative payments) is queried. In this 
function the personnel calculation rule X012 (Calculate valuation bases for alternative 
payment) is queried. This personnel calculation rule checks whether a partial period must 
be paid differently. The following cases are taken into account: 

• The employee works at a work center that is not assigned to them. The valuation bases 
for this period are determined using data for the work center at which the substitution 
occurs. 

• The collective agreement provisions of a different wage group / wage level apply to the 
employee. The valuation bases are determined using the wage group or wage level that 
is valid for this period. 

4. The system determines the wage types that are valuated using a valuation basis. 

The personnel calculation rule X015 (Valuation of time wage types) is queried in 
subschema XT00. This personnel calculation rule is queried depending on the employee 
subgroup. The personnel calculation rule X015 checks whether the input table (IT) 
contains time wage types that should be valuated using valuation bases. 

Using operations AMT?0, NUM?0 and RTE?0 the system checks the contents of the 
AMT (Amount), NUM (Number) and RTE (Rate) fields. The following cases are 
distinguished between: 

• If the AMT (Amount) field contains a value, the wage type will be transferred to the output 
table OT using operation ADDWT. 

• If the NUM (Number) and RTE (Rate) fields contain values these are multiplied by each 
other. The result is entered in the Total Amount field and the wage type is transferred to 
the output table OT using operation ADDWT. 

• If only the Number field (NUM) field contains a value, the operation VALBS determines  
whether a valuation basis has been entered in the Wage Type Valuation table T512W for 
the wage type. If a valuation basis has been specified, the wage type is valuated 
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accordingly. If no valuation basis has been specified, the wage type is valuated using the 
principle of averages, in accordance with the specification in processing class 15. 

 
The query of personnel calculation rule X015 is identical for all subareas, in other 
words, the queries described above are effected at the same time for all employee 
subgroup groupings (hourly wage earners, monthly wage earners, salaried 
employees, and so on). 

The wage type valuation using a valuation basis is different for wage earners and 
salaried employees; that is, the wage type valuation depends on the employee 
subgroup grouping. If no valuation basis exists the wage type is valuated using the 
principle of averages. 

Using personnel calculation rule X015 the system valuates all the determined wage 
types using the valuation bases. In so doing it distinguishes between the employee 
subgroup grouping: 

− For hourly wage earners (employee subgroup grouping with specification 1): 

a) The base wage type is valuated using operation VALBS0 

b) The first derived wage type is valuated using operation VALBS1 

c) The second derived wage type is valuated using operation VALBS2 

d) Operation ADDNA cumulates the values in the NUM and AMT fields. The RTE field remains 
unchanged. 

− For monthly wage earners and salaried employees (employee subgroup grouping with all 
other specifications): 

a) The system accesses the personnel calculation rule X115 (Valuation of time wage types) and 
carries out the following steps: 

b) The system uses this indicator to determine whether the existing wage type must also be 
paid differently. The alternative payment depends on the specification in processing class 18 
(Processing for Work Center-Related Payments): 

 Specification of processing class 18 Valuation 
 0, BLANK Remuneration with higher valuation basis 

 1 Remuneration with difference 

 

c) The base wage type is valuated in accordance with processing class 18 using operation 
VALBS0. 

d) The first derived wage type is valuated using operation VALBS1 

e) The second derived wage type is valuated using operation VALBS2 

f) Operation ADDNA cumulates the values in the NUM and AMT fields. The RTE field remains 
unchanged. 

Result 
All wage types are allocated with an amount that can be processed during the payroll run. 
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Wage Type-Dependent Constant Valuation Bases 
Definition 
Values for bonuses dependent on the bonus wage type. 

Use 
The valuation of a time wage type with wage type-dependent constants is often dependent on 
certain conditions being met. You can define different, wage type dependent constants that 
depend on a modifier. Different conditions are represented with different modifiers. The value of 
these modifiers is queried with the function RAB (Read Absences) or the operation VALBS 
(Valuation bases). 

Further conditions can be defined within the personnel calculation rule to determine whether a 
time wage type is valuated using a wage type-dependent constant valuation basis. In the 
standard system, the modifier MODIF 2 is used. You set the modifiers in personnel calculation 
rule XMOD [Page 267]  (Modifiers for Payroll). 

Prerequisites 
In Customizing for Payroll under Time Wage Type Valuation→Valuation Bases→Assign 
Valuation Bases you have determined which wage type should be calculated with a wage type 
dependent constant. 

In Customizing for Payroll under Time Wage Type Valuation→Valuation Bases→Constant 
Valuation Bases→Define Wage Type-Dependent Constants you define the amount with which a 
wage type should be valuated depending on the wage type constant. The wage type-dependent 
constants are defined as dependent on a payroll modifier. 

The modifier value is set as MODIF 2 within personnel calculation rule XMOD [Page 267] 
(employee grouping for payroll). In the personnel calculation rule XMOD, you can define 
customer-specific conditions depending on this modifier. 

 
For further information on system settings, see the Implementation Guide (IMG) for 
Payroll:<country> under Time Wage Type Valuation → Valuation Bases → Constant 
Valuation Bases. 

Please take particular care with the Employee Remuneration Information infotype (2010). This 
infotype allows you to enter manually calculated wage types, for example, bonuses for hazardous 
or unpleasant work, and premiums. This is also the case for time wage types, for example, for 
overtime. 

If you enter the Bonus for overtime wage type with an Amount in the Employee Remuneration 
Information infotype (2010), the wage type is included in the payroll run with its amount. In this 
case, the valuation basis is not used to valuate the wage type. By entering a wage type using the 
EE Remuneration Information infotype (2010), you can override time wage type valuation using a 
valuation basis. 

The Customizing system enables you to specify the wage types that can be entered in the 
Employee Remuneration Information infotype (2010). For more information, see the IMG for 
Personnel Management under Personnel Administration → Payroll Data → Employee 
Remuneration Information. 
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Wage Type- Dependent Constant Valuation Bases 
Example 
Initial Situation 
The Overtime on Sunday wage type is valuated at your company with a constant, wage type-
dependent valuation basis. The value of the constant valuation basis is 25 for the hourly paid, 
and 30 for all other employees. 

Procedure 
In Customizing for Payroll under Time Wage Type Valuation→ Valuation Bases→ Assign 
Valuation Bases you determine which time wage type is calculated with which valuation basis. 
You create entries for the modifier values 01 and 02 in the following way: 

Modifier value Wage type Valuation basis 

01 Overtime on Sunday 25 

02 Overtime on Sunday 30 

Calculation rule XMOD (Employee grouping for payroll) is called in calculation schema XT00 
(Processing of time data for Payroll), and is dependent on the employee subgroup grouping for 
the personnel calculation rule.  

Only the entries for modifier 01 in the Constant Valuations table (T510J) should be read for the 
employee subgroup grouping for personnel calculation rule with specification 1 (hourly wage 
earners). The entries for modifier 02 should be read for all other employee subgroup groupings 
for personnel calculation rules. 

The modifier used to read the Constant valuations table (T510J) is modifier 2 (MODIF 2). You 
must set modifier 2 to modifier value 01 for the employee subgroup grouping for personnel 
calculation rule with the specification 1 (hourly paid): MODIF 2 = 01. You must set modifier 2 
to modifier value 02 for all other employee subgroup groupings: MODIF 2 = 02 

Result 
The entry for modifier 01 is read in the Constant valuations table (T510J) for the hourly-wage 
earners. Hourly wage earners are assigned the Overtime on Sunday constant with a constant 
valuation of 25 per hour. 

The entry for modifier 02 is read in the Constant valuations table (T510J) for all other employees. 
Overtime worked on Sundays by employees who are not hourly wage earners is valuated at 30. 

 
In personnel calculation rule XMOD (Employee grouping for Payroll), other modifiers 
are set in addition to modifier 2, which reads the Constant valuations table (T510J). 
For information on which modifiers you can use in the standard system, refer to the 
documentation on the MODIF operation. 
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Personnel Calculation Rule XMOD 
Definition 
Personnel calculation rule XMOD (Employee Grouping for Payroll) is used to set modifiers for 
reading tables relevant to payroll.  
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Constant Valuation Bases that Depend on the Collective 
Agreement 
Definition 
Values for bonuses dependent on pay scale group and pay group level. 
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Constant Valuation Bases that Depend on the Collective 
Agreement Example 
Initial Situation 
In accordance with the collective agreement, overtime on public holidays should always be 
remunerated with $50 for every overtime hour, for all employees in pay scale group 1 and pay 
scale level 2. In other words, the overtime on public holidays wage type is always valuated using 
a constant valuation basis, that depends on the pay scale group and pay scale level. An 
employee with this pay scale group and level has worked two hours overtime, on a public 
holiday, which should be remunerated. 

In Customizing for Personnel Administration under Check wage type characteristics, you have 
determined which module should be used to valuate the wage types. 

In Payroll Customizing, under Time Wage Type Valuation → Valuation Bases → Constant 
Valuation Bases → Define Wage Type-Dependent Constants, you have defined the amount a 
wage type should be valuated with, depending on the wage type constant. 

 
For more information on how to use a module to indirectly valuate wage types, see 
Customizing (IMG) for Personnel Administration under Personnel Administration 
→ Payroll data. Each infotype includes the section Wage type → Checking the wage 
type catalog → Check wage type characteristics, which describes how to code the 
wage types. 

For more information on how to process pay scale groups and pay scale levels, for 
valuation with constant valuation bases that depend on the collective agreement, 
refer to the Payroll <country> Implementation Guide (IMG) and choose Time wage 
type valuation → Valuation bases → Constant valuation bases → Define pay scale-
dependent constants. 

Procedure 
In the SAP System, you first enter the overtime hours for the employee in the Time Management 
application component. The system then uses preset conditions to choose the appropriate time 
wage type [Page 170], in this case "Overtime on public holidays", with the number of hours as 2. 
This wage type is valuated with a valuation basis that is dependent on the following employee 
characteristics: 

• Does the employee belong to pay scale group 1? 

• Does the employee belong to pay scale level 2? 

The appropriate valuation basis is determined using the Pay scale module. The following values 
are available for the wage type overtime on public holiday: 

Field Value 

NUM (Number) 2 hours 

RTE (Rate) $50 per hour 

The system calculates the wage type amount ($100) by multiplying the number by a rate. 
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Result 
The employee receives remuneration of $100 (Number of working hours * valuation basis). 
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Employee-Related Valuation Basis 
Definition 
Individual value for every employee for whom payroll is carried out on the basis of wage types. 

You can valuate the bonus wage types using a percentage premium [Page 274] in accordance 
with the conditions specified in the collective agreement. This premium is a supplement to the 
employee’s basic remuneration. 

Use 
You create employee-related valuated bases by copying model wage types in a wage type group 
[Page 178]. The standard system contains the secondary wage types /001, /002, /003 and /004. 
In these secondary wage types the rate of the respective dialog wage types are collected. These 
rates are the respective valuation bases. 

 
Secondary wage types /001 and /002 are used on an hourly basis for valuating wage 
types. Secondary wage types /003 and /004 are only used in the German payroll to 
valuate wage types on a daily basis. 

To include a wage type in one of these valuation bases, the wage type in question must be 
coded in processing class 1 with a specification from the following table. 

Specification Meaning 
0 The wage type is not written to a valuation basis. 
1 The wage type is written to secondary wage type /001 (and also to secondary 

wage type /003 for Germany). 
2 The wage type is written to secondary wage type /002 (and also to secondary 

wage type /004 for Germany). 
3 The wage type is written to secondary wage types /001, /002, /003 and /004. 
5 The wage type amount is divided by the total hourly amount. 

 
All of the wage types that you enter using the Basic Pay infotype (0008) must be 
coded in processing class 1. 

The secondary wage types /001 and /002, must be coded in processing class 1 with 
specification 5. In doing this, the basic pay for hourly-wage earners, which is 
cumulated in these wage types, is divided by the number of working hours in the 
payroll period. The resulting rate can be used as a valuation basis. 

The German payroll system also requires that secondary wage types /003 and /004 
are coded with specification 5 in processing class 1. No other wage types may be 
coded with specification 5. 

In Customizing for Payroll under Time Wage Type Valuation→Valuation Bases→Assign 
Valuation Bases→Maintain Basic Pay for Valuation Bases you determine which dialog wage type 
is included in which valuation basis. 

In Customizing for Payroll under Time Wage Type Valuation→Valuation Bases→Assign 
Valuation Bases you determine which time wage type is calculated with which valuation basis. 
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Additionally, you can determine the percentage of a valuation basis used to valuate a time wage 
type, and whether derived wage types are considered. 

 
For further information on system settings, see the Implementation Guide (IMG) for 
Payroll:<country> under Time Wage Type Valuation → Valuation Bases → Create 
Person-Related Valuation Bases. 
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Person-Related Valuation Bases: Example 
Initial Situation 
In accordance with the collective agreement, all of an employee’s wage elements are used to 
valuate overtime worked on Sunday. 

However, voluntary payments are also taken into account when the overtime on public holiday 
wage type is valuated. 

Your employee works two hours on a Sunday and three hours on a public holiday. His/her salary 
contains the following elements: 

Wage type: Amount 

Standard salary $30 per hour 

Standard bonus $10 per hour 

Voluntary bonus $5 per hour 

Procedure 
The system creates the following person-related valuation bases: 

• Valuation basis for working on a Sunday (valuation basis 1) 

Valuation basis 1 is calculated from the salary at $30 per hour plus the standard bonus at 
$10 per hour. $30 +$10 = $40 per hour 

The Overtime on Sundays wage type is created with the number two. This number is 
valuated with valuation basis 1: $40 per hour x 2 hours = $80 

• Valuation basis for working on a public holiday (valuation basis 2) 

Valuation basis 2 is created using the salary, the standard bonus, and the voluntary 
bonus of $5 per hour. $30 + $10 + $5 = $45 per hour 

The Overtime on a Public Holiday wage type is created with the number three. This 
number is valuated with valuation basis 2: $45 x 3 hours = $135. 

Result 
In addition to his/her salary, the employee gets $80 Sunday bonus and $135 public holiday 
bonus. 
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Percentage Advance Pay for Individual Valuation Bases 
Use 
Collective agreement provisions usually stipulate that time wage types such as Overtime on 
Sunday and Overtime on Public Holidays must be valuated with a percentage of the employee’s 
basic remuneration. 

 
The Overtime on Sunday wage type must be valuated with a 25% increase in basic 
remuneration, consisting of the salary, standard bonus, and voluntary bonus. 
Valuation basis 1 is used. 

There are two ways of effecting this percentage increase: 

• Percentage increase of base wage type 
The base wage type is the Overtime on Sunday time wage type. This 
wage type is valuated with 125% of valuation basis 1. If an employee 
works overtime on a Sunday, he or she is assigned the wage type 
Overtime on Sunday valuated with 125% of valuation basis 1. 

• Create a derived wage type 
The Overtime on Sunday base wage type is valuated with 100% of 
valuation basis 1. You also specify the Overtime on Sunday derived wage 
type:  25 %. This wage type is valuated with 25% of valuation basis 1. 
In this case, the employee has the following wage types: 

- The Overtime on Sunday base wage type is valuated with 100% of 
valuation basis 1. 

- The derived wage type Overtime on Sunday is valuated with 25% of 
valuation basis one 1. 

The advantage of this procedure is that the derived wage type enables 
you to display and print the 25% bonus separately in the form. 
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Valuating using the Principle of Averages 
Purpose 
This method is often used to calculate absences [Page 244], however, it can also be used to 
calculate holiday pay or other bonuses, for example. 

Prerequisites 
You make the system settings for calculations using the principle of averages in Customizing for 
Payroll under Time Wage Type Valuation → Averages New.  

 
Here, you also find the section Previous Averages - Not for Reconfiguration, which refers to the 
calculation of averages up to Release 4.5. The old version is not further developed and is only 
available in Customizing to make changes. You can only use one of the two versions; that is, you 
can not use the old and new tables simultaneously. 

In one of the up-coming releases, conversion from the old to new processing of averages will 
take place automatically.  

 
You perform payroll monthly in your enterprise.  

An employee takes 14 days leave in August. In accordance with the company 
agreement, the employee receives not only basic remuneration during this period of 
absence, but also extra remuneration to cover unearned bonuses. This extra 
remuneration is calculated on the basis of the bonuses for night work, work on 
Sundays and public holidays, which the employee received on average in the three 
previous months.  

As an average calculation basis, on which the calculation of bonuses is based, you 
have set up the Collected Bonuses wage type in Customizing. 

Process Flow 
In this example, the absence is calculated using the principle of averages as follows: 

1. Creating Average Bases 

Therefore, the average calculation basis contains the sum of the wage types that you have 
selected for valuation using the principle of averages. In each payroll period, average calculation 
bases are formed in accordance with your settings in Customizing for each employee.  

In the above examples the Bonus for Night Work, Bonus for Work on a Sunday, and Bonus for 
Work on a Public Holiday wage types are collected and added to the Collected Bonuses wage 
type. You can choose to collect the number of working hours, the amount, or the rate for the 
wage type. 

2. Determining the Payroll Periods 

For calculations using the principle of averages, only the average calculation bases for specific 
previous periods are used.  
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In the above example you have determined in Customizing that the average calculation basis 
should be based on the three previous months when calculating using the principle of averages. 
Since your employee was absent in August, that is in payroll period 8, only payroll periods 5, 6 
and 7 are included in the Collected Bonuses wage type when calculating the average bonus. 

3. Determining the Valuation Basis 

As a calculation basis the System must determine a Rate for the Collected Bonuses wage type: 

In the above example the Amount of the Collected Bonuses wage type is divided by the Number 
of working hours. It does not matter whether you have collected the bonuses according to 
Number, Amount or Rate, you must still change the calculation rule for the standard system 
according to the entries in Customizing. 

 

If the average value is not recalculated for each absence valuation, you can use frozen averages 
[Page 277]. 

If no average bases have been created for an employee, you can use the EE Remuneration Info. 
infotype (2010) to enter the average value directly [Page 259] using a wage type. First, you must 
define a user-specific wage type for the average value and enter this in the Calculation Rules for 
Averages view (V_T51AV_A). For more information, see Customizing for Payroll under Time 
Wage Type Valuation → Averages New. 

 

 
You can define absence valuation rules for employee groupings (for example, for all 
salaried employees) and for groups of absence types (for example, paid leave). You 
define these absence valuation rules in Customizing. Please note, however, that the 
values used to perform a valuation in accordance with the principle of averages are 
determined using the average bases for each individual employee and are 
employee-specific. 
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Frozen Averages 
 

Use 
As an additional function for calculating averages, the R/3 System enables you to freeze average 
values. This means that you can use an average value calculated on the basis of several periods 
at the beginning of an absence for all of the periods affected by the absence, instead of always 
having to recalculate the average value for each period. 

 
An employee takes leave in periods 04 and 05. The Leave absence is valuated 
according to the principle of averages. Three previous periods are to be used in the 
calculation. 

In this case, the following options are possible: 

• 

• 

Normal valuation using the principle of averages 
The absence is valuated in period 04 for the first time using averages. 
The relevant previous periods are periods 01, 02, and 03. 
The second absence valuation takes place in period 05. In this case, the 
relevant previous periods are 02, 03, and 04. 
The absence can be valuated differently in periods 04 and 05 because 
the calculation is performed using average bases from different previous 
periods in each case. 

Valuation using frozen averages 
The absence is valuated at the start of the absence in period 04 after the 
average is calculated. The relevant previous periods are periods 01, 02, 
and 03. The calculated average is then frozen, in other words, it is saved 
and used again in the subsequent period (period 05). 
The absence is valuated in exactly the same way in periods 04 and 05 
using a frozen average value. 

 
The duration of the employee’s absence determines whether an average should be 
frozen or whether the absence should be valuated with a frozen average. Up until 
Release 4.5 the duration of the absence was queried in the R/3 System, in personnel 
calculation rule X016, once the calculation of averages had been concluded. For 
more information, see the section Technical Sequence for Processing Averages 
[Page 279]. 

In the processing of averages this information is queried internally in the coding, as 
of Release 4.6.  
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Determining the Average Value without a Basis 
Use 
You can use a wage type to enter an average value for an employee instead of creating the 
average value using average calculation bases. This is useful if no average bases have been 
calculated for an employee but you still want to use an average value to valuate the employee 
absence. Furthermore, this procedure allows you to override the average value calculated by the 
system, for example, for a new employee, by entering a wage type with an average value for the 
employee in question. 

Activities 
Firstly, you must define a user-specific wage type for the average value and enter this in the 
Calculation Rules for Averages view (V_T51AV_A). For more information, see Customizing for 
Payroll under Time Wage Type Valuation → Averages New. 

You enter this wage type for the employee in the EE Remuneration Info infotype (2010) as 
follows:  

1. Enter the name of the wage type in the Wage and Salary Type field. 

2. In the Amount field, enter the rate to be used as the average value. 

For this employee, absence valuation is performed using the rate for this wage type, which has 
been entered in the EE Remuneration Info infotype (2010). 
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Old and New Processing of Averages 
Use 

 
As of Release 4.6B the processing of averages has fundamentally changed. You can 
find information on the new processing of averages under Technical Sequence for 
Processing Averages (new) [Page 282]. You can find information on the old 
processing of averages under Technical Sequence for Processing Averages (old) 
[Page 288].  

For some country versions (Argentina, Brazil, Mexico, Sweden, USA and Venezuela) the new 
version of the processing of averages was delivered with Release 4.5B. These country versions 
can only use the new processing of averages and cannot choose between the old and new 
processing of averages. In the IMG for Payroll for these countries, the only section that still exists 
for the averages is Averages New. 

All other countries can choose between the old and new versions for processing averages. In the 
corresponding IMG for Payroll, you can find both the Averages New and Previous Averages - Not 
for Reconfiguration sections. However, you can only use one of the two versions; that is, you can 
not use the old and new versions for processing averages simultaneously. If you have been 
using the old version for processing averages up until now, you can still continue to use this 
version. You do not have to convert your system to the new version. The old version for 
processing averages is no longer being developed. 

 
We recommend that you use the new version for processing averages, if: 

− you set up the processing of averages for wage types for the first time in your 
system 

− up until now you have been using the old version for processing averages, but 
now want to use the additional functions of the new version 

Changes in the Processesing of Averages 
• The average value is no longer calculated for each wage type in operation MEANV 

(Calculation of Averages), but rather for each average value calculation rule in function 
AVERA (Calculation of Averages). 

• All the required payroll results are imported with a database access. 

The SAP name space and the customer-specific name space for objects are clearly 
separated from each other. 

• 

• The bases for calculating average values can now also be formed from partial period 
parameters [Ext.]. 

• You now define the average value calculation rule based on time. For example, you can 
specify that up until a specific point in time the averages are formed over a three month 
period, and then from this time over a 5 month period. 

The time unit for average periods is now freely defined  For example, you can form averages 
over five months or 12 weeks. 

• 
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Now, you can not only include the regular payroll [Page 57] run in the calculation of 
averages, but also the off-cycle payroll [Page 134] run. 

• 

• If an employee changes payroll periodicity [Page 44], the system adjusts the calculation of 
averages. 

• All the averages are calculated at once. First of all the system collects all the wage types, 
then every average value calculation rule is applied once. 

Changes in Customizing for Averages 
You make the Customizing settings for averages, as of Release 4.6B, in the Implementation 
Guide (IMG) for Payroll under Time Wage Type Valuation → Averages New. The Customizing 
settings, which were previously made in personnel calculation rules or processing classes, can 
now be made in the maintenance view. 

The following table shows a comparison between the Customizing settings for Release 4.6B and 
the settings that were made in releases prior to Release 4.6B: 

Customizing Setting Before Release 4.6B From Release 4.6B 

Forming the Basis for 
Calculating Average Values 

View V_512W_C 
(Averages) 

Table T51AV_2W (Assignment of 
Primary Wage Types to Average 
Bases) 

Forming the Basis for 
Calculating Average Values 
from Partial Period 
Parameters 

 Table T51AV_2P (Assignment of 
Partial Period Parameters to 
Average Bases) 

Relevancy Test Personnel Calculation Rule 
X017 (Relevancy Test for 
Averages Calculation) 

Table T51AV_R (Relevance Rule 
for Calculating Averages) 

Table T51AV_ROC (Off-Cycle 
Reasons not Relevant for 
Calculation of Averages) 

Adjustment Rule Table T511C (Adjustment 
Rules for Bases for 
Calculating Average 
Values) 

Table T51AV_C (Adjustment 
Rules for Bases for Calculating 
Average Values) 

Cumulation Rule Table T511B (Cumulation 
Rules for Bases for 
Calculating Average 
Values) 

Table T51AV_B (Cumulation 
Rules for Bases for Calculating 
Average Values) 

Final Processing Personnel Calculation Rule 
X018 (Calculation of 
Averages after 
Cumulation: AMT/NUM) 

Table T51AV_E (Final Processing 
Rules for Averages) 

Average Value Calculation 
Rules 

Table T511A (Calculation 
Rules for Averages) 

Table T51AV_A (Calculation 
Rules for Averages) 

Assigning the Valuation of 
Averages to a Primary Wage 
Type. 

Processing Class 15 Table T51AV_P (Assignment of 
Wage Types to Average 
Calculation Rules) 
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Technical Process of Average Processing (New) 
Purpose 

 
The procedure for processing averages described in this and the following sections 
refers to releases from Release 4.6B. The processing of averages has fundamentally 
changed since this release.  

For more information, see the Implementation Guide (IMG) for Payroll under Time 
Wage Type Valuation → Averages New → Bases for Valuation of Averages [Ext.]. 

If you have been using the old version for processing averages up until now, you 
can still continue to use this version. You do not have to convert your system to 
the new version. However, the old version for processing averages will no longer 
be developed. If you reconfigure, you should only use the new version for 
processing averages. 

Prerequisites 
When setting up the new average valuation of wage types in your system, you 
must perform the following activities: 
• Forming the Basis for Calculating Average Values 

The average calculation bases are used as a basis for calculating averages. The wage 
types assigned to the average calculation bases are stored in the secondary wage types 
/201 to /232. 

• Definition of calculation rules for averages 

The calculation rules are made up of the following rules and values: 

− Relevancy rules 

− Cumulation rules 

− Final processing rules 

− Comparison rules 

− Adjustment rules 

− Number of relevant previous periods 

− Specify if the calculated average value should be frozen 

− Manual values (employee- and period-specific) 

− Off-cycle rules 

• Assignment of calculation rules to wage types 

This assignment defines which primary wage type should be calculated according to 
which calculation rule. 
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For information on setting up average valuation, see the Implementation Guide 
(IMG) for Payroll under Time Wage Type Valuation → Averages New. 

Process Flow 

 
In the following, certain personnel calculation schemas and rules that start with the 
letter X serve as an example. The X represents the international personnel 
calculation schemas and rules and can be replaced with a country-specific letter. For 
example, there is a German personnel calculation schema D000 for the international 
personnel calculation schema X000. 

The subschema XT00 (Processing of Time Data for Payroll) is accessed by 
personnel calculation schema X000. The function AVERA (Average Calculation) is 
called within this schema and performs the whole average calculation. 
Averages are calculated in the following sequence: 
1. Wage type selection and specification of calculation rules 

You can specify which wage types you want to valuate with an average value in Payroll 
Customizing under Time Wage Type Valuation → Averages New → Basis for Valuation 
of Averages. The function AVERA selects the wage types marked in such a way and 
establishes which calculation rules are assigned to these wage types. 

2. The system checks the calculation rules for manual values 

The system checks if a manually assigned value already exists for a wage type in the 
internal table IT for every calculation rule. The system uses this value from the AMT field 
as an average value. In this case, the system skips averages calculation and continues 
processing with step 7. 

3. The system checks the calculation rules for frozen averages 

For each calculation rule, the system checks the start and finish date specified in the 
internal table AVERAGE: If a frozen average already exists for the relevant wage type 
and is valid for the current period, the system skips the calculation of averages and 
continues processing with step 7. 

4. Selection of all potentially relevant payroll results and creation of average calculation bases 

You have specified under which conditions a period should be relevant for the calculation 
of averages in the IMG for Payroll using the calculation rule in the relevancy rule. The 
system selects all payroll results that are, according to the relevancy rule, relevant and 
checks these according to the Relevancy Test for Valuation According to the New 
Principle of Averages [Page 286]. 

You can also flag the current period as being relevant for the calculation of averages. 
The system then accesses a preliminary value from the data previously determined for 
the current period and uses this value for average calculation. The system finally 
calculates the final value for the current period that is written to the results table RT at 
the end of averages calculation in step 9. 

5. Cumulating average calculation bases 

The system cumulates the individual average calculation bases from the selected payroll 
results (from the relevant periods) for each calculation rule in the internal table MV. 
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In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create 
Calculation Rules for Averages [Ext.], you can specify which of the values from the fields 
NUM, RTE or AMT of the wage type are cumulated. Here, you can also specify which 
sign (+/-) should be used to cumulate each value. 

In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create 
Calculation Rules for Averages, you can make the following settings in the view 
Adjustment Rules for Bases for Calculating Average Values (V_T51AV_C) using 
adjustment rules: 

− You can decide whether the system reads payroll results that are only partially in the 
averages period completely, partially or not at all for averages calculation. 

− You can take a pay increase or an individual wage increase and, in this way, adjust the 
average calculation bases to the increased payments. 

− You can make both positive and negative adjustments. 

6. Calculation of the average value 

The average value is calculated in the personnel calculation rule X018. In the standard 
system, the system divides the cumulated amount calculated in step 5 for all AMT fields 
by the cumulated amount from all NUM fields of the average calculation bases. You can 
also specify your own formulas or constants in the personnel calculation rule X018. The 
result of the calculation is the average value in the RTE field (rate). 

In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create 
Calculation Rules for Averages, you can create your own final processing rules in the 
view Final Processing Rules for Averages (V_T51AV_E), which you can then assign to a 
calculation rule. 

In Customizing for Payroll under Time Wage Type Valuation → Averages New → Create 
Calculation Rules for Averages, you can create your own final comparison rules in the 
view Comparison Rules for Averages (V_T51AV_W), which you can then assign to a 
calculation rule. For example, you can compare the calculated value with a specified 
value (for example, standard pay) and specify under which conditions which value should 
be used as an average value. 

7. Multiplying the average value with the number 

The system writes the average value calculated in step 6 in the RTE field for every 
calculation rule to the RTE field for all wage types that are assigned to this calculation 
rule. The amount of the average value in the field AMT of the wage types is the result of 
multiplying the contents of the fields RTE and NUM for each wage type. 

8. Freezing the average 

You may want to freeze the value obtained by calculating averages. To do so, you can 
save the average value from the RTE field in the payroll results in the internal table 
AVERAGE for every calculation rule. In Customizing for Payroll under Time Wage Type 
Valuation → Averages New → Create Calculation Rules for Averages, you can specify 
the period for which the average should be frozen in the view Calculation Rules for 
Averages (V_T51AV_A). 

9. Creating the average calculation bases for subsequent periods 

The function ADDCU (Update Cumulations) checks which wage types from the results 
table RT should be included in an average calculation basis. These wage types are 
collected in the relevant average calculation bases and the average calculation bases 
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are finally written to the results table RT. This means that they are available in the payroll 
results for future calculations according to the principle of averages. 
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Relevancy Test for Valuation According To the New 
Principle of Averages 
Purpose 
When calculating average values, the SAP System uses the average bases that 
are stored for each employee. You can flag payroll results and average periods 
as relevant or irrelevant for the calculation of averages, based on particular 
criteria. Starting at the current period, the system performs a relevancy test for 
the current and previous periods. If the average period is relevant, cumulation 
takes place in a secondary wage type. 

 
If you use Off-Cycle Activities [Page 130] in your system, you can use the new 
method of calculating averages to exclude certain off-cycle payroll runs from 
averages valuation if there is an off-cycle reason. 

Prerequisites 
In Customizing for Payroll you determine via Time Wage Type Valuation → Averages 
New → Create Calculation Rules for Averages [Ext.] the following default values: 
• Number and unit of relevant average periods 

Taking the current period as the starting point, the number of previous periods that the 
system must deem relevant and use to calculate averages. This is independent of payroll 
periodicity.  

• Maximum number of average periods 

The maximum number of periods that the system checks to determine the required 
number of relevant average periods. 

Process Flow 
The decision as to whether an average period is relevant for the calculation of 
averages is made in two steps: 
1. Taking the current period as the starting point, the system checks if a payroll result is 

relevant. It does this for all payroll results that were marked as being potentially relevant. 

2. The periodicity of payroll results and average periods can be different, for example, if you 
have weekly payroll results but use monthly average periods. Using the payroll results that 
were flagged as being relevant or irrelevant, the system checks if the average period is 
relevant. You can make the following settings in Customizing for this: 

− An average period is only relevant when all the payroll results assigned to it are relevant. 

− An average period is only relevant when at least one of the payroll results assigned to it 
are relevant. 
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Result 
The relevancy test can have the following results: 
• A period is relevant for the calculation of averages. 

In this case, the average calculation bases for the period are cumulated according to the 
cumulation rule stored in table T51AV_B (Cumulation Rules for Average Calculation 
Bases). 

• A period is not relevant in the calculation of averages. 

In this case, the average bases are not cumulated which means that they are not 
included in the calculation of averages. 

Example 
The number of relevant average periods is two. The maximum number of 
average periods is four. The calculation of the averages takes place in period 8. 
You have monthly average periods but run payroll on a weekly basis. An 
average period is relevant if all the payroll results assigned to it are relevant. The 
current period should not be taken into consideration in the calculation of 
averages. 
1. Checking the payroll results: 

The system checks all the results of the weekly payroll run, which are assigned to the 
average periods 7, 6, 5 and 4 and decides if these payroll results are relevant or not.  

2. Checking the average periods: 

The system finally checks the average periods until it has found at least two that are 
relevant. For example, if a payroll result, which is assigned to the average period 6 was 
flagged as being irrelevant, the average period is, according to the specifications, also 
irrelevant.   

The system checks a maximum of four previous periods, in this example the 
periods 7, 6, 5 and 4. If the desired number of periods is not found after the 
check, the calculation of averages is carried out with the least number of periods. 
If the system checks the maximum number of previous periods but fails to find a 
single relevant period, the average value is 0. 
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Technical Process of Average Processing (Old) 
Prerequisites 

 
The procedure for processing averages described in this section, and in the following 
sections, refers to releases prior to Release 4.6B. The processing of averages as of 
Release 4.6B has fundamentally changed. For more information, see Old and New 
Processing of Averages [Page 279] and the Implementation Guide (IMG) under 
Payroll → Time Wage Type Valuation → Averages New → Bases for Valuation of 
Averages [Ext.]. 

If you been using the old version for processing averages up until now, you can 
now use this version. You do not have to convert your system to the new 
version. However, the old version for processing averages will no longer be 
developed. If you reconfigure, you should only use the new version for 
processing averages. 

Process Flow 
The old version of average processing takes place in the following sequence: 

1. Creating Bases for Calculating Averages 
Primary wage types to be included in the average bases are cumulated in one of 
the secondary wage types for average bases in accordance with the entries you 
have made. This cumulation is performed in each payroll period for each 
employee. The average bases are stored in internal table RT at the end of 
payroll, and are available for future calculations performed in accordance with 
the principle of averages. 

2. Specifying the Wage Types to be Valuated Using the Averages Principle 
The subschema XT00 (Processing of Time Data for Payroll) is accessed by 
personnel calculation schema X000. The calculation rule X015 (Valuation of Time 
Wage Types) is the first action relevant to the calculation of averages. 

 
In the following, the X sign represents certain personnel calculation schemas and 
rules. This sign stands for the international versions of the personnel calculation 
schemas and rules and can be replaced with a country-specific letter. For example, 
there is a German personnel calculation schema D000 for the international personnel 
calculation schema X000. 

The personnel calculation rule X015 determines whether the internal table IT 
contains time wage types that should be valuated according to the principle of 
averages. The contents of the AMT (Amount), NUM (Number), and RTE (Rate) 
fields are checked using decision operations AMT?0, NUM?0 and RTE?0. 
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• If the AMT field contains a value, the wage type will be transferred with the operation 
ADDWT (Add Wage Type to Subsequent Wage Type). 

• If the AMT field does not contain a value, but the NUM and RTE fields do contain values, the 
value in the NUM field will be multiplied by the value in the RTE field. The result is entered in 
the AMT field and the wage type is transferred with the operation ADDWT. 

• If only the NUM field contains a value, the operation VALBS (Evaluate Valuation Bases) 
queries whether a valuation basis has been entered in table T512W for the wage type. If this 
is the case, the wage type is valuated using the appropriate valuation basis. If a valuation 
basis has not been specified, but a specification has been entered for processing class 15, 
the wage type is valuated in accordance with the principle of averages. Processing is 
continued using operation GCY with personnel calculation rule X016 (Special Processing for 
the Valuation of Time Wage Types). 

Only wage types that meet the following conditions are calculated according to 
the principle of averages: 
• Only the NUM field (Number) contains a value. 

• No valuation basis has been entered. 

• A specification has been entered for processing class 15. 

3. Defining Calculation Rules 
After defining which wage types are to be valuated according to the principle of 
averages, the calculation rule is defined. This is carried out by the decision 
operation VWTCL° 15 in the calculation rule X016. This decision operation 
queries processing class 15. Wage types that are to be evaluated using the 
principle of averages, are coded in processing class 15 with a particular 
specification. The operation MEANV <nn> is called for each specification. In this 
operation, nn stands for a calculation rule from the Calculation Rules for 
Averages view (V_T511A). Depending on the calculation rule, operation MEANV 
<nn> performs the actual calculation of average values. 

  
Your wage type has specification 1 in processing class 15. You have entered 
personnel calculation rules X017 (Relevancy Test for Averages), X018 (Calculation 
of Averages after Cumulation) and the cumulation type 01 (from the Cumulation 
Rules for Bases for Calculating Average Values view (V_T511B)) for calculation rule 
01. You have also specified that 3 previous periods should be taken into account 
when the averages are calculated. In rule X016, the operation MEANV 01 is 
assigned to specification 1. Using parameter 01, calculation rule 01 is determined 
using personnel calculation rules X017 and X018, cumulation type 01, and 3 
previous periods. Operation MEANV performs the calculation of averages on the 
basis of these entries. 

4. Calculating the Averages 
Operation MEANV performs the following steps when calculating averages: 
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1. The internal table MV is queried and this determines whether averages have already been 
calculated for the employee concerned within the current payroll period using the same 
average calculation rule. 

– If this is the case, the value that has already been determined is entered in the RTE field 
(rate). 

– If this is not the case, step 2 is performed. 

2. The internal table IT is queried and determines whether the Average Value wage type exists 
for the employee concerned (from the Calculation Rules for Averages view (V_T511A)). 

– If this is the case, the value is entered in the RTE field (rate). 

– If this is not the case, step 3 is performed. 

3. The individual periods [Page 295] are processed. 

a. Each previous period to be processed is imported, starting with the current period - 1. 

b. The relevancy test [Page 293] is performed. 

c. If the period is relevant, the cumulation takes place using the cumulation rule. 

4. The system checks whether the maximum number of periods to be taken into account has 
been reached. 

If this is not the case, return to step 2. 

5. The final processing of averages [Page 296]  is performed: 

a. The average is calculated using personnel calculation rule X016 for final processing of 
averages from the Calculation Rules for Averages view (V_T511A). 

b. The value is entered in the RTE (Rate) field for the wage type to be valuated. 

When the calculation of averages has finished, an average value is entered in 
the RTE field (Rate) for the appropriate wage type. This average value is used to 
effect a valuation (usually of absences). To do this, the values in the RTE and 
NUM fields are multiplied. 

5. Special Processing for Frozen Averages 
Special processing for frozen averages is dependent on the specification of a 
wage type in processing class 15. If a wage type has specification A in 
processing class 15, the decision operation ABEVL? will be called in the 
calculation rule X016. 
The decision operation ABEVL? determines whether an employee’s absence 
goes beyond the current period and returns a value (0, 1, 2 or 3) as the result of 
the query. Based on this value, you can trigger the following absence valuations 
in the personnel calculation rule X016: 
• Return value 0: The absence begins and ends in the current period. 

Operation MEANV calculates the average. 

• Return value 1: The absence begins in the current period and ends in the next period. 
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In this instance, the average value is calculated for the current period and frozen for the 
next period. 

− Operation MEANV calculates the average. 

− Operation ZERO=NA sets the NUM (Number) and AMT (Amount) fields to zero. 

− Operation ELIMI deletes split indicators. 

− Operation ADDNAE/02A transfers the value from the RTE field (Rate) to wage type /02A 
and saves the value in the internal table RT. By placing the value in this wage type, the 
rate , in other words, the average value, is frozen and can be re-used in the next period 
to valuate the same absence. 

• Return value 2: The absence begins in the previous period, continues through the current 
period, and ends in the next period. 

The absence is first valuated in the current period using the frozen average value from 
the previous period. The average value is then frozen again for the next period. 

− Operation RTE=L /02A reads wage type /02A, in which the average value of the previous 
period was fixed, from internal table LRT. 

− Operation MULTI NRA multiplies the value in the Rate (RTE) field, in other words the 
average value, by the Number (NUM) field, in other words the number of absence hours 
or absence days. The result is entered and stored in the Amount (AMT) field. 

− Operation ZERO=NA sets the NUM (Number) and AMT (Amount) fields to zero. 

− Operation ELIMI deletes split indicators. 

− Operation ADDNAE/02A transfers the value from the RTE field (Rate) to wage type /02A 
and saves the value in the internal table RT. By placing the value in this wage type, the 
rate , in other words, the average value, is frozen and can be re-used in the next period 
to valuate the same absence. 

• Return value 3: The absence starts in the previous period and ends in the current period. 

The absence is valuated using the frozen average value of the previous period. 

− Operation RTE=L /02A reads wage type /02A, in which the average value of the previous 
period was fixed, from internal table LRT. 

− Operation MULTI NRA multiplies the value in the Rate (RTE) field, in other words the 
average value, by the value in the Number (NUM) field, in other words the number of 
absence hours or absence days. The result is entered and stored in the Amount (AMT) 
field. 
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Valuation of Primary Wage Types 
Use 
To valuate primary wage types using the principle of averages, you must flag these wage types 
accordingly. To do this, use the Processing Classes, Cumulations, and Evaluation Classes view 
8V_512W_D) to enter a specification for primary wage type in processing class 15. Each 
specification of processing class 15 corresponds to a calculation rule in the Calculation Rules for 
Averages view (V_T511A). 

The following parameters must be set for each calculation rule: 

Personnel calculation rules, used for the relevancy test for valuations in accordance with 
the principle of averages [Page 293]. 

• 

Conditions for the cumulation of average calculation bases [Page 294]. • 

 Personnel calculation rules for the final processing of averages [Page 296]  • 

• Number of periods [Page 295], used for valuations in accordance with the principle of 
averages. 

The Averages view (V_512W_C) enables you to determine the secondary wage type for average 
bases in which the primary wage type for the calculation of averages is cumulated. It also 
enables you to determine whether the RTE (Rate), NUM (Number) or AMT (Amount) field is 
cumulated. 
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Relevancy Test for Valuation Using the Principle of 
Averages (old) 
Use 
You can flag a payroll period as relevant or irrelevant for the calculation of averages, based on 
particular criteria. In this respect, you can define a personnel calculation rule according to which 
a relevancy test is carried out. 

The standard system includes the calculation rule X017 (Relevancy Test for Averages). You can 
modify the calculation rule to meet your enterprise-specific requirements. In the standard system, 
all previous periods are flagged as relevant in calculation rule X017. 

 
You want to determine that the only payroll periods used in the calculation of 
averages are those in which the employee has at least 15 social insurance days. 

You can create a customer calculation rule to perform this query for each employee 
and then flag only the periods in which the employee has at least 15 social insurance 
days as relevant for the calculation of averages. 

Prerequisites 
In Customizing for Payroll under Time Wage Type Valuation → Averages Old → Create 
Relevancy Test, you can define customer calculation rules for the relevancy test. You must then 
assign the average calculation rule to a calculation rule in the Calculation Rules for Averages 
view (V_T511A). 

The relevancy test can have the following results: 

• A period is relevant for the calculation of averages. 

The average bases of the period are cumulated in accordance with the cumulation rules 
in view V_T511B Cumulation Rules for Average Bases. 

• A period is not relevant in the calculation of averages. 

The average bases are not cumulated which means that they are not included in the 
calculation of averages. 
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Cumulating Average Bases 
Use 
If the relevancy test has determined that the average bases of a period must be included in the 
calculation of averages, the average bases are cumulated in internal table MV. 

In Customizing for Payroll under Time Wage Type Valuation → Averages Old → Create 
Cumulation Rules for Bases for Calculating Averages, you can specify which of the values from 
the following fields are cumulated: 

• NUM (Number) of a wage type 

• AMT (Amount) of a wage type 

• RTE (Rate) of a wage type 

You can also specify which sign (+/-) should be used to cumulate each value. 

In the Cumulation Rules for Bases for Calculating Average Values view (V_t511B), you create 
the cumulation rules in accordance with the conditions. You must then assign a cumulation rule 
to a calculation rule in view V_T511A Calculation Rules for Averages. 
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Determining Relevant Previous Periods 
Use 
When calculating average values, the SAP System uses the average bases of previous periods 
that are stored for each employee. Starting at the current period, the system performs a 
relevancy test for the previous period. If the period is relevant, cumulation takes place in a 
secondary wage type. 

In Customizing for Payroll you determine via Time Wage Type Valuation → Averages Old → 
Create Calculation Rules for Averages [Ext.] the following default values: 

• Number of relevant periods 

Taking the current period as the starting point, the number of previous periods that the 
system must deem relevant and use to calculate averages. 

• Maximum number of periods 

The maximum number of previous periods that the system checks to determine the 
required number of relevant periods. 

 
The number of relevant periods is two. The maximum number of periods is four. The 
calculation of the averages takes place in period 8. The system keeps checking 
previous periods until it has found at least two that are relevant. A maximum of four 
previous periods are checked, in this example the periods 7, 6, 5 and 4. If the 
desired number of periods is not found after a maximum check of four previous 
periods then the calculation of averages is carried out with the fewest number of 
periods. If the system checks the maximum number of previous periods but fails to 
find a single relevant period, the average value is 0. 
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Final Processing of Averages 
Use 
After the calculation of averages, the Rate field (RTE) must contain a valuation basis for the 
wage type in question. A formula must be created in the personnel calculation rule used. This 
formula performs the final processing of averages step.  

The standard system contains the calculation rule X018 (Calculation of Averages After 
Cumulation: AMT/NUM). This calculation rule calculates an hourly rate by dividing the value in 
the AMT field (Amount) by the value in the NUM field (Number). The hourly rate is entered in the 
RTE (Rate) field. 

Prerequisites 
In Customizing for Payroll under Time Wage Type Valuation → Averages Old → Create Final 
Processing Rule, you can create an individual personnel calculation rule for final processing of 
averages. You must then assign this personnel calculation rule to a calculation rule in view 
V_T511A Calculation Rules for Averages. 
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Adapting the Average Bases to Increased Payments 
Use 
You can take a standard or individual wage increase into account when creating the average 
calculation bases. You must define a rule in Customizing to adapt the average bases to the 
changed pay scale conditions with retroactive effect . For more information see Customizing for 
Payroll and choose Time Wage Type Valuation → Averages → Create Adjustment Rules for 
Bases for Calculating Averages. 
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Incentive Wages: Overview 
Familiarity with the technical aspects of SAP Payroll is a prerequisite for understanding incentive 
wages accounting. In particular, you must understand the following terms: personnel calculation 
scheme, personnel calculation rule, function, and operation. 

The extensive options for implementing SAP Incentive Wages make system standardization 
difficult. If the time ticket types and the manner in which time tickets are recorded differs greatly 
from one enterprise to the next, then valuation of time tickets can often be completely different. 
Therefore, it does not make sense to elaborate incentive wages accounting processes in detail to 
cover all possible accounting scenarios. 

Following, you will find a number of versions as examples to use when setting up your own 
incentive wages accounting process. The international version contains an accounting process 
for hourly-wage earners, while the German version features two additional processes for monthly 
wage earners based on the collective agreement provisions existing in the Federal German 
states of Baden Wuerttemberg and North Rhein-Wesfalia. Please refer to the Implementation 
Guide (IMG) for further information. 
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Incentive Wages Accounting: Processes 
Three accounting processes for incentive wages are contained in the standard SAP System. The 
concepts behind these processes are explained further. 
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Monthly Wage Calculation for Incentive Wages 
In monthly wage calculation, the target time is valuated for each time ticket using the piecework 
rate. The piecework rate for the wage group [Ext.] entered on the time ticket is used for this case. 
The result is the amount that the piecework employee is due for the respective time ticket. The 
calculated amount is made up of the following: 

• Basic Monthly Wage 

• Time-dependent variable element 

• Performance-dependent variable element 

Basic Monthly Wage 
The basic monthly wage is the part of the gross wage paid to employees regardless of their 
performance. It can be paid in a monthly lump sum, or defined as an hourly wage dependent on 
the working time. 

The basic monthly wage is determined in the gross part of payroll. This amount is used in 
incentive wages as the basis for calculating variable elements. 

Monthly wages are converted to hourly rates for incentive wage accounting. 

 
Various bonuses can be paid out in addition to the basic wage. Examples include 
bonuses for working nights or on Sundays. However, these bonuses are not taken 
into account in the standard SAP System for incentive wages accounting. 

Time-Dependent Variable Element 
Employees can be assigned to a pay scale group different from their master pay scale group, 
and remunerated at a higher rate for certain activities in incentive wages accounting. The higher 
pay scale group must be entered on the time ticket. The difference amount is determined in 
incentive wage accounting, and valuated using the actual time as specified on the time ticket. 
The resulting amount is referred to as a time-dependent variable element. 
Performance-Dependent Variable Element 
The performance-dependent variable element credits the employee with completing work in less 
than the target time. The difference between target and actual time is valuated according to the 
pay scale group specified on the time ticket. 

Theoretically, both the time-dependent and the performance-dependent variable elements can be 
negative and result in a wage deduction. This can be the case for the time-dependent variable 
element if the pay scale group specified on a time ticket is lower (that is, valuated at a lower rate) 
than the employee’s master wage group. Downgrading is limited to a maximum of one pay scale 
group in the standard SAP System. If the actual time is greater than the target time, the 
performance-dependent variable element assumes a negative value. In this case, the time ticket 
is usually paid at the average rate, that is, the performance-dependent variable element has a 
value of zero. 

The following diagram shows the relationship between the various gross wage elements: 
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The individual areas are represented in proportion to the gross wage elements. 

 
The piecework rate in an employee’s master wage group is 22 euros/hour. 

The employee completes an order in four hours, instead of the target time of five 
hours. The employee is also assigned to a higher wage group with a piecework rate 
of 24 euros/hour. The higher wage group is entered on the time ticket. 

The standard calculation performed in incentive wages accounting for this time ticket 
is as follows: 

The total amount due to the employee for this time ticket is calculated by multiplying 
the target time by the piecework rate on the time ticket: 

5 hours x 24 euros/hour = 120 euros 

The basic monthly wage element is determined by multiplying the actual time by the 
piecework rate of the master wage group: 

4 hours x 22 euros/hour = 88 euros 

You get the time-dependent variable element by multiplying the 2 euros extra in the 
higher wage group by the actual time: 

4 hours x 2 euros/hour = 8 euros 

The performance-dependent variable element is determined by multiplying the 
difference between target and actual time by the piecework rate of the time ticket: 
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( 5 hours − 4 hours) x 24 euros/hour = 24 euros 

The result is then: 

88 euros + 24 euros + 8 euros = 120 euros 

The time-dependent variable element of 8 euros and the performance-dependent 
variable element of 24 euros are explicitly indicated as elements of the gross wage. 
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Calculating the Earnings Factor for Incentive Wages 
The following describes the procedure for calculating the earnings factor in incentive wages 
accounting, based on the one stipulated in Baden Wuerttemberg. The basic monthly wage of the 
current month is multiplied by the earnings factor of the last two months. 

The earnings factor is calculated as follows: 

DRS_A = Total (SZ(LS) x ARS(LS)) + DZ(LS) x DRS_V
ANWZ

 

Earnings Factor = D R S_V
AR S

 
Whereby: 

Table Caption 

SZ(LS): The target time of the individual time ticket 

ARS(LS): The piecework rate of the wage group on the time ticket 

DZ(LS): The actual time of the time tickets paid at the average rate 

DRS_A: The average basic rate of the current month 

DRS_V: The average basic rate of the last two months 

ARS:  The piecework rate of the master wage group 

ANWZ: The total of all actual times (piecework and average) 

•  

•  

•  

•  

•  

•  

•  

The total is for all time tickets in the reference period, that is, two months in the standard SAP 
System. 
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Earnings Factor: Example 
An employee receives a basic monthly wage of 3,200 euros. This is an hourly wage (= piecework 
rate) of 20 euros/hour for a monthly working time of 160 hours. 

Of the 160 working hours, he works 100 hours on a piecework basis (= actual time), and the 
remaining 60 hours are paid at the average rate. 

The employee’s performance corresponds to a target time of 120 hours. From this target time, 
20 hours are paid at a rate of 20 euros/hours and 100 hours are paid at a rate of  25 euros/hour. 
A higher is entered as the master wage group on the time ticket.for the 100 hours. The employee 
is entitled to a total of 2,900 euros for the work. The piecework hourly wage (actual time = 100 
hours) is thus calculated as 29 euros/hour. This value is the average rate for the current month. 

To calculate the earnings factor for the current month, the average rate of the current month is 
divided by the piecework rate of the master wage group: 

Earnings Factor =
29 euros/hour
20 euros/hour = 145%

 
In order to calculate the employee’s gross monthly wage, the basic monthly wage is multiplied by 
the earnings factor: 

Gross Monthly Wages = 3,200 euros x 145% = 4,640 euros

 
The employee’s gross monthly wage is 4,640 euros. 

 
In the above example, the gross monthly wage was calculated according to the 
earnings factor of the current month. The average earnings factor of the previous two 
months is also used in the standard procedure, however. This allows a monthly wage 
with deferred payment. 
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Incentive Wages Accounting: Hourly Wage Earners 
The process for hourly wages accounting is basically the same as the process for monthly wages 
accounting [Page 300]. However, There is one major difference: 

The monthly wage is specified as an hourly wage from the start of the process. As a result, the 
monthly basic wage does not need to be converted into an hourly wage. 
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Incentive Wage Accounting: Tools 
The following sections contain additional information regarding personnel calculation schemas, 
functions, and personnel calculation rules to be used in incentive wages accounting. 
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Incentive Wages Accounting: Personnel Calculation 
Schemas 
The recorded time tickets are valuated in the gross part of payroll; incentive wages accounting is 
an integral part of payroll. 

There are two reference schemas for incentive wages accounting: 

• German Version: DIW0 
Schema DIW0 is used in the German version of SAP Payroll, and contains special 
features that are specific to Germany only. 

In the German version, subschema DT00 is called from schema D000. From there, 
schema DT00 (which processes the time data) is called to valuate the time tickets. 

The feature of schema DIW0 specific to Germany is the final monthly calculation. 

For more information, see the Implementation Guide (IMG) for SAP Incentive Wages 
under Set controls for accounting. 

• International Version: XIW00 
Since the procedure for valuating time tickets varies so greatly from one country and 
organization to the next, there are no country-specific accounting schemas for Incentive 
Wages. Instead, you can use schema XIW0 as a reference for setting up your own 
incentive wage accounting system. 

Schema X000 serves as a reference for the entire international Payroll component (gross 
and net part). Subschema XT00 is provided for the gross part. Schema XIW0 is then 
called from schema XT00, and is used to valuate the time tickets. 

For more information, see the IMG for SAP Incentive Wages under Set controls for 
accounting. 

 
The personnel calculation schemas XIW0 and DIW0 are activated in the standard 
SAP System. If they are not required, they can simply be deactivated to improve 
system performance. 
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Personnel Calculation Rules DIW0 and XIW0 

• Processing time tickets for individual incentive wages 

After the time tickets have been valuated in the German DIW0 schema, the ACTIO function is 
called with the DWM personnel calculation rule as a parameter to perform a final monthly 
calculation. 

The structures of personnel calculation rules DIW0 and XIW0 are identical. They consist of the 
following steps: 

• Testing the employee’s employee subgroup 

• Reading special valuation bases for incentive wages 

• Processing time tickets for group incentive wages 

 

Schema DIW0 includes the following additional feature for Germany:Final monthly calculation 

 

The above steps are carried out in separate functions. 

Before the time tickets are valuated, average values from the previous month are read by calling 
the ACTIO function with the XW0 personnel calculation rule as a parameter. These are used as 
valuation bases for working times that are valuated with an average rate (for example, working 
times that have been recorded on time-based time tickets). 

Two special functions are provided to actually process the individual time tickets: Individual time 
tickets are valuated with function PW1, and group time tickets are valuated with function PW2. 
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Functions PW1 and PW2 
Functions PW1 and PW2 are used to process time tickets in SAP Payroll. 

Function PW1 performs the following steps: 

• Reads the time ticket data for individual incentive wages, importing only those time tickets: 

– Having payroll indicators with a value of 1 

– Which are not locked 

– Whose posting date is within the recording period. 

• Reads the account assignment splits for work center, cost center, and employee subgroup 
grouping for personnel calculation rules for each time ticket. 

• Valuates the time tickets according to the personnel calculation rule that is entered as the 
parameter. 

Function PW2 performs the following steps: 

• Reads the time ticket data  for individual incentive wages, importing only those time tickets: 

– Having payroll indicators with a value of 2 

– Which are not locked 

– Whose posting date is within the accounting period. 

• Reads the group results. 

• Enters the group result in the labor utilization rate field of the time ticket (this takes place 
temporarily so that calculations can be performed and is not written to the database). 

• Calculates the target time from the actual time on the respective time ticket and the group 
result, and enters it in the appropriate time ticket field. 

• Reads the account assignment splits for work center, cost center and employee subgroup 
grouping for personnel calculation rules for each time ticket. 

• Valuates the time tickets according to the personnel calculation rule that is entered as the 
parameter. 
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Incentive Wages Accounting: Personnel Calculation 
Rules 
The following personnel calculation rules are used in the international and in the German payroll 
schema to perform various individual steps: 

 International German

Test Employee Subgroup XW3 XW3 

Test Employee XW4 XW4 

Special Valuation Bases XW0 XW0 

Process Individual Time Tickets XW1 DW1 

Process Group Time Tickets XW2 DW2 

Final Monthly Calculation — DWM 

 

XW3: 
The employee subgroup is read in the XW3 personnel calculation rule. Employees who work on 
an incentive wage basis have to be assigned to employee DJ, DK, DO, or DP subgroups in the 
standard SAP System. If this is the case, the variable INCW is set to a value of 1. If the employee 
belongs to a different subgroup, then the variable retains its intial value of 0. 

XW4: 
The XW4 personnel calculation rule is used as a parameter by the IF function. The INCW 
variable is evaluated in this particular rule. If INCW has the value of 1, the subsequent 
processing steps are carried out; they are not if the value is other than 1. 

XW0: 
Average values from the previous month are made accessible in the XW0 personnel calculation 
rule, according to the employee subgroup. These are used as valuation bases for working times 
that are valuated with an average rate (for example, working times that have been recorded on 
time-based time tickets). 

XW1, XW2, DW1, DW2: 
The time tickets are valuated according to XW1, XW2, DW1 and DW2. 

DWM 

A final monthly calculation is performed in the DWM personnel calculation rule, according to the 
employee’s pay scale area. This only makes sense if the earnings factor [Page 30 ]3  was 
calculated in the previous accounting steps. 

 
All of the procedures described here depending on wage group, that is, the amounts 
calculated are differentiated by wage group for the hourly wage. 
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Special Operations 
The following operations are required to set up incentive wages accounting to suit individual 
customer requirements: 

• MEANV: Average calculation 

• VWTCL: Value of processing class 

(Processing class 46 is used here) 

• RE510: Reads pay scale table 

• GETAL: Sets labor utilization rate 

• TABLE: Prepares access to table fields 

– You can activate the LE parameter to access all fields in the time ticket being 
processed. 

– You can activate the GT parameter to read data on an employee’s membership in 
the group when processing group time tickets. 

VARGB: Sets field from table in variable argument • 

• FILLW: Writes to the subsequent time ticket [Ext.] 

• ADDWT: Totals in subsequent time ticket (specification M) 

 
For more information, see the RPDSYS00 documentation. 
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Wage Types 
Wage types for basic pay, wage types on time tickets, and wage types as payroll results are 
relevant in SAP Incentive Wages. 
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Wage Types from Basic Pay 
Different wage types are taken as the basis for calculating piecework bonuses, depending on 
whether the employee is an hourly or monthly wage earner. 

Hourly Wage Earners: 
The standard hourly wage ME10 is referenced to valuate time tickets for hourly wage earners. 

Monthly Wage Earners: 
Wage type MC10 is used in the standard system for monthly wage earners.  

The basic monthly wage is included in the gross amount for the monthly wage calculation in the 
standard system, and is supplemented by the variable elements for incentive wages accounting. 

For earnings factor calculation, which is also set up in the standard system, the basic monthly 
wage is multiplied by the earnings factor. The difference between this amount and the basic 
monthly wage is included in the gross amount as a piecework bonus. 

 
The monthly wage or the standard hourly wage must be specified in the Basic Pay 
infotype (0008). 
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Wage Types on Time Tickets 
There are two methods of valuating a time ticket in payroll. 

The target time on the time ticket can be valuated with the piecework rate for the wage group 
specified on the time ticket. The time tickets are paid at a piecework rate. 

The actual time on a time ticket can be paid at an average rate (for example average value from 
previous month). These are time tickets paid at an average rate. 

The wage type entered on the time ticket specifies whether the time ticket is paid at a piecework 
rate, or at an average rate. 

Wage type ML01 is used for piecework payment in the standard system, while payment at an 
average rate is indicated by wage type ML02. 

 
A wage type is only entered on time tickets that specify a personnel number. 

You can specify which wage types can be entered on which types of time ticket when you 
customize the system. See Define permitted wage types in the SAP Incentive Wages section of 
the IMG. 

Processing class 46 is used in the wage type settings to identify the payment type (piecework or 
average). The processing class has two standard specifications: 

• 1: Piecework paid time tickets 

• 2: Average paid time tickets 

This is difference between the ML01 and ML02 wage types in the standard SAP System. 
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Wage Types as Accounting Results 
Different wage types are entered in the result table by the personnel calculation rules in SAP 
Incentive Wages, depending on the accounting procedure used. 

The following wage types are used for the standard accounting procedures: 

• Hourly and Monthly Wage: 
– Time-dependent variable elements per wage group: 

ML09, ML10, ML11, ..., ML19 

– Performance-dependent variable elements per wage group: 

ML29, ML30, ML31, ..., ML39 

– Earnings for times paid at an average rate: 

MLDU 

– Performance-dependent variable element: 

MLVL 

– Time-dependent variable element: 

MLVZ 

• Earnings Factor: 
– Piecework earnings per wage group: 

ML59, ML60, ML61,…, ML69 

– Earnings for times paid at an average rate: 

MLDU 

– Earnings factor: 

MLSU 

– Incentive wages bonus: 

MLAZ 
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Partial Period Remuneration (Factoring) 
Purpose 
If an employee did not work for the whole payroll period, then a partial remuneration is calculated 
during the payroll run. In this way only results for the current period are considered. Factoring is 
used in the following cases: 

To reduce payments [Page 318] made to an employee because he or she joins, leaves, or is 
absent from the company during a period 

• 

• To calculate remuneration for an exact period [Page 31 ]9  because of substitutions, changes 
in basic pay, organizational reassignments, or changes in the personal work schedule 

• To calculate cost accounting wage types for an exact period. This will enable you to decide 
how much remuneration an employee receives for work done and for paid absences. The 
different amounts can be assigned to different cost centers. 

Scope of Function 
To determine an employee’s exact remuneration, the remuneration amount is multiplied by a 
partial period factor. The partial period factor can be calculated using different methods: 

• Payment method 

• Deduction method 

• Hybrid of payment and deduction methods 

• PWS method 

• All or nothing method 

You find guidelines on which method to select in the collective agreement, the company 
agreement and in the documentation on the individual methods. The question of which method to 
use is extremely important, particularly if payroll is run for monthly periods. 

The standard system contains a few examples for factoring rules that are needed to determine 
the partial period factor. You can either use these rules as they are, or adapt them in 
Customizing for Payroll under Factoring to meet your company requirements. Using Create 
Wage Types for Cost Accounting, you assign the wage types to different wage types for cost 
accounting.  

The following infotypes are evaluated for factoring in payroll: 

• Actions infotype(0000) 

• Organizational Assignment infotype(0001) 

• Planned Working Time infotype (0007) 

• Basic Pay infotype(0008) 

• Recurring Payments and Deductions infotype (0014) 

• Additional Payments infotype (0015) 

• Absences infotype (2001) 

• Substitutions infotype (2003) 

316  April 2001 



 SAP AG Payroll United States (PY-US) 

  Partial Period Remuneration (Factoring) 

 

April 2001  317 



Payroll United States (PY-US)  SAP AG 

Application Examples for Reductions 

Application Examples for Reductions 
When the following situations arise within a payroll period, the payments made for an exact 
period are reduced: 

• Reduction in basic pay 

− An employee joins the company on a day other than the first day of the period. 

− An employee leaves the company on a day other than the last day of the period. 

− An employee takes one week of unpaid leave. 

• Reduction of recurring payments 

− An employee regularly receives a transportation allowance but takes leave for three 
weeks. The transportation allowance must only be paid for the period during which the 
employee travels to work. 

• Reduction of additional payments 

− Your enterprise only pays a bonus on the condition that the employee will still be working 
for the enterprise the following month. 
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Application Examples for Period-Specific Remuneration 
Calculation 
When the following situations arise within a payroll period, wage types are calculated for exact 
periods. This means that the remuneration elements are calculated separately for each partial 
period. 

• Change in basic pay 

An employee’s payments are increased in the middle of a period. One half of the lower, 
period-specific remuneration amount is paid for the first partial period, and one half of the 
higher, period-specific remuneration amount is paid for the second partial period. 

• Organizational assignment 

An employee changes department and is, therefore, assigned to a different cost center. 
This does not mean that the employee receives more or less remuneration, but it does 
mean that the appropriate amounts must be debited to the cost centers in question for 
exact periods. 
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Partial Period Factor 
Definition 
You can find a definition of the term Partial Period Factor [Ext.] in the glossary. 

Structure 
The SAP System uses the following formula to calculate the partial period factor: 

(Planned working time or flat rate period working time – absence) ÷ divisor 

All of this formula’s parameters [Page 321] are time entries that must be based on the same 
calculation unit. The following calculation units exist: 

• Working hours (S) 

• Work days (A) 

• Calendar days (K) 

The parameters for the factoring formula are available in table PSP (Personal Work Schedule) in 
all three calculation units. In the personnel calculation rule, the calculation unit of the individual 
parameters is indicated by the above letters. 

 
SSOLL contains the value for planned working time in hours, and ASOLL contains 
the value in work days. 

When calculating the partial period factor you must specify the period that should be used: 

• Partial period 

If a WPBP split indicator exists for a basic pay wage type, you should use a partial period 
as the calculation basis. In this case, the period of each partial period is used as planned 
working time. In this case a “T” is set before the calculation formula parameters in the 
personnel calculation rules. 

• Whole period 

If there is no WPBP split indicator or if it is not relevant to the proportional calculation of 
remuneration, use the whole period as the calculation basis. For example, this is the 
case for recurring payments/deductions or additional payments. In this case, the period 
of the whole period is used as planned working time. A “G” is set before the calculation 
formula parameters in the personnel calculation rules.  
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Factoring Parameter 
The formula, with which the partial period factor is determined, is filled as follows: 

• Planned working time 

Planned working time is determined using table PSP (Personal Work Schedule). The 
values of the planned working time parameter can be different for employees in the same 
period if they have different personal work schedules. 

• Flat rate period working time 

The flat rate period working time is determined using table WPBP (Work Center/Basic 
Pay). 

• Absence 

In reductions, absence means the working time during which an employee was not at 
work and did not get paid. The absence is paid out in counting classes. 

• Partial period 

If remuneration elements are calculated for exact periods, employee remuneration is 
calculated separately for specific partial periods. These partial periods are determined 
using table WPBP (Work Center/Basic Pay). 

• Divisors 

The flat rate or individual period working time is used as a divisor in accordance with 
table PSP (Personal Work Schedule). 

The parameters have the following meaning: 

Value of whole period Value of a partial period Meaning 

GSSOLL TSSOLL Planned working time in hours 

GASOLL TASOLL Planned working time in work days 

GKSOLL TKSOLL Planned working time in calendar days 

GSAU** TSAU** Unpaid absence in hours for all counting 
classes 

GAAU** TAAU** Unpaid absence in work days for all 
counting classes 

GKAU** TKAU** Unpaid absence in calendar days for all 
counting classes 

GSAP** TSAP** Paid absence in hours for all counting 
classes 

GAAP** TAAP** Paid absence in work days for all 
counting classes 

GKAP** TKAP** Paid absence in calendar days for all 
counting classes 
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GSAX** TSAX** Work on public holidays in hours for all 
counting classes 

GAAX** TAAX** Work on public holidays on a work day 
for all counting classes 

GKAX** TKAX** Work on public holidays on a calendar 
day for all counting classes 

GSDIVI TSDIVI Individual period working time in hours 

GADIVI TADIVI Individual period working time in work 
days 

GSDIVP TSDIVP Flat rate period working time in hours 

GADIVP TADIVP Flat rate period working time in work 
days 

GKDIVP TKDIVP Flat rate period working time in calendar 
days 
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Technical Sequence for Partial Period Remuneration 
Purpose 
For information on the use of partial period remuneration see partial period remuneration 
(factoring) [Page 316]. 

Prerequisites 
The following conditions must be met before factoring schema xAL0 can run correctly: 

• In Customizing for Payroll under Factoring→Create Reduction Factors you have 
determined the way in which the system should calculate the employees remuneration in 
different situations. 

• Processing classes 10 (Mark wage types for factoring) and 31 (Split monthly lump sums 
for cost accounting) must be maintained for the primary wage types that require 
factoring. 

Process Flow 

  
The X sign appears in the following text in a number of schemas, functions, and 
personnel calculation rules. This abbreviation represents the country indicator and 
the international versions of the schemas, functions, and personnel calculation rules. 
You should only use this if schemas, functions, and personnel calculation rules have 
not been set up specifically for your country or if you do not want to use the country-
specific functions that are available. 

In personnel calculation schema X000 (Determine gross wage and transfer) subschema xAL9 ( 
factoring and storage) is called up. The country-specific factoring schemas included in the 
standard system take account of common, country-specific requirements. If a country-specific 
schema does not exist for your country, make a copy of international subschema XAL9 or a 
suitable country-specific schema, and adapt the copy to your particular requirements. 

1. Using function GEN/8 the system generates the secondary wage types /801 to /8<nn> 
for every partial period and enters them in the Input Table (IT).  

These wage types contain the partial period factor. The value is set at 1 in each wage 
type and is then multiplied by the constant GENAU 100,000.00 to increase the accuracy 
of the calculations. The result is written to the Rate (RTE) field. The partial period factor 
can be changed in further procedures. 

The employee subgroup grouping for personnel calculation rules and the WPBP split 
indicator are entered in each generated secondary wage type /8<nn>. 

 
The standard system generates 16 secondary wage types for the partial period 
factors. You can use the secondary wage types /801 to /809 for your own partial 
period factors. The secondary wage types /810 to /816 are used in the R/3 System to 
calculate monthly lump sums. 

2.  
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If no split indicator is available the value of the partial period remains 1. The 
corresponding wage type is paid out with the whole amount. If the checked wage type 
contains a split indicator the factoring process continues. 

3. Using the personnel calculation rule xPPF the system determines the partial period factor 
for each partial period. 

If the employee worked in the payroll period, the system determines whether he was also 
absent and using this information calculates the partial period factor. The RTE field (rate) 
is updated in the input table (IT) for each secondary wage type /8<nn>. 

4. Using the personnel calculation rule xCMO the System determines the flat-rate period for 
cost accounting. 

The processing class 31 (Cost distribution) for all wage types in the Input Table (IT) is 
valuated and the amount of the following cost accounting wage types is calculated: 

- /840 (Difference between Working Hours for the Current Month and the Average 
Value) 

- /844 (Paid public holidays) 

- /845 (Total paid non-work) 

- /846 (Total unpaid absences) 

5. Using the personnel calculation rule xVAL the System determines the salary components 
of the wage types in the Input Table (IT) by multiplying the amount of the primary wage 
type with the rate of the wage type /80<n>, which corresponds to the specification of  
processing class 10 (Mark wage types for factoring). 

The new calculated value is then entered in the AMT field (Amount) of the corresponding 
primary wage type. 

6. The system determines the hourly rates for cost accounting. 

7. The reduced values are written in the Input Table (IT). 
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PWS Method 
Definition 
The method used to calculate partial period factors. 

Use 
If the PWS method is used to calculate the partial period factor, the individual, actual planned 
working time according to the employee’s personal work schedule (PWS) is used as the divisor. 

The PWS method is suitable for use in the following situations: 

• for reductions if planned working time is specified exactly and you enter all deviations 
from planned working time in the following infotypes: 

- Absences infotype (2001) 

- Substitutions infotype (2003) 

- Planned Working Time infotype (0007) 

• Rules for calculating partial payments for exact periods 

The PWS method is not suitable if the payroll is run for monthly periods.  The employee then has 
a lower reduction amount in periods with less planned working time (short months) than in 
periods with more planned working time (long months). 

Structure 
The partial period factor is calculated as follows: 

Factor = (planed working time - absence) / individual period working time 

 

 

April 2001  325 



Payroll United States (PY-US)  SAP AG 

Payment Method 

Payment Method 
Definition 
The method used to calculate partial period factors. 

Use 
If the payment method is employed, the employee is remunerated for the period actually worked 
or for paid absences. The constant for the flat-rate period working time is used as the divisor. 

If the payroll is run for monthly periods, the general divisor determines that each calculation unit 
[Page 320] (hour or day) has the same value, irrespective of whether the period is a short or long 
month.  

The payment method is suitable for use in the following situations: 

• The employee has many unpaid absences. 

• The actual length of the period is not different from the general length of the period (for 
example, weekly payment). 

The payment method is not suitable to use in the following situations: 

• Payroll is run for an employee on a monthly basis (monthly or half-monthly) and the 
employee has only few unpaid absences. 

• In long months (for example, July) remuneration could be calculated and the amount 
could exceed the basic remuneration amount for the period, despite the absences. 

• In short months (e.g. February) an employees remuneration is reduced too much even if 
there are few absences.  

• Partial payments must be calculated for exact periods. 

The employee would receive an amount that is different from the remuneration amount 
for the period because the number of hours or days does not correspond to the average. 

Structure 
The partial period factor is calculated as follows: 

Factor = (planed working time - absence) / general period working time 

 
You can use the average values typical for your particular country, industry, or 
company as general period working time. 
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Deduction Method 
Definition 
The method used to calculate partial period factors. 

Use 
If the deduction method is employed, a prorata amount is deducted from employee remuneration 
for the period of his or her unpaid absence. The constant for the flat-rate period work time is used 
as the divisor. 

If the payroll is run for monthly periods, the general divisor determines that each calculation unit 
[Page 320] has the same value, irrespective of whether the period is a short or long month.  

The deduction method is suitable to use in the following situations: 

• The employee has few unpaid absences. 

• The actual length of the period is not different from the general length of the period (for 
example, weekly payment). 

The deduction method is not suitable to use in the following situations: 

• Payroll is run for an employee on a monthly basis (monthly or half-monthly) and the 
employee has only a few unpaid absences. 

• In long months (e.g. July) a large number of absences could result in negative 
remuneration, i.e. money would be claimed from the employee. 

• In short months (e.g. February) the employee also receives remuneration if he was 
absent for the whole month. 

• Partial payments must be calculated for exact periods. 

The employee would receive an amount that is different from the remuneration amount 
for the period because the number of hours or days does not correspond to the average. 

Structure 
The partial period factor is calculated as follows: 

Factor = (general period work time - absence) / general period work time 

 
You can use the average values typical for your particular country, industry, or 
company as general period working time. 
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Hybrid of Payment and Deduction Methods 
Definition 
The method used to calculate partial period factors. 

Use 
Since the deduction method is used for a lot of absences and the payment method is used for 
few absences it is recommended that each individual should decide which method should be 
used. For few absences the payment method should be used because then the remuneration is 
high. For a lot of absences the deduction method should be used because then the employee 
would earn less accordingly. 

 

 
Mary Brown receives a basic monthly pay of 5,456.00 and has a general period 
working time of 22 workdays. In a month that contains 23 workdays, she has an 
unpaid absence of 10 workdays. 

Reduction using different methods 

Days of absence Factoring method Partial period factor Standard salary 
10 Deduction (22-10)/22 = 12/22 2 976,00 
10 Payment (23-10)/22 = 13/22 3 224,00 
11 Deduction (22-11)/22 = 11/22 2 728,00 
11 Payment (23-11)/22 = 12/22 2 976,00 

The calculation shows: If Mary Brown were to be absent and unpaid for 11 days she 
would earn just as much if the calculation was made using the payment method as 
she would if the absence were calculated for 10 days using the deduction method. 
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All or Nothing Method 
Definition 
The method used to calculate partial period factors. 

Use 
If the all or nothing method is employed, the employee receives either the entire wage type 
amount or nothing at all. A criterion for entitlement to the entire amount could, for example, be a 
minimum period that the employee must have worked. If the condition is met, the factor is 1. If 
the condition is not met, the factor is 0. 

The all or nothing method is suitable to use in the following situations: 

• Cost transfer of travel allowance 

• If the employer pays a savings plan allowance 
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Reduction of Payments: Example 
Gertrude Jones has unpaid leave from February 3 to March 29. This means that she works just 2 
days in both February (20 workdays) and March (23 workdays). Her monthly basic remuneration 
is 3252,00. Her weekly working time is based on 37 hours. 

Parameter values in hours 

Parameter February March 

Planned working time (SSOLL) 148 172 

Absence (SAU) 132 156 

Individual period working time (SDIVI)  
148 

 
172 

General period working time (SDIVP)  
167,7 

 
167,7 

Reduction using different methods 

Method Calculation formula Remuneration for 
February 

Remuneration for 
March 

PWS a = (SSOLL-
SAU**)/SDIVI 

0,108 0,093 

 Reduced remuneration: 
b x a 

351,22 302,44 

Payment a = (SSOLL-SAU**)/ 
SDIVP 

0,095 0,095 

 Reduced remuneration: 
b x a 

308,94 308,94 

Deduction a = (SDIVP-SAU**)/ 
SDIVP 

0,213 0,070 

 Reduced remuneration: 
b x a 

692,68 227,64 

Legend [Page 321] 

a =Partial period factor   b = basic remuneration 

If the payment method is employed, Gertrude Jones receives the same amount of remuneration 
for both months. If the deduction method is employed, she is significantly overpaid in February 
and significantly underpaid in March. If the PWS method is used, she would still receive a higher 
salary in February than in March, however the difference would be significantly lower than when 
using the deduction method. 
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Calculating Period-Specific Remuneration:  Example 
Mary Brown receives a basic monthly pay of 5,456.00 and has a general period working time of 
22 workdays. She changes cost center on the 16th of a month containing 23 workdays. 

Calculating using different methods 

Partial period in 
workdays 

Factoring method Partial Period Factor Remuneration 

1.-15. = 11 Payment (23–11)/22 = 12/22 2 976,00 
Deduction (22–11)/22 = 11/22 2 728,00 

 PWS (23–11)/23 = 12/23 2 846,60 
16.-30. = 12 Payment (23–12)/22 = 11/22 2 728,00 
 Deduction (22–12)/22 = 10/22 2 480,00 
 PWS (23–12)/23 = 11/23 2 609,40 
  Total using payment 

method 
5 704,00 

  Total using deduction 
method 

5 208,00 

  Total using PWS 
method 

5 456,00 

 

 

Since Mary Brown only changed cost center and was not absent, her basic payments should be 
calculated using the PWS method. With this calculation method she receives the basic payments 
that she is entitled to for this month.  
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Net Part of Payroll (PY-US-NT) 
Purpose 
The Net Payroll Component of the SAP Payroll system processes garnishments, deductions, 
taxes, and benefits for employees during a payroll run. Net Payroll processing is based on wage 
types entered in SAP HR Master Data as well as wage types that are calculated in the Gross 
Payroll component. Net Payroll generates a results cluster containing wage types and amounts 
for all employees in a payroll run. This cluster serves as the basis for all output from the SAP 
Payroll system, such as third-party remittances and statutory reporting. 

Implementation Considerations 
You should consult with members of the Personnel Administration, Financial Accounting, and 
Benefits implementation teams prior to and during implementation of the Net Payroll component. 
Taxes are calculated within the Net Payroll component using an interface to a third-part tax 
calculation product: TaxFactory from BSI. To implement this interface, you need to install a BSI 
server, database and GUI outside of the SAP system, and link it to SAP Payroll via RFC. To 
implement Net Payroll, therefore, you need to consult with project team members with knowledge 
of network administration, database administration, SAP Basis and relevant operating systems. 

Integration 
The Net Payroll component is fully integrated with HR Personnel Administration (Master Data), 
Benefits, Financial Accounting and Controlling and other components of the SAP system. 

 

332  April 2001 



 SAP AG Payroll United States (PY-US) 

  Tax (PY-US-NT-TX) 

Tax (PY-US-NT-TX) 
Purpose 
This component calculates the amount of tax that needs to be deducted from employees' pay 
each pay period according to the relevant federal, state and local tax authority's regulations. It 
also generates the information used to create tax reports required by various taxing authorities. 

Implementation Considerations 
The Tax component is an integral part of the US Net Payroll component and requires an 
additional software license for BSI TaxFactory. This is a third-party product from Business 
Software, Inc (BSI) that serves as the tax calculation engine for SAP’s US Payroll solution. 
TaxFactory is a requirement for running SAP Payroll in the United States. 

Integration 
This component relies on data from the HR Master Data component as well as the from HR Net 
Payroll component to calculate taxes. Information generated in the Tax component is used by the 
Tax Reporter component to generate various tax reports. 

Features 
The Tax component supports all payroll tax authorities at the federal, state, county, city and 
school district level. 

It also supports different payment types for tax calculation (regular, supplemental, cumulative and 
vacation) and multiple payment methods for each payment type, such as regular, cumulative, etc. 
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The Tax Calculation Process 
Purpose 
Before the SAP Payroll component sends any data to the BSI TaxFactory for tax calculation, the 
payroll driver goes through a number of steps to determine exactly which taxes will be applied for 
each payment or deduction wage type. These steps depend largely on how you configure wage 
types, tax types, tax authorities, and taxability models in the Tax section of the Payroll: USA IMG. 
This topic illustrates the process by which the payroll driver determines which tax calculations will 
be performed by the BSI tax calculation engine. 

Prerequisites 
• All relevant configuration steps in the Tax section of the Payroll: USA IMG have been carried 

out.  

• All relevant employee master data has been maintained, such as Infotypes 008, 0207, 0208 
and 0209. 

Process Flow 
The following graphic illustrates the SAP tax calculation process. 

 

Tax Type Combinations
Combo # Tax type

01 10  ER unemployment
20  EE unemployment

02 20  EE unemployment

03 01  Withholding tax
10  ER unemployment

. . . . . . .

Model # R/W/U Tax class Combo #

  01    R      0    08
  01    U      0       02
  02    R      0    03
  02    R      1    01
  . . . .
  . . . .

Taxability Model

Tax area from infotypes:
- Residence tax area (IT 0207)
- Work tax area (IT 0208)
- Unemployment state (IT 0209)

Processing class 71 specification:
0  Regular taxable wages
1  Other taxable wages
2  Cafeteria plans (2)
       . . . .

Tax Authority Model

Tax authority      Tax model

FED              01
. . . .
CA              18
CA01              03
. . . . 
PR              19
. . . .

Employee Samuel Chan:
Residence tax area from IT 0207 = FED / CA
Salary from wage type M003 = $1000
Wage type M003: 
Processing class 71 = 0 (regular taxable wages)

Taxability model used:
For M003 for Samuel Chan = 
01    R    0    08

08 01  Withholding tax
02  EIC payment
03  EE social sec. tax
04  ER social sec. tax
05  EE Medicare tax
06  ER Medicare tax

. . . . . . .

 
The tax calculation process follows these steps: 
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1. The payroll driver determines which tax authorities apply to the employee, such as residence 
area FED, by looking at the employee's master data. 

2. The payroll driver reads a wage type and its tax class (processing class 71 specification). For 
example, M003 Salary of $1000.00 with processing class 71 specification 0 (Regular wages). 

Tax Model Tax Type Combo 

3. Based on the applicable tax area and tax authority, the payroll driver selects a taxability 
model for this combination of tax class, tax area and tax authority. In this case, the taxability 
model would look like this: 

Tax Authority R/W/U Tax Class 

FED 01 R 0 08 

4. Based on the tax type combination included in the taxability model, the payroll driver 
determines which tax types must be applied to the wage type amount. The payroll driver 
sends BSI the wage type amount and the relevant tax types. In this case, the following data 
would be sent to BSI for tax calculation: 

Amount Tax Type 

$1000 01 Withholding tax 

$1000 02 EIC payment 

$1000 03 EE Social Security  

$1000 04 ER Social Security 

$1000 05 EE Medicare  

$1000 06 ER Medicare 

5. The BSI tax engine calculates the tax on the wage type amount. The tax types passed to 
BSI determine which calculation formulas it uses. 

6. BSI returns the results of the tax calculations to the SAP Payroll system, including the tax 
amounts calculated for each wage type amount and tax type. This information appears in 
the payroll log. 

Result 
The tax wage types determined in this process are stored in the payroll results cluster for the 
employee. These tax wage types can also be copied to the tax interface tables where they form 
the basis for various tax reports generated by the SAP Tax Reporter component. 
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Tax Allowance Processing 
Purpose 

Tax allowance thresholds 

This report checks Infotype 0210 W-4 Withholding Information records and displays all 
employees whose allowances exceed the allowed limits and whose filing status is not the same 
as their Infotype 0161 IRS Mandates record. You can access this report from the main US 
Payroll menu: Info system → Tax → Withholding Allowance Report. 

The Exemption Expiration Report (RPUTAXU7) is also available. It displays all employees whose 
exemptions are due to expire within a selected date range. You can access this report from the 
main US Payroll menu: Info system → Tax → Exemption Expiration Report. 

If an Infotype 0210 record is not set up for a state and that state does not allow employees to use 
withholding information from the federal W-4, the system will now default correctly to the 
individual state rule.  

Most jurisdictions allow reductions to taxable income based on different factors, and these factors 
vary from jurisdiction to jurisdiction. The different factors have been incorporated into the system 
to determine how data can be entered into various tax-related infotypes, as well as how 
employee allowances and tax exemptions are handled by the the payroll driver. 

Process Flow 

The reporting thresholds for withholding allowances are stored by jurisdiction. If an end user 
creates an Infotype 0210 W-4 Withholding Information record with exemptions greater than the 
jurisdictional threshold (e.g. 10 for federal), the system will accept the entries and issue a 
warning that the employee's W-4 certificate should be filed to the relevant agency. 

The Withholding Allowance Report (RPUTAXU8) is also available to report those employees who 
claim exemptions greater than the jurisdictional threshold or greater than their existing mandated 
values.  

Federal and state rules governing exemptions 
Exemption expiration dates are stored by jurisdiction. If an employee claims a withholding 
exemption, the system will automatically delimit the Infotype 0210 record with the corresponding 
effective date. If a new exemption certificate is not supplied by the employee, the system will 
automatically withhold tax for check dates after the jurisdictional-mandated date.  

Defaults and edits 
The system contains edits at the jurisdictional level to ensure an end user does not set up 
allowance data which is not allowed. For example, the states of AZ, MS, PA, and PR do not allow 
additional withholding. This means, if a user attempts to enter an additional withholding amount 
on Infotype 0210, the system will return an error message.  
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Tip Income Taxation  
Purpose 
This process allows the system to handle tip income separately from regular income when 
calculating taxes.  

Different wage types are used for storing the results.   In case of retrocalculation, the 
calculation for tip incomes (and other non-cash incomes) always uses the 'Tax when 
earned' principle. 

2. Prioritize regular income taxes and tip income taxes using the tax priority module.  

If there is any amount not taken for tip income taxes, it is stored in table RT with a wage 
type assigned via T51P1 for the tip income tax.  This wage type is the 'Not taken' wage 
type. 

Process Flow 
1. Calculate taxes for regular income and tip income separately. 

3. In subsequent payroll runs, some 'Not taken' taxes are recovered by self-adjustment 
during the tax calculation. 

This recovery process must be performed separately between regular income taxes and 
tip income taxes.  

 

338  April 2001 



 SAP AG Payroll United States (PY-US) 

  Employee Tax Information 

Employee Tax Information 
Definition 
Employee tax information is used by the US payroll driver to calculate the tax an employee is 
liable to pay and the amount the employer must contribute to federal, state and local tax, as well 
as unemployment insurance.  

Structure 
Employee tax information consists of many separate pieces of information. To ensure that an 
employee’s withholdings are processed correctly, the following master data infotypes must be 
maintained: 

• Address (Infotype 0006) [Ext.] 

The employee’s permanent address is also used as their tax residence.  If these are not 
the same address, a different record can be created for the home address. 

• Residence Tax Area (Infotype 0207) [Page 34 ]0  
The Residence Tax Area establishes the tax authorities that may levy tax on an 
employee. 

• Work Tax Area (Infotype 0208) [Page 342] 
The Work Tax Area is used to calculate the amount of taxes paid to each authority for an 
employee who works across several tax areas. 

• Unemployment State (Infotype 0209) [Page 34 ]7  
An employee is assigned to an unemployment state so that Unemployment Insurance 
can be paid for that employee. 

• Withholding Information (Infotype 0210) [Page 349] 
Details from an employee’s Federal Employee Withholding Allowance Certificate, State 
Employee Withholding Allowance Certificate and the equivalent certificate for local tax 
authorities are held in the system. They are used to calculate deductions from an 
employee’s pay. 

• Withholding Overrides (Infotype 0234) [Page 353] 
In addition to holding information from employees’ Withholding Allowance Certificates, 
you may wish to store data for a tax authority that the payroll should use to calculate 
withholdings from special payments. 

• Other Taxes (Infotype 0235) [Page 355] 

In certain exceptional circumstances it may be necessary to record alternatives to the 
standard calculation of taxes for an employee. 

• IRS Mandates (Infotype 0161) [Page 357] 

If an employee has limits or exemption amounts set by the Internal Revenue Service 
(IRS) or equivalent state and local authorities, these will be taken into account by the 
system. 
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Residence Tax Area (Infotype 0207) 
Definition 
The residence tax area is the group of authorities to which an individual employee pays tax.    

Use 
As long as a particular combination of local, state and federal tax authorities has been 
maintained in the relevant section of the Implementation Guide, all the tax authorities to which 
the employee must pay tax, based on their residence, will be displayed by the system in this 
infotype. 

For further information, please see the Tax areas section of the US Payroll Implementation 
Guide. 

 
Suppose that an employee lives in San Francisco, California.  You enter the code 
CA01 for that tax area.  The system will then display the San Francisco, state of 
California, and Federal tax authorities to which the employee must pay tax. 
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Creating Residence Tax Area Data (Infotype 0207) 
Prerequisites 
The particular combination of local, state and federal tax authorities has been maintained in the 
Tax areas section of the US Payroll Implementation Guide. 

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Select the Residence Tax Area infotype (Infotype 0207) [Page 34 ]0  by entering the name or 
number in the Infotype field. 

4. Choose . 

5. Enter the employee’s residence tax area. 

All the relevant local, state and federal authorities will be displayed under Tax authorities. 

6. Save your entries. 

Result 
A Residence Tax Area record is created for the employee, which enables the payroll to calculate 
local, state and federal taxes correctly.  

April 2001  341 



Payroll United States (PY-US)  SAP AG 

Work Tax Area (Infotype 0208) 

Work Tax Area (Infotype 0208) 
Definition 
An employee who works in more than one locality during a tax year, may be subject to taxes in 
those localities.  The Work Tax Area infotype records the amount of time an employee spends in 
each locality other than their Residence Tax Area (Infotype 0207) throughout the tax period.   
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Creating an Employee’s Work Tax Area (Infotype 0208) 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Work Tax Area infotype (Infotype 0208) in the Infotype field. 

4. Choose . 

5. Enter the employee’s work tax area in the Tax area field. 

6. In the Allocation percent field, enter the percent of total work for the validity period of the 
record that the employee will perform in this tax area. 

The relevant tax authority and level are displayed. 

7. Save your entries. 

8. Repeat steps 3 through 7 for each of the tax areas in which the employee will be subject to 
tax during the period. 

Result 
The employee’s work tax area details are recorded. 
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Creating Work Tax Area Percentages for an Employee 
Suppose that an employee, John Smith, will work 100 days in San Francisco, 100 days in 
Oregon, and 50 days in Washington state in the coming year.  His residence tax area is San 
Francisco.  You should create Work Tax Area infotype records for the amount of time John Smith 
will work in each of the areas other than his residence tax area. 

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number.   

3. Specify Work Tax Area (Infotype 0208) in the Infotype field. 

4. Choose . 

5. Enter OR for Oregon in the Tax area field. 

6. Enter 40 in the Allocation percent field. 

The Tax authority Oregon and Tax level B State are displayed. 

7. Save your entries. 

8. Repeat steps 3 through 7 using 20% for Washington state. 

Result  
John Smith’s work tax area details are recorded. 
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Recording Overrides to an Employee's Work Tax Area 
Use 
If an employee works in multiple tax jurisdictions within a pay period, you can assign appropriate 
work tax areas to increments of time the employee spends working in each jurisdiction. You 
record this information in the Different Payment section of Time Evaluation Infotypes: 
Attendances (2002), Substitutions (2003), Overtime (2005), Remuneration Information (2010). 

Prerequisites 
You have maintained processing class 67 for supplemental payment wage types, and 70 for 
salaried wage types in the Maintain tax-related processing classes step under the Tax chapter of 
the Payroll USA Implementation Guide (IMG). No configuration is necessary for wage types 
related to hourly wages. 

Procedure 
1. From the main SAP menu, choose Human resources → Personnel management → 

Administration → Maintain master data. 

2. Choose the Time recording tab strip. 

6. From the same screen, choose Goto → Different payment and enter the appropriate 
work tax area for the time period specified in the Tax area field. 

7. Save your entries. 

 

3. On the screen that appears, enter: 

• the employee's personnel number 

• the relevant time period 

and choose the appropriate infotype (for example, Attendences). 

4. On the dialog-box that appears, choose the appropriate subtype. 

5. On the screen that appears, enter the relevant time data for the employee. 

Result 
You have assigned a work tax area to a given period of an employee's work time and when you 
run payroll for this period taxes will be allocated to the appropriate authorities. 

 
See also:
Example:  Recording Overrides to an Employee's Work Tax Area [Page 346] 

 

April 2001  345 



Payroll United States (PY-US)  SAP AG 

Recording Overrides to an Employee's Work Tax Area: Example 

Recording Overrides to an Employee's Work Tax Area: 
Example 
 

Scenario 
John Smith, a salesperson for Acme Tools, in Pasadena, California and earns a semi-monthly 
salary of $2,265.14. During payroll period three of 1999 John spends two days visiting clients in 
Tucson, Arizona. To ensure that the appropriate taxes are withheld when payroll is run, the 
payroll administrator records a work tax area override on the Attendances infotype (using the 
Business trip subtype) for the two days worked in Arizona. 

When the administrator runs payroll for period three the taxable gross of $197.01 and $3.85 
appears in the payroll results for the two days Mr. Smith worked in Arizona.  Although taxes are 
prorated for the days worked in Arizona, the gross taxable and tax for California are not reduced, 
since he resides in California. 

 

Taxable gross for:
FED withholding
AZ state withholding
CA state withholding

Taxes:
FED withholding
AZ state withholding
CA state withholding

  RT Results table

/101 Total gross 2,265.14
……

/601 TG Withholding 01 2,265.14
/601 TG Withholding 02    197.01
/601 TG Withholding 03 2,265.14
…..

/401 TX Withholding 01    306.65
/401 TX Withholding 02        3.85
/401 TX Withholding 03      64.10

…...       
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Unemployment State (Infotype 0209) 
Definition 
Unemployment state information is used for the payment of Unemployment Insurance for each 
employee.  You should create Unemployment State records in accordance with company policies 
and the applicable state laws.  

This information is also used to provide statistical information to unemployment authorities 
requiring multiple work site reports.  

 
It is very important to follow company and state policy when determining an 
employee’s unemployment state.   
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Creating an Employee’s Unemployment State Record 
(Infotype 0209) 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number.   

3. Specify Unemployment State (Infotype 0209) in the Infotype field.  

4. Choose . 

5. Enter the employee’s unemployment state in the Tax authority field. 

6. If necessary enter the employee’s work site. 

 
For those employees whose unemployment state requires statistical reporting by work 
site, you should also enter this data. 

7. Save your entries. 

Result 
The employee’s unemployment state details are recorded. 
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W-4 Withholding Information (Infotype 0210) 
Use 
This infotype is used to store the details from an employee’s Federal Employee Withholding 
Allowance Certificates (Form W-4) and from the employee's equivalent state and local 
Withholding Allowance Certificates, if applicable. The information stored on Infotype 0210 is used 
together with the information in Infotype 0234 Withholding Overrides and Infotype 0161 IRS 
Mandates to calculate withholding tax for an employee. 

Structure 
The fields and structure of Infotype 0210 will vary depending on whether you are creating an 
Infotype 0210 record with the Federal subtype or with a subtype for a state or local authority. 

Exemptions 
An employee’s W-4 or state/local equivalent may contain a number of allowances as well as 
amounts.  These should be entered in the relevant sections.  

If the IRS or other authority has set a limit on the number of allowances an employee may claim, 
the IRS mandates indicator will be active. 

The Tax exempt indicator should be defined for employees who are exempt from withholding tax 
for a particular authority. 

Withholding adjustments 
An employee may also specify an additional amount to be withheld from their pay to go towards 
paying their federal, state and local taxes. 

You can assign an alternative formula to be used to calculate the withholding. 

W-5 filing status 

The EIC status field is only available on the Federal subtype of Infotype 0210. If an employee 
turns in a Form W-5 (Earned Income Credit Advance Payment Certificate), you should enter the 
information from the form here.  

Withholding Overrides 
If an employee has withholding overrides defined on Infotype 0234 Withholding Overrides, this 
information is displayed here.   
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Creating Federal Withholding Information 
Use 
The IRS allows employees to claim allowances and exemptions from their income tax. This 
information is entered here on Infotype 0210 and used to calculate the employee's income tax 
liability. 

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number.   

3. Specify W-4 Withholding Information (Infotype 0210) in the Infotype field, enter FED in the 
Subtype field, and choose . 

4. Enter the employee’s filing status and the relevant exemption information and amounts.   

 
If a limit on the number of allowances an employee may claim has been set by the 
IRS or other authority and entered in Infotype 0161 IRS Mandates, the IRS 
mandates indicator will be active. 

5. If you define the employee as exempt with the Tax exempt indicator, then you need to define 
the validity dates for the exemption in the Start and To fields. 

6. If the employee has requested that an additional amount be withheld from his or her pay, 
enter the amount in the Add. withholding field and define the calculation method to be used 
for the withholding amount. 

7. Enter the employee’s Earned Income Credit status, if necessary. 

8. Save your entries. 

Result  
The employee’s Federal Withholding Allowance Certificate details are recorded. 
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Creating State or Local Withholding Information 
(Infotype 0210) 
Use 
Some states and local tax authorities allow employees to claim allowances and exemptions from 
their income tax. This information is entered here on Infotype 0210 and used to calculate the 
employee's income tax liability. 

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number.   

3. Specify W-4 Withholding Information (Infotype 0210) in the Infotype field 

4. Enter the state or local authority in the Subtype field, and choose . 

The Create W-4 Withholding Info. screen appears. 

 
Different fields will be active on the infotype depending on which authority you 
entered in the Subtype field. 

5. Enter the employee’s filing status and the relevant exemption information and amounts.  

 
If a limit on the number of allowances an employee may claim has been set by the 
IRS or other authority and entered in Infotype 0161 IRS Mandates, the IRS 
mandates indicator will be active. 

6. If you define the employee as exempt with the Tax exempt indicator, then you need to define 
the validity dates for the exemption in the Start and To fields. 

7. If the employee has requested an additional amount to be withheld from their pay, enter the 
amount in the Add. withholding field and define the calculation method to be used for the 
withholding amount. 

8. Save your entries. 

Result 
The employee’s State or Local Withholding Allowance Certificate details are recorded. 
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Withholding Overrides (Infotype 0234) 
Definition 
The information entered for an employee here is used in conjunction with the employee's W-4 
Withholding Information (Infotype 0210) to calculate withholding taxes for the employee.  

Use 
Payroll uses the information on Infotype 0234 to calculate withholdings from special payments. 
The type of supplemental method to be used to calculate the tax is also likely to differ with each 
payment. For this reason it may be advisable to create a new record for each payment. 

Alternatively, you may have employees to whom standard tax calculation does not apply.  In this 
case you should specify the Employee override group to which they belong in the Federal 
subtype of this record.  The override will apply to all tax authorities. 

Additional information 
The withholding method used by payroll, either supplemental as defined here, or standard, is 
determined when the payment to an employee is entered into the system. Please see the Wage 
type section for further information. 
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Creating Withholding Overrides (Infotype 0234) 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Withholding Overrides (Infotype 0234) in the Infotype field. 

4. Enter the relevant tax authority in the Subtype field and choose . 

5. Enter the supplemental method, if required. 

6. For state or local tax authorities, specify the type of certificate provided by the employee, if 
required. 

7. Save your entries.  

Result 
The withholding override information is recorded for the employee. 
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Other Taxes (Infotype 0235) 
Definition 
In certain exceptional circumstances it may be necessary to record alternatives to the standard 
calculation of taxes for an employee. 

The Other taxes (Infotype 0235) record may be used for any tax authority.  

Tax types 
All tax types except withholding tax are displayed and may be adjusted for the particular 
authority.  You may either alter the calculation of the tax by changing the formula used, or 
exempt an employee entirely from a tax.  

Any change you make here will override the standard calculation of the tax. 
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Creating Other Taxes (Infotype 0235) 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Other taxes (Infotype 0235) in the Infotype field. 

4. Enter the relevant tax authority in the Subtype field and choose . 

The Create Other Taxes screen appears, listing all the tax types for the particular tax 
authority. 

5. Either assign an alternative formula to the tax type you wish to change, or indicate an 
employee’s exemption from the tax by activating the Exe. field. 

6. Save your entries.  

Result 
You have changed the way in which local, state or federal taxes are calculated for certain 
employees. 

 
You will only need to change the way taxes are calculated for an employee, or 
exempt an employee from a tax in very exceptional circumstances. 
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IRS Mandates (Infotype 0161) 
Definition 
An employee may have limits on exemption amounts set by the Internal Revenue Service (IRS) 
or another tax authority. The IRS Mandates infotype ensures that the system will not allow an 
employee to claim more allowances or withholdings than the IRS or the relevant tax authority has 
deemed appropriate for that individual. You should maintain the IRS Mandates infotype with any 
data provided by the relevant authority. 

Use 
If an employee has IRS mandates stored in Infotype 0161, the system will compare the 
allowances stored in the employee's Infotype 0161 IRS Mandates record with the employee's 
Infotype 0210 W-4 Withholding Information record and use whichever amount is lower.   

Example 
Employee Pat Smith has an IRS Mandates record with eight allowances. Pat claims 10 
allowances on her Form W-4 (and therefore has a W-4 Withholding Information record with 10 
allowances). When payroll is run, the payroll driver will use the mandated allowances of eight 
from Infotype 0161 IRS Mandates to calculate her withholdings.  

Employee Jan Jones has an IRS Mandates record with six allowances. Pat claims four 
allowances on his Form W-4 (and therefore has a W-4 Withholding Information record with four 
allowances). In this case when payroll is run, the payroll driver will use the claimed allowances of 
four from Infotype 0210 W-4 Withholding Information to calculate his withholdings. 
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Creating IRS Mandates for an Employee (Infotype 0161) 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify IRS Mandates (Infotype 0161) in the Infotype field. 

4. Enter the tax authority in the Subtype field and choose . 

5. Enter the employee’s filing status and maximum number of exemptions allowed as indicated 
on the document sent by the relevant authority. 

6. Save your entries. 

Result 
Details of the limits set by the IRS or other authority are recorded in the system. 
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Retrocalculation 
Use 
When there is a change of earnings for the past, payroll results need to be recalculated to correct 
tax and earnings amounts.  

Integration 
Payroll results, and therefore payroll retrocaclulations, form the basis for evaluations and posting 
to accounting, tax deposits, as well as forms produced in the Tax Reporter component. 

Prerequisites 
The system performs a retrocalculation of payroll results when you make a retroactive master 
data change that affects an employee's past earnings.  

Features 
Wage offset calculation 
In almost all cases, the SAP payroll driver uses the wage offset method to calculate taxes for 
retroactive changes. This means that any under or overpayments are forwarded to the current 
period and taxed with the current tax authority and tax rate.  

"Tax-when-earned" calculation 
In certain cases, the system uses the tax-when-earned method. This means the payroll driver 
goes back to the pay period where the master data change occurred and repeats the tax 
calculation. It changes the taxable earnings, runs the tax calculation on the updated earnings 
using the previous tax authority and that tax authority's current tax rate, and changes the taxes 
paid in that period.  

 
If a retroactive change crosses the year, the payroll driver does not go back and 
recalculate taxes for the prior year. This is controlled by function UOTX0 within 
schema U000. 

Cases when the tax-when-earned calculation is used: 

• any retroactive non-authorized manual check 

• a prior-period change of tax authority 

• a prior period change of taxability model 

• a retrocalculation made to a gross-up (not recommended) 

As delivered, the payroll driver does not allow retroactive taxes to be higher than the taxes 
withheld in the original period, i.e. a 'cap' is placed on retroactive taxes. This cap could lead to 
errors when performing a retrocalculation where a state change is involved. 
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Retrocalculation 

 
You can control whether a cap is placed on retroactive taxes in function UTPRI 
within schema U000. 

Cross-quarter retrocalculation 
When you make a cross-quarter retrocalculation, the system identifies and records key data for 
the run in the Cross-Quarter Retrocalculation table. This data is critical for both Tax Reporter and 
the Payroll Reconciliation Report. Payroll creates entries in this table whenever it detects a cross-
quarter retrocalculation of payroll results that were already included in a productive Tax Reporter 
form generation run, as indicated in the Tax Reporter Control Record. Entries are made in the 
Cross-Quarter Retrocalculation table for any retro change that adjusts taxable or tax wage type 
amounts in the original period. 

Other retroactive adjustments not impacting tax reporting are not flagged in this table. Tax 
Reporter uses the entries in this table to pre-select employees for correction forms, allowing 
more efficient runtimes during tax form generation. 
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Benefits Integration to Payroll 
Purpose 
Users of the R/3 Benefits component can use Benefits Integration to streamline the payroll 
calculation process for their employees. The Benefits Integration component allows benefits-
related deductions and contributions entered in master data to be processed during net payroll 
processing.  

Implementation Considerations 
The Payroll: USA Implementation Guide (IMG) contains a section for configuring Benefits 
Integration. You have to ensure that payroll-related settings for your Benefits plans are 
configured properly before running payroll. For example, you must set up contribution limits for 
registered savings plans, like 401(K) plans, to ensure that employee deductions fall within legal 
limits.  

Integration 
This component integrates the Payroll component with the Benefits component. Deduction and 
contribution amounts can be remitted to benefits providers using functionality from the Third 
Party Remittance component. 
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401(k) Nondiscrimination Testing 
Use 
The 401(k) Nondiscrimination Testing program can be used to alert you to potential year-end 
problems, thus allowing time to make adjustments to participants’ deferred contributions that 
might be necessary to maintain the plan within published guidelines. The 401(k)-
nondiscrimination test identifies the number and/or identity of HCEs (highly compensated 
employees) within the company. It also outputs an evaluation of your 401(k) plan and indicates 
whether the plan is in compliance with current regulations. You can also use this program to 
update the HCE indicator in master data for employees it identifies as HCEs. 

Prerequisites 
You must be using both the Benefits and Payroll modules to run this test. 

Features 
The 401(k) Nondiscrimination Testing program evaluates the 401(k) plans at your company, and 
determines whether they comply with current regulatory guidelines. The program also identifies 
HCEs within your organization. 

Activities 
The 401(k) Nondiscrimination Test report has two selection screens. You can switch between 
selection screens using the following menu bar pushbuttons: 

• General info 

• Tests 

After all selections have been made, the program evaluates benefit plan data, master data and 
payroll results for the relevant employee population. Finally, it outputs the results to a list screen. 
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Running the 401(k) Nondiscrimination Test 
Prerequisites 
You must be using the Benefits Integration component with US Payroll to perform this test. 
Payroll results must be available in the system for your selected test population. Also, all Benefits 
plan data must have been maintained in the Benefits component. 

Procedure 
There are two selection screens for the 401(k) nondiscrimination test report: 

1. General Information  

2. Tests  

This procedure describes how to make selections and execute the 401(k) nondiscrimination test.  

 

Step 1: Start the test report  
1. Select System-> Services-> Reporting. 

2. Enter program RPSBENU1. 

3. Execute the program. The Benefits: 401(k) Non-discrimination Testing selection screen 
for General Information appears. 

Step 2: Set general test parameters 

1. In the Date Selection area of the first (General Info) selection screen, enter the plan year 
to be tested (required). The default is the year prior to the current system year. 

2. The report automatically uses the information from Box 1 of the W-2 Federal Tax and 
Wage Statement form. Box 1 uses the last payroll result of the testing year as the 
compensation to be used in testing. You can customize this compensation by including 
and/or excluding additional wage types in the Define Compensation Adjustment area. 

3. In the Choose Benefit Plan(s) for Testing area, enter the benefit area and benefit plan(s) 
to be tested. (This is a required field when you run nondiscrimination testing. It is optional 
when you are simply identifying HCEs.) 

4. To automatically run all tests necessary to determine whether chosen plans qualify for 
tax exemption, select Perform All Necessary Tests. Do not select it if you want to run 
tests individually on subsequent screens.  

Step 3: Describe, restrict, and determine the HCE population 

1. Enter the minimum annual taxable compensation your company uses to define HCEs for 
the testing year selected. This is a required field in the first (General Info) selection 
screen.  

2. Select a method for determining HCEs. You can use either of two methods: 

− The first method includes employees who own at least 5% of the company, or whose 
compensation exceeds the minimum annual taxable compensation you defined in 
the previous step 
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− The second method includes the top 20% of employees whose compensation 
exceeds the minimum annual taxable compensation you defined, plus those 
employees who own at least 5% of the company (but whose compensation is below 
that of the top 20% of employees)   

You can also run the test under both options to compare the results. 

If you select the second (top 20%) method, there are three places where you can identify 
certain employees as exempt from classification as HCEs: 

− Select General Exclusions As Permitted By Law, for a list of some exclusionary 
categories. Choose all applicable categories.  

 
If you choose Have Not Completed 6 Months of Service, then you must also 
enter the Date Type Indicating First Day Of Work, and you must maintain the 
Date Specifications Infotype (Infotype 0041) for that date type.  

If you choose Have Terminated, then you must also enter the Date Type 
Indicating Last Day Of Work, and you must maintain the Date Specifications 
Infotype (Infotype 0041) for that date type.   

− Exclude by criteria entered in the Master Data Exclusion area.  

− Exclude by criteria entered in the Benefit Data Exclusion area. 

 

Step 4: Select the test(s) to run 

1. In the Update Database area in the first (General Info) selection screen, select either to: 

• Run the test as Testing Only, Do Not Update.  This is the default. 

• Allow the program to update the HCE indicator in the HCE Information infotype (infotype 
0375), using a batch-processing session, by selecting Batch Input Information.   

2. If you did not choose Perform All Necessary Tests on the General Information screen, 
you may perform the Ratio Percentage Test and/or Average Benefit Test. To run these 
tests, choose Tests from the application toolbar to access the second selection screen. If 
you chose to perform all necessary tests or run the Ratio Percentage Test, check to see 
whether you can exempt certain employees from ratio percentage testing. There are two 
places where you can identify these employees as exempt: 

• On the second (Tests) selection screen, choose General Exclusions As Permitted By 
Law for a list of some exclusionary categories. Choose all applicable categories.  

 
If you choose Have Not Completed 6 Months of Service, then you must also enter 
the Date Type Indicating First Day Of Work, and you must maintain the Date 
Specifications Infotype (Infotype 0041) for that date type.  

If you choose Have Terminated, then you must also enter the Date Type Indicating 
Last Day Of Work, and you must maintain the Date Specifications Infotype (Infotype 
0041) for that date type.   

• Exclude by criteria entered in the Master Data Exclusion area of the second (Tests) 
selection screen. 
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3. If you chose to perform all necessary tests or run the Average Benefit Test, and if the 

benefit plan(s) you are testing are designed to integrate with Social Security, then you 
may enter the appropriate Social Security Wage Types to include in the testing. 

4. Enter the Maximum Annual Compensation value appropriate for the testing year selected 
previously. This is a required field in the second (Tests) screen.  

5. If you did not choose Perform All Necessary Tests on the General Information screen, 
you may select and run the Actual Deferral Percentage (ADP) Test and/or Actual 
Contribution Percentage (ACP) Test. 

• If you chose to perform all necessary tests or run the ADP Test, then you may select 
certain contributions to include in the testing. 

• If you chose to perform all necessary tests or run the ACP Test, then you may select 
certain contributions and/or an elective deferral or to include in the testing.   

6. Select Execute to run the test(s). 

Result 
The program outputs a list screen containing the test results. It also provides additional 
information about the testing population and the HCEs. You can save this list to a local file, or 
print it. 
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ERISA 5500 Testing 
Use 
You can run program RPSBENU2 whenever you need to file an ERISA 5500 for an employee 
benefit plan.  

Prerequisites 
You must be using the Benefits Integration component to use this report. It requires benefit plan 
data and payroll results to be available in the system. 

Features 
The ERISA 5500 form is used to determine whether employee benefit plans are operated 
according to governmental regulations. Program RPSBENU2 assists in the completion of the 
ERISA 5500 form by providing information needed for the following sections of the form: 

• 7 - number of participants in the plan 

• 21 - check if substantiation guidelines from Revenue Procedure 93-42 are being applied 

• 32 - plan income, expenses, and changes in net assets for the plan year 

Activities 
This report features multiple selection screens: 

• Population  

• Plan info  

• Items 7, 21 

Use these selection screens to tell the program which plan to examine, for which employee 
population, and also which features to use to derive the info needed for items 7 and 21. 
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Running the ERISA 5500 test 
Prerequisites 
You must be using the Benefits Integration component with U.S. Payroll to perform this test. 
Payroll results must be available in the system for your selected test population. Also, all Benefits 
plan data must have been maintained in the Benefits component. 

Procedure 
To run this report, you have to carry out the following steps using two separate screens: 

• Start the program and enter benefit plan information 

• Specify features for identifying active/deceased/highly compensated participants (needed 
for items 7 and 21 of ERISA form 5500) 

The information below describes how to make these selections, and run the ERISA 5500 test 
program.  

 

Step 1: Start the program and enter benefit plan information 

1. Select System-> Services-> Reporting. 

2. Enter program RPSBENU2. 

3. Execute the program.  

4. In the first section of the screen (Plan information), select the benefit area, benefit plan, 
and type of plan. 

5. In the second section of the screen (Date selection), enter the plan year begin and end 
dates for the plan you are testing. 

6. Continue making selections by choosing Items 7, 21. 

 

Step 2: Specify features for items 7 and 21 of ERISA form 5500 

1. In the first section of the screen (Information related to Item 7), specify the features you 
wish to use for the following tasks: 

• Define active participants (default feature ACTIV) 

• Define deceased participants (default feature DECEA) 

• Define terminated participants (default feature TERMI) 

2. Also in the first section of the screen, you can enter wage types to identify retired or 
separated participants receiving benefits. Enter any relevant wage types in this field. 

3. In the second section of the screen (Information related to Item 21), specify the method 
for identifying Highly Compensated Employees to be used in the ERISA 5500 test. You 
can enter the minimum annual taxable compensation and select one of the following two 
methods for identifying HCEs: 

− 5% Company Owner Or Compensation Exceed Limit Entered Above 
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− Top 20% Employees Whose Compensation Exceed Above Limit Plus 5% Owner     

Once you have completed making selections on the three selection screens, choose Execute 
to run the report. 

Result 
The report outputs data in a format, which allows results to be easily transferred to the 
corresponding sections of the ERISA 5500 form. You can save the output to a file, or print it. 
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Garnishments 
Purpose 
A garnishment is a legal procedure authorizing a deduction from an employee’s earnings to 
satisfy a debt. It refers to a court proceeding through which a creditor seeks to reach an 
employee’s earnings before they are paid, so they can be used to satisfy a legal claim against 
the employee. This component enables you to track and manage employee garnishments, for 
example for child and spousal support and federal and state tax levies.  

Implementation Considerations 
Install this component if you want to be able to: 

• Create and send out garnishment notice letters and answers 

• Determine garnishable wage types and amounts that can be garnished 

• Handle garnishment adjustments  

• Set up bank transfers to transfer garnished amounts to financial institutions 

• Track the employee garnishments in your company  

Integration 
The Garnishments component within US Payroll uses data entered in SAP HR Master Data 
(garnishment infotypes) to generate garnishment deductions and reports.  
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The Garnishment Process 
Purpose 
The process describes how you can create garnishments on employee wages using SAP HR.  

Prerequisite 
The appropriate settings for garnishment processing have been made in the Implementation 
Guide (IMG). 

Process Flow 
The garnishment process 

Court

Garnishment 
request

SAP HR

Garnishment 
document

Garnishment
order

Payroll
run

Payment to
creditor

 
1. The garnishment process is triggered when your company receives a garnishment order 

from the court requesting that you set aside a specific amount of an employee's wages to 
repay a debt.  

2. You then need to create the garnishment document in SAP HR detailing what type of 
debt it is, who is requesting payment for the debt, etc.  

3. You then create the garnishment order for the garnishment document. The garnishment 
order includes information such as how much will be garnished from the employee's 
wages. 

4. When payroll is run, the system looks at the garnishment order, and depending on its 
status, creates the appropriate remittance information for the creditor. 
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Result 
The garnishment payment is made to the creditor and the balance is automatically adjusted in 
SAP HR. 
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Garnishment Document (Infotype 0194) 
Definition 
This is the main garnishment infotype and is used to store garnishment document information, 
including 

• General information such as status, important dates, priority, and category 

• Vendor information 

 

• Originator information 

• Garnishment processing information, such as applicable service charges, and remittance 
information    

Integration
The Garnishment Order (Infotype 0194) is closely linked with the Garnishment Order (Infotype 
0195) and the Garnishment Adjustment (Infotype 0216). When you create and save a 
garnishment document, the Garnishment Order (Infotype 0195) [Page 37 ]6  fast-entry screen 
appears. This screen allows you to enter garnishment order information for several different order 
types.  

Adjustments to a garnishment, such as a refund, a stopped payment or an additional deduction, 
are performed using the Garnishment Adjustment (Infotype 0216) [Page 381]. 
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Creating a Garnishment Document (Infotype 0194) 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. In the Infotype field, specify Garnishment Document (0194). 

4. Choose . 

5. Enter the necessary information on the Create Garnishment Document screen.  

 
You must at least enter data in the fields for case number, priority, internal number, 
status and category. 

6. Choose Calculate end date if you want to create the end date of the garnishment.  

This will calculate the end date from when the garnishment first becomes active to the end of 
the obligation after a report is run.  

 
The end date can only be calculated when the status of the garnishment is Pending. 

7. Save your entries. 

Result 
Once you have saved your entries, the Garnishment Order (Infotype 0195) [Page 376] fast-entry 
screen appears. You can now continue creating the garnishment request. 

See also: 
Creating a Garnishment Order [Page 37 ]8 . 
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Changing Garnishment Document Information 
Procedure  

1. Choose Human resources → Personnel management → Administration → HR master 
data → Maintain. 

2. Enter the employee’s personnel number. 

3. In the Infotype field, select Garnishment Document (0194) and choose . 

The List Garnishment Document screen appears.  

4. Select the desired garnishment case from the displayed list and choose . 

5. Choose . 

The Copy Garnishment Document screen appears. 

6. Make the necessary changes. 

7. Adjust the begin date of the new record, if necessary. 

8. Save your entries. 

Result 
The garnishment document information is changed. 

See also: 
Changing the Frequency of Payment Answers to the Originator: Example [Ext.]  
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Garnishment Order (Infotype 0195) 
Definition 
The data for garnishments is stored in several infotypes. The garnishment document information 
is stored in the infotype Garnishment Document (Infotype 0194) [Page 37 ]3 . This infotype must 
be created before you can create a garnishment order.  

Use 
The Garnishment Order (Infotype 0195) allows you to store the processing data for a 
garnishment request. This data includes: 

• The initial balance of the claim 

• The periodic deduction information  

• Any information on non-exempt and exempt limits 

This infotype can be displayed in either a fast-entry or detail-entry screen. Both screens allow 
you to enter the main data of the garnishment order type, but only the fast-entry screen allows 
you to insert several order types using one entry screen. 

If you need to fill in more fields than there are in the fast-entry screen, you can use the detail-
entry screen, which you can access from the fast-entry screen by choosing Garnishment → 
Order, by selecting Order from the toolbar, or by simply double-clicking the desired entry in the 
fast-entry screen. 

Structure 
• Order Fast-Entry Screen: 

The order fast-entry screen enables you to enter information on multiple garnishment 
orders at one time.  

The deduction is defined in two fields. The Deduction Unit field refers the specified unit to 
the value of the deduction for calculating the deduction of every pay period. The Value of 
Deduction field is the value which will be taken from payments to the employee, for all 
periods, until the garnishment end date has been met. 

The Limit information corresponds to three fields. The Limit Indicator tells you whether 
the Limit Value is for the exempt or the non-exempt amount. The system refers the Limit 
Unit to the value for calculating the non-exempt amount. The Limit Value allows you to 
enter either an amount or a percentage. 

The Lock Indicator allows you to lock an order type so the information is not considered 
during the payroll run. 

• Detail-Entry Screen 

The detail-entry screen includes all of the fields on the fast-entry screen, except for the 
operation field, as well as the fields discussed below. 

If you copy an entry in the detail screen of this infotype, a new field will appear, New 
Balance. This tells the system to no longer use the remaining balance. It will deduct the 
initial balance, ignoring the old balance. If you do not select this field, the system will 
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correct the remaining balance by calculating the difference between the new entry and 
the old entry. 

You can choose Supplements on the toolbar if you need to add additional information 
pertaining to a Federal Tax levy or State tax case. This information includes the tax filing 
status, the model for levy statement, the number of exemptions, any additional standard 
deductions, and the levy form date. 

Integration 
Adjustments to a garnishment, such as a refund, a stopped payment or an additional deduction, 
are performed in Garnishment Adjustment (Infotype 0216) [Page 381]. 
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Creating a Garnishment Order (Infotype 0195) 
Prerequisites 
You must create a Garnishment Document (Infotype 0194) immediately before you create the 
garnishment order. Upon saving the new garnishment document, the Garnishment Order fast-
entry screen appears. You must make entries here before the record can be saved. 

Procedure 
1. On the Create Garnishment Order screen, specify the desired rule in the RI (Rule 

Indicator) field. 

2. Enter either the Initial balance or the Deduction. 

 
Usually, initial balances are required in Creditor, Federal Tax, and State Tax cases and 
deductions are mandatory in Child Support and Alimony cases. However, your company 
can customize the tables to change this. 

3. Enter any additional limits if applicable.  

 

If you use a rule, limits are not necessary, but still possible. If you do not choose a rule, 
you must set limits. 

4. If necessary, choose Supplements to access another entry screen and add any 
additional information. 

 
If the case is a Federal Tax or State Tax levy, you are required to enter supplemental 
information. 

5. Save your entries. 

Result 
The garnishment order record is created. 
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Changing a Garnishment Order (Infotype 0195) 
Procedures 
There are two procedures depending on whether the garnishment order information has been 
used in a previous payroll run: 

• If payroll has not been run, follow the procedure Changing Pre-Payroll Garnishment Order 
Information.   

• If payroll has been run since the data you want to change was entered, follow the procedure 
Changing Post-Payroll Garnishment Order Information. 

Changing Pre-Payroll Garnishment Order Information 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number.  

3. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

4. Choose . 

5. Select the desired garnishment case from the displayed list and choose . 

The Change Garnishment Document (Infotype 0194) screen appears. 

6. Choose Garnishment → Order.  

If you prefer to view the Garnishment Order fast-entry screen, choose Garnishment → Order 
fast. 

7. Make your changes. 

 
You can undo changes made to an order in the fast-entry screen (for example if you 
changed the balance), by choosing Edit → Undo. However, you can only do this if you 
have not yet saved the incorrect balance. 

8. Save your entries. 

Result 
The garnishment document information is changed. 

Changing Post-Payroll Garnishment Order Information 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. In the infotype field, specify Garnishment Document (Infotype 0194) and choose . 

4. Select the desired garnishment case from the displayed list and choose . 

The Copy Garnishment Document screen appears. 
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5. Make your changes. 

6. Adjust the begin date of the new record. 

7. Save your entries. 

Result 
The garnishment document information is changed. 
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Garnishment Adjustment (Infotype 0216) 
Definition 
The data for garnishments is stored in several infotypes. The garnishment document information 
is stored in the infotype Garnishment Document (Infotype 0194) [Page 37 ]3  and the garnishment 
order information is stored in the infotype Garnishment Order (Infotype 0195) [Page 37 ]6 . 

Structure 
You can access the Garnishment Adjustment infotype directly from either of these infotypes by 
choosing Garnishment → Adjustment. Depending on the type of adjustment you make, you 
access different screens from this infotype. The infotype allows for the following adjustments:  

• Separate calculation of payments 

In circumstances in which there are two payments in the same payroll period for the 
same garnishment, for example, if the employee receieves as bonus as well as her 
regular pay, you may need to process a separate calculation. 

• Calculating the garnishment end date 

Some states put a time limit on how long a garnishment can be active. The end date 
represents the day on which the garnishment is no longer active, and can be calculated 
automatically by the system given the day that the garnishment becomes active and the 
number of valid days that the law specifies. If you forget to calculate the end date when 
first creating the garnishment document, you can still make an adjustment. 

• Declaring a new balance 

At times you may get the order to change the balance of an existing garnishment. In this 
case the system will disregard the old balance, and calculate the garnishment using the 
new balance. 

• Processing refunds from the vendor 
At times you may receive a refund from the vendor. This usually happens when a new 
balance is declared, when the vendor has a different balance on record than the value 
stored in the system, or when a garnishment payment is paid after the valid number of 
payable days. 

• Stopping a payment 
Stopping a payment is similar to a refund in that balances must be corrected because a 
check does not go to the vendor. 

• Adding additional deductions 

If an employee receives a refund from the vendor or a one-time bonus payment, this 
employee may be required by either state law or your company’s procedure to have an 
additional garnishment deduction. 

• Exeptional payments 

The type of adjustment you choose determines which screens and fields are available for editing.   
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Calculating the Garnishment End Date 
Prerequisite 
The garnishment must have the status Pending.  

 
You may not calculate the end date for all types of garnishments. Support 
garnishments usually do not have a number of valid days for which the employee’s 
pay can be garnished; therefore no end date will exist. 

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

4. Choose . 

.5. Select the desired garnishment case from the displayed list and choose  

6. Choose Garnishment → Adjustment → Calculate end date. 

The Create Calculate End Date (Infotype 0216) screen appears. 

 
You can also access this adjustment infotype via the Order fast-entry screen or the 
Garnishment Order single-entry screen by choosing the same options. 

7. Enter the number of valid days in the appropriate field. 

8. Save your entries. 

Result 
A record is created in infotype 0216 and the end date is calculated by a report. This report is run 
after every payroll period and delimits infotypes 0194 and 0195 after the number of valid days 
during which a garnishment can be active have expired. 
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Declaring a New Balance for a Garnishment 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Garnishment Document (Infotype 0194) n the Infotype field. 

4. Choose . 

5. Select the desired garnishment case from the displayed list and choose . 

The Copy Garnishment Document screen appears. 

6. Choose Garnishment → Order. 

The Copy Garnishment Order screen appears. 

Notice that a New balance indicator appears. 

7. Mark the New balance indicator. 

8. Enter the new begin date. 

9. In the Initial balance field, enter the new initial balance. 

10. Save your entries. 

Result 
The initial balance is the new balance from the begin date on. The system creates an adjustment 
in Infotype 0216 Garnishment Adjustment and any remaining balance is ignored in the next 
payroll run. 

 
Note that this is changing the initial balance to a new balance. If you would like to 
correct an existing balance, see Correcting an Incorrect Balance [Page 38 ]4 . 
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Correcting an Incorrect Balance 
Procedure  

1. Choose Human resources → Personnel management → Administration → HR master 
data → Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

4. Choose . 

5. Select the desired garnishment case from the displayed list and choose . 

6. Choose Garnishment → Order (fast-entry). 

7. Select the line that requires the change and choose . 

8. In the fast-entry screen, place the cursor on the line where the Operation indicator is I.  

This field can be found as the last entry in the line. 

9. Change the amount. 

10. Save your entries. 

Result 
The initial balance owed to the creditor is corrected (no new record is created). The difference 
will correct the remaining balance in the next payroll run. 

 
The above procedure is different from the one for declaring a new balance. For steps 
on how to declare a new balance, see Declaring a New Balance for a Garnishment 
[Page 383]. 
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Processing Refunds of Garnishment Payments 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

4. Choose . 

5. Select the desired garnishment case from the displayed list and choose . 

6. Choose Garnishment → Adjustment → Refund. 

The Create Refund (Infotype 0216) screen appears. 

7. Enter the date of adjustment and the sequence number of garnishment orders at which the 
balance should be corrected. 

8. In the Adjustment amount field, enter the refund amount. 

9. Enter the adjustment wage type.   

 
Depending on the wage type you choose, you can send the refund amount to the 
employee, garnish it, or a combination of the two.  

10. Save your entries. 

Saving your entry will automatically bring you to the Garnishment Document infotype. 

11. Change the status on infotype 0194 to Reactivate for Refund.  

This is done if the refund occurs after the release date on which the status was changed to 
Released.   

Result 
The garnishment payment refund is processed and the system automatically corrects the 
remaining balance. 
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Adding an Additional Deduction to an Existing 
Deduction 
Procedure 
6. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

7. Enter the employee’s personnel number. 

8. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

9. Choose . 

10. Select the desired garnishment case from the displayed list and choose . 

6. Choose Garnishment → Adjustment → Additional deduction. 

The Create Additional Deduction (Infotype 0216) screen appears. 

7. Enter the Date of adjustment, which must be a date within the next payroll period. 

8. Enter the sequence number of garnishment order in the SeqNo garn orders field.  

9. Enter the additional amount in the Garnishment Amount field.  

This is the additional amount to be garnished only for the particular order type. 

10. Save your entries.  

Result 
The additional deduction is processed. 
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Stopping Payment of a Garnishment 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

4. Choose . 

5. Select the desired garnishment case from the displayed list. 

6. Choose . 

7. Choose Extras → Garnishment History. 

The Garnishment History Sorted by Order Type screen appears. 

8. Choose Remittance. 

A list of the payments appears. 

 
The list is separated depending on the Remittance status of the payments. A payment 
can only be stopped when the Remittance status is set in the Evaluated section.  

9. Since there may be more than one payment, place the cursor on the Remittance status of the 
part you would like to stop, and choose Edit → Stop Payments. 

In a pop-up window a list appears of all payments that belong to the selected part. 

11. Enter the adjustment wage type.  

10. From that list, select the payment you want to stop. 

A pop-up window appears. 

Here you decide whether the stopped payment should go completely to the employee or to 
other garnishments.  

 
This pop-up window proposes an adjustment date. It is the next possible day when the 
adjustment can be made to the payroll. 

 

Result 
The payment is stopped and a Stopped Payment record is created in Garnishment Adjustment 
(Infotype 0216).  In the garnishment history, the stopped payment appears in the section with the 
Remittance status Stopped Payments. 
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Calculating Garnishment Amounts from Bonus and 
Regular Pay Separately 
Procedure 
11. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

12. Enter the employee’s personnel number. 

13. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

14. Choose . 

15. Select the desired garnishment case from the displayed list and choose . 

6. Choose Garnishment → Adjustment → Separate calculation. 

7. Save your entries.  

Result 
The garnished amount of the regular pay and that of the bonus pay are calculated separately. 
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Garnishment Reports 

Structure 

The garnishment history report displays the garnishment history for a specified employee. 
You will be able to see the corrections and deductions for the history of the employee, as well 
as remaining balances and the total to date. You can see the service charges, if any, that 
were rendered by the company, as well as remittance information. 

• The Garnishment Statistics Report 

A garnishment batch input report should be run after every payroll run to change garnishment 
status. These reports will do one of the following: 

c) Delimit all chosen garnishments. 

The information is then updated automatically in the infotypes using batch input. 

• Garnishment Letters 

Definition 
Garnishment reports retrieve garnishment data from the system. Three of these reports display 
relevant garnishment data, and one manipulates data to change the status of garnishments in the 
infotypes via batch input.  

The garnishment reports are the following: 

• The Garnishment History Report 

• The Garnishment Review Report 
The garnishment review report displays all customizing parameters that are used in 
processing garnishments. These parameters include the tables in which the information is 
stored. 

The garnishment statistics report displays the total number of employees with garnishments 
and without garnishments by personnel area, personnel subarea, employee group and 
employee subgroup. 

• The Garnishment Batch Input Reports 

a) Change all expired garnishments with the status of Active to Inactive. 

b) Change all relevant garnishments from Pending to Active. 

There are two types of garnishment letters that you can create and print using the SAP 
System. These are Answer Letters and Notice Letters. You can create each of them, either 
for an individual employee or a group of employees. The mechanism used for creating letters 
for a group of employees is automatic, depending on different events in the system. 
Depending on these events a flag is stored that is read by the report that creates the letter. 
The mechanism used for creating a letter for an individual employee is the employee’s 
garnishment infotype. 
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Executing the Garnishment Statistics Report 
Procedure 
1. From the US Payroll menu, choose Subsequent activities → Period-independent →  Payroll 

supplement → Garnishment statements. 

2. Select the reporting parameters.  

3. Choose Execute. 

Result 
You see the garnishment statistics report which displays the number of employees with 
garnishments and without garnishments sorted by personnel area, personnel subarea, employee 
group and employee subgroup. 

 
Select a personnel subarea by placing the cursor on the appropriate line and by 
choosing Choose. This displays the names of the employees in the specified 
personnel subarea that have garnishments, as well as the number of garnishments 
that are outstanding. This function is only available when garnishments exist for the 
subarea. 

Further, if you place the cursor on an employee’s name and choose Choose, the 
system will display all garnishments for the particular employee. 

You can sort by status and priority or by garnishment numbers. 

Next to each garnishment, a traffic light displays the status. A red light means the 
garnishment is either Inactive or Released, a green light means that a garnishment is 
Active, and a yellow light means that a garnishment is Pending. 
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Executing the Garnishment History Report 
Prerequisites 
The garnishment history report displays the garnishment history for a specified employee. You 
can see the corrections and deductions for the history of the employee, as well as remaining 
balances and the total to date. You also see the service charges, if any, that were rendered by 
the company, and Remittance information can be displayed.  

Procedure 
12. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

13. Enter the employee’s personnel number. 

14. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

15. Choose . 

16. Select the desired garnishment case from the displayed list. 

17. Choose . 

18. Choose History. 

Result 
The garnishment history is displayed. 

 
The system defaults the present calendar year for the parameter of this report. If you 
would like to display employee information for different dates, choose New Dates. 

To display Remittance information for the specified employee, choose Edit → 
Remittance info. Here you can see if a check is already in the Third-Party 
Remittance table. You can make changes to the dates or stop a payment as long as 
the Remittance status is set to Evaluated. 

You can sort by release date or by order type by choosingSort by Release Date or 
Sort by Order Type on the toolbar. 
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Changing the Garnishment Due Date Using the 
Garnishment History Report: Example 
Scenario 
John Smith’s creditor garnishment has expired. However, although his debt has been paid, the 
due date on his garnishment in the system is incorrect. This due date can be corrected using the 
garnishment history report. 

Procedure  
1. Choose Human resources → Personnel management → Administration → HR master 

data → Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Garnishment Document (0194) in the Infotype field. 

4. Choose . 

5. Select the case with the desired garnishment and choose . 

6. Choose History. 

The garnishment history is displayed. 

7. Choose Remittance. 

8. Place the cursor on the due date that you want to change.  

If there are payments from different payroll runs, you can select from a list which payments 
you want to change the due date for. 

 
This is only possible if the Remittance status is set on Evaluated. 

9. Enter the new due date and save your entries. 

Result  
The garnishment due date is changed. 
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Executing the Garnishment Review Report 
Prerequisites 
The garnishment review report displays all customizing parameters that are used in processing 
garnishments. These parameters include the tables in which the information is stored. 

Procedure 

20. Enter the employee’s personnel number. 

24. Choose . 

19. Choose Human resources → Personnel management → Administration → HR master data 
→ Maintain. 

21. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

22. Choose . 

23. Select the desired garnishment case from the displayed list. 

25. Choose Extras → Customizing review 

Result 
You see the customizing entries. 

 
If you access the review report from Garnishment Document (Infotype 0194), you 
receive the list of garnishment document customizing tables. If you access from 
Garnishment Order (Infotype 0195), you receive the list of garnishment order 
customizing tables. 
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Garnishment Letters 
Definition 
Garnishment letters include answer letters and notice letters that must be sent out to the 
employee being garnished and the originator of the garnishment.   

Use 
Notice letters are used in cases of bankruptcy, termination, notification, release, and leave of 
absence. These letters depend on the status of the garnishment as shown in Garnishment 
Document (Infotype 0194). 

Answer letters use information from previous payroll runs to create a letter to the vendor. This 
letter may or may not be requested by the vendor. 

Structure 

Letters for groups of employees are printed using two reports; one for notice letters and one for 
answer letters. Theses reports can be found in the US Payroll menu under Subsequent activities 
→ Period-independent, then Payroll supplement → Garnishment letter. See the online report 
documentation for more information on these reports. 

There are two ways to create letters for employees. You can create letters for: 

• Individual employees 

• Groups of employees 

Letters for individual employees are printed directly from the employee’s Garnishment Document 
infotype.  
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Creating a Garnishment Answer Letter for an Employee 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

5. Select the desired garnishment case and choose . 

2. Enter the employee’s personnel number. 

3. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

4. Choose . 

The Change Garnishment Document screen appears. 

6. Choose Extras → Print Answer Letter or choose Answer letter on the toolbar. 

A list of payroll results appears. 

7. Select the payroll results for which you would like to create an answer letter.  

 
Depending on the selected payroll results, the corresponding type of letter will be 
created. If an assignment is not made to a form in the customizing table, the name of 
the form can be entered here. 

Result 
An answer letter is created and displayed on the screen. The administrator can now: 

• Print the letter. 

• Make individual changes to the letter by choosing Edit → Edit letter before printing. 

• Select another form to create a different letter by choosing Letter → Other form. 
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Creating a Garnishment Notice Letter for an Employee 
Procedure 
6. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

7. Enter the employee’s personnel number. 

8. Specify Garnishment Document (Infotype 0194) in the Infotype field. 

9. Choose .. 

10. Select the desired garnishment case and choose . 

11. Choose Extras → Print Notice letter or choose Notice letter from the toolbar. 

 
Depending on the garnishment status, the corresponding type of letter is created. If 
an assignment is not made to a form in the customizing table, you can enter the 
name of the form directly. 

Result 
A notice letter is created and displayed on the screen. The administrator can now: 

• Print the letter. 

• Make individual changes to the letter by choosing Edit → Edit letter before printing. 

• Select another form to create a different letter by choosing Letter → Other form. 
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Tips 
Purpose 
This component calculates wages and taxes for employees who receive tips, while taking tip 
credits and tip allocation into account. 

Features 
This component enables you to: 

• Differentiate between tipped and non-tipped employees  

• Record tips for each employee 

• Process tip credits 

• Determine tip allocations 

• Calculate and track withholding taxes for tips 

• Record tip information required on Form 8027 (Employer's Annual Information Return of Tip 
Income and Allocated Receipts) 

Constraints 
The Tips component does not include an automatic process for determining whether jurisdictional 
thresholds have been met that would require an employee to report tips or would make an 
employee eligible for tip credit, such as $20 per month. Instead, the customer must predetermine 
which employees should report tips. From a system point of view, if tips are entered, they will be 
processed. For tip credit, employees must be flagged as either eligible or not eligible for tip credit 
on Infotype 0506 Tip Indicators.  

This component does not provide an automatic process for calculating establishment-level tip 
information that is needed for the tip allocation process. Specifically, this component does not 
calculate gross receipts per establishment, total direct and indirect tips per establishment or total 
tip shortfall per establishment. Instead, it relies on the user supplying this data on a pay-period 
basis. 

For overtime wage rate calculation, the tax area defined on Infotype 0208 Work Tax Area must 
be the same as the tax authority in defined in the US Payroll IMG step Define establishments for 
tip processing. This is because the system uses the tax area and tax authority to derive the state 
minimum wage. 
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Calculating Tip Allocation 
Purpose 
Establishments that are required by the IRS to calculate tip allocation for their employees are 
assigned a percentage of their total food and beverage sales for a pay period, usually 8%, as a 
tip allocation amount. Employees at the establishment who do not report sufficient tips to cover 
their prorated share of this percentage each pay period must be allocated the difference between 
what tips they report and their prorated share of the tip allocation amount. This must be 
calculated every pay period for each of the establishments at which an employee works during 
that period. This amount is also calculated as a year-to-date amount each pay period and printed 
on the employee's Form W-2 at the end of the year. 

Prerequisites 
You have made all of the necessary customizing for tips in the Tips chapter of the US Payroll 
Implementation Guide (IMG). 

You have recorded your adjusted gross receipts for the pay period, including the total tip shortfall 
for the establishment (the difference between the amount of gross receipts an establishment is 
required to report to the IRS as tips, and the amount actually reported by employees as tips) in 
the Record adjusted gross receipts section in the Tips chapter of the US Payroll Implementation 
Guide (IMG). 

Process Flow 
When payroll is run for your employees, the system goes through several steps to determine 
whether or not tip allocation applies to each combination of employee and establishment, and if 
so, whether the employee earned sufficient tips at an establishment to cover that establishment's 
tip allocation percentage. 
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The tip allocation process 

No tip allocation
calculated for employee

YES

NOTip allocation
allowed for 
establishment?

Determine establishment 
of employment from
Infotype 2010 cost center

Determine employee’s
 prorated tip

allocation amount
for establishment

Table T5UP2 -
Establishment/stores for

tip processing

YES

Determine percentage
of tip allocation
allowed for establishment

Table T5UP2 -
Establishment/stores for

tip processing

Determine gross receipts 
for establishment 
for pay period

Table T5UP4 -
Establishment level

adjusted gross receipts

Do employee’s tips 
cover establishment’s 
tip allocation percent?

No

YES

No tip allocation
calculated 

for employee

Total tips for pay period

Compare Infotype 2010
EE Remuneration
Info

Infotype 2010
EE Remuneration
Info

Calculate tip 
allocation 

for employee

Employee eligible
for tip allocation? 

Infotype 0506
Tip Indicators

No tip allocation
calculated for employee

NO

YES

 
1. The system looks at the employee's Infotype 0506 (Tip Indicators) record to determine 

whether the employee is eligible for tip allocation. 
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Calculating Tip Allocation 

 
Employee must be defined as a directly tipped employee to be eligible for tip 
allocation. 

2. The system then determines at which establishment(s) the employee worked by looking at 
the employee's Infotype 2010 (EE Remuneration) records. 

3. The establishment is then checked against table T5UP2 (Establishment/stores for tip 
processing) to see if tip allocation is allowed for that establishment.  

4. If tip allocation is not allowed for that establishment, no tip allocation is calculated for the 
employee. If allocation is allowed, then the system determines the establishment's tip 
allocation percentage from table T5UP2 (Establishment/stores for tip processing). 

5. The system then looks at Table T5UP4 (Establishment level adjusted gross receipts) to 
determine the establishment's gross receipts for the pay period. This amount is used to 
calculate the employee's prorated tip allocation amount for the pay period. 

6. The employee's prorated tip allocation amount for the pay period is then compared against 
their total tips for the pay period entered on Infotype 2010 (EE Remuneration Info). 

7. If the amount is sufficient to cover the employee's prorated tip allocation amount for the pay 
period, then no tip allocation is calculated for the employee. If it is not sufficient, tip allocation 
is calculated for the employee. 

Result 
Tip allocation is calculated for the employee, if necessary.  
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Calculating Wages Using Tip Credit 
Purpose 

Process Flow 

When an employee qualifies as a "tipped" employee, the employer may credit any tips received 
by the worker up to a certain amount of the worker's hourly wage, depending on the jurisdiction. 
However, if the employee does not earn sufficient tips to cover the tip credit amount, the 
employer must pay the employee the difference.   

Prerequisites 
You have made all of the necessary customizing for tips in the Tips chapter of the US Payroll 
Implementation Guide (IMG). 

When payroll is run for your employees, the system goes through several steps to determine 
whether or not tip credit applies to each employee, and if so, whether they earned sufficient tips 
to cover the tip credit: 
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Calculating wages using tip credit 

Infotype 0506
Tip Indicators

Infotype 0008
Basic Pay
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 Minimum and cash 
 wages for tip credit
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Basic Pay

Infotype 2010
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Table T5UP1
most favorable 
rule

YES
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wage payment 
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No
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1. The system examines the employee's Infotype 0506 (Tip Indicators) to determine whether 

the employee is eligible for tip credit calculation. 
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2. The system then determines the wages for a tipped position versus a non-tipped position by 
looking at the employee's Infotype 0008 (Basic Pay) and Infotype 2010 (EE Remuneration 
Info). 

 
The hourly wage amount stored in the employee's Basic Pay record (Infotype 0008) 
is the applicable cash wage (minimum wage minus tip credit) and not the minimum 
wage. 

If the employee is working in a non-tipped position, the employee's wages are calculated 
without tip credit. If the employee is working in a tipped position, the system proceeds to 
Step 3. 

3. The system looks up the establishment at which the employee's tips were recorded, and from 
that information, it derives the state code for the establishment and the applicable state rule 
for calculating tip credit. 

4. The system then compares the federal and state rule to determine which is the most 
favorable to the employee and uses that rule to calculate the employee's wages. 

5. If the tips reported by the employee were not sufficient to cover the tip credit, the system 
calculates the applicable sub-minimum wage payment for that employee (pay period credit 
amount minus total tips amount). 

Result 
The system has determined whether tip credit applies to the employee and calculated the sub-
minimum payment for the employee if necessary. 
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Tip Indicators (Infotype 0506) 
Definition 
This infotype enables you to define the tipped status of an employee. This status is used when 
calculating tip credit and tip allocation. 

Use 
This infotype allows you to define whether an employee is: 

• Non-tipped  

• Directly tipped  

• Indirectly tipped  

If the employee is a tipped employee, you can also define whether or not the employee is eligible 
for tip credit. 
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Defining Tip Indicators (Infotype 0506) 
Use 
The tip indicators entered here determine which rules apply to an employee for tip credit and tip 
allocation. 

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the desired personnel number . 

3. Specify Tip Indicators (Infotype 0506) in the Infotype field. 

4. Choose . 

5. Enter the appropriate Tipped Emp. Indicator and, if the employee is a tipped employee, 
define whether the employee is eligible for tip credit. 

6. Save your entries. 

Result 
You have defined the tip indicators for your employee.  
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Recording Adjusted Gross Receipts 
Use 
Adjusted gross receipts are used as allocation bases for tip allocation. They need to be recorded 
every pay period. 

Prerequisites 
You have defined your establishments/stores in the Tips chapter of the Payroll USA 
Implementation Guide, under step Define establishments for tip processing.  

Procedure 
Execute the Payroll USA Implementation Guide step Record adjusted gross receipts under the 
Tips chapter.  

See the documentation for that step for more information. 
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Recording Reported Tip Amounts 
Procedure 
7. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the personnel number. 

3. Specify EE Remuneration Info (Infotype 2010) in the Infotype field. 

5. Here you can enter the regular work hours and/or overtime hours as well as the directly 
tipped or indirectly tipped amounts and total gross receipts for that employee. 

 
The system does not check whether the employee is classified as tipped or non-
tipped employee in Infotype 0506 Tip Indicators and does not generate a warning or 
error message if you enter tips for an employee defined as non-tipped. 

4. Choose . 

The Create EE Remuneration Info (Infotype 2010) screen appears. 

6. Choose Cost assignment to define at which cost center/establishment the tips were received. 

 
The employee will be rejected if no cost center is specified here. The first six 
characters of the cost center must correspond to the value defined for the 
establishment in the US Payroll Implementation Guide, step Define establishments 
for tip processing.  

7. Save your entries. 

Result 
You have recorded tip amounts received by an employee at a specific establishment. 
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Deductions (PY-US-DD) 
Purpose 

Implementation Considerations 
Deductions processing requires configuration of deduction wage types for use in Personnel 
Administration. You also need to create payment/deduction schedules to ensure deductions are 
taken at the correct intervals. See the Deductions chapter of the Payroll: USA Implementation 
Guide (IMG) for further information. 

Integration 

 

Deductions (post-tax) are processed during net payroll calculation. The SAP system offers 
extensive functionality for deductions processing, such as deductions processing with goals and 
arrears processing.  

Deductions processing begins with the entry of deduction wage types for employees in the SAP 
Personnel Administration component. For example, you can use the Recurring Payments and 
Deductions infotype to create a deduction for union dues for an employee. Any deductions 
entered in this way will be automatically taken during net payroll calculation.  
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Employee Deductions 
Definition 

Deductions from employees’ pay can be processed automatically by the R/3 Payroll 
component. For example, you can use Payroll to processing priorities and arrears 
automatically, and to set limits on deductions. By deductions we mean union dues, 
insurance contributions, charitable donations and so on; tax and garnishment deductions 
are processed.  

Structure 
Wage Type 

A wage type represents each deduction. Individual wage types have characteristics that 
determine their processing by the payroll. For deductions processing, these 
characteristics can include the amount to be deducted, the moments and the frequency 
at which the deduction should be taken, as well as arrears processing and limits on 
deductions. These details will have been set up using the Payroll Implementation Guide, 
Environment for Maintaining Wage Types section.  

Number and Unit 
For deductions of non-monetary objects the payroll will use a predefined formula to make 
the appropriate monetary deduction from the employee’s pay. This formula is part of the 
characteristics of the particular wage type (see above). 

First Payments and Intervals 

You may determine the payroll period in which the first deduction is made by entering 
either of two details: 

• The payroll period 

• The date 

The payroll will make the first deduction in the payroll period that contains the date 
specified. 

Further deductions can be made in intervals of payroll periods or days/weeks/ 
months/years. 

Alternatively, a payment model may have been assigned as a default to a particular wage type. 
This will have been set up using the Payroll Implementation Guide, Deduction Frequencies 
chapter. The payment model will appear automatically when you enter the wage type. In this 
case you do not have to enter the payment intervals, as they are predefined. At this stage, you 
can also change the payment model. 

Integration 
The processing of deductions from employee pay integrates master data and payroll 
functionality. In R/3, the Payroll component processes deductions from employees’ pay 
using data from their Recurring Payments and Deductions (Infotype 0014) records. 
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Deductions and Intervals per Payroll Period: Example [Ext.] 

Deductions and Intervals by Date and Time Period: Example [Ext.] 
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Creating a Regular Deduction per Payroll Period 
Prerequisites 
When a deduction needs to be made from an employee’s paycheck every time that the employee 
is paid, you need to create a Recurring Payments and Deductions (Infotype 0014) record for the 
employee.  

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Recurring Payments and Deductions (Infotype 0014) in the Infotype field. 

4. Choose . 

5. Enter the validity period of the deduction. 

6. Select the number of the wage type that represents the deduction. 

7. Enter either the (monetary) amount to be deducted or the number and type of units of the 
deduction. 

 
The Number/unit fields may only be used for wage types that have been set up to deduct 
per unit. This will have been done using the Payroll Implementation Guide, Environment 
for Maintaining Wage Types section. 

8. Enter an assignment number if required. 

9. Enter the number of the first payment period. 

10. In the Interval in periods field, enter 01 so that the deduction is made with each payment the 
employee receives. 

11. Save your entries. 

Result 
The deduction will be made automatically each time that the employee is paid. 

See also: 
Creating a Regular Deduction: Example [Ext.] 
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Creating a Deduction with a Different Interval than the 
Employee’s Payroll Period 
Prerequisites 
When a deduction needs to be made from an employee’s paycheck at intervals which differ from 
the intervals at which the employee is paid, you need to create a Recurring Payments and 
Deductions (Infotype 0014) record for them.  

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master 

data → Maintain. 

2. Enter the employee’s personnel number. 

3. Specify Recurring Payments and Deductions (Infotype 0014) in the Infotype field. 

4. Choose . 

5. Enter the validity period of the deduction. 

6. Select the number of the wage type that represents the deduction.  

7. Enter the (monetary) amount to be deducted or the number and type of units of the 
deduction. 

 
The Number/unit fields may only be used for wage types that have been set up to deduct 
per unit. This will have been done using the Payroll Implementation Guide, Environment 
for Maintaining Wage Types section. 

8. Enter an assignment number if required. 

9. Enter the date of the first payment in the First payment date field.  

The payroll will make the first payment in the payroll period in which this date falls. 

10. In the Interval field, enter the interval number and unit, 6 weeks for instance.  

The payroll will calculate the intervals from the First payment date. Each time the interval falls 
in a payroll period a deduction will be made. 

11. Save your entries. 

Result 
The deduction will be made automatically from the employee's paycheck at the correct interval. 

 

412  April 2001 



 SAP AG Payroll United States (PY-US) 

  Limits on Deductions 

Limits on Deductions 
Definition 
Set up standard limits on deductions using the Payroll Implementation Guide, Limits on 
Deductions chapter. The limits set here apply to deductions created for an employee using 
Recurring payments and deductions (Infotype 0014) records, and are processed automatically by 
the payroll. 

 
These limits will, for instance, determine that no more than 5% or $150 may be 
deducted from the total gross amount an employee receives per month. 

If you wish different limits to apply to certain deductions for particular employees, you may 
override the automatic limits by creating a Limits on Deductions (Infotype 0165) record for them.  

See also: 
Limits on Deductions (Infotype 0165) [Ext.]  
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Wage Type Classes 
Definition 
Individual wage types that are related and represent particular deductions are grouped into wage 
type classes. All insurance deductions, for instance, could have been grouped into one wage 
type class. 
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Limiting Rule 

Definition 
Rules are set up in the Payroll Implementation Guide, Limits on Deductions chapter. They apply 
to whole or percentage amounts of wage types. A rule may define, for instance, that no more 
than 5% of the total gross amount received by an employee may be deducted.  
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Creating Limits on Deductions (Infotype 0165) 
Prerequisites 
If a limit on a deduction that is not the same as the standard limit that applies to a particular 
employee, you should create a Limits on Deductions (Infotype 0165) record for this employee. 
This will record override the standard limit set in the system.  

Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the employee’s personnel number.  

3. Specify Limits on Deductions (Infotype 0165) in the Infotype field. 

4. Choose . 

5. Select the Wage Type Classes [Page 414] to which the limit should apply. 

6. Select the time frame to which the limit applies. 

7. In the Interval field, enter the required time frame. 

8. Enter a fixed amount or a select a Limiting Rule [Page 415] for the limit. 

9. Save your entries. 

Result 
A non-standard limit is set for this employee on the relevant deductions. 

 
You may assign a number of different limits to one wage type class for an employee. 
This allows you to specify, for example, that no more than 6% or $200 may be 
deducted from the total gross amount a particular employee receives per month. 
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Loans 
Purpose 
You can use this component to enter, administer and perform payroll for company loans in the 
SAP system. 

You can grant an employee company loans for a specific purpose, for example, to build a house 
or buy a car. In doing so, you grant the employee an interest rate lower than the market’s usual 
reference interest rate. The employee’s salary provides your enterprise with security.  

The amount of administration is kept low as the processing of formalities, payment of the loan, 
repayment and interest payment by the employee, can simply be processed using Payroll. 

Integration 
Loan repayment and interest calculation are automatically processed in Payroll and, according to 
your entries, withheld from the employee’s salary. The loan accounting data is saved together 
with the payroll results. 

Scope of Function 
In principal, you can choose between various loan categories in the SAP system, such as 
installment loans and annuity loans, with different repayment types. 

To simplify awarding and evaluating the loan, we distinguish between various loan types. Loan 
types distinguish between loans using the purpose and the loan category, for example, Building 
loan with installment repayment. 

At least one loan condition is assigned to a loan type. The interest rate and repayment pattern 
for the loan are stored in this type of loan condition. 

You enter all the loan data in the Loans infotype (0045). 

You set up loan types and their conditions in the Loans unit in Payroll Customizing. 
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Company Loans (Infotype 0045) 
Definition 
You use this infotype to enter all the loan data. This infotype contains information 
on: 
• Basic data 

• Conditions 

• Payments 

Use 
During the payroll run, the data in the Loans infotype (0045) is used to calculate 
the following values: 
• Loan deductions  

• Loan interest calculation 

• Imputed income taxation 

Structure 
Loan Types 
The loan types are stored as subtypes in the Loans infotype (0045). Every loan 
that you create gets a sequential number. The combination of loan type and 
sequential number makes is possible for the system to clearly identify every loan. 
This makes it possible for you to create several loans of the same type for an 
employee. 

 
When creating a loan, the system always proposes a sequential number. Depending 
on whether you create a loan of the same type for an employee or just want to 
change the conditions of a loan that already exists, you must either keep or change 
the sequential number proposed by the system: 

• If you want to create a new loan and create a new infotype record for this 
purpose, the system suggests a new sequential number that has not been 
used before. We recommend that you keep this number. 

• If you want to create a new loan and copy an existing infotype record for this 
purpose, the system will suggest the sequential number of the infotype 
record you have copied. You must change this number. We recommend that 
you first of all check the list of existing infotype records to see which 
sequential numbers have already been assigned to this employee. If you use 
an existing sequential number, the system cannot clearly assign payments to 
a loan. 
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• If you want to change the conditions of a loan that already exists and copy 
an existing infotype record for this purpose, the system will suggest the 
sequential number of the infotype record you have copied. You must keep 
this number. 

Tab Pages 
On the Basic data tab page, enter the date of approval and the amount of the 
loan. The status of the loan is also displayed here. However, payments and 
special payments that you have entered after the last payroll run, are not taken 
into consideration. 
On the Conditions tab page, you enter the relevant loan conditions. You also 
specify when repayment should begin. Regardless of this, interest payments are 
included in the payroll run, immediately after the loan is paid to the employee. 
On the Payments tab page, you enter all the payments that are made by your 
company or employee with regard to the loan.  

Payments 
On the Payments tab page you enter outgoing payments, repayments and other 
payments, for example, loan charges. You can pay a maximum of the approved 
amount to the employee. The approved amount is occasionally paid in several 
partial amounts. 

 
The approval of a loan does not automatically lead to payment. You should only 
allocate the loan payment on the Payments tab page. 

Payments that have already been included in the payroll run are inactive and can 
not be changed, as you usually do not make changes to such payments. 
However, if you want to process a payment that has already been accounted, 
select it and choose . The payment is then released for processing. 

 
Subsequent changes to payments trigger retroactive accounting in Payroll. 

Payment Types 
There are various payment types available for entering payments. The payment 
types differentiate between payments according to: 
• Whether it is a case of a payment to the borrower or a repayment to the employer 

• Whether the payment is made directly by check or bank transfer or is cleared with the 
employee's remuneration during the payroll run 
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We recommend that you use the payment types provided by SAP as far as this is 
possible. However, if you require your own payment types, you can set these up in 
Payroll Customizing under Loans → Master Data → Customer Payment Types [Ext.]. 

Using Payment Types 

Payment type Use Comment/Example 

Outgoing payment to 
third-party  

You do not want to pay out the loan to 
the employee, you want pay it to a third 
person instead. 

An employee receives a 
building loan to build a house. 
You do not pay the loan to the 
employee, but to the 
contractor who builds the 
house. 

Loan payment 
(payroll) 

You want to pay the employee the total 
approved amount of the loan or part of 
this together with his/her pay. 

 

Loan payment 
(external) 

You want to pay the employee the total 
approved amount of the loan or part of 
this by check or bank transfer. 

 

Loan remission An employee cannot repay his/her loan 
or you want to release him/her from the 
remaining debt. 

You can only close a loan in 
the system when the 
remaining loan amount has 
either been repaid by the 
borrower or remitted by the 
lender. 

Fees You want to demand fees from your 
employee for granting the loan. 

 

Total repayment The employee repays the total 
outstanding amount of the loan by 
check or bank transfer. 

 

Special repayment 
(payroll) 

The employee makes an unscheduled 
repayment that should be withheld 
from his/her pay. 

 

Special repayment 
(external) 

The employee makes an unscheduled 
repayment by check or bank transfer. 

 

Loan balance transfer You want to transfer company loans 
from a legacy system. 

You can also use the 
payment type Loan 
payment (external) for 
transferring loans from 
legacy systems. 
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The Special Repayment (External) and Complete Repayment payment types can 
both be used for a direct repayment by check or bank transfer. These payment types 
have different types of interest calculation: 

• In the case of special repayment (external), the day you specify as the 
payment date is not taken into consideration in interest calculation. 

• In the case of total repayment, this day is taken into consideration in interest 
calculation. 

If you want to enter a repayment for an employee, that leaves the company or 
changes company code, use the Total repayment payment type. This guarantees 
that interest is calculated for the loan even for the last day that the employee works 
in the company or is assigned to the old company code. 

 
The employee Anne Lovelace leaves your company on April 30. She was granted a 
company loan. You want to enter an external repayment for this loan on April 30. If 
you enter the repayment as a special repayment (external) with the payment date of 
April 30th, no more interest is calculated for the loan for this day. If you enter the 
payment as a complete repayment with the payment date as April 30, interest will still 
accrue for this day.  As Anne Lovelace is no longer an employee in your company on 
May 01, you can not enter the payment as a special repayment (external) with the 
payment date as May 01, so that interest can still be calculated for April 30. 

Integration 
The correct repayment of a loan is only guaranteed when there is a valid infotype 
record for the Loans infotype (0045). That is why Payroll is interrupted with an 
error message when there is no valid infotype record for an open loan. This can, 
for example, occur when the validity of a loan created was underestimated. You 
must therefore extend the validity of the loan in a case like this. When doing so, 
proceed as described in correct incorrect entries [Page 423]. 
Once the employee has completely repaid the loan, a message is displayed in 
the payroll log. We recommend that you delimit loans that are completely repaid 
in the Loans infotype (0045). 
See also: 
Company Loans (Infotype 0045): National Features Great Britain [Ext.] 
Company Loans (Infotype 0045): National Features Belgium [Ext.] 
Loans (Infotype 0045): Features for Venezuela [Ext.] 
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Creating Loans and Loan Payments 
Use 

An employee applies to the HR department for a loan for a certain purpose. The HR department 
checks whether the employee fulfills the criteria for a loan. You specify the amount of the loan, 
the repayment type and conditions together with the employee. You can modify this data at any 
time. You also specify the validity period and approval date. 

Each loan is assigned to an employee and can be clearly identified using the personnel number, 
loan type and sequential number. 

 
To distinguish between different loans assigned to the same employee, you use a 
combination of the loan type and the sequential number. For this reason, you can not 
use a sequential number that has already been assigned to a new loan with the 
same type as another loan, even if the loans do not coincide or if one of the loans 
has already been delimited. The system suggests the next available sequential 
number. 

Prerequisites 
• You have set up loan conditions and loan types in Payroll Customizing, under Loans → 

Master Data → Create a Loan Type [Ext.]  

• You are in master data maintenance [Ext.]. 

Procedure 
1. Enter the employee’s personnel number. 

2. In the Infotype field, enter 0045, and in the Subtype field, enter the loan type. 

 
If you create a new data record, you must enter the loan type as a subtype on the 
menu screen. The field is no longer ready for input in the Loans infotype (0045). 

3. Choose . 

4. Enter the data required and save your entries.  

 
We recommend that you specify the payment on the Payments tab page. 

You can also enter a note or a commentary on the loan or employee. Choose Edit  
→  Maintain Text. When you have created a text, a  pushbutton is displayed, 
which you can use to call up the text. 
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Correcting Incorrect Entries 
Use 
You have created a loan and discovered incorrect entries. You must correct the incorrect loan 
values. You could correct the following entries: 

• validity period 

• external reference number 

• loan condition 

• repayment or annuity installment 

• approval date 

• approved loan amount 

• payments 

 
These type of corrections trigger a retroactive accounting run in Payroll. Retroactive 
accounting takes places until the date that is set in the Valid field of the Loans 
infotype (0045). If you only change payment information, the system uses the date of 
payment as the retroactive accounting limit. 

Prerequisites 
• You have created a loan [Page 422]. 

• You are in master data maintenance [Ext.]. 

Procedure 
1. Enter the employee’s personnel number. 

2. In the Infotype field, enter 0045 and in the Type field, enter the loan type to be changed. 

3. Choose . 

4. If several loans exist for the same loan type, select the loan to be changed using  or . 

5. Correct the relevant values. 

6. Save your entries. 
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Creating a Special Repayment 
Use 
As well as the repayment installment that regularly incurs, an employee wants to make an 
additional repayment for his/her loan. This is possible using the Special Repayment (External) or 
Special Repayment (Payroll) payment types. The employee can pay the external special 
repayment by check, cash payment, and so on. He/she can use part of the available 
remuneration, for example, Christmas bonus or vacation bonus or other gratuities, for the special 
payment (Payroll). 

Prerequisites 
• You have created a loan [Page 422]. 

• You are in master data maintenance [Ext.]. 

Procedure 
1. Enter the employee’s personnel number. 

2. In the Infotype field, enter 0045 and in the Subtype field, enter the correct loan type. 

3. Choose . 

4. If several loans exist for the same loan type, select the loan to be changed using  or . 

5. Choose the Payments tab page. 

6. Enter a special repayment. 

 
If the employee wants to repay the loan completely, you use the loan amount open, 
displayed on the Basic Data tab page. 

For the Special Repayment (Payroll) payment type, the repayment amount should 
not exceed the payment amount of remuneration that the employee receives. 

7. Save your entries. 
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Changing the Value of a Loan 
Use 
If the interest rate for the loan conditions or the repayment amount and/or annuity installment 
change, you must create a new infotype record for the Loans infotype (0045). The old data 
record is then delimited in time. If several data records exist for one loan in a payroll period, the 
record that is valid at the beginning of the period is evaluated within Payroll. 

The loan amount and approval date are fixed elements of a loan. These values must remain 
constant in all the loan data records. 

 
If there is a split in the payroll results due to a personnel action or change in the legal 
person, proceed as described in Processing Loans in the Case of a Change in 
Company Code.  [Page 426] 

Prerequisites 
• You have created a loan [Page 422]. 

• You are in master data maintenance [Ext.]. 

Procedure 
1. Enter the employee’s personnel number. 

2. In the Infotype field, enter 0045 and in the Subtype field, enter the loan type to be changed. 

3. Choose . 

4. If several loans exist for the same loan type, select the loan to be changed using  or . 

5. Choose Edit → Copy. 

6. Enter the new validity period and change the loan values (for example, the repayment 
installment). 

7. Save your entries. 

Result 
You have made a time-dependent change to the loan. A new data record is created and the old 
data record is delimited. 
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Processing Loans in the Case of a Change in Company 
Code 
Purpose 
If an employee changes company code [Ext.], for example, works for another company within 
your group, he can not transfer his loan to the new company code. This is due to the fact that he 
would no longer repay repayments to the company that awarded him the loan but to the new 
company. 

That is why you must delimit the Loans infotype (0045) to the date of the change of company 
code. To do this, you change the end date of the infotype record so that the infotype record is 
only valid until the date of the change of company code. 

You must also close the infotype with a complete repayment. The person, who makes this 
payment in whatever way, should be arranged within the company. 

Finally, you create a new loan for the employee from the point in time that he belongs to the new 
company code. 

Process Flow 
1. The employee changes company code. 

2. You make the following changes in the Loans infotype (0045): 

You delimit the infotype record to the date of the change of company code. − 

− You close the employee's loan with a complete repayment in a similar way to leaving 
[Page 427]. 

3. You create a new loan [Page 422] for the employee from the point in time that he belongs to 
the new company code in the Loans (0045) infotype. 

 
You can link the Loans infotype (0045) to the dynamic action Change of company 
code. To do so, choose dynamic actions [Ext.] in Personnel Administration 
Customizing, under Setting up procedures. 
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Processing Loans for an Employee Who Leaves 
Use 
When an employee who has been granted a loan, leaves your enterprise, you must make sure 
that he/she has completely repaid the loan. After the employee has left your enterprise, payroll is 
no longer performed for him/her, making it impossible for repayment to take place via payroll. 
Any outstanding debts must be settled in Financial Accounting. We therefore recommend that 
you close the loan with a special repayment or complete repayment, before the employee 
leaves. 

 
When an employee leaves the company, a message is displayed in the payroll log. 
The SAP System does not automatically settle outstanding balances. 

Prerequisites 
• You have created a loan [Page 422]. 

• You are in master data maintenance [Ext.]. 

Procedure 
1. In the Infotype field, enter 0045 and in the Type field, enter the loan type to be changed. 

2. Choose . 

3. If several loans exist for the same loan type, select the loan to be changed using  or . 

4. Choose the Payments tab page. 

5. Enter a special repayment or complete repayment for the amount of the loan amount still 
outstanding and save your entries. 
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Processing Loans for Inactive Agreements 
Use 
If an employee does not get paid for a certain period of time, repayment of the loan should be 
inactive for this time. 

Prerequisites 
• You have created a loan [Page 422]. 

• You are in master data maintenance [Ext.]. 

Procedure 
1. Enter the employee’s personnel number. 

2. In the Infotype field, enter 0045 and in the Type field, enter the loan type to be changed. 

3. Choose . 

4. If several loans exist for the same loan type, select the loan to be changed using  or . 

5. Choose Edit → Copy. 

6. In the fields Valid ... to (valid from and to), you enter the date, from which repayment of the 
loan should be inactive. 

7. Choose the Conditions tab page and enter 0 in the Repayment or Annuity installment field.  

8. Save your entries. 

The system refers to the fact that the existing data record is split. 

9. Confirm the message. 

Result 
There are now three data records with different start and end dates for the changed loan: 

Loans Infotype (0045)

Before change:

After change:
Data record 1 Data record 2 Data record 3

= Start date = End date

One data record

 

Repayment No repayment Repayment

Repayment

• Record 1: from the original start date to the date from which repayment should become 
inactive 

• Record 2: from the date on which repayment should become inactive to the date from which 
repayment should recommence 

• Record 3: from the date on which repayments should start again to the original end date 
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You have changed the employee's loan for a certain period in such a way that no repayments are 
due. After the end of the period without repayments, the repayment installment originally 
specified is automatically due. 
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Deleting Loans 
Use 
A loan can be deleted for the following reasons: 

• an incorrect personnel number has been entered. 

• the employee rejects the loan. 

• the employer does not approve the loan. 

 
If you want to delete a loan, you must first of all delete all the accompanying 
payments, as described below. 

You cannot delete the Loans infotype (0045) if a loan has already been paid and the 
employee has not repaid it completely yet. 

You cannot delete loans that have been paid back completely, and for which 
processing is complete. 

Prerequisites 
• You have created a loan [Page 422]. 

• You are in master data maintenance [Ext.]. 

Procedure 
1. Enter the employee’s personnel number. 

2. In the Infotype field, enter 0045 and in the Subtype field, enter the loan type of the loan to be 
deleted and choose . 

3. If several loans exist for the same loan type, select the loan to be deleted using  or . 

4. Choose the Payments tab page. 

5. Select a payment and choose . 

6. Repeat step 5 until you have deleted all payments. 

7. Save the infotype record. 

Depending on whether other loans exist for the same loan type, you access 

− another loan record 

From here, you go back to the Maintain HR Master Data screen 

− directly to the Maintain HR Master Data screen 

8. Choose . 

9. Check whether the information displayed refers to the loan to be deleted, and choose  
again. 
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Repayment 
Use 
If you have paid a loan to an employee, he/she usually repays the amount in regular partial 
amounts. The loan repayment is made up of a repayment share, which reduces the loan amount 
paid for each loan period, and an interest share. 

The type of loan repayment is stored in different loan categories. The start of repayment and 
repayment pattern are stored in different loan conditions. 

Prerequisites 
In Payroll Customizing, under Loans → Master Data → Create a Loan Type [Ext.] you have 

• specified the assignment of loan categories to loan types in the Technical Attributes view. 

• specified at least one loan condition for each loan type in the Conditions view. 

Scope of Function 
The SAP system distinguishes between the following loan categories: 

• Repayment in installments 

In this case, the employee regularly pays a repayment installment. This installment 
contains only the repayment. The interest receivable is added on in every payroll period. 
The total amount that the employee must pay in every period, thus changes. As the term 
of the loan progresses, the amount gets less and less, as the remaining debt and also 
the interest receivable from the employee decrease. 

• Annuity repayment 

In this case, the employee regularly pays a annuity installment. This installment 
contains both the repayment and the interest. The total of repayment and interest 
payment thus remains constant. This type of repayment is awarded on a more regular 
basis, as the charge to the borrower remains constant for the complete term of the loan. 

• Recurring advance 

In this case, you can pay the employee a certain amount on one occasion. The recurring 
advance is not repaid and no interest incurs. The employee must only repay the amount 
when he/she leaves the enterprise. 

 
Expenses of 1,000 euro regularly incur for an employee in the external sales force. 
So that the employee does not have to pay this amount from his own pocket, he/she 
receives a one-off recurring advance of 1,000 euro. Each time expenses are 
accounted at the end of a payroll period, the employee is repaid exactly the amount 
that he spent on expenses in this period. The recurring advance is not affected by 
this. On leaving, the employee must only repay the enterprise exactly 1000 euro. 
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Activities 
When you create a loan for an employee in the Loans infotype (0045), choose a loan type. This 
loan type has been assigned a certain loan category in Customizing. In this way, you determine 
the type of repayment according to which the employee must repay the loan. 

Select the repayment pattern for the loan in the Loan condition field, on the Conditions tab page 
in the Loans infotype (0045). Specify the repayment amount in the Repayment installment or 
Annuity installment field. 
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Repayment of Installment Loans 
The repayment amount that reduces the balance of the loan in each loan period remains 
constant. Interest accrues as an additional charge against the employee.  

The expected term of the loan can be determined for this loan type. 

Prerequisites 
Loan amount paid out 30,000 euro 

Interest rate 5 % p.a. 

Repayment installment 250 euro 

Interest calculation frequency Monthly 

Repayment frequency Monthly 

Repayment start date One year after loan was paid out 

Loan Calculation 
• In the first twelve months, interest of 125 euro accrues monthly. As the loan balance of 

30,000 euro remains unchanged in this period, the interest amount remains constant. 

• Repayment, which starts after 12 months, is calculated in the following way: 

30,000 euro / 250 euro = 120 months 

• The total term of the installment loan is eleven years. 

• In the first month after repayment begins, deductions taken from the employee's 
remuneration are 375 euro = 250 euro repayment + 125 euro interest). 

• The remaining debt after the first repayment is 29,750 euro. 

• With each repayment, the amount of interest is reduced, and subsequently the amount paid 
by the employee is also reduced. 
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Example: Repayment of Installment Loans 
A repayment amount is calculated, that is then deducted from the employee’s pay in each loan 
period. This repayment amount consists of a repayment share and an interest share. The 
repayment amount remains constant, but the interest share decreases and the repayment share 
increases during the loan period. 

Because of the interest deductions, the term of the loan cannot be directly deduced from the rate 
of repayment for this loan type. 

Prerequisites 
Loan amount paid out 30,000 euro 

Interest rate 5 % p.a. 

Annuity installment 250 euro 

Interest calculation frequency Monthly 

Repayment frequency Monthly 

Repayment start date One year after loan has been paid out 

Loan Calculation 
• In the first twelve months, interest accrues every month, which increases the balance of the 

loan and the interest. In the first month, the interest is 125 euro, in the twelfth month it is 
130.31 euro, so that the loan balance increases to 31,404.02 euro before the first repayment. 

• From the first annuity installment, 130.85 euro is allotted to interest and 119.15 euro to the 
regular repayment. 

• The total term of the loan, including the first year when no repayments are made, amounts to 
almost 27 years. 

• The amount that the employee must pay each month remains constant at 250 euro. 
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Repayment Plan 
Use 
You can create a repayment plan for a loan to obtain detailed information on the term of the loan 
and the charge to the employee.  

Integration 
You can only create the repayment plan for loans that you create in the Loans infotype (0045) or 
have already created. 

Scope of Function 
• You create the repayment plan for each of the employee's loans, which is identified by the 

loan type and the sequential number. 

• You create the repayment plan in the currency of the repayment installment. 

• If you have already created loan payments, this is mentioned in the repayment plan. 

• When you create a loan in the Loans infotype (0045), you can simulate a repayment plan for 
an employee even if you have not yet entered any loan payments, and have not yet saved 
the loan. 

You can enter any values for the loan amount, repayment installment, start of repayment 
and payment date. You can repeat the repayment plan again and again, for example, to 
check the effect a higher or lower repayment installment has on the term of the loan. 

• You can copy the values to the infotype that you have specified when simulating the 
repayment plan. 

If you have, for example specified a different value for the loan amount when creating the 
repayment plan, to the value you have entered in the Approved loan amount field when 
creating the infotype record, you can copy this change to the infotype. The system then 
automatically copies the changed amount from the dialogbox Parameter for Repayment 
Plan to the Approved loan amount field. You must not manually enter the changed 
amount in this field. 
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Example: Repayment Plan 
Prerequisites 
In the SAP system, the following values are stored for an employee’s loan: 

Personnel number 123456 

Loan type Building loan with annuity payment (0200) 

Sequential number 06 

Legacy data transfer 7,700 euro on June 01 1998 

Special repayment 1,000 euro on December 24 1998 

Annuity installment 450 euro monthly 

Repayment start date June 01 1998 

Result 
Using this information, the system creates the following repayment plan: 

Repayment plan for Personnel number 123456 

Loan ID 0200 06 (Building loan with annuity repayment) 

Currency euro 

 

Year Period Balance Repayment Interest 

1998 06 7,282.08 417.92 32.08

1998 07 6,862.42 419.66 30.34

1998 08 6,441.01 421.41 28.59

1998 09 6,017.85 423.16 26.84

1998 10 5,592.92 424.93 25.07

1998 11 5,166.22 426.70 23.30

1998 12 3,737.75 428.47 21.53

1999 01 3,303.32 434.43 15.57

1999 02 2,867.08 436.08 13.76

1999 03 2,429.03 438.05 11.95

1999 04 1,989.15 439.88 10.12

1999 05 1,547.44 441.71 8.29

1999 06 1,103.89 443.55 6.45

1999 07 658.49 445.40 4.60

1999 08 211.23 447.26 2.74
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1999 09 0.00 211.23 0.88

   7,700 262.11
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Creating Repayment Plans 
Prerequisites 
You have created a loan [Page 422]. 

 
When you are creating a new loan, you can also create the repayment plan. You 
must only specify the approved loan amount and the loan condition. You can then 
choose any parameters for the repayment plan. 

You are in master data maintenance [Ext.]. 

Procedure 
1. Enter the employee’s personnel number. 

2. In the Infotype field, enter 0045 and in the Subtype field, enter the loan type. 

3. Choose  or . 

4. If several loans with the same loan type exist, select the loan for which you want to create the 
repayment plan, using  or  . 

5. Choose  (Create Repayment Plan). 

You are in the Parameter for the repayment plan dialog box. 

6. If necessary, change the data displayed and choose . 

Result 
The system creates the repayment plan. 

To copy the values to the infotype that you have entered in the Parameter for repayment plan 
dialogbox, you proceed in the following way: 

1. Go from the repayment plan back to the Parameter for the repayment plan dialogbox. 

2. Choose  (Copy). 
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Displaying Conditions 
Use 
The Conditions function allows you to display detailed information on the interest amount and the 
interest and/or repayment pattern of the loan. 

Prerequisites 
• You have created a loan [Page 422]. 

• You are in master data maintenance [Ext.]. 

Procedure 
1. Enter the employee’s personnel number. 

2. In the Infotype field, enter 0045 and in the Type field, enter the loan type. 

3. Choose . 

4. If several loans exist for the same loan type, select the loan to be displayed using  or . 

5. On the Conditions tab page, choose the  function (condition overview). 

Result 
In the Conditions ... for loan type dialog box, you can see the validity date, debit interest rate, 
reference interest rate and, depending on the loan type, the repayment and/or interest pattern: 

• In the case of an installment loan, the interest and repayment patterns are displayed. 

• In the case of an annuity loan, only the repayment pattern is displayed, as the interest is 
due at the same time. 

The repayment pattern determines when a repayment installment is due. The interest pattern 
determines when the cumulated interest that incurs in every payroll period is due. 

 

April 2001  439 



Payroll United States (PY-US)  SAP AG 

Interest Calculation 

Interest Calculation 
Use 
The SAP system calculates the interest that incurs for a loan in accordance with 
the specifications that you have made in Customizing for the relevant loan type. 

Prerequisites 
In Payroll Customizing, you have defined the following: 

Value date • 

You have specified at which point in time interest on loans should be calculated in your 
enterprise, under Loans → Calculation  → Adjust Value Date [Ext.]. In the standard 
system, interest is calculated at the end of the payroll period. 

Interest rate and interest calculation frequency • 

In the Conditions view under Loans → Master Data → Maintain Loan Types [Ext.], you 
have specified the amount and the intervals at which interest should be due. 

 
If you want to award an interest-free company loan, create your own condition with 
debit interest of 0% for this purpose. 

• Interest calculation method 

You have the following options for determining the interest calculation method: 

− Under Loans → Calculation → Specify Interest Calculation Method [Ext.] , you can 
change the standard interest calculation method provided by SAP using the INTLO 
feature (HR Loans: Interest Calculation Method). In the process, you can specify an 
interest calculation method for your whole system, for certain loan types or certain loan 
conditions. The standard interest calculation method assumes there are 30 interest days 
in a month and 360 interest days in a year. 

We recommend this procedure. 

− You can specify the interest calculation method for a certain loan condition in the 
Conditions view, under Loans → Master Data → Maintain Loan Types.  If you specify an 
interest calculation method here, you thus override the interest calculation method that 
you may have entered in the INTLO feature. 

• Reference interest rate 

You have the following options for determining the reference interest rate: 

− You can use the REFIN payroll constant (Reference interest rate) in table T511K (Payroll 
Constants) to store the reference interest rate for your whole system, under Loans → 
Calculation → Check Payroll Constants [Ext.]. 

We recommend this procedure. 

− You can specify the reference interest rate for a certain loan condition in the Conditions 
view, under Loans → Master Data → Maintain Loan Types.  If you specify a reference 
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interest rate here, you thus override the reference interest rate that you may have 
specified with the REFIN payroll constant. 

 
If you specify the interest calculation method and the reference interest rate with the 
INTLO feature and the REFIN constant, you may possibly want to prevent entries 
being made in the step Maintain Loan Types. That is why, you can hide these fields 
from the Conditions view. To do so, choose Loans → Master Data → Adjust Screen 
Control [Ext.] in Payroll Customizing. 

Scope of Function 
The date that you choose for the interest calculation of loans depends on the 
payment date of your payroll areas. The payment date can, for example, be at 
the beginning or end of the payroll period. Interest should also be calculated 
accordingly for an employee’s loan; that is, at the beginning or end of the payroll 
period. 
If you pay an employee’s loan with the payroll run, the time of interest calculation 
has the following effects: 
• If interest is calculated at the start of the period, interest is due in the payroll period in which 

you create the loan. The number of days for which interest is calculated depends on the 
calculation method that you choose for your system. In the standard system, interest is 
calculated for 30 days for each month. 

• If interest is calculated at the end of the period, no interest incurs for the payment amount in 
this payroll period. 

This case has already been created in the standard system. 

Interest calculation for external payments, such as payments by check or bank 
transfer is for the exact day. Within the current payroll period, interest is 
calculated for only the days on which it actually accrues. 
During the payroll run, the system calculates the interest for each payroll period 
and includes it, when due, as a deduction in accordance with the loan conditions. 

Activities 
If you create a loan in the Loans infotype (0045), choose a loans condition on the 
Conditions tab page. With that, you specify the rate of interest and calculation 
frequency for this loan. The conditions that you can select here depend on the 
loan type. You can specify an interest rate in the Individual interest rate field, 
which should apply for this employee.  

 
You can also hide the Individual interest rate field from the infotype interface. 

To display the conditions for a loan type in a detailed form, choose the  
function (conditions overview) on the Conditions tab page. 

April 2001  441 



Payroll United States (PY-US)  SAP AG 

Interest Calculation 

 

442  April 2001 



 SAP AG Payroll United States (PY-US) 

  Example: Interest Calculation 

Example: Interest Calculation 
Prerequisites 
In your enterprise, payroll takes place on a monthly basis. You have created a loan for an 
employee with the following data: 

Loan type Building loan with payment by installments 

Loan amount paid out 10,000 euro 

Loan payment January 10 of the current year 

Repayment start date May 01 of the current year 

Repayment installment 300 euro each month 

The following values are stored in Customizing for the loan type Building loan with repayment 
installment: 

Debit interest 5 % 

Interest calculation frequency First period: 03 

 Interval: 03 

Repayment frequency First period: 03 

 Interval: 03 

The interest for this loan is thus due in the months of March, June, September, and December. 

The repayment installment for the loan type Building loan with installment repayment is also due 
in the months of March, June, September and December. However, the employee must only pay 
the first repayment installment for the loan on hand in June, as you specified May 01 as the start 
of repayment date. June is the first month, in which a repayment installment is due for the 
repayment pattern for this loan type after the start of repayment date on May 01. 
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Interest Calculation 

/LOE

/LRP

Repayment

/LRP

/LLB /LLB /LLB /LLB /LLB /LLB /LLB /LLB /LLB

April
March

Feb.
Jan. July

June
May September

August

/LIM

/LIC

/LIM

/LIC

/LIM /LIM

/LIC

/LIM

/LIC

/LIM /LIM

/LIC

/LIM

/LIC

/LIM

 

/LID

Interest

/LID/LID

Interest is calculated for each payroll period and stored in the Interest for current period wage 
type (/LIM). If interest is not due in the previous payroll period, it is cumulated in the Cumulated 
interest wage type (/LIC) until the next due date. When the interest is due, the Cumulated interest 
wage type (/LIC) is converted to the Interest due wage type (/LID). 

In the example, the loan is paid out on January 10 of the current year. This means that only 21 
days of interest accrue in this month. For the first payroll period, interest of 10,000 x 0.05 x 21 / 
360 = 29.17 euro accrues (10,000 euro balance, 5% interest, 21 days interest, 360 days per 
year). 

For the remaining periods up to the first repayment, interest of 10,000 x 0.05 x 30 / 360 = 41.67 
euro accrues (10,000 euro balance, 5% interest, 30 days interest, 360 days per year). 

The interest per payroll period is cumulated and due at an interval of 3 periods. 

Wage Types 
The following loan wage types arise for the first six payroll periods: 

Period Wage type Wage type text 
 

Amount Explanation 

Period 01 /LIC Cumulated interest 29.17  

(January) /LIM Interest for current period  29.17 21 days 

 /LLB Loan balance 10,000  

 /LOE External loan payment  10,000  

Period 02 /LIC Cumulated interest 70.84  

(February) /LIM Interest for current period  41.67  

 /LLB Loan balance 10,000  
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Period 03 /LID Interest due 112.51  

(March) /LIM Interest for current period  41.67  

 /LLB Loan balance 10,000  

Period 04 /LIC Cumulated interest 41.67  

(April) /LIM Interest for current period  41.67  

 /LLB Loan balance 10,000  

Period 05 /LIC Cumulated interest 84.34  

(May) /LIM Interest for current period  41.67  

 /LLB Loan balance 10,000  

Period 06 /LID Interest due 125.01  

(June) /LIM Interest for current period  41.67  

 /LLB Loan balance 9,700  

 /LRP Regular repayment 300  
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Calculating Imputed Income 
Use 
The interest saving for a loan, which results from a particularly reasonable interest rate, can be 
remuneration in the form of imputed income. The SAP system automatically calculates the 
imputed income (or interest rate advantage), that an employee incurs from a loan. This is the 
result of the difference between the debit interest and the reference interest rate, as the debit 
interest awarded by the employer is often significantly less than the usual reference interest rate 
awarded by the bank. 

To find out the statutory bases for inputed income, see the employment tax guidelines. 

Prerequisites 
The prerequisites are the same as those for interest calculation [Page 44 ]0 . You have also 
selected the Interest rate advantage field in the Conditions view in Payroll Customizing under 
Loans → Master Data → Create a Loan Type [Ext.] . 

Features 
Exemption Limit for Germany 
The exemption limit, which is currently 5,000 DM is automatically taken into consideration during 
payroll.  
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Example of an Imputed Income Calculation 
Prerequisites 
In your enterprise, payroll takes place on a monthly basis. You have created a loan for an 
employee with the following data: 
Loan type Building loan with payment by installments 
Loan amount paid out 10,000  
Loan payment January 10 of the current year 
Repayment start date May 01 of the current year 

Repayment installment 300 euro each month 

The following values are stored in Customizing for the loan type Building loan with repayment 
installment: 
Debit interest 5 % 
Reference interest rate 6 % 
Interest rate advantage Selected 

Interest calculation frequency First period: 03 

 Interval: 03 

Repayment frequency First period: 03 

 Interval: 03 

Calculating Imputed Income (Interest Rate Advantage) 

/LBM

/LBC

March JulyMay September
AprilFeb. June August

/LBC /LBC /LBC /LBC /LBC

/LBM /LBM /LBM /LBM /LBM/LBM /LBM /LBM

Jan.

 

Int. rate advantage

/LBD/LBD/LBD

For the first payroll period, imputed income of 10,000 x 0.01 x 21 / 360 = 5.83 incurs (10,000 
amount of loan, 1% interest rate advantage = 6% reference interest rate -- 5 % debit interest; for 
21 days of interest, 360 days per year). 

For the remaining payroll periods up to the first repayment, calculation is as follows: 10,000 x 
0.01 x 30 / 360 = 8.33. 

April 2001  447 



Payroll United States (PY-US)  SAP AG 

Example of an Imputed Income Calculation 

The interest for each payroll period is cumulated, and is due after 3 periods. 

Wage Types 
As well as the wage types listed in the Example: Interest Calculation [Page 443], the following 
wage types are created when calculating imputed income. 

Period Wage type Wage type text 
 

Amount Explanation 

Period 01 /LBC Cumulated interest advantage 5.83  
 /LBM Interest rate advantage/current period 5.83 21 days 

Period 02 /LBC Cumulated interest advantage 14.16  
 /LBM Interest rate advantage/current period 8.33  

Period 03 /LBD Taxed interest advantage 22.49 Due 
 /LBM Interest rate advantage/current period 8.33  
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Evaluating a Loan 
Use 
You can use various forms of evaluation to check loans, which have already been included in the 
payroll run. You usually call up the evaluation reports described in the following documentation in 
the General Report Selection for several employees. In the Loans infotype (0045), you can also 
partially evaluate individual employees. 

Scope of Function 
The following evaluations are possible: 

• Report RPCLOF00 (Account Statement for Company Loans) 

The account statement lists all transactions and current balances for the employee's 
company loans. You can choose between the Debit Memo - Credit Memo or Transaction 
- Balance formats. 

• Report RPCLOF00 (Account Statement for Company Loans) 

The overview lists the total of all loans for each employee. The evaluation displays the 
results from the perspective of the evaluation period. In other words, it includes all of the 
changes made during the evaluation period, for example, even if they affect periods prior 
to the evaluation period because of retroactive accounting runs. 

Report RPCLOH00 (Calculate Present Value for Company Loans) • 

The overview lists the present values [Ext.] of the company loans. 

Activities 
To evaluate several employees, choose Information systems → General report selection → 
Human resources → Payroll → Payroll <Country> → (Company) Loans and call up the report 
you require. Enter the necessary data and execute the report. 

To display an account statement or an overview of loans for an individual employee, choose 
Goto → Account statement or Goto → Loans overview in the Loans infotype (0045). 
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Loan Wage Types 
In Payroll, loan wage types start with /Lnn: In most of the countries that use the Loans 
component, the following wage types are used: 

 

Wage type Wage type text 
 

/LBC Cumulated interest advantage 

/LBD Taxed interest advantage 

/LBM Interest rate advantage/current period 

/LCI Interest-bearing capital 

/LEE Special repayment, external 

/LEP Special payroll repayment  

/LER Loan remission 

/LEX Complete repayment 

/LFC Cumulated interest exemption  

/LFM Interest exemption/current period 

/LFP Loan fees  

/LIC Cumulated interest 

/LID Interest due 

/LIM Interest for current period 

/LLB Loan balance 

/LO3 Third-party loan payment  

/LOE External loan payment  

/LOP Loan payment - payroll 

/LRP Regular repayment (both installment and annuity loans) 

/LTE Transfer loan balance 

Additional country-specific loan wage types are also used in some countries. 
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Arrears Processing for Deductions 
Use 
Arrears processing refers to the Voluntary Deductions [Ext.] that are deducted from the net 
remuneration. You enter these voluntary deductions using deduction wage types in the Recurring 
Payments/Deductions [Page 215] (0014) and Additional Payments [Page 217] (0015) infotypes, 
and in country specific infotypes for employer benefits. The system compares the deduction 
amount with the remaining net amount and, if possible, makes the deduction. When making this 
comparison the system takes a calculated country-specific minimum net amount into account.  

Arrears processing is responsible for determining how payroll is performed if the deductions 
exceed the net remuneration. 

 
Your employee takes part in a savings plan which means that a fixed amount is 
withheld from the net remuneration in each payroll period.  

Moreover, regular amounts are deducted from the net remuneration and are paid to 
different institutions or towards company insurance. 

If the sum of all the deductions is greater than the net amount , then all the 
deductions that were entered in the master data cannot be made during the payroll 
process.  

Unpaid absences, for example, can lead to unexpectedly low net remuneration. If all 
deductions are taken in full, the difference between total net remuneration and the 
sum of all deductions becomes an outstanding debt owed to the employee. 

Integration 
You make the settings for arrears processing in Customizing for Payroll under Deductions → 
Arrears and Priorities.  

Features 
Arrears processing is controlled using deduction wage type characteristics. You assign the 
following characteristics to deduction wage types for arrears processing: 

• Priority 
The priority specifies the sequence in which the deduction wage types are processed. If 
deduction wage types exist with the same priority in payroll, then the system sorts them 
according to name. 

 
If you use the Garnishment component, you should assign the garnishment wage 
type with the highest priority. 

Arrears-characteristics • 

You must also specify in Customizing the way in which deduction wage types should be 
processed if the net amount does not provide sufficient cover. The possibilities available 
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for arrears characteristics are described in detail in Customizing for Payroll under 
Deductions →Arrears and Priorities→Define Priority for Deduction [Ext.] 
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Technical Procedure of Arrears Processing 
Purpose 
For more information on the purpose of this process, see Arrears Processing for Deductions 
[Page 451]. 

Process Flow 
Arrears Processing 

IT 0014IT 0014

ARRRS
Pre-period

      Import deductions from 
infotypes to IT

Import deductions from
infotypes to IT

Import deductions from 
        ARRRS from previous period to IT

Import deductions from 
ARRRS from previous period to IT

Reduce deductions in IT 
by amount in DDNTK 

Tax,
Net amount

Tax,
Net amount

     Compare deductions 
with net amount

Compare deductions 
with net amount

Net is sufficient 
for everything

Net is not 
suficient

      Net is sufficient 
  for everything

Net is not
sufficient

Difference in DDNTK
and ARRRS

Further differences 
in DDNTK and ARRRS

Adjust
DDNTK

IT 0015IT 0015

--

--

DDNTK

DDNTK

ARRRS DDNTK ARRRS

ARRRS

RT

...

PRARTPRART

PRDNTPRDNT

PRPRIPRPRI

PRENDPREND

PRPRIPRPRI

PRDNTPRDNT

PRARTPRART

PRENDPREND

 
Legend: 
Tables 

• ARRRS Arrears table 

This contains the amounts of the deductions, which could not be processed in the 
previous period. These amounts are added to the amounts of the deduction wage types 
for the current period and are included in the current processing. Deduction wage types 
which cannot be processed in the current period and which are allocated with 
corresponding arrears characteristics are placed in the ARRRS table to be processed in 
the next period.  

• DDNTK Deductions not taken  

Contains amounts of deductions that could not be taken from the net amount in the 
current period.  

Functions 
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PRART Processing of Table OARRS 

PRART Processing of Table DDNTK 

PRPRI Processing of priorities table 

PREND Modify table DDNTK at end of loop 

For more information on the functions use transaction PDSY HR Documentation Maintenance or 
go to the menu for Payroll using the menu path Tools→ Maintenance Tools→Function/Operation. 

 

The steps in the graphic are performed in the following way: 

1. Import of the deductions 

The following deduction wage types are imported to the input table (IT) for further 
processing: 

− Amounts from the ARRRS table from the previous period with function PRART 

Using personnel calculation rule X014 you can determine whether a deduction wage 
type, which was not processed in the previous period, should be processed during 
the current period. 

− Current amounts from the Additional Payments (0015) and Recurring 
Payments/Deductions (0014) infotypes.  

2. Processing of table DDNTK: Deductions not taken  

This processing step does not take place the first time the loop is run because the table 
is empty. 

The amounts of the deduction wage types in the input table (IT) are reduced by the 
amounts of table DDNTK in function PRDNT. Further processing, such as tax 
calculations, is based on these reduced deductions. 

3. Processing deductions according to priority 

Once the net amount has been calculated, the system processes all of the deduction 
wage types in accordance with their priority and their arrears characteristics. The system 
checks, using function PRPRI, whether the remaining net amount is sufficient for the 
deduction, for every deduction wage type involved. 

− If the net amount is sufficient, the deduction is not changed. 

− If the net amount were not sufficient, the deduction would result in a negative net 
amount. Therefore, the amount of the deduction wage type must be reduced by the 
appropriate difference. This difference is stored in table DDNTK. The amount is also 
added to the ARRRS table according to the arrears characteristic. 

After the deductions have been processed the system checks whether deduction wage 
types need to be reduced, that is, whether table DDNTK is full. 

 
Processing of steps 1 to 3 takes place in a loop, which is performed several times if 
the deduction wage types have to be reduced. 
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Since certain deductions can be made from the remuneration before taxation, and 
since the gross tax amount can change, processing must therefore take place in a 
loop. For more information see Processing Reduced Gross Tax Amounts [Page 456]. 

4. Adjusting table DDNTK 

After the last loop has been run, table DDNTK can contain amounts that must be 
deducted from the deductions for the current period. However, it can also contain 
amounts from the ARRRS table. Table DDNTK should, however, only contain the 
amounts which could not be taken into consideration in the current period. This is 
implemented using function PREND.  

 
 

ARRRS (Start of processing) 80,00 Deductions from the previous period 

IT 0014 30,00 Deductions from the current period 

 110,00 Total deductions 

RT 60,00 Amount that could be deducted from the net amount 

ARRRS 

(End of processing) 

50,00 Amount that could not be deducted from the net 
amount and which is transferred 

DDNTK 50,00 Amount that could not be deducted from the net 
amount in the current period 

Table DDNTK should in fact only contain the amount 30,00 from the Recurring 
Payments and Deductions Infotype (0014) 

Using function PREND the system compares the values of the deduction wage types 
in table DDNTK with the values in the RT and ARRRS tables. In this way the amount 
of the current deduction is determined and is written to table DDNTK. 

 
Tables DDNTK and ARRRS are stored along with the payroll results in cluster table 
PCL2, and can be displayed using report RPCLSTRX. 
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Processing Reduced Gross Tax Amounts 
Use 
If the deductions do not affect an employees gross tax amount then processing can take place as 
described in Technical Procedure of Arrears Processing [Page 453]  

Exceptions are deductions which are made from the net salary amount, but which still reduce the 
gross tax amount. This is the case with donations or company insurance, for example. The 
processing class that you use for this determines whether a wage type should be deducted from 
remuneration before or after taxation. 

Features 
If such a wage type results in a deduction, and part of the amount is placed in table DDNTK, then 
the system recalculates the gross tax amount. Previously the deduction that was not reduced 
was used to calculate the gross tax amount. Calculation of the gross tax amount using the new 
reduced deduction amount results in a higher gross tax amount.  

The result of the higher gross tax amount, using the new tax calculation, is a changed net 
amount. The deductions are then made from this net amount. 

 
Payment/deduction type Calculation 1 Calculation 2

Total gross amount 3 000,00 3 000,00 

Donations, deduction from remuneration before taxation    500,00 300,00 

Gross tax amount 2 500,00 2 700,00 

Net amount 1 500,00 1 650,00 

Garnishment. 1 000,00 1 000,00 

Loans    200,00    200,00 

Actual deduction for donation    300,00 
Remaining amount 

   300,00 

 

DDNTK     200,00 …– 

Payment Amount     150,00 

Calculation 1 
The total gross amount is reduced by the amount of the donation to the gross tax amount, from 
which the net amount is then calculated. The amounts for the garnishment and the repayment of 
loans are deducted from the net amount first, because they have a higher priority than the 
donation. Only 300,00 of the net amount remain for the deduction of donations. Since the 
donations amount to 500,00, the 200,00 which cannot be deducted is placed in table DDNTK. 

Calculation 2 
The gross tax amount must be redefined starting with reduced donation amounts. The loop must 
therefore be repeated again to process the new gross tax amount and the new donation amount. 

456  April 2001 



 SAP AG Payroll United States (PY-US) 

  Processing Reduced Gross Tax Amounts 

 

April 2001  457 



Payroll United States (PY-US)  SAP AG 

Processing Arrears in Retroactive Accounting 

Processing Arrears in Retroactive Accounting 
Use 
When the original payroll is run for a payroll period, deduction wage types are subtracted and 
paid. This procedure cannot be reversed. If you have to trigger retroactive accounting in this 
payroll period after you have changed a deductions wage type, then the deduction wage type is 
processed specially.  

Features 
The changed amount of the deduction wage type cannot be taken into consideration by the 
system. In retroactive accounting the amount of the deductions wage type that was processed in 
the original run is processed again. 

Of course, a positive or negative difference can exist between the deduction amount in the 
original system and the changed deduction amount. This difference can be written to the next 
payroll period using the Arrears table (ARRRS). 

In Customizing for Payroll under Deductions→Arrears and Priorities→Maintain Arrears 
Deductions for Retroactive Accounting [Ext.] you determine how changed deduction wage types 
should be processed in retroactive accounting.  

 
In retroactive accounting arrears are processed in a different way to that of an 
original period. Processing in retroactive accounting takes place in function PRDNT, 
namely before the tax calculation. The loop must therefore be performed again, there 
is no iteration. Processing in functions PRPRI and PREND does not take place 
either.  
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National Bond and Trust Data Transfers 
Purpose 
The National Bond and Trust Data Transfer functionality provides customers the flexiblity to offer 
employees the option to purchase US Savings Bonds through payroll deductions. SAP has 
chosen the the National Bond and Trust Company (NBT) to provide the US Bond administration 
services. In addition to purchasing US savings bonds, NBT provides other bond-related 
administrative services including:  distribution, registration, owner and co-owner tracking, 
beneficiary, and all other bond servicing requirements. 

Process Flow 
1. The first step is to enroll interested employees in the savings bond purchase program.  

2. Then, after you have run payroll you export the savings bond deduction data to an 
intermediate file using the Interface Toolbox.   

3. You then create the final file for NBT using the Layout Conversion function in the Interface 
Toolbox.  

4. Finally you download a file containing the savings bond deduction data, and a report file 
which summarizes the contents of the savings bond deduction data file.  

5. Your company then remits the the data and report files and savings deduction funds to the 
NBT. 
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Enrolling Employees in the Bond Purchase Program 
Procedure 
1. Choose Human resources → Personnel management → Administration → HR master data 

→ Maintain. 

2. Enter the personnel number. 

3. Specify Recurring Payments and Deductions (Infotype 0014) in the Infotype field.  

4. Specify D100 (Bond Purchase Deduction) in the STy field. 

5.  Choose . 

6. Specify when the deduction should begin, the amount and frequency of the deduction, and 
the reason for change, if applicable. 

7. Save your entries. 

Result 
The specified employee is enrolled in the saving bond purchase program. 
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Exporting Bond Data to an Intermediate File 
Prerequisities 
You have enrolled the employee in the bond purchase program and run payroll. 

Procedure 
1. Choose Human resources → Payroll accounting → America → USA and then Tools → 

Interface toolbox. 

The Interface Toolbox screen appears. 

2. In the Export and Import section, choose Export. 

The Export pop up appears. 

3. Enter NBT1 in the Export for interface format field and choose Export. 

The Export selection screen appears. 

4. Specify the appropriate selection criteria, including the name of the export file 

 
Make note of this file name. You will need it when you create the final file in NBT-
compatible format. 

5. Choose Execute. 

Result 
The savings bond deduction data for the payroll period specified is exported to intermediate file 
and can now be converted to a file with a National Bond and Trust (NBT)-compatible format. 
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Creating Files for Submission to the National Bond and 
Trust (NBT) 
Procedure 
5. Choose Human resources → Payroll accounting → America → USA → Tools → Outsourcing 

- Interface Toolbox → Interface Toolbox. 

The Interface Toolbox screen appears. 

6. Choose the  Export tab. 

3. Select Conversion with file layout and specify NBT3. 

4.  Choose  Execute. 

The File Layout - NBT3 screen appears. 

5. In the Import file field, enter file name you defined when you exported the bond data to an 
intermediate file (See Exporting Bond Data to an Intermediate File [Page 461]). 

6. Assign a name to the Export file and make a note of it. 

 
SAP recommends that you use one file name per payroll area. 

7. In the Options section, select Append file to attach this file to a previously created NBT file 
(i.e. a file with data from another payroll area or pay period, or both). 

8. Choose .  

Result 
Your intermediate savings bond deductions file is copied to a file with NBT-compatible format and 
can be downloaded to your PC. 
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Downloading Files and Summary Report for the National 
Bond and Trust  
Prerequisites 
You have exported bond data to intermediate file and created the files in the proper format for 
submission to the National Bond and Trust (NBT).  

Procedure 
1. Choose Human resources → Payroll accounting → America → USA and then Tools → 

Outsourcing - Interface Toolbox →  Interface Toolbox. 

2. Choose the  Export tab. 

3. Select Download from TemSe. 

4. In the TemSe object field, enter the name of the export file you created when you created 
files for submission to NBT (see Creating Files for Submission to the NBT [Page 462]). 

5. Specify a file name of your choice in the File name field.  

6. Choose  Execute. 

7. To download the bond deductions summary report, repeat Steps 1-6, and use file nbt.rpt as 
the TemSe file in Step 3. 

Result 
The NBT savings bond deduction data file and summary report are downloaded to PC and can 
be submitted to NBT. 
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Prepaid Deductions 
Purpose 
When employees go on leave, their available income and therefore their net payments within a 
pay period may not be great enough to cover specific deductions (for example, health insurance 
deductions). In the SAP system, you can set up your system to handle these recurring 
deductions in different ways. You can have them accumulate within arrears, be covered by an 
advance from the company, or, using Prepaid Deductions functionality, enable employees to give 
you checks to prepay one or several of their deductions while they are on leave. This is 
advantageous for the employee because it reduces the amount of deductions in arrears the 
employee has to repay when he returns to work. 

Prerequisites 
You have defined which deductions can be prepaid in your company and configured the prepaid 
deduction wage types accordingly in the Payroll IMG under Deductions -> Prepaid Deductions.  

Process Flow 
Prepaid Deduction Processing 
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Employee goes
on leave 

Prepay
deductions? 

Employee turns in
Cheques and selects

which deductions
to prepay 

NO YES

Run payroll
and take

deductions 

Run payroll
and take

deductions 

Enough pay to
cover deductions?  

NO

Place deficit
amount in

arrears 

NO

Take deduction
from pay

YES

Take deduction
from pay

YES

Prepaid balance enough
to cover deductions?

Take deduction
from prepaid

balance

YES

Place deficit
amount in

arrears

NO

Enough pay to
cover deductions? 

 
1. An employee goes on leave, and decides whether he wants to prepay some of his 

deductions that will be due during his leave. 

2. If he decides to prepay deductions, he gives the company one or several checks and informs 
them which of the deductions available for prepayment in the company he wants to prepay. 

3. The amount received from the employee is placed in a prepayment deduction 'bank' (or 
balance) for the employee. 

4. When payroll is run, the payroll driver first tries to take the deduction from the employee's 
regular pay.  

If there is not a sufficient amount to cover the deduction, it will determine whether the 
employee has a prepayment balance for deductions. If not, it will put the amount into 
arrears. If the employee does have a prepayment balance, it tries to take the deduction 
from that money.  
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If there are not enough funds in the prepayment balance to cover a specific 
deduction in full, the system checks the configuration of the deduction wage type to 
determine its arrears processing indicator, and will either take part of the deduction 
or put the entire deduction amount in arrears. For example, if the deduction wage 
type's arrears indicator is "All or nothing, write to arrears table", the entire deduction 
amount for the period is placed in arrears. 

5. The employee returns to work and normal processing resumes.  

If the employee has a positive balance in his prepayment deduction 'bank', the company 
reimburses the employee the balance. 

If the employee has deductions in arrears, these are taken from the employee's pay the 
next time (or several times) payroll is run.   

Result 
If the employee opted to prepay deductions, the amount in arrears that has to be taken when the 
employee returns to work is significantly lower than if the employee had not opted to prepay 
deductions. 
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Prepaid Deduction Processing and Retrocalculation 
Purpose 
Retrocalculation affects prepaid deductions in different ways depending on whether you change 
the deduction amount or the prepaid deduction balance retroactively. 

Prerequisites 
You have configured the Prepaid Deduction wage types in the Payroll IMG under Deductions → 
Prepaid Deductions. 

Process Flow 
The following two examples show how retrocalculation affects prepaid deduction processing. 

Period 10
in period 10

Period 11
in period 11

Period 12
in period 12

($300) ($200) ($100)

diff. $20 
arrears $20
($300)

diff. $20
arrears $40
($200)

diff. $20
arrears $60
($100)

Period 10
in period 13

Period 11
in period 13

Period 12
in period 13

Period 13
in period 13

arrears $8
($0)

Medical deduction of $100
per period.
Employee prepaid deduction
balance after deduction is taken
is shown in parentheses:

Medical deduction increased in
Period 13 to $120 per period
back to Period 10. Differences are
placed in arrears.
Results after retrocalculation:

Retroactive deduction increase with prepaid deduction processing

 

$100 $100 $100

$100 $100 $100 $120

0 

 

1. The specific deduction amounts are changed retroactively and retrocalculation is carried out. 

2. Deductions taken in the original periods are not changed retroactively.  

3. The difference between the original period amount and the retrocalculation amount for the 
period is placed into arrears. 

4. When the payroll driver gets to the current period, it first checks whether the prepaid 
deduction balance is sufficient to cover the specific deduction in that period. 

If yes, it takes the deduction and determines whether there are sufficient funds to cover 
some or all of the arrears built up during the retrocalculation.  

If no, it either takes the remaining balance amount and puts the rest into arrears or puts 
the entire amount into arrears if the deduction wage type is flagged with the "take all or 
take nothing" arrears indicator. 
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Period 10
in period 10

Period 11
in period 11

Period 12
in period 12

($300) ($200) ($100)

($300) ($200)
$50

($100)
-$150

Period 10
in period 13

Period 11
in period 13

Period 12
in period 13

Period 13
in period 13

arrears $100

-$150

Medical deduction of $100
per period.
Employee prepaid deduction
balance after deduction is taken
is shown in parentheses:

In Period 13, the employee’s
prepaid deduction balance is
corrected to $150 ($50 after 
deduction is taken) for Period 11.

Adjusted prepaid deduction
balance shown in blue.
Results after retrocalculation:

Reimbursement of $150 triggered to cover
the negative deduction balance; claim of $150
created. The $100 deduction from Period 13 is
placed into arrears.

Retroactive decrease of a prepaid deduction balance

$100 $100 $100

$100 $100 $100 $100

 
 

1. A prepaid deduction payment for an employee is changed retroactively. For example, if the 
payment amount was entered incorrectly. 

3. Retrocalculation is carried out. 

Since the specific deductions taken within a pay period are not changed during 
retrocalculation, the prepaid deduction deductions are not changed during 
retrocalculation either.  

4. If the prepaid deduction balance is no longer sufficient to cover the prepaid deduction 
deductions taken in prior periods, the prepaid deduction balance becomes negative.  

5. When the payroll driver gets to the current period, it triggers a reimbursement of the negative 
prepaid deduction balance (without triggering a reimbursement wage type) and places the 
regular deduction from the current period into arrears.  

When retrocalculation is carried out and the prepaid deduction balance is not sufficient to cover 
the deductions in prior periods, the system either  

• Places the deduction amounts into arrears  

• Places the deduction amount for the current period into arrears and creates a claim for the 
negative prepaid deduction reimbursement 

2. This, in turn, changes the employee's prepaid deduction balance. 

6. The reimbursement is added to net payments and deductions and a claim is created for the 
amount. 

Result 
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Entering a Prepaid Deduction Payment 
Use 
Using Prepaid Deduction functionality, employees who are going on leave can choose to 
voluntarily prepay recurring deductions that will become due while they are on leave. These 
prepayments create the employee's 'prepaid deduction balance', which is used to cover 
deductions during their absence.  

Prerequisites 
You have configured your prepaid deduction wage types in the Payroll IMG under Deductions  → 
Prepaid Deductions. 

1. From the main Personnel management menu, choose Administration → HR master data → 
Maintain. 

The Maintain HR Master Data screen appears. 

2. Specify the employee for which you are entering the payment, select Infotype 0014 (Recur. 
Payments/Deds.) and choose Create. 

The Create Recur. Payments/Deds. screen appears. 

 
The wage type you specify determines the prepayment deduction balance for which 
you are entering the payment. 

4. Save the record. 

 

Result 
The payment is placed in the employee's prepaid deduction balance to cover deductions when 
the employee's regular pay is not sufficient to cover the deduction.  

Procedure 

3. Enter the amount of the payment and any other necessary information. 

You can also enter the prepaid deduction payment on Infotype 0015 Additional 
Payments. 
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Reimbursing an Employee's Prepaid Deduction Balance 
Use 
Using Prepaid Deduction functionality, employees who are going on leave can choose to 
voluntarily prepay recurring deductions that will become due while they are on leave. These 
prepayments create the employee's 'prepaid deduction balance' used to cover deductions during 
their absence. When the employee returns to work, any remaining money in the prepaid 
deduction balance needs to be reimbursed to the employee. 

You have configured your prepaid deduction wage types in the Payroll IMG under Deductions  → 
Prepaid Deductions. 

Procedure 
5. From the main Personnel management menu, choose Administration → HR master data → 

Maintain. 

The Maintain HR Master Data screen appears. 

The Create Recur. Payments/Deds. screen appears. 

7. Enter the amount of the reimbursement and any other necessary information. 

 
The wage type you specify determines the prepayment deduction balance which you 
are reimbursing. 

Prerequisites 

6. Specify the employee for which you are reimbursing the balance, select Infotype 0014 
(Recur. Payments/Deds.) and choose Create. 

8. Save the record. 

 
You can also enter the prepaid deduction reimbursements on Infotype 0015 
Additional Payments. 

Result 
The employee is reimbursed their prepaid deduction balance. 
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Final Payroll Processing (PY-US-FP) 
Purpose 
After completion of Net Payroll calculation, the SAP system offers a wide variety of post-
processing activities, which are included in the Final Payroll Processing component.  

Integration 
This component allows you to post payroll results directly to General Ledger and Controlling 
accounts in other modules of the SAP system. It also allows you to create electronic media for 
making direct deposits at employee banks. The Final Payroll Processing component is therefore 
highly integrated with SAP Financial Accounting. 

Features 
Final Payroll processing contains the following features: 

• Direct deposit of employee pay 

• Third party remittances 

• Earnings statements 

• Posting to Financial Accounting/Controlling including month-end accruals 
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Wage and Salary Payments 
Purpose 
This component enables you to pay wages and salaries to employees, while taking into 
consideration country and bank-specific requirements and specifications. Moreover, you can 
make certain employee-specific payments to third parties (dependent on the country version), 
whereby the employee is not the payment recipient. The system offers different variants of wage 
and salary payments, which are used in various combinations by the individual country versions. 

You can find technical information on wage and salary payments and notes on the necessary 
Customizing settings in the following sections: 

Payment-Related Information in the Master Data [Page 475]•   

Payment-Related Information in the Payroll Result [Page 47 ]6   • 

Preliminary Program for Data Medium Exchange [Page 47 ]8  • 

You can find information on the posting of payment transactions in the documentation for Posting 
to Accounting, under Integration with the Posting of Payment Transactions [Page 540]. 

Scope of Function 
You can find information on wage and salary payments in the following sections. 
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Payment-Related Information in the Master Data 
Certain information from the master data for your employees reappears in the 
Payroll results. The Wage and Salary Payments evaluates this 

, but also accesses certain infotypes directly. 
Information in the Payroll 

Results [Page 476]

Below is a list of the international infotypes that contain payment-related 
information.  

Organizational Assignment (Infotype 0001) [Ext.] • 

Personal Data (Infotype 0002) [Ext.] • 

Addresses (Infotype 0006) [Ext.] • 

Bank Details (Infotype 0009) [Ext.] • 

•  External Bank Transfers (Infotype 0011) [Ext.]

 
In addition to the infotypes mentioned above, there are other international wage 
types (e.g. for capital formation) that contain payment-related information. These 
infotypes will not be discussed here. For more information on international infotypes, 
see the SAP Library under Human Resources → Payroll → <Country>. 

For more information on how the system evaluates the payment-related 
information in the master data and the payroll results, see 

. 
 

Preliminary Program DME 
[Page 478]
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Payment-Related Information in the Payroll Results 
The following tables in the payroll results contain payment-related information 
that the system evaluates during the wage and salary payments process. 

Payment Information table (BT) 

The origin and treatment of employee-specific payments to third parties is 
country-specific. If, for example, salary elements for an employee are garnished 
or are retained for capital formation, an entry is created in the Payment Information 
table (BT) in the employee's payroll results, for payment of the retained amount 
to a third party (e.g. the creditor or the capital formation institute). The origin of 
this entry depends on the county version used, and the settings in Customizing. 
However, employee-specific payments to third parties do not necessarily create 
an entry in the Payment Information table (BT) for the employee. The reason for 
this is that in certain country versions these payments are made independent of 
the Wage and Salary Payments component. 

Entries in the Payment Information Table (BT) for Payments to the Employee 

• The Payment Method field is always filled. 

• Payment Information (BT) 

Every entry in the Payment Information table (BT) in an employee's payroll results 
corresponds to a payment that was created in a payroll period for this employee. 
However, the employee is not necessarily the payment recipient of all 
payments. A difference must be made, for entries in the Payment Information table 
(BT), between payments to the employee and employee-specific payments to 
third parties. 

• The Bank Number and Bank Account fields are filled, if the payment method requires bank 
details. 

• Work Center/Basic Pay (WPBP) 

• The Recipient, Postal Code and Location fields are filled, if you have manually overwritten 
the corresonding fields in the . If you have not manually 
overwritten these fields in the Bank Details infotype (0009), the values from the Personal 
Data (0002) [Ext.] and  infotypes are displayed there. In this case, the 
Recipient, Postal Code and Location fields are not filled in the Payment Information table 
(BT). 

Bank Details infotype (0009) [Ext.]

Entries in the Payment Information Table (BT) for Employee-Specific Payments to Third 
Parties 

• The entry in the Payment Information table (BT) for an employee-specific payment to a third 
party either contains detailed information from the infotype that forms the basis of the 
payment (Payment Method, Bank Details, Name and Addresses), or a recipient key in the 
Recipient field. This recipient key refers to Customizing for Personnel Management, where 
you must store the detailed information mentioned. 

Addresses (0006) [Ext.]
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• The Purpose field in the Payment Information table (BT) is filled, if a purpose was entered in 
the infotype that forms the basis of the payment. 

 
Note that not all the fields in the Payment Information table (BT) are discussed here. 
For more information on how the system determines the information on the payment 
recipient, see Preliminary Program DME [Page 478], in the "Scope of Function" 
section. 

Certain organizational elements from the Organizational Assignment infotype (0001) 
are stored in the Work Center/Basic Pay table (WPBP) during payroll. These 
organizational elements are used in the wage and salary payments process 
(dependent on Customizing) to determine the house bank and the house bank 
account. 

Work Center/Basic Pay Table (WPBP) 

WPBP Split [Ext.]

Furthermore, the system uses the Work Center/Basic Pay table (WPBP) to 
determine the paying company code. Specification of the paying company code 
is optional in Customizing. If you have not specified a paying company code in 
Customizing, the system uses the company code that is stored in the Work 
Center/Basic Pay table (WPBP) in the employee's payroll results. If the Work 
Center/Basic Pay (WPBP) table for the employee contains several partial periods 
as the result of a , in the payroll period to be processed, the 
system uses the company code in the last partial period, in which the employee 
was active, to determine the paying company code. 
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Preliminary Program DME 

You use the preliminary program DME to evaluate the payroll results to create 
payment data. The creation of payment data is the first step in the wage and 
salary payments process. 

Use 

You can also use the preliminary program DME if you want to make several 
partial payments on different dates within a payroll period (

To start the preliminary program DME, choose Human Resources → Payroll → Payroll 
→ Bank Transfer → Pre. Program DME from the SAP Easy Access menu. 

Qualified Advance 
Payment [Page 90]). 
The preliminary program DME can evaluate payments using different payment 
methods [Ext.] in a payment run. The payment medium programs, which further 
process the data created by the preliminary program DME, select the relevant 
data records using the payment method. 
The preliminary program DME processes both 

 and  for an employee. 
information from the master data [Page 

]475 information from the payroll results [Page 476]

Integration 

 
You have exited payroll for the payroll periods for which you want to make wage 
and salary payments. (Exception: You make a 

The payment data created by the preliminary program DME is processed by the 
country-specific payment medium programs in Accounting to create payment 
mediums (for example, DME files for the bank, checks). You must start these 
subsequent programs after the preliminary program DME has evaluated the 
payroll results for the employee and has created the payment data. 

Prerequisites

Qualified Advance Payment [Page 90] 
before exiting payroll.) 

• Setting up the payment methods (in Customizing for Personnel Management under 
Personnel Administration → Personal Data → Bank Details →

You have checked or made the following settings in agreement with Accounting. 

 Define Payment Method 
[Ext.]) 

Setting up the house banks and house bank accounts (in Customizing for Payroll under 
Data Medium Exchange → Preliminary Programs for Data Medium Exchange → Set Up 
House Banks [Ext.]) 

• 

Defining the Sending Banks (using the Sender Account Number for Data Medium 
Exchange feature (DTAKT) in Customizing for Payroll under Data Medium Exchange → 
Preliminary Programs for Data Medium Exchange → ) 

• 

Define Sending Banks [Ext.]
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• Defining the paying company code if you do not want to use the company code stored in 
the Organizational Assignment (0001) infotype (using the Sender Account Number for Data 
Medium Exchange feature (DTAKT) in Customizing for Payroll under Data Medium 
Exchange → Preliminary Programs for Data Medium Exchange → Define Sending Banks 
[Ext.]). 

• Assigning the text key for the payment transaction to transfer wage types (in 
Customizing for Payroll under Data Medium Exchange → Preliminary Programs for Data 
Medium Exchange → Check Text Keys for Payment Transactions [Ext.]) 

This assignment is not necessary in all country versions. 

Scope of Function 
For every current original result for employees processed in a payment run, the 
preliminary program DME reads the Payment Information table (BT) in the payroll 
results. 
In the process, the system performs the following steps for every entry in this 
table: 
• The system determines the information on the payment recipient 

− from the entry in the Payment Information table (BT) 

− from the Payee Keys table (T521B), if the entry in the Payment Information table (BT) 
contains a recipient key 

− from the Personal Data (0002) and Addresses (0006) infotypes, if the entry in the 
Payment Information table (BT) does not contain a recipient key and does not contain 
any recipient data 

• The system evaluates the Sender Account Number for Data Medium Exchange feature 
(DTAKT) to determine the following information: 

− The paying company code 

− The house bank 

− The house bank account 

• The system reads the Purpose field in the Payment Information table (BT): 

− If the Purpose field is filled, the contents of the field are transferred to the payment data. 

− If the Purpose field is not filled, the following text is used: "Wage/Salary", <Personnel 
Number>, <Payroll Period> or "Pension", <Personnel Number>, <Payroll Period>. 

• The system determines the payment currency: 

− If the Currency field in the Payment Information table (BT) contains a currency, this 
currency is used for the payment. 

− If the Currency field in the Payment Information table (BT) does not contain a currency, 
the currency from the Currency field in the Payroll Status Information table (VERSC) is 
used for the payment. 

• The system reads the bank codes of the house banks and the recipient bank from the Bank 
Master Record table (BNKA). 
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• The system checks the payment data for consistency. If a payment with inconsistent data 
exists for an employee, the system does not make any payment for this employee. 

• For every entry in the Payment Information table (BT) the system creates an entry in the 
payment data. 

Selection 
The selection screen for the preliminary program DME is country-specific. The 
following describes only the most important international parameters.  
Set Flag for Transfers 

We recommend that you mark this indicator. It causes the system to mark every 
processed entry in the Payment Information table (BT) with date and time, to show 
payment runs carried out later that it is "processed". This prevents entries in the 
Payment Information table (BT) being accidently processed more than once. If the 
payroll run is repeated after you have executed the preliminary program DME, 
the system does not overwrite the entries marked with date and time but 
performs a difference calculation. That is why you must mark the Set Flag for 
Transfers indicator if you want to perform a qualified advance payment. 
Wage Type 

You can use these input fields to restrict a payment run to certain wage types, for 
example, to pay the wage types created for External bank Transfers (Infotype 0011) 
separately from the employee's salary. 
Test 

If you mark this indicator, the system only displays the payments to be made as 
the result for a payment run. It does not create any payment data and does not 
change any data in the payroll results. 

Output 
The preliminary program DME creates a payment run, which contains payment 
data.  You can clearly identify every payment run using the Program Run Date and 
Identification Feature combination. The Identification Feature originates from the six-
digit system time, at which you started the preliminary program DME. The 
system replaces the last digit of the six-digit system time in the Identification Feature 
with a P. 

 
You started the preliminary program DME at 09.25 on 04.14.2000. You can clearly 
identify the payment run created using the Program Run Date (04.14.2000) and 
Identification Feature (09251P) combination. 

The payment data contained in a payment run is saved in the following tables: 
• Control Records for the Payment Program (REGUV) 

• Settlement Data from Payment Program (REGUH) 
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Processed Items from Payment Program (REGUP) • 

The data in these tables is further processed by the payment medium programs 
in Accounting. For more information, see . Payments (FI-BL) [Ext.]

See also: 
Repeating a Payment Run [Page 482] 
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Repeating a Payment Run 
Use 
If a payment run was not carried out correctly (for example, because of a 
program termination), you have to repeat this payment run. 

Prerequisites 
When you created the payment run that you now want to repeat, you marked the 
Set Flag for Transfers indicator. 

Procedure 
1. Make the same settings on the Preliminary Program DME [Page 47 ]8  selection screen that 

you made when you created the original payment run. 

2. In the Repeat Run: Date and Time fields, enter the date and time for the payment run to be 
repeated. 

The system uses this entry to evaluate the entries in the Payment Information table (BT) 
which the preliminary program DME marked with data and time, but for which the date 
and time correspond to your entries in the Repeat Run: Date and Time fields. 

3. If you only want to evaluate entries in the Payment Information table (BT) which have already 
been marked, select the Flagged Records Only indicator. 

If you do not set this indicator, the system also evaluates the entries in the Payment 
Information table (BT) which are still not marked with date and time. 

4. Choose . 

 
If you do not know the date and time for the payment run to be repeated, proceed as 
follows: 

1. Use the  program (Report H99_DISPLAY_PAYRESULT) to 
display a payroll result (for any employee) that was evaluated during the original payment 
run. 

Display Payroll Results [Page 80]

2. Display the Payment Information table (BT). 

3. Select an entry from the Payment Information table (BT) which the preliminary program DME 
marked with date and time when creating the original payment run. 

4. Make a note of the values in the Date and Time fields so that you can enter them in the 
Repeat Run: Date and Time fields on the Preliminary Program DME selection screen. 
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Wage and Salary Payments by Check with Integrated 
Remuneration Statement 
Purpose 
The system uses this process to print the wage and salary checks for your employees. The 
system creates a remuneration statement for each employee and prints it on the check. 
Furthermore, you can print a payment summary which lists the individual payments. You can use 
the payment summary to, amongst other things, post the wage and salary payments manually to 
Financial Accounting. 

 Process Flow
1. The  evaluates the entries in the Payment Information 

table (BT) in the payroll results for the employees, and creates: 
preliminary program DME [Page 478]

− a payment run which contains the payment data 

− remuneration statements 

2. The International Payment Medium - Check (with check management) program (Report 
RFFOUS_C) 

a. evaluates the payment data 

b. imports the remuneration statements that belong to the checks 

c. prints checks with integrated remuneration statement 

d. prints the payment summary 

3. The system stores information on the checks created, in the . check management [Ext.]

The following graphic shows the process flow of wage and salary payments by check with 
integrated remuneration statement. 
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Payment
summary

Payment
medium
program

Check with
integrated
remuneration
statement

Remuneration
statement
for check

Payroll
result

Payment 
data

Pre. program
DME

Sample printout
Document/Date
12345 / 01/06/2000
Our accounting clerk
Jeffrey Stone
Telephone
494949-49
Fax
595959-59
Your account with us
4343434343

Check

Dear Sir or Madam,

we have settled the items listed below with the enclosed
check for payment 12345, subject to the goods and
services supplied and the invoice therefore being in
order.

                                                                                                                                                             

Document Your document            Date Deductions Gross amount
                                                                                                                                                             
12345 54321     01/06/2000 0.00 1.780,56
Sum total 0.00 1.780,56

Payment document Check number Date      Currency Payment amount
54321 98765 01/06/2000  USD 1.233,27

Bank number Account number Check number
1415161718 777888999 223344

Catherine Miller 1.233,27
34 Meadow Rd.
AL, 35762 01/06/2000

Catherine Miller
34 Meadow Rd.
AL, 35762

Check
management
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Evaluating Payroll Results 
Use 
The  can evaluate payments using different 

. For this reason, you only have to execute the Evaluate Payroll Results step 
once, if you use the following processes together: 

preliminary program DME [Page 478] payment 
methods [Ext.]

Wage and Salary Payment by Check with Integrated Remuneration Statement [Page 483] • 

•   Wage and Salary Payment by Bank Transfer with Payment Advice Printing [Page 489]

 
The data medium programs, which further process the data created by the 
preliminary program DME, select the corresponding records using the payment 
method. Therefore, you should not fill the Payment Method field on the Preliminary 
Program DME selection screen (in the Additional Data section). If you fill this field, 
some payments may not get processed in certain system constellations. 

Procedure 
1. Start the preliminary program DME [Page 478].  

2. Make the required entries for Payroll period, Selection and Wage types.  

3. Select the Set flag for transfers indicator (see 478 ). Preliminary Program DME [Page ]

4. Make the other entries necessary for creating the remuneration statement, and select . 

The system produces statistics on the personnel numbers evaluated and the entries in 
the Payment Information table (BT). 

5. Make a note of the program run date and the six-digit identification feature. You will have to 
enter these values at a later stage on the selection screen of the payment medium program, 
which you use for printing checks [Page 486]. 

Result 
The system evaluates the payroll results for the employees you selected, and saves the payment 
information as payment data and the remumeration statements to the database. 
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Printing Checks 
Procedure 
1. Start the International Payment Medium - Check (with check management) program (Report 

RFFOUS_C). 

2. Enter the program run date and the identification feature of the payment run to be processed. 

3. In the Print control section, select the Print checks and Print payment summary indicators. 

4. Enter the additional necessary data, and choose . 

Result 
The system evaluates the payment data for the payment run you entered, and 
creates checks with an integrated remuneration statement. Moreover, the system 
creates the payment summary for the checks that have been created, and stores 
the information on these checks in the . Check Management [Ext.]
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Zero-Net Checks 
Purpose 
If an employee does not get a salary payment in a payroll period, you can print 
the remuneration statement for this employee on a voided check (zero-net 
check). 

Prerequisites 

− 

In Payroll Customizing, you have checked the standard settings for zero-net 
checks under Direct Deposit/Data Medium Exchange and, if necessary, modified them 
to meet your requirements. 

Process Flow 
If there is no salary payment for an employee in a payroll period, the system 
performs the following process for creating zero-net checks: 
1. The system creates an entry in the Bank Transactions table (BT) in the payroll results for the 

employee, which contains wage type /559 Bank Transfer with the amount of zero. 

2. The system checks if there is a valid record of the Bank Details infotype (0009) for the 
employee at the time of payroll: 

− If there is a valid record of the Bank Details infotype (0009), the system writes the 
payment method that is stored in the Bank Details infotype (0009) to the entry created in 
the Bank Transaction (BT) table. 

If there is no valid record of the Bank Details infotype (0009), the system uses the Check 
payment method that is stored as a parameter in function P9ZNC in the payroll schema. 
The system checks if the Check and Allowed for personnel payments indicators are set 
for this payment method in Customizing of Accounting. If this is the case, the system 
writes the payment method to the entry created in the Bank Transaction (BT) table. If this 
is not the case, the system rejects the employee in payroll. 

3. The system processes the entry created in the Bank Transaction (BT) table during the 
process of 
483  and creates a cancelled check with an integrated remuneration statement for the 
employee. 

wage and salary payment by check with integrated remuneration statement [Page 
]

 
If you do not use the creation of zero-net checks (in other words function P9ZNC is 
not included in the payroll schema), the pre-program DME prints remuneration 
statements for employees without a salary payment. In such cases, you cannot use 
SAPscipt for the remuneration statements. 

The following graphic shows the creation of zero-net checks and 
. 

zero-net advices 
[Page 494]
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Zero-Net Checks 

Wage type /559 or
/558 in RT?

Employee gets payment amount
by check or bank transfer

(depending on the payment method in
infotype 0009)

Write wage type /559 with amount zero to BT

Write payment method from infotype
0009 to BT

Is the Customizing for
payment method from

function P9ZNC
o.k.?

yes no

yes no

Infotype 0009: Is there a valid
record?

Write Check payment method from
function P9ZNC to BT

Reject
employee

yes no

Print zero-net check (RFFOUS_C)

Print zero-net advice (RFFOAVIS) or zero-net check
(RFFOUS_C) (depending on payment method)
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Wage and Salary Payments by Bank Transfer with 
Payment Advice Printing 
Purpose 
The system uses this process to provide all the information your house bank needs to transfer 
the wage and salary payments to your employees. The system creates a DME file and the DME 
accompanying sheet, and creates a payment advice for every employee, on which the 
remuneration statement is printed. Furthermore, you can print a payment summary which lists 
the individual payments. You can use the payment summary to, amongst other things, post the 
wage and salary payments manually to Financial Accounting. 

Process Flow 
1. The  evaluates the entries in the Payment Information 

table (BT) in the payroll results for the employees, and creates: 
preliminary program DME [Page 478]

− a payment run which contains the payment data 

− remuneration statements 

The preliminary program DME prints the remuneration statements or transfers them to 
the payment medium program. This is dependent on the Payslip on Payment Advice 
Note indicator on the selection screen for the program. 

 
For employees who, in addition to the bank transfer, receive one or several payments by 
check, the preliminary program DME transfers the remuneration statement to the 
International Payment Medium - Check (with check management) program (Report 
RFFOUS_C). This is independent of the Payslip on Payment Advice Note indicator on 
the selection screen for the program. 

2. The  for the bank transfer evaluates the payment data. payment medium program [Ext.]

− It creates the DME file, the DME accompanying sheet and the payment summary. The 
DME file contains all bank transactions and is of the same format as the file used by the 
bank in your country. 

− It also prints the remuneration statements, if these were transferred by the preliminary 
program DME. 

3. You provide your house bank with the DME file created, so that the bank transfer can be 
made. 

The following graphic shows the process flow of wage and salary payments by bank transfer with 
payment advice printing. 
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DME
accomp.sheet

Payment summary

Payroll
result

Payment  
data

Pre.program
DME

Payment
medium
program

Disk

DME
Administration

Remuneration
statement

Sample printout
Document/Date
12345 / 01/06/2000
Our accounting clerk
Jeffrey Stone
Telephone
494949-49
Fax
595959-59
Your account with us
4343434343

Payment advice

Dear Sir or Madam,

we have settled the items listed below with the enclosed
check for payment 12345, subject to the goods and
services supplied and the invoice therefore being in
order.

                                                                                                                                                             

Document Your document            Date Deductions Gross amount
                                                                                                                                                             
12345 54321     01/06/2000 1.800 1.780,56
Sum total 1.800 1,780,56

Payment document Check number Date      Currency Payment amount
54321 98765 01/06/2000  USD 0,00

Catherine Miller
34 Meadow Rd.
AL, 35762

Payment
advice
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Prenotification 
Purpose 
This process is only available in the USA. If you want to pay an employee by 
bank transfer, you can check the employee's bank details before the first 
payment by making a test transfer with the amount zero. If you use the test 
transfer, the preliminary program DME checks, during the 

 process, if a test 
transfer was made to check the bank details. In the following situations it 
changes the bank transfer into a check payment: 

Wage and Salary 
Payments by Bank Transfer with Payment Advice Printing [Page 48 ]9

• You have still not created the DME file for the test transfer. 

• The test transfer revealed that the bank details are invalid.  

• The test transfer was made less than 10 days ago. 

Prerequisites 
You have stored the bank details for the bank transfer in the Bank Details infotype (0009) 
and, if necessary, in the External Bank Transfers (0011) infotype. 

• 

• You have set up the creation of short-term documents for the Bank Details (0009) and 
External Bank Transfers (0011) infotypes (in Customizing for Payroll under Payroll: USA → 
Electronic Funds Transfer (EFT) → Prenotification → ). Set up Prenotification [Ext.]

Process Flow 
1. You create, or change, the Bank Details (0009) or External Bank Transfers (0011) infotype 

for one or several employees. You enter bank details when doing this. 

The system creates (dependent on your Customizing settings) short-term documents for 
these infotypes. 

2. You start the Prenotification program (Report RPCDTEU0) at the appropriate time. 

The system reads the short-term documents for the specified time, and creates entries in 
the Prenotification: New Bank Data from Master Records table (PNBK) for the bank 
details that are to be tested. 

3. You start the Prenotification: Creation of the Prenotification File program(Report 
RFPNFC00). 

The system creates a prenotifications file in ACH format. 

4. You provide your house bank with the prenotifications file. 

5. Your house bank checks the bank details and reports any possible errors, so that the 
employee's master data can be corrected. 
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Evaluating Payroll Results 
Use 
The  can evaluate payments using different 

. For this reason, you only have to execute the Evaluate Payroll Results step 
once, if you use the following processes together: 

preliminary program DME [Page 478] payment 
methods [Ext.]

Wage and Salary Payments by Check with Integrated Remuneration Statement [Page 483] • 

•   Wage and Salary Payments by Bank Transfer with Payment Advice Printing [Page 489]

 
The data medium programs, which further process the data created by the 
preliminary program DME, select the corresponding records using the payment 
method. Therefore, you should not fill the Payment Method field on the Preliminary 
Program DME selection screen (in the Additional Data section). If you fill this field, 
some payments may not be processed in certain system constellations. 

Procedure 
1. Start the preliminary program DME [Page 478].  

2. Make the required entries for Payroll period, Selection and Wage types.  

3. Select the Set flag for transfers indicator (see ). Preliminary Program DME [Page 47 ]8

4. If you want to transfer the remuneration statements as payment advice to the payment 
medium program for bank transfer, 

− flag the Payslip on Payment Advice Note indicator 

− enter the form for creating the remuneration statement in the Payroll Form for Advice 
field 

If you do not flag the Payslip on Payment Advice Note indicator, the preliminary program 
DME prints the remuneration statements, and uses the form that you entered in the 
Payroll Form field to do this. 

5. Choose . 

The system produces statistics on the personnel numbers evaluated and the entries in 
the Payment Information table (BT). 

6. Make a note of the program run date and the six-digit identification feature. You will have to 
enter these values at a later stage on the selection screen of the payment medium program, 
which you use for . creating the DME file [Page 493]

Result 
The system evaluates the payroll results for the employees you selected, and saves the payment 
information as payment data and the remumeration statements to the database. 
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Creating a DME File 
Procedure 
1. Start the payment medium program for the bank transfer. 

2. Enter the program run date and the identification feature of the payment run to be processed.  

3. In the Print control section, select the Data medium exchange, Print payment advice notes 
and Print payment summary indicators.  

4. Enter the additional necessary data, and choose . 

Result 
The system evaluates the payment data for the payment run you entered, and creates a DME 
file. The DME file contains all bank transactions and is of the same format as the file used by 
your house bank. You can continue to process the DME file created, using 

496 . 
data medium 

administration [Page ]

The system creates the DME accompanying sheet and the payment summary for this DME file. 
Furthermore, the system prints the payment advices with the remuneration statements, if these 
were transferred by the preliminary program DME (dependent on your settings). 
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Zero-Net Advices 
Purpose 
If an employee, who is paid by bank transfer, does not receive a salary payment 
in a payroll period, you can print the remuneration statement for this employee 
on a zero-net advice. 

Prerequisites 
In Payroll Customizing you have checked the standard settings for zero-net 
checks under Direct Deposit/Data Medium Exchange and, if necessary, modified them 
to meet your requirements. 

Process Flow 
If there is no salary payment for an employee in a payroll period, the following 
process takes place for creating zero-net advices: 
1. During the payroll run, the system creates an entry in the Bank Transactions (BT) table in the 

payroll results for the employee that contains wage type /559 Bank Transfer with the amount 
of zero.  

2. The system checks if there is a valid record of the Bank Details infotype (0009) for the 
employee at the time of payroll: 

If there is a valid record of the Bank Details infotype (0009), the system writes the 
payment method stored in the Bank Details infotype (0009) to the entry created in the 
Bank Transaction (BT) table.  

− 

− If there is no valid record of the Bank Details infotype (0009) for the employee, the 
system does not create a zero-net advice, but creates a  
instead. The system uses the payment method stored as a parameter in function P9ZNC 
in the payroll schema.  
The system checks that the Check and Allowed for personnel payments indicators are 
set for this payment method in Customizing of Accounting. If this is the case, the system 
writes the payment method to the entry created in the Bank Transaction (BT) table. If this 
is not the case, the system rejects the employee during the payroll run. 

zero-net check [Page 48 ]7

3. You perform the process of 
  During the process the pre-program DME also creates payment data for 

the entries from the Bank Transaction (BT) table, that contains wage type /559 Bank Transfer 
with an amount of zero. However, the payment medium program that you use to create the 
DME file does not select this payment data with the amount of zero.  

wage and salary payment by bank transfer with payment advice 
printing [Page 489]

4. You start the program International Payment Medium – Zero Balance Notice (Report 
RFFOAVIS) and evaluate the payment run created a second time. In this way, the system 
prints a zero-net advice for the employees who do not get a salary payment and are paid by 
bank transfer in accordance with the Bank Details infotype (0009). 

The following graphic shows the creation of 487  and zero-net advices. zero-net checks [Page ]
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Wage type /559 or
/558 in RT?
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infotype 0009)

Write wage type /559 with amount zero to BT

Write payment method from infotype
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Print zero-net advice (RFFOAVIS) or zero-net check
(RFFOUS_C) (depending on payment method)
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Data Medium Administration 
Use 
Data medium administration (DME administration) helps you to manage the data media that you 
create in Financial Accounting and in Human Resources.  

In the Accounts Receivable or Accounts Payable menu, choose Periodic processing → 
Payments. The system displays the Automatic Payment Transactions: Status screen. From 
here, choose Environment → Payment medium → DME administration to reach the DME 
administration screen. 

In the Payroll country menus, choose Payroll → Bank transfer → DME management. 

In the DME administration overview, the system displays all the data media created with the 
selection criteria you have specified. You can call up further information for each data medium. 
Select the required data medium.  

Features 
DME administration includes the following functions: 

• Displaying data medium attributes 

Choose Extras → DME attributes 

The system displays the following information for the selected data medium:  

− Payment run ID 

− House bank or clearing house 

− Date and time of data medium creation 

− Responsible person 

− Amount paid in currency specified 

− Further technical data 

• Deleting an individual or several data media 

The accompanying administrative data is deleted from the system at the same time.  

Select the required data medium and then choose Edit → Delete data medium. A 
confirmation prompt appears. The selected data media are deleted when you confirm 
this prompt. 

If you wish to delete data media from several company codes, then you should use the 
reorganization function within the payment program. 

See also:  
Deleting DME Administrative Data Across Company Codes [Ext.] 

• Downloading one or more files from the SAP system or from the file system to hard 
drive or disk 

See also: 
Downloading a DME File onto Disk [Ext.] 

496  April 2001 



 SAP AG Payroll United States (PY-US) 

  Data Medium Administration 

• Displaying the contents of a data medium on the screen or printing the contents 

Choose Edit → Display DME contents from the DME administration overview screen. 

 

 
The following functions are not available for payments from Human Resources (HR). 

• Displaying Documents 

Choose Extras → DME attributes and then Environment → Display documents. By 
selecting Choose, you branch into the selected payment document. 

• Displaying the transferred data after receiving and entering the account statement 

To do this, choose Extras → Bk transact.attribs from the DME administration overview 
screen. If your electronic account statements are processed automatically, then the 
system fills in the fields within the Account statement group. 

• Printing the payment summary for the selected data medium 

To do this, choose Extras → Payment summary from the DME administration overview 
screen. 

• Creating a payment advice note 

If you do not use the automatic transfer of electronic account statements but instead 
enter the account statement data manually, you can simplify this work by means of 
payment advice notes within DME administration. 

You can create a payment advice note for a specified data medium using Environment 
→ Generate doc.pmt adv. You can enter this payment advice number at a later stage 
when clearing the bank clearing account. During clearing, the system then only proposes 
those open items which belong to the payments specified in the payment advice.  

You can find more information on the use of this function in Great Britain, (for the 
creation of a Telepay file, for example) in the documentation of report RFFODTA1. 
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Remuneration Statement (Report RPCEDTx0; 
HxxCEDT0) 
Purpose 
The R/3 System lists all the payments and deductions made for an employee in a clear format on 
the remuneration statement. The system also allows you to enter personal or general 
notifications for your employees. These are printed on the remuneration statement as additional 
information. This additional information, for example, general information from the management 
or birthday greetings can be entered in the Notifications infotype (0128).  

You usually create the remuneration statement after the payroll run and before the bank transfer. 
If you perform more than one payroll run in a single period, you can create remuneration 
statements after each payroll run. 

You specify the format, structure and content of the form for the remuneration statement in 
Customizing for Payroll under Remuneration Statement. 
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Creating Remuneration Statements 
Procedure 
1. In the SAP Menu choose Human Resources → Payroll → International → Information 

System → Employee → Remuneration Statement. 

2. Enter the appropriate values in the fields, and set the indicators required. 

 
The system enters a default value in the Payroll Area field. This corresponds to your 
entries in the initial payroll or to the settings under Tools → Set Modifiers → Payroll 
Area. You can overwrite this default value. 

3. Choose Program → Execute or Execute + Print or Execute in Background. 
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Notifications Infotype (0128) 
Definition 
In the Notifications Infotype (0128) you define the additional information that should be printed on 
your employee’s remuneration statement. For example, messages from management and 
birthday congratulations. 

Structure 
The Notifications infotype (0128) has the following subtypes in the standard system. 

• Subtype 1: General notifications 

In this subtype you assign a text module to a personnel number. You have created the 
text module previously using the function Tools →SAPscript →Standardtext. You cannot 
edit the text module directly in the Notifications Infotype (0128). 

• Subtype 2: Personal notifications 

In this subtype you edit an individual text module for the personnel number in question. 
You can only edit and display this text directly in the infotype. 
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Creating a General Notification 
Procedure 
1. Choose Tools → Form Printout → SAPscript → Standard Text. 

2. In the Text Name and Language fields, enter the required data. 

3. In the Text ID field, enter HR_G. 

4. Choose Create. 

5. Choose Goto → Header. 

6. Enter a short title for the new text module. 

 
Maintain the short title for the text modules you have used. This provides you with a 
better overview within the Notifications infotype (0128), because the short title, not 
the text name, is displayed in the list screen or overview screen for the infotype. 

 
A change to a text module affects all of the personnel numbers to which the text is 
assigned in subtype 1 (General Notifications). 

7. Enter the text for the general notification. 

 
The system does not support formatting within the remuneration statement. 

8. Choose Save. 
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Assigning a Notification to a Remuneration Statement 
Prerequisites 
You have created a general notification by choosing Tools → Form Printout → SAPscript → 
Standard Text. 

Procedure 
1. Choose Human Resources → Personnel Management → Administration → HR Master Data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. In the Infotype field, enter 0128 and in the Subtype field, enter 1 for a General Notification. 

4. Choose Create. 

5. Enter the text name. 

6. Enter any other necessary data, if and when required. 

 
You should define the beginning and end date of the notification, as the notification 
will be printed in every payroll period otherwise. 

7. Choose Save. 

Result 
You have assigned a general notification to an employee’s remuneration statement. 
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Editing Personal Notifications 
Procedure 
1. Choose Human Resources → Personnel Management → Administration → HR Master Data 

→ Maintain. 

2. Enter the employee’s personnel number. 

3. Enter 0128 in the Infotype field and 2 in the Type field for a Personal Notification. 

4. Choose Create. 

5. Enter a short title for the personal notification. 

6. In lower part of the window, enter the personal notification. If this area is too small, you can 
access the SAPscript editor by choosing Maintain Notification. You can now edit the text 
again. 

 
The system does not support formatting within the remuneration statement. 

You should define the beginning and end date of the notification, as the notification 
will be printed in every payroll period otherwise. 

7. Choose Save. 
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Parallel Execution of Evaluation Programs 
Use 
If you want to generate evaluations for a large number of personnel numbers (for example, print 
remuneration statements), you can use report RPCS0000 to create several background jobs. 
The system then processes the background jobs simultaneously using different application 
servers. 

 
You should not use report RPCS0000 to run simultaneous evaluations with only one 
result (for example, for an employee telephone directory). This is because you 
cannot combine the results of individual background jobs. 

Prerequisites 
The following prerequisites must be met if you want to run an evaluation program using report 
RPCS0000: 

• A suitable variant must be defined in the evaluation program. 

• The evaluation program must use the logical database PNP. 

Scope of Functions 
You specify the number of personnel numbers to be evaluated in the background job or how 
many background jobs should be created. Report RPCS0000 selects the personnel numbers to 
be evaluated from the database and groups them together in background jobs. You can release 
each background job separately or you can release them together. 

 
Report RPCS0000 does not use the criteria for the logical database PNP when 
sorting. Sort sequences defined in the program variants may, therefore, not be 
performed correctly. 

You can enter a short text for each evaluation run. Each background job contains this short title 
and a sequential number. The short text can be helpful if you want to display the background jobs 
in the general job overview. 

The program displays a log after the evaluation has been completed.  
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Starting Evaluation Programs Simultaneously 
Prerequisites 
You have defined a program variant for the evaluation program (for example, for the creation of 
remuneration documents) and are in the ABAP/4 Execute Program screen. 

Procedure 
1. Enter program RPCS0000. 

2. Choose Execute. 

3. Enter the evaluation program and a variant. 

4. Enter the number of personnel numbers to be included in the parallel payroll run, or enter 
the number of jobs for which the payroll run should be split. 

5. Choose one of the following steps: 

• Program → Execute 

• Program → Execute + Print 

• Program → Execute in Background 

Result 
The system performs the evaluation and then prints a log. This contains the following information: 

• Date and time of the individual program steps 

• Error messages 

• Warnings 

• Overview of generated background processes 

You can clearly identify the jobs using the job numbers and job names. 
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Payroll Journal (Report RPCLJNx0; HxxCLJN0) 
Purpose 
The payroll journal contains detailed, selected payroll data for several employees, for whom 
payroll has been run in a particular time interval or a selected payroll period. 

You can use the payroll journal to: 

• Identify errors that have occurred during the payroll run 

• Cumulate payroll data belonging to an organizational unit 

• Track the development of data over several payroll periods 

• Have an additional, detailed control medium for revisions 

Scope of Function 
The new version of the payroll journal differentiates between: 

• Page headers 

The page header is printed on each page and contains the organizational assignment for 
the employee. 

• Payroll excerpts 

The payroll excerpts contain the payroll data for each employee and the payroll result. 

• Continuation excerpts 

If the printed payroll excerpts cover two pages, the continuation excerpts appear in first 
position on the second page, and then the rest of the payroll excerpt follows. 

• Totals page 

The totals page contains the cumulated data from the payroll excerpts for each 
organizational unit. 

In the old version of the payroll journal all this information was grouped together. 

When the payroll journal is generated, the system evaluates the data records within Payroll 
whose  are within the specified time interval. Any retroactive accounting 
differences that exist for a specific payroll period are first of all evaluated in the payroll journal, 
with the payroll period during which the retroactive accounting run took place. The selected 
payroll results are listed one after the other, in accordance with the , in the 
forms mentioned above. 

In-Periods [Ext.]

In-Period View [Ext.]

Restrictions 
The payroll journal cannot be used as a basis for reconciliation with the Financial Accounting and 
Controlling application components. 
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Creating a Payroll Journal 
Prerequisite 
You have made the necessary settings for the payroll journal in Customizing for Payroll, under 
Forms → Payroll Journal, and have ended the payroll run successfully. 

You are in the initial screen for Payroll. 

Procedure 
1. In the SAP Menu choose Human Resources → Payroll → International → Information 

System → Organizational Entity → Payroll Journal. 

2. Enter the appropriate values in the fields, and set the indicators required. 

 
You can specify a period of time or a payroll period as data selection criteria. 

Fill in the Payroll Type and Payroll Identifier fields, if these are available in your 
country version, to restrict the payroll results that are to be evaluated. 

You use Delimitation to determine the sorting sequence and the way in which the 
values for the totals pages should be cumulated. 

You use Format Retroactive Accounting to determine how retroactive accounting 
should be displayed on the payroll excerpts. 

You use Format Retroactive Accounting to determine how current periods are printed 
and whether superlines are printed.  

3. Choose Program → Execute or Execute + Print or In Background. 

Result 
The payroll journal was created. According to the settings you have made, you only obtain 
information concerning the personnel area, or additionally you obtain information concerning the 
individual employees. 
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Wage Type Statement 
Definition 
The wage type distribution is a list that gives you an overview of the wage types in the in-period 
view. The system evaluates the payroll results from results tables RT and CRT and determines 
the original payroll result and the retroactive accounting results created in the period in question. 

The system also evaluates the employee’s organizational assignment. This is included in the 
payroll results. This data is taken from the Work Center Basic Pay table (WPBP).  

Use 
You can use the wage type statement to 

• Identify errors that have occurred during the payroll run 

• Cumulate payroll data belonging to an organizational unit 

• Have an additional, detailed control medium for revisions 

The following evaluation options can be used when creating the wage type statement: 

• Individual evaluation 

This type of evaluation is performed for each personnel number. The number and 
amount is printed for each wage type. The individual evaluation can be sorted according 
to personnel number or employee name within the organizational assignment. 

• Totals evaluation 

This type of evaluation is performed without specification of personnel number and 
name. The selected wage types are cumulated and printed for all selected personnel 
numbers. The totals evaluation can only be sorted according to organizational 
assignment. 

Wage type statements can only be created for one country. Personnel numbers that are 
assigned to another country are listed in the error log. 
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Creating a Wage Type Statement 
Prerequisites 
Payroll results exist. 

You are in the initial screen for Payroll. 

Procedure 
1. In the SAP Menu choose Human Resources → Payroll → International → Information 

Systems → Wage Type → Wage Type Statement. 

2. Enter the appropriate values in the fields, and set the indicators required. 

 
If you do not enter a wage type, the SAP System selects all wage types that are in 
the internal Results tables RT or CRT for the selected payroll result. 

If you flag the New Page Per Wage Type field, each new wage type is printed on a 
new page in the individual statement. This parameter is not used in totals evaluation. 

In the Reference Period field, you can enter a payroll period as a comparison period. 
The results of the comparison and the absolute and relative differences between the 
wage types will then be printed on the wage type statement. The comparison values 
that are generated when a reference period is used cannot be printed on the form. 

If you flag the Read Cumulated Results field, the cumulated annual values for the 
results table CRT are read and formatted for the wage type statement. 

In the Totals Formation group, you can change the standard output by changing one 
of the sort criteria. 

3. Choose Program → Execute or Execute + Print or Execute in Background. 

Result 
A wage type statement is displayed. 
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Wage Type Distribution 
Definition 
The wage type distribution is a list that gives you an overview of the wage types in the for-period 
view. The system evaluates the payroll results from results table RT and determines the last 
payroll result for the for-periods for a period. 

The system also evaluates the employee’s organizational assignment. This is included in the 
payroll results. This data is taken from the Work Center Basic Pay table (WPBP). The system 
does not include any retroactive accounting differences in the wage type distribution. 

When creating the list, the system only considers the current data records that are valid at the 
time of the evaluation. This means that the evaluation runs that take place later may not have the 
same result: If retroactive accounting has taken place in this period, a new payroll result exists, 
which is then displayed. 

Use 
You can use the wage type distribution to: 

• Identify errors that have occurred during the payroll run 

• Cumulate payroll data belonging to an organizational unit 

• Track the development of data over several payroll periods 

• Have an additional, detailed control medium for revisions 

The following evaluation options can be used when creating the wage type statement: 

• Individual evaluation 

This type of evaluation is performed for each personnel number. The number and 
amount is printed for each wage type. The individual evaluation can be sorted according 
to personnel number or employee name within the organizational assignment. 

• Totals evaluation 

This type of evaluation is performed without specification of personnel number and 
name. The selected wage types are cumulated and printed for all selected personnel 
numbers. The totals evaluation can only be sorted according to organizational 
assignment. 

Wage type distribution lists can only be created for one country. Personnel numbers that are 
assigned to another country are listed in the error log. 

 

510  April 2001 



 SAP AG Payroll United States (PY-US) 

  Creating the Wage Type Distribution List 

Creating the Wage Type Distribution List 
Prerequisites 
Payroll results exist. 

You are in the initial screen for Payroll. 

Procedure 
4. In the SAP Menu choose Human Resources→ Payroll → International → Information System 

→ Wage Type → Wage Type Distribution. 

5. Enter the appropriate values in the fields, and set the indicators required. 

 
If you do not enter a Wage Type, the SAP System selects all wage types that are in 
the internal Results tables RT for the selected payroll result. 

If you flag the New Page Per Wage Type field, each new wage type is printed on a 
new page in the individual statement. This parameter is not used in totals evaluation. 

If you only flag the Evaluation Start field in the Evaluation Period group, only this 
period will be evaluated. 

In the Totals Formation group, you can change the standard output by changing one 
of the sort criteria. 

6. Choose Program → Execute or Execute + Print or Execute in Background. 

Result 
You have created a wage type distribution. 
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Wage Type Reporter (H99CWTR0) 
Use 
You use the wage type reporter to evaluate wage types that are contained in the payroll results. 
Data from the Results Table (RT) and the Work Center Basic Pay table (WPBP) is used in the 
evaluation. 

 
Data from the Personnel Administration application component (PA-PA) (for 
example, infotypes), or from other tables in the R/3 System is not included in this 
evaluation. 

Prerequisites 
Payroll has been run successfully. 

Scope of Function 
Evaluation options 

• Evaluation of wage types for a selected period 

• Overview of the wage types from an  or a . for-period view [Ext.]in-period view [Ext.]

• Variable column selection for the list (for example, company code, wage type, and 
) 

in-period 
[Ext.]

• Selection of wage types to restrict the evaluation 

• Summarized output of selected wage types 

• Summarized output of selected wage types 

List display 

Output and display in • 

- SAP List Viewer [Page 51 ]3  

- Microsoft Excel Table [Page 514] 
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SAP List Viewer 
Definition 
The SAP List Viewer is a user interface, which enables you to display lists in a standardized list 
format in the R/3 System. The List Viewer uses a simple list format and includes functions for the 
dynamic creation of display variants. 

Use 
The List Viewer enables you to 

• Use pre-defined SAP standard display variants 

• Create display variants 

• Sort the data 

• Sort the lines according to the values in the columns, either in an ascending or descending 
sequence 

• Set a filter 

• Display lines that meet certain criteria 

• Form totals and subtotals 

The wage type reporter uses the List Viewer as a method for displaying the created list. You can 
choose how to display the list using the display variants. For example, you can 

• Move columns 

• Hide columns 

• Form totals 

• Sort the data 

For more information, see the documentation on Cross Application Components (CA-GTF) under 
. SAP List Viewer [Ext.]
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Displaying the Excel Table 
Use 
The wage type reporter uses Microsoft Excel to display the list in a table format. 

Activities 
When you use Microsoft Excel to display the form, SAP recommends that you use an Excel 
template and use the following procedure: 

1. Start the wage type reporter with the required data, however, do not specify an Excel 
template. 

The system creates a temporary table. 

2. Enter suitable column headers in the table. Insert the headers as the first line. 

3. Select all columns in the area containing the data.  

4. Choose the Pivot Table Report and create the required report.  

5. Insert this report in a new Excel sheet. 

 

The Pivot Table is displayed. 

6. To save the Pivot Table as a template, select all data in the temporary table. Do not 
select the column headers. 

7. Delete the selected data and place the cursor in the first column and second line. 

8. Save the template in the file format .XLT. 

The template can be re-used for other Excel tables; however, the objects selected must be the 
same as the objects selected when the template was created. 

1. In the Excel model template field, enter the path for the template. 

2. Start the wage type reporter. 

The new temporary table is displayed. 

3. Choose the sheet with the Pivot Table, and update the table. 
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Creating a List of Wage Types 
Prerequisites 
Payroll results exist. 
You are in the initial screen for Payroll. 

Procedure 
1. In the SAP Menu choose Human Resources → Payroll → International → Information 

System → Wage Type → Wage Type Reporter. 

2. Enter the appropriate values in the fields, and set the indicators required. 

 
The standard selection fields are available in the Selection group. Note that the 
selection according to organizational criteria in these fields need not correspond to 
the selection of payroll results for the selected organizational unit. Differences may 
occur if master data is changed retroactively. SAP recommends that you include the 
objects used for selection in the Object Selection function. 

If you flag the In-period or For-period view in the Period Determination group, a list is 
created for the selected view. 

If you do not enter a wage type, the SAP System selects all wage types that are in 
the internal Results Table RT or in the Work Center Basic Pay table for the selected 
payroll result. 

You use the Object Selection function to define which objects are displayed as 
columns in the list and which objects are summarized. The selected objects are 
printed as columns in the list and the objects not selected are summarized. 

In the Output group, you define whether the list is created with the List Viewer or 
printed as a Microsoft Excel table. 

If Display using list display or Layout list viewer is selected, the list is displayed in the 
. SAP List Viewer [Page 51 ]3

If Display using Excel or Excel model template is selected, the list is displayed as a 
Microsoft Excel Table [Page 514]. 

3. Choose Program → Execute. 

Result 
A list is displayed of the wage type evaluation. 
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Month-End Accruals Concept 
Definition 
Payroll Accounting is usually carried out in a fixed cycle. This cycle is determined by the length of 
the periods for which the payroll is run, such as a month or a week. 

Once the payroll run is complete, the results are transferred to accounting (Financial Accounting 
and Cost Accounting) where they are posted using a fixed posting date, such as the check date. 
Financial Accounting also assigns its accounting transactions to fixed periods, such as months or 
four weeks. 

If the periods used within Human Resources (HR) and Financial Accounting are the same, the 
posting date enables you to assign the posting of payroll results correctly. 

If the payroll periods are not the same as the posting periods used within Financial Accounting, 
the FROM and TO dates of the payroll period might belong to different posting periods within 
Financial Accounting. The payroll results are then posted using a fixed posting date, such as the 
check date. As a result, all of the personnel expenses are assigned to a single posting period 
within Financial Accounting, even though the expenses were actually incurred in two different 
posting periods. This makes it difficult to make a meaningful comparison of expenses incurred in 
different posting periods. 

You then need to be able to split personnel expenses so that for exact periods within Financial 
Accounting they can be assigned to different posting periods. 

The month-end accruals function was developed to solve this problem. 

Two Ways of Splitting Personnel Expenses for Exact Periods 

• Approach Using Estimates 

The personnel expenses expected for a posting period are estimated on the basis of the 
results from past payroll periods and the appropriate accruals are created. These 
accruals are then reversed in the posting period to which the corresponding payroll 
results are posted. 

• Approach Using Actual Values 

The personnel expenses calculated by the payroll run are split directly for the posting 
periods in question.  

 

The SAP solution is designed to use a combination of these two methods, but can be configured 
to use one or the other. 

See also:
Approach Using Estimates [Page 517] 

Approach Using Actual Values [Page 518] 

The SAP Solution [Page ]519  
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Approach Using Estimates 
The Approach Using Estimates is an accounting method frequently used when a pay period 
intersects two different accounting periods.  

Suppose your company’s accounting periods are on a monthly basis and pay period C intersects 
accounting periods June and July. You can use the actual payroll results of pay period B to 
estimate the payroll results in pay period C. Financial Accounting will debit the June accounting 
period for the amount of work in pay period C that occurred in June, and debit the July 
accounting period for the amount of work in pay period C that occurred in July. 

accounting period

B C D
pay periodactual payroll result estimated payroll result

JulyJune
COFI

HR
 

In the June accounting period, Financial Accounting can debit a special expense account with the 
estimated amount for the part of payroll period C that belongs to June. To balance the postings in 
the June accounting period, a provisional account can then be credited with the same amount 
that was debited to the special expense account mentioned above. 

In the July accounting period when the actual payroll values are posted, you balance these 
accounts by reversing the estimated postings. You can credit the special expense account and 
debiting the provisional account with the original estimated amounts 

 
If the June accounting period is still open when the payroll results of pay period C are 
posted, estimated values can have been used although the more accurate actual 
values were available 
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Approach Using Actual Values 
The Approach Using Actual Values is an accounting method frequently used when a pay period 
intersects two different accounting periods.  

Suppose your company’s accounting periods are on a monthly basis and pay period C intersects 
accounting periods June and July. The posting date for pay period C is derived from the end 
date, or the check date of the pay period. Suppose your posting date for pay period C is in the 
July accounting period. All the actual values for pay period C, then, can be posted into the July 
accounting period. Financial Accounting will then determine what amount of the actual values for 
pay period C should be transferred into the June accounting period. 

accounting period

B C D
pay period actual payroll result

JulyJune
COFI

HR
 

Financial Accounting can debit a special expense account with this amount for the part of payroll 
period C that belongs to June. To balance the postings in the June accounting period, a 
provisional account can then be credited with the same amount that was debited to the special 
expense account mentioned above. 

For the July accounting period, you balance these accounts by reversing the two postings. You 
can credit the special expense account and debiting the provisional account with the appropriate 
amounts.  

It may occur that, for example, the June accounting period is already closed when you want to 
post the actual values into June. In this event you must post the actual values into the next, in 
this case the July, accounting period. One option is to do the posting similar to the way it is done 
in the . Approach Using Estimates [Page 517]
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The SAP Solution 
Choice of Method used to Split Expenses 
The SAP solution for month end accruals enables you to split personnel expenses for the 
appropriate posting periods. You can do this by using a combination of 

 and . As a result, such splits are 
executed using the most up-to-date (and therefore the best) information available. 

Approach Using 
Estimates [Page 51 ]7 Approach Using Actual Values [Page 518]

This means that the splits are based on current values, if possible. This is the case if all of the 
posting periods in question are still capable of receiving posting data when the payroll results are 
posted. 

Otherwise, the amount of personnel expenses still expected for a posting period is estimated 
during an earlier payroll run.  

You can also set up the system so that only the Approach Using Estimates or Approach Using 
Actual Values is used. 

There are no presettings to determine the date on which the payroll results are posted for a 
particular payroll period. When customizing the system, you are required to enter dates by which 
the payroll results must be posted. Using this latest document creation date (LDCD), you can 
determine the date by which postings must be effected for each subsequent payroll period. You 
cannot change these dates, which means it is essential that you meet the specified deadline for 
posting. You must also use the Implementation Guide (IMG) to specify a final date for each 
posting period with regard to postings from HR. When the payroll is run, the system compares 
these two dates with each other. 

If the LDCD of the payroll period in question is earlier than the final dates for all of the posting 
periods within Financial Accounting, the system recognizes that the expenses can be split on the 
basis of the current payroll results. 

In the following example, the LDCD of the (current) payroll period C is earlier than the final 
posting date of the June (and July) posting period (s). For this reason, the expenses can be split 
using the appropriate basis (see below) in accordance with the Approach Using Actual Values. 

accounting period

B C D
pay periodactual payroll result LDCD of C before closing date of June

closing date of June

JulyJune
COFI

HR
 

If the earlier of the two posting periods can no longer receive posting data by the LDCD of the 
current payroll period, you can no longer split the current values. The system recognizes this 
situation during the payroll run for the previous payroll period. 

 

In the next example, the June posting period is no longer capable of receiving posting data by the 
LDCD of payroll period C. During the payroll run for payroll period B, the system uses the payroll 
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results for payroll period B to estimate the expected amount of June expenses for payroll period 
C. The system then creates accruals for June in the amount of the estimated expenses. 

accounting period

B C D
pay period

actual payroll result
estimated payroll result LDCD of C after closing date of June

closing date of June

JulyJune
COFI

HR
 

The current results for the whole of payroll period C are subsequently posted using a posting 
date in July. For this reason, the accruals created for June must be reversed in July. 

See Approach Using Estimates [Page 517] for a description of how the system splits expenses 
by creating accruals. 

The system also splits the current values (by creating and reversing accruals in accordance with 
the . Approach Using Actual Values [Page 518]

 

Effected Postings: Example 
 

1000$

400$

Expenses

June

July

400$

Accrued Expenses

June

July

Accruals Account

400$

400$

Payable

1000$
 

 

Of the $1000 incurred for payroll period C that must be posted to July in accordance with the 
customizing settings, $400 (for example) should actually be posted to the posting period for June. 
This is achieved by debiting the $400 to an expense account (Accrued Expenses) using a 
posting date in June. The offsetting entry is made in an accruals account. The actual payroll 
posting of $1000 (Expenses to Payable) is effected using a posting date in July. A posting date in 
July is also used to credit the so-called Accrued Expenses account and to reverse the accrual. 
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If you use the Approach Using Estimates, the additional postings are effected after the payroll run 
for payroll period B. If you use the Approach Using Actual Values, on the other hand, these 
postings are not effected until payroll period C. 

 

Note that you must set the Posting date acc. to table parameter when starting Transfer to FI/CO 
to ensure that the regular posting is effected using the posting date specified during customizing. 

 

Basis Used to Split Expenses 
The system enables you to split expenses in accordance with: 

• Calendar Days 

• Workdays According to the Personal Work Schedule 

• Working Hours According to the Personal Work Schedule 

Refer to the appropriate section within the IMG for more information. 

 

Effect of an Organizational Reassignment 
If an employee’s remuneration or organizational assignment changes during a payroll period 
(creation of a WPBP split), the calculation of month end accruals is affected as follows: 

1. Approach Using Estimates 

If expenses for a future payroll period are estimated on the basis of the current payroll results, 
the system assumes that the employee’s organizational assignments in the period to be 
estimated are the same as on the last day of the current payroll period. For this reason, the 
expected personnel expenses are debited to the Cost Center assigned on the last day because 
the system assumes that the employee will remain on this Cost Center after the change has 
been effected. However, the entire period is used as the basis of the amount of expected 
expenses. The following example makes this clearer:  

accounting period

HR

FI CO
JulyJune

750 $
CCtr 1

250 $
CCtr 2

+
= 1000 $

calculation basis, e.g. working days

6 4

x 6/10

600 $

x 4/10

400 $B C D
CCtr 2 CCtr 2

 
At the end of payroll period B, the employee works on Cost Center 2 so that the accruals for 
payroll period C are debited to Cost Center 2. However, the basis of the estimation consists of 
the entire periodic expenses at the amount of $1000. 
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Note the system’s assumption that wage types with an explicit cost assignment (table C1) also 
occur in the period to be estimated with the same cost assignment. Such payments are assigned 
to the entire payroll period, irrespective of the exact time at which the payment is effected, and 
are then split accordingly. 

 

The system ignores future changes made to the employee’s organizational data, even if they are 
already entered and stored in the system when the payroll is run. The reason for this is that 
changes usually compensate for one another. For example, an employee who leaves the 
company in the payroll period to be estimated and for whom month end accruals are not really 
required is usually replaced by another employee. 

 

2. Approach Using Actual Values 

When expenses are split using the Approach Using Actual Values, all of the required information 
on the best possible split is already in the system when the posting is effected. All of the partial 
periods within the payroll period are checked individually and assigned to the posting periods. In 
the following example, the first of the two partial periods, during which the employee works for 
Cost Center 1, is assigned in its entirety to the June posting period. The expenses incurred in the 
second partial period, on the other hand, are distributed to June as well as July, in accordance 
with the basis used for the split (workdays in this example). 

accounting period

HR

FI CO
JulyJune

calculation basis, e.g. working days

4 4

200 $ 400 $B D
400 $
CCtr 1

600 $
CCtr 2

2

600 $ CCtr 2
x 2/6 = 200 $ CCtr 2

x 4/6 = 400 $ CCtr 2  
Wage types with an explicit cost assignment (table C1) are assigned to the partial period in which 
they occur. Irrespective of their exact date of origin, they are distributed to the posting periods in 
accordance with the expenses incurred in the partial period that includes their date of origin. 

 

Such wage types are not entered until the subsequent payroll run, which triggers a retroactive 
accounting run for the current payroll period. 

Regularly Entered Delayed Wage Types 
Sometimes, particular wage types, such as overtime bonuses, are regularly entered in the 
system in the period following the payroll period to which they apply. When the payroll is run, the 
system has no information on the amount of these wage types for the current payroll period. 

If the current period is used as a basis for distributing expenses to two different posting periods, 
these wage types are ignored because they are not yet available in the system. However, it is 
possible to estimate the expected amount of such wage types on the basis of the last payroll 
period for which they are available, which is the preceding period. 
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You can flag such wage types as Regularly Entered Delayed when customizing the system. They 
are then taken from the previous period when month end accruals are created. 

The following example explains this situation for the Approach Using Actual Values. It illustrates 
a hybrid form because the amount of Regularly Entered Delayed wage types is estimated. 

accounting period

HR

FI CO
JulyJune

calculation basis, e.g. working days

6 4

normal wages: 1000 $
delayed wages: 200 $

normal wages: 1000 $

x 6/10 =

x 4/10 =

+
= 1200 $

B C D

720 $

480 $

720 $ 480 $

 
The basis of the distribution does not merely consist of the $1000 in current payroll period C. 
Instead, $200 are also used; period C is expected to incur this amount but it is not entered and 
included in a payroll run until payroll period D. At this time, you can no longer assign part of this 
amount to the June posting period because this period can no longer receive posting data. 

If the Approach Using Estimates is used (see following example), the expenses expected in 
period C are estimated during the payroll run for period B. 

accounting period

HR

FI CO
JulyJune

calculation basis, e.g. working days

6 4

delayed wages
from period A

normal wages: 1000 $

+ = 1200 $
x 6/10

x 4/10

B C DA
200 $

 
Period A represents the last payroll period for which Regularly Entered Delayed wage types are 
available at this time. Thus, the basis of the estimation consists of the wage types normally 
entered for period B and the Regularly Entered Delayed wage types in period A. 

The personnel calculation schema determines whether a particular wage type is Regularly 
Entered Delayed for specific employee groupings. 

 

Posting Retroactive Accounting Differences to Previous Posting Periods 
The section Regularly Entered Delayed Wage Types describes how, under certain conditions, 
expense wage types can be assigned to their appropriate posting periods, despite the fact that 
retroactive accounting has been performed. You can do this if you know in advance that such 
wage types are regularly entered one period later than the period to which they actually apply. 
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However, if retroactive changes are made to ordinary wage types, an unexpected retroactive 
accounting run is triggered for previous payroll periods. Retroactive pay increases are an 
example of such unexpected changes. 

The differences between the new and original payroll results for the retroactively accounted 
period are usually posted using the posting date of the current period, even if part or all of the 
retroactively accounted period belongs to a previous posting period. 

If the payroll period in question belongs entirely to previous posting periods, you can use the 
month end accruals function to set up the system so that retroactive accounting differences are 
posted to the last posting period that can receive such data. For example: 

accounting period

HR

FI CO
JulyJune

B
C D

pay periodactual payroll result

closing date of June

LDCD of C before closing date of June

retrocalculated payroll result

50$ difference

 
In this example, the basic pay data in payroll period B is increased with retroactive effect from 
$1000 to $1050. Data can still be posted to June because the LDCD of the current payroll period 
C is earlier than the final date of the June posting period. The difference of $50 for the 
retroactively accounted period B is posted to the June posting period because B belongs entirely 
to June. 

You can only use this function if just one previous posting period can still receive such posting 
data. 

 

 

Note that Regularly Entered Delayed wage types are ignored because accruals are created for 
these wage types during the normal procedure. 
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Posting to Accounting (PY-XX-DT) 
Purpose 
The payroll results contain information that is relevant for Accounting. For this reason, they must 
be evaluated for posting to Accounting. The Posting to Accounting component performs this task. 
It is the interface between Payroll and Accounting. It helps to: 

• Perform the relevant postings in the Accounting components 

Payroll (PY) 

• Group together posting-relevant information from the payroll results 

• Create summarized documents 

Integration 
Various components of the R/3 system interact when posting to Accounting: 

The Payroll component creates payroll results for each payroll period. To do so, 
 with different business purposes are created. They are created according to tax, 

social insurance law, industrial law, pay scale and operative points of view. 

wage types 
[Page 166]

Financial Accounting (FI) 

• Accounts Payable (FI-AP) 

• Accounts Receivable (FI-AR) 

• Special Ledger (FI-SL) 

Financial Accounting illustrates all business transactions in the enterprise using postings to the 
relevant accounts. Posting to Accounting provides the necessary data for the following 
components in Financial Accounting: 

• General Ledger Accounting (FI-GL) 

• Funds Management (FI-FM) 

Cost Accounting (CO) 
Cost Accounting provides information on the relationship between costs and activities within the 
enterprise. To do so, costs are either assigned to a cost center or to another account assignment 
object. The posting to Accounting component usually posts to the following account assignment 
objects: 

• Cost center 

• Order 

It is also possible to post to the following account assignment objects: 

• Cost object 

• Work breakdown structure element 

• Network number 

• Activity number 
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• Sales order 

• Item in sales order 

Personnel Cost Planning (PA-CM-CP) 
The system can provide Personnel Cost Planning with data based on simulated or actual payroll 
results from posting to Accounting  

The graphic shows how the components link together when posting to Accounting 

Payroll
HRHR

COCO

FIFI

Wage types relevant to posting
Direct labor costs, Salary, ...
Bank transfer, Tax withheld, ...

Assignments
Organizational assignment
Special cost assignment
Special Funds Management 

      assignment

Expense accounts
Wages, salaries, overtime, ...

Payables accounts
W&S payable, taxes payable, ...

Customers
Customer "Hibbert", customer "Miller", ...

Vendors
Vendor “Union", ...

Funds center
Funds center “Administration", ...

Fund
Funds from secondary sources, ...

CO objects
Cost center, orders

General and Subsidiary Ledgers

Funds Management

Special Ledger

Cost Center Accounting

 

Implementation Considerations 
The components involved in posting to Accounting do not have to be in the same client in the R/3 
system. If the components involved are in different R/3 systems, R/2 systems or third-party 
systems, you can find more information in the following sections: 

Posting from HR Systems < 4.0 [Page 59 ]2  • 

Posting to AC Systems < 4.0 [Page 596] • 

•  Posting Posting Documents [Ext.]

• In Customizing of Cross-Application Components, under Predefined ALE Business 
Processes → Human Resources → HR <--> AC → Posting of Payroll Results to Accounting 

Scope of Function 
• You can use the Accounting interface (AC interface) to directly post the documents created 

to the Accounting components. 

• You can simulate posting runs before the end of the payroll run. In this way, you can check if 
the payroll results are also correct from the point of view of posting to Accounting. 
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• You can access information on the creation and processing of posting runs at any time using 
status management and the history. 

• By selecting the payroll results, you prevent them from being evaluated twice. This also lets 
you check if payroll results were missed out during reporting. 

• 

• With the help of layouts, which you can configure to your individual needs (for example, totals 
formation, sorting, filtering), you can check posting documents efficiently. 

The summarized line items can be traced back to the payroll result for a personnel number at 
any time. This function is protected by authorizations. 

• The data created can be archived. For more information on archiving, see 
 and . 

Archiving Posting 
Documents (PY-XX-DT) [Ext.] Archiving Index Files (PY-XX-DT) [Ext.]

• You can provide data for Personnel Cost Planning 
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Central Objects 
You can use the Central Objects section to gather information on the following objects: 

• Posting runs 

• Posting documents 

To be able to correctly control the process of Posting to Accounting, you must thoroughly 
understand both these objects and their relationship to one another. 
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Posting Runs 
Definition 
Central object in posting to Accounting. The step creating a posting run [Page 56 ]8  creates a 
posting run based on the payroll results, with a distinctive number, the run type PP and the 
accompanying . A posting run always contains all the posting 
documents created. Therefore, all activities performed with reference to the posting run affect all 
of its accompanying posting documents. 

posting documents [Page 532]

During posting to Accounting the posting run takes on various statuses that provide information 
on the progress of the posting and any errors that may occur. 

Use 
Posting Document: Assigned Activities 

Activity Procedure(s) 

Simulate 

Create  

Modify 

Post 

Reverse 

Archive the index files 

Simulating a posting run [Page 566] 

Creating a posting run [Page 568] 

Display Displaying the posting run overview [Page 577] 

Displaying the history [Page 589] 

Displaying the attributes of a posting run [Page 579] 

Displaying detailed information [Page 59 ]0  

Changing or creating a posting run text [Page 578] 

Deleting a posting run [Page 580] 

Posting posting documents [Page 573] 

Reversing a posting run [Page 587] 

Archiving index files (PY-XX-DT) [Ext.] 

 

• 

• 

The posting run ensures that an employee’s payroll results are only posted once: 

During the step Creating a posting run, the system locks the payroll results for the selected 
personnel numbers. In this way, it is not possible for either another posting run or the payroll 
driver to process these payroll results. 

In posting to Accounting, a posting run can only be accessed by one sub-process at a time. 
Amongst these sub-processes are: 

− Creating a posting run 

− Deleting a posting run 

− Posting posting documents 

− Reversing posting documents 
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Status management ensures that these sub-processes are listed in a permitted order. 

• 

Attributes 

• R/3 System Release 

The system selects the payroll results for a personnel number, which are processed in the 
step Create posting run. When attempting to repeat payroll for the same payroll period, the 
system rejects a personnel number whose payroll results are selected. It is also not possible 
to process a payroll result that has already been selected with the step Create posting run. 
However, selection of the payroll results is only cancelled 

− If you delete a posting run for which the accompanying posting documents have 
not yet been posted 

− If you reverse posting documents that have already been posted for a posting 
run 

Structure 

A posting run can, depending on Customizing and the country version, have the following 
attributes: 

• Payroll area and period 

• Due date 

• Country grouping 

• Number of personnel numbers selected 

• Number of personnel numbers evaluated 

• Number of personnel numbers rejected 

• Number of personnel numbers skipped 

• Payroll type, payroll identifier and payment date for Off-Cycle Payroll 

• Program that has generated the run 

• Name of accompanying TemSe data object 

• Function exit: Account determination is used 

• Function exit: Filling out ZUONR/SGTXT is used 

• Function exit: Temporary wage type is used 

• Number of document archive 

• Number of index archive 

• Month End Accruals evaluated by posting 

• Month End Accruals evaluated by reversal 

 
You should consider that not every posting run has all attributes named. 
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Status History 
The system automatically creates a status history for posting documents, to log changes with the 
date, time and user responsible. 
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Posting Documents 
Definition 
Central object in posting to Accounting, which contains all the information transferred when 
posting to Accounting. Posting documents are created in the step Create posting run. All posting 
documents that are created as a result of creating a posting run are grouped together to one unit 
in this posting run. 

Each posting document is given a clear number when it is created. During posting to Accounting, 
the posting document takes on different statuses, which provide information on which activities 
were performed with reference to the posting document. 

The Accounting components use the posting document as the original document for creating 
other documents. These accounting documents contain a link to the posting document on which 
they are based. 

The  is a special form of the posting document. It has the same 
structure as the posting documents that are created for a regular posting. The system creates 
reversal documents if you reverse the posting documents for a posting run. 

reversal document [Page 58 ]5

Use 
Posting document: assigned activities 

Activity Procedure(s) 

Display 

display the accompanying accounting 
documents 

Release 

Post 

Archive 

Displaying the Document Overview [Page 582] 

Displaying the Posting Document [Page 583] 

Analyzing the Line Items [Page 58 ]4  

Displaying the History [Page 589] 

Displaying Detailed Information [Page 59 ]0  

Checking the Accounting Documents [Page 
]574  

Release the Posting Documents [Page 572] 

Posting Posting Documents [Page 573] 

Archiving Posting Documents (PY-XX-DT) 
[Ext.] 

 

Structure 
Document header and lines 
Posting documents always consist of document header and document lines. 

The document header contains information on 

• Document number 
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• Company codes 

• Posting date 

• Document date 

The document header contains information on 

• Account number  

• Account assignment objects (for example, cost center) 

• Amount 

• Currency 

 
In Accounting, a document line is also called a document line item. 

Status History 
The system automatically creates a status history for posting documents, to log changes with the 
date, time and user responsible. 
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Business Basics 
You can use the Business Basics unit to get information on the business aspects of posting to 
Accounting using examples. 
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Example: Posting a Salary 
Payroll Results (HR) 
Payroll calculates wage types with different business tasks. Some of these wage types (for 
example, the primary wage type MA10 Standard Pay or the secondary wage type /559 Bank 
Transfer) contain information that is relevant for Accounting. Thus, from the point of view of 
Financial Accounting, Wage type MA10, Standard Pay, contains a company-related expense 
while the wage type /559, Bank Transfer, contains a payable. 

Within Posting to Accounting, wage type /559 Bank Transfer, is posted to a payables account. In 
this example, the wage type is posted to the account Wages and salaries payable.  

The wage type MA10 Standard Pay is posted to an expenses account. In this example, it is 
posted to the Salaries account. As additional account assignment, this posting contains the 
master cost center of the employee, for example, cost center 600 Production.  

Posting in Financial Accounting (FI) 
Posting payroll results in Financial Accounting takes place in the following way: 

 Account Debit Credit

 Salaries 2,000 

Wages and salaries to be paid 2,000 to 

 
The posting of payment transactions is not part of the technical process of Posting to 
Accounting. The procedure will, however, be described in the following 
documentation in order to demonstrate this example's relevance for business. 

If you make payments to the employee, you must (within this payment transaction) make 
postings from the payables account above to the bank account involved, so that the clearing 
account is clear again after both posting transactions.  

The following posting is to be performed within the payment transaction: 

 Account Debit Credit

 Wages and salaries to be paid 2,000 

to Bank account 2,000

 

Posting to Cost Accounting (CO) 
Cost Accounting interprets the posting of payroll results as the posting of primary costs to the 
value of the salary paid to the employee (2,000 euro). These costs are posted to cost center 600, 
Production, with the cost type Salaries. 
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Complete Posting 
Use 
The system only assigns an account to the largest part of the wage types to be posted to which 
the relevant amount is posted. Complete posting is only guaranteed by correctly selecting the 
wage types to be posted when processing the posting characteristics of wage types in 
Customizing. 

Some of the wage types created in Payroll illustrate employer expenses. They should be posted 
in the Accounting components. 

This expenses posting is offset by posting the receivables against the employees to the account 
Wages and Salaries to Be Paid. Other receivables against different recipients of deductions that 
are retained from the employee’s salary also arise, depending on the respective country. These 
are usually posted to a receivables account for each recipient group. 

See also: 
Example: Posting A Salary [Page 535] 
Example for Germany: Complete Posting [Page 537] 

Example for Switzerland: Complete Posting [Page 53 ]8  

Prerequisites 
You must have defined the posting characteristics of the wage types in Payroll Customizing 
(under Reporting for Posting Payroll Results to Accounting → Activities in the HR System → 
Maintain Wage Types → Define Posting Characteristics of Wage Types. 
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Example for Germany: Complete Posting 
The Standard Salary primary wage type (MA10) is posted as an expense. The secondary wage 
types Bank Transfer (/559), EE Taxes (/260), and EE SI Shares (/261) are posted to payables 
accounts. Wage types /351, /361, /371, and /381 (ER Shares for Social Insurance) are posted 
twice, since they represent both an expense and a payable. 

Example Posting for Germany 

Postings to expense 
accounts 

Postings to payables 
accounts 

Wage type Amount Wage type Amount 

MA10 Standard 
Salary 

5,000 /559 Bank Transfer 2,902.21 

  /260 EE Taxes 1,110.29 

  /261 EE SI Shares 987.50 

/351 ER HI share 335.00 /351 ER HI share 335.00 

/361 ER PI share 465.00 /361 ER PI share 465.00 

/371 ER RP share 162.50 /371 ER RP share 162.50 

/3Q1 ER NI share 25.00 /3Q1 ER NI share 25.00 

 5,987.50  5,987.50 

The relevant posting records are as follows: 

 FI accounts in INT account plan Debit Credit 

 430000 Salaries  5,000  

 440000 Legal social expenses 987.50  

to 176000 Salaries/wages to be paid  2,902.21 

to 176100 Employment and church tax   1,110.29 

to 176200 Social Insurance  1,975.00 

  5,987.50 5,987.50 
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Example for Switzerland: Complete Posting 
Postings to expense 

accounts 
Postings to payables 

accounts 

Wage type Amount Wage type Amount 

M100 Monthly salary 5,500 /559 Bank Transfer 4,694.50 

  /411 AHV contribution 277.75 

  /420 AHV contribution 82.50 

  /430 Non-industrial accident 85.25 

  /451 Pension fund 360 

/410 AHV 
administration costs 

3.35 /410 AHV administration costs 3.35 

/412 AHV premium / 
ER share 

277.75 /412 AHV premium / ER share 277.75 

/429 ALV/ER share 82.50 /429 ALV/ER share 82.50 

/452 EE’s PF/ER 
share 

360 /452 EE’s PF/ER share 360 

/43C Industrial 
accident 

75.25 /43C Industrial accident 75.25 

/40A FAK contribution 
fund 

82.50 /40A FAK contribution fund 82.50 

/480 reserve, 13th 
month wages 

458.35 /480 reserve, 13th month wages 458.35 

 6,839.70  6,839.70 

The relevant posting records are as follows: 

 Account Debit Credit 

 400000 Wages and salaries 5,500  

 400200 13. 13th Month Wage 458.35  

 405100 Social insurance AHV/ALV/FAK 446.10  

 405200 Round up pension fund 360.00  

 405300 Social insurance BU/NBU 75.25  

to 220100 AHV/ALV Payroll account  723.85 

to 220200 SUVA Premium payroll account  160.50 

to 220600 FAK payroll account  82.50 

to 222100 Pension funds payroll account  720 

to 225100 Payment account  4,694.50 
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to 226100 Reserve, cash discount 13th salary discount  458.35 

  6,839.70 6,839.70 
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Integration with the Posting of Payment Transactions 
Use 
Posting payroll results ensures that the personnel expenses that arise within the company are 
posted in Financial Accounting and Cost Accounting. The resulting payables are also offset as 
follows: 

• Payables to employees are offset against the Wages and Salaries Payable account 

• Payables to the recipients of the deductions retained from the employees are offset in 
additional payables accounts. This is country-specific. 

Activities 
These payables are triggered in Financial Accounting as follows: 

• Payables against the employees are settled by payments. 

• The receivables against third parties (for example, tax, social insurance) are settled by 
payments. 

The following steps are performed for each transaction: 

1. The amounts payable are calculated. 

2. The amounts calculated are paid. 

3. A Payables account to bank clearing account posting is created. 

 
Steps 2 and 3 are performed either automatically or manually, based on the country 
and respective payment transaction. 

When the appropriate account statements are created, the Bank clearing account to bank posting 
run clears the bank clearing account. 

See also: 
Germany: Integration with the Posting of Payment Transactions [Page 541] 

USA: Integration with the Posting of Payment Transactions [Page 542] 
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Germany: Integration with the Posting of Payment 
Transactions 
Use 
Posting payroll results ensures that the personnel expenses within the company are posted to 
Financial Accounting and Cost Accounting. The resulting payables are also offset as follows: 

• 

• 

• 

• 

• 

• 

Payables to employees are offset against the Wages and Salaries Payable account 

Payables to the tax office are offset against the Taxes Payable account 

Payables to the social insurance agencies are offset against the Social Insurance 
Contributions Payable account. 

In certain cases, further payables against other recipients can arise. 

Activities 
These payables are cleared in Financial Accounting as follows: 

Payables to employees are effected using payments (usually bank transfers). 

Taxes are based on the Employment Tax Notification and are transferred to the tax office 
with the other general company tax payments. 

The social insurance contributions payable are based on the Statement of Contributions and 
are transferred to the health insurance funds using the Transfer to HI Fund function. 

The following graphic shows an overview of integration with the posting of payment transactions: 
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USA: Integration with the Posting of Payment Transactions 

Accounts involved in subsequent activities

Payroll
posting

Payments to
employees

Tax

Health
Insurance
funds

Posting documents

Payment list

Employment tax
notification

Statement of
contributions

automatic
posting

manual
posting

manual
posting

manual
posting

Expense

Costs

W&S payable

Tax payable

SI payable

W&S payable

Tax payable

SI payable Bank clearing

Bank clearing

Bank clearing

Example for Germany

 
The following steps are performed for each of these payment transactions: 

1. The amounts payable are calculated. 

2. The amounts calculated are paid. This takes place based on the transaction either 
automatically or manually. 

3. A Payables account to bank clearing account posting is created. You must perform this 
posting manually. 

When the appropriate account statements are created, the Bank clearing account to bank posting 
run clears the bank clearing account.  

 

 

USA: Integration with the Posting of Payment 
Transactions 
In the USA, payables against the tax authorities and other vendors are posted to the relevant 
vendor accounts using the function Third Party Remittance [Ext.], they are then paid by the 
normal payment run in Financial Accounting. 
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Technical Aspects 
You can use the Technical Aspects unit 

• To get an overview of the technical process of Posting to Accounting 

• To get information on the technical details 
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Technical Sequence of Posting 
Purpose 
Posting to Accounting includes the evaluation of the payroll results, the creation of posting 
documents and posting them in the Accounting components. 

Process Flow 
1. Each time Posting to Accounting is started, the system creates a posting run with a 

distinctive number. The posting run allows you to recreate the information edited at any time. 
The posting run has a different status at each point between the reporting of the payroll 
results and the posting of the summarized information. 

2. The system evaluates the payroll results in view of information relevant to posting. If payroll 
results are evaluated for a live posting run, they are flagged. This ensures that the payroll 
results are not evaluated twice. The system can also use the selection to check whether any 
payroll results exist in a payroll period that has not been evaluated yet. 

3. The system determines the symbolic account assignment from the wage types to be posted 
using the settings in Customizing. The system derives the employee grouping for the account 
assignment from certain characteristics of the employee. The system derives the G/L 
account from the combination of employee grouping and symbolic account. The account 
assignment objects are determined. 

4. The system creates summarized posting documents from the data determined. These only 
contain information that is relevant for the Accounting components. 

5. The system posts the posting documents directly to the Accounting components involved 
using the Accounting interface [Ext.]. 
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Posting-Relevant Information from Master Data, Time 
Data and Organizational Management 
Certain information from master and time data and from Organizational Management [Ext.] 
appears in the payroll result. When evaluating the payroll results for posting to Accounting, the 
system filters out the posting-relevant information from the payroll results. 

Organizational Assignment 
The Organizational Assignment infotype (0001) includes the assignment of the employee to a 
personnel area and a company code. This infotype also includes the assignment to a master 
cost center and to a business area. If you do not specify any other assignments, the system will 
use this assignment in posting to Accounting. 

Cost Distribution from Organizational Management 
In Organizational Management, you can specify a percentage cost distribution to several account 
assignment objects (cost centers orders or projects) for a position. It is possible to evaluate this 
cost distribution in Payroll, so that costs for the employee that would otherwise be posted to the 
master cost center are distributed to the required account assignment objects in the next posting. 
A cost distribution from Organizational Management can also be a result of the percentage 
assignment of an employee to several positions. 

Cost Distribution from HR Master Data 
In the Cost Distribution Infotype (0027) [Ext.], you can specify a percentage distribution of costs 
to several account assignment objects (cost centers, orders or projects) for the employee. If you 
specify the cost distribution for an employee for a partial period of a payroll period in the Cost 
Distribution infotype (0027), the account assignments from the Organizational Assignment 
infotype (0001) (master cost center) and Organizational Management are not taken into 
consideration for this part of the costs. 

Employee Remuneration 
Information relevant to posting, in a broader sense, is contained in all infotypes that the system 
directly or indirectly uses to calculate an employee's remuneration in Payroll. The most important 
infotypes are: 

• Basic Pay infotype (0008) 

• Recurring Payments and Deductions infotype (0014) 

• Additional Payments (0015) 

• Absences infotype (2001) 

• Attendances (2002) 

• Substitutions (2003) 

• Availability (2004) 

• Overtime (2005) 

• EE Remuneration Info (2010) 

With the exception of the Basic Pay infotype (0008), you can specify a cost assignment in all the 
infotypes listed. If you enter the relevant data for cost assignment in one of these infotypes, this 
cost assignment and not the cost assignment from the infotypes Organizational Assignment 
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Posting-Relevant Information from Master Data, Time Data and Organizational 
Management 
(0001) and Cost Distribution (0027) or from Organizational Management is taken into 
consideration when posting to Accounting. However, this only applies when wage types are 
posted that were entered in these infotypes or created using them. 

 
The list above is not a complete list of infotypes in which you can specify a cost 
assignment. 

 

See also: 
Posting to Substitute Cost Centers [Page 561] 

Posting to Fixed Cost Centers [Page 605] 

Posting to Funds Management [Page 635] 
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Posting-Relevant Information in the Payroll Result 
The following tables in the payroll result contain information relevant to posting: 

• The Results Table (RT) contains the wage types saved in the payroll results, with information 
on the rate (RTE), number (NUM), and amount (AMT), as well as the assignments to other 
tables. The assignments to the tables Work Center/Basic Pay (WPBP), Cost Distribution 
(C0), and Cost Assignment from Various Infotypes (C1) play a central role in the posting of 
payroll results. 

• The Work Center/Basic Pay table (WPBP) contains central partial period information from the 
following infotypes (as well as derived information): 

− Actions (0000) 

− Organizational Assignment (0001) 

− Planned Working Time (0007) 

− 

• 

 

Basic Pay (0008) 

The Cost Distribution (CO) table contains information from cost distribution within 
Organizational Management or from the Cost Distribution infotype (0027). The entries in the 
Cost Distribution (CO) table are assigned to entries in the Work Center/Basic Pay (WPBP) 
table.

• The table Cost Distribution from Various Infotypes (C1) contains the cost assignments from 
various infotypes. For a list of the most important infotypes in which you can specify a cost 
assignment, see Posting-Relevant Information from Master Data, Time Data and 
Organizational Management [Page 545]. Those entries in the Results Table (RT) that contain 
wage types that were entered in one of these infotypes with a cost assignment or were 
created from it, link to the relevant entries in the table Cost Distribution from Various 
Infotypes (C1). A prerequisite for this is that the link to the table Cost Distribution from 
Various Infotypes (C1) was not deleted in the payroll calculation rules. 

You can consider the payroll results from various points of view. The following functions are 
available: 

Perspective Function Path 
Employee Remuneration Statement Payroll →Payroll → Remuneration statement 
Department Wage Type Statement Payroll → Information System → Wage Type 

→ Wage Type Statement 
Department Payroll Journal Payroll → Information System → Organizational Unit 

→ Payroll Journal 
Technical Display cluster Rx Payroll → Tools → Display Payroll Results 
When posting to Accounting, the system evaluates the information in the payroll result 
tables for each personnel number in the following way: 

• It determines the posting characteristics defined in Customizing for every wage type 
contained in the Results Table (RT). 

If a wage type should be posted to an expenses account in accordance with Customizing, the 
system checks if the entry for this wage type in the Results Table (RT) links to an entry in the 
table Cost Distribution from Various Infotypes (C1). If this is the case, the system posts the 
wage type amount to this cost assignment. If you have, however, specified that cost 

• 
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assignments from the table Cost Distribution from Various Infotypes (C1) should be ignored 
in the posting characteristics for the wage type, the system does not post the wage type 
amount to the specified cost assignment. 

• If the entry for a wage type in the Results Table (RT) does not link to an entry in the table 
Cost Distribution from Various Infotypes (C1) or the cost assignment specified is ignored 
because of the wage type’s posting characteristics, the system checks if the entry in the 
Results Table (RT) refers to a Partial Period in the Work Center/Basic Pay Table (WPBP) 
[Ext.]. If this is the case this partial period is selected. If this is not the case, the system 
selects the last partial period in the table Work Center/Basic Pay (WPBP). 

• The system checks if a cost distribution in the Cost Distribution (CO) table is specified for the 
period defined in the table Work Center/Basic Pay (WPBP). 

− If this is the case, the system posts the wage type amount on a percentage basis to this 
cost assignment. If a cost assignment of less than 100% is specified in the table Cost 
Distribution (CO), the system posts the remaining amount to the master cost center that 
is specified for the respective partial period in the table Work Center/Basic Pay (WPBP). 

− If this is not the case, the system posts the total wage type amount to the master cost 
center that is specified for the respective partial period in the table Work Center/Basic 
Pay (WPBP). 

• If a wage type is posting-relevant according to Customizing but should not be posted to an 
expenses account, the system checks if the entry for this wage type in the Results Table 
(RT) links to a partial period in the table Work Center/Basic Pay (WPBP). If this is the case 
this partial period is selected. If this is not the case, the system selects the last partial period 
in the table Work Center/Basic Pay (WPBP). The system reads the company code, and if 
necessary, the business area from the defined partial period, and posts the wage type 
amount using this information as a basis. The business area is not taken into consideration 
when posting to customer and vendor accounts. 

Evaluating Tables in the Payroll Result for Posting to Accounting 
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Read wage type from RT

Expenses wage type (acc. to Customizing)?

Cost assignment in C1? Link to partial period from WPBP?

Post to cost assignment Link to partial 
period from WPBP?

Select partial
period

Select last partial
period

Select partial
period

Select last
partial period

Cost distribution for
WPBP partial period in C0?

Post wage type on a 
percentage basis

Is the amount 100 % distributed?

Post total amount to master cost
center from WPBP period

Wage type was 
completely posted

Post remaining amount to master
cost center from WPBP period

Company code and, if necessary, the
business area of the
WPBP partial period

Post wage
type

Yes

Yes

Yes

No

No

Yes No

Yes No

No or  ignored Yes No
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Example: Posting-Relevant Information in the Payroll 
Result 
The following basic conditions apply for an employee: 

• Your employee is assigned to the Central Development master cost center 

• The basic pay is 5,000.00 

• From January 01 – January 15, the employee works for the Product Planning cost center for 
50% of the time and for the master cost center for 50% of the time. 

• From January 16 - January 31, your employee works for the Sales cost center (30%) and for 
the Quality assurance cost center (70%). 

• On January 16, your employee receives a one-off payment of 100.00 from the Training cost 
center. 

This affects the payroll results for the payroll month of January as follows: 

Work Center / Basic Pay Table (WPBP) 

WPBP Partial Period From - To Company Code Master Cost Center 

01 01.01-15.01. 0001 Central development 

02 16.01-31.01. 0001 Central development 

Results Table (RT) 

Wage type WPBP Partial Period Cost Accounting Amount 

Monthly salary (M020) 01  2,400.00 

Monthly salary (M020) 02  2,600.00 

One-off payment (M110) 02 0001 100.00 

Bank transfer (/559)   5,100 

Cost Distribution Table (C0) 

WPBP Partial Period SeqNr Company Code Cost Center Percent 

01 01 0001 Product planning 50 

02 01 0001 Sales and distribution 30 

02 02 0001 Quality assurance 70 

Table of Cost Distribution from Different Infotypes (C1) 

Cost Accounting Company codes Cost center 

0001 0001 Training 

This information in the payroll results tables is evaluated by the Posting to Accounting component 
as follows: 
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Posting Wage Type Monthly Salary (M020) for WPBP Partial Period 01: 
1. The system reads the Monthly Salary wage type (M020) for work center 01 from the results 

table (RT). 

2. The system reads the posting characteristics for the wage type in Customizing and identifies 
that this wage type is to be posted to an expense account. 

3. The system checks whether there is an entry for this wage type in the Cost Distribution from 
Different Infotypes table (C1). This is not the case. 

4. The system checks whether the entry for this wage type in the results table (RT) refers to a 
partial period in the Work Center Basic Pay table (WPBP) and identifies the partial period 
January 01 – January 15. 

5. The system checks whether cost distribution has been specified in the Cost Distribution table 
(C0) for this partial period and identifies a distribution of 50% to the Product Planning cost 
center.  

6. The system posts 50% of the wage type amount to this cost center (1,200 to the Product 
Planning cost center). 

7. The system checks whether the wage type amount has been distributed at 100%. This is not 
the case. For this reason, the system posts the remaining amount (50% = 1,200) to the 
master cost center for the employee (Central Development). The wage type amount is then 
completely posted. 

Posting Wage Type Monthly Salary (M020) for WPBP Partial Period 02: 
1. The system reads the Monthly Salary wage type (M020) for work center 02 from the results 

table (RT). 

2. The system reads the posting characteristics for the wage type in Customizing and identifies 
that this wage type is to be posted to an expense account. 

3. The system checks whether there is an entry for this wage type in the Cost Distribution from 
Different Infotypes table (C1). This is not the case. 

4. The system checks whether the entry for this wage type in the results table (RT) refers to a 
partial period in the Work Center Basic Pay table (WPBP) and identifies the partial period 
January 16 – January 31. 

5. The system checks whether cost distribution has been specified in the Cost Distribution table 
(C0) for this partial period and identifies a distribution of 30 % to the Quality Assurance cost 
center. 

6. The system posts the wage type amount, which is distributed on a percentage basis, to the 
cost centers (780 to the Product Planning cost center and 1,820 to the Quality Assurance 
cost center). 

7. The system checks whether the wage type amount has been distributed at 100%. This is the 
case. The wage type amount is then completely posted. 

Posting the One-Off Payment Wage Type (M110): 
1. The system reads the One-Off Payment wage type (M110) from the results table (RT). 

2. The system reads the posting characteristics for the wage type in Customizing and identifies 
that this wage type is to be posted to an expense account. 
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3. The system checks whether an entry for this wage type exists in the Cost Distribution from 
Different Infotypes table (C1) and identifies that the wage type amount is to be posted to the 
Training cost center. 

4. The system posts the wage type amount to the cost center. 

Posting Bank Transfer Wage Type (/559) 
1. The system reads the Bank Transfer wage type (/559) from the results table (RT). 

2. The system reads the posting characteristics for the wage type in Customizing and identifies 
that this wage type is to be posted to a balance sheet account. 

3. The system checks whether the entry for this wage type in the results table (RT) refers to a 
partial period in the Work Center Basic Pay table (WPBP). This is not the case. The system 
chooses the last partial period in the Work Center/Basic Pay table (WPBP) (16.01 – 31.01). 

4. The system reads the company code 0001 from the partial period for the Work Center/Basic 
Pay table (WPBP) and posts the wage type amount to this company code. 

Posting Documents 
The system creates the following posting document for the described postings: 

Company code 0001 

G/L account Cost Center Debit Credit 

Salaries Product planning 1,200.00  

Salaries Central development 1,200.00  

Salaries Sales and distribution 780.00  

Salaries Quality assurance 1820.00  

Salaries Training 100.00  

Wages and salaries to be paid   5,100.00 
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Account Determination 
Use 
You can use Customizing for Posting to Accounting to determine which wage types are posted, 
and to which Financial Accounting accounts the amount contained in these wage types should be 
posted. If you perform posting to Accounting, the wage types from the payroll results to be posted 
are posted to the assigned accounts. This automatic process is called account determination. 

 
With the help of the report Display Assignment of Wage Types to G/L Accounts 
(RPDKON00) [Ext.], you can specify which wage types are posted to which 
accounts. 

Accounts are determined in the following steps: 

1. The system determines the assigned symbolic account from the wage type. 

2. The assigned Financial Accounting account (G/L account, customer account or vendor 
account) is determined from the symbolic account. 

The two-stage procedure is advantageous since Payroll is separated from the Accounting 
components by the “Symbolic Account” interface. If there are organizational changes in 
Accounting, the symbolic account assignment of the wage types remains unaffected. On the 
other hand, payroll changes do not necessarily cause changes to the account assignment 
settings in the Accounting components. 

Activities 
In Customizing for posting to Accounting, you can assign a G/L account to a symbolic account in 
the following ways: 

• You assign a G/L account to a symbolic account. 

• You assign various G/L accounts to a symbolic account, irrespective of the employee 
grouping for account determination, for example, you assign the G/L account Wages to the 
symbolic account Wages and salaries for industrial workers, and you assign the G/L account 
Salaries to the symbolic account Wages and salaries for salaried employees. 

For account determination to run successfully, you must specify the account assignment type for 
every symbolic account in Payroll Customizing, under Reporting for Posting Payroll Results to 
Accounting → Activities in the HR System → Employee Grouping and Symbolic Accounts 
→ Define Symbolic Accounts. This specifies if the posting is a G/L account posting, a customer 
posting or a vendor posting. 

During account determination, the system determines the relevant account in Financial 
Accounting for every symbolic account using the account assignment type and the value of the 
employee grouping for account determination. 

See also: 
Germany: Account Determination for Specific Service Types in Accordance with the KHBV/PBV 
[Page 630] 
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Document Split Account 
Definition 
An object in Accounting used as a clearing account within posting to Accounting. 

Use 
When posting to Accounting, various situations require the posting data to be split into several 
documents. 

If it is necessary to split documents but a document split account was not set up in the system, 
posting to Accounting cannot take place. For this reason, you should set up a document split 
account and assign the account planned for this purpose, even if it does not appear necessary to 
split documents when the system is introduced. 

You assign a document-split account to the relevant symbolic accounts in Payroll Customizing 
(under Reporting for Posting Payroll Results to Accounting → Activities in the AC System → 
Assign Accounts → Assign Technical Accounts). 

The system splits the document in the following situations: 

• The posting data contains posting records with a different posting date or different posting 
periods. 

• The posting data contains posting records with different company codes. 

• The posting data does not only contain G/L account postings but also payable/receivable 
postings. 

• Document split control that is stored in the posting variant used requires you to split the 
documents. 

• The size of the posting data makes it necessary to split the documents. 

If the system splits documents in one of these situations, the posting items do not always have a 
balance of zero. If the balance of the posting items for a document is not equal to zero, an item 
for the relevant posting to the document split account is added to this document in order to clear 
the balance of this document. 

If you use business areas [Ext.] in Financial Accounting, the system makes sure that the balance 
within a G/L account document is zero for each business area when posting to Accounting. To do 
so, the system adds postings to the document split account under specification of the business 
area. Thus, the document split account is only posted to if the document has not been split but 
the balance of the posting items has not been cleared for each business area. 
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Posting Retroactive Accounting Data 
Use 
When posting retroactive accounting data, the posting run for the previous payroll result is 
reversed (posting with reversed sign) and the new payroll result is posted for the payroll periods 
accounted retroactively. 

The summarization of posting information performed in posting to Accounting has the following 
effect when posting retroactive accounting data: 

• If only the amount changes, the difference is posted. 

If the account assignment objects also change, the amount in the old account assignment 
objects is cancelled and posted to the new ones. 

• 

At the time of posting, Financial Accounting has usually closed the previous posting periods 
[Page 560]. For this reason, the retroactive accounting data is posted in the posting period that 
belongs to the current payroll period (with the exception of posting to special periods [Page 607]). 

If, at the time of posting retroactive data, the previous payroll result for the retroactively 
accounted period was already posted in Accounting, the system does not evaluate this payroll 
result a second time using Customizing to reverse the posting. Instead, the system evaluates the 
posting run that was created for this payroll result. In the process it determines 

• Which wage types were posted 

• Which symbolic accounts were used 

• With which account assignment type the posting took place 

• With which Employee grouping for the account determination this posting took place 

• Which entries from the payroll results tables (for example, table WPBP, C0, C1) were 
evaluated 

The system reverses the posting using this information. 

See also: 

• Example: Posting Retroactive Accounting Data [Page 556] 

Recalculation Differences [Page 558] • 

• Retroactive Accounting [Page 48] 
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Example: Posting Retroactive Accounting Runs 
In period 1, an employee receives monthly remuneration of 5,000. In period 2, basic 
remuneration is increased retroactively to 6,000 for period 1 and all subsequent periods.  

The following graphic shows only the basic wage types that are relevant in posting: 

• Since wage type /560 (Net Pay) is not posted, the posting-relevant wage type /559 (Bank 
Transfer) is taken into account for the payment. 

• No other payments or deductions are taken into consideration. The payment amount (wage 
type /559 Bank Transfer) therefore represents the monthly remuneration for the employee 
(wage type M020). 

I 01/2000 IN 01/2000

01/2000 IN 02/2000

M020
/559

5,000
5,000

M020
/559
/551

6,000
5,000

- 1,000

02/2000 IN 02/2000

M020
/552
/559

6,000
1,000
7,000

In February 2000, 
employee receives 
retroactive salary 
increase of 1,000  
from January 01, 2000

II

III
7,000

Salary W&S payable
7,000

Recal.diff.account

Sal. Jan. old - 5,000
Sal. Jan. new +6,000
Sal. Feb. new +6,000
Sal.   7,000
Pymt Jan. old - 5,000
Pymt Jan. new +6,000
Pymt Feb. new +6,000
Pymt   7,000
Recalc. Jan. new - 1,000
Recalc. Feb. new +1,000
Recalc. diff.          0,-

 

Part I: Consideration of Payroll Results 
In period 01, the monthly salary for the employee is 5,000 (wage type M020). This amount is paid 
out to the employee (wage type /559 Bank Transfer) 

As a result of the retroactive accounting run, a new payroll result is created in period 02 for 
period 01. In this result, the basic remuneration is increased to the new agreed amount of 6,000 
(M020). The payment amount in period 01 remains unchanged (wage type /559 Bank Transfer) 
The difference of 1,000 is recorded in the separate wage type /551 Recalculation Difference.  

In period 2, the employee receives 7,000 (wage type /559 Bank Transfer). This is due to the 
retroactive remuneration increase. This amount consists of the monthly salary for period 2 (wage 
type M020 = 6,000) and the retroactive salary increase for period 1 (wage type /552 
Subs.clearing/prev.month = 1,000). 

 
If the tax is calculated according to the principle of origin, wage types /551 
Recalculation Difference and /552 Subs.clearing/prev.month are formed when 
retroactive differences are created. However, if the tax is calculated according to the 
inflow principle, other wage types may be relevant to posting with regard to 
retroactive differences either instead of or in addition to these wage types. 
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Part II: Consideration of Postings 
When this retroactive run is posted, the posting for payroll result period 01 in period 01 is 
reversed. In this way, the posting of wage type M020 creates a balance of 7,000, which is posted 
to the debit side of the remuneration account as an expense. The posting of the payment amount 
(wage type /559) creates a balance of 7,000, which is posted to the credit side of the Payments 
account as a payable. In the posting, the amounts for wage types /551 and /552 create a balance 
of zero. Therefore, no posting is created from these recalculation differences. 

Part III: Consideration of Accounts 
7,000 are posted to the debit side of the Remuneration account. 7,000 are posted to the credit 
side of the Payments account. There is no posting to the recalculation difference account. A 
retroactive run can, for example, trigger a posting to the recalculation difference account if 
several company codes are affected by the retroactive run. 

See also: 
Recalculation Differences [Page 558] 
Cross-Company Code Transactions [Page 609] 
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Recalculation Differences 
Use 
Creation of Recalculation Differences in Payroll 
In retroactive runs, the amounts of the Payment Amount wage type /560 are not changed. The 
system calculates a new payment amount for the previous period; however; it does not save this 
amount. Instead, it creates the amount for the Recalculation Difference wage type (/551) from the 
difference between this amount and the original payment amount. 

The system saves this amount in the results table (RT) from the new payroll results for the period 
recalculated and transfers it to wage type /552 Subs.clearing/prev.month for the current period. 
The system stores the amount for wage type /552 (Subs.clearing/prev.month) in the results table 
(RT) from the original results for the current period. 

Wage types /551 (Recalculation Difference) and /552 (Subs.clearing/prev.month) have opposite 
positive (+)/negative (-) signs: 

Change Sign /551 Recalculation 
Difference 

Sign for /552 
Subs.clearing/prev.month 

A remuneration element for an 
employee is increased 
retroactively 

Negative Positive 

A remuneration element for an 
employee is reduced 
retroactively 

Positive Negative 

Posting Recalculation Differences 
When the system posts the payroll results to Accounting, it checks that the balance of the single 
items to be posted is zero for each employee and payroll result. For this reason, you must code 
the wage types /551 (Recalculation Difference) and /552 (Subs.clearing/prev.month) as relevant 
to posting in Customizing. If you fail to do so, the balance per payroll result will not be zero if 
recalculation differences occur, as you cannot change the amount for wage type /559 Bank 
Transfer retroactively. 

 
Wage type /560 Payment Amount is not taken into account by the evaluation for 
posting to Accounting. Only wage type /559 (Bank Transfer) is relevant for posting. 

Due to the opposite positive/negative signs, the total of wage types /551 (Recalculation 
Difference) and /552 (Subs.clearing/prev.month) is zero for the employee. For this reason, these 
wage types do not usually create a posting, even though they are coded as relevant for posting. 
However, this does not apply if company code clearing is not used, and a retroactive run 
including the period before the employee changed company code is carried out after a change in 
company code. For more information and an example of posting, see Retroactive Accounting for 
Summary Clearing [Page 613]. Other exceptions are retroactive runs over the end of the fiscal 
year and posting to special periods. 

We recommend that you set up a different clearing account in Accounting for posting 
recalculation differences. This clearing account should not be used for any other postings. 
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If the tax is calculated according to the principle of origin, wage types /551 
Recalculation Difference and /552 Subs.clearing/prev.month are formed when 
retroactive differences are created. However, if tax is calculated according to the 
inflow principle, other wage types may be relevant to postings concerning retroactive 
differences (either instead of or in addition to these wage types). 

See also: 
Posting Retroactive Accounting Data [Page 555] 

Example: Posting Retroactive Accounting Runs [Page 556] 

Prerequisites 
You must set up the system correctly in Payroll Customizing, under Reporting for Posting Payroll 
Results to Accounting, to ensure that recalculation differences are posted correctly to 
Accounting. 

• You must define a symbolic account for recalculation differences (under Activities in the HR 
System → Employee Grouping and Symbolic Accounts → Define Symbolic Accounts) 

• You must assign the symbolic account for recalculation differences to the corresponding 
wage types (under Activities in the HR System → Maintain Wage Types → Define Posting 
Characteristics of Wage Types) 

• You must assign a balance sheet account from Accounting to the symbolic account (under 
Activities in AC System→ Assigning Accounts → Assign Balance Sheet Accounts) 
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Posting Period and Posting Date 
The system usually determines the posting date from the current payroll period. As a result, 
retroactive accounting runs are also posted with the posting date that originates from the current 
payroll period. Posting to Special Periods [Page 607] is an exception to this rule. 

The Accounting components determine the posting period that is posted to, from the posting 
date. 

Use 
You have the following options for specifying the posting date: 

• Using the relevant settings in the table of date specifications for a specific period in Payroll 
Customizing, under Reporting for Posting Payroll Results to Accounting → Activities in the 
HR System → Maintain the Posting Date for Payroll Periods 

• By manual entry in the step Create posting run in the Specifications for posting date group 
box 

By setting the Acc.to payment indicator in the step Create posting run in the Posting date 
specification group box. However, use of the payment date, as a posting date is only useful 
in countries in which the payment date is given a relevant meaning (for example, USA, 
Canada, Japan). 

• 

In some countries, payroll periods and posting periods can have different lengths. If the start and 
finish of a payroll period are in different posting periods for a weekly payroll run, it is necessary to 
distribute the expense from this payroll period (proportionally) to two posting periods. In some 
countries, this is possible with the help of the Month-End Accruals [Page 516] function. 
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Posting to Substitute Cost Centers 
Use 
Particularly for objects such as orders or projects to which can only be posted for a limited period 
of time, or after a change in the cost center structure, it may not be possible to post to certain 
account assignment objects in cost accounting.  

In this case, the system posts to the master cost center instead, which is set in the infotype 
Organizational Assignment (0001). This master cost center is determined from the last partial 
period from the table Work Center/Basic Pay (WPBP) for the current payroll result. 

If this master cost center is in a different company code, or cannot be posted to, the system posts 
to a substitute cost center. 

The system logs the substitution of account assignment objects in the document. You must 
check these substitutions and perform manual postings after executing posting to Accounting if 
the expense should not remain in the account assignment objects determined on a substitution 
basis. 

Prerequisites 
You must have set up the substitute cost center in cost accounting, and assigned it in Payroll 
Customizing (under Reporting for Posting Payroll Results to Accounting → Activities in AC 
system → Assign Substitute Cost Centers). 
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Substitution Logic for Closed CO Account Assignment 
Objects 
Purpose 
The substitution logic for closed CO account assignment objects assumes that you manually 
repost posting items, which the system posts to the substitute cost centers, to other account 
assignment objects. This will be explained in the following example. 

 
An employee gets a salary of 5,000 and changes his/her master cost center on the 
1st January 2000 (from the cost center Special Development to the cost center 
Training). The cost center Special Development is closed as of 31st December 1999. 
By mistake, you do not enter the employee’s change of cost center in the master 
data before completing payroll for period 01 in 2000. For this reason, the 
Workplace/Basic Pay (WPBP) table in the payroll results 01 in 01 contains the 
Special Development cost center. 

Process Flow 
Posting for Payroll Period 01 
1. As it is not possible to post to the Special Development cost center, the system posts the 

expense of 5,000 (for the employee’s salary) to the substitute cost center [Page 561] that you 
have specified in Customizing. 

2. The system documents the substitution of the account assignment object in the posting 
document to remind you that you must manually repost the expense of 5,000 from the 
substitute cost center to the employee’s new master cost center (Training). 

3. You perform the reposting. 

Retrospective Change in Master Data and Retroactive Accounting 
1. Following the payroll run for period 01/2000, you enter the change in cost center in the 

employee’s master data. 

2. This change in master data leads to a retroactive accounting run in period 02/2000. The 
Workplace/Basic Pay (WPBP) table in the payroll results 01 in 02 contains the correct 
Training cost center. 

Posting for Payroll Period 02 
The system compares the payroll results 01 in 01 and 01 in 02 and (because of the change in 
cost center) tries to cancel the amount of 5,000 on the cost center for the result 01 in 01 (Special 
Development) and post it to the cost center for the result 01 in 02 (Training). However, as the 
cost center Special Development is closed, the system uses the current master cost center 
(Training), which it determines from the last partial period in the table Workplace/Basic Pay 
(WPBP) for the current payroll result (02 in 02). 

1. The system thus cancels the amount of 5,000 on the Training cost center. 

2. The system also posts the amount of 5,000 to the Training cost center. 
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3. When checking the posting documents [Page 571] you realize that these two postings cancel 
each other out and that the amount of 5,000, which you manually posted to the Training cost 
center remains in this cost center. 

Result 

 
If you would not repost manually after posting the payroll results 01/2000, the system 
would still perform the same postings to the Training cost center when posting the 
payroll results 02/2000. In this case, the expense of 5,000 would remain on the 
substitute cost center and the expense of 5,000 for the salary that the employee 
received in the payroll period 01/2000 would be missing on the Training cost center. 

The following table shows an overview of which posting you must perform in this example and 
which postings are made by the system. To keep the explanation simple, posting the salary for 
period 02/2000 is not taken into consideration. 

Posting for Payroll 
Period  

Cost Center 
Special 
Development 

Cost Center 
Training 

Substitute 
cost centers 

Posting 
performed by 

01   + 5,000 the system 

01  + 5,000 - 5,000 the user 

02  - 5,000  the system 

02  + 5,000  the system 

 

Total  + 5,000 0  
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Steps 
You can use the Steps unit 

• To inform yourself, at a glance, which steps you must carry out to perform the posting [Page 
565]  

• To call detailed descriptions of these steps 

• To gain information on steps within posting, which you only need to perform in certain 
situations (for example, deleting a posting run, reversing posting documents) 
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Performing the Posting 
Purpose 
Posting to Accounting includes the evaluation of the payroll results, the creation of summarized 
documents and posting them in the Accounting components. 

The documents created in posting to Accounting contain summarized information. However, 
provided you have authorization, you can trace back which information (from the payroll results) 
the posting documents are based on for a specific personnel number. 

If documents have been posted with an incorrect posting date, you can also reverse [Page 585] a 
posting run. 

You can also archive the data created in posting to Accounting. For more information, see 
Archiving Posting Documents (PY-XX-DT) [Ext.] and Archiving Index Files (PY-XX-DT) [Ext.]. 

Prerequisites 
You have successfully run payroll. 

Process Flow 
When posting to Accounting, you carry out the following activities: 

1. Simulating a Posting Run 

2. Creating A Posting Run 

3. Checking a Posting Run 

4. Checking the Posting Documents 

5. Releasing Posting Documents 

6. Posting Posting Documents 

7. Checking Accounting Documents 

8. Checking the Completeness of the Postings 

9. Subsequent Activities in Financial Accounting 

Result 
You have posted the personnel expenses and payables to the accounts and account assignment 
objects in the Accounting components. 
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Simulating a Posting Run 
Use 
We recommend that you simulate a posting run both before and after completing payroll. In this 
way, you can recognize posting-relevant errors in the payroll results early on, and avoid errors 
when creating a live posting run. 

You can repeat simulation of posting runs as often as you require, as this does not, unlike 
creating a live posting run, lead to the payroll results being selected. 

You have two options for simulating a posting run: 

• Creating a test run without posting documents (limited check). The system performs the 
following activities: 

− It selects the payroll results. 

− It determines the posting-relevant information and the wage types to be posted. 

− It determines the symbolic accounts and the employee grouping for account 
determination. 

In this way, the system creates individual items, which, unlike the posting documents for 
a simulation run, are not saved. The system finally checks if the balance of these 
individual items is equal to zero for each payroll result. 

• Creating a simulation run with posting documents (complete posting). The system performs 
the following activities: 

− It creates a posting run and marks it as being a simulation run. For this reason, the 
system does not post the posting documents for this posting run. 

− The posting documents are put through the same checks as the posting documents from 
a live posting run. 

Simulating A Posting Run before Finishing Payroll 
Before completing payroll, you should create a simulation run to recognize posting-relevant 
errors in the payroll result early on. If you do not want to create a simulation run at this stage, you 
should at least create a test run. 

Simulating A Posting Run after Finishing Payroll 
After finishing payroll, you should create a simulation run in order to check the posting 
documents (this may have to be approved by Accounting). Remove any possible causes of 
errors and repeat creation of the simulation run, until technically correct posting documents with 
the right contents are created. You should only create a live posting run at this point in time. 

Procedure 
You proceed as described in creating a posting run [Page 568]. When doing so, bear the 
following special feature in mind: 

• If you want to create a test run, enter the value T in the field Document creation type (in the 
Run attribute group box).  
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• If you want to create a simulation run, enter the value S in the field Document creation type 
(in the Run attribute group box).  

 
If you want to have a complete log of a number of personnel numbers (selected for 
test purposes) that is easy to keep track of, set the Display log indicator in the Run 
attribute group box. We advise you against creating a complete log for a larger 
number of personnel numbers. Even if you do not set the Display log indicator, the 
system produces a log if there are errors for the personnel numbers affected. 

Result if Successful 
In the case of test runs, the system displays a detailed log if you have set the Display log 
indicator in the step Create posting run. If you have not set the Display log indicator, the system 
displays statistics for the evaluated personnel numbers. 

In the case of simulation runs, the system creates a posting run and marks it as a simulation 
run. This prevents the accompanying posting documents being posted. The simulation run gets 
the status Documents created and is saved. The accompanying posting documents get the 
status created. An index is created for all processed payroll results. This ensures that the origin 
of a document item can be retraced, provided that the original payroll result has not been 
replaced as the result of a correction run. For more information, see Displaying Revision 
information [Page 584] 

Result if Unsuccessful 
In the case of test runs, the system displays a log containing the relevant error messages. 

In the case of simulation runs, various errors can occur: 

• If an error occurs when selecting or processing the payroll results for individual employees, 
the system rejects the incorrect personnel numbers and does not include them in the 
document. The log contains a relevant error message. 

• If an error occurs when creating the document, a relevant error message appears in the 
document display after the document has been created. The posting run gets the status 
Documents incorrect. The accompanying posting documents get the status incorrect. 

• Certain situations in which an error occurs (for example, rejection of all personnel numbers) 
can lead to no documents being created. In this case, the log contains the comment No 
documents created. The posting run gets deleted status. 

 
Delete the simulation runs you no longer require to avoid creating unnecessarily 
large amounts of data. For more information, see deleting the posting run [Page 580] 
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Creating a Posting Run 
Use 
After completing Payroll, you must create a live posting run to post the personnel expenses and 
payables to the accounts and account assignment objects in the Accounting components. 

Before creating a live posting run you should have created a simulation run [Page 566] with 
technically correct posting documents containing the correct information. 

Prerequisites 
You must have successfully run payroll for the personnel numbers, for which the payroll results 
should be evaluated for posting. 

Payroll must have been completed for all payroll areas affected by posting. 

A simulation run, with technically correct posting documents containing the correct information 
should have been created.  

Procedure 
1. Choose Human Resources → Payroll → Subsequent activities → Per payroll period → 

Posting to Accounting → Execute run. 

2. To select the payroll period, you enter the payroll area and choose . 

The current payroll period is displayed. 

If you want to evaluate a different payroll period to the current period, choose Other 
period and enter the period you require. 

6. In the Document creation data group, specify the posting variant you require or copy the 
standard entry. 

3. Make the necessary entries in the Selection group. Entering the payroll area usually makes 
the selection. 

4. Enter the value P in the field Type of document creation. 

5. You can enter a Text for the posting run. You can choose this text yourself. It helps identify 
the posting run in the overview of posting runs. 

7. Only make settings for the options described in the following table in special cases. 

8. To create the posting run, choose . 

Controlling the Evaluation Report in Special Cases 

Option Explanation 

Off-Cycle Payroll If you want to evaluate the results of an Off-Cycle Payroll Run [Page 
], enter the necessary data. Off-Cycle payroll runs only take place 

in certain countries. 
130
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Display log If you set this indicator, after creating the posting run the system 
displays a log that contains detailed information, for example, the 
wage types evaluated for posting, for every personnel number for 
which payroll was performed. Only set this indicator if you want to 
process an easily comprehensible range of personnel numbers. The 
creation of a log for large numbers of personnel numbers requires a 
lot of memory space and is not recommended. If you do not set the 
Display log indicator, errors that occurred when creating the posting 
run are still displayed in a log for specific personnel numbers. 

Cost planning If you want to provide the results of the evaluation report as data for 
personnel cost planning [Page 64 ]9 , choose Cost Planning and make 
the necessary entries. 

Default value for posting 
date group box 

Here, you can specify the posting date [Page 560] or make further 
entries for posting for special periods [Page 60 ]7 . You should flag the 
Acc. to period definition indicator for regular posting runs. 

Document date You can enter a Document date in the Document creation data group 
box. If you do not enter a document date, the system uses the date 
on which the posting documents were created, therefore the current 
system date. 

Result if Successful 
If you have set the Display log indicator, the system displays a detailed log. If you have not set 
the Display log indicator, the system displays statistics for the evaluated personnel numbers. 

The posting run created gets the status Documents created and is saved. It has a clear number. 
The accompanying posting documents get the status created. 

An index of all processed payroll results is created. This makes it possible to trace creation of a 
document item although the documents have been summarized. 

The system selects the processed payroll results to ensure that they are only posted once. 

Result if Unsuccessful 
The following errors can occur when creating a posting run: 

• If an error occurs when selecting or processing the payroll results for individual employees, 
the system rejects the incorrect personnel numbers and does not include them in the 
document. The log contains a relevant error message. 

• If an error occurs when creating the document, a relevant error message appears in the 
document display after the document has been created. The posting run gets the status 
Documents incorrect. The accompanying posting documents get the status incorrect. 

Certain situations in which an error occurs (for example, rejection of all personnel numbers) 
can lead to no documents being created. In this case, the log contains the comment No 
documents created. The posting run gets deleted status. 

• 

For more information on the treatment of errors in posting, see unselected or incorrect personnel 
numbers [Page 652]. 
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Checking a Posting Run 
Use 
After you have created the posting run, make sure that no errors occurred. 

Prerequisites 
You have performed the step creating a posting run [Page 568].  

Procedure 
Go to the document overview [Page 577] and check the status of the relevant posting run. 

Posting run status Meaning (for live posting runs) 

Documents created You have successfully created a posting run and can continue 
processing the posting run. 

Incorrect documents You must remove the error, delete the posting run and create 
a new posting run. 

Deleted When creating the posting run, the system rejected all the 
personnel numbers and did not create any documents. You 
must remove the error and create a new posting run. 

Selection is running 

Document creation is triggered 

Document creation is running 

Creation of the posting run is still running. It is also possible 
that the system interrupted creation of the posting run after the 
payroll results for individual personnel numbers were selected. 
In this case, you must delete the posting run and create a new 
posting run. 

For notes on causes of errors, see the display of the posting documents for a posting run. The 
display of the history, attributes and details of a posting run can provide further indications of 
causes of errors. To view this, select the posting run in the overview of posting runs, then choose 
Go to and the relevant menu option. 

See also: 
Checking the Completeness of the Postings [Page 575] 
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Checking the Posting Documents 
Use 
If you have performed the step Check posting run, you should check the posting documents for 
the posting run in question. 

Prerequisites 
You have created a posting run. 

Procedure 
1. In the document display [Page 583], you check the line items in the posting documents 

created. 

2. If necessary, check the revision information [Page 584] for the individual line items. 

If a posting run contains one or more incorrect posting documents, the system cannot post the 
correct posting documents, as it is only possible to post all the posting documents belonging to a 
posting run at the same time. 

Therefore, if you discover errors when checking the posting documents, you must delete the 
posting run in question and create and check a new posting run, after removing the cause of the 
problem. 

If the posting documents are correct, you can release them. 
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Releasing Posting Documents 
Use 
If, when checking a live posting run and the accompanying posting documents, you establish that 
all posting documents are technically correct and contain the right contents, you can post the 
posting documents. To do so, you must first of all release all posting documents for the posting 
run. 

Procedure 
1. Display the posting documents for a posting run in the document overview. 

2. Select the posting documents that you want to release. 

3. Choose . 

A dialog box appears in which you must confirm the release of the posting documents. 

4. Choose Yes to release the posting documents or No to terminate the process. 

Result 
The released posting documents have the status Released. If you have released all posting 
documents for a posting run, the posting run has the status All documents released. 

You should not reset the release status. If you find errors in a posting run after releasing the 
posting documents, you must delete it and create a new posting run. 

Additional Information 

You can grant authorization for the release of posting documents for every company code for 
another person. 

However, another authorization is necessary for posting the documents. This authorization is not 
assigned for each company code, as it is only possible to post all posting documents for a 
posting run (which may belong to different company codes) at the same time. Posting posting 
documents should therefore be seen as a technical step, as the person responsible for the 
individual company codes has already given their approval for posting the posting documents by 
releasing them. 

You can set up a workflow for the release of posting documents. The 
PayrollAccDocument.Release method from the business object BUS7009 is used in this 
workflow. In Customizing, choose Basis → Business Management → SAP Business Workflow → 
Perform Task-Specific Customizing, and from there, choose the following path from the 
component hierarchy under Payroll → Payroll: General Parts → Transfer, to make settings for the 
task Release posting document. 

The standard task PY_EVDOCREL is provided as a model. When this event is triggered, the task 
sends a work item containing the above method.  

For general information on workflows, see the SAP Business Workflow (BC-BMT-WFM) [Ext.]. 
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Posting Posting Documents 
Use 
After you have released all the posting documents for a posting run, and the posting run thus has 
the status All documents released, you can post the posting documents. 

You must post all the posting documents belonging to a posting run together in the Accounting 
components. Individual posting documents cannot be posted. 

Prerequisites 
The posting run has the status All documents released. 

Procedure 
1. Go to the overview of posting runs. 

2. Select the required posting runs. 

3. Choose . 

A dialog box is displayed, in which you must confirm that you want to post the posting 
documents for the selected posting runs. 

4. Choose Immediately or Create job, to start the reversal or  Cancel, to cancel the reversal.  

Result if Successful 
If you use Human Resources and Accounting in the same system, the posting documents were 
posted in the components affected in Accounting. The posting run has the status Documents 
posted. 

If you use Human Resources and Accounting in separate systems, posting does not take place 
simultaneously in the Accounting components. The system creates Idocs for the posting 
documents for a posting run. The posting run gets the status Documents transferred. The Idocs 
are sent to the logical system, in which the posting documents should be posted, using the ALE 
interface. When processing the Idoc in the target system, the posting documents are posted in 
the Accounting components affected. 

If agreed with Accounting, you can reverse posting documents [Page 585] that have been 
posted, if this is necessary because of an error in the contents. 

Result if Unsuccessful 
The posting run has the status Document transfer has failed. Posting to Accounting did not take 
place. 

Depending on the error that occurred, it may be a good idea to start posting this posting run once 
again. If the error still occurs and it is not possible to post the posting run, you must delete the 
posting run and create a new one. 

 

April 2001  573 



Payroll United States (PY-US)  SAP AG 

Checking Accounting Documents 

Checking Accounting Documents 
Use 
The Accounting components create their own posting documents based on the summarized 
posting documents. You should check these documents after you have posted the posting 
documents for a posting run. 

Prerequisites 
• The relevant posting run has the status Documents posted when Payroll and Accounting are 

in one system. 

• The relevant posting run has the status Documents posted when Payroll and Accounting are 
in distributed (separate) systems. 

Procedure 
1. Go to the document overview. 

2. Select the posting document you require. 

3. Choose Goto  → Accounting documents. 

A dialog box appears with a list of the accounting documents created. 

4. Selected the accounting document you require. 

Result 
You see the document that the specified Accounting component has created. 

For more information, see Accounting Documents Were Not Created [Page 653] 
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Checking the Completeness of the Postings 
Use 
When checking a posting run or after you have posted the posting documents for one or several 
posting runs, you can use the completeness check to make sure that all employees that were 
included in the payroll run were taken into consideration when reporting for posting to 
Accounting. 

During the completeness check, the system checks if all the existing payroll results were 
evaluated for posting to Accounting and therefore selected.  

  
During this check, the system possibly processes very large amounts of data. It can 
therefore be time-consuming and put pressure on the system. 

Procedure 
1. In Payroll, choose Subsequent Activities → Per Payroll Period  → Posting to Accounting → 

Completeness Check.  

2. Enter a date, from which the completeness of the posting should be checked and choose . 
During the check, all the payroll results are checked that were created after the date 
specified. 

 
Bear in mind that this check can only be made for payroll results that have been 
included in a payroll run and posted with an R/3 system of 4.0A or above. 

Result 
The system displays a list of the following information: 

• Existing payroll rules that were not evaluated for posting to Accounting. 

• Live posting runs that do not have any of the following statuses: 

− Transferred 

− Posted 

− Deleted 

− Reversed 

− Archived 

− Partially archived 
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Subsequent Activities in Financial Accounting 
Use 
After performing posting to Accounting, you should perform certain reconciliation tasks and 
checks in Accounting. 

Prerequisites 
You have performed posting to Accounting and successfully posted the posting documents in the 
relevant Accounting components. 

Procedure 
For example, in Financial Accounting, the following steps are amongst the checks to be made: 

• Comparison of transferred and posted payables. 

• Checking of the retention amount for advances. 

• Checking of the retention amount for claims. 

• Clearing the cross-company-code activities: 
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Displaying an Overview of the Posting Runs 
Use 
In the overview of posting runs you can display a list of all available posting runs. 

After you have created a posting run, the posting run overview is the starting point for all other 
actions that you perform with reference to the posting run: 

• 

• Checking a posting run 

• Posting posting documents 

• Reversing posting documents 

• Deleting a posting run 

• Changing or creating text for a posting run 

Manually setting the status of a posting run to posted 

The SAP list viewer [Ext.] is used to display the posting runs. It offers a wide range of functions 
(for example, layouts, sort functions), which you can use to modify the display to meet your 
requirements. 

Procedure 
Choose Payroll → Payroll → Subs.Activities → Per Payroll Period → Evaluation → Posting to 
Accounting → Edit Run. 

To go from the log display to the posting run overview after creating a posting run, choose 
Posting run overview. 

Result 
You access the posting run overview. In the standard system, the display is limited to posting 
runs that have not been posted yet using a filter. If you want to see the posting runs that have 
already been posted, you must delete the filter [Ext.]. 
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Changing or Creating a Text for a Posting Run 
Use 
To identify the posting runs it is useful, particularly when creating posting runs in background 
processing, to enter a descriptive text for the individual posting runs. In the standard system, this 
text is displayed in the posting run overview in the column Run text. 

Procedure 
Creating a Text before Creating the Posting Run 
Enter the desired text in the Posting run text field in the Run attributes group box in the selection 
screen of the program Create posting run before executing the program. 

Creating or Changing a Text after Creating the Posting Run 
1. Go to the overview of posting runs. 

2. Select the posting run whose text you want to change. 

3. Choose Edit  → Change name 

4. Enter the desired name or make changes and choose . 
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Displaying the Attributes of a Posting Run 
Use 
You can use the attributes of a posting run to, amongst other things, access the information that 
is displayed as statistics after creating the posting run, in other words, the number of selected, 
evaluated, rejected and missed out personnel numbers. 

For more information on posting run attributes, see the Posting Run Documentation [Page 529]. 

Procedure 
1. Go to the overview of posting runs. 

2. Select the required posting run. 

3. Choose Goto → Run attribute. 
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Deleting a Posting Run 
Use 
If, before posting a live posting run, you realize that it contains errors (either technical, or in the 
contents), you must create this posting run a second time. As the system has selected the payroll 
results that were evaluated in this posting run, you must delete the posting run to remove 
selection of the payroll results. It is only then possible for the system to evaluate the relevant 
payroll results a second time for posting to Accounting. 

If you no longer require simulation runs for test purposes, it is a good idea to delete them. 

Prerequisites 
If you want to delete a posting run, it should not have any of the following statuses: 

• Documents transferred 

• Documents posted 

• Reversal documents transferred 

• Reversal documents posted 

• Reversal document creation is running 

• Reversal documents created 

• Reversal is running 

• Reversal was unsuccessful 

• Reversal documents are incorrect 

• Partially archived 

• Archived 

Procedure 
1. Go to the overview of posting runs. 

2. Select the posting runs you want to delete. 

3. Choose . 

A dialog box appears in which you must confirm the deletion procedure. 

4. Choose Immediately or Create job, to start the reversal or  Cancel, to cancel.  

Result 
The result of the deletion procedure depends if you delete a live posting run or a simulation run. 

• If you delete a live posting run, the posting documents and index remain. The status of the 
posting run is set to Deleted. Selection of the payroll results is cancelled. This makes it 
possible for the system to evaluate these payroll results a second time for the creation of a 
live posting run. 
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If you delete a simulation run, the index and document lines are deleted. The status of the 
simulation run is set to Deleted. Only the document header remains.  

• 

You can delete the data from deleted live runs or simulation runs that is still on the database after 
this step, in a subsequent run within Archiving [Ext.].  
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Displaying the Document Overview 
Use 
In the document overview, you can display which posting documents belong to one or more 
posting runs. 

Procedure 
Go to the overview of posting runs. 

• To see the posting documents for a posting run, double-click on the posting run required 
in the document overview. 

• To see the posting documents for several posting runs, select the posting runs and 
choose . 
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Displaying Posting Documents 
Use 
In the document display, you can display the document line items for one or more posting 
documents. 

Procedure 
Go to the document overview. 

• To display the document line items for a posting run, double-click on the posting run 
required in the document display.  

• To display the posting documents for several posting runs, select the posting runs and 
choose . 
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Displaying Revision Information 
An important part of posting to Accounting is the ability to retrace individual line items. This is 
particularly important if a revision is required. In this case the following occurs: 

• Postings are carried out in a summarized form, meaning that the Accounting components are 
only provided with the information that they require. 

• This prevents unauthorized persons from accessing personal data. 

• You can still retrace postings at any time, as the system creates an index of the processed 
payroll results when summarizing the posting data within posting to Accounting. Special 
authorization allows you to retrace the document line items back to the payroll results for the 
employee. 

 
The Vacation bonus cost type was posted to a cost center in a payroll period where 
payment of the vacation bonus was not expected. You want to find out which 
employee and wage type formed the basis for this posting. 

Procedure 
Go to the document display [Page 583]for the document that you want to check. 

• To see the revision information for a document line item, double-click on the document 
line item you require in the revision information display. 

• To display the revision information for several document line items, select the document 
line item and choose . 

Check the information displayed for wage types, personnel numbers, payroll periods, accounts, 
account assignment objects, and so on. 

For an overview of the wage types contained in the employee’s payroll result, double-click on a 
line in the revision information. 

To hide all the wage types that are not posted in this overview, choose Only posted wage types. 

To return to the full display of wage types, choose all wage types.  
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Reversal of Posting Documents 
Use 
If you have successfully posted posting documents and realize that the posted data is incorrect, 
you can reverse all documents for the posting run in question. You cannot reverse individual 
posting documents for a posting run. The system uses the same posting run to administer 
posting documents and reversal documents.  

Reversal of Posting Documents 
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The graphic shows the relationship between posting documents from Human Resources (HR) 
and the documents from Accounting after a reversal. 

The Accounting components use the posting documents as original documents. The Accounting 
components have created their own documents based on these original documents. 

To reverse these accounting documents you must first of all create reversal documents in Human 
Resources that then serve as original documents for the reversal documents from Accounting. 

After a reversal, there is a relevant reversal document for each posting document and each 
accounting document. The reversal documents contain all the document line items from the 
documents to be reversed with a reversed sign. 

 
The reversal documents from Human Resources contain a link to the accompanying 
posting documents. However, the reversal documents from Accounting do not 
contain a link to the accompanying accounting documents. 
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Activities 
Reversing posting documents [Page 587] 

Resetting the reversal after termination [Page 655] 
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Reversing Posting Documents 
Use 
If you have successfully posted posting documents and realize that the posted data is incorrect, 
you can reverse all documents for the posting run in question. 

See also: 
Reversal of posting documents [Page 585] 

Prerequisites 
• You have successfully posted the posting documents for a posting run. The posting run has 

one of the following statuses: 

− Documents transferred 

− Documents posted 

• It is initially not possible to reverse posting documents if payroll results were processed for 
which retroactive accounting runs took place and the results of these runs have already been 
processed in a live posting run. In this case, you must firstly reverse or delete the posting 
documents from the posting runs with retroactive accounting, and finally reverse the posting 
documents from the incorrect posting run. 

• Accounting has approved the reversal. 

• The system should not have used any line items from the documents created in Accounting 
for clearing. 

• It must be possible to post the reversal documents (for example, the relevant CO account 
assignments should not yet be closed). 

Procedure 
1. Go to the overview of posting runs. If the posting run, whose posting documents you want to 

reverse, is not displayed, choose Edit → Filter → Delete filter. 

2. Select the required posting run. 

3. Choose Edit → Reverse  → Reverse documents. 

4. A dialog box appears, in which you must enter information on the reversal date: 

− Choose Yes, to copy the respective posting date of the original documents as the 
reversal date. A posting run can contain posting documents with different posting dates. 

− Choose No, to enter a different reversal date. If you enter a different posting date, it must 
be after the posting date for the original documents. 

 
You can determine the posting date of the posting documents in the document 
overview. 

5. To start the reversal, choose Immediately or Create job, or choose  Cancel to cancel the 
reversal. 
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The system prints a log that informs you on the success of the reversal.  

Result if Successful 
• Reversal documents are created containing all document line items for the original 

documents with reversed plus/minus (+/-) signs. 

• The reversal documents were transferred to Accounting and posted there. This cancels the 
original, incorrect posting. 

• The selection of accompanying payroll results was reset. 

• Links to the reversed posting documents were inserted in the reversal documents. You can 
see this by showing the Reversal documents column in the document overview. 

You must create a new posting run in order to repost the payroll results, which were processed in 
the posting run whose posting documents you have reversed, in their corrected state. 

Result if Unsuccessful 
For information on the steps that you must perform if the reversal process is terminated due to an 
error, see Resetting the Reversal after Termination [Page 655].  
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Displaying the Status History 
Use 
The system automatically creates a status history for posting runs and posting documents to log 
the actions performed with the date, time and person responsible. You can display this status 
history. 

Procedure 
Displaying the Status History for a Posting Run 
1. Go to the overview of posting runs. 

2. Select the required posting run. 

3. Choose Goto  → Run history. 

Displaying the Status History for a Posting Document 
1. Go to the document overview. 

2. Select the posting document you require. 

3. Choose Goto  → Document history. 
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Displaying Detailed Information 
Use 
You can access detailed information on posting runs, posting documents and document items. 

Whereas fields can be hidden in the list display, in the detailed information the system displays 
the contents of all the fields containing data. 

Procedure 
Displaying Detailed Information for a Posting Run 
1. Go to the overview of posting runs. 

2. Select the posting run you require. 

3. Choose Goto  → Display details. 

Displaying Detailed Information for a Posting Document 
1. Go to the document overview. 

2. Select the posting document you require. 

3. Choose Goto  → Display details. 

Displaying Detailed Information for a Document Item 
1. Go to the document display. 

2. Selection the document item you require. 

3. Choose Goto  → Display details. 
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Posting in Previous Releases 
It is still possible to post to Accounting if Payroll or Accounting is in an R/3 system with a release 
status of 4.0A or below, or is in an R/2 system.  When performing posting to Accounting, only the 
functions available in both release statuses are supported.  
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Posting from HR Systems < 4.0  
Use 
It is still possible to post to Accounting if Accounting is in an R/3 system with a release status of 
4.0A or above and Payroll is in an R/3 system with a release status below 4.0A or is in an R/2 
system. 

When posting to Accounting, only the functions available in both release statuses are supported. 
In the following, the most important functions and restrictions are named: 

In Financial Accounting (FI) you have the option of summarized posting [Page 60 ]4 . • 

When posting to fixed cost centers [Page 605], you can specify the fixed cost center for each 
business area. 

• 

• In the case of CO account assignments, which cannot be posted to, the system posts to the 
substitute cost center [Page 561]. Substitution takes place using the substitute cost center 
and not the master cost center. The master cost center is not provided in this constellation of 
the HR system. 

Prerequisites 
• Accounting is situated in a central system, along with all the components. 

• The Accounting master data (for example, cost centers to which you want to post) must be 
available in the HR system. 

Procedure 
In order to post from HR systems with a release status lower than 4.0A, you must create a 
TemSe file, from which posting documents are created, after completing payroll in the Accounting 
system (AC-system). You have two options for creating this TemSe file: 

• Using a file transfer 

• Using an ALE business process (using IDocs in the HR system) 

 
If you want to use ALE technology for this purpose, you must make the relevant 
settings in ALE Customizing. 

If the HR system has a release status lower than 3.1G, you can only post using a file transfer. 

 Posting Using a File Transfer 
Steps in the HR System (Sending System) 
1. Start the report Payroll program <Country> (RPCALCx0) with the payroll schema x500. 

The HR system evaluates the payroll results and writes the posting-relevant information 
to a TemSe file. 

2. Start the report Transfer to Accounting: Export to R/2 or R/3 Release < 4.0 (RPCIPX00). 

The HR system creates a second modified TemSe file from the first TemSe file. 
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3. Start the report Posting to Accounting: Transfer Program for RPCIPX00 and RPCIPI00 
(RPCIPT00). 

The HR system creates a work file on the presentation or application server from the 
second TemSe file. 

Steps in the AC System (Receiving System) 
4. Start the report Posting to Accounting: Transfer Program for RPCIPX00 and RPCIPI00 

(RPCIPT00), to further process the file created by the HR system. 

The AC system creates a TemSe file. 

5. Start the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00). 

The AC system creates posting documents from the data for the TemSe file. These 
documents are grouped together in one posting run. 

6. Check the posting run [Page 570] 

7. Check the posting documents [Page 57 ]1  

During this procedure, consider that revision information is not available in this 
constellation. For more information, see using revision information [Page 595]. 

8. Release the posting documents [Page 572]. 

9. Post the posting documents [Page 573] 

Posting Using an ALE Business Process 
Steps in the HR System (Sending System) 
1. Start the report Payroll program <Country> (RPCALCx0) with the payroll schema x500. 

The HR system evaluates the payroll results and writes the posting-relevant information 
to a TemSe file. 

2. Start the report Transfer to Accounting: Export to R/2 or R/3 Release <4.0 (RPCIPX00). 

− The HR system creates a master Idoc from the TemSe file. 

− The HR system uses the Customizing for the distribution model to determine from which 
logical system the Idoc should be received. 

− The data is transferred to the AC system via the ALE layer. Inbound processing takes 
place there. When doing so, the AC system creates a TemSe file from the data in the 
Idoc received. 

Steps in the AC System (Receiving System) 
3. Start the report Transfer to Accounting: Import from R/2 or R/3 < 4.0. 

The AC system creates posting documents from the data for the TemSe file. These 
documents are grouped together in one posting run. 

Check the posting run [Page 570] 4. 

Check the posting documents [Page 571] 5. 

During this procedure, consider that revision information is not available in this 
constellation. For more information, see using revision information [Page 595]. 

6. Release the posting documents [Page 572]. 
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7. Post the posting documents [Page 573] 

Consider that this ALE business process has the following restrictions: 

The TemSe objects created are not defined as application objects. For this reason, the 
system does not update links between the TemSe object and the Idoc. 

• 

• The system does not support serialization [Ext.]. 

• In connection with the prerequisite already mentioned, that the Accounting master data must 
be available in the HR system, the restriction that not all account assignment objects can be 
distributed using ALE applies for ALE scenarios. 

Result 
The payroll results were transferred and posted to the Accounting components. 
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Using Revision Information 
Use 
When posting from HR systems with a release status lower than 4.0A to AC systems, with a 
release status from 4.0A onwards, it is not possible to access revision information (personnel 
numbers and wage types) for the documents created using the report Transfer to Accounting: 
Import from R/2 or  R/3 < 4.0 (RPCIPI00). If you want to use the revision information in this 
situation, you must perform further steps as well as the actual posting procedure. 

Prerequisites 
To be able to use the revision information in the combination of systems mentioned, you must 
store the assignment of symbolic accounts to Accounting accounts in both the HR system and 
the AC system. To do so, you make the relevant settings in Payroll Customizing under Transfer 
to FI/CO → Symbolic Accounts. 

Procedure 
1. Start the report Payroll program <Land> (RPCALCx0) with the payroll schema x500. Set the 

Activate revision indicator. 

The HR system writes the posting-relevant information, as well as the personnel 
numbers and wage types, to a TemSe file. 

2. Start the report Interface Payroll/Accounting (RPCIPO00), to process the TemSe file created. 

3. Make the necessary entries in the selection screen of the report. 

4. Set the Revision tool on? indicator 

5. Do not set the indicator Create batch-Input? 

The HR system creates a list containing the information required. 
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Posting to AC Systems < 4.0  
 

Use 
It is still possible to post to Accounting if Human Resources is in an R/3 system with a release 
status of 4.0A or above, and Accounting is in an R/3 system with a release status lower than 
4.0A, or is in an R/2 system. 

When posting to Accounting, only the functions available in both release statuses are supported. 
The most important functions and restrictions are named in the following: 

• You can repeat creation of the TemSe file. To do so, you must delete live posting runs. If you 
manually set the status of the posting run to posted in the HR system, in the last step, it is not 
possible to repeat the creation of the TemSe file. 

• It is possible to post to fixed cost centers; however, it is not possible to post using the 
business area as a basis. 

• In Financial Accounting (FI), the system can perform a summarized posting if the AC system 
has a release status of 3.0A or above. For this purpose, you must specify the clearing cost 
center in the AC system in Payroll Customizing under Transfer to FI/CO → Concluding 
Activities → Maintain Clearing Cost Centers. Before starting the report Transfer to 
Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00), set the Assign clearing cost center 
indicator. 

• In the case of closed cost centers, the system does not post to the substitute cost center. 

Prerequisites 
• Accounting is located in a central system, along with all the components. 

• You have specified the company codes that are in the AC system with a release status below 
4.0 in Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → 
Special Scenarios → Posting in Previous Releases → Set Up Export to R/2 System or R/3 
System < 4.0. 

• The Accounting master data (for example, the cost centers to which you want to post) must 
be available in the HR system. 

Procedure 
To post to AC systems with a release status lower than 4.0A, you must create a batch-input 
session after completing payroll in the AC system. 

If the AC system has a release status of 3.1G or above, you have two options for performing the 
posting. 

• Using an ALE business process (using IDocs in the HR system) 

• Using a file transfer 

 
If you want to use ALE technology for this purpose, you must make the relevant 
settings in ALE Customizing. 
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If the HR system has a release status lower than 3.1G, you can only post using a file transfer. 

 Posting Using a File Transfer 
Steps in the HR System (Sending System) 
1. Perform the step creating a posting run [Page 568]. We recommend that you only create live 

posting runs even if this is not absolutely necessary in the current constellation. If you want to 
use the revision information, set the indicator Revision help Export R/3 3.x. If you enter a text 
for the posting run, the first ten characters of this text form the last ten characters of the 
name of the TemSe file. If you do not enter a text for the posting run, a number is generated 
for the last ten characters of the name of the TemSe file. 

The HR system evaluates the payroll results and writes the posting-relevant information 
to a TemSe file. 

2. Start the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPX00). 

The HR system creates another TemSe file. 

3. Start the report Posting to Accounting: Transfer Program for RPCIPX00 and RPCIPI00 
(RPCIPT00). 

The HR system creates a work file on the presentation or application server. 

Steps in the AC System (Receiving System) 
4. To further process the file created by the HR system, start the report Posting to Accounting: 

Transfer Program for RPCIPX00 and RPCIPI00 (RPCIPT00). 

The AC system creates a TemSe file. 

5. Start the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00). 

The AC system creates batch-input sessions from the data in the TemSe file for the 
transaction Post Document (FB01) and for the transaction Enter Reposting of Primary 
Costs (KB11), if required. 

6. Post the payroll results by processing the batch input session. 

7. Select the posting run created in the overview of posting runs in the HR system. Choose Edit 
→ In old releases → Manually set to posted. 

Be aware of the following special feature in this step: You must not manually set the 
posting run to posted if posting documents and the TemSe file exist for this posting run, 
as the company codes exist in another AC system with release status 4.0A or higher. In 
this case, you must release the posting documents [Page 572] in the HR system and 
finally post [Page 57 ]3 . 

Posting Using an ALE Business Process 
Steps in the HR System (Sending System) 
1. Perform the step creating a posting run [Page 568]. We recommend that you only post live 

posting runs even if it is possible to post simulation runs [Page 56 ]6  in the current 
constellation. If you want to use the revision information, set the indicator Revision help 
Export R/3 3.x. If you enter a text for the posting run, the first ten characters of this text form 
the last ten characters of the name of the TemSe file. If you do not enter a text for the posting 
run, a number is generated for the last ten characters of the name of the TemSe file. 

April 2001  597 



Payroll United States (PY-US)  SAP AG 

Posting to AC Systems < 4.0 

The HR system evaluates the payroll results and writes the posting-relevant information 
to a TemSe file. 

2. Start the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPX00). 

5. 

• The HR system creates a master Idoc from the TemSe file. 

• The HR system uses Customizing for the distribution model to determine from which 
logical system the Idoc should be received. 

• The data is transferred to the AC system via the ALE layer. Inbound processing 
takes place here. When doing so, the AC system creates a TemSe file from the data 
in the Idoc it has received. 

Steps in the AC System (Receiving System) 
3. Start the report Transfer to Accounting: Import from R/2 or R/3 < 4.0 (RPCIPI00). 

The AC system creates batch-input sessions from the data in the TemSe file for the 
transaction Post Document (FB01) and, if necessary, for the transaction Enter Reposting 
of Primary Costs (KB11). 

4. Post the payroll results by processing the batch input session. 

Select the posting run created in the overview of posting runs in the HR system. Choose Edit 
→ In old releases → Manually set to posted. 

Be aware of the following special feature of this step: You must not manually set the 
posting run to posted if posting documents and the TemSe file exist for this posting run, 
as the company codes are in another AC system with release status 4.0A or higher. In 
this case, you must release the posting documents [Page 572] in the HR system and 
finally post [Page 57 ]3 . 

Bear in mind that this ALE business process has the following restrictions: 

The TemSe objects created are not defined as application objects. For this reason, the 
system does not update links between the TemSe object and the Idoc. 

• 

• The system does not support serialization [Ext.]. 

• In connection with the prerequisite already mentioned, (that the Accounting master data must 
be available in the HR system), the restriction that the system is unable to distribute all the 
account assignment objects using ALE applies for ALE scenarios. 

Result 
The payroll results were transferred and posted to the Accounting components. 
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Special Business Requirements for Posting 
You can use the section Special Business Requirements for Posting 

• To get a more detailed overview of the functions of Posting to Accounting 

• To gain information on the way in which the system supports your special business 
requirements 
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Posting with Personnel Numbers 
Use 
If wage types are posted to balance sheet accounts, in particular cases, you can reduce the time 
spent on checking within Financial Accounting. Posting using personnel numbers and setting the 
accounts in such a way that they can be cleared automatically does this. 

 
The use of personnel numbers when posting payroll results is only planned for 
balance sheet accounts, and not for expense accounts, customer or vendor 
accounts. 

See also: 
Example: Posting Using Personnel Numbers [Page 601] 

Further Information on Clearing Accounts [Ext.] 
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Example: Posting Using Personnel Numbers 
Advances are paid to the cash office. In Financial Accounting, the system makes a respective 
Advances to cash office posting. The personnel number is assigned to the posting to the 
advances account. 

By entering an Advance wage type in the master data for the employee affected, the system 
makes a net deduction (to the amount of the advance) within payroll, and posts it to the advance 
account when posting to Accounting. 

You can check the retained advance payments using a list that is generated together with the 
wage type statement. 

If posting to the advance account is based on personnel numbers, Financial Accounting can 
automatically clear this account, as shown in the following graphic: 
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Posting to Customer and Vendor Accounts 
Use 
When posting to expenses and payables accounts, the G/L account is always derived from the 
symbolic account, and, if necessary, from the Employee Grouping for Account Determination. 

When posting to customer and vendor accounts, you have two possibilities for controlling 
account determination: 

• If you want to use fixed customer and vendor accounts, you can directly assign the number 
of the customer or vendor account to a symbolic account and, if necessary, an employee 
grouping. 

• If you want to run customer and vendor accounts on an employee basis, you can set the 
system in such a way that the personnel numbers are also included in account determination. 

 
It is not possible to use the special general ledger indicator when posting to customer 
and vendor accounts. 

See also: 
Example: Posting to Customer Accounts for Employees [Page 60 ]3  

Assign Customer Accounts [Ext.] 

Assign Vendor Accounts [Ext.] 

Assign Customer Accounts for Loan-Specific Posting [Ext.] 

Prerequisites 
You have made the necessary settings in Payroll Customizing, under → Reporting for Posting 
Payroll Results to Accounting → Activities in AC System → Assign Accounts. 
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Example: Posting to Customer Accounts for Employees 
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The graphic shows how the system posts the repayment of company loans to customer accounts 
for employees. 

The employees Murphy, Miller and Smith were all granted a company loan. Each of these 
employees has their own customer account in Financial Accounting. In Human Resources, a 
symbolic account is used for the repayment of employee loans in Customizing. 

The system does not assign this symbolic account a customer account number in Customizing 
for posting to Accounting, but assigns a code which takes the personnel numbers into account 
when determining the account. 

In this way, a symbolic account is used in Human Resources Customizing for the repayments 
specified in the example, however, in Accounting, the system still posts to individual customer 
accounts for employees. 

When posting to these customer accounts, the system automatically posts to the reconciliation 
account assigned to the customer in the general ledger. 
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Summarization in the Accounting Components 
Use 
When posting payroll results to Accounting, it is sometimes useful to have documents in 
Accounting, which are as small as possible. These documents should be summarized using CO 
account assignments while detailed information on the CO account assignments should be 
available to Controlling. This is necessary in the following situations, for example: 

• You should remove the information you do not require from Financial Accounting. 

Due to the longer retention periods for posting documents in Accounting, smaller 
documents should be created. 

• Accounting should not have access to certain detailed information, for example, when 
posting to cost centers that were set up for individual employees. 

You can meet these requirements with the help of Document Summarization for Overhead 
Costs-Controlling in Accounting. 

For information on document summarization in Controlling and Funds Management, see 
. 

Posting 
with Position Management [Page 645]

Prerequisites 
To use document summarization in Financial Accounting for posting the payroll results, you must 
make the relevant settings for HRPAY in Customizing for Financial Accounting, under (General 
Ledger Accounting → Business Transactions → Integration → Overhead Cost Controlling → 
Carry Out Document Summarization in Overhead Cost Controlling). 
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Posting to Fixed Cost Centers 
Use 
In certain situations it is useful to post particular cost accounting wage types to fixed cost centers 
or to orders, instead of to the employee’s master cost center or to another specified cost 
assignment. This is known as Posting to a Fixed Cost Center or Posting to Fixed Orders or 
Standard Orders. 

Posting to a fixed cost center is usually necessary if directly assigning costs to an employee’s 
master cost center would be incorrect from the cost accounting point of view. By posting to a 
fixed cost center or to a standard order, the Controlling (CO) department receives the costs in a 
summarized form, separate from the amounts assigned directly. Repostings can then be 
performed within Controlling, according to other criteria, for example, the number of employees 
or total remuneration. 

 
• Decrease in expenses to the Canteen cost center 

• The employer’s contribution to social insurance and capital formation payments 

• Flat-rate taxes paid by the employer 

• Vacation bonus with accrual calculation in Controlling 

• Holiday bonus with accrual calculation in Controlling 

Prerequisites 
You have set up posting to fixed cost centers in Payroll Customizing (under Reporting for Posting 
Payroll Results to Accounting → Activities in the AC System → Set Up Fixed Cost Postings). 

See also:
 

 
Example: Posting Without and With a Fixed Cost Center [Page 606]
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Example: Posting With or Without a Fixed Cost Center 
Posting data 

Account Cost center Amount
430000 Salaries  711 1,000.00
435000 Annual bonus 711 200.00
  
430000 Salaries  712 1,200.00
435000 Annual bonus 712 400.00

 

Cost centers without a fixed cost center 

Cost center Cost type Amount
711 430000 1,000.00
711 435000 200.00

712 430000 1,200.00
712 435000 400.00

 

Cost centers with fixed cost center 99 for cost element 435000 

Cost center Cost type Amount
711 430000 1,000.00
712 430000 1,200.00

99 435000 600.00
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Posting to Special Periods 
Use 
If retroactive runs affect the previous fiscal year, you follow a different procedure than described 
in the section  In this case, the last general 
posting period is usually already finished. However, posting to special periods in the old fiscal 
year is sometimes still possible, and usually necessary. This process in called posting to special 
periods. You can trigger posting to special periods when starting posting to Accounting. 

Posting Retroactive Accounting Data [Page 555]

The number and duration of posting periods and special periods are defined within Financial 
Accounting using fiscal year variants assigned to the company codes. There are usually twelve 
regular posting periods which, for example, correspond to the calendar months, and four special 
periods. If the fiscal year has been moved, and in other special cases, the number and dates of 
the posting periods will be different to this case. 

 
If retroactive accounting runs affect the fiscal year that precedes the previous fiscal 
year, the resulting data is also posted to the special periods for the previous fiscal 
year. 

See also: 
Example: Posting to Special Periods [Page 608] 
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Example: Posting to Special Periods 
In this example, the fiscal year is made up of 12 regular posting periods, which correspond to the 
calendar months. In this example, period 13 is a special period. 

Posting retroactive accounting data
at the end of the fiscal year

Posting retroactive accounting data within 
the fiscal year

Backdated pay
increase from December 01,1999
in January 2000

Backdated pay 
increase from April 01, 1999
in May 1999

5,000 5,000

1,000 1,000

Amounts to be paid are not included in
the example.

Posting period 13/1999

SalariesSalaries
1,000

Clearing
1,000

W&S to be paidW&S to be paid

Jan. 2000

May 1999

Salaries
6,000  7,000

 7,000  7,000

Clearing
1,000

W&S to be paid

 
The right side of the graphic shows a retroactive accounting run that was triggered by a 
backdated pay increase affecting the previous fiscal year. As a comparison, the left-hand side 
shows posting a comparable retroactive accounting run during the fiscal year. 

In January 2000, an employee gets a backdated pay increase for December 01 1999. 

The system posts the pay increase of 1,000 to the credit side of the Salaries account for the 
special period 13/1999. The offsetting posting in the special period 13/1999 is made to the credit 
side of a clearing account, to which the system posts the  of 
1,000. 

recalculation difference [Page 558]

In the current posting period, (01/2000), the system posts the regular salary of 6,000 to the debit 
side of the Salaries account and posts the recalculation difference of 1,000 to the debit side of a 
clearing account. This is offset by posting 7,000 to the account Wages and salaries to be paid in 
the current posting period. 
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Cross-Company Code Transactions 
Use 
Several company codes can be involved in a payroll run for an employee. In such a cross-
company code transaction, receivables and payables can arise between company codes. 

In the following situations, cross-company code transactions occur: 

• An employee works for several company codes (because of proportional assignment or 
change of company code within a payroll period) within a payroll period. 

• After an employee has changed company code, retroactive accounting is performed for the 
time before the change of company code. 

• An employee changes company code retrospectively. 

You can clear the receivables and payables that may arise in these three cases, either on a 
summarized basis or using company code clearing accounts. 

Prerequisites 
You have made the necessary settings in Payroll Customizing, under Reporting for Posting 
Payroll Results to Accounting → Activities in HR System → Posting Variants. For the posting 
variant you use, the Post to company code clearing accounts indicator must  

• not be set, if you want to use summary clearing [Page 610] 

• be set, if you want to use  clearing using company code clearing accounts [Page 610]
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Summary Clearing 
Use 
If the Post to company code clearing accounts indicator is not set in Customizing for the posting 
variant you use, when cross-company code transactions take place, this results in balances on 
the document-split accounts, the recalculation difference account or the payment accounts. 
These balances illustrate receivables or payables between the company codes. 

You can only use summary clearing if balancing the receivables and payables between the 
company codes involved is permitted and if it is also sufficient to explain the receivables and 
payables between the company codes from the procedure only. 

Prerequisites 
To use summary clearing, you must make sure that the Post to company code clearing accounts 
indicator is not set for the posting variant that you use. You make these settings in Payroll 
Customizing, under → Reporting for Posting Payroll Results to Accounting → Activities in AC 
System → Create Posting Variants). 
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Proportional Assignment to Several Company Codes 
within a Payroll Period with Summary Clearing 
Use 
If an employee works for several company codes within a payroll period, the expenses incurred 
are distributed to these company codes on a proportional basis. However, the system assigns 
the relevant payables to the company code in which the master cost center is located to which 
the employee was assigned on the last day in the payroll period. 

In this way, receivables and payables arise between the company codes, which appear as 
balances on the document split accounts. 

• 

In the following cases, an employee is assigned to several company codes on a proportional 
basis: 

• The employee changes company code during a payroll period. 

• You have specified a percentage cost distribution to several company codes for the 
employee in the Cost Distribution infotype (0027) or in Organizational Management. 

You have specified a different cost assignment for individual wage elements for the 
employee, which contains a different company code. 

You can find more information on cost distribution and cost assignment under 
. 

Posting-relevant 
Information from Master Data, Time Data and Organizational Management [Page 545]

The graphic shows an example of an employee who works for two company codes. To simplify 
the explanation, no other payments or deductions are taken into consideration in this example. 

 

 

 

In this example, the following expenses incur during posting: 

• Company code 0001: 7,000  

• Company code 0002: 3.000  

The payables of 10,000 are posted to company code 0001. 

Consequently, the document-split accounts are not cleared in both company codes. 

• The balance of the document-split account for company code 0001 shows a receivable of 
3,000 against company code 0002. 

• The balance of the document-split account for company code 0002 shows a receivable of 
3,000 against company code 0001. 

Activities 
The balances of the document-split accounts correspond to the receivables and payables 
between the company codes. 

You must manually clear the receivables and payables between the company codes. When 
doing so, you also clear the balances of the document-split accounts. 
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Retroactive Accounting for Summary Clearing 
Use 
If an employee changes company code and, for example, after the change receives a backdated 
pay increase which also affects the time before the change, receivables and payables incur 
between the two company codes. 

Although the relevant expenses wage type changes for the period for which retroactive 
accounting is run, the amount to be paid to the employee remains the same. The payment 
amount firstly changes in the current period so that the system transfers the payments that the 
old company code must make because of the backdated pay increase from the new company 
code. 

In this way, receivables and payables incur between the company codes that appear as balances 
on the recalculation difference account. 

The graphic shows the case where an employee changes from company code 0001 to company 
code 0003 at the start of period 02. In period 02, his/her monthly salary is increased by 1.000 for 
period 01.  

Wage types Documents

Accounts

CoCde WT Amount
0001 M020 Monthly salary 5,000
0001 /559 Bank transfer 5,000

0001 M020 Monthly salary 6,000
0001 /559 Bank transfer 5,000
0001 /551 Recalc.diff. -1,000

0003 M020 Monthly salary 6,000
0003 /552 Subs.clearing 1,000
0003 /559 Bank transfer 7,000

Period

01 in 01 {
01 in 02 

02 in 02 {

{

Remuneration
0001

1,000

Remuneration
0003

6,000

Payment
0003

7,000

Payment
0001

Receivables and payables

0001
Remun.                              1,000
Recalculation differences 1,000

0

0003
Remun.                               6,000
Payment
Recalc.differences              1,000

7,000

0

Recalc.difference account

           0001                          0003
1,000             1,000

 
In period 01, the employee receives a monthly salary of 5,000 (wage type M020). This amount is 
also paid to the employee (wage type /559) as no other payments and deductions are taken into 
account in this example. 

In period 02, the employee gets a monthly salary of 6,000 for period 02 (wage type M020) as well 
as a backdated pay increase of 1,000 for period 01. 

In this way, expenses of 1,000 incur in company code 0001. The payment amount is not 
increased retrospectively for period 01, but is transferred to the current period using the wage 
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types /551 Recalculation difference and /552 Subsequent clearing from previous period instead. 
The expense of 1,000 in company code is thus offset by a recalculation difference of 1,000 that is 
posted to the credit side of the recalculation difference account. 

A payment amount of 7,000 incurs for the current period in company code 0003; this amount is 
made up of the increased salary of 6,000 and the subsequent clearing of 1,000 from the previous 
month. This amount is posted to the Payment account in credit. This is offset by an expense of 
6,000 that is posted to the debit side of the Remuneration account, as well as a recalculation 
difference of 1,000 that is posted in the debit side of the recalculation difference account for 
company code 0003. 

Consequently, the recalculation difference accounts are not cleared in both company codes. 

• The balance of the recalculation difference account for company code 0001 shows a payable 
of 1.000 from company code 0003.  

• The balance of the document-split account for company code 0003 shows a receivable of 
1.000 from company code 0001. 

 
If, in Payroll Customizing under Reporting for Posting Payroll Results to Accounting -
> Activities in HR System -> Employee Grouping and Symbolic Accounts ->Define 
Symbolic Accounts, you code the symbolic account to which the wage types /551 
Recalculation difference and /552 Subsequent clearing from previous period are 
assigned with the account assignment type FL Balance sheet account for checking 
the balance in the case of retroactive accounting data, the balance incurs on the 
document split account instead. 

Activities 
The balances of the recalculation difference accounts correspond to the receivables and 
payables between the company codes. 

You must manually clear the receivables and payables between the company codes. When 
doing so, you also clear the balances of the recalculation difference accounts. 
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Retroactive Accounting in Several Company Codes with 
Summary Clearing 
Use 
If an employee is retrospectively assigned to another company code, retroactive accounting is 
triggered. Posting of this retroactive accounting run happens in the following way: 

• Posting of the old payroll results from the retroactively accounted period is reversed in the old 
company code. 

• The new payroll result from the retroactively accounted period is posted in the new company 
code. 

Reversal in the old company code and the posting in the new company code also affect the 
accounts for the outgoing accounts. As the payment can no longer be cancelled, the balances of 
the outgoing accounts are subsequently no longer balanced. 

The graphic shows an example for the case of an employee who has retrospectively changed 
company code. To simplify matters, the assumption is made that the company code has changed 
retrospectively for the whole period 01. 

Wage types Documents

Accounts

CoCde WT Amount
0001 M020 Monthly salary 5,000
0001 /559 Bank transfer 5,000

0003 M020 Monthly salary 5,000
0003 /559 Bank transfer 5,000

0003 M020 Monthly salary 5,000
0003 /559 Bank transfer 5,000

Period

01 in 01 {
01 in 02 

02 in 02 {

{

Remuneration
0001

5,000

Remuneration
0003

10,000

Payment
0003

5,000 10,000
You must clear the payment accounts!
This example also contains the posting
Payment to bank clearing account.

Bank clearing account

           0001                          0003
5,000

0001
Remuneration
Payment                              5,000

5,000

0

0003
Remun.                             10,000
Payment 10,000

0

Payment
0001

5,000
*5,000

* original posting in period 01

*5,000*5,000 *.5000

 
Originally, an amount of 5,000 was posted from the Remuneration account to the Outgoing 
payment account in period 01 in company code 0001. After making the payment, the Payment 
account was cleared to the amount of 5,000 by the manual posting Payment to company code 
clearing account. 

The backdated change of company code for the employee from company code 0001 to company 
code 0003 causes the Remuneration to outgoing posting to the amount of 5,000 to be reversed 
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in company code 0001 and posted in company code 0003.  As the payment to the employee has, 
however, already been made and was made by company code 0001, a receivable of 5,000 from 
company code 0001 incurs against company code 0003. 

After making the payment in period 02, the outgoing accounts in both company codes are not 
cleared. 

• The balance of the outgoing account for company code 0001 shows a receivable of 
5,000 against company code 0003.  

• The balance of the outgoing account for company code 0003 shows a payable of 5,000 
against company code 0001. 

 
If you code the symbolic account to which the wage type /559 Bank transfer is 
assigned with the account assignment type FO Balance sheet account in original 
period only (in Customizing for Payroll under Reporting for Posting Payroll Results to 
Accounting -> Employee Grouping and Symbolic Accounts -> Define symbolic 
accounts), the balances do not arise in the outgoing accounts but in the document 
split accounts. 

Activities 
The balances of the outgoing accounts correspond to the receivables and payables between the 
company codes. 

You must manually clear the receivables and payables between the company codes. When 
doing so, you also clear the balances of the outgoing accounts. 
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Clearing Using Company Code Clearing Accounts 
Use 
If the Post to company code clearing accounts indicator is set in Customizing for the posting 
variant that you use, when cross-company code transactions take place, this results in balances 
on the company code clearing accounts. These balances illustrate receivables or payables 
between the company codes. 

In this way, the company code clearing accounts exactly show which receivables or payables 
exist between the individual company codes. 

You can only use clearing using company code clearing accounts if the company codes in your 
enterprise only illustrate parts of a legal unit meaning that clearing can take place without any 
difficulties. If this prerequisite is not met, you cannot make any entries that lead to cross-
company code transactions, unless other activities take place in Financial Accounting (for 
example, issuing an invoice, correcting group turnover). 

Prerequisites 
To use summary clearing, you must make sure that the Post to company code clearing accounts 
indicator is set for the posting variant that you use. You make these settings in Payroll 
Customizing, (under → Reporting for Posting Payroll Results to Accounting → Activities in HR 
System → Create Posting Variants). 

You have created the company code clearing accounts required in Customizing for Financial 
Accounting, under General Ledger Accounting → Business Transactions → Cross-Company 
Code Transactions. 
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Proportional Assignment to Several Company Codes 
within a Payroll Period when using Company Code 
Clearing Accounts 
Use 
If an employee works for several company codes within a payroll period, the expenses incurred 
are distributed to these company codes on a proportional basis. However, the system assigns 
the relevant payables to the company code in which the master cost center is located to which 
the employee was assigned on the last day in the payroll period. 

In this way, receivables and payables incur between the company codes. They appear as 
balances on the company code clearing accounts. 

In the following cases, an employee is proportionally assigned to several company codes: 

• 

• The employee changes company code during a payroll period.  

• You have specified a percentage cost distribution to several cost centers for the employee in 
the Cost Distribution infotype (0027) or in Organizational Management. 

You have specified a different cost assignment for individual wage elements for the 
employee. This cost assignment contains a different company code. 

You can find more information on cost distribution and cost assignment under Posting-Relevant 
Information from Master Data, Time Data and Organizational Management [Page 545]. 

The graphic shows an example of an employee who works for two company codes. To simplify 
the explanation, no other payments or deductions are taken into consideration in this example. 
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Wage type Documents

Accounts

Employee is paid by company code
0001, but works for company code 0002
on a proportional basis

CoCde WT Amount
0001 M020 Monthly salary 7,000
0002 M020 Monthly salary 3,000
0001 /559 Bank transfer      10,000

0001
Remun.                            7,000
Payment
Receivable to 0002          3,000

10,000

0

0002
Remun.                             3,000
Payable to 0001 3,000

0

Remuneration
0001

7,000

Payment
0001

10,000

Receivable to 0002
0001

3,000

Remuneration
0002

3,000

Payment
0002

You must clear the company
code clearing accounts!

Payable to 0001
0002

3,000

 
In this example, the following expenses incur during posting: 

• Company code 0001: 7,000  

• Company code 0002: 3.000  

The payables of 10,000 are posted to company code 0001. 

The receivables and payables between the company codes are paid to the company code 
clearing accounts set up for this purpose. 

• The balance of the company code clearing accounts for company code 0001 shows a 
receivable of 3,000 from company code 0002.  

• The balance of the company code clearing accounts for company code 0002 shows a 
receivable of 3,000 from company code 0001. 

Activities 
The balances of the company code clearing accounts correspond to the receivables and 
payables between the company codes. 

You must manually clear the receivables and payables between the company codes. When 
doing so, you also clear the balances of the company code clearing accounts. 
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Retroactive Accounting in Several Company Codes - 
Clearing Using Company Code Clearing Accounts 
Use 
If an employee changes company code and, for example, after the change receives a backdated 
pay increase which also affects the time before the change, receivables and payables incur 
between the two company codes. 

Although the relevant expenses wage type changes for the period for which retroactive 
accounting is run, the amount to be paid to the employee remains the same. The payment 
amount firstly changes in the current period so that the system transfers the payments that the 
old company code must make because of the backdated pay increase from the new company 
code. 

In this way, receivables and payables incur between the company codes. They appear as 
balances on the company code clearing accounts. 

The graphic shows the case where an employee changes from company code 0001 to company 
code 0003 at the start of period 02. In period 02, his/her monthly salary is increased by 1,000 for 
period 01.  

 

Wage Types Documents

Accounts

CoCde WT Amount
0001 M020 Monthly salary 5,000
0001 /559 Bank transfer 5,000

0001 M020 Monthly salary 6,000
0001 /559 Bank transfer 5,000
0001 /551 Recalc.difference -1,000

0003 M020 Monthly salary 6,000
0003 /552 Subs.clearing 1,000
0003 /559 Bank transfer 7,000

Period

01 in 01 {
01 in 02 

02 in 02 {

{

0001
Rem.                               1,000
Payable to 0003 1,000

0

0003
Rem.                               6,000
Payment
Receivable to 0001         1,000

7,000

0

Remuneration
0001

1,000

Pay. to 0003
0001

1,000

Remuneration
0003

6,000

Payment
0003

7,000

Rec. to 0001
0003

1,000

Payment
0001

Recalc.difference account

               0001                 0003

You must clear the
company code clearing
accounts!

 
 

In period 01, the employee receives a monthly salary of 5,000 (wage type M020). This amount is 
also paid to the employee (wage type /559) as no other payments and deductions are taken into 
account in this example. 
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In period 02, the employee gets a monthly salary of 6,000 for period 02 (wage type M020) as well 
as a backdated pay increase of 1,000 for period 01. 

In this way, expenses of 1,000 incur in company code 0001. The payment amount is not 
increased retroactively for period 01, but is transferred to the current period instead using the 
wage types /551 Recalculation difference and /552 Subsequent clearing from previous period. 
The payable against company code 0003 of 1,000 offsets the expense of 1,000 in company code 
0001.  

A payment amount of 7,000 incurs for the current period in company code 0003; this amount is 
made up of the increased salary of 6,000 and the subsequent clearing of 1,000 from the previous 
month. This amount is posted to the Payment account in credit. This is offset by an expense of 
6,000 that is posted to the debit side of the Remuneration account, as well as the receivable of 
1,000 against company code 0001 that is posted in the debit side of the company code clearing 
account from company code 0003. 

The receivables and payables between the company codes are paid to the company code 
clearing accounts set up for this purpose. 

• The balance of the company code clearing account for company code 0002 shows a 
receivable of 1.000 from company code 0001.  

• The balance of the company code clearing account for company code 0001 shows a 
receivable of 1.000 from company code 0002. 

 
The amounts for wage types /551 Recalculation difference and /552 Subsequent 
clearing from previous period do not, in this case, lead to a posting to the 
recalculation difference account. As these wage types are posted to a symbolic 
account with the account assignment type FL Balance sheet account for checking 
the balance in the case of retroactive accounting data, they are posted to the last 
company code for the actual payroll result, therefore to company code 0003, in this 
case. They thus balance to zero so that a posting to the recalculation difference 
account does not take place. 

Prerequisites 
The symbolic account to which the wage types /551 Recalculation difference and /552 
Subsequent clearing/previous month has the account assignment type FL Balance sheet account 
for checking the balance in the case of retroactive data. For more information, see the 
Implementation Guide (IMG) for Payroll, under Reporting for Posting Payroll Results to 
Accounting → Special Scenarios → Posting to Company Code Clearing Accounts. 

Activities 
The balances of the company code clearing accounts correspond to the receivables and 
payables between the company codes. 

You must manually clear the receivables and payables between the company codes. When 
doing so, you also clear the balances of the company code clearing accounts. 
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Retroactive Accounting after a Retrospective Change of 
Company Code when Clearing Using Company Code 
Clearing Accounts 
Use 
If an employee is retrospectively assigned to another company code, retroactive accounting is 
triggered. Posting of this retroactive accounting run happens in the following way: 

• Posting of the old payroll results from the retroactively accounted period is reversed in the old 
company code. 

• The new payroll result from the retroactively accounted period is posted in the new company 
code. 

The payment that took place in period 01 can no longer be reversed. In this way, a receivable or 
a payable arises between the two company codes, which then appears on the company code 
clearing accounts. 

The graphic shows an example for the case of an employee who has retrospectively changed 
company code. To simplify matters, the assumption is made that the company code has changed 
retrospectively for the whole period 01. 

Wage types Documents

Accounts

CoCde WT Amount
0001 M020 Monthly salary 5,000
0001 /559 Bank transfer 5,000

0003 M020 Monthly salary 5,000
0003 /559 Bank transfer 5,000

0003 M020 Monthly salary 5,000
0003 /559 Bank transfer 5,000

Period

01 in 01 {
01 in 02 

02 in 02 {

{

0001
Remun.
Receivable to 0003          5,000

5,000

0

0003
Rem.                             10,000
Payment
Payable to 0001

5,000
5,000

0

Remuneration
0001

5,000

Rec. to 0003
0001

5,000

Remuneration
0003

10,000

Payment
0003

5,000 5,000

Pay. to 0001
0003

5,000

Payment
0001

The payment accounts are
cleared.
You must clear the company
code clearing accounts!

Bank clearing account

           0001                          0003
5,000*5,000 *5,000 *.5000

* original posting to in period 01

*5,000

 
 

Originally, an amount of 5,000 was posted from the Remuneration account to the Outgoing 
payment account in period 01 in company code 0001. After making the payment, the Payment 
account was cleared by the manual posting Payment to bank clearing account to the amount of 
5,000. 
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The backdated change of company code for the employee from company code 0001 to company 
code 0003 causes the Remuneration to payment posting of 5,000 to be reversed in company 
code 0001.  However, as the payment has already been made to the employee, a receivable of 
5,000 incurs from company code 0001 to company code 0003 that appears on the company 
code clearing account of company code 0001. 

In company code 0003, an amount of 10,000 is posted as an expense to the Remuneration 
account. This amount contains the expense of 5,000 for period 01 and the expense of 5,000 for 
period 02. This posting of 5,000 to the payment account of company code 0003 and 5,000 to the 
company code clearing account of company code 0003 offsets this. 

After the amount of 5,000 was paid to the employee for period 02, the system performs a manual 
posting Payments to bank clearing accounts of 5,000. This clears the payment accounts in both 
company codes, but does not clear the company code clearing accounts. 

• The balance of the company code clearing account for company code 0001 shows a 
receivable of 5,000 against company code 0003.  

• The balance of the company code clearing account for company code 0003 shows a payable 
of 5,000 against company code 0001. 

 
The amounts of wage type /559 Bank transfer for period 01 do not lead to a posting 
in this case. As the wage type is posted to a symbolic account with the account 
assignment type FO Balance sheet account in original period only, only the amount 
for this wage type from the original period is posted. 

Prerequisites 
The symbolic account to which wage type /559 Bank transfer is posted, has the account 
assignment type FO Posting in original period only. For more information, see the 
Implementation Guide (IMG) for Payroll, under Reporting for Posting Payroll Results to 
Accounting → Activities in the HR System → Employee Grouping and Symbolic Accounts → 
Define Symbolic Accounts. 

Activities 
The balances of the company code clearing accounts correspond to the receivables and 
payables between the company codes. 

You must manually clear the receivables and payables between the company codes. When 
doing so, you also clear the balances of the company code clearing accounts. 
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Postings Relevant to Value-Added Tax 
Postings from the payroll results - usually postings in the form of Expenses to Payables - are not 
usually subject to value-added tax. Neither the expenses, nor the payables contain input or 
output tax. When posting payroll results, this does not usually affect accounts to which amounts 
subject to value-added tax as a result of other transactions are posted. 

The posting of value-added tax using the posting to Accounting component is only technically 
possible in a few cases for reasons of upward compatibility. However, we do not recommend 
this procedure. 

 
If you want to perform the value-added tax posting with posting to Accounting, you 
must exactly check if the calculation and posting of the value-added tax corresponds 
with the legal recommendations. In the standard system, it is not planned to perform 
value-added tax postings using posting to Accounting. For this reason, we can not 
guarantee that calculation and posting of value-added tax using these components 
corresponds to the legal recommendations. 

If you want to perform value-added tax postings using posting to Accounting against our 
recommendations, you should consider the following points: Bear in mind that this is not a 
complete list: 

• In the countries in which not all the information for the calculation and posting of value-added 
tax is available in the payroll results or during the posting of the payroll results to Accounting, 
no value-added tax postings can be performed using the posting to Accounting component. 
The USA and Canada are, for example, amongst these countries, as the system requires a 
Jurisdiction Code in this case, which is not available in Payroll. 

• If you want to perform a value-added tax posting using posting to Accounting, there should 
not only be a check on the legal side, this procedure must also be agreed on internally. 

• Using value-added tax postings using posting to Accounting: 

− Separate business transactions are grouped together. 

− Sometimes, amounts are posted using the revenue principle. 

− The value-added tax is posted in the company code in which the accompanying expense 
is posted. For this reason, this procedure leads to incorrect results if there are cross-
company code procedures. This can have serious consequences if the company codes 
do not belong to the same integrated company liable to sales tax. 

In the following sections, you find examples of value-added tax postings and notes on which 
procedures are planned for these postings in the standard system. 

Bear in mind that this is not a complete list: Other procedures are also feasible in which value-
added tax postings can occur.  

Travel Expenses [Page 627] • 

• Invoices to Employees [Page 628] 

•  Amounts Paid by the Employee [Page 62 ]9
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Travel Expenses 
Separate Posting (Recommended Procedure) 
If you reimburse employees’ travel expenses using Payroll, this results in value-added-tax 
postings. For this reason, you should post the following procedures separately: 

• Posting of travel expense to payables for employees. This procedure is performed within the 
Travel Management component. For more information, see and 

. 
Transfer to Accounting [Ext.]

Transfer to HR Payroll [Ext.]

• Reimbursement of the amounts to be paid via Payroll and then the value-added tax free 
posting of payables for employees to wages and salaries to be paid using the Posting to 
Accounting component. 

This procedure has the advantage that it allows a real-time posting of travel expenses and this 
posting is not linked to the posting of the payroll results. 

Combined Posting (Non-Recommended Procedure) 
It is technically possible to set up the relevant wage types in such a way that the travel expenses 
relevant to value-added-tax are not posted using Travel expenses reporting, but are posted using 
the Posting to Accounting component. The value-added-tax indicator that is transferred from 
Travel expenses reporting to Payroll is taken into consideration when posting the payroll results 
to Accounting, so that the value-added tax is calculated and posted. 

Bear in mind that we do not recommend this procedure and cannot guarantee that the calculation 
and posting of the value-added-tax always corresponds to the legal recommendations. 

See also: 
Posting Value-Added Tax [Page 625] 
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Invoices to Employees 
Separate Posting (Recommended Procedure) 
If the company issues invoices to employees (for example, for company-owned apartments, 
private conversations using a company-owned telephone, and so on), this results in value-added 
tax postings. You should therefore perform the following procedures separately, in accordance 
with the declaration principle. 

• Creating an invoice with the subsequent value-added tax posting of employee receivable to 
income/expense reduction. This procedure is performed in the Financial Accounting 
component. 

• Retaining the amounts claimed via Payroll with the subsequent value-added tax free posting 
of personnel expense to employee receivable using Posting to Accounting. 

Combined Posting (Non-Recommended Procedure) 
It is technically possible to group together the posting of both these procedures and perform a 
value-added tax posting of personnel expenses to income/expense reduction using the Posting 
to Accounting component. To do so, a fixed value-added tax indicator must be assigned to the 
income/expenses account to which the relevant wage type is posted. This value-added tax 
indicator is then taken into consideration when posting the payroll results to Accounting so that 
the value-added tax is calculated and posted. 

Bear in mind that we do not recommend this procedure and cannot guarantee that the calculation 
and posting of the value-added-tax always corresponds to the legal recommendations. 

 
If one of the following tax categories is assigned to the income/expenses account, 
and the posting without tax permitted indicator is set in the master data for the 
account; Posting to Accounting does not calculate the value-added tax when posting 
to this account. 

If one of the following tax categories is assigned to the income/expenses account, 
and the Posting without tax permitted indicator is not set in the master data for the 
account; Posting to Accounting can not post to this account in the case described 
here. 

 

Tax category Meaning 

* All tax types allowed 

+ Only output tax allowed

– Only input tax allowed 

See also: 
Posting Value-Added Tax [Page 625] 
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Amounts Paid by the Employees 
Separate Posting (Recommended Procedure) 
If you reimburse amounts that were paid by employees, this results in value-added tax postings. 
You should therefore perform the following procedures separately, in accordance with the 
declaration principle. 

• Receipt of invoice with the subsequent value-added tax posting of expense to payables for 
employees in Financial Accounting. 

• Reimbursement of the amounts via Payroll and value-added tax free posting of payables for 
employees to wages and salaries to be paid using the Posting to Accounting component. 

Combined Posting (Non-Recommended Procedure) 
It is technically possible to group together the posting of both these procedures and perform a 
value-added tax posting of expenses to wages and salaries to be paid using the Posting to 
Accounting component. To do so, a fixed value-added tax indicator must be assigned to the 
expense account to which the relevant wage type is posted in Financial Accounting. This value-
added tax indicator is then taken into consideration when posting the payroll results to 
Accounting so that the value-added tax is calculated and posted. 

Bear in mind that we do not recommend this procedure and cannot guarantee that the calculation 
and posting of the value-added-tax always corresponds to the legal recommendations. 

 
If one of the following tax categories is assigned to the expenses account, and the 
posting without tax indicator is set in the master data for the account, posting to 
Accounting does not calculate the value-added tax when posting to this account. 

If one of the following tax categories is assigned to the expenses account, and the 
Posting without tax permitted indicator is not set in the master data for the account; 
Posting to Accounting cannot, in this case, post to this account. 

 

Tax category Meaning 

* All tax types allowed 

+ Only output tax allowed

– Only input tax allowed 

See also: 
Posting Value-Added Tax [Page 625] 
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Germany: Account Determination for Specific Service 
Types in Accordance with the KHBV/PBV 
Use 
The Hospitals Accounting Regulation (KHBV) and Nursing Homes Accounting Regulation (PBV) 
specify for which service types (employee groups) expense accounts must be within Financial 
Accounting, in the case of public-sector hospitals and nursing homes. These regulations also 
specify to which service type the employees should be assigned. 

You can post the personnel expenses to these expense accounts for a specific service type by 
making the relevant settings in the system, so that the symbolic account, the employee grouping 
for account determination, and the service type are all taken into consideration during account 
determination. 

Prerequisites 
You have made the relevant settings in Payroll Customizing under Payroll Germany → Industries 
→ Public Sector → Hospitals and Homes → Service Type. 

You have made the relevant settings in Payroll Customizing, under Payroll: Germany → Posting 
to Accounting → Activities in AC System → Assigning Accounts → Assign Expense Accounts. 

Scope of Function 
• For the hospitals and nursing homes sector, you can assign employees to a service category 

using the fields Service type and Service category in the Organizational Assignment infotype 
(0001). 

• 
 

You can specify a percentage distribution to several service types/categories in the Cost 
Distribution infotype (0027).

• In certain infotypes you can specify a cost assignment. You can also store a service 
type/category here. For a list of the most important infotypes in which a cost assignment can 
be stored, see 

. 
Posting-Relevant Information from Master Data, Time Data and 

Organizational Management [Page 545]

• In Organizational Management, you can store the service type/category in a position. 

Payroll reads the information on the service type/category from the master and time data, and 
from Organizational Management, and saves it in the payroll result. 

When posting to Accounting, the system reads this information from the payroll results and 
includes it in account determination. 
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EMU: Special Features of Posting to Accounting 
The currency conversion for the European Monetary Union is particular important in Posting to 
Accounting. 

The system uses the currency from the payroll results as the document currency for posting. For 
this reason you can convert the house currency in Financial Accounting at a different time to the 
payroll currency used in Human Resources. The document currency transferred from Payroll to 
Accounting is subsequently interpreted as a foreign currency in Financial Accounting and 
converted into the house currency. 

If retroactive accounting is necessary after the currency conversion in Human Resources, and 
the retroactive run includes periods before the conversion date, the system creates separate 
documents during posting using the respective document currency. 

 
You convert the currency used in Payroll on January 01, 2002. If, during the payroll 
run in January 2002, a retroactive accounting run is required for the period of 
December 2001, the recalculated “December in January” results for December uses 
the old country currency as the payroll currency. The difference between the old and 
new result for December is then posted in the old national currency. The payroll 
result for January 2002 is posted in euro. 

Please note that the retroactive accounting difference is usually posted in the current posting 
period. The only exception is posting to special periods at the end of the fiscal year.  

 

As a result, retroactive runs after 01.07.02 may create documents in the current period that have 
the old national currency as the document currency. 

Rounding Differences 
The payables posted by the posting to Accounting component are cleared during the other 
subsequent activities for Payroll and the connected postings. After the postings have been 
performed in connection with the subsequent activities, all the payables are thus cleared and the 
balances of the payable accounts are equal to zero. 

Due to rounding differences resulting from the currency conversion, it may be the case that some 
payable accounts do not have a balance of zero. This effect can be due to the fact that posting to 
Accounting transfers the amounts to Accounting without a currency conversion. Here they are 
converted into the house currency. In contrast, in other subsequent activities in Payroll, it is 
necessary to convert the currency on a personnel number level and then calculate the totals. 

You should also take this into account when the accounts are reconciled. You should manually 
adjust any balances in these accounts that are not equal to zero due to rounding differences. 

See also:
European Monetary Union: Euro (CA-EUR) [Ext.] 

Treatment of Rounding Differences [Ext.] 
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Integration with Other Components 
You can use the section Integration with Other Components to inform yourself on how Posting to 
Accounting supports the following components: 

• Funds Management (with and without using Position Management) 

• Personnel Cost Planning 
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Posting to Funds Management 
Use 
When posting personnel expenses to Funds Management, the system distinguishes between the 
following scenarios: 

Posting to Funds Management without Entering FM Account Assignments [Page ] 1. 634

2. Integration of Funds Management without using Position Management [Page 63 ]5  

3.  Integration of Funds Management using Position Management [Page 637]

For every company code, you can specify if scenario 2 should be used and a date specified on 
which the integration of Funds Management should be activated. You make the necessary 
settings in Customizing for Financial Accounting (under Funds Management → Actual and 
Commitment Update/Integration → Integration → Integration with HR (Human Resources) → 
Define Begin of HR Integration. 

At FM level, you can specify if scenario 3 should be used.  However, it is possible to activate this 
scenario for certain employee groups only, which you create based on certain employee 
characteristics. You can activate the scenario at a different time for every employee grouping. 
You make the necessary settings in Customizing for Personnel Management (under, Position 
Management → Integration → Integration With Funds Management). 

In the following cases, scenario 3 does not apply for an employee: 

• Scenario 3 is not activated for the employee’s FM area. 

• Scenario 3 is only activated for certain employee groupings from the employee’s FM area. 
The employee does not belong to any of these employee groupings. 

In both cases, scenario 2 applies for the employee if it is activated for the employee’s company 
code. If scenario 2 was not activated for the employee’s company code, scenario 1 applies for 
the employee in both cases. 
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Posting to Funds Management without Entering FM 
Account Assignments 
Use 
You can also post personnel expenses to Funds Management if you do not want to store any 
Funds Management account assignments in Human Resources. 

For this purpose, you can define assignments of FM account assignments to CO account 
assignments in Funds Management so that when posting the payroll results to Accounting the 
FM account assignments are derived from the CO account assignments that are contained in the 
posting documents. 

 
It is only possible to post personnel expenses to Funds Management without 
entering FM account assignments if the master data structure of Funds Management 
corresponds to the master data structure of Controlling. 

For more information, see . Assigning FM Account Assignment to CO Account Assignment [Ext.]
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Integration of Funds Management without using 
Position Management 
Use 
You can store the following account assignment objects from Funds Management in the 
employee’s master data or in Organizational Management to post personnel expenses to these 
account assignment objects within posting the payroll results to Accounting. 

• Funds center 

• Commitment item (in certain cases only) 

• Fund 

Integration 
You use the Funds Management component (FI-FM).  

Prerequisites 
You have specified from when account assignment objects from Funds Management should be 
transferred when posting to Accounting in Customizing for Financial Accounting under Funds 
Management -> Actual and Commitment Update -> Integration -> Integration with HR (Human 
Resources) -> Define Begin of HR Integration. It is only possible to store account assignment 
objects from Funds Management in the employee’s master data or in Organizational 
Management from this point in time onwards. 

You have made the relevant settings in Customizing for Personnel Administration so that the 
account assignment objects from Funds Management can be entered in the HR master data. 

Scope of Function 
You can assign an employee account assignment objects from Funds Management in different 
ways: 

• 

• You can assign a funds center and, optionally, a fund to the employee in the Organizational 
Assignment infotype (0001). 

• Using the Cost Distribution infotype (0027), you can assign the employee to several funds 
centers and, optionally, funds on a percentage basis so that his/her personnel expenses are 
distributed to these account assignment objects. 

You can assign the employee to a position to which a cost distribution is assigned that 
contains one or several funds centers. The employee can also be assigned to several such 
positions on a percentage basis. 

• You can assign individual remuneration elements for an employee to a funds center and, 
optionally to a commitment item and a fund, by storing a cost assignment in the infotypes 
intended for this purpose. For a list of the most important infotypes in which you can specify a 
cost assignment, see 

. 
Posting-Relevant Information from Master Data, Time Data and 

Organizational Management [Page 545]

If the system can no longer post to the fund for the Funds Management account assignment to 
be used because it’s financial purpose has expired (for example, in the case of a retroactive 
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accounting run), the system deletes the fund from the relevant document line of the posting 
document (a fund is not given for the posting). The system documents deletion of the fund from 
the document line in the posting document. 
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Integration of Funds Management without using 
Position Management 
Use 
The aim of Position Management is to finance, arrange and plan the work areas and employees 
as efficiently as possible within the budget allocated. Integration with Funds Management makes 
it possible for Position Management to access the part of the budget from Funds Management 
that contains the personnel expenses. 

Persons and positions can be financed in Position Management using the budget set for 
personnel expenses in Funds Management. This creates fund commitments in Funds 
Management. When posting to Accounting, these funds commitments are used up and an actual 
posting takes place in Funds Management. 

For more information on the environment in Position Management and Funds Management, see 
 and . Position Management [Ext.] Funds Management [Ext.]

Integration 
The integration of Position Management (PA-PM) with Funds Management (FI-FM) must be 
activated. For information on activating the integration, see the Implementation Guide (IMG) for 
Personnel Management under Position Management -> Integration -> Integration with Funds 
Management. 

Prerequisites 
The employees in question must have been financed in Position Management. The master data 
for this employee must meet the following conditions: 

• No account assignments from Funds Management (funds center, commitment item and fund) 
should be stored in the infotypes Organizational Assignment (0001) and Cost Distribution 
(0027). 

• The account assignment objects from Controlling that are stored in these infotypes, must 
belong to controlling areas that belong to the same FM area for each employee. 

 
• In the infotypes, in which deviating cost assignments can be specified, you can also store 

account assignments from Funds Management. For a list of the most important infotypes in 
which you can specify a cost assignment, see 

. If you enter a deviating 
account assignment in these infotypes and the integration of  Funds Management and 
Controlling are active, you must store account assignment objects for both account 
assignment objects:  

Posting-Relevant Information from Master 
Data, Time Data and Organizational Management [Page 54 ]5

• If a wage type is posted as an expense, you must have specified which expenditure type is 
used for the accompanying financing in Position Management. 

• You must have specified to which account assignment objects from Funds Management the 
system should post if an expenditure type was not financed for an employee. 
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Process Flow for Integrated Position Management 
Purpose 
If integration of Position Management (PA-PM) to Funds Management (FI-FM) is activated, 
financing, payroll and posting take place as in the following example. 

Process Flow 
1. Financing the Person 

FMFM
HR - FPM

HR

HR - PY

Funds center: S1
Commitment item: Salaries
Fund: F1

Acc.assignment objects

Budget
1,000,000PersonPosition

Financing A001:
2,000 F1 S1 Salaries

Funds commitment
Doc. 00000111 / 002

2,000

1. Financing for
the person

 
The person is financed either directly or via their position in Position Management. 

In this example, financing of 2,000 is created based on the expenditure type A001 with the 
following account assignment objects from Funds Management: 

 

• Funds center: S1 

• Commitment item: Salaries 

• Fund 1: F1 

This creates a funds commitment of 2,000 on this account assignment in Funds Management 
(FM). The funds commitment takes place in the funds commitment document number 00000111 
in line 002. 
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2. Payroll 

HR - FPM

HR - PY

Funds center: S1
Commitment item: Salaries
Fund: F1

Acc.assignment objects

Budget
1,000,000PersonPosition

Financing A001:
2,000 F1 S1 Salaries

Funds commitment
Doc. 00000111 / 002

2,000

1. Financing for
the person

Payroll
result

FUND

A001: 100% 
F1 S1 Salaries
00000111  002 

2. Payroll

HR FMFM

 
Position Management provides Payroll with the following information for the period that 
corresponds to the processed payroll period: 

• Account assignment objects from Funds Management that were created when financing the 
various expenditure types for the employee 

• Document number and line number for the funds commitment in Funds Management 

The financing amounts on the account assignment objects are converted to percentages and 
saved in the Funding (FUND) table in the payroll result along with the information mentioned 
using account assignment objects and funds commitment. 

 
In the example, the expenditure type A001 is 100% financed from the account 
assignment objects funds center S1, commitment item Salaries and fund F1. 
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3. Evaluating the Payroll Results 

HR - FPM

HR - PY

Funds center: S1
Commitment item: Salaries
Fund: F1

Acc.assignment objects

Budget
1,000,000PersonPosition

Financing A001:
2,000 F1 S1 Salaries

Funds commitment
Doc. 00000111 / 002

2,000

1. Financing for
the person

Payroll
result

FUND

A001: 100% 
F1 S1 Salaries
00000111  002 

2. Payroll

Amount... FM-acc.assignment Funds commitment

2,125 ... F1 S1 Salaries 00000111 002

...

HR-document

3. Create
posting run

HR FMFM

RT

Wage type M020
Monthly salary
2,125

 
When evaluating the payroll results for posting to Accounting, the system uses the settings in 
Customizing to determine which expenditure type every expenditure wage type is assigned to 
that exists in the Results table (RT) in the payroll result for the employee and should be taken 
into consideration when posting. The Financing (FUND) table in the payroll result for an 
employee is used to determine with which account assignments from Funds Management these 
expenditure types were financed and which document and line number the funds commitment 
created by Position Management in Funds Management has. These account assignments from 
Funds Management and the document and line number of the funds commitment are given as 
account assignment information when posting the expenditure wage types to Accounting. 
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In the example, the expenditure wage type M020 Monthly salary has an amount of 
2,125 according to the Results Table (RT). The expenditure type A001 is assigned to 
this wage type in Customizing. The Financing (FUND) table is used to determine that 
the expenditure type A001 was financed with the account assignment objects; funds 
center S1, funds commitment Salaries and fund F1. This information, as well as the 
document and line number of the funds commitment is contained in the posting 
document created by posting to Accounting. 

4. Posting to Accounting 

FMFM
HR - FPM

HR

HR - PY

Funds center: S1
Commitment item: Salaries
Fund: F1

Acc.assignment objects

Budget
1,000,000PersonPosition

Financing A001:
2,000 F1 S1 Salaries

Funds commitment
Doc. 00000111 / 002

2,000

1. Financing for
the person

Payroll
result

FUND

A001: 100% 
F1 S1 Salaries
00000111  002 

2. Payroll

Amount... FM-acc.assignment Funds commitment

2,125 ... F1 S1 Salaries 00000111 002

...

HR-Beleg

3. Create
posting run

Actual posting
2,125

Used up

4. Posting to 
Accounting

 
When posting to Accounting, an actual posting to the account assignment objects specified in the 
posting document takes place in Funds Management. The funds commitment is reduced by the 
amount of the actual posting. 

 
In the example, the actual posting to the account assignment objects; funds center 
S1, funds commitment Salaries and fund F1, takes place in Funds Management. As 
the amount of the actual posting (2,125) is higher than the funds commitment 
(2,000), the funds commitment is reduced completely. 

See also: 
Payroll with Position Management [Page 643] 

Posting with Position Management [Page 645] 
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Payroll with Position Management 
Purpose 
If integration of Position Management (PA-PM) to Funds Management (FI-FM) is activated, the 
following process takes place in Payroll. 

Process Flow 
During payroll, the person’s financing for the period of every payroll period processed is read 
from Position Management (PA-PM). In the process, percentages are calculated from the 
financing amounts from the account assignment objects in Funds Management (FI-FM), resulting 
in 100% for each financed expenditure type. 

Even if the budget provided only partially covers the financing required, this is also converted to a 
total of 100%. 

 
Example 1 

Financing required: 2,000 

Financing from account assignment objects in Funds 
Management (funds center S1, commitment item Salaries, fund 
F1) 

1,000 = 100 % 

 

Example 2 

Financing required: 2,000 

Financing from account assignment objects in Funds Management 
(funds center S1, commitment item Salaries, fund F1) 

750 = 75% 

Financing from account assignment objects in Funds Management 
(funds center S2, commitment item Salaries, fund F2) 

250 = 25 % 

 

A  takes place if financing is not provided for the whole of the payroll period, or 
financing changes within the payroll period 

WPBP-Split [Ext.]

Financing is stored in the table Financing (FUND) in the payroll results for every WPBP period. 
This table contains the following data for every WPBP period and every expenditure type that 
was financed in Position Management: 

• The Funds Management account assignment (funds center, commitment item and funds), 
used to finance the employee 

• Document number and line of the funds commitment created because of the financing in 
Position Management in Funds Management. 

• Percentage used to fund the expenditure type for the employee in this WPBP period using 
these Funds Management account assignment objects (the total of all percentages for each 
expenditure type and WPBP period is always 100 %) 
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• Whether the expenditure type financed is basic pay financing 

The financing (FUND) table is stored in the payroll results. 

If a person's basic pay is not financed in a period of the payroll period, the system informs you of 
this during the payroll run. 

In Customizing for Personnel Management, you can make settings for the message to be 
displayed and the relevant system reaction with reference to payroll in Customizing for Personnel 
Management, under Position Management → Integration → Determining Funds Required → 
Defining the Process Flow for Payroll Simulations → Define System Reactions for Payroll. 

The following reactions are possible: 

Set system 
reactions 

Message in payroll log Consequences for payroll 

Information (I) No message The Financing (FUND) table does not contain 
any account assignment objects, but only 
contains an entry in which the Basic pay-
financing indicator is set. 

Warning (W) The Financing (FUND) table does not contain 
any account assignment objects, but only 
contains an entry in which the Basic pay-
financing indicator is set. 

“The expenditure type 
Basic pay is not 
financed without gaps”. 

Error message (E) The non-financed person is rejected in the 
payroll run. You must have created basic pay 
financing before payroll can be performed for 
the person. 

“The expenditure type 
Basic pay is not 
financed without gaps”. 
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Posting with Position Management 
Purpose 
If integration of Position Management (PA-PM) to Funds Management (FI-FM) is activated, the 
following process takes place in posting to Accounting. 

Prerequisites 
If a wage type is posted as an expense, you must have specified which expenditure type is used 
for the accompanying financing in Position Management in Payroll Customizing, under Reporting 
for Posting Payroll Results to Accounting → Special Scenarios → Integration of HR Funds and 
Position Management → Assign Expenditure Types to Wage Types. 

Process Flow 
When evaluating the payroll results for posting to Accounting, the system uses Customizing to 
determine the expenditure type assigned to every wage type that is to be posted as an expense. 
It uses this expenditure type and the WPBP split [Ext.] of the wage type to determine which 
financing should be used from the Financing (FUND) table in the payroll results. 

The relevant posting items contain the information obtained. The subsequent posting then uses 
up the funds commitment specified in the Financing (FUND) table in Funds Management and 
creates an actual posting to the Funds Management account assignment stored in the Financing 
(FUND) table. 

If the expenditure type is financed proportionally from several Fund Management account 
assignments, the wage type amount is distributed to these account assignments based on the 
portions. Any rounding off differences are added to the greatest share. 

 
If a different Funds Management account assignment was specified in one of the 
infotypes in which a cost assignment can be specified, this Funds Management 
account assignment is copied from the table Cost Distribution from Various Infotypes 
(C1) when posting the relevant expense. The Funds Management account 
assignment from the Financing (FUND) table is not taken into consideration for this 
posting. Moreover, the funds commitments are not used up in this expense posting. 

For a list of the most important infotypes in which you can specify a cost assignment, 
see 

. 
Posting-Relevant Information from Master Data, Time Data and Organizational 

Management [Page 545]

If a cost distribution to several CO account assignments was specified in the Cost Distribution 
infotype (0027), all the CO account assignments are multiplied with the calculated percentages of 
the financing from Position Management. 

 
Cost center/funds center distribution 

Financing of 1,000 takes place using the following account assignment objects from 
Funds Management. 
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Account assignment 1: Funds center S1, commitment item Salaries, fund F1. 
(Amount: 500) 

Account assignment 2: Funds center S2, commitment item Salaries, fund F2. 
(Amount: 500) 

The Financing table (FUND) thus shows 50% for account assignment 1 and 50% for 
account assignment 2. 

However, a cost distribution of 40% is entered in the Cost Assignment infotype 
(0027) for the cost center HR-01. The other 60% are posted to the employee’s 
master cost center (HR-ALL) from the Organizational Assignment (0001) infotype.  

A wage type with the amount of 1,000 was posted accordingly in the following way: 

 

Cost center FM account assignment Multiplication Amount 

HR-ALL 1 1,000 x 60 % x 50 % 300 

HR-ALL 2 1,000 x 60 % x 50 % 300 

HR-01 1 1,000 x 40 % x 50 % 200 

HR-01 2 1,000 x 40 % x 50 % 200 

 

 
The documents in Controlling and in Funds Management contain summarized 
information: 

In the Controlling document in the example, only the allocation to both the cost 
centers HR-ALL (amount: 600) and HR-01 (amount: 400) would appear. A 
prerequisite for this is that you have made the relevant settings for the reference 
procedure HRPAY in Customizing for Controllings under General Controlling → 

. Document Summarization for External Accounting Documents [Ext.]

Only the allocation to both the account assignments 1 and 2 (an amount of 500 
respectively) would appear in the Funds Management document. 
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Special Cases of Integration between Funds 
Management and Position Management 
If integration of Position Management (PA-PM) to Funds Management (FI-FM) is activated, the 
following special cases can occur when posting to Accounting. 

Special Case 1: Missing Financing for an Expenditure Type 
If a wage type is assigned to an expenditure type that was not directly financed or was not 
financed using a position in Position Management in the period in question, there are no entries 
for this expenditure type and WPBP period in the Financing (FUND) table. In this case, the 
system attempts to determine a substitute account assignment by determining the default 
account assignment of the integration of Funds Management/Position Management from Funds 
Management. You define the substitute account assignment for each FM area and fiscal year in 
Payroll Customizing, under Reporting for Posting Payroll Results to Accounting → Special 
Scenarios → Integration of HR Funds and Position Management → Define Posting Collector. 

Two-Step Substitution Concept 
The system determines the substitute account assignment for wage types that are assigned to an 
expenditure type, that were not directly financed or were financed using a position in Position 
Management in the relevant period, in the following way: 

1. The system first of all attempts to derive the substitute account assignment from the basic 
pay financing. If basic pay is financed in the relevant period (that means, there is financing 
with the Basic pay indicator for this period in the Financing (FUND) table in the payroll 
results), a substitute account assignment is derived from the Funds Management account 
assignment for this financing. The system derives the substitute account assignment using 
the Customizing settings from posting to Accounting named above. The non-financed 
expense is posted with this substitute account assignment. If basic pay is financed 
proportionally, the wage type amount with the non-financed expenditure type is distributed 
proportionally to the substitute account assignments determined in this way.  

2. If basic pay is also not financed, the system determines the default account assignment 
without financed basic pay as the substitute account assignment in a second step, which you 
have stored in Customizing for posting to Accounting as described above. The account 
assignment objects stored in this position are used to post the wage type. 

When using a substitute account assignment, the funds commitment is not used up when 
posting. Only an actual posting takes place. 

If the system is not able to determine a substitute account assignment or if incorrect account 
assignment objects are stored (for example, funds whose financing purpose has come to an 
end), the posting document contains an error message.  The posting document has the status 
Documents incorrect. 

Special Case 2: Retroactive Accounting and Substitution 
When posting a retroactive accounting run the amounts on the Funds Management account 
assignments are reversed that were previously posted to. This also applies if the substitute 
account assignment is posted to because of an incorrect financing. A prerequisite for this is, 
however, that you have not changed Customizing for the substitute account assignment in the 
meantime. 
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If the system posted to the substitute account assignment of the FM area in the previous month 
because of a lack of basic pay financing and the person was subsequently financed in Position 
Management, when posting retroactive accounting runs in the subsequent month, the previous 
month's amount is reversed on the substitute account assignment and the (possibly changed) 
amount is posted to the Funds Management account assignment of the financing now stored in 
Position Management. In this case, the prerequisite that you have not, in the meantime, changed 
Customizing for the substitute account assignment, also applies. 

Special Case 3: Fund whose Financing Purpose Has Come To An End  
If the system can no longer post to the fund of the Funds Management account assignment to be 
used because it’s financial purpose has expired (for example, in the case of a retroactive 
accounting run), the system deletes the fund from the relevant document line of the posting 
document (a fund is not given for the posting). This does not apply if the fund originates from the 
default account assignment that you have stored in Customizing for posting to Accounting as 
described above. The system documents deletion of the fund from the document line in the 
posting document. 

Special Case 4: Funds Commitment with Completed Indicator 
If, when posting, the system determines that the funds commitment to be used up in Funds 
Management is indicated as being completed (this can particularly occur in the case of 
retroactive accounting runs for the last fiscal year), this funds commitment number is deleted 
from the relevant document line of the posting document. This only causes the actual posting to 
be made in Funds Management, without using up a funds commitment in the process. The 
system documents deletion of the funds commitment number from the document line in the 
posting document. 
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Providing Data for Personnel Cost Planning 
Use 
You can use the program Posting to Accounting: Create Posting Run (Report RPCIPE00) to 
provide Cost Planning with data based on existing or simulated payroll results. 

Procedure 
1. Choose Human Resources → Payroll → Subsequent activities → Per payroll period → 

Posting to Accounting → Execute posting run.  

2. To select the payroll period, enter the payroll area and choose .  

The current payroll period is displayed. 

If you want to evaluate a different payroll period to the current period, choose Other 
period and enter the period you require. 

3. Make the necessary entries in the Selection group. Entering the payroll area usually makes 
the selection. 

4. In the Run attribute group box, choose the relevant Type of document creation. 

− If you want to provide Cost Planning with data based on payroll results that exist, you 
have the possibility of using all types of document creation. 

− If you want to provide Cost Planning with data based on simulated payroll results, you 
must enter a T (test run) in the Type of documentation field 

5. Choose Cost Planning (in the Run attribute group box) 

6. Set the Cost planning data indicator in the Cost Planning dialog box. If you want to provide 
Cost Planning with data using simulated payroll results rather than existing ones, set the 
Simulate payroll indicator and specify the appropriate payroll program and, if necessary, a 
report variant. 

7. In the dialog box, choose Cost Planning . 

8. Choose . 

Result 
Cost planning is provided with the data from Payroll. For more information, see 

. 
Personnel Cost 

Planning [Ext.]
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Troubleshooting 
You can use the Troubleshooting section to get help in unexpected situations when posting to 
Accounting: 

Posting run cancelled with status "selection running" [Page 651] • 

Personnel numbers not selected or rejected [Page 652] • 

Accounting documents were not created [Page 653] • 

Posting run is missing in posting run overview [Page 654] • 

•  Resetting the reversal after termination [Page 655]
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Posting Run Cancelled with Status "Selection Running" 
Use 
During creation, a posting run has the status Selection running. If the creation of a posting run 
was cancelled after the payroll results for individual personnel numbers had already been 
selected, the posting run thus retains the status Selection running. 

To be able to create a new posting run, you must remove the selection of the payroll results. You 
do this by deleting the posting run. 

Procedure 
You  the posting run. delete [Page 58 ]0

Result 
By deleting the posting run, you have removed the selection of the payroll results for personnel 
numbers already processed. You can now create a new posting run. 

Troubleshooting [Page 650] 
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Personnel Numbers not Selected or Rejected 
Use 
If personnel numbers were not selected or were rejected when creating a live posting run, you 
can subsequently select these personnel numbers for evaluation. 

Procedure 
You have two different options for selecting personnel numbers for evaluation that were not 
selected or were rejected. 

Creating a New Posting Run for All Personnel Numbers 
1. Remove the cause of the error stated in the log. 

2. Delete the posting. 

3. Create a new posting run. 

Creating a Separate Posting Run for the Personnel Numbers Skipped 
1. Remove the cause of the error stated in the log. 

2. Create a new posting run. When doing so, enter the same parameters in the selection screen 
that you entered when creating the first posting run. 

The payroll results already contained in another live posting run are not evaluated a 
second time. Only the payroll results for the skipped personnel numbers or for the 
personnel numbers not selected are included in a separate posting run. 

Result 
The payroll results for the personnel numbers that were not selected or were skipped are now 
included in a live posting run. 

 Troubleshooting [Page 650]
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Accounting Documents Were not Created 
Use 
If the system has not created any corresponding accounting documents after posting the posting 
documents in the Accounting components, this can be due to various errors. 

Procedure 
• First of all, check the status and the history of the posting run in the posting run overview. In 

this way, you can check if you have actually performed all the steps for posting to 
Accounting.  

 
The posting run must have the status Documents posted or (in distributed systems) 
the status Documents transferred. If the posting run has a different status, it has not 
yet been posted. 

• If you use ALE technology and the posting run has the status Documents transferred, check 
the status of the Idoc created in the HR system and sent to the AC system with the help of 
the Idoc list [Ext.].  If the Idocs were processed correctly, check the status of the posting 
[Ext.] in the AC system. 

• If you do not use ALE technology and the run has the status Documents posted, check the 
status of the posting. 

Troubleshooting [Page 650]
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Posting Run is Missing in the Posting Run Overview 
Use 
After you have posted, reversed, deleted or archived the posting documents for a posting run, the 
posting run is no longer displayed in the posting run overview. This is due to a filter that is set in 
the standard system.  

Procedure 
If you want to display posting runs in the posting run overview whose posting documents were 
posted, reversed, deleted or archived, choose Edit → Filter → Delete filter in the posting run 
overview. 

See also: 
Setting and Deleting Filter [Ext.] 

Result 
The posting runs required are displayed in the posting run overview. The standard settings are 
not changed by this procedure. For more information, see . layouts [Ext.]

Troubleshooting [Page 650] 
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Resetting the Reversal after Termination 
Use 
In certain situations, the reversal of posting documents may be cancelled with an error. This may, 
for example, occur in the following situations: 

• The specified posting date is in a posting period that is already closed. 

Checking Incorrect Reversal Documents 

• At the time of the reversal, the posting of the original document had not been completed. 

• Account assignment objects (for example, cost centers) which were posted to in the original 
document are closed at the time of the reversal. 

• Posting items that were created by the original document are already cleared at the time of 
the reversal (for example to customer and vendor accounts). 

If the reversal is cancelled with an error, the relevant posting run gets the status Reversal 
documents incorrect. In this case, you must check the incorrect reversal documents and reverse 
the reversal that went wrong to be able to reverse the posting documents a second time. 

If the reversal is cancelled not because of an error but for example, for technical reasons, the 
posting run in question can have one of the following statuses: 

• Reversal document creation is running 

• Reversal documents created 

• Reversal is running 

In this case, it is not necessary to perform the steps for checking the incorrect reversal 
documents specified below. Only perform the steps that are required to reverse the incorrect 
reversal. 

Procedure 

1. Go to the document overview for the relevant posting run. 

2. Select the posting documents that have the status incorrect (Reversal) and choose . 

The document display is displayed. 

1. Go to the overview of posting runs. 

Result 

3. Read the error messages that were created for the incorrect reversal documents and remove 
the cause of the error. 

Cancelling Incorrect Reversal 

2. Select the posting run that contains the incorrect reversal documents. 

3. Choose Edit → Reversal → Reset the reversal after termination. 

The posting run was returned back to the same state as it had after the posting documents to be 
reversed were posted. It can be reversed again. 
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Resetting the Reversal after Termination 

 
The incorrect reversal documents get the status Reversal reset. You no longer have 
an influence on Posting to Accounting. 

Troubleshooting [Page 650] 
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Third-Party Remittance 
Purpose 
Like the Transfer to FI/CO functionality, the Third-Party Remittance component involves the 
transfer of financial posting data from HR to FI/CO accounts. Like the Direct Deposit/Data 
Medium Exchange program, the third-party remittance component also generates actual physical 
payments in the form of bank transfers or checks. However, third-party remittance differs from 
the FI/CO Transfer component in one critical way - it exclusively handles posting and payment 
information for external payees, such as tax authorities, garnishment recipients and benefits 
providers. Third-party remittance provides reports that extract all relevant external payment info 
from SAP Payroll results, posts the data to FI/CO, and generates the external payments. 

 
Third-party remittance is intended as an automatic process, configured accordingly in 
the IMG. Ideally, it should be run every day. Although it is possible, SAP does not 
recommend that you carry out third-party remittance manually.  

Implementation Considerations 

Features 

Third-party remittance is a flexible component, insofar as its functionality works equally well in 
single or multi-system environments. ALE links can be made to external SAP systems, allowing 
you to transfer posting and payment data from a dedicated SAP R/3 HR system to an R/2, R/3 or 
non-SAP system.  

Since many customers elect to run HR in a dedicated, separate R/3 system, one of the primary 
considerations in setting up third-party remittance is the link between the HR and other systems 
managing the general ledger, payment program and controlling functions. 

Integration 
You need to implement third-party remittance if you are using SAP Net Payroll. Wage types 
configured for payroll must also be configured to post financial information to FI through the third-
party remittance component. Third-party remittance stores tax-related data needed by the Tax 
Reporter component. It is also fully integrated with SAP Garnishments processing. 

Third-party remittance is a complete solution for transferring HR posting data to FI and 
generating external payments. It also includes reporting functions that reconcile data between the 
HR and FI components, even in distributed environments where HR is run in a dedicated system. 

The third-party remittance component allows wage type amounts from payroll results to be split 
out to multiple payees, a feature that allows efficient processing of garnishments and benefits in 
Payroll while enabling detailed financial postings from generated payroll results. 
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The Third-Party Remittance Process 
Purpose 
This business process allows you to complete three major tasks related to the final processing of 
a payroll run. They are: 

• Reconciling payments made in FI with payables data stored in HR. 

The FI Payment Program must be configured so that the system knows when to run the payment 
program, and with which variants, for the HR creditors you defined. This allows the check printing 
and direct deposit programs (RFFOUS_C and RFFOUS_T) to generate payments automatically 
as needed. 

• Posting financial data to the appropriate G/L and subledger accounts in FI and CO. 

• Generating bank transfer and check payments to third parties, such as tax authorities and 
benefits providers 

Prerequisites 
You must have completed all configuration of HR creditors, remittance rules, wage types and 
number ranges in the Third-Party Remittance chapter of the Payroll: USA or Payroll: Canada 
Implementation Guide. 

Additionally, payroll results must exist for the employee population for which you want to begin 
the remittance process. It is also recommended that the Remuneration Statement, Transfer to 
FI/CO, and Direct Deposit/Data Medium Exchange programs are run prior to beginning this 
process. 
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Process Flow 

Collect data
from payroll
results Update

remittance
tables

Generate
HR posting
documents

Post
third-party
payments

Generate checks and
bank transfers

Reconcile
payment data

 

 
It is recommended that you complete this entire process after each payroll run. The 
Transfer Withholdings for Third Parties (RPURMP00) program, which creates HR 
posting documents used in the Display Posting Runs (PCP0) transaction, should be 
run in batch every night. This ensures that all amounts due are remitted in a timely 
fashion. 

 
As described here, the process assumes that the HR and FI/CO applications are 
running in a single system. 

1. Collect data from existing payroll results for third-party remittance and posting to FI/CO.  

Data collection is accomplished by running RPCALC using the U500 evaluation schema. 
The schema generates 2 TemSe files containing the extracted third-party payment data - 
one file for individual results and one for cumulated results 

2. You then execute the 'Update Remittance Tables' (RPURMU00) program, which extracts 
data from the TemSe files and stores it in the third-party remittance interface tables 
(T51R5, T51R6, T51R7 and T51R8). 

3. Run the 'Create Posting Run' (RPURMP00) program to create a list of HR posting 
documents containing third-party payment data. 
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4. Post third-party payments to the appropriate FI/CO accounts. 

The 'Process Posting Run' function (transaction PCP0) allows you to select the results 
from your RPURMP00 run, view the documents created, then release and post the 
documents to FI/CO. 

5. Generate checks and bank transfers. 

The RFFOUS_C and RFFOUS_T programs generate checks and transfers, respectively. 
These reports run automatically based on how you configured the payment program in 
transaction F110. 

6. Reconcile payment data from FI with third-party remittance interface tables in HR. 

The 'Reconcile Postings' (RPURMR00) produces a list of third-party remittance items 
that have been posted to FI. The list contains information confirmed by FI, such as 
receipt of the posting, payment of the posting and FI vendor/HR creditor details 

7. The 'Acknowledgement Report' (RPURMA00) function within third-party remittance is 
provided primarily for use in conjunction with a non-SAP FI system, or an R/3 system 
with a release prior to 4.0. 

The report reads third-party remittance posting data from the FI system either via 
manually entered data, or a TemSe file created by the external system. It then updates 
the HR system accordingly. The system marks all entries paid by the specified accounts 
payable run for each company code and business area. 

8. The 'Undo processing steps' function can be used to cancel a third-party remittance run 
prior to actual posting to FI. 

Result 
All third parties to which tax, garnishment, membership or benefits payments are owed have 
been paid. The amounts have been posted to the appropriate G/L, subledger and bank accounts 
in FI/CO. 
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Executing the Data Collection Run 
Use 
The third-party remittance data collection run collects data from existing payroll results for third-
party remittance and posting to FI/CO.  

This data is stored in two TemSe files. One file contains all cumulated remittance data, the other 
one contains more detailed individual remittance data. 

Prerequisites 
Payroll results must exist for the employee population for which you want to run third-party 
remittance. 

Procedure 
1. From the US Payroll menu, choose Subsequent activities → Period-independent → 

Evaluation → Third-party remittance → Collect data. 

The Payroll Driver (USA) screen appears. 

 
The US Payroll Driver uses schema U500 to collect the third-party remittance data.  

2. Enter the parameters. 

3. Choose Execute 

Result 
The two third-party remittance TemSe files are created and listed in the log. You will use these 
files in the next third-party remittance step to update the system tables that store third-party 
remittance data. 
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Updating the Third-Party Remittance Tables 
Use 
This report updates the remittance tables with data from two TemSe files created in the previous 
third-party remittance step ('Collect Data'). The Temse files contain cumulated third-party 
remittance data collected from the previous payroll run. 

Prerequisites 
You have successfully executed the data collection step for the employee population for which 
you want to run third-party remittance. 

Procedure 
1. From the US Payroll menu, choose Subsequent activities → Period-independent → 

Evaluation → Third-party remittance → Update tables. 

The Update Remittance Tables from TemSe Object screen appears 

2. Select both TemSe files created in the previous data collection run. If they do not match each 
other, they will be rejected. Matching files usually have sequential numbers. 

You can run the update in test mode first to check which data will be updated in the 
real run. 

 

3. Choose Execute. 

Result 
The system issues a log listing HR payees for which third-party remittance is payable, along with 
the amount and the due date. You should note down the earliest due date in the list for use in the 
next step: 'Create Posting Run'. 
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Creating the Third-Party Remittance Posting Run 
Use 
The posting run provides financial posting information. Remittance due is listed according to FI 
vendor and HR payee. A third-party remittance posting run is created  

Prerequisite 
You have successfully carried out the previous third-party remittance step 'Update third-party 
remittance tables'.  

Procedure 

For help on the selection screen, choose the Selection screen help function on the toolbar. 
For additional selection criteria, choose the Selection options button on the toolbar. 

 

Result 
The third-party remittance posting run is created The report creates a log listing all remittances 
due by FI vendor and HR creditor. The third-party remittance posting run is entered at the bottom 
of the log. You can proceed to the next 'Process Posting Run' step by double-clicking on the '3PR 
posting' line. 

 
For information on releasing and posting the third-party remittance items in the 
'Process posting run' step, see the report documentation (RPURMP00) on the 
'Create Posting Run' screen. (choose the information icon). 

1. From the US Payroll menu, choose Subsequent activities → Period-independent → 
Evaluation → Third-party remittance → Create posting run. 

2. Enter the parameters. 

The due date you select for the posting run should always be the first due date listed 
in the update run log from the previous third-party remittance step (Update 
Remittance Tables from TemSe Object - RPURMU00). When you enter this date in 
the Due date field, you should also use the "Less than or equal to" selection option to 
be sure that you catch any earlier outstanding remittance items. 

3. Choose . 

April 2001  665 



Payroll United States (PY-US)  SAP AG 

 

 

 

 

 

666  April 2001 



 SAP AG Payroll United States (PY-US) 

  Processing the Posting Run 

Processing the Posting Run 
Use 
This is where you check, release and post the items in your third-party remittance posting run. 

Prerequisites 

4. From the US Payroll menu, choose Subsequent activities → Period-independent → 
Evaluation → Third-party remittance → Process posting run. 

5. Choose your third-party remittance run from the list of posting runs. (Third-party remittance 
runs appear towards the bottom of the screen, under the heading: 'TP'). 

Result 
The third-party remittance run is posted to FI. 

You have successfully carried out the previous third-party remittance step 'Create posting run'. 

Procedure 

6. Process your third-party remittance posting run by double-clicking it to check and release its 
documents. 

7. Once all documents are released, you can post the entire run to FI from the 'Display posting 
run' screen. 
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Reconciling the Postings 
Use 
This report produces a list of third-party remittance items that have been posted to FI. The list 
contains information confirmed by FI, such as receipt of the posting, payment of the posting and 
FI vendor/HR creditor details. 

Prerequisite 
You have successfully released and posted your third-party remittance posting run to FI/CO. 

Procedure 
4. From the US Payroll menu, choose Subsequent activities → Period-independent → 

Evaluation → Third-party remittance → Reconcile postings. 

The Reconciliation of Transfers screen appears. 

5. Enter the parameters. 

6. Choose Execute. 

Result 
The processed and paid remittances are reconciled. 
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Checking the Processing Classes 
Use 
At times, you may need to change the processing class used for third-party remittance. An 
example of this would be when you change assignment to wage types. 

This program maintains the wage type table according to the assignment of wage types to HR 
creditors. It checks whether the wage types have been assigned the correct processing class 
type in processing class 78. If not, the program either changes the processing class type or 
prompts you to change it in Customizing for third-party remittance. 

Procedure 
1. From the US Payroll menu, choose Subsequent activities → Period-independent →  

Evaluation → Third-party remittance → Check processing classes. 

The Check Processing Classes screen appears. 

2. Enter the parameters. 

3. Choose . 

Result 
The processing classes are maintained. For further information on this report and the resulting 
output, see the report documentation for this screen. 
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Acknowledging the Posting Run 
Use 
This report is intended primarily for use in conjunction with a non-SAP FI system or an R/3 FI 
system with a release prior to 4.0. 

The report reads third-party remittance posting data from the FI system either via manually 
entered data, or a TemSe file created by the external system. It then updates the HR system 
accordingly. 

Prerequisites 
The posting and reconciliation runs have been executed. 

Procedure  
1. From the US Payroll menu, choose Subsequent activities → Period-independent → 

Evaluation → Third-party remittance → Acknowledge postings. 

2. Enter the parameters. 

3. Choose Execute.  

Result 
The acknowledgement run is executed and all those remittances that have been paid are marked 
and identified after the information is sent to the Finances department from HR. 
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Undoing the Processing Steps 
Use 
You can use this report to undo the third-party remittance process at certain, defined points. 

Procedure 
1. From the US Payroll menu, choose Subsequent activities → Period-independent → 

Evaluation → Third-party remittance → Undo processing steps. 

2. Enter the parameters.  

 
You must mark at least the run(s) that you want to undo.  

If you select "Undo all", you will no longer have any information on what has been 
remitted to whom and when. Make sure that you will not need any of the data before 
using this function.  

3. Choose Execute. 

Result 
The run(s) you selected are undone. 
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Payroll Results Adjustments 
Purpose 
Most employees’ payroll results can be made using Retroactive Payroll processing. By correcting 
master data, the system will automatically determine the amounts that should have been paid 
and make the necessary adjustments.   

However, there may be situations where you still need to make manual adjustments or process 
adjustments in a separate payroll run. Adjustments can be made through Master Data 
maintenance, the Off-Cycle Workbench or the Adjustments Workbench. All of these methods are 
based on Infotype 0221 Payroll Results Adjustment.  

Overview of Adjustments and Where They are Maintained 

Type of Adjustment Infotype 0221 
Subtype 

Adjustments 
Workbench 

Off-Cycle 
Workbench 

Master Data 
Maintenance 

x  

Included TWEG x 

x  

Excluded YAWA x   

Included TCRT   x 

Included blank x x x 

Included ADJT x 

x  

Excluded  YANA 

Included adjustments are defined here as adjustments which are included in normal payroll 
processing. This means these adjustments are picked up in retrocalculations, normal payroll runs 
as well as in off-cycle runs of type 'C'. Excluded adjustments are processed outside normal 
payroll processing with their own special adjustment run. These adjustments are therefore kept 
separate from any other master data changes since they are processed independently in their 
own payroll run. 

Process Flow 
1. You discover that you need to adjust an employee's payroll results. 

2. You determine whether the change can be processed in the next regular payroll run, an off-
cycle run, or should be processed separately without any retroactive adjustments that may 
occur.  

3. You make the adjustment either through the Adjustments Workbench, the Off-Cycle 
Workbench or through master data maintenance.   

Adjusting Payroll Results through a Retroactive Master Data Change  
1. Make a retroactive change to the employee's master data.  

2. Run payroll. 

 
You can also trigger a retrocalculation immediately without waiting for the next 
regular payroll run. 
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Result 
The master data change is picked up in the payroll run and the employee's results are 
recalculated accordingly. Both underpayments and overpayments are carried forward to the 
current payroll period, based on the constructive receipt principle. Any overpayments (claims) 
which cannot be cleared by the employee’s current pay will be carried forward into subsequent 
periods until the claim is cleared.   

Adjusting Payroll Results with Infotype 0221, subtype blank   
1. Create an Infotype 0221 record for the employee with the relevant adjustment amounts. 

2. Run either a regular payroll or an off-cycle payroll with Pay Type = C. 

Result 
The change is picked up in the payroll run and the employee's results are adjusted accordingly. 

Adjusting Payroll Results with the Adjustments Workbench 
1. Decide if the adjustment should be processed in the next payroll run, in an off-cycle run, or in 

a special run that will bypass retroactive processing.   

2. Access the Adjustments Workbench and enter the appropriate adjustment. 

If you entered… Then 

An excluded adjustment  
(subtype YANA or YAWA) 

An Infotype 0221 Payroll Results Adjustment subtype record is 
created with adjustment status X (not yet processed). This 
status means that the record will be ignored by the Payroll 
Driver in normal payroll runs and that the record can still be 
changed. 

An included adjustment 
(subtype blank, ADJT, 
TWEG or TCRT) 

An Infotype 0221 Payroll Results Adjustment subtype record is 
created that will be picked up in the next normal payroll run. 

3. Run payroll for the adjustment. 

If you entered… Then 

An excluded adjustment  
(subtype YANA or YAWA) 

Trigger the special adjustment run from the Adjustments 
Workbench to process the adjustment.  

An included adjustment 
(subtype blank, ADJT, 
TWEG or TCRT) 

Run payroll as normal or trigger an off-cycle payroll run with 
type C. 

Result 
If you entered… Then 

An excluded adjustment  
(subtype YANA or YAWA) 

The special run picks up the adjustments and changes the 
adjustment status of the processed subtypes to ' ' (space) and 
updates the sequence number of the special adjustment in 
Infotype 0221. 
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An included adjustment 
(subtype blank, ADJT, 
TWEG or TCRT) 

The adjustments are picked up and processed with the normal 
payroll run.  

See also: 
Payroll Results Adjustment (Infotype 0221) [Page 68 ]2  
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The Adjustments Workbench 
Purpose 
This component allows you to easily process employees’ payroll adjustments. You can create 
two categories of adjustments:  those processed within normal payroll run processing and those 
processed independently in a separate payroll run that bypasses retroactive processing. All 
adjustments you can make are represented various subtypes of Infotype 0221 Payroll Results 
Adjustment. 

Features 
The Adjustments Workbench provides you with the tools you need to  

• make adjustments to an employee's payroll results  

• trigger a special adjustments payroll run  

• correct adjustments  

• determine whether or not adjustments have already been processed in a payroll run  

It functions as a single interface to all the utilities you need to make the adjustments, including 
Infotype 0221 Payroll Results Adjustment, the payroll driver and other tools for checking and 
correcting adjustments. 
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Making an Adjustment (Manual Input) 
Procedure 
1. From the Adjustments Workbench, select the type of adjustment you want to make under 

Manual input and choose  Enter data. 

The Personnel number dialog box appears. 

2. Specify the person for which you are making the adjustment and choose . 

The Create Payroll Results Adjustment screen appears. 

3. Specify the adjustment date in the Adjust. date field. 

 
For prior-period adjustments, the adjustment date must be equal to or later than the 
employee's latest pay date. 

For prior-year adjustments, the adjustment date must create the latest cluster result 
in the year for the employee. If you are making an adjustment for a terminated 
employee or if you have not yet run payroll for the new year, you should change the 
date to the employee's termination date or last pay period end date. 

4. The payroll ID number, which uniquely identifies the adjustment, is defaulted in the Payr.ID 
field. You can overwrite this if necessary. 

5. If desired, enter a reason for the adjustment in the OC reason field. 

6. Specify the wage types and amounts for the adjustment in the Wage, Hour and Amount 
fields. 

Result 
The adjustment has been entered into the relevant Payroll Results Adjustment subtype. If you 
entered an excluded adjustment (subtype YANA or YAWA), the subtype is flagged with the 
adjustments indicator 'X' (not yet processed) and can now be included in a special adjustments 
run. 

 

 

7. Save your entries. 
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Making an Adjustment (Batch Input) 
1. From the Adjustments Workbench, select the type of adjustment you want to make under 

Batch input and choose  Preparation. 

The BDC data import for adjustments screen appears. 

2. Specify the Batch input session name, User name, whether you want to keep the session 
when finished and how long the session should be held. 

3. Specify the name of the file you want to upload in the BDC upload file name field.  

 
The Subtype for Infotype 0221 will be defaulted and cannot be changed. 

4. Choose  to upload the file. 

The file is uploaded and a log screen appears informing you of the status of the upload. 

5. Choose  to return to the Adjustments Workbench. 

6. Choose  Batch input to start the batch input session that will load the adjustments into the 
relevant Payroll Results Adjustment subtypes.  

The Batch Input: Session Overview screen appears. 

7. Select the relevant session and choose  Process to start the session. 

Result 
The adjustment has been entered into the relevant Payroll Results Adjustment subtype and 
flagged with the adjustments indicator 'X' (not yet processed) and can now be included in a 
special adjustment run. 
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Preparing Files for Batch Input 
Use 
If you need to make mass adjustments through the Adjustments Workbench, you can do so 
through batch input. 

Procedure 
1. On the Adjustments Workbench, choose  to download a sample batch input file.  

2. Save the sample file with extension .txt. 

3. Open the sample file in any spreadsheet program to determine how the data needs to be 
entered in the file. 

 
If you are opening file in Excel and the Text Import Wizard appears, simply choose 
Finish to load the file. 

4. Enter data in the spreadsheet as needed with up to 20 entries per personnel number. 

5. Save the file as type TXT with tabs as separators. 

6. On the Adjustments Workbench, choose  Preparation to upload the TXT file. 

7. Execute batch input processing. 

Result 
You have uploaded a file for batch input in the correct format and can now start the batch 
adjustment process. 
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Special Adjustment Run 
Use 
This function recalculates an employee's payroll results once an excluded adjustment has been 
made for the employee through the Adjustments Workbench. Special adjustment runs only pick 
up excluded adjustments, which are made with Infotype 0221 subtypes YAWA and YANA and do 
not include any master data changes that may have been made for an employee.  

Excluded adjustments created from the Adjustments Workbench are processed with payroll run 
type 'C' (Manual Check). 

Integration 
Special adjustment runs are called from the Adjustments Workbench. 

Activities 
When you execute a special adjustment run, the special adjustment date specified on the 
selection screen must match the adjustment date specified on the Infotype 0221 subtype.  
The special run picks up the adjustments and changes the adjustment status of the processed 
subtypes to from X to ' ' (space) and updates the sequence number of the special adjustment in 
Infotype 0221. 
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Starting a Special Adjustment Run for Excluded 
Adjustments 
Use 
Special adjustment runs are necessary to pick up excluded adjustments made from Adjustments 
Workbench. Excluded adjustments are those adjustments that are processed outside the normal 
payroll processing, and are made with Infotype 0221 subtypes YANA and YAWA. 

Prerequisites 
You have created an excluded adjustment the Adjustments Workbench that has not yet been 
processed by a special adjustment run. If you entered the adjustments through batch input, then 
must have also already processed the batch input session to upload the adjustments to the 
subtypes. 

Procedure 
Procedure for manual input 
8. From the Adjustments Workbench, select the type of adjustment you want to make under 

Manual input and choose  Payroll. 

9. On the Personnel number dialog box, specify the person for which you want to run payroll 
and choose  Continue. 

The Payroll Driver screen appears. 

 
The payroll area is defaulted based on the personnel number you entered. The 
correct payroll run type is defaulted based on the type of adjustment you selected on 
the Adjustments Workbench.  

10. Specify the relevant payroll identifier that uniquely identifies the adjustment in the Off-cycle 
payroll section. 

11. Specify the run date in the Off-cycle payroll section. 

 
The run date must match the adjustment date specified on the Infotype 0221 subtype 
used to make the adjustment.  

12. Choose . 

Procedure for batch input  
8. From the Adjustments Workbench, select the type of adjustment you want to make under 

Batch input and choose  Payroll. 
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The correct payroll run type is defaulted based on the type of adjustment you 
selected on the Adjustments Workbench.  

9. Specify the employee population for which you want to run payroll in the Selection section.  

10. Specify the adjustment date and relevant payroll identifier that uniquely identifies the 
adjustment in the Off-cycle payroll section. 

11.  Choose . 

Result 
A special payroll run is carried out for the adjustments. 
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Payroll Results Adjustment (Infotype 0221) 
Definition 
The Payroll Results Adjustment infotype allows you to enter data for checks that were issued 
outside of the SAP Payroll system. This data is then updated in the employee's payroll results in 
the SAP Payroll component.  

Adjustments made with Infotype 0221 are processed in the period represented by the check date 
on the infotype and are therefore taxed on a taxed-when-earned basis. This differs from normal 
retroactive master data changes, which are taxed using the wage offset method (tax-when-paid). 

Use 
The following table gives an overview of the various Infotype 0221 subtypes, where you can 
maintain them, what you need to enter on the subtypes, what the system calculates and how 
they are picked up and processed. 

Overview of Payroll Results Adjustment Subtypes and Their Uses 

Subtyp
e 

Where maintained What you specify What the system 
calculates 

How 
processed 

blank 
(NAMC) 

Adjustments 
Workbench / 
Master Data / Off-
Cycle Workbench 

positive gross 
amounts, employee 
taxes 

employer taxes, 
technical wage types 

Included in 
normal payroll 
processing 

ADJT Adjustments 
Workbench / 
Master Data 

positive and negative 
gross amounts, both 
employee and 
employer taxes 

technical wage types Included in 
normal payroll 
processing 

TWEG Adjustments 
Workbench / 
Master Data 

positive gross 
amounts 

employee and 
employer taxes, 
technical wage types 

Included in 
normal payroll 
processing 

YANA Adjustments 
Workbench  

positive and negative 
gross amounts, 
technical wage types, 
both employee and 
employer taxes 

nothing 

 

Special payroll 
run (excluded 
from normal 
payroll 
processing) 

YAWA Adjustments 
Workbench  

positive gross 
amounts, employee 
taxes (optional) 

employee and 
employer taxes, 
technical wage 
types,  

Special payroll 
run(excluded 
from normal 
payroll 
processing) 

TCRT Master Data employee and 
employer taxes 

nothing Included in 
normal payroll 
processing 
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Structure 
The Payroll Results Adjustment infotype (0221) consists of a main infotype screen for entering 
manual check data and various subtypes with slightly different screens and logic, allowing you to 
make adjustments to adjustment data for an employee. 

Integration 
This infotype is closely integrated with the US Payroll component. Data entered in this infotype 
and its subtypes is directly updated in the payroll results cluster for the employee. 

See also: 
Payroll Results Adjustment - Subtype 'blank' [Page 684] 

Payroll Results Adjustment - Subtype ADJT [Page 685] 

Payroll Results Adjustment - Subtype TWEG [Page 686] 

Payroll Results Adjustment - Subtypes YANA and YAWA [Page 687] 

Payroll Results Adjustment - Subtype TCRT [Page 688] 
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Payroll Results Adjustment - Subtype 'blank' 
Definition 
Subtype 'blank' (Non-authorized manual check) of Infotype 0221 (Payroll Results Adjustment) 
allows you to make positive adjustments to employees' payroll results.  

When you make an adjustment with subtype 'blank', you specify the positive adjustment amount 
and employee taxes. The system calculates the employer taxes and the taxable wages (technical 
wage types) during the payroll process. 

Use 
This subtype can be used to enter an adjustment for an employee when you know the gross 
adjustment amount and the employee taxes, but you want the system to calculate the employer 
taxes and technical wage types. This subtype is maintained either directly through Master Data 
maintenance, the Adjustments Workbench or through Off-Cycle Payroll. 

Structure 
The Infotype 0221, subtype 'blank' screen allows you to enter the following information: 

• Check date  

 
If you enter a check date that falls in the prior year and you have already begun 
running payroll for the current year, you cannot use the Start payroll function from the 
Infotype 0221 screen. You can either wait for the next regular payroll run or trigger 
the adjustment from the payroll driver screen using special run type C and the 
Payr.ID you specified for the entry on the infotype. 

• Payroll identifier  

• Check number  

• Tax company 

• Off-cycle reason  

• Payment and deduction wage types and amounts  

• Tax authorities for tax deductions 
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Payroll Results Adjustment - Subtype ADJT 
Definition 
Subtype ADJT (Adjustment NAMC) of Infotype 0221 (Payroll Results Adjustment) allows you to 
make positive and negative adjustments to employees' payroll results.  

When you make an adjustment with subtype ADJT, you need to determine the appropriate taxes 
for the adjustment and specify them on the subtype. The system only calculates the taxable 
wages (technical wage types) during the payroll process. 

Use 
This subtype allows you to adjust an employee's payroll results when you know the gross 
adjustment amount as well as the tax amounts to be adjusted. This subtype also has functionality 
to help clear claims from payroll.  

 
To clear the claims, you first need to execute the Claims Processing report (from the 
Payroll USA menu: Period-independent -> Payroll supplement -> Claims processing) 
to determine the gross and net claim amounts, and the tax components on the claim. 
The repayment amount is listed in the report output. These amounts must be listed 
on Infotype 0221 subtype ADJT, with the wage type RPAY representing the 
repayment amount. When ADJT sees the RPAY wage type, it performs special 
processing to clear the claim from payroll.  

Note: This procedure is only valid for terminated employees. 

Structure 
The Infotype 0221, subtype ADJT screen allows you to enter the following information: 

• Check date  

 
If you enter a check date that falls in the prior year and you have already begun 
running payroll for the current year, you cannot use the Start payroll function from the 
Infotype 0221 screen. You can either wait for the next regular payroll run or trigger 
the adjustment from the payroll driver screen using special run type C and the 
Payr.ID you specified for the entry on the infotype. 

• Payroll identifier  

• Check number  

• Tax company 

• Off-cycle reason 

• Payment and deduction wage types and amounts  

• Tax authorities for tax deductions 
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Payroll Results Adjustment - Subtype TWEG 
Definition 
Subtype TWEG (Prior period gross adjustment) of Infotype 0221 (Payroll Results Adjustment) 
allows you to make positive adjustments to employees' payroll results.  

When you make an adjustment with subtype TWEG, you simply need to specify the gross 
adjustment amount. The system calculates all taxes and taxable wages (technical wage types) 
during the payroll process. 

Use 
This subtype allows you to make adjustments to an employee's payroll results when you know 
the gross adjustment amount, but want the system to calculate the taxes. This is especially 
useful when making adjustments to imputed income. 

Structure 
The Infotype 0221, subtype TWEG screen allows you to enter the following information: 

• Check date  

 
If you enter a check date that falls in the prior year and you have already begun 
running payroll for the current year, you cannot use the Start payroll function from the 
Infotype 0221 screen. You can either wait for the next regular payroll run or trigger 
the adjustment from the payroll driver screen using special run type C and the 
Payr.ID you specified for the entry on the infotype. 

• Payroll identifier  

• Check number  

• Tax company 

• Off-cycle reason  

• Payment and deduction wage types and amounts  

• Tax authorities for tax deductions 
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Payroll Results Adjustment - Subtypes YANA and YAWA 
Definition 
Subtypes YANA (Adjustments, No Tax Calculation) and YAWA (Adjustments Without Tax 
Calculation) of Infotype 0221 (Payroll Results Adjustment) allow you to make non-cash 
adjustments to employees' payroll results without triggering retrocalculation.  

When you make an adjustment with subtype YANA, you need to determine the appropriate taxes 
for the adjustment and specify them on the subtype. When you make an adjustment with subtype 
YAWA, you only need to specify the gross adjustment amount. The system automatically 
calculates the employee and employer taxes and technical wage types during the payroll 
process.  

Use 
These subtypes allow you to make changes to an employee's payroll results separately from 
master data changes that affect an employee's payroll results. Adjustments made with subtypes 
YANA and YAWA are handled outside the normal retrocalculation process. This ensures that 
YANA and YAWA adjustments are not affected by normal payroll runs. It also ensures that other 
master data changes are still picked up in normal payroll runs.  

You must manually trigger a special adjustment run to process these adjustments from the 
Adjustments Workbench. This special adjustment run only takes into account adjustments with 
subtypes YAWA and YANA; normal master data changes are not taken into account until the 
next normal payroll run. 

Structure 
The Infotype 0221, subtypes YANA and YAWA screens allow you to enter the following 
information: 

• Check date  

• Payroll identifier  

• Check number  

• Tax company 

• Off-cycle reason  

• Payment and deduction wage types and amounts  

• Tax authorities for tax deductions 

Integration 
These subtypes are maintained through the Adjustments Workbench. 
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Payroll Results Adjustment - Subtype TCRT 
Definition 
Subtype TCRT allows you to adjust employee and employer taxes in table TCRT. 

Use 
Subtype TCRT allows you to maintain accurate tax balance limits for employees who switch tax 
companies during the year. In this subtype, you can enter a special wage type representing the 
cumulated tax amount that was paid before the employee switched tax companies. This 
'artificially' boosts the total tax paid for each pay period in which you enter the wage type, 
ensuring that cumulated tax amounts continue to build on the cumulated amount, in spite of the 
change in tax company. 

 
This subtype only updates table TCRT (and not RT or CRT). 

Structure 
The Infotype 0221, subtype TCRT screen allows you to enter the following information: 

• Check date  

• Payroll identifier  

• Check number  

• Tax company 

• Off-cycle reason 

• Employee and employer tax wage types and amounts  

• Tax authorities for tax deductions 
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Out-of-Sequence Checks 
Use 
Out-of-sequence check processing is supported by SAP Payroll. Using this functionality, your 
enterprise may execute off-cycle payroll runs with a pay date that is earlier than the pay date of 
the last completed payroll run. Out-of-sequence check processing primarily affects bonus, 
correction, and year-end adjustment payroll runs. 

Example 
In certain prior releases, if you ran payroll on May 25 for pay period 10, with May 30 as the pay 
date, then the earliest possible pay date for subsequent off-cycle payroll runs would have been 
May 30. To illustrate, if an employee left your enterprise on May 27 without providing appropriate 
notice, and if you are required by law or company policy to pay all outstanding wages 
immediately as a payment in advance, then the earliest possible pay date for that payment would 
have been May 30. However, using the functionality that supports out-of-sequence checks, you 
may now select May 27 as the pay date in the described scenario. 

Integration 
Out-of-sequence check processing is fully integrated for use within the U.S. Payroll component. 

Prerequisites 
If your enterprise has never issued out-of-sequence checks, then you must configure your 
system to do so. To this end, execute the following steps in the U.S. Payroll IMG: 

• Cumulations → Company-Specific Cumulation → Define cumulation intervals 

• Cumulations → Generate cumulation intervals 
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Payroll Reporting (PY-US-RP) 
Purpose 
The R/3 HR Payroll System provides all regulatory and tax reports required by U.S. federal and 
state law, such as SUI reports for state unemployment agencies, W-2 reports for the federal and 
state governments, and the Multiple Worksite Report for the Bureau of Labor Statistics. 
Additional payroll reports are available for other business purposes, such as the New Hire 
Report. These reports allow efficient evaluation of payroll data and ensure compliance with 
government regulations.  

Implementation Considerations 
When implementing R/3 Payroll, ensure that all configuration steps for regulatory reports are 
carried out in such a way as to guarantee compliance. For example, some reports use forms that 
you configure in the IMG. If you do not configure the form properly, the reports may not generate 
certain kinds of data that are required by law.  As the laws affecting regulatory reports change, 
you may need to re-examine the payroll IMG to make adjustments, thereby ensuring compliance. 

Integration 
Payroll reports access information from all HR infotypes and evaluate data from HR Time 
Management and HR Organizational Management as well as HR Personnel Administration. 

Features 
R/3 Payroll offers numerous internal and regulatory reports, including: 

• New Hire Reporting 

• Tax Reporter for federal and state reports 
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Tax Reporter 
Purpose 
This component enables you to produce payroll tax and other reports for government authorities 
in the format required by each authority.  

Tax Reporter generates the following forms: 

• Form 940 – Employer’s Annual Federal Unemployment Tax Return  

• Form 941 – Employer's Quarterly Federal Tax Return 

• Form 941C  

• Form W-2 – Wage and Tax Statement 

• Form W-2C 

• 1099-R  

• 1099-RC 

• Multiple Worksite Report (Combined format for Bureau of Labor Statistics) 

• Unemployment Insurance reports for all states 

Implementation Considerations 
Tax Companies  
Tax Reporter can only be run in production mode for an entire tax company. In the SAP system, 
you assign tax companies to employees indirectly – via the personnel area and subarea (IMG: 
Payroll USA -> Tax -> Tax companies). You should therefore ensure that tax companies have 
been defined correctly and are represented properly in employee payroll results before you start 
testing tax reporter. 

Client-dependent entries 
Where SAP delivers preconfigured tax form tables for a magnetic media report (diskette or tape) 
such as the SUI or W-2 reports, the configuration is loaded to your system either as a transport 
or as an LCP. For this reason, it is very important for the IT support teams responsible for HR to 
understand how to properly cascade customizing entries from client 000 to the test and 
production clients. 

Worksites 
If you are producing a Multiple Worksite Report (MWR) from the SAP Tax Reporter component, 
these worksites must exist in the configuration for US Personnel Administration. End users 
should be trained to enter the worksite on IT0209 when hiring or transferring employees. 

Features 
Tax Reporter supports at least one of the required media formats for each tax authority and 
report provided. For example, some reports are set up to be compliant for magnetic tape 
reporting as opposed to diskette or paper, and the supported format may vary from one tax 
authority to another.  
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Additionally, users can create their own tax reports for authorities and/or forms not supported in 
the standard SAP Payroll system. For example, if you have employees in the state of 
Pennsylvania, you may want to create a number of custom tax reports for reporting withholding 
and occupational taxes and wages to the many school districts and other tax authorities in that 
state. 
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The Reporting Process 
Purpose 
This process describes how to use Tax Reporter to create regulatory reports for federal and local 
agencies.  

Prerequisites 
You must have already run payroll for your employees and have payroll results. Some reports 
may also require that specific infotypes have been maintained. 

Process Flow 
The Tax Reporter Reporting Process 

The following graphic provides a technical overview of the Tax Reporting process: 

 
Table RT

 

 
Table RT
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The reporting process is roughly the same for all reports generated by Tax Reporter, the 
periodicity (for example, quarterly or annual) of the reports depends on federal and local 
requirements. 

Tax Form Generation 
Specify exactly what report you want to generate and the area and period for which you want the 
report created. The system uses your entries to extract the appropriate data from the payroll 
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results. You can output the form on paper, magnetic tape or magnetic diskette depending on the 
report you choose. 

 
Tax forms are always run for a Tax Company. You cannot perform a production tax 
form run for a subset of employees or individual employees, however you can 
perform simulations of any tax form for any groups of employees. 

Result 
You have produced the regulatory report in the format required by the government agency and 
can now submit it. 
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The Forms Cluster 
Definition 
The forms cluster allows for greater flexibility when rerunning forms after retrocalculations have 
been performed. 

Use 
The forms cluster (PCL4) serves as persistent storage for any form produced by Tax Reporter. It 
stores actual tax form field data as reported on the form. The forms cluster contains tax form field 
data at employee level as well as at aggregate (Tax Company level). After a retrocalculation has 
been performed to correct data in Payroll, you can rerun a tax form for the employee, and Tax 
Reporter will obtain the new result for the employee and update the cluster accordingly. 
To view the contents of the forms cluster, select a tax form, then choose Utilities  Display form 
fields from the initial Tax Reporter screen. 
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Tax Form Reconciliation 
Definition 
All tax form reconciliation is carried out using the Payroll Reconciliation Report. 

To access the Payroll Reconciliation report from the US Payroll menu, choose Subsequent 
activities → Per payroll period → Lists/statistics → Payroll reconciliation report. 

The Payroll Reconciliation Report balances tax forms to Payroll and FI by showing you the 
payroll results totals for tax form-relevant wage type groupings (such as Taxable earnings) for 
each tax company and tax authority selected. Additionally, this report is specially designed to 
display any retrocalculations that impacted the reporting period’s results but which were not 
included on the tax form because they were created after the tax form run. 

 
W-2 forms are run on January 14th. On January 15th, a retrocalculation is performed 
that changes taxable wages for an employee in the prior year. This prior year 
adjustment will be listed separately on the Reconciliation Report, as it will not be 
included in the tax form itself. 

Process Description: 
To reconcile a tax form produced by Tax Reporter, use the following general process: 
1. Set up the Payroll Reconciliation Report to look at the same tax company and reporting 

period as the form you are producing. 

 
Running the reconciliation report by a tax company may cause the report to run more 
slowly than using another selection such as company code or personnel area. If your 
tax company is large (containing over 10,000 employees) and maps exactly to a 
personnel area/subarea or a company code, it is advisable to run the report by those 
criteria instead of choosing the tax company on the report selection screen. The 
reason for this is that company code, personnel area and subarea are HR Logical 
Database fields, and tax company is not. HR reports can select employees more 
quickly for Logical Database fields than for other fields not included. Also, choosing 
“employee details” for a large employee range can significantly slow the program. 

2. Check the wage type groupings on the report to match the boxes on the tax form you are 
reconciling. 

 
When reconciling a tax form, make sure you select Tax Company and Tax Authority 
as “Reportable Fields” on the selection screen. Otherwise, tax wage type amounts 
will be totaled for all tax companies and authorities, yielding unusable results. 

3. Where variances exist between the reconciliation report and the tax form, check the following 
two factors: 

a) Number of employees selected: The Reconciliation Report will select all employees 
with current RT results in the tax company and period you selected. Tax Reporter, 
however, contains logic that rejects some employees from a tax form run, such as 
when the employee has negative wages. Always check the Tax Reporter Log for the 
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form you are balancing prior to running the reconciliation report to see if and how 
many employees were rejected from the tax form run. If employees were rejected, 
manually exclude those employees from the Payroll Reconciliation Report run. 

b) Manual entries in the Tax Interface Table (T5UT1). You may sometimes need to 
make manual entries for an employee in one or more tax form groups to ensure that 
values are included on the tax form that for some reason were not included in the 
payroll results. Since the Reconciliation Report does not read this table, you need to 
know which employees had manual entries, and which tax form groups/wage type 
groupings they impacted. 

Result 
Using this basic technique, you should be able to quickly identify the source of variances 
between payroll results/FI postings and tax form data. 
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Form Field Definition 
Use 
This function allows you to check the configuration of the tax form groups assigned to the forms 
you generate with Tax Reporter. You can do this by drilling down within each tax form group to 
see which wage types you have assigned to it. 

Prerequisites 
You have configured your tax form groups in the Tax Form Groups section of the Tax Reporter 
chapter of the US Payroll Implementation Guide (IMG) . 

Features 
This function enables you to drill down from a tax form field to tax form groups and from a tax 
form group down to the actual wage types that make up the amount that appears in the tax form 
field. The graphic illustrates this process using the example of Box 2 (Federal income tax 
withheld) from the W-2 Wage and Tax Statement form.  

Wage Type Drilldown 

 

Activities 
To access this function from the Tax Reporter screen, choose the desired form from the Tax 
Forms structure on the left side of the screen, the Form field definition tab and then the Display 
form fields function button. 
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Generating Tax Forms 
Prerequisites 
• You have carried out all necessary configuration steps in the Tax Reporter section of the US 

Payroll Implementation Guide (IMG). 

• You have defined an output device in User Profiles under System on the main R/3 menu. 

Procedure 
1. From the US Payroll menu choose Subsequent activities → Period-independent → Payroll 

supplement → Tax Reporter. 

The Tax Reporter screen appears. 

2. On the tree structure on the left side of the screen, choose the periodicity relevant for your 
form class (for example, Annual for W-2), and then your form class. 

A generation screen specific to your form class appears. 

3. Enter the desired tax company and generation date in the appropriate fields (if you leave the 
tax company field blank, all tax companies will be selected), and on the PROD. run screen 
you can further define your selections and output (if relevant for your form class). 

 
To generate your forms in test mode choose the TEST run tab. On the screen that 
appears, enter a range of personnel numbers, choose a data source (payroll results 
or tax interface tables), and choose the Test online function button (or Test 
background to process your test run in the background). 

4. Choose Online. 

 
If you prefer to generate your forms in the background, choose Background. On the 
dialog-box that appears, enter your background job scheduling information, and 
choose Save. 

The Generation run output screen appears displaying the categories of output 
organized in a tree structure.  

5. To print a form, expand the Forms folder of the tree structure and choose the icon 
next to a form in the list. On the Tax reporter Forms Print/Preview screen, choose 
Print. On the following screen, specify an output device and then choose the print 
icon.  

6. To download a magnetic media file to a local directory, expand the Magnetic Media 
file folder, choose the desired file from the list that appears. The View/Download 
Magnetic Tape Files screen appears, which displays the contents of the file Choose 
Download, and on the dialog-box that appears, specify a local directory and Save. 

 
If you would like to view the structure of the file, choose File Structure from the 
View/Download Magnetic Tape Files screen. You can also verify the contents of the 
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magnetic media file by double clicking in any record of the displayed file. This calls 
up a special view that allows you to quickly check the Tax Reporter has added the 
correct content to each field on the tape. 

7. Check the Log section of the output to see what messages were issued during the run, if 
manual entries were read, employees were rejected, etc. 

Result 
The forms and reports (where applicable) are generated in the specified formats.  

 
You can verify the data generated using the US Payroll Reconciliation Report. 
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User Preferences in Tax Reporter Generation 
Use 
The User Preferences dialog-box Tax Reporter allows you to define what appears on the screen 
when you start Tax Reporter and specify the sort order for downloading magnetic media files. 

To access the User Preferences maintenance dialog-box form Tax Reporter, choose Tools → 
Preferences. 

Structure 
The User Preferences dialog-box consists of the selection areas which allow you to 

• designate which screen should appear when you start Tax Reporter 

- the last screen accessed 

- the screen for a particular form class (for example. W-2 Processing) 

• specify that the form selection tree-structure appears expanded, showing all available forms 
at start-up 

• specify a default sort order in which  magnetic media files downloaded 

• specify form output selection details to be shown at start-up 

• determine whether the tab for Productive run, Test run, Generation dates, or for Form 
Definition appears as the active tab at start-up. 
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View/ Download Magnetic Media Files Created During 
Tax Reporter Generation 
Use 
By selecting the All mag.media files function button on the Tax Reporter screen, you can display 
a list of magnetic media files that have been generated (in production and/or test mode) for a 
particular form class. From the list screen you can display the contents for a particular file, and 
download the file to a local directory. 

Prerequisites 
You have run Tax Reporter for the desired tax form class (W-2 Processing, for example). 

Procedure 
3. From the US Payroll menu choose Subsequent activities → Period-independent → Payroll 

supplement -> Tax reporter. 

The Tax Reporter screen appears. 

2. To view magnetic media files for all tax form classes for both productive and test 
generation runs, choose the All mag. media files function button. 

 
You can also restrict you selection to magnetic media files generated for a particular 
form class and generation run type (productive or test) by choosing the desired form 
class from the Tax Forms tree structure, the corresponding PROD. run or TEST run 
tab on the main screen, and then the mag. media files function button. 

3. If the Sorting order dialog box appears, specifiy the order in which you wish to have 
the magnetic media files displayed, and then choose Continue . 

 
If you have already defined a default sort order in Preferences, this dialog box will 
not appear. For further information on defining user preferences, see User 
Preferences in Tax Reporter Generation [Page 701]. 

Result 
A list of the magnetic media files generated in Tax Reporter is displayed according to your 
selection criteria. From this screen, you can drill down to view the contents of the magnetic media 
files displayed or download these files. 
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Correction W-2 Forms 
Definition 
A Correction W–2 is an adjusted version of the employee copy of Form W–2, and can be 
generated before tax forms are filed with tax authorities.  

Use 
Before you file your W–2s with the relevant tax authorities, Tax Reporter allows you to generate 
Correction W–2s for employees whose wage and tax information is adjusted after the W–2 
employee copies have been distributed. “Correction” is printed on the face of Correction W-2s to 
differentiate these forms from the incorrect originals. 
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Generating Correction W-2 Forms 
Use 
In some cases it is necessary to make a correction to an employee's payroll results that will affect 
his or her W-2 form. If this change is made after you have generated and distributed W–2s to 
employees, but before have filed the W–2s with tax authorities (no “File date” in the Generation 
Bookkeeping Table for the SAPS file (HR_F_W2)), you can produce Correction W-2 forms within 
Tax Reporter. 

Whenever a payroll is run which changes tax amounts for a period that has already been 
reported from Tax Reporter, Payroll flags the employee and the run in a special Cross-Period 
Recalculation table (T5UQR). The Payroll function that performs this check and flagging is 
UCQRC. The procedure below shows how you can take advantage of this function  

Prerequisites 
You have adjusted the payroll results of the employees for whom you are generating Correction 
W-2s. 

Procedure 
1. From the US Payroll menu choose Subsequent activities → Period-independent → Payroll 

supplement -> Tax reporter. 

2. The Tax Reporter screen appears. 

3. On the tree structure on the left side of the screen, choose Annual and then W-2 Processing. 

4. The W-2 Processing generation screen appears. 

5. Enter the relevant tax company and generation date in the appropriate field, and on the 
PROD. run screen select Generate employee copy, Generate magnetic tape and then the 
Employee copy icon. 

6. Select the Correct employees only with retroactive changes radio button. 

 
The other radio buttons provide additional options, such as forcing correction for 
specific employee numbers. This may be useful if a change was made that did not 
cause the employee to be flagged in T5UQR, such as a name or Social Security 
number change. 

7. Choose Online. 

 
If you prefer to generate your forms in the background, choose Background. On the 
dialog box that appears, enter your background job scheduling information, and 
choose Save. 

8. A dialog box appears asking whether or not you wish to overwrite existing results. Choose 
Yes. 

9. The Generation run output screen displays the categories of output organized in a tree 
structure. 
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10. To print the employee Correction W-2 forms, expand the Forms folder of the tree structure 
and choose the icon next to Form W-2 Multiple Copy per Employee On the Tax reporter 
Forms Print/Preview screen, choose Print. On the following screen, specify an output device 
and then choose the print icon.  

Result 
Correction W–2s are generated for the specified employees and the magnetic media files are 
updated to reflect the adjustments. 

 
Even if you generate Correction W-2s for only a few employees, the system may 
require considerable time to process the form data, since all magnetic media files 
affected by the adjustments must be updated. 
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Reprinting W-2 Employee Copies 
Use 
If you have generated and distributed W–2s to employees and need to reprint a W-2, for 
example, if an employee requests another copy, you can use this function to reissue a W-2 to an 
employee. 

Procedure 
1. From the US Payroll menu choose Period-independent, then Payroll supplement  → Tax 

reporter → Generation. 

The Tax Reporter: Generation screen appears. 

2. Enter the desired tax company and generation date in the appropriate fields. 

3. Choose Annual from the tree structure on the left side of the screen, and then W-2 
Processing. 

4. Choose the W-2 Processing (PROD. run) tab on the main screen. 

5. On the screen that appears, enter the desired range of employees, select Print copies. 

 
Make sure that you select Generate employee copy only. 

6. Choose Online. 

The Confirmation dialog box appears. 

7. Choose Print. 

The W-2 Processing Generation run output screen appears. 

8. Choose the Forms folder icon and then icon next to Form W-2 Multiple Copy per Employee. 

The Tax Reporter Forms - Print/Preview Utility screen appears. 

9. Choose Print, specify an output device, and choose the Print icon. 

Result 
W-2 Forms are printed directly from the tax form data in PCL4. No tax form generation is 
performed by the Print Copies function. You can also use the “Print copies” function to generate 
magnetic media from the tax form cluster. 
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Generating for W-2c Forms 
Prerequisites 
You must have generated W-2s for a Tax Company in production mode and marked the run as 
filed (using the menu path Tools->Set filing date in Tax Reporter). 

Procedure 
1. From the US Payroll menu choose Subsequent activities → Period-independent → Payroll 

supplement -> Tax reporter. 

The Tax Reporter screen appears. 

2. On the tree structure on the left side of the screen, choose Annual, and then W-2c 
Processing. 

The W-2c Processing generation screen appears. 

3. Enter the desired tax company and generation date in the appropriate fields (if you leave the 
tax company field blank, all tax companies will be selected). 

5. On the W-2c PROD. run screen, enter the desired range of employees and choose 
Online. 

 
If you prefer to generate your forms in the background, choose Background. On the 
subsequent dialog box that appears, enter your background job scheduling 
information, and choose Save. 

The Generation run output screen appears, displaying the categories of output 
organized in a tree structure.  

5. To print the employee copy W-2c Forms, expand the Forms folder of the tree 
structure and choose the icon next to W-2c Forms in the list that appears. On the Tax 
reporter Forms Print/Preview screen that appears, choose Print. Specify an output 
device and then choose the print icon.  

6. To download a magnetic media file to a local directory, expand the Magnetic Media 
file folder, choose the desired file from the list that appears. The View/Download 
Magnetic Tape Files screen appears, which displays the contents of the file Choose 
Download, and on the following dialog box that appears, specify a local directory and 
Save. 

 
If you would like to view the structure of the file, choose File Structure from the 
View/Download Magnetic Tape Files screen. 

Result 
W-2c forms and data are generated for the employees selected. Six forms (copies A, B, C, D, 1, 
and 2) are produced for each employee. The system outputs two forms per page (A with 1, B 
with 2, and C with D) for a total of three pages. The system also generates a separate Notice to 
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Employee and a summary W-3c form. When you generate W-2c forms for multiple employees, 
the copies are sorted by employee.  

Some of the boxes on the W-2 do not have boxes that directly correspond to them on the W-2c. 
The table below shows where the corrected amounts go on the W-2c if there are no designated 
boxes for the information on the W-2c. 

 

Original on W-2 Is placed on W-2c in 

Advance EIC payment (Box 9) Empty box on the left 

Dependent care benefits (Box 10) Empty box on the left 

Nonqualified plans (Box 11) Empty box on the left 

Benefits included in box 1 (Box 12) Empty box on the left 

Box 13 items A - H Empty box on the left 

Special tax types (Boxes 19-21) Boxes 20-21 

 

Box 19 on the W-2 contains text information. This information is placed in front of the Box 20 and 
Box 21 information on the W-2c. 
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Multiple Worksite Reporting 
Use 
Employers are required to submit the Multiple Worksite Report (MWR) to the Bureau of Labor 
Statistics (BLS) in addition to quarterly state unemployment insurance (SUI) contribution and 
wage reports to state authorities.  

Integration 
The Multiple Worksite Report is a subset of the Tax Reporter component. It relies on results from 
the Payroll component and master data from Personnel Administration. When payroll is run, 
worksite information is stored in the TAXR table of the payroll results cluster. When you prepare 
to run Tax Reporter, this worksite data is transferred to the Tax Interface tables (T5UT1 and 
T5UT2). MWR pulls this worksite data from the Tax Interface tables. 

Features 
The MWR is a totaling report that reports the sum of employees in different worksites, rather than 
providing details for each employee. The MWR also lists, per worksite, total wages for the 
reporting period, headcount by month, and reporting unit address. This report generates a file in 
the magnetic tape format required by the BLS. A paper log is also created (for employer record-
keeping purposes only). The MWR can be filed individually to each state or centrally to the BLS 
for all states (provided you have registered with the BLS). 
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Running the Multiple Worksite Report 
Prerequisites 
• You have entered the relevant worksite data for each of your employees in Infotype 209 

(Unemployment State) and have decided whether you want to file the MWR separately for 
each state, or centrally for all states. 

• If you choose to file the MWR centrally for all states, you must first register with the Bureau of 
Labor Statistics (BLS). 

Procedure 
1. Choose: Human resources → Payroll → America → USA, then Subsequent activities → 

Period-independent → Payroll supplement -> Tax reporter. 

The Tax Reporter screen appears. 

2. Run the Tax Reporter function for that company or companies, using Multiple Worksite 
Report - Combined for central filing to the BLS or Multiple Worksite Report - 
State Level if you are filing the MWR by state. 

 
SAP recommends filing the MWR centrally with the BLS for all states. 

3. Download the TemSe file created by Tax Reporter to magnetic tape, and submit the tape to 
the appropriate authority. 

 

Result 
You have generated the data for the Multiple Worksite Report and can now submit it to the 
appropriate authority. 
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New Hire Reporting 
Use 
The Personal Responsibility and Work Opportunity Act of 1996 requires reports to be generated 
and sent to state tax authorities after new employees are hired. Companies that operate in 
multiple states can also choose to file their new hire reports for all states centrally to one state. 
The New Hire Report generates these reports, which include all federal and state requirements.  

Prerequisites 
Depending on the state or states in which your company operates, the New Hire Reporting 
frequency may vary. Determine the required reporting frequency prior to running the New Hire 
Report. 

Features 
The report contains the following federally mandated information for each new hire in the 
reporting period: 

• Employee name 

• Social Security Number 

• Employee address 

• Employer name  

• Employer address 

• Employer Identification Number (EIN) 

Some states require additional types of information, such as employee date of birth, hire/rehire 
date, and employer SUI account number. 

The report allows employers to choose any state in which they operate as the one to which they 
report all new hires.  Based upon that choice, the system automatically selects the appropriate 
information required by that state and produces a data file for all newly hired and rehired 
employees for the period specified.   

The report results can be output on magnetic media or printed and saved. 

Activities 
To run the New Hire Report from the Personnel administration menu choose Administration → 
Reporting → Reports → Administration US → Compliance → New Hire Reporting. When you run 
this report, it reads all needed employer and employee data from various sources, including the 
tax interface tables and employee master data from infotypes 0000, 0001, 0002, 0006, 0007, 
0167, 0209, and 0210.  The program also determines which information is necessary for each 
new employee in the reporting period selected, depending on the employee’s Unemployment 
Insurance (UI) state. 
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Running the New Hire Report 
Prerequisites 
Determine the reporting period required by the states in which your company operates prior to 
running the New Hire Report. Also ensure that all required data has been entered in the relevant 
infotypes.  

If you choose to submit the combined report on magnetic media, you also need to choose which 
state you will be submitting the report to. 

Procedure 
1. From the Personnel administration menu choose Administration → Reporting → Reports → 

Administration US → Compliance → New hire reporting.  

2. Specify your selection criteria under Report-specific selections.  

 
The report only selects active employees (employees with employment status '3'). If 
necessary, you can make additional selections for the report under the Selection 
section. 

3. Choose the type of output you want (paper or magnetic media).  

If you choose to output the report on magnetic media, select which state you are 
reporting to and specify the path and name of the file. 

4. Choose Execute. 

Result 
A summary of the required data for the employer and each new employee is displayed. The 
report results can be printed and saved. If you chose to output the report on magnetic media, the 
file is saved to the path and file name you specified. 
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Running the NC-9901: Report of Organization 
Use 
Federal law requires US business to submit payroll data to the Bureau of the Census for the 
previous calendar year in the form of Form NC-9901: Report of Organization. This program 
generates the data for this report. 

 
You must obtain special software from the Bureau of the Census (Computerized 
Self-Administered Questionnaire - CSAQ) to complete the information on the file 
output by this program and submit the file to the Bureau. 

Prerequisites 
• You have maintained worksite data for your employees in Infotype 0209 (Unemployment 

State). 

• You have defined the activity codes for Form NC-9901 in the Payroll Administration 
Implementation Guide under step Define activity codes and defined additional data for your 
worksites in the US Payroll Implementation Guide under step Define unemployment 
worksites. 

Procedure 
1. Choose System → Services → Reporting and execute Program RPLNCU00. 

The NC-9901 Report: Generate Importable File screen appears. 

2. Define the selection period for the report. 

 
The system recognizes the current date and defaults the selection period to the 
previous year. 

3. Choose Org. structure and select the organizational units for which you want to run the 
report, or enter your selection criteria in the Selection section. 

4. Define the complete file path and file name for your output in the Local output file name field.   

5. Choose Execute. 

 
You can also execute the program in the background by choosing Program → 
Execute in background.  

Result 
You have generated a file with the data for the report. You can now import this file into the 
software from the Bureau of the Census, complete the necessary information and submit it. 
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The program outputs the annual and quarterly payroll amounts in thousands. For 
example, if the annual payroll amount for the company were $100,000, then 100 
would appear as the annual payroll amount in the output.  
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HIPAA Reporting 
Use 
This report generates a letter to any employee who has recently lost a medical benefit. You can 
configure a feature that allows you to generate similar letters when other benefits are lost. The 
report ensures compliance with the Health Insurance Portability and Accountability Act (HIPAA). 

Prerequisites 
SAPscript form HR_HIPAA_FORM_F and feature PLTIP should be configured as needed prior to 
running the report.  

Features 
This letter outlines the medical coverage data, including the beginning and end dates of the 
coverage and dependent information. The employee/former employee can then show this letter 
to his or her next employer in order to ensure continuous coverage under HIPAA guidelines. 

Activities 
The HIPAA reporting process begins whenever an employee or dependent loses a medical 
benefit. This is triggered by a personnel action such as a termination. Whenever an employee 
loses a medical benefit, start the HIPAA. This report checks table T5UB1 to see whether a 
benefit plan type MEDI exists for the employee. It then generates a letter to the employee.  
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Running the HIPAA Report 
Prerequisites 
Make sure that feature PLTYP checks table T5UB1 for plans with benefit type MEDI within 
country grouping 10. This will ensure that the report will comply with regulatory requirements by 
generating letters to all employees who have lost a medical benefit. 

Procedure 
Periodically run the HIPAA Report to generate letters to your employees who have lost a medical 
benefit. To access this report from the Personnel administration menu choose Administration → 
Reporting → Reports → Administration US  → Compliance → HIPAA Reporting. 

Result 
The system generates letters for all affected employees.  
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US Workers’ Compensation Summary Report 
Use 
The US Workers’ Compensation Summary Report provides you with a summary of the workers’ 
compensation information for a given organizational unit, as well as detailed workers’ 
compensation information per employee. This information serves as a basis for calculating 
workers’ compensation insurance premiums. 

Integration 
This report reads data defined for your employees and/or organizational units defined in the 
Workers' Compensation chapter of the Personnel Administration Implementation Guide under 
Organizational Data. You can also make workers' compensation code assignments and other 
settings using the WC State and Code PD infotype for organizational units and the WC State, 
Code, Attribute PD infotype for positions. 

Features 
The report generated contains the following information: 

• Workers’ compensation state 

• Organizational unit number and name 

• Workers’ compensation code 

• Total number of employees 

• Workers’ compensation wage 

• Detailed employee workers compensation information 

• Employee name 

• Personnel number 

• Organizational unit 

• Position 

• Workers’ compensation state, code, and wage  

Period-related parameters:  

You can specify any calendar period for which you want the workers’ compensation data 
to be selected for the report.  

Selection parameters: Organizational unit/Personnel number  

Report-specific selection: Include workers’ compensation wages in report 

Show detail list in background 

Activities 
To access this report from the Personnel management menu choose Administration → Info 
System → Reports → Administration US →Workers' compensation → US workers' compensation 
report. 
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For more information, see the application help for the report. It contains details on 
output options and required configuration.  
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Using Evaluation Schemas 
Use 
You can evaluate the payroll results using the respective country-specific schema x500. This 
schema is only used in a few country versions. 

The payroll results are evaluated in an additional run, which is carried out by the payroll driver. A 
sequential file (TemSe object) is generated with the payroll data. The file created in this way is 
stored under the respective file name, your user ID, and the date and time of the program run. 
The subsequent evaluations access this data. 

Prerequisites 
The payroll run must have been completed successfully for the personnel numbers you want to 
post. 

You are in the ABAP Editor: Initial Screen. 

Activities 
1. You start the payroll driver with the appropriate evaluation schema. 

2. Enter the appropriate values in the fields and set the required indicators. 

3. Choose Program → Execute or Execute + Print or In Background. 

If you have chosen Display log, after posting, a log will appear on screen which displays 
the evaluation data. 
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Evaluating the Payroll Results Using Infotypes or the 
Logical Database 
Use 
The following options are available in the SAP system for evaluating the payroll results. 

• The payroll infotypes [Page 725] and the InfoSet Query [Ext.] 

For detailed information on the InfoSet Query, see the SAP Library under Human 
Resources → Reporting in Human Resources Management → HR Reporting Tools → 
SAP Query (BC-ERV-Que) → InfoSet Query. 

• Logical Database [Ext.] 

• Standard reports 

You can evaluate the payroll results in direct access with the standard reports. 

 
Remuneration statement [Page 498] − 

Payroll journal [Page 506] − 

Payroll account [Ext.] − 

− Wage type reporter [Page 512] 

For detailed information on the standard reports, see the SAP Library under Payroll → 
Other Countries → Subsequent Activities. 

• Business Warehouse 

You can also evaluate the payroll results in the SAP Business Warehouse environment. 
For detailed information on this, see the Business Warehouse in the SAP Library. 
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InfoSet QueryInfoSet Query

Fill
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Warehouse
Business
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database
Logical

database

Payroll results

Direct access
Rem. statement
Payroll account
Payroll journal
Wage type reporter
:

Cluster
Rx

Transparent tables
HRPY_RGDIR
HRPY_WPBP

Ways of Evaluating the Payroll Results

 

Scope of Function 
Inform yourself of the evaluation options before you evaluate the payroll results. 

Comparison of the Evaluation Options using Payroll Infotypes or using the Logical 
Database PNP with the Enhancements for the Payroll Results 

General criteria for the 
evaluation 

Payroll infotypes for the 
evaluation with the InfoSet 
Query 

Enhancement of the logical 
database PNP for Payroll for 
direct evaluation with 
reports 

Evaluation path If you want to evaluate the 
payroll results using the 
InfoSet Query [Ext.], use the 
relevant payroll infotype (for 
example, Monthly Cumulation 
(0458)). You use the payroll 
infotype to provide the InfoSet 
Query with the payroll results 
for evaluation. 

If you want to use reports to 
evaluate the payroll results, 
you use the logical database 
for Payroll. The reports call the 
logical database to evaluate 
the payroll results. 

The InfoSet Query does not 
use the logical database for 
Payroll to evaluate the payroll 
results. 
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Storing the data The SAP system stores the 
data in the transparent tables 
for the payroll infotypes. 
Special wage types called 
evaluation wage types [Ext.] 
are available for this purpose. 

The payroll driver stores the 
data for the logical database 
redundantly, in transparent 
form, in the following tables: 

Calling the data The SAP system only calls the 
current payroll results. You 
can select the evaluation data 
with the help of wage types. 

The SAP system calls all the 
payroll results from the 
evaluation period for 
processing. 

Data Selection You get a quick selection of 
the payroll results with the 
help of the wage types that 
are provided in the payroll 
infotype. 

You get a high-performance 
selection of the payroll results 
with the help of selected fields 
from the Period group box and 
the organizational fields from 
the Selections group box (for 
example, personnel number, 
payroll area or company 
code). 

Example in report: 

EXAMPLE_PNP_GET_PAYR
OLL [Page 741] 

Programming You should not change the 
programming of the payroll 
infotypes and use (read) them 
in other programs. 

You can use the existing 
reports to evaluate or write 
evaluation reports using 
program examples [Page 741] 

Validity for the countries As well as payroll infotypes 
[Page 725], that are valid 
internationally (for example, 
payroll results: Periodical 
Values (0402), Monthly 
Cumulation (0458) there are 
payroll infotypes that are valid 
for one country. 

In the SAP system, there is 
one logical database for all 
countries. Country-specific 
features are provided by 
standardizing the node 
PAYROLL (for example, 
NODES: PAYROLL TYPE 
PAYUS_RESULT) 

• Directory information from 
the CU cluster is stored in 
the transparent table 
HRPY_RGDIR. The 
cluster remains in the 
system. 

• Data for the Work 
Center/Basic Pay (Table 
WPBP) from the RX 
cluster is stored in the 
transparent table 
HRPY_WPBP. The RX 
cluster remains in the 
system. 
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Prerequisites 
 

Description Payroll infotypes Enhancement of the PNP logical 
database for Payroll 

Customizing In Customizing for Personnel 
Management under Human Resources 
Information System → Payroll Results 
[Ext.] you have: 

In the attributes for the evaluation 
report, you have specified the 
following: 

 

• Logical database: PNP 
• defined the evaluation wage types • Selection screen version: 900 

selection screen for the payroll 
results 

• assigned the wage types 

• set up the payroll infotype 
• HR report class for Payroll (for 

example, the standard value 
PY_DEF) and the function Payroll 
report class selected. 

• assigned the payroll infotype to 
Payroll 
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Infotypes for Evaluating Payroll Results 
Use 
In addition to master data, applicant data, and personnel planning data, you can also evaluate 
payroll results using a query and InfoSet query.  

A number of predefined infotypes are available for the evaluation. The wage types required for 
the evaluation are entered in these infotypes: 

Infotype Meaning 

0402 Payroll Results: Period Values 

0403 Payroll Results: Period Values 
(not required at present) 

0458 Monthly Cumulation of Payroll Results 

0459 Quarterly Cumulation of Payroll Results 

0460 Annual Cumulation of Payroll Results 

You can either activate these predefined infotypes or create your own infotypes using the same 
structures. You can enhance these infotypes by using additional wage types and then activating 
the infotypes. This makes the necessary data, from the payroll results, available on the PNP 
logical database. 

 
If an error occurs when filling the payroll infotype, refer to the note Problems when 
Filling the Payroll Infotype (note number 0125921). 

Furthermore, we recommend that you create your own payroll infotypes in the 
customer name range 9* and do not modify the payroll infotypes Payroll Results: 
Period Values (0402 or 0403). 

USA: Infotypes for Tax Reporting 

The pre-defined infotypes 0446 and 0457 are also used for tax reporting. These infotypes have 
been created specifically for the USA. For more information, see US Tax Payroll Infotypes (0446 
-0457) [Page 748]. 

Prerequisites 
You have performed the following activities before you set up the evaluation of payroll results 
using a query or InfoSet Query: 

1. In Customizing for Personnel Management under Human Resources Information System → 
Payroll Results → Set Up Payroll Infotypes [Ext.], you have activated the payroll infotypes 
you require. You can create new payroll infotypes based on pre-defined payroll infotypes and 
then enhance these to meet your requirements. 

2. The infotype was filled out with the information from a payroll result. You have two options: 

– As long as Customizing has been set up accordingly, data is automatically transferred to 
the infotype in each payroll run. You do this in Customizing for Personnel Management 
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under Human Resources Information System → Payroll Results → Set Up Assignment 
for Payroll [Ext.]. 

– You can enter data in the infotype without a payroll run using report RPABRI00. 

Activities 
For information on evaluations using a query or InfoSet query, see BC - SAP Query [Ext.]. For 
information on evaluations in Human Resources, see Maintaining Queries in the HR Application 
[Ext.]. 

 

 

726  April 2001 



 SAP AG Payroll United States (PY-US) 

  Payroll Results Infotypes: Period Values (0402 and 0403) 

Payroll Results Infotypes: Period Values (0402 and 0403) 
Definition 
The Payroll Results: Period Values infotype (0402) contains information from the payroll results 
of the regular payroll run. Infotype 0403 is identical and is currently not required. 

The start and end dates for the infotype correspond to the payroll period. 

Structure 
You define the structure of the infotype in Customizing for Personnel Management under Payroll 
Results [Ext.]. 

You cannot maintain the infotype on-line. You can maintain the infotype using one of the 
following methods: 

• The data is automatically updated when the payroll run has been completed successfully, 
however, this must be set up accordingly in Customizing for Personnel Management under 
Human Resources Information System → Payroll Results → Set Up Assignment for Payroll 
[Ext.]. We recommend that you use this procedure as the data in the payroll infotype is 
automatically updated by the system (also in the case of retroactive accounting). 

• You can update the data at any time using report RPABRI00. We recommend that you use 
this procedure if existing payroll results should be evaluated. 

Using this infotype as a basis, you can evaluate the results of a regular payroll run using the 
query and the InfoSet Query. 
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Monthly Cumulations (Infotype 0458) 
Definition 
In the standard system, the Monthly Cumulation of Payroll Results infotype (0458) contains 
general information from the payroll results and cumulation wage types [Ext.] referring to one 
month. This can be useful if the periods for your payroll run are weekly and not monthly, or if 
payroll is run using a different frequency. 

The start and end dates for the infotype correspond to the cumulation period. If your employee, 
for example, leaves the company in the middle of a cumulation period, you can still access the 
cumulated values. 

Structure 
You define the structure of the infotype in Customizing for Personnel Management under Payroll 
Results. 

You cannot maintain the infotype on-line. You can maintain the infotype using one of the 
following methods: 

• The data is automatically updated when the payroll run has been completed successfully, 
however, this must be set up accordingly in Customizing for Personnel Management under 
Human Resources Information System → Payroll Results → Set Up Assignment for Payroll 
[Ext.]. 

• You can update the data at any time using report RPABRI00. 

Using this infotype as a basis, you can evaluate payroll results using the query and the InfoSet 
Query. 
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Quarterly Cumulations (Infotype 0459) 
 

Definition 
In the standard system, the Quarterly Cumulation of Payroll Results infotype (0459) contains 
general information from the payroll results, as well as cumulation wage types [Ext.] that refer to 
quarterly values. 

The start and end dates for the infotype correspond to the cumulation period. If your employee, 
for example, leaves the company in the middle of a cumulation period, you can still access the 
cumulated values. 

Structure 
You define the structure of the infotype in Customizing for Personnel Management under Payroll 
Results. 

You cannot maintain the infotype on-line. You can maintain the infotype using one of the 
following methods: 

• The data is automatically updated when the payroll run has been completed successfully, 
however, this must be set up accordingly in Customizing for Personnel Management under 
Human Resources Information System → Payroll Results → Set Up Assignment for Payroll 
[Ext.]. 

• You can update the data at any time using report RPABRI00. 

Using this infotype as a basis, you can evaluate payroll results using the query and the InfoSet 
Query. 
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Annual Cumulations (Infotype 0460) 
Definition 
In the standard system, the infotype Annual Cumulation of Payroll Results (0460) contains 
general information from the payroll results as well as cumulation wage types [Ext.] for annual 
values.  

The start and end dates for the infotype correspond to the cumulation period. If your employee, 
for example, leaves the company in the middle of a cumulation period, you can still access the 
cumulated values.  

Structure 
You define the structure of the infotype in Customizing for Personnel Management under Payroll 
Results.  

You cannot maintain the infotype on-line. You can maintain the infotype using one of the 
following methods: 

• The data is automatically updated when the payroll run has been completed successfully, 
however, this must be set up accordingly in Customizing for Personnel Management under 
Human Resources Information System → Payroll Results → Set Up Assignment for Payroll 
[Ext.].  

• You can update the data at any time using report RPABRI00. 

Using this infotype as a basis, you can evaluate payroll results using the query and the InfoSet 
Query. 
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Using the Logical Database for Payroll 
Use 
From Release 4.6A, the evaluation of payroll results is supported by a logical database that is 
integrated in the logical database PNP for HR master data [Ext.]. This tool enables you to create 
programs for the evaluation of payroll results both simply and quickly. 

Infotypes

Evaluation report 2Evaluation report 2 Evaluation report 3Evaluation report 3

HR master data

Org. Assignment (0001)
Basic Pay      (0008)

Payroll
PAYROLL

EVP

INTER

NAT

RT

CRT

SV

Evaluation report 1Evaluation report 1

Infotypes

Transparent table

HRPY_RGDIR

Transparent table
HRPY_WPBP

Transparent table

Cluster
RX

Cluster
CU

Logical Database PNP

Mode of Operation of the Logical Database PNP with the Enhancements for Evaluation of the
Payroll Results

 
Using the logical database for payroll results has the following advantages for the user: 

• You can access the payroll results faster and more easily. 

• 

• 

• It is a simple and standardized way of evaluating the payroll results. 

• Evaluation reports use this standardized interface and have a standard appearance. 

• The performance of the evaluation reports is improved by using transparent tables for data 
selection. 

• The number of coding lines in the evaluation programs (reports) is reduced by up to 60 
percent. 

An evaluation report can be created in less time. 

The logical database supports use of the HR process workbench [Page 102]. This improves 
integration in the whole payroll process. 
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• The selection screen can be customized. To do this, you use the new report categories 
[Page 746]  

• Different sort variants (all the fields for WPBP and RGDIR can currently be sorted) 

• It is not necessary to customize the payroll infotypes. 

 
Use the logical database for payroll for new reports that evaluate the payroll results. 

Scope of Function 
The most important functions are: 

Data Retrieval • 

The logical database [Ext.] consists of special ABAP programs that also provide the 
programs in Payroll with the evaluation data. All the data in a payroll record is provided in 
the subobjects for a complex structure [Page 736] at a selected time. To evaluate the 
payroll results, you can use reports from the standard system or create your own reports. 

• Data Selection 

The logical database provides a particular view of the database tables for Personnel 
Administration (PA-PA) or Payroll (PY) and enables you to select and evaluate payroll 
results according to particular criteria. 

 
Employees can now be selected on the selection screen of the evaluation report 
according to organizational criteria, for example, you can select all employees in a 
payroll area, however, the selection is made using exclusively the payroll results. 

• Authorization 

The system checks whether the user who started the evaluation has the correct 
authorization for this evaluation. The authorization concept corresponds to the concept of 
the previous PNP report. 
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Payroll results
CLUSTER RX, RD,...

InfoSet QueryInfoSet Query

Payroll
infotype

Fill automatically
or using

RPABRI00

Fill automatically
or using

RPABRI00 Business
Warehouse
Business

Warehouse

External
system

ExtractorExtractor

Report

Attribute PNP 900

HRPY_RGDIR
HRPY_WPBP

Transparent 
tables

No longer as of 

Release 5.0

Standard
report (EDT, ...)
„ALT“

Attribute PNP  ‘ ‘

Technical Realization of the Evaluation Options for Payroll Results

 
Comparison of the Logical Database for HR Master Data and the Logical Database for 
Payroll 

Technical Criteria or 
Enhancements 

Logical Database for HR 
Master Data (PNP) 

Logical Database for Payroll 
(PNP with Screen 900) 
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Time of data retrieval  There is only one date 
available for data retrieval: 

Several data retrieval events 
exist: 

Retrieval of payroll data for the 
evaluation programs 

Each internal table and field 
string (for example, RT, BT, 
SV, and so on) must be sorted 
and processed individually 

A complex structure 
containing all tables (WPBP, 
SV, BT, and so on) for each 
country 

Selection 

Evaluation report • Uses complex structures 
[Page 736]  

• At the time of GET 
PERNR, all infotype 
records are placed in an 
internal table for one 
personnel number 

• At the time of GET 
PERNR, all the infotype 
records are made 
available in an internal 
table (infotype table) for 
one personnel number 

• At the time of GET 
PAYROLL, the payroll 
results for a personnel 
number are made 
available in a complex 
structure  

• If all GET PAYROLL 
events have run for a 
personnel number, the 
event GET PERNR LATE 
is triggered 

• According to infotypes  • According to payroll 
results 

• Extends to the HR master 
data • Extends to the HR master 

data and payroll results 

• Uses import macros (for 
example, RP-IMP-C2-RX) 

• You can use all fields in 
the internal tables 
HRPY_RGDIR and 
HRPY_WPBP and sort 
them as required 

Sorting required • 

• Selection of required sort 
sequence using the Sort 
function in the report 
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Modifying the selection screen In Customizing for Personnel 
Management under Human 
Resources Information 
System → Reporting using: 

Report categories (selection 
criteria [Ext.]) 

 

In Customizing (when creating 
a report) using: 

Report categories 

The fields on the selection 
screen for the evaluation 
report are controlled using the 
new report categories. The 
main procedure for 
customizing the selection 
screen corresponds to the 
familiar procedure for 
customizing the PNP report 
categories. 
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Structure of Logical Database for Payroll 
The logical database for payroll transfers the payroll results to the evaluation reports in a 
complex structure. This structure contains an international and a national node that are 
subordinate to the root nodes: 

• International node 

The international node contains international (non-country-dependent) tables (for 
example, RT, CRT). The appropriate international tables are filled at runtime and 
retrieved using the complex structures. 

• National node 

The national node contains the national tables (for example, SV) The corresponding 
national tables are determined and filled at runtime using the type assignment.  

 

RT

CRT

...

SV

SCRT

...

INTER

NAT

PAYROLL

EVP Period information

Root nodes Nodes Tables
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Conversion of Evaluation Reports 
How Do You Convert an Existing Evaluation Report to the 
Logical Database for Payroll? 
In Release 4.6C, we recommend that you first convert any reports (standard reports and 
customer reports) that are not used by any other report. You should not convert reports that are 
called using function modules or other reports (for example, the remuneration statement or the 
payroll account) in this release. 

 
See the release note Using the Logical Database for Payroll for Release 4.6C. 

To convert a report to the logical database for payroll, proceed as follows: 

• Enter the following in the report attributes: 

• Logical database: PNP 

• Selection screen version: 900 selection screen for the payroll results 

• HR report category for payroll: PY_DEF of a customer report category 

Select Payroll report category. 

• Change the following in the coding: 

• The evaluation report is assigned to a country when the coding line NODES: 
PAYROLL TYPE PAY99_RESULT is inserted. 

• Switch the RP-IMP-C2-xx macro to the event GET PAYROLL. We recommend that 
you no longer use the macro RP-IMP-C2-xx. 

PNP Selections „900“PNP Selections „900“

Report SelectionsReport Selections

Get PernrGet Pernr

Report after conversionReport after conversion

GET PAYROLL

Do something 1

Do something 2
Get Pernr Late

Do something 3

PNP selectionsPNP selections

Report SelectionsReport Selections

Get PernrGet Pernr

Process modell FB...Process modell FB...

Loop RGDIR..
Read RGDIR

RP-IMP-XXX

Do something 1

Report before conversionReport before conversion

Do something 2
Do something 3

 

 
SAP provides the report EXAMPLE_PNP_GET_PAYROLL [Page 741] as an 
example. 
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To convert old evaluation reports, use the utility macros [Page 742], which are contained in the 
standard system, and one of the listed variants. 

• 

• 

If you only want to make minor changes to the coding of the report, we recommend that you 
use variant A for the conversion. With this variant, the conversion effort required is minimal.  

Example: Old coding [Page 743]  

• Example: Variant A – New coding [Page 744]  

• We recommend that you use variant B for the conversion if the report is not very large and 
you want it to be compatible for further developments. 

Switch macro RP-IMP-C2-xx to the event GET PAYROLL. 

Example: Old coding [Page 743]  • 

• Example: Variant B – New coding [Page 745]  

See also: 
Example 1: ABAP Coding: Read International Payroll Results [Page 739]  

Example 2: ABAP Coding: Read National Payroll Results [Page 74 ]0   

Example 3: Utility Macros for Report Conversion [Page 742]  

Example 4: Old Coding [Page 743]  

Example 5: Variant A – New Coding [Page 744]  

Example 6: Variant B – New Coding [Page 745]  

Example 7: Report EXAMPLE_PNP_GET_PAYROLL for Evaluation of Payroll Results [Page 
]  741
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ABAP Coding: Read International Payroll Results 
The system reads the international part of the payroll results for all clusters. The GET PAYROLL 
event is triggered for all personnel numbers and not just for the international country grouping 
(99). 

Segment from coding

NODES: 

DATA:  wa LIKE LINE OF .  . payroll-inter-rt.

GET PERNR.

...

  LOOP AT 
          INTO wa.
    WRITE:  wa-lgart.
  ENDLOOP.

 

payroll TYPE pay99_result.

GET PAYROLL.
payroll-inter-rt
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ABAP Coding: Read National Payroll Results 
The system reads country-specific payroll results (for example, for Germany). The GET 
PAYROLL event is only triggered for personnel numbers for the specified country. 

Segment from coding

REPORT EXAMPLE_ ...

NODES: 

...

GET PERNR.

...

  LOOP AT 
    WRITE:  wa1-lgart.
  ENDLOOP.
  LOOP AT 
    WRITE:  wa2-rvnum.
  ENDLOOP.

 

payroll TYPE payde_result.

GET PAYROLL.
payroll-inter-rt INTO wa1.

payroll-nat-sv INTO wa2.
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ABAP Coding: Report EXAMPLE_PNP_GET_PAYROLL 
for Evaluation of Payroll Results 
This report uses the logical database PNP to evaluate the payroll results. 

Example: Short version of report EXAMPLE_PNP_GET_PAYROLL 

REPORT EXAMPLE_PNP_GET_PAYROLL. 
* You find an extended version  

* of this report in your R/3 system ! 
TABLES: pernr, pyorgscreen, pytimescreen. 
NODES:  payroll TYPE pay99_result. 
Data: g_result_counter type i. 
GET pernr. 
WRITE: / 'Currently working on:', pernr-pernr. 
GET pernr LATE. 
WRITE: / 'Found', g_result_counter,  

         'results for #', pernr-pernr. 
ULINE. 
GET payroll. 
g_result_counter =  g_result_counter + 1. 
WRITE: / 'Seq No. = ',     payroll-evp-seqnr, 
         'In period =',  payroll-inter-versc-inper, 
         'In period =',  payroll-inter-versc-inper, 

         'Pay date =',   payroll-inter-versc-paydt. 
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Utility Macros for Report Conversion 

REPORT

NODES: payroll TYPE pay esult.

...

GET PERNR.

...

GET PAYROLL.

LOOP AT  INTO wa.
    WRITE:  wa-lgart.
ENDLOOP.
...

RT[] = &1-INTER-RT.
CRT[] = &1-INTER-CRT.
BT[] = &1-INTER-BT.
C0[] = &1-INTER-C0.
C1[] = &1-INTER-C1.
...

The SAP system
contains generated
macros for easy
conversion of old
reports. The coding for
this report is based on
the individual payroll
tables (for example,
RT, CRT).

Segment from Coding

 

INCLUDE h99paytransmac.

DE_r

Copytodata payroll.

rt

 
• For the O tables (for example, ORT), use copytodata_o. 

• To transfer the contents of the single tables (for example, RT) to the complex 
structure, use copytostruc(_o). 

• The macro copystruc_o works in the same way as copystruc but for O 
tables. 
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Example – Old Coding 

Segment from coding

INCLUDE: RPC2RX00.

INCLUDE: RPC2RXX0.

INCLUDE: RPPPXD00.

DATA: BEGIN OF COMMON PART BUFFER.

  INCLUDE RPPPXD10.

DATA: END OF COMMON PART BUFFER.

INCLUDE: RPPPXM00.

...

START-OF-SELECTION.

GET PERNR.

RP-IMP-C2-RX.
LOOP AT RT.
...
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Example: Variant A: New Coding  

Segment from coding

INCLUDE: RPC2RX00.

INCLUDE: RPC2RXX0.

...

START-OF-SELECTION.

GET PERNR.

LOOP AT RT.
...

 

NODES: payroll type pay99_result.

GET PAYROLL.

COPYTODATA PAYROLL.

Advantage 
Parts of the coding that refer to the single tables (for example, RT, CRT, and so on) need not be 
changed since the single tables are filled by the macro copytodate. 
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Example: Variant B: New Coding  

Segment from coding

...

START-OF-SELECTION.

...

GET PERNR.

...

 

NODES: PAYROLL TYPE PAY99_RESULT.

DATA: RT_HEADER TYPE LINE OF HRPAY99_RT.

GET PAYROLL.

LOOP AT PAYROLL-INTER-RT INTO RT_HEADER.

Advantage 
The use of the complex structure simplifies the layout of the report. This variant does not require 
the macros. Instead, it uses the new complex structure PAYROLL. You do not need to use an 
INCLUDE as in the Example – Variant A: New Coding [Page 744]. 

Disadvantage 
You must replace the link to the single tables (for example, RT, CRT) by a link to the complex 
structure. 
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Report Category 
Definition 
The report category specifies which fields are displayed on the selection screens of evaluation 
reports in Human Resources. 

Use 
Report Categories for HR Master Data 
The report categories for HR Master Data define which master data fields are displayed on the 
standard selection screens for standard evaluation reports. Report categories are already 
assigned to the standard reports. 

In Customizing for Personnel Management, you can create report categories [Ext.] and assign a 
report category to an evaluation report [Ext.]. 

 
Only change the report categories for the standard SAP reports, if the selection 
screen for the SAP standard system does not meet your requirements and you are 
aware of the effect this will have on the selection screen.  

Report Categories for Payroll 
The report categories for the evaluation of payroll results define which master data fields are 
displayed on the standard selection screens for evaluation reports. 

If you want to create a new evaluation report to evaluate the payroll results using the logical 
database for payroll, use either report category PY_DEF, or create your own report category and 
assign it to the new report. 

See also: 
Creating a Report and Report Category [Page 747]  
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Creating a Report and Report Category 
Use 
You want to create a new report to evaluate the payroll results. 

Prerequisites 
You are in the ABAP Editor in the Change Program Attributes <name report> screen. 

Procedure 
1. Enter the required values in the fields you are already familiar with. 

2. In the Logical database field, enter PNP and in the Selection screen version field, enter 900 
for the logical database for payroll.  

3. Choose HR report categories. 

The Report Category Assignment dialog box appears. 

4. Select Payroll results (Cluster) and enter the name of the new report category. 

5. Choose  Create report category. 

The View Change “Time Selection Definition” Overview: screen appears. 

6. To develop the report further, define the time and organizational selections. 

7. Save your entries. 

Result 
You can use the report to evaluate payroll results. 
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US Tax Payroll Infotypes (0446 - 0457) 
Definition 
The US tax payroll infotypes contain Federal, State, and Local tax data from generated payroll 
results. As the table below indicates, SAP delivers predefined US Tax infotypes for various tax 
authority/periodicity combinations. Alternatively, you can copy the DDIC structures of these 
infotypes and generate custom infotypes using your customer name range.   

 

Tax Level Payroll Period Monthly 
Cumulations 

Quarterly 
Cumulations 

Annual 
Cumulations 

Federal 0446 0447 0448 0449 

State 0450 0451 0452 0453 

Local 0454 0455 0456 0457 

 

Use 
You can select these infotypes to retrieve US tax data from payroll results, when generating 
reports with Query and Ad-hoc Query functionalities. For further information see Reporting of 
Payroll Results [Page 721]. 

 
Before you can use these infotypes to evaluate payroll results with Query or Ad-hoc 
Query, you must have first configured the infotypes with the desired wage types and 
have these wage types filled with data from the payroll results. For details, see the 
Prerequisites section of Reporting of Payroll Results [Page 721]. 
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US Garnishments Infotype for ABAP / Ad Hoc Query   
Definition 
A number of fields are available in Infotype 0195 (Garnishment Order) for reporting purposes. 
These fields are not visible to the user when displaying or maintaining HR master data, but they 
are available in the background for query. You can retrieve all information related to 
garnishments processing from this infotype using ABAP query and ad hoc query. This 
information includes data from the Garnishment Document (Infotype 0194) and Garnishment 
Order (Infotype 0195) fields, as well as from payroll results. The table below outlines the fields 
available for query according to data source:  

 

Fields Available for Query in Infotype 0195 

Garnishment Document 
(Infotype 0194) 

Garnishment Order 
(Infotype 0195) 

Payroll Results 
 

Employee Order type Amount  (collected in current period)2 

Case no. Rule Month-to-date3 

Start / End dates of doc. Initial balance1 Year- to-date4 

Case no. Deduction Total-to-date5 

Status Limit 1 value /unit Remaining balance6 

Released date Limit 2 value / unit  

Priority Additional amount Value / unit  

Origin   

Category   

Vendor   

Originator   

Plaintiff   

1.  Initial Balance - total amount to be garnished as of the date the document is issued. 

2.  Amount (collected in current period) - amount paid during the current payroll period of 
 specified key date. If the key date covers more than one payroll period, this field 
 contains the amount collected during the last period of the key date range. If 
 nothingwas collected during this period, the query will return $0.00. 

3.  Month-to-date - amount paid during the month of specified key date. If the key date covers 
 more than one month, this field contains the amount collected during the last month 
 of the key date range. If nothing was collected this month, the query will return $0.00. 

4.  Year-to-date - amount paid during the year of specified key date. If the key date covers 
 more than one month, this field contains the amount collected during the last year of 
 the key date range. If nothing was collected this year, the query will return $0.00. 

5.  Total-to-date - total amount paid as of key date. 

6.  Remaining Balance - the amount that remains to be paid. 
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For information on evaluations using a query or ad-hoc query, refer to the Basis 
Components (BC) section of the R/3 Library under BC - ABAPQuery. For information 
on evaluations in Human Resources, see Special Features when Maintaining 
Queries from the HR Application (under BC - ABAPQuery). 

 
When you create a functional area to query payroll results for garnishments use only 
Infotype 0195 (Garnishment Order). If you use Infotype 0194 (Garnishment 
Document) and Infotype 0195 within the same functional area query, the query 
results will contain duplicate entries for fields on Infotype 0194. 

 

 

Interface Toolbox for Human Resources (PX-XX-TL) 
Purpose 
In the SAP System, you can use the following methods to transfer data from the application 
components in Human Resources (HR) to a third-party system, or vice versa: 

Interface Toolbox • 

• Application Link Enabling (ALE [Ext.]) 

Business Application Programming Interface (BAPI [Ext.]) • 

A comparison of the technology [Page 752] shows which method is most suitable to perform the 
task. 

You use the Interface Toolbox to retrieve data from Human Resources for further processing in a 
third-party system. The third-party system can be a payroll system used outside of the SAP 
System. This can be useful if, for example, you run gross payroll in your enterprise and the net 
payroll takes place in a third-party system. 

Alternatively, you can use the Toolbox to import results based on personnel numbers from the 
third-party system and use them for payroll in the SAP System. 

You use the interface to 

• Evaluate data from Human Resources in a third-party system 

• Run payroll partially or completely in a third-party system 

The data is retrieved from the Personnel Administration (PA-PA), Payroll (PY), and Time 
Management components, or from all three. 
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Access 
You access the Toolbox using transaction PU12. 

In the Time Management component (PT), you call the Interface Toolbox from the menu. Choose 
Time Management → Administration → Environment → Third-party payroll.. 

In the Payroll component (PY), you also call the Interface Toolbox from the menu. In the SAP 
Menu, choose Human resources → Payroll → Tools → Maintenance tools → Interface Toolbox. 

Features 
Selected examples show which scenarios can be performed using the Toolbox: 

Exporting master data to a third-party system [Page 75 ]4  • 

Exporting master data and payroll results to a third-party system [Page 75 ]6  • 

• Gross payroll in an SAP System and net payroll in a third-party system [Page 758] 

The Toolbox enables you to create an interface as well as carry out routine work.  The following 
processes and associated functions are important for using the Interface Toolbox: 

For the data export • 

Setting up the interface for exporting with the Toolbox [Page 760] 

Data export with the Toolbox [Page 76 ]2  

For the data import • 

Importing wage types with the Toolbox [Page 925] 

 
For detailed information on the required activities, see the individual sections. 
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Technology for Interface Scenarios 
 

Task Method  

  

• 

Export HR master data  
(infotypes)  
from the SAP System to a 
third-party system 

Interface Toolbox 

• Example: Export master data to a third-party system 
[Page 754] 

 

ALE [Ext.] (Application Link Enabling) 

Data is exported in the SAP format only (no conversion) 

Import HR master data  

(infotypes)  
from the third-party system 
to the SAP System 

ALE / BAPI [Ext.]s (Business Application Programming 
Interface) 

• Batch input technology [Ext.] 

Export payroll results 
(infotypes)  
from the SAP System to a 
third-party system 

Interface Toolbox 

• Example: Export master data and payroll results to a 
third-party system [Page 756] 

Combination of Toolbox and ALE 

 

• Transport HR master data from all possible infotypes 
(also customer infotypes)  

Convert selected data to file format for third-party system 

• The standard system contains an ALE business process 
for some infotypes 

• You can insert additional infotypes (see note in OSS note 
system) 

• Select all possible tables in Payroll 

Additional options for processing wage types (for 
example, consideration of retroactive accounting) 

• 

• The Toolbox fills the IDocs 

• Distribute the complete IDocs using ALE 

• IDocs exist in the SAP interface for North America - they 
can be used by customers (in IDoc administration, these 
are the IDoc types that begin with 'HROT')  
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Import wage types  
from a third-party system to 
the SAP System 

Process 
(See also: Importing Wage Types with the Interface 
Toolbox [Page 925]) 

Export time evaluation results 
(infotypes)  
from the SAP System to a 
third-party system 

Interface Toolbox 
Selection of Time Management tables that are relevant 
for payroll (tables: ZL, C1, ALP) 

Import time evaluation results 
from the third-party system 
to the SAP System 

Human Resources and external applications [Ext.] 

Change validation (Transport 
changed data to third-party 
system) 

Interface Toolbox 
(See also: Change Validation [Page 79 ]8 ) 

ALE 

1. Transfer the wage types to interface tables with 

− Transfer by customer program 

− A BAPI (Object: BUS7023 Manager for External 
Payroll; Method: InsertOutsourcer) 

2. Start payroll to transfer the wage type to the payroll result 

• Change validation is possible for individual fields or for 
complete infotype records 

• Method: Import all data and compare it with old data 
(check performance). 

• Change validation only possible on infotype record level 
(export complete infotype record) 

• Method: Change display technology 
(system recognizes changes to the infotype and only 
exports these if a change takes place) 
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Example 1: Export Master Data to a Third-Party System 
Task 
You want to export HR master data from the SAP System to a third-party system to be used as a 
basis for 

• Evaluations 

• Payroll 

SAP Third-Party System

Payroll

Evaluation 
programs

Master 
data

Export with the
Interface Toolbox

 
This application example is simple to effect with the Interface Toolbox. 

 
Only master data is taken from the SAP System. No information is transferred 
from the third-party system to the SAP System. 

Prerequisites 
You use the Personnel Administration application component (PA-PA) in your enterprise. 

Method  
 

Step in the SAP System  In the Third-Party System 

With the Toolbox  The master data and payroll 
results from the SAP System 
are in the third-party system. 

1. Export HR master data  
(infotypes) from the SAP 
System to a third-party 
system 

• Set up the interface for the 
export 

• Run the data export 
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2. You start payroll or payroll 
reporting programs in the 
third-party system. 

 The payroll and reporting 
results are available in the 
third-party system. 
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Example 2: Export Master Data and Payroll Results to 
Third-Party System 
Task 
You want to use HR master data and payroll results (gross or net) from the SAP System to a 
third-party system as a basis for 

• Evaluations 

• Payroll 

You can also transfer time results to the third-party system instead of the payroll results. 

No information is transferred from the third-party system to the SAP System. 

Evaluation
programs

SAP Third-Party 
System

Master 
data

Payroll results
(gross/net)

Export with the
Interface Toolbox

SAP
Payroll

 

Prerequisites 
You use the following application components in your enterprise: 

• Personnel Administration (PA-PA) 

• Time Management (PT) 

• Payroll (PY) 

You have set up gross payroll in the SAP System. 

Method  
 

Step in the SAP System  In the Third-Party System 

The payroll results are 
available after a successful 
payroll run. 

 1. You run payroll (gross or 
net) in the SAP System. 
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2. You export the master 
data (infotypes) and the 
payroll results to the third-
party system. 

With the Toolbox  The master data and payroll 
results from the SAP System 
are in the third-party system. 

 The reporting results are 
available in the third-party 
system. 

• Set up the interface for the 
export 

• Run the data export 

3. Start the reporting 
programs in the third-party 
system. 
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Example 3: Gross Payroll in SAP System, Net Payroll in 
Third-Party System 
Task 
You want to use master data and payroll results (gross) from the SAP System as the basis for 
further payroll in a third-party system. You also want to transfer wage types (net) from the third-
party system to the SAP System. 

In the SAP System, you require information on the net wage types if you 

− Run posting to Accounting with the Human Resources component (HR) 

− Print remuneration statements or checks in the SAP System 

− Start programs for reporting in the SAP System 

− Collect all wage type information in the payroll result for the SAP System 

Wage type
table

SAP

Master 
data

Payroll 
results
(gross)

SAP Payroll
(Gross)

Transfer net
wage types to
payroll result

Third-
party

system

Export with the
Interface Toolbox

Import wage types
using Toolbox or

 ALE

Net
payroll

 

Prerequisites 
You use the following application components in your enterprise: 

• Personnel Administration (PA-PA) 

• Payroll (PY) 

You have set up gross payroll in the SAP System. 
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Method  
 

Step in the SAP System  In the Third-Party System 

The payroll results (gross) are 
available after a successful 
payroll run. 

 

With the Toolbox  The master data and payroll 
results from the SAP System 
are in the third-party system. 

 The payroll results (net) are 
available after a successful 
payroll run. 

With the Toolbox   

In the SAP System, the wage 
type information is integrated 
with the payroll results. 

 

1. You run payroll (gross) in 
the SAP System. 

2. You export the master 
data (infotypes) and the 
payroll results (gross) to 
the third-party system. 

• Set up the interface for the 
export 

• Run the data export 

3. Start payroll (net) in the 
third-party system. 

4. You import the payroll 
wage types (net) from the 
third-party system to the 
SAP System. 

• Import the wage types 
from the third-party 
system to the SAP 
System 

5. Start payroll in the SAP 
System to transfer the 
payroll wage types (net) to 
the payroll results. 
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Setting Up the Interface for Export with the Toolbox 
Purpose 
You use this process to 

• Set up the interface for exporting with the Toolbox 

• Export the selected data to the third-party system using the Interface Toolbox. 

Prerequisites 
You use the following application components in your enterprise: 

• Personnel Administration (PA-PA) 

• Time Management (PT) 

• Payroll (PY) 

Process flow 
The process is split into several steps: 

2. You use the Toolbox to create an interface format [Page 76 ]3 . In this step, you select the 
data and convert [Page 78 ]1  the data to be exported. 

The interface format includes the following functions: 

• Create objects 

• Delete objects 

• Data definition for cluster objects 

• Table entries 

• Convert field objects 

• Restrictions for field objects 

• Attributes 

3. You determine which data is only to be exported if it has changed.  

 
You need only perform this step if only changed data is to be exported.  

You use the change validation functions [Page 798] to determine the data for the export. 
These functions include: 

• Create objects 

• Delimit objects 

• Validating single fields  

• Key fields 

• Relations 
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• Wage types 

3. You use the data entered in the interface format and in change validation to generate the 
export program [Page 857]. 

You use the functions in the file layout [Page 871] to set up the required file format for 
the data to be exported.  These functions include: 

• Create 

• Delete 

• Move 

• Insert 

• Attributes 

• Blocks 

• Structures 

Fields • 

4. You use the specifications for the file layout to generate the conversion program [Page 898]. 

Result 
You have set up an interface for the export. You can start the generated export program to run 
the data export and convert the data to the required file format. 
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Data Export with the Toolbox 

Prerequisites 

• Time Management (PT) 

• 

Purpose 
You use this process to retrieve data from the Human Resources application components (HR) 
for Payroll or for the payroll reporting programs for use in a third-party system. 

You use the following application components in your enterprise: 

• Personnel Administration (PA-PA) 

Payroll (PY) 

You have used the Interface Toolbox to set up an interface for the export (see application 
example 1 [Page 75 ]4 ) or you are using an interface from the standard system. 

Process flow 
The process is split into several steps: 

With the Toolbox, start the export program [Page 859]. 1. 

2. You use the Toolbox to download the export files from the TemSe file to your PC or to an 
application server (Downloading the Export Files [Page 870]). 

3. If the system administrator for this system is in agreement, you can transfer the data to 
the third-party system. 

 

Result 
The third-party system contains data from the SAP System. You can use this data for Payroll or 
for the payroll evaluation programs. 
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Interface Format 
Definition 

The interface format is the basis for data export with the Interface Toolbox. You use the interface 
format to determine which HR data you want to select, and also how this selection should take 
place. When you define an interface format, you can access all employee data for the following 
application components: 

• Payroll (PY) 

The interface format contains the objects that you want to export from the Human Resources 
application component (HR) to a third-party system. 

Use 

• Personnel Administration (PA-PA) 

• Time Management (PT) 

Using your defined interface format as a basis, the Interface Toolbox will ultimately generate a 
program using the Advanced Business Application Programming language (ABAP [Ext.] ). You 
use this program to export the data. The system processes the data quickly and effectively during 
the export. 

SAP Third-Party
System

Generate
export program

Interface
format

Payroll

Evaluation
programs

Export 
selected data

 

Structure 
The interface format is a hierarchical sequence of objects. 

Objects and their hierarchy 

Example Object Hierarchy classification
Database objects [Page 76 ]7  1 MDTA for HR master data PCL2 for 

payroll  
Cluster objects [Page 768] 2 RX, RD, ... for payroll results B2 for 

time evaluation results 
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Table objects [Page 769] 3 WPBP for work center/basic pay, 
P0002 for personal data 

Field objects [Page 771] 4 PERSK for employee group ANZHL 
for number 

 

Task 
To save the personnel number data, the interface format uses the objects in the Human 
Resources component (HR). You use the interface format to select a data subset that meets your 
requirements. 

 
You can choose to select only the infotypes that you require for processing in a third-
party system. 

You can also select particular fields from the fields in an infotype. 

The interface format and objects exactly match the definition of the data to be exported later with 
the export program. For performance reasons, the set of export data should be arranged in the 
best possible way. 

Characteristic 
Each object in the Interface Toolbox has specific characteristics. The characteristics determine 
how the object is processed and are assigned as follows: 

• Entered explicitly by the user 

 
You assign the Conversion characteristic to a field object. 

• Implicitly by the Interface Toolbox 

 
The Interface Toolbox automatically assigns the Length characteristic to the field 
object. 

• By the SAP System 

 
The SAP System assigns the Permissibility per infotype characteristic to the field 
object. 
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Create Objects 
Use 
The Create function is permitted for all objects. 

Database objects [Page 767] • 

Cluster objects [Page 768] • 

Table objects [Page 769] • 

• Field objects [Page 771] 

You use the function to create an object in the tree structure and the accompanying 
characteristics. 

First name = Mary

PCL2 Wage type 
MA10 
Standard salary

MDTA
Last name = Model

RD

. . 
.

RX

Database
object

Cluster
object

Field objectTable object

WPBP
MA10

MA20

. . .

. . .

. . .

. . .

P0002

Last name

First name

. . .

. . .

. .
 .

Database
object

Field objectTable object
Personal Data infotype (0002)

 
Different dialogs are used depending on the object, and you must enter information for the object 
to be created. 

To use the Create function efficiently and to create the data consistently, you must always create 
the parts of the objects that are subordinate in the hierarchy. 

 
You want to create a database object with the type Master Data (MDTA). To do this, 
select the required infotypes. 

You also want to create a database object with the type Export-Import File (PCL2). 
To do this, you must select the required cluster object (for example, RX) and then 
select the required objects from the table objects belonging to the cluster (for 
example, WPBP). 

The field object is an exception. If you create a table object, the system will automatically transfer 
all assigned field objects to the interface format. 
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Activities 
You create an interface format [Page 77 ]2 . 
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Database Object 
Definition 
Subset of tables from a database. 

You can use the Interface Toolbox to select the following database objects: 

• Set of all infotypes (MDTA) with the type Master Data 

• Payroll and Time Management data (PCL2) with the type Import/Export file 

Use 
You use the database object to create an interface format. When you create an interface format, 
note the following: 

• Database objects with the type Master Data (MDTA) are followed by table objects. Infotypes 
belong to the table objects. 

If you create a database object with this type, you can assign required infotypes for the 
subsequent export. 

The table object (infotype) automatically includes all field objects belonging to the 
relevant infotype. 

• If database objects have the type Import/Export File (PCL2), then the subordinate hierarchy 
level consists of cluster objects. 

When you create a database object with this characteristic, you must enter the name of 
the database table on which the interface format is based (for example, PCL2). The 
Interface Toolbox will then check whether the specified database table exists in the SAP 
System. 

You must also maintain the following objects which are lower in the hierarchy: 

– Cluster object 

– Table object 

The table object automatically includes all field objects belonging to the table. 

 
You can also create an additional database object at a later point. 

You then run 

• The dialog for a table object for master data 

• The dialog for a cluster object for an import/export file 
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Cluster Object 
Definition 
Each database object, for example, PCL1 or PCL2, with the type Import/Export file consists of 
related areas. These areas are known as clusters, for example. RX, RD. Cluster objects are 
dependent on the superordinate database object. 

 
You can select the following cluster objects for database object PCL2: 

– Cluster RD 

– Cluster RX 

– Cluster B2 

If the database object has the type Master Data, then there is no cluster object. 

Use 
If you assign a database object with the type Import/Export file to the interface format, you must 
select the cluster in which the payroll or time evaluation data is found. 

When the interface format is processing cluster data, it uses the existing import macros [Ext.]  in 
the SAP System. If you have changed the table objects for the data import in the import macro 
(for example, if you have deleted or inserted a table object), these changes are automatically 
transferred to the Interface Toolbox. 

The Toolbox checks that the import macro is actually reading the data from the superordinate 
database object and the specified cluster. 

The system checks that the data definition include [Page 79 ]5   and the import macro are 
syntactically correct. 

If you create a new cluster object or change the characteristics of an existing cluster object, you 
must enter the following information in the system: 

• Name of the cluster (for example, B2) 

• Name of the data definition include (for example, RPC2RDD0) 

The data definition include contains the definition of the data defined by the import 
macro. 

• Import macro (for example, RP-IMP-C2-RD) 

The import macro determines the set of all possible subsequent table objects. 

You then run the dialog for the table objects. 
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Table Object 
Definition 
Table from Human Resources (HR). 

The only available characteristics for the table object are those automatically assigned by the 
SAP System. 

The system differentiates between the following types: 

• Section of a cluster object 

The table object, for example, WPBP, is a section of a cluster object, for example, RX, 
which belongs in turn to the database object, for example, PCL2. 

• Infotype 

The table object, for example, P0002, is an infotype whose superordinate database 
object (MDTA) is the set of all infotypes. 

Characteristic 

 
Characteristics that you have assigned using the Table Entries function are an 
exception. For more information, see Table Entries [Page 77 ]9 . 

The system derives the characteristics from the data definition include (for example, RPC2RDD0) 
for the superordinate cluster object (for example, RD). 

 
For more information, see the section on data definition of cluster data with the data 
definition include [Page 795]. 

For table objects with the Set of All Infotypes as the superordinate database object (MDTA), the 
system derives the characteristics from the ABAP Dictionary (DDIC) [Ext.]. 

Use 
If you assign a database object with the type Import/Export file to the interface format, you must 
select the cluster containing the payroll or time evaluation data. 

When you create a table object, the system displays a list of all internal tables and field strings. 
There following types of lists are available: 

• List of all internal tables or field strings, if the table object belongs to a cluster object. 

• List of all infotypes, if the table object belongs to a database object with the type Master 
Data. 

From this list, you can select the table objects for data export. The Interface Toolbox 
automatically inserts all accompanying field objects for the selected table object. 
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Field Object 
Definition 
The field object, for example, BUKRS for company code, is a field in the superordinate table 
object, for example, the Organizational Assignment infotype (P0001). The system first assigns 
characteristics to the field object based on the ABAP Dictionary [Ext.]. You can change these 
later by converting the field object. 

Characteristic 
• Type (for example, CHAR) 

• Length (for example, 4) 

• Content (for example, 0001) 

Use 
Each table object contains a particular number of field objects. A list of all fields belonging to the 
corresponding table object is displayed. The Interface Toolbox creates the list using the structure 
assigned to the table object from the ABAP Dictionary. From this list you can select all the field 
objects whose data you want to export. 
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Creating an Interface Format 
Use 
You want to create an interface format with the name Z000. The interface format Z000 should 
contain database objects: 

• Personal data (P0002): 

• Basic pay (P0008) 

You want to use all field objects from both database objects. 

Procedure 
1. Choose the Configuration tab index. 

2. In the Object to be processed group box, choose Interface Format. 

3. In the Interface format field, enter the name of your new interface format Z000. 

4. Choose Create. 

You access the Create Interface Format dialog box. 

5. In the Country grouping field, enter the country indicator and, in the Description of new 
interface format field, enter a text. 

You access the Create database object dialog box. 

6. To create a database object with the type Master Data, choose the Master Data. 

 
To create an interface format with the type Import/Export file, you should be familiar 
with the import macro for cluster data [Ext.] and cluster data definition using a data 
definition include [Page 79 ]5 . 

You access the Create master data dialog box. 

7. Select the Personal Data (P0002) and Basic Pay (P0008) infotypes. 

The Export program dialog box is displayed. 

8. Enter data as required. 

 
If you choose Suggest values, the system proposes names for the export program 
and includes. 

9. Choose Continue. 

10. Choose Edit → Expand. 

The system displays all levels of the object tree with the individual field objects for the 
infotypes. 

11. Save your entries. 

You access the Create object catalog entry dialog box. 
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12. Enter the development class and choose Save. 

Result 
You have created an interface format with the name Z000. 

 
You can use the individual interface format functions to edit the generated interface 
format. For example, you can insert a field object in an interface format [Page 774]. 
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Inserting a Field Object 
Use 
You can use the Create function to insert field objects in a table object and consequently, alter 
the sequence of the field objects within a table object. The system inserts the selected field 
objects after the current cursor position. 

Prerequisites 
You have created an interface format. 

Procedure 
1. Choose the Configuration tab index. 

2. In the Object to be processed group box, choose Interface Format. 

3. In the Interface format field, enter the name of your interface format. 

4. Choose Change. 

The system displays the tree structure. 

5. Choose Edit → Expand. 

The system displays all table objects with the accompanying field objects. 

6. In the selected table object, position your cursor on the field object after which you want to 
insert one or more field objects. 

7. Choose Create. 

You access the Add Fields from <name> dialog box. 

8. Select the field object(s) you want to add to the table object. 

The system inserts the selected field objects after the current cursor position. 

 
If you select a field object from the list that is already assigned to the relevant table 
object, then this field object will be ignored and not transferred. 

9. Save your entries. 

Result 

You have added one or more field objects to the table object. 
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Delete Objects 
Use 
The Delete function is permitted for all objects. 

Database objects [Page 76 ]7  • 

Cluster objects [Page 768] • 

Table objects [Page 769] • 

• Field objects [Page 771] 

You use the function to remove an object from the tree structure. 

If you delete an object from the tree structure, you also remove all objects below it in the 
hierarchy. 

 
You also want to create a database object with the type Export-Import File (PCL2). 

The accompanying cluster objects, table objects, and field objects are also deleted. 

Integration 
If you delete objects from the tree structure of the Interface Toolbox , the change validation [Page 

] objects derived from these objects will also be deleted. 798

This means that the relationship between the object in the interface format and in change 
validation is always consistent. 

 
For example, if you delete the field object (LGART) from the table object (RT), this 
field object will also be deleted from the change validation tree structure. 

Activities 
Delete an object [Page 776]. 
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Deleting Objects 
Prerequisites 
You have created an interface format. 

You are in the tree structure [Page 774] and all table objects are displayed with all field objects. 

Procedure 
1. Select the objects to be deleted using Select. 

 
When you select an object, the Interface Toolbox includes all dependent objects in 
the object hierarchy. This means that all objects subordinate to the object to be 
deleted will also be selected. 

2. Choose Delete. 

The system deletes all selected objects including those subordinate to the object to be 
deleted. 

3. Save your entries. 

Result 

You have deleted objects from the tree structure. 
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Data Definition for Cluster Objects 
Use 
The Data Definition function is only valid for cluster objects [Page 768]. 

This function allows you to change the name of a data definition include [Page 795] for a cluster 
object. 

If you create a new database object or cluster object for the interface format, the Interface 
Toolbox requires the following information: 

• Name of the cluster 

• Name of the data definition include 

• Name of import macro 

 
If you change the name of the data definition include you should ensure that the new 
data definition include contains at least all the data definitions from the old include. 

Activities 
Either change the name of a data definition include [Page 77 ]8  or display the include. 
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Changing or Displaying the Data Definition for a Cluster 
Object 
Prerequisites 
You have created an interface format. 

You are in the tree structure [Page 77 ]4  and all table objects are displayed with all field objects. 

Procedure 
1. Position the cursor on the required cluster object. 

2. Choose Data definition. 

You access the Data Definition for DB <name>, Cluster <name> dialog box. 

3. You can now change the name of the data definition include or display the include. 

The dialog box also gives you an overview of the assignment of internal table names or field 
string names to the corresponding structures in the data dictionary. 

4. If you have changed the name of the data definition include, choose Save. 

Result 
You have changed the name of your data definition include and you have displayed an overview 
of the assignments to cluster objects. 

 

 

 

778  April 2001 



 SAP AG Payroll United States (PY-US) 

  Table Entries 

Table Entries 
Use 
The Table entries function only applies to table objects [Page 769]. 

 
WPBP (Work center/Basic pay) 

Basic pay infotype (P0008) 

This function allows you to use the Interface Toolbox to select records for data export from the 
input data stream. You can specify whether you want to export all table entries or just a selection 
of entries. 

Activities 
Select table entries [Page 780] for a table object. 
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Selecting Table Entries 
Prerequisites 
You have created an interface format. 

You are in the tree structure [Page 774] and all table objects are displayed with all field objects. 

Procedure 
1. Place the cursor on the selected table object. 

2. Choose Table entries. 

You access the Table entries for <name> dialog box. 

3. Choose an entry for 

a. For an infotype, choose 

– All records valid at the start date of the current period 

– All records valid at the end date of the current period 

– All records valid on at least one day in the current period 

– All existing records, including those outside of the current period  

b. A cluster 

– First entry 

– Last entry 

– All entries in the current period 

– All entries 

4. Save your entries. 

Result 
The result of this selection is only apparent after the data export, for example, in the export 
program log, or directly in the output file. 
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Conversion for Field Objects 
Use 
The Conversion function only applies to field objects [Page 771]. 

The Interface Toolbox allows you to modify the export file to meet the requirements of the third-
party system, as well as allowing you to transfer the data in the SAP System to the third-party 
system. The conversion then modifies the data. 

During the conversion, the system replaces the old content (value) of the object with the new 
content (value). 

 
• The Gender Key field object (P0002-GESCH) has the content (value) 2, which should be 

replaced by the content (value) 1 during the export. 

• The Form of Address Key field object (P0002-ANRED) has the content (value) 1, which 
should be replaced by a text (for example, Dear Sir). 

• The names of the wage types in the SAP System (for example, /101) can be replaced by the 
names of the wage types used in the third-party system (for example, GROSS). 

Features 
The system differentiates between three conversion types for field objects: 

Direct value [Page 782] • 

Table value [Page 785] • 

• User exit [Page 788] 

 
The Toolbox also includes additional conversion options in the file layout [Page 871] 
. You can use these options in addition to or instead of the conversion options in the 
interface format. 

 Activities
Select the conversion for a field object [Page 790]. 
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Constant Conversion Type 
Use 
The Constant conversion type causes the Interface Toolbox to replace the old value of a field 
object by a new value during the data export. You can enter the necessary default values for the 
conversion of the field objects in the <name> (old) and <name>(new) fields of the Direct Value 
for <name> dialog box.  

 
You want to replace the old value of the ANSSA field object, which is contained in 
the Addresses infotype (P0006), with a new value. 

Enter the following in the Constant for “Address Record Type” dialog box. 

Field: ANSSA (old) Field: ANSSA (new)

1 Main address 

2 Temporary address 

* Holiday address 

Features 
Replace Constant Generically 
Use the * (asterisk) character to replace values generically. In your selected field object, enter a 
* (asterisk) in the... (old) field as the first and only character. Enter the new constant in the ... 
(new) field. 

If, when processing the data records, the Toolbox finds the character * (asterisk) for generic 
replacement, the system replaces all values without a suitable entry in the ...(old) field with the 
value from the ...(new) field for the generic lines. 

See also: 
Example: Replacing a Constant Generically [Page 784]  

Length of the Field Object for the Constant Conversion Type 
You can use the Length function to redefine the field length of a field object. Normally the 
Toolbox uses the length in the ABAP dictionary as the length of the field object. The new field 
length can be either longer than, equal to, or shorter than the length in the ABAP dictionary. 

Reference for the Constant Conversion Type 
You can use the Reference function to refer to an existing, suitable conversion. You can define a 
reference to an existing conversion program without creating a new conversion program. If you 
modify the fields in the Constant Value for <name> dialog box then the Toolbox will also integrate 
these changes in the referenced fields. 

If suitable references for the field object to be converted already exist in the SAP System, then 
they will be shown in the Reference Conversion Type dialog box and they can be used again 
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Your payroll result contains the table objects A and B. The LGART field object is 
contained in table A and table B. 

You define the constant conversion type for the LGART field object from table object 
A. 

You only define one reference from the LGART field object in table object B to the 
LGART field object in table A. 

If you modify the Constant conversion type in one of the two fields (A-LGART, B-
LGART), then the Toolbox will automatically integrate these changes in the 
referenced fields. 

Transfer of Entries for Conversion 
Once you have made all the entries for the conversion of a field object, choose Transfer. 
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Example: Replacing a Constant Generically 
Purpose 
You want to replace the selected values of the KOSTL field object (cost center) with new values 
during the data export. 

Process flow 
Perform the conversion of direct values in two steps: 

1. Enter the following values in the KOSTL (old) and KOSTL (new) fields in the Constant for 
Cost Center dialog box. 

Field: KOSTL (old) Field: KOSTL (new)

1111 Z1111 

2222 Z222 

* ZZZZ 

2. When the Interface Toolbox exports data, selected values for the Cost Center  (KOSTL) field 
are contained in the input data stream records. The system replaces these selected input 
values for the Old cost center (KOSTL (old)) field by the values you have entered in the New 
cost center (KOSTL (new)) field. 

Values for the KOSTL field in the input 
data stream for the export 

Content of the KOSTL field after the data 
export 

1111 Z1111 

2222 Z2222 

3333 ZZZZZ 
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Table Value Conversion Type 
Use 
The Table Value conversion type operates in a similar way to the Constant conversion type 
where the Interface Toolbox replaces the old value of the field object with a new value during the 
export process. However it differs from the constant conversion type because the new value 
contained in a field, for example, TITEL for title, comes from a database table [Page 786], for 
example, T535N for name supplements. The new value is a value stored in the SAP System and 
is not determined by a constant. 

 
To use the table value conversion type, you need to know the table names of the 
required database tables (for example, table T535N for name supplements) and 
fields (for example, the TITEL field for title). 

Key Fields for the Table Value Conversion Type 

The content of the key fields defines the access path for the selected field, whose content is to be 
used as the replacement. 

If you enter the name of the database table and field name and choose Enter, then the Toolbox 
automatically enters the default values from the SAP System in the key fields for this table. 

The access path for the key fields is a default value in the SAP System. Check and, if necessary, 
correct this access path so that the correct field object can be used for the table value 
conversion. 

In addition, the SAP System allows you to use system fields that are available in the System 
Fields in ABAP Programs (SYST) table. These are the fields that begin with SY-, for example, 
SY-LANGU for the language key in the SAP logon procedure, and SY-DATUM for the current 
date in the system: You can use these system fields to define the access path to a field object. 
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Database Table 
Database tables used when converting table values are all tables in the SAP System that exist in 
the ABAP Dictionary (DDIC). This does not just include the database objects used by the 
Interface Toolbox for the interface format. 
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Example: Replacing a Table Value 
You can use the table value conversion type is to replace values that represent a code with 
values that represent a text and which already exist in a field in the database table. 

 
You want to replace the value in the Form of Address (ANRED) field object in the 
Personal Data (P0002) infotype with the value from the Form of Address text 
(ATEXT) in the Forms of Address (T522T) database table. 

You are in Conversion → Table value for the Form of Address (ANRED) field object 
from the Personal Data (P0002) table object. 

Enter T522T in the Table field and ATEXT in the Field Name field in the Table Values 
for “Form of Address Key” dialog box. When you choose Enter, the key fields P0002-
SPRSL and P002-ANRED are displayed, provided you have selected both fields for 
the export. 

You end the example with the Transfer function. 
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User Exit Conversion Type 
Use 
If the functions offered by the Constant and Table Value conversion types do not meet your 
requirements, the Interface Toolbox allows you to use your own, user-defined conversion 
program. The User Exit conversion type creates the link to the customer conversion program. 

Prerequisites 
The following conditions must be met before you can define the field object conversion for the 
User Exit conversion type in the interface format: 

• You have generated a user-defined program for the conversion of a field object. 

The name of the user-defined program matches the program name in the Program field. 

• The routine specified in the Form Routine field is specified in your user-defined program. 

The SAP System checks that the specified form routine exists in your user program. 

• The Interface Toolbox provides you with a default value for the length of the field object to be 
converted. You can modify this length to suit your requirements at any time. 

The User Exit conversion is carried out for each table line in the selected table object (for 
example, WPBP) in the input data stream. Define the form routine in your user-defined program 
with two parameters: 

Parameters Meaning 

Parameter 1 Current line of the table object in which the field object is contained (input 
parameter) 

Parameter 2 Result of conversion (return value) 

The return value is interpreted as a character field type. 

See also: 
Example: User Exit with Form Routine [Page 789] 
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Example: User Exit with Form Routine 
Basic Situation 
You use a customer User Exit with the program name ZUSEREXl and the form routine with the 
name KONVERT. 

You wish to convert the value in the Title (TITEL) field object in the Personal Data infotype 
(P0002) to the text from the Title (TTOUT) field in the Name Supplements (T535N) table. The title 
ING (for engineer) should not be used. 

Procedure 
The customer program for the user exit (including the form routine) could be as follows: 

 
     FORM KONVERT TITEL USING    VALUE(P0002) STRUCTURE P0002 

                        CHANGING VALUE(RESULT). 

          IF P0002-TITEL <> `ING.`. 

             SELECT SINGLE * FROM T535N 

                                  WHERE ART = `T` 

                                  AND TITEL = P0002-TITEL. 

         IF SY-SUBRC = 0. 

                RESULT = T535N-TTOUT. 

   ELSE. 

                CLEAR RESULT. 

   ENDIF. 

ENDFORM. 
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Selecting the Conversion for A Field Object 
Prerequisites 
You have created an interface format. 

You are in the tree structure [Page 774] and all table objects are displayed with all field objects. 

Procedure 
5. Place the cursor on the selected table object. 

6. Choose Table entries. 

You access the Table entries for <name> dialog box. 

7. Place the cursor on the selected field object and choose Conversion. 

The Conversion type dialog box appears. 

8. Choose one of the following conversion types: 

– Constant 

You access the Direct Value for <name> dialog box. 

a) Enter data as required. 

b) Choose Transfer. 

– Table value 

You access the Table Value for <name> dialog box. 

a) Enter data as required. 

b) Choose Transfer. 

– User Exit 

You access the User Exit for <name> dialog box. 

a) Enter the required data. 

Field Content 

Program name of the user-defined 
user exit 

Form routine Name of form routine 

Conversion length Length of converted field object 

Program 

b) Choose Continue. 

9. Save your entries. 

Result 
You have assigned a conversion type to the selected field object. 
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Restrictions for Field Objects 
Use 
The Restrictions function only applies to field objects [Page 771]. 

 
The Address record type field (ANSSA) in the Addresses infotype (P0006). 

The Pay scale type field (TAFAR) from table WPBP (Work center/Basic pay). 

You can use this function to select records from the input data stream to be exported by the 
Interface Toolbox. The selection criterion is the field object with the predetermined restrictions. 
You can use your default values to define the restrictions referring to the content of the selected 
field object. Only the data records whose field object matches that in the Restrictions function will 
be exported from the input data stream. 

 
You only want to select the main address from the ANSSA (address type) field in the 
Addresses infotype (P0006). You do not need the other address types. 

To do this, enter 1 for address in the Restrictions for “P0006-ANSSA” dialog box and 
copy the entry. 

The Interface Toolbox only exports the input records for the data stream that have 1 
(main address) in the ANSSA field. Data records with other addresses are not 
exported. 

Restriction types for field objects 

• Special restrictions for wage types 

This type of restriction is only valid for wage types from wage type tables. 

 
For more information on wage types, see Wage Type Processing in the Interface 
Toolbox [Page 828]. 

 

• General restrictions 

This type of restriction is valid for field objects with the type CHAR and NUM. 

Activities
Select the restrictions for a field object [Page 793]. 
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Creating Restrictions for a Field Object 
Prerequisites 
You have created an interface format. 

You are in the tree structure [Page 77 ]4  and all table objects are displayed with all field objects. 

Procedure 
1. Place the cursor on the selected field object. 

2. Choose Restrictions. 

You access the Restrictions for <name> dialog box. 

3. If you have already defined restrictions for the field object and want to insert more 
restrictions, choose New line. 

4. Enter the restrictions. 

 
Several entries for a field object are linked implicitly with the logical operation OR. 

5. Choose Transfer.  

6. Save your entries. 

Result 
You have created a restriction for the selected field object. 
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Attributes in the Interface Format 
Use 
You use the Attributes function to define the processing parameters for the interface format. 
These are used by system when the data is exported. They determine how the interface format 
will be used in the SAP System. 

Features 
The attributes can be changed during or after the processing of the interface format. 

• 

For the process control: 

• Interface without payroll 

• Check control record 

• No retroactive accounting 

• Valuate wage types indirectly 

Layout conversion directly after export 

• New change validation [Page 802] 

For storing the interface results: 

• Do not save to cluster IF 

• Save current results only 

Activities 
You use the Attributes function to assign the attributes at any time during the editing of the 
interface format. 

 
You must assign the attributes to the interface format before you generate the export 
program.  

If you assign the attributes to the interface format later, you must regenerate the 
export program. 
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Data Definition Include 
Definition 
The data definition include contains the definitions of the internal tables and field strings used in 
the import macro [Ext.]. Like the import macro, it is a further characteristic of the cluster object 
[Page 768]. There is just one include for each cluster object, and it contains the definition of the 
data. 

Use 
The Interface Toolbox must recognize the structure of the cluster to be able to read cluster 
objects in the SAP System. The data definition include contains this structure definition. The 
Toolbox uses the data definition include to read the data from a cluster. 

Activities 
The Interface Toolbox enables you to generate a data definition include automatically [Page 796] 
using the specifications for this program. 
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Creating an Include Automatically or Using an Existing 
Include 
Procedure 
1. Choose the Configuration tab index. 

2. In the Object to be processed group box, choose Interface Format. 

3. In the Interface format field, enter the name of your new interface format. 

4. Choose Create. 

You access the Create Interface Format dialog box. 

5. In the Country grouping field, enter the country indicator and, in the Description of new 
interface format field, enter a text. 

You access the Create database object dialog box. 

6. Choose Payroll results/Time data. 

You access the Create Payroll Results/Time Data dialog box. 

7. In the File Data data group, enter the following fields: 

Import/Export Table Name of import/export file (for example, PCL2)

Name of the cluster Name of the cluster (for example, RU) 

8. Choose Continue. 

The system suggests values for the automatic generation of data definition include. 

 
For example, RP-IMP-C2-RD is displayed in the Name of import macro field. 

For example, RPCALCU0 is displayed in the Name of program field. 

9. Choose one of the following steps: 

− Create a data definition include automatically 
a) So that the system will generate the data definition include, enter a new name for the 

include (for example, ZPC2RU00) in the Include to be created field of the Data 
definition include group. If necessary, change the names of the import macro and 
program. 

 
The program name for the cluster containing payroll results (Rx)  is the program 
name of the payroll driver that you use in Payroll. 

− RPCALCx0; where x is the country indicator, for example, RPCALCD0 

− HxxCALC0; where xx is the country indicator, for example, AR for Argentina 

The program name for the time evaluation cluster B2 is the international name 
RPTIME00 (Time Evaluation). 
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b) To generate the include, choose Continue. 

You access the Create Object Catalog dialog box. 

c) In the subsequent dialog, enter the corresponding object catalog entry. 

You access the Add Tables/Field Strings dialog box. 

− Use an existing include 
You have already created a data definition include for another interface format for the 
same cluster object, and want to use this include. 

a) To use this data definition include, choose Existing include in the Data definition 
include data group. In the Name of include field, enter the name. 

b) Choose Continue. 

The Insert Tables/Field Strings dialog box is displayed. 

10. Select the required objects. 

11. Choose Continue. 

12. Save your entries. 

Result 
You have created your data definition include automatically or used an existing data definition 
include. 
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Change Validation 
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Use 
Most of the data exported to a third-party system using the Interface Toolbox does not change in 
every payroll period [Ext.]. For example, an employee’s personal details (name, first name, 
personnel number, and so on) rarely differ from one period to the next. 

If the Interface Toolbox transfers all data for a payroll period for every data export, the following 
disadvantages arise: 

• Increased redundancy of exported data (larger volume of data) 

• Increased transfer load during the data export 

• Increased processing 

The receiver must process all transferred information as it is not possible to determine in 
advance whether or not the information has changed during the payroll periods. 

• High probability of errors made by the Interface Toolbox during data export and during the 
processing of the information by the receiver 

It is therefore a good idea to only export data that has changed since the last data export. The 
third-party system can use the data that has not changed since the last data export again since 
this data already meets your requirements. Only changes to the data must be transferred to the 
third-party system for further processing. 

The Change Validation function allows you to avoid exporting unchanged data. 

Prerequisites 
You have created an Interface Format and can only call the objects assigned to the Interface 
Format for change validation. The objects for change validation  include: 

Table objects [Page 769] (internal tables, field strings, and infotypes) • 

• Field objects [Page 771] 

 

798  April 2001 



 SAP AG Payroll United States (PY-US) 

  Change Validation 

For more information on the interface format and objects, see Interface Format [Page 
].763  

• 

Features 
To deal with this problem, the Interface Toolbox has a change validation function with a wide 
range of functions. 

Create objects [Page 809] 

Delimit objects [Page 811] • 

Single field validation [Page 814] • 

Key fields [Page 817] • 

Relations [Page 820] • 

Wage types [Page 823] • 

• User-defined change validation [Page 82 ]4  

 
There are special rules for the change validation of wage types from the 
corresponding wage type tables. For more information, see Wage Type Processing 
in the Interface Toolbox [Page 82 ]8  . 

See also: 
Comparison Period for Change Validation [Page 800] 
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Comparison Period for Change Validation 
Definition 
The comparison period is a payroll period used in change validation to determine which data has 
changed since the last export.  

Use 
The Change Validation function allows the Interface Toolbox to determine which data has 
changed from one period to another. This data is then transferred to the export file and this 
determines the volume of data to be exported. 

If retroactive accounting is first excluded from individual payroll periods and from multiple 
exports, then it is easy to determine which data in a payroll period will be used for comparison. A 
comparison is always made between the data for the current export and the data for the last 
export, since it identifies the changes that have occurred in the data to be exported. 

 
Data from the March payroll period is compared with the data from the February 
payroll period when the data is exported.  Differences in the March payroll period 
when compared to the February payroll period are exported. 

If data is exported for an employee for the first time, there is no comparison period 
for payroll. If this is the case, the system exports the data for the existing payroll 
period. 

The determination of payroll periods for retroactive accounting and multiple exports is explained 
in the following sections. 

 See also:
Setting the Comparison Period for Multiple Export [Page 80 ]1  

Setting the Comparison Period for Retroactive Accounting [Page 802] 
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Setting the Comparison Period for Multiple Export 

• Repeat 

The selection screen for the 

Use 
If you run the export program several times for the same payroll period, then this is known as 
multiple export. Multiple export can be split into two types: 

• Additional export 

To identify the changes in the dataset for multiple export, the system must know the payroll 
period. When you define the payroll period, you should note the following: 

export program [Page 85 ]9  contains a Repeat run parameter in the 
Export options group box. 

The last data export for this payroll period did not take place for the export program. 

The change validation function uses the last but one data export from the selected 
payroll period to compare the data. An export must have taken place previously, 
otherwise the comparison will be made with the most recent comparison period. 

• Do not select the checkbox for an additional export. 

 

• Select the checkbox for a repeat run. 

If another export run takes place during the selected payroll period, the export program 
assumes that the third-party system has received the data from the last export. 

The change validation function uses the last data export from the selected payroll period 
to compare the data. An export must have taken place previously, otherwise the most 
recent period will be used for the comparison. 

See also:
Setting the Comparison Period for Retroactive Accounting [Page 802] 
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Setting the Comparison Period for Retroactive 
Accounting 
Use 
There are two ways of setting the comparison period for retroactive accounting: 

• First method 

The third-party system receives the data from the original period as well as from the 
retroactive accounting period. 

If the New change validation attribute is flagged, the Toolbox uses the new 
variant for the first method [Page 803]  

− 

If the New change validation attribute is not flagged, the Toolbox uses the old 
variant for the first method [Page 805]  

− 

• Second method [Page 807] 

The third-party system only receives data from the original period. 
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Determination of Comparison Period Using First Method 
if New change validation Attribute Is Flagged 
Prerequisites 
The Toolbox uses this variant if you 

1. Have flagged the New change validation attribute [Page 794]  in the interface format 

2. Have not flagged the Only original periods export option for the export. 

It is assumed that the third-party system has received the data from the retroactive 
accounting periods as well as from the original periods. 

 Use
We recommend that you use this variant because the disadvantages of the old variant [Page 
805] do not apply. The Toolbox now uses the new variant as the standard for a new interface 
format. 

Advantages 

• Each change is only sent once per payroll period. If subsequent exports follow the first 
export, in contrast to the old variant, these changes are not sent. 

• The Toolbox also sends retroactive changes in all cases. 

 
For the first export after a change that covers several payroll periods, the 
changes are sent for each payroll period affected by the change. 

In retroactive accounting for payroll, the preceding payroll periods are defined using the rule that 
the last original period is always used as the comparison period. 

Rule 
The system always determines the most recent payroll period in which the for-period view [Ext.] 
matches the payroll period.  If this does not exist, the last exported payroll period is used. The 
payroll period can be a previous retroactive period for the current export if it exists or the last 
payroll period of the past export. 

These rules are described in an example. 

 
The payroll periods listed in the table are applicable for an employee. 

 

     New New New Old Old Old 

Sequ
ential 
no. 
 

For-
perio
d 
 

In-
perio
d 
 

Conte
nts 
field 
1 

Conte
nts 
field 
2 

Prec
eding 
perio
d 
 

Conte
nts 
field 1 
sent 

Conten
ts field 
2 sent 

Prece
ding 
perio
d 
 

Conte
nts 
field 1 
sent 

Conte
nts 
field 2 
sent 
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1 01 
2000 

01 
2000 

A X - A X - A X 

2 02 
2000 

02 
2000 

B X 1 B # 1 B # 

3 01 
2000 

02 
2000 

A Y 1 # Y 1 # Y 

4 02 
2000 

02 
2000 

B Y 2 # Y 3 B # 
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Determination of Comparison Period Using First Method 
if New change validation Attribute Is Not Flagged 
Prerequisites 
The Toolbox uses this variant if you 

1. Have not flagged the New change validation attribute [Page 794]  in the interface format 

2. Have not flagged the Only original periods export option for the export. 

It is assumed that the third-party system has received the data from the retroactive 
accounting periods as well as from the original periods. 

Use 
The specification of the precedent for the payroll period in change validation has been converted. 
For compatibility reasons, SAP supports this variant.  

Disadvantages 

• If a payroll period is exported several times, changes are also transferred several times. 

• In certain situations, the Toolbox does not export retroactive changes. 

In retroactive accounting for payroll, the preceding payroll periods are defined using the following 
rules: 

Rule 1 
For the first retroactive accounting period in payroll, the preceding period is the most recent 
payroll period in the in-period view [Ext.] that matches the current payroll period in the for-period 
view [Ext.]. If this payroll period does not exist, then the system does not call up a preceding 
period for the data comparison. 

Rule 2 
For the following retroactive accounting periods and the original period for payroll, the system 
always uses the preceding retroactive accounting periods.  

These rules are described in an example. 

 
The payroll periods listed in the table are applicable for an employee. 

 

Sequential no. 
 

For-period 
 

In-period
 

Preceding period Explanation 
 

00001 01 2000 01 2000 none First export 

00002 02 2000 02 2000 00001   

03 2000 03 2000 00002   

00004 04 2000 04 2000 00003   

00003 
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Attribute Is Not Flagged 

00005 02 2000 05 2000 00002 Preceding period according to 
rule 1 

00006 03 2000 05 2000 00005 Preceding period according to 
rule 2 

00007 04 2000 05 2000 00006 Preceding period according to 
rule 2 

00008 05 2000 05 2000 00007 Preceding period according to 
rule 2 
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Second Method for Setting the Comparison Period 
Use 
It is assumed that the third-party system has not received the data from the retroactive 
accounting periods. The third-party system only receives data from the original period. 

In retroactive accounting for payroll, the preceding payroll periods are defined using the rule that 
the last original period is always used as the comparison period. 

Rule 
The system always uses the last original period as the comparison period. 

Application and Procedure for this rule 
On the selection screen for the  , select the Only Original Periods 
radio button in the Export Options group box. The export program then uses the original payroll 
periods to check for changes. 

export program [Page 859]

Result 
The retroactive periods in payroll are suppressed for the data export. 

The comparison period for change validation  is always an original period. 

 
The payroll periods listed in the table are applicable for an employee. 

Only the original periods should be called up for the data export. The third-party 
system does not contain the data from the retroactive accounting periods. 

 

Sequential no. 
 

For-period 
 

In-period
 

Preceding period Period type 
 

00001 01 1996 01 1996 No preceding  
period 

O 

00002 02 1996 02 1996 00001 O 

00003 03 1996 03 1996 00002 O 

00004 04 1996 04 1996 00003 O 

00005 02 1996 05 1996 No export R 

00006 03 1996 05 1996 No export R 

00007 04 1996 05 1996 No export R 

00008 05 1996 05 1996 00004 O 

Legend 

O Original period 

R Retroactive accounting period 
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Create Objects 
Use 
The Create function for change validation only applies to table objects [Page 769]. 

This function checks a table objects and accompanying field objects assigned to the interface 
format for changes to the dataset between two exports. The system compares an object from 
one data export with the same object from the previous data export and checks for changes. The 
table object and all field objects lower in the hierarchy are included in data validation. 

 
For example, the Personal Data infotype (P0002) includes all field objects that the 
infotype has in the selected interface format. 

If you do not use any other change validation functions, the system performs change validation 
for the table objects using the accompanying field objects. If change validation identifies at least 
one change in an object, then the export program will transfer the complete table object with 
data to the third-party system. 

Activities 
Create table objects for change validation [Page 810]. 
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Creating Objects 
Prerequisites 
You have created an interface format. 

Procedure 
10. Choose the Configuration tab index. 

11. In the Object to be processed group box, choose Interface Format. 

12. In the Interface format field, enter the name of your interface format. 

13. Choose Change Validation. 

14. Choose Display / Change. 

The system changes to the change mode. 

15. Choose Create. 

You access the Field Strings/Tables dialog box. 

16. Select the table object for change validation. 

17. Choose Continue. 

The system displays the tree structure. 

18. Choose Edit → Expand. 

The system displays the accompanying field objects for the table object. 

19. Save your entries. 

Result 
You have assigned selected objects in your interface format to change validation, or created 
objects for the change validation. 
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Delimit Objects 
Use 
You can use the Delimit function for table objects [Page 769]  (internal tables, field strings, and 
infotypes). 

This function flags a table object and the accompanying field objects in the payroll period to be 
exported as invalid. 

 
The Delimit function cannot be used separately for an individual field object. If you 
create this function for a table object, the system includes all field objects belonging 
to this object in the delimitation. 

Features 
By delimiting an object, all field objects belonging to this object are flagged with the character 
“<“. The delimitation information “<“ is transferred with the respective field object length. 

The key fields [Page 817]  are exceptions because the system always exports the contents of 
key fields. 

During the data export by the Interface Toolbox, the delimited object is transferred to the third-
party system along with all flagged field objects. By looking at the flagged field object the receiver 
can determine whether or not the object is still valid for the relevant employee. 

Activities 
Activate the Delimit [Page 813] function for a table object. 

See also: 
Example: Delimiting an Infotype [Page 812] 
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Example: Delimiting an Infotype 
You have activated Change Validation for the External Bank Transfers infotype (0011). Choose 
Delimit and define a unique key for the infotypes, for example, the fields BANKL and BANKN. 

The normal change validation process is not affected. However, if the infotype record with the 
defined key is delimited, the Interface Toolbox only defines the values for these key fields. The 
delimitation character “<“ is entered in all other fields. 

Your employee was a member of a club, and between January 1996 and March 1996 the 
membership fees were paid by external bank transfer. This amount is entered in Ext.Bank 
Transfer (0011) infotype. 

The employee ended the club membership on March 31, 1996. You must now set the validity end 
date for this external bank transfer to March 31, 1996 using master data maintenance. 

Use the Interface Toolbox to carry out the data export for April 1996. The following field objects 
for the Ext. Bank Transfer (0011) infotype are included in the objects transported to the third-
party system. 

External Transfers Infotype (0011) 

Field Object Name Field content

P0011-BANKL Bank key 672922 

P0011-BANKN Bank account number 700100 

P011-BETRAG Amount <... < 

P0011-LGART Wage types <... < 

 

The field content “<“ (delimitation) means that the Ext.Bank Transfer infotype (0011) and all 
relevant field objects are invalid for this employee in the export payroll period. 
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Delimiting Objects 
Prerequisites 
You have created an interface format. 

Procedure 
20. Choose the Configuration tab index. 

21. In the Object to be processed group box, choose Interface Format. 

22. In the Interface format field, enter the name of your interface format. 

23. Choose Change Validation. 

24. Choose Display / Change. 

The system switches to the change mode and displays the tree structure. 

25. Choose Edit → Expand. 

The system displays the accompanying field objects for the table object. 
26. Place the cursor on the table object. 

27. Choose Delimit. 

The system delimits the selected table objects with the accompanying field objects. 

28. Save your entries. 

Result 
You have delimited the table object and respective field objects for change validation. 

 
You can reverse the delimitation by selecting the table object and choosing the 
Delimit function again. 
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Single Field Validation 
Use 
The Single Field Validation function only applies to table objects [Page 769]. 

The Change Validation function usually considers the field objects in a table object (internal 
tables, field strings and infotypes) as a unit. The system exports the complete table object as 
soon as a field object in the table object has changed. 

The Single Field Validation function allows you to export just the field objects that have changed. 
If the field object has not changed, the “#” character is exported. 

 
If no field object in a table object has changed from one payroll period to the next, 
then the complete table object is ignored. The corresponding table object is not 
exported. 

Activities 
Activate single field validation [Page 816] for a table object. 

See also: 
Example: Single Field Validation [Page 815] 
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Example: Single Field Validation 
In the TEST interface format, the Work Center/Basic Pay (WPBP) table object is defined with the 
Personnel Subarea (BTRTL), Personnel Area (WERKS) and Employee Subgroup Grouping for 
Personnel Calculation Rule (ABART) field objects. The individual field validation function is 
activated for the table object (WPBP). The system exports the following values for the displayed 
payroll results: 

Export with Single Field Validation 

Object 
 

Previous payroll result
 

Current payroll 
result 

Data after
import 

WPBP-BTRTL 0001 0001 #### 

WPBP-WERKS 0002 0003 0003 

WPBP-ABART 1 1 # 

For Comparison: 

Export Without Single Field Validation 

Object 
 

Previous payroll result
 

Current payroll 
result 

Data after
import 

WPBP-BTRTL 0001 0001 0001 

WPBP-WERKS 0002 0003 0003 

WPBP-ABART 1 1 1 

 

 

 

April 2001  815 



Payroll United States (PY-US)  SAP AG 

Validating Single Fields 

Validating Single Fields 
Prerequisites 
1. You have created an interface format [Page 772]. 

2. You have created the change validation for a table object [Page 810]. 

3. The Maintain Change Validation screen appears. 

The system displays the accompanying field objects for the table object [Page 813]. 

Procedure 
1. Place the cursor on the table object. 

2. Choose Single Field Validation. 

The system validates the single fields for the selected table object. 

3. Save your entries. 

Result 
You have activated single field validation for a table object. In the future, only changed field 
objects will be exported. 

 
You can reverse the single field validation by selecting the table object and choosing 
the Single Field Validation function again. 
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Key Fields 
Use 
You can only use the Key Fields function for field objects [Page 771]  in internal tables or 
infotypes. 

 
The Key Field function cannot be used for the Field string table object, since the 
field string only consists of one entry (for example, the Personal Features (PERM) 
field string in cluster object Rx (for example, RD, RU)). 

Change validation for table objects (internal tables) can only function successfully if you specify 
which line of the current table is to be compared with which line in the table from the comparison 
period. The Key Field function defines those fields which clearly determine a table line as key 
fields for the table object. This means that one table cannot contain two lines that match in all key 
fields. 

For each current table entry, the SAP System searches in the current payroll period for a table 
entry with the same key fields in the comparison period and then compares all fields. 

Activities 
Define the field objects as key fields [Page 819] 

See also: 
Example: Key Fields [Page 818] 
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Example: Key Fields 
You have defined two field objects, Bank Number (BANKL) and Account Number (BANKN) as 
key fields in the table object containing the bank transfer amounts. 

A bank transfer must exist for each account number so that change validation function can work 
with the key field function successfully. 

 

Payroll Period 
01 

Payroll Period 
02 

  

BANKL BANKN AMOUNT  BANKL BANKN AMOUNT

Key field Key field   Key field Key field  

672922 700100 900.00   
 

672922 700100 950.00 

672922 700101 500.00     

672922 700102 400.00   
 

672922 700102 400.00 

    672922 700103 100.00 

    672922 600500 500.00 

 

 

BANKL BANKN AMOUNT Legend 

Key field Key field   

672922 700100 950.00 Change in amount 

672922 700101 <…< 

 

if delimitation active

672922 700103 100.00 Only in period 02 

672922 600500 500,00 Only in period 02 

 

 
The Bank Number (BANKL) and Account Number (BANKN) field objects are key 
fields. The content of these fields is exported, not the “<“ character (delimitation). 
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Defining Key Fields 
Prerequisites 
1. You have created an interface format [Page 772]. 

2. You have created the change validation for a table object [Page 810]. 

3. The Maintain Change Validation screen appears. 

The system displays the accompanying field objects for the table object [Page 813]. 

Procedure 
4. Place the cursor on the table object. 

5. Choose Key Fields. 

The selected field objects in the tree structure have the key field symbol. 

6. Save your entries. 

Result 
You have defined a key field object for change validation. 

 
You can reverse the definition by selecting the field object and choosing the Key 
fields again. 
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Relations 
Use 
The Relations function only applies to field objects [Page 771]. 

 
To use the Relations Between Field Objects function, single field validation [Page 
814] must be active for the relevant table object. 

Features 
The single field validation and relations are related as follows: 
If single field validation is active for a table object, the system only exports fields from the table 
object that have changed. 

There are often close relationships between individual fields in a table in the SAP System. This 
means that the fields are only meaningful together. For example, an employee’s personnel 
subarea data is only meaningful if the personnel area to which the personnel subarea is assigned 
is also known. 

To meet this requirement, you can use the Interface Toolbox to define relations between two or 
more fields. If at least one field that is linked to one or more other fields by the Relations function 
changes, then the system exports all linked fields again. 

Activities 
Create relations [Page 822] between field objects. 

See also: 
Example: Relations Between Field Objects [Page 821]  
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Example: Relations Between Field Objects 
You have already activated single field validation for the Work Center/Basic Pay (WPBP) table 
object 

You want to link the Personnel Area (WERKS) and Personnel Subarea (BTRTL) field objects 
using relations. 

If the content of one of the two field objects changes from one data export to the next, the system 
exports both field objects again. 

 

Previous payroll 
period 

Current payroll  
period 

Export the following 
data 

Explanation 
 

WPBP-BTRTL=0001 WPBP-BTRTL=0001 WPBP-BTRTL=0001 Export again 

WPBP-WERKS=0002 WPBP-WERKS=0003 WPBP-WERKS=0003 Export again 

WPBP-ABART=1 WPBP-ABART=1 WPBP-ABART=# No change, single 
field validation is 
active 

 

The system also checks field objects with no relations individually. 
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Creating Relations 
Prerequisites 
1. You have created an interface format [Page 772]. 

2. You have created the change validation for a table object [Page 810]. 

3. To perform this function, you must first activate Single Field Validation [Page 814]  

4. 

for the 
table object to which the field object belongs. 

The Maintain Change Validation screen appears. 

The system displays the accompanying field objects for the table object [Page 813]. 

Procedure 
1. Place the cursor on the selected field object. 

2. Choose Relations. 

You access the Relations for <name> dialog box. 

3. Select the field object(s) to be linked to the previously selected field object with a relation. 

4. Save your entries. 

Result 
You have created relations for a field object in change validation. 

 
If you choose the Relations icon in front of the name of the field object, you display a 
list of all field objects related to the selected field object. 

To delete unwanted entries, select the entry and choose Delete. 
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Wage types 
For information on the Wage Types function, see Wage Types in Change Validation [Page 838]. 
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User-Defined Change Validation 
Use 
You can use this function to specify that the decision of whether or not to carry out change 
validation will only be made when the export program runs. If you want to use this function, the 
Toolbox requires a user-defined program to decide whether or not to activate change validation. 

Features 
The Interface Toolbox makes demands on the user-defined program so that the change 
validation can be activated when the program runs. 

Program type 
The program type can have the following values: 

• 1 Executable program 

• S Subroutine pool 

Parameters 
The program must contain a form routine with only one parameter. This parameter displays the 
return value for the form routine. The return value determines whether or not the export value is 
to carry out the change validation. The following values are possible for the return value: 

• Change validation not active 

• Change validation active 

The Change Validation function is set to active as default. 

INCLUDE 
If you include INCLUDE 3 from the Export Program function (interface format [Page 763]) in the 
customer program, you can use current export data and the export data from the comparison 
period to the customer form routine to decide whether to activate change validation. 

Activities 
Activate the user-defined change validation [Page 827] 

See also: 
Naming Conventions for Export Data [Page 825] 

Example: User-Defined Change Validation [Page 826] 
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Naming Conventions for Export Data 
The following naming conventions apply to the export data: 

• NEW_<table name> for the current export data (for example, NEW_WPBP) 

• OLD_<table name> for the export data from the comparison period (for example, 
OLD_WPBP) 
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Example: Customer Program for Change Validation 
The following example shows a possible structure for your user-defined program, which will be 
used to decide whether or not to activate change validation when the export program runs. 

 
   REPORT ZPCIFP01. 

   INCLUDE ZPCIFRX3.       “INCLUDE 3 from export program 

   FORM DIFFERENCE_CHECK USING SWITCH. 

      SWITCH = `1`.         “change validation is active 

      READ TABLE NEW_WPBP INDEX 1. 

         IF SY-SUBRC = 0. 

         READ TABLE OLD_WPBP INDEX 1. 

         IF SY-SUBRC = 0. 

            IF ( NEW_WPBP-MASSN <> OLD_WPBP-MASSN) AND 

               ( NEW_WPBP-MASSN = `05`). 

               SWITCH = `0`. “change validation is not active 

   ENDIF. 

   ENDIF. 

      ENDIF 

ENDFORM. 

 

Legend 

The form routine uses the SWITCH parameter, which decides whether or not the change 
validation is active. 

The change validation function is set to active as default (SWITCH = 1). If the MASSN field in the 
Work Center/Basic Pay (WPBP) table for the current export data differs from that in the 
comparison period, and if the current personnel action (MASSN) is ‘05’, then change validation is 
not active. 
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Activating User-Defined Change Validation 
Prerequisites 
1. You have created an interface format [Page 772]. 

2. You have created the change validation for a table object [Page 810]. 

3. The Maintain Change Validation screen appears. 

The system displays the accompanying field objects for the table object [Page 813]. 

Procedure 
5. Choose User-defined change validation. 

The User-Defined Change Validation dialog box appears. 

6. In the Program field, enter the customer (user-defined) program. In the Form Routine field, 
enter the name of the accompanying form routine. 

7. Save your entries. 

Result 
You have specified which user-defined program the Toolbox will use to decide whether or not to 
activate change validation when the export program is run. 
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Wage Type Processing with the Toolbox 
Use 
In payroll, wage types [Ext.] are important stores of information which are used to calculate 
wages and salaries. The wage type is particularly important in the Interface Toolbox, which was 
developed to export payroll results from the Human Resources (HR) component to a third-party 
system. 

Special, enhanced processing rules apply for particular functions in the Interface Toolbox to meet 
the demands made on the wage types. These processing rules differ from the processing rules 
for individual functions. This concerns the following functions: 

Interface Format • 

Wage Types in the Interface Format [Page 829] 

Change Validation • 

Wage Types in Change Validation [Page 838] 

 
The same processing rules apply to wage types as to other objects for all functions in 
the interface format or change validation that are not specifically mentioned here (for 
example, the conversion function for field objects, and so on) 
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Wage Type Tables in the Interface Format 
Definition 
A Human Resources (HR) table can be treated as a wage type table in the interface format if the 
table contains at least one field with the LGART field name. 

Use 
The Interface Toolbox processes wage types and the accompanying wage type tables in the SAP 
System separately in the interface format. 

Table Types 
If there is a field in the table with the name LGART, then one of the following two table types can 
be set for this table: 

• Regular tables 

The system treats the tables in the interface format as regular tables (for example, 
WPBP (Work Center/Basic Pay)). 

• Wage type tables 

The system treats the tables in the interface format as wage type tables (for example, 
RT (Results Table)). 

Assign Table Type 
The Restrictions function in the interface format allows you to assign one of the two table types to 
a table containing at least one field with the name LGART. If you select one of the special 
restrictions for wage types using the Restrictions [Page 792] function, then the Toolbox will define 
this table as a wage type table. 

 
The Results Table (RT) table object is automatically defined as a wage type table by 
the Interface Toolbox. 

Other table objects are considered to be regular tables. 

See also: 
Wage Type Selection in the Interface Format [Page 830] 
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Wage Type Selection in the Interface Format 
Use 
You can select subsets of a wage type table (individual wage types) for export in the same way 
as when selecting a field object in a regular table. In both cases, use the Restrictions [Page 792] 
function in the Interface Format to select a subset of table entries (lines in the table [Page 831]) 
for wage types or field objects. 

Different From Selecting Other Field Objects 
The selection of wage types from wage type tables differs from the selection of other field objects 
form regular tables. 

• If you do not enter any restrictions, all wage types will be exported. 

• If you enter restrictions, the only wage types exported are those that you have assigned to 
the wage type table using the Restrictions function. 

To process the wage types, the Interface Toolbox requires additional information that must be 
entered when the wage types are selected for data export (Restrictions function). This 
information determines how the wage types are processed in the original payroll run and also in 
retroactive accounting. This additional information is contained in the different wage type 
options for retroactive accounting. 
If you have entered restrictions, the Interface Toolbox exports all wage types using wage type 
option [Page 832] R1. 

 
If the same processing rules apply to a subset of wage types, then you can also 
select these wage types generically, for example, * or /1*. 

Prerequisites 
To process wage type tables, you must assign your table objects to the interface format before 
you can export data. 

See also: 
Wage Type Options for Retroactive Accounting [Page 832] 
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Structure of a Wage Type 
Definition 
A wage type is a table entry in a wage type table. A wage type consists of the LGART field and 
the following three numerical fields: 

• Amount 

• Rate 

• Number 

Other fields also belong to a wage type (for example, Split Indicator, Currency). 

 

Wage types Amount Rate Number 

LGART (RTE) (AMT) (NUM) 

For example, MA10 For example, 10 For example, 5 For example, 2

 

These fields form one line (table entry) in the wage type table for the corresponding wage type. 
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Wage Type Options for Retroactive Accounting 
Use 
The ability to run retroactive accounting is one of the most important characteristics of payroll. 
A retroactive run is necessary, for example, in the following case: 

You have made changes to HR master data for the payroll past. 

The system must run payroll for these payroll periods again, even though payroll is completed. 
The modified payroll data must be taken into account. 

When comparing the payroll periods [Ext.] to be included in retroactive accounting with the 
original payroll period, the payroll program or reporting programs may identify that corrections are 
required. 

 
As a result of a retroactive salary increase, an additional amount must be transferred 
to the employee. 

Wage Types in a Retroactive Run 
Most wage types are created in the retroactive accounting period with the amount that would 
have been used in the original period (for example, wage type /101 (Total Gross Amount)). 

However, there are wage types that contain the differences between the retroactive period and 
the original payroll period. 

 
Wage type /553 (Recalculation difference for last payroll run) is the difference 
between the payment amount for the current payroll period in the payroll run and the 
previous result. 

To support third-party payroll systems that do not use retroactive accounting, or that use a 
different method to form retroactive accounting differences, the Interface Toolbox has 
retroactive accounting functions. 

Features 
• Retroactive Accounting Option R1 

The system processes the selected wage type as in the original payroll period. The 
system transfers the values in the three wage type fields (Amount, Rate, and Number) 
unchanged to the third-party system. 

Retroactive Accounting Option R2 • 

The system calculates the difference between the values in the three wage type fields 
(amount, rate, and number) for the selected wage type from the retroactive accounting 
period and the comparison period [Page 834]. These differences are assigned  to the 
respective retroactive accounting period. If the difference for all three fields is 0 (zero) 
then the system does not export this wage type. 

• Retroactive Accounting Option R3 
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As for option R2, the system calculates the difference between the values in the three 
wage type fields (amount, rate, and number) from the retroactive accounting period and 
the comparison period. However, these differences are assigned to the period 
immediately preceding the current payroll period. 

• Retroactive Accounting Option R4 
As for options R2 and R3, the system calculates the difference between the values in 
the three wage type fields (amount, rate, and number) from the retroactive accounting 
period and the comparison period. These differences are assigned to the current 
payroll period. If the relevant wage type already exists in the payroll period, then the 
system cumulates the values for each personnel number. If the third-party system does 
not use retroactive accounting, you should choose this wage type option. 

• Option DT 
Options R3 and R4 have a special feature to allow wage types to be assigned to a 
payroll period, even if they do not originate in this payroll period and come from 
retroactive accounting periods instead. If you wish to retain information on whether the 
wage type comes from a retroactive accounting period or from an original period, then 
choose option DT. 

The system assigns wage types that originate from retroactive accounting to a table with 
the name $D<name>, instead of to a table in the original period. 

Activities 
Choose a wage type option [Page 837] 
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Comparison Period for Wage Type Options in 
Retroactive Accounting 
Definition 
The comparison period is a payroll period used within the Restrictions function in Change 
validation. It is used to determine which data has changed since the last export.  

Use 
If you are running first retroactive accounting for the first time for the for-period [Ext.] in question, 
the Interface Toolbox will use the original payroll period as the comparison period. However, it 
could be the case that several retroactive accounting runs are required for a payroll period [Ext.] 
.  

 
You are recalculating payroll period 01 from period 02. 

If it is necessary to recalculate payroll period 01 from period 04 again, then the 
differences are created as follows. 

The difference between the payroll period “period 01 recalculated from period 
04” and the payroll period “period 01 recalculated from period 02”. 
The difference for the original period 01 is not created. 

Rule 

The payroll period that the system always uses for comparison is the most recent payroll period 
with the same for-period view [Page 835] as the payroll period currently being processed. 

See also: 
Defining the Comparison Period for Generating Wage Type Differences for Several Retroactive 
Runs [Page 836] 
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In-Period Information / For-Period Information 
The for-period information specifies the payroll period for which the payroll result is valid. 

The in-period information specifies the payroll period in which the system has created the 
payroll result. 

Together the in-period information and the for-period information characterize one payroll 
result. 

 

Example: For-Period Information / In-Period Information 

Payroll result 
 
 
 

For-per. 
informati
on 
 
 

Start date of for-per.
information 
 

End date of
for-per. 
information
 

In-per. 
informat
ion 
 
 

End date of 
in-per. 
information 
 

1 01/1997 01.01.1997. 31.01.1997 02/1997 02.28.1997 

2 02/1997 02.01.1997 28.02.1997 02/1997 02.28.1997 

 

Explanation 
 
Payroll result 1 for payroll period (for-period) 01/1997 has the start date January 01, 1997 and 
the end date January 31, 1997. This payroll result was created in payroll period (in-period) 
02/1997. 
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Example: Comparison Period for Wage Type Differences 
for Several Retroactive Runs 

 
Do not confuse this example with the determination of the comparison period for 
change validation [Page 800]. 

An employee has the payroll results listed in the table. The payroll results contain each relevant 
payroll comparison period for the creation of wage type differences (changes). The system 
compares the most recent payroll period with the same for-period information [Page 835] as the 
payroll period being processed. 

 

Sequential no. 
 

For-period 
 

In-period
 

Preceding period
 

00001 01 1996 01 1996 No preceding  
period 

00002 01 1996 02 1996 00001 

00003 02 1996 02 1996 No preceding  
period 

00004 03 1996 03 1996 No preceding  
period 

00005 01 1996 04 1996 00002 

00006 02 1996 04 1996 00003 

00007 03 1996 04 1996 00004 

00008 04 1996 04 1996 No preceding  
period 
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Activating Wage Type Options for Retroactive 
Accounting 
Prerequisites 
1. You have created an interface format [Page 772]. 

2. You are in the object tree [Page 774] and all table objects are displayed with all field objects. 

Procedure 
10. Place the cursor on the selected wage type field (LGART) in the table object to be edited. 

11. Choose Restrictions. 

You access the Set Restrictions dialog box. 

12. Select Special restrictions for wage types. 

You access the Wage Type Restriction for <name> dialog box. 

13. Enter the restrictions. 

 
Several entries for a field object are linked implicitly with the logical operation OR. 

14. Enter the name of the wage type and select the required option (DT, R1-R4). 

15. Choose Transfer.  

16. Save your entries. 

Result 
You have used the Interface Toolbox to activate one of the wage type options for retroactive 
accounting (R1 to R4) for a wage type field. If you have already activated wage type option DT, 
wage types used in the retroactive run will be assigned to the table $D<table name >. The 
information necessary for the data export of a wage type is now complete and the wage type is 
assigned to the corresponding wage type table. 
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Wage Types in Change Validation 
Use 
The Interface Toolbox processes wage types and the accompanying wage type tables separately 
during change validation. 

Just as the Interface Toolbox processes regular tables [Page 829] in change validation, you can 
also run change validation [Page 798] for wage type tables. The system only exports the wage 
types to the third-party system if they have changed from one data export to another. 

The following topics are important for using this transaction: 

Change validation and wage type tables [Page 839]  • 

Change validation and wage type comparison [Page 840]  • 

• Wage types and split indicators [Page 841] 

Features 
The following functions are available for wage types in change validation: 

• Activate wage types for change validation [Page 842] 

The functions are only valid for wage types. 

You can use the following change validation functions to process wage types. The functions have 
modified or restricted processing rules. 

• Delimit wage types for change validation [Page 844] 

The following functions cannot be used in connection with the change validation: 

• Validating single fields  

• Key fields 

The explicit definition of key fields is not possible for wage types. The wage type name 
(LGART) is always used as the key field. 

• Relations 

 

Prerequisite 
You have assigned the individual wage type to the relevant interface format using the 
Restrictions [Page 792] function for field objects in the Interface Format. In this assignment, you 
have activated one of the wage type options for retroactive accounting (R1 to R4) for each wage 
type to be included in change validation. 

If you have not entered restrictions, all wage types will be exported with wage type option R1. 
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Change Validation and Wage Type Tables 
If it is a regular table, activate change validation for the complete table. 

If it is a wage type table, then change validation always refers to a single wage type. 

Just as with regular tables, the only field objects included in change validation are those you 
have already assigned to change validation. You must assign each wage type required for the 
difference check to change validation. 

If you do not specify any wage types. change validation will not take place in the standard 
system. 
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Change Validation and Wage Type Comparison 
You can set the comparison period for change validation with wage types as for all other objects. 
When the system checks a wage type [Page 83 ]1  for changes, it uses the three fields (amount, 
rate, and number) that are common to all wage types. 

The wage type comparison has the following results: 

• If the content of at least one of the three wage type fields has changed then the relevant 
wage type and the three fields will be exported again. 

• If the content of none of the three wage type fields has changed then this wage type will be 
ignored. The relevant wage type is not exported.  

 
For more information on comparison periods in change validation, see 
Comparison Periods in Change Validation [Page 800]. 
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Wage Types and Split Indicators 
If wage types have split indicators [Ext.], there can be several table entries (lines in the table 
[Page 831]) for this wage type in the wage type table. As a result the wage type name is not 
sufficient as a key to identifying a table entry. 

The Problem of Wage Types and Split Indicators [Page 199]  

In change validation, it is not clear which table entry for the wage type in the comparison period is 
to be compared with which table entry in the current payroll period. 

Solution 

If you want to use change validation for wage types, you must ensure that only one table entry 
exists per wage type. To ensure that this is the case, do not export split indicators. You must 
not select the field object containing the split indicator for export. If you have already selected this 
field object for export, delete it. If the wage type exists several times after the split indicator has 
been deleted, the system cumulates the multiple entries for this wage type and stores them in 
one entry. 

 

 

 

April 2001  841 



Payroll United States (PY-US)  SAP AG 

Activating Wage Types for Change Validation 

Activating Wage Types for Change Validation 
Use 
The Wage Types function is only allowed for wage types. The system only checks the wage 
types for changes if you have assigned the wage types to change validation using the Wage 
Types function. 

Activities 
Activate wage types for change validation [Page 843] 
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Activating Wage Types for Change Validation 
Prerequisites 
1. You have created an interface format [Page 772]. 

2. You must first use the Restrictions [Page 792] function to assign the wage type to be 
processed to the interface format to be processed. 

3. You have created the change validation for a table object [Page 810]. 

4. The Maintain Change Validation screen appears. 

The system displays the accompanying field objects for the table object [Page 81 ]3 . 

Procedure 
29. Place the cursor on the field object LGART. 

30. Choose Wage types. 

You access the Wage Types for <name> dialog box. 

31. Select the wage types you want to include in change validation. 

32. Choose Continue. 

33. Save your entries. 

Result 
You have assigned individual wage types in a wage type table to change validation. 

 
You can remove individual wage types from the assignment by selecting the wage 
type symbol. The system displays the wage types. Select the wage type and choose 
Delete. 
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Wage Type Delimitation for Change Validation 
Use 
The Delimit function refers to a single wage type. A wage type table is delimited on the wage 
type level and must be carried out for each wage type individually. 

Alternatively, you can use the Delimit function following the instructions under Delimiting Objects 
[Page 811]. 

Constraints 
If you use the Delimit function for wage types, you should note that a wage type is delimited 
irrespective of the wage type options for retroactive accounting (R1 to R4). 

Activities 
Delimit wage types for change validation [Page 845] 
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Delimiting Wage Types for Change Validation 
Prerequisites 
1. You have created an interface format [Page 772]. 

2. You must first use the Restrictions [Page 792] function to assign the wage type to be 
processed to the interface format to be processed. 

3. You have created the change validation for a table object [Page 81 ]0 . 

4. The Maintain Change Validation screen appears. 

The system displays the accompanying field objects for the table object [Page 81 ]3 . 

Procedure 
1. Choose wage types. 

The system displays the accompanying field objects for the LGART field. 

2. Place the cursor on a wage type. 

3. Choose Delimit. 

The Delimit symbol appears next to the wage type. 

4. Save your entries. 

Result 
You have delimited individual wage types in a wage type table for the data transport. 
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Examples: Interaction of Wage Types and Wage Type 
Options for Retroactive Accounting in Change 
Validation 
The following example explains how the individual change validation functions can be used for 
wage types from wage type tables. 

Example: An employee has the following payroll periods 

 
Sequent
ial no. 
 

 
For-
period 
 

 
In-period 
 

Total Gross Amount wage type from the results table 
(RT) 
 

00001 01 1996 01 1996 3 000.00 
 

00002 02 1996 02 1996 3 000.00 
 

00003 01 1996 03 1996 3 500.00 
 

00004 02 1996 03 1996 3 500.00 
 

00005 03 1996 03 1996 3 500.00 
 

00006 03 1996 04 1996 Wage type not available 

00007 04 1996 04 1996 Wage type not available 

The following examples consider the generation of a special wage type. The Total Gross Amount 
wage type (secondary wage type /101) from the Results Table (RT) is used as an example wage 
type for the employee. 

The total gross amount wage type contains an amount of 3,000.00 for the payroll periods 01 and 
02. 

• Before payroll is run for payroll period 03, the Total Gross Amount wage type is increased 
retroactively to 3,500.00 as of payroll period 01. This increase corresponds to a salary 
increase for the employee. The retroactive increase in the total gross amount triggers 
retroactive accounting for this employee. 

• Before the payroll run for payroll period 04, the Total Gross Amount wage type is set to 
ZERO (0) as of payroll period 03 since the employee should not receive any pay as of payroll 
period 03. 

Payroll is run for payroll period 04 with retroactive accounting for period 03. 

The following examples show how the Interface Toolbox works in connection with wage type 
processing in the interface format and change validation. 
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Example 1: Third-Party Payroll System Runs Retroactive Accounting (R1) [Page 848] • 

Example 2: Third-Party Payroll System Runs Retroactive Accounting (R1); Change 
Validation and Delimitation Functions are Active [Page 849] 

• 

Example 3: Third-Party Payroll System Runs Retroactive Accounting (R2) [Page 851] • 

Example 4: Third-Party Payroll System Runs Retroactive Accounting (R2); Change 
Validation and Delimitation Functions are Active [Page 852] 

• 

Example 5: Third-Party Payroll System Without Retroactive Accounting (R4) [Page 85 ]4  • 

• Example 6: Third-Party Payroll System Without Retroactive Accounting (R4); Change 
Validation and Delimitation Functions are Active [Page 855] 
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Example 1: Third-Party Payroll System Runs Retroactive 
Accounting (R1) 
A third-party payroll system runs retroactive accounting. You want to transfer the Total Gross 
Amount wage type and all other wage types in the SAP System from the employee’s payroll 
result to the third-party system. 

To do this, choose retroactive accounting option R1 [Page 832]. The Total Gross Amount wage 
type has the following values after the data export: 

Payroll period 
 

Total Gross Amount wage type from the results table (RT) 

01 in 01 3 000.00 

 

02 in 02 3 000.00 

 

01 in 03 3 500.00 

 

02 in 03 3 500.00 

 

03 in 03 3 500.00 

 

----------- 

04 in 04 ------------ 

03 in 04 

Legend 
1. In the 01 in 03 and 02 in 03 payroll periods, the system exports the unchanged total 

values for the wage type from the original period. 

2. The wage type is no longer available in the payroll periods 03 in 04 and 04 in 04 since it 
was set to ZERO as of payroll period 03, before the payroll run for payroll period 04. 
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Example 2: Third-Party Payroll System Runs Retroactive 
Accounting (R1); Change Validation and Delimitation 
Functions are Active 
You only want to export wage types if they have changed from one payroll period to another. You 
activate change validation for your wage types by assigning single wage types to change 
validation using the Create function. (For more information on creating objects in change 
validation, see Creating Objects [Page 809]). 

The following problem can occur in this situation. 

A wage type from a payroll period does not exist in the export file. It is unclear whether the wage 
type did not occur in this payroll period, or whether it has a value identical to the value in the 
comparison period. 

There are two possible solutions to this problem: 

• The user is active: 

You provide information on whether the wage type still exists in the payroll period. You can 
do this using an additional wage type. This additional wage type acts as a switch (switch 
wage type). The system generates the switch wage type if the original wage type no longer 
exists. 

• The Interface Toolbox is active with the Delimit  function: 

You can delimit the wage type using the corresponding function. The system generates the 
character “<“ for the wage type in question. The delimitation sign means that the wage type is 
no longer valid for the employee. 

 
For more information on delimiting objects within change validation, see Change 
Validation → Delimiting Objects and Wage Type Processing in the Interface Toolbox 
→ Delimiting Wage Types for Change Validation. 

If change validation and delimitation are active for the wage type, then the Total Gross Amount 
wage type has the following result data for the data export: 

Payroll period 
 

Total Gross Amount wage type from the results table (RT) 

01 in 01 3 000.00 

 

02 in 02 ---------- 

01 in 03 3 500.00 

 

02 in 03 ---------- 

03 in 03 --------- 

03 in 04 < ... < 
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04 in 04 ------------ 

Legend 
1. The wage type in the 02 in 02 payroll period is not exported since the total value of the 

wage type has not changed when compared with the values in the 01 in 01 payroll 
period. 

2. The wage type is not exported in the 02 in 03 and 03 in 03 payroll periods, since the total 
value for the wage type has not changed from the value in the 01 in 03 payroll period. 

3. In the 03 in 04 payroll period, the wage type is delimited, since it no longer exists. 

4. The wage type no longer exists in the 04 in 04 payroll period since the system has 
already transferred the delimitation information to the 03 in 04 payroll period 
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Example 3: Third-Party Payroll System Runs Retroactive 
Accounting (R2) 
A third-party payroll system runs retroactive accounting. You only want the SAP System to 
transfer the differences between the payroll period used in retroactive accounting and the payroll 
period from the original payroll run to the third-party system for retroactive accounting periods. 

To do this, choose retroactive accounting option R2 [Page 837]. 

The Total Gross Amount wage type has the following results data for the data export: 

Payroll period 
 

Total Gross Amount wage type from the results table (RT) 

01 in 01  3 000.00 

 

02 in 02  3 000.00 

 

01 in 03    500.00 

 

02 in 03    500.00 

 

03 in 03  3 500.00 

 

03 in 04 -3 500.00 

 

04 in 04 ------------- 

Legend 
1. In the 01 in 03 and 02 in 03 payroll periods, the system only exports differences from the 

retroactive accounting period and the original period. 

3 500.00 - 3 000.00 = 500.00 

2. In the 03 in 04 payroll period, the total wage type amount is - 3,500.00, since the value of 
the wage type was retroactively set to ZERO in payroll period 03. 

0 - 3 500.00 = - 3 500.00 

3. The wage type no longer exists in the 04 in 04 period, since it was set to ZERO as of 
payroll period 03, before the payroll run for payroll period 04. 
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Example 4: Third-Party Payroll System Runs Retroactive 
Accounting (R2); Change Validation and Delimitation 
Functions are Active 
A third-party payroll system runs retroactive accounting. You only want the R/3 System to 
transfer the differences between the retroactive accounting payroll period and the comparison 
period to the third-party system during retroactive accounting periods. 

 
For more information on the comparison period, see Defining the Comparison Period 
for Wage Type Options in Retroactive Accounting. 

To do this, choose retroactive accounting option R2 [Page 832]. 

By activating change validation, you also ensure, as in example 2, that export wage types are 
only exported again if they have changed. 

 

 
Make sure that change validation is only activated for the original periods, and not for 
the retroactive periods in payroll. 

The change validation function for retroactive accounting periods is controlled by the 
R2 retroactive accounting option. 

Change validation for the original periods in payroll also refers to the total value of the 
respective wage type and not to the differences. 

To delimit wage types, follow the procedure recommended in example 2. 

 
The system only delimits wage types if the respective wage type exists and has a 
difference in retroactive accounting. 

The Total Gross Amount wage type has the following results data for the data export: 

Payroll period 
 

Total Gross Amount wage type from the results table (RT) 

01 in 01  3 000.00 

 

02 in 02 ----------- 

01 in 03     500.00 

 

02 in 03     500.00 

 

03 in 03 ------------- 
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03 in 04 -3,500.00 (first entry) 

< ... < (additional delimitation information) 

04 in 04 ------------ 

Legend 
1. The wage type in the 03 in 03 payroll period is not exported since the total value of the 

wage type has not changed when compared with the values in the 02 in 03 payroll 
period. 

2. In the 03 in 04 payroll period, the results table (RT) contains two entries for the Total 
Gross Amount wage type. On the one hand, the difference between the original 03 in 03 
payroll period and 03 in 04 (0.00 - 3,500.00 = -3,500.00) is transferred. On the other 
hand, the wage type no longer exists in the payroll period, so the “<“ delimitation 
information must be transferred. 

3. The wage type no longer exists in the 04 in 04 payroll period since the delimitation 
information has already been transferred in the 03 in 04 payroll period 
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Example 5: Third-Party Payroll System Without 
Retroactive Accounting (R4) 
The third-party system performs payroll without retroactive accounting. 

Therefore, you want to collect the differences from the retroactive accounting run and transfer 
them with the corresponding original period to payroll. 

To do this, choose retroactive accounting option R4 [Page 832]. 

The Total Gross Amount wage type has the following results data for the data export: 

Payroll period 
 

Total Gross Amount wage type from the results table (RT) 
 

01 in 01 3 000.00 

 

02 in 02 3 000.00 

 

01 in 03 ----------- 

02 in 03 ----------- 

03 in 03 4 500.00 

 

03 in 04 ------------ 

04 in 04 3 500.00 (Repayment from 03 as recalculation difference) 

Legend 
1. The differences from the 01 in 03 (500.00) and 02 in 03 (500.00) payroll periods are 

collected. 

The value of 4,500.00 is calculated as follows: 

2 * 500.00 + 3 500.00 = 4 500.00 

2. The wage type is no longer available in the payroll periods 03 in 04 and 04 in 04 since it 
was set to ZERO as of payroll period 03, before the payroll run for payroll period 04. 
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Example 6: Third-Party Payroll System Without 
Retroactive Accounting (R4); Change Validation and 
Delimitation Functions are Active 
The third-party system performs payroll without retroactive accounting. Therefore, you want to 
collect the differences from the retroactive accounting run and transfer them with the 
corresponding original period to payroll. To do this, choose retroactive accounting option R4 
[Page 832]. 

You also want to activate the change validation and delimitation functions for wage types. This 
can cause problems, since the information (wage type) is condensed in such a way that the 
result could be interpreted incorrectly. 

The Total Gross Amount wage type has the following results data for the data export: 

Payroll period 
 

Total Gross Amount wage type from the results table (RT) 

01 in 01  3 000.00 

 

02 in 02 ------------ (since change validation is not active) 

01 in 03 ------------ 

02 in 03 ------------ 

03 in 03  4 500.00 

 

03 in 04 ------------ 

04 in 04 -3,500.00 (first entry) 

< ... < (additional delimitation information) 

Problem 
• If this information is the only information available for the wage type, then it could be 

interpreted as follows: 

• In payroll periods 01 and 02 the wage type was worth 3,000.00. 

• This value did not change with retroactive effect in the 01 in 03 and 02 in 03 payroll periods. 

• In payroll period 03, the wage type was worth 4,500.00. 

The calculation of the amount 4,500.00 (2*500.00 + 3,500.00 = 4,500.00) cannot be 
reconstructed here. However, it is necessary since change validation is used. 

• This would also mean that the value of the wage type had decreased retroactively for payroll 
period 03, and would have the value 1,000.00. 

• Payroll period 04 is the first period in which the wage type does not occur. 
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Solution 
To solve this problem, you should activate the DT [Page 832] wage type option for retroactive 
accounting. The values for the Total Gross Amount may appear as follows: 

 

Payroll period 
 
 

Total Gross Amount wage type 
from the results table (RT) 

Total Gross Amount wage type 
from the table ($DRT) 
 

01 in 01 3 000.00 

 

------------ 

02 in 02 ------------  ------------ 

01 in 03 ----------- ------------ 

02 in 03 ----------- ------------ 

03 in 03 3 500.00 

 

 1 000.00 

 

03 in 04 ------------ ------------ 

04 in 04 < ... < -3 500.00 

 

 

Legend 
1. In the 03 in 03 payroll period, the retroactive accounting difference of 1,000.00 and the 

amount of 3,500.00 are shown separately. This clearly shows that the current value of the 
wage type is 3,500.00 for the 03 in 03 payroll period. 

This information would be of particular importance for the payroll run in the 04 in 04 
payroll period if the wage type had retained the value of 3,500.00 and no longer occurred 
because the change validation function was active. It would be unclear whether the 
employee is entitled to 3,000.00 or 4,500.00. 

2. The change validation function sends the delimitation information to the “04 in 04” payroll 
period even though the wage type no longer exists in the 03 in 04 payroll period. 

The reason for this is the Only Export in Original Period option which is flagged in the 
selection screen for the export program. 

If you had not selected this option, then the Toolbox would have sent the delimitation 
information in the 03 in 04 payroll period. 
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Generation - Interface Format for the Export Program 
Use 
The Interface Toolbox does not use a standard data export program when exporting data. This 
means that there is no ready-made program for data export in the SAP System. 

Features 
The following demands are placed when exporting data from the SAP System to a third-party 
system. 

• Flexibility for the user 

• High transfer speed during data export 

To meet these requirements, the system generates the export program based on user’s 
requirements. These user requirements are stored in the tables in the Interface Toolbox. 

If you have created an interface format, or have changed one of the following areas, you must 
regenerate the export program when before you can use it: 

Interface format [Page 76 ]3  • 

Import macro for cluster data [Ext.] • 

Data definition include [Page 795]  • 

Change validation [Page 79 ]8  • 

• Wage type processing [Page 828] 

Prerequisite 
Before you generate the export program, you must enter the name of the export program in the 
interface format for the Toolbox: 

• In the Main Program field, enter the name of the export program 

• In the Include 1 to 9 fields, enter the name of the data definition include 

 
Do not use the name of a program or include that has already been used for a 
different purpose. 

The Toolbox only receives the names of the export program and includes. The coding for the 
export program is generated in the interface format via the Generate function. 

Activities 
Generate the export program [Page 858] 
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Generating the Export Program 

Prerequisites 
You have created an interface format or made changes in one of the following areas: 

Interface format [Page 76 ]3  • 

Import macro for cluster data [Ext.] • 

Data definition include [Page 795] • 

Change validation [Page 79 ]8  • 

• Wage type processing [Page 828] 

Procedure 
13. Choose the Configuration tab index. 

14. In the Object to be processed group box, choose Interface Format. 

15. In the Interface format field, enter the name of your new interface format. 

16. Choose Generate. 

Result 
The customer export program for the interface format has been generated for data export. 
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Export Program 

Definition 
Using your defined interface format as a basis, the Interface Toolbox generates a program using 
the Advanced Business Application Programming language (ABAP). This program is the export 
program. 

• 

Use 
The export program transfers payroll results from the SAP System to a third-party system. You 
must  

generate [Page 857], and 

• execute [Page 860] the export to suit your requirements. 

Structure 
When you start the export program, you see a selection screen with several input blocks. 

• You can select the payroll period and personnel numbers in the upper areas. 

• The lower area allows you set parameters for the export program. 

Activities 
Start the export program [Page 860] 
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Starting the Export Program 
Prerequisites 
You have created an interface format. 

Procedure 
1. Choose the Export tab index. 

2. In the Export activities group box, choose Export with interface format. 

3. In the Interface format field, enter the name of your interface format. 

4. Choose Execute. 

You access the Export dialog box. 

5. In the individual fields, enter the necessary data and select the required export options. 

6. Choose Execute. 

Result 
You have created the export file for the personnel numbers selected from a payroll area. 
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Infotype: Export Status (0415) 
Use 
The Interface Toolbox uses the Export Status infotype (0415) to monitor the export status for the 
individual interface formats.  

The infotype enables you to run payroll at the same time as other interface formats (Master Data 
interfaces and payroll interfaces). Separate administration of retroactive accounting (using the 
Payroll Status infotype (0003)) and interfaces (using the Export Status infotype (0415) subtype 
(interface name)) ensures that unwanted interaction is avoided. The retroactive accounting 
capabilities remain unrestricted. 

Structure 
Subtype 
• Interface name 

Name of the interface format from which the export program has been generated. 

Fields 
The fields correspond to the relevant fields in the Payroll Status infotype (0003). 

• Earliest personal RA date 

Earliest date from which data can be exported. 

• Export until 

The employee data is exported until this date, even if the date is after the employee 
leaving date. The date must be in a period during which the employee is not active. 

• Do not export after 

The employee data was exported until this date. 

• Exported until 

The employee data has been exported up to this date. 

• Earliest MD change 

If payroll data is changed for an employee, the R/3 System stores the validity start date. 

The export program uses this date to identify whether an export must be repeated, and if 
so, the date on which the new export must take place to transfer the change to the third-
party system. 

• Personnel number locked 

If this field is flagged, the employee is locked for export and the personnel number will 
not be exported. In this case, the personnel number is not exported.  

Features 
The Interface Toolbox creates and maintains the Export Status infotype (0415). 
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Fields 

• The interface format creates the Export Status infotype (0415) for this personnel number 
when the personnel number is exported for the first time with a particular interface format. 

• For each subsequent export, the Interface Toolbox enters the end date of the exported 
payroll period in the Exported Until field. 

• The SAP System automatically enters the appropriate date in the Earliest MD Change field at 
the same time as the Earliest MD change field in the Payroll Status infotype (0003). 

• You can use the remaining fields to monitor the export of individual personnel numbers. The 
Interface Toolbox usually maintains the Export Status infotype (0415) for you. 
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Export History for Interface Results 
Use 
To carry out detailed change and wage type validation, the export program must be able to 
access the data from previous exports. For this reason, the Interface Toolbox stores the data for 
each export. 

Just like the payroll results, the stored interface results can be divided as follows: 

• Interface directory 

The interface directory is a table of contents for personnel numbers. It contains all payroll 
runs, along with other detailed information (for example, for-period, in-period, payroll 
area.) 

• Interface data 

The interface data contains the individual export data for the personnel number(s). 

 

The interface data is always in its original state, that is, the state before change 
validation is carried out. 

The Interface Toolbox can work with several interface formats. As a result, the interface results 
are stored for each interface format. 

Prerequisites
You must select the Update export option before you start the export program [Page 85 ]9 . 

Features 
You can use the Toolbox to  

• Display 

• Delete  

It is often a good idea to delete interface results in the test system. The Interface Toolbox 
offers you two options: 

• Delete the last interface result for one or more personnel number(s). 

The interface results for the selected personnel number(s) are deleted. 

• Delete all interface results for an interface format. 

If no personnel number is entered, the interface results for all personnel numbers 
belonging to this interface format are deleted. 

To ensure consistency, it is not possible to delete an individual interface result within the 
sequence of interface results. The last (current) interface result is the only exception. 
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Displaying the Interface Format 

Procedure 

3. If required, you can use the Personnel no. and Payroll area fields to restrict the selection of 
the data. 

The system displays the content of the table at the time when the selected interface 
result was exported. 

 

Prerequisites 
You want to display the interface results for an interface format after the data export. 

1. Choose the Export History tabstrip. 

2. In the Interface format field, enter the name of your interface format. 

4. Choose Display. 

5. Select a line from the interface results. 

To give a complete overview, both the exported entries and those entries not exported 
due to change validation are displayed. However, wage types with restrictions are not 
displayed. 

Result 
You have displayed the interface data for an interface format. 
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Deleting Interface Results 

Procedure 

3. Choose Delete. 

5. If you want to delete all the interface results, flag Delete all to. 

Result 

 

Prerequisites 
You want to display the interface results for an interface format after the data export. 

1. Choose the Export History tabstrip. 

2. In the Interface Format field, enter the name of your interface format and, if required, the 
personnel number(s). 

You access the Delete Interface Results screen. 

4. If you want to select individual lines in the interface result for deletion, flag Manual selection. 

Enter the date up to which you want to delete the interface results. 

6. Choose Delete. 

You have deleted interface results for an interface format. 
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Automatic Conversion of Interface Results 
Use 

The Interface Toolbox runs this data conversion automatically when the old results are imported. 
No further processing by the user is required. 

The Interface Toolbox saves all values for all exported fields as interface results in cluster IF. The 
Interface Toolbox uses this information to determine whether the field has changed since the last 
export. This takes place in change validation. Changes in the data structures (field length or field 
type in the Data Dictionary) may mean that the Interface Toolbox cannot import results when 
exporting or displaying the interface results. 

If a result with an old data structure cannot be imported, the Interface Toolbox temporarily 
converts the data to be imported to the new format. This is done using the data definition in the 
Version Management Cluster IF - Exported Tables (T532K) and Version Management Cluster IF 
- Fields Structure (T532L) tables. 

The data is stored in the database in the old data structure. This avoids the loss of information. 

 
Upgrade to Release 4.5 
There is no version description for the old version for an upgrade from a previous 
release. If data structures are changed in an upgrade, you must carry out one-time 
activities. 

 

For more information, see the documentation for report RPCLSTIF_CONVERSION 
(Conversion of Interface Results in IF Cluster) under Structure Changes for an 
Upgrade. When you call the report, choose Help → Application help. 
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Manual Conversion of Interface Results 
Use 
In addition to automatic conversion of the interface results without permanent conversion on the 
database, the Interface Toolbox also enables you to convert and store interface results manually. 
You use manual conversion to 

Prerequisites 

• Run a test 

• Quickly process old interface results that must be imported frequently (performance) 

You have used the Interface Toolbox to create an interface format and used this format to export 
payroll results or HR master data. The interface results have been saved in cluster IF. One of the 
exported data structures was then changed in the Data Dictionary. 

 
You, or SAP, have changed the type or length of a data element. 

If you want to import data from the old interface format, you must transfer the data to a new 
format. 

You want to run a conversion of the old interface results on the database, and do not want to 
convert the interface results automatically [Page 866] . 

Features 
Manual conversion takes place for a particular interface format, a selected old and new version of 
the data, and a selection of personnel numbers. 

 
For more information, see the documentation for report RPCLSTIF_CONVERSION 
(Conversion of Interface Results in IF Cluster). When you call the report, choose 
Help → Application help. 
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Displaying TemSe Files 
Prerequisites 
You have exported the data. 

Procedure 
1. In the menu, choose File → Display TemSe object. 

The Display TemSe object dialog box appears. 

2. In the TemSe object field, enter the names of your export field with the appropriate prefix. 

 
You want to display the export file with the name TESTFILE, which you have 
selected from the export program selection screen. 

In the File field, enter HR_PINTFS_TESTFILE and choose Display. 

3. Choose Display. 

 
If the Toolbox identifies an error when export file is displayed, it will display the 
export file in an unformatted form [Page 903]. The unformatted display is better for 
identifying errors. 

Result 
The content of the TemSe file is displayed. 
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Managing TemSe Files 
Use 
You want to use the enhanced TemSe management functions: 

Delete TemSe objects • 

• Display TemSe files [Page 868] 

Prerequisites 
You have exported the data and created a TemSe object. 

Procedure 
1. In the menu, choose File → TemSe administration. 

You access the TemSe: Request Screen. 

2. Enter the required selection criteria. 

 
If you do not know the exact object name or creator, leave the fields blank and enter 
an approximate date in the Creation date field. Try to enter a date that is as accurate 
as possible. 

3. Choose Object list. 

You access the TemSe: List of Objects dialog box. 

4. To display the contents of an object, select the required object and choose Contents. 

You access the TemSe: Contents of Object screen. 

5. Different selection options for the selected objects are now displayed. 

Result 
You have accessed the TemSe file administration functions. 
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Downloading an Export File 
Use 
You can download the exported file from the TemSe file to your PC or application server. 

Prerequisites 
The data was successfully exported. 

Procedure 
1. Choose the Export tab index. 

2. In the Export activities group box, choose Download from TemSe. 

3. In the TemSe object and File name fields, make the appropriate entries.  

4. Choose Execute. 

Result 
The exported TemSe file can be found on your PC or application server. 

 

 

870  April 2001 



 SAP AG Payroll United States (PY-US) 

  File Layout 

File Layout 
Definition 
The file layout describes the structure of the export file, in particular the sequence and length of 
the field objects [Page 774]. 

Use 
The File Layout function allows you to convert the export file format, which is known as the SAP 
export file format, into any user-defined file format. An interface format [Page 763] is assigned to 
each file layout. 

SAP Third-
party
system

Interface
format

Change
validation

Generate
export program

Generate
file layout

File
layout

Layout conversion
(modification of 

file format)

Evaluation
programs

Export 
selected data

 

File Layout Types for the Export File 
• SAP standard file layout [Page 904] 

• User-defined file layout 

 
The section on the file layout refers to the user-defined file layout. 

Structure 
Like the interface format, the file layout has hierarchical objects. 

Objects in the File Layout and their Hierarchy 
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File Layout 

Object Hierarchy classification Example 

Block 1 BEGIN_OF_FILE

Structure 2 MASTER_DATA 

Field 3 P0002-NACHN 

 

You can define blocks, structures and fields in the file layout. When you create a file layout, 
use the following sequence: 

1. Blocks 

2. Assigned structures 

Structures 
You can group a certain number of fields together in a structure. A structure corresponds to one 
line in the export file. 

 

3. Fields of the assigned structures 

The blocks, structures and fields can have any name. 

Fields 
• You can assign fields in the interface format to the defined fields belonging to the file layout. 

You can also copy the characteristics and content of these interface format fields. 

• You can also define the fields to suit your requirements. 

Blocks 
Several structures are grouped together in a block. Blocks are not represented in the export file. 
They are only used to control the editing of the structures. 

See also:
Generating the File Layout [Page 898] 

Layout Conversion [Page 900] 
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Processing the File Layout 
Purpose 
You use this process to convert the file format for the export file to a user-defined file format. 

Prerequisites 
The SAP System contains an export file in the SAP standard file layout [Page 903]. 

Process flow 
1. Creation of file layout [Page 896]. 

The defined blocks, structures, and fields form the file layout for the export file. 

2. Generation of file layout [Page 898] 

You must also generate the file layout at the same time as the export program. 

3. Conversion of file layout [Page 900]. 

The Conversion function uses the rules you have defined to process the blocks, 
structures, and fields. The blocks, structures and fields are processed individually and 
processing is triggered by specific processing times in the Interface Toolbox. The 
Interface Toolbox calls these processing times, and processes all blocks that you have 
assigned to this processing time. The Interface Toolbox subsequently processes all 
structures assigned to the block, and all fields assigned to the structure. 

 
If the file layout function does not meet your requirements, you can define form 
routines to process the  file layout and call these form routines using a user exit. 

Result 
The SAP System contains an export file with the user-defined file layout. 
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Editing and Attributes for the File Layout 
Use 
You use these functions to edit the file layout. 

Features 
• Create 

The Create function is valid for all objects (block, structure, field). 

You must assign an existing interface format to the file layout. 

− If the file layout does not yet have any objects (block, structure, field), choose 
Create. 

− If you want to add additional objects to an existing file layout, place the cursor on 
an object of the same type (block, structure, field) and choose Create. 

• Delete 
The Delete function is valid for all objects (block, structure, field). 

− Select the object to be deleted and choose Delete. 

The objects located below this object in the hierarchy will also be deleted. 

If the object to be deleted (structure, field) is used elsewhere in the file 
layout, it will NOT be deleted there. If you have deleted all occurrences of 
the object, the Interface Toolbox will query whether you want to delete the 
object from the object list. If the object remains in the object list, you can use 
the object again at any time by choosing Insert. 

For an alphabetical list of all structures or fields, see Structures or Fields. 

• Move 
The Move function is valid for all objects (block, structure, field). 

− Select the object you wish to move.  
− Place the cursor on the object in front of which you wish to insert the object and 

choose Move. 

• Insert 
The Insert function is allowed for structures and fields. 

You can use structures and fields several times in the file layout. 

• Attributes 
The Attributes function creates the link with the interface format assigned to the file 
layout. 
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User Exits and User-Defined Form Routines 
Use 
You can use the Interface Toolbox to call your customer form routines during the conversion. 
This enables you to implement complicated file layouts. 

If a user-defined form routine is called up, the Interface Toolbox transfers parameters to the user-
defined form routine. The form routine transfers a return value to the Toolbox. 

If you want to implement a user-defined form routine using the user exit, you must specify which 
form routine is used and in which program this form routine can be found. 

Prerequisites 
The user-defined form routine must meet two criteria: 

• It must contain 16 parameters. 

• Parameter 16 is the return value for the Interface Toolbox. 

 

 
If you use a user-defined form routine, you can choose to set the first 15 parameters. 
These parameters are used as input parameters. If a parameter does not have an 
entry, then the Interface Toolbox uses SPACE. 

You can use the following types of input parameters: 

Constant values as input parameters [Page 87 ]6  • 

Interface format values as input parameters [Page 87 ]7  • 

• Interface variables as input parameters [Page 878] 
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Constant Values as Input Parameters 

Constant Values as Input Parameters 
Definition 
You can use a constant value as the input parameter for a user-defined form routine. You must 
enter constant values in quotation marks, for example “CONSTANT_VALUE”.  

The FIRST control parameter is used for constant values. 
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Interface Format Values as Input Parameters 
Definition 
You can use all data defined in the interface format as input parameters for a user-defined form 
routine. 

Use 
This allows you to use data from the export file, in other words, data from internal tables, field 
strings, and infotypes. 

You enter the data as follows: <table name>-<field name> (for example, P0002-NACHN, 
VERSC-ABKRS, WPBP-WERKS). 

You must also use the following control parameters for the interface format: 

• First 
The system uses the value from the first entry. 

• Last 
The system uses the value from the last entry. 

• Current 
The system uses the value from the current work area. 

You can only use the Last and All control parameters for internal tables and infotypes. If you use 
a field string value as the input parameter, you must set the First control parameter. 

 
You should only use the All control parameter if the user exit is called up within a 
field or structure assigned to a block. The object is processed according to the data 
in the repeat factor. 
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Interface Variables as Input Parameters 
Definition 
The interface format includes numerous internal interface variables. An interface variable always 
begins with &VAR-. 

 
The Personnel Number interface variable could be used as an input parameter as 
follows: &VAR-PERNR. 

Use 
You must also use the First control parameter for the interface variables. 

 

Interface variable Data type Length Meaning 

PERNR Numeric 8 Personnel number from BOP 

PERNA Character 8  Name of export program from BPR 

UNAME Character 12  User name for export program from BPR 

DATUM Date 8 Date of export from BPR 

UZEIT Time 6 Time of export from BPR 

Numeric 5 Version number from BPR 

BEGDA Date 8  Start date of first payroll period from BOP 

ENDDA Date 8  End date of first payroll period from BOP 

PERIO Numeric 2  Number of exported payroll period from BOP (in-
period) 

PERBE Date 8  Start date of exported payroll period from BPE (for-
period) 

PEREN Date 8  End date of exported payroll period from BPE (for-
period) 

RCALC Character 1  Retroactive accounting indicator from BPE 

Numeric 6  Number of employees from BPO 

VALUE Character   Value of current structure (dynamic length) 

TABNA Character 10  Current processed table name from BOT 

ENTRY Numeric 6  Number of entries in the current processed table from 
BOT 

NENTR Numeric 6  Line number of the current entry from BOE 

INFBE Date 8  Start date for current processed infotype from BOI 

INFEN Date 8  End date for current infotype from BOI 

VERSN 

NPERN 
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WTYEN Date 8  End date of current processed wage type from BOW 

PERMO Numeric 2 Period modifier from BPE 

PABRJ Numeric 4 Payroll year from BPR 

PABRB Numeric 2 Payroll period BPR 

MFILE Character 40  Output file for conversion (main export file) 

AFIL1 Character 40  Additional conversion file 1 (additional export file 1) 

AFIL2 Character 40  Additional conversion file 2 (additional export file 2) 

AFIL3 Character 40  Additional conversion file 3 (additional export file 3) 

AFIL4 Character 40  Additional conversion file 4 (additional export file 4) 

APPEN Character 1 Conversion option 
Append File 
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Blocks in the File Layout 
Use 
The blocks form the highest level in the file layout hierarchy. They control the processing of the 
structures and fields. The interface format stores the objects (block, structure, field) in a graphical 
overview. 

Features 
The functions for the blocks are shown as symbols in the tree structure. To access the 
appropriate function, select an icon. 

• Processing 

Determines the processing time for a block. 

• Repeat 

Determines how often a block is processed. 

• Output to file 

Name of the file to which the export file is written. 

User exit before [Page 881] • 

• User exit after [Page 882] 

Activities 
To execute this function you must be in the Change File Layout <name> (Block View) screen. 
Choose Block, Structure or Field. The blocks are displayed in the selected sequence. The 
structure and field strings are arranged alphabetically. This is because fields and structures can 
be used several times. 
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User Exit Before (Block) 
Use 
You use the User Exit Before function to call a user-defined form routine. The form routine is 
called before the Interface Toolbox starts to process the block, in other words, before the 
Toolbox processes the structures and fields assigned to a block. 

Each user exit must have 16 parameters. 

Input Values 
Parameters 1 to 15 are available as input values for the user exit. 

If you use tables, you can select the following parameters for the table entries: 

• First 

The first table entry is transferred to the form routine. 

• Last 

The last table entry is transferred to the form routine. 

• Current 

The current table entry (from the table header) is transferred to the form routine. 

Return Value 
In the form routine, the return value is parameter 16. The return value of a form routine 
determines how the block is subsequently processed. The return value can have the following 
values: 

• 0 

The Toolbox does not process the block. 

• 1 

The Toolbox processes the block. 

Activities 
In the User Exit dialog box, enter the data for the program, for the form routine, and for 
parameters 1 to 15. 
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User Exit After (Block) 
Use 
You use the User Exit After function to call a user-defined form routine. The form routine is called 
after the Interface Toolbox has processed all structures and fields belonging to a block. The 
result for the currently processed block is stored in the local interface block buffer [Page 88 ]8 , 
which can be accessed in the user exit. 

Each user exit must have 16 parameters. 

Input Values 
Parameters 1 to 15 are available as input values for the user exit. 

If you use tables, you can select the following parameters for the table entries: 

• First 

The first table entry is transferred to the form routine. 

• Last 

The last table entry is transferred to the form routine. 

• Current 

The current table entry (from the table header) is transferred to the form routine. 

Return Value 
In the form routine, the return value is parameter 16. The return value of a form routine 
determines whether the interface block buffer is written to the export file. The return value can 
have the following values: 

• 0 

The Interface Toolbox does not write the interface block buffer to the file. 

• 1 

The Interface Toolbox writes the interface block buffer to the file. 

Activities 
In the User Exit dialog box, enter the data for the program, for the form routine, and for 
parameters 1 to 15. 
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Structures in the File Layout 
Use 
A structure corresponds to one line in the export file. 

• 

Features 
The functions are represented by icons in the object tree. To access a function, select an icon. 

• Export 

The export parameters tell the Interface Toolbox the conditions for writing data to the 
interface block buffer. 

User exit before [Page 884] 

• User exit after [Page 885] 
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User Exit Before (Structure) 
Use 
You use the User Exit Before function to call a user-defined form routine. The form routine is 
called before the Interface Toolbox starts to process the structure, in other words, before the 
Toolbox processes a particular structure and related fields. 

The current table entry (from the table header) is transferred to the form routine. 

 

Each user exit must have 16 parameters. 

Input Values 
Parameters 1 to 15 are available as input values for the user exit. 

If you use tables, you can select the following parameters for the table entries: 

• First 

The first table entry is transferred to the form routine. 

• Last 

The last table entry is transferred to the form routine. 

• Current 

Return Value 
In the form routine, the return value is parameter 16. The return value of a form routine 
determines how the structure is subsequently processed. The return value can have the following 
values: 

• 0 

The Interface Toolbox does not process the structure. 

• 1 

The Interface Toolbox processes the structure. 

Activities 
In the User Exit dialog box, enter the data for the program, for the form routine, and for 
parameters 1 to 15. 
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User Exit After (Structure) 
Use 
You use the User Exit After function to call a user-defined form routine. The form routine is called 
up after the Interface Toolbox has processed all fields belonging to a structure. The result for the 
currently processed block is stored in the local interface block buffer [Page 88 ]8 , which can be 
accessed in the user exit. 

Each user exit must have 16 parameters. 

Input Values 
Parameters 1 to 15 are available as input values for the user exit. 

If you use tables, you can select the following parameters for the table entries: 

• First 

The first table entry is transferred to the form routine. 

• Last 

The last table entry is transferred to the form routine. 

• Current 

The current table entry (from the table header) is transferred to the form routine. 

Return Value 
In the form routine, the return value is parameter 16. The return value of a form routine 
determines whether the interface block buffer is written to the export file. The return value can 
have the following values: 

• 0 

The Toolbox disregards any changes in the form routine and writes the unchanged 
structure to the interface block buffer. 

• 1 

The Interface Toolbox writes the unchanged structure to the interface block buffer. 

Activities 
In the User Exit dialog box, enter the data for the program, for the form routine, and for 
parameters 1 to 15. 

You can decide whether to transfer the block buffer to the export file in the User Exit After (block). 

 

 

 

April 2001  885 



Payroll United States (PY-US)  SAP AG 

Field Functions in the File Layout 

Field Functions in the File Layout 
Use 
The fields in the file layout are the lowest level in the object hierarchy. Values are stored in these 
fields. 

Features 
The functions are represented by icons in the object tree. To access the appropriate function, 
select an icon. 

• Length 

Defines the length of a field. 

• Content 

Informs the Toolbox how the content of a field is defined. 
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Calling Specific Interface Data 
Use 
The Interface Toolbox enables you to select specific data for use in the user-defined form routine. 

You can use data from the following areas: 

Interface block buffer [Page 888] • 

Interface format data [Page 891] • 

Access to export data in a user-defined file layout [Page 893]  • 

• Structure definitions [Page 894] 

See also: 
Generating the File Layout [Page 898] 

Layout Conversion [Page 900] 
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Interface Block Buffer 
Definition 
Each file layout, a block buffer is assigned to each block. The Interface Toolbox does not write 
the block fields to this block buffer at this point. The block buffer is only transferred to the export 
file when the block has been processed. 

Use 
If you use the User Exit After [Page 88 ]2  function during block processing, you can specify 
whether the interface block buffer is written to the export file. 

The Toolbox defines the interface block buffer and can be used by the user-defined form routine. 
If your program contains the user-defined form routine and uses the RPCIFI26 include in the 
Interface Toolbox, you have unlimited access to the interface block buffer. 

In the RPCIFI26 include, the interface block buffer is defined as an internal table with the name 
BLOCKS_OUTPUT. 

 
     DATA: BLOCKS_OUTPUT TYPE PINTF_OUTPUT OCCURS 10 WITH HEADER LINE. 

     TYPES: BEGIN OF PINTF_OUTPUT, 

             SNAME(25), 

             LENTH(6) TYPE N, 

             VALUE TYPE PINTF_MAX_RECORD, 

           END OF PINTF_OUTPUT. 

     TYPES: PINTF_MAX_RECORD (4096) TYPE C. 

 

The BLOCKS_OUTPUT-SNAME field contains the name of a structure assigned to a block. The 
BLOCKS_OUTPUT-LENTH field contains the length of this structure and the 
BLOCKS_OUTPUT_VALUE field contains the content. 

SNAME LENTH VALUE 

STRUCTURE_01 17 12199601010002X00 

STRUCTURE_02 20 Bond, James 

19961010 STRUCTURE_03 8 

 

The Interface Toolbox writes the value of the BLOCKS_OUTPUT-VALUE field in the length 
specified in the BLOCKS_OUTPUT-LENTH field to the output file. 

If you use a user-defined form routine that uses the User Exit After function for blocks, you can 
maintain the interface block buffer by deleting, changing, moving, or inserting entries. 

 
INCLUDE RPCIFI26. 
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FORM MAINTAIN_BLOCK USING PAR_01 

                             PAR_02 

                             PAR_03 

                             PAR_04 

                             PAR_05 

       BLOCKS_OUTPUT-VALUE(2) = `XS`. 

       CLEAR BLOCKS_OUTPUT-VALUE. 

       BLOCKS_OUTPUT-LENTH = 10. 

                             PAR_06 

                             PAR_07 

                             PAR_08 

                             PAR_09 

                             PAR_10 

                             PAR_11 

                             PAR_12 

                             PAR_13 

                             PAR_14 

                             PAR_15     “Input parameters 1 - 15 

                         RETURN_VALUE. “return parameter 

   RETURN_VALUE = `1`. 

LOOP AT BLOCKS_OUTPUT. 

    IF BLOCKS_OUTPUT-SNAME = `STRUCTURE_A` AND 

       BLOCKS_OUTPUT-VALUE = `DS19960125`. 

       MODIFY BLOCKS_OUTPUT. 

   ENDIF. 

  ENDLOOP. 

ENDFORM. 

 

 
If you change the BLOCKS_OUTPUT interface block buffer and the value 1 is returned 
to the Toolbox, the Interface Toolbox exports the exact content of the interface block 
buffer. It is not possible to recreate the previous content of the interface block buffer. 

You can use the interface block buffer for each customer form routine that uses the 
User Exit After function for blocks. 

Example of an Interface Block Buffer 
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Before SNAME LENTH VALUE 

 STRUCTURE_A 12 XS0123456789 

 

After SNAME LENTH VALUE 

 STRUCTURE_A 10 DS 19960125 
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Interface Format Data 
Use 
If you use the During Processing of Employee Data processing time to process blocks, 
structures, and fields in your user-defined form routine, the data can be used as defined in the 
interface format. The Interface Toolbox generates coding that represents the internal tables, 
infotypes, and field strings from the interface format. 

The coding for the interface format data is defined in the first include used to generate the 
conversion program for the file layout. If you use this include in the program containing the user-
defined form routine, the interface format data can be called up in the form <table name>-<field 
name>. You can also use the standard table operations used in the Advanced Business 
Application Programming (ABAP) language, for example, LOOP, READ TABLE, and so on. 

 
For example, if you have specified that the NACHN, VORNA and GESCH fields from infotype 
P0002 (Personal Data) are used, the Interface Toolbox generates the following coding: 

  
     DATA: BEGIN OF P0002 OCCURS 5, 

             NACHN(000025) TYPE C, 

             VORNA(000025) TYPE C, 

             GESCH(000001) TYPE C, 

     END OF P0002. 

 

You can now use the names of the fields defined above (NACHN, P0002-VORNA, and P0002-
GESCH): 

 
REPORT ZUSER_EXITS. 

INCLUDE ZPCIFT01. 

FORM EXAMPLE_P0002 USING PAR_01 

                             PAR_02 

                             PAR_03 

                             PAR_04 

                             PAR_05 

                             PAR_06 

                             PAR_07 

                             PAR_08 

                             PAR_09 

                             PAR_10 
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                             PAR_11 

                             PAR_12 

                             PAR_13 

                             PAR_14 

                             PAR_15 

                         RETURN_VALUE. 

READ TABLE P0002 INDEX 1. 

CONCATENATE P0002-NACHN 

               P0002-VORNA 

            INTO RETURN_VALUE 

      SEPARATED BY `,`. 

ENDFORM. 

 

Legend 
If the first line of infotype P0002 (Personal Data) contains the first name (P0002-VORNA) ’James’ 
and the surname (P0002-NACHN) ’Bond’, then the return value is the character string ‘Bond, 
James’. 

If the system processes a new payroll period, the Interface Toolbox enters the corresponding 
payroll period values in the interface format data. 

 
You can also transfer infotype P0002 (Personal Data) directly in parameters 1 to 15, 
instead of following the above example. 
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Access to Export Data in a User-Defined File Layout 
Use 
You can set up user exits in different areas (for example, structure, block) within the file layout. If 
the change validation functions [Page 79 ]8  provided do not meet your requirements, you can 
define customer user exits. In your user exits, you use the function modules included in the 
standard system to define your change validation function. 

Features 
You can use the function module within the file layout to enter data for the structures (NEW_ and 
OLD_ structures) that already exist in the export program for the change validation user exit. SAP 
recommends that you use this procedure in the following situations: 

• You want to access the values for the exported files during change validation, although the 
system has not identified any changes. 

In the standard system, the change validation function uses the last exported payroll period 
for comparison. You also want to compare the values for a payroll period with the values for 
a different period. 

• 

• If you have flagged the Layout conversion directly after export attribute [Page 79 ]4  in the 
interface format, the tables and field strings (NEW_ and OLD_ structures) still contain values. 
You can still use the function module to retrieve another comparison period for change 
validation or to run the conversion of the file layout. 

The standard system contains the following function modules: 

1. HR_INTF_INITIALIZE 

This function module must be called once before all other function module. You must 
enter the current program name for the Interface Toolbox. 

3. HR_INTF_IMPORT_O 

This function module enters the current result in the NEW tables. 

 

2. HR_INTF_IMPORT_L 

This function module enters data in the OLD tables in the same way as the Import 
function (IMPRT with specification L). 

This function module enters data in the OLD tables in the same way as the Import 
function (IMPRT with specification O). 

4. HR_INTF_IMPORT_CURRENT 
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Structure Definition 
Definition 
The Interface Toolbox generates a corresponding field string in the second include for each 
defined structure. This then generates the conversion program for the file layout. You can call 
each field assigned to a structure, using <structure name>-<field name>. 

 

 

You can use the generated structure information for the 

Use 
You have defined the STRUCTURE 01 structure. If you have assigned the NAME (constant 
length: 24) and GENDER (Constant length: 6) fields to the structure, the system generates the 
following coding: 

     DATA: BEGIN OF STRUCTURE_01, 

             NAME(000024) TYPE C, 

             GENDER(000006) TYPE C, 

     END OF STRUCTURE_01. 

User Exit After [Page 885] structure 
function in the user-defined form routine. If the field content is redefined and the value 1 is 
returned, the Interface Toolbox will write the structure to the interface block buffer [Page 888] 
without updating &VAR-VALUE (&VAR-VALUE contains the content of the current structure). 

REPORT ZUSER_EXITS. 

                             PAR_02 

                             PAR_05 

                             PAR_08 

                             PAR_11 

 

INCLUDE ZPCIFT01. 

FORM EXAMPLE_STRUCTURE USING PAR_01 

                             PAR_03 

                             PAR_04 

                             PAR_06 

                             PAR_07 

                             PAR_09 

                             PAR_10 

                             PAR_12 

                             PAR_13 
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                             PAR_14 

   RETURN_VALUE = `1`. 

READ TABLE P0002 INDEX 1. 

CONCATENATE P0002-NACHN 

                             PAR_15     “Input parameters 1 - 15 

                             RETURN_VALUE.    “Return parameter 

               P0002-VORNA 

               INTO STRUCTURE_01-NAME 

      SEPARATED BY `,`. 

   IF P0002-GESCH = `1`. 

      STRUCTURE_01-GENDER = `MALE`. 

   ELSE. 

      STRUCTURE_01-GENDER = `FEMALE`. 

   ENDIF. 

ENDFORM. 

 

Legend 
If James is the value for P0002-VORNA, Bond is the value for P0002-NACHN and 1 is the value 
for P0002-GESCH, then the following entry is made in the BLOCKS_OUTPUT interface format 
block buffer: 

 

SNAME LENTH VALUE 

STRUCTURE_01 30 Bond, James             MALE
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Creating a File Layout 
Prerequisites 
If you want to access the fields in the interface format [Page 763] when creating the file layout, 
you must use the following functions for the file layout objects: 

• The Processing and Repeat functions for the Block object 

• The Export function for the Structure object 

12. Choose Subordinate structure. 

• The Length and Content of the field for the Field object 

Procedure 
1. Choose the Configuration tab index. 

2. In the Object to be processed field, enter the name of the new file layout. 

3. Choose Create. 

You access the Create New File Layout dialog box. 

4. In the Interface Format field, enter the name of the interface format whose export file you 
want to convert. Also enter a short text for the new file layout. 

5.  Choose Continue. 

The Change File Layout <Name> (Block View) screen appears. 

6. Choose Create. 

You access the Create Block dialog box. 

7. In the Block Name field, enter the name of the block and check the default value. 

8. Choose Complete. 

The object tree for the block is displayed. 

9. Select the appropriate function, for example, Processing or Repeat. 

You access the appropriate dialog box. 

10. Make the necessary selection in the dialog box. 

11. Place the cursor on the block name and choose Structure. 

You access the Create dialog box. 

You access the Create Structure dialog box. 

13. In the Structure Name field, enter the name of the structure. 

14. Click the plus sign to the left of the structure name. 

The tree structure for the structure is displayed. 

15. Choose the appropriate function, for example, Export. 

You access the appropriate dialog box. 
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16. Make the necessary selection in the dialog box. 

17. Place the cursor on the structure name and choose Fields. 

You access the Create Field dialog box. 

18. In the Field Name field, enter the name of the field. 

19. Click the plus sign to the left of the field name. 

The tree structure for the field is displayed. 

20. Select the appropriate function, for example, Length or Contents. 

You access the appropriate dialog box. 

21. Make the necessary selection in the dialog box. 

22. Save your entries. 

Result: 
You have created a customer file layout. 
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Generating the File Layout 
Use 
After creating a new file layout or modifying an existing file layout, you must generate the file 
layout. 

If you make changes in the following areas, you must generate the file layout again: 

• Interface format [Page 76 ]3  

Import macro for cluster data • 

• Data definition include [Page 795]  

Change validation [Page 798] • 

• Wage type processing [Page 828] 

Prerequisite 
You must enter the following names in the Interface Toolbox before you generate the file layout. 

• Name of the file layout program and the include 

You assign the names in the file layout using the File Layout Function program. 

• Name of the data definition include 

 
For more information on file layouts, see File Layout [Page 871]. 

Activities 
Generate the file layout [Page 899] 

See also: 
Layout Conversion [Page 900] 
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Generating the File Layout 
Prerequisites 
You have created a file layout. 

Procedure 
6. Choose the Configuration tab index. 

7. In the File Layout field, enter the name of the file layout. 

8. Choose Generate. 

Result 
The file layout has been generated. 
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Conversion with the File Layout 
Use 
Layout conversion converts the export file to another format that has been defined in the file 
layout. You use this function to run the conversion program. 

Features 
The following parameters can be used: 

• Input file 

The name of the file to be converted, in other words the export file created by the export 
program. 

• Output file 

The name of the output export file. The converted export file is written to this file. 

• Additional export files 1 to 4 

The file names used if particular blocks are to be written to an additional file. 

• Append on export files 

The Toolbox adds the specified file or files to the current conversion output. 

If you do not activate this parameter and the specified file(s) already exist, the system will 
overwrite the existing file(s). 

• Log 

Detailed information on the conversion procedure. 

• Update 

If the parameter is flagged, the system writes the output file to the TemSe file. 

If the parameter is not flagged, the system performs a test run. 

Prerequisites 
Before you can convert the layout, the Interface Toolbox must have successfully exported the 
data. 

 
For more information on exports, see Export Program [Page 859]. 

You must also generate the program for the file layout according to the definitions set for blocks, 
structures, and fields. 

 
For more information, see Generating the File Layout [Page 898]. 

Activities 
Convert the file layout [Page 902] 
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Converting a File Layout 
Prerequisites 
1. The Interface Toolbox has successfully exported the data. 

2. You have generated the conversion program for the file layout. 

Procedure 
1. Choose the Export tab page. 

2. In the Export activities group box, select Conversion with file layout and enter the name of 
the file layout. 

3. Choose Execute. 

The File Layout <name> dialog box is displayed. 

4. In the Input and output files group box, enter the names of the files. 

5. In the Options group box, enter the name of the required function. 

• Append on export files 

• Log 

• Update 

6. Choose Execute. 

Result 
You have used the file layout to convert the file specified under Import-Export File. The converted 
export file is written to the TemSe file (Display TemSe File [Page 868]). 
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File Format of Export File (SAP Standard) 
If an error occurs when the TemSe file is displayed normally [Page 868], the Toolbox displays the 
export file in an unformatted view. 

 
This detailed information on the file format of the export file is required to trace and 
remove errors, or if you have created a customer program that is based on the SAP 
standard file layout. 

Definition 
The export file contains the data that generates the respective export program. The payroll 
results for each personnel number are grouped together and stored in this file. 

The export file is structured so that it has a compact data format and can also be easily read 
automatically. The compact data format means that majority of data is displayed implicitly, not 
explicitly. It also ensures that information is saved with minimum redundancy. 
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Structure of an Export File 
Definition 
The export file consists of a sequence of bytes that can also be considered to be a sequence of 
commands in machine language. These commands consist of: 

• Operator codes 

• Operator parameters (operands) 

Structure 
Operator Code, Operator Parameter, and Operand 
The first two bytes in a command contain the operator code. Several bytes follow the operator 
code and these form the operator parameter. The operator parameters represent the 
operands. However, there are also operators without operands. 

 
The BOT operator (Begin operator for table) has two operands. The first operand is 
10 bytes long, and the second is 6 bytes long. The first operand contains the table 
name, and the second operand contains the line number of the table entry. 

Structure 
An export file begins with a start sequence, the preamble. The preamble is followed by 
personnel numbers. The postamble constitutes the end sequence. 

Preamble 

The preamble shows the start of the export file. The operands in the preamble contain 
information on the export program (for example, creation date). The export file always starts with 
a preamble. 

Personnel number 
Each personnel number begins with a BOP operator (begin operator for personnel number). The 
payroll period that the BPE operator (begin operator period) introduces follows. Within the payroll 
periods there is the actual export data, which is grouped together in blocks. The EPE operator 
(end operator personnel number) forms the end of the payroll period. The EOP operator (end 
operator for personnel number) is at the end of the personnel number. 

Postamble 

The postamble is at the end of the export file. The postamble begins with the BPO operator 
(begin operator for postamble), followed by an operand. The EPO (end operator for postamble) 
operator forms the end of the postamble. 
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Preamble

Payroll
period block n Data kData 1

Postamble

Personnel number block l

Personnel number block 1

Payroll
period block 1 Data mData 1

Secondary information

 

 
For more information on operators, see Operators for Export/Import Files [Page 907]. 

See also: 
Displaying Export Files Using Operator Blocks [Page 906] 
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Display Export Files Using Operator Blocks 
Definition 
Each export file can be displayed as a sequence of operator blocks. 

Structure 
Each block is introduced by a begin operator and closed by the accompanying end operator. 
Between the begin and end operators there is a data section. This data section can also consist 
of a sequence of operator blocks. 

End 
operator

Begin
operator Operands Data

 
The type of operator gives the operator block the following information: 

• Number of operands 

• Meaning of the operands 

• Structure of the data section 

• The structure of the data section is determined by the secondary file. 

An export file can consist of the following operator blocks: 

• Preamble block 

• Personnel number block 

• Payroll period block 

• Postamble block 

See also: 
Creating the Export File [Page 90 ]7   
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Operators for the Export File 

The structure of the export file is determined by operators and operands. A combination of 
individual operators define the results to be exported. The export file consists of a sequence of 
operator blocks. Each block begins with a begin operator and ends with an end operator. The 
type of operator determines how the data between the begin operator and the end operator is 
interpreted. 

Structure 
The operator is uniquely defined by the operator code. The operator code is 12 bytes long and 
contains a hexadecimal number. 

Definition 

The following operator codes are available: 

Begin of preamble BPR - operator code 01 [Page 909] • 

End of preamble EPR - operator code 02 [Page 909] • 

Begin of secondary information BSC - operator code 17 [Page 910] • 

End of secondary information BSC - operator code 18 [Page 910] • 

Begin of personnel number BOP - operator code 05 [Page 91 ]1  • 

End of personnel number EOP - operator code 06 [Page 91 ]1  • 

Begin of payroll period BPE - operator code 07 [Page 912] • 

End of payroll period EPE - operator code 08 [Page 91 ]2  • 

Begin of table BOT - operator code 09 [Page 913] • 

End of table EOT - operator code 0A [Page 91 ]3  • 

Begin of table entry BOE - operator code 0B [Page 914] • 

End of table entry EOE - operator code 0C [Page 91 ]4  • 

Begin of field string BOF - operator 0D [Page 915] • 

End of field string EOF - operator code 0E [Page 915] • 

• Begin of infotype BOI - operator code 0F [Page 916] 

• End of infotype EOI - operator code 10 [Page 916] 

Begin of wage type BOW - operator code 11 [Page 91 ]7  • 

End of wage type EOW - operator code 12 [Page 917] • 

Begin of postamble BPO - operator code 03 [Page 918] • 

• End of postamble EPO - operator code 04 [Page 918] 

See also: 
Structure of the Secondary File [Page 920] 
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Begin Preamble BPR (01) / End Preamble (02) 
Definition 
Each export file starts with the preamble block. This block starts with the BPR operator, and ends 
with the EPR operator. 

199901011501471501471999011319990113TESTUSER001TESTUSER001ZPCIFRX0ZPCIFRX0BPR EPR00020101

 
The begin preamble operator introduces the export file. This operator must be at the beginning 
of the export file. 

 

No. Operand Length Type Example 

1 Name of export program 40 Character ZPCIFRX0 

2 User name 12 Character TESTUSER0001

3 Export date 8 Date 19991013 

4 Time of export 6 Time 150147 

5 Period modifier 2 Numeric 01 

6 Payroll year 4 Numeric 1999 

7 Payroll period 
 

2 Numeric 01 

8 Version number 5 Numeric 00002 

 

The end preamble operator closes the begin preamble operator. This operator has no 
operands. 
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Begin of Secondary Information BSC (17)/End of 
Secondary Information ESC (18) 
Definition 
Secondary information begins with the BSC operator and ends with the ESC operator. 

Between the BSC operator and the ESC operator, there is a number of table entries and the 
actual table containing the secondary information. 

Number ofNumber of
table entries  (n)table entries  (n)BSC ESC

Table

Secondary 
information
(n lines)

 
The begin secondary information operator indicates that secondary information follows. 

 

No. Operand Length Type Example 

1 Number of table entries 6 Numeric 000016 

2 Table of secondary information from ABAP Dictionary PPU12_SEC  

 

The end secondary information operator, which has no operands, closes the begin secondary 
information operator. 
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Begin Personnel Number BOP (05) / End Personnel 
Number EOP (06) 
Definition 
In the export file, personnel number blocks follow the preamble block. These personnel number 
blocks start with the BOP operator and end with the EOP operator. 

0303199903311999033119990101199901010090010000900100BOP EOP

 
The begin personnel number operator indicates the beginning of a personnel number. 

 

No. Operand Length Type Example 

1 Personnel number 8 Numeric 00900100

2 Start date of first payroll period 8 Date 19990101

3 End date of last payroll period 8 Date 19990331

4 Number of payroll periods 2 Numeric 03 

 

The end personnel number operator closes the begin personnel number operator. 
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Begin Payroll Period BPE (07) / End Payroll Period EPE 
(08) 
Definition 
The individual payroll periods in the payroll run are listed within the personnel number blocks. 
These block begin with the BPE operator and end with the EPE operator. 

0019990131199901311999010119990101BPE EPE

 
The begin payroll period operator indicates the beginning of a payroll period. 

 

No. Operand Length Type Example 

1 Start date of payroll period 8 Date 19990101 

2 End date of payroll period 8 Date 19990131 

3 Retroactive accounting indicator 
0=no RA period,1=RA period 

1 Character 1 

4 Payroll type 1 Character A: bonus accounting 

5 Payroll ID 1 Character 1 to make distinction between 
several special payroll runs 

6 Payroll area 2 Character A1 

7 Period modifier 2 Numeric 01 

8 For-period 
 

6 Character 199901 

9 Sequence number for cluster IF 9 Numeric 00001 

10 Sequence number, payroll result 5 Numeric 00001 

 

The end payroll period operator closes the begin payroll period operator. This operator has no 
operands. It indicates that a payroll period has been processed. 
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Begin Table BOT (09) / End Table EOT (0A) 
Definition 
Table data begins with the BOT operator and ends with the EOT operator. 

For each table entry there is an operator pair BOE and EOE between the BOT operator and the 
EOT operator. The secondary file defines the data between the BOE and EOE. 

The second operand of the BOT operator specifies the number of table entries. 

WPBPWPBPBOT EOT000001000001 BOE 000001000001 EOE

 
The begin table operator indicates that table data follows. 

 

No. Operand Length Type Example

1 Name of table 10 Character RT 

2 Number of table entries 6 Numeric 000016 

 

The end table operator closes the begin table operator. This operator has no operands. It 
indicates that table data has been processed. 
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Begin of Table Entry BOE (0B) / End of Table Entry EOE 
(0C) 
Definition 
For each table entry there is an operator pair BOE and EOE between the BOT operator and the 
EOT operator. The secondary file defines the data between the BOE and EOE. 

The second operand of the BOT operator specifies the number of table entries. 

WPBPWPBPBOT EOT000001000001 BOE 000001000001 EOE

 
The begin table entry operator indicates that table entry data follows. 

 

No. Operand Length Type Example

1 Line number for entry 6 Numeric 000001 

 

The end table entry operator, which has no operands, closes the begin table entry operator. It 
shows that the table entry data has been processed. 
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Begin of Field String BOF (0D) / End of Field String EOF 
(0E) 
Definition 

VERSCVERSCBOF EOF

 
The begin of field string operator indicates that field string data follows. 

 

No. Operand Length Type Example

1 Name of field string 10 Character VERSC 

 

The end field string operator closes the begin field string operator. This operator has no 
operands. It indicates that the field string data has been processed. 
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Begin of Infotype BOI (0F) / End of Infotype EOI (10) 
Definition 

1999010119990101P0002P0002BOI EOI1999013119990131

 
The begin of infotype operator indicates that infotype data follows. 

 

No. Operand Length Type Example 

1 Name of infotype 10 Character P0006 

2 Start date for infotype 8 Date 19990101

3 End date for infotype 8 Date 19990131

 

The end of infotype operator closes the begin infotype operator. This operator has no 
operands. It indicates that infotype data has been processed. 
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Begin Wage Type BOW (11) / End Wage Type EOW (12) 
Definition 

RTRTBOW EOW1999013119990131

 
The begin wage type operator indicates that wage types follow. 

 

No. Operand Length Type Example 

1 Table name for wage type 10 Character RT 

2 End date of wage type 8 Date 19990131

 

The end wage type operator closes the begin wage type operator. This operator has no 
operands. It indicates that wage type data has been processed. 
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Begin Postamble BPO (03) / End Postamble EPO (04) 
Definition 
Each export file ends with the postamble block. This block starts with the BPO operator, and 
ends with the EPO operator. 

000003000003BPO EPO

 
The begin postamble operator is almost at the end of the export file. Only the number of 
employees whose data was exported and the end post operator come after this operator. 

 

No. Operand Length Type Example

1 Number of employees 6 Numeric 000019 

 

The end postamble operator closes the begin postamble operator. This operator has no 
operands. This is the end of the export file. 
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Display of Export File - Formatted 
 

The following structure is formatted so it is easier to understand. 

 
BPR (01)   ZPCIFX0 TEST_USER_01 19990113 105402 01 1999 01 00002 

EPR (02) 

  BOP (05)   00900100 19990101 19990131 01 

    BPE (07)   19990101 1999 131 1 

      BOI (0F)   P0002     19990101 19990131 

        NACHN           Bond 

        VORNA           James 

        GESCH           1 

      EOI (10) 

      BOT (09)   BT        000001 

        BOE (0B)   000001 

          BANKL          67290010 

          BANKN          123456789 

        BETRG          +000500000 

        EOE (0C) 

      EOT (0A) 

      BOW (11)   RT        19990131 

        LGART          /101 

        BETRG          +000000000500000 

      EOW (12) 

    EPE (08) 

  EOP (06) 

BPO (03)   000001 

EPO (04) 
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Secondary Files 
Definition 
The secondary file contains information on each table object (tables, field strings, and infotypes) 
that you have assigned to the interface format. This is information that can be displayed when 
you edit the interface format by choosing the Information on table object function. The secondary 
file ensures that the export file can also be processed outside of the SAP System. 

Structure 
The secondary file, like the export file, can be found in the TemSe file. Each line in the secondary 
file contains specific information on a table object. 

Line Format of Secondary File 

No. Field Length Type Example 

1 Name of table 10 Character RT 

2 Field name 10 Character LGART 

3 Data type 1 Character D 

4 Field length 6 Numeric 000008 

5 
 

Number of decimal places 6 
 

Numeric 000000 
 

6 Conversion indicator 1 Character For internal use only

7 Conversion type 2 Numeric For internal use only

8 Conversion modifier 6 Numeric For internal use only

 

Data Types 

Data type Meaning Example 

C Character ABCD01 

N Numerical value 038472 

D Date in the form YYYYMMDD 19990101 

T Time in the form HHMMSS 105453 

V Floating point number (with +/- sign) +0003450 

 • 1 byte is the sign (+ or -) -003746543

 • The last bytes are the decimal places (according to the value 
in the Number of decimal places field.) 
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The following example shows a characteristic section of a secondary file. The blank 
characters are represented by periods. 
RT........LGART.....C000004000000000000000 

RT........ANZHL.....V000016000002100000000 

RT........BETRG.....V000016000002100000000 

P0002.....NACHN.....C000025000000000000000 

P0002.....VORNA.....C000025000000000000000 

See also: 
Example: Structure of the Secondary File (Formatted) [Page 922] 
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Secondary Files 

Structure of the Secondary File (Formatted) 
 

Field Data type Length

P0002-NACHN C 20 

P0002-VORNA C 20 

P0002-GESCH C 1 

BT-BANKL N 8 

BT-BANKN N 9 

BT-BETRG V 10 

RT-LGART C 4 

RT-BETRG V 16 
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Generation of Secondary File 
Use 
The secondary file ensures that the export file can also be processed outside of the SAP System. 
The secondary file contains all information on the structure of the tables to be used, the field 
strings, and infotypes. 

 
If you transfer the export file to an third-party payroll system that uses the SAP 
standard file layout in the Interface Toolbox, you must regenerate the secondary file 
after every change in the interface format. 

If you use the import program, you must regenerate the secondary file. 

If the third-party payroll system uses neither the unconverted export file nor the import 
program from the Toolbox, then it is not necessary to regenerate the secondary file. 

Activities 
Generate the secondary file [Page 924] 
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Generating the Secondary File 
Prerequisites 
You have created the export file for the personnel numbers selected from a payroll area. 

Procedure 
9. In the menu, choose File → Generate secondary file. 

You access the Generate Secondary File dialog box. 

10. In the Interface Format and Secondary File fields, enter the names of your interface format 
and secondary file. 

 
If you leave the Secondary File field blank, the secondary file will only be saved in 
the Interface Format (IF) cluster. 

If you enter a name for the secondary file in the Secondary File field (using the 
naming conventions), a secondary file will also be saved in the TemSe file 
(Displaying the TemSe File [Page 868]). 

11. Choose Display. 

12. Choose Execute. 

13. Choose Generate. 

Result 
You have generated the secondary file that will be used to further process data from the SAP 
System. 

 
You can then save the file to a PC by downloading it from the TemSe file. 
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Import Wage Types  
Use 
You use the Import wage types function to transfer wage types from a third-party system to the 
payroll results of the SAP System. 

 
For more information, see the Implementation Guide (IMG) for Cross Application 
Components under Predefined ALE Business Processes → Human Resources → 
HR External Systems → Connection With an External Payroll System → Import 
Payroll Results or in the SAP Library under CA Cross Application Components → 
Business Framework Architecture (CA-BFA) → Library of ALE Business Processes 
→ Human Resources → Human Resources - External Applications → Process Flow: 
Import Payroll Results from a Third-Party System [Ext.]. 

Features 
The import transfers wage types for payroll from the third-party system to the R/3 System. 

SAP Third-Party
System

Interface
format

Change
validation

File
layout

Generate
export program

Generate
file layout

Layout conversion
(Modification of 

data format)

Export 
selected data

Payroll
results 

(gross/net)

RPCALC
x 0 Import

(wage type)

T558 B/C/D/E

Payroll

schema
XINF

 

Activities 
Run the Import [Page 926]   
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Starting the Import 
Prerequisites 
You have successfully run payroll in a third-party system. 

Procedure 
1. In the menu, choose Import wage types → Create IDocs. 

You access the IDoc Inbound Processing Via File screen. 

2. In the Complete file name field, enter the name of the input file. 

3. Choose Execute. 

The system message contains the number of created IDocs. 

4. In the menu, choose File → Import wage types → Create IDocs. 

You access the Inbound Processing of IDocs Ready for Transfer screen. 

5. Enter MANAGEREXTPAYROLL_INSERTOUT as the Message type and, if required, enter the 
Creation date and the Creation time. 

6. Choose Execute. 

Result 
The wage types created in the third-party system are available for further processing in the 
interface tables of the SAP System. 

You can then start payroll in the SAP System and perform the subsequent payroll activities: 

• Create a remuneration statement 

• Run posting to Accounting 
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Outsourcing 
Starting the Outsourcing Process [Page 928] 

Outsourcing Gross Payroll and Master Data [Page 937] 

Outsourcing Time Wage Types [Page 980] 

Troubleshooting [Page 987] 
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Starting the Outsourcing Process 
Before you begin using the Outsourcing functionality, you need to set up your system to be able 
to send and receive data. This requires selecting which type of payroll outsourcing best serves 
you company's needs, changing that option and setting up a logical system, a partner definition, 
and a port or ports. 

A flowchart of the high level process follows. 

Outsourcing
Setup

Check / change
OTVSN feature

Set up Logical
System

Set up
Outsourcing

Ports

Use
Function
Module?

Set up
Function Module

Set up Partner
Definitions

No

 Yes

 
See also: 
 

Set the Outsourcing Type [Page 929] 

Setup Process for Outsourcing [Page 931] 
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Set the Outsourcing Type 
Before you begin, you must determine which outsourcing option is most appropriate for your 
company. After deciding, you might be required to change the preset option. The default option is 
for Combined Payroll. If your company does not choose to use this option, then you must change 
the OTSVN value. 

For more information, see Changing the OTVSN Option [Page 930]. 
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Changing the OTVSN Option 
Use 
When you need to change the type of Payroll Outsourcing that your company wants to perform, 
use this procedure to do so. 

Prerequisites 
Make sure that you have not run any other type of Payroll Outsourcing before you make this 
change. 

Procedure 
1. In the command box, type pe03 and press Enter. 

The Features Initial Screen screen appears. 

2. In the Feature field, type OTVSN, then choose Change. 

3. Select the only field in the tree structure, CM, then select Edit → Change nodes. 

 
If this field contains anything other than CM, it indicates that someone has already 
changed this information. 

4. Type the appropriate code for the version of Outsourcing that you want to use, then choose 
Transfer. (MD for Master Data, GP for Gross Payroll) 

5. Select Feature → Activate. 

The Feature was generated message appears in the status bar on your screen. 

6. Select Goto → Back. 

7. Select Feature → Activate. 

The Generate Features screen appears. 

8. Select Program → Execute. 

The Generate Features log appears. 

9. Select Goto → Back until you return to the main menu. 

Result 
You have successfully completed changing the OTVSN option. When you have set up your 
system, you are ready to begin using Payroll Outsourcing. 
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Setup Process for Outsourcing 
Purpose 
In order to run Payroll Outsourcing successfully, you must make sure that you have properly 
configured the server. 

For more information regarding IDocs, see IDoc Interface / Electronic Data Interchange [Ext.]. 

Prerequisites 
SAP recommends that you perform the procedures in the order listed in the process flow. 

Process Flow 
1. Set up a logical system. 

2. Set up the outsourcing ports and the function module (optional). 

3. Define the partner definition. 

Result 
You are ready to begin the Payroll Outsourcing tasks. 

See also: 
 

Setting Up Logical Systems [Page 932] 

Setting Up Outsourcing Ports / Function Modules [Page 933] 

Setting Up the Partner Definition [Page 935] 
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Setting Up Logical Systems 
Prerequisites 
Set up a logical system before you define your ports and partners. For a smoother workflow, 
perform each of these tasks in the order they appear in this text. Doing so makes less work than 
performing these tasks in another sequence. 

 
The IMG path varies by release. 

Procedure 
1. Choose Tools → Accelerated SAP → Customizing → Edit project. 

The Customizing Execute Project screen appears. 

2. Choose Goto → SAP Reference IMG. 

The Display IMG screen appears. 

3. Select and expand the Basis Components file. 

4. Select and expand the Distribution (ALE) file. 

5. Select and expand the Sending and Receiving Systems file. 

6. Select and expand the Logical Systems file. 

7. Select Define Logical System. 

The Change View Logical Systems screen appears. 

8. Choose Edit → New Entries. 

9. In the Log System field, type FILEPORT. 

10. In the Description field, type the appropriate definition for this system, then choose Save. 

Result 
You have successfully set up your logical system. Continue with Setting Up Outsourcing Ports / 
Function Modules [Page 933]. 
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Setting Up Outsourcing Ports / Function Modules 
Prerequisites 
Make sure that you have configured the port area on the server so that the third-party payroll 
service provider is able to access the file easily. Also ensure that both the user and the 
outsourcer know the name of the port before they need to create and export the payroll file or 
import the payroll results file. 

Make sure that you create both an Outbound file and an Inbound file port on the server, if you are 
both exporting and importing information. These directories must be separate. 

You can also assign a function module for an Inbound or Outbound file at the same time you are 
setting up the ports. Depending on your business requirements, you can use an existing function 
module or you can create your own. 

 
This procedure assumes that you are using an existing function module. 

If you are starting this process from the SAP Reference IMG screen, begin with step 3. 

 
The IMG path varies by release. 

Procedure 
Setting up the Outbound file port 
11. Choose Tools → Accelerated SAP → Customizing → Edit project. 

The Customizing Edit Project screen appears. 

12. Choose Goto → SAP Reference IMG. 

The Display IMG screen appears. 

13. Select and expand the Basis Components file. 

14. Select and expand the Distribution (ALE) file. 

15. Select and expand the Sending and Receiving systems file. 

16. Select and expand the Systems in Network file. 

17. Select and expand the Asynchronous processing file. 

18. Select and expand the Assigning ports file. 

19. Select Define port. 

The Ports in IDoc Processing screen appears. 

20. Expand the File file. 

21. Select the appropriate HROT_xx file. 

April 2001  933 



Payroll United States (PY-US)  SAP AG 

Setting Up Outsourcing Ports / Function Modules 

 
The detailed information appears on the right hand side of the screen. 

22. Select the Outbound File tab, if required. 

23. Select the Physical directory field, then type the path for the server and directory on which 
the export file will be stored for the Outsourcer in that field. 

24. In the Outbound File field, type the name for the export file. 

 
If you want to set up a function module, continue with step 14. 
If you do not want to set up a function module, continue with step 15. 
If you do not need to set up an inbound file port, choose Save. 

25. In the Function Module field, select the function module for the export file, then choose Save. 

Setting up the Inbound file port 
26. Select the HROTIN file. 

The detailed information appears on the right hand side of the screen. 

15. Select the Inbound File tab. 

16. Select the Physical directory field, then type the path for the server and directory on which 
the import file will be stored from the third-party payroll service provider. 

17. In the Inbound File field, type the name for the import file. 

 
If you want to set up a function module, continue with step 18. 
If you do not want to set up a function module, choose Save. 

18. In the Function Module field, select the function module for the import file, then choose Save. 

Result 
You have successfully set up your file ports. Continue with Setting Up the Partner Definition 
[Page 935]. 
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Setting Up the Partner Definition 
Prerequisites 
If you have not set up the logical system or the ports, you will need to come back to this screen to 
add the information. It is a good idea to set up the logical system and define the ports before you 
set up the partner definition. 

Procedure 
Creating a partner 
1. Select Tools → Business Communication → IDoc-Basis → IDoc → Partner Profile. 

The Partner profiles screen appears. 

2. Select and expand the Partner type LS folder. 

3. Select Partners → Create. 

The Partner profiles detail screen appears on the right-hand side of your screen. 

4. In the Partn.number field, type FILEPORT. 

5. In the Partn.type field, make sure that LS (for Logical System) appears.  

 
If LS does not appear in the Partn.type field, select it. 

6. Select the Classification tab. 

7. In the Partn.Status field, select A (for Active), then choose Save. 

Defining outbound parameters 
8. In the Outbound Parmtrs group box, select the Create outbound parameters pushbutton. 

The Partner Profiles Outbound Parameters screen appears. 

9. In the Message Type field, select the appropriate HROT_xx file. 

10. In the Receiver Port field, select the matching HROT_xx file. 

 
Select the File tab, if required. 

11. Select the Transfer IDocs immed. field. 

12. In the Basic Type field, select the corresponding Basic IDoc type, if the information is not 
supplied automatically. 

13. Save the information. 

14. Repeat steps 8 through 13 for each type of outbound IDoc you need to define. 
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Setting Up the Partner Definition 

 
If you are using the Combined Payroll Export, you must set up both types of IDocs, 
master data and gross payroll. 

Result 
You have successfully set up your partner and defined the outbound IDoc parameters. 

You are ready to begin exporting payroll or master data information. 
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Outsourcing Gross and Combined Payroll and Master 
Data 
The Payroll Outsourcing functionality allows you to create data in an electronic file and send that 
data to a third-party payroll service provider for processing. The Outsourcing menu appears on 
the Payroll screen, allowing you to create and prepare the electronic file you need to transmit to 
your third-party payroll service provider. 

The Payroll Outsourcing software allows you to send Gross Payroll or employee Master Data 
information or both to your third-party payroll service provider. The service provider translates 
values, creates a file, calculates the tax and benefit deductions, prints the payroll checks, and 
returns the payroll and wage-type information to the SAP system electronically for updating 
Financial and Controlling figures. 

You can decide if you want to export gross payroll, master data only, or a combination of the two. 
Then you can decide whether or not to import the payroll results from the third-party payroll 
service provider. If you are using the gross payroll or combined payroll outsourcing and you 
decide that you want to receive the payroll results from the third-party service provider, you can 
choose to either import payroll results directly into Finance and Controlling or import the payroll 
results into HR for reconciliation before transferring the data into Finance and Controlling. If you 
send only master data to the third party service provider, you can import payroll results only into 
Finance and Controlling. 

For basic payroll outsourcing, you must determine whether your company uses Master Data or 
Gross Payroll or Combined Payroll to follow the proper instructions. The following flowchart 
shows the high level process for each of these types of outsourced payroll processes. If you use 
the combined payroll outsourcing, this flowchart helps you determine which process to observe 
based on which option you choose. 

Master
Data?

Run Gross Payroll
Export process

Run Master Data
Export process

Payroll
Outsourcing

Set the control
record to Release

Payroll

Send IDoc to
service provider 

Run Payroll with
the appropriate

schema

Service provider
processes payroll
and returns data

Send IDoc to
service provider 

No

 Yes

Service provider
processes

Gross Payroll
ARun the import

process
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Run Payroll Import
with appropriate

schema

Service provider
returns payroll

results

Wait for payroll
results to be
returned from

service provider

Set control record
to Exit Payroll

A

 
For more information regarding IDocs, see IDoc Interface / Electronic Data Interchange [Ext.]. 

See also: 
 

Setup Process for Outsourcing [Page 931] 

Combined Payroll Outsourcing Process [Page 939] 

Gross Payroll Outsourcing Process [Page 948] 

Master Data Outsourcing Process [Page 954] 

Importing Payroll Results Process [Page 957] 

Payroll Outsourcing Screens [Page 96 ]3  

Troubleshooting [Page 987] 
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Combined Payroll Outsourcing Process 
Purpose 
The Combined Payroll Process allows you to update master data during a pay period and to 
export these changes. Not all IDoc segments can be exported in this mini-master version. The 
mini master uses fewer segments than the master data version. The mini-master data contains 
those IDoc segments which allow you to perform mid-pay-period processing on the Outsourcer's 
system (such as bonus runs). 

You can process the Mini Master export multiple times during a pay period. It picks up all the 
changes you made since you processed the last export. The Mini-Master Export option prepares 
the export file to send to the third-party payroll service provider. 

Once the IDoc is created, you assign the export IDoc to the appropriate service port for transport 
to the payroll server on which the third-party payroll service provider's software resides. 

The Gross Payroll export uses pay related data only and provides the data as calculated by the 
Payroll driver. 

 
The Gross Payroll exports the benefit infotype changes that occur during a pay 
period with the payroll driver. This way, the Outsourcers can process the benefit 
changes along with the corresponding deductions. 

When you run the Combined Payroll option for outsourcing, you must perform two procedures to 
create the payroll data. The first procedure creates the gross payroll file to be used to export data 
to the third-party payroll service provider. The second procedure prepares the export file, called 
IDoc, to send to the third-party payroll service provider. It also allows you to assign the export 
IDoc to the appropriate service port for transport to the payroll server on which the payroll 
software resides. 

Prerequisites 
Make sure that all required information has been configured. You must establish: 

• Tax authorities 

• Payroll areas 

• Calendars associated with each payroll area 

• Wage types 

• Deduction frequencies 

• Payroll control records for each payroll area 

  
Make sure that you run the gross payroll schema before you run the outsourcing 
options. 
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Combined Payroll Outsourcing Process 

Process Flow 
1. Run the gross payroll process from the Payroll menu using the appropriate schema. 

2. Review the payroll results to ensure that the gross payroll process ran without errors. 

3. If the payroll results show errors, correct the errors and repeat steps 1 through 3. - OR - If the 
payroll results are error free, continue with step 4. 

4. Run this process from the Human Resources → Payroll → Outsourcing → Export → 
Combined Payroll Export menu. In order to produce the outsourcing IDoc, you must use 
each available option in the Export menu in the following order for each option. 

Mini-Master Data 
1. Run the Mini Master Export option. 

2. Run the Display IDocs option. 

3. Run the Process Outbound IDocs option. 

Combined Payroll 
1. Run the Combined Payroll Export option. 

2. Run the Display IDocs option. 

3. Run the Process Outbound IDocs option. 

Result 
You have completed the outsourcing payroll process. 

See also: 
 

Importing Payroll Results Process [Page 957] 

Exporting Mini-Master Data [Page 942] 

Exporting Combined Payroll [Page 944] 

Locating New IDocs [Page 946] 

Processing New IDocs [Page 947] 

Comparing SAP Data with Third-Party Data [Page 956] 
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Exporting Mini-Master Data 
Use 
The Mini-Master Export allows you to provide the Outsourcer with employee information as it 
changes. Using this feature reduces the size of the IDocs that are created and sent to the 
Outsourcer. Use this program to provide the Outsourcer changes to the employee's master data 
without running payroll. 

Prerequisites 
Make sure that all administrative tasks have been performed and closed before beginning the 
Mini-Master Data Export process. 

Procedure 
1. Select Human Resources → Payroll → Outsourcing → Export → Combined Payroll Export → 

Mini Master Export. 

The Mini Master Export screen appears. 

2. In the Payroll Period group box, Payroll field, type or select the appropriate value for the 
payroll that you want to export. 

3. In the Selection group box, Personnel number fields, type the employee number or range of 
numbers, if applicable. 

4. In the Payroll Area field, type or select the appropriate value for the payroll that you want to 
export. 

5. Select the Update field. 

6. Add or select other information appropriate to the payroll run. 

7. Select Execute. 

The Export Statistics screen appears. 

8. Close the Export Statistics screen. 

 
If you need to create another Outsourcing file for export, repeat steps 2 through 8. 

9. Return to the main menu. 

Result 
You have successfully generated the electronic mini-master data file. You can continue with 
Locating New IDocs [Page 946]. 

See also: 
 

Exporting Combined Payroll [Page 944] 

Comparing SAP Data with Third-Party Data [Page 95 ]6  
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Exporting Combined Payroll 
Prerequisites 
Make sure that all administrative tasks have been performed and closed before generating the 
electronic payroll file. 

Procedure 
1. Start the payroll from the Payroll menu. 

 
For more information, see Starting Payroll [Page 70]. 

2. In the General program control group box, Schema field, you must type the appropriate 
schema for your country. 

 
For example, the US payroll uses schema U200 and the Canadian payroll uses 
schema K200. 

3. Select Human Resources → Payroll → Outsourcing → Export → Combined Payroll Export → 
Combined Payroll Export. 

The Combined Payroll Export screen appears. 

4. In the Payroll Period group box, Payroll field, type or select the appropriate value for the 
payroll that you want to export. 

5. In the Selection group box, Personnel number fields, type the employee number or range of 
numbers, if applicable. 

6. In the Selection group box, Payroll Area field, type or select the appropriate value for the 
payroll that you want to export. 

7. Select the Update field. 

8. Add or select other information appropriate to the payroll run. 

9. Select Execute. 

The Export Statistics screen appears. 

10. Close the Export Statistics screen. 

 
If you need to create another Outsourcing file for export, repeat steps 4 through 10. 

11. Return to the main menu. 

Result 
You have successfully generated the electronic payroll file. You can continue with Locating New 
IDocs [Page 946]. 

See also: 
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Running Off-Cycle Gross Payroll [Page 952] 
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Locating New IDocs 
Prerequisites 
Make sure that you have generated the electronic payroll file or files for export. 

Procedure 
1. Select Human Resources → Payroll → Outsourcing → Export → Display IDocs. 

The IDoc Lists screen appears. 

2. In the Date created field, type or select the appropriate date on which the IDoc file or files 
were created, if it were created on a different day than the default (today's) date. 

3. In the Time created fields, type the time of day that the IDoc file or files were created, if 
applicable. 

4. Add or select other information appropriate to the IDoc file you want to locate. 

5. Select Execute. 

The IDoc Lists screen appears with all of the IDoc information listed. 

6. In the Number field, select the IDoc file or files that you have created, then select Goto → 
Status List Details. 

The Detail Data on IDoc Status screen appears. 

7. Locate and make a note of the IDoc number. 

8. Close the Detail Data on IDoc Status screen. 

 
If you need to locate another IDoc file for export, repeat steps 6 through 8. 

9. Return to the initial SAP menu. 

Result 
You have successfully located the IDoc file. You can continue with Processing New IDocs [Page 

]. 947
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Processing New IDocs 
Prerequisites 
Make sure that you have located and written down the number of the IDoc file or files for export. 

Procedure 
1. Select Human Resources → Payroll → Outsourcing → Export → Process Outbound. 

The Process All Selected Intermediate Documents screen appears. 

2. In the IDoc number field, type the number or the range of numbers for the IDocs you want to 
export. 

3. In the Port of Receiver field, select the appropriate HROT_xx file. 

4. Add or select other information appropriate to the IDoc file you want to locate. 

5. Select Execute. 

The Information dialog box appears, indicating how many IDocs were selected for 
transport. 

6. Select Continue. 

Result 
You have successfully processed the outbound IDoc file or files. 
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Gross Payroll Outsourcing Process 
Purpose 
When you run your payroll for outsourcing, you must use two procedures. The first procedure 
creates the gross payroll file to be used to export data to the third-party payroll service provider. 

The second procedure prepares the export file, called IDoc, to send to the third-party payroll 
service provider. It also allows you to assign the export IDoc to the appropriate service port for 
transport to the payroll server on which the payroll software resides. 

Prerequisites 
Make sure that all required information has been configured. You must establish: 

• Tax authorities 

• Payroll areas 

• Calendars associated with each payroll area 

• Wage types 

• Deduction frequencies 

• Payroll control records for each payroll area 

  
Make sure that you run the gross payroll schema before you run the outsourcing 
options. 

Process Flow 
5. Run the gross payroll process from the Payroll menu using the appropriate schema. 

6. Review the payroll results to ensure that the gross payroll process ran without errors. 

7. If the payroll results show errors, correct the errors and repeat steps 1 through 3. - OR - If the 
payroll results are error free, continue with step 4. 

8. Run these processes from the Human Resources → Payroll → Outsourcing → Export menu. 
In order to produce the outsourcing IDoc, you must use each available option in the Export 
menu in the following order. 

a. Run the Gross Payroll Export option. 

b. Run the Display IDocs option. 

c. Run the Process Outbound IDocs option. 

Result 
You have completed the outsourcing payroll process. 

See also: 
 

Importing Payroll Results Process [Page 957] 
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Running Gross Payroll Outsourcing [Page 950] 

Locating New IDocs [Page 946] 

Processing New IDocs [Page 947] 

Running Off-Cycle Gross Payroll [Page 952] 
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Running Gross Payroll Outsourcing 
Prerequisites 
Make sure that all administrative tasks have been performed and closed before generating the 
electronic payroll file. 

Procedure 
12. Start the payroll from the Payroll menu. 

 
For more information, see Starting Payroll [Page 70]. 

2. In the General program control group box, Schema field, you must type the appropriate 
schema for your country. 

 
For example, the US payroll uses schema U200 and the Canadian payroll uses 
schema K200. 

3. Select Human Resources → Payroll → Outsourcing → Export → Gross Payroll Export. 

The Gross Payroll Export screen appears. 

4. In the Payroll Period group box, Payroll field, type or select the appropriate value for the 
payroll that you want to export. 

5. In the Selection group box, Personnel number fields, type the employee number or range 
of numbers, if applicable. 

6. In the Selection group box, Payroll Area field, type or select the appropriate value for the 
payroll that you want to export. 

7. Select the Update field. 

8. Add or select other information appropriate to the payroll run. 

9. Select Execute. 

The Export Statistics screen appears. 

10. Close the Export Statistics screen. 

 
If you need to create another Outsourcing file for export, repeat steps 4 through 10. 

11. Return to the main menu. 

Result 
You have successfully generated the electronic payroll file. You can continue with Locating New 
IDocs [Page 946]. 

See also: 
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Running Off-Cycle Gross Payroll [Page 952] 

Processing New IDocs [Page 947] 
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Running Off-Cycle Gross Payroll 
Use 
When you need to run an off-cycle payroll for outsourcing, use this procedure. 

Prerequisites 
If you are using Gross Payroll Outsourcing, then you can run off-cycle payroll as required, using 
this procedure. 

Procedure 
1. Run the off-cycle payroll. 

 
For more information, see Off-Cycle Payroll Accounting [Page 134]. 

2. From the main menu, select Human Resources → Payroll → Outsourcing → Export → Gross 
Payroll Export - OR - select Human Resources → Payroll → Outsourcing → Export → 
Combined  Payroll Export → Combined Payroll Export. 

Either the Gross Payroll or the Combined Payroll Export screen appears. 

3. In the Payroll Period group box, leave the setting for Current Period. 

4. In the Payroll field, type or select the appropriate value for the payroll that you want to export. 

5. In the Selection group box, Personnel number fields, type the employee number or range of 
numbers, if applicable. 

6. In the Selection group box, Payroll Area field, select the appropriate value for the payroll that 
you want to export. 

7. Select the Update field. 

8. In the Special payroll run group box, Special Payroll Type field, select the appropriate code 
for the type of off-cycle run. 

9. In the Special Payroll Identifier field, add a sequential number, if applicable. 

10. In the Special Payroll Date field, type the date for the off-cycle run. 

 
This data must reflect the data for the off-cycle run exactly. You assign the 
sequential number for the special payroll runs as necessary. 

11. Add or select other information appropriate to the payroll run. 

12. Select Execute. 

The Export Statistics screen appears. 

13. Close the Export Statistics screen. 

14. Select Continue. 
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Result 
You have successfully run the off-cycle gross payroll for outsourcing. You can continue with 
Locating New IDocs [Page 946]. 
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Master Data Outsourcing Process 
Purpose 
When you export employee data for payroll outsourcing, do not run Payroll from the Payroll 
menu. The Master Data option prepares the export file, called IDoc, to send to the third-party 
payroll service provider. 

Once the IDoc is created, you assign the export IDoc to the appropriate service port for transport 
to the payroll server on which the third-party payroll service provider's software resides. 

Prerequisites 
Make sure that all required information has been configured. You must establish: 

• Tax authorities 

• Payroll areas 

• Calendars associated with each payroll area 

• Payroll control records for each payroll area 

If you also export wage types (Infotypes 14 and 15) and benefits, then you must configure: 

• Wage types 

• Deduction frequencies 

Process Flow 
Run these processes from the Human Resources → Payroll → Outsourcing → Export menu. In 
order to produce the outsourcing IDoc, you must use each available option in the Export menu in 
the following order. 

1. Run the Master Data Export option. 

2. Run the Display IDocs option. 

3. Run the Process Outbound IDocs option. 

Result 
You have completed the outsourcing payroll process. 

See also: 
 

Importing Payroll Results Process [Page 957] 

Running Master Data Outsourcing [Page 955] 

Locating New IDocs [Page 946] 

Processing New IDocs [Page 947] 

Comparing SAP Data with Third-Party Data [Page 95 ]6  
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Running Master Data Outsourcing 
Prerequisites 
Make sure that all administrative tasks have been performed and closed before beginning the 
Master Data Export process. 

Procedure 
10. Select Human Resources → Payroll → Outsourcing → Export → Master Data Export. 

The Master Data Payroll Export screen appears. 

11. In the Payroll Period group box, Payroll field, type or select the appropriate value for the 
payroll that you want to export. 

12. In the Selection group box, Personnel number fields, type the employee number range, if 
applicable. 

13. In the Payroll Area field, type or select the appropriate value for the payroll that you want to 
export. 

14. Select the Update field. 

15. Add or select other information appropriate to the payroll run. 

16. Select Execute. 

The Export Statistics screen appears. 

17. Close the Export Statistics screen. 

 
If you need to create another Outsourcing file for export, repeat steps 2 through 8. 

18. Return to the main menu. 

Result 
You have successfully generated the electronic payroll file. You can continue with Locating New 
IDocs [Page 946]. 

See also: 
 

Comparing SAP Data with Third-Party Data [Page 95 ]6  
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Comparing SAP Data with Third-Party Data 
Use 
If you are using Master Data Outsourcing, you can occasionally check to make sure that your 
data matches the data that your third-party payroll service provider has, using this procedure. 

Prerequisites 
Be sure to schedule these transmissions with your third-party service provider. 

Procedure 
1. Select Human Resources → Payroll → Outsourcing → Export → Master Data Export. 

The Master Data Payroll Export screen appears. 

2. In the Payroll Period group box, leave the setting for Current Period. 

3. In the Payroll field, type or select the appropriate value for the payroll that you want to export. 

4. In the Selection group box, Personnel number fields, type the employee number range, if 
applicable. 

5. In the Payroll Area field, select the appropriate value for the payroll that you want to export. 

6. Select the Update field. 

7. Select the All data (not diffs. only) field. 

8. Add or select other information appropriate to the payroll run. 

9. Select Execute. 

The Export Statistics screen appears. 

10. Close the Export Statistics screen. 

11. Select Continue. 

12. Run the other two procedures in this process as you would for a normal export to the third-
party payroll service provider. 

Result 
You have successfully run the master data all data program to send to the third-party payroll 
service provider for comparing with its data. 

See also: 
 

Locating New IDocs [Page 946] 

Processing New IDocs [Page 947] 
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Importing Payroll Results Process 
Purpose 
There are two ways to import payroll results. One way imports payroll directly to the Finance and 
Controlling (FI/CO) modules. The other way imports payroll results directly into a payroll results 
table within the HR module, for Payroll to reconcile all amounts before releasing the data to 
FI/CO. 

If you use the Master Data Export, then you must import payroll results directly to FI/CO. Since 
the Master Data Export does not use the SAP Payroll clusters, payroll results cannot be imported 
back through them. If you want to import financial data from the Outsourcer's system to SAP's 
financial modules, you have only this option to do so. 

If you use the Gross or Combined Payroll Export programs, you can use either option. Using the 
direct import method means that there are no records within SAP for reconciliation between 
payroll and the figures appearing in SAP's FI/CO. When you export the gross payroll data and 
import payroll results directly to FI/CO, you can only use the Outsourcer's system for 
reconciliation. 

When you are using Gross or Combined Payroll Export programs, you can choose to import 
payroll results into the SAP HR module. This process imports all the Outsourcer's net and gross 
data and stores it in the SAP payroll results cluster. Using this method, you can reconcile 
financial data before transferring it to FI/CO. Since the import provides a total of differences 
between the gross values you exported and the gross values the Outsourcer imported, you can 
use these differences for any required reconciliation between the two systems. 

Prerequisites 
Use procedure only if you outsource your payroll using either master data, gross payroll, or 
combined payroll outsourcing. 

Process Flow 
Importing Payroll Results to FI / CO 
1. Receive the payroll results file from the third-party payroll service provider. 

2. Process the file from the service provider. 

3. Locate the new IDoc. 

4. Release the IDoc. 

Importing Payroll Results to the HR Module for Reconciliation 
1. Receive the payroll results file from the third-party payroll service provider. 

2. Process the file from the service provider from a file to an IDoc. 

3. Locate the new IDoc and evaluate the payroll results. 

4. Release the IDoc. 

5. Release the payroll results to Finance and Controlling. 
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Result 
You have successfully completed the process for importing payroll results into SAP software. 

See also: 
 

Processing the Payroll Results File [Page 959] 

Locating Import IDocs [Page 960] 

Releasing IDocs [Page 961] 

Importing Payroll Results [Page 962] 
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Processing the Payroll Results File 
Prerequisites 
Make sure that you have received the electronic payroll results file or files from the third-party 
payroll service provider. 

Procedure 
1. Select Human Resources → Payroll → Outsourcing → Import → Process Inbound. 

The Trigger Inbound Processing screen displays. 

2. In the Directory + File field, type the network path for the directory in which the inbound file is 
located, followed by the file name. 

 
You can find the path information in the inbound port definiton you set up for 
outsourcing. For more information, see Setting Up Outsourcing Ports / Function 
Modules [Page 933]. 

3. In the Port field, type the name of the port to which you want to transfer the IDoc. 

4. Select Execute. 

The processing of the inbound file begins. 

Result 
You have successfully completed processing the inbound payroll results file. You can continue 
with Locating Import IDocs [Page 960]. 
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Locating Import IDocs 
Prerequisites 
Make sure that you have processed the electronic payroll results file or files from the third-party 
payroll service provider to an IDoc file or files. 

Procedure 
1. Select Human Resources → Payroll → Outsourcing → Import → Display IDocs. 

The IDoc Lists screen appears. 

2. In the Date created field, type or select the appropriate date on which the IDoc file or files 
were created, if it were created on a different day than the date shown. 

3. In the Time created fields, type the time of day that the IDoc file or files were created, if 
applicable. 

4. Add or select other information appropriate to the IDoc file you want to locate. 

5. Select Execute. 

The IDoc Lists screen appears with all of the IDoc information listed. 

6. In the Number field, select the IDoc file or files that you have created, then select Goto → 
Status List Details. 

The Detail Data on IDoc Status screen appears. 

7. Locate and make a note of the IDoc number. 

8. Close the Detail Data on IDoc Status screen. 

 
If you need to locate another IDoc file for export, repeat steps 6 through 8. 

9. Return to the main Payroll screen. 

Result 
You have successfully located the IDoc file. You can continue with Releasing IDocs [Page 961]. 
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Releasing IDocs 
Use 
In order to prepare the IDoc to be processed or released to Finance and Controlling modules 
(FI/CO), you must first release it. 

Prerequisites 
Make sure that you have converted the electronic payroll results file or files from the third-party 
payroll service provider to an IDoc file or files. 

Procedure 
10. Select Human Resources → Payroll → Outsourcing → Import → Release IDocs. 

The Inbound Processing of IDocs Ready for Transfer screen appears. 

2. In the IDoc number field, type the number of the IDoc or IDocs. 

3. Choose Execute. 

Result 
You have successfully released the IDoc for processing. If you are not releasing the payroll 
results directly to FI/CO, you can continue with Importing Payroll Results [Page 962]. 
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Importing Payroll Results 
Prerequisites 
Make sure that you have converted the electronic payroll results file or files from the third-party 
payroll service provider to an IDoc file or files. 

Procedure 
1. Select Human Resources → Payroll → Outsourcing → Import → Payroll Import. 

The Payroll Driver screen appears. 

2. In the General program control area, Schema field, type x250. The x represents your country 
code (letter). 

 
Type U250 in the US or K250 in Canada. 

3. In the Payroll Period area, Payroll field, type or select the appropriate value for the payroll 
that you want to export. 

4. In the Selection area, Personnel number fields, type the employee number range, if 
applicable. 

5. In the Selection area, Payroll Area field, type or select the appropriate value for the payroll 
that you want to export. 

6. Select the Update field. 

7. Add or select other information appropriate to releasing the payroll results. 

8. Select Execute. 

The Payroll Driver log screen appears. 

9. Close the Payroll Driver log screen. 

 
If you are using Gross Payroll outsourcing, you can set the Payroll Control record to 
exit. 

Result 
You have successfully imported the payroll results. 
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Payroll Outsourcing Screens 
When you are ready to export IDocs to the third-party payroll service provider, make sure that 
you have completed all necessary steps before you prepare the export IDoc. Once you have 
done so, you are ready to begin the payroll outsourcing process. 

The outsourcing option has been added to the Payroll menu. All outsourcing options are located 
in this menu. 

For more information regarding IDocs, see IDoc Interface / Electronic Data Interchange [Ext.]. 

See also: 
 

Export Screen [Page 964] 

IDoc Lists Screen [Page 96 ]6  

IDoc Display Screen [Page 968] 

Data Record Screens [Page 970] 

Header Record Data Elements [Page 97 ]2  • 

Key Record Data Elements [Page 973] • 

Trailer Record Data Elements [Page 97 ]5  • 

Process All Selected IDocs Screen [Page 976] 

Trigger Inbound Processing Screen [Page 977] 

Payroll Driver for Import Process Screen [Page 978] 
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Export Screen 
Purpose 
Use this screen to prepare the IDoc file or files to be exported to the third-party payroll service 
provider. 

Features 
Field Name Description 

Payroll area Required.  Type or select the specific payroll area for the payroll you 
want to outsource. 

Current period Default 

Other period Optional.  If you want to create the payroll outsourcing file for a different 
period, select this field and type the appropriate period information. 

Personnel number 
Optional.  You can control which people are to be paid via the 
outsourcing file by defining the starting and ending personnel number in 
these fields. 

Payroll area Optional / Recommended.  Type or select the specific payroll area for 
the payroll you want to outsource. 

Repeat Optional.  Select this option if you need to repeat the creation of a 
payroll outsourcing file due to errors in a previous run. 

Update 
Default.  This option updates a payroll outsourcing file. If you clear this 
option, you risk creating errant or old information from a previous payroll 
run. 

Display log Optional.  Select this option if you want to view the log after you have 
created your outsourcing file. 

All data (not diffs. 
only) 

Optional.  Select this option if you want to send all of the data to the 
Outsourcer, for example, comparing data in both databases. 

Number of IDoc 
segments 

Optional.  The default value for this field is 6000. If you have a less 
powerful system, type 3000. 

Gross / Combined 
Payroll field Description 

Special Payroll Type Optional.  Type or select the specific payroll type to identify the off-cycle 
payment type. 

Special Payroll 
Identifier 

Optional.  Type or select the specific payroll identifier for this off-cycle 
payment type. 

Special Payroll Date Optional.  Type the appropriate date for this off-cycle payment run. 

See also: 
 

IDoc Lists Screen [Page 966] 
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Process All Selected IDocs Screen [Page 976] 
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IDoc Lists Screen 
Purpose 
Use this screen to locate the IDoc file or files that you have created. 

Features 
Field Name Description 

Date created Recommended.  Type the date or range of dates on which the files were 
created in these fields. Use the DDMMYYYY format. 

Time created Optional.  Type the time or the range of times at which the files were 
created in these fields. Use the HHMMSS format. 

Logical message 
type Optional 

Message code Optional 

Message function Optional 

Partner type of 
sender Optional 

Optional 

Partner number of 
sender Optional 

Partner type of 
recipient Optional 

Partner function of 
recipient Optional 

Partner number of 
recipient Optional 

Partner function of 
sender 

 

For more information regarding IDocs, see IDoc Interface / Electronic Data Interchange [Ext.]. 

See also: 
 

IDoc Lists Screen (2) [Page 967] 

IDoc Display Screen [Page 968] 

Data Record Screens [Page 970] 
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IDoc Lists Screen (2) 
Purpose 
Use this screen to review the IDoc or IDocs that you want to send to the Outsourcing system 
port. This screen shows you the status and the name of the IDoc, as well as the means to display 
the information contained within the IDoc. You can review the contents of the IDoc as a means of 
checking data for accuracy. 

Features 
In the left frame, you can locate the type of IDoc you have created, Outbound or Inbound. In the 
right frame, look for the appropriate message type. The message type is associated with the 
appropriate IDoc type. 

In the right frame, select the Message type, HROT_xxP or HROT_xxM as appropriate, then 
choose the IDoc Display pushbutton. 

For more information regarding IDocs, see IDoc Interface / Electronic Data Interchange [Ext.]. 

See also: 
 

IDoc Lists Screen [Page 96 ]6  

IDoc Display Screen [Page 968] 

Data Record Screens [Page 970] 
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IDoc Display Screen 
Purpose 
This screen displays all high level information for the specific IDoc you selected. From here, you 
can select information that you want to view to ensure the validity of the data. 

Field Name 

Features 
Left Frame 
The left frame of this screen displays all of the IDocs that you have created. Each is assigned a 
sequential number by the system. Normally, the IDoc you want to transfer to the Outsourcing port 
is the last IDoc in the list. 

Description 

The list of IDocs created with this message type 

The top record for the selected IDoc file 

The data used to create the IDoc 

Select and expand this folder to view the IDoc information. 

E1HR_HD The IDoc segment containing the header record 

E1HR_KY 
The IDoc segments containing the key record or payroll information 

Select and expand this folder to view the IDoc segments. Select this field 
and select Choose to view specific data contained in the IDoc. 

E1HR_TL 
The IDoc segment containing the trailer record 

The number next to this data record represents the total number of data 
segments contained in the IDoc. 

The status record information stored during the IDoc creation process 

IDoc <number> 

Control Record 

Data Records 

Status records 

Right Frame 
The right frame contains more information about the IDoc itself. 

Field Name Description 

Direction Indicates whether the IDoc is inbound or outbound 

Current status Indicates the state of the IDoc at this moment, for example, an error occurred 
or it is ready for processing 

Basic type Contains the message type country-specific information for this IDoc 

Extension Contains additional information for the basic type field, if applicable 

Message type The message that is associated with the IDoc type 

Partn. number Contains the name of the partner that you established when you set up the 
partner definition 
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Partn. type Contains the information that you established when you defined the logical 
system 

Port Contains the name of the port that you established when you defined the port 
defintion 

See also: 
 

IDoc Lists Screen [Page 96 ]6  

IDoc Lists Screen (2) [Page 967] 

Data Record Screens [Page 970] 
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Data Record Screens 
These screens allow you to view the data elements which are being transfered to the third-party 
payroll service provider. 

The Data Record screens vary, therefore the screens explained herein are those screens which 
are written in every export IDoc. For more information, see Converting IDoc Documentation to 
HTML [Page 989]. 

See also: 
 

Header Record Data Elements [Page 972] 

Key Record Data Elements [Page 973] 

Trailer Record Data Elements [Page 975] 
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Header Record Data Elements 
Purpose 
The header record contains all pertinent information regarding the contents of the IDoc. 

Integration 
This information allows you to make sure that you are sending all of the appropriate information 
to the third-party payroll service provider, for example, you can check the payroll period, the type 
of payroll, and so on. 

Features 
Data element Description 

ABKRS 

Payroll area 
Payroll area to which the employees with the same payroll schedule are 
assigned 

ZEINH 

Payroll time units 
The code for which type of payroll is included in the IDoc 

PABRJ 

Accounting year 
The company's fiscal year 

The company's accounting period within its fiscal year 

PERBE 

Start date 
The date on which the Payroll For period begins 

PEREN 

End date 
The date on which the Payroll For period ends 

VERSN 

HR: Outsourcing 
Payroll version 

Identifies which type of payroll information is contained in the IDoc. 

PABRP 

Accounting period 

See also: 
 

Data Record Screens [Page 970] 

Key Record Data Elements [Page 973] 

Trailer Record Data Elements [Page 975] 
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Key Record Data Elements 
Purpose 
The header record contains all pertinent information regarding the specific employee for which 
the following information applies. 

Integration 
This information allows you to make sure that you are sending data for every employee within a 
payroll area. 

Features 
Data element Description 

PERNR 

Personnel Number 
The number assigned to an employee 

This contains a number that has been assigned to an employee by an 
outside institution, such as a tax number or a social insurance number 

ABKRS 

Payroll area 
Payroll area to which employees with the same payroll schedule are 
assigned 

FPBER 

Start of payroll 
period 

The date on which the Payroll For period begins 

FPEND 

End of payroll 
period 

The date on which the Payroll For period ends 

FPPER 

For-period for 
payroll 

The date on which the For-period payroll is valid 

BUKRS 

Company code 
The code the company uses for its payroll 

WERKS 

Personnel area 
The area to which an employee is assigned 

BTRTL 

Personnel subarea 
The subarea within an area to which an employee is assigned, if 
applicable 

PERID 

Personal ID 
Number 

See also: 
 

Data Record Screens [Page 970] 
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Header Record Data Elements [Page 97 ]2  

Trailer Record Data Elements [Page 97 ]5  
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Trailer Record Data Elements 
Purpose 
The trailer record reiterates information contained in the header record plus one additional field. 

Integration 
The trailer record indicates the end of the information contained in this IDoc. 

Features 
Data element Description 

ABKRS 

Payroll area 
Payroll area to which employees with the same payroll schedule are 
assigned 

ZEINH 

Payroll time units 
The code for which type of payroll is included in the IDoc 

PABRJ 

Accounting year 
The company's fiscal year 

PABRP 

Accounting period 
The company's accounting period within its fiscal year 

Start date 
The date on which the Payroll For period begins 

PEREN 

End date 
The date on which the Payroll For period ends 

NPERN 

Number of 
personnel 
processed 

The number of employees included in this IDoc 

TRECS 

Number of 
segments 
processed 

The number of data segments processed in this IDoc 

PERBE 

See also: 
 

Data Record Screens [Page 970] 

Header Record Data Elements [Page 97 ]2  

Key Record Data Elements [Page 973] 
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Process All Selected IDocs Screen 
Purpose 
Use this screen to prepare the IDoc or IDocs to be transported to the Outsourcing system port. 

Features 
Field name Description 

IDoc number Type the number of the IDoc file you want to send to the third-party 
payroll service provider in this field. 

Basic IDoc type Select the appropriate IDoc type from the list. 

Port of receiver Type or select the appropriate port for your Outsourcing process. 

Partner type of 
recipient Optional 

Partner function of 
recipient Optional 

Partner number of 
recipient Optional 

Logical message 
type Optional 

Last changed on Optional 

Time of last 
change Optional 

Output mode Optional 

Test option Optional 

Maximum number 
of IDocs Optional 

See also: 
 

Export Screen [Page 964] 

IDoc Lists Screen [Page 966] 

IDoc Lists Screen (2) [Page 967] 

Data Record Screens [Page 970] 
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Trigger Inbound Processing Screen 
Purpose 
Use this screen to begin processing inbound data from the third-party payroll service provider 
into an IDoc format. 

Features 
Field name Description 

Directory + File Type the full path for the directory and filename in which the inbound payroll 
results file is stored. 

Port Type or select the name of the port which the outsourcing software uses to 
locate the directory and file. 

 

For more information regarding IDocs, see IDoc Interface / Electronic Data Interchange [Ext.]. 

See also: 
 

IDoc Lists Screen [Page 96 ]6  

Payroll Driver for Import Process Screen [Page 978] 
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Payroll Driver for Import Process Screen 
Purpose 
Use this screen to release the payroll results data in the IDoc to FI/CO. 

Features 
Field Name Description 

Payroll area Required.  Type or select the specific payroll area for the payroll you want 
to outsource. 

Current period Default 

Other period Optional.  If you want to create the payroll outsourcing file for a different 
period, select this field and type the appropriate period information. 

Personnel number Optional.  You can control which people are to be paid via the outsourcing 
file by defining the starting and ending personnel number in these fields. 

Payroll area Optional / Recommended.  Type or select the specific payroll area for the 
payroll you want to outsource. 

See also: 
 

Trigger Inbound Processing Screen [Page 977] 

IDoc Lists Screen [Page 96 ]6  
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Outsourcing Time Wage Types 
The Time Wage Type Outsourcing functionality allows you to create data in an electronic file and 
send that data to a third-party service provider for processing. The Outsourcing menu appears in 
the Human Resources → Payroll menu, allowing you to create and prepare the electronic file you 
need to transmit to your third-party service provider. 

The Time Wage Type Outsourcing software allows you to send Time evaluation along with 
employee Master Data information to your third-party service provider. The service provider 
translates values, creates a file, calculates the tax and benefit deductions, prints the payroll 
checks, and returns the payroll and wage-type information to the SAP system electronically for 
updating Financial and Controlling figures. 

When you decide to export time wage types to a third-party service provider, you allow the 
outsourcer to evaluate your employees' time data. In addition to sending this data, you must also 
export master data in order for the payroll to be processed properly. 

This process allows you to send only time wage types; it does not permit you to send raw time 
data. In other words, you will be required to set up and run all time managment and time 
evaluation on the SAP system before you send this data to the outsourcer for further processing. 

A flowchart of the high level process follows. 

Run Time
Evaluation

Time Wage
Type Export

Run Time Wage
Type Export 

Run Master
Data Export

 
You can decide if you want to import the payroll results from the third-party payroll service 
provider. If you decide to import this information, you can import payroll results only into Finance 
and Controlling. 

For more information regarding IDocs, see IDoc Interface / Electronic Data Interchange [Ext.]. 

See also: 
 

Time Wage Type Outsourcing Process [Page 983] 

Processing Time Wage Types [Page 985] 
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Time Wage Type Outsourcing Process 
Purpose 
When you outsource your time wage type information for processing, you also need to prepare 
Master Data for export to the third-party service provider. 

Prerequisites 
Make sure that all required information has been configured. You must establish: 

• Tax authorities 

• Payroll areas 

• Calendars associated with each payroll area 

• Payroll control records for each payroll area 

If you also export wage types (Infotypes 14 and 15) and benefits, then you must configure: 

• Wage types 

• Deduction frequencies 

  
Make sure that you run the time evaluation before you run the outsourcing options. 

Process Flow 
9. Run the time evaluation process from the Time Management menu. 

10. Review the results to ensure that the time evaluation process ran without errors. 

11. If the time evaluation results show errors, correct the errors and repeat steps 1 through 3. - 
OR - If the time evaluation results are error free, continue with step 4. 

12. Run these processes from the Human Resources → Payroll → Outsourcing → Export menu. 
In order to produce the outsourcing IDoc, you must use these options in the Export menu in 
the following order. 

d. Run the Time Wage Type Export option. 

e. Run the Master Data Export option. 

f. Run the Display IDocs option. 

g. Run the Process Outbound IDocs option. 

Result 
You have completed the time wage type outsourcing process. 

See also: 
 

Processing Time Wage Types [Page 985] 

Locating New IDocs [Page 946] 
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Processing New IDocs [Page 947] 
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Processing Time Wage Types 
Use 
Send time wage types to the outsourcer for payroll processing. When you use this option, you 
must also use the Master Data Export for the third-party service providers to process the time 
wage types. 

Prerequisites 
Make sure that all administrative tasks have been performed and closed before generating the 
electronic payroll file. 

Procedure 
13. Start the Time Evaluation process from the Time Management menu. 

 
For more information, see Running the Time Evaluation Report (RPTIME00) [Ext.]. 

2. Go to the main menu. 

3. Select Human Resources → Payroll → Outsourcing → Export → Time Wage Type Export. 

The Time Wage Type Export screen appears. 

4. In the Payroll Period group box, Payroll field, type or select the appropriate value for the 
payroll that you want to export. 

5. In the Selection group box, Personnel number fields, type the employee number or range of 
numbers, if applicable. 

6. In the Selection group box, Payroll Area field, type or select the appropriate value for the 
payroll that you want to export. 

7. Select the Update field. 

8. Add or select other information appropriate to the payroll run. 

9. Select Execute. 

The Export Statistics screen appears. 

10. Close the Export Statistics screen. 

 
If you need to create another Outsourcing file for export, repeat steps 4 through 9. 

12. Return to the main menu. 

Result 
You have successfully exported your time wage types. You can continue with either Locating 
New IDocs [Page 94 ]6  or with Running Master Data Outsourcing [Page 955]. 

See also: 
Processing New IDocs [Page 947] 
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Troubleshooting 
As this is an interface, you must first determine wherein the problem lies. Once you establish the 
source of the problem, you can resolve it. 

This section offers some tips for determining the source of problems. To further assist your 
troubleshooting efforts, check the list of links below. 

Determining the Source 
Source Check Correct? Action 

The data? Original data  No Correct data 

  Yes Check further 

 Actual exported data  No Contact support 

  Yes Inform the Outsourcer 

The calculation? Master Data: 
Outsourcer owns the process 

 Inform the Outsourcer 

 Gross Payroll:  
SAP owns the process 

 Contact support 

 Net payroll calculation and legislative 
reporting 

 Inform the Outsourcer 

 Gross Payroll entries made by the 
Outsourcer 

 Inform the Outsourcer 

 Gross Payroll recalculated by 
Outsourcer 

 Inform the Outsourcer 

See also: 
 

Scheduling IDoc Transfers [Page 988] 

Repeating the Process [Page 99 ]0  

Transferring Data [Page 99 ]1  

Scheduling Changes to Employee Records [Page 99 ]2  

Rehires, Transfers, and Reference Personnel Numbers [Page 99 ]3  

No IDoc Created [Page 99 ]4  
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Scheduling IDoc Transfers 
Purpose 
Make sure that all IDoc files have been transferred to the third-party payroll service provider 
before you write another IDoc to the Outsourcing port. 

 

Integration 
Each time you prepare an IDoc to send to the Outsourcing port, you automatically overwrite the 
existing file. Make sure that you and your third-party payroll service provider have set up a 
workable schedule for creating the IDoc data as well as making sure that the third-party payroll 
service provider has retrieved the IDoc. 

See also: 

Converting IDoc Documentation to HTML [Page 989] 
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Converting IDoc Documentation to HTML 
Use 
This procedure is used for sending documentation explaining IDoc field information electronically 
to your third-party payroll service providers. 

Prerequisites 
Use the information contained in this HTML file format to determine the information contained in 
the other data segments of the IDoc. You can send these documents to your third-party payroll 
service provider as a reference to the information contained in the IDoc. 

Make sure that you are starting from the initial screen. 

Procedure 
1. Select Tools → Business Communication → IDoc-Basis → Documentation → IDoc Types. 

The Documentation for IDoc Types screen appears. 

2. In the ObjectName field, type the name of the IDoc. 

3. Select Documentation → HTML Page. 

The Parameter for HTML File Names dialog box appears. 

4. In the Local Directory field, type the name of the directory to which you want to save the 
HTML documents, then select Continue. 

All of the documentation for the specific type of IDoc that you specified is converted into 
HTML format. 

5. Return to the main menu. 

Result 
You have successfully generated the online IDoc documentation file. 
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Repeating the Process 
Purpose 
The Repeat and Update options provide different functionality when used combined or 
separately. Make sure you know which is required for the version of Payroll Outsourcing you are 
using. 

Features 
Using Repeat and Update options in Gross Payroll 
Use the Repeat and Update options when you need to recreate an IDoc from the previous run. In 
order to do this, you must not have exited payroll on the control record. Select the same period 
as you used for the last export to re-run the payroll export option, and use both the Repeat and 
Update options. If you were unable to complete or to export an IDoc file for whatever reason, 
then you can use this option to create a new IDoc to export to the third-party payroll service 
provider. 

Using Repeat and Update options with Master Data 
Use the Repeat and Update options when you need to recreate an IDoc for the previous payroll. 
Master Data only allows you to repeat the previous payroll. It does not allow you to go back to a 
prior pay period. If you need to do this, you can perform one of the following options. 

• You can make changes to the employee records using prior effective dates, and the system 
automatically retroactively calculates these changes for you. 

• You can select Repeat and All Data (not diffs. only) to compare your data against the data 
your third-party payroll service provider has stored. 
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Transferring Data 
Purpose 
Make sure you know which data you are transferring to the third-party service provider at any 
given time. Depending on whether changes were made to an employee record and when those 
changes were made or took effect, you can send new information only or both sets of 
information. 

Constraints 
What data transfers when you change an employee record? 
If an employee is promoted in the middle of a pay period, both sets of data transfer to the third-
party payroll service provider for them to interpret. 

What data does not transfer when you change an employee record? 
If you change a base wage type in the table, only the most current information writes to the IDoc. 
(The information that is effective on the date in which you run the payroll and create the IDoc.) 
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Scheduling Changes to Employee Records 
Constraints 
Gross Payroll 
If you are importing payroll results, you must not exit payroll until you have received the payroll 
results. When you have received and processed the inbound IDoc from the third-party payroll 
service provider, you can exit payroll to allow changes. 

Master Data 
If you are importing payroll results, SAP recommends that you set the control record in Payroll to 
protect data from being changed in the base wage type area. When you have received and 
processed payroll results from the third-party payroll service provider, you can exit payroll to 
allow changes. 
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Rehires, Transfers, and Reference Personnel Numbers 
Purpose 
In situations in which you have rehired an employee, transferred an employee, or you have 
created a reference personnel number, you must select All data (not diffs. only) to process the 
export document. The third-party payroll service providers will require full information for the 
employee in order that all of the data processes will be supported and updated properly. Check 
with your third-party payroll service provider to make sure that all of the data you are sending will 
be supported in their software systems. 

 
This means that any employees that have been transferred or have a reference 
personnel number will receive two payroll checks from the third-party payroll service 
provider. Doing so ensures accuracy of your payroll balance. 
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No IDoc Created 
Purpose 
When this occurs, make sure that you have provided data in all of the appropriate fields. Check 
the Payroll Area fields to ensure that you have added the same information in both fields. This 
is important because the Export program uses the information contained in the second Paroll 
area field as its main selection criteria. If this value differs from the value in the first field, this 
situation can occur. 

See also: 
 

Exporting Mini-Master Data [Page 942] 

Exporting Combined Payroll [Page 944] 

Running Gross Payroll Outsourcing [Page 950] 

Running Off-Cycle Gross Payroll [Page 952] 

Running Master Data Outsourcing [Page 955] 

Processing Time Wage Types [Page 985] 
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US-Specific HR Intotypes 
Definition 
This section contains a collection of US-specific HR infotypes.  
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Additional Personal Data (Infotype 0077) 
Definition 
Infotype 0077, Additional Personal Data, stores personal information that is not stored in the 
other master data infotypes.  

Use 
This infotype contains information that is confidential, and should only be accessed by a select 
few employees. 

The field for ethnic origin is required.  It is used mostly for EEO regulatory reporting that is 
required by the government  The field Military status stores the military information of the 
employee. 

The Challenge section allows you to identify the employee as disabled.  This field is required for 
government compliance of the Employees with Disabilities Act. 

The section for Veteran status allows you to store the veteran status of the employee.  The 
choices are specially challenged veteran, Vietnam veteran, or non-veteran.  You can mark all 
that apply.  These fields are also used for government compliance of EEO laws. 

 
This infotype is used most effectively by being included in the New Hire Action. 
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Assignment of EEO and AAP Categories to Jobs (PD 
Infotype 1610) 
Definition 
This infotype allows you to maintain legally required data for jobs within U.S. organizations. You 
can define both Equal Employment Opportunity (EEO) and Affirmative Action Planning (AAP) 
categories. 

Use 
Although these same assignments can be made from the Personnel Administration IMG, end-
users in the Human Resources area can maintain this PD infotype more easily. 

 
You want to maintain EEO/AAP categories for a newly created job classification. For 
job no. 50000101, ‘Department Manager’, make the following entry: 

Valid dates  01/01/97 - 12/31/97 

EEO Category 01 - Officers and Managers 

AAP Category 02 - Managers 

How To Access This Infotype 
You can access Infotype 1610 from the Detail Maintenance menu within Organization and 
Planning. 

 
When selecting from the list of PD infotypes, ensure that the country indicator is set for ‘US’. 
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Assignment of Workers’ Comp Codes to Org Units (PD 
Infotype 1612)  
Definition 
You can use this PD infotype to assign Workers’ Compensation Classification Codes to 
organizational units for U.S. companies.  The infotype accesses view V_T5U26. 

Use 
Although these same assignments can be made from the US Payroll IMG, end-users in the 
Human Resources area can maintain this PD infotype more easily. 

 
You have defined organizational unit 407, Human Resources, in the system.  If the 
state of California, in which this department was located, has a workers’ 
compensation classification code 9901 (Office and Clerical) for 1997. You would 
make the following entry to complete the assignment of this code to your department: 

Org.Unit 407 

Text  Human Resources 

WC State CA 

Descr.  California 

WC Code 9901 

WC Text Office and Clerical 

From  01/01/1997 

To   12/31/1997 

How To Access This Infotype 
You can access Infotype 1612 from the Detail Maintenance menu within Organization and 
Planning. 

 
When selecting from the list of PD infotypes, ensure that the country indicator is set 
for ‘US’.  

Integration 
PD Infotype 1613 allows you to assign workers’ compensation classification codes directly to 
individual positions 

See also: 
Assignment of Workers’ Comp Codes to Positions (PD Infotype 1613) [Page 999] 
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Assignment of Workers’ Comp Codes to Positions (PD 
Infotype 1613) 
Definition 
Each U.S. state has its own classification system for workers’ compensation codes.  The state 
workers’ compensation board publishes a list of valid codes within the state.  The codes are used 
by state or commercial insurers to classify types of work performed, and calculate a 
corresponding workers’ compensation insurance premium. 

Use 
You can use this PD infotype for assigning workers’ compensation classification codes to 
individual positions within U.S. companies. State-specific attributes, such as the area codes 
required in Alaska, can also be entered here. The infotype accesses view V_T5U28. Although 
these same assignments can be made from the US Payroll IMG, end-users in the Human 
Resources area can maintain this PD infotype more easily. Where code assignments exist for 
both a position and an organizational unit, the assignment to the position has priority.  

 
An employee with personnel number 50000084 works in the Food Production 
department.  You have assigned workers’ compensation classification code 9901 to 
this department.  However, this employee’s position involves machine maintenance. 
Assign classification code 9910 (Machine Maintenance) to this position instead of 
9901 (Food Production).  

 
The infotype table differs slightly from the maintenance view in the IMG - you can 
assign a number of state-specific attributes to positions using the infotype table.  
These state-specific attributes must be maintained in separate steps within the IMG. 

How To Access This Infotype  
You can access Infotype 1613 from the Detail Maintenance menu within Organization and 
Planning. 

Integration 
PD Infotype 1612 allows you to assign workers’ compensation classification codes to 
organizational units.   

See also: 
Assignment of Workers’ Comp Codes to Org Units (PD Infotype 1612) [Page 998] 
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Residence Status (Infotype 0094)  
Definition 
Infotype 0094 allows you to store information regarding an employee’s residence status, as well 
as information regarding the compliance with the Immigration Reform and Control Act (IRCA), 
which requires every employer verify that each person hired can prove via documents their 
identity, and their eligibility for employment.  

Structure 
This infotype is divided into two parts:  the personal identification information section (the 
residence permit) and the employment verification section (the work permit). 

Personal identification 
This section stores the information for personal identification. The only field which is required on 
this infotype is Residence status.   

The ID type field describes the type of documentation the employee presents to the company. 
You can also enter data for the issuing authority. 

The ID number is the number of the document provided by the employee to the company.  The 
Issuing date is the date on which the personal identification document was issued to the 
employee.  This date must be the same as or later than the employee’s date of birth. 

Lastly, the ID expiry date field is the date that the provided identification expires. 

 
If the expiration date is filled, and there is a value of A (Alien) in the Residence status 
field, then this transaction will automatically generate a transaction to store a 
deadline for the expiration of the work permit (infotype 0019, subtype 71). 

Employment verification 
This section stores the information for employment verification.  The Work permit field stores the 
type of work permit.  The Work permit number field stores the number of the document provided 
by the employee to establish work eligibility. 

The date issued and the issuing authority are also stored.  The Expiry of work perm. field stores 
the date on which work eligibility expires.  This field should only be filled for those employees 
who are NOT citizens. 

 
You can use the Overview function on the toolbar to view an overview of the 
employee residence status history. 
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Workers' Compensation (Infotype 0076) 
Definition 
Infotype 0076 is used in conjunction with Infotype 0082, Additional Absence Data, to store 
information that will be needed when filling out a Workers' Compensation form. 

Structure 
The Workers' Compensation infotype has two screens.  The first screen is divided into two parts, 
the first part holding static illness data and the second part holding static payroll data.  The 
second screen contains the variable data associated with the injury or illness.  

Before accessing this infotype you must choose a subtype.  The subtype is either the state or 
province that the employee in which the employee works.  Every state/province has its own 
workers compensation form, and therefore has its own data requirements. 

First screen 
As mentioned, the first screen contains static information, and is divided into illness information 
and payroll information. 

Each illness/injury has a case number that is entered into the field Case number.  This number is 
assigned either by the Workers' Compensation Board or internally.  The status field stores the 
processing status of the worker’s compensation claim.  Examples of status are R-Reporting; O-
Open; P-Pending; or C-Closed. 

Also stored is the date and time that work stopped. 

In the No. of hours worked field you enter the number of hours that the employee worked on the 
day the illness or injury occurred.  This information is used for reporting purposes only, and has 
no effect on payroll calculation. 

The payroll information appears in the bottom half of the screen.  The Payment type, which is the 
wage type for the workers compensation, is entered in this field.  In the Payment amount field, 
you enter an amount that can be used with the field Payment rule in the payroll calculation.  This 
Payment rule is the rule used in the actual payroll calculation.  This is a user-defined field that 
may depend on the laws/requirements of the state/province in which the user operates. 

 
You can use the Overview function from the toolbar to access an overview of the 
chosen employee’s workers compensation history.  

Second screen 
You access the second screen to the Workers' Compensation infotype by choosing the Variable 
Data function from the toolbar in the first screen.  This screen stores such information as whether 
or not in-house care was used, and if so, when.  Also, there is a field that stores any remarks or 
comments about the particular case. 

 
To use this infotype most effectively, you must access it by using the Absence 
function on the toolbar of Infotype 0082, Additional Absence Data.   
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US-Specific HR Internet Application Components  
Definition 
The US-specific Internet Application Components (IACs) in SAP HR allow employees to access 
information stored in the SAP HR system through your company's intranet.  

Use 
These IACs allow employees to take responsibility for changing personal information, such as 
their address and withholding allowances. It also helps ease the workload of the company's HR 
department since the employees are making these changes themselves. In addition, the IACs 
offer employees the opportunity to request information from the HR department, such as their 
previous year's W-2 Form.  

Integration 
The IAC is integrated with the online SAP HR system, so that any master data changed or 
entered through the IAC is immediately reflected in the HR system.  
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Address Information in the Internet (PA-PA-US) 
Use 
In this Internet Application Component (IAC), employees take responsibility for their own address 
information. They can create, change and display their address information, which is used on 
different occasions, such as for mailing and tax purposes. When employees have access to their 
own information, employers can expect faster response times and more accurate data. 

When employees change their data in this IAC, the old status is not lost. Instead, a historical 
record is created. 

Type of Internet Application Component 
Intranet - Employee Self-Service (ESS)  

For more information on Internet Application Components, see R/3 Internet Application 
Components [Ext.]. 

Prerequisites 
An employee must have an SAP user that is directly linked to their R/3 employee master data, 
via the Communication infotype (0105). 

Authorizations 
SAP delivers a standard activity group that contains all the necessary authorizations. For more 
information, see Employee Self-Service (ESS) [Ext.]. 

Standard Settings 

 

To set up the ESS users, you have to make various settings in Customizing.  For further details, 
see Customizing Personnel Management -> Employee Self-Service.  

Features 
In this service, the fields are reduced to their essentials, so that employees who have no 
knowledge of the R/3 System can change their addresses. 

The Address Information IAC can be linked to the IAC for changing W-4 withholding information 
by means of a feature in the IMG. If you turn on the link to the W-4 IAC, the W-4 IAC is accessed 
when an employee makes an address change that could affect his or her W-4 withholding 
information. 

Service Name
The service name of this IAC is PZ02. You can find all the relevant data under the service name 
in the SAP@WebStudio [Ext.]. 

R/3 Development Objects 
These R/3 development objects are used: 

• Development class: PB10 

• Transaction: PZ02 
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• Function group: EHU1 

• BAPIs: 

− EmployeePrivAddress.Change 

− EmployeePrivAddress.Getdetail 

− EmployeePrivAddress.Create 

− EmployeePrivAddress.Delete 

− EmployeePrivAddress.Getlist 

− EmployeePrivAddress.Getdetailedlist 
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Address Information (PA-PA-US) 

Process Flow (No Link to W-4 ESS) 

3. The user saves the data. 

1. The user accesses the address information ESS through their company's intranet. 

5. Depending on the new state's regulations for calculating withholding tax, the system will react 
in different ways: 

Then… 

Purpose 
This service allows employees to display and change their own address information via their 
company's intranet. If desired, this Employee Self-Service (ESS) scenario can be linked to the W-
4 Withholding Information ESS with feature W4SWH. This feature can be maintained in the 
Payroll USA IMG under Internet Application Components (IACs) -> Maintain link between 
address change and W-4 info. IACs. This link is useful when an employee makes a change to 
their home address that would effect their state withholding elections. 

1. The user accesses the address information ESS through their company's intranet. 

2. The user can then display, change, delete or create new address information for different 
address types (permanent, temporary, etc.). 

4. The payroll manager is notified of the changes. 

5. The user receives confirmation that the address change is complete. 

Result 
Any records changed are immediately updated in SAP HR and the old records are delimited. 

Process Flow (Change of Home Address With Link to W-4 ESS) 

2. The user can then display, change, delete or create new address information for different 
address types (permanent, temporary, etc.). 

3. If the user changes their home address, the system compares the new address to the old 
address to determine if the user changed their state. 

4. If the user did change their state, the system checks whether this change effects the user's 
W-4 withholding information.  

 

If the use of Federal elections for 
state withholdings is... 

Required The employee's elections on the Federal W-4 are 
used to calculate the state withholding tax. The 
employee does not get directed to the W-4 ESS 
scenario. 
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Not allowed The employee's elections on the Federal W-4 
cannot be used to calculate the state withholding 
tax. The employee is taken to the W-4 ESS 
scenario to define elections for state withholding. 

Optional A dialog box appears asking the employee if they 
want to change their state withholding elections or 
use the Federal elections. If they choose to 
change their state elections, they will be taken to 
the W-4 ESS scenario. 

 

6. The user saves their changes. 

Result 
Any records changed are immediately updated in SAP HR and the old records are delimited.  

See also: 

7. A message is sent to the payroll manager indicating that the employee has changed their 
address via ESS and that their withholding infotypes (W-4 Withholding Info. - Infotype 0210 
and Residence Tax Area - Infotype 207) need to be reviewed for tax purposes. 

8. The user receives confirmation that the address change is complete. 

W-4 Withholding Information in the Internet (PA-PA-US) 
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W-2 Reprint Option in the Internet (PA-PA-US) 
Use 
This Internet Application Component (IAC) provides employees with an easy method of 
requesting a reprint of their previous year's Form W-2.  

Type of Internet Application Component 
Intranet - Employee Self-Service (ESS)  

For more information on Internet Application Components, see R/3 Internet Application 
Components [Ext.]. 

Prerequisites 
An employee must have an SAP user that is directly linked to their R/3 employee master data, 
via the Communication infotype (0105). 

The employee's W-2 must have already been printed and the corresponding TemSe file created. 
For more information, see Generating Tax Forms [Page 699]. 

Authorizations 
SAP delivers a standard activity group that contains all the necessary authorizations. For more 
information, see Employee Self-Service (ESS) [Ext.]. 

Standard Settings 
To set up the ESS users, you have to make various settings in Customizing.  For further details, 
see Customizing Personnel Management -> Employee Self-Service.  

Features 
When employees request a W-2 reprint with this scenario, they can choose between picking up 
the reprint in the Payroll Department in the company, or having the copy sent to their home 
address.   

If they choose to have the copy sent to their home address, a screen appears with their home 
address as currently defined in SAP. If the address is correct, then can submit the request. If not, 
they have to access the Address Change ESS where they can change their home address. For 
more information, see Address Information in the Internet (PA-PA-US) [Page 100 ]4  

Service Name 
The service name of this IAC is WS01000090. You can find all the relevant data under the 
service name in the SAP@WebStudio [Ext.]. 

R/3 Development Objects 
These R/3 development objects are used: 

• Development class: PB10 

• Transaction: WS01000090 

• Module pool: SAPMWS01000090H  
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  Requesting a W-2 Reprint 

Requesting a W-2 Reprint 
Use 
This Employee Self-Service (ESS) scenario provides you with an easy method of requesting a 
copy of your prior year's Form W-2.  

Prerequisites 
You have an SAP user that is directly linked to your R/3 employee master data, via the 
Communication infotype (Infotype 0105). 

Procedure 
1. Access your company intranet and choose the ESS for W-2 reprints.  

 
You can only request a copy of your W-2 from the immediate prior year (for example 
in 1999, you can only request your 1998 W-2). 

2. Select the delivery method for the reprint. This can be: 

• Sent with regular mail 

• Sent through intercompany mail 

• Pick up the reprint yourself at your company's payroll/HR office 

 
If you choose to have the copy sent to your home, a screen appears showing your 
current home address as stored in the SAP system. 

3. If your address is correct choose Confirm. 

4. If your address is incorrect, you must first inform your HR department of your correct address 
or access the Address Change ESS and change your address there. 

5. Save your entries. 

Result 
Your request is forwarded to your company's payroll administrator. 
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W-4 Withholding Information in the Internet (PA-PA-US) 
Use 
In this Internet Application Component (IAC), employees take responsibility for keeping their W-4 
withholding information current. They can create, change and display the information they would 
normally include on Form W-4 (Employee's Withholding Allowance Certificate) and on state-
specific W-4 forms. This information is used to withhold the correct amount from the employee's 
salary for tax purposes. This both reduces the administration necessary in the Human Resources 
department for entering withholding data into the system and empowers employees to quickly 
and easily check and change their withholding information when necessary. 

When employees change their data in this IAC, the old status is not lost. Instead, a historical 
record is created.   

Type of Internet Application Component 
Intranet - Employee Self-Service (ESS)  

For more information on Internet Application Components, see R/3 Internet Application 
Components [Ext.]. 

Prerequisites 
An employee must have an SAP user that is directly linked to their R/3 employee master data, 
via the Communication infotype (0105). 

Authorizations 
SAP delivers a standard activity group that contains all the necessary authorizations. For more 
information, see Employee Self-Service (ESS) [Ext.]. 

Standard Settings 
To set up the ESS users, you have to make various settings in Customizing.  For further details, 
see Customizing Personnel Management -> Employee Self-Service.  

Features 

 

In this scenario, the fields are reduced to their essentials, so that employees who have no 
knowledge of the R/3 System can change their details. 

This Internet Application Component is based on Infotype 0210 (Withh. Info. W4/W5 US), which 
stores tax information from both Form W-4 and Form W-5 (Earned Income Credit Advance 
Payment Certificate). However, it is not possible to display or change W-5 information with this 
IAC.  

When employees change their withholding information with this scenario, they are required to 
check a box certifying, under penalty of perjury, that they are entitled to the allowances they are 
claiming and that the information they are supplying is correct. 

Service Name
The service name of this IAC is PZ10. You can find all the relevant data under the service name 
in the SAP@WebStudio [Ext.]. 
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R/3 Development Objects 
These R/3 development objects are used: 

• Development class: PB10 

• Transaction: PZ10 

• Function group: EHU2 

• BAPIs: 

− EmployeeW4W5InfoUS.Create 

− EmployeeW4W5InfoUS.Change  

− EmployeeW4W5InfoUS.Delete 

− EmployeeW4W5InfoUS.GetList 

− EmployeeW4W5InfoUS.GetDetailedList  

− EmployeeUS.Enqueue 

− EmployeeUS.Dequeue 

 

April 2001  1011 



Payroll United States (PY-US)  SAP AG 

Updating W-4 Withholding Information 

Updating W-4 Withholding Information 
Use 
This service allows you to display and change US withholding tax information stored on Form W-
4 using the Internet Application Component (IAC) for tax withholding data. 

Prerequisites 
You have an SAP user that is directly linked to your R/3 employee master data, via the 
Communication infotype (Infotype 0105). 

Procedure 
6. Access your company intranet and choose the IAC for W-4 withholding information.  

7. Display or change your state and/or federal tax withholding information as necessary. 

8. Save your changes. 

Result 
Any information changed in the IAC is automatically updated in the master data records in your 
company's SAP HR system. 
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