Concept Check Tool

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Caution Icon]</td>
<td>Caution</td>
</tr>
<tr>
<td>![Example Icon]</td>
<td>Example</td>
</tr>
<tr>
<td>![Note Icon]</td>
<td>Note</td>
</tr>
<tr>
<td>![Recommendation Icon]</td>
<td>Recommendation</td>
</tr>
<tr>
<td>![Syntax Icon]</td>
<td>Syntax</td>
</tr>
<tr>
<td>![Tip Icon]</td>
<td>Tip</td>
</tr>
</tbody>
</table>
Contents

Concept Check Tool ...................................................................................................... 5
Checklist ........................................................................................................................ 6
Report ............................................................................................................................ 7
Importing the Project Scope from the Q&A db ............................................................ 8
Working with Checklists ............................................................................................... 9
Completing Checklists ................................................................................................. 10
Changing Checklists ................................................................................................... 12
Storing and Displaying Comments ............................................................................. 13
Displaying reports ....................................................................................................... 14
Sending Reports to SAP ............................................................................................. 15
Inbox ............................................................................................................................ 16
Displaying SAP Notes for Reports ............................................................................... 17
Concept Check Tool

Purpose

The Concept Check Tool is an analytical tool with which you can carry out quality checks on your implementation project. By answering a series of checklists you can pinpoint and react promptly to issues or potential conflicts.

Features

- The Concept Check Tool contains checklists that you can use to obtain a detailed analysis of your system settings.
  - The checklists are designed dynamically – that is the answer you give to the first question triggers subsequent questions that are relevant to you.
  - The checklist structure in the Project Preparation phase matches the Roadmap structure.
  - The checklist structure in the Business Blueprint phase matches the SAP Reference Structure. To date, checklists are available for organizational units, master data, and for several scenarios and processes.
  - The questions are generally closed (yes/no) or multiple choice and focus on project organization, basic system settings, and system performance.
  - The questions are displayed, with the answers you have entered so far, in a separate frame beside the active question and answer frame. This provides you with a summary of the checklist structure at all times.
- You can import your project scope from the Business Blueprint phase in the Question & Answer database (Q&Adb) to the Concept Check Tool. The system then displays only the checklists that relate to your implementation project.
- The system generates a report after you have completed each checklist. This report
  - Offers recommendations on how to optimize your system configuration
  - Pinpoints critical data sets and values
  - Contains important information on performing stress tests and the Going Live Check.
- You can send each of these reports to SAP and access the SAP Notes associated with them using the SAP R/3 – Frontend.

Once you have worked through all the checklists, you can generate a global report that summarizes the essential characteristics of your core functions. This report forms the basis for the review in the SAP Review Program. The report you have generated provides valuable input for solving problems that the Concept Check Tool has identified.
Checklist

Definition
Checklists are “review instruments.” You use them to analyze the implementation project or other project you have planned, and check the practical implications of your choices.

Use
The quality check that you carry out using these lists covers the Project Preparation and Business Blueprint phases of the Roadmap, particularly Initial Project Planning and R/3 applications configuration. You can either work through the checklist yourself or with your SAP consultant. You can limit the number of checklists by choosing File → Import scope from Q&Adb.

Structure
The checklist contains the following screen areas:

- Questions
  displays each question in the checklist in turn.

- Answers
  displays notes or warnings related to the answer.
  You can also display Help Text here.

- History
  displays your predefined user profile and questions you have already answered, along with the answer to those questions.

See also:
Importing the Project Scope from the Q&Adb [Page 8]
Completing Checklists [Page 10]
Changing Checklists [Page 12]
Report

Definition
Each report presents the contents of a checklist and information pertaining to it in the form of a file that can be saved and printed.

Structure
Reports created by the Concept Check Tool consist of the following:

- The user profile that has been defined
- The date and time at which the project was generated
- Questions and answers
- Notes and warnings for individual answers

See also:
Displaying reports [Page 14]
SAP Review Program [Ext.]
Importing the Project Scope from the Q&Adb

Use
You can copy your project scope from the Question & Answer database (Q&Adb) to the Concept Check Tool. The system then displays only those items you have set in scope.

Prerequisites
In the SAP Reference Structure, you must set the items you want to be in scope, for example business processes.

Procedure
1. Choose File → Import Scope from Q&Adb. The system displays a dialog box.
2. To log on, enter your name and password and choose OK.
3. To display only those items that are in scope, choose View → In scope

Result
The tree structure displays only items that have been set in scope in the Q&Adb; all others are hidden.

If you set more items in scope later, in the Q&Adb, and if you want to copy these items into the Concept Check Tool, simply repeat the above steps.

See also:
Completing Checklists [Page 10]
Changing Checklists [Page 12]
Working with Checklists

Purpose
You use this process to complete checklists and change those you have already completed.

Process Flow
1. You complete a checklist.
2. You can change these checklists as necessary, either when completing them for the first time, or at any time thereafter.

See also:
Completing Checklists [Page 10]
Changing Checklists [Page 12]
Completing Checklists

Procedure

1. Open the checklist you want to change by choosing the symbol beside it. The checklist opens.

2. Complete the user profile.

   Check your entries before you start answering the checklist questions, since you can only complete the user profile at the beginning of each checklist.

3. To display the questions in the checklist, choose Continue.

   The system offers three different types of questions:
   - Yes/no answers
   - Multiple choice
   - Free format answers

   Make your answers as precise as you can, since revising your answers afterwards can be time-consuming, although it is technically possible.

Some of the answers contain notes or warnings. These are described in more detail below:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>![arrow]</td>
<td>Note on optimizing your installation. You can usually ignore one note, without having any serious performance problems. However, ignoring several such notes can affect system performance.</td>
</tr>
<tr>
<td>![exclamation]</td>
<td>Warning message, indicating possible problems with performance or data volumes. You must consider and test your concepts and activities again.</td>
</tr>
<tr>
<td>![stop]</td>
<td>Warning message, indicating major performance problems. You must carry out any activities suggested in the message, for example contact your consultant partner or SAP</td>
</tr>
</tbody>
</table>

4. To create a report, (after having completed your checklist), choose Continue.

5. A dialog box is displayed. Choose Yes to display the report.

See also:

Displaying reports [Page 14]
Changing Checklists [Page 12]
Changing Checklists

Use

Use the History group box to edit questions you have answered already, for example when you meant to choose Yes but chose No to answer a question.

Prerequisites

The History screen area must be displayed. If not, choose the icon (between the Questions screen area and the Answer screen area).

⚠️

Remember that you must then answer all subsequent questions again, since questions are designed dynamically. In some cases, this may affect a large number of questions.

Procedure

To change answers while you are completing a checklist

1. In the History frame, select the question you want to change.
2. A dialog box is displayed. Choose Yes.
3. Change your answer.

To change completed checklists

1. Select the checklist you want to change in the Checklist overview.
2. Choose Reset.
3. A dialog box is displayed. Choose Yes to delete all the answers in this checklist.

If you want to work through all your checklists again, choose Reset all. The system automatically deletes all the answers to checklists.
You can display answers in reports you have saved, however, by choosing Open report.

See also:

Completing Checklists [Page 10]
Displaying reports [Page 14]
Storing and Displaying Comments [Page 13]
Storing and Displaying Comments

Use
Use the Comment screen area to store comments that pertain to a specific question or answer. You can store comments either on individual questions or on the checklist as a whole.

Procedure

1. Choose one of the following options:
   - To store a comment on a whole checklist, choose the icon in the Checklist Overview.
   - To store a comment on an individual question, choose the icon between the Questions screen area and the Answer screen area.
   The system opens the Comment dialog box.

2. Enter your comment.

3. Save your comment and close the dialog box.
   The comment icon in the Checklist Overview turns yellow.

4. To display a comment, choose the relevant comment icon. You can then change your comment if you wish.

   Choose All comments to display all the comments you have completed to date, for example to print them all as one document.

   You can highlight important comments by choosing Highlight.
Displaying reports

Prerequisites
You must complete a checklist for which you would like to create a report.

Procedure
1. Select the checklist for which you want to see the report.

Choose All reports to display all the reports you have completed to date, for example to print them all as one document.

The system saves each report automatically. To save the report under a different name, choose Save.

See also:
Completing Checklists [Page 10]
Sending Reports to SAP

Use
To obtain more information on problems mentioned (as warnings or notes) in your reports, you can send them to SAP by Internet. You can then use your personal Inbox to access, for example, SAP Notes pertaining to your report.

Prerequisites
You must complete a checklist and create a report from it.

Procedure
1. Choose Open report.
2. Choose Send.
The system displays an Outbox window and asks you whether you want to send the report to SAP.
3. Choose Send report.
4. The system displays a dialog box. Enter your user ID and password. To confirm your entry, choose OK.
The system attempts to send the report and displays a message telling you whether or not it has been successful. The report is then stored in your SAP personal Inbox.

See also:
Inbox [Page 16]
Displaying SAP Notes for Reports [Page 17]
Inbox

Use
This function provides a summary of your personal Inbox data – the reports you have sent to SAP along with the date you sent them and the name of anyone who has processed these reports. You can then use your personal Inbox to access, for example, SAP Notes pertaining to your report.

Prerequisites
You must send at least one report to SAP by Internet.

Features
Functions available in your personal Inbox
- Report
  The checklists you have sent in along with the notes and warnings pertaining to them. You can then display the SAP Note that applies to these notes or warnings.
- Reviser
  The name of whoever revised the checklist.
- Date
  The date and time at which you sent in the report.
- Status
  New indicates that you have not yet read the report.
  Open indicates that you have read the report.
- Delete

Other functions
- Home
  Displays the SAP Home Page in a new window.
- Mail
  Allows you to send a mail from your Inbox.

Activities
1. To open your personal Inbox, choose Inbox.
2. To log on, enter your name and password and choose OK.

See also:
Displaying SAP Notes for Reports [Page 17]
Displaying SAP Notes for Reports

Use
You can use the SAPNet - R/3 Frontend to access SAP Notes that relate to the notes and warnings mentioned in your checklist.

Prerequisites
You must send the report on the relevant checklist to SAP.

Procedure
1. From your personal Inbox, choose the report for which you want to display the SAP Notes. The system displays the note or warning.
2. Choose SAPNet Notes. The system displays a list of SAP Notes that relate to the warning or note in the report.

   The system will display a message if there are no SAP Notes or other information available.
3. Work through the SAP Notes as necessary.
4. To display the report details, choose Back.
5. Navigate through the list of notes and warnings using Previous and Next.
6. To display a summary of all your reports, choose Inbox.